Aspose.Imaging for .NET API Reference

The Aspose.Imaging for .NET class library provides the following namespaces:

Aspose.Imaging for .Net
Contains classes to work with Images of different formats without requiring any image editor.

We guarantee a prompt response to any inquiry!

© 2003-2013 Aspose Pty Ltd. All rights reserved.


Aspose.Imaging

Aspose.Imaging Documentation

Aspose.Imaging Namespace

Namespace hierarchy

Classes

Class | Description
Blend | Defines a blend pattern. This class cannot be inherited.
Brush | The base brush class.
BuildVersionInfo | Contains the current build version information.
Cache | Contains cache settings.
ColorBlend | Defines arrays of colors and positions used for interpolating color blending in a multicolor gradient. This class cannot be inherited.
ColorMap | Defines a map for converting colors. Several methods of the ImageAttributes class adjust image colors by using a color-remap table, which is an array of ColorMap structures. Not inheritable.
ColorMatrix | Defines a 5 x 5 matrix that contains the coordinates for the RGBA space. Several methods of the ImageAttributes class adjust image colors by using a color matrix. This class cannot be inherited.
ColorPalette | Defines an array of colors that make up a color palette. The colors are 32-bit ARGB colors. Not inheritable.
ColorTranslator | Translates colors to and from GDI+ Color structures. This class cannot be inherited.
CustomLineCap | Encapsulates a custom user-defined line cap.
DataStreamSupporter | The data stream container.
DisposableObject | Represents disposable object.
Figure | The figure. A container for shapes.
FileStreamContainer | Helper for file stream processing.
Font | Defines a particular format for text, including font face, size, and style attributes. This class cannot be inherited.
Graphics | Represents the graphics according to the graphics engine used in the current assembly.
GraphicsPath | Represents a series of connected lines and curves. This class cannot be inherited.
Image | The image is the base class for all type of images.
ImageAttributes | An ImageAttributes object contains information about how bitmap and metafile colors are manipulated during rendering. An ImageAttributes object maintains several color-adjustment settings, including color-adjustment matrices, grayscale-adjustment matrices, gamma-correction values, color-map tables, and color-threshold values. During rendering, colors can be corrected, darkened, lightened, and removed. To apply such manipulations, initialize an ImageAttributes object and pass the path of that ImageAttributes object (along with the path of an Image) to the DrawImage method.
ImageCreatorsRegistry | Represents the image creators registry.
ImageExportersRegistry | Represents the image exporters registry.
ImageLoadersRegistry | Represents the image loaders registry.
ImageOptionsBase | The image base options.
License | Provides methods to license the component.
LoadOptions | Represents the loading options.
Matrix | Replaces the GDI+ Matrix.
ObjectWithBounds | The object having bounds.
Pen | Defines an object used to draw lines, curves and figures.
Pens | Pens for all the standard colors. This class cannot be inherited.
PixelDataFormat | The pixel data format.
RasterCachedImage | Represents a raster image supporting raster graphics operations. This image caches pixel data when required.
RasterImage | Represents a raster image supporting raster graphics operations.
RawDataSettings | The raw data settings
Region | Describes the interior of a graphics shape composed of rectangles and paths. This class cannot be inherited.
Shape | The shape. A continuous set of points connected using a specific rule.
ShapeSegment | Represents a shape segment. A segment is a line or curve connecting two points.
Source | The source is used to contain all relevant information for an object pipe.
StreamContainer | Represents stream container which contains the stream and provides stream processing routines.
StringFormat | Encapsulates text layout information (such as alignment, orientation and tab stops) display manipulations (such as ellipsis insertion and national digit substitution) and OpenType features. This class cannot be inherited.
TransparencySupporter | The object supporting transparency.

Interfaces

Interface | Description
IAdvancedBufferProcessor | The advanced buffer processor.
IBufferProcessor | The buffer processor.
IColorConverter | The color converter.
IColorPalette | The color palette interface.
IImageCreator | The image creator.
IImageCreatorDescriptor | The image creator descriptor specifying the creator properties. The creator descriptor is used to overcome the necessity to contain each image creator instance in memory and multithreading issues.
IImageDescriptor | The image descriptor. Contains base properties and methods for all other image descriptor types.
IImageExporter | The image exporter. Can export data from internal Aspose.Imaging format to a specified data format.
IImageExporterDescriptor | Represents the image exporter descriptor. The exporter descriptor is used to overcome the necessity to contain each exporter instance in memory and multithreading issues.
IImageLoader | The image loader.
IImageLoaderDescriptor | The image loader descriptor specifying the loader properties. The loader descriptor is used to overcome the necessity to contain each image loader instance in memory and multithreading issues.
IIndexedColorConverter | The color converter for indexed image formats.
IKeyedObject | Represents interface for objects with keys.
IObjectWithBounds | Represents an object with bounds.
IOrderedShape | Represents an ordered shape. An ordered shape is a continuous set of points having a start point and end point. The continuous set of points connected using a specific rule.
IPartialCMYKPixelLoader | Conforms to the pixels loaded partially.
IPartialPixelLoader | Conforms to the pixels loaded partially.
IPartialRawDataLoader | The partial data loader.
IPsdColorPalette | The pasd color palette
IRasterImagePixelLoader | The raster image pixel loader.
IRasterImageRawDataLoader | The raster image raw data loader.

Structures

Structure | Description
CMYKColor | The CMYK color of pixel.
Color | The color of the pixel.
Point | Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.
PointF | Represents an ordered pair of floating-point x- and y-coordinates that defines a point in a two-dimensional plane.
Rectangle | Stores a set of four integers that represent the location and size of a rectangle.
RectangleF | Stores a set of four floating-point numbers that represent the location and size of a rectangle.
Size | Represents size.
SizeF | Stores an ordered pair of floating-point numbers, typically the width and height of a rectangle.

Enumerations

Enumeration | Description
CacheType | Specifies the cache type to use.
CharacterSet | Represents the character set used.
ColorAdjustType | Specifies which objects use color adjustment information.
ColorChannelFlag | Specifies individual channels in the CMYK (cyan, magenta, yellow, black) color space. This enumeration is used by the SetOutputChannel methods.
ColorMatrixFlag | Specifies the types of images and colors that will be affected by the color and grayscale adjustment settings of an ImageAttributes.
CompositingQuality | Specifies the quality level to use during compositing.
DashCap | Specifies the type of graphic shape to use on both ends of each dash in a dashed line.
DashStyle | Specifies the style of dashed lines drawn with a Pen object.
DataRecoveryMode | The data recovery mode.
DitheringMethods | The dithering methods used to control color conversion.
FileFormat | One of supported imaging file formats.
FillMode | Specifies how the interior of a closed path is filled.
FontStyle | Specifies style information applied to text.
GraphicsUnit | Specifies the unit of measure for the given data.
HatchStyle | Specifies the different patterns available for HatchBrush objects.
HotkeyPrefix | Specifies the type of display for hot-key prefixes that relate to text.
InterpolationMode | The InterpolationMode enumeration specifies the algorithm that is used when images are scaled or rotated.
KnownColor | Specifies the known system colors.
LineCap | Specifies the available cap styles with which a Pen object can end a line.
LineJoin | Specifies how to join consecutive line or curve segments in a figure (subpath) contained in a GraphicsPath object.
MatrixOrder | Specifies the order for matrix transform operations.
PenAlignment | Specifies the alignment of a Pen object in relation to the theoretical, zero-width line.
PenType | Specifies the type of fill a Pen object uses to fill lines.
PixelFormat | The pixel data format actual meaning.
ResizeType | Specifies the resize type.
RotateFlipType | Specifies how much an image is rotated and the axis used to flip the image.
SmoothingMode | Specifies whether smoothing (antialiasing) is applied to lines and curves and the edges of filled areas.
StringAlignment | Specifies the alignment of a text string relative to its layout rectangle.
StringDigitSubstitute | The enumeration specifies how to substitute digits in a string according to a user's locale or language.
StringFormatFlags | Specifies the display and layout information for text strings.
StringTrimming | Specifies how to trim characters from a string that does not completely fit into a layout shape.
TextRenderingHint | Specifies the quality of text rendering.
WarpMode | Specifies the type of warp transformation applied.
WrapMode | Specifies how a texture or gradient is tiled when it is smaller than the area being filled.

Generated:2014-05-08 10:18:18,version:1.3.49.0


Blend Class

Defines a blend pattern. This class cannot be inherited.

For a list of all members of this type, see Blend Members.

System.Object
Aspose.Imaging.Blend

public sealed class Blend

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The typical blend class usage is defining a blend pattern for brush. And thus the blend properties should be initialized carefully. Null arrays are not allowed. The brush will throw the appropriate exception if blend factors or positions array are empty or their length is not the same. If there are two or more elements in the positions array then the first element should be 0 and the last should be 1.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Blend Members | Aspose.Imaging Namespace


Blend Members

Blend overview

Public Static Operators

Equality Operator | Tests whether two specified Blend classes are different.
Inequality Operator | Tests whether two specified Blend classes are equivalent.

Public Instance Constructors

Blend Overloaded. Initializes a new instance of the Blend class.

Public Instance Properties

Factors | Gets or sets the array of blend factors for the gradient.
Positions | Gets or sets the array of blend positions for the gradient.

Public Instance Methods

Equals | Tests whether the specified object is a Blend class and is equivalent to this Blend class.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Blend Class | Aspose.Imaging Namespace


Blend Constructor

Initializes a new instance of the Blend class. The number of elements in the factor and blend arrays will be equal to 1.

Overload List

Initializes a new instance of the Blend class. The number of elements in the factor and blend arrays will be equal to 1.

public Blend();

Initializes a new instance of the Blend class with the specified number of factors and positions.

public Blend(int);

See Also

Blend Class | Aspose.Imaging Namespace


Blend Constructor ()

Initializes a new instance of the Blend class. The number of elements in the factor and blend arrays will be equal to 1.

public Blend();

See Also

Blend Class | Aspose.Imaging Namespace | Blend Constructor Overload List


Blend Constructor (Int32)

Initializes a new instance of the Blend class with the specified number of factors and positions.

public Blend(
int count
);

Parameters

count
The number of elements in the factor and position arrays.

See Also

Blend Class | Aspose.Imaging Namespace | Blend Constructor Overload List


Blend Properties

The properties of the Blend class are listed below. For a complete list of Blend class members, see the Blend Members topic.

Public Instance Properties

Factors | Gets or sets the array of blend factors for the gradient.
Positions | Gets or sets the array of blend positions for the gradient.

See Also

Blend Class | Aspose.Imaging Namespace


Factors Property

Aspose.Imaging Documentation

Blend.Factors Property

Gets or sets the array of blend factors for the gradient.

public float[] Factors {get; set;}

Property Value

The array of blend factors that specify the percentages of the starting color and the ending color to be used at the corresponding position.

See Also

Blend Class | Aspose.Imaging Namespace


Positions Property

Aspose.Imaging Documentation

Blend.Positions Property

Gets or sets the array of blend positions for the gradient.

public float[] Positions {get; set;}

Property Value

The array of blend positions that specify the percentages of distance along the gradient line.

See Also

Blend Class | Aspose.Imaging Namespace


Blend Methods

The methods of the Blend class are listed below. For a complete list of Blend class members, see the Blend Members topic.

Public Instance Methods

Equals | Tests whether the specified object is a Blend class and is equivalent to this Blend class.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Blend Class | Aspose.Imaging Namespace


Blend.Equals Method

Tests whether the specified object is a Blend class and is equivalent to this Blend class.

public override bool Equals(
object obj
);

Parameters

obj
The object to test.

Return Value

True if obj is a Blend class equivalent to this Blend class; otherwise, false.

See Also

Blend Class | Aspose.Imaging Namespace


Blend.GetHashCode Method

Returns a hash code for this instance.

public override int GetHashCode();

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

Blend Class | Aspose.Imaging Namespace


Blend Operators

The operators of the Blend class are listed below. For a complete list of Blend class members, see the Blend Members topic.

Public Static Operators

Equality Operator | Tests whether two specified Blend classes are different.
Inequality Operator | Tests whether two specified Blend classes are equivalent.

See Also

Blend Class | Blend Members | Aspose.Imaging Namespace


Blend Equality Operator

Tests whether two specified Blend classes are different.

public static bool operator ==(
Blend blend1,
Blend blend2
);

Parameters

blend1
The Blend that is to the left of the inequality operator.
blend2
The Blend that is to the right of the inequality operator.

Return Value

True if the two Blend classes are different; otherwise, false.

See Also

Blend Class | Aspose.Imaging Namespace


Blend Inequality Operator

Tests whether two specified Blend classes are equivalent.

public static bool operator !=(
Blend blend1,
Blend blend2
);

Parameters

blend1
The Blend that is to the left of the equality operator.
blend2
The Blend that is to the right of the equality operator.

Return Value

True if the two Blend classes are equal; otherwise, false.

See Also

Blend Class | Aspose.Imaging Namespace


Brush Class

The base brush class.

For a list of all members of this type, see Brush Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.Brush
Aspose.Imaging.Brushes.HatchBrush
Aspose.Imaging.Brushes.SolidBrush
Aspose.Imaging.Brushes.TransformBrush

public abstract class Brush : DisposableObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Brush Members | Aspose.Imaging Namespace


Brush Members

Brush overview

Public Instance Properties

Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
Opacity | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.

Public Instance Methods

DeepClone | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Brush Constructor Initializes a new instance of the Brush class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReleaseManagedResources (inherited from DisposableObject) | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

Brush Class | Aspose.Imaging Namespace


Brush Constructor

Initializes a new instance of the Brush class.

protected Brush();

See Also

Brush Class | Aspose.Imaging Namespace


Brush Properties

The properties of the Brush class are listed below. For a complete list of Brush class members, see the Brush Members topic.

Public Instance Properties

Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
Opacity | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.

See Also

Brush Class | Aspose.Imaging Namespace


Opacity Property

Aspose.Imaging Documentation

Brush.Opacity Property

Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.

public float Opacity {get; set;}

Property Value

The brush opacity value.

See Also

Brush Class | Aspose.Imaging Namespace


Brush Methods

The methods of the Brush class are listed below. For a complete list of Brush class members, see the Brush Members topic.

Public Instance Methods

DeepClone | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReleaseManagedResources (inherited from DisposableObject) | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

Brush Class | Aspose.Imaging Namespace


Brush.DeepClone Method

Creates a new deep clone of the current Brush.

public virtual Brush DeepClone();

Return Value

A new Brush which is the deep clone of this Brush instance.

See Also

Brush Class | Aspose.Imaging Namespace


BuildVersionInfo Class

Contains the current build version information.

For a list of all members of this type, see BuildVersionInfo Members.

System.Object
Aspose.Imaging.BuildVersionInfo

public abstract sealed class BuildVersionInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

BuildVersionInfo Members | Aspose.Imaging Namespace


BuildVersionInfo Members

BuildVersionInfo overview

Public Static Fields

AssemblyVersion | The assembly version.
FileVersion | The file version.
Product | The product title.
ProductMajor | The major product version.
ProductMinor | The minor product version.
ReleaseDate | The product release date.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BuildVersionInfo Class | Aspose.Imaging Namespace


BuildVersionInfo Fields

The fields of the BuildVersionInfo class are listed below. For a complete list of BuildVersionInfo class members, see the BuildVersionInfo Members topic.

Public Static Fields

AssemblyVersion | The assembly version.
FileVersion | The file version.
Product | The product title.
ProductMajor | The major product version.
ProductMinor | The minor product version.
ReleaseDate | The product release date.

See Also

BuildVersionInfo Class | Aspose.Imaging Namespace


BuildVersionInfo.AssemblyVersion Field

The assembly version.

public static readonly string AssemblyVersion;

See Also

BuildVersionInfo Class | Aspose.Imaging Namespace


BuildVersionInfo.FileVersion Field

The file version.

public static readonly string FileVersion;

See Also

BuildVersionInfo Class | Aspose.Imaging Namespace


BuildVersionInfo.Product Field

The product title.

public static readonly string Product;

See Also

BuildVersionInfo Class | Aspose.Imaging Namespace


BuildVersionInfo.ProductMajor Field

The major product version.

public static readonly int ProductMajor;

See Also

BuildVersionInfo Class | Aspose.Imaging Namespace


BuildVersionInfo.ProductMinor Field

The minor product version.

public static readonly int ProductMinor;

See Also

BuildVersionInfo Class | Aspose.Imaging Namespace


BuildVersionInfo.ReleaseDate Field

The product release date.

public static readonly DateTime ReleaseDate;

See Also

BuildVersionInfo Class | Aspose.Imaging Namespace


Cache Class

Contains cache settings.

For a list of all members of this type, see Cache Members.

System.Object
Aspose.Imaging.Cache

public abstract sealed class Cache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example demonstrates the use of Aspose.Imaging.Cache

[C#]

// By default the cache folder is set to user's local temp directory.
// You can also specify another cache folder than default like the following:
// Cache.CacheFolder = @"D:\\MyTemp";

// Auto mode is flexible and efficient
Cache.CacheType = CacheType.Auto;

// Default value is 0, which means there is no upper limit
Cache.MaxDiskSpaceForCache = 1073741824; // 1 gigabyte
Cache.MaxMemoryForCache = 1073741824; // 1 gigabyte

// It is not recommended to change the following property as it may greatly affect the performance
Cache.ExactReallocateOnly = false;

// At any time you may check how many bytes currently allocated for memory or disk
// cache by examining the following properties
long l1 = Cache.AllocatedDiskBytesCount;
long l2 = Cache.AllocatedMemoryBytesCount;

// Do some image processing as below
Aspose.Imaging.ImageOptions.GifOptions options = new Aspose.Imaging.ImageOptions.GifOptions();
options.Palette = new ColorPalette(new Color[] { Color.Red, Color.Blue, Color.Black, Color.White });
options.Source = new StreamSource(new MemoryStream(), true);
using (RasterImage image = (RasterImage)Image.Create(options, 100, 100))
{
    Color[] pixels = new Color[10000];
    for (int i = 0; i < pixels.Length; i++)
    {
        pixels[i] = Color.White;
    }

    image.SavePixels(image.Bounds, pixels);

    // after executing the code above there will be allocated 40000 bytes in-memory.
    long diskBytes = Cache.AllocatedDiskBytesCount;
    long memoryBytes = Cache.AllocatedMemoryBytesCount;
}

// The allocation properties may be used to check whether all Aspose.Imaging objects were properly disposed.
// In case you've forgot to call dispose on some object the cache values will be different than 0.
l1 = Cache.AllocatedDiskBytesCount;
l2 = Cache.AllocatedMemoryBytesCount;
[Visual Basic]

' By default the cache folder is set to user's local temp directory.
' You can also specify another cache folder than default like the following:
' Cache.CacheFolder = @"D:\\MyTemp";

' Auto mode is flexible and efficient
Cache.CacheType = CacheType.Auto

' Default value is 0, which means there is no upper limit
Cache.MaxDiskSpaceForCache = 1073741824 ' 1 gigabyte
Cache.MaxMemoryForCache = 1073741824 ' 1 gigabyte

' It is not recommended to change the following property as it may greatly affect the performance
Cache.ExactReallocateOnly = False

' At any time you may check how many bytes currently allocated for memory or disk
' cache by examining the following properties
Dim l1 As Long = Cache.AllocatedDiskBytesCount
Dim l2 As Long = Cache.AllocatedMemoryBytesCount

' Do some image processing as below
Dim options As Aspose.Imaging.ImageOptions.GifOptions = New Aspose.Imaging.ImageOptions.GifOptions()
options.Palette = New ColorPalette(New Color() { Color.Red, Color.Blue, Color.Black, Color.White })
options.Source = New StreamSource(New MemoryStream(), True)
Using image As RasterImage = CType(Image.Create(options, 100, 100), RasterImage)
Dim pixels As Color() = New Color(9999) {}
Dim i As Integer = 0
    Do While i < pixels.Length
        pixels(i) = Color.White
        i += 1
    Loop

    image.SavePixels(image.Bounds, pixels)

' after executing the code above there will be allocated 40000 bytes in-memory.
Dim diskBytes As Long = Cache.AllocatedDiskBytesCount
Dim memoryBytes As Long = Cache.AllocatedMemoryBytesCount
End Using

' The allocation properties may be used to check whether all Aspose.Imaging objects were properly disposed.
' In case you've forgot to call dispose on some object the cache values will be different than 0.
l1 = Cache.AllocatedDiskBytesCount
l2 = Cache.AllocatedMemoryBytesCount

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Cache Members | Aspose.Imaging Namespace


Cache Members

Cache overview

Public Static Properties

AllocatedDiskBytesCount | Gets the allocated disk bytes count.
AllocatedMemoryBytesCount | Gets the allocated in-memory bytes count.
CacheFolder | Gets or sets the cache folder.
CacheType | Gets or sets the cache scheme used.
ExactReallocateOnly | Gets or sets a value indicating whether reallocation should be exact or not. If reallocation is non exact the performance should be higher.
MaxDiskSpaceForCache | Gets or sets the maximum available disk space for cache. The value specified is megabytes count.
MaxMemoryForCache | Gets or sets the maximum available memory for cache in memory. The value specified is megabytes count.

Public Static Methods

SetDefaults Sets the Cache settings to defaults.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Cache Class | Aspose.Imaging Namespace


Cache Properties

The properties of the Cache class are listed below. For a complete list of Cache class members, see the Cache Members topic.

Public Static Properties

AllocatedDiskBytesCount | Gets the allocated disk bytes count.
AllocatedMemoryBytesCount | Gets the allocated in-memory bytes count.
CacheFolder | Gets or sets the cache folder.
CacheType | Gets or sets the cache scheme used.
ExactReallocateOnly | Gets or sets a value indicating whether reallocation should be exact or not. If reallocation is non exact the performance should be higher.
MaxDiskSpaceForCache | Gets or sets the maximum available disk space for cache. The value specified is megabytes count.
MaxMemoryForCache | Gets or sets the maximum available memory for cache in memory. The value specified is megabytes count.

See Also

Cache Class | Aspose.Imaging Namespace


AllocatedDiskBytesCount Property

Aspose.Imaging Documentation

Cache.AllocatedDiskBytesCount Property

Gets the allocated disk bytes count.

public static long AllocatedDiskBytesCount {get;}

Property Value

The allocated disk bytes count.

See Also

Cache Class | Aspose.Imaging Namespace


AllocatedMemoryBytesCount Property

Aspose.Imaging Documentation

Cache.AllocatedMemoryBytesCount Property

Gets the allocated in-memory bytes count.

public static long AllocatedMemoryBytesCount {get;}

Property Value

The allocated in-memory bytes count.

See Also

Cache Class | Aspose.Imaging Namespace


CacheFolder Property

Aspose.Imaging Documentation

Cache.CacheFolder Property

Gets or sets the cache folder.

public static string CacheFolder {get; set;}

Property Value

The cache folder.

See Also

Cache Class | Aspose.Imaging Namespace


CacheType Property

Aspose.Imaging Documentation

Cache.CacheType Property

Gets or sets the cache scheme used.

public static CacheType CacheType {get; set;}

Property Value

The cache scheme used.

See Also

Cache Class | Aspose.Imaging Namespace


ExactReallocateOnly Property

Aspose.Imaging Documentation

Cache.ExactReallocateOnly Property

Gets or sets a value indicating whether reallocation should be exact or not. If reallocation is non exact the performance should be higher.

public static bool ExactReallocateOnly {get; set;}

Property Value

true if reallocation is exact; otherwise, false.

Remarks

The exact reallocation will perform reallocation of additional memory only up to the upper limit specified. When passing upper limit for in-memory during reallocation the cached data will be copied to disk if possible. When passing upper limit for disk memory during reallocation the appropriate exception is thrown. The performance should be higher if this option is turned off as no additional copying will be performed if possible, however this may also lead to pass upper limits specified for memory or disk.

See Also

Cache Class | Aspose.Imaging Namespace


MaxDiskSpaceForCache Property

Aspose.Imaging Documentation

Cache.MaxDiskSpaceForCache Property

Gets or sets the maximum available disk space for cache. The value specified is megabytes count.

public static int MaxDiskSpaceForCache {get; set;}

Property Value

The maximum available disk space for cache.

Remarks

Value of 0 will consume all available memory and serves as no upper limit.

See Also

Cache Class | Aspose.Imaging Namespace


MaxMemoryForCache Property

Aspose.Imaging Documentation

Cache.MaxMemoryForCache Property

Gets or sets the maximum available memory for cache in memory. The value specified is megabytes count.

public static int MaxMemoryForCache {get; set;}

Property Value

The maximum memory for cache.

Remarks

Value of 0 will consume all available memory and serves as no upper limit.

See Also

Cache Class | Aspose.Imaging Namespace


Cache Methods

The methods of the Cache class are listed below. For a complete list of Cache class members, see the Cache Members topic.

Public Static Methods

SetDefaults Sets the Cache settings to defaults.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Cache Class | Aspose.Imaging Namespace


Cache.SetDefaults Method

Sets the Cache settings to defaults.

public static void SetDefaults();

See Also

Cache Class | Aspose.Imaging Namespace


CacheType Enumeration

Specifies the cache type to use.

public enum CacheType

Members

Member Name | Description | Value
Auto | Specifies auto cache type. The auto cache scheme will try to cache in-memory first then on disk. | 0
CacheOnDiskOnly | The disk cache only. | 1
CacheInMemoryOnly | The in-memory cache only. | 2

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


CharacterSet Enumeration

Represents the character set used.

public enum CharacterSet

Members

Member Name | Description | Value
Ansi | 1252 Latin 1, 1250 Latin 2, 1256 Arabic character sets | 0
Default | The default character set. | 1
Symbol | The symbol character set | 2
Shiftjis | DBCS, 932 Japanese character set. | 128
Hangeul | DBCS, 949 Korean character set. | 129
Hangul | DBCS, 949 Korean character set. | 129
Gb2312 | DBCS, 936 Simplified Chinese character set. | 134
ChineseBig5 | DBCS, 950 Traditional Chinese character set. | 136
Oem | 437 MS-DOS Latin 1, 852 MS-DOS Latin 2, 864 MS-DOS Arabic character sets. | 255
Johab | DBCS, 1361 Korean character set. | 130
Hebrew | 1255 Hebrew character set. | 177
Arabic | 1256 Arabic character set. | 178
Greek | 1253 Greek character set. | 161
Turkish | 1254 Turkish character set. | 162
Vietnamese | 1258 Vietnamese character set. | 163
Thai | 874 Thai character set. | 222
Easteurope | 1250 Latin 2, Central Europe character set. | 238
Russian | 1251 Cyrillic (Slavic) character set. | 204
Mac | 10000 Mac Roman, 10029 Mac Central Europe, 10007 Mac Cyrillic character sets. | 77
Baltic | 1257 Baltic Rim character set. | 186

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


CMYKColor Structure

The CMYK color of pixel.

For a list of all members of this type, see CMYKColor Members.

System.Object
System.ValueType
Aspose.Imaging.CMYKColor

public struct CMYKColor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CMYKColor Members | Aspose.Imaging Namespace


CMYKColor Members

CMYKColor overview

Public Static Properties

Empty Gets the empty.

Public Static Methods

FromParams Creates a CMYKColor structure from a 32-bit cyan, magenta, yellow and black values.

Public Instance Properties

C | Gets the cyan component value of this Color structure.
IsEmpty | Gets a value indicating whether this Color structure is uninitialized.
K | Gets the black component value of this Color structure.
M | Gets the magenta component value of this Color structure.
Y | Gets the yellow component value of this Color structure.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode | The get hash code.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

CMYKColor Class | Aspose.Imaging Namespace


CMYKColor Properties

The properties of the CMYKColor structure are listed below. For a complete list of CMYKColor structure members, see the CMYKColor Members topic.

Public Static Properties

Empty Gets the empty.

Public Instance Properties

C | Gets the cyan component value of this Color structure.
IsEmpty | Gets a value indicating whether this Color structure is uninitialized.
K | Gets the black component value of this Color structure.
M | Gets the magenta component value of this Color structure.
Y | Gets the yellow component value of this Color structure.

See Also

CMYKColor Class | Aspose.Imaging Namespace


C Property

Aspose.Imaging Documentation

CMYKColor.C Property

Gets the cyan component value of this Color structure.

public byte C {get;}

Property Value

The cyan component value of this Color.

See Also

CMYKColor Class | Aspose.Imaging Namespace


Empty Property

Aspose.Imaging Documentation

CMYKColor.Empty Property

Gets the empty.

public static CMYKColor Empty {get;}

See Also

CMYKColor Class | Aspose.Imaging Namespace


IsEmpty Property

Aspose.Imaging Documentation

CMYKColor.IsEmpty Property

Gets a value indicating whether this Color structure is uninitialized.

public bool IsEmpty {get;}

Property Value

This property returns true if this color is uninitialized; otherwise, false.

See Also

CMYKColor Class | Aspose.Imaging Namespace


K Property

Aspose.Imaging Documentation

CMYKColor.K Property

Gets the black component value of this Color structure.

public byte K {get;}

Property Value

The black component value of this Color.

See Also

CMYKColor Class | Aspose.Imaging Namespace


M Property

Aspose.Imaging Documentation

CMYKColor.M Property

Gets the magenta component value of this Color structure.

public byte M {get;}

Property Value

The magenta component value of this Color.

See Also

CMYKColor Class | Aspose.Imaging Namespace


Y Property

Aspose.Imaging Documentation

CMYKColor.Y Property

Gets the yellow component value of this Color structure.

public byte Y {get;}

Property Value

The yellow component value of this Color.

See Also

CMYKColor Class | Aspose.Imaging Namespace


CMYKColor Methods

The methods of the CMYKColor structure are listed below. For a complete list of CMYKColor structure members, see the CMYKColor Members topic.

Public Static Methods

FromParams Creates a CMYKColor structure from a 32-bit cyan, magenta, yellow and black values.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode | The get hash code.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

CMYKColor Class | Aspose.Imaging Namespace


CMYKColor.FromParams Method

Creates a CMYKColor structure from a 32-bit cyan, magenta, yellow and black values.

public static CMYKColor FromParams(
int cyan,
int magenta,
int yellow,
int black
);

Parameters

cyan
The cyan component. Valid values are 0 through 255.
magenta
The magenta component. Valid values are 0 through 255.
yellow
The yellow component. Valid values are 0 through 255.
black
The black component. Valid values are 0 through 255.

Return Value

The CMYKColor.

See Also

CMYKColor Class | Aspose.Imaging Namespace


CMYKColor.GetHashCode Method

The get hash code.

public override int GetHashCode();

Return Value

The Int32.

See Also

CMYKColor Class | Aspose.Imaging Namespace


Color Structure

The color of the pixel.

For a list of all members of this type, see Color Members.

System.Object
System.ValueType
Aspose.Imaging.Color

public struct Color

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Color Members | Aspose.Imaging Namespace


Color Members

Color overview

Public Static Properties

AliceBlue | Gets a system-defined color.
AntiqueWhite | Gets a system-defined color.
Aqua | Gets a system-defined color.
Aquamarine | Gets a system-defined color.
Azure | Gets a system-defined color.
Beige | Gets a system-defined color.
Bisque | Gets a system-defined color.
Black | Gets a system-defined color.
BlanchedAlmond | Gets a system-defined color.
Blue | Gets a system-defined color.
BlueViolet | Gets a system-defined color.
Brown | Gets a system-defined color.
BurlyWood | Gets a system-defined color.
CadetBlue | Gets a system-defined color.
Chartreuse | Gets a system-defined color.
Chocolate | Gets a system-defined color.
Coral | Gets a system-defined color.
CornflowerBlue | Gets a system-defined color.
Cornsilk | Gets a system-defined color.
Crimson | Gets a system-defined color.
Cyan | Gets a system-defined color.
DarkBlue | Gets a system-defined color.
DarkCyan | Gets a system-defined color.
DarkGoldenrod | Gets a system-defined color.
DarkGray | Gets a system-defined color.
DarkGreen | Gets a system-defined color.
DarkKhaki | Gets a system-defined color.
DarkMagenta | Gets a system-defined color.
DarkOliveGreen | Gets a system-defined color.
DarkOrange | Gets a system-defined color.
DarkOrchid | Gets a system-defined color.
DarkRed | Gets a system-defined color.
DarkSalmon | Gets a system-defined color.
DarkSeaGreen | Gets a system-defined color.
DarkSlateBlue | Gets a system-defined color.
DarkSlateGray | Gets a system-defined color.
DarkTurquoise | Gets a system-defined color.
DarkViolet | Gets a system-defined color.
DeepPink | Gets a system-defined color.
DeepSkyBlue | Gets a system-defined color.
DimGray | Gets a system-defined color.
DodgerBlue | Gets a system-defined color.
Empty | Gets an empty Color.
Firebrick | Gets a system-defined color.
FloralWhite | Gets a system-defined color.
ForestGreen | Gets a system-defined color.
Fuchsia | Gets a system-defined color.
Gainsboro | Gets a system-defined color.
GhostWhite | Gets a system-defined color.
Gold | Gets a system-defined color.
Goldenrod | Gets a system-defined color.
Gray | Gets a system-defined color.
Green | Gets a system-defined color.
GreenYellow | Gets a system-defined color.
Honeydew | Gets a system-defined color.
HotPink | Gets a system-defined color.
IndianRed | Gets a system-defined color.
Indigo | Gets a system-defined color.
Ivory | Gets a system-defined color.
Khaki | Gets a system-defined color.
Lavender | Gets a system-defined color.
LavenderBlush | Gets a system-defined color.
LawnGreen | Gets a system-defined color.
LemonChiffon | Gets a system-defined color.
LightBlue | Gets a system-defined color.
LightCoral | Gets a system-defined color.
LightCyan | Gets a system-defined color.
LightGoldenrodYellow | Gets a system-defined color.
LightGray | Gets a system-defined color.
LightGreen | Gets a system-defined color.
LightPink | Gets a system-defined color.
LightSalmon | Gets a system-defined color.
LightSeaGreen | Gets a system-defined color.
LightSkyBlue | Gets a system-defined color.
LightSlateGray | Gets a system-defined color.
LightSteelBlue | Gets a system-defined color.
LightYellow | Gets a system-defined color.
Lime | Gets a system-defined color.
LimeGreen | Gets a system-defined color.
Linen | Gets a system-defined color.
Magenta | Gets a system-defined color.
Maroon | Gets a system-defined color.
MediumAquamarine | Gets a system-defined color.
MediumBlue | Gets a system-defined color.
MediumOrchid | Gets a system-defined color.
MediumPurple | Gets a system-defined color.
MediumSeaGreen | Gets a system-defined color.
MediumSlateBlue | Gets a system-defined color.
MediumSpringGreen | Gets a system-defined color.
MediumTurquoise | Gets a system-defined color.
MediumVioletRed | Gets a system-defined color.
MidnightBlue | Gets a system-defined color.
MintCream | Gets a system-defined color.
MistyRose | Gets a system-defined color.
Moccasin | Gets a system-defined color.
NavajoWhite | Gets a system-defined color.
Navy | Gets a system-defined color.
OldLace | Gets a system-defined color.
Olive | Gets a system-defined color.
OliveDrab | Gets a system-defined color.
Orange | Gets a system-defined color.
OrangeRed | Gets a system-defined color.
Orchid | Gets a system-defined color.
PaleGoldenrod | Gets a system-defined color.
PaleGreen | Gets a system-defined color.
PaleTurquoise | Gets a system-defined color.
PaleVioletRed | Gets a system-defined color.
PapayaWhip | Gets a system-defined color.
PeachPuff | Gets a system-defined color.
Peru | Gets a system-defined color.
Pink | Gets a system-defined color.
Plum | Gets a system-defined color.
PowderBlue | Gets a system-defined color.
Purple | Gets a system-defined color.
Red | Gets a system-defined color.
RosyBrown | Gets a system-defined color.
RoyalBlue | Gets a system-defined color.
SaddleBrown | Gets a system-defined color.
Salmon | Gets a system-defined color.
SandyBrown | Gets a system-defined color.
SeaGreen | Gets a system-defined color.
SeaShell | Gets a system-defined color.
Sienna | Gets a system-defined color.
Silver | Gets a system-defined color.
SkyBlue | Gets a system-defined color.
SlateBlue | Gets a system-defined color.
SlateGray | Gets a system-defined color.
Snow | Gets a system-defined color.
SpringGreen | Gets a system-defined color.
SteelBlue | Gets a system-defined color.
Tan | Gets a system-defined color.
Teal | Gets a system-defined color.
Thistle | Gets a system-defined color.
Tomato | Gets a system-defined color.
Transparent | Gets a system-defined color.
Turquoise | Gets a system-defined color.
Violet | Gets a system-defined color.
Wheat | Gets a system-defined color.
White | Gets a system-defined color.
WhiteSmoke | Gets a system-defined color.
Yellow | Gets a system-defined color.
YellowGreen | Gets a system-defined color.

Public Static Methods

FromArgb | Overloaded. Creates a Color structure from a 32-bit ARGB value.
FromKnownColor | Creates a Color structure from the specified predefined color.
FromName | Creates a Color structure from the specified name of a predefined color.

Public Static Operators

Equality Operator | Tests whether two specified Color structures are equivalent.
Inequality Operator | Tests whether two specified Color structures are different.

Public Instance Properties

A | Gets the alpha component value of this Color structure.
B | Gets the blue component value of this Color structure.
G | Gets the green component value of this Color structure.
IsEmpty | Gets a value indicating whether this Color structure is uninitialized.
IsKnownColor | Gets a value indicating whether this Color structure is a predefined color. Predefined colors are represented by the elements of the KnownColor enumeration.
IsNamedColor | Gets a value indicating whether this Color structure is a named color or a member of the KnownColor enumeration.
Name | Gets the name of this Color.
R | Gets the red component value of this Color structure.

Public Instance Methods

Equals | Tests whether the specified object is a Color structure and is equivalent to this Color structure.
GetBrightness | Gets the hue-saturation-brightness (HSB) brightness value for this Color structure.
GetHashCode | Returns a hash code for this Color structure.
GetHue | Gets the hue-saturation-brightness (HSB) hue value, in degrees, for this Color structure.
GetSaturation | Gets the hue-saturation-brightness (HSB) saturation value for this Color structure.
GetType (inherited from Object) | Gets the Type of the current instance.
ToArgb | Gets the 32-bit ARGB value of this Color structure.
ToKnownColor | Gets the KnownColor value of this Color structure.
ToString | Converts this Color structure to a human-readable string.

See Also

Color Class | Aspose.Imaging Namespace


Color Properties

The properties of the Color structure are listed below. For a complete list of Color structure members, see the Color Members topic.

Public Static Properties

AliceBlue | Gets a system-defined color.
AntiqueWhite | Gets a system-defined color.
Aqua | Gets a system-defined color.
Aquamarine | Gets a system-defined color.
Azure | Gets a system-defined color.
Beige | Gets a system-defined color.
Bisque | Gets a system-defined color.
Black | Gets a system-defined color.
BlanchedAlmond | Gets a system-defined color.
Blue | Gets a system-defined color.
BlueViolet | Gets a system-defined color.
Brown | Gets a system-defined color.
BurlyWood | Gets a system-defined color.
CadetBlue | Gets a system-defined color.
Chartreuse | Gets a system-defined color.
Chocolate | Gets a system-defined color.
Coral | Gets a system-defined color.
CornflowerBlue | Gets a system-defined color.
Cornsilk | Gets a system-defined color.
Crimson | Gets a system-defined color.
Cyan | Gets a system-defined color.
DarkBlue | Gets a system-defined color.
DarkCyan | Gets a system-defined color.
DarkGoldenrod | Gets a system-defined color.
DarkGray | Gets a system-defined color.
DarkGreen | Gets a system-defined color.
DarkKhaki | Gets a system-defined color.
DarkMagenta | Gets a system-defined color.
DarkOliveGreen | Gets a system-defined color.
DarkOrange | Gets a system-defined color.
DarkOrchid | Gets a system-defined color.
DarkRed | Gets a system-defined color.
DarkSalmon | Gets a system-defined color.
DarkSeaGreen | Gets a system-defined color.
DarkSlateBlue | Gets a system-defined color.
DarkSlateGray | Gets a system-defined color.
DarkTurquoise | Gets a system-defined color.
DarkViolet | Gets a system-defined color.
DeepPink | Gets a system-defined color.
DeepSkyBlue | Gets a system-defined color.
DimGray | Gets a system-defined color.
DodgerBlue | Gets a system-defined color.
Empty | Gets an empty Color.
Firebrick | Gets a system-defined color.
FloralWhite | Gets a system-defined color.
ForestGreen | Gets a system-defined color.
Fuchsia | Gets a system-defined color.
Gainsboro | Gets a system-defined color.
GhostWhite | Gets a system-defined color.
Gold | Gets a system-defined color.
Goldenrod | Gets a system-defined color.
Gray | Gets a system-defined color.
Green | Gets a system-defined color.
GreenYellow | Gets a system-defined color.
Honeydew | Gets a system-defined color.
HotPink | Gets a system-defined color.
IndianRed | Gets a system-defined color.
Indigo | Gets a system-defined color.
Ivory | Gets a system-defined color.
Khaki | Gets a system-defined color.
Lavender | Gets a system-defined color.
LavenderBlush | Gets a system-defined color.
LawnGreen | Gets a system-defined color.
LemonChiffon | Gets a system-defined color.
LightBlue | Gets a system-defined color.
LightCoral | Gets a system-defined color.
LightCyan | Gets a system-defined color.
LightGoldenrodYellow | Gets a system-defined color.
LightGray | Gets a system-defined color.
LightGreen | Gets a system-defined color.
LightPink | Gets a system-defined color.
LightSalmon | Gets a system-defined color.
LightSeaGreen | Gets a system-defined color.
LightSkyBlue | Gets a system-defined color.
LightSlateGray | Gets a system-defined color.
LightSteelBlue | Gets a system-defined color.
LightYellow | Gets a system-defined color.
Lime | Gets a system-defined color.
LimeGreen | Gets a system-defined color.
Linen | Gets a system-defined color.
Magenta | Gets a system-defined color.
Maroon | Gets a system-defined color.
MediumAquamarine | Gets a system-defined color.
MediumBlue | Gets a system-defined color.
MediumOrchid | Gets a system-defined color.
MediumPurple | Gets a system-defined color.
MediumSeaGreen | Gets a system-defined color.
MediumSlateBlue | Gets a system-defined color.
MediumSpringGreen | Gets a system-defined color.
MediumTurquoise | Gets a system-defined color.
MediumVioletRed | Gets a system-defined color.
MidnightBlue | Gets a system-defined color.
MintCream | Gets a system-defined color.
MistyRose | Gets a system-defined color.
Moccasin | Gets a system-defined color.
NavajoWhite | Gets a system-defined color.
Navy | Gets a system-defined color.
OldLace | Gets a system-defined color.
Olive | Gets a system-defined color.
OliveDrab | Gets a system-defined color.
Orange | Gets a system-defined color.
OrangeRed | Gets a system-defined color.
Orchid | Gets a system-defined color.
PaleGoldenrod | Gets a system-defined color.
PaleGreen | Gets a system-defined color.
PaleTurquoise | Gets a system-defined color.
PaleVioletRed | Gets a system-defined color.
PapayaWhip | Gets a system-defined color.
PeachPuff | Gets a system-defined color.
Peru | Gets a system-defined color.
Pink | Gets a system-defined color.
Plum | Gets a system-defined color.
PowderBlue | Gets a system-defined color.
Purple | Gets a system-defined color.
Red | Gets a system-defined color.
RosyBrown | Gets a system-defined color.
RoyalBlue | Gets a system-defined color.
SaddleBrown | Gets a system-defined color.
Salmon | Gets a system-defined color.
SandyBrown | Gets a system-defined color.
SeaGreen | Gets a system-defined color.
SeaShell | Gets a system-defined color.
Sienna | Gets a system-defined color.
Silver | Gets a system-defined color.
SkyBlue | Gets a system-defined color.
SlateBlue | Gets a system-defined color.
SlateGray | Gets a system-defined color.
Snow | Gets a system-defined color.
SpringGreen | Gets a system-defined color.
SteelBlue | Gets a system-defined color.
Tan | Gets a system-defined color.
Teal | Gets a system-defined color.
Thistle | Gets a system-defined color.
Tomato | Gets a system-defined color.
Transparent | Gets a system-defined color.
Turquoise | Gets a system-defined color.
Violet | Gets a system-defined color.
Wheat | Gets a system-defined color.
White | Gets a system-defined color.
WhiteSmoke | Gets a system-defined color.
Yellow | Gets a system-defined color.
YellowGreen | Gets a system-defined color.

Public Instance Properties

A | Gets the alpha component value of this Color structure.
B | Gets the blue component value of this Color structure.
G | Gets the green component value of this Color structure.
IsEmpty | Gets a value indicating whether this Color structure is uninitialized.
IsKnownColor | Gets a value indicating whether this Color structure is a predefined color. Predefined colors are represented by the elements of the KnownColor enumeration.
IsNamedColor | Gets a value indicating whether this Color structure is a named color or a member of the KnownColor enumeration.
Name | Gets the name of this Color.
R | Gets the red component value of this Color structure.

See Also

Color Class | Aspose.Imaging Namespace


A Property

Aspose.Imaging Documentation

Color.A Property

Gets the alpha component value of this Color structure.

public byte A {get;}

Property Value

The alpha component value of this Color.

See Also

Color Class | Aspose.Imaging Namespace


AliceBlue Property

Aspose.Imaging Documentation

Color.AliceBlue Property

Gets a system-defined color.

public static Color AliceBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


AntiqueWhite Property

Aspose.Imaging Documentation

Color.AntiqueWhite Property

Gets a system-defined color.

public static Color AntiqueWhite {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Aqua Property

Aspose.Imaging Documentation

Color.Aqua Property

Gets a system-defined color.

public static Color Aqua {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Aquamarine Property

Aspose.Imaging Documentation

Color.Aquamarine Property

Gets a system-defined color.

public static Color Aquamarine {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Azure Property

Aspose.Imaging Documentation

Color.Azure Property

Gets a system-defined color.

public static Color Azure {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


B Property

Aspose.Imaging Documentation

Color.B Property

Gets the blue component value of this Color structure.

public byte B {get;}

Property Value

The blue component value of this Color.

See Also

Color Class | Aspose.Imaging Namespace


Beige Property

Aspose.Imaging Documentation

Color.Beige Property

Gets a system-defined color.

public static Color Beige {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Bisque Property

Aspose.Imaging Documentation

Color.Bisque Property

Gets a system-defined color.

public static Color Bisque {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Black Property

Aspose.Imaging Documentation

Color.Black Property

Gets a system-defined color.

public static Color Black {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


BlanchedAlmond Property

Aspose.Imaging Documentation

Color.BlanchedAlmond Property

Gets a system-defined color.

public static Color BlanchedAlmond {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Blue Property

Aspose.Imaging Documentation

Color.Blue Property

Gets a system-defined color.

public static Color Blue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


BlueViolet Property

Aspose.Imaging Documentation

Color.BlueViolet Property

Gets a system-defined color.

public static Color BlueViolet {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Brown Property

Aspose.Imaging Documentation

Color.Brown Property

Gets a system-defined color.

public static Color Brown {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


BurlyWood Property

Aspose.Imaging Documentation

Color.BurlyWood Property

Gets a system-defined color.

public static Color BurlyWood {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


CadetBlue Property

Aspose.Imaging Documentation

Color.CadetBlue Property

Gets a system-defined color.

public static Color CadetBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Chartreuse Property

Aspose.Imaging Documentation

Color.Chartreuse Property

Gets a system-defined color.

public static Color Chartreuse {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Chocolate Property

Aspose.Imaging Documentation

Color.Chocolate Property

Gets a system-defined color.

public static Color Chocolate {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Coral Property

Aspose.Imaging Documentation

Color.Coral Property

Gets a system-defined color.

public static Color Coral {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


CornflowerBlue Property

Aspose.Imaging Documentation

Color.CornflowerBlue Property

Gets a system-defined color.

public static Color CornflowerBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Cornsilk Property

Aspose.Imaging Documentation

Color.Cornsilk Property

Gets a system-defined color.

public static Color Cornsilk {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Crimson Property

Aspose.Imaging Documentation

Color.Crimson Property

Gets a system-defined color.

public static Color Crimson {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Cyan Property

Aspose.Imaging Documentation

Color.Cyan Property

Gets a system-defined color.

public static Color Cyan {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkBlue Property

Aspose.Imaging Documentation

Color.DarkBlue Property

Gets a system-defined color.

public static Color DarkBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkCyan Property

Aspose.Imaging Documentation

Color.DarkCyan Property

Gets a system-defined color.

public static Color DarkCyan {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkGoldenrod Property

Aspose.Imaging Documentation

Color.DarkGoldenrod Property

Gets a system-defined color.

public static Color DarkGoldenrod {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkGray Property

Aspose.Imaging Documentation

Color.DarkGray Property

Gets a system-defined color.

public static Color DarkGray {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkGreen Property

Aspose.Imaging Documentation

Color.DarkGreen Property

Gets a system-defined color.

public static Color DarkGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkKhaki Property

Aspose.Imaging Documentation

Color.DarkKhaki Property

Gets a system-defined color.

public static Color DarkKhaki {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkMagenta Property

Aspose.Imaging Documentation

Color.DarkMagenta Property

Gets a system-defined color.

public static Color DarkMagenta {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkOliveGreen Property

Aspose.Imaging Documentation

Color.DarkOliveGreen Property

Gets a system-defined color.

public static Color DarkOliveGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkOrange Property

Aspose.Imaging Documentation

Color.DarkOrange Property

Gets a system-defined color.

public static Color DarkOrange {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkOrchid Property

Aspose.Imaging Documentation

Color.DarkOrchid Property

Gets a system-defined color.

public static Color DarkOrchid {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkRed Property

Aspose.Imaging Documentation

Color.DarkRed Property

Gets a system-defined color.

public static Color DarkRed {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkSalmon Property

Aspose.Imaging Documentation

Color.DarkSalmon Property

Gets a system-defined color.

public static Color DarkSalmon {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkSeaGreen Property

Aspose.Imaging Documentation

Color.DarkSeaGreen Property

Gets a system-defined color.

public static Color DarkSeaGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkSlateBlue Property

Aspose.Imaging Documentation

Color.DarkSlateBlue Property

Gets a system-defined color.

public static Color DarkSlateBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkSlateGray Property

Aspose.Imaging Documentation

Color.DarkSlateGray Property

Gets a system-defined color.

public static Color DarkSlateGray {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkTurquoise Property

Aspose.Imaging Documentation

Color.DarkTurquoise Property

Gets a system-defined color.

public static Color DarkTurquoise {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DarkViolet Property

Aspose.Imaging Documentation

Color.DarkViolet Property

Gets a system-defined color.

public static Color DarkViolet {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DeepPink Property

Aspose.Imaging Documentation

Color.DeepPink Property

Gets a system-defined color.

public static Color DeepPink {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DeepSkyBlue Property

Aspose.Imaging Documentation

Color.DeepSkyBlue Property

Gets a system-defined color.

public static Color DeepSkyBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DimGray Property

Aspose.Imaging Documentation

Color.DimGray Property

Gets a system-defined color.

public static Color DimGray {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


DodgerBlue Property

Aspose.Imaging Documentation

Color.DodgerBlue Property

Gets a system-defined color.

public static Color DodgerBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Empty Property

Aspose.Imaging Documentation

Color.Empty Property

Gets an empty Color.

public static Color Empty {get;}

Property Value

The empty Color.

See Also

Color Class | Aspose.Imaging Namespace


Firebrick Property

Aspose.Imaging Documentation

Color.Firebrick Property

Gets a system-defined color.

public static Color Firebrick {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


FloralWhite Property

Aspose.Imaging Documentation

Color.FloralWhite Property

Gets a system-defined color.

public static Color FloralWhite {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


ForestGreen Property

Aspose.Imaging Documentation

Color.ForestGreen Property

Gets a system-defined color.

public static Color ForestGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Fuchsia Property

Aspose.Imaging Documentation

Color.Fuchsia Property

Gets a system-defined color.

public static Color Fuchsia {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


G Property

Aspose.Imaging Documentation

Color.G Property

Gets the green component value of this Color structure.

public byte G {get;}

Property Value

The green component value of this Color.

See Also

Color Class | Aspose.Imaging Namespace


Gainsboro Property

Aspose.Imaging Documentation

Color.Gainsboro Property

Gets a system-defined color.

public static Color Gainsboro {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


GhostWhite Property

Aspose.Imaging Documentation

Color.GhostWhite Property

Gets a system-defined color.

public static Color GhostWhite {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Gold Property

Aspose.Imaging Documentation

Color.Gold Property

Gets a system-defined color.

public static Color Gold {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Goldenrod Property

Aspose.Imaging Documentation

Color.Goldenrod Property

Gets a system-defined color.

public static Color Goldenrod {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Gray Property

Aspose.Imaging Documentation

Color.Gray Property

Gets a system-defined color.

public static Color Gray {get;}

Property Value

A Color structure representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Green Property

Aspose.Imaging Documentation

Color.Green Property

Gets a system-defined color.

public static Color Green {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


GreenYellow Property

Aspose.Imaging Documentation

Color.GreenYellow Property

Gets a system-defined color.

public static Color GreenYellow {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Honeydew Property

Aspose.Imaging Documentation

Color.Honeydew Property

Gets a system-defined color.

public static Color Honeydew {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


HotPink Property

Aspose.Imaging Documentation

Color.HotPink Property

Gets a system-defined color.

public static Color HotPink {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


IndianRed Property

Aspose.Imaging Documentation

Color.IndianRed Property

Gets a system-defined color.

public static Color IndianRed {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Indigo Property

Aspose.Imaging Documentation

Color.Indigo Property

Gets a system-defined color.

public static Color Indigo {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


IsEmpty Property

Aspose.Imaging Documentation

Color.IsEmpty Property

Gets a value indicating whether this Color structure is uninitialized.

public bool IsEmpty {get;}

Property Value

This property returns true if this color is uninitialized; otherwise, false.

See Also

Color Class | Aspose.Imaging Namespace


IsKnownColor Property

Aspose.Imaging Documentation

Color.IsKnownColor Property

Gets a value indicating whether this Color structure is a predefined color. Predefined colors are represented by the elements of the KnownColor enumeration.

public bool IsKnownColor {get;}

Property Value

True if this Color was created from a predefined color by using either the FromName method or the FromKnownColor method; otherwise, false.

See Also

Color Class | Aspose.Imaging Namespace


IsNamedColor Property

Aspose.Imaging Documentation

Color.IsNamedColor Property

Gets a value indicating whether this Color structure is a named color or a member of the KnownColor enumeration.

public bool IsNamedColor {get;}

Property Value

True if this Color was created by using either the FromName method or the FromKnownColor method; otherwise, false.

See Also

Color Class | Aspose.Imaging Namespace


Ivory Property

Aspose.Imaging Documentation

Color.Ivory Property

Gets a system-defined color.

public static Color Ivory {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Khaki Property

Aspose.Imaging Documentation

Color.Khaki Property

Gets a system-defined color.

public static Color Khaki {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Lavender Property

Aspose.Imaging Documentation

Color.Lavender Property

Gets a system-defined color.

public static Color Lavender {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LavenderBlush Property

Aspose.Imaging Documentation

Color.LavenderBlush Property

Gets a system-defined color.

public static Color LavenderBlush {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LawnGreen Property

Aspose.Imaging Documentation

Color.LawnGreen Property

Gets a system-defined color.

public static Color LawnGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LemonChiffon Property

Aspose.Imaging Documentation

Color.LemonChiffon Property

Gets a system-defined color.

public static Color LemonChiffon {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightBlue Property

Aspose.Imaging Documentation

Color.LightBlue Property

Gets a system-defined color.

public static Color LightBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightCoral Property

Aspose.Imaging Documentation

Color.LightCoral Property

Gets a system-defined color.

public static Color LightCoral {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightCyan Property

Aspose.Imaging Documentation

Color.LightCyan Property

Gets a system-defined color.

public static Color LightCyan {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightGoldenrodYellow Property

Aspose.Imaging Documentation

Color.LightGoldenrodYellow Property

Gets a system-defined color.

public static Color LightGoldenrodYellow {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightGray Property

Aspose.Imaging Documentation

Color.LightGray Property

Gets a system-defined color.

public static Color LightGray {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightGreen Property

Aspose.Imaging Documentation

Color.LightGreen Property

Gets a system-defined color.

public static Color LightGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightPink Property

Aspose.Imaging Documentation

Color.LightPink Property

Gets a system-defined color.

public static Color LightPink {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightSalmon Property

Aspose.Imaging Documentation

Color.LightSalmon Property

Gets a system-defined color.

public static Color LightSalmon {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightSeaGreen Property

Aspose.Imaging Documentation

Color.LightSeaGreen Property

Gets a system-defined color.

public static Color LightSeaGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightSkyBlue Property

Aspose.Imaging Documentation

Color.LightSkyBlue Property

Gets a system-defined color.

public static Color LightSkyBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightSlateGray Property

Aspose.Imaging Documentation

Color.LightSlateGray Property

Gets a system-defined color.

public static Color LightSlateGray {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightSteelBlue Property

Aspose.Imaging Documentation

Color.LightSteelBlue Property

Gets a system-defined color.

public static Color LightSteelBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LightYellow Property

Aspose.Imaging Documentation

Color.LightYellow Property

Gets a system-defined color.

public static Color LightYellow {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Lime Property

Aspose.Imaging Documentation

Color.Lime Property

Gets a system-defined color.

public static Color Lime {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


LimeGreen Property

Aspose.Imaging Documentation

Color.LimeGreen Property

Gets a system-defined color.

public static Color LimeGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Linen Property

Aspose.Imaging Documentation

Color.Linen Property

Gets a system-defined color.

public static Color Linen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Magenta Property

Aspose.Imaging Documentation

Color.Magenta Property

Gets a system-defined color.

public static Color Magenta {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Maroon Property

Aspose.Imaging Documentation

Color.Maroon Property

Gets a system-defined color.

public static Color Maroon {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


MediumAquamarine Property

Aspose.Imaging Documentation

Color.MediumAquamarine Property

Gets a system-defined color.

public static Color MediumAquamarine {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


MediumBlue Property

Aspose.Imaging Documentation

Color.MediumBlue Property

Gets a system-defined color.

public static Color MediumBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


MediumOrchid Property

Aspose.Imaging Documentation

Color.MediumOrchid Property

Gets a system-defined color.

public static Color MediumOrchid {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


MediumPurple Property

Aspose.Imaging Documentation

Color.MediumPurple Property

Gets a system-defined color.

public static Color MediumPurple {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


MediumSeaGreen Property

Aspose.Imaging Documentation

Color.MediumSeaGreen Property

Gets a system-defined color.

public static Color MediumSeaGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


MediumSlateBlue Property

Aspose.Imaging Documentation

Color.MediumSlateBlue Property

Gets a system-defined color.

public static Color MediumSlateBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


MediumSpringGreen Property

Aspose.Imaging Documentation

Color.MediumSpringGreen Property

Gets a system-defined color.

public static Color MediumSpringGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


MediumTurquoise Property

Aspose.Imaging Documentation

Color.MediumTurquoise Property

Gets a system-defined color.

public static Color MediumTurquoise {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


MediumVioletRed Property

Aspose.Imaging Documentation

Color.MediumVioletRed Property

Gets a system-defined color.

public static Color MediumVioletRed {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


MidnightBlue Property

Aspose.Imaging Documentation

Color.MidnightBlue Property

Gets a system-defined color.

public static Color MidnightBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


MintCream Property

Aspose.Imaging Documentation

Color.MintCream Property

Gets a system-defined color.

public static Color MintCream {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


MistyRose Property

Aspose.Imaging Documentation

Color.MistyRose Property

Gets a system-defined color.

public static Color MistyRose {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Moccasin Property

Aspose.Imaging Documentation

Color.Moccasin Property

Gets a system-defined color.

public static Color Moccasin {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Name Property

Aspose.Imaging Documentation

Color.Name Property

Gets the name of this Color.

public string Name {get;}

Property Value

The name of this Color.

See Also

Color Class | Aspose.Imaging Namespace


NavajoWhite Property

Aspose.Imaging Documentation

Color.NavajoWhite Property

Gets a system-defined color.

public static Color NavajoWhite {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Navy Property

Aspose.Imaging Documentation

Color.Navy Property

Gets a system-defined color.

public static Color Navy {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


OldLace Property

Aspose.Imaging Documentation

Color.OldLace Property

Gets a system-defined color.

public static Color OldLace {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Olive Property

Aspose.Imaging Documentation

Color.Olive Property

Gets a system-defined color.

public static Color Olive {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


OliveDrab Property

Aspose.Imaging Documentation

Color.OliveDrab Property

Gets a system-defined color.

public static Color OliveDrab {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Orange Property

Aspose.Imaging Documentation

Color.Orange Property

Gets a system-defined color.

public static Color Orange {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


OrangeRed Property

Aspose.Imaging Documentation

Color.OrangeRed Property

Gets a system-defined color.

public static Color OrangeRed {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Orchid Property

Aspose.Imaging Documentation

Color.Orchid Property

Gets a system-defined color.

public static Color Orchid {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


PaleGoldenrod Property

Aspose.Imaging Documentation

Color.PaleGoldenrod Property

Gets a system-defined color.

public static Color PaleGoldenrod {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


PaleGreen Property

Aspose.Imaging Documentation

Color.PaleGreen Property

Gets a system-defined color.

public static Color PaleGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


PaleTurquoise Property

Aspose.Imaging Documentation

Color.PaleTurquoise Property

Gets a system-defined color.

public static Color PaleTurquoise {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


PaleVioletRed Property

Aspose.Imaging Documentation

Color.PaleVioletRed Property

Gets a system-defined color.

public static Color PaleVioletRed {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


PapayaWhip Property

Aspose.Imaging Documentation

Color.PapayaWhip Property

Gets a system-defined color.

public static Color PapayaWhip {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


PeachPuff Property

Aspose.Imaging Documentation

Color.PeachPuff Property

Gets a system-defined color.

public static Color PeachPuff {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Peru Property

Aspose.Imaging Documentation

Color.Peru Property

Gets a system-defined color.

public static Color Peru {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Pink Property

Aspose.Imaging Documentation

Color.Pink Property

Gets a system-defined color.

public static Color Pink {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Plum Property

Aspose.Imaging Documentation

Color.Plum Property

Gets a system-defined color.

public static Color Plum {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


PowderBlue Property

Aspose.Imaging Documentation

Color.PowderBlue Property

Gets a system-defined color.

public static Color PowderBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Purple Property

Aspose.Imaging Documentation

Color.Purple Property

Gets a system-defined color.

public static Color Purple {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


R Property

Aspose.Imaging Documentation

Color.R Property

Gets the red component value of this Color structure.

public byte R {get;}

Property Value

The red component value of this Color.

See Also

Color Class | Aspose.Imaging Namespace


Red Property

Aspose.Imaging Documentation

Color.Red Property

Gets a system-defined color.

public static Color Red {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


RosyBrown Property

Aspose.Imaging Documentation

Color.RosyBrown Property

Gets a system-defined color.

public static Color RosyBrown {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


RoyalBlue Property

Aspose.Imaging Documentation

Color.RoyalBlue Property

Gets a system-defined color.

public static Color RoyalBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


SaddleBrown Property

Aspose.Imaging Documentation

Color.SaddleBrown Property

Gets a system-defined color.

public static Color SaddleBrown {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Salmon Property

Aspose.Imaging Documentation

Color.Salmon Property

Gets a system-defined color.

public static Color Salmon {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


SandyBrown Property

Aspose.Imaging Documentation

Color.SandyBrown Property

Gets a system-defined color.

public static Color SandyBrown {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


SeaGreen Property

Aspose.Imaging Documentation

Color.SeaGreen Property

Gets a system-defined color.

public static Color SeaGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


SeaShell Property

Aspose.Imaging Documentation

Color.SeaShell Property

Gets a system-defined color.

public static Color SeaShell {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Sienna Property

Aspose.Imaging Documentation

Color.Sienna Property

Gets a system-defined color.

public static Color Sienna {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Silver Property

Aspose.Imaging Documentation

Color.Silver Property

Gets a system-defined color.

public static Color Silver {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


SkyBlue Property

Aspose.Imaging Documentation

Color.SkyBlue Property

Gets a system-defined color.

public static Color SkyBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


SlateBlue Property

Aspose.Imaging Documentation

Color.SlateBlue Property

Gets a system-defined color.

public static Color SlateBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


SlateGray Property

Aspose.Imaging Documentation

Color.SlateGray Property

Gets a system-defined color.

public static Color SlateGray {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Snow Property

Aspose.Imaging Documentation

Color.Snow Property

Gets a system-defined color.

public static Color Snow {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


SpringGreen Property

Aspose.Imaging Documentation

Color.SpringGreen Property

Gets a system-defined color.

public static Color SpringGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


SteelBlue Property

Aspose.Imaging Documentation

Color.SteelBlue Property

Gets a system-defined color.

public static Color SteelBlue {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Tan Property

Aspose.Imaging Documentation

Color.Tan Property

Gets a system-defined color.

public static Color Tan {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Teal Property

Aspose.Imaging Documentation

Color.Teal Property

Gets a system-defined color.

public static Color Teal {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Thistle Property

Aspose.Imaging Documentation

Color.Thistle Property

Gets a system-defined color.

public static Color Thistle {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Tomato Property

Aspose.Imaging Documentation

Color.Tomato Property

Gets a system-defined color.

public static Color Tomato {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Transparent Property

Aspose.Imaging Documentation

Color.Transparent Property

Gets a system-defined color.

public static Color Transparent {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Turquoise Property

Aspose.Imaging Documentation

Color.Turquoise Property

Gets a system-defined color.

public static Color Turquoise {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Violet Property

Aspose.Imaging Documentation

Color.Violet Property

Gets a system-defined color.

public static Color Violet {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Wheat Property

Aspose.Imaging Documentation

Color.Wheat Property

Gets a system-defined color.

public static Color Wheat {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


White Property

Aspose.Imaging Documentation

Color.White Property

Gets a system-defined color.

public static Color White {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


WhiteSmoke Property

Aspose.Imaging Documentation

Color.WhiteSmoke Property

Gets a system-defined color.

public static Color WhiteSmoke {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Yellow Property

Aspose.Imaging Documentation

Color.Yellow Property

Gets a system-defined color.

public static Color Yellow {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


YellowGreen Property

Aspose.Imaging Documentation

Color.YellowGreen Property

Gets a system-defined color.

public static Color YellowGreen {get;}

Property Value

A Color representing a system-defined color.

See Also

Color Class | Aspose.Imaging Namespace


Color Methods

The methods of the Color structure are listed below. For a complete list of Color structure members, see the Color Members topic.

Public Static Methods

FromArgb | Overloaded. Creates a Color structure from a 32-bit ARGB value.
FromKnownColor | Creates a Color structure from the specified predefined color.
FromName | Creates a Color structure from the specified name of a predefined color.

Public Instance Methods

Equals | Tests whether the specified object is a Color structure and is equivalent to this Color structure.
GetBrightness | Gets the hue-saturation-brightness (HSB) brightness value for this Color structure.
GetHashCode | Returns a hash code for this Color structure.
GetHue | Gets the hue-saturation-brightness (HSB) hue value, in degrees, for this Color structure.
GetSaturation | Gets the hue-saturation-brightness (HSB) saturation value for this Color structure.
GetType (inherited from Object) | Gets the Type of the current instance.
ToArgb | Gets the 32-bit ARGB value of this Color structure.
ToKnownColor | Gets the KnownColor value of this Color structure.
ToString | Converts this Color structure to a human-readable string.

See Also

Color Class | Aspose.Imaging Namespace


Color.Equals Method

Tests whether the specified object is a Color structure and is equivalent to this Color structure.

public override bool Equals(
object obj
);

Parameters

obj
The object to test.

Return Value

True if obj is a Color structure equivalent to this Color structure; otherwise, false.

See Also

Color Class | Aspose.Imaging Namespace


FromArgb Method

Aspose.Imaging Documentation

Color.FromArgb Method

Creates a Color structure from a 32-bit ARGB value.

Overload List

Creates a Color structure from a 32-bit ARGB value.

public static Color FromArgb(int);

Creates a Color structure from the specified Color structure, but with the new specified alpha value. Although this method allows a 32-bit value to be passed for the alpha value, the value is limited to 8 bits.

public static Color FromArgb(int,Color);

Creates a Color structure from the specified 8-bit color values (red, green, and blue). The alpha value is implicitly 255 (fully opaque). Although this method allows a 32-bit value to be passed for each color component, the value of each component is limited to 8 bits.

public static Color FromArgb(int,int,int);

Creates a Color structure from the four ARGB component (alpha, red, green, and blue) values. Although this method allows a 32-bit value to be passed for each component, the value of each component is limited to 8 bits.

public static Color FromArgb(int,int,int,int);

See Also

Color Class | Aspose.Imaging Namespace


Color.FromArgb Method (Int32)

Creates a Color structure from a 32-bit ARGB value.

public static Color FromArgb(
int argb
);

Parameters

argb
A value specifying the 32-bit ARGB value.

Return Value

The Color structure that this method creates.

See Also

Color Class | Aspose.Imaging Namespace | Color.FromArgb Overload List


Color.FromArgb Method (Int32, Color)

Creates a Color structure from the specified Color structure, but with the new specified alpha value. Although this method allows a 32-bit value to be passed for the alpha value, the value is limited to 8 bits.

public static Color FromArgb(
int alpha,
Color baseColor
);

Parameters

alpha
The alpha value for the new Color. Valid values are 0 through 255.
baseColor
The Color from which to create the new Color.

Return Value

The Color that this method creates.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | alpha is less than 0 or greater than 255.

See Also

Color Class | Aspose.Imaging Namespace | Color.FromArgb Overload List


Color.FromArgb Method (Int32, Int32, Int32)

Creates a Color structure from the specified 8-bit color values (red, green, and blue). The alpha value is implicitly 255 (fully opaque). Although this method allows a 32-bit value to be passed for each color component, the value of each component is limited to 8 bits.

public static Color FromArgb(
int red,
int green,
int blue
);

Parameters

red
The red component value for the new Color. Valid values are 0 through 255.
green
The green component value for the new Color. Valid values are 0 through 255.
blue
The blue component value for the new Color. Valid values are 0 through 255.

Return Value

The Color that this method creates.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | red, green, or blue is less than 0 or greater than 255.

See Also

Color Class | Aspose.Imaging Namespace | Color.FromArgb Overload List


Color.FromArgb Method (Int32, Int32, Int32, Int32)

Creates a Color structure from the four ARGB component (alpha, red, green, and blue) values. Although this method allows a 32-bit value to be passed for each component, the value of each component is limited to 8 bits.

public static Color FromArgb(
int alpha,
int red,
int green,
int blue
);

Parameters

alpha
The alpha component. Valid values are 0 through 255.
red
The red component. Valid values are 0 through 255.
green
The green component. Valid values are 0 through 255.
blue
The blue component. Valid values are 0 through 255.

Return Value

The Color that this method creates.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | alpha, red, green, or blue is less than 0 or greater than 255.

See Also

Color Class | Aspose.Imaging Namespace | Color.FromArgb Overload List


Color.FromKnownColor Method

Creates a Color structure from the specified predefined color.

public static Color FromKnownColor(
KnownColor color
);

Parameters

color
An element of the KnownColor enumeration.

Return Value

The Color that this method creates.

See Also

Color Class | Aspose.Imaging Namespace


Color.FromName Method

Creates a Color structure from the specified name of a predefined color.

public static Color FromName(
string name
);

Parameters

name
A string that is the name of a predefined color. Valid names are the same as the names of the elements of the KnownColor enumeration.

Return Value

The Color that this method creates.

See Also

Color Class | Aspose.Imaging Namespace


Color.GetBrightness Method

Gets the hue-saturation-brightness (HSB) brightness value for this Color structure.

public float GetBrightness();

Return Value

The brightness of this Color. The brightness ranges from 0.0 through 1.0, where 0.0 represents black and 1.0 represents white.

See Also

Color Class | Aspose.Imaging Namespace


Color.GetHashCode Method

Returns a hash code for this Color structure.

public override int GetHashCode();

Return Value

An integer value that specifies the hash code for this Color.

See Also

Color Class | Aspose.Imaging Namespace


Color.GetHue Method

Gets the hue-saturation-brightness (HSB) hue value, in degrees, for this Color structure.

public float GetHue();

Return Value

The hue, in degrees, of this Color. The hue is measured in degrees, ranging from 0.0 through 360.0, in HSB color space.

See Also

Color Class | Aspose.Imaging Namespace


Color.GetSaturation Method

Gets the hue-saturation-brightness (HSB) saturation value for this Color structure.

public float GetSaturation();

Return Value

The saturation of this Color. The saturation ranges from 0.0 through 1.0, where 0.0 is grayscale and 1.0 is the most saturated.

See Also

Color Class | Aspose.Imaging Namespace


Color.ToArgb Method

Gets the 32-bit ARGB value of this Color structure.

public int ToArgb();

Return Value

The 32-bit ARGB value of this Color.

See Also

Color Class | Aspose.Imaging Namespace


Color.ToKnownColor Method

Gets the KnownColor value of this Color structure.

public KnownColor ToKnownColor();

Return Value

An element of the KnownColor enumeration, if the Color is created from a predefined color by using either the FromName method or the FromKnownColor method; otherwise, 0.

See Also

Color Class | Aspose.Imaging Namespace


Color.ToString Method

Converts this Color structure to a human-readable string.

public override string ToString();

Return Value

A string that is the name of this Color, if the Color is created from a predefined color by using either the FromName method or the FromKnownColor method; otherwise, a string that consists of the ARGB component names and their values.

See Also

Color Class | Aspose.Imaging Namespace


Color Operators

The operators of the Color structure are listed below. For a complete list of Color structure members, see the Color Members topic.

Public Static Operators

Equality Operator | Tests whether two specified Color structures are equivalent.
Inequality Operator | Tests whether two specified Color structures are different.

See Also

Color Class | Color Members | Aspose.Imaging Namespace


Color Equality Operator

Tests whether two specified Color structures are equivalent.

public static bool operator ==(
Color left,
Color right
);

Parameters

left
The Color that is to the left of the equality operator.
right
The Color that is to the right of the equality operator.

Return Value

True if the two Color structures are equal; otherwise, false.

See Also

Color Class | Aspose.Imaging Namespace


Color Inequality Operator

Tests whether two specified Color structures are different.

public static bool operator !=(
Color left,
Color right
);

Parameters

left
The Color that is to the left of the inequality operator.
right
The Color that is to the right of the inequality operator.

Return Value

True if the two Color structures are different; otherwise, false.

See Also

Color Class | Aspose.Imaging Namespace


ColorAdjustType Enumeration

Specifies which objects use color adjustment information.

public enum ColorAdjustType

Members

Member Name | Description | Value
Default | Color adjustment information that is used by all GDI+ objects that do not have their own color adjustment information. | 0
Bitmap | Color adjustment information for Bitmap objects. | 1
Brush | Color adjustment information for Brush objects. | 2
Pen | Color adjustment information for Pen objects. | 3
Text | Color adjustment information for text. | 4
Count | The number of types specified. | 5
Any | The number of types specified. | 6

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


ColorBlend Class

Defines arrays of colors and positions used for interpolating color blending in a multicolor gradient. This class cannot be inherited.

For a list of all members of this type, see ColorBlend Members.

System.Object
Aspose.Imaging.ColorBlend

public sealed class ColorBlend

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ColorBlend Members | Aspose.Imaging Namespace


ColorBlend Members

ColorBlend overview

Public Static Operators

Equality Operator | Tests whether two specified ColorBlend classes are different.
Inequality Operator | Tests whether two specified ColorBlend classes are equivalent.

Public Instance Constructors

ColorBlend Overloaded. Initializes a new instance of the ColorBlend class.

Public Instance Properties

Colors | Gets or sets an array of colors that represents the colors to use at corresponding positions along a gradient.
Positions | Gets or sets the positions along a gradient line.

Public Instance Methods

Equals | Tests whether the specified object is a ColorBlend class and is equivalent to this ColorBlend class.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorBlend Class | Aspose.Imaging Namespace


ColorBlend Constructor

Initializes a new instance of the ColorBlend class.

Overload List

Initializes a new instance of the ColorBlend class.

public ColorBlend();

Initializes a new instance of the ColorBlend class with the specified number of colors and positions.

public ColorBlend(int);

See Also

ColorBlend Class | Aspose.Imaging Namespace


ColorBlend Constructor ()

Initializes a new instance of the ColorBlend class.

public ColorBlend();

See Also

ColorBlend Class | Aspose.Imaging Namespace | ColorBlend Constructor Overload List


ColorBlend Constructor (Int32)

Initializes a new instance of the ColorBlend class with the specified number of colors and positions.

public ColorBlend(
int count
);

Parameters

count
The number of colors and positions in this ColorBlend.

See Also

ColorBlend Class | Aspose.Imaging Namespace | ColorBlend Constructor Overload List


ColorBlend Properties

The properties of the ColorBlend class are listed below. For a complete list of ColorBlend class members, see the ColorBlend Members topic.

Public Instance Properties

Colors | Gets or sets an array of colors that represents the colors to use at corresponding positions along a gradient.
Positions | Gets or sets the positions along a gradient line.

See Also

ColorBlend Class | Aspose.Imaging Namespace


Colors Property

Aspose.Imaging Documentation

ColorBlend.Colors Property

Gets or sets an array of colors that represents the colors to use at corresponding positions along a gradient.

public Color[] Colors {get; set;}

See Also

ColorBlend Class | Aspose.Imaging Namespace


Positions Property

Aspose.Imaging Documentation

ColorBlend.Positions Property

Gets or sets the positions along a gradient line.

public float[] Positions {get; set;}

See Also

ColorBlend Class | Aspose.Imaging Namespace


ColorBlend Methods

The methods of the ColorBlend class are listed below. For a complete list of ColorBlend class members, see the ColorBlend Members topic.

Public Instance Methods

Equals | Tests whether the specified object is a ColorBlend class and is equivalent to this ColorBlend class.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorBlend Class | Aspose.Imaging Namespace


ColorBlend.Equals Method

Tests whether the specified object is a ColorBlend class and is equivalent to this ColorBlend class.

public override bool Equals(
object obj
);

Parameters

obj
The object to test.

Return Value

True if obj is a ColorBlend class equivalent to this ColorBlend class; otherwise, false.

See Also

ColorBlend Class | Aspose.Imaging Namespace


ColorBlend.GetHashCode Method

Returns a hash code for this instance.

public override int GetHashCode();

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

ColorBlend Class | Aspose.Imaging Namespace


ColorBlend Operators

The operators of the ColorBlend class are listed below. For a complete list of ColorBlend class members, see the ColorBlend Members topic.

Public Static Operators

Equality Operator | Tests whether two specified ColorBlend classes are different.
Inequality Operator | Tests whether two specified ColorBlend classes are equivalent.

See Also

ColorBlend Class | ColorBlend Members | Aspose.Imaging Namespace


ColorBlend Equality Operator

Tests whether two specified ColorBlend classes are different.

public static bool operator ==(
ColorBlend colorBlend1,
ColorBlend colorBlend2
);

Parameters

colorBlend1
The ColorBlend that is to the left of the inequality operator.
colorBlend2
The ColorBlend that is to the right of the inequality operator.

Return Value

True if the two ColorBlend classes are different; otherwise, false.

See Also

ColorBlend Class | Aspose.Imaging Namespace


ColorBlend Inequality Operator

Tests whether two specified ColorBlend classes are equivalent.

public static bool operator !=(
ColorBlend colorBlend1,
ColorBlend colorBlend2
);

Parameters

colorBlend1
The ColorBlend that is to the left of the equality operator.
colorBlend2
The ColorBlend that is to the right of the equality operator.

Return Value

True if the two ColorBlend classes are equal; otherwise, false.

See Also

ColorBlend Class | Aspose.Imaging Namespace


ColorChannelFlag Enumeration

Specifies individual channels in the CMYK (cyan, magenta, yellow, black) color space. This enumeration is used by the SetOutputChannel methods.

public enum ColorChannelFlag

Members

Member Name | Description | Value
ColorChannelC | The cyan color channel. | 0
ColorChannelM | The magenta color channel. | 1
ColorChannelY | The yellow color channel. | 2
ColorChannelK | The black color channel. | 3
ColorChannelLast | The last selected channel should be used. | 4

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


ColorMap Class

Defines a map for converting colors. Several methods of the ImageAttributes class adjust image colors by using a color-remap table, which is an array of ColorMap structures. Not inheritable.

For a list of all members of this type, see ColorMap Members.

System.Object
Aspose.Imaging.ColorMap

public sealed class ColorMap

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ColorMap Members | Aspose.Imaging Namespace


ColorMap Members

ColorMap overview

Public Instance Constructors

ColorMap Constructor Initializes a new instance of the ColorMap class.

Public Instance Properties

NewColor | Gets or sets the new Color structure to which to convert.
OldColor | Gets or sets the existing Color structure to be converted.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorMap Class | Aspose.Imaging Namespace


ColorMap Constructor

Initializes a new instance of the ColorMap class.

public ColorMap();

See Also

ColorMap Class | Aspose.Imaging Namespace


ColorMap Properties

The properties of the ColorMap class are listed below. For a complete list of ColorMap class members, see the ColorMap Members topic.

Public Instance Properties

NewColor | Gets or sets the new Color structure to which to convert.
OldColor | Gets or sets the existing Color structure to be converted.

See Also

ColorMap Class | Aspose.Imaging Namespace


NewColor Property

Aspose.Imaging Documentation

ColorMap.NewColor Property

Gets or sets the new Color structure to which to convert.

public Color NewColor {get; set;}

Property Value

The new Color structure to which to convert.

See Also

ColorMap Class | Aspose.Imaging Namespace


OldColor Property

Aspose.Imaging Documentation

ColorMap.OldColor Property

Gets or sets the existing Color structure to be converted.

public Color OldColor {get; set;}

Property Value

The existing Color structure to be converted.

See Also

ColorMap Class | Aspose.Imaging Namespace


ColorMatrix Class

Defines a 5 x 5 matrix that contains the coordinates for the RGBA space. Several methods of the ImageAttributes class adjust image colors by using a color matrix. This class cannot be inherited.

For a list of all members of this type, see ColorMatrix Members.

System.Object
Aspose.Imaging.ColorMatrix

public sealed class ColorMatrix

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ColorMatrix Members | Aspose.Imaging Namespace


ColorMatrix Members

ColorMatrix overview

Public Static Fields

MatrixDimensionElementsCount | The number of elements in matrix dimension.
MatrixDimensionsCount | The number of matrix dimensions.
MatrixTotalElementsCount | The total number of elements in the matrix.

Public Instance Constructors

ColorMatrix Overloaded. Initializes a new instance of the ColorMatrix class.

Public Instance Properties

Item | Gets or sets the element at the specified row and column in the ColorMatrix.
Matrix00 | Gets or sets the element at the 0 (zero) row and 0 column of this ColorMatrix.
Matrix01 | Gets or sets the element at the 0 (zero) row and first column of this ColorMatrix.
Matrix02 | Gets or sets the element at the 0 (zero) row and second column of this ColorMatrix.
Matrix03 | Gets or sets the element at the 0 (zero) row and third column of this ColorMatrix.
Matrix04 | Gets or sets the element at the 0 (zero) row and fourth column of this ColorMatrix.
Matrix10 | Gets or sets the element at the first row and 0 (zero) column of this ColorMatrix.
Matrix11 | Gets or sets the element at the first row and first column of this ColorMatrix.
Matrix12 | Gets or sets the element at the first row and second column of this ColorMatrix.
Matrix13 | Gets or sets the element at the first row and third column of this ColorMatrix.
Matrix14 | Gets or sets the element at the first row and fourth column of this ColorMatrix.
Matrix20 | Gets or sets the element at the second row and 0 (zero) column of this ColorMatrix.
Matrix21 | Gets or sets the element at the second row and first column of this ColorMatrix.
Matrix22 | Gets or sets the element at the second row and second column of this ColorMatrix.
Matrix23 | Gets or sets the element at the second row and third column of this ColorMatrix.
Matrix24 | Gets or sets the element at the second row and fourth column of this ColorMatrix.
Matrix30 | Gets or sets the element at the third row and 0 (zero) column of this ColorMatrix.
Matrix31 | Gets or sets the element at the third row and first column of this ColorMatrix.
Matrix32 | Gets or sets the element at the third row and second column of this ColorMatrix.
Matrix33 | Gets or sets the element at the third row and third column of this ColorMatrix.
Matrix34 | Gets or sets the element at the third row and fourth column of this ColorMatrix.
Matrix40 | Gets or sets the element at the fourth row and 0 (zero) column of this ColorMatrix.
Matrix41 | Gets or sets the element at the fourth row and first column of this ColorMatrix.
Matrix42 | Gets or sets the element at the fourth row and second column of this ColorMatrix.
Matrix43 | Gets or sets the element at the fourth row and third column of this ColorMatrix.
Matrix44 | Gets or sets the element at the fourth row and fourth column of this ColorMatrix.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMatrix | Gets the matrix values.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


ColorMatrix Constructor

Initializes a new instance of the ColorMatrix class.

Overload List

Initializes a new instance of the ColorMatrix class.

public ColorMatrix();

Initializes a new instance of the ColorMatrix class using the elements in the specified matrix newColorMatrix.

public ColorMatrix(float[][]);

See Also

ColorMatrix Class | Aspose.Imaging Namespace


ColorMatrix Constructor ()

Initializes a new instance of the ColorMatrix class.

public ColorMatrix();

See Also

ColorMatrix Class | Aspose.Imaging Namespace | ColorMatrix Constructor Overload List


ColorMatrix Constructor (Single[][])

Initializes a new instance of the ColorMatrix class using the elements in the specified matrix newColorMatrix.

public ColorMatrix(
float[][] newColorMatrix
);

Parameters

newColorMatrix
The values of the elements for the new ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace | ColorMatrix Constructor Overload List


ColorMatrix Fields

The fields of the ColorMatrix class are listed below. For a complete list of ColorMatrix class members, see the ColorMatrix Members topic.

Public Static Fields

MatrixDimensionElementsCount | The number of elements in matrix dimension.
MatrixDimensionsCount | The number of matrix dimensions.
MatrixTotalElementsCount | The total number of elements in the matrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


ColorMatrix.MatrixDimensionElementsCount Field

The number of elements in matrix dimension.

public const int MatrixDimensionElementsCount = 5;

See Also

ColorMatrix Class | Aspose.Imaging Namespace


ColorMatrix.MatrixDimensionsCount Field

The number of matrix dimensions.

public const int MatrixDimensionsCount = 5;

See Also

ColorMatrix Class | Aspose.Imaging Namespace


ColorMatrix.MatrixTotalElementsCount Field

The total number of elements in the matrix.

public const int MatrixTotalElementsCount = 25;

See Also

ColorMatrix Class | Aspose.Imaging Namespace


ColorMatrix Properties

The properties of the ColorMatrix class are listed below. For a complete list of ColorMatrix class members, see the ColorMatrix Members topic.

Public Instance Properties

Item | Gets or sets the element at the specified row and column in the ColorMatrix.
Matrix00 | Gets or sets the element at the 0 (zero) row and 0 column of this ColorMatrix.
Matrix01 | Gets or sets the element at the 0 (zero) row and first column of this ColorMatrix.
Matrix02 | Gets or sets the element at the 0 (zero) row and second column of this ColorMatrix.
Matrix03 | Gets or sets the element at the 0 (zero) row and third column of this ColorMatrix.
Matrix04 | Gets or sets the element at the 0 (zero) row and fourth column of this ColorMatrix.
Matrix10 | Gets or sets the element at the first row and 0 (zero) column of this ColorMatrix.
Matrix11 | Gets or sets the element at the first row and first column of this ColorMatrix.
Matrix12 | Gets or sets the element at the first row and second column of this ColorMatrix.
Matrix13 | Gets or sets the element at the first row and third column of this ColorMatrix.
Matrix14 | Gets or sets the element at the first row and fourth column of this ColorMatrix.
Matrix20 | Gets or sets the element at the second row and 0 (zero) column of this ColorMatrix.
Matrix21 | Gets or sets the element at the second row and first column of this ColorMatrix.
Matrix22 | Gets or sets the element at the second row and second column of this ColorMatrix.
Matrix23 | Gets or sets the element at the second row and third column of this ColorMatrix.
Matrix24 | Gets or sets the element at the second row and fourth column of this ColorMatrix.
Matrix30 | Gets or sets the element at the third row and 0 (zero) column of this ColorMatrix.
Matrix31 | Gets or sets the element at the third row and first column of this ColorMatrix.
Matrix32 | Gets or sets the element at the third row and second column of this ColorMatrix.
Matrix33 | Gets or sets the element at the third row and third column of this ColorMatrix.
Matrix34 | Gets or sets the element at the third row and fourth column of this ColorMatrix.
Matrix40 | Gets or sets the element at the fourth row and 0 (zero) column of this ColorMatrix.
Matrix41 | Gets or sets the element at the fourth row and first column of this ColorMatrix.
Matrix42 | Gets or sets the element at the fourth row and second column of this ColorMatrix.
Matrix43 | Gets or sets the element at the fourth row and third column of this ColorMatrix.
Matrix44 | Gets or sets the element at the fourth row and fourth column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Item Property

Aspose.Imaging Documentation

ColorMatrix.Item Property

Gets or sets the element at the specified row and column in the ColorMatrix.

public float this[
int row,
int column
] {get; set;}

Parameters

row
The row number.
column
The column number.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix00 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix00 Property

Gets or sets the element at the 0 (zero) row and 0 column of this ColorMatrix.

public float Matrix00 {get; set;}

Property Value

The element at the 0 row and 0 column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix01 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix01 Property

Gets or sets the element at the 0 (zero) row and first column of this ColorMatrix.

public float Matrix01 {get; set;}

Property Value

The element at the 0 row and first column of this ColorMatrix .

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix02 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix02 Property

Gets or sets the element at the 0 (zero) row and second column of this ColorMatrix.

public float Matrix02 {get; set;}

Property Value

The element at the 0 row and second column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix03 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix03 Property

Gets or sets the element at the 0 (zero) row and third column of this ColorMatrix.

public float Matrix03 {get; set;}

Property Value

The element at the 0 row and third column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix04 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix04 Property

Gets or sets the element at the 0 (zero) row and fourth column of this ColorMatrix.

public float Matrix04 {get; set;}

Property Value

The element at the 0 row and fourth column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix10 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix10 Property

Gets or sets the element at the first row and 0 (zero) column of this ColorMatrix.

public float Matrix10 {get; set;}

Property Value

The element at the first row and 0 column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix11 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix11 Property

Gets or sets the element at the first row and first column of this ColorMatrix.

public float Matrix11 {get; set;}

Property Value

The element at the first row and first column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix12 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix12 Property

Gets or sets the element at the first row and second column of this ColorMatrix.

public float Matrix12 {get; set;}

Property Value

The element at the first row and second column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix13 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix13 Property

Gets or sets the element at the first row and third column of this ColorMatrix.

public float Matrix13 {get; set;}

Property Value

The element at the first row and third column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix14 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix14 Property

Gets or sets the element at the first row and fourth column of this ColorMatrix.

public float Matrix14 {get; set;}

Property Value

The element at the first row and fourth column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix20 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix20 Property

Gets or sets the element at the second row and 0 (zero) column of this ColorMatrix.

public float Matrix20 {get; set;}

Property Value

The element at the second row and 0 column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix21 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix21 Property

Gets or sets the element at the second row and first column of this ColorMatrix.

public float Matrix21 {get; set;}

Property Value

The element at the second row and first column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix22 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix22 Property

Gets or sets the element at the second row and second column of this ColorMatrix.

public float Matrix22 {get; set;}

Property Value

The element at the second row and second column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix23 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix23 Property

Gets or sets the element at the second row and third column of this ColorMatrix.

public float Matrix23 {get; set;}

Property Value

The element at the second row and third column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix24 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix24 Property

Gets or sets the element at the second row and fourth column of this ColorMatrix.

public float Matrix24 {get; set;}

Property Value

The element at the second row and fourth column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix30 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix30 Property

Gets or sets the element at the third row and 0 (zero) column of this ColorMatrix.

public float Matrix30 {get; set;}

Property Value

The element at the third row and 0 column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix31 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix31 Property

Gets or sets the element at the third row and first column of this ColorMatrix.

public float Matrix31 {get; set;}

Property Value

The element at the third row and first column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix32 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix32 Property

Gets or sets the element at the third row and second column of this ColorMatrix.

public float Matrix32 {get; set;}

Property Value

The element at the third row and second column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix33 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix33 Property

Gets or sets the element at the third row and third column of this ColorMatrix.

public float Matrix33 {get; set;}

Property Value

The element at the third row and third column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix34 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix34 Property

Gets or sets the element at the third row and fourth column of this ColorMatrix.

public float Matrix34 {get; set;}

Property Value

The element at the third row and fourth column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix40 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix40 Property

Gets or sets the element at the fourth row and 0 (zero) column of this ColorMatrix.

public float Matrix40 {get; set;}

Property Value

The element at the fourth row and 0 column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix41 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix41 Property

Gets or sets the element at the fourth row and first column of this ColorMatrix.

public float Matrix41 {get; set;}

Property Value

The element at the fourth row and first column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix42 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix42 Property

Gets or sets the element at the fourth row and second column of this ColorMatrix.

public float Matrix42 {get; set;}

Property Value

The element at the fourth row and second column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix43 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix43 Property

Gets or sets the element at the fourth row and third column of this ColorMatrix.

public float Matrix43 {get; set;}

Property Value

The element at the fourth row and third column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


Matrix44 Property

Aspose.Imaging Documentation

ColorMatrix.Matrix44 Property

Gets or sets the element at the fourth row and fourth column of this ColorMatrix.

public float Matrix44 {get; set;}

Property Value

The element at the fourth row and fourth column of this ColorMatrix.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


ColorMatrix Methods

The methods of the ColorMatrix class are listed below. For a complete list of ColorMatrix class members, see the ColorMatrix Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMatrix | Gets the matrix values.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


ColorMatrix.GetMatrix Method

Gets the matrix values.

public float[][] GetMatrix();

Return Value

The matrix values array.

See Also

ColorMatrix Class | Aspose.Imaging Namespace


ColorMatrixFlag Enumeration

Specifies the types of images and colors that will be affected by the color and grayscale adjustment settings of an ImageAttributes.

public enum ColorMatrixFlag

Members

Member Name | Description | Value
Default | All color values, including gray shades, are adjusted by the same color-adjustment matrix. | 0
SkipGrays | All colors are adjusted, but gray shades are not adjusted. A gray shade is any color that has the same value for its red, green, and blue components. | 1
AltGrays | Only gray shades are adjusted. | 2

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


ColorPalette Class

Defines an array of colors that make up a color palette. The colors are 32-bit ARGB colors. Not inheritable.

For a list of all members of this type, see ColorPalette Members.

System.Object
Aspose.Imaging.ColorPalette

public sealed class ColorPalette : IColorPalette

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ColorPalette Members | Aspose.Imaging Namespace


ColorPalette Members

ColorPalette overview

Public Static Methods

CopyPalette Overloaded. Copies the palette.

Public Instance Constructors

ColorPalette Overloaded. Initializes a new instance of the ColorPalette class.

Public Instance Properties

Entries | Gets an array of Color structures.
EntriesCount | Gets the entries count.
IsCompactPalette | Gets or sets a value indicating whether compact palette is used.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColor | Gets the palette color by index.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNearestColorIndex | Gets the index of the nearest color.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorPalette Class | Aspose.Imaging Namespace


ColorPalette Constructor

Initializes a new instance of the ColorPalette class.

Overload List

Initializes a new instance of the ColorPalette and IsCompactPalette is false.

public ColorPalette(Color[]);

Initializes a new instance of the ColorPalette class.

public ColorPalette(Color[],bool);

See Also

ColorPalette Class | Aspose.Imaging Namespace


ColorPalette Constructor (Color[], Boolean)

Initializes a new instance of the ColorPalette class.

public ColorPalette(
Color[] entries,
bool isCompactPalette
);

Parameters

entries
The color palette entries.
isCompactPalette
Indicating whether compact it palette.

See Also

ColorPalette Class | Aspose.Imaging Namespace | ColorPalette Constructor Overload List


ColorPalette Constructor (Color[])

Initializes a new instance of the ColorPalette and IsCompactPalette is false.

public ColorPalette(
Color[] entries
);

Parameters

entries
The color palette entries.

See Also

ColorPalette Class | Aspose.Imaging Namespace | ColorPalette Constructor Overload List


ColorPalette Properties

The properties of the ColorPalette class are listed below. For a complete list of ColorPalette class members, see the ColorPalette Members topic.

Public Instance Properties

Entries | Gets an array of Color structures.
EntriesCount | Gets the entries count.
IsCompactPalette | Gets or sets a value indicating whether compact palette is used.

See Also

ColorPalette Class | Aspose.Imaging Namespace


Entries Property

Aspose.Imaging Documentation

ColorPalette.Entries Property

Gets an array of Color structures.

public Color[] Entries {get;}

Property Value

The entries.

Implements

IColorPalette.Entries

See Also

ColorPalette Class | Aspose.Imaging Namespace


EntriesCount Property

Aspose.Imaging Documentation

ColorPalette.EntriesCount Property

Gets the entries count.

public int EntriesCount {get;}

Property Value

The entries count.

Implements

IColorPalette.EntriesCount

See Also

ColorPalette Class | Aspose.Imaging Namespace


IsCompactPalette Property

Aspose.Imaging Documentation

ColorPalette.IsCompactPalette Property

Gets or sets a value indicating whether compact palette is used.

public bool IsCompactPalette {get;}

Property Value

true if compact palette is used; otherwise, false.

Implements

IColorPalette.IsCompactPalette

Remarks

Compact palette means that image will contain only the specified palette entries if possible or in other words the image will be more compact and occupy less space; otherwise there will be 2^BitsPerPixel entries and image will reserve more space for all possible palette entries. Setting this value to true and changing palette entries may cause performance penalty since data movement may occur so use it carefully.

See Also

ColorPalette Class | Aspose.Imaging Namespace


ColorPalette Methods

The methods of the ColorPalette class are listed below. For a complete list of ColorPalette class members, see the ColorPalette Members topic.

Public Static Methods

CopyPalette Overloaded. Copies the palette.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColor | Gets the palette color by index.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNearestColorIndex | Gets the index of the nearest color.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorPalette Class | Aspose.Imaging Namespace


CopyPalette Method

Aspose.Imaging Documentation

ColorPalette.CopyPalette Method

Copies the palette.

Overload List

Copies the palette.

public static ColorPalette CopyPalette(IColorPalette);

Copies the palette.

public static ColorPalette CopyPalette(IColorPalette,bool);

See Also

ColorPalette Class | Aspose.Imaging Namespace


ColorPalette.CopyPalette Method (IColorPalette)

Copies the palette.

public static ColorPalette CopyPalette(
IColorPalette colorPalette
);

Parameters

colorPalette
The color palette.

Return Value

The newly created and copied palette or null if null palette passed.

See Also

ColorPalette Class | Aspose.Imaging Namespace | ColorPalette.CopyPalette Overload List


ColorPalette.CopyPalette Method (IColorPalette, Boolean)

Copies the palette.

public static ColorPalette CopyPalette(
IColorPalette colorPalette,
bool useCompactPalette
);

Parameters

colorPalette
The color palette.
useCompactPalette
Indicating whether compact palette.

Return Value

The newly created and copied palette or null if null palette passed.

See Also

ColorPalette Class | Aspose.Imaging Namespace | ColorPalette.CopyPalette Overload List


ColorPalette.GetColor Method

Gets the palette color by index.

public Color GetColor(
int index
);

Parameters

index
The palette color index.

Return Value

The color palette entry specified by the index.

Implements

IColorPalette.GetColor

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | if color palette index specified is out of the palette entries range.

See Also

ColorPalette Class | Aspose.Imaging Namespace


ColorPalette.GetNearestColorIndex Method

Gets the index of the nearest color.

public int GetNearestColorIndex(
Color color
);

Parameters

color
The color.

Return Value

The index of the nearest color.

Implements

IColorPalette.GetNearestColorIndex

See Also

ColorPalette Class | Aspose.Imaging Namespace


ColorTranslator Class

Translates colors to and from GDI+ Color structures. This class cannot be inherited.

For a list of all members of this type, see ColorTranslator Members.

System.Object
Aspose.Imaging.ColorTranslator

public sealed class ColorTranslator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ColorTranslator Members | Aspose.Imaging Namespace


ColorTranslator Members

ColorTranslator overview

Public Static Methods

FromHtml | Takes color from the HTML color.
FromOle | Takes color from the OLE color.
FromWin32 | Takes color from the HTML color.
ToHtml | Creates HTML color from the color.
ToOle | Translates OLE color to color.
ToWin32 | Translates the color to win32 color.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorTranslator Class | Aspose.Imaging Namespace


ColorTranslator Methods

The methods of the ColorTranslator class are listed below. For a complete list of ColorTranslator class members, see the ColorTranslator Members topic.

Public Static Methods

FromHtml | Takes color from the HTML color.
FromOle | Takes color from the OLE color.
FromWin32 | Takes color from the HTML color.
ToHtml | Creates HTML color from the color.
ToOle | Translates OLE color to color.
ToWin32 | Translates the color to win32 color.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorTranslator Class | Aspose.Imaging Namespace


ColorTranslator.FromHtml Method

Takes color from the HTML color.

public static Color FromHtml(
string htmlColor
);

Parameters

htmlColor
HTML color.

Return Value

The color.

See Also

ColorTranslator Class | Aspose.Imaging Namespace


ColorTranslator.FromOle Method

Takes color from the OLE color.

public static Color FromOle(
int oleColor
);

Parameters

oleColor
OLE color.

Return Value

The color.

See Also

ColorTranslator Class | Aspose.Imaging Namespace


ColorTranslator.FromWin32 Method

Takes color from the HTML color.

public static Color FromWin32(
int win32Color
);

Parameters

win32Color
Win32 color.

Return Value

The color.

See Also

ColorTranslator Class | Aspose.Imaging Namespace


ColorTranslator.ToHtml Method

Creates HTML color from the color.

public static string ToHtml(
Color c
);

Parameters

c
The color class.

Return Value

The html string color.

See Also

ColorTranslator Class | Aspose.Imaging Namespace


ColorTranslator.ToOle Method

Translates OLE color to color.

public static int ToOle(
Color c
);

Parameters

c
The color.

Return Value

The OLE color.

See Also

ColorTranslator Class | Aspose.Imaging Namespace


ColorTranslator.ToWin32 Method

Translates the color to win32 color.

public static int ToWin32(
Color c
);

Parameters

c
The color.

Return Value

The win32 color.

See Also

ColorTranslator Class | Aspose.Imaging Namespace


CompositingQuality Enumeration

Specifies the quality level to use during compositing.

public enum CompositingQuality

Members

Member Name | Description | Value
Invalid | Invalid quality. | -1
Default | Default quality. | 0
HighSpeed | High speed, low quality. | 1
HighQuality | High quality, low speed compositing. | 2
GammaCorrected | Gamma correction is used. | 3
AssumeLinear | Assume linear values. | 4

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


CustomLineCap Class

Encapsulates a custom user-defined line cap.

For a list of all members of this type, see CustomLineCap Members.

System.Object
Aspose.Imaging.CustomLineCap

public class CustomLineCap

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CustomLineCap Members | Aspose.Imaging Namespace


CustomLineCap Members

CustomLineCap overview

Public Instance Constructors

CustomLineCap Overloaded. Initializes a new instance of the CustomLineCap class.

Public Instance Properties

BaseCap | Gets or sets the LineCap enumeration on which this CustomLineCap is based.
BaseInset | Gets or sets the distance between the cap and the line.
StrokeJoin | Gets or sets the LineJoin enumeration that determines how lines that compose this CustomLineCap object are joined.
WidthScale | Gets or sets the amount by which to scale this CustomLineCap Class object with respect to the width of the Pen object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetStrokeCaps |
GetType (inherited from Object) | Gets the Type of the current instance.
SetStrokeCaps | Sets the caps used to start and end lines that make up this custom cap.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CustomLineCap Class | Aspose.Imaging Namespace


CustomLineCap Constructor

Initializes a new instance of the CustomLineCap class with the specified outline and fill.

Overload List

Initializes a new instance of the CustomLineCap class with the specified outline and fill.

public CustomLineCap(GraphicsPath,GraphicsPath);

Initializes a new instance of the CustomLineCap class from the specified existing LineCap enumeration with the specified outline and fill.

public CustomLineCap(GraphicsPath,GraphicsPath,LineCap);

Initializes a new instance of the CustomLineCap class from the specified existing LineCap enumeration with the specified outline, fill, and inset.

public CustomLineCap(GraphicsPath,GraphicsPath,LineCap,float);

See Also

CustomLineCap Class | Aspose.Imaging Namespace


CustomLineCap Constructor (GraphicsPath, GraphicsPath)

Initializes a new instance of the CustomLineCap class with the specified outline and fill.

public CustomLineCap(
GraphicsPath fillPath,
GraphicsPath strokePath
);

Parameters

fillPath
A GraphicsPath object that defines the fill for the custom cap.
strokePath
A GraphicsPath object that defines the outline of the custom cap.

See Also

CustomLineCap Class | Aspose.Imaging Namespace | CustomLineCap Constructor Overload List


CustomLineCap Constructor (GraphicsPath, GraphicsPath, LineCap)

Initializes a new instance of the CustomLineCap class from the specified existing LineCap enumeration with the specified outline and fill.

public CustomLineCap(
GraphicsPath fillPath,
GraphicsPath strokePath,
LineCap baseCap
);

Parameters

fillPath
A GraphicsPath object that defines the fill for the custom cap.
strokePath
A GraphicsPath object that defines the outline of the custom cap.
baseCap
The line cap from which to create the custom cap.

See Also

CustomLineCap Class | Aspose.Imaging Namespace | CustomLineCap Constructor Overload List


CustomLineCap Constructor (GraphicsPath, GraphicsPath, LineCap, Single)

Initializes a new instance of the CustomLineCap class from the specified existing LineCap enumeration with the specified outline, fill, and inset.

public CustomLineCap(
GraphicsPath fillPath,
GraphicsPath strokePath,
LineCap baseCap,
float baseInset
);

Parameters

fillPath
A GraphicsPath object that defines the fill for the custom cap.
strokePath
A GraphicsPath object that defines the outline of the custom cap.
baseCap
The line cap from which to create the custom cap.
baseInset
The distance between the cap and the line.

See Also

CustomLineCap Class | Aspose.Imaging Namespace | CustomLineCap Constructor Overload List


CustomLineCap Properties

The properties of the CustomLineCap class are listed below. For a complete list of CustomLineCap class members, see the CustomLineCap Members topic.

Public Instance Properties

BaseCap | Gets or sets the LineCap enumeration on which this CustomLineCap is based.
BaseInset | Gets or sets the distance between the cap and the line.
StrokeJoin | Gets or sets the LineJoin enumeration that determines how lines that compose this CustomLineCap object are joined.
WidthScale | Gets or sets the amount by which to scale this CustomLineCap Class object with respect to the width of the Pen object.

See Also

CustomLineCap Class | Aspose.Imaging Namespace


BaseCap Property

Aspose.Imaging Documentation

CustomLineCap.BaseCap Property

Gets or sets the LineCap enumeration on which this CustomLineCap is based.

public LineCap BaseCap {get; set;}

Property Value

The LineCap enumeration on which this CustomLineCap is based.

See Also

CustomLineCap Class | Aspose.Imaging Namespace


BaseInset Property

Aspose.Imaging Documentation

CustomLineCap.BaseInset Property

Gets or sets the distance between the cap and the line.

public float BaseInset {get; set;}

Property Value

The distance between the beginning of the cap and the end of the line.

See Also

CustomLineCap Class | Aspose.Imaging Namespace


StrokeJoin Property

Aspose.Imaging Documentation

CustomLineCap.StrokeJoin Property

Gets or sets the LineJoin enumeration that determines how lines that compose this CustomLineCap object are joined.

public LineJoin StrokeJoin {get; set;}

Property Value

The LineJoin enumeration this CustomLineCap object uses to join lines.

See Also

CustomLineCap Class | Aspose.Imaging Namespace


WidthScale Property

Aspose.Imaging Documentation

CustomLineCap.WidthScale Property

Gets or sets the amount by which to scale this CustomLineCap Class object with respect to the width of the Pen object.

public float WidthScale {get; set;}

Property Value

The amount by which to scale the cap.

See Also

CustomLineCap Class | Aspose.Imaging Namespace


CustomLineCap Methods

The methods of the CustomLineCap class are listed below. For a complete list of CustomLineCap class members, see the CustomLineCap Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetStrokeCaps |
GetType (inherited from Object) | Gets the Type of the current instance.
SetStrokeCaps | Sets the caps used to start and end lines that make up this custom cap.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CustomLineCap Class | Aspose.Imaging Namespace


CustomLineCap.GetStrokeCaps Method

public void GetStrokeCaps(
out LineCap startCap,
out LineCap endCap
);

See Also

CustomLineCap Class | Aspose.Imaging Namespace


CustomLineCap.SetStrokeCaps Method

Sets the caps used to start and end lines that make up this custom cap.

public void SetStrokeCaps(
LineCap startCap,
LineCap endCap
);

Parameters

startCap
The LineCap enumeration used at the beginning of a line within this cap.
endCap
The LineCap enumeration used at the end of a line within this cap.

See Also

CustomLineCap Class | Aspose.Imaging Namespace


DashCap Enumeration

Specifies the type of graphic shape to use on both ends of each dash in a dashed line.

public enum DashCap

Members

Member Name | Description | Value
Flat | Specifies a square cap that squares off both ends of each dash. | 0
Round | Specifies a circular cap that rounds off both ends of each dash. | 2
Triangle | Specifies a triangular cap that points both ends of each dash. | 3

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


DashStyle Enumeration

Specifies the style of dashed lines drawn with a Pen object.

public enum DashStyle

Members

Member Name | Description | Value
Solid | Specifies a solid line. | 0
Dash | Specifies a line consisting of dashes. | 1
Dot | Specifies a line consisting of dots. | 2
DashDot | Specifies a line consisting of a repeating pattern of dash-dot. | 3
DashDotDot | Specifies a line consisting of a repeating pattern of dash-dot-dot. | 4
Custom | Specifies a user-defined custom dash style. | 5

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


DataRecoveryMode Enumeration

The data recovery mode.

public enum DataRecoveryMode

Members

Member Name | Description | Value
None | No data recovery is implied. Whenever the file format has some corrupted data the appropriate exception is thrown. | 0
ConsistentRecover | The consistent recovery mode tries to recover all data as long as corruption does not break the file format and allows correct further processing. | 1
MaximalRecover | The maximal recovery mode recovers all data even if the file format has corrupted structure and further processing may yield unattended effects. | 2

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


DataStreamSupporter Class

The data stream container.

For a list of all members of this type, see DataStreamSupporter Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image

public abstract class DataStreamSupporter : DisposableObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

DataStreamSupporter Members | Aspose.Imaging Namespace


DataStreamSupporter Members

DataStreamSupporter overview

Public Instance Properties

DataStreamContainer | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
IsCached | Gets a value indicating whether object's data is cached currently and no data readig is required.

Public Instance Methods

CacheData | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves the object's data to the current DataStreamSupporter.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

DataStreamSupporter Constructor Initializes a new instance of the DataStreamSupporter class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataStreamContainerChanging | Called when data stream container is changing.
ReleaseManagedResources | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
SaveData | Saves the data.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace


DataStreamSupporter Constructor

Initializes a new instance of the DataStreamSupporter class.

protected DataStreamSupporter();

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace


DataStreamSupporter Properties

The properties of the DataStreamSupporter class are listed below. For a complete list of DataStreamSupporter class members, see the DataStreamSupporter Members topic.

Public Instance Properties

DataStreamContainer | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
IsCached | Gets a value indicating whether object's data is cached currently and no data readig is required.

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace


DataStreamContainer Property

Aspose.Imaging Documentation

DataStreamSupporter.DataStreamContainer Property

Gets the object's data stream.

public StreamContainer DataStreamContainer {get; set;}

Property Value

The object's data stream.

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace


IsCached Property

Aspose.Imaging Documentation

DataStreamSupporter.IsCached Property

Gets a value indicating whether object's data is cached currently and no data readig is required.

public abstract bool IsCached {get;}

Property Value

true if object's data is cached; otherwise, false.

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace


DataStreamSupporter Methods

The methods of the DataStreamSupporter class are listed below. For a complete list of DataStreamSupporter class members, see the DataStreamSupporter Members topic.

Public Instance Methods

CacheData | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves the object's data to the current DataStreamSupporter.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataStreamContainerChanging | Called when data stream container is changing.
ReleaseManagedResources | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
SaveData | Saves the data.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace


DataStreamSupporter.CacheData Method

Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.

public abstract void CacheData();

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace


DataStreamSupporter.OnDataStreamContainerChanging Method

Called when data stream container is changing.

protected virtual void OnDataStreamContainerChanging(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container.

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace


DataStreamSupporter.ReleaseManagedResources Method

Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.

protected override void ReleaseManagedResources();

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace


Save Method

Aspose.Imaging Documentation

DataStreamSupporter.Save Method

Saves the object's data to the current DataStreamSupporter.

Overload List

Saves the object's data to the current DataStreamSupporter.

public virtual void Save();

Saves the object's data to the specified stream.

public void Save(Stream);

Saves the object's data to the specified file location.

public void Save(string);

Saves the object's data to the specified file location.

public virtual void Save(string,bool);

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace


DataStreamSupporter.Save Method ()

Saves the object's data to the current DataStreamSupporter.

public virtual void Save();

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace | DataStreamSupporter.Save Overload List


DataStreamSupporter.Save Method (Stream)

Saves the object's data to the specified stream.

public void Save(
Stream stream
);

Parameters

stream
The stream to save the object's data to.

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace | DataStreamSupporter.Save Overload List


DataStreamSupporter.Save Method (String)

Saves the object's data to the specified file location.

public void Save(
string filePath
);

Parameters

filePath
The file path to save the object's data to.

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace | DataStreamSupporter.Save Overload List


DataStreamSupporter.Save Method (String, Boolean)

Saves the object's data to the specified file location.

public virtual void Save(
string filePath,
bool overWrite
);

Parameters

filePath
The file path to save the object's data to.
overWrite
if set to true over write the file contents, otherwise append will occur.

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace | DataStreamSupporter.Save Overload List


DataStreamSupporter.SaveData Method

Saves the data.

protected abstract void SaveData(
Stream stream
);

Parameters

stream
The stream to save data to.

See Also

DataStreamSupporter Class | Aspose.Imaging Namespace


DisposableObject Class

Represents disposable object.

For a list of all members of this type, see DisposableObject Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.Brush
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.StreamContainer
Aspose.Imaging.StringFormat

public class DisposableObject : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

DisposableObject Members | Aspose.Imaging Namespace


DisposableObject Members

DisposableObject overview

Public Instance Constructors

DisposableObject Constructor Initializes a new instance of the DisposableObject class.

Public Instance Properties

Disposed Gets a value indicating whether this instance is disposed.

Public Instance Methods

Dispose | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReleaseManagedResources | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
VerifyNotDisposed | Verifies that the current instance is not disposed.

See Also

DisposableObject Class | Aspose.Imaging Namespace


DisposableObject Constructor

Initializes a new instance of the DisposableObject class.

public DisposableObject();

See Also

DisposableObject Class | Aspose.Imaging Namespace


DisposableObject Properties

The properties of the DisposableObject class are listed below. For a complete list of DisposableObject class members, see the DisposableObject Members topic.

Public Instance Properties

Disposed Gets a value indicating whether this instance is disposed.

See Also

DisposableObject Class | Aspose.Imaging Namespace


Disposed Property

Aspose.Imaging Documentation

DisposableObject.Disposed Property

Gets a value indicating whether this instance is disposed.

public bool Disposed {get;}

Property Value

true if disposed; otherwise, false.

See Also

DisposableObject Class | Aspose.Imaging Namespace


DisposableObject Methods

The methods of the DisposableObject class are listed below. For a complete list of DisposableObject class members, see the DisposableObject Members topic.

Public Instance Methods

Dispose | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReleaseManagedResources | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
VerifyNotDisposed | Verifies that the current instance is not disposed.

See Also

DisposableObject Class | Aspose.Imaging Namespace


DisposableObject.Dispose Method

Disposes the current instance.

public void Dispose();

Implements

IDisposable.Dispose

See Also

DisposableObject Class | Aspose.Imaging Namespace


DisposableObject.ReleaseManagedResources Method

Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.

protected virtual void ReleaseManagedResources();

See Also

DisposableObject Class | Aspose.Imaging Namespace


DisposableObject.ReleaseUnmanagedResources Method

Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.

protected virtual void ReleaseUnmanagedResources();

See Also

DisposableObject Class | Aspose.Imaging Namespace


DisposableObject.VerifyNotDisposed Method

Verifies that the current instance is not disposed.

protected void VerifyNotDisposed();

See Also

DisposableObject Class | Aspose.Imaging Namespace


DitheringMethods Enumeration

The dithering methods used to control color conversion.

public enum DitheringMethods

Members

Member Name | Description | Value
PaletteIgnore | The palette is ignored | 0
PaletteConversion | The palette is not ignored and wise color conversion should be applied. | 1
CustomConverter | The custom converter. | 2

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


Figure Class

The figure. A container for shapes.

For a list of all members of this type, see Figure Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Figure

public class Figure : ObjectWithBounds

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This examples make use of GraphicsPath and Graphics class to create and manipulate Figures on an Image surface. Example creates a new Image (of type Tiff) and draw paths with the help of GraphicsPath class. At the end DrawPath method exposed by Graphics class is called to render the paths on surface.

[C#]

//Create an instance of FileStream
using (System.IO.FileStream stream = new System.IO.FileStream(@"C:\temp\output.tiff", System.IO.FileMode.Create))
{
    //Create an instance of TiffOptions and set its various properties
    Aspose.Imaging.ImageOptions.TiffOptions tiffOptions = new Aspose.Imaging.ImageOptions.TiffOptions();

    //Set the source for the instance of ImageOptions
    tiffOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(tiffOptions, 500, 500))
    {
        //Create and initialize an instance of Graphics class
        Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

        //Clear Graphics surface
        graphics.Clear(Color.Wheat);

        //Create an instance of GraphicsPath class
        Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

        //Create an instance of Figure class
        Aspose.Imaging.Figure figure = new Aspose.Imaging.Figure();

        //Add Shapes to Figure object
        figure.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new RectangleF(10, 10, 300, 300)));
        figure.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
        figure.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(250, 250), new Size(200, 200)), 0, 45));

        //Add Figure object to GraphicsPath
        graphicspath.AddFigure(figure);

        //Draw path with Pen object of color Black
        graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

        // save all changes.
        image.Save();
    }
}
[Visual Basic]

'Create an instance of FileStream
Using stream As System.IO.FileStream = New System.IO.FileStream("C:\temp\output.tiff", System.IO.FileMode.Create)
'Create an instance of TiffOptions and set its various properties
Dim tiffOptions As Aspose.Imaging.ImageOptions.TiffOptions = New Aspose.Imaging.ImageOptions.TiffOptions()

'Set the source for the instance of ImageOptions
    tiffOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(tiffOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
        graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shapes to Figure object
        figure.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New RectangleF(10, 10, 300, 300)))
        figure.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
        figure.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(250, 250), New Size(200, 200)), 0, 45))

'Add Figure object to GraphicsPath
        graphicspath.AddFigure(figure)

'Draw path with Pen object of color Black
        graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
        image.Save()
    End Using
End Using

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Figure Members | Aspose.Imaging Namespace


Figure Members

Figure overview

Public Instance Constructors

Figure Constructor Initializes a new instance of the Figure class.

Public Instance Properties

Bounds | Gets or sets the object's bounds.
IsClosed | Gets or sets a value indicating whether this figure is closed. A closed figure will make a difference only in case where the first and the last figure's shapes are continuous shapes. In such case the first point of the first shape will be connected by a straight line from the last point of the last shape.
Segments | Gets the whole figure segments.
Shapes | Gets the figure shapes.

Public Instance Methods

AddShape | Adds a shape to the figure.
AddShapes | Adds a range of shapes to the figure.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveShape | Removes a shape from the figure.
RemoveShapes | Removes a range of shapes from the figure.
Reverse | Reverses this figure shapes order and shapes point order.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Applies the specified transformation to the shape.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Figure Class | Aspose.Imaging Namespace


Figure Constructor

Initializes a new instance of the Figure class.

public Figure();

See Also

Figure Class | Aspose.Imaging Namespace


Figure Properties

The properties of the Figure class are listed below. For a complete list of Figure class members, see the Figure Members topic.

Public Instance Properties

Bounds | Gets or sets the object's bounds.
IsClosed | Gets or sets a value indicating whether this figure is closed. A closed figure will make a difference only in case where the first and the last figure's shapes are continuous shapes. In such case the first point of the first shape will be connected by a straight line from the last point of the last shape.
Segments | Gets the whole figure segments.
Shapes | Gets the figure shapes.

See Also

Figure Class | Aspose.Imaging Namespace


Bounds Property

Aspose.Imaging Documentation

Figure.Bounds Property

Gets or sets the object's bounds.

public override RectangleF Bounds {get;}

Property Value

The object's bounds.

See Also

Figure Class | Aspose.Imaging Namespace


IsClosed Property

Aspose.Imaging Documentation

Figure.IsClosed Property

Gets or sets a value indicating whether this figure is closed. A closed figure will make a difference only in case where the first and the last figure's shapes are continuous shapes. In such case the first point of the first shape will be connected by a straight line from the last point of the last shape.

public bool IsClosed {get; set;}

Property Value

True if this figure is closed; otherwise, false.

See Also

Figure Class | Aspose.Imaging Namespace


Segments Property

Aspose.Imaging Documentation

Figure.Segments Property

Gets the whole figure segments.

public ShapeSegment[] Segments {get;}

Property Value

The figure segments.

See Also

Figure Class | Aspose.Imaging Namespace


Shapes Property

Aspose.Imaging Documentation

Figure.Shapes Property

Gets the figure shapes.

public Shape[] Shapes {get;}

Property Value

The figure shapes.

See Also

Figure Class | Aspose.Imaging Namespace


Figure Methods

The methods of the Figure class are listed below. For a complete list of Figure class members, see the Figure Members topic.

Public Instance Methods

AddShape | Adds a shape to the figure.
AddShapes | Adds a range of shapes to the figure.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveShape | Removes a shape from the figure.
RemoveShapes | Removes a range of shapes from the figure.
Reverse | Reverses this figure shapes order and shapes point order.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Applies the specified transformation to the shape.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Figure Class | Aspose.Imaging Namespace


Figure.AddShape Method

Adds a shape to the figure.

public void AddShape(
Shape shape
);

Parameters

shape
The shape to add.

Example

This examples make use of GraphicsPath and Graphics class to create and manipulate Figures on an Image surface. Example creates a new Image (of type Tiff) and draw paths with the help of GraphicsPath class. At the end DrawPath method exposed by Graphics class is called to render the paths on surface.

[C#]

//Create an instance of FileStream
using (System.IO.FileStream stream = new System.IO.FileStream(@"C:\temp\output.tiff", System.IO.FileMode.Create))
{
    //Create an instance of TiffOptions and set its various properties
    Aspose.Imaging.ImageOptions.TiffOptions tiffOptions = new Aspose.Imaging.ImageOptions.TiffOptions();

    //Set the source for the instance of ImageOptions
    tiffOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(tiffOptions, 500, 500))
    {
        //Create and initialize an instance of Graphics class
        Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

        //Clear Graphics surface
        graphics.Clear(Color.Wheat);

        //Create an instance of GraphicsPath class
        Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

        //Create an instance of Figure class
        Aspose.Imaging.Figure figure = new Aspose.Imaging.Figure();

        //Add Shapes to Figure object
        figure.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new RectangleF(10, 10, 300, 300)));
        figure.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
        figure.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(250, 250), new Size(200, 200)), 0, 45));

        //Add Figure object to GraphicsPath
        graphicspath.AddFigure(figure);

        //Draw path with Pen object of color Black
        graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

        // save all changes.
        image.Save();
    }
}
[Visual Basic]

'Create an instance of FileStream
Using stream As System.IO.FileStream = New System.IO.FileStream("C:\temp\output.tiff", System.IO.FileMode.Create)
'Create an instance of TiffOptions and set its various properties
Dim tiffOptions As Aspose.Imaging.ImageOptions.TiffOptions = New Aspose.Imaging.ImageOptions.TiffOptions()

'Set the source for the instance of ImageOptions
    tiffOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(tiffOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
        graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shapes to Figure object
        figure.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New RectangleF(10, 10, 300, 300)))
        figure.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
        figure.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(250, 250), New Size(200, 200)), 0, 45))

'Add Figure object to GraphicsPath
        graphicspath.AddFigure(figure)

'Draw path with Pen object of color Black
        graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
        image.Save()
    End Using
End Using

See Also

Figure Class | Aspose.Imaging Namespace


Figure.AddShapes Method

Adds a range of shapes to the figure.

public void AddShapes(
Shape[] shapes
);

Parameters

shapes
The shapes to add.

Example

This example creates a new Image and draws a variety of shapes using Figures and GraphicsPath on the Image surface

[C#]

//Creates an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"c:\temp\output.bmp", false);

//Create an instance of Image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Create and initialize an instance of Graphics class
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clear Graphics surface
    graphics.Clear(Color.Wheat);

    //Create an instance of GraphicsPath class
    Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure1 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure1.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
    figure1.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(110, 110), new Size(200, 200)), 0, 90));

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure2 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure2.AddShape(new Aspose.Imaging.Shapes.ArcShape(new RectangleF(10, 10, 300, 300), 0, 45));
    figure2.AddShape(new Aspose.Imaging.Shapes.PolygonShape(new[] { new PointF(150, 10), new PointF(150, 200), new PointF(250, 300), new PointF(350, 400) }, true));
    figure2.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new Rectangle(new Point(250, 250), new Size(200, 200))));

    //Add Figure object to GraphicsPath
    graphicspath.AddFigures(new[] { figure1, figure2 });

    //Draw path with Pen object of color Black
    graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

    // save all changes.
    image.Save();
}
[Visual Basic]

'Creates an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("c:\temp\output.bmp", False)

'Create an instance of Image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
    graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure1 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure1.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
    figure1.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(110, 110), New Size(200, 200)), 0, 90))

'Create an instance of Figure class
Dim figure2 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure2.AddShape(New Aspose.Imaging.Shapes.ArcShape(New RectangleF(10, 10, 300, 300), 0, 45))
    figure2.AddShape(New Aspose.Imaging.Shapes.PolygonShape(New() { New PointF(150, 10), New PointF(150, 200), New PointF(250, 300), New PointF(350, 400) }, True))
    figure2.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New Rectangle(New Point(250, 250), New Size(200, 200))))

'Add Figure object to GraphicsPath
    graphicspath.AddFigures(New() { figure1, figure2 })

'Draw path with Pen object of color Black
    graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
    image.Save()
End Using

See Also

Figure Class | Aspose.Imaging Namespace


GetBounds Method

Aspose.Imaging Documentation

Figure.GetBounds Method

Gets the object's bounds.

Overload List

Gets the object's bounds.

public override RectangleF GetBounds(Matrix);

Gets the object's bounds.

public override RectangleF GetBounds(Matrix,Pen);

See Also

Figure Class | Aspose.Imaging Namespace


Figure.GetBounds Method (Matrix)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix
);

Parameters

matrix
The matrix to apply before bounds will be calculated.

Return Value

The estimated object's bounds.

See Also

Figure Class | Aspose.Imaging Namespace | Figure.GetBounds Overload List


Figure.GetBounds Method (Matrix, Pen)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix,
Pen pen
);

Parameters

matrix
The matrix to apply before bounds will be calculated.
pen
The pen to use for object. This can influence the object's bounds size.

Return Value

The estimated object's bounds.

See Also

Figure Class | Aspose.Imaging Namespace | Figure.GetBounds Overload List


Figure.RemoveShape Method

Removes a shape from the figure.

public void RemoveShape(
Shape shape
);

Parameters

shape
The shape to remove.

See Also

Figure Class | Aspose.Imaging Namespace


Figure.RemoveShapes Method

Removes a range of shapes from the figure.

public void RemoveShapes(
Shape[] shapes
);

Parameters

shapes
The shapes range to remove.

See Also

Figure Class | Aspose.Imaging Namespace


Figure.Reverse Method

Reverses this figure shapes order and shapes point order.

public void Reverse();

See Also

Figure Class | Aspose.Imaging Namespace


Figure.Transform Method

Applies the specified transformation to the shape.

public override void Transform(
Matrix transform
);

Parameters

transform
The transformation to apply.

See Also

Figure Class | Aspose.Imaging Namespace


FileFormat Enumeration

One of supported imaging file formats.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum FileFormat

Members

Member Name | Description | Value
Undefined | Undefined file format. | 0
Custom | Custom file format. | 1
Bmp | Bmp file format. | 2
Gif | Gif file format. | 4
Jpeg | Jpeg file format. | 8
Png | Png file format. | 16
Tiff | Tiff file format. | 32
Psd | Psd file format. | 64
Dxf | Dxf file format | 128
Dwg | Dwg file format | 256

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


FileStreamContainer Class

Helper for file stream processing.

For a list of all members of this type, see FileStreamContainer Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.StreamContainer
Aspose.Imaging.FileStreamContainer

public sealed class FileStreamContainer : StreamContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

FileStreamContainer Members | Aspose.Imaging Namespace


FileStreamContainer Members

FileStreamContainer overview

Public Static Type Conversions

Explicit FileStreamContainer to FileStream Conversion | Performs an explicit conversion from FileStreamContainer to FileStream.
Explicit FileStreamContainer to Stream Conversion | Performs an explicit conversion from FileStreamContainer to Stream.

Public Instance Properties

CanRead (inherited from StreamContainer) | Gets a value indicating whether stream supports reading.
CanSeek (inherited from StreamContainer) | Gets a value indicating whether stream supports seeking.
CanWrite (inherited from StreamContainer) | Gets a value indicating whether stream supports writing.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
FilePath | Gets the file path.
IsCreated | Gets a value indicating whether stream was created explicitly.
IsStreamDisposedOnClose (inherited from StreamContainer) | Gets a value indicating whether this stream is disposed on close.
IsTemporal | Gets or sets a value indicating whether stream is temporal.
Length (inherited from StreamContainer) | Gets or sets the stream length in bytes. This value is less than the Length by the starting stream position passed in the StreamContainer constructor.
Position (inherited from StreamContainer) | Gets or sets the current position within the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.
Stream (inherited from StreamContainer) | Gets the data stream.

Public Instance Methods

Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from StreamContainer) | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Read (inherited from StreamContainer) | Overloaded. Reads bytes to fill the specified bytes buffer.
ReadByte (inherited from StreamContainer) | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.
Save (inherited from StreamContainer) | Overloaded. Saves (copies) the stream's data to the specified stream. Uses default buffer size ReadWriteBytesCount and stream Length value.
Seek (inherited from StreamContainer) | Sets the position within the current stream.
SeekBegin (inherited from StreamContainer) | Sets the stream position to the beginning of the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.
Shift (inherited from StreamContainer) | Shifts the data from the current stream position. The data starts from the current byte and continues to the end of the file.
ToBytes (inherited from StreamContainer) | Overloaded. Converts the stream data to the Byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from StreamContainer) | Overloaded. Writes all of the specified bytes to the stream.
WriteByte (inherited from StreamContainer) | Writes a byte to the current position in the stream and advances the position within the stream by one byte.
WriteTo (inherited from StreamContainer) | Overloaded. Copies the contained data to another StreamContainer.

See Also

FileStreamContainer Class | Aspose.Imaging Namespace


FileStreamContainer Properties

The properties of the FileStreamContainer class are listed below. For a complete list of FileStreamContainer class members, see the FileStreamContainer Members topic.

Public Instance Properties

CanRead (inherited from StreamContainer) | Gets a value indicating whether stream supports reading.
CanSeek (inherited from StreamContainer) | Gets a value indicating whether stream supports seeking.
CanWrite (inherited from StreamContainer) | Gets a value indicating whether stream supports writing.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
FilePath | Gets the file path.
IsCreated | Gets a value indicating whether stream was created explicitly.
IsStreamDisposedOnClose (inherited from StreamContainer) | Gets a value indicating whether this stream is disposed on close.
IsTemporal | Gets or sets a value indicating whether stream is temporal.
Length (inherited from StreamContainer) | Gets or sets the stream length in bytes. This value is less than the Length by the starting stream position passed in the StreamContainer constructor.
Position (inherited from StreamContainer) | Gets or sets the current position within the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.
Stream (inherited from StreamContainer) | Gets the data stream.

See Also

FileStreamContainer Class | Aspose.Imaging Namespace


FilePath Property

Aspose.Imaging Documentation

FileStreamContainer.FilePath Property

Gets the file path.

public string FilePath {get;}

Property Value

The file path.

See Also

FileStreamContainer Class | Aspose.Imaging Namespace


IsCreated Property

Aspose.Imaging Documentation

FileStreamContainer.IsCreated Property

Gets a value indicating whether stream was created explicitly.

public bool IsCreated {get;}

Property Value

true if stream was created explicitly; otherwise, false.

See Also

FileStreamContainer Class | Aspose.Imaging Namespace


IsTemporal Property

Aspose.Imaging Documentation

FileStreamContainer.IsTemporal Property

Gets or sets a value indicating whether stream is temporal.

public bool IsTemporal {get; set;}

Property Value

true if stream is temporal; otherwise, false.

Remarks

A temporal stream will remove iself when disposed. If the stream is memory based this property has no effect. The stream can be marked as temporal or persistent in case it was created explicitly otherwise the appropriate exception is thrown.

See Also

FileStreamContainer Class | Aspose.Imaging Namespace


FileStreamContainer Type Conversions

The type conversions of the FileStreamContainer class are listed below. For a complete list of FileStreamContainer class members, see the FileStreamContainer Members topic.

Public Static Type Conversions

Explicit FileStreamContainer to FileStream Conversion | Performs an explicit conversion from FileStreamContainer to FileStream.
Explicit FileStreamContainer to Stream Conversion | Performs an explicit conversion from FileStreamContainer to Stream.

See Also

FileStreamContainer Class | FileStreamContainer Members | Aspose.Imaging Namespace


FileStreamContainer Explicit FileStreamContainer to FileStream Conversion

Performs an explicit conversion from FileStreamContainer to FileStream.

public static explicit operator FileStream(
FileStreamContainer fileStreamContainer
);

Parameters

fileStreamContainer
The file stream container.

Return Value

The result of the conversion.

See Also

FileStreamContainer Class | Aspose.Imaging Namespace


FileStreamContainer Explicit FileStreamContainer to Stream Conversion

Performs an explicit conversion from FileStreamContainer to Stream.

public static explicit operator Stream(
FileStreamContainer fileStreamContainer
);

Parameters

fileStreamContainer
The file stream container.

Return Value

The result of the conversion.

See Also

FileStreamContainer Class | Aspose.Imaging Namespace


FillMode Enumeration

Specifies how the interior of a closed path is filled.

public enum FillMode

Members

Member Name | Description | Value
Alternate | Specifies the alternate fill mode. | 0
Winding | Specifies the winding fill mode. | 1

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


Font Class

Defines a particular format for text, including font face, size, and style attributes. This class cannot be inherited.

For a list of all members of this type, see Font Members.

System.Object
Aspose.Imaging.Font

public sealed class Font

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example demonstrates the use of Font and SolidBrush class to draw strings on Image surface. The example creates a new Image and draw shapes using Figures and GraphicsPath

[C#]

//Creates an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"C:\temp\sample.bmp", false);

//Creates an instance of Image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Creates and initialize an instance of Graphics class
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clears Graphics surface
    graphics.Clear(Color.Wheat);

    //Creates an instance of Font
    Aspose.Imaging.Font font = new Aspose.Imaging.Font("Times New Roman", 16);

    //Create an instance of SolidBrush having Red Color
    Aspose.Imaging.Brushes.SolidBrush brush = new Aspose.Imaging.Brushes.SolidBrush(Color.Red);

    //Draw a String
    graphics.DrawString("Created by Aspose.Imaging for .Net", font, brush, new PointF(100, 100));

    // save all changes
    image.Save();
}
[Visual Basic]

'Creates an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("C:\temp\sample.bmp", False)

'Creates an instance of Image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Creates and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clears Graphics surface
    graphics.Clear(Color.Wheat)

'Creates an instance of Font
Dim font As Aspose.Imaging.Font = New Aspose.Imaging.Font("Times New Roman", 16)

'Create an instance of SolidBrush having Red Color
Dim brush As Aspose.Imaging.Brushes.SolidBrush = New Aspose.Imaging.Brushes.SolidBrush(Color.Red)

'Draw a String
    graphics.DrawString("Created by Aspose.Imaging for .Net", font, brush, New PointF(100, 100))

' save all changes
    image.Save()
End Using

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Font Members | Aspose.Imaging Namespace


Font Members

Font overview

Public Instance Constructors

Font Overloaded. Initializes a new instance of the Font class.

Public Instance Properties

Bold | Gets a value indicating whether this Font is bold.
CharacterSet | Gets a byte value that specifies the character set that this Font uses.
Italic | Gets a value indicating whether this Font is italic.
Name | Gets the face name of this Font.
Size | Gets the em-size of this Font measured in the units specified by the Unit property.
Strikeout | Gets a value indicating whether this Font specifies a horizontal line through the font.
Style | Gets style information for this Font.
Underline | Gets a value indicating whether this Font is underlined.
Unit | Gets the unit of measure for this Font.

Public Instance Methods

DeepClone | Creates an exact deep copy of this Font.
Equals | Indicates whether the specified object is a Font and has the same property values as this Font.
GetHashCode | Gets the hash code for this Font.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a human-readable string representation of this Font.

See Also

Font Class | Aspose.Imaging Namespace


Font Constructor

Initializes a new Font that uses the specified existing Font and FontStyle enumeration.

Overload List

Initializes a new Font that uses the specified existing Font and FontStyle enumeration.

public Font(Font,FontStyle);

Initializes a new Font using a specified size. The character set is set to Default, the graphics unit to Point, the font style to Regular.

public Font(string,float);

Initializes a new Font using a specified size and style. The character set is set to Default, the graphics unit to Point.

public Font(string,float,FontStyle);

Initializes a new Font using a specified size, style, and unit.

public Font(string,float,FontStyle,GraphicsUnit);

Initializes a new Font using a specified size, style, unit, and character set.

public Font(string,float,FontStyle,GraphicsUnit,CharacterSet);

Initializes a new Font using a specified size and unit. The character set is set to Default, the style is set to Regular.

public Font(string,float,GraphicsUnit);

See Also

Font Class | Aspose.Imaging Namespace


Font Constructor (Font, FontStyle)

Initializes a new Font that uses the specified existing Font and FontStyle enumeration.

public Font(
Font prototype,
FontStyle newStyle
);

Parameters

prototype
The existing Font from which to create the new Font.
newStyle
The FontStyle to apply to the new Font. Multiple values of the FontStyle enumeration can be combined with the OR operator.

Exceptions

Exception Type | Condition
ArgumentNullException | prototype is null.

See Also

Font Class | Aspose.Imaging Namespace | Font Constructor Overload List


Font Constructor (String, Single)

Initializes a new Font using a specified size. The character set is set to Default, the graphics unit to Point, the font style to Regular.

public Font(
string fontName,
float emSize
);

Parameters

fontName
A string representation of the Font name.
emSize
The em-size, in points, of the new font.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | emSize is less than or equal to 0, evaluates to infinity or is not a valid number.
ArgumentNullException | fontName is null.

See Also

Font Class | Aspose.Imaging Namespace | Font Constructor Overload List


Font Constructor (String, Single, FontStyle)

Initializes a new Font using a specified size and style. The character set is set to Default, the graphics unit to Point.

public Font(
string fontName,
float emSize,
FontStyle style
);

Parameters

fontName
A string representation of the Font name.
emSize
The em-size, in points, of the new font.
style
The FontStyle of the new font.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | emSize is less than or equal to 0, evaluates to infinity or is not a valid number.
ArgumentNullException | fontName is null.

See Also

Font Class | Aspose.Imaging Namespace | Font Constructor Overload List


Font Constructor (String, Single, GraphicsUnit)

Initializes a new Font using a specified size and unit. The character set is set to Default, the style is set to Regular.

public Font(
string fontName,
float emSize,
GraphicsUnit unit
);

Parameters

fontName
A string representation of the Font name.
emSize
The em-size of the new font in the units specified by the unit parameter.
unit
The GraphicsUnit of the new font.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | emSize is less than or equal to 0, evaluates to infinity or is not a valid number.
ArgumentNullException | fontName is null.

See Also

Font Class | Aspose.Imaging Namespace | Font Constructor Overload List


Font Constructor (String, Single, FontStyle, GraphicsUnit, CharacterSet)

Initializes a new Font using a specified size, style, unit, and character set.

public Font(
string fontName,
float emSize,
FontStyle style,
GraphicsUnit unit,
CharacterSet characterSet
);

Parameters

fontName
A string representation of the Font name.
emSize
The em-size of the new font in the units specified by the unit parameter.
style
The FontStyle of the new font.
unit
The GraphicsUnit of the new font.
characterSet
A character set to use for this font.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | emSize is less than or equal to 0, evaluates to infinity or is not a valid number.
ArgumentNullException | fontName is null.

See Also

Font Class | Aspose.Imaging Namespace | Font Constructor Overload List


Font Constructor (String, Single, FontStyle, GraphicsUnit)

Initializes a new Font using a specified size, style, and unit.

public Font(
string fontName,
float emSize,
FontStyle style,
GraphicsUnit unit
);

Parameters

fontName
A string representation of the Font name.
emSize
The em-size of the new font in the units specified by the unit parameter.
style
The FontStyle of the new font.
unit
The GraphicsUnit of the new font.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | emSize is less than or equal to 0, evaluates to infinity or is not a valid number.
ArgumentNullException | fontName is null.

See Also

Font Class | Aspose.Imaging Namespace | Font Constructor Overload List


Font Properties

The properties of the Font class are listed below. For a complete list of Font class members, see the Font Members topic.

Public Instance Properties

Bold | Gets a value indicating whether this Font is bold.
CharacterSet | Gets a byte value that specifies the character set that this Font uses.
Italic | Gets a value indicating whether this Font is italic.
Name | Gets the face name of this Font.
Size | Gets the em-size of this Font measured in the units specified by the Unit property.
Strikeout | Gets a value indicating whether this Font specifies a horizontal line through the font.
Style | Gets style information for this Font.
Underline | Gets a value indicating whether this Font is underlined.
Unit | Gets the unit of measure for this Font.

See Also

Font Class | Aspose.Imaging Namespace


Bold Property

Aspose.Imaging Documentation

Font.Bold Property

Gets a value indicating whether this Font is bold.

public bool Bold {get;}

Property Value

True if this Font is bold; otherwise, false.

See Also

Font Class | Aspose.Imaging Namespace


CharacterSet Property

Aspose.Imaging Documentation

Font.CharacterSet Property

Gets a byte value that specifies the character set that this Font uses.

public CharacterSet CharacterSet {get;}

Property Value

A character set that this Font uses.

See Also

Font Class | Aspose.Imaging Namespace


Italic Property

Aspose.Imaging Documentation

Font.Italic Property

Gets a value indicating whether this Font is italic.

public bool Italic {get;}

Property Value

True if this Font is italic; otherwise, false.

See Also

Font Class | Aspose.Imaging Namespace


Name Property

Aspose.Imaging Documentation

Font.Name Property

Gets the face name of this Font.

public string Name {get;}

Property Value

A string representation of the face name of this Font.

See Also

Font Class | Aspose.Imaging Namespace


Size Property

Aspose.Imaging Documentation

Font.Size Property

Gets the em-size of this Font measured in the units specified by the Unit property.

public float Size {get;}

Property Value

The em-size of this Font.

See Also

Font Class | Aspose.Imaging Namespace


Strikeout Property

Aspose.Imaging Documentation

Font.Strikeout Property

Gets a value indicating whether this Font specifies a horizontal line through the font.

public bool Strikeout {get;}

Property Value

True if this Font has a horizontal line through it; otherwise, false.

See Also

Font Class | Aspose.Imaging Namespace


Style Property

Aspose.Imaging Documentation

Font.Style Property

Gets style information for this Font.

public FontStyle Style {get;}

Property Value

A FontStyle enumeration that contains style information for this Font.

See Also

Font Class | Aspose.Imaging Namespace


Underline Property

Aspose.Imaging Documentation

Font.Underline Property

Gets a value indicating whether this Font is underlined.

public bool Underline {get;}

Property Value

True if this Font is underlined; otherwise, false.

See Also

Font Class | Aspose.Imaging Namespace


Unit Property

Aspose.Imaging Documentation

Font.Unit Property

Gets the unit of measure for this Font.

public GraphicsUnit Unit {get;}

Property Value

A GraphicsUnit that represents the unit of measure for this Font.

See Also

Font Class | Aspose.Imaging Namespace


Font Methods

The methods of the Font class are listed below. For a complete list of Font class members, see the Font Members topic.

Public Instance Methods

DeepClone | Creates an exact deep copy of this Font.
Equals | Indicates whether the specified object is a Font and has the same property values as this Font.
GetHashCode | Gets the hash code for this Font.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a human-readable string representation of this Font.

See Also

Font Class | Aspose.Imaging Namespace


Font.DeepClone Method

Creates an exact deep copy of this Font.

public Font DeepClone();

Return Value

The Font this method creates.

See Also

Font Class | Aspose.Imaging Namespace


Font.Equals Method

Indicates whether the specified object is a Font and has the same property values as this Font.

public override bool Equals(
object obj
);

Parameters

obj
The object to test.

Return Value

True if the obj parameter is a Font and has the same property values as this Font; otherwise, false.

See Also

Font Class | Aspose.Imaging Namespace


Font.GetHashCode Method

Gets the hash code for this Font.

public override int GetHashCode();

Return Value

The hash code for this Font.

See Also

Font Class | Aspose.Imaging Namespace


Font.ToString Method

Returns a human-readable string representation of this Font.

public override string ToString();

Return Value

A string that represents this Font.

See Also

Font Class | Aspose.Imaging Namespace


FontStyle Enumeration

Specifies style information applied to text.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum FontStyle

Members

Member Name | Description | Value
Regular | Normal text. | 0
Bold | Bold text. | 1
Italic | Italic text. | 2
Underline | Underlined text. | 4
Strikeout | Text with a line through the middle. | 8

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


Graphics Class

Represents the graphics according to the graphics engine used in the current assembly.

For a list of all members of this type, see Graphics Members.

System.Object
Aspose.Imaging.Graphics

public sealed class Graphics

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example uses Graphics class to create primitive shapes on the Image surface. To demonstrate the operation, the example creates a new Image in PNG format and draw primitive shapes on Image surface using Draw methods exposed by Graphics class

[C#]

//Creates an instance of FileStream
using (System.IO.FileStream stream = new System.IO.FileStream(@"C:\temp\output.png", System.IO.FileMode.Create))
{
    //Create an instance of PngOptions and set its various properties
    Aspose.Imaging.ImageOptions.PngOptions pngOptions = new Aspose.Imaging.ImageOptions.PngOptions();

    //Set the Source for PngOptions
    pngOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(pngOptions, 500, 500))
    {
        //Create and initialize an instance of Graphics class
        Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

        //Clear Graphics surface
        graphics.Clear(Color.Wheat);

        //Draw an Arc by specifying the Pen object having Black color,
        //a Rectangle surrounding the Arc, Start Angle and Sweep Angle
        graphics.DrawArc(new Pen(Color.Black, 2), new Rectangle(200, 200, 100, 200), 0, 300);

        //Draw a Bezier by specifying the Pen object having Blue color and co-ordinate Points.
        graphics.DrawBezier(new Pen(Color.Blue, 2), new Point(250, 100), new Point(300, 30), new Point(450, 100), new Point(235, 25));

        //Draw a Curve by specifying the Pen object having Green color and an array of Points
        graphics.DrawCurve(new Pen(Color.Green, 2), new[] { new Point(100, 200), new Point(100, 350), new Point(200, 450) });

        //Draw an Ellipse using the Pen object and a surrounding Rectangle
        graphics.DrawEllipse(new Pen(Color.Yellow, 2), new Rectangle(300, 300, 100, 100));

        //Draw a Line
        graphics.DrawLine(new Pen(Color.Violet, 2), new Point(100, 100), new Point(200, 200));

        //Draw a Pie segment
        graphics.DrawPie(new Pen(Color.Silver, 2), new Rectangle(new Point(200, 20), new Size(200, 200)), 0, 45);

        //Draw a Polygon by specifying the Pen object having Red color and an array of Points
        graphics.DrawPolygon(new Pen(Color.Red, 2), new[] { new Point(20, 100), new Point(20, 200), new Point(220, 20) });

        //Draw a Rectangle
        graphics.DrawRectangle(new Pen(Color.Orange, 2), new Rectangle(new Point(250, 250), new Size(100, 100)));

        //Create a SolidBrush object and set its various properties
        Aspose.Imaging.Brushes.SolidBrush brush = new Aspose.Imaging.Brushes.SolidBrush();
        brush.Color = Color.Purple;
        brush.Opacity = 100;

        //Draw a String using the SolidBrush object and Font, at specific Point
        graphics.DrawString("This image is created by Aspose.Imaging API", new Font("Times New Roman", 16), brush, new PointF(50, 400));

        // save all changes.
        image.Save();
    }
}
[Visual Basic]

'Creates an instance of FileStream
Using stream As System.IO.FileStream = New System.IO.FileStream("C:\temp\output.png", System.IO.FileMode.Create)
'Create an instance of PngOptions and set its various properties
Dim pngOptions As Aspose.Imaging.ImageOptions.PngOptions = New Aspose.Imaging.ImageOptions.PngOptions()

'Set the Source for PngOptions
    pngOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(pngOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
        graphics.Clear(Color.Wheat)

'Draw an Arc by specifying the Pen object having Black color,
'a Rectangle surrounding the Arc, Start Angle and Sweep Angle
        graphics.DrawArc(New Pen(Color.Black, 2), New Rectangle(200, 200, 100, 200), 0, 300)

'Draw a Bezier by specifying the Pen object having Blue color and co-ordinate Points.
        graphics.DrawBezier(New Pen(Color.Blue, 2), New Point(250, 100), New Point(300, 30), New Point(450, 100), New Point(235, 25))

'Draw a Curve by specifying the Pen object having Green color and an array of Points
        graphics.DrawCurve(New Pen(Color.Green, 2), New() { New Point(100, 200), New Point(100, 350), New Point(200, 450) })

'Draw an Ellipse using the Pen object and a surrounding Rectangle
        graphics.DrawEllipse(New Pen(Color.Yellow, 2), New Rectangle(300, 300, 100, 100))

'Draw a Line
        graphics.DrawLine(New Pen(Color.Violet, 2), New Point(100, 100), New Point(200, 200))

'Draw a Pie segment
        graphics.DrawPie(New Pen(Color.Silver, 2), New Rectangle(New Point(200, 20), New Size(200, 200)), 0, 45)

'Draw a Polygon by specifying the Pen object having Red color and an array of Points
        graphics.DrawPolygon(New Pen(Color.Red, 2), New() { New Point(20, 100), New Point(20, 200), New Point(220, 20) })

'Draw a Rectangle
        graphics.DrawRectangle(New Pen(Color.Orange, 2), New Rectangle(New Point(250, 250), New Size(100, 100)))

'Create a SolidBrush object and set its various properties
Dim brush As Aspose.Imaging.Brushes.SolidBrush = New Aspose.Imaging.Brushes.SolidBrush()
        brush.Color = Color.Purple
        brush.Opacity = 100

'Draw a String using the SolidBrush object and Font, at specific Point
        graphics.DrawString("This image is created by Aspose.Imaging API", New Font("Times New Roman", 16), brush, New PointF(50, 400))

' save all changes.
        image.Save()
    End Using
End Using

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Graphics Members | Aspose.Imaging Namespace


Graphics Members

Graphics overview

Public Instance Constructors

Graphics Constructor Initializes a new instance of the Graphics class.

Public Instance Properties

CompositingQuality | Gets or sets the compositing quality.
Image | Gets the image.
InterpolationMode | Gets or sets the interpolation mode.
IsInBeginUpdateCall | Gets a value indicating whether graphics is in BeginUpdate call state.
SmoothingMode | Gets or sets the smoothing mode.
TextRenderingHint | Gets or sets the text rendering hint.
Transform | Gets or sets a copy of the geometric world transformation for this Graphics.

Public Instance Methods

BeginUpdate | Starts caching of the following graphics operations. The graphics effects applied afterwards will not be applied immediately instead the EndUpdate will cause applying all the effects at once.
Clear | Clears the graphics surface using the specified color.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.
DrawBeziers | Overloaded. Draws a series of Bézier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of PointF structures. This method uses a default tension of 0.5 and Alternate fill mode.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of PointF structures. This method uses a default tension of 0.5.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding RectangleF.
DrawImage | Overloaded. Draws the specified Image, using its original physical size, at the specified location.
DrawImageUnscaled | Overloaded. Draws a specified image using its original physical size at a specified location.
DrawImageUnscaledAndClipped | Draws the specified image without scaling and clips it, if necessary, to fit in the specified rectangle.
DrawLine | Overloaded. Draws a line connecting two Point structures.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a GraphicsPath.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of PointF structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a RectangleF structure.
DrawRectangles | Overloaded. Draws a series of rectangles specified by RectangleF structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndUpdate | Finishes caching of the graphics operations started after BeginUpdate was called. The preceding graphics operations will be applied at once when calling this method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FillClosedCurve | Overloaded. Fills the interior of a closed cardinal spline curve defined by an array of PointF structures. This method uses a default tension of 0.5 and Alternate fill mode.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.
FillPath | Fills the interior of a GraphicsPath.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by PointF structures and Alternate.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a Rectangle structure.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a Region.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform | Overloaded. Multiplies the Matrix that represents the local geometric transform of this Graphics by the specified Matrix by prepending the specified Matrix.
ResetTransform | Resets the Transform property to identity.
RotateTransform | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics Constructor

Initializes a new instance of the Graphics class.

public Graphics(
Image sourceImage
);

Parameters

sourceImage
The source image.

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics Properties

The properties of the Graphics class are listed below. For a complete list of Graphics class members, see the Graphics Members topic.

Public Instance Properties

CompositingQuality | Gets or sets the compositing quality.
Image | Gets the image.
InterpolationMode | Gets or sets the interpolation mode.
IsInBeginUpdateCall | Gets a value indicating whether graphics is in BeginUpdate call state.
SmoothingMode | Gets or sets the smoothing mode.
TextRenderingHint | Gets or sets the text rendering hint.
Transform | Gets or sets a copy of the geometric world transformation for this Graphics.

See Also

Graphics Class | Aspose.Imaging Namespace


CompositingQuality Property

Aspose.Imaging Documentation

Graphics.CompositingQuality Property

Gets or sets the compositing quality.

public CompositingQuality CompositingQuality {get; set;}

Property Value

The compositing quality.

See Also

Graphics Class | Aspose.Imaging Namespace


Image Property

Aspose.Imaging Documentation

Graphics.Image Property

Gets the image.

public Image Image {get;}

Property Value

The graphics image.

See Also

Graphics Class | Aspose.Imaging Namespace


InterpolationMode Property

Aspose.Imaging Documentation

Graphics.InterpolationMode Property

Gets or sets the interpolation mode.

public InterpolationMode InterpolationMode {get; set;}

Property Value

The interpolation mode.

See Also

Graphics Class | Aspose.Imaging Namespace


IsInBeginUpdateCall Property

Aspose.Imaging Documentation

Graphics.IsInBeginUpdateCall Property

Gets a value indicating whether graphics is in BeginUpdate call state.

public bool IsInBeginUpdateCall {get;}

Property Value

True if graphics is in BeginUpdate call state; otherwise, false.

See Also

Graphics Class | Aspose.Imaging Namespace


SmoothingMode Property

Aspose.Imaging Documentation

Graphics.SmoothingMode Property

Gets or sets the smoothing mode.

public SmoothingMode SmoothingMode {get; set;}

Property Value

The smoothing mode.

See Also

Graphics Class | Aspose.Imaging Namespace


TextRenderingHint Property

Aspose.Imaging Documentation

Graphics.TextRenderingHint Property

Gets or sets the text rendering hint.

public TextRenderingHint TextRenderingHint {get; set;}

Property Value

The text rendering hint.

See Also

Graphics Class | Aspose.Imaging Namespace


Transform Property

Aspose.Imaging Documentation

Graphics.Transform Property

Gets or sets a copy of the geometric world transformation for this Graphics.

public Matrix Transform {get; set;}

Property Value

A copy of the Matrix that represents the geometric world transformation for this Graphics.

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics Methods

The methods of the Graphics class are listed below. For a complete list of Graphics class members, see the Graphics Members topic.

Public Instance Methods

BeginUpdate | Starts caching of the following graphics operations. The graphics effects applied afterwards will not be applied immediately instead the EndUpdate will cause applying all the effects at once.
Clear | Clears the graphics surface using the specified color.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.
DrawBeziers | Overloaded. Draws a series of Bézier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of PointF structures. This method uses a default tension of 0.5 and Alternate fill mode.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of PointF structures. This method uses a default tension of 0.5.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding RectangleF.
DrawImage | Overloaded. Draws the specified Image, using its original physical size, at the specified location.
DrawImageUnscaled | Overloaded. Draws a specified image using its original physical size at a specified location.
DrawImageUnscaledAndClipped | Draws the specified image without scaling and clips it, if necessary, to fit in the specified rectangle.
DrawLine | Overloaded. Draws a line connecting two Point structures.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a GraphicsPath.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of PointF structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a RectangleF structure.
DrawRectangles | Overloaded. Draws a series of rectangles specified by RectangleF structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndUpdate | Finishes caching of the graphics operations started after BeginUpdate was called. The preceding graphics operations will be applied at once when calling this method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FillClosedCurve | Overloaded. Fills the interior of a closed cardinal spline curve defined by an array of PointF structures. This method uses a default tension of 0.5 and Alternate fill mode.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.
FillPath | Fills the interior of a GraphicsPath.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by PointF structures and Alternate.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a Rectangle structure.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a Region.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform | Overloaded. Multiplies the Matrix that represents the local geometric transform of this Graphics by the specified Matrix by prepending the specified Matrix.
ResetTransform | Resets the Transform property to identity.
RotateTransform | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.BeginUpdate Method

Starts caching of the following graphics operations. The graphics effects applied afterwards will not be applied immediately instead the EndUpdate will cause applying all the effects at once.

public void BeginUpdate();

Remarks

Note the effects after BeginUpdate is called will not be applied in case EndUpdate is not called.

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.Clear Method

Clears the graphics surface using the specified color.

public void Clear(
Color color
);

Parameters

color
The color to clear the graphics surface by.

See Also

Graphics Class | Aspose.Imaging Namespace


DrawArc Method

Aspose.Imaging Documentation

Graphics.DrawArc Method

Draws an arc representing a portion of an ellipse specified by a Rectangle structure.

Overload List

Draws an arc representing a portion of an ellipse specified by a Rectangle structure.

public void DrawArc(Pen,Rectangle,float,float);

Draws an arc representing a portion of an ellipse specified by a RectangleF structure.

public void DrawArc(Pen,RectangleF,float,float);

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

public void DrawArc(Pen,int,int,int,int,int,int);

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

public void DrawArc(Pen,float,float,float,float,float,float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawArc Method (Pen, Rectangle, Single, Single)

Draws an arc representing a portion of an ellipse specified by a Rectangle structure.

public void DrawArc(
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
);

Parameters

pen
Pen that determines the color, width, and style of the arc.
rect
RectangleF structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawArc Overload List


Graphics.DrawArc Method (Pen, RectangleF, Single, Single)

Draws an arc representing a portion of an ellipse specified by a RectangleF structure.

public void DrawArc(
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
);

Parameters

pen
Pen that determines the color, width, and style of the arc.
rect
RectangleF structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawArc Overload List


Graphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

public void DrawArc(
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
);

Parameters

pen
Pen that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
Width of the rectangle that defines the ellipse.
height
Height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawArc Overload List


Graphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

public void DrawArc(
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
);

Parameters

pen
Pen that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
Width of the rectangle that defines the ellipse.
height
Height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawArc Overload List


DrawBezier Method

Aspose.Imaging Documentation

Graphics.DrawBezier Method

Draws a Bézier spline defined by four Point structures.

Overload List

Draws a Bézier spline defined by four Point structures.

public void DrawBezier(Pen,Point,Point,Point,Point);

Draws a Bézier spline defined by four PointF structures.

public void DrawBezier(Pen,PointF,PointF,PointF,PointF);

Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.

public void DrawBezier(Pen,float,float,float,float,float,float,float,float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawBezier Method (Pen, Point, Point, Point, Point)

Draws a Bézier spline defined by four Point structures.

public void DrawBezier(
Pen pen,
Point pt1,
Point pt2,
Point pt3,
Point pt4
);

Parameters

pen
Pen structure that determines the color, width, and style of the curve.
pt1
Point structure that represents the starting point of the curve.
pt2
Point structure that represents the first control point for the curve.
pt3
Point structure that represents the second control point for the curve.
pt4
Point structure that represents the ending point of the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawBezier Overload List


Graphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)

Draws a Bézier spline defined by four PointF structures.

public void DrawBezier(
Pen pen,
PointF pt1,
PointF pt2,
PointF pt3,
PointF pt4
);

Parameters

pen
Pen that determines the color, width, and style of the curve.
pt1
PointF structure that represents the starting point of the curve.
pt2
PointF structure that represents the first control point for the curve.
pt3
PointF structure that represents the second control point for the curve.
pt4
PointF structure that represents the ending point of the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawBezier Overload List


Graphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)

Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.

public void DrawBezier(
Pen pen,
float x1,
float y1,
float x2,
float y2,
float x3,
float y3,
float x4,
float y4
);

Parameters

pen
Pen that determines the color, width, and style of the curve.
x1
The x-coordinate of the starting point of the curve.
y1
The y-coordinate of the starting point of the curve.
x2
The x-coordinate of the first control point of the curve.
y2
The y-coordinate of the first control point of the curve.
x3
The x-coordinate of the second control point of the curve.
y3
The y-coordinate of the second control point of the curve.
x4
The x-coordinate of the ending point of the curve.
y4
The y-coordinate of the ending point of the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawBezier Overload List


DrawBeziers Method

Aspose.Imaging Documentation

Graphics.DrawBeziers Method

Draws a series of Bézier splines from an array of Point structures.

Overload List

Draws a series of Bézier splines from an array of Point structures.

public void DrawBeziers(Pen,Point[]);

Draws a series of Bézier splines from an array of PointF structures.

public void DrawBeziers(Pen,PointF[]);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawBeziers Method (Pen, Point[])

Draws a series of Bézier splines from an array of Point structures.

public void DrawBeziers(
Pen pen,
Point[] points
);

Parameters

pen
Pen that determines the color, width, and style of the curve.
points
Array of Point structures that represent the points that determine the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawBeziers Overload List


Graphics.DrawBeziers Method (Pen, PointF[])

Draws a series of Bézier splines from an array of PointF structures.

public void DrawBeziers(
Pen pen,
PointF[] points
);

Parameters

pen
Pen that determines the color, width, and style of the curve.
points
Array of PointF structures that represent the points that determine the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawBeziers Overload List


DrawClosedCurve Method

Aspose.Imaging Documentation

Graphics.DrawClosedCurve Method

Draws a closed cardinal spline defined by an array of Point structures. This method uses a default tension of 0.5 and Alternate fill mode.

Overload List

Draws a closed cardinal spline defined by an array of Point structures. This method uses a default tension of 0.5 and Alternate fill mode.

public void DrawClosedCurve(Pen,Point[]);

Draws a closed cardinal spline defined by an array of Point structures using a specified tension. This method uses a default Alternate fill mode.

public void DrawClosedCurve(Pen,Point[],float);

Draws a closed cardinal spline defined by an array of PointF structures. This method uses a default tension of 0.5 and Alternate fill mode.

public void DrawClosedCurve(Pen,PointF[]);

Draws a closed cardinal spline defined by an array of PointF structures using a specified tension. This method uses a default Alternate fill mode.

public void DrawClosedCurve(Pen,PointF[],float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawClosedCurve Method (Pen, Point[])

Draws a closed cardinal spline defined by an array of Point structures. This method uses a default tension of 0.5 and Alternate fill mode.

public void DrawClosedCurve(
Pen pen,
Point[] points
);

Parameters

pen
Pen that determines the color, width, and height of the curve.
points
Array of Point structures that define the spline.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawClosedCurve Overload List


Graphics.DrawClosedCurve Method (Pen, Point[], Single)

Draws a closed cardinal spline defined by an array of Point structures using a specified tension. This method uses a default Alternate fill mode.

public void DrawClosedCurve(
Pen pen,
Point[] points,
float tension
);

Parameters

pen
Pen that determines the color, width, and height of the curve.
points
Array of Point structures that define the spline.
tension
Value greater than or equal to 0.0F that specifies the tension of the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawClosedCurve Overload List


Graphics.DrawClosedCurve Method (Pen, PointF[])

Draws a closed cardinal spline defined by an array of PointF structures. This method uses a default tension of 0.5 and Alternate fill mode.

public void DrawClosedCurve(
Pen pen,
PointF[] points
);

Parameters

pen
Pen that determines the color, width, and height of the curve.
points
Array of PointF structures that define the spline.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawClosedCurve Overload List


Graphics.DrawClosedCurve Method (Pen, PointF[], Single)

Draws a closed cardinal spline defined by an array of PointF structures using a specified tension. This method uses a default Alternate fill mode.

public void DrawClosedCurve(
Pen pen,
PointF[] points,
float tension
);

Parameters

pen
Pen that determines the color, width, and height of the curve.
points
Array of PointF structures that define the spline.
tension
Value greater than or equal to 0.0F that specifies the tension of the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawClosedCurve Overload List


DrawCurve Method

Aspose.Imaging Documentation

Graphics.DrawCurve Method

Draws a cardinal spline through a specified array of Point structures.

Overload List

Draws a cardinal spline through a specified array of Point structures.

public void DrawCurve(Pen,Point[]);

Draws a cardinal spline through a specified array of Point structures using a specified tension.

public void DrawCurve(Pen,Point[],int,int,float);

Draws a cardinal spline through a specified array of Point structures using a specified tension.

public void DrawCurve(Pen,Point[],float);

Draws a cardinal spline through a specified array of PointF structures. This method uses a default tension of 0.5.

public void DrawCurve(Pen,PointF[]);

Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array. This method uses a default tension of 0.5.

public void DrawCurve(Pen,PointF[],int,int);

Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.

public void DrawCurve(Pen,PointF[],int,int,float);

Draws a cardinal spline through a specified array of PointF structures using a specified tension.

public void DrawCurve(Pen,PointF[],float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawCurve Method (Pen, Point[])

Draws a cardinal spline through a specified array of Point structures.

public void DrawCurve(
Pen pen,
Point[] points
);

Parameters

pen
Pen that determines the color, width, and height of the curve.
points
Array of Point structures that define the spline.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawCurve Overload List


Graphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)

Draws a cardinal spline through a specified array of Point structures using a specified tension.

public void DrawCurve(
Pen pen,
Point[] points,
int offset,
int numberOfSegments,
float tension
);

Parameters

pen
Pen that determines the color, width, and height of the curve.
points
Array of Point structures that define the spline.
offset
Offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
Number of segments after the starting point to include in the curve.
tension
Value greater than or equal to 0.0F that specifies the tension of the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawCurve Overload List


Graphics.DrawCurve Method (Pen, Point[], Single)

Draws a cardinal spline through a specified array of Point structures using a specified tension.

public void DrawCurve(
Pen pen,
Point[] points,
float tension
);

Parameters

pen
Pen that determines the color, width, and height of the curve.
points
Array of Point structures that define the spline.
tension
Value greater than or equal to 0.0F that specifies the tension of the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawCurve Overload List


Graphics.DrawCurve Method (Pen, PointF[])

Draws a cardinal spline through a specified array of PointF structures. This method uses a default tension of 0.5.

public void DrawCurve(
Pen pen,
PointF[] points
);

Parameters

pen
Pen that determines the color, width, and height of the curve.
points
Array of PointF structures that define the spline.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawCurve Overload List


Graphics.DrawCurve Method (Pen, PointF[], Int32, Int32)

Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array. This method uses a default tension of 0.5.

public void DrawCurve(
Pen pen,
PointF[] points,
int offset,
int numberOfSegments
);

Parameters

pen
Pen that determines the color, width, and height of the curve.
points
Array of PointF structures that define the spline.
offset
Offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
Number of segments after the starting point to include in the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawCurve Overload List


Graphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)

Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.

public void DrawCurve(
Pen pen,
PointF[] points,
int offset,
int numberOfSegments,
float tension
);

Parameters

pen
Pen that determines the color, width, and height of the curve.
points
Array of PointF structures that define the spline.
offset
Offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
Number of segments after the starting point to include in the curve.
tension
Value greater than or equal to 0.0F that specifies the tension of the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawCurve Overload List


Graphics.DrawCurve Method (Pen, PointF[], Single)

Draws a cardinal spline through a specified array of PointF structures using a specified tension.

public void DrawCurve(
Pen pen,
PointF[] points,
float tension
);

Parameters

pen
Pen that determines the color, width, and height of the curve.
points
Array of PointF structures that represent the points that define the curve.
tension
Value greater than or equal to 0.0F that specifies the tension of the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawCurve Overload List


DrawEllipse Method

Aspose.Imaging Documentation

Graphics.DrawEllipse Method

Draws an ellipse specified by a bounding Rectangle structure.

Overload List

Draws an ellipse specified by a bounding Rectangle structure.

public void DrawEllipse(Pen,Rectangle);

Draws an ellipse defined by a bounding RectangleF.

public void DrawEllipse(Pen,RectangleF);

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

public void DrawEllipse(Pen,int,int,int,int);

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

public void DrawEllipse(Pen,float,float,float,float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawEllipse Method (Pen, Rectangle)

Draws an ellipse specified by a bounding Rectangle structure.

public void DrawEllipse(
Pen pen,
Rectangle rect
);

Parameters

pen
Pen that determines the color, width, and style of the ellipse.
rect
Rectangle structure that defines the boundaries of the ellipse.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawEllipse Overload List


Graphics.DrawEllipse Method (Pen, RectangleF)

Draws an ellipse defined by a bounding RectangleF.

public void DrawEllipse(
Pen pen,
RectangleF rect
);

Parameters

pen
Pen that determines the color, width, and style of the ellipse.
rect
RectangleF structure that defines the boundaries of the ellipse.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawEllipse Overload List


Graphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

public void DrawEllipse(
Pen pen,
int x,
int y,
int width,
int height
);

Parameters

pen
Pen that determines the color, width, and style of the ellipse.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawEllipse Overload List


Graphics.DrawEllipse Method (Pen, Single, Single, Single, Single)

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

public void DrawEllipse(
Pen pen,
float x,
float y,
float width,
float height
);

Parameters

pen
Pen that determines the color, width, and style of the ellipse.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawEllipse Overload List


DrawImage Method

Aspose.Imaging Documentation

Graphics.DrawImage Method

Draws the specified Image, using its original physical size, at the specified location.

Overload List

Draws the specified Image, using its original physical size, at the specified location.

public void DrawImage(Image,Point);

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(Image,Point[]);

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(Image,Point[],Rectangle);

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(Image,Point[],Rectangle,GraphicsUnit);

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(Image,Point[],Rectangle,GraphicsUnit,ImageAttributes);

Draws the specified Image, using its original physical size, at the specified location.

public void DrawImage(Image,PointF);

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(Image,PointF[]);

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(Image,PointF[],RectangleF);

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(Image,PointF[],RectangleF,GraphicsUnit);

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(Image,PointF[],RectangleF,GraphicsUnit,ImageAttributes);

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(Image,Rectangle);

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(Image,Rectangle,GraphicsUnit);

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(Image,Rectangle,GraphicsUnit,ImageAttributes);

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(Image,Rectangle,Rectangle,GraphicsUnit);

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(Image,Rectangle,Rectangle,GraphicsUnit,ImageAttributes);

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(Image,RectangleF);

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(Image,RectangleF,GraphicsUnit);

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(Image,RectangleF,GraphicsUnit,ImageAttributes);

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(Image,RectangleF,RectangleF,GraphicsUnit);

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(Image,RectangleF,RectangleF,GraphicsUnit,ImageAttributes);

Draws the specified image, using its original physical size, at the location specified by a coordinate pair.

public void DrawImage(Image,int,int);

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(Image,int,int,int,int);

Draws the specified Image, using its original physical size, at the specified location.

public void DrawImage(Image,float,float);

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(Image,float,float,float,float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawImage Method (Image, Point)

Draws the specified Image, using its original physical size, at the specified location.

public void DrawImage(
Image sourceImage,
Point point
);

Parameters

sourceImage
The image to draw with.
point
Point structure that represents the location of the upper-left corner of the drawn image.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Point[])

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(
Image image,
Point[] destPoints
);

Parameters

image
The image to draw.
destPoints
Array of three PointF structures that define a parallelogram.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Point[], Rectangle)

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(
Image image,
Point[] destPoints,
Rectangle srcRect
);

Parameters

image
The image to draw.
destPoints
Array of three PointF structures that define a parallelogram.
srcRect
The source rectangle.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit
);

Parameters

image
The image to draw.
destPoints
Array of three PointF structures that define a parallelogram.
srcRect
The source rectangle.
srcUnit
The units of measure.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttributes
);

Parameters

image
The image to draw.
destPoints
Array of three PointF structures that define a parallelogram.
srcRect
The source rectangle.
srcUnit
The units of measure.
imageAttributes
The image attributes.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, PointF)

Draws the specified Image, using its original physical size, at the specified location.

public void DrawImage(
Image sourceImage,
PointF point
);

Parameters

sourceImage
The image to draw with.
point
PointF structure that represents the upper-left corner of the drawn image.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, PointF[])

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(
Image image,
PointF[] destPoints
);

Parameters

image
The image to draw.
destPoints
Array of three PointF structures that define a parallelogram.

Exceptions

Exception Type | Condition
ArgumentNullException | image

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, PointF[], RectangleF)

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(
Image image,
PointF[] destPoints,
RectangleF srcRect
);

Parameters

image
The image to draw.
destPoints
Array of three PointF structures that define a parallelogram.
srcRect
The source rectangle.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit
);

Parameters

image
The image to draw.
destPoints
Array of three PointF structures that define a parallelogram.
srcRect
The source rectangle.
srcUnit
The units of measure.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)

Draws the specified portion of the specified image at the specified location and with the specified size.

public void DrawImage(
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttributes
);

Parameters

image
The image to draw.
destPoints
Array of three PointF structures that define a parallelogram.
srcRect
The source rectangle.
srcUnit
The units of measure.
imageAttributes
The image attributes.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Rectangle)

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(
Image sourceImage,
Rectangle rect
);

Parameters

sourceImage
The image to draw with.
rect
Rectangle structure that specifies the location and size of the drawn image.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Rectangle, GraphicsUnit)

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(
Image sourceImage,
Rectangle rectDestination,
GraphicsUnit graphicsUnit
);

Parameters

sourceImage
The image to draw with.
rectDestination
The destination rectangle.
graphicsUnit
The graphics unit.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Rectangle, GraphicsUnit, ImageAttributes)

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(
Image sourceImage,
Rectangle rectDestination,
GraphicsUnit graphicsUnit,
ImageAttributes imageAttributes
);

Parameters

sourceImage
The image to draw with.
rectDestination
The destination rectangle.
graphicsUnit
The graphics unit.
imageAttributes
The image attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(
Image sourceImage,
Rectangle rectSource,
Rectangle rectDestination,
GraphicsUnit graphicsUnit
);

Parameters

sourceImage
The image to draw with.
rectSource
The rect source.
rectDestination
The rect destination.
graphicsUnit
The graphics unit.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit, ImageAttributes)

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(
Image sourceImage,
Rectangle rectSource,
Rectangle rectDestination,
GraphicsUnit graphicsUnit,
ImageAttributes imageAttributes
);

Parameters

sourceImage
The image to draw with.
rectSource
The rect source.
rectDestination
The rect destination.
graphicsUnit
The graphics unit.
imageAttributes
The image attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, RectangleF)

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(
Image sourceImage,
RectangleF rect
);

Parameters

sourceImage
The image to draw with.
rect
RectangleF structure that specifies the location and size of the drawn image.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, RectangleF, GraphicsUnit)

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(
Image sourceImage,
RectangleF rectDestination,
GraphicsUnit graphicsUnit
);

Parameters

sourceImage
The image to draw with.
rectDestination
The destination rectangle.
graphicsUnit
The graphics unit.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, RectangleF, GraphicsUnit, ImageAttributes)

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(
Image sourceImage,
RectangleF rectDestination,
GraphicsUnit graphicsUnit,
ImageAttributes imageAttributes
);

Parameters

sourceImage
The image to draw with.
rectDestination
The destination rectangle to draw in.
graphicsUnit
The graphics unit.
imageAttributes
The image attributes.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(
Image sourceImage,
RectangleF rectSource,
RectangleF rectDestination,
GraphicsUnit graphicsUnit
);

Parameters

sourceImage
The image to draw with.
rectSource
The rect source.
rectDestination
The rect destination.
graphicsUnit
The graphics unit.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit, ImageAttributes)

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(
Image sourceImage,
RectangleF rectSource,
RectangleF rectDestination,
GraphicsUnit graphicsUnit,
ImageAttributes imageAttributes
);

Parameters

sourceImage
The image to draw with.
rectSource
The source rectangle.
rectDestination
The destination rectangle.
graphicsUnit
The graphics unit to use.
imageAttributes
The image attributes to use.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Int32, Int32)

Draws the specified image, using its original physical size, at the location specified by a coordinate pair.

public void DrawImage(
Image sourceImage,
int x,
int y
);

Parameters

sourceImage
The image to draw with.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(
Image sourceImage,
int x,
int y,
int width,
int height
);

Parameters

sourceImage
The image to draw with.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
Width of the drawn image.
height
Height of the drawn image.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Single, Single)

Draws the specified Image, using its original physical size, at the specified location.

public void DrawImage(
Image sourceImage,
float x,
float y
);

Parameters

sourceImage
The image to draw with.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


Graphics.DrawImage Method (Image, Single, Single, Single, Single)

Draws the specified Image at the specified location and with the specified size.

public void DrawImage(
Image sourceImage,
float x,
float y,
float width,
float height
);

Parameters

sourceImage
The image to draw with.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
Width of the drawn image.
height
Height of the drawn image.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImage Overload List


DrawImageUnscaled Method

Aspose.Imaging Documentation

Graphics.DrawImageUnscaled Method

Draws a specified image using its original physical size at a specified location.

Overload List

Draws a specified image using its original physical size at a specified location.

public void DrawImageUnscaled(Image,Point);

Draws a specified image using its original physical size at a specified location.

public void DrawImageUnscaled(Image,Rectangle);

Draws the specified image using its original physical size at the location specified by a coordinate pair.

public void DrawImageUnscaled(Image,int,int);

Draws a specified image using its original physical size at a specified location.

public void DrawImageUnscaled(Image,int,int,int,int);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawImageUnscaled Method (Image, Point)

Draws a specified image using its original physical size at a specified location.

public void DrawImageUnscaled(
Image sourceImage,
Point point
);

Parameters

sourceImage
The image to draw with.
point
Point structure that specifies the upper-left corner of the drawn image.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImageUnscaled Overload List


Graphics.DrawImageUnscaled Method (Image, Rectangle)

Draws a specified image using its original physical size at a specified location.

public void DrawImageUnscaled(
Image sourceImage,
Rectangle rect
);

Parameters

sourceImage
The image to draw with.
rect
Rectangle that specifies the upper-left corner of the drawn image. The X and Y properties of the rectangle specify the upper-left corner. The Width and Height properties are ignored.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImageUnscaled Overload List


Graphics.DrawImageUnscaled Method (Image, Int32, Int32)

Draws the specified image using its original physical size at the location specified by a coordinate pair.

public void DrawImageUnscaled(
Image sourceImage,
int x,
int y
);

Parameters

sourceImage
The image to draw with.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImageUnscaled Overload List


Graphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)

Draws a specified image using its original physical size at a specified location.

public void DrawImageUnscaled(
Image sourceImage,
int x,
int y,
int width,
int height
);

Parameters

sourceImage
The image to draw with.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The parameter is not used.
height
The parameter is not used.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawImageUnscaled Overload List


Graphics.DrawImageUnscaledAndClipped Method

Draws the specified image without scaling and clips it, if necessary, to fit in the specified rectangle.

public void DrawImageUnscaledAndClipped(
Image sourceImage,
Rectangle rect
);

Parameters

sourceImage
The image to draw with.
rect
The Rectangle in which to draw the image.

Exceptions

Exception Type | Condition
ArgumentNullException | sourceImage is null.

See Also

Graphics Class | Aspose.Imaging Namespace


DrawLine Method

Aspose.Imaging Documentation

Graphics.DrawLine Method

Draws a line connecting two Point structures.

Overload List

Draws a line connecting two Point structures.

public void DrawLine(Pen,Point,Point);

Draws a line connecting two PointF structures.

public void DrawLine(Pen,PointF,PointF);

Draws a line connecting the two points specified by the coordinate pairs.

public void DrawLine(Pen,int,int,int,int);

Draws a line connecting the two points specified by the coordinate pairs.

public void DrawLine(Pen,float,float,float,float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawLine Method (Pen, Point, Point)

Draws a line connecting two Point structures.

public void DrawLine(
Pen pen,
Point point1,
Point point2
);

Parameters

pen
Pen that determines the color, width, and style of the line.
point1
Point structure that represents the first point to connect.
point2
Point structure that represents the second point to connect.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawLine Overload List


Graphics.DrawLine Method (Pen, PointF, PointF)

Draws a line connecting two PointF structures.

public void DrawLine(
Pen pen,
PointF point1,
PointF point2
);

Parameters

pen
Pen that determines the color, width, and style of the line.
point1
PointF structure that represents the first point to connect.
point2
PointF structure that represents the second point to connect.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawLine Overload List


Graphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)

Draws a line connecting the two points specified by the coordinate pairs.

public void DrawLine(
Pen pen,
int x1,
int y1,
int x2,
int y2
);

Parameters

pen
Pen that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawLine Overload List


Graphics.DrawLine Method (Pen, Single, Single, Single, Single)

Draws a line connecting the two points specified by the coordinate pairs.

public void DrawLine(
Pen pen,
float x1,
float y1,
float x2,
float y2
);

Parameters

pen
Pen that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawLine Overload List


DrawLines Method

Aspose.Imaging Documentation

Graphics.DrawLines Method

Draws a series of line segments that connect an array of Point structures.

Overload List

Draws a series of line segments that connect an array of Point structures.

public void DrawLines(Pen,Point[]);

Draws a series of line segments that connect an array of PointF structures.

public void DrawLines(Pen,PointF[]);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawLines Method (Pen, Point[])

Draws a series of line segments that connect an array of Point structures.

public void DrawLines(
Pen pen,
Point[] points
);

Parameters

pen
Pen that determines the color, width, and style of the line segments.
points
Array of Point structures that represent the points to connect.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.
ArgumentException | The points array contains less than 2 points.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawLines Overload List


Graphics.DrawLines Method (Pen, PointF[])

Draws a series of line segments that connect an array of PointF structures.

public void DrawLines(
Pen pen,
PointF[] points
);

Parameters

pen
Pen that determines the color, width, and style of the line segments.
points
Array of PointF structures that represent the points to connect.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.
ArgumentException | The points array contains less than 2 points.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawLines Overload List


Graphics.DrawPath Method

Draws a GraphicsPath.

public void DrawPath(
Pen pen,
GraphicsPath path
);

Parameters

pen
Pen that determines the color, width, and style of the path.
path
GraphicsPath to draw.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- path is null.

Example

This examples make use of GraphicsPath and Graphics class to create and manipulate Figures on an Image surface. Example creates a new Image (of type Tiff) and draw paths with the help of GraphicsPath class. At the end DrawPath method exposed by Graphics class is called to render the paths on surface.

[C#]

//Create an instance of FileStream
using (System.IO.FileStream stream = new System.IO.FileStream(@"C:\temp\output.tiff", System.IO.FileMode.Create))
{
    //Create an instance of TiffOptions and set its various properties
    Aspose.Imaging.ImageOptions.TiffOptions tiffOptions = new Aspose.Imaging.ImageOptions.TiffOptions();

    //Set the source for the instance of ImageOptions
    tiffOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(tiffOptions, 500, 500))
    {
        //Create and initialize an instance of Graphics class
        Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

        //Clear Graphics surface
        graphics.Clear(Color.Wheat);

        //Create an instance of GraphicsPath class
        Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

        //Create an instance of Figure class
        Aspose.Imaging.Figure figure = new Aspose.Imaging.Figure();

        //Add Shapes to Figure object
        figure.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new RectangleF(10, 10, 300, 300)));
        figure.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
        figure.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(250, 250), new Size(200, 200)), 0, 45));

        //Add Figure object to GraphicsPath
        graphicspath.AddFigure(figure);

        //Draw path with Pen object of color Black
        graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

        // save all changes.
        image.Save();
    }
}
[Visual Basic]

'Create an instance of FileStream
Using stream As System.IO.FileStream = New System.IO.FileStream("C:\temp\output.tiff", System.IO.FileMode.Create)
'Create an instance of TiffOptions and set its various properties
Dim tiffOptions As Aspose.Imaging.ImageOptions.TiffOptions = New Aspose.Imaging.ImageOptions.TiffOptions()

'Set the source for the instance of ImageOptions
    tiffOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(tiffOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
        graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shapes to Figure object
        figure.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New RectangleF(10, 10, 300, 300)))
        figure.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
        figure.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(250, 250), New Size(200, 200)), 0, 45))

'Add Figure object to GraphicsPath
        graphicspath.AddFigure(figure)

'Draw path with Pen object of color Black
        graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
        image.Save()
    End Using
End Using

See Also

Graphics Class | Aspose.Imaging Namespace


DrawPie Method

Aspose.Imaging Documentation

Graphics.DrawPie Method

Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.

Overload List

Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.

public void DrawPie(Pen,Rectangle,float,float);

Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.

public void DrawPie(Pen,RectangleF,float,float);

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.

public void DrawPie(Pen,int,int,int,int,int,int);

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.

public void DrawPie(Pen,float,float,float,float,float,float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawPie Method (Pen, Rectangle, Single, Single)

Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.

public void DrawPie(
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
);

Parameters

pen
Pen that determines the color, width, and style of the pie shape.
rect
Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawPie Overload List


Graphics.DrawPie Method (Pen, RectangleF, Single, Single)

Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.

public void DrawPie(
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
);

Parameters

pen
Pen that determines the color, width, and style of the pie shape.
rect
RectangleF structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawPie Overload List


Graphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.

public void DrawPie(
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
);

Parameters

pen
Pen that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawPie Overload List


Graphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.

public void DrawPie(
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
);

Parameters

pen
Pen that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawPie Overload List


DrawPolygon Method

Aspose.Imaging Documentation

Graphics.DrawPolygon Method

Draws a polygon defined by an array of Point structures.

Overload List

Draws a polygon defined by an array of Point structures.

public void DrawPolygon(Pen,Point[]);

Draws a polygon defined by an array of PointF structures.

public void DrawPolygon(Pen,PointF[]);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawPolygon Method (Pen, Point[])

Draws a polygon defined by an array of Point structures.

public void DrawPolygon(
Pen pen,
Point[] points
);

Parameters

pen
Pen that determines the color, width, and style of the polygon.
points
Array of Point structures that represent the vertices of the polygon.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawPolygon Overload List


Graphics.DrawPolygon Method (Pen, PointF[])

Draws a polygon defined by an array of PointF structures.

public void DrawPolygon(
Pen pen,
PointF[] points
);

Parameters

pen
Pen that determines the color, width, and style of the polygon.
points
Array of PointF structures that represent the vertices of the polygon.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawPolygon Overload List


DrawRectangle Method

Aspose.Imaging Documentation

Graphics.DrawRectangle Method

Draws a rectangle specified by a Rectangle structure.

Overload List

Draws a rectangle specified by a Rectangle structure.

public void DrawRectangle(Pen,Rectangle);

Draws a rectangle specified by a RectangleF structure.

public void DrawRectangle(Pen,RectangleF);

Draws a rectangle specified by a coordinate pair, a width, and a height.

public void DrawRectangle(Pen,int,int,int,int);

Draws a rectangle specified by a coordinate pair, a width, and a height.

public void DrawRectangle(Pen,float,float,float,float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawRectangle Method (Pen, Rectangle)

Draws a rectangle specified by a Rectangle structure.

public void DrawRectangle(
Pen pen,
Rectangle rect
);

Parameters

pen
A Pen that determines the color, width, and style of the rectangle.
rect
A Rectangle structure that represents the rectangle to draw.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawRectangle Overload List


Graphics.DrawRectangle Method (Pen, RectangleF)

Draws a rectangle specified by a RectangleF structure.

public void DrawRectangle(
Pen pen,
RectangleF rect
);

Parameters

pen
A Pen that determines the color, width, and style of the rectangle.
rect
A RectangleF structure that represents the rectangle to draw.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawRectangle Overload List


Graphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)

Draws a rectangle specified by a coordinate pair, a width, and a height.

public void DrawRectangle(
Pen pen,
int x,
int y,
int width,
int height
);

Parameters

pen
Pen that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawRectangle Overload List


Graphics.DrawRectangle Method (Pen, Single, Single, Single, Single)

Draws a rectangle specified by a coordinate pair, a width, and a height.

public void DrawRectangle(
Pen pen,
float x,
float y,
float width,
float height
);

Parameters

pen
A Pen that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawRectangle Overload List


DrawRectangles Method

Aspose.Imaging Documentation

Graphics.DrawRectangles Method

Draws a series of rectangles specified by Rectangle structures.

Overload List

Draws a series of rectangles specified by Rectangle structures.

public void DrawRectangles(Pen,Rectangle[]);

Draws a series of rectangles specified by RectangleF structures.

public void DrawRectangles(Pen,RectangleF[]);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawRectangles Method (Pen, Rectangle[])

Draws a series of rectangles specified by Rectangle structures.

public void DrawRectangles(
Pen pen,
Rectangle[] rects
);

Parameters

pen
Pen that determines the color, width, and style of the outlines of the rectangles.
rects
Array of Rectangle structures that represent the rectangles to draw.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- rects is null.

Example

This example shows the creation and usage Pen objects. The example creates a new Image and draw Rectangles on Image surface.

[C#]

//Create an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"C:\temp\sample.bmp", false);

//Create an instance of Image at specified Path
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Create an instance of Graphics and initialize it with Image object
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clear the Graphics sutface with White Color
    graphics.Clear(Aspose.Imaging.Color.White);

    //Create an instance of Pen with color Red and width 5
    Aspose.Imaging.Pen pen = new Pen(Aspose.Imaging.Color.Red, 5);

    //Create an instance of HatchBrush and set its properties
    Aspose.Imaging.Brushes.HatchBrush brush = new HatchBrush();
    brush.BackgroundColor = Color.Wheat;
    brush.ForegroundColor = Color.Red;

    //Create an instance of Pen
    //initialize it with HatchBrush object and width
    Aspose.Imaging.Pen brusedpen = new Pen(brush, 5);

    //Draw Rectangles by specifying Pen object
    graphics.DrawRectangles(pen, new[] { new Rectangle(new Point(210, 210), new Size(100, 100)), new Rectangle(new Point(110, 110), new Size(100, 100)), new Rectangle(new Point(310, 310), new Size(100, 100)) });

    //Draw Rectangles by specifying Pen object
    graphics.DrawRectangles(brusedpen, new[] { new Rectangle(new Point(310, 110), new Size(100, 100)), new Rectangle(new Point(110, 310), new Size(100, 100)) });

    // save all changes.
    image.Save();
}
[Visual Basic]

'Create an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("C:\temp\sample.bmp", False)

'Create an instance of Image at specified Path
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Create an instance of Graphics and initialize it with Image object
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear the Graphics sutface with White Color
    graphics.Clear(Aspose.Imaging.Color.White)

'Create an instance of Pen with color Red and width 5
Dim pen As Aspose.Imaging.Pen = New Pen(Aspose.Imaging.Color.Red, 5)

'Create an instance of HatchBrush and set its properties
Dim brush As Aspose.Imaging.Brushes.HatchBrush = New HatchBrush()
    brush.BackgroundColor = Color.Wheat
    brush.ForegroundColor = Color.Red

'Create an instance of Pen
'initialize it with HatchBrush object and width
Dim brusedpen As Aspose.Imaging.Pen = New Pen(brush, 5)

'Draw Rectangles by specifying Pen object
    graphics.DrawRectangles(pen, New() { New Rectangle(New Point(210, 210), New Size(100, 100)), New Rectangle(New Point(110, 110), New Size(100, 100)), New Rectangle(New Point(310, 310), New Size(100, 100)) })

'Draw Rectangles by specifying Pen object
    graphics.DrawRectangles(brusedpen, New() { New Rectangle(New Point(310, 110), New Size(100, 100)), New Rectangle(New Point(110, 310), New Size(100, 100)) })

' save all changes.
    image.Save()
End Using

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawRectangles Overload List


Graphics.DrawRectangles Method (Pen, RectangleF[])

Draws a series of rectangles specified by RectangleF structures.

public void DrawRectangles(
Pen pen,
RectangleF[] rects
);

Parameters

pen
Pen that determines the color, width, and style of the outlines of the rectangles.
rects
Array of RectangleF structures that represent the rectangles to draw.

Exceptions

Exception Type | Condition
ArgumentNullException | pen is null. -or- rects is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawRectangles Overload List


DrawString Method

Aspose.Imaging Documentation

Graphics.DrawString Method

Draws the specified text string at the specified location with the specified Brush and Font objects.

Overload List

Draws the specified text string at the specified location with the specified Brush and Font objects.

public void DrawString(string,Font,Brush,PointF);

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat.

public void DrawString(string,Font,Brush,PointF,StringFormat);

Draws the specified text string in the specified rectangle with the specified Brush and Font objects.

public void DrawString(string,Font,Brush,RectangleF);

Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat.

public void DrawString(string,Font,Brush,RectangleF,StringFormat);

Draws the specified text string at the specified location with the specified Brush and Font objects.

public void DrawString(string,Font,Brush,float,float);

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat.

public void DrawString(string,Font,Brush,float,float,StringFormat);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.DrawString Method (String, Font, Brush, PointF)

Draws the specified text string at the specified location with the specified Brush and Font objects.

public void DrawString(
string s,
Font font,
Brush brush,
PointF point
);

Parameters

s
String to draw.
font
Font that defines the text format of the string.
brush
Brush that determines the color and texture of the drawn text.
point
PointF structure that specifies the upper-left corner of the drawn text.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- s is null.

Example

This example demonstrates the use of Font and SolidBrush class to draw strings on Image surface. The example creates a new Image and draw shapes using Figures and GraphicsPath

[C#]

//Creates an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"C:\temp\sample.bmp", false);

//Creates an instance of Image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Creates and initialize an instance of Graphics class
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clears Graphics surface
    graphics.Clear(Color.Wheat);

    //Creates an instance of Font
    Aspose.Imaging.Font font = new Aspose.Imaging.Font("Times New Roman", 16);

    //Create an instance of SolidBrush having Red Color
    Aspose.Imaging.Brushes.SolidBrush brush = new Aspose.Imaging.Brushes.SolidBrush(Color.Red);

    //Draw a String
    graphics.DrawString("Created by Aspose.Imaging for .Net", font, brush, new PointF(100, 100));

    // save all changes
    image.Save();
}
[Visual Basic]

'Creates an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("C:\temp\sample.bmp", False)

'Creates an instance of Image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Creates and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clears Graphics surface
    graphics.Clear(Color.Wheat)

'Creates an instance of Font
Dim font As Aspose.Imaging.Font = New Aspose.Imaging.Font("Times New Roman", 16)

'Create an instance of SolidBrush having Red Color
Dim brush As Aspose.Imaging.Brushes.SolidBrush = New Aspose.Imaging.Brushes.SolidBrush(Color.Red)

'Draw a String
    graphics.DrawString("Created by Aspose.Imaging for .Net", font, brush, New PointF(100, 100))

' save all changes
    image.Save()
End Using

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawString Overload List


Graphics.DrawString Method (String, Font, Brush, PointF, StringFormat)

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat.

public void DrawString(
string s,
Font font,
Brush brush,
PointF point,
StringFormat format
);

Parameters

s
String to draw.
font
Font that defines the text format of the string.
brush
Brush that determines the color and texture of the drawn text.
point
PointF structure that specifies the upper-left corner of the drawn text.
format
StringFormat that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- s is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawString Overload List


Graphics.DrawString Method (String, Font, Brush, RectangleF)

Draws the specified text string in the specified rectangle with the specified Brush and Font objects.

public void DrawString(
string s,
Font font,
Brush brush,
RectangleF layoutRectangle
);

Parameters

s
String to draw.
font
Font that defines the text format of the string.
brush
Brush that determines the color and texture of the drawn text.
layoutRectangle
RectangleF structure that specifies the location of the drawn text.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- s is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawString Overload List


Graphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)

Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat.

public void DrawString(
string s,
Font font,
Brush brush,
RectangleF layoutRectangle,
StringFormat format
);

Parameters

s
String to draw.
font
Font that defines the text format of the string.
brush
Brush that determines the color and texture of the drawn text.
layoutRectangle
RectangleF structure that specifies the location of the drawn text.
format
StringFormat that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- s is null. -or- brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawString Overload List


Graphics.DrawString Method (String, Font, Brush, Single, Single)

Draws the specified text string at the specified location with the specified Brush and Font objects.

public void DrawString(
string s,
Font font,
Brush brush,
float x,
float y
);

Parameters

s
String to draw.
font
Font that defines the text format of the string.
brush
Brush that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- s is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawString Overload List


Graphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat.

public void DrawString(
string s,
Font font,
Brush brush,
float x,
float y,
StringFormat format
);

Parameters

s
String to draw.
font
Font that defines the text format of the string.
brush
Brush that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.
format
StringFormat that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- s is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.DrawString Overload List


Graphics.EndUpdate Method

Finishes caching of the graphics operations started after BeginUpdate was called. The preceding graphics operations will be applied at once when calling this method.

public void EndUpdate();

See Also

Graphics Class | Aspose.Imaging Namespace


FillClosedCurve Method

Aspose.Imaging Documentation

Graphics.FillClosedCurve Method

Fills the interior of a closed cardinal spline curve defined by an array of Point structures. This method uses a default tension of 0.5 and Alternate fill mode.

Overload List

Fills the interior of a closed cardinal spline curve defined by an array of Point structures. This method uses a default tension of 0.5 and Alternate fill mode.

public void FillClosedCurve(Brush,Point[]);

Fills the interior of a closed cardinal spline curve defined by an array of Point structures using the specified fill mode. This method uses a default tension of 0.5.

public void FillClosedCurve(Brush,Point[],FillMode);

Fills the interior of a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.

public void FillClosedCurve(Brush,Point[],FillMode,float);

Fills the interior of a closed cardinal spline curve defined by an array of PointF structures. This method uses a default tension of 0.5 and Alternate fill mode.

public void FillClosedCurve(Brush,PointF[]);

Fills the interior of a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode. This method uses a default tension of 0.5.

public void FillClosedCurve(Brush,PointF[],FillMode);

Fills the interior of a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

public void FillClosedCurve(Brush,PointF[],FillMode,float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.FillClosedCurve Method (Brush, Point[])

Fills the interior of a closed cardinal spline curve defined by an array of Point structures. This method uses a default tension of 0.5 and Alternate fill mode.

public void FillClosedCurve(
Brush brush,
Point[] points
);

Parameters

brush
Brush that determines the characteristics of the fill.
points
Array of Point structures that define the spline.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillClosedCurve Overload List


Graphics.FillClosedCurve Method (Brush, Point[], FillMode)

Fills the interior of a closed cardinal spline curve defined by an array of Point structures using the specified fill mode. This method uses a default tension of 0.5.

public void FillClosedCurve(
Brush brush,
Point[] points,
FillMode fillmode
);

Parameters

brush
Brush that determines the characteristics of the fill.
points
Array of Point structures that define the spline.
fillmode
Member of the FillMode enumeration that determines how the curve is filled.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillClosedCurve Overload List


Graphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)

Fills the interior of a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.

public void FillClosedCurve(
Brush brush,
Point[] points,
FillMode fillmode,
float tension
);

Parameters

brush
Brush that determines the characteristics of the fill.
points
Array of Point structures that define the spline.
fillmode
Member of the FillMode enumeration that determines how the curve is filled.
tension
Value greater than or equal to 0.0F that specifies the tension of the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillClosedCurve Overload List


Graphics.FillClosedCurve Method (Brush, PointF[])

Fills the interior of a closed cardinal spline curve defined by an array of PointF structures. This method uses a default tension of 0.5 and Alternate fill mode.

public void FillClosedCurve(
Brush brush,
PointF[] points
);

Parameters

brush
Brush that determines the characteristics of the fill.
points
Array of PointF structures that define the spline.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillClosedCurve Overload List


Graphics.FillClosedCurve Method (Brush, PointF[], FillMode)

Fills the interior of a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode. This method uses a default tension of 0.5.

public void FillClosedCurve(
Brush brush,
PointF[] points,
FillMode fillmode
);

Parameters

brush
Brush that determines the characteristics of the fill.
points
Array of PointF structures that define the spline.
fillmode
Member of the FillMode enumeration that determines how the curve is filled.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillClosedCurve Overload List


Graphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)

Fills the interior of a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

public void FillClosedCurve(
Brush brush,
PointF[] points,
FillMode fillmode,
float tension
);

Parameters

brush
A Brush that determines the characteristics of the fill.
points
Array of PointF structures that define the spline.
fillmode
Member of the FillMode enumeration that determines how the curve is filled.
tension
Value greater than or equal to 0.0F that specifies the tension of the curve.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillClosedCurve Overload List


FillEllipse Method

Aspose.Imaging Documentation

Graphics.FillEllipse Method

Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.

Overload List

Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.

public void FillEllipse(Brush,Rectangle);

Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.

public void FillEllipse(Brush,RectangleF);

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

public void FillEllipse(Brush,int,int,int,int);

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

public void FillEllipse(Brush,float,float,float,float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.FillEllipse Method (Brush, Rectangle)

Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.

public void FillEllipse(
Brush brush,
Rectangle rect
);

Parameters

brush
Brush that determines the characteristics of the fill.
rect
Rectangle structure that represents the bounding rectangle that defines the ellipse.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillEllipse Overload List


Graphics.FillEllipse Method (Brush, RectangleF)

Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.

public void FillEllipse(
Brush brush,
RectangleF rect
);

Parameters

brush
Brush that determines the characteristics of the fill.
rect
RectangleF structure that represents the bounding rectangle that defines the ellipse.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillEllipse Overload List


Graphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

public void FillEllipse(
Brush brush,
int x,
int y,
int width,
int height
);

Parameters

brush
Brush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillEllipse Overload List


Graphics.FillEllipse Method (Brush, Single, Single, Single, Single)

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

public void FillEllipse(
Brush brush,
float x,
float y,
float width,
float height
);

Parameters

brush
Brush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillEllipse Overload List


Graphics.FillPath Method

Fills the interior of a GraphicsPath.

public void FillPath(
Brush brush,
GraphicsPath path
);

Parameters

brush
Brush that determines the characteristics of the fill.
path
GraphicsPath that represents the path to fill.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- path is null.

See Also

Graphics Class | Aspose.Imaging Namespace


FillPie Method

Aspose.Imaging Documentation

Graphics.FillPie Method

Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.

Overload List

Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.

public void FillPie(Brush,Rectangle,float,float);

Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.

public void FillPie(Brush,RectangleF,float,float);

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, a height, and two radial lines.

public void FillPie(Brush,int,int,int,int,int,int);

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, a height, and two radial lines.

public void FillPie(Brush,float,float,float,float,float,float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.FillPie Method (Brush, Rectangle, Single, Single)

Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.

public void FillPie(
Brush brush,
Rectangle rect,
float startAngle,
float sweepAngle
);

Parameters

brush
Brush that determines the characteristics of the fill.
rect
Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
Angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillPie Overload List


Graphics.FillPie Method (Brush, RectangleF, Single, Single)

Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.

public void FillPie(
Brush brush,
RectangleF rect,
float startAngle,
float sweepAngle
);

Parameters

brush
Brush that determines the characteristics of the fill.
rect
RectangleF structure that represents the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
Angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillPie Overload List


Graphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, a height, and two radial lines.

public void FillPie(
Brush brush,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
);

Parameters

brush
Brush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
Angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillPie Overload List


Graphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, a height, and two radial lines.

public void FillPie(
Brush brush,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
);

Parameters

brush
Brush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
Angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillPie Overload List


FillPolygon Method

Aspose.Imaging Documentation

Graphics.FillPolygon Method

Fills the interior of a polygon defined by an array of points specified by Point structures and Alternate.

Overload List

Fills the interior of a polygon defined by an array of points specified by Point structures and Alternate.

public void FillPolygon(Brush,Point[]);

Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.

public void FillPolygon(Brush,Point[],FillMode);

Fills the interior of a polygon defined by an array of points specified by PointF structures and Alternate.

public void FillPolygon(Brush,PointF[]);

Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

public void FillPolygon(Brush,PointF[],FillMode);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.FillPolygon Method (Brush, Point[])

Fills the interior of a polygon defined by an array of points specified by Point structures and Alternate.

public void FillPolygon(
Brush brush,
Point[] points
);

Parameters

brush
Brush that determines the characteristics of the fill.
points
Array of Point structures that represent the vertices of the polygon to fill.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillPolygon Overload List


Graphics.FillPolygon Method (Brush, Point[], FillMode)

Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.

public void FillPolygon(
Brush brush,
Point[] points,
FillMode fillMode
);

Parameters

brush
Brush that determines the characteristics of the fill.
points
Array of Point structures that represent the vertices of the polygon to fill.
fillMode
Member of the FillMode enumeration that determines the style of the fill.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillPolygon Overload List


Graphics.FillPolygon Method (Brush, PointF[])

Fills the interior of a polygon defined by an array of points specified by PointF structures and Alternate.

public void FillPolygon(
Brush brush,
PointF[] points
);

Parameters

brush
Brush that determines the characteristics of the fill.
points
Array of PointF structures that represent the vertices of the polygon to fill.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillPolygon Overload List


Graphics.FillPolygon Method (Brush, PointF[], FillMode)

Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

public void FillPolygon(
Brush brush,
PointF[] points,
FillMode fillMode
);

Parameters

brush
Brush that determines the characteristics of the fill.
points
Array of PointF structures that represent the vertices of the polygon to fill.
fillMode
Member of the FillMode enumeration that determines the style of the fill.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- points is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillPolygon Overload List


FillRectangle Method

Aspose.Imaging Documentation

Graphics.FillRectangle Method

Fills the interior of a rectangle specified by a Rectangle structure.

Overload List

Fills the interior of a rectangle specified by a Rectangle structure.

public void FillRectangle(Brush,Rectangle);

Fills the interior of a rectangle specified by a RectangleF structure.

public void FillRectangle(Brush,RectangleF);

Fills the interior of a rectangle specified by a pair of coordinates, a width and a height.

public void FillRectangle(Brush,int,int,int,int);

Fills the interior of a rectangle specified by a pair of coordinates, a width and a height.

public void FillRectangle(Brush,float,float,float,float);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.FillRectangle Method (Brush, Rectangle)

Fills the interior of a rectangle specified by a Rectangle structure.

public void FillRectangle(
Brush brush,
Rectangle rect
);

Parameters

brush
Brush that determines the characteristics of the fill.
rect
Rectangle structure that represents the rectangle to fill.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillRectangle Overload List


Graphics.FillRectangle Method (Brush, RectangleF)

Fills the interior of a rectangle specified by a RectangleF structure.

public void FillRectangle(
Brush brush,
RectangleF rect
);

Parameters

brush
Brush that determines the characteristics of the fill.
rect
RectangleF structure that represents the rectangle to fill.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillRectangle Overload List


Graphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)

Fills the interior of a rectangle specified by a pair of coordinates, a width and a height.

public void FillRectangle(
Brush brush,
int x,
int y,
int width,
int height
);

Parameters

brush
Brush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
Width of the rectangle to fill.
height
Height of the rectangle to fill.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillRectangle Overload List


Graphics.FillRectangle Method (Brush, Single, Single, Single, Single)

Fills the interior of a rectangle specified by a pair of coordinates, a width and a height.

public void FillRectangle(
Brush brush,
float x,
float y,
float width,
float height
);

Parameters

brush
Brush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
Width of the rectangle to fill.
height
Height of the rectangle to fill.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillRectangle Overload List


FillRectangles Method

Aspose.Imaging Documentation

Graphics.FillRectangles Method

Fills the interiors of a series of rectangles specified by Rectangle structures.

Overload List

Fills the interiors of a series of rectangles specified by Rectangle structures.

public void FillRectangles(Brush,Rectangle[]);

Fills the interiors of a series of rectangles specified by RectangleF structures.

public void FillRectangles(Brush,RectangleF[]);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.FillRectangles Method (Brush, Rectangle[])

Fills the interiors of a series of rectangles specified by Rectangle structures.

public void FillRectangles(
Brush brush,
Rectangle[] rects
);

Parameters

brush
Brush that determines the characteristics of the fill.
rects
Array of Rectangle structures that represent the rectangles to fill.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null or rects is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillRectangles Overload List


Graphics.FillRectangles Method (Brush, RectangleF[])

Fills the interiors of a series of rectangles specified by RectangleF structures.

public void FillRectangles(
Brush brush,
RectangleF[] rects
);

Parameters

brush
Brush that determines the characteristics of the fill.
rects
Array of Rectangle structures that represent the rectangles to fill.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null or rects is null.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.FillRectangles Overload List


Graphics.FillRegion Method

Fills the interior of a Region.

public void FillRegion(
Brush brush,
Region region
);

Parameters

brush
Brush that determines the characteristics of the fill.
region
Region that represents the area to fill.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null. -or- region is null.

See Also

Graphics Class | Aspose.Imaging Namespace


MultiplyTransform Method

Aspose.Imaging Documentation

Graphics.MultiplyTransform Method

Multiplies the Matrix that represents the local geometric transform of this Graphics by the specified Matrix by prepending the specified Matrix.

Overload List

Multiplies the Matrix that represents the local geometric transform of this Graphics by the specified Matrix by prepending the specified Matrix.

public void MultiplyTransform(Matrix);

Multiplies the Matrix that represents the local geometric transform of this Graphics by the specified Matrix in the specified order.

public void MultiplyTransform(Matrix,MatrixOrder);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.MultiplyTransform Method (Matrix)

Multiplies the Matrix that represents the local geometric transform of this Graphics by the specified Matrix by prepending the specified Matrix.

public void MultiplyTransform(
Matrix matrix
);

Parameters

matrix
The Matrix by which to multiply the geometric transform.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.MultiplyTransform Overload List


Graphics.MultiplyTransform Method (Matrix, MatrixOrder)

Multiplies the Matrix that represents the local geometric transform of this Graphics by the specified Matrix in the specified order.

public void MultiplyTransform(
Matrix matrix,
MatrixOrder order
);

Parameters

matrix
The Matrix by which to multiply the geometric transform.
order
A MatrixOrder that specifies in which order to multiply the two matrices.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.MultiplyTransform Overload List


Graphics.ResetTransform Method

Resets the Transform property to identity.

public void ResetTransform();

See Also

Graphics Class | Aspose.Imaging Namespace


RotateTransform Method

Aspose.Imaging Documentation

Graphics.RotateTransform Method

Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.

Overload List

Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.

public void RotateTransform(float);

Rotates the local geometric transform by the specified amount in the specified order.

public void RotateTransform(float,MatrixOrder);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.RotateTransform Method (Single)

Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.

public void RotateTransform(
float angle
);

Parameters

angle
The angle of rotation.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.RotateTransform Overload List


Graphics.RotateTransform Method (Single, MatrixOrder)

Rotates the local geometric transform by the specified amount in the specified order.

public void RotateTransform(
float angle,
MatrixOrder order
);

Parameters

angle
The angle of rotation.
order
A MatrixOrder that specifies whether to append or prepend the rotation matrix.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.RotateTransform Overload List


ScaleTransform Method

Aspose.Imaging Documentation

Graphics.ScaleTransform Method

Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.

Overload List

Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.

public void ScaleTransform(float,float);

Scales the local geometric transform by the specified amounts in the specified order.

public void ScaleTransform(float,float,MatrixOrder);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.ScaleTransform Method (Single, Single)

Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.

public void ScaleTransform(
float sx,
float sy
);

Parameters

sx
The amount by which to scale the transform in the x-axis direction.
sy
The amount by which to scale the transform in the y-axis direction.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.ScaleTransform Overload List


Graphics.ScaleTransform Method (Single, Single, MatrixOrder)

Scales the local geometric transform by the specified amounts in the specified order.

public void ScaleTransform(
float sx,
float sy,
MatrixOrder order
);

Parameters

sx
The amount by which to scale the transform in the x-axis direction.
sy
The amount by which to scale the transform in the y-axis direction.
order
A MatrixOrder that specifies whether to append or prepend the scaling matrix.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.ScaleTransform Overload List


TranslateTransform Method

Aspose.Imaging Documentation

Graphics.TranslateTransform Method

Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

Overload List

Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

public void TranslateTransform(float,float);

Translates the local geometric transform by the specified dimensions in the specified order.

public void TranslateTransform(float,float,MatrixOrder);

See Also

Graphics Class | Aspose.Imaging Namespace


Graphics.TranslateTransform Method (Single, Single)

Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

public void TranslateTransform(
float dx,
float dy
);

Parameters

dx
The value of the translation in x.
dy
The value of the translation in y.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.TranslateTransform Overload List


Graphics.TranslateTransform Method (Single, Single, MatrixOrder)

Translates the local geometric transform by the specified dimensions in the specified order.

public void TranslateTransform(
float dx,
float dy,
MatrixOrder order
);

Parameters

dx
The value of the translation in x.
dy
The value of the translation in y.
order
The order (prepend or append) in which to apply the translation.

See Also

Graphics Class | Aspose.Imaging Namespace | Graphics.TranslateTransform Overload List


GraphicsPath Class

Represents a series of connected lines and curves. This class cannot be inherited.

For a list of all members of this type, see GraphicsPath Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.GraphicsPath

public sealed class GraphicsPath : ObjectWithBounds

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This examples make use of GraphicsPath and Graphics class to create and manipulate Figures on an Image surface. Example creates a new Image (of type Tiff) and draw paths with the help of GraphicsPath class. At the end DrawPath method exposed by Graphics class is called to render the paths on surface.

[C#]

//Create an instance of FileStream
using (System.IO.FileStream stream = new System.IO.FileStream(@"C:\temp\output.tiff", System.IO.FileMode.Create))
{
    //Create an instance of TiffOptions and set its various properties
    Aspose.Imaging.ImageOptions.TiffOptions tiffOptions = new Aspose.Imaging.ImageOptions.TiffOptions();

    //Set the source for the instance of ImageOptions
    tiffOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(tiffOptions, 500, 500))
    {
        //Create and initialize an instance of Graphics class
        Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

        //Clear Graphics surface
        graphics.Clear(Color.Wheat);

        //Create an instance of GraphicsPath class
        Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

        //Create an instance of Figure class
        Aspose.Imaging.Figure figure = new Aspose.Imaging.Figure();

        //Add Shapes to Figure object
        figure.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new RectangleF(10, 10, 300, 300)));
        figure.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
        figure.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(250, 250), new Size(200, 200)), 0, 45));

        //Add Figure object to GraphicsPath
        graphicspath.AddFigure(figure);

        //Draw path with Pen object of color Black
        graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

        // save all changes.
        image.Save();
    }
}
[Visual Basic]

'Create an instance of FileStream
Using stream As System.IO.FileStream = New System.IO.FileStream("C:\temp\output.tiff", System.IO.FileMode.Create)
'Create an instance of TiffOptions and set its various properties
Dim tiffOptions As Aspose.Imaging.ImageOptions.TiffOptions = New Aspose.Imaging.ImageOptions.TiffOptions()

'Set the source for the instance of ImageOptions
    tiffOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(tiffOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
        graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shapes to Figure object
        figure.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New RectangleF(10, 10, 300, 300)))
        figure.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
        figure.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(250, 250), New Size(200, 200)), 0, 45))

'Add Figure object to GraphicsPath
        graphicspath.AddFigure(figure)

'Draw path with Pen object of color Black
        graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
        image.Save()
    End Using
End Using

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GraphicsPath Members | Aspose.Imaging Namespace


GraphicsPath Members

GraphicsPath overview

Public Instance Constructors

GraphicsPath Overloaded. Initializes a new instance of the GraphicsPath class.

Public Instance Properties

Bounds | Gets or sets the object's bounds.
Figures | Gets the path figures.
FillMode | Gets or sets a FillMode enumeration that determines how the interiors of shapes in this GraphicsPath are filled.

Public Instance Methods

AddFigure | Adds a new figure.
AddFigures | Adds new figures.
AddPath | Overloaded. Appends the specified GraphicsPath to this path.
DeepClone | Performs a deep clone of this graphics path.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flatten | Overloaded. Converts each curve in this path into a sequence of connected line segments.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsOutlineVisible | Overloaded. Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen.
IsVisible | Overloaded. Indicates whether the specified point is contained within this GraphicsPath.
RemoveFigure | Removes a figure.
RemoveFigures | Removes figures.
Reset | Empties the graphics path and sets the FillMode to Alternate.
Reverse | Reverses the order of figures, shapes, and points in each shape of this GraphicsPath.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Applies the specified transformation to the shape.
Warp | Overloaded. Applies a warp transform, defined by a rectangle and a parallelogram, to this GraphicsPath.
Widen | Overloaded. Adds an additional outline to the path.

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath Constructor

Initializes a new instance of the GraphicsPath class.

Overload List

Initializes a new instance of the GraphicsPath class.

public GraphicsPath();

Initializes a new instance of the GraphicsPath class.

public GraphicsPath(Figure[]);

Initializes a new instance of the GraphicsPath class.

public GraphicsPath(Figure[],FillMode);

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath Constructor ()

Initializes a new instance of the GraphicsPath class.

public GraphicsPath();

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath Constructor Overload List


GraphicsPath Constructor (Figure[])

Initializes a new instance of the GraphicsPath class.

public GraphicsPath(
Figure[] figures
);

Parameters

figures
The figures to initialize from.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath Constructor Overload List


GraphicsPath Constructor (Figure[], FillMode)

Initializes a new instance of the GraphicsPath class.

public GraphicsPath(
Figure[] figures,
FillMode fillMode
);

Parameters

figures
The figures to initialize from.
fillMode
The fill mode.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath Constructor Overload List


GraphicsPath Properties

The properties of the GraphicsPath class are listed below. For a complete list of GraphicsPath class members, see the GraphicsPath Members topic.

Public Instance Properties

Bounds | Gets or sets the object's bounds.
Figures | Gets the path figures.
FillMode | Gets or sets a FillMode enumeration that determines how the interiors of shapes in this GraphicsPath are filled.

See Also

GraphicsPath Class | Aspose.Imaging Namespace


Bounds Property

Aspose.Imaging Documentation

GraphicsPath.Bounds Property

Gets or sets the object's bounds.

public override RectangleF Bounds {get;}

Property Value

The object's bounds.

See Also

GraphicsPath Class | Aspose.Imaging Namespace


Figures Property

Aspose.Imaging Documentation

GraphicsPath.Figures Property

Gets the path figures.

public Figure[] Figures {get;}

Property Value

The path figures.

See Also

GraphicsPath Class | Aspose.Imaging Namespace


FillMode Property

Aspose.Imaging Documentation

GraphicsPath.FillMode Property

Gets or sets a FillMode enumeration that determines how the interiors of shapes in this GraphicsPath are filled.

public FillMode FillMode {get; set;}

Property Value

The fill mode.

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath Methods

The methods of the GraphicsPath class are listed below. For a complete list of GraphicsPath class members, see the GraphicsPath Members topic.

Public Instance Methods

AddFigure | Adds a new figure.
AddFigures | Adds new figures.
AddPath | Overloaded. Appends the specified GraphicsPath to this path.
DeepClone | Performs a deep clone of this graphics path.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flatten | Overloaded. Converts each curve in this path into a sequence of connected line segments.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsOutlineVisible | Overloaded. Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen.
IsVisible | Overloaded. Indicates whether the specified point is contained within this GraphicsPath.
RemoveFigure | Removes a figure.
RemoveFigures | Removes figures.
Reset | Empties the graphics path and sets the FillMode to Alternate.
Reverse | Reverses the order of figures, shapes, and points in each shape of this GraphicsPath.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Applies the specified transformation to the shape.
Warp | Overloaded. Applies a warp transform, defined by a rectangle and a parallelogram, to this GraphicsPath.
Widen | Overloaded. Adds an additional outline to the path.

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.AddFigure Method

Adds a new figure.

public void AddFigure(
Figure figure
);

Parameters

figure
The figure to add.

Example

This examples make use of GraphicsPath and Graphics class to create and manipulate Figures on an Image surface. Example creates a new Image (of type Tiff) and draw paths with the help of GraphicsPath class. At the end DrawPath method exposed by Graphics class is called to render the paths on surface.

[C#]

//Create an instance of FileStream
using (System.IO.FileStream stream = new System.IO.FileStream(@"C:\temp\output.tiff", System.IO.FileMode.Create))
{
    //Create an instance of TiffOptions and set its various properties
    Aspose.Imaging.ImageOptions.TiffOptions tiffOptions = new Aspose.Imaging.ImageOptions.TiffOptions();

    //Set the source for the instance of ImageOptions
    tiffOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(tiffOptions, 500, 500))
    {
        //Create and initialize an instance of Graphics class
        Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

        //Clear Graphics surface
        graphics.Clear(Color.Wheat);

        //Create an instance of GraphicsPath class
        Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

        //Create an instance of Figure class
        Aspose.Imaging.Figure figure = new Aspose.Imaging.Figure();

        //Add Shapes to Figure object
        figure.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new RectangleF(10, 10, 300, 300)));
        figure.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
        figure.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(250, 250), new Size(200, 200)), 0, 45));

        //Add Figure object to GraphicsPath
        graphicspath.AddFigure(figure);

        //Draw path with Pen object of color Black
        graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

        // save all changes.
        image.Save();
    }
}
[Visual Basic]

'Create an instance of FileStream
Using stream As System.IO.FileStream = New System.IO.FileStream("C:\temp\output.tiff", System.IO.FileMode.Create)
'Create an instance of TiffOptions and set its various properties
Dim tiffOptions As Aspose.Imaging.ImageOptions.TiffOptions = New Aspose.Imaging.ImageOptions.TiffOptions()

'Set the source for the instance of ImageOptions
    tiffOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(tiffOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
        graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shapes to Figure object
        figure.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New RectangleF(10, 10, 300, 300)))
        figure.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
        figure.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(250, 250), New Size(200, 200)), 0, 45))

'Add Figure object to GraphicsPath
        graphicspath.AddFigure(figure)

'Draw path with Pen object of color Black
        graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
        image.Save()
    End Using
End Using

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.AddFigures Method

Adds new figures.

public void AddFigures(
Figure[] figures
);

Parameters

figures
The figures to add.

Example

This example creates a new Image and draws a variety of shapes using Figures and GraphicsPath on the Image surface

[C#]

//Creates an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"c:\temp\output.bmp", false);

//Create an instance of Image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Create and initialize an instance of Graphics class
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clear Graphics surface
    graphics.Clear(Color.Wheat);

    //Create an instance of GraphicsPath class
    Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure1 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure1.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
    figure1.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(110, 110), new Size(200, 200)), 0, 90));

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure2 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure2.AddShape(new Aspose.Imaging.Shapes.ArcShape(new RectangleF(10, 10, 300, 300), 0, 45));
    figure2.AddShape(new Aspose.Imaging.Shapes.PolygonShape(new[] { new PointF(150, 10), new PointF(150, 200), new PointF(250, 300), new PointF(350, 400) }, true));
    figure2.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new Rectangle(new Point(250, 250), new Size(200, 200))));

    //Add Figure object to GraphicsPath
    graphicspath.AddFigures(new[] { figure1, figure2 });

    //Draw path with Pen object of color Black
    graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

    // save all changes.
    image.Save();
}
[Visual Basic]

'Creates an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("c:\temp\output.bmp", False)

'Create an instance of Image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
    graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure1 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure1.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
    figure1.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(110, 110), New Size(200, 200)), 0, 90))

'Create an instance of Figure class
Dim figure2 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure2.AddShape(New Aspose.Imaging.Shapes.ArcShape(New RectangleF(10, 10, 300, 300), 0, 45))
    figure2.AddShape(New Aspose.Imaging.Shapes.PolygonShape(New() { New PointF(150, 10), New PointF(150, 200), New PointF(250, 300), New PointF(350, 400) }, True))
    figure2.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New Rectangle(New Point(250, 250), New Size(200, 200))))

'Add Figure object to GraphicsPath
    graphicspath.AddFigures(New() { figure1, figure2 })

'Draw path with Pen object of color Black
    graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
    image.Save()
End Using

See Also

GraphicsPath Class | Aspose.Imaging Namespace


AddPath Method

Aspose.Imaging Documentation

GraphicsPath.AddPath Method

Appends the specified GraphicsPath to this path.

Overload List

Appends the specified GraphicsPath to this path.

public void AddPath(GraphicsPath);

Appends the specified GraphicsPath to this path.

public void AddPath(GraphicsPath,bool);

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.AddPath Method (GraphicsPath)

Appends the specified GraphicsPath to this path.

public void AddPath(
GraphicsPath addingPath
);

Parameters

addingPath
The GraphicsPath to add.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.AddPath Overload List


GraphicsPath.AddPath Method (GraphicsPath, Boolean)

Appends the specified GraphicsPath to this path.

public void AddPath(
GraphicsPath addingPath,
bool connect
);

Parameters

addingPath
The GraphicsPath to add.
connect
A Boolean value that specifies whether the first figure in the added path is part of the last figure in this path. A value of true specifies that the first figure in the added path is part of the last figure in this path. A value of false specifies that the first figure in the added path is separate from the last figure in this path.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.AddPath Overload List


GraphicsPath.DeepClone Method

Performs a deep clone of this graphics path.

public GraphicsPath DeepClone();

Return Value

A deep clone of the graphics path.

See Also

GraphicsPath Class | Aspose.Imaging Namespace


Flatten Method

Aspose.Imaging Documentation

GraphicsPath.Flatten Method

Converts each curve in this path into a sequence of connected line segments.

Overload List

Converts each curve in this path into a sequence of connected line segments.

public void Flatten();

Applies the specified transform and then converts each curve in this GraphicsPath into a sequence of connected line segments.

public void Flatten(Matrix);

Converts each curve in this GraphicsPath into a sequence of connected line segments.

public void Flatten(Matrix,float);

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.Flatten Method ()

Converts each curve in this path into a sequence of connected line segments.

public void Flatten();

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.Flatten Overload List


GraphicsPath.Flatten Method (Matrix)

Applies the specified transform and then converts each curve in this GraphicsPath into a sequence of connected line segments.

public void Flatten(
Matrix matrix
);

Parameters

matrix
A Matrix by which to transform this GraphicsPath before flattening.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.Flatten Overload List


GraphicsPath.Flatten Method (Matrix, Single)

Converts each curve in this GraphicsPath into a sequence of connected line segments.

public void Flatten(
Matrix matrix,
float flatness
);

Parameters

matrix
A Matrix by which to transform this GraphicsPath before flattening.
flatness
Specifies the maximum permitted error between the curve and its flattened approximation. A value of 0.25 is the default. Reducing the flatness value will increase the number of line segments in the approximation.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.Flatten Overload List


GetBounds Method

Aspose.Imaging Documentation

GraphicsPath.GetBounds Method

Gets the object's bounds.

Overload List

Gets the object's bounds.

public override RectangleF GetBounds(Matrix);

Gets the object's bounds.

public override RectangleF GetBounds(Matrix,Pen);

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.GetBounds Method (Matrix)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix
);

Parameters

matrix
The matrix to apply before bounds will be calculated.

Return Value

The estimated object's bounds.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.GetBounds Overload List


GraphicsPath.GetBounds Method (Matrix, Pen)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix,
Pen pen
);

Parameters

matrix
The matrix to apply before bounds will be calculated.
pen
The pen to use for object. This can influence the object's bounds size.

Return Value

The estimated object's bounds.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.GetBounds Overload List


IsOutlineVisible Method

Aspose.Imaging Documentation

GraphicsPath.IsOutlineVisible Method

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen.

Overload List

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen.

public bool IsOutlineVisible(Point,Pen);

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen and using the specified Graphics.

public bool IsOutlineVisible(Point,Pen,Graphics);

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen.

public bool IsOutlineVisible(PointF,Pen);

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen and using the specified Graphics.

public bool IsOutlineVisible(PointF,Pen,Graphics);

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen.

public bool IsOutlineVisible(int,int,Pen);

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen and using the specified Graphics.

public bool IsOutlineVisible(int,int,Pen,Graphics);

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen.

public bool IsOutlineVisible(float,float,Pen);

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen and using the specified Graphics.

public bool IsOutlineVisible(float,float,Pen,Graphics);

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.IsOutlineVisible Method (Point, Pen)

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen.

public bool IsOutlineVisible(
Point point,
Pen pen
);

Parameters

point
A Point that specifies the location to test.
pen
The Pen to test.

Return Value

This method returns true if the specified point is contained within the outline of this GraphicsPath when drawn with the specified Pen; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible Method (Point, Pen, Graphics)

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen and using the specified Graphics.

public bool IsOutlineVisible(
Point pt,
Pen pen,
Graphics graphics
);

Parameters

pt
A Point that specifies the location to test.
pen
The Pen to test.
graphics
The Graphics for which to test visibility.

Return Value

This method returns true if the specified point is contained within the outline of this GraphicsPath as drawn with the specified Pen; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible Method (PointF, Pen)

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen.

public bool IsOutlineVisible(
PointF point,
Pen pen
);

Parameters

point
A PointF that specifies the location to test.
pen
The Pen to test.

Return Value

This method returns true if the specified point is contained within the outline of this GraphicsPath when drawn with the specified Pen; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible Method (PointF, Pen, Graphics)

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen and using the specified Graphics.

public bool IsOutlineVisible(
PointF pt,
Pen pen,
Graphics graphics
);

Parameters

pt
A PointF that specifies the location to test.
pen
The Pen to test.
graphics
The Graphics for which to test visibility.

Return Value

This method returns true if the specified point is contained within (under) the outline of this GraphicsPath as drawn with the specified Pen; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible Method (Int32, Int32, Pen)

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen.

public bool IsOutlineVisible(
int x,
int y,
Pen pen
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.
pen
The Pen to test.

Return Value

This method returns true if the specified point is contained within the outline of this GraphicsPath when drawn with the specified Pen; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible Method (Int32, Int32, Pen, Graphics)

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen and using the specified Graphics.

public bool IsOutlineVisible(
int x,
int y,
Pen pen,
Graphics graphics
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.
pen
The Pen to test.
graphics
The Graphics for which to test visibility.

Return Value

This method returns true if the specified point is contained within the outline of this GraphicsPath as drawn with the specified Pen; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible Method (Single, Single, Pen)

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen.

public bool IsOutlineVisible(
float x,
float y,
Pen pen
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.
pen
The Pen to test.

Return Value

This method returns true if the specified point is contained within the outline of this GraphicsPath when drawn with the specified Pen; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsOutlineVisible Overload List


GraphicsPath.IsOutlineVisible Method (Single, Single, Pen, Graphics)

Indicates whether the specified point is contained within (under) the outline of this GraphicsPath when drawn with the specified Pen and using the specified Graphics.

public bool IsOutlineVisible(
float x,
float y,
Pen pen,
Graphics graphics
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.
pen
The Pen to test.
graphics
The Graphics for which to test visibility.

Return Value

This method returns true if the specified point is contained within (under) the outline of this GraphicsPath as drawn with the specified Pen; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsOutlineVisible Overload List


IsVisible Method

Aspose.Imaging Documentation

GraphicsPath.IsVisible Method

Indicates whether the specified point is contained within this GraphicsPath.

Overload List

Indicates whether the specified point is contained within this GraphicsPath.

public bool IsVisible(Point);

Indicates whether the specified point is contained within this GraphicsPath.

public bool IsVisible(Point,Graphics);

Indicates whether the specified point is contained within this GraphicsPath.

public bool IsVisible(PointF);

Indicates whether the specified point is contained within this GraphicsPath.

public bool IsVisible(PointF,Graphics);

Indicates whether the specified point is contained within this GraphicsPath.

public bool IsVisible(int,int);

Indicates whether the specified point is contained within this GraphicsPath, using the specified Graphics.

public bool IsVisible(int,int,Graphics);

Indicates whether the specified point is contained within this GraphicsPath.

public bool IsVisible(float,float);

Indicates whether the specified point is contained within this GraphicsPath in the visible clip region of the specified Graphics.

public bool IsVisible(float,float,Graphics);

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.IsVisible Method (Point)

Indicates whether the specified point is contained within this GraphicsPath.

public bool IsVisible(
Point point
);

Parameters

point
A Point that represents the point to test.

Return Value

This method returns true if the specified point is contained within this GraphicsPath; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible Method (Point, Graphics)

Indicates whether the specified point is contained within this GraphicsPath.

public bool IsVisible(
Point pt,
Graphics graphics
);

Parameters

pt
A Point that represents the point to test.
graphics
The Graphics for which to test visibility.

Return Value

This method returns true if the specified point is contained within this GraphicsPath; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible Method (PointF)

Indicates whether the specified point is contained within this GraphicsPath.

public bool IsVisible(
PointF point
);

Parameters

point
A PointF that represents the point to test.

Return Value

This method returns true if the specified point is contained within this GraphicsPath; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible Method (PointF, Graphics)

Indicates whether the specified point is contained within this GraphicsPath.

public bool IsVisible(
PointF pt,
Graphics graphics
);

Parameters

pt
A PointF that represents the point to test.
graphics
The Graphics for which to test visibility.

Return Value

This method returns true if the specified point is contained within this; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible Method (Int32, Int32)

Indicates whether the specified point is contained within this GraphicsPath.

public bool IsVisible(
int x,
int y
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.

Return Value

This method returns true if the specified point is contained within this GraphicsPath; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible Method (Int32, Int32, Graphics)

Indicates whether the specified point is contained within this GraphicsPath, using the specified Graphics.

public bool IsVisible(
int x,
int y,
Graphics graphics
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.
graphics
The Graphics for which to test visibility.

Return Value

This method returns true if the specified point is contained within this GraphicsPath; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible Method (Single, Single)

Indicates whether the specified point is contained within this GraphicsPath.

public bool IsVisible(
float x,
float y
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.

Return Value

This method returns true if the specified point is contained within this GraphicsPath; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.IsVisible Method (Single, Single, Graphics)

Indicates whether the specified point is contained within this GraphicsPath in the visible clip region of the specified Graphics.

public bool IsVisible(
float x,
float y,
Graphics graphics
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.
graphics
The Graphics for which to test visibility.

Return Value

This method returns true if the specified point is contained within this GraphicsPath; otherwise, false.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.IsVisible Overload List


GraphicsPath.RemoveFigure Method

Removes a figure.

public void RemoveFigure(
Figure figure
);

Parameters

figure
The figure to remove.

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.RemoveFigures Method

Removes figures.

public void RemoveFigures(
Figure[] figures
);

Parameters

figures
The figures to remove.

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.Reset Method

Empties the graphics path and sets the FillMode to Alternate.

public void Reset();

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.Reverse Method

Reverses the order of figures, shapes, and points in each shape of this GraphicsPath.

public void Reverse();

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.Transform Method

Applies the specified transformation to the shape.

public override void Transform(
Matrix transform
);

Parameters

transform
The transformation to apply.

See Also

GraphicsPath Class | Aspose.Imaging Namespace


Warp Method

Aspose.Imaging Documentation

GraphicsPath.Warp Method

Applies a warp transform, defined by a rectangle and a parallelogram, to this GraphicsPath.

Overload List

Applies a warp transform, defined by a rectangle and a parallelogram, to this GraphicsPath.

public void Warp(PointF[],RectangleF);

Applies a warp transform, defined by a rectangle and a parallelogram, to this GraphicsPath.

public void Warp(PointF[],RectangleF,Matrix);

Applies a warp transform, defined by a rectangle and a parallelogram, to this GraphicsPath.

public void Warp(PointF[],RectangleF,Matrix,WarpMode);

Applies a warp transform, defined by a rectangle and a parallelogram, to this GraphicsPath.

public void Warp(PointF[],RectangleF,Matrix,WarpMode,float);

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.Warp Method (PointF[], RectangleF)

Applies a warp transform, defined by a rectangle and a parallelogram, to this GraphicsPath.

public void Warp(
PointF[] destPoints,
RectangleF srcRect
);

Parameters

destPoints
An array of PointF structures that define a parallelogram to which the rectangle defined by srcRect is transformed. The array can contain either three or four elements. If the array contains three elements, the lower-right corner of the parallelogram is implied by the first three points.
srcRect
A RectangleF that represents the rectangle that is transformed to the parallelogram defined by destPoints.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.Warp Overload List


GraphicsPath.Warp Method (PointF[], RectangleF, Matrix)

Applies a warp transform, defined by a rectangle and a parallelogram, to this GraphicsPath.

public void Warp(
PointF[] destPoints,
RectangleF srcRect,
Matrix matrix
);

Parameters

destPoints
An array of PointF structures that define a parallelogram to which the rectangle defined by srcRect is transformed. The array can contain either three or four elements. If the array contains three elements, the lower-right corner of the parallelogram is implied by the first three points.
srcRect
A RectangleF that represents the rectangle that is transformed to the parallelogram defined by destPoints.
matrix
A Matrix that specifies a geometric transform to apply to the path.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.Warp Overload List


GraphicsPath.Warp Method (PointF[], RectangleF, Matrix, WarpMode)

Applies a warp transform, defined by a rectangle and a parallelogram, to this GraphicsPath.

public void Warp(
PointF[] destPoints,
RectangleF srcRect,
Matrix matrix,
WarpMode warpMode
);

Parameters

destPoints
An array of PointF structures that defines a parallelogram to which the rectangle defined by srcRect is transformed. The array can contain either three or four elements. If the array contains three elements, the lower-right corner of the parallelogram is implied by the first three points.
srcRect
A RectangleF that represents the rectangle that is transformed to the parallelogram defined by destPoints.
matrix
A Matrix that specifies a geometric transform to apply to the path.
warpMode
A WarpMode enumeration that specifies whether this warp operation uses perspective or bilinear mode.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.Warp Overload List


GraphicsPath.Warp Method (PointF[], RectangleF, Matrix, WarpMode, Single)

Applies a warp transform, defined by a rectangle and a parallelogram, to this GraphicsPath.

public void Warp(
PointF[] destPoints,
RectangleF srcRect,
Matrix matrix,
WarpMode warpMode,
float flatness
);

Parameters

destPoints
An array of PointF structures that define a parallelogram to which the rectangle defined by srcRect is transformed. The array can contain either three or four elements. If the array contains three elements, the lower-right corner of the parallelogram is implied by the first three points.
srcRect
A RectangleF that represents the rectangle that is transformed to the parallelogram defined by destPoints.
matrix
A Matrix that specifies a geometric transform to apply to the path.
warpMode
A WarpMode enumeration that specifies whether this warp operation uses perspective or bilinear mode.
flatness
A value from 0 through 1 that specifies how flat the resulting path is. For more information, see the Flatten methods.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.Warp Overload List


Widen Method

Aspose.Imaging Documentation

GraphicsPath.Widen Method

Adds an additional outline to the path.

Overload List

Adds an additional outline to the path.

public void Widen(Pen);

Adds an additional outline to the GraphicsPath.

public void Widen(Pen,Matrix);

Replaces this GraphicsPath with curves that enclose the area that is filled when this path is drawn by the specified pen.

public void Widen(Pen,Matrix,float);

See Also

GraphicsPath Class | Aspose.Imaging Namespace


GraphicsPath.Widen Method (Pen)

Adds an additional outline to the path.

public void Widen(
Pen pen
);

Parameters

pen
A Pen that specifies the width between the original outline of the path and the new outline this method creates.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.Widen Overload List


GraphicsPath.Widen Method (Pen, Matrix)

Adds an additional outline to the GraphicsPath.

public void Widen(
Pen pen,
Matrix matrix
);

Parameters

pen
A Pen that specifies the width between the original outline of the path and the new outline this method creates.
matrix
A Matrix that specifies a transform to apply to the path before widening.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.Widen Overload List


GraphicsPath.Widen Method (Pen, Matrix, Single)

Replaces this GraphicsPath with curves that enclose the area that is filled when this path is drawn by the specified pen.

public void Widen(
Pen pen,
Matrix matrix,
float flatness
);

Parameters

pen
A Pen that specifies the width between the original outline of the path and the new outline this method creates.
matrix
A Matrix that specifies a transform to apply to the path before widening.
flatness
A value that specifies the flatness for curves.

See Also

GraphicsPath Class | Aspose.Imaging Namespace | GraphicsPath.Widen Overload List


GraphicsUnit Enumeration

Specifies the unit of measure for the given data.

public enum GraphicsUnit

Members

Member Name | Description | Value
World | Specifies the world coordinate system unit as the unit of measure. | 0
Display | Specifies the unit of measure of the display device. Typically pixels for video displays, and 1/100 inch for printers. | 1
Pixel | Specifies a device pixel as the unit of measure. | 2
Point | Specifies a printer's point (1/72 inch) as the unit of measure. | 3
Inch | Specifies the inch as the unit of measure. | 4
Document | Specifies the document unit (1/300 inch) as the unit of measure. | 5
Millimeter | Specifies the millimeter as the unit of measure. | 6

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


HatchStyle Enumeration

Specifies the different patterns available for HatchBrush objects.

public enum HatchStyle

Members

Member Name | Description | Value
Horizontal | A pattern of horizontal lines. | 0
Min | Specifies hatch style Horizontal. | 0
Vertical | A pattern of vertical lines. | 1
ForwardDiagonal | A pattern of lines on a diagonal from upper left to lower right. | 2
BackwardDiagonal | A pattern of lines on a diagonal from upper right to lower left. | 3
Cross | Specifies horizontal and vertical lines that cross. | 4
LargeGrid | Specifies the hatch style Cross. | 4
Max | Specifies hatch style SolidDiamond. | 4
DiagonalCross | A pattern of crisscross diagonal lines. | 5
Percent05 | Specifies a 5-percent hatch. The ratio of foreground color to background color is 5:95. | 6
Percent10 | Specifies a 10-percent hatch. The ratio of foreground color to background color is 10:90. | 7
Percent20 | Specifies a 20-percent hatch. The ratio of foreground color to background color is 20:80. | 8
Percent25 | Specifies a 25-percent hatch. The ratio of foreground color to background color is 25:75. | 9
Percent30 | Specifies a 30-percent hatch. The ratio of foreground color to background color is 30:70. | 10
Percent40 | Specifies a 40-percent hatch. The ratio of foreground color to background color is 40:60. | 11
Percent50 | Specifies a 50-percent hatch. The ratio of foreground color to background color is 50:50. | 12
Percent60 | Specifies a 60-percent hatch. The ratio of foreground color to background color is 60:40. | 13
Percent70 | Specifies a 70-percent hatch. The ratio of foreground color to background color is 70:30. | 14
Percent75 | Specifies a 75-percent hatch. The ratio of foreground color to background color is 75:25. | 15
Percent80 | Specifies a 80-percent hatch. The ratio of foreground color to background color is 80:100. | 16
Percent90 | Specifies a 90-percent hatch. The ratio of foreground color to background color is 90:10. | 17
LightDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points and are spaced 50 percent closer together than ForwardDiagonal, but are not antialiased. | 18
LightUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points and are spaced 50 percent closer together than BackwardDiagonal, but they are not antialiased. | 19
DarkDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, are spaced 50 percent closer together than, and are twice the width of ForwardDiagonal. This hatch pattern is not antialiased. | 20
DarkUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, are spaced 50 percent closer together than BackwardDiagonal, and are twice its width, but the lines are not antialiased. | 21
WideDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, have the same spacing as hatch style ForwardDiagonal, and are triple its width, but are not antialiased. | 22
WideUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, have the same spacing as hatch style BackwardDiagonal, and are triple its width, but are not antialiased. | 23
LightVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical. | 24
LightHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal. | 25
NarrowVertical | Specifies vertical lines that are spaced 75 percent closer together than hatch style Vertical (or 25 percent closer together than LightVertical). | 26
NarrowHorizontal | Specifies horizontal lines that are spaced 75 percent closer together than hatch style Horizontal (or 25 percent closer together than LightHorizontal). | 27
DarkVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical and are twice its width. | 28
DarkHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal and are twice the width of Horizontal. | 29
DashedDownwardDiagonal | Specifies dashed diagonal lines, that slant to the right from top points to bottom points. | 30
DashedUpwardDiagonal | Specifies dashed diagonal lines, that slant to the left from top points to bottom points. | 31
DashedHorizontal | Specifies dashed horizontal lines. | 32
DashedVertical | Specifies dashed vertical lines. | 33
SmallConfetti | Specifies a hatch that has the appearance of confetti. | 34
LargeConfetti | Specifies a hatch that has the appearance of confetti, and is composed of larger pieces than SmallConfetti. | 35
ZigZag | Specifies horizontal lines that are composed of zigzags. | 36
Wave | Specifies horizontal lines that are composed of tildes. | 37
DiagonalBrick | Specifies a hatch that has the appearance of layered bricks that slant to the left from top points to bottom points. | 38
HorizontalBrick | Specifies a hatch that has the appearance of horizontally layered bricks. | 39
Weave | Specifies a hatch that has the appearance of a woven material. | 40
Plaid | Specifies a hatch that has the appearance of a plaid material. | 41
Divot | Specifies a hatch that has the appearance of divots. | 42
DottedGrid | Specifies horizontal and vertical lines, each of which is composed of dots, that cross. | 43
DottedDiamond | Specifies forward diagonal and backward diagonal lines, each of which is composed of dots, that cross. | 44
Shingle | Specifies a hatch that has the appearance of diagonally layered shingles that slant to the right from top points to bottom points. | 45
Trellis | Specifies a hatch that has the appearance of a trellis. | 46
Sphere | Specifies a hatch that has the appearance of spheres laid adjacent to one another. | 47
SmallGrid | Specifies horizontal and vertical lines that cross and are spaced 50 percent closer together than hatch style Cross. | 48
SmallCheckerBoard | Specifies a hatch that has the appearance of a checkerboard. | 49
LargeCheckerBoard | Specifies a hatch that has the appearance of a checkerboard with squares that are twice the size of SmallCheckerBoard. | 50
OutlinedDiamond | Specifies forward diagonal and backward diagonal lines that cross but are not antialiased. | 51
SolidDiamond | Specifies a hatch that has the appearance of a checkerboard placed diagonally. | 52

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


HotkeyPrefix Enumeration

Specifies the type of display for hot-key prefixes that relate to text.

public enum HotkeyPrefix

Members

Member Name | Description | Value
None | No hot-key prefix. | 0
Show | Display the hot-key prefix. | 1
Hide | Do not display the hot-key prefix. | 2

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


IAdvancedBufferProcessor Interface

The advanced buffer processor.

For a list of all members of this type, see IAdvancedBufferProcessor Members.

public interface IAdvancedBufferProcessor : IBufferProcessor

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IAdvancedBufferProcessor Members | Aspose.Imaging Namespace


IAdvancedBufferProcessor Members

IAdvancedBufferProcessor overview

Public Instance Methods

FinishRow | Finishes the row.
FinishRows | Finishes the rows.

See Also

IAdvancedBufferProcessor Interface | Aspose.Imaging Namespace


IAdvancedBufferProcessor Methods

The methods of the IAdvancedBufferProcessor interface are listed below. For a complete list of IAdvancedBufferProcessor interface members, see the IAdvancedBufferProcessor Members topic.

Public Instance Methods

FinishRow | Finishes the row.
FinishRows | Finishes the rows.

See Also

IAdvancedBufferProcessor Interface | Aspose.Imaging Namespace


IAdvancedBufferProcessor.FinishRow Method

Finishes the row.

void FinishRow();

See Also

IAdvancedBufferProcessor Interface | Aspose.Imaging Namespace


IAdvancedBufferProcessor.FinishRows Method

Finishes the rows.

void FinishRows(
int rowsCount
);

Parameters

rowsCount
The rows count.

See Also

IAdvancedBufferProcessor Interface | Aspose.Imaging Namespace


IBufferProcessor Interface

The buffer processor.

For a list of all members of this type, see IBufferProcessor Members.

Aspose.Imaging.IBufferProcessor
Aspose.Imaging.IAdvancedBufferProcessor

public interface IBufferProcessor

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IBufferProcessor Members | Aspose.Imaging Namespace


IBufferProcessor Members

IBufferProcessor overview

Public Instance Methods

ProcessBuffer Processes the buffer.

See Also

IBufferProcessor Interface | Aspose.Imaging Namespace


IBufferProcessor Methods

The methods of the IBufferProcessor interface are listed below. For a complete list of IBufferProcessor interface members, see the IBufferProcessor Members topic.

Public Instance Methods

ProcessBuffer Processes the buffer.

See Also

IBufferProcessor Interface | Aspose.Imaging Namespace


IBufferProcessor.ProcessBuffer Method

Processes the buffer.

void ProcessBuffer(
byte[] buffer,
int bufferLength
);

Parameters

buffer
The buffer to process.
bufferLength
The buffer length to process.

See Also

IBufferProcessor Interface | Aspose.Imaging Namespace


IColorConverter Interface

The color converter.

For a list of all members of this type, see IColorConverter Members.

public interface IColorConverter

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IColorConverter Members | Aspose.Imaging Namespace


IColorConverter Members

IColorConverter overview

Public Instance Methods

Convert Converts the passed data to the output format.

See Also

IColorConverter Interface | Aspose.Imaging Namespace


IColorConverter Methods

The methods of the IColorConverter interface are listed below. For a complete list of IColorConverter interface members, see the IColorConverter Members topic.

Public Instance Methods

Convert Converts the passed data to the output format.

See Also

IColorConverter Interface | Aspose.Imaging Namespace


IColorConverter.Convert Method

Converts the passed data to the output format.

int Convert(
PixelDataFormat sourceFormat,
byte[] data,
int offset,
int bitStart,
int samplesCount,
int linesCount,
PixelDataFormat destFormat,
byte[] outputData,
int outputOffset
);

Parameters

sourceFormat
The source format.
data
The source data.
offset
The offset in bytes where data copying should begin.
bitStart
The bit start. Note this value is not byte aligned value instead this is actual bit where copying should begin.
samplesCount
The samples count.
linesCount
The lines count.
destFormat
The destination format.
outputData
The output data.
outputOffset
The output offset where data copying should start.

Return Value

The converted bytes count.

See Also

IColorConverter Interface | Aspose.Imaging Namespace


IColorPalette Interface

The color palette interface.

For a list of all members of this type, see IColorPalette Members.

Aspose.Imaging.IColorPalette
Aspose.Imaging.IPsdColorPalette

public interface IColorPalette

Types that implement IColorPalette

Type | Description
ColorPalette | Defines an array of colors that make up a color palette. The colors are 32-bit ARGB colors. Not inheritable.
PsdColorPalette | The PSD color palette.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IColorPalette Members | Aspose.Imaging Namespace


IColorPalette Members

IColorPalette overview

Public Instance Properties

Entries | Gets an array of Color structures.
EntriesCount | Gets the entries count.
IsCompactPalette | Gets a value indicating whether compact palette is used.

Public Instance Methods

GetColor | Gets the palette color by index.
GetNearestColorIndex | Gets the index of the nearest color.

See Also

IColorPalette Interface | Aspose.Imaging Namespace


IColorPalette Properties

The properties of the IColorPalette interface are listed below. For a complete list of IColorPalette interface members, see the IColorPalette Members topic.

Public Instance Properties

Entries | Gets an array of Color structures.
EntriesCount | Gets the entries count.
IsCompactPalette | Gets a value indicating whether compact palette is used.

See Also

IColorPalette Interface | Aspose.Imaging Namespace


Entries Property

Aspose.Imaging Documentation

IColorPalette.Entries Property

Gets an array of Color structures.

Color[] Entries {get;}

Property Value

The entries.

See Also

IColorPalette Interface | Aspose.Imaging Namespace


EntriesCount Property

Aspose.Imaging Documentation

IColorPalette.EntriesCount Property

Gets the entries count.

int EntriesCount {get;}

Property Value

The entries count.

See Also

IColorPalette Interface | Aspose.Imaging Namespace


IsCompactPalette Property

Aspose.Imaging Documentation

IColorPalette.IsCompactPalette Property

Gets a value indicating whether compact palette is used.

bool IsCompactPalette {get;}

Property Value

true if compact palette is used; otherwise, false.

Remarks

Compact palette means that image will contain only the specified palette entries if possible or in other words the image will be more compact and occupy less space; otherwise there will be 2^BitsPerPixel entries and image will reserve more space for all possible palette entries. Setting this value to true and changing palette entries may cause performance penalty since data movement may occur so use it carefully.

See Also

IColorPalette Interface | Aspose.Imaging Namespace


IColorPalette Methods

The methods of the IColorPalette interface are listed below. For a complete list of IColorPalette interface members, see the IColorPalette Members topic.

Public Instance Methods

GetColor | Gets the palette color by index.
GetNearestColorIndex | Gets the index of the nearest color.

See Also

IColorPalette Interface | Aspose.Imaging Namespace


IColorPalette.GetColor Method

Gets the palette color by index.

Color GetColor(
int index
);

Parameters

index
The palette color index.

Return Value

The color palette entry specified by the index.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | if color palette index specified is out of the palette entries range.

See Also

IColorPalette Interface | Aspose.Imaging Namespace


IColorPalette.GetNearestColorIndex Method

Gets the index of the nearest color.

int GetNearestColorIndex(
Color color
);

Parameters

color
The color.

Return Value

The index of the nearest color.

See Also

IColorPalette Interface | Aspose.Imaging Namespace


IImageCreator Interface

The image creator.

For a list of all members of this type, see IImageCreator Members.

public interface IImageCreator

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IImageCreator Members | Aspose.Imaging Namespace


IImageCreator Members

IImageCreator overview

Public Instance Methods

Create Creates a new image instance with imageOptions.

See Also

IImageCreator Interface | Aspose.Imaging Namespace


IImageCreator Methods

The methods of the IImageCreator interface are listed below. For a complete list of IImageCreator interface members, see the IImageCreator Members topic.

Public Instance Methods

Create Creates a new image instance with imageOptions.

See Also

IImageCreator Interface | Aspose.Imaging Namespace


IImageCreator.Create Method

Creates a new image instance with imageOptions.

Image Create(
StreamContainer streamContainer,
ImageOptionsBase imageOptions,
int width,
int height
);

Parameters

streamContainer
The stream container to create image data in.
imageOptions
The image options.
width
width of new image
height
height of new image

Return Value

A new image instance.

See Also

IImageCreator Interface | Aspose.Imaging Namespace


IImageCreatorDescriptor Interface

The image creator descriptor specifying the creator properties. The creator descriptor is used to overcome the necessity to contain each image creator instance in memory and multithreading issues.

For a list of all members of this type, see IImageCreatorDescriptor Members.

public interface IImageCreatorDescriptor : IImageDescriptor

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IImageCreatorDescriptor Members | Aspose.Imaging Namespace


IImageCreatorDescriptor Members

IImageCreatorDescriptor overview

Public Instance Methods

CanCreate | Determines whether image creator can create a new image using the imageOptions.
CreateInstance | Creates a new creator instance.

See Also

IImageCreatorDescriptor Interface | Aspose.Imaging Namespace


IImageCreatorDescriptor Methods

The methods of the IImageCreatorDescriptor interface are listed below. For a complete list of IImageCreatorDescriptor interface members, see the IImageCreatorDescriptor Members topic.

Public Instance Methods

CanCreate | Determines whether image creator can create a new image using the imageOptions.
CreateInstance | Creates a new creator instance.

See Also

IImageCreatorDescriptor Interface | Aspose.Imaging Namespace


IImageCreatorDescriptor.CanCreate Method

Determines whether image creator can create a new image using the imageOptions.

bool CanCreate(
ImageOptionsBase imageOptions
);

Parameters

imageOptions
The image options.

Return Value

True if image creator created by this descriptor can create image data using the specified imageOptions; otherwise, false.

See Also

IImageCreatorDescriptor Interface | Aspose.Imaging Namespace


IImageCreatorDescriptor.CreateInstance Method

Creates a new creator instance.

IImageCreator CreateInstance();

Return Value

A new creator instance.

See Also

IImageCreatorDescriptor Interface | Aspose.Imaging Namespace


IImageDescriptor Interface

The image descriptor. Contains base properties and methods for all other image descriptor types.

For a list of all members of this type, see IImageDescriptor Members.

Aspose.Imaging.IImageDescriptor
Aspose.Imaging.IImageCreatorDescriptor
Aspose.Imaging.IImageExporterDescriptor
Aspose.Imaging.IImageLoaderDescriptor

public interface IImageDescriptor

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IImageDescriptor Members | Aspose.Imaging Namespace


IImageDescriptor Members

IImageDescriptor overview

Public Instance Properties

SupportedFormat Gets the supported format.

See Also

IImageDescriptor Interface | Aspose.Imaging Namespace


IImageDescriptor Properties

The properties of the IImageDescriptor interface are listed below. For a complete list of IImageDescriptor interface members, see the IImageDescriptor Members topic.

Public Instance Properties

SupportedFormat Gets the supported format.

See Also

IImageDescriptor Interface | Aspose.Imaging Namespace


SupportedFormat Property

Aspose.Imaging Documentation

IImageDescriptor.SupportedFormat Property

Gets the supported format.

FileFormat SupportedFormat {get;}

Property Value

The supported format.

See Also

IImageDescriptor Interface | Aspose.Imaging Namespace


IImageExporter Interface

The image exporter. Can export data from internal Aspose.Imaging format to a specified data format.

For a list of all members of this type, see IImageExporter Members.

public interface IImageExporter

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IImageExporter Members | Aspose.Imaging Namespace


IImageExporter Members

IImageExporter overview

Public Instance Methods

Export Exports the specified image data into specified data format.

See Also

IImageExporter Interface | Aspose.Imaging Namespace


IImageExporter Methods

The methods of the IImageExporter interface are listed below. For a complete list of IImageExporter interface members, see the IImageExporter Members topic.

Public Instance Methods

Export Exports the specified image data into specified data format.

See Also

IImageExporter Interface | Aspose.Imaging Namespace


IImageExporter.Export Method

Exports the specified image data into specified data format.

void Export(
Image image,
Stream stream,
ImageOptionsBase optionsBase
);

Parameters

image
The image data to export.
stream
The stream to export data to.
optionsBase
Options for image export

See Also

IImageExporter Interface | Aspose.Imaging Namespace


IImageExporterDescriptor Interface

Represents the image exporter descriptor. The exporter descriptor is used to overcome the necessity to contain each exporter instance in memory and multithreading issues.

For a list of all members of this type, see IImageExporterDescriptor Members.

public interface IImageExporterDescriptor : IImageDescriptor

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IImageExporterDescriptor Members | Aspose.Imaging Namespace


IImageExporterDescriptor Members

IImageExporterDescriptor overview

Public Instance Methods

CanExport | Determines whether image exporter can export the specified image to the specified image format specified by save options.
CreateInstance | Creates a new exporter instance.

See Also

IImageExporterDescriptor Interface | Aspose.Imaging Namespace


IImageExporterDescriptor Methods

The methods of the IImageExporterDescriptor interface are listed below. For a complete list of IImageExporterDescriptor interface members, see the IImageExporterDescriptor Members topic.

Public Instance Methods

CanExport | Determines whether image exporter can export the specified image to the specified image format specified by save options.
CreateInstance | Creates a new exporter instance.

See Also

IImageExporterDescriptor Interface | Aspose.Imaging Namespace


IImageExporterDescriptor.CanExport Method

Determines whether image exporter can export the specified image to the specified image format specified by save options.

bool CanExport(
Image image,
ImageOptionsBase optionsBase
);

Parameters

image
The image to export.
optionsBase
The options base.

Return Value

True if exporter created by this descriptor can export the specified image to the specified file format; otherwise, false.

See Also

IImageExporterDescriptor Interface | Aspose.Imaging Namespace


IImageExporterDescriptor.CreateInstance Method

Creates a new exporter instance.

IImageExporter CreateInstance();

Return Value

A new exporter instance.

See Also

IImageExporterDescriptor Interface | Aspose.Imaging Namespace


IImageLoader Interface

The image loader.

For a list of all members of this type, see IImageLoader Members.

public interface IImageLoader

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IImageLoader Members | Aspose.Imaging Namespace


IImageLoader Members

IImageLoader overview

Public Instance Methods

Load Opens a new image with loadOptions.

See Also

IImageLoader Interface | Aspose.Imaging Namespace


IImageLoader Methods

The methods of the IImageLoader interface are listed below. For a complete list of IImageLoader interface members, see the IImageLoader Members topic.

Public Instance Methods

Load Opens a new image with loadOptions.

See Also

IImageLoader Interface | Aspose.Imaging Namespace


IImageLoader.Load Method

Opens a new image with loadOptions.

Image Load(
StreamContainer streamContainer,
LoadOptions loadOptions
);

Parameters

streamContainer
The stream container.
loadOptions
The load options.

Return Value

A newly opened image instance.

See Also

IImageLoader Interface | Aspose.Imaging Namespace


IImageLoaderDescriptor Interface

The image loader descriptor specifying the loader properties. The loader descriptor is used to overcome the necessity to contain each image loader instance in memory and multithreading issues.

For a list of all members of this type, see IImageLoaderDescriptor Members.

public interface IImageLoaderDescriptor : IImageDescriptor

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IImageLoaderDescriptor Members | Aspose.Imaging Namespace


IImageLoaderDescriptor Members

IImageLoaderDescriptor overview

Public Instance Methods

CanLoad | Determines whether image loader can read a new image from the specified stream and optionally using the loadOptions.
CreateInstance | Creates a new loader instance.

See Also

IImageLoaderDescriptor Interface | Aspose.Imaging Namespace


IImageLoaderDescriptor Methods

The methods of the IImageLoaderDescriptor interface are listed below. For a complete list of IImageLoaderDescriptor interface members, see the IImageLoaderDescriptor Members topic.

Public Instance Methods

CanLoad | Determines whether image loader can read a new image from the specified stream and optionally using the loadOptions.
CreateInstance | Creates a new loader instance.

See Also

IImageLoaderDescriptor Interface | Aspose.Imaging Namespace


IImageLoaderDescriptor.CanLoad Method

Determines whether image loader can read a new image from the specified stream and optionally using the loadOptions.

bool CanLoad(
StreamContainer streamContainer,
LoadOptions loadOptions
);

Parameters

streamContainer
The stream container.
loadOptions
The file format details specified by loadOptions. The loadOptions may be null.

Return Value

true if image loader created by this descriptor can read image from stream; otherwise, false.

See Also

IImageLoaderDescriptor Interface | Aspose.Imaging Namespace


IImageLoaderDescriptor.CreateInstance Method

Creates a new loader instance.

IImageLoader CreateInstance();

Return Value

A new loader instance.

See Also

IImageLoaderDescriptor Interface | Aspose.Imaging Namespace


IIndexedColorConverter Interface

The color converter for indexed image formats.

For a list of all members of this type, see IIndexedColorConverter Members.

public interface IIndexedColorConverter

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IIndexedColorConverter Members | Aspose.Imaging Namespace


IIndexedColorConverter Members

IIndexedColorConverter overview

Public Instance Methods

FillIndexedtoIndexedMap Fills the indexed to indexed image conversion map.

See Also

IIndexedColorConverter Interface | Aspose.Imaging Namespace


IIndexedColorConverter Methods

The methods of the IIndexedColorConverter interface are listed below. For a complete list of IIndexedColorConverter interface members, see the IIndexedColorConverter Members topic.

Public Instance Methods

FillIndexedtoIndexedMap Fills the indexed to indexed image conversion map.

See Also

IIndexedColorConverter Interface | Aspose.Imaging Namespace


IIndexedColorConverter.FillIndexedtoIndexedMap Method

Fills the indexed to indexed image conversion map.

void FillIndexedtoIndexedMap(
byte[] map,
PixelDataFormat sourceFormat,
PixelDataFormat destFormat
);

Parameters

map
The conversion map.
sourceFormat
The source format.
destFormat
The destination format.

See Also

IIndexedColorConverter Interface | Aspose.Imaging Namespace


IKeyedObject Interface

Represents interface for objects with keys.

For a list of all members of this type, see IKeyedObject Members.

public interface IKeyedObject

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IKeyedObject Members | Aspose.Imaging Namespace


IKeyedObject Members

IKeyedObject overview

Public Instance Properties

Key Gets the object key.

See Also

IKeyedObject Interface | Aspose.Imaging Namespace


IKeyedObject Properties

The properties of the IKeyedObject interface are listed below. For a complete list of IKeyedObject interface members, see the IKeyedObject Members topic.

Public Instance Properties

Key Gets the object key.

See Also

IKeyedObject Interface | Aspose.Imaging Namespace


Key Property

Aspose.Imaging Documentation

IKeyedObject.Key Property

Gets the object key.

string Key {get;}

Property Value

The object key.

See Also

IKeyedObject Interface | Aspose.Imaging Namespace


Image Class

The image is the base class for all type of images.

For a list of all members of this type, see Image Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image
Aspose.Imaging.FileFormats.Cad.CadImage
Aspose.Imaging.RasterImage

public abstract class Image : DataStreamSupporter, IObjectWithBounds

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example creates a new Image file at some disk location as specified by Source property of the BmpOptions instance. Several properties for BmpOptions instance are set before creating the actual image. Especially the Source property, that refers to the actual disk location in this case.

[C#]

//Create an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"C:\temp\sample.bmp", false);

//Create an instance of Image and initialize it with instance of BmpOptions by calling Create method
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //do some image processing

    // save all changes
    image.Save();
}
[Visual Basic]

'Create an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("C:\temp\sample.bmp", False)

'Create an instance of Image and initialize it with instance of BmpOptions by calling Create method
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'do some image processing

' save all changes
    image.Save()
End Using

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Image Members | Aspose.Imaging Namespace


Image Members

Image overview

Public Static Methods

CanLoad | Overloaded. Determines whether image can be loaded from the specified file path.
Create | Creates a new image using the specified create options.
GetFileFormat | Overloaded. Gets the file format.
GetFittingRectangle | Overloaded. Gets rectangle which fits the current image.
Load | Overloaded. Loads a new image from the specified file.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
Bounds | Gets the image bounds.
Container | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
Height | Gets the image height.
IsCached (inherited from DataStreamSupporter) | Gets a value indicating whether object's data is cached currently and no data readig is required.
Palette | Gets or sets the color palette.
Size | Gets the image size.
Width | Gets the image width.

Public Instance Methods

CacheData (inherited from DataStreamSupporter) | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave | Determines whether image can be saved to the specified file format represented by the passed save options.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Resize | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip | Rotates, flips, or rotates and flips the image.
Save | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SetPalette | Sets the image palette.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Image Overloaded. Initializes a new instance of the Image class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFitRectangle | Overloaded. Gets rectangle which fits the current image.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataStreamContainerChanging (inherited from DataStreamSupporter) | Called when data stream container is changing.
OnPaletteChanged | Called when palette is changed.
OnPaletteChanging | Called when palette is changing.
ReleaseManagedResources | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
SaveData (inherited from DataStreamSupporter) | Saves the data.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

Image Class | Aspose.Imaging Namespace


Image Constructor

Initializes a new instance of the Image class.

Overload List

Initializes a new instance of the Image class.

protected Image();

Initializes a new instance of the Image class.

protected Image(IColorPalette);

See Also

Image Class | Aspose.Imaging Namespace


Image Constructor ()

Initializes a new instance of the Image class.

protected Image();

See Also

Image Class | Aspose.Imaging Namespace | Image Constructor Overload List


Image Constructor (IColorPalette)

Initializes a new instance of the Image class.

protected Image(
IColorPalette colorPalette
);

Parameters

colorPalette
The color palette.

See Also

Image Class | Aspose.Imaging Namespace | Image Constructor Overload List


Image Properties

The properties of the Image class are listed below. For a complete list of Image class members, see the Image Members topic.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
Bounds | Gets the image bounds.
Container | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
Height | Gets the image height.
IsCached (inherited from DataStreamSupporter) | Gets a value indicating whether object's data is cached currently and no data readig is required.
Palette | Gets or sets the color palette.
Size | Gets the image size.
Width | Gets the image width.

See Also

Image Class | Aspose.Imaging Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

Image.BitsPerPixel Property

Gets the image bits per pixel count.

public abstract int BitsPerPixel {get;}

Property Value

The image bits per pixel count.

See Also

Image Class | Aspose.Imaging Namespace


Bounds Property

Aspose.Imaging Documentation

Image.Bounds Property

Gets the image bounds.

public Rectangle Bounds {get;}

Property Value

The image bounds.

Implements

IObjectWithBounds.Bounds

See Also

Image Class | Aspose.Imaging Namespace


Container Property

Aspose.Imaging Documentation

Image.Container Property

Gets the Image container.

public Image Container {get;}

Property Value

The Image container.

Remarks

If this property is not null it indicates the image is contained whithin another image.

See Also

Image Class | Aspose.Imaging Namespace


Height Property

Aspose.Imaging Documentation

Image.Height Property

Gets the image height.

public abstract int Height {get;}

Property Value

The image height.

Implements

IObjectWithBounds.Height

See Also

Image Class | Aspose.Imaging Namespace


Palette Property

Aspose.Imaging Documentation

Image.Palette Property

Gets or sets the color palette.

public IColorPalette Palette {get; set;}

Property Value

The color palette.

See Also

Image Class | Aspose.Imaging Namespace


Size Property

Aspose.Imaging Documentation

Image.Size Property

Gets the image size.

public Size Size {get;}

Property Value

The image size.

Implements

IObjectWithBounds.Size

See Also

Image Class | Aspose.Imaging Namespace


Width Property

Aspose.Imaging Documentation

Image.Width Property

Gets the image width.

public abstract int Width {get;}

Property Value

The image width.

Implements

IObjectWithBounds.Width

See Also

Image Class | Aspose.Imaging Namespace


Image Methods

The methods of the Image class are listed below. For a complete list of Image class members, see the Image Members topic.

Public Static Methods

CanLoad | Overloaded. Determines whether image can be loaded from the specified file path.
Create | Creates a new image using the specified create options.
GetFileFormat | Overloaded. Gets the file format.
GetFittingRectangle | Overloaded. Gets rectangle which fits the current image.
Load | Overloaded. Loads a new image from the specified file.

Public Instance Methods

CacheData (inherited from DataStreamSupporter) | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave | Determines whether image can be saved to the specified file format represented by the passed save options.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Resize | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip | Rotates, flips, or rotates and flips the image.
Save | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SetPalette | Sets the image palette.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFitRectangle | Overloaded. Gets rectangle which fits the current image.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataStreamContainerChanging (inherited from DataStreamSupporter) | Called when data stream container is changing.
OnPaletteChanged | Called when palette is changed.
OnPaletteChanging | Called when palette is changing.
ReleaseManagedResources | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
SaveData (inherited from DataStreamSupporter) | Saves the data.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

Image Class | Aspose.Imaging Namespace


CanLoad Method

Aspose.Imaging Documentation

Image.CanLoad Method

Determines whether image can be loaded from the specified stream.

Overload List

Determines whether image can be loaded from the specified stream.

public static bool CanLoad(Stream);

Determines whether image can be loaded from the specified stream and optionally using the specified loadOptions.

public static bool CanLoad(Stream,LoadOptions);

Determines whether image can be loaded from the specified file path.

public static bool CanLoad(string);

Determines whether image can be loaded from the specified file path and optionally using the specified open options.

public static bool CanLoad(string,LoadOptions);

See Also

Image Class | Aspose.Imaging Namespace


Image.CanLoad Method (Stream)

Determines whether image can be loaded from the specified stream.

public static bool CanLoad(
Stream stream
);

Parameters

stream
The stream to load from.

Return Value

true if image can be loaded from the specified stream; otherwise, false.

See Also

Image Class | Aspose.Imaging Namespace | Image.CanLoad Overload List


Image.CanLoad Method (Stream, LoadOptions)

Determines whether image can be loaded from the specified stream and optionally using the specified loadOptions.

public static bool CanLoad(
Stream stream,
LoadOptions loadOptions
);

Parameters

stream
The stream to load from.
loadOptions
The load options.

Return Value

true if image can be loaded from the specified stream; otherwise, false.

See Also

Image Class | Aspose.Imaging Namespace | Image.CanLoad Overload List


Image.CanLoad Method (String)

Determines whether image can be loaded from the specified file path.

public static bool CanLoad(
string filePath
);

Parameters

filePath
The file path.

Return Value

true if image can be loaded from the specified file; otherwise, false.

See Also

Image Class | Aspose.Imaging Namespace | Image.CanLoad Overload List


Image.CanLoad Method (String, LoadOptions)

Determines whether image can be loaded from the specified file path and optionally using the specified open options.

public static bool CanLoad(
string filePath,
LoadOptions loadOptions
);

Parameters

filePath
The file path.
loadOptions
The load options.

Return Value

true if image can be loaded from the specified file; otherwise, false.

See Also

Image Class | Aspose.Imaging Namespace | Image.CanLoad Overload List


Image.CanSave Method

Determines whether image can be saved to the specified file format represented by the passed save options.

public bool CanSave(
ImageOptionsBase options
);

Parameters

options
The save options to use.

Return Value

true if image can be saved to the specified file format represented by the passed save options; otherwise, false.

See Also

Image Class | Aspose.Imaging Namespace


Image.Create Method

Creates a new image using the specified create options.

public static Image Create(
ImageOptionsBase imageOptions,
int width,
int height
);

Parameters

imageOptions
The image options.
width
The width.
height
The height.

Return Value

The newly created image.

Example

This example creates a new Image file at some disk location as specified by Source property of the BmpOptions instance. Several properties for BmpOptions instance are set before creating the actual image. Especially the Source property, that refers to the actual disk location in this case.

[C#]

//Create an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"C:\temp\sample.bmp", false);

//Create an instance of Image and initialize it with instance of BmpOptions by calling Create method
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //do some image processing

    // save all changes
    image.Save();
}
[Visual Basic]

'Create an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("C:\temp\sample.bmp", False)

'Create an instance of Image and initialize it with instance of BmpOptions by calling Create method
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'do some image processing

' save all changes
    image.Save()
End Using

See Also

Image Class | Aspose.Imaging Namespace


GetFileFormat Method

Aspose.Imaging Documentation

Image.GetFileFormat Method

Gets the file format.

Overload List

Gets the file format.

public static FileFormat GetFileFormat(Stream);

Gets the file format.

public static FileFormat GetFileFormat(string);

See Also

Image Class | Aspose.Imaging Namespace


Image.GetFileFormat Method (Stream)

Gets the file format.

public static FileFormat GetFileFormat(
Stream stream
);

Parameters

stream
The stream.

Return Value

The determined file format.

Remarks

The file format determined does not mean that the specified image may be loaded. Use one of the CanLoad method overloads to determine whether stream may be loaded.

See Also

Image Class | Aspose.Imaging Namespace | Image.GetFileFormat Overload List


Image.GetFileFormat Method (String)

Gets the file format.

public static FileFormat GetFileFormat(
string filePath
);

Parameters

filePath
The file path.

Return Value

The determined file format.

Remarks

The file format determined does not mean that the specified image may be loaded. Use one of the CanLoad method overloads to determine whether file may be loaded.

See Also

Image Class | Aspose.Imaging Namespace | Image.GetFileFormat Overload List


GetFitRectangle Method

Aspose.Imaging Documentation

Image.GetFitRectangle Method

Gets rectangle which fits the current image.

Overload List

Gets rectangle which fits the current image.

protected Rectangle GetFitRectangle(Rectangle);

Gets rectangle which fits the current bitmap taking into account the pixels passed. The passed pixels array count should be equal to the fitting rectangle size.

protected Rectangle GetFitRectangle(Rectangle,Color[]);

See Also

Image Class | Aspose.Imaging Namespace


Image.GetFitRectangle Method (Rectangle)

Gets rectangle which fits the current image.

protected Rectangle GetFitRectangle(
Rectangle rectangle
);

Parameters

rectangle
The rectangle to get fitting rectangle for.

Return Value

The fitting rectangle

See Also

Image Class | Aspose.Imaging Namespace | Image.GetFitRectangle Overload List


Image.GetFitRectangle Method (Rectangle, Color[])

Gets rectangle which fits the current bitmap taking into account the pixels passed. The passed pixels array count should be equal to the fitting rectangle size.

protected Rectangle GetFitRectangle(
Rectangle rectangle,
Color[] pixels
);

Parameters

rectangle
The rectangle to get fitting rectangle for.
pixels
The pixels array.

Return Value

The fitting rectangle.

See Also

Image Class | Aspose.Imaging Namespace | Image.GetFitRectangle Overload List


GetFittingRectangle Method

Aspose.Imaging Documentation

Image.GetFittingRectangle Method

Gets rectangle which fits the current image.

Overload List

Gets rectangle which fits the current image.

public static Rectangle GetFittingRectangle(Rectangle,Color[],int,int);

Gets rectangle which fits the current image.

public static Rectangle GetFittingRectangle(Rectangle,int,int);

See Also

Image Class | Aspose.Imaging Namespace


Image.GetFittingRectangle Method (Rectangle, Color[], Int32, Int32)

Gets rectangle which fits the current image.

public static Rectangle GetFittingRectangle(
Rectangle rectangle,
Color[] pixels,
int width,
int height
);

Parameters

rectangle
The rectangle to get fitting rectangle for.
pixels
The pixels.
width
The object width.
height
The object height.

Return Value

The fitting rectangle or exception if no fitting rectangle can be found.

See Also

Image Class | Aspose.Imaging Namespace | Image.GetFittingRectangle Overload List


Image.GetFittingRectangle Method (Rectangle, Int32, Int32)

Gets rectangle which fits the current image.

public static Rectangle GetFittingRectangle(
Rectangle rectangle,
int width,
int height
);

Parameters

rectangle
The rectangle to get fitting rectangle for.
width
The object width.
height
The object height.

Return Value

The fitting rectangle or exception if no fitting rectangle can be found.

See Also

Image Class | Aspose.Imaging Namespace | Image.GetFittingRectangle Overload List


Load Method

Aspose.Imaging Documentation

Image.Load Method

Loads a new image from the specified stream.

Overload List

Loads a new image from the specified stream.

public static Image Load(Stream);

Loads a new image from the specified stream.

public static Image Load(Stream,LoadOptions);

Loads a new image from the specified file.

public static Image Load(string);

Loads a new image from the specified file.

public static Image Load(string,LoadOptions);

See Also

Image Class | Aspose.Imaging Namespace


Image.Load Method (Stream)

Loads a new image from the specified stream.

public static Image Load(
Stream stream
);

Parameters

stream
The stream to load image from.

Return Value

The loaded image.

Example

This example demonstrates the use of System.IO.Stream objects to load an existing Image file

[C#]

//Create an instance of FileStream
using(System.IO.FileStream stream = new System.IO.FileStream(@"C:\temp\sample.bmp",System.IO.FileMode.Open))
{
    //Create an instance of Image class and load an existing file through FileStream object by calling Load method
    using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(stream))
    {
        //do some image processing.
    }
}
[Visual Basic]

'Create an instance of FileStream
Using stream As System.IO.FileStream = New System.IO.FileStream("C:\temp\sample.bmp",System.IO.FileMode.Open)
'Create an instance of Image class and load an existing file through FileStream object by calling Load method
    Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load(stream)
'do some image processing.
    End Using
End Using

See Also

Image Class | Aspose.Imaging Namespace | Image.Load Overload List


Image.Load Method (Stream, LoadOptions)

Loads a new image from the specified stream.

public static Image Load(
Stream stream,
LoadOptions loadOptions
);

Parameters

stream
The stream to load image from.
loadOptions
The load options.

Return Value

The loaded image.

See Also

Image Class | Aspose.Imaging Namespace | Image.Load Overload List


Image.Load Method (String)

Loads a new image from the specified file.

public static Image Load(
string filePath
);

Parameters

filePath
The file path to load image from.

Return Value

The loaded image.

Example

This example demonstrates the loading of an existing Image file into an instance of Aspose.Imaging.Image using file path specified

[C#]

//Create Image instance and initialize it with an existing image file from disk location
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(@"C:\temp\sample.bmp"))
{
    //do some image processing
}
[Visual Basic]

'Create Image instance and initialize it with an existing image file from disk location
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load("C:\temp\sample.bmp")
'do some image processing
End Using

See Also

Image Class | Aspose.Imaging Namespace | Image.Load Overload List


Image.Load Method (String, LoadOptions)

Loads a new image from the specified file.

public static Image Load(
string filePath,
LoadOptions loadOptions
);

Parameters

filePath
The file path to load image from.
loadOptions
The load options.

Return Value

The loaded image.

See Also

Image Class | Aspose.Imaging Namespace | Image.Load Overload List


Image.OnPaletteChanged Method

Called when palette is changed.

protected virtual void OnPaletteChanged(
IColorPalette oldPalette,
IColorPalette newPalette
);

Parameters

oldPalette
The old palette.
newPalette
The new palette.

See Also

Image Class | Aspose.Imaging Namespace


Image.OnPaletteChanging Method

Called when palette is changing.

protected virtual void OnPaletteChanging(
IColorPalette oldPalette,
IColorPalette newPalette
);

Parameters

oldPalette
The old palette.
newPalette
The new palette.

See Also

Image Class | Aspose.Imaging Namespace


Image.ReleaseManagedResources Method

Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.

protected override void ReleaseManagedResources();

See Also

Image Class | Aspose.Imaging Namespace


Resize Method

Aspose.Imaging Documentation

Image.Resize Method

Resizes the image. The default LeftTopToLeftTop is used.

Overload List

Resizes the image. The default LeftTopToLeftTop is used.

public void Resize(int,int);

Resizes the image.

public abstract void Resize(int,int,ResizeType);

See Also

Image Class | Aspose.Imaging Namespace


Image.Resize Method (Int32, Int32)

Resizes the image. The default LeftTopToLeftTop is used.

public void Resize(
int newWidth,
int newHeight
);

Parameters

newWidth
The new width.
newHeight
The new height.

See Also

Image Class | Aspose.Imaging Namespace | Image.Resize Overload List


Image.Resize Method (Int32, Int32, ResizeType)

Resizes the image.

public abstract void Resize(
int newWidth,
int newHeight,
ResizeType resizeType
);

Parameters

newWidth
The new width.
newHeight
The new height.
resizeType
The resize type.

See Also

Image Class | Aspose.Imaging Namespace | Image.Resize Overload List


Image.RotateFlip Method

Rotates, flips, or rotates and flips the image.

public abstract void RotateFlip(
RotateFlipType rotateFlipType
);

Parameters

rotateFlipType
Type of the rotate flip.

Example

This example demonstrates the use of Rotate operation on an image. Example loads an existing image file from some disk location and performs the Rotate operaation on the image according to the value of Enum Aspose.Imaging.RotateFlipType

[C#]

//Create an instance of image class and initialize it with an existing image file through File path
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(@"C:\temp\sample.bmp"))
{
    //Rotate the image at 180 degree about X axis
    image.RotateFlip(Aspose.Imaging.RotateFlipType.Rotate180FlipX);

    // save all changes.
    image.Save();
}
[Visual Basic]

'Create an instance of image class and initialize it with an existing image file through File path
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load("C:\temp\sample.bmp")
'Rotate the image at 180 degree about X axis
    image.RotateFlip(Aspose.Imaging.RotateFlipType.Rotate180FlipX)

' save all changes.
    image.Save()
End Using

See Also

Image Class | Aspose.Imaging Namespace


Save Method

Aspose.Imaging Documentation

Image.Save Method

Saves the image data to the underlying stream.

Overload List

Saves the image data to the underlying stream.

public void Save();

Inherited from DataStreamSupporter.

public void Save(Stream);

Saves the image's data to the specified stream in the specified file format according to save options.

public virtual void Save(Stream,ImageOptionsBase);

Inherited from DataStreamSupporter.

public void Save(string);

Saves the object's data to the specified file location in the specified file format according to save options.

public virtual void Save(string,ImageOptionsBase);

Inherited from DataStreamSupporter.

public virtual void Save(string,bool);

See Also

Image Class | Aspose.Imaging Namespace


Image.Save Method ()

Saves the image data to the underlying stream.

public void Save();

See Also

Image Class | Aspose.Imaging Namespace | Image.Save Overload List


Image.Save Method (Stream, ImageOptionsBase)

Saves the image's data to the specified stream in the specified file format according to save options.

public virtual void Save(
Stream stream,
ImageOptionsBase optionsBase
);

Parameters

stream
The stream to save the image's data to.
optionsBase
The save options.

Example

This example shows the process of Saving an Image to MemoryStream. To demonstrate this operation, example loads an existing file from some disk location, performs Rotate operation on the image and Save the image in PSD format

[C#]

//Create an instance of MemoryStream
using(System.IO.MemoryStream stream = new System.IO.MemoryStream())
{
    //Create an instance of image class and initialize it with an existing file through File path
    using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(@"C:\temp\sample.bmp"))
    {
        //Rotate the image at 180 degree about X axis
        image.RotateFlip(Aspose.Imaging.RotateFlipType.Rotate180FlipX);

        //Save the Image as PSD to MemoryStream with default PsdOptions settings
        image.Save(stream, new Aspose.Imaging.ImageOptions.PsdOptions());
    }
}
[Visual Basic]

'Create an instance of MemoryStream
Using stream As System.IO.MemoryStream = New System.IO.MemoryStream()
'Create an instance of image class and initialize it with an existing file through File path
    Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load("C:\temp\sample.bmp")
'Rotate the image at 180 degree about X axis
        image.RotateFlip(Aspose.Imaging.RotateFlipType.Rotate180FlipX)

'Save the Image as PSD to MemoryStream with default PsdOptions settings
        image.Save(stream, New Aspose.Imaging.ImageOptions.PsdOptions())
    End Using
End Using

See Also

Image Class | Aspose.Imaging Namespace | Image.Save Overload List


Image.Save Method (String, ImageOptionsBase)

Saves the object's data to the specified file location in the specified file format according to save options.

public virtual void Save(
string filePath,
ImageOptionsBase options
);

Parameters

filePath
The file path.
options
The options.

Example

This example shows the simple steps to Save an Image. To demonstrate this operation, we load an existing file from some disk location, performs Rotate operation on the image and Save the image in PSD format using File Path

[C#]

//Create an instance of image class and initialize it with an existing file through File path
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(@"C:\temp\sample.bmp"))
{
    //Rotate the image at 180 degree about X axis
    image.RotateFlip(Aspose.Imaging.RotateFlipType.Rotate180FlipX);

    //Save the Image as PSD to File Path with default PsdOptions settings
    image.Save(@"C:\temp\output.psd", new Aspose.Imaging.ImageOptions.PsdOptions());
}
[Visual Basic]

'Create an instance of image class and initialize it with an existing file through File path
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load("C:\temp\sample.bmp")
'Rotate the image at 180 degree about X axis
    image.RotateFlip(Aspose.Imaging.RotateFlipType.Rotate180FlipX)

'Save the Image as PSD to File Path with default PsdOptions settings
    image.Save("C:\temp\output.psd", New Aspose.Imaging.ImageOptions.PsdOptions())
End Using

See Also

Image Class | Aspose.Imaging Namespace | Image.Save Overload List


Image.SetPalette Method

Sets the image palette.

public abstract void SetPalette(
IColorPalette palette,
bool updateColors
);

Parameters

palette
The palette to set.
updateColors
if set to true colors will be updated according to the new palette; otherwise color indexes remain unchanged. Note that unchanged indexes may crash the image on loading if some indexes have no corresponding palette entries.

See Also

Image Class | Aspose.Imaging Namespace


ImageAttributes Class

An ImageAttributes object contains information about how bitmap and metafile colors are manipulated during rendering. An ImageAttributes object maintains several color-adjustment settings, including color-adjustment matrices, grayscale-adjustment matrices, gamma-correction values, color-map tables, and color-threshold values. During rendering, colors can be corrected, darkened, lightened, and removed. To apply such manipulations, initialize an ImageAttributes object and pass the path of that ImageAttributes object (along with the path of an Image) to the DrawImage method.

For a list of all members of this type, see ImageAttributes Members.

System.Object
Aspose.Imaging.ImageAttributes

public sealed class ImageAttributes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ImageAttributes Members | Aspose.Imaging Namespace


ImageAttributes Members

ImageAttributes overview

Public Instance Constructors

ImageAttributes Constructor Initializes a new instance of the ImageAttributes class.

Public Instance Methods

ClearBrushRemapTable | Clears the brush color-remap table of this ImageAttributes object.
ClearColorKey | Overloaded. Clears the color key (transparency range) for the default category.
ClearColorMatrix | Overloaded. Clears the color-adjustment matrix for the default category.
ClearGamma | Overloaded. Disables gamma correction for the default category.
ClearNoOp | Overloaded. Clears the NoOp setting for the default category.
ClearOutputChannel | Overloaded. Clears the CMYK (cyan-magenta-yellow-black) output channel setting for the default category.
ClearOutputChannelColorProfile | Overloaded. Clears the output channel color profile setting for the default category.
ClearRemapTable | Overloaded. Clears the color-remap table for the default category.
ClearThreshold | Overloaded. Clears the threshold value for the default category.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetBrushRemapTable | Sets the color-remap table for the brush category.
SetColorKey | Overloaded. Sets the color key for the default category.
SetColorMatrices | Overloaded. Sets the color-adjustment matrix and the grayscale-adjustment matrix for the default category.
SetColorMatrix | Overloaded. Sets the color-adjustment matrix for the default category.
SetGamma | Overloaded. Sets the gamma value for the default category.
SetNoOp | Overloaded. Turns off color adjustment for the default category.
SetOutputChannel | Overloaded. Sets the CMYK (cyan-magenta-yellow-black) output channel for the default category.
SetOutputChannelColorProfile | Overloaded. Sets the output channel color-profile file for the default category.
SetRemapTable | Overloaded. Sets the color-remap table for the default category.
SetThreshold | Overloaded. Sets the threshold (transparency range) for the default category.
SetWrapMode | Overloaded. Sets the wrap mode that is used to decide how to tile a texture across a shape, or at shape boundaries. A texture is tiled across a shape to fill it in when the texture is smaller than the shape it is filling.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes Constructor

Initializes a new instance of the ImageAttributes class.

public ImageAttributes();

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes Methods

The methods of the ImageAttributes class are listed below. For a complete list of ImageAttributes class members, see the ImageAttributes Members topic.

Public Instance Methods

ClearBrushRemapTable | Clears the brush color-remap table of this ImageAttributes object.
ClearColorKey | Overloaded. Clears the color key (transparency range) for the default category.
ClearColorMatrix | Overloaded. Clears the color-adjustment matrix for the default category.
ClearGamma | Overloaded. Disables gamma correction for the default category.
ClearNoOp | Overloaded. Clears the NoOp setting for the default category.
ClearOutputChannel | Overloaded. Clears the CMYK (cyan-magenta-yellow-black) output channel setting for the default category.
ClearOutputChannelColorProfile | Overloaded. Clears the output channel color profile setting for the default category.
ClearRemapTable | Overloaded. Clears the color-remap table for the default category.
ClearThreshold | Overloaded. Clears the threshold value for the default category.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetBrushRemapTable | Sets the color-remap table for the brush category.
SetColorKey | Overloaded. Sets the color key for the default category.
SetColorMatrices | Overloaded. Sets the color-adjustment matrix and the grayscale-adjustment matrix for the default category.
SetColorMatrix | Overloaded. Sets the color-adjustment matrix for the default category.
SetGamma | Overloaded. Sets the gamma value for the default category.
SetNoOp | Overloaded. Turns off color adjustment for the default category.
SetOutputChannel | Overloaded. Sets the CMYK (cyan-magenta-yellow-black) output channel for the default category.
SetOutputChannelColorProfile | Overloaded. Sets the output channel color-profile file for the default category.
SetRemapTable | Overloaded. Sets the color-remap table for the default category.
SetThreshold | Overloaded. Sets the threshold (transparency range) for the default category.
SetWrapMode | Overloaded. Sets the wrap mode that is used to decide how to tile a texture across a shape, or at shape boundaries. A texture is tiled across a shape to fill it in when the texture is smaller than the shape it is filling.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.ClearBrushRemapTable Method

Clears the brush color-remap table of this ImageAttributes object.

public void ClearBrushRemapTable();

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ClearColorKey Method

Aspose.Imaging Documentation

ImageAttributes.ClearColorKey Method

Clears the color key (transparency range) for the default category.

Overload List

Clears the color key (transparency range) for the default category.

public void ClearColorKey();

Clears the color key (transparency range) for a specified category.

public void ClearColorKey(ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.ClearColorKey Method ()

Clears the color key (transparency range) for the default category.

public void ClearColorKey();

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearColorKey Overload List


ImageAttributes.ClearColorKey Method (ColorAdjustType)

Clears the color key (transparency range) for a specified category.

public void ClearColorKey(
ColorAdjustType type
);

Parameters

type
An element of ColorAdjustType that specifies the category for which the color key is cleared.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearColorKey Overload List


ClearColorMatrix Method

Aspose.Imaging Documentation

ImageAttributes.ClearColorMatrix Method

Clears the color-adjustment matrix for the default category.

Overload List

Clears the color-adjustment matrix for the default category.

public void ClearColorMatrix();

Clears the color-adjustment matrix for a specified category.

public void ClearColorMatrix(ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.ClearColorMatrix Method ()

Clears the color-adjustment matrix for the default category.

public void ClearColorMatrix();

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearColorMatrix Overload List


ImageAttributes.ClearColorMatrix Method (ColorAdjustType)

Clears the color-adjustment matrix for a specified category.

public void ClearColorMatrix(
ColorAdjustType type
);

Parameters

type
An element of ColorAdjustType that specifies the category for which the color-adjustment matrix is cleared.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearColorMatrix Overload List


ClearGamma Method

Aspose.Imaging Documentation

ImageAttributes.ClearGamma Method

Disables gamma correction for the default category.

Overload List

Disables gamma correction for the default category.

public void ClearGamma();

Disables gamma correction for a specified category.

public void ClearGamma(ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.ClearGamma Method ()

Disables gamma correction for the default category.

public void ClearGamma();

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearGamma Overload List


ImageAttributes.ClearGamma Method (ColorAdjustType)

Disables gamma correction for a specified category.

public void ClearGamma(
ColorAdjustType type
);

Parameters

type
An element of ColorAdjustType that specifies the category for which gamma correction is disabled.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearGamma Overload List


ClearNoOp Method

Aspose.Imaging Documentation

ImageAttributes.ClearNoOp Method

Clears the NoOp setting for the default category.

Overload List

Clears the NoOp setting for the default category.

public void ClearNoOp();

Clears the NoOp setting for a specified category.

public void ClearNoOp(ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.ClearNoOp Method ()

Clears the NoOp setting for the default category.

public void ClearNoOp();

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearNoOp Overload List


ImageAttributes.ClearNoOp Method (ColorAdjustType)

Clears the NoOp setting for a specified category.

public void ClearNoOp(
ColorAdjustType type
);

Parameters

type
An element of ColorAdjustType that specifies the category for which the NoOp setting is cleared.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearNoOp Overload List


ClearOutputChannel Method

Aspose.Imaging Documentation

ImageAttributes.ClearOutputChannel Method

Clears the CMYK (cyan-magenta-yellow-black) output channel setting for the default category.

Overload List

Clears the CMYK (cyan-magenta-yellow-black) output channel setting for the default category.

public void ClearOutputChannel();

Clears the (cyan-magenta-yellow-black) output channel setting for a specified category.

public void ClearOutputChannel(ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.ClearOutputChannel Method ()

Clears the CMYK (cyan-magenta-yellow-black) output channel setting for the default category.

public void ClearOutputChannel();

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearOutputChannel Overload List


ImageAttributes.ClearOutputChannel Method (ColorAdjustType)

Clears the (cyan-magenta-yellow-black) output channel setting for a specified category.

public void ClearOutputChannel(
ColorAdjustType type
);

Parameters

type
An element of ColorAdjustType that specifies the category for which the output channel setting is cleared.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearOutputChannel Overload List


ClearOutputChannelColorProfile Method

Aspose.Imaging Documentation

ImageAttributes.ClearOutputChannelColorProfile Method

Clears the output channel color profile setting for the default category.

Overload List

Clears the output channel color profile setting for the default category.

public void ClearOutputChannelColorProfile();

Clears the output channel color profile setting for a specified category.

public void ClearOutputChannelColorProfile(ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.ClearOutputChannelColorProfile Method ()

Clears the output channel color profile setting for the default category.

public void ClearOutputChannelColorProfile();

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearOutputChannelColorProfile Overload List


ImageAttributes.ClearOutputChannelColorProfile Method (ColorAdjustType)

Clears the output channel color profile setting for a specified category.

public void ClearOutputChannelColorProfile(
ColorAdjustType type
);

Parameters

type
An element of ColorAdjustType that specifies the category for which the output channel profile setting is cleared.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearOutputChannelColorProfile Overload List


ClearRemapTable Method

Aspose.Imaging Documentation

ImageAttributes.ClearRemapTable Method

Clears the color-remap table for the default category.

Overload List

Clears the color-remap table for the default category.

public void ClearRemapTable();

Clears the color-remap table for a specified category.

public void ClearRemapTable(ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.ClearRemapTable Method ()

Clears the color-remap table for the default category.

public void ClearRemapTable();

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearRemapTable Overload List


ImageAttributes.ClearRemapTable Method (ColorAdjustType)

Clears the color-remap table for a specified category.

public void ClearRemapTable(
ColorAdjustType type
);

Parameters

type
An element of ColorAdjustType that specifies the category for which the remap table is cleared.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearRemapTable Overload List


ClearThreshold Method

Aspose.Imaging Documentation

ImageAttributes.ClearThreshold Method

Clears the threshold value for the default category.

Overload List

Clears the threshold value for the default category.

public void ClearThreshold();

Clears the threshold value for a specified category.

public void ClearThreshold(ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.ClearThreshold Method ()

Clears the threshold value for the default category.

public void ClearThreshold();

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearThreshold Overload List


ImageAttributes.ClearThreshold Method (ColorAdjustType)

Clears the threshold value for a specified category.

public void ClearThreshold(
ColorAdjustType type
);

Parameters

type
An element of ColorAdjustType that specifies the category for which the threshold is cleared.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.ClearThreshold Overload List


ImageAttributes.SetBrushRemapTable Method

Sets the color-remap table for the brush category.

public void SetBrushRemapTable(
ColorMap[] map
);

Parameters

map
An array of ColorMap objects.

See Also

ImageAttributes Class | Aspose.Imaging Namespace


SetColorKey Method

Aspose.Imaging Documentation

ImageAttributes.SetColorKey Method

Sets the color key for the default category.

Overload List

Sets the color key for the default category.

public void SetColorKey(Color,Color);

Sets the color key (transparency range) for a specified category.

public void SetColorKey(Color,Color,ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.SetColorKey Method (Color, Color)

Sets the color key for the default category.

public void SetColorKey(
Color colorLow,
Color colorHigh
);

Parameters

colorLow
The low color-key value.
colorHigh
The high color-key value.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetColorKey Overload List


ImageAttributes.SetColorKey Method (Color, Color, ColorAdjustType)

Sets the color key (transparency range) for a specified category.

public void SetColorKey(
Color colorLow,
Color colorHigh,
ColorAdjustType type
);

Parameters

colorLow
The low color-key value.
colorHigh
The high color-key value.
type
An element of ColorAdjustType that specifies the category for which the color key is set.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetColorKey Overload List


SetColorMatrices Method

Aspose.Imaging Documentation

ImageAttributes.SetColorMatrices Method

Sets the color-adjustment matrix and the grayscale-adjustment matrix for the default category.

Overload List

Sets the color-adjustment matrix and the grayscale-adjustment matrix for the default category.

public void SetColorMatrices(ColorMatrix,ColorMatrix);

Sets the color-adjustment matrix and the grayscale-adjustment matrix for the default category.

public void SetColorMatrices(ColorMatrix,ColorMatrix,ColorMatrixFlag);

Sets the color-adjustment matrix and the grayscale-adjustment matrix for a specified category.

public void SetColorMatrices(ColorMatrix,ColorMatrix,ColorMatrixFlag,ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.SetColorMatrices Method (ColorMatrix, ColorMatrix)

Sets the color-adjustment matrix and the grayscale-adjustment matrix for the default category.

public void SetColorMatrices(
ColorMatrix newColorMatrix,
ColorMatrix grayMatrix
);

Parameters

newColorMatrix
The color-adjustment matrix.
grayMatrix
The grayscale-adjustment matrix.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetColorMatrices Overload List


ImageAttributes.SetColorMatrices Method (ColorMatrix, ColorMatrix, ColorMatrixFlag)

Sets the color-adjustment matrix and the grayscale-adjustment matrix for the default category.

public void SetColorMatrices(
ColorMatrix newColorMatrix,
ColorMatrix grayMatrix,
ColorMatrixFlag flags
);

Parameters

newColorMatrix
The color-adjustment matrix.
grayMatrix
The grayscale-adjustment matrix.
flags
An element of ColorMatrixFlag that specifies the type of image and color that will be affected by the color-adjustment and grayscale-adjustment matrices.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetColorMatrices Overload List


ImageAttributes.SetColorMatrices Method (ColorMatrix, ColorMatrix, ColorMatrixFlag, ColorAdjustType)

Sets the color-adjustment matrix and the grayscale-adjustment matrix for a specified category.

public void SetColorMatrices(
ColorMatrix newColorMatrix,
ColorMatrix grayMatrix,
ColorMatrixFlag mode,
ColorAdjustType type
);

Parameters

newColorMatrix
The color-adjustment matrix.
grayMatrix
The grayscale-adjustment matrix.
mode
An element of ColorMatrixFlag that specifies the type of image and color that will be affected by the color-adjustment and grayscale-adjustment matrices.
type
An element of ColorAdjustType that specifies the category for which the color-adjustment and grayscale-adjustment matrices are set.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetColorMatrices Overload List


SetColorMatrix Method

Aspose.Imaging Documentation

ImageAttributes.SetColorMatrix Method

Sets the color-adjustment matrix for the default category.

Overload List

Sets the color-adjustment matrix for the default category.

public void SetColorMatrix(ColorMatrix);

Sets the color-adjustment matrix for the default category.

public void SetColorMatrix(ColorMatrix,ColorMatrixFlag);

Sets the color-adjustment matrix for a specified category.

public void SetColorMatrix(ColorMatrix,ColorMatrixFlag,ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.SetColorMatrix Method (ColorMatrix)

Sets the color-adjustment matrix for the default category.

public void SetColorMatrix(
ColorMatrix newColorMatrix
);

Parameters

newColorMatrix
The color-adjustment matrix.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetColorMatrix Overload List


ImageAttributes.SetColorMatrix Method (ColorMatrix, ColorMatrixFlag)

Sets the color-adjustment matrix for the default category.

public void SetColorMatrix(
ColorMatrix newColorMatrix,
ColorMatrixFlag flags
);

Parameters

newColorMatrix
The color-adjustment matrix.
flags
An element of ColorMatrixFlag that specifies the type of image and color that will be affected by the color-adjustment matrix.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetColorMatrix Overload List


ImageAttributes.SetColorMatrix Method (ColorMatrix, ColorMatrixFlag, ColorAdjustType)

Sets the color-adjustment matrix for a specified category.

public void SetColorMatrix(
ColorMatrix newColorMatrix,
ColorMatrixFlag mode,
ColorAdjustType type
);

Parameters

newColorMatrix
The color-adjustment matrix.
mode
An element of ColorMatrixFlag that specifies the type of image and color that will be affected by the color-adjustment matrix.
type
An element of ColorAdjustType that specifies the category for which the color-adjustment matrix is set.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetColorMatrix Overload List


SetGamma Method

Aspose.Imaging Documentation

ImageAttributes.SetGamma Method

Sets the gamma value for the default category.

Overload List

Sets the gamma value for the default category.

public void SetGamma(float);

Sets the gamma value for a specified category.

public void SetGamma(float,ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.SetGamma Method (Single)

Sets the gamma value for the default category.

public void SetGamma(
float gamma
);

Parameters

gamma
The gamma correction value.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetGamma Overload List


ImageAttributes.SetGamma Method (Single, ColorAdjustType)

Sets the gamma value for a specified category.

public void SetGamma(
float gamma,
ColorAdjustType type
);

Parameters

gamma
The gamma correction value.
type
An element of the ColorAdjustType enumeration that specifies the category for which the gamma value is set.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetGamma Overload List


SetNoOp Method

Aspose.Imaging Documentation

ImageAttributes.SetNoOp Method

Turns off color adjustment for the default category.

Overload List

Turns off color adjustment for the default category.

public void SetNoOp();

Turns off color adjustment for a specified category.

public void SetNoOp(ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.SetNoOp Method ()

Turns off color adjustment for the default category.

public void SetNoOp();

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetNoOp Overload List


ImageAttributes.SetNoOp Method (ColorAdjustType)

Turns off color adjustment for a specified category.

public void SetNoOp(
ColorAdjustType type
);

Parameters

type
An element of ColorAdjustType that specifies the category for which color correction is turned off.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetNoOp Overload List


SetOutputChannel Method

Aspose.Imaging Documentation

ImageAttributes.SetOutputChannel Method

Sets the CMYK (cyan-magenta-yellow-black) output channel for the default category.

Overload List

Sets the CMYK (cyan-magenta-yellow-black) output channel for the default category.

public void SetOutputChannel(ColorChannelFlag);

Sets the CMYK (cyan-magenta-yellow-black) output channel for a specified category.

public void SetOutputChannel(ColorChannelFlag,ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.SetOutputChannel Method (ColorChannelFlag)

Sets the CMYK (cyan-magenta-yellow-black) output channel for the default category.

public void SetOutputChannel(
ColorChannelFlag flags
);

Parameters

flags
An element of ColorChannelFlag that specifies the output channel.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetOutputChannel Overload List


ImageAttributes.SetOutputChannel Method (ColorChannelFlag, ColorAdjustType)

Sets the CMYK (cyan-magenta-yellow-black) output channel for a specified category.

public void SetOutputChannel(
ColorChannelFlag flags,
ColorAdjustType type
);

Parameters

flags
An element of ColorChannelFlag that specifies the output channel.
type
An element of ColorAdjustType that specifies the category for which the output channel is set.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetOutputChannel Overload List


SetOutputChannelColorProfile Method

Aspose.Imaging Documentation

ImageAttributes.SetOutputChannelColorProfile Method

Sets the output channel color-profile file for the default category.

Overload List

Sets the output channel color-profile file for the default category.

public void SetOutputChannelColorProfile(string);

Sets the output channel color-profile file for a specified category.

public void SetOutputChannelColorProfile(string,ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.SetOutputChannelColorProfile Method (String)

Sets the output channel color-profile file for the default category.

public void SetOutputChannelColorProfile(
string colorProfileFilename
);

Parameters

colorProfileFilename
The path name of a color-profile file. If the color-profile file is in the %SystemRoot%\System32\Spool\Drivers\Color directory, this parameter can be the file name. Otherwise, this parameter must be the fully qualified path name.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetOutputChannelColorProfile Overload List


ImageAttributes.SetOutputChannelColorProfile Method (String, ColorAdjustType)

Sets the output channel color-profile file for a specified category.

public void SetOutputChannelColorProfile(
string colorProfileFilename,
ColorAdjustType type
);

Parameters

colorProfileFilename
The path name of a color-profile file. If the color-profile file is in the %SystemRoot%\System32\Spool\Drivers\Color directory, this parameter can be the file name. Otherwise, this parameter must be the fully qualified path name.
type
An element of ColorAdjustType that specifies the category for which the output channel color-profile file is set.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetOutputChannelColorProfile Overload List


SetRemapTable Method

Aspose.Imaging Documentation

ImageAttributes.SetRemapTable Method

Sets the color-remap table for the default category.

Overload List

Sets the color-remap table for the default category.

public void SetRemapTable(ColorMap[]);

Sets the color-remap table for a specified category.

public void SetRemapTable(ColorMap[],ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.SetRemapTable Method (ColorMap[])

Sets the color-remap table for the default category.

public void SetRemapTable(
ColorMap[] map
);

Parameters

map
An array of color pairs of type ColorMap. Each color pair contains an existing color (the first value) and the color that it will be mapped to (the second value).

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetRemapTable Overload List


ImageAttributes.SetRemapTable Method (ColorMap[], ColorAdjustType)

Sets the color-remap table for a specified category.

public void SetRemapTable(
ColorMap[] map,
ColorAdjustType type
);

Parameters

map
An array of color pairs of type ColorMap. Each color pair contains an existing color (the first value) and the color that it will be mapped to (the second value).
type
An element of ColorAdjustType that specifies the category for which the color-remap table is set.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetRemapTable Overload List


SetThreshold Method

Aspose.Imaging Documentation

ImageAttributes.SetThreshold Method

Sets the threshold (transparency range) for the default category.

Overload List

Sets the threshold (transparency range) for the default category.

public void SetThreshold(float);

Sets the threshold (transparency range) for a specified category.

public void SetThreshold(float,ColorAdjustType);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.SetThreshold Method (Single)

Sets the threshold (transparency range) for the default category.

public void SetThreshold(
float threshold
);

Parameters

threshold
A real number that specifies the threshold value.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetThreshold Overload List


ImageAttributes.SetThreshold Method (Single, ColorAdjustType)

Sets the threshold (transparency range) for a specified category.

public void SetThreshold(
float threshold,
ColorAdjustType type
);

Parameters

threshold
A threshold value from 0.0 to 1.0 that is used as a breakpoint to sort colors that will be mapped to either a maximum or a minimum value.
type
An element of ColorAdjustType that specifies the category for which the color threshold is set.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetThreshold Overload List


SetWrapMode Method

Aspose.Imaging Documentation

ImageAttributes.SetWrapMode Method

Sets the wrap mode that is used to decide how to tile a texture across a shape, or at shape boundaries. A texture is tiled across a shape to fill it in when the texture is smaller than the shape it is filling.

Overload List

Sets the wrap mode that is used to decide how to tile a texture across a shape, or at shape boundaries. A texture is tiled across a shape to fill it in when the texture is smaller than the shape it is filling.

public void SetWrapMode(WrapMode);

Sets the wrap mode and color used to decide how to tile a texture across a shape, or at shape boundaries. A texture is tiled across a shape to fill it in when the texture is smaller than the shape it is filling.

public void SetWrapMode(WrapMode,Color);

Sets the wrap mode and color used to decide how to tile a texture across a shape, or at shape boundaries. A texture is tiled across a shape to fill it in when the texture is smaller than the shape it is filling.

public void SetWrapMode(WrapMode,Color,bool);

See Also

ImageAttributes Class | Aspose.Imaging Namespace


ImageAttributes.SetWrapMode Method (WrapMode)

Sets the wrap mode that is used to decide how to tile a texture across a shape, or at shape boundaries. A texture is tiled across a shape to fill it in when the texture is smaller than the shape it is filling.

public void SetWrapMode(
WrapMode mode
);

Parameters

mode
An element of WrapMode that specifies how repeated copies of an image are used to tile an area.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetWrapMode Overload List


ImageAttributes.SetWrapMode Method (WrapMode, Color)

Sets the wrap mode and color used to decide how to tile a texture across a shape, or at shape boundaries. A texture is tiled across a shape to fill it in when the texture is smaller than the shape it is filling.

public void SetWrapMode(
WrapMode mode,
Color color
);

Parameters

mode
An element of WrapMode that specifies how repeated copies of an image are used to tile an area.
color
An ImageAttributes object that specifies the color of pixels outside of a rendered image. This color is visible if the mode parameter is set to Clamp and the source rectangle passed to DrawImage is larger than the image itself.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetWrapMode Overload List


ImageAttributes.SetWrapMode Method (WrapMode, Color, Boolean)

Sets the wrap mode and color used to decide how to tile a texture across a shape, or at shape boundaries. A texture is tiled across a shape to fill it in when the texture is smaller than the shape it is filling.

public void SetWrapMode(
WrapMode mode,
Color color,
bool clamp
);

Parameters

mode
An element of WrapMode that specifies how repeated copies of an image are used to tile an area.
color
A color object that specifies the color of pixels outside of a rendered image. This color is visible if the mode parameter is set to Clamp and the source rectangle passed to DrawImage is larger than the image itself.
clamp
This parameter has no effect. Set it to false.

See Also

ImageAttributes Class | Aspose.Imaging Namespace | ImageAttributes.SetWrapMode Overload List


ImageCreatorsRegistry Class

Represents the image creators registry.

For a list of all members of this type, see ImageCreatorsRegistry Members.

System.Object
Aspose.Imaging.ImageCreatorsRegistry

public abstract sealed class ImageCreatorsRegistry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ImageCreatorsRegistry Members | Aspose.Imaging Namespace


ImageCreatorsRegistry Members

ImageCreatorsRegistry overview

Public Static Properties

RegisteredDescriptors | Gets the registered descriptors.
RegisteredFormats | Gets the registered image creation formats.

Public Static Methods

CreateFirstSupportedCreator | Creates the first found creator suitable for the specified.
GetFirstSupportedDescriptor | Gets the fist found supported descriptor suitable for the specified.
RegisterCreator | Registers the creator.
UnregisterCreator | Unregisters the creator.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImageCreatorsRegistry Class | Aspose.Imaging Namespace


ImageCreatorsRegistry Properties

The properties of the ImageCreatorsRegistry class are listed below. For a complete list of ImageCreatorsRegistry class members, see the ImageCreatorsRegistry Members topic.

Public Static Properties

RegisteredDescriptors | Gets the registered descriptors.
RegisteredFormats | Gets the registered image creation formats.

See Also

ImageCreatorsRegistry Class | Aspose.Imaging Namespace


RegisteredDescriptors Property

Aspose.Imaging Documentation

ImageCreatorsRegistry.RegisteredDescriptors Property

Gets the registered descriptors.

public static IImageCreatorDescriptor[] RegisteredDescriptors {get;}

Property Value

The registered descriptors.

See Also

ImageCreatorsRegistry Class | Aspose.Imaging Namespace


RegisteredFormats Property

Aspose.Imaging Documentation

ImageCreatorsRegistry.RegisteredFormats Property

Gets the registered image creation formats.

public static FileFormat RegisteredFormats {get;}

Property Value

The registered image creation formats.

See Also

ImageCreatorsRegistry Class | Aspose.Imaging Namespace


ImageCreatorsRegistry Methods

The methods of the ImageCreatorsRegistry class are listed below. For a complete list of ImageCreatorsRegistry class members, see the ImageCreatorsRegistry Members topic.

Public Static Methods

CreateFirstSupportedCreator | Creates the first found creator suitable for the specified.
GetFirstSupportedDescriptor | Gets the fist found supported descriptor suitable for the specified.
RegisterCreator | Registers the creator.
UnregisterCreator | Unregisters the creator.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImageCreatorsRegistry Class | Aspose.Imaging Namespace


ImageCreatorsRegistry.CreateFirstSupportedCreator Method

Creates the first found creator suitable for the specified.

public static IImageCreator CreateFirstSupportedCreator(
ImageOptionsBase imageOptions
);

Parameters

imageOptions
The image options.

Return Value

The creator which supports the specified or null if no such creator is found.

Remarks

The first creator will be actually the last registered.

See Also

ImageCreatorsRegistry Class | Aspose.Imaging Namespace


ImageCreatorsRegistry.GetFirstSupportedDescriptor Method

Gets the fist found supported descriptor suitable for the specified.

public static IImageCreatorDescriptor GetFirstSupportedDescriptor(
ImageOptionsBase imageOptions
);

Parameters

imageOptions
The image options.

Return Value

The creator descriptor which supports the specified or null if no such descriptor is found.

Remarks

The first creator descriptor will be actually the last registered.

See Also

ImageCreatorsRegistry Class | Aspose.Imaging Namespace


ImageCreatorsRegistry.RegisterCreator Method

Registers the creator.

public static void RegisterCreator(
IImageCreatorDescriptor creatorDescriptor
);

Parameters

creatorDescriptor
The creator descriptor to register.

See Also

ImageCreatorsRegistry Class | Aspose.Imaging Namespace


ImageCreatorsRegistry.UnregisterCreator Method

Unregisters the creator.

public static void UnregisterCreator(
IImageCreatorDescriptor creatorDescriptor
);

Parameters

creatorDescriptor
The creator descriptor.

See Also

ImageCreatorsRegistry Class | Aspose.Imaging Namespace


ImageExportersRegistry Class

Represents the image exporters registry.

For a list of all members of this type, see ImageExportersRegistry Members.

System.Object
Aspose.Imaging.ImageExportersRegistry

public abstract sealed class ImageExportersRegistry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ImageExportersRegistry Members | Aspose.Imaging Namespace


ImageExportersRegistry Members

ImageExportersRegistry overview

Public Static Properties

RegisteredExporterDescriptors | Gets the registered exporter descriptors.
RegisteredFormats | Gets the registered export formats.

Public Static Methods

CreateFirstSupportedExporter | Creates the first found exporter suitable for the specified save options and image.
GetFirstSupportedDescriptor | Gets the fist found supported descriptor suitable for the specified save options and image.
RegisterExporter | Registers the exporter.
UnregisterExporter | Unregisters the exporter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImageExportersRegistry Class | Aspose.Imaging Namespace


ImageExportersRegistry Properties

The properties of the ImageExportersRegistry class are listed below. For a complete list of ImageExportersRegistry class members, see the ImageExportersRegistry Members topic.

Public Static Properties

RegisteredExporterDescriptors | Gets the registered exporter descriptors.
RegisteredFormats | Gets the registered export formats.

See Also

ImageExportersRegistry Class | Aspose.Imaging Namespace


RegisteredExporterDescriptors Property

Aspose.Imaging Documentation

ImageExportersRegistry.RegisteredExporterDescriptors Property

Gets the registered exporter descriptors.

public static IImageExporterDescriptor[] RegisteredExporterDescriptors {get;}

Property Value

The registered exporter descriptors.

See Also

ImageExportersRegistry Class | Aspose.Imaging Namespace


RegisteredFormats Property

Aspose.Imaging Documentation

ImageExportersRegistry.RegisteredFormats Property

Gets the registered export formats.

public static FileFormat RegisteredFormats {get;}

Property Value

The registered export formats.

See Also

ImageExportersRegistry Class | Aspose.Imaging Namespace


ImageExportersRegistry Methods

The methods of the ImageExportersRegistry class are listed below. For a complete list of ImageExportersRegistry class members, see the ImageExportersRegistry Members topic.

Public Static Methods

CreateFirstSupportedExporter | Creates the first found exporter suitable for the specified save options and image.
GetFirstSupportedDescriptor | Gets the fist found supported descriptor suitable for the specified save options and image.
RegisterExporter | Registers the exporter.
UnregisterExporter | Unregisters the exporter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImageExportersRegistry Class | Aspose.Imaging Namespace


ImageExportersRegistry.CreateFirstSupportedExporter Method

Creates the first found exporter suitable for the specified save options and image.

public static IImageExporter CreateFirstSupportedExporter(
Image image,
ImageOptionsBase options
);

Parameters

image
The image to export.
options
The save options to use for export.

Return Value

The exporter which supports the specified image and save options or null if no such exporter is found.

Remarks

The first exporter will be actually the last registered.

See Also

ImageExportersRegistry Class | Aspose.Imaging Namespace


ImageExportersRegistry.GetFirstSupportedDescriptor Method

Gets the fist found supported descriptor suitable for the specified save options and image.

public static IImageExporterDescriptor GetFirstSupportedDescriptor(
Image image,
ImageOptionsBase options
);

Parameters

image
The image to export.
options
The options.

Return Value

The exporter descriptor which supports the specified image and save options or null if no such descriptor is found.

Remarks

The first exporter descriptor will be actually the last registered.

See Also

ImageExportersRegistry Class | Aspose.Imaging Namespace


ImageExportersRegistry.RegisterExporter Method

Registers the exporter.

public static void RegisterExporter(
IImageExporterDescriptor exporterDescriptor
);

Parameters

exporterDescriptor
The exporter descriptor to register.

See Also

ImageExportersRegistry Class | Aspose.Imaging Namespace


ImageExportersRegistry.UnregisterExporter Method

Unregisters the exporter.

public static void UnregisterExporter(
IImageExporterDescriptor exporterDescriptor
);

Parameters

exporterDescriptor
The exporter descriptor to unregister.

See Also

ImageExportersRegistry Class | Aspose.Imaging Namespace


ImageLoadersRegistry Class

Represents the image loaders registry.

For a list of all members of this type, see ImageLoadersRegistry Members.

System.Object
Aspose.Imaging.ImageLoadersRegistry

public abstract sealed class ImageLoadersRegistry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ImageLoadersRegistry Members | Aspose.Imaging Namespace


ImageLoadersRegistry Members

ImageLoadersRegistry overview

Public Static Properties

RegisteredDescriptors | Gets the registered descriptors.
RegisteredFormats | Gets the registered image loading formats.

Public Static Methods

CreateFirstSupportedLoader | Creates the first found loader suitable for the specified stream and optionally the loadOptions.
GetFirstSupportedDescriptor | Gets the fist found supported descriptor suitable for the specified stream and optionally the loadOptions.
GetFirstSupportedDescriptorByTypeName | Gets the first supported descriptor by its type name.
RegisterLoader | Registers the loader.
UnregisterLoader | Unregisters the loader.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImageLoadersRegistry Class | Aspose.Imaging Namespace


ImageLoadersRegistry Properties

The properties of the ImageLoadersRegistry class are listed below. For a complete list of ImageLoadersRegistry class members, see the ImageLoadersRegistry Members topic.

Public Static Properties

RegisteredDescriptors | Gets the registered descriptors.
RegisteredFormats | Gets the registered image loading formats.

See Also

ImageLoadersRegistry Class | Aspose.Imaging Namespace


RegisteredDescriptors Property

Aspose.Imaging Documentation

ImageLoadersRegistry.RegisteredDescriptors Property

Gets the registered descriptors.

public static IImageLoaderDescriptor[] RegisteredDescriptors {get;}

Property Value

The registered descriptors.

See Also

ImageLoadersRegistry Class | Aspose.Imaging Namespace


RegisteredFormats Property

Aspose.Imaging Documentation

ImageLoadersRegistry.RegisteredFormats Property

Gets the registered image loading formats.

public static FileFormat RegisteredFormats {get;}

Property Value

The registered image loading formats.

See Also

ImageLoadersRegistry Class | Aspose.Imaging Namespace


ImageLoadersRegistry Methods

The methods of the ImageLoadersRegistry class are listed below. For a complete list of ImageLoadersRegistry class members, see the ImageLoadersRegistry Members topic.

Public Static Methods

CreateFirstSupportedLoader | Creates the first found loader suitable for the specified stream and optionally the loadOptions.
GetFirstSupportedDescriptor | Gets the fist found supported descriptor suitable for the specified stream and optionally the loadOptions.
GetFirstSupportedDescriptorByTypeName | Gets the first supported descriptor by its type name.
RegisterLoader | Registers the loader.
UnregisterLoader | Unregisters the loader.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImageLoadersRegistry Class | Aspose.Imaging Namespace


ImageLoadersRegistry.CreateFirstSupportedLoader Method

Creates the first found loader suitable for the specified stream and optionally the loadOptions.

public static IImageLoader CreateFirstSupportedLoader(
Stream stream,
LoadOptions loadOptions
);

Parameters

stream
The stream.
loadOptions
The load options.

Return Value

The loader which supports the specified stream and loadOptions or null if no such loader is found.

Remarks

The first loader will be actually the last registered.

See Also

ImageLoadersRegistry Class | Aspose.Imaging Namespace


ImageLoadersRegistry.GetFirstSupportedDescriptor Method

Gets the fist found supported descriptor suitable for the specified stream and optionally the loadOptions.

public static IImageLoaderDescriptor GetFirstSupportedDescriptor(
Stream stream,
LoadOptions loadOptions
);

Parameters

stream
The stream.
loadOptions
The load options.

Return Value

The loader descriptor which supports the specified stream and loadOptions or null if no such descriptor is found.

Remarks

The first loader descriptor will be actually the last registered.

See Also

ImageLoadersRegistry Class | Aspose.Imaging Namespace


ImageLoadersRegistry.GetFirstSupportedDescriptorByTypeName Method

Gets the first supported descriptor by its type name.

public static IImageLoaderDescriptor GetFirstSupportedDescriptorByTypeName(
string descriptorTypeName
);

Parameters

descriptorTypeName
The descriptor type name.

Return Value

The first found loader descriptor or null if not such descriptor is found.

Remarks

The first loader descriptor will be actually the last registered.

See Also

ImageLoadersRegistry Class | Aspose.Imaging Namespace


ImageLoadersRegistry.RegisterLoader Method

Registers the loader.

public static void RegisterLoader(
IImageLoaderDescriptor loaderDescriptor
);

Parameters

loaderDescriptor
The loader descriptor to register.

See Also

ImageLoadersRegistry Class | Aspose.Imaging Namespace


ImageLoadersRegistry.UnregisterLoader Method

Unregisters the loader.

public static void UnregisterLoader(
IImageLoaderDescriptor loaderDescriptor
);

Parameters

loaderDescriptor
The loader descriptor to unregister.

See Also

ImageLoadersRegistry Class | Aspose.Imaging Namespace


ImageOptionsBase Class

The image base options.

For a list of all members of this type, see ImageOptionsBase Members.

System.Object
Aspose.Imaging.ImageOptionsBase
Derived types

public abstract class ImageOptionsBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ImageOptionsBase Members | Aspose.Imaging Namespace


ImageOptionsBase Members

ImageOptionsBase overview

Public Instance Properties

Palette | Gets or sets the color palette.
Source | Gets or sets the source to create image in.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ImageOptionsBase Overloaded. Initializes a new instance of the ImageOptionsBase class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageOptionsBase Class | Aspose.Imaging Namespace


ImageOptionsBase Constructor

Initializes a new instance of the ImageOptionsBase class.

Overload List

Initializes a new instance of the ImageOptionsBase class.

protected ImageOptionsBase();

Initializes a new instance of the ImageOptionsBase class.

protected ImageOptionsBase(ImageOptionsBase);

See Also

ImageOptionsBase Class | Aspose.Imaging Namespace


ImageOptionsBase Constructor ()

Initializes a new instance of the ImageOptionsBase class.

protected ImageOptionsBase();

See Also

ImageOptionsBase Class | Aspose.Imaging Namespace | ImageOptionsBase Constructor Overload List


ImageOptionsBase Constructor (ImageOptionsBase)

Initializes a new instance of the ImageOptionsBase class.

protected ImageOptionsBase(
ImageOptionsBase imageOptions
);

Parameters

imageOptions
The image options.

See Also

ImageOptionsBase Class | Aspose.Imaging Namespace | ImageOptionsBase Constructor Overload List


ImageOptionsBase Properties

The properties of the ImageOptionsBase class are listed below. For a complete list of ImageOptionsBase class members, see the ImageOptionsBase Members topic.

Public Instance Properties

Palette | Gets or sets the color palette.
Source | Gets or sets the source to create image in.

See Also

ImageOptionsBase Class | Aspose.Imaging Namespace


Palette Property

Aspose.Imaging Documentation

ImageOptionsBase.Palette Property

Gets or sets the color palette.

public virtual IColorPalette Palette {get; set;}

Property Value

The color palette.

See Also

ImageOptionsBase Class | Aspose.Imaging Namespace


Source Property

Aspose.Imaging Documentation

ImageOptionsBase.Source Property

Gets or sets the source to create image in.

public Source Source {get; set;}

Property Value

The source to create image in.

See Also

ImageOptionsBase Class | Aspose.Imaging Namespace


InterpolationMode Enumeration

The InterpolationMode enumeration specifies the algorithm that is used when images are scaled or rotated.

public enum InterpolationMode

Members

Member Name | Description | Value
Invalid | Invalid interpolation mode. | -1
Default | Specifies default mode. | 0
Low | Specifies low quality interpolation. | 1
High | Specifies high quality interpolation. | 2
Bilinear | Specifies bilinear interpolation. No prefiltering is done. This mode is not suitable for shrinking an image below 50 percent of its original size. | 3
Bicubic | Specifies bicubic interpolation. No prefiltering is done. This mode is not suitable for shrinking an image below 25 percent of its original size. | 4
NearestNeighbor | Specifies nearest-neighbor interpolation. | 5
HighQualityBilinear | Specifies high-quality, bilinear interpolation. Prefiltering is performed to ensure high-quality shrinking. | 6
HighQualityBicubic | Specifies high-quality, bicubic interpolation. Prefiltering is performed to ensure high-quality shrinking. This mode produces the highest quality transformed images. | 7

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


IObjectWithBounds Interface

Represents an object with bounds.

For a list of all members of this type, see IObjectWithBounds Members.

public interface IObjectWithBounds

Types that implement IObjectWithBounds

Type | Description
BmpImage | A bmp image.
CadImage | Cad image class
GifFrameBlock | Gif frame block.
GifImage | A gif image.
JpegImage | A jpeg image.
PngImage | Represents PNG image.
PsdImage | A PSD image.
TiffFrame | The tiff frame.
TiffImage | The tiff image.
Image | The image is the base class for all type of images.
RasterCachedImage | Represents a raster image supporting raster graphics operations. This image caches pixel data when required.
RasterImage | Represents a raster image supporting raster graphics operations.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IObjectWithBounds Members | Aspose.Imaging Namespace


IObjectWithBounds Members

IObjectWithBounds overview

Public Instance Properties

Bounds | Gets the object bounds.
Height | Gets the object height.
Size | Gets the object size.
Width | Gets the object width.

See Also

IObjectWithBounds Interface | Aspose.Imaging Namespace


IObjectWithBounds Properties

The properties of the IObjectWithBounds interface are listed below. For a complete list of IObjectWithBounds interface members, see the IObjectWithBounds Members topic.

Public Instance Properties

Bounds | Gets the object bounds.
Height | Gets the object height.
Size | Gets the object size.
Width | Gets the object width.

See Also

IObjectWithBounds Interface | Aspose.Imaging Namespace


Bounds Property

Aspose.Imaging Documentation

IObjectWithBounds.Bounds Property

Gets the object bounds.

Rectangle Bounds {get;}

Property Value

The object bounds.

See Also

IObjectWithBounds Interface | Aspose.Imaging Namespace


Height Property

Aspose.Imaging Documentation

IObjectWithBounds.Height Property

Gets the object height.

int Height {get;}

Property Value

The object height.

See Also

IObjectWithBounds Interface | Aspose.Imaging Namespace


Size Property

Aspose.Imaging Documentation

IObjectWithBounds.Size Property

Gets the object size.

Size Size {get;}

Property Value

The object size.

See Also

IObjectWithBounds Interface | Aspose.Imaging Namespace


Width Property

Aspose.Imaging Documentation

IObjectWithBounds.Width Property

Gets the object width.

int Width {get;}

Property Value

The object width.

See Also

IObjectWithBounds Interface | Aspose.Imaging Namespace


IOrderedShape Interface

Represents an ordered shape. An ordered shape is a continuous set of points having a start point and end point. The continuous set of points connected using a specific rule.

For a list of all members of this type, see IOrderedShape Members.

public interface IOrderedShape

Types that implement IOrderedShape

Type | Description
ArcShape | Represents an arc shape.
BezierShape | Represents a bezier spline.
CurveShape | Represents a curved spline shape.
PolygonShape | Represents a polygon shape.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IOrderedShape Members | Aspose.Imaging Namespace


IOrderedShape Members

IOrderedShape overview

Public Instance Properties

EndPoint | Gets the ending shape point.
IsClosed | Gets or sets a value indicating whether ordered shape is closed. When processing closed ordered shape the starting and ending points have no meaning.
StartPoint | Gets the starting shape point.

Public Instance Methods

Reverse Reverses the order of points for this shape.

See Also

IOrderedShape Interface | Aspose.Imaging Namespace


IOrderedShape Properties

The properties of the IOrderedShape interface are listed below. For a complete list of IOrderedShape interface members, see the IOrderedShape Members topic.

Public Instance Properties

EndPoint | Gets the ending shape point.
IsClosed | Gets or sets a value indicating whether ordered shape is closed. When processing closed ordered shape the starting and ending points have no meaning.
StartPoint | Gets the starting shape point.

See Also

IOrderedShape Interface | Aspose.Imaging Namespace


EndPoint Property

Aspose.Imaging Documentation

IOrderedShape.EndPoint Property

Gets the ending shape point.

PointF EndPoint {get;}

Property Value

The ending shape point.

See Also

IOrderedShape Interface | Aspose.Imaging Namespace


IsClosed Property

Aspose.Imaging Documentation

IOrderedShape.IsClosed Property

Gets or sets a value indicating whether ordered shape is closed. When processing closed ordered shape the starting and ending points have no meaning.

bool IsClosed {get; set;}

Property Value

True if this ordered shape is closed; otherwise, false.

See Also

IOrderedShape Interface | Aspose.Imaging Namespace


StartPoint Property

Aspose.Imaging Documentation

IOrderedShape.StartPoint Property

Gets the starting shape point.

PointF StartPoint {get;}

Property Value

The starting shape point.

See Also

IOrderedShape Interface | Aspose.Imaging Namespace


IOrderedShape Methods

The methods of the IOrderedShape interface are listed below. For a complete list of IOrderedShape interface members, see the IOrderedShape Members topic.

Public Instance Methods

Reverse Reverses the order of points for this shape.

See Also

IOrderedShape Interface | Aspose.Imaging Namespace


IOrderedShape.Reverse Method

Reverses the order of points for this shape.

void Reverse();

See Also

IOrderedShape Interface | Aspose.Imaging Namespace


IPartialCMYKPixelLoader Interface

Conforms to the pixels loaded partially.

For a list of all members of this type, see IPartialCMYKPixelLoader Members.

public interface IPartialCMYKPixelLoader : IPartialPixelLoader

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IPartialCMYKPixelLoader Members | Aspose.Imaging Namespace


IPartialCMYKPixelLoader Members

IPartialCMYKPixelLoader overview

Public Instance Methods

Process Processes the loaded pixels.

See Also

IPartialCMYKPixelLoader Interface | Aspose.Imaging Namespace


IPartialCMYKPixelLoader Methods

The methods of the IPartialCMYKPixelLoader interface are listed below. For a complete list of IPartialCMYKPixelLoader interface members, see the IPartialCMYKPixelLoader Members topic.

Public Instance Methods

Process Processes the loaded pixels.

See Also

IPartialCMYKPixelLoader Interface | Aspose.Imaging Namespace


IPartialCMYKPixelLoader.Process Method

Processes the loaded pixels.

void Process(
Rectangle pixelsRectangle,
CMYKColor[] pixels,
Point start,
Point end
);

Parameters

pixelsRectangle
The pixels rectangle.
pixels
The pixels.
start
The start pixels point. If not equal to (left,top) meaning that it is not full rectangle we have.
end
The end pixels point. If not equal to (right,bottom) meaning that it is not full rectangle we have.

See Also

IPartialCMYKPixelLoader Interface | Aspose.Imaging Namespace


IPartialPixelLoader Interface

Conforms to the pixels loaded partially.

For a list of all members of this type, see IPartialPixelLoader Members.

Aspose.Imaging.IPartialPixelLoader
Aspose.Imaging.IPartialCMYKPixelLoader

public interface IPartialPixelLoader

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IPartialPixelLoader Members | Aspose.Imaging Namespace


IPartialPixelLoader Members

IPartialPixelLoader overview

Public Instance Methods

Process Processes the loaded pixels.

See Also

IPartialPixelLoader Interface | Aspose.Imaging Namespace


IPartialPixelLoader Methods

The methods of the IPartialPixelLoader interface are listed below. For a complete list of IPartialPixelLoader interface members, see the IPartialPixelLoader Members topic.

Public Instance Methods

Process Processes the loaded pixels.

See Also

IPartialPixelLoader Interface | Aspose.Imaging Namespace


IPartialPixelLoader.Process Method

Processes the loaded pixels.

void Process(
Rectangle pixelsRectangle,
Color[] pixels,
Point start,
Point end
);

Parameters

pixelsRectangle
The pixels rectangle.
pixels
The pixels.
start
The start pixels point. If not equal to (left,top) meaning that it is not full rectangle we have.
end
The end pixels point. If not equal to (right,bottom) meaning that it is not full rectangle we have.

See Also

IPartialPixelLoader Interface | Aspose.Imaging Namespace


IPartialRawDataLoader Interface

The partial data loader.

For a list of all members of this type, see IPartialRawDataLoader Members.

public interface IPartialRawDataLoader

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IPartialRawDataLoader Members | Aspose.Imaging Namespace


IPartialRawDataLoader Members

IPartialRawDataLoader overview

Public Instance Methods

Process Processes the loaded data.

See Also

IPartialRawDataLoader Interface | Aspose.Imaging Namespace


IPartialRawDataLoader Methods

The methods of the IPartialRawDataLoader interface are listed below. For a complete list of IPartialRawDataLoader interface members, see the IPartialRawDataLoader Members topic.

Public Instance Methods

Process Processes the loaded data.

See Also

IPartialRawDataLoader Interface | Aspose.Imaging Namespace


IPartialRawDataLoader.Process Method

Processes the loaded data.

void Process(
Rectangle rectangle,
byte[] data,
Point start,
Point end
);

Parameters

rectangle
The data rectangle.
data
The raw data.
start
The start data point. If not equal to (left,top) meaning that it is not full rectangle we have.
end
The end data point. If not equal to (right,bottom) meaning that it is not full rectangle we have.

See Also

IPartialRawDataLoader Interface | Aspose.Imaging Namespace


IPsdColorPalette Interface

The pasd color palette

For a list of all members of this type, see IPsdColorPalette Members.

public interface IPsdColorPalette : IColorPalette

Types that implement IPsdColorPalette

Type | Description
PsdColorPalette | The PSD color palette.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IPsdColorPalette Members | Aspose.Imaging Namespace


IPsdColorPalette Members

IPsdColorPalette overview

Public Instance Properties

HasTransparentColor | Gets a value indicating whether transparent color exists.
RawEntries | Gets the raw color palette entries data.
RawEntriesCount | Gets the raw color palette entries count.
TransparentColor | Gets the transparent color.
TransparentIndex | Gets the index of the transparent color.

See Also

IPsdColorPalette Interface | Aspose.Imaging Namespace


IPsdColorPalette Properties

The properties of the IPsdColorPalette interface are listed below. For a complete list of IPsdColorPalette interface members, see the IPsdColorPalette Members topic.

Public Instance Properties

HasTransparentColor | Gets a value indicating whether transparent color exists.
RawEntries | Gets the raw color palette entries data.
RawEntriesCount | Gets the raw color palette entries count.
TransparentColor | Gets the transparent color.
TransparentIndex | Gets the index of the transparent color.

See Also

IPsdColorPalette Interface | Aspose.Imaging Namespace


HasTransparentColor Property

Aspose.Imaging Documentation

IPsdColorPalette.HasTransparentColor Property

Gets a value indicating whether transparent color exists.

bool HasTransparentColor {get;}

Property Value

true if transparent color exists; otherwise, false.

See Also

IPsdColorPalette Interface | Aspose.Imaging Namespace


RawEntries Property

Aspose.Imaging Documentation

IPsdColorPalette.RawEntries Property

Gets the raw color palette entries data.

byte[] RawEntries {get;}

Property Value

The raw color palette entries data.

See Also

IPsdColorPalette Interface | Aspose.Imaging Namespace


RawEntriesCount Property

Aspose.Imaging Documentation

IPsdColorPalette.RawEntriesCount Property

Gets the raw color palette entries count.

int RawEntriesCount {get;}

Property Value

The raw color palette entries count.

See Also

IPsdColorPalette Interface | Aspose.Imaging Namespace


TransparentColor Property

Aspose.Imaging Documentation

IPsdColorPalette.TransparentColor Property

Gets the transparent color.

Color TransparentColor {get;}

Property Value

The transparent color.

See Also

IPsdColorPalette Interface | Aspose.Imaging Namespace


TransparentIndex Property

Aspose.Imaging Documentation

IPsdColorPalette.TransparentIndex Property

Gets the index of the transparent color.

short TransparentIndex {get;}

Property Value

The index of the transparent color.

See Also

IPsdColorPalette Interface | Aspose.Imaging Namespace


IRasterImagePixelLoader Interface

The raster image pixel loader.

For a list of all members of this type, see IRasterImagePixelLoader Members.

public interface IRasterImagePixelLoader : IRasterImageRawDataLoader

Types that implement IRasterImagePixelLoader

Type | Description
BmpImage | A bmp image.
GifFrameBlock | Gif frame block.
GifImage | A gif image.
JpegImage | A jpeg image.
PngImage | Represents PNG image.
PsdImage | A PSD image.
TiffFrame | The tiff frame.
TiffImage | The tiff image.
RasterCachedImage | Represents a raster image supporting raster graphics operations. This image caches pixel data when required.
RasterImage | Represents a raster image supporting raster graphics operations.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IRasterImagePixelLoader Members | Aspose.Imaging Namespace


IRasterImagePixelLoader Members

IRasterImagePixelLoader overview

Public Instance Methods

LoadPartialPixels Loads pixels partially (by blocks).

See Also

IRasterImagePixelLoader Interface | Aspose.Imaging Namespace


IRasterImagePixelLoader Methods

The methods of the IRasterImagePixelLoader interface are listed below. For a complete list of IRasterImagePixelLoader interface members, see the IRasterImagePixelLoader Members topic.

Public Instance Methods

LoadPartialPixels Loads pixels partially (by blocks).

See Also

IRasterImagePixelLoader Interface | Aspose.Imaging Namespace


IRasterImagePixelLoader.LoadPartialPixels Method

Loads pixels partially (by blocks).

void LoadPartialPixels(
Rectangle rectangle,
IPartialPixelLoader partialLoader
);

Parameters

rectangle
The rectangle to load pixels from.
partialLoader
The partial loader.

See Also

IRasterImagePixelLoader Interface | Aspose.Imaging Namespace


IRasterImageRawDataLoader Interface

The raster image raw data loader.

For a list of all members of this type, see IRasterImageRawDataLoader Members.

Aspose.Imaging.IRasterImageRawDataLoader
Aspose.Imaging.IRasterImagePixelLoader

public interface IRasterImageRawDataLoader

Types that implement IRasterImageRawDataLoader

Type | Description
BmpImage | A bmp image.
GifFrameBlock | Gif frame block.
GifImage | A gif image.
JpegImage | A jpeg image.
PngImage | Represents PNG image.
PsdImage | A PSD image.
TiffFrame | The tiff frame.
TiffImage | The tiff image.
RasterCachedImage | Represents a raster image supporting raster graphics operations. This image caches pixel data when required.
RasterImage | Represents a raster image supporting raster graphics operations.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IRasterImageRawDataLoader Members | Aspose.Imaging Namespace


IRasterImageRawDataLoader Members

IRasterImageRawDataLoader overview

Public Instance Properties

IsRawDataAvailable | Gets a value indicating whether raw data loading is supported.
RawDataSettings | Gets the current raw data settings. Note when using these settings the data loads without conversion.

Public Instance Methods

LoadRawData Loads raw data.

See Also

IRasterImageRawDataLoader Interface | Aspose.Imaging Namespace


IRasterImageRawDataLoader Properties

The properties of the IRasterImageRawDataLoader interface are listed below. For a complete list of IRasterImageRawDataLoader interface members, see the IRasterImageRawDataLoader Members topic.

Public Instance Properties

IsRawDataAvailable | Gets a value indicating whether raw data loading is supported.
RawDataSettings | Gets the current raw data settings. Note when using these settings the data loads without conversion.

See Also

IRasterImageRawDataLoader Interface | Aspose.Imaging Namespace


IsRawDataAvailable Property

Aspose.Imaging Documentation

IRasterImageRawDataLoader.IsRawDataAvailable Property

Gets a value indicating whether raw data loading is supported.

bool IsRawDataAvailable {get;}

Property Value

true if raw data loading is supported; otherwise, false.

See Also

IRasterImageRawDataLoader Interface | Aspose.Imaging Namespace


RawDataSettings Property

Aspose.Imaging Documentation

IRasterImageRawDataLoader.RawDataSettings Property

Gets the current raw data settings. Note when using these settings the data loads without conversion.

RawDataSettings RawDataSettings {get;}

Property Value

The current raw data settings.

See Also

IRasterImageRawDataLoader Interface | Aspose.Imaging Namespace


IRasterImageRawDataLoader Methods

The methods of the IRasterImageRawDataLoader interface are listed below. For a complete list of IRasterImageRawDataLoader interface members, see the IRasterImageRawDataLoader Members topic.

Public Instance Methods

LoadRawData Loads raw data.

See Also

IRasterImageRawDataLoader Interface | Aspose.Imaging Namespace


IRasterImageRawDataLoader.LoadRawData Method

Loads raw data.

void LoadRawData(
Rectangle rectangle,
RawDataSettings rawDataSettings,
IPartialRawDataLoader rawDataLoader
);

Parameters

rectangle
The rectangle to load raw data from.
rawDataSettings
The raw data settings to use for loaded data. Note if data is not in the format specified then data conversion will be performed.
rawDataLoader
The raw data loader.

See Also

IRasterImageRawDataLoader Interface | Aspose.Imaging Namespace


KnownColor Enumeration

Specifies the known system colors.

public enum KnownColor

Members

Member Name | Description | Value
Transparent | A system-defined color. | 27
AliceBlue | A system-defined color. | 28
AntiqueWhite | A system-defined color. | 29
Aqua | A system-defined color. | 30
Aquamarine | A system-defined color. | 31
Azure | A system-defined color. | 32
Beige | A system-defined color. | 33
Bisque | A system-defined color. | 34
Black | A system-defined color. | 35
BlanchedAlmond | A system-defined color. | 36
Blue | A system-defined color. | 37
BlueViolet | A system-defined color. | 38
Brown | A system-defined color. | 39
BurlyWood | A system-defined color. | 40
CadetBlue | A system-defined color. | 41
Chartreuse | A system-defined color. | 42
Chocolate | A system-defined color. | 43
Coral | A system-defined color. | 44
CornflowerBlue | A system-defined color. | 45
Cornsilk | A system-defined color. | 46
Crimson | A system-defined color. | 47
Cyan | A system-defined color. | 48
DarkBlue | A system-defined color. | 49
DarkCyan | A system-defined color. | 50
DarkGoldenrod | A system-defined color. | 51
DarkGray | A system-defined color. | 52
DarkGreen | A system-defined color. | 53
DarkKhaki | A system-defined color. | 54
DarkMagenta | A system-defined color. | 55
DarkOliveGreen | A system-defined color. | 56
DarkOrange | A system-defined color. | 57
DarkOrchid | A system-defined color. | 58
DarkRed | A system-defined color. | 59
DarkSalmon | A system-defined color. | 60
DarkSeaGreen | A system-defined color. | 61
DarkSlateBlue | A system-defined color. | 62
DarkSlateGray | A system-defined color. | 63
DarkTurquoise | A system-defined color. | 64
DarkViolet | A system-defined color. | 65
DeepPink | A system-defined color. | 66
DeepSkyBlue | A system-defined color. | 67
DimGray | A system-defined color. | 68
DodgerBlue | A system-defined color. | 69
Firebrick | A system-defined color. | 70
FloralWhite | A system-defined color. | 71
ForestGreen | A system-defined color. | 72
Fuchsia | A system-defined color. | 73
Gainsboro | A system-defined color. | 74
GhostWhite | A system-defined color. | 75
Gold | A system-defined color. | 76
Goldenrod | A system-defined color. | 77
Gray | A system-defined color. | 78
Green | A system-defined color. | 79
GreenYellow | A system-defined color. | 80
Honeydew | A system-defined color. | 81
HotPink | A system-defined color. | 82
IndianRed | A system-defined color. | 83
Indigo | A system-defined color. | 84
Ivory | A system-defined color. | 85
Khaki | A system-defined color. | 86
Lavender | A system-defined color. | 87
LavenderBlush | A system-defined color. | 88
LawnGreen | A system-defined color. | 89
LemonChiffon | A system-defined color. | 90
LightBlue | A system-defined color. | 91
LightCoral | A system-defined color. | 92
LightCyan | A system-defined color. | 93
LightGoldenrodYellow | A system-defined color. | 94
LightGray | A system-defined color. | 95
LightGreen | A system-defined color. | 96
LightPink | A system-defined color. | 97
LightSalmon | A system-defined color. | 98
LightSeaGreen | A system-defined color. | 99
LightSkyBlue | A system-defined color. | 100
LightSlateGray | A system-defined color. | 101
LightSteelBlue | A system-defined color. | 102
LightYellow | A system-defined color. | 103
Lime | A system-defined color. | 104
LimeGreen | A system-defined color. | 105
Linen | A system-defined color. | 106
Magenta | A system-defined color. | 107
Maroon | A system-defined color. | 108
MediumAquamarine | A system-defined color. | 109
MediumBlue | A system-defined color. | 110
MediumOrchid | A system-defined color. | 111
MediumPurple | A system-defined color. | 112
MediumSeaGreen | A system-defined color. | 113
MediumSlateBlue | A system-defined color. | 114
MediumSpringGreen | A system-defined color. | 115
MediumTurquoise | A system-defined color. | 116
MediumVioletRed | A system-defined color. | 117
MidnightBlue | A system-defined color. | 118
MintCream | A system-defined color. | 119
MistyRose | A system-defined color. | 120
Moccasin | A system-defined color. | 121
NavajoWhite | A system-defined color. | 122
Navy | A system-defined color. | 123
OldLace | A system-defined color. | 124
Olive | A system-defined color. | 125
OliveDrab | A system-defined color. | 126
Orange | A system-defined color. | 127
OrangeRed | A system-defined color. | 128
Orchid | A system-defined color. | 129
PaleGoldenrod | A system-defined color. | 130
PaleGreen | A system-defined color. | 131
PaleTurquoise | A system-defined color. | 132
PaleVioletRed | A system-defined color. | 133
PapayaWhip | A system-defined color. | 134
PeachPuff | A system-defined color. | 135
Peru | A system-defined color. | 136
Pink | A system-defined color. | 137
Plum | A system-defined color. | 138
PowderBlue | A system-defined color. | 139
Purple | A system-defined color. | 140
Red | A system-defined color. | 141
RosyBrown | A system-defined color. | 142
RoyalBlue | A system-defined color. | 143
SaddleBrown | A system-defined color. | 144
Salmon | A system-defined color. | 145
SandyBrown | A system-defined color. | 146
SeaGreen | A system-defined color. | 147
SeaShell | A system-defined color. | 148
Sienna | A system-defined color. | 149
Silver | A system-defined color. | 150
SkyBlue | A system-defined color. | 151
SlateBlue | A system-defined color. | 152
SlateGray | A system-defined color. | 153
Snow | A system-defined color. | 154
SpringGreen | A system-defined color. | 155
SteelBlue | A system-defined color. | 156
Tan | A system-defined color. | 157
Teal | A system-defined color. | 158
Thistle | A system-defined color. | 159
Tomato | A system-defined color. | 160
Turquoise | A system-defined color. | 161
Violet | A system-defined color. | 162
Wheat | A system-defined color. | 163
White | A system-defined color. | 164
WhiteSmoke | A system-defined color. | 165
Yellow | A system-defined color. | 166
YellowGreen | A system-defined color. | 167

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


License Class

Provides methods to license the component.

For a list of all members of this type, see License Members.

System.Object
Aspose.Imaging.License

public class License

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As license = New license
License.SetLicense("MyLicense.lic")
the component jar file:
Requirements
Namespace:  Aspose.Imaging
Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also
License Members | Aspose.Imaging Namespace


License Members

License overview

Public Instance Constructors

License Constructor Initializes a new instance of this class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetLicense | Overloaded. Licenses the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

License Class | Aspose.Imaging Namespace


License Constructor

Initializes a new instance of this class.

public License();

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As license = New license
License.SetLicense("MyLicense.lic")
the component jar file:
See Also
License Class | Aspose.Imaging Namespace


License Methods

The methods of the License class are listed below. For a complete list of License class members, see the License Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetLicense | Overloaded. Licenses the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

License Class | Aspose.Imaging Namespace


SetLicense Method

Aspose.Imaging Documentation

License.SetLicense Method

Licenses the component.

Overload List

Licenses the component.

public void SetLicense(Stream);

Licenses the component.

public void SetLicense(string);

See Also

License Class | Aspose.Imaging Namespace


License.SetLicense Method (Stream)

Licenses the component.

public void SetLicense(
Stream stream
);

Parameters

stream
A stream that contains the license.

Remarks

Use this method to load a license from a stream.

Example

See Also
License Class | Aspose.Imaging Namespace | License.SetLicense Overload List


License.SetLicense Method (String)

Licenses the component.

public void SetLicense(
string licenseName
);

Remarks

Tries to find the license in the following locations:

1. Explicit path.

2. The folder that contains the Aspose component assembly.

3. The folder that contains the client's calling assembly.

4. The folder that contains the entry (startup) assembly.

5. An embedded resource in the client's calling assembly.

Note:On the .NET Compact Framework, tries to find the license only in these locations:

1. Explicit path.

2. An embedded resource in the client's calling assembly.

2. The folder that contains the Aspose component JAR file.

3. The folder that contains the client's calling JAR file.

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As License = New License
license.SetLicense("MyLicense.lic")
the component jar file:
Can be a full or short file name or name of an embedded resource. Use an empty string to switch to evaluation mode.
See Also
License Class | Aspose.Imaging Namespace | License.SetLicense Overload List


LineCap Enumeration

Specifies the available cap styles with which a Pen object can end a line.

public enum LineCap

Members

Member Name | Description | Value
Flat | Specifies a flat line cap. | 0
Square | Specifies a square line cap. | 1
Round | Specifies a round line cap. | 2
Triangle | Specifies a triangular line cap. | 3
NoAnchor | Specifies no anchor. | 16
SquareAnchor | Specifies a square anchor line cap. | 17
RoundAnchor | Specifies a round anchor cap. | 18
DiamondAnchor | Specifies a diamond anchor cap. | 19
ArrowAnchor | Specifies an arrow-shaped anchor cap. | 20
AnchorMask | Specifies a custom line cap. | 240
Custom | Specifies a mask used to check whether a line cap is an anchor cap. | 255

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


LineJoin Enumeration

Specifies how to join consecutive line or curve segments in a figure (subpath) contained in a GraphicsPath object.

public enum LineJoin

Members

Member Name | Description | Value
Miter | Specifies a mitered join. This produces a sharp corner or a clipped corner, depending on whether the length of the miter exceeds the miter limit. | 0
Bevel | Specifies a beveled join. This produces a diagonal corner. | 1
Round | Specifies a circular join. This produces a smooth, circular arc between the lines. | 2
MiterClipped | Specifies a mitered join. This produces a sharp corner or a beveled corner, depending on whether the length of the miter exceeds the miter limit. | 3

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


LoadOptions Class

Represents the loading options.

For a list of all members of this type, see LoadOptions Members.

System.Object
Aspose.Imaging.LoadOptions
Aspose.Imaging.ImageLoadOptions.JpegLoadOptions

public class LoadOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

LoadOptions Members | Aspose.Imaging Namespace


LoadOptions Members

LoadOptions overview

Public Instance Constructors

LoadOptions Constructor Initializes a new instance of the LoadOptions class.

Public Instance Properties

DataBackgroundColor | Gets or sets the Image background Color.
DataRecoveryMode | Gets or sets the data recovery mode.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LoadOptions Class | Aspose.Imaging Namespace


LoadOptions Constructor

Initializes a new instance of the LoadOptions class.

public LoadOptions();

See Also

LoadOptions Class | Aspose.Imaging Namespace


LoadOptions Properties

The properties of the LoadOptions class are listed below. For a complete list of LoadOptions class members, see the LoadOptions Members topic.

Public Instance Properties

DataBackgroundColor | Gets or sets the Image background Color.
DataRecoveryMode | Gets or sets the data recovery mode.

See Also

LoadOptions Class | Aspose.Imaging Namespace


DataBackgroundColor Property

Aspose.Imaging Documentation

LoadOptions.DataBackgroundColor Property

Gets or sets the Image background Color.

public Color DataBackgroundColor {get; set;}

Property Value

The background color.

Remarks

Typically the background color is set whenever pixel value cannot be recovered due to data corruption.

See Also

LoadOptions Class | Aspose.Imaging Namespace


DataRecoveryMode Property

Aspose.Imaging Documentation

LoadOptions.DataRecoveryMode Property

Gets or sets the data recovery mode.

public DataRecoveryMode DataRecoveryMode {get; set;}

Property Value

The data recovery mode.

See Also

LoadOptions Class | Aspose.Imaging Namespace


Matrix Class

Replaces the GDI+ Matrix.

For a list of all members of this type, see Matrix Members.

System.Object
Aspose.Imaging.Matrix

public class Matrix

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Most algorithms taken from Sun's AffineTransform.java. Java's names for matrix elements used internally. Map of java names to .net ones to description: m00 M11 Scale X m10 M12 Shear Y m01 M21 Shear X m11 M22 Scale Y m02 M31 Translate X m12 M32 Translate Y

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Matrix Members | Aspose.Imaging Namespace


Matrix Members

Matrix overview

Public Static Fields

TypeFlip | This flag bit indicates that the transform defined by this object performs a mirror image flip about some axis which changes the normally right handed coordinate system into a left handed system in addition to the conversions indicated by other flag bits. A right handed coordinate system is one where the positive X axis rotates counterclockwise to overlay the positive Y axis similar to the direction that the fingers on your right hand curl when you stare end on at your thumb. A left handed coordinate system is one where the positive X axis rotates clockwise to overlay the positive Y axis similar to the direction that the fingers on your left hand curl. There is no mathematical way to determine the angle of the original flipping or mirroring transformation since all angles of flip are identical given an appropriate adjusting rotation. NOTE: TypeFlip was added after GENERAL_TRANSFORM was in public circulation and the flag bits could no longer be conveniently renumbered without introducing binary incompatibility in outside code.
TypeGeneralRotation | This flag bit indicates that the transform defined by this object performs a rotation by an arbitrary angle in addition to the conversions indicated by other flag bits. A rotation changes the angles of vectors by the same amount regardless of the original direction of the vector and without changing the length of the vector. This flag bit is mutually exclusive with the
TypeGeneralScale | A general scale multiplies the length of vectors by different amounts in the x and y directions without changing the angle between perpendicular vectors. This flag bit is mutually exclusive with the TypeUniformScale flag.
TypeGeneralTransform | This constant indicates that the transform defined by this object performs an arbitrary conversion of the input coordinates. If this transform can be classified by any of the above constants, the type will either be the constant TypeIdentity or a combination of the appropriate flag bits for the various coordinate conversions that this transform performs.
TypeIdentity | An identity transform is one in which the output coordinates are always the same as the input coordinates. If this transform is anything other than the identity transform, the type will either be the constant GENERAL_TRANSFORM or a combination of the appropriate flag bits for the various coordinate conversions that this transform performs.
TypeMaskRotation | This constant is a bit mask for any of the rotation flag bits.
TypeMaskScale | This constant is a bit mask for any of the scale flag bits.
TypeQuadrantRotation | This flag bit indicates that the transform defined by this object performs a quadrant rotation by some multiple of 90 degrees in addition to the conversions indicated by other flag bits. A rotation changes the angles of vectors by the same amount regardless of the original direction of the vector and without changing the length of the vector. This flag bit is mutually exclusive with the TypeGeneralRotation flag.
TypeTranslation | A translation moves the coordinates by a constant amount in x and y without changing the length or angle of vectors.
TypeUniformScale | A uniform scale multiplies the length of vectors by the same amount in both the x and y directions without changing the angle between vectors. This flag bit is mutually exclusive with the TypeGeneralScale flag.

Public Static Methods

Equals Overloaded. Determines whether two matrixes are equal.

Public Static Operators

Equality Operator | Implements the operator ==.
Inequality Operator | Implements the operator !=.

Public Instance Constructors

Matrix Overloaded. Initializes a new instance of the Matrix class.

Public Instance Properties

Elements | Gets an array of floating-point values that represents the elements of this Matrix.
M11 | Gets the matrix element at first row first column. Represents scale along X axis.
M12 | Gets the matrix element at first row second column. Represents shear along Y axis.
M21 | Gets the matrix element at second row first column. Represents shear along X axis.
M22 | Gets the matrix element at second row second column. Represents scale along Y axis.
M31 | Gets the matrix element at third row first column. Represents translation along X axis.
M32 | Gets the matrix element at third row first column. Represents translation along Y axis.

Public Instance Methods

Equals | Overloaded. Determines whether the specified Object is equal to this instance.
GetElements | Gets the copy of matrix elements.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Multiply | Overloaded. Multiplies this Matrix by the matrix specified in the matrix parameter, and in the order specified in the order parameter.
Reset | Resets this Matrix to have the elements of the identity matrix.
Rotate | Overloaded. Applies a clockwise rotation of an amount specified in the angle parameter, around the origin (zero x and y coordinates) for this Matrix in the specified order.
RotateAt | Overloaded. Applies a clockwise rotation about the specified point to this Matrix in the specified order.
Scale | Overloaded. Applies the specified scale vector (scaleX and scaleY) to this Matrix using the specified order.
ToString | Returns a String that represents this instance.
TransformPoints | Applies the geometric transform represented by this Matrix to a specified array of points.
Translate | Overloaded. Applies the specified translation vector to this Matrix in the specified order.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix Constructor

Initializes a new instance of the Matrix class as the identity matrix.

Overload List

Initializes a new instance of the Matrix class as the identity matrix.

public Matrix();

Initializes a new instance of the Matrix class to the geometric transform defined by the specified rectangle and array of points.

public Matrix(Rectangle,Point[]);

Initializes a new instance of the Matrix class to the geometric transform defined by the specified rectangle and array of points.

public Matrix(RectangleF,PointF[]);

Initializes a new instance of the Matrix class.

public Matrix(float,float,float,float,float,float);

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix Constructor ()

Initializes a new instance of the Matrix class as the identity matrix.

public Matrix();

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix Constructor Overload List


Matrix Constructor (Single, Single, Single, Single, Single, Single)

Initializes a new instance of the Matrix class.

public Matrix(
float m11,
float m12,
float m21,
float m22,
float m31,
float m32
);

Parameters

m11
m00 M11 Scale X
m12
m10 M12 Shear Y
m21
m01 M21 Shear X
m22
m11 M22 Scale Y
m31
m02 M31 Translate X
m32
m12 M32 Translate Y

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix Constructor Overload List


Matrix Constructor (RectangleF, PointF[])

Initializes a new instance of the Matrix class to the geometric transform defined by the specified rectangle and array of points.

public Matrix(
RectangleF rect,
PointF[] plgpts
);

Parameters

rect
A RectangleF structure that represents the rectangle to be transformed.
plgpts
An array of three PointF structures that represents the points of a parallelogram to which the upper-left, upper-right, and lower-left corners of the rectangle is to be transformed. The lower-right corner of the parallelogram is implied by the first three corners.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix Constructor Overload List


Matrix Constructor (Rectangle, Point[])

Initializes a new instance of the Matrix class to the geometric transform defined by the specified rectangle and array of points.

public Matrix(
Rectangle rect,
Point[] plgpts
);

Parameters

rect
A Rectangle structure that represents the rectangle to be transformed.
plgpts
An array of three Point structures that represents the points of a parallelogram to which the upper-left, upper-right, and lower-left corners of the rectangle is to be transformed. The lower-right corner of the parallelogram is implied by the first three corners.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix Constructor Overload List


Matrix Fields

The fields of the Matrix class are listed below. For a complete list of Matrix class members, see the Matrix Members topic.

Public Static Fields

TypeFlip | This flag bit indicates that the transform defined by this object performs a mirror image flip about some axis which changes the normally right handed coordinate system into a left handed system in addition to the conversions indicated by other flag bits. A right handed coordinate system is one where the positive X axis rotates counterclockwise to overlay the positive Y axis similar to the direction that the fingers on your right hand curl when you stare end on at your thumb. A left handed coordinate system is one where the positive X axis rotates clockwise to overlay the positive Y axis similar to the direction that the fingers on your left hand curl. There is no mathematical way to determine the angle of the original flipping or mirroring transformation since all angles of flip are identical given an appropriate adjusting rotation. NOTE: TypeFlip was added after GENERAL_TRANSFORM was in public circulation and the flag bits could no longer be conveniently renumbered without introducing binary incompatibility in outside code.
TypeGeneralRotation | This flag bit indicates that the transform defined by this object performs a rotation by an arbitrary angle in addition to the conversions indicated by other flag bits. A rotation changes the angles of vectors by the same amount regardless of the original direction of the vector and without changing the length of the vector. This flag bit is mutually exclusive with the
TypeGeneralScale | A general scale multiplies the length of vectors by different amounts in the x and y directions without changing the angle between perpendicular vectors. This flag bit is mutually exclusive with the TypeUniformScale flag.
TypeGeneralTransform | This constant indicates that the transform defined by this object performs an arbitrary conversion of the input coordinates. If this transform can be classified by any of the above constants, the type will either be the constant TypeIdentity or a combination of the appropriate flag bits for the various coordinate conversions that this transform performs.
TypeIdentity | An identity transform is one in which the output coordinates are always the same as the input coordinates. If this transform is anything other than the identity transform, the type will either be the constant GENERAL_TRANSFORM or a combination of the appropriate flag bits for the various coordinate conversions that this transform performs.
TypeMaskRotation | This constant is a bit mask for any of the rotation flag bits.
TypeMaskScale | This constant is a bit mask for any of the scale flag bits.
TypeQuadrantRotation | This flag bit indicates that the transform defined by this object performs a quadrant rotation by some multiple of 90 degrees in addition to the conversions indicated by other flag bits. A rotation changes the angles of vectors by the same amount regardless of the original direction of the vector and without changing the length of the vector. This flag bit is mutually exclusive with the TypeGeneralRotation flag.
TypeTranslation | A translation moves the coordinates by a constant amount in x and y without changing the length or angle of vectors.
TypeUniformScale | A uniform scale multiplies the length of vectors by the same amount in both the x and y directions without changing the angle between vectors. This flag bit is mutually exclusive with the TypeGeneralScale flag.

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.TypeFlip Field

This flag bit indicates that the transform defined by this object performs a mirror image flip about some axis which changes the normally right handed coordinate system into a left handed system in addition to the conversions indicated by other flag bits. A right handed coordinate system is one where the positive X axis rotates counterclockwise to overlay the positive Y axis similar to the direction that the fingers on your right hand curl when you stare end on at your thumb. A left handed coordinate system is one where the positive X axis rotates clockwise to overlay the positive Y axis similar to the direction that the fingers on your left hand curl. There is no mathematical way to determine the angle of the original flipping or mirroring transformation since all angles of flip are identical given an appropriate adjusting rotation. NOTE: TypeFlip was added after GENERAL_TRANSFORM was in public circulation and the flag bits could no longer be conveniently renumbered without introducing binary incompatibility in outside code.

public const int TypeFlip = 64;

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.TypeGeneralRotation Field

This flag bit indicates that the transform defined by this object performs a rotation by an arbitrary angle in addition to the conversions indicated by other flag bits. A rotation changes the angles of vectors by the same amount regardless of the original direction of the vector and without changing the length of the vector. This flag bit is mutually exclusive with the

public const int TypeGeneralRotation = 16;

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.TypeGeneralScale Field

A general scale multiplies the length of vectors by different amounts in the x and y directions without changing the angle between perpendicular vectors. This flag bit is mutually exclusive with the TypeUniformScale flag.

public const int TypeGeneralScale = 4;

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.TypeGeneralTransform Field

This constant indicates that the transform defined by this object performs an arbitrary conversion of the input coordinates. If this transform can be classified by any of the above constants, the type will either be the constant TypeIdentity or a combination of the appropriate flag bits for the various coordinate conversions that this transform performs.

public const int TypeGeneralTransform = 32;

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.TypeIdentity Field

An identity transform is one in which the output coordinates are always the same as the input coordinates. If this transform is anything other than the identity transform, the type will either be the constant GENERAL_TRANSFORM or a combination of the appropriate flag bits for the various coordinate conversions that this transform performs.

public const int TypeIdentity = 0;

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.TypeMaskRotation Field

This constant is a bit mask for any of the rotation flag bits.

public const int TypeMaskRotation = 24;

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.TypeMaskScale Field

This constant is a bit mask for any of the scale flag bits.

public const int TypeMaskScale = 6;

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.TypeQuadrantRotation Field

This flag bit indicates that the transform defined by this object performs a quadrant rotation by some multiple of 90 degrees in addition to the conversions indicated by other flag bits. A rotation changes the angles of vectors by the same amount regardless of the original direction of the vector and without changing the length of the vector. This flag bit is mutually exclusive with the TypeGeneralRotation flag.

public const int TypeQuadrantRotation = 8;

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.TypeTranslation Field

A translation moves the coordinates by a constant amount in x and y without changing the length or angle of vectors.

public const int TypeTranslation = 1;

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.TypeUniformScale Field

A uniform scale multiplies the length of vectors by the same amount in both the x and y directions without changing the angle between vectors. This flag bit is mutually exclusive with the TypeGeneralScale flag.

public const int TypeUniformScale = 2;

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix Properties

The properties of the Matrix class are listed below. For a complete list of Matrix class members, see the Matrix Members topic.

Public Instance Properties

Elements | Gets an array of floating-point values that represents the elements of this Matrix.
M11 | Gets the matrix element at first row first column. Represents scale along X axis.
M12 | Gets the matrix element at first row second column. Represents shear along Y axis.
M21 | Gets the matrix element at second row first column. Represents shear along X axis.
M22 | Gets the matrix element at second row second column. Represents scale along Y axis.
M31 | Gets the matrix element at third row first column. Represents translation along X axis.
M32 | Gets the matrix element at third row first column. Represents translation along Y axis.

See Also

Matrix Class | Aspose.Imaging Namespace


Elements Property

Aspose.Imaging Documentation

Matrix.Elements Property

Gets an array of floating-point values that represents the elements of this Matrix.

public float[] Elements {get;}

Property Value

An array of floating-point values that represents the elements of this Matrix.

See Also

Matrix Class | Aspose.Imaging Namespace


M11 Property

Aspose.Imaging Documentation

Matrix.M11 Property

Gets the matrix element at first row first column. Represents scale along X axis.

public float M11 {get;}

See Also

Matrix Class | Aspose.Imaging Namespace


M12 Property

Aspose.Imaging Documentation

Matrix.M12 Property

Gets the matrix element at first row second column. Represents shear along Y axis.

public float M12 {get;}

See Also

Matrix Class | Aspose.Imaging Namespace


M21 Property

Aspose.Imaging Documentation

Matrix.M21 Property

Gets the matrix element at second row first column. Represents shear along X axis.

public float M21 {get;}

See Also

Matrix Class | Aspose.Imaging Namespace


M22 Property

Aspose.Imaging Documentation

Matrix.M22 Property

Gets the matrix element at second row second column. Represents scale along Y axis.

public float M22 {get;}

See Also

Matrix Class | Aspose.Imaging Namespace


M31 Property

Aspose.Imaging Documentation

Matrix.M31 Property

Gets the matrix element at third row first column. Represents translation along X axis.

public float M31 {get;}

See Also

Matrix Class | Aspose.Imaging Namespace


M32 Property

Aspose.Imaging Documentation

Matrix.M32 Property

Gets the matrix element at third row first column. Represents translation along Y axis.

public float M32 {get;}

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix Methods

The methods of the Matrix class are listed below. For a complete list of Matrix class members, see the Matrix Members topic.

Public Static Methods

Equals Overloaded. Determines whether two matrixes are equal.

Public Instance Methods

Equals | Overloaded. Determines whether the specified Object is equal to this instance.
GetElements | Gets the copy of matrix elements.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Multiply | Overloaded. Multiplies this Matrix by the matrix specified in the matrix parameter, and in the order specified in the order parameter.
Reset | Resets this Matrix to have the elements of the identity matrix.
Rotate | Overloaded. Applies a clockwise rotation of an amount specified in the angle parameter, around the origin (zero x and y coordinates) for this Matrix in the specified order.
RotateAt | Overloaded. Applies a clockwise rotation about the specified point to this Matrix in the specified order.
Scale | Overloaded. Applies the specified scale vector (scaleX and scaleY) to this Matrix using the specified order.
ToString | Returns a String that represents this instance.
TransformPoints | Applies the geometric transform represented by this Matrix to a specified array of points.
Translate | Overloaded. Applies the specified translation vector to this Matrix in the specified order.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Matrix Class | Aspose.Imaging Namespace


Equals Method

Aspose.Imaging Documentation

Matrix.Equals Method

Determines whether two matrixes are equal.

Overload List

Determines whether two matrixes are equal.

public static bool Equals(Matrix,Matrix);

Determines whether the specified Object is equal to this instance.

public override bool Equals(object);

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.Equals Method (Matrix, Matrix)

Determines whether two matrixes are equal.

public static bool Equals(
Matrix a,
Matrix b
);

Parameters

a
The first matrix to compare.
b
The second matrix to compare.

Return Value

True if matrixes are equal.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix.Equals Overload List


Matrix.Equals Method (Object)

Determines whether the specified Object is equal to this instance.

public override bool Equals(
object obj
);

Parameters

obj
The Object to compare with this instance.

Return Value

true if the specified Object is equal to this instance; otherwise, false.

Exceptions

Exception Type | Condition
NullReferenceException | The obj parameter is null.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix.Equals Overload List


Matrix.GetElements Method

Gets the copy of matrix elements.

public float[] GetElements();

Return Value

A matrix elements copy.

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.GetHashCode Method

Returns a hash code for this instance.

public override int GetHashCode();

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

Matrix Class | Aspose.Imaging Namespace


Multiply Method

Aspose.Imaging Documentation

Matrix.Multiply Method

Multiplies this Matrix by the matrix specified in the matrix parameter using (default) Prepend order.

Overload List

Multiplies this Matrix by the matrix specified in the matrix parameter using (default) Prepend order.

public void Multiply(Matrix);

Multiplies this Matrix by the matrix specified in the matrix parameter, and in the order specified in the order parameter.

public void Multiply(Matrix,MatrixOrder);

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.Multiply Method (Matrix)

Multiplies this Matrix by the matrix specified in the matrix parameter using (default) Prepend order.

public void Multiply(
Matrix Tx
);

Parameters

Tx
The matrix to multiply with.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix.Multiply Overload List


Matrix.Multiply Method (Matrix, MatrixOrder)

Multiplies this Matrix by the matrix specified in the matrix parameter, and in the order specified in the order parameter.

public void Multiply(
Matrix Tx,
MatrixOrder order
);

Parameters

Tx
The tx. The tx. The tx.
order
The order. The order. The order.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix.Multiply Overload List


Matrix.Reset Method

Resets this Matrix to have the elements of the identity matrix.

public void Reset();

See Also

Matrix Class | Aspose.Imaging Namespace


Rotate Method

Aspose.Imaging Documentation

Matrix.Rotate Method

Applies a clockwise rotation of an amount specified in the angle parameter, around the origin (zero x and y coordinates) for this Matrix in the default (Prepend) order.

Overload List

Applies a clockwise rotation of an amount specified in the angle parameter, around the origin (zero x and y coordinates) for this Matrix in the default (Prepend) order.

public void Rotate(float);

Applies a clockwise rotation of an amount specified in the angle parameter, around the origin (zero x and y coordinates) for this Matrix in the specified order.

public void Rotate(float,MatrixOrder);

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.Rotate Method (Single)

Applies a clockwise rotation of an amount specified in the angle parameter, around the origin (zero x and y coordinates) for this Matrix in the default (Prepend) order.

public void Rotate(
float angle
);

Parameters

angle
The rotate angle.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix.Rotate Overload List


Matrix.Rotate Method (Single, MatrixOrder)

Applies a clockwise rotation of an amount specified in the angle parameter, around the origin (zero x and y coordinates) for this Matrix in the specified order.

public void Rotate(
float angle,
MatrixOrder order
);

Parameters

angle
The rotate angle.
order
The matrix order.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix.Rotate Overload List


RotateAt Method

Aspose.Imaging Documentation

Matrix.RotateAt Method

Applies a clockwise rotation about the specified point to this Matrix in the default (Prepend) order.

Overload List

Applies a clockwise rotation about the specified point to this Matrix in the default (Prepend) order.

public void RotateAt(float,PointF);

Applies a clockwise rotation about the specified point to this Matrix in the specified order.

public void RotateAt(float,PointF,MatrixOrder);

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.RotateAt Method (Single, PointF)

Applies a clockwise rotation about the specified point to this Matrix in the default (Prepend) order.

public void RotateAt(
float angle,
PointF point
);

Parameters

angle
The angle.
point
The point.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix.RotateAt Overload List


Matrix.RotateAt Method (Single, PointF, MatrixOrder)

Applies a clockwise rotation about the specified point to this Matrix in the specified order.

public void RotateAt(
float angle,
PointF point,
MatrixOrder order
);

Parameters

angle
The angle.
point
The point.
order
The order.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix.RotateAt Overload List


Scale Method

Aspose.Imaging Documentation

Matrix.Scale Method

Applies the specified scale vector (scaleX and scaleY) to this Matrix using (default) Prepend order.

Overload List

Applies the specified scale vector (scaleX and scaleY) to this Matrix using (default) Prepend order.

public void Scale(float,float);

Applies the specified scale vector (scaleX and scaleY) to this Matrix using the specified order.

public void Scale(float,float,MatrixOrder);

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.Scale Method (Single, Single)

Applies the specified scale vector (scaleX and scaleY) to this Matrix using (default) Prepend order.

public void Scale(
float sx,
float sy
);

Parameters

sx
The sx. The sx. The sx.
sy
The sy. The sy. The sy.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix.Scale Overload List


Matrix.Scale Method (Single, Single, MatrixOrder)

Applies the specified scale vector (scaleX and scaleY) to this Matrix using the specified order.

public void Scale(
float scaleX,
float scaleY,
MatrixOrder order
);

Parameters

scaleX
The scale X.
scaleY
The scale Y.
order
The order.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix.Scale Overload List


Matrix.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.TransformPoints Method

Applies the geometric transform represented by this Matrix to a specified array of points.

public void TransformPoints(
PointF[] points
);

Parameters

points
The points.

See Also

Matrix Class | Aspose.Imaging Namespace


Translate Method

Aspose.Imaging Documentation

Matrix.Translate Method

Applies the specified translation vector to this Matrix using (default) Prepend order.

Overload List

Applies the specified translation vector to this Matrix using (default) Prepend order.

public void Translate(float,float);

Applies the specified translation vector to this Matrix in the specified order.

public void Translate(float,float,MatrixOrder);

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix.Translate Method (Single, Single)

Applies the specified translation vector to this Matrix using (default) Prepend order.

public void Translate(
float tx,
float ty
);

Parameters

tx
The tx. The tx. The tx.
ty
The ty. The ty. The ty.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix.Translate Overload List


Matrix.Translate Method (Single, Single, MatrixOrder)

Applies the specified translation vector to this Matrix in the specified order.

public void Translate(
float offsetX,
float offsetY,
MatrixOrder order
);

Parameters

offsetX
The offset X.
offsetY
The offset Y.
order
The order.

See Also

Matrix Class | Aspose.Imaging Namespace | Matrix.Translate Overload List


Matrix Operators

The operators of the Matrix class are listed below. For a complete list of Matrix class members, see the Matrix Members topic.

Public Static Operators

Equality Operator | Implements the operator ==.
Inequality Operator | Implements the operator !=.

See Also

Matrix Class | Matrix Members | Aspose.Imaging Namespace


Matrix Equality Operator

Implements the operator ==.

public static bool operator ==(
Matrix matrix1,
Matrix matrix2
);

Parameters

matrix1
The first matrix to compare.
matrix2
The second matrix to compare.

Return Value

The result of the operator.

See Also

Matrix Class | Aspose.Imaging Namespace


Matrix Inequality Operator

Implements the operator !=.

public static bool operator !=(
Matrix matrix1,
Matrix matrix2
);

Parameters

matrix1
The first matrix to compare.
matrix2
The second matrix to compare.

Return Value

The result of the operator.

See Also

Matrix Class | Aspose.Imaging Namespace


MatrixOrder Enumeration

Specifies the order for matrix transform operations.

public enum MatrixOrder

Members

Member Name | Description | Value
Prepend | The new operation is applied before the old operation. | 0
Append | The new operation is applied after the old operation. | 1

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


ObjectWithBounds Class

The object having bounds.

For a list of all members of this type, see ObjectWithBounds Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Figure
Aspose.Imaging.GraphicsPath
Aspose.Imaging.Shape

public abstract class ObjectWithBounds

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ObjectWithBounds Members | Aspose.Imaging Namespace


ObjectWithBounds Members

ObjectWithBounds overview

Public Instance Properties

Bounds Gets the object's bounds.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Applies the specified transformation to the shape.

Protected Instance Constructors

ObjectWithBounds Constructor Initializes a new instance of the ObjectWithBounds class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectWithBounds Class | Aspose.Imaging Namespace


ObjectWithBounds Constructor

Initializes a new instance of the ObjectWithBounds class.

protected ObjectWithBounds();

See Also

ObjectWithBounds Class | Aspose.Imaging Namespace


ObjectWithBounds Properties

The properties of the ObjectWithBounds class are listed below. For a complete list of ObjectWithBounds class members, see the ObjectWithBounds Members topic.

Public Instance Properties

Bounds Gets the object's bounds.

See Also

ObjectWithBounds Class | Aspose.Imaging Namespace


Bounds Property

Aspose.Imaging Documentation

ObjectWithBounds.Bounds Property

Gets the object's bounds.

public abstract RectangleF Bounds {get;}

Property Value

The object's bounds.

See Also

ObjectWithBounds Class | Aspose.Imaging Namespace


ObjectWithBounds Methods

The methods of the ObjectWithBounds class are listed below. For a complete list of ObjectWithBounds class members, see the ObjectWithBounds Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Applies the specified transformation to the shape.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectWithBounds Class | Aspose.Imaging Namespace


GetBounds Method

Aspose.Imaging Documentation

ObjectWithBounds.GetBounds Method

Gets the object's bounds.

Overload List

Gets the object's bounds.

public abstract RectangleF GetBounds(Matrix);

Gets the object's bounds.

public abstract RectangleF GetBounds(Matrix,Pen);

See Also

ObjectWithBounds Class | Aspose.Imaging Namespace


ObjectWithBounds.GetBounds Method (Matrix)

Gets the object's bounds.

public abstract RectangleF GetBounds(
Matrix matrix
);

Parameters

matrix
The matrix to apply before bounds will be calculated.

Return Value

The estimated object's bounds.

See Also

ObjectWithBounds Class | Aspose.Imaging Namespace | ObjectWithBounds.GetBounds Overload List


ObjectWithBounds.GetBounds Method (Matrix, Pen)

Gets the object's bounds.

public abstract RectangleF GetBounds(
Matrix matrix,
Pen pen
);

Parameters

matrix
The matrix to apply before bounds will be calculated.
pen
The pen to use for object. This can influence the object's bounds size.

Return Value

The estimated object's bounds.

See Also

ObjectWithBounds Class | Aspose.Imaging Namespace | ObjectWithBounds.GetBounds Overload List


ObjectWithBounds.Transform Method

Applies the specified transformation to the shape.

public abstract void Transform(
Matrix transform
);

Parameters

transform
The transformation to apply.

See Also

ObjectWithBounds Class | Aspose.Imaging Namespace


Pen Class

Defines an object used to draw lines, curves and figures.

For a list of all members of this type, see Pen Members.

System.Object
Aspose.Imaging.TransparencySupporter
Aspose.Imaging.Pen

public class Pen : TransparencySupporter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows the creation and usage Pen objects. The example creates a new Image and draw Rectangles on Image surface.

[C#]

//Create an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"C:\temp\sample.bmp", false);

//Create an instance of Image at specified Path
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Create an instance of Graphics and initialize it with Image object
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clear the Graphics sutface with White Color
    graphics.Clear(Aspose.Imaging.Color.White);

    //Create an instance of Pen with color Red and width 5
    Aspose.Imaging.Pen pen = new Pen(Aspose.Imaging.Color.Red, 5);

    //Create an instance of HatchBrush and set its properties
    Aspose.Imaging.Brushes.HatchBrush brush = new HatchBrush();
    brush.BackgroundColor = Color.Wheat;
    brush.ForegroundColor = Color.Red;

    //Create an instance of Pen
    //initialize it with HatchBrush object and width
    Aspose.Imaging.Pen brusedpen = new Pen(brush, 5);

    //Draw Rectangles by specifying Pen object
    graphics.DrawRectangles(pen, new[] { new Rectangle(new Point(210, 210), new Size(100, 100)), new Rectangle(new Point(110, 110), new Size(100, 100)), new Rectangle(new Point(310, 310), new Size(100, 100)) });

    //Draw Rectangles by specifying Pen object
    graphics.DrawRectangles(brusedpen, new[] { new Rectangle(new Point(310, 110), new Size(100, 100)), new Rectangle(new Point(110, 310), new Size(100, 100)) });

    // save all changes.
    image.Save();
}
[Visual Basic]

'Create an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("C:\temp\sample.bmp", False)

'Create an instance of Image at specified Path
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Create an instance of Graphics and initialize it with Image object
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear the Graphics sutface with White Color
    graphics.Clear(Aspose.Imaging.Color.White)

'Create an instance of Pen with color Red and width 5
Dim pen As Aspose.Imaging.Pen = New Pen(Aspose.Imaging.Color.Red, 5)

'Create an instance of HatchBrush and set its properties
Dim brush As Aspose.Imaging.Brushes.HatchBrush = New HatchBrush()
    brush.BackgroundColor = Color.Wheat
    brush.ForegroundColor = Color.Red

'Create an instance of Pen
'initialize it with HatchBrush object and width
Dim brusedpen As Aspose.Imaging.Pen = New Pen(brush, 5)

'Draw Rectangles by specifying Pen object
    graphics.DrawRectangles(pen, New() { New Rectangle(New Point(210, 210), New Size(100, 100)), New Rectangle(New Point(110, 110), New Size(100, 100)), New Rectangle(New Point(310, 310), New Size(100, 100)) })

'Draw Rectangles by specifying Pen object
    graphics.DrawRectangles(brusedpen, New() { New Rectangle(New Point(310, 110), New Size(100, 100)), New Rectangle(New Point(110, 310), New Size(100, 100)) })

' save all changes.
    image.Save()
End Using

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Pen Members | Aspose.Imaging Namespace


Pen Members

Pen overview

Public Instance Constructors

Pen Overloaded. Initializes a new instance of the Pen class.

Public Instance Properties

Alignment | Gets or sets the alignment for this Pen.
Brush | Gets or sets the Brush that determines attributes of this Pen.
Color | Gets or sets the color of this Pen.
CompoundArray | Gets or sets an array of values that specifies a compound pen. A compound pen draws a compound line made up of parallel lines and spaces.
CustomEndCap | Gets or sets a custom cap to use at the end of lines drawn with this Pen.
CustomStartCap | Gets or sets a custom cap to use at the beginning of lines drawn with this Pen.
DashCap | Gets or sets the cap style used at the end of the dashes that make up dashed lines drawn with this Pen.
DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
DashPattern | Gets or sets an array of custom dashes and spaces.
DashStyle | Gets or sets the style used for dashed lines drawn with this Pen.
EndCap | Gets or sets the cap style used at the end of lines drawn with this Pen.
LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen.
MiterLimit | Gets or sets the limit of the thickness of the join on a mitered corner.
Opacity (inherited from TransparencySupporter) | Gets or sets the object's opacity. The value should be between 0 and 1. Value of 0 means that object is fully visible, value of 1 means the object is fully opaque.
PenType | Gets the style of lines drawn with this Pen.
StartCap | Gets or sets the cap style used at the beginning of lines drawn with this Pen.
Transform | Gets or sets a copy of the geometric transformation for this Pen.
Width | Gets or sets the width of this Pen, in units of the Graphics object used for drawing.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform | Overloaded. Multiplies the transformation matrix for this Pen by the specified Matrix.
ResetTransform | Resets the geometric transformation matrix for this Pen to identity.
RotateTransform | Overloaded. Rotates the local geometric transformation by the specified angle. This method prepends the rotation to the transformation.
ScaleTransform | Overloaded. Scales the local geometric transformation by the specified factors. This method prepends the scaling matrix to the transformation.
SetLineCap | Sets the values that determine the style of cap used to end lines drawn by this Pen.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. Translates the local geometric transformation by the specified dimensions. This method prepends the translation to the transformation.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pen Class | Aspose.Imaging Namespace


Pen Constructor

Initializes a new instance of the Pen class with the specified color.

Overload List

Initializes a new instance of the Pen class with the specified Brush.

public Pen(Brush);

Initializes a new instance of the Pen class with the specified Brush and Width.

public Pen(Brush,float);

Initializes a new instance of the Pen class with the specified color.

public Pen(Color);

Initializes a new instance of the Pen class with the specified Color and Width properties.

public Pen(Color,float);

See Also

Pen Class | Aspose.Imaging Namespace


Pen Constructor (Color)

Initializes a new instance of the Pen class with the specified color.

public Pen(
Color color
);

Parameters

color
A Color structure that indicates the color of this Pen.

See Also

Pen Class | Aspose.Imaging Namespace | Pen Constructor Overload List


Pen Constructor (Color, Single)

Initializes a new instance of the Pen class with the specified Color and Width properties.

public Pen(
Color color,
float width
);

Parameters

color
A Color structure that indicates the color of this Pen.
width
A value indicating the width of this Pen.

See Also

Pen Class | Aspose.Imaging Namespace | Pen Constructor Overload List


Pen Constructor (Brush)

Initializes a new instance of the Pen class with the specified Brush.

public Pen(
Brush brush
);

Parameters

brush
A Brush that determines the fill properties of this Pen.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Pen Class | Aspose.Imaging Namespace | Pen Constructor Overload List


Pen Constructor (Brush, Single)

Initializes a new instance of the Pen class with the specified Brush and Width.

public Pen(
Brush brush,
float width
);

Parameters

brush
A Brush that determines the characteristics of this Pen.
width
The width of the new Pen.

Exceptions

Exception Type | Condition
ArgumentNullException | brush is null.

See Also

Pen Class | Aspose.Imaging Namespace | Pen Constructor Overload List


Pen Properties

The properties of the Pen class are listed below. For a complete list of Pen class members, see the Pen Members topic.

Public Instance Properties

Alignment | Gets or sets the alignment for this Pen.
Brush | Gets or sets the Brush that determines attributes of this Pen.
Color | Gets or sets the color of this Pen.
CompoundArray | Gets or sets an array of values that specifies a compound pen. A compound pen draws a compound line made up of parallel lines and spaces.
CustomEndCap | Gets or sets a custom cap to use at the end of lines drawn with this Pen.
CustomStartCap | Gets or sets a custom cap to use at the beginning of lines drawn with this Pen.
DashCap | Gets or sets the cap style used at the end of the dashes that make up dashed lines drawn with this Pen.
DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
DashPattern | Gets or sets an array of custom dashes and spaces.
DashStyle | Gets or sets the style used for dashed lines drawn with this Pen.
EndCap | Gets or sets the cap style used at the end of lines drawn with this Pen.
LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen.
MiterLimit | Gets or sets the limit of the thickness of the join on a mitered corner.
Opacity (inherited from TransparencySupporter) | Gets or sets the object's opacity. The value should be between 0 and 1. Value of 0 means that object is fully visible, value of 1 means the object is fully opaque.
PenType | Gets the style of lines drawn with this Pen.
StartCap | Gets or sets the cap style used at the beginning of lines drawn with this Pen.
Transform | Gets or sets a copy of the geometric transformation for this Pen.
Width | Gets or sets the width of this Pen, in units of the Graphics object used for drawing.

See Also

Pen Class | Aspose.Imaging Namespace


Alignment Property

Aspose.Imaging Documentation

Pen.Alignment Property

Gets or sets the alignment for this Pen.

public PenAlignment Alignment {get; set;}

Property Value

A PenAlignment that represents the alignment for this Pen.

Exceptions

Exception Type | Condition
ArgumentException | The Alignment property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


Brush Property

Aspose.Imaging Documentation

Pen.Brush Property

Gets or sets the Brush that determines attributes of this Pen.

public Brush Brush {get; set;}

Property Value

A Brush that determines attributes of this Pen.

Exceptions

Exception Type | Condition
ArgumentException | The Brush property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


Color Property

Aspose.Imaging Documentation

Pen.Color Property

Gets or sets the color of this Pen.

public Color Color {get; set;}

Property Value

A Color structure that represents the color of this Pen.

Exceptions

Exception Type | Condition
ArgumentException | The Color property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


CompoundArray Property

Aspose.Imaging Documentation

Pen.CompoundArray Property

Gets or sets an array of values that specifies a compound pen. A compound pen draws a compound line made up of parallel lines and spaces.

public float[] CompoundArray {get; set;}

Property Value

An array of real numbers that specifies the compound array. The elements in the array must be in increasing order, not less than 0, and not greater than 1.

Exceptions

Exception Type | Condition
ArgumentException | The CompoundArray property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


CustomEndCap Property

Aspose.Imaging Documentation

Pen.CustomEndCap Property

Gets or sets a custom cap to use at the end of lines drawn with this Pen.

public CustomLineCap CustomEndCap {get; set;}

Property Value

A CustomLineCap that represents the cap used at the end of lines drawn with this Pen.

Exceptions

Exception Type | Condition
ArgumentException | The CustomEndCap property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


CustomStartCap Property

Aspose.Imaging Documentation

Pen.CustomStartCap Property

Gets or sets a custom cap to use at the beginning of lines drawn with this Pen.

public CustomLineCap CustomStartCap {get; set;}

Property Value

A CustomLineCap that represents the cap used at the beginning of lines drawn with this Pen.

Exceptions

Exception Type | Condition
ArgumentException | The CustomStartCap property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


DashCap Property

Aspose.Imaging Documentation

Pen.DashCap Property

Gets or sets the cap style used at the end of the dashes that make up dashed lines drawn with this Pen.

public DashCap DashCap {get; set;}

Property Value

One of the DashCap values that represents the cap style used at the beginning and end of the dashes that make up dashed lines drawn with this Pen.

Exceptions

Exception Type | Condition
ArgumentException | The DashCap property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


DashOffset Property

Aspose.Imaging Documentation

Pen.DashOffset Property

Gets or sets the distance from the start of a line to the beginning of a dash pattern.

public float DashOffset {get; set;}

Property Value

The distance from the start of a line to the beginning of a dash pattern.

Exceptions

Exception Type | Condition
ArgumentException | The DashOffset property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


DashPattern Property

Aspose.Imaging Documentation

Pen.DashPattern Property

Gets or sets an array of custom dashes and spaces.

public float[] DashPattern {get; set;}

Property Value

An array of real numbers that specifies the lengths of alternating dashes and spaces in dashed lines.

Exceptions

Exception Type | Condition
ArgumentException | The DashPattern property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


DashStyle Property

Aspose.Imaging Documentation

Pen.DashStyle Property

Gets or sets the style used for dashed lines drawn with this Pen.

public DashStyle DashStyle {get; set;}

Property Value

A DashStyle that represents the style used for dashed lines drawn with this Pen.

Exceptions

Exception Type | Condition
ArgumentException | The DashStyle property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


EndCap Property

Aspose.Imaging Documentation

Pen.EndCap Property

Gets or sets the cap style used at the end of lines drawn with this Pen.

public LineCap EndCap {get; set;}

Property Value

One of the LineCap values that represents the cap style used at the end of lines drawn with this Pen.

Exceptions

Exception Type | Condition
ArgumentException | The EndCap property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


LineJoin Property

Aspose.Imaging Documentation

Pen.LineJoin Property

Gets or sets the join style for the ends of two consecutive lines drawn with this Pen.

public LineJoin LineJoin {get; set;}

Property Value

A LineJoin that represents the join style for the ends of two consecutive lines drawn with this Pen.

Exceptions

Exception Type | Condition
ArgumentException | The LineJoin property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


MiterLimit Property

Aspose.Imaging Documentation

Pen.MiterLimit Property

Gets or sets the limit of the thickness of the join on a mitered corner.

public float MiterLimit {get; set;}

Property Value

The limit of the thickness of the join on a mitered corner.

Exceptions

Exception Type | Condition
ArgumentException | The MiterLimit property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


PenType Property

Aspose.Imaging Documentation

Pen.PenType Property

Gets the style of lines drawn with this Pen.

public PenType PenType {get;}

Property Value

A PenType enumeration that specifies the style of lines drawn with this Pen.

See Also

Pen Class | Aspose.Imaging Namespace


StartCap Property

Aspose.Imaging Documentation

Pen.StartCap Property

Gets or sets the cap style used at the beginning of lines drawn with this Pen.

public LineCap StartCap {get; set;}

Property Value

One of the LineCap values that represents the cap style used at the beginning of lines drawn with this Pen.

Exceptions

Exception Type | Condition
ArgumentException | The StartCap property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


Transform Property

Aspose.Imaging Documentation

Pen.Transform Property

Gets or sets a copy of the geometric transformation for this Pen.

public Matrix Transform {get; set;}

Property Value

A copy of the Matrix that represents the geometric transformation for this Pen.

Exceptions

Exception Type | Condition
ArgumentException | The Transform property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


Width Property

Aspose.Imaging Documentation

Pen.Width Property

Gets or sets the width of this Pen, in units of the Graphics object used for drawing.

public float Width {get; set;}

Property Value

The width of this Pen.

Exceptions

Exception Type | Condition
ArgumentException | The Width property is set on an immutable Pen, such as those returned by the Pens class.

See Also

Pen Class | Aspose.Imaging Namespace


Pen Methods

The methods of the Pen class are listed below. For a complete list of Pen class members, see the Pen Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform | Overloaded. Multiplies the transformation matrix for this Pen by the specified Matrix.
ResetTransform | Resets the geometric transformation matrix for this Pen to identity.
RotateTransform | Overloaded. Rotates the local geometric transformation by the specified angle. This method prepends the rotation to the transformation.
ScaleTransform | Overloaded. Scales the local geometric transformation by the specified factors. This method prepends the scaling matrix to the transformation.
SetLineCap | Sets the values that determine the style of cap used to end lines drawn by this Pen.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. Translates the local geometric transformation by the specified dimensions. This method prepends the translation to the transformation.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pen Class | Aspose.Imaging Namespace


MultiplyTransform Method

Aspose.Imaging Documentation

Pen.MultiplyTransform Method

Multiplies the transformation matrix for this Pen by the specified Matrix.

Overload List

Multiplies the transformation matrix for this Pen by the specified Matrix.

public void MultiplyTransform(Matrix);

Multiplies the transformation matrix for this Pen by the specified Matrix in the specified order.

public void MultiplyTransform(Matrix,MatrixOrder);

See Also

Pen Class | Aspose.Imaging Namespace


Pen.MultiplyTransform Method (Matrix)

Multiplies the transformation matrix for this Pen by the specified Matrix.

public void MultiplyTransform(
Matrix matrix
);

Parameters

matrix
The Matrix object by which to multiply the transformation matrix.

See Also

Pen Class | Aspose.Imaging Namespace | Pen.MultiplyTransform Overload List


Pen.MultiplyTransform Method (Matrix, MatrixOrder)

Multiplies the transformation matrix for this Pen by the specified Matrix in the specified order.

public void MultiplyTransform(
Matrix matrix,
MatrixOrder order
);

Parameters

matrix
The Matrix by which to multiply the transformation matrix.
order
The order in which to perform the multiplication operation.

See Also

Pen Class | Aspose.Imaging Namespace | Pen.MultiplyTransform Overload List


Pen.ResetTransform Method

Resets the geometric transformation matrix for this Pen to identity.

public void ResetTransform();

See Also

Pen Class | Aspose.Imaging Namespace


RotateTransform Method

Aspose.Imaging Documentation

Pen.RotateTransform Method

Rotates the local geometric transformation by the specified angle. This method prepends the rotation to the transformation.

Overload List

Rotates the local geometric transformation by the specified angle. This method prepends the rotation to the transformation.

public void RotateTransform(float);

Rotates the local geometric transformation by the specified angle in the specified order.

public void RotateTransform(float,MatrixOrder);

See Also

Pen Class | Aspose.Imaging Namespace


Pen.RotateTransform Method (Single)

Rotates the local geometric transformation by the specified angle. This method prepends the rotation to the transformation.

public void RotateTransform(
float angle
);

Parameters

angle
The angle of rotation.

See Also

Pen Class | Aspose.Imaging Namespace | Pen.RotateTransform Overload List


Pen.RotateTransform Method (Single, MatrixOrder)

Rotates the local geometric transformation by the specified angle in the specified order.

public void RotateTransform(
float angle,
MatrixOrder order
);

Parameters

angle
The angle of rotation.
order
A MatrixOrder that specifies whether to append or prepend the rotation matrix.

See Also

Pen Class | Aspose.Imaging Namespace | Pen.RotateTransform Overload List


ScaleTransform Method

Aspose.Imaging Documentation

Pen.ScaleTransform Method

Scales the local geometric transformation by the specified factors. This method prepends the scaling matrix to the transformation.

Overload List

Scales the local geometric transformation by the specified factors. This method prepends the scaling matrix to the transformation.

public void ScaleTransform(float,float);

Scales the local geometric transformation by the specified factors in the specified order.

public void ScaleTransform(float,float,MatrixOrder);

See Also

Pen Class | Aspose.Imaging Namespace


Pen.ScaleTransform Method (Single, Single)

Scales the local geometric transformation by the specified factors. This method prepends the scaling matrix to the transformation.

public void ScaleTransform(
float sx,
float sy
);

Parameters

sx
The factor by which to scale the transformation in the x-axis direction.
sy
The factor by which to scale the transformation in the y-axis direction.

See Also

Pen Class | Aspose.Imaging Namespace | Pen.ScaleTransform Overload List


Pen.ScaleTransform Method (Single, Single, MatrixOrder)

Scales the local geometric transformation by the specified factors in the specified order.

public void ScaleTransform(
float sx,
float sy,
MatrixOrder order
);

Parameters

sx
The factor by which to scale the transformation in the x-axis direction.
sy
The factor by which to scale the transformation in the y-axis direction.
order
A MatrixOrder that specifies whether to append or prepend the scaling matrix.

See Also

Pen Class | Aspose.Imaging Namespace | Pen.ScaleTransform Overload List


Pen.SetLineCap Method

Sets the values that determine the style of cap used to end lines drawn by this Pen.

public void SetLineCap(
LineCap startCap,
LineCap endCap,
DashCap dashCap
);

Parameters

startCap
A LineCap that represents the cap style to use at the beginning of lines drawn with this Pen.
endCap
A LineCap that represents the cap style to use at the end of lines drawn with this Pen.
dashCap
A LineCap that represents the cap style to use at the beginning or end of dashed lines drawn with this Pen.

See Also

Pen Class | Aspose.Imaging Namespace


TranslateTransform Method

Aspose.Imaging Documentation

Pen.TranslateTransform Method

Translates the local geometric transformation by the specified dimensions. This method prepends the translation to the transformation.

Overload List

Translates the local geometric transformation by the specified dimensions. This method prepends the translation to the transformation.

public void TranslateTransform(float,float);

Translates the local geometric transformation by the specified dimensions in the specified order.

public void TranslateTransform(float,float,MatrixOrder);

See Also

Pen Class | Aspose.Imaging Namespace


Pen.TranslateTransform Method (Single, Single)

Translates the local geometric transformation by the specified dimensions. This method prepends the translation to the transformation.

public void TranslateTransform(
float dx,
float dy
);

Parameters

dx
The value of the translation in x.
dy
The value of the translation in y.

See Also

Pen Class | Aspose.Imaging Namespace | Pen.TranslateTransform Overload List


Pen.TranslateTransform Method (Single, Single, MatrixOrder)

Translates the local geometric transformation by the specified dimensions in the specified order.

public void TranslateTransform(
float dx,
float dy,
MatrixOrder order
);

Parameters

dx
The value of the translation in x.
dy
The value of the translation in y.
order
The order (prepend or append) in which to apply the translation.

See Also

Pen Class | Aspose.Imaging Namespace | Pen.TranslateTransform Overload List


PenAlignment Enumeration

Specifies the alignment of a Pen object in relation to the theoretical, zero-width line.

public enum PenAlignment

Members

Member Name | Description | Value
Center | Specifies that the Pen object is centered over the theoretical line. | 0
Inset | Specifies that the Pen is positioned on the inside of the theoretical line. | 1
Outset | Specifies the Pen is positioned on the outside of the theoretical line. | 2
Left | Specifies the Pen is positioned to the left of the theoretical line. | 3
Right | Specifies the Pen is positioned to the right of the theoretical line. | 4

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


Pens Class

Pens for all the standard colors. This class cannot be inherited.

For a list of all members of this type, see Pens Members.

System.Object
Aspose.Imaging.Pens

public sealed class Pens

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Pens Members | Aspose.Imaging Namespace


Pens Members

Pens overview

Public Instance Constructors

Pens Constructor Initializes a new instance of the Pens class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Pens Class | Aspose.Imaging Namespace


Pens Constructor

Initializes a new instance of the Pens class.

public Pens();

See Also

Pens Class | Aspose.Imaging Namespace


PenType Enumeration

Specifies the type of fill a Pen object uses to fill lines.

public enum PenType

Members

Member Name | Description | Value
SolidColor | Specifies a solid fill. | 0
HatchFill | Specifies a hatch fill. | 1
TextureFill | Specifies a bitmap texture fill. | 2
PathGradient | Specifies a path gradient fill. | 3
LinearGradient | Specifies a linear gradient fill. | 4

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


PixelDataFormat Class

The pixel data format.

For a list of all members of this type, see PixelDataFormat Members.

System.Object
Aspose.Imaging.PixelDataFormat

public class PixelDataFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PixelDataFormat Members | Aspose.Imaging Namespace


PixelDataFormat Members

PixelDataFormat overview

Public Static Properties

CMYK | Gets the PixelDataFormat defined for 32 bits per pixel with 8 bits for each of the alpha, red, green and blue.
Grayscale | Gets the grayscale.
Rgb16Bpp555 | Gets the PixelDataFormat defined for 16 bits per pixel with 5 bits for each of the red, green and blue, alpha is not defined.
Rgb24Bpp | Gets the PixelDataFormat defined for 24 bits per pixel with 8 bits for each of the alpha, red, green and blue, alpha is not defined.
Rgb32Bpp | Gets the PixelDataFormat defined for 32 bits per pixel with 8 bits for each of the alpha, red, green and blue.
RgbIndexed1Bpp | Gets the PixelDataFormat defined for indexed 1 bit per color. The indexed pixel data storage is intended to allow data storage and retrieval everywhere the color palette is used. Use with caution, because may require conversion from one palette to another or from RGBA to indexed color model.
RgbIndexed2Bpp | Gets the PixelDataFormat defined for indexed 2 bit per color. The indexed pixel data storage is intended to allow data storage and retrieval everywhere the color palette is used. Use with caution, because may require conversion from one palette to another or from RGBA to indexed color model.
RgbIndexed4Bpp | Gets the PixelDataFormat defined for indexed 4 bit per color. The indexed pixel data storage is intended to allow data storage and retrieval everywhere the color palette is used. Use with caution, because may require conversion from one palette to another or from RGBA to indexed color model.
RgbIndexed8Bpp | Gets the PixelDataFormat defined for indexed 8 bit per color. The indexed pixel data storage is intended to allow data storage and retrieval everywhere the color palette is used. Use with caution, because may require conversion from one palette to another or from RGBA to indexed color model.
YCbCr | Gets the y cb cr.
Ycck | Gets the ycck.

Public Static Operators

Equality Operator | Returns result of equality for two PixelDataFormat classes.
Inequality Operator | Returns result of non-equality for two PixelDataFormat classes.

Public Instance Properties

BitsPerPixel | Gets the bits per pixel.
ChannelBits | Gets the bits count for each channel.
ChannelsCount | Gets the channels count.
PixelFormat | Gets the pixel format.

Public Instance Methods

Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


PixelDataFormat Properties

The properties of the PixelDataFormat class are listed below. For a complete list of PixelDataFormat class members, see the PixelDataFormat Members topic.

Public Static Properties

CMYK | Gets the PixelDataFormat defined for 32 bits per pixel with 8 bits for each of the alpha, red, green and blue.
Grayscale | Gets the grayscale.
Rgb16Bpp555 | Gets the PixelDataFormat defined for 16 bits per pixel with 5 bits for each of the red, green and blue, alpha is not defined.
Rgb24Bpp | Gets the PixelDataFormat defined for 24 bits per pixel with 8 bits for each of the alpha, red, green and blue, alpha is not defined.
Rgb32Bpp | Gets the PixelDataFormat defined for 32 bits per pixel with 8 bits for each of the alpha, red, green and blue.
RgbIndexed1Bpp | Gets the PixelDataFormat defined for indexed 1 bit per color. The indexed pixel data storage is intended to allow data storage and retrieval everywhere the color palette is used. Use with caution, because may require conversion from one palette to another or from RGBA to indexed color model.
RgbIndexed2Bpp | Gets the PixelDataFormat defined for indexed 2 bit per color. The indexed pixel data storage is intended to allow data storage and retrieval everywhere the color palette is used. Use with caution, because may require conversion from one palette to another or from RGBA to indexed color model.
RgbIndexed4Bpp | Gets the PixelDataFormat defined for indexed 4 bit per color. The indexed pixel data storage is intended to allow data storage and retrieval everywhere the color palette is used. Use with caution, because may require conversion from one palette to another or from RGBA to indexed color model.
RgbIndexed8Bpp | Gets the PixelDataFormat defined for indexed 8 bit per color. The indexed pixel data storage is intended to allow data storage and retrieval everywhere the color palette is used. Use with caution, because may require conversion from one palette to another or from RGBA to indexed color model.
YCbCr | Gets the y cb cr.
Ycck | Gets the ycck.

Public Instance Properties

BitsPerPixel | Gets the bits per pixel.
ChannelBits | Gets the bits count for each channel.
ChannelsCount | Gets the channels count.
PixelFormat | Gets the pixel format.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

PixelDataFormat.BitsPerPixel Property

Gets the bits per pixel.

public int BitsPerPixel {get;}

Property Value

The bits per pixel.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


ChannelBits Property

Aspose.Imaging Documentation

PixelDataFormat.ChannelBits Property

Gets the bits count for each channel.

public int[] ChannelBits {get;}

Property Value

The channel bits.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


ChannelsCount Property

Aspose.Imaging Documentation

PixelDataFormat.ChannelsCount Property

Gets the channels count.

public int ChannelsCount {get;}

Property Value

The channels count.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


CMYK Property

Aspose.Imaging Documentation

PixelDataFormat.CMYK Property

Gets the PixelDataFormat defined for 32 bits per pixel with 8 bits for each of the alpha, red, green and blue.

public static PixelDataFormat CMYK {get;}

Property Value

The PixelDataFormat defined for 32 bits per pixel with 8 bits for each of the alpha, red, green and blue.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


Grayscale Property

Aspose.Imaging Documentation

PixelDataFormat.Grayscale Property

Gets the grayscale.

public static PixelDataFormat Grayscale {get;}

Property Value

The grayscale.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


PixelFormat Property

Aspose.Imaging Documentation

PixelDataFormat.PixelFormat Property

Gets the pixel format.

public PixelFormat PixelFormat {get;}

Property Value

The pixel format.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


Rgb16Bpp555 Property

Aspose.Imaging Documentation

PixelDataFormat.Rgb16Bpp555 Property

Gets the PixelDataFormat defined for 16 bits per pixel with 5 bits for each of the red, green and blue, alpha is not defined.

public static PixelDataFormat Rgb16Bpp555 {get;}

Property Value

The PixelDataFormat defined for 16 bits per pixel with 5 bits for each of the red, green and blue, alpha is not defined.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


Rgb24Bpp Property

Aspose.Imaging Documentation

PixelDataFormat.Rgb24Bpp Property

Gets the PixelDataFormat defined for 24 bits per pixel with 8 bits for each of the alpha, red, green and blue, alpha is not defined.

public static PixelDataFormat Rgb24Bpp {get;}

Property Value

The PixelDataFormat defined for 24 bits per pixel with 8 bits for each of the alpha, red, green and blue, alpha is not defined.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


Rgb32Bpp Property

Aspose.Imaging Documentation

PixelDataFormat.Rgb32Bpp Property

Gets the PixelDataFormat defined for 32 bits per pixel with 8 bits for each of the alpha, red, green and blue.

public static PixelDataFormat Rgb32Bpp {get;}

Property Value

The PixelDataFormat defined for 32 bits per pixel with 8 bits for each of the alpha, red, green and blue.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


RgbIndexed1Bpp Property

Aspose.Imaging Documentation

PixelDataFormat.RgbIndexed1Bpp Property

Gets the PixelDataFormat defined for indexed 1 bit per color. The indexed pixel data storage is intended to allow data storage and retrieval everywhere the color palette is used. Use with caution, because may require conversion from one palette to another or from RGBA to indexed color model.

public static PixelDataFormat RgbIndexed1Bpp {get;}

Property Value

The PixelDataFormat defined for indexed 1 bit per color.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


RgbIndexed2Bpp Property

Aspose.Imaging Documentation

PixelDataFormat.RgbIndexed2Bpp Property

Gets the PixelDataFormat defined for indexed 2 bit per color. The indexed pixel data storage is intended to allow data storage and retrieval everywhere the color palette is used. Use with caution, because may require conversion from one palette to another or from RGBA to indexed color model.

public static PixelDataFormat RgbIndexed2Bpp {get;}

Property Value

The PixelDataFormat defined for indexed 2 bit per color.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


RgbIndexed4Bpp Property

Aspose.Imaging Documentation

PixelDataFormat.RgbIndexed4Bpp Property

Gets the PixelDataFormat defined for indexed 4 bit per color. The indexed pixel data storage is intended to allow data storage and retrieval everywhere the color palette is used. Use with caution, because may require conversion from one palette to another or from RGBA to indexed color model.

public static PixelDataFormat RgbIndexed4Bpp {get;}

Property Value

The PixelDataFormat defined for indexed 4 bit per color.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


RgbIndexed8Bpp Property

Aspose.Imaging Documentation

PixelDataFormat.RgbIndexed8Bpp Property

Gets the PixelDataFormat defined for indexed 8 bit per color. The indexed pixel data storage is intended to allow data storage and retrieval everywhere the color palette is used. Use with caution, because may require conversion from one palette to another or from RGBA to indexed color model.

public static PixelDataFormat RgbIndexed8Bpp {get;}

Property Value

The PixelDataFormat defined for indexed 8 bit per color.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


YCbCr Property

Aspose.Imaging Documentation

PixelDataFormat.YCbCr Property

Gets the y cb cr.

public static PixelDataFormat YCbCr {get;}

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


Ycck Property

Aspose.Imaging Documentation

PixelDataFormat.Ycck Property

Gets the ycck.

public static PixelDataFormat Ycck {get;}

Property Value

The ycck.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


PixelDataFormat Methods

The methods of the PixelDataFormat class are listed below. For a complete list of PixelDataFormat class members, see the PixelDataFormat Members topic.

Public Instance Methods

Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


PixelDataFormat.Equals Method

Determines whether the specified Object is equal to this instance.

public override bool Equals(
object obj
);

Parameters

obj
The Object to compare with this instance.

Return Value

true if the specified Object is equal to this instance; otherwise, false.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


PixelDataFormat.GetHashCode Method

Returns a hash code for this instance.

public override int GetHashCode();

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


PixelDataFormat.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


PixelDataFormat Operators

The operators of the PixelDataFormat class are listed below. For a complete list of PixelDataFormat class members, see the PixelDataFormat Members topic.

Public Static Operators

Equality Operator | Returns result of equality for two PixelDataFormat classes.
Inequality Operator | Returns result of non-equality for two PixelDataFormat classes.

See Also

PixelDataFormat Class | PixelDataFormat Members | Aspose.Imaging Namespace


PixelDataFormat Equality Operator

Returns result of equality for two PixelDataFormat classes.

public static bool operator ==(
PixelDataFormat pixelFormat1,
PixelDataFormat pixelFormat2
);

Parameters

pixelFormat1
The first PixelDataFormat to compare.
pixelFormat2
The second PixelDataFormat to compare.

Return Value

True if both pixelFormat1 and pixelFormat2 contain equal data or both parameters are null.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


PixelDataFormat Inequality Operator

Returns result of non-equality for two PixelDataFormat classes.

public static bool operator !=(
PixelDataFormat pixelFormat1,
PixelDataFormat pixelFormat2
);

Parameters

pixelFormat1
The first PixelDataFormat to compare.
pixelFormat2
The second PixelDataFormat to compare.

Return Value

True if both pixelFormat1 and pixelFormat2 contain non-equal data or one of the parameters is null.

See Also

PixelDataFormat Class | Aspose.Imaging Namespace


PixelFormat Enumeration

The pixel data format actual meaning.

public enum PixelFormat

Members

Member Name | Description | Value
Grayscale | The grayscale color space | 0
RGB | The RGB color space. | 1
YCbCr | The YCbCr color space. | 2
CMYK | The CMYK color space. | 3
YCCK | The YCCK color space. | 4

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


Point Structure

Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.

For a list of all members of this type, see Point Members.

System.Object
System.ValueType
Aspose.Imaging.Point

public struct Point

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Point Members | Aspose.Imaging Namespace


Point Members

Point overview

Public Static Properties

Empty Gets a new instance of the Point structure that has X and Y values set to zero.

Public Static Methods

Add | Adds the specified Size to the specified Point.
Ceiling | Converts the specified PointF to a Point by rounding the values of the PointF to the next higher integer values.
Round | Converts the specified PointF to a Point object by rounding the Point values to the nearest integer.
Subtract | Returns the result of subtracting specified Size from the specified Point.
Truncate | Converts the specified PointF to a Point by truncating the values of the Point.

Public Static Operators and Type Conversions

Addition Operator | Translates a Point by a given Size.
Equality Operator | Compares two Point objects. The result specifies whether the values of the X and Y properties of the two Point objects are equal.
Inequality Operator | Compares two Point objects. The result specifies whether the values of the X or Y properties of the two Point objects are unequal.
Subtraction Operator | Translates a Point by the negative of a given Size.
Explicit Point to Size Conversion | Converts the specified Point structure to a Size structure.
Implicit Point to PointF Conversion | Converts the specified Point structure to the PointF structure.

Public Instance Constructors

Point Overloaded. Initializes a new instance of the Point class.

Public Instance Properties

IsEmpty | Gets a value indicating whether this Point is empty.
X | Gets or sets the x-coordinate of this Point.
Y | Gets or sets the y-coordinate of this Point.

Public Instance Methods

Equals | Specifies whether this Point contains the same coordinates as the specified Object.
GetHashCode | Returns a hash code for this Point.
GetType (inherited from Object) | Gets the Type of the current instance.
Offset | Overloaded. Translates this Point by the specified Point.
ToString | Converts this Point to a human-readable string.

See Also

Point Class | Aspose.Imaging Namespace


Point Constructor

Initializes a new instance of the Point structure with the specified coordinates.

Overload List

Initializes a new instance of the Point structure from the Size structure.

public Point(Size);

Initializes a new instance of the Point structure using coordinates specified by an integer value.

public Point(int);

Initializes a new instance of the Point structure with the specified coordinates.

public Point(int,int);

See Also

Point Class | Aspose.Imaging Namespace


Point Constructor (Int32, Int32)

Initializes a new instance of the Point structure with the specified coordinates.

public Point(
int x,
int y
);

Parameters

x
The horizontal position of the point.
y
The vertical position of the point.

See Also

Point Class | Aspose.Imaging Namespace | Point Constructor Overload List


Point Constructor (Size)

Initializes a new instance of the Point structure from the Size structure.

public Point(
Size size
);

Parameters

size
Contains the new point coordinates.

See Also

Point Class | Aspose.Imaging Namespace | Point Constructor Overload List


Point Constructor (Int32)

Initializes a new instance of the Point structure using coordinates specified by an integer value.

public Point(
int dw
);

Parameters

dw
A 32-bit integer that specifies the coordinates for the new point.

See Also

Point Class | Aspose.Imaging Namespace | Point Constructor Overload List


Point Properties

The properties of the Point structure are listed below. For a complete list of Point structure members, see the Point Members topic.

Public Static Properties

Empty Gets a new instance of the Point structure that has X and Y values set to zero.

Public Instance Properties

IsEmpty | Gets a value indicating whether this Point is empty.
X | Gets or sets the x-coordinate of this Point.
Y | Gets or sets the y-coordinate of this Point.

See Also

Point Class | Aspose.Imaging Namespace


Empty Property

Aspose.Imaging Documentation

Point.Empty Property

Gets a new instance of the Point structure that has X and Y values set to zero.

public static Point Empty {get;}

See Also

Point Class | Aspose.Imaging Namespace


IsEmpty Property

Aspose.Imaging Documentation

Point.IsEmpty Property

Gets a value indicating whether this Point is empty.

public bool IsEmpty {get;}

See Also

Point Class | Aspose.Imaging Namespace


X Property

Aspose.Imaging Documentation

Point.X Property

Gets or sets the x-coordinate of this Point.

public int X {get; set;}

See Also

Point Class | Aspose.Imaging Namespace


Y Property

Aspose.Imaging Documentation

Point.Y Property

Gets or sets the y-coordinate of this Point.

public int Y {get; set;}

See Also

Point Class | Aspose.Imaging Namespace


Point Methods

The methods of the Point structure are listed below. For a complete list of Point structure members, see the Point Members topic.

Public Static Methods

Add | Adds the specified Size to the specified Point.
Ceiling | Converts the specified PointF to a Point by rounding the values of the PointF to the next higher integer values.
Round | Converts the specified PointF to a Point object by rounding the Point values to the nearest integer.
Subtract | Returns the result of subtracting specified Size from the specified Point.
Truncate | Converts the specified PointF to a Point by truncating the values of the Point.

Public Instance Methods

Equals | Specifies whether this Point contains the same coordinates as the specified Object.
GetHashCode | Returns a hash code for this Point.
GetType (inherited from Object) | Gets the Type of the current instance.
Offset | Overloaded. Translates this Point by the specified Point.
ToString | Converts this Point to a human-readable string.

See Also

Point Class | Aspose.Imaging Namespace


Point.Add Method

Adds the specified Size to the specified Point.

public static Point Add(
Point point,
Size size
);

Parameters

point
The Point to add to.
size
The Size to add to the point.

Return Value

The Point that is the result of the addition operation.

See Also

Point Class | Aspose.Imaging Namespace


Point.Ceiling Method

Converts the specified PointF to a Point by rounding the values of the PointF to the next higher integer values.

public static Point Ceiling(
PointF point
);

Parameters

point
The PointF to convert.

Return Value

The Point this method converts to.

See Also

Point Class | Aspose.Imaging Namespace


Point.Equals Method

Specifies whether this Point contains the same coordinates as the specified Object.

public override bool Equals(
object obj
);

Parameters

obj
The Object to test.

Return Value

True if obj is a Point and has the same coordinates as this Point.

See Also

Point Class | Aspose.Imaging Namespace


Point.GetHashCode Method

Returns a hash code for this Point.

public override int GetHashCode();

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

Point Class | Aspose.Imaging Namespace


Offset Method

Aspose.Imaging Documentation

Point.Offset Method

Translates this Point by the specified Point.

Overload List

Translates this Point by the specified Point.

public void Offset(Point);

Translates this Point by the specified amount.

public void Offset(int,int);

See Also

Point Class | Aspose.Imaging Namespace


Point.Offset Method (Point)

Translates this Point by the specified Point.

public void Offset(
Point point
);

Parameters

point
The Point used to offset this Point.

See Also

Point Class | Aspose.Imaging Namespace | Point.Offset Overload List


Point.Offset Method (Int32, Int32)

Translates this Point by the specified amount.

public void Offset(
int dx,
int dy
);

Parameters

dx
The amount to offset the x-coordinate.
dy
The amount to offset the y-coordinate.

See Also

Point Class | Aspose.Imaging Namespace | Point.Offset Overload List


Point.Round Method

Converts the specified PointF to a Point object by rounding the Point values to the nearest integer.

public static Point Round(
PointF point
);

Parameters

point
The PointF to convert.

Return Value

The Point this method converts to.

See Also

Point Class | Aspose.Imaging Namespace


Point.Subtract Method

Returns the result of subtracting specified Size from the specified Point.

public static Point Subtract(
Point point,
Size size
);

Parameters

point
The Point to be subtracted from.
size
The Size to subtract from the point.

Return Value

The Point that is the result of the subtraction operation.

See Also

Point Class | Aspose.Imaging Namespace


Point.ToString Method

Converts this Point to a human-readable string.

public override string ToString();

Return Value

A String that represents this instance.

See Also

Point Class | Aspose.Imaging Namespace


Point.Truncate Method

Converts the specified PointF to a Point by truncating the values of the Point.

public static Point Truncate(
PointF point
);

Parameters

point
The PointF to convert.

Return Value

The Point this method converts to.

See Also

Point Class | Aspose.Imaging Namespace


Point Operators and Type Conversions

The operators and type conversions of the Point structure are listed below. For a complete list of Point structure members, see the Point Members topic.

Public Static Operators and Type Conversions

Addition Operator | Translates a Point by a given Size.
Equality Operator | Compares two Point objects. The result specifies whether the values of the X and Y properties of the two Point objects are equal.
Inequality Operator | Compares two Point objects. The result specifies whether the values of the X or Y properties of the two Point objects are unequal.
Subtraction Operator | Translates a Point by the negative of a given Size.
Explicit Point to Size Conversion | Converts the specified Point structure to a Size structure.
Implicit Point to PointF Conversion | Converts the specified Point structure to the PointF structure.

See Also

Point Class | Point Members | Aspose.Imaging Namespace


Point Addition Operator

Translates a Point by a given Size.

public static Point operator +(
Point point,
Size size
);

Parameters

point
The Point to translate.
size
A Size that specifies the pair of numbers to add to the coordinates of point.

Return Value

The translated Point.

See Also

Point Class | Aspose.Imaging Namespace


Point Equality Operator

Compares two Point objects. The result specifies whether the values of the X and Y properties of the two Point objects are equal.

public static bool operator ==(
Point point1,
Point point2
);

Parameters

point1
A first Point to compare.
point2
A second Point to compare.

Return Value

True if the X and Y values of point1 and point2 are equal; otherwise, false.

See Also

Point Class | Aspose.Imaging Namespace


Point Inequality Operator

Compares two Point objects. The result specifies whether the values of the X or Y properties of the two Point objects are unequal.

public static bool operator !=(
Point point1,
Point point2
);

Parameters

point1
A first Point to compare.
point2
A second Point to compare.

Return Value

True if the values of either the X properties or the Y properties of point1 and point2 differ; otherwise, false.

See Also

Point Class | Aspose.Imaging Namespace


Point Subtraction Operator

Translates a Point by the negative of a given Size.

public static Point operator -(
Point point,
Size size
);

Parameters

point
The Point to translate.
size
A Size that specifies the pair of numbers to subtract from the coordinates of point.

Return Value

A Point structure that is translated by the negative of a given Size structure.

See Also

Point Class | Aspose.Imaging Namespace


Point Explicit Point to Size Conversion

Converts the specified Point structure to a Size structure.

public static explicit operator Size(
Point point
);

Parameters

point
The Point to be converted.

Return Value

The Size that results from the conversion.

See Also

Point Class | Aspose.Imaging Namespace


Point Implicit Point to PointF Conversion

Converts the specified Point structure to the PointF structure.

public static implicit operator PointF(
Point point
);

Parameters

point
The Point to be converted.

Return Value

The PointF that results from the conversion.

See Also

Point Class | Aspose.Imaging Namespace


PointF Structure

Represents an ordered pair of floating-point x- and y-coordinates that defines a point in a two-dimensional plane.

For a list of all members of this type, see PointF Members.

System.Object
System.ValueType
Aspose.Imaging.PointF

public struct PointF

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PointF Members | Aspose.Imaging Namespace


PointF Members

PointF overview

Public Static Properties

Empty Gets a new instance of the PointF structure that has X and Y values set to zero.

Public Static Methods

Add | Overloaded. Translates a given PointF by the specified Size.
Subtract | Overloaded. Translates a PointF by the negative of a specified size.

Public Static Operators

Addition Operator | Overloaded. Translates a PointF by a given Size.
Equality Operator | Compares two PointF structures. The result specifies whether the values of the X and Y properties of the two PointF structures are equal.
Inequality Operator | Determines whether the coordinates of the specified points are not equal.
Subtraction Operator | Overloaded. Translates a PointF by the negative of a given Size.

Public Instance Constructors

PointF Constructor Initializes a new instance of the PointF structure with the specified coordinates.

Public Instance Properties

IsEmpty | Gets a value indicating whether this PointF is empty.
X | Gets or sets the x-coordinate of this PointF.
Y | Gets or sets the y-coordinate of this PointF.

Public Instance Methods

Equals | Specifies whether this PointF contains the same coordinates as the specified Object.
GetHashCode | Returns a hash code for this PointF structure.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Converts this PointF to a human readable string.

See Also

PointF Class | Aspose.Imaging Namespace


PointF Constructor

Initializes a new instance of the PointF structure with the specified coordinates.

public PointF(
float x,
float y
);

Parameters

x
The horizontal position of the point.
y
The vertical position of the point.

See Also

PointF Class | Aspose.Imaging Namespace


PointF Properties

The properties of the PointF structure are listed below. For a complete list of PointF structure members, see the PointF Members topic.

Public Static Properties

Empty Gets a new instance of the PointF structure that has X and Y values set to zero.

Public Instance Properties

IsEmpty | Gets a value indicating whether this PointF is empty.
X | Gets or sets the x-coordinate of this PointF.
Y | Gets or sets the y-coordinate of this PointF.

See Also

PointF Class | Aspose.Imaging Namespace


Empty Property

Aspose.Imaging Documentation

PointF.Empty Property

Gets a new instance of the PointF structure that has X and Y values set to zero.

public static PointF Empty {get;}

See Also

PointF Class | Aspose.Imaging Namespace


IsEmpty Property

Aspose.Imaging Documentation

PointF.IsEmpty Property

Gets a value indicating whether this PointF is empty.

public bool IsEmpty {get;}

Property Value

True if both X and Y are 0; otherwise, false.

See Also

PointF Class | Aspose.Imaging Namespace


X Property

Aspose.Imaging Documentation

PointF.X Property

Gets or sets the x-coordinate of this PointF.

public float X {get; set;}

See Also

PointF Class | Aspose.Imaging Namespace


Y Property

Aspose.Imaging Documentation

PointF.Y Property

Gets or sets the y-coordinate of this PointF.

public float Y {get; set;}

See Also

PointF Class | Aspose.Imaging Namespace


PointF Methods

The methods of the PointF structure are listed below. For a complete list of PointF structure members, see the PointF Members topic.

Public Static Methods

Add | Overloaded. Translates a given PointF by the specified Size.
Subtract | Overloaded. Translates a PointF by the negative of a specified size.

Public Instance Methods

Equals | Specifies whether this PointF contains the same coordinates as the specified Object.
GetHashCode | Returns a hash code for this PointF structure.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Converts this PointF to a human readable string.

See Also

PointF Class | Aspose.Imaging Namespace


Add Method

Aspose.Imaging Documentation

PointF.Add Method

Translates a given PointF by the specified Size.

Overload List

Translates a given PointF by the specified Size.

public static PointF Add(PointF,Size);

Translates a given PointF by a specified SizeF.

public static PointF Add(PointF,SizeF);

See Also

PointF Class | Aspose.Imaging Namespace


PointF.Add Method (PointF, Size)

Translates a given PointF by the specified Size.

public static PointF Add(
PointF point,
Size size
);

Parameters

point
The PointF to translate.
size
The Size that specifies the numbers to add to the coordinates of point.

Return Value

The translated PointF.

See Also

PointF Class | Aspose.Imaging Namespace | PointF.Add Overload List


PointF.Add Method (PointF, SizeF)

Translates a given PointF by a specified SizeF.

public static PointF Add(
PointF point,
SizeF size
);

Parameters

point
The PointF to translate.
size
The SizeF that specifies the numbers to add to the coordinates of point.

Return Value

The translated PointF.

See Also

PointF Class | Aspose.Imaging Namespace | PointF.Add Overload List


PointF.Equals Method

Specifies whether this PointF contains the same coordinates as the specified Object.

public override bool Equals(
object obj
);

Parameters

obj
The Object to test.

Return Value

This method returns true if obj is a PointF and has the same coordinates as this Point.

See Also

PointF Class | Aspose.Imaging Namespace


PointF.GetHashCode Method

Returns a hash code for this PointF structure.

public override int GetHashCode();

Return Value

An integer value that specifies a hash value for this PointF structure.

See Also

PointF Class | Aspose.Imaging Namespace


Subtract Method

Aspose.Imaging Documentation

PointF.Subtract Method

Translates a PointF by the negative of a specified size.

Overload List

Translates a PointF by the negative of a specified size.

public static PointF Subtract(PointF,Size);

Translates a PointF by the negative of a specified size.

public static PointF Subtract(PointF,SizeF);

See Also

PointF Class | Aspose.Imaging Namespace


PointF.Subtract Method (PointF, Size)

Translates a PointF by the negative of a specified size.

public static PointF Subtract(
PointF point,
Size size
);

Parameters

point
The PointF to translate.
size
The Size that specifies the numbers to subtract from the coordinates of point.

Return Value

The translated PointF.

See Also

PointF Class | Aspose.Imaging Namespace | PointF.Subtract Overload List


PointF.Subtract Method (PointF, SizeF)

Translates a PointF by the negative of a specified size.

public static PointF Subtract(
PointF point,
SizeF size
);

Parameters

point
The PointF to translate.
size
The SizeF that specifies the numbers to subtract from the coordinates of point.

Return Value

The translated PointF.

See Also

PointF Class | Aspose.Imaging Namespace | PointF.Subtract Overload List


PointF.ToString Method

Converts this PointF to a human readable string.

public override string ToString();

Return Value

A string that represents this PointF.

See Also

PointF Class | Aspose.Imaging Namespace


PointF Operators

The operators of the PointF structure are listed below. For a complete list of PointF structure members, see the PointF Members topic.

Public Static Operators

Addition Operator | Overloaded. Translates a PointF by a given Size.
Equality Operator | Compares two PointF structures. The result specifies whether the values of the X and Y properties of the two PointF structures are equal.
Inequality Operator | Determines whether the coordinates of the specified points are not equal.
Subtraction Operator | Overloaded. Translates a PointF by the negative of a given Size.

See Also

PointF Class | PointF Members | Aspose.Imaging Namespace


PointF Addition Operator

Translates a PointF by a given Size.

Overload List

Translates a PointF by a given Size.

public static PointF Addition Operator(PointF,Size);

Translates the PointF by the specified SizeF.

public static PointF Addition Operator(PointF,SizeF);

See Also

PointF Class | Aspose.Imaging Namespace


PointF Addition Operator

Translates a PointF by a given Size.

public static PointF operator +(
PointF point,
Size size
);

Parameters

point
The PointF to translate.
size
A Size that specifies the pair of numbers to add to the coordinates of point.

Return Value

Returns the translated PointF.

See Also

PointF Class | Aspose.Imaging Namespace | PointFAddition Operator Overload List


PointF Addition Operator

Translates the PointF by the specified SizeF.

public static PointF operator +(
PointF point,
SizeF size
);

Parameters

point
The PointF to translate.
size
The SizeF that specifies the numbers to add to the x- and y-coordinates of the point.

Return Value

The translated PointF.

See Also

PointF Class | Aspose.Imaging Namespace | PointFAddition Operator Overload List


PointF Equality Operator

Compares two PointF structures. The result specifies whether the values of the X and Y properties of the two PointF structures are equal.

public static bool operator ==(
PointF point1,
PointF point2
);

Parameters

point1
A first PointF to compare.
point2
A second PointF to compare.

Return Value

True if the X and Y values of the first and second PointF structures are equal; otherwise, false.

See Also

PointF Class | Aspose.Imaging Namespace


PointF Inequality Operator

Determines whether the coordinates of the specified points are not equal.

public static bool operator !=(
PointF point1,
PointF point2
);

Parameters

point1
A first PointF to compare.
point2
A second PointF to compare.

Return Value

True to indicate the X and Y values of point1 and point2 are not equal; otherwise, false.

See Also

PointF Class | Aspose.Imaging Namespace


PointF Subtraction Operator

Translates a PointF by the negative of a given Size.

Overload List

Translates a PointF by the negative of a given Size.

public static PointF Subtraction Operator(PointF,Size);

Translates a PointF by the negative of a specified SizeF.

public static PointF Subtraction Operator(PointF,SizeF);

See Also

PointF Class | Aspose.Imaging Namespace


PointF Subtraction Operator

Translates a PointF by the negative of a given Size.

public static PointF operator -(
PointF point,
Size size
);

Parameters

point
A PointF to translate.
size
A Size that specifies the numbers to subtract from the x- and y-coordinates of the point.

Return Value

The translated PointF.

See Also

PointF Class | Aspose.Imaging Namespace | PointFSubtraction Operator Overload List


PointF Subtraction Operator

Translates a PointF by the negative of a specified SizeF.

public static PointF operator -(
PointF point,
SizeF size
);

Parameters

point
The PointF to translate.
size
The SizeF that specifies the numbers to subtract from the coordinates of point.

Return Value

The translated PointF.

See Also

PointF Class | Aspose.Imaging Namespace | PointFSubtraction Operator Overload List


RasterCachedImage Class

Represents a raster image supporting raster graphics operations. This image caches pixel data when required.

For a list of all members of this type, see RasterCachedImage Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image
Aspose.Imaging.RasterImage
Aspose.Imaging.RasterCachedImage
Aspose.Imaging.FileFormats.Bmp.BmpImage
Aspose.Imaging.FileFormats.Gif.Blocks.GifFrameBlock
Aspose.Imaging.FileFormats.Jpeg.JpegImage
Aspose.Imaging.FileFormats.Psd.PsdImage
Aspose.Imaging.FileFormats.Tiff.TiffFrame

public abstract class RasterCachedImage : RasterImage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

RasterCachedImage Members | Aspose.Imaging Namespace


RasterCachedImage Members

RasterCachedImage overview

Public Instance Properties

BitsPerPixel (inherited from Image) | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
Height (inherited from Image) | Gets the image height.
HorizontalResolution (inherited from RasterImage) | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
IsCached | Gets a value indicating whether image data is cached currently.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution (inherited from RasterImage) | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width (inherited from Image) | Gets the image width.

Public Instance Methods

CacheData | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
Resize | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution (inherited from RasterImage) | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

Protected Instance Constructors

RasterCachedImage Overloaded. Initializes a new instance of the RasterCachedImage class.

Protected Instance Properties

DataLoader (inherited from RasterImage) Gets or sets the data loader.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFitRectangle (inherited from Image) | Overloaded. Gets rectangle which fits the current image.
LoadPixelsInternal (inherited from RasterImage) | Loads pixels (format specific method).
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCached | Called when data is cached and all related resources may be de-allocated.
OnDataStreamContainerChanging (inherited from DataStreamSupporter) | Called when data stream container is changing.
OnPaletteChanged | Called when palette is changed.
OnPaletteChanging (inherited from Image) | Called when palette is changing.
ReleaseManagedResources (inherited from RasterImage) | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
SaveData (inherited from DataStreamSupporter) | Saves the data.
SavePixelsInternal | Saves pixels (format specific method).
UpdateDimensions | Updates the image dimensions.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


RasterCachedImage Constructor

Initializes a new instance of the RasterCachedImage class.

Overload List

Initializes a new instance of the RasterCachedImage class.

protected RasterCachedImage();

Initializes a new instance of the RasterCachedImage class.

protected RasterCachedImage(IColorPalette);

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


RasterCachedImage Constructor ()

Initializes a new instance of the RasterCachedImage class.

protected RasterCachedImage();

See Also

RasterCachedImage Class | Aspose.Imaging Namespace | RasterCachedImage Constructor Overload List


RasterCachedImage Constructor (IColorPalette)

Initializes a new instance of the RasterCachedImage class.

protected RasterCachedImage(
IColorPalette colorPalette
);

Parameters

colorPalette
The color palette.

See Also

RasterCachedImage Class | Aspose.Imaging Namespace | RasterCachedImage Constructor Overload List


RasterCachedImage Properties

The properties of the RasterCachedImage class are listed below. For a complete list of RasterCachedImage class members, see the RasterCachedImage Members topic.

Public Instance Properties

BitsPerPixel (inherited from Image) | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
Height (inherited from Image) | Gets the image height.
HorizontalResolution (inherited from RasterImage) | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
IsCached | Gets a value indicating whether image data is cached currently.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution (inherited from RasterImage) | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width (inherited from Image) | Gets the image width.

Protected Instance Properties

DataLoader (inherited from RasterImage) Gets or sets the data loader.

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


IsCached Property

Aspose.Imaging Documentation

RasterCachedImage.IsCached Property

Gets a value indicating whether image data is cached currently.

public bool IsCached {get;}

Property Value

true if image data is cached; otherwise, false.

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


RasterCachedImage Methods

The methods of the RasterCachedImage class are listed below. For a complete list of RasterCachedImage class members, see the RasterCachedImage Members topic.

Public Instance Methods

CacheData | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
Resize | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution (inherited from RasterImage) | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFitRectangle (inherited from Image) | Overloaded. Gets rectangle which fits the current image.
LoadPixelsInternal (inherited from RasterImage) | Loads pixels (format specific method).
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCached | Called when data is cached and all related resources may be de-allocated.
OnDataStreamContainerChanging (inherited from DataStreamSupporter) | Called when data stream container is changing.
OnPaletteChanged | Called when palette is changed.
OnPaletteChanging (inherited from Image) | Called when palette is changing.
ReleaseManagedResources (inherited from RasterImage) | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
SaveData (inherited from DataStreamSupporter) | Saves the data.
SavePixelsInternal | Saves pixels (format specific method).
UpdateDimensions | Updates the image dimensions.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


RasterCachedImage.CacheData Method

Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.

public void CacheData();

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


Crop Method

Aspose.Imaging Documentation

RasterCachedImage.Crop Method

Cropping the image.

Overload List

Cropping the image.

public override void Crop(Rectangle);

Inherited from RasterImage.

public virtual void Crop(int,int,int,int);

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


RasterCachedImage.Crop Method (Rectangle)

Cropping the image.

public override void Crop(
Rectangle rectangle
);

Parameters

rectangle
The rectangle.

See Also

RasterCachedImage Class | Aspose.Imaging Namespace | RasterCachedImage.Crop Overload List


RasterCachedImage.OnCached Method

Called when data is cached and all related resources may be de-allocated.

protected virtual void OnCached();

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


RasterCachedImage.OnPaletteChanged Method

Called when palette is changed.

protected override void OnPaletteChanged(
IColorPalette oldPalette,
IColorPalette newPalette
);

Parameters

oldPalette
The old palette.
newPalette
The new palette.

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


Resize Method

Aspose.Imaging Documentation

RasterCachedImage.Resize Method

Resizes the image.

Overload List

Inherited from Image.

public void Resize(int,int);

Resizes the image.

public void Resize(int,int,ResizeType);

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


RasterCachedImage.Resize Method (Int32, Int32, ResizeType)

Resizes the image.

public void Resize(
int newWidth,
int newHeight,
ResizeType resizeType
);

Parameters

newWidth
The new width.
newHeight
The new height.
resizeType
The resize type.

See Also

RasterCachedImage Class | Aspose.Imaging Namespace | RasterCachedImage.Resize Overload List


RasterCachedImage.RotateFlip Method

Rotates, flips, or rotates and flips the image.

public void RotateFlip(
RotateFlipType rotateFlipType
);

Parameters

rotateFlipType
The rotate flip type.

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


RasterCachedImage.SavePixelsInternal Method

Saves pixels (format specific method).

protected void SavePixelsInternal(
Rectangle rectangle,
Color[] pixels
);

Parameters

rectangle
The rectangle to save pixels to.
pixels
The pixels array.

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


RasterCachedImage.UpdateDimensions Method

Updates the image dimensions.

protected abstract void UpdateDimensions(
int newWidth,
int newHeight
);

Parameters

newWidth
The new image width.
newHeight
The new image height.

See Also

RasterCachedImage Class | Aspose.Imaging Namespace


RasterImage Class

Represents a raster image supporting raster graphics operations.

For a list of all members of this type, see RasterImage Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image
Aspose.Imaging.RasterImage
Aspose.Imaging.FileFormats.Gif.GifImage
Aspose.Imaging.FileFormats.Png.PngImage
Aspose.Imaging.FileFormats.Tiff.TiffImage
Aspose.Imaging.RasterCachedImage

public abstract class RasterImage : Image, IRasterImagePixelLoader, IRasterImageRawDataLoader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows how to Loads Pixel information in an Array of Type Color, manipulates the array and set it back to the image. To perform these operations, this example creates a new Image file (in GIF format) uisng MemoryStream object.

[C#]

//Create an instance of MemoryStream
using (System.IO.MemoryStream stream = new System.IO.MemoryStream())
{
    //Create an instance of GifOptions and set its various properties including the Source property
    Aspose.Imaging.ImageOptions.GifOptions gifOptions = new Aspose.Imaging.ImageOptions.GifOptions();
    gifOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.RasterImage image = (Aspose.Imaging.RasterImage)Aspose.Imaging.Image.Create(gifOptions, 500, 500))
    {
        //Get the pixels of image by specifying the area as image boundary
        Aspose.Imaging.Color[] pixels = image.LoadPixels(image.Bounds);

        //Loop over the Array and sets color of alrenative indexed pixel
        for (int index = 0; index < pixels.Length; index++)
        {
            if (index % 2 == 0)
            {
                //Set the indexed pixel color to yellow
                pixels[index] = Aspose.Imaging.Color.Yellow;
            }
            else
            {
                //Set the indexed pixel color to blue
                pixels[index] = Aspose.Imaging.Color.Blue;
            }
        }

        //Apply the pixel changes to the image
        image.SavePixels(image.Bounds, pixels);

        // save all changes.
        image.Save();
    }

    //Write MemoryStream to File
    stream.WriteTo(new System.IO.FileStream(@"C:\temp\output.gif", System.IO.FileMode.CreateNew));
}
[Visual Basic]

'Create an instance of MemoryStream
Using stream As System.IO.MemoryStream = New System.IO.MemoryStream()
'Create an instance of GifOptions and set its various properties including the Source property
Dim gifOptions As Aspose.Imaging.ImageOptions.GifOptions = New Aspose.Imaging.ImageOptions.GifOptions()
    gifOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.RasterImage = CType(Aspose.Imaging.Image.Create(gifOptions, 500, 500), Aspose.Imaging.RasterImage)
'Get the pixels of image by specifying the area as image boundary
Dim pixels As Aspose.Imaging.Color() = image.LoadPixels(image.Bounds)

'Loop over the Array and sets color of alrenative indexed pixel
Dim index As Integer = 0
        Do While index < pixels.Length
            If index Mod 2 = 0 Then
'Set the indexed pixel color to yellow
                pixels(index) = Aspose.Imaging.Color.Yellow
            Else
'Set the indexed pixel color to blue
                pixels(index) = Aspose.Imaging.Color.Blue
            End If
            index += 1
        Loop

'Apply the pixel changes to the image
        image.SavePixels(image.Bounds, pixels)

' save all changes.
        image.Save()
    End Using

'Write MemoryStream to File
    stream.WriteTo(New System.IO.FileStream("C:\temp\output.gif", System.IO.FileMode.CreateNew))
End Using

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

RasterImage Members | Aspose.Imaging Namespace


RasterImage Members

RasterImage overview

Public Instance Properties

BitsPerPixel (inherited from Image) | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings | Gets or sets the dithering settings.
Height (inherited from Image) | Gets the image height.
HorizontalResolution | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
IsCached (inherited from DataStreamSupporter) | Gets a value indicating whether object's data is cached currently and no data readig is required.
IsRawDataAvailable | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter | Gets or sets the custom color converter
RawDataFormat | Gets the raw data format.
RawDataSettings | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter | Gets or sets the indexed color converter
RawLineSize | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width (inherited from Image) | Gets the image width.

Public Instance Methods

CacheData (inherited from DataStreamSupporter) | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels | Loads pixels in CMYK format.
LoadPartialPixels | Loads pixels partially by packs.
LoadPixels | Loads pixels.
LoadRawData | Loads raw data.
ReadScanLine | Reads the whole scan line by the specified scan line index.
Resize | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip (inherited from Image) | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels | Saves the pixels.
SavePixels | Saves the pixels.
SaveRawData | Saves the raw data.
SetPalette | Sets the image palette.
SetPixel | Sets an image pixel for the specified position.
SetResolution | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine | Writes the whole scan line to the specified scan line index.

Protected Instance Constructors

RasterImage Overloaded. Initializes a new instance of the RasterImage class.

Protected Instance Properties

DataLoader Gets or sets the data loader.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFitRectangle (inherited from Image) | Overloaded. Gets rectangle which fits the current image.
LoadPixelsInternal | Loads pixels (format specific method).
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataStreamContainerChanging (inherited from DataStreamSupporter) | Called when data stream container is changing.
OnPaletteChanged (inherited from Image) | Called when palette is changed.
OnPaletteChanging (inherited from Image) | Called when palette is changing.
ReleaseManagedResources | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
SaveData (inherited from DataStreamSupporter) | Saves the data.
SavePixelsInternal | Saves pixels (format specific method).
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage Constructor

Initializes a new instance of the RasterImage class.

Overload List

Initializes a new instance of the RasterImage class.

protected RasterImage();

Initializes a new instance of the RasterImage class.

protected RasterImage(IColorPalette);

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage Constructor ()

Initializes a new instance of the RasterImage class.

protected RasterImage();

See Also

RasterImage Class | Aspose.Imaging Namespace | RasterImage Constructor Overload List


RasterImage Constructor (IColorPalette)

Initializes a new instance of the RasterImage class.

protected RasterImage(
IColorPalette colorPalette
);

Parameters

colorPalette
The color palette.

See Also

RasterImage Class | Aspose.Imaging Namespace | RasterImage Constructor Overload List


RasterImage Properties

The properties of the RasterImage class are listed below. For a complete list of RasterImage class members, see the RasterImage Members topic.

Public Instance Properties

BitsPerPixel (inherited from Image) | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings | Gets or sets the dithering settings.
Height (inherited from Image) | Gets the image height.
HorizontalResolution | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
IsCached (inherited from DataStreamSupporter) | Gets a value indicating whether object's data is cached currently and no data readig is required.
IsRawDataAvailable | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter | Gets or sets the custom color converter
RawDataFormat | Gets the raw data format.
RawDataSettings | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter | Gets or sets the indexed color converter
RawLineSize | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width (inherited from Image) | Gets the image width.

Protected Instance Properties

DataLoader Gets or sets the data loader.

See Also

RasterImage Class | Aspose.Imaging Namespace


DataLoader Property

Aspose.Imaging Documentation

RasterImage.DataLoader Property

Gets or sets the data loader.

protected IRasterImagePixelLoader DataLoader {get; set;}

Property Value

The data loader.

See Also

RasterImage Class | Aspose.Imaging Namespace


DitheringSettings Property

Aspose.Imaging Documentation

RasterImage.DitheringSettings Property

Gets or sets the dithering settings.

public virtual DitheringMode DitheringSettings {get; set;}

See Also

RasterImage Class | Aspose.Imaging Namespace


HorizontalResolution Property

Aspose.Imaging Documentation

RasterImage.HorizontalResolution Property

Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.

public virtual double HorizontalResolution {get; set;}

Property Value

The horizontal resolution.

Remarks

Note by default this value is always 96 since different platforms cannot return the screen resolution. You may consider using the SetResolution method for updating both resolution values in single call.

See Also

RasterImage Class | Aspose.Imaging Namespace


IsRawDataAvailable Property

Aspose.Imaging Documentation

RasterImage.IsRawDataAvailable Property

Gets a value indicating whether raw data loading is available.

public bool IsRawDataAvailable {get;}

Property Value

true if this raw data loading is available; otherwise, false.

Implements

IRasterImageRawDataLoader.IsRawDataAvailable

See Also

RasterImage Class | Aspose.Imaging Namespace


RawCustomColorConverter Property

Aspose.Imaging Documentation

RasterImage.RawCustomColorConverter Property

Gets or sets the custom color converter

public IColorConverter RawCustomColorConverter {get; set;}

Property Value

The custom color converter

See Also

RasterImage Class | Aspose.Imaging Namespace


RawDataFormat Property

Aspose.Imaging Documentation

RasterImage.RawDataFormat Property

Gets the raw data format.

public virtual PixelDataFormat RawDataFormat {get;}

Property Value

The raw data format.

See Also

RasterImage Class | Aspose.Imaging Namespace


RawDataSettings Property

Aspose.Imaging Documentation

RasterImage.RawDataSettings Property

Gets the current raw data settings. Note when using these settings the data loads without conversion.

public RawDataSettings RawDataSettings {get;}

Property Value

The current raw data settings.

Implements

IRasterImageRawDataLoader.RawDataSettings

See Also

RasterImage Class | Aspose.Imaging Namespace


RawDitheringMethod Property

Aspose.Imaging Documentation

RasterImage.RawDitheringMethod Property

Gets or sets the dithering method to use for raw data conversion

public DitheringMethods RawDitheringMethod {get; set;}

Property Value

The dithering method to use for raw data conversion

See Also

RasterImage Class | Aspose.Imaging Namespace


RawFallbackIndex Property

Aspose.Imaging Documentation

RasterImage.RawFallbackIndex Property

Gets or sets the fallback index to use when palette index is out of bounds

public int RawFallbackIndex {get; set;}

Property Value

The fallback index to use when palette index is out of bounds

See Also

RasterImage Class | Aspose.Imaging Namespace


RawIndexedColorConverter Property

Aspose.Imaging Documentation

RasterImage.RawIndexedColorConverter Property

Gets or sets the indexed color converter

public IIndexedColorConverter RawIndexedColorConverter {get; set;}

Property Value

The indexed color converter

See Also

RasterImage Class | Aspose.Imaging Namespace


RawLineSize Property

Aspose.Imaging Documentation

RasterImage.RawLineSize Property

Gets the raw line size in bytes.

public virtual int RawLineSize {get;}

Property Value

The raw line size in bytes.

See Also

RasterImage Class | Aspose.Imaging Namespace


VerticalResolution Property

Aspose.Imaging Documentation

RasterImage.VerticalResolution Property

Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.

public virtual double VerticalResolution {get; set;}

Property Value

The vertical resolution.

Remarks

Note by default this value is always 96 since different platforms cannot return the screen resolution. You may consider using the SetResolution method for updating both resolution values in single call.

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage Methods

The methods of the RasterImage class are listed below. For a complete list of RasterImage class members, see the RasterImage Members topic.

Public Instance Methods

CacheData (inherited from DataStreamSupporter) | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels | Loads pixels in CMYK format.
LoadPartialPixels | Loads pixels partially by packs.
LoadPixels | Loads pixels.
LoadRawData | Loads raw data.
ReadScanLine | Reads the whole scan line by the specified scan line index.
Resize | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip (inherited from Image) | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels | Saves the pixels.
SavePixels | Saves the pixels.
SaveRawData | Saves the raw data.
SetPalette | Sets the image palette.
SetPixel | Sets an image pixel for the specified position.
SetResolution | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine | Writes the whole scan line to the specified scan line index.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFitRectangle (inherited from Image) | Overloaded. Gets rectangle which fits the current image.
LoadPixelsInternal | Loads pixels (format specific method).
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataStreamContainerChanging (inherited from DataStreamSupporter) | Called when data stream container is changing.
OnPaletteChanged (inherited from Image) | Called when palette is changed.
OnPaletteChanging (inherited from Image) | Called when palette is changing.
ReleaseManagedResources | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
SaveData (inherited from DataStreamSupporter) | Saves the data.
SavePixelsInternal | Saves pixels (format specific method).
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

RasterImage Class | Aspose.Imaging Namespace


Crop Method

Aspose.Imaging Documentation

RasterImage.Crop Method

Cropping the image.

Overload List

Cropping the image.

public virtual void Crop(Rectangle);

Crops the specified left.

public virtual void Crop(int,int,int,int);

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.Crop Method (Rectangle)

Cropping the image.

public virtual void Crop(
Rectangle rectangle
);

Parameters

rectangle
The rectangle.

See Also

RasterImage Class | Aspose.Imaging Namespace | RasterImage.Crop Overload List


RasterImage.Crop Method (Int32, Int32, Int32, Int32)

Crops the specified left.

public virtual void Crop(
int left,
int right,
int top,
int bottom
);

Parameters

left
The left shift.
right
The right shift.
top
The top shift.
bottom
The bottom shift.

See Also

RasterImage Class | Aspose.Imaging Namespace | RasterImage.Crop Overload List


GetDefaultPixels Method

Aspose.Imaging Documentation

RasterImage.GetDefaultPixels Method

Gets the default pixels array.

Overload List

Gets the default pixels array.

public Color[] GetDefaultPixels(Rectangle);

Gets the default pixels array using partial pixel loader.

public void GetDefaultPixels(Rectangle,IPartialPixelLoader);

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.GetDefaultPixels Method (Rectangle)

Gets the default pixels array.

public Color[] GetDefaultPixels(
Rectangle rectangle
);

Parameters

rectangle
The rectangle to get pixels for.

Return Value

The default pixels array.

See Also

RasterImage Class | Aspose.Imaging Namespace | RasterImage.GetDefaultPixels Overload List


RasterImage.GetDefaultPixels Method (Rectangle, IPartialPixelLoader)

Gets the default pixels array using partial pixel loader.

public void GetDefaultPixels(
Rectangle rectangle,
IPartialPixelLoader partialPixelLoader
);

Parameters

rectangle
The rectangle to get pixels for.
partialPixelLoader
The partial pixel loader.

See Also

RasterImage Class | Aspose.Imaging Namespace | RasterImage.GetDefaultPixels Overload List


RasterImage.GetPixel Method

Gets an image pixel.

public Color GetPixel(
int x,
int y
);

Parameters

x
The pixel x location.
y
The pixel y location.

Return Value

The pixel color for the specified location.

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.LoadCMYKPixels Method

Loads pixels in CMYK format.

public CMYKColor[] LoadCMYKPixels(
Rectangle rectangle
);

Parameters

rectangle
The rectangle to load pixels from.

Return Value

The loaded CMYK pixels array.

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.LoadPartialPixels Method

Loads pixels partially by packs.

public void LoadPartialPixels(
Rectangle desiredRectangle,
IPartialPixelLoader pixelLoader
);

Parameters

desiredRectangle
The desired rectangle.
pixelLoader
The pixel loader.

Implements

IRasterImagePixelLoader.LoadPartialPixels

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.LoadPixels Method

Loads pixels.

public Color[] LoadPixels(
Rectangle rectangle
);

Parameters

rectangle
The rectangle to load pixels from.

Return Value

The loaded pixels array.

Example

This example shows how to Loads Pixel information in an Array of Type Color, manipulates the array and set it back to the image. To perform these operations, this example creates a new Image file (in GIF format) uisng MemoryStream object.

[C#]

//Create an instance of MemoryStream
using (System.IO.MemoryStream stream = new System.IO.MemoryStream())
{
    //Create an instance of GifOptions and set its various properties including the Source property
    Aspose.Imaging.ImageOptions.GifOptions gifOptions = new Aspose.Imaging.ImageOptions.GifOptions();
    gifOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.RasterImage image = (Aspose.Imaging.RasterImage)Aspose.Imaging.Image.Create(gifOptions, 500, 500))
    {
        //Get the pixels of image by specifying the area as image boundary
        Aspose.Imaging.Color[] pixels = image.LoadPixels(image.Bounds);

        //Loop over the Array and sets color of alrenative indexed pixel
        for (int index = 0; index < pixels.Length; index++)
        {
            if (index % 2 == 0)
            {
                //Set the indexed pixel color to yellow
                pixels[index] = Aspose.Imaging.Color.Yellow;
            }
            else
            {
                //Set the indexed pixel color to blue
                pixels[index] = Aspose.Imaging.Color.Blue;
            }
        }

        //Apply the pixel changes to the image
        image.SavePixels(image.Bounds, pixels);

        // save all changes.
        image.Save();
    }

    //Write MemoryStream to File
    stream.WriteTo(new System.IO.FileStream(@"C:\temp\output.gif", System.IO.FileMode.CreateNew));
}
[Visual Basic]

'Create an instance of MemoryStream
Using stream As System.IO.MemoryStream = New System.IO.MemoryStream()
'Create an instance of GifOptions and set its various properties including the Source property
Dim gifOptions As Aspose.Imaging.ImageOptions.GifOptions = New Aspose.Imaging.ImageOptions.GifOptions()
    gifOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.RasterImage = CType(Aspose.Imaging.Image.Create(gifOptions, 500, 500), Aspose.Imaging.RasterImage)
'Get the pixels of image by specifying the area as image boundary
Dim pixels As Aspose.Imaging.Color() = image.LoadPixels(image.Bounds)

'Loop over the Array and sets color of alrenative indexed pixel
Dim index As Integer = 0
        Do While index < pixels.Length
            If index Mod 2 = 0 Then
'Set the indexed pixel color to yellow
                pixels(index) = Aspose.Imaging.Color.Yellow
            Else
'Set the indexed pixel color to blue
                pixels(index) = Aspose.Imaging.Color.Blue
            End If
            index += 1
        Loop

'Apply the pixel changes to the image
        image.SavePixels(image.Bounds, pixels)

' save all changes.
        image.Save()
    End Using

'Write MemoryStream to File
    stream.WriteTo(New System.IO.FileStream("C:\temp\output.gif", System.IO.FileMode.CreateNew))
End Using

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.LoadPixelsInternal Method

Loads pixels (format specific method).

protected void LoadPixelsInternal(
Rectangle rectangle,
IPartialPixelLoader pixelLoader
);

Parameters

rectangle
The rectangle to load pixels from.
pixelLoader
The partial pixel loader. The inheritor should call corresponding methods on this interface when pixels are loaded.

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.LoadRawData Method

Loads raw data.

public void LoadRawData(
Rectangle rectangle,
RawDataSettings rawDataSettings,
IPartialRawDataLoader rawDataLoader
);

Parameters

rectangle
The rectangle to load raw data from.
rawDataSettings
The raw data settings to use for loaded data. Note if data is not in the format specified then data conversion will be performed.
rawDataLoader
The raw data loader.

Implements

IRasterImageRawDataLoader.LoadRawData

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.ReadScanLine Method

Reads the whole scan line by the specified scan line index.

public Color[] ReadScanLine(
int scanLineIndex
);

Parameters

scanLineIndex
Zero based index of the scan line.

Return Value

The scan line pixel color values array.

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.ReleaseManagedResources Method

Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.

protected override void ReleaseManagedResources();

See Also

RasterImage Class | Aspose.Imaging Namespace


Resize Method

Aspose.Imaging Documentation

RasterImage.Resize Method

Resizes the image.

Overload List

Inherited from Image.

public void Resize(int,int);

Resizes the image.

public override void Resize(int,int,ResizeType);

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.Resize Method (Int32, Int32, ResizeType)

Resizes the image.

public override void Resize(
int newWidth,
int newHeight,
ResizeType resizeType
);

Parameters

newWidth
The new width.
newHeight
The new height.
resizeType
The resize type.

See Also

RasterImage Class | Aspose.Imaging Namespace | RasterImage.Resize Overload List


RasterImage.SaveCMYKPixels Method

Saves the pixels.

public void SaveCMYKPixels(
Rectangle rectangle,
CMYKColor[] pixels
);

Parameters

rectangle
The rectangle to save pixels to.
pixels
The CMYK pixels array.

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.SavePixels Method

Saves the pixels.

public void SavePixels(
Rectangle rectangle,
Color[] pixels
);

Parameters

rectangle
The rectangle to save pixels to.
pixels
The pixels array.

Example

This example shows how to Loads Pixel information in an Array of Type Color, manipulates the array and set it back to the image. To perform these operations, this example creates a new Image file (in GIF format) uisng MemoryStream object.

[C#]

//Create an instance of MemoryStream
using (System.IO.MemoryStream stream = new System.IO.MemoryStream())
{
    //Create an instance of GifOptions and set its various properties including the Source property
    Aspose.Imaging.ImageOptions.GifOptions gifOptions = new Aspose.Imaging.ImageOptions.GifOptions();
    gifOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.RasterImage image = (Aspose.Imaging.RasterImage)Aspose.Imaging.Image.Create(gifOptions, 500, 500))
    {
        //Get the pixels of image by specifying the area as image boundary
        Aspose.Imaging.Color[] pixels = image.LoadPixels(image.Bounds);

        //Loop over the Array and sets color of alrenative indexed pixel
        for (int index = 0; index < pixels.Length; index++)
        {
            if (index % 2 == 0)
            {
                //Set the indexed pixel color to yellow
                pixels[index] = Aspose.Imaging.Color.Yellow;
            }
            else
            {
                //Set the indexed pixel color to blue
                pixels[index] = Aspose.Imaging.Color.Blue;
            }
        }

        //Apply the pixel changes to the image
        image.SavePixels(image.Bounds, pixels);

        // save all changes.
        image.Save();
    }

    //Write MemoryStream to File
    stream.WriteTo(new System.IO.FileStream(@"C:\temp\output.gif", System.IO.FileMode.CreateNew));
}
[Visual Basic]

'Create an instance of MemoryStream
Using stream As System.IO.MemoryStream = New System.IO.MemoryStream()
'Create an instance of GifOptions and set its various properties including the Source property
Dim gifOptions As Aspose.Imaging.ImageOptions.GifOptions = New Aspose.Imaging.ImageOptions.GifOptions()
    gifOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.RasterImage = CType(Aspose.Imaging.Image.Create(gifOptions, 500, 500), Aspose.Imaging.RasterImage)
'Get the pixels of image by specifying the area as image boundary
Dim pixels As Aspose.Imaging.Color() = image.LoadPixels(image.Bounds)

'Loop over the Array and sets color of alrenative indexed pixel
Dim index As Integer = 0
        Do While index < pixels.Length
            If index Mod 2 = 0 Then
'Set the indexed pixel color to yellow
                pixels(index) = Aspose.Imaging.Color.Yellow
            Else
'Set the indexed pixel color to blue
                pixels(index) = Aspose.Imaging.Color.Blue
            End If
            index += 1
        Loop

'Apply the pixel changes to the image
        image.SavePixels(image.Bounds, pixels)

' save all changes.
        image.Save()
    End Using

'Write MemoryStream to File
    stream.WriteTo(New System.IO.FileStream("C:\temp\output.gif", System.IO.FileMode.CreateNew))
End Using

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.SavePixelsInternal Method

Saves pixels (format specific method).

protected abstract void SavePixelsInternal(
Rectangle rectangle,
Color[] pixels
);

Parameters

rectangle
The rectangle to save pixels to.
pixels
The pixels array.

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.SaveRawData Method

Saves the raw data.

public void SaveRawData(
byte[] data,
int dataOffset,
Rectangle rectangle,
RawDataSettings rawDataSettings
);

Parameters

data
The raw data.
dataOffset
The starting raw data offset.
rectangle
The raw data rectangle.
rawDataSettings
The raw data settings the data is in.

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.SetPalette Method

Sets the image palette.

public override void SetPalette(
IColorPalette palette,
bool updateColors
);

Parameters

palette
The palette to set.
updateColors
if set to true colors will be updated according to the new palette; otherwise color indexes remain unchanged. Note that unchanged indexes may crash the image on loading if some indexes have no corresponding palette entries.

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.SetPixel Method

Sets an image pixel for the specified position.

public void SetPixel(
int x,
int y,
Color color
);

Parameters

x
The pixel x location.
y
The pixel y location.
color
The pixel color for the specified position.

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.SetResolution Method

Sets the resolution for this RasterImage.

public virtual void SetResolution(
double dpiX,
double dpiY
);

Parameters

dpiX
The horizontal resolution, in dots per inch, of the RasterImage.
dpiY
The vertical resolution, in dots per inch, of the RasterImage.

See Also

RasterImage Class | Aspose.Imaging Namespace


RasterImage.WriteScanLine Method

Writes the whole scan line to the specified scan line index.

public void WriteScanLine(
int scanLineIndex,
Color[] pixels
);

Parameters

scanLineIndex
Zero based index of the scan line.
pixels
The pixel colors array to write.

See Also

RasterImage Class | Aspose.Imaging Namespace


RawDataSettings Class

The raw data settings

For a list of all members of this type, see RawDataSettings Members.

System.Object
Aspose.Imaging.RawDataSettings

public class RawDataSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

RawDataSettings Members | Aspose.Imaging Namespace


RawDataSettings Members

RawDataSettings overview

Public Instance Constructors

RawDataSettings Constructor Initializes a new instance of the RawDataSettings class.

Public Instance Properties

ColorPalette | Gets or sets the color palette
CustomColorConverter | Gets or sets the custom color converter
DitheringMethod | Gets or sets the dithering method to use for raw data conversion
FallbackIndex | Gets or sets the fallback index to use when palette index is out of bounds
IndexedColorConverter | Gets or sets the indexed color converter
LineSize | Gets or sets the pixels line size in bytes for raw data processing
PixelDataFormat | Gets or sets the pixel data format

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RawDataSettings Class | Aspose.Imaging Namespace


RawDataSettings Constructor

Initializes a new instance of the RawDataSettings class.

public RawDataSettings();

See Also

RawDataSettings Class | Aspose.Imaging Namespace


RawDataSettings Properties

The properties of the RawDataSettings class are listed below. For a complete list of RawDataSettings class members, see the RawDataSettings Members topic.

Public Instance Properties

ColorPalette | Gets or sets the color palette
CustomColorConverter | Gets or sets the custom color converter
DitheringMethod | Gets or sets the dithering method to use for raw data conversion
FallbackIndex | Gets or sets the fallback index to use when palette index is out of bounds
IndexedColorConverter | Gets or sets the indexed color converter
LineSize | Gets or sets the pixels line size in bytes for raw data processing
PixelDataFormat | Gets or sets the pixel data format

See Also

RawDataSettings Class | Aspose.Imaging Namespace


ColorPalette Property

Aspose.Imaging Documentation

RawDataSettings.ColorPalette Property

Gets or sets the color palette

public IColorPalette ColorPalette {get; set;}

Property Value

The color palette

See Also

RawDataSettings Class | Aspose.Imaging Namespace


CustomColorConverter Property

Aspose.Imaging Documentation

RawDataSettings.CustomColorConverter Property

Gets or sets the custom color converter

public IColorConverter CustomColorConverter {get; set;}

Property Value

The custom color converter

See Also

RawDataSettings Class | Aspose.Imaging Namespace


DitheringMethod Property

Aspose.Imaging Documentation

RawDataSettings.DitheringMethod Property

Gets or sets the dithering method to use for raw data conversion

public DitheringMethods DitheringMethod {get; set;}

Property Value

The dithering method to use for raw data conversion

See Also

RawDataSettings Class | Aspose.Imaging Namespace


FallbackIndex Property

Aspose.Imaging Documentation

RawDataSettings.FallbackIndex Property

Gets or sets the fallback index to use when palette index is out of bounds

public int FallbackIndex {get; set;}

Property Value

The fallback index to use when palette index is out of bounds

See Also

RawDataSettings Class | Aspose.Imaging Namespace


IndexedColorConverter Property

Aspose.Imaging Documentation

RawDataSettings.IndexedColorConverter Property

Gets or sets the indexed color converter

public IIndexedColorConverter IndexedColorConverter {get; set;}

Property Value

The indexed color converter

See Also

RawDataSettings Class | Aspose.Imaging Namespace


LineSize Property

Aspose.Imaging Documentation

RawDataSettings.LineSize Property

Gets or sets the pixels line size in bytes for raw data processing

public int LineSize {get; set;}

Property Value

The pixels line size in bytes for raw data processing

See Also

RawDataSettings Class | Aspose.Imaging Namespace


PixelDataFormat Property

Aspose.Imaging Documentation

RawDataSettings.PixelDataFormat Property

Gets or sets the pixel data format

public PixelDataFormat PixelDataFormat {get; set;}

Property Value

The pixel data format

See Also

RawDataSettings Class | Aspose.Imaging Namespace


Rectangle Structure

Stores a set of four integers that represent the location and size of a rectangle.

For a list of all members of this type, see Rectangle Members.

System.Object
System.ValueType
Aspose.Imaging.Rectangle

public struct Rectangle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Rectangle Members | Aspose.Imaging Namespace


Rectangle Members

Rectangle overview

Public Static Properties

Empty Gets a new instance of the Rectangle structure that has X, Y, Width and Height values set to zero.

Public Static Methods

Ceiling | Converts the specified RectangleF structure to a Rectangle structure by rounding the RectangleF values to the next higher integer values.
FromLeftTopRightBottom | Creates a Rectangle structure with the specified edge locations.
FromPoints | Creates a new Rectangle from two points specified. Two verticales of the created Rectangle will be equal to the passed point1 and point2. These would be typically the opposite vertices.
Inflate | Overloaded. Creates and returns an inflated copy of the specified Rectangle structure. The copy is inflated by the specified amount. The original Rectangle structure remains unmodified.
Intersect | Overloaded. Returns a third Rectangle structure that represents the intersection of two other Rectangle structures. If there is no intersection, an empty Rectangle is returned.
Round | Converts the specified RectangleF to a Rectangle by rounding the RectangleF values to the nearest integer values.
Truncate | Converts the specified RectangleF to a Rectangle by truncating the RectangleF values.
Union | Gets a Rectangle structure that contains the union of two Rectangle structures.

Public Static Operators

Equality Operator | Tests whether two Rectangle structures have equal location and size.
Inequality Operator | Tests whether two Rectangle structures differ in location or size.

Public Instance Constructors

Rectangle Overloaded. Initializes a new instance of the Rectangle class.

Public Instance Properties

Bottom | Gets or sets the y-coordinate that is the sum of the Y and Height property values of this Rectangle structure.
Height | Gets or sets the height of this Rectangle structure.
IsEmpty | Gets a value indicating whether all numeric properties of this Rectangle have values of zero.
Left | Gets or sets the x-coordinate of the left edge of this Rectangle structure.
Location | Gets or sets the coordinates of the upper-left corner of this Rectangle structure.
Right | Gets or sets the x-coordinate that is the sum of X and Width property values of this Rectangle structure.
Size | Gets or sets the size of this Rectangle.
Top | Gets or sets the y-coordinate of the top edge of this Rectangle structure.
Width | Gets or sets the width of this Rectangle structure.
X | Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Y | Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.

Public Instance Methods

Contains | Overloaded. Determines if the specified point is contained within this Rectangle structure.
Equals | Tests whether obj is a Rectangle structure with the same location and size of this Rectangle structure.
GetHashCode | Returns the hash code for this Rectangle structure.
GetType (inherited from Object) | Gets the Type of the current instance.
Inflate | Overloaded. Inflates this Rectangle by the specified amount.
Intersect | Overloaded. Replaces this Rectangle with the intersection of itself and the specified Rectangle.
IntersectsWith | Determines if this rectangle intersects with rect.
Normalize | Normalizes the rectangle by making it's width and height positive, left less than right and top less than bottom.
Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
ToString | Converts the attributes of this Rectangle to a human-readable string.

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle Constructor

Initializes a new instance of the Rectangle structure with the specified location and size.

Overload List

Initializes a new instance of the Rectangle structure with the specified location and size.

public Rectangle(Point,Size);

Initializes a new instance of the Rectangle structure with the specified location and size.

public Rectangle(int,int,int,int);

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle Constructor (Int32, Int32, Int32, Int32)

Initializes a new instance of the Rectangle structure with the specified location and size.

public Rectangle(
int x,
int y,
int width,
int height
);

Parameters

x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.

See Also

Rectangle Class | Aspose.Imaging Namespace | Rectangle Constructor Overload List


Rectangle Constructor (Point, Size)

Initializes a new instance of the Rectangle structure with the specified location and size.

public Rectangle(
Point location,
Size size
);

Parameters

location
A Point that represents the upper-left corner of the rectangular region.
size
A Size that represents the width and height of the rectangular region.

See Also

Rectangle Class | Aspose.Imaging Namespace | Rectangle Constructor Overload List


Rectangle Properties

The properties of the Rectangle structure are listed below. For a complete list of Rectangle structure members, see the Rectangle Members topic.

Public Static Properties

Empty Gets a new instance of the Rectangle structure that has X, Y, Width and Height values set to zero.

Public Instance Properties

Bottom | Gets or sets the y-coordinate that is the sum of the Y and Height property values of this Rectangle structure.
Height | Gets or sets the height of this Rectangle structure.
IsEmpty | Gets a value indicating whether all numeric properties of this Rectangle have values of zero.
Left | Gets or sets the x-coordinate of the left edge of this Rectangle structure.
Location | Gets or sets the coordinates of the upper-left corner of this Rectangle structure.
Right | Gets or sets the x-coordinate that is the sum of X and Width property values of this Rectangle structure.
Size | Gets or sets the size of this Rectangle.
Top | Gets or sets the y-coordinate of the top edge of this Rectangle structure.
Width | Gets or sets the width of this Rectangle structure.
X | Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Y | Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.

See Also

Rectangle Class | Aspose.Imaging Namespace


Bottom Property

Aspose.Imaging Documentation

Rectangle.Bottom Property

Gets or sets the y-coordinate that is the sum of the Y and Height property values of this Rectangle structure.

public int Bottom {get; set;}

Property Value

The y-coordinate that is the sum of Y and Height of this Rectangle.

See Also

Rectangle Class | Aspose.Imaging Namespace


Empty Property

Aspose.Imaging Documentation

Rectangle.Empty Property

Gets a new instance of the Rectangle structure that has X, Y, Width and Height values set to zero.

public static Rectangle Empty {get;}

See Also

Rectangle Class | Aspose.Imaging Namespace


Height Property

Aspose.Imaging Documentation

Rectangle.Height Property

Gets or sets the height of this Rectangle structure.

public int Height {get; set;}

See Also

Rectangle Class | Aspose.Imaging Namespace


IsEmpty Property

Aspose.Imaging Documentation

Rectangle.IsEmpty Property

Gets a value indicating whether all numeric properties of this Rectangle have values of zero.

public bool IsEmpty {get;}

Property Value

This property returns true if the Width, Height, X, and Y properties of this Rectangle all have values of zero; otherwise, false.

See Also

Rectangle Class | Aspose.Imaging Namespace


Left Property

Aspose.Imaging Documentation

Rectangle.Left Property

Gets or sets the x-coordinate of the left edge of this Rectangle structure.

public int Left {get; set;}

Property Value

The x-coordinate of the left edge of this Rectangle structure.

See Also

Rectangle Class | Aspose.Imaging Namespace


Location Property

Aspose.Imaging Documentation

Rectangle.Location Property

Gets or sets the coordinates of the upper-left corner of this Rectangle structure.

public Point Location {get; set;}

Property Value

A Point that represents the upper-left corner of this Rectangle structure.

See Also

Rectangle Class | Aspose.Imaging Namespace


Right Property

Aspose.Imaging Documentation

Rectangle.Right Property

Gets or sets the x-coordinate that is the sum of X and Width property values of this Rectangle structure.

public int Right {get; set;}

Property Value

The x-coordinate that is the sum of X and Width of this Rectangle.

See Also

Rectangle Class | Aspose.Imaging Namespace


Size Property

Aspose.Imaging Documentation

Rectangle.Size Property

Gets or sets the size of this Rectangle.

public Size Size {get; set;}

Property Value

A Size that represents the width and height of this Rectangle structure.

See Also

Rectangle Class | Aspose.Imaging Namespace


Top Property

Aspose.Imaging Documentation

Rectangle.Top Property

Gets or sets the y-coordinate of the top edge of this Rectangle structure.

public int Top {get; set;}

Property Value

The y-coordinate of the top edge of this Rectangle structure.

See Also

Rectangle Class | Aspose.Imaging Namespace


Width Property

Aspose.Imaging Documentation

Rectangle.Width Property

Gets or sets the width of this Rectangle structure.

public int Width {get; set;}

See Also

Rectangle Class | Aspose.Imaging Namespace


X Property

Aspose.Imaging Documentation

Rectangle.X Property

Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.

public int X {get; set;}

Property Value

The x-coordinate of the upper-left corner of this Rectangle structure.

See Also

Rectangle Class | Aspose.Imaging Namespace


Y Property

Aspose.Imaging Documentation

Rectangle.Y Property

Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.

public int Y {get; set;}

Property Value

The y-coordinate of the upper-left corner of this Rectangle structure.

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle Methods

The methods of the Rectangle structure are listed below. For a complete list of Rectangle structure members, see the Rectangle Members topic.

Public Static Methods

Ceiling | Converts the specified RectangleF structure to a Rectangle structure by rounding the RectangleF values to the next higher integer values.
FromLeftTopRightBottom | Creates a Rectangle structure with the specified edge locations.
FromPoints | Creates a new Rectangle from two points specified. Two verticales of the created Rectangle will be equal to the passed point1 and point2. These would be typically the opposite vertices.
Inflate | Overloaded. Creates and returns an inflated copy of the specified Rectangle structure. The copy is inflated by the specified amount. The original Rectangle structure remains unmodified.
Intersect | Overloaded. Returns a third Rectangle structure that represents the intersection of two other Rectangle structures. If there is no intersection, an empty Rectangle is returned.
Round | Converts the specified RectangleF to a Rectangle by rounding the RectangleF values to the nearest integer values.
Truncate | Converts the specified RectangleF to a Rectangle by truncating the RectangleF values.
Union | Gets a Rectangle structure that contains the union of two Rectangle structures.

Public Instance Methods

Contains | Overloaded. Determines if the specified point is contained within this Rectangle structure.
Equals | Tests whether obj is a Rectangle structure with the same location and size of this Rectangle structure.
GetHashCode | Returns the hash code for this Rectangle structure.
GetType (inherited from Object) | Gets the Type of the current instance.
Inflate | Overloaded. Inflates this Rectangle by the specified amount.
Intersect | Overloaded. Replaces this Rectangle with the intersection of itself and the specified Rectangle.
IntersectsWith | Determines if this rectangle intersects with rect.
Normalize | Normalizes the rectangle by making it's width and height positive, left less than right and top less than bottom.
Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
ToString | Converts the attributes of this Rectangle to a human-readable string.

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle.Ceiling Method

Converts the specified RectangleF structure to a Rectangle structure by rounding the RectangleF values to the next higher integer values.

public static Rectangle Ceiling(
RectangleF value
);

Parameters

value
The RectangleF structure to be converted.

Return Value

Returns a Rectangle.

See Also

Rectangle Class | Aspose.Imaging Namespace


Contains Method

Aspose.Imaging Documentation

Rectangle.Contains Method

Determines if the specified point is contained within this Rectangle structure.

Overload List

Determines if the specified point is contained within this Rectangle structure.

public bool Contains(Point);

Determines if the rectangular region represented by rect is entirely contained within this Rectangle structure.

public bool Contains(Rectangle);

Determines if the specified point is contained within this Rectangle structure.

public bool Contains(int,int);

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle.Contains Method (Point)

Determines if the specified point is contained within this Rectangle structure.

public bool Contains(
Point point
);

Parameters

point
The Point to test.

Return Value

This method returns true if the point represented by point is contained within this Rectangle structure; otherwise false.

See Also

Rectangle Class | Aspose.Imaging Namespace | Rectangle.Contains Overload List


Rectangle.Contains Method (Rectangle)

Determines if the rectangular region represented by rect is entirely contained within this Rectangle structure.

public bool Contains(
Rectangle rect
);

Parameters

rect
The Rectangle to test.

Return Value

This method returns true if the rectangular region represented by rect is entirely contained within this Rectangle structure; otherwise false.

See Also

Rectangle Class | Aspose.Imaging Namespace | Rectangle.Contains Overload List


Rectangle.Contains Method (Int32, Int32)

Determines if the specified point is contained within this Rectangle structure.

public bool Contains(
int x,
int y
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.

Return Value

This method returns true if the point defined by x and y is contained within this Rectangle structure; otherwise false.

See Also

Rectangle Class | Aspose.Imaging Namespace | Rectangle.Contains Overload List


Rectangle.Equals Method

Tests whether obj is a Rectangle structure with the same location and size of this Rectangle structure.

public override bool Equals(
object obj
);

Parameters

obj
The Object to test.

Return Value

This method returns true if obj is a Rectangle structure and its X, Y, Width, and Height properties are equal to the corresponding properties of this Rectangle structure; otherwise, false.

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle.FromLeftTopRightBottom Method

Creates a Rectangle structure with the specified edge locations.

public static Rectangle FromLeftTopRightBottom(
int left,
int top,
int right,
int bottom
);

Parameters

left
The x-coordinate of the upper-left corner of this Rectangle structure.
top
The y-coordinate of the upper-left corner of this Rectangle structure.
right
The x-coordinate of the lower-right corner of this Rectangle structure.
bottom
The y-coordinate of the lower-right corner of this Rectangle structure.

Return Value

The new Rectangle that this method creates.

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle.FromPoints Method

Creates a new Rectangle from two points specified. Two verticales of the created Rectangle will be equal to the passed point1 and point2. These would be typically the opposite vertices.

public static Rectangle FromPoints(
Point point1,
Point point2
);

Parameters

point1
The first Point for the new rectangle.
point2
The second Point for the new rectangle.

Return Value

A newly created Rectangle.

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle.GetHashCode Method

Returns the hash code for this Rectangle structure.

public override int GetHashCode();

Return Value

An integer that represents the hash code for this rectangle.

See Also

Rectangle Class | Aspose.Imaging Namespace


Inflate Method

Aspose.Imaging Documentation

Rectangle.Inflate Method

Creates and returns an inflated copy of the specified Rectangle structure. The copy is inflated by the specified amount. The original Rectangle structure remains unmodified.

Overload List

Creates and returns an inflated copy of the specified Rectangle structure. The copy is inflated by the specified amount. The original Rectangle structure remains unmodified.

public static Rectangle Inflate(Rectangle,int,int);

Inflates this Rectangle by the specified amount.

public void Inflate(Size);

Inflates this Rectangle by the specified amount.

public void Inflate(int,int);

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle.Inflate Method (Rectangle, Int32, Int32)

Creates and returns an inflated copy of the specified Rectangle structure. The copy is inflated by the specified amount. The original Rectangle structure remains unmodified.

public static Rectangle Inflate(
Rectangle rect,
int x,
int y
);

Parameters

rect
The Rectangle with which to start. This rectangle is not modified.
x
The amount to inflate this Rectangle horizontally.
y
The amount to inflate this Rectangle vertically.

Return Value

The inflated Rectangle.

See Also

Rectangle Class | Aspose.Imaging Namespace | Rectangle.Inflate Overload List


Rectangle.Inflate Method (Size)

Inflates this Rectangle by the specified amount.

public void Inflate(
Size size
);

Parameters

size
The amount to inflate this rectangle.

See Also

Rectangle Class | Aspose.Imaging Namespace | Rectangle.Inflate Overload List


Rectangle.Inflate Method (Int32, Int32)

Inflates this Rectangle by the specified amount.

public void Inflate(
int width,
int height
);

Parameters

width
The amount to inflate this Rectangle horizontally.
height
The amount to inflate this Rectangle vertically.

See Also

Rectangle Class | Aspose.Imaging Namespace | Rectangle.Inflate Overload List


Intersect Method

Aspose.Imaging Documentation

Rectangle.Intersect Method

Replaces this Rectangle with the intersection of itself and the specified Rectangle.

Overload List

Replaces this Rectangle with the intersection of itself and the specified Rectangle.

public void Intersect(Rectangle);

Returns a third Rectangle structure that represents the intersection of two other Rectangle structures. If there is no intersection, an empty Rectangle is returned.

public static Rectangle Intersect(Rectangle,Rectangle);

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle.Intersect Method (Rectangle)

Replaces this Rectangle with the intersection of itself and the specified Rectangle.

public void Intersect(
Rectangle rect
);

Parameters

rect
The Rectangle with which to intersect.

See Also

Rectangle Class | Aspose.Imaging Namespace | Rectangle.Intersect Overload List


Rectangle.Intersect Method (Rectangle, Rectangle)

Returns a third Rectangle structure that represents the intersection of two other Rectangle structures. If there is no intersection, an empty Rectangle is returned.

public static Rectangle Intersect(
Rectangle a,
Rectangle b
);

Parameters

a
A first rectangle to intersect.
b
A second rectangle to intersect.

Return Value

A Rectangle that represents the intersection of a and b.

See Also

Rectangle Class | Aspose.Imaging Namespace | Rectangle.Intersect Overload List


Rectangle.IntersectsWith Method

Determines if this rectangle intersects with rect.

public bool IntersectsWith(
Rectangle rect
);

Parameters

rect
The rectangle to test.

Return Value

This method returns true if there is any intersection, otherwise false.

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle.Normalize Method

Normalizes the rectangle by making it's width and height positive, left less than right and top less than bottom.

public void Normalize();

See Also

Rectangle Class | Aspose.Imaging Namespace


Offset Method

Aspose.Imaging Documentation

Rectangle.Offset Method

Adjusts the location of this rectangle by the specified amount.

Overload List

Adjusts the location of this rectangle by the specified amount.

public void Offset(Point);

Adjusts the location of this rectangle by the specified amount.

public void Offset(int,int);

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle.Offset Method (Point)

Adjusts the location of this rectangle by the specified amount.

public void Offset(
Point pos
);

Parameters

pos
Amount to offset the location.

See Also

Rectangle Class | Aspose.Imaging Namespace | Rectangle.Offset Overload List


Rectangle.Offset Method (Int32, Int32)

Adjusts the location of this rectangle by the specified amount.

public void Offset(
int x,
int y
);

Parameters

x
The horizontal offset.
y
The vertical offset.

See Also

Rectangle Class | Aspose.Imaging Namespace | Rectangle.Offset Overload List


Rectangle.Round Method

Converts the specified RectangleF to a Rectangle by rounding the RectangleF values to the nearest integer values.

public static Rectangle Round(
RectangleF value
);

Parameters

value
The RectangleF to be converted.

Return Value

A new Rectangle.

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle.ToString Method

Converts the attributes of this Rectangle to a human-readable string.

public override string ToString();

Return Value

A string that contains the position, width, and height of this Rectangle structure.

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle.Truncate Method

Converts the specified RectangleF to a Rectangle by truncating the RectangleF values.

public static Rectangle Truncate(
RectangleF value
);

Parameters

value
The RectangleF to be converted.

Return Value

A new Rectangle.

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle.Union Method

Gets a Rectangle structure that contains the union of two Rectangle structures.

public static Rectangle Union(
Rectangle a,
Rectangle b
);

Parameters

a
A first rectangle to union.
b
A second rectangle to union.

Return Value

A Rectangle structure that bounds the union of the two Rectangle structures.

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle Operators

The operators of the Rectangle structure are listed below. For a complete list of Rectangle structure members, see the Rectangle Members topic.

Public Static Operators

Equality Operator | Tests whether two Rectangle structures have equal location and size.
Inequality Operator | Tests whether two Rectangle structures differ in location or size.

See Also

Rectangle Class | Rectangle Members | Aspose.Imaging Namespace


Rectangle Equality Operator

Tests whether two Rectangle structures have equal location and size.

public static bool operator ==(
Rectangle left,
Rectangle right
);

Parameters

left
The Rectangle structure that is to the left of the equality operator.
right
The Rectangle structure that is to the right of the equality operator.

Return Value

This operator returns true if the two Rectangle structures have equal X, Y, Width, and Height properties.

See Also

Rectangle Class | Aspose.Imaging Namespace


Rectangle Inequality Operator

Tests whether two Rectangle structures differ in location or size.

public static bool operator !=(
Rectangle left,
Rectangle right
);

Parameters

left
The Rectangle structure that is to the left of the inequality operator.
right
The Rectangle structure that is to the right of the inequality operator.

Return Value

This operator returns true if any of the X, Y, Width or Height properties of the two Rectangle structures are unequal; otherwise false.

See Also

Rectangle Class | Aspose.Imaging Namespace


RectangleF Structure

Stores a set of four floating-point numbers that represent the location and size of a rectangle.

For a list of all members of this type, see RectangleF Members.

System.Object
System.ValueType
Aspose.Imaging.RectangleF

public struct RectangleF

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

RectangleF Members | Aspose.Imaging Namespace


RectangleF Members

RectangleF overview

Public Static Properties

Empty Gets a new instance of the RectangleF structure that has X, Y, Width and Height values set to zero.

Public Static Methods

FromLeftTopRightBottom | Creates a RectangleF structure with upper-left corner and lower-right corner at the specified locations.
FromPoints | Creates a new Rectangle from two points specified. Two verticles of the created Rectangle will be equal to the passed point1 and point2. These would be typically the opposite vertices.
Inflate | Overloaded. Creates and returns an inflated copy of the specified RectangleF structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.
Intersect | Overloaded. Returns a RectangleF structure that represents the intersection of two rectangles. If there is no intersection, and empty RectangleF is returned.
Union | Creates the smallest possible third rectangle that can contain both of two rectangles that form a union.

Public Static Operators and Type Conversions

Equality Operator | Tests whether two RectangleF structures have equal location and size.
Inequality Operator | Tests whether two RectangleF structures differ in location or size.
Implicit Rectangle to RectangleF Conversion | Converts the specified Rectangle structure to a RectangleF structure.

Public Instance Constructors

RectangleF Overloaded. Initializes a new instance of the RectangleF class.

Public Instance Properties

Bottom | Gets or sets the y-coordinate that is the sum of Y and Height of this RectangleF structure.
Height | Gets or sets the height of this RectangleF structure.
IsEmpty | Gets a value indicating whether the Width or Height property of this RectangleF has a value of zero.
Left | Gets or sets the x-coordinate of the left edge of this RectangleF structure.
Location | Gets or sets the coordinates of the upper-left corner of this RectangleF structure.
Right | Gets or sets the x-coordinate that is the sum of X and Width of this RectangleF structure.
Size | Gets or sets the size of this RectangleF.
Top | Gets or sets the y-coordinate of the top edge of this RectangleF structure.
Width | Gets or sets the width of this RectangleF structure.
X | Gets or sets the x-coordinate of the upper-left corner of this RectangleF structure.
Y | Gets or sets the y-coordinate of the upper-left corner of this RectangleF structure.

Public Instance Methods

Contains | Overloaded. Determines if the specified point is contained within this RectangleF structure.
Equals | Tests whether obj is a RectangleF with the same location and size of this RectangleF.
GetHashCode | Gets the hash code for this RectangleF structure.
GetType (inherited from Object) | Gets the Type of the current instance.
Inflate | Overloaded. Inflates this RectangleF structure by the specified amount.
Intersect | Overloaded. Replaces this RectangleF structure with the intersection of itself and the specified RectangleF structure.
IntersectsWith | Determines if this rectangle intersects with rect.
Normalize | Normalizes the rectangle by making it's width and height positive, left less than right and top less than bottom.
Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
ToString | Converts the attributes of this RectangleF to a human-readable string.

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF Constructor

Initializes a new instance of the RectangleF structure with the specified location and size.

Overload List

Initializes a new instance of the RectangleF structure with the specified location and size.

public RectangleF(PointF,SizeF);

Initializes a new instance of the RectangleF structure with the specified location and size.

public RectangleF(float,float,float,float);

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF Constructor (Single, Single, Single, Single)

Initializes a new instance of the RectangleF structure with the specified location and size.

public RectangleF(
float x,
float y,
float width,
float height
);

Parameters

x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.

See Also

RectangleF Class | Aspose.Imaging Namespace | RectangleF Constructor Overload List


RectangleF Constructor (PointF, SizeF)

Initializes a new instance of the RectangleF structure with the specified location and size.

public RectangleF(
PointF location,
SizeF size
);

Parameters

location
A PointF that represents the upper-left corner of the rectangular region.
size
A SizeF that represents the width and height of the rectangular region.

See Also

RectangleF Class | Aspose.Imaging Namespace | RectangleF Constructor Overload List


RectangleF Properties

The properties of the RectangleF structure are listed below. For a complete list of RectangleF structure members, see the RectangleF Members topic.

Public Static Properties

Empty Gets a new instance of the RectangleF structure that has X, Y, Width and Height values set to zero.

Public Instance Properties

Bottom | Gets or sets the y-coordinate that is the sum of Y and Height of this RectangleF structure.
Height | Gets or sets the height of this RectangleF structure.
IsEmpty | Gets a value indicating whether the Width or Height property of this RectangleF has a value of zero.
Left | Gets or sets the x-coordinate of the left edge of this RectangleF structure.
Location | Gets or sets the coordinates of the upper-left corner of this RectangleF structure.
Right | Gets or sets the x-coordinate that is the sum of X and Width of this RectangleF structure.
Size | Gets or sets the size of this RectangleF.
Top | Gets or sets the y-coordinate of the top edge of this RectangleF structure.
Width | Gets or sets the width of this RectangleF structure.
X | Gets or sets the x-coordinate of the upper-left corner of this RectangleF structure.
Y | Gets or sets the y-coordinate of the upper-left corner of this RectangleF structure.

See Also

RectangleF Class | Aspose.Imaging Namespace


Bottom Property

Aspose.Imaging Documentation

RectangleF.Bottom Property

Gets or sets the y-coordinate that is the sum of Y and Height of this RectangleF structure.

public float Bottom {get; set;}

See Also

RectangleF Class | Aspose.Imaging Namespace


Empty Property

Aspose.Imaging Documentation

RectangleF.Empty Property

Gets a new instance of the RectangleF structure that has X, Y, Width and Height values set to zero.

public static RectangleF Empty {get;}

See Also

RectangleF Class | Aspose.Imaging Namespace


Height Property

Aspose.Imaging Documentation

RectangleF.Height Property

Gets or sets the height of this RectangleF structure.

public float Height {get; set;}

See Also

RectangleF Class | Aspose.Imaging Namespace


IsEmpty Property

Aspose.Imaging Documentation

RectangleF.IsEmpty Property

Gets a value indicating whether the Width or Height property of this RectangleF has a value of zero.

public bool IsEmpty {get;}

See Also

RectangleF Class | Aspose.Imaging Namespace


Left Property

Aspose.Imaging Documentation

RectangleF.Left Property

Gets or sets the x-coordinate of the left edge of this RectangleF structure.

public float Left {get; set;}

See Also

RectangleF Class | Aspose.Imaging Namespace


Location Property

Aspose.Imaging Documentation

RectangleF.Location Property

Gets or sets the coordinates of the upper-left corner of this RectangleF structure.

public PointF Location {get; set;}

See Also

RectangleF Class | Aspose.Imaging Namespace


Right Property

Aspose.Imaging Documentation

RectangleF.Right Property

Gets or sets the x-coordinate that is the sum of X and Width of this RectangleF structure.

public float Right {get; set;}

See Also

RectangleF Class | Aspose.Imaging Namespace


Size Property

Aspose.Imaging Documentation

RectangleF.Size Property

Gets or sets the size of this RectangleF.

public SizeF Size {get; set;}

See Also

RectangleF Class | Aspose.Imaging Namespace


Top Property

Aspose.Imaging Documentation

RectangleF.Top Property

Gets or sets the y-coordinate of the top edge of this RectangleF structure.

public float Top {get; set;}

See Also

RectangleF Class | Aspose.Imaging Namespace


Width Property

Aspose.Imaging Documentation

RectangleF.Width Property

Gets or sets the width of this RectangleF structure.

public float Width {get; set;}

See Also

RectangleF Class | Aspose.Imaging Namespace


X Property

Aspose.Imaging Documentation

RectangleF.X Property

Gets or sets the x-coordinate of the upper-left corner of this RectangleF structure.

public float X {get; set;}

See Also

RectangleF Class | Aspose.Imaging Namespace


Y Property

Aspose.Imaging Documentation

RectangleF.Y Property

Gets or sets the y-coordinate of the upper-left corner of this RectangleF structure.

public float Y {get; set;}

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF Methods

The methods of the RectangleF structure are listed below. For a complete list of RectangleF structure members, see the RectangleF Members topic.

Public Static Methods

FromLeftTopRightBottom | Creates a RectangleF structure with upper-left corner and lower-right corner at the specified locations.
FromPoints | Creates a new Rectangle from two points specified. Two verticles of the created Rectangle will be equal to the passed point1 and point2. These would be typically the opposite vertices.
Inflate | Overloaded. Creates and returns an inflated copy of the specified RectangleF structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.
Intersect | Overloaded. Returns a RectangleF structure that represents the intersection of two rectangles. If there is no intersection, and empty RectangleF is returned.
Union | Creates the smallest possible third rectangle that can contain both of two rectangles that form a union.

Public Instance Methods

Contains | Overloaded. Determines if the specified point is contained within this RectangleF structure.
Equals | Tests whether obj is a RectangleF with the same location and size of this RectangleF.
GetHashCode | Gets the hash code for this RectangleF structure.
GetType (inherited from Object) | Gets the Type of the current instance.
Inflate | Overloaded. Inflates this RectangleF structure by the specified amount.
Intersect | Overloaded. Replaces this RectangleF structure with the intersection of itself and the specified RectangleF structure.
IntersectsWith | Determines if this rectangle intersects with rect.
Normalize | Normalizes the rectangle by making it's width and height positive, left less than right and top less than bottom.
Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
ToString | Converts the attributes of this RectangleF to a human-readable string.

See Also

RectangleF Class | Aspose.Imaging Namespace


Contains Method

Aspose.Imaging Documentation

RectangleF.Contains Method

Determines if the specified point is contained within this RectangleF structure.

Overload List

Determines if the specified point is contained within this RectangleF structure.

public bool Contains(PointF);

Determines if the rectangular region represented by rect is entirely contained within this RectangleF structure.

public bool Contains(RectangleF);

Determines if the specified point is contained within this RectangleF structure.

public bool Contains(float,float);

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF.Contains Method (PointF)

Determines if the specified point is contained within this RectangleF structure.

public bool Contains(
PointF point
);

Parameters

point
The PointF to test.

Return Value

This method returns true if the point represented by the point parameter is contained within this RectangleF structure; otherwise false.

See Also

RectangleF Class | Aspose.Imaging Namespace | RectangleF.Contains Overload List


RectangleF.Contains Method (RectangleF)

Determines if the rectangular region represented by rect is entirely contained within this RectangleF structure.

public bool Contains(
RectangleF rect
);

Parameters

rect
The RectangleF to test.

Return Value

This method returns true if the rectangular region represented by rect is entirely contained within the rectangular region represented by this RectangleF; otherwise false.

See Also

RectangleF Class | Aspose.Imaging Namespace | RectangleF.Contains Overload List


RectangleF.Contains Method (Single, Single)

Determines if the specified point is contained within this RectangleF structure.

public bool Contains(
float x,
float y
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.

Return Value

This method returns true if the point defined by x and y is contained within this RectangleF structure; otherwise false.

See Also

RectangleF Class | Aspose.Imaging Namespace | RectangleF.Contains Overload List


RectangleF.Equals Method

Tests whether obj is a RectangleF with the same location and size of this RectangleF.

public override bool Equals(
object obj
);

Parameters

obj
The Object to test.

Return Value

This method returns true if obj is a RectangleF and its X, Y, Width, and Height properties are equal to the corresponding properties of this RectangleF; otherwise, false.

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF.FromLeftTopRightBottom Method

Creates a RectangleF structure with upper-left corner and lower-right corner at the specified locations.

public static RectangleF FromLeftTopRightBottom(
float left,
float top,
float right,
float bottom
);

Parameters

left
The x-coordinate of the upper-left corner of the rectangular region.
top
The y-coordinate of the upper-left corner of the rectangular region.
right
The x-coordinate of the lower-right corner of the rectangular region.
bottom
The y-coordinate of the lower-right corner of the rectangular region.

Return Value

The new RectangleF that this method creates.

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF.FromPoints Method

Creates a new Rectangle from two points specified. Two verticles of the created Rectangle will be equal to the passed point1 and point2. These would be typically the opposite vertices.

public static RectangleF FromPoints(
PointF point1,
PointF point2
);

Parameters

point1
The first Point for the new rectangle.
point2
The second Point for the new rectangle.

Return Value

A newly created Rectangle.

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF.GetHashCode Method

Gets the hash code for this RectangleF structure.

public override int GetHashCode();

Return Value

The hash code for this RectangleF.

See Also

RectangleF Class | Aspose.Imaging Namespace


Inflate Method

Aspose.Imaging Documentation

RectangleF.Inflate Method

Creates and returns an inflated copy of the specified RectangleF structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.

Overload List

Creates and returns an inflated copy of the specified RectangleF structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.

public static RectangleF Inflate(RectangleF,float,float);

Inflates this RectangleF by the specified amount.

public void Inflate(SizeF);

Inflates this RectangleF structure by the specified amount.

public void Inflate(float,float);

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF.Inflate Method (RectangleF, Single, Single)

Creates and returns an inflated copy of the specified RectangleF structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.

public static RectangleF Inflate(
RectangleF rect,
float x,
float y
);

Parameters

rect
The RectangleF to be copied. This rectangle is not modified.
x
The amount to inflate the copy of the rectangle horizontally.
y
The amount to inflate the copy of the rectangle vertically.

Return Value

The inflated RectangleF.

See Also

RectangleF Class | Aspose.Imaging Namespace | RectangleF.Inflate Overload List


RectangleF.Inflate Method (SizeF)

Inflates this RectangleF by the specified amount.

public void Inflate(
SizeF size
);

Parameters

size
The amount to inflate this rectangle.

See Also

RectangleF Class | Aspose.Imaging Namespace | RectangleF.Inflate Overload List


RectangleF.Inflate Method (Single, Single)

Inflates this RectangleF structure by the specified amount.

public void Inflate(
float x,
float y
);

Parameters

x
The amount to inflate this RectangleF structure horizontally.
y
The amount to inflate this RectangleF structure vertically.

See Also

RectangleF Class | Aspose.Imaging Namespace | RectangleF.Inflate Overload List


Intersect Method

Aspose.Imaging Documentation

RectangleF.Intersect Method

Replaces this RectangleF structure with the intersection of itself and the specified RectangleF structure.

Overload List

Replaces this RectangleF structure with the intersection of itself and the specified RectangleF structure.

public void Intersect(RectangleF);

Returns a RectangleF structure that represents the intersection of two rectangles. If there is no intersection, and empty RectangleF is returned.

public static RectangleF Intersect(RectangleF,RectangleF);

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF.Intersect Method (RectangleF)

Replaces this RectangleF structure with the intersection of itself and the specified RectangleF structure.

public void Intersect(
RectangleF rect
);

Parameters

rect
The rectangle to intersect.

See Also

RectangleF Class | Aspose.Imaging Namespace | RectangleF.Intersect Overload List


RectangleF.Intersect Method (RectangleF, RectangleF)

Returns a RectangleF structure that represents the intersection of two rectangles. If there is no intersection, and empty RectangleF is returned.

public static RectangleF Intersect(
RectangleF a,
RectangleF b
);

Parameters

a
A first rectangle to intersect.
b
A second rectangle to intersect.

Return Value

A third RectangleF structure the size of which represents the overlapped area of the two specified rectangles.

See Also

RectangleF Class | Aspose.Imaging Namespace | RectangleF.Intersect Overload List


RectangleF.IntersectsWith Method

Determines if this rectangle intersects with rect.

public bool IntersectsWith(
RectangleF rect
);

Parameters

rect
The rectangle to test.

Return Value

This method returns true if there is any intersection.

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF.Normalize Method

Normalizes the rectangle by making it's width and height positive, left less than right and top less than bottom.

public void Normalize();

See Also

RectangleF Class | Aspose.Imaging Namespace


Offset Method

Aspose.Imaging Documentation

RectangleF.Offset Method

Adjusts the location of this rectangle by the specified amount.

Overload List

Adjusts the location of this rectangle by the specified amount.

public void Offset(PointF);

Adjusts the location of this rectangle by the specified amount.

public void Offset(float,float);

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF.Offset Method (PointF)

Adjusts the location of this rectangle by the specified amount.

public void Offset(
PointF pos
);

Parameters

pos
The amount to offset the location.

See Also

RectangleF Class | Aspose.Imaging Namespace | RectangleF.Offset Overload List


RectangleF.Offset Method (Single, Single)

Adjusts the location of this rectangle by the specified amount.

public void Offset(
float x,
float y
);

Parameters

x
The amount to offset the location horizontally.
y
The amount to offset the location vertically.

See Also

RectangleF Class | Aspose.Imaging Namespace | RectangleF.Offset Overload List


RectangleF.ToString Method

Converts the attributes of this RectangleF to a human-readable string.

public override string ToString();

Return Value

A string that contains the position, width, and height of this RectangleF structure.

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF.Union Method

Creates the smallest possible third rectangle that can contain both of two rectangles that form a union.

public static RectangleF Union(
RectangleF a,
RectangleF b
);

Parameters

a
A first rectangle to union.
b
A second rectangle to union.

Return Value

A third RectangleF structure that contains both of the two rectangles that form the union.

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF Operators and Type Conversions

The operators and type conversions of the RectangleF structure are listed below. For a complete list of RectangleF structure members, see the RectangleF Members topic.

Public Static Operators and Type Conversions

Equality Operator | Tests whether two RectangleF structures have equal location and size.
Inequality Operator | Tests whether two RectangleF structures differ in location or size.
Implicit Rectangle to RectangleF Conversion | Converts the specified Rectangle structure to a RectangleF structure.

See Also

RectangleF Class | RectangleF Members | Aspose.Imaging Namespace


RectangleF Equality Operator

Tests whether two RectangleF structures have equal location and size.

public static bool operator ==(
RectangleF left,
RectangleF right
);

Parameters

left
The RectangleF structure that is to the left of the equality operator.
right
The RectangleF structure that is to the right of the equality operator.

Return Value

This operator returns true if the two specified RectangleF structures have equal X, Y, Width, and Height properties.

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF Inequality Operator

Tests whether two RectangleF structures differ in location or size.

public static bool operator !=(
RectangleF left,
RectangleF right
);

Parameters

left
The RectangleF structure that is to the left of the inequality operator.
right
The RectangleF structure that is to the right of the inequality operator.

Return Value

This operator returns true if any of the X , Y, Width, or Height properties of the two RectangleF structures are unequal; otherwise false.

See Also

RectangleF Class | Aspose.Imaging Namespace


RectangleF Implicit Rectangle to RectangleF Conversion

Converts the specified Rectangle structure to a RectangleF structure.

public static implicit operator RectangleF(
Rectangle rect
);

Parameters

rect
The Rectangle structure to convert.

Return Value

The RectangleF structure that is converted from the specified Rectangle structure.

See Also

RectangleF Class | Aspose.Imaging Namespace


Region Class

Describes the interior of a graphics shape composed of rectangles and paths. This class cannot be inherited.

For a list of all members of this type, see Region Members.

System.Object
Aspose.Imaging.Region

public sealed class Region

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Region Members | Aspose.Imaging Namespace


Region Members

Region overview

Public Instance Constructors

Region Overloaded. Initializes a new instance of the Region class.

Public Instance Methods

Complement | Overloaded. Updates this Region to contain the portion of the specified RectangleF structure that does not intersect with this Region.
DeepClone | Creates an exact deep copy of this Region.
Equals | Overloaded. Tests whether the specified Region is identical to this Region on the specified drawing surface.
Equals (inherited from Object) | Overloaded. Determines whether the specified Object is equal to the current Object.
Exclude | Overloaded. Updates this Region to contain only the portion of its interior that does not intersect with the specified RectangleF structure.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Intersect | Overloaded. Updates this Region to the intersection of itself with the specified RectangleF structure.
IsEmpty | Tests whether this Region has an empty interior on the specified drawing surface.
IsInfinite | Tests whether this Region has an infinite interior on the specified drawing surface.
IsVisible | Overloaded. Tests whether the specified point is contained within this Region.
MakeEmpty | Initializes this Region to an empty interior.
MakeInfinite | Initializes this Region object to an infinite interior.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Transforms this Region by the specified Matrix.
Translate | Overloaded. Offsets the coordinates of this Region by the specified amount.
Union | Overloaded. Updates this Region to the union of itself and the specified RectangleF structure.
Xor | Overloaded. Updates this Region to the union minus the intersection of itself with the specified RectangleF structure.

See Also

Region Class | Aspose.Imaging Namespace


Region Constructor

Initializes a new Region.

Overload List

Initializes a new Region.

public Region();

Initializes a new Region with the specified GraphicsPath.

public Region(GraphicsPath);

Initializes a new Region from the specified Rectangle structure.

public Region(Rectangle);

Initializes a new Region from the specified RectangleF structure.

public Region(RectangleF);

See Also

Region Class | Aspose.Imaging Namespace


Region Constructor ()

Initializes a new Region.

public Region();

See Also

Region Class | Aspose.Imaging Namespace | Region Constructor Overload List


Region Constructor (RectangleF)

Initializes a new Region from the specified RectangleF structure.

public Region(
RectangleF rect
);

Parameters

rect
A RectangleF structure that defines the interior of the new Region.

See Also

Region Class | Aspose.Imaging Namespace | Region Constructor Overload List


Region Constructor (Rectangle)

Initializes a new Region from the specified Rectangle structure.

public Region(
Rectangle rect
);

Parameters

rect
A Rectangle structure that defines the interior of the new Region.

See Also

Region Class | Aspose.Imaging Namespace | Region Constructor Overload List


Region Constructor (GraphicsPath)

Initializes a new Region with the specified GraphicsPath.

public Region(
GraphicsPath path
);

Parameters

path
A GraphicsPath that defines the new Region.

Exceptions

Exception Type | Condition
ArgumentNullException | path is null.

See Also

Region Class | Aspose.Imaging Namespace | Region Constructor Overload List


Region Methods

The methods of the Region class are listed below. For a complete list of Region class members, see the Region Members topic.

Public Instance Methods

Complement | Overloaded. Updates this Region to contain the portion of the specified RectangleF structure that does not intersect with this Region.
DeepClone | Creates an exact deep copy of this Region.
Equals | Overloaded. Tests whether the specified Region is identical to this Region on the specified drawing surface.
Equals (inherited from Object) | Overloaded. Determines whether the specified Object is equal to the current Object.
Exclude | Overloaded. Updates this Region to contain only the portion of its interior that does not intersect with the specified RectangleF structure.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Intersect | Overloaded. Updates this Region to the intersection of itself with the specified RectangleF structure.
IsEmpty | Tests whether this Region has an empty interior on the specified drawing surface.
IsInfinite | Tests whether this Region has an infinite interior on the specified drawing surface.
IsVisible | Overloaded. Tests whether the specified point is contained within this Region.
MakeEmpty | Initializes this Region to an empty interior.
MakeInfinite | Initializes this Region object to an infinite interior.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Transforms this Region by the specified Matrix.
Translate | Overloaded. Offsets the coordinates of this Region by the specified amount.
Union | Overloaded. Updates this Region to the union of itself and the specified RectangleF structure.
Xor | Overloaded. Updates this Region to the union minus the intersection of itself with the specified RectangleF structure.

See Also

Region Class | Aspose.Imaging Namespace


Complement Method

Aspose.Imaging Documentation

Region.Complement Method

Updates this Region to contain the portion of the specified GraphicsPath that does not intersect with this Region.

Overload List

Updates this Region to contain the portion of the specified GraphicsPath that does not intersect with this Region.

public void Complement(GraphicsPath);

Updates this Region to contain the portion of the specified Rectangle structure that does not intersect with this Region.

public void Complement(Rectangle);

Updates this Region to contain the portion of the specified RectangleF structure that does not intersect with this Region.

public void Complement(RectangleF);

Updates this Region to contain the portion of the specified Region that does not intersect with this Region.

public void Complement(Region);

See Also

Region Class | Aspose.Imaging Namespace


Region.Complement Method (GraphicsPath)

Updates this Region to contain the portion of the specified GraphicsPath that does not intersect with this Region.

public void Complement(
GraphicsPath path
);

Parameters

path
The GraphicsPath to complement this Region.

Exceptions

Exception Type | Condition
ArgumentNullException | path isnull.

See Also

Region Class | Aspose.Imaging Namespace | Region.Complement Overload List


Region.Complement Method (Rectangle)

Updates this Region to contain the portion of the specified Rectangle structure that does not intersect with this Region.

public void Complement(
Rectangle rect
);

Parameters

rect
The Rectangle structure to complement this Region.

See Also

Region Class | Aspose.Imaging Namespace | Region.Complement Overload List


Region.Complement Method (RectangleF)

Updates this Region to contain the portion of the specified RectangleF structure that does not intersect with this Region.

public void Complement(
RectangleF rect
);

Parameters

rect
The RectangleF structure to complement this Region.

See Also

Region Class | Aspose.Imaging Namespace | Region.Complement Overload List


Region.Complement Method (Region)

Updates this Region to contain the portion of the specified Region that does not intersect with this Region.

public void Complement(
Region region
);

Parameters

region
The Region object to complement this Region object.

Exceptions

Exception Type | Condition
ArgumentNullException | region isnull.

See Also

Region Class | Aspose.Imaging Namespace | Region.Complement Overload List


Region.DeepClone Method

Creates an exact deep copy of this Region.

public Region DeepClone();

Return Value

The Region that this method creates.

See Also

Region Class | Aspose.Imaging Namespace


Equals Method

Aspose.Imaging Documentation

Region.Equals Method

Tests whether the specified Region is identical to this Region on the specified drawing surface.

Overload List

Tests whether the specified Region is identical to this Region on the specified drawing surface.

public bool Equals(Region,Graphics);

Inherited from Object.

public virtual bool Equals(object);

See Also

Region Class | Aspose.Imaging Namespace


Region.Equals Method (Region, Graphics)

Tests whether the specified Region is identical to this Region on the specified drawing surface.

public bool Equals(
Region region,
Graphics g
);

Parameters

region
The Region to test.
g
A Graphics that represents a drawing surface.

Return Value

True if the interior of region is identical to the interior of this region when the transformation associated with the g parameter is applied; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | gorregion is null.

See Also

Region Class | Aspose.Imaging Namespace | Region.Equals Overload List


Exclude Method

Aspose.Imaging Documentation

Region.Exclude Method

Updates this Region to contain only the portion of its interior that does not intersect with the specified GraphicsPath.

Overload List

Updates this Region to contain only the portion of its interior that does not intersect with the specified GraphicsPath.

public void Exclude(GraphicsPath);

Updates this Region to contain only the portion of its interior that does not intersect with the specified Rectangle structure.

public void Exclude(Rectangle);

Updates this Region to contain only the portion of its interior that does not intersect with the specified RectangleF structure.

public void Exclude(RectangleF);

Updates this Region to contain only the portion of its interior that does not intersect with the specified Region.

public void Exclude(Region);

See Also

Region Class | Aspose.Imaging Namespace


Region.Exclude Method (GraphicsPath)

Updates this Region to contain only the portion of its interior that does not intersect with the specified GraphicsPath.

public void Exclude(
GraphicsPath path
);

Parameters

path
The GraphicsPath to exclude from this Region.

Exceptions

Exception Type | Condition
ArgumentNullException | path is null.

See Also

Region Class | Aspose.Imaging Namespace | Region.Exclude Overload List


Region.Exclude Method (Rectangle)

Updates this Region to contain only the portion of its interior that does not intersect with the specified Rectangle structure.

public void Exclude(
Rectangle rect
);

Parameters

rect
The Rectangle structure to exclude from this Region.

See Also

Region Class | Aspose.Imaging Namespace | Region.Exclude Overload List


Region.Exclude Method (RectangleF)

Updates this Region to contain only the portion of its interior that does not intersect with the specified RectangleF structure.

public void Exclude(
RectangleF rect
);

Parameters

rect
The RectangleF structure to exclude from this Region.

See Also

Region Class | Aspose.Imaging Namespace | Region.Exclude Overload List


Region.Exclude Method (Region)

Updates this Region to contain only the portion of its interior that does not intersect with the specified Region.

public void Exclude(
Region region
);

Parameters

region
The Region to exclude from this Region.

Exceptions

Exception Type | Condition
ArgumentNullException | region is null.

See Also

Region Class | Aspose.Imaging Namespace | Region.Exclude Overload List


Intersect Method

Aspose.Imaging Documentation

Region.Intersect Method

Updates this Region to the intersection of itself with the specified GraphicsPath.

Overload List

Updates this Region to the intersection of itself with the specified GraphicsPath.

public void Intersect(GraphicsPath);

Updates this Region to the intersection of itself with the specified Rectangle structure.

public void Intersect(Rectangle);

Updates this Region to the intersection of itself with the specified RectangleF structure.

public void Intersect(RectangleF);

Updates this Region to the intersection of itself with the specified Region.

public void Intersect(Region);

See Also

Region Class | Aspose.Imaging Namespace


Region.Intersect Method (GraphicsPath)

Updates this Region to the intersection of itself with the specified GraphicsPath.

public void Intersect(
GraphicsPath path
);

Parameters

path
The GraphicsPath to intersect with this Region.

See Also

Region Class | Aspose.Imaging Namespace | Region.Intersect Overload List


Region.Intersect Method (Rectangle)

Updates this Region to the intersection of itself with the specified Rectangle structure.

public void Intersect(
Rectangle rect
);

Parameters

rect
The Rectangle structure to intersect with this Region.

See Also

Region Class | Aspose.Imaging Namespace | Region.Intersect Overload List


Region.Intersect Method (RectangleF)

Updates this Region to the intersection of itself with the specified RectangleF structure.

public void Intersect(
RectangleF rect
);

Parameters

rect
The RectangleF structure to intersect with this Region.

See Also

Region Class | Aspose.Imaging Namespace | Region.Intersect Overload List


Region.Intersect Method (Region)

Updates this Region to the intersection of itself with the specified Region.

public void Intersect(
Region region
);

Parameters

region
The Region to intersect with this Region.

See Also

Region Class | Aspose.Imaging Namespace | Region.Intersect Overload List


Region.IsEmpty Method

Tests whether this Region has an empty interior on the specified drawing surface.

public bool IsEmpty(
Graphics g
);

Parameters

g
A Graphics that represents a drawing surface.

Return Value

true if the interior of this Region is empty when the transformation associated with g is applied; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | g is null.

See Also

Region Class | Aspose.Imaging Namespace


Region.IsInfinite Method

Tests whether this Region has an infinite interior on the specified drawing surface.

public bool IsInfinite(
Graphics g
);

Parameters

g
A Graphics that represents a drawing surface.

Return Value

true if the interior of this Region is infinite when the transformation associated with g is applied; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | g is null.

See Also

Region Class | Aspose.Imaging Namespace


IsVisible Method

Aspose.Imaging Documentation

Region.IsVisible Method

Tests whether the specified Point structure is contained within this Region.

Overload List

Tests whether the specified Point structure is contained within this Region.

public bool IsVisible(Point);

Tests whether the specified Point structure is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(Point,Graphics);

Tests whether the specified PointF structure is contained within this Region.

public bool IsVisible(PointF);

Tests whether the specified PointF structure is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(PointF,Graphics);

Tests whether any portion of the specified Rectangle structure is contained within this Region.

public bool IsVisible(Rectangle);

Tests whether any portion of the specified Rectangle structure is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(Rectangle,Graphics);

Tests whether any portion of the specified RectangleF structure is contained within this Region.

public bool IsVisible(RectangleF);

Tests whether any portion of the specified RectangleF structure is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(RectangleF,Graphics);

Tests whether the specified point is contained within this Region object when drawn using the specified Graphics object.

public bool IsVisible(int,int,Graphics);

Tests whether any portion of the specified rectangle is contained within this Region.

public bool IsVisible(int,int,int,int);

Tests whether any portion of the specified rectangle is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(int,int,int,int,Graphics);

Tests whether the specified point is contained within this Region.

public bool IsVisible(float,float);

Tests whether the specified point is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(float,float,Graphics);

Tests whether any portion of the specified rectangle is contained within this Region.

public bool IsVisible(float,float,float,float);

Tests whether any portion of the specified rectangle is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(float,float,float,float,Graphics);

See Also

Region Class | Aspose.Imaging Namespace


Region.IsVisible Method (Point)

Tests whether the specified Point structure is contained within this Region.

public bool IsVisible(
Point point
);

Parameters

point
The Point structure to test.

Return Value

true when point is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (Point, Graphics)

Tests whether the specified Point structure is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(
Point point,
Graphics g
);

Parameters

point
The Point structure to test.
g
A Graphics that represents a graphics context.

Return Value

true when point is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (PointF)

Tests whether the specified PointF structure is contained within this Region.

public bool IsVisible(
PointF point
);

Parameters

point
The PointF structure to test.

Return Value

true when point is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (PointF, Graphics)

Tests whether the specified PointF structure is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(
PointF point,
Graphics g
);

Parameters

point
The PointF structure to test.
g
A Graphics that represents a graphics context.

Return Value

true when point is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (Rectangle)

Tests whether any portion of the specified Rectangle structure is contained within this Region.

public bool IsVisible(
Rectangle rect
);

Parameters

rect
The Rectangle structure to test.

Return Value

This method returns true when any portion of rect is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (Rectangle, Graphics)

Tests whether any portion of the specified Rectangle structure is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(
Rectangle rect,
Graphics g
);

Parameters

rect
The Rectangle structure to test.
g
A Graphics that represents a graphics context.

Return Value

true when any portion of the rect is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (RectangleF)

Tests whether any portion of the specified RectangleF structure is contained within this Region.

public bool IsVisible(
RectangleF rect
);

Parameters

rect
The RectangleF structure to test.

Return Value

true when any portion of rect is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (RectangleF, Graphics)

Tests whether any portion of the specified RectangleF structure is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(
RectangleF rect,
Graphics g
);

Parameters

rect
The RectangleF structure to test.
g
A Graphics that represents a graphics context.

Return Value

true when rect is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (Int32, Int32, Graphics)

Tests whether the specified point is contained within this Region object when drawn using the specified Graphics object.

public bool IsVisible(
int x,
int y,
Graphics g
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.
g
A Graphics that represents a graphics context.

Return Value

true when the specified point is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (Int32, Int32, Int32, Int32)

Tests whether any portion of the specified rectangle is contained within this Region.

public bool IsVisible(
int x,
int y,
int width,
int height
);

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test.
y
The y-coordinate of the upper-left corner of the rectangle to test.
width
The width of the rectangle to test.
height
The height of the rectangle to test.

Return Value

true when any portion of the specified rectangle is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (Int32, Int32, Int32, Int32, Graphics)

Tests whether any portion of the specified rectangle is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(
int x,
int y,
int width,
int height,
Graphics g
);

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test.
y
The y-coordinate of the upper-left corner of the rectangle to test.
width
The width of the rectangle to test.
height
The height of the rectangle to test.
g
A Graphics that represents a graphics context.

Return Value

true when any portion of the specified rectangle is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (Single, Single)

Tests whether the specified point is contained within this Region.

public bool IsVisible(
float x,
float y
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.

Return Value

True when the specified point is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (Single, Single, Graphics)

Tests whether the specified point is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(
float x,
float y,
Graphics g
);

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.
g
A Graphics that represents a graphics context.

Return Value

True when the specified point is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (Single, Single, Single, Single)

Tests whether any portion of the specified rectangle is contained within this Region.

public bool IsVisible(
float x,
float y,
float width,
float height
);

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test.
y
The y-coordinate of the upper-left corner of the rectangle to test.
width
The width of the rectangle to test.
height
The height of the rectangle to test.

Return Value

true when any portion of the specified rectangle is contained within this Region object; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.IsVisible Method (Single, Single, Single, Single, Graphics)

Tests whether any portion of the specified rectangle is contained within this Region when drawn using the specified Graphics.

public bool IsVisible(
float x,
float y,
float width,
float height,
Graphics g
);

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test.
y
The y-coordinate of the upper-left corner of the rectangle to test.
width
The width of the rectangle to test.
height
The height of the rectangle to test.
g
A Graphics that represents a graphics context.

Return Value

true when any portion of the specified rectangle is contained within this Region; otherwise, false.

See Also

Region Class | Aspose.Imaging Namespace | Region.IsVisible Overload List


Region.MakeEmpty Method

Initializes this Region to an empty interior.

public void MakeEmpty();

See Also

Region Class | Aspose.Imaging Namespace


Region.MakeInfinite Method

Initializes this Region object to an infinite interior.

public void MakeInfinite();

See Also

Region Class | Aspose.Imaging Namespace


Region.Transform Method

Transforms this Region by the specified Matrix.

public void Transform(
Matrix matrix
);

Parameters

matrix
The Matrix by which to transform this Region.

Exceptions

Exception Type | Condition
ArgumentNullException | matrix is null.

See Also

Region Class | Aspose.Imaging Namespace


Translate Method

Aspose.Imaging Documentation

Region.Translate Method

Offsets the coordinates of this Region by the specified amount.

Overload List

Offsets the coordinates of this Region by the specified amount.

public void Translate(int,int);

Offsets the coordinates of this Region by the specified amount.

public void Translate(float,float);

See Also

Region Class | Aspose.Imaging Namespace


Region.Translate Method (Int32, Int32)

Offsets the coordinates of this Region by the specified amount.

public void Translate(
int dx,
int dy
);

Parameters

dx
The amount to offset this Region horizontally.
dy
The amount to offset this Region vertically.

See Also

Region Class | Aspose.Imaging Namespace | Region.Translate Overload List


Region.Translate Method (Single, Single)

Offsets the coordinates of this Region by the specified amount.

public void Translate(
float dx,
float dy
);

Parameters

dx
The amount to offset this Region horizontally.
dy
The amount to offset this Region vertically.

See Also

Region Class | Aspose.Imaging Namespace | Region.Translate Overload List


Union Method

Aspose.Imaging Documentation

Region.Union Method

Updates this Region to the union of itself and the specified GraphicsPath.

Overload List

Updates this Region to the union of itself and the specified GraphicsPath.

public void Union(GraphicsPath);

Updates this Region to the union of itself and the specified Rectangle structure.

public void Union(Rectangle);

Updates this Region to the union of itself and the specified RectangleF structure.

public void Union(RectangleF);

Updates this Region to the union of itself and the specified Region.

public void Union(Region);

See Also

Region Class | Aspose.Imaging Namespace


Region.Union Method (GraphicsPath)

Updates this Region to the union of itself and the specified GraphicsPath.

public void Union(
GraphicsPath path
);

Parameters

path
The GraphicsPath to unite with this Region.

Exceptions

Exception Type | Condition
ArgumentNullException | path is null.

See Also

Region Class | Aspose.Imaging Namespace | Region.Union Overload List


Region.Union Method (Rectangle)

Updates this Region to the union of itself and the specified Rectangle structure.

public void Union(
Rectangle rect
);

Parameters

rect
The Rectangle structure to unite with this Region.

See Also

Region Class | Aspose.Imaging Namespace | Region.Union Overload List


Region.Union Method (RectangleF)

Updates this Region to the union of itself and the specified RectangleF structure.

public void Union(
RectangleF rect
);

Parameters

rect
The RectangleF structure to unite with this Region.

See Also

Region Class | Aspose.Imaging Namespace | Region.Union Overload List


Region.Union Method (Region)

Updates this Region to the union of itself and the specified Region.

public void Union(
Region region
);

Parameters

region
The Region to unite with this Region.

Exceptions

Exception Type | Condition
ArgumentNullException | region is null.

See Also

Region Class | Aspose.Imaging Namespace | Region.Union Overload List


Xor Method

Aspose.Imaging Documentation

Region.Xor Method

Updates this Region to the union minus the intersection of itself with the specified GraphicsPath.

Overload List

Updates this Region to the union minus the intersection of itself with the specified GraphicsPath.

public void Xor(GraphicsPath);

Updates this Region to the union minus the intersection of itself with the specified Rectangle structure.

public void Xor(Rectangle);

Updates this Region to the union minus the intersection of itself with the specified RectangleF structure.

public void Xor(RectangleF);

Updates this Region to the union minus the intersection of itself with the specified Region.

public void Xor(Region);

See Also

Region Class | Aspose.Imaging Namespace


Region.Xor Method (GraphicsPath)

Updates this Region to the union minus the intersection of itself with the specified GraphicsPath.

public void Xor(
GraphicsPath path
);

Parameters

path
The GraphicsPath to xor with this Region.

Exceptions

Exception Type | Condition
ArgumentNullException | path is null.

See Also

Region Class | Aspose.Imaging Namespace | Region.Xor Overload List


Region.Xor Method (Rectangle)

Updates this Region to the union minus the intersection of itself with the specified Rectangle structure.

public void Xor(
Rectangle rect
);

Parameters

rect
The Rectangle structure to xor with this Region.

See Also

Region Class | Aspose.Imaging Namespace | Region.Xor Overload List


Region.Xor Method (RectangleF)

Updates this Region to the union minus the intersection of itself with the specified RectangleF structure.

public void Xor(
RectangleF rect
);

Parameters

rect
The RectangleF structure to xor with this Region.

See Also

Region Class | Aspose.Imaging Namespace | Region.Xor Overload List


Region.Xor Method (Region)

Updates this Region to the union minus the intersection of itself with the specified Region.

public void Xor(
Region region
);

Parameters

region
The Region to xor with this Region.

Exceptions

Exception Type | Condition
ArgumentNullException | region is null.

See Also

Region Class | Aspose.Imaging Namespace | Region.Xor Overload List


ResizeType Enumeration

Specifies the resize type.

public enum ResizeType

Members

Member Name | Description | Value
None | The pixels are not preserved during resize operation. | 0
LeftTopToLeftTop | Left top point of the new image will coincide with the left top point of the original image. Crop will occur if required. | 1
RightTopToRightTop | Right top point of the new image will coincide with the right top point of the original image. Crop will occur if required. | 2
RightBottomToRightBottom | Right bottom point of the new image will coincide with the right bottom point of the original image. Crop will occur if required. | 3
LeftBottomToLeftBottom | Left bottom point of the new image will coincide with the left bottom point of the original image. Crop will occur if required. | 4
CenterToCenter | Center of the new image will coincide with the center of the original image. Crop will occur if required. | 5
LanczosResample | Resample using lanczos algorithm with a=3. | 6
NearestNeighbourResample | Resample using nearest neighbour algorithm. | 7

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


RotateFlipType Enumeration

Specifies how much an image is rotated and the axis used to flip the image.

public enum RotateFlipType

Members

Member Name | Description | Value
RotateNoneFlipNone | Specifies no clockwise rotation and no flipping. | 0
Rotate90FlipNone | Specifies how much an image is rotated and the axis used to flip the image. | 1
Rotate180FlipNone | Specifies a 180-degree clockwise rotation without flipping. | 2
Rotate270FlipNone | Specifies a 270-degree clockwise rotation without flipping. | 3
RotateNoneFlipX | Specifies no clockwise rotation followed by a horizontal flip. | 4
Rotate90FlipX | Specifies a 90-degree clockwise rotation followed by a horizontal flip. | 5
Rotate180FlipX | Specifies a 180-degree clockwise rotation followed by a horizontal flip. | 6
Rotate270FlipX | Specifies a 270-degree clockwise rotation followed by a horizontal flip. | 7
RotateNoneFlipY | Specifies no clockwise rotation followed by a vertical flip. | 8
Rotate90FlipY | Specifies a 90-degree clockwise rotation followed by a vertical flip. | 9
Rotate180FlipY | Specifies a 180-degree clockwise rotation followed by a vertical flip. | 10
Rotate270FlipY | Specifies a 270-degree clockwise rotation followed by a vertical flip. | 11
RotateNoneFlipXY | Specifies no clockwise rotation followed by a horizontal and vertical flip. | 12
Rotate90FlipXY | Specifies a 90-degree clockwise rotation followed by a horizontal and vertical flip. | 13
Rotate180FlipXY | Specifies a 180-degree clockwise rotation followed by a horizontal and vertical flip. | 14
Rotate270FlipXY | Specifies a 270-degree clockwise rotation followed by a horizontal and vertical flip. | 15

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


Shape Class

The shape. A continuous set of points connected using a specific rule.

For a list of all members of this type, see Shape Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Shape
Aspose.Imaging.Shapes.PolygonShape
Aspose.Imaging.Shapes.RectangleProjectedShape

public abstract class Shape : ObjectWithBounds

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Shape Members | Aspose.Imaging Namespace


Shape Members

Shape overview

Public Instance Properties

Bounds (inherited from ObjectWithBounds) | Gets the object's bounds.
Center | Gets the shape's center.
HasSegments | Gets a value indicating whether shape has segments.
Segments | Gets the shape segments.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds (inherited from ObjectWithBounds) | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform (inherited from ObjectWithBounds) | Applies the specified transformation to the shape.

Protected Instance Constructors

Shape Constructor Initializes a new instance of the Shape class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Shape Class | Aspose.Imaging Namespace


Shape Constructor

Initializes a new instance of the Shape class.

protected Shape();

See Also

Shape Class | Aspose.Imaging Namespace


Shape Properties

The properties of the Shape class are listed below. For a complete list of Shape class members, see the Shape Members topic.

Public Instance Properties

Bounds (inherited from ObjectWithBounds) | Gets the object's bounds.
Center | Gets the shape's center.
HasSegments | Gets a value indicating whether shape has segments.
Segments | Gets the shape segments.

See Also

Shape Class | Aspose.Imaging Namespace


Center Property

Aspose.Imaging Documentation

Shape.Center Property

Gets the shape's center.

public abstract PointF Center {get;}

Property Value

The shape's center.

See Also

Shape Class | Aspose.Imaging Namespace


HasSegments Property

Aspose.Imaging Documentation

Shape.HasSegments Property

Gets a value indicating whether shape has segments.

public abstract bool HasSegments {get;}

Property Value

True if shape has segments; otherwise, false.

See Also

Shape Class | Aspose.Imaging Namespace


Segments Property

Aspose.Imaging Documentation

Shape.Segments Property

Gets the shape segments.

public abstract ShapeSegment[] Segments {get;}

Property Value

The shape segments.

See Also

Shape Class | Aspose.Imaging Namespace


ShapeSegment Class

Represents a shape segment. A segment is a line or curve connecting two points.

For a list of all members of this type, see ShapeSegment Members.

System.Object
Aspose.Imaging.ShapeSegment
Aspose.Imaging.ShapeSegments.LineSegment

public abstract class ShapeSegment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ShapeSegment Members | Aspose.Imaging Namespace


ShapeSegment Members

ShapeSegment overview

Public Instance Properties

EndPoint | Gets the ending point.
StartPoint | Gets the starting point.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ShapeSegment Constructor Initializes a new instance of the ShapeSegment class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShapeSegment Class | Aspose.Imaging Namespace


ShapeSegment Constructor

Initializes a new instance of the ShapeSegment class.

protected ShapeSegment();

See Also

ShapeSegment Class | Aspose.Imaging Namespace


ShapeSegment Properties

The properties of the ShapeSegment class are listed below. For a complete list of ShapeSegment class members, see the ShapeSegment Members topic.

Public Instance Properties

EndPoint | Gets the ending point.
StartPoint | Gets the starting point.

See Also

ShapeSegment Class | Aspose.Imaging Namespace


EndPoint Property

Aspose.Imaging Documentation

ShapeSegment.EndPoint Property

Gets the ending point.

public abstract PointF EndPoint {get;}

Property Value

The ending point.

See Also

ShapeSegment Class | Aspose.Imaging Namespace


StartPoint Property

Aspose.Imaging Documentation

ShapeSegment.StartPoint Property

Gets the starting point.

public abstract PointF StartPoint {get;}

Property Value

The starting point.

See Also

ShapeSegment Class | Aspose.Imaging Namespace


Size Structure

Represents size.

For a list of all members of this type, see Size Members.

System.Object
System.ValueType
Aspose.Imaging.Size

public struct Size

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Size Members | Aspose.Imaging Namespace


Size Members

Size overview

Public Static Properties

Empty Gets a new instance of the Size structure that has Width and Height values set to zero.

Public Static Methods

Add | Adds the width and height of one Size structure to the width and height of another Size structure.
Ceiling | Converts the specified SizeF structure to a Size structure by rounding the values of the Size structure to the next higher integer values.
Round | Converts the specified SizeF structure to a Size structure by rounding the values of the SizeF structure to the nearest integer values.
Subtract | Subtracts the width and height of one Size structure from the width and height of another Size structure.
Truncate | Converts the specified SizeF structure to a Size structure by truncating the values of the SizeF structure to the next lower integer values.

Public Static Operators and Type Conversions

Addition Operator | Adds the width and height of one Size structure to the width and height of another Size structure.
Equality Operator | Tests whether two Size structures are equal.
Inequality Operator | Tests whether two Size structures are different.
Subtraction Operator | Subtracts the width and height of one Size structure from the width and height of another Size structure.
Explicit Size to Point Conversion | Converts the specified Size to a Point.
Implicit Size to SizeF Conversion | Converts the specified Size to a SizeF.

Public Instance Constructors

Size Overloaded. Initializes a new instance of the Size class.

Public Instance Properties

Height | Gets or sets the vertical component of this Size.
IsEmpty | Gets a value indicating whether this Size has width and height of 0.
Width | Gets or sets the horizontal component of this Size.

Public Instance Methods

Equals | Tests to see whether the specified object is a Size with the same dimensions as this Size.
GetHashCode | Returns a hash code for this Size structure.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Creates a human-readable string that represents this Size.

See Also

Size Class | Aspose.Imaging Namespace


Size Constructor

Initializes a new instance of the Size structure from the specified Point.

Overload List

Initializes a new instance of the Size structure from the specified Point.

public Size(Point);

Initializes a new instance of the Size structure from the specified dimensions.

public Size(int,int);

See Also

Size Class | Aspose.Imaging Namespace


Size Constructor (Point)

Initializes a new instance of the Size structure from the specified Point.

public Size(
Point point
);

Parameters

point
The Point from which to initialize this Size.

See Also

Size Class | Aspose.Imaging Namespace | Size Constructor Overload List


Size Constructor (Int32, Int32)

Initializes a new instance of the Size structure from the specified dimensions.

public Size(
int width,
int height
);

Parameters

width
The width component of the new Size.
height
The height component of the new Size.

See Also

Size Class | Aspose.Imaging Namespace | Size Constructor Overload List


Size Properties

The properties of the Size structure are listed below. For a complete list of Size structure members, see the Size Members topic.

Public Static Properties

Empty Gets a new instance of the Size structure that has Width and Height values set to zero.

Public Instance Properties

Height | Gets or sets the vertical component of this Size.
IsEmpty | Gets a value indicating whether this Size has width and height of 0.
Width | Gets or sets the horizontal component of this Size.

See Also

Size Class | Aspose.Imaging Namespace


Empty Property

Aspose.Imaging Documentation

Size.Empty Property

Gets a new instance of the Size structure that has Width and Height values set to zero.

public static Size Empty {get;}

See Also

Size Class | Aspose.Imaging Namespace


Height Property

Aspose.Imaging Documentation

Size.Height Property

Gets or sets the vertical component of this Size.

public int Height {get; set;}

See Also

Size Class | Aspose.Imaging Namespace


IsEmpty Property

Aspose.Imaging Documentation

Size.IsEmpty Property

Gets a value indicating whether this Size has width and height of 0.

public bool IsEmpty {get;}

See Also

Size Class | Aspose.Imaging Namespace


Width Property

Aspose.Imaging Documentation

Size.Width Property

Gets or sets the horizontal component of this Size.

public int Width {get; set;}

See Also

Size Class | Aspose.Imaging Namespace


Size Methods

The methods of the Size structure are listed below. For a complete list of Size structure members, see the Size Members topic.

Public Static Methods

Add | Adds the width and height of one Size structure to the width and height of another Size structure.
Ceiling | Converts the specified SizeF structure to a Size structure by rounding the values of the Size structure to the next higher integer values.
Round | Converts the specified SizeF structure to a Size structure by rounding the values of the SizeF structure to the nearest integer values.
Subtract | Subtracts the width and height of one Size structure from the width and height of another Size structure.
Truncate | Converts the specified SizeF structure to a Size structure by truncating the values of the SizeF structure to the next lower integer values.

Public Instance Methods

Equals | Tests to see whether the specified object is a Size with the same dimensions as this Size.
GetHashCode | Returns a hash code for this Size structure.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Creates a human-readable string that represents this Size.

See Also

Size Class | Aspose.Imaging Namespace


Size.Add Method

Adds the width and height of one Size structure to the width and height of another Size structure.

public static Size Add(
Size size1,
Size size2
);

Parameters

size1
The first Size to add.
size2
The second Size to add.

Return Value

A Size structure that is the result of the addition operation.

See Also

Size Class | Aspose.Imaging Namespace


Size.Ceiling Method

Converts the specified SizeF structure to a Size structure by rounding the values of the Size structure to the next higher integer values.

public static Size Ceiling(
SizeF size
);

Parameters

size
The SizeF structure to convert.

Return Value

The Size structure this method converts to.

See Also

Size Class | Aspose.Imaging Namespace


Size.Equals Method

Tests to see whether the specified object is a Size with the same dimensions as this Size.

public override bool Equals(
object obj
);

Parameters

obj
The Object to test.

Return Value

True if obj is a Size and has the same width and height as this Size; otherwise, false.

See Also

Size Class | Aspose.Imaging Namespace


Size.GetHashCode Method

Returns a hash code for this Size structure.

public override int GetHashCode();

Return Value

An integer value that specifies a hash value for this Size structure.

See Also

Size Class | Aspose.Imaging Namespace


Size.Round Method

Converts the specified SizeF structure to a Size structure by rounding the values of the SizeF structure to the nearest integer values.

public static Size Round(
SizeF size
);

Parameters

size
The SizeF structure to convert.

Return Value

The Size structure this method converts to.

See Also

Size Class | Aspose.Imaging Namespace


Size.Subtract Method

Subtracts the width and height of one Size structure from the width and height of another Size structure.

public static Size Subtract(
Size size1,
Size size2
);

Parameters

size1
The Size structure on the left side of the subtraction operator.
size2
The Size structure on the right side of the subtraction operator.

Return Value

The Size that is a result of the subtraction operation.

See Also

Size Class | Aspose.Imaging Namespace


Size.ToString Method

Creates a human-readable string that represents this Size.

public override string ToString();

Return Value

A string that represents this Size.

See Also

Size Class | Aspose.Imaging Namespace


Size.Truncate Method

Converts the specified SizeF structure to a Size structure by truncating the values of the SizeF structure to the next lower integer values.

public static Size Truncate(
SizeF size
);

Parameters

size
The SizeF structure to convert.

Return Value

The Size structure this method converts to.

See Also

Size Class | Aspose.Imaging Namespace


Size Operators and Type Conversions

The operators and type conversions of the Size structure are listed below. For a complete list of Size structure members, see the Size Members topic.

Public Static Operators and Type Conversions

Addition Operator | Adds the width and height of one Size structure to the width and height of another Size structure.
Equality Operator | Tests whether two Size structures are equal.
Inequality Operator | Tests whether two Size structures are different.
Subtraction Operator | Subtracts the width and height of one Size structure from the width and height of another Size structure.
Explicit Size to Point Conversion | Converts the specified Size to a Point.
Implicit Size to SizeF Conversion | Converts the specified Size to a SizeF.

See Also

Size Class | Size Members | Aspose.Imaging Namespace


Size Addition Operator

Adds the width and height of one Size structure to the width and height of another Size structure.

public static Size operator +(
Size size1,
Size size2
);

Parameters

size1
The first Size to add.
size2
The second Size to add.

Return Value

A Size structure that is the result of the addition operation.

See Also

Size Class | Aspose.Imaging Namespace


Size Equality Operator

Tests whether two Size structures are equal.

public static bool operator ==(
Size size1,
Size size2
);

Parameters

size1
The Size structure on the left side of the equality operator.
size2
The Size structure on the right of the equality operator.

Return Value

True if size1 and size2 have equal width and height; otherwise, false.

See Also

Size Class | Aspose.Imaging Namespace


Size Inequality Operator

Tests whether two Size structures are different.

public static bool operator !=(
Size size1,
Size size2
);

Parameters

size1
The Size structure on the left of the inequality operator.
size2
The Size structure on the right of the inequality operator.

Return Value

True if size1 and size2 differ either in width or height; false if size1 and size2 are equal.

See Also

Size Class | Aspose.Imaging Namespace


Size Subtraction Operator

Subtracts the width and height of one Size structure from the width and height of another Size structure.

public static Size operator -(
Size size1,
Size size2
);

Parameters

size1
The Size structure on the left side of the subtraction operator.
size2
The Size structure on the right side of the subtraction operator.

Return Value

A Size structure that is the result of the subtraction operation.

See Also

Size Class | Aspose.Imaging Namespace


Size Explicit Size to Point Conversion

Converts the specified Size to a Point.

public static explicit operator Point(
Size size
);

Parameters

size
The Size to convert.

Return Value

The Point structure to which this operator converts.

See Also

Size Class | Aspose.Imaging Namespace


Size Implicit Size to SizeF Conversion

Converts the specified Size to a SizeF.

public static implicit operator SizeF(
Size size
);

Parameters

size
The Size to convert.

Return Value

The SizeF structure to which this operator converts.

See Also

Size Class | Aspose.Imaging Namespace


SizeF Structure

Stores an ordered pair of floating-point numbers, typically the width and height of a rectangle.

For a list of all members of this type, see SizeF Members.

System.Object
System.ValueType
Aspose.Imaging.SizeF

public struct SizeF

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

SizeF Members | Aspose.Imaging Namespace


SizeF Members

SizeF overview

Public Static Properties

Empty Gets a new instance of the SizeF structure that has Width and Height values set to zero.

Public Static Methods

Add | Adds the width and height of one SizeF structure to the width and height of another SizeF structure.
Subtract | Subtracts the width and height of one SizeF structure from the width and height of another SizeF structure.

Public Static Operators and Type Conversions

Addition Operator | Adds the width and height of one SizeF structure to the width and height of another SizeF structure.
Equality Operator | Tests whether two SizeF structures are equal.
Inequality Operator | Tests whether two SizeF structures are different.
Subtraction Operator | Subtracts the width and height of one SizeF structure from the width and height of another SizeF structure.
Explicit SizeF to PointF Conversion | Converts the specified SizeF to a PointF.

Public Instance Constructors

SizeF Overloaded. Initializes a new instance of the SizeF class.

Public Instance Properties

Height | Gets or sets the vertical component of this SizeF.
IsEmpty | Gets a value indicating whether this SizeF has zero width and height.
Width | Gets or sets the horizontal component of this SizeF.

Public Instance Methods

Equals | Tests to see whether the specified object is a SizeF with the same dimensions as this SizeF.
GetHashCode | Returns a hash code for this Size structure.
GetType (inherited from Object) | Gets the Type of the current instance.
ToPointF | Converts a SizeF to a PointF.
ToSize | Converts a SizeF to a Size structure with truncated size values.
ToString | Creates a human-readable string that represents this SizeF.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF Constructor

Initializes a new instance of the SizeF structure from the specified SizeF.

Overload List

Initializes a new instance of the SizeF structure from the specified PointF.

public SizeF(PointF);

Initializes a new instance of the SizeF structure from the specified SizeF.

public SizeF(SizeF);

Initializes a new instance of the SizeF structure from the specified dimensions.

public SizeF(float,float);

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF Constructor (SizeF)

Initializes a new instance of the SizeF structure from the specified SizeF.

public SizeF(
SizeF size
);

Parameters

size
The SizeF from which to create the new SizeF.

See Also

SizeF Class | Aspose.Imaging Namespace | SizeF Constructor Overload List


SizeF Constructor (PointF)

Initializes a new instance of the SizeF structure from the specified PointF.

public SizeF(
PointF point
);

Parameters

point
The PointF from which to initialize this SizeF.

See Also

SizeF Class | Aspose.Imaging Namespace | SizeF Constructor Overload List


SizeF Constructor (Single, Single)

Initializes a new instance of the SizeF structure from the specified dimensions.

public SizeF(
float width,
float height
);

Parameters

width
The width component of the new SizeF.
height
The height component of the new SizeF.

See Also

SizeF Class | Aspose.Imaging Namespace | SizeF Constructor Overload List


SizeF Properties

The properties of the SizeF structure are listed below. For a complete list of SizeF structure members, see the SizeF Members topic.

Public Static Properties

Empty Gets a new instance of the SizeF structure that has Width and Height values set to zero.

Public Instance Properties

Height | Gets or sets the vertical component of this SizeF.
IsEmpty | Gets a value indicating whether this SizeF has zero width and height.
Width | Gets or sets the horizontal component of this SizeF.

See Also

SizeF Class | Aspose.Imaging Namespace


Empty Property

Aspose.Imaging Documentation

SizeF.Empty Property

Gets a new instance of the SizeF structure that has Width and Height values set to zero.

public static SizeF Empty {get;}

See Also

SizeF Class | Aspose.Imaging Namespace


Height Property

Aspose.Imaging Documentation

SizeF.Height Property

Gets or sets the vertical component of this SizeF.

public float Height {get; set;}

See Also

SizeF Class | Aspose.Imaging Namespace


IsEmpty Property

Aspose.Imaging Documentation

SizeF.IsEmpty Property

Gets a value indicating whether this SizeF has zero width and height.

public bool IsEmpty {get;}

See Also

SizeF Class | Aspose.Imaging Namespace


Width Property

Aspose.Imaging Documentation

SizeF.Width Property

Gets or sets the horizontal component of this SizeF.

public float Width {get; set;}

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF Methods

The methods of the SizeF structure are listed below. For a complete list of SizeF structure members, see the SizeF Members topic.

Public Static Methods

Add | Adds the width and height of one SizeF structure to the width and height of another SizeF structure.
Subtract | Subtracts the width and height of one SizeF structure from the width and height of another SizeF structure.

Public Instance Methods

Equals | Tests to see whether the specified object is a SizeF with the same dimensions as this SizeF.
GetHashCode | Returns a hash code for this Size structure.
GetType (inherited from Object) | Gets the Type of the current instance.
ToPointF | Converts a SizeF to a PointF.
ToSize | Converts a SizeF to a Size structure with truncated size values.
ToString | Creates a human-readable string that represents this SizeF.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF.Add Method

Adds the width and height of one SizeF structure to the width and height of another SizeF structure.

public static SizeF Add(
SizeF size1,
SizeF size2
);

Parameters

size1
The first SizeF to add.
size2
The second SizeF to add.

Return Value

A SizeF structure that is the result of the addition operation.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF.Equals Method

Tests to see whether the specified object is a SizeF with the same dimensions as this SizeF.

public override bool Equals(
object obj
);

Parameters

obj
The Object to test.

Return Value

This method returns true if obj is a SizeF and has the same width and height as this SizeF; otherwise, false.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF.GetHashCode Method

Returns a hash code for this Size structure.

public override int GetHashCode();

Return Value

An integer value that specifies a hash value for this Size structure.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF.Subtract Method

Subtracts the width and height of one SizeF structure from the width and height of another SizeF structure.

public static SizeF Subtract(
SizeF size1,
SizeF size2
);

Parameters

size1
The SizeF structure on the left side of the subtraction operator.
size2
The SizeF structure on the right side of the subtraction operator.

Return Value

The SizeF that is a result of the subtraction operation.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF.ToPointF Method

Converts a SizeF to a PointF.

public PointF ToPointF();

Return Value

Returns a PointF structure.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF.ToSize Method

Converts a SizeF to a Size structure with truncated size values.

public Size ToSize();

Return Value

Returns a Size structure.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF.ToString Method

Creates a human-readable string that represents this SizeF.

public override string ToString();

Return Value

A string that represents this SizeF.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF Operators and Type Conversions

The operators and type conversions of the SizeF structure are listed below. For a complete list of SizeF structure members, see the SizeF Members topic.

Public Static Operators and Type Conversions

Addition Operator | Adds the width and height of one SizeF structure to the width and height of another SizeF structure.
Equality Operator | Tests whether two SizeF structures are equal.
Inequality Operator | Tests whether two SizeF structures are different.
Subtraction Operator | Subtracts the width and height of one SizeF structure from the width and height of another SizeF structure.
Explicit SizeF to PointF Conversion | Converts the specified SizeF to a PointF.

See Also

SizeF Class | SizeF Members | Aspose.Imaging Namespace


SizeF Addition Operator

Adds the width and height of one SizeF structure to the width and height of another SizeF structure.

public static SizeF operator +(
SizeF size1,
SizeF size2
);

Parameters

size1
The first SizeF to add.
size2
The second SizeF to add.

Return Value

A SizeF structure that is the result of the addition operation.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF Equality Operator

Tests whether two SizeF structures are equal.

public static bool operator ==(
SizeF size1,
SizeF size2
);

Parameters

size1
The SizeF structure on the left side of the equality operator.
size2
The SizeF structure on the right of the equality operator.

Return Value

This operator returns true if size1 and size2 have equal width and height; otherwise, false.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF Inequality Operator

Tests whether two SizeF structures are different.

public static bool operator !=(
SizeF size1,
SizeF size2
);

Parameters

size1
The SizeF structure on the left of the inequality operator.
size2
The SizeF structure on the right of the inequality operator.

Return Value

This operator returns true if size1 and size2 differ either in width or height; false if size1 and size2 are equal.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF Subtraction Operator

Subtracts the width and height of one SizeF structure from the width and height of another SizeF structure.

public static SizeF operator -(
SizeF size1,
SizeF size2
);

Parameters

size1
The SizeF on the left side of the subtraction operator.
size2
The SizeF on the right side of the subtraction operator.

Return Value

A SizeF that is the result of the subtraction operation.

See Also

SizeF Class | Aspose.Imaging Namespace


SizeF Explicit SizeF to PointF Conversion

Converts the specified SizeF to a PointF.

public static explicit operator PointF(
SizeF size
);

Parameters

size
The SizeF structure to be converted

Return Value

The PointF structure to which this operator converts.

See Also

SizeF Class | Aspose.Imaging Namespace


SmoothingMode Enumeration

Specifies whether smoothing (antialiasing) is applied to lines and curves and the edges of filled areas.

public enum SmoothingMode

Members

Member Name | Description | Value
Invalid | Specifies an invalid mode. | -1
Default | Specifies no antialiasing. | 0
HighSpeed | Specifies no antialiasing. | 1
HighQuality | Specifies antialiased rendering. | 2
None | Specifies no antialiasing. | 3
AntiAlias | Specifies antialiased rendering. | 4

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


Source Class

The source is used to contain all relevant information for an object pipe.

For a list of all members of this type, see Source Members.

System.Object
Aspose.Imaging.Source
Aspose.Imaging.Sources.FileSource
Aspose.Imaging.Sources.StreamSource

public abstract class Source

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Source Members | Aspose.Imaging Namespace


Source Members

Source overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Source Constructor Initializes a new instance of the Source class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Source Class | Aspose.Imaging Namespace


Source Constructor

Initializes a new instance of the Source class.

protected Source();

See Also

Source Class | Aspose.Imaging Namespace


StreamContainer Class

Represents stream container which contains the stream and provides stream processing routines.

For a list of all members of this type, see StreamContainer Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.StreamContainer
Aspose.Imaging.FileFormats.Tiff.FileManagement.TiffStream
Aspose.Imaging.FileStreamContainer

public class StreamContainer : DisposableObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

StreamContainer Members | Aspose.Imaging Namespace


StreamContainer Members

StreamContainer overview

Public Static Fields

ReadWriteBytesCount Specifies read and write bytes count when reading sequentially.

Public Static Type Conversions

Explicit StreamContainer to Stream Conversion Performs an explicit conversion from StreamContainer to Stream.

Public Instance Properties

CanRead | Gets a value indicating whether stream supports reading.
CanSeek | Gets a value indicating whether stream supports seeking.
CanWrite | Gets a value indicating whether stream supports writing.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
IsStreamDisposedOnClose | Gets a value indicating whether this stream is disposed on close.
Length | Gets or sets the stream length in bytes. This value is less than the Length by the starting stream position passed in the StreamContainer constructor.
Position | Gets or sets the current position within the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.
Stream | Gets the data stream.

Public Instance Methods

Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Read | Overloaded. Reads bytes to fill the specified bytes buffer.
ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.
Save | Overloaded. Saves (copies) the stream's data to the specified stream. Uses default buffer size ReadWriteBytesCount and stream Length value.
Seek | Sets the position within the current stream.
SeekBegin | Sets the stream position to the beginning of the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.
Shift | Shifts the data from the current stream position. The data starts from the current byte and continues to the end of the file.
ToBytes | Overloaded. Converts the stream data to the Byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes all of the specified bytes to the stream.
WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte.
WriteTo | Overloaded. Copies the contained data to another StreamContainer.

Protected Instance Methods

AfterStreamDisposed | Called after the stream is disposed.
BeforeSave | Called before save occurs on the destination stream.
BeforeStreamDisposed | Called before the stream is disposed.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReleaseManagedResources | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer Fields

The fields of the StreamContainer class are listed below. For a complete list of StreamContainer class members, see the StreamContainer Members topic.

Public Static Fields

ReadWriteBytesCount Specifies read and write bytes count when reading sequentially.

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.ReadWriteBytesCount Field

Specifies read and write bytes count when reading sequentially.

public const int ReadWriteBytesCount = 4096;

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer Properties

The properties of the StreamContainer class are listed below. For a complete list of StreamContainer class members, see the StreamContainer Members topic.

Public Instance Properties

CanRead | Gets a value indicating whether stream supports reading.
CanSeek | Gets a value indicating whether stream supports seeking.
CanWrite | Gets a value indicating whether stream supports writing.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
IsStreamDisposedOnClose | Gets a value indicating whether this stream is disposed on close.
Length | Gets or sets the stream length in bytes. This value is less than the Length by the starting stream position passed in the StreamContainer constructor.
Position | Gets or sets the current position within the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.
Stream | Gets the data stream.

See Also

StreamContainer Class | Aspose.Imaging Namespace


CanRead Property

Aspose.Imaging Documentation

StreamContainer.CanRead Property

Gets a value indicating whether stream supports reading.

public bool CanRead {get;}

Property Value

true if stream supports reading; otherwise, false.

See Also

StreamContainer Class | Aspose.Imaging Namespace


CanSeek Property

Aspose.Imaging Documentation

StreamContainer.CanSeek Property

Gets a value indicating whether stream supports seeking.

public bool CanSeek {get;}

Property Value

true if stream supports seeking; otherwise, false.

See Also

StreamContainer Class | Aspose.Imaging Namespace


CanWrite Property

Aspose.Imaging Documentation

StreamContainer.CanWrite Property

Gets a value indicating whether stream supports writing.

public bool CanWrite {get;}

Property Value

true if stream supports writing; otherwise, false.

See Also

StreamContainer Class | Aspose.Imaging Namespace


IsStreamDisposedOnClose Property

Aspose.Imaging Documentation

StreamContainer.IsStreamDisposedOnClose Property

Gets a value indicating whether this stream is disposed on close.

public bool IsStreamDisposedOnClose {get;}

Property Value

true if stream is disposed on close; otherwise, false.

See Also

StreamContainer Class | Aspose.Imaging Namespace


Length Property

Aspose.Imaging Documentation

StreamContainer.Length Property

Gets or sets the stream length in bytes. This value is less than the Length by the starting stream position passed in the StreamContainer constructor.

public long Length {get; set;}

Property Value

The stream length.

See Also

StreamContainer Class | Aspose.Imaging Namespace


Position Property

Aspose.Imaging Documentation

StreamContainer.Position Property

Gets or sets the current position within the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.

public long Position {get; set;}

Property Value

The current stream position.

See Also

StreamContainer Class | Aspose.Imaging Namespace


Stream Property

Aspose.Imaging Documentation

StreamContainer.Stream Property

Gets the data stream.

public Stream Stream {get;}

Property Value

The data stream.

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer Methods

The methods of the StreamContainer class are listed below. For a complete list of StreamContainer class members, see the StreamContainer Members topic.

Public Instance Methods

Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Read | Overloaded. Reads bytes to fill the specified bytes buffer.
ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.
Save | Overloaded. Saves (copies) the stream's data to the specified stream. Uses default buffer size ReadWriteBytesCount and stream Length value.
Seek | Sets the position within the current stream.
SeekBegin | Sets the stream position to the beginning of the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.
Shift | Shifts the data from the current stream position. The data starts from the current byte and continues to the end of the file.
ToBytes | Overloaded. Converts the stream data to the Byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes all of the specified bytes to the stream.
WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte.
WriteTo | Overloaded. Copies the contained data to another StreamContainer.

Protected Instance Methods

AfterStreamDisposed | Called after the stream is disposed.
BeforeSave | Called before save occurs on the destination stream.
BeforeStreamDisposed | Called before the stream is disposed.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReleaseManagedResources | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.AfterStreamDisposed Method

Called after the stream is disposed.

protected virtual void AfterStreamDisposed();

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.BeforeSave Method

Called before save occurs on the destination stream.

protected virtual void BeforeSave(
Stream destinationStream
);

Parameters

destinationStream
The destination stream.

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.BeforeStreamDisposed Method

Called before the stream is disposed.

protected virtual void BeforeStreamDisposed();

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.Flush Method

Clears all buffers for this stream and causes any buffered data to be written to the underlying device.

public void Flush();

See Also

StreamContainer Class | Aspose.Imaging Namespace


Read Method

Aspose.Imaging Documentation

StreamContainer.Read Method

Reads bytes to fill the specified bytes buffer.

Overload List

Reads bytes to fill the specified bytes buffer.

public int Read(byte[]);

Reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.

public int Read(byte[],int,int);

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.Read Method (Byte[])

Reads bytes to fill the specified bytes buffer.

public int Read(
byte[] bytes
);

Parameters

bytes
The bytes to fill.

Return Value

The number of bytes read. This value can be less than the number of bytes in the buffer if there is not enough bytes in the stream.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.Read Overload List


StreamContainer.Read Method (Byte[], Int32, Int32)

Reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.

public int Read(
byte[] buffer,
int offset,
int count
);

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.Read Overload List


StreamContainer.ReadByte Method

Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.

public int ReadByte();

Return Value

The unsigned byte cast to an Int32, or -1 if at the end of the stream.

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.ReleaseManagedResources Method

Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.

protected override void ReleaseManagedResources();

See Also

StreamContainer Class | Aspose.Imaging Namespace


Save Method

Aspose.Imaging Documentation

StreamContainer.Save Method

Saves (copies) the stream's data to the specified stream. Uses default buffer size ReadWriteBytesCount and stream Length value.

Overload List

Saves (copies) the stream's data to the specified stream. Uses default buffer size ReadWriteBytesCount and stream Length value.

public void Save(Stream);

Saves (copies) all the stream's data to the specified stream. Uses stream Length value.

public void Save(Stream,int);

Saves (copies) the stream's data to the specified stream.

public void Save(Stream,int,long);

Saves (copies) the stream's data to the specified stream. Uses default buffer size ReadWriteBytesCount and stream Length value.

public void Save(string);

Saves (copies) the stream's data to the specified stream. Uses stream Length value.

public void Save(string,int);

Saves (copies) the stream's data to the specified stream.

public void Save(string,int,long);

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.Save Method (Stream)

Saves (copies) the stream's data to the specified stream. Uses default buffer size ReadWriteBytesCount and stream Length value.

public void Save(
Stream destinationStream
);

Parameters

destinationStream
The stream to save the data to.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.Save Overload List


StreamContainer.Save Method (Stream, Int32)

Saves (copies) all the stream's data to the specified stream. Uses stream Length value.

public void Save(
Stream destinationStream,
int bufferSize
);

Parameters

destinationStream
The stream to save the data to.
bufferSize
The buffer.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.Save Overload List


StreamContainer.Save Method (Stream, Int32, Int64)

Saves (copies) the stream's data to the specified stream.

public void Save(
Stream destinationStream,
int bufferSize,
long length
);

Parameters

destinationStream
The stream to save the data to.
bufferSize
The buffer size. By default ReadWriteBytesCount value is used.
length
The stream data length to copy. By default the length is set to Length value.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.Save Overload List


StreamContainer.Save Method (String)

Saves (copies) the stream's data to the specified stream. Uses default buffer size ReadWriteBytesCount and stream Length value.

public void Save(
string filePath
);

Parameters

filePath
The file path to save the stream data to.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.Save Overload List


StreamContainer.Save Method (String, Int32)

Saves (copies) the stream's data to the specified stream. Uses stream Length value.

public void Save(
string filePath,
int bufferSize
);

Parameters

filePath
The file path to save the stream data to.
bufferSize
The buffer size. By default ReadWriteBytesCount value is used.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.Save Overload List


StreamContainer.Save Method (String, Int32, Int64)

Saves (copies) the stream's data to the specified stream.

public void Save(
string filePath,
int bufferSize,
long length
);

Parameters

filePath
The file path to save the stream data to.
bufferSize
The buffer size. By default ReadWriteBytesCount value is used.
length
The stream data length to copy. By default the length is set to Length value.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.Save Overload List


StreamContainer.Seek Method

Sets the position within the current stream.

public long Seek(
long offset,
SeekOrigin origin
);

Parameters

offset
A byte offset relative to the origin parameter. This value represents offset from the starting stream position passed in the StreamContainer constructor.
origin
A value of type SeekOrigin indicating the reference point used to obtain the new position.

Return Value

The new position within the current stream.

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.SeekBegin Method

Sets the stream position to the beginning of the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.

public void SeekBegin();

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.Shift Method

Shifts the data from the current stream position. The data starts from the current byte and continues to the end of the file.

public void Shift(
long shift
);

Parameters

shift
The shift value. Positive value will shift the data to the end of the file, while negative will move the data backwards to the file beginning.

See Also

StreamContainer Class | Aspose.Imaging Namespace


ToBytes Method

Aspose.Imaging Documentation

StreamContainer.ToBytes Method

Converts the stream data to the Byte array.

Overload List

Converts the stream data to the Byte array.

public byte[] ToBytes();

Converts the stream data to the Byte array.

public byte[] ToBytes(long,long);

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.ToBytes Method ()

Converts the stream data to the Byte array.

public byte[] ToBytes();

Return Value

The stream data converted to the Byte array.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.ToBytes Overload List


StreamContainer.ToBytes Method (Int64, Int64)

Converts the stream data to the Byte array.

public byte[] ToBytes(
long position,
long bytesCount
);

Parameters

position
The position to start reading bytes from.
bytesCount
The bytes count to read.

Return Value

The stream data converted to the Byte array.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.ToBytes Overload List


Write Method

Aspose.Imaging Documentation

StreamContainer.Write Method

Writes all of the specified bytes to the stream.

Overload List

Writes all of the specified bytes to the stream.

public void Write(byte[]);

Writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.

public void Write(byte[],int,int);

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.Write Method (Byte[])

Writes all of the specified bytes to the stream.

public void Write(
byte[] bytes
);

Parameters

bytes
The bytes to write.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.Write Overload List


StreamContainer.Write Method (Byte[], Int32, Int32)

Writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.

public void Write(
byte[] buffer,
int offset,
int count
);

Parameters

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count
The number of bytes to be written to the current stream.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.Write Overload List


StreamContainer.WriteByte Method

Writes a byte to the current position in the stream and advances the position within the stream by one byte.

public void WriteByte(
byte value
);

Parameters

value
The byte to write to the stream.

See Also

StreamContainer Class | Aspose.Imaging Namespace


WriteTo Method

Aspose.Imaging Documentation

StreamContainer.WriteTo Method

Copies the contained data to another StreamContainer.

Overload List

Copies the contained data to another StreamContainer.

public void WriteTo(StreamContainer);

Copies the contained data to another StreamContainer.

public void WriteTo(StreamContainer,long);

See Also

StreamContainer Class | Aspose.Imaging Namespace


StreamContainer.WriteTo Method (StreamContainer)

Copies the contained data to another StreamContainer.

public void WriteTo(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container to copy to.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.WriteTo Overload List


StreamContainer.WriteTo Method (StreamContainer, Int64)

Copies the contained data to another StreamContainer.

public void WriteTo(
StreamContainer streamContainer,
long length
);

Parameters

streamContainer
The stream container to copy to.
length
The bytes count to write.

Exceptions

Exception Type | Condition
FrameworkException | Copy operation cannot complete. Cannot read + count + bytes.

See Also

StreamContainer Class | Aspose.Imaging Namespace | StreamContainer.WriteTo Overload List


StreamContainer Type Conversions

The type conversions of the StreamContainer class are listed below. For a complete list of StreamContainer class members, see the StreamContainer Members topic.

Public Static Type Conversions

Explicit StreamContainer to Stream Conversion Performs an explicit conversion from StreamContainer to Stream.

See Also

StreamContainer Class | StreamContainer Members | Aspose.Imaging Namespace


StreamContainer Explicit StreamContainer to Stream Conversion

Performs an explicit conversion from StreamContainer to Stream.

public static explicit operator Stream(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container.

Return Value

The result of the conversion.

See Also

StreamContainer Class | Aspose.Imaging Namespace


StringAlignment Enumeration

Specifies the alignment of a text string relative to its layout rectangle.

public enum StringAlignment

Members

Member Name | Description | Value
Near | Specifies the text be aligned near the layout. In a left-to-right layout, the near position is left. In a right-to-left layout, the near position is right. | 0
Center | Specifies that text is aligned in the center of the layout rectangle. | 1
Far | Specifies that text is aligned far from the origin position of the layout rectangle. In a left-to-right layout, the far position is right. In a right-to-left layout, the far position is left. | 2

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


StringDigitSubstitute Enumeration

The enumeration specifies how to substitute digits in a string according to a user's locale or language.

public enum StringDigitSubstitute

Members

Member Name | Description | Value
User | Specifies a user-defined substitution scheme. | 0
None | Specifies to disable substitutions. | 1
National | Specifies substitution digits that correspond with the official national language of the user's locale. | 2
Traditional | Specifies substitution digits that correspond with the user's native script or language, which may be different from the official national language of the user's locale. | 3

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


StringFormat Class

Encapsulates text layout information (such as alignment, orientation and tab stops) display manipulations (such as ellipsis insertion and national digit substitution) and OpenType features. This class cannot be inherited.

For a list of all members of this type, see StringFormat Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.StringFormat

public sealed class StringFormat : DisposableObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

StringFormat Members | Aspose.Imaging Namespace


StringFormat Members

StringFormat overview

Public Static Properties

GenericDefault | Gets a generic default StringFormat object.
GenericTypographic | Gets a generic typographic StringFormat object.

Public Instance Constructors

StringFormat Overloaded. Initializes a new instance of the StringFormat class.

Public Instance Properties

Alignment | Gets or sets text alignment information on the vertical plane.
DigitSubstitutionLanguage | Gets or sets the language that is used when local digits are substituted for western digits.
DigitSubstitutionMethod | Gets or sets the method to be used for digit substitution.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
FirstTabOffset | Gets the number of spaces between the beginning of a line of text and the first tab stop.
FormatFlags | Gets or sets a StringFormatFlags enumeration that contains formatting information.
HotkeyPrefix | Gets or sets the HotkeyPrefix object for this StringFormat object.
LineAlignment | Gets or sets the line alignment on the horizontal plane.
TabStops | Gets an array of distances between tab stops in the units specified by the PageUnit property.
Trimming | Gets or sets the StringTrimming enumeration for this StringFormat object.

Public Instance Methods

DeepClone | Creates a deep clone of this StringFormat object.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetTabStops | Sets tab stops for this StringFormat object.
ToString | Converts this StringFormat object to a human-readable string.

See Also

StringFormat Class | Aspose.Imaging Namespace


StringFormat Constructor

Initializes a new StringFormat object.

Overload List

Initializes a new StringFormat object.

public StringFormat();

Initializes a new StringFormat object from the specified existing StringFormat object.

public StringFormat(StringFormat);

Initializes a new StringFormat object with the specified StringFormatFlags enumeration and language.

public StringFormat(StringFormatFlags);

See Also

StringFormat Class | Aspose.Imaging Namespace


StringFormat Constructor ()

Initializes a new StringFormat object.

public StringFormat();

See Also

StringFormat Class | Aspose.Imaging Namespace | StringFormat Constructor Overload List


StringFormat Constructor (StringFormatFlags)

Initializes a new StringFormat object with the specified StringFormatFlags enumeration and language.

public StringFormat(
StringFormatFlags options
);

Parameters

options
The StringFormatFlags enumeration for the new StringFormat object.

See Also

StringFormat Class | Aspose.Imaging Namespace | StringFormat Constructor Overload List


StringFormat Constructor (StringFormat)

Initializes a new StringFormat object from the specified existing StringFormat object.

public StringFormat(
StringFormat format
);

Parameters

format
The StringFormat object from which to initialize the new StringFormat object.

Exceptions

Exception Type | Condition
ArgumentNullException | format is null.

See Also

StringFormat Class | Aspose.Imaging Namespace | StringFormat Constructor Overload List


StringFormat Properties

The properties of the StringFormat class are listed below. For a complete list of StringFormat class members, see the StringFormat Members topic.

Public Static Properties

GenericDefault | Gets a generic default StringFormat object.
GenericTypographic | Gets a generic typographic StringFormat object.

Public Instance Properties

Alignment | Gets or sets text alignment information on the vertical plane.
DigitSubstitutionLanguage | Gets or sets the language that is used when local digits are substituted for western digits.
DigitSubstitutionMethod | Gets or sets the method to be used for digit substitution.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
FirstTabOffset | Gets the number of spaces between the beginning of a line of text and the first tab stop.
FormatFlags | Gets or sets a StringFormatFlags enumeration that contains formatting information.
HotkeyPrefix | Gets or sets the HotkeyPrefix object for this StringFormat object.
LineAlignment | Gets or sets the line alignment on the horizontal plane.
TabStops | Gets an array of distances between tab stops in the units specified by the PageUnit property.
Trimming | Gets or sets the StringTrimming enumeration for this StringFormat object.

See Also

StringFormat Class | Aspose.Imaging Namespace


Alignment Property

Aspose.Imaging Documentation

StringFormat.Alignment Property

Gets or sets text alignment information on the vertical plane.

public StringAlignment Alignment {get; set;}

Property Value

A StringAlignment enumeration that specifies text alignment information.

See Also

StringFormat Class | Aspose.Imaging Namespace


DigitSubstitutionLanguage Property

Aspose.Imaging Documentation

StringFormat.DigitSubstitutionLanguage Property

Gets or sets the language that is used when local digits are substituted for western digits.

public int DigitSubstitutionLanguage {get; set;}

Property Value

A National Language Support (NLS) language identifier that identifies the language that will be used when local digits are substituted for western digits. You can pass the LCID property of a CultureInfo object as the NLS language identifier. For example, suppose you create a CultureInfo object by passing the string "ar-EG" to a CultureInfo constructor. If you pass the LCID property of that CultureInfo object along with. Traditional to the SetDigitSubstitution method, then Arabic-Indic digits will be substituted for western digits at display time.

Remarks

The setter is introduced for the obsolete method SetDigitSubstitution.

See Also

StringFormat Class | Aspose.Imaging Namespace


DigitSubstitutionMethod Property

Aspose.Imaging Documentation

StringFormat.DigitSubstitutionMethod Property

Gets or sets the method to be used for digit substitution.

public StringDigitSubstitute DigitSubstitutionMethod {get; set;}

Property Value

A StringDigitSubstitute enumeration value that specifies how to substitute characters in a string that cannot be displayed because they are not supported by the current font.

Remarks

The setter is introduced for the obsolete method SetDigitSubstitution.

See Also

StringFormat Class | Aspose.Imaging Namespace


FirstTabOffset Property

Aspose.Imaging Documentation

StringFormat.FirstTabOffset Property

Gets the number of spaces between the beginning of a line of text and the first tab stop.

public float FirstTabOffset {get;}

Property Value

The first tab offset.

Remarks

The property is introduced for removed method GetTabStops.

See Also

StringFormat Class | Aspose.Imaging Namespace


FormatFlags Property

Aspose.Imaging Documentation

StringFormat.FormatFlags Property

Gets or sets a StringFormatFlags enumeration that contains formatting information.

public StringFormatFlags FormatFlags {get; set;}

Property Value

A StringFormatFlags enumeration that contains formatting information.

See Also

StringFormat Class | Aspose.Imaging Namespace


GenericDefault Property

Aspose.Imaging Documentation

StringFormat.GenericDefault Property

Gets a generic default StringFormat object.

public static StringFormat GenericDefault {get;}

Property Value

The generic default StringFormat object.

See Also

StringFormat Class | Aspose.Imaging Namespace


GenericTypographic Property

Aspose.Imaging Documentation

StringFormat.GenericTypographic Property

Gets a generic typographic StringFormat object.

public static StringFormat GenericTypographic {get;}

Property Value

A generic typographic StringFormat object.

See Also

StringFormat Class | Aspose.Imaging Namespace


HotkeyPrefix Property

Aspose.Imaging Documentation

StringFormat.HotkeyPrefix Property

Gets or sets the HotkeyPrefix object for this StringFormat object.

public HotkeyPrefix HotkeyPrefix {get; set;}

Property Value

The HotkeyPrefix object for this StringFormat object, the default is None.

See Also

StringFormat Class | Aspose.Imaging Namespace


LineAlignment Property

Aspose.Imaging Documentation

StringFormat.LineAlignment Property

Gets or sets the line alignment on the horizontal plane.

public StringAlignment LineAlignment {get; set;}

Property Value

A StringAlignment enumeration that represents the line alignment.

See Also

StringFormat Class | Aspose.Imaging Namespace


TabStops Property

Aspose.Imaging Documentation

StringFormat.TabStops Property

Gets an array of distances between tab stops in the units specified by the PageUnit property.

public float[] TabStops {get;}

Property Value

The tab stops.

Remarks

The property is introduced for removed method GetTabStops.

See Also

StringFormat Class | Aspose.Imaging Namespace


Trimming Property

Aspose.Imaging Documentation

StringFormat.Trimming Property

Gets or sets the StringTrimming enumeration for this StringFormat object.

public StringTrimming Trimming {get; set;}

Property Value

A StringTrimming enumeration that indicates how text drawn with this StringFormat object is trimmed when it exceeds the edges of the layout rectangle.

See Also

StringFormat Class | Aspose.Imaging Namespace


StringFormat Methods

The methods of the StringFormat class are listed below. For a complete list of StringFormat class members, see the StringFormat Members topic.

Public Instance Methods

DeepClone | Creates a deep clone of this StringFormat object.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetTabStops | Sets tab stops for this StringFormat object.
ToString | Converts this StringFormat object to a human-readable string.

See Also

StringFormat Class | Aspose.Imaging Namespace


StringFormat.DeepClone Method

Creates a deep clone of this StringFormat object.

public StringFormat DeepClone();

Return Value

The deep clone of the current StringFormat.

See Also

StringFormat Class | Aspose.Imaging Namespace


StringFormat.SetTabStops Method

Sets tab stops for this StringFormat object.

public void SetTabStops(
float firstTabOffset,
float[] tabStops
);

Parameters

firstTabOffset
The number of spaces between the beginning of a line of text and the first tab stop.
tabStops
An array of distances between tab stops in the units specified by the PageUnit property.

See Also

StringFormat Class | Aspose.Imaging Namespace


StringFormat.ToString Method

Converts this StringFormat object to a human-readable string.

public override string ToString();

Return Value

A string representation of this StringFormat object.

See Also

StringFormat Class | Aspose.Imaging Namespace


StringFormatFlags Enumeration

Specifies the display and layout information for text strings.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum StringFormatFlags

Members

Member Name | Description | Value
DirectionRightToLeft | Text is displayed from right to left. | 1
DirectionVertical | Text is vertically aligned. | 2
FitBlackBox | Parts of characters are allowed to overhang the string's layout rectangle. By default, characters are repositioned to avoid any overhang. | 4
DisplayFormatControl | Control characters such as the left-to-right mark are shown in the output with a representative glyph. | 32
NoFontFallback | Fallback to alternate fonts for characters not supported in the requested font is disabled. Any missing characters are displayed with the fonts missing glyph, usually an open square. | 1024
MeasureTrailingSpaces | Includes the trailing space at the end of each line. By default the boundary rectangle returned by the MeasureString method excludes the space at the end of each line. Set this flag to include that space in measurement. | 2048
NoWrap | Text wrapping between lines when formatting within a rectangle is disabled. This flag is implied when a point is passed instead of a rectangle, or when the specified rectangle has a zero line length. | 4096
LineLimit | Only entire lines are laid out in the formatting rectangle. By default layout continues until the end of the text, or until no more lines are visible as a result of clipping, whichever comes first. Note that the default settings allow the last line to be partially obscured by a formatting rectangle that is not a whole multiple of the line height. To ensure that only whole lines are seen, specify this value and be careful to provide a formatting rectangle at least as tall as the height of one line. | 8192
NoClip | Overhanging parts of glyphs, and unwrapped text reaching outside the formatting rectangle are allowed to show. By default all text and glyph parts reaching outside the formatting rectangle are clipped. | 16384

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


StringTrimming Enumeration

Specifies how to trim characters from a string that does not completely fit into a layout shape.

public enum StringTrimming

Members

Member Name | Description | Value
None | Specifies no trimming. | 0
Character | Specifies that the text is trimmed to the nearest character. | 1
Word | Specifies that text is trimmed to the nearest word. | 2
EllipsisCharacter | Specifies that the text is trimmed to the nearest character, and an ellipsis is inserted at the end of a trimmed line. | 3
EllipsisWord | Specifies that text is trimmed to the nearest word, and an ellipsis is inserted at the end of a trimmed line. | 4
EllipsisPath | The center is removed from trimmed lines and replaced by an ellipsis. The algorithm keeps as much of the last slash-delimited segment of the line as possible. | 5

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


TextRenderingHint Enumeration

Specifies the quality of text rendering.

public enum TextRenderingHint

Members

Member Name | Description | Value
SystemDefault | Each character is drawn using its glyph bitmap, with the system default rendering hint. The text will be drawn using whatever font-smoothing settings the user has selected for the system. | 0
SingleBitPerPixelGridFit | Each character is drawn using its glyph bitmap. Hinting is used to improve character appearance on stems and curvature. | 1
SingleBitPerPixel | Each character is drawn using its glyph bitmap. Hinting is not used. | 2
AntiAliasGridFit | Each character is drawn using its antialiased glyph bitmap with hinting. Much better quality due to antialiasing, but at a higher performance cost. | 3
AntiAlias | Each character is drawn using its antialiased glyph bitmap without hinting. Better quality due to antialiasing. Stem width differences may be noticeable because hinting is turned off. | 4
ClearTypeGridFit | Each character is drawn using its glyph ClearType bitmap with hinting. The highest quality setting. Used to take advantage of ClearType font features. | 5

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


TransparencySupporter Class

The object supporting transparency.

For a list of all members of this type, see TransparencySupporter Members.

System.Object
Aspose.Imaging.TransparencySupporter
Aspose.Imaging.Pen

public class TransparencySupporter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TransparencySupporter Members | Aspose.Imaging Namespace


TransparencySupporter Members

TransparencySupporter overview

Public Instance Constructors

TransparencySupporter Constructor Initializes a new instance of the TransparencySupporter class.

Public Instance Properties

Opacity Gets or sets the object's opacity. The value should be between 0 and 1. Value of 0 means that object is fully visible, value of 1 means the object is fully opaque.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TransparencySupporter Class | Aspose.Imaging Namespace


TransparencySupporter Constructor

Initializes a new instance of the TransparencySupporter class.

public TransparencySupporter();

See Also

TransparencySupporter Class | Aspose.Imaging Namespace


TransparencySupporter Properties

The properties of the TransparencySupporter class are listed below. For a complete list of TransparencySupporter class members, see the TransparencySupporter Members topic.

Public Instance Properties

Opacity Gets or sets the object's opacity. The value should be between 0 and 1. Value of 0 means that object is fully visible, value of 1 means the object is fully opaque.

See Also

TransparencySupporter Class | Aspose.Imaging Namespace


Opacity Property

Aspose.Imaging Documentation

TransparencySupporter.Opacity Property

Gets or sets the object's opacity. The value should be between 0 and 1. Value of 0 means that object is fully visible, value of 1 means the object is fully opaque.

public float Opacity {get; set;}

Property Value

The opacity value.

See Also

TransparencySupporter Class | Aspose.Imaging Namespace


WarpMode Enumeration

Specifies the type of warp transformation applied.

public enum WarpMode

Members

Member Name | Description | Value
Perspective | Specifies a perspective warp. | 0
Bilinear | Specifies a bilinear warp. | 1

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


WrapMode Enumeration

Specifies how a texture or gradient is tiled when it is smaller than the area being filled.

public enum WrapMode

Members

Member Name | Description | Value
Tile | Tiles the gradient or texture. | 0
TileFlipX | Reverses the texture or gradient horizontally and then tiles the texture or gradient. | 1
TileFlipY | Reverses the texture or gradient vertically and then tiles the texture or gradient. | 2
TileFlipXY | Reverses the texture or gradient horizontally and vertically and then tiles the texture or gradient. | 3
Clamp | The texture or gradient is not tiled. | 4

Requirements

Namespace: Aspose.Imaging

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging Namespace


Aspose.Imaging.Brushes

Aspose.Imaging Documentation

Aspose.Imaging.Brushes Namespace

Namespace hierarchy

Classes

Class | Description
HatchBrush | Defines a rectangular brush with a hatch style, a foreground color, and a background color. This class cannot be inherited.
LinearGradientBrush | Encapsulates a Brush with a linear gradient. This class cannot be inherited.
LinearGradientBrushBase | Represents a Brush with gradient capabilities and appropriate properties.
LinearMulticolorGradientBrush | Represents a Brush with linear gradient defined by multiple colors and appropriate positions. This class cannot be inherited.
PathGradientBrush | Encapsulates a Brush object with a gradient. This class cannot be inherited.
PathGradientBrushBase | Represents a Brush with base path gradient functionality.
PathMulticolorGradientBrush | Encapsulates a Brush object with a gradient. This class cannot be inherited.
SolidBrush | Solid brush is intended for drawing continiously with specific color. This class cannot be inherited.
TextureBrush | Each property of the TextureBrush class is a Brush object that uses an image to fill the interior of a shape. This class cannot be inherited.
TransformBrush | A Brush with transform capabilities.


HatchBrush Class

Defines a rectangular brush with a hatch style, a foreground color, and a background color. This class cannot be inherited.

For a list of all members of this type, see HatchBrush Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.Brush
Aspose.Imaging.Brushes.HatchBrush

public sealed class HatchBrush : Brush

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example shows the creation and usage Pen objects. The example creates a new Image and draw Rectangles on Image surface.

[C#]

//Create an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"C:\temp\sample.bmp", false);

//Create an instance of Image at specified Path
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Create an instance of Graphics and initialize it with Image object
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clear the Graphics sutface with White Color
    graphics.Clear(Aspose.Imaging.Color.White);

    //Create an instance of Pen with color Red and width 5
    Aspose.Imaging.Pen pen = new Pen(Aspose.Imaging.Color.Red, 5);

    //Create an instance of HatchBrush and set its properties
    Aspose.Imaging.Brushes.HatchBrush brush = new HatchBrush();
    brush.BackgroundColor = Color.Wheat;
    brush.ForegroundColor = Color.Red;

    //Create an instance of Pen
    //initialize it with HatchBrush object and width
    Aspose.Imaging.Pen brusedpen = new Pen(brush, 5);

    //Draw Rectangles by specifying Pen object
    graphics.DrawRectangles(pen, new[] { new Rectangle(new Point(210, 210), new Size(100, 100)), new Rectangle(new Point(110, 110), new Size(100, 100)), new Rectangle(new Point(310, 310), new Size(100, 100)) });

    //Draw Rectangles by specifying Pen object
    graphics.DrawRectangles(brusedpen, new[] { new Rectangle(new Point(310, 110), new Size(100, 100)), new Rectangle(new Point(110, 310), new Size(100, 100)) });

    // save all changes.
    image.Save();
}
[Visual Basic]

'Create an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("C:\temp\sample.bmp", False)

'Create an instance of Image at specified Path
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Create an instance of Graphics and initialize it with Image object
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear the Graphics sutface with White Color
    graphics.Clear(Aspose.Imaging.Color.White)

'Create an instance of Pen with color Red and width 5
Dim pen As Aspose.Imaging.Pen = New Pen(Aspose.Imaging.Color.Red, 5)

'Create an instance of HatchBrush and set its properties
Dim brush As Aspose.Imaging.Brushes.HatchBrush = New HatchBrush()
    brush.BackgroundColor = Color.Wheat
    brush.ForegroundColor = Color.Red

'Create an instance of Pen
'initialize it with HatchBrush object and width
Dim brusedpen As Aspose.Imaging.Pen = New Pen(brush, 5)

'Draw Rectangles by specifying Pen object
    graphics.DrawRectangles(pen, New() { New Rectangle(New Point(210, 210), New Size(100, 100)), New Rectangle(New Point(110, 110), New Size(100, 100)), New Rectangle(New Point(310, 310), New Size(100, 100)) })

'Draw Rectangles by specifying Pen object
    graphics.DrawRectangles(brusedpen, New() { New Rectangle(New Point(310, 110), New Size(100, 100)), New Rectangle(New Point(110, 310), New Size(100, 100)) })

' save all changes.
    image.Save()
End Using

Requirements

Namespace: Aspose.Imaging.Brushes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

HatchBrush Members | Aspose.Imaging.Brushes Namespace


HatchBrush Members

HatchBrush overview

Public Instance Constructors

HatchBrush Constructor Initializes a new instance of the HatchBrush class.

Public Instance Properties

BackgroundColor | Gets or sets the color of spaces between the hatch lines.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
ForegroundColor | Gets or sets the color of hatch lines.
HatchStyle | Gets or sets the hatch style of this brush.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HatchBrush Class | Aspose.Imaging.Brushes Namespace


HatchBrush Constructor

Initializes a new instance of the HatchBrush class.

public HatchBrush();

See Also

HatchBrush Class | Aspose.Imaging.Brushes Namespace


HatchBrush Properties

The properties of the HatchBrush class are listed below. For a complete list of HatchBrush class members, see the HatchBrush Members topic.

Public Instance Properties

BackgroundColor | Gets or sets the color of spaces between the hatch lines.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
ForegroundColor | Gets or sets the color of hatch lines.
HatchStyle | Gets or sets the hatch style of this brush.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.

See Also

HatchBrush Class | Aspose.Imaging.Brushes Namespace


BackgroundColor Property

Aspose.Imaging Documentation

HatchBrush.BackgroundColor Property

Gets or sets the color of spaces between the hatch lines.

public Color BackgroundColor {get; set;}

Property Value

The color of spaces between the hatch lines.

See Also

HatchBrush Class | Aspose.Imaging.Brushes Namespace


ForegroundColor Property

Aspose.Imaging Documentation

HatchBrush.ForegroundColor Property

Gets or sets the color of hatch lines.

public Color ForegroundColor {get; set;}

Property Value

The color of hatch lines.

See Also

HatchBrush Class | Aspose.Imaging.Brushes Namespace


HatchStyle Property

Aspose.Imaging Documentation

HatchBrush.HatchStyle Property

Gets or sets the hatch style of this brush.

public HatchStyle HatchStyle {get; set;}

See Also

HatchBrush Class | Aspose.Imaging.Brushes Namespace


LinearGradientBrush Class

Encapsulates a Brush with a linear gradient. This class cannot be inherited.

For a list of all members of this type, see LinearGradientBrush Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.Brush
Aspose.Imaging.Brushes.TransformBrush
Aspose.Imaging.Brushes.LinearGradientBrushBase
Aspose.Imaging.Brushes.LinearGradientBrush

public sealed class LinearGradientBrush : LinearGradientBrushBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Brushes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

LinearGradientBrush Members | Aspose.Imaging.Brushes Namespace


LinearGradientBrush Members

LinearGradientBrush overview

Public Instance Constructors

LinearGradientBrush Overloaded. Initializes a new instance of the LinearGradientBrush class.

Public Instance Properties

Angle (inherited from LinearGradientBrushBase) | Gets or sets the gradient angle.
Blend | Gets or sets a Blend that specifies positions and factors that define a custom falloff for the gradient.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
EndColor | Gets or sets the ending gradient color.
GammaCorrection (inherited from LinearGradientBrushBase) | Gets or sets a value indicating whether gamma correction is enabled for this LinearGradientBrushBase.
InterpolationColors | Obsolete. Gets or sets a ColorBlend that defines a multicolor linear gradient.
IsAngleScalable (inherited from LinearGradientBrushBase) | Gets or sets a value indicating whether Angle is changed during trasnformations with this LinearGradientBrushBase.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
LinearColors | Obsolete. Gets or sets the starting and ending colors of the gradient.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
Rectangle (inherited from LinearGradientBrushBase) | Gets or sets a rectangular region that defines the starting and ending points of the gradient.
StartColor | Gets or sets the starting gradient color.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform (inherited from TransformBrush) | Overloaded. Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.
ResetTransform (inherited from TransformBrush) | Resets the Transform property to identity.
RotateTransform (inherited from TransformBrush) | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform (inherited from TransformBrush) | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
SetBlendTriangularShape | Overloaded. Creates a linear gradient with a center color and a linear falloff to a single color on both ends.
SetSigmaBellShape | Overloaded. Creates a gradient falloff based on a bell-shaped curve.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform (inherited from TransformBrush) | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace


LinearGradientBrush Constructor

Initializes a new instance of the LinearGradientBrush class with default parameters. The starting color is black, the ending color is white, the angle is 45 degrees and the rectangle is located in (0,0) with size (1,1).

Overload List

Initializes a new instance of the LinearGradientBrush class with default parameters. The starting color is black, the ending color is white, the angle is 45 degrees and the rectangle is located in (0,0) with size (1,1).

public LinearGradientBrush();

Initializes a new instance of the LinearGradientBrush class with the specified points and colors.

public LinearGradientBrush(Point,Point,Color,Color);

Initializes a new instance of the LinearGradientBrush class with the specified points and colors.

public LinearGradientBrush(PointF,PointF,Color,Color);

Initializes a new instance of the LinearGradientBrush class based on a rectangle, starting and ending colors, and an orientation angle.

public LinearGradientBrush(Rectangle,Color,Color,float);

Initializes a new instance of the LinearGradientBrush class based on a rectangle, starting and ending colors, and an orientation angle.

public LinearGradientBrush(Rectangle,Color,Color,float,bool);

Initializes a new instance of the LinearGradientBrush class based on a rectangle, starting and ending colors, and an orientation angle.

public LinearGradientBrush(RectangleF,Color,Color,float);

Initializes a new instance of the LinearGradientBrush class based on a rectangle, starting and ending colors, and an orientation angle.

public LinearGradientBrush(RectangleF,Color,Color,float,bool);

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace


LinearGradientBrush Constructor ()

Initializes a new instance of the LinearGradientBrush class with default parameters. The starting color is black, the ending color is white, the angle is 45 degrees and the rectangle is located in (0,0) with size (1,1).

public LinearGradientBrush();

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (Point, Point, Color, Color)

Initializes a new instance of the LinearGradientBrush class with the specified points and colors.

public LinearGradientBrush(
Point point1,
Point point2,
Color color1,
Color color2
);

Parameters

point1
A Point structure that represents the starting point of the linear gradient.
point2
A Point structure that represents the endpoint of the linear gradient.
color1
A Color structure that represents the starting color of the linear gradient.
color2
A Color structure that represents the ending color of the linear gradient.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (PointF, PointF, Color, Color)

Initializes a new instance of the LinearGradientBrush class with the specified points and colors.

public LinearGradientBrush(
PointF point1,
PointF point2,
Color color1,
Color color2
);

Parameters

point1
A PointF structure that represents the starting point of the linear gradient.
point2
A PointF structure that represents the endpoint of the linear gradient.
color1
A Color structure that represents the starting color of the linear gradient.
color2
A Color structure that represents the ending color of the linear gradient.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (Rectangle, Color, Color, Single)

Initializes a new instance of the LinearGradientBrush class based on a rectangle, starting and ending colors, and an orientation angle.

public LinearGradientBrush(
Rectangle rect,
Color color1,
Color color2,
float angle
);

Parameters

rect
A RectangleF structure that specifies the bounds of the linear gradient.
color1
A Color structure that represents the starting color for the gradient.
color2
A Color structure that represents the ending color for the gradient.
angle
The angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (RectangleF, Color, Color, Single)

Initializes a new instance of the LinearGradientBrush class based on a rectangle, starting and ending colors, and an orientation angle.

public LinearGradientBrush(
RectangleF rect,
Color color1,
Color color2,
float angle
);

Parameters

rect
A RectangleF structure that specifies the bounds of the linear gradient.
color1
A Color structure that represents the starting color for the gradient.
color2
A Color structure that represents the ending color for the gradient.
angle
The angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (Rectangle, Color, Color, Single, Boolean)

Initializes a new instance of the LinearGradientBrush class based on a rectangle, starting and ending colors, and an orientation angle.

public LinearGradientBrush(
Rectangle rect,
Color color1,
Color color2,
float angle,
bool isAngleScalable
);

Parameters

rect
A RectangleF structure that specifies the bounds of the linear gradient.
color1
A Color structure that represents the starting color for the gradient.
color2
A Color structure that represents the ending color for the gradient.
angle
The angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.
isAngleScalable
if set to true the angle is changed during transformations with this LinearGradientBrush.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Constructor (RectangleF, Color, Color, Single, Boolean)

Initializes a new instance of the LinearGradientBrush class based on a rectangle, starting and ending colors, and an orientation angle.

public LinearGradientBrush(
RectangleF rect,
Color color1,
Color color2,
float angle,
bool isAngleScalable
);

Parameters

rect
A RectangleF structure that specifies the bounds of the linear gradient.
color1
A Color structure that represents the starting color for the gradient.
color2
A Color structure that represents the ending color for the gradient.
angle
The angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.
isAngleScalable
if set to true the angle is changed during transformations with this LinearGradientBrush.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrush Constructor Overload List


LinearGradientBrush Properties

The properties of the LinearGradientBrush class are listed below. For a complete list of LinearGradientBrush class members, see the LinearGradientBrush Members topic.

Public Instance Properties

Angle (inherited from LinearGradientBrushBase) | Gets or sets the gradient angle.
Blend | Gets or sets a Blend that specifies positions and factors that define a custom falloff for the gradient.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
EndColor | Gets or sets the ending gradient color.
GammaCorrection (inherited from LinearGradientBrushBase) | Gets or sets a value indicating whether gamma correction is enabled for this LinearGradientBrushBase.
InterpolationColors | Obsolete. Gets or sets a ColorBlend that defines a multicolor linear gradient.
IsAngleScalable (inherited from LinearGradientBrushBase) | Gets or sets a value indicating whether Angle is changed during trasnformations with this LinearGradientBrushBase.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
LinearColors | Obsolete. Gets or sets the starting and ending colors of the gradient.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
Rectangle (inherited from LinearGradientBrushBase) | Gets or sets a rectangular region that defines the starting and ending points of the gradient.
StartColor | Gets or sets the starting gradient color.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace


Blend Property

Aspose.Imaging Documentation

LinearGradientBrush.Blend Property

Gets or sets a Blend that specifies positions and factors that define a custom falloff for the gradient.

public Blend Blend {get; set;}

Property Value

A Blend that represents a custom falloff for the gradient.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace


EndColor Property

Aspose.Imaging Documentation

LinearGradientBrush.EndColor Property

Gets or sets the ending gradient color.

public Color EndColor {get; set;}

Property Value

The ending gradient color.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace


InterpolationColors Property

Aspose.Imaging Documentation

LinearGradientBrush.InterpolationColors Property

NOTE: This property is now obsolete.

This property is not used anymore in this class. Use instance of the LinearMulticolorGradientBrush class instead.

Gets or sets a ColorBlend that defines a multicolor linear gradient.

public ColorBlend InterpolationColors {get; set;}

Property Value

A ColorBlend that defines a multicolor linear gradient.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace


LinearColors Property

Aspose.Imaging Documentation

LinearGradientBrush.LinearColors Property

NOTE: This property is now obsolete.

Use StartColor and EndColor properties instead.

Gets or sets the starting and ending colors of the gradient.

public Color[] LinearColors {get; set;}

Property Value

An array of two Color structures that represents the starting and ending colors of the gradient.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace


StartColor Property

Aspose.Imaging Documentation

LinearGradientBrush.StartColor Property

Gets or sets the starting gradient color.

public Color StartColor {get; set;}

Property Value

The starting gradient color.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace


LinearGradientBrush Methods

The methods of the LinearGradientBrush class are listed below. For a complete list of LinearGradientBrush class members, see the LinearGradientBrush Members topic.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform (inherited from TransformBrush) | Overloaded. Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.
ResetTransform (inherited from TransformBrush) | Resets the Transform property to identity.
RotateTransform (inherited from TransformBrush) | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform (inherited from TransformBrush) | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
SetBlendTriangularShape | Overloaded. Creates a linear gradient with a center color and a linear falloff to a single color on both ends.
SetSigmaBellShape | Overloaded. Creates a gradient falloff based on a bell-shaped curve.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform (inherited from TransformBrush) | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace


SetBlendTriangularShape Method

Aspose.Imaging Documentation

LinearGradientBrush.SetBlendTriangularShape Method

Creates a linear gradient with a center color and a linear falloff to a single color on both ends.

Overload List

Creates a linear gradient with a center color and a linear falloff to a single color on both ends.

public void SetBlendTriangularShape(float);

Creates a linear gradient with a center color and a linear falloff to a single color on both ends.

public void SetBlendTriangularShape(float,float);

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace


LinearGradientBrush.SetBlendTriangularShape Method (Single)

Creates a linear gradient with a center color and a linear falloff to a single color on both ends.

public void SetBlendTriangularShape(
float focus
);

Parameters

focus
A value from 0 through 1 that specifies the center of the gradient (the point where the gradient is composed of only the ending color).

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrush.SetBlendTriangularShape Overload List


LinearGradientBrush.SetBlendTriangularShape Method (Single, Single)

Creates a linear gradient with a center color and a linear falloff to a single color on both ends.

public void SetBlendTriangularShape(
float focus,
float scale
);

Parameters

focus
A value from 0 through 1 that specifies the center of the gradient (the point where the gradient is composed of only the ending color).
scale
A value from 0 through1 that specifies how fast the colors falloff from the starting color to focus (ending color)

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrush.SetBlendTriangularShape Overload List


SetSigmaBellShape Method

Aspose.Imaging Documentation

LinearGradientBrush.SetSigmaBellShape Method

Creates a gradient falloff based on a bell-shaped curve.

Overload List

Creates a gradient falloff based on a bell-shaped curve.

public void SetSigmaBellShape(float);

Creates a gradient falloff based on a bell-shaped curve.

public void SetSigmaBellShape(float,float);

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace


LinearGradientBrush.SetSigmaBellShape Method (Single)

Creates a gradient falloff based on a bell-shaped curve.

public void SetSigmaBellShape(
float focus
);

Parameters

focus
A value from 0 through 1 that specifies the center of the gradient (the point where the starting color and ending color are blended equally).

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrush.SetSigmaBellShape Overload List


LinearGradientBrush.SetSigmaBellShape Method (Single, Single)

Creates a gradient falloff based on a bell-shaped curve.

public void SetSigmaBellShape(
float focus,
float scale
);

Parameters

focus
A value from 0 through 1 that specifies the center of the gradient (the point where the gradient is composed of only the ending color).
scale
A value from 0 through 1 that specifies how fast the colors falloff from the focus.

See Also

LinearGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrush.SetSigmaBellShape Overload List


LinearGradientBrushBase Class

Represents a Brush with gradient capabilities and appropriate properties.

For a list of all members of this type, see LinearGradientBrushBase Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.Brush
Aspose.Imaging.Brushes.TransformBrush
Aspose.Imaging.Brushes.LinearGradientBrushBase
Aspose.Imaging.Brushes.LinearGradientBrush
Aspose.Imaging.Brushes.LinearMulticolorGradientBrush

public abstract class LinearGradientBrushBase : TransformBrush

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Brushes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

LinearGradientBrushBase Members | Aspose.Imaging.Brushes Namespace


LinearGradientBrushBase Members

LinearGradientBrushBase overview

Public Instance Properties

Angle | Gets or sets the gradient angle.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
GammaCorrection | Gets or sets a value indicating whether gamma correction is enabled for this LinearGradientBrushBase.
IsAngleScalable | Gets or sets a value indicating whether Angle is changed during trasnformations with this LinearGradientBrushBase.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
Rectangle | Gets or sets a rectangular region that defines the starting and ending points of the gradient.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform (inherited from TransformBrush) | Overloaded. Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.
ResetTransform (inherited from TransformBrush) | Resets the Transform property to identity.
RotateTransform (inherited from TransformBrush) | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform (inherited from TransformBrush) | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform (inherited from TransformBrush) | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

Protected Instance Constructors

LinearGradientBrushBase Overloaded. Initializes a new instance of the LinearGradientBrushBase class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReleaseManagedResources (inherited from DisposableObject) | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

LinearGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


LinearGradientBrushBase Constructor

Initializes a new instance of the LinearGradientBrushBase class with default parameters. The angle is 45 degrees and the rectangle is located in (0,0) with size (1,1).

Overload List

Initializes a new instance of the LinearGradientBrushBase class with default parameters. The angle is 45 degrees and the rectangle is located in (0,0) with size (1,1).

protected LinearGradientBrushBase();

Initializes a new instance of the LinearGradientBrushBase class. The gradient rectangle is calculated from the specified points.

protected LinearGradientBrushBase(Point,Point);

Initializes a new instance of the LinearGradientBrushBase class. The gradient rectangle is calculated from the specified points.

protected LinearGradientBrushBase(PointF,PointF);

Initializes a new instance of the LinearGradientBrushBase class based on a rectangle and an orientation angle.

protected LinearGradientBrushBase(Rectangle,float,bool);

Initializes a new instance of the LinearGradientBrushBase class based on a rectangle, starting and ending colors, and an orientation angle.

protected LinearGradientBrushBase(RectangleF,float,bool);

See Also

LinearGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


LinearGradientBrushBase Constructor ()

Initializes a new instance of the LinearGradientBrushBase class with default parameters. The angle is 45 degrees and the rectangle is located in (0,0) with size (1,1).

protected LinearGradientBrushBase();

See Also

LinearGradientBrushBase Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrushBase Constructor Overload List


LinearGradientBrushBase Constructor (Point, Point)

Initializes a new instance of the LinearGradientBrushBase class. The gradient rectangle is calculated from the specified points.

protected LinearGradientBrushBase(
Point point1,
Point point2
);

Parameters

point1
A Point structure that represents the starting point of the linear gradient.
point2
A Point structure that represents the endpoint of the linear gradient.

See Also

LinearGradientBrushBase Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrushBase Constructor Overload List


LinearGradientBrushBase Constructor (PointF, PointF)

Initializes a new instance of the LinearGradientBrushBase class. The gradient rectangle is calculated from the specified points.

protected LinearGradientBrushBase(
PointF point1,
PointF point2
);

Parameters

point1
A PointF structure that represents the starting point of the linear gradient.
point2
A PointF structure that represents the endpoint of the linear gradient.

See Also

LinearGradientBrushBase Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrushBase Constructor Overload List


LinearGradientBrushBase Constructor (Rectangle, Single, Boolean)

Initializes a new instance of the LinearGradientBrushBase class based on a rectangle and an orientation angle.

protected LinearGradientBrushBase(
Rectangle rect,
float angle,
bool isAngleScalable
);

Parameters

rect
A RectangleF structure that specifies the bounds of the linear gradient.
angle
The angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.
isAngleScalable
if set to true the angle is changed during transformations applied to this LinearGradientBrushBase.

See Also

LinearGradientBrushBase Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrushBase Constructor Overload List


LinearGradientBrushBase Constructor (RectangleF, Single, Boolean)

Initializes a new instance of the LinearGradientBrushBase class based on a rectangle, starting and ending colors, and an orientation angle.

protected LinearGradientBrushBase(
RectangleF rect,
float angle,
bool isAngleScalable
);

Parameters

rect
A RectangleF structure that specifies the bounds of the linear gradient.
angle
The angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.
isAngleScalable
if set to true the angle is changed during transformations with this LinearGradientBrushBase.

See Also

LinearGradientBrushBase Class | Aspose.Imaging.Brushes Namespace | LinearGradientBrushBase Constructor Overload List


LinearGradientBrushBase Properties

The properties of the LinearGradientBrushBase class are listed below. For a complete list of LinearGradientBrushBase class members, see the LinearGradientBrushBase Members topic.

Public Instance Properties

Angle | Gets or sets the gradient angle.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
GammaCorrection | Gets or sets a value indicating whether gamma correction is enabled for this LinearGradientBrushBase.
IsAngleScalable | Gets or sets a value indicating whether Angle is changed during trasnformations with this LinearGradientBrushBase.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
Rectangle | Gets or sets a rectangular region that defines the starting and ending points of the gradient.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

See Also

LinearGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


Angle Property

Aspose.Imaging Documentation

LinearGradientBrushBase.Angle Property

Gets or sets the gradient angle.

public float Angle {get; set;}

Property Value

The gradient angle.

See Also

LinearGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


GammaCorrection Property

Aspose.Imaging Documentation

LinearGradientBrushBase.GammaCorrection Property

Gets or sets a value indicating whether gamma correction is enabled for this LinearGradientBrushBase.

public bool GammaCorrection {get; set;}

Property Value

The value is true if gamma correction is enabled for this LinearGradientBrushBase; otherwise, false.

See Also

LinearGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


IsAngleScalable Property

Aspose.Imaging Documentation

LinearGradientBrushBase.IsAngleScalable Property

Gets or sets a value indicating whether Angle is changed during trasnformations with this LinearGradientBrushBase.

public bool IsAngleScalable {get; set;}

Property Value

true if Angle is changed during transformations with this LinearGradientBrushBase; otherwise, false.

See Also

LinearGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


Rectangle Property

Aspose.Imaging Documentation

LinearGradientBrushBase.Rectangle Property

Gets or sets a rectangular region that defines the starting and ending points of the gradient.

public RectangleF Rectangle {get; set;}

Property Value

A RectangleF structure that specifies the starting and ending points of the gradient.

See Also

LinearGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


LinearMulticolorGradientBrush Class

Represents a Brush with linear gradient defined by multiple colors and appropriate positions. This class cannot be inherited.

For a list of all members of this type, see LinearMulticolorGradientBrush Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.Brush
Aspose.Imaging.Brushes.TransformBrush
Aspose.Imaging.Brushes.LinearGradientBrushBase
Aspose.Imaging.Brushes.LinearMulticolorGradientBrush

public sealed class LinearMulticolorGradientBrush : LinearGradientBrushBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Brushes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

LinearMulticolorGradientBrush Members | Aspose.Imaging.Brushes Namespace


LinearMulticolorGradientBrush Members

LinearMulticolorGradientBrush overview

Public Instance Constructors

LinearMulticolorGradientBrush Overloaded. Initializes a new instance of the LinearMulticolorGradientBrush class.

Public Instance Properties

Angle (inherited from LinearGradientBrushBase) | Gets or sets the gradient angle.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
GammaCorrection (inherited from LinearGradientBrushBase) | Gets or sets a value indicating whether gamma correction is enabled for this LinearGradientBrushBase.
InterpolationColors | Gets or sets a ColorBlend that defines a multicolor linear gradient.
IsAngleScalable (inherited from LinearGradientBrushBase) | Gets or sets a value indicating whether Angle is changed during trasnformations with this LinearGradientBrushBase.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
Rectangle (inherited from LinearGradientBrushBase) | Gets or sets a rectangular region that defines the starting and ending points of the gradient.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform (inherited from TransformBrush) | Overloaded. Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.
ResetTransform (inherited from TransformBrush) | Resets the Transform property to identity.
RotateTransform (inherited from TransformBrush) | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform (inherited from TransformBrush) | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform (inherited from TransformBrush) | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

See Also

LinearMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace


LinearMulticolorGradientBrush Constructor

Initializes a new instance of the LinearMulticolorGradientBrush class with default parameters. The starting color is black, the ending color is white, the angle is 45 degrees and the rectangle is located in (0,0) with size (1,1).

Overload List

Initializes a new instance of the LinearMulticolorGradientBrush class with default parameters. The starting color is black, the ending color is white, the angle is 45 degrees and the rectangle is located in (0,0) with size (1,1).

public LinearMulticolorGradientBrush();

Initializes a new instance of the LinearMulticolorGradientBrush class with the specified points.

public LinearMulticolorGradientBrush(Point,Point);

Initializes a new instance of the LinearMulticolorGradientBrush class with the specified points.

public LinearMulticolorGradientBrush(PointF,PointF);

Initializes a new instance of the LinearMulticolorGradientBrush class based on a rectangle and an orientation angle.

public LinearMulticolorGradientBrush(Rectangle,float);

Initializes a new instance of the LinearMulticolorGradientBrush class based on a rectangle and an orientation angle.

public LinearMulticolorGradientBrush(Rectangle,float,bool);

Initializes a new instance of the LinearMulticolorGradientBrush class based on a rectangle and an orientation angle.

public LinearMulticolorGradientBrush(RectangleF,float);

Initializes a new instance of the LinearMulticolorGradientBrush class based on a rectangle and an orientation angle.

public LinearMulticolorGradientBrush(RectangleF,float,bool);

See Also

LinearMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace


LinearMulticolorGradientBrush Constructor ()

Initializes a new instance of the LinearMulticolorGradientBrush class with default parameters. The starting color is black, the ending color is white, the angle is 45 degrees and the rectangle is located in (0,0) with size (1,1).

public LinearMulticolorGradientBrush();

See Also

LinearMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearMulticolorGradientBrush Constructor Overload List


LinearMulticolorGradientBrush Constructor (Point, Point)

Initializes a new instance of the LinearMulticolorGradientBrush class with the specified points.

public LinearMulticolorGradientBrush(
Point point1,
Point point2
);

Parameters

point1
A Point structure that represents the starting point of the linear gradient.
point2
A Point structure that represents the endpoint of the linear gradient.

See Also

LinearMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearMulticolorGradientBrush Constructor Overload List


LinearMulticolorGradientBrush Constructor (PointF, PointF)

Initializes a new instance of the LinearMulticolorGradientBrush class with the specified points.

public LinearMulticolorGradientBrush(
PointF point1,
PointF point2
);

Parameters

point1
A PointF structure that represents the starting point of the linear gradient.
point2
A PointF structure that represents the endpoint of the linear gradient.

See Also

LinearMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearMulticolorGradientBrush Constructor Overload List


LinearMulticolorGradientBrush Constructor (Rectangle, Single)

Initializes a new instance of the LinearMulticolorGradientBrush class based on a rectangle and an orientation angle.

public LinearMulticolorGradientBrush(
Rectangle rect,
float angle
);

Parameters

rect
A RectangleF structure that specifies the bounds of the linear gradient.
angle
The angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.

See Also

LinearMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearMulticolorGradientBrush Constructor Overload List


LinearMulticolorGradientBrush Constructor (RectangleF, Single)

Initializes a new instance of the LinearMulticolorGradientBrush class based on a rectangle and an orientation angle.

public LinearMulticolorGradientBrush(
RectangleF rect,
float angle
);

Parameters

rect
A RectangleF structure that specifies the bounds of the linear gradient.
angle
The angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.

See Also

LinearMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearMulticolorGradientBrush Constructor Overload List


LinearMulticolorGradientBrush Constructor (Rectangle, Single, Boolean)

Initializes a new instance of the LinearMulticolorGradientBrush class based on a rectangle and an orientation angle.

public LinearMulticolorGradientBrush(
Rectangle rect,
float angle,
bool isAngleScalable
);

Parameters

rect
A RectangleF structure that specifies the bounds of the linear gradient.
angle
The angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.
isAngleScalable
if set to true the angle is changed during transformations with this LinearMulticolorGradientBrush.

See Also

LinearMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearMulticolorGradientBrush Constructor Overload List


LinearMulticolorGradientBrush Constructor (RectangleF, Single, Boolean)

Initializes a new instance of the LinearMulticolorGradientBrush class based on a rectangle and an orientation angle.

public LinearMulticolorGradientBrush(
RectangleF rect,
float angle,
bool isAngleScalable
);

Parameters

rect
A RectangleF structure that specifies the bounds of the linear gradient.
angle
The angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.
isAngleScalable
if set to true the angle is changed during transformations with this LinearMulticolorGradientBrush.

See Also

LinearMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace | LinearMulticolorGradientBrush Constructor Overload List


LinearMulticolorGradientBrush Properties

The properties of the LinearMulticolorGradientBrush class are listed below. For a complete list of LinearMulticolorGradientBrush class members, see the LinearMulticolorGradientBrush Members topic.

Public Instance Properties

Angle (inherited from LinearGradientBrushBase) | Gets or sets the gradient angle.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
GammaCorrection (inherited from LinearGradientBrushBase) | Gets or sets a value indicating whether gamma correction is enabled for this LinearGradientBrushBase.
InterpolationColors | Gets or sets a ColorBlend that defines a multicolor linear gradient.
IsAngleScalable (inherited from LinearGradientBrushBase) | Gets or sets a value indicating whether Angle is changed during trasnformations with this LinearGradientBrushBase.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
Rectangle (inherited from LinearGradientBrushBase) | Gets or sets a rectangular region that defines the starting and ending points of the gradient.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

See Also

LinearMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace


InterpolationColors Property

Aspose.Imaging Documentation

LinearMulticolorGradientBrush.InterpolationColors Property

Gets or sets a ColorBlend that defines a multicolor linear gradient.

public ColorBlend InterpolationColors {get; set;}

Property Value

A ColorBlend that defines a multicolor linear gradient.

See Also

LinearMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace


PathGradientBrush Class

Encapsulates a Brush object with a gradient. This class cannot be inherited.

For a list of all members of this type, see PathGradientBrush Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.Brush
Aspose.Imaging.Brushes.TransformBrush
Aspose.Imaging.Brushes.PathGradientBrushBase
Aspose.Imaging.Brushes.PathGradientBrush

public sealed class PathGradientBrush : PathGradientBrushBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The center color is white by default. A user can changed this value at any time later.

The surround colors array is initialized by single element containing white color by default. The surround colors may be changed later, however at least single element is required when setting up the surround colors.

See the Blend for more details about its initialization.

Requirements

Namespace: Aspose.Imaging.Brushes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PathGradientBrush Members | Aspose.Imaging.Brushes Namespace


PathGradientBrush Members

PathGradientBrush overview

Public Instance Constructors

PathGradientBrush Overloaded. Initializes a new instance of the PathGradientBrush class.

Public Instance Properties

Blend | Gets or sets a Blend that specifies positions and factors that define a custom falloff for the gradient.
CenterColor | Gets or sets the color at the center of the path gradient.
CenterPoint (inherited from PathGradientBrushBase) | Gets or sets the center point of the path gradient.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
FocusScales (inherited from PathGradientBrushBase) | Gets or sets the focus point for the gradient falloff.
GraphicsPath (inherited from PathGradientBrushBase) | Gets the graphics path this brush was build upon.
InterpolationColors | Obsolete. Gets or sets a ColorBlend that defines a multicolor linear gradient.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
PathPoints (inherited from PathGradientBrushBase) | Gets the path points this brush was build upon.
SurroundColors | Gets or sets an array of colors that correspond to the points in the path this PathGradientBrush fills.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform (inherited from TransformBrush) | Overloaded. Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.
ResetTransform (inherited from TransformBrush) | Resets the Transform property to identity.
RotateTransform (inherited from TransformBrush) | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform (inherited from TransformBrush) | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
SetBlendTriangularShape | Overloaded. Creates a gradient with a center color and a linear falloff to one surrounding color.
SetSigmaBellShape | Overloaded. Creates a gradient brush that changes color starting from the center of the path outward to the path's boundary. The transition from one color to another is based on a bell-shaped curve.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform (inherited from TransformBrush) | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace


PathGradientBrush Constructor

Initializes a new instance of the PathGradientBrush class with the specified points.

Overload List

Initializes a new instance of the PathGradientBrush class with the specified path.

public PathGradientBrush(GraphicsPath);

Initializes a new instance of the PathGradientBrush class with the specified points.

public PathGradientBrush(Point[]);

Initializes a new instance of the PathGradientBrush class with the specified points and wrap mode.

public PathGradientBrush(Point[],WrapMode);

Initializes a new instance of the PathGradientBrush class with the specified points.

public PathGradientBrush(PointF[]);

Initializes a new instance of the PathGradientBrush class with the specified points and wrap mode.

public PathGradientBrush(PointF[],WrapMode);

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace


PathGradientBrush Constructor (PointF[])

Initializes a new instance of the PathGradientBrush class with the specified points.

public PathGradientBrush(
PointF[] points
);

Parameters

points
An array of PointF structures that represents the points that make up the vertices of the path.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathGradientBrush Constructor Overload List


PathGradientBrush Constructor (PointF[], WrapMode)

Initializes a new instance of the PathGradientBrush class with the specified points and wrap mode.

public PathGradientBrush(
PointF[] points,
WrapMode wrapMode
);

Parameters

points
An array of PointF structures that represents the points that make up the vertices of the path.
wrapMode
A WrapMode that specifies how fills drawn with this PathGradientBrush are tiled.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathGradientBrush Constructor Overload List


PathGradientBrush Constructor (Point[])

Initializes a new instance of the PathGradientBrush class with the specified points.

public PathGradientBrush(
Point[] points
);

Parameters

points
An array of Point structures that represents the points that make up the vertices of the path.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathGradientBrush Constructor Overload List


PathGradientBrush Constructor (Point[], WrapMode)

Initializes a new instance of the PathGradientBrush class with the specified points and wrap mode.

public PathGradientBrush(
Point[] points,
WrapMode wrapMode
);

Parameters

points
An array of Point structures that represents the points that make up the vertices of the path.
wrapMode
A WrapMode that specifies how fills drawn with this PathGradientBrush are tiled.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathGradientBrush Constructor Overload List


PathGradientBrush Constructor (GraphicsPath)

Initializes a new instance of the PathGradientBrush class with the specified path.

public PathGradientBrush(
GraphicsPath path
);

Parameters

path
The GraphicsPath that defines the area filled by this PathGradientBrush.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathGradientBrush Constructor Overload List


PathGradientBrush Properties

The properties of the PathGradientBrush class are listed below. For a complete list of PathGradientBrush class members, see the PathGradientBrush Members topic.

Public Instance Properties

Blend | Gets or sets a Blend that specifies positions and factors that define a custom falloff for the gradient.
CenterColor | Gets or sets the color at the center of the path gradient.
CenterPoint (inherited from PathGradientBrushBase) | Gets or sets the center point of the path gradient.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
FocusScales (inherited from PathGradientBrushBase) | Gets or sets the focus point for the gradient falloff.
GraphicsPath (inherited from PathGradientBrushBase) | Gets the graphics path this brush was build upon.
InterpolationColors | Obsolete. Gets or sets a ColorBlend that defines a multicolor linear gradient.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
PathPoints (inherited from PathGradientBrushBase) | Gets the path points this brush was build upon.
SurroundColors | Gets or sets an array of colors that correspond to the points in the path this PathGradientBrush fills.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace


Blend Property

Aspose.Imaging Documentation

PathGradientBrush.Blend Property

Gets or sets a Blend that specifies positions and factors that define a custom falloff for the gradient.

public Blend Blend {get; set;}

Property Value

A Blend that represents a custom falloff for the gradient.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace


CenterColor Property

Aspose.Imaging Documentation

PathGradientBrush.CenterColor Property

Gets or sets the color at the center of the path gradient.

public Color CenterColor {get; set;}

Property Value

A Color that represents the color at the center of the path gradient.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace


InterpolationColors Property

Aspose.Imaging Documentation

PathGradientBrush.InterpolationColors Property

NOTE: This property is now obsolete.

This property is not used in this class anymore. Use PathMulticolorGradientBrush class instead.

Gets or sets a ColorBlend that defines a multicolor linear gradient.

public ColorBlend InterpolationColors {get; set;}

Property Value

A ColorBlend that defines a multicolor linear gradient.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace


SurroundColors Property

Aspose.Imaging Documentation

PathGradientBrush.SurroundColors Property

Gets or sets an array of colors that correspond to the points in the path this PathGradientBrush fills.

public Color[] SurroundColors {get; set;}

Property Value

An array of Color structures that represents the colors associated with each point in the path this PathGradientBrush fills.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace


PathGradientBrush Methods

The methods of the PathGradientBrush class are listed below. For a complete list of PathGradientBrush class members, see the PathGradientBrush Members topic.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform (inherited from TransformBrush) | Overloaded. Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.
ResetTransform (inherited from TransformBrush) | Resets the Transform property to identity.
RotateTransform (inherited from TransformBrush) | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform (inherited from TransformBrush) | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
SetBlendTriangularShape | Overloaded. Creates a gradient with a center color and a linear falloff to one surrounding color.
SetSigmaBellShape | Overloaded. Creates a gradient brush that changes color starting from the center of the path outward to the path's boundary. The transition from one color to another is based on a bell-shaped curve.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform (inherited from TransformBrush) | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace


SetBlendTriangularShape Method

Aspose.Imaging Documentation

PathGradientBrush.SetBlendTriangularShape Method

Creates a gradient with a center color and a linear falloff to one surrounding color.

Overload List

Creates a gradient with a center color and a linear falloff to one surrounding color.

public void SetBlendTriangularShape(float);

Creates a gradient with a center color and a linear falloff to each surrounding color.

public void SetBlendTriangularShape(float,float);

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace


PathGradientBrush.SetBlendTriangularShape Method (Single)

Creates a gradient with a center color and a linear falloff to one surrounding color.

public void SetBlendTriangularShape(
float focus
);

Parameters

focus
A value from 0 through 1 that specifies where, along any radial from the center of the path to the path's boundary, the center color will be at its highest intensity. A value of 1 (the default) places the highest intensity at the center of the path.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathGradientBrush.SetBlendTriangularShape Overload List


PathGradientBrush.SetBlendTriangularShape Method (Single, Single)

Creates a gradient with a center color and a linear falloff to each surrounding color.

public void SetBlendTriangularShape(
float focus,
float scale
);

Parameters

focus
A value from 0 through 1 that specifies where, along any radial from the center of the path to the path's boundary, the center color will be at its highest intensity. A value of 1 (the default) places the highest intensity at the center of the path.
scale
A value from 0 through 1 that specifies the maximum intensity of the center color that gets blended with the boundary color. A value of 1 causes the highest possible intensity of the center color, and it is the default value.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathGradientBrush.SetBlendTriangularShape Overload List


SetSigmaBellShape Method

Aspose.Imaging Documentation

PathGradientBrush.SetSigmaBellShape Method

Creates a gradient brush that changes color starting from the center of the path outward to the path's boundary. The transition from one color to another is based on a bell-shaped curve.

Overload List

Creates a gradient brush that changes color starting from the center of the path outward to the path's boundary. The transition from one color to another is based on a bell-shaped curve.

public void SetSigmaBellShape(float);

Creates a gradient brush that changes color starting from the center of the path outward to the path's boundary. The transition from one color to another is based on a bell-shaped curve.

public void SetSigmaBellShape(float,float);

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace


PathGradientBrush.SetSigmaBellShape Method (Single)

Creates a gradient brush that changes color starting from the center of the path outward to the path's boundary. The transition from one color to another is based on a bell-shaped curve.

public void SetSigmaBellShape(
float focus
);

Parameters

focus
A value from 0 through 1 that specifies where, along any radial from the center of the path to the path's boundary, the center color will be at its highest intensity. A value of 1 (the default) places the highest intensity at the center of the path.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathGradientBrush.SetSigmaBellShape Overload List


PathGradientBrush.SetSigmaBellShape Method (Single, Single)

Creates a gradient brush that changes color starting from the center of the path outward to the path's boundary. The transition from one color to another is based on a bell-shaped curve.

public void SetSigmaBellShape(
float focus,
float scale
);

Parameters

focus
A value from 0 through 1 that specifies where, along any radial from the center of the path to the path's boundary, the center color will be at its highest intensity. A value of 1 (the default) places the highest intensity at the center of the path.
scale
A value from 0 through 1 that specifies the maximum intensity of the center color that gets blended with the boundary color. A value of 1 causes the highest possible intensity of the center color, and it is the default value.

See Also

PathGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathGradientBrush.SetSigmaBellShape Overload List


PathGradientBrushBase Class

Represents a Brush with base path gradient functionality.

For a list of all members of this type, see PathGradientBrushBase Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.Brush
Aspose.Imaging.Brushes.TransformBrush
Aspose.Imaging.Brushes.PathGradientBrushBase
Aspose.Imaging.Brushes.PathGradientBrush
Aspose.Imaging.Brushes.PathMulticolorGradientBrush

public abstract class PathGradientBrushBase : TransformBrush

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Note that when creating the PathGradientBrushBase class it should be initialized with 2 points at least. The internal path created will always be a closed figure, the last point connects the first point. That shape is filled with this PathGradientBrushBase. The GDI+ implementation throws an OutOfMemoryException when passing in empty arrays or points set having the same coordinates. The PathGradientBrushBase throws an exception when points array contain less than 2 points, the ArgumentException is thrown rather than OutOfMemoryException when points array is unacceptable. The center point is calculated as a center of mass for the passed in points by default. A user can change this point later. The focus scales is an empty point (0.0, 0.0) by default.

Requirements

Namespace: Aspose.Imaging.Brushes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PathGradientBrushBase Members | Aspose.Imaging.Brushes Namespace


PathGradientBrushBase Members

PathGradientBrushBase overview

Public Instance Properties

CenterPoint | Gets or sets the center point of the path gradient.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
FocusScales | Gets or sets the focus point for the gradient falloff.
GraphicsPath | Gets the graphics path this brush was build upon.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
PathPoints | Gets the path points this brush was build upon.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform (inherited from TransformBrush) | Overloaded. Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.
ResetTransform (inherited from TransformBrush) | Resets the Transform property to identity.
RotateTransform (inherited from TransformBrush) | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform (inherited from TransformBrush) | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform (inherited from TransformBrush) | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

Protected Instance Constructors

PathGradientBrushBase Overloaded. Initializes a new instance of the PathGradientBrushBase class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReleaseManagedResources (inherited from DisposableObject) | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

PathGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


PathGradientBrushBase Constructor

Initializes a new instance of the PathGradientBrushBase class with the specified points.

Overload List

Initializes a new instance of the PathGradientBrushBase class with the specified path.

protected PathGradientBrushBase(GraphicsPath);

Initializes a new instance of the PathGradientBrushBase class with the specified points.

protected PathGradientBrushBase(Point[]);

Initializes a new instance of the PathGradientBrushBase class with the specified points and wrap mode.

protected PathGradientBrushBase(Point[],WrapMode);

Initializes a new instance of the PathGradientBrushBase class with the specified points.

protected PathGradientBrushBase(PointF[]);

Initializes a new instance of the PathGradientBrushBase class with the specified points and wrap mode.

protected PathGradientBrushBase(PointF[],WrapMode);

See Also

PathGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


PathGradientBrushBase Constructor (PointF[])

Initializes a new instance of the PathGradientBrushBase class with the specified points.

protected PathGradientBrushBase(
PointF[] points
);

Parameters

points
An array of PointF structures that represents the points that make up the vertices of the path.

See Also

PathGradientBrushBase Class | Aspose.Imaging.Brushes Namespace | PathGradientBrushBase Constructor Overload List


PathGradientBrushBase Constructor (PointF[], WrapMode)

Initializes a new instance of the PathGradientBrushBase class with the specified points and wrap mode.

protected PathGradientBrushBase(
PointF[] points,
WrapMode wrapMode
);

Parameters

points
An array of PointF structures that represents the points that make up the vertices of the path.
wrapMode
A WrapMode that specifies how fills drawn with this PathGradientBrushBase are tiled.

See Also

PathGradientBrushBase Class | Aspose.Imaging.Brushes Namespace | PathGradientBrushBase Constructor Overload List


PathGradientBrushBase Constructor (Point[])

Initializes a new instance of the PathGradientBrushBase class with the specified points.

protected PathGradientBrushBase(
Point[] points
);

Parameters

points
An array of Point structures that represents the points that make up the vertices of the path.

See Also

PathGradientBrushBase Class | Aspose.Imaging.Brushes Namespace | PathGradientBrushBase Constructor Overload List


PathGradientBrushBase Constructor (Point[], WrapMode)

Initializes a new instance of the PathGradientBrushBase class with the specified points and wrap mode.

protected PathGradientBrushBase(
Point[] points,
WrapMode wrapMode
);

Parameters

points
An array of Point structures that represents the points that make up the vertices of the path.
wrapMode
A WrapMode that specifies how fills drawn with this PathGradientBrushBase are tiled.

See Also

PathGradientBrushBase Class | Aspose.Imaging.Brushes Namespace | PathGradientBrushBase Constructor Overload List


PathGradientBrushBase Constructor (GraphicsPath)

Initializes a new instance of the PathGradientBrushBase class with the specified path.

protected PathGradientBrushBase(
GraphicsPath path
);

Parameters

path
The GraphicsPath that defines the area filled by this PathGradientBrushBase.

See Also

PathGradientBrushBase Class | Aspose.Imaging.Brushes Namespace | PathGradientBrushBase Constructor Overload List


PathGradientBrushBase Properties

The properties of the PathGradientBrushBase class are listed below. For a complete list of PathGradientBrushBase class members, see the PathGradientBrushBase Members topic.

Public Instance Properties

CenterPoint | Gets or sets the center point of the path gradient.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
FocusScales | Gets or sets the focus point for the gradient falloff.
GraphicsPath | Gets the graphics path this brush was build upon.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
PathPoints | Gets the path points this brush was build upon.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

See Also

PathGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


CenterPoint Property

Aspose.Imaging Documentation

PathGradientBrushBase.CenterPoint Property

Gets or sets the center point of the path gradient.

public PointF CenterPoint {get; set;}

Property Value

A PointF that represents the center point of the path gradient.

See Also

PathGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


FocusScales Property

Aspose.Imaging Documentation

PathGradientBrushBase.FocusScales Property

Gets or sets the focus point for the gradient falloff.

public PointF FocusScales {get; set;}

Property Value

A PointF that represents the focus point for the gradient falloff.

See Also

PathGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


GraphicsPath Property

Aspose.Imaging Documentation

PathGradientBrushBase.GraphicsPath Property

Gets the graphics path this brush was build upon.

public GraphicsPath GraphicsPath {get;}

Property Value

The graphics path.

See Also

PathGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


PathPoints Property

Aspose.Imaging Documentation

PathGradientBrushBase.PathPoints Property

Gets the path points this brush was build upon.

public PointF[] PathPoints {get;}

Property Value

The path points.

See Also

PathGradientBrushBase Class | Aspose.Imaging.Brushes Namespace


PathMulticolorGradientBrush Class

Encapsulates a Brush object with a gradient. This class cannot be inherited.

For a list of all members of this type, see PathMulticolorGradientBrush Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.Brush
Aspose.Imaging.Brushes.TransformBrush
Aspose.Imaging.Brushes.PathGradientBrushBase
Aspose.Imaging.Brushes.PathMulticolorGradientBrush

public sealed class PathMulticolorGradientBrush : PathGradientBrushBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Brushes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PathMulticolorGradientBrush Members | Aspose.Imaging.Brushes Namespace


PathMulticolorGradientBrush Members

PathMulticolorGradientBrush overview

Public Instance Constructors

PathMulticolorGradientBrush Overloaded. Initializes a new instance of the PathMulticolorGradientBrush class.

Public Instance Properties

CenterPoint (inherited from PathGradientBrushBase) | Gets or sets the center point of the path gradient.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
FocusScales (inherited from PathGradientBrushBase) | Gets or sets the focus point for the gradient falloff.
GraphicsPath (inherited from PathGradientBrushBase) | Gets the graphics path this brush was build upon.
InterpolationColors | Gets or sets a ColorBlend that defines a multicolor linear gradient.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
PathPoints (inherited from PathGradientBrushBase) | Gets the path points this brush was build upon.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform (inherited from TransformBrush) | Overloaded. Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.
ResetTransform (inherited from TransformBrush) | Resets the Transform property to identity.
RotateTransform (inherited from TransformBrush) | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform (inherited from TransformBrush) | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform (inherited from TransformBrush) | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

See Also

PathMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace


PathMulticolorGradientBrush Constructor

Initializes a new instance of the PathMulticolorGradientBrush class with the specified points.

Overload List

Initializes a new instance of the PathMulticolorGradientBrush class with the specified path.

public PathMulticolorGradientBrush(GraphicsPath);

Initializes a new instance of the PathMulticolorGradientBrush class with the specified points.

public PathMulticolorGradientBrush(Point[]);

Initializes a new instance of the PathMulticolorGradientBrush class with the specified points and wrap mode.

public PathMulticolorGradientBrush(Point[],WrapMode);

Initializes a new instance of the PathMulticolorGradientBrush class with the specified points.

public PathMulticolorGradientBrush(PointF[]);

Initializes a new instance of the PathMulticolorGradientBrush class with the specified points and wrap mode.

public PathMulticolorGradientBrush(PointF[],WrapMode);

See Also

PathMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace


PathMulticolorGradientBrush Constructor (PointF[])

Initializes a new instance of the PathMulticolorGradientBrush class with the specified points.

public PathMulticolorGradientBrush(
PointF[] points
);

Parameters

points
An array of PointF structures that represents the points that make up the vertices of the path.

See Also

PathMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathMulticolorGradientBrush Constructor Overload List


PathMulticolorGradientBrush Constructor (PointF[], WrapMode)

Initializes a new instance of the PathMulticolorGradientBrush class with the specified points and wrap mode.

public PathMulticolorGradientBrush(
PointF[] points,
WrapMode wrapMode
);

Parameters

points
An array of PointF structures that represents the points that make up the vertices of the path.
wrapMode
A WrapMode that specifies how fills drawn with this PathMulticolorGradientBrush are tiled.

See Also

PathMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathMulticolorGradientBrush Constructor Overload List


PathMulticolorGradientBrush Constructor (Point[])

Initializes a new instance of the PathMulticolorGradientBrush class with the specified points.

public PathMulticolorGradientBrush(
Point[] points
);

Parameters

points
An array of Point structures that represents the points that make up the vertices of the path.

See Also

PathMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathMulticolorGradientBrush Constructor Overload List


PathMulticolorGradientBrush Constructor (Point[], WrapMode)

Initializes a new instance of the PathMulticolorGradientBrush class with the specified points and wrap mode.

public PathMulticolorGradientBrush(
Point[] points,
WrapMode wrapMode
);

Parameters

points
An array of Point structures that represents the points that make up the vertices of the path.
wrapMode
A WrapMode that specifies how fills drawn with this PathMulticolorGradientBrush are tiled.

See Also

PathMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathMulticolorGradientBrush Constructor Overload List


PathMulticolorGradientBrush Constructor (GraphicsPath)

Initializes a new instance of the PathMulticolorGradientBrush class with the specified path.

public PathMulticolorGradientBrush(
GraphicsPath path
);

Parameters

path
The GraphicsPath that defines the area filled by this PathMulticolorGradientBrush.

See Also

PathMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace | PathMulticolorGradientBrush Constructor Overload List


PathMulticolorGradientBrush Properties

The properties of the PathMulticolorGradientBrush class are listed below. For a complete list of PathMulticolorGradientBrush class members, see the PathMulticolorGradientBrush Members topic.

Public Instance Properties

CenterPoint (inherited from PathGradientBrushBase) | Gets or sets the center point of the path gradient.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
FocusScales (inherited from PathGradientBrushBase) | Gets or sets the focus point for the gradient falloff.
GraphicsPath (inherited from PathGradientBrushBase) | Gets the graphics path this brush was build upon.
InterpolationColors | Gets or sets a ColorBlend that defines a multicolor linear gradient.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
PathPoints (inherited from PathGradientBrushBase) | Gets the path points this brush was build upon.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

See Also

PathMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace


InterpolationColors Property

Aspose.Imaging Documentation

PathMulticolorGradientBrush.InterpolationColors Property

Gets or sets a ColorBlend that defines a multicolor linear gradient.

public ColorBlend InterpolationColors {get; set;}

Property Value

A ColorBlend that defines a multicolor linear gradient.

See Also

PathMulticolorGradientBrush Class | Aspose.Imaging.Brushes Namespace


SolidBrush Class

Solid brush is intended for drawing continiously with specific color. This class cannot be inherited.

For a list of all members of this type, see SolidBrush Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.Brush
Aspose.Imaging.Brushes.SolidBrush

public sealed class SolidBrush : Brush

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example uses Graphics class to create primitive shapes on the Image surface. To demonstrate the operation, the example creates a new Image in PNG format and draw primitive shapes on Image surface using Draw methods exposed by Graphics class

[C#]

//Creates an instance of FileStream
using (System.IO.FileStream stream = new System.IO.FileStream(@"C:\temp\output.png", System.IO.FileMode.Create))
{
    //Create an instance of PngOptions and set its various properties
    Aspose.Imaging.ImageOptions.PngOptions pngOptions = new Aspose.Imaging.ImageOptions.PngOptions();

    //Set the Source for PngOptions
    pngOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(pngOptions, 500, 500))
    {
        //Create and initialize an instance of Graphics class
        Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

        //Clear Graphics surface
        graphics.Clear(Color.Wheat);

        //Draw an Arc by specifying the Pen object having Black color,
        //a Rectangle surrounding the Arc, Start Angle and Sweep Angle
        graphics.DrawArc(new Pen(Color.Black, 2), new Rectangle(200, 200, 100, 200), 0, 300);

        //Draw a Bezier by specifying the Pen object having Blue color and co-ordinate Points.
        graphics.DrawBezier(new Pen(Color.Blue, 2), new Point(250, 100), new Point(300, 30), new Point(450, 100), new Point(235, 25));

        //Draw a Curve by specifying the Pen object having Green color and an array of Points
        graphics.DrawCurve(new Pen(Color.Green, 2), new[] { new Point(100, 200), new Point(100, 350), new Point(200, 450) });

        //Draw an Ellipse using the Pen object and a surrounding Rectangle
        graphics.DrawEllipse(new Pen(Color.Yellow, 2), new Rectangle(300, 300, 100, 100));

        //Draw a Line
        graphics.DrawLine(new Pen(Color.Violet, 2), new Point(100, 100), new Point(200, 200));

        //Draw a Pie segment
        graphics.DrawPie(new Pen(Color.Silver, 2), new Rectangle(new Point(200, 20), new Size(200, 200)), 0, 45);

        //Draw a Polygon by specifying the Pen object having Red color and an array of Points
        graphics.DrawPolygon(new Pen(Color.Red, 2), new[] { new Point(20, 100), new Point(20, 200), new Point(220, 20) });

        //Draw a Rectangle
        graphics.DrawRectangle(new Pen(Color.Orange, 2), new Rectangle(new Point(250, 250), new Size(100, 100)));

        //Create a SolidBrush object and set its various properties
        Aspose.Imaging.Brushes.SolidBrush brush = new Aspose.Imaging.Brushes.SolidBrush();
        brush.Color = Color.Purple;
        brush.Opacity = 100;

        //Draw a String using the SolidBrush object and Font, at specific Point
        graphics.DrawString("This image is created by Aspose.Imaging API", new Font("Times New Roman", 16), brush, new PointF(50, 400));

        // save all changes.
        image.Save();
    }
}
[Visual Basic]

'Creates an instance of FileStream
Using stream As System.IO.FileStream = New System.IO.FileStream("C:\temp\output.png", System.IO.FileMode.Create)
'Create an instance of PngOptions and set its various properties
Dim pngOptions As Aspose.Imaging.ImageOptions.PngOptions = New Aspose.Imaging.ImageOptions.PngOptions()

'Set the Source for PngOptions
    pngOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(pngOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
        graphics.Clear(Color.Wheat)

'Draw an Arc by specifying the Pen object having Black color,
'a Rectangle surrounding the Arc, Start Angle and Sweep Angle
        graphics.DrawArc(New Pen(Color.Black, 2), New Rectangle(200, 200, 100, 200), 0, 300)

'Draw a Bezier by specifying the Pen object having Blue color and co-ordinate Points.
        graphics.DrawBezier(New Pen(Color.Blue, 2), New Point(250, 100), New Point(300, 30), New Point(450, 100), New Point(235, 25))

'Draw a Curve by specifying the Pen object having Green color and an array of Points
        graphics.DrawCurve(New Pen(Color.Green, 2), New() { New Point(100, 200), New Point(100, 350), New Point(200, 450) })

'Draw an Ellipse using the Pen object and a surrounding Rectangle
        graphics.DrawEllipse(New Pen(Color.Yellow, 2), New Rectangle(300, 300, 100, 100))

'Draw a Line
        graphics.DrawLine(New Pen(Color.Violet, 2), New Point(100, 100), New Point(200, 200))

'Draw a Pie segment
        graphics.DrawPie(New Pen(Color.Silver, 2), New Rectangle(New Point(200, 20), New Size(200, 200)), 0, 45)

'Draw a Polygon by specifying the Pen object having Red color and an array of Points
        graphics.DrawPolygon(New Pen(Color.Red, 2), New() { New Point(20, 100), New Point(20, 200), New Point(220, 20) })

'Draw a Rectangle
        graphics.DrawRectangle(New Pen(Color.Orange, 2), New Rectangle(New Point(250, 250), New Size(100, 100)))

'Create a SolidBrush object and set its various properties
Dim brush As Aspose.Imaging.Brushes.SolidBrush = New Aspose.Imaging.Brushes.SolidBrush()
        brush.Color = Color.Purple
        brush.Opacity = 100

'Draw a String using the SolidBrush object and Font, at specific Point
        graphics.DrawString("This image is created by Aspose.Imaging API", New Font("Times New Roman", 16), brush, New PointF(50, 400))

' save all changes.
        image.Save()
    End Using
End Using

Requirements

Namespace: Aspose.Imaging.Brushes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

SolidBrush Members | Aspose.Imaging.Brushes Namespace


SolidBrush Members

SolidBrush overview

Public Instance Constructors

SolidBrush Overloaded. Initializes a new instance of the SolidBrush class.

Public Instance Properties

Color | Gets or sets the brush color.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SolidBrush Class | Aspose.Imaging.Brushes Namespace


SolidBrush Constructor

Initializes a new instance of the SolidBrush class.

Overload List

Initializes a new instance of the SolidBrush class.

public SolidBrush();

Initializes a new instance of the SolidBrush class.

public SolidBrush(Color);

See Also

SolidBrush Class | Aspose.Imaging.Brushes Namespace


SolidBrush Constructor ()

Initializes a new instance of the SolidBrush class.

public SolidBrush();

See Also

SolidBrush Class | Aspose.Imaging.Brushes Namespace | SolidBrush Constructor Overload List


SolidBrush Constructor (Color)

Initializes a new instance of the SolidBrush class.

public SolidBrush(
Color color
);

Parameters

color
The solid brush color.

See Also

SolidBrush Class | Aspose.Imaging.Brushes Namespace | SolidBrush Constructor Overload List


SolidBrush Properties

The properties of the SolidBrush class are listed below. For a complete list of SolidBrush class members, see the SolidBrush Members topic.

Public Instance Properties

Color | Gets or sets the brush color.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.

See Also

SolidBrush Class | Aspose.Imaging.Brushes Namespace


Color Property

Aspose.Imaging Documentation

SolidBrush.Color Property

Gets or sets the brush color.

public Color Color {get; set;}

Property Value

The brush color.

See Also

SolidBrush Class | Aspose.Imaging.Brushes Namespace


TextureBrush Class

Each property of the TextureBrush class is a Brush object that uses an image to fill the interior of a shape. This class cannot be inherited.

For a list of all members of this type, see TextureBrush Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.Brush
Aspose.Imaging.Brushes.TransformBrush
Aspose.Imaging.Brushes.TextureBrush

public sealed class TextureBrush : TransformBrush

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Brushes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TextureBrush Members | Aspose.Imaging.Brushes Namespace


TextureBrush Members

TextureBrush overview

Public Instance Constructors

TextureBrush Overloaded. Initializes a new instance of the TextureBrush class.

Public Instance Properties

Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
Image | Gets the Image object associated with this TextureBrush object.
ImageAttributes | Gets the ImageAttributes associated with this TextureBrush.
ImageRectangle | Gets the Rectangle associated with this TextureBrush.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform (inherited from TransformBrush) | Overloaded. Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.
ResetTransform (inherited from TransformBrush) | Resets the Transform property to identity.
RotateTransform (inherited from TransformBrush) | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform (inherited from TransformBrush) | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform (inherited from TransformBrush) | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace


TextureBrush Constructor

Initializes a new instance of the TextureBrush class that uses the specified image.

Overload List

Initializes a new instance of the TextureBrush class that uses the specified image.

public TextureBrush(Image);

Initializes a new instance of the TextureBrush class that uses the specified image and bounding rectangle.

public TextureBrush(Image,Rectangle);

Initializes a new instance of the TextureBrush class that uses the specified image, bounding rectangle, and image attributes.

public TextureBrush(Image,Rectangle,ImageAttributes);

Initializes a new instance of the TextureBrush class that uses the specified image and bounding rectangle.

public TextureBrush(Image,RectangleF);

Initializes a new instance of the TextureBrush class that uses the specified image, bounding rectangle, and image attributes.

public TextureBrush(Image,RectangleF,ImageAttributes);

Initializes a new instance of the TextureBrush class that uses the specified image and wrap mode.

public TextureBrush(Image,WrapMode);

Initializes a new instance of the TextureBrush class that uses the specified image, wrap mode, and bounding rectangle.

public TextureBrush(Image,WrapMode,Rectangle);

Initializes a new instance of the TextureBrush class that uses the specified image, wrap mode, and bounding rectangle.

public TextureBrush(Image,WrapMode,RectangleF);

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace


TextureBrush Constructor (Image)

Initializes a new instance of the TextureBrush class that uses the specified image.

public TextureBrush(
Image image
);

Parameters

image
The Image object with which this TextureBrush object fills interiors.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace | TextureBrush Constructor Overload List


TextureBrush Constructor (Image, WrapMode)

Initializes a new instance of the TextureBrush class that uses the specified image and wrap mode.

public TextureBrush(
Image image,
WrapMode wrapMode
);

Parameters

image
The Image object with which this TextureBrush object fills interiors.
wrapMode
A WrapMode enumeration that specifies how this TextureBrush object is tiled.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace | TextureBrush Constructor Overload List


TextureBrush Constructor (Image, WrapMode, RectangleF)

Initializes a new instance of the TextureBrush class that uses the specified image, wrap mode, and bounding rectangle.

public TextureBrush(
Image image,
WrapMode wrapMode,
RectangleF destinationRectangle
);

Parameters

image
The Image object with which this TextureBrush object fills interiors.
wrapMode
A WrapMode enumeration that specifies how this TextureBrush object is tiled.
destinationRectangle
A RectangleF structure that represents the bounding rectangle for this TextureBrush object.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace | TextureBrush Constructor Overload List


TextureBrush Constructor (Image, WrapMode, Rectangle)

Initializes a new instance of the TextureBrush class that uses the specified image, wrap mode, and bounding rectangle.

public TextureBrush(
Image image,
WrapMode wrapMode,
Rectangle destinationRectangle
);

Parameters

image
The Image object with which this TextureBrush object fills interiors.
wrapMode
A WrapMode enumeration that specifies how this TextureBrush object is tiled.
destinationRectangle
A Rectangle structure that represents the bounding rectangle for this TextureBrush object.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace | TextureBrush Constructor Overload List


TextureBrush Constructor (Image, RectangleF)

Initializes a new instance of the TextureBrush class that uses the specified image and bounding rectangle.

public TextureBrush(
Image image,
RectangleF destinationRectangle
);

Parameters

image
The Image object with which this TextureBrush object fills interiors.
destinationRectangle
A RectangleF structure that represents the bounding rectangle for this TextureBrush object.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace | TextureBrush Constructor Overload List


TextureBrush Constructor (Image, RectangleF, ImageAttributes)

Initializes a new instance of the TextureBrush class that uses the specified image, bounding rectangle, and image attributes.

public TextureBrush(
Image image,
RectangleF destinationRectangle,
ImageAttributes imageAttributes
);

Parameters

image
The Image object with which this TextureBrush object fills interiors.
destinationRectangle
A RectangleF structure that represents the bounding rectangle for this TextureBrush object.
imageAttributes
An ImageAttributes object that contains additional information about the image used by this TextureBrush object.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace | TextureBrush Constructor Overload List


TextureBrush Constructor (Image, Rectangle)

Initializes a new instance of the TextureBrush class that uses the specified image and bounding rectangle.

public TextureBrush(
Image image,
Rectangle destinationRectangle
);

Parameters

image
The Image object with which this TextureBrush object fills interiors.
destinationRectangle
A Rectangle structure that represents the bounding rectangle for this TextureBrush object.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace | TextureBrush Constructor Overload List


TextureBrush Constructor (Image, Rectangle, ImageAttributes)

Initializes a new instance of the TextureBrush class that uses the specified image, bounding rectangle, and image attributes.

public TextureBrush(
Image image,
Rectangle destinationRectangle,
ImageAttributes imageAttributes
);

Parameters

image
The Image object with which this TextureBrush object fills interiors.
destinationRectangle
A Rectangle structure that represents the bounding rectangle for this TextureBrush object.
imageAttributes
An ImageAttributes object that contains additional information about the image used by this TextureBrush object.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace | TextureBrush Constructor Overload List


TextureBrush Properties

The properties of the TextureBrush class are listed below. For a complete list of TextureBrush class members, see the TextureBrush Members topic.

Public Instance Properties

Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
Image | Gets the Image object associated with this TextureBrush object.
ImageAttributes | Gets the ImageAttributes associated with this TextureBrush.
ImageRectangle | Gets the Rectangle associated with this TextureBrush.
IsTransformChanged (inherited from TransformBrush) | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
Transform (inherited from TransformBrush) | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode (inherited from TransformBrush) | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace


Image Property

Aspose.Imaging Documentation

TextureBrush.Image Property

Gets the Image object associated with this TextureBrush object.

public Image Image {get;}

Property Value

An Image object that represents the image with which this TextureBrush object fills shapes.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace


ImageAttributes Property

Aspose.Imaging Documentation

TextureBrush.ImageAttributes Property

Gets the ImageAttributes associated with this TextureBrush.

public ImageAttributes ImageAttributes {get;}

Property Value

The ImageAttributes.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace


ImageRectangle Property

Aspose.Imaging Documentation

TextureBrush.ImageRectangle Property

Gets the Rectangle associated with this TextureBrush.

public RectangleF ImageRectangle {get;}

Property Value

The Rectangle.

See Also

TextureBrush Class | Aspose.Imaging.Brushes Namespace


TransformBrush Class

A Brush with transform capabilities.

For a list of all members of this type, see TransformBrush Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.Brush
Aspose.Imaging.Brushes.TransformBrush
Aspose.Imaging.Brushes.LinearGradientBrushBase
Aspose.Imaging.Brushes.PathGradientBrushBase
Aspose.Imaging.Brushes.TextureBrush

public abstract class TransformBrush : Brush

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Brushes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TransformBrush Members | Aspose.Imaging.Brushes Namespace


TransformBrush Members

TransformBrush overview

Public Instance Properties

Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
IsTransformChanged | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
Transform | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform | Overloaded. Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.
ResetTransform | Resets the Transform property to identity.
RotateTransform | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

Protected Instance Constructors

TransformBrush Constructor Initializes a new instance of the TransformBrush class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReleaseManagedResources (inherited from DisposableObject) | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace


TransformBrush Constructor

Initializes a new instance of the TransformBrush class.

protected TransformBrush();

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace


TransformBrush Properties

The properties of the TransformBrush class are listed below. For a complete list of TransformBrush class members, see the TransformBrush Members topic.

Public Instance Properties

Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
IsTransformChanged | Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.
Opacity (inherited from Brush) | Gets or sets the brush opacity. The value should be between 0 and 1. Value of 0 means that brush is fully visible, value of 1 means the brush is fully opaque.
Transform | Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.
WrapMode | Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace


IsTransformChanged Property

Aspose.Imaging Documentation

TransformBrush.IsTransformChanged Property

Gets a value indicating whether transformations were changed in some way. For example setting the transformation matrix or calling any of the methods altering the transformation matrix. The property is introduced for backward compatibility with GDI+.

public bool IsTransformChanged {get;}

Property Value

True if transformation was changed; otherwise, false.

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace


Transform Property

Aspose.Imaging Documentation

TransformBrush.Transform Property

Gets or sets a copy Matrix that defines a local geometric transform for this TransformBrush.

public Matrix Transform {get; set;}

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace


WrapMode Property

Aspose.Imaging Documentation

TransformBrush.WrapMode Property

Gets or sets a WrapMode enumeration that indicates the wrap mode for this TransformBrush.

public WrapMode WrapMode {get; set;}

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace


TransformBrush Methods

The methods of the TransformBrush class are listed below. For a complete list of TransformBrush class members, see the TransformBrush Members topic.

Public Instance Methods

DeepClone (inherited from Brush) | Creates a new deep clone of the current Brush.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MultiplyTransform | Overloaded. Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.
ResetTransform | Resets the Transform property to identity.
RotateTransform | Overloaded. Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.
ScaleTransform | Overloaded. Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.
ToString (inherited from Object) | Returns a String that represents the current Object.
TranslateTransform | Overloaded. Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReleaseManagedResources (inherited from DisposableObject) | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace


MultiplyTransform Method

Aspose.Imaging Documentation

TransformBrush.MultiplyTransform Method

Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.

Overload List

Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.

public void MultiplyTransform(Matrix);

Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix in the specified order.

public void MultiplyTransform(Matrix,MatrixOrder);

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace


TransformBrush.MultiplyTransform Method (Matrix)

Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix by prepending the specified Matrix.

public void MultiplyTransform(
Matrix matrix
);

Parameters

matrix
The Matrix by which to multiply the geometric transform.

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace | TransformBrush.MultiplyTransform Overload List


TransformBrush.MultiplyTransform Method (Matrix, MatrixOrder)

Multiplies the Matrix that represents the local geometric transform of this LinearGradientBrush by the specified Matrix in the specified order.

public void MultiplyTransform(
Matrix matrix,
MatrixOrder order
);

Parameters

matrix
The Matrix by which to multiply the geometric transform.
order
A MatrixOrder that specifies in which order to multiply the two matrices.

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace | TransformBrush.MultiplyTransform Overload List


TransformBrush.ResetTransform Method

Resets the Transform property to identity.

public void ResetTransform();

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace


RotateTransform Method

Aspose.Imaging Documentation

TransformBrush.RotateTransform Method

Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.

Overload List

Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.

public void RotateTransform(float);

Rotates the local geometric transform by the specified amount in the specified order.

public void RotateTransform(float,MatrixOrder);

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace


TransformBrush.RotateTransform Method (Single)

Rotates the local geometric transform by the specified amount. This method prepends the rotation to the transform.

public void RotateTransform(
float angle
);

Parameters

angle
The angle of rotation.

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace | TransformBrush.RotateTransform Overload List


TransformBrush.RotateTransform Method (Single, MatrixOrder)

Rotates the local geometric transform by the specified amount in the specified order.

public void RotateTransform(
float angle,
MatrixOrder order
);

Parameters

angle
The angle of rotation.
order
A MatrixOrder that specifies whether to append or prepend the rotation matrix.

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace | TransformBrush.RotateTransform Overload List


ScaleTransform Method

Aspose.Imaging Documentation

TransformBrush.ScaleTransform Method

Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.

Overload List

Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.

public void ScaleTransform(float,float);

Scales the local geometric transform by the specified amounts in the specified order.

public void ScaleTransform(float,float,MatrixOrder);

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace


TransformBrush.ScaleTransform Method (Single, Single)

Scales the local geometric transform by the specified amounts. This method prepends the scaling matrix to the transform.

public void ScaleTransform(
float sx,
float sy
);

Parameters

sx
The amount by which to scale the transform in the x-axis direction.
sy
The amount by which to scale the transform in the y-axis direction.

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace | TransformBrush.ScaleTransform Overload List


TransformBrush.ScaleTransform Method (Single, Single, MatrixOrder)

Scales the local geometric transform by the specified amounts in the specified order.

public void ScaleTransform(
float sx,
float sy,
MatrixOrder order
);

Parameters

sx
The amount by which to scale the transform in the x-axis direction.
sy
The amount by which to scale the transform in the y-axis direction.
order
A MatrixOrder that specifies whether to append or prepend the scaling matrix.

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace | TransformBrush.ScaleTransform Overload List


TranslateTransform Method

Aspose.Imaging Documentation

TransformBrush.TranslateTransform Method

Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

Overload List

Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

public void TranslateTransform(float,float);

Translates the local geometric transform by the specified dimensions in the specified order.

public void TranslateTransform(float,float,MatrixOrder);

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace


TransformBrush.TranslateTransform Method (Single, Single)

Translates the local geometric transform by the specified dimensions. This method prepends the translation to the transform.

public void TranslateTransform(
float dx,
float dy
);

Parameters

dx
The value of the translation in x.
dy
The value of the translation in y.

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace | TransformBrush.TranslateTransform Overload List


TransformBrush.TranslateTransform Method (Single, Single, MatrixOrder)

Translates the local geometric transform by the specified dimensions in the specified order.

public void TranslateTransform(
float dx,
float dy,
MatrixOrder order
);

Parameters

dx
The value of the translation in x.
dy
The value of the translation in y.
order
The order (prepend or append) in which to apply the translation.

See Also

TransformBrush Class | Aspose.Imaging.Brushes Namespace | TransformBrush.TranslateTransform Overload List


Aspose.Imaging.Dithering

Aspose.Imaging Documentation

Aspose.Imaging.Dithering Namespace

Namespace hierarchy

Classes

Class | Description
DitheringMode | Dithering settings to be applied to image upon saving.

Enumerations

Enumeration | Description
DitheringMethod | Dithering method.


DitheringMethod Enumeration

Dithering method.

public enum DitheringMethod

Members

Member Name | Description | Value
None | No dithering. | 0
FloydSteinbergDithering | The Floyd-Steinberg dithering. | 1

Requirements

Namespace: Aspose.Imaging.Dithering

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Dithering Namespace


DitheringMode Class

Dithering settings to be applied to image upon saving.

For a list of all members of this type, see DitheringMode Members.

System.Object
Aspose.Imaging.Dithering.DitheringMode

public class DitheringMode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Dithering

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

DitheringMode Members | Aspose.Imaging.Dithering Namespace


DitheringMode Members

DitheringMode overview

Public Instance Constructors

DitheringMode Constructor Initializes a new instance of the DitheringMode class.

Public Instance Properties

Bits | The sampling factor of dithered image.
CustomPalette | The custom palette for dithering.
Method | Dithering algorithm selection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DitheringMode Class | Aspose.Imaging.Dithering Namespace


DitheringMode Constructor

Initializes a new instance of the DitheringMode class.

public DitheringMode();

See Also

DitheringMode Class | Aspose.Imaging.Dithering Namespace


DitheringMode Properties

The properties of the DitheringMode class are listed below. For a complete list of DitheringMode class members, see the DitheringMode Members topic.

Public Instance Properties

Bits | The sampling factor of dithered image.
CustomPalette | The custom palette for dithering.
Method | Dithering algorithm selection.

See Also

DitheringMode Class | Aspose.Imaging.Dithering Namespace


Bits Property

Aspose.Imaging Documentation

DitheringMode.Bits Property

The sampling factor of dithered image.

public int Bits {get; set;}

See Also

DitheringMode Class | Aspose.Imaging.Dithering Namespace


CustomPalette Property

Aspose.Imaging Documentation

DitheringMode.CustomPalette Property

The custom palette for dithering.

public IColorPalette CustomPalette {get; set;}

See Also

DitheringMode Class | Aspose.Imaging.Dithering Namespace


Method Property

Aspose.Imaging Documentation

DitheringMode.Method Property

Dithering algorithm selection.

public DitheringMethod Method {get; set;}

See Also

DitheringMode Class | Aspose.Imaging.Dithering Namespace


Aspose.Imaging.Exceptions

Aspose.Imaging Documentation

Aspose.Imaging.Exceptions Namespace

Namespace hierarchy

Classes

Class | Description
CompressorException | The compressor exception.
FrameworkException | The imaging framework exception. This class is a core class for all Aspose.Imaging exceptions. Introduced to discriminate between the exceptions thrown by the Aspose.Imaging engine and all other exception types.
ImageCreateException | The image create exception. Occurs during image creation.
ImageException | The image exception.
ImageLoadException | The image load exception. Occurs during image loading.
ImageSaveException | The image save exception. Occurs during image saving.


CompressorException Class

The compressor exception.

For a list of all members of this type, see CompressorException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.FrameworkException
Aspose.Imaging.Exceptions.CompressorException
Aspose.Imaging.Exceptions.Compressors.LzwCompressorException
Aspose.Imaging.Exceptions.Compressors.RleCompressorException

public class CompressorException : FrameworkException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CompressorException Members | Aspose.Imaging.Exceptions Namespace


CompressorException Members

CompressorException overview

Public Instance Constructors

CompressorException Overloaded. Initializes a new instance of the CompressorException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompressorException Class | Aspose.Imaging.Exceptions Namespace


CompressorException Constructor

Initializes a new instance of the CompressorException class.

Overload List

Initializes a new instance of the CompressorException class.

public CompressorException(string);

Initializes a new instance of the CompressorException class.

public CompressorException(string,Exception);

See Also

CompressorException Class | Aspose.Imaging.Exceptions Namespace


CompressorException Constructor (String)

Initializes a new instance of the CompressorException class.

public CompressorException(
string message
);

Parameters

message
The exception message.

See Also

CompressorException Class | Aspose.Imaging.Exceptions Namespace | CompressorException Constructor Overload List


CompressorException Constructor (String, Exception)

Initializes a new instance of the CompressorException class.

public CompressorException(
string message,
Exception innerException
);

Parameters

message
The exception message.
innerException
The inner exception.

See Also

CompressorException Class | Aspose.Imaging.Exceptions Namespace | CompressorException Constructor Overload List


FrameworkException Class

The imaging framework exception. This class is a core class for all Aspose.Imaging exceptions. Introduced to discriminate between the exceptions thrown by the Aspose.Imaging engine and all other exception types.

For a list of all members of this type, see FrameworkException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.FrameworkException
Aspose.Imaging.Exceptions.CompressorException

public class FrameworkException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

FrameworkException Members | Aspose.Imaging.Exceptions Namespace


FrameworkException Members

FrameworkException overview

Public Instance Constructors

FrameworkException Overloaded. Initializes a new instance of the FrameworkException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FrameworkException Class | Aspose.Imaging.Exceptions Namespace


FrameworkException Constructor

Initializes a new instance of the FrameworkException class.

Overload List

Initializes a new instance of the FrameworkException class.

public FrameworkException(string);

Initializes a new instance of the FrameworkException class.

public FrameworkException(string,Exception);

See Also

FrameworkException Class | Aspose.Imaging.Exceptions Namespace


FrameworkException Constructor (String)

Initializes a new instance of the FrameworkException class.

public FrameworkException(
string message
);

Parameters

message
The message.

See Also

FrameworkException Class | Aspose.Imaging.Exceptions Namespace | FrameworkException Constructor Overload List


FrameworkException Constructor (String, Exception)

Initializes a new instance of the FrameworkException class.

public FrameworkException(
string message,
Exception innerException
);

Parameters

message
The message.
innerException
The inner exception.

See Also

FrameworkException Class | Aspose.Imaging.Exceptions Namespace | FrameworkException Constructor Overload List


ImageCreateException Class

The image create exception. Occurs during image creation.

For a list of all members of this type, see ImageCreateException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.ImageException
Aspose.Imaging.Exceptions.ImageCreateException

public class ImageCreateException : ImageException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ImageCreateException Members | Aspose.Imaging.Exceptions Namespace


ImageCreateException Members

ImageCreateException overview

Public Instance Constructors

ImageCreateException Overloaded. Initializes a new instance of the ImageCreateException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageCreateException Class | Aspose.Imaging.Exceptions Namespace


ImageCreateException Constructor

Initializes a new instance of the ImageCreateException class.

Overload List

Initializes a new instance of the ImageCreateException class.

public ImageCreateException(string);

Initializes a new instance of the ImageCreateException class.

public ImageCreateException(string,Exception);

See Also

ImageCreateException Class | Aspose.Imaging.Exceptions Namespace


ImageCreateException Constructor (String)

Initializes a new instance of the ImageCreateException class.

public ImageCreateException(
string message
);

Parameters

message
The exception message.

See Also

ImageCreateException Class | Aspose.Imaging.Exceptions Namespace | ImageCreateException Constructor Overload List


ImageCreateException Constructor (String, Exception)

Initializes a new instance of the ImageCreateException class.

public ImageCreateException(
string message,
Exception innerException
);

Parameters

message
The exception message.
innerException
The inner exception.

See Also

ImageCreateException Class | Aspose.Imaging.Exceptions Namespace | ImageCreateException Constructor Overload List


ImageException Class

The image exception.

For a list of all members of this type, see ImageException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.ImageException
Derived types

public class ImageException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ImageException Members | Aspose.Imaging.Exceptions Namespace


ImageException Members

ImageException overview

Public Instance Constructors

ImageException Overloaded. Initializes a new instance of the ImageException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageException Class | Aspose.Imaging.Exceptions Namespace


ImageException Constructor

Initializes a new instance of the ImageException class.

Overload List

Initializes a new instance of the ImageException class.

public ImageException(string);

Initializes a new instance of the ImageException class.

public ImageException(string,Exception);

See Also

ImageException Class | Aspose.Imaging.Exceptions Namespace


ImageException Constructor (String)

Initializes a new instance of the ImageException class.

public ImageException(
string message
);

Parameters

message
The exception message.

See Also

ImageException Class | Aspose.Imaging.Exceptions Namespace | ImageException Constructor Overload List


ImageException Constructor (String, Exception)

Initializes a new instance of the ImageException class.

public ImageException(
string message,
Exception innerException
);

Parameters

message
The exception message.
innerException
The inner exception.

See Also

ImageException Class | Aspose.Imaging.Exceptions Namespace | ImageException Constructor Overload List


ImageLoadException Class

The image load exception. Occurs during image loading.

For a list of all members of this type, see ImageLoadException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.ImageException
Aspose.Imaging.Exceptions.ImageLoadException

public class ImageLoadException : ImageException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ImageLoadException Members | Aspose.Imaging.Exceptions Namespace


ImageLoadException Members

ImageLoadException overview

Public Instance Constructors

ImageLoadException Overloaded. Initializes a new instance of the ImageLoadException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageLoadException Class | Aspose.Imaging.Exceptions Namespace


ImageLoadException Constructor

Initializes a new instance of the ImageLoadException class.

Overload List

Initializes a new instance of the ImageLoadException class.

public ImageLoadException(string);

Initializes a new instance of the ImageLoadException class.

public ImageLoadException(string,Exception);

See Also

ImageLoadException Class | Aspose.Imaging.Exceptions Namespace


ImageLoadException Constructor (String)

Initializes a new instance of the ImageLoadException class.

public ImageLoadException(
string message
);

Parameters

message
The exception message.

See Also

ImageLoadException Class | Aspose.Imaging.Exceptions Namespace | ImageLoadException Constructor Overload List


ImageLoadException Constructor (String, Exception)

Initializes a new instance of the ImageLoadException class.

public ImageLoadException(
string message,
Exception innerException
);

Parameters

message
The exception message.
innerException
The inner exception.

See Also

ImageLoadException Class | Aspose.Imaging.Exceptions Namespace | ImageLoadException Constructor Overload List


ImageSaveException Class

The image save exception. Occurs during image saving.

For a list of all members of this type, see ImageSaveException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.ImageException
Aspose.Imaging.Exceptions.ImageSaveException

public class ImageSaveException : ImageException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ImageSaveException Members | Aspose.Imaging.Exceptions Namespace


ImageSaveException Members

ImageSaveException overview

Public Instance Constructors

ImageSaveException Overloaded. Initializes a new instance of the ImageSaveException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageSaveException Class | Aspose.Imaging.Exceptions Namespace


ImageSaveException Constructor

Initializes a new instance of the ImageSaveException class.

Overload List

Initializes a new instance of the ImageSaveException class.

public ImageSaveException(string);

Initializes a new instance of the ImageSaveException class.

public ImageSaveException(string,Exception);

See Also

ImageSaveException Class | Aspose.Imaging.Exceptions Namespace


ImageSaveException Constructor (String)

Initializes a new instance of the ImageSaveException class.

public ImageSaveException(
string message
);

Parameters

message
The exception message.

See Also

ImageSaveException Class | Aspose.Imaging.Exceptions Namespace | ImageSaveException Constructor Overload List


ImageSaveException Constructor (String, Exception)

Initializes a new instance of the ImageSaveException class.

public ImageSaveException(
string message,
Exception innerException
);

Parameters

message
The exception message.
innerException
The inner exception.

See Also

ImageSaveException Class | Aspose.Imaging.Exceptions Namespace | ImageSaveException Constructor Overload List


Aspose.Imaging.Exceptions.Compressors

Aspose.Imaging Documentation

Aspose.Imaging.Exceptions.Compressors Namespace

Namespace hierarchy

Classes

Class | Description
LzwCompressorException | The lzw compressor exception.
RleCompressorException | The rle compressor exception.


LzwCompressorException Class

The lzw compressor exception.

For a list of all members of this type, see LzwCompressorException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.FrameworkException
Aspose.Imaging.Exceptions.CompressorException
Aspose.Imaging.Exceptions.Compressors.LzwCompressorException

public class LzwCompressorException : CompressorException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions.Compressors

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

LzwCompressorException Members | Aspose.Imaging.Exceptions.Compressors Namespace


LzwCompressorException Members

LzwCompressorException overview

Public Instance Constructors

LzwCompressorException Overloaded. Initializes a new instance of the LzwCompressorException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LzwCompressorException Class | Aspose.Imaging.Exceptions.Compressors Namespace


LzwCompressorException Constructor

Initializes a new instance of the LzwCompressorException class.

Overload List

Initializes a new instance of the LzwCompressorException class.

public LzwCompressorException(string);

Initializes a new instance of the LzwCompressorException class.

public LzwCompressorException(string,Exception);

See Also

LzwCompressorException Class | Aspose.Imaging.Exceptions.Compressors Namespace


LzwCompressorException Constructor (String)

Initializes a new instance of the LzwCompressorException class.

public LzwCompressorException(
string message
);

Parameters

message
The exception message.

See Also

LzwCompressorException Class | Aspose.Imaging.Exceptions.Compressors Namespace | LzwCompressorException Constructor Overload List


LzwCompressorException Constructor (String, Exception)

Initializes a new instance of the LzwCompressorException class.

public LzwCompressorException(
string message,
Exception innerException
);

Parameters

message
The exception message.
innerException
The inner exception.

See Also

LzwCompressorException Class | Aspose.Imaging.Exceptions.Compressors Namespace | LzwCompressorException Constructor Overload List


RleCompressorException Class

The rle compressor exception.

For a list of all members of this type, see RleCompressorException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.FrameworkException
Aspose.Imaging.Exceptions.CompressorException
Aspose.Imaging.Exceptions.Compressors.RleCompressorException

public class RleCompressorException : CompressorException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions.Compressors

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

RleCompressorException Members | Aspose.Imaging.Exceptions.Compressors Namespace


RleCompressorException Members

RleCompressorException overview

Public Instance Constructors

RleCompressorException Overloaded. Initializes a new instance of the RleCompressorException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RleCompressorException Class | Aspose.Imaging.Exceptions.Compressors Namespace


RleCompressorException Constructor

Initializes a new instance of the RleCompressorException class.

Overload List

Initializes a new instance of the RleCompressorException class.

public RleCompressorException(string);

Initializes a new instance of the RleCompressorException class.

public RleCompressorException(string,Exception);

See Also

RleCompressorException Class | Aspose.Imaging.Exceptions.Compressors Namespace


RleCompressorException Constructor (String)

Initializes a new instance of the RleCompressorException class.

public RleCompressorException(
string message
);

Parameters

message
The exception message.

See Also

RleCompressorException Class | Aspose.Imaging.Exceptions.Compressors Namespace | RleCompressorException Constructor Overload List


RleCompressorException Constructor (String, Exception)

Initializes a new instance of the RleCompressorException class.

public RleCompressorException(
string message,
Exception innerException
);

Parameters

message
The exception message.
innerException
The inner exception.

See Also

RleCompressorException Class | Aspose.Imaging.Exceptions.Compressors Namespace | RleCompressorException Constructor Overload List


Aspose.Imaging.Exceptions.ImageFormats

Aspose.Imaging Documentation

Aspose.Imaging.Exceptions.ImageFormats Namespace

Namespace hierarchy

Classes

Class | Description
BmpImageException | The bmp image exception.
CadException | The Cad exception.
GifImageException | The Gif image exception.
JpegException | Exceptions for Jpeg files
PsdImageException | The psd image exception.
PsdImageResourceException | The psd image resource exception.
TiffImageException | The Tiff image exception


BmpImageException Class

The bmp image exception.

For a list of all members of this type, see BmpImageException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.ImageException
Aspose.Imaging.Exceptions.ImageFormats.BmpImageException

public class BmpImageException : ImageException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions.ImageFormats

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

BmpImageException Members | Aspose.Imaging.Exceptions.ImageFormats Namespace


BmpImageException Members

BmpImageException overview

Public Instance Constructors

BmpImageException Overloaded. Initializes a new instance of the BmpImageException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BmpImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


BmpImageException Constructor

Initializes a new instance of the BmpImageException class.

Overload List

Initializes a new instance of the BmpImageException class.

public BmpImageException(string);

Initializes a new instance of the BmpImageException class.

public BmpImageException(string,Exception);

See Also

BmpImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


BmpImageException Constructor (String)

Initializes a new instance of the BmpImageException class.

public BmpImageException(
string message
);

Parameters

message
The exception message.

See Also

BmpImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | BmpImageException Constructor Overload List


BmpImageException Constructor (String, Exception)

Initializes a new instance of the BmpImageException class.

public BmpImageException(
string message,
Exception innerException
);

Parameters

message
The exception message.
innerException
The inner exception.

See Also

BmpImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | BmpImageException Constructor Overload List


CadException Class

The Cad exception.

For a list of all members of this type, see CadException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.ImageException
Aspose.Imaging.Exceptions.ImageFormats.CadException

public class CadException : ImageException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions.ImageFormats

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadException Members | Aspose.Imaging.Exceptions.ImageFormats Namespace


CadException Members

CadException overview

Public Instance Constructors

CadException Overloaded. Initializes a new instance of the CadException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


CadException Constructor

Initializes a new instance of the CadException class.

Overload List

Initializes a new instance of the CadException class.

public CadException(string);

Initializes a new instance of the CadException class.

public CadException(string,Exception);

See Also

CadException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


CadException Constructor (String)

Initializes a new instance of the CadException class.

public CadException(
string message
);

Parameters

message
The message.

See Also

CadException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | CadException Constructor Overload List


CadException Constructor (String, Exception)

Initializes a new instance of the CadException class.

public CadException(
string message,
Exception innerException
);

Parameters

message
The exception message.
innerException
The inner exception.

See Also

CadException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | CadException Constructor Overload List


GifImageException Class

The Gif image exception.

For a list of all members of this type, see GifImageException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.ImageException
Aspose.Imaging.Exceptions.ImageFormats.GifImageException

public class GifImageException : ImageException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions.ImageFormats

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GifImageException Members | Aspose.Imaging.Exceptions.ImageFormats Namespace


GifImageException Members

GifImageException overview

Public Instance Constructors

GifImageException Overloaded. Initializes a new instance of the GifImageException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


GifImageException Constructor

Initializes a new instance of the GifImageException class.

Overload List

Initializes a new instance of the GifImageException class.

public GifImageException(string);

Initializes a new instance of the GifImageException class.

public GifImageException(string,Exception);

See Also

GifImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


GifImageException Constructor (String)

Initializes a new instance of the GifImageException class.

public GifImageException(
string message
);

Parameters

message
The exception message.

See Also

GifImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | GifImageException Constructor Overload List


GifImageException Constructor (String, Exception)

Initializes a new instance of the GifImageException class.

public GifImageException(
string message,
Exception innerException
);

Parameters

message
The exception message.
innerException
The inner exception.

See Also

GifImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | GifImageException Constructor Overload List


JpegException Class

Exceptions for Jpeg files

For a list of all members of this type, see JpegException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.ImageException
Aspose.Imaging.Exceptions.ImageFormats.JpegException

public class JpegException : ImageException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions.ImageFormats

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

JpegException Members | Aspose.Imaging.Exceptions.ImageFormats Namespace


JpegException Members

JpegException overview

Public Instance Constructors

JpegException Overloaded. Initializes a new instance of the JpegException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

JpegException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


JpegException Constructor

Initializes a new instance of the JpegException class.

Overload List

Initializes a new instance of the JpegException class.

public JpegException(string);

Initializes a new instance of the JpegException class.

public JpegException(string,Exception);

See Also

JpegException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


JpegException Constructor (String)

Initializes a new instance of the JpegException class.

public JpegException(
string message
);

Parameters

message
The exception message.

See Also

JpegException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | JpegException Constructor Overload List


JpegException Constructor (String, Exception)

Initializes a new instance of the JpegException class.

public JpegException(
string message,
Exception innerException
);

Parameters

message
The message.
innerException
The inner exception.

See Also

JpegException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | JpegException Constructor Overload List


PsdImageException Class

The psd image exception.

For a list of all members of this type, see PsdImageException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.ImageException
Aspose.Imaging.Exceptions.ImageFormats.PsdImageException
Aspose.Imaging.Exceptions.ImageFormats.PsdImageResourceException

public class PsdImageException : ImageException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions.ImageFormats

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PsdImageException Members | Aspose.Imaging.Exceptions.ImageFormats Namespace


PsdImageException Members

PsdImageException overview

Public Instance Constructors

PsdImageException Overloaded. Initializes a new instance of the PsdImageException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PsdImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


PsdImageException Constructor

Initializes a new instance of the PsdImageException class.

Overload List

Initializes a new instance of the PsdImageException class.

public PsdImageException(string);

Initializes a new instance of the PsdImageException class.

public PsdImageException(string,Exception);

See Also

PsdImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


PsdImageException Constructor (String)

Initializes a new instance of the PsdImageException class.

public PsdImageException(
string message
);

Parameters

message
The exception message.

See Also

PsdImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | PsdImageException Constructor Overload List


PsdImageException Constructor (String, Exception)

Initializes a new instance of the PsdImageException class.

public PsdImageException(
string message,
Exception innerException
);

Parameters

message
The exception message.
innerException
The inner exception.

See Also

PsdImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | PsdImageException Constructor Overload List


PsdImageResourceException Class

The psd image resource exception.

For a list of all members of this type, see PsdImageResourceException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.ImageException
Aspose.Imaging.Exceptions.ImageFormats.PsdImageException
Aspose.Imaging.Exceptions.ImageFormats.PsdImageResourceException

public class PsdImageResourceException : PsdImageException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions.ImageFormats

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PsdImageResourceException Members | Aspose.Imaging.Exceptions.ImageFormats Namespace


PsdImageResourceException Members

PsdImageResourceException overview

Public Instance Constructors

PsdImageResourceException Overloaded. Initializes a new instance of the PsdImageResourceException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Resource | Gets the psd resource which caused this exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PsdImageResourceException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


PsdImageResourceException Constructor

Initializes a new instance of the PsdImageResourceException class.

Overload List

Initializes a new instance of the PsdImageResourceException class.

public PsdImageResourceException(string,ResourceBlock);

Initializes a new instance of the PsdImageResourceException class.

public PsdImageResourceException(string,ResourceBlock,Exception);

See Also

PsdImageResourceException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


PsdImageResourceException Constructor (String, ResourceBlock)

Initializes a new instance of the PsdImageResourceException class.

public PsdImageResourceException(
string message,
ResourceBlock resource
);

Parameters

message
The exception message.
resource
The resource.

See Also

PsdImageResourceException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | PsdImageResourceException Constructor Overload List


PsdImageResourceException Constructor (String, ResourceBlock, Exception)

Initializes a new instance of the PsdImageResourceException class.

public PsdImageResourceException(
string message,
ResourceBlock resource,
Exception innerException
);

Parameters

message
The exception message.
resource
The resource.
innerException
The inner exception.

See Also

PsdImageResourceException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | PsdImageResourceException Constructor Overload List


PsdImageResourceException Properties

The properties of the PsdImageResourceException class are listed below. For a complete list of PsdImageResourceException class members, see the PsdImageResourceException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Resource | Gets the psd resource which caused this exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

PsdImageResourceException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


Resource Property

Aspose.Imaging Documentation

PsdImageResourceException.Resource Property

Gets the psd resource which caused this exception.

public ResourceBlock Resource {get;}

Property Value

The resource.

See Also

PsdImageResourceException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


TiffImageException Class

The Tiff image exception

For a list of all members of this type, see TiffImageException Members.

System.Object
System.Exception
Aspose.Imaging.Exceptions.ImageException
Aspose.Imaging.Exceptions.ImageFormats.TiffImageException

public class TiffImageException : ImageException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exceptions.ImageFormats

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffImageException Members | Aspose.Imaging.Exceptions.ImageFormats Namespace


TiffImageException Members

TiffImageException overview

Public Instance Constructors

TiffImageException Overloaded. Initializes a new instance of the TiffImageException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
OptionsError | Gets the tiff options error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TiffImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


TiffImageException Constructor

Initializes a new instance of the TiffImageException class.

Overload List

Initializes a new instance of the TiffImageException class.

public TiffImageException(TiffOptionsError);

Initializes a new instance of the TiffImageException class.

public TiffImageException(string);

Initializes a new instance of the TiffImageException class.

public TiffImageException(string,TiffOptionsError);

Initializes a new instance of the TiffImageException class.

public TiffImageException(string,Exception);

See Also

TiffImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


TiffImageException Constructor (String)

Initializes a new instance of the TiffImageException class.

public TiffImageException(
string message
);

Parameters

message
The exception message.

See Also

TiffImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | TiffImageException Constructor Overload List


TiffImageException Constructor (String, Exception)

Initializes a new instance of the TiffImageException class.

public TiffImageException(
string message,
Exception innerException
);

Parameters

message
The message.
innerException
The inner exception.

See Also

TiffImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | TiffImageException Constructor Overload List


TiffImageException Constructor (String, TiffOptionsError)

Initializes a new instance of the TiffImageException class.

public TiffImageException(
string message,
TiffOptionsError error
);

Parameters

message
The message.
error
The error.

See Also

TiffImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | TiffImageException Constructor Overload List


TiffImageException Constructor (TiffOptionsError)

Initializes a new instance of the TiffImageException class.

public TiffImageException(
TiffOptionsError error
);

Parameters

error
The error.

See Also

TiffImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace | TiffImageException Constructor Overload List


TiffImageException Properties

The properties of the TiffImageException class are listed below. For a complete list of TiffImageException class members, see the TiffImageException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
OptionsError | Gets the tiff options error.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

TiffImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


OptionsError Property

Aspose.Imaging Documentation

TiffImageException.OptionsError Property

Gets the tiff options error.

public TiffOptionsError OptionsError {get;}

Property Value

The tiff options error.

See Also

TiffImageException Class | Aspose.Imaging.Exceptions.ImageFormats Namespace


Aspose.Imaging.Exif

Aspose.Imaging Documentation

Aspose.Imaging.Exif Namespace

Namespace hierarchy

Classes

Class | Description
ExifData | Exif data container.
JpegExifData | Exif data container for jpeg files.

Enumerations

Enumeration | Description
ExifProperties | Exif tags list


ExifData Class

Exif data container.

For a list of all members of this type, see ExifData Members.

System.Object
Aspose.Imaging.Exif.ExifData
Aspose.Imaging.Exif.JpegExifData

public class ExifData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exif

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ExifData Members | Aspose.Imaging.Exif Namespace


ExifData Members

ExifData overview

Public Instance Constructors

ExifData Overloaded. Initializes a new instance of the ExifData class.

Public Instance Properties

ApertureValue | Gets or sets the aperture value.
BodySerialNumber | Gets or sets camera body serial number.
BrightnessValue | Gets or sets the brightness value.
CameraOwnerName | Get or set camera owner name
CFAPattern | Gets or sets the cfa pattern.
ColorSpace | Gets or sets the color space.
ComponentsConfiguration | Gets or sets the components configuration.
CompressedBitsPerPixel | Gets or sets the compressed bits per pixel.
Contrast | Gets or sets the contrast.
CustomRendered | Gets or sets the custom rendered.
DateTimeDigitized | Gets or sets the date time digitized.
DateTimeOriginal | Gets or sets the date time original.
DeviceSettingDescription | Gets or sets device settings description
DigitalZoomRatio | Gets or sets the digital zoom ratio.
ExifVersion | Gets or sets the exif version.
ExposureBiasValue | Gets or sets the exposure bias value.
ExposureIndex | Gets or sets the exposure index.
ExposureMode | Gets or sets the exposure mode.
ExposureProgram | Gets or sets the exposure program.
ExposureTime | Gets or sets the exposure time.
FileSource | Gets or sets the file source type.
Flash | Gets or sets the flash.
FlashEnergy | Gets or sets the flash energy.
FlashpixVersion | Gets or sets the flashpix version.
FNumber | Gets or sets the f number.
FocalLength | Gets or sets the focal length.
FocalLengthIn35MmFilm | Gets or sets the focal length in 35 mm film.
FocalPlaneResolutionUnit | Gets or sets the focal plane resolution unit.
FocalPlaneXResolution | Gets or sets the focal plane x resolution.
FocalPlaneYResolution | Gets or sets the focal plane y resolution.
GainControl | Gets or sets the gain control.
Gamma | Get or set gamma.
GPSAltitude | Gets or sets the gps altitude.
GPSAltitudeRef | Gets or sets the gps altitude ref.
GPSAreaInformation | Gets or sets the gps area information.
GPSDateStamp | Gets or sets the gps img direction ref.
GPSDestBearing | Gets or sets the gps dest bearing.
GPSDestBearingRef | Gets or sets the gps dest bearing ref.
GPSDestDistance | Gets or sets the gps dest distance.
GPSDestDistanceRef | Gets or sets the gps dest distance ref.
GPSDestLatitude | Gets or sets the gps dest latitude.
GPSDestLatitudeRef | Gets or sets the gps dest latitude ref.
GPSDestLongitude | Gets or sets the gps dest longitude.
GPSDestLongitudeRef | Gets or sets the gps dest longitude ref.
GPSDifferential | Gets or sets the gps differential.
GPSDOP | Gets or sets the gpsdop.
GPSImgDirection | Gets or sets the gps img direction.
GPSImgDirectionRef | Gets or sets the gps img direction ref.
GPSLatitude | Gets or sets the gps latitude.
GPSLatitudeRef | Gets or sets the gps latitude ref.
GPSLongitude | Gets or sets the gps longitude.
GPSLongitudeRef | Gets or sets the gps longitude ref.
GPSMapDatum | Gets or sets the gps map datum.
GPSMeasureMode | Gets or sets the gps measure mode.
GPSProcessingMethod | Gets or sets the gps processing method.
GPSSatellites | Gets or sets the gps satellites.
GPSSpeed | Gets or sets the gps speed.
GPSSpeedRef | Gets or sets the gps speed ref.
GPSStatus | Gets or sets the gps status.
GPSTimestamp | Gets or sets the gps timestamp.
GPSTrack | Gets or sets the gps track.
GPSTrackRef | Gets or sets the gps track ref.
GPSVersionID | Gets or sets the gps version id.
ImageUniqueID | Gets or sets the image unique id.
ISOSpeed | Gets or sets ISO speed
ISOSpeedLatitudeYYY | Gets or sets ISO Speed Latitude YYY value
ISOSpeedLatitudeZZZ | Gets or sets ISO Speed Latitude YYY value
LensMake | Get or set maker of lens
LensModel | Get or set lens model
LensSerialNumber | Get or set lens serial number
LensSpecification | Gets or sets lens specification
LightSource | Gets or sets the light source.
MakerNoteData | Gets the maker note data.
MakerNoteRawData | Gets or sets the maker note raw data.
MaxApertureValue | Gets or sets the max aperture value.
MeteringMode | Gets or sets the metering mode.
OECF | Gets or sets the oecf.
PhotographicSensitivity | Gets or sets the iso speed ratings.
PixelXDimension | Gets or sets the pixel x dimension.
PixelYDimension | Gets or sets the pixel y dimension.
Properties | Gets or sets the properties.
RecommendedExposureIndex | Gets or sets recommended exposure index
RelatedSoundFile | Gets or sets the related sound file.
Saturation | Gets or sets the saturation.
SceneCaptureType | Gets or sets the scene capture type.
SceneType | Gets or sets the scene type.
SensingMethod | Gets or sets the sensing method.
SensitivityType | Get or set sensitivity type
Sharpness | Gets or sets the sharpness.
ShutterSpeedValue | Gets or sets the shutter speed value.
SpatialFrequencyResponse | Gets or sets the spatial frequency response.
SpectralSensitivity | Gets or sets the spectral sensitivity.
StandardOutputSensitivity | Gets or sets standard output sensitivity
SubjectArea | Gets or sets the subject area.
SubjectDistance | Gets or sets the subject distance.
SubjectDistanceRange | Gets or sets the subject distance range.
SubjectLocation | Gets or sets the subject location.
SubsecTime | Gets or sets the subsec time.
SubsecTimeDigitized | Gets or sets the subsec time digitized.
SubsecTimeOriginal | Gets or sets the subsec time original.
UserComment | Gets or sets the user comment.
WhiteBalance | Gets or sets the white balance.
WhitePoint | Gets or sets the white point.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveTag | Remove tag from container
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

Dictionary Gets or sets the properties.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSectionTags Get tags, belonging to n-th section.

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExifData Constructor

Initializes a new instance of the ExifData class.

Overload List

Initializes a new instance of the ExifData class.

public ExifData();

Initializes a new instance of the ExifData class with data from array.

public ExifData(TiffDataType[]);

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExifData Constructor ()

Initializes a new instance of the ExifData class.

public ExifData();

See Also

ExifData Class | Aspose.Imaging.Exif Namespace | ExifData Constructor Overload List


ExifData Constructor (TiffDataType[])

Initializes a new instance of the ExifData class with data from array.

public ExifData(
TiffDataType[] exifdata
);

Parameters

exifdata
Array of exif tags.

See Also

ExifData Class | Aspose.Imaging.Exif Namespace | ExifData Constructor Overload List


ExifData Fields

The fields of the ExifData class are listed below. For a complete list of ExifData class members, see the ExifData Members topic.

Protected Instance Fields

Dictionary Gets or sets the properties.

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExifData.Dictionary Field

Gets or sets the properties.

protected readonly TiffDataType} Dictionary;

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExifData Properties

The properties of the ExifData class are listed below. For a complete list of ExifData class members, see the ExifData Members topic.

Public Instance Properties

ApertureValue | Gets or sets the aperture value.
BodySerialNumber | Gets or sets camera body serial number.
BrightnessValue | Gets or sets the brightness value.
CameraOwnerName | Get or set camera owner name
CFAPattern | Gets or sets the cfa pattern.
ColorSpace | Gets or sets the color space.
ComponentsConfiguration | Gets or sets the components configuration.
CompressedBitsPerPixel | Gets or sets the compressed bits per pixel.
Contrast | Gets or sets the contrast.
CustomRendered | Gets or sets the custom rendered.
DateTimeDigitized | Gets or sets the date time digitized.
DateTimeOriginal | Gets or sets the date time original.
DeviceSettingDescription | Gets or sets device settings description
DigitalZoomRatio | Gets or sets the digital zoom ratio.
ExifVersion | Gets or sets the exif version.
ExposureBiasValue | Gets or sets the exposure bias value.
ExposureIndex | Gets or sets the exposure index.
ExposureMode | Gets or sets the exposure mode.
ExposureProgram | Gets or sets the exposure program.
ExposureTime | Gets or sets the exposure time.
FileSource | Gets or sets the file source type.
Flash | Gets or sets the flash.
FlashEnergy | Gets or sets the flash energy.
FlashpixVersion | Gets or sets the flashpix version.
FNumber | Gets or sets the f number.
FocalLength | Gets or sets the focal length.
FocalLengthIn35MmFilm | Gets or sets the focal length in 35 mm film.
FocalPlaneResolutionUnit | Gets or sets the focal plane resolution unit.
FocalPlaneXResolution | Gets or sets the focal plane x resolution.
FocalPlaneYResolution | Gets or sets the focal plane y resolution.
GainControl | Gets or sets the gain control.
Gamma | Get or set gamma.
GPSAltitude | Gets or sets the gps altitude.
GPSAltitudeRef | Gets or sets the gps altitude ref.
GPSAreaInformation | Gets or sets the gps area information.
GPSDateStamp | Gets or sets the gps img direction ref.
GPSDestBearing | Gets or sets the gps dest bearing.
GPSDestBearingRef | Gets or sets the gps dest bearing ref.
GPSDestDistance | Gets or sets the gps dest distance.
GPSDestDistanceRef | Gets or sets the gps dest distance ref.
GPSDestLatitude | Gets or sets the gps dest latitude.
GPSDestLatitudeRef | Gets or sets the gps dest latitude ref.
GPSDestLongitude | Gets or sets the gps dest longitude.
GPSDestLongitudeRef | Gets or sets the gps dest longitude ref.
GPSDifferential | Gets or sets the gps differential.
GPSDOP | Gets or sets the gpsdop.
GPSImgDirection | Gets or sets the gps img direction.
GPSImgDirectionRef | Gets or sets the gps img direction ref.
GPSLatitude | Gets or sets the gps latitude.
GPSLatitudeRef | Gets or sets the gps latitude ref.
GPSLongitude | Gets or sets the gps longitude.
GPSLongitudeRef | Gets or sets the gps longitude ref.
GPSMapDatum | Gets or sets the gps map datum.
GPSMeasureMode | Gets or sets the gps measure mode.
GPSProcessingMethod | Gets or sets the gps processing method.
GPSSatellites | Gets or sets the gps satellites.
GPSSpeed | Gets or sets the gps speed.
GPSSpeedRef | Gets or sets the gps speed ref.
GPSStatus | Gets or sets the gps status.
GPSTimestamp | Gets or sets the gps timestamp.
GPSTrack | Gets or sets the gps track.
GPSTrackRef | Gets or sets the gps track ref.
GPSVersionID | Gets or sets the gps version id.
ImageUniqueID | Gets or sets the image unique id.
ISOSpeed | Gets or sets ISO speed
ISOSpeedLatitudeYYY | Gets or sets ISO Speed Latitude YYY value
ISOSpeedLatitudeZZZ | Gets or sets ISO Speed Latitude YYY value
LensMake | Get or set maker of lens
LensModel | Get or set lens model
LensSerialNumber | Get or set lens serial number
LensSpecification | Gets or sets lens specification
LightSource | Gets or sets the light source.
MakerNoteData | Gets the maker note data.
MakerNoteRawData | Gets or sets the maker note raw data.
MaxApertureValue | Gets or sets the max aperture value.
MeteringMode | Gets or sets the metering mode.
OECF | Gets or sets the oecf.
PhotographicSensitivity | Gets or sets the iso speed ratings.
PixelXDimension | Gets or sets the pixel x dimension.
PixelYDimension | Gets or sets the pixel y dimension.
Properties | Gets or sets the properties.
RecommendedExposureIndex | Gets or sets recommended exposure index
RelatedSoundFile | Gets or sets the related sound file.
Saturation | Gets or sets the saturation.
SceneCaptureType | Gets or sets the scene capture type.
SceneType | Gets or sets the scene type.
SensingMethod | Gets or sets the sensing method.
SensitivityType | Get or set sensitivity type
Sharpness | Gets or sets the sharpness.
ShutterSpeedValue | Gets or sets the shutter speed value.
SpatialFrequencyResponse | Gets or sets the spatial frequency response.
SpectralSensitivity | Gets or sets the spectral sensitivity.
StandardOutputSensitivity | Gets or sets standard output sensitivity
SubjectArea | Gets or sets the subject area.
SubjectDistance | Gets or sets the subject distance.
SubjectDistanceRange | Gets or sets the subject distance range.
SubjectLocation | Gets or sets the subject location.
SubsecTime | Gets or sets the subsec time.
SubsecTimeDigitized | Gets or sets the subsec time digitized.
SubsecTimeOriginal | Gets or sets the subsec time original.
UserComment | Gets or sets the user comment.
WhiteBalance | Gets or sets the white balance.
WhitePoint | Gets or sets the white point.

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ApertureValue Property

Aspose.Imaging Documentation

ExifData.ApertureValue Property

Gets or sets the aperture value.

public TiffRational ApertureValue {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


BodySerialNumber Property

Aspose.Imaging Documentation

ExifData.BodySerialNumber Property

Gets or sets camera body serial number.

public string BodySerialNumber {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


BrightnessValue Property

Aspose.Imaging Documentation

ExifData.BrightnessValue Property

Gets or sets the brightness value.

public TiffSRational BrightnessValue {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


CameraOwnerName Property

Aspose.Imaging Documentation

ExifData.CameraOwnerName Property

Get or set camera owner name

public string CameraOwnerName {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


CFAPattern Property

Aspose.Imaging Documentation

ExifData.CFAPattern Property

Gets or sets the cfa pattern.

public byte[] CFAPattern {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ColorSpace Property

Aspose.Imaging Documentation

ExifData.ColorSpace Property

Gets or sets the color space.

public ExifColorSpace ColorSpace {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ComponentsConfiguration Property

Aspose.Imaging Documentation

ExifData.ComponentsConfiguration Property

Gets or sets the components configuration.

public byte[] ComponentsConfiguration {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


CompressedBitsPerPixel Property

Aspose.Imaging Documentation

ExifData.CompressedBitsPerPixel Property

Gets or sets the compressed bits per pixel.

public TiffRational CompressedBitsPerPixel {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


Contrast Property

Aspose.Imaging Documentation

ExifData.Contrast Property

Gets or sets the contrast.

public ExifContrast Contrast {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


CustomRendered Property

Aspose.Imaging Documentation

ExifData.CustomRendered Property

Gets or sets the custom rendered.

public ExifCustomRendered CustomRendered {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


DateTimeDigitized Property

Aspose.Imaging Documentation

ExifData.DateTimeDigitized Property

Gets or sets the date time digitized.

public string DateTimeDigitized {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


DateTimeOriginal Property

Aspose.Imaging Documentation

ExifData.DateTimeOriginal Property

Gets or sets the date time original.

public string DateTimeOriginal {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


DeviceSettingDescription Property

Aspose.Imaging Documentation

ExifData.DeviceSettingDescription Property

Gets or sets device settings description

public byte[] DeviceSettingDescription {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


DigitalZoomRatio Property

Aspose.Imaging Documentation

ExifData.DigitalZoomRatio Property

Gets or sets the digital zoom ratio.

public TiffRational DigitalZoomRatio {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExifVersion Property

Aspose.Imaging Documentation

ExifData.ExifVersion Property

Gets or sets the exif version.

public byte[] ExifVersion {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExposureBiasValue Property

Aspose.Imaging Documentation

ExifData.ExposureBiasValue Property

Gets or sets the exposure bias value.

public TiffSRational ExposureBiasValue {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExposureIndex Property

Aspose.Imaging Documentation

ExifData.ExposureIndex Property

Gets or sets the exposure index.

public TiffRational ExposureIndex {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExposureMode Property

Aspose.Imaging Documentation

ExifData.ExposureMode Property

Gets or sets the exposure mode.

public ExifExposureMode ExposureMode {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExposureProgram Property

Aspose.Imaging Documentation

ExifData.ExposureProgram Property

Gets or sets the exposure program.

public ExifExposureProgram ExposureProgram {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExposureTime Property

Aspose.Imaging Documentation

ExifData.ExposureTime Property

Gets or sets the exposure time.

public TiffRational ExposureTime {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


FileSource Property

Aspose.Imaging Documentation

ExifData.FileSource Property

Gets or sets the file source type.

public ExifFileSource FileSource {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


Flash Property

Aspose.Imaging Documentation

ExifData.Flash Property

Gets or sets the flash.

public ExifFlash Flash {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


FlashEnergy Property

Aspose.Imaging Documentation

ExifData.FlashEnergy Property

Gets or sets the flash energy.

public TiffRational FlashEnergy {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


FlashpixVersion Property

Aspose.Imaging Documentation

ExifData.FlashpixVersion Property

Gets or sets the flashpix version.

public byte[] FlashpixVersion {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


FNumber Property

Aspose.Imaging Documentation

ExifData.FNumber Property

Gets or sets the f number.

public TiffRational FNumber {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


FocalLength Property

Aspose.Imaging Documentation

ExifData.FocalLength Property

Gets or sets the focal length.

public TiffRational FocalLength {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


FocalLengthIn35MmFilm Property

Aspose.Imaging Documentation

ExifData.FocalLengthIn35MmFilm Property

Gets or sets the focal length in 35 mm film.

public ushort FocalLengthIn35MmFilm {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


FocalPlaneResolutionUnit Property

Aspose.Imaging Documentation

ExifData.FocalPlaneResolutionUnit Property

Gets or sets the focal plane resolution unit.

public ExifUnit FocalPlaneResolutionUnit {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


FocalPlaneXResolution Property

Aspose.Imaging Documentation

ExifData.FocalPlaneXResolution Property

Gets or sets the focal plane x resolution.

public TiffRational FocalPlaneXResolution {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


FocalPlaneYResolution Property

Aspose.Imaging Documentation

ExifData.FocalPlaneYResolution Property

Gets or sets the focal plane y resolution.

public TiffRational FocalPlaneYResolution {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GainControl Property

Aspose.Imaging Documentation

ExifData.GainControl Property

Gets or sets the gain control.

public ExifGainControl GainControl {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


Gamma Property

Aspose.Imaging Documentation

ExifData.Gamma Property

Get or set gamma.

public TiffRational Gamma {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSAltitude Property

Aspose.Imaging Documentation

ExifData.GPSAltitude Property

Gets or sets the gps altitude.

public TiffRational GPSAltitude {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSAltitudeRef Property

Aspose.Imaging Documentation

ExifData.GPSAltitudeRef Property

Gets or sets the gps altitude ref.

public ExifGPSAltitudeRef GPSAltitudeRef {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSAreaInformation Property

Aspose.Imaging Documentation

ExifData.GPSAreaInformation Property

Gets or sets the gps area information.

public byte[] GPSAreaInformation {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSDateStamp Property

Aspose.Imaging Documentation

ExifData.GPSDateStamp Property

Gets or sets the gps img direction ref.

public string GPSDateStamp {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSDestBearing Property

Aspose.Imaging Documentation

ExifData.GPSDestBearing Property

Gets or sets the gps dest bearing.

public TiffRational GPSDestBearing {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSDestBearingRef Property

Aspose.Imaging Documentation

ExifData.GPSDestBearingRef Property

Gets or sets the gps dest bearing ref.

public string GPSDestBearingRef {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSDestDistance Property

Aspose.Imaging Documentation

ExifData.GPSDestDistance Property

Gets or sets the gps dest distance.

public TiffRational GPSDestDistance {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSDestDistanceRef Property

Aspose.Imaging Documentation

ExifData.GPSDestDistanceRef Property

Gets or sets the gps dest distance ref.

public string GPSDestDistanceRef {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSDestLatitude Property

Aspose.Imaging Documentation

ExifData.GPSDestLatitude Property

Gets or sets the gps dest latitude.

public TiffRational[] GPSDestLatitude {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSDestLatitudeRef Property

Aspose.Imaging Documentation

ExifData.GPSDestLatitudeRef Property

Gets or sets the gps dest latitude ref.

public string GPSDestLatitudeRef {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSDestLongitude Property

Aspose.Imaging Documentation

ExifData.GPSDestLongitude Property

Gets or sets the gps dest longitude.

public TiffRational[] GPSDestLongitude {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSDestLongitudeRef Property

Aspose.Imaging Documentation

ExifData.GPSDestLongitudeRef Property

Gets or sets the gps dest longitude ref.

public string GPSDestLongitudeRef {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSDifferential Property

Aspose.Imaging Documentation

ExifData.GPSDifferential Property

Gets or sets the gps differential.

public ushort GPSDifferential {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSDOP Property

Aspose.Imaging Documentation

ExifData.GPSDOP Property

Gets or sets the gpsdop.

public TiffRational GPSDOP {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSImgDirection Property

Aspose.Imaging Documentation

ExifData.GPSImgDirection Property

Gets or sets the gps img direction.

public TiffRational GPSImgDirection {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSImgDirectionRef Property

Aspose.Imaging Documentation

ExifData.GPSImgDirectionRef Property

Gets or sets the gps img direction ref.

public string GPSImgDirectionRef {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSLatitude Property

Aspose.Imaging Documentation

ExifData.GPSLatitude Property

Gets or sets the gps latitude.

public TiffRational[] GPSLatitude {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSLatitudeRef Property

Aspose.Imaging Documentation

ExifData.GPSLatitudeRef Property

Gets or sets the gps latitude ref.

public string GPSLatitudeRef {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSLongitude Property

Aspose.Imaging Documentation

ExifData.GPSLongitude Property

Gets or sets the gps longitude.

public TiffRational[] GPSLongitude {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSLongitudeRef Property

Aspose.Imaging Documentation

ExifData.GPSLongitudeRef Property

Gets or sets the gps longitude ref.

public string GPSLongitudeRef {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSMapDatum Property

Aspose.Imaging Documentation

ExifData.GPSMapDatum Property

Gets or sets the gps map datum.

public string GPSMapDatum {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSMeasureMode Property

Aspose.Imaging Documentation

ExifData.GPSMeasureMode Property

Gets or sets the gps measure mode.

public string GPSMeasureMode {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSProcessingMethod Property

Aspose.Imaging Documentation

ExifData.GPSProcessingMethod Property

Gets or sets the gps processing method.

public byte[] GPSProcessingMethod {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSSatellites Property

Aspose.Imaging Documentation

ExifData.GPSSatellites Property

Gets or sets the gps satellites.

public string GPSSatellites {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSSpeed Property

Aspose.Imaging Documentation

ExifData.GPSSpeed Property

Gets or sets the gps speed.

public TiffRational GPSSpeed {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSSpeedRef Property

Aspose.Imaging Documentation

ExifData.GPSSpeedRef Property

Gets or sets the gps speed ref.

public string GPSSpeedRef {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSStatus Property

Aspose.Imaging Documentation

ExifData.GPSStatus Property

Gets or sets the gps status.

public string GPSStatus {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSTimestamp Property

Aspose.Imaging Documentation

ExifData.GPSTimestamp Property

Gets or sets the gps timestamp.

public TiffRational[] GPSTimestamp {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSTrack Property

Aspose.Imaging Documentation

ExifData.GPSTrack Property

Gets or sets the gps track.

public string GPSTrack {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSTrackRef Property

Aspose.Imaging Documentation

ExifData.GPSTrackRef Property

Gets or sets the gps track ref.

public string GPSTrackRef {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


GPSVersionID Property

Aspose.Imaging Documentation

ExifData.GPSVersionID Property

Gets or sets the gps version id.

public byte[] GPSVersionID {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ImageUniqueID Property

Aspose.Imaging Documentation

ExifData.ImageUniqueID Property

Gets or sets the image unique id.

public string ImageUniqueID {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ISOSpeed Property

Aspose.Imaging Documentation

ExifData.ISOSpeed Property

Gets or sets ISO speed

public uint ISOSpeed {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ISOSpeedLatitudeYYY Property

Aspose.Imaging Documentation

ExifData.ISOSpeedLatitudeYYY Property

Gets or sets ISO Speed Latitude YYY value

public uint ISOSpeedLatitudeYYY {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ISOSpeedLatitudeZZZ Property

Aspose.Imaging Documentation

ExifData.ISOSpeedLatitudeZZZ Property

Gets or sets ISO Speed Latitude YYY value

public uint ISOSpeedLatitudeZZZ {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


LensMake Property

Aspose.Imaging Documentation

ExifData.LensMake Property

Get or set maker of lens

public string LensMake {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


LensModel Property

Aspose.Imaging Documentation

ExifData.LensModel Property

Get or set lens model

public string LensModel {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


LensSerialNumber Property

Aspose.Imaging Documentation

ExifData.LensSerialNumber Property

Get or set lens serial number

public string LensSerialNumber {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


LensSpecification Property

Aspose.Imaging Documentation

ExifData.LensSpecification Property

Gets or sets lens specification

public TiffRational[] LensSpecification {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


LightSource Property

Aspose.Imaging Documentation

ExifData.LightSource Property

Gets or sets the light source.

public ExifLightSource LightSource {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


MakerNoteData Property

Aspose.Imaging Documentation

ExifData.MakerNoteData Property

Gets the maker note data.

public TiffDataType[] MakerNoteData {get;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


MakerNoteRawData Property

Aspose.Imaging Documentation

ExifData.MakerNoteRawData Property

Gets or sets the maker note raw data.

public byte[] MakerNoteRawData {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


MaxApertureValue Property

Aspose.Imaging Documentation

ExifData.MaxApertureValue Property

Gets or sets the max aperture value.

public TiffRational MaxApertureValue {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


MeteringMode Property

Aspose.Imaging Documentation

ExifData.MeteringMode Property

Gets or sets the metering mode.

public ExifMeteringMode MeteringMode {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


OECF Property

Aspose.Imaging Documentation

ExifData.OECF Property

Gets or sets the oecf.

public byte[] OECF {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


PhotographicSensitivity Property

Aspose.Imaging Documentation

ExifData.PhotographicSensitivity Property

Gets or sets the iso speed ratings.

public uint PhotographicSensitivity {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


PixelXDimension Property

Aspose.Imaging Documentation

ExifData.PixelXDimension Property

Gets or sets the pixel x dimension.

public uint PixelXDimension {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


PixelYDimension Property

Aspose.Imaging Documentation

ExifData.PixelYDimension Property

Gets or sets the pixel y dimension.

public uint PixelYDimension {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


Properties Property

Aspose.Imaging Documentation

ExifData.Properties Property

Gets or sets the properties.

public TiffDataType[] Properties {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


RecommendedExposureIndex Property

Aspose.Imaging Documentation

ExifData.RecommendedExposureIndex Property

Gets or sets recommended exposure index

public uint RecommendedExposureIndex {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


RelatedSoundFile Property

Aspose.Imaging Documentation

ExifData.RelatedSoundFile Property

Gets or sets the related sound file.

public string RelatedSoundFile {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


Saturation Property

Aspose.Imaging Documentation

ExifData.Saturation Property

Gets or sets the saturation.

public ExifSaturation Saturation {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SceneCaptureType Property

Aspose.Imaging Documentation

ExifData.SceneCaptureType Property

Gets or sets the scene capture type.

public ExifSceneCaptureType SceneCaptureType {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SceneType Property

Aspose.Imaging Documentation

ExifData.SceneType Property

Gets or sets the scene type.

public byte SceneType {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SensingMethod Property

Aspose.Imaging Documentation

ExifData.SensingMethod Property

Gets or sets the sensing method.

public ExifSensingMethod SensingMethod {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SensitivityType Property

Aspose.Imaging Documentation

ExifData.SensitivityType Property

Get or set sensitivity type

public ushort SensitivityType {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


Sharpness Property

Aspose.Imaging Documentation

ExifData.Sharpness Property

Gets or sets the sharpness.

public ushort Sharpness {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ShutterSpeedValue Property

Aspose.Imaging Documentation

ExifData.ShutterSpeedValue Property

Gets or sets the shutter speed value.

public TiffSRational ShutterSpeedValue {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SpatialFrequencyResponse Property

Aspose.Imaging Documentation

ExifData.SpatialFrequencyResponse Property

Gets or sets the spatial frequency response.

public byte[] SpatialFrequencyResponse {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SpectralSensitivity Property

Aspose.Imaging Documentation

ExifData.SpectralSensitivity Property

Gets or sets the spectral sensitivity.

public string SpectralSensitivity {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


StandardOutputSensitivity Property

Aspose.Imaging Documentation

ExifData.StandardOutputSensitivity Property

Gets or sets standard output sensitivity

public uint StandardOutputSensitivity {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SubjectArea Property

Aspose.Imaging Documentation

ExifData.SubjectArea Property

Gets or sets the subject area.

public ushort[] SubjectArea {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SubjectDistance Property

Aspose.Imaging Documentation

ExifData.SubjectDistance Property

Gets or sets the subject distance.

public TiffRational SubjectDistance {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SubjectDistanceRange Property

Aspose.Imaging Documentation

ExifData.SubjectDistanceRange Property

Gets or sets the subject distance range.

public ExifSubjectDistanceRange SubjectDistanceRange {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SubjectLocation Property

Aspose.Imaging Documentation

ExifData.SubjectLocation Property

Gets or sets the subject location.

public ushort[] SubjectLocation {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SubsecTime Property

Aspose.Imaging Documentation

ExifData.SubsecTime Property

Gets or sets the subsec time.

public string SubsecTime {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SubsecTimeDigitized Property

Aspose.Imaging Documentation

ExifData.SubsecTimeDigitized Property

Gets or sets the subsec time digitized.

public string SubsecTimeDigitized {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


SubsecTimeOriginal Property

Aspose.Imaging Documentation

ExifData.SubsecTimeOriginal Property

Gets or sets the subsec time original.

public string SubsecTimeOriginal {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


UserComment Property

Aspose.Imaging Documentation

ExifData.UserComment Property

Gets or sets the user comment.

public string UserComment {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


WhiteBalance Property

Aspose.Imaging Documentation

ExifData.WhiteBalance Property

Gets or sets the white balance.

public ExifWhiteBalance WhiteBalance {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


WhitePoint Property

Aspose.Imaging Documentation

ExifData.WhitePoint Property

Gets or sets the white point.

public TiffRational[] WhitePoint {get; set;}

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExifData Methods

The methods of the ExifData class are listed below. For a complete list of ExifData class members, see the ExifData Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveTag | Remove tag from container
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

GetSectionTags Get tags, belonging to n-th section.

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExifData.GetSectionTags Method

Get tags, belonging to n-th section.

protected internal TiffDataType[] GetSectionTags(
int sectionId
);

Parameters

sectionId
Id of section

Return Value

Array of tags

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExifData.RemoveTag Method

Remove tag from container

public void RemoveTag(
ExifProperties tag
);

Parameters

tag
Tag to remove

See Also

ExifData Class | Aspose.Imaging.Exif Namespace


ExifProperties Enumeration

Exif tags list

public enum ExifProperties

Members

Member Name | Description | Value
ImageWidth | The number of columns of image data, equal to the number of pixels per row. | 256
ImageLength | The number of rows of image data. | 257
BitsPerSample | The number of bits per image component. In this standard each component of the image is 8 bits, so the value for this tag is 8. | 258
Compression | The compression scheme used for the image data. When a primary image is JPEG compressed, this designation is not necessary and is omitted. | 259
PhotometricInterpretation | The pixel composition. | 262
ImageDescription | A character string giving the title of the image. It may be a comment such as "1988 company picnic" or the like. | 270
Make | The manufacturer of the recording equipment. This is the manufacturer of the DSC, scanner, video digitizer or other equipment that generated the image. When the field is left blank, it is treated as unknown. | 271
Model | The model name or model number of the equipment. This is the model name or number of the DSC, scanner, video digitizer or other equipment that generated the image. When the field is left blank, it is treated as unknown. | 272
Orientation | The image orientation viewed in terms of rows and columns. | 274
SamplesPerPixel | The number of components per pixel. Since this standard applies to RGB and YCbCr images, the value set for this tag is 3. | 277
XResolution | The number of pixels per ResolutionUnit in the ImageWidth direction. When the image resolution is unknown, 72 [dpi] is designated. | 282
YResolution | The number of pixels per ResolutionUnit in the ImageLength direction. The same value as XResolution is designated. | 283
PlanarConfiguration | Indicates whether pixel components are recorded in a chunky or planar format. If this field does not exist, the TIFF default of 1 (chunky) is assumed. | 284
ResolutionUnit | The unit for measuring XResolution and YResolution. The same unit is used for both XResolution and YResolution. If the image resolution is unknown, 2 (inches) is designated. | 296
TransferFunction | A transfer function for the image, described in tabular style. Normally this tag is not necessary, since color space is specified in the color space information ColorSpace tag. | 301
Software | This tag records the name and version of the software or firmware of the camera or image input device used to generate the image. The detailed format is not specified, but it is recommended that the example shown below be followed. When the field is left blank, it is treated as unknown. | 305
DateTime | The date and time of image creation. In Exif standard, it is the date and time the file was changed. | 306
Artist | This tag records the name of the camera owner, photographer or image creator. The detailed format is not specified, but it is recommended that the information be written as in the example below for ease of Interoperability. When the field is left blank, it is treated as unknown. Ex.) "Camera owner, John Smith; Photographer, Michael Brown; Image creator, Ken James" | 315
WhitePoint | The chromaticity of the white point of the image. Normally this tag is not necessary, since color space is specified in the colorspace information ColorSpace tag. | 318
PrimaryChromaticities | The chromaticity of the three primary colors of the image. Normally this tag is not necessary, since colorspace is specified in the colorspace information ColorSpace tag. | 319
YCbCrCoefficients | The matrix coefficients for transformation from RGB to YCbCr image data. | 529
YCbCrSubSampling | The sampling ratio of chrominance components in relation to the luminance component. | 530
YCbCrPositioning | The position of chrominance components in relation to the luminance component. This field is designated only for JPEG compressed data or uncompressed YCbCr data. The TIFF default is 1 (centered); but when Y:Cb:Cr = 4:2:2 it is recommended in this standard that 2 (co-sited) be used to record data, in order to improve the image quality when viewed on TV systems. When this field does not exist, the reader shall assume the TIFF default. In the case of Y:Cb:Cr = 4:2:0, the TIFF default (centered) is recommended. If the reader does not have the capability of supporting both kinds of YCbCrPositioning, it shall follow the TIFF default regardless of the value in this field. It is preferable that readers " be able to support both centered and co-sited positioning. | 531
ReferenceBlackWhite | The reference black point value and reference white point value. No defaults are given in TIFF, but the values below are given as defaults here. The color space is declared in a color space information tag, with the default being the value that gives the optimal image characteristics Interoperability these conditions | 532
Copyright | Copyright information. In this standard the tag is used to indicate both the photographer and editor copyrights. It is the copyright notice of the person or organization claiming rights to the image. The Interoperability copyright statement including date and rights should be written in this field; e.g., "Copyright, John Smith, 19xx. All rights reserved.". In this standard the field records both the photographer and editor copyrights, with each recorded in a separate part of the statement. When there is a clear distinction between the photographer and editor copyrights, these are to be written in the order of photographer followed by editor copyright, separated by NULL (in this case since the statement also ends with a NULL, there are two NULL codes). When only the photographer copyright is given, it is terminated by one NULL code . When only the editor copyright is given, the photographer copyright part consists of one space followed by a terminating NULL code, then the editor copyright is given. When the field is left blank, it is treated as unknown. | 33432
ExposureTime | Exposure time, given in seconds. | 33434
FNumber | The F number. | 33437
ExposureProgram | The class of the program used by the camera to set exposure when the picture is taken. | 34850
SpectralSensitivity | Indicates the spectral sensitivity of each channel of the camera used. | 34852
PhotographicSensitivity | Indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232. | 34855
OECF | Indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524. | 34856
ExifVersion | The exif version. | 36864
DateTimeOriginal | The date and time when the original image data was generated. | 36867
DateTimeDigitized | The date time digitized. | 36868
ComponentsConfiguration | The components configuration. | 37121
CompressedBitsPerPixel | Specific to compressed data; states the compressed bits per pixel. | 37122
ShutterSpeedValue | The shutter speed value. | 37377
ApertureValue | The lens aperture value. | 37378
BrightnessValue | The brightness value. | 37379
ExposureBiasValue | The exposure bias value. | 37380
MaxApertureValue | The max aperture value. | 37381
SubjectDistance | The distance to the subject, given in meters. | 37382
MeteringMode | The metering mode. | 37383
LightSource | The kind light source. | 37384
Flash | Indicates the status of flash when the image was shot. | 37385
FocalLength | The actual focal length of the lens, in mm. | 37386
SubjectArea | This tag indicates the location and area of the main subject in the overall scene. | 37396
MakerNote | A tag for manufacturers of Exif writers to record any desired information. The contents are up to the manufacturer, but this tag should not be used for any other than its intended purpose. | 37500
UserComment | A tag for Exif users to write keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag. | 37510
SubsecTime | A tag used to record fractions of seconds for the DateTime tag. | 37520
SubsecTimeOriginal | A tag used to record fractions of seconds for the DateTimeOriginal tag. | 37521
SubsecTimeDigitized | A tag used to record fractions of seconds for the DateTimeDigitized tag. | 37522
FlashpixVersion | The Flashpix format version supported by a FPXR file. | 40960
ColorSpace | The color space information tag (ColorSpace) is always recorded as the color space specifier. | 40961
RelatedSoundFile | The related sound file. | 40964
FlashEnergy | Indicates the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds(BCPS). | 41483
SpatialFrequencyResponse | This tag records the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233. | 41484
FocalPlaneXResolution | Indicates the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane. | 41486
FocalPlaneYResolution | Indicates the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane. | 41487
FocalPlaneResolutionUnit | Indicates the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution. This value is the same as the ResolutionUnit. | 41488
SubjectLocation | Indicates the location of the main subject in the scene. The value of this tag represents the pixel at the center of the main subject relative to the left edge, prior to rotation processing as per the Rotation tag. | 41492
ExposureIndex | Indicates the exposure index selected on the camera or input device at the time the image is captured. | 41493
SensingMethod | Indicates the image sensor type on the camera or input device. | 41495
FileSource | The file source. | 41728
SceneType | Indicates the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed. | 41729
CFAPattern | Indicates the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods. | 41730
CustomRendered | This tag indicates the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing. | 41985
ExposureMode | This tag indicates the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings. | 41986
WhiteBalance | This tag indicates the white balance mode set when the image was shot. | 41987
DigitalZoomRatio | This tag indicates the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used. | 41988
FocalLengthIn35MmFilm | This tag indicates the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag. | 41989
SceneCaptureType | This tag indicates the type of scene that was shot. It can also be used to record the mode in which the image was shot. | 41990
GainControl | This tag indicates the degree of overall image gain adjustment. | 41991
Contrast | This tag indicates the direction of contrast processing applied by the camera when the image was shot. | 41992
Saturation | This tag indicates the direction of saturation processing applied by the camera when the image was shot. | 41993
Sharpness | This tag indicates the direction of sharpness processing applied by the camera when the image was shot | 41994
DeviceSettingDescription | This tag indicates information on the picture-taking conditions of a particular camera model. The tag is used only to indicate the picture-taking conditions in the reader. | 41995
SubjectDistanceRange | This tag indicates the distance to the subject. | 41996
ImageUniqueID | The image unique id. | 42016
GPSVersionID | Indicates the version of GPSInfoIFD. | 0
GPSLatitudeRef | Indicates whether the latitude is north or south latitude. | 1
GPSLatitude | Indicates the latitude. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1. | 2
GPSLongitudeRef | Indicates whether the longitude is east or west longitude. | 3
GPSLongitude | Indicates the longitude. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1. | 4
GPSAltitudeRef | Indicates the altitude used as the reference altitude. If the reference is sea level and the altitude is above sea level, 0 is given. If the altitude is below sea level, a value of 1 is given and the altitude is indicated as an absolute value in the GPSAltitude tag. | 5
GPSAltitude | Indicates the altitude based on the reference in GPSAltitudeRef. Altitude is expressed as one RATIONAL value. The reference unit is meters. | 6
GPSTimestamp | Indicates the time as UTC (Coordinated Universal Time). TimeStamp is expressed as three RATIONAL values giving the hour, minute, and second. | 7
GPSSatellites | Indicates the GPS satellites used for measurements. This tag can be used to describe the number of satellites, their ID number, angle of elevation, azimuth, SNR and other information in ASCII notation. The format is not specified. If the GPS receiver is incapable of taking measurements, value of the tag shall be set to NULL. | 8
GPSStatus | Indicates the status of the GPS receiver when the image is recorded. | 9
GPSMeasureMode | Indicates the GPS measurement mode. - 2- or 3- dimensional. | 10
GPSDOP | Indicates the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement. | 11
GPSSpeedRef | Indicates the unit used to express the GPS receiver speed of movement. 'K' 'M' and 'N' represents kilometers per hour, miles per hour, and knots. | 12
GPSSpeed | Indicates the speed of GPS receiver movement. | 13
GPSTrackRef | Indicates the reference for giving the direction of GPS receiver movement. 'T' denotes true direction and 'M' is magnetic direction. | 14
GPSTrack | Indicates the direction of GPS receiver movement. The range of values is from 0.00 to 359.99. | 15
GPSImgDirectionRef | Indicates the reference for giving the direction of the image when it is captured. 'T' denotes true direction and 'M' is magnetic direction. | 16
GPSImgDirection | Indicates the direction of the image when it was captured. The range of values is from 0.00 to 359.99. | 17
GPSMapDatum | Indicates the geodetic survey data used by the GPS receiver. | 18
GPSDestLatitudeRef | Indicates whether the latitude of the destination point is north or south latitude. The ASCII value 'N' indicates north latitude, and 'S' is south latitude. | 19
GPSDestLatitude | Indicates the latitude of the destination point. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1. | 20
GPSDestLongitudeRef | Indicates whether the longitude of the destination point is east or west longitude. ASCII 'E' indicates east longitude, and 'W' is west longitude. | 21
GPSDestLongitude | Indicates the longitude of the destination point. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1. | 22
GPSDestBearingRef | Indicates the reference used for giving the bearing to the destination point. 'T' denotes true direction and 'M' is magnetic direction. | 23
GPSDestBearing | Indicates the bearing to the destination point. The range of values is from 0.00 to 359.99. | 24
GPSDestDistanceRef | Indicates the unit used to express the distance to the destination point. 'K', 'M' and 'N' represent kilometers, miles and knots. | 25
GPSDestDistance | Indicates the distance to the destination point. | 26
GPSProcessingMethod | A character string recording the name of the method used for location finding. The first byte indicates the character code used, and this is followed by the name of the method. | 27
GPSAreaInformation | A character string recording the name of the GPS area. The first byte indicates the character code used, and this is followed by the name of the GPS area. | 28
GPSDateStamp | A character string recording date and time information relative to UTC (Coordinated Universal Time). The format is YYYY:MM:DD. | 29
GPSDifferential | Indicates whether differential correction is applied to the GPS receiver. | 30
StripOffsets | For each strip, the byte offset of that strip. It is recommended that this be selected so the number of strip bytes does not exceed 64 Kbytes. Aux tag. | 273
JPEGInterchangeFormat | The offset to the start byte (SOI) of JPEG compressed thumbnail data. This is not used for primary image JPEG data. | 513
JPEGInterchangeFormatLength | The number of bytes of JPEG compressed thumbnail data. This is not used for primary image JPEG data. JPEG thumbnails are not divided but are recorded as a continuous JPEG bitstream from SOI to EOI. Appn and COM markers should not be recorded. Compressed thumbnails must be recorded in no more than 64 Kbytes, including all other data to be recorded in APP1. | 514
ExifIfdPointer | A pointer to the Exif IFD. Interoperability, Exif IFD has the same structure as that of the IFD specified in TIFF. ordinarily, however, it does not contain image data as in the case of TIFF. | 34665
GPSIfdPointer | The gps ifd pointer. | 34853
RowsPerStrip | The number of rows per strip. This is the number of rows in the image of one strip when an image is divided into strips. | 278
StripByteCounts | The total number of bytes in each strip. | 279
PixelXDimension | Information specific to compressed data. When a compressed file is recorded, the valid width of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker. | 40962
PixelYDimension | Information specific to compressed data. When a compressed file is recorded, the valid height of the meaningful image shall be recorded in this tag | 40963
Gamma | Gamma value | 42240
SensitivityType | Type of photographic sensitivity | 34864
StandardOutputSensitivity | Indicates standard output sensitivity of camera | 34865
RecommendedExposureIndex | Indicates recommended exposure index | 34866
ISOSpeed | Information about iso speed value as defined in ISO 12232 | 34867
ISOSpeedLatitudeYYY | This tag indicates ISO speed latitude yyy value as defined in ISO 12232 | 34868
ISOSpeedLatitudeZZZ | This tag indicates ISO speed latitude zzz value as defined in ISO 12232 | 34869
CameraOwnerName | Contains camera owner name | 42032
BodySerialNumber | Contains camera body serial number | 42033
LensMake | This tag records lens manufacturer | 42035
LensModel | This tag records lens`s model name and model number | 42036
LensSerialNumber | This tag records the serial number of interchangable lens | 42037
LensSpecification | This tag notes minimum focal length, maximum focal length, minimum F number in the minimum focal length and minimum F number in maximum focal length | 42034

Requirements

Namespace: Aspose.Imaging.Exif

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif Namespace


JpegExifData Class

Exif data container for jpeg files.

For a list of all members of this type, see JpegExifData Members.

System.Object
Aspose.Imaging.Exif.ExifData
Aspose.Imaging.Exif.JpegExifData

public sealed class JpegExifData : ExifData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Exif

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

JpegExifData Members | Aspose.Imaging.Exif Namespace


JpegExifData Members

JpegExifData overview

Public Instance Constructors

JpegExifData Constructor Initializes a new instance of the JpegExifData class.

Public Instance Properties

ApertureValue (inherited from ExifData) | Gets or sets the aperture value.
Artist | Gets or sets the artist.
BitsPerSample | Gets or sets the cfa pattern.
BodySerialNumber (inherited from ExifData) | Gets or sets camera body serial number.
BrightnessValue (inherited from ExifData) | Gets or sets the brightness value.
CameraOwnerName (inherited from ExifData) | Get or set camera owner name
CFAPattern (inherited from ExifData) | Gets or sets the cfa pattern.
ColorSpace (inherited from ExifData) | Gets or sets the color space.
ComponentsConfiguration (inherited from ExifData) | Gets or sets the components configuration.
CompressedBitsPerPixel (inherited from ExifData) | Gets or sets the compressed bits per pixel.
Compression | Gets or sets the compression.
Contrast (inherited from ExifData) | Gets or sets the contrast.
Copyright | Gets or sets the copyright.
CustomRendered (inherited from ExifData) | Gets or sets the custom rendered.
DateTime | Gets or sets the date time.
DateTimeDigitized (inherited from ExifData) | Gets or sets the date time digitized.
DateTimeOriginal (inherited from ExifData) | Gets or sets the date time original.
DeviceSettingDescription (inherited from ExifData) | Gets or sets device settings description
DigitalZoomRatio (inherited from ExifData) | Gets or sets the digital zoom ratio.
ExifVersion (inherited from ExifData) | Gets or sets the exif version.
ExposureBiasValue (inherited from ExifData) | Gets or sets the exposure bias value.
ExposureIndex (inherited from ExifData) | Gets or sets the exposure index.
ExposureMode (inherited from ExifData) | Gets or sets the exposure mode.
ExposureProgram (inherited from ExifData) | Gets or sets the exposure program.
ExposureTime (inherited from ExifData) | Gets or sets the exposure time.
FileSource (inherited from ExifData) | Gets or sets the file source type.
Flash (inherited from ExifData) | Gets or sets the flash.
FlashEnergy (inherited from ExifData) | Gets or sets the flash energy.
FlashpixVersion (inherited from ExifData) | Gets or sets the flashpix version.
FNumber (inherited from ExifData) | Gets or sets the f number.
FocalLength (inherited from ExifData) | Gets or sets the focal length.
FocalLengthIn35MmFilm (inherited from ExifData) | Gets or sets the focal length in 35 mm film.
FocalPlaneResolutionUnit (inherited from ExifData) | Gets or sets the focal plane resolution unit.
FocalPlaneXResolution (inherited from ExifData) | Gets or sets the focal plane x resolution.
FocalPlaneYResolution (inherited from ExifData) | Gets or sets the focal plane y resolution.
GainControl (inherited from ExifData) | Gets or sets the gain control.
Gamma (inherited from ExifData) | Get or set gamma.
GPSAltitude (inherited from ExifData) | Gets or sets the gps altitude.
GPSAltitudeRef (inherited from ExifData) | Gets or sets the gps altitude ref.
GPSAreaInformation (inherited from ExifData) | Gets or sets the gps area information.
GPSDateStamp (inherited from ExifData) | Gets or sets the gps img direction ref.
GPSDestBearing (inherited from ExifData) | Gets or sets the gps dest bearing.
GPSDestBearingRef (inherited from ExifData) | Gets or sets the gps dest bearing ref.
GPSDestDistance (inherited from ExifData) | Gets or sets the gps dest distance.
GPSDestDistanceRef (inherited from ExifData) | Gets or sets the gps dest distance ref.
GPSDestLatitude (inherited from ExifData) | Gets or sets the gps dest latitude.
GPSDestLatitudeRef (inherited from ExifData) | Gets or sets the gps dest latitude ref.
GPSDestLongitude (inherited from ExifData) | Gets or sets the gps dest longitude.
GPSDestLongitudeRef (inherited from ExifData) | Gets or sets the gps dest longitude ref.
GPSDifferential (inherited from ExifData) | Gets or sets the gps differential.
GPSDOP (inherited from ExifData) | Gets or sets the gpsdop.
GPSImgDirection (inherited from ExifData) | Gets or sets the gps img direction.
GPSImgDirectionRef (inherited from ExifData) | Gets or sets the gps img direction ref.
GPSLatitude (inherited from ExifData) | Gets or sets the gps latitude.
GPSLatitudeRef (inherited from ExifData) | Gets or sets the gps latitude ref.
GPSLongitude (inherited from ExifData) | Gets or sets the gps longitude.
GPSLongitudeRef (inherited from ExifData) | Gets or sets the gps longitude ref.
GPSMapDatum (inherited from ExifData) | Gets or sets the gps map datum.
GPSMeasureMode (inherited from ExifData) | Gets or sets the gps measure mode.
GPSProcessingMethod (inherited from ExifData) | Gets or sets the gps processing method.
GPSSatellites (inherited from ExifData) | Gets or sets the gps satellites.
GPSSpeed (inherited from ExifData) | Gets or sets the gps speed.
GPSSpeedRef (inherited from ExifData) | Gets or sets the gps speed ref.
GPSStatus (inherited from ExifData) | Gets or sets the gps status.
GPSTimestamp (inherited from ExifData) | Gets or sets the gps timestamp.
GPSTrack (inherited from ExifData) | Gets or sets the gps track.
GPSTrackRef (inherited from ExifData) | Gets or sets the gps track ref.
GPSVersionID (inherited from ExifData) | Gets or sets the gps version id.
ImageDescription | Gets or sets the image description.
ImageLength | Gets or sets the image length.
ImageUniqueID (inherited from ExifData) | Gets or sets the image unique id.
ImageWidth | Gets or sets the image width.
ISOSpeed (inherited from ExifData) | Gets or sets ISO speed
ISOSpeedLatitudeYYY (inherited from ExifData) | Gets or sets ISO Speed Latitude YYY value
ISOSpeedLatitudeZZZ (inherited from ExifData) | Gets or sets ISO Speed Latitude YYY value
LensMake (inherited from ExifData) | Get or set maker of lens
LensModel (inherited from ExifData) | Get or set lens model
LensSerialNumber (inherited from ExifData) | Get or set lens serial number
LensSpecification (inherited from ExifData) | Gets or sets lens specification
LightSource (inherited from ExifData) | Gets or sets the light source.
Make | Gets or sets the make.
MakerNoteData (inherited from ExifData) | Gets the maker note data.
MakerNoteRawData (inherited from ExifData) | Gets or sets the maker note raw data.
MaxApertureValue (inherited from ExifData) | Gets or sets the max aperture value.
MeteringMode (inherited from ExifData) | Gets or sets the metering mode.
Model | Gets or sets the model.
OECF (inherited from ExifData) | Gets or sets the oecf.
Orientation | Gets or sets the orientation.
PhotographicSensitivity (inherited from ExifData) | Gets or sets the iso speed ratings.
PhotometricInterpretation | Gets or sets the photometric interpretation.
PixelXDimension (inherited from ExifData) | Gets or sets the pixel x dimension.
PixelYDimension (inherited from ExifData) | Gets or sets the pixel y dimension.
PlanarConfiguration | Gets or sets the planar configuration.
PrimaryChromaticities | Gets or sets the primary chromaticities.
Properties (inherited from ExifData) | Gets or sets the properties.
RecommendedExposureIndex (inherited from ExifData) | Gets or sets recommended exposure index
ReferenceBlackWhite | Gets or sets the reference black white.
RelatedSoundFile (inherited from ExifData) | Gets or sets the related sound file.
ResolutionUnit | Gets or sets the resolution unit.
SamplesPerPixel | Gets or sets the samples per pixel.
Saturation (inherited from ExifData) | Gets or sets the saturation.
SceneCaptureType (inherited from ExifData) | Gets or sets the scene capture type.
SceneType (inherited from ExifData) | Gets or sets the scene type.
SensingMethod (inherited from ExifData) | Gets or sets the sensing method.
SensitivityType (inherited from ExifData) | Get or set sensitivity type
Sharpness (inherited from ExifData) | Gets or sets the sharpness.
ShutterSpeedValue (inherited from ExifData) | Gets or sets the shutter speed value.
Software | Gets or sets the software.
SpatialFrequencyResponse (inherited from ExifData) | Gets or sets the spatial frequency response.
SpectralSensitivity (inherited from ExifData) | Gets or sets the spectral sensitivity.
StandardOutputSensitivity (inherited from ExifData) | Gets or sets standard output sensitivity
SubjectArea (inherited from ExifData) | Gets or sets the subject area.
SubjectDistance (inherited from ExifData) | Gets or sets the subject distance.
SubjectDistanceRange (inherited from ExifData) | Gets or sets the subject distance range.
SubjectLocation (inherited from ExifData) | Gets or sets the subject location.
SubsecTime (inherited from ExifData) | Gets or sets the subsec time.
SubsecTimeDigitized (inherited from ExifData) | Gets or sets the subsec time digitized.
SubsecTimeOriginal (inherited from ExifData) | Gets or sets the subsec time original.
Thumbnail | Gets or sets the thumbnail image.
TransferFunction | Gets or sets the transfer function.
UserComment (inherited from ExifData) | Gets or sets the user comment.
WhiteBalance (inherited from ExifData) | Gets or sets the white balance.
WhitePoint (inherited from ExifData) | Gets or sets the white point.
XResolution | Gets or sets the x resolution.
YCbCrCoefficients | Gets or sets the y cb cr coefficients.
YCbCrPositioning | Gets or sets the y cb cr positioning.
YCbCrSubSampling | Gets or sets the y-cb-cr subsampling.
YResolution | Gets or sets the y resolution.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
EstimateExifSize | The estimation of exif segment size. Segment size must be less than 65528 bytes in order to produce correct jpeg image.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveTag (inherited from ExifData) | Remove tag from container
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

GetSectionTags (inherited from ExifData) Get tags, belonging to n-th section.

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


JpegExifData Constructor

Initializes a new instance of the JpegExifData class.

public JpegExifData();

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


JpegExifData Properties

The properties of the JpegExifData class are listed below. For a complete list of JpegExifData class members, see the JpegExifData Members topic.

Public Instance Properties

ApertureValue (inherited from ExifData) | Gets or sets the aperture value.
Artist | Gets or sets the artist.
BitsPerSample | Gets or sets the cfa pattern.
BodySerialNumber (inherited from ExifData) | Gets or sets camera body serial number.
BrightnessValue (inherited from ExifData) | Gets or sets the brightness value.
CameraOwnerName (inherited from ExifData) | Get or set camera owner name
CFAPattern (inherited from ExifData) | Gets or sets the cfa pattern.
ColorSpace (inherited from ExifData) | Gets or sets the color space.
ComponentsConfiguration (inherited from ExifData) | Gets or sets the components configuration.
CompressedBitsPerPixel (inherited from ExifData) | Gets or sets the compressed bits per pixel.
Compression | Gets or sets the compression.
Contrast (inherited from ExifData) | Gets or sets the contrast.
Copyright | Gets or sets the copyright.
CustomRendered (inherited from ExifData) | Gets or sets the custom rendered.
DateTime | Gets or sets the date time.
DateTimeDigitized (inherited from ExifData) | Gets or sets the date time digitized.
DateTimeOriginal (inherited from ExifData) | Gets or sets the date time original.
DeviceSettingDescription (inherited from ExifData) | Gets or sets device settings description
DigitalZoomRatio (inherited from ExifData) | Gets or sets the digital zoom ratio.
ExifVersion (inherited from ExifData) | Gets or sets the exif version.
ExposureBiasValue (inherited from ExifData) | Gets or sets the exposure bias value.
ExposureIndex (inherited from ExifData) | Gets or sets the exposure index.
ExposureMode (inherited from ExifData) | Gets or sets the exposure mode.
ExposureProgram (inherited from ExifData) | Gets or sets the exposure program.
ExposureTime (inherited from ExifData) | Gets or sets the exposure time.
FileSource (inherited from ExifData) | Gets or sets the file source type.
Flash (inherited from ExifData) | Gets or sets the flash.
FlashEnergy (inherited from ExifData) | Gets or sets the flash energy.
FlashpixVersion (inherited from ExifData) | Gets or sets the flashpix version.
FNumber (inherited from ExifData) | Gets or sets the f number.
FocalLength (inherited from ExifData) | Gets or sets the focal length.
FocalLengthIn35MmFilm (inherited from ExifData) | Gets or sets the focal length in 35 mm film.
FocalPlaneResolutionUnit (inherited from ExifData) | Gets or sets the focal plane resolution unit.
FocalPlaneXResolution (inherited from ExifData) | Gets or sets the focal plane x resolution.
FocalPlaneYResolution (inherited from ExifData) | Gets or sets the focal plane y resolution.
GainControl (inherited from ExifData) | Gets or sets the gain control.
Gamma (inherited from ExifData) | Get or set gamma.
GPSAltitude (inherited from ExifData) | Gets or sets the gps altitude.
GPSAltitudeRef (inherited from ExifData) | Gets or sets the gps altitude ref.
GPSAreaInformation (inherited from ExifData) | Gets or sets the gps area information.
GPSDateStamp (inherited from ExifData) | Gets or sets the gps img direction ref.
GPSDestBearing (inherited from ExifData) | Gets or sets the gps dest bearing.
GPSDestBearingRef (inherited from ExifData) | Gets or sets the gps dest bearing ref.
GPSDestDistance (inherited from ExifData) | Gets or sets the gps dest distance.
GPSDestDistanceRef (inherited from ExifData) | Gets or sets the gps dest distance ref.
GPSDestLatitude (inherited from ExifData) | Gets or sets the gps dest latitude.
GPSDestLatitudeRef (inherited from ExifData) | Gets or sets the gps dest latitude ref.
GPSDestLongitude (inherited from ExifData) | Gets or sets the gps dest longitude.
GPSDestLongitudeRef (inherited from ExifData) | Gets or sets the gps dest longitude ref.
GPSDifferential (inherited from ExifData) | Gets or sets the gps differential.
GPSDOP (inherited from ExifData) | Gets or sets the gpsdop.
GPSImgDirection (inherited from ExifData) | Gets or sets the gps img direction.
GPSImgDirectionRef (inherited from ExifData) | Gets or sets the gps img direction ref.
GPSLatitude (inherited from ExifData) | Gets or sets the gps latitude.
GPSLatitudeRef (inherited from ExifData) | Gets or sets the gps latitude ref.
GPSLongitude (inherited from ExifData) | Gets or sets the gps longitude.
GPSLongitudeRef (inherited from ExifData) | Gets or sets the gps longitude ref.
GPSMapDatum (inherited from ExifData) | Gets or sets the gps map datum.
GPSMeasureMode (inherited from ExifData) | Gets or sets the gps measure mode.
GPSProcessingMethod (inherited from ExifData) | Gets or sets the gps processing method.
GPSSatellites (inherited from ExifData) | Gets or sets the gps satellites.
GPSSpeed (inherited from ExifData) | Gets or sets the gps speed.
GPSSpeedRef (inherited from ExifData) | Gets or sets the gps speed ref.
GPSStatus (inherited from ExifData) | Gets or sets the gps status.
GPSTimestamp (inherited from ExifData) | Gets or sets the gps timestamp.
GPSTrack (inherited from ExifData) | Gets or sets the gps track.
GPSTrackRef (inherited from ExifData) | Gets or sets the gps track ref.
GPSVersionID (inherited from ExifData) | Gets or sets the gps version id.
ImageDescription | Gets or sets the image description.
ImageLength | Gets or sets the image length.
ImageUniqueID (inherited from ExifData) | Gets or sets the image unique id.
ImageWidth | Gets or sets the image width.
ISOSpeed (inherited from ExifData) | Gets or sets ISO speed
ISOSpeedLatitudeYYY (inherited from ExifData) | Gets or sets ISO Speed Latitude YYY value
ISOSpeedLatitudeZZZ (inherited from ExifData) | Gets or sets ISO Speed Latitude YYY value
LensMake (inherited from ExifData) | Get or set maker of lens
LensModel (inherited from ExifData) | Get or set lens model
LensSerialNumber (inherited from ExifData) | Get or set lens serial number
LensSpecification (inherited from ExifData) | Gets or sets lens specification
LightSource (inherited from ExifData) | Gets or sets the light source.
Make | Gets or sets the make.
MakerNoteData (inherited from ExifData) | Gets the maker note data.
MakerNoteRawData (inherited from ExifData) | Gets or sets the maker note raw data.
MaxApertureValue (inherited from ExifData) | Gets or sets the max aperture value.
MeteringMode (inherited from ExifData) | Gets or sets the metering mode.
Model | Gets or sets the model.
OECF (inherited from ExifData) | Gets or sets the oecf.
Orientation | Gets or sets the orientation.
PhotographicSensitivity (inherited from ExifData) | Gets or sets the iso speed ratings.
PhotometricInterpretation | Gets or sets the photometric interpretation.
PixelXDimension (inherited from ExifData) | Gets or sets the pixel x dimension.
PixelYDimension (inherited from ExifData) | Gets or sets the pixel y dimension.
PlanarConfiguration | Gets or sets the planar configuration.
PrimaryChromaticities | Gets or sets the primary chromaticities.
Properties (inherited from ExifData) | Gets or sets the properties.
RecommendedExposureIndex (inherited from ExifData) | Gets or sets recommended exposure index
ReferenceBlackWhite | Gets or sets the reference black white.
RelatedSoundFile (inherited from ExifData) | Gets or sets the related sound file.
ResolutionUnit | Gets or sets the resolution unit.
SamplesPerPixel | Gets or sets the samples per pixel.
Saturation (inherited from ExifData) | Gets or sets the saturation.
SceneCaptureType (inherited from ExifData) | Gets or sets the scene capture type.
SceneType (inherited from ExifData) | Gets or sets the scene type.
SensingMethod (inherited from ExifData) | Gets or sets the sensing method.
SensitivityType (inherited from ExifData) | Get or set sensitivity type
Sharpness (inherited from ExifData) | Gets or sets the sharpness.
ShutterSpeedValue (inherited from ExifData) | Gets or sets the shutter speed value.
Software | Gets or sets the software.
SpatialFrequencyResponse (inherited from ExifData) | Gets or sets the spatial frequency response.
SpectralSensitivity (inherited from ExifData) | Gets or sets the spectral sensitivity.
StandardOutputSensitivity (inherited from ExifData) | Gets or sets standard output sensitivity
SubjectArea (inherited from ExifData) | Gets or sets the subject area.
SubjectDistance (inherited from ExifData) | Gets or sets the subject distance.
SubjectDistanceRange (inherited from ExifData) | Gets or sets the subject distance range.
SubjectLocation (inherited from ExifData) | Gets or sets the subject location.
SubsecTime (inherited from ExifData) | Gets or sets the subsec time.
SubsecTimeDigitized (inherited from ExifData) | Gets or sets the subsec time digitized.
SubsecTimeOriginal (inherited from ExifData) | Gets or sets the subsec time original.
Thumbnail | Gets or sets the thumbnail image.
TransferFunction | Gets or sets the transfer function.
UserComment (inherited from ExifData) | Gets or sets the user comment.
WhiteBalance (inherited from ExifData) | Gets or sets the white balance.
WhitePoint (inherited from ExifData) | Gets or sets the white point.
XResolution | Gets or sets the x resolution.
YCbCrCoefficients | Gets or sets the y cb cr coefficients.
YCbCrPositioning | Gets or sets the y cb cr positioning.
YCbCrSubSampling | Gets or sets the y-cb-cr subsampling.
YResolution | Gets or sets the y resolution.

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


Artist Property

Aspose.Imaging Documentation

JpegExifData.Artist Property

Gets or sets the artist.

public string Artist {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


BitsPerSample Property

Aspose.Imaging Documentation

JpegExifData.BitsPerSample Property

Gets or sets the cfa pattern.

public ushort[] BitsPerSample {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


Compression Property

Aspose.Imaging Documentation

JpegExifData.Compression Property

Gets or sets the compression.

public ushort Compression {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


Copyright Property

Aspose.Imaging Documentation

JpegExifData.Copyright Property

Gets or sets the copyright.

public string Copyright {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


DateTime Property

Aspose.Imaging Documentation

JpegExifData.DateTime Property

Gets or sets the date time.

public string DateTime {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


ImageDescription Property

Aspose.Imaging Documentation

JpegExifData.ImageDescription Property

Gets or sets the image description.

public string ImageDescription {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


ImageLength Property

Aspose.Imaging Documentation

JpegExifData.ImageLength Property

Gets or sets the image length.

public uint ImageLength {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


ImageWidth Property

Aspose.Imaging Documentation

JpegExifData.ImageWidth Property

Gets or sets the image width.

public uint ImageWidth {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


Make Property

Aspose.Imaging Documentation

JpegExifData.Make Property

Gets or sets the make.

public string Make {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


Model Property

Aspose.Imaging Documentation

JpegExifData.Model Property

Gets or sets the model.

public string Model {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


Orientation Property

Aspose.Imaging Documentation

JpegExifData.Orientation Property

Gets or sets the orientation.

public ExifOrientation Orientation {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


PhotometricInterpretation Property

Aspose.Imaging Documentation

JpegExifData.PhotometricInterpretation Property

Gets or sets the photometric interpretation.

public ushort PhotometricInterpretation {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


PlanarConfiguration Property

Aspose.Imaging Documentation

JpegExifData.PlanarConfiguration Property

Gets or sets the planar configuration.

public ushort PlanarConfiguration {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


PrimaryChromaticities Property

Aspose.Imaging Documentation

JpegExifData.PrimaryChromaticities Property

Gets or sets the primary chromaticities.

public TiffRational[] PrimaryChromaticities {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


ReferenceBlackWhite Property

Aspose.Imaging Documentation

JpegExifData.ReferenceBlackWhite Property

Gets or sets the reference black white.

public TiffRational[] ReferenceBlackWhite {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


ResolutionUnit Property

Aspose.Imaging Documentation

JpegExifData.ResolutionUnit Property

Gets or sets the resolution unit.

public ExifUnit ResolutionUnit {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


SamplesPerPixel Property

Aspose.Imaging Documentation

JpegExifData.SamplesPerPixel Property

Gets or sets the samples per pixel.

public ushort SamplesPerPixel {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


Software Property

Aspose.Imaging Documentation

JpegExifData.Software Property

Gets or sets the software.

public string Software {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


Thumbnail Property

Aspose.Imaging Documentation

JpegExifData.Thumbnail Property

Gets or sets the thumbnail image.

public RasterImage Thumbnail {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


TransferFunction Property

Aspose.Imaging Documentation

JpegExifData.TransferFunction Property

Gets or sets the transfer function.

public ushort[] TransferFunction {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


XResolution Property

Aspose.Imaging Documentation

JpegExifData.XResolution Property

Gets or sets the x resolution.

public TiffRational XResolution {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


YCbCrCoefficients Property

Aspose.Imaging Documentation

JpegExifData.YCbCrCoefficients Property

Gets or sets the y cb cr coefficients.

public TiffRational[] YCbCrCoefficients {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


YCbCrPositioning Property

Aspose.Imaging Documentation

JpegExifData.YCbCrPositioning Property

Gets or sets the y cb cr positioning.

public ExifYCbCrPositioning YCbCrPositioning {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


YCbCrSubSampling Property

Aspose.Imaging Documentation

JpegExifData.YCbCrSubSampling Property

Gets or sets the y-cb-cr subsampling.

public ushort[] YCbCrSubSampling {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


YResolution Property

Aspose.Imaging Documentation

JpegExifData.YResolution Property

Gets or sets the y resolution.

public TiffRational YResolution {get; set;}

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


JpegExifData Methods

The methods of the JpegExifData class are listed below. For a complete list of JpegExifData class members, see the JpegExifData Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
EstimateExifSize | The estimation of exif segment size. Segment size must be less than 65528 bytes in order to produce correct jpeg image.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveTag (inherited from ExifData) | Remove tag from container
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

GetSectionTags (inherited from ExifData) Get tags, belonging to n-th section.

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


JpegExifData.EstimateExifSize Method

The estimation of exif segment size. Segment size must be less than 65528 bytes in order to produce correct jpeg image.

public int EstimateExifSize();

Return Value

The Int32.

See Also

JpegExifData Class | Aspose.Imaging.Exif Namespace


Aspose.Imaging.Exif.Enums

Aspose.Imaging Documentation

Aspose.Imaging.Exif.Enums Namespace

Namespace hierarchy

Enumerations

Enumeration | Description
ExifColorSpace | exif color space enum.
ExifContrast | exif normal soft hard enum.
ExifCustomRendered | exif custom rendered enum.
ExifExposureMode | exif exposure mode enum.
ExifExposureProgram | exif exposure program enum.
ExifFileSource | exif file source enum.
ExifFlash | Flash mode.
ExifGainControl | exif gain control enum.
ExifGPSAltitudeRef | exif gps altitude ref enum.
ExifLightSource | The exif light source.
ExifMeteringMode | exif metering mode enum.
ExifOrientation | Exif image orientation.
ExifSaturation | exif saturation enum.
ExifSceneCaptureType | exif scene capture type enum.
ExifSensingMethod | exif sensing method enum.
ExifSubjectDistanceRange | exif subject distance range enum.
ExifUnit | exif unit enum.
ExifWhiteBalance | exif white balance enum.
ExifYCbCrPositioning | exif y cb cr positioning enum.


ExifColorSpace Enumeration

exif color space enum.

public enum ExifColorSpace

Members

Member Name | Description | Value
sRGB | SRGB color space. | 1
AdobeRGB | Adobe rgb color space. | 2
Uncalibrated | Uncalibrated color space. | 65535

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifContrast Enumeration

exif normal soft hard enum.

public enum ExifContrast

Members

Member Name | Description | Value
Normal | Normal contrast. | 0
Low | Low contrast. | 1
High | High contrast. | 2

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifCustomRendered Enumeration

exif custom rendered enum.

public enum ExifCustomRendered

Members

Member Name | Description | Value
NormalProcess | Normal render process. | 0
CustomProcess | Custom render process. | 1

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifExposureMode Enumeration

exif exposure mode enum.

public enum ExifExposureMode

Members

Member Name | Description | Value
Auto | Auto exposure. | 0
Manual | Manual exposure. | 1
AutoBracket | Auto bracket. | 2

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifExposureProgram Enumeration

exif exposure program enum.

public enum ExifExposureProgram

Members

Member Name | Description | Value
Notdefined | Not defined. | 0
Manual | Manual program. | 1
Auto | Auto exposure. | 2
Aperturepriority | Aperture priority. | 3
Shutterpriority | Shutter priority. | 4
Creativeprogram | Creative program. | 5
Actionprogram | Action program. | 6
Portraitmode | Portrait mode. | 7
Landscapemode | Landscape mode. | 8

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifFileSource Enumeration

exif file source enum.

public enum ExifFileSource

Members

Member Name | Description | Value
Others | The others. | 0
FilmScanner | Film scanner. | 1
ReflexionPrintScanner | Reflexion print scanner. | 2
DigitalStillCamera | Digital still camera. | 3

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifFlash Enumeration

Flash mode.

public enum ExifFlash

Members

Member Name | Description | Value
Noflash | No flash fired. | 0
Fired | Flash fired. | 1
FiredReturnLightNotDetected | Flash fired, return light not detected. | 5
FiredReturnLightDetected | Flash fired, return light detected. | 7
YesCompulsory | Flash fired, compulsory flash mode. | 9
YesCompulsoryReturnLightNotDetected | Flash fired, compulsory mode, return light not detected. | 13
YesCompulsoryReturnLightDetected | Flash fired, compulsory mode, return light detected. | 15
NoCompulsory | Flash did not fire, compulsory flash mode. | 16
NoDidNotFireReturnLightNotDetected | Flash did not fire, return light not detected. | 20
NoAuto | Flash did not fire, auto mode. | 24
YesAuto | Flash firedm auto mode. | 25
YesAutoReturnLightNotDetected | Flash fired, auto mode, return light not detected. | 29
YesAutoReturnLightDetected | Flash fired, auto mode, return light detected. | 31
NoFlashFunction | No flash function. | 32

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifGainControl Enumeration

exif gain control enum.

public enum ExifGainControl

Members

Member Name | Description | Value
None | No gain control. | 0
LowGainUp | Low gain up. | 1
HighGainUp | High gain up. | 2
LowGainDown | Low gain down. | 3
HighGainDown | High gain down. | 4

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifGPSAltitudeRef Enumeration

exif gps altitude ref enum.

public enum ExifGPSAltitudeRef

Members

Member Name | Description | Value
AboveSeaLevel | Above sea level. | 0
BelowSeaLevel | Below sea level. | 1

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifLightSource Enumeration

The exif light source.

public enum ExifLightSource

Members

Member Name | Description | Value
Unknown | The unknown. | 0
Daylight | The daylight. | 1
Fluorescent | The fluorescent. | 2
Tungsten | The tungsten. | 3
Flash | The flash. | 4
Fineweather | The fineweather. | 9
Cloudyweather | The cloudyweather. | 10
Shade | The shade. | 11
DaylightFluorescent | The daylight fluorescent. | 12
DayWhiteFluorescent | The day white fluorescent. | 13
CoolWhiteFluorescent | The cool white fluorescent. | 14
WhiteFluorescent | The white fluorescent. | 15
StandardlightA | The standardlight a. | 17
StandardlightB | The standardlight b. | 18
StandardlightC | The standardlight c. | 19
D55 | The d55 value(5500K). | 20
D65 | The d65 value(6500K). | 21
D75 | The d75 value(7500K). | 22
D50 | The d50 value(5000K). | 23
ISOstudiotungsten | The iso studio tungsten lightsource. | 24
Otherlightsource | The otherlightsource. | 255

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifMeteringMode Enumeration

exif metering mode enum.

public enum ExifMeteringMode

Members

Member Name | Description | Value
Unknown | Undefined mode | 0
Average | Average metering | 1
Centerweightedaverage | Center weighted average. | 2
Spot | Spot metering | 3
MultiSpot | Multi spot metering | 4
MultiSegment | Multi segment metering. | 5
Partial | Partial metering. | 6
Other | For other modes. | 255

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifOrientation Enumeration

Exif image orientation.

public enum ExifOrientation

Members

Member Name | Description | Value
TopLeft | Top left. Default orientation. | 1
TopRight | Top right. Horizontally reversed. | 2
BottomRight | Bottom right. Rotated by 180 degrees. | 3
BottomLeft | Bottom left. Rotated by 180 degrees and then horizontally reversed. | 4
LeftTop | Left top. Rotated by 90 degrees counterclockwise and then horizontally reversed. | 5
RightTop | Right top. Rotated by 90 degrees clockwise. | 6
RightBottom | Right bottom. Rotated by 90 degrees clockwise and then horizontally reversed. | 7
LeftBottom | Left bottom. Rotated by 90 degrees counterclockwise. | 8

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifSaturation Enumeration

exif saturation enum.

public enum ExifSaturation

Members

Member Name | Description | Value
Normal | Normal saturation. | 0
Low | Low saturation. | 1
High | High saturation. | 2

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifSceneCaptureType Enumeration

exif scene capture type enum.

public enum ExifSceneCaptureType

Members

Member Name | Description | Value
Standard | Standard scene. | 0
Landscape | Landscape scene. | 1
Portrait | Portrait scene. | 2
NightScene | Night scene. | 3

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifSensingMethod Enumeration

exif sensing method enum.

public enum ExifSensingMethod

Members

Member Name | Description | Value
Notdefined | Not defined. | 1
OneChipColorArea | One chip color area. | 2
TwoChipColorArea | Two chip color area. | 3
ThreeChipColorArea | Three chip color area. | 4
Colorsequentialarea | Color Sequential area. | 5
Trilinearsensor | Trilinear sensor. | 7
Colorsequentiallinear | Color sequential linear sensor. | 8

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifSubjectDistanceRange Enumeration

exif subject distance range enum.

public enum ExifSubjectDistanceRange

Members

Member Name | Description | Value
Unknown | Unknown subject distance range | 0
Macro | Macro range | 1
CloseView | Close view. | 2
DistantView | Distant view. | 3

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifUnit Enumeration

exif unit enum.

public enum ExifUnit

Members

Member Name | Description | Value
None | Undefined units | 1
Inch | Inch units | 2
Cm | Metric centimeter units | 3

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifWhiteBalance Enumeration

exif white balance enum.

public enum ExifWhiteBalance

Members

Member Name | Description | Value
Auto | Auto white balance | 0
Manual | Manual white balance | 1

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


ExifYCbCrPositioning Enumeration

exif y cb cr positioning enum.

public enum ExifYCbCrPositioning

Members

Member Name | Description | Value
Centered | Centered YCbCr | 1
CoSited | Co-sited position | 2

Requirements

Namespace: Aspose.Imaging.Exif.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.Exif.Enums Namespace


Aspose.Imaging.Extensions

Aspose.Imaging Documentation

Aspose.Imaging.Extensions Namespace

Namespace hierarchy

Classes

Class | Description
BrushExtensions | Contains extension methods for Brush and Brush.
ColorBlendExtensions | Contains ColorBlend extension methods.
ColorExtensions | The Color extension methods.
ColorMapExtensions | The ColorMap extension methods.
ColorMatrixExtensions | The ColorMatrix extension methods.
FileFormatExtensions | Contains FileFormat extension methods.
FontExtensions | Contains extension methods for the Font class.
GraphicsPathExtensions | Contains the GraphicsPath extension methods.
ImageAttributesExtensions | Contains extension methods for ImageAttributes and ImageAttributes.
ImageExtensions | Contains extension methods for conversions based on Image and Image.
MatrixExtensions | Contains the Matrix class extensions.
PenExtensions | Contains extension methods for Pen and Pen.
PointExtensions | Contains extension methods for Point and PointF structures.
RectangleExtensions | Contains extension methods for Rectangle.
RegionExtensions | Contains extension methods for the Region class.
RotateFlipExtensions | Contains extension methods for conversion the RotateFlipType and the RotateFlipType classes.
StringFormatExtensions | Contains extension methods for the StringFormat class.


BrushExtensions Class

Contains extension methods for Brush and Brush.

For a list of all members of this type, see BrushExtensions Members.

System.Object
Aspose.Imaging.Extensions.BrushExtensions

public abstract sealed class BrushExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

BrushExtensions Members | Aspose.Imaging.Extensions Namespace


BrushExtensions Members

BrushExtensions overview

Public Static Methods

ToGdiBrush Converts the Brush to the Brush.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BrushExtensions Class | Aspose.Imaging.Extensions Namespace


BrushExtensions Methods

The methods of the BrushExtensions class are listed below. For a complete list of BrushExtensions class members, see the BrushExtensions Members topic.

Public Static Methods

ToGdiBrush Converts the Brush to the Brush.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BrushExtensions Class | Aspose.Imaging.Extensions Namespace


BrushExtensions.ToGdiBrush Method

Converts the Brush to the Brush.

public static Brush ToGdiBrush(
Brush brush
);

Parameters

brush
The Brush to convert.

Return Value

The converted Brush.

See Also

BrushExtensions Class | Aspose.Imaging.Extensions Namespace


ColorBlendExtensions Class

Contains ColorBlend extension methods.

For a list of all members of this type, see ColorBlendExtensions Members.

System.Object
Aspose.Imaging.Extensions.ColorBlendExtensions

public abstract sealed class ColorBlendExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ColorBlendExtensions Members | Aspose.Imaging.Extensions Namespace


ColorBlendExtensions Members

ColorBlendExtensions overview

Public Static Methods

ToGdiColorBlend Converts the ColorBlend to ColorBlend.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorBlendExtensions Class | Aspose.Imaging.Extensions Namespace


ColorBlendExtensions Methods

The methods of the ColorBlendExtensions class are listed below. For a complete list of ColorBlendExtensions class members, see the ColorBlendExtensions Members topic.

Public Static Methods

ToGdiColorBlend Converts the ColorBlend to ColorBlend.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorBlendExtensions Class | Aspose.Imaging.Extensions Namespace


ColorBlendExtensions.ToGdiColorBlend Method

Converts the ColorBlend to ColorBlend.

public static ColorBlend ToGdiColorBlend(
ColorBlend colorBlend
);

Parameters

colorBlend
The color blend.

Return Value

The converted ColorBlend.

See Also

ColorBlendExtensions Class | Aspose.Imaging.Extensions Namespace


ColorExtensions Class

The Color extension methods.

For a list of all members of this type, see ColorExtensions Members.

System.Object
Aspose.Imaging.Extensions.ColorExtensions

public abstract sealed class ColorExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ColorExtensions Members | Aspose.Imaging.Extensions Namespace


ColorExtensions Members

ColorExtensions overview

Public Static Methods

ToGdiColor | Converts the Color to the Color.
ToGdiColors | Converts the Color array to the Color array.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorExtensions Class | Aspose.Imaging.Extensions Namespace


ColorExtensions Methods

The methods of the ColorExtensions class are listed below. For a complete list of ColorExtensions class members, see the ColorExtensions Members topic.

Public Static Methods

ToGdiColor | Converts the Color to the Color.
ToGdiColors | Converts the Color array to the Color array.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorExtensions Class | Aspose.Imaging.Extensions Namespace


ColorExtensions.ToGdiColor Method

Converts the Color to the Color.

public static Color ToGdiColor(
Color color
);

Parameters

color
TheColor to convert.

Return Value

The converted Color.

See Also

ColorExtensions Class | Aspose.Imaging.Extensions Namespace


ColorExtensions.ToGdiColors Method

Converts the Color array to the Color array.

public static Color[] ToGdiColors(
Color[] colors
);

Parameters

colors
TheColor array to convert.

Return Value

The converted Color array.

See Also

ColorExtensions Class | Aspose.Imaging.Extensions Namespace


ColorMapExtensions Class

The ColorMap extension methods.

For a list of all members of this type, see ColorMapExtensions Members.

System.Object
Aspose.Imaging.Extensions.ColorMapExtensions

public abstract sealed class ColorMapExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ColorMapExtensions Members | Aspose.Imaging.Extensions Namespace


ColorMapExtensions Members

ColorMapExtensions overview

Public Static Methods

ToGdiColorMap | Converts the ColorMap to the ColorMap.
ToGdiColorMaps | Converts the ColorMap array to the ColorMap array.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorMapExtensions Class | Aspose.Imaging.Extensions Namespace


ColorMapExtensions Methods

The methods of the ColorMapExtensions class are listed below. For a complete list of ColorMapExtensions class members, see the ColorMapExtensions Members topic.

Public Static Methods

ToGdiColorMap | Converts the ColorMap to the ColorMap.
ToGdiColorMaps | Converts the ColorMap array to the ColorMap array.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorMapExtensions Class | Aspose.Imaging.Extensions Namespace


ColorMapExtensions.ToGdiColorMap Method

Converts the ColorMap to the ColorMap.

public static ColorMap ToGdiColorMap(
ColorMap colorMap
);

Parameters

colorMap
The color map to convert.

Return Value

The converted ColorMap.

See Also

ColorMapExtensions Class | Aspose.Imaging.Extensions Namespace


ColorMapExtensions.ToGdiColorMaps Method

Converts the ColorMap array to the ColorMap array.

public static ColorMap[] ToGdiColorMaps(
ColorMap[] colorMaps
);

Parameters

colorMaps
The color maps to convert.

Return Value

The converted ColorMap array.

See Also

ColorMapExtensions Class | Aspose.Imaging.Extensions Namespace


ColorMatrixExtensions Class

The ColorMatrix extension methods.

For a list of all members of this type, see ColorMatrixExtensions Members.

System.Object
Aspose.Imaging.Extensions.ColorMatrixExtensions

public abstract sealed class ColorMatrixExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ColorMatrixExtensions Members | Aspose.Imaging.Extensions Namespace


ColorMatrixExtensions Members

ColorMatrixExtensions overview

Public Static Methods

ToGdiColorMatrix Converts the ColorMatrix to the ColorMatrix.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorMatrixExtensions Class | Aspose.Imaging.Extensions Namespace


ColorMatrixExtensions Methods

The methods of the ColorMatrixExtensions class are listed below. For a complete list of ColorMatrixExtensions class members, see the ColorMatrixExtensions Members topic.

Public Static Methods

ToGdiColorMatrix Converts the ColorMatrix to the ColorMatrix.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ColorMatrixExtensions Class | Aspose.Imaging.Extensions Namespace


ColorMatrixExtensions.ToGdiColorMatrix Method

Converts the ColorMatrix to the ColorMatrix.

public static ColorMatrix ToGdiColorMatrix(
ColorMatrix colorMatrix
);

Parameters

colorMatrix
The color matrix to convert.

Return Value

The converted ColorMatrix.

See Also

ColorMatrixExtensions Class | Aspose.Imaging.Extensions Namespace


FileFormatExtensions Class

Contains FileFormat extension methods.

For a list of all members of this type, see FileFormatExtensions Members.

System.Object
Aspose.Imaging.Extensions.FileFormatExtensions

public abstract sealed class FileFormatExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

FileFormatExtensions Members | Aspose.Imaging.Extensions Namespace


FileFormatExtensions Members

FileFormatExtensions overview

Public Static Methods

IsSingleFormatDefined Determines whether single file format is defined.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileFormatExtensions Class | Aspose.Imaging.Extensions Namespace


FileFormatExtensions Methods

The methods of the FileFormatExtensions class are listed below. For a complete list of FileFormatExtensions class members, see the FileFormatExtensions Members topic.

Public Static Methods

IsSingleFormatDefined Determines whether single file format is defined.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileFormatExtensions Class | Aspose.Imaging.Extensions Namespace


FileFormatExtensions.IsSingleFormatDefined Method

Determines whether single file format is defined.

public static bool IsSingleFormatDefined(
FileFormat fileFormat
);

Parameters

fileFormat
The file format to check.

Return Value

True if single file format is defined; otherwise, false.

See Also

FileFormatExtensions Class | Aspose.Imaging.Extensions Namespace


FontExtensions Class

Contains extension methods for the Font class.

For a list of all members of this type, see FontExtensions Members.

System.Object
Aspose.Imaging.Extensions.FontExtensions

public abstract sealed class FontExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

FontExtensions Members | Aspose.Imaging.Extensions Namespace


FontExtensions Members

FontExtensions overview

Public Static Methods

ToGdiFont Converts the Font to the Font.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FontExtensions Class | Aspose.Imaging.Extensions Namespace


FontExtensions Methods

The methods of the FontExtensions class are listed below. For a complete list of FontExtensions class members, see the FontExtensions Members topic.

Public Static Methods

ToGdiFont Converts the Font to the Font.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FontExtensions Class | Aspose.Imaging.Extensions Namespace


FontExtensions.ToGdiFont Method

Converts the Font to the Font.

public static Font ToGdiFont(
Font font
);

Parameters

font
The Font to convert.

Return Value

The converted Font.

See Also

FontExtensions Class | Aspose.Imaging.Extensions Namespace


GraphicsPathExtensions Class

Contains the GraphicsPath extension methods.

For a list of all members of this type, see GraphicsPathExtensions Members.

System.Object
Aspose.Imaging.Extensions.GraphicsPathExtensions

public abstract sealed class GraphicsPathExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GraphicsPathExtensions Members | Aspose.Imaging.Extensions Namespace


GraphicsPathExtensions Members

GraphicsPathExtensions overview

Public Static Methods

ToGdiGraphicsPath Converts the GraphicsPath to the GraphicsPath.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GraphicsPathExtensions Class | Aspose.Imaging.Extensions Namespace


GraphicsPathExtensions Methods

The methods of the GraphicsPathExtensions class are listed below. For a complete list of GraphicsPathExtensions class members, see the GraphicsPathExtensions Members topic.

Public Static Methods

ToGdiGraphicsPath Converts the GraphicsPath to the GraphicsPath.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GraphicsPathExtensions Class | Aspose.Imaging.Extensions Namespace


GraphicsPathExtensions.ToGdiGraphicsPath Method

Converts the GraphicsPath to the GraphicsPath.

public static GraphicsPath ToGdiGraphicsPath(
GraphicsPath graphicsPath
);

Parameters

graphicsPath
The graphics path to convert.

Return Value

The converted GraphicsPath.

See Also

GraphicsPathExtensions Class | Aspose.Imaging.Extensions Namespace


ImageAttributesExtensions Class

Contains extension methods for ImageAttributes and ImageAttributes.

For a list of all members of this type, see ImageAttributesExtensions Members.

System.Object
Aspose.Imaging.Extensions.ImageAttributesExtensions

public abstract sealed class ImageAttributesExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ImageAttributesExtensions Members | Aspose.Imaging.Extensions Namespace


ImageAttributesExtensions Members

ImageAttributesExtensions overview

Public Static Methods

ToGdiImageAttributes Converts the ImageAttributes to the ImageAttributes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImageAttributesExtensions Class | Aspose.Imaging.Extensions Namespace


ImageAttributesExtensions Methods

The methods of the ImageAttributesExtensions class are listed below. For a complete list of ImageAttributesExtensions class members, see the ImageAttributesExtensions Members topic.

Public Static Methods

ToGdiImageAttributes Converts the ImageAttributes to the ImageAttributes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImageAttributesExtensions Class | Aspose.Imaging.Extensions Namespace


ImageAttributesExtensions.ToGdiImageAttributes Method

Converts the ImageAttributes to the ImageAttributes.

public static ImageAttributes ToGdiImageAttributes(
ImageAttributes imageAttributes
);

Parameters

imageAttributes
The ImageAttributes to convert.

Return Value

The converted ImageAttributes.

See Also

ImageAttributesExtensions Class | Aspose.Imaging.Extensions Namespace


ImageExtensions Class

Contains extension methods for conversions based on Image and Image.

For a list of all members of this type, see ImageExtensions Members.

System.Object
Aspose.Imaging.Extensions.ImageExtensions

public abstract sealed class ImageExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ImageExtensions Members | Aspose.Imaging.Extensions Namespace


ImageExtensions Members

ImageExtensions overview

Public Static Methods

ToGdiImage Obsolete. Converts the Image to the Image.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImageExtensions Class | Aspose.Imaging.Extensions Namespace


ImageExtensions Methods

The methods of the ImageExtensions class are listed below. For a complete list of ImageExtensions class members, see the ImageExtensions Members topic.

Public Static Methods

ToGdiImage Obsolete. Converts the Image to the Image.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImageExtensions Class | Aspose.Imaging.Extensions Namespace


ImageExtensions.ToGdiImage Method

NOTE: This method is now obsolete.

Please do not use this method as you may get OutOfMemoryException if image is too large for GDI to fit.

Converts the Image to the Image.

public static Image ToGdiImage(
Image image
);

Parameters

image
The Image to convert.

Return Value

The converted Image.

Remarks

Warning, the GDI image may get lower bounds than image has. To get all parts of the image use more safe extension method ToGdiImageFull.

See Also

ImageExtensions Class | Aspose.Imaging.Extensions Namespace


MatrixExtensions Class

Contains the Matrix class extensions.

For a list of all members of this type, see MatrixExtensions Members.

System.Object
Aspose.Imaging.Extensions.MatrixExtensions

public abstract sealed class MatrixExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

MatrixExtensions Members | Aspose.Imaging.Extensions Namespace


MatrixExtensions Members

MatrixExtensions overview

Public Static Methods

ToGdiMatrix Converts the Matrix to the Matrix.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MatrixExtensions Class | Aspose.Imaging.Extensions Namespace


MatrixExtensions Methods

The methods of the MatrixExtensions class are listed below. For a complete list of MatrixExtensions class members, see the MatrixExtensions Members topic.

Public Static Methods

ToGdiMatrix Converts the Matrix to the Matrix.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MatrixExtensions Class | Aspose.Imaging.Extensions Namespace


MatrixExtensions.ToGdiMatrix Method

Converts the Matrix to the Matrix.

public static Matrix ToGdiMatrix(
Matrix matrix
);

Parameters

matrix
The Matrix to convert.

Return Value

The converted Matrix.

See Also

MatrixExtensions Class | Aspose.Imaging.Extensions Namespace


PenExtensions Class

Contains extension methods for Pen and Pen.

For a list of all members of this type, see PenExtensions Members.

System.Object
Aspose.Imaging.Extensions.PenExtensions

public abstract sealed class PenExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PenExtensions Members | Aspose.Imaging.Extensions Namespace


PenExtensions Members

PenExtensions overview

Public Static Methods

ToGdiPen Converts the Pen to the Pen.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PenExtensions Class | Aspose.Imaging.Extensions Namespace


PenExtensions Methods

The methods of the PenExtensions class are listed below. For a complete list of PenExtensions class members, see the PenExtensions Members topic.

Public Static Methods

ToGdiPen Converts the Pen to the Pen.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PenExtensions Class | Aspose.Imaging.Extensions Namespace


PenExtensions.ToGdiPen Method

Converts the Pen to the Pen.

public static Pen ToGdiPen(
Pen pen
);

Parameters

pen
The Pen to convert.

Return Value

The converted Pen.

See Also

PenExtensions Class | Aspose.Imaging.Extensions Namespace


PointExtensions Class

Contains extension methods for Point and PointF structures.

For a list of all members of this type, see PointExtensions Members.

System.Object
Aspose.Imaging.Extensions.PointExtensions

public abstract sealed class PointExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PointExtensions Members | Aspose.Imaging.Extensions Namespace


PointExtensions Members

PointExtensions overview

Public Static Methods

ToGdiPoint | Converts the PointF to PointF.
ToGdiPoints | Converts the PointF array to the PointF array.
ToPointsArray | Converts the Point array to the PointF array.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PointExtensions Class | Aspose.Imaging.Extensions Namespace


PointExtensions Methods

The methods of the PointExtensions class are listed below. For a complete list of PointExtensions class members, see the PointExtensions Members topic.

Public Static Methods

ToGdiPoint | Converts the PointF to PointF.
ToGdiPoints | Converts the PointF array to the PointF array.
ToPointsArray | Converts the Point array to the PointF array.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PointExtensions Class | Aspose.Imaging.Extensions Namespace


PointExtensions.ToGdiPoint Method

Converts the PointF to PointF.

public static PointF ToGdiPoint(
PointF point
);

Parameters

point
The PointF to convert.

Return Value

The converted PointF.

See Also

PointExtensions Class | Aspose.Imaging.Extensions Namespace


PointExtensions.ToGdiPoints Method

Converts the PointF array to the PointF array.

public static PointF[] ToGdiPoints(
PointF[] points
);

Parameters

points
The PointF array to convert.

Return Value

The converted PointF array.

See Also

PointExtensions Class | Aspose.Imaging.Extensions Namespace


PointExtensions.ToPointsArray Method

Converts the Point array to the PointF array.

public static PointF[] ToPointsArray(
Point[] points
);

Parameters

points
The Point array to convert.

Return Value

The converted PointF array.

See Also

PointExtensions Class | Aspose.Imaging.Extensions Namespace


RectangleExtensions Class

Contains extension methods for Rectangle.

For a list of all members of this type, see RectangleExtensions Members.

System.Object
Aspose.Imaging.Extensions.RectangleExtensions

public abstract sealed class RectangleExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

RectangleExtensions Members | Aspose.Imaging.Extensions Namespace


RectangleExtensions Members

RectangleExtensions overview

Public Static Methods

ToGdiRectangle Overloaded. Converts the Rectangle to the Rectangle.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RectangleExtensions Class | Aspose.Imaging.Extensions Namespace


RectangleExtensions Methods

The methods of the RectangleExtensions class are listed below. For a complete list of RectangleExtensions class members, see the RectangleExtensions Members topic.

Public Static Methods

ToGdiRectangle Overloaded. Converts the Rectangle to the Rectangle.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RectangleExtensions Class | Aspose.Imaging.Extensions Namespace


ToGdiRectangle Method

Aspose.Imaging Documentation

RectangleExtensions.ToGdiRectangle Method

Converts the Rectangle to the Rectangle.

Overload List

Converts the Rectangle to the Rectangle.

public static Rectangle ToGdiRectangle(Rectangle);

Converts the RectangleF to the Rectangle.

public static RectangleF ToGdiRectangle(RectangleF);

See Also

RectangleExtensions Class | Aspose.Imaging.Extensions Namespace


RectangleExtensions.ToGdiRectangle Method (Rectangle)

Converts the Rectangle to the Rectangle.

public static Rectangle ToGdiRectangle(
Rectangle rectangle
);

Parameters

rectangle
The rectangle to convert.

Return Value

The converted Rectangle.

See Also

RectangleExtensions Class | Aspose.Imaging.Extensions Namespace | RectangleExtensions.ToGdiRectangle Overload List


RectangleExtensions.ToGdiRectangle Method (RectangleF)

Converts the RectangleF to the Rectangle.

public static RectangleF ToGdiRectangle(
RectangleF rectangle
);

Parameters

rectangle
The rectangle to convert.

Return Value

The converted RectangleF.

See Also

RectangleExtensions Class | Aspose.Imaging.Extensions Namespace | RectangleExtensions.ToGdiRectangle Overload List


RegionExtensions Class

Contains extension methods for the Region class.

For a list of all members of this type, see RegionExtensions Members.

System.Object
Aspose.Imaging.Extensions.RegionExtensions

public abstract sealed class RegionExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

RegionExtensions Members | Aspose.Imaging.Extensions Namespace


RegionExtensions Members

RegionExtensions overview

Public Static Methods

ToGdiRegion Converts the Region to the Region.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RegionExtensions Class | Aspose.Imaging.Extensions Namespace


RegionExtensions Methods

The methods of the RegionExtensions class are listed below. For a complete list of RegionExtensions class members, see the RegionExtensions Members topic.

Public Static Methods

ToGdiRegion Converts the Region to the Region.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RegionExtensions Class | Aspose.Imaging.Extensions Namespace


RegionExtensions.ToGdiRegion Method

Converts the Region to the Region.

public static Region ToGdiRegion(
Region region
);

Parameters

region
The Region to convert.

Return Value

The converted Region.

See Also

RegionExtensions Class | Aspose.Imaging.Extensions Namespace


RotateFlipExtensions Class

Contains extension methods for conversion the RotateFlipType and the RotateFlipType classes.

For a list of all members of this type, see RotateFlipExtensions Members.

System.Object
Aspose.Imaging.Extensions.RotateFlipExtensions

public abstract sealed class RotateFlipExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

RotateFlipExtensions Members | Aspose.Imaging.Extensions Namespace


RotateFlipExtensions Members

RotateFlipExtensions overview

Public Static Methods

ToGdiRotateFlipType Converts Aspose.Imaging.RotateFlipType to System.Drawing.RotateFlipType.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RotateFlipExtensions Class | Aspose.Imaging.Extensions Namespace


RotateFlipExtensions Methods

The methods of the RotateFlipExtensions class are listed below. For a complete list of RotateFlipExtensions class members, see the RotateFlipExtensions Members topic.

Public Static Methods

ToGdiRotateFlipType Converts Aspose.Imaging.RotateFlipType to System.Drawing.RotateFlipType.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RotateFlipExtensions Class | Aspose.Imaging.Extensions Namespace


RotateFlipExtensions.ToGdiRotateFlipType Method

Converts Aspose.Imaging.RotateFlipType to System.Drawing.RotateFlipType.

public static RotateFlipType ToGdiRotateFlipType(
RotateFlipType rotateFlipType
);

Parameters

rotateFlipType
Type of the rotate flip.

Return Value

The gdi RotateFlipType

See Also

RotateFlipExtensions Class | Aspose.Imaging.Extensions Namespace


StringFormatExtensions Class

Contains extension methods for the StringFormat class.

For a list of all members of this type, see StringFormatExtensions Members.

System.Object
Aspose.Imaging.Extensions.StringFormatExtensions

public abstract sealed class StringFormatExtensions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Extensions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

StringFormatExtensions Members | Aspose.Imaging.Extensions Namespace


StringFormatExtensions Members

StringFormatExtensions overview

Public Static Methods

ToGdiStringFormat Converts the StringFormat to the StringFormat.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringFormatExtensions Class | Aspose.Imaging.Extensions Namespace


StringFormatExtensions Methods

The methods of the StringFormatExtensions class are listed below. For a complete list of StringFormatExtensions class members, see the StringFormatExtensions Members topic.

Public Static Methods

ToGdiStringFormat Converts the StringFormat to the StringFormat.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringFormatExtensions Class | Aspose.Imaging.Extensions Namespace


StringFormatExtensions.ToGdiStringFormat Method

Converts the StringFormat to the StringFormat.

public static StringFormat ToGdiStringFormat(
StringFormat stringFormat
);

Parameters

stringFormat
The StringFormat to convert.

Return Value

The converted StringFormat.

See Also

StringFormatExtensions Class | Aspose.Imaging.Extensions Namespace


Aspose.Imaging.FileFormats.Bmp

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Bmp Namespace

Namespace hierarchy

Classes

Class | Description
BmpImage | A bmp image.

Enumerations

Enumeration | Description
BitmapCompression | Specifies different bitmap compression methods.


BitmapCompression Enumeration

Specifies different bitmap compression methods.

public enum BitmapCompression

Members

Member Name | Description | Value
Rgb | No compression. | 0
Rle8 | RLE 8-bit/pixel compression. Can be used only with 8-bit/pixel bitmaps. | 1
Rle4 | RLE 4-bit/pixel compression. Can be used only with 4-bit/pixel bitmaps. | 2
Bitfields | Bit fields. Can be used only with 16 and 32-bit/pixel bitmaps. | 3
Jpeg | JPEG compression. The bitmap contains a JPEG image. | 4
Png | PNG compression. The bitmap contains a PNG image. | 5

Requirements

Namespace: Aspose.Imaging.FileFormats.Bmp

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Bmp Namespace


BmpImage Class

A bmp image.

For a list of all members of this type, see BmpImage Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image
Aspose.Imaging.RasterImage
Aspose.Imaging.RasterCachedImage
Aspose.Imaging.FileFormats.Bmp.BmpImage

public sealed class BmpImage : RasterCachedImage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Bmp

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

BmpImage Members | Aspose.Imaging.FileFormats.Bmp Namespace


BmpImage Members

BmpImage overview

Public Instance Constructors

BmpImage Overloaded. Initializes a new instance of the BmpImage class.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Compression | Gets the image compression.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
Height | Gets the image height.
HorizontalResolution | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
IsCached (inherited from RasterCachedImage) | Gets a value indicating whether image data is cached currently.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width | Gets the image width.

Public Instance Methods

CacheData (inherited from RasterCachedImage) | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop (inherited from RasterCachedImage) | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
Resize (inherited from RasterCachedImage) | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip (inherited from RasterCachedImage) | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


BmpImage Constructor

Initializes a new instance of the BmpImage class.

Overload List

Initializes a new instance of the BmpImage class.

public BmpImage(RasterImage);

Initializes a new instance of the BmpImage class.

public BmpImage(RasterImage,ushort,BitmapCompression,double,double);

Initializes a new instance of the BmpImage class.

public BmpImage(int,int);

Initializes a new instance of the BmpImage class.

public BmpImage(int,int,ushort,IColorPalette);

Initializes a new instance of the BmpImage class.

public BmpImage(int,int,ushort,IColorPalette,BitmapCompression,double,double);

Initializes a new instance of the BmpImage class.

public BmpImage(Stream);

Initializes a new instance of the BmpImage class.

public BmpImage(Stream,ushort,BitmapCompression,double,double);

Initializes a new instance of the BmpImage class.

public BmpImage(string);

Initializes a new instance of the BmpImage class.

public BmpImage(string,ushort,BitmapCompression,double,double);

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


BmpImage Constructor (String)

Initializes a new instance of the BmpImage class.

public BmpImage(
string path
);

Parameters

path
The path to load image from and initialize pixel and palette data with.

Exceptions

Exception Type | Condition
ArgumentNullException | raster image is null;rasterImage
BmpImageException | The height should be positive.
ArgumentException | Palette should be specified for images with 8 bits per pixel or less.;palette

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace | BmpImage Constructor Overload List


BmpImage Constructor (String, UInt16, BitmapCompression, Double, Double)

Initializes a new instance of the BmpImage class.

public BmpImage(
string path,
ushort bitsPerPixel,
BitmapCompression compression,
double horizontalResolution,
double verticalResolution
);

Parameters

path
The path to load image from and initialize pixel and palette data with.
bitsPerPixel
The bits per pixel.
compression
The compression to use.
horizontalResolution
The horizontal resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.
verticalResolution
The vertical resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.

Exceptions

Exception Type | Condition
ArgumentNullException | The raster image cannot be null;rasterImage
BmpImageException | The height should be positive.
ArgumentException | Palette should be specified for images with 8 bits per pixel or less.;palette

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace | BmpImage Constructor Overload List


BmpImage Constructor (Stream)

Initializes a new instance of the BmpImage class.

public BmpImage(
Stream stream
);

Parameters

stream
The stream to load image from and initialize pixel and palette data with.

Exceptions

Exception Type | Condition
ArgumentNullException | The raster image cannot be null;rasterImage
BmpImageException | The height should be positive.
ArgumentException | Palette should be specified for images with 8 bits per pixel or less.;palette

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace | BmpImage Constructor Overload List


BmpImage Constructor (Stream, UInt16, BitmapCompression, Double, Double)

Initializes a new instance of the BmpImage class.

public BmpImage(
Stream stream,
ushort bitsPerPixel,
BitmapCompression compression,
double horizontalResolution,
double verticalResolution
);

Parameters

stream
The stream to load image from and initialize pixel and palette data with.
bitsPerPixel
The bits per pixel.
compression
The compression to use.
horizontalResolution
The horizontal resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.
verticalResolution
The vertical resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.

Exceptions

Exception Type | Condition
ArgumentNullException | The raster image cannot be null;rasterImage
BmpImageException | The height should be positive.
ArgumentException | Palette should be specified for images with 8 bits per pixel or less.;palette

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace | BmpImage Constructor Overload List


BmpImage Constructor (RasterImage)

Initializes a new instance of the BmpImage class.

public BmpImage(
RasterImage rasterImage
);

Parameters

rasterImage
The image to initialize pixel and palette data with.

Exceptions

Exception Type | Condition
ArgumentNullException | The raster image cannot be null;rasterImage
BmpImageException | The height should be positive.
ArgumentException | Palette should be specified for images with 8 bits per pixel or less.;palette

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace | BmpImage Constructor Overload List


BmpImage Constructor (RasterImage, UInt16, BitmapCompression, Double, Double)

Initializes a new instance of the BmpImage class.

public BmpImage(
RasterImage rasterImage,
ushort bitsPerPixel,
BitmapCompression compression,
double horizontalResolution,
double verticalResolution
);

Parameters

rasterImage
The image to initialize pixel and palette data with.
bitsPerPixel
The bits per pixel.
compression
The compression to use.
horizontalResolution
The horizontal resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.
verticalResolution
The vertical resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.

Exceptions

Exception Type | Condition
ArgumentNullException | The raster image cannot be null;rasterImage
BmpImageException | The height should be positive.
ArgumentException | Palette should be specified for images with 8 bits per pixel or less.;palette

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace | BmpImage Constructor Overload List


BmpImage Constructor (Int32, Int32)

Initializes a new instance of the BmpImage class.

public BmpImage(
int width,
int height
);

Parameters

width
The image width.
height
The image height.

Exceptions

Exception Type | Condition
BmpImageException | The height should be positive.
ArgumentException | Palette should be specified for images with 8 bits per pixel or less.;palette

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace | BmpImage Constructor Overload List


BmpImage Constructor (Int32, Int32, UInt16, IColorPalette)

Initializes a new instance of the BmpImage class.

public BmpImage(
int width,
int height,
ushort bitsPerPixel,
IColorPalette palette
);

Parameters

width
The image width.
height
The image height.
bitsPerPixel
The bits per pixel.
palette
The color palette.

Exceptions

Exception Type | Condition
BmpImageException | The height should be positive.
ArgumentException | Palette should be specified for images with 8 bits per pixel or less.;palette

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace | BmpImage Constructor Overload List


BmpImage Constructor (Int32, Int32, UInt16, IColorPalette, BitmapCompression, Double, Double)

Initializes a new instance of the BmpImage class.

public BmpImage(
int width,
int height,
ushort bitsPerPixel,
IColorPalette palette,
BitmapCompression compression,
double horizontalResolution,
double verticalResolution
);

Parameters

width
The image width.
height
The image height.
bitsPerPixel
The bits per pixel.
palette
The color palette.
compression
The compression to use.
horizontalResolution
The horizontal resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.
verticalResolution
The vertical resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.

Exceptions

Exception Type | Condition
BmpImageException | The height should be positive.
ArgumentException | Palette should be specified for images with 8 bits per pixel or less.;palette

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace | BmpImage Constructor Overload List


BmpImage Properties

The properties of the BmpImage class are listed below. For a complete list of BmpImage class members, see the BmpImage Members topic.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Compression | Gets the image compression.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
Height | Gets the image height.
HorizontalResolution | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
IsCached (inherited from RasterCachedImage) | Gets a value indicating whether image data is cached currently.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width | Gets the image width.

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

BmpImage.BitsPerPixel Property

Gets the image bits per pixel count.

public override int BitsPerPixel {get;}

Property Value

The image bits per pixel count.

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


Compression Property

Aspose.Imaging Documentation

BmpImage.Compression Property

Gets the image compression.

public BitmapCompression Compression {get;}

Property Value

The image compression.

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


Height Property

Aspose.Imaging Documentation

BmpImage.Height Property

Gets the image height.

public override int Height {get;}

Property Value

The image height.

Implements

IObjectWithBounds.Height

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


HorizontalResolution Property

Aspose.Imaging Documentation

BmpImage.HorizontalResolution Property

Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.

public override double HorizontalResolution {get; set;}

Property Value

The horizontal resolution.

Remarks

Note by default this value is always 96 since different platforms cannot return the screen resolution. You may consider using the SetResolution method for updating both resolution values in single call.

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


RawDataFormat Property

Aspose.Imaging Documentation

BmpImage.RawDataFormat Property

Gets the raw data format.

public override PixelDataFormat RawDataFormat {get;}

Property Value

The raw data format.

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


RawLineSize Property

Aspose.Imaging Documentation

BmpImage.RawLineSize Property

Gets the raw line size in bytes.

public override int RawLineSize {get;}

Property Value

The raw line size in bytes.

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


VerticalResolution Property

Aspose.Imaging Documentation

BmpImage.VerticalResolution Property

Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.

public override double VerticalResolution {get; set;}

Property Value

The vertical resolution.

Remarks

Note by default this value is always 96 since different platforms cannot return the screen resolution. You may consider using the SetResolution method for updating both resolution values in single call.

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


Width Property

Aspose.Imaging Documentation

BmpImage.Width Property

Gets the image width.

public override int Width {get;}

Property Value

The image width.

Implements

IObjectWithBounds.Width

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


BmpImage Methods

The methods of the BmpImage class are listed below. For a complete list of BmpImage class members, see the BmpImage Members topic.

Public Instance Methods

CacheData (inherited from RasterCachedImage) | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop (inherited from RasterCachedImage) | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
Resize (inherited from RasterCachedImage) | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip (inherited from RasterCachedImage) | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


BmpImage.SetResolution Method

Sets the resolution for this RasterImage.

public override void SetResolution(
double dpiX,
double dpiY
);

Parameters

dpiX
The horizontal resolution, in dots per inch, of the RasterImage.
dpiY
The vertical resolution, in dots per inch, of the RasterImage.

See Also

BmpImage Class | Aspose.Imaging.FileFormats.Bmp Namespace


Aspose.Imaging.FileFormats.Cad

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Cad Namespace

Namespace hierarchy

Classes

Class | Description
CadAciColor | Represents an indexed color.
CadBlockDictionary | CAD blocks collection
CadCodeValue | Code Value class
CadDimensionDictionary | Collection of dimension styles
CadImage | Cad image class
CadLayersDictionary | Layers of the Cad Image
CadLayoutDictionary | Collection of cad layouts
CadLineTypesDictionary | Represents dictionary with types of lines.
CadStylesDictionary | Dictionary of Cad styles

Enumerations

Enumeration | Description
CadDrawTypeMode | Represents possible modes for colorization of objects.
CadEntityAttribute | Entities enum
ScaleType | Represents possible modes for automatic scale of an image.


CadAciColor Class

Represents an indexed color.

For a list of all members of this type, see CadAciColor Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadAciColor

public class CadAciColor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadAciColor Members | Aspose.Imaging.FileFormats.Cad Namespace


CadAciColor Members

CadAciColor overview

Public Static Properties

Blue | Gets the blue.
ByBlock | Gets the ByBlock color.
ByLayer | Gets the ByLayer color.
Cyan | Gets a default cyan color.
DarkGrey | Gets a default dark grey color.
Default | Gets a default white/black color.
Green | Gets a default green color.
LightGrey | Gets a default light grey color.
Magenta | Gets a default magenta color.
Red | Gets a default red color.
Yellow | Gets a default yellow color.

Public Instance Constructors

CadAciColor Overloaded. Initializes a new instance of the CadAciColor class.

Public Instance Properties

Index Gets or sets the color index.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToColor | Converts the CadAciColor to a color.
ToString | Converts the value of this instance to its equivalent string representation.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


CadAciColor Constructor

Initializes a new instance of the CadAciColor class.

Overload List

Initializes a new instance of the CadAciColor class.

public CadAciColor(Color);

Initializes a new instance of the CadAciColor class.

public CadAciColor(byte,byte,byte);

Initializes a new instance of the class.

public CadAciColor(short);

Initializes a new instance of the CadAciColor class.

public CadAciColor(float,float,float);

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


CadAciColor Constructor (Byte, Byte, Byte)

Initializes a new instance of the CadAciColor class.

public CadAciColor(
byte r,
byte g,
byte b
);

Parameters

r
The Red Color
g
The Green Color
b
The Blue Color

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace | CadAciColor Constructor Overload List


CadAciColor Constructor (Single, Single, Single)

Initializes a new instance of the CadAciColor class.

public CadAciColor(
float r,
float g,
float b
);

Parameters

r
The Red Color
g
The Green Color
b
The Blue Color

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace | CadAciColor Constructor Overload List


CadAciColor Constructor (Color)

Initializes a new instance of the CadAciColor class.

public CadAciColor(
Color color
);

Parameters

color
The color.

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace | CadAciColor Constructor Overload List


CadAciColor Constructor (Int16)

Initializes a new instance of the class.

public CadAciColor(
short index
);

Parameters

index
The index.

Exceptions

Exception Type | Condition
ArgumentException | index out of range

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace | CadAciColor Constructor Overload List


CadAciColor Properties

The properties of the CadAciColor class are listed below. For a complete list of CadAciColor class members, see the CadAciColor Members topic.

Public Static Properties

Blue | Gets the blue.
ByBlock | Gets the ByBlock color.
ByLayer | Gets the ByLayer color.
Cyan | Gets a default cyan color.
DarkGrey | Gets a default dark grey color.
Default | Gets a default white/black color.
Green | Gets a default green color.
LightGrey | Gets a default light grey color.
Magenta | Gets a default magenta color.
Red | Gets a default red color.
Yellow | Gets a default yellow color.

Public Instance Properties

Index Gets or sets the color index.

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


Blue Property

Aspose.Imaging Documentation

CadAciColor.Blue Property

Gets the blue.

public static CadAciColor Blue {get;}

Property Value

The blue Color.

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


ByBlock Property

Aspose.Imaging Documentation

CadAciColor.ByBlock Property

Gets the ByBlock color.

public static CadAciColor ByBlock {get;}

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


ByLayer Property

Aspose.Imaging Documentation

CadAciColor.ByLayer Property

Gets the ByLayer color.

public static CadAciColor ByLayer {get;}

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


Cyan Property

Aspose.Imaging Documentation

CadAciColor.Cyan Property

Gets a default cyan color.

public static CadAciColor Cyan {get;}

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


DarkGrey Property

Aspose.Imaging Documentation

CadAciColor.DarkGrey Property

Gets a default dark grey color.

public static CadAciColor DarkGrey {get;}

Property Value

The dark grey.

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


Default Property

Aspose.Imaging Documentation

CadAciColor.Default Property

Gets a default white/black color.

public static CadAciColor Default {get;}

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


Green Property

Aspose.Imaging Documentation

CadAciColor.Green Property

Gets a default green color.

public static CadAciColor Green {get;}

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


Index Property

Aspose.Imaging Documentation

CadAciColor.Index Property

Gets or sets the color index.

public short Index {get; set;}

Remarks

Accepted color index values range from 0 to 256. Indexes from 1 to 255 represents a color, the index 256 is reserved to define a color bylayer and the index 0 represents byblock.

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


LightGrey Property

Aspose.Imaging Documentation

CadAciColor.LightGrey Property

Gets a default light grey color.

public static CadAciColor LightGrey {get;}

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


Magenta Property

Aspose.Imaging Documentation

CadAciColor.Magenta Property

Gets a default magenta color.

public static CadAciColor Magenta {get;}

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


Red Property

Aspose.Imaging Documentation

CadAciColor.Red Property

Gets a default red color.

public static CadAciColor Red {get;}

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


Yellow Property

Aspose.Imaging Documentation

CadAciColor.Yellow Property

Gets a default yellow color.

public static CadAciColor Yellow {get;}

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


CadAciColor Methods

The methods of the CadAciColor class are listed below. For a complete list of CadAciColor class members, see the CadAciColor Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToColor | Converts the CadAciColor to a color.
ToString | Converts the value of this instance to its equivalent string representation.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


CadAciColor.ToColor Method

Converts the CadAciColor to a color.

public Color ToColor();

Return Value

A default color white will be used for byblock and bylayer colors.

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


CadAciColor.ToString Method

Converts the value of this instance to its equivalent string representation.

public override string ToString();

Return Value

The string representation.

See Also

CadAciColor Class | Aspose.Imaging.FileFormats.Cad Namespace


CadBlockDictionary Class

CAD blocks collection

For a list of all members of this type, see CadBlockDictionary Members.

System.Object
System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadObjects.CadBlockEntity, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]
Aspose.Imaging.FileFormats.Cad.CadBlockDictionary

public class CadBlockDictionary : Dictionary`2, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadBlockDictionary Members | Aspose.Imaging.FileFormats.Cad Namespace


CadBlockDictionary Members

CadBlockDictionary overview

Public Instance Constructors

CadBlockDictionary Constructor Initializes a new instance of the CadBlockDictionary class.

Public Instance Properties

Comparer (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Count (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Keys (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Values (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clone | The clone.
ContainsKey (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ContainsValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBlockDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadBlockDictionary Constructor

Initializes a new instance of the CadBlockDictionary class.

public CadBlockDictionary();

See Also

CadBlockDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadBlockDictionary Methods

The methods of the CadBlockDictionary class are listed below. For a complete list of CadBlockDictionary class members, see the CadBlockDictionary Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clone | The clone.
ContainsKey (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ContainsValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBlockDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadBlockDictionary.Clone Method

The clone.

public object Clone();

Return Value

The Object.

Implements

ICloneable.Clone

See Also

CadBlockDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadCodeValue Class

Code Value class

For a list of all members of this type, see CadCodeValue Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadCodeValue

public class CadCodeValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadCodeValue Members | Aspose.Imaging.FileFormats.Cad Namespace


CadCodeValue Members

CadCodeValue overview

Public Static Methods

Read Reads the specified stream.

Public Instance Constructors

CadCodeValue Constructor Initializes a new instance of the CadCodeValue class.

Public Instance Properties

Attribute | Gets the attribute.
Code | Gets or sets the code.
Value | Gets or sets the value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDoubleValue | The get double value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIntValue | The get int value.
GetShortValue | The get short value.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadCodeValue Class | Aspose.Imaging.FileFormats.Cad Namespace


CadCodeValue Constructor

Initializes a new instance of the CadCodeValue class.

public CadCodeValue();

See Also

CadCodeValue Class | Aspose.Imaging.FileFormats.Cad Namespace


CadCodeValue Properties

The properties of the CadCodeValue class are listed below. For a complete list of CadCodeValue class members, see the CadCodeValue Members topic.

Public Instance Properties

Attribute | Gets the attribute.
Code | Gets or sets the code.
Value | Gets or sets the value.

See Also

CadCodeValue Class | Aspose.Imaging.FileFormats.Cad Namespace


Attribute Property

Aspose.Imaging Documentation

CadCodeValue.Attribute Property

Gets the attribute.

public CadEntityAttribute Attribute {get;}

See Also

CadCodeValue Class | Aspose.Imaging.FileFormats.Cad Namespace


Code Property

Aspose.Imaging Documentation

CadCodeValue.Code Property

Gets or sets the code.

public int Code {get; set;}

Property Value

The code.

See Also

CadCodeValue Class | Aspose.Imaging.FileFormats.Cad Namespace


Value Property

Aspose.Imaging Documentation

CadCodeValue.Value Property

Gets or sets the value.

public string Value {get; set;}

Property Value

The value.

See Also

CadCodeValue Class | Aspose.Imaging.FileFormats.Cad Namespace


CadCodeValue Methods

The methods of the CadCodeValue class are listed below. For a complete list of CadCodeValue class members, see the CadCodeValue Members topic.

Public Static Methods

Read Reads the specified stream.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDoubleValue | The get double value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIntValue | The get int value.
GetShortValue | The get short value.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadCodeValue Class | Aspose.Imaging.FileFormats.Cad Namespace


CadCodeValue.GetDoubleValue Method

The get double value.

public double GetDoubleValue();

Return Value

The Double.

See Also

CadCodeValue Class | Aspose.Imaging.FileFormats.Cad Namespace


CadCodeValue.GetIntValue Method

The get int value.

public int GetIntValue();

Return Value

The Int32.

See Also

CadCodeValue Class | Aspose.Imaging.FileFormats.Cad Namespace


CadCodeValue.GetShortValue Method

The get short value.

public short GetShortValue();

Return Value

The Int16.

See Also

CadCodeValue Class | Aspose.Imaging.FileFormats.Cad Namespace


CadCodeValue.Read Method

Reads the specified stream.

public static CadCodeValue Read(
TextReader stream
);

Parameters

stream
The stream.

Return Value

Code value instance

Exceptions

Exception Type | Condition
CadException | Invalid group code + codeLine + in pos: + stream.BaseStream.Position

See Also

CadCodeValue Class | Aspose.Imaging.FileFormats.Cad Namespace


CadDimensionDictionary Class

Collection of dimension styles

For a list of all members of this type, see CadDimensionDictionary Members.

System.Object
System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadDimensionStyleTable, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]
Aspose.Imaging.FileFormats.Cad.CadDimensionDictionary

public class CadDimensionDictionary : Dictionary`2, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadDimensionDictionary Members | Aspose.Imaging.FileFormats.Cad Namespace


CadDimensionDictionary Members

CadDimensionDictionary overview

Public Instance Constructors

CadDimensionDictionary Constructor Initializes a new instance of the CadDimensionDictionary class.

Public Instance Properties

Comparer (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Count (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Keys (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Values (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clone | The clone.
ContainsKey (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ContainsValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadDimensionDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadDimensionDictionary Constructor

Initializes a new instance of the CadDimensionDictionary class.

public CadDimensionDictionary();

See Also

CadDimensionDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadDimensionDictionary Methods

The methods of the CadDimensionDictionary class are listed below. For a complete list of CadDimensionDictionary class members, see the CadDimensionDictionary Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clone | The clone.
ContainsKey (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ContainsValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadDimensionDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadDimensionDictionary.Clone Method

The clone.

public object Clone();

Return Value

The Object.

Implements

ICloneable.Clone

See Also

CadDimensionDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadDrawTypeMode Enumeration

Represents possible modes for colorization of objects.

public enum CadDrawTypeMode

Members

Member Name | Description | Value
UseDrawColor | Allows to use common color. | 0
UseObjectColor | Allows to use separate color for every object. | 1

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad Namespace


CadEntityAttribute Enumeration

Entities enum

public enum CadEntityAttribute

Members

Member Name | Description | Value
CadAppEntityName | APP: entity name (changes each time a drawing is opened) | -1
Cad000 | Entity type | 0
Cad001 | Entity attribute value | 1
Cad002 | The Cad two | 2
Cad003 | The Cad 003. | 3
Cad005 | Handle of the object | 5
Cad102 | 102 Start or End of application-defined group “{application_name” (optional) | 102
Cad330 | Soft-pointer ID/handle to.. depends on situation | 330
Cad331 | The Cad 331. | 331
Cad360 | Hard-owner ID/handle to owner dictionary (optional) | 360
Cad100 | Subclass marker | 100
Cad067 | Absent or zero indicates entity is in model space. 1 indicates entity is in paper space (optional) | 67
Cad410 | APP: layout tab name | 410
Cad008 | Layer name | 8
Cad006 | Linetype name (present if not BYLAYER). The special name BYBLOCK indicates a floating linetype (optional) | 6
Cad007 | The Cad007 | 7
Cad347 | Hard-pointer ID/handle to material object (present if not BYLAYER) | 347
Cad350 | The Cad350 | 350
Cad062 | Color number (present if not BYLAYER); | 62
Cad064 | The Cad 064. | 64
Cad065 | The Cad 065. | 65
Cad068 | The Cad 068. | 68
Cad069 | The Cad 069. | 69
Cad370 | Lineweight enum value. Stored and moved around as a 16-bit integer | 370
Cad048 | Linetype scale (optional) | 48
Cad049 | The Cad049 | 49
Cad060 | Object visibility (optional): 0 = Visible; 1 = Invisible | 60
Cad092 | Number of bytes in the proxy entity graphics represented in the subsequent 310 groups, which are binary chunk records (optional) | 92
Cad310 | Proxy entity graphics data (multiple lines; 256 characters max. per line) | 310
Cad420 | A 24-bit color value that should be dealt with in terms of bytes with values of 0 to 255. The lowest byte is the blue value, the middle byte is the green value, and the third byte is the red value. The top byte is always 0 | 420
Cad421 | The Cad 421. | 421
Cad422 | The Cad 422. | 422
Cad423 | The Cad 423. | 423
Cad424 | The Cad 424. | 424
Cad425 | The Cad 425. | 425
Cad426 | The Cad 426. | 426
Cad427 | The Cad 427. | 427
Cad428 | The Cad 428. | 428
Cad429 | The Cad 429. | 429
Cad430 | The Cad 430. | 430
Cad431 | The Cad 431. | 431
Cad432 | The Cad 432. | 432
Cad433 | The Cad 433. | 433
Cad434 | The Cad 434. | 434
Cad435 | The Cad 435. | 435
Cad436 | The Cad 436. | 436
Cad437 | The Cad 437. | 437
Cad438 | The Cad 438. | 438
Cad439 | The Cad 439. | 439
Cad440 | Transparency value. | 440
Cad441 | The Cad 441. | 441
Cad390 | 390 Hard-pointer ID/handle to the plot style object | 390
Cad284 | Shadow mode | 284
Cad090 | Points count | 90
Cad010 | First point or corner X | 10
Cad020 | First point or corner Y | 20
Cad030 | First point or corner Z | 30
Cad011 | End point or corner X | 11
Cad021 | End point or corner Y | 21
Cad022 | The Cad022 | 22
Cad031 | End point or corner Z | 31
Cad012 | Start tangent X | 12
Cad032 | Start tangent Z | 32
Cad013 | End tangent X | 13
Cad016 | The Cad 016. | 16
Cad023 | End tangent Y | 23
Cad026 | The Cad 026. | 26
Cad033 | End tangent Z | 33
Cad036 | The Cad 036. | 36
Cad040 | Radius or width | 40
Cad050 | First angle or Rotation angle or... | 50
Cad051 | First angle or Rotation angle or... | 51
Cad053 | The Cad fifty three | 53
Cad210 | Extrusion Direction X Value | 210
Cad211 | Extrusion Direction Y Value | 211
Cad212 | Extrusion Direction Z Value | 212
Cad220 | Extrusion Direction Y Value | 220
Cad230 | Extrusion Direction Z Value | 230
Cad039 | Thickness (optional; default = 0) | 39
Cad066 | Obsolete; formerly an “entities follow flag” (optional; ignore if present) | 66
Cad041 | Default end width (optional; default = 0) | 41
Cad071 | Polygon mesh M vertex count (optional; default = 0) | 71
Cad072 | Polygon mesh N vertex count (optional; default = 0) | 72
Cad073 | Smooth surface M density (optional; default = 0) | 73
Cad074 | Smooth surface N density (optional; default = 0) | 74
Cad075 | Curves and smooth surface type (optional; default = 0); integer codes, not bit-coded: | 75
Cad076 | The Cad 076. | 76
Cad078 | The Cad 078. | 78
Cad079 | The Cad 079. | 79
Cad042 | Bulge (optional; default is 0). The bulge is the tangent of one fourth the included angle for an arc segment, made negative if the arc goes clockwise from the start point to the endpoint. A bulge of 0 indicates a straight segment, and a bulge of 1 is a semicircle | 42
Cad043 | Control Point Tolerance | 43
Cad070 | Vertex flags | 70
Cad091 | Vertex identifier | 91
Cad290 | Handendness of the helix | 290
Cad280 | Constrain type | 280
Cad281 | The Cad 281. | 281
Cad282 | The Cad 282. | 282
Cad283 | The Cad 283. | 283
Cad289 | The Cad 289. | 289
Cad340 | Leader Style Id | 340
Cad341 | Leader Style Id | 341
Cad171 | LeaderLine wight | 171
Cad291 | Enable Dogleg | 291
Cad172 | Content Type | 172
Cad343 | Text Style ID | 343
Cad173 | Text Left Attachment Type | 173
Cad271 | Text attachment direction | 271
Cad272 | Bottom text attachment direction | 272
Cad273 | Top text attachment direction | 273
Cad275 | The Cad 275. | 275
Cad276 | The Cad 276. | 276
Cad277 | The Cad 277. | 277
Cad278 | The Cad 278. | 278
Cad279 | The Cad 279. | 279
Cad178 | Text Align in IPE | 178
Cad179 | Text Attachment Point | 179
Cad294 | Text Direction Negative | 294
Cad302 | Block Attribute Text String | 302
Cad044 | Block Attribute Width | 44
Cad177 | Block Attribute Index | 177
Cad345 | Arrowhead ID | 345
Cad094 | Arrowhead Index | 94
Cad293 | Enable Annotation Scale | 293
Cad176 | Block Content Connection Type | 176
Cad093 | Block Content Color | 93
Cad292 | Enable Frame Text | 292
Cad344 | Block Content ID | 344
Cad174 | Text Angle Type | 174
Cad175 | Text Alignment Type | 175
Cad095 | Text Right Attachment Type | 95
Cad096 | The Cad 096. | 96
Cad342 | Arrowhead ID | 342
Cad170 | Leader Line Type | 170
Cad140 | Arrowhead Size | 140
Cad145 | Landing Gap | 145
Cad304 | Default Text Contents | 304
Cad045 | Line Spacing Factor | 45
Cad141 | Text Background Scale Factor | 141
Cad142 | Text Column Width | 142
Cad143 | Text Column Gutter Width | 143
Cad144 | 144 Text Column Height | 144
Cad295 | Text Use Word Break | 295
Cad296 | 296 Enumeration | 296
Cad014 | Block Content Normal Direction X | 14
Cad024 | Block Content Normal Direction Y | 24
Cad034 | Block Content Normal Direction Z | 34
Cad015 | Block Content Position X | 15
Cad025 | Block Content Position Y | 25
Cad035 | Block Content Position Z | 35
Cad038 | The Cad 038. | 38
Cad16 | Block Content Scale | 16
Cad046 | Block Content Rotation | 46
Cad047 | Block Transformation Matrix | 47
Cad110 | MLeader Plane Origin Point | 110
Cad111 | MLeader Plane X-Axis Direction | 111
Cad112 | MLeader Plane Y-Axis Direction | 112
Cad297 | MLeader Plane Normal Reversed | 297
Cad300 | Context data | 300
Cad063 | Indicator color | 63
Cad411 | The Cad 411. | 411
Cad017 | The Cad 017. | 17
Cad037 | The Cad 037. | 37
Cad027 | The Cad 027. | 27
Cad120 | The Cad 120. | 120
Cad130 | The Cad 130. | 130
Cad121 | The Cad 121. | 121
Cad131 | The Cad 131. | 131
Cad132 | The Cad 132. | 132
Cad122 | The Cad 122. | 122
Cad346 | The Cad 346. | 346
Cad146 | The Cad 146. | 146
Cad061 | The Cad 061. | 61
Cad332 | The Cad 332. | 332
Cad333 | The Cad 333. | 333
Cad348 | The Cad 348. | 348
Cad361 | The Cad 361. | 361
Cad335 | The Cad 335. | 335
Cad004 | The Cad 004. | 4
Cad052 | The Cad 052. | 52
Cad077 | The Cad 077. | 77
Cad098 | The Cad 098. | 98
Cad099 | The Cad 099. | 99
Cad450 | The Cad 450. | 450
Cad452 | The Cad 452. | 452
Cad453 | The Cad 453. | 453
Cad460 | The Cad 460. | 460
Cad461 | The Cad 461. | 461
Cad462 | The Cad 462. | 462
Cad097 | The Cad 097. | 97
Cad147 | The Cad 147. | 147
Cad148 | The Cad 148. | 148
Cad149 | The cad149 | 149
Cad270 | The Cad 270. | 270
Cad274 | The Cad 274. | 274
Cad285 | The Cad 285. | 285
Cad286 | The Cad 286. | 286
Cad287 | The Cad 287. | 287
Cad288 | The Cad 288. | 288
Cad371 | The Cad 371. | 371
Cad372 | The Cad 372. | 372
Cad1000 | The Cad 1000. | 1000
Cad1001 | The Cad 1001. | 1001
Cad1002 | The Cad 1002. | 1002
Cad1003 | The Cad 1003. | 1003
Cad1004 | The Cad 1004. | 1004
Cad1005 | The Cad 1005. | 1005
Cad1006 | The Cad 1006. | 1006
Cad1007 | The Cad 1007. | 1007
Cad1008 | The Cad 1008. | 1008
Cad1009 | The Cad 1009. | 1009
Cad1010 | The Cad 1010. | 1010
Cad1011 | The Cad 1011. | 1011
Cad1012 | The Cad 1012. | 1012
Cad1013 | The Cad 1013. | 1013
Cad1014 | The Cad 1014. | 1014
Cad1015 | The Cad 1015. | 1015
Cad1016 | The Cad 1016. | 1016
Cad1017 | The Cad 1017. | 1017
Cad1018 | The Cad 1018. | 1018
Cad1019 | The Cad 1019. | 1019
Cad1020 | The Cad 1020. | 1020
Cad1021 | The Cad 1021. | 1021
Cad1022 | The Cad 1022. | 1022
Cad1023 | The Cad 1023. | 1023
Cad1024 | The Cad 1024. | 1024
Cad1025 | The Cad 1025. | 1025
Cad1026 | The Cad 1026. | 1026
Cad1027 | The Cad 1027. | 1027
Cad1028 | The Cad 1028. | 1028
Cad1029 | The Cad 1029. | 1029
Cad1030 | The Cad 1030. | 1030
Cad1031 | The Cad 1031. | 1031
Cad1032 | The Cad 1032. | 1032
Cad1033 | The Cad 1033. | 1033
Cad1034 | The Cad 1034. | 1034
Cad1035 | The Cad 1035. | 1035
Cad1036 | The Cad 1036. | 1036
Cad1037 | The Cad 1037. | 1037
Cad1038 | The Cad 1038. | 1038
Cad1039 | The Cad 1039. | 1039
Cad1040 | The Cad 1040. | 1040
Cad1041 | The Cad 1041. | 1041
Cad1042 | The Cad 1042. | 1042
Cad1043 | The Cad 1043. | 1043
Cad1044 | The Cad 1044. | 1044
Cad1045 | The Cad 1045. | 1045
Cad1046 | The Cad 1046. | 1046
Cad1047 | The Cad 1047. | 1047
Cad1048 | The Cad 1048. | 1048
Cad1049 | The Cad 1049. | 1049
Cad1050 | The Cad 1050. | 1050
Cad1051 | The Cad 1051. | 1051
Cad1052 | The Cad 1052. | 1052
Cad1053 | The Cad 1053. | 1053
Cad1054 | The Cad 1054. | 1054
Cad1055 | The Cad 1055. | 1055
Cad1056 | The Cad 1056. | 1056
Cad1057 | The Cad 1057. | 1057
Cad1058 | The Cad 1058. | 1058
Cad1059 | The Cad 1059. | 1059
Cad1060 | The Cad 1060. | 1060
Cad1061 | The Cad 1061. | 1061
Cad1062 | The Cad 1062. | 1062
Cad1063 | The Cad 1063. | 1063
Cad1064 | The Cad 1064. | 1064
Cad1065 | The Cad 1065. | 1065
Cad1066 | The Cad 1066. | 1066
Cad1067 | The Cad 1067. | 1067
Cad1068 | The Cad 1068. | 1068
Cad1069 | The Cad 1069. | 1069
Cad1070 | The Cad 1070. | 1070
Cad1071 | The Cad 1071. | 1071
Cad009 | The Cad009 | 9

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad Namespace


CadImage Class

Cad image class

For a list of all members of this type, see CadImage Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image
Aspose.Imaging.FileFormats.Cad.CadImage

public class CadImage : Image

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadImage Members | Aspose.Imaging.FileFormats.Cad Namespace


CadImage Members

CadImage overview

Public Instance Constructors

CadImage Constructor Initializes a new instance of the CadImage class.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
BlockEntities | Gets or sets the block entities.
BlocksTables | Gets or sets the blocks tables.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
DimensionStyles | Gets or sets the dimension styles.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
Entities | Gets or sets the entities.
Height | Gets the image height.
IsCached | Gets a value indicating whether object's data is cached currently and no data reading is required.
Layers | Gets or sets the layers.
Layouts | Gets the layouts.
LineTypes | Gets or sets the dimension styles.
MaxPoint | Gets the max point.
MinPoint | Gets the min point.
Objects | Gets or sets the objects.
Palette (inherited from Image) | Gets or sets the color palette.
Size (inherited from Image) | Gets the image size.
Styles | Gets or sets the styles.
Width | Gets the image width.

Public Instance Methods

CacheData | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Resize | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SetPalette | Sets the image palette.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFitRectangle (inherited from Image) | Overloaded. Gets rectangle which fits the current image.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataStreamContainerChanging (inherited from DataStreamSupporter) | Called when data stream container is changing.
OnPaletteChanged (inherited from Image) | Called when palette is changed.
OnPaletteChanging (inherited from Image) | Called when palette is changing.
ReleaseManagedResources (inherited from Image) | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
SaveData | Saves the object's data to the specified stream.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


CadImage Constructor

Initializes a new instance of the CadImage class.

public CadImage();

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


CadImage Properties

The properties of the CadImage class are listed below. For a complete list of CadImage class members, see the CadImage Members topic.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
BlockEntities | Gets or sets the block entities.
BlocksTables | Gets or sets the blocks tables.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
DimensionStyles | Gets or sets the dimension styles.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
Entities | Gets or sets the entities.
Height | Gets the image height.
IsCached | Gets a value indicating whether object's data is cached currently and no data reading is required.
Layers | Gets or sets the layers.
Layouts | Gets the layouts.
LineTypes | Gets or sets the dimension styles.
MaxPoint | Gets the max point.
MinPoint | Gets the min point.
Objects | Gets or sets the objects.
Palette (inherited from Image) | Gets or sets the color palette.
Size (inherited from Image) | Gets the image size.
Styles | Gets or sets the styles.
Width | Gets the image width.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

CadImage.BitsPerPixel Property

Gets the image bits per pixel count.

public override int BitsPerPixel {get;}

Property Value

The image bits per pixel count.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


BlockEntities Property

Aspose.Imaging Documentation

CadImage.BlockEntities Property

Gets or sets the block entities.

public CadBlockDictionary BlockEntities {get; set;}

Property Value

The block entities.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


BlocksTables Property

Aspose.Imaging Documentation

CadImage.BlocksTables Property

Gets or sets the blocks tables.

public CadBlockTableObject} BlocksTables {get; set;}

Property Value

The blocks tables.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


DimensionStyles Property

Aspose.Imaging Documentation

CadImage.DimensionStyles Property

Gets or sets the dimension styles.

public CadDimensionDictionary DimensionStyles {get; set;}

Property Value

The dimension styles.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


Entities Property

Aspose.Imaging Documentation

CadImage.Entities Property

Gets or sets the entities.

public CadBaseEntity[] Entities {get; set;}

Property Value

The entities.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


Height Property

Aspose.Imaging Documentation

CadImage.Height Property

Gets the image height.

public override int Height {get;}

Property Value

The image height.

Implements

IObjectWithBounds.Height

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


IsCached Property

Aspose.Imaging Documentation

CadImage.IsCached Property

Gets a value indicating whether object's data is cached currently and no data reading is required.

public bool IsCached {get;}

Property Value

true if object's data is cached; otherwise, false.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


Layers Property

Aspose.Imaging Documentation

CadImage.Layers Property

Gets or sets the layers.

public CadLayersDictionary Layers {get; set;}

Property Value

The layers.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


Layouts Property

Aspose.Imaging Documentation

CadImage.Layouts Property

Gets the layouts.

public CadLayoutDictionary Layouts {get;}

Property Value

The layouts.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


LineTypes Property

Aspose.Imaging Documentation

CadImage.LineTypes Property

Gets or sets the dimension styles.

public CadLineTypesDictionary LineTypes {get; set;}

Property Value

The dimension styles.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


MaxPoint Property

Aspose.Imaging Documentation

CadImage.MaxPoint Property

Gets the max point.

public PointF MaxPoint {get;}

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


MinPoint Property

Aspose.Imaging Documentation

CadImage.MinPoint Property

Gets the min point.

public PointF MinPoint {get;}

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


Objects Property

Aspose.Imaging Documentation

CadImage.Objects Property

Gets or sets the objects.

public CadBaseObject[] Objects {get; set;}

Property Value

The objects.

Exceptions

Exception Type | Condition
CadException | Invalid value for Objects

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


Styles Property

Aspose.Imaging Documentation

CadImage.Styles Property

Gets or sets the styles.

public CadStylesDictionary Styles {get; set;}

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


Width Property

Aspose.Imaging Documentation

CadImage.Width Property

Gets the image width.

public override int Width {get;}

Property Value

The image width.

Implements

IObjectWithBounds.Width

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


CadImage Methods

The methods of the CadImage class are listed below. For a complete list of CadImage class members, see the CadImage Members topic.

Public Instance Methods

CacheData | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Resize | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SetPalette | Sets the image palette.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFitRectangle (inherited from Image) | Overloaded. Gets rectangle which fits the current image.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnDataStreamContainerChanging (inherited from DataStreamSupporter) | Called when data stream container is changing.
OnPaletteChanged (inherited from Image) | Called when palette is changed.
OnPaletteChanging (inherited from Image) | Called when palette is changing.
ReleaseManagedResources (inherited from Image) | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
SaveData | Saves the object's data to the specified stream.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


CadImage.CacheData Method

Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.

public void CacheData();

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


Resize Method

Aspose.Imaging Documentation

CadImage.Resize Method

Resizes the image.

Overload List

Inherited from Image.

public void Resize(int,int);

Resizes the image.

public override void Resize(int,int,ResizeType);

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


CadImage.Resize Method (Int32, Int32, ResizeType)

Resizes the image.

public override void Resize(
int newWidth,
int newHeight,
ResizeType resizeType
);

Parameters

newWidth
The new width.
newHeight
The new height.
resizeType
The resize type.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace | CadImage.Resize Overload List


CadImage.RotateFlip Method

Rotates, flips, or rotates and flips the image.

public override void RotateFlip(
RotateFlipType rotateFlipType
);

Parameters

rotateFlipType
Type of the rotate flip.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


CadImage.SaveData Method

Saves the object's data to the specified stream.

protected override void SaveData(
Stream stream
);

Parameters

stream
The stream to save the object's data to.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


CadImage.SetPalette Method

Sets the image palette.

public override void SetPalette(
IColorPalette palette,
bool updateColors
);

Parameters

palette
The palette to set.
updateColors
if set to true colors will be updated according to the new palette; otherwise color indexes remain unchanged. Note that unchanged indexes may crash the image on loading if some indexes have no corresponding palette entries.

See Also

CadImage Class | Aspose.Imaging.FileFormats.Cad Namespace


CadLayersDictionary Class

Layers of the Cad Image

For a list of all members of this type, see CadLayersDictionary Members.

System.Object
System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadLayerTable, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]
Aspose.Imaging.FileFormats.Cad.CadLayersDictionary

public class CadLayersDictionary : Dictionary`2, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadLayersDictionary Members | Aspose.Imaging.FileFormats.Cad Namespace


CadLayersDictionary Members

CadLayersDictionary overview

Public Instance Constructors

CadLayersDictionary Constructor Initializes a new instance of the CadLayersDictionary class.

Public Instance Properties

Comparer (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Count (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Keys (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Values (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clone | The clone.
ContainsKey (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ContainsValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLayersDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadLayersDictionary Constructor

Initializes a new instance of the CadLayersDictionary class.

public CadLayersDictionary();

See Also

CadLayersDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadLayersDictionary Methods

The methods of the CadLayersDictionary class are listed below. For a complete list of CadLayersDictionary class members, see the CadLayersDictionary Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clone | The clone.
ContainsKey (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ContainsValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLayersDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadLayersDictionary.Clone Method

The clone.

public object Clone();

Return Value

The Object.

Implements

ICloneable.Clone

See Also

CadLayersDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadLayoutDictionary Class

Collection of cad layouts

For a list of all members of this type, see CadLayoutDictionary Members.

System.Object
System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadObjects.CadLayout, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]
Aspose.Imaging.FileFormats.Cad.CadLayoutDictionary

public class CadLayoutDictionary : Dictionary`2, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadLayoutDictionary Members | Aspose.Imaging.FileFormats.Cad Namespace


CadLayoutDictionary Members

CadLayoutDictionary overview

Public Instance Constructors

CadLayoutDictionary Constructor Initializes a new instance of the CadLayoutDictionary class.

Public Instance Properties

Comparer (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Count (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Keys (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Values (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clone | The clone.
ContainsKey (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ContainsValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLayoutDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadLayoutDictionary Constructor

Initializes a new instance of the CadLayoutDictionary class.

public CadLayoutDictionary();

See Also

CadLayoutDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadLayoutDictionary Methods

The methods of the CadLayoutDictionary class are listed below. For a complete list of CadLayoutDictionary class members, see the CadLayoutDictionary Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clone | The clone.
ContainsKey (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ContainsValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLayoutDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadLayoutDictionary.Clone Method

The clone.

public object Clone();

Return Value

The Object.

Implements

ICloneable.Clone

See Also

CadLayoutDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadLineTypesDictionary Class

Represents dictionary with types of lines.

For a list of all members of this type, see CadLineTypesDictionary Members.

System.Object
System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadLineTypeTableObject, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]
Aspose.Imaging.FileFormats.Cad.CadLineTypesDictionary

public class CadLineTypesDictionary : Dictionary`2, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadLineTypesDictionary Members | Aspose.Imaging.FileFormats.Cad Namespace


CadLineTypesDictionary Members

CadLineTypesDictionary overview

Public Instance Constructors

CadLineTypesDictionary Constructor Initializes a new instance of the CadLineTypesDictionary class.

Public Instance Properties

Comparer (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Count (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Keys (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Values (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clone | Creates the clone of an object.
ContainsKey (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ContainsValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLineTypesDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadLineTypesDictionary Constructor

Initializes a new instance of the CadLineTypesDictionary class.

public CadLineTypesDictionary();

See Also

CadLineTypesDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadLineTypesDictionary Methods

The methods of the CadLineTypesDictionary class are listed below. For a complete list of CadLineTypesDictionary class members, see the CadLineTypesDictionary Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clone | Creates the clone of an object.
ContainsKey (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ContainsValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLineTypesDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadLineTypesDictionary.Clone Method

Creates the clone of an object.

public object Clone();

Return Value

The Object.

Implements

ICloneable.Clone

See Also

CadLineTypesDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadStylesDictionary Class

Dictionary of Cad styles

For a list of all members of this type, see CadStylesDictionary Members.

System.Object
System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadStyleTableObject, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]
Aspose.Imaging.FileFormats.Cad.CadStylesDictionary

public class CadStylesDictionary : Dictionary`2, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadStylesDictionary Members | Aspose.Imaging.FileFormats.Cad Namespace


CadStylesDictionary Members

CadStylesDictionary overview

Public Instance Constructors

CadStylesDictionary Constructor Initializes a new instance of the CadStylesDictionary class.

Public Instance Properties

Comparer (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Count (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Keys (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])
Values (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clone | The clone.
ContainsKey (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ContainsValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadStylesDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadStylesDictionary Constructor

Initializes a new instance of the CadStylesDictionary class.

public CadStylesDictionary();

See Also

CadStylesDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadStylesDictionary Methods

The methods of the CadStylesDictionary class are listed below. For a complete list of CadStylesDictionary class members, see the CadStylesDictionary Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Clone | The clone.
ContainsKey (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ContainsValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
GetType (inherited from Object) | Gets the Type of the current instance.
OnDeserialization (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue (inherited from 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadStylesDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


CadStylesDictionary.Clone Method

The clone.

public object Clone();

Return Value

The Object.

Implements

ICloneable.Clone

See Also

CadStylesDictionary Class | Aspose.Imaging.FileFormats.Cad Namespace


ScaleType Enumeration

Represents possible modes for automatic scale of an image.

public enum ScaleType

Members

Member Name | Description | Value
ShrinkToFit | Automatically shrink image to fit on canvas. | 0
GrowToFit | Automatically increase image to fit on canvas. | 1
None | Do not use automatic scaling. | 2

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad Namespace


Aspose.Imaging.FileFormats.Cad.CadConsts

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace

Namespace hierarchy

Classes

Class | Description
CadCommon | General constant values for Cad file format.
CadSubClassName | Cad subclasses names
CadTableNames | The Cad table names.

Enumerations

Enumeration | Description
CadAcadVersion | Autocad version enum
CadAttachmentPoint | The Cad attachment point.
CadAttachmentType | Cad attachment point type
CadBoundaryPathTypeFlag | The boundary path type flag.
CadDimensionType | Cad Dimension type enum
CadDrawingDirection | The Cad drawing direction.
CadEntityCoordinates | The Cad entity coordinates.
CadEntitySpaceMode | The Cad entity space mode.
CadEntityTypeName | Contains Entity names
CadFillSetting | The Cad fill setting.
CadHatchBoundryType | Polyline type hatch
CadHeaderAttribute | Contains Header Variable names
CadHelixLimitation | The Cad helix limitation.
CadHorizontalDirection | The Cad horizontal direcrtion.
CadIntegralParamType | The Cad integral param type.
CadLayoutControlFlag | Flag to control. CadLayout
CadLayoutUcsOrthographicType | Orthographic type of UCS. CadLayout
CadLineSpacing | The Cad line spacing.
CadLineSpacingType | Cad Line spacing enum
CadObjectTypeName | Contains Object names
CadOrdinate | Cad Ordinate position
CadParameterType | Type of parsing parameters
CadPlotLayoutFlag | Plot layout flag. CadPlotSettings
CadPlotPaperUnits | Plot paper units. CadPlotSettings
CadPlotRotation | Plot rotation. CadPlotSettings
CadPlotStandardScaleType | Standard scale type. CadPlotSettings
CadPlotType | Plot type (portion of paper space to output to the media). CadPlotSettings
CadSectionType | Contains Section type
CadShadePlotMode | ShadePlot mode. CadPlotSettings
CadShadePlotResolutionLevel | ShadePlot resolution level. CadPlotSettings
CadShadowMode | Shadow enumeration
CadTableSymbols | Contains TABLE Types


CadAcadVersion Enumeration

Autocad version enum

public enum CadAcadVersion

Members

Member Name | Description | Value
NONE | Value for non-versioned | 0
AC1006 | Value the AutoCAD drawing database R10 version number string marker | 1
AC1009 | Value the AutoCAD drawing database R11 and R12 version number string marker | 2
AC1012 | Value the AutoCAD drawing database R13 version number string marker | 3
AC1014 | Value the AutoCAD drawing database R14 version number string marker | 4
AC1015 | Value the AutoCAD drawing database AutoCAD 2000 version number string marker | 5
AC1018 | Value the AutoCAD drawing database AutoCAD 2004 version number string marker | 6
AC1021 | Value the AutoCAD drawing database AutoCAD 2007 version number string marker | 7
AC1024 | Value the AutoCAD drawing database AutoCAD 2010 version number string marker | 8

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadAttachmentPoint Enumeration

The Cad attachment point.

public enum CadAttachmentPoint

Members

Member Name | Description | Value
TopLeft | Top left attachment point. | 1
TopCenter | Top center attachment point. | 2
TopRight | Top right attachment point. | 3
MiddleLeft | Middle left attachment point. | 4
MiddleCenter | Middle center attachment point. | 5
MiddleRight | Middle right attachment point. | 6
BottomLeft | Bottom left attachment point. | 7
BottomCenter | Bottom center attachment point. | 8
BottomRight | Bottom right attachment point. | 9

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadAttachmentType Enumeration

Cad attachment point type

public enum CadAttachmentType

Members

Member Name | Description | Value
TopLeft | The top left | 1
TopCenter | The top center | 2
TopRight | The top right | 3
MiddleLeft | The middle left | 4
MiddleCenter | The middle center | 5
MiddleRight | The middle right | 6
BottomLeft | The bottom left | 7
BottomCenter | The bottom center | 8
BottomRight | The bottom right | 9

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadBoundaryPathTypeFlag Enumeration

The boundary path type flag.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum CadBoundaryPathTypeFlag

Members

Member Name | Description | Value
Default | Default boundary type. | 0
External | External boundary type. | 1
Polyline | Polyline boundary type. | 2
Derived | Derived boundary type. | 4
Textbox | Textbox boundary type. | 8
Outermost | Outermost boundary type. | 16

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon Class

General constant values for Cad file format.

For a list of all members of this type, see CadCommon Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadConsts.CadCommon

public abstract sealed class CadCommon

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadCommon Members | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon Members

CadCommon overview

Public Static Fields

DEFAULT_TEXT_STYLE | The DEFAULT TEXT STYLE const
Divider | Begin section marker
EndBlock | The end block
EndSection | End Section string marker
EndTable | The end table marker
Eof | Variable namning for EOF
HelperSymbol | Variable namning prefix for parse
SectionTitle | Begin Entity marker
STANDARD_STYLE | The standard style.
StartSection | Start section string marker
SubclassMarker | Variable namning prefix for parse
VarNameMarker | Begin header variable description
VarPrefix | Header variable prefix

Public Static Properties

ByLayer Gets the by layer.

Public Static Methods

GetTypeName Gets the name of the enum variable type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon Fields

The fields of the CadCommon class are listed below. For a complete list of CadCommon class members, see the CadCommon Members topic.

Public Static Fields

DEFAULT_TEXT_STYLE | The DEFAULT TEXT STYLE const
Divider | Begin section marker
EndBlock | The end block
EndSection | End Section string marker
EndTable | The end table marker
Eof | Variable namning for EOF
HelperSymbol | Variable namning prefix for parse
SectionTitle | Begin Entity marker
STANDARD_STYLE | The standard style.
StartSection | Start section string marker
SubclassMarker | Variable namning prefix for parse
VarNameMarker | Begin header variable description
VarPrefix | Header variable prefix

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.DEFAULT_TEXT_STYLE Field

The DEFAULT TEXT STYLE const

public const string DEFAULT_TEXT_STYLE = "STANDARD";

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.Divider Field

Begin section marker

public const string Divider = "0";

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.EndBlock Field

The end block

public const string EndBlock = "ENDBLK";

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.EndSection Field

End Section string marker

public const string EndSection = "ENDSEC";

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.EndTable Field

The end table marker

public const string EndTable = "ENDTAB";

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.Eof Field

Variable namning for EOF

public const string Eof = "EOF";

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.HelperSymbol Field

Variable namning prefix for parse

public const string HelperSymbol = "_";

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.SectionTitle Field

Begin Entity marker

public const string SectionTitle = "2";

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.STANDARD_STYLE Field

The standard style.

public static string STANDARD_STYLE;

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.StartSection Field

Start section string marker

public const string StartSection = "SECTION";

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.SubclassMarker Field

Variable namning prefix for parse

public const string SubclassMarker = "100";

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.VarNameMarker Field

Begin header variable description

public const string VarNameMarker = "9";

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.VarPrefix Field

Header variable prefix

public const string VarPrefix = "$";

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon Properties

The properties of the CadCommon class are listed below. For a complete list of CadCommon class members, see the CadCommon Members topic.

Public Static Properties

ByLayer Gets the by layer.

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


ByLayer Property

Aspose.Imaging Documentation

CadCommon.ByLayer Property

Gets the by layer.

public static string ByLayer {get;}

Property Value

The by layer.

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon Methods

The methods of the CadCommon class are listed below. For a complete list of CadCommon class members, see the CadCommon Members topic.

Public Static Methods

GetTypeName Gets the name of the enum variable type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadCommon.GetTypeName Method

Gets the name of the enum variable type.

public static string GetTypeName(
object enumObject,
string frontAdditive
);

Parameters

enumObject
Name of the enum object.
frontAdditive
string added to the front.

Return Value

string name of the enum variable type

See Also

CadCommon Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadDimensionType Enumeration

Cad Dimension type enum

public enum CadDimensionType

Members

Member Name | Description | Value
Rotated | The rotated dimension type | 0
Aligned | The aligned dimension type | 1
Angular | The angular dimension type | 2
Diameter | The diameter dimension type | 3
Radius | The radius dimension type | 4
Angular3Point | The angular3 point dimension type | 5
Ordinate | The ordinate dimension type | 6
Block | The block dimension type | 32

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadDrawingDirection Enumeration

The Cad drawing direction.

public enum CadDrawingDirection

Members

Member Name | Description | Value
LeftToRight | The left to right. | 1
TopToBottom | The top to bottom. | 3
ByStyle | The by style. | 5

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadEntityCoordinates Enumeration

The Cad entity coordinates.

public enum CadEntityCoordinates

Members

Member Name | Description | Value
Cad10 | The Cad 10. | 10
Cad11 | The Cad 11. | 11
Cad12 | The Cad 12. | 12
Cad13 | The Cad 13. | 13
Cad14 | The Cad 14. | 14
Cad15 | The Cad 15. | 15
Cad16 | The Cad 16. | 16
Cad17 | The Cad 17. | 17
Cad18 | The Cad 18. | 18
Cad210 | The Cad 210. | 210

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadEntitySpaceMode Enumeration

The Cad entity space mode.

public enum CadEntitySpaceMode

Members

Member Name | Description | Value
ModelSpace | The model space. | 0
PapaerSpace | The papaer space. | 1

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadEntityTypeName Enumeration

Contains Entity names

public enum CadEntityTypeName

Members

Member Name | Description | Value
NONE | NONE - default type | 0
FACE3D | 3DFACE entity | 1
SOLID3D | 3DSOLID entity | 2
ACAD_PROXY_ENTITY | ACAD_PROXY_ENTITY entity | 3
ARC | ARC entity | 4
ATTDEF | ATTDEF entity | 5
ATTRIB | ATTRIB entity | 6
BODY | BODY entity | 7
DIMENSION | DIMENSION entity | 8
ELLIPSE | ELLIPSE entity | 9
HATCH | HATCH entity | 10
HELIX | HELIX entity | 11
HEADER | HEADER entity | 12
IMAGE | IMAGE entity | 13
INSERT | INSERT entity | 14
CadCalloutLine | Callout line entity | 15
CadCalloutData | Callout context data entity | 16
LEADER | Callout LEADER entity | 17
LIGHT | LIGHT entity | 18
LWPOLYLINE | LWPOLYLINE entity | 19
MESH | MESH entity | 20
MLINE | MLINE entity | 21
CadCallOutStyle | MLEADERSTYLE entity | 22
MLEADER | MLEADER entity | 23
MLEADERSTYLE | MLEADERSTYLE entity | 24
MULTILEADER | MULTILEADER entity | 25
MTEXT | MTEXT entity | 26
OLEFRAME | OLEFRAME entity | 27
OLE2FRAME | OLE@FRAME entity | 28
POINT | POINT entity | 29
POLYLINE | POLYLINE entity | 30
RAY | RAY entity | 31
REGION | REGION entity | 32
SECTION | SECTION entity | 33
SEQEND | SEQEND entity | 34
SHAPE | SHAPE entity | 35
SOLID | SOLID entity | 36
SPLINE | SPLINE entity | 37
SUN | SUN entity | 38
SURFACE | SURFACE entity | 39
ACAD_TABLE | TABLE entity | 40
TEXT | TEXT entity | 41
UNDERLAY | UNDERLAY entity | 42
PDFUNDERLAY | PDFUNDERLAY entity | 43
DWFUNDERLAY | DWFUNDERLAY entity | 44
DGNUNDERLAY | DGNUNDERLAY entity | 45
VERTEX | VERTEX entity | 46
VIEWPORT | VIEWPORT entity | 47
WIPEOUT | WIPEOUT entity | 48
LINE | The line entity | 49
XLINE | The Xline entity | 50
CIRCLE | The circle entity | 51
TRACE | The trace entity | 52
TOLERANCE | The tolerance entity | 53

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadFillSetting Enumeration

The Cad fill setting.

public enum CadFillSetting

Members

Member Name | Description | Value
FillOff | The fill off. | 0
UseBackgroundColor | The use background color. | 1
UseWindowColor | The use window color. | 2

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadHatchBoundryType Enumeration

Polyline type hatch

public enum CadHatchBoundryType

Members

Member Name | Description | Value
Line | The line boundary type | 1
Circle | The circle boundary type | 2
Ellipse | The ellipse boundary type | 3
Spline | The spline boundary type | 4

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadHeaderAttribute Enumeration

Contains Header Variable names

public enum CadHeaderAttribute

Members

Member Name | Description | Value
NONE | Default attrbute | 0
ACADVER | The acad version. | 1
ACADMAINTVER | The acadmaintver. | 2
DWGCODEPAGE | The dwgcodepage. | 3
DRAGMODE | The Dragmode. | 4
OSMODE | The Osmode. | 5
BLIPMODE | The Blipmode. | 6
COORDS | The Coords. | 7
ATTDIA | The Attdia. | 8
ATTREQ | The Attreq. | 9
HANDLING | The Handling. | 10
LASTSAVEDBY | The lastsavedby. | 11
CUSTOMPROPERTYTAG | The custompropertytag | 12
CUSTOMPROPERTY | The customproperty | 13
INSBASE | The insbase. | 14
EXTMIN | The extmin. | 15
EXTMAX | The extmax. | 16
LIMMIN | The limmin. | 17
LIMMAX | The limmax. | 18
ORTHOMODE | The orthomode. | 19
REGENMODE | The regenmode. | 20
FILLMODE | The fillmode. | 21
QTEXTMODE | The qtextmode. | 22
MIRRTEXT | The mirrtext. | 23
LTSCALE | The ltscale. | 24
ATTMODE | The attmode. | 25
TEXTSIZE | The textsize. | 26
TRACEWID | The tracewid. | 27
TEXTSTYLE | The textstyle. | 28
CLAYER | The clayer. | 29
CELTYPE | The celtype. | 30
CECOLOR | The cecolor. | 31
CELTSCALE | The celtscale. | 32
DISPSILH | The dispsilh. | 33
DIMSCALE | The dimscale. | 34
DIMASZ | The dimasz. | 35
DIMEXO | The dimexo. | 36
DIMDLI | The dimdli. | 37
DIMRND | The dimrnd. | 38
DIMDLE | The dimdle. | 39
DIMEXE | The dimexe. | 40
DIMTP | The dimtp. | 41
DIMTM | The dimtm. | 42
DIMTXT | The dimtxt. | 43
DIMCEN | The dimcen. | 44
DIMTSZ | The dimtsz. | 45
DIMTOL | The dimtol. | 46
DIMLIM | The dimlim. | 47
DIMTIH | The dimtih. | 48
DIMTOH | The dimtoh. | 49
DIMSE1 | The dims e 1. | 50
DIMSE2 | The dims e 2. | 51
DIMTAD | The dimtad. | 52
DIMZIN | The dimzin. | 53
DIMBLK | The dimblk. | 54
DIMASO | The dimaso. | 55
DIMSHO | The dimsho. | 56
DIMPOST | The dimpost. | 57
DIMAPOST | The dimapost. | 58
DIMALT | The dimalt. | 59
DIMALTD | The dimaltd. | 60
DIMALTF | The dimaltf. | 61
DIMLFAC | The dimlfac. | 62
DIMTOFL | The dimtofl. | 63
DIMTVP | The dimtvp. | 64
DIMTIX | The dimtix. | 65
DIMSOXD | The dimsoxd. | 66
DIMSAH | The dimsah. | 67
DIMBLK1 | The dimbl k 1. | 68
DIMBLK2 | The dimbl k 2. | 69
DIMSTYLE | The dimstyle. | 70
DIMCLRD | The dimclrd. | 71
DIMCLRE | The dimclre. | 72
DIMCLRT | The dimclrt. | 73
DIMTFAC | The dimtfac. | 74
DIMGAP | The dimgap. | 75
DIMJUST | The dimjust. | 76
DIMSD1 | The dims d 1. | 77
DIMSD2 | The dims d 2. | 78
DIMTOLJ | The dimtolj. | 79
DIMTZIN | The dimtzin. | 80
DIMALTZ | The dimaltz. | 81
DIMALTTZ | The dimalttz. | 82
DIMUPT | The dimupt. | 83
DIMDEC | The dimdec. | 84
DIMTDEC | The dimtdec. | 85
DIMALTU | The dimaltu. | 86
DIMALTTD | The dimalttd. | 87
DIMTXSTY | The dimtxsty. | 88
DIMAUNIT | The dimaunit. | 89
DIMADEC | The dimadec. | 90
DIMALTRND | The dimaltrnd. | 91
DIMAZIN | The dimazin. | 92
DIMDSEP | The dimdsep. | 93
DIMATFIT | The dimatfit. | 94
DIMFRAC | The dimfrac. | 95
DIMLDRBLK | The dimldrblk. | 96
DIMLUNIT | The dimlunit. | 97
DIMLWD | The dimlwd. | 98
DIMLWE | The dimlwe. | 99
DIMTMOVE | The dimtmove. | 100
DIMFXL | The dimfxl. | 101
DIMFXLON | The dimfxlon. | 102
DIMJOGANG | The dimjogang. | 103
DIMTFILL | The dimtfill. | 104
DIMTFILLCLR | The dimtfillclr. | 105
DIMARCSYM | The dimarcsym. | 106
DIMLTYPE | The dimltype. | 107
DIMLTEX1 | The dimlte x 1. | 108
DIMLTEX2 | The dimlte x 2. | 109
DIMTXTDIRECTION | The dimtxtdirection. | 110
LUNITS | The lunits. | 111
LUPREC | The luprec. | 112
SKETCHINC | The sketchinc. | 113
FILLETRAD | The filletrad. | 114
AUNITS | The aunits. | 115
AUPREC | The auprec. | 116
MENU | The menu attribute. | 117
ELEVATION | The elevation. | 118
PELEVATION | The pelevation. | 119
THICKNESS | The thickness. | 120
LIMCHECK | The limcheck. | 121
CHAMFERA | The chamfera. | 122
CHAMFERB | The chamferb. | 123
CHAMFERC | The chamferc. | 124
CHAMFERD | The chamferd. | 125
SKPOLY | The skpoly. | 126
TDCREATE | The tdcreate. | 127
TDUCREATE | The tducreate. | 128
TDUPDATE | The tdupdate. | 129
TDUUPDATE | The tduupdate. | 130
TDINDWG | The tdindwg. | 131
TDUSRTIMER | The tdusrtimer. | 132
USRTIMER | The usrtimer. | 133
ANGBASE | The angbase. | 134
ANGDIR | The angdir. | 135
PDMODE | The pdmode. | 136
PDSIZE | The pdsize. | 137
PLINEWID | The plinewid. | 138
SPLFRAME | The splframe. | 139
SPLINETYPE | The splinetype. | 140
SPLINESEGS | The splinesegs. | 141
HANDSEED | The handseed. | 142
SURFTAB1 | The surfta b 1. | 143
SURFTAB2 | The surfta b 2. | 144
SURFTYPE | The surftype. | 145
SURFU | The surfu. | 146
SURFV | The surfv. | 147
UCSBASE | The ucsbase. | 148
UCSNAME | The ucsname. | 149
UCSORG | The ucsorg. | 150
UCSXDIR | The ucsxdir. | 151
UCSYDIR | The ucsydir. | 152
UCSORTHOREF | The ucsorthoref. | 153
UCSORTHOVIEW | The ucsorthoview. | 154
UCSORGTOP | The ucsorgtop. | 155
UCSORGBOTTOM | The ucsorgbottom. | 156
UCSORGLEFT | The ucsorgleft. | 157
UCSORGRIGHT | The ucsorgright. | 158
UCSORGFRONT | The ucsorgfront. | 159
UCSORGBACK | The ucsorgback. | 160
PUCSBASE | The pucsbase. | 161
PUCSNAME | The pucsname. | 162
PUCSORG | The pucsorg. | 163
PUCSXDIR | The pucsxdir. | 164
PUCSYDIR | The pucsydir. | 165
PUCSORTHOREF | The pucsorthoref. | 166
PUCSORTHOVIEW | The pucsorthoview. | 167
PUCSORGTOP | The pucsorgtop. | 168
PUCSORGBOTTOM | The pucsorgbottom. | 169
PUCSORGLEFT | The pucsorgleft. | 170
PUCSORGRIGHT | The pucsorgright. | 171
PUCSORGFRONT | The pucsorgfront. | 172
PUCSORGBACK | The pucsorgback. | 173
USERI1 | The user i 1. | 174
USERI2 | The user i 2. | 175
USERI3 | The user i 3. | 176
USERI4 | The user i 4. | 177
USERI5 | The user i 5. | 178
USERR1 | The user r 1. | 179
USERR2 | The user r 2. | 180
USERR3 | The user r 3. | 181
USERR4 | The user r 4. | 182
USERR5 | The user r 5. | 183
WORLDVIEW | The worldview. | 184
SHADEDGE | The shadedge. | 185
SHADEDIF | The shadedif. | 186
TILEMODE | The tilemode. | 187
MAXACTVP | The maxactvp. | 188
PINSBASE | The pinsbase. | 189
PLIMCHECK | The plimcheck. | 190
PEXTMIN | The pextmin. | 191
PEXTMAX | The pextmax. | 192
PLIMMIN | The plimmin. | 193
PLIMMAX | The plimmax. | 194
UNITMODE | The unitmode. | 195
VISRETAIN | The visretain. | 196
PLINEGEN | The plinegen. | 197
PSLTSCALE | The psltscale. | 198
TREEDEPTH | The treedepth. | 199
CMLSTYLE | The cmlstyle. | 200
CMLJUST | The cmljust. | 201
CMLSCALE | The cmlscale. | 202
PROXYGRAPHICS | The proxygraphics. | 203
MEASUREMENT | The measurement. | 204
CELWEIGHT | The celweight. | 205
ENDCAPS | The endcaps. | 206
JOINSTYLE | The joinstyle. | 207
LWDISPLAY | The lwdisplay. | 208
INSUNITS | The insunits. | 209
HYPERLINKBASE | The hyperlinkbase. | 210
STYLESHEET | The stylesheet. | 211
XEDIT | The xedit. | 212
CEPSNTYPE | The cepsntype. | 213
PSTYLEMODE | The pstylemode. | 214
FINGERPRINTGUID | The fingerprintguid. | 215
VERSIONGUID | The versionguid. | 216
EXTNAMES | The extnames. | 217
PSVPSCALE | The psvpscale. | 218
OLESTARTUP | The olestartup. | 219
SORTENTS | The sortents. | 220
INDEXCTL | The indexctl. | 221
HIDETEXT | The hidetext. | 222
XCLIPFRAME | The xclipframe. | 223
HALOGAP | The halogap. | 224
OBSCOLOR | The obscolor. | 225
OBSLTYPE | The obsltype. | 226
INTERSECTIONDISPLAY | The intersectiondisplay. | 227
INTERSECTIONCOLOR | The intersectioncolor. | 228
DIMASSOC | The dimassoc. | 229
PROJECTNAME | The projectname. | 230
CAMERADISPLAY | The cameradisplay. | 231
LENSLENGTH | The lenslength. | 232
CAMERAHEIGHT | The cameraheight. | 233
STEPSPERSEC | The stepspersec. | 234
STEPSIZE | The stepsize. | 235
_3DDWFPREC | The _3 ddwfprec. | 236
PSOLWIDTH | The psolwidth. | 237
PSOLHEIGHT | The psolheight. | 238
LOFTANG1 | The loftan g 1. | 239
LOFTANG2 | The loftan g 2. | 240
LOFTMAG1 | The loftma g 1. | 241
LOFTMAG2 | The loftma g 2. | 242
LOFTPARAM | The loftparam. | 243
LOFTNORMALS | The loftnormals. | 244
LATITUDE | The latitude. | 245
LONGITUDE | The longitude. | 246
NORTHDIRECTION | The northdirection. | 247
TIMEZONE | The timezone. | 248
LIGHTGLYPHDISPLAY | The lightglyphdisplay. | 249
TILEMODELIGHTSYNCH | The tilemodelightsynch. | 250
CMATERIAL | The cmaterial. | 251
SOLIDHIST | The solidhist. | 252
SHOWHIST | The showhist. | 253
DWFFRAME | The dwfframe. | 254
DGNFRAME | The dgnframe. | 255
REALWORLDSCALE | The realworldscale. | 256
INTERFERECOLOR | The interferecolor. | 257
INTERFEREOBJVS | The interfereobjvs. | 258
INTERFEREVPVS | The interferevpvs. | 259
CSHADOW | The cshadow. | 260
SHADOWPLANELOCATION | The shadowplanelocation. | 261
WFPREC3DD | The wfpre c 3 dd. | 262
FPREC3DD | The fpre c 3 dd. | 263
DIMUNIT | Dim unit value. | 264

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadHelixLimitation Enumeration

The Cad helix limitation.

public enum CadHelixLimitation

Members

Member Name | Description | Value
TurnHeight | The turn height. | 0
TurnCount | The turn count. | 1
Height | The height. | 2

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadHorizontalDirection Enumeration

The Cad horizontal direcrtion.

public enum CadHorizontalDirection

Members

Member Name | Description | Value
Left | The left direction. | 0
Right | The right direction. | 1

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadIntegralParamType Enumeration

The Cad integral param type.

public enum CadIntegralParamType

Members

Member Name | Description | Value
UknkownParam | The uknkown param. | 0
BoolParam | The bool param. | 1
DoubleParam | The double param. | 2
IntParam | The int param. | 3
ShortParam | The short param. | 4
StringParam | The string param. | 5
LongParam | The long param | 6

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadLayoutControlFlag Enumeration

Flag to control. CadLayout

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum CadLayoutControlFlag

Members

Member Name | Description | Value
PsltScale | Indicates the PSLTSCALE value for this layout when this layout is current | 1
LimCheck | Indicates the LIMCHECK value for this layout when this layout is current | 2

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadLayoutUcsOrthographicType Enumeration

Orthographic type of UCS. CadLayout

public enum CadLayoutUcsOrthographicType

Members

Member Name | Description | Value
IsNotOrthographic | Is not orthographic | 0
Top | Orthographic is top | 1
Bottom | Orthographic is bottom | 2
Front | Orthographic is front | 3
Back | Orthographic is back | 4
Left | Orthographic is left | 5
Right | Orthographic is right | 6

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadLineSpacing Enumeration

The Cad line spacing.

public enum CadLineSpacing

Members

Member Name | Description | Value
AtLeast | The at least. | 1
Exact | The exact. | 2

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadLineSpacingType Enumeration

Cad Line spacing enum

public enum CadLineSpacingType

Members

Member Name | Description | Value
AtLeast | At least (taller characters will override) | 1
Exact | The exact (taller characters will not override) | 2

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadObjectTypeName Enumeration

Contains Object names

public enum CadObjectTypeName

Members

Member Name | Description | Value
NONE | NONE - default type | 0
ACAD_PROXY_OBJECT | ACAD_PROXY_OBJECT object | 1
ACDBDICTIONARYWDFLT | ACDBDICTIONARYWDFLT object | 2
ACDBPLACEHOLDER | ACDBPLACEHOLDER object | 3
DATATABLE | DATATABLE object | 4
DICTIONARY | DICTIONARY object | 5
DICTIONARYVAR | DICTIONARYVAR object | 6
DIMASSOC | DIMASSOC object | 7
FIELD | FIELD object | 8
GEODATA | GEODATA object | 9
GROUP | GROUP object | 10
IDBUFFER | IDBUFFER object | 11
IMAGEDEF | IMAGEDEF object | 12
IMAGEDEF_REACTOR | IMAGEDEF_REACTOR object | 13
LAYER_INDEX | LAYER_INDEX object | 14
LAYER_FILTER | LAYER_FILTER object | 15
LAYOUT | LAYOUT object | 16
LIGHTLIST | LIGHTLIST object | 17
MATERIAL | MATERIAL object | 18
MLINESTYLE | MLINESTYLE object | 19
OBJECT_PTR | OBJECT_PTR object | 20
PLOTSETTINGS | PLOTSETTINGS object | 21
RASTERVARIABLES | RASTERVARIABLES object | 22
RENDERENVIRONMENT | RENDERENVIRONMENT object | 23
MENTALRAYRENDERSETTINGS | MENTALRAYRENDERSETTINGS object | 24
SECTIONMANAGER | SECTIONMANAGER object | 25
SECTION | SECTIONSETTINGS object | 26
SPATIAL_INDEX | SPATIAL_INDEX object | 27
SPATIAL_FILTER | SPATIAL_FILTER object | 28
SORTENTSTABLE | SORTENTSTABLE object | 29
TABLESTYLE | TABLESTYLE object | 30
UNDERLAYDEFINITION | UNDERLAYDEFINITION object | 31
VISUALSTYLE | VISUALSTYLE object | 32
VBA_PROJECT | VBA_PROJECT object | 33
WIPEOUTVARIABLES | WIPEOUTVARIABLES object | 34
XRECORD | XRECORD object | 35

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadOrdinate Enumeration

Cad Ordinate position

public enum CadOrdinate

Members

Member Name | Description | Value
Yordinate | The y ordinate | 0
Xordinate | The x ordinate | 1

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadParameterType Enumeration

Type of parsing parameters

public enum CadParameterType

Members

Member Name | Description | Value
MustHave | The must have. | 0
Optional | The optional. | 1

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadPlotLayoutFlag Enumeration

Plot layout flag. CadPlotSettings

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum CadPlotLayoutFlag

Members

Member Name | Description | Value
PlotViewportBorders | The plot viewport borders | 1
ShowPlotStyles | The show plot styles | 2
PlotCentered | The plot centered | 4
PlotHidden | The plot hidden | 8
UseStandardScale | The use standard scale | 16
PlotPlotStyles | The plot plot styles | 32
ScaleLineWeights | The scale line weights | 64
PrintLineWeights | The print line weights | 128
DrawViewportsFirst | The draw viewports first | 512
ModelType | The model type | 1024
UpdatePaper | The update paper | 2048
ZoomToPaperOnUpdate | The zoom to paper on update | 4096
Initializing | The initializing | 8192
PrevPlotInit | The previous plot initialize | 16384

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadPlotPaperUnits Enumeration

Plot paper units. CadPlotSettings

public enum CadPlotPaperUnits

Members

Member Name | Description | Value
PlotInInches | The plot in inches | 0
PlotInMillimeters | The plot in millimeters | 1
PlotInPixels | The plot in pixels | 2

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadPlotRotation Enumeration

Plot rotation. CadPlotSettings

public enum CadPlotRotation

Members

Member Name | Description | Value
NoRotation | The no rotation | 0
Counterclockwise90Degrees | The counterclockwise90 degrees | 1
UpsideDown | The upside down | 2
Clockwise90Degrees | The clockwise90 degrees | 3

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadPlotStandardScaleType Enumeration

Standard scale type. CadPlotSettings

public enum CadPlotStandardScaleType

Members

Member Name | Description | Value
ScaledToFit | The scaled To fit | 0
Scale1To128Sec | Scale is 1/128"=1' | 1
Scale1To64Sec | Scale is 1/64"=1' | 2
Scale1To32Sec | Scale is 1/32"=1' | 3
Scale1To16Sec | Scale is 1/16"=1' | 4
Scale3To32Sec | Scale is 3/32"=1' | 5
Scale1To8Sec | Scale is 1/8"=1' | 6
Scale3To16Sec | Scale is 3/16"=1' | 7
Scale1To4Sec | Scale is 1/4"=1' | 8
Scale3To8Sec | Scale is 3/8"=1' | 9
Scale1To2Sec | Scale is 1/2"=1' | 10
Scale3To4Sec | Scale is 3/4"=1' | 11
Scale1Sec | Scale is 1"=1' | 12
Scale3Sec | Scale is 3"=1' | 13
Scale6Sec | Scale is 6"=1' | 14
Scale1Min | Scale is 1'=1' | 15
Scale1To1 | Scale is 1:1 | 16
Scale1To2 | Scale is 1:2 | 17
Scale1To4 | Scale is 1:4 | 18
Scale1To8 | Scale is 1:8 | 19
Scale1To10 | Scale is 1:10 | 20
Scale1To16 | Scale is 1:16 | 21
Scale1To20 | Scale is 1:20 | 22
Scale1To30 | Scale is 1:30 | 23
Scale1To40 | Scale is 1:40 | 24
Scale1To50 | Scale is 1:50 | 25
Scale1To100 | Scale is 1:100 | 26
Scale2To1 | Scale is 2:1 | 27
Scale4To1 | Scale is 4:1 | 28
Scale8To1 | Scale is 8:1 | 29
Scale10To1 | Scale is 10:1 | 30
Scale100To1 | Scale is 100:1 | 31
Scale1000To1 | Scale is 1000:1 | 32

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadPlotType Enumeration

Plot type (portion of paper space to output to the media). CadPlotSettings

public enum CadPlotType

Members

Member Name | Description | Value
NoRotation | The no rotation | 0
Counterclockwise90Degrees | The counterclockwise90 degrees | 1
UpsideDown | The upside down | 2
Clockwise90Degrees | The clockwise90 degrees | 3

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSectionType Enumeration

Contains Section type

public enum CadSectionType

Members

Member Name | Description | Value
NotSet | Section is not set - default | 0
Another | Another section | 1
HEADER | Header string marker | 2
TABLES | Tables string marker | 4
BLOCKS | Blocks string marker | 8
ENTITIES | Entities string marker | 16
CLASSES | Classes string marker | 32
OBJECTS | Objects string marker | 64
THUMBNAILIMAGE | Entities string marker | 128

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadShadePlotMode Enumeration

ShadePlot mode. CadPlotSettings

public enum CadShadePlotMode

Members

Member Name | Description | Value
AsDisplayed | As displayed | 0
Wireframe | The wireframe | 1
Hidden | The hidden | 2
Rendered | The rendered | 3

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadShadePlotResolutionLevel Enumeration

ShadePlot resolution level. CadPlotSettings

public enum CadShadePlotResolutionLevel

Members

Member Name | Description | Value
Draft | Resolution is draft | 0
Preview | Resolution is preview | 1
Normal | Resolution is normal | 2
Presentation | Resolution is presentation | 3
Maximum | Resolution is maximum | 4
Custom | Resolution is custom | 5

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadShadowMode Enumeration

Shadow enumeration

public enum CadShadowMode

Members

Member Name | Description | Value
CastAndReceiveShadow | The cast and receive shadow. | 0
CastShadow | The cast shadow. | 1
ReceiveShadow | The receive shadow. | 2
IgnoreShadow | The ignore shadow. | 3

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName Class

Cad subclasses names

For a list of all members of this type, see CadSubClassName Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadConsts.CadSubClassName

public abstract sealed class CadSubClassName

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadSubClassName Members | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName Members

CadSubClassName overview

Public Static Fields

APPTABLERECORD | The app table record class.
ARC | The arc subclass name.
ATTDEF | The attribute definition subclass name.
ATTRIB | The attribute subclass name.
BLOCK_ENTITY | The block entity subclass name.
BLOCK_RECORD | The block record subclass name.
BLOCK_REFERENCE | The block reference subclass name.
CIRCLE | The circle subclass name.
DBATTRIBUTE | The data base attribute subclass name.
DIMENSION | The dimension subclass name.
DIMENSION2LINES | The dimension between lines subclass name.
DIMENSIONALIGNED | The aligned dimension subclass name.
DIMENSIONANGULAR | The angular dimension subclass name.
DIMENSIONDIAMETRIC | The diametric dimension subclass name.
DIMENSIONLINEAR | The linear dimension subclass name.
DIMENSIONORDINATE | The ordinate dimension subclass name.
DIMENSIONRADIAL | The radial dimension subclass name.
DIMENSIONROTATED | The rotated dimension radial.
DIMSTYLE_TABLE_RECORD | The dimension style table record subclass name.
ELLIPSE | The ellipse subclass name.
ENTITY | The entity subclass name.
FACE3D | The face 3d subclass name.
HATCH | The hatch subclass name.
HELIX | The helix subclass name.
INSERT | The INSERT subclass name
LAYER_TABLE_RECORD | The layer table record subclass name
LAYOUT | The layout subclass name.
LEADER | The leader subclass name.
LINE | The line subclass name.
LSTYLE_TABLE_RECORD | The LSTYLE Table record subclass name.
LWPOLYLINE | The lwpolyline subclass name.
MESH | The mesh subclass name.
MLINE | The MLINE subclass name
MODELER_GEOM | The modeler geometry
MODELERGEOMETRY | The modeler geometry subclass name.
MTEXT | The multiline text subclass name.
MULTILEADER | The multileader subclass name.
NONE | none subclass name.
PLOTSETTINGS | The plotsettings subclass name.
POINT | The point subclass name.
POLYLINE | The polyline subclass name.
POLYLINE3D | The polyline 3d subclass name.
PROXY_ENTITY | The proxy entity subclass name.
RAY | The ray subclass name.
SECTION | The section subclass name.
SEQEND | The seqend subclass name.
SHAPE | The shape subclass name.
SOLID | The solid subclass name.
SOLID3D | The solid 3d subclass name.
SPLINE | The spline subclass name.
STYLE_TABLE_RECORD | The TEXT Style table record subclass name.
SUN | The sun subclass name.
SURFACEBASE | The surfacebase subclass name.
SURFACELOFTED | The surfacelofted subclass name.
SURFACEREVOLVED | The surfacerevolved subclass name.
SURFACESWEPT | The surfaceswept subclass name.
SURFACEXTRUDED | The surfacextruded subclass name.
TABLE_ENTITY | The table entity subclass name.
TABLE_SECTION | The table section subclass name.
TEXT | The text subclass name.
TOLERANCE | The tolerance subclass name.
TRACE | The trace subclass name.
UNDERLAY | The underlay subclass name.
VERTEX | The vertex subclass name.
VERTEX2D | The vertex 2d subclass name.
VERTEX3D | The vertex 3d subclass name.
VIEWPORT | The viewport subclass name.
WIPEOUT | The wipeout subclass name.
XLINE | The xline subclass name.
XRECORD | The xrecord subclass name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName Fields

The fields of the CadSubClassName class are listed below. For a complete list of CadSubClassName class members, see the CadSubClassName Members topic.

Public Static Fields

APPTABLERECORD | The app table record class.
ARC | The arc subclass name.
ATTDEF | The attribute definition subclass name.
ATTRIB | The attribute subclass name.
BLOCK_ENTITY | The block entity subclass name.
BLOCK_RECORD | The block record subclass name.
BLOCK_REFERENCE | The block reference subclass name.
CIRCLE | The circle subclass name.
DBATTRIBUTE | The data base attribute subclass name.
DIMENSION | The dimension subclass name.
DIMENSION2LINES | The dimension between lines subclass name.
DIMENSIONALIGNED | The aligned dimension subclass name.
DIMENSIONANGULAR | The angular dimension subclass name.
DIMENSIONDIAMETRIC | The diametric dimension subclass name.
DIMENSIONLINEAR | The linear dimension subclass name.
DIMENSIONORDINATE | The ordinate dimension subclass name.
DIMENSIONRADIAL | The radial dimension subclass name.
DIMENSIONROTATED | The rotated dimension radial.
DIMSTYLE_TABLE_RECORD | The dimension style table record subclass name.
ELLIPSE | The ellipse subclass name.
ENTITY | The entity subclass name.
FACE3D | The face 3d subclass name.
HATCH | The hatch subclass name.
HELIX | The helix subclass name.
INSERT | The INSERT subclass name
LAYER_TABLE_RECORD | The layer table record subclass name
LAYOUT | The layout subclass name.
LEADER | The leader subclass name.
LINE | The line subclass name.
LSTYLE_TABLE_RECORD | The LSTYLE Table record subclass name.
LWPOLYLINE | The lwpolyline subclass name.
MESH | The mesh subclass name.
MLINE | The MLINE subclass name
MODELER_GEOM | The modeler geometry
MODELERGEOMETRY | The modeler geometry subclass name.
MTEXT | The multiline text subclass name.
MULTILEADER | The multileader subclass name.
NONE | none subclass name.
PLOTSETTINGS | The plotsettings subclass name.
POINT | The point subclass name.
POLYLINE | The polyline subclass name.
POLYLINE3D | The polyline 3d subclass name.
PROXY_ENTITY | The proxy entity subclass name.
RAY | The ray subclass name.
SECTION | The section subclass name.
SEQEND | The seqend subclass name.
SHAPE | The shape subclass name.
SOLID | The solid subclass name.
SOLID3D | The solid 3d subclass name.
SPLINE | The spline subclass name.
STYLE_TABLE_RECORD | The TEXT Style table record subclass name.
SUN | The sun subclass name.
SURFACEBASE | The surfacebase subclass name.
SURFACELOFTED | The surfacelofted subclass name.
SURFACEREVOLVED | The surfacerevolved subclass name.
SURFACESWEPT | The surfaceswept subclass name.
SURFACEXTRUDED | The surfacextruded subclass name.
TABLE_ENTITY | The table entity subclass name.
TABLE_SECTION | The table section subclass name.
TEXT | The text subclass name.
TOLERANCE | The tolerance subclass name.
TRACE | The trace subclass name.
UNDERLAY | The underlay subclass name.
VERTEX | The vertex subclass name.
VERTEX2D | The vertex 2d subclass name.
VERTEX3D | The vertex 3d subclass name.
VIEWPORT | The viewport subclass name.
WIPEOUT | The wipeout subclass name.
XLINE | The xline subclass name.
XRECORD | The xrecord subclass name.

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.APPTABLERECORD Field

The app table record class.

public const string APPTABLERECORD = "AcDbRegAppTableRecord";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.ARC Field

The arc subclass name.

public const string ARC = "AcDbArc";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.ATTDEF Field

The attribute definition subclass name.

public const string ATTDEF = "AcDbAttributeDefinition";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.ATTRIB Field

The attribute subclass name.

public const string ATTRIB = "AcDbText";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.BLOCK_ENTITY Field

The block entity subclass name.

public const string BLOCK_ENTITY = "AcDbBlockBegin";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.BLOCK_RECORD Field

The block record subclass name.

public const string BLOCK_RECORD = "AcDbBlockTableRecord";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.BLOCK_REFERENCE Field

The block reference subclass name.

public const string BLOCK_REFERENCE = "AcDbBlockReference";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.CIRCLE Field

The circle subclass name.

public const string CIRCLE = "AcDbCircle";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.DBATTRIBUTE Field

The data base attribute subclass name.

public const string DBATTRIBUTE = "AcDbAttribute";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.DIMENSION Field

The dimension subclass name.

public const string DIMENSION = "AcDbDimension";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.DIMENSION2LINES Field

The dimension between lines subclass name.

public const string DIMENSION2LINES = "AcDb2LineAngularDimension";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.DIMENSIONALIGNED Field

The aligned dimension subclass name.

public const string DIMENSIONALIGNED = "AcDbAlignedDimension";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.DIMENSIONANGULAR Field

The angular dimension subclass name.

public const string DIMENSIONANGULAR = "AcDb3PointAngularDimension";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.DIMENSIONDIAMETRIC Field

The diametric dimension subclass name.

public const string DIMENSIONDIAMETRIC = "AcDbDiametricDimension";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.DIMENSIONLINEAR Field

The linear dimension subclass name.

public const string DIMENSIONLINEAR = "AcDbAlignedDimension";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.DIMENSIONORDINATE Field

The ordinate dimension subclass name.

public const string DIMENSIONORDINATE = "AcDbOrdinateDimension";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.DIMENSIONRADIAL Field

The radial dimension subclass name.

public const string DIMENSIONRADIAL = "AcDbRadialDimension";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.DIMENSIONROTATED Field

The rotated dimension radial.

public const string DIMENSIONROTATED = "AcDbRotatedDimension";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.DIMSTYLE_TABLE_RECORD Field

The dimension style table record subclass name.

public const string DIMSTYLE_TABLE_RECORD = "AcDbDimStyleTableRecord";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.ELLIPSE Field

The ellipse subclass name.

public const string ELLIPSE = "AcDbEllipse";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.ENTITY Field

The entity subclass name.

public const string ENTITY = "AcDbEntity";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.FACE3D Field

The face 3d subclass name.

public const string FACE3D = "AcDbFace";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.HATCH Field

The hatch subclass name.

public const string HATCH = "AcDbHatch";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.HELIX Field

The helix subclass name.

public const string HELIX = "AcDbHelix";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.INSERT Field

The INSERT subclass name

public const string INSERT = "AcDbBlockReference";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.LAYER_TABLE_RECORD Field

The layer table record subclass name

public const string LAYER_TABLE_RECORD = "AcDbLayerTableRecord";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.LAYOUT Field

The layout subclass name.

public const string LAYOUT = "AcDbLayout";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.LEADER Field

The leader subclass name.

public const string LEADER = "AcDbLeader";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.LINE Field

The line subclass name.

public const string LINE = "AcDbLine";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.LSTYLE_TABLE_RECORD Field

The LSTYLE Table record subclass name.

public const string LSTYLE_TABLE_RECORD = "AcDbLinetypeTableRecord";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.LWPOLYLINE Field

The lwpolyline subclass name.

public const string LWPOLYLINE = "AcDbPolyline";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.MESH Field

The mesh subclass name.

public const string MESH = "AcDbSubDMesh";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.MLINE Field

The MLINE subclass name

public const string MLINE = "AcDbMline";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.MODELER_GEOM Field

The modeler geometry

public const string MODELER_GEOM = "AcDbModelerGeometry";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.MODELERGEOMETRY Field

The modeler geometry subclass name.

public const string MODELERGEOMETRY = "AcDbModelerGeometry";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.MTEXT Field

The multiline text subclass name.

public const string MTEXT = "AcDbMText";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.MULTILEADER Field

The multileader subclass name.

public const string MULTILEADER = "AcDbMLeader";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.NONE Field

none subclass name.

public const string NONE = "";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.PLOTSETTINGS Field

The plotsettings subclass name.

public const string PLOTSETTINGS = "AcDbPlotSettings";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.POINT Field

The point subclass name.

public const string POINT = "AcDbPoint";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.POLYLINE Field

The polyline subclass name.

public const string POLYLINE = "AcDb2dPolyline";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.POLYLINE3D Field

The polyline 3d subclass name.

public const string POLYLINE3D = "AcDb3dPolyline";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.PROXY_ENTITY Field

The proxy entity subclass name.

public const string PROXY_ENTITY = "AcDbProxyEntity";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.RAY Field

The ray subclass name.

public const string RAY = "AcDbRay";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.SECTION Field

The section subclass name.

public const string SECTION = "AcDbSection";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.SEQEND Field

The seqend subclass name.

public const string SEQEND = "";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.SHAPE Field

The shape subclass name.

public const string SHAPE = "AcDbShape";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.SOLID Field

The solid subclass name.

public const string SOLID = "AcDbTrace";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.SOLID3D Field

The solid 3d subclass name.

public const string SOLID3D = "AcDb3dSolid";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.SPLINE Field

The spline subclass name.

public const string SPLINE = "AcDbSpline";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.STYLE_TABLE_RECORD Field

The TEXT Style table record subclass name.

public const string STYLE_TABLE_RECORD = "AcDbTextStyleTableRecord";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.SUN Field

The sun subclass name.

public const string SUN = "AcDbSun";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.SURFACEBASE Field

The surfacebase subclass name.

public const string SURFACEBASE = "AcDbSurface";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.SURFACELOFTED Field

The surfacelofted subclass name.

public const string SURFACELOFTED = "AcDbLoftedSurface";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.SURFACEREVOLVED Field

The surfacerevolved subclass name.

public const string SURFACEREVOLVED = "AcDbRevolvedSurface";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.SURFACESWEPT Field

The surfaceswept subclass name.

public const string SURFACESWEPT = "AcDbSweptSurface";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.SURFACEXTRUDED Field

The surfacextruded subclass name.

public const string SURFACEXTRUDED = "AcDbExtrudedSurface";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.TABLE_ENTITY Field

The table entity subclass name.

public const string TABLE_ENTITY = "AcDbTable";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.TABLE_SECTION Field

The table section subclass name.

public const string TABLE_SECTION = "AcDbSymbolTable";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.TEXT Field

The text subclass name.

public const string TEXT = "AcDbText";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.TOLERANCE Field

The tolerance subclass name.

public const string TOLERANCE = "AcDbFcf";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.TRACE Field

The trace subclass name.

public const string TRACE = "AcDbTrace";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.UNDERLAY Field

The underlay subclass name.

public const string UNDERLAY = "AcDbUnderlayReference";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.VERTEX Field

The vertex subclass name.

public const string VERTEX = "AcDbVertex";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.VERTEX2D Field

The vertex 2d subclass name.

public const string VERTEX2D = "AcDb2dVertex";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.VERTEX3D Field

The vertex 3d subclass name.

public const string VERTEX3D = "AcDb3dPolylineVertex";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.VIEWPORT Field

The viewport subclass name.

public const string VIEWPORT = "AcDbViewport";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.WIPEOUT Field

The wipeout subclass name.

public const string WIPEOUT = "AcDbRasterImage";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.XLINE Field

The xline subclass name.

public const string XLINE = "AcDbXline";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadSubClassName.XRECORD Field

The xrecord subclass name.

public const string XRECORD = "AcDbXrecord";

See Also

CadSubClassName Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames Class

The Cad table names.

For a list of all members of this type, see CadTableNames Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadConsts.CadTableNames

public abstract sealed class CadTableNames

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadTableNames Members | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames Members

CadTableNames overview

Public Static Fields

ApplicationIDTable | extended data application registry.
BeginBlock | Cad name string.
BeginSection | Cad name string.
BlockRecordTable | block records.
BlocksSection | blocks table name.
ClassesSection | clases table name.
Dictionary | dictionary
DimensionStyleTable | dimension styles.
EndBlock | end table code.
EndOfFile | end of file
EndSection | end secction code.
EndSequence | end of an element sequence
EndTable | end table code.
EntitiesSection | entities section.
HeaderSection | header section.
LayerTable | layers section.
LineTypeTable | line types.
ObjectsSection | objects section.
Table | Cad name string.
TablesSection | tables section name.
TextStyleTable | text styles table.
UcsTable | ucs table name.
Unknown | not defined .
ViewPortTable | view ports table.
ViewTable | views table.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames Fields

The fields of the CadTableNames class are listed below. For a complete list of CadTableNames class members, see the CadTableNames Members topic.

Public Static Fields

ApplicationIDTable | extended data application registry.
BeginBlock | Cad name string.
BeginSection | Cad name string.
BlockRecordTable | block records.
BlocksSection | blocks table name.
ClassesSection | clases table name.
Dictionary | dictionary
DimensionStyleTable | dimension styles.
EndBlock | end table code.
EndOfFile | end of file
EndSection | end secction code.
EndSequence | end of an element sequence
EndTable | end table code.
EntitiesSection | entities section.
HeaderSection | header section.
LayerTable | layers section.
LineTypeTable | line types.
ObjectsSection | objects section.
Table | Cad name string.
TablesSection | tables section name.
TextStyleTable | text styles table.
UcsTable | ucs table name.
Unknown | not defined .
ViewPortTable | view ports table.
ViewTable | views table.

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.ApplicationIDTable Field

extended data application registry.

public const string ApplicationIDTable = "APPID";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.BeginBlock Field

Cad name string.

public const string BeginBlock = "BLOCK";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.BeginSection Field

Cad name string.

public const string BeginSection = "SECTION";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.BlockRecordTable Field

block records.

public const string BlockRecordTable = "BLOCK_RECORD";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.BlocksSection Field

blocks table name.

public const string BlocksSection = "BLOCKS";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.ClassesSection Field

clases table name.

public const string ClassesSection = "CLASSES";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.Dictionary Field

dictionary

public const string Dictionary = "DICTIONARY";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.DimensionStyleTable Field

dimension styles.

public const string DimensionStyleTable = "DIMSTYLE";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.EndBlock Field

end table code.

public const string EndBlock = "ENDBLK";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.EndOfFile Field

end of file

public const string EndOfFile = "EOF";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.EndSection Field

end secction code.

public const string EndSection = "ENDSEC";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.EndSequence Field

end of an element sequence

public const string EndSequence = "SEQEND";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.EndTable Field

end table code.

public const string EndTable = "ENDTAB";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.EntitiesSection Field

entities section.

public const string EntitiesSection = "ENTITIES";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.HeaderSection Field

header section.

public const string HeaderSection = "HEADER";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.LayerTable Field

layers section.

public const string LayerTable = "LAYER";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.LineTypeTable Field

line types.

public const string LineTypeTable = "LTYPE";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.ObjectsSection Field

objects section.

public const string ObjectsSection = "OBJECTS";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.Table Field

Cad name string.

public const string Table = "TABLE";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.TablesSection Field

tables section name.

public const string TablesSection = "TABLES";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.TextStyleTable Field

text styles table.

public const string TextStyleTable = "STYLE";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.UcsTable Field

ucs table name.

public const string UcsTable = "UCS";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.Unknown Field

not defined .

public const string Unknown = "";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.ViewPortTable Field

view ports table.

public const string ViewPortTable = "VPORT";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableNames.ViewTable Field

views table.

public const string ViewTable = "VIEW";

See Also

CadTableNames Class | Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadTableSymbols Enumeration

Contains TABLE Types

public enum CadTableSymbols

Members

Member Name | Description | Value
APPID | The application id. | 0
DIMSTYLE | The dimension style . | 1
LAYER | The layer table. | 2
LTYPE | The line type. | 3
STYLE | The style table. | 4
UCS | The ucs table. | 5
VIEW | The view table. | 6
VPORT | The view port. | 7
BLOCK_RECORD | The block record. | 8

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadConsts

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


Aspose.Imaging.FileFormats.Cad.CadObjects

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Cad.CadObjects Namespace

Namespace hierarchy

Classes

Class | Description
Cad2DPoint | The Cad 2 d point.
Cad2DVertex | The Cad 2 d vertex.
Cad2LineAngleDimension | The Cad angle dimension.
Cad3DPoint | The Cad point.
Cad3DVertex | The Cad 3 d vertex.
CadAlignedDimension | The Cad aligned dimension.
CadAngularDimension | The Cad angular dimension.
CadApplicationCodes | The Cad Application Defined Codes
CadApplicationCodesContainer | The CadApplicationCodes Container
CadArc | Class describing Cad ARC
CadAttDef | Class describing Cad AttributeDefinitions
CadAttrib | The Cad attrib.
CadBase | Base class for Cad objects
CadBaseEntity | The Cad base entity object.
CadBaseExtrudedEntity | The Cad base extruded entity object.
CadBaseObject | Base class for Cad objects
CadBaseOwned | The Cad base owned object.
CadBaseTable | The Cad base table object.
CadBlockEntity | The Cad block entity.
CadCallout | Class describing Cad callout for CadConsts.CadSubClassName.LEADER type
CadCalloutData | Class describing Cad ARC
CadCalloutLeader | Class describing Cad Callout Leader. For CadConsts.CadSubClassName.LEADER type.
CadCalloutLine | Class describing Cad Callout Line
CadCircle | Class describing Cad circle
CadDiametricDimension | The Cad diameter dimension. NOTE: This class is an exact copy of CadRadialDimension except sublcass name
CadDimensionBase | The CadDimension class
CadDimensionOrdinate | The Cad dimension ordinate.
CadEllipse | Class describing Cad ellipse
CadHatch | The Cad hatch.
CadHatchBoundaryPathContainer | Boundary for hatch
CadHatchPatternData | Cad hatch pattern class
CadHelix | Class describing CadHelix
CadInsertObject | The Cad insert object.
CadInvisibleObject | Base class for Cad objects
CadLayout | The Cad layout object.
CadLine | Class describing Cad line
CadLwPolyline | Class describing Cad lwPoliline
CadMesh | Class describing Cad mesh
CadMText | Class describing Cad Mtext
CadMultiLine | The Cad multi line.
CadMultiLineVectorBlock | Cad mline vector block
CadPlotSettings | The Cad Plot Settings object.
CadPoint | Class describing Cad ARC
CadPolyline | Class describing Cad POLYLINE
CadPolyline3D | The Cad polyline 3 d.
CadPolylineBase | Class describing Cad POLYLINE
CadPolylineBoundaryPath | The Cad polyline boundary path.
CadProxyEntity | Class describing Cad Acad Proxy Entity
CadRadialDimension | The Cad radial dimension. NOTE: This class is an exact copy of CadDiametricDimension except sublcass name
CadRay | Class describing CadRay
CadRotatedDimension | The Cad rotated dimension.
CadSectionEntity | Class describing Cad Section Entity
CadSeqend | Class describing Cad SEQEND. For CadConsts.CadSubClassName.SEQEND type.
CadSize | The Cad size
CadSolid | Class describing CadSolid
CadSpline | Class describing Cad SPLINE
CadSurfaceBase | The Cad surface base.
CadTableEntity | The Cad table entity.
CadText | Class describing Cad text
CadVertexBase | Class describing Cad VERTEX
CadViewport | The Cad view port.
CadXdata | The Cad xdata.
CadXdataContainer | The Xdata Container
CadXLine | Class describing CadXLine


Cad2DPoint Class

The Cad 2 d point.

For a list of all members of this type, see Cad2DPoint Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad2DPoint
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad3DPoint

public class Cad2DPoint

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Cad2DPoint Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2DPoint Members

Cad2DPoint overview

Public Instance Constructors

Cad2DPoint Overloaded. Initializes a new instance of the Cad2DPoint class.

Public Instance Properties

X | Gets or sets the x.
Y | Gets or sets the y.

Public Instance Methods

Distance | Distances the specified destination.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFPoint | Gets the point.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Cad2DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2DPoint Constructor

Initializes a new instance of the Cad2DPoint class.

Overload List

Initializes a new instance of the Cad2DPoint class.

public Cad2DPoint();

Initializes a new instance of the Cad2DPoint class.

public Cad2DPoint(CadEntityAttribute,CadEntityAttribute);

Initializes a new instance of the Cad2DPoint class.

public Cad2DPoint(double,double);

See Also

Cad2DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2DPoint Constructor ()

Initializes a new instance of the Cad2DPoint class.

public Cad2DPoint();

See Also

Cad2DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | Cad2DPoint Constructor Overload List


Cad2DPoint Constructor (Double, Double)

Initializes a new instance of the Cad2DPoint class.

public Cad2DPoint(
double x,
double y
);

Parameters

x
The x ordinate.
y
The y ordinate.

See Also

Cad2DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | Cad2DPoint Constructor Overload List


Cad2DPoint Constructor (CadEntityAttribute, CadEntityAttribute)

Initializes a new instance of the Cad2DPoint class.

public Cad2DPoint(
CadEntityAttribute attributeX,
CadEntityAttribute attributeY
);

Parameters

attributeX
The attribute x.
attributeY
The attribute y.

See Also

Cad2DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | Cad2DPoint Constructor Overload List


Cad2DPoint Properties

The properties of the Cad2DPoint class are listed below. For a complete list of Cad2DPoint class members, see the Cad2DPoint Members topic.

Public Instance Properties

X | Gets or sets the x.
Y | Gets or sets the y.

See Also

Cad2DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


X Property

Aspose.Imaging Documentation

Cad2DPoint.X Property

Gets or sets the x.

public double X {get; set;}

See Also

Cad2DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Y Property

Aspose.Imaging Documentation

Cad2DPoint.Y Property

Gets or sets the y.

public double Y {get; set;}

See Also

Cad2DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2DPoint Methods

The methods of the Cad2DPoint class are listed below. For a complete list of Cad2DPoint class members, see the Cad2DPoint Members topic.

Public Instance Methods

Distance | Distances the specified destination.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFPoint | Gets the point.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Cad2DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2DPoint.Distance Method

Distances the specified destination.

public double Distance(
Cad2DPoint destination
);

Parameters

destination
The destination.

Return Value

Distance to point

See Also

Cad2DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2DPoint.GetFPoint Method

Gets the point.

public PointF GetFPoint();

Return Value

The PointF.

See Also

Cad2DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2DVertex Class

The Cad 2 d vertex.

For a list of all members of this type, see Cad2DVertex Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadVertexBase
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad2DVertex

public class Cad2DVertex : CadVertexBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Cad2DVertex Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2DVertex Members

Cad2DVertex overview

Public Instance Constructors

Cad2DVertex Constructor Initializes a new instance of the Cad2DVertex class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
Bugle (inherited from CadVertexBase) | Gets or sets the bugle.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
CurveFitTangentDirection (inherited from CadVertexBase) | Gets or sets the curve fit tangent direction.
EndingWidth (inherited from CadVertexBase) | Gets or sets the ending width.
Flags (inherited from CadVertexBase) | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
LocationPoint | Gets or sets the location point.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MeshVertexIndex1 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 1.
MeshVertexIndex2 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 2.
MeshVertexIndex3 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 3.
MeshVertexIndex4 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 4.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartingWidth (inherited from CadVertexBase) | Gets or sets the starting width.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VertexId (inherited from CadVertexBase) | Gets or sets the vertex id.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Cad2DVertex Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2DVertex Constructor

Initializes a new instance of the Cad2DVertex class.

public Cad2DVertex();

See Also

Cad2DVertex Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2DVertex Properties

The properties of the Cad2DVertex class are listed below. For a complete list of Cad2DVertex class members, see the Cad2DVertex Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
Bugle (inherited from CadVertexBase) | Gets or sets the bugle.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
CurveFitTangentDirection (inherited from CadVertexBase) | Gets or sets the curve fit tangent direction.
EndingWidth (inherited from CadVertexBase) | Gets or sets the ending width.
Flags (inherited from CadVertexBase) | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
LocationPoint | Gets or sets the location point.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MeshVertexIndex1 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 1.
MeshVertexIndex2 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 2.
MeshVertexIndex3 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 3.
MeshVertexIndex4 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 4.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartingWidth (inherited from CadVertexBase) | Gets or sets the starting width.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VertexId (inherited from CadVertexBase) | Gets or sets the vertex id.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

Cad2DVertex Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LocationPoint Property

Aspose.Imaging Documentation

Cad2DVertex.LocationPoint Property

Gets or sets the location point.

public Cad2DPoint LocationPoint {get; set;}

Property Value

The location point.

See Also

Cad2DVertex Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2LineAngleDimension Class

The Cad angle dimension.

For a list of all members of this type, see Cad2LineAngleDimension Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDimensionBase
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad2LineAngleDimension

public class Cad2LineAngleDimension : CadDimensionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Cad2LineAngleDimension Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2LineAngleDimension Members

Cad2LineAngleDimension overview

Public Instance Constructors

Cad2LineAngleDimension Constructor Initializes a new instance of the Cad2LineAngleDimension class.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
AngularArcDefinitionPoint | Gets or sets the angular arc definition point.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DefinitionPoint1 | Gets or sets the definition point1.
DefinitionPoint2 | Gets or sets the definition point2.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RadiusDefinitionPoint | Gets or sets the radius definition point.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Cad2LineAngleDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2LineAngleDimension Constructor

Initializes a new instance of the Cad2LineAngleDimension class.

public Cad2LineAngleDimension();

See Also

Cad2LineAngleDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad2LineAngleDimension Properties

The properties of the Cad2LineAngleDimension class are listed below. For a complete list of Cad2LineAngleDimension class members, see the Cad2LineAngleDimension Members topic.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
AngularArcDefinitionPoint | Gets or sets the angular arc definition point.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DefinitionPoint1 | Gets or sets the definition point1.
DefinitionPoint2 | Gets or sets the definition point2.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RadiusDefinitionPoint | Gets or sets the radius definition point.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

Cad2LineAngleDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AngularArcDefinitionPoint Property

Aspose.Imaging Documentation

Cad2LineAngleDimension.AngularArcDefinitionPoint Property

Gets or sets the angular arc definition point.

public Cad3DPoint AngularArcDefinitionPoint {get; set;}

Property Value

The angular arc definition point.

See Also

Cad2LineAngleDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DefinitionPoint1 Property

Aspose.Imaging Documentation

Cad2LineAngleDimension.DefinitionPoint1 Property

Gets or sets the definition point1.

public Cad3DPoint DefinitionPoint1 {get; set;}

Property Value

The definition point1.

See Also

Cad2LineAngleDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DefinitionPoint2 Property

Aspose.Imaging Documentation

Cad2LineAngleDimension.DefinitionPoint2 Property

Gets or sets the definition point2.

public Cad3DPoint DefinitionPoint2 {get; set;}

Property Value

The definition point2.

See Also

Cad2LineAngleDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RadiusDefinitionPoint Property

Aspose.Imaging Documentation

Cad2LineAngleDimension.RadiusDefinitionPoint Property

Gets or sets the radius definition point.

public Cad3DPoint RadiusDefinitionPoint {get; set;}

Property Value

The radius definition point.

See Also

Cad2LineAngleDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad3DPoint Class

The Cad point.

For a list of all members of this type, see Cad3DPoint Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad2DPoint
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad3DPoint

public class Cad3DPoint : Cad2DPoint

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Cad3DPoint Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad3DPoint Members

Cad3DPoint overview

Public Static Methods

AngleBetween3Points | Angles the between3 points.
RotatePoint | Rotates one point arount another one

Public Instance Constructors

Cad3DPoint Overloaded. Initializes a new instance of the Cad3DPoint class.

Public Instance Properties

X (inherited from Cad2DPoint) | Gets or sets the x.
Y (inherited from Cad2DPoint) | Gets or sets the y.
Z | Gets or sets the z.

Public Instance Methods

Distance | Overloaded. The distance.
Distance (inherited from Cad2DPoint) | Overloaded. Distances the specified destination.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFPoint (inherited from Cad2DPoint) | Gets the point.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad3DPoint Constructor

Initializes a new instance of the Cad3DPoint class.

Overload List

Initializes a new instance of the Cad3DPoint class.

public Cad3DPoint();

Initializes a new instance of the Cad3DPoint class.

public Cad3DPoint(CadEntityAttribute,CadEntityAttribute,CadEntityAttribute);

Initializes a new instance of the Cad3DPoint class.

public Cad3DPoint(double,double);

Initializes a new instance of the Cad3DPoint class.

public Cad3DPoint(double,double,double);

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad3DPoint Constructor ()

Initializes a new instance of the Cad3DPoint class.

public Cad3DPoint();

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | Cad3DPoint Constructor Overload List


Cad3DPoint Constructor (Double, Double, Double)

Initializes a new instance of the Cad3DPoint class.

public Cad3DPoint(
double x,
double y,
double z
);

Parameters

x
The x ordinate.
y
The y ordinate.
z
The z ordinate.

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | Cad3DPoint Constructor Overload List


Cad3DPoint Constructor (CadEntityAttribute, CadEntityAttribute, CadEntityAttribute)

Initializes a new instance of the Cad3DPoint class.

public Cad3DPoint(
CadEntityAttribute attributeX,
CadEntityAttribute attributeY,
CadEntityAttribute attributeZ
);

Parameters

attributeX
The attribute x.
attributeY
The attribute y.
attributeZ
The attribute z.

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | Cad3DPoint Constructor Overload List


Cad3DPoint Constructor (Double, Double)

Initializes a new instance of the Cad3DPoint class.

public Cad3DPoint(
double pointX,
double pointY
);

Parameters

pointX
The pointX.
pointY
The point Y.

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | Cad3DPoint Constructor Overload List


Cad3DPoint Properties

The properties of the Cad3DPoint class are listed below. For a complete list of Cad3DPoint class members, see the Cad3DPoint Members topic.

Public Instance Properties

X (inherited from Cad2DPoint) | Gets or sets the x.
Y (inherited from Cad2DPoint) | Gets or sets the y.
Z | Gets or sets the z.

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Z Property

Aspose.Imaging Documentation

Cad3DPoint.Z Property

Gets or sets the z.

public double Z {get; set;}

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad3DPoint Methods

The methods of the Cad3DPoint class are listed below. For a complete list of Cad3DPoint class members, see the Cad3DPoint Members topic.

Public Static Methods

AngleBetween3Points | Angles the between3 points.
RotatePoint | Rotates one point arount another one

Public Instance Methods

Distance | Overloaded. The distance.
Distance (inherited from Cad2DPoint) | Overloaded. Distances the specified destination.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFPoint (inherited from Cad2DPoint) | Gets the point.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad3DPoint.AngleBetween3Points Method

Angles the between3 points.

public static double AngleBetween3Points(
Cad3DPoint a,
Cad3DPoint b,
Cad3DPoint c
);

Parameters

a
First Point
b
second point
c
third point

Return Value

Angle between 3 points

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Distance Method

Aspose.Imaging Documentation

Cad3DPoint.Distance Method

The distance.

Overload List

Inherited from Cad2DPoint.

public double Distance(Cad2DPoint);

The distance.

public double Distance(Cad3DPoint);

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad3DPoint.Distance Method (Cad3DPoint)

The distance.

public double Distance(
Cad3DPoint destination
);

Parameters

destination
The destination.

Return Value

The Double.

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | Cad3DPoint.Distance Overload List


Cad3DPoint.RotatePoint Method

Rotates one point arount another one

public static Cad3DPoint RotatePoint(
Cad3DPoint pointToRotate,
Cad3DPoint centerPoint,
double angleInRadians
);

Parameters

pointToRotate
the point to rotate
centerPoint
the centre point of rotation
angleInRadians
The angle In Radians.

Return Value

Rotated point

See Also

Cad3DPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad3DVertex Class

The Cad 3 d vertex.

For a list of all members of this type, see Cad3DVertex Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadVertexBase
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad3DVertex

public class Cad3DVertex : CadVertexBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Cad3DVertex Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad3DVertex Members

Cad3DVertex overview

Public Instance Constructors

Cad3DVertex Constructor Initializes a new instance of the Cad3DVertex class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
Bugle (inherited from CadVertexBase) | Gets or sets the bugle.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
CurveFitTangentDirection (inherited from CadVertexBase) | Gets or sets the curve fit tangent direction.
EndingWidth (inherited from CadVertexBase) | Gets or sets the ending width.
Flags (inherited from CadVertexBase) | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
LocationPoint | Gets or sets the location point.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MeshVertexIndex1 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 1.
MeshVertexIndex2 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 2.
MeshVertexIndex3 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 3.
MeshVertexIndex4 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 4.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartingWidth (inherited from CadVertexBase) | Gets or sets the starting width.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VertexId (inherited from CadVertexBase) | Gets or sets the vertex id.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Cad3DVertex Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad3DVertex Constructor

Initializes a new instance of the Cad3DVertex class.

public Cad3DVertex();

See Also

Cad3DVertex Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Cad3DVertex Properties

The properties of the Cad3DVertex class are listed below. For a complete list of Cad3DVertex class members, see the Cad3DVertex Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
Bugle (inherited from CadVertexBase) | Gets or sets the bugle.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
CurveFitTangentDirection (inherited from CadVertexBase) | Gets or sets the curve fit tangent direction.
EndingWidth (inherited from CadVertexBase) | Gets or sets the ending width.
Flags (inherited from CadVertexBase) | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
LocationPoint | Gets or sets the location point.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MeshVertexIndex1 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 1.
MeshVertexIndex2 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 2.
MeshVertexIndex3 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 3.
MeshVertexIndex4 (inherited from CadVertexBase) | Gets or sets the mesh vertex index 4.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartingWidth (inherited from CadVertexBase) | Gets or sets the starting width.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VertexId (inherited from CadVertexBase) | Gets or sets the vertex id.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

Cad3DVertex Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LocationPoint Property

Aspose.Imaging Documentation

Cad3DVertex.LocationPoint Property

Gets or sets the location point.

public Cad3DPoint LocationPoint {get; set;}

See Also

Cad3DVertex Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAlignedDimension Class

The Cad aligned dimension.

For a list of all members of this type, see CadAlignedDimension Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDimensionBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadAlignedDimension
Aspose.Imaging.FileFormats.Cad.CadObjects.CadRotatedDimension

public class CadAlignedDimension : CadDimensionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadAlignedDimension Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAlignedDimension Members

CadAlignedDimension overview

Public Instance Constructors

CadAlignedDimension Constructor Initializes a new instance of the CadAlignedDimension class.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DefinitionPoint1 | Gets or sets the definition point1.
DefinitionPoint2 | Gets or sets the definition point2.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
InsertionPoint | Gets or sets the insertion point.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadAlignedDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAlignedDimension Constructor

Initializes a new instance of the CadAlignedDimension class.

public CadAlignedDimension();

See Also

CadAlignedDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAlignedDimension Properties

The properties of the CadAlignedDimension class are listed below. For a complete list of CadAlignedDimension class members, see the CadAlignedDimension Members topic.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DefinitionPoint1 | Gets or sets the definition point1.
DefinitionPoint2 | Gets or sets the definition point2.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
InsertionPoint | Gets or sets the insertion point.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadAlignedDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DefinitionPoint1 Property

Aspose.Imaging Documentation

CadAlignedDimension.DefinitionPoint1 Property

Gets or sets the definition point1.

public Cad3DPoint DefinitionPoint1 {get; set;}

Property Value

The definition point1.

See Also

CadAlignedDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DefinitionPoint2 Property

Aspose.Imaging Documentation

CadAlignedDimension.DefinitionPoint2 Property

Gets or sets the definition point2.

public Cad3DPoint DefinitionPoint2 {get; set;}

Property Value

The definition point2.

See Also

CadAlignedDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


InsertionPoint Property

Aspose.Imaging Documentation

CadAlignedDimension.InsertionPoint Property

Gets or sets the insertion point.

public Cad3DPoint InsertionPoint {get; set;}

Property Value

The insertion point.

See Also

CadAlignedDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAngularDimension Class

The Cad angular dimension.

For a list of all members of this type, see CadAngularDimension Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDimensionBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadAngularDimension

public class CadAngularDimension : CadDimensionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadAngularDimension Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAngularDimension Members

CadAngularDimension overview

Public Instance Constructors

CadAngularDimension Constructor Initializes a new instance of the CadAngularDimension class.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
ArcDefinitionPoint | Gets arc definition point
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LeftBottomPoint | Gets left bottom point
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RightBottomPoint | Gets right bottom point
RightTopPoint | Gets right top point
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadAngularDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAngularDimension Constructor

Initializes a new instance of the CadAngularDimension class.

public CadAngularDimension();

See Also

CadAngularDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAngularDimension Properties

The properties of the CadAngularDimension class are listed below. For a complete list of CadAngularDimension class members, see the CadAngularDimension Members topic.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
ArcDefinitionPoint | Gets arc definition point
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LeftBottomPoint | Gets left bottom point
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RightBottomPoint | Gets right bottom point
RightTopPoint | Gets right top point
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadAngularDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ArcDefinitionPoint Property

Aspose.Imaging Documentation

CadAngularDimension.ArcDefinitionPoint Property

Gets arc definition point

public Cad3DPoint ArcDefinitionPoint {get;}

See Also

CadAngularDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LeftBottomPoint Property

Aspose.Imaging Documentation

CadAngularDimension.LeftBottomPoint Property

Gets left bottom point

public Cad3DPoint LeftBottomPoint {get;}

See Also

CadAngularDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RightBottomPoint Property

Aspose.Imaging Documentation

CadAngularDimension.RightBottomPoint Property

Gets right bottom point

public Cad3DPoint RightBottomPoint {get;}

See Also

CadAngularDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RightTopPoint Property

Aspose.Imaging Documentation

CadAngularDimension.RightTopPoint Property

Gets right top point

public Cad3DPoint RightTopPoint {get;}

See Also

CadAngularDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodes Class

The Cad Application Defined Codes

For a list of all members of this type, see CadApplicationCodes Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadApplicationCodes

public class CadApplicationCodes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadApplicationCodes Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodes Members

CadApplicationCodes overview

Public Instance Constructors

CadApplicationCodes Constructor Initializes a new instance of the CadApplicationCodes class. Initializes a new instance of the class.

Public Instance Properties

CodesList | Gets or sets the data list.
Name | Gets the name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Gets the value.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadApplicationCodes Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodes Constructor

Initializes a new instance of the CadApplicationCodes class. Initializes a new instance of the class.

public CadApplicationCodes(
string applicationName
);

Parameters

applicationName
Name of the application.

See Also

CadApplicationCodes Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodes Properties

The properties of the CadApplicationCodes class are listed below. For a complete list of CadApplicationCodes class members, see the CadApplicationCodes Members topic.

Public Instance Properties

CodesList | Gets or sets the data list.
Name | Gets the name.

See Also

CadApplicationCodes Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CodesList Property

Aspose.Imaging Documentation

CadApplicationCodes.CodesList Property

Gets or sets the data list.

public CadCodeValue} CodesList {get; set;}

Property Value

The data list.

See Also

CadApplicationCodes Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Name Property

Aspose.Imaging Documentation

CadApplicationCodes.Name Property

Gets the name.

public string Name {get;}

Property Value

The name.

See Also

CadApplicationCodes Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodes Methods

The methods of the CadApplicationCodes class are listed below. For a complete list of CadApplicationCodes class members, see the CadApplicationCodes Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Gets the value.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadApplicationCodes Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodes.GetValue Method

Gets the value.

public string GetValue(
CadEntityAttribute cadEntityAttribute
);

Parameters

cadEntityAttribute
The cad entity attribute.

Return Value

The first occurrence a attribute, if found; otherwise, null.

See Also

CadApplicationCodes Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodesContainer Class

The CadApplicationCodes Container

For a list of all members of this type, see CadApplicationCodesContainer Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadApplicationCodesContainer

public class CadApplicationCodesContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadApplicationCodesContainer Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodesContainer Members

CadApplicationCodesContainer overview

Public Instance Constructors

CadApplicationCodesContainer Constructor Initializes a new instance of the CadApplicationCodesContainer class.

Public Instance Properties

Codes Gets or sets the codes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAcadReactorsCodes | Gets the ACAD Reactors codes
GetAcadXDictionaryCodes | Gets the ACAD XDictionary codes
GetCodes | Gets the codes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Initialize the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadApplicationCodesContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodesContainer Constructor

Initializes a new instance of the CadApplicationCodesContainer class.

public CadApplicationCodesContainer();

See Also

CadApplicationCodesContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodesContainer Properties

The properties of the CadApplicationCodesContainer class are listed below. For a complete list of CadApplicationCodesContainer class members, see the CadApplicationCodesContainer Members topic.

Public Instance Properties

Codes Gets or sets the codes.

See Also

CadApplicationCodesContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Codes Property

Aspose.Imaging Documentation

CadApplicationCodesContainer.Codes Property

Gets or sets the codes.

public CadApplicationCodes} Codes {get; set;}

Property Value

The codes.

See Also

CadApplicationCodesContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodesContainer Methods

The methods of the CadApplicationCodesContainer class are listed below. For a complete list of CadApplicationCodesContainer class members, see the CadApplicationCodesContainer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAcadReactorsCodes | Gets the ACAD Reactors codes
GetAcadXDictionaryCodes | Gets the ACAD XDictionary codes
GetCodes | Gets the codes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Initialize the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadApplicationCodesContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodesContainer.GetAcadReactorsCodes Method

Gets the ACAD Reactors codes

public CadApplicationCodes GetAcadReactorsCodes();

Return Value

The Application Codes.

See Also

CadApplicationCodesContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodesContainer.GetAcadXDictionaryCodes Method

Gets the ACAD XDictionary codes

public CadApplicationCodes GetAcadXDictionaryCodes();

Return Value

The Application Codes.

See Also

CadApplicationCodesContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodesContainer.GetCodes Method

Gets the codes.

public CadApplicationCodes GetCodes(
string applicationName
);

Parameters

applicationName
Name of the application.

Return Value

The Application Codes

See Also

CadApplicationCodesContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadApplicationCodesContainer.Init Method

Initialize the specified stream.

public CadCodeValue Init(
TextReader stream,
CadCodeValue codeValue
);

Parameters

stream
The stream.
codeValue
The code value.

Return Value

Last read codeValue

See Also

CadApplicationCodesContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadArc Class

Class describing Cad ARC

For a list of all members of this type, see CadArc Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadCircle
Aspose.Imaging.FileFormats.Cad.CadObjects.CadArc

public class CadArc : CadCircle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadArc Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadArc Members

CadArc overview

Public Instance Constructors

CadArc Constructor Initializes a new instance of the CadArc class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
CenterPoint (inherited from CadCircle) | Gets or sets the centerPoint.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
CounterClockwize | Gets or sets the counter clockwize.
EndAngle | Gets or sets the End angle.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
Radius (inherited from CadCircle) | Gets or sets the radius.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartAngle | Gets or sets Start angle.
Thickness (inherited from CadCircle) | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadArc Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadArc Constructor

Initializes a new instance of the CadArc class.

public CadArc();

See Also

CadArc Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadArc Properties

The properties of the CadArc class are listed below. For a complete list of CadArc class members, see the CadArc Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
CenterPoint (inherited from CadCircle) | Gets or sets the centerPoint.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
CounterClockwize | Gets or sets the counter clockwize.
EndAngle | Gets or sets the End angle.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
Radius (inherited from CadCircle) | Gets or sets the radius.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartAngle | Gets or sets Start angle.
Thickness (inherited from CadCircle) | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadArc Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CounterClockwize Property

Aspose.Imaging Documentation

CadArc.CounterClockwize Property

Gets or sets the counter clockwize.

public short CounterClockwize {get; set;}

Property Value

The counter clockwize.

See Also

CadArc Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


EndAngle Property

Aspose.Imaging Documentation

CadArc.EndAngle Property

Gets or sets the End angle.

public double EndAngle {get; set;}

Property Value

End angle.

See Also

CadArc Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StartAngle Property

Aspose.Imaging Documentation

CadArc.StartAngle Property

Gets or sets Start angle.

public double StartAngle {get; set;}

Property Value

The Start angle

See Also

CadArc Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAttDef Class

Class describing Cad AttributeDefinitions

For a list of all members of this type, see CadAttDef Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadAttDef

public class CadAttDef : CadBaseEntity, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadAttDef Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAttDef Members

CadAttDef overview

Public Instance Constructors

CadAttDef Constructor Initializes a new instance of the CadAttDef class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefaultString | Gets or sets the default string.
FieldLength | Gets or sets the field length.
FirstAlignment | Gets or sets the first alignment.
Flags | Gets or sets the flags.
GenerationFlag | Gets or sets the generation flag.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalAlignment | Gets or sets the horizontal alignment.
Id | Gets or sets the id.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
ObliqueAngle | Gets or sets the oblique angle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PromptString | Gets or sets the prompt string.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RotationAngle | Gets or sets the rotation angle.
ScaleX | Gets or sets the scale x.
SecondAlignment | Gets or sets the second alignment.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName | Gets or sets the style name.
TextHeight | Gets or sets the text height.
Thickness | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VerticalJustification | Gets or sets the vertical justification.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Clone | Clones current object
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAttDef Constructor

Initializes a new instance of the CadAttDef class.

public CadAttDef();

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAttDef Properties

The properties of the CadAttDef class are listed below. For a complete list of CadAttDef class members, see the CadAttDef Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefaultString | Gets or sets the default string.
FieldLength | Gets or sets the field length.
FirstAlignment | Gets or sets the first alignment.
Flags | Gets or sets the flags.
GenerationFlag | Gets or sets the generation flag.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalAlignment | Gets or sets the horizontal alignment.
Id | Gets or sets the id.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
ObliqueAngle | Gets or sets the oblique angle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PromptString | Gets or sets the prompt string.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RotationAngle | Gets or sets the rotation angle.
ScaleX | Gets or sets the scale x.
SecondAlignment | Gets or sets the second alignment.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName | Gets or sets the style name.
TextHeight | Gets or sets the text height.
Thickness | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VerticalJustification | Gets or sets the vertical justification.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DefaultString Property

Aspose.Imaging Documentation

CadAttDef.DefaultString Property

Gets or sets the default string.

public string DefaultString {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FieldLength Property

Aspose.Imaging Documentation

CadAttDef.FieldLength Property

Gets or sets the field length.

public short FieldLength {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FirstAlignment Property

Aspose.Imaging Documentation

CadAttDef.FirstAlignment Property

Gets or sets the first alignment.

public Cad3DPoint FirstAlignment {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Flags Property

Aspose.Imaging Documentation

CadAttDef.Flags Property

Gets or sets the flags.

public short Flags {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


GenerationFlag Property

Aspose.Imaging Documentation

CadAttDef.GenerationFlag Property

Gets or sets the generation flag.

public short GenerationFlag {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HorizontalAlignment Property

Aspose.Imaging Documentation

CadAttDef.HorizontalAlignment Property

Gets or sets the horizontal alignment.

public short HorizontalAlignment {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Id Property

Aspose.Imaging Documentation

CadAttDef.Id Property

Gets or sets the id.

public string Id {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ObliqueAngle Property

Aspose.Imaging Documentation

CadAttDef.ObliqueAngle Property

Gets or sets the oblique angle.

public double ObliqueAngle {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PromptString Property

Aspose.Imaging Documentation

CadAttDef.PromptString Property

Gets or sets the prompt string.

public string PromptString {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RotationAngle Property

Aspose.Imaging Documentation

CadAttDef.RotationAngle Property

Gets or sets the rotation angle.

public double RotationAngle {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ScaleX Property

Aspose.Imaging Documentation

CadAttDef.ScaleX Property

Gets or sets the scale x.

public double ScaleX {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SecondAlignment Property

Aspose.Imaging Documentation

CadAttDef.SecondAlignment Property

Gets or sets the second alignment.

public Cad3DPoint SecondAlignment {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StyleName Property

Aspose.Imaging Documentation

CadAttDef.StyleName Property

Gets or sets the style name.

public string StyleName {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextHeight Property

Aspose.Imaging Documentation

CadAttDef.TextHeight Property

Gets or sets the text height.

public double TextHeight {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Thickness Property

Aspose.Imaging Documentation

CadAttDef.Thickness Property

Gets or sets the thickness.

public double Thickness {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


VerticalJustification Property

Aspose.Imaging Documentation

CadAttDef.VerticalJustification Property

Gets or sets the vertical justification.

public short VerticalJustification {get; set;}

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAttDef Methods

The methods of the CadAttDef class are listed below. For a complete list of CadAttDef class members, see the CadAttDef Members topic.

Public Instance Methods

Clone | Clones current object
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAttDef.Clone Method

Clones current object

public object Clone();

Return Value

Clone of current object

Implements

ICloneable.Clone

See Also

CadAttDef Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAttrib Class

The Cad attrib.

For a list of all members of this type, see CadAttrib Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadAttrib

public class CadAttrib : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadAttrib Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAttrib Members

CadAttrib overview

Public Instance Constructors

CadAttrib Constructor Initializes a new instance of the CadAttrib class.

Public Instance Properties

AlignmentPoint | Gets or sets the alignment point.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
AttributeString | Gets or sets the attribute string.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefaultText | Gets or sets the default text.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MultiText | Gets or sets the multi text.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
ObliqueAngle | Gets or sets the obliqueAngle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RelativeScale | Gets or sets the relativeScale.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleType | Gets or sets the attribute string.
TextFlags | Gets or sets the textFlags.
TextHeight | Gets or sets the text height.
TextJustH | Gets or sets the textJustH.
TextJustV | Gets or sets the textJustV.
TextRotation | Gets or sets the text rotation.
TextStartPoint | Gets or sets the text start point.
Thickness | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Version | Gets or sets the version.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAttrib Constructor

Initializes a new instance of the CadAttrib class.

public CadAttrib();

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadAttrib Properties

The properties of the CadAttrib class are listed below. For a complete list of CadAttrib class members, see the CadAttrib Members topic.

Public Instance Properties

AlignmentPoint | Gets or sets the alignment point.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
AttributeString | Gets or sets the attribute string.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefaultText | Gets or sets the default text.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MultiText | Gets or sets the multi text.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
ObliqueAngle | Gets or sets the obliqueAngle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RelativeScale | Gets or sets the relativeScale.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleType | Gets or sets the attribute string.
TextFlags | Gets or sets the textFlags.
TextHeight | Gets or sets the text height.
TextJustH | Gets or sets the textJustH.
TextJustV | Gets or sets the textJustV.
TextRotation | Gets or sets the text rotation.
TextStartPoint | Gets or sets the text start point.
Thickness | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Version | Gets or sets the version.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AlignmentPoint Property

Aspose.Imaging Documentation

CadAttrib.AlignmentPoint Property

Gets or sets the alignment point.

public Cad3DPoint AlignmentPoint {get; set;}

Property Value

The alignment point.

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AttributeString Property

Aspose.Imaging Documentation

CadAttrib.AttributeString Property

Gets or sets the attribute string.

public string AttributeString {get; set;}

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DefaultText Property

Aspose.Imaging Documentation

CadAttrib.DefaultText Property

Gets or sets the default text.

public string DefaultText {get; set;}

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MultiText Property

Aspose.Imaging Documentation

CadAttrib.MultiText Property

Gets or sets the multi text.

public CadMText MultiText {get; set;}

Property Value

The multi text.

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ObliqueAngle Property

Aspose.Imaging Documentation

CadAttrib.ObliqueAngle Property

Gets or sets the obliqueAngle.

public double ObliqueAngle {get; set;}

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RelativeScale Property

Aspose.Imaging Documentation

CadAttrib.RelativeScale Property

Gets or sets the relativeScale.

public double RelativeScale {get; set;}

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StyleType Property

Aspose.Imaging Documentation

CadAttrib.StyleType Property

Gets or sets the attribute string.

public string StyleType {get; set;}

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextFlags Property

Aspose.Imaging Documentation

CadAttrib.TextFlags Property

Gets or sets the textFlags.

public short TextFlags {get; set;}

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextHeight Property

Aspose.Imaging Documentation

CadAttrib.TextHeight Property

Gets or sets the text height.

public double TextHeight {get; set;}

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextJustH Property

Aspose.Imaging Documentation

CadAttrib.TextJustH Property

Gets or sets the textJustH.

public short TextJustH {get; set;}

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextJustV Property

Aspose.Imaging Documentation

CadAttrib.TextJustV Property

Gets or sets the textJustV.

public short TextJustV {get; set;}

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextRotation Property

Aspose.Imaging Documentation

CadAttrib.TextRotation Property

Gets or sets the text rotation.

public double TextRotation {get; set;}

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextStartPoint Property

Aspose.Imaging Documentation

CadAttrib.TextStartPoint Property

Gets or sets the text start point.

public Cad3DPoint TextStartPoint {get; set;}

Property Value

The text start point.

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Thickness Property

Aspose.Imaging Documentation

CadAttrib.Thickness Property

Gets or sets the thickness.

public double Thickness {get; set;}

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Version Property

Aspose.Imaging Documentation

CadAttrib.Version Property

Gets or sets the version.

public short Version {get; set;}

See Also

CadAttrib Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBase Class

Base class for Cad objects

For a list of all members of this type, see CadBase Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadCalloutLine

public abstract class CadBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadBase Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBase Members

CadBase overview

Public Static Properties

ParameterOrder Gets the parameter order.

Public Instance Constructors

CadBase Constructor Initializes a new instance of the CadBase class.

Public Instance Properties

ApplicationCodesContainer | Gets or sets the application defined codes container.
AttributeOrder | Gets or sets the attribute order.
ObjectHandle | Gets or sets the object handle.
PropertyList | Gets or sets the property list.
ShapeObject | Gets or sets the shape object.
XdataContainer | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBase Constructor

Initializes a new instance of the CadBase class.

public CadBase();

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBase Properties

The properties of the CadBase class are listed below. For a complete list of CadBase class members, see the CadBase Members topic.

Public Static Properties

ParameterOrder Gets the parameter order.

Public Instance Properties

ApplicationCodesContainer | Gets or sets the application defined codes container.
AttributeOrder | Gets or sets the attribute order.
ObjectHandle | Gets or sets the object handle.
PropertyList | Gets or sets the property list.
ShapeObject | Gets or sets the shape object.
XdataContainer | Gets or sets the xdata container.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ApplicationCodesContainer Property

Aspose.Imaging Documentation

CadBase.ApplicationCodesContainer Property

Gets or sets the application defined codes container.

public CadApplicationCodesContainer ApplicationCodesContainer {get; set;}

Property Value

The application defined codes container.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AttributeOrder Property

Aspose.Imaging Documentation

CadBase.AttributeOrder Property

Gets or sets the attribute order.

public String} AttributeOrder {get; set;}

Property Value

The attribute order.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ObjectHandle Property

Aspose.Imaging Documentation

CadBase.ObjectHandle Property

Gets or sets the object handle.

public string ObjectHandle {get; set;}

Property Value

The object handle.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ParameterOrder Property

Aspose.Imaging Documentation

CadBase.ParameterOrder Property

Gets the parameter order.

public static String}} ParameterOrder {get;}

Property Value

The parameter order.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PropertyList Property

Aspose.Imaging Documentation

CadBase.PropertyList Property

Gets or sets the property list.

public String}} PropertyList {get; set;}

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ShapeObject Property

Aspose.Imaging Documentation

CadBase.ShapeObject Property

Gets or sets the shape object.

public Shape ShapeObject {get; set;}

Property Value

The shape object.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


XdataContainer Property

Aspose.Imaging Documentation

CadBase.XdataContainer Property

Gets or sets the xdata container.

public CadXdataContainer XdataContainer {get; set;}

Property Value

The xdata container.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBase Methods

The methods of the CadBase class are listed below. For a complete list of CadBase class members, see the CadBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


GetDouble Method

Aspose.Imaging Documentation

CadBase.GetDouble Method

Gets the double Value.

Overload List

Gets the double Value.

public double GetDouble(CadEntityAttribute);

Gets the double.

public double GetDouble(CadEntityAttribute,CadParameterType);

Gets the double.

public double GetDouble(CadEntityAttribute,int);

Gets the double value.

public double GetDouble(CadEntityAttribute,int,CadParameterType);

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBase.GetDouble Method (CadEntityAttribute)

Gets the double Value.

public double GetDouble(
CadEntityAttribute attribute
);

Parameters

attribute
The attribute.

Return Value

The Double.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | CadBase.GetDouble Overload List


CadBase.GetDouble Method (CadEntityAttribute, CadParameterType)

Gets the double.

public double GetDouble(
CadEntityAttribute attribute,
CadParameterType parameterType
);

Parameters

attribute
The attribute.
parameterType
Type of the parameter.

Return Value

The Double.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | CadBase.GetDouble Overload List


CadBase.GetDouble Method (CadEntityAttribute, Int32)

Gets the double.

public double GetDouble(
CadEntityAttribute attribute,
int index
);

Parameters

attribute
The attribute.
index
The index.

Return Value

The Double.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | CadBase.GetDouble Overload List


CadBase.GetDouble Method (CadEntityAttribute, Int32, CadParameterType)

Gets the double value.

public double GetDouble(
CadEntityAttribute attribute,
int parameterIndex,
CadParameterType parameterType
);

Parameters

attribute
The attribute.
parameterIndex
Index of the parameter.
parameterType
Type of the parameter.

Return Value

The Double.

Exceptions

Exception Type | Condition
CadException | Value not exists for + attribute.ToString()

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | CadBase.GetDouble Overload List


GetInt Method

Aspose.Imaging Documentation

CadBase.GetInt Method

Gets the int.

Overload List

Gets the int.

public int GetInt(CadEntityAttribute);

Gets the int.

public int GetInt(CadEntityAttribute,CadParameterType);

Gets the int.

public int GetInt(CadEntityAttribute,int,CadParameterType);

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBase.GetInt Method (CadEntityAttribute)

Gets the int.

public int GetInt(
CadEntityAttribute attribute
);

Parameters

attribute
The attribute.

Return Value

The Int32.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | CadBase.GetInt Overload List


CadBase.GetInt Method (CadEntityAttribute, CadParameterType)

Gets the int.

public int GetInt(
CadEntityAttribute attribute,
CadParameterType parameterType
);

Parameters

attribute
The attribute.
parameterType
Type of the parameter.

Return Value

The Int32.

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | CadBase.GetInt Overload List


CadBase.GetInt Method (CadEntityAttribute, Int32, CadParameterType)

Gets the int.

public int GetInt(
CadEntityAttribute attribute,
int parameterIndex,
CadParameterType parameterType
);

Parameters

attribute
The attribute.
parameterIndex
Index of the parameter.
parameterType
Type of the parameter.

Return Value

The Int32.

Exceptions

Exception Type | Condition
CadException | Value not exists for + attribute.ToString()

See Also

CadBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | CadBase.GetInt Overload List


CadBaseEntity Class

The Cad base entity object.

For a list of all members of this type, see CadBaseEntity Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Derived types

public abstract class CadBaseEntity : CadBaseOwned

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadBaseEntity Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseEntity Members

CadBaseEntity overview

Public Instance Constructors

CadBaseEntity Constructor Initializes a new instance of the CadBaseEntity class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects | Gets or sets the child objects.
ColorId | Gets or sets the color id.
ColorName | Gets or sets the name of the color.
ColorValue | Gets or sets the color value.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName | Gets or sets the name of the layer.
LineScale | Gets or sets the line scale.
LineTypeName | Gets or sets the name of the line type.
LineWeight | Gets or sets the line weight.
Material | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount | Gets or sets the proxy bytes count.
ProxyData | Gets or sets the proxy data.
ShadowMode | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode | Gets or sets the space mode.
Transparency | Gets or sets the transparency.
TypeName | Gets the name of the type.
Visible | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseEntity Constructor

Initializes a new instance of the CadBaseEntity class.

public CadBaseEntity();

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseEntity Properties

The properties of the CadBaseEntity class are listed below. For a complete list of CadBaseEntity class members, see the CadBaseEntity Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects | Gets or sets the child objects.
ColorId | Gets or sets the color id.
ColorName | Gets or sets the name of the color.
ColorValue | Gets or sets the color value.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName | Gets or sets the name of the layer.
LineScale | Gets or sets the line scale.
LineTypeName | Gets or sets the name of the line type.
LineWeight | Gets or sets the line weight.
Material | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount | Gets or sets the proxy bytes count.
ProxyData | Gets or sets the proxy data.
ShadowMode | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode | Gets or sets the space mode.
Transparency | Gets or sets the transparency.
TypeName | Gets the name of the type.
Visible | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ChildObjects Property

Aspose.Imaging Documentation

CadBaseEntity.ChildObjects Property

Gets or sets the child objects.

public CadBaseEntity} ChildObjects {get; set;}

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColorId Property

Aspose.Imaging Documentation

CadBaseEntity.ColorId Property

Gets or sets the color id.

public int ColorId {get; set;}

Property Value

The color id.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColorName Property

Aspose.Imaging Documentation

CadBaseEntity.ColorName Property

Gets or sets the name of the color.

public string ColorName {get; set;}

Property Value

The name of the color.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColorValue Property

Aspose.Imaging Documentation

CadBaseEntity.ColorValue Property

Gets or sets the color value.

public int ColorValue {get; set;}

Property Value

The color value.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LayerName Property

Aspose.Imaging Documentation

CadBaseEntity.LayerName Property

Gets or sets the name of the layer.

public string LayerName {get; set;}

Property Value

The name of the layer.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LineScale Property

Aspose.Imaging Documentation

CadBaseEntity.LineScale Property

Gets or sets the line scale.

public double LineScale {get; set;}

Property Value

The line scale.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LineTypeName Property

Aspose.Imaging Documentation

CadBaseEntity.LineTypeName Property

Gets or sets the name of the line type.

public string LineTypeName {get; set;}

Property Value

The name of the line type.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LineWeight Property

Aspose.Imaging Documentation

CadBaseEntity.LineWeight Property

Gets or sets the line weight.

public short LineWeight {get; set;}

Property Value

The line weight.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Material Property

Aspose.Imaging Documentation

CadBaseEntity.Material Property

Gets or sets the material.

public string Material {get; set;}

Property Value

The material.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PlotStyle Property

Aspose.Imaging Documentation

CadBaseEntity.PlotStyle Property

Gets or sets the plot style.

public string PlotStyle {get; set;}

Property Value

The plot style.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ProxyBytesCount Property

Aspose.Imaging Documentation

CadBaseEntity.ProxyBytesCount Property

Gets or sets the proxy bytes count.

public int ProxyBytesCount {get; set;}

Property Value

The proxy bytes count.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ProxyData Property

Aspose.Imaging Documentation

CadBaseEntity.ProxyData Property

Gets or sets the proxy data.

public string ProxyData {get; set;}

Property Value

The proxy data.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ShadowMode Property

Aspose.Imaging Documentation

CadBaseEntity.ShadowMode Property

Gets or sets the shadow mode.

public CadShadowMode ShadowMode {get; set;}

Property Value

The shadow mode.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SpaceMode Property

Aspose.Imaging Documentation

CadBaseEntity.SpaceMode Property

Gets or sets the space mode.

public CadEntitySpaceMode SpaceMode {get; set;}

Property Value

The space mode.

Exceptions

Exception Type | Condition
CadException | Space mode is not valid

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Transparency Property

Aspose.Imaging Documentation

CadBaseEntity.Transparency Property

Gets or sets the transparency.

public int Transparency {get; set;}

Property Value

The transparency.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TypeName Property

Aspose.Imaging Documentation

CadBaseEntity.TypeName Property

Gets the name of the type.

public CadEntityTypeName TypeName {get; set;}

Property Value

The name of the type.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Visible Property

Aspose.Imaging Documentation

CadBaseEntity.Visible Property

Gets or sets a value indicating whether this CadBaseEntity is visible.

public short Visible {get; set;}

Property Value

true if visible; otherwise, false.

See Also

CadBaseEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseExtrudedEntity Class

The Cad base extruded entity object.

For a list of all members of this type, see CadBaseExtrudedEntity Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Derived types

public abstract class CadBaseExtrudedEntity : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadBaseExtrudedEntity Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseExtrudedEntity Members

CadBaseExtrudedEntity overview

Public Instance Constructors

CadBaseExtrudedEntity Constructor Initializes a new instance of the CadBaseExtrudedEntity class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtrusionDirection | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBaseExtrudedEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseExtrudedEntity Constructor

Initializes a new instance of the CadBaseExtrudedEntity class.

public CadBaseExtrudedEntity();

See Also

CadBaseExtrudedEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseExtrudedEntity Properties

The properties of the CadBaseExtrudedEntity class are listed below. For a complete list of CadBaseExtrudedEntity class members, see the CadBaseExtrudedEntity Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtrusionDirection | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadBaseExtrudedEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ExtrusionDirection Property

Aspose.Imaging Documentation

CadBaseExtrudedEntity.ExtrusionDirection Property

Gets or sets the extrusion direction.

public Cad3DPoint ExtrusionDirection {get; set;}

See Also

CadBaseExtrudedEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseObject Class

Base class for Cad objects

For a list of all members of this type, see CadBaseObject Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseObject
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPlotSettings

public abstract class CadBaseObject : CadBaseOwned

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadBaseObject Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseObject Members

CadBaseObject overview

Public Instance Constructors

CadBaseObject Constructor Initializes a new instance of the CadBaseObject class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects | Gets or sets the child objects.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
TypeName | Gets the name of the type.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBaseObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseObject Constructor

Initializes a new instance of the CadBaseObject class.

public CadBaseObject();

See Also

CadBaseObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseObject Properties

The properties of the CadBaseObject class are listed below. For a complete list of CadBaseObject class members, see the CadBaseObject Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects | Gets or sets the child objects.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
TypeName | Gets the name of the type.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadBaseObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ChildObjects Property

Aspose.Imaging Documentation

CadBaseObject.ChildObjects Property

Gets or sets the child objects.

public CadBase} ChildObjects {get; set;}

See Also

CadBaseObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TypeName Property

Aspose.Imaging Documentation

CadBaseObject.TypeName Property

Gets the name of the type.

public CadObjectTypeName TypeName {get; set;}

Property Value

The name of the type.

See Also

CadBaseObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseOwned Class

The Cad base owned object.

For a list of all members of this type, see CadBaseOwned Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseObject
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseTable

public abstract class CadBaseOwned : CadBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadBaseOwned Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseOwned Members

CadBaseOwned overview

Public Instance Constructors

CadBaseOwned Constructor Initializes a new instance of the CadBaseOwned class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
HardOwner | Gets or sets the hard owner.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner | Gets or sets the soft owner.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBaseOwned Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseOwned Constructor

Initializes a new instance of the CadBaseOwned class.

public CadBaseOwned();

See Also

CadBaseOwned Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseOwned Properties

The properties of the CadBaseOwned class are listed below. For a complete list of CadBaseOwned class members, see the CadBaseOwned Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
HardOwner | Gets or sets the hard owner.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner | Gets or sets the soft owner.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadBaseOwned Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HardOwner Property

Aspose.Imaging Documentation

CadBaseOwned.HardOwner Property

Gets or sets the hard owner.

public string HardOwner {get; set;}

See Also

CadBaseOwned Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SoftOwner Property

Aspose.Imaging Documentation

CadBaseOwned.SoftOwner Property

Gets or sets the soft owner.

public string SoftOwner {get; set;}

See Also

CadBaseOwned Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseTable Class

The Cad base table object.

For a list of all members of this type, see CadBaseTable Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseTable
Derived types

public class CadBaseTable : CadBaseOwned

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadBaseTable Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseTable Members

CadBaseTable overview

Public Instance Constructors

CadBaseTable Constructor Initializes a new instance of the CadBaseTable class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
MaxTableEntriesCount | Gets or sets the max table entries count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
TableName | Gets or sets the name of the table.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBaseTable Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseTable Constructor

Initializes a new instance of the CadBaseTable class.

public CadBaseTable();

See Also

CadBaseTable Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseTable Properties

The properties of the CadBaseTable class are listed below. For a complete list of CadBaseTable class members, see the CadBaseTable Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
MaxTableEntriesCount | Gets or sets the max table entries count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
TableName | Gets or sets the name of the table.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadBaseTable Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MaxTableEntriesCount Property

Aspose.Imaging Documentation

CadBaseTable.MaxTableEntriesCount Property

Gets or sets the max table entries count.

public short MaxTableEntriesCount {get; set;}

Property Value

The max table entries count.

See Also

CadBaseTable Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TableName Property

Aspose.Imaging Documentation

CadBaseTable.TableName Property

Gets or sets the name of the table.

public string TableName {get; set;}

Property Value

The name of the table.

See Also

CadBaseTable Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBlockEntity Class

The Cad block entity.

For a list of all members of this type, see CadBlockEntity Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBlockEntity

public class CadBlockEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadBlockEntity Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBlockEntity Members

CadBlockEntity overview

Public Instance Constructors

CadBlockEntity Constructor Initializes a new instance of the CadBlockEntity class.

Public Instance Properties

BasePoint | Gets or sets the base point.
Entities | Gets or sets the entities.
Flags | Gets or sets the flags.
Handle | Gets or sets the handle.
Name | Gets or sets the name.
SoftOwner | Gets or sets the soft owner.
XdataContainer | Gets or sets the xdata container.

Public Instance Methods

AddEntity | Adds the entity.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBlockEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBlockEntity Constructor

Initializes a new instance of the CadBlockEntity class.

public CadBlockEntity();

See Also

CadBlockEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBlockEntity Properties

The properties of the CadBlockEntity class are listed below. For a complete list of CadBlockEntity class members, see the CadBlockEntity Members topic.

Public Instance Properties

BasePoint | Gets or sets the base point.
Entities | Gets or sets the entities.
Flags | Gets or sets the flags.
Handle | Gets or sets the handle.
Name | Gets or sets the name.
SoftOwner | Gets or sets the soft owner.
XdataContainer | Gets or sets the xdata container.

See Also

CadBlockEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BasePoint Property

Aspose.Imaging Documentation

CadBlockEntity.BasePoint Property

Gets or sets the base point.

public Cad3DPoint BasePoint {get; set;}

See Also

CadBlockEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Entities Property

Aspose.Imaging Documentation

CadBlockEntity.Entities Property

Gets or sets the entities.

public CadBaseEntity[] Entities {get; set;}

See Also

CadBlockEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Flags Property

Aspose.Imaging Documentation

CadBlockEntity.Flags Property

Gets or sets the flags.

public short Flags {get; set;}

See Also

CadBlockEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Handle Property

Aspose.Imaging Documentation

CadBlockEntity.Handle Property

Gets or sets the handle.

public string Handle {get; set;}

See Also

CadBlockEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Name Property

Aspose.Imaging Documentation

CadBlockEntity.Name Property

Gets or sets the name.

public string Name {get; set;}

See Also

CadBlockEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SoftOwner Property

Aspose.Imaging Documentation

CadBlockEntity.SoftOwner Property

Gets or sets the soft owner.

public string SoftOwner {get; set;}

Property Value

The soft owner.

See Also

CadBlockEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


XdataContainer Property

Aspose.Imaging Documentation

CadBlockEntity.XdataContainer Property

Gets or sets the xdata container.

public CadXdataContainer XdataContainer {get; set;}

Property Value

The xdata container.

See Also

CadBlockEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBlockEntity Methods

The methods of the CadBlockEntity class are listed below. For a complete list of CadBlockEntity class members, see the CadBlockEntity Members topic.

Public Instance Methods

AddEntity | Adds the entity.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBlockEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBlockEntity.AddEntity Method

Adds the entity.

public void AddEntity(
CadBaseEntity entityObject
);

Parameters

entityObject
The entity object.

See Also

CadBlockEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCallout Class

Class describing Cad callout for CadConsts.CadSubClassName.LEADER type

For a list of all members of this type, see CadCallout Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadCallout

public class CadCallout : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadCallout Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCallout Members

CadCallout overview

Public Instance Constructors

CadCallout Constructor Initializes a new instance of the CadCallout class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
ArrowheadID | Gets or sets the arrowhead ID.
ArrowheadIndex | Gets or sets the index of the arrowhead.
ArrowheadSize | Gets or sets the size of the arrowhead.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockAttributeIndex | Gets or sets the index of the block attribute.
BlockAttributerId | Gets or sets the block attributer id.
BlockAttributeWidth | Gets or sets the width of the block attribute.
BlockbAttributeTextString | Gets or sets the blockb attribute text string.
BlockContentColor | Gets or sets the color of the block content.
BlockContentConnectionType | Gets or sets the type of the block content connection.
BlockContentID | Gets or sets the block content ID.
BlockContentRotation | Gets or sets the block content rotation.
BlockContentScale | Gets or sets the block content scale.
BottomTextAttachmentDirection | Gets or sets the bottom text attachment direction.
CalloutData | Gets or sets the callout data.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ContentType | Gets or sets the type of the content.
DoglegLength | Gets or sets the length of the dogleg.
EnableAnnotationScale | Gets or sets a value indicating whether [enable annotation scale].
EnableDogleg | Gets or sets a value indicating whether [enable dogleg].
EnableFrameText | Gets or sets a value indicating whether [enable frame text].
EnableLanding | Gets or sets a value indicating whether [enable landing].
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LeaderLineColor | Gets or sets the color of the leader line.
LeaderLineType | Gets or sets the type of the leader line.
LeaderLineTypeID | Gets or sets the leader line type ID.
LeaderLineWeight | Gets or sets the leader line weight.
LeaderStyleId | Gets or sets the leader style id.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
NewArrowheadID | Gets or sets the new arrowhead ID.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
PropertyOverrideFlag | Gets or sets the property override flag.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
TextAligninIpe | Gets or sets the text alignin ipe.
TextAlignmentType | Gets or sets the type of the text alignment.
TextAngleType | Gets or sets the type of the text angle.
TextAttachmentDirection | Gets or sets the text attachment direction.
TextAttachmentPoint | Gets or sets the text attachment point.
TextColor | Gets or sets the color of the text.
TextDirectionNegative | Gets or sets a value indicating whether [text direction negative].
TextLeftAttachmentType | Gets or sets the type of the text left attachment.
TextRightAttachmentType | Gets or sets the type of the text right attachement.
TextStyleID | Gets or sets the text style ID.
TopTextAttachmentDirection | Gets or sets the top text attachment direction.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCallout Constructor

Initializes a new instance of the CadCallout class.

public CadCallout();

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCallout Properties

The properties of the CadCallout class are listed below. For a complete list of CadCallout class members, see the CadCallout Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
ArrowheadID | Gets or sets the arrowhead ID.
ArrowheadIndex | Gets or sets the index of the arrowhead.
ArrowheadSize | Gets or sets the size of the arrowhead.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockAttributeIndex | Gets or sets the index of the block attribute.
BlockAttributerId | Gets or sets the block attributer id.
BlockAttributeWidth | Gets or sets the width of the block attribute.
BlockbAttributeTextString | Gets or sets the blockb attribute text string.
BlockContentColor | Gets or sets the color of the block content.
BlockContentConnectionType | Gets or sets the type of the block content connection.
BlockContentID | Gets or sets the block content ID.
BlockContentRotation | Gets or sets the block content rotation.
BlockContentScale | Gets or sets the block content scale.
BottomTextAttachmentDirection | Gets or sets the bottom text attachment direction.
CalloutData | Gets or sets the callout data.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ContentType | Gets or sets the type of the content.
DoglegLength | Gets or sets the length of the dogleg.
EnableAnnotationScale | Gets or sets a value indicating whether [enable annotation scale].
EnableDogleg | Gets or sets a value indicating whether [enable dogleg].
EnableFrameText | Gets or sets a value indicating whether [enable frame text].
EnableLanding | Gets or sets a value indicating whether [enable landing].
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LeaderLineColor | Gets or sets the color of the leader line.
LeaderLineType | Gets or sets the type of the leader line.
LeaderLineTypeID | Gets or sets the leader line type ID.
LeaderLineWeight | Gets or sets the leader line weight.
LeaderStyleId | Gets or sets the leader style id.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
NewArrowheadID | Gets or sets the new arrowhead ID.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
PropertyOverrideFlag | Gets or sets the property override flag.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
TextAligninIpe | Gets or sets the text alignin ipe.
TextAlignmentType | Gets or sets the type of the text alignment.
TextAngleType | Gets or sets the type of the text angle.
TextAttachmentDirection | Gets or sets the text attachment direction.
TextAttachmentPoint | Gets or sets the text attachment point.
TextColor | Gets or sets the color of the text.
TextDirectionNegative | Gets or sets a value indicating whether [text direction negative].
TextLeftAttachmentType | Gets or sets the type of the text left attachment.
TextRightAttachmentType | Gets or sets the type of the text right attachement.
TextStyleID | Gets or sets the text style ID.
TopTextAttachmentDirection | Gets or sets the top text attachment direction.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ArrowheadID Property

Aspose.Imaging Documentation

CadCallout.ArrowheadID Property

Gets or sets the arrowhead ID.

public string ArrowheadID {get; set;}

Property Value

The arrowhead ID.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ArrowheadIndex Property

Aspose.Imaging Documentation

CadCallout.ArrowheadIndex Property

Gets or sets the index of the arrowhead.

public int ArrowheadIndex {get; set;}

Property Value

The index of the arrowhead.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ArrowheadSize Property

Aspose.Imaging Documentation

CadCallout.ArrowheadSize Property

Gets or sets the size of the arrowhead.

public double ArrowheadSize {get; set;}

Property Value

The size of the arrowhead.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockAttributeIndex Property

Aspose.Imaging Documentation

CadCallout.BlockAttributeIndex Property

Gets or sets the index of the block attribute.

public int BlockAttributeIndex {get; set;}

Property Value

The index of the block attribute.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockAttributerId Property

Aspose.Imaging Documentation

CadCallout.BlockAttributerId Property

Gets or sets the block attributer id.

public string BlockAttributerId {get; set;}

Property Value

The block attributer id.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockAttributeWidth Property

Aspose.Imaging Documentation

CadCallout.BlockAttributeWidth Property

Gets or sets the width of the block attribute.

public double BlockAttributeWidth {get; set;}

Property Value

The width of the block attribute.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockbAttributeTextString Property

Aspose.Imaging Documentation

CadCallout.BlockbAttributeTextString Property

Gets or sets the blockb attribute text string.

public string BlockbAttributeTextString {get; set;}

Property Value

The blockb attribute text string.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockContentColor Property

Aspose.Imaging Documentation

CadCallout.BlockContentColor Property

Gets or sets the color of the block content.

public int BlockContentColor {get; set;}

Property Value

The color of the block content.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockContentConnectionType Property

Aspose.Imaging Documentation

CadCallout.BlockContentConnectionType Property

Gets or sets the type of the block content connection.

public int BlockContentConnectionType {get; set;}

Property Value

The type of the block content connection.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockContentID Property

Aspose.Imaging Documentation

CadCallout.BlockContentID Property

Gets or sets the block content ID.

public string BlockContentID {get; set;}

Property Value

The block content ID.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockContentRotation Property

Aspose.Imaging Documentation

CadCallout.BlockContentRotation Property

Gets or sets the block content rotation.

public double BlockContentRotation {get; set;}

Property Value

The block content rotation.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockContentScale Property

Aspose.Imaging Documentation

CadCallout.BlockContentScale Property

Gets or sets the block content scale.

public double BlockContentScale {get; set;}

Property Value

The block content scale.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BottomTextAttachmentDirection Property

Aspose.Imaging Documentation

CadCallout.BottomTextAttachmentDirection Property

Gets or sets the bottom text attachment direction.

public int BottomTextAttachmentDirection {get; set;}

Property Value

The bottom text attachment direction.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CalloutData Property

Aspose.Imaging Documentation

CadCallout.CalloutData Property

Gets or sets the callout data.

public CadCalloutData CalloutData {get; set;}

Property Value

The callout data.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ContentType Property

Aspose.Imaging Documentation

CadCallout.ContentType Property

Gets or sets the type of the content.

public int ContentType {get; set;}

Property Value

The type of the content.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DoglegLength Property

Aspose.Imaging Documentation

CadCallout.DoglegLength Property

Gets or sets the length of the dogleg.

public double DoglegLength {get; set;}

Property Value

The length of the dogleg.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


EnableAnnotationScale Property

Aspose.Imaging Documentation

CadCallout.EnableAnnotationScale Property

Gets or sets a value indicating whether [enable annotation scale].

public bool EnableAnnotationScale {get; set;}

Property Value

true if [enable annotation scale]; otherwise, false.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


EnableDogleg Property

Aspose.Imaging Documentation

CadCallout.EnableDogleg Property

Gets or sets a value indicating whether [enable dogleg].

public bool EnableDogleg {get; set;}

Property Value

true if [enable dogleg]; otherwise, false.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


EnableFrameText Property

Aspose.Imaging Documentation

CadCallout.EnableFrameText Property

Gets or sets a value indicating whether [enable frame text].

public bool EnableFrameText {get; set;}

Property Value

true if [enable frame text]; otherwise, false.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


EnableLanding Property

Aspose.Imaging Documentation

CadCallout.EnableLanding Property

Gets or sets a value indicating whether [enable landing].

public bool EnableLanding {get; set;}

Property Value

true if [enable landing]; otherwise, false.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LeaderLineColor Property

Aspose.Imaging Documentation

CadCallout.LeaderLineColor Property

Gets or sets the color of the leader line.

public int LeaderLineColor {get; set;}

Property Value

The color of the leader line.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LeaderLineType Property

Aspose.Imaging Documentation

CadCallout.LeaderLineType Property

Gets or sets the type of the leader line.

public int LeaderLineType {get; set;}

Property Value

The type of the leader line.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LeaderLineTypeID Property

Aspose.Imaging Documentation

CadCallout.LeaderLineTypeID Property

Gets or sets the leader line type ID.

public string LeaderLineTypeID {get; set;}

Property Value

The leader line type ID.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LeaderLineWeight Property

Aspose.Imaging Documentation

CadCallout.LeaderLineWeight Property

Gets or sets the leader line weight.

public int LeaderLineWeight {get; set;}

Property Value

The leader line weight.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LeaderStyleId Property

Aspose.Imaging Documentation

CadCallout.LeaderStyleId Property

Gets or sets the leader style id.

public string LeaderStyleId {get; set;}

Property Value

The leader style id.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


NewArrowheadID Property

Aspose.Imaging Documentation

CadCallout.NewArrowheadID Property

Gets or sets the new arrowhead ID.

public string NewArrowheadID {get; set;}

Property Value

The new arrowhead ID.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PropertyOverrideFlag Property

Aspose.Imaging Documentation

CadCallout.PropertyOverrideFlag Property

Gets or sets the property override flag.

public int PropertyOverrideFlag {get; set;}

Property Value

The property override flag.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextAligninIpe Property

Aspose.Imaging Documentation

CadCallout.TextAligninIpe Property

Gets or sets the text alignin ipe.

public int TextAligninIpe {get; set;}

Property Value

The text alignin ipe.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextAlignmentType Property

Aspose.Imaging Documentation

CadCallout.TextAlignmentType Property

Gets or sets the type of the text alignment.

public int TextAlignmentType {get; set;}

Property Value

The type of the text alignment.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextAngleType Property

Aspose.Imaging Documentation

CadCallout.TextAngleType Property

Gets or sets the type of the text angle.

public int TextAngleType {get; set;}

Property Value

The type of the text angle.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextAttachmentDirection Property

Aspose.Imaging Documentation

CadCallout.TextAttachmentDirection Property

Gets or sets the text attachment direction.

public int TextAttachmentDirection {get; set;}

Property Value

The text attachment direction.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextAttachmentPoint Property

Aspose.Imaging Documentation

CadCallout.TextAttachmentPoint Property

Gets or sets the text attachment point.

public int TextAttachmentPoint {get; set;}

Property Value

The text attachment point.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextColor Property

Aspose.Imaging Documentation

CadCallout.TextColor Property

Gets or sets the color of the text.

public int TextColor {get; set;}

Property Value

The color of the text.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextDirectionNegative Property

Aspose.Imaging Documentation

CadCallout.TextDirectionNegative Property

Gets or sets a value indicating whether [text direction negative].

public bool TextDirectionNegative {get; set;}

Property Value

true if [text direction negative]; otherwise, false.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextLeftAttachmentType Property

Aspose.Imaging Documentation

CadCallout.TextLeftAttachmentType Property

Gets or sets the type of the text left attachment.

public int TextLeftAttachmentType {get; set;}

Property Value

The type of the text left attachment.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextRightAttachmentType Property

Aspose.Imaging Documentation

CadCallout.TextRightAttachmentType Property

Gets or sets the type of the text right attachement.

public int TextRightAttachmentType {get; set;}

Property Value

The type of the text right attachement.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextStyleID Property

Aspose.Imaging Documentation

CadCallout.TextStyleID Property

Gets or sets the text style ID.

public string TextStyleID {get; set;}

Property Value

The text style ID.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TopTextAttachmentDirection Property

Aspose.Imaging Documentation

CadCallout.TopTextAttachmentDirection Property

Gets or sets the top text attachment direction.

public int TopTextAttachmentDirection {get; set;}

Property Value

The top text attachment direction.

See Also

CadCallout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCalloutData Class

Class describing Cad ARC

For a list of all members of this type, see CadCalloutData Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadCalloutData

public class CadCalloutData : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadCalloutData Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCalloutData Members

CadCalloutData overview

Public Instance Constructors

CadCalloutData Constructor Initializes a new instance of the CadCalloutData class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockContentColor | Gets or sets the color of the block content.
BlockContentID | Gets or sets the block content ID.
BlockContentNormalDirection | Gets or sets the block content normal direction.
BlockContentPosition | Gets or sets the block content position.
BlockContentRotation | Gets or sets the block content rotation.
BlockContentScale | Gets or sets the block content scale.
BlockTransformationMatrix | Gets or sets the block transformation matrix.
BreakPointIndex | Gets or sets the index of the break point.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ContentBasePosition | Gets or sets the content base position.
ContentScale | Gets or sets the content scale.
Data1TextHeight | Gets or sets the height of the data1 text.
DataArrowheadSize | Gets or sets the size of the data arrowhead.
DataBlockContentColor | Gets or sets the color of the data block content.
DataBlockContentID | Gets or sets the data block content ID.
DataBlockContentNormalDirection | Gets or sets the data block content normal direction.
DataBlockContentPosition | Gets or sets the data block content position.
DataBlockContentRotation | Gets or sets the data block content rotation.
DataBlockContentScale | Gets or sets the data block content scale.
DataBlockTransformationMatrix | Gets or sets the data block transformation matrix.
DataHasBlock | Gets or sets a value indicating whether [data has block].
DataIsTextBackgroundColorOn | Gets or sets a value indicating whether [data is text background color on].
DataIsTextBackgroundFillOn | Gets or sets a value indicating whether [data is text background fill on].
DataMleaderPlaneNormalReversed | Gets or sets a value indicating whether [data mleader plane normal reversed].
DataMleaderPlaneOriginPoint | Gets or sets the data mleader plane origin point.
DataMleaderPlaneXAxisDirection | Gets or sets the data mleader plane X axis direction.
DataMleaderPlaneYAxisDirection | Gets or sets the data mleader plane Y axis direction.
DataMLeaderPlaneYAxisDirection | Gets or sets the data M leader plane Y axis direction.
DataTextAttachment | Gets or sets the data text attachment.
DataTextBackgroundColor | Gets or sets the color of the data text background.
DataTextBackgroundScaleFactor | Gets or sets the data text background scale factor.
DataTextBackgroundTransparency | Gets or sets the data text background transparency.
DataTextColor | Gets or sets the color of the data text.
DataTextColumnFlowReversed | Gets or sets a value indicating whether [data text column flow reversed].
DataTextColumnGutterWidth | Gets or sets the width of the data text column gutter.
DataTextColumnHeight | Gets or sets the height of the data text column.
DataTextColumnType | Gets or sets the type of the data text column.
DataTextColumnWidth | Gets or sets the width of the data text column.
DataTextFlowDirection | Gets or sets the data text flow direction.
DataTextHeight | Gets or sets the height of the data text.
DataTextLineSpacingFactor | Gets or sets the data text line spacing factor.
DataTextLineSpacingStyle | Gets or sets the data text line spacing style.
DataTextUseWordBreak | Gets or sets a value indicating whether [data text use word break].
DataTextWidth | Gets or sets the width of the data text.
DataUseTextAutoHeight | Gets or sets a value indicating whether [data use text auto height].
DefaultTextContents | Gets or sets the default text contents.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HasBlock | Gets or sets a value indicating whether this instance has block.
HasMText | Gets or sets a value indicating whether this instance has M text.
LandingGap | Gets or sets the landing gap.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
Leader | Gets or sets the leader.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MLeaderPlaneNormalReversed | Gets or sets a value indicating whether [M leader plane normal reversed].
MLeaderPlaneOriginPoint | Gets or sets the M leader plane origin point.
MLeaderPlaneXAxisDirection | Gets or sets the M leader plane X axis direction.
MLeaderPlaneYAxisDirection | Gets or sets the M leader plane Y axis direction.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
TextAttachment | Gets or sets the text attachment.
TextBackgroundColor | Gets or sets the color of the text background.
TextBackgroundColorOn | Gets or sets a value indicating whether this instance is text background color on.
TextBackgroundFillOn | Gets or sets a value indicating whether this instance is text background fill on.
TextBackgroundScaleFactor | Gets or sets the text background scale factor.
TextBackgroundTransparency | Gets or sets the text background transparency.
TextColor | Gets or sets the color of the text.
TextColumnFlowReversed | Gets or sets a value indicating whether [text column flow reversed].
TextColumnGutterWidth | Gets or sets the width of the text column gutter.
TextColumnHeight | Gets or sets the height of the text column.
TextColumnType | Gets or sets the type of the text column.
TextColumnWidth | Gets or sets the width of the text column.
TextDirection | Gets or sets the text direction.
TextFlowDirection | Gets or sets the text flow direction.
TextHeight | Gets or sets the height of the text.
TextLineSpacingFactor | Gets or sets the text line spacing factor.
TextLineSpacingStyle | Gets or sets the text line spacing style.
TextLocation | Gets or sets the text location.
TextNormalDirection | Gets or sets the text normal direction.
TextRotation | Gets or sets the text rotation.
TextStyleID | Gets or sets the text style ID.
TextUseWordBreak | Gets or sets a value indicating whether [text use word break].
TextWidth | Gets or sets the width of the text.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
UseTextAutoHeight | Gets or sets a value indicating whether [use text auto height].
Vertex | Gets or sets the vertex.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCalloutData Constructor

Initializes a new instance of the CadCalloutData class.

public CadCalloutData();

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCalloutData Properties

The properties of the CadCalloutData class are listed below. For a complete list of CadCalloutData class members, see the CadCalloutData Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockContentColor | Gets or sets the color of the block content.
BlockContentID | Gets or sets the block content ID.
BlockContentNormalDirection | Gets or sets the block content normal direction.
BlockContentPosition | Gets or sets the block content position.
BlockContentRotation | Gets or sets the block content rotation.
BlockContentScale | Gets or sets the block content scale.
BlockTransformationMatrix | Gets or sets the block transformation matrix.
BreakPointIndex | Gets or sets the index of the break point.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ContentBasePosition | Gets or sets the content base position.
ContentScale | Gets or sets the content scale.
Data1TextHeight | Gets or sets the height of the data1 text.
DataArrowheadSize | Gets or sets the size of the data arrowhead.
DataBlockContentColor | Gets or sets the color of the data block content.
DataBlockContentID | Gets or sets the data block content ID.
DataBlockContentNormalDirection | Gets or sets the data block content normal direction.
DataBlockContentPosition | Gets or sets the data block content position.
DataBlockContentRotation | Gets or sets the data block content rotation.
DataBlockContentScale | Gets or sets the data block content scale.
DataBlockTransformationMatrix | Gets or sets the data block transformation matrix.
DataHasBlock | Gets or sets a value indicating whether [data has block].
DataIsTextBackgroundColorOn | Gets or sets a value indicating whether [data is text background color on].
DataIsTextBackgroundFillOn | Gets or sets a value indicating whether [data is text background fill on].
DataMleaderPlaneNormalReversed | Gets or sets a value indicating whether [data mleader plane normal reversed].
DataMleaderPlaneOriginPoint | Gets or sets the data mleader plane origin point.
DataMleaderPlaneXAxisDirection | Gets or sets the data mleader plane X axis direction.
DataMleaderPlaneYAxisDirection | Gets or sets the data mleader plane Y axis direction.
DataMLeaderPlaneYAxisDirection | Gets or sets the data M leader plane Y axis direction.
DataTextAttachment | Gets or sets the data text attachment.
DataTextBackgroundColor | Gets or sets the color of the data text background.
DataTextBackgroundScaleFactor | Gets or sets the data text background scale factor.
DataTextBackgroundTransparency | Gets or sets the data text background transparency.
DataTextColor | Gets or sets the color of the data text.
DataTextColumnFlowReversed | Gets or sets a value indicating whether [data text column flow reversed].
DataTextColumnGutterWidth | Gets or sets the width of the data text column gutter.
DataTextColumnHeight | Gets or sets the height of the data text column.
DataTextColumnType | Gets or sets the type of the data text column.
DataTextColumnWidth | Gets or sets the width of the data text column.
DataTextFlowDirection | Gets or sets the data text flow direction.
DataTextHeight | Gets or sets the height of the data text.
DataTextLineSpacingFactor | Gets or sets the data text line spacing factor.
DataTextLineSpacingStyle | Gets or sets the data text line spacing style.
DataTextUseWordBreak | Gets or sets a value indicating whether [data text use word break].
DataTextWidth | Gets or sets the width of the data text.
DataUseTextAutoHeight | Gets or sets a value indicating whether [data use text auto height].
DefaultTextContents | Gets or sets the default text contents.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HasBlock | Gets or sets a value indicating whether this instance has block.
HasMText | Gets or sets a value indicating whether this instance has M text.
LandingGap | Gets or sets the landing gap.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
Leader | Gets or sets the leader.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MLeaderPlaneNormalReversed | Gets or sets a value indicating whether [M leader plane normal reversed].
MLeaderPlaneOriginPoint | Gets or sets the M leader plane origin point.
MLeaderPlaneXAxisDirection | Gets or sets the M leader plane X axis direction.
MLeaderPlaneYAxisDirection | Gets or sets the M leader plane Y axis direction.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
TextAttachment | Gets or sets the text attachment.
TextBackgroundColor | Gets or sets the color of the text background.
TextBackgroundColorOn | Gets or sets a value indicating whether this instance is text background color on.
TextBackgroundFillOn | Gets or sets a value indicating whether this instance is text background fill on.
TextBackgroundScaleFactor | Gets or sets the text background scale factor.
TextBackgroundTransparency | Gets or sets the text background transparency.
TextColor | Gets or sets the color of the text.
TextColumnFlowReversed | Gets or sets a value indicating whether [text column flow reversed].
TextColumnGutterWidth | Gets or sets the width of the text column gutter.
TextColumnHeight | Gets or sets the height of the text column.
TextColumnType | Gets or sets the type of the text column.
TextColumnWidth | Gets or sets the width of the text column.
TextDirection | Gets or sets the text direction.
TextFlowDirection | Gets or sets the text flow direction.
TextHeight | Gets or sets the height of the text.
TextLineSpacingFactor | Gets or sets the text line spacing factor.
TextLineSpacingStyle | Gets or sets the text line spacing style.
TextLocation | Gets or sets the text location.
TextNormalDirection | Gets or sets the text normal direction.
TextRotation | Gets or sets the text rotation.
TextStyleID | Gets or sets the text style ID.
TextUseWordBreak | Gets or sets a value indicating whether [text use word break].
TextWidth | Gets or sets the width of the text.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
UseTextAutoHeight | Gets or sets a value indicating whether [use text auto height].
Vertex | Gets or sets the vertex.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockContentColor Property

Aspose.Imaging Documentation

CadCalloutData.BlockContentColor Property

Gets or sets the color of the block content.

public int BlockContentColor {get; set;}

Property Value

The color of the block content.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockContentID Property

Aspose.Imaging Documentation

CadCalloutData.BlockContentID Property

Gets or sets the block content ID.

public string BlockContentID {get; set;}

Property Value

The block content ID.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockContentNormalDirection Property

Aspose.Imaging Documentation

CadCalloutData.BlockContentNormalDirection Property

Gets or sets the block content normal direction.

public Cad3DPoint BlockContentNormalDirection {get; set;}

Property Value

The block content normal direction.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockContentPosition Property

Aspose.Imaging Documentation

CadCalloutData.BlockContentPosition Property

Gets or sets the block content position.

public Cad3DPoint BlockContentPosition {get; set;}

Property Value

The block content position.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockContentRotation Property

Aspose.Imaging Documentation

CadCalloutData.BlockContentRotation Property

Gets or sets the block content rotation.

public double BlockContentRotation {get; set;}

Property Value

The block content rotation.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockContentScale Property

Aspose.Imaging Documentation

CadCalloutData.BlockContentScale Property

Gets or sets the block content scale.

public double BlockContentScale {get; set;}

Property Value

The block content scale.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockTransformationMatrix Property

Aspose.Imaging Documentation

CadCalloutData.BlockTransformationMatrix Property

Gets or sets the block transformation matrix.

public int BlockTransformationMatrix {get; set;}

Property Value

The block transformation matrix.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BreakPointIndex Property

Aspose.Imaging Documentation

CadCalloutData.BreakPointIndex Property

Gets or sets the index of the break point.

public int BreakPointIndex {get; set;}

Property Value

The index of the break point.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ContentBasePosition Property

Aspose.Imaging Documentation

CadCalloutData.ContentBasePosition Property

Gets or sets the content base position.

public Cad3DPoint ContentBasePosition {get; set;}

Property Value

The content base position.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ContentScale Property

Aspose.Imaging Documentation

CadCalloutData.ContentScale Property

Gets or sets the content scale.

public double ContentScale {get; set;}

Property Value

The content scale.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Data1TextHeight Property

Aspose.Imaging Documentation

CadCalloutData.Data1TextHeight Property

Gets or sets the height of the data1 text.

public double Data1TextHeight {get; set;}

Property Value

The height of the data1 text.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataArrowheadSize Property

Aspose.Imaging Documentation

CadCalloutData.DataArrowheadSize Property

Gets or sets the size of the data arrowhead.

public double DataArrowheadSize {get; set;}

Property Value

The size of the data arrowhead.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataBlockContentColor Property

Aspose.Imaging Documentation

CadCalloutData.DataBlockContentColor Property

Gets or sets the color of the data block content.

public int DataBlockContentColor {get; set;}

Property Value

The color of the data block content.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataBlockContentID Property

Aspose.Imaging Documentation

CadCalloutData.DataBlockContentID Property

Gets or sets the data block content ID.

public string DataBlockContentID {get; set;}

Property Value

The data block content ID.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataBlockContentNormalDirection Property

Aspose.Imaging Documentation

CadCalloutData.DataBlockContentNormalDirection Property

Gets or sets the data block content normal direction.

public Cad3DPoint DataBlockContentNormalDirection {get; set;}

Property Value

The data block content normal direction.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataBlockContentPosition Property

Aspose.Imaging Documentation

CadCalloutData.DataBlockContentPosition Property

Gets or sets the data block content position.

public Cad3DPoint DataBlockContentPosition {get; set;}

Property Value

The data block content position.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataBlockContentRotation Property

Aspose.Imaging Documentation

CadCalloutData.DataBlockContentRotation Property

Gets or sets the data block content rotation.

public double DataBlockContentRotation {get; set;}

Property Value

The data block content rotation.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataBlockContentScale Property

Aspose.Imaging Documentation

CadCalloutData.DataBlockContentScale Property

Gets or sets the data block content scale.

public double DataBlockContentScale {get; set;}

Property Value

The data block content scale.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataBlockTransformationMatrix Property

Aspose.Imaging Documentation

CadCalloutData.DataBlockTransformationMatrix Property

Gets or sets the data block transformation matrix.

public double DataBlockTransformationMatrix {get; set;}

Property Value

The data block transformation matrix.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataHasBlock Property

Aspose.Imaging Documentation

CadCalloutData.DataHasBlock Property

Gets or sets a value indicating whether [data has block].

public bool DataHasBlock {get; set;}

Property Value

true if [data has block]; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataIsTextBackgroundColorOn Property

Aspose.Imaging Documentation

CadCalloutData.DataIsTextBackgroundColorOn Property

Gets or sets a value indicating whether [data is text background color on].

public bool DataIsTextBackgroundColorOn {get; set;}

Property Value

true if [data is text background color on]; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataIsTextBackgroundFillOn Property

Aspose.Imaging Documentation

CadCalloutData.DataIsTextBackgroundFillOn Property

Gets or sets a value indicating whether [data is text background fill on].

public bool DataIsTextBackgroundFillOn {get; set;}

Property Value

true if [data is text background fill on]; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataMleaderPlaneNormalReversed Property

Aspose.Imaging Documentation

CadCalloutData.DataMleaderPlaneNormalReversed Property

Gets or sets a value indicating whether [data mleader plane normal reversed].

public bool DataMleaderPlaneNormalReversed {get; set;}

Property Value

true if [data mleader plane normal reversed]; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataMleaderPlaneOriginPoint Property

Aspose.Imaging Documentation

CadCalloutData.DataMleaderPlaneOriginPoint Property

Gets or sets the data mleader plane origin point.

public double DataMleaderPlaneOriginPoint {get; set;}

Property Value

The data mleader plane origin point.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataMleaderPlaneXAxisDirection Property

Aspose.Imaging Documentation

CadCalloutData.DataMleaderPlaneXAxisDirection Property

Gets or sets the data mleader plane X axis direction.

public double DataMleaderPlaneXAxisDirection {get; set;}

Property Value

The data mleader plane X axis direction.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataMLeaderPlaneYAxisDirection Property

Aspose.Imaging Documentation

CadCalloutData.DataMLeaderPlaneYAxisDirection Property

Gets or sets the data M leader plane Y axis direction.

public double DataMLeaderPlaneYAxisDirection {get; set;}

Property Value

The data M leader plane Y axis direction.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextAttachment Property

Aspose.Imaging Documentation

CadCalloutData.DataTextAttachment Property

Gets or sets the data text attachment.

public int DataTextAttachment {get; set;}

Property Value

The data text attachment.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextBackgroundColor Property

Aspose.Imaging Documentation

CadCalloutData.DataTextBackgroundColor Property

Gets or sets the color of the data text background.

public int DataTextBackgroundColor {get; set;}

Property Value

The color of the data text background.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextBackgroundScaleFactor Property

Aspose.Imaging Documentation

CadCalloutData.DataTextBackgroundScaleFactor Property

Gets or sets the data text background scale factor.

public double DataTextBackgroundScaleFactor {get; set;}

Property Value

The data text background scale factor.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextBackgroundTransparency Property

Aspose.Imaging Documentation

CadCalloutData.DataTextBackgroundTransparency Property

Gets or sets the data text background transparency.

public int DataTextBackgroundTransparency {get; set;}

Property Value

The data text background transparency.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextColor Property

Aspose.Imaging Documentation

CadCalloutData.DataTextColor Property

Gets or sets the color of the data text.

public int DataTextColor {get; set;}

Property Value

The color of the data text.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextColumnFlowReversed Property

Aspose.Imaging Documentation

CadCalloutData.DataTextColumnFlowReversed Property

Gets or sets a value indicating whether [data text column flow reversed].

public bool DataTextColumnFlowReversed {get; set;}

Property Value

true if [data text column flow reversed]; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextColumnGutterWidth Property

Aspose.Imaging Documentation

CadCalloutData.DataTextColumnGutterWidth Property

Gets or sets the width of the data text column gutter.

public double DataTextColumnGutterWidth {get; set;}

Property Value

The width of the data text column gutter.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextColumnHeight Property

Aspose.Imaging Documentation

CadCalloutData.DataTextColumnHeight Property

Gets or sets the height of the data text column.

public double DataTextColumnHeight {get; set;}

Property Value

The height of the data text column.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextColumnType Property

Aspose.Imaging Documentation

CadCalloutData.DataTextColumnType Property

Gets or sets the type of the data text column.

public int DataTextColumnType {get; set;}

Property Value

The type of the data text column.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextColumnWidth Property

Aspose.Imaging Documentation

CadCalloutData.DataTextColumnWidth Property

Gets or sets the width of the data text column.

public double DataTextColumnWidth {get; set;}

Property Value

The width of the data text column.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextFlowDirection Property

Aspose.Imaging Documentation

CadCalloutData.DataTextFlowDirection Property

Gets or sets the data text flow direction.

public int DataTextFlowDirection {get; set;}

Property Value

The data text flow direction.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextHeight Property

Aspose.Imaging Documentation

CadCalloutData.DataTextHeight Property

Gets or sets the height of the data text.

public double DataTextHeight {get; set;}

Property Value

The height of the data text.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextLineSpacingFactor Property

Aspose.Imaging Documentation

CadCalloutData.DataTextLineSpacingFactor Property

Gets or sets the data text line spacing factor.

public double DataTextLineSpacingFactor {get; set;}

Property Value

The data text line spacing factor.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextLineSpacingStyle Property

Aspose.Imaging Documentation

CadCalloutData.DataTextLineSpacingStyle Property

Gets or sets the data text line spacing style.

public int DataTextLineSpacingStyle {get; set;}

Property Value

The data text line spacing style.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextUseWordBreak Property

Aspose.Imaging Documentation

CadCalloutData.DataTextUseWordBreak Property

Gets or sets a value indicating whether [data text use word break].

public bool DataTextUseWordBreak {get; set;}

Property Value

true if [data text use word break]; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataTextWidth Property

Aspose.Imaging Documentation

CadCalloutData.DataTextWidth Property

Gets or sets the width of the data text.

public double DataTextWidth {get; set;}

Property Value

The width of the data text.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataUseTextAutoHeight Property

Aspose.Imaging Documentation

CadCalloutData.DataUseTextAutoHeight Property

Gets or sets a value indicating whether [data use text auto height].

public bool DataUseTextAutoHeight {get; set;}

Property Value

true if [data use text auto height]; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DefaultTextContents Property

Aspose.Imaging Documentation

CadCalloutData.DefaultTextContents Property

Gets or sets the default text contents.

public string DefaultTextContents {get; set;}

Property Value

The default text contents.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HasBlock Property

Aspose.Imaging Documentation

CadCalloutData.HasBlock Property

Gets or sets a value indicating whether this instance has block.

public bool HasBlock {get; set;}

Property Value

true if this instance has block; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HasMText Property

Aspose.Imaging Documentation

CadCalloutData.HasMText Property

Gets or sets a value indicating whether this instance has M text.

public bool HasMText {get; set;}

Property Value

true if this instance has M text; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LandingGap Property

Aspose.Imaging Documentation

CadCalloutData.LandingGap Property

Gets or sets the landing gap.

public double LandingGap {get; set;}

Property Value

The landing gap.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Leader Property

Aspose.Imaging Documentation

CadCalloutData.Leader Property

Gets or sets the leader.

public CadCalloutLeader Leader {get; set;}

Property Value

The leader.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MLeaderPlaneNormalReversed Property

Aspose.Imaging Documentation

CadCalloutData.MLeaderPlaneNormalReversed Property

Gets or sets a value indicating whether [M leader plane normal reversed].

public bool MLeaderPlaneNormalReversed {get; set;}

Property Value

true if [M leader plane normal reversed]; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MLeaderPlaneOriginPoint Property

Aspose.Imaging Documentation

CadCalloutData.MLeaderPlaneOriginPoint Property

Gets or sets the M leader plane origin point.

public double MLeaderPlaneOriginPoint {get; set;}

Property Value

The M leader plane origin point.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MLeaderPlaneXAxisDirection Property

Aspose.Imaging Documentation

CadCalloutData.MLeaderPlaneXAxisDirection Property

Gets or sets the M leader plane X axis direction.

public double MLeaderPlaneXAxisDirection {get; set;}

Property Value

The M leader plane X axis direction.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MLeaderPlaneYAxisDirection Property

Aspose.Imaging Documentation

CadCalloutData.MLeaderPlaneYAxisDirection Property

Gets or sets the M leader plane Y axis direction.

public double MLeaderPlaneYAxisDirection {get; set;}

Property Value

The M leader plane Y axis direction.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextAttachment Property

Aspose.Imaging Documentation

CadCalloutData.TextAttachment Property

Gets or sets the text attachment.

public int TextAttachment {get; set;}

Property Value

The text attachment.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextBackgroundColor Property

Aspose.Imaging Documentation

CadCalloutData.TextBackgroundColor Property

Gets or sets the color of the text background.

public int TextBackgroundColor {get; set;}

Property Value

The color of the text background.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextBackgroundColorOn Property

Aspose.Imaging Documentation

CadCalloutData.TextBackgroundColorOn Property

Gets or sets a value indicating whether this instance is text background color on.

public bool TextBackgroundColorOn {get; set;}

Property Value

true if this instance is text background color on; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextBackgroundFillOn Property

Aspose.Imaging Documentation

CadCalloutData.TextBackgroundFillOn Property

Gets or sets a value indicating whether this instance is text background fill on.

public bool TextBackgroundFillOn {get; set;}

Property Value

true if this instance is text background fill on; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextBackgroundScaleFactor Property

Aspose.Imaging Documentation

CadCalloutData.TextBackgroundScaleFactor Property

Gets or sets the text background scale factor.

public double TextBackgroundScaleFactor {get; set;}

Property Value

The text background scale factor.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextBackgroundTransparency Property

Aspose.Imaging Documentation

CadCalloutData.TextBackgroundTransparency Property

Gets or sets the text background transparency.

public int TextBackgroundTransparency {get; set;}

Property Value

The text background transparency.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextColor Property

Aspose.Imaging Documentation

CadCalloutData.TextColor Property

Gets or sets the color of the text.

public int TextColor {get; set;}

Property Value

The color of the text.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextColumnFlowReversed Property

Aspose.Imaging Documentation

CadCalloutData.TextColumnFlowReversed Property

Gets or sets a value indicating whether [text column flow reversed].

public bool TextColumnFlowReversed {get; set;}

Property Value

true if [text column flow reversed]; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextColumnGutterWidth Property

Aspose.Imaging Documentation

CadCalloutData.TextColumnGutterWidth Property

Gets or sets the width of the text column gutter.

public double TextColumnGutterWidth {get; set;}

Property Value

The width of the text column gutter.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextColumnHeight Property

Aspose.Imaging Documentation

CadCalloutData.TextColumnHeight Property

Gets or sets the height of the text column.

public double TextColumnHeight {get; set;}

Property Value

The height of the text column.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextColumnType Property

Aspose.Imaging Documentation

CadCalloutData.TextColumnType Property

Gets or sets the type of the text column.

public int TextColumnType {get; set;}

Property Value

The type of the text column.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextColumnWidth Property

Aspose.Imaging Documentation

CadCalloutData.TextColumnWidth Property

Gets or sets the width of the text column.

public double TextColumnWidth {get; set;}

Property Value

The width of the text column.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextDirection Property

Aspose.Imaging Documentation

CadCalloutData.TextDirection Property

Gets or sets the text direction.

public Cad3DPoint TextDirection {get; set;}

Property Value

The text direction.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextFlowDirection Property

Aspose.Imaging Documentation

CadCalloutData.TextFlowDirection Property

Gets or sets the text flow direction.

public int TextFlowDirection {get; set;}

Property Value

The text flow direction.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextHeight Property

Aspose.Imaging Documentation

CadCalloutData.TextHeight Property

Gets or sets the height of the text.

public double TextHeight {get; set;}

Property Value

The height of the text.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextLineSpacingFactor Property

Aspose.Imaging Documentation

CadCalloutData.TextLineSpacingFactor Property

Gets or sets the text line spacing factor.

public double TextLineSpacingFactor {get; set;}

Property Value

The text line spacing factor.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextLineSpacingStyle Property

Aspose.Imaging Documentation

CadCalloutData.TextLineSpacingStyle Property

Gets or sets the text line spacing style.

public int TextLineSpacingStyle {get; set;}

Property Value

The text line spacing style.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextLocation Property

Aspose.Imaging Documentation

CadCalloutData.TextLocation Property

Gets or sets the text location.

public Cad3DPoint TextLocation {get; set;}

Property Value

The text location.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextNormalDirection Property

Aspose.Imaging Documentation

CadCalloutData.TextNormalDirection Property

Gets or sets the text normal direction.

public Cad3DPoint TextNormalDirection {get; set;}

Property Value

The text normal direction.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextRotation Property

Aspose.Imaging Documentation

CadCalloutData.TextRotation Property

Gets or sets the text rotation.

public double TextRotation {get; set;}

Property Value

The text rotation.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextStyleID Property

Aspose.Imaging Documentation

CadCalloutData.TextStyleID Property

Gets or sets the text style ID.

public string TextStyleID {get; set;}

Property Value

The text style ID.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextUseWordBreak Property

Aspose.Imaging Documentation

CadCalloutData.TextUseWordBreak Property

Gets or sets a value indicating whether [text use word break].

public bool TextUseWordBreak {get; set;}

Property Value

true if [text use word break]; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextWidth Property

Aspose.Imaging Documentation

CadCalloutData.TextWidth Property

Gets or sets the width of the text.

public double TextWidth {get; set;}

Property Value

The width of the text.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


UseTextAutoHeight Property

Aspose.Imaging Documentation

CadCalloutData.UseTextAutoHeight Property

Gets or sets a value indicating whether [use text auto height].

public bool UseTextAutoHeight {get; set;}

Property Value

true if [use text auto height]; otherwise, false.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Vertex Property

Aspose.Imaging Documentation

CadCalloutData.Vertex Property

Gets or sets the vertex.

public Cad3DPoint Vertex {get; set;}

Property Value

The vertex.

See Also

CadCalloutData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCalloutLeader Class

Class describing Cad Callout Leader. For CadConsts.CadSubClassName.LEADER type.

For a list of all members of this type, see CadCalloutLeader Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadCalloutLeader

public class CadCalloutLeader : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadCalloutLeader Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCalloutLeader Members

CadCalloutLeader overview

Public Instance Constructors

CadCalloutLeader Constructor Initializes a new instance of the CadCalloutLeader class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BreakEndPoint | Gets or sets the break end point.
BreakStartPoint | Gets or sets the break start point.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DoglegVector | Gets or sets the dogleg vector.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HasSetDoglegVector | Gets or sets a value indicating whether this instance has set dogleg vector.
HasSetLastLeaderLinePoint | Gets or sets a value indicating whether this instance has set last leader line point.
LastLeaderLinePoint | Gets or sets the last leader line point.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LeaderBranchIndex | Gets or sets the index of the leader branch.
LeaderLine | Gets or sets the leader line.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadCalloutLeader Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCalloutLeader Constructor

Initializes a new instance of the CadCalloutLeader class.

public CadCalloutLeader();

See Also

CadCalloutLeader Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCalloutLeader Properties

The properties of the CadCalloutLeader class are listed below. For a complete list of CadCalloutLeader class members, see the CadCalloutLeader Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BreakEndPoint | Gets or sets the break end point.
BreakStartPoint | Gets or sets the break start point.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DoglegVector | Gets or sets the dogleg vector.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HasSetDoglegVector | Gets or sets a value indicating whether this instance has set dogleg vector.
HasSetLastLeaderLinePoint | Gets or sets a value indicating whether this instance has set last leader line point.
LastLeaderLinePoint | Gets or sets the last leader line point.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LeaderBranchIndex | Gets or sets the index of the leader branch.
LeaderLine | Gets or sets the leader line.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadCalloutLeader Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BreakEndPoint Property

Aspose.Imaging Documentation

CadCalloutLeader.BreakEndPoint Property

Gets or sets the break end point.

public Cad3DPoint BreakEndPoint {get; set;}

Property Value

The break end point.

See Also

CadCalloutLeader Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BreakStartPoint Property

Aspose.Imaging Documentation

CadCalloutLeader.BreakStartPoint Property

Gets or sets the break start point.

public Cad3DPoint BreakStartPoint {get; set;}

Property Value

The break start point.

See Also

CadCalloutLeader Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DoglegVector Property

Aspose.Imaging Documentation

CadCalloutLeader.DoglegVector Property

Gets or sets the dogleg vector.

public Cad3DPoint DoglegVector {get; set;}

Property Value

The dogleg vector.

See Also

CadCalloutLeader Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HasSetDoglegVector Property

Aspose.Imaging Documentation

CadCalloutLeader.HasSetDoglegVector Property

Gets or sets a value indicating whether this instance has set dogleg vector.

public bool HasSetDoglegVector {get; set;}

Property Value

true if this instance has set dogleg vector; otherwise, false.

See Also

CadCalloutLeader Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HasSetLastLeaderLinePoint Property

Aspose.Imaging Documentation

CadCalloutLeader.HasSetLastLeaderLinePoint Property

Gets or sets a value indicating whether this instance has set last leader line point.

public bool HasSetLastLeaderLinePoint {get; set;}

Property Value

true if this instance has set last leader line point; otherwise, false.

See Also

CadCalloutLeader Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LastLeaderLinePoint Property

Aspose.Imaging Documentation

CadCalloutLeader.LastLeaderLinePoint Property

Gets or sets the last leader line point.

public Cad3DPoint LastLeaderLinePoint {get; set;}

Property Value

The last leader line point.

See Also

CadCalloutLeader Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LeaderBranchIndex Property

Aspose.Imaging Documentation

CadCalloutLeader.LeaderBranchIndex Property

Gets or sets the index of the leader branch.

public int LeaderBranchIndex {get; set;}

Property Value

The index of the leader branch.

See Also

CadCalloutLeader Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LeaderLine Property

Aspose.Imaging Documentation

CadCalloutLeader.LeaderLine Property

Gets or sets the leader line.

public CadCalloutLine LeaderLine {get; set;}

Property Value

The leader line.

See Also

CadCalloutLeader Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCalloutLine Class

Class describing Cad Callout Line

For a list of all members of this type, see CadCalloutLine Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadCalloutLine

public class CadCalloutLine : CadBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadCalloutLine Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCalloutLine Members

CadCalloutLine overview

Public Instance Constructors

CadCalloutLine Constructor Initializes a new instance of the CadCalloutLine class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BreakEndPoint | Gets or sets the break end point.
BreakPointIndex | Gets or sets the index of the break point.
BreakStartPoint | Gets or sets the break start point.
LeaderLineIndex | Gets or sets the index of the leader line.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
TypeName | Gets or sets the name of the type.
Vertex | Gets or sets the vertex.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadCalloutLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCalloutLine Constructor

Initializes a new instance of the CadCalloutLine class.

public CadCalloutLine();

See Also

CadCalloutLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCalloutLine Properties

The properties of the CadCalloutLine class are listed below. For a complete list of CadCalloutLine class members, see the CadCalloutLine Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BreakEndPoint | Gets or sets the break end point.
BreakPointIndex | Gets or sets the index of the break point.
BreakStartPoint | Gets or sets the break start point.
LeaderLineIndex | Gets or sets the index of the leader line.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
TypeName | Gets or sets the name of the type.
Vertex | Gets or sets the vertex.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadCalloutLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BreakEndPoint Property

Aspose.Imaging Documentation

CadCalloutLine.BreakEndPoint Property

Gets or sets the break end point.

public Cad3DPoint BreakEndPoint {get; set;}

Property Value

The break end point.

See Also

CadCalloutLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BreakPointIndex Property

Aspose.Imaging Documentation

CadCalloutLine.BreakPointIndex Property

Gets or sets the index of the break point.

public int BreakPointIndex {get; set;}

Property Value

The index of the break point.

See Also

CadCalloutLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BreakStartPoint Property

Aspose.Imaging Documentation

CadCalloutLine.BreakStartPoint Property

Gets or sets the break start point.

public Cad3DPoint BreakStartPoint {get; set;}

Property Value

The break start point.

See Also

CadCalloutLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LeaderLineIndex Property

Aspose.Imaging Documentation

CadCalloutLine.LeaderLineIndex Property

Gets or sets the index of the leader line.

public int LeaderLineIndex {get; set;}

Property Value

The index of the leader line.

See Also

CadCalloutLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TypeName Property

Aspose.Imaging Documentation

CadCalloutLine.TypeName Property

Gets or sets the name of the type.

public CadEntityTypeName TypeName {get; set;}

Property Value

The name of the type.

See Also

CadCalloutLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Vertex Property

Aspose.Imaging Documentation

CadCalloutLine.Vertex Property

Gets or sets the vertex.

public Cad3DPoint Vertex {get; set;}

Property Value

The vertex.

See Also

CadCalloutLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCircle Class

Class describing Cad circle

For a list of all members of this type, see CadCircle Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadCircle
Aspose.Imaging.FileFormats.Cad.CadObjects.CadArc

public class CadCircle : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadCircle Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCircle Members

CadCircle overview

Public Instance Constructors

CadCircle Constructor Initializes a new instance of the CadCircle class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
CenterPoint | Gets or sets the centerPoint.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
Radius | Gets or sets the radius.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Thickness | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadCircle Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCircle Constructor

Initializes a new instance of the CadCircle class.

public CadCircle();

See Also

CadCircle Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadCircle Properties

The properties of the CadCircle class are listed below. For a complete list of CadCircle class members, see the CadCircle Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
CenterPoint | Gets or sets the centerPoint.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
Radius | Gets or sets the radius.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Thickness | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadCircle Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CenterPoint Property

Aspose.Imaging Documentation

CadCircle.CenterPoint Property

Gets or sets the centerPoint.

public Cad3DPoint CenterPoint {get; set;}

Property Value

The centerPoint.

See Also

CadCircle Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Radius Property

Aspose.Imaging Documentation

CadCircle.Radius Property

Gets or sets the radius.

public double Radius {get; set;}

Property Value

The radius.

See Also

CadCircle Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Thickness Property

Aspose.Imaging Documentation

CadCircle.Thickness Property

Gets or sets the thickness.

public double Thickness {get; set;}

Property Value

The thickness.

See Also

CadCircle Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDiametricDimension Class

The Cad diameter dimension. NOTE: This class is an exact copy of CadRadialDimension except sublcass name

For a list of all members of this type, see CadDiametricDimension Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDimensionBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDiametricDimension

public class CadDiametricDimension : CadDimensionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadDiametricDimension Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDiametricDimension Members

CadDiametricDimension overview

Public Instance Constructors

CadDiametricDimension Constructor Initializes a new instance of the CadDiametricDimension class.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LeaderLength | Gets or sets the leader length.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RadiusDefinitionPoint | Gets or sets the radius definition point.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadDiametricDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDiametricDimension Constructor

Initializes a new instance of the CadDiametricDimension class.

public CadDiametricDimension();

See Also

CadDiametricDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDiametricDimension Properties

The properties of the CadDiametricDimension class are listed below. For a complete list of CadDiametricDimension class members, see the CadDiametricDimension Members topic.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LeaderLength | Gets or sets the leader length.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RadiusDefinitionPoint | Gets or sets the radius definition point.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadDiametricDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LeaderLength Property

Aspose.Imaging Documentation

CadDiametricDimension.LeaderLength Property

Gets or sets the leader length.

public double LeaderLength {get; set;}

See Also

CadDiametricDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RadiusDefinitionPoint Property

Aspose.Imaging Documentation

CadDiametricDimension.RadiusDefinitionPoint Property

Gets or sets the radius definition point.

public Cad3DPoint RadiusDefinitionPoint {get; set;}

See Also

CadDiametricDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDimensionBase Class

The CadDimension class

For a list of all members of this type, see CadDimensionBase Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDimensionBase
Derived types

public class CadDimensionBase : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadDimensionBase Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDimensionBase Members

CadDimensionBase overview

Public Instance Constructors

CadDimensionBase Constructor Initializes a new instance of the CadDimensionBase class.

Public Instance Properties

ActualMeasurement | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint | Gets or sets the definition point.
DimensionTextLineSpacingFactor | Gets or sets the dimension text line spacing factor.
DimensionType | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection | Gets or sets the horizontal direction.
IsSingleUse | Gets a value indicating whether is single use.
IsUserDimension | Gets a value indicating whether this instance is user dimension.
IsXOrdinate | Gets a value indicating whether this instance is X ordinate.
IsYordinate | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName | Gets or sets the style name.
Text | Gets or sets the text.
TextLineSpacing | Gets or sets the text line spacing.
TextRotationAngle | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDimensionBase Constructor

Initializes a new instance of the CadDimensionBase class.

public CadDimensionBase();

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDimensionBase Properties

The properties of the CadDimensionBase class are listed below. For a complete list of CadDimensionBase class members, see the CadDimensionBase Members topic.

Public Instance Properties

ActualMeasurement | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint | Gets or sets the definition point.
DimensionTextLineSpacingFactor | Gets or sets the dimension text line spacing factor.
DimensionType | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection | Gets or sets the horizontal direction.
IsSingleUse | Gets a value indicating whether is single use.
IsUserDimension | Gets a value indicating whether this instance is user dimension.
IsXOrdinate | Gets a value indicating whether this instance is X ordinate.
IsYordinate | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName | Gets or sets the style name.
Text | Gets or sets the text.
TextLineSpacing | Gets or sets the text line spacing.
TextRotationAngle | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ActualMeasurement Property

Aspose.Imaging Documentation

CadDimensionBase.ActualMeasurement Property

Gets or sets the actual measurement.

public double ActualMeasurement {get; set;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AttachmentType Property

Aspose.Imaging Documentation

CadDimensionBase.AttachmentType Property

Gets or sets the attachment type.

public short AttachmentType {get; set;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockName Property

Aspose.Imaging Documentation

CadDimensionBase.BlockName Property

Gets or sets the block name.

public string BlockName {get; set;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DefinitionPoint Property

Aspose.Imaging Documentation

CadDimensionBase.DefinitionPoint Property

Gets or sets the definition point.

public Cad3DPoint DefinitionPoint {get; set;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DimensionTextLineSpacingFactor Property

Aspose.Imaging Documentation

CadDimensionBase.DimensionTextLineSpacingFactor Property

Gets or sets the dimension text line spacing factor.

public double DimensionTextLineSpacingFactor {get; set;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DimensionType Property

Aspose.Imaging Documentation

CadDimensionBase.DimensionType Property

Gets or sets the dimension type.

public short DimensionType {get; set;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HorizontalDirection Property

Aspose.Imaging Documentation

CadDimensionBase.HorizontalDirection Property

Gets or sets the horizontal direction.

public double HorizontalDirection {get; set;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


IsSingleUse Property

Aspose.Imaging Documentation

CadDimensionBase.IsSingleUse Property

Gets a value indicating whether is single use.

public bool IsSingleUse {get;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


IsUserDimension Property

Aspose.Imaging Documentation

CadDimensionBase.IsUserDimension Property

Gets a value indicating whether this instance is user dimension.

public bool IsUserDimension {get;}

Property Value

true if this instance is user dimension; otherwise, false.

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


IsXOrdinate Property

Aspose.Imaging Documentation

CadDimensionBase.IsXOrdinate Property

Gets a value indicating whether this instance is X ordinate.

public bool IsXOrdinate {get;}

Property Value

true if this instance is X ordinate; otherwise, false.

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


IsYordinate Property

Aspose.Imaging Documentation

CadDimensionBase.IsYordinate Property

Gets a value indicating whether this instance is yordinate.

public bool IsYordinate {get;}

Property Value

true if this instance is yordinate; otherwise, false.

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MiddleTextLocation Property

Aspose.Imaging Documentation

CadDimensionBase.MiddleTextLocation Property

Gets or sets the middle text location.

public Cad3DPoint MiddleTextLocation {get; set;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StyleName Property

Aspose.Imaging Documentation

CadDimensionBase.StyleName Property

Gets or sets the style name.

public string StyleName {get; set;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Text Property

Aspose.Imaging Documentation

CadDimensionBase.Text Property

Gets or sets the text.

public string Text {get; set;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextLineSpacing Property

Aspose.Imaging Documentation

CadDimensionBase.TextLineSpacing Property

Gets or sets the text line spacing.

public short TextLineSpacing {get; set;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextRotationAngle Property

Aspose.Imaging Documentation

CadDimensionBase.TextRotationAngle Property

Gets or sets the textRotationAngle angle.

public double TextRotationAngle {get; set;}

See Also

CadDimensionBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDimensionOrdinate Class

The Cad dimension ordinate.

For a list of all members of this type, see CadDimensionOrdinate Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDimensionBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDimensionOrdinate

public class CadDimensionOrdinate : CadDimensionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadDimensionOrdinate Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDimensionOrdinate Members

CadDimensionOrdinate overview

Public Instance Constructors

CadDimensionOrdinate Constructor Initializes a new instance of the CadDimensionOrdinate class.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
Definition13 | Gets or sets the definition13.
Definition14 | Gets or sets the definition14.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadDimensionOrdinate Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDimensionOrdinate Constructor

Initializes a new instance of the CadDimensionOrdinate class.

public CadDimensionOrdinate();

See Also

CadDimensionOrdinate Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDimensionOrdinate Properties

The properties of the CadDimensionOrdinate class are listed below. For a complete list of CadDimensionOrdinate class members, see the CadDimensionOrdinate Members topic.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
Definition13 | Gets or sets the definition13.
Definition14 | Gets or sets the definition14.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadDimensionOrdinate Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Definition13 Property

Aspose.Imaging Documentation

CadDimensionOrdinate.Definition13 Property

Gets or sets the definition13.

public Cad3DPoint Definition13 {get; set;}

Property Value

The definition13.

See Also

CadDimensionOrdinate Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Definition14 Property

Aspose.Imaging Documentation

CadDimensionOrdinate.Definition14 Property

Gets or sets the definition14.

public Cad3DPoint Definition14 {get; set;}

Property Value

The definition14.

See Also

CadDimensionOrdinate Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadEllipse Class

Class describing Cad ellipse

For a list of all members of this type, see CadEllipse Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadEllipse

public class CadEllipse : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadEllipse Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadEllipse Members

CadEllipse overview

Public Instance Constructors

CadEllipse Constructor Initializes a new instance of the CadEllipse class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
AxisRatio | Gets or sets the axis ratio.
CenterPoint | Gets or sets the center point.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
End | Gets or sets the end.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
MajorEndPoint | Gets or sets the majour end point.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Start | Gets or sets the start.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadEllipse Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadEllipse Constructor

Initializes a new instance of the CadEllipse class.

public CadEllipse();

See Also

CadEllipse Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadEllipse Properties

The properties of the CadEllipse class are listed below. For a complete list of CadEllipse class members, see the CadEllipse Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
AxisRatio | Gets or sets the axis ratio.
CenterPoint | Gets or sets the center point.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
End | Gets or sets the end.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
MajorEndPoint | Gets or sets the majour end point.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Start | Gets or sets the start.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadEllipse Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AxisRatio Property

Aspose.Imaging Documentation

CadEllipse.AxisRatio Property

Gets or sets the axis ratio.

public double AxisRatio {get; set;}

Property Value

The axis ratio.

See Also

CadEllipse Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CenterPoint Property

Aspose.Imaging Documentation

CadEllipse.CenterPoint Property

Gets or sets the center point.

public Cad3DPoint CenterPoint {get; set;}

Property Value

The center point.

See Also

CadEllipse Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


End Property

Aspose.Imaging Documentation

CadEllipse.End Property

Gets or sets the end.

public double End {get; set;}

Property Value

The end.

See Also

CadEllipse Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MajorEndPoint Property

Aspose.Imaging Documentation

CadEllipse.MajorEndPoint Property

Gets or sets the majour end point.

public Cad3DPoint MajorEndPoint {get; set;}

Property Value

The majour end point.

See Also

CadEllipse Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Start Property

Aspose.Imaging Documentation

CadEllipse.Start Property

Gets or sets the start.

public double Start {get; set;}

Property Value

The start.

See Also

CadEllipse Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatch Class

The Cad hatch.

For a list of all members of this type, see CadHatch Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadHatch

public class CadHatch : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadHatch Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatch Members

CadHatch overview

Public Instance Constructors

CadHatch Constructor Initializes a new instance of the CadHatch class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AssociativeFlag | Gets or sets the associative flag.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BoundaryAnnotation | Gets or sets the boundary annotation.
BoundaryPaths | Gets or sets the boundary paths.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
Elevation | Gets or sets the elevation.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
GradientColorsType | Gets or sets the gradient colors type.
GradientColorTint | Gets or sets the gradient color tint.
GradientDefinition | Gets or sets the gradient definition.
GradientRotationAngle | Gets or sets the gradient rotation angle.
GradientType | Gets or sets the gradient type.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HatchAngle | Gets or sets the hatch angle.
HatchPatternDoubleFlag | Gets or sets the hatch pattern double flag.
HatchPatternType | Gets or sets the hatch pattern type.
HatchScaleOrSpacing | Gets or sets the hatch scale or spacing.
HatchStyle | Gets or sets the hatch style.
IgnoredBoundaries | Gets or sets the ignored boundaries.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
NumberOfBoundaries | Gets or sets the number of boundaries.
NumberOfPatternDefinitions | Gets or sets the number of pattern definitions.
NumberOfSeedPoints | Gets or sets the number of seed points.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
OffsetVector | Gets or sets the offset vector.
PatternDefinitions | Gets or sets the pattern definitions.
PatternFillColor | Gets or sets the pattern fill color.
PatternName | Gets or sets the pattern name.
PixelSize | Gets or sets the pixel size.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
SeedPoints | Gets or sets the seed points.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SolidFillFlag | Gets or sets the solid fill flag.
SolidOrGradient | Gets or sets the solid or gradient.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatch Constructor

Initializes a new instance of the CadHatch class.

public CadHatch();

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatch Properties

The properties of the CadHatch class are listed below. For a complete list of CadHatch class members, see the CadHatch Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AssociativeFlag | Gets or sets the associative flag.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BoundaryAnnotation | Gets or sets the boundary annotation.
BoundaryPaths | Gets or sets the boundary paths.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
Elevation | Gets or sets the elevation.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
GradientColorsType | Gets or sets the gradient colors type.
GradientColorTint | Gets or sets the gradient color tint.
GradientDefinition | Gets or sets the gradient definition.
GradientRotationAngle | Gets or sets the gradient rotation angle.
GradientType | Gets or sets the gradient type.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HatchAngle | Gets or sets the hatch angle.
HatchPatternDoubleFlag | Gets or sets the hatch pattern double flag.
HatchPatternType | Gets or sets the hatch pattern type.
HatchScaleOrSpacing | Gets or sets the hatch scale or spacing.
HatchStyle | Gets or sets the hatch style.
IgnoredBoundaries | Gets or sets the ignored boundaries.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
NumberOfBoundaries | Gets or sets the number of boundaries.
NumberOfPatternDefinitions | Gets or sets the number of pattern definitions.
NumberOfSeedPoints | Gets or sets the number of seed points.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
OffsetVector | Gets or sets the offset vector.
PatternDefinitions | Gets or sets the pattern definitions.
PatternFillColor | Gets or sets the pattern fill color.
PatternName | Gets or sets the pattern name.
PixelSize | Gets or sets the pixel size.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
SeedPoints | Gets or sets the seed points.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SolidFillFlag | Gets or sets the solid fill flag.
SolidOrGradient | Gets or sets the solid or gradient.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AssociativeFlag Property

Aspose.Imaging Documentation

CadHatch.AssociativeFlag Property

Gets or sets the associative flag.

public short AssociativeFlag {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BoundaryAnnotation Property

Aspose.Imaging Documentation

CadHatch.BoundaryAnnotation Property

Gets or sets the boundary annotation.

public short BoundaryAnnotation {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BoundaryPaths Property

Aspose.Imaging Documentation

CadHatch.BoundaryPaths Property

Gets or sets the boundary paths.

public CadHatchBoundaryPathContainer} BoundaryPaths {get; set;}

Property Value

The boundary paths.

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Elevation Property

Aspose.Imaging Documentation

CadHatch.Elevation Property

Gets or sets the elevation.

public Cad3DPoint Elevation {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


GradientColorsType Property

Aspose.Imaging Documentation

CadHatch.GradientColorsType Property

Gets or sets the gradient colors type.

public long GradientColorsType {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


GradientColorTint Property

Aspose.Imaging Documentation

CadHatch.GradientColorTint Property

Gets or sets the gradient color tint.

public double GradientColorTint {get; set;}

Property Value

The gradient color tint.

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


GradientDefinition Property

Aspose.Imaging Documentation

CadHatch.GradientDefinition Property

Gets or sets the gradient definition.

public double GradientDefinition {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


GradientRotationAngle Property

Aspose.Imaging Documentation

CadHatch.GradientRotationAngle Property

Gets or sets the gradient rotation angle.

public double GradientRotationAngle {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


GradientType Property

Aspose.Imaging Documentation

CadHatch.GradientType Property

Gets or sets the gradient type.

public long GradientType {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HatchAngle Property

Aspose.Imaging Documentation

CadHatch.HatchAngle Property

Gets or sets the hatch angle.

public double HatchAngle {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HatchPatternDoubleFlag Property

Aspose.Imaging Documentation

CadHatch.HatchPatternDoubleFlag Property

Gets or sets the hatch pattern double flag.

public short HatchPatternDoubleFlag {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HatchPatternType Property

Aspose.Imaging Documentation

CadHatch.HatchPatternType Property

Gets or sets the hatch pattern type.

public short HatchPatternType {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HatchScaleOrSpacing Property

Aspose.Imaging Documentation

CadHatch.HatchScaleOrSpacing Property

Gets or sets the hatch scale or spacing.

public double HatchScaleOrSpacing {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HatchStyle Property

Aspose.Imaging Documentation

CadHatch.HatchStyle Property

Gets or sets the hatch style.

public short HatchStyle {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


IgnoredBoundaries Property

Aspose.Imaging Documentation

CadHatch.IgnoredBoundaries Property

Gets or sets the ignored boundaries.

public int IgnoredBoundaries {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


NumberOfBoundaries Property

Aspose.Imaging Documentation

CadHatch.NumberOfBoundaries Property

Gets or sets the number of boundaries.

public int NumberOfBoundaries {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


NumberOfPatternDefinitions Property

Aspose.Imaging Documentation

CadHatch.NumberOfPatternDefinitions Property

Gets or sets the number of pattern definitions.

public short NumberOfPatternDefinitions {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


NumberOfSeedPoints Property

Aspose.Imaging Documentation

CadHatch.NumberOfSeedPoints Property

Gets or sets the number of seed points.

public int NumberOfSeedPoints {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


OffsetVector Property

Aspose.Imaging Documentation

CadHatch.OffsetVector Property

Gets or sets the offset vector.

public double OffsetVector {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PatternDefinitions Property

Aspose.Imaging Documentation

CadHatch.PatternDefinitions Property

Gets or sets the pattern definitions.

public CadHatchPatternData} PatternDefinitions {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PatternFillColor Property

Aspose.Imaging Documentation

CadHatch.PatternFillColor Property

Gets or sets the pattern fill color.

public short PatternFillColor {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PatternName Property

Aspose.Imaging Documentation

CadHatch.PatternName Property

Gets or sets the pattern name.

public string PatternName {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PixelSize Property

Aspose.Imaging Documentation

CadHatch.PixelSize Property

Gets or sets the pixel size.

public double PixelSize {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SeedPoints Property

Aspose.Imaging Documentation

CadHatch.SeedPoints Property

Gets or sets the seed points.

public Cad3DPoint} SeedPoints {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SolidFillFlag Property

Aspose.Imaging Documentation

CadHatch.SolidFillFlag Property

Gets or sets the solid fill flag.

public short SolidFillFlag {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SolidOrGradient Property

Aspose.Imaging Documentation

CadHatch.SolidOrGradient Property

Gets or sets the solid or gradient.

public long SolidOrGradient {get; set;}

See Also

CadHatch Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatchBoundaryPathContainer Class

Boundary for hatch

For a list of all members of this type, see CadHatchBoundaryPathContainer Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadHatchBoundaryPathContainer

public class CadHatchBoundaryPathContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadHatchBoundaryPathContainer Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatchBoundaryPathContainer Members

CadHatchBoundaryPathContainer overview

Public Instance Constructors

CadHatchBoundaryPathContainer Constructor Initializes a new instance of the CadHatchBoundaryPathContainer class.

Public Instance Properties

BoundaryObjectCount | Gets or sets the boundary object count.
BoundaryPath | Gets or sets the boundary path.
EdgeType | Gets or sets the edge type.
NumberOfEdges | Gets or sets the number of edges.
PathType | Gets or sets the path type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | The initialization function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadHatchBoundaryPathContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatchBoundaryPathContainer Constructor

Initializes a new instance of the CadHatchBoundaryPathContainer class.

public CadHatchBoundaryPathContainer();

See Also

CadHatchBoundaryPathContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatchBoundaryPathContainer Properties

The properties of the CadHatchBoundaryPathContainer class are listed below. For a complete list of CadHatchBoundaryPathContainer class members, see the CadHatchBoundaryPathContainer Members topic.

Public Instance Properties

BoundaryObjectCount | Gets or sets the boundary object count.
BoundaryPath | Gets or sets the boundary path.
EdgeType | Gets or sets the edge type.
NumberOfEdges | Gets or sets the number of edges.
PathType | Gets or sets the path type.

See Also

CadHatchBoundaryPathContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BoundaryObjectCount Property

Aspose.Imaging Documentation

CadHatchBoundaryPathContainer.BoundaryObjectCount Property

Gets or sets the boundary object count.

public int BoundaryObjectCount {get; set;}

See Also

CadHatchBoundaryPathContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BoundaryPath Property

Aspose.Imaging Documentation

CadHatchBoundaryPathContainer.BoundaryPath Property

Gets or sets the boundary path.

public CadPolylineBoundaryPath} BoundaryPath {get; set;}

See Also

CadHatchBoundaryPathContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


EdgeType Property

Aspose.Imaging Documentation

CadHatchBoundaryPathContainer.EdgeType Property

Gets or sets the edge type.

public short EdgeType {get; set;}

See Also

CadHatchBoundaryPathContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


NumberOfEdges Property

Aspose.Imaging Documentation

CadHatchBoundaryPathContainer.NumberOfEdges Property

Gets or sets the number of edges.

public int NumberOfEdges {get; set;}

See Also

CadHatchBoundaryPathContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PathType Property

Aspose.Imaging Documentation

CadHatchBoundaryPathContainer.PathType Property

Gets or sets the path type.

public int PathType {get; set;}

See Also

CadHatchBoundaryPathContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatchBoundaryPathContainer Methods

The methods of the CadHatchBoundaryPathContainer class are listed below. For a complete list of CadHatchBoundaryPathContainer class members, see the CadHatchBoundaryPathContainer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | The initialization function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadHatchBoundaryPathContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatchBoundaryPathContainer.Init Method

The initialization function.

public CadCodeValue Init(
TextReader stream,
CadCodeValue parameter,
int pathCount
);

Parameters

stream
The stream.
parameter
The parameter.
pathCount
The path count.

Return Value

The CadCodeValue.

See Also

CadHatchBoundaryPathContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatchPatternData Class

Cad hatch pattern class

For a list of all members of this type, see CadHatchPatternData Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadHatchPatternData

public class CadHatchPatternData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadHatchPatternData Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatchPatternData Members

CadHatchPatternData overview

Public Instance Constructors

CadHatchPatternData Constructor Initializes a new instance of the CadHatchPatternData class.

Public Instance Properties

DashLengthCount | Gets or sets the dash length count.
DashLengths | Gets or sets the dash lengths.
LineAngle | Gets or sets the line angle.
LineBasePoint | Gets or sets the line base point.
LineOffset | Gets or sets the line offset.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | The initialization function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadHatchPatternData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatchPatternData Constructor

Initializes a new instance of the CadHatchPatternData class.

public CadHatchPatternData();

See Also

CadHatchPatternData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatchPatternData Properties

The properties of the CadHatchPatternData class are listed below. For a complete list of CadHatchPatternData class members, see the CadHatchPatternData Members topic.

Public Instance Properties

DashLengthCount | Gets or sets the dash length count.
DashLengths | Gets or sets the dash lengths.
LineAngle | Gets or sets the line angle.
LineBasePoint | Gets or sets the line base point.
LineOffset | Gets or sets the line offset.

See Also

CadHatchPatternData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DashLengthCount Property

Aspose.Imaging Documentation

CadHatchPatternData.DashLengthCount Property

Gets or sets the dash length count.

public short DashLengthCount {get; set;}

Property Value

The dash length count.

See Also

CadHatchPatternData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DashLengths Property

Aspose.Imaging Documentation

CadHatchPatternData.DashLengths Property

Gets or sets the dash lengths.

public Double} DashLengths {get; set;}

Property Value

The dash lengths.

See Also

CadHatchPatternData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LineAngle Property

Aspose.Imaging Documentation

CadHatchPatternData.LineAngle Property

Gets or sets the line angle.

public double LineAngle {get; set;}

Property Value

The line angle.

See Also

CadHatchPatternData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LineBasePoint Property

Aspose.Imaging Documentation

CadHatchPatternData.LineBasePoint Property

Gets or sets the line base point.

public Cad2DPoint LineBasePoint {get; set;}

Property Value

The line base point.

See Also

CadHatchPatternData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LineOffset Property

Aspose.Imaging Documentation

CadHatchPatternData.LineOffset Property

Gets or sets the line offset.

public Cad2DPoint LineOffset {get; set;}

Property Value

The line offset.

See Also

CadHatchPatternData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatchPatternData Methods

The methods of the CadHatchPatternData class are listed below. For a complete list of CadHatchPatternData class members, see the CadHatchPatternData Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | The initialization function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadHatchPatternData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHatchPatternData.Init Method

The initialization function.

public CadCodeValue Init(
CadCodeValue code,
TextReader stream
);

Parameters

code
The code of the pattern data.
stream
The stream data.

Return Value

The CadCodeValue.

See Also

CadHatchPatternData Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHelix Class

Class describing CadHelix

For a list of all members of this type, see CadHelix Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadHelix

public class CadHelix : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadHelix Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHelix Members

CadHelix overview

Public Instance Constructors

CadHelix Constructor Initializes a new instance of the CadHelix class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
AxisPoints | Gets or sets the axis points.
AxisVector | Gets or sets the axis vector.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ConstrainType | Gets or sets the type of the constrain.
Handedness | Gets or sets a value indicating whether this CadHelix is left or right handed.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
Radius | Gets or sets the radius.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
SplineObject | Gets or sets the spline object.
StartPoint | Gets or sets the start point.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TurnLength | Gets or sets the turn length.
TurnsNumber | Gets or sets the turns number.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadHelix Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHelix Constructor

Initializes a new instance of the CadHelix class.

public CadHelix();

See Also

CadHelix Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadHelix Properties

The properties of the CadHelix class are listed below. For a complete list of CadHelix class members, see the CadHelix Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
AxisPoints | Gets or sets the axis points.
AxisVector | Gets or sets the axis vector.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ConstrainType | Gets or sets the type of the constrain.
Handedness | Gets or sets a value indicating whether this CadHelix is left or right handed.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
Radius | Gets or sets the radius.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
SplineObject | Gets or sets the spline object.
StartPoint | Gets or sets the start point.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TurnLength | Gets or sets the turn length.
TurnsNumber | Gets or sets the turns number.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadHelix Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AxisPoints Property

Aspose.Imaging Documentation

CadHelix.AxisPoints Property

Gets or sets the axis points.

public PointF} AxisPoints {get; set;}

Property Value

The axis points.

See Also

CadHelix Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AxisVector Property

Aspose.Imaging Documentation

CadHelix.AxisVector Property

Gets or sets the axis vector.

public Cad3DPoint AxisVector {get; set;}

Property Value

The axis vector.

See Also

CadHelix Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ConstrainType Property

Aspose.Imaging Documentation

CadHelix.ConstrainType Property

Gets or sets the type of the constrain.

public CadHelixLimitation ConstrainType {get; set;}

Property Value

The type of the constrain.

See Also

CadHelix Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Handedness Property

Aspose.Imaging Documentation

CadHelix.Handedness Property

Gets or sets a value indicating whether this CadHelix is left or right handed.

public CadHorizontalDirection Handedness {get; set;}

Property Value

true if left handed; otherwise, false.

See Also

CadHelix Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Radius Property

Aspose.Imaging Documentation

CadHelix.Radius Property

Gets or sets the radius.

public double Radius {get; set;}

Property Value

The radius.

See Also

CadHelix Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SplineObject Property

Aspose.Imaging Documentation

CadHelix.SplineObject Property

Gets or sets the spline object.

public CadSpline SplineObject {get; set;}

See Also

CadHelix Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StartPoint Property

Aspose.Imaging Documentation

CadHelix.StartPoint Property

Gets or sets the start point.

public Cad3DPoint StartPoint {get; set;}

Property Value

The start point.

See Also

CadHelix Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TurnLength Property

Aspose.Imaging Documentation

CadHelix.TurnLength Property

Gets or sets the turn length.

public double TurnLength {get; set;}

See Also

CadHelix Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TurnsNumber Property

Aspose.Imaging Documentation

CadHelix.TurnsNumber Property

Gets or sets the turns number.

public double TurnsNumber {get; set;}

Property Value

The turns number.

See Also

CadHelix Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadInsertObject Class

The Cad insert object.

For a list of all members of this type, see CadInsertObject Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadInsertObject

public class CadInsertObject : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadInsertObject Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadInsertObject Members

CadInsertObject overview

Public Instance Constructors

CadInsertObject Constructor Initializes a new instance of the CadInsertObject class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ColumnCount | Gets or sets the column count.
ColumnSpacing | Gets or sets the column spacing.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
Flags | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
InsertionPoint | Gets or sets the insertion point.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
Name | Gets or sets the name.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RotationAngle | Gets or sets the rotation angle.
RowCount | Gets or sets the row count.
RowSpacing | Gets or sets the row spacing.
ScaleX | Gets or sets the scale x.
ScaleY | Gets or sets the scale y.
ScaleZ | Gets or sets the scale z.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadInsertObject Constructor

Initializes a new instance of the CadInsertObject class.

public CadInsertObject();

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadInsertObject Properties

The properties of the CadInsertObject class are listed below. For a complete list of CadInsertObject class members, see the CadInsertObject Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ColumnCount | Gets or sets the column count.
ColumnSpacing | Gets or sets the column spacing.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
Flags | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
InsertionPoint | Gets or sets the insertion point.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
Name | Gets or sets the name.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RotationAngle | Gets or sets the rotation angle.
RowCount | Gets or sets the row count.
RowSpacing | Gets or sets the row spacing.
ScaleX | Gets or sets the scale x.
ScaleY | Gets or sets the scale y.
ScaleZ | Gets or sets the scale z.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColumnCount Property

Aspose.Imaging Documentation

CadInsertObject.ColumnCount Property

Gets or sets the column count.

public short ColumnCount {get; set;}

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColumnSpacing Property

Aspose.Imaging Documentation

CadInsertObject.ColumnSpacing Property

Gets or sets the column spacing.

public double ColumnSpacing {get; set;}

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Flags Property

Aspose.Imaging Documentation

CadInsertObject.Flags Property

Gets or sets the flags.

public short Flags {get; set;}

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


InsertionPoint Property

Aspose.Imaging Documentation

CadInsertObject.InsertionPoint Property

Gets or sets the insertion point.

public Cad3DPoint InsertionPoint {get;}

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Name Property

Aspose.Imaging Documentation

CadInsertObject.Name Property

Gets or sets the name.

public string Name {get; set;}

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RotationAngle Property

Aspose.Imaging Documentation

CadInsertObject.RotationAngle Property

Gets or sets the rotation angle.

public double RotationAngle {get; set;}

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RowCount Property

Aspose.Imaging Documentation

CadInsertObject.RowCount Property

Gets or sets the row count.

public short RowCount {get; set;}

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RowSpacing Property

Aspose.Imaging Documentation

CadInsertObject.RowSpacing Property

Gets or sets the row spacing.

public double RowSpacing {get; set;}

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ScaleX Property

Aspose.Imaging Documentation

CadInsertObject.ScaleX Property

Gets or sets the scale x.

public double ScaleX {get; set;}

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ScaleY Property

Aspose.Imaging Documentation

CadInsertObject.ScaleY Property

Gets or sets the scale y.

public double ScaleY {get; set;}

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ScaleZ Property

Aspose.Imaging Documentation

CadInsertObject.ScaleZ Property

Gets or sets the scale z.

public double ScaleZ {get; set;}

See Also

CadInsertObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadInvisibleObject Class

Base class for Cad objects

For a list of all members of this type, see CadInvisibleObject Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadInvisibleObject

public class CadInvisibleObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadInvisibleObject Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadInvisibleObject Members

CadInvisibleObject overview

Public Instance Constructors

CadInvisibleObject Constructor Initializes a new instance of the CadInvisibleObject class.

Public Instance Properties

AttributeOrder | Gets or sets the attribute order.
Order | Gets or sets the order.
Properties | Gets or sets the properties.
PropertyList | Gets or sets the property list.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Initializes the specified data.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadInvisibleObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadInvisibleObject Constructor

Initializes a new instance of the CadInvisibleObject class.

public CadInvisibleObject();

See Also

CadInvisibleObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadInvisibleObject Properties

The properties of the CadInvisibleObject class are listed below. For a complete list of CadInvisibleObject class members, see the CadInvisibleObject Members topic.

Public Instance Properties

AttributeOrder | Gets or sets the attribute order.
Order | Gets or sets the order.
Properties | Gets or sets the properties.
PropertyList | Gets or sets the property list.

See Also

CadInvisibleObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AttributeOrder Property

Aspose.Imaging Documentation

CadInvisibleObject.AttributeOrder Property

Gets or sets the attribute order.

public String} AttributeOrder {get; set;}

Property Value

The attribute order.

See Also

CadInvisibleObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Order Property

Aspose.Imaging Documentation

CadInvisibleObject.Order Property

Gets or sets the order.

public int Order {get; set;}

Property Value

The order.

See Also

CadInvisibleObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Properties Property

Aspose.Imaging Documentation

CadInvisibleObject.Properties Property

Gets or sets the properties.

public String[]} Properties {get; set;}

Property Value

The properties.

See Also

CadInvisibleObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PropertyList Property

Aspose.Imaging Documentation

CadInvisibleObject.PropertyList Property

Gets or sets the property list.

public String}} PropertyList {get; set;}

See Also

CadInvisibleObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadInvisibleObject Methods

The methods of the CadInvisibleObject class are listed below. For a complete list of CadInvisibleObject class members, see the CadInvisibleObject Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Initializes the specified data.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadInvisibleObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadInvisibleObject.Initialize Method

Initializes the specified data.

public virtual void Initialize(
List<string> data,
int orderInFile
);

Parameters

data
The list of strings - rows of the file.
orderInFile
The order in file.

See Also

CadInvisibleObject Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadLayout Class

The Cad layout object.

For a list of all members of this type, see CadLayout Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseObject
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPlotSettings
Aspose.Imaging.FileFormats.Cad.CadObjects.CadLayout

public class CadLayout : CadPlotSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadLayout Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadLayout Members

CadLayout overview

Public Instance Constructors

CadLayout Constructor Initializes a new instance of the CadLayout class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockTableRecordHandle | Gets or sets the handle block table record.
BottomSize (inherited from CadPlotSettings) | Gets or sets the size of the bottom.
ChildObjects (inherited from CadBaseObject) | Gets or sets the child objects.
ControlFlag | Gets or sets the control flag.
CurrentStyleSheet (inherited from CadPlotSettings) | Gets or sets the current style sheet.
CustomPrintScaleDenominator (inherited from CadPlotSettings) | Gets or sets the custom print scale denominator.
CustomPrintScaleNumerator (inherited from CadPlotSettings) | Gets or sets the custom print scale numerator.
Elevation | Gets or sets the elevation.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
InsertionBasePoint | Gets or sets the insertion base point.
LastActiveViewportHandle | Gets or sets the handle last active viewport.
LayoutName | Gets or sets the name of the layout.
LeftSideSize (inherited from CadPlotSettings) | Gets or sets the size of the left side.
MaxExtents | Gets or sets the maximum extents.
MaxLimits | Gets or sets the maximum limits.
MinExtents | Gets or sets the minimum extents.
MinLimits | Gets or sets the minimum limits.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PageSetupName (inherited from CadPlotSettings) | Gets or sets the name of the page setup.
PaperImageOrigin (inherited from CadPlotSettings) | Gets or sets the paper image origin.
PaperSize (inherited from CadPlotSettings) | Gets or sets the size of the paper.
PlotLayoutFlag (inherited from CadPlotSettings) | Gets or sets the plot layout flag.
PlotOrigin (inherited from CadPlotSettings) | Gets or sets the plot origin.
PlotPaperSize (inherited from CadPlotSettings) | Gets or sets the size of the plot paper.
PlotPaperUnits (inherited from CadPlotSettings) | Gets or sets the plot paper units.
PlotRotation (inherited from CadPlotSettings) | Gets or sets the plot rotation.
PlotType (inherited from CadPlotSettings) | Gets or sets the type of the plot.
PlotViewName (inherited from CadPlotSettings) | Gets or sets the name of the plot view.
PlotWindowArea1 (inherited from CadPlotSettings) | Gets or sets the plot window area1.
PlotWindowArea2 (inherited from CadPlotSettings) | Gets or sets the plot window area2.
PrinterOrConfigurationFileName (inherited from CadPlotSettings) | Gets or sets the name of the printer or configuration file.
PropertyList (inherited from CadBase) | Gets or sets the property list.
RightSideSize (inherited from CadPlotSettings) | Gets or sets the size of the right side.
ShadePlotCustomDpi (inherited from CadPlotSettings) | Gets or sets the shade plot custom dpi.
ShadePlotHandle (inherited from CadPlotSettings) | Gets or sets the shade plot handle.
ShadePlotId | Gets or sets the shade plot identifier.
ShadePlotMode (inherited from CadPlotSettings) | Gets or sets the shade plot mode.
ShadePlotResolutionLevel (inherited from CadPlotSettings) | Gets or sets the shade plot resolution level.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
StandardScaleType (inherited from CadPlotSettings) | Gets or sets the type of the standard scale.
StandardScaleTypeFactor (inherited from CadPlotSettings) | Gets or sets the standard scale type factor.
TabOrder | Gets or sets the tab order.
TopSize (inherited from CadPlotSettings) | Gets or sets the size of the top.
TypeName (inherited from CadBaseObject) | Gets the name of the type.
UcsOrigin | Gets or sets the UCS origin.
UcsOrthographicType | Gets or sets the type of the UCS orthographic.
UcsTableRecordHandleWhenOrthographicUcs | Gets or sets the handle ac database UCS table record UCS.
UcsTableRecordHandleWhenUcsNamed | Gets or sets the handle ac database UCS table record UCS named.
UcsXAxis | Gets or sets the UCS x axis.
UcsYAxis | Gets or sets the UCS y axis.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadLayout Constructor

Initializes a new instance of the CadLayout class.

public CadLayout();

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadLayout Properties

The properties of the CadLayout class are listed below. For a complete list of CadLayout class members, see the CadLayout Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockTableRecordHandle | Gets or sets the handle block table record.
BottomSize (inherited from CadPlotSettings) | Gets or sets the size of the bottom.
ChildObjects (inherited from CadBaseObject) | Gets or sets the child objects.
ControlFlag | Gets or sets the control flag.
CurrentStyleSheet (inherited from CadPlotSettings) | Gets or sets the current style sheet.
CustomPrintScaleDenominator (inherited from CadPlotSettings) | Gets or sets the custom print scale denominator.
CustomPrintScaleNumerator (inherited from CadPlotSettings) | Gets or sets the custom print scale numerator.
Elevation | Gets or sets the elevation.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
InsertionBasePoint | Gets or sets the insertion base point.
LastActiveViewportHandle | Gets or sets the handle last active viewport.
LayoutName | Gets or sets the name of the layout.
LeftSideSize (inherited from CadPlotSettings) | Gets or sets the size of the left side.
MaxExtents | Gets or sets the maximum extents.
MaxLimits | Gets or sets the maximum limits.
MinExtents | Gets or sets the minimum extents.
MinLimits | Gets or sets the minimum limits.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PageSetupName (inherited from CadPlotSettings) | Gets or sets the name of the page setup.
PaperImageOrigin (inherited from CadPlotSettings) | Gets or sets the paper image origin.
PaperSize (inherited from CadPlotSettings) | Gets or sets the size of the paper.
PlotLayoutFlag (inherited from CadPlotSettings) | Gets or sets the plot layout flag.
PlotOrigin (inherited from CadPlotSettings) | Gets or sets the plot origin.
PlotPaperSize (inherited from CadPlotSettings) | Gets or sets the size of the plot paper.
PlotPaperUnits (inherited from CadPlotSettings) | Gets or sets the plot paper units.
PlotRotation (inherited from CadPlotSettings) | Gets or sets the plot rotation.
PlotType (inherited from CadPlotSettings) | Gets or sets the type of the plot.
PlotViewName (inherited from CadPlotSettings) | Gets or sets the name of the plot view.
PlotWindowArea1 (inherited from CadPlotSettings) | Gets or sets the plot window area1.
PlotWindowArea2 (inherited from CadPlotSettings) | Gets or sets the plot window area2.
PrinterOrConfigurationFileName (inherited from CadPlotSettings) | Gets or sets the name of the printer or configuration file.
PropertyList (inherited from CadBase) | Gets or sets the property list.
RightSideSize (inherited from CadPlotSettings) | Gets or sets the size of the right side.
ShadePlotCustomDpi (inherited from CadPlotSettings) | Gets or sets the shade plot custom dpi.
ShadePlotHandle (inherited from CadPlotSettings) | Gets or sets the shade plot handle.
ShadePlotId | Gets or sets the shade plot identifier.
ShadePlotMode (inherited from CadPlotSettings) | Gets or sets the shade plot mode.
ShadePlotResolutionLevel (inherited from CadPlotSettings) | Gets or sets the shade plot resolution level.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
StandardScaleType (inherited from CadPlotSettings) | Gets or sets the type of the standard scale.
StandardScaleTypeFactor (inherited from CadPlotSettings) | Gets or sets the standard scale type factor.
TabOrder | Gets or sets the tab order.
TopSize (inherited from CadPlotSettings) | Gets or sets the size of the top.
TypeName (inherited from CadBaseObject) | Gets the name of the type.
UcsOrigin | Gets or sets the UCS origin.
UcsOrthographicType | Gets or sets the type of the UCS orthographic.
UcsTableRecordHandleWhenOrthographicUcs | Gets or sets the handle ac database UCS table record UCS.
UcsTableRecordHandleWhenUcsNamed | Gets or sets the handle ac database UCS table record UCS named.
UcsXAxis | Gets or sets the UCS x axis.
UcsYAxis | Gets or sets the UCS y axis.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockTableRecordHandle Property

Aspose.Imaging Documentation

CadLayout.BlockTableRecordHandle Property

Gets or sets the handle block table record.

public string BlockTableRecordHandle {get; set;}

Property Value

The handle block table record.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ControlFlag Property

Aspose.Imaging Documentation

CadLayout.ControlFlag Property

Gets or sets the control flag.

public CadLayoutControlFlag ControlFlag {get; set;}

Property Value

The control flag.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Elevation Property

Aspose.Imaging Documentation

CadLayout.Elevation Property

Gets or sets the elevation.

public double Elevation {get; set;}

Property Value

The elevation.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


InsertionBasePoint Property

Aspose.Imaging Documentation

CadLayout.InsertionBasePoint Property

Gets or sets the insertion base point.

public Cad3DPoint InsertionBasePoint {get; set;}

Property Value

The insertion base point.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LastActiveViewportHandle Property

Aspose.Imaging Documentation

CadLayout.LastActiveViewportHandle Property

Gets or sets the handle last active viewport.

public string LastActiveViewportHandle {get; set;}

Property Value

The handle last active viewport.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LayoutName Property

Aspose.Imaging Documentation

CadLayout.LayoutName Property

Gets or sets the name of the layout.

public string LayoutName {get; set;}

Property Value

The name of the layout.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MaxExtents Property

Aspose.Imaging Documentation

CadLayout.MaxExtents Property

Gets or sets the maximum extents.

public Cad3DPoint MaxExtents {get; set;}

Property Value

The maximum extents.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MaxLimits Property

Aspose.Imaging Documentation

CadLayout.MaxLimits Property

Gets or sets the maximum limits.

public Cad2DPoint MaxLimits {get; set;}

Property Value

The maximum limits.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MinExtents Property

Aspose.Imaging Documentation

CadLayout.MinExtents Property

Gets or sets the minimum extents.

public Cad3DPoint MinExtents {get; set;}

Property Value

The minimum extents.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MinLimits Property

Aspose.Imaging Documentation

CadLayout.MinLimits Property

Gets or sets the minimum limits.

public Cad2DPoint MinLimits {get; set;}

Property Value

The minimum limits.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ShadePlotId Property

Aspose.Imaging Documentation

CadLayout.ShadePlotId Property

Gets or sets the shade plot identifier.

public string ShadePlotId {get; set;}

Property Value

The shade plot identifier.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TabOrder Property

Aspose.Imaging Documentation

CadLayout.TabOrder Property

Gets or sets the tab order.

public short TabOrder {get; set;}

Property Value

The tab order.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


UcsOrigin Property

Aspose.Imaging Documentation

CadLayout.UcsOrigin Property

Gets or sets the UCS origin.

public Cad3DPoint UcsOrigin {get; set;}

Property Value

The UCS origin.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


UcsOrthographicType Property

Aspose.Imaging Documentation

CadLayout.UcsOrthographicType Property

Gets or sets the type of the UCS orthographic.

public CadLayoutUcsOrthographicType UcsOrthographicType {get; set;}

Property Value

The type of the UCS orthographic.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


UcsTableRecordHandleWhenOrthographicUcs Property

Aspose.Imaging Documentation

CadLayout.UcsTableRecordHandleWhenOrthographicUcs Property

Gets or sets the handle ac database UCS table record UCS.

public string UcsTableRecordHandleWhenOrthographicUcs {get; set;}

Property Value

The handle ac database UCS table record orthographic UCS.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


UcsTableRecordHandleWhenUcsNamed Property

Aspose.Imaging Documentation

CadLayout.UcsTableRecordHandleWhenUcsNamed Property

Gets or sets the handle ac database UCS table record UCS named.

public string UcsTableRecordHandleWhenUcsNamed {get; set;}

Property Value

The handle ac database UCS table record UCS named.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


UcsXAxis Property

Aspose.Imaging Documentation

CadLayout.UcsXAxis Property

Gets or sets the UCS x axis.

public Cad3DPoint UcsXAxis {get; set;}

Property Value

The UCS x axis.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


UcsYAxis Property

Aspose.Imaging Documentation

CadLayout.UcsYAxis Property

Gets or sets the UCS y axis.

public Cad3DPoint UcsYAxis {get; set;}

Property Value

The UCS y axis.

See Also

CadLayout Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadLine Class

Class describing Cad line

For a list of all members of this type, see CadLine Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadLine

public class CadLine : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadLine Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadLine Members

CadLine overview

Public Instance Constructors

CadLine Constructor Initializes a new instance of the CadLine class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
FirstPoint | Gets or sets the first Point.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
SecondPoint | Gets or sets the second Point.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Thickness | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadLine Constructor

Initializes a new instance of the CadLine class.

public CadLine();

See Also

CadLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadLine Properties

The properties of the CadLine class are listed below. For a complete list of CadLine class members, see the CadLine Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
FirstPoint | Gets or sets the first Point.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
SecondPoint | Gets or sets the second Point.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Thickness | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FirstPoint Property

Aspose.Imaging Documentation

CadLine.FirstPoint Property

Gets or sets the first Point.

public Cad3DPoint FirstPoint {get; set;}

Property Value

The First Point.

See Also

CadLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SecondPoint Property

Aspose.Imaging Documentation

CadLine.SecondPoint Property

Gets or sets the second Point.

public Cad3DPoint SecondPoint {get; set;}

Property Value

The Second Point.

See Also

CadLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Thickness Property

Aspose.Imaging Documentation

CadLine.Thickness Property

Gets or sets the thickness.

public double Thickness {get; set;}

Property Value

The thickness.

See Also

CadLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadLwPolyline Class

Class describing Cad lwPoliline

For a list of all members of this type, see CadLwPolyline Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadLwPolyline

public class CadLwPolyline : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadLwPolyline Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadLwPolyline Members

CadLwPolyline overview

Public Instance Constructors

CadLwPolyline Constructor Initializes a new instance of the CadLwPolyline class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
Bugle | Gets or sets the bugle.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ConstantWidth | Gets or sets the Constant Width.
Coordinates | Gets or sets the coordinates.
Elevation | Gets or sets the elevation.
EndWidth | Gets or sets the end width.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
Flag | Gets or sets the flag.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PointCount | Gets or sets the PointCount
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartWidth | Gets or sets the start width.
Thickness | Gets or sets the Thickness
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLwPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadLwPolyline Constructor

Initializes a new instance of the CadLwPolyline class.

public CadLwPolyline();

See Also

CadLwPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadLwPolyline Properties

The properties of the CadLwPolyline class are listed below. For a complete list of CadLwPolyline class members, see the CadLwPolyline Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
Bugle | Gets or sets the bugle.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ConstantWidth | Gets or sets the Constant Width.
Coordinates | Gets or sets the coordinates.
Elevation | Gets or sets the elevation.
EndWidth | Gets or sets the end width.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
Flag | Gets or sets the flag.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PointCount | Gets or sets the PointCount
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartWidth | Gets or sets the start width.
Thickness | Gets or sets the Thickness
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadLwPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Bugle Property

Aspose.Imaging Documentation

CadLwPolyline.Bugle Property

Gets or sets the bugle.

public CadParameter} Bugle {get; set;}

Property Value

The bugle.

See Also

CadLwPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ConstantWidth Property

Aspose.Imaging Documentation

CadLwPolyline.ConstantWidth Property

Gets or sets the Constant Width.

public double ConstantWidth {get; set;}

Property Value

The Constant Width.

See Also

CadLwPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Coordinates Property

Aspose.Imaging Documentation

CadLwPolyline.Coordinates Property

Gets or sets the coordinates.

public Cad2DPoint} Coordinates {get; set;}

Property Value

The coordinates.

See Also

CadLwPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Elevation Property

Aspose.Imaging Documentation

CadLwPolyline.Elevation Property

Gets or sets the elevation.

public double Elevation {get; set;}

Property Value

The elevation.

See Also

CadLwPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


EndWidth Property

Aspose.Imaging Documentation

CadLwPolyline.EndWidth Property

Gets or sets the end width.

public CadDoubleParameter} EndWidth {get; set;}

Property Value

The end width.

See Also

CadLwPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Flag Property

Aspose.Imaging Documentation

CadLwPolyline.Flag Property

Gets or sets the flag.

public short Flag {get; set;}

Property Value

The flag.

See Also

CadLwPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PointCount Property

Aspose.Imaging Documentation

CadLwPolyline.PointCount Property

Gets or sets the PointCount

public int PointCount {get; set;}

Property Value

The count of points.

See Also

CadLwPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StartWidth Property

Aspose.Imaging Documentation

CadLwPolyline.StartWidth Property

Gets or sets the start width.

public CadDoubleParameter} StartWidth {get; set;}

Property Value

The start width.

See Also

CadLwPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Thickness Property

Aspose.Imaging Documentation

CadLwPolyline.Thickness Property

Gets or sets the Thickness

public double Thickness {get; set;}

Property Value

The Thickness.

See Also

CadLwPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMesh Class

Class describing Cad mesh

For a list of all members of this type, see CadMesh Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadMesh

public class CadMesh : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadMesh Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMesh Members

CadMesh overview

Public Instance Constructors

CadMesh Constructor Initializes a new instance of the CadMesh class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadMesh Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMesh Constructor

Initializes a new instance of the CadMesh class.

public CadMesh();

See Also

CadMesh Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMText Class

Class describing Cad Mtext

For a list of all members of this type, see CadMText Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadMText

public class CadMText : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadMText Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMText Members

CadMText overview

Public Instance Constructors

CadMText Constructor Initializes a new instance of the CadMText class.

Public Instance Properties

AdditionalText | Gets or sets the additional text.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentPoint | Gets or sets the attachment point.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BackgroundFillSetting | Gets or sets the background fill setting.
BackgroundTransparency | Gets or sets the background transparency.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ColumnAutoHeight | Gets or sets the column auto height.
ColumnCount | Gets or sets the column count.
ColumnFlow | Gets or sets the column flow.
ColumnGutter | Gets or sets the column gutter.
ColumnType | Gets or sets the column type.
ColumnWidth | Gets or sets the column width.
DirectionVector | Gets or sets the direction vector.
DrawingDirection | Gets or sets the drawing direction.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
FillBoxScale | Gets or sets the fill box scale.
FillColor | Gets or sets fill Color
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalWidth | Gets or sets the horizontal width.
InitialTextHeight | Gets or sets the initial text height.
InsertionPoint | Gets or sets the insertion point.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineSpacingStyle | Gets or sets the line spacing style.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ReferenceRectangleWidth | Gets or sets the reference rectangle width.
RotationAngleRad | Gets or sets the rotation angle rad.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
SpacingFactor | Gets or sets the spacing factor.
Text | Gets or sets the text.
TextStyleName | Gets or sets the text style name.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VerticalHeight | Gets or sets the vertical height.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMText Constructor

Initializes a new instance of the CadMText class.

public CadMText();

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMText Properties

The properties of the CadMText class are listed below. For a complete list of CadMText class members, see the CadMText Members topic.

Public Instance Properties

AdditionalText | Gets or sets the additional text.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentPoint | Gets or sets the attachment point.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BackgroundFillSetting | Gets or sets the background fill setting.
BackgroundTransparency | Gets or sets the background transparency.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ColumnAutoHeight | Gets or sets the column auto height.
ColumnCount | Gets or sets the column count.
ColumnFlow | Gets or sets the column flow.
ColumnGutter | Gets or sets the column gutter.
ColumnType | Gets or sets the column type.
ColumnWidth | Gets or sets the column width.
DirectionVector | Gets or sets the direction vector.
DrawingDirection | Gets or sets the drawing direction.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
FillBoxScale | Gets or sets the fill box scale.
FillColor | Gets or sets fill Color
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalWidth | Gets or sets the horizontal width.
InitialTextHeight | Gets or sets the initial text height.
InsertionPoint | Gets or sets the insertion point.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineSpacingStyle | Gets or sets the line spacing style.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ReferenceRectangleWidth | Gets or sets the reference rectangle width.
RotationAngleRad | Gets or sets the rotation angle rad.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
SpacingFactor | Gets or sets the spacing factor.
Text | Gets or sets the text.
TextStyleName | Gets or sets the text style name.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VerticalHeight | Gets or sets the vertical height.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AdditionalText Property

Aspose.Imaging Documentation

CadMText.AdditionalText Property

Gets or sets the additional text.

public string AdditionalText {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AttachmentPoint Property

Aspose.Imaging Documentation

CadMText.AttachmentPoint Property

Gets or sets the attachment point.

public CadAttachmentPoint AttachmentPoint {get; set;}

Property Value

The attachment point.

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BackgroundFillSetting Property

Aspose.Imaging Documentation

CadMText.BackgroundFillSetting Property

Gets or sets the background fill setting.

public CadFillSetting BackgroundFillSetting {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BackgroundTransparency Property

Aspose.Imaging Documentation

CadMText.BackgroundTransparency Property

Gets or sets the background transparency.

public int BackgroundTransparency {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColumnAutoHeight Property

Aspose.Imaging Documentation

CadMText.ColumnAutoHeight Property

Gets or sets the column auto height.

public short ColumnAutoHeight {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColumnCount Property

Aspose.Imaging Documentation

CadMText.ColumnCount Property

Gets or sets the column count.

public short ColumnCount {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColumnFlow Property

Aspose.Imaging Documentation

CadMText.ColumnFlow Property

Gets or sets the column flow.

public short ColumnFlow {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColumnGutter Property

Aspose.Imaging Documentation

CadMText.ColumnGutter Property

Gets or sets the column gutter.

public double ColumnGutter {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColumnType Property

Aspose.Imaging Documentation

CadMText.ColumnType Property

Gets or sets the column type.

public short ColumnType {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColumnWidth Property

Aspose.Imaging Documentation

CadMText.ColumnWidth Property

Gets or sets the column width.

public double ColumnWidth {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DirectionVector Property

Aspose.Imaging Documentation

CadMText.DirectionVector Property

Gets or sets the direction vector.

public Cad3DPoint DirectionVector {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DrawingDirection Property

Aspose.Imaging Documentation

CadMText.DrawingDirection Property

Gets or sets the drawing direction.

public CadDrawingDirection DrawingDirection {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FillBoxScale Property

Aspose.Imaging Documentation

CadMText.FillBoxScale Property

Gets or sets the fill box scale.

public double FillBoxScale {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FillColor Property

Aspose.Imaging Documentation

CadMText.FillColor Property

Gets or sets fill Color

public short FillColor {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HorizontalWidth Property

Aspose.Imaging Documentation

CadMText.HorizontalWidth Property

Gets or sets the horizontal width.

public double HorizontalWidth {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


InitialTextHeight Property

Aspose.Imaging Documentation

CadMText.InitialTextHeight Property

Gets or sets the initial text height.

public double InitialTextHeight {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


InsertionPoint Property

Aspose.Imaging Documentation

CadMText.InsertionPoint Property

Gets or sets the insertion point.

public Cad3DPoint InsertionPoint {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LineSpacingStyle Property

Aspose.Imaging Documentation

CadMText.LineSpacingStyle Property

Gets or sets the line spacing style.

public CadLineSpacing LineSpacingStyle {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ReferenceRectangleWidth Property

Aspose.Imaging Documentation

CadMText.ReferenceRectangleWidth Property

Gets or sets the reference rectangle width.

public double ReferenceRectangleWidth {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RotationAngleRad Property

Aspose.Imaging Documentation

CadMText.RotationAngleRad Property

Gets or sets the rotation angle rad.

public double RotationAngleRad {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SpacingFactor Property

Aspose.Imaging Documentation

CadMText.SpacingFactor Property

Gets or sets the spacing factor.

public double SpacingFactor {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Text Property

Aspose.Imaging Documentation

CadMText.Text Property

Gets or sets the text.

public string Text {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextStyleName Property

Aspose.Imaging Documentation

CadMText.TextStyleName Property

Gets or sets the text style name.

public string TextStyleName {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


VerticalHeight Property

Aspose.Imaging Documentation

CadMText.VerticalHeight Property

Gets or sets the vertical height.

public double VerticalHeight {get; set;}

See Also

CadMText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMultiLine Class

The Cad multi line.

For a list of all members of this type, see CadMultiLine Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadMultiLine

public class CadMultiLine : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadMultiLine Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMultiLine Members

CadMultiLine overview

Public Instance Constructors

CadMultiLine Constructor Initializes a new instance of the CadMultiLine class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
Justification | Gets or sets the justification: 0 = Top; 1 = Zero; 2 = Bottom
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
NumberOfStyleElements | Gets or sets the number of style elements.
NumberOfVertices | Gets or sets the number of vertices.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartPoint | Gets the start point.
StyleName | Gets or sets the style name.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VectorBlocks | Gets or sets the vector blocks.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadMultiLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMultiLine Constructor

Initializes a new instance of the CadMultiLine class.

public CadMultiLine();

See Also

CadMultiLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMultiLine Properties

The properties of the CadMultiLine class are listed below. For a complete list of CadMultiLine class members, see the CadMultiLine Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
Justification | Gets or sets the justification: 0 = Top; 1 = Zero; 2 = Bottom
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
NumberOfStyleElements | Gets or sets the number of style elements.
NumberOfVertices | Gets or sets the number of vertices.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartPoint | Gets the start point.
StyleName | Gets or sets the style name.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VectorBlocks | Gets or sets the vector blocks.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadMultiLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Justification Property

Aspose.Imaging Documentation

CadMultiLine.Justification Property

Gets or sets the justification: 0 = Top; 1 = Zero; 2 = Bottom

public short Justification {get; set;}

See Also

CadMultiLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


NumberOfStyleElements Property

Aspose.Imaging Documentation

CadMultiLine.NumberOfStyleElements Property

Gets or sets the number of style elements.

public short NumberOfStyleElements {get; set;}

Property Value

The number of style elements.

See Also

CadMultiLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


NumberOfVertices Property

Aspose.Imaging Documentation

CadMultiLine.NumberOfVertices Property

Gets or sets the number of vertices.

public short NumberOfVertices {get; set;}

See Also

CadMultiLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StartPoint Property

Aspose.Imaging Documentation

CadMultiLine.StartPoint Property

Gets the start point.

public Cad3DPoint StartPoint {get;}

See Also

CadMultiLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StyleName Property

Aspose.Imaging Documentation

CadMultiLine.StyleName Property

Gets or sets the style name.

public string StyleName {get; set;}

See Also

CadMultiLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


VectorBlocks Property

Aspose.Imaging Documentation

CadMultiLine.VectorBlocks Property

Gets or sets the vector blocks.

public CadMultiLineVectorBlock} VectorBlocks {get; set;}

Property Value

The vector blocks.

See Also

CadMultiLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMultiLineVectorBlock Class

Cad mline vector block

For a list of all members of this type, see CadMultiLineVectorBlock Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadMultiLineVectorBlock

public class CadMultiLineVectorBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadMultiLineVectorBlock Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMultiLineVectorBlock Members

CadMultiLineVectorBlock overview

Public Instance Constructors

CadMultiLineVectorBlock Constructor Initializes a new instance of the CadMultiLineVectorBlock class.

Public Instance Properties

AreaParameters | Gets or sets the area parameters.
AreaParametersCount | Gets or sets the area parameters count.
ElementParameters | Gets or sets the element parameters.
ElementParametersCount | Gets or sets the element parameters count.
MilterVector | Gets or sets the milter vector.
SegmentDirection | Gets or sets the segment direction.
Vertex | Gets or sets the vertex.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadMultiLineVectorBlock Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMultiLineVectorBlock Constructor

Initializes a new instance of the CadMultiLineVectorBlock class.

public CadMultiLineVectorBlock();

See Also

CadMultiLineVectorBlock Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadMultiLineVectorBlock Properties

The properties of the CadMultiLineVectorBlock class are listed below. For a complete list of CadMultiLineVectorBlock class members, see the CadMultiLineVectorBlock Members topic.

Public Instance Properties

AreaParameters | Gets or sets the area parameters.
AreaParametersCount | Gets or sets the area parameters count.
ElementParameters | Gets or sets the element parameters.
ElementParametersCount | Gets or sets the element parameters count.
MilterVector | Gets or sets the milter vector.
SegmentDirection | Gets or sets the segment direction.
Vertex | Gets or sets the vertex.

See Also

CadMultiLineVectorBlock Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AreaParameters Property

Aspose.Imaging Documentation

CadMultiLineVectorBlock.AreaParameters Property

Gets or sets the area parameters.

public CadDoubleParameter} AreaParameters {get; set;}

See Also

CadMultiLineVectorBlock Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AreaParametersCount Property

Aspose.Imaging Documentation

CadMultiLineVectorBlock.AreaParametersCount Property

Gets or sets the area parameters count.

public CadShortParameter} AreaParametersCount {get; set;}

See Also

CadMultiLineVectorBlock Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ElementParameters Property

Aspose.Imaging Documentation

CadMultiLineVectorBlock.ElementParameters Property

Gets or sets the element parameters.

public CadDoubleParameter} ElementParameters {get; set;}

See Also

CadMultiLineVectorBlock Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ElementParametersCount Property

Aspose.Imaging Documentation

CadMultiLineVectorBlock.ElementParametersCount Property

Gets or sets the element parameters count.

public CadShortParameter} ElementParametersCount {get; set;}

See Also

CadMultiLineVectorBlock Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MilterVector Property

Aspose.Imaging Documentation

CadMultiLineVectorBlock.MilterVector Property

Gets or sets the milter vector.

public Cad3DPoint MilterVector {get; set;}

See Also

CadMultiLineVectorBlock Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SegmentDirection Property

Aspose.Imaging Documentation

CadMultiLineVectorBlock.SegmentDirection Property

Gets or sets the segment direction.

public Cad3DPoint SegmentDirection {get; set;}

See Also

CadMultiLineVectorBlock Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Vertex Property

Aspose.Imaging Documentation

CadMultiLineVectorBlock.Vertex Property

Gets or sets the vertex.

public Cad3DPoint Vertex {get; set;}

See Also

CadMultiLineVectorBlock Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPlotSettings Class

The Cad Plot Settings object.

For a list of all members of this type, see CadPlotSettings Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseObject
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPlotSettings
Aspose.Imaging.FileFormats.Cad.CadObjects.CadLayout

public class CadPlotSettings : CadBaseObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadPlotSettings Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPlotSettings Members

CadPlotSettings overview

Public Instance Constructors

CadPlotSettings Constructor Initializes a new instance of the CadPlotSettings class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BottomSize | Gets or sets the size of the bottom.
ChildObjects (inherited from CadBaseObject) | Gets or sets the child objects.
CurrentStyleSheet | Gets or sets the current style sheet.
CustomPrintScaleDenominator | Gets or sets the custom print scale denominator.
CustomPrintScaleNumerator | Gets or sets the custom print scale numerator.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LeftSideSize | Gets or sets the size of the left side.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PageSetupName | Gets or sets the name of the page setup.
PaperImageOrigin | Gets or sets the paper image origin.
PaperSize | Gets or sets the size of the paper.
PlotLayoutFlag | Gets or sets the plot layout flag.
PlotOrigin | Gets or sets the plot origin.
PlotPaperSize | Gets or sets the size of the plot paper.
PlotPaperUnits | Gets or sets the plot paper units.
PlotRotation | Gets or sets the plot rotation.
PlotType | Gets or sets the type of the plot.
PlotViewName | Gets or sets the name of the plot view.
PlotWindowArea1 | Gets or sets the plot window area1.
PlotWindowArea2 | Gets or sets the plot window area2.
PrinterOrConfigurationFileName | Gets or sets the name of the printer or configuration file.
PropertyList (inherited from CadBase) | Gets or sets the property list.
RightSideSize | Gets or sets the size of the right side.
ShadePlotCustomDpi | Gets or sets the shade plot custom dpi.
ShadePlotHandle | Gets or sets the shade plot handle.
ShadePlotMode | Gets or sets the shade plot mode.
ShadePlotResolutionLevel | Gets or sets the shade plot resolution level.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
StandardScaleType | Gets or sets the type of the standard scale.
StandardScaleTypeFactor | Gets or sets the standard scale type factor.
TopSize | Gets or sets the size of the top.
TypeName (inherited from CadBaseObject) | Gets the name of the type.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPlotSettings Constructor

Initializes a new instance of the CadPlotSettings class.

public CadPlotSettings();

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPlotSettings Properties

The properties of the CadPlotSettings class are listed below. For a complete list of CadPlotSettings class members, see the CadPlotSettings Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BottomSize | Gets or sets the size of the bottom.
ChildObjects (inherited from CadBaseObject) | Gets or sets the child objects.
CurrentStyleSheet | Gets or sets the current style sheet.
CustomPrintScaleDenominator | Gets or sets the custom print scale denominator.
CustomPrintScaleNumerator | Gets or sets the custom print scale numerator.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LeftSideSize | Gets or sets the size of the left side.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PageSetupName | Gets or sets the name of the page setup.
PaperImageOrigin | Gets or sets the paper image origin.
PaperSize | Gets or sets the size of the paper.
PlotLayoutFlag | Gets or sets the plot layout flag.
PlotOrigin | Gets or sets the plot origin.
PlotPaperSize | Gets or sets the size of the plot paper.
PlotPaperUnits | Gets or sets the plot paper units.
PlotRotation | Gets or sets the plot rotation.
PlotType | Gets or sets the type of the plot.
PlotViewName | Gets or sets the name of the plot view.
PlotWindowArea1 | Gets or sets the plot window area1.
PlotWindowArea2 | Gets or sets the plot window area2.
PrinterOrConfigurationFileName | Gets or sets the name of the printer or configuration file.
PropertyList (inherited from CadBase) | Gets or sets the property list.
RightSideSize | Gets or sets the size of the right side.
ShadePlotCustomDpi | Gets or sets the shade plot custom dpi.
ShadePlotHandle | Gets or sets the shade plot handle.
ShadePlotMode | Gets or sets the shade plot mode.
ShadePlotResolutionLevel | Gets or sets the shade plot resolution level.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
StandardScaleType | Gets or sets the type of the standard scale.
StandardScaleTypeFactor | Gets or sets the standard scale type factor.
TopSize | Gets or sets the size of the top.
TypeName (inherited from CadBaseObject) | Gets the name of the type.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BottomSize Property

Aspose.Imaging Documentation

CadPlotSettings.BottomSize Property

Gets or sets the size of the bottom.

public double BottomSize {get; set;}

Property Value

The size of the bottom.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CurrentStyleSheet Property

Aspose.Imaging Documentation

CadPlotSettings.CurrentStyleSheet Property

Gets or sets the current style sheet.

public string CurrentStyleSheet {get; set;}

Property Value

The current style sheet.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CustomPrintScaleDenominator Property

Aspose.Imaging Documentation

CadPlotSettings.CustomPrintScaleDenominator Property

Gets or sets the custom print scale denominator.

public double CustomPrintScaleDenominator {get; set;}

Property Value

The custom print scale denominator.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CustomPrintScaleNumerator Property

Aspose.Imaging Documentation

CadPlotSettings.CustomPrintScaleNumerator Property

Gets or sets the custom print scale numerator.

public double CustomPrintScaleNumerator {get; set;}

Property Value

The custom print scale numerator.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LeftSideSize Property

Aspose.Imaging Documentation

CadPlotSettings.LeftSideSize Property

Gets or sets the size of the left side.

public double LeftSideSize {get; set;}

Property Value

The size of the left side.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PageSetupName Property

Aspose.Imaging Documentation

CadPlotSettings.PageSetupName Property

Gets or sets the name of the page setup.

public string PageSetupName {get; set;}

Property Value

The name of the page setup.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PaperImageOrigin Property

Aspose.Imaging Documentation

CadPlotSettings.PaperImageOrigin Property

Gets or sets the paper image origin.

public Cad2DPoint PaperImageOrigin {get; set;}

Property Value

The paper image origin.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PaperSize Property

Aspose.Imaging Documentation

CadPlotSettings.PaperSize Property

Gets or sets the size of the paper.

public string PaperSize {get; set;}

Property Value

The size of the paper.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PlotLayoutFlag Property

Aspose.Imaging Documentation

CadPlotSettings.PlotLayoutFlag Property

Gets or sets the plot layout flag.

public CadPlotLayoutFlag PlotLayoutFlag {get; set;}

Property Value

The plot layout flag.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PlotOrigin Property

Aspose.Imaging Documentation

CadPlotSettings.PlotOrigin Property

Gets or sets the plot origin.

public Cad2DPoint PlotOrigin {get; set;}

Property Value

The plot origin.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PlotPaperSize Property

Aspose.Imaging Documentation

CadPlotSettings.PlotPaperSize Property

Gets or sets the size of the plot paper.

public CadSize PlotPaperSize {get; set;}

Property Value

The size of the plot paper.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PlotPaperUnits Property

Aspose.Imaging Documentation

CadPlotSettings.PlotPaperUnits Property

Gets or sets the plot paper units.

public CadPlotPaperUnits PlotPaperUnits {get; set;}

Property Value

The plot paper units.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PlotRotation Property

Aspose.Imaging Documentation

CadPlotSettings.PlotRotation Property

Gets or sets the plot rotation.

public CadPlotRotation PlotRotation {get; set;}

Property Value

The plot rotation.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PlotType Property

Aspose.Imaging Documentation

CadPlotSettings.PlotType Property

Gets or sets the type of the plot.

public CadPlotType PlotType {get; set;}

Property Value

The type of the plot.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PlotViewName Property

Aspose.Imaging Documentation

CadPlotSettings.PlotViewName Property

Gets or sets the name of the plot view.

public string PlotViewName {get; set;}

Property Value

The name of the plot view.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PlotWindowArea1 Property

Aspose.Imaging Documentation

CadPlotSettings.PlotWindowArea1 Property

Gets or sets the plot window area1.

public Cad2DPoint PlotWindowArea1 {get; set;}

Property Value

The plot window area1.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PlotWindowArea2 Property

Aspose.Imaging Documentation

CadPlotSettings.PlotWindowArea2 Property

Gets or sets the plot window area2.

public Cad2DPoint PlotWindowArea2 {get; set;}

Property Value

The plot window area2.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PrinterOrConfigurationFileName Property

Aspose.Imaging Documentation

CadPlotSettings.PrinterOrConfigurationFileName Property

Gets or sets the name of the printer or configuration file.

public string PrinterOrConfigurationFileName {get; set;}

Property Value

The name of the printer or configuration file.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RightSideSize Property

Aspose.Imaging Documentation

CadPlotSettings.RightSideSize Property

Gets or sets the size of the right side.

public double RightSideSize {get; set;}

Property Value

The size of the right side.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ShadePlotCustomDpi Property

Aspose.Imaging Documentation

CadPlotSettings.ShadePlotCustomDpi Property

Gets or sets the shade plot custom dpi.

public short ShadePlotCustomDpi {get; set;}

Property Value

The shade plot custom dpi.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ShadePlotHandle Property

Aspose.Imaging Documentation

CadPlotSettings.ShadePlotHandle Property

Gets or sets the shade plot handle.

public string ShadePlotHandle {get; set;}

Property Value

The shade plot handle.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ShadePlotMode Property

Aspose.Imaging Documentation

CadPlotSettings.ShadePlotMode Property

Gets or sets the shade plot mode.

public CadShadePlotMode ShadePlotMode {get; set;}

Property Value

The shade plot mode.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ShadePlotResolutionLevel Property

Aspose.Imaging Documentation

CadPlotSettings.ShadePlotResolutionLevel Property

Gets or sets the shade plot resolution level.

public CadShadePlotResolutionLevel ShadePlotResolutionLevel {get; set;}

Property Value

The shade plot resolution level.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StandardScaleType Property

Aspose.Imaging Documentation

CadPlotSettings.StandardScaleType Property

Gets or sets the type of the standard scale.

public CadPlotStandardScaleType StandardScaleType {get; set;}

Property Value

The type of the standard scale.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StandardScaleTypeFactor Property

Aspose.Imaging Documentation

CadPlotSettings.StandardScaleTypeFactor Property

Gets or sets the standard scale type factor.

public double StandardScaleTypeFactor {get; set;}

Property Value

The standard scale type factor.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TopSize Property

Aspose.Imaging Documentation

CadPlotSettings.TopSize Property

Gets or sets the size of the top.

public double TopSize {get; set;}

Property Value

The size of the top.

See Also

CadPlotSettings Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPoint Class

Class describing Cad ARC

For a list of all members of this type, see CadPoint Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPoint

public class CadPoint : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadPoint Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPoint Members

CadPoint overview

Public Instance Constructors

CadPoint Constructor Initializes a new instance of the CadPoint class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PointLocation | Gets or sets the point location.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartAngle | Gets or sets angle XAxis.
Thickness | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPoint Constructor

Initializes a new instance of the CadPoint class.

public CadPoint();

See Also

CadPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPoint Properties

The properties of the CadPoint class are listed below. For a complete list of CadPoint class members, see the CadPoint Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PointLocation | Gets or sets the point location.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartAngle | Gets or sets angle XAxis.
Thickness | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PointLocation Property

Aspose.Imaging Documentation

CadPoint.PointLocation Property

Gets or sets the point location.

public Cad3DPoint PointLocation {get; set;}

Property Value

The Point location.

See Also

CadPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StartAngle Property

Aspose.Imaging Documentation

CadPoint.StartAngle Property

Gets or sets angle XAxis.

public double StartAngle {get; set;}

Property Value

The angle X axis

See Also

CadPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Thickness Property

Aspose.Imaging Documentation

CadPoint.Thickness Property

Gets or sets the thickness.

public double Thickness {get; set;}

Property Value

The thickness.

See Also

CadPoint Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolyline Class

Class describing Cad POLYLINE

For a list of all members of this type, see CadPolyline Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPolylineBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPolyline

public class CadPolyline : CadPolylineBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadPolyline Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolyline Members

CadPolyline overview

Public Instance Constructors

CadPolyline Constructor Initializes a new instance of the CadPolyline class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
Elevation (inherited from CadPolylineBase) | Gets or sets the elevation.
EndWidth (inherited from CadPolylineBase) | Gets or sets the end width.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
Flag (inherited from CadPolylineBase) | Gets or sets the flag.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MeshMVertexCount (inherited from CadPolylineBase) | Gets or sets the mesh M vertex count.
MeshNVertexCount (inherited from CadPolylineBase) | Gets or sets the mesh N vertex count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartWidth (inherited from CadPolylineBase) | Gets or sets the start width.
SurfaceMDensity (inherited from CadPolylineBase) | Gets or sets the surface M density.
SurfaceNDensity (inherited from CadPolylineBase) | Gets or sets the surface N density.
SurfaceType (inherited from CadPolylineBase) | Gets or sets the type of the surface.
Thickness (inherited from CadPolylineBase) | Gets or sets the Thickness
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolyline Constructor

Initializes a new instance of the CadPolyline class.

public CadPolyline();

See Also

CadPolyline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolyline3D Class

The Cad polyline 3 d.

For a list of all members of this type, see CadPolyline3D Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPolylineBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPolyline3D

public class CadPolyline3D : CadPolylineBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadPolyline3D Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolyline3D Members

CadPolyline3D overview

Public Instance Constructors

CadPolyline3D Constructor Initializes a new instance of the CadPolyline3D class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
Elevation (inherited from CadPolylineBase) | Gets or sets the elevation.
EndWidth (inherited from CadPolylineBase) | Gets or sets the end width.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
Flag (inherited from CadPolylineBase) | Gets or sets the flag.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MeshMVertexCount (inherited from CadPolylineBase) | Gets or sets the mesh M vertex count.
MeshNVertexCount (inherited from CadPolylineBase) | Gets or sets the mesh N vertex count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartWidth (inherited from CadPolylineBase) | Gets or sets the start width.
SurfaceMDensity (inherited from CadPolylineBase) | Gets or sets the surface M density.
SurfaceNDensity (inherited from CadPolylineBase) | Gets or sets the surface N density.
SurfaceType (inherited from CadPolylineBase) | Gets or sets the type of the surface.
Thickness (inherited from CadPolylineBase) | Gets or sets the Thickness
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadPolyline3D Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolyline3D Constructor

Initializes a new instance of the CadPolyline3D class.

public CadPolyline3D();

See Also

CadPolyline3D Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolylineBase Class

Class describing Cad POLYLINE

For a list of all members of this type, see CadPolylineBase Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPolylineBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPolyline
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPolyline3D

public class CadPolylineBase : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadPolylineBase Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolylineBase Members

CadPolylineBase overview

Public Instance Constructors

CadPolylineBase Constructor Initializes a new instance of the CadPolylineBase class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
Elevation | Gets or sets the elevation.
EndWidth | Gets or sets the end width.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
Flag | Gets or sets the flag.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MeshMVertexCount | Gets or sets the mesh M vertex count.
MeshNVertexCount | Gets or sets the mesh N vertex count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartWidth | Gets or sets the start width.
SurfaceMDensity | Gets or sets the surface M density.
SurfaceNDensity | Gets or sets the surface N density.
SurfaceType | Gets or sets the type of the surface.
Thickness | Gets or sets the Thickness
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolylineBase Constructor

Initializes a new instance of the CadPolylineBase class.

public CadPolylineBase();

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolylineBase Properties

The properties of the CadPolylineBase class are listed below. For a complete list of CadPolylineBase class members, see the CadPolylineBase Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
Elevation | Gets or sets the elevation.
EndWidth | Gets or sets the end width.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
Flag | Gets or sets the flag.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MeshMVertexCount | Gets or sets the mesh M vertex count.
MeshNVertexCount | Gets or sets the mesh N vertex count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartWidth | Gets or sets the start width.
SurfaceMDensity | Gets or sets the surface M density.
SurfaceNDensity | Gets or sets the surface N density.
SurfaceType | Gets or sets the type of the surface.
Thickness | Gets or sets the Thickness
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Elevation Property

Aspose.Imaging Documentation

CadPolylineBase.Elevation Property

Gets or sets the elevation.

public double Elevation {get; set;}

Property Value

The elevation.

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


EndWidth Property

Aspose.Imaging Documentation

CadPolylineBase.EndWidth Property

Gets or sets the end width.

public double EndWidth {get; set;}

Property Value

The end width.

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Flag Property

Aspose.Imaging Documentation

CadPolylineBase.Flag Property

Gets or sets the flag.

public short Flag {get; set;}

Property Value

The flag.

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MeshMVertexCount Property

Aspose.Imaging Documentation

CadPolylineBase.MeshMVertexCount Property

Gets or sets the mesh M vertex count.

public short MeshMVertexCount {get; set;}

Property Value

The mesh M vertex count.

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MeshNVertexCount Property

Aspose.Imaging Documentation

CadPolylineBase.MeshNVertexCount Property

Gets or sets the mesh N vertex count.

public short MeshNVertexCount {get; set;}

Property Value

The mesh N vertex count.

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StartWidth Property

Aspose.Imaging Documentation

CadPolylineBase.StartWidth Property

Gets or sets the start width.

public double StartWidth {get; set;}

Property Value

The start width.

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SurfaceMDensity Property

Aspose.Imaging Documentation

CadPolylineBase.SurfaceMDensity Property

Gets or sets the surface M density.

public short SurfaceMDensity {get; set;}

Property Value

The surface M density.

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SurfaceNDensity Property

Aspose.Imaging Documentation

CadPolylineBase.SurfaceNDensity Property

Gets or sets the surface N density.

public short SurfaceNDensity {get; set;}

Property Value

The surface N density.

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SurfaceType Property

Aspose.Imaging Documentation

CadPolylineBase.SurfaceType Property

Gets or sets the type of the surface.

public short SurfaceType {get; set;}

Property Value

The type of the surface.

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Thickness Property

Aspose.Imaging Documentation

CadPolylineBase.Thickness Property

Gets or sets the Thickness

public double Thickness {get; set;}

Property Value

The Thickness.

See Also

CadPolylineBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolylineBoundaryPath Class

The Cad polyline boundary path.

For a list of all members of this type, see CadPolylineBoundaryPath Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPolylineBoundaryPath

public class CadPolylineBoundaryPath

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadPolylineBoundaryPath Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolylineBoundaryPath Members

CadPolylineBoundaryPath overview

Public Instance Constructors

CadPolylineBoundaryPath Constructor Initializes a new instance of the CadPolylineBoundaryPath class.

Public Instance Properties

HasBugle | Gets or sets a value indicating whether has bugle.
IsClosed | Gets or sets a value indicating whether is closed.
MaxArrayLen | Gets or sets the max array len.
Objects | Gets or sets the points.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadPolylineBoundaryPath Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolylineBoundaryPath Constructor

Initializes a new instance of the CadPolylineBoundaryPath class.

public CadPolylineBoundaryPath();

See Also

CadPolylineBoundaryPath Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadPolylineBoundaryPath Properties

The properties of the CadPolylineBoundaryPath class are listed below. For a complete list of CadPolylineBoundaryPath class members, see the CadPolylineBoundaryPath Members topic.

Public Instance Properties

HasBugle | Gets or sets a value indicating whether has bugle.
IsClosed | Gets or sets a value indicating whether is closed.
MaxArrayLen | Gets or sets the max array len.
Objects | Gets or sets the points.

See Also

CadPolylineBoundaryPath Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HasBugle Property

Aspose.Imaging Documentation

CadPolylineBoundaryPath.HasBugle Property

Gets or sets a value indicating whether has bugle.

public bool HasBugle {get; set;}

See Also

CadPolylineBoundaryPath Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


IsClosed Property

Aspose.Imaging Documentation

CadPolylineBoundaryPath.IsClosed Property

Gets or sets a value indicating whether is closed.

public bool IsClosed {get; set;}

See Also

CadPolylineBoundaryPath Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MaxArrayLen Property

Aspose.Imaging Documentation

CadPolylineBoundaryPath.MaxArrayLen Property

Gets or sets the max array len.

public int MaxArrayLen {get; set;}

See Also

CadPolylineBoundaryPath Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Objects Property

Aspose.Imaging Documentation

CadPolylineBoundaryPath.Objects Property

Gets or sets the points.

public CadBaseEntity} Objects {get; set;}

See Also

CadPolylineBoundaryPath Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadProxyEntity Class

Class describing Cad Acad Proxy Entity

For a list of all members of this type, see CadProxyEntity Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadProxyEntity

public class CadProxyEntity : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadProxyEntity Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadProxyEntity Members

CadProxyEntity overview

Public Instance Constructors

CadProxyEntity Constructor Initializes a new instance of the CadProxyEntity class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
ApplicationEntityClassID | Gets or sets Application entity's class ID.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
CustomObjectDataFormat | Gets or sets Original custom object data format:
EntityData | Gets or sets the Binary entity data
EntityDataSize | Gets or sets Size of entity data in bits
GraphicsData | Gets or sets the Binary graphics data
GraphicsDataSize | Gets or sets Size of graphics data in bytes
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectDrawingFormat | Gets or sets Object drawing format
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
ObjectID | Gets or sets an object ID
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ProxyEntityClassID | Gets or sets Proxy entity class ID
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadProxyEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadProxyEntity Constructor

Initializes a new instance of the CadProxyEntity class.

public CadProxyEntity();

See Also

CadProxyEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadProxyEntity Properties

The properties of the CadProxyEntity class are listed below. For a complete list of CadProxyEntity class members, see the CadProxyEntity Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
ApplicationEntityClassID | Gets or sets Application entity's class ID.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
CustomObjectDataFormat | Gets or sets Original custom object data format:
EntityData | Gets or sets the Binary entity data
EntityDataSize | Gets or sets Size of entity data in bits
GraphicsData | Gets or sets the Binary graphics data
GraphicsDataSize | Gets or sets Size of graphics data in bytes
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectDrawingFormat | Gets or sets Object drawing format
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
ObjectID | Gets or sets an object ID
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ProxyEntityClassID | Gets or sets Proxy entity class ID
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadProxyEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ApplicationEntityClassID Property

Aspose.Imaging Documentation

CadProxyEntity.ApplicationEntityClassID Property

Gets or sets Application entity's class ID.

public int ApplicationEntityClassID {get; set;}

Property Value

The Application entity's class ID.

See Also

CadProxyEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CustomObjectDataFormat Property

Aspose.Imaging Documentation

CadProxyEntity.CustomObjectDataFormat Property

Gets or sets Original custom object data format:

public int CustomObjectDataFormat {get; set;}

Property Value

The Original custom object data format:

See Also

CadProxyEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


EntityData Property

Aspose.Imaging Documentation

CadProxyEntity.EntityData Property

Gets or sets the Binary entity data

public string EntityData {get; set;}

Property Value

The Binary entity data

See Also

CadProxyEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


EntityDataSize Property

Aspose.Imaging Documentation

CadProxyEntity.EntityDataSize Property

Gets or sets Size of entity data in bits

public int EntityDataSize {get; set;}

Property Value

Size of entity data in bits

See Also

CadProxyEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


GraphicsData Property

Aspose.Imaging Documentation

CadProxyEntity.GraphicsData Property

Gets or sets the Binary graphics data

public string GraphicsData {get; set;}

Property Value

The Binary graphics data

See Also

CadProxyEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


GraphicsDataSize Property

Aspose.Imaging Documentation

CadProxyEntity.GraphicsDataSize Property

Gets or sets Size of graphics data in bytes

public int GraphicsDataSize {get; set;}

Property Value

The Size of graphics data in bytes

See Also

CadProxyEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ObjectDrawingFormat Property

Aspose.Imaging Documentation

CadProxyEntity.ObjectDrawingFormat Property

Gets or sets Object drawing format

public int ObjectDrawingFormat {get; set;}

Property Value

The Object drawing format

See Also

CadProxyEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ObjectID Property

Aspose.Imaging Documentation

CadProxyEntity.ObjectID Property

Gets or sets an object ID

public string ObjectID {get; set;}

Property Value

The object ID

See Also

CadProxyEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ProxyEntityClassID Property

Aspose.Imaging Documentation

CadProxyEntity.ProxyEntityClassID Property

Gets or sets Proxy entity class ID

public int ProxyEntityClassID {get; set;}

Property Value

The Proxy entity class ID

See Also

CadProxyEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadRadialDimension Class

The Cad radial dimension. NOTE: This class is an exact copy of CadDiametricDimension except sublcass name

For a list of all members of this type, see CadRadialDimension Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDimensionBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadRadialDimension

public class CadRadialDimension : CadDimensionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadRadialDimension Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadRadialDimension Members

CadRadialDimension overview

Public Instance Constructors

CadRadialDimension Constructor Initializes a new instance of the CadRadialDimension class.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LeaderLength | Gets or sets the leader length.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RadiusDefinitionPoint | Gets or sets the radius definition point.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadRadialDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadRadialDimension Constructor

Initializes a new instance of the CadRadialDimension class.

public CadRadialDimension();

See Also

CadRadialDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadRadialDimension Properties

The properties of the CadRadialDimension class are listed below. For a complete list of CadRadialDimension class members, see the CadRadialDimension Members topic.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LeaderLength | Gets or sets the leader length.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RadiusDefinitionPoint | Gets or sets the radius definition point.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadRadialDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LeaderLength Property

Aspose.Imaging Documentation

CadRadialDimension.LeaderLength Property

Gets or sets the leader length.

public double LeaderLength {get; set;}

See Also

CadRadialDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RadiusDefinitionPoint Property

Aspose.Imaging Documentation

CadRadialDimension.RadiusDefinitionPoint Property

Gets or sets the radius definition point.

public Cad3DPoint RadiusDefinitionPoint {get; set;}

See Also

CadRadialDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadRay Class

Class describing CadRay

For a list of all members of this type, see CadRay Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadRay

public class CadRay : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadRay Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadRay Members

CadRay overview

Public Instance Constructors

CadRay Constructor Initializes a new instance of the CadRay class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartPoint | Gets or sets the start point .
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
UnitDirectionVector | Gets or sets the unit direction vector.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadRay Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadRay Constructor

Initializes a new instance of the CadRay class.

public CadRay();

See Also

CadRay Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadRay Properties

The properties of the CadRay class are listed below. For a complete list of CadRay class members, see the CadRay Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartPoint | Gets or sets the start point .
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
UnitDirectionVector | Gets or sets the unit direction vector.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadRay Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StartPoint Property

Aspose.Imaging Documentation

CadRay.StartPoint Property

Gets or sets the start point .

public Cad3DPoint StartPoint {get; set;}

Property Value

The Point location.

See Also

CadRay Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


UnitDirectionVector Property

Aspose.Imaging Documentation

CadRay.UnitDirectionVector Property

Gets or sets the unit direction vector.

public Cad3DPoint UnitDirectionVector {get; set;}

Property Value

The unit direction vector.

See Also

CadRay Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadRotatedDimension Class

The Cad rotated dimension.

For a list of all members of this type, see CadRotatedDimension Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDimensionBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadAlignedDimension
Aspose.Imaging.FileFormats.Cad.CadObjects.CadRotatedDimension

public class CadRotatedDimension : CadAlignedDimension

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadRotatedDimension Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadRotatedDimension Members

CadRotatedDimension overview

Public Instance Constructors

CadRotatedDimension Constructor Initializes a new instance of the CadRotatedDimension class.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DefinitionPoint1 (inherited from CadAlignedDimension) | Gets or sets the definition point1.
DefinitionPoint2 (inherited from CadAlignedDimension) | Gets or sets the definition point2.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtensionLineAngle | Gets or sets the extension line angle.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
InsertionPoint (inherited from CadAlignedDimension) | Gets or sets the insertion point.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RotationAngle | Gets or sets the rotation angle.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadRotatedDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadRotatedDimension Constructor

Initializes a new instance of the CadRotatedDimension class.

public CadRotatedDimension();

See Also

CadRotatedDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadRotatedDimension Properties

The properties of the CadRotatedDimension class are listed below. For a complete list of CadRotatedDimension class members, see the CadRotatedDimension Members topic.

Public Instance Properties

ActualMeasurement (inherited from CadDimensionBase) | Gets or sets the actual measurement.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttachmentType (inherited from CadDimensionBase) | Gets or sets the attachment type.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName (inherited from CadDimensionBase) | Gets or sets the block name.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefinitionPoint (inherited from CadDimensionBase) | Gets or sets the definition point.
DefinitionPoint1 (inherited from CadAlignedDimension) | Gets or sets the definition point1.
DefinitionPoint2 (inherited from CadAlignedDimension) | Gets or sets the definition point2.
DimensionTextLineSpacingFactor (inherited from CadDimensionBase) | Gets or sets the dimension text line spacing factor.
DimensionType (inherited from CadDimensionBase) | Gets or sets the dimension type.
ExtensionLineAngle | Gets or sets the extension line angle.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalDirection (inherited from CadDimensionBase) | Gets or sets the horizontal direction.
InsertionPoint (inherited from CadAlignedDimension) | Gets or sets the insertion point.
IsSingleUse (inherited from CadDimensionBase) | Gets a value indicating whether is single use.
IsUserDimension (inherited from CadDimensionBase) | Gets a value indicating whether this instance is user dimension.
IsXOrdinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is X ordinate.
IsYordinate (inherited from CadDimensionBase) | Gets a value indicating whether this instance is yordinate.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MiddleTextLocation (inherited from CadDimensionBase) | Gets or sets the middle text location.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RotationAngle | Gets or sets the rotation angle.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleName (inherited from CadDimensionBase) | Gets or sets the style name.
Text (inherited from CadDimensionBase) | Gets or sets the text.
TextLineSpacing (inherited from CadDimensionBase) | Gets or sets the text line spacing.
TextRotationAngle (inherited from CadDimensionBase) | Gets or sets the textRotationAngle angle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadRotatedDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ExtensionLineAngle Property

Aspose.Imaging Documentation

CadRotatedDimension.ExtensionLineAngle Property

Gets or sets the extension line angle.

public double ExtensionLineAngle {get; set;}

Property Value

The extension line angle.

See Also

CadRotatedDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RotationAngle Property

Aspose.Imaging Documentation

CadRotatedDimension.RotationAngle Property

Gets or sets the rotation angle.

public double RotationAngle {get; set;}

See Also

CadRotatedDimension Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSectionEntity Class

Class describing Cad Section Entity

For a list of all members of this type, see CadSectionEntity Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadSectionEntity

public class CadSectionEntity : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadSectionEntity Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSectionEntity Members

CadSectionEntity overview

Public Instance Constructors

CadSectionEntity Constructor Initializes a new instance of the CadSectionEntity class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BackLineVertexCount | Gets or sets the back line vertex count.
BackVertices | Gets or sets the back vertices.
BottomHeight | Gets or sets the bottom height.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
Color441 | Gets or sets the color 441.
Color63 | Gets or sets the color 63.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
Flags | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
IndicatorTransparency | Gets or sets the indicator transparency.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
Name | Gets or sets the name.
NumberOfVertices | Gets or sets the number of vertices.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
State | Gets or sets the state.
TopHeight | Gets or sets the top height.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VerticalDirection | Gets or sets the vertical direction.
Vertices | Gets or sets the vertices.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSectionEntity Constructor

Initializes a new instance of the CadSectionEntity class.

public CadSectionEntity();

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSectionEntity Properties

The properties of the CadSectionEntity class are listed below. For a complete list of CadSectionEntity class members, see the CadSectionEntity Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BackLineVertexCount | Gets or sets the back line vertex count.
BackVertices | Gets or sets the back vertices.
BottomHeight | Gets or sets the bottom height.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
Color441 | Gets or sets the color 441.
Color63 | Gets or sets the color 63.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
Flags | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
IndicatorTransparency | Gets or sets the indicator transparency.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
Name | Gets or sets the name.
NumberOfVertices | Gets or sets the number of vertices.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
State | Gets or sets the state.
TopHeight | Gets or sets the top height.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VerticalDirection | Gets or sets the vertical direction.
Vertices | Gets or sets the vertices.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BackLineVertexCount Property

Aspose.Imaging Documentation

CadSectionEntity.BackLineVertexCount Property

Gets or sets the back line vertex count.

public int BackLineVertexCount {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BackVertices Property

Aspose.Imaging Documentation

CadSectionEntity.BackVertices Property

Gets or sets the back vertices.

public Cad3DPoint} BackVertices {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BottomHeight Property

Aspose.Imaging Documentation

CadSectionEntity.BottomHeight Property

Gets or sets the bottom height.

public double BottomHeight {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Color441 Property

Aspose.Imaging Documentation

CadSectionEntity.Color441 Property

Gets or sets the color 441.

public short Color441 {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Color63 Property

Aspose.Imaging Documentation

CadSectionEntity.Color63 Property

Gets or sets the color 63.

public short Color63 {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Flags Property

Aspose.Imaging Documentation

CadSectionEntity.Flags Property

Gets or sets the flags.

public int Flags {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


IndicatorTransparency Property

Aspose.Imaging Documentation

CadSectionEntity.IndicatorTransparency Property

Gets or sets the indicator transparency.

public short IndicatorTransparency {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Name Property

Aspose.Imaging Documentation

CadSectionEntity.Name Property

Gets or sets the name.

public string Name {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


NumberOfVertices Property

Aspose.Imaging Documentation

CadSectionEntity.NumberOfVertices Property

Gets or sets the number of vertices.

public int NumberOfVertices {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


State Property

Aspose.Imaging Documentation

CadSectionEntity.State Property

Gets or sets the state.

public int State {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TopHeight Property

Aspose.Imaging Documentation

CadSectionEntity.TopHeight Property

Gets or sets the top height.

public double TopHeight {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


VerticalDirection Property

Aspose.Imaging Documentation

CadSectionEntity.VerticalDirection Property

Gets or sets the vertical direction.

public Cad3DPoint VerticalDirection {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Vertices Property

Aspose.Imaging Documentation

CadSectionEntity.Vertices Property

Gets or sets the vertices.

public Cad3DPoint} Vertices {get; set;}

See Also

CadSectionEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSeqend Class

Class describing Cad SEQEND. For CadConsts.CadSubClassName.SEQEND type.

For a list of all members of this type, see CadSeqend Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadSeqend

public class CadSeqend : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadSeqend Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSeqend Members

CadSeqend overview

Public Instance Constructors

CadSeqend Constructor Initializes a new instance of the CadSeqend class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadSeqend Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSeqend Constructor

Initializes a new instance of the CadSeqend class.

public CadSeqend();

See Also

CadSeqend Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSize Class

The Cad size

For a list of all members of this type, see CadSize Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadSize

public class CadSize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadSize Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSize Members

CadSize overview

Public Instance Constructors

CadSize Overloaded. Initializes a new instance of the CadSize class.

Public Instance Properties

Height | Gets or sets the height.
Width | Gets or sets the Width.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.
Truncate | Gets the point.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadSize Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSize Constructor

Initializes a new instance of the CadSize class.

Overload List

Initializes a new instance of the CadSize class.

public CadSize(CadEntityAttribute,CadEntityAttribute);

Initializes a new instance of the CadSize class.

public CadSize(double,double);

See Also

CadSize Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSize Constructor (Double, Double)

Initializes a new instance of the CadSize class.

public CadSize(
double valueWidth,
double valueHeight
);

Parameters

valueWidth
Width of the value.
valueHeight
Height of the value.

See Also

CadSize Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | CadSize Constructor Overload List


CadSize Constructor (CadEntityAttribute, CadEntityAttribute)

Initializes a new instance of the CadSize class.

public CadSize(
CadEntityAttribute attributeWidth,
CadEntityAttribute attributeHeight
);

Parameters

attributeWidth
Width of the attribute.
attributeHeight
Height of the attribute.

See Also

CadSize Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace | CadSize Constructor Overload List


CadSize Properties

The properties of the CadSize class are listed below. For a complete list of CadSize class members, see the CadSize Members topic.

Public Instance Properties

Height | Gets or sets the height.
Width | Gets or sets the Width.

See Also

CadSize Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Height Property

Aspose.Imaging Documentation

CadSize.Height Property

Gets or sets the height.

public double Height {get; set;}

See Also

CadSize Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Width Property

Aspose.Imaging Documentation

CadSize.Width Property

Gets or sets the Width.

public double Width {get; set;}

See Also

CadSize Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSize Methods

The methods of the CadSize class are listed below. For a complete list of CadSize class members, see the CadSize Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.
Truncate | Gets the point.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadSize Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSize.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

CadSize Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSize.Truncate Method

Gets the point.

public Size Truncate();

Return Value

The Size.

See Also

CadSize Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSolid Class

Class describing CadSolid

For a list of all members of this type, see CadSolid Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadSolid

public class CadSolid : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadSolid Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSolid Members

CadSolid overview

Public Instance Constructors

CadSolid Constructor Initializes a new instance of the CadSolid class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtrusionDirection | Gets or sets the extrusion direction.
FirstCorner | Gets or sets the first corner.
FourthCorner | Gets or sets the fourth corner.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
SecondCorner | Gets or sets the second corner.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Thickness | Gets or sets the thickness.
ThirdCorner | Gets or sets the third corner.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadSolid Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSolid Constructor

Initializes a new instance of the CadSolid class.

public CadSolid();

See Also

CadSolid Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSolid Properties

The properties of the CadSolid class are listed below. For a complete list of CadSolid class members, see the CadSolid Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtrusionDirection | Gets or sets the extrusion direction.
FirstCorner | Gets or sets the first corner.
FourthCorner | Gets or sets the fourth corner.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
SecondCorner | Gets or sets the second corner.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Thickness | Gets or sets the thickness.
ThirdCorner | Gets or sets the third corner.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadSolid Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ExtrusionDirection Property

Aspose.Imaging Documentation

CadSolid.ExtrusionDirection Property

Gets or sets the extrusion direction.

public Cad3DPoint ExtrusionDirection {get; set;}

Property Value

The extrusion direction.

See Also

CadSolid Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FirstCorner Property

Aspose.Imaging Documentation

CadSolid.FirstCorner Property

Gets or sets the first corner.

public Cad3DPoint FirstCorner {get; set;}

Property Value

The first corner.

See Also

CadSolid Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FourthCorner Property

Aspose.Imaging Documentation

CadSolid.FourthCorner Property

Gets or sets the fourth corner.

public Cad3DPoint FourthCorner {get; set;}

Property Value

The fourth corner.

See Also

CadSolid Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SecondCorner Property

Aspose.Imaging Documentation

CadSolid.SecondCorner Property

Gets or sets the second corner.

public Cad3DPoint SecondCorner {get; set;}

Property Value

The second corner.

See Also

CadSolid Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Thickness Property

Aspose.Imaging Documentation

CadSolid.Thickness Property

Gets or sets the thickness.

public float Thickness {get; set;}

Property Value

The thickness.

See Also

CadSolid Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ThirdCorner Property

Aspose.Imaging Documentation

CadSolid.ThirdCorner Property

Gets or sets the third corner.

public Cad3DPoint ThirdCorner {get; set;}

Property Value

The third corner.

See Also

CadSolid Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSpline Class

Class describing Cad SPLINE

For a list of all members of this type, see CadSpline Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadSpline

public class CadSpline : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadSpline Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSpline Members

CadSpline overview

Public Instance Constructors

CadSpline Constructor Initializes a new instance of the CadSpline class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ControlPoints | Gets or sets the control points.
ControlPointsNumber | Gets or sets the control points number.
ControlPointTolerance | Gets or sets the control point tolerance.
CurveDegree | Gets or sets the curve degree.
Degree | Gets or sets the degree.
EndTangent | Gets or sets the end tangent.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
FitPoints | Gets or sets the fit points.
FitPointsNumber | Gets or sets the fit points number.
FitTolerance | Gets or sets the fit tolerance.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
KnotsNumber | Gets or sets the knots number.
KnotTolerance | Gets or sets the knot tolerance.
KnotValues | Gets or sets the knot values.
KnotWeight | Gets or sets the knot weight.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
NormalVector | Gets or sets the normal vector.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
Periodirc | Gets or sets the periodic
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
Rational | Gets or sets the rational
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
SplineFlag | Gets or sets the spline flag.
StartTangent | Gets or sets the start tangent.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
WeightParam | Gets or sets the weight parameter
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSpline Constructor

Initializes a new instance of the CadSpline class.

public CadSpline();

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSpline Properties

The properties of the CadSpline class are listed below. For a complete list of CadSpline class members, see the CadSpline Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ControlPoints | Gets or sets the control points.
ControlPointsNumber | Gets or sets the control points number.
ControlPointTolerance | Gets or sets the control point tolerance.
CurveDegree | Gets or sets the curve degree.
Degree | Gets or sets the degree.
EndTangent | Gets or sets the end tangent.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
FitPoints | Gets or sets the fit points.
FitPointsNumber | Gets or sets the fit points number.
FitTolerance | Gets or sets the fit tolerance.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
KnotsNumber | Gets or sets the knots number.
KnotTolerance | Gets or sets the knot tolerance.
KnotValues | Gets or sets the knot values.
KnotWeight | Gets or sets the knot weight.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
NormalVector | Gets or sets the normal vector.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
Periodirc | Gets or sets the periodic
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
Rational | Gets or sets the rational
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
SplineFlag | Gets or sets the spline flag.
StartTangent | Gets or sets the start tangent.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
WeightParam | Gets or sets the weight parameter
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ControlPoints Property

Aspose.Imaging Documentation

CadSpline.ControlPoints Property

Gets or sets the control points.

public Cad3DPoint} ControlPoints {get; set;}

Property Value

The control points.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ControlPointsNumber Property

Aspose.Imaging Documentation

CadSpline.ControlPointsNumber Property

Gets or sets the control points number.

public short ControlPointsNumber {get; set;}

Property Value

The control points number.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ControlPointTolerance Property

Aspose.Imaging Documentation

CadSpline.ControlPointTolerance Property

Gets or sets the control point tolerance.

public double ControlPointTolerance {get; set;}

Property Value

The control point tolerance.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CurveDegree Property

Aspose.Imaging Documentation

CadSpline.CurveDegree Property

Gets or sets the curve degree.

public short CurveDegree {get; set;}

Property Value

The curve degree.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Degree Property

Aspose.Imaging Documentation

CadSpline.Degree Property

Gets or sets the degree.

public int Degree {get; set;}

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


EndTangent Property

Aspose.Imaging Documentation

CadSpline.EndTangent Property

Gets or sets the end tangent.

public Cad3DPoint EndTangent {get; set;}

Property Value

The end tangent.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FitPoints Property

Aspose.Imaging Documentation

CadSpline.FitPoints Property

Gets or sets the fit points.

public Cad3DPoint} FitPoints {get; set;}

Property Value

The fit points.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FitPointsNumber Property

Aspose.Imaging Documentation

CadSpline.FitPointsNumber Property

Gets or sets the fit points number.

public short FitPointsNumber {get; set;}

Property Value

The fit points number.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FitTolerance Property

Aspose.Imaging Documentation

CadSpline.FitTolerance Property

Gets or sets the fit tolerance.

public double FitTolerance {get; set;}

Property Value

The fit tolerance.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


KnotsNumber Property

Aspose.Imaging Documentation

CadSpline.KnotsNumber Property

Gets or sets the knots number.

public short KnotsNumber {get; set;}

Property Value

The knots number.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


KnotTolerance Property

Aspose.Imaging Documentation

CadSpline.KnotTolerance Property

Gets or sets the knot tolerance.

public float KnotTolerance {get; set;}

Property Value

The knot tolerance.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


KnotValues Property

Aspose.Imaging Documentation

CadSpline.KnotValues Property

Gets or sets the knot values.

public CadDoubleParameter} KnotValues {get; set;}

Property Value

The knot values.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


KnotWeight Property

Aspose.Imaging Documentation

CadSpline.KnotWeight Property

Gets or sets the knot weight.

public Double} KnotWeight {get; set;}

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


NormalVector Property

Aspose.Imaging Documentation

CadSpline.NormalVector Property

Gets or sets the normal vector.

public PointF NormalVector {get; set;}

Property Value

The normal vector.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Periodirc Property

Aspose.Imaging Documentation

CadSpline.Periodirc Property

Gets or sets the periodic

public short Periodirc {get; set;}

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Rational Property

Aspose.Imaging Documentation

CadSpline.Rational Property

Gets or sets the rational

public short Rational {get; set;}

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SplineFlag Property

Aspose.Imaging Documentation

CadSpline.SplineFlag Property

Gets or sets the spline flag.

public short SplineFlag {get; set;}

Property Value

The spline flag.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StartTangent Property

Aspose.Imaging Documentation

CadSpline.StartTangent Property

Gets or sets the start tangent.

public Cad3DPoint StartTangent {get; set;}

Property Value

The start tangent.

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


WeightParam Property

Aspose.Imaging Documentation

CadSpline.WeightParam Property

Gets or sets the weight parameter

public CadParameter} WeightParam {get; set;}

Property Value

The weight parameter

See Also

CadSpline Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSurfaceBase Class

The Cad surface base.

For a list of all members of this type, see CadSurfaceBase Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadSurfaceBase

public abstract class CadSurfaceBase : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadSurfaceBase Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSurfaceBase Members

CadSurfaceBase overview

Public Instance Constructors

CadSurfaceBase Constructor Initializes a new instance of the CadSurfaceBase class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadSurfaceBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadSurfaceBase Constructor

Initializes a new instance of the CadSurfaceBase class.

public CadSurfaceBase();

See Also

CadSurfaceBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadTableEntity Class

The Cad table entity.

For a list of all members of this type, see CadTableEntity Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadTableEntity

public class CadTableEntity : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadTableEntity Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadTableEntity Members

CadTableEntity overview

Public Instance Constructors

CadTableEntity Constructor Initializes a new instance of the CadTableEntity class.

Public Instance Properties

AdditionalStrings | Gets or sets the additional strings.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttribDefSoftPointer | Gets or sets the attrib def soft pointer.
AttribTextStrings | Gets or sets the attrib text strings.
AttributeDefinitionsCount | Gets or sets the attribute definitions count.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BackgroundColorOfCell | Gets or sets the background color of cell.
BlockName | Gets or sets the block name.
BlockScale | Gets or sets the block scale.
CellAlignment | Gets or sets the cell alignment.
CellStrings | Gets or sets the cell strings.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorBottomBorder | Gets or sets the color bottom border.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorLeftBorder | Gets or sets the color left border.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorOfCellContent | Gets or sets the color of cell content.
ColorRightBorder | Gets or sets the color right border.
ColorTopBorder | Gets or sets the color top border.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtendedCellFlag | Gets or sets the extended cell flag.
FieldHardPointer | Gets or sets the field hard pointer.
FillColorIsOn | Gets or sets the fill color is on.
FlagForTableValue | Gets or sets the flag for table value.
FlagOverride | Gets or sets the flag override.
FlagOverrideBorderColor | Gets or sets the flag override border color.
FlagOverrideBorderLineWeight | Gets or sets the flag override border line weight.
FlagOverrideBorderVisibility | Gets or sets the flag override border visibility.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HardPointerIds | Gets or sets the hard pointer ids.
InsertionPoint | Gets or sets the insertion point.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
LineWeightBottomBorder | Gets or sets the line weight bottom border.
LineWeightLeftBorder | Gets or sets the line weight left border.
LineWeightRightBorder | Gets or sets the line weight right border.
LineWeightTopBorder | Gets or sets the line weight top border.
Material (inherited from CadBaseEntity) | Gets or sets the material.
NumberOfColumns | Gets or sets the number of columns.
NumberOfRows | Gets or sets the number of rows.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PointerIdToOwnerBlock | Gets or sets the pointer id to owner block.
PointerIdTotablestyle | Gets or sets the pointer id totablestyle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RotationAngle | Gets or sets the rotation angle.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
TableDataVersionNumber | Gets or sets the table data version number.
TextHeight | Gets or sets the text height.
TextStyleName | Gets or sets the text style name.
TextStyleNameCellType | Gets or sets the text style name cell type.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VirtualEdgeFlag | Gets or sets the virtual edge flag.
VisibilityTopBorder | Gets or sets the visibility top border.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadTableEntity Constructor

Initializes a new instance of the CadTableEntity class.

public CadTableEntity();

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadTableEntity Properties

The properties of the CadTableEntity class are listed below. For a complete list of CadTableEntity class members, see the CadTableEntity Members topic.

Public Instance Properties

AdditionalStrings | Gets or sets the additional strings.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttribDefSoftPointer | Gets or sets the attrib def soft pointer.
AttribTextStrings | Gets or sets the attrib text strings.
AttributeDefinitionsCount | Gets or sets the attribute definitions count.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BackgroundColorOfCell | Gets or sets the background color of cell.
BlockName | Gets or sets the block name.
BlockScale | Gets or sets the block scale.
CellAlignment | Gets or sets the cell alignment.
CellStrings | Gets or sets the cell strings.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorBottomBorder | Gets or sets the color bottom border.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorLeftBorder | Gets or sets the color left border.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorOfCellContent | Gets or sets the color of cell content.
ColorRightBorder | Gets or sets the color right border.
ColorTopBorder | Gets or sets the color top border.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
ExtendedCellFlag | Gets or sets the extended cell flag.
FieldHardPointer | Gets or sets the field hard pointer.
FillColorIsOn | Gets or sets the fill color is on.
FlagForTableValue | Gets or sets the flag for table value.
FlagOverride | Gets or sets the flag override.
FlagOverrideBorderColor | Gets or sets the flag override border color.
FlagOverrideBorderLineWeight | Gets or sets the flag override border line weight.
FlagOverrideBorderVisibility | Gets or sets the flag override border visibility.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HardPointerIds | Gets or sets the hard pointer ids.
InsertionPoint | Gets or sets the insertion point.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
LineWeightBottomBorder | Gets or sets the line weight bottom border.
LineWeightLeftBorder | Gets or sets the line weight left border.
LineWeightRightBorder | Gets or sets the line weight right border.
LineWeightTopBorder | Gets or sets the line weight top border.
Material (inherited from CadBaseEntity) | Gets or sets the material.
NumberOfColumns | Gets or sets the number of columns.
NumberOfRows | Gets or sets the number of rows.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PointerIdToOwnerBlock | Gets or sets the pointer id to owner block.
PointerIdTotablestyle | Gets or sets the pointer id totablestyle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
RotationAngle | Gets or sets the rotation angle.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
TableDataVersionNumber | Gets or sets the table data version number.
TextHeight | Gets or sets the text height.
TextStyleName | Gets or sets the text style name.
TextStyleNameCellType | Gets or sets the text style name cell type.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VirtualEdgeFlag | Gets or sets the virtual edge flag.
VisibilityTopBorder | Gets or sets the visibility top border.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AdditionalStrings Property

Aspose.Imaging Documentation

CadTableEntity.AdditionalStrings Property

Gets or sets the additional strings.

public CadStringParameter} AdditionalStrings {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AttribDefSoftPointer Property

Aspose.Imaging Documentation

CadTableEntity.AttribDefSoftPointer Property

Gets or sets the attrib def soft pointer.

public CadStringParameter} AttribDefSoftPointer {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AttribTextStrings Property

Aspose.Imaging Documentation

CadTableEntity.AttribTextStrings Property

Gets or sets the attrib text strings.

public CadStringParameter} AttribTextStrings {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AttributeDefinitionsCount Property

Aspose.Imaging Documentation

CadTableEntity.AttributeDefinitionsCount Property

Gets or sets the attribute definitions count.

public short AttributeDefinitionsCount {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BackgroundColorOfCell Property

Aspose.Imaging Documentation

CadTableEntity.BackgroundColorOfCell Property

Gets or sets the background color of cell.

public CadShortParameter} BackgroundColorOfCell {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockName Property

Aspose.Imaging Documentation

CadTableEntity.BlockName Property

Gets or sets the block name.

public string BlockName {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BlockScale Property

Aspose.Imaging Documentation

CadTableEntity.BlockScale Property

Gets or sets the block scale.

public CadDoubleParameter} BlockScale {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CellAlignment Property

Aspose.Imaging Documentation

CadTableEntity.CellAlignment Property

Gets or sets the cell alignment.

public CadShortParameter} CellAlignment {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CellStrings Property

Aspose.Imaging Documentation

CadTableEntity.CellStrings Property

Gets or sets the cell strings.

public CadStringParameter} CellStrings {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColorBottomBorder Property

Aspose.Imaging Documentation

CadTableEntity.ColorBottomBorder Property

Gets or sets the color bottom border.

public CadShortParameter} ColorBottomBorder {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColorLeftBorder Property

Aspose.Imaging Documentation

CadTableEntity.ColorLeftBorder Property

Gets or sets the color left border.

public CadShortParameter} ColorLeftBorder {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColorOfCellContent Property

Aspose.Imaging Documentation

CadTableEntity.ColorOfCellContent Property

Gets or sets the color of cell content.

public CadShortParameter} ColorOfCellContent {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColorRightBorder Property

Aspose.Imaging Documentation

CadTableEntity.ColorRightBorder Property

Gets or sets the color right border.

public CadShortParameter} ColorRightBorder {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ColorTopBorder Property

Aspose.Imaging Documentation

CadTableEntity.ColorTopBorder Property

Gets or sets the color top border.

public CadShortParameter} ColorTopBorder {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ExtendedCellFlag Property

Aspose.Imaging Documentation

CadTableEntity.ExtendedCellFlag Property

Gets or sets the extended cell flag.

public CadIntParameter} ExtendedCellFlag {get; set;}

Property Value

The extended cell flag.

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FieldHardPointer Property

Aspose.Imaging Documentation

CadTableEntity.FieldHardPointer Property

Gets or sets the field hard pointer.

public string FieldHardPointer {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FillColorIsOn Property

Aspose.Imaging Documentation

CadTableEntity.FillColorIsOn Property

Gets or sets the fill color is on.

public CadShortParameter} FillColorIsOn {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FlagForTableValue Property

Aspose.Imaging Documentation

CadTableEntity.FlagForTableValue Property

Gets or sets the flag for table value.

public int FlagForTableValue {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FlagOverride Property

Aspose.Imaging Documentation

CadTableEntity.FlagOverride Property

Gets or sets the flag override.

public int FlagOverride {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FlagOverrideBorderColor Property

Aspose.Imaging Documentation

CadTableEntity.FlagOverrideBorderColor Property

Gets or sets the flag override border color.

public int FlagOverrideBorderColor {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FlagOverrideBorderLineWeight Property

Aspose.Imaging Documentation

CadTableEntity.FlagOverrideBorderLineWeight Property

Gets or sets the flag override border line weight.

public int FlagOverrideBorderLineWeight {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FlagOverrideBorderVisibility Property

Aspose.Imaging Documentation

CadTableEntity.FlagOverrideBorderVisibility Property

Gets or sets the flag override border visibility.

public int FlagOverrideBorderVisibility {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HardPointerIds Property

Aspose.Imaging Documentation

CadTableEntity.HardPointerIds Property

Gets or sets the hard pointer ids.

public CadStringParameter} HardPointerIds {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


InsertionPoint Property

Aspose.Imaging Documentation

CadTableEntity.InsertionPoint Property

Gets or sets the insertion point.

public Cad3DPoint InsertionPoint {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LineWeightBottomBorder Property

Aspose.Imaging Documentation

CadTableEntity.LineWeightBottomBorder Property

Gets or sets the line weight bottom border.

public CadShortParameter} LineWeightBottomBorder {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LineWeightLeftBorder Property

Aspose.Imaging Documentation

CadTableEntity.LineWeightLeftBorder Property

Gets or sets the line weight left border.

public CadShortParameter} LineWeightLeftBorder {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LineWeightRightBorder Property

Aspose.Imaging Documentation

CadTableEntity.LineWeightRightBorder Property

Gets or sets the line weight right border.

public CadShortParameter} LineWeightRightBorder {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


LineWeightTopBorder Property

Aspose.Imaging Documentation

CadTableEntity.LineWeightTopBorder Property

Gets or sets the line weight top border.

public CadShortParameter} LineWeightTopBorder {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


NumberOfColumns Property

Aspose.Imaging Documentation

CadTableEntity.NumberOfColumns Property

Gets or sets the number of columns.

public int NumberOfColumns {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


NumberOfRows Property

Aspose.Imaging Documentation

CadTableEntity.NumberOfRows Property

Gets or sets the number of rows.

public int NumberOfRows {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PointerIdToOwnerBlock Property

Aspose.Imaging Documentation

CadTableEntity.PointerIdToOwnerBlock Property

Gets or sets the pointer id to owner block.

public string PointerIdToOwnerBlock {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PointerIdTotablestyle Property

Aspose.Imaging Documentation

CadTableEntity.PointerIdTotablestyle Property

Gets or sets the pointer id totablestyle.

public string PointerIdTotablestyle {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RotationAngle Property

Aspose.Imaging Documentation

CadTableEntity.RotationAngle Property

Gets or sets the rotation angle.

public double RotationAngle {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TableDataVersionNumber Property

Aspose.Imaging Documentation

CadTableEntity.TableDataVersionNumber Property

Gets or sets the table data version number.

public short TableDataVersionNumber {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextHeight Property

Aspose.Imaging Documentation

CadTableEntity.TextHeight Property

Gets or sets the text height.

public CadDoubleParameter} TextHeight {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextStyleName Property

Aspose.Imaging Documentation

CadTableEntity.TextStyleName Property

Gets or sets the text style name.

public CadStringParameter} TextStyleName {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextStyleNameCellType Property

Aspose.Imaging Documentation

CadTableEntity.TextStyleNameCellType Property

Gets or sets the text style name cell type.

public CadStringParameter} TextStyleNameCellType {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


VirtualEdgeFlag Property

Aspose.Imaging Documentation

CadTableEntity.VirtualEdgeFlag Property

Gets or sets the virtual edge flag.

public short VirtualEdgeFlag {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


VisibilityTopBorder Property

Aspose.Imaging Documentation

CadTableEntity.VisibilityTopBorder Property

Gets or sets the visibility top border.

public CadShortParameter} VisibilityTopBorder {get; set;}

See Also

CadTableEntity Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadText Class

Class describing Cad text

For a list of all members of this type, see CadText Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadText

public class CadText : CadBaseExtrudedEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadText Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadText Members

CadText overview

Public Instance Constructors

CadText Constructor Initializes a new instance of the CadText class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefaultValue | Gets or sets the default value.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
FirstAlignment | Gets or sets the first alignment.
GenerationFlag | Gets or sets the generation flag.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalJustification | Gets or sets the horizontal justification.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
ObliqueAngle | Gets or sets the oblique angle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ScaleX | Gets or sets the scale x.
SecondAlignmentPoint | Gets or sets the second alignment point.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleType | Gets or sets the style type.
TextHeight | Gets or sets the text height.
TextRotation | Gets or sets the text rotation.
TextWidth | Gets the text width.
Thickness | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VerticalJustification | Gets or sets the vertical justification.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadText Constructor

Initializes a new instance of the CadText class.

public CadText();

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadText Properties

The properties of the CadText class are listed below. For a complete list of CadText class members, see the CadText Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefaultValue | Gets or sets the default value.
ExtrusionDirection (inherited from CadBaseExtrudedEntity) | Gets or sets the extrusion direction.
FirstAlignment | Gets or sets the first alignment.
GenerationFlag | Gets or sets the generation flag.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HorizontalJustification | Gets or sets the horizontal justification.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
ObliqueAngle | Gets or sets the oblique angle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ScaleX | Gets or sets the scale x.
SecondAlignmentPoint | Gets or sets the second alignment point.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StyleType | Gets or sets the style type.
TextHeight | Gets or sets the text height.
TextRotation | Gets or sets the text rotation.
TextWidth | Gets the text width.
Thickness | Gets or sets the thickness.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VerticalJustification | Gets or sets the vertical justification.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DefaultValue Property

Aspose.Imaging Documentation

CadText.DefaultValue Property

Gets or sets the default value.

public string DefaultValue {get; set;}

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FirstAlignment Property

Aspose.Imaging Documentation

CadText.FirstAlignment Property

Gets or sets the first alignment.

public Cad3DPoint FirstAlignment {get; set;}

Property Value

The first alignment.

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


GenerationFlag Property

Aspose.Imaging Documentation

CadText.GenerationFlag Property

Gets or sets the generation flag.

public short GenerationFlag {get; set;}

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


HorizontalJustification Property

Aspose.Imaging Documentation

CadText.HorizontalJustification Property

Gets or sets the horizontal justification.

public short HorizontalJustification {get; set;}

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ObliqueAngle Property

Aspose.Imaging Documentation

CadText.ObliqueAngle Property

Gets or sets the oblique angle.

public double ObliqueAngle {get; set;}

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ScaleX Property

Aspose.Imaging Documentation

CadText.ScaleX Property

Gets or sets the scale x.

public double ScaleX {get; set;}

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SecondAlignmentPoint Property

Aspose.Imaging Documentation

CadText.SecondAlignmentPoint Property

Gets or sets the second alignment point.

public Cad3DPoint SecondAlignmentPoint {get; set;}

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StyleType Property

Aspose.Imaging Documentation

CadText.StyleType Property

Gets or sets the style type.

public string StyleType {get; set;}

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextHeight Property

Aspose.Imaging Documentation

CadText.TextHeight Property

Gets or sets the text height.

public double TextHeight {get; set;}

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextRotation Property

Aspose.Imaging Documentation

CadText.TextRotation Property

Gets or sets the text rotation.

public double TextRotation {get; set;}

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TextWidth Property

Aspose.Imaging Documentation

CadText.TextWidth Property

Gets the text width.

public double TextWidth {get;}

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Thickness Property

Aspose.Imaging Documentation

CadText.Thickness Property

Gets or sets the thickness.

public double Thickness {get; set;}

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


VerticalJustification Property

Aspose.Imaging Documentation

CadText.VerticalJustification Property

Gets or sets the vertical justification.

public short VerticalJustification {get; set;}

See Also

CadText Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadVertexBase Class

Class describing Cad VERTEX

For a list of all members of this type, see CadVertexBase Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadVertexBase
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad2DVertex
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad3DVertex

public class CadVertexBase : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadVertexBase Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadVertexBase Members

CadVertexBase overview

Public Instance Constructors

CadVertexBase Constructor Initializes a new instance of the CadVertexBase class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
Bugle | Gets or sets the bugle.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
CurveFitTangentDirection | Gets or sets the curve fit tangent direction.
EndingWidth | Gets or sets the ending width.
Flags | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MeshVertexIndex1 | Gets or sets the mesh vertex index 1.
MeshVertexIndex2 | Gets or sets the mesh vertex index 2.
MeshVertexIndex3 | Gets or sets the mesh vertex index 3.
MeshVertexIndex4 | Gets or sets the mesh vertex index 4.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartingWidth | Gets or sets the starting width.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VertexId | Gets or sets the vertex id.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadVertexBase Constructor

Initializes a new instance of the CadVertexBase class.

public CadVertexBase();

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadVertexBase Properties

The properties of the CadVertexBase class are listed below. For a complete list of CadVertexBase class members, see the CadVertexBase Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
Bugle | Gets or sets the bugle.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
CurveFitTangentDirection | Gets or sets the curve fit tangent direction.
EndingWidth | Gets or sets the ending width.
Flags | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
MeshVertexIndex1 | Gets or sets the mesh vertex index 1.
MeshVertexIndex2 | Gets or sets the mesh vertex index 2.
MeshVertexIndex3 | Gets or sets the mesh vertex index 3.
MeshVertexIndex4 | Gets or sets the mesh vertex index 4.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
StartingWidth | Gets or sets the starting width.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
VertexId | Gets or sets the vertex id.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Bugle Property

Aspose.Imaging Documentation

CadVertexBase.Bugle Property

Gets or sets the bugle.

public double Bugle {get; set;}

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CurveFitTangentDirection Property

Aspose.Imaging Documentation

CadVertexBase.CurveFitTangentDirection Property

Gets or sets the curve fit tangent direction.

public double CurveFitTangentDirection {get; set;}

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


EndingWidth Property

Aspose.Imaging Documentation

CadVertexBase.EndingWidth Property

Gets or sets the ending width.

public double EndingWidth {get; set;}

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Flags Property

Aspose.Imaging Documentation

CadVertexBase.Flags Property

Gets or sets the flags.

public short Flags {get; set;}

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MeshVertexIndex1 Property

Aspose.Imaging Documentation

CadVertexBase.MeshVertexIndex1 Property

Gets or sets the mesh vertex index 1.

public short MeshVertexIndex1 {get; set;}

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MeshVertexIndex2 Property

Aspose.Imaging Documentation

CadVertexBase.MeshVertexIndex2 Property

Gets or sets the mesh vertex index 2.

public short MeshVertexIndex2 {get; set;}

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MeshVertexIndex3 Property

Aspose.Imaging Documentation

CadVertexBase.MeshVertexIndex3 Property

Gets or sets the mesh vertex index 3.

public short MeshVertexIndex3 {get; set;}

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


MeshVertexIndex4 Property

Aspose.Imaging Documentation

CadVertexBase.MeshVertexIndex4 Property

Gets or sets the mesh vertex index 4.

public short MeshVertexIndex4 {get; set;}

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


StartingWidth Property

Aspose.Imaging Documentation

CadVertexBase.StartingWidth Property

Gets or sets the starting width.

public double StartingWidth {get; set;}

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


VertexId Property

Aspose.Imaging Documentation

CadVertexBase.VertexId Property

Gets or sets the vertex id.

public int VertexId {get; set;}

See Also

CadVertexBase Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadViewport Class

The Cad view port.

For a list of all members of this type, see CadViewport Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadViewport

public class CadViewport : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadViewport Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadViewport Members

CadViewport overview

Public Instance Constructors

CadViewport Constructor Initializes a new instance of the CadViewport class.

Public Instance Properties

AmbientElement1 | Gets or sets the ambient element 1.
AmbientElement2 | Gets or sets the ambient element 2.
AmbientElement3 | Gets or sets the ambient element 3.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
AxisXOfUcs | Gets or sets the axis x of UCS.
AxisYOfUcs | Gets or sets the axis y of UCS.
BackClipZValue | Gets or sets the back clip z value.
BackgroundHandle | Gets or sets the background handle.
CenterPoint | Gets or sets the center point.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
CircleZoomPresent | Gets or sets the circle zoom present.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefaultLigtingFlag | Gets or sets a value indicating whether default ligting flag.
DefaultLigtingType | Gets or sets the default ligting type.
DisplayUcs | Gets or sets the display UCS.
Elevation | Gets or sets the elevation.
FrontClipZValue | Gets or sets the front clip z value.
FrozenLayerObjectId | Gets or sets the frozen layer object id.
GridFrequency | Gets or sets the grid frequency.
GridSpacing | Gets or sets the grid spacing.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
Height | Gets or sets the height.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
OriginUcs | Gets or sets the origin UCS.
Orthographic | Gets or sets the orthographic.
PerspectiveLensLength | Gets or sets the perspective lens length.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PlotStyleSheetName | Gets or sets the plot style sheet name.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ReferenceToTableRecord | Gets or sets the reference to table record.
ReferenceToTableRecordOrthoGraphic | Gets or sets the reference to table record ortho graphic.
RenderMode | Gets or sets the render mode.
ShadeHandle | Gets or sets the shade handle.
ShadePlotMode | Gets or sets the shade plot mode.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SnapAngle | Gets or sets the snap angle.
SnapBasePoint | Gets or sets the snap base point.
SnapSpacing | Gets or sets the snap spacing.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Status | Gets or sets the status.
SunHandle | Gets or sets the sun handle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TwistAngle | Gets or sets the twist angle.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
UcsPerViewPort | Gets or sets the UCS per view port.
VeiwHeight | Gets or sets the view height.
ViewBrigtness | Gets or sets the view brigtness.
ViewCenterPoint | Gets or sets the view center point.
ViewContrast | Gets or sets the view contrast.
ViewDirectionVector | Gets or sets the view direction vector.
ViewPointRef1 | Gets or sets the view point ref 1.
ViewPointRef2 | Gets or sets the view point ref 2.
ViewPointRef3 | Gets or sets the view point ref 3.
ViewPointRef4 | Gets or sets the view point ref 4.
ViewportClippingObjectId | Gets or sets the viewport clipping object id.
ViewPortId | Gets or sets the view port id.
ViewPortStatus | Gets or sets the view port status.
ViewTargetVector | Gets or sets the view target vector.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
VisualStyleHandle | Gets or sets the visual style handle.
Width | Gets or sets the width.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadViewport Constructor

Initializes a new instance of the CadViewport class.

public CadViewport();

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadViewport Properties

The properties of the CadViewport class are listed below. For a complete list of CadViewport class members, see the CadViewport Members topic.

Public Instance Properties

AmbientElement1 | Gets or sets the ambient element 1.
AmbientElement2 | Gets or sets the ambient element 2.
AmbientElement3 | Gets or sets the ambient element 3.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
AxisXOfUcs | Gets or sets the axis x of UCS.
AxisYOfUcs | Gets or sets the axis y of UCS.
BackClipZValue | Gets or sets the back clip z value.
BackgroundHandle | Gets or sets the background handle.
CenterPoint | Gets or sets the center point.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
CircleZoomPresent | Gets or sets the circle zoom present.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
DefaultLigtingFlag | Gets or sets a value indicating whether default ligting flag.
DefaultLigtingType | Gets or sets the default ligting type.
DisplayUcs | Gets or sets the display UCS.
Elevation | Gets or sets the elevation.
FrontClipZValue | Gets or sets the front clip z value.
FrozenLayerObjectId | Gets or sets the frozen layer object id.
GridFrequency | Gets or sets the grid frequency.
GridSpacing | Gets or sets the grid spacing.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
Height | Gets or sets the height.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
OriginUcs | Gets or sets the origin UCS.
Orthographic | Gets or sets the orthographic.
PerspectiveLensLength | Gets or sets the perspective lens length.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PlotStyleSheetName | Gets or sets the plot style sheet name.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ReferenceToTableRecord | Gets or sets the reference to table record.
ReferenceToTableRecordOrthoGraphic | Gets or sets the reference to table record ortho graphic.
RenderMode | Gets or sets the render mode.
ShadeHandle | Gets or sets the shade handle.
ShadePlotMode | Gets or sets the shade plot mode.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SnapAngle | Gets or sets the snap angle.
SnapBasePoint | Gets or sets the snap base point.
SnapSpacing | Gets or sets the snap spacing.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Status | Gets or sets the status.
SunHandle | Gets or sets the sun handle.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TwistAngle | Gets or sets the twist angle.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
UcsPerViewPort | Gets or sets the UCS per view port.
VeiwHeight | Gets or sets the view height.
ViewBrigtness | Gets or sets the view brigtness.
ViewCenterPoint | Gets or sets the view center point.
ViewContrast | Gets or sets the view contrast.
ViewDirectionVector | Gets or sets the view direction vector.
ViewPointRef1 | Gets or sets the view point ref 1.
ViewPointRef2 | Gets or sets the view point ref 2.
ViewPointRef3 | Gets or sets the view point ref 3.
ViewPointRef4 | Gets or sets the view point ref 4.
ViewportClippingObjectId | Gets or sets the viewport clipping object id.
ViewPortId | Gets or sets the view port id.
ViewPortStatus | Gets or sets the view port status.
ViewTargetVector | Gets or sets the view target vector.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
VisualStyleHandle | Gets or sets the visual style handle.
Width | Gets or sets the width.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AmbientElement1 Property

Aspose.Imaging Documentation

CadViewport.AmbientElement1 Property

Gets or sets the ambient element 1.

public short AmbientElement1 {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AmbientElement2 Property

Aspose.Imaging Documentation

CadViewport.AmbientElement2 Property

Gets or sets the ambient element 2.

public int AmbientElement2 {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AmbientElement3 Property

Aspose.Imaging Documentation

CadViewport.AmbientElement3 Property

Gets or sets the ambient element 3.

public string AmbientElement3 {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AxisXOfUcs Property

Aspose.Imaging Documentation

CadViewport.AxisXOfUcs Property

Gets or sets the axis x of UCS.

public Cad3DPoint AxisXOfUcs {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


AxisYOfUcs Property

Aspose.Imaging Documentation

CadViewport.AxisYOfUcs Property

Gets or sets the axis y of UCS.

public Cad3DPoint AxisYOfUcs {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BackClipZValue Property

Aspose.Imaging Documentation

CadViewport.BackClipZValue Property

Gets or sets the back clip z value.

public double BackClipZValue {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


BackgroundHandle Property

Aspose.Imaging Documentation

CadViewport.BackgroundHandle Property

Gets or sets the background handle.

public string BackgroundHandle {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CenterPoint Property

Aspose.Imaging Documentation

CadViewport.CenterPoint Property

Gets or sets the center point.

public Cad3DPoint CenterPoint {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CircleZoomPresent Property

Aspose.Imaging Documentation

CadViewport.CircleZoomPresent Property

Gets or sets the circle zoom present.

public short CircleZoomPresent {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DefaultLigtingFlag Property

Aspose.Imaging Documentation

CadViewport.DefaultLigtingFlag Property

Gets or sets a value indicating whether default ligting flag.

public bool DefaultLigtingFlag {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DefaultLigtingType Property

Aspose.Imaging Documentation

CadViewport.DefaultLigtingType Property

Gets or sets the default ligting type.

public short DefaultLigtingType {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DisplayUcs Property

Aspose.Imaging Documentation

CadViewport.DisplayUcs Property

Gets or sets the display UCS.

public short DisplayUcs {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Elevation Property

Aspose.Imaging Documentation

CadViewport.Elevation Property

Gets or sets the elevation.

public double Elevation {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FrontClipZValue Property

Aspose.Imaging Documentation

CadViewport.FrontClipZValue Property

Gets or sets the front clip z value.

public double FrontClipZValue {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FrozenLayerObjectId Property

Aspose.Imaging Documentation

CadViewport.FrozenLayerObjectId Property

Gets or sets the frozen layer object id.

public string FrozenLayerObjectId {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


GridFrequency Property

Aspose.Imaging Documentation

CadViewport.GridFrequency Property

Gets or sets the grid frequency.

public short GridFrequency {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


GridSpacing Property

Aspose.Imaging Documentation

CadViewport.GridSpacing Property

Gets or sets the grid spacing.

public Cad2DPoint GridSpacing {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Height Property

Aspose.Imaging Documentation

CadViewport.Height Property

Gets or sets the height.

public double Height {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


OriginUcs Property

Aspose.Imaging Documentation

CadViewport.OriginUcs Property

Gets or sets the origin UCS.

public Cad3DPoint OriginUcs {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Orthographic Property

Aspose.Imaging Documentation

CadViewport.Orthographic Property

Gets or sets the orthographic.

public short Orthographic {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PerspectiveLensLength Property

Aspose.Imaging Documentation

CadViewport.PerspectiveLensLength Property

Gets or sets the perspective lens length.

public double PerspectiveLensLength {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


PlotStyleSheetName Property

Aspose.Imaging Documentation

CadViewport.PlotStyleSheetName Property

Gets or sets the plot style sheet name.

public string PlotStyleSheetName {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ReferenceToTableRecord Property

Aspose.Imaging Documentation

CadViewport.ReferenceToTableRecord Property

Gets or sets the reference to table record.

public string ReferenceToTableRecord {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ReferenceToTableRecordOrthoGraphic Property

Aspose.Imaging Documentation

CadViewport.ReferenceToTableRecordOrthoGraphic Property

Gets or sets the reference to table record ortho graphic.

public string ReferenceToTableRecordOrthoGraphic {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


RenderMode Property

Aspose.Imaging Documentation

CadViewport.RenderMode Property

Gets or sets the render mode.

public short RenderMode {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ShadeHandle Property

Aspose.Imaging Documentation

CadViewport.ShadeHandle Property

Gets or sets the shade handle.

public string ShadeHandle {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ShadePlotMode Property

Aspose.Imaging Documentation

CadViewport.ShadePlotMode Property

Gets or sets the shade plot mode.

public short ShadePlotMode {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SnapAngle Property

Aspose.Imaging Documentation

CadViewport.SnapAngle Property

Gets or sets the snap angle.

public double SnapAngle {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SnapBasePoint Property

Aspose.Imaging Documentation

CadViewport.SnapBasePoint Property

Gets or sets the snap base point.

public Cad2DPoint SnapBasePoint {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SnapSpacing Property

Aspose.Imaging Documentation

CadViewport.SnapSpacing Property

Gets or sets the snap spacing.

public Cad2DPoint SnapSpacing {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Status Property

Aspose.Imaging Documentation

CadViewport.Status Property

Gets or sets the status.

public short Status {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


SunHandle Property

Aspose.Imaging Documentation

CadViewport.SunHandle Property

Gets or sets the sun handle.

public string SunHandle {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


TwistAngle Property

Aspose.Imaging Documentation

CadViewport.TwistAngle Property

Gets or sets the twist angle.

public double TwistAngle {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


UcsPerViewPort Property

Aspose.Imaging Documentation

CadViewport.UcsPerViewPort Property

Gets or sets the UCS per view port.

public short UcsPerViewPort {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


VeiwHeight Property

Aspose.Imaging Documentation

CadViewport.VeiwHeight Property

Gets or sets the view height.

public double VeiwHeight {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ViewBrigtness Property

Aspose.Imaging Documentation

CadViewport.ViewBrigtness Property

Gets or sets the view brigtness.

public double ViewBrigtness {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ViewCenterPoint Property

Aspose.Imaging Documentation

CadViewport.ViewCenterPoint Property

Gets or sets the view center point.

public Cad2DPoint ViewCenterPoint {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ViewContrast Property

Aspose.Imaging Documentation

CadViewport.ViewContrast Property

Gets or sets the view contrast.

public double ViewContrast {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ViewDirectionVector Property

Aspose.Imaging Documentation

CadViewport.ViewDirectionVector Property

Gets or sets the view direction vector.

public Cad3DPoint ViewDirectionVector {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ViewPointRef1 Property

Aspose.Imaging Documentation

CadViewport.ViewPointRef1 Property

Gets or sets the view point ref 1.

public string ViewPointRef1 {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ViewPointRef2 Property

Aspose.Imaging Documentation

CadViewport.ViewPointRef2 Property

Gets or sets the view point ref 2.

public string ViewPointRef2 {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ViewPointRef3 Property

Aspose.Imaging Documentation

CadViewport.ViewPointRef3 Property

Gets or sets the view point ref 3.

public string ViewPointRef3 {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ViewPointRef4 Property

Aspose.Imaging Documentation

CadViewport.ViewPointRef4 Property

Gets or sets the view point ref 4.

public int ViewPointRef4 {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ViewportClippingObjectId Property

Aspose.Imaging Documentation

CadViewport.ViewportClippingObjectId Property

Gets or sets the viewport clipping object id.

public string ViewportClippingObjectId {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ViewPortId Property

Aspose.Imaging Documentation

CadViewport.ViewPortId Property

Gets or sets the view port id.

public short ViewPortId {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ViewPortStatus Property

Aspose.Imaging Documentation

CadViewport.ViewPortStatus Property

Gets or sets the view port status.

public int ViewPortStatus {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


ViewTargetVector Property

Aspose.Imaging Documentation

CadViewport.ViewTargetVector Property

Gets or sets the view target vector.

public Cad3DPoint ViewTargetVector {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


VisualStyleHandle Property

Aspose.Imaging Documentation

CadViewport.VisualStyleHandle Property

Gets or sets the visual style handle.

public string VisualStyleHandle {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Width Property

Aspose.Imaging Documentation

CadViewport.Width Property

Gets or sets the width.

public double Width {get; set;}

See Also

CadViewport Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXdata Class

The Cad xdata.

For a list of all members of this type, see CadXdata Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadXdata

public class CadXdata

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadXdata Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXdata Members

CadXdata overview

Public Instance Constructors

CadXdata Constructor Initializes a new instance of the CadXdata class. Initializes a new instance of the class.

Public Instance Properties

DataList | Gets or sets the data list.
Name | Gets or sets the name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadXdata Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXdata Constructor

Initializes a new instance of the CadXdata class. Initializes a new instance of the class.

public CadXdata();

See Also

CadXdata Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXdata Properties

The properties of the CadXdata class are listed below. For a complete list of CadXdata class members, see the CadXdata Members topic.

Public Instance Properties

DataList | Gets or sets the data list.
Name | Gets or sets the name.

See Also

CadXdata Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


DataList Property

Aspose.Imaging Documentation

CadXdata.DataList Property

Gets or sets the data list.

public CadCodeValue} DataList {get; set;}

Property Value

The data list.

See Also

CadXdata Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Name Property

Aspose.Imaging Documentation

CadXdata.Name Property

Gets or sets the name.

public string Name {get; set;}

Property Value

The name.

See Also

CadXdata Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXdataContainer Class

The Xdata Container

For a list of all members of this type, see CadXdataContainer Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadXdataContainer

public class CadXdataContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadXdataContainer Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXdataContainer Members

CadXdataContainer overview

Public Instance Constructors

CadXdataContainer Constructor Initializes a new instance of the CadXdataContainer class.

Public Instance Properties

Xdatas Gets or sets the xdatas.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAcadData | Gets the ACAD data.
GetData | Gets the data.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Initialize the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadXdataContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXdataContainer Constructor

Initializes a new instance of the CadXdataContainer class.

public CadXdataContainer();

See Also

CadXdataContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXdataContainer Properties

The properties of the CadXdataContainer class are listed below. For a complete list of CadXdataContainer class members, see the CadXdataContainer Members topic.

Public Instance Properties

Xdatas Gets or sets the xdatas.

See Also

CadXdataContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Xdatas Property

Aspose.Imaging Documentation

CadXdataContainer.Xdatas Property

Gets or sets the xdatas.

public CadXdata} Xdatas {get; set;}

Property Value

The xdatas.

See Also

CadXdataContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXdataContainer Methods

The methods of the CadXdataContainer class are listed below. For a complete list of CadXdataContainer class members, see the CadXdataContainer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAcadData | Gets the ACAD data.
GetData | Gets the data.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Initialize the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadXdataContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXdataContainer.GetAcadData Method

Gets the ACAD data.

public CadXdata GetAcadData();

Return Value

The xdata.

See Also

CadXdataContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXdataContainer.GetData Method

Gets the data.

public CadXdata GetData(
string applicationName
);

Parameters

applicationName
Name of the application.

Return Value

The xdata.

See Also

CadXdataContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXdataContainer.Init Method

Initialize the specified stream.

public CadCodeValue Init(
TextReader stream,
CadCodeValue codeValue
);

Parameters

stream
The stream.
codeValue
The code value.

Return Value

Last read codeValue

See Also

CadXdataContainer Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXLine Class

Class describing CadXLine

For a list of all members of this type, see CadXLine Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadXLine

public class CadXLine : CadBaseEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadObjects

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadXLine Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXLine Members

CadXLine overview

Public Instance Constructors

CadXLine Constructor Initializes a new instance of the CadXLine class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
FirstPoint | Gets or sets the first point .
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
UnitDirectionVector | Gets or sets the unit direction vector.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadXLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXLine Constructor

Initializes a new instance of the CadXLine class.

public CadXLine();

See Also

CadXLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadXLine Properties

The properties of the CadXLine class are listed below. For a complete list of CadXLine class members, see the CadXLine Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ChildObjects (inherited from CadBaseEntity) | Gets or sets the child objects.
ColorId (inherited from CadBaseEntity) | Gets or sets the color id.
ColorName (inherited from CadBaseEntity) | Gets or sets the name of the color.
ColorValue (inherited from CadBaseEntity) | Gets or sets the color value.
FirstPoint | Gets or sets the first point .
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LayerName (inherited from CadBaseEntity) | Gets or sets the name of the layer.
LineScale (inherited from CadBaseEntity) | Gets or sets the line scale.
LineTypeName (inherited from CadBaseEntity) | Gets or sets the name of the line type.
LineWeight (inherited from CadBaseEntity) | Gets or sets the line weight.
Material (inherited from CadBaseEntity) | Gets or sets the material.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotStyle (inherited from CadBaseEntity) | Gets or sets the plot style.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ProxyBytesCount (inherited from CadBaseEntity) | Gets or sets the proxy bytes count.
ProxyData (inherited from CadBaseEntity) | Gets or sets the proxy data.
ShadowMode (inherited from CadBaseEntity) | Gets or sets the shadow mode.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
SpaceMode (inherited from CadBaseEntity) | Gets or sets the space mode.
Transparency (inherited from CadBaseEntity) | Gets or sets the transparency.
TypeName (inherited from CadBaseEntity) | Gets the name of the type.
UnitDirectionVector | Gets or sets the unit direction vector.
Visible (inherited from CadBaseEntity) | Gets or sets a value indicating whether this CadBaseEntity is visible.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadXLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


FirstPoint Property

Aspose.Imaging Documentation

CadXLine.FirstPoint Property

Gets or sets the first point .

public Cad3DPoint FirstPoint {get; set;}

Property Value

The First Point .

See Also

CadXLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


UnitDirectionVector Property

Aspose.Imaging Documentation

CadXLine.UnitDirectionVector Property

Gets or sets the unit direction vector.

public Cad3DPoint UnitDirectionVector {get; set;}

Property Value

The unit direction vector.

See Also

CadXLine Class | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Aspose.Imaging.FileFormats.Cad.CadParameters

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Cad.CadParameters Namespace

Namespace hierarchy

Classes

Class | Description
CadBoolParameter | The Cad bool parameter.
CadDoubleParameter | Class for Double values
CadIntParameter | The Cad int parameter.
CadLongParameter | The Cad long parameter.
CadParameter | Parameter base class
CadShortParameter | The Cad short parameter.
CadStringParameter | The Cad string parameter.


CadBoolParameter Class

The Cad bool parameter.

For a list of all members of this type, see CadBoolParameter Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadParameters.CadParameter
Aspose.Imaging.FileFormats.Cad.CadParameters.CadBoolParameter

public class CadBoolParameter : CadParameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadParameters

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadBoolParameter Members | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadBoolParameter Members

CadBoolParameter overview

Public Instance Constructors

CadBoolParameter Overloaded. Initializes a new instance of the CadBoolParameter class.

Public Instance Properties

DefaultValue (inherited from CadParameter) | Gets or sets the default value.
IntegralParamType (inherited from CadParameter) | Gets or sets the type of the integral param.
Optional (inherited from CadParameter) | Gets or sets a value indicating whether this instance is optional.
Setted (inherited from CadParameter) | Gets or sets a value indicating whether this instance is set.
SubClassName (inherited from CadParameter) | Gets or sets the name of the sub class.
Type (inherited from CadParameter) | Gets the type.
Value | Gets or sets a value indicating whether this CadBoolParameter is value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. The initialization.
Prepare (inherited from CadParameter) | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBoolParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadBoolParameter Constructor

Initializes a new instance of the CadBoolParameter class.

Overload List

Initializes a new instance of the CadBoolParameter class.

public CadBoolParameter();

Initializes a new instance of the CadBoolParameter class.

public CadBoolParameter(CadEntityAttribute);

Initializes a new instance of the CadBoolParameter class.

public CadBoolParameter(CadEntityAttribute,CadParameterType);

Initializes a new instance of the CadBoolParameter class.

public CadBoolParameter(CadEntityAttribute,CadParameterType,object);

See Also

CadBoolParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadBoolParameter Constructor (CadEntityAttribute)

Initializes a new instance of the CadBoolParameter class.

public CadBoolParameter(
CadEntityAttribute type
);

Parameters

type
The type of the parameter.

See Also

CadBoolParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadBoolParameter Constructor Overload List


CadBoolParameter Constructor ()

Initializes a new instance of the CadBoolParameter class.

public CadBoolParameter();

See Also

CadBoolParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadBoolParameter Constructor Overload List


CadBoolParameter Constructor (CadEntityAttribute, CadParameterType)

Initializes a new instance of the CadBoolParameter class.

public CadBoolParameter(
CadEntityAttribute type,
CadParameterType optional
);

Parameters

type
The type of the parameter.
optional
Optional flag.

See Also

CadBoolParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadBoolParameter Constructor Overload List


CadBoolParameter Constructor (CadEntityAttribute, CadParameterType, Object)

Initializes a new instance of the CadBoolParameter class.

public CadBoolParameter(
CadEntityAttribute type,
CadParameterType optional,
object defaultValue
);

Parameters

type
The type of the parameter.
optional
The optional.
defaultValue
The default value.

See Also

CadBoolParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadBoolParameter Constructor Overload List


CadBoolParameter Properties

The properties of the CadBoolParameter class are listed below. For a complete list of CadBoolParameter class members, see the CadBoolParameter Members topic.

Public Instance Properties

DefaultValue (inherited from CadParameter) | Gets or sets the default value.
IntegralParamType (inherited from CadParameter) | Gets or sets the type of the integral param.
Optional (inherited from CadParameter) | Gets or sets a value indicating whether this instance is optional.
Setted (inherited from CadParameter) | Gets or sets a value indicating whether this instance is set.
SubClassName (inherited from CadParameter) | Gets or sets the name of the sub class.
Type (inherited from CadParameter) | Gets the type.
Value | Gets or sets a value indicating whether this CadBoolParameter is value.

See Also

CadBoolParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Value Property

Aspose.Imaging Documentation

CadBoolParameter.Value Property

Gets or sets a value indicating whether this CadBoolParameter is value.

public bool Value {get; set;}

Property Value

true if value; otherwise, false.

See Also

CadBoolParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadBoolParameter Methods

The methods of the CadBoolParameter class are listed below. For a complete list of CadBoolParameter class members, see the CadBoolParameter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. The initialization.
Prepare (inherited from CadParameter) | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBoolParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Init Method

Aspose.Imaging Documentation

CadBoolParameter.Init Method

The initialization.

Overload List

The initialization.

public override void Init(CadEntityAttribute,string);

Inits the specified value.

public override void Init(string);

See Also

CadBoolParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadBoolParameter.Init Method (CadEntityAttribute, String)

The initialization.

public override void Init(
CadEntityAttribute type,
string value
);

Parameters

type
The type of the parameter.
value
The value of the parameter.

See Also

CadBoolParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadBoolParameter.Init Overload List


CadBoolParameter.Init Method (String)

Inits the specified value.

public override void Init(
string value
);

Parameters

value
The value of the parameter.

See Also

CadBoolParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadBoolParameter.Init Overload List


CadDoubleParameter Class

Class for Double values

For a list of all members of this type, see CadDoubleParameter Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadParameters.CadParameter
Aspose.Imaging.FileFormats.Cad.CadParameters.CadDoubleParameter

public class CadDoubleParameter : CadParameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadParameters

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadDoubleParameter Members | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadDoubleParameter Members

CadDoubleParameter overview

Public Instance Constructors

CadDoubleParameter Overloaded. Initializes a new instance of the CadDoubleParameter class.

Public Instance Properties

DefaultValue (inherited from CadParameter) | Gets or sets the default value.
IntegralParamType (inherited from CadParameter) | Gets or sets the type of the integral param.
Optional (inherited from CadParameter) | Gets or sets a value indicating whether this instance is optional.
Setted (inherited from CadParameter) | Gets or sets a value indicating whether this instance is set.
SubClassName (inherited from CadParameter) | Gets or sets the name of the sub class.
Type (inherited from CadParameter) | Gets the type.
Value | Gets or sets the value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. The initialization .
Prepare (inherited from CadParameter) | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadDoubleParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadDoubleParameter Constructor

Initializes a new instance of the CadDoubleParameter class.

Overload List

Initializes a new instance of the CadDoubleParameter class.

public CadDoubleParameter();

Initializes a new instance of the CadDoubleParameter class.

public CadDoubleParameter(CadEntityAttribute);

Initializes a new instance of the CadDoubleParameter class.

public CadDoubleParameter(CadEntityAttribute,CadParameterType);

Initializes a new instance of the CadDoubleParameter class.

public CadDoubleParameter(CadEntityAttribute,CadParameterType,object);

See Also

CadDoubleParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadDoubleParameter Constructor (CadEntityAttribute)

Initializes a new instance of the CadDoubleParameter class.

public CadDoubleParameter(
CadEntityAttribute attribute
);

Parameters

attribute
The attribute.

See Also

CadDoubleParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadDoubleParameter Constructor Overload List


CadDoubleParameter Constructor ()

Initializes a new instance of the CadDoubleParameter class.

public CadDoubleParameter();

See Also

CadDoubleParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadDoubleParameter Constructor Overload List


CadDoubleParameter Constructor (CadEntityAttribute, CadParameterType)

Initializes a new instance of the CadDoubleParameter class.

public CadDoubleParameter(
CadEntityAttribute type,
CadParameterType optional
);

Parameters

type
The type of the parameter.
optional
The optional.

See Also

CadDoubleParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadDoubleParameter Constructor Overload List


CadDoubleParameter Constructor (CadEntityAttribute, CadParameterType, Object)

Initializes a new instance of the CadDoubleParameter class.

public CadDoubleParameter(
CadEntityAttribute type,
CadParameterType optional,
object defaultValue
);

Parameters

type
The type of the parameter.
optional
The optional flag.
defaultValue
The default value.

See Also

CadDoubleParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadDoubleParameter Constructor Overload List


CadDoubleParameter Properties

The properties of the CadDoubleParameter class are listed below. For a complete list of CadDoubleParameter class members, see the CadDoubleParameter Members topic.

Public Instance Properties

DefaultValue (inherited from CadParameter) | Gets or sets the default value.
IntegralParamType (inherited from CadParameter) | Gets or sets the type of the integral param.
Optional (inherited from CadParameter) | Gets or sets a value indicating whether this instance is optional.
Setted (inherited from CadParameter) | Gets or sets a value indicating whether this instance is set.
SubClassName (inherited from CadParameter) | Gets or sets the name of the sub class.
Type (inherited from CadParameter) | Gets the type.
Value | Gets or sets the value.

See Also

CadDoubleParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Value Property

Aspose.Imaging Documentation

CadDoubleParameter.Value Property

Gets or sets the value.

public double Value {get; set;}

Property Value

The value of the parameter.

See Also

CadDoubleParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadDoubleParameter Methods

The methods of the CadDoubleParameter class are listed below. For a complete list of CadDoubleParameter class members, see the CadDoubleParameter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. The initialization .
Prepare (inherited from CadParameter) | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadDoubleParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Init Method

Aspose.Imaging Documentation

CadDoubleParameter.Init Method

The initialization .

Overload List

The initialization .

public override void Init(CadEntityAttribute,string);

The initialization of the class.

public override void Init(string);

See Also

CadDoubleParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadDoubleParameter.Init Method (CadEntityAttribute, String)

The initialization .

public override void Init(
CadEntityAttribute type,
string value
);

Parameters

type
The type of the parameter.
value
The value of the parameter.

See Also

CadDoubleParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadDoubleParameter.Init Overload List


CadDoubleParameter.Init Method (String)

The initialization of the class.

public override void Init(
string value
);

Parameters

value
The string value will be converted to Double.

See Also

CadDoubleParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadDoubleParameter.Init Overload List


CadIntParameter Class

The Cad int parameter.

For a list of all members of this type, see CadIntParameter Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadParameters.CadParameter
Aspose.Imaging.FileFormats.Cad.CadParameters.CadIntParameter

public class CadIntParameter : CadParameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadParameters

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadIntParameter Members | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadIntParameter Members

CadIntParameter overview

Public Instance Constructors

CadIntParameter Overloaded. Initializes a new instance of the CadIntParameter class.

Public Instance Properties

DefaultValue (inherited from CadParameter) | Gets or sets the default value.
IntegralParamType (inherited from CadParameter) | Gets or sets the type of the integral param.
Optional (inherited from CadParameter) | Gets or sets a value indicating whether this instance is optional.
Setted (inherited from CadParameter) | Gets or sets a value indicating whether this instance is set.
SubClassName (inherited from CadParameter) | Gets or sets the name of the sub class.
Type (inherited from CadParameter) | Gets the type.
Value | Gets or sets the value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. The initialization function.
Prepare (inherited from CadParameter) | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadIntParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadIntParameter Constructor

Initializes a new instance of the CadIntParameter class.

Overload List

Initializes a new instance of the CadIntParameter class.

public CadIntParameter();

Initializes a new instance of the CadIntParameter class.

public CadIntParameter(CadEntityAttribute);

Initializes a new instance of the CadIntParameter class.

public CadIntParameter(CadEntityAttribute,CadParameterType);

Initializes a new instance of the CadIntParameter class.

public CadIntParameter(CadEntityAttribute,CadParameterType,object);

See Also

CadIntParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadIntParameter Constructor (CadEntityAttribute)

Initializes a new instance of the CadIntParameter class.

public CadIntParameter(
CadEntityAttribute type
);

Parameters

type
The type of the parameter.

See Also

CadIntParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadIntParameter Constructor Overload List


CadIntParameter Constructor ()

Initializes a new instance of the CadIntParameter class.

public CadIntParameter();

See Also

CadIntParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadIntParameter Constructor Overload List


CadIntParameter Constructor (CadEntityAttribute, CadParameterType)

Initializes a new instance of the CadIntParameter class.

public CadIntParameter(
CadEntityAttribute type,
CadParameterType optional
);

Parameters

type
The type of the parameter to create.
optional
The optional flag.

See Also

CadIntParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadIntParameter Constructor Overload List


CadIntParameter Constructor (CadEntityAttribute, CadParameterType, Object)

Initializes a new instance of the CadIntParameter class.

public CadIntParameter(
CadEntityAttribute type,
CadParameterType optional,
object defaultValue
);

Parameters

type
The type of the parameter.
optional
The optional.
defaultValue
The default value.

See Also

CadIntParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadIntParameter Constructor Overload List


CadIntParameter Properties

The properties of the CadIntParameter class are listed below. For a complete list of CadIntParameter class members, see the CadIntParameter Members topic.

Public Instance Properties

DefaultValue (inherited from CadParameter) | Gets or sets the default value.
IntegralParamType (inherited from CadParameter) | Gets or sets the type of the integral param.
Optional (inherited from CadParameter) | Gets or sets a value indicating whether this instance is optional.
Setted (inherited from CadParameter) | Gets or sets a value indicating whether this instance is set.
SubClassName (inherited from CadParameter) | Gets or sets the name of the sub class.
Type (inherited from CadParameter) | Gets the type.
Value | Gets or sets the value.

See Also

CadIntParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Value Property

Aspose.Imaging Documentation

CadIntParameter.Value Property

Gets or sets the value.

public int Value {get; set;}

Property Value

The value of the parameter.

See Also

CadIntParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadIntParameter Methods

The methods of the CadIntParameter class are listed below. For a complete list of CadIntParameter class members, see the CadIntParameter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. The initialization function.
Prepare (inherited from CadParameter) | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadIntParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Init Method

Aspose.Imaging Documentation

CadIntParameter.Init Method

The initialization function.

Overload List

The initialization function.

public override void Init(CadEntityAttribute,string);

Inits the specified value.

public override void Init(string);

See Also

CadIntParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadIntParameter.Init Method (CadEntityAttribute, String)

The initialization function.

public override void Init(
CadEntityAttribute type,
string value
);

Parameters

type
The type of the parameter.
value
The value to assign.

See Also

CadIntParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadIntParameter.Init Overload List


CadIntParameter.Init Method (String)

Inits the specified value.

public override void Init(
string value
);

Parameters

value
The value to assign.

See Also

CadIntParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadIntParameter.Init Overload List


CadLongParameter Class

The Cad long parameter.

For a list of all members of this type, see CadLongParameter Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadParameters.CadParameter
Aspose.Imaging.FileFormats.Cad.CadParameters.CadLongParameter

public class CadLongParameter : CadParameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadParameters

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadLongParameter Members | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadLongParameter Members

CadLongParameter overview

Public Instance Constructors

CadLongParameter Constructor Initializes a new instance of the CadLongParameter class.

Public Instance Properties

DefaultValue (inherited from CadParameter) | Gets or sets the default value.
IntegralParamType (inherited from CadParameter) | Gets or sets the type of the integral param.
Optional (inherited from CadParameter) | Gets or sets a value indicating whether this instance is optional.
Setted (inherited from CadParameter) | Gets or sets a value indicating whether this instance is set.
SubClassName (inherited from CadParameter) | Gets or sets the name of the sub class.
Type (inherited from CadParameter) | Gets the type.
Value | Gets or sets the value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. Inits the specified type.
Prepare (inherited from CadParameter) | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLongParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadLongParameter Constructor

Initializes a new instance of the CadLongParameter class.

public CadLongParameter(
CadEntityAttribute CadEntityAttribute
);

Parameters

CadEntityAttribute
The Cad entity attribute.

See Also

CadLongParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadLongParameter Properties

The properties of the CadLongParameter class are listed below. For a complete list of CadLongParameter class members, see the CadLongParameter Members topic.

Public Instance Properties

DefaultValue (inherited from CadParameter) | Gets or sets the default value.
IntegralParamType (inherited from CadParameter) | Gets or sets the type of the integral param.
Optional (inherited from CadParameter) | Gets or sets a value indicating whether this instance is optional.
Setted (inherited from CadParameter) | Gets or sets a value indicating whether this instance is set.
SubClassName (inherited from CadParameter) | Gets or sets the name of the sub class.
Type (inherited from CadParameter) | Gets the type.
Value | Gets or sets the value.

See Also

CadLongParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Value Property

Aspose.Imaging Documentation

CadLongParameter.Value Property

Gets or sets the value.

public long Value {get; set;}

Property Value

The value.

See Also

CadLongParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadLongParameter Methods

The methods of the CadLongParameter class are listed below. For a complete list of CadLongParameter class members, see the CadLongParameter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. Inits the specified type.
Prepare (inherited from CadParameter) | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLongParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Init Method

Aspose.Imaging Documentation

CadLongParameter.Init Method

Inits the specified type.

Overload List

Inits the specified type.

public override void Init(CadEntityAttribute,string);

The initialization.

public override void Init(string);

See Also

CadLongParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadLongParameter.Init Method (CadEntityAttribute, String)

Inits the specified type.

public override void Init(
CadEntityAttribute type,
string value
);

Parameters

type
The type of the parameter.
value
The value of the parameter.

See Also

CadLongParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadLongParameter.Init Overload List


CadLongParameter.Init Method (String)

The initialization.

public override void Init(
string value
);

Parameters

value
The value of the parameter.

See Also

CadLongParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadLongParameter.Init Overload List


CadParameter Class

Parameter base class

For a list of all members of this type, see CadParameter Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadParameters.CadParameter
Derived types

public abstract class CadParameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadParameters

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadParameter Members | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadParameter Members

CadParameter overview

Public Static Methods

Write Writes the specified writer.

Public Instance Constructors

CadParameter Overloaded. Initializes a new instance of the CadParameter class.

Public Instance Properties

DefaultValue | Gets or sets the default value.
IntegralParamType | Gets or sets the type of the integral param.
Optional | Gets or sets a value indicating whether this instance is optional.
Setted | Gets or sets a value indicating whether this instance is set.
SubClassName | Gets or sets the name of the sub class.
Type | Gets the type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. Inits the specified type.
Prepare | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadParameter Constructor

Initializes a new instance of the CadParameter class.

Overload List

Initializes a new instance of the CadParameter class.

public CadParameter();

Initializes a new instance of the CadParameter class.

public CadParameter(CadEntityAttribute);

Initializes a new instance of the CadParameter class.

public CadParameter(CadEntityAttribute,CadParameterType);

Initializes a new instance of the CadParameter class.

public CadParameter(CadEntityAttribute,CadParameterType,object);

public CadParameter(CadEntityAttribute,CadParameterType,object,ref object);

Initializes a new instance of the CadParameter class.

public CadParameter(CadEntityAttribute,object);

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadParameter Constructor (CadEntityAttribute)

Initializes a new instance of the CadParameter class.

public CadParameter(
CadEntityAttribute type
);

Parameters

type
The type of the parameter.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadParameter Constructor Overload List


CadParameter Constructor (CadEntityAttribute, CadParameterType)

Initializes a new instance of the CadParameter class.

public CadParameter(
CadEntityAttribute type,
CadParameterType optional
);

Parameters

type
The type of the parameter.
optional
The optional flag.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadParameter Constructor Overload List


CadParameter Constructor (CadEntityAttribute, CadParameterType, Object)

Initializes a new instance of the CadParameter class.

public CadParameter(
CadEntityAttribute type,
CadParameterType optional,
object defaultValue
);

Parameters

type
The type of the parameter.
optional
The optional flag.
defaultValue
The default value.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadParameter Constructor Overload List


CadParameter Constructor (CadEntityAttribute, CadParameterType, Object, Object)

public CadParameter(
CadEntityAttribute type,
CadParameterType optional,
object defaultValue,
ref object bondedObject
);

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadParameter Constructor Overload List


CadParameter Constructor (CadEntityAttribute, Object)

Initializes a new instance of the CadParameter class.

public CadParameter(
CadEntityAttribute type,
object bondingObject
);

Parameters

type
The type of the parameter.
bondingObject
The bonding object.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadParameter Constructor Overload List


CadParameter Constructor ()

Initializes a new instance of the CadParameter class.

public CadParameter();

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadParameter Constructor Overload List


CadParameter Properties

The properties of the CadParameter class are listed below. For a complete list of CadParameter class members, see the CadParameter Members topic.

Public Instance Properties

DefaultValue | Gets or sets the default value.
IntegralParamType | Gets or sets the type of the integral param.
Optional | Gets or sets a value indicating whether this instance is optional.
Setted | Gets or sets a value indicating whether this instance is set.
SubClassName | Gets or sets the name of the sub class.
Type | Gets the type.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


DefaultValue Property

Aspose.Imaging Documentation

CadParameter.DefaultValue Property

Gets or sets the default value.

public object DefaultValue {get; set;}

Property Value

The default value.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


IntegralParamType Property

Aspose.Imaging Documentation

CadParameter.IntegralParamType Property

Gets or sets the type of the integral param.

public CadIntegralParamType IntegralParamType {get; set;}

Property Value

The type of the integral param.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Optional Property

Aspose.Imaging Documentation

CadParameter.Optional Property

Gets or sets a value indicating whether this instance is optional.

public CadParameterType Optional {get; set;}

Property Value

true if this instance is optional; otherwise, false.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Setted Property

Aspose.Imaging Documentation

CadParameter.Setted Property

Gets or sets a value indicating whether this instance is set.

public bool Setted {get; set;}

Property Value

true if this instance is set; otherwise, false.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


SubClassName Property

Aspose.Imaging Documentation

CadParameter.SubClassName Property

Gets or sets the name of the sub class.

public string SubClassName {get; set;}

Property Value

The name of the sub class.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Type Property

Aspose.Imaging Documentation

CadParameter.Type Property

Gets the type.

public CadEntityAttribute Type {get;}

Property Value

The type.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadParameter Methods

The methods of the CadParameter class are listed below. For a complete list of CadParameter class members, see the CadParameter Members topic.

Public Static Methods

Write Writes the specified writer.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. Inits the specified type.
Prepare | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Init Method

Aspose.Imaging Documentation

CadParameter.Init Method

Inits the specified type.

Overload List

Inits the specified type.

public abstract void Init(CadEntityAttribute,string);

Inits the specified value.

public abstract void Init(string);

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadParameter.Init Method (CadEntityAttribute, String)

Inits the specified type.

public abstract void Init(
CadEntityAttribute type,
string value
);

Parameters

type
The type of the parameter.
value
The value of the parameter.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadParameter.Init Overload List


CadParameter.Init Method (String)

Inits the specified value.

public abstract void Init(
string value
);

Parameters

value
The value of the parameter.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadParameter.Init Overload List


CadParameter.Prepare Method

The prepare function.

public void Prepare(
CadEntityAttribute type
);

Parameters

type
The type of the parameter.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadParameter.Write Method

Writes the specified writer.

public static void Write(
StreamWriter writer,
CadEntityAttribute attribute,
string value
);

Parameters

writer
The writer.
attribute
The attribute.
value
The value to write.

See Also

CadParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadShortParameter Class

The Cad short parameter.

For a list of all members of this type, see CadShortParameter Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadParameters.CadParameter
Aspose.Imaging.FileFormats.Cad.CadParameters.CadShortParameter

public class CadShortParameter : CadParameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadParameters

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadShortParameter Members | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadShortParameter Members

CadShortParameter overview

Public Instance Constructors

CadShortParameter Overloaded. Initializes a new instance of the CadShortParameter class.

Public Instance Properties

DefaultValue (inherited from CadParameter) | Gets or sets the default value.
IntegralParamType (inherited from CadParameter) | Gets or sets the type of the integral param.
Optional (inherited from CadParameter) | Gets or sets a value indicating whether this instance is optional.
Setted (inherited from CadParameter) | Gets or sets a value indicating whether this instance is set.
SubClassName (inherited from CadParameter) | Gets or sets the name of the sub class.
Type (inherited from CadParameter) | Gets the type.
Value | Gets or sets the value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. The initialization.
Prepare (inherited from CadParameter) | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadShortParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadShortParameter Constructor

Initializes a new instance of the CadShortParameter class.

Overload List

Initializes a new instance of the CadShortParameter class.

public CadShortParameter();

Initializes a new instance of the CadShortParameter class.

public CadShortParameter(CadEntityAttribute);

Initializes a new instance of the CadShortParameter class.

public CadShortParameter(CadEntityAttribute,CadParameterType);

Initializes a new instance of the CadShortParameter class.

public CadShortParameter(CadEntityAttribute,CadParameterType,object);

See Also

CadShortParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadShortParameter Constructor (CadEntityAttribute)

Initializes a new instance of the CadShortParameter class.

public CadShortParameter(
CadEntityAttribute attribute
);

Parameters

attribute
The attribute.

See Also

CadShortParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadShortParameter Constructor Overload List


CadShortParameter Constructor ()

Initializes a new instance of the CadShortParameter class.

public CadShortParameter();

See Also

CadShortParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadShortParameter Constructor Overload List


CadShortParameter Constructor (CadEntityAttribute, CadParameterType)

Initializes a new instance of the CadShortParameter class.

public CadShortParameter(
CadEntityAttribute type,
CadParameterType optional
);

Parameters

type
The type of the parameter.
optional
The optional flag.

See Also

CadShortParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadShortParameter Constructor Overload List


CadShortParameter Constructor (CadEntityAttribute, CadParameterType, Object)

Initializes a new instance of the CadShortParameter class.

public CadShortParameter(
CadEntityAttribute type,
CadParameterType optional,
object defaultValue
);

Parameters

type
The type of the parameter.
optional
The optional flag.
defaultValue
The default value.

See Also

CadShortParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadShortParameter Constructor Overload List


CadShortParameter Properties

The properties of the CadShortParameter class are listed below. For a complete list of CadShortParameter class members, see the CadShortParameter Members topic.

Public Instance Properties

DefaultValue (inherited from CadParameter) | Gets or sets the default value.
IntegralParamType (inherited from CadParameter) | Gets or sets the type of the integral param.
Optional (inherited from CadParameter) | Gets or sets a value indicating whether this instance is optional.
Setted (inherited from CadParameter) | Gets or sets a value indicating whether this instance is set.
SubClassName (inherited from CadParameter) | Gets or sets the name of the sub class.
Type (inherited from CadParameter) | Gets the type.
Value | Gets or sets the value.

See Also

CadShortParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Value Property

Aspose.Imaging Documentation

CadShortParameter.Value Property

Gets or sets the value.

public short Value {get; set;}

Property Value

The value of the parameter.

See Also

CadShortParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadShortParameter Methods

The methods of the CadShortParameter class are listed below. For a complete list of CadShortParameter class members, see the CadShortParameter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. The initialization.
Prepare (inherited from CadParameter) | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadShortParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Init Method

Aspose.Imaging Documentation

CadShortParameter.Init Method

The initialization.

Overload List

The initialization.

public override void Init(CadEntityAttribute,string);

Inits the specified value.

public override void Init(string);

See Also

CadShortParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadShortParameter.Init Method (CadEntityAttribute, String)

The initialization.

public override void Init(
CadEntityAttribute type,
string value
);

Parameters

type
The type of the parameter.
value
The value of the parameter.

See Also

CadShortParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadShortParameter.Init Overload List


CadShortParameter.Init Method (String)

Inits the specified value.

public override void Init(
string value
);

Parameters

value
The value of the parameter.

See Also

CadShortParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadShortParameter.Init Overload List


CadStringParameter Class

The Cad string parameter.

For a list of all members of this type, see CadStringParameter Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadParameters.CadParameter
Aspose.Imaging.FileFormats.Cad.CadParameters.CadStringParameter

public class CadStringParameter : CadParameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadParameters

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadStringParameter Members | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadStringParameter Members

CadStringParameter overview

Public Instance Constructors

CadStringParameter Overloaded. Initializes a new instance of the CadStringParameter class.

Public Instance Properties

DefaultValue (inherited from CadParameter) | Gets or sets the default value.
IntegralParamType (inherited from CadParameter) | Gets or sets the type of the integral param.
Optional (inherited from CadParameter) | Gets or sets a value indicating whether this instance is optional.
Setted (inherited from CadParameter) | Gets or sets a value indicating whether this instance is set.
SubClassName (inherited from CadParameter) | Gets or sets the name of the sub class.
Type (inherited from CadParameter) | Gets the type.
Value | Gets or sets the value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. The initialization.
Prepare (inherited from CadParameter) | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadStringParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadStringParameter Constructor

Initializes a new instance of the CadStringParameter class.

Overload List

Initializes a new instance of the CadStringParameter class.

public CadStringParameter();

Initializes a new instance of the CadStringParameter class.

public CadStringParameter(CadEntityAttribute);

Initializes a new instance of the CadStringParameter class.

public CadStringParameter(CadEntityAttribute,CadParameterType);

Initializes a new instance of the CadStringParameter class.

public CadStringParameter(CadEntityAttribute,CadParameterType,object);

See Also

CadStringParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadStringParameter Constructor (CadEntityAttribute)

Initializes a new instance of the CadStringParameter class.

public CadStringParameter(
CadEntityAttribute type
);

Parameters

type
The type of the parameter.

See Also

CadStringParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadStringParameter Constructor Overload List


CadStringParameter Constructor (CadEntityAttribute, CadParameterType)

Initializes a new instance of the CadStringParameter class.

public CadStringParameter(
CadEntityAttribute type,
CadParameterType optional
);

Parameters

type
The type of the parameter.
optional
The optional flag.

See Also

CadStringParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadStringParameter Constructor Overload List


CadStringParameter Constructor ()

Initializes a new instance of the CadStringParameter class.

public CadStringParameter();

See Also

CadStringParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadStringParameter Constructor Overload List


CadStringParameter Constructor (CadEntityAttribute, CadParameterType, Object)

Initializes a new instance of the CadStringParameter class.

public CadStringParameter(
CadEntityAttribute type,
CadParameterType optional,
object defaultValue
);

Parameters

type
The type of the parameter.
optional
The optional flag.
defaultValue
The default value.

See Also

CadStringParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadStringParameter Constructor Overload List


CadStringParameter Properties

The properties of the CadStringParameter class are listed below. For a complete list of CadStringParameter class members, see the CadStringParameter Members topic.

Public Instance Properties

DefaultValue (inherited from CadParameter) | Gets or sets the default value.
IntegralParamType (inherited from CadParameter) | Gets or sets the type of the integral param.
Optional (inherited from CadParameter) | Gets or sets a value indicating whether this instance is optional.
Setted (inherited from CadParameter) | Gets or sets a value indicating whether this instance is set.
SubClassName (inherited from CadParameter) | Gets or sets the name of the sub class.
Type (inherited from CadParameter) | Gets the type.
Value | Gets or sets the value.

See Also

CadStringParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Value Property

Aspose.Imaging Documentation

CadStringParameter.Value Property

Gets or sets the value.

public string Value {get; set;}

Property Value

The value of the parameter.

See Also

CadStringParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadStringParameter Methods

The methods of the CadStringParameter class are listed below. For a complete list of CadStringParameter class members, see the CadStringParameter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded. The initialization.
Prepare (inherited from CadParameter) | The prepare function.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadStringParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Init Method

Aspose.Imaging Documentation

CadStringParameter.Init Method

The initialization.

Overload List

The initialization.

public override void Init(CadEntityAttribute,string);

Inits the specified value.

public override void Init(string);

See Also

CadStringParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


CadStringParameter.Init Method (CadEntityAttribute, String)

The initialization.

public override void Init(
CadEntityAttribute type,
string value
);

Parameters

type
The type of the parameter.
value
The value of the parameter.

See Also

CadStringParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadStringParameter.Init Overload List


CadStringParameter.Init Method (String)

Inits the specified value.

public override void Init(
string value
);

Parameters

value
The value of the parameter.

See Also

CadStringParameter Class | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace | CadStringParameter.Init Overload List


Aspose.Imaging.FileFormats.Cad.CadTables

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Cad.CadTables Namespace

Namespace hierarchy

Classes

Class | Description
CadAppIdTableObject | The Cad app id table.
CadBlockTableObject | The Cad block table object.
CadDimensionStyleTable | The Cad dimension style table.
CadLayerTable | The Cad layer table.
CadLineTypeTableObject | The Cad line type table object.
CadStyleTableObject | The Cad style table object.


CadAppIdTableObject Class

The Cad app id table.

For a list of all members of this type, see CadAppIdTableObject Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseTable
Aspose.Imaging.FileFormats.Cad.CadTables.CadAppIdTableObject

public class CadAppIdTableObject : CadBaseTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadTables

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadAppIdTableObject Members | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadAppIdTableObject Members

CadAppIdTableObject overview

Public Instance Constructors

CadAppIdTableObject Constructor Initializes a new instance of the CadAppIdTableObject class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
ApplicationFlag | Gets or sets the application flag.
AppName | Gets or sets the app name.
AppNameIsSet | Gets a value indicating whether app name is set.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
MaxTableEntriesCount (inherited from CadBaseTable) | Gets or sets the max table entries count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
TableName (inherited from CadBaseTable) | Gets or sets the name of the table.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadAppIdTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadAppIdTableObject Constructor

Initializes a new instance of the CadAppIdTableObject class.

public CadAppIdTableObject();

See Also

CadAppIdTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadAppIdTableObject Properties

The properties of the CadAppIdTableObject class are listed below. For a complete list of CadAppIdTableObject class members, see the CadAppIdTableObject Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
ApplicationFlag | Gets or sets the application flag.
AppName | Gets or sets the app name.
AppNameIsSet | Gets a value indicating whether app name is set.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
MaxTableEntriesCount (inherited from CadBaseTable) | Gets or sets the max table entries count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
TableName (inherited from CadBaseTable) | Gets or sets the name of the table.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadAppIdTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


ApplicationFlag Property

Aspose.Imaging Documentation

CadAppIdTableObject.ApplicationFlag Property

Gets or sets the application flag.

public short ApplicationFlag {get; set;}

See Also

CadAppIdTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


AppName Property

Aspose.Imaging Documentation

CadAppIdTableObject.AppName Property

Gets or sets the app name.

public string AppName {get; set;}

See Also

CadAppIdTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


AppNameIsSet Property

Aspose.Imaging Documentation

CadAppIdTableObject.AppNameIsSet Property

Gets a value indicating whether app name is set.

public bool AppNameIsSet {get;}

See Also

CadAppIdTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadBlockTableObject Class

The Cad block table object.

For a list of all members of this type, see CadBlockTableObject Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseTable
Aspose.Imaging.FileFormats.Cad.CadTables.CadBlockTableObject

public class CadBlockTableObject : CadBaseTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadTables

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadBlockTableObject Members | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadBlockTableObject Members

CadBlockTableObject overview

Public Instance Constructors

CadBlockTableObject Constructor Initializes a new instance of the CadBlockTableObject class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName | Gets or sets the name of the block.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HardPointerToLayout | Gets or sets the hard pointer to layout.
MaxTableEntriesCount (inherited from CadBaseTable) | Gets or sets the max table entries count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
TableName (inherited from CadBaseTable) | Gets or sets the name of the table.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadBlockTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadBlockTableObject Constructor

Initializes a new instance of the CadBlockTableObject class.

public CadBlockTableObject();

See Also

CadBlockTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadBlockTableObject Properties

The properties of the CadBlockTableObject class are listed below. For a complete list of CadBlockTableObject class members, see the CadBlockTableObject Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BlockName | Gets or sets the name of the block.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
HardPointerToLayout | Gets or sets the hard pointer to layout.
MaxTableEntriesCount (inherited from CadBaseTable) | Gets or sets the max table entries count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
TableName (inherited from CadBaseTable) | Gets or sets the name of the table.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadBlockTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


BlockName Property

Aspose.Imaging Documentation

CadBlockTableObject.BlockName Property

Gets or sets the name of the block.

public string BlockName {get; set;}

Property Value

The name of the block.

See Also

CadBlockTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


HardPointerToLayout Property

Aspose.Imaging Documentation

CadBlockTableObject.HardPointerToLayout Property

Gets or sets the hard pointer to layout.

public string HardPointerToLayout {get; set;}

Property Value

The hard pointer to layout.

See Also

CadBlockTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadDimensionStyleTable Class

The Cad dimension style table.

For a list of all members of this type, see CadDimensionStyleTable Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseTable
Aspose.Imaging.FileFormats.Cad.CadTables.CadDimensionStyleTable

public class CadDimensionStyleTable : CadBaseTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadTables

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadDimensionStyleTable Members | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadDimensionStyleTable Members

CadDimensionStyleTable overview

Public Instance Constructors

CadDimensionStyleTable Constructor Initializes a new instance of the CadDimensionStyleTable class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
Dimadec | Gets or sets The dimadec - 179
Dimalt | Gets or sets The dimalt - 170
Dimaltd | Gets or sets The dimaltd - 171
Dimaltf | Gets or sets The dimaltf -143
Dimaltrnd | Gets or sets The dimaltrnd - 148
Dimalttd | Gets or sets The dimalttd - 274
Dimalttz | Gets or sets The dimalttz - 286
Dimaltu | Gets or sets The dimaltu - 273
Dimaltz | Gets or sets The dimaltz - 285
Dimapost | Gets or sets The dimapost - 004
Dimasz | Gets or sets The dimasz - 041
Dimatfit | Gets or sets The dimatfit - 289
Dimaunit | Gets or sets The dimaunit -275
Dimazin | Gets or sets The dimazin 079
Dimblk | Gets or sets The dimblk - 342
Dimblk1 | Gets or sets The dimblk1 - 343
Dimblk2 | Gets or sets The dimblk2
Dimcen | Gets or sets The dimcen - 141
Dimclrd | Gets or sets The dimclrd - 176
Dimclre | Gets or sets The dimclre - 177
Dimclrt | Gets or sets The dimclrt - 178
Dimdec | Gets or sets The dimdec 271
Dimdle | Gets or sets The dimdle - 046
Dimdli | Gets or sets The dimdli - 043
Dimdsep | Gets or sets The dimdsep - 278
Dimexe | Gets or sets The dimexe - 044
Dimexo | Gets or sets The dimexo - 042
Dimfit | Gets or sets The dimfit - 287
Dimfrac | Gets or sets The dimfrac - 276
Dimgap | Gets or sets The dimgap - 147
Dimjust | Gets or sets The dimjust - 280
Dimldrblk | Gets or sets The dimldrblk - 341
Dimlfac | Gets or sets The dimlfac - 144
Dimlim | Gets or sets The dimlim - 072
Dimlunit | Gets or sets The dimlunit - 277
Dimlwd | Gets or sets The dimlwd - 371
Dimlwe | Gets or sets The dimlwe - 372
Dimpost | Gets or sets The dimpost - 003
Dimrnd | Gets or sets The dimrnd - 045
Dimsah | Gets or sets The dimsah - 173
Dimscale | Gets or sets The dimscale - 040
Dimsd1 | Gets or sets The dimsd1 - 281
Dimsd2 | Gets or sets The dimsd2 - 282
Dimse1 | Gets or sets The dimse1 - 075
Dimse2 | Gets or sets The dimse2 - 076
Dimsoxd | Gets or sets The dimsoxd - 175
Dimtad | Gets or sets The dimtad - 077
Dimtdec | Gets or sets The dimtdec - 272
Dimtfac | Gets or sets The dimtfac - 146
Dimtih | Gets or sets The dimtih - 073
Dimtix | Gets or sets The dimtix - 174
Dimtm | Gets or sets The dimtm - 048
Dimtmove | Gets or sets The dimtmove - 279
Dimtofl | Gets or sets The dimtofl - 172
Dimtoh | Gets or sets The dimtoh - 074
Dimtol | Gets or sets The dimtol - 071
Dimtolj | Gets or sets The dimtolj - 283
Dimtp | Gets or sets The dimtp - 047
Dimtsz | Gets or sets The dimtsz -142
Dimtvp | Gets or sets The dimtvp - 145
Dimtxsty | Gets or sets The DIMTXSTY - 340
Dimtxt | Gets or sets The dimtxt - 140
Dimtzin | Gets or sets The dimtzin - 284
Dimunit | Gets or sets The dimunit 270
Dimupt | Gets or sets The dimupt - 288
Dimzin | Gets or sets The dimzin - 078
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
MaxTableEntriesCount (inherited from CadBaseTable) | Gets or sets the max table entries count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
StandardFlag | Gets or sets The standard flag - 070
StyleName | Gets or sets The style name - 002
TableName (inherited from CadBaseTable) | Gets or sets the name of the table.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadDimensionStyleTable Constructor

Initializes a new instance of the CadDimensionStyleTable class.

public CadDimensionStyleTable();

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadDimensionStyleTable Properties

The properties of the CadDimensionStyleTable class are listed below. For a complete list of CadDimensionStyleTable class members, see the CadDimensionStyleTable Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
Dimadec | Gets or sets The dimadec - 179
Dimalt | Gets or sets The dimalt - 170
Dimaltd | Gets or sets The dimaltd - 171
Dimaltf | Gets or sets The dimaltf -143
Dimaltrnd | Gets or sets The dimaltrnd - 148
Dimalttd | Gets or sets The dimalttd - 274
Dimalttz | Gets or sets The dimalttz - 286
Dimaltu | Gets or sets The dimaltu - 273
Dimaltz | Gets or sets The dimaltz - 285
Dimapost | Gets or sets The dimapost - 004
Dimasz | Gets or sets The dimasz - 041
Dimatfit | Gets or sets The dimatfit - 289
Dimaunit | Gets or sets The dimaunit -275
Dimazin | Gets or sets The dimazin 079
Dimblk | Gets or sets The dimblk - 342
Dimblk1 | Gets or sets The dimblk1 - 343
Dimblk2 | Gets or sets The dimblk2
Dimcen | Gets or sets The dimcen - 141
Dimclrd | Gets or sets The dimclrd - 176
Dimclre | Gets or sets The dimclre - 177
Dimclrt | Gets or sets The dimclrt - 178
Dimdec | Gets or sets The dimdec 271
Dimdle | Gets or sets The dimdle - 046
Dimdli | Gets or sets The dimdli - 043
Dimdsep | Gets or sets The dimdsep - 278
Dimexe | Gets or sets The dimexe - 044
Dimexo | Gets or sets The dimexo - 042
Dimfit | Gets or sets The dimfit - 287
Dimfrac | Gets or sets The dimfrac - 276
Dimgap | Gets or sets The dimgap - 147
Dimjust | Gets or sets The dimjust - 280
Dimldrblk | Gets or sets The dimldrblk - 341
Dimlfac | Gets or sets The dimlfac - 144
Dimlim | Gets or sets The dimlim - 072
Dimlunit | Gets or sets The dimlunit - 277
Dimlwd | Gets or sets The dimlwd - 371
Dimlwe | Gets or sets The dimlwe - 372
Dimpost | Gets or sets The dimpost - 003
Dimrnd | Gets or sets The dimrnd - 045
Dimsah | Gets or sets The dimsah - 173
Dimscale | Gets or sets The dimscale - 040
Dimsd1 | Gets or sets The dimsd1 - 281
Dimsd2 | Gets or sets The dimsd2 - 282
Dimse1 | Gets or sets The dimse1 - 075
Dimse2 | Gets or sets The dimse2 - 076
Dimsoxd | Gets or sets The dimsoxd - 175
Dimtad | Gets or sets The dimtad - 077
Dimtdec | Gets or sets The dimtdec - 272
Dimtfac | Gets or sets The dimtfac - 146
Dimtih | Gets or sets The dimtih - 073
Dimtix | Gets or sets The dimtix - 174
Dimtm | Gets or sets The dimtm - 048
Dimtmove | Gets or sets The dimtmove - 279
Dimtofl | Gets or sets The dimtofl - 172
Dimtoh | Gets or sets The dimtoh - 074
Dimtol | Gets or sets The dimtol - 071
Dimtolj | Gets or sets The dimtolj - 283
Dimtp | Gets or sets The dimtp - 047
Dimtsz | Gets or sets The dimtsz -142
Dimtvp | Gets or sets The dimtvp - 145
Dimtxsty | Gets or sets The DIMTXSTY - 340
Dimtxt | Gets or sets The dimtxt - 140
Dimtzin | Gets or sets The dimtzin - 284
Dimunit | Gets or sets The dimunit 270
Dimupt | Gets or sets The dimupt - 288
Dimzin | Gets or sets The dimzin - 078
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
MaxTableEntriesCount (inherited from CadBaseTable) | Gets or sets the max table entries count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
StandardFlag | Gets or sets The standard flag - 070
StyleName | Gets or sets The style name - 002
TableName (inherited from CadBaseTable) | Gets or sets the name of the table.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimadec Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimadec Property

Gets or sets The dimadec - 179

public short Dimadec {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimalt Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimalt Property

Gets or sets The dimalt - 170

public short Dimalt {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimaltd Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimaltd Property

Gets or sets The dimaltd - 171

public short Dimaltd {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimaltf Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimaltf Property

Gets or sets The dimaltf -143

public double Dimaltf {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimaltrnd Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimaltrnd Property

Gets or sets The dimaltrnd - 148

public double Dimaltrnd {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimalttd Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimalttd Property

Gets or sets The dimalttd - 274

public short Dimalttd {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimalttz Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimalttz Property

Gets or sets The dimalttz - 286

public short Dimalttz {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimaltu Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimaltu Property

Gets or sets The dimaltu - 273

public short Dimaltu {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimaltz Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimaltz Property

Gets or sets The dimaltz - 285

public short Dimaltz {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimapost Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimapost Property

Gets or sets The dimapost - 004

public string Dimapost {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimasz Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimasz Property

Gets or sets The dimasz - 041

public double Dimasz {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimatfit Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimatfit Property

Gets or sets The dimatfit - 289

public short Dimatfit {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimaunit Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimaunit Property

Gets or sets The dimaunit -275

public short Dimaunit {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimazin Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimazin Property

Gets or sets The dimazin 079

public short Dimazin {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimblk Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimblk Property

Gets or sets The dimblk - 342

public string Dimblk {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimblk1 Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimblk1 Property

Gets or sets The dimblk1 - 343

public string Dimblk1 {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimblk2 Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimblk2 Property

Gets or sets The dimblk2

public string Dimblk2 {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimcen Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimcen Property

Gets or sets The dimcen - 141

public double Dimcen {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimclrd Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimclrd Property

Gets or sets The dimclrd - 176

public short Dimclrd {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimclre Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimclre Property

Gets or sets The dimclre - 177

public short Dimclre {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimclrt Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimclrt Property

Gets or sets The dimclrt - 178

public short Dimclrt {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimdec Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimdec Property

Gets or sets The dimdec 271

public short Dimdec {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimdle Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimdle Property

Gets or sets The dimdle - 046

public double Dimdle {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimdli Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimdli Property

Gets or sets The dimdli - 043

public double Dimdli {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimdsep Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimdsep Property

Gets or sets The dimdsep - 278

public short Dimdsep {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimexe Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimexe Property

Gets or sets The dimexe - 044

public double Dimexe {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimexo Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimexo Property

Gets or sets The dimexo - 042

public double Dimexo {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimfit Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimfit Property

Gets or sets The dimfit - 287

public short Dimfit {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimfrac Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimfrac Property

Gets or sets The dimfrac - 276

public short Dimfrac {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimgap Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimgap Property

Gets or sets The dimgap - 147

public double Dimgap {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimjust Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimjust Property

Gets or sets The dimjust - 280

public short Dimjust {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimldrblk Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimldrblk Property

Gets or sets The dimldrblk - 341

public string Dimldrblk {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimlfac Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimlfac Property

Gets or sets The dimlfac - 144

public double Dimlfac {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimlim Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimlim Property

Gets or sets The dimlim - 072

public short Dimlim {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimlunit Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimlunit Property

Gets or sets The dimlunit - 277

public short Dimlunit {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimlwd Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimlwd Property

Gets or sets The dimlwd - 371

public short Dimlwd {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimlwe Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimlwe Property

Gets or sets The dimlwe - 372

public short Dimlwe {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimpost Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimpost Property

Gets or sets The dimpost - 003

public string Dimpost {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimrnd Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimrnd Property

Gets or sets The dimrnd - 045

public double Dimrnd {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimsah Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimsah Property

Gets or sets The dimsah - 173

public short Dimsah {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimscale Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimscale Property

Gets or sets The dimscale - 040

public double Dimscale {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimsd1 Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimsd1 Property

Gets or sets The dimsd1 - 281

public short Dimsd1 {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimsd2 Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimsd2 Property

Gets or sets The dimsd2 - 282

public short Dimsd2 {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimse1 Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimse1 Property

Gets or sets The dimse1 - 075

public short Dimse1 {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimse2 Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimse2 Property

Gets or sets The dimse2 - 076

public short Dimse2 {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimsoxd Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimsoxd Property

Gets or sets The dimsoxd - 175

public short Dimsoxd {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtad Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtad Property

Gets or sets The dimtad - 077

public short Dimtad {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtdec Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtdec Property

Gets or sets The dimtdec - 272

public short Dimtdec {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtfac Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtfac Property

Gets or sets The dimtfac - 146

public double Dimtfac {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtih Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtih Property

Gets or sets The dimtih - 073

public short Dimtih {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtix Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtix Property

Gets or sets The dimtix - 174

public short Dimtix {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtm Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtm Property

Gets or sets The dimtm - 048

public double Dimtm {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtmove Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtmove Property

Gets or sets The dimtmove - 279

public short Dimtmove {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtofl Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtofl Property

Gets or sets The dimtofl - 172

public short Dimtofl {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtoh Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtoh Property

Gets or sets The dimtoh - 074

public short Dimtoh {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtol Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtol Property

Gets or sets The dimtol - 071

public short Dimtol {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtolj Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtolj Property

Gets or sets The dimtolj - 283

public short Dimtolj {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtp Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtp Property

Gets or sets The dimtp - 047

public double Dimtp {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtsz Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtsz Property

Gets or sets The dimtsz -142

public double Dimtsz {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtvp Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtvp Property

Gets or sets The dimtvp - 145

public double Dimtvp {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtxsty Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtxsty Property

Gets or sets The DIMTXSTY - 340

public string Dimtxsty {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtxt Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtxt Property

Gets or sets The dimtxt - 140

public double Dimtxt {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimtzin Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimtzin Property

Gets or sets The dimtzin - 284

public short Dimtzin {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimunit Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimunit Property

Gets or sets The dimunit 270

public short Dimunit {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimupt Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimupt Property

Gets or sets The dimupt - 288

public short Dimupt {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Dimzin Property

Aspose.Imaging Documentation

CadDimensionStyleTable.Dimzin Property

Gets or sets The dimzin - 078

public short Dimzin {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


StandardFlag Property

Aspose.Imaging Documentation

CadDimensionStyleTable.StandardFlag Property

Gets or sets The standard flag - 070

public short StandardFlag {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


StyleName Property

Aspose.Imaging Documentation

CadDimensionStyleTable.StyleName Property

Gets or sets The style name - 002

public string StyleName {get; set;}

See Also

CadDimensionStyleTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadLayerTable Class

The Cad layer table.

For a list of all members of this type, see CadLayerTable Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseTable
Aspose.Imaging.FileFormats.Cad.CadTables.CadLayerTable

public class CadLayerTable : CadBaseTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadTables

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadLayerTable Members | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadLayerTable Members

CadLayerTable overview

Public Instance Constructors

CadLayerTable Constructor Initializes a new instance of the CadLayerTable class.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ColorId | Gets or sets the color id.
Flags | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LineTypeName | Gets or sets the line type name.
LineWeight | Gets or sets the line weight.
MaterialHanlde | Gets or sets the material hanlde.
MaxTableEntriesCount (inherited from CadBaseTable) | Gets or sets the max table entries count.
Name | Gets or sets the name.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotFlag | Gets or sets the plot flag.
PlotStyleHandle | Gets or sets the plot style handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
TableName (inherited from CadBaseTable) | Gets or sets the name of the table.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLayerTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadLayerTable Constructor

Initializes a new instance of the CadLayerTable class.

public CadLayerTable();

See Also

CadLayerTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadLayerTable Properties

The properties of the CadLayerTable class are listed below. For a complete list of CadLayerTable class members, see the CadLayerTable Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
ColorId | Gets or sets the color id.
Flags | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LineTypeName | Gets or sets the line type name.
LineWeight | Gets or sets the line weight.
MaterialHanlde | Gets or sets the material hanlde.
MaxTableEntriesCount (inherited from CadBaseTable) | Gets or sets the max table entries count.
Name | Gets or sets the name.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
PlotFlag | Gets or sets the plot flag.
PlotStyleHandle | Gets or sets the plot style handle.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
TableName (inherited from CadBaseTable) | Gets or sets the name of the table.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadLayerTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


ColorId Property

Aspose.Imaging Documentation

CadLayerTable.ColorId Property

Gets or sets the color id.

public short ColorId {get; set;}

See Also

CadLayerTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Flags Property

Aspose.Imaging Documentation

CadLayerTable.Flags Property

Gets or sets the flags.

public short Flags {get; set;}

See Also

CadLayerTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


LineTypeName Property

Aspose.Imaging Documentation

CadLayerTable.LineTypeName Property

Gets or sets the line type name.

public string LineTypeName {get; set;}

See Also

CadLayerTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


LineWeight Property

Aspose.Imaging Documentation

CadLayerTable.LineWeight Property

Gets or sets the line weight.

public short LineWeight {get; set;}

See Also

CadLayerTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


MaterialHanlde Property

Aspose.Imaging Documentation

CadLayerTable.MaterialHanlde Property

Gets or sets the material hanlde.

public string MaterialHanlde {get; set;}

See Also

CadLayerTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Name Property

Aspose.Imaging Documentation

CadLayerTable.Name Property

Gets or sets the name.

public string Name {get; set;}

See Also

CadLayerTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


PlotFlag Property

Aspose.Imaging Documentation

CadLayerTable.PlotFlag Property

Gets or sets the plot flag.

public bool PlotFlag {get; set;}

See Also

CadLayerTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


PlotStyleHandle Property

Aspose.Imaging Documentation

CadLayerTable.PlotStyleHandle Property

Gets or sets the plot style handle.

public string PlotStyleHandle {get; set;}

See Also

CadLayerTable Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadLineTypeTableObject Class

The Cad line type table object.

For a list of all members of this type, see CadLineTypeTableObject Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseTable
Aspose.Imaging.FileFormats.Cad.CadTables.CadLineTypeTableObject

public class CadLineTypeTableObject : CadBaseTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadTables

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadLineTypeTableObject Members | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadLineTypeTableObject Members

CadLineTypeTableObject overview

Public Instance Constructors

CadLineTypeTableObject Constructor Initializes a new instance of the CadLineTypeTableObject class.

Public Instance Properties

AlignmentCode | Gets or sets the alignment code.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
DashDotLength | Gets or sets the dash dot length.
Description | Gets or sets the description.
Flags | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LineTypeElement | Gets or sets the line type element.
MaxTableEntriesCount (inherited from CadBaseTable) | Gets or sets the max table entries count.
Name | Gets or sets the name.
NumberOfLinetypeElements | Gets or sets the number of linetype elements.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
OffsetX | Gets or sets the offset x.
OffsetY | Gets or sets the offset y.
PatternLength | Gets or sets the pattern length.
PropertyList (inherited from CadBase) | Gets or sets the property list.
RotationAngle | Gets or sets the rotation angle.
Scale | Gets or sets the scale.
ShapeNumber | Gets or sets the shape number.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
StyleReference | Gets or sets the style reference.
TableName (inherited from CadBaseTable) | Gets or sets the name of the table.
TextStrings | Gets or sets the text strings.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadLineTypeTableObject Constructor

Initializes a new instance of the CadLineTypeTableObject class.

public CadLineTypeTableObject();

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadLineTypeTableObject Properties

The properties of the CadLineTypeTableObject class are listed below. For a complete list of CadLineTypeTableObject class members, see the CadLineTypeTableObject Members topic.

Public Instance Properties

AlignmentCode | Gets or sets the alignment code.
ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
DashDotLength | Gets or sets the dash dot length.
Description | Gets or sets the description.
Flags | Gets or sets the flags.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LineTypeElement | Gets or sets the line type element.
MaxTableEntriesCount (inherited from CadBaseTable) | Gets or sets the max table entries count.
Name | Gets or sets the name.
NumberOfLinetypeElements | Gets or sets the number of linetype elements.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
OffsetX | Gets or sets the offset x.
OffsetY | Gets or sets the offset y.
PatternLength | Gets or sets the pattern length.
PropertyList (inherited from CadBase) | Gets or sets the property list.
RotationAngle | Gets or sets the rotation angle.
Scale | Gets or sets the scale.
ShapeNumber | Gets or sets the shape number.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
StyleReference | Gets or sets the style reference.
TableName (inherited from CadBaseTable) | Gets or sets the name of the table.
TextStrings | Gets or sets the text strings.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


AlignmentCode Property

Aspose.Imaging Documentation

CadLineTypeTableObject.AlignmentCode Property

Gets or sets the alignment code.

public short AlignmentCode {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


DashDotLength Property

Aspose.Imaging Documentation

CadLineTypeTableObject.DashDotLength Property

Gets or sets the dash dot length.

public CadDoubleParameter} DashDotLength {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Description Property

Aspose.Imaging Documentation

CadLineTypeTableObject.Description Property

Gets or sets the description.

public string Description {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Flags Property

Aspose.Imaging Documentation

CadLineTypeTableObject.Flags Property

Gets or sets the flags.

public short Flags {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


LineTypeElement Property

Aspose.Imaging Documentation

CadLineTypeTableObject.LineTypeElement Property

Gets or sets the line type element.

public CadShortParameter} LineTypeElement {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Name Property

Aspose.Imaging Documentation

CadLineTypeTableObject.Name Property

Gets or sets the name.

public string Name {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


NumberOfLinetypeElements Property

Aspose.Imaging Documentation

CadLineTypeTableObject.NumberOfLinetypeElements Property

Gets or sets the number of linetype elements.

public short NumberOfLinetypeElements {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


OffsetX Property

Aspose.Imaging Documentation

CadLineTypeTableObject.OffsetX Property

Gets or sets the offset x.

public CadDoubleParameter} OffsetX {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


OffsetY Property

Aspose.Imaging Documentation

CadLineTypeTableObject.OffsetY Property

Gets or sets the offset y.

public CadDoubleParameter} OffsetY {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


PatternLength Property

Aspose.Imaging Documentation

CadLineTypeTableObject.PatternLength Property

Gets or sets the pattern length.

public double PatternLength {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


RotationAngle Property

Aspose.Imaging Documentation

CadLineTypeTableObject.RotationAngle Property

Gets or sets the rotation angle.

public CadDoubleParameter} RotationAngle {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Scale Property

Aspose.Imaging Documentation

CadLineTypeTableObject.Scale Property

Gets or sets the scale.

public CadDoubleParameter} Scale {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


ShapeNumber Property

Aspose.Imaging Documentation

CadLineTypeTableObject.ShapeNumber Property

Gets or sets the shape number.

public CadShortParameter} ShapeNumber {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


StyleReference Property

Aspose.Imaging Documentation

CadLineTypeTableObject.StyleReference Property

Gets or sets the style reference.

public CadStringParameter} StyleReference {get; set;}

Property Value

The style reference.

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


TextStrings Property

Aspose.Imaging Documentation

CadLineTypeTableObject.TextStrings Property

Gets or sets the text strings.

public CadStringParameter} TextStrings {get; set;}

See Also

CadLineTypeTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadStyleTableObject Class

The Cad style table object.

For a list of all members of this type, see CadStyleTableObject Members.

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseTable
Aspose.Imaging.FileFormats.Cad.CadTables.CadStyleTableObject

public class CadStyleTableObject : CadBaseTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Cad.CadTables

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CadStyleTableObject Members | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadStyleTableObject Members

CadStyleTableObject overview

Public Instance Constructors

CadStyleTableObject Constructor Initializes a new instance of the CadStyleTableObject class. Prevents a default instance of the CadStyleTableObject class from being created.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BigFontName | Gets or sets the big font name.
FixedHeight | Gets or sets the fixed height.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LastHeight | Gets or sets the last height.
MaxTableEntriesCount (inherited from CadBaseTable) | Gets or sets the max table entries count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
ObliqueAngle | Gets or sets the oblique angle.
PrimaryFontName | Gets or sets the primary font name.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
StyleFlag | Gets or sets the style flag.
StyleName | Gets or sets the style name.
TableName (inherited from CadBaseTable) | Gets or sets the name of the table.
TextGenerationFlag | Gets or sets the text generation flag.
WidthFactor | Gets or sets the width factor.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble (inherited from CadBase) | Overloaded. Gets the double Value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt (inherited from CadBase) | Overloaded. Gets the int.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CadStyleTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadStyleTableObject Constructor

Initializes a new instance of the CadStyleTableObject class. Prevents a default instance of the CadStyleTableObject class from being created.

public CadStyleTableObject();

See Also

CadStyleTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


CadStyleTableObject Properties

The properties of the CadStyleTableObject class are listed below. For a complete list of CadStyleTableObject class members, see the CadStyleTableObject Members topic.

Public Instance Properties

ApplicationCodesContainer (inherited from CadBase) | Gets or sets the application defined codes container.
AttributeOrder (inherited from CadBase) | Gets or sets the attribute order.
BigFontName | Gets or sets the big font name.
FixedHeight | Gets or sets the fixed height.
HardOwner (inherited from CadBaseOwned) | Gets or sets the hard owner.
LastHeight | Gets or sets the last height.
MaxTableEntriesCount (inherited from CadBaseTable) | Gets or sets the max table entries count.
ObjectHandle (inherited from CadBase) | Gets or sets the object handle.
ObliqueAngle | Gets or sets the oblique angle.
PrimaryFontName | Gets or sets the primary font name.
PropertyList (inherited from CadBase) | Gets or sets the property list.
ShapeObject (inherited from CadBase) | Gets or sets the shape object.
SoftOwner (inherited from CadBaseOwned) | Gets or sets the soft owner.
StyleFlag | Gets or sets the style flag.
StyleName | Gets or sets the style name.
TableName (inherited from CadBaseTable) | Gets or sets the name of the table.
TextGenerationFlag | Gets or sets the text generation flag.
WidthFactor | Gets or sets the width factor.
XdataContainer (inherited from CadBase) | Gets or sets the xdata container.

See Also

CadStyleTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


BigFontName Property

Aspose.Imaging Documentation

CadStyleTableObject.BigFontName Property

Gets or sets the big font name.

public string BigFontName {get; set;}

See Also

CadStyleTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


FixedHeight Property

Aspose.Imaging Documentation

CadStyleTableObject.FixedHeight Property

Gets or sets the fixed height.

public double FixedHeight {get; set;}

See Also

CadStyleTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


LastHeight Property

Aspose.Imaging Documentation

CadStyleTableObject.LastHeight Property

Gets or sets the last height.

public double LastHeight {get; set;}

See Also

CadStyleTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


ObliqueAngle Property

Aspose.Imaging Documentation

CadStyleTableObject.ObliqueAngle Property

Gets or sets the oblique angle.

public double ObliqueAngle {get; set;}

See Also

CadStyleTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


PrimaryFontName Property

Aspose.Imaging Documentation

CadStyleTableObject.PrimaryFontName Property

Gets or sets the primary font name.

public string PrimaryFontName {get; set;}

See Also

CadStyleTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


StyleFlag Property

Aspose.Imaging Documentation

CadStyleTableObject.StyleFlag Property

Gets or sets the style flag.

public short StyleFlag {get; set;}

See Also

CadStyleTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


StyleName Property

Aspose.Imaging Documentation

CadStyleTableObject.StyleName Property

Gets or sets the style name.

public string StyleName {get; set;}

See Also

CadStyleTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


TextGenerationFlag Property

Aspose.Imaging Documentation

CadStyleTableObject.TextGenerationFlag Property

Gets or sets the text generation flag.

public short TextGenerationFlag {get; set;}

See Also

CadStyleTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


WidthFactor Property

Aspose.Imaging Documentation

CadStyleTableObject.WidthFactor Property

Gets or sets the width factor.

public double WidthFactor {get; set;}

See Also

CadStyleTableObject Class | Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Aspose.Imaging.FileFormats.Gif

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Gif Namespace

Namespace hierarchy

Classes

Class | Description
GifBlock | The default gif block implementation.
GifBlocksRegistry | Represents the gif blocks openers registry.
GifImage | A gif image.

Interfaces

Interface | Description
IGifBlock | Represents GIF block interface.
IGifBlockLoaderDescriptor | Gif block Loader descriptor.

Enumerations

Enumeration | Description
DisposalMethod | Indicates the way in which the graphic is to be treated after being displayed.


DisposalMethod Enumeration

Indicates the way in which the graphic is to be treated after being displayed.

public enum DisposalMethod

Members

Member Name | Description | Value
None | No disposal specified. | 0
Preserve | Do not dispose. The graphic is to be left in place. | 1
Restore | Restore to background color. The area used by the graphic must be restored to the background color. | 2
Previuos | Restore to previous. The decoder is required to restore the area overwritten by the graphic with what was there prior to rendering the graphic. | 3
Undefined | Undefined value. | 4

Requirements

Namespace: Aspose.Imaging.FileFormats.Gif

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Gif Namespace


GifBlock Class

The default gif block implementation.

For a list of all members of this type, see GifBlock Members.

System.Object
Aspose.Imaging.FileFormats.Gif.GifBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifApplicationExtensionBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifCommentBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifGraphicsControlBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifPlainTextRenderingBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifUnknownExtensionBlock

public abstract class GifBlock : IGifBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Gif

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GifBlock Members | Aspose.Imaging.FileFormats.Gif Namespace


GifBlock Members

GifBlock overview

Public Instance Properties

IsChanged Gets or sets a value indicating whether block has changed and requires save.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

GifBlock Constructor Initializes a new instance of the GifBlock class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifBlock Class | Aspose.Imaging.FileFormats.Gif Namespace


GifBlock Constructor

Initializes a new instance of the GifBlock class.

protected GifBlock();

See Also

GifBlock Class | Aspose.Imaging.FileFormats.Gif Namespace


GifBlock Properties

The properties of the GifBlock class are listed below. For a complete list of GifBlock class members, see the GifBlock Members topic.

Public Instance Properties

IsChanged Gets or sets a value indicating whether block has changed and requires save.

See Also

GifBlock Class | Aspose.Imaging.FileFormats.Gif Namespace


IsChanged Property

Aspose.Imaging Documentation

GifBlock.IsChanged Property

Gets or sets a value indicating whether block has changed and requires save.

public bool IsChanged {get; set;}

Property Value

true if block has changed; otherwise, false.

See Also

GifBlock Class | Aspose.Imaging.FileFormats.Gif Namespace


GifBlock Methods

The methods of the GifBlock class are listed below. For a complete list of GifBlock class members, see the GifBlock Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifBlock Class | Aspose.Imaging.FileFormats.Gif Namespace


GifBlock.Save Method

Saves the block to the specified stream.

public abstract void Save(
Stream stream
);

Parameters

stream
The stream to save data to.

Implements

IGifBlock.Save

See Also

GifBlock Class | Aspose.Imaging.FileFormats.Gif Namespace


GifBlocksRegistry Class

Represents the gif blocks openers registry.

For a list of all members of this type, see GifBlocksRegistry Members.

System.Object
Aspose.Imaging.FileFormats.Gif.GifBlocksRegistry

public abstract sealed class GifBlocksRegistry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Gif

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GifBlocksRegistry Members | Aspose.Imaging.FileFormats.Gif Namespace


GifBlocksRegistry Members

GifBlocksRegistry overview

Public Static Properties

RegisteredDescriptors Gets the registered descriptors.

Public Static Methods

GetFirstSupportedDescriptor | Gets the first supported opener descriptor.
GetFirstSupportedDescriptorByTypeName | Gets the first supported descriptor by its type name.
LoadBlockByFirstSupportedDescriptor | Loads gif block using first found opener suitable for the specified stream.
RegisterOpener | Registers the opener.
UnregisterOpener | Unregisters the opener.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GifBlocksRegistry Class | Aspose.Imaging.FileFormats.Gif Namespace


GifBlocksRegistry Properties

The properties of the GifBlocksRegistry class are listed below. For a complete list of GifBlocksRegistry class members, see the GifBlocksRegistry Members topic.

Public Static Properties

RegisteredDescriptors Gets the registered descriptors.

See Also

GifBlocksRegistry Class | Aspose.Imaging.FileFormats.Gif Namespace


RegisteredDescriptors Property

Aspose.Imaging Documentation

GifBlocksRegistry.RegisteredDescriptors Property

Gets the registered descriptors.

public static IGifBlockLoaderDescriptor[] RegisteredDescriptors {get;}

Property Value

The registered descriptors.

See Also

GifBlocksRegistry Class | Aspose.Imaging.FileFormats.Gif Namespace


GifBlocksRegistry Methods

The methods of the GifBlocksRegistry class are listed below. For a complete list of GifBlocksRegistry class members, see the GifBlocksRegistry Members topic.

Public Static Methods

GetFirstSupportedDescriptor | Gets the first supported opener descriptor.
GetFirstSupportedDescriptorByTypeName | Gets the first supported descriptor by its type name.
LoadBlockByFirstSupportedDescriptor | Loads gif block using first found opener suitable for the specified stream.
RegisterOpener | Registers the opener.
UnregisterOpener | Unregisters the opener.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GifBlocksRegistry Class | Aspose.Imaging.FileFormats.Gif Namespace


GifBlocksRegistry.GetFirstSupportedDescriptor Method

Gets the first supported opener descriptor.

public static IGifBlockLoaderDescriptor GetFirstSupportedDescriptor(
Stream stream
);

Parameters

stream
The stream.

Return Value

The gif block opener descriptor or null if no opener descriptor supported for such stream.

Remarks

The first opener will be actually the last registered.

See Also

GifBlocksRegistry Class | Aspose.Imaging.FileFormats.Gif Namespace


GifBlocksRegistry.GetFirstSupportedDescriptorByTypeName Method

Gets the first supported descriptor by its type name.

public static IGifBlockLoaderDescriptor GetFirstSupportedDescriptorByTypeName(
string descriptorTypeName
);

Parameters

descriptorTypeName
The descriptor type name.

Return Value

The first found opener descriptor or null if not such descriptor is found.

Remarks

The first opener descriptor will be actually the last registered.

See Also

GifBlocksRegistry Class | Aspose.Imaging.FileFormats.Gif Namespace


GifBlocksRegistry.LoadBlockByFirstSupportedDescriptor Method

Loads gif block using first found opener suitable for the specified stream.

public static IGifBlock LoadBlockByFirstSupportedDescriptor(
Stream stream,
IColorPalette containerPalette
);

Parameters

stream
The stream.
containerPalette
The container palette.

Return Value

The loaded gif block or null if no opener is found.

Remarks

The first opener will be actually the last registered.

See Also

GifBlocksRegistry Class | Aspose.Imaging.FileFormats.Gif Namespace


GifBlocksRegistry.RegisterOpener Method

Registers the opener.

public static void RegisterOpener(
IGifBlockLoaderDescriptor openerDescriptor
);

Parameters

openerDescriptor
The opener descriptor to register.

See Also

GifBlocksRegistry Class | Aspose.Imaging.FileFormats.Gif Namespace


GifBlocksRegistry.UnregisterOpener Method

Unregisters the opener.

public static void UnregisterOpener(
IGifBlockLoaderDescriptor openerDescriptor
);

Parameters

openerDescriptor
The opener descriptor to unregister.

See Also

GifBlocksRegistry Class | Aspose.Imaging.FileFormats.Gif Namespace


GifImage Class

A gif image.

For a list of all members of this type, see GifImage Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image
Aspose.Imaging.RasterImage
Aspose.Imaging.FileFormats.Gif.GifImage

public sealed class GifImage : RasterImage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Gif

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GifImage Members | Aspose.Imaging.FileFormats.Gif Namespace


GifImage Members

GifImage overview

Public Instance Constructors

GifImage Overloaded. Initializes a new instance of the GifImage class.

Public Instance Properties

ActiveFrame | Gets or sets the active frame.
BackgroundColor | Gets or sets the background color.
BackgroundColorIndex | Gets or sets the background color index.
BitsPerPixel | Gets the bits per pixel count.
Blocks | Gets the GIF blocks.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings | Gets or sets the dithering settings for each block.
HasTrailer | Gets or sets a value indicating whether GIF has trailer.
Height | Gets the object height.
HorizontalResolution (inherited from RasterImage) | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
IsCached | Gets a value indicating whether object's data is cached currently and no data reading is required.
IsPaletteSorted | Gets or sets a value indicating whether palette is sorted.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
PaletteColorResolutionBits | Gets or sets the palette color resolution bits.
PixelAspectRatio | Gets or sets the pixel aspect ratio.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution (inherited from RasterImage) | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width | Gets the object width.

Public Instance Methods

AddBlock | Adds a new GIF block.
CacheData | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
ClearBlocks | Clears all the GIF blocks.
Crop | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
OrderBlocks | Orders the GIF blocks according to the GIF specification. Some GifGraphicsControlBlock may be removed for proper GIF layout.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
RemoveBlock | Removes the GIF block.
Resize | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
ResizeProportional | Performs proportional resize on the image. The proportional resize will resize each frame according to the ratio of newWidth/width and newHeight/height.
RotateFlip | Rotates, flips, or rotates and flips the image.
RotateFlipAll | Rotates the flip all frames in the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution (inherited from RasterImage) | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


GifImage Constructor

Initializes a new instance of the GifImage class.

Overload List

Initializes a new instance of the GifImage class.

public GifImage(GifFrameBlock);

Initializes a new instance of the GifImage class.

public GifImage(GifFrameBlock,IColorPalette);

Initializes a new instance of the GifImage class.

public GifImage(GifFrameBlock,IColorPalette,bool,byte,byte,byte,bool);

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


GifImage Constructor (GifFrameBlock, IColorPalette)

Initializes a new instance of the GifImage class.

public GifImage(
GifFrameBlock firstFrame,
IColorPalette globalPalette
);

Parameters

firstFrame
The first frame to initialize gif image with.
globalPalette
The global palette to use. Note if both firstFrame and globalPalette are null then default global palette is used.

Exceptions

Exception Type | Condition
ArgumentNullException | The frame cannot be null;firstFrame
ArgumentException | The first frame already belongs to some other image. Check the Container property.;firstFrame
GifImageException | The palette specified should contain entries count equal to power of 2. Minimal palette size is 2, maximal is 256.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace | GifImage Constructor Overload List


GifImage Constructor (GifFrameBlock)

Initializes a new instance of the GifImage class.

public GifImage(
GifFrameBlock firstFrame
);

Parameters

firstFrame
The first frame to initialize gif image with.

Exceptions

Exception Type | Condition
ArgumentNullException | The frame cannot be null;firstFrame
ArgumentException | The first frame already belongs to some other image. Check the Container property.;firstFrame
GifImageException | The palette specified should contain entries count equal to power of 2. Minimal palette size is 2, maximal is 256.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace | GifImage Constructor Overload List


GifImage Constructor (GifFrameBlock, IColorPalette, Boolean, Byte, Byte, Byte, Boolean)

Initializes a new instance of the GifImage class.

public GifImage(
GifFrameBlock firstFrame,
IColorPalette globalPalette,
bool isPaletteSorted,
byte paletteColorResolution,
byte paletteBackgroundColorIndex,
byte aspectRatio,
bool hasTrailer
);

Parameters

firstFrame
The first frame to initialize gif image with.
globalPalette
The global palette to use. Note if both firstFrame and globalPalette are null then default global palette is used.
isPaletteSorted
if set to true the palette is sorted. Note the parameter is used when globalPalette is not null.
paletteColorResolution
The palette color resolution. Note the parameter is used when globalPalette is not null.
paletteBackgroundColorIndex
The palette background color index.
aspectRatio
The aspect ratio.
hasTrailer
if set to true the gif image has trailer otherwise no trailer written at the end of the stream.

Exceptions

Exception Type | Condition
ArgumentNullException | The frame cannot be null;firstFrame
ArgumentException | The first frame already belongs to some other image. Check the Container property.;firstFrame
GifImageException | The palette specified should contain entries count equal to power of 2. Minimal palette size is 2, maximal is 256.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace | GifImage Constructor Overload List


GifImage Properties

The properties of the GifImage class are listed below. For a complete list of GifImage class members, see the GifImage Members topic.

Public Instance Properties

ActiveFrame | Gets or sets the active frame.
BackgroundColor | Gets or sets the background color.
BackgroundColorIndex | Gets or sets the background color index.
BitsPerPixel | Gets the bits per pixel count.
Blocks | Gets the GIF blocks.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings | Gets or sets the dithering settings for each block.
HasTrailer | Gets or sets a value indicating whether GIF has trailer.
Height | Gets the object height.
HorizontalResolution (inherited from RasterImage) | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
IsCached | Gets a value indicating whether object's data is cached currently and no data reading is required.
IsPaletteSorted | Gets or sets a value indicating whether palette is sorted.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
PaletteColorResolutionBits | Gets or sets the palette color resolution bits.
PixelAspectRatio | Gets or sets the pixel aspect ratio.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution (inherited from RasterImage) | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width | Gets the object width.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


ActiveFrame Property

Aspose.Imaging Documentation

GifImage.ActiveFrame Property

Gets or sets the active frame.

public GifFrameBlock ActiveFrame {get; set;}

Property Value

The active frame.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


BackgroundColor Property

Aspose.Imaging Documentation

GifImage.BackgroundColor Property

Gets or sets the background color.

public Color BackgroundColor {get; set;}

Property Value

The background color.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


BackgroundColorIndex Property

Aspose.Imaging Documentation

GifImage.BackgroundColorIndex Property

Gets or sets the background color index.

public byte BackgroundColorIndex {get; set;}

Property Value

The background color index.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

GifImage.BitsPerPixel Property

Gets the bits per pixel count.

public override int BitsPerPixel {get;}

Property Value

The bits per pixel count.

Remarks

For GIF this value is calculated from active frame.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


Blocks Property

Aspose.Imaging Documentation

GifImage.Blocks Property

Gets the GIF blocks.

public IGifBlock[] Blocks {get;}

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


DitheringSettings Property

Aspose.Imaging Documentation

GifImage.DitheringSettings Property

Gets or sets the dithering settings for each block.

public override DitheringMode DitheringSettings {get; set;}

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


HasTrailer Property

Aspose.Imaging Documentation

GifImage.HasTrailer Property

Gets or sets a value indicating whether GIF has trailer.

public bool HasTrailer {get; set;}

Property Value

true if GIF has trailer; otherwise, false.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


Height Property

Aspose.Imaging Documentation

GifImage.Height Property

Gets the object height.

public override int Height {get;}

Property Value

The object height.

Implements

IObjectWithBounds.Height

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


IsCached Property

Aspose.Imaging Documentation

GifImage.IsCached Property

Gets a value indicating whether object's data is cached currently and no data reading is required.

public bool IsCached {get;}

Property Value

true if object's data is cached; otherwise, false.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


IsPaletteSorted Property

Aspose.Imaging Documentation

GifImage.IsPaletteSorted Property

Gets or sets a value indicating whether palette is sorted.

public bool IsPaletteSorted {get; set;}

Property Value

true if palette is sorted; otherwise, false.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


PaletteColorResolutionBits Property

Aspose.Imaging Documentation

GifImage.PaletteColorResolutionBits Property

Gets or sets the palette color resolution bits.

public byte PaletteColorResolutionBits {get; set;}

Property Value

The palette color resolution bits.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


PixelAspectRatio Property

Aspose.Imaging Documentation

GifImage.PixelAspectRatio Property

Gets or sets the pixel aspect ratio.

public byte PixelAspectRatio {get; set;}

Property Value

The pixel aspect ratio.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


Width Property

Aspose.Imaging Documentation

GifImage.Width Property

Gets the object width.

public override int Width {get;}

Property Value

The object width.

Implements

IObjectWithBounds.Width

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


GifImage Methods

The methods of the GifImage class are listed below. For a complete list of GifImage class members, see the GifImage Members topic.

Public Instance Methods

AddBlock | Adds a new GIF block.
CacheData | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
ClearBlocks | Clears all the GIF blocks.
Crop | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
OrderBlocks | Orders the GIF blocks according to the GIF specification. Some GifGraphicsControlBlock may be removed for proper GIF layout.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
RemoveBlock | Removes the GIF block.
Resize | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
ResizeProportional | Performs proportional resize on the image. The proportional resize will resize each frame according to the ratio of newWidth/width and newHeight/height.
RotateFlip | Rotates, flips, or rotates and flips the image.
RotateFlipAll | Rotates the flip all frames in the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution (inherited from RasterImage) | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


GifImage.AddBlock Method

Adds a new GIF block.

public void AddBlock(
IGifBlock block
);

Parameters

block
The GIF block to add.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


GifImage.CacheData Method

Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.

public void CacheData();

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


GifImage.ClearBlocks Method

Clears all the GIF blocks.

public void ClearBlocks();

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


Crop Method

Aspose.Imaging Documentation

GifImage.Crop Method

Cropping the image.

Overload List

Cropping the image.

public override void Crop(Rectangle);

Inherited from RasterImage.

public virtual void Crop(int,int,int,int);

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


GifImage.Crop Method (Rectangle)

Cropping the image.

public override void Crop(
Rectangle rectangle
);

Parameters

rectangle
The rectangle.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace | GifImage.Crop Overload List


GifImage.OrderBlocks Method

Orders the GIF blocks according to the GIF specification. Some GifGraphicsControlBlock may be removed for proper GIF layout.

public void OrderBlocks();

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


GifImage.RemoveBlock Method

Removes the GIF block.

public void RemoveBlock(
IGifBlock block
);

Parameters

block
The block to remove.

Remarks

Note: do not forget to Dispose the block if you will not add it to some other GifImage.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


Resize Method

Aspose.Imaging Documentation

GifImage.Resize Method

Resizes the image.

Overload List

Inherited from Image.

public void Resize(int,int);

Resizes the image.

public override void Resize(int,int,ResizeType);

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


GifImage.Resize Method (Int32, Int32, ResizeType)

Resizes the image.

public override void Resize(
int newWidth,
int newHeight,
ResizeType resizeType
);

Parameters

newWidth
The new width.
newHeight
The new height.
resizeType
The resize type.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace | GifImage.Resize Overload List


GifImage.ResizeProportional Method

Performs proportional resize on the image. The proportional resize will resize each frame according to the ratio of newWidth/width and newHeight/height.

public void ResizeProportional(
int newWidth,
int newHeight,
ResizeType resizeType
);

Parameters

newWidth
The new width.
newHeight
The new height.
resizeType
The resize type.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


GifImage.RotateFlip Method

Rotates, flips, or rotates and flips the image.

public override void RotateFlip(
RotateFlipType rotateFlipType
);

Parameters

rotateFlipType
The rotate flip type.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


GifImage.RotateFlipAll Method

Rotates the flip all frames in the image.

public void RotateFlipAll(
RotateFlipType rotateFlip
);

Parameters

rotateFlip
The rotate flip type to perform.

See Also

GifImage Class | Aspose.Imaging.FileFormats.Gif Namespace


IGifBlock Interface

Represents GIF block interface.

For a list of all members of this type, see IGifBlock Members.

public interface IGifBlock

Types that implement IGifBlock

Type | Description
GifApplicationExtensionBlock | Gif application extension block.
GifCommentBlock | Gif comment block.
GifFrameBlock | Gif frame block.
GifGraphicsControlBlock | Gif graphics control block.
GifPlainTextRenderingBlock | Gif plain text extension block. The plain text extension contains textual data and the parameters necessary to render that data as a graphic, in a simple form.
GifUnknownExtensionBlock | Gif Unknown Extension Block.
GifBlock | The default gif block implementation.

Requirements

Namespace: Aspose.Imaging.FileFormats.Gif

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IGifBlock Members | Aspose.Imaging.FileFormats.Gif Namespace


IGifBlock Members

IGifBlock overview

Public Instance Methods

Save Saves the block to the specified stream.

See Also

IGifBlock Interface | Aspose.Imaging.FileFormats.Gif Namespace


IGifBlock Methods

The methods of the IGifBlock interface are listed below. For a complete list of IGifBlock interface members, see the IGifBlock Members topic.

Public Instance Methods

Save Saves the block to the specified stream.

See Also

IGifBlock Interface | Aspose.Imaging.FileFormats.Gif Namespace


IGifBlock.Save Method

Saves the block to the specified stream.

void Save(
Stream stream
);

Parameters

stream
The stream to save data to.

See Also

IGifBlock Interface | Aspose.Imaging.FileFormats.Gif Namespace


IGifBlockLoaderDescriptor Interface

Gif block Loader descriptor.

For a list of all members of this type, see IGifBlockLoaderDescriptor Members.

public interface IGifBlockLoaderDescriptor

Requirements

Namespace: Aspose.Imaging.FileFormats.Gif

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IGifBlockLoaderDescriptor Members | Aspose.Imaging.FileFormats.Gif Namespace


IGifBlockLoaderDescriptor Members

IGifBlockLoaderDescriptor overview

Public Instance Methods

CanLoad | Determines whether loader can load the specified data.
Load | Loads the gif block.

See Also

IGifBlockLoaderDescriptor Interface | Aspose.Imaging.FileFormats.Gif Namespace


IGifBlockLoaderDescriptor Methods

The methods of the IGifBlockLoaderDescriptor interface are listed below. For a complete list of IGifBlockLoaderDescriptor interface members, see the IGifBlockLoaderDescriptor Members topic.

Public Instance Methods

CanLoad | Determines whether loader can load the specified data.
Load | Loads the gif block.

See Also

IGifBlockLoaderDescriptor Interface | Aspose.Imaging.FileFormats.Gif Namespace


IGifBlockLoaderDescriptor.CanLoad Method

Determines whether loader can load the specified data.

bool CanLoad(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container to load data from.

Return Value

true loader can load the specified data; otherwise, false.

See Also

IGifBlockLoaderDescriptor Interface | Aspose.Imaging.FileFormats.Gif Namespace


IGifBlockLoaderDescriptor.Load Method

Loads the gif block.

IGifBlock Load(
StreamContainer streamContainer,
IColorPalette containerPalette
);

Parameters

streamContainer
The stream container.
containerPalette
The container palette.

Return Value

A new gif block.

See Also

IGifBlockLoaderDescriptor Interface | Aspose.Imaging.FileFormats.Gif Namespace


Aspose.Imaging.FileFormats.Gif.Blocks

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Gif.Blocks Namespace

Namespace hierarchy

Classes

Class | Description
GifApplicationExtensionBlock | Gif application extension block.
GifCommentBlock | Gif comment block.
GifFrameBlock | Gif frame block.
GifGraphicsControlBlock | Gif graphics control block.
GifPlainTextRenderingBlock | Gif plain text extension block. The plain text extension contains textual data and the parameters necessary to render that data as a graphic, in a simple form.
GifUnknownExtensionBlock | Gif Unknown Extension Block.


GifApplicationExtensionBlock Class

Gif application extension block.

For a list of all members of this type, see GifApplicationExtensionBlock Members.

System.Object
Aspose.Imaging.FileFormats.Gif.GifBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifApplicationExtensionBlock

public class GifApplicationExtensionBlock : GifBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Gif.Blocks

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GifApplicationExtensionBlock Members | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifApplicationExtensionBlock Members

GifApplicationExtensionBlock overview

Public Instance Constructors

GifApplicationExtensionBlock Overloaded. Initializes a new instance of the GifApplicationExtensionBlock class.

Public Instance Properties

ApplicationAuthenticationCode | Gets or sets the application authentication code.
ApplicationData | Gets or sets the application data.
ApplicationIdentifier | Gets or sets the application identifier.
IsChanged (inherited from GifBlock) | Gets or sets a value indicating whether block has changed and requires save.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifApplicationExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifApplicationExtensionBlock Constructor

Initializes a new instance of the GifApplicationExtensionBlock class.

Overload List

Initializes a new instance of the GifApplicationExtensionBlock class.

public GifApplicationExtensionBlock();

Initializes a new instance of the GifApplicationExtensionBlock class.

public GifApplicationExtensionBlock(string,byte[],byte[]);

See Also

GifApplicationExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifApplicationExtensionBlock Constructor ()

Initializes a new instance of the GifApplicationExtensionBlock class.

public GifApplicationExtensionBlock();

See Also

GifApplicationExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifApplicationExtensionBlock Constructor Overload List


GifApplicationExtensionBlock Constructor (String, Byte[], Byte[])

Initializes a new instance of the GifApplicationExtensionBlock class.

public GifApplicationExtensionBlock(
string applicationIdentifier,
byte[] applicationAuthenticationCode,
byte[] applicationData
);

Parameters

applicationIdentifier
The application identifier.
applicationAuthenticationCode
The application authentication code.
applicationData
The application data.

See Also

GifApplicationExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifApplicationExtensionBlock Constructor Overload List


GifApplicationExtensionBlock Properties

The properties of the GifApplicationExtensionBlock class are listed below. For a complete list of GifApplicationExtensionBlock class members, see the GifApplicationExtensionBlock Members topic.

Public Instance Properties

ApplicationAuthenticationCode | Gets or sets the application authentication code.
ApplicationData | Gets or sets the application data.
ApplicationIdentifier | Gets or sets the application identifier.
IsChanged (inherited from GifBlock) | Gets or sets a value indicating whether block has changed and requires save.

See Also

GifApplicationExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


ApplicationAuthenticationCode Property

Aspose.Imaging Documentation

GifApplicationExtensionBlock.ApplicationAuthenticationCode Property

Gets or sets the application authentication code.

public byte[] ApplicationAuthenticationCode {get; set;}

Property Value

The application authentication code.

See Also

GifApplicationExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


ApplicationData Property

Aspose.Imaging Documentation

GifApplicationExtensionBlock.ApplicationData Property

Gets or sets the application data.

public byte[] ApplicationData {get; set;}

Property Value

The application data.

See Also

GifApplicationExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


ApplicationIdentifier Property

Aspose.Imaging Documentation

GifApplicationExtensionBlock.ApplicationIdentifier Property

Gets or sets the application identifier.

public string ApplicationIdentifier {get; set;}

Property Value

The application identifier.

See Also

GifApplicationExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifApplicationExtensionBlock Methods

The methods of the GifApplicationExtensionBlock class are listed below. For a complete list of GifApplicationExtensionBlock class members, see the GifApplicationExtensionBlock Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifApplicationExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifApplicationExtensionBlock.Save Method

Saves the block to the specified stream.

public override void Save(
Stream stream
);

Parameters

stream
The stream to save data to.

Implements

IGifBlock.Save

See Also

GifApplicationExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifCommentBlock Class

Gif comment block.

For a list of all members of this type, see GifCommentBlock Members.

System.Object
Aspose.Imaging.FileFormats.Gif.GifBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifCommentBlock

public class GifCommentBlock : GifBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Gif.Blocks

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GifCommentBlock Members | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifCommentBlock Members

GifCommentBlock overview

Public Instance Constructors

GifCommentBlock Overloaded. Initializes a new instance of the GifCommentBlock class.

Public Instance Properties

Comment | Gets or sets the comment. Note that comment must use ASCII encoding and will be stored accordingly.
IsChanged (inherited from GifBlock) | Gets or sets a value indicating whether block has changed and requires save.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifCommentBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifCommentBlock Constructor

Initializes a new instance of the GifCommentBlock class.

Overload List

Initializes a new instance of the GifCommentBlock class.

public GifCommentBlock();

Initializes a new instance of the GifCommentBlock class.

public GifCommentBlock(string);

See Also

GifCommentBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifCommentBlock Constructor ()

Initializes a new instance of the GifCommentBlock class.

public GifCommentBlock();

See Also

GifCommentBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifCommentBlock Constructor Overload List


GifCommentBlock Constructor (String)

Initializes a new instance of the GifCommentBlock class.

public GifCommentBlock(
string comment
);

Parameters

comment
The comment.

See Also

GifCommentBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifCommentBlock Constructor Overload List


GifCommentBlock Properties

The properties of the GifCommentBlock class are listed below. For a complete list of GifCommentBlock class members, see the GifCommentBlock Members topic.

Public Instance Properties

Comment | Gets or sets the comment. Note that comment must use ASCII encoding and will be stored accordingly.
IsChanged (inherited from GifBlock) | Gets or sets a value indicating whether block has changed and requires save.

See Also

GifCommentBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


Comment Property

Aspose.Imaging Documentation

GifCommentBlock.Comment Property

Gets or sets the comment. Note that comment must use ASCII encoding and will be stored accordingly.

public string Comment {get; set;}

Property Value

The comment.

See Also

GifCommentBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifCommentBlock Methods

The methods of the GifCommentBlock class are listed below. For a complete list of GifCommentBlock class members, see the GifCommentBlock Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifCommentBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifCommentBlock.Save Method

Saves the block to the specified stream.

public override void Save(
Stream stream
);

Parameters

stream
The stream to save data to.

Implements

IGifBlock.Save

See Also

GifCommentBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifFrameBlock Class

Gif frame block.

For a list of all members of this type, see GifFrameBlock Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image
Aspose.Imaging.RasterImage
Aspose.Imaging.RasterCachedImage
Aspose.Imaging.FileFormats.Gif.Blocks.GifFrameBlock

public sealed class GifFrameBlock : RasterCachedImage, IGifBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Gif.Blocks

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GifFrameBlock Members | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifFrameBlock Members

GifFrameBlock overview

Public Static Methods

CreateFlags | Creates the flags.
GetColorPalette | Gets the associated color palette.

Public Instance Constructors

GifFrameBlock Overloaded. Initializes a new instance of the GifFrameBlock class.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
ControlBlock | Gets the graphics control block associated with this block.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
Flags | Gets or sets the flags.
GifFrameBitsPerPixel | Gets or sets the GIF frame bits per pixel.
Height | Gets the image height.
HorizontalResolution (inherited from RasterImage) | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
Interlaced | Gets or sets a value indicating whether this GifFrameBlock is interlaced.
IsCached (inherited from RasterCachedImage) | Gets a value indicating whether image data is cached currently.
IsPaletteSorted | Gets or sets a value indicating whether color palette is sorted.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Left | Gets or sets the left image location.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
Top | Gets or sets the top image location.
VerticalResolution (inherited from RasterImage) | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width | Gets the image width.

Public Instance Methods

CacheData (inherited from RasterCachedImage) | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop (inherited from RasterCachedImage) | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
Resize (inherited from RasterCachedImage) | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip (inherited from RasterCachedImage) | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution (inherited from RasterImage) | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifFrameBlock Constructor

Initializes a new instance of the GifFrameBlock class.

Overload List

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(RasterImage);

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(RasterImage,ushort,ushort);

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(RasterImage,ushort,ushort,bool,bool,byte);

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(Stream);

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(Stream,ushort,ushort);

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(Stream,ushort,ushort,bool,bool,byte);

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(string);

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(string,ushort,ushort);

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(string,ushort,ushort,bool,bool,byte);

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(ushort,ushort);

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(ushort,ushort,ushort,ushort);

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(ushort,ushort,ushort,ushort,IColorPalette,bool,bool,byte);

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifFrameBlock Constructor (UInt16, UInt16)

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(
ushort width,
ushort height
);

Parameters

width
The image width.
height
The image height.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifFrameBlock Constructor Overload List


GifFrameBlock Constructor (UInt16, UInt16, UInt16, UInt16)

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(
ushort left,
ushort top,
ushort width,
ushort height
);

Parameters

left
The left image position.
top
The top image position.
width
The image width.
height
The image height.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifFrameBlock Constructor Overload List


GifFrameBlock Constructor (UInt16, UInt16, UInt16, UInt16, IColorPalette, Boolean, Boolean, Byte)

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(
ushort left,
ushort top,
ushort width,
ushort height,
IColorPalette colorPalette,
bool isPaletteSorted,
bool isGifFrameInterlaced,
byte bitsPerPixel
);

Parameters

left
The left image position.
top
The top image position.
width
The image Width.
height
The image Height.
colorPalette
The color palette.
isPaletteSorted
if set to true the color palette is sorted.
isGifFrameInterlaced
if set to true the GIF frame is interlaced.
bitsPerPixel
The bits per pixel.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifFrameBlock Constructor Overload List


GifFrameBlock Constructor (RasterImage)

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(
RasterImage image
);

Parameters

image
The image to initialize frame pixel and palette data with.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifFrameBlock Constructor Overload List


GifFrameBlock Constructor (RasterImage, UInt16, UInt16)

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(
RasterImage image,
ushort left,
ushort top
);

Parameters

image
The image to initialize frame pixel and palette data with.
left
The left image position.
top
The top image position.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifFrameBlock Constructor Overload List


GifFrameBlock Constructor (RasterImage, UInt16, UInt16, Boolean, Boolean, Byte)

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(
RasterImage image,
ushort left,
ushort top,
bool isPaletteSorted,
bool isGifFrameInterlaced,
byte lzwCodeSize
);

Parameters

image
The image to initialize frame pixel and palette data with.
left
The left image position.
top
The top image position.
isPaletteSorted
if set to true the color palette is sorted.
isGifFrameInterlaced
if set to true the GIF frame is interlaced.
lzwCodeSize
The bits per pixel.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifFrameBlock Constructor Overload List


GifFrameBlock Constructor (Stream)

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(
Stream stream
);

Parameters

stream
The stream to load an image from and initialize frame pixel and palette data with.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifFrameBlock Constructor Overload List


GifFrameBlock Constructor (Stream, UInt16, UInt16)

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(
Stream stream,
ushort left,
ushort top
);

Parameters

stream
The stream to load an image from and initialize frame pixel and palette data with.
left
The left image position.
top
The top image position.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifFrameBlock Constructor Overload List


GifFrameBlock Constructor (Stream, UInt16, UInt16, Boolean, Boolean, Byte)

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(
Stream stream,
ushort left,
ushort top,
bool isPaletteSorted,
bool isGifFrameInterlaced,
byte lzwCodeSize
);

Parameters

stream
The stream to load an image from and initialize frame pixel and palette data with.
left
The left image position.
top
The top image position.
isPaletteSorted
if set to true the color palette is sorted.
isGifFrameInterlaced
if set to true the GIF frame is interlaced.
lzwCodeSize
The bits per pixel.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifFrameBlock Constructor Overload List


GifFrameBlock Constructor (String)

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(
string path
);

Parameters

path
The path to load an image from and initialize frame pixel and palette data with.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifFrameBlock Constructor Overload List


GifFrameBlock Constructor (String, UInt16, UInt16)

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(
string path,
ushort left,
ushort top
);

Parameters

path
The path to load an image from and initialize frame pixel and palette data with.
left
The left image position.
top
The top image position.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifFrameBlock Constructor Overload List


GifFrameBlock Constructor (String, UInt16, UInt16, Boolean, Boolean, Byte)

Initializes a new instance of the GifFrameBlock class.

public GifFrameBlock(
string path,
ushort left,
ushort top,
bool isPaletteSorted,
bool isGifFrameInterlaced,
byte lzwCodeSize
);

Parameters

path
The path to load an image from and initialize frame pixel and palette data with.
left
The left image position.
top
The top image position.
isPaletteSorted
if set to true the color palette is sorted.
isGifFrameInterlaced
if set to true the GIF frame is interlaced.
lzwCodeSize
The bits per pixel.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifFrameBlock Constructor Overload List


GifFrameBlock Properties

The properties of the GifFrameBlock class are listed below. For a complete list of GifFrameBlock class members, see the GifFrameBlock Members topic.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
ControlBlock | Gets the graphics control block associated with this block.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
Flags | Gets or sets the flags.
GifFrameBitsPerPixel | Gets or sets the GIF frame bits per pixel.
Height | Gets the image height.
HorizontalResolution (inherited from RasterImage) | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
Interlaced | Gets or sets a value indicating whether this GifFrameBlock is interlaced.
IsCached (inherited from RasterCachedImage) | Gets a value indicating whether image data is cached currently.
IsPaletteSorted | Gets or sets a value indicating whether color palette is sorted.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Left | Gets or sets the left image location.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
Top | Gets or sets the top image location.
VerticalResolution (inherited from RasterImage) | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width | Gets the image width.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

GifFrameBlock.BitsPerPixel Property

Gets the image bits per pixel count.

public override int BitsPerPixel {get;}

Property Value

The image bits per pixel count.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


ControlBlock Property

Aspose.Imaging Documentation

GifFrameBlock.ControlBlock Property

Gets the graphics control block associated with this block.

public GifGraphicsControlBlock ControlBlock {get;}

Property Value

The control block.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


Flags Property

Aspose.Imaging Documentation

GifFrameBlock.Flags Property

Gets or sets the flags.

public byte Flags {get; set;}

Property Value

The flags.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifFrameBitsPerPixel Property

Aspose.Imaging Documentation

GifFrameBlock.GifFrameBitsPerPixel Property

Gets or sets the GIF frame bits per pixel.

public byte GifFrameBitsPerPixel {get; set;}

Property Value

The GIF frame bits per pixel.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


Height Property

Aspose.Imaging Documentation

GifFrameBlock.Height Property

Gets the image height.

public override int Height {get;}

Property Value

The image height.

Implements

IObjectWithBounds.Height

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


Interlaced Property

Aspose.Imaging Documentation

GifFrameBlock.Interlaced Property

Gets or sets a value indicating whether this GifFrameBlock is interlaced.

public bool Interlaced {get; set;}

Property Value

true if interlaced; otherwise, false.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


IsPaletteSorted Property

Aspose.Imaging Documentation

GifFrameBlock.IsPaletteSorted Property

Gets or sets a value indicating whether color palette is sorted.

public bool IsPaletteSorted {get; set;}

Property Value

true if color palette is sorted; otherwise, false.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


Left Property

Aspose.Imaging Documentation

GifFrameBlock.Left Property

Gets or sets the left image location.

public ushort Left {get; set;}

Property Value

The left image location.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


Top Property

Aspose.Imaging Documentation

GifFrameBlock.Top Property

Gets or sets the top image location.

public ushort Top {get; set;}

Property Value

The top image location.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


Width Property

Aspose.Imaging Documentation

GifFrameBlock.Width Property

Gets the image width.

public override int Width {get;}

Property Value

The image width.

Implements

IObjectWithBounds.Width

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifFrameBlock Methods

The methods of the GifFrameBlock class are listed below. For a complete list of GifFrameBlock class members, see the GifFrameBlock Members topic.

Public Static Methods

CreateFlags | Creates the flags.
GetColorPalette | Gets the associated color palette.

Public Instance Methods

CacheData (inherited from RasterCachedImage) | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop (inherited from RasterCachedImage) | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
Resize (inherited from RasterCachedImage) | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip (inherited from RasterCachedImage) | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution (inherited from RasterImage) | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifFrameBlock.CreateFlags Method

Creates the flags.

public static byte CreateFlags(
IColorPalette colorPalette,
bool isPaletteSorted,
bool isGifFrameInterlaced
);

Parameters

colorPalette
The color palette.
isPaletteSorted
if set to true the colors in color palette are sorted.
isGifFrameInterlaced
if set to true the GIF frame image is interlaced.

Return Value

The created flags.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifFrameBlock.GetColorPalette Method

Gets the associated color palette.

public static IColorPalette GetColorPalette(
IColorPalette framePalette,
IColorPalette containerPalette
);

Parameters

framePalette
The frame palette.
containerPalette
The container palette.

Return Value

The color palette.

See Also

GifFrameBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifGraphicsControlBlock Class

Gif graphics control block.

For a list of all members of this type, see GifGraphicsControlBlock Members.

System.Object
Aspose.Imaging.FileFormats.Gif.GifBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifGraphicsControlBlock

public class GifGraphicsControlBlock : GifBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Gif.Blocks

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GifGraphicsControlBlock Members | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifGraphicsControlBlock Members

GifGraphicsControlBlock overview

Public Static Methods

CreateFlags Creates the flags.

Public Instance Constructors

GifGraphicsControlBlock Overloaded. Initializes a new instance of the GifGraphicsControlBlock class.

Public Instance Properties

DelayTime | Gets or sets the frame delay time expressed in 1/100 seconds.
DisposalMethod | Gets or sets the disposal method.
Flags | Gets or sets the flags.
HasTransparentColor | Gets or sets a value indicating whether graphics control block has transparent color.
IsChanged (inherited from GifBlock) | Gets or sets a value indicating whether block has changed and requires save.
TransparentColorIndex | Gets or sets the transparent color index.
UserInputExpected | Gets or sets a value indicating whether user input is expected.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifGraphicsControlBlock Constructor

Initializes a new instance of the GifGraphicsControlBlock class.

Overload List

Initializes a new instance of the GifGraphicsControlBlock class.

public GifGraphicsControlBlock();

Initializes a new instance of the GifGraphicsControlBlock class.

public GifGraphicsControlBlock(byte,ushort,byte);

Initializes a new instance of the GifGraphicsControlBlock class.

public GifGraphicsControlBlock(ushort,bool,byte,bool,DisposalMethod);

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifGraphicsControlBlock Constructor ()

Initializes a new instance of the GifGraphicsControlBlock class.

public GifGraphicsControlBlock();

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifGraphicsControlBlock Constructor Overload List


GifGraphicsControlBlock Constructor (Byte, UInt16, Byte)

Initializes a new instance of the GifGraphicsControlBlock class.

public GifGraphicsControlBlock(
byte flags,
ushort delayTime,
byte transparentColorIndex
);

Parameters

flags
The flags.
delayTime
The delay time expressed in 1/100 seconds.
transparentColorIndex
The transparent color index.

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifGraphicsControlBlock Constructor Overload List


GifGraphicsControlBlock Constructor (UInt16, Boolean, Byte, Boolean, DisposalMethod)

Initializes a new instance of the GifGraphicsControlBlock class.

public GifGraphicsControlBlock(
ushort delayTime,
bool hasTransparentColor,
byte transparentColorIndex,
bool requiresUserInput,
DisposalMethod disposalMethod
);

Parameters

delayTime
The delay time expressed in 1/100 seconds.
hasTransparentColor
if set to true the transparentColorIndex is valid.
transparentColorIndex
The transparent color index.
requiresUserInput
if set to true the user input is expected.
disposalMethod
The disposal method.

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifGraphicsControlBlock Constructor Overload List


GifGraphicsControlBlock Properties

The properties of the GifGraphicsControlBlock class are listed below. For a complete list of GifGraphicsControlBlock class members, see the GifGraphicsControlBlock Members topic.

Public Instance Properties

DelayTime | Gets or sets the frame delay time expressed in 1/100 seconds.
DisposalMethod | Gets or sets the disposal method.
Flags | Gets or sets the flags.
HasTransparentColor | Gets or sets a value indicating whether graphics control block has transparent color.
IsChanged (inherited from GifBlock) | Gets or sets a value indicating whether block has changed and requires save.
TransparentColorIndex | Gets or sets the transparent color index.
UserInputExpected | Gets or sets a value indicating whether user input is expected.

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


DelayTime Property

Aspose.Imaging Documentation

GifGraphicsControlBlock.DelayTime Property

Gets or sets the frame delay time expressed in 1/100 seconds.

public ushort DelayTime {get; set;}

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


DisposalMethod Property

Aspose.Imaging Documentation

GifGraphicsControlBlock.DisposalMethod Property

Gets or sets the disposal method.

public DisposalMethod DisposalMethod {get; set;}

Property Value

The disposal method.

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


Flags Property

Aspose.Imaging Documentation

GifGraphicsControlBlock.Flags Property

Gets or sets the flags.

public byte Flags {get; set;}

Property Value

The flags.

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


HasTransparentColor Property

Aspose.Imaging Documentation

GifGraphicsControlBlock.HasTransparentColor Property

Gets or sets a value indicating whether graphics control block has transparent color.

public bool HasTransparentColor {get; set;}

Property Value

true if graphics control block has transparent color; otherwise, false.

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


TransparentColorIndex Property

Aspose.Imaging Documentation

GifGraphicsControlBlock.TransparentColorIndex Property

Gets or sets the transparent color index.

public byte TransparentColorIndex {get; set;}

Property Value

The transparent color index.

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


UserInputExpected Property

Aspose.Imaging Documentation

GifGraphicsControlBlock.UserInputExpected Property

Gets or sets a value indicating whether user input is expected.

public bool UserInputExpected {get; set;}

Property Value

true if user input is expected; otherwise, false.

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifGraphicsControlBlock Methods

The methods of the GifGraphicsControlBlock class are listed below. For a complete list of GifGraphicsControlBlock class members, see the GifGraphicsControlBlock Members topic.

Public Static Methods

CreateFlags Creates the flags.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifGraphicsControlBlock.CreateFlags Method

Creates the flags.

public static byte CreateFlags(
bool hasTransparentColor,
bool requiresUserInput,
DisposalMethod disposalMethod
);

Parameters

hasTransparentColor
if set to true the GifGraphicsControlBlock has valid transparent color index.
requiresUserInput
if set to true the user input is expected.
disposalMethod
The disposal method.

Return Value

The generated flags.

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifGraphicsControlBlock.Save Method

Saves the block to the specified stream.

public override void Save(
Stream stream
);

Parameters

stream
The stream to save data to.

Implements

IGifBlock.Save

See Also

GifGraphicsControlBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifPlainTextRenderingBlock Class

Gif plain text extension block. The plain text extension contains textual data and the parameters necessary to render that data as a graphic, in a simple form.

For a list of all members of this type, see GifPlainTextRenderingBlock Members.

System.Object
Aspose.Imaging.FileFormats.Gif.GifBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifPlainTextRenderingBlock

public class GifPlainTextRenderingBlock : GifBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Gif.Blocks

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GifPlainTextRenderingBlock Members | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifPlainTextRenderingBlock Members

GifPlainTextRenderingBlock overview

Public Instance Constructors

GifPlainTextRenderingBlock Overloaded. Initializes a new instance of the GifPlainTextRenderingBlock class.

Public Instance Properties

CharacterCellHeight | Gets or sets the character cell height, in pixels, of each cell in the grid.
CharacterCellWidth | Gets or sets the character cell width, in pixels, of each cell in the grid.
IsChanged (inherited from GifBlock) | Gets or sets a value indicating whether block has changed and requires save.
PlainTextData | Gets or sets the plain text data.
TextBackgroundColorIndex | Gets or sets the index of the color in the global color palette used to draw the text background.
TextForegroundColorIndex | Gets or sets the index of the color in the global color palette used to draw the text foreground.
TextGridHeight | Gets or sets the text grid height in pixels
TextGridLeftPosition | Gets or sets the text grid left position.
TextGridTopPosition | Gets or sets the text grid top position.
TextGridWidth | Gets or sets the text grid with in pixels

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifPlainTextRenderingBlock Constructor

Initializes a new instance of the GifPlainTextRenderingBlock class.

Overload List

Initializes a new instance of the GifPlainTextRenderingBlock class.

public GifPlainTextRenderingBlock();

Initializes a new instance of the GifPlainTextRenderingBlock class.

public GifPlainTextRenderingBlock(ushort,ushort,ushort,ushort,byte,byte,byte,byte,byte[]);

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifPlainTextRenderingBlock Constructor ()

Initializes a new instance of the GifPlainTextRenderingBlock class.

public GifPlainTextRenderingBlock();

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifPlainTextRenderingBlock Constructor Overload List


GifPlainTextRenderingBlock Constructor (UInt16, UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte[])

Initializes a new instance of the GifPlainTextRenderingBlock class.

public GifPlainTextRenderingBlock(
ushort textGridLeftPosition,
ushort textGridTopPosition,
ushort textGridWidth,
ushort textGridHeight,
byte characterCellWidth,
byte characterCellHeight,
byte textForegroundColorIndex,
byte textBackgroundColorIndex,
byte[] data
);

Parameters

textGridLeftPosition
The text grid left position.
textGridTopPosition
The text grid top position.
textGridWidth
The text grid width.
textGridHeight
The text grid height.
characterCellWidth
The character cell width.
characterCellHeight
The character cell height.
textForegroundColorIndex
The foreground color index.
textBackgroundColorIndex
The background color index.
data
The plain text data.

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifPlainTextRenderingBlock Constructor Overload List


GifPlainTextRenderingBlock Properties

The properties of the GifPlainTextRenderingBlock class are listed below. For a complete list of GifPlainTextRenderingBlock class members, see the GifPlainTextRenderingBlock Members topic.

Public Instance Properties

CharacterCellHeight | Gets or sets the character cell height, in pixels, of each cell in the grid.
CharacterCellWidth | Gets or sets the character cell width, in pixels, of each cell in the grid.
IsChanged (inherited from GifBlock) | Gets or sets a value indicating whether block has changed and requires save.
PlainTextData | Gets or sets the plain text data.
TextBackgroundColorIndex | Gets or sets the index of the color in the global color palette used to draw the text background.
TextForegroundColorIndex | Gets or sets the index of the color in the global color palette used to draw the text foreground.
TextGridHeight | Gets or sets the text grid height in pixels
TextGridLeftPosition | Gets or sets the text grid left position.
TextGridTopPosition | Gets or sets the text grid top position.
TextGridWidth | Gets or sets the text grid with in pixels

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


CharacterCellHeight Property

Aspose.Imaging Documentation

GifPlainTextRenderingBlock.CharacterCellHeight Property

Gets or sets the character cell height, in pixels, of each cell in the grid.

public byte CharacterCellHeight {get; set;}

Property Value

The character cell height.

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


CharacterCellWidth Property

Aspose.Imaging Documentation

GifPlainTextRenderingBlock.CharacterCellWidth Property

Gets or sets the character cell width, in pixels, of each cell in the grid.

public byte CharacterCellWidth {get; set;}

Property Value

The character cell width.

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


PlainTextData Property

Aspose.Imaging Documentation

GifPlainTextRenderingBlock.PlainTextData Property

Gets or sets the plain text data.

public byte[] PlainTextData {get; set;}

Property Value

The plain text data.

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


TextBackgroundColorIndex Property

Aspose.Imaging Documentation

GifPlainTextRenderingBlock.TextBackgroundColorIndex Property

Gets or sets the index of the color in the global color palette used to draw the text background.

public byte TextBackgroundColorIndex {get; set;}

Property Value

The background color index.

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


TextForegroundColorIndex Property

Aspose.Imaging Documentation

GifPlainTextRenderingBlock.TextForegroundColorIndex Property

Gets or sets the index of the color in the global color palette used to draw the text foreground.

public byte TextForegroundColorIndex {get; set;}

Property Value

The foreground color index.

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


TextGridHeight Property

Aspose.Imaging Documentation

GifPlainTextRenderingBlock.TextGridHeight Property

Gets or sets the text grid height in pixels

public ushort TextGridHeight {get; set;}

Property Value

The text grid height in pixels.

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


TextGridLeftPosition Property

Aspose.Imaging Documentation

GifPlainTextRenderingBlock.TextGridLeftPosition Property

Gets or sets the text grid left position.

public ushort TextGridLeftPosition {get; set;}

Property Value

The text grid left position.

Remarks

This is a column number, in pixels, of the left edge of the text grid, with respect to the left edge of the logical screen.

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


TextGridTopPosition Property

Aspose.Imaging Documentation

GifPlainTextRenderingBlock.TextGridTopPosition Property

Gets or sets the text grid top position.

public ushort TextGridTopPosition {get; set;}

Property Value

The text grid top position.

Remarks

This is a row number, in pixels, of the top edge of the text grid, with respect to the top edge of the logical screen.

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


TextGridWidth Property

Aspose.Imaging Documentation

GifPlainTextRenderingBlock.TextGridWidth Property

Gets or sets the text grid with in pixels

public ushort TextGridWidth {get; set;}

Property Value

The text grid width in pixels.

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifPlainTextRenderingBlock Methods

The methods of the GifPlainTextRenderingBlock class are listed below. For a complete list of GifPlainTextRenderingBlock class members, see the GifPlainTextRenderingBlock Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifPlainTextRenderingBlock.Save Method

Saves the block to the specified stream.

public override void Save(
Stream stream
);

Parameters

stream
The stream to save data to.

Implements

IGifBlock.Save

See Also

GifPlainTextRenderingBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifUnknownExtensionBlock Class

Gif Unknown Extension Block.

For a list of all members of this type, see GifUnknownExtensionBlock Members.

System.Object
Aspose.Imaging.FileFormats.Gif.GifBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifUnknownExtensionBlock

public class GifUnknownExtensionBlock : GifBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Gif.Blocks

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GifUnknownExtensionBlock Members | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifUnknownExtensionBlock Members

GifUnknownExtensionBlock overview

Public Instance Constructors

GifUnknownExtensionBlock Overloaded. Initializes a new instance of the GifUnknownExtensionBlock class.

Public Instance Properties

ExtensionLabel | Gets or sets the block's extension label.
IsChanged (inherited from GifBlock) | Gets or sets a value indicating whether block has changed and requires save.
UnknownData | Gets or sets the unknown data.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifUnknownExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifUnknownExtensionBlock Constructor

Initializes a new instance of the GifUnknownExtensionBlock class.

Overload List

Initializes a new instance of the GifUnknownExtensionBlock class.

public GifUnknownExtensionBlock();

Initializes a new instance of the GifUnknownExtensionBlock class.

public GifUnknownExtensionBlock(byte,byte[]);

See Also

GifUnknownExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifUnknownExtensionBlock Constructor ()

Initializes a new instance of the GifUnknownExtensionBlock class.

public GifUnknownExtensionBlock();

See Also

GifUnknownExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifUnknownExtensionBlock Constructor Overload List


GifUnknownExtensionBlock Constructor (Byte, Byte[])

Initializes a new instance of the GifUnknownExtensionBlock class.

public GifUnknownExtensionBlock(
byte extensionLabel,
byte[] data
);

Parameters

extensionLabel
The extension label.
data
The block data.

See Also

GifUnknownExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace | GifUnknownExtensionBlock Constructor Overload List


GifUnknownExtensionBlock Properties

The properties of the GifUnknownExtensionBlock class are listed below. For a complete list of GifUnknownExtensionBlock class members, see the GifUnknownExtensionBlock Members topic.

Public Instance Properties

ExtensionLabel | Gets or sets the block's extension label.
IsChanged (inherited from GifBlock) | Gets or sets a value indicating whether block has changed and requires save.
UnknownData | Gets or sets the unknown data.

See Also

GifUnknownExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


ExtensionLabel Property

Aspose.Imaging Documentation

GifUnknownExtensionBlock.ExtensionLabel Property

Gets or sets the block's extension label.

public byte ExtensionLabel {get; set;}

Property Value

The block's extension label.

See Also

GifUnknownExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


UnknownData Property

Aspose.Imaging Documentation

GifUnknownExtensionBlock.UnknownData Property

Gets or sets the unknown data.

public byte[] UnknownData {get; set;}

Property Value

The unknown data.

See Also

GifUnknownExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifUnknownExtensionBlock Methods

The methods of the GifUnknownExtensionBlock class are listed below. For a complete list of GifUnknownExtensionBlock class members, see the GifUnknownExtensionBlock Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifUnknownExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


GifUnknownExtensionBlock.Save Method

Saves the block to the specified stream.

public override void Save(
Stream stream
);

Parameters

stream
The stream to save data to.

Implements

IGifBlock.Save

See Also

GifUnknownExtensionBlock Class | Aspose.Imaging.FileFormats.Gif.Blocks Namespace


Aspose.Imaging.FileFormats.Jpeg

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Jpeg Namespace

Namespace hierarchy

Classes

Class | Description
JFIFData | The jfif segment.
JpegImage | A jpeg image.

Enumerations

Enumeration | Description
JfifDensityUnits | The jfif density units.
JpegCompressionColorMode | Сolor mode for jpeg images.
JpegCompressionMode | Compression mode for jpeg images.


JFIFData Class

The jfif segment.

For a list of all members of this type, see JFIFData Members.

System.Object
Aspose.Imaging.FileFormats.Jpeg.JFIFData

public sealed class JFIFData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Jpeg

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

JFIFData Members | Aspose.Imaging.FileFormats.Jpeg Namespace


JFIFData Members

JFIFData overview

Public Instance Constructors

JFIFData Constructor Initializes a new instance of the JFIFData class.

Public Instance Properties

DensityUnits | Gets or sets the density units.
Thumbnail | Gets or sets the thumbnail.
Version | Gets or sets the version.
XDensity | Gets or sets the x density.
YDensity | Gets or sets the y density.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

JFIFData Class | Aspose.Imaging.FileFormats.Jpeg Namespace


JFIFData Constructor

Initializes a new instance of the JFIFData class.

public JFIFData();

See Also

JFIFData Class | Aspose.Imaging.FileFormats.Jpeg Namespace


JFIFData Properties

The properties of the JFIFData class are listed below. For a complete list of JFIFData class members, see the JFIFData Members topic.

Public Instance Properties

DensityUnits | Gets or sets the density units.
Thumbnail | Gets or sets the thumbnail.
Version | Gets or sets the version.
XDensity | Gets or sets the x density.
YDensity | Gets or sets the y density.

See Also

JFIFData Class | Aspose.Imaging.FileFormats.Jpeg Namespace


DensityUnits Property

Aspose.Imaging Documentation

JFIFData.DensityUnits Property

Gets or sets the density units.

public JfifDensityUnits DensityUnits {get; set;}

See Also

JFIFData Class | Aspose.Imaging.FileFormats.Jpeg Namespace


Thumbnail Property

Aspose.Imaging Documentation

JFIFData.Thumbnail Property

Gets or sets the thumbnail.

public RasterImage Thumbnail {get; set;}

See Also

JFIFData Class | Aspose.Imaging.FileFormats.Jpeg Namespace


Version Property

Aspose.Imaging Documentation

JFIFData.Version Property

Gets or sets the version.

public short Version {get;}

See Also

JFIFData Class | Aspose.Imaging.FileFormats.Jpeg Namespace


XDensity Property

Aspose.Imaging Documentation

JFIFData.XDensity Property

Gets or sets the x density.

public short XDensity {get; set;}

See Also

JFIFData Class | Aspose.Imaging.FileFormats.Jpeg Namespace


YDensity Property

Aspose.Imaging Documentation

JFIFData.YDensity Property

Gets or sets the y density.

public short YDensity {get; set;}

See Also

JFIFData Class | Aspose.Imaging.FileFormats.Jpeg Namespace


JfifDensityUnits Enumeration

The jfif density units.

public enum JfifDensityUnits

Members

Member Name | Description | Value
NoUnits | The no units. | 0
PixelsPerInch | The pixels per inch. | 1
PixelsPerCm | The pixels per cm. | 2

Requirements

Namespace: Aspose.Imaging.FileFormats.Jpeg

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Jpeg Namespace


JpegCompressionColorMode Enumeration

Сolor mode for jpeg images.

public enum JpegCompressionColorMode

Members

Member Name | Description | Value
Grayscale | The Grayscale image. | 0
YCbCr | YCbCr image, standard option for jpeg images. | 1
CMYK | 4-component CMYK image. | 2
Ycck | The ycck color jpeg image. Needs icc profile for saving. | 3
Rgb | The RGB Color mode. | 4

Requirements

Namespace: Aspose.Imaging.FileFormats.Jpeg

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Jpeg Namespace


JpegCompressionMode Enumeration

Compression mode for jpeg images.

public enum JpegCompressionMode

Members

Member Name | Description | Value
Baseline | The baseline compression. | 0
Progressive | The progressive. | 1

Requirements

Namespace: Aspose.Imaging.FileFormats.Jpeg

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Jpeg Namespace


JpegImage Class

A jpeg image.

For a list of all members of this type, see JpegImage Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image
Aspose.Imaging.RasterImage
Aspose.Imaging.RasterCachedImage
Aspose.Imaging.FileFormats.Jpeg.JpegImage

public sealed class JpegImage : RasterCachedImage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Jpeg

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

JpegImage Members | Aspose.Imaging.FileFormats.Jpeg Namespace


JpegImage Members

JpegImage overview

Public Instance Constructors

JpegImage Overloaded. Initializes a new instance of the JpegImage class.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Comment | Gets or sets the jpeg file comment.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
ExifData | Get or set exif data container
Height | Gets the image height.
HorizontalResolution | Gets the horizontal resolution, in pixels per inch, of this Image.
IsCached (inherited from RasterCachedImage) | Gets a value indicating whether image data is cached currently.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Jfif | Gets or sets the jfif.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution | Gets a value indicating whether object's data is cached currently and no data readig is required.
Width | Gets the image width.

Public Instance Methods

CacheData (inherited from RasterCachedImage) | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop (inherited from RasterCachedImage) | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
Resize (inherited from RasterCachedImage) | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip (inherited from RasterCachedImage) | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution (inherited from RasterImage) | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace


JpegImage Constructor

Initializes a new instance of the JpegImage class.

Overload List

Initializes a new instance of the JpegImage class.

public JpegImage(JpegOptions,int,int);

Initializes a new instance of the JpegImage class.

public JpegImage(RasterImage);

Initializes a new instance of the JpegImage class.

public JpegImage(int,int);

Initializes a new instance of the JpegImage class.

public JpegImage(Stream);

Initializes a new instance of the JpegImage class.

public JpegImage(string);

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace


JpegImage Constructor (String)

Initializes a new instance of the JpegImage class.

public JpegImage(
string path
);

Parameters

path
The path to load image from and initialize pixel and palette data with.

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace | JpegImage Constructor Overload List


JpegImage Constructor (Stream)

Initializes a new instance of the JpegImage class.

public JpegImage(
Stream stream
);

Parameters

stream
The stream to load image from and initialize pixel and palette data with.

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace | JpegImage Constructor Overload List


JpegImage Constructor (RasterImage)

Initializes a new instance of the JpegImage class.

public JpegImage(
RasterImage rasterImage
);

Parameters

rasterImage
The image to initialize pixel and palette data with.

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace | JpegImage Constructor Overload List


JpegImage Constructor (Int32, Int32)

Initializes a new instance of the JpegImage class.

public JpegImage(
int width,
int height
);

Parameters

width
The image width.
height
The image height.

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace | JpegImage Constructor Overload List


JpegImage Constructor (JpegOptions, Int32, Int32)

Initializes a new instance of the JpegImage class.

public JpegImage(
JpegOptions jpegOptions,
int width,
int height
);

Parameters

jpegOptions
The jpeg options.
width
Image width.
height
Image height.

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace | JpegImage Constructor Overload List


JpegImage Properties

The properties of the JpegImage class are listed below. For a complete list of JpegImage class members, see the JpegImage Members topic.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Comment | Gets or sets the jpeg file comment.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
ExifData | Get or set exif data container
Height | Gets the image height.
HorizontalResolution | Gets the horizontal resolution, in pixels per inch, of this Image.
IsCached (inherited from RasterCachedImage) | Gets a value indicating whether image data is cached currently.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Jfif | Gets or sets the jfif.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution | Gets a value indicating whether object's data is cached currently and no data readig is required.
Width | Gets the image width.

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

JpegImage.BitsPerPixel Property

Gets the image bits per pixel count.

public override int BitsPerPixel {get;}

Property Value

The image bits per pixel count.

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace


Comment Property

Aspose.Imaging Documentation

JpegImage.Comment Property

Gets or sets the jpeg file comment.

public char[] Comment {get; set;}

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace


ExifData Property

Aspose.Imaging Documentation

JpegImage.ExifData Property

Get or set exif data container

public JpegExifData ExifData {get; set;}

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace


Height Property

Aspose.Imaging Documentation

JpegImage.Height Property

Gets the image height.

public override int Height {get;}

Property Value

The image height.

Implements

IObjectWithBounds.Height

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace


HorizontalResolution Property

Aspose.Imaging Documentation

JpegImage.HorizontalResolution Property

Gets the horizontal resolution, in pixels per inch, of this Image.

public override double HorizontalResolution {get; set;}

Property Value

The horizontal resolution.

Remarks

Note by default this value is always 96 since different platforms cannot return the screen resolution. You may consider using the SetResolution method for updating both resolution values in single call.

Example

You can decide to store resolution either in jfif segment or exif segment. You can set resolution by following: this.Jfif.YDensity = 100; this.ExifData.YResolution = 100;

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace


Jfif Property

Aspose.Imaging Documentation

JpegImage.Jfif Property

Gets or sets the jfif.

public JFIFData Jfif {get; set;}

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace


RawDataFormat Property

Aspose.Imaging Documentation

JpegImage.RawDataFormat Property

Gets the raw data format.

public override PixelDataFormat RawDataFormat {get;}

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace


VerticalResolution Property

Aspose.Imaging Documentation

JpegImage.VerticalResolution Property

Gets a value indicating whether object's data is cached currently and no data readig is required.

public override double VerticalResolution {get; set;}

Property Value

true if object's data is cached; otherwise, false. The vertical resolution.

Example

You can decide to store resolution either in jfif segment or exif segment. You can set resolution by following: this.Jfif.YDensity = 100; this.ExifData.YResolution = 100;

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace


Width Property

Aspose.Imaging Documentation

JpegImage.Width Property

Gets the image width.

public override int Width {get;}

Property Value

The image width.

Implements

IObjectWithBounds.Width

See Also

JpegImage Class | Aspose.Imaging.FileFormats.Jpeg Namespace


Aspose.Imaging.FileFormats.Pdf

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Pdf Namespace

Namespace hierarchy

Classes

Class | Description
PdfDocumentInfo | This class represents set of metadata for document description.


PdfDocumentInfo Class

This class represents set of metadata for document description.

For a list of all members of this type, see PdfDocumentInfo Members.

System.Object
Aspose.Imaging.FileFormats.Pdf.PdfDocumentInfo

public class PdfDocumentInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Pdf

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PdfDocumentInfo Members | Aspose.Imaging.FileFormats.Pdf Namespace


PdfDocumentInfo Members

PdfDocumentInfo overview

Public Instance Constructors

PdfDocumentInfo Constructor Initializes a new instance of the PdfDocumentInfo class.

Public Instance Properties

Author | Gets or sets author of the document.
Keywords | Gets or sets keywords of the document.
Subject | Gets or sets subject of the document.
Title | Gets or sets title of the document.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PdfDocumentInfo Class | Aspose.Imaging.FileFormats.Pdf Namespace


PdfDocumentInfo Constructor

Initializes a new instance of the PdfDocumentInfo class.

public PdfDocumentInfo();

See Also

PdfDocumentInfo Class | Aspose.Imaging.FileFormats.Pdf Namespace


PdfDocumentInfo Properties

The properties of the PdfDocumentInfo class are listed below. For a complete list of PdfDocumentInfo class members, see the PdfDocumentInfo Members topic.

Public Instance Properties

Author | Gets or sets author of the document.
Keywords | Gets or sets keywords of the document.
Subject | Gets or sets subject of the document.
Title | Gets or sets title of the document.

See Also

PdfDocumentInfo Class | Aspose.Imaging.FileFormats.Pdf Namespace


Author Property

Aspose.Imaging Documentation

PdfDocumentInfo.Author Property

Gets or sets author of the document.

public string Author {get; set;}

See Also

PdfDocumentInfo Class | Aspose.Imaging.FileFormats.Pdf Namespace


Keywords Property

Aspose.Imaging Documentation

PdfDocumentInfo.Keywords Property

Gets or sets keywords of the document.

public string Keywords {get; set;}

See Also

PdfDocumentInfo Class | Aspose.Imaging.FileFormats.Pdf Namespace


Subject Property

Aspose.Imaging Documentation

PdfDocumentInfo.Subject Property

Gets or sets subject of the document.

public string Subject {get; set;}

See Also

PdfDocumentInfo Class | Aspose.Imaging.FileFormats.Pdf Namespace


Title Property

Aspose.Imaging Documentation

PdfDocumentInfo.Title Property

Gets or sets title of the document.

public string Title {get; set;}

See Also

PdfDocumentInfo Class | Aspose.Imaging.FileFormats.Pdf Namespace


Aspose.Imaging.FileFormats.Png

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Png Namespace

Namespace hierarchy

Classes

Class | Description
PngImage | Represents PNG image.


PngImage Class

Represents PNG image.

For a list of all members of this type, see PngImage Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image
Aspose.Imaging.RasterImage
Aspose.Imaging.FileFormats.Png.PngImage

public sealed class PngImage : RasterImage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Png

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PngImage Members | Aspose.Imaging.FileFormats.Png Namespace


PngImage Members

PngImage overview

Public Instance Constructors

PngImage Overloaded. Initializes a new instance of the PngImage class.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
Height | Gets the image height.
HorizontalResolution | Gets the horizontal resolution, in pixels per inch, of this Image.
IsCached | Gets a value indicating whether object's data is cached currently and no data reading is required.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution | Gets the vertical resolution, in pixels per inch, of this Image.
Width | Gets the image width.

Public Instance Methods

CacheData | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
Resize | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


PngImage Constructor

Initializes a new instance of the PngImage class.

Overload List

Initializes a new instance of the PngImage class.

public PngImage(RasterImage);

Initializes a new instance of the PngImage class.

public PngImage(int,int);

Initializes a new instance of the PngImage class.

public PngImage(Stream);

Initializes a new instance of the PngImage class.

public PngImage(string);

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


PngImage Constructor (String)

Initializes a new instance of the PngImage class.

public PngImage(
string path
);

Parameters

path
The path to load image from and initialize pixel and palette data with.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace | PngImage Constructor Overload List


PngImage Constructor (Stream)

Initializes a new instance of the PngImage class.

public PngImage(
Stream stream
);

Parameters

stream
The stream to load image from and initialize pixel and palette data with.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace | PngImage Constructor Overload List


PngImage Constructor (RasterImage)

Initializes a new instance of the PngImage class.

public PngImage(
RasterImage rasterImage
);

Parameters

rasterImage
The image to initialize pixel and palette data with.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace | PngImage Constructor Overload List


PngImage Constructor (Int32, Int32)

Initializes a new instance of the PngImage class.

public PngImage(
int width,
int height
);

Parameters

width
The image width.
height
The image height.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace | PngImage Constructor Overload List


PngImage Properties

The properties of the PngImage class are listed below. For a complete list of PngImage class members, see the PngImage Members topic.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
Height | Gets the image height.
HorizontalResolution | Gets the horizontal resolution, in pixels per inch, of this Image.
IsCached | Gets a value indicating whether object's data is cached currently and no data reading is required.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution | Gets the vertical resolution, in pixels per inch, of this Image.
Width | Gets the image width.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

PngImage.BitsPerPixel Property

Gets the image bits per pixel count.

public override int BitsPerPixel {get;}

Property Value

The image bits per pixel count.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


Height Property

Aspose.Imaging Documentation

PngImage.Height Property

Gets the image height.

public override int Height {get;}

Property Value

The image height.

Implements

IObjectWithBounds.Height

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


HorizontalResolution Property

Aspose.Imaging Documentation

PngImage.HorizontalResolution Property

Gets the horizontal resolution, in pixels per inch, of this Image.

public override double HorizontalResolution {get; set;}

Property Value

The horizontal resolution.

Remarks

Note by default this value is always 96 since different platforms cannot return the screen resolution. You may consider using the SetResolution method for updating both resolution values in single call.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


IsCached Property

Aspose.Imaging Documentation

PngImage.IsCached Property

Gets a value indicating whether object's data is cached currently and no data reading is required.

public override bool IsCached {get;}

Property Value

true if object's data is cached; otherwise, false.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


VerticalResolution Property

Aspose.Imaging Documentation

PngImage.VerticalResolution Property

Gets the vertical resolution, in pixels per inch, of this Image.

public override double VerticalResolution {get; set;}

Property Value

The vertical resolution.

Remarks

Note by default this value is always 96 since different platforms cannot return the screen resolution. You may consider using the SetResolution method for updating both resolution values in single call.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


Width Property

Aspose.Imaging Documentation

PngImage.Width Property

Gets the image width.

public override int Width {get;}

Property Value

The image width.

Implements

IObjectWithBounds.Width

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


PngImage Methods

The methods of the PngImage class are listed below. For a complete list of PngImage class members, see the PngImage Members topic.

Public Instance Methods

CacheData | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
Resize | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


PngImage.CacheData Method

Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.

public override void CacheData();

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


Crop Method

Aspose.Imaging Documentation

PngImage.Crop Method

Cropping the image.

Overload List

Cropping the image.

public override void Crop(Rectangle);

Inherited from RasterImage.

public virtual void Crop(int,int,int,int);

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


PngImage.Crop Method (Rectangle)

Cropping the image.

public override void Crop(
Rectangle rectangle
);

Parameters

rectangle
The rectangle.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace | PngImage.Crop Overload List


Resize Method

Aspose.Imaging Documentation

PngImage.Resize Method

Resizes the image.

Overload List

Inherited from Image.

public void Resize(int,int);

Resizes the image.

public override void Resize(int,int,ResizeType);

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


PngImage.Resize Method (Int32, Int32, ResizeType)

Resizes the image.

public override void Resize(
int newWidth,
int newHeight,
ResizeType resizeType
);

Parameters

newWidth
The new width.
newHeight
The new height.
resizeType
The resize type.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace | PngImage.Resize Overload List


PngImage.RotateFlip Method

Rotates, flips, or rotates and flips the image.

public override void RotateFlip(
RotateFlipType rotateFlipType
);

Parameters

rotateFlipType
Type of the rotate flip.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


PngImage.SetResolution Method

Sets the resolution for this RasterImage.

public override void SetResolution(
double dpiX,
double dpiY
);

Parameters

dpiX
The horizontal resolution, in dots per inch, of the RasterImage.
dpiY
The vertical resolution, in dots per inch, of the RasterImage.

See Also

PngImage Class | Aspose.Imaging.FileFormats.Png Namespace


Aspose.Imaging.FileFormats.Psd

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Psd Namespace

Namespace hierarchy

Classes

Class | Description
PsdColorPalette | The PSD color palette.
PsdImage | A PSD image.
ResourceBlock | The resource block.

Enumerations

Enumeration | Description
ColorModes | Represents the psd file format color modes.
CompressionMethod | Defines the compression method used for image data.


ColorModes Enumeration

Represents the psd file format color modes.

public enum ColorModes

Members

Member Name | Description | Value
Bitmap | The bitmap color mode. | 0
Grayscale | The grayscale mode. | 1
Indexed | Indexed color mode. | 2
RGB | RGB color mode. | 3
CMYK | CMYK color mode. | 4
Multichannel | Multichannel color mode. | 7
Duotone | Duotone color mode. | 8
Lab | Lab color mode. | 9

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Psd Namespace


CompressionMethod Enumeration

Defines the compression method used for image data.

public enum CompressionMethod

Members

Member Name | Description | Value
Raw | No compression. The image data stored as raw bytes in RGBA planar order. That means that first all R data is written, then all G is written, then all B and finally all A data is written. | 0
RLE | RLE compressed the image data starts with the byte counts for all the scan lines (rows * channels), with each count stored as a two-byte value. The RLE compressed data follows, with each scan line compressed separately. The RLE compression is the same compression algorithm used by the Macintosh ROM routine PackBits and the TIFF standard. | 1
ZipWithoutPrediction | ZIP without prediction. | 2
ZipWithPrediction | ZIP with prediction. | 3

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Psd Namespace


PsdColorPalette Class

The PSD color palette.

For a list of all members of this type, see PsdColorPalette Members.

System.Object
Aspose.Imaging.FileFormats.Psd.PsdColorPalette

public class PsdColorPalette : IPsdColorPalette, IColorPalette

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PsdColorPalette Members | Aspose.Imaging.FileFormats.Psd Namespace


PsdColorPalette Members

PsdColorPalette overview

Public Static Methods

CopyPalette Overloaded. Copies the palette.

Public Instance Constructors

PsdColorPalette Overloaded. Initializes a new instance of the PsdColorPalette class.

Public Instance Properties

Entries | Gets an array of Color structures.
EntriesCount | Gets the entries count.
HasTransparentColor | Gets a value indicating whether transparent color exists.
IsCompactPalette | Gets a value indicating whether compact it palette.
RawEntries | Gets the raw color palette entries data.
RawEntriesCount | Gets the raw color palette entries count.
TransparentColor | Gets the transparent color.
TransparentIndex | Gets the index of the transparent color.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColor | Gets the palette color by index.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNearestColorIndex | Gets the index of the nearest color.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


PsdColorPalette Constructor

Initializes a new instance of the PsdColorPalette class.

Overload List

Initializes a new instance of the PsdColorPalette class and IsCompactPalette is false.

public PsdColorPalette(Color[]);

Initializes a new instance of the PsdColorPalette class.

public PsdColorPalette(Color[],bool);

Initializes a new instance of the PsdColorPalette class and IsCompactPalette is false.

public PsdColorPalette(Color[],short);

Initializes a new instance of the PsdColorPalette class.

public PsdColorPalette(Color[],short,bool);

Initializes a new instance of the PsdColorPalette class.

public PsdColorPalette(IColorPalette);

Initializes a new instance of the PsdColorPalette class.

public PsdColorPalette(IColorPalette,short);

Initializes a new instance of the PsdColorPalette class and IsCompactPalette is false.

public PsdColorPalette(byte[]);

Initializes a new instance of the PsdColorPalette class.

public PsdColorPalette(byte[],bool);

Initializes a new instance of the PsdColorPalette class and IsCompactPalette is false.

public PsdColorPalette(byte[],short);

Initializes a new instance of the PsdColorPalette class.

public PsdColorPalette(byte[],short,bool);

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


PsdColorPalette Constructor (IColorPalette)

Initializes a new instance of the PsdColorPalette class.

public PsdColorPalette(
IColorPalette colorPalette
);

Parameters

colorPalette
The color palette.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdColorPalette Constructor Overload List


PsdColorPalette Constructor (IColorPalette, Int16)

Initializes a new instance of the PsdColorPalette class.

public PsdColorPalette(
IColorPalette colorPalette,
short transparentIndex
);

Parameters

colorPalette
The color palette.
transparentIndex
The transparent color index.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdColorPalette Constructor Overload List


PsdColorPalette Constructor (Byte[], Boolean)

Initializes a new instance of the PsdColorPalette class.

public PsdColorPalette(
byte[] rawEntriesData,
bool isCompactPalette
);

Parameters

rawEntriesData
The raw entries data.
isCompactPalette
Indicating whether compact it palette.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdColorPalette Constructor Overload List


PsdColorPalette Constructor (Byte[])

Initializes a new instance of the PsdColorPalette class and IsCompactPalette is false.

public PsdColorPalette(
byte[] rawEntriesData
);

Parameters

rawEntriesData
The raw entries data.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdColorPalette Constructor Overload List


PsdColorPalette Constructor (Byte[], Int16, Boolean)

Initializes a new instance of the PsdColorPalette class.

public PsdColorPalette(
byte[] rawEntriesData,
short transparentIndex,
bool useCompactPalette
);

Parameters

rawEntriesData
The raw entries data.
transparentIndex
The transparent color index. Note the index is not the raw entries index instead it is for the converted color array.
useCompactPalette
Indicating whether compact it palette.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdColorPalette Constructor Overload List


PsdColorPalette Constructor (Byte[], Int16)

Initializes a new instance of the PsdColorPalette class and IsCompactPalette is false.

public PsdColorPalette(
byte[] rawEntriesData,
short transparentIndex
);

Parameters

rawEntriesData
The raw entries data.
transparentIndex
The transparent color index. Note the index is not the raw entries index instead it is for the converted color array.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdColorPalette Constructor Overload List


PsdColorPalette Constructor (Color[], Boolean)

Initializes a new instance of the PsdColorPalette class.

public PsdColorPalette(
Color[] colorPaletteEntries,
bool isCompactPalette
);

Parameters

colorPaletteEntries
The color palette entries.
isCompactPalette
Indicating whether compact it palette.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdColorPalette Constructor Overload List


PsdColorPalette Constructor (Color[])

Initializes a new instance of the PsdColorPalette class and IsCompactPalette is false.

public PsdColorPalette(
Color[] colorPaletteEntries
);

Parameters

colorPaletteEntries
The color palette entries.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdColorPalette Constructor Overload List


PsdColorPalette Constructor (Color[], Int16, Boolean)

Initializes a new instance of the PsdColorPalette class.

public PsdColorPalette(
Color[] colorPaletteEntries,
short transparentIndex,
bool useCompactPalette
);

Parameters

colorPaletteEntries
The color palette entries.
transparentIndex
The transparent color index.
useCompactPalette
Indicating whether compact it palette.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdColorPalette Constructor Overload List


PsdColorPalette Constructor (Color[], Int16)

Initializes a new instance of the PsdColorPalette class and IsCompactPalette is false.

public PsdColorPalette(
Color[] colorPaletteEntries,
short transparentIndex
);

Parameters

colorPaletteEntries
The color palette entries.
transparentIndex
The transparent color index.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdColorPalette Constructor Overload List


PsdColorPalette Properties

The properties of the PsdColorPalette class are listed below. For a complete list of PsdColorPalette class members, see the PsdColorPalette Members topic.

Public Instance Properties

Entries | Gets an array of Color structures.
EntriesCount | Gets the entries count.
HasTransparentColor | Gets a value indicating whether transparent color exists.
IsCompactPalette | Gets a value indicating whether compact it palette.
RawEntries | Gets the raw color palette entries data.
RawEntriesCount | Gets the raw color palette entries count.
TransparentColor | Gets the transparent color.
TransparentIndex | Gets the index of the transparent color.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


Entries Property

Aspose.Imaging Documentation

PsdColorPalette.Entries Property

Gets an array of Color structures.

public Color[] Entries {get;}

Property Value

The entries.

Implements

IColorPalette.Entries

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


EntriesCount Property

Aspose.Imaging Documentation

PsdColorPalette.EntriesCount Property

Gets the entries count.

public int EntriesCount {get;}

Property Value

The entries count.

Implements

IColorPalette.EntriesCount

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


HasTransparentColor Property

Aspose.Imaging Documentation

PsdColorPalette.HasTransparentColor Property

Gets a value indicating whether transparent color exists.

public bool HasTransparentColor {get;}

Property Value

true if transparent color exists; otherwise, false.

Implements

IPsdColorPalette.HasTransparentColor

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


IsCompactPalette Property

Aspose.Imaging Documentation

PsdColorPalette.IsCompactPalette Property

Gets a value indicating whether compact it palette.

public bool IsCompactPalette {get;}

Property Value

true if compact it palette; otherwise, false.

Implements

IColorPalette.IsCompactPalette

Remarks

Compact palette means that image will contain only the specified palette entries if possible or in other words the image will be more compact and occupy less space; otherwise there will be 2^BitsPerPixel entries and image will reserve more space for all possible palette entries. Setting this value to true and changing palette entries may cause performance penalty since data movement may occur so use it carefully.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


RawEntries Property

Aspose.Imaging Documentation

PsdColorPalette.RawEntries Property

Gets the raw color palette entries data.

public byte[] RawEntries {get;}

Property Value

The raw color palette entries data.

Implements

IPsdColorPalette.RawEntries

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


RawEntriesCount Property

Aspose.Imaging Documentation

PsdColorPalette.RawEntriesCount Property

Gets the raw color palette entries count.

public int RawEntriesCount {get;}

Property Value

The raw color palette entries count.

Implements

IPsdColorPalette.RawEntriesCount

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


TransparentColor Property

Aspose.Imaging Documentation

PsdColorPalette.TransparentColor Property

Gets the transparent color.

public Color TransparentColor {get;}

Property Value

The transparent color.

Implements

IPsdColorPalette.TransparentColor

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


TransparentIndex Property

Aspose.Imaging Documentation

PsdColorPalette.TransparentIndex Property

Gets the index of the transparent color.

public short TransparentIndex {get;}

Property Value

The index of the transparent color.

Implements

IPsdColorPalette.TransparentIndex

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


PsdColorPalette Methods

The methods of the PsdColorPalette class are listed below. For a complete list of PsdColorPalette class members, see the PsdColorPalette Members topic.

Public Static Methods

CopyPalette Overloaded. Copies the palette.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColor | Gets the palette color by index.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNearestColorIndex | Gets the index of the nearest color.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


CopyPalette Method

Aspose.Imaging Documentation

PsdColorPalette.CopyPalette Method

Copies the palette.

Overload List

Copies the palette.

public static PsdColorPalette CopyPalette(IColorPalette);

Copies the palette.

public static PsdColorPalette CopyPalette(IColorPalette,bool);

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


PsdColorPalette.CopyPalette Method (IColorPalette)

Copies the palette.

public static PsdColorPalette CopyPalette(
IColorPalette colorPalette
);

Parameters

colorPalette
The color palette.

Return Value

The newly created and copied palette or null if null palette passed.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdColorPalette.CopyPalette Overload List


PsdColorPalette.CopyPalette Method (IColorPalette, Boolean)

Copies the palette.

public static PsdColorPalette CopyPalette(
IColorPalette colorPalette,
bool useCompactPalette
);

Parameters

colorPalette
The color palette.
useCompactPalette
Indicating whether compact palette.

Return Value

The newly created and copied palette or null if null palette passed.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdColorPalette.CopyPalette Overload List


PsdColorPalette.GetColor Method

Gets the palette color by index.

public Color GetColor(
int index
);

Parameters

index
The palette color index.

Return Value

The color palette entry specified by the index.

Implements

IColorPalette.GetColor

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | if color palette index specified is out of the palette entries range.

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


PsdColorPalette.GetNearestColorIndex Method

Gets the index of the nearest color.

public int GetNearestColorIndex(
Color color
);

Parameters

color
The color.

Return Value

The index of the nearest color.

Implements

IColorPalette.GetNearestColorIndex

See Also

PsdColorPalette Class | Aspose.Imaging.FileFormats.Psd Namespace


PsdImage Class

A PSD image.

For a list of all members of this type, see PsdImage Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image
Aspose.Imaging.RasterImage
Aspose.Imaging.RasterCachedImage
Aspose.Imaging.FileFormats.Psd.PsdImage

public sealed class PsdImage : RasterCachedImage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PsdImage Members | Aspose.Imaging.FileFormats.Psd Namespace


PsdImage Members

PsdImage overview

Public Instance Constructors

PsdImage Overloaded. Initializes a new instance of the PsdImage class.

Public Instance Properties

BitsPerChannel | Gets the bits per channel.
BitsPerPixel | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
ChannelsCount | Gets the PSD channels count.
ColorMode | Gets or sets the color mode.
Compression | Gets the compression method.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
GlobalLayerMaskInfo | Gets the global layer mask info.
GlobalLayerResources | Gets or sets the global layer resources.
HasTransparencyData | Gets or sets a value indicating whether first alpha channel contains the transparency data for the merged result when specifying layers data.
Height | Gets the image height.
HorizontalResolution (inherited from RasterImage) | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
ImageResources | Gets or sets the PSD image resources.
IsCached (inherited from RasterCachedImage) | Gets a value indicating whether image data is cached currently.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Layers | Gets or sets the PSD layers.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
Version | Gets or sets the version.
VerticalResolution (inherited from RasterImage) | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width | Gets the image width.

Public Instance Methods

CacheData (inherited from RasterCachedImage) | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop (inherited from RasterCachedImage) | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
Resize (inherited from RasterCachedImage) | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip (inherited from RasterCachedImage) | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution (inherited from RasterImage) | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


PsdImage Constructor

Initializes a new instance of the PsdImage class.

Overload List

Initializes a new instance of the PsdImage class.

public PsdImage(RasterImage);

Initializes a new instance of the PsdImage class.

public PsdImage(RasterImage,ColorModes,short,short,int,CompressionMethod);

Initializes a new instance of the PsdImage class.

public PsdImage(int,int);

Initializes a new instance of the PsdImage class.

public PsdImage(int,int,IColorPalette,ColorModes,short,short,int,CompressionMethod);

Initializes a new instance of the PsdImage class.

public PsdImage(Stream);

Initializes a new instance of the PsdImage class.

public PsdImage(Stream,ColorModes,short,short,int,CompressionMethod);

Initializes a new instance of the PsdImage class.

public PsdImage(string);

Initializes a new instance of the PsdImage class.

public PsdImage(string,ColorModes,short,short,int,CompressionMethod);

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


PsdImage Constructor (String)

Initializes a new instance of the PsdImage class.

public PsdImage(
string path
);

Parameters

path
The path to load pixel and palette data from and initialize with.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdImage Constructor Overload List


PsdImage Constructor (String, ColorModes, Int16, Int16, Int32, CompressionMethod)

Initializes a new instance of the PsdImage class.

public PsdImage(
string path,
ColorModes colorMode,
short channelBitDepth,
short channels,
int psdVersion,
CompressionMethod compression
);

Parameters

path
The path to load pixel and palette data from and initialize with.
colorMode
The color mode.
channelBitDepth
The PSD bit depth per channel.
channels
The PSD channels count.
psdVersion
The PSD version.
compression
The compression to use.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdImage Constructor Overload List


PsdImage Constructor (Stream)

Initializes a new instance of the PsdImage class.

public PsdImage(
Stream stream
);

Parameters

stream
The stream to load pixel and palette data from and initialize with.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdImage Constructor Overload List


PsdImage Constructor (Stream, ColorModes, Int16, Int16, Int32, CompressionMethod)

Initializes a new instance of the PsdImage class.

public PsdImage(
Stream stream,
ColorModes colorMode,
short channelBitDepth,
short channels,
int psdVersion,
CompressionMethod compression
);

Parameters

stream
The stream to load pixel and palette data from and initialize with.
colorMode
The color mode.
channelBitDepth
The PSD bit depth per channel.
channels
The PSD channels count.
psdVersion
The PSD version.
compression
The compression to use.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdImage Constructor Overload List


PsdImage Constructor (RasterImage)

Initializes a new instance of the PsdImage class.

public PsdImage(
RasterImage rasterImage
);

Parameters

rasterImage
The image to load pixel and palette data from and initialize with.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdImage Constructor Overload List


PsdImage Constructor (RasterImage, ColorModes, Int16, Int16, Int32, CompressionMethod)

Initializes a new instance of the PsdImage class.

public PsdImage(
RasterImage rasterImage,
ColorModes colorMode,
short channelBitDepth,
short channels,
int psdVersion,
CompressionMethod compression
);

Parameters

rasterImage
The image to load pixel and palette data from and initialize with.
colorMode
The color mode.
channelBitDepth
The PSD bit depth per channel.
channels
The PSD channels count.
psdVersion
The PSD version.
compression
The compression to use.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdImage Constructor Overload List


PsdImage Constructor (Int32, Int32)

Initializes a new instance of the PsdImage class.

public PsdImage(
int width,
int height
);

Parameters

width
The image width.
height
The image height.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdImage Constructor Overload List


PsdImage Constructor (Int32, Int32, IColorPalette, ColorModes, Int16, Int16, Int32, CompressionMethod)

Initializes a new instance of the PsdImage class.

public PsdImage(
int width,
int height,
IColorPalette colorPalette,
ColorModes colorMode,
short channelBitDepth,
short channels,
int psdVersion,
CompressionMethod compression
);

Parameters

width
The image width.
height
The image height.
colorPalette
The color palette.
colorMode
The color mode.
channelBitDepth
The PSD bit depth per channel.
channels
The PSD channels count.
psdVersion
The PSD version.
compression
The compression to use.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace | PsdImage Constructor Overload List


PsdImage Properties

The properties of the PsdImage class are listed below. For a complete list of PsdImage class members, see the PsdImage Members topic.

Public Instance Properties

BitsPerChannel | Gets the bits per channel.
BitsPerPixel | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
ChannelsCount | Gets the PSD channels count.
ColorMode | Gets or sets the color mode.
Compression | Gets the compression method.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
GlobalLayerMaskInfo | Gets the global layer mask info.
GlobalLayerResources | Gets or sets the global layer resources.
HasTransparencyData | Gets or sets a value indicating whether first alpha channel contains the transparency data for the merged result when specifying layers data.
Height | Gets the image height.
HorizontalResolution (inherited from RasterImage) | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
ImageResources | Gets or sets the PSD image resources.
IsCached (inherited from RasterCachedImage) | Gets a value indicating whether image data is cached currently.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Layers | Gets or sets the PSD layers.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
Version | Gets or sets the version.
VerticalResolution (inherited from RasterImage) | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width | Gets the image width.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


BitsPerChannel Property

Aspose.Imaging Documentation

PsdImage.BitsPerChannel Property

Gets the bits per channel.

public int BitsPerChannel {get;}

Property Value

The bits per channel.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

PsdImage.BitsPerPixel Property

Gets the image bits per pixel count.

public override int BitsPerPixel {get;}

Property Value

The image bits per pixel count.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


ChannelsCount Property

Aspose.Imaging Documentation

PsdImage.ChannelsCount Property

Gets the PSD channels count.

public int ChannelsCount {get;}

Property Value

The PSD channels count.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


ColorMode Property

Aspose.Imaging Documentation

PsdImage.ColorMode Property

Gets or sets the color mode.

public ColorModes ColorMode {get; set;}

Property Value

The color mode.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


Compression Property

Aspose.Imaging Documentation

PsdImage.Compression Property

Gets the compression method.

public CompressionMethod Compression {get;}

Property Value

The compression.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


GlobalLayerMaskInfo Property

Aspose.Imaging Documentation

PsdImage.GlobalLayerMaskInfo Property

Gets the global layer mask info.

public GlobalLayerMaskInfo GlobalLayerMaskInfo {get;}

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


GlobalLayerResources Property

Aspose.Imaging Documentation

PsdImage.GlobalLayerResources Property

Gets or sets the global layer resources.

public LayerResource[] GlobalLayerResources {get; set;}

Property Value

The global layer resources.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


HasTransparencyData Property

Aspose.Imaging Documentation

PsdImage.HasTransparencyData Property

Gets or sets a value indicating whether first alpha channel contains the transparency data for the merged result when specifying layers data.

public bool HasTransparencyData {get; set;}

Property Value

true if first alpha channel contains the transparency data for the merged result when specifying layers data; otherwise, false.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


Height Property

Aspose.Imaging Documentation

PsdImage.Height Property

Gets the image height.

public override int Height {get;}

Property Value

The image height.

Implements

IObjectWithBounds.Height

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


ImageResources Property

Aspose.Imaging Documentation

PsdImage.ImageResources Property

Gets or sets the PSD image resources.

public ResourceBlock[] ImageResources {get; set;}

Property Value

The PSD image resources.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


Layers Property

Aspose.Imaging Documentation

PsdImage.Layers Property

Gets or sets the PSD layers.

public Layer[] Layers {get; set;}

Property Value

The PSD layers.

Remarks

Note that if there are no layers the other related information within layer and mask information section will not be preserved (layer masks, resources and etc).

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


Version Property

Aspose.Imaging Documentation

PsdImage.Version Property

Gets or sets the version.

public int Version {get; set;}

Property Value

The version.

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


Width Property

Aspose.Imaging Documentation

PsdImage.Width Property

Gets the image width.

public override int Width {get;}

Property Value

The image width.

Implements

IObjectWithBounds.Width

See Also

PsdImage Class | Aspose.Imaging.FileFormats.Psd Namespace


ResourceBlock Class

The resource block.

For a list of all members of this type, see ResourceBlock Members.

System.Object
Aspose.Imaging.FileFormats.Psd.ResourceBlock
Aspose.Imaging.FileFormats.Psd.Resources.GridAndGuidesResouce
Aspose.Imaging.FileFormats.Psd.Resources.ThumbnailResource
Aspose.Imaging.FileFormats.Psd.Resources.TransparencyIndexResource
Aspose.Imaging.FileFormats.Psd.Resources.UnknownResource

public abstract class ResourceBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ResourceBlock Members | Aspose.Imaging.FileFormats.Psd Namespace


ResourceBlock Members

ResourceBlock overview

Public Instance Properties

DataSize | Gets the resource data size in bytes.
ID | Gets or sets the unique identifier for the resource.
MinimalVersion | Gets the minimal required psd version.
Name | Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).
Signature | Gets the resource signature. Should be always '8BIM'.
Size | Gets the resource block size in bytes including its data.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the resource block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
ValidateValues | Validates the resource values.

Protected Instance Constructors

ResourceBlock Constructor Initializes a new instance of the ResourceBlock class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveData | Saves the resource block data.

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


ResourceBlock Constructor

Initializes a new instance of the ResourceBlock class.

protected ResourceBlock();

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


ResourceBlock Properties

The properties of the ResourceBlock class are listed below. For a complete list of ResourceBlock class members, see the ResourceBlock Members topic.

Public Instance Properties

DataSize | Gets the resource data size in bytes.
ID | Gets or sets the unique identifier for the resource.
MinimalVersion | Gets the minimal required psd version.
Name | Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).
Signature | Gets the resource signature. Should be always '8BIM'.
Size | Gets the resource block size in bytes including its data.

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


DataSize Property

Aspose.Imaging Documentation

ResourceBlock.DataSize Property

Gets the resource data size in bytes.

public abstract int DataSize {get;}

Property Value

The resource data size.

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


ID Property

Aspose.Imaging Documentation

ResourceBlock.ID Property

Gets or sets the unique identifier for the resource.

public short ID {get; set;}

Property Value

The unique identifier for the resource.

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


MinimalVersion Property

Aspose.Imaging Documentation

ResourceBlock.MinimalVersion Property

Gets the minimal required psd version.

public abstract int MinimalVersion {get;}

Property Value

The minimal psd version.

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


Name Property

Aspose.Imaging Documentation

ResourceBlock.Name Property

Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).

public string Name {get; set;}

Property Value

The resource name.

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


Signature Property

Aspose.Imaging Documentation

ResourceBlock.Signature Property

Gets the resource signature. Should be always '8BIM'.

public int Signature {get;}

Property Value

The resource signature.

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


Size Property

Aspose.Imaging Documentation

ResourceBlock.Size Property

Gets the resource block size in bytes including its data.

public int Size {get;}

Property Value

The resource block size.

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


ResourceBlock Methods

The methods of the ResourceBlock class are listed below. For a complete list of ResourceBlock class members, see the ResourceBlock Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the resource block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
ValidateValues | Validates the resource values.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveData | Saves the resource block data.

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


ResourceBlock.Save Method

Saves the resource block to the specified stream.

public void Save(
StreamContainer stream
);

Parameters

stream
The stream to save the resource block to.

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


ResourceBlock.SaveData Method

Saves the resource block data.

protected abstract void SaveData(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container to save to.

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


ResourceBlock.ValidateValues Method

Validates the resource values.

public virtual void ValidateValues();

See Also

ResourceBlock Class | Aspose.Imaging.FileFormats.Psd Namespace


Aspose.Imaging.FileFormats.Psd.Layers

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Psd.Layers Namespace

Namespace hierarchy

Classes

Class | Description
BlendRange | The blend range.
ChannelInformation | The channel information.
GlobalLayerMaskInfo | The global layer mask section.
Layer | The psd layer.
LayerBlendingRangesData | The layer blending ranges data.
LayerMaskData | The layer mask data.
LayerMaskDataFull | The full layer mask information.
LayerMaskDataShort | The short layer mask information.
LayerResource | Represents layer info.
LayerResourcesRegistry | Represents the layer resources registry.

Interfaces

Interface | Description
ILayerResourceLoader | The layer resource loader.

Enumerations

Enumeration | Description
BlendMode | The layer blend mode.
LayerMaskFlags | The layer mask flags


BlendMode Enumeration

The layer blend mode.

public enum BlendMode

Members

Member Name | Description | Value
Normal | Normal blend mode. | 1852797549
Darken | Darken blend mode. | 1684107883
Lighten | Lighten blend mode. | 1818850405
Hue | Hue blend mode. | 1752524064
Saturation | Saturation blend mode. | 1935766560
Color | Color blend mode. | 1668246642
Luminosity | Luminosity blend mode. | 1819634976
Multiply | Multiply blend mode. | 1836411936
Screen | Screen blend mode. | 1935897198
Dissolve | Dissolve blend mode. | 1684632435
Overlay | Overlay blend mode. | 1870030194
HardLight | Hard light blend mode. | 1749838196
SoftLight | Soft light blend mode. | 1934387572
Difference | Difference blend mode. | 1684629094
Exclusion | Exclusion blend mode. | 1936553316
ColorDodge | Color dodge blend mode. | 1684633120
ColorBurn | Color burn blend mode. | 1768188278
LinearBurn | Linear burn blend mode. | 1818391150
LinearDodge | Linear dodge blend mode. | 1818518631
VividLight | Vivid light blend mode. | 1984719220
LinearLight | Linear light blend mode. | 1816947060
PinLight | Pin light blend mode. | 1884055924
HardMix | Hard mix blend mode. | 1749903736
PassThrough | Pass through blend mode. | 1885434739
DarkerColor | Darker color blend mode. | 1684751212
LighterColor | Lighter color blend mode. | 1818706796
Subtract | Subtract blend mode. | 1718842722
Divide | Divide blend mode. | 1717856630

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Psd.Layers Namespace


BlendRange Class

The blend range.

For a list of all members of this type, see BlendRange Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.BlendRange

public sealed class BlendRange

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

BlendRange Members | Aspose.Imaging.FileFormats.Psd.Layers Namespace


BlendRange Members

BlendRange overview

Public Instance Constructors

BlendRange Constructor Initializes a new instance of the BlendRange class.

Public Instance Properties

Destination | Gets or sets the destination blend range.
Source | Gets or sets the source blend range.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BlendRange Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


BlendRange Constructor

Initializes a new instance of the BlendRange class.

public BlendRange();

See Also

BlendRange Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


BlendRange Properties

The properties of the BlendRange class are listed below. For a complete list of BlendRange class members, see the BlendRange Members topic.

Public Instance Properties

Destination | Gets or sets the destination blend range.
Source | Gets or sets the source blend range.

See Also

BlendRange Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Destination Property

Aspose.Imaging Documentation

BlendRange.Destination Property

Gets or sets the destination blend range.

public int Destination {get; set;}

Property Value

The destination blend range.

See Also

BlendRange Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Source Property

Aspose.Imaging Documentation

BlendRange.Source Property

Gets or sets the source blend range.

public int Source {get; set;}

Property Value

The source blend range.

See Also

BlendRange Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ChannelInformation Class

The channel information.

For a list of all members of this type, see ChannelInformation Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.ChannelInformation

public class ChannelInformation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ChannelInformation Members | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ChannelInformation Members

ChannelInformation overview

Public Instance Constructors

ChannelInformation Constructor Initializes a new instance of the ChannelInformation class.

Public Instance Properties

ChannelID | Gets or sets the channel ID.
CompressionMethod | Gets or sets the compression method.
Length | Gets the channel length in bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChannelInformation Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ChannelInformation Constructor

Initializes a new instance of the ChannelInformation class.

public ChannelInformation();

See Also

ChannelInformation Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ChannelInformation Properties

The properties of the ChannelInformation class are listed below. For a complete list of ChannelInformation class members, see the ChannelInformation Members topic.

Public Instance Properties

ChannelID | Gets or sets the channel ID.
CompressionMethod | Gets or sets the compression method.
Length | Gets the channel length in bytes.

See Also

ChannelInformation Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ChannelID Property

Aspose.Imaging Documentation

ChannelInformation.ChannelID Property

Gets or sets the channel ID.

public short ChannelID {get; set;}

Property Value

The channel ID.

See Also

ChannelInformation Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


CompressionMethod Property

Aspose.Imaging Documentation

ChannelInformation.CompressionMethod Property

Gets or sets the compression method.

public CompressionMethod CompressionMethod {get; set;}

Property Value

The compression method.

See Also

ChannelInformation Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Length Property

Aspose.Imaging Documentation

ChannelInformation.Length Property

Gets the channel length in bytes.

public int Length {get;}

See Also

ChannelInformation Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


GlobalLayerMaskInfo Class

The global layer mask section.

For a list of all members of this type, see GlobalLayerMaskInfo Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.GlobalLayerMaskInfo

public sealed class GlobalLayerMaskInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GlobalLayerMaskInfo Members | Aspose.Imaging.FileFormats.Psd.Layers Namespace


GlobalLayerMaskInfo Members

GlobalLayerMaskInfo overview

Public Instance Constructors

GlobalLayerMaskInfo Constructor Initializes a new instance of the GlobalLayerMaskInfo class.

Public Instance Properties

AlphaMask | Gets or sets the alpha mask.
BlueMask | Gets or sets the blue mask.
GreenMask | Gets or sets the green mask.
Kind | Gets or sets the kind. 0 = Color selected--i.e. inverted; 1 = Color protected; 128 = use value stored per layer. This value is preferred. The others are for backward compatibility with beta versions.
Length | Gets the global layer mask section length in bytes.
Opacity | Gets or sets global layers opacity. 0 = transparent, 100 = opaque.
OverlayColorSpace | Gets or sets the overlay color space (undocumented value).
RedMask | Gets or sets the red mask.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GlobalLayerMaskInfo Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


GlobalLayerMaskInfo Constructor

Initializes a new instance of the GlobalLayerMaskInfo class.

public GlobalLayerMaskInfo();

See Also

GlobalLayerMaskInfo Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


GlobalLayerMaskInfo Properties

The properties of the GlobalLayerMaskInfo class are listed below. For a complete list of GlobalLayerMaskInfo class members, see the GlobalLayerMaskInfo Members topic.

Public Instance Properties

AlphaMask | Gets or sets the alpha mask.
BlueMask | Gets or sets the blue mask.
GreenMask | Gets or sets the green mask.
Kind | Gets or sets the kind. 0 = Color selected--i.e. inverted; 1 = Color protected; 128 = use value stored per layer. This value is preferred. The others are for backward compatibility with beta versions.
Length | Gets the global layer mask section length in bytes.
Opacity | Gets or sets global layers opacity. 0 = transparent, 100 = opaque.
OverlayColorSpace | Gets or sets the overlay color space (undocumented value).
RedMask | Gets or sets the red mask.

See Also

GlobalLayerMaskInfo Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


AlphaMask Property

Aspose.Imaging Documentation

GlobalLayerMaskInfo.AlphaMask Property

Gets or sets the alpha mask.

public short AlphaMask {get; set;}

Property Value

The alpha mask.

See Also

GlobalLayerMaskInfo Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


BlueMask Property

Aspose.Imaging Documentation

GlobalLayerMaskInfo.BlueMask Property

Gets or sets the blue mask.

public short BlueMask {get; set;}

Property Value

The blue mask.

See Also

GlobalLayerMaskInfo Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


GreenMask Property

Aspose.Imaging Documentation

GlobalLayerMaskInfo.GreenMask Property

Gets or sets the green mask.

public short GreenMask {get; set;}

Property Value

The green mask.

See Also

GlobalLayerMaskInfo Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Kind Property

Aspose.Imaging Documentation

GlobalLayerMaskInfo.Kind Property

Gets or sets the kind. 0 = Color selected--i.e. inverted; 1 = Color protected; 128 = use value stored per layer. This value is preferred. The others are for backward compatibility with beta versions.

public byte Kind {get; set;}

Property Value

The kind.

See Also

GlobalLayerMaskInfo Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Length Property

Aspose.Imaging Documentation

GlobalLayerMaskInfo.Length Property

Gets the global layer mask section length in bytes.

public int Length {get;}

See Also

GlobalLayerMaskInfo Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Opacity Property

Aspose.Imaging Documentation

GlobalLayerMaskInfo.Opacity Property

Gets or sets global layers opacity. 0 = transparent, 100 = opaque.

public short Opacity {get; set;}

Property Value

The global layers opacity.

See Also

GlobalLayerMaskInfo Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


OverlayColorSpace Property

Aspose.Imaging Documentation

GlobalLayerMaskInfo.OverlayColorSpace Property

Gets or sets the overlay color space (undocumented value).

public short OverlayColorSpace {get; set;}

Property Value

The overlay color space.

See Also

GlobalLayerMaskInfo Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


RedMask Property

Aspose.Imaging Documentation

GlobalLayerMaskInfo.RedMask Property

Gets or sets the red mask.

public short RedMask {get; set;}

Property Value

The red mask.

See Also

GlobalLayerMaskInfo Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ILayerResourceLoader Interface

The layer resource loader.

For a list of all members of this type, see ILayerResourceLoader Members.

public interface ILayerResourceLoader

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ILayerResourceLoader Members | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ILayerResourceLoader Members

ILayerResourceLoader overview

Public Instance Methods

CanLoad | Determines whether layer resource can be loaded from the specified StreamContainer.
Load | Loads the LayerResource.

See Also

ILayerResourceLoader Interface | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ILayerResourceLoader Methods

The methods of the ILayerResourceLoader interface are listed below. For a complete list of ILayerResourceLoader interface members, see the ILayerResourceLoader Members topic.

Public Instance Methods

CanLoad | Determines whether layer resource can be loaded from the specified StreamContainer.
Load | Loads the LayerResource.

See Also

ILayerResourceLoader Interface | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ILayerResourceLoader.CanLoad Method

Determines whether layer resource can be loaded from the specified StreamContainer.

bool CanLoad(
StreamContainer streamContainer,
int psdVersion
);

Parameters

streamContainer
The stream container.
psdVersion
The PSD version.

Return Value

true if layer resource can be loaded from the specified StreamContainer; otherwise, false.

See Also

ILayerResourceLoader Interface | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ILayerResourceLoader.Load Method

Loads the LayerResource.

LayerResource Load(
StreamContainer streamContainer,
int psdVersion
);

Parameters

streamContainer
The stream container to load from.
psdVersion
The PSD version.

Return Value

The loaded resource.

See Also

ILayerResourceLoader Interface | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Layer Class

The psd layer.

For a list of all members of this type, see Layer Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.Layer

public class Layer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Layer Members | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Layer Members

Layer overview

Public Instance Constructors

Layer Constructor Initializes a new instance of the Layer class. Constructor for lazy initialization.

Public Instance Properties

BlendModeKey | Gets or sets the blend mode key.
BlendModeSignature | Gets the blend mode signature.
Bottom | Gets or sets the bottom layer position.
Bounds | Gets the bounds.
ChannelInformation | Gets or sets the channel information.
ChannelsCount | Gets the layer's channels count.
Clipping | Gets or sets the layer clipping. 0 = base, 1 = non-base.
ExtraLength | Gets the layer extra information length in bytes.
Filler | Gets or sets the layer filler.
Flags | Gets or sets the layer flags. bit 0 = transparency protected; bit 1 = visible; bit 2 = obsolete; bit 3 = 1 for Photoshop 5.0 and later, tells if bit 4 has useful information; bit 4 = pixel data irrelevant to appearance of document.
LayerBlendingRangesData | Gets or sets the layer blending ranges data.
LayerMaskData | Gets or sets the layer mask data.
Left | Gets or sets the left layer position.
Length | Gets the overall layer length in bytes.
Name | Gets or sets the layer name.
Opacity | Gets or sets the layer opacity. 0 = transparent, 255 = opaque.
Resources | Gets or sets the layer resources.
Right | Gets or sets the right layer position.
Top | Gets or sets the top layer position.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Layer Constructor

Initializes a new instance of the Layer class. Constructor for lazy initialization.

public Layer();

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Layer Properties

The properties of the Layer class are listed below. For a complete list of Layer class members, see the Layer Members topic.

Public Instance Properties

BlendModeKey | Gets or sets the blend mode key.
BlendModeSignature | Gets the blend mode signature.
Bottom | Gets or sets the bottom layer position.
Bounds | Gets the bounds.
ChannelInformation | Gets or sets the channel information.
ChannelsCount | Gets the layer's channels count.
Clipping | Gets or sets the layer clipping. 0 = base, 1 = non-base.
ExtraLength | Gets the layer extra information length in bytes.
Filler | Gets or sets the layer filler.
Flags | Gets or sets the layer flags. bit 0 = transparency protected; bit 1 = visible; bit 2 = obsolete; bit 3 = 1 for Photoshop 5.0 and later, tells if bit 4 has useful information; bit 4 = pixel data irrelevant to appearance of document.
LayerBlendingRangesData | Gets or sets the layer blending ranges data.
LayerMaskData | Gets or sets the layer mask data.
Left | Gets or sets the left layer position.
Length | Gets the overall layer length in bytes.
Name | Gets or sets the layer name.
Opacity | Gets or sets the layer opacity. 0 = transparent, 255 = opaque.
Resources | Gets or sets the layer resources.
Right | Gets or sets the right layer position.
Top | Gets or sets the top layer position.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


BlendModeKey Property

Aspose.Imaging Documentation

Layer.BlendModeKey Property

Gets or sets the blend mode key.

public BlendMode BlendModeKey {get; set;}

Property Value

The blend mode key.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


BlendModeSignature Property

Aspose.Imaging Documentation

Layer.BlendModeSignature Property

Gets the blend mode signature.

public int BlendModeSignature {get;}

Property Value

The blend mode signature.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Bottom Property

Aspose.Imaging Documentation

Layer.Bottom Property

Gets or sets the bottom layer position.

public int Bottom {get; set;}

Property Value

The bottom layer position.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Bounds Property

Aspose.Imaging Documentation

Layer.Bounds Property

Gets the bounds.

public Rectangle Bounds {get;}

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ChannelInformation Property

Aspose.Imaging Documentation

Layer.ChannelInformation Property

Gets or sets the channel information.

public ChannelInformation[] ChannelInformation {get; set;}

Property Value

The channel information.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ChannelsCount Property

Aspose.Imaging Documentation

Layer.ChannelsCount Property

Gets the layer's channels count.

public ushort ChannelsCount {get;}

Property Value

The layer's channels count.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Clipping Property

Aspose.Imaging Documentation

Layer.Clipping Property

Gets or sets the layer clipping. 0 = base, 1 = non-base.

public byte Clipping {get; set;}

Property Value

The layer clipping.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ExtraLength Property

Aspose.Imaging Documentation

Layer.ExtraLength Property

Gets the layer extra information length in bytes.

public int ExtraLength {get;}

Property Value

The extra layer length.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Filler Property

Aspose.Imaging Documentation

Layer.Filler Property

Gets or sets the layer filler.

public byte Filler {get; set;}

Property Value

The layer filler.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Flags Property

Aspose.Imaging Documentation

Layer.Flags Property

Gets or sets the layer flags. bit 0 = transparency protected; bit 1 = visible; bit 2 = obsolete; bit 3 = 1 for Photoshop 5.0 and later, tells if bit 4 has useful information; bit 4 = pixel data irrelevant to appearance of document.

public byte Flags {get; set;}

Property Value

The layer flags.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerBlendingRangesData Property

Aspose.Imaging Documentation

Layer.LayerBlendingRangesData Property

Gets or sets the layer blending ranges data.

public LayerBlendingRangesData LayerBlendingRangesData {get; set;}

Property Value

The layer blending ranges data.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskData Property

Aspose.Imaging Documentation

Layer.LayerMaskData Property

Gets or sets the layer mask data.

public LayerMaskData LayerMaskData {get; set;}

Property Value

The layer mask data.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Left Property

Aspose.Imaging Documentation

Layer.Left Property

Gets or sets the left layer position.

public int Left {get; set;}

Property Value

The left layer position.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Length Property

Aspose.Imaging Documentation

Layer.Length Property

Gets the overall layer length in bytes.

public int Length {get;}

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Name Property

Aspose.Imaging Documentation

Layer.Name Property

Gets or sets the layer name.

public string Name {get; set;}

Property Value

The layer name.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Opacity Property

Aspose.Imaging Documentation

Layer.Opacity Property

Gets or sets the layer opacity. 0 = transparent, 255 = opaque.

public byte Opacity {get; set;}

Property Value

The layer opacity.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Resources Property

Aspose.Imaging Documentation

Layer.Resources Property

Gets or sets the layer resources.

public LayerResource[] Resources {get; set;}

Property Value

The layer resources.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Right Property

Aspose.Imaging Documentation

Layer.Right Property

Gets or sets the right layer position.

public int Right {get; set;}

Property Value

The right layer position.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Top Property

Aspose.Imaging Documentation

Layer.Top Property

Gets or sets the top layer position.

public int Top {get; set;}

Property Value

The top layer position.

See Also

Layer Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerBlendingRangesData Class

The layer blending ranges data.

For a list of all members of this type, see LayerBlendingRangesData Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerBlendingRangesData

public sealed class LayerBlendingRangesData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

LayerBlendingRangesData Members | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerBlendingRangesData Members

LayerBlendingRangesData overview

Public Instance Constructors

LayerBlendingRangesData Constructor Initializes a new instance of the LayerBlendingRangesData class.

Public Instance Properties

ChannelBlendRanges | Gets or sets the channel blend ranges.
CompositeBlendRange | Gets or sets the composite blend ranges.
Length | Gets the length of layer blending ranges data in bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LayerBlendingRangesData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerBlendingRangesData Constructor

Initializes a new instance of the LayerBlendingRangesData class.

public LayerBlendingRangesData();

See Also

LayerBlendingRangesData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerBlendingRangesData Properties

The properties of the LayerBlendingRangesData class are listed below. For a complete list of LayerBlendingRangesData class members, see the LayerBlendingRangesData Members topic.

Public Instance Properties

ChannelBlendRanges | Gets or sets the channel blend ranges.
CompositeBlendRange | Gets or sets the composite blend ranges.
Length | Gets the length of layer blending ranges data in bytes.

See Also

LayerBlendingRangesData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


ChannelBlendRanges Property

Aspose.Imaging Documentation

LayerBlendingRangesData.ChannelBlendRanges Property

Gets or sets the channel blend ranges.

public BlendRange[] ChannelBlendRanges {get; set;}

Property Value

The channel blend ranges.

See Also

LayerBlendingRangesData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


CompositeBlendRange Property

Aspose.Imaging Documentation

LayerBlendingRangesData.CompositeBlendRange Property

Gets or sets the composite blend ranges.

public BlendRange CompositeBlendRange {get; set;}

Property Value

The composite blend ranges.

See Also

LayerBlendingRangesData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Length Property

Aspose.Imaging Documentation

LayerBlendingRangesData.Length Property

Gets the length of layer blending ranges data in bytes.

public int Length {get;}

Property Value

The length of layer blending ranges data.

See Also

LayerBlendingRangesData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskData Class

The layer mask data.

For a list of all members of this type, see LayerMaskData Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerMaskData
Aspose.Imaging.FileFormats.Psd.Layers.LayerMaskDataFull
Aspose.Imaging.FileFormats.Psd.Layers.LayerMaskDataShort

public abstract class LayerMaskData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

LayerMaskData Members | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskData Members

LayerMaskData overview

Public Instance Properties

Bottom | Gets or sets the bottom layer mask position.
DataSize | Gets the size of the layer mask mask data.
DefaultColor | Gets or sets the default color.
Flags | Gets or sets the layer mask flags.
Left | Gets or sets the left layer mask position.
Right | Gets or sets the right layer mask position.
Top | Gets or sets the top layer mask position.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

LayerMaskData Constructor Initializes a new instance of the LayerMaskData class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SaveCommon Saves the common info.

See Also

LayerMaskData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskData Constructor

Initializes a new instance of the LayerMaskData class.

protected LayerMaskData(
int dataSize
);

Parameters

dataSize
The data size.

See Also

LayerMaskData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskData Properties

The properties of the LayerMaskData class are listed below. For a complete list of LayerMaskData class members, see the LayerMaskData Members topic.

Public Instance Properties

Bottom | Gets or sets the bottom layer mask position.
DataSize | Gets the size of the layer mask mask data.
DefaultColor | Gets or sets the default color.
Flags | Gets or sets the layer mask flags.
Left | Gets or sets the left layer mask position.
Right | Gets or sets the right layer mask position.
Top | Gets or sets the top layer mask position.

See Also

LayerMaskData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Bottom Property

Aspose.Imaging Documentation

LayerMaskData.Bottom Property

Gets or sets the bottom layer mask position.

public int Bottom {get; set;}

Property Value

The bottom layer mask position.

See Also

LayerMaskData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


DataSize Property

Aspose.Imaging Documentation

LayerMaskData.DataSize Property

Gets the size of the layer mask mask data.

public int DataSize {get;}

Property Value

The size of the layer mask mask data.

See Also

LayerMaskData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


DefaultColor Property

Aspose.Imaging Documentation

LayerMaskData.DefaultColor Property

Gets or sets the default color.

public byte DefaultColor {get; set;}

Property Value

The default color.

See Also

LayerMaskData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Flags Property

Aspose.Imaging Documentation

LayerMaskData.Flags Property

Gets or sets the layer mask flags.

public LayerMaskFlags Flags {get; set;}

Property Value

The layer mask flags.

See Also

LayerMaskData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Left Property

Aspose.Imaging Documentation

LayerMaskData.Left Property

Gets or sets the left layer mask position.

public int Left {get; set;}

Property Value

The left layer mask position.

See Also

LayerMaskData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Right Property

Aspose.Imaging Documentation

LayerMaskData.Right Property

Gets or sets the right layer mask position.

public int Right {get; set;}

Property Value

The right layer mask position.

See Also

LayerMaskData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Top Property

Aspose.Imaging Documentation

LayerMaskData.Top Property

Gets or sets the top layer mask position.

public int Top {get; set;}

Property Value

The top layer mask position.

See Also

LayerMaskData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskData Methods

The methods of the LayerMaskData class are listed below. For a complete list of LayerMaskData class members, see the LayerMaskData Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

SaveCommon Saves the common info.

See Also

LayerMaskData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskData.SaveCommon Method

Saves the common info.

protected internal void SaveCommon(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container.

See Also

LayerMaskData Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskDataFull Class

The full layer mask information.

For a list of all members of this type, see LayerMaskDataFull Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerMaskData
Aspose.Imaging.FileFormats.Psd.Layers.LayerMaskDataFull

public sealed class LayerMaskDataFull : LayerMaskData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

LayerMaskDataFull Members | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskDataFull Members

LayerMaskDataFull overview

Public Instance Constructors

LayerMaskDataFull Constructor Initializes a new instance of the LayerMaskDataFull class.

Public Instance Properties

BackgroundColor | Gets or sets the background color.
Bottom (inherited from LayerMaskData) | Gets or sets the bottom layer mask position.
DataSize (inherited from LayerMaskData) | Gets the size of the layer mask mask data.
DefaultColor (inherited from LayerMaskData) | Gets or sets the default color.
EnclosingBottom | Gets or sets the enclosing bottom layer mask position.
EnclosingLeft | Gets or sets the enclosing left layer mask position.
EnclosingRight | Gets or sets the enclosing right layer mask position.
EnclosingTop | Gets or sets the enclosing top layer mask position.
Flags (inherited from LayerMaskData) | Gets or sets the layer mask flags.
Left (inherited from LayerMaskData) | Gets or sets the left layer mask position.
RealFlags | Gets or sets the real layer mask flags.
Right (inherited from LayerMaskData) | Gets or sets the right layer mask position.
Top (inherited from LayerMaskData) | Gets or sets the top layer mask position.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

SaveCommon (inherited from LayerMaskData) Saves the common info.

See Also

LayerMaskDataFull Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskDataFull Constructor

Initializes a new instance of the LayerMaskDataFull class.

public LayerMaskDataFull();

See Also

LayerMaskDataFull Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskDataFull Properties

The properties of the LayerMaskDataFull class are listed below. For a complete list of LayerMaskDataFull class members, see the LayerMaskDataFull Members topic.

Public Instance Properties

BackgroundColor | Gets or sets the background color.
Bottom (inherited from LayerMaskData) | Gets or sets the bottom layer mask position.
DataSize (inherited from LayerMaskData) | Gets the size of the layer mask mask data.
DefaultColor (inherited from LayerMaskData) | Gets or sets the default color.
EnclosingBottom | Gets or sets the enclosing bottom layer mask position.
EnclosingLeft | Gets or sets the enclosing left layer mask position.
EnclosingRight | Gets or sets the enclosing right layer mask position.
EnclosingTop | Gets or sets the enclosing top layer mask position.
Flags (inherited from LayerMaskData) | Gets or sets the layer mask flags.
Left (inherited from LayerMaskData) | Gets or sets the left layer mask position.
RealFlags | Gets or sets the real layer mask flags.
Right (inherited from LayerMaskData) | Gets or sets the right layer mask position.
Top (inherited from LayerMaskData) | Gets or sets the top layer mask position.

See Also

LayerMaskDataFull Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


BackgroundColor Property

Aspose.Imaging Documentation

LayerMaskDataFull.BackgroundColor Property

Gets or sets the background color.

public byte BackgroundColor {get; set;}

Property Value

The background color.

See Also

LayerMaskDataFull Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


EnclosingBottom Property

Aspose.Imaging Documentation

LayerMaskDataFull.EnclosingBottom Property

Gets or sets the enclosing bottom layer mask position.

public int EnclosingBottom {get; set;}

Property Value

The bottom layer mask position.

See Also

LayerMaskDataFull Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


EnclosingLeft Property

Aspose.Imaging Documentation

LayerMaskDataFull.EnclosingLeft Property

Gets or sets the enclosing left layer mask position.

public int EnclosingLeft {get; set;}

Property Value

The left layer mask position.

See Also

LayerMaskDataFull Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


EnclosingRight Property

Aspose.Imaging Documentation

LayerMaskDataFull.EnclosingRight Property

Gets or sets the enclosing right layer mask position.

public int EnclosingRight {get; set;}

Property Value

The right layer mask position.

See Also

LayerMaskDataFull Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


EnclosingTop Property

Aspose.Imaging Documentation

LayerMaskDataFull.EnclosingTop Property

Gets or sets the enclosing top layer mask position.

public int EnclosingTop {get; set;}

Property Value

The top layer mask position.

See Also

LayerMaskDataFull Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


RealFlags Property

Aspose.Imaging Documentation

LayerMaskDataFull.RealFlags Property

Gets or sets the real layer mask flags.

public LayerMaskFlags RealFlags {get; set;}

Property Value

The real layer mask flags.

See Also

LayerMaskDataFull Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskDataShort Class

The short layer mask information.

For a list of all members of this type, see LayerMaskDataShort Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerMaskData
Aspose.Imaging.FileFormats.Psd.Layers.LayerMaskDataShort

public sealed class LayerMaskDataShort : LayerMaskData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

LayerMaskDataShort Members | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskDataShort Members

LayerMaskDataShort overview

Public Instance Constructors

LayerMaskDataShort Constructor Initializes a new instance of the LayerMaskDataShort class.

Public Instance Properties

Bottom (inherited from LayerMaskData) | Gets or sets the bottom layer mask position.
DataSize (inherited from LayerMaskData) | Gets the size of the layer mask mask data.
DefaultColor (inherited from LayerMaskData) | Gets or sets the default color.
Flags (inherited from LayerMaskData) | Gets or sets the layer mask flags.
Left (inherited from LayerMaskData) | Gets or sets the left layer mask position.
Padding | Gets or sets the layer mask padding.
Right (inherited from LayerMaskData) | Gets or sets the right layer mask position.
Top (inherited from LayerMaskData) | Gets or sets the top layer mask position.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

SaveCommon (inherited from LayerMaskData) Saves the common info.

See Also

LayerMaskDataShort Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskDataShort Constructor

Initializes a new instance of the LayerMaskDataShort class.

public LayerMaskDataShort();

See Also

LayerMaskDataShort Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskDataShort Properties

The properties of the LayerMaskDataShort class are listed below. For a complete list of LayerMaskDataShort class members, see the LayerMaskDataShort Members topic.

Public Instance Properties

Bottom (inherited from LayerMaskData) | Gets or sets the bottom layer mask position.
DataSize (inherited from LayerMaskData) | Gets the size of the layer mask mask data.
DefaultColor (inherited from LayerMaskData) | Gets or sets the default color.
Flags (inherited from LayerMaskData) | Gets or sets the layer mask flags.
Left (inherited from LayerMaskData) | Gets or sets the left layer mask position.
Padding | Gets or sets the layer mask padding.
Right (inherited from LayerMaskData) | Gets or sets the right layer mask position.
Top (inherited from LayerMaskData) | Gets or sets the top layer mask position.

See Also

LayerMaskDataShort Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Padding Property

Aspose.Imaging Documentation

LayerMaskDataShort.Padding Property

Gets or sets the layer mask padding.

public short Padding {get; set;}

Property Value

The layer mask padding.

See Also

LayerMaskDataShort Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerMaskFlags Enumeration

The layer mask flags

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum LayerMaskFlags

Members

Member Name | Description | Value
None | No flags defined. | 0
RelativeToLayer | Position is relative to layer. | 1
Disabled | Layer mask is disabled. | 2
InvertedWhenBlending | Invert layer mask when blending. | 4

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResource Class

Represents layer info.

For a list of all members of this type, see LayerResource Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResource
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfo6Resource
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.UnknownResource

public abstract class LayerResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

LayerResource Members | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResource Members

LayerResource overview

Public Instance Properties

Key | Gets the layer resource key.
Length | Gets the layer resource length in bytes.
PsdVersion | Gets the minimal psd version required for layer resource. 0 indicates no restrictions.
Signature | Gets the layer resource signature.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the resource to the specified stream container.
ToString | Returns a String that represents this instance.

Protected Instance Constructors

LayerResource Constructor Initializes a new instance of the LayerResource class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveResourceHeader | Saves the resource header.

See Also

LayerResource Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResource Constructor

Initializes a new instance of the LayerResource class.

protected LayerResource();

See Also

LayerResource Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResource Properties

The properties of the LayerResource class are listed below. For a complete list of LayerResource class members, see the LayerResource Members topic.

Public Instance Properties

Key | Gets the layer resource key.
Length | Gets the layer resource length in bytes.
PsdVersion | Gets the minimal psd version required for layer resource. 0 indicates no restrictions.
Signature | Gets the layer resource signature.

See Also

LayerResource Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Key Property

Aspose.Imaging Documentation

LayerResource.Key Property

Gets the layer resource key.

public abstract int Key {get;}

See Also

LayerResource Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Length Property

Aspose.Imaging Documentation

LayerResource.Length Property

Gets the layer resource length in bytes.

public abstract int Length {get;}

See Also

LayerResource Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


PsdVersion Property

Aspose.Imaging Documentation

LayerResource.PsdVersion Property

Gets the minimal psd version required for layer resource. 0 indicates no restrictions.

public abstract int PsdVersion {get;}

See Also

LayerResource Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Signature Property

Aspose.Imaging Documentation

LayerResource.Signature Property

Gets the layer resource signature.

public abstract int Signature {get;}

See Also

LayerResource Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResource Methods

The methods of the LayerResource class are listed below. For a complete list of LayerResource class members, see the LayerResource Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the resource to the specified stream container.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveResourceHeader | Saves the resource header.

See Also

LayerResource Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResource.Save Method

Saves the resource to the specified stream container.

public abstract void Save(
StreamContainer streamContainer,
int psdVersion
);

Parameters

streamContainer
The stream container to save to.
psdVersion
The PSD version.

See Also

LayerResource Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResource.SaveResourceHeader Method

Saves the resource header.

protected void SaveResourceHeader(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container.

See Also

LayerResource Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResource.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

LayerResource Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResourcesRegistry Class

Represents the layer resources registry.

For a list of all members of this type, see LayerResourcesRegistry Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResourcesRegistry

public abstract sealed class LayerResourcesRegistry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

LayerResourcesRegistry Members | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResourcesRegistry Members

LayerResourcesRegistry overview

Public Static Properties

RegisteredDescriptors Gets the registered descriptors.

Public Static Methods

GetFirstSupportedDescriptor | Gets the first supported opener descriptor.
GetFirstSupportedDescriptorByTypeName | Gets the first supported descriptor by its type name.
LoadResourceByFirstSupportedDescriptor | Loads LayerResource using first found opener suitable for the specified stream.
RegisterOpener | Registers the opener.
UnregisterOpener | Unregisters the opener.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LayerResourcesRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResourcesRegistry Properties

The properties of the LayerResourcesRegistry class are listed below. For a complete list of LayerResourcesRegistry class members, see the LayerResourcesRegistry Members topic.

Public Static Properties

RegisteredDescriptors Gets the registered descriptors.

See Also

LayerResourcesRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


RegisteredDescriptors Property

Aspose.Imaging Documentation

LayerResourcesRegistry.RegisteredDescriptors Property

Gets the registered descriptors.

public static ILayerResourceLoader[] RegisteredDescriptors {get;}

Property Value

The registered descriptors.

See Also

LayerResourcesRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResourcesRegistry Methods

The methods of the LayerResourcesRegistry class are listed below. For a complete list of LayerResourcesRegistry class members, see the LayerResourcesRegistry Members topic.

Public Static Methods

GetFirstSupportedDescriptor | Gets the first supported opener descriptor.
GetFirstSupportedDescriptorByTypeName | Gets the first supported descriptor by its type name.
LoadResourceByFirstSupportedDescriptor | Loads LayerResource using first found opener suitable for the specified stream.
RegisterOpener | Registers the opener.
UnregisterOpener | Unregisters the opener.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LayerResourcesRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResourcesRegistry.GetFirstSupportedDescriptor Method

Gets the first supported opener descriptor.

public static ILayerResourceLoader GetFirstSupportedDescriptor(
Stream stream,
int psdVersion
);

Parameters

stream
The stream.
psdVersion
The PSD version.

Return Value

The layer resource loader descriptor or null if no loader descriptor supported for such stream.

Remarks

The first loader will be actually the last registered.

See Also

LayerResourcesRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResourcesRegistry.GetFirstSupportedDescriptorByTypeName Method

Gets the first supported descriptor by its type name.

public static ILayerResourceLoader GetFirstSupportedDescriptorByTypeName(
string descriptorTypeName
);

Parameters

descriptorTypeName
The descriptor type name.

Return Value

The first found opener descriptor or null if not such descriptor is found.

Remarks

The first opener descriptor will be actually the last registered.

See Also

LayerResourcesRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResourcesRegistry.LoadResourceByFirstSupportedDescriptor Method

Loads LayerResource using first found opener suitable for the specified stream.

public static LayerResource LoadResourceByFirstSupportedDescriptor(
Stream stream,
int psdVersion
);

Parameters

stream
The stream.
psdVersion
The PSD version.

Return Value

The loaded LayerResource or null if no opener is found.

Remarks

The first opener will be actually the last registered.

See Also

LayerResourcesRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResourcesRegistry.RegisterOpener Method

Registers the opener.

public static void RegisterOpener(
ILayerResourceLoader openerDescriptor
);

Parameters

openerDescriptor
The opener descriptor to register.

See Also

LayerResourcesRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


LayerResourcesRegistry.UnregisterOpener Method

Unregisters the opener.

public static void UnregisterOpener(
ILayerResourceLoader openerDescriptor
);

Parameters

openerDescriptor
The opener descriptor to unregister.

See Also

LayerResourcesRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers Namespace


Aspose.Imaging.FileFormats.Psd.Layers.LayerResources

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace

Namespace hierarchy

Classes

Class | Description
ClassID | The PSD Class ID object.
OSTypeStructure | Represents the OS type structure.
OSTypeStructuresRegistry | Represents the OSTypeStructure resources registry.
TypeToolFontInfo | Contains information about type tool font.
TypeToolInfo6Resource | The type tool information. For PSD version higher or equal to the 6.0.
TypeToolLineInfo | Type tool line info.
TypeToolStyleInfo | Type tool style information.
UnknownResource | The unknown resource.

Interfaces

Interface | Description
IOSTypeStructureLoader | The OSTypeStructure resource loader.


ClassID Class

The PSD Class ID object.

For a list of all members of this type, see ClassID Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.ClassID

public class ClassID

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ClassID Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


ClassID Members

ClassID overview

Public Instance Constructors

ClassID Overloaded. Initializes a new instance of the ClassID class.

Public Instance Properties

Bytes | Gets the bytes representing class ID.
ClassName | Gets the class name as ASCII encoding.
Length | Gets the class ID length in bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the class information to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ClassID Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


ClassID Constructor

Initializes a new instance of the ClassID class.

Overload List

Initializes a new instance of the ClassID class.

public ClassID(byte[]);

Initializes a new instance of the ClassID class.

public ClassID(int);

Initializes a new instance of the ClassID class.

public ClassID(string);

Initializes a new instance of the ClassID class.

public ClassID(uint);

See Also

ClassID Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


ClassID Constructor (Byte[])

Initializes a new instance of the ClassID class.

public ClassID(
byte[] classID
);

Parameters

classID
The class ID as series of bytes.

See Also

ClassID Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace | ClassID Constructor Overload List


ClassID Constructor (Int32)

Initializes a new instance of the ClassID class.

public ClassID(
int classID
);

Parameters

classID
The class ID.

See Also

ClassID Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace | ClassID Constructor Overload List


ClassID Constructor (UInt32)

Initializes a new instance of the ClassID class.

public ClassID(
uint classID
);

Parameters

classID
The class ID.

See Also

ClassID Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace | ClassID Constructor Overload List


ClassID Constructor (String)

Initializes a new instance of the ClassID class.

public ClassID(
string classID
);

Parameters

classID
The class ID in ASCII encoding.

See Also

ClassID Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace | ClassID Constructor Overload List


ClassID Properties

The properties of the ClassID class are listed below. For a complete list of ClassID class members, see the ClassID Members topic.

Public Instance Properties

Bytes | Gets the bytes representing class ID.
ClassName | Gets the class name as ASCII encoding.
Length | Gets the class ID length in bytes.

See Also

ClassID Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Bytes Property

Aspose.Imaging Documentation

ClassID.Bytes Property

Gets the bytes representing class ID.

public byte[] Bytes {get;}

See Also

ClassID Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


ClassName Property

Aspose.Imaging Documentation

ClassID.ClassName Property

Gets the class name as ASCII encoding.

public string ClassName {get;}

Property Value

The class name.

See Also

ClassID Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Length Property

Aspose.Imaging Documentation

ClassID.Length Property

Gets the class ID length in bytes.

public int Length {get;}

See Also

ClassID Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


ClassID Methods

The methods of the ClassID class are listed below. For a complete list of ClassID class members, see the ClassID Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the class information to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ClassID Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


ClassID.Save Method

Saves the class information to the specified stream container.

public void Save(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container to save to.

See Also

ClassID Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


IOSTypeStructureLoader Interface

The OSTypeStructure resource loader.

For a list of all members of this type, see IOSTypeStructureLoader Members.

public interface IOSTypeStructureLoader

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IOSTypeStructureLoader Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


IOSTypeStructureLoader Members

IOSTypeStructureLoader overview

Public Instance Methods

CanLoad | Determines whether OSTypeStructure resource can be loaded from the specified StreamContainer.
Load | Loads the OSTypeStructure.

See Also

IOSTypeStructureLoader Interface | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


IOSTypeStructureLoader Methods

The methods of the IOSTypeStructureLoader interface are listed below. For a complete list of IOSTypeStructureLoader interface members, see the IOSTypeStructureLoader Members topic.

Public Instance Methods

CanLoad | Determines whether OSTypeStructure resource can be loaded from the specified StreamContainer.
Load | Loads the OSTypeStructure.

See Also

IOSTypeStructureLoader Interface | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


IOSTypeStructureLoader.CanLoad Method

Determines whether OSTypeStructure resource can be loaded from the specified StreamContainer.

bool CanLoad(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container.

Return Value

true if OSTypeStructure resource can be loaded from the specified StreamContainer; otherwise, false.

See Also

IOSTypeStructureLoader Interface | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


IOSTypeStructureLoader.Load Method

Loads the OSTypeStructure.

OSTypeStructure Load(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container to load from.

Return Value

The loaded OSTypeStructure resource.

See Also

IOSTypeStructureLoader Interface | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructure Class

Represents the OS type structure.

For a list of all members of this type, see OSTypeStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Derived types

public abstract class OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

OSTypeStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructure Members

OSTypeStructure overview

Public Instance Constructors

OSTypeStructure Constructor Initializes a new instance of the OSTypeStructure class.

Public Instance Properties

Key | Gets the structure key.
KeyName | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHeaderLength | Gets the header length.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveData | Saves the data.

See Also

OSTypeStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructure Constructor

Initializes a new instance of the OSTypeStructure class.

public OSTypeStructure(
ClassID keyName
);

Parameters

keyName
The key name.

See Also

OSTypeStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructure Properties

The properties of the OSTypeStructure class are listed below. For a complete list of OSTypeStructure class members, see the OSTypeStructure Members topic.

Public Instance Properties

Key | Gets the structure key.
KeyName | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

See Also

OSTypeStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Key Property

Aspose.Imaging Documentation

OSTypeStructure.Key Property

Gets the structure key.

public abstract int Key {get;}

See Also

OSTypeStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


KeyName Property

Aspose.Imaging Documentation

OSTypeStructure.KeyName Property

Gets or sets the key name.

public ClassID KeyName {get; set;}

Property Value

The key name.

See Also

OSTypeStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Length Property

Aspose.Imaging Documentation

OSTypeStructure.Length Property

Gets the OSTypeStructure length in bytes.

public abstract int Length {get;}

See Also

OSTypeStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructure Methods

The methods of the OSTypeStructure class are listed below. For a complete list of OSTypeStructure class members, see the OSTypeStructure Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHeaderLength | Gets the header length.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveData | Saves the data.

See Also

OSTypeStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructure.GetHeaderLength Method

Gets the header length.

protected int GetHeaderLength();

Return Value

The header length

See Also

OSTypeStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructure.Save Method

Saves the structure to the specified stream container.

public void Save(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container.

See Also

OSTypeStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructure.SaveData Method

Saves the data.

protected abstract void SaveData(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container.

See Also

OSTypeStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructuresRegistry Class

Represents the OSTypeStructure resources registry.

For a list of all members of this type, see OSTypeStructuresRegistry Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructuresRegistry

public abstract sealed class OSTypeStructuresRegistry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

OSTypeStructuresRegistry Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructuresRegistry Members

OSTypeStructuresRegistry overview

Public Static Properties

RegisteredDescriptors Gets the registered descriptors.

Public Static Methods

GetFirstSupportedDescriptor | Gets the first supported opener descriptor.
GetFirstSupportedDescriptorByTypeName | Gets the first supported descriptor by its type name.
LoadResourceByFirstSupportedDescriptor | Loads OSTypeStructure using first found opener suitable for the specified stream.
RegisterOpener | Registers the opener.
UnregisterOpener | Unregisters the opener.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

OSTypeStructuresRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructuresRegistry Properties

The properties of the OSTypeStructuresRegistry class are listed below. For a complete list of OSTypeStructuresRegistry class members, see the OSTypeStructuresRegistry Members topic.

Public Static Properties

RegisteredDescriptors Gets the registered descriptors.

See Also

OSTypeStructuresRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


RegisteredDescriptors Property

Aspose.Imaging Documentation

OSTypeStructuresRegistry.RegisteredDescriptors Property

Gets the registered descriptors.

public static IOSTypeStructureLoader[] RegisteredDescriptors {get;}

Property Value

The registered descriptors.

See Also

OSTypeStructuresRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructuresRegistry Methods

The methods of the OSTypeStructuresRegistry class are listed below. For a complete list of OSTypeStructuresRegistry class members, see the OSTypeStructuresRegistry Members topic.

Public Static Methods

GetFirstSupportedDescriptor | Gets the first supported opener descriptor.
GetFirstSupportedDescriptorByTypeName | Gets the first supported descriptor by its type name.
LoadResourceByFirstSupportedDescriptor | Loads OSTypeStructure using first found opener suitable for the specified stream.
RegisterOpener | Registers the opener.
UnregisterOpener | Unregisters the opener.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

OSTypeStructuresRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructuresRegistry.GetFirstSupportedDescriptor Method

Gets the first supported opener descriptor.

public static IOSTypeStructureLoader GetFirstSupportedDescriptor(
Stream stream
);

Parameters

stream
The stream.

Return Value

The layer resource loader descriptor or null if no loader descriptor supported for such stream.

Remarks

The first loader will be actually the last registered.

See Also

OSTypeStructuresRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructuresRegistry.GetFirstSupportedDescriptorByTypeName Method

Gets the first supported descriptor by its type name.

public static IOSTypeStructureLoader GetFirstSupportedDescriptorByTypeName(
string descriptorTypeName
);

Parameters

descriptorTypeName
The descriptor type name.

Return Value

The first found opener descriptor or null if not such descriptor is found.

Remarks

The first opener descriptor will be actually the last registered.

See Also

OSTypeStructuresRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructuresRegistry.LoadResourceByFirstSupportedDescriptor Method

Loads OSTypeStructure using first found opener suitable for the specified stream.

public static OSTypeStructure LoadResourceByFirstSupportedDescriptor(
Stream stream
);

Parameters

stream
The stream.

Return Value

The loaded LayerResource or null if no opener is found.

Remarks

The first opener will be actually the last registered.

See Also

OSTypeStructuresRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructuresRegistry.RegisterOpener Method

Registers the opener.

public static void RegisterOpener(
IOSTypeStructureLoader openerDescriptor
);

Parameters

openerDescriptor
The opener descriptor to register.

See Also

OSTypeStructuresRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


OSTypeStructuresRegistry.UnregisterOpener Method

Unregisters the opener.

public static void UnregisterOpener(
IOSTypeStructureLoader openerDescriptor
);

Parameters

openerDescriptor
The opener descriptor to unregister.

See Also

OSTypeStructuresRegistry Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolFontInfo Class

Contains information about type tool font.

For a list of all members of this type, see TypeToolFontInfo Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolFontInfo

public class TypeToolFontInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TypeToolFontInfo Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolFontInfo Members

TypeToolFontInfo overview

Public Instance Constructors

TypeToolFontInfo Constructor Initializes a new instance of the TypeToolFontInfo class.

Public Instance Properties

DesignAxes | Gets or sets the design axes vector to follow.
DesignVectorValue | Gets or sets the design vector value.
FontFamily | Gets or sets the font family.
FontName | Gets or sets the font name.
FontStyle | Gets or sets the font style name.
FontTypeData | Gets or sets the font type data.
MarkValue | Gets or sets the mark value.
ScriptValue | Gets or sets the script value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the TypeToolFontInfo information to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolFontInfo Constructor

Initializes a new instance of the TypeToolFontInfo class.

public TypeToolFontInfo();

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolFontInfo Properties

The properties of the TypeToolFontInfo class are listed below. For a complete list of TypeToolFontInfo class members, see the TypeToolFontInfo Members topic.

Public Instance Properties

DesignAxes | Gets or sets the design axes vector to follow.
DesignVectorValue | Gets or sets the design vector value.
FontFamily | Gets or sets the font family.
FontName | Gets or sets the font name.
FontStyle | Gets or sets the font style name.
FontTypeData | Gets or sets the font type data.
MarkValue | Gets or sets the mark value.
ScriptValue | Gets or sets the script value.

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


DesignAxes Property

Aspose.Imaging Documentation

TypeToolFontInfo.DesignAxes Property

Gets or sets the design axes vector to follow.

public int DesignAxes {get; set;}

Property Value

The design axes vector to follow.

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


DesignVectorValue Property

Aspose.Imaging Documentation

TypeToolFontInfo.DesignVectorValue Property

Gets or sets the design vector value.

public int DesignVectorValue {get; set;}

Property Value

The design vector value.

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


FontFamily Property

Aspose.Imaging Documentation

TypeToolFontInfo.FontFamily Property

Gets or sets the font family.

public string FontFamily {get; set;}

Property Value

The font family.

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


FontName Property

Aspose.Imaging Documentation

TypeToolFontInfo.FontName Property

Gets or sets the font name.

public string FontName {get; set;}

Property Value

The font name.

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


FontStyle Property

Aspose.Imaging Documentation

TypeToolFontInfo.FontStyle Property

Gets or sets the font style name.

public string FontStyle {get; set;}

Property Value

The font style name.

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


FontTypeData Property

Aspose.Imaging Documentation

TypeToolFontInfo.FontTypeData Property

Gets or sets the font type data.

public int FontTypeData {get; set;}

Property Value

The font type data.

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


MarkValue Property

Aspose.Imaging Documentation

TypeToolFontInfo.MarkValue Property

Gets or sets the mark value.

public short MarkValue {get; set;}

Property Value

The mark value.

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


ScriptValue Property

Aspose.Imaging Documentation

TypeToolFontInfo.ScriptValue Property

Gets or sets the script value.

public short ScriptValue {get; set;}

Property Value

The script value.

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolFontInfo Methods

The methods of the TypeToolFontInfo class are listed below. For a complete list of TypeToolFontInfo class members, see the TypeToolFontInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the TypeToolFontInfo information to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolFontInfo.Save Method

Saves the TypeToolFontInfo information to the specified stream container.

public void Save(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container to save to.

See Also

TypeToolFontInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolInfo6Resource Class

The type tool information. For PSD version higher or equal to the 6.0.

For a list of all members of this type, see TypeToolInfo6Resource Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResource
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfo6Resource

public class TypeToolInfo6Resource : LayerResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TypeToolInfo6Resource Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolInfo6Resource Members

TypeToolInfo6Resource overview

Public Instance Constructors

TypeToolInfo6Resource Constructor Initializes a new instance of the TypeToolInfo6Resource class.

Public Instance Properties

Bottom | Gets or sets the bottom location.
ClassID | Gets or sets the class ID.
ClassName | Gets or sets the class name.
DescriptorVersion | Gets or sets the descriptor version.
Items | Gets or sets the items.
Key | Gets the layer resource key.
Left | Gets or sets the left location.
Length | Gets the layer resource length in bytes.
PsdVersion | Gets the minimal psd version required for layer resource. 0 indicates no restrictions.
Right | Gets or sets the right location.
Signature | Gets the layer resource signature.
TextVersion | Gets or sets the text version.
Top | Gets or sets the top location.
TransformMatrix | Gets or sets the transform matrix.
Version | Gets or sets the type tool version.
WarpClassID | Gets or sets the class ID.
WarpClassName | Gets or sets the warp class name.
WarpDescriptorVersion | Gets or sets the warp descriptor version.
WarpItems | Gets or sets the warp items.
WarpVersion | Gets or sets the warp version.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the resource to the specified stream container.
ToString (inherited from LayerResource) | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveResourceHeader (inherited from LayerResource) | Saves the resource header.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolInfo6Resource Constructor

Initializes a new instance of the TypeToolInfo6Resource class.

public TypeToolInfo6Resource(
ClassID classID,
ClassID warpClassID
);

Parameters

classID
The class ID.
warpClassID
The warp class ID.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolInfo6Resource Properties

The properties of the TypeToolInfo6Resource class are listed below. For a complete list of TypeToolInfo6Resource class members, see the TypeToolInfo6Resource Members topic.

Public Instance Properties

Bottom | Gets or sets the bottom location.
ClassID | Gets or sets the class ID.
ClassName | Gets or sets the class name.
DescriptorVersion | Gets or sets the descriptor version.
Items | Gets or sets the items.
Key | Gets the layer resource key.
Left | Gets or sets the left location.
Length | Gets the layer resource length in bytes.
PsdVersion | Gets the minimal psd version required for layer resource. 0 indicates no restrictions.
Right | Gets or sets the right location.
Signature | Gets the layer resource signature.
TextVersion | Gets or sets the text version.
Top | Gets or sets the top location.
TransformMatrix | Gets or sets the transform matrix.
Version | Gets or sets the type tool version.
WarpClassID | Gets or sets the class ID.
WarpClassName | Gets or sets the warp class name.
WarpDescriptorVersion | Gets or sets the warp descriptor version.
WarpItems | Gets or sets the warp items.
WarpVersion | Gets or sets the warp version.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Bottom Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.Bottom Property

Gets or sets the bottom location.

public int Bottom {get; set;}

Property Value

The bottom location.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


ClassID Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.ClassID Property

Gets or sets the class ID.

public ClassID ClassID {get; set;}

Property Value

The class ID.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


ClassName Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.ClassName Property

Gets or sets the class name.

public string ClassName {get; set;}

Property Value

The class name.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


DescriptorVersion Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.DescriptorVersion Property

Gets or sets the descriptor version.

public int DescriptorVersion {get; set;}

Property Value

The descriptor version.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Items Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.Items Property

Gets or sets the items.

public OSTypeStructure[] Items {get; set;}

Property Value

The items.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Key Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.Key Property

Gets the layer resource key.

public override int Key {get;}

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Left Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.Left Property

Gets or sets the left location.

public int Left {get; set;}

Property Value

The left location.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Length Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.Length Property

Gets the layer resource length in bytes.

public override int Length {get;}

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


PsdVersion Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.PsdVersion Property

Gets the minimal psd version required for layer resource. 0 indicates no restrictions.

public override int PsdVersion {get;}

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Right Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.Right Property

Gets or sets the right location.

public int Right {get; set;}

Property Value

The right location.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Signature Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.Signature Property

Gets the layer resource signature.

public override int Signature {get;}

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TextVersion Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.TextVersion Property

Gets or sets the text version.

public short TextVersion {get; set;}

Property Value

The text version.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Top Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.Top Property

Gets or sets the top location.

public int Top {get; set;}

Property Value

The top location.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TransformMatrix Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.TransformMatrix Property

Gets or sets the transform matrix.

public double[] TransformMatrix {get; set;}

Property Value

The transform matrix.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Version Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.Version Property

Gets or sets the type tool version.

public short Version {get; set;}

Property Value

The type tool version.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


WarpClassID Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.WarpClassID Property

Gets or sets the class ID.

public ClassID WarpClassID {get; set;}

Property Value

The class ID.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


WarpClassName Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.WarpClassName Property

Gets or sets the warp class name.

public string WarpClassName {get; set;}

Property Value

The warp class name.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


WarpDescriptorVersion Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.WarpDescriptorVersion Property

Gets or sets the warp descriptor version.

public int WarpDescriptorVersion {get; set;}

Property Value

The warp descriptor version.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


WarpItems Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.WarpItems Property

Gets or sets the warp items.

public OSTypeStructure[] WarpItems {get; set;}

Property Value

The warp items.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


WarpVersion Property

Aspose.Imaging Documentation

TypeToolInfo6Resource.WarpVersion Property

Gets or sets the warp version.

public short WarpVersion {get; set;}

Property Value

The warp version.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolInfo6Resource Methods

The methods of the TypeToolInfo6Resource class are listed below. For a complete list of TypeToolInfo6Resource class members, see the TypeToolInfo6Resource Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the resource to the specified stream container.
ToString (inherited from LayerResource) | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveResourceHeader (inherited from LayerResource) | Saves the resource header.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolInfo6Resource.Save Method

Saves the resource to the specified stream container.

public override void Save(
StreamContainer streamContainer,
int psdVersion
);

Parameters

streamContainer
The stream container to save to.
psdVersion
The PSD version.

See Also

TypeToolInfo6Resource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolLineInfo Class

Type tool line info.

For a list of all members of this type, see TypeToolLineInfo Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolLineInfo

public class TypeToolLineInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TypeToolLineInfo Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolLineInfo Members

TypeToolLineInfo overview

Public Instance Constructors

TypeToolLineInfo Constructor Initializes a new instance of the TypeToolLineInfo class.

Public Instance Properties

Alignment | Gets or sets the alignment.
Char | Gets or sets the char.
CharacterCount | Gets or sets the character count.
Orientation | Gets or sets the orientation.
Style | Gets or sets the style.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeToolLineInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolLineInfo Constructor

Initializes a new instance of the TypeToolLineInfo class.

public TypeToolLineInfo();

See Also

TypeToolLineInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolLineInfo Properties

The properties of the TypeToolLineInfo class are listed below. For a complete list of TypeToolLineInfo class members, see the TypeToolLineInfo Members topic.

Public Instance Properties

Alignment | Gets or sets the alignment.
Char | Gets or sets the char.
CharacterCount | Gets or sets the character count.
Orientation | Gets or sets the orientation.
Style | Gets or sets the style.

See Also

TypeToolLineInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Alignment Property

Aspose.Imaging Documentation

TypeToolLineInfo.Alignment Property

Gets or sets the alignment.

public short Alignment {get; set;}

Property Value

The alignment.

See Also

TypeToolLineInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Char Property

Aspose.Imaging Documentation

TypeToolLineInfo.Char Property

Gets or sets the char.

public char Char {get; set;}

Property Value

The char.

See Also

TypeToolLineInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


CharacterCount Property

Aspose.Imaging Documentation

TypeToolLineInfo.CharacterCount Property

Gets or sets the character count.

public int CharacterCount {get; set;}

Property Value

The character count.

See Also

TypeToolLineInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Orientation Property

Aspose.Imaging Documentation

TypeToolLineInfo.Orientation Property

Gets or sets the orientation.

public short Orientation {get; set;}

Property Value

The orientation.

See Also

TypeToolLineInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Style Property

Aspose.Imaging Documentation

TypeToolLineInfo.Style Property

Gets or sets the style.

public short Style {get; set;}

Property Value

The style.

See Also

TypeToolLineInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolStyleInfo Class

Type tool style information.

For a list of all members of this type, see TypeToolStyleInfo Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolStyleInfo

public class TypeToolStyleInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TypeToolStyleInfo Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolStyleInfo Members

TypeToolStyleInfo overview

Public Instance Constructors

TypeToolStyleInfo Constructor Initializes a new instance of the TypeToolStyleInfo class.

Public Instance Properties

AutoKern | Gets or sets a value indicating whether auto kerning is on or off.
BaseShiftValue | Gets or sets the base shift value.
FaceMarkValue | Gets or sets the face mark value.
KerningValue | Gets or sets the kerning value.
LeadingValue | Gets or sets the leading value.
MarkValue | Gets or sets the mark value.
RotateDown | Gets or sets a value indicating whether it is a rotate down style.
SizeValue | Gets or sets the size value.
TrackingValue | Gets or sets the tracking value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the TypeToolFontInfo information to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolStyleInfo Constructor

Initializes a new instance of the TypeToolStyleInfo class.

public TypeToolStyleInfo();

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolStyleInfo Properties

The properties of the TypeToolStyleInfo class are listed below. For a complete list of TypeToolStyleInfo class members, see the TypeToolStyleInfo Members topic.

Public Instance Properties

AutoKern | Gets or sets a value indicating whether auto kerning is on or off.
BaseShiftValue | Gets or sets the base shift value.
FaceMarkValue | Gets or sets the face mark value.
KerningValue | Gets or sets the kerning value.
LeadingValue | Gets or sets the leading value.
MarkValue | Gets or sets the mark value.
RotateDown | Gets or sets a value indicating whether it is a rotate down style.
SizeValue | Gets or sets the size value.
TrackingValue | Gets or sets the tracking value.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


AutoKern Property

Aspose.Imaging Documentation

TypeToolStyleInfo.AutoKern Property

Gets or sets a value indicating whether auto kerning is on or off.

public bool AutoKern {get; set;}

Property Value

true if auto kerning is on; otherwise, false.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


BaseShiftValue Property

Aspose.Imaging Documentation

TypeToolStyleInfo.BaseShiftValue Property

Gets or sets the base shift value.

public int BaseShiftValue {get; set;}

Property Value

The base shift value.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


FaceMarkValue Property

Aspose.Imaging Documentation

TypeToolStyleInfo.FaceMarkValue Property

Gets or sets the face mark value.

public short FaceMarkValue {get; set;}

Property Value

The face mark value.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


KerningValue Property

Aspose.Imaging Documentation

TypeToolStyleInfo.KerningValue Property

Gets or sets the kerning value.

public int KerningValue {get; set;}

Property Value

The kerning value.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


LeadingValue Property

Aspose.Imaging Documentation

TypeToolStyleInfo.LeadingValue Property

Gets or sets the leading value.

public int LeadingValue {get; set;}

Property Value

The leading value.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


MarkValue Property

Aspose.Imaging Documentation

TypeToolStyleInfo.MarkValue Property

Gets or sets the mark value.

public short MarkValue {get; set;}

Property Value

The mark value.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


RotateDown Property

Aspose.Imaging Documentation

TypeToolStyleInfo.RotateDown Property

Gets or sets a value indicating whether it is a rotate down style.

public bool RotateDown {get; set;}

Property Value

true if it is a rotate down style; otherwise, false.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


SizeValue Property

Aspose.Imaging Documentation

TypeToolStyleInfo.SizeValue Property

Gets or sets the size value.

public int SizeValue {get; set;}

Property Value

The size value.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TrackingValue Property

Aspose.Imaging Documentation

TypeToolStyleInfo.TrackingValue Property

Gets or sets the tracking value.

public int TrackingValue {get; set;}

Property Value

The tracking value.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolStyleInfo Methods

The methods of the TypeToolStyleInfo class are listed below. For a complete list of TypeToolStyleInfo class members, see the TypeToolStyleInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the TypeToolFontInfo information to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


TypeToolStyleInfo.Save Method

Saves the TypeToolFontInfo information to the specified stream container.

public void Save(
StreamContainer streamContainer,
int psdVersion
);

Parameters

streamContainer
The stream container to save to.
psdVersion
The PSD version.

See Also

TypeToolStyleInfo Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


UnknownResource Class

The unknown resource.

For a list of all members of this type, see UnknownResource Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResource
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.UnknownResource

public class UnknownResource : LayerResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

UnknownResource Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


UnknownResource Members

UnknownResource overview

Public Instance Constructors

UnknownResource Constructor Initializes a new instance of the UnknownResource class.

Public Instance Properties

Data | Gets or sets the data.
Key | Gets the layer resource key.
Length | Gets the layer resource length in bytes.
PsdVersion | Gets the minimal psd version required for layer resource. 0 indicates no restrictions.
Signature | Gets the layer resource signature.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the specified stream container.
ToString (inherited from LayerResource) | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveResourceHeader (inherited from LayerResource) | Saves the resource header.

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


UnknownResource Constructor

Initializes a new instance of the UnknownResource class.

public UnknownResource(
int signature,
int key
);

Parameters

signature
The signature.
key
The resource key.

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


UnknownResource Properties

The properties of the UnknownResource class are listed below. For a complete list of UnknownResource class members, see the UnknownResource Members topic.

Public Instance Properties

Data | Gets or sets the data.
Key | Gets the layer resource key.
Length | Gets the layer resource length in bytes.
PsdVersion | Gets the minimal psd version required for layer resource. 0 indicates no restrictions.
Signature | Gets the layer resource signature.

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Data Property

Aspose.Imaging Documentation

UnknownResource.Data Property

Gets or sets the data.

public byte[] Data {get; set;}

Property Value

The data.

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Key Property

Aspose.Imaging Documentation

UnknownResource.Key Property

Gets the layer resource key.

public override int Key {get;}

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Length Property

Aspose.Imaging Documentation

UnknownResource.Length Property

Gets the layer resource length in bytes.

public override int Length {get;}

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


PsdVersion Property

Aspose.Imaging Documentation

UnknownResource.PsdVersion Property

Gets the minimal psd version required for layer resource. 0 indicates no restrictions.

public override int PsdVersion {get;}

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Signature Property

Aspose.Imaging Documentation

UnknownResource.Signature Property

Gets the layer resource signature.

public override int Signature {get;}

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


UnknownResource Methods

The methods of the UnknownResource class are listed below. For a complete list of UnknownResource class members, see the UnknownResource Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the specified stream container.
ToString (inherited from LayerResource) | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveResourceHeader (inherited from LayerResource) | Saves the resource header.

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


UnknownResource.Save Method

Saves the specified stream container.

public override void Save(
StreamContainer streamContainer,
int psdVersion
);

Parameters

streamContainer
The stream container.
psdVersion
The PSD version.

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace

Namespace hierarchy

Classes

Class | Description
AliasStructure | The alias structure.
BooleanStructure | The boolean structure.
ClassStructure | The class structure.
DoubleStructure | The double structure.
EnumeratedDescriptorStructure | The enumerated descriptor structure.
EnumeratedReferenceStructure | Enumerated reference structure.
IntegerStructure | The integer structure.
ListStructure | The list structure.
OffsetStructure | The offset structure.
PropertyStructure | The property structure.
RawDataStructure | The raw data structure.
ReferenceStructure | The reference structure.
StringStructure | The string structure.
UnitStructure | The unit structure.
UnknownStructure | The unknown structure.

Enumerations

Enumeration | Description
UnitTypes | The unit types.


AliasStructure Class

The alias structure.

For a list of all members of this type, see AliasStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.AliasStructure

public sealed class AliasStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

AliasStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


AliasStructure Members

AliasStructure overview

Public Instance Constructors

AliasStructure Constructor Initializes a new instance of the AliasStructure class.

Public Instance Properties

DataLength | Gets the exact data length in bytes.
FullPath | Gets or sets the full path.
Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AliasStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


AliasStructure Constructor

Initializes a new instance of the AliasStructure class.

public AliasStructure(
ClassID keyName
);

Parameters

keyName
The key name.

See Also

AliasStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


AliasStructure Properties

The properties of the AliasStructure class are listed below. For a complete list of AliasStructure class members, see the AliasStructure Members topic.

Public Instance Properties

DataLength | Gets the exact data length in bytes.
FullPath | Gets or sets the full path.
Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

See Also

AliasStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


DataLength Property

Aspose.Imaging Documentation

AliasStructure.DataLength Property

Gets the exact data length in bytes.

public int DataLength {get;}

Property Value

The data length in bytes.

See Also

AliasStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


FullPath Property

Aspose.Imaging Documentation

AliasStructure.FullPath Property

Gets or sets the full path.

public string FullPath {get; set;}

Property Value

The full path.

See Also

AliasStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

AliasStructure.Key Property

Gets the structure key.

public override int Key {get;}

See Also

AliasStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

AliasStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

AliasStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


BooleanStructure Class

The boolean structure.

For a list of all members of this type, see BooleanStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.BooleanStructure

public sealed class BooleanStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

BooleanStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


BooleanStructure Members

BooleanStructure overview

Public Instance Constructors

BooleanStructure Constructor Initializes a new instance of the BooleanStructure class.

Public Instance Properties

Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
Value | Gets or sets a boolean value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BooleanStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


BooleanStructure Constructor

Initializes a new instance of the BooleanStructure class.

public BooleanStructure(
ClassID keyName
);

Parameters

keyName
The key name.

See Also

BooleanStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


BooleanStructure Properties

The properties of the BooleanStructure class are listed below. For a complete list of BooleanStructure class members, see the BooleanStructure Members topic.

Public Instance Properties

Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
Value | Gets or sets a boolean value.

See Also

BooleanStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

BooleanStructure.Key Property

Gets the structure key.

public override int Key {get;}

See Also

BooleanStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

BooleanStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

BooleanStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Value Property

Aspose.Imaging Documentation

BooleanStructure.Value Property

Gets or sets a boolean value.

public bool Value {get; set;}

Property Value

A boolean value.

See Also

BooleanStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ClassStructure Class

The class structure.

For a list of all members of this type, see ClassStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.ClassStructure

public sealed class ClassStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ClassStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ClassStructure Members

ClassStructure overview

Public Instance Constructors

ClassStructure Constructor Initializes a new instance of the ClassStructure class.

Public Instance Properties

ClassID | Gets or sets the class ID.
ClassName | Gets or sets the class name.
Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ClassStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ClassStructure Constructor

Initializes a new instance of the ClassStructure class.

public ClassStructure(
ClassID keyName,
ClassID classID,
int structureKey
);

Parameters

keyName
Name of the key.
classID
The class ID.
structureKey
The structure key.

See Also

ClassStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ClassStructure Properties

The properties of the ClassStructure class are listed below. For a complete list of ClassStructure class members, see the ClassStructure Members topic.

Public Instance Properties

ClassID | Gets or sets the class ID.
ClassName | Gets or sets the class name.
Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

See Also

ClassStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ClassID Property

Aspose.Imaging Documentation

ClassStructure.ClassID Property

Gets or sets the class ID.

public ClassID ClassID {get; set;}

Property Value

The class ID.

See Also

ClassStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ClassName Property

Aspose.Imaging Documentation

ClassStructure.ClassName Property

Gets or sets the class name.

public string ClassName {get; set;}

Property Value

The class name.

See Also

ClassStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

ClassStructure.Key Property

Gets the structure key.

public override int Key {get;}

See Also

ClassStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

ClassStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

ClassStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


DoubleStructure Class

The double structure.

For a list of all members of this type, see DoubleStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.DoubleStructure

public sealed class DoubleStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

DoubleStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


DoubleStructure Members

DoubleStructure overview

Public Instance Constructors

DoubleStructure Constructor Initializes a new instance of the DoubleStructure class.

Public Instance Properties

Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
Value | Gets or sets the double value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DoubleStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


DoubleStructure Constructor

Initializes a new instance of the DoubleStructure class.

public DoubleStructure(
ClassID keyName
);

Parameters

keyName
The key name.

See Also

DoubleStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


DoubleStructure Properties

The properties of the DoubleStructure class are listed below. For a complete list of DoubleStructure class members, see the DoubleStructure Members topic.

Public Instance Properties

Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
Value | Gets or sets the double value.

See Also

DoubleStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

DoubleStructure.Key Property

Gets the structure key.

public override int Key {get;}

See Also

DoubleStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

DoubleStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

DoubleStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Value Property

Aspose.Imaging Documentation

DoubleStructure.Value Property

Gets or sets the double value.

public double Value {get; set;}

Property Value

The double value.

See Also

DoubleStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


EnumeratedDescriptorStructure Class

The enumerated descriptor structure.

For a list of all members of this type, see EnumeratedDescriptorStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.EnumeratedDescriptorStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.EnumeratedReferenceStructure

public class EnumeratedDescriptorStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

EnumeratedDescriptorStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


EnumeratedDescriptorStructure Members

EnumeratedDescriptorStructure overview

Public Instance Constructors

EnumeratedDescriptorStructure Constructor Initializes a new instance of the EnumeratedDescriptorStructure class.

Public Instance Properties

EnumName | Gets or sets the enum name.
Key | Gets the key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
TypeID | Gets or sets the type ID.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHeaderLength (inherited from OSTypeStructure) | Gets the header length.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveData | Saves the data.

See Also

EnumeratedDescriptorStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


EnumeratedDescriptorStructure Constructor

Initializes a new instance of the EnumeratedDescriptorStructure class.

public EnumeratedDescriptorStructure(
ClassID keyName,
ClassID typeID,
ClassID enumName
);

Parameters

keyName
The key name.
typeID
The type ID.
enumName
The enum name.

See Also

EnumeratedDescriptorStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


EnumeratedDescriptorStructure Properties

The properties of the EnumeratedDescriptorStructure class are listed below. For a complete list of EnumeratedDescriptorStructure class members, see the EnumeratedDescriptorStructure Members topic.

Public Instance Properties

EnumName | Gets or sets the enum name.
Key | Gets the key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
TypeID | Gets or sets the type ID.

See Also

EnumeratedDescriptorStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


EnumName Property

Aspose.Imaging Documentation

EnumeratedDescriptorStructure.EnumName Property

Gets or sets the enum name.

public ClassID EnumName {get; set;}

Property Value

The enum name.

See Also

EnumeratedDescriptorStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

EnumeratedDescriptorStructure.Key Property

Gets the key.

public override int Key {get;}

See Also

EnumeratedDescriptorStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

EnumeratedDescriptorStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

EnumeratedDescriptorStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


TypeID Property

Aspose.Imaging Documentation

EnumeratedDescriptorStructure.TypeID Property

Gets or sets the type ID.

public ClassID TypeID {get; set;}

Property Value

The type ID.

See Also

EnumeratedDescriptorStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


EnumeratedDescriptorStructure Methods

The methods of the EnumeratedDescriptorStructure class are listed below. For a complete list of EnumeratedDescriptorStructure class members, see the EnumeratedDescriptorStructure Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHeaderLength (inherited from OSTypeStructure) | Gets the header length.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveData | Saves the data.

See Also

EnumeratedDescriptorStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


EnumeratedDescriptorStructure.SaveData Method

Saves the data.

protected override void SaveData(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container.

See Also

EnumeratedDescriptorStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


EnumeratedReferenceStructure Class

Enumerated reference structure.

For a list of all members of this type, see EnumeratedReferenceStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.EnumeratedDescriptorStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.EnumeratedReferenceStructure

public sealed class EnumeratedReferenceStructure : EnumeratedDescriptorStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

EnumeratedReferenceStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


EnumeratedReferenceStructure Members

EnumeratedReferenceStructure overview

Public Instance Constructors

EnumeratedReferenceStructure Constructor Initializes a new instance of the EnumeratedReferenceStructure class.

Public Instance Properties

ClassID | Gets or sets the class ID.
ClassName | Gets or sets the class name.
EnumName (inherited from EnumeratedDescriptorStructure) | Gets or sets the enum name.
Key | Gets the key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
TypeID (inherited from EnumeratedDescriptorStructure) | Gets or sets the type ID.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EnumeratedReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


EnumeratedReferenceStructure Constructor

Initializes a new instance of the EnumeratedReferenceStructure class.

public EnumeratedReferenceStructure(
ClassID keyName,
ClassID typeID,
ClassID enumName,
ClassID classID
);

Parameters

keyName
The key name.
typeID
The type ID.
enumName
The enum name.
classID
The class ID.

See Also

EnumeratedReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


EnumeratedReferenceStructure Properties

The properties of the EnumeratedReferenceStructure class are listed below. For a complete list of EnumeratedReferenceStructure class members, see the EnumeratedReferenceStructure Members topic.

Public Instance Properties

ClassID | Gets or sets the class ID.
ClassName | Gets or sets the class name.
EnumName (inherited from EnumeratedDescriptorStructure) | Gets or sets the enum name.
Key | Gets the key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
TypeID (inherited from EnumeratedDescriptorStructure) | Gets or sets the type ID.

See Also

EnumeratedReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ClassID Property

Aspose.Imaging Documentation

EnumeratedReferenceStructure.ClassID Property

Gets or sets the class ID.

public ClassID ClassID {get; set;}

Property Value

The class ID.

See Also

EnumeratedReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ClassName Property

Aspose.Imaging Documentation

EnumeratedReferenceStructure.ClassName Property

Gets or sets the class name.

public string ClassName {get; set;}

Property Value

The class name.

See Also

EnumeratedReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

EnumeratedReferenceStructure.Key Property

Gets the key.

public override int Key {get;}

See Also

EnumeratedReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

EnumeratedReferenceStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

EnumeratedReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


IntegerStructure Class

The integer structure.

For a list of all members of this type, see IntegerStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.IntegerStructure

public sealed class IntegerStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

IntegerStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


IntegerStructure Members

IntegerStructure overview

Public Instance Constructors

IntegerStructure Constructor Initializes a new instance of the IntegerStructure class.

Public Instance Properties

Key | Gets the key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
Value | Gets or sets an integer value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IntegerStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


IntegerStructure Constructor

Initializes a new instance of the IntegerStructure class.

public IntegerStructure(
ClassID keyName
);

Parameters

keyName
The key name.

See Also

IntegerStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


IntegerStructure Properties

The properties of the IntegerStructure class are listed below. For a complete list of IntegerStructure class members, see the IntegerStructure Members topic.

Public Instance Properties

Key | Gets the key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
Value | Gets or sets an integer value.

See Also

IntegerStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

IntegerStructure.Key Property

Gets the key.

public override int Key {get;}

See Also

IntegerStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

IntegerStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

IntegerStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Value Property

Aspose.Imaging Documentation

IntegerStructure.Value Property

Gets or sets an integer value.

public int Value {get; set;}

Property Value

An integer value.

See Also

IntegerStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ListStructure Class

The list structure.

For a list of all members of this type, see ListStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.ListStructure

public sealed class ListStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ListStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ListStructure Members

ListStructure overview

Public Instance Constructors

ListStructure Constructor Initializes a new instance of the ListStructure class.

Public Instance Properties

ItemsCount | Gets the items count.
Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
Types | Gets or sets the types.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ListStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ListStructure Constructor

Initializes a new instance of the ListStructure class.

public ListStructure(
ClassID keyName
);

Parameters

keyName
The key name.

See Also

ListStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ListStructure Properties

The properties of the ListStructure class are listed below. For a complete list of ListStructure class members, see the ListStructure Members topic.

Public Instance Properties

ItemsCount | Gets the items count.
Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
Types | Gets or sets the types.

See Also

ListStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ItemsCount Property

Aspose.Imaging Documentation

ListStructure.ItemsCount Property

Gets the items count.

public int ItemsCount {get;}

See Also

ListStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

ListStructure.Key Property

Gets the structure key.

public override int Key {get;}

See Also

ListStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

ListStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

ListStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Types Property

Aspose.Imaging Documentation

ListStructure.Types Property

Gets or sets the types.

public OSTypeStructure[] Types {get; set;}

Property Value

The types.

See Also

ListStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


OffsetStructure Class

The offset structure.

For a list of all members of this type, see OffsetStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.OffsetStructure

public sealed class OffsetStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

OffsetStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


OffsetStructure Members

OffsetStructure overview

Public Instance Constructors

OffsetStructure Constructor Initializes a new instance of the OffsetStructure class.

Public Instance Properties

ClassID | Gets or sets the class ID.
ClassName | Gets or sets the class name.
Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
Value | Gets or sets the integer value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

OffsetStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


OffsetStructure Constructor

Initializes a new instance of the OffsetStructure class.

public OffsetStructure(
ClassID keyName,
ClassID classID
);

Parameters

keyName
The key name.
classID
The class ID.

See Also

OffsetStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


OffsetStructure Properties

The properties of the OffsetStructure class are listed below. For a complete list of OffsetStructure class members, see the OffsetStructure Members topic.

Public Instance Properties

ClassID | Gets or sets the class ID.
ClassName | Gets or sets the class name.
Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
Value | Gets or sets the integer value.

See Also

OffsetStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ClassID Property

Aspose.Imaging Documentation

OffsetStructure.ClassID Property

Gets or sets the class ID.

public ClassID ClassID {get; set;}

Property Value

The class ID.

See Also

OffsetStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ClassName Property

Aspose.Imaging Documentation

OffsetStructure.ClassName Property

Gets or sets the class name.

public string ClassName {get; set;}

Property Value

The class name.

See Also

OffsetStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

OffsetStructure.Key Property

Gets the structure key.

public override int Key {get;}

See Also

OffsetStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

OffsetStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

OffsetStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Value Property

Aspose.Imaging Documentation

OffsetStructure.Value Property

Gets or sets the integer value.

public int Value {get; set;}

Property Value

The integer value.

See Also

OffsetStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


PropertyStructure Class

The property structure.

For a list of all members of this type, see PropertyStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.PropertyStructure

public sealed class PropertyStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PropertyStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


PropertyStructure Members

PropertyStructure overview

Public Instance Constructors

PropertyStructure Constructor Initializes a new instance of the PropertyStructure class.

Public Instance Properties

ClassID | Gets or sets the class ID.
ClassName | Gets or sets the class name.
Key | Gets the structure key.
KeyID | Gets or sets the key ID.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PropertyStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


PropertyStructure Constructor

Initializes a new instance of the PropertyStructure class.

public PropertyStructure(
ClassID keyName,
ClassID classID,
ClassID keyID
);

Parameters

keyName
Name of the key.
classID
The class ID.
keyID
The key ID.

See Also

PropertyStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


PropertyStructure Properties

The properties of the PropertyStructure class are listed below. For a complete list of PropertyStructure class members, see the PropertyStructure Members topic.

Public Instance Properties

ClassID | Gets or sets the class ID.
ClassName | Gets or sets the class name.
Key | Gets the structure key.
KeyID | Gets or sets the key ID.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

See Also

PropertyStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ClassID Property

Aspose.Imaging Documentation

PropertyStructure.ClassID Property

Gets or sets the class ID.

public ClassID ClassID {get; set;}

Property Value

The class ID.

See Also

PropertyStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ClassName Property

Aspose.Imaging Documentation

PropertyStructure.ClassName Property

Gets or sets the class name.

public string ClassName {get; set;}

Property Value

The class name.

See Also

PropertyStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

PropertyStructure.Key Property

Gets the structure key.

public override int Key {get;}

See Also

PropertyStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


KeyID Property

Aspose.Imaging Documentation

PropertyStructure.KeyID Property

Gets or sets the key ID.

public ClassID KeyID {get; set;}

Property Value

The key ID.

See Also

PropertyStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

PropertyStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

PropertyStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


RawDataStructure Class

The raw data structure.

For a list of all members of this type, see RawDataStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.RawDataStructure

public sealed class RawDataStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

RawDataStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


RawDataStructure Members

RawDataStructure overview

Public Instance Constructors

RawDataStructure Constructor Initializes a new instance of the RawDataStructure class.

Public Instance Properties

Data | Gets or sets the data.
Key | Gets the key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RawDataStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


RawDataStructure Constructor

Initializes a new instance of the RawDataStructure class.

public RawDataStructure(
ClassID keyName
);

Parameters

keyName
The key name.

See Also

RawDataStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


RawDataStructure Properties

The properties of the RawDataStructure class are listed below. For a complete list of RawDataStructure class members, see the RawDataStructure Members topic.

Public Instance Properties

Data | Gets or sets the data.
Key | Gets the key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

See Also

RawDataStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Data Property

Aspose.Imaging Documentation

RawDataStructure.Data Property

Gets or sets the data.

public byte[] Data {get; set;}

Property Value

The data.

See Also

RawDataStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

RawDataStructure.Key Property

Gets the key.

public override int Key {get;}

See Also

RawDataStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

RawDataStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

RawDataStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ReferenceStructure Class

The reference structure.

For a list of all members of this type, see ReferenceStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.ReferenceStructure

public sealed class ReferenceStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ReferenceStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ReferenceStructure Members

ReferenceStructure overview

Public Instance Constructors

ReferenceStructure Constructor Initializes a new instance of the ReferenceStructure class.

Public Instance Properties

Items | Gets or sets the items.
Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ReferenceStructure Constructor

Initializes a new instance of the ReferenceStructure class.

public ReferenceStructure(
ClassID keyName
);

Parameters

keyName
The key name.

See Also

ReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


ReferenceStructure Properties

The properties of the ReferenceStructure class are listed below. For a complete list of ReferenceStructure class members, see the ReferenceStructure Members topic.

Public Instance Properties

Items | Gets or sets the items.
Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

See Also

ReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Items Property

Aspose.Imaging Documentation

ReferenceStructure.Items Property

Gets or sets the items.

public OSTypeStructure[] Items {get; set;}

Property Value

The items.

See Also

ReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

ReferenceStructure.Key Property

Gets the structure key.

public override int Key {get;}

See Also

ReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

ReferenceStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

ReferenceStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


StringStructure Class

The string structure.

For a list of all members of this type, see StringStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.StringStructure

public sealed class StringStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

StringStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


StringStructure Members

StringStructure overview

Public Instance Constructors

StringStructure Constructor Initializes a new instance of the StringStructure class.

Public Instance Properties

Key | Gets the key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
Value | Gets or sets the value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


StringStructure Constructor

Initializes a new instance of the StringStructure class.

public StringStructure(
ClassID keyName
);

Parameters

keyName
The key name.

See Also

StringStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


StringStructure Properties

The properties of the StringStructure class are listed below. For a complete list of StringStructure class members, see the StringStructure Members topic.

Public Instance Properties

Key | Gets the key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
Value | Gets or sets the value.

See Also

StringStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

StringStructure.Key Property

Gets the key.

public override int Key {get;}

See Also

StringStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

StringStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

StringStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Value Property

Aspose.Imaging Documentation

StringStructure.Value Property

Gets or sets the value.

public string Value {get; set;}

Property Value

The value.

See Also

StringStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


UnitStructure Class

The unit structure.

For a list of all members of this type, see UnitStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.UnitStructure

public sealed class UnitStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

UnitStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


UnitStructure Members

UnitStructure overview

Public Instance Constructors

UnitStructure Constructor Initializes a new instance of the UnitStructure class.

Public Instance Properties

Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
UnitType | Gets or sets the unit type.
Value | Gets or sets the value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UnitStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


UnitStructure Constructor

Initializes a new instance of the UnitStructure class.

public UnitStructure(
ClassID keyName
);

Parameters

keyName
The key name.

See Also

UnitStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


UnitStructure Properties

The properties of the UnitStructure class are listed below. For a complete list of UnitStructure class members, see the UnitStructure Members topic.

Public Instance Properties

Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.
UnitType | Gets or sets the unit type.
Value | Gets or sets the value.

See Also

UnitStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

UnitStructure.Key Property

Gets the structure key.

public override int Key {get;}

See Also

UnitStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

UnitStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

UnitStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


UnitType Property

Aspose.Imaging Documentation

UnitStructure.UnitType Property

Gets or sets the unit type.

public UnitTypes UnitType {get; set;}

Property Value

The unit type.

See Also

UnitStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Value Property

Aspose.Imaging Documentation

UnitStructure.Value Property

Gets or sets the value.

public double Value {get; set;}

Property Value

The value.

See Also

UnitStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


UnitTypes Enumeration

The unit types.

public enum UnitTypes

Members

Member Name | Description | Value
Angle | Angle unit. | 591490663
Density | Density unit. | 592606060
Distance | Distance unit. | 592604276
None | Undefined unit. | 592342629
Percent | Percent unit. | 592474723
Pixels | Pixels unit. | 592476268

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


UnknownStructure Class

The unknown structure.

For a list of all members of this type, see UnknownStructure Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.UnknownStructure

public sealed class UnknownStructure : OSTypeStructure

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

UnknownStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


UnknownStructure Members

UnknownStructure overview

Public Instance Constructors

UnknownStructure Constructor Initializes a new instance of the UnknownStructure class.

Public Instance Properties

Data | Gets or sets the data.
Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from OSTypeStructure) | Saves the structure to the specified stream container.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UnknownStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


UnknownStructure Constructor

Initializes a new instance of the UnknownStructure class.

public UnknownStructure(
ClassID keyName,
int key
);

Parameters

keyName
The key name.
key
The structure key.

See Also

UnknownStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


UnknownStructure Properties

The properties of the UnknownStructure class are listed below. For a complete list of UnknownStructure class members, see the UnknownStructure Members topic.

Public Instance Properties

Data | Gets or sets the data.
Key | Gets the structure key.
KeyName (inherited from OSTypeStructure) | Gets or sets the key name.
Length | Gets the OSTypeStructure length in bytes.

See Also

UnknownStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Data Property

Aspose.Imaging Documentation

UnknownStructure.Data Property

Gets or sets the data.

public byte[] Data {get; set;}

Property Value

The data.

See Also

UnknownStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Key Property

Aspose.Imaging Documentation

UnknownStructure.Key Property

Gets the structure key.

public override int Key {get;}

See Also

UnknownStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Length Property

Aspose.Imaging Documentation

UnknownStructure.Length Property

Gets the OSTypeStructure length in bytes.

public override int Length {get;}

See Also

UnknownStructure Class | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Aspose.Imaging.FileFormats.Psd.Resources

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Psd.Resources Namespace

Namespace hierarchy

Classes

Class | Description
GridAndGuidesResouce | Represents the grid and guides resource.
GuideResource | The guide resource block.
Thumbnail4Resource | Represents the thumbnail resource for psd 4.0.
ThumbnailResource | The thumbnail resource block.
TransparencyIndexResource | The transparency index resource block.
UnknownResource | The unknown resource. When a resource block is not recognized then this resource block is created.

Enumerations

Enumeration | Description
GuideDirection | The guide direction.
ThumbnailFormat | Specifies thumbnail data format.


GridAndGuidesResouce Class

Represents the grid and guides resource.

For a list of all members of this type, see GridAndGuidesResouce Members.

System.Object
Aspose.Imaging.FileFormats.Psd.ResourceBlock
Aspose.Imaging.FileFormats.Psd.Resources.GridAndGuidesResouce

public sealed class GridAndGuidesResouce : ResourceBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Resources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GridAndGuidesResouce Members | Aspose.Imaging.FileFormats.Psd.Resources Namespace


GridAndGuidesResouce Members

GridAndGuidesResouce overview

Public Instance Constructors

GridAndGuidesResouce Constructor Initializes a new instance of the GridAndGuidesResouce class.

Public Instance Properties

DataSize | Gets the resource data size in bytes.
GridCycleX | Gets or sets the horizontal grid cycle. The default is 576.
GridCycleY | Gets or sets the vertical grid cycle. The default is 576.
GuideCount | Gets the guide resource blocks count.
Guides | Gets or sets the guides.
HeaderVersion | Gets or sets the header version. This value should be always 1.
ID (inherited from ResourceBlock) | Gets or sets the unique identifier for the resource.
MinimalVersion | Gets the minimal required psd version.
Name (inherited from ResourceBlock) | Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).
Signature (inherited from ResourceBlock) | Gets the resource signature. Should be always '8BIM'.
Size (inherited from ResourceBlock) | Gets the resource block size in bytes including its data.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from ResourceBlock) | Saves the resource block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
ValidateValues (inherited from ResourceBlock) | Validates the resource values.

See Also

GridAndGuidesResouce Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


GridAndGuidesResouce Constructor

Initializes a new instance of the GridAndGuidesResouce class.

public GridAndGuidesResouce();

See Also

GridAndGuidesResouce Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


GridAndGuidesResouce Properties

The properties of the GridAndGuidesResouce class are listed below. For a complete list of GridAndGuidesResouce class members, see the GridAndGuidesResouce Members topic.

Public Instance Properties

DataSize | Gets the resource data size in bytes.
GridCycleX | Gets or sets the horizontal grid cycle. The default is 576.
GridCycleY | Gets or sets the vertical grid cycle. The default is 576.
GuideCount | Gets the guide resource blocks count.
Guides | Gets or sets the guides.
HeaderVersion | Gets or sets the header version. This value should be always 1.
ID (inherited from ResourceBlock) | Gets or sets the unique identifier for the resource.
MinimalVersion | Gets the minimal required psd version.
Name (inherited from ResourceBlock) | Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).
Signature (inherited from ResourceBlock) | Gets the resource signature. Should be always '8BIM'.
Size (inherited from ResourceBlock) | Gets the resource block size in bytes including its data.

See Also

GridAndGuidesResouce Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


DataSize Property

Aspose.Imaging Documentation

GridAndGuidesResouce.DataSize Property

Gets the resource data size in bytes.

public override int DataSize {get;}

Property Value

The resource data size.

See Also

GridAndGuidesResouce Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


GridCycleX Property

Aspose.Imaging Documentation

GridAndGuidesResouce.GridCycleX Property

Gets or sets the horizontal grid cycle. The default is 576.

public int GridCycleX {get; set;}

Property Value

The horizontal grid cycle.

See Also

GridAndGuidesResouce Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


GridCycleY Property

Aspose.Imaging Documentation

GridAndGuidesResouce.GridCycleY Property

Gets or sets the vertical grid cycle. The default is 576.

public int GridCycleY {get; set;}

Property Value

The vertical grid cycle.

See Also

GridAndGuidesResouce Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


GuideCount Property

Aspose.Imaging Documentation

GridAndGuidesResouce.GuideCount Property

Gets the guide resource blocks count.

public int GuideCount {get;}

Property Value

The guide resource blocks count.

See Also

GridAndGuidesResouce Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


Guides Property

Aspose.Imaging Documentation

GridAndGuidesResouce.Guides Property

Gets or sets the guides.

public GuideResource[] Guides {get; set;}

Property Value

The guides.

See Also

GridAndGuidesResouce Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


HeaderVersion Property

Aspose.Imaging Documentation

GridAndGuidesResouce.HeaderVersion Property

Gets or sets the header version. This value should be always 1.

public int HeaderVersion {get; set;}

Property Value

The header version.

See Also

GridAndGuidesResouce Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


MinimalVersion Property

Aspose.Imaging Documentation

GridAndGuidesResouce.MinimalVersion Property

Gets the minimal required psd version.

public override int MinimalVersion {get;}

Property Value

The minimal psd version.

See Also

GridAndGuidesResouce Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


GuideDirection Enumeration

The guide direction.

public enum GuideDirection

Members

Member Name | Description | Value
Vertical | Vertical guide direction. | 0
Horizontal | Horizontal guide direction. | 1

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Resources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Psd.Resources Namespace


GuideResource Class

The guide resource block.

For a list of all members of this type, see GuideResource Members.

System.Object
Aspose.Imaging.FileFormats.Psd.Resources.GuideResource

public sealed class GuideResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Resources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GuideResource Members | Aspose.Imaging.FileFormats.Psd.Resources Namespace


GuideResource Members

GuideResource overview

Public Instance Constructors

GuideResource Constructor Initializes a new instance of the GuideResource class.

Public Instance Properties

Direction | Gets or sets the direction of guide.
Location | Gets or sets the location of guide in document coordinates.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GuideResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


GuideResource Constructor

Initializes a new instance of the GuideResource class.

public GuideResource();

See Also

GuideResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


GuideResource Properties

The properties of the GuideResource class are listed below. For a complete list of GuideResource class members, see the GuideResource Members topic.

Public Instance Properties

Direction | Gets or sets the direction of guide.
Location | Gets or sets the location of guide in document coordinates.

See Also

GuideResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


Direction Property

Aspose.Imaging Documentation

GuideResource.Direction Property

Gets or sets the direction of guide.

public GuideDirection Direction {get; set;}

Property Value

The direction of guide.

See Also

GuideResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


Location Property

Aspose.Imaging Documentation

GuideResource.Location Property

Gets or sets the location of guide in document coordinates.

public int Location {get; set;}

Property Value

The guide location.

See Also

GuideResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


Thumbnail4Resource Class

Represents the thumbnail resource for psd 4.0.

For a list of all members of this type, see Thumbnail4Resource Members.

System.Object
Aspose.Imaging.FileFormats.Psd.ResourceBlock
Aspose.Imaging.FileFormats.Psd.Resources.ThumbnailResource
Aspose.Imaging.FileFormats.Psd.Resources.Thumbnail4Resource

public sealed class Thumbnail4Resource : ThumbnailResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Resources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Thumbnail4Resource Members | Aspose.Imaging.FileFormats.Psd.Resources Namespace


Thumbnail4Resource Members

Thumbnail4Resource overview

Public Instance Constructors

Thumbnail4Resource Constructor Initializes a new instance of the Thumbnail4Resource class.

Public Instance Properties

BitsPixel (inherited from ThumbnailResource) | Gets or sets the bits pixel.
DataSize (inherited from ThumbnailResource) | Gets the resource data size in bytes.
Format (inherited from ThumbnailResource) | Gets or sets the thumbnail data format.
Height (inherited from ThumbnailResource) | Gets or sets the height of thumbnail in pixels.
ID (inherited from ResourceBlock) | Gets or sets the unique identifier for the resource.
MinimalVersion | Gets the minimal required psd version.
Name (inherited from ResourceBlock) | Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).
PlanesCount (inherited from ThumbnailResource) | Gets or sets the planes count.
Signature (inherited from ResourceBlock) | Gets the resource signature. Should be always '8BIM'.
Size (inherited from ResourceBlock) | Gets the resource block size in bytes including its data.
SizeAfterCompression (inherited from ThumbnailResource) | Gets or sets the size after compression. Used for consistency check.
ThumbnailData (inherited from ThumbnailResource) | Gets or sets the thumbnail data.
TotalSize (inherited from ThumbnailResource) | Gets the total data size.
Width (inherited from ThumbnailResource) | Gets or sets the width of thumbnail in pixels.
WidthBytes (inherited from ThumbnailResource) | Gets the row width in bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from ResourceBlock) | Saves the resource block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
ValidateValues (inherited from ThumbnailResource) | Validates the resource values.

See Also

Thumbnail4Resource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


Thumbnail4Resource Constructor

Initializes a new instance of the Thumbnail4Resource class.

public Thumbnail4Resource();

See Also

Thumbnail4Resource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


Thumbnail4Resource Properties

The properties of the Thumbnail4Resource class are listed below. For a complete list of Thumbnail4Resource class members, see the Thumbnail4Resource Members topic.

Public Instance Properties

BitsPixel (inherited from ThumbnailResource) | Gets or sets the bits pixel.
DataSize (inherited from ThumbnailResource) | Gets the resource data size in bytes.
Format (inherited from ThumbnailResource) | Gets or sets the thumbnail data format.
Height (inherited from ThumbnailResource) | Gets or sets the height of thumbnail in pixels.
ID (inherited from ResourceBlock) | Gets or sets the unique identifier for the resource.
MinimalVersion | Gets the minimal required psd version.
Name (inherited from ResourceBlock) | Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).
PlanesCount (inherited from ThumbnailResource) | Gets or sets the planes count.
Signature (inherited from ResourceBlock) | Gets the resource signature. Should be always '8BIM'.
Size (inherited from ResourceBlock) | Gets the resource block size in bytes including its data.
SizeAfterCompression (inherited from ThumbnailResource) | Gets or sets the size after compression. Used for consistency check.
ThumbnailData (inherited from ThumbnailResource) | Gets or sets the thumbnail data.
TotalSize (inherited from ThumbnailResource) | Gets the total data size.
Width (inherited from ThumbnailResource) | Gets or sets the width of thumbnail in pixels.
WidthBytes (inherited from ThumbnailResource) | Gets the row width in bytes.

See Also

Thumbnail4Resource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


MinimalVersion Property

Aspose.Imaging Documentation

Thumbnail4Resource.MinimalVersion Property

Gets the minimal required psd version.

public override int MinimalVersion {get;}

Property Value

The minimal psd version.

See Also

Thumbnail4Resource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


ThumbnailFormat Enumeration

Specifies thumbnail data format.

public enum ThumbnailFormat

Members

Member Name | Description | Value
kRawRGB | Raw RGB format. | 0
kJpegRGB | Compressed Jpeg format. | 1

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Resources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Psd.Resources Namespace


ThumbnailResource Class

The thumbnail resource block.

For a list of all members of this type, see ThumbnailResource Members.

System.Object
Aspose.Imaging.FileFormats.Psd.ResourceBlock
Aspose.Imaging.FileFormats.Psd.Resources.ThumbnailResource
Aspose.Imaging.FileFormats.Psd.Resources.Thumbnail4Resource

public class ThumbnailResource : ResourceBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Resources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ThumbnailResource Members | Aspose.Imaging.FileFormats.Psd.Resources Namespace


ThumbnailResource Members

ThumbnailResource overview

Public Instance Constructors

ThumbnailResource Constructor Initializes a new instance of the ThumbnailResource class.

Public Instance Properties

BitsPixel | Gets or sets the bits pixel.
DataSize | Gets the resource data size in bytes.
Format | Gets or sets the thumbnail data format.
Height | Gets or sets the height of thumbnail in pixels.
ID (inherited from ResourceBlock) | Gets or sets the unique identifier for the resource.
MinimalVersion | Gets the minimal required psd version.
Name (inherited from ResourceBlock) | Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).
PlanesCount | Gets or sets the planes count.
Signature (inherited from ResourceBlock) | Gets the resource signature. Should be always '8BIM'.
Size (inherited from ResourceBlock) | Gets the resource block size in bytes including its data.
SizeAfterCompression | Gets or sets the size after compression. Used for consistency check.
ThumbnailData | Gets or sets the thumbnail data.
TotalSize | Gets the total data size.
Width | Gets or sets the width of thumbnail in pixels.
WidthBytes | Gets the row width in bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from ResourceBlock) | Saves the resource block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
ValidateValues | Validates the resource values.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveCommonData | Saves the common data.
SaveData | Saves the resource block data.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


ThumbnailResource Constructor

Initializes a new instance of the ThumbnailResource class.

public ThumbnailResource();

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


ThumbnailResource Properties

The properties of the ThumbnailResource class are listed below. For a complete list of ThumbnailResource class members, see the ThumbnailResource Members topic.

Public Instance Properties

BitsPixel | Gets or sets the bits pixel.
DataSize | Gets the resource data size in bytes.
Format | Gets or sets the thumbnail data format.
Height | Gets or sets the height of thumbnail in pixels.
ID (inherited from ResourceBlock) | Gets or sets the unique identifier for the resource.
MinimalVersion | Gets the minimal required psd version.
Name (inherited from ResourceBlock) | Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).
PlanesCount | Gets or sets the planes count.
Signature (inherited from ResourceBlock) | Gets the resource signature. Should be always '8BIM'.
Size (inherited from ResourceBlock) | Gets the resource block size in bytes including its data.
SizeAfterCompression | Gets or sets the size after compression. Used for consistency check.
ThumbnailData | Gets or sets the thumbnail data.
TotalSize | Gets the total data size.
Width | Gets or sets the width of thumbnail in pixels.
WidthBytes | Gets the row width in bytes.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


BitsPixel Property

Aspose.Imaging Documentation

ThumbnailResource.BitsPixel Property

Gets or sets the bits pixel.

public short BitsPixel {get; set;}

Property Value

The thumbnail bits pixel.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


DataSize Property

Aspose.Imaging Documentation

ThumbnailResource.DataSize Property

Gets the resource data size in bytes.

public override int DataSize {get;}

Property Value

The resource data size.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


Format Property

Aspose.Imaging Documentation

ThumbnailResource.Format Property

Gets or sets the thumbnail data format.

public ThumbnailFormat Format {get; set;}

Property Value

The thumbnail data format.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


Height Property

Aspose.Imaging Documentation

ThumbnailResource.Height Property

Gets or sets the height of thumbnail in pixels.

public int Height {get; set;}

Property Value

The thumbnail height.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


MinimalVersion Property

Aspose.Imaging Documentation

ThumbnailResource.MinimalVersion Property

Gets the minimal required psd version.

public override int MinimalVersion {get;}

Property Value

The minimal psd version.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


PlanesCount Property

Aspose.Imaging Documentation

ThumbnailResource.PlanesCount Property

Gets or sets the planes count.

public short PlanesCount {get; set;}

Property Value

The thumbnail planes count.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


SizeAfterCompression Property

Aspose.Imaging Documentation

ThumbnailResource.SizeAfterCompression Property

Gets or sets the size after compression. Used for consistency check.

public int SizeAfterCompression {get; set;}

Property Value

The size after compression.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


ThumbnailData Property

Aspose.Imaging Documentation

ThumbnailResource.ThumbnailData Property

Gets or sets the thumbnail data.

public Color[] ThumbnailData {get; set;}

Property Value

The thumbnail data.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


TotalSize Property

Aspose.Imaging Documentation

ThumbnailResource.TotalSize Property

Gets the total data size.

public int TotalSize {get;}

Property Value

The total data size.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


Width Property

Aspose.Imaging Documentation

ThumbnailResource.Width Property

Gets or sets the width of thumbnail in pixels.

public int Width {get; set;}

Property Value

The thumbnail width.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


WidthBytes Property

Aspose.Imaging Documentation

ThumbnailResource.WidthBytes Property

Gets the row width in bytes.

public int WidthBytes {get;}

Property Value

The row width in bytes.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


ThumbnailResource Methods

The methods of the ThumbnailResource class are listed below. For a complete list of ThumbnailResource class members, see the ThumbnailResource Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from ResourceBlock) | Saves the resource block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
ValidateValues | Validates the resource values.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SaveCommonData | Saves the common data.
SaveData | Saves the resource block data.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


ThumbnailResource.SaveCommonData Method

Saves the common data.

protected void SaveCommonData(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


ThumbnailResource.SaveData Method

Saves the resource block data.

protected override void SaveData(
StreamContainer streamContainer
);

Parameters

streamContainer
The stream container to save to.

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


ThumbnailResource.ValidateValues Method

Validates the resource values.

public override void ValidateValues();

See Also

ThumbnailResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


TransparencyIndexResource Class

The transparency index resource block.

For a list of all members of this type, see TransparencyIndexResource Members.

System.Object
Aspose.Imaging.FileFormats.Psd.ResourceBlock
Aspose.Imaging.FileFormats.Psd.Resources.TransparencyIndexResource

public sealed class TransparencyIndexResource : ResourceBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Resources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TransparencyIndexResource Members | Aspose.Imaging.FileFormats.Psd.Resources Namespace


TransparencyIndexResource Members

TransparencyIndexResource overview

Public Instance Constructors

TransparencyIndexResource Constructor Initializes a new instance of the TransparencyIndexResource class.

Public Instance Properties

DataSize | Gets the resource data size in bytes.
ID (inherited from ResourceBlock) | Gets or sets the unique identifier for the resource.
MinimalVersion | Gets the minimal required psd version.
Name (inherited from ResourceBlock) | Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).
Signature (inherited from ResourceBlock) | Gets the resource signature. Should be always '8BIM'.
Size (inherited from ResourceBlock) | Gets the resource block size in bytes including its data.
TransparencyIndex | Gets or sets the transparency color index.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from ResourceBlock) | Saves the resource block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
ValidateValues (inherited from ResourceBlock) | Validates the resource values.

See Also

TransparencyIndexResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


TransparencyIndexResource Constructor

Initializes a new instance of the TransparencyIndexResource class.

public TransparencyIndexResource();

See Also

TransparencyIndexResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


TransparencyIndexResource Properties

The properties of the TransparencyIndexResource class are listed below. For a complete list of TransparencyIndexResource class members, see the TransparencyIndexResource Members topic.

Public Instance Properties

DataSize | Gets the resource data size in bytes.
ID (inherited from ResourceBlock) | Gets or sets the unique identifier for the resource.
MinimalVersion | Gets the minimal required psd version.
Name (inherited from ResourceBlock) | Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).
Signature (inherited from ResourceBlock) | Gets the resource signature. Should be always '8BIM'.
Size (inherited from ResourceBlock) | Gets the resource block size in bytes including its data.
TransparencyIndex | Gets or sets the transparency color index.

See Also

TransparencyIndexResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


DataSize Property

Aspose.Imaging Documentation

TransparencyIndexResource.DataSize Property

Gets the resource data size in bytes.

public override int DataSize {get;}

Property Value

The resource data size.

See Also

TransparencyIndexResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


MinimalVersion Property

Aspose.Imaging Documentation

TransparencyIndexResource.MinimalVersion Property

Gets the minimal required psd version.

public override int MinimalVersion {get;}

Property Value

The minimal psd version.

See Also

TransparencyIndexResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


TransparencyIndex Property

Aspose.Imaging Documentation

TransparencyIndexResource.TransparencyIndex Property

Gets or sets the transparency color index.

public short TransparencyIndex {get; set;}

Property Value

The transparency color index.

See Also

TransparencyIndexResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


UnknownResource Class

The unknown resource. When a resource block is not recognized then this resource block is created.

For a list of all members of this type, see UnknownResource Members.

System.Object
Aspose.Imaging.FileFormats.Psd.ResourceBlock
Aspose.Imaging.FileFormats.Psd.Resources.UnknownResource

public sealed class UnknownResource : ResourceBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Psd.Resources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

UnknownResource Members | Aspose.Imaging.FileFormats.Psd.Resources Namespace


UnknownResource Members

UnknownResource overview

Public Instance Properties

Data | Gets the resource data.
DataSize | Gets the resource data size in bytes.
ID (inherited from ResourceBlock) | Gets or sets the unique identifier for the resource.
MinimalVersion | Gets the minimal required psd version.
Name (inherited from ResourceBlock) | Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).
Signature (inherited from ResourceBlock) | Gets the resource signature. Should be always '8BIM'.
Size (inherited from ResourceBlock) | Gets the resource block size in bytes including its data.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from ResourceBlock) | Saves the resource block to the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
ValidateValues (inherited from ResourceBlock) | Validates the resource values.

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


UnknownResource Properties

The properties of the UnknownResource class are listed below. For a complete list of UnknownResource class members, see the UnknownResource Members topic.

Public Instance Properties

Data | Gets the resource data.
DataSize | Gets the resource data size in bytes.
ID (inherited from ResourceBlock) | Gets or sets the unique identifier for the resource.
MinimalVersion | Gets the minimal required psd version.
Name (inherited from ResourceBlock) | Gets or sets the resource name. Pascal string, padded to make the size even (a null name consists of two bytes of 0).
Signature (inherited from ResourceBlock) | Gets the resource signature. Should be always '8BIM'.
Size (inherited from ResourceBlock) | Gets the resource block size in bytes including its data.

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


Data Property

Aspose.Imaging Documentation

UnknownResource.Data Property

Gets the resource data.

public byte[] Data {get;}

Property Value

The resource data.

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


DataSize Property

Aspose.Imaging Documentation

UnknownResource.DataSize Property

Gets the resource data size in bytes.

public override int DataSize {get;}

Property Value

The resource data size.

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


MinimalVersion Property

Aspose.Imaging Documentation

UnknownResource.MinimalVersion Property

Gets the minimal required psd version.

public override int MinimalVersion {get;}

Property Value

The minimal psd version.

See Also

UnknownResource Class | Aspose.Imaging.FileFormats.Psd.Resources Namespace


Aspose.Imaging.FileFormats.Tiff

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Tiff Namespace

Namespace hierarchy

Classes

Class | Description
TiffDataType | The tiff data type.
TiffFrame | The tiff frame.
TiffImage | The tiff image.
TiffRational | The tiff rational type.
TiffSRational | The tiff rational type.


TiffDataType Class

The tiff data type.

For a list of all members of this type, see TiffDataType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffASCIIType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffUndefinedType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffUnknownType

public abstract class TiffDataType : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffDataType Members | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType Members

TiffDataType overview

Public Static Methods

ReadTag Reads the tag data.

Public Instance Properties

Count | Gets the count of elements.
DataSize | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
Id | Gets tag id integer representation.
IsValid | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.

Public Instance Methods

CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag | Writes the tag data.

Protected Instance Constructors

TiffDataType Constructor Initializes a new instance of the TiffDataType class.

Protected Instance Methods

CopyInstanceData | Copies the instance data into the cloned type.
CreateInstance | Creates a new instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReadData | Reads the additional data.
WriteTagValueOrOffset | Writes the tag value or additional offset.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType Constructor

Initializes a new instance of the TiffDataType class.

protected TiffDataType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType Properties

The properties of the TiffDataType class are listed below. For a complete list of TiffDataType class members, see the TiffDataType Members topic.

Public Instance Properties

Count | Gets the count of elements.
DataSize | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
Id | Gets tag id integer representation.
IsValid | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


Count Property

Aspose.Imaging Documentation

TiffDataType.Count Property

Gets the count of elements.

public abstract uint Count {get;}

Property Value

The count of elements.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


DataSize Property

Aspose.Imaging Documentation

TiffDataType.DataSize Property

Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).

public abstract uint DataSize {get;}

Property Value

The additional data size in bytes.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


Id Property

Aspose.Imaging Documentation

TiffDataType.Id Property

Gets tag id integer representation.

public ushort Id {get;}

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


IsValid Property

Aspose.Imaging Documentation

TiffDataType.IsValid Property

Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.

public bool IsValid {get;}

Property Value

true if tag data is valid; otherwise, false.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TagId Property

Aspose.Imaging Documentation

TiffDataType.TagId Property

Gets the tag id.

public TiffTags TagId {get;}

Property Value

The tag id.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TagType Property

Aspose.Imaging Documentation

TiffDataType.TagType Property

Gets the tag type.

public abstract TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


Value Property

Aspose.Imaging Documentation

TiffDataType.Value Property

Gets or sets the value this data type contains.

public abstract object Value {get; set;}

Property Value

The value.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType Methods

The methods of the TiffDataType class are listed below. For a complete list of TiffDataType class members, see the TiffDataType Members topic.

Public Static Methods

ReadTag Reads the tag data.

Public Instance Methods

CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag | Writes the tag data.

Protected Instance Methods

CopyInstanceData | Copies the instance data into the cloned type.
CreateInstance | Creates a new instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReadData | Reads the additional data.
WriteTagValueOrOffset | Writes the tag value or additional offset.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType.CompareTo Method

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

public int CompareTo(
object obj
);

Parameters

obj
An object to compare with this instance.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparable.CompareTo

Exceptions

Exception Type | Condition
TiffImageException | Expected TiffDataType type.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType.CopyInstanceData Method

Copies the instance data into the cloned type.

protected virtual void CopyInstanceData(
TiffDataType clonedType
);

Parameters

clonedType
The cloned type.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType.CreateInstance Method

Creates a new instance.

protected abstract TiffDataType CreateInstance();

Return Value

A new TiffDataType instance.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType.DeepClone Method

Performs a deep clone of this instance.

public virtual TiffDataType DeepClone();

Return Value

A deep clone of the current instance.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType.ReadData Method

Reads the additional data.

protected abstract void ReadData(
TiffStream dataStream,
uint count
);

Parameters

dataStream
The data stream.
count
The count of elements.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType.ReadTag Method

Reads the tag data.

public static TiffDataType ReadTag(
TiffStream dataStream
);

Parameters

dataStream
The data stream

Return Value

The read tag.

Exceptions

Exception Type | Condition
ArgumentNullException | dataStream
FrameworkException | Unable to read values for + (TiffTags)tagId + tag. Message : + exception.Message

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType.WriteAdditionalData Method

Writes the additional tag data.

public abstract void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType.WriteTag Method

Writes the tag data.

public void WriteTag(
TiffStream dataStream,
uint additionalDataOffset
);

Parameters

dataStream
The data stream.
additionalDataOffset
The offset to write additional data to.

Exceptions

Exception Type | Condition
ImageSaveException | Unable to Write values for + this.TagType + Message : + exception.Message

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffDataType.WriteTagValueOrOffset Method

Writes the tag value or additional offset.

protected abstract void WriteTagValueOrOffset(
TiffStream dataStream,
uint additionalDataOffset
);

Parameters

dataStream
The data stream.
additionalDataOffset
The additional data offset.

See Also

TiffDataType Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffFrame Class

The tiff frame.

For a list of all members of this type, see TiffFrame Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image
Aspose.Imaging.RasterImage
Aspose.Imaging.RasterCachedImage
Aspose.Imaging.FileFormats.Tiff.TiffFrame

public sealed class TiffFrame : RasterCachedImage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffFrame Members | Aspose.Imaging.FileFormats.Tiff Namespace


TiffFrame Members

TiffFrame overview

Public Static Methods

CopyFrame | Copies the entire frame (duplicates).
CreateFrameFrom | Creates the frame from specified tiffFrame using the specified options. The pixel data is preserved but converted to the desired format.

Public Instance Constructors

TiffFrame Overloaded. Initializes a new instance of the TiffFrame class.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
ExifData | Gets or sets EXIF data from frame.
FrameOptions | Gets the frame create options.
Height | Gets the image height.
HorizontalResolution (inherited from RasterImage) | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
IsCached (inherited from RasterCachedImage) | Gets a value indicating whether image data is cached currently.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution (inherited from RasterImage) | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width | Gets the image width.

Public Instance Methods

CacheData (inherited from RasterCachedImage) | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop (inherited from RasterCachedImage) | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
Resize (inherited from RasterCachedImage) | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip (inherited from RasterCachedImage) | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution (inherited from RasterImage) | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffFrame Constructor

Initializes a new instance of the TiffFrame class.

Overload List

Initializes a new instance of the TiffFrame class.

public TiffFrame(TiffOptions,int,int);

Initializes a new instance of the TiffFrame class.

public TiffFrame(RasterImage);

Initializes a new instance of the TiffFrame class.

public TiffFrame(RasterImage,TiffOptions);

Initializes a new instance of the TiffFrame class.

public TiffFrame(Stream);

Initializes a new instance of the TiffFrame class.

public TiffFrame(Stream,TiffOptions);

Initializes a new instance of the TiffFrame class.

public TiffFrame(string);

Initializes a new instance of the TiffFrame class.

public TiffFrame(string,TiffOptions);

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffFrame Constructor (Stream)

Initializes a new instance of the TiffFrame class.

public TiffFrame(
Stream stream
);

Parameters

stream
The stream to load an image from and initialize frame pixel and palette data with.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffFrame Constructor Overload List


TiffFrame Constructor (Stream, TiffOptions)

Initializes a new instance of the TiffFrame class.

public TiffFrame(
Stream stream,
TiffOptions options
);

Parameters

stream
The stream to load an image from and initialize frame pixel and palette data with.
options
The options to use for the newly created frame.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffFrame Constructor Overload List


TiffFrame Constructor (String)

Initializes a new instance of the TiffFrame class.

public TiffFrame(
string path
);

Parameters

path
The path to load an image from and initialize frame pixel and palette data with.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffFrame Constructor Overload List


TiffFrame Constructor (String, TiffOptions)

Initializes a new instance of the TiffFrame class.

public TiffFrame(
string path,
TiffOptions options
);

Parameters

path
The path to load an image from and initialize frame pixel and palette data with.
options
The options to use for the newly created frame.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffFrame Constructor Overload List


TiffFrame Constructor (RasterImage)

Initializes a new instance of the TiffFrame class.

public TiffFrame(
RasterImage image
);

Parameters

image
The image to initialize frame pixel and palette data with.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffFrame Constructor Overload List


TiffFrame Constructor (RasterImage, TiffOptions)

Initializes a new instance of the TiffFrame class.

public TiffFrame(
RasterImage image,
TiffOptions options
);

Parameters

image
The image to initialize frame pixel and palette data with.
options
The options to use for the newly created frame.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffFrame Constructor Overload List


TiffFrame Constructor (TiffOptions, Int32, Int32)

Initializes a new instance of the TiffFrame class.

public TiffFrame(
TiffOptions options,
int width,
int height
);

Parameters

options
The frame options.
width
The width.
height
The height.

Exceptions

Exception Type | Condition
ArgumentNullException | Options parameter is null.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffFrame Constructor Overload List


TiffFrame Properties

The properties of the TiffFrame class are listed below. For a complete list of TiffFrame class members, see the TiffFrame Members topic.

Public Instance Properties

BitsPerPixel | Gets the image bits per pixel count.
Bounds (inherited from Image) | Gets the image bounds.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings (inherited from RasterImage) | Gets or sets the dithering settings.
ExifData | Gets or sets EXIF data from frame.
FrameOptions | Gets the frame create options.
Height | Gets the image height.
HorizontalResolution (inherited from RasterImage) | Gets or sets the horizontal resolution, in pixels per inch, of this RasterImage.
IsCached (inherited from RasterCachedImage) | Gets a value indicating whether image data is cached currently.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution (inherited from RasterImage) | Gets or sets the vertical resolution, in pixels per inch, of this RasterImage.
Width | Gets the image width.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

TiffFrame.BitsPerPixel Property

Gets the image bits per pixel count.

public override int BitsPerPixel {get;}

Property Value

The image bits per pixel count.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace


ExifData Property

Aspose.Imaging Documentation

TiffFrame.ExifData Property

Gets or sets EXIF data from frame.

public ExifData ExifData {get; set;}

Property Value

EXIF data container

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace


FrameOptions Property

Aspose.Imaging Documentation

TiffFrame.FrameOptions Property

Gets the frame create options.

public TiffOptions FrameOptions {get;}

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace


Height Property

Aspose.Imaging Documentation

TiffFrame.Height Property

Gets the image height.

public override int Height {get;}

Property Value

The image height.

Implements

IObjectWithBounds.Height

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace


Width Property

Aspose.Imaging Documentation

TiffFrame.Width Property

Gets the image width.

public override int Width {get;}

Property Value

The image width.

Implements

IObjectWithBounds.Width

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffFrame Methods

The methods of the TiffFrame class are listed below. For a complete list of TiffFrame class members, see the TiffFrame Members topic.

Public Static Methods

CopyFrame | Copies the entire frame (duplicates).
CreateFrameFrom | Creates the frame from specified tiffFrame using the specified options. The pixel data is preserved but converted to the desired format.

Public Instance Methods

CacheData (inherited from RasterCachedImage) | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop (inherited from RasterCachedImage) | Overloaded. Cropping the image.
Crop (inherited from RasterImage) | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
Resize (inherited from RasterCachedImage) | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
RotateFlip (inherited from RasterCachedImage) | Rotates, flips, or rotates and flips the image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution (inherited from RasterImage) | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffFrame.CopyFrame Method

Copies the entire frame (duplicates).

public static TiffFrame CopyFrame(
TiffFrame tiffFrame
);

Parameters

tiffFrame
The tiff frame to copy.

Return Value

The newly copied tiff frame.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffFrame.CreateFrameFrom Method

Creates the frame from specified tiffFrame using the specified options. The pixel data is preserved but converted to the desired format.

public static TiffFrame CreateFrameFrom(
TiffFrame tiffFrame,
TiffOptions options
);

Parameters

tiffFrame
The tiff frame to create from.
options
The new options to use.

Return Value

The newly created frame.

See Also

TiffFrame Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage Class

The tiff image.

For a list of all members of this type, see TiffImage Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image
Aspose.Imaging.RasterImage
Aspose.Imaging.FileFormats.Tiff.TiffImage

public sealed class TiffImage : RasterImage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffImage Members | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage Members

TiffImage overview

Public Instance Constructors

TiffImage Constructor Initializes a new instance of the TiffImage class.

Public Instance Properties

ActiveFrame | Gets or sets the active frame.
BitsPerPixel | Gets the image bits per pixel value of current frame.
Bounds (inherited from Image) | Gets the image bounds.
ByteOrder | Gets or sets a value indicating the tiff byte order.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings | Gets or sets the dithering settings for tiff image. Settings are applied to all frames in image.
ExifData | Gets or sets EXIF data for the active frame.
Frames | Gets Frames array of the image.
Height | Gets the image height.
HorizontalResolution | Gets the horizontal resolution, in pixels per inch, of this Image.
IsCached | Gets a value indicating whether object's data is cached currently and no data reading is required.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution | Gets the vertical resolution, in pixels per inch, of this Image.
Width | Gets the image width.

Public Instance Methods

Add | Adds the specified image's frames to current frame.
AddFrame | Adds the frame to image
AddFrames | Adds the frames array to image
CacheData | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertFrame | The insert frame.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
RemoveFrame | Overloaded. Removes the frame by its index.
Resize | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
ResizeProportional | Performs proportional resize on the image. The proportional resize will resize each frame according to the ratio of newWidth/width and newHeight/height.
RotateFlip | Rotates, flips, or rotates and flips the Active frame only.
RotateFlipAll | Rotates the flip all frames in image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage Constructor

Initializes a new instance of the TiffImage class.

public TiffImage(
TiffFrame frame
);

Parameters

frame
The tiff frame to initialize image with.

Exceptions

Exception Type | Condition
ArgumentNullException | Tiff frame cannot be empty.;frame

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage Properties

The properties of the TiffImage class are listed below. For a complete list of TiffImage class members, see the TiffImage Members topic.

Public Instance Properties

ActiveFrame | Gets or sets the active frame.
BitsPerPixel | Gets the image bits per pixel value of current frame.
Bounds (inherited from Image) | Gets the image bounds.
ByteOrder | Gets or sets a value indicating the tiff byte order.
Container (inherited from Image) | Gets the Image container.
DataStreamContainer (inherited from DataStreamSupporter) | Gets the object's data stream.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
DitheringSettings | Gets or sets the dithering settings for tiff image. Settings are applied to all frames in image.
ExifData | Gets or sets EXIF data for the active frame.
Frames | Gets Frames array of the image.
Height | Gets the image height.
HorizontalResolution | Gets the horizontal resolution, in pixels per inch, of this Image.
IsCached | Gets a value indicating whether object's data is cached currently and no data reading is required.
IsRawDataAvailable (inherited from RasterImage) | Gets a value indicating whether raw data loading is available.
Palette (inherited from Image) | Gets or sets the color palette.
RawCustomColorConverter (inherited from RasterImage) | Gets or sets the custom color converter
RawDataFormat (inherited from RasterImage) | Gets the raw data format.
RawDataSettings (inherited from RasterImage) | Gets the current raw data settings. Note when using these settings the data loads without conversion.
RawDitheringMethod (inherited from RasterImage) | Gets or sets the dithering method to use for raw data conversion
RawFallbackIndex (inherited from RasterImage) | Gets or sets the fallback index to use when palette index is out of bounds
RawIndexedColorConverter (inherited from RasterImage) | Gets or sets the indexed color converter
RawLineSize (inherited from RasterImage) | Gets the raw line size in bytes.
Size (inherited from Image) | Gets the image size.
VerticalResolution | Gets the vertical resolution, in pixels per inch, of this Image.
Width | Gets the image width.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


ActiveFrame Property

Aspose.Imaging Documentation

TiffImage.ActiveFrame Property

Gets or sets the active frame.

public TiffFrame ActiveFrame {get; set;}

Property Value

Active frame.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

TiffImage.BitsPerPixel Property

Gets the image bits per pixel value of current frame.

public override int BitsPerPixel {get;}

Property Value

The image bits per pixel count.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


ByteOrder Property

Aspose.Imaging Documentation

TiffImage.ByteOrder Property

Gets or sets a value indicating the tiff byte order.

public TiffByteOrder ByteOrder {get; set;}

Property Value

The tiff byte order.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


DitheringSettings Property

Aspose.Imaging Documentation

TiffImage.DitheringSettings Property

Gets or sets the dithering settings for tiff image. Settings are applied to all frames in image.

public override DitheringMode DitheringSettings {get; set;}

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


ExifData Property

Aspose.Imaging Documentation

TiffImage.ExifData Property

Gets or sets EXIF data for the active frame.

public ExifData ExifData {get; set;}

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


Frames Property

Aspose.Imaging Documentation

TiffImage.Frames Property

Gets Frames array of the image.

public TiffFrame[] Frames {get;}

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


Height Property

Aspose.Imaging Documentation

TiffImage.Height Property

Gets the image height.

public override int Height {get;}

Property Value

The image height.

Implements

IObjectWithBounds.Height

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


HorizontalResolution Property

Aspose.Imaging Documentation

TiffImage.HorizontalResolution Property

Gets the horizontal resolution, in pixels per inch, of this Image.

public override double HorizontalResolution {get; set;}

Property Value

The horizontal resolution.

Remarks

Note by default this value is always 96 since different platforms cannot return the screen resolution. You may consider using the SetResolution method for updating both resolution values in single call.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


IsCached Property

Aspose.Imaging Documentation

TiffImage.IsCached Property

Gets a value indicating whether object's data is cached currently and no data reading is required.

public bool IsCached {get;}

Property Value

true if object's data is cached; otherwise, false.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


VerticalResolution Property

Aspose.Imaging Documentation

TiffImage.VerticalResolution Property

Gets the vertical resolution, in pixels per inch, of this Image.

public override double VerticalResolution {get; set;}

Property Value

The vertical resolution.

Remarks

Note by default this value is always 96 since different platforms cannot return the screen resolution. You may consider using the SetResolution method for updating both resolution values in single call.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


Width Property

Aspose.Imaging Documentation

TiffImage.Width Property

Gets the image width.

public override int Width {get;}

Property Value

The image width.

Implements

IObjectWithBounds.Width

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage Methods

The methods of the TiffImage class are listed below. For a complete list of TiffImage class members, see the TiffImage Members topic.

Public Instance Methods

Add | Adds the specified image's frames to current frame.
AddFrame | Adds the frame to image
AddFrames | Adds the frames array to image
CacheData | Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.
CanSave (inherited from Image) | Determines whether image can be saved to the specified file format represented by the passed save options.
Crop | Overloaded. Cropping the image.
Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDefaultPixels (inherited from RasterImage) | Overloaded. Gets the default pixels array using partial pixel loader.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPixel (inherited from RasterImage) | Gets an image pixel.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertFrame | The insert frame.
LoadCMYKPixels (inherited from RasterImage) | Loads pixels in CMYK format.
LoadPartialPixels (inherited from RasterImage) | Loads pixels partially by packs.
LoadPixels (inherited from RasterImage) | Loads pixels.
LoadRawData (inherited from RasterImage) | Loads raw data.
ReadScanLine (inherited from RasterImage) | Reads the whole scan line by the specified scan line index.
RemoveFrame | Overloaded. Removes the frame by its index.
Resize | Overloaded. Resizes the image.
Resize (inherited from Image) | Overloaded. Resizes the image. The default LeftTopToLeftTop is used.
ResizeProportional | Performs proportional resize on the image. The proportional resize will resize each frame according to the ratio of newWidth/width and newHeight/height.
RotateFlip | Rotates, flips, or rotates and flips the Active frame only.
RotateFlipAll | Rotates the flip all frames in image.
Save (inherited from Image) | Overloaded. Saves the image data to the underlying stream.
Save (inherited from DataStreamSupporter) | Overloaded. Saves the object's data to the current DataStreamSupporter.
SaveCMYKPixels (inherited from RasterImage) | Saves the pixels.
SavePixels (inherited from RasterImage) | Saves the pixels.
SaveRawData (inherited from RasterImage) | Saves the raw data.
SetPalette (inherited from RasterImage) | Sets the image palette.
SetPixel (inherited from RasterImage) | Sets an image pixel for the specified position.
SetResolution | Sets the resolution for this RasterImage.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteScanLine (inherited from RasterImage) | Writes the whole scan line to the specified scan line index.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage.Add Method

Adds the specified image's frames to current frame.

public void Add(
TiffImage image
);

Parameters

image
The source image.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage.AddFrame Method

Adds the frame to image

public void AddFrame(
TiffFrame frame
);

Parameters

frame
The frame to add.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage.AddFrames Method

Adds the frames array to image

public void AddFrames(
TiffFrame[] frames
);

Parameters

frames
The frames array to add

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage.CacheData Method

Caches the data and ensures no additional data loading will be performed from the underlying DataStreamContainer.

public void CacheData();

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


Crop Method

Aspose.Imaging Documentation

TiffImage.Crop Method

Cropping the image.

Overload List

Cropping the image.

public override void Crop(Rectangle);

Crops the specified left.

public override void Crop(int,int,int,int);

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage.Crop Method (Rectangle)

Cropping the image.

public override void Crop(
Rectangle rectangle
);

Parameters

rectangle
The rectangle.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffImage.Crop Overload List


TiffImage.Crop Method (Int32, Int32, Int32, Int32)

Crops the specified left.

public override void Crop(
int left,
int right,
int top,
int bottom
);

Parameters

left
The left shift.
right
The right shift.
top
The top shift.
bottom
The bottom shift.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffImage.Crop Overload List


TiffImage.InsertFrame Method

The insert frame.

public void InsertFrame(
int index,
TiffFrame frameToInsert
);

Parameters

index
Index of new frame in list of frames
frameToInsert
The frame To Insert.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


RemoveFrame Method

Aspose.Imaging Documentation

TiffImage.RemoveFrame Method

Removes the specified frame.

Overload List

Removes the specified frame.

public void RemoveFrame(TiffFrame);

Removes the frame by its index.

public TiffFrame RemoveFrame(int);

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage.RemoveFrame Method (TiffFrame)

Removes the specified frame.

public void RemoveFrame(
TiffFrame frame
);

Parameters

frame
The frame to remove.

Remarks

Note: do not forget to Dispose the frame if you will not add it to some other TiffImage.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffImage.RemoveFrame Overload List


TiffImage.RemoveFrame Method (Int32)

Removes the frame by its index.

public TiffFrame RemoveFrame(
int index
);

Parameters

index
Index of frame to be removed.

Return Value

The removed frame.

Remarks

Note: do not forget to Dispose the frame if you will not add it to some other TiffImage.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffImage.RemoveFrame Overload List


Resize Method

Aspose.Imaging Documentation

TiffImage.Resize Method

Resizes the image.

Overload List

Inherited from Image.

public void Resize(int,int);

Resizes the image.

public override void Resize(int,int,ResizeType);

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage.Resize Method (Int32, Int32, ResizeType)

Resizes the image.

public override void Resize(
int newWidth,
int newHeight,
ResizeType resizeType
);

Parameters

newWidth
The new width.
newHeight
The new height.
resizeType
The resize type.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffImage.Resize Overload List


TiffImage.ResizeProportional Method

Performs proportional resize on the image. The proportional resize will resize each frame according to the ratio of newWidth/width and newHeight/height.

public void ResizeProportional(
int newWidth,
int newHeight,
ResizeType resizeType
);

Parameters

newWidth
The new width.
newHeight
The new height.
resizeType
The resize type.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage.RotateFlip Method

Rotates, flips, or rotates and flips the Active frame only.

public override void RotateFlip(
RotateFlipType rotateFlipType
);

Parameters

rotateFlipType
The rotate flip type.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage.RotateFlipAll Method

Rotates the flip all frames in image.

public void RotateFlipAll(
RotateFlipType rotateFlip
);

Parameters

rotateFlip
The rotate flip type.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffImage.SetResolution Method

Sets the resolution for this RasterImage.

public override void SetResolution(
double dpiX,
double dpiY
);

Parameters

dpiX
The horizontal resolution, in dots per inch, of the RasterImage.
dpiY
The vertical resolution, in dots per inch, of the RasterImage.

See Also

TiffImage Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational Class

The tiff rational type.

For a list of all members of this type, see TiffRational Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffRational

public class TiffRational

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffRational Members | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational Members

TiffRational overview

Public Static Fields

Epsilon The epsilon for fraction calculation

Public Static Methods

ApproximateFraction Overloaded. Approximates the provided value to a fraction.

Public Static Operators

Equality Operator | Returns the comparison result of the two rational numbers.
Inequality Operator | Returns the negative comparison result of the two rational numbers.

Public Instance Constructors

TiffRational Overloaded. Initializes a new instance of the TiffRational class.

Public Instance Properties

Denominator | Gets the denominator.
Nominator | Gets the nominator.
Value | Gets the float value.
ValueD | Gets the double value.

Public Instance Methods

Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational Constructor

Initializes a new instance of the TiffRational class.

Overload List

Initializes a new instance of the TiffRational class.

public TiffRational();

Initializes a new instance of the TiffRational class.

public TiffRational(uint);

Initializes a new instance of the TiffRational class.

public TiffRational(uint,uint);

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational Constructor ()

Initializes a new instance of the TiffRational class.

public TiffRational();

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffRational Constructor Overload List


TiffRational Constructor (UInt32)

Initializes a new instance of the TiffRational class.

public TiffRational(
uint value
);

Parameters

value
The nominator value.

Remarks

The nominator will be used as the value specified and denominator will be equal 1.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffRational Constructor Overload List


TiffRational Constructor (UInt32, UInt32)

Initializes a new instance of the TiffRational class.

public TiffRational(
uint nominator,
uint denominator
);

Parameters

nominator
The nominator.
denominator
The denominator.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffRational Constructor Overload List


TiffRational Fields

The fields of the TiffRational class are listed below. For a complete list of TiffRational class members, see the TiffRational Members topic.

Public Static Fields

Epsilon The epsilon for fraction calculation

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational.Epsilon Field

The epsilon for fraction calculation

public const double Epsilon = 1E-06;

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational Properties

The properties of the TiffRational class are listed below. For a complete list of TiffRational class members, see the TiffRational Members topic.

Public Instance Properties

Denominator | Gets the denominator.
Nominator | Gets the nominator.
Value | Gets the float value.
ValueD | Gets the double value.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


Denominator Property

Aspose.Imaging Documentation

TiffRational.Denominator Property

Gets the denominator.

public uint Denominator {get;}

Property Value

The denominator.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


Nominator Property

Aspose.Imaging Documentation

TiffRational.Nominator Property

Gets the nominator.

public uint Nominator {get;}

Property Value

The nominator.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


Value Property

Aspose.Imaging Documentation

TiffRational.Value Property

Gets the float value.

public float Value {get;}

Property Value

The float value.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


ValueD Property

Aspose.Imaging Documentation

TiffRational.ValueD Property

Gets the double value.

public double ValueD {get;}

Property Value

The double value.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational Methods

The methods of the TiffRational class are listed below. For a complete list of TiffRational class members, see the TiffRational Members topic.

Public Static Methods

ApproximateFraction Overloaded. Approximates the provided value to a fraction.

Public Instance Methods

Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


ApproximateFraction Method

Aspose.Imaging Documentation

TiffRational.ApproximateFraction Method

Approximates the provided value to a fraction.

Overload List

Approximates the provided value to a fraction.

public static TiffRational ApproximateFraction(double);

Approximates the provided value to a fraction.

public static TiffRational ApproximateFraction(double,double);

Approximates the provided value to a fraction.

public static TiffRational ApproximateFraction(float);

Approximates the provided value to a fraction.

public static TiffRational ApproximateFraction(float,double);

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational.ApproximateFraction Method (Double)

Approximates the provided value to a fraction.

public static TiffRational ApproximateFraction(
double value
);

Parameters

value
The value.

Return Value

A rational number having error less than Epsilon.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffRational.ApproximateFraction Overload List


TiffRational.ApproximateFraction Method (Double, Double)

Approximates the provided value to a fraction.

public static TiffRational ApproximateFraction(
double value,
double epsilon
);

Parameters

value
The value.
epsilon
The error allowed.

Return Value

A rational number having error less than epsilon.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffRational.ApproximateFraction Overload List


TiffRational.ApproximateFraction Method (Single)

Approximates the provided value to a fraction.

public static TiffRational ApproximateFraction(
float value
);

Parameters

value
The value.

Return Value

A rational number having error less than Epsilon.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffRational.ApproximateFraction Overload List


TiffRational.ApproximateFraction Method (Single, Double)

Approximates the provided value to a fraction.

public static TiffRational ApproximateFraction(
float value,
double epsilon
);

Parameters

value
The value.
epsilon
The error allowed.

Return Value

A rational number having error less than epsilon.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffRational.ApproximateFraction Overload List


TiffRational.Equals Method

Determines whether the specified Object is equal to this instance.

public override bool Equals(
object obj
);

Parameters

obj
The Object to compare with this instance.

Return Value

true if the specified Object is equal to this instance; otherwise, false.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational.GetHashCode Method

Returns a hash code for this instance.

public override int GetHashCode();

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational Operators

The operators of the TiffRational class are listed below. For a complete list of TiffRational class members, see the TiffRational Members topic.

Public Static Operators

Equality Operator | Returns the comparison result of the two rational numbers.
Inequality Operator | Returns the negative comparison result of the two rational numbers.

See Also

TiffRational Class | TiffRational Members | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational Equality Operator

Returns the comparison result of the two rational numbers.

public static bool operator ==(
TiffRational rational1,
TiffRational rational2
);

Parameters

rational1
The first rational to compare.
rational2
The second rational to compare.

Return Value

The comparison result.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffRational Inequality Operator

Returns the negative comparison result of the two rational numbers.

public static bool operator !=(
TiffRational rational1,
TiffRational rational2
);

Parameters

rational1
The first rational to compare.
rational2
The second rational to compare.

Return Value

The negative comparison result.

See Also

TiffRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational Class

The tiff rational type.

For a list of all members of this type, see TiffSRational Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffSRational

public class TiffSRational

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffSRational Members | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational Members

TiffSRational overview

Public Static Fields

Epsilon The epsilon for fraction calculation

Public Static Methods

ApproximateFraction Overloaded. Approximates the provided value to a fraction.

Public Static Operators

Equality Operator | Returns the comparison result of the two rational numbers.
Inequality Operator | Returns the negative comparison result of the two rational numbers.

Public Instance Constructors

TiffSRational Overloaded. Initializes a new instance of the TiffSRational class.

Public Instance Properties

Denominator | Gets the denominator.
Nominator | Gets the nominator.
Value | Gets the float value.
ValueD | Gets the double value.

Public Instance Methods

Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational Constructor

Initializes a new instance of the TiffSRational class.

Overload List

Initializes a new instance of the TiffSRational class.

public TiffSRational();

Initializes a new instance of the TiffRational class.

public TiffSRational(int);

Initializes a new instance of the TiffSRational class.

public TiffSRational(int,int);

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational Constructor ()

Initializes a new instance of the TiffSRational class.

public TiffSRational();

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffSRational Constructor Overload List


TiffSRational Constructor (Int32)

Initializes a new instance of the TiffRational class.

public TiffSRational(
int value
);

Parameters

value
The nominator value.

Remarks

The nominator will be used as the value specified and denominator will be equal 1.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffSRational Constructor Overload List


TiffSRational Constructor (Int32, Int32)

Initializes a new instance of the TiffSRational class.

public TiffSRational(
int nominator,
int denominator
);

Parameters

nominator
The nominator.
denominator
The denominator.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffSRational Constructor Overload List


TiffSRational Fields

The fields of the TiffSRational class are listed below. For a complete list of TiffSRational class members, see the TiffSRational Members topic.

Public Static Fields

Epsilon The epsilon for fraction calculation

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational.Epsilon Field

The epsilon for fraction calculation

public const double Epsilon = 1E-06;

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational Properties

The properties of the TiffSRational class are listed below. For a complete list of TiffSRational class members, see the TiffSRational Members topic.

Public Instance Properties

Denominator | Gets the denominator.
Nominator | Gets the nominator.
Value | Gets the float value.
ValueD | Gets the double value.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


Denominator Property

Aspose.Imaging Documentation

TiffSRational.Denominator Property

Gets the denominator.

public int Denominator {get;}

Property Value

The denominator.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


Nominator Property

Aspose.Imaging Documentation

TiffSRational.Nominator Property

Gets the nominator.

public int Nominator {get;}

Property Value

The nominator.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


Value Property

Aspose.Imaging Documentation

TiffSRational.Value Property

Gets the float value.

public float Value {get;}

Property Value

The float value.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


ValueD Property

Aspose.Imaging Documentation

TiffSRational.ValueD Property

Gets the double value.

public double ValueD {get;}

Property Value

The double value.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational Methods

The methods of the TiffSRational class are listed below. For a complete list of TiffSRational class members, see the TiffSRational Members topic.

Public Static Methods

ApproximateFraction Overloaded. Approximates the provided value to a fraction.

Public Instance Methods

Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


ApproximateFraction Method

Aspose.Imaging Documentation

TiffSRational.ApproximateFraction Method

Approximates the provided value to a fraction.

Overload List

Approximates the provided value to a fraction.

public static TiffSRational ApproximateFraction(double);

Approximates the provided value to a fraction.

public static TiffSRational ApproximateFraction(double,double);

Approximates the provided value to a fraction.

public static TiffSRational ApproximateFraction(float);

Approximates the provided value to a fraction.

public static TiffSRational ApproximateFraction(float,double);

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational.ApproximateFraction Method (Double)

Approximates the provided value to a fraction.

public static TiffSRational ApproximateFraction(
double value
);

Parameters

value
The value.

Return Value

A rational number having error less than Epsilon.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffSRational.ApproximateFraction Overload List


TiffSRational.ApproximateFraction Method (Double, Double)

Approximates the provided value to a fraction.

public static TiffSRational ApproximateFraction(
double value,
double epsilon
);

Parameters

value
The value.
epsilon
The error allowed.

Return Value

A rational number having error less than epsilon.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffSRational.ApproximateFraction Overload List


TiffSRational.ApproximateFraction Method (Single)

Approximates the provided value to a fraction.

public static TiffSRational ApproximateFraction(
float value
);

Parameters

value
The value.

Return Value

A rational number having error less than Epsilon.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffSRational.ApproximateFraction Overload List


TiffSRational.ApproximateFraction Method (Single, Double)

Approximates the provided value to a fraction.

public static TiffSRational ApproximateFraction(
float value,
double epsilon
);

Parameters

value
The value.
epsilon
The error allowed.

Return Value

A rational number having error less than epsilon.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace | TiffSRational.ApproximateFraction Overload List


TiffSRational.Equals Method

Determines whether the specified Object is equal to this instance.

public override bool Equals(
object obj
);

Parameters

obj
The Object to compare with this instance.

Return Value

true if the specified Object is equal to this instance; otherwise, false.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational.GetHashCode Method

Returns a hash code for this instance.

public override int GetHashCode();

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational Operators

The operators of the TiffSRational class are listed below. For a complete list of TiffSRational class members, see the TiffSRational Members topic.

Public Static Operators

Equality Operator | Returns the comparison result of the two rational numbers.
Inequality Operator | Returns the negative comparison result of the two rational numbers.

See Also

TiffSRational Class | TiffSRational Members | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational Equality Operator

Returns the comparison result of the two rational numbers.

public static bool operator ==(
TiffSRational rational1,
TiffSRational rational2
);

Parameters

rational1
The first rational to compare.
rational2
The second rational to compare.

Return Value

The comparison result.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


TiffSRational Inequality Operator

Returns the negative comparison result of the two rational numbers.

public static bool operator !=(
TiffSRational rational1,
TiffSRational rational2
);

Parameters

rational1
The first rational to compare.
rational2
The second rational to compare.

Return Value

The negative comparison result.

See Also

TiffSRational Class | Aspose.Imaging.FileFormats.Tiff Namespace


Aspose.Imaging.FileFormats.Tiff.Enums

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Tiff.Enums Namespace

Namespace hierarchy

Enumerations

Enumeration | Description
Group3Options | Options for CCITT Group 3/4 fax encoding. Possible values for GROUP3OPTIONS / TiffTag.T4OPTIONS and TiffTag.GROUP4OPTIONS / TiffTag.T6OPTIONS tags.
TiffAlphaStorage | Specifies the alpha storage for tiff documents.
TiffByteOrder | The byte order for the tiff image
TiffCompressions | Holds compression types
TiffDataTypes | The tiff data type enum.
TiffFillOrders | Data order within a byte. Possible values for FILLORDER tag.
TiffNewSubFileTypes | The tiff new sub file type enum.
TiffOrientations | Image orientation. Possible values for ORIENTATION tag.
TiffPhotometrics | Photometric interpolation enum
TiffPlanarConfigs | Storage organization. Possible values for PLANARCONFIG tag.
TiffPredictor | Prediction scheme for LZW
TiffResolutionUnits | Tiff Resolution Unit Enum
TiffSampleFormats | Sample format enum
TiffTags | The tiff tag enum.
TiffThresholds | Thresholding used on data.


Group3Options Enumeration

Options for CCITT Group 3/4 fax encoding.
Possible values for GROUP3OPTIONS / TiffTag.T4OPTIONS and TiffTag.GROUP4OPTIONS / TiffTag.T6OPTIONS tags.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum Group3Options

Members

Member Name | Description | Value
Encoding1D | 1-dimensional coding. (default) | 0
Encoding2D | 2-dimensional coding. | 1
Uncompressed | Data not compressed. | 2
FillBits | Fill to byte boundary. | 4

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffAlphaStorage Enumeration

Specifies the alpha storage for tiff documents.

public enum TiffAlphaStorage

Members

Member Name | Description | Value
Unspecified | The alpha is not specified and stored in the tiff file. | 0
Associated | The alpha value is stored in premultiplied form. When alpha is restored there may be some rounding effects and restored value may be different from the original. | 1
Unassociated | The alpha value is stored in unassociated form. That means that alpha restored is exactly the same as it was stored to the tiff. | 2

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffByteOrder Enumeration

The byte order for the tiff image

public enum TiffByteOrder

Members

Member Name | Description | Value
BigEndian | The big endian byte order (Motorola). | 19789
LittleEndian | The little endian byte order (Intel). | 18761

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffCompressions Enumeration

Holds compression types

public enum TiffCompressions

Members

Member Name | Description | Value
None | Dump mode. | 1
CcittRle | CCITT modified Huffman RLE. | 2
CcittFax3 | CCITT Group 3 fax encoding. | 3
CcittFax4 | CCITT Group 4 fax encoding. | 4
Lzw | Lempel-Ziv & Welch. | 5
Ojpeg | Original JPEG / Old-style JPEG (6.0). | 6
Jpeg | JPEG DCT compression. Introduced post TIFF rev 6.0. | 7
Next | NeXT 2-bit RLE. | 32766
CcittRleW | CCITT RLE. | 32771
Packbits | Macintosh RLE. | 32773
Thunderscan | ThunderScan RLE. | 32809
It8Ctpad | IT8 CT w/padding. Reserved for ANSI IT8 TIFF/IT. | 32895
It8Lw | IT8 Linework RLE. Reserved for ANSI IT8 TIFF/IT. | 32896
It8Mp | IT8 Monochrome picture. Reserved for ANSI IT8 TIFF/IT. | 32897
It8Bl | IT8 Binary line art. Reserved for ANSI IT8 TIFF/IT. | 32898
PixarFilm | Pixar companded 10bit LZW. Reserved for Pixar. | 32908
PixarLog | Pixar companded 11bit ZIP. Reserved for Pixar. | 32909
Deflate | Deflate compression. | 32946
AdobeDeflate | Deflate compression, as recognized by Adobe. | 8
Dcs | Kodak DCS encoding. Reserved for Oceana Matrix | 32947
Jbig | ISO Jpeg big. | 34661
Sgilog | SGI Log Luminance RLE. | 34676
Sgilog24 | SGI Log 24-bit packed. | 34677
Jp2000 | Leadtools JPEG2000. | 34712

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffDataTypes Enumeration

The tiff data type enum.

public enum TiffDataTypes

Members

Member Name | Description | Value
Byte | 8-bit unsigned integer. | 1
Ascii | 8-bit bytes with last byte null. | 2
Short | 16-bit unsigned integer. | 3
Long | 32-bit unsigned integer. | 4
Rational | 64-bit unsigned fraction. | 5
Sbyte | 8-bit signed integer. | 6
Undefined | 8-bit untyped data. | 7
Sshort | 16-bit signed integer. | 8
Slong | 32-bit signed integer. | 9
Srational | 64-bit signed fraction. | 10
Float | 32-bit IEEE floating point. | 11
Double | 64-bit IEEE floating point. | 12

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffFillOrders Enumeration

Data order within a byte.
Possible values for FILLORDER tag.

public enum TiffFillOrders

Members

Member Name | Description | Value
Msb2Lsb | Most significant -> least. | 1
Lsb2Msb | Least significant -> most. | 2

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffNewSubFileTypes Enumeration

The tiff new sub file type enum.

public enum TiffNewSubFileTypes

Members

Member Name | Description | Value
FileTypeDefault | The default filetype. | 0
FileTypeReducedImage | The reduced image filetype. | 1
FileTypePage | The page filetype. | 2
FileTypeMask | The mask filetype. | 4
FileTypeLast | The last filetype. | 5

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffOrientations Enumeration

Image orientation.
Possible values for ORIENTATION tag.

public enum TiffOrientations

Members

Member Name | Description | Value
TopLeft | Row 0 top, Column 0 lhs. | 1
TopRight | Row 0 top, Column 0 rhs. | 2
BottomRight | Row 0 bottom, Column 0 rhs. | 3
BottomLeft | Row 0 bottom, Column 0 lhs. | 4
LeftTop | Row 0 lhs, Column 0 top. | 5
RightTop | Row 0 rhs, Column 0 top. | 6
RightBottom | Row 0 rhs, Column 0 bottom. | 7
LeftBottom | Row 0 lhs, Column 0 bottom. | 8

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffPhotometrics Enumeration

Photometric interpolation enum

public enum TiffPhotometrics

Members

Member Name | Description | Value
MinIsWhite | Min value is white. | 0
MinIsBlack | Min value is black. | 1
Rgb | RGB color model. | 2
Palette | Color map indexed. | 3
Mask | [obsoleted by TIFF rev. 6.0] Holdout mask. | 4
Separated | Color separations. | 5
Ycbcr | The CCIR 601. | 6
Cielab | 1976 CIE L*a*b*. | 8
Icclab | ICC L*a*b*. Introduced post TIFF rev 6.0 by Adobe TIFF Technote 4. | 9
Itulab | ITU L*a*b*. | 10
Logl | CIE Log2(L). | 32844
Logluv | CIE Log2(L) (u',v'). | 32845

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffPlanarConfigs Enumeration

Storage organization.
Possible values for PLANARCONFIG tag.

public enum TiffPlanarConfigs

Members

Member Name | Description | Value
Contiguous | Single image plane. | 1
Separate | Separate planes of data. | 2

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffPredictor Enumeration

Prediction scheme for LZW

public enum TiffPredictor

Members

Member Name | Description | Value
None | No prediction scheme used. | 1
Horizontal | Horizontal differencing. | 2

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffResolutionUnits Enumeration

Tiff Resolution Unit Enum

public enum TiffResolutionUnits

Members

Member Name | Description | Value
None | No meaningful units. | 1
Inch | English system. | 2
Centimeter | Metric system. | 3

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffSampleFormats Enumeration

Sample format enum

public enum TiffSampleFormats

Members

Member Name | Description | Value
Uint | Unsigned integer data | 1
Int | Signed integer data | 2
IeeeFp | IEEE floating point data | 3
Void | Untyped data | 4
ComplexInt | Complex signed int | 5
ComplexIeeeFp | Complex ieee floating | 6

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffTags Enumeration

The tiff tag enum.

public enum TiffTags

Members

Member Name | Description | Value
SubFileType | Subfile data descriptor. | 254
OsubfileType | [obsoleted by TIFF rev. 5.0] Kind of data in subfile. | 255
ImageWidth | Image width in pixels. | 256
ImageLength | Image height in pixels. | 257
BitsPerSample | Bits per channel (sample). | 258
Compression | Data compression technique. | 259
Photometric | Photometric interpretation. | 262
Thresholding | [obsoleted by TIFF rev. 5.0] Thresholding used on data. | 263
CellWidth | [obsoleted by TIFF rev. 5.0] Dithering matrix width. | 264
CellLength | [obsoleted by TIFF rev. 5.0] Dithering matrix height. | 265
FillOrder | Data order within a byte. | 266
DocumentName | Name of document which holds for image. | 269
ImageDescription | Information about image. | 270
Make | Scanner manufacturer name. | 271
Model | Scanner model name/number. | 272
StripOffsets | Offsets to data strips. | 273
Orientation | [obsoleted by TIFF rev. 5.0] Image orientation. | 274
SamplesPerPixel | Samples per pixel. | 277
RowsPerStrip | Rows per strip of data. | 278
StripByteCounts | Bytes counts for strips. | 279
MinSampleValue | [obsoleted by TIFF rev. 5.0] Minimum sample value. | 280
MaxSampleValue | [obsoleted by TIFF rev. 5.0] Maximum sample value. | 281
Xresolution | Pixels/resolution in x. | 282
Yresolution | Pixels/resolution in y. | 283
PlanarConfig | Storage organization. | 284
PageName | Page name image is from. | 285
Xposition | X page offset of image lhs. | 286
Yposition | Y page offset of image lhs. | 287
FreeOffsets | [obsoleted by TIFF rev. 5.0] Byte offset to free block. | 288
FreeByteCounts | [obsoleted by TIFF rev. 5.0] Sizes of free blocks. | 289
GrayResponseUnit | [obsoleted by TIFF rev. 6.0] Gray scale curve accuracy. | 290
GrayResponseCurve | [obsoleted by TIFF rev. 6.0] Gray scale response curve. | 291
T4Options | TIFF 6.0 proper name alias for GROUP3OPTIONS. Options for CCITT Group 3 fax encoding. 32 flag bits. | 292
T6Options | Options for CCITT Group 4 fax encoding. 32 flag bits. TIFF 6.0 proper name alias for GROUP4OPTIONS. | 293
ResolutionUnit | Units of resolutions. | 296
PageNumber | Page numbers of multi-page. | 297
ColorResponseUnit | [obsoleted by TIFF rev. 6.0] Color curve accuracy. | 300
TransferFunction | Colorimetry info. | 301
Software | Name & release. | 305
DateTime | Creation date and time. | 306
Artist | Creator of image. | 315
HostComputer | Machine where created. | 316
Predictor | Prediction scheme w/ LZW. | 317
WhitePoint | Image white point. | 318
PrimaryChromaticities | Primary chromaticities. | 319
ColorMap | RGB map for pallette image. | 320
HalftoneHints | Highlight + shadow info. | 321
TileWidth | Tile width in pixels. | 322
TileLength | Tile height in pixels. | 323
TileOffsets | Offsets to data tiles. | 324
TileByteCounts | Byte counts for tiles. | 325
BadFaxLines | Lines with wrong pixel count. | 326
CleanFaxData | Regenerated line info. | 327
ConsecutiveBadFaxLines | Max consecutive bad lines. | 328
SubIfd | Subimage descriptors. | 330
InkSet | Inks in separated image. | 332
InkNames | ASCII names of inks. | 333
NumberOfInks | Number of inks. | 334
DotRange | 0% and 100% dot codes. | 336
TargetPrinter | Separation target. | 337
ExtraSamples | Information about extra samples. | 338
SampleFormat | Data sample format. | 339
SminSampleValue | Variable MinSampleValue. | 340
SmaxSampleValue | Variable MaxSampleValue. | 341
TransferRange | Variable TransferRange | 342
ClipPath | ClipPath. Introduced post TIFF rev 6.0 by Adobe TIFF technote 2. | 343
Xclippathunits | XClipPathUnits. Introduced post TIFF rev 6.0 by Adobe TIFF technote 2. | 344
Yclippathunits | YClipPathUnits. Introduced post TIFF rev 6.0 by Adobe TIFF technote 2. | 345
Indexed | Indexed. Introduced post TIFF rev 6.0 by Adobe TIFF Technote 3. | 346
JpegTables | JPEG table stream. Introduced post TIFF rev 6.0. | 347
OpiProxy | OPI Proxy. Introduced post TIFF rev 6.0 by Adobe TIFF technote. | 351
JpegProc | [obsoleted by Technical Note #2 which specifies a revised JPEG-in-TIFF scheme] JPEG processing algorithm. | 512
JpegInerchangeFormat | [obsoleted by Technical Note #2 which specifies a revised JPEG-in-TIFF scheme] Pointer to SOI marker. | 513
JpegInterchangeFormatLength | [obsoleted by Technical Note #2 which specifies a revised JPEG-in-TIFF scheme] JFIF stream length | 514
JpegRestartInterval | [obsoleted by Technical Note #2 which specifies a revised JPEG-in-TIFF scheme] Restart interval length. | 515
JpegLosslessPredictors | [obsoleted by Technical Note #2 which specifies a revised JPEG-in-TIFF scheme] Lossless proc predictor. | 517
JpegPointTransform | [obsoleted by Technical Note #2 which specifies a revised JPEG-in-TIFF scheme] Lossless point transform. | 518
JpegQTables | [obsoleted by Technical Note #2 which specifies a revised JPEG-in-TIFF scheme] Q matrice offsets. | 519
JpegDCtables | [obsoleted by Technical Note #2 which specifies a revised JPEG-in-TIFF scheme] DCT table offsets. | 520
JpegACtables | [obsoleted by Technical Note #2 which specifies a revised JPEG-in-TIFF scheme] AC coefficient offsets. | 521
YcbcrCoefficients | RGB -> YCbCr transform. | 529
YcbcrSubSampling | YCbCr subsampling factors. | 530
YcbcrPositioning | Subsample positioning. | 531
ReferenceBlackWhite | Colorimetry info. | 532
XmlPacket | XML packet. Introduced post TIFF rev 6.0 by Adobe XMP Specification, January 2004. | 700
OpiImageid | OPI ImageID. Introduced post TIFF rev 6.0 by Adobe TIFF technote. | 32781
Refpts | Image reference points. Private tag registered to Island Graphics. | 32953
Copyright | Copyright string. This tag is listed in the TIFF rev. 6.0 w/ unknown ownership. | 33432

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


TiffThresholds Enumeration

Thresholding used on data.

public enum TiffThresholds

Members

Member Name | Description | Value
NoDithering | No dithering is performed. | 1
HalfTone | Dithered scan. | 2
ErrorDiffuse | Usually Floyd-Steinberg. | 3

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.Enums

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


Aspose.Imaging.FileFormats.Tiff.FileManagement

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace

Namespace hierarchy

Classes

Class | Description
TiffBigEndianStream | The tiff stream for handling big endian tiff file format.
TiffStream | The tiff stream for handling little endian tiff file format.


TiffBigEndianStream Class

The tiff stream for handling big endian tiff file format.

For a list of all members of this type, see TiffBigEndianStream Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.StreamContainer
Aspose.Imaging.FileFormats.Tiff.FileManagement.TiffStream
Aspose.Imaging.FileFormats.Tiff.FileManagement.TiffBigEndianStream

public sealed class TiffBigEndianStream : TiffStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.FileManagement

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffBigEndianStream Members | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffBigEndianStream Members

TiffBigEndianStream overview

Public Instance Constructors

TiffBigEndianStream Overloaded. Initializes a new instance of the TiffBigEndianStream class.

Public Instance Properties

CanRead (inherited from StreamContainer) | Gets a value indicating whether stream supports reading.
CanSeek (inherited from StreamContainer) | Gets a value indicating whether stream supports seeking.
CanWrite (inherited from StreamContainer) | Gets a value indicating whether stream supports writing.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
IsStreamDisposedOnClose (inherited from StreamContainer) | Gets a value indicating whether this stream is disposed on close.
Length (inherited from StreamContainer) | Gets or sets the stream length in bytes. This value is less than the Length by the starting stream position passed in the StreamContainer constructor.
Position (inherited from StreamContainer) | Gets or sets the current position within the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.
Stream (inherited from StreamContainer) | Gets the data stream.

Public Instance Methods

Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from StreamContainer) | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Read (inherited from StreamContainer) | Overloaded. Reads bytes to fill the specified bytes buffer.
ReadByte (inherited from StreamContainer) | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.
ReadDouble (inherited from TiffStream) | Read a single double value from the stream.
ReadDoubleArrayInt32 (inherited from TiffStream) | Reads an array of double values from the stream.
ReadDoubleArrayUInt32 (inherited from TiffStream) | Reads an array of double values from the stream.
ReadFloat (inherited from TiffStream) | Read a single float value from the stream.
ReadFloatArrayInt32 (inherited from TiffStream) | Reads an array of float values from the stream.
ReadFloatArrayUInt32 (inherited from TiffStream) | Reads an array of float values from the stream.
ReadRational (inherited from TiffStream) | Read a single rational number value from the stream.
ReadRationalArrayInt32 (inherited from TiffStream) | Reads an array of rational values from the stream.
ReadRationalArrayUInt32 (inherited from TiffStream) | Reads an array of rational values from the stream.
ReadSByte (inherited from TiffStream) | Reads signed byte data from the stream.
ReadSByteArrayInt32 (inherited from TiffStream) | Reads an array of signed byte values from the stream.
ReadSByteArrayUInt32 (inherited from TiffStream) | Reads an array of signed byte values from the stream.
ReadSLong (inherited from TiffStream) | Read signed integer value from the stream.
ReadSLongArrayInt32 (inherited from TiffStream) | Reads an array of signed integer values from the stream.
ReadSLongArrayUInt32 (inherited from TiffStream) | Reads an array of signed integer values from the stream.
ReadSRational (inherited from TiffStream) | Read a single signed rational number value from the stream.
ReadSRationalArrayInt32 (inherited from TiffStream) | Reads an array of signed rational values from the stream.
ReadSRationalArrayUInt32 (inherited from TiffStream) | Reads an array of signed rational values from the stream.
ReadSShort (inherited from TiffStream) | Read signed short value from the stream.
ReadSShortArrayInt32 (inherited from TiffStream) | Reads an array of signed short values from the stream.
ReadSShortArrayUInt32 (inherited from TiffStream) | Reads an array of signed short values from the stream.
ReadUByte (inherited from TiffStream) | Read unsigned byte value from the stream.
ReadUByteArrayInt32 (inherited from TiffStream) | Reads an array of unsigned byte values from the stream.
ReadUByteArrayUInt32 (inherited from TiffStream) | Reads an array of unsigned byte values from the stream.
ReadULong (inherited from TiffStream) | Read unsigned integer value from the stream.
ReadULongArrayInt32 (inherited from TiffStream) | Reads an array of unsigned integer values from the stream.
ReadULongArrayUInt32 (inherited from TiffStream) | Reads an array of unsigned integer values from the stream.
ReadUShort (inherited from TiffStream) | Read unsigned short value from the stream.
ReadUShortArrayInt32 (inherited from TiffStream) | Reads an array of unsigned integer values from the stream.
ReadUShortArrayUInt32 (inherited from TiffStream) | Reads an array of unsigned integer values from the stream.
Save (inherited from StreamContainer) | Overloaded. Saves (copies) the stream's data to the specified stream. Uses default buffer size ReadWriteBytesCount and stream Length value.
Seek (inherited from StreamContainer) | Sets the position within the current stream.
SeekBegin (inherited from StreamContainer) | Sets the stream position to the beginning of the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.
Shift (inherited from StreamContainer) | Shifts the data from the current stream position. The data starts from the current byte and continues to the end of the file.
ToBytes (inherited from StreamContainer) | Overloaded. Converts the stream data to the Byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from StreamContainer) | Overloaded. Writes all of the specified bytes to the stream.
WriteByte (inherited from StreamContainer) | Writes a byte to the current position in the stream and advances the position within the stream by one byte.
WriteDouble (inherited from TiffStream) | Writes a single double value to the stream.
WriteDoubleArray (inherited from TiffStream) | Writes an array of double values to the stream.
WriteFloat (inherited from TiffStream) | Writes a single float value to the stream.
WriteFloatArray (inherited from TiffStream) | Writes an array of float values to the stream.
WriteRational (inherited from TiffStream) | Writes a single rational number value to the stream.
WriteRationalArray (inherited from TiffStream) | Writes an array of unsigned rational values to the stream.
WriteSByte (inherited from TiffStream) | Writes a single signed byte value to the stream.
WriteSByteArray (inherited from TiffStream) | Writes an array of signed byte values to the stream.
WriteSlong (inherited from TiffStream) | Writes a single integer value to the stream.
WriteSLongArray (inherited from TiffStream) | Writes an array of integer values to the stream.
WriteSRational (inherited from TiffStream) | Writes a single signed rational number value to the stream.
WriteSRationalArray (inherited from TiffStream) | Writes an array of signed rational values to the stream.
WriteSShort (inherited from TiffStream) | Writes a single short value to the stream.
WriteSShortArray (inherited from TiffStream) | Writes an array of short values to the stream.
WriteTo (inherited from StreamContainer) | Overloaded. Copies the contained data to another StreamContainer.
WriteUByte (inherited from TiffStream) | Writes a single byte value to the stream.
WriteULong (inherited from TiffStream) | Writes a single unsigned integer value to the stream.
WriteULongArray (inherited from TiffStream) | Writes an array of unsigned integer values to the stream.
WriteUShort (inherited from TiffStream) | Writes a single unsigned short value to the stream.
WriteUShortArray (inherited from TiffStream) | Writes an array of unsigned short values to the stream.

See Also

TiffBigEndianStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffBigEndianStream Constructor

Initializes a new instance of the TiffBigEndianStream class.

Overload List

Initializes a new instance of the TiffBigEndianStream class.

public TiffBigEndianStream(Stream);

Initializes a new instance of the TiffBigEndianStream class.

public TiffBigEndianStream(Stream,bool);

See Also

TiffBigEndianStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffBigEndianStream Constructor (Stream)

Initializes a new instance of the TiffBigEndianStream class.

public TiffBigEndianStream(
Stream stream
);

Parameters

stream
The stream.

See Also

TiffBigEndianStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace | TiffBigEndianStream Constructor Overload List


TiffBigEndianStream Constructor (Stream, Boolean)

Initializes a new instance of the TiffBigEndianStream class.

public TiffBigEndianStream(
Stream stream,
bool disposeStream
);

Parameters

stream
The stream.
disposeStream
if set to true stream will be disposed.

See Also

TiffBigEndianStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace | TiffBigEndianStream Constructor Overload List


TiffStream Class

The tiff stream for handling little endian tiff file format.

For a list of all members of this type, see TiffStream Members.

System.Object
Aspose.Imaging.DisposableObject
Aspose.Imaging.StreamContainer
Aspose.Imaging.FileFormats.Tiff.FileManagement.TiffStream
Aspose.Imaging.FileFormats.Tiff.FileManagement.TiffBigEndianStream

public class TiffStream : StreamContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.FileManagement

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffStream Members | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream Members

TiffStream overview

Public Instance Constructors

TiffStream Overloaded. Initializes a new instance of the TiffStream class.

Public Instance Properties

CanRead (inherited from StreamContainer) | Gets a value indicating whether stream supports reading.
CanSeek (inherited from StreamContainer) | Gets a value indicating whether stream supports seeking.
CanWrite (inherited from StreamContainer) | Gets a value indicating whether stream supports writing.
Disposed (inherited from DisposableObject) | Gets a value indicating whether this instance is disposed.
IsStreamDisposedOnClose (inherited from StreamContainer) | Gets a value indicating whether this stream is disposed on close.
Length (inherited from StreamContainer) | Gets or sets the stream length in bytes. This value is less than the Length by the starting stream position passed in the StreamContainer constructor.
Position (inherited from StreamContainer) | Gets or sets the current position within the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.
Stream (inherited from StreamContainer) | Gets the data stream.

Public Instance Methods

Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from StreamContainer) | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Read (inherited from StreamContainer) | Overloaded. Reads bytes to fill the specified bytes buffer.
ReadByte (inherited from StreamContainer) | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.
ReadDouble | Read a single double value from the stream.
ReadDoubleArrayInt32 | Reads an array of double values from the stream.
ReadDoubleArrayUInt32 | Reads an array of double values from the stream.
ReadFloat | Read a single float value from the stream.
ReadFloatArrayInt32 | Reads an array of float values from the stream.
ReadFloatArrayUInt32 | Reads an array of float values from the stream.
ReadRational | Read a single rational number value from the stream.
ReadRationalArrayInt32 | Reads an array of rational values from the stream.
ReadRationalArrayUInt32 | Reads an array of rational values from the stream.
ReadSByte | Reads signed byte data from the stream.
ReadSByteArrayInt32 | Reads an array of signed byte values from the stream.
ReadSByteArrayUInt32 | Reads an array of signed byte values from the stream.
ReadSLong | Read signed integer value from the stream.
ReadSLongArrayInt32 | Reads an array of signed integer values from the stream.
ReadSLongArrayUInt32 | Reads an array of signed integer values from the stream.
ReadSRational | Read a single signed rational number value from the stream.
ReadSRationalArrayInt32 | Reads an array of signed rational values from the stream.
ReadSRationalArrayUInt32 | Reads an array of signed rational values from the stream.
ReadSShort | Read signed short value from the stream.
ReadSShortArrayInt32 | Reads an array of signed short values from the stream.
ReadSShortArrayUInt32 | Reads an array of signed short values from the stream.
ReadUByte | Read unsigned byte value from the stream.
ReadUByteArrayInt32 | Reads an array of unsigned byte values from the stream.
ReadUByteArrayUInt32 | Reads an array of unsigned byte values from the stream.
ReadULong | Read unsigned integer value from the stream.
ReadULongArrayInt32 | Reads an array of unsigned integer values from the stream.
ReadULongArrayUInt32 | Reads an array of unsigned integer values from the stream.
ReadUShort | Read unsigned short value from the stream.
ReadUShortArrayInt32 | Reads an array of unsigned integer values from the stream.
ReadUShortArrayUInt32 | Reads an array of unsigned integer values from the stream.
Save (inherited from StreamContainer) | Overloaded. Saves (copies) the stream's data to the specified stream. Uses default buffer size ReadWriteBytesCount and stream Length value.
Seek (inherited from StreamContainer) | Sets the position within the current stream.
SeekBegin (inherited from StreamContainer) | Sets the stream position to the beginning of the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.
Shift (inherited from StreamContainer) | Shifts the data from the current stream position. The data starts from the current byte and continues to the end of the file.
ToBytes (inherited from StreamContainer) | Overloaded. Converts the stream data to the Byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from StreamContainer) | Overloaded. Writes all of the specified bytes to the stream.
WriteByte (inherited from StreamContainer) | Writes a byte to the current position in the stream and advances the position within the stream by one byte.
WriteDouble | Writes a single double value to the stream.
WriteDoubleArray | Writes an array of double values to the stream.
WriteFloat | Writes a single float value to the stream.
WriteFloatArray | Writes an array of float values to the stream.
WriteRational | Writes a single rational number value to the stream.
WriteRationalArray | Writes an array of unsigned rational values to the stream.
WriteSByte | Writes a single signed byte value to the stream.
WriteSByteArray | Writes an array of signed byte values to the stream.
WriteSlong | Writes a single integer value to the stream.
WriteSLongArray | Writes an array of integer values to the stream.
WriteSRational | Writes a single signed rational number value to the stream.
WriteSRationalArray | Writes an array of signed rational values to the stream.
WriteSShort | Writes a single short value to the stream.
WriteSShortArray | Writes an array of short values to the stream.
WriteTo (inherited from StreamContainer) | Overloaded. Copies the contained data to another StreamContainer.
WriteUByte | Writes a single byte value to the stream.
WriteULong | Writes a single unsigned integer value to the stream.
WriteULongArray | Writes an array of unsigned integer values to the stream.
WriteUShort | Writes a single unsigned short value to the stream.
WriteUShortArray | Writes an array of unsigned short values to the stream.

Protected Instance Methods

AfterStreamDisposed (inherited from StreamContainer) | Called after the stream is disposed.
BeforeSave (inherited from StreamContainer) | Called before save occurs on the destination stream.
BeforeStreamDisposed (inherited from StreamContainer) | Called before the stream is disposed.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ProcessReadDataDouble | Performs a conversion to the double array.
ProcessReadDataFloat | Performs a conversion to the float array.
ProcessReadDataLong | Performs a conversion to the integer array.
ProcessReadDataShort | Performs a conversion to the short array.
ProcessReadDataULong | Performs a conversion to the unsigned integer array.
ProcessReadDataUShort | Performs a conversion to the unsigned short array.
ProcessWriteDataDouble | Performs a conversion from the specific data type to the raw bytes.
ProcessWriteDataFloat | Performs a conversion from the specific data type to the raw bytes.
ProcessWriteDataLong | Performs a conversion from the specific data type to the raw bytes.
ProcessWriteDataRational | Performs a conversion from the specific data type to the raw bytes.
ProcessWriteDataShort | Performs a conversion from the specific data type to the raw bytes.
ProcessWriteDataULong | Performs a conversion from the specific data type to the raw bytes.
ProcessWriteDataUShort | Performs a conversion from the specific data type to the raw bytes.
ReleaseManagedResources (inherited from StreamContainer) | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream Constructor

Initializes a new instance of the TiffStream class.

Overload List

Initializes a new instance of the TiffStream class.

public TiffStream(Stream);

Initializes a new instance of the TiffStream class.

public TiffStream(Stream,bool);

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream Constructor (Stream)

Initializes a new instance of the TiffStream class.

public TiffStream(
Stream stream
);

Parameters

stream
The stream.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace | TiffStream Constructor Overload List


TiffStream Constructor (Stream, Boolean)

Initializes a new instance of the TiffStream class.

public TiffStream(
Stream stream,
bool disposeStream
);

Parameters

stream
The stream.
disposeStream
if set to true stream will be disposed.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace | TiffStream Constructor Overload List


TiffStream Methods

The methods of the TiffStream class are listed below. For a complete list of TiffStream class members, see the TiffStream Members topic.

Public Instance Methods

Dispose (inherited from DisposableObject) | Disposes the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from StreamContainer) | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Read (inherited from StreamContainer) | Overloaded. Reads bytes to fill the specified bytes buffer.
ReadByte (inherited from StreamContainer) | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.
ReadDouble | Read a single double value from the stream.
ReadDoubleArrayInt32 | Reads an array of double values from the stream.
ReadDoubleArrayUInt32 | Reads an array of double values from the stream.
ReadFloat | Read a single float value from the stream.
ReadFloatArrayInt32 | Reads an array of float values from the stream.
ReadFloatArrayUInt32 | Reads an array of float values from the stream.
ReadRational | Read a single rational number value from the stream.
ReadRationalArrayInt32 | Reads an array of rational values from the stream.
ReadRationalArrayUInt32 | Reads an array of rational values from the stream.
ReadSByte | Reads signed byte data from the stream.
ReadSByteArrayInt32 | Reads an array of signed byte values from the stream.
ReadSByteArrayUInt32 | Reads an array of signed byte values from the stream.
ReadSLong | Read signed integer value from the stream.
ReadSLongArrayInt32 | Reads an array of signed integer values from the stream.
ReadSLongArrayUInt32 | Reads an array of signed integer values from the stream.
ReadSRational | Read a single signed rational number value from the stream.
ReadSRationalArrayInt32 | Reads an array of signed rational values from the stream.
ReadSRationalArrayUInt32 | Reads an array of signed rational values from the stream.
ReadSShort | Read signed short value from the stream.
ReadSShortArrayInt32 | Reads an array of signed short values from the stream.
ReadSShortArrayUInt32 | Reads an array of signed short values from the stream.
ReadUByte | Read unsigned byte value from the stream.
ReadUByteArrayInt32 | Reads an array of unsigned byte values from the stream.
ReadUByteArrayUInt32 | Reads an array of unsigned byte values from the stream.
ReadULong | Read unsigned integer value from the stream.
ReadULongArrayInt32 | Reads an array of unsigned integer values from the stream.
ReadULongArrayUInt32 | Reads an array of unsigned integer values from the stream.
ReadUShort | Read unsigned short value from the stream.
ReadUShortArrayInt32 | Reads an array of unsigned integer values from the stream.
ReadUShortArrayUInt32 | Reads an array of unsigned integer values from the stream.
Save (inherited from StreamContainer) | Overloaded. Saves (copies) the stream's data to the specified stream. Uses default buffer size ReadWriteBytesCount and stream Length value.
Seek (inherited from StreamContainer) | Sets the position within the current stream.
SeekBegin (inherited from StreamContainer) | Sets the stream position to the beginning of the stream. This value represents offset from the starting stream position passed in the StreamContainer constructor.
Shift (inherited from StreamContainer) | Shifts the data from the current stream position. The data starts from the current byte and continues to the end of the file.
ToBytes (inherited from StreamContainer) | Overloaded. Converts the stream data to the Byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write (inherited from StreamContainer) | Overloaded. Writes all of the specified bytes to the stream.
WriteByte (inherited from StreamContainer) | Writes a byte to the current position in the stream and advances the position within the stream by one byte.
WriteDouble | Writes a single double value to the stream.
WriteDoubleArray | Writes an array of double values to the stream.
WriteFloat | Writes a single float value to the stream.
WriteFloatArray | Writes an array of float values to the stream.
WriteRational | Writes a single rational number value to the stream.
WriteRationalArray | Writes an array of unsigned rational values to the stream.
WriteSByte | Writes a single signed byte value to the stream.
WriteSByteArray | Writes an array of signed byte values to the stream.
WriteSlong | Writes a single integer value to the stream.
WriteSLongArray | Writes an array of integer values to the stream.
WriteSRational | Writes a single signed rational number value to the stream.
WriteSRationalArray | Writes an array of signed rational values to the stream.
WriteSShort | Writes a single short value to the stream.
WriteSShortArray | Writes an array of short values to the stream.
WriteTo (inherited from StreamContainer) | Overloaded. Copies the contained data to another StreamContainer.
WriteUByte | Writes a single byte value to the stream.
WriteULong | Writes a single unsigned integer value to the stream.
WriteULongArray | Writes an array of unsigned integer values to the stream.
WriteUShort | Writes a single unsigned short value to the stream.
WriteUShortArray | Writes an array of unsigned short values to the stream.

Protected Instance Methods

AfterStreamDisposed (inherited from StreamContainer) | Called after the stream is disposed.
BeforeSave (inherited from StreamContainer) | Called before save occurs on the destination stream.
BeforeStreamDisposed (inherited from StreamContainer) | Called before the stream is disposed.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ProcessReadDataDouble | Performs a conversion to the double array.
ProcessReadDataFloat | Performs a conversion to the float array.
ProcessReadDataLong | Performs a conversion to the integer array.
ProcessReadDataShort | Performs a conversion to the short array.
ProcessReadDataULong | Performs a conversion to the unsigned integer array.
ProcessReadDataUShort | Performs a conversion to the unsigned short array.
ProcessWriteDataDouble | Performs a conversion from the specific data type to the raw bytes.
ProcessWriteDataFloat | Performs a conversion from the specific data type to the raw bytes.
ProcessWriteDataLong | Performs a conversion from the specific data type to the raw bytes.
ProcessWriteDataRational | Performs a conversion from the specific data type to the raw bytes.
ProcessWriteDataShort | Performs a conversion from the specific data type to the raw bytes.
ProcessWriteDataULong | Performs a conversion from the specific data type to the raw bytes.
ProcessWriteDataUShort | Performs a conversion from the specific data type to the raw bytes.
ReleaseManagedResources (inherited from StreamContainer) | Releases the managed resources. Make sure no unmanaged resources are released here, since they may have been already released.
ReleaseUnmanagedResources (inherited from DisposableObject) | Releases the unmanaged resources. Make sure no managed resources are released here, since they may have been already released.
VerifyNotDisposed (inherited from DisposableObject) | Verifies that the current instance is not disposed.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessReadDataDouble Method

Performs a conversion to the double array.

protected virtual double[] ProcessReadDataDouble(
byte[] data
);

Parameters

data
The data to convert.

Return Value

The converted array.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessReadDataFloat Method

Performs a conversion to the float array.

protected virtual float[] ProcessReadDataFloat(
byte[] data
);

Parameters

data
The data to convert.

Return Value

The converted array.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessReadDataLong Method

Performs a conversion to the integer array.

protected virtual int[] ProcessReadDataLong(
byte[] data
);

Parameters

data
The data to convert.

Return Value

The converted array.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessReadDataShort Method

Performs a conversion to the short array.

protected virtual short[] ProcessReadDataShort(
byte[] data
);

Parameters

data
The data to convert.

Return Value

The converted array.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessReadDataULong Method

Performs a conversion to the unsigned integer array.

protected virtual uint[] ProcessReadDataULong(
byte[] data
);

Parameters

data
The data to convert.

Return Value

The converted array.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessReadDataUShort Method

Performs a conversion to the unsigned short array.

protected virtual ushort[] ProcessReadDataUShort(
byte[] data
);

Parameters

data
The data to convert.

Return Value

The converted array.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessWriteDataDouble Method

Performs a conversion from the specific data type to the raw bytes.

protected virtual void ProcessWriteDataDouble(
double[] data,
byte[] dest
);

Parameters

data
The data to convert.
dest
The destination array containing the converted data..

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessWriteDataFloat Method

Performs a conversion from the specific data type to the raw bytes.

protected virtual void ProcessWriteDataFloat(
float[] data,
byte[] dest
);

Parameters

data
The data to convert.
dest
The destination array containing the converted data..

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessWriteDataLong Method

Performs a conversion from the specific data type to the raw bytes.

protected virtual void ProcessWriteDataLong(
int[] data,
byte[] dest
);

Parameters

data
The data to convert.
dest
The destination array containing the converted data..

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessWriteDataRational Method

Performs a conversion from the specific data type to the raw bytes.

protected virtual void ProcessWriteDataRational(
TiffRational[] data,
byte[] dest
);

Parameters

data
The data to convert.
dest
The destination array containing the converted data..

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessWriteDataShort Method

Performs a conversion from the specific data type to the raw bytes.

protected virtual void ProcessWriteDataShort(
short[] data,
byte[] dest
);

Parameters

data
The data to convert.
dest
The destination array containing the converted data..

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessWriteDataULong Method

Performs a conversion from the specific data type to the raw bytes.

protected virtual void ProcessWriteDataULong(
uint[] data,
byte[] dest
);

Parameters

data
The data to convert.
dest
The destination array containing the converted data..

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ProcessWriteDataUShort Method

Performs a conversion from the specific data type to the raw bytes.

protected virtual void ProcessWriteDataUShort(
ushort[] data,
byte[] dest
);

Parameters

data
The data to convert.
dest
The destination array containing the converted data..

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadDouble Method

Read a single double value from the stream.

public double ReadDouble();

Return Value

The single double value.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadDoubleArrayInt32 Method

Reads an array of double values from the stream.

public double[] ReadDoubleArrayInt32(
int count
);

Parameters

count
The elements count.

Return Value

The array of double values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadDoubleArrayUInt32 Method

Reads an array of double values from the stream.

public double[] ReadDoubleArrayUInt32(
uint count
);

Parameters

count
The elements count.

Return Value

The array of double values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadFloat Method

Read a single float value from the stream.

public float ReadFloat();

Return Value

The single float value.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadFloatArrayInt32 Method

Reads an array of float values from the stream.

public float[] ReadFloatArrayInt32(
int count
);

Parameters

count
The elements count.

Return Value

The array of float values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadFloatArrayUInt32 Method

Reads an array of float values from the stream.

public float[] ReadFloatArrayUInt32(
uint count
);

Parameters

count
The elements count.

Return Value

The array of float values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadRational Method

Read a single rational number value from the stream.

public TiffRational ReadRational();

Return Value

The rational number.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadRationalArrayInt32 Method

Reads an array of rational values from the stream.

public TiffRational[] ReadRationalArrayInt32(
int count
);

Parameters

count
The elements count.

Return Value

The array of rational values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadRationalArrayUInt32 Method

Reads an array of rational values from the stream.

public TiffRational[] ReadRationalArrayUInt32(
uint count
);

Parameters

count
The elements count.

Return Value

The array of rational values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadSByte Method

Reads signed byte data from the stream.

public sbyte ReadSByte();

Return Value

The signed byte value.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadSByteArrayInt32 Method

Reads an array of signed byte values from the stream.

public sbyte[] ReadSByteArrayInt32(
int count
);

Parameters

count
The elements count.

Return Value

The array of signed byte values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadSByteArrayUInt32 Method

Reads an array of signed byte values from the stream.

public sbyte[] ReadSByteArrayUInt32(
uint count
);

Parameters

count
The elements count.

Return Value

The array of signed byte values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadSLong Method

Read signed integer value from the stream.

public int ReadSLong();

Return Value

A signed integer value.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadSLongArrayInt32 Method

Reads an array of signed integer values from the stream.

public int[] ReadSLongArrayInt32(
int count
);

Parameters

count
The elements count.

Return Value

The array of signed integer values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadSLongArrayUInt32 Method

Reads an array of signed integer values from the stream.

public int[] ReadSLongArrayUInt32(
uint count
);

Parameters

count
The elements count.

Return Value

The array of signed integer values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadSRational Method

Read a single signed rational number value from the stream.

public TiffSRational ReadSRational();

Return Value

The signed rational number.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadSRationalArrayInt32 Method

Reads an array of signed rational values from the stream.

public TiffSRational[] ReadSRationalArrayInt32(
int count
);

Parameters

count
The elements count.

Return Value

The array of signed rational values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadSRationalArrayUInt32 Method

Reads an array of signed rational values from the stream.

public TiffSRational[] ReadSRationalArrayUInt32(
uint count
);

Parameters

count
The elements count.

Return Value

The array of signed rational values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadSShort Method

Read signed short value from the stream.

public short ReadSShort();

Return Value

A signed short value.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadSShortArrayInt32 Method

Reads an array of signed short values from the stream.

public short[] ReadSShortArrayInt32(
int count
);

Parameters

count
The elements count.

Return Value

The array of signed short values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadSShortArrayUInt32 Method

Reads an array of signed short values from the stream.

public short[] ReadSShortArrayUInt32(
uint count
);

Parameters

count
The elements count.

Return Value

The array of signed short values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadUByte Method

Read unsigned byte value from the stream.

public byte ReadUByte();

Return Value

An unsigned byte value.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadUByteArrayInt32 Method

Reads an array of unsigned byte values from the stream.

public byte[] ReadUByteArrayInt32(
int count
);

Parameters

count
The elements count.

Return Value

The array of unsigned byte values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadUByteArrayUInt32 Method

Reads an array of unsigned byte values from the stream.

public byte[] ReadUByteArrayUInt32(
uint count
);

Parameters

count
The elements count.

Return Value

The array of unsigned byte values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadULong Method

Read unsigned integer value from the stream.

public uint ReadULong();

Return Value

An unsigned integer value.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadULongArrayInt32 Method

Reads an array of unsigned integer values from the stream.

public uint[] ReadULongArrayInt32(
int count
);

Parameters

count
The elements count.

Return Value

The array of unsigned integer values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadULongArrayUInt32 Method

Reads an array of unsigned integer values from the stream.

public uint[] ReadULongArrayUInt32(
uint count
);

Parameters

count
The elements count.

Return Value

The array of unsigned integer values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadUShort Method

Read unsigned short value from the stream.

public ushort ReadUShort();

Return Value

An unsigned short value.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadUShortArrayInt32 Method

Reads an array of unsigned integer values from the stream.

public ushort[] ReadUShortArrayInt32(
int count
);

Parameters

count
The elements count.

Return Value

The array of unsigned integer values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.ReadUShortArrayUInt32 Method

Reads an array of unsigned integer values from the stream.

public ushort[] ReadUShortArrayUInt32(
uint count
);

Parameters

count
The elements count.

Return Value

The array of unsigned integer values.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteDouble Method

Writes a single double value to the stream.

public void WriteDouble(
double data
);

Parameters

data
The value to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteDoubleArray Method

Writes an array of double values to the stream.

public void WriteDoubleArray(
double[] data
);

Parameters

data
The array to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteFloat Method

Writes a single float value to the stream.

public void WriteFloat(
float data
);

Parameters

data
The value to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteFloatArray Method

Writes an array of float values to the stream.

public void WriteFloatArray(
float[] data
);

Parameters

data
The array to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteRational Method

Writes a single rational number value to the stream.

public void WriteRational(
TiffRational data
);

Parameters

data
The value to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteRationalArray Method

Writes an array of unsigned rational values to the stream.

public void WriteRationalArray(
TiffRational[] data
);

Parameters

data
The array to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteSByte Method

Writes a single signed byte value to the stream.

public void WriteSByte(
sbyte data
);

Parameters

data
The value to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteSByteArray Method

Writes an array of signed byte values to the stream.

public void WriteSByteArray(
sbyte[] data
);

Parameters

data
The array to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteSlong Method

Writes a single integer value to the stream.

public void WriteSlong(
int data
);

Parameters

data
The value to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteSLongArray Method

Writes an array of integer values to the stream.

public void WriteSLongArray(
int[] data
);

Parameters

data
The array to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteSRational Method

Writes a single signed rational number value to the stream.

public void WriteSRational(
TiffSRational data
);

Parameters

data
The value to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteSRationalArray Method

Writes an array of signed rational values to the stream.

public void WriteSRationalArray(
TiffSRational[] data
);

Parameters

data
The array to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteSShort Method

Writes a single short value to the stream.

public void WriteSShort(
short data
);

Parameters

data
The value to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteSShortArray Method

Writes an array of short values to the stream.

public void WriteSShortArray(
short[] data
);

Parameters

data
The array to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteUByte Method

Writes a single byte value to the stream.

public void WriteUByte(
byte data
);

Parameters

data
The value to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteULong Method

Writes a single unsigned integer value to the stream.

public void WriteULong(
uint data
);

Parameters

data
The value to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteULongArray Method

Writes an array of unsigned integer values to the stream.

public void WriteULongArray(
uint[] data
);

Parameters

data
The array to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteUShort Method

Writes a single unsigned short value to the stream.

public void WriteUShort(
ushort data
);

Parameters

data
The value to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


TiffStream.WriteUShortArray Method

Writes an array of unsigned short values to the stream.

public void WriteUShortArray(
ushort[] data
);

Parameters

data
The array to write.

See Also

TiffStream Class | Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


Aspose.Imaging.FileFormats.Tiff.InstanceFactory

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Tiff.InstanceFactory Namespace

Namespace hierarchy

Classes

Class | Description
TiffTagFactory | Tag factory class

Interfaces

Interface | Description
ITiffTagCreator | The tiff tag creator.


ITiffTagCreator Interface

The tiff tag creator.

For a list of all members of this type, see ITiffTagCreator Members.

public interface ITiffTagCreator

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.InstanceFactory

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ITiffTagCreator Members | Aspose.Imaging.FileFormats.Tiff.InstanceFactory Namespace


ITiffTagCreator Members

ITiffTagCreator overview

Public Instance Methods

CreateInstance Creates a new tag instance.

See Also

ITiffTagCreator Interface | Aspose.Imaging.FileFormats.Tiff.InstanceFactory Namespace


ITiffTagCreator Methods

The methods of the ITiffTagCreator interface are listed below. For a complete list of ITiffTagCreator interface members, see the ITiffTagCreator Members topic.

Public Instance Methods

CreateInstance Creates a new tag instance.

See Also

ITiffTagCreator Interface | Aspose.Imaging.FileFormats.Tiff.InstanceFactory Namespace


ITiffTagCreator.CreateInstance Method

Creates a new tag instance.

TiffDataType CreateInstance(
ushort tagId
);

Parameters

tagId
The tag id.

Return Value

The newly created instance.

See Also

ITiffTagCreator Interface | Aspose.Imaging.FileFormats.Tiff.InstanceFactory Namespace


TiffTagFactory Class

Tag factory class

For a list of all members of this type, see TiffTagFactory Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.InstanceFactory.TiffTagFactory

public abstract sealed class TiffTagFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.InstanceFactory

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffTagFactory Members | Aspose.Imaging.FileFormats.Tiff.InstanceFactory Namespace


TiffTagFactory Members

TiffTagFactory overview

Public Static Methods

CreateInstance Creates a new data type instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TiffTagFactory Class | Aspose.Imaging.FileFormats.Tiff.InstanceFactory Namespace


TiffTagFactory Methods

The methods of the TiffTagFactory class are listed below. For a complete list of TiffTagFactory class members, see the TiffTagFactory Members topic.

Public Static Methods

CreateInstance Creates a new data type instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TiffTagFactory Class | Aspose.Imaging.FileFormats.Tiff.InstanceFactory Namespace


TiffTagFactory.CreateInstance Method

Creates a new data type instance.

public static TiffDataType CreateInstance(
ushort dataType,
ushort tagId
);

Parameters

dataType
The data type instance.
tagId
The tag id.

Return Value

Tiff tag data type

See Also

TiffTagFactory Class | Aspose.Imaging.FileFormats.Tiff.InstanceFactory Namespace


Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace

Namespace hierarchy

Classes

Class | Description
TiffASCIIType | The tiff ascii type.
TiffByteType | The tiff byte type.
TiffCommonArrayType | The tiff common array type.
TiffDoubleType | The tiff double type.
TiffFloatType | The tiff float type.
TiffLongType | The tiff long type.
TiffRationalType | The tiff rational type.
TiffSByteType | The tiff signed byte type.
TiffShortType | The tiff short type.
TiffSLongType | The tiff signed long type.
TiffSRationalType | The tiff signed rational type.
TiffSShortType | The tiff signed short type.
TiffUndefinedType | The tiff undefined type.
TiffUnknownType | The unknown tiff type. In case the tiff tag cannot be recognized this type is instantinated.


TiffASCIIType Class

The tiff ascii type.

For a list of all members of this type, see TiffASCIIType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffASCIIType

public sealed class TiffASCIIType : TiffDataType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffASCIIType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffASCIIType Members

TiffASCIIType overview

Public Instance Constructors

TiffASCIIType Overloaded. Initializes a new instance of the TiffASCIIType class.

Public Instance Properties

Count | Gets the count of elements.
DataSize | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Text | Gets or sets the text.
Value | Gets or sets the value this data type contains.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffASCIIType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffASCIIType Constructor

Initializes a new instance of the TiffASCIIType class.

Overload List

Initializes a new instance of the TiffASCIIType class.

public TiffASCIIType(TiffTags);

Initializes a new instance of the TiffASCIIType class.

public TiffASCIIType(ushort);

See Also

TiffASCIIType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffASCIIType Constructor (TiffTags)

Initializes a new instance of the TiffASCIIType class.

public TiffASCIIType(
TiffTags tagId
);

Parameters

tagId
The tag id.

See Also

TiffASCIIType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffASCIIType Constructor Overload List


TiffASCIIType Constructor (UInt16)

Initializes a new instance of the TiffASCIIType class.

public TiffASCIIType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffASCIIType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffASCIIType Constructor Overload List


TiffASCIIType Properties

The properties of the TiffASCIIType class are listed below. For a complete list of TiffASCIIType class members, see the TiffASCIIType Members topic.

Public Instance Properties

Count | Gets the count of elements.
DataSize | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Text | Gets or sets the text.
Value | Gets or sets the value this data type contains.

See Also

TiffASCIIType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Count Property

Aspose.Imaging Documentation

TiffASCIIType.Count Property

Gets the count of elements.

public override uint Count {get;}

Property Value

The count of elements.

See Also

TiffASCIIType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


DataSize Property

Aspose.Imaging Documentation

TiffASCIIType.DataSize Property

Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).

public override uint DataSize {get;}

Property Value

The additional data size in bytes.

See Also

TiffASCIIType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffASCIIType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffASCIIType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Text Property

Aspose.Imaging Documentation

TiffASCIIType.Text Property

Gets or sets the text.

public string Text {get; set;}

Property Value

The text.

See Also

TiffASCIIType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffASCIIType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentException | Only string is supported.

See Also

TiffASCIIType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffASCIIType Methods

The methods of the TiffASCIIType class are listed below. For a complete list of TiffASCIIType class members, see the TiffASCIIType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffASCIIType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffASCIIType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

Exceptions

Exception Type | Condition
ArgumentNullException | dataStream
TiffImageException | There is no addtional data to write.

See Also

TiffASCIIType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffByteType Class

The tiff byte type.

For a list of all members of this type, see TiffByteType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffByteType

public sealed class TiffByteType : TiffCommonArrayType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffByteType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffByteType Members

TiffByteType overview

Public Instance Constructors

TiffByteType Overloaded. Initializes a new instance of the TiffByteType class.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffByteType Constructor

Initializes a new instance of the TiffByteType class.

Overload List

Initializes a new instance of the TiffByteType class.

public TiffByteType(TiffTags);

Initializes a new instance of the TiffByteType class.

public TiffByteType(ushort);

See Also

TiffByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffByteType Constructor (TiffTags)

Initializes a new instance of the TiffByteType class.

public TiffByteType(
TiffTags tagId
);

Parameters

tagId
The tag id.

See Also

TiffByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffByteType Constructor Overload List


TiffByteType Constructor (UInt16)

Initializes a new instance of the TiffByteType class.

public TiffByteType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffByteType Constructor Overload List


TiffByteType Properties

The properties of the TiffByteType class are listed below. For a complete list of TiffByteType class members, see the TiffByteType Members topic.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

See Also

TiffByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ElementSize Property

Aspose.Imaging Documentation

TiffByteType.ElementSize Property

Gets the element size in bytes.

public override uint ElementSize {get;}

Property Value

The element size in bytes.

See Also

TiffByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffByteType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffByteType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentException | Only byte array is supported.

See Also

TiffByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Values Property

Aspose.Imaging Documentation

TiffByteType.Values Property

Gets or sets the values.

public byte[] Values {get; set;}

Property Value

The data.

See Also

TiffByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ValuesContainer Property

Aspose.Imaging Documentation

TiffByteType.ValuesContainer Property

Gets the values container.

public override Array ValuesContainer {get;}

Property Value

The values container.

See Also

TiffByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffByteType Methods

The methods of the TiffByteType class are listed below. For a complete list of TiffByteType class members, see the TiffByteType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffByteType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

See Also

TiffByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffCommonArrayType Class

The tiff common array type.

For a list of all members of this type, see TiffCommonArrayType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Derived types

public abstract class TiffCommonArrayType : TiffDataType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffCommonArrayType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffCommonArrayType Members

TiffCommonArrayType overview

Public Instance Properties

Count | Gets the count of elements.
DataSize | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType (inherited from TiffDataType) | Gets the tag type.
Value (inherited from TiffDataType) | Gets or sets the value this data type contains.
ValuesContainer | Gets the values container.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData (inherited from TiffDataType) | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

Protected Instance Constructors

TiffCommonArrayType Constructor Initializes a new instance of the TiffCommonArrayType class.

Protected Instance Methods

CopyInstanceData (inherited from TiffDataType) | Copies the instance data into the cloned type.
CreateInstance (inherited from TiffDataType) | Creates a new instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReadData (inherited from TiffDataType) | Reads the additional data.
WriteTagValue | Writes the current tag value.
WriteTagValueOrOffset | Writes the tag value or additional offset.

See Also

TiffCommonArrayType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffCommonArrayType Constructor

Initializes a new instance of the TiffCommonArrayType class.

protected TiffCommonArrayType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffCommonArrayType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffCommonArrayType Properties

The properties of the TiffCommonArrayType class are listed below. For a complete list of TiffCommonArrayType class members, see the TiffCommonArrayType Members topic.

Public Instance Properties

Count | Gets the count of elements.
DataSize | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType (inherited from TiffDataType) | Gets the tag type.
Value (inherited from TiffDataType) | Gets or sets the value this data type contains.
ValuesContainer | Gets the values container.

See Also

TiffCommonArrayType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Count Property

Aspose.Imaging Documentation

TiffCommonArrayType.Count Property

Gets the count of elements.

public uint Count {get;}

Property Value

The count of elements.

See Also

TiffCommonArrayType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


DataSize Property

Aspose.Imaging Documentation

TiffCommonArrayType.DataSize Property

Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).

public uint DataSize {get;}

Property Value

The additional data size in bytes.

See Also

TiffCommonArrayType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ElementSize Property

Aspose.Imaging Documentation

TiffCommonArrayType.ElementSize Property

Gets the element size in bytes.

public abstract uint ElementSize {get;}

Property Value

The element size in bytes.

See Also

TiffCommonArrayType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ValuesContainer Property

Aspose.Imaging Documentation

TiffCommonArrayType.ValuesContainer Property

Gets the values container.

public abstract Array ValuesContainer {get;}

Property Value

The values container.

See Also

TiffCommonArrayType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffCommonArrayType Methods

The methods of the TiffCommonArrayType class are listed below. For a complete list of TiffCommonArrayType class members, see the TiffCommonArrayType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData (inherited from TiffDataType) | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

Protected Instance Methods

CopyInstanceData (inherited from TiffDataType) | Copies the instance data into the cloned type.
CreateInstance (inherited from TiffDataType) | Creates a new instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ReadData (inherited from TiffDataType) | Reads the additional data.
WriteTagValue | Writes the current tag value.
WriteTagValueOrOffset | Writes the tag value or additional offset.

See Also

TiffCommonArrayType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffCommonArrayType.WriteTagValue Method

Writes the current tag value.

protected abstract void WriteTagValue(
TiffStream dataStream
);

Parameters

dataStream
The data stream to write to.

See Also

TiffCommonArrayType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffCommonArrayType.WriteTagValueOrOffset Method

Writes the tag value or additional offset.

protected void WriteTagValueOrOffset(
TiffStream dataStream,
uint additionalDataOffset
);

Parameters

dataStream
The data stream.
additionalDataOffset
The additional data offset.

See Also

TiffCommonArrayType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffDoubleType Class

The tiff double type.

For a list of all members of this type, see TiffDoubleType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffDoubleType

public sealed class TiffDoubleType : TiffCommonArrayType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffDoubleType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffDoubleType Members

TiffDoubleType overview

Public Instance Constructors

TiffDoubleType Overloaded. Initializes a new instance of the TiffDoubleType class.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffDoubleType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffDoubleType Constructor

Initializes a new instance of the TiffDoubleType class.

Overload List

Initializes a new instance of the TiffDoubleType class.

public TiffDoubleType(TiffTags);

Initializes a new instance of the TiffDoubleType class.

public TiffDoubleType(ushort);

See Also

TiffDoubleType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffDoubleType Constructor (TiffTags)

Initializes a new instance of the TiffDoubleType class.

public TiffDoubleType(
TiffTags tagId
);

Parameters

tagId
The tag id.

See Also

TiffDoubleType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffDoubleType Constructor Overload List


TiffDoubleType Constructor (UInt16)

Initializes a new instance of the TiffDoubleType class.

public TiffDoubleType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffDoubleType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffDoubleType Constructor Overload List


TiffDoubleType Properties

The properties of the TiffDoubleType class are listed below. For a complete list of TiffDoubleType class members, see the TiffDoubleType Members topic.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

See Also

TiffDoubleType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ElementSize Property

Aspose.Imaging Documentation

TiffDoubleType.ElementSize Property

Gets the element size in bytes.

public override uint ElementSize {get;}

Property Value

The element size in bytes.

See Also

TiffDoubleType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffDoubleType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffDoubleType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffDoubleType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentException | Only double array is supported.

See Also

TiffDoubleType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Values Property

Aspose.Imaging Documentation

TiffDoubleType.Values Property

Gets or sets the values.

public double[] Values {get; set;}

Property Value

The values.

See Also

TiffDoubleType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ValuesContainer Property

Aspose.Imaging Documentation

TiffDoubleType.ValuesContainer Property

Gets the values container.

public override Array ValuesContainer {get;}

Property Value

The values container.

See Also

TiffDoubleType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffDoubleType Methods

The methods of the TiffDoubleType class are listed below. For a complete list of TiffDoubleType class members, see the TiffDoubleType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffDoubleType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffDoubleType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

See Also

TiffDoubleType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffFloatType Class

The tiff float type.

For a list of all members of this type, see TiffFloatType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffFloatType

public sealed class TiffFloatType : TiffCommonArrayType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffFloatType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffFloatType Members

TiffFloatType overview

Public Instance Constructors

TiffFloatType Overloaded. Initializes a new instance of the TiffFloatType class.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffFloatType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffFloatType Constructor

Initializes a new instance of the TiffFloatType class.

Overload List

Initializes a new instance of the TiffFloatType class.

public TiffFloatType(TiffTags);

Initializes a new instance of the TiffFloatType class.

public TiffFloatType(ushort);

See Also

TiffFloatType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffFloatType Constructor (TiffTags)

Initializes a new instance of the TiffFloatType class.

public TiffFloatType(
TiffTags tagId
);

Parameters

tagId
The tag id.

See Also

TiffFloatType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffFloatType Constructor Overload List


TiffFloatType Constructor (UInt16)

Initializes a new instance of the TiffFloatType class.

public TiffFloatType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffFloatType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffFloatType Constructor Overload List


TiffFloatType Properties

The properties of the TiffFloatType class are listed below. For a complete list of TiffFloatType class members, see the TiffFloatType Members topic.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

See Also

TiffFloatType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ElementSize Property

Aspose.Imaging Documentation

TiffFloatType.ElementSize Property

Gets the element size in bytes.

public override uint ElementSize {get;}

Property Value

The element size in bytes.

See Also

TiffFloatType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffFloatType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffFloatType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffFloatType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentException | Only float array is supported.

See Also

TiffFloatType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Values Property

Aspose.Imaging Documentation

TiffFloatType.Values Property

Gets or sets the values.

public float[] Values {get; set;}

Property Value

The values.

See Also

TiffFloatType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ValuesContainer Property

Aspose.Imaging Documentation

TiffFloatType.ValuesContainer Property

Gets the values container.

public override Array ValuesContainer {get;}

Property Value

The values container.

See Also

TiffFloatType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffFloatType Methods

The methods of the TiffFloatType class are listed below. For a complete list of TiffFloatType class members, see the TiffFloatType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffFloatType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffFloatType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

See Also

TiffFloatType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffLongType Class

The tiff long type.

For a list of all members of this type, see TiffLongType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffLongType

public sealed class TiffLongType : TiffCommonArrayType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffLongType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffLongType Members

TiffLongType overview

Public Instance Constructors

TiffLongType Overloaded. Initializes a new instance of the TiffLongType class.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffLongType Constructor

Initializes a new instance of the TiffLongType class.

Overload List

Initializes a new instance of the TiffLongType class.

public TiffLongType(TiffTags);

Initializes a new instance of the TiffLongType class.

public TiffLongType(ushort);

See Also

TiffLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffLongType Constructor (TiffTags)

Initializes a new instance of the TiffLongType class.

public TiffLongType(
TiffTags tagId
);

Parameters

tagId
The tag id.

See Also

TiffLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffLongType Constructor Overload List


TiffLongType Constructor (UInt16)

Initializes a new instance of the TiffLongType class.

public TiffLongType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffLongType Constructor Overload List


TiffLongType Properties

The properties of the TiffLongType class are listed below. For a complete list of TiffLongType class members, see the TiffLongType Members topic.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

See Also

TiffLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ElementSize Property

Aspose.Imaging Documentation

TiffLongType.ElementSize Property

Gets the element size in bytes.

public override uint ElementSize {get;}

Property Value

The element size in bytes.

See Also

TiffLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffLongType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffLongType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentException | Only uint array is supported.

See Also

TiffLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Values Property

Aspose.Imaging Documentation

TiffLongType.Values Property

Gets or sets the values.

public uint[] Values {get; set;}

Property Value

The values.

See Also

TiffLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ValuesContainer Property

Aspose.Imaging Documentation

TiffLongType.ValuesContainer Property

Gets the values container.

public override Array ValuesContainer {get;}

Property Value

The values container.

See Also

TiffLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffLongType Methods

The methods of the TiffLongType class are listed below. For a complete list of TiffLongType class members, see the TiffLongType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffLongType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

See Also

TiffLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffRationalType Class

The tiff rational type.

For a list of all members of this type, see TiffRationalType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffRationalType

public sealed class TiffRationalType : TiffCommonArrayType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffRationalType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffRationalType Members

TiffRationalType overview

Public Instance Constructors

TiffRationalType Overloaded. Initializes a new instance of the TiffRationalType class.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffRationalType Constructor

Initializes a new instance of the TiffRationalType class.

Overload List

Initializes a new instance of the TiffRationalType class.

public TiffRationalType(TiffTags);

Initializes a new instance of the TiffRationalType class.

public TiffRationalType(ushort);

See Also

TiffRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffRationalType Constructor (TiffTags)

Initializes a new instance of the TiffRationalType class.

public TiffRationalType(
TiffTags tagId
);

Parameters

tagId
The tag id.

See Also

TiffRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffRationalType Constructor Overload List


TiffRationalType Constructor (UInt16)

Initializes a new instance of the TiffRationalType class.

public TiffRationalType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffRationalType Constructor Overload List


TiffRationalType Properties

The properties of the TiffRationalType class are listed below. For a complete list of TiffRationalType class members, see the TiffRationalType Members topic.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

See Also

TiffRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ElementSize Property

Aspose.Imaging Documentation

TiffRationalType.ElementSize Property

Gets the element size in bytes.

public override uint ElementSize {get;}

Property Value

The element size in bytes.

See Also

TiffRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffRationalType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffRationalType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentException | Only TiffRational array is supported.

See Also

TiffRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Values Property

Aspose.Imaging Documentation

TiffRationalType.Values Property

Gets or sets the values.

public TiffRational[] Values {get; set;}

Property Value

The values.

See Also

TiffRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ValuesContainer Property

Aspose.Imaging Documentation

TiffRationalType.ValuesContainer Property

Gets the values container.

public override Array ValuesContainer {get;}

Property Value

The values container.

See Also

TiffRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffRationalType Methods

The methods of the TiffRationalType class are listed below. For a complete list of TiffRationalType class members, see the TiffRationalType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffRationalType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

See Also

TiffRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSByteType Class

The tiff signed byte type.

For a list of all members of this type, see TiffSByteType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffSByteType

public sealed class TiffSByteType : TiffCommonArrayType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffSByteType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSByteType Members

TiffSByteType overview

Public Instance Constructors

TiffSByteType Overloaded. Initializes a new instance of the TiffSByteType class.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffSByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSByteType Constructor

Initializes a new instance of the TiffSByteType class.

Overload List

Initializes a new instance of the TiffSByteType class.

public TiffSByteType(TiffTags);

Initializes a new instance of the TiffSByteType class.

public TiffSByteType(ushort);

See Also

TiffSByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSByteType Constructor (TiffTags)

Initializes a new instance of the TiffSByteType class.

public TiffSByteType(
TiffTags tagId
);

Parameters

tagId
The tag id.

See Also

TiffSByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffSByteType Constructor Overload List


TiffSByteType Constructor (UInt16)

Initializes a new instance of the TiffSByteType class.

public TiffSByteType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffSByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffSByteType Constructor Overload List


TiffSByteType Properties

The properties of the TiffSByteType class are listed below. For a complete list of TiffSByteType class members, see the TiffSByteType Members topic.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

See Also

TiffSByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ElementSize Property

Aspose.Imaging Documentation

TiffSByteType.ElementSize Property

Gets the element size in bytes.

public override uint ElementSize {get;}

Property Value

The element size in bytes.

See Also

TiffSByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffSByteType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffSByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffSByteType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentException | Only signed byte array is supported.

See Also

TiffSByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Values Property

Aspose.Imaging Documentation

TiffSByteType.Values Property

Gets or sets the values.

public sbyte[] Values {get; set;}

Property Value

The data.

See Also

TiffSByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ValuesContainer Property

Aspose.Imaging Documentation

TiffSByteType.ValuesContainer Property

Gets the values container.

public override Array ValuesContainer {get;}

Property Value

The values container.

See Also

TiffSByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSByteType Methods

The methods of the TiffSByteType class are listed below. For a complete list of TiffSByteType class members, see the TiffSByteType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffSByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSByteType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

See Also

TiffSByteType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffShortType Class

The tiff short type.

For a list of all members of this type, see TiffShortType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffShortType

public sealed class TiffShortType : TiffCommonArrayType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffShortType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffShortType Members

TiffShortType overview

Public Instance Constructors

TiffShortType Overloaded. Initializes a new instance of the TiffShortType class.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the data.
ValuesContainer | Gets the values container.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffShortType Constructor

Initializes a new instance of the TiffShortType class.

Overload List

Initializes a new instance of the TiffShortType class.

public TiffShortType(TiffTags);

Initializes a new instance of the TiffShortType class.

public TiffShortType(ushort);

See Also

TiffShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffShortType Constructor (TiffTags)

Initializes a new instance of the TiffShortType class.

public TiffShortType(
TiffTags tagId
);

Parameters

tagId
The tag id.

See Also

TiffShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffShortType Constructor Overload List


TiffShortType Constructor (UInt16)

Initializes a new instance of the TiffShortType class.

public TiffShortType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffShortType Constructor Overload List


TiffShortType Properties

The properties of the TiffShortType class are listed below. For a complete list of TiffShortType class members, see the TiffShortType Members topic.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the data.
ValuesContainer | Gets the values container.

See Also

TiffShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ElementSize Property

Aspose.Imaging Documentation

TiffShortType.ElementSize Property

Gets the element size in bytes.

public override uint ElementSize {get;}

Property Value

The element size in bytes.

See Also

TiffShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffShortType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffShortType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentException | Only ushort array is supported.

See Also

TiffShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Values Property

Aspose.Imaging Documentation

TiffShortType.Values Property

Gets or sets the data.

public ushort[] Values {get; set;}

Property Value

The data.

See Also

TiffShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ValuesContainer Property

Aspose.Imaging Documentation

TiffShortType.ValuesContainer Property

Gets the values container.

public override Array ValuesContainer {get;}

Property Value

The values container.

See Also

TiffShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffShortType Methods

The methods of the TiffShortType class are listed below. For a complete list of TiffShortType class members, see the TiffShortType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffShortType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

See Also

TiffShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSLongType Class

The tiff signed long type.

For a list of all members of this type, see TiffSLongType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffSLongType

public sealed class TiffSLongType : TiffCommonArrayType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffSLongType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSLongType Members

TiffSLongType overview

Public Instance Constructors

TiffSLongType Overloaded. Initializes a new instance of the TiffSLongType class.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffSLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSLongType Constructor

Initializes a new instance of the TiffSLongType class.

Overload List

Initializes a new instance of the TiffSLongType class.

public TiffSLongType(TiffTags);

Initializes a new instance of the TiffSLongType class.

public TiffSLongType(ushort);

See Also

TiffSLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSLongType Constructor (TiffTags)

Initializes a new instance of the TiffSLongType class.

public TiffSLongType(
TiffTags tagId
);

Parameters

tagId
The tag id.

See Also

TiffSLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffSLongType Constructor Overload List


TiffSLongType Constructor (UInt16)

Initializes a new instance of the TiffSLongType class.

public TiffSLongType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffSLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffSLongType Constructor Overload List


TiffSLongType Properties

The properties of the TiffSLongType class are listed below. For a complete list of TiffSLongType class members, see the TiffSLongType Members topic.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

See Also

TiffSLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ElementSize Property

Aspose.Imaging Documentation

TiffSLongType.ElementSize Property

Gets the element size in bytes.

public override uint ElementSize {get;}

Property Value

The element size in bytes.

See Also

TiffSLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffSLongType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffSLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffSLongType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentException | Only signed integer array is supported.

See Also

TiffSLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Values Property

Aspose.Imaging Documentation

TiffSLongType.Values Property

Gets or sets the values.

public int[] Values {get; set;}

Property Value

The values.

See Also

TiffSLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ValuesContainer Property

Aspose.Imaging Documentation

TiffSLongType.ValuesContainer Property

Gets the values container.

public override Array ValuesContainer {get;}

Property Value

The values container.

See Also

TiffSLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSLongType Methods

The methods of the TiffSLongType class are listed below. For a complete list of TiffSLongType class members, see the TiffSLongType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffSLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSLongType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

See Also

TiffSLongType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSRationalType Class

The tiff signed rational type.

For a list of all members of this type, see TiffSRationalType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffSRationalType

public sealed class TiffSRationalType : TiffCommonArrayType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffSRationalType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSRationalType Members

TiffSRationalType overview

Public Instance Constructors

TiffSRationalType Overloaded. Initializes a new instance of the TiffSRationalType class.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffSRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSRationalType Constructor

Initializes a new instance of the TiffSRationalType class.

Overload List

Initializes a new instance of the TiffSRationalType class.

public TiffSRationalType(TiffTags);

Initializes a new instance of the TiffSRationalType class.

public TiffSRationalType(ushort);

See Also

TiffSRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSRationalType Constructor (TiffTags)

Initializes a new instance of the TiffSRationalType class.

public TiffSRationalType(
TiffTags tagId
);

Parameters

tagId
The tag id.

See Also

TiffSRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffSRationalType Constructor Overload List


TiffSRationalType Constructor (UInt16)

Initializes a new instance of the TiffSRationalType class.

public TiffSRationalType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffSRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffSRationalType Constructor Overload List


TiffSRationalType Properties

The properties of the TiffSRationalType class are listed below. For a complete list of TiffSRationalType class members, see the TiffSRationalType Members topic.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

See Also

TiffSRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ElementSize Property

Aspose.Imaging Documentation

TiffSRationalType.ElementSize Property

Gets the element size in bytes.

public override uint ElementSize {get;}

Property Value

The element size in bytes.

See Also

TiffSRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffSRationalType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffSRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffSRationalType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentException | Only TiffSRational array is supported.

See Also

TiffSRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Values Property

Aspose.Imaging Documentation

TiffSRationalType.Values Property

Gets or sets the values.

public TiffSRational[] Values {get; set;}

Property Value

The values.

See Also

TiffSRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ValuesContainer Property

Aspose.Imaging Documentation

TiffSRationalType.ValuesContainer Property

Gets the values container.

public override Array ValuesContainer {get;}

Property Value

The values container.

See Also

TiffSRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSRationalType Methods

The methods of the TiffSRationalType class are listed below. For a complete list of TiffSRationalType class members, see the TiffSRationalType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffSRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSRationalType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

See Also

TiffSRationalType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSShortType Class

The tiff signed short type.

For a list of all members of this type, see TiffSShortType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffSShortType

public sealed class TiffSShortType : TiffCommonArrayType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffSShortType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSShortType Members

TiffSShortType overview

Public Instance Constructors

TiffSShortType Overloaded. Initializes a new instance of the TiffSShortType class.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffSShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSShortType Constructor

Initializes a new instance of the TiffSShortType class.

Overload List

Initializes a new instance of the TiffSShortType class.

public TiffSShortType(TiffTags);

Initializes a new instance of the TiffSShortType class.

public TiffSShortType(ushort);

See Also

TiffSShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSShortType Constructor (TiffTags)

Initializes a new instance of the TiffSShortType class.

public TiffSShortType(
TiffTags tagId
);

Parameters

tagId
The tag id.

See Also

TiffSShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffSShortType Constructor Overload List


TiffSShortType Constructor (UInt16)

Initializes a new instance of the TiffSShortType class.

public TiffSShortType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffSShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffSShortType Constructor Overload List


TiffSShortType Properties

The properties of the TiffSShortType class are listed below. For a complete list of TiffSShortType class members, see the TiffSShortType Members topic.

Public Instance Properties

Count (inherited from TiffCommonArrayType) | Gets the count of elements.
DataSize (inherited from TiffCommonArrayType) | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
ElementSize | Gets the element size in bytes.
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.
Values | Gets or sets the values.
ValuesContainer | Gets the values container.

See Also

TiffSShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ElementSize Property

Aspose.Imaging Documentation

TiffSShortType.ElementSize Property

Gets the element size in bytes.

public override uint ElementSize {get;}

Property Value

The element size in bytes.

See Also

TiffSShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffSShortType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffSShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffSShortType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentException | Only signed short array is supported.

See Also

TiffSShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Values Property

Aspose.Imaging Documentation

TiffSShortType.Values Property

Gets or sets the values.

public short[] Values {get; set;}

Property Value

The values.

See Also

TiffSShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


ValuesContainer Property

Aspose.Imaging Documentation

TiffSShortType.ValuesContainer Property

Gets the values container.

public override Array ValuesContainer {get;}

Property Value

The values container.

See Also

TiffSShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSShortType Methods

The methods of the TiffSShortType class are listed below. For a complete list of TiffSShortType class members, see the TiffSShortType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffSShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffSShortType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

See Also

TiffSShortType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUndefinedType Class

The tiff undefined type.

For a list of all members of this type, see TiffUndefinedType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffUndefinedType

public sealed class TiffUndefinedType : TiffDataType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffUndefinedType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUndefinedType Members

TiffUndefinedType overview

Public Instance Constructors

TiffUndefinedType Overloaded. Initializes a new instance of the TiffUndefinedType class.

Public Instance Properties

Count | Gets the count of elements.
Data | Gets or sets the data.
DataSize | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffUndefinedType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUndefinedType Constructor

Initializes a new instance of the TiffUndefinedType class.

Overload List

Initializes a new instance of the TiffUndefinedType class.

public TiffUndefinedType(TiffTags);

Initializes a new instance of the TiffUndefinedType class.

public TiffUndefinedType(ushort);

See Also

TiffUndefinedType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUndefinedType Constructor (TiffTags)

Initializes a new instance of the TiffUndefinedType class.

public TiffUndefinedType(
TiffTags tagId
);

Parameters

tagId
The tag id.

See Also

TiffUndefinedType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffUndefinedType Constructor Overload List


TiffUndefinedType Constructor (UInt16)

Initializes a new instance of the TiffUndefinedType class.

public TiffUndefinedType(
ushort tagId
);

Parameters

tagId
The tag id.

See Also

TiffUndefinedType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace | TiffUndefinedType Constructor Overload List


TiffUndefinedType Properties

The properties of the TiffUndefinedType class are listed below. For a complete list of TiffUndefinedType class members, see the TiffUndefinedType Members topic.

Public Instance Properties

Count | Gets the count of elements.
Data | Gets or sets the data.
DataSize | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.

See Also

TiffUndefinedType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Count Property

Aspose.Imaging Documentation

TiffUndefinedType.Count Property

Gets the count of elements.

public override uint Count {get;}

Property Value

The count of elements.

See Also

TiffUndefinedType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Data Property

Aspose.Imaging Documentation

TiffUndefinedType.Data Property

Gets or sets the data.

public byte[] Data {get; set;}

Property Value

The data.

See Also

TiffUndefinedType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


DataSize Property

Aspose.Imaging Documentation

TiffUndefinedType.DataSize Property

Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).

public override uint DataSize {get;}

Property Value

The additional data size in bytes.

See Also

TiffUndefinedType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffUndefinedType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffUndefinedType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffUndefinedType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentException | Only byte array is supported.

See Also

TiffUndefinedType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUndefinedType Methods

The methods of the TiffUndefinedType class are listed below. For a complete list of TiffUndefinedType class members, see the TiffUndefinedType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TiffDataType) | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffUndefinedType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUndefinedType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

See Also

TiffUndefinedType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUnknownType Class

The unknown tiff type. In case the tiff tag cannot be recognized this type is instantinated.

For a list of all members of this type, see TiffUnknownType Members.

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffUnknownType

public sealed class TiffUnknownType : TiffDataType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Note the TiffUnknownType is not serialized back to stream.

Requirements

Namespace: Aspose.Imaging.FileFormats.Tiff.TiffTagTypes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffUnknownType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUnknownType Members

TiffUnknownType overview

Public Instance Constructors

TiffUnknownType Constructor Initializes a new instance of the TiffUnknownType class.

Public Instance Properties

Count | Gets the count of elements.
DataSize | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
OffsetOrValue | Gets the offset value for an additional data or value itself in case count is 1.
Stream | Gets the stream to read additional data from.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffUnknownType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUnknownType Constructor

Initializes a new instance of the TiffUnknownType class.

public TiffUnknownType(
TiffStream stream,
ushort tagType,
ushort tagId,
uint count,
uint offsetOrValue
);

Parameters

stream
The stream to read from.
tagType
Type of the tag.
tagId
The tag id.
count
The count value.
offsetOrValue
The offset or value.

See Also

TiffUnknownType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUnknownType Properties

The properties of the TiffUnknownType class are listed below. For a complete list of TiffUnknownType class members, see the TiffUnknownType Members topic.

Public Instance Properties

Count | Gets the count of elements.
DataSize | Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).
Id (inherited from TiffDataType) | Gets tag id integer representation.
IsValid (inherited from TiffDataType) | Gets a value indicating whether tag data is valid. The valid tag contains data which may be preserved. The invalid tag cannot be stored.
OffsetOrValue | Gets the offset value for an additional data or value itself in case count is 1.
Stream | Gets the stream to read additional data from.
TagId (inherited from TiffDataType) | Gets the tag id.
TagType | Gets the tag type.
Value | Gets or sets the value this data type contains.

See Also

TiffUnknownType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Count Property

Aspose.Imaging Documentation

TiffUnknownType.Count Property

Gets the count of elements.

public override uint Count {get;}

Property Value

The count of elements.

See Also

TiffUnknownType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


DataSize Property

Aspose.Imaging Documentation

TiffUnknownType.DataSize Property

Gets the additional data size in bytes (in case the 12 bytes is not enough to fit the tag data).

public override uint DataSize {get;}

Property Value

The additional data size in bytes.

Exceptions

Exception Type | Condition
NotImplementedException |

See Also

TiffUnknownType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


OffsetOrValue Property

Aspose.Imaging Documentation

TiffUnknownType.OffsetOrValue Property

Gets the offset value for an additional data or value itself in case count is 1.

public uint OffsetOrValue {get;}

Property Value

The offset or value.

See Also

TiffUnknownType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Stream Property

Aspose.Imaging Documentation

TiffUnknownType.Stream Property

Gets the stream to read additional data from.

public TiffStream Stream {get;}

Property Value

The stream to read data from.

See Also

TiffUnknownType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TagType Property

Aspose.Imaging Documentation

TiffUnknownType.TagType Property

Gets the tag type.

public override TiffDataTypes TagType {get;}

Property Value

The tag type.

See Also

TiffUnknownType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Value Property

Aspose.Imaging Documentation

TiffUnknownType.Value Property

Gets or sets the value this data type contains.

public override object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
NotImplementedException |

See Also

TiffUnknownType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUnknownType Methods

The methods of the TiffUnknownType class are listed below. For a complete list of TiffUnknownType class members, see the TiffUnknownType Members topic.

Public Instance Methods

CompareTo (inherited from TiffDataType) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
DeepClone (inherited from TiffDataType) | Performs a deep clone of this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.
WriteAdditionalData | Writes the additional tag data.
WriteTag (inherited from TiffDataType) | Writes the tag data.

See Also

TiffUnknownType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUnknownType.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

TiffUnknownType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


TiffUnknownType.WriteAdditionalData Method

Writes the additional tag data.

public override void WriteAdditionalData(
TiffStream dataStream
);

Parameters

dataStream
The data stream.

Exceptions

Exception Type | Condition
NotImplementedException |

See Also

TiffUnknownType Class | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Aspose.Imaging.ImageLoadOptions

Aspose.Imaging Documentation

Aspose.Imaging.ImageLoadOptions Namespace

Namespace hierarchy

Classes

Class | Description
JpegLoadOptions | Load options class for jpeg images.


JpegLoadOptions Class

Load options class for jpeg images.

For a list of all members of this type, see JpegLoadOptions Members.

System.Object
Aspose.Imaging.LoadOptions
Aspose.Imaging.ImageLoadOptions.JpegLoadOptions

public class JpegLoadOptions : LoadOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.ImageLoadOptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

JpegLoadOptions Members | Aspose.Imaging.ImageLoadOptions Namespace


JpegLoadOptions Members

JpegLoadOptions overview

Public Instance Constructors

JpegLoadOptions Constructor Initializes a new instance of the JpegLoadOptions class.

Public Instance Properties

DataBackgroundColor (inherited from LoadOptions) | Gets or sets the Image background Color.
DataRecoveryMode (inherited from LoadOptions) | Gets or sets the data recovery mode.
IccProfile | Gets or sets RGB Icc profile. RGB color profile is used for conversion from internal jpeg CMYK color space to RGB.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

JpegLoadOptions Class | Aspose.Imaging.ImageLoadOptions Namespace


JpegLoadOptions Constructor

Initializes a new instance of the JpegLoadOptions class.

public JpegLoadOptions();

See Also

JpegLoadOptions Class | Aspose.Imaging.ImageLoadOptions Namespace


JpegLoadOptions Properties

The properties of the JpegLoadOptions class are listed below. For a complete list of JpegLoadOptions class members, see the JpegLoadOptions Members topic.

Public Instance Properties

DataBackgroundColor (inherited from LoadOptions) | Gets or sets the Image background Color.
DataRecoveryMode (inherited from LoadOptions) | Gets or sets the data recovery mode.
IccProfile | Gets or sets RGB Icc profile. RGB color profile is used for conversion from internal jpeg CMYK color space to RGB.

See Also

JpegLoadOptions Class | Aspose.Imaging.ImageLoadOptions Namespace


IccProfile Property

Aspose.Imaging Documentation

JpegLoadOptions.IccProfile Property

Gets or sets RGB Icc profile. RGB color profile is used for conversion from internal jpeg CMYK color space to RGB.

public StreamSource IccProfile {get; set;}

See Also

JpegLoadOptions Class | Aspose.Imaging.ImageLoadOptions Namespace


Aspose.Imaging.ImageOptions

Aspose.Imaging Documentation

Aspose.Imaging.ImageOptions Namespace

Namespace hierarchy

Classes

Class | Description
BmpOptions | The bmp file format creation options.
GifOptions | The gif file format creation options.
JpegOptions | The jpeg file format create options.
PdfOptions | The pdf options.
PngOptions | The png file format create options.
PsdOptions | The psd file format create options.
TiffOptions | The tiff file format options. Note that width and height tags will get overwritten on image creation by width and height parameters so there is no need to specify them directly. Note that many options return a default value but that does not mean that this option is set explicitly as a tag value. To verify the tag is present use Tags property or the corresponding IsTagPresent method.

Enumerations

Enumeration | Description
TiffOptionsError | The tiff options error codes.


BmpOptions Class

The bmp file format creation options.

For a list of all members of this type, see BmpOptions Members.

System.Object
Aspose.Imaging.ImageOptionsBase
Aspose.Imaging.ImageOptions.BmpOptions

public class BmpOptions : ImageOptionsBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example demonstrates the use of different classes from SaveOptions Namespace for export purposes. An image of type Gif is loaded into an instance of Image and then exported out to several formats.

[C#]

//Load an existing image (of type Gif) in an instance of Image class
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(@"C:\temp\sample.gif"))
{
    //Export to BMP file format using the default options
    image.Save(@"C:\output.bmp", new Aspose.Imaging.ImageOptions.BmpOptions());

    //Export to JPEG file format using the default options
    image.Save(@"C:\output.jpeg", new Aspose.Imaging.ImageOptions.JpegOptions());

    //Export to PNG file format using the default options
    image.Save(@"C:\output.png", new Aspose.Imaging.ImageOptions.PngOptions());

    //Export to TIFF file format using the default options
    image.Save(@"c:\output.tiff", new Aspose.Imaging.ImageOptions.TiffOptions());
}
[Visual Basic]

'Load an existing image (of type Gif) in an instance of Image class
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load("C:\temp\sample.gif")
'Export to BMP file format using the default options
    image.Save("C:\output.bmp", New Aspose.Imaging.ImageOptions.BmpOptions())

'Export to JPEG file format using the default options
    image.Save("C:\output.jpeg", New Aspose.Imaging.ImageOptions.JpegOptions())

'Export to PNG file format using the default options
    image.Save("C:\output.png", New Aspose.Imaging.ImageOptions.PngOptions())

'Export to TIFF file format using the default options
    image.Save("c:\output.tiff", New Aspose.Imaging.ImageOptions.TiffOptions())
End Using
This example creates a new Image file at some disk location as specified by Source property of the BmpOptions instance. Several properties for BmpOptions instance are set before creating the actual image. Especially the Source property, that refers to the actual disk location in this case.
[C#]

//Create an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"C:\temp\sample.bmp", false);

//Create an instance of Image and initialize it with instance of BmpOptions by calling Create method
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //do some image processing

    // save all changes
    image.Save();
}
[Visual Basic]

'Create an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("C:\temp\sample.bmp", False)

'Create an instance of Image and initialize it with instance of BmpOptions by calling Create method
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'do some image processing

' save all changes
    image.Save()
End Using

Requirements

Namespace: Aspose.Imaging.ImageOptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

BmpOptions Members | Aspose.Imaging.ImageOptions Namespace


BmpOptions Members

BmpOptions overview

Public Instance Constructors

BmpOptions Overloaded. Initializes a new instance of the BmpOptions class.

Public Instance Properties

BitsPerPixel | Gets or sets the image bits per pixel count.
Compression | Gets or sets the compression.
HorizontalResolution | Gets or sets the horizontal resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.
Palette (inherited from ImageOptionsBase) | Gets or sets the color palette.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.
VerticalResolution | Gets or sets the vertical resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BmpOptions Class | Aspose.Imaging.ImageOptions Namespace


BmpOptions Constructor

Initializes a new instance of the BmpOptions class.

Overload List

Initializes a new instance of the BmpOptions class.

public BmpOptions();

Initializes a new instance of the BmpOptions class.

public BmpOptions(BmpOptions);

See Also

BmpOptions Class | Aspose.Imaging.ImageOptions Namespace


BmpOptions Constructor ()

Initializes a new instance of the BmpOptions class.

public BmpOptions();

See Also

BmpOptions Class | Aspose.Imaging.ImageOptions Namespace | BmpOptions Constructor Overload List


BmpOptions Constructor (BmpOptions)

Initializes a new instance of the BmpOptions class.

public BmpOptions(
BmpOptions bmpOptions
);

Parameters

bmpOptions
The BMP options.

See Also

BmpOptions Class | Aspose.Imaging.ImageOptions Namespace | BmpOptions Constructor Overload List


BmpOptions Properties

The properties of the BmpOptions class are listed below. For a complete list of BmpOptions class members, see the BmpOptions Members topic.

Public Instance Properties

BitsPerPixel | Gets or sets the image bits per pixel count.
Compression | Gets or sets the compression.
HorizontalResolution | Gets or sets the horizontal resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.
Palette (inherited from ImageOptionsBase) | Gets or sets the color palette.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.
VerticalResolution | Gets or sets the vertical resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.

See Also

BmpOptions Class | Aspose.Imaging.ImageOptions Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

BmpOptions.BitsPerPixel Property

Gets or sets the image bits per pixel count.

public int BitsPerPixel {get; set;}

Property Value

The image bits per pixel count.

See Also

BmpOptions Class | Aspose.Imaging.ImageOptions Namespace


Compression Property

Aspose.Imaging Documentation

BmpOptions.Compression Property

Gets or sets the compression.

public BitmapCompression Compression {get; set;}

Property Value

The compression.

See Also

BmpOptions Class | Aspose.Imaging.ImageOptions Namespace


HorizontalResolution Property

Aspose.Imaging Documentation

BmpOptions.HorizontalResolution Property

Gets or sets the horizontal resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.

public double HorizontalResolution {get; set;}

Property Value

The horizontal resolution.

See Also

BmpOptions Class | Aspose.Imaging.ImageOptions Namespace


VerticalResolution Property

Aspose.Imaging Documentation

BmpOptions.VerticalResolution Property

Gets or sets the vertical resolution. Note due to the rounding the resulting resolution may slightly differ from the passed.

public double VerticalResolution {get; set;}

Property Value

The vertical resolution.

See Also

BmpOptions Class | Aspose.Imaging.ImageOptions Namespace


GifOptions Class

The gif file format creation options.

For a list of all members of this type, see GifOptions Members.

System.Object
Aspose.Imaging.ImageOptionsBase
Aspose.Imaging.ImageOptions.GifOptions

public class GifOptions : ImageOptionsBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example demonstrates the use of different classes from SaveOptions Namespace for export purposes. An image of type Gif is loaded into an instance of Image and then exported out to several formats.

[C#]

//Load an existing image (of type Gif) in an instance of Image class
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(@"C:\temp\sample.gif"))
{
    //Export to BMP file format using the default options
    image.Save(@"C:\output.bmp", new Aspose.Imaging.ImageOptions.BmpOptions());

    //Export to JPEG file format using the default options
    image.Save(@"C:\output.jpeg", new Aspose.Imaging.ImageOptions.JpegOptions());

    //Export to PNG file format using the default options
    image.Save(@"C:\output.png", new Aspose.Imaging.ImageOptions.PngOptions());

    //Export to TIFF file format using the default options
    image.Save(@"c:\output.tiff", new Aspose.Imaging.ImageOptions.TiffOptions());
}
[Visual Basic]

'Load an existing image (of type Gif) in an instance of Image class
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load("C:\temp\sample.gif")
'Export to BMP file format using the default options
    image.Save("C:\output.bmp", New Aspose.Imaging.ImageOptions.BmpOptions())

'Export to JPEG file format using the default options
    image.Save("C:\output.jpeg", New Aspose.Imaging.ImageOptions.JpegOptions())

'Export to PNG file format using the default options
    image.Save("C:\output.png", New Aspose.Imaging.ImageOptions.PngOptions())

'Export to TIFF file format using the default options
    image.Save("c:\output.tiff", New Aspose.Imaging.ImageOptions.TiffOptions())
End Using
This example shows how to Loads Pixel information in an Array of Type Color, manipulates the array and set it back to the image. To perform these operations, this example creates a new Image file (in GIF format) uisng MemoryStream object.
[C#]

//Create an instance of MemoryStream
using (System.IO.MemoryStream stream = new System.IO.MemoryStream())
{
    //Create an instance of GifOptions and set its various properties including the Source property
    Aspose.Imaging.ImageOptions.GifOptions gifOptions = new Aspose.Imaging.ImageOptions.GifOptions();
    gifOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.RasterImage image = (Aspose.Imaging.RasterImage)Aspose.Imaging.Image.Create(gifOptions, 500, 500))
    {
        //Get the pixels of image by specifying the area as image boundary
        Aspose.Imaging.Color[] pixels = image.LoadPixels(image.Bounds);

        //Loop over the Array and sets color of alrenative indexed pixel
        for (int index = 0; index < pixels.Length; index++)
        {
            if (index % 2 == 0)
            {
                //Set the indexed pixel color to yellow
                pixels[index] = Aspose.Imaging.Color.Yellow;
            }
            else
            {
                //Set the indexed pixel color to blue
                pixels[index] = Aspose.Imaging.Color.Blue;
            }
        }

        //Apply the pixel changes to the image
        image.SavePixels(image.Bounds, pixels);

        // save all changes.
        image.Save();
    }

    //Write MemoryStream to File
    stream.WriteTo(new System.IO.FileStream(@"C:\temp\output.gif", System.IO.FileMode.CreateNew));
}
[Visual Basic]

'Create an instance of MemoryStream
Using stream As System.IO.MemoryStream = New System.IO.MemoryStream()
'Create an instance of GifOptions and set its various properties including the Source property
Dim gifOptions As Aspose.Imaging.ImageOptions.GifOptions = New Aspose.Imaging.ImageOptions.GifOptions()
    gifOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.RasterImage = CType(Aspose.Imaging.Image.Create(gifOptions, 500, 500), Aspose.Imaging.RasterImage)
'Get the pixels of image by specifying the area as image boundary
Dim pixels As Aspose.Imaging.Color() = image.LoadPixels(image.Bounds)

'Loop over the Array and sets color of alrenative indexed pixel
Dim index As Integer = 0
        Do While index < pixels.Length
            If index Mod 2 = 0 Then
'Set the indexed pixel color to yellow
                pixels(index) = Aspose.Imaging.Color.Yellow
            Else
'Set the indexed pixel color to blue
                pixels(index) = Aspose.Imaging.Color.Blue
            End If
            index += 1
        Loop

'Apply the pixel changes to the image
        image.SavePixels(image.Bounds, pixels)

' save all changes.
        image.Save()
    End Using

'Write MemoryStream to File
    stream.WriteTo(New System.IO.FileStream("C:\temp\output.gif", System.IO.FileMode.CreateNew))
End Using

Requirements

Namespace: Aspose.Imaging.ImageOptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

GifOptions Members | Aspose.Imaging.ImageOptions Namespace


GifOptions Members

GifOptions overview

Public Instance Constructors

GifOptions Overloaded. Initializes a new instance of the GifOptions class.

Public Instance Properties

BackgroundColorIndex | Gets or sets the GIF background color index.
ColorResolution | Gets or sets the GIF color resolution.
HasTrailer | Gets or sets a value indicating whether GIF has trailer.
Interlaced | True if image should be interlaced.
IsPaletteSorted | Gets or sets a value indicating whether palette entries are sorted.
Palette (inherited from ImageOptionsBase) | Gets or sets the color palette.
PixelAspectRatio | Gets or sets the GIF pixel aspect ratio.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GifOptions Class | Aspose.Imaging.ImageOptions Namespace


GifOptions Constructor

Initializes a new instance of the GifOptions class.

Overload List

Initializes a new instance of the GifOptions class.

public GifOptions();

Initializes a new instance of the GifOptions class.

public GifOptions(GifOptions);

See Also

GifOptions Class | Aspose.Imaging.ImageOptions Namespace


GifOptions Constructor ()

Initializes a new instance of the GifOptions class.

public GifOptions();

See Also

GifOptions Class | Aspose.Imaging.ImageOptions Namespace | GifOptions Constructor Overload List


GifOptions Constructor (GifOptions)

Initializes a new instance of the GifOptions class.

public GifOptions(
GifOptions gifOptions
);

Parameters

gifOptions
The GIF Options.

See Also

GifOptions Class | Aspose.Imaging.ImageOptions Namespace | GifOptions Constructor Overload List


GifOptions Properties

The properties of the GifOptions class are listed below. For a complete list of GifOptions class members, see the GifOptions Members topic.

Public Instance Properties

BackgroundColorIndex | Gets or sets the GIF background color index.
ColorResolution | Gets or sets the GIF color resolution.
HasTrailer | Gets or sets a value indicating whether GIF has trailer.
Interlaced | True if image should be interlaced.
IsPaletteSorted | Gets or sets a value indicating whether palette entries are sorted.
Palette (inherited from ImageOptionsBase) | Gets or sets the color palette.
PixelAspectRatio | Gets or sets the GIF pixel aspect ratio.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.

See Also

GifOptions Class | Aspose.Imaging.ImageOptions Namespace


BackgroundColorIndex Property

Aspose.Imaging Documentation

GifOptions.BackgroundColorIndex Property

Gets or sets the GIF background color index.

public byte BackgroundColorIndex {get; set;}

Property Value

The GIF background color index.

See Also

GifOptions Class | Aspose.Imaging.ImageOptions Namespace


ColorResolution Property

Aspose.Imaging Documentation

GifOptions.ColorResolution Property

Gets or sets the GIF color resolution.

public byte ColorResolution {get; set;}

Property Value

The color resolution.

Remarks

Color Resolution - Number of bits per primary color available to the original image, minus 1. This value represents the size of the entire palette from which the colors in the graphic were selected, not the number of colors actually used in the graphic. For example, if the value in this field is 3, then the palette of the original image had 4 bits per primary color available to create the image. This value should be set to indicate the richness of the original palette, even if not every color from the whole palette is available on the source machine.

See Also

GifOptions Class | Aspose.Imaging.ImageOptions Namespace


HasTrailer Property

Aspose.Imaging Documentation

GifOptions.HasTrailer Property

Gets or sets a value indicating whether GIF has trailer.

public bool HasTrailer {get; set;}

Property Value

true if GIF has trailer; otherwise, false.

See Also

GifOptions Class | Aspose.Imaging.ImageOptions Namespace


Interlaced Property

Aspose.Imaging Documentation

GifOptions.Interlaced Property

True if image should be interlaced.

public bool Interlaced {get; set;}

See Also

GifOptions Class | Aspose.Imaging.ImageOptions Namespace


IsPaletteSorted Property

Aspose.Imaging Documentation

GifOptions.IsPaletteSorted Property

Gets or sets a value indicating whether palette entries are sorted.

public bool IsPaletteSorted {get; set;}

Property Value

true if palette entries are sorted; otherwise, false.

See Also

GifOptions Class | Aspose.Imaging.ImageOptions Namespace


PixelAspectRatio Property

Aspose.Imaging Documentation

GifOptions.PixelAspectRatio Property

Gets or sets the GIF pixel aspect ratio.

public byte PixelAspectRatio {get; set;}

Property Value

The GIF pixel aspect ratio.

Remarks

Pixel Aspect Ratio - Factor used to compute an approximation of the aspect ratio of the pixel in the original image. If the value of the field is not 0, this approximation of the aspect ratio is computed based on the formula: Aspect Ratio = (Pixel Aspect Ratio + 15) / 64 The Pixel Aspect Ratio is defined to be the quotient of the pixel's width over its height. The value range in this field allows specification of the widest pixel of 4:1 to the tallest pixel of 1:4 in increments of 1/64th. Values : 0 - No aspect ratio information is given. 1..255 - Value used in the computation.

See Also

GifOptions Class | Aspose.Imaging.ImageOptions Namespace


JpegOptions Class

The jpeg file format create options.

For a list of all members of this type, see JpegOptions Members.

System.Object
Aspose.Imaging.ImageOptionsBase
Aspose.Imaging.ImageOptions.JpegOptions

public class JpegOptions : ImageOptionsBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example demonstrates the use of different classes from SaveOptions Namespace for export purposes. An image of type Gif is loaded into an instance of Image and then exported out to several formats.

[C#]

//Load an existing image (of type Gif) in an instance of Image class
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(@"C:\temp\sample.gif"))
{
    //Export to BMP file format using the default options
    image.Save(@"C:\output.bmp", new Aspose.Imaging.ImageOptions.BmpOptions());

    //Export to JPEG file format using the default options
    image.Save(@"C:\output.jpeg", new Aspose.Imaging.ImageOptions.JpegOptions());

    //Export to PNG file format using the default options
    image.Save(@"C:\output.png", new Aspose.Imaging.ImageOptions.PngOptions());

    //Export to TIFF file format using the default options
    image.Save(@"c:\output.tiff", new Aspose.Imaging.ImageOptions.TiffOptions());
}
[Visual Basic]

'Load an existing image (of type Gif) in an instance of Image class
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load("C:\temp\sample.gif")
'Export to BMP file format using the default options
    image.Save("C:\output.bmp", New Aspose.Imaging.ImageOptions.BmpOptions())

'Export to JPEG file format using the default options
    image.Save("C:\output.jpeg", New Aspose.Imaging.ImageOptions.JpegOptions())

'Export to PNG file format using the default options
    image.Save("C:\output.png", New Aspose.Imaging.ImageOptions.PngOptions())

'Export to TIFF file format using the default options
    image.Save("c:\output.tiff", New Aspose.Imaging.ImageOptions.TiffOptions())
End Using
This example demonstrates the use of System.IO.Stream to Create a new Image file (a JPEG type)
[C#]

//Creates an instance of JpegOptions and set its various properties
Aspose.Imaging.ImageOptions.JpegOptions jpegOptions = new Aspose.Imaging.ImageOptions.JpegOptions();

//Create an instance of System.IO.Stream
System.IO.Stream stream = new System.IO.FileStream(@"C:\temp\sample.jpeg", System.IO.FileMode.Create);

//Define the source property for the instance of JpegOptions
//Second boolean parameter determins if the Stream is disposed once get out of scope
jpegOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream, true);

//Creates an instance of Image and call Create method with JpegOptions as parameter to initialize the Image object
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(jpegOptions, 500, 500))
{
    //do some image processing
}
[Visual Basic]

'Creates an instance of JpegOptions and set its various properties
Dim jpegOptions As Aspose.Imaging.ImageOptions.JpegOptions = New Aspose.Imaging.ImageOptions.JpegOptions()

'Create an instance of System.IO.Stream
Dim stream As System.IO.Stream = New System.IO.FileStream("C:\temp\sample.jpeg", System.IO.FileMode.Create)

'Define the source property for the instance of JpegOptions
'Second boolean parameter determins if the Stream is disposed once get out of scope
jpegOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream, True)

'Creates an instance of Image and call Create method with JpegOptions as parameter to initialize the Image object
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(jpegOptions, 500, 500)
'do some image processing
End Using

Requirements

Namespace: Aspose.Imaging.ImageOptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

JpegOptions Members | Aspose.Imaging.ImageOptions Namespace


JpegOptions Members

JpegOptions overview

Public Instance Constructors

JpegOptions Overloaded. Initializes a new instance of the JpegOptions class.

Public Instance Properties

CMYKColorProfile | The CMYK color profile for CMYK jpeg images. Must be in pair with RGBColorProfile for correct color conversion.
ColorType | Gets or sets the color type for jpeg image.
CompressionType | Gets or sets the compression type.
Palette (inherited from ImageOptionsBase) | Gets or sets the color palette.
Quality | Gets or sets image quality.
RGBColorProfile | The RGB color profile for CMYK jpeg images. Must be in pair with CMYKColorProfile for correct color conversion.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

JpegOptions Class | Aspose.Imaging.ImageOptions Namespace


JpegOptions Constructor

Initializes a new instance of the JpegOptions class.

Overload List

Initializes a new instance of the JpegOptions class.

public JpegOptions();

Initializes a new instance of the JpegOptions class.

public JpegOptions(JpegOptions);

See Also

JpegOptions Class | Aspose.Imaging.ImageOptions Namespace


JpegOptions Constructor ()

Initializes a new instance of the JpegOptions class.

public JpegOptions();

See Also

JpegOptions Class | Aspose.Imaging.ImageOptions Namespace | JpegOptions Constructor Overload List


JpegOptions Constructor (JpegOptions)

Initializes a new instance of the JpegOptions class.

public JpegOptions(
JpegOptions jpegOptions
);

Parameters

jpegOptions
The JPEG options.

See Also

JpegOptions Class | Aspose.Imaging.ImageOptions Namespace | JpegOptions Constructor Overload List


JpegOptions Properties

The properties of the JpegOptions class are listed below. For a complete list of JpegOptions class members, see the JpegOptions Members topic.

Public Instance Properties

CMYKColorProfile | The CMYK color profile for CMYK jpeg images. Must be in pair with RGBColorProfile for correct color conversion.
ColorType | Gets or sets the color type for jpeg image.
CompressionType | Gets or sets the compression type.
Palette (inherited from ImageOptionsBase) | Gets or sets the color palette.
Quality | Gets or sets image quality.
RGBColorProfile | The RGB color profile for CMYK jpeg images. Must be in pair with CMYKColorProfile for correct color conversion.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.

See Also

JpegOptions Class | Aspose.Imaging.ImageOptions Namespace


CMYKColorProfile Property

Aspose.Imaging Documentation

JpegOptions.CMYKColorProfile Property

The CMYK color profile for CMYK jpeg images. Must be in pair with RGBColorProfile for correct color conversion.

public StreamSource CMYKColorProfile {get; set;}

See Also

JpegOptions Class | Aspose.Imaging.ImageOptions Namespace


ColorType Property

Aspose.Imaging Documentation

JpegOptions.ColorType Property

Gets or sets the color type for jpeg image.

public JpegCompressionColorMode ColorType {get; set;}

See Also

JpegOptions Class | Aspose.Imaging.ImageOptions Namespace


CompressionType Property

Aspose.Imaging Documentation

JpegOptions.CompressionType Property

Gets or sets the compression type.

public JpegCompressionMode CompressionType {get; set;}

See Also

JpegOptions Class | Aspose.Imaging.ImageOptions Namespace


Quality Property

Aspose.Imaging Documentation

JpegOptions.Quality Property

Gets or sets image quality.

public int Quality {get; set;}

See Also

JpegOptions Class | Aspose.Imaging.ImageOptions Namespace


RGBColorProfile Property

Aspose.Imaging Documentation

JpegOptions.RGBColorProfile Property

The RGB color profile for CMYK jpeg images. Must be in pair with CMYKColorProfile for correct color conversion.

public StreamSource RGBColorProfile {get; set;}

See Also

JpegOptions Class | Aspose.Imaging.ImageOptions Namespace


PdfOptions Class

The pdf options.

For a list of all members of this type, see PdfOptions Members.

System.Object
Aspose.Imaging.ImageOptionsBase
Aspose.Imaging.ImageOptions.PdfOptions

public class PdfOptions : ImageOptionsBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example demonstrates the use of PdfOptions class to convert image from DXF to PDF format with default parameters.

[C#]

// name of the file
string filename = "Drawing1.dxf";

// load an image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(filename))
{
    // create options
    PdfOptions pdfOptions = new PdfOptions();

    // set output file size
    pdfOptions.PageWidth = 800;
    pdfOptions.PageHeight = 600;

    // export
    image.Save(filename + ".pdf", pdfOptions);
}
[Visual Basic]

'name of the file
Dim filename As String
filename = "Drawing1.dxf"

'load an image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load(filename)

'create options
Dim pdfOptions As New Aspose.Imaging.ImageOptions.PdfOptions()

'set output file size
    pdfOptions.PageWidth = 800
    pdfOptions.PageHeight = 600

'export
    image.Save(filename + ".pdf", pdfOptions)
End Using
This example demonstrates the use of PdfOptions class to convert image from DXF to PDF format with automatical increasing of a size of drawing to fit PDF size.
[C#]

// name of the file
string filename = "Drawing2.dxf";

// load an image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(filename))
{
    // create options
    PdfOptions pdfOptions = new PdfOptions();

    // set output file size
    pdfOptions.PageWidth = 850;
    pdfOptions.PageHeight = 600;

    // allow upscaling
    pdfOptions.ScaleMethod = ScaleType.GrowToFit;

    // export
    image.Save(filename + "_UpScale.pdf", pdfOptions);
}
[Visual Basic]

'name of the file
Dim filename As String
filename = "Drawing2.dxf"

'load an image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load(filename)

'create options
Dim pdfOptions As New Aspose.Imaging.ImageOptions.PdfOptions()

'set output file size
    pdfOptions.PageWidth = 850
    pdfOptions.PageHeight = 600

'allow upscaling
    pdfOptions.ScaleMethod = ScaleType.GrowToFit

'export
    image.Save(filename + "_UpScale.pdf", pdfOptions)

End Using
This example demonstrates the use of PdfOptions class to convert image from DXF to PDF format with color parameters: every entity will be drawn with its own color and background of output PDF file will be black.
[C#]

// name of the file
string filename = "Drawing1.dxf";

// load an image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(filename))
{
    // create options
    PdfOptions pdfOptions = new PdfOptions();

    // set output file size
    pdfOptions.PageWidth = 800;
    pdfOptions.PageHeight = 600;

    // set color properties
    pdfOptions.DrawType = CadDrawTypeMode.UseObjectColor;
    pdfOptions.BackgroundColor = Aspose.Imaging.Color.Black;

    // export
    image.Save(filename + "_BlackBackground.pdf", pdfOptions);
}
[Visual Basic]

'name of the file
Dim filename As String
filename = "Drawing1.dxf"

'load an image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load(filename)

'create options
Dim pdfOptions As New Aspose.Imaging.ImageOptions.PdfOptions()

'set output file size
    pdfOptions.PageWidth = 800
    pdfOptions.PageHeight = 600

'set color properties
    pdfOptions.DrawType = CadDrawTypeMode.UseObjectColor
    pdfOptions.BackgroundColor = Aspose.Imaging.Color.Black

'export
    image.Save(filename + "_BlackBackground.pdf", pdfOptions)

End Using

Requirements

Namespace: Aspose.Imaging.ImageOptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PdfOptions Members | Aspose.Imaging.ImageOptions Namespace


PdfOptions Members

PdfOptions overview

Public Instance Constructors

PdfOptions Constructor Initializes a new instance of the PdfOptions class.

Public Instance Properties

BackgroundColor | Gets or sets a background color.
BorderX | Gets or sets the border X.
BorderY | Gets or sets the border Y.
CenterDrawing | Gets or sets a value indicating whether center drawing.
CorePdfOptions | Gets or sets the core PDF options.
DrawColor | Gets or sets a foreground color.
DrawType | Gets or sets type of drawing.
Layers | Gets or sets layers of Dxf file to export.
LayoutName | Gets or sets the layoutName.
PageHeight | Gets or sets the page height.
PageSize | Gets or sets the page size.
PageWidth | Gets or sets the page width.
Palette (inherited from ImageOptionsBase) | Gets or sets the color palette.
PdfDocumentInfo | Gets or sets metadata for document.
ScaleMethod | Gets or sets scale method for automatic adjust of image size.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


PdfOptions Constructor

Initializes a new instance of the PdfOptions class.

public PdfOptions();

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


PdfOptions Properties

The properties of the PdfOptions class are listed below. For a complete list of PdfOptions class members, see the PdfOptions Members topic.

Public Instance Properties

BackgroundColor | Gets or sets a background color.
BorderX | Gets or sets the border X.
BorderY | Gets or sets the border Y.
CenterDrawing | Gets or sets a value indicating whether center drawing.
CorePdfOptions | Gets or sets the core PDF options.
DrawColor | Gets or sets a foreground color.
DrawType | Gets or sets type of drawing.
Layers | Gets or sets layers of Dxf file to export.
LayoutName | Gets or sets the layoutName.
PageHeight | Gets or sets the page height.
PageSize | Gets or sets the page size.
PageWidth | Gets or sets the page width.
Palette (inherited from ImageOptionsBase) | Gets or sets the color palette.
PdfDocumentInfo | Gets or sets metadata for document.
ScaleMethod | Gets or sets scale method for automatic adjust of image size.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


BackgroundColor Property

Aspose.Imaging Documentation

PdfOptions.BackgroundColor Property

Gets or sets a background color.

public Color BackgroundColor {get; set;}

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


BorderX Property

Aspose.Imaging Documentation

PdfOptions.BorderX Property

Gets or sets the border X.

public float BorderX {get; set;}

Property Value

The border X.

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


BorderY Property

Aspose.Imaging Documentation

PdfOptions.BorderY Property

Gets or sets the border Y.

public float BorderY {get; set;}

Property Value

The border Y.

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


CenterDrawing Property

Aspose.Imaging Documentation

PdfOptions.CenterDrawing Property

Gets or sets a value indicating whether center drawing.

public bool CenterDrawing {get; set;}

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


CorePdfOptions Property

Aspose.Imaging Documentation

PdfOptions.CorePdfOptions Property

Gets or sets the core PDF options.

public PdfOptionsCore CorePdfOptions {get; set;}

Property Value

The core PDF options.

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


DrawColor Property

Aspose.Imaging Documentation

PdfOptions.DrawColor Property

Gets or sets a foreground color.

public Color DrawColor {get; set;}

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


DrawType Property

Aspose.Imaging Documentation

PdfOptions.DrawType Property

Gets or sets type of drawing.

public CadDrawTypeMode DrawType {get; set;}

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


Layers Property

Aspose.Imaging Documentation

PdfOptions.Layers Property

Gets or sets layers of Dxf file to export.

public String} Layers {get; set;}

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


LayoutName Property

Aspose.Imaging Documentation

PdfOptions.LayoutName Property

Gets or sets the layoutName.

public string LayoutName {get; set;}

Property Value

The specific layout name or null for use Model. Model is also a layout.

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


PageHeight Property

Aspose.Imaging Documentation

PdfOptions.PageHeight Property

Gets or sets the page height.

public float PageHeight {get; set;}

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


PageSize Property

Aspose.Imaging Documentation

PdfOptions.PageSize Property

Gets or sets the page size.

public SizeF PageSize {get; set;}

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


PageWidth Property

Aspose.Imaging Documentation

PdfOptions.PageWidth Property

Gets or sets the page width.

public float PageWidth {get; set;}

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


PdfDocumentInfo Property

Aspose.Imaging Documentation

PdfOptions.PdfDocumentInfo Property

Gets or sets metadata for document.

public PdfDocumentInfo PdfDocumentInfo {get; set;}

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


ScaleMethod Property

Aspose.Imaging Documentation

PdfOptions.ScaleMethod Property

Gets or sets scale method for automatic adjust of image size.

public ScaleType ScaleMethod {get; set;}

See Also

PdfOptions Class | Aspose.Imaging.ImageOptions Namespace


PngOptions Class

The png file format create options.

For a list of all members of this type, see PngOptions Members.

System.Object
Aspose.Imaging.ImageOptionsBase
Aspose.Imaging.ImageOptions.PngOptions

public class PngOptions : ImageOptionsBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example demonstrates the use of different classes from SaveOptions Namespace for export purposes. An image of type Gif is loaded into an instance of Image and then exported out to several formats.

[C#]

//Load an existing image (of type Gif) in an instance of Image class
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(@"C:\temp\sample.gif"))
{
    //Export to BMP file format using the default options
    image.Save(@"C:\output.bmp", new Aspose.Imaging.ImageOptions.BmpOptions());

    //Export to JPEG file format using the default options
    image.Save(@"C:\output.jpeg", new Aspose.Imaging.ImageOptions.JpegOptions());

    //Export to PNG file format using the default options
    image.Save(@"C:\output.png", new Aspose.Imaging.ImageOptions.PngOptions());

    //Export to TIFF file format using the default options
    image.Save(@"c:\output.tiff", new Aspose.Imaging.ImageOptions.TiffOptions());
}
[Visual Basic]

'Load an existing image (of type Gif) in an instance of Image class
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load("C:\temp\sample.gif")
'Export to BMP file format using the default options
    image.Save("C:\output.bmp", New Aspose.Imaging.ImageOptions.BmpOptions())

'Export to JPEG file format using the default options
    image.Save("C:\output.jpeg", New Aspose.Imaging.ImageOptions.JpegOptions())

'Export to PNG file format using the default options
    image.Save("C:\output.png", New Aspose.Imaging.ImageOptions.PngOptions())

'Export to TIFF file format using the default options
    image.Save("c:\output.tiff", New Aspose.Imaging.ImageOptions.TiffOptions())
End Using
This example uses Graphics class to create primitive shapes on the Image surface. To demonstrate the operation, the example creates a new Image in PNG format and draw primitive shapes on Image surface using Draw methods exposed by Graphics class
[C#]

//Creates an instance of FileStream
using (System.IO.FileStream stream = new System.IO.FileStream(@"C:\temp\output.png", System.IO.FileMode.Create))
{
    //Create an instance of PngOptions and set its various properties
    Aspose.Imaging.ImageOptions.PngOptions pngOptions = new Aspose.Imaging.ImageOptions.PngOptions();

    //Set the Source for PngOptions
    pngOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(pngOptions, 500, 500))
    {
        //Create and initialize an instance of Graphics class
        Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

        //Clear Graphics surface
        graphics.Clear(Color.Wheat);

        //Draw an Arc by specifying the Pen object having Black color,
        //a Rectangle surrounding the Arc, Start Angle and Sweep Angle
        graphics.DrawArc(new Pen(Color.Black, 2), new Rectangle(200, 200, 100, 200), 0, 300);

        //Draw a Bezier by specifying the Pen object having Blue color and co-ordinate Points.
        graphics.DrawBezier(new Pen(Color.Blue, 2), new Point(250, 100), new Point(300, 30), new Point(450, 100), new Point(235, 25));

        //Draw a Curve by specifying the Pen object having Green color and an array of Points
        graphics.DrawCurve(new Pen(Color.Green, 2), new[] { new Point(100, 200), new Point(100, 350), new Point(200, 450) });

        //Draw an Ellipse using the Pen object and a surrounding Rectangle
        graphics.DrawEllipse(new Pen(Color.Yellow, 2), new Rectangle(300, 300, 100, 100));

        //Draw a Line
        graphics.DrawLine(new Pen(Color.Violet, 2), new Point(100, 100), new Point(200, 200));

        //Draw a Pie segment
        graphics.DrawPie(new Pen(Color.Silver, 2), new Rectangle(new Point(200, 20), new Size(200, 200)), 0, 45);

        //Draw a Polygon by specifying the Pen object having Red color and an array of Points
        graphics.DrawPolygon(new Pen(Color.Red, 2), new[] { new Point(20, 100), new Point(20, 200), new Point(220, 20) });

        //Draw a Rectangle
        graphics.DrawRectangle(new Pen(Color.Orange, 2), new Rectangle(new Point(250, 250), new Size(100, 100)));

        //Create a SolidBrush object and set its various properties
        Aspose.Imaging.Brushes.SolidBrush brush = new Aspose.Imaging.Brushes.SolidBrush();
        brush.Color = Color.Purple;
        brush.Opacity = 100;

        //Draw a String using the SolidBrush object and Font, at specific Point
        graphics.DrawString("This image is created by Aspose.Imaging API", new Font("Times New Roman", 16), brush, new PointF(50, 400));

        // save all changes.
        image.Save();
    }
}
[Visual Basic]

'Creates an instance of FileStream
Using stream As System.IO.FileStream = New System.IO.FileStream("C:\temp\output.png", System.IO.FileMode.Create)
'Create an instance of PngOptions and set its various properties
Dim pngOptions As Aspose.Imaging.ImageOptions.PngOptions = New Aspose.Imaging.ImageOptions.PngOptions()

'Set the Source for PngOptions
    pngOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(pngOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
        graphics.Clear(Color.Wheat)

'Draw an Arc by specifying the Pen object having Black color,
'a Rectangle surrounding the Arc, Start Angle and Sweep Angle
        graphics.DrawArc(New Pen(Color.Black, 2), New Rectangle(200, 200, 100, 200), 0, 300)

'Draw a Bezier by specifying the Pen object having Blue color and co-ordinate Points.
        graphics.DrawBezier(New Pen(Color.Blue, 2), New Point(250, 100), New Point(300, 30), New Point(450, 100), New Point(235, 25))

'Draw a Curve by specifying the Pen object having Green color and an array of Points
        graphics.DrawCurve(New Pen(Color.Green, 2), New() { New Point(100, 200), New Point(100, 350), New Point(200, 450) })

'Draw an Ellipse using the Pen object and a surrounding Rectangle
        graphics.DrawEllipse(New Pen(Color.Yellow, 2), New Rectangle(300, 300, 100, 100))

'Draw a Line
        graphics.DrawLine(New Pen(Color.Violet, 2), New Point(100, 100), New Point(200, 200))

'Draw a Pie segment
        graphics.DrawPie(New Pen(Color.Silver, 2), New Rectangle(New Point(200, 20), New Size(200, 200)), 0, 45)

'Draw a Polygon by specifying the Pen object having Red color and an array of Points
        graphics.DrawPolygon(New Pen(Color.Red, 2), New() { New Point(20, 100), New Point(20, 200), New Point(220, 20) })

'Draw a Rectangle
        graphics.DrawRectangle(New Pen(Color.Orange, 2), New Rectangle(New Point(250, 250), New Size(100, 100)))

'Create a SolidBrush object and set its various properties
Dim brush As Aspose.Imaging.Brushes.SolidBrush = New Aspose.Imaging.Brushes.SolidBrush()
        brush.Color = Color.Purple
        brush.Opacity = 100

'Draw a String using the SolidBrush object and Font, at specific Point
        graphics.DrawString("This image is created by Aspose.Imaging API", New Font("Times New Roman", 16), brush, New PointF(50, 400))

' save all changes.
        image.Save()
    End Using
End Using

Requirements

Namespace: Aspose.Imaging.ImageOptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PngOptions Members | Aspose.Imaging.ImageOptions Namespace


PngOptions Members

PngOptions overview

Public Instance Constructors

PngOptions Overloaded. Initializes a new instance of the PngOptions class.

Public Instance Properties

Palette (inherited from ImageOptionsBase) | Gets or sets the color palette.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PngOptions Class | Aspose.Imaging.ImageOptions Namespace


PngOptions Constructor

Initializes a new instance of the PngOptions class.

Overload List

Initializes a new instance of the PngOptions class.

public PngOptions();

Initializes a new instance of the JpegOptions class.

public PngOptions(PngOptions);

See Also

PngOptions Class | Aspose.Imaging.ImageOptions Namespace


PngOptions Constructor ()

Initializes a new instance of the PngOptions class.

public PngOptions();

See Also

PngOptions Class | Aspose.Imaging.ImageOptions Namespace | PngOptions Constructor Overload List


PngOptions Constructor (PngOptions)

Initializes a new instance of the JpegOptions class.

public PngOptions(
PngOptions pngOptions
);

Parameters

pngOptions
The PNG options.

See Also

PngOptions Class | Aspose.Imaging.ImageOptions Namespace | PngOptions Constructor Overload List


PsdOptions Class

The psd file format create options.

For a list of all members of this type, see PsdOptions Members.

System.Object
Aspose.Imaging.ImageOptionsBase
Aspose.Imaging.ImageOptions.PsdOptions

public class PsdOptions : ImageOptionsBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example demonstrates the use of Aspsoe.Imaging for .Net API to convert Images to PSD format. To achieve this goal this example loads an existing image and then saves it back to PSD format.

[C#]

//Creates an instance of image class and initialize it with an existing file through File path
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(@"C:\temp\sample.bmp"))
{
    //Create an instance of PsdOptions class
    Aspose.Imaging.ImageOptions.PsdOptions psdOptions = new Aspose.Imaging.ImageOptions.PsdOptions();

    //Set the CompressionMethod as RLE
    //Note: Other supported CompressionMethod is CompressionMethod.RAW [No Compression]
    psdOptions.CompressionMethod = Aspose.Imaging.FileFormats.Psd.CompressionMethod.RLE;

    //Set the ColorMode to GrayScale
    //Note: Other supported ColorModes are ColorModes.Bitmap and ColorModes.RGB
    psdOptions.ColorMode = Aspose.Imaging.FileFormats.Psd.ColorModes.Grayscale;

    //Save the image to disk location with supplied PsdOptions settings
    image.Save(@"C:\temp\output.psd", psdOptions);
}
[Visual Basic]

'Creates an instance of image class and initialize it with an existing file through File path
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load("C:\temp\sample.bmp")
'Create an instance of PsdOptions class
Dim psdOptions As Aspose.Imaging.ImageOptions.PsdOptions = New Aspose.Imaging.ImageOptions.PsdOptions()

'Set the CompressionMethod as RLE
'Note: Other supported CompressionMethod is CompressionMethod.RAW [No Compression]
    psdOptions.CompressionMethod = Aspose.Imaging.FileFormats.Psd.CompressionMethod.RLE

'Set the ColorMode to GrayScale
'Note: Other supported ColorModes are ColorModes.Bitmap and ColorModes.RGB
    psdOptions.ColorMode = Aspose.Imaging.FileFormats.Psd.ColorModes.Grayscale

'Save the image to disk location with supplied PsdOptions settings
    image.Save("C:\temp\output.psd", psdOptions)
End Using

Requirements

Namespace: Aspose.Imaging.ImageOptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PsdOptions Members | Aspose.Imaging.ImageOptions Namespace


PsdOptions Members

PsdOptions overview

Public Instance Constructors

PsdOptions Constructor Initializes a new instance of the PsdOptions class.

Public Instance Properties

ChannelBitsCount | Gets or sets the bits count per color channel.
ChannelsCount | Gets or sets the color channels count.
ColorMode | Gets or sets the psd color mode.
CompressionMethod | Gets or sets the psd compression method.
Palette (inherited from ImageOptionsBase) | Gets or sets the color palette.
Resources | Gets or sets the psd resources.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.
Version | Gets or sets the psd file version.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PsdOptions Class | Aspose.Imaging.ImageOptions Namespace


PsdOptions Constructor

Initializes a new instance of the PsdOptions class.

public PsdOptions();

See Also

PsdOptions Class | Aspose.Imaging.ImageOptions Namespace


PsdOptions Properties

The properties of the PsdOptions class are listed below. For a complete list of PsdOptions class members, see the PsdOptions Members topic.

Public Instance Properties

ChannelBitsCount | Gets or sets the bits count per color channel.
ChannelsCount | Gets or sets the color channels count.
ColorMode | Gets or sets the psd color mode.
CompressionMethod | Gets or sets the psd compression method.
Palette (inherited from ImageOptionsBase) | Gets or sets the color palette.
Resources | Gets or sets the psd resources.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.
Version | Gets or sets the psd file version.

See Also

PsdOptions Class | Aspose.Imaging.ImageOptions Namespace


ChannelBitsCount Property

Aspose.Imaging Documentation

PsdOptions.ChannelBitsCount Property

Gets or sets the bits count per color channel.

public short ChannelBitsCount {get; set;}

Property Value

The bits count per color channel.

See Also

PsdOptions Class | Aspose.Imaging.ImageOptions Namespace


ChannelsCount Property

Aspose.Imaging Documentation

PsdOptions.ChannelsCount Property

Gets or sets the color channels count.

public short ChannelsCount {get; set;}

Property Value

The color channels count.

See Also

PsdOptions Class | Aspose.Imaging.ImageOptions Namespace


ColorMode Property

Aspose.Imaging Documentation

PsdOptions.ColorMode Property

Gets or sets the psd color mode.

public ColorModes ColorMode {get; set;}

Property Value

The color mode.

See Also

PsdOptions Class | Aspose.Imaging.ImageOptions Namespace


CompressionMethod Property

Aspose.Imaging Documentation

PsdOptions.CompressionMethod Property

Gets or sets the psd compression method.

public CompressionMethod CompressionMethod {get; set;}

Property Value

The compression method.

See Also

PsdOptions Class | Aspose.Imaging.ImageOptions Namespace


Resources Property

Aspose.Imaging Documentation

PsdOptions.Resources Property

Gets or sets the psd resources.

public ResourceBlock[] Resources {get; set;}

Property Value

The psd resources.

See Also

PsdOptions Class | Aspose.Imaging.ImageOptions Namespace


Version Property

Aspose.Imaging Documentation

PsdOptions.Version Property

Gets or sets the psd file version.

public int Version {get; set;}

Property Value

The psd file version.

See Also

PsdOptions Class | Aspose.Imaging.ImageOptions Namespace


TiffOptions Class

The tiff file format options. Note that width and height tags will get overwritten on image creation by width and height parameters so there is no need to specify them directly. Note that many options return a default value but that does not mean that this option is set explicitly as a tag value. To verify the tag is present use Tags property or the corresponding IsTagPresent method.

For a list of all members of this type, see TiffOptions Members.

System.Object
Aspose.Imaging.ImageOptionsBase
Aspose.Imaging.ImageOptions.TiffOptions

public class TiffOptions : ImageOptionsBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example demonstrates the use of different classes from SaveOptions Namespace for export purposes. An image of type Gif is loaded into an instance of Image and then exported out to several formats.

[C#]

//Load an existing image (of type Gif) in an instance of Image class
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Load(@"C:\temp\sample.gif"))
{
    //Export to BMP file format using the default options
    image.Save(@"C:\output.bmp", new Aspose.Imaging.ImageOptions.BmpOptions());

    //Export to JPEG file format using the default options
    image.Save(@"C:\output.jpeg", new Aspose.Imaging.ImageOptions.JpegOptions());

    //Export to PNG file format using the default options
    image.Save(@"C:\output.png", new Aspose.Imaging.ImageOptions.PngOptions());

    //Export to TIFF file format using the default options
    image.Save(@"c:\output.tiff", new Aspose.Imaging.ImageOptions.TiffOptions());
}
[Visual Basic]

'Load an existing image (of type Gif) in an instance of Image class
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Load("C:\temp\sample.gif")
'Export to BMP file format using the default options
    image.Save("C:\output.bmp", New Aspose.Imaging.ImageOptions.BmpOptions())

'Export to JPEG file format using the default options
    image.Save("C:\output.jpeg", New Aspose.Imaging.ImageOptions.JpegOptions())

'Export to PNG file format using the default options
    image.Save("C:\output.png", New Aspose.Imaging.ImageOptions.PngOptions())

'Export to TIFF file format using the default options
    image.Save("c:\output.tiff", New Aspose.Imaging.ImageOptions.TiffOptions())
End Using
This examples make use of GraphicsPath and Graphics class to create and manipulate Figures on an Image surface. Example creates a new Image (of type Tiff) and draw paths with the help of GraphicsPath class. At the end DrawPath method exposed by Graphics class is called to render the paths on surface.
[C#]

//Create an instance of FileStream
using (System.IO.FileStream stream = new System.IO.FileStream(@"C:\temp\output.tiff", System.IO.FileMode.Create))
{
    //Create an instance of TiffOptions and set its various properties
    Aspose.Imaging.ImageOptions.TiffOptions tiffOptions = new Aspose.Imaging.ImageOptions.TiffOptions();

    //Set the source for the instance of ImageOptions
    tiffOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(tiffOptions, 500, 500))
    {
        //Create and initialize an instance of Graphics class
        Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

        //Clear Graphics surface
        graphics.Clear(Color.Wheat);

        //Create an instance of GraphicsPath class
        Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

        //Create an instance of Figure class
        Aspose.Imaging.Figure figure = new Aspose.Imaging.Figure();

        //Add Shapes to Figure object
        figure.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new RectangleF(10, 10, 300, 300)));
        figure.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
        figure.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(250, 250), new Size(200, 200)), 0, 45));

        //Add Figure object to GraphicsPath
        graphicspath.AddFigure(figure);

        //Draw path with Pen object of color Black
        graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

        // save all changes.
        image.Save();
    }
}
[Visual Basic]

'Create an instance of FileStream
Using stream As System.IO.FileStream = New System.IO.FileStream("C:\temp\output.tiff", System.IO.FileMode.Create)
'Create an instance of TiffOptions and set its various properties
Dim tiffOptions As Aspose.Imaging.ImageOptions.TiffOptions = New Aspose.Imaging.ImageOptions.TiffOptions()

'Set the source for the instance of ImageOptions
    tiffOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(tiffOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
        graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shapes to Figure object
        figure.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New RectangleF(10, 10, 300, 300)))
        figure.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
        figure.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(250, 250), New Size(200, 200)), 0, 45))

'Add Figure object to GraphicsPath
        graphicspath.AddFigure(figure)

'Draw path with Pen object of color Black
        graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
        image.Save()
    End Using
End Using

Requirements

Namespace: Aspose.Imaging.ImageOptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TiffOptions Members | Aspose.Imaging.ImageOptions Namespace


TiffOptions Members

TiffOptions overview

Public Instance Constructors

TiffOptions Overloaded. Initializes a new instance of the TiffOptions class.

Public Instance Properties

AlphaStorage | Gets or sets the alpha storage option. Options other than Unspecified are used when there are more than 3 SamplesPerPixel defined.
Artist | Gets or sets the artist.
BitsPerPixel | Gets the bits per pixel.
BitsPerSample | Gets or sets the bits per sample.
ByteOrder | Gets or sets a value indicating the tiff byte order.
ColorMap | Gets or sets the color map.
Compression | Gets or sets the compression.
Copyright | Gets or sets the copyright.
DateTime | Gets or sets the date and time.
DocumentName | Gets or sets the name of the document.
FaxT4Options | Gets or sets the fax t4 options.
FillOrder | Gets or sets the byte bits fill order.
HalfToneHints | Gets or sets the halftone hints.
ImageDescription | Gets or sets the image description.
ImageLength | Gets or sets the image length.
ImageWidth | Gets or sets the image width.
InkNames | Gets or sets the ink names.
IsValid | Gets a value indicating whether the TiffOptions have been properly configured. Use Validate method as to find the failure reason.
MaxSampleValue | Gets or sets the max sample value.
MinSampleValue | Gets or sets the min sample value.
Orientation | Gets or sets the orientation.
PageName | Gets or sets the page name.
PageNumber | Gets or sets the page number tag.
Palette | Gets or sets the color palette.
Photometric | Gets or sets the photometric.
PlanarConfiguration | Gets or sets the planar configuration.
Predictor | Gets or sets the predictor for LZW compression.
ResolutionUnit | Gets or sets the resolution unit.
RowsPerStrip | Gets or sets the rows per strip.
SampleFormat | Gets or sets the sample format.
SamplesPerPixel | Gets the samples per pixel. To change this property value use the BitsPerSample property setter.
ScannerManufacturer | Gets or sets the scanner manufacturer.
ScannerModel | Gets or sets the scanner model.
SmaxSampleValue | Gets or sets the max sample value. The value has a field type which best matches the sample data (Byte, Short or Long type).
SminSampleValue | Gets or sets the min sample value. The value has a field type which best matches the sample data (Byte, Short or Long type).
SoftwareType | Gets or sets the software type.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.
StripByteCounts | Gets or sets the strip byte counts.
StripOffsets | Gets or sets the strip offsets.
SubFileType | Gets or sets a general indication of the kind of data contained in this subfile.
Tags | Gets or sets the tags.
TargetPrinter | Gets or sets the target printer.
Threshholding | Gets or sets the threshholding.
TotalPages | Gets the total pages.
ValidTagCount | Gets the valid tag count. This is not the total tags count but the number of tags which may be preserved.
Xposition | Gets or sets the x position.
Xresolution | Gets or sets the x resolution.
Yposition | Gets or sets the y position.
Yresolution | Gets or sets the y resolution.

Public Instance Methods

AddTag | Adds a new tag.
AddTags | Overloaded. Adds the tags.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsTagPresent | Determines whether tag is present in the options or not.
RemoveTag | Removes the tag.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates if options have valid combination of tags

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


TiffOptions Constructor

Initializes a new instance of the TiffOptions class.

Overload List

Initializes a new instance of the TiffOptions class.

public TiffOptions();

Initializes a new instance of the TiffOptions class.

public TiffOptions(TiffDataType[]);

Initializes a new instance of the TiffOptions class.

public TiffOptions(TiffOptions);

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


TiffOptions Constructor ()

Initializes a new instance of the TiffOptions class.

public TiffOptions();

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace | TiffOptions Constructor Overload List


TiffOptions Constructor (TiffOptions)

Initializes a new instance of the TiffOptions class.

public TiffOptions(
TiffOptions options
);

Parameters

options
The options to copy from.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace | TiffOptions Constructor Overload List


TiffOptions Constructor (TiffDataType[])

Initializes a new instance of the TiffOptions class.

public TiffOptions(
TiffDataType[] tags
);

Parameters

tags
The tags to initialize options with.

Exceptions

Exception Type | Condition
ArgumentNullException | tags

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace | TiffOptions Constructor Overload List


TiffOptions Properties

The properties of the TiffOptions class are listed below. For a complete list of TiffOptions class members, see the TiffOptions Members topic.

Public Instance Properties

AlphaStorage | Gets or sets the alpha storage option. Options other than Unspecified are used when there are more than 3 SamplesPerPixel defined.
Artist | Gets or sets the artist.
BitsPerPixel | Gets the bits per pixel.
BitsPerSample | Gets or sets the bits per sample.
ByteOrder | Gets or sets a value indicating the tiff byte order.
ColorMap | Gets or sets the color map.
Compression | Gets or sets the compression.
Copyright | Gets or sets the copyright.
DateTime | Gets or sets the date and time.
DocumentName | Gets or sets the name of the document.
FaxT4Options | Gets or sets the fax t4 options.
FillOrder | Gets or sets the byte bits fill order.
HalfToneHints | Gets or sets the halftone hints.
ImageDescription | Gets or sets the image description.
ImageLength | Gets or sets the image length.
ImageWidth | Gets or sets the image width.
InkNames | Gets or sets the ink names.
IsValid | Gets a value indicating whether the TiffOptions have been properly configured. Use Validate method as to find the failure reason.
MaxSampleValue | Gets or sets the max sample value.
MinSampleValue | Gets or sets the min sample value.
Orientation | Gets or sets the orientation.
PageName | Gets or sets the page name.
PageNumber | Gets or sets the page number tag.
Palette | Gets or sets the color palette.
Photometric | Gets or sets the photometric.
PlanarConfiguration | Gets or sets the planar configuration.
Predictor | Gets or sets the predictor for LZW compression.
ResolutionUnit | Gets or sets the resolution unit.
RowsPerStrip | Gets or sets the rows per strip.
SampleFormat | Gets or sets the sample format.
SamplesPerPixel | Gets the samples per pixel. To change this property value use the BitsPerSample property setter.
ScannerManufacturer | Gets or sets the scanner manufacturer.
ScannerModel | Gets or sets the scanner model.
SmaxSampleValue | Gets or sets the max sample value. The value has a field type which best matches the sample data (Byte, Short or Long type).
SminSampleValue | Gets or sets the min sample value. The value has a field type which best matches the sample data (Byte, Short or Long type).
SoftwareType | Gets or sets the software type.
Source (inherited from ImageOptionsBase) | Gets or sets the source to create image in.
StripByteCounts | Gets or sets the strip byte counts.
StripOffsets | Gets or sets the strip offsets.
SubFileType | Gets or sets a general indication of the kind of data contained in this subfile.
Tags | Gets or sets the tags.
TargetPrinter | Gets or sets the target printer.
Threshholding | Gets or sets the threshholding.
TotalPages | Gets the total pages.
ValidTagCount | Gets the valid tag count. This is not the total tags count but the number of tags which may be preserved.
Xposition | Gets or sets the x position.
Xresolution | Gets or sets the x resolution.
Yposition | Gets or sets the y position.
Yresolution | Gets or sets the y resolution.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


AlphaStorage Property

Aspose.Imaging Documentation

TiffOptions.AlphaStorage Property

Gets or sets the alpha storage option. Options other than Unspecified are used when there are more than 3 SamplesPerPixel defined.

public TiffAlphaStorage AlphaStorage {get; set;}

Property Value

The alpha storage option.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Artist Property

Aspose.Imaging Documentation

TiffOptions.Artist Property

Gets or sets the artist.

public string Artist {get; set;}

Property Value

The artist.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


BitsPerPixel Property

Aspose.Imaging Documentation

TiffOptions.BitsPerPixel Property

Gets the bits per pixel.

public int BitsPerPixel {get;}

Property Value

The bits per pixel.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


BitsPerSample Property

Aspose.Imaging Documentation

TiffOptions.BitsPerSample Property

Gets or sets the bits per sample.

public ushort[] BitsPerSample {get; set;}

Property Value

The bits per sample value.

Remarks

When setting this value keep in mind that it will also set SamplesPerPixel value to array length. These 2 properties are very tightly coupled so may be set alltogether only.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


ByteOrder Property

Aspose.Imaging Documentation

TiffOptions.ByteOrder Property

Gets or sets a value indicating the tiff byte order.

public TiffByteOrder ByteOrder {get; set;}

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


ColorMap Property

Aspose.Imaging Documentation

TiffOptions.ColorMap Property

Gets or sets the color map.

public ushort[] ColorMap {get; set;}

Property Value

The color map.

Exceptions

Exception Type | Condition
ArgumentNullException | value
TiffImageException | The color map may be defined for samples per pixel equal to 1 only. or The bits per sample are not defined.
ArgumentOutOfRangeException | value;The array length must correspond to the followign formula: 3 * (2**BitsPerSample).

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Compression Property

Aspose.Imaging Documentation

TiffOptions.Compression Property

Gets or sets the compression.

public TiffCompressions Compression {get; set;}

Property Value

The compression.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Copyright Property

Aspose.Imaging Documentation

TiffOptions.Copyright Property

Gets or sets the copyright.

public string Copyright {get; set;}

Property Value

The copyright.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


DateTime Property

Aspose.Imaging Documentation

TiffOptions.DateTime Property

Gets or sets the date and time.

public string DateTime {get; set;}

Property Value

The date and time.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


DocumentName Property

Aspose.Imaging Documentation

TiffOptions.DocumentName Property

Gets or sets the name of the document.

public string DocumentName {get; set;}

Property Value

The name of the document.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


FaxT4Options Property

Aspose.Imaging Documentation

TiffOptions.FaxT4Options Property

Gets or sets the fax t4 options.

public Group3Options FaxT4Options {get; set;}

Property Value

The fax t4 options.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


FillOrder Property

Aspose.Imaging Documentation

TiffOptions.FillOrder Property

Gets or sets the byte bits fill order.

public TiffFillOrders FillOrder {get; set;}

Property Value

The byte bits fill order.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


HalfToneHints Property

Aspose.Imaging Documentation

TiffOptions.HalfToneHints Property

Gets or sets the halftone hints.

public ushort[] HalfToneHints {get; set;}

Property Value

The halftone hints.

Exceptions

Exception Type | Condition
ArgumentNullException | value
ArgumentOutOfRangeException | value;Halftone hints array length must be equal to 2.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


ImageDescription Property

Aspose.Imaging Documentation

TiffOptions.ImageDescription Property

Gets or sets the image description.

public string ImageDescription {get; set;}

Property Value

The image description.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


ImageLength Property

Aspose.Imaging Documentation

TiffOptions.ImageLength Property

Gets or sets the image length.

public uint ImageLength {get; set;}

Property Value

The image length.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


ImageWidth Property

Aspose.Imaging Documentation

TiffOptions.ImageWidth Property

Gets or sets the image width.

public uint ImageWidth {get; set;}

Property Value

The image width.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


InkNames Property

Aspose.Imaging Documentation

TiffOptions.InkNames Property

Gets or sets the ink names.

public string InkNames {get; set;}

Property Value

The ink names.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


IsValid Property

Aspose.Imaging Documentation

TiffOptions.IsValid Property

Gets a value indicating whether the TiffOptions have been properly configured. Use Validate method as to find the failure reason.

public bool IsValid {get;}

Property Value

true if TiffOptions are properly configured; otherwise, false.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


MaxSampleValue Property

Aspose.Imaging Documentation

TiffOptions.MaxSampleValue Property

Gets or sets the max sample value.

public ushort[] MaxSampleValue {get; set;}

Property Value

The max sample value.

Exceptions

Exception Type | Condition
ArgumentNullException | value
ArgumentOutOfRangeException | value;The array length must correspond to the samples per pixel count.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


MinSampleValue Property

Aspose.Imaging Documentation

TiffOptions.MinSampleValue Property

Gets or sets the min sample value.

public ushort[] MinSampleValue {get; set;}

Property Value

The min sample value.

Exceptions

Exception Type | Condition
ArgumentNullException | value
ArgumentOutOfRangeException | value;The array length must correspond to the samples per pixel count.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Orientation Property

Aspose.Imaging Documentation

TiffOptions.Orientation Property

Gets or sets the orientation.

public TiffOrientations Orientation {get; set;}

Property Value

The orientation.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


PageName Property

Aspose.Imaging Documentation

TiffOptions.PageName Property

Gets or sets the page name.

public string PageName {get; set;}

Property Value

The page name.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


PageNumber Property

Aspose.Imaging Documentation

TiffOptions.PageNumber Property

Gets or sets the page number tag.

public ushort[] PageNumber {get; set;}

Property Value

The page number tag.

Exceptions

Exception Type | Condition
ArgumentNullException | value
ArgumentOutOfRangeException | value;Expected 2 values in the array: PageNumber[0] is the page number and PageNumber[1] is the total number of pages in the document.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Palette Property

Aspose.Imaging Documentation

TiffOptions.Palette Property

Gets or sets the color palette.

public override IColorPalette Palette {get; set;}

Property Value

The color palette.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Photometric Property

Aspose.Imaging Documentation

TiffOptions.Photometric Property

Gets or sets the photometric.

public TiffPhotometrics Photometric {get; set;}

Property Value

The photometric.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


PlanarConfiguration Property

Aspose.Imaging Documentation

TiffOptions.PlanarConfiguration Property

Gets or sets the planar configuration.

public TiffPlanarConfigs PlanarConfiguration {get; set;}

Property Value

The planar configuration.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Predictor Property

Aspose.Imaging Documentation

TiffOptions.Predictor Property

Gets or sets the predictor for LZW compression.

public TiffPredictor Predictor {get; set;}

Property Value

The predictor type.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


ResolutionUnit Property

Aspose.Imaging Documentation

TiffOptions.ResolutionUnit Property

Gets or sets the resolution unit.

public TiffResolutionUnits ResolutionUnit {get; set;}

Property Value

The resolution unit.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


RowsPerStrip Property

Aspose.Imaging Documentation

TiffOptions.RowsPerStrip Property

Gets or sets the rows per strip.

public uint RowsPerStrip {get; set;}

Property Value

The rows per strip.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


SampleFormat Property

Aspose.Imaging Documentation

TiffOptions.SampleFormat Property

Gets or sets the sample format.

public TiffSampleFormats[] SampleFormat {get; set;}

Property Value

The sample format.

Exceptions

Exception Type | Condition
ArgumentNullException | value
ArgumentOutOfRangeException | value;The array length must correspond to the samples per pixel count.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


SamplesPerPixel Property

Aspose.Imaging Documentation

TiffOptions.SamplesPerPixel Property

Gets the samples per pixel. To change this property value use the BitsPerSample property setter.

public ushort SamplesPerPixel {get;}

Property Value

The samples per pixel.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


ScannerManufacturer Property

Aspose.Imaging Documentation

TiffOptions.ScannerManufacturer Property

Gets or sets the scanner manufacturer.

public string ScannerManufacturer {get; set;}

Property Value

The scanner manufacturer.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


ScannerModel Property

Aspose.Imaging Documentation

TiffOptions.ScannerModel Property

Gets or sets the scanner model.

public string ScannerModel {get; set;}

Property Value

The scanner model.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


SmaxSampleValue Property

Aspose.Imaging Documentation

TiffOptions.SmaxSampleValue Property

Gets or sets the max sample value. The value has a field type which best matches the sample data (Byte, Short or Long type).

public uint[] SmaxSampleValue {get; set;}

Property Value

The max sample value.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


SminSampleValue Property

Aspose.Imaging Documentation

TiffOptions.SminSampleValue Property

Gets or sets the min sample value. The value has a field type which best matches the sample data (Byte, Short or Long type).

public uint[] SminSampleValue {get; set;}

Property Value

The min sample value.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


SoftwareType Property

Aspose.Imaging Documentation

TiffOptions.SoftwareType Property

Gets or sets the software type.

public string SoftwareType {get; set;}

Property Value

The software type.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


StripByteCounts Property

Aspose.Imaging Documentation

TiffOptions.StripByteCounts Property

Gets or sets the strip byte counts.

public uint[] StripByteCounts {get; set;}

Property Value

The strip byte counts.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


StripOffsets Property

Aspose.Imaging Documentation

TiffOptions.StripOffsets Property

Gets or sets the strip offsets.

public uint[] StripOffsets {get; set;}

Property Value

The strip offsets.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


SubFileType Property

Aspose.Imaging Documentation

TiffOptions.SubFileType Property

Gets or sets a general indication of the kind of data contained in this subfile.

public TiffNewSubFileTypes SubFileType {get; set;}

Property Value

The general indication of the kind of data contained in this subfile.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Tags Property

Aspose.Imaging Documentation

TiffOptions.Tags Property

Gets or sets the tags.

public TiffDataType[] Tags {get; set;}

Property Value

The tags.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


TargetPrinter Property

Aspose.Imaging Documentation

TiffOptions.TargetPrinter Property

Gets or sets the target printer.

public string TargetPrinter {get; set;}

Property Value

The target printer.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Threshholding Property

Aspose.Imaging Documentation

TiffOptions.Threshholding Property

Gets or sets the threshholding.

public TiffThresholds Threshholding {get; set;}

Property Value

The threshholding.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


TotalPages Property

Aspose.Imaging Documentation

TiffOptions.TotalPages Property

Gets the total pages.

public ushort TotalPages {get;}

Property Value

The total pages.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


ValidTagCount Property

Aspose.Imaging Documentation

TiffOptions.ValidTagCount Property

Gets the valid tag count. This is not the total tags count but the number of tags which may be preserved.

public int ValidTagCount {get;}

Property Value

The valid tag count.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Xposition Property

Aspose.Imaging Documentation

TiffOptions.Xposition Property

Gets or sets the x position.

public TiffRational Xposition {get; set;}

Property Value

The x position.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Xresolution Property

Aspose.Imaging Documentation

TiffOptions.Xresolution Property

Gets or sets the x resolution.

public TiffRational Xresolution {get; set;}

Property Value

The x resolution.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Yposition Property

Aspose.Imaging Documentation

TiffOptions.Yposition Property

Gets or sets the y position.

public TiffRational Yposition {get; set;}

Property Value

The y position.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


Yresolution Property

Aspose.Imaging Documentation

TiffOptions.Yresolution Property

Gets or sets the y resolution.

public TiffRational Yresolution {get; set;}

Property Value

The y resolution.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


TiffOptions Methods

The methods of the TiffOptions class are listed below. For a complete list of TiffOptions class members, see the TiffOptions Members topic.

Public Instance Methods

AddTag | Adds a new tag.
AddTags | Overloaded. Adds the tags.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsTagPresent | Determines whether tag is present in the options or not.
RemoveTag | Removes the tag.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates if options have valid combination of tags

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


TiffOptions.AddTag Method

Adds a new tag.

public void AddTag(
TiffDataType tagToAdd
);

Parameters

tagToAdd
The tag to add.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


AddTags Method

Aspose.Imaging Documentation

TiffOptions.AddTags Method

Adds the tags.

Overload List

Adds the tags.

public void AddTags(TiffDataType[]);

Adds the tags.

public void AddTags(TiffDataType});

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


TiffOptions.AddTags Method (TiffDataType[])

Adds the tags.

public void AddTags(
TiffDataType[] tagsToAdd
);

Parameters

tagsToAdd
The tags to add.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace | TiffOptions.AddTags Overload List


TiffOptions.AddTags Method (TiffDataType})

Adds the tags.

public void AddTags(
IEnumerable<TiffDataType> tagsToAdd
);

Parameters

tagsToAdd
The tags to add.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace | TiffOptions.AddTags Overload List


TiffOptions.IsTagPresent Method

Determines whether tag is present in the options or not.

public bool IsTagPresent(
TiffTags tag
);

Parameters

tag
The tag id to check.

Return Value

true if tag is present; otherwise, false.

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


TiffOptions.RemoveTag Method

Removes the tag.

public bool RemoveTag(
TiffTags tag
);

Parameters

tag
The tag to remove.

Return Value

true if successfully removed

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


TiffOptions.Validate Method

Validates if options have valid combination of tags

public void Validate();

See Also

TiffOptions Class | Aspose.Imaging.ImageOptions Namespace


TiffOptionsError Enumeration

The tiff options error codes.

public enum TiffOptionsError

Members

Member Name | Description | Value
NoError | No error code. | 0
NoColorMap | The color map is not defined. | 1
ColorMapLengthInvalid | The color map length is invalid. | 2
CompressionSppMismatch | The compression does not match the samples per pixel count. | 3
PhotometricCompressionMismatch | The compression does not match the photometric settings. | 4
PhotometricSppMismatch | The photometric does not match the samples per pixel count. | 5

Requirements

Namespace: Aspose.Imaging.ImageOptions

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

Aspose.Imaging.ImageOptions Namespace


Aspose.Imaging.Shapes

Aspose.Imaging Documentation

Aspose.Imaging.Shapes Namespace

Namespace hierarchy

Classes

Class | Description
ArcShape | Represents an arc shape.
BezierShape | Represents a bezier spline.
CurveShape | Represents a curved spline shape.
EllipseShape | Represents an ellipse shape.
PieShape | Represents a pie shape.
PolygonShape | Represents a polygon shape.
RectangleProjectedShape | Represents a shape which is projected over rectangle turned to a particular orientation. Specified by four points which can be rotated in space maintaining the same edges length and 90 degrees between adjacent edges.
RectangleShape | Represents a rectangular shape.
TextShape | Represents a text shape.


ArcShape Class

Represents an arc shape.

For a list of all members of this type, see ArcShape Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Shape
Aspose.Imaging.Shapes.RectangleProjectedShape
Aspose.Imaging.Shapes.RectangleShape
Aspose.Imaging.Shapes.EllipseShape
Aspose.Imaging.Shapes.PieShape
Aspose.Imaging.Shapes.ArcShape

public sealed class ArcShape : PieShape, IOrderedShape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example creates a new Image and draws a variety of shapes using Figures and GraphicsPath on the Image surface

[C#]

//Creates an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"c:\temp\output.bmp", false);

//Create an instance of Image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Create and initialize an instance of Graphics class
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clear Graphics surface
    graphics.Clear(Color.Wheat);

    //Create an instance of GraphicsPath class
    Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure1 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure1.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
    figure1.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(110, 110), new Size(200, 200)), 0, 90));

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure2 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure2.AddShape(new Aspose.Imaging.Shapes.ArcShape(new RectangleF(10, 10, 300, 300), 0, 45));
    figure2.AddShape(new Aspose.Imaging.Shapes.PolygonShape(new[] { new PointF(150, 10), new PointF(150, 200), new PointF(250, 300), new PointF(350, 400) }, true));
    figure2.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new Rectangle(new Point(250, 250), new Size(200, 200))));

    //Add Figure object to GraphicsPath
    graphicspath.AddFigures(new[] { figure1, figure2 });

    //Draw path with Pen object of color Black
    graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

    // save all changes.
    image.Save();
}
[Visual Basic]

'Creates an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("c:\temp\output.bmp", False)

'Create an instance of Image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
    graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure1 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure1.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
    figure1.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(110, 110), New Size(200, 200)), 0, 90))

'Create an instance of Figure class
Dim figure2 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure2.AddShape(New Aspose.Imaging.Shapes.ArcShape(New RectangleF(10, 10, 300, 300), 0, 45))
    figure2.AddShape(New Aspose.Imaging.Shapes.PolygonShape(New() { New PointF(150, 10), New PointF(150, 200), New PointF(250, 300), New PointF(350, 400) }, True))
    figure2.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New Rectangle(New Point(250, 250), New Size(200, 200))))

'Add Figure object to GraphicsPath
    graphicspath.AddFigures(New() { figure1, figure2 })

'Draw path with Pen object of color Black
    graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
    image.Save()
End Using

Requirements

Namespace: Aspose.Imaging.Shapes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

ArcShape Members | Aspose.Imaging.Shapes Namespace


ArcShape Members

ArcShape overview

Public Instance Constructors

ArcShape Overloaded. Initializes a new instance of the ArcShape class.

Public Instance Properties

Bounds (inherited from RectangleProjectedShape) | Gets the object's bounds.
Center (inherited from RectangleProjectedShape) | Gets the shape's center.
EndPoint | Gets the ending shape point.
HasSegments (inherited from RectangleProjectedShape) | Gets a value indicating whether shape has segments.
IsClosed | Gets or sets a value indicating whether ordered shape is closed. When processing closed ordered shape the starting and ending points have no meaning.
LeftBottom (inherited from RectangleProjectedShape) | Gets the left bottom rectangle point.
LeftTop (inherited from RectangleProjectedShape) | Gets the left top rectangle point.
RectangleHeight (inherited from RectangleProjectedShape) | Gets the rectangle height.
RectangleWidth (inherited from RectangleProjectedShape) | Gets the rectangle width.
RightBottom (inherited from RectangleProjectedShape) | Gets the right bottom rectangle point.
RightTop (inherited from RectangleProjectedShape) | Gets the right top rectangle point.
Segments | Gets the shape segments.
StartAngle (inherited from PieShape) | Gets or sets the start angle.
StartPoint | Gets the starting shape point.
SweepAngle (inherited from PieShape) | Gets or sets the sweep angle.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Reverse | Reverses the order of points for this shape.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform (inherited from RectangleProjectedShape) | Applies the specified transformation to the shape.

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace


ArcShape Constructor

Initializes a new instance of the ArcShape class.

Overload List

Initializes a new instance of the ArcShape class.

public ArcShape();

Initializes a new instance of the ArcShape class.

public ArcShape(RectangleF,float,float);

Initializes a new instance of the ArcShape class.

public ArcShape(RectangleF,float,float,bool);

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace


ArcShape Constructor ()

Initializes a new instance of the ArcShape class.

public ArcShape();

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace | ArcShape Constructor Overload List


ArcShape Constructor (RectangleF, Single, Single)

Initializes a new instance of the ArcShape class.

public ArcShape(
RectangleF rectangle,
float startAngle,
float sweepAngle
);

Parameters

rectangle
The rectangle.
startAngle
The start angle.
sweepAngle
The sweep angle.

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace | ArcShape Constructor Overload List


ArcShape Constructor (RectangleF, Single, Single, Boolean)

Initializes a new instance of the ArcShape class.

public ArcShape(
RectangleF rectangle,
float startAngle,
float sweepAngle,
bool isClosed
);

Parameters

rectangle
The rectangle.
startAngle
The start angle.
sweepAngle
The sweep angle.
isClosed
If set to true the arc is closed. The closed arc is actually degenereates to an ellipse.

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace | ArcShape Constructor Overload List


ArcShape Properties

The properties of the ArcShape class are listed below. For a complete list of ArcShape class members, see the ArcShape Members topic.

Public Instance Properties

Bounds (inherited from RectangleProjectedShape) | Gets the object's bounds.
Center (inherited from RectangleProjectedShape) | Gets the shape's center.
EndPoint | Gets the ending shape point.
HasSegments (inherited from RectangleProjectedShape) | Gets a value indicating whether shape has segments.
IsClosed | Gets or sets a value indicating whether ordered shape is closed. When processing closed ordered shape the starting and ending points have no meaning.
LeftBottom (inherited from RectangleProjectedShape) | Gets the left bottom rectangle point.
LeftTop (inherited from RectangleProjectedShape) | Gets the left top rectangle point.
RectangleHeight (inherited from RectangleProjectedShape) | Gets the rectangle height.
RectangleWidth (inherited from RectangleProjectedShape) | Gets the rectangle width.
RightBottom (inherited from RectangleProjectedShape) | Gets the right bottom rectangle point.
RightTop (inherited from RectangleProjectedShape) | Gets the right top rectangle point.
Segments | Gets the shape segments.
StartAngle (inherited from PieShape) | Gets or sets the start angle.
StartPoint | Gets the starting shape point.
SweepAngle (inherited from PieShape) | Gets or sets the sweep angle.

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace


EndPoint Property

Aspose.Imaging Documentation

ArcShape.EndPoint Property

Gets the ending shape point.

public PointF EndPoint {get;}

Property Value

The ending shape point.

Implements

IOrderedShape.EndPoint

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace


IsClosed Property

Aspose.Imaging Documentation

ArcShape.IsClosed Property

Gets or sets a value indicating whether ordered shape is closed. When processing closed ordered shape the starting and ending points have no meaning.

public bool IsClosed {get; set;}

Property Value

True if this ordered shape is closed; otherwise, false.

Implements

IOrderedShape.IsClosed

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace


Segments Property

Aspose.Imaging Documentation

ArcShape.Segments Property

Gets the shape segments.

public override ShapeSegment[] Segments {get;}

Property Value

The shape segments.

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace


StartPoint Property

Aspose.Imaging Documentation

ArcShape.StartPoint Property

Gets the starting shape point.

public PointF StartPoint {get;}

Property Value

The starting shape point.

Implements

IOrderedShape.StartPoint

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace


ArcShape Methods

The methods of the ArcShape class are listed below. For a complete list of ArcShape class members, see the ArcShape Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Reverse | Reverses the order of points for this shape.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform (inherited from RectangleProjectedShape) | Applies the specified transformation to the shape.

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace


GetBounds Method

Aspose.Imaging Documentation

ArcShape.GetBounds Method

Gets the object's bounds.

Overload List

Gets the object's bounds.

public override RectangleF GetBounds(Matrix);

Gets the object's bounds.

public override RectangleF GetBounds(Matrix,Pen);

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace


ArcShape.GetBounds Method (Matrix)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix
);

Parameters

matrix
The matrix to apply before bounds will be calculated.

Return Value

The estimated object's bounds.

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace | ArcShape.GetBounds Overload List


ArcShape.GetBounds Method (Matrix, Pen)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix,
Pen pen
);

Parameters

matrix
The matrix to apply before bounds will be calculated.
pen
The pen to use for object. This can influence the object's bounds size.

Return Value

The estimated object's bounds.

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace | ArcShape.GetBounds Overload List


ArcShape.Reverse Method

Reverses the order of points for this shape.

public void Reverse();

Implements

IOrderedShape.Reverse

See Also

ArcShape Class | Aspose.Imaging.Shapes Namespace


BezierShape Class

Represents a bezier spline.

For a list of all members of this type, see BezierShape Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Shape
Aspose.Imaging.Shapes.PolygonShape
Aspose.Imaging.Shapes.BezierShape

public sealed class BezierShape : PolygonShape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Shapes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

BezierShape Members | Aspose.Imaging.Shapes Namespace


BezierShape Members

BezierShape overview

Public Instance Constructors

BezierShape Overloaded. Initializes a new instance of the BezierShape class.

Public Instance Properties

Bounds | Gets the object's bounds.
Center | Gets the shape's center.
EndPoint | Gets the ending shape point.
HasSegments | Gets a value indicating whether shape has segments.
IsClosed (inherited from PolygonShape) | Gets or sets a value indicating whether shape is closed.
Points (inherited from PolygonShape) | Gets or sets the curve points.
Segments | Gets the shape segments.
StartPoint (inherited from PolygonShape) | Gets the starting shape point.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Reverse (inherited from PolygonShape) | Reverses the order of points for this shape.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform (inherited from PolygonShape) | Applies the specified transformation to the shape.

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace


BezierShape Constructor

Initializes a new instance of the BezierShape class.

Overload List

Initializes a new instance of the BezierShape class.

public BezierShape();

Initializes a new instance of the BezierShape class.

public BezierShape(PointF[]);

Initializes a new instance of the BezierShape class.

public BezierShape(PointF[],bool);

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace


BezierShape Constructor ()

Initializes a new instance of the BezierShape class.

public BezierShape();

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace | BezierShape Constructor Overload List


BezierShape Constructor (PointF[])

Initializes a new instance of the BezierShape class.

public BezierShape(
PointF[] points
);

Parameters

points
The points array.

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace | BezierShape Constructor Overload List


BezierShape Constructor (PointF[], Boolean)

Initializes a new instance of the BezierShape class.

public BezierShape(
PointF[] points,
bool isClosed
);

Parameters

points
The points array.
isClosed
If set to true the bezier spline is closed.

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace | BezierShape Constructor Overload List


BezierShape Properties

The properties of the BezierShape class are listed below. For a complete list of BezierShape class members, see the BezierShape Members topic.

Public Instance Properties

Bounds | Gets the object's bounds.
Center | Gets the shape's center.
EndPoint | Gets the ending shape point.
HasSegments | Gets a value indicating whether shape has segments.
IsClosed (inherited from PolygonShape) | Gets or sets a value indicating whether shape is closed.
Points (inherited from PolygonShape) | Gets or sets the curve points.
Segments | Gets the shape segments.
StartPoint (inherited from PolygonShape) | Gets the starting shape point.

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace


Bounds Property

Aspose.Imaging Documentation

BezierShape.Bounds Property

Gets the object's bounds.

public override RectangleF Bounds {get;}

Property Value

The object's bounds.

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace


Center Property

Aspose.Imaging Documentation

BezierShape.Center Property

Gets the shape's center.

public override PointF Center {get;}

Property Value

The shape's center.

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace


EndPoint Property

Aspose.Imaging Documentation

BezierShape.EndPoint Property

Gets the ending shape point.

public override PointF EndPoint {get;}

Property Value

The ending shape point.

Implements

IOrderedShape.EndPoint

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace


HasSegments Property

Aspose.Imaging Documentation

BezierShape.HasSegments Property

Gets a value indicating whether shape has segments.

public override bool HasSegments {get;}

Property Value

True if shape has segments; otherwise, false.

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace


Segments Property

Aspose.Imaging Documentation

BezierShape.Segments Property

Gets the shape segments.

public override ShapeSegment[] Segments {get;}

Property Value

The shape segments.

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace


BezierShape Methods

The methods of the BezierShape class are listed below. For a complete list of BezierShape class members, see the BezierShape Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Reverse (inherited from PolygonShape) | Reverses the order of points for this shape.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform (inherited from PolygonShape) | Applies the specified transformation to the shape.

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace


GetBounds Method

Aspose.Imaging Documentation

BezierShape.GetBounds Method

Gets the object's bounds.

Overload List

Gets the object's bounds.

public override RectangleF GetBounds(Matrix);

Gets the object's bounds.

public override RectangleF GetBounds(Matrix,Pen);

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace


BezierShape.GetBounds Method (Matrix)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix
);

Parameters

matrix
The matrix to apply before bounds will be calculated.

Return Value

The estimated object's bounds.

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace | BezierShape.GetBounds Overload List


BezierShape.GetBounds Method (Matrix, Pen)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix,
Pen pen
);

Parameters

matrix
The matrix to apply before bounds will be calculated.
pen
The pen to use for object. This can influence the object's bounds size.

Return Value

The estimated object's bounds.

See Also

BezierShape Class | Aspose.Imaging.Shapes Namespace | BezierShape.GetBounds Overload List


CurveShape Class

Represents a curved spline shape.

For a list of all members of this type, see CurveShape Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Shape
Aspose.Imaging.Shapes.PolygonShape
Aspose.Imaging.Shapes.CurveShape

public sealed class CurveShape : PolygonShape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Shapes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

CurveShape Members | Aspose.Imaging.Shapes Namespace


CurveShape Members

CurveShape overview

Public Instance Constructors

CurveShape Overloaded. Initializes a new instance of the CurveShape class.

Public Instance Properties

Bounds | Gets the object's bounds.
Center | Gets the shape's center.
EndPoint (inherited from PolygonShape) | Gets the ending shape point.
HasSegments (inherited from PolygonShape) | Gets a value indicating whether shape has segments.
IsClosed (inherited from PolygonShape) | Gets or sets a value indicating whether shape is closed.
Points (inherited from PolygonShape) | Gets or sets the curve points.
Segments | Gets the shape segments.
StartPoint (inherited from PolygonShape) | Gets the starting shape point.
Tension | Gets or sets the curve tension.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Reverse (inherited from PolygonShape) | Reverses the order of points for this shape.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform (inherited from PolygonShape) | Applies the specified transformation to the shape.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace


CurveShape Constructor

Initializes a new instance of the CurveShape class.

Overload List

Initializes a new instance of the CurveShape class.

public CurveShape();

Initializes a new instance of the CurveShape class. The default tension of 0.5 is used.

public CurveShape(PointF[]);

Initializes a new instance of the CurveShape class. The default tension of 0.5 is used.

public CurveShape(PointF[],bool);

Initializes a new instance of the CurveShape class.

public CurveShape(PointF[],float);

Initializes a new instance of the CurveShape class.

public CurveShape(PointF[],float,bool);

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace


CurveShape Constructor ()

Initializes a new instance of the CurveShape class.

public CurveShape();

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace | CurveShape Constructor Overload List


CurveShape Constructor (PointF[])

Initializes a new instance of the CurveShape class. The default tension of 0.5 is used.

public CurveShape(
PointF[] points
);

Parameters

points
The points array.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace | CurveShape Constructor Overload List


CurveShape Constructor (PointF[], Boolean)

Initializes a new instance of the CurveShape class. The default tension of 0.5 is used.

public CurveShape(
PointF[] points,
bool isClosed
);

Parameters

points
The points array.
isClosed
if set to true the curve is closed.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace | CurveShape Constructor Overload List


CurveShape Constructor (PointF[], Single)

Initializes a new instance of the CurveShape class.

public CurveShape(
PointF[] points,
float tension
);

Parameters

points
The points array.
tension
The curve tension.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace | CurveShape Constructor Overload List


CurveShape Constructor (PointF[], Single, Boolean)

Initializes a new instance of the CurveShape class.

public CurveShape(
PointF[] points,
float tension,
bool isClosed
);

Parameters

points
The points array.
tension
The curve tension.
isClosed
if set to true the curve is closed.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace | CurveShape Constructor Overload List


CurveShape Properties

The properties of the CurveShape class are listed below. For a complete list of CurveShape class members, see the CurveShape Members topic.

Public Instance Properties

Bounds | Gets the object's bounds.
Center | Gets the shape's center.
EndPoint (inherited from PolygonShape) | Gets the ending shape point.
HasSegments (inherited from PolygonShape) | Gets a value indicating whether shape has segments.
IsClosed (inherited from PolygonShape) | Gets or sets a value indicating whether shape is closed.
Points (inherited from PolygonShape) | Gets or sets the curve points.
Segments | Gets the shape segments.
StartPoint (inherited from PolygonShape) | Gets the starting shape point.
Tension | Gets or sets the curve tension.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace


Bounds Property

Aspose.Imaging Documentation

CurveShape.Bounds Property

Gets the object's bounds.

public override RectangleF Bounds {get;}

Property Value

The object's bounds.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace


Center Property

Aspose.Imaging Documentation

CurveShape.Center Property

Gets the shape's center.

public override PointF Center {get;}

Property Value

The shape's center.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace


Segments Property

Aspose.Imaging Documentation

CurveShape.Segments Property

Gets the shape segments.

public override ShapeSegment[] Segments {get;}

Property Value

The shape segments.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace


Tension Property

Aspose.Imaging Documentation

CurveShape.Tension Property

Gets or sets the curve tension.

public float Tension {get; set;}

Property Value

The curve tension.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace


CurveShape Methods

The methods of the CurveShape class are listed below. For a complete list of CurveShape class members, see the CurveShape Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Reverse (inherited from PolygonShape) | Reverses the order of points for this shape.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform (inherited from PolygonShape) | Applies the specified transformation to the shape.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace


GetBounds Method

Aspose.Imaging Documentation

CurveShape.GetBounds Method

Gets the object's bounds.

Overload List

Gets the object's bounds.

public override RectangleF GetBounds(Matrix);

Gets the object's bounds.

public override RectangleF GetBounds(Matrix,Pen);

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace


CurveShape.GetBounds Method (Matrix)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix
);

Parameters

matrix
The matrix to apply before bounds will be calculated.

Return Value

The estimated object's bounds.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace | CurveShape.GetBounds Overload List


CurveShape.GetBounds Method (Matrix, Pen)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix,
Pen pen
);

Parameters

matrix
The matrix to apply before bounds will be calculated.
pen
The pen to use for object. This can influence the object's bounds size.

Return Value

The estimated object's bounds.

See Also

CurveShape Class | Aspose.Imaging.Shapes Namespace | CurveShape.GetBounds Overload List


EllipseShape Class

Represents an ellipse shape.

For a list of all members of this type, see EllipseShape Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Shape
Aspose.Imaging.Shapes.RectangleProjectedShape
Aspose.Imaging.Shapes.RectangleShape
Aspose.Imaging.Shapes.EllipseShape
Aspose.Imaging.Shapes.PieShape

public class EllipseShape : RectangleShape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example creates a new Image and draws a variety of shapes using Figures and GraphicsPath on the Image surface

[C#]

//Creates an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"c:\temp\output.bmp", false);

//Create an instance of Image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Create and initialize an instance of Graphics class
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clear Graphics surface
    graphics.Clear(Color.Wheat);

    //Create an instance of GraphicsPath class
    Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure1 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure1.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
    figure1.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(110, 110), new Size(200, 200)), 0, 90));

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure2 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure2.AddShape(new Aspose.Imaging.Shapes.ArcShape(new RectangleF(10, 10, 300, 300), 0, 45));
    figure2.AddShape(new Aspose.Imaging.Shapes.PolygonShape(new[] { new PointF(150, 10), new PointF(150, 200), new PointF(250, 300), new PointF(350, 400) }, true));
    figure2.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new Rectangle(new Point(250, 250), new Size(200, 200))));

    //Add Figure object to GraphicsPath
    graphicspath.AddFigures(new[] { figure1, figure2 });

    //Draw path with Pen object of color Black
    graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

    // save all changes.
    image.Save();
}
[Visual Basic]

'Creates an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("c:\temp\output.bmp", False)

'Create an instance of Image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
    graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure1 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure1.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
    figure1.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(110, 110), New Size(200, 200)), 0, 90))

'Create an instance of Figure class
Dim figure2 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure2.AddShape(New Aspose.Imaging.Shapes.ArcShape(New RectangleF(10, 10, 300, 300), 0, 45))
    figure2.AddShape(New Aspose.Imaging.Shapes.PolygonShape(New() { New PointF(150, 10), New PointF(150, 200), New PointF(250, 300), New PointF(350, 400) }, True))
    figure2.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New Rectangle(New Point(250, 250), New Size(200, 200))))

'Add Figure object to GraphicsPath
    graphicspath.AddFigures(New() { figure1, figure2 })

'Draw path with Pen object of color Black
    graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
    image.Save()
End Using

Requirements

Namespace: Aspose.Imaging.Shapes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

EllipseShape Members | Aspose.Imaging.Shapes Namespace


EllipseShape Members

EllipseShape overview

Public Instance Constructors

EllipseShape Overloaded. Initializes a new instance of the EllipseShape class.

Public Instance Properties

Bounds (inherited from RectangleProjectedShape) | Gets the object's bounds.
Center (inherited from RectangleProjectedShape) | Gets the shape's center.
HasSegments (inherited from RectangleProjectedShape) | Gets a value indicating whether shape has segments.
LeftBottom (inherited from RectangleProjectedShape) | Gets the left bottom rectangle point.
LeftTop (inherited from RectangleProjectedShape) | Gets the left top rectangle point.
RectangleHeight (inherited from RectangleProjectedShape) | Gets the rectangle height.
RectangleWidth (inherited from RectangleProjectedShape) | Gets the rectangle width.
RightBottom (inherited from RectangleProjectedShape) | Gets the right bottom rectangle point.
RightTop (inherited from RectangleProjectedShape) | Gets the right top rectangle point.
Segments | Gets the shape segments.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds (inherited from RectangleProjectedShape) | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform (inherited from RectangleProjectedShape) | Applies the specified transformation to the shape.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EllipseShape Class | Aspose.Imaging.Shapes Namespace


EllipseShape Constructor

Initializes a new instance of the EllipseShape class.

Overload List

Initializes a new instance of the EllipseShape class.

public EllipseShape();

Initializes a new instance of the EllipseShape class.

public EllipseShape(RectangleF);

See Also

EllipseShape Class | Aspose.Imaging.Shapes Namespace


EllipseShape Constructor ()

Initializes a new instance of the EllipseShape class.

public EllipseShape();

See Also

EllipseShape Class | Aspose.Imaging.Shapes Namespace | EllipseShape Constructor Overload List


EllipseShape Constructor (RectangleF)

Initializes a new instance of the EllipseShape class.

public EllipseShape(
RectangleF rectangle
);

Parameters

rectangle
The rectangle.

See Also

EllipseShape Class | Aspose.Imaging.Shapes Namespace | EllipseShape Constructor Overload List


EllipseShape Properties

The properties of the EllipseShape class are listed below. For a complete list of EllipseShape class members, see the EllipseShape Members topic.

Public Instance Properties

Bounds (inherited from RectangleProjectedShape) | Gets the object's bounds.
Center (inherited from RectangleProjectedShape) | Gets the shape's center.
HasSegments (inherited from RectangleProjectedShape) | Gets a value indicating whether shape has segments.
LeftBottom (inherited from RectangleProjectedShape) | Gets the left bottom rectangle point.
LeftTop (inherited from RectangleProjectedShape) | Gets the left top rectangle point.
RectangleHeight (inherited from RectangleProjectedShape) | Gets the rectangle height.
RectangleWidth (inherited from RectangleProjectedShape) | Gets the rectangle width.
RightBottom (inherited from RectangleProjectedShape) | Gets the right bottom rectangle point.
RightTop (inherited from RectangleProjectedShape) | Gets the right top rectangle point.
Segments | Gets the shape segments.

See Also

EllipseShape Class | Aspose.Imaging.Shapes Namespace


Segments Property

Aspose.Imaging Documentation

EllipseShape.Segments Property

Gets the shape segments.

public override ShapeSegment[] Segments {get;}

Property Value

The shape segments.

See Also

EllipseShape Class | Aspose.Imaging.Shapes Namespace


PieShape Class

Represents a pie shape.

For a list of all members of this type, see PieShape Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Shape
Aspose.Imaging.Shapes.RectangleProjectedShape
Aspose.Imaging.Shapes.RectangleShape
Aspose.Imaging.Shapes.EllipseShape
Aspose.Imaging.Shapes.PieShape
Aspose.Imaging.Shapes.ArcShape

public class PieShape : EllipseShape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example creates a new Image and draws a variety of shapes using Figures and GraphicsPath on the Image surface

[C#]

//Creates an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"c:\temp\output.bmp", false);

//Create an instance of Image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Create and initialize an instance of Graphics class
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clear Graphics surface
    graphics.Clear(Color.Wheat);

    //Create an instance of GraphicsPath class
    Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure1 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure1.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
    figure1.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(110, 110), new Size(200, 200)), 0, 90));

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure2 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure2.AddShape(new Aspose.Imaging.Shapes.ArcShape(new RectangleF(10, 10, 300, 300), 0, 45));
    figure2.AddShape(new Aspose.Imaging.Shapes.PolygonShape(new[] { new PointF(150, 10), new PointF(150, 200), new PointF(250, 300), new PointF(350, 400) }, true));
    figure2.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new Rectangle(new Point(250, 250), new Size(200, 200))));

    //Add Figure object to GraphicsPath
    graphicspath.AddFigures(new[] { figure1, figure2 });

    //Draw path with Pen object of color Black
    graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

    // save all changes.
    image.Save();
}
[Visual Basic]

'Creates an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("c:\temp\output.bmp", False)

'Create an instance of Image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
    graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure1 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure1.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
    figure1.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(110, 110), New Size(200, 200)), 0, 90))

'Create an instance of Figure class
Dim figure2 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure2.AddShape(New Aspose.Imaging.Shapes.ArcShape(New RectangleF(10, 10, 300, 300), 0, 45))
    figure2.AddShape(New Aspose.Imaging.Shapes.PolygonShape(New() { New PointF(150, 10), New PointF(150, 200), New PointF(250, 300), New PointF(350, 400) }, True))
    figure2.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New Rectangle(New Point(250, 250), New Size(200, 200))))

'Add Figure object to GraphicsPath
    graphicspath.AddFigures(New() { figure1, figure2 })

'Draw path with Pen object of color Black
    graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
    image.Save()
End Using

Requirements

Namespace: Aspose.Imaging.Shapes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PieShape Members | Aspose.Imaging.Shapes Namespace


PieShape Members

PieShape overview

Public Instance Constructors

PieShape Overloaded. Initializes a new instance of the PieShape class.

Public Instance Properties

Bounds (inherited from RectangleProjectedShape) | Gets the object's bounds.
Center (inherited from RectangleProjectedShape) | Gets the shape's center.
HasSegments (inherited from RectangleProjectedShape) | Gets a value indicating whether shape has segments.
LeftBottom (inherited from RectangleProjectedShape) | Gets the left bottom rectangle point.
LeftTop (inherited from RectangleProjectedShape) | Gets the left top rectangle point.
RectangleHeight (inherited from RectangleProjectedShape) | Gets the rectangle height.
RectangleWidth (inherited from RectangleProjectedShape) | Gets the rectangle width.
RightBottom (inherited from RectangleProjectedShape) | Gets the right bottom rectangle point.
RightTop (inherited from RectangleProjectedShape) | Gets the right top rectangle point.
Segments | Gets the shape segments.
StartAngle | Gets or sets the start angle.
SweepAngle | Gets or sets the sweep angle.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds (inherited from RectangleProjectedShape) | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform (inherited from RectangleProjectedShape) | Applies the specified transformation to the shape.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PieShape Class | Aspose.Imaging.Shapes Namespace


PieShape Constructor

Initializes a new instance of the PieShape class.

Overload List

Initializes a new instance of the PieShape class.

public PieShape();

Initializes a new instance of the PieShape class.

public PieShape(RectangleF,float,float);

See Also

PieShape Class | Aspose.Imaging.Shapes Namespace


PieShape Constructor ()

Initializes a new instance of the PieShape class.

public PieShape();

See Also

PieShape Class | Aspose.Imaging.Shapes Namespace | PieShape Constructor Overload List


PieShape Constructor (RectangleF, Single, Single)

Initializes a new instance of the PieShape class.

public PieShape(
RectangleF rectangle,
float startAngle,
float sweepAngle
);

Parameters

rectangle
The rectangle.
startAngle
The start angle.
sweepAngle
The sweep angle.

See Also

PieShape Class | Aspose.Imaging.Shapes Namespace | PieShape Constructor Overload List


PieShape Properties

The properties of the PieShape class are listed below. For a complete list of PieShape class members, see the PieShape Members topic.

Public Instance Properties

Bounds (inherited from RectangleProjectedShape) | Gets the object's bounds.
Center (inherited from RectangleProjectedShape) | Gets the shape's center.
HasSegments (inherited from RectangleProjectedShape) | Gets a value indicating whether shape has segments.
LeftBottom (inherited from RectangleProjectedShape) | Gets the left bottom rectangle point.
LeftTop (inherited from RectangleProjectedShape) | Gets the left top rectangle point.
RectangleHeight (inherited from RectangleProjectedShape) | Gets the rectangle height.
RectangleWidth (inherited from RectangleProjectedShape) | Gets the rectangle width.
RightBottom (inherited from RectangleProjectedShape) | Gets the right bottom rectangle point.
RightTop (inherited from RectangleProjectedShape) | Gets the right top rectangle point.
Segments | Gets the shape segments.
StartAngle | Gets or sets the start angle.
SweepAngle | Gets or sets the sweep angle.

See Also

PieShape Class | Aspose.Imaging.Shapes Namespace


Segments Property

Aspose.Imaging Documentation

PieShape.Segments Property

Gets the shape segments.

public override ShapeSegment[] Segments {get;}

Property Value

The shape segments.

See Also

PieShape Class | Aspose.Imaging.Shapes Namespace


StartAngle Property

Aspose.Imaging Documentation

PieShape.StartAngle Property

Gets or sets the start angle.

public float StartAngle {get; set;}

Property Value

The start angle.

See Also

PieShape Class | Aspose.Imaging.Shapes Namespace


SweepAngle Property

Aspose.Imaging Documentation

PieShape.SweepAngle Property

Gets or sets the sweep angle.

public float SweepAngle {get; set;}

Property Value

The sweep angle.

See Also

PieShape Class | Aspose.Imaging.Shapes Namespace


PolygonShape Class

Represents a polygon shape.

For a list of all members of this type, see PolygonShape Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Shape
Aspose.Imaging.Shapes.PolygonShape
Aspose.Imaging.Shapes.BezierShape
Aspose.Imaging.Shapes.CurveShape

public class PolygonShape : Shape, IOrderedShape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example creates a new Image and draws a variety of shapes using Figures and GraphicsPath on the Image surface

[C#]

//Creates an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"c:\temp\output.bmp", false);

//Create an instance of Image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Create and initialize an instance of Graphics class
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clear Graphics surface
    graphics.Clear(Color.Wheat);

    //Create an instance of GraphicsPath class
    Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure1 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure1.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
    figure1.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(110, 110), new Size(200, 200)), 0, 90));

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure2 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure2.AddShape(new Aspose.Imaging.Shapes.ArcShape(new RectangleF(10, 10, 300, 300), 0, 45));
    figure2.AddShape(new Aspose.Imaging.Shapes.PolygonShape(new[] { new PointF(150, 10), new PointF(150, 200), new PointF(250, 300), new PointF(350, 400) }, true));
    figure2.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new Rectangle(new Point(250, 250), new Size(200, 200))));

    //Add Figure object to GraphicsPath
    graphicspath.AddFigures(new[] { figure1, figure2 });

    //Draw path with Pen object of color Black
    graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

    // save all changes.
    image.Save();
}
[Visual Basic]

'Creates an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("c:\temp\output.bmp", False)

'Create an instance of Image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
    graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure1 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure1.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
    figure1.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(110, 110), New Size(200, 200)), 0, 90))

'Create an instance of Figure class
Dim figure2 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure2.AddShape(New Aspose.Imaging.Shapes.ArcShape(New RectangleF(10, 10, 300, 300), 0, 45))
    figure2.AddShape(New Aspose.Imaging.Shapes.PolygonShape(New() { New PointF(150, 10), New PointF(150, 200), New PointF(250, 300), New PointF(350, 400) }, True))
    figure2.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New Rectangle(New Point(250, 250), New Size(200, 200))))

'Add Figure object to GraphicsPath
    graphicspath.AddFigures(New() { figure1, figure2 })

'Draw path with Pen object of color Black
    graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
    image.Save()
End Using

Requirements

Namespace: Aspose.Imaging.Shapes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

PolygonShape Members | Aspose.Imaging.Shapes Namespace


PolygonShape Members

PolygonShape overview

Public Instance Constructors

PolygonShape Overloaded. Initializes a new instance of the PolygonShape class.

Public Instance Properties

Bounds | Gets the object's bounds.
Center | Gets the shape's center.
EndPoint | Gets the ending shape point.
HasSegments | Gets a value indicating whether shape has segments.
IsClosed | Gets or sets a value indicating whether shape is closed.
Points | Gets or sets the curve points.
Segments | Gets the shape segments.
StartPoint | Gets the starting shape point.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Reverse | Reverses the order of points for this shape.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Applies the specified transformation to the shape.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


PolygonShape Constructor

Initializes a new instance of the PolygonShape class.

Overload List

Initializes a new instance of the PolygonShape class.

public PolygonShape();

Initializes a new instance of the PolygonShape class.

public PolygonShape(PointF[]);

Initializes a new instance of the PolygonShape class.

public PolygonShape(PointF[],bool);

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


PolygonShape Constructor ()

Initializes a new instance of the PolygonShape class.

public PolygonShape();

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace | PolygonShape Constructor Overload List


PolygonShape Constructor (PointF[])

Initializes a new instance of the PolygonShape class.

public PolygonShape(
PointF[] points
);

Parameters

points
The points array.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace | PolygonShape Constructor Overload List


PolygonShape Constructor (PointF[], Boolean)

Initializes a new instance of the PolygonShape class.

public PolygonShape(
PointF[] points,
bool isClosed
);

Parameters

points
The points array.
isClosed
If set to true the polygon is closed.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace | PolygonShape Constructor Overload List


PolygonShape Properties

The properties of the PolygonShape class are listed below. For a complete list of PolygonShape class members, see the PolygonShape Members topic.

Public Instance Properties

Bounds | Gets the object's bounds.
Center | Gets the shape's center.
EndPoint | Gets the ending shape point.
HasSegments | Gets a value indicating whether shape has segments.
IsClosed | Gets or sets a value indicating whether shape is closed.
Points | Gets or sets the curve points.
Segments | Gets the shape segments.
StartPoint | Gets the starting shape point.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


Bounds Property

Aspose.Imaging Documentation

PolygonShape.Bounds Property

Gets the object's bounds.

public override RectangleF Bounds {get;}

Property Value

The object's bounds.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


Center Property

Aspose.Imaging Documentation

PolygonShape.Center Property

Gets the shape's center.

public override PointF Center {get;}

Property Value

The shape's center.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


EndPoint Property

Aspose.Imaging Documentation

PolygonShape.EndPoint Property

Gets the ending shape point.

public virtual PointF EndPoint {get;}

Property Value

The ending shape point.

Implements

IOrderedShape.EndPoint

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


HasSegments Property

Aspose.Imaging Documentation

PolygonShape.HasSegments Property

Gets a value indicating whether shape has segments.

public override bool HasSegments {get;}

Property Value

True if shape has segments; otherwise, false.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


IsClosed Property

Aspose.Imaging Documentation

PolygonShape.IsClosed Property

Gets or sets a value indicating whether shape is closed.

public bool IsClosed {get; set;}

Property Value

true if shape is closed; otherwise, false.

Implements

IOrderedShape.IsClosed

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


Points Property

Aspose.Imaging Documentation

PolygonShape.Points Property

Gets or sets the curve points.

public PointF[] Points {get; set;}

Property Value

The curve points.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


Segments Property

Aspose.Imaging Documentation

PolygonShape.Segments Property

Gets the shape segments.

public override ShapeSegment[] Segments {get;}

Property Value

The shape segments.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


StartPoint Property

Aspose.Imaging Documentation

PolygonShape.StartPoint Property

Gets the starting shape point.

public virtual PointF StartPoint {get;}

Property Value

The starting shape point.

Implements

IOrderedShape.StartPoint

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


PolygonShape Methods

The methods of the PolygonShape class are listed below. For a complete list of PolygonShape class members, see the PolygonShape Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Reverse | Reverses the order of points for this shape.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Applies the specified transformation to the shape.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


GetBounds Method

Aspose.Imaging Documentation

PolygonShape.GetBounds Method

Gets the object's bounds.

Overload List

Gets the object's bounds.

public override RectangleF GetBounds(Matrix);

Gets the object's bounds.

public override RectangleF GetBounds(Matrix,Pen);

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


PolygonShape.GetBounds Method (Matrix)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix
);

Parameters

matrix
The matrix to apply before bounds will be calculated.

Return Value

The estimated object's bounds.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace | PolygonShape.GetBounds Overload List


PolygonShape.GetBounds Method (Matrix, Pen)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix,
Pen pen
);

Parameters

matrix
The matrix to apply before bounds will be calculated.
pen
The pen to use for object. This can influence the object's bounds size.

Return Value

The estimated object's bounds.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace | PolygonShape.GetBounds Overload List


PolygonShape.Reverse Method

Reverses the order of points for this shape.

public void Reverse();

Implements

IOrderedShape.Reverse

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


PolygonShape.Transform Method

Applies the specified transformation to the shape.

public override void Transform(
Matrix transform
);

Parameters

transform
The transformation to apply.

See Also

PolygonShape Class | Aspose.Imaging.Shapes Namespace


RectangleProjectedShape Class

Represents a shape which is projected over rectangle turned to a particular orientation. Specified by four points which can be rotated in space maintaining the same edges length and 90 degrees between adjacent edges.

For a list of all members of this type, see RectangleProjectedShape Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Shape
Aspose.Imaging.Shapes.RectangleProjectedShape
Aspose.Imaging.Shapes.RectangleShape
Aspose.Imaging.Shapes.TextShape

public abstract class RectangleProjectedShape : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Shapes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

RectangleProjectedShape Members | Aspose.Imaging.Shapes Namespace


RectangleProjectedShape Members

RectangleProjectedShape overview

Public Instance Constructors

RectangleProjectedShape Overloaded. Initializes a new instance of the RectangleProjectedShape class.

Public Instance Properties

Bounds | Gets the object's bounds.
Center | Gets the shape's center.
HasSegments | Gets a value indicating whether shape has segments.
LeftBottom | Gets the left bottom rectangle point.
LeftTop | Gets the left top rectangle point.
RectangleHeight | Gets the rectangle height.
RectangleWidth | Gets the rectangle width.
RightBottom | Gets the right bottom rectangle point.
RightTop | Gets the right top rectangle point.
Segments (inherited from Shape) | Gets the shape segments.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Applies the specified transformation to the shape.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


RectangleProjectedShape Constructor

Initializes a new instance of the RectangleProjectedShape class.

Overload List

Initializes a new instance of the RectangleProjectedShape class.

public RectangleProjectedShape();

Initializes a new instance of the RectangleProjectedShape class.

public RectangleProjectedShape(RectangleF);

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


RectangleProjectedShape Constructor ()

Initializes a new instance of the RectangleProjectedShape class.

public RectangleProjectedShape();

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace | RectangleProjectedShape Constructor Overload List


RectangleProjectedShape Constructor (RectangleF)

Initializes a new instance of the RectangleProjectedShape class.

public RectangleProjectedShape(
RectangleF rectangle
);

Parameters

rectangle
The rectangle to initialize from.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace | RectangleProjectedShape Constructor Overload List


RectangleProjectedShape Properties

The properties of the RectangleProjectedShape class are listed below. For a complete list of RectangleProjectedShape class members, see the RectangleProjectedShape Members topic.

Public Instance Properties

Bounds | Gets the object's bounds.
Center | Gets the shape's center.
HasSegments | Gets a value indicating whether shape has segments.
LeftBottom | Gets the left bottom rectangle point.
LeftTop | Gets the left top rectangle point.
RectangleHeight | Gets the rectangle height.
RectangleWidth | Gets the rectangle width.
RightBottom | Gets the right bottom rectangle point.
RightTop | Gets the right top rectangle point.
Segments (inherited from Shape) | Gets the shape segments.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


Bounds Property

Aspose.Imaging Documentation

RectangleProjectedShape.Bounds Property

Gets the object's bounds.

public override RectangleF Bounds {get;}

Property Value

The object's bounds.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


Center Property

Aspose.Imaging Documentation

RectangleProjectedShape.Center Property

Gets the shape's center.

public override PointF Center {get;}

Property Value

The shape's center.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


HasSegments Property

Aspose.Imaging Documentation

RectangleProjectedShape.HasSegments Property

Gets a value indicating whether shape has segments.

public override bool HasSegments {get;}

Property Value

True if shape has segments; otherwise, false.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


LeftBottom Property

Aspose.Imaging Documentation

RectangleProjectedShape.LeftBottom Property

Gets the left bottom rectangle point.

public PointF LeftBottom {get;}

Property Value

The left bottom rectangle point.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


LeftTop Property

Aspose.Imaging Documentation

RectangleProjectedShape.LeftTop Property

Gets the left top rectangle point.

public PointF LeftTop {get;}

Property Value

The left top rectangle point.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


RectangleHeight Property

Aspose.Imaging Documentation

RectangleProjectedShape.RectangleHeight Property

Gets the rectangle height.

public double RectangleHeight {get;}

Property Value

The rectangle height.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


RectangleWidth Property

Aspose.Imaging Documentation

RectangleProjectedShape.RectangleWidth Property

Gets the rectangle width.

public double RectangleWidth {get;}

Property Value

The rectangle width.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


RightBottom Property

Aspose.Imaging Documentation

RectangleProjectedShape.RightBottom Property

Gets the right bottom rectangle point.

public PointF RightBottom {get;}

Property Value

The right bottom rectangle point.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


RightTop Property

Aspose.Imaging Documentation

RectangleProjectedShape.RightTop Property

Gets the right top rectangle point.

public PointF RightTop {get;}

Property Value

The right top rectangle point.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


RectangleProjectedShape Methods

The methods of the RectangleProjectedShape class are listed below. For a complete list of RectangleProjectedShape class members, see the RectangleProjectedShape Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Applies the specified transformation to the shape.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


GetBounds Method

Aspose.Imaging Documentation

RectangleProjectedShape.GetBounds Method

Gets the object's bounds.

Overload List

Gets the object's bounds.

public override RectangleF GetBounds(Matrix);

Gets the object's bounds.

public override RectangleF GetBounds(Matrix,Pen);

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


RectangleProjectedShape.GetBounds Method (Matrix)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix
);

Parameters

matrix
The matrix to apply before bounds will be calculated.

Return Value

The estimated object's bounds.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace | RectangleProjectedShape.GetBounds Overload List


RectangleProjectedShape.GetBounds Method (Matrix, Pen)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix,
Pen pen
);

Parameters

matrix
The matrix to apply before bounds will be calculated.
pen
The pen to use for object. This can influence the object's bounds size.

Return Value

The estimated object's bounds.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace | RectangleProjectedShape.GetBounds Overload List


RectangleProjectedShape.Transform Method

Applies the specified transformation to the shape.

public override void Transform(
Matrix transform
);

Parameters

transform
The transformation to apply.

See Also

RectangleProjectedShape Class | Aspose.Imaging.Shapes Namespace


RectangleShape Class

Represents a rectangular shape.

For a list of all members of this type, see RectangleShape Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Shape
Aspose.Imaging.Shapes.RectangleProjectedShape
Aspose.Imaging.Shapes.RectangleShape
Aspose.Imaging.Shapes.EllipseShape

public class RectangleShape : RectangleProjectedShape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example creates a new Image and draws a variety of shapes using Figures and GraphicsPath on the Image surface

[C#]

//Creates an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"c:\temp\output.bmp", false);

//Create an instance of Image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Create and initialize an instance of Graphics class
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clear Graphics surface
    graphics.Clear(Color.Wheat);

    //Create an instance of GraphicsPath class
    Aspose.Imaging.GraphicsPath graphicspath = new Aspose.Imaging.GraphicsPath();

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure1 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure1.AddShape(new Aspose.Imaging.Shapes.EllipseShape(new RectangleF(50, 50, 300, 300)));
    figure1.AddShape(new Aspose.Imaging.Shapes.PieShape(new Rectangle(new Point(110, 110), new Size(200, 200)), 0, 90));

    //Create an instance of Figure class
    Aspose.Imaging.Figure figure2 = new Aspose.Imaging.Figure();

    //Add Shape to Figure object
    figure2.AddShape(new Aspose.Imaging.Shapes.ArcShape(new RectangleF(10, 10, 300, 300), 0, 45));
    figure2.AddShape(new Aspose.Imaging.Shapes.PolygonShape(new[] { new PointF(150, 10), new PointF(150, 200), new PointF(250, 300), new PointF(350, 400) }, true));
    figure2.AddShape(new Aspose.Imaging.Shapes.RectangleShape(new Rectangle(new Point(250, 250), new Size(200, 200))));

    //Add Figure object to GraphicsPath
    graphicspath.AddFigures(new[] { figure1, figure2 });

    //Draw path with Pen object of color Black
    graphics.DrawPath(new Pen(Aspose.Imaging.Color.Black, 2), graphicspath);

    // save all changes.
    image.Save();
}
[Visual Basic]

'Creates an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("c:\temp\output.bmp", False)

'Create an instance of Image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
    graphics.Clear(Color.Wheat)

'Create an instance of GraphicsPath class
Dim graphicspath As Aspose.Imaging.GraphicsPath = New Aspose.Imaging.GraphicsPath()

'Create an instance of Figure class
Dim figure1 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure1.AddShape(New Aspose.Imaging.Shapes.EllipseShape(New RectangleF(50, 50, 300, 300)))
    figure1.AddShape(New Aspose.Imaging.Shapes.PieShape(New Rectangle(New Point(110, 110), New Size(200, 200)), 0, 90))

'Create an instance of Figure class
Dim figure2 As Aspose.Imaging.Figure = New Aspose.Imaging.Figure()

'Add Shape to Figure object
    figure2.AddShape(New Aspose.Imaging.Shapes.ArcShape(New RectangleF(10, 10, 300, 300), 0, 45))
    figure2.AddShape(New Aspose.Imaging.Shapes.PolygonShape(New() { New PointF(150, 10), New PointF(150, 200), New PointF(250, 300), New PointF(350, 400) }, True))
    figure2.AddShape(New Aspose.Imaging.Shapes.RectangleShape(New Rectangle(New Point(250, 250), New Size(200, 200))))

'Add Figure object to GraphicsPath
    graphicspath.AddFigures(New() { figure1, figure2 })

'Draw path with Pen object of color Black
    graphics.DrawPath(New Pen(Aspose.Imaging.Color.Black, 2), graphicspath)

' save all changes.
    image.Save()
End Using

Requirements

Namespace: Aspose.Imaging.Shapes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

RectangleShape Members | Aspose.Imaging.Shapes Namespace


RectangleShape Members

RectangleShape overview

Public Instance Constructors

RectangleShape Overloaded. Initializes a new instance of the RectangleShape class.

Public Instance Properties

Bounds (inherited from RectangleProjectedShape) | Gets the object's bounds.
Center (inherited from RectangleProjectedShape) | Gets the shape's center.
HasSegments (inherited from RectangleProjectedShape) | Gets a value indicating whether shape has segments.
LeftBottom (inherited from RectangleProjectedShape) | Gets the left bottom rectangle point.
LeftTop (inherited from RectangleProjectedShape) | Gets the left top rectangle point.
RectangleHeight (inherited from RectangleProjectedShape) | Gets the rectangle height.
RectangleWidth (inherited from RectangleProjectedShape) | Gets the rectangle width.
RightBottom (inherited from RectangleProjectedShape) | Gets the right bottom rectangle point.
RightTop (inherited from RectangleProjectedShape) | Gets the right top rectangle point.
Segments | Gets the shape segments.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds (inherited from RectangleProjectedShape) | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform (inherited from RectangleProjectedShape) | Applies the specified transformation to the shape.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RectangleShape Class | Aspose.Imaging.Shapes Namespace


RectangleShape Constructor

Initializes a new instance of the RectangleShape class.

Overload List

Initializes a new instance of the RectangleShape class.

public RectangleShape();

Initializes a new instance of the RectangleShape class.

public RectangleShape(RectangleF);

See Also

RectangleShape Class | Aspose.Imaging.Shapes Namespace


RectangleShape Constructor ()

Initializes a new instance of the RectangleShape class.

public RectangleShape();

See Also

RectangleShape Class | Aspose.Imaging.Shapes Namespace | RectangleShape Constructor Overload List


RectangleShape Constructor (RectangleF)

Initializes a new instance of the RectangleShape class.

public RectangleShape(
RectangleF rectangle
);

Parameters

rectangle
The rectangle.

See Also

RectangleShape Class | Aspose.Imaging.Shapes Namespace | RectangleShape Constructor Overload List


RectangleShape Properties

The properties of the RectangleShape class are listed below. For a complete list of RectangleShape class members, see the RectangleShape Members topic.

Public Instance Properties

Bounds (inherited from RectangleProjectedShape) | Gets the object's bounds.
Center (inherited from RectangleProjectedShape) | Gets the shape's center.
HasSegments (inherited from RectangleProjectedShape) | Gets a value indicating whether shape has segments.
LeftBottom (inherited from RectangleProjectedShape) | Gets the left bottom rectangle point.
LeftTop (inherited from RectangleProjectedShape) | Gets the left top rectangle point.
RectangleHeight (inherited from RectangleProjectedShape) | Gets the rectangle height.
RectangleWidth (inherited from RectangleProjectedShape) | Gets the rectangle width.
RightBottom (inherited from RectangleProjectedShape) | Gets the right bottom rectangle point.
RightTop (inherited from RectangleProjectedShape) | Gets the right top rectangle point.
Segments | Gets the shape segments.

See Also

RectangleShape Class | Aspose.Imaging.Shapes Namespace


Segments Property

Aspose.Imaging Documentation

RectangleShape.Segments Property

Gets the shape segments.

public override ShapeSegment[] Segments {get;}

Property Value

The shape segments.

See Also

RectangleShape Class | Aspose.Imaging.Shapes Namespace


TextShape Class

Represents a text shape.

For a list of all members of this type, see TextShape Members.

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Shape
Aspose.Imaging.Shapes.RectangleProjectedShape
Aspose.Imaging.Shapes.TextShape

public sealed class TextShape : RectangleProjectedShape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Shapes

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

TextShape Members | Aspose.Imaging.Shapes Namespace


TextShape Members

TextShape overview

Public Instance Constructors

TextShape Overloaded. Initializes a new instance of the TextShape class.

Public Instance Properties

Bounds | Gets the object's bounds.
Center | Gets the shape's center.
Font | Gets or sets the font used to draw the text.
HasSegments | Gets a value indicating whether shape has segments.
LeftBottom (inherited from RectangleProjectedShape) | Gets the left bottom rectangle point.
LeftTop (inherited from RectangleProjectedShape) | Gets the left top rectangle point.
RectangleHeight (inherited from RectangleProjectedShape) | Gets the rectangle height.
RectangleWidth (inherited from RectangleProjectedShape) | Gets the rectangle width.
RightBottom (inherited from RectangleProjectedShape) | Gets the right bottom rectangle point.
RightTop (inherited from RectangleProjectedShape) | Gets the right top rectangle point.
Segments | Gets the shape segments.
Text | Gets or sets the drawn text.
TextFormat | Gets or sets the text format.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Applies the specified transformation to the shape.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


TextShape Constructor

Initializes a new instance of the TextShape class.

Overload List

Initializes a new instance of the TextShape class.

public TextShape();

Initializes a new instance of the TextShape class.

public TextShape(string,RectangleF,Font,StringFormat);

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


TextShape Constructor ()

Initializes a new instance of the TextShape class.

public TextShape();

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace | TextShape Constructor Overload List


TextShape Constructor (String, RectangleF, Font, StringFormat)

Initializes a new instance of the TextShape class.

public TextShape(
string text,
RectangleF rectangle,
Font font,
StringFormat stringFormat
);

Parameters

text
The text to draw.
rectangle
The text rectangle.
font
The font to use.
stringFormat
The string format.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace | TextShape Constructor Overload List


TextShape Properties

The properties of the TextShape class are listed below. For a complete list of TextShape class members, see the TextShape Members topic.

Public Instance Properties

Bounds | Gets the object's bounds.
Center | Gets the shape's center.
Font | Gets or sets the font used to draw the text.
HasSegments | Gets a value indicating whether shape has segments.
LeftBottom (inherited from RectangleProjectedShape) | Gets the left bottom rectangle point.
LeftTop (inherited from RectangleProjectedShape) | Gets the left top rectangle point.
RectangleHeight (inherited from RectangleProjectedShape) | Gets the rectangle height.
RectangleWidth (inherited from RectangleProjectedShape) | Gets the rectangle width.
RightBottom (inherited from RectangleProjectedShape) | Gets the right bottom rectangle point.
RightTop (inherited from RectangleProjectedShape) | Gets the right top rectangle point.
Segments | Gets the shape segments.
Text | Gets or sets the drawn text.
TextFormat | Gets or sets the text format.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


Bounds Property

Aspose.Imaging Documentation

TextShape.Bounds Property

Gets the object's bounds.

public override RectangleF Bounds {get;}

Property Value

The object's bounds.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


Center Property

Aspose.Imaging Documentation

TextShape.Center Property

Gets the shape's center.

public override PointF Center {get;}

Property Value

The shape's center.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


Font Property

Aspose.Imaging Documentation

TextShape.Font Property

Gets or sets the font used to draw the text.

public Font Font {get; set;}

Property Value

The font used to draw the text.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


HasSegments Property

Aspose.Imaging Documentation

TextShape.HasSegments Property

Gets a value indicating whether shape has segments.

public override bool HasSegments {get;}

Property Value

True if shape has segments; otherwise, false.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


Segments Property

Aspose.Imaging Documentation

TextShape.Segments Property

Gets the shape segments.

public override ShapeSegment[] Segments {get;}

Property Value

The shape segments.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


Text Property

Aspose.Imaging Documentation

TextShape.Text Property

Gets or sets the drawn text.

public string Text {get; set;}

Property Value

The drawn text.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


TextFormat Property

Aspose.Imaging Documentation

TextShape.TextFormat Property

Gets or sets the text format.

public StringFormat TextFormat {get; set;}

Property Value

The text format.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


TextShape Methods

The methods of the TextShape class are listed below. For a complete list of TextShape class members, see the TextShape Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBounds | Overloaded. Gets the object's bounds.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform | Applies the specified transformation to the shape.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


GetBounds Method

Aspose.Imaging Documentation

TextShape.GetBounds Method

Gets the object's bounds.

Overload List

Gets the object's bounds.

public override RectangleF GetBounds(Matrix);

Gets the object's bounds.

public override RectangleF GetBounds(Matrix,Pen);

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


TextShape.GetBounds Method (Matrix)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix
);

Parameters

matrix
The matrix to apply before bounds will be calculated.

Return Value

The estimated object's bounds.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace | TextShape.GetBounds Overload List


TextShape.GetBounds Method (Matrix, Pen)

Gets the object's bounds.

public override RectangleF GetBounds(
Matrix matrix,
Pen pen
);

Parameters

matrix
The matrix to apply before bounds will be calculated.
pen
The pen to use for object. This can influence the object's bounds size.

Return Value

The estimated object's bounds.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace | TextShape.GetBounds Overload List


TextShape.Transform Method

Applies the specified transformation to the shape.

public override void Transform(
Matrix transform
);

Parameters

transform
The transformation to apply.

See Also

TextShape Class | Aspose.Imaging.Shapes Namespace


Aspose.Imaging.ShapeSegments

Aspose.Imaging Documentation

Aspose.Imaging.ShapeSegments Namespace

Namespace hierarchy

Classes

Class | Description
BezierSegment | The bezier segment going from one point to the next point and using two control points.
LineSegment | Represents a segment leading derectly from a specific point to the next point.


BezierSegment Class

The bezier segment going from one point to the next point and using two control points.

For a list of all members of this type, see BezierSegment Members.

System.Object
Aspose.Imaging.ShapeSegment
Aspose.Imaging.ShapeSegments.LineSegment
Aspose.Imaging.ShapeSegments.BezierSegment

public sealed class BezierSegment : LineSegment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.ShapeSegments

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

BezierSegment Members | Aspose.Imaging.ShapeSegments Namespace


BezierSegment Members

BezierSegment overview

Public Instance Constructors

BezierSegment Constructor Initializes a new instance of the BezierSegment class.

Public Instance Properties

EndPoint (inherited from LineSegment) | Gets the ending point.
FirstControlPoint | Gets the first control point of a bezier spline.
SecondControlPoint | Gets the second control point of a bezier spline.
StartPoint (inherited from LineSegment) | Gets the starting point.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BezierSegment Class | Aspose.Imaging.ShapeSegments Namespace


BezierSegment Constructor

Initializes a new instance of the BezierSegment class.

public BezierSegment(
PointF startPoint,
PointF firstControlPoint,
PointF secondControlPoint,
PointF endPoint
);

Parameters

startPoint
The start point.
firstControlPoint
The first control point.
secondControlPoint
The second control point.
endPoint
The end point.

See Also

BezierSegment Class | Aspose.Imaging.ShapeSegments Namespace


BezierSegment Properties

The properties of the BezierSegment class are listed below. For a complete list of BezierSegment class members, see the BezierSegment Members topic.

Public Instance Properties

EndPoint (inherited from LineSegment) | Gets the ending point.
FirstControlPoint | Gets the first control point of a bezier spline.
SecondControlPoint | Gets the second control point of a bezier spline.
StartPoint (inherited from LineSegment) | Gets the starting point.

See Also

BezierSegment Class | Aspose.Imaging.ShapeSegments Namespace


FirstControlPoint Property

Aspose.Imaging Documentation

BezierSegment.FirstControlPoint Property

Gets the first control point of a bezier spline.

public PointF FirstControlPoint {get;}

Property Value

The first control point.

See Also

BezierSegment Class | Aspose.Imaging.ShapeSegments Namespace


SecondControlPoint Property

Aspose.Imaging Documentation

BezierSegment.SecondControlPoint Property

Gets the second control point of a bezier spline.

public PointF SecondControlPoint {get;}

Property Value

The second control point.

See Also

BezierSegment Class | Aspose.Imaging.ShapeSegments Namespace


LineSegment Class

Represents a segment leading derectly from a specific point to the next point.

For a list of all members of this type, see LineSegment Members.

System.Object
Aspose.Imaging.ShapeSegment
Aspose.Imaging.ShapeSegments.LineSegment
Aspose.Imaging.ShapeSegments.BezierSegment

public class LineSegment : ShapeSegment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.ShapeSegments

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

LineSegment Members | Aspose.Imaging.ShapeSegments Namespace


LineSegment Members

LineSegment overview

Public Instance Constructors

LineSegment Constructor Initializes a new instance of the LineSegment class.

Public Instance Properties

EndPoint | Gets the ending point.
StartPoint | Gets the starting point.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LineSegment Class | Aspose.Imaging.ShapeSegments Namespace


LineSegment Constructor

Initializes a new instance of the LineSegment class.

public LineSegment(
PointF startPoint,
PointF endPoint
);

Parameters

startPoint
The start point.
endPoint
The end point.

See Also

LineSegment Class | Aspose.Imaging.ShapeSegments Namespace


LineSegment Properties

The properties of the LineSegment class are listed below. For a complete list of LineSegment class members, see the LineSegment Members topic.

Public Instance Properties

EndPoint | Gets the ending point.
StartPoint | Gets the starting point.

See Also

LineSegment Class | Aspose.Imaging.ShapeSegments Namespace


EndPoint Property

Aspose.Imaging Documentation

LineSegment.EndPoint Property

Gets the ending point.

public override PointF EndPoint {get;}

Property Value

The ending point.

See Also

LineSegment Class | Aspose.Imaging.ShapeSegments Namespace


StartPoint Property

Aspose.Imaging Documentation

LineSegment.StartPoint Property

Gets the starting point.

public override PointF StartPoint {get;}

Property Value

The starting point.

See Also

LineSegment Class | Aspose.Imaging.ShapeSegments Namespace


Aspose.Imaging.Sources

Aspose.Imaging Documentation

Aspose.Imaging.Sources Namespace

Namespace hierarchy

Classes

Class | Description
FileCreateSource | Represents a file source for creation.
FileOpenSource | Represents a file source for opening.
FileSource | Represents a file source which is capable of files manipulation.
StreamSource | Represents a stream source.


FileCreateSource Class

Represents a file source for creation.

For a list of all members of this type, see FileCreateSource Members.

System.Object
Aspose.Imaging.Source
Aspose.Imaging.Sources.FileSource
Aspose.Imaging.Sources.FileCreateSource

public sealed class FileCreateSource : FileSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example demonstrates the use of Font and SolidBrush class to draw strings on Image surface. The example creates a new Image and draw shapes using Figures and GraphicsPath

[C#]

//Creates an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"C:\temp\sample.bmp", false);

//Creates an instance of Image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //Creates and initialize an instance of Graphics class
    Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

    //Clears Graphics surface
    graphics.Clear(Color.Wheat);

    //Creates an instance of Font
    Aspose.Imaging.Font font = new Aspose.Imaging.Font("Times New Roman", 16);

    //Create an instance of SolidBrush having Red Color
    Aspose.Imaging.Brushes.SolidBrush brush = new Aspose.Imaging.Brushes.SolidBrush(Color.Red);

    //Draw a String
    graphics.DrawString("Created by Aspose.Imaging for .Net", font, brush, new PointF(100, 100));

    // save all changes
    image.Save();
}
[Visual Basic]

'Creates an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("C:\temp\sample.bmp", False)

'Creates an instance of Image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'Creates and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clears Graphics surface
    graphics.Clear(Color.Wheat)

'Creates an instance of Font
Dim font As Aspose.Imaging.Font = New Aspose.Imaging.Font("Times New Roman", 16)

'Create an instance of SolidBrush having Red Color
Dim brush As Aspose.Imaging.Brushes.SolidBrush = New Aspose.Imaging.Brushes.SolidBrush(Color.Red)

'Draw a String
    graphics.DrawString("Created by Aspose.Imaging for .Net", font, brush, New PointF(100, 100))

' save all changes
    image.Save()
End Using

Requirements

Namespace: Aspose.Imaging.Sources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

FileCreateSource Members | Aspose.Imaging.Sources Namespace


FileCreateSource Members

FileCreateSource overview

Public Instance Constructors

FileCreateSource Overloaded. Initializes a new instance of the FileCreateSource class.

Public Instance Properties

FilePath | Gets the file path to create.
IsTemporal | Gets a value indicating whether file will be temporal.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileCreateSource Class | Aspose.Imaging.Sources Namespace


FileCreateSource Constructor

Initializes a new instance of the FileCreateSource class.

Overload List

Initializes a new instance of the FileCreateSource class.

public FileCreateSource(string);

Initializes a new instance of the FileCreateSource class.

public FileCreateSource(string,bool);

See Also

FileCreateSource Class | Aspose.Imaging.Sources Namespace


FileCreateSource Constructor (String)

Initializes a new instance of the FileCreateSource class.

public FileCreateSource(
string filePath
);

Parameters

filePath
The file path to create.

Example

This example creates a new Image file at some disk location as specified by Source property of the BmpOptions instance. If second parameter is not passed to the constructor of FileCreateSource, then by default the file to be created has property IsTemporal set to True. With IsTemporal set to True, no file will be saved on disk at the end of execution.

[C#]

//Creates an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//If second parameter is not passed, then by default the file has IsTemporal set to True
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"C:\temp\output.bmp");

//Creates an instance of Image
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //do some image processing
}
[Visual Basic]

'Creates an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'If second parameter is not passed, then by default the file has IsTemporal set to True
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("C:\temp\output.bmp")

'Creates an instance of Image
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'do some image processing
End Using

See Also

FileCreateSource Class | Aspose.Imaging.Sources Namespace | FileCreateSource Constructor Overload List


FileCreateSource Constructor (String, Boolean)

Initializes a new instance of the FileCreateSource class.

public FileCreateSource(
string filePath,
bool isTemporal
);

Parameters

filePath
The file path to create.
isTemporal
If set to true the created file will be temporal.

Example

This example creates a new Image file at some disk location as specified by Source property of the BmpOptions instance. Several properties for BmpOptions instance are set before creating the actual image. Especially the Source property, that refers to the actual disk location in this case.

[C#]

//Create an instance of BmpOptions and set its various properties
Aspose.Imaging.ImageOptions.BmpOptions bmpOptions = new Aspose.Imaging.ImageOptions.BmpOptions();
bmpOptions.BitsPerPixel = 24;

//Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
//Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = new Aspose.Imaging.Sources.FileCreateSource(@"C:\temp\sample.bmp", false);

//Create an instance of Image and initialize it with instance of BmpOptions by calling Create method
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500))
{
    //do some image processing

    // save all changes
    image.Save();
}
[Visual Basic]

'Create an instance of BmpOptions and set its various properties
Dim bmpOptions As Aspose.Imaging.ImageOptions.BmpOptions = New Aspose.Imaging.ImageOptions.BmpOptions()
bmpOptions.BitsPerPixel = 24

'Create an instance of FileCreateSource and assign it as Source for the instance of BmpOptions
'Second Boolean parameter determines if the file to be created IsTemporal or not
bmpOptions.Source = New Aspose.Imaging.Sources.FileCreateSource("C:\temp\sample.bmp", False)

'Create an instance of Image and initialize it with instance of BmpOptions by calling Create method
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(bmpOptions, 500, 500)
'do some image processing

' save all changes
    image.Save()
End Using

See Also

FileCreateSource Class | Aspose.Imaging.Sources Namespace | FileCreateSource Constructor Overload List


FileCreateSource Properties

The properties of the FileCreateSource class are listed below. For a complete list of FileCreateSource class members, see the FileCreateSource Members topic.

Public Instance Properties

FilePath | Gets the file path to create.
IsTemporal | Gets a value indicating whether file will be temporal.

See Also

FileCreateSource Class | Aspose.Imaging.Sources Namespace


FilePath Property

Aspose.Imaging Documentation

FileCreateSource.FilePath Property

Gets the file path to create.

public string FilePath {get;}

Property Value

The file path to create.

See Also

FileCreateSource Class | Aspose.Imaging.Sources Namespace


IsTemporal Property

Aspose.Imaging Documentation

FileCreateSource.IsTemporal Property

Gets a value indicating whether file will be temporal.

public override bool IsTemporal {get;}

Property Value

true if file will be temporal; otherwise, false.

See Also

FileCreateSource Class | Aspose.Imaging.Sources Namespace


FileOpenSource Class

Represents a file source for opening.

For a list of all members of this type, see FileOpenSource Members.

System.Object
Aspose.Imaging.Source
Aspose.Imaging.Sources.FileSource
Aspose.Imaging.Sources.FileOpenSource

public sealed class FileOpenSource : FileSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Sources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

FileOpenSource Members | Aspose.Imaging.Sources Namespace


FileOpenSource Members

FileOpenSource overview

Public Instance Constructors

FileOpenSource Constructor Initializes a new instance of the FileOpenSource class.

Public Instance Properties

FilePath | Gets the file path to open.
IsTemporal | Gets a value indicating whether file will be temporal.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileOpenSource Class | Aspose.Imaging.Sources Namespace


FileOpenSource Constructor

Initializes a new instance of the FileOpenSource class.

public FileOpenSource(
string filePath
);

Parameters

filePath
The file path to open.

See Also

FileOpenSource Class | Aspose.Imaging.Sources Namespace


FileOpenSource Properties

The properties of the FileOpenSource class are listed below. For a complete list of FileOpenSource class members, see the FileOpenSource Members topic.

Public Instance Properties

FilePath | Gets the file path to open.
IsTemporal | Gets a value indicating whether file will be temporal.

See Also

FileOpenSource Class | Aspose.Imaging.Sources Namespace


FilePath Property

Aspose.Imaging Documentation

FileOpenSource.FilePath Property

Gets the file path to open.

public string FilePath {get;}

Property Value

The file path to open.

See Also

FileOpenSource Class | Aspose.Imaging.Sources Namespace


IsTemporal Property

Aspose.Imaging Documentation

FileOpenSource.IsTemporal Property

Gets a value indicating whether file will be temporal.

public override bool IsTemporal {get;}

Property Value

true if file will be temporal; otherwise, false.

See Also

FileOpenSource Class | Aspose.Imaging.Sources Namespace


FileSource Class

Represents a file source which is capable of files manipulation.

For a list of all members of this type, see FileSource Members.

System.Object
Aspose.Imaging.Source
Aspose.Imaging.Sources.FileSource
Aspose.Imaging.Sources.FileCreateSource
Aspose.Imaging.Sources.FileOpenSource

public abstract class FileSource : Source

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Imaging.Sources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

FileSource Members | Aspose.Imaging.Sources Namespace


FileSource Members

FileSource overview

Public Instance Properties

IsTemporal Gets a value indicating whether file will be temporal.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

FileSource Constructor Initializes a new instance of the FileSource class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileSource Class | Aspose.Imaging.Sources Namespace


FileSource Constructor

Initializes a new instance of the FileSource class.

protected FileSource();

See Also

FileSource Class | Aspose.Imaging.Sources Namespace


FileSource Properties

The properties of the FileSource class are listed below. For a complete list of FileSource class members, see the FileSource Members topic.

Public Instance Properties

IsTemporal Gets a value indicating whether file will be temporal.

See Also

FileSource Class | Aspose.Imaging.Sources Namespace


IsTemporal Property

Aspose.Imaging Documentation

FileSource.IsTemporal Property

Gets a value indicating whether file will be temporal.

public abstract bool IsTemporal {get;}

Property Value

true if file will be temporal; otherwise, false.

See Also

FileSource Class | Aspose.Imaging.Sources Namespace


StreamSource Class

Represents a stream source.

For a list of all members of this type, see StreamSource Members.

System.Object
Aspose.Imaging.Source
Aspose.Imaging.Sources.StreamSource

public sealed class StreamSource : Source

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example uses Graphics class to create primitive shapes on the Image surface. To demonstrate the operation, the example creates a new Image in PNG format and draw primitive shapes on Image surface using Draw methods exposed by Graphics class

[C#]

//Creates an instance of FileStream
using (System.IO.FileStream stream = new System.IO.FileStream(@"C:\temp\output.png", System.IO.FileMode.Create))
{
    //Create an instance of PngOptions and set its various properties
    Aspose.Imaging.ImageOptions.PngOptions pngOptions = new Aspose.Imaging.ImageOptions.PngOptions();

    //Set the Source for PngOptions
    pngOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(pngOptions, 500, 500))
    {
        //Create and initialize an instance of Graphics class
        Aspose.Imaging.Graphics graphics = new Aspose.Imaging.Graphics(image);

        //Clear Graphics surface
        graphics.Clear(Color.Wheat);

        //Draw an Arc by specifying the Pen object having Black color,
        //a Rectangle surrounding the Arc, Start Angle and Sweep Angle
        graphics.DrawArc(new Pen(Color.Black, 2), new Rectangle(200, 200, 100, 200), 0, 300);

        //Draw a Bezier by specifying the Pen object having Blue color and co-ordinate Points.
        graphics.DrawBezier(new Pen(Color.Blue, 2), new Point(250, 100), new Point(300, 30), new Point(450, 100), new Point(235, 25));

        //Draw a Curve by specifying the Pen object having Green color and an array of Points
        graphics.DrawCurve(new Pen(Color.Green, 2), new[] { new Point(100, 200), new Point(100, 350), new Point(200, 450) });

        //Draw an Ellipse using the Pen object and a surrounding Rectangle
        graphics.DrawEllipse(new Pen(Color.Yellow, 2), new Rectangle(300, 300, 100, 100));

        //Draw a Line
        graphics.DrawLine(new Pen(Color.Violet, 2), new Point(100, 100), new Point(200, 200));

        //Draw a Pie segment
        graphics.DrawPie(new Pen(Color.Silver, 2), new Rectangle(new Point(200, 20), new Size(200, 200)), 0, 45);

        //Draw a Polygon by specifying the Pen object having Red color and an array of Points
        graphics.DrawPolygon(new Pen(Color.Red, 2), new[] { new Point(20, 100), new Point(20, 200), new Point(220, 20) });

        //Draw a Rectangle
        graphics.DrawRectangle(new Pen(Color.Orange, 2), new Rectangle(new Point(250, 250), new Size(100, 100)));

        //Create a SolidBrush object and set its various properties
        Aspose.Imaging.Brushes.SolidBrush brush = new Aspose.Imaging.Brushes.SolidBrush();
        brush.Color = Color.Purple;
        brush.Opacity = 100;

        //Draw a String using the SolidBrush object and Font, at specific Point
        graphics.DrawString("This image is created by Aspose.Imaging API", new Font("Times New Roman", 16), brush, new PointF(50, 400));

        // save all changes.
        image.Save();
    }
}
[Visual Basic]

'Creates an instance of FileStream
Using stream As System.IO.FileStream = New System.IO.FileStream("C:\temp\output.png", System.IO.FileMode.Create)
'Create an instance of PngOptions and set its various properties
Dim pngOptions As Aspose.Imaging.ImageOptions.PngOptions = New Aspose.Imaging.ImageOptions.PngOptions()

'Set the Source for PngOptions
    pngOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(pngOptions, 500, 500)
'Create and initialize an instance of Graphics class
Dim graphics As Aspose.Imaging.Graphics = New Aspose.Imaging.Graphics(image)

'Clear Graphics surface
        graphics.Clear(Color.Wheat)

'Draw an Arc by specifying the Pen object having Black color,
'a Rectangle surrounding the Arc, Start Angle and Sweep Angle
        graphics.DrawArc(New Pen(Color.Black, 2), New Rectangle(200, 200, 100, 200), 0, 300)

'Draw a Bezier by specifying the Pen object having Blue color and co-ordinate Points.
        graphics.DrawBezier(New Pen(Color.Blue, 2), New Point(250, 100), New Point(300, 30), New Point(450, 100), New Point(235, 25))

'Draw a Curve by specifying the Pen object having Green color and an array of Points
        graphics.DrawCurve(New Pen(Color.Green, 2), New() { New Point(100, 200), New Point(100, 350), New Point(200, 450) })

'Draw an Ellipse using the Pen object and a surrounding Rectangle
        graphics.DrawEllipse(New Pen(Color.Yellow, 2), New Rectangle(300, 300, 100, 100))

'Draw a Line
        graphics.DrawLine(New Pen(Color.Violet, 2), New Point(100, 100), New Point(200, 200))

'Draw a Pie segment
        graphics.DrawPie(New Pen(Color.Silver, 2), New Rectangle(New Point(200, 20), New Size(200, 200)), 0, 45)

'Draw a Polygon by specifying the Pen object having Red color and an array of Points
        graphics.DrawPolygon(New Pen(Color.Red, 2), New() { New Point(20, 100), New Point(20, 200), New Point(220, 20) })

'Draw a Rectangle
        graphics.DrawRectangle(New Pen(Color.Orange, 2), New Rectangle(New Point(250, 250), New Size(100, 100)))

'Create a SolidBrush object and set its various properties
Dim brush As Aspose.Imaging.Brushes.SolidBrush = New Aspose.Imaging.Brushes.SolidBrush()
        brush.Color = Color.Purple
        brush.Opacity = 100

'Draw a String using the SolidBrush object and Font, at specific Point
        graphics.DrawString("This image is created by Aspose.Imaging API", New Font("Times New Roman", 16), brush, New PointF(50, 400))

' save all changes.
        image.Save()
    End Using
End Using

Requirements

Namespace: Aspose.Imaging.Sources

Assembly: Aspose.Imaging (in Aspose.Imaging.dll)

See Also

StreamSource Members | Aspose.Imaging.Sources Namespace


StreamSource Members

StreamSource overview

Public Instance Constructors

StreamSource Overloaded. Initializes a new instance of the StreamSource class.

Public Instance Properties

DisposeStream | Gets a value indicating whether stream should be disposed whenever container gets disposed.
Stream | Gets the stream.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StreamSource Class | Aspose.Imaging.Sources Namespace


StreamSource Constructor

Initializes a new instance of the StreamSource class.

Overload List

Initializes a new instance of the StreamSource class.

public StreamSource(Stream);

Initializes a new instance of the StreamSource class.

public StreamSource(Stream,bool);

See Also

StreamSource Class | Aspose.Imaging.Sources Namespace


StreamSource Constructor (Stream)

Initializes a new instance of the StreamSource class.

public StreamSource(
Stream stream
);

Parameters

stream
The stream to open.

Example

This example shows how to Loads Pixel information in an Array of Type Color, manipulates the array and set it back to the image. To perform these operations, this example creates a new Image file (in GIF format) uisng MemoryStream object.

[C#]

//Create an instance of MemoryStream
using (System.IO.MemoryStream stream = new System.IO.MemoryStream())
{
    //Create an instance of GifOptions and set its various properties including the Source property
    Aspose.Imaging.ImageOptions.GifOptions gifOptions = new Aspose.Imaging.ImageOptions.GifOptions();
    gifOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream);

    //Create an instance of Image
    using (Aspose.Imaging.RasterImage image = (Aspose.Imaging.RasterImage)Aspose.Imaging.Image.Create(gifOptions, 500, 500))
    {
        //Get the pixels of image by specifying the area as image boundary
        Aspose.Imaging.Color[] pixels = image.LoadPixels(image.Bounds);

        //Loop over the Array and sets color of alrenative indexed pixel
        for (int index = 0; index < pixels.Length; index++)
        {
            if (index % 2 == 0)
            {
                //Set the indexed pixel color to yellow
                pixels[index] = Aspose.Imaging.Color.Yellow;
            }
            else
            {
                //Set the indexed pixel color to blue
                pixels[index] = Aspose.Imaging.Color.Blue;
            }
        }

        //Apply the pixel changes to the image
        image.SavePixels(image.Bounds, pixels);

        // save all changes.
        image.Save();
    }

    //Write MemoryStream to File
    stream.WriteTo(new System.IO.FileStream(@"C:\temp\output.gif", System.IO.FileMode.CreateNew));
}
[Visual Basic]

'Create an instance of MemoryStream
Using stream As System.IO.MemoryStream = New System.IO.MemoryStream()
'Create an instance of GifOptions and set its various properties including the Source property
Dim gifOptions As Aspose.Imaging.ImageOptions.GifOptions = New Aspose.Imaging.ImageOptions.GifOptions()
    gifOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream)

'Create an instance of Image
    Using image As Aspose.Imaging.RasterImage = CType(Aspose.Imaging.Image.Create(gifOptions, 500, 500), Aspose.Imaging.RasterImage)
'Get the pixels of image by specifying the area as image boundary
Dim pixels As Aspose.Imaging.Color() = image.LoadPixels(image.Bounds)

'Loop over the Array and sets color of alrenative indexed pixel
Dim index As Integer = 0
        Do While index < pixels.Length
            If index Mod 2 = 0 Then
'Set the indexed pixel color to yellow
                pixels(index) = Aspose.Imaging.Color.Yellow
            Else
'Set the indexed pixel color to blue
                pixels(index) = Aspose.Imaging.Color.Blue
            End If
            index += 1
        Loop

'Apply the pixel changes to the image
        image.SavePixels(image.Bounds, pixels)

' save all changes.
        image.Save()
    End Using

'Write MemoryStream to File
    stream.WriteTo(New System.IO.FileStream("C:\temp\output.gif", System.IO.FileMode.CreateNew))
End Using

See Also

StreamSource Class | Aspose.Imaging.Sources Namespace | StreamSource Constructor Overload List


StreamSource Constructor (Stream, Boolean)

Initializes a new instance of the StreamSource class.

public StreamSource(
Stream stream,
bool disposeStream
);

Parameters

stream
The stream to open.
disposeStream
if set to true the stream will be disposed.

Example

This example demonstrates the use of System.IO.Stream to Create a new Image file (a JPEG type)

[C#]

//Creates an instance of JpegOptions and set its various properties
Aspose.Imaging.ImageOptions.JpegOptions jpegOptions = new Aspose.Imaging.ImageOptions.JpegOptions();

//Create an instance of System.IO.Stream
System.IO.Stream stream = new System.IO.FileStream(@"C:\temp\sample.jpeg", System.IO.FileMode.Create);

//Define the source property for the instance of JpegOptions
//Second boolean parameter determins if the Stream is disposed once get out of scope
jpegOptions.Source = new Aspose.Imaging.Sources.StreamSource(stream, true);

//Creates an instance of Image and call Create method with JpegOptions as parameter to initialize the Image object
using (Aspose.Imaging.Image image = Aspose.Imaging.Image.Create(jpegOptions, 500, 500))
{
    //do some image processing
}
[Visual Basic]

'Creates an instance of JpegOptions and set its various properties
Dim jpegOptions As Aspose.Imaging.ImageOptions.JpegOptions = New Aspose.Imaging.ImageOptions.JpegOptions()

'Create an instance of System.IO.Stream
Dim stream As System.IO.Stream = New System.IO.FileStream("C:\temp\sample.jpeg", System.IO.FileMode.Create)

'Define the source property for the instance of JpegOptions
'Second boolean parameter determins if the Stream is disposed once get out of scope
jpegOptions.Source = New Aspose.Imaging.Sources.StreamSource(stream, True)

'Creates an instance of Image and call Create method with JpegOptions as parameter to initialize the Image object
Using image As Aspose.Imaging.Image = Aspose.Imaging.Image.Create(jpegOptions, 500, 500)
'do some image processing
End Using

See Also

StreamSource Class | Aspose.Imaging.Sources Namespace | StreamSource Constructor Overload List


StreamSource Properties

The properties of the StreamSource class are listed below. For a complete list of StreamSource class members, see the StreamSource Members topic.

Public Instance Properties

DisposeStream | Gets a value indicating whether stream should be disposed whenever container gets disposed.
Stream | Gets the stream.

See Also

StreamSource Class | Aspose.Imaging.Sources Namespace


DisposeStream Property

Aspose.Imaging Documentation

StreamSource.DisposeStream Property

Gets a value indicating whether stream should be disposed whenever container gets disposed.

public bool DisposeStream {get;}

Property Value

true if stream should be disposed; otherwise, false.

See Also

StreamSource Class | Aspose.Imaging.Sources Namespace


Stream Property

Aspose.Imaging Documentation

StreamSource.Stream Property

Gets the stream.

public Stream Stream {get;}

Property Value

The stream.

See Also

StreamSource Class | Aspose.Imaging.Sources Namespace


Aspose.Imaging.BrushesHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.Brushes Hierarchy

System.Object
Aspose.Imaging.DisposableObject ---- System.IDisposable
Aspose.Imaging.Brush
Aspose.Imaging.Brushes.HatchBrush
Aspose.Imaging.Brushes.SolidBrush
Aspose.Imaging.Brushes.TransformBrush
Aspose.Imaging.Brushes.LinearGradientBrushBase
Aspose.Imaging.Brushes.LinearGradientBrush
Aspose.Imaging.Brushes.LinearMulticolorGradientBrush
Aspose.Imaging.Brushes.PathGradientBrushBase
Aspose.Imaging.Brushes.PathGradientBrush
Aspose.Imaging.Brushes.PathMulticolorGradientBrush
Aspose.Imaging.Brushes.TextureBrush

See Also

Aspose.Imaging.Brushes Namespace


Aspose.Imaging.DitheringHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.Dithering Hierarchy

System.Object
Aspose.Imaging.Dithering.DitheringMode
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.Dithering.DitheringMethod

See Also

Aspose.Imaging.Dithering Namespace


Aspose.Imaging.Exceptions.CompressorsHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.Exceptions.Compressors Hierarchy

System.Object
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Imaging.Exceptions.FrameworkException
Aspose.Imaging.Exceptions.CompressorException
Aspose.Imaging.Exceptions.Compressors.LzwCompressorException
Aspose.Imaging.Exceptions.Compressors.RleCompressorException

See Also

Aspose.Imaging.Exceptions.Compressors Namespace


ImageException Hierarchy

System.Object
Exception
ImageException
ImageCreateException
BmpImageException
CadException
GifImageException
JpegException
PsdImageException
TiffImageException
ImageLoadException
ImageSaveException

See Also

ImageException Class | ImageException Members | Aspose.Imaging.Exceptions Namespace


Aspose.Imaging.Exceptions.ImageFormatsHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.Exceptions.ImageFormats Hierarchy

System.Object
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Imaging.Exceptions.ImageException
Aspose.Imaging.Exceptions.ImageFormats.BmpImageException
Aspose.Imaging.Exceptions.ImageFormats.CadException
Aspose.Imaging.Exceptions.ImageFormats.GifImageException
Aspose.Imaging.Exceptions.ImageFormats.JpegException
Aspose.Imaging.Exceptions.ImageFormats.PsdImageException
Aspose.Imaging.Exceptions.ImageFormats.PsdImageResourceException
Aspose.Imaging.Exceptions.ImageFormats.TiffImageException

See Also

Aspose.Imaging.Exceptions.ImageFormats Namespace


Aspose.Imaging.ExceptionsHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.Exceptions Hierarchy

System.Object
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Imaging.Exceptions.FrameworkException
Aspose.Imaging.Exceptions.CompressorException
Aspose.Imaging.Exceptions.ImageException
Aspose.Imaging.Exceptions.ImageCreateException
Aspose.Imaging.Exceptions.ImageLoadException
Aspose.Imaging.Exceptions.ImageSaveException

See Also

Aspose.Imaging.Exceptions Namespace


Aspose.Imaging.Exif.EnumsHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.Exif.Enums Hierarchy

System.Object
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.Exif.Enums.ExifColorSpace
Aspose.Imaging.Exif.Enums.ExifContrast
Aspose.Imaging.Exif.Enums.ExifCustomRendered
Aspose.Imaging.Exif.Enums.ExifExposureMode
Aspose.Imaging.Exif.Enums.ExifExposureProgram
Aspose.Imaging.Exif.Enums.ExifFileSource
Aspose.Imaging.Exif.Enums.ExifFlash
Aspose.Imaging.Exif.Enums.ExifGainControl
Aspose.Imaging.Exif.Enums.ExifGPSAltitudeRef
Aspose.Imaging.Exif.Enums.ExifLightSource
Aspose.Imaging.Exif.Enums.ExifMeteringMode
Aspose.Imaging.Exif.Enums.ExifOrientation
Aspose.Imaging.Exif.Enums.ExifSaturation
Aspose.Imaging.Exif.Enums.ExifSceneCaptureType
Aspose.Imaging.Exif.Enums.ExifSensingMethod
Aspose.Imaging.Exif.Enums.ExifSubjectDistanceRange
Aspose.Imaging.Exif.Enums.ExifUnit
Aspose.Imaging.Exif.Enums.ExifWhiteBalance
Aspose.Imaging.Exif.Enums.ExifYCbCrPositioning

See Also

Aspose.Imaging.Exif.Enums Namespace


Aspose.Imaging.ExifHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.Exif Hierarchy

System.Object
Aspose.Imaging.Exif.ExifData
Aspose.Imaging.Exif.JpegExifData
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.Exif.ExifProperties

See Also

Aspose.Imaging.Exif Namespace


Aspose.Imaging.ExtensionsHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.Extensions Hierarchy

System.Object
Aspose.Imaging.Extensions.BrushExtensions
Aspose.Imaging.Extensions.ColorBlendExtensions
Aspose.Imaging.Extensions.ColorExtensions
Aspose.Imaging.Extensions.ColorMapExtensions
Aspose.Imaging.Extensions.ColorMatrixExtensions
Aspose.Imaging.Extensions.FileFormatExtensions
Aspose.Imaging.Extensions.FontExtensions
Aspose.Imaging.Extensions.GraphicsPathExtensions
Aspose.Imaging.Extensions.ImageAttributesExtensions
Aspose.Imaging.Extensions.ImageExtensions
Aspose.Imaging.Extensions.MatrixExtensions
Aspose.Imaging.Extensions.PenExtensions
Aspose.Imaging.Extensions.PointExtensions
Aspose.Imaging.Extensions.RectangleExtensions
Aspose.Imaging.Extensions.RegionExtensions
Aspose.Imaging.Extensions.RotateFlipExtensions
Aspose.Imaging.Extensions.StringFormatExtensions

See Also

Aspose.Imaging.Extensions Namespace


Aspose.Imaging.FileFormats.BmpHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Bmp Hierarchy

System.Object
Aspose.Imaging.DisposableObject ---- System.IDisposable
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image ---- Aspose.Imaging.IObjectWithBounds
Aspose.Imaging.RasterImage ---- Aspose.Imaging.IRasterImagePixelLoader, Aspose.Imaging.IRasterImageRawDataLoader
Aspose.Imaging.RasterCachedImage
Aspose.Imaging.FileFormats.Bmp.BmpImage
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.FileFormats.Bmp.BitmapCompression

See Also

Aspose.Imaging.FileFormats.Bmp Namespace


Aspose.Imaging.FileFormats.Cad.CadConstsHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Cad.CadConsts Hierarchy

System.Object
Aspose.Imaging.FileFormats.Cad.CadConsts.CadCommon
Aspose.Imaging.FileFormats.Cad.CadConsts.CadSubClassName
Aspose.Imaging.FileFormats.Cad.CadConsts.CadTableNames
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.FileFormats.Cad.CadConsts.CadAcadVersion
Aspose.Imaging.FileFormats.Cad.CadConsts.CadAttachmentPoint
Aspose.Imaging.FileFormats.Cad.CadConsts.CadAttachmentType
Aspose.Imaging.FileFormats.Cad.CadConsts.CadBoundaryPathTypeFlag
Aspose.Imaging.FileFormats.Cad.CadConsts.CadDimensionType
Aspose.Imaging.FileFormats.Cad.CadConsts.CadDrawingDirection
Aspose.Imaging.FileFormats.Cad.CadConsts.CadEntityCoordinates
Aspose.Imaging.FileFormats.Cad.CadConsts.CadEntitySpaceMode
Aspose.Imaging.FileFormats.Cad.CadConsts.CadEntityTypeName
Aspose.Imaging.FileFormats.Cad.CadConsts.CadFillSetting
Aspose.Imaging.FileFormats.Cad.CadConsts.CadHatchBoundryType
Aspose.Imaging.FileFormats.Cad.CadConsts.CadHeaderAttribute
Aspose.Imaging.FileFormats.Cad.CadConsts.CadHelixLimitation
Aspose.Imaging.FileFormats.Cad.CadConsts.CadHorizontalDirection
Aspose.Imaging.FileFormats.Cad.CadConsts.CadIntegralParamType
Aspose.Imaging.FileFormats.Cad.CadConsts.CadLayoutControlFlag
Aspose.Imaging.FileFormats.Cad.CadConsts.CadLayoutUcsOrthographicType
Aspose.Imaging.FileFormats.Cad.CadConsts.CadLineSpacing
Aspose.Imaging.FileFormats.Cad.CadConsts.CadLineSpacingType
Aspose.Imaging.FileFormats.Cad.CadConsts.CadObjectTypeName
Aspose.Imaging.FileFormats.Cad.CadConsts.CadOrdinate
Aspose.Imaging.FileFormats.Cad.CadConsts.CadParameterType
Aspose.Imaging.FileFormats.Cad.CadConsts.CadPlotLayoutFlag
Aspose.Imaging.FileFormats.Cad.CadConsts.CadPlotPaperUnits
Aspose.Imaging.FileFormats.Cad.CadConsts.CadPlotRotation
Aspose.Imaging.FileFormats.Cad.CadConsts.CadPlotStandardScaleType
Aspose.Imaging.FileFormats.Cad.CadConsts.CadPlotType
Aspose.Imaging.FileFormats.Cad.CadConsts.CadSectionType
Aspose.Imaging.FileFormats.Cad.CadConsts.CadShadePlotMode
Aspose.Imaging.FileFormats.Cad.CadConsts.CadShadePlotResolutionLevel
Aspose.Imaging.FileFormats.Cad.CadConsts.CadShadowMode
Aspose.Imaging.FileFormats.Cad.CadConsts.CadTableSymbols

See Also

Aspose.Imaging.FileFormats.Cad.CadConsts Namespace


CadBaseEntity Hierarchy

System.Object
CadBase
CadBaseOwned
CadBaseEntity
CadAttDef
CadBaseExtrudedEntity
CadCallout
CadCalloutData
CadCalloutLeader
CadHelix
CadMesh
CadProxyEntity
CadRay
CadSectionEntity
CadSeqend
CadSolid
CadSurfaceBase
CadTableEntity
CadVertexBase
CadViewport
CadXLine

See Also

CadBaseEntity Class | CadBaseEntity Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseExtrudedEntity Hierarchy

System.Object
CadBase
CadBaseOwned
CadBaseEntity
CadBaseExtrudedEntity
CadAttrib
CadCircle
CadDimensionBase
CadEllipse
CadHatch
CadInsertObject
CadLine
CadLwPolyline
CadMText
CadMultiLine
CadPoint
CadPolylineBase
CadSpline
CadText

See Also

CadBaseExtrudedEntity Class | CadBaseExtrudedEntity Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadBaseTable Hierarchy

System.Object
CadBase
CadBaseOwned
CadBaseTable
CadAppIdTableObject
CadBlockTableObject
CadDimensionStyleTable
CadLayerTable
CadLineTypeTableObject
CadStyleTableObject

See Also

CadBaseTable Class | CadBaseTable Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadDimensionBase Hierarchy

System.Object
CadBase
CadBaseOwned
CadBaseEntity
CadBaseExtrudedEntity
CadDimensionBase
Cad2LineAngleDimension
CadAlignedDimension
CadAngularDimension
CadDiametricDimension
CadDimensionOrdinate
CadRadialDimension

See Also

CadDimensionBase Class | CadDimensionBase Members | Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


Aspose.Imaging.FileFormats.Cad.CadObjectsHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Cad.CadObjects Hierarchy

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad2DPoint
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad3DPoint
Aspose.Imaging.FileFormats.Cad.CadObjects.CadApplicationCodes
Aspose.Imaging.FileFormats.Cad.CadObjects.CadApplicationCodesContainer
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadAttDef ---- System.ICloneable
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseExtrudedEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadAttrib
Aspose.Imaging.FileFormats.Cad.CadObjects.CadCircle
Aspose.Imaging.FileFormats.Cad.CadObjects.CadArc
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDimensionBase
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad2LineAngleDimension
Aspose.Imaging.FileFormats.Cad.CadObjects.CadAlignedDimension
Aspose.Imaging.FileFormats.Cad.CadObjects.CadRotatedDimension
Aspose.Imaging.FileFormats.Cad.CadObjects.CadAngularDimension
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDiametricDimension
Aspose.Imaging.FileFormats.Cad.CadObjects.CadDimensionOrdinate
Aspose.Imaging.FileFormats.Cad.CadObjects.CadRadialDimension
Aspose.Imaging.FileFormats.Cad.CadObjects.CadEllipse
Aspose.Imaging.FileFormats.Cad.CadObjects.CadHatch
Aspose.Imaging.FileFormats.Cad.CadObjects.CadInsertObject
Aspose.Imaging.FileFormats.Cad.CadObjects.CadLine
Aspose.Imaging.FileFormats.Cad.CadObjects.CadLwPolyline
Aspose.Imaging.FileFormats.Cad.CadObjects.CadMText
Aspose.Imaging.FileFormats.Cad.CadObjects.CadMultiLine
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPoint
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPolylineBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPolyline
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPolyline3D
Aspose.Imaging.FileFormats.Cad.CadObjects.CadSpline
Aspose.Imaging.FileFormats.Cad.CadObjects.CadText
Aspose.Imaging.FileFormats.Cad.CadObjects.CadCallout
Aspose.Imaging.FileFormats.Cad.CadObjects.CadCalloutData
Aspose.Imaging.FileFormats.Cad.CadObjects.CadCalloutLeader
Aspose.Imaging.FileFormats.Cad.CadObjects.CadHelix
Aspose.Imaging.FileFormats.Cad.CadObjects.CadMesh
Aspose.Imaging.FileFormats.Cad.CadObjects.CadProxyEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadRay
Aspose.Imaging.FileFormats.Cad.CadObjects.CadSectionEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadSeqend
Aspose.Imaging.FileFormats.Cad.CadObjects.CadSolid
Aspose.Imaging.FileFormats.Cad.CadObjects.CadSurfaceBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadTableEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadVertexBase
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad2DVertex
Aspose.Imaging.FileFormats.Cad.CadObjects.Cad3DVertex
Aspose.Imaging.FileFormats.Cad.CadObjects.CadViewport
Aspose.Imaging.FileFormats.Cad.CadObjects.CadXLine
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseObject
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPlotSettings
Aspose.Imaging.FileFormats.Cad.CadObjects.CadLayout
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseTable
Aspose.Imaging.FileFormats.Cad.CadObjects.CadCalloutLine
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBlockEntity
Aspose.Imaging.FileFormats.Cad.CadObjects.CadHatchBoundaryPathContainer
Aspose.Imaging.FileFormats.Cad.CadObjects.CadHatchPatternData
Aspose.Imaging.FileFormats.Cad.CadObjects.CadInvisibleObject
Aspose.Imaging.FileFormats.Cad.CadObjects.CadMultiLineVectorBlock
Aspose.Imaging.FileFormats.Cad.CadObjects.CadPolylineBoundaryPath
Aspose.Imaging.FileFormats.Cad.CadObjects.CadSize
Aspose.Imaging.FileFormats.Cad.CadObjects.CadXdata
Aspose.Imaging.FileFormats.Cad.CadObjects.CadXdataContainer

See Also

Aspose.Imaging.FileFormats.Cad.CadObjects Namespace


CadParameter Hierarchy

System.Object
CadParameter
CadBoolParameter
CadDoubleParameter
CadIntParameter
CadLongParameter
CadShortParameter
CadStringParameter

See Also

CadParameter Class | CadParameter Members | Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Aspose.Imaging.FileFormats.Cad.CadParametersHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Cad.CadParameters Hierarchy

System.Object
Aspose.Imaging.FileFormats.Cad.CadParameters.CadParameter
Aspose.Imaging.FileFormats.Cad.CadParameters.CadBoolParameter
Aspose.Imaging.FileFormats.Cad.CadParameters.CadDoubleParameter
Aspose.Imaging.FileFormats.Cad.CadParameters.CadIntParameter
Aspose.Imaging.FileFormats.Cad.CadParameters.CadLongParameter
Aspose.Imaging.FileFormats.Cad.CadParameters.CadShortParameter
Aspose.Imaging.FileFormats.Cad.CadParameters.CadStringParameter

See Also

Aspose.Imaging.FileFormats.Cad.CadParameters Namespace


Aspose.Imaging.FileFormats.Cad.CadTablesHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Cad.CadTables Hierarchy

System.Object
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBase
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseOwned
Aspose.Imaging.FileFormats.Cad.CadObjects.CadBaseTable
Aspose.Imaging.FileFormats.Cad.CadTables.CadAppIdTableObject
Aspose.Imaging.FileFormats.Cad.CadTables.CadBlockTableObject
Aspose.Imaging.FileFormats.Cad.CadTables.CadDimensionStyleTable
Aspose.Imaging.FileFormats.Cad.CadTables.CadLayerTable
Aspose.Imaging.FileFormats.Cad.CadTables.CadLineTypeTableObject
Aspose.Imaging.FileFormats.Cad.CadTables.CadStyleTableObject

See Also

Aspose.Imaging.FileFormats.Cad.CadTables Namespace


Aspose.Imaging.FileFormats.CadHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Cad Hierarchy

System.Object
Aspose.Imaging.DisposableObject ---- System.IDisposable
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image ---- Aspose.Imaging.IObjectWithBounds
Aspose.Imaging.FileFormats.Cad.CadImage
Aspose.Imaging.FileFormats.Cad.CadAciColor
Aspose.Imaging.FileFormats.Cad.CadCodeValue
System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadObjects.CadBlockEntity, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]] ---- System.Collections.Generic.ICollection`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadObjects.CadBlockEntity, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.Generic.IDictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadObjects.CadBlockEntity, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadObjects.CadBlockEntity, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable, System.Runtime.Serialization.IDeserializationCallback, System.Runtime.Serialization.ISerializable
Aspose.Imaging.FileFormats.Cad.CadBlockDictionary ---- System.ICloneable
System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadObjects.CadLayout, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]] ---- System.Collections.Generic.ICollection`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadObjects.CadLayout, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.Generic.IDictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadObjects.CadLayout, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadObjects.CadLayout, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable, System.Runtime.Serialization.IDeserializationCallback, System.Runtime.Serialization.ISerializable
Aspose.Imaging.FileFormats.Cad.CadLayoutDictionary ---- System.ICloneable
System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadDimensionStyleTable, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]] ---- System.Collections.Generic.ICollection`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadDimensionStyleTable, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.Generic.IDictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadDimensionStyleTable, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadDimensionStyleTable, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable, System.Runtime.Serialization.IDeserializationCallback, System.Runtime.Serialization.ISerializable
Aspose.Imaging.FileFormats.Cad.CadDimensionDictionary ---- System.ICloneable
System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadLayerTable, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]] ---- System.Collections.Generic.ICollection`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadLayerTable, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.Generic.IDictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadLayerTable, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadLayerTable, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable, System.Runtime.Serialization.IDeserializationCallback, System.Runtime.Serialization.ISerializable
Aspose.Imaging.FileFormats.Cad.CadLayersDictionary ---- System.ICloneable
System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadLineTypeTableObject, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]] ---- System.Collections.Generic.ICollection`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadLineTypeTableObject, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.Generic.IDictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadLineTypeTableObject, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadLineTypeTableObject, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable, System.Runtime.Serialization.IDeserializationCallback, System.Runtime.Serialization.ISerializable
Aspose.Imaging.FileFormats.Cad.CadLineTypesDictionary ---- System.ICloneable
System.Collections.Generic.Dictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadStyleTableObject, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]] ---- System.Collections.Generic.ICollection`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadStyleTableObject, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.Generic.IDictionary`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadStyleTableObject, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Imaging.FileFormats.Cad.CadTables.CadStyleTableObject, Aspose.Imaging, Version=2.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable, System.Runtime.Serialization.IDeserializationCallback, System.Runtime.Serialization.ISerializable
Aspose.Imaging.FileFormats.Cad.CadStylesDictionary ---- System.ICloneable
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.FileFormats.Cad.CadDrawTypeMode
Aspose.Imaging.FileFormats.Cad.CadEntityAttribute
Aspose.Imaging.FileFormats.Cad.ScaleType

See Also

Aspose.Imaging.FileFormats.Cad Namespace


Aspose.Imaging.FileFormats.Gif.BlocksHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Gif.Blocks Hierarchy

System.Object
Aspose.Imaging.DisposableObject ---- System.IDisposable
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image ---- Aspose.Imaging.IObjectWithBounds
Aspose.Imaging.RasterImage ---- Aspose.Imaging.IRasterImagePixelLoader, Aspose.Imaging.IRasterImageRawDataLoader
Aspose.Imaging.RasterCachedImage
Aspose.Imaging.FileFormats.Gif.Blocks.GifFrameBlock ---- Aspose.Imaging.FileFormats.Gif.IGifBlock
Aspose.Imaging.FileFormats.Gif.GifBlock ---- Aspose.Imaging.FileFormats.Gif.IGifBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifApplicationExtensionBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifCommentBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifGraphicsControlBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifPlainTextRenderingBlock
Aspose.Imaging.FileFormats.Gif.Blocks.GifUnknownExtensionBlock

See Also

Aspose.Imaging.FileFormats.Gif.Blocks Namespace


Aspose.Imaging.FileFormats.GifHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Gif Hierarchy

System.Object
Aspose.Imaging.DisposableObject ---- System.IDisposable
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image ---- Aspose.Imaging.IObjectWithBounds
Aspose.Imaging.RasterImage ---- Aspose.Imaging.IRasterImagePixelLoader, Aspose.Imaging.IRasterImageRawDataLoader
Aspose.Imaging.FileFormats.Gif.GifImage
Aspose.Imaging.FileFormats.Gif.GifBlock ---- Aspose.Imaging.FileFormats.Gif.IGifBlock
Aspose.Imaging.FileFormats.Gif.GifBlocksRegistry
Aspose.Imaging.FileFormats.Gif.IGifBlock
Aspose.Imaging.FileFormats.Gif.IGifBlockLoaderDescriptor
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.FileFormats.Gif.DisposalMethod

See Also

Aspose.Imaging.FileFormats.Gif Namespace


Aspose.Imaging.FileFormats.JpegHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Jpeg Hierarchy

System.Object
Aspose.Imaging.DisposableObject ---- System.IDisposable
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image ---- Aspose.Imaging.IObjectWithBounds
Aspose.Imaging.RasterImage ---- Aspose.Imaging.IRasterImagePixelLoader, Aspose.Imaging.IRasterImageRawDataLoader
Aspose.Imaging.RasterCachedImage
Aspose.Imaging.FileFormats.Jpeg.JpegImage
Aspose.Imaging.FileFormats.Jpeg.JFIFData
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.FileFormats.Jpeg.JfifDensityUnits
Aspose.Imaging.FileFormats.Jpeg.JpegCompressionColorMode
Aspose.Imaging.FileFormats.Jpeg.JpegCompressionMode

See Also

Aspose.Imaging.FileFormats.Jpeg Namespace


Aspose.Imaging.FileFormats.PdfHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Pdf Hierarchy

System.Object
Aspose.Imaging.FileFormats.Pdf.PdfDocumentInfo

See Also

Aspose.Imaging.FileFormats.Pdf Namespace


Aspose.Imaging.FileFormats.PngHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Png Hierarchy

System.Object
Aspose.Imaging.DisposableObject ---- System.IDisposable
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image ---- Aspose.Imaging.IObjectWithBounds
Aspose.Imaging.RasterImage ---- Aspose.Imaging.IRasterImagePixelLoader, Aspose.Imaging.IRasterImageRawDataLoader
Aspose.Imaging.FileFormats.Png.PngImage

See Also

Aspose.Imaging.FileFormats.Png Namespace


OSTypeStructure Hierarchy

System.Object
OSTypeStructure
AliasStructure
BooleanStructure
ClassStructure
DoubleStructure
EnumeratedDescriptorStructure
IntegerStructure
ListStructure
OffsetStructure
PropertyStructure
RawDataStructure
ReferenceStructure
StringStructure
UnitStructure
UnknownStructure

See Also

OSTypeStructure Class | OSTypeStructure Members | Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructuresHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Hierarchy

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.AliasStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.BooleanStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.ClassStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.DoubleStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.EnumeratedDescriptorStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.EnumeratedReferenceStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.IntegerStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.ListStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.OffsetStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.PropertyStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.RawDataStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.ReferenceStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.StringStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.UnitStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.UnknownStructure
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures.UnitTypes

See Also

Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfoStructures Namespace


Aspose.Imaging.FileFormats.Psd.Layers.LayerResourcesHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Hierarchy

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.LayerResource
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolInfo6Resource
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.UnknownResource
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.ClassID
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.IOSTypeStructureLoader
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructure
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.OSTypeStructuresRegistry
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolFontInfo
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolLineInfo
Aspose.Imaging.FileFormats.Psd.Layers.LayerResources.TypeToolStyleInfo

See Also

Aspose.Imaging.FileFormats.Psd.Layers.LayerResources Namespace


Aspose.Imaging.FileFormats.Psd.LayersHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Psd.Layers Hierarchy

System.Object
Aspose.Imaging.FileFormats.Psd.Layers.BlendRange
Aspose.Imaging.FileFormats.Psd.Layers.ChannelInformation
Aspose.Imaging.FileFormats.Psd.Layers.GlobalLayerMaskInfo
Aspose.Imaging.FileFormats.Psd.Layers.ILayerResourceLoader
Aspose.Imaging.FileFormats.Psd.Layers.Layer
Aspose.Imaging.FileFormats.Psd.Layers.LayerBlendingRangesData
Aspose.Imaging.FileFormats.Psd.Layers.LayerMaskData
Aspose.Imaging.FileFormats.Psd.Layers.LayerMaskDataFull
Aspose.Imaging.FileFormats.Psd.Layers.LayerMaskDataShort
Aspose.Imaging.FileFormats.Psd.Layers.LayerResource
Aspose.Imaging.FileFormats.Psd.Layers.LayerResourcesRegistry
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.FileFormats.Psd.Layers.BlendMode
Aspose.Imaging.FileFormats.Psd.Layers.LayerMaskFlags

See Also

Aspose.Imaging.FileFormats.Psd.Layers Namespace


Aspose.Imaging.FileFormats.Psd.ResourcesHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Psd.Resources Hierarchy

System.Object
Aspose.Imaging.FileFormats.Psd.ResourceBlock
Aspose.Imaging.FileFormats.Psd.Resources.GridAndGuidesResouce
Aspose.Imaging.FileFormats.Psd.Resources.ThumbnailResource
Aspose.Imaging.FileFormats.Psd.Resources.Thumbnail4Resource
Aspose.Imaging.FileFormats.Psd.Resources.TransparencyIndexResource
Aspose.Imaging.FileFormats.Psd.Resources.UnknownResource
Aspose.Imaging.FileFormats.Psd.Resources.GuideResource
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.FileFormats.Psd.Resources.GuideDirection
Aspose.Imaging.FileFormats.Psd.Resources.ThumbnailFormat

See Also

Aspose.Imaging.FileFormats.Psd.Resources Namespace


Aspose.Imaging.FileFormats.PsdHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Psd Hierarchy

System.Object
Aspose.Imaging.DisposableObject ---- System.IDisposable
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image ---- Aspose.Imaging.IObjectWithBounds
Aspose.Imaging.RasterImage ---- Aspose.Imaging.IRasterImagePixelLoader, Aspose.Imaging.IRasterImageRawDataLoader
Aspose.Imaging.RasterCachedImage
Aspose.Imaging.FileFormats.Psd.PsdImage
Aspose.Imaging.FileFormats.Psd.PsdColorPalette ---- Aspose.Imaging.IColorPalette, Aspose.Imaging.IPsdColorPalette
Aspose.Imaging.FileFormats.Psd.ResourceBlock
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.FileFormats.Psd.ColorModes
Aspose.Imaging.FileFormats.Psd.CompressionMethod

See Also

Aspose.Imaging.FileFormats.Psd Namespace


Aspose.Imaging.FileFormats.Tiff.EnumsHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Tiff.Enums Hierarchy

System.Object
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.FileFormats.Tiff.Enums.Group3Options
Aspose.Imaging.FileFormats.Tiff.Enums.TiffAlphaStorage
Aspose.Imaging.FileFormats.Tiff.Enums.TiffByteOrder
Aspose.Imaging.FileFormats.Tiff.Enums.TiffCompressions
Aspose.Imaging.FileFormats.Tiff.Enums.TiffDataTypes
Aspose.Imaging.FileFormats.Tiff.Enums.TiffFillOrders
Aspose.Imaging.FileFormats.Tiff.Enums.TiffNewSubFileTypes
Aspose.Imaging.FileFormats.Tiff.Enums.TiffOrientations
Aspose.Imaging.FileFormats.Tiff.Enums.TiffPhotometrics
Aspose.Imaging.FileFormats.Tiff.Enums.TiffPlanarConfigs
Aspose.Imaging.FileFormats.Tiff.Enums.TiffPredictor
Aspose.Imaging.FileFormats.Tiff.Enums.TiffResolutionUnits
Aspose.Imaging.FileFormats.Tiff.Enums.TiffSampleFormats
Aspose.Imaging.FileFormats.Tiff.Enums.TiffTags
Aspose.Imaging.FileFormats.Tiff.Enums.TiffThresholds

See Also

Aspose.Imaging.FileFormats.Tiff.Enums Namespace


Aspose.Imaging.FileFormats.Tiff.FileManagementHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Tiff.FileManagement Hierarchy

System.Object
Aspose.Imaging.DisposableObject ---- System.IDisposable
Aspose.Imaging.StreamContainer
Aspose.Imaging.FileFormats.Tiff.FileManagement.TiffStream
Aspose.Imaging.FileFormats.Tiff.FileManagement.TiffBigEndianStream

See Also

Aspose.Imaging.FileFormats.Tiff.FileManagement Namespace


Aspose.Imaging.FileFormats.Tiff.InstanceFactoryHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Tiff.InstanceFactory Hierarchy

System.Object
Aspose.Imaging.FileFormats.Tiff.InstanceFactory.ITiffTagCreator
Aspose.Imaging.FileFormats.Tiff.InstanceFactory.TiffTagFactory

See Also

Aspose.Imaging.FileFormats.Tiff.InstanceFactory Namespace


TiffCommonArrayType Hierarchy

System.Object
TiffDataType
TiffCommonArrayType
TiffByteType
TiffDoubleType
TiffFloatType
TiffLongType
TiffRationalType
TiffSByteType
TiffShortType
TiffSLongType
TiffSRationalType
TiffSShortType

See Also

TiffCommonArrayType Class | TiffCommonArrayType Members | Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Aspose.Imaging.FileFormats.Tiff.TiffTagTypesHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Hierarchy

System.Object
Aspose.Imaging.FileFormats.Tiff.TiffDataType ---- System.IComparable
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffASCIIType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffCommonArrayType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffByteType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffDoubleType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffFloatType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffLongType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffRationalType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffSByteType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffShortType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffSLongType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffSRationalType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffSShortType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffUndefinedType
Aspose.Imaging.FileFormats.Tiff.TiffTagTypes.TiffUnknownType

See Also

Aspose.Imaging.FileFormats.Tiff.TiffTagTypes Namespace


Aspose.Imaging.FileFormats.TiffHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.FileFormats.Tiff Hierarchy

System.Object
Aspose.Imaging.DisposableObject ---- System.IDisposable
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image ---- Aspose.Imaging.IObjectWithBounds
Aspose.Imaging.RasterImage ---- Aspose.Imaging.IRasterImagePixelLoader, Aspose.Imaging.IRasterImageRawDataLoader
Aspose.Imaging.FileFormats.Tiff.TiffImage
Aspose.Imaging.RasterCachedImage
Aspose.Imaging.FileFormats.Tiff.TiffFrame
Aspose.Imaging.FileFormats.Tiff.TiffDataType ---- System.IComparable
Aspose.Imaging.FileFormats.Tiff.TiffRational
Aspose.Imaging.FileFormats.Tiff.TiffSRational

See Also

Aspose.Imaging.FileFormats.Tiff Namespace


Aspose.Imaging.ImageLoadOptionsHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.ImageLoadOptions Hierarchy

System.Object
Aspose.Imaging.LoadOptions
Aspose.Imaging.ImageLoadOptions.JpegLoadOptions

See Also

Aspose.Imaging.ImageLoadOptions Namespace


ImageOptionsBase Hierarchy

System.Object
ImageOptionsBase
BmpOptions
GifOptions
JpegOptions
PdfOptions
PngOptions
PsdOptions
TiffOptions

See Also

ImageOptionsBase Class | ImageOptionsBase Members | Aspose.Imaging Namespace


Aspose.Imaging.ImageOptionsHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.ImageOptions Hierarchy

System.Object
Aspose.Imaging.ImageOptionsBase
Aspose.Imaging.ImageOptions.BmpOptions
Aspose.Imaging.ImageOptions.GifOptions
Aspose.Imaging.ImageOptions.JpegOptions
Aspose.Imaging.ImageOptions.PdfOptions
Aspose.Imaging.ImageOptions.PngOptions
Aspose.Imaging.ImageOptions.PsdOptions
Aspose.Imaging.ImageOptions.TiffOptions
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.ImageOptions.TiffOptionsError

See Also

Aspose.Imaging.ImageOptions Namespace


Aspose.Imaging.ShapeSegmentsHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.ShapeSegments Hierarchy

System.Object
Aspose.Imaging.ShapeSegment
Aspose.Imaging.ShapeSegments.LineSegment
Aspose.Imaging.ShapeSegments.BezierSegment

See Also

Aspose.Imaging.ShapeSegments Namespace


Aspose.Imaging.ShapesHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.Shapes Hierarchy

System.Object
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Shape
Aspose.Imaging.Shapes.PolygonShape ---- Aspose.Imaging.IOrderedShape
Aspose.Imaging.Shapes.BezierShape
Aspose.Imaging.Shapes.CurveShape
Aspose.Imaging.Shapes.RectangleProjectedShape
Aspose.Imaging.Shapes.RectangleShape
Aspose.Imaging.Shapes.EllipseShape
Aspose.Imaging.Shapes.PieShape
Aspose.Imaging.Shapes.ArcShape ---- Aspose.Imaging.IOrderedShape
Aspose.Imaging.Shapes.TextShape

See Also

Aspose.Imaging.Shapes Namespace


Aspose.Imaging.SourcesHierarchy

Aspose.Imaging Documentation

Aspose.Imaging.Sources Hierarchy

System.Object
Aspose.Imaging.Source
Aspose.Imaging.Sources.FileSource
Aspose.Imaging.Sources.FileCreateSource
Aspose.Imaging.Sources.FileOpenSource
Aspose.Imaging.Sources.StreamSource

See Also

Aspose.Imaging.Sources Namespace


Aspose.ImagingHierarchy

Aspose.Imaging Documentation

Aspose.Imaging Hierarchy

System.Object
Aspose.Imaging.Blend
Aspose.Imaging.BuildVersionInfo
Aspose.Imaging.Cache
Aspose.Imaging.ColorBlend
Aspose.Imaging.ColorMap
Aspose.Imaging.ColorMatrix
Aspose.Imaging.ColorPalette ---- Aspose.Imaging.IColorPalette
Aspose.Imaging.ColorTranslator
Aspose.Imaging.CustomLineCap
Aspose.Imaging.DisposableObject ---- System.IDisposable
Aspose.Imaging.Brush
Aspose.Imaging.DataStreamSupporter
Aspose.Imaging.Image ---- Aspose.Imaging.IObjectWithBounds
Aspose.Imaging.RasterImage ---- Aspose.Imaging.IRasterImagePixelLoader, Aspose.Imaging.IRasterImageRawDataLoader
Aspose.Imaging.RasterCachedImage
Aspose.Imaging.StreamContainer
Aspose.Imaging.FileStreamContainer
Aspose.Imaging.StringFormat
Aspose.Imaging.Font
Aspose.Imaging.Graphics
Aspose.Imaging.IAdvancedBufferProcessor ---- Aspose.Imaging.IBufferProcessor
Aspose.Imaging.IBufferProcessor
Aspose.Imaging.IColorConverter
Aspose.Imaging.IColorPalette
Aspose.Imaging.IImageCreator
Aspose.Imaging.IImageCreatorDescriptor ---- Aspose.Imaging.IImageDescriptor
Aspose.Imaging.IImageDescriptor
Aspose.Imaging.IImageExporter
Aspose.Imaging.IImageExporterDescriptor ---- Aspose.Imaging.IImageDescriptor
Aspose.Imaging.IImageLoader
Aspose.Imaging.IImageLoaderDescriptor ---- Aspose.Imaging.IImageDescriptor
Aspose.Imaging.IIndexedColorConverter
Aspose.Imaging.IKeyedObject
Aspose.Imaging.ImageAttributes
Aspose.Imaging.ImageCreatorsRegistry
Aspose.Imaging.ImageExportersRegistry
Aspose.Imaging.ImageLoadersRegistry
Aspose.Imaging.ImageOptionsBase
Aspose.Imaging.IObjectWithBounds
Aspose.Imaging.IOrderedShape
Aspose.Imaging.IPartialCMYKPixelLoader ---- Aspose.Imaging.IPartialPixelLoader
Aspose.Imaging.IPartialPixelLoader
Aspose.Imaging.IPartialRawDataLoader
Aspose.Imaging.IPsdColorPalette ---- Aspose.Imaging.IColorPalette
Aspose.Imaging.IRasterImagePixelLoader ---- Aspose.Imaging.IRasterImageRawDataLoader
Aspose.Imaging.IRasterImageRawDataLoader
Aspose.Imaging.License
Aspose.Imaging.LoadOptions
Aspose.Imaging.Matrix
Aspose.Imaging.ObjectWithBounds
Aspose.Imaging.Figure
Aspose.Imaging.GraphicsPath
Aspose.Imaging.Shape
Aspose.Imaging.Pens
Aspose.Imaging.PixelDataFormat
Aspose.Imaging.RawDataSettings
Aspose.Imaging.Region
Aspose.Imaging.ShapeSegment
Aspose.Imaging.Source
Aspose.Imaging.TransparencySupporter
Aspose.Imaging.Pen
System.ValueType
Aspose.Imaging.CMYKColor
Aspose.Imaging.Color
Aspose.Imaging.Point
Aspose.Imaging.PointF
Aspose.Imaging.Rectangle
Aspose.Imaging.RectangleF
Aspose.Imaging.Size
Aspose.Imaging.SizeF
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Imaging.CacheType
Aspose.Imaging.CharacterSet
Aspose.Imaging.ColorAdjustType
Aspose.Imaging.ColorChannelFlag
Aspose.Imaging.ColorMatrixFlag
Aspose.Imaging.CompositingQuality
Aspose.Imaging.DashCap
Aspose.Imaging.DashStyle
Aspose.Imaging.DataRecoveryMode
Aspose.Imaging.DitheringMethods
Aspose.Imaging.FileFormat
Aspose.Imaging.FillMode
Aspose.Imaging.FontStyle
Aspose.Imaging.GraphicsUnit
Aspose.Imaging.HatchStyle
Aspose.Imaging.HotkeyPrefix
Aspose.Imaging.InterpolationMode
Aspose.Imaging.KnownColor
Aspose.Imaging.LineCap
Aspose.Imaging.LineJoin
Aspose.Imaging.MatrixOrder
Aspose.Imaging.PenAlignment
Aspose.Imaging.PenType
Aspose.Imaging.PixelFormat
Aspose.Imaging.ResizeType
Aspose.Imaging.RotateFlipType
Aspose.Imaging.SmoothingMode
Aspose.Imaging.StringAlignment
Aspose.Imaging.StringDigitSubstitute
Aspose.Imaging.StringFormatFlags
Aspose.Imaging.StringTrimming
Aspose.Imaging.TextRenderingHint
Aspose.Imaging.WarpMode
Aspose.Imaging.WrapMode

See Also

Aspose.Imaging Namespace