Aspose.Slides for .NET API Reference

The Aspose.Slides class library provides the following namespaces:

Aspose.Slides
Contains classes for work with Microsoft PowerPoint presentations without utilizing Microsoft PowerPoint.

We guarantee a prompt response to any inquiry!

© 2003-2013 Aspose Pty Ltd. All rights reserved.


Aspose.Slides

Aspose.Slides Documentation

Aspose.Slides Namespace

Namespace hierarchy

Classes

Class | Description
AdjustValue | Represents a geometry shape's adjustment value. These values affect shape's form.
AdjustValueCollection | Reprasents a collection of shape's adjustments.
Audio | Represents an embedded audio file.
AudioCollection | Represents a collection of embedded audio files.
AudioFrame | Represents an audio clip on a slide.
AutoShape | Represents an AutoShape.
AutoShapeLock | Determines which operations are disabled on the parent AutoshapeEx.
Backdrop3DScene | Defines a plane in which effects, such as glow and shadow, are applied in relation to the shape they are being applied to
Background | Represents background of a slide.
BaseShapeLock | Represents a base class for locks (disabled operation).
BaseSlide | Represents common data for all slide types.
BuildVersionInfo | Contains information about version of Aspose.Slides.
BulletFormat |
BulletFormatEffectiveData | Immutable object which contains the paragraph's formatting properties.
Camera | Represents Camera.
Cell | Represents a cell of a table.
CellCollection | Represents a collection of cells.
ColorFormat | Represents a color used in a presentation.
ColorOperation | Represents different color operations used for color transformations.
ColorOperationCollection | Represents a collection of color transform operations.
Column | Represents a column in a table.
ColumnCollection | Represents collection of columns in a table.
Comment | Represents a comment on a slide.
CommentAuthor | Represents an author of comments.
CommentAuthorCollection | Represents a collection of comment authors.
CommentCollection | Represents a collection of comments of one author.
Connector | Represents a connector.
ConnectorLock | Determines which operations are disabled on the parent Connector.
Control | Represents an ActiveX control.
ControlCollection | A collection of ActiveX controls.
ControlPropertiesCollection | A collection of AcitveX properties.
CustomData |
DocumentProperties | Represents properties of a presentation.
EffectFormat | Represents effect properties of shape.
EffectFormatEffectiveData | Imutable object which contains effect properties.
Field | Represents a field.
FieldType | Represents a type of field. This value determines which text will be set to the field portion when it will be updated.
FillFormat | Represents a fill formatting options.
FillFormatEffectiveData | Imutable object which contains fill properties.
FontData | Represents a font definition. Immutable.
FontDataFactory | FontData factory
Fonts | Fonts collection.
FontsEffectiveData | Immutable Fonts object.
FontsLoader | Class for loading custom fonts defined by user. Should be used before creating any presentation objects.
GeometryShape | Represents the parent class for all geometric shapes.
GlobalLayoutSlideCollection | Represents a collection of all layout slides in presentation. Extends LayoutSlideCollection class with methods for adding/cloning layout slides in context of uniting of the individual collections of master's layout slides.
GradientFormat | Represent a gradient format.
GradientFormatEffectiveData | Imutable object which contains gradient properties.
GradientStop | Represents a gradient stop.
GradientStopCollection | Represnts a collection of gradient stops.
GradientStopCollectionEffectiveData | Represents a collection of GradientStopData objects.
GradientStopEffectiveData | immutable object which represents a gradient stop.
GraphicalObject | Represents abstract graphical object.
GraphicalObjectLock | Determines which operations are disabled on the parent GraphicalObject.
GroupShape | Represents a group of shapes on a slide.
GroupShapeLock | Determines which operations are disabled on the parent GroupShape.
HeaderFooterManager | Represents manager which holds behavior of a header\footer placeholders
Hyperlink | Represents a hyperlink. Immutable.
HyperlinkManager |
HyperlinkQueries |
ImageCollection | Represents collection of PPImage.
ImageWrapper | System.Drawing.Image wrapper for COM interface.
ImageWrapperFactory | This class allows to initialize IBitmapWrapper.
InvalidPasswordException |
LayoutSlide | Represents a layout slide.
LayoutSlideCollection | Represents a base class for collection of a layout slides.
License | Provides methods to license the component.
LightRig | Represents LightRig.
LineFillFormat | Represents properties for lines filling.
LineFillFormatEffectiveData | Immutable object which represents properties for lines filling.
LineFormat | Represents format of a line.
LineFormatEffectiveData | Immutable object which contains line properties.
LoadOptions | Allows to specify additional options (such as format or default font) when loading a presentation.
MasterHandoutSlide | Represents master slide for handouts.
MasterLayoutSlideCollection | Represents a collections of all layout slides of defined master slide. Extends LayoutSlideCollection class with methods for adding/inserting/removing/cloning/reordering layout slides in context of the individual collections of master's layout slides.
MasterNotesSlide | Represents master slide for notes.
MasterSlide | Represents a master slide in a presentation.
MasterSlideCollection | Represents a collection of master slides.
NotesSlide | Represents a notes slide in a presentation.
OleObjectFrame | Represents an OLE object on a slide.
OOXMLCorruptFileException |
OOXMLException |
Paragraph | Represents a paragraph of text.
ParagraphCollection | Represents a collection of a paragraphs.
ParagraphFactory | Allows to create paragraphs
ParagraphFormat | This class contains the paragraph formatting properties. Unlike ParagraphFormatEffectiveData, all properties of this class are writeable.
ParagraphFormatEffectiveData | Immutable object which contains paragraph formatting properties.
PatternFormat | Represents a pattern to fill a shape.
PatternFormatEffectiveData | Immutable object which represents a pattern to fill a shape.
Picture | Represents a picture in a presentation.
PictureEffectiveData | Immutable object which represents a picture in a presentation.
PictureFillFormat | Represents a picture fill style.
PictureFillFormatEffectiveData | Immutable object which contains the properties of picture fill.
PictureFrame | Represents a frame with a picture inside.
PictureFrameLock | Determines which operations are disabled on the parent PictureFrame.
Placeholder | Represents a placeholder on a slide.
Portion | Represents a portion of text inside a text paragraph.
PortionCollection | Represents a collection of a portions.
PortionFactory | Allows to create test portions
PortionFormat | This class contains the text portion formatting properties. Unlike PortionFormatEffectiveData, all properties of this class are writeable.
PortionFormatEffectiveData | Immutable object which contains text portion formatting properties.
PPImage | Represents an image in a presentation.
PptCorruptFileException |
PptEditException |
PptException |
PptReadException |
PptUnsupportedFormatException |
PptxEditException |
PptxException |
PptxReadException |
PptxUnsupportedFormatException |
Presentation | Represents a Microsoft PowerPoint presentation.
PresentationFactory | Allows to create presentation via COM interface
ProtectionManager |
Row | Represents a row in a table.
RowCollection | Represents a collection of rows.
Shape | Represents a shape on a slide.
ShapeBevel | Contains the properties of shape's main face relief.
ShapeCollection | Represents a collection of a shapes.
ShapeElement | Represents a part of shape with same outline and fill properties.
ShapeFrame | Represents shape frame's properties.
ShapeStyle | Represent shape's style reference.
Slide | Represents a slide in a presentation.
SlideCollection | Represents a collection of a slides.
SlideSize | Represents a size of slide.
StreamWrapper | Aspose.IO.Stream wrapper for COM interface.
StreamWrapperFactory | Factory of StreamWrappers. For COM interface.
Tab | Represents a tabulation for a text.
TabCollection | Represents a collection of tabs.
TabEffectiveData | Immutable object which represents a text's tabulation stop.
TabFactory | Allowa to create ITab instances
Table | Represents a table on a slide.
TagCollection | Represents the collection of tags (user defined pairs of strings)
TextFrame | Represents a TextFrame.
TextFrameFormat | Contains the TextFrame's formatting properties.
TextStyle | Summary description for TextStyle.
ThreeDFormat | Represents 3-D properties.
ThreeDFormatEffectiveData | Immutable object which represents 3-D properties.
Video | Represents an image embedded into a presentation.
VideoCollection | Represents a collection of Video objects.
VideoFrame | Represents a video clip on a slide.

Interfaces

Interface | Description
IAdjustValue |
IAdjustValueCollection |
IAnimationTimeLine |
IAudio |
IAudioCollection |
IAudioFrame |
IAutoShape |
IAutoShapeLock |
IBackdrop3DScene |
IBackground |
IBaseShapeLock |
IBaseSlide |
IBulletFormat |
IBulletFormatEffectiveData |
ICamera |
ICameraEffectiveData |
ICell |
ICellCollection |
IColorFormat |
IColorOperation |
IColorOperationCollection |
IColumn |
IColumnCollection |
IComment |
ICommentAuthor |
ICommentAuthorCollection |
ICommentCollection |
IConnector |
IConnectorLock |
IControl |
IControlCollection |
IControlPropertiesCollection |
ICustomData |
IDocumentProperties |
IEffectFormat |
IEffectFormatEffectiveData |
IField |
IFieldType |
IFillFormat |
IFillFormatEffectiveData |
IFillParamSource |
IFontData |
IFontDataFactory |
IFonts |
IFontsEffectiveData |
IFontsLoader |
IGeometryShape |
IGlobalLayoutSlideCollection |
IGradientFormat |
IGradientFormatEffectiveData |
IGradientStop |
IGradientStopCollection |
IGradientStopCollectionEffectiveData |
IGradientStopEffectiveData |
IGraphicalObject |
IGraphicalObjectLock |
IGroupShape |
IGroupShapeLock |
IHeaderFooterManager |
IHyperlink |
IHyperlinkContainer |
IHyperlinkManager |
IHyperlinkQueries |
IImageCollection |
IImageWrapper |
IImageWrapperFactory |
ILayoutSlide |
ILayoutSlideCollection |
ILightRig |
ILightRigEffectiveData |
ILineFillFormat |
ILineFillFormatEffectiveData |
ILineFormat |
ILineFormatEffectiveData |
ILoadOptions |
IMasterHandoutSlide |
IMasterHandoutSlideManager |
IMasterLayoutSlideCollection |
IMasterNotesSlide |
IMasterNotesSlideManager |
IMasterSlide |
IMasterSlideCollection |
INotesSlide |
IOleObjectFrame |
IParagraph |
IParagraphCollection |
IParagraphFactory |
IParagraphFormat |
IParagraphFormatEffectiveData |
IPatternFormat |
IPatternFormatEffectiveData |
IPictureEffectiveData |
IPictureFillFormat |
IPictureFillFormatEffectiveData |
IPictureFrame |
IPictureFrameLock |
IPlaceholder |
IPortion |
IPortionCollection |
IPortionFactory |
IPortionFormat |
IPortionFormatEffectiveData |
IPPImage |
IPresentation |
IPresentationComponent |
IPresentationFactory |
IProtectionManager |
IRow |
IRowCollection |
IShape |
IShapeBevel |
IShapeBevelEffectiveData |
IShapeCollection |
IShapeElement |
IShapeFrame |
IShapeStyle |
ISlide |
ISlideCollection |
ISlideComponent |
ISlideShowTransition |
ISlideSize |
ISlidesPicture |
IStreamWrapper |
IStreamWrapperFactory |
ITab |
ITabCollection |
ITabEffectiveData |
ITabFactory |
ITable |
ITagCollection |
ITextFrame |
ITextFrameFormat |
ITextStyle |
IThreeDFormat |
IThreeDFormatEffectiveData |
IVideo |
IVideoCollection |
IVideoFrame |

Enumerations

Enumeration | Description
AudioPlayModePreset |
AudioVolumeMode |
BackgroundType |
BevelColorMode |
BevelPresetType |
BlackWhiteMode |
BulletType |
CameraPresetType |
ColorSchemeIndex |
ColorStringFormat |
ColorTransformOperation |
ColorType |
ControlType |
FillBlendMode |
FillType |
FontAlignment |
FontCollectionIndex |
GradientDirection |
GradientShape |
HyperlinkActionType |
LightingDirection |
LightRigPresetType |
LineAlignment |
LineArrowheadLength |
LineArrowheadStyle |
LineArrowheadWidth |
LineCapStyle |
LineDashStyle |
LineJoinStyle |
LineStyle |
LoadFormat |
MaterialPresetType |
NullableBool |
NumberedBulletStyle |
Orientation |
PatternStyle |
PictureFillMode |
PlaceholderSize |
PlaceholderType |
PPImageFormat |
PresetColor |
PresetShadowType |
RectangleAlignment |
SchemeColor |
ShapeElementFillSource |
ShapeElementStrokeSource |
ShapeThumbnailBounds |
ShapeType |
SlideLayoutType |
SlideOrienation |
SlideSizeType |
SourceFormat |
SystemColor |
TabAlignment |
TableStylePreset |
TextAlignment |
TextAnchorType |
TextAutofitType |
TextCapType |
TextShapeType |
TextStrikethroughType |
TextUnderlineType |
TextVerticalOverflowType |
TextVerticalType |
TileFlip |
VideoPlayModePreset |

Generated:2014-06-01 04:07:47,version:1.3.49.0


AdjustValue Class

Represents a geometry shape's adjustment value. These values affect shape's form.

For a list of all members of this type, see AdjustValue Members.

System.Object
Aspose.Slides.AdjustValue

[Visual Basic]
Public Class AdjustValue
Implements IAdjustValue
[C#]
public class AdjustValue : IAdjustValue

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AdjustValue Members | Aspose.Slides Namespace


AdjustValue Members

AdjustValue overview

Public Instance Properties

AngleValue | Returns or sets value, interpreting it as angle in degrees. Read/write Single.
Name | Returns a name of this adjustment value.
RawValue | Returns or sets ajustment value "as is". Read/write long.

See Also

AdjustValue Class | Aspose.Slides Namespace


AdjustValue Properties

The properties of the AdjustValue class are listed below. For a complete list of AdjustValue class members, see the AdjustValue Members topic.

Public Instance Properties

AngleValue | Returns or sets value, interpreting it as angle in degrees. Read/write Single.
Name | Returns a name of this adjustment value.
RawValue | Returns or sets ajustment value "as is". Read/write long.

See Also

AdjustValue Class | Aspose.Slides Namespace


AngleValue Property

Aspose.Slides Documentation

AdjustValue.AngleValue Property

Returns or sets value, interpreting it as angle in degrees. Read/write Single.

[Visual Basic]
NotOverridable Public Property AngleValue As Single _
Implements IAdjustValue.AngleValue
[C#]
public float AngleValue {get; set;}

Implements

IAdjustValue.AngleValue

See Also

AdjustValue Class | Aspose.Slides Namespace


Name Property

Aspose.Slides Documentation

AdjustValue.Name Property

Returns a name of this adjustment value.

[Visual Basic]
NotOverridable Public ReadOnly Property Name As String _
Implements IAdjustValue.Name
[C#]
public string Name {get;}

Implements

IAdjustValue.Name

See Also

AdjustValue Class | Aspose.Slides Namespace


RawValue Property

Aspose.Slides Documentation

AdjustValue.RawValue Property

Returns or sets ajustment value "as is". Read/write long.

[Visual Basic]
NotOverridable Public Property RawValue As Long _
Implements IAdjustValue.RawValue
[C#]
public long RawValue {get; set;}

Implements

IAdjustValue.RawValue

See Also

AdjustValue Class | Aspose.Slides Namespace


AdjustValueCollection Class

Reprasents a collection of shape's adjustments.

For a list of all members of this type, see AdjustValueCollection Members.

System.Object
Aspose.Slides.AdjustValueCollection

[Visual Basic]
NotInheritable Public Class AdjustValueCollection
Implements IAdjustValueCollection, ICollection, IEnumerable
[C#]
public sealed class AdjustValueCollection : IAdjustValueCollection, ICollection, IEnumerable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AdjustValueCollection Members | Aspose.Slides Namespace


AdjustValueCollection Members

AdjustValueCollection overview

Public Instance Properties

Count | Return a number of adjustments.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns adjustment by index.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

AdjustValueCollection Class | Aspose.Slides Namespace


AdjustValueCollection Properties

The properties of the AdjustValueCollection class are listed below. For a complete list of AdjustValueCollection class members, see the AdjustValueCollection Members topic.

Public Instance Properties

Count | Return a number of adjustments.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns adjustment by index.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

AdjustValueCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

AdjustValueCollection.Count Property

Return a number of adjustments.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

AdjustValueCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

AdjustValueCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

AdjustValueCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

AdjustValueCollection.Item Property

Returns adjustment by index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IAdjustValueCollection.Item
As IAdjustValue _
Implements IAdjustValueCollection.Item
[C#]
public IAdjustValue this[
int index
] {get;}

Parameters

index
adjustment's index.

Implements

IAdjustValueCollection.Item

See Also

AdjustValueCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

AdjustValueCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

AdjustValueCollection Class | Aspose.Slides Namespace


AdjustValueCollection Methods

The methods of the AdjustValueCollection class are listed below. For a complete list of AdjustValueCollection class members, see the AdjustValueCollection Members topic.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

AdjustValueCollection Class | Aspose.Slides Namespace


AdjustValueCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

AdjustValueCollection Class | Aspose.Slides Namespace


AdjustValueCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

AdjustValueCollection Class | Aspose.Slides Namespace


Audio Class

Represents an embedded audio file.

For a list of all members of this type, see Audio Members.

System.Object
Aspose.Slides.Audio

[Visual Basic]
Public Class Audio
Implements IAudio
[C#]
public class Audio : IAudio

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Audio Members | Aspose.Slides Namespace


Audio Members

Audio overview

Public Instance Properties

BinaryData | Returns the copy of an audio's data. Read-only Byte[].
ContentType | Returns a MIME type of an audio, encoded in BinaryData. Read-only String.

See Also

Audio Class | Aspose.Slides Namespace


Audio Properties

The properties of the Audio class are listed below. For a complete list of Audio class members, see the Audio Members topic.

Public Instance Properties

BinaryData | Returns the copy of an audio's data. Read-only Byte[].
ContentType | Returns a MIME type of an audio, encoded in BinaryData. Read-only String.

See Also

Audio Class | Aspose.Slides Namespace


BinaryData Property

Aspose.Slides Documentation

Audio.BinaryData Property

Returns the copy of an audio's data. Read-only Byte[].

[Visual Basic]
NotOverridable Public ReadOnly Property BinaryData As Byte() _
Implements IAudio.BinaryData
[C#]
public byte[] BinaryData {get;}

Implements

IAudio.BinaryData

See Also

Audio Class | Aspose.Slides Namespace


ContentType Property

Aspose.Slides Documentation

Audio.ContentType Property

Returns a MIME type of an audio, encoded in BinaryData. Read-only String.

[Visual Basic]
NotOverridable Public ReadOnly Property ContentType As String _
Implements IAudio.ContentType
[C#]
public string ContentType {get;}

Implements

IAudio.ContentType

See Also

Audio Class | Aspose.Slides Namespace


AudioCollection Class

Represents a collection of embedded audio files.

For a list of all members of this type, see AudioCollection Members.

System.Object
Aspose.Slides.AudioCollection

[Visual Basic]
Public Class AudioCollection
Implements IAudioCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IAudio, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class AudioCollection : IAudioCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AudioCollection Members | Aspose.Slides Namespace


AudioCollection Members

AudioCollection overview

Public Instance Properties

Count | Returns a number of audio files in the collection.
Item | Gets the element at the specified index. Read-only IAudio.

Public Instance Methods

AddAudio | Overloaded. Adds a copy of an audio file from an another presentation.
GetEnumerator | Returns an enumerator that iterates through the collection.

See Also

AudioCollection Class | Aspose.Slides Namespace


AudioCollection Properties

The properties of the AudioCollection class are listed below. For a complete list of AudioCollection class members, see the AudioCollection Members topic.

Public Instance Properties

Count | Returns a number of audio files in the collection.
Item | Gets the element at the specified index. Read-only IAudio.

See Also

AudioCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

AudioCollection.Count Property

Returns a number of audio files in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

AudioCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

AudioCollection.Item Property

Gets the element at the specified index. Read-only IAudio.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IAudioCollection.Item
As IAudio _
Implements IAudioCollection.Item
[C#]
public IAudio this[
int index
] {get;}

Implements

IAudioCollection.Item

See Also

AudioCollection Class | Aspose.Slides Namespace


AudioCollection Methods

The methods of the AudioCollection class are listed below. For a complete list of AudioCollection class members, see the AudioCollection Members topic.

Public Instance Methods

AddAudio | Overloaded. Adds a copy of an audio file from an another presentation.
GetEnumerator | Returns an enumerator that iterates through the collection.

See Also

AudioCollection Class | Aspose.Slides Namespace


AddAudio Method

Aspose.Slides Documentation

AudioCollection.AddAudio Method

Adds a copy of an audio file from an another presentation.

Overload List

Adds a copy of an audio file from an another presentation.

public IAudio AddAudio(IAudio);

Creates and adds a audio to a presentation from byte array.

public IAudio AddAudio(byte[]);

Creates and adds a audio to a presentation from stream.

public IAudio AddAudio(Stream);

See Also

AudioCollection Class | Aspose.Slides Namespace


AudioCollection.AddAudio Method (IAudio)

Adds a copy of an audio file from an another presentation.

[Visual Basic]
NotOverridable Overloads Public Function AddAudio( _
ByVal audio As IAudio _
) As IAudio _
Implements IAudioCollection.AddAudio
[C#]
public IAudio AddAudio(
IAudio audio
);

Parameters

audio
Source audio.

Return Value

Added audio.

Implements

IAudioCollection.AddAudio

See Also

AudioCollection Class | Aspose.Slides Namespace | AudioCollection.AddAudio Overload List


AudioCollection.AddAudio Method (Byte[])

Creates and adds a audio to a presentation from byte array.

[Visual Basic]
NotOverridable Overloads Public Function AddAudio( _
ByVal audioData As Byte() _
) As IAudio _
Implements IAudioCollection.AddAudio
[C#]
public IAudio AddAudio(
byte[] audioData
);

Parameters

audioData
Audio bytes.

Return Value

Added audio.

Implements

IAudioCollection.AddAudio

See Also

AudioCollection Class | Aspose.Slides Namespace | AudioCollection.AddAudio Overload List


AudioCollection.AddAudio Method (Stream)

Creates and adds a audio to a presentation from stream.

[Visual Basic]
NotOverridable Overloads Public Function AddAudio( _
ByVal stream As Stream _
) As IAudio _
Implements IAudioCollection.AddAudio
[C#]
public IAudio AddAudio(
Stream stream
);

Parameters

stream
Stream to add audio from.

Return Value

Added audio.

Implements

IAudioCollection.AddAudio

See Also

AudioCollection Class | Aspose.Slides Namespace | AudioCollection.AddAudio Overload List


AudioCollection.GetEnumerator Method

Returns an enumerator that iterates through the collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator(Of IAudio) _
Implements IEnumerable`1.GetEnumerator
[C#]
public IEnumerator<IAudio> GetEnumerator();

Return Value

A IEnumerator`1 that can be used to iterate through the collection.

Implements

IEnumerable`1.GetEnumerator

See Also

AudioCollection Class | Aspose.Slides Namespace


AudioFrame Class

Represents an audio clip on a slide.

For a list of all members of this type, see AudioFrame Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GeometryShape
Aspose.Slides.PictureFrame
Aspose.Slides.AudioFrame

[Visual Basic]
Public Class AudioFrame
Inherits PictureFrame
Implements IAudioFrame
[C#]
public class AudioFrame : PictureFrame, IAudioFrame

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AudioFrame Members | Aspose.Slides Namespace


AudioFrame Members

AudioFrame overview

Public Instance Properties

Adjustments (inherited from GeometryShape) | Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
AudioCdEndTrack | Returns or sets a last track index Read/write Int32.
AudioCdEndTrackTime | Returns or sets a last track time. Read/write Int32.
AudioCdStartTrack | Returns or sets a start track index. Read/write Int32.
AudioCdStartTrackTime | Returns or sets a start track time. Read/write Int32.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
Embedded | Determines whether a sound is embedded to a presentation. Read-only Boolean.
EmbeddedAudio | Returns or sets embedded audio object. Read/write Audio.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HideAtShowing | Determines whether an AudioFrame is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
LinkPathLong | Returns or sets the name of an audio file which is linked to an AudioFrame. Read/write String.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
PictureFormat (inherited from PictureFrame) | Returns the PictureFillFormat object for a picture frame. Read-only PictureFillFormat.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
PlayLoopMode | Determines whether an audio is looped. Read/write Boolean.
PlayMode | Returns or sets the audio play mode. Read/write AudioPlayModePreset.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
RelativeScaleHeight (inherited from PictureFrame) | Returns or sets the scale of height(relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.
RelativeScaleWidth (inherited from PictureFrame) | Returns or sets the scale of width (relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock (inherited from PictureFrame) | Returns shape's locks. Readonly PictureFrameLock.
ShapeStyle (inherited from GeometryShape) | Returns shape's style object. Read-only ShapeStyle.
ShapeType (inherited from PictureFrame) | Returns or sets the AutoShape type for a PictureFrame. There are allowable all items of the set ShapeType, except all sorts of lines: ShapeType.Line, ShapeType.StraightConnector1, ShapeType.BentConnector2, ShapeType.BentConnector3, ShapeType.BentConnector4, ShapeType.BentConnector5, ShapeType.CurvedConnector2, ShapeType.CurvedConnector3, ShapeType.CurvedConnector4, ShapeType.CurvedConnector5. Read/write ShapeType.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Volume | Returns or sets the audio volume. Read/write AudioVolumeMode.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateShapeElements (inherited from GeometryShape) | Creates and returns array of shape's elements.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

AudioFrame Class | Aspose.Slides Namespace


AudioFrame Properties

The properties of the AudioFrame class are listed below. For a complete list of AudioFrame class members, see the AudioFrame Members topic.

Public Instance Properties

Adjustments (inherited from GeometryShape) | Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
AudioCdEndTrack | Returns or sets a last track index Read/write Int32.
AudioCdEndTrackTime | Returns or sets a last track time. Read/write Int32.
AudioCdStartTrack | Returns or sets a start track index. Read/write Int32.
AudioCdStartTrackTime | Returns or sets a start track time. Read/write Int32.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
Embedded | Determines whether a sound is embedded to a presentation. Read-only Boolean.
EmbeddedAudio | Returns or sets embedded audio object. Read/write Audio.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HideAtShowing | Determines whether an AudioFrame is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
LinkPathLong | Returns or sets the name of an audio file which is linked to an AudioFrame. Read/write String.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
PictureFormat (inherited from PictureFrame) | Returns the PictureFillFormat object for a picture frame. Read-only PictureFillFormat.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
PlayLoopMode | Determines whether an audio is looped. Read/write Boolean.
PlayMode | Returns or sets the audio play mode. Read/write AudioPlayModePreset.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
RelativeScaleHeight (inherited from PictureFrame) | Returns or sets the scale of height(relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.
RelativeScaleWidth (inherited from PictureFrame) | Returns or sets the scale of width (relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock (inherited from PictureFrame) | Returns shape's locks. Readonly PictureFrameLock.
ShapeStyle (inherited from GeometryShape) | Returns shape's style object. Read-only ShapeStyle.
ShapeType (inherited from PictureFrame) | Returns or sets the AutoShape type for a PictureFrame. There are allowable all items of the set ShapeType, except all sorts of lines: ShapeType.Line, ShapeType.StraightConnector1, ShapeType.BentConnector2, ShapeType.BentConnector3, ShapeType.BentConnector4, ShapeType.BentConnector5, ShapeType.CurvedConnector2, ShapeType.CurvedConnector3, ShapeType.CurvedConnector4, ShapeType.CurvedConnector5. Read/write ShapeType.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Volume | Returns or sets the audio volume. Read/write AudioVolumeMode.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

AudioFrame Class | Aspose.Slides Namespace


AudioCdEndTrack Property

Aspose.Slides Documentation

AudioFrame.AudioCdEndTrack Property

Returns or sets a last track index Read/write Int32.

[Visual Basic]
NotOverridable Public Property AudioCdEndTrack As Integer _
Implements IAudioFrame.AudioCdEndTrack
[C#]
public int AudioCdEndTrack {get; set;}

Implements

IAudioFrame.AudioCdEndTrack

See Also

AudioFrame Class | Aspose.Slides Namespace


AudioCdEndTrackTime Property

Aspose.Slides Documentation

AudioFrame.AudioCdEndTrackTime Property

Returns or sets a last track time. Read/write Int32.

[Visual Basic]
NotOverridable Public Property AudioCdEndTrackTime As Integer _
Implements IAudioFrame.AudioCdEndTrackTime
[C#]
public int AudioCdEndTrackTime {get; set;}

Implements

IAudioFrame.AudioCdEndTrackTime

See Also

AudioFrame Class | Aspose.Slides Namespace


AudioCdStartTrack Property

Aspose.Slides Documentation

AudioFrame.AudioCdStartTrack Property

Returns or sets a start track index. Read/write Int32.

[Visual Basic]
NotOverridable Public Property AudioCdStartTrack As Integer _
Implements IAudioFrame.AudioCdStartTrack
[C#]
public int AudioCdStartTrack {get; set;}

Implements

IAudioFrame.AudioCdStartTrack

See Also

AudioFrame Class | Aspose.Slides Namespace


AudioCdStartTrackTime Property

Aspose.Slides Documentation

AudioFrame.AudioCdStartTrackTime Property

Returns or sets a start track time. Read/write Int32.

[Visual Basic]
NotOverridable Public Property AudioCdStartTrackTime As Integer _
Implements IAudioFrame.AudioCdStartTrackTime
[C#]
public int AudioCdStartTrackTime {get; set;}

Implements

IAudioFrame.AudioCdStartTrackTime

See Also

AudioFrame Class | Aspose.Slides Namespace


Embedded Property

Aspose.Slides Documentation

AudioFrame.Embedded Property

Determines whether a sound is embedded to a presentation. Read-only Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property Embedded As Boolean _
Implements IAudioFrame.Embedded
[C#]
public bool Embedded {get;}

Implements

IAudioFrame.Embedded

See Also

AudioFrame Class | Aspose.Slides Namespace


EmbeddedAudio Property

Aspose.Slides Documentation

AudioFrame.EmbeddedAudio Property

Returns or sets embedded audio object. Read/write Audio.

[Visual Basic]
NotOverridable Public Property EmbeddedAudio As IAudio _
Implements IAudioFrame.EmbeddedAudio
[C#]
public IAudio EmbeddedAudio {get; set;}

Implements

IAudioFrame.EmbeddedAudio

See Also

AudioFrame Class | Aspose.Slides Namespace


HideAtShowing Property

Aspose.Slides Documentation

AudioFrame.HideAtShowing Property

Determines whether an AudioFrame is hidden. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property HideAtShowing As Boolean _
Implements IAudioFrame.HideAtShowing
[C#]
public bool HideAtShowing {get; set;}

Implements

IAudioFrame.HideAtShowing

See Also

AudioFrame Class | Aspose.Slides Namespace


LinkPathLong Property

Aspose.Slides Documentation

AudioFrame.LinkPathLong Property

Returns or sets the name of an audio file which is linked to an AudioFrame. Read/write String.

[Visual Basic]
NotOverridable Public Property LinkPathLong As String _
Implements IAudioFrame.LinkPathLong
[C#]
public string LinkPathLong {get; set;}

Implements

IAudioFrame.LinkPathLong

See Also

AudioFrame Class | Aspose.Slides Namespace


PlayLoopMode Property

Aspose.Slides Documentation

AudioFrame.PlayLoopMode Property

Determines whether an audio is looped. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property PlayLoopMode As Boolean _
Implements IAudioFrame.PlayLoopMode
[C#]
public bool PlayLoopMode {get; set;}

Implements

IAudioFrame.PlayLoopMode

See Also

AudioFrame Class | Aspose.Slides Namespace


PlayMode Property

Aspose.Slides Documentation

AudioFrame.PlayMode Property

Returns or sets the audio play mode. Read/write AudioPlayModePreset.

[Visual Basic]
NotOverridable Public Property PlayMode As AudioPlayModePreset _
Implements IAudioFrame.PlayMode
[C#]
public AudioPlayModePreset PlayMode {get; set;}

Implements

IAudioFrame.PlayMode

See Also

AudioFrame Class | Aspose.Slides Namespace


Volume Property

Aspose.Slides Documentation

AudioFrame.Volume Property

Returns or sets the audio volume. Read/write AudioVolumeMode.

[Visual Basic]
NotOverridable Public Property Volume As AudioVolumeMode _
Implements IAudioFrame.Volume
[C#]
public AudioVolumeMode Volume {get; set;}

Implements

IAudioFrame.Volume

See Also

AudioFrame Class | Aspose.Slides Namespace


AudioPlayModePreset Enumeration

[Visual Basic]
Public Enum AudioPlayModePreset
[C#]
public enum AudioPlayModePreset

Members

Member Name | Description | Value
Mixed |  | -1
Auto |  | 0
OnClick |  | 1
AllSlides |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


AudioVolumeMode Enumeration

[Visual Basic]
Public Enum AudioVolumeMode
[C#]
public enum AudioVolumeMode

Members

Member Name | Description | Value
Mixed |  | -1
Mute |  | 0
Low |  | 1
Medium |  | 2
Loud |  | 3

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


AutoShape Class

Represents an AutoShape.

For a list of all members of this type, see AutoShape Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GeometryShape
Aspose.Slides.AutoShape

[Visual Basic]
Public Class AutoShape
Inherits GeometryShape
Implements IAutoShape
[C#]
public class AutoShape : GeometryShape, IAutoShape

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AutoShape Members | Aspose.Slides Namespace


AutoShape Members

AutoShape overview

Public Instance Properties

Adjustments (inherited from GeometryShape) | Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock | Overloaded. Returns shape's locks. Read-only AutoShapeLock.
ShapeStyle (inherited from GeometryShape) | Returns shape's style object. Read-only ShapeStyle.
ShapeType (inherited from GeometryShape) | Returns or sets the geometry preset type. Note: on value changing all adjustment values will reset to their default values. Read/write ShapeType.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
TextFrame | Returns TextFrame object for the AutoShape. Read-only TextFrame.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
UseBackgroundFill | Determines whether this autoshape should be filled with slide's background fill instead of specified by style or fill format. Read/write bool.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
AddTextFrame | Adds a new TextFrame to a shape. If shape already has TextFrame then simply changes its text.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateShapeElements (inherited from GeometryShape) | Creates and returns array of shape's elements.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

AutoShape Class | Aspose.Slides Namespace


AutoShape Properties

The properties of the AutoShape class are listed below. For a complete list of AutoShape class members, see the AutoShape Members topic.

Public Instance Properties

Adjustments (inherited from GeometryShape) | Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock | Overloaded. Returns shape's locks. Read-only AutoShapeLock.
ShapeStyle (inherited from GeometryShape) | Returns shape's style object. Read-only ShapeStyle.
ShapeType (inherited from GeometryShape) | Returns or sets the geometry preset type. Note: on value changing all adjustment values will reset to their default values. Read/write ShapeType.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
TextFrame | Returns TextFrame object for the AutoShape. Read-only TextFrame.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
UseBackgroundFill | Determines whether this autoshape should be filled with slide's background fill instead of specified by style or fill format. Read/write bool.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

AutoShape Class | Aspose.Slides Namespace


ShapeLock Property

Aspose.Slides Documentation

AutoShape.ShapeLock Property

Returns shape's locks. Read-only AutoShapeLock.

[Visual Basic]
NotOverridable Overloads Public ReadOnly Property ShapeLock As IAutoShapeLock _
Implements IAutoShape.ShapeLock
[C#]
new public IAutoShapeLock ShapeLock {get;}

Implements

IAutoShape.ShapeLock

See Also

AutoShape Class | Aspose.Slides Namespace


TextFrame Property

Aspose.Slides Documentation

AutoShape.TextFrame Property

Returns TextFrame object for the AutoShape. Read-only TextFrame.

[Visual Basic]
NotOverridable Public ReadOnly Property TextFrame As ITextFrame _
Implements IAutoShape.TextFrame
[C#]
public ITextFrame TextFrame {get;}

Implements

IAutoShape.TextFrame

See Also

AutoShape Class | Aspose.Slides Namespace


UseBackgroundFill Property

Aspose.Slides Documentation

AutoShape.UseBackgroundFill Property

Determines whether this autoshape should be filled with slide's background fill instead of specified by style or fill format. Read/write bool.

[Visual Basic]
NotOverridable Public Property UseBackgroundFill As Boolean _
Implements IAutoShape.UseBackgroundFill
[C#]
public bool UseBackgroundFill {get; set;}

Implements

IAutoShape.UseBackgroundFill

See Also

AutoShape Class | Aspose.Slides Namespace


AutoShape Methods

The methods of the AutoShape class are listed below. For a complete list of AutoShape class members, see the AutoShape Members topic.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
AddTextFrame | Adds a new TextFrame to a shape. If shape already has TextFrame then simply changes its text.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateShapeElements (inherited from GeometryShape) | Creates and returns array of shape's elements.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

AutoShape Class | Aspose.Slides Namespace


AutoShape.AddTextFrame Method

Adds a new TextFrame to a shape. If shape already has TextFrame then simply changes its text.

[Visual Basic]
Overridable Public Function AddTextFrame( _
ByVal text As String _
) As ITextFrame _
Implements IAutoShape.AddTextFrame
[C#]
public virtual ITextFrame AddTextFrame(
string text
);

Parameters

text
Default text for a new TextFrame.

Implements

IAutoShape.AddTextFrame

See Also

AutoShape Class | Aspose.Slides Namespace


AutoShapeLock Class

Determines which operations are disabled on the parent AutoshapeEx.

For a list of all members of this type, see AutoShapeLock Members.

System.Object
Aspose.Slides.BaseShapeLock
Aspose.Slides.AutoShapeLock

[Visual Basic]
Public Class AutoShapeLock
Inherits BaseShapeLock
Implements IAutoShapeLock
[C#]
public class AutoShapeLock : BaseShapeLock, IAutoShapeLock

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AutoShapeLock Members | Aspose.Slides Namespace


AutoShapeLock Members

AutoShapeLock overview

Public Instance Properties

AdjustHandlesLocked | Determines whether a changing adjust values is forbidden.
ArrowheadsLocked | Determines whether a changing arrowheads is forbidden.
AspectRatioLocked | Determines whether a shape have to preserve aspect ratio on resizing.
EditPointsLocked | Determines whether a direct changing of contour of this shape is forbidden.
GroupingLocked | Determines whether an adding this shape to a group is forbidden.
NoLocks (inherited from BaseShapeLock) | Return true if all lock-flags are disabled.
PositionLocked | Determines whether a moving this shape is forbidden.
RotateLocked | Determines whether a changing rotation angle of this shape is forbidden.
SelectLocked | Determines whether a selecting this shape is forbidden.
ShapeTypeLocked | Determines whether a changing of a shape type is forbidden.
SizeLocked | Determines whether a resizing this shape is forbidden.
TextLocked | Determines whether an editing of text is forbidden.

See Also

AutoShapeLock Class | Aspose.Slides Namespace


AutoShapeLock Properties

The properties of the AutoShapeLock class are listed below. For a complete list of AutoShapeLock class members, see the AutoShapeLock Members topic.

Public Instance Properties

AdjustHandlesLocked | Determines whether a changing adjust values is forbidden.
ArrowheadsLocked | Determines whether a changing arrowheads is forbidden.
AspectRatioLocked | Determines whether a shape have to preserve aspect ratio on resizing.
EditPointsLocked | Determines whether a direct changing of contour of this shape is forbidden.
GroupingLocked | Determines whether an adding this shape to a group is forbidden.
NoLocks (inherited from BaseShapeLock) | Return true if all lock-flags are disabled.
PositionLocked | Determines whether a moving this shape is forbidden.
RotateLocked | Determines whether a changing rotation angle of this shape is forbidden.
SelectLocked | Determines whether a selecting this shape is forbidden.
ShapeTypeLocked | Determines whether a changing of a shape type is forbidden.
SizeLocked | Determines whether a resizing this shape is forbidden.
TextLocked | Determines whether an editing of text is forbidden.

See Also

AutoShapeLock Class | Aspose.Slides Namespace


AdjustHandlesLocked Property

Aspose.Slides Documentation

AutoShapeLock.AdjustHandlesLocked Property

Determines whether a changing adjust values is forbidden.

[Visual Basic]
NotOverridable Public Property AdjustHandlesLocked As Boolean _
Implements IAutoShapeLock.AdjustHandlesLocked
[C#]
public bool AdjustHandlesLocked {get; set;}

Implements

IAutoShapeLock.AdjustHandlesLocked

See Also

AutoShapeLock Class | Aspose.Slides Namespace


ArrowheadsLocked Property

Aspose.Slides Documentation

AutoShapeLock.ArrowheadsLocked Property

Determines whether a changing arrowheads is forbidden.

[Visual Basic]
NotOverridable Public Property ArrowheadsLocked As Boolean _
Implements IAutoShapeLock.ArrowheadsLocked
[C#]
public bool ArrowheadsLocked {get; set;}

Implements

IAutoShapeLock.ArrowheadsLocked

See Also

AutoShapeLock Class | Aspose.Slides Namespace


AspectRatioLocked Property

Aspose.Slides Documentation

AutoShapeLock.AspectRatioLocked Property

Determines whether a shape have to preserve aspect ratio on resizing.

[Visual Basic]
NotOverridable Public Property AspectRatioLocked As Boolean _
Implements IAutoShapeLock.AspectRatioLocked
[C#]
public bool AspectRatioLocked {get; set;}

Implements

IAutoShapeLock.AspectRatioLocked

See Also

AutoShapeLock Class | Aspose.Slides Namespace


EditPointsLocked Property

Aspose.Slides Documentation

AutoShapeLock.EditPointsLocked Property

Determines whether a direct changing of contour of this shape is forbidden.

[Visual Basic]
NotOverridable Public Property EditPointsLocked As Boolean _
Implements IAutoShapeLock.EditPointsLocked
[C#]
public bool EditPointsLocked {get; set;}

Implements

IAutoShapeLock.EditPointsLocked

See Also

AutoShapeLock Class | Aspose.Slides Namespace


GroupingLocked Property

Aspose.Slides Documentation

AutoShapeLock.GroupingLocked Property

Determines whether an adding this shape to a group is forbidden.

[Visual Basic]
NotOverridable Public Property GroupingLocked As Boolean _
Implements IAutoShapeLock.GroupingLocked
[C#]
public bool GroupingLocked {get; set;}

Implements

IAutoShapeLock.GroupingLocked

See Also

AutoShapeLock Class | Aspose.Slides Namespace


PositionLocked Property

Aspose.Slides Documentation

AutoShapeLock.PositionLocked Property

Determines whether a moving this shape is forbidden.

[Visual Basic]
NotOverridable Public Property PositionLocked As Boolean _
Implements IAutoShapeLock.PositionLocked
[C#]
public bool PositionLocked {get; set;}

Implements

IAutoShapeLock.PositionLocked

See Also

AutoShapeLock Class | Aspose.Slides Namespace


RotateLocked Property

Aspose.Slides Documentation

AutoShapeLock.RotateLocked Property

Determines whether a changing rotation angle of this shape is forbidden.

[Visual Basic]
NotOverridable Public Property RotateLocked As Boolean _
Implements IAutoShapeLock.RotateLocked
[C#]
public bool RotateLocked {get; set;}

Implements

IAutoShapeLock.RotateLocked

See Also

AutoShapeLock Class | Aspose.Slides Namespace


SelectLocked Property

Aspose.Slides Documentation

AutoShapeLock.SelectLocked Property

Determines whether a selecting this shape is forbidden.

[Visual Basic]
NotOverridable Public Property SelectLocked As Boolean _
Implements IAutoShapeLock.SelectLocked
[C#]
public bool SelectLocked {get; set;}

Implements

IAutoShapeLock.SelectLocked

See Also

AutoShapeLock Class | Aspose.Slides Namespace


ShapeTypeLocked Property

Aspose.Slides Documentation

AutoShapeLock.ShapeTypeLocked Property

Determines whether a changing of a shape type is forbidden.

[Visual Basic]
NotOverridable Public Property ShapeTypeLocked As Boolean _
Implements IAutoShapeLock.ShapeTypeLocked
[C#]
public bool ShapeTypeLocked {get; set;}

Implements

IAutoShapeLock.ShapeTypeLocked

See Also

AutoShapeLock Class | Aspose.Slides Namespace


SizeLocked Property

Aspose.Slides Documentation

AutoShapeLock.SizeLocked Property

Determines whether a resizing this shape is forbidden.

[Visual Basic]
NotOverridable Public Property SizeLocked As Boolean _
Implements IAutoShapeLock.SizeLocked
[C#]
public bool SizeLocked {get; set;}

Implements

IAutoShapeLock.SizeLocked

See Also

AutoShapeLock Class | Aspose.Slides Namespace


TextLocked Property

Aspose.Slides Documentation

AutoShapeLock.TextLocked Property

Determines whether an editing of text is forbidden.

[Visual Basic]
NotOverridable Public Property TextLocked As Boolean _
Implements IAutoShapeLock.TextLocked
[C#]
public bool TextLocked {get; set;}

Implements

IAutoShapeLock.TextLocked

See Also

AutoShapeLock Class | Aspose.Slides Namespace


Backdrop3DScene Class

Defines a plane in which effects, such as glow and shadow, are applied in relation to the shape they are being applied to

For a list of all members of this type, see Backdrop3DScene Members.

System.Object
Aspose.Slides.Backdrop3DScene

[Visual Basic]
Public Class Backdrop3DScene
Implements IBackdrop3DScene
[C#]
public class Backdrop3DScene : IBackdrop3DScene

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Backdrop3DScene Members | Aspose.Slides Namespace


Backdrop3DScene Members

Backdrop3DScene overview

Public Instance Constructors

Backdrop3DScene Constructor Initializes a new instance of the Backdrop3DScene class.

Public Instance Properties

AnchorPoint | Returns or sets a point in 3D space. This point is the point in space that anchors the backdrop plane. 3D point represented by array of 3 float values which define X, Y and Z coordinates.
NormalVector | Returns or sets a normal vector. To be more precise, this attribute defines a vector normal to the face of the backdrop plane. Vector represented by array of 3 float values which define X, Y and Z coordinates.
UpVector | Returns or sets a vector representing up. To be more precise, this attribute defines a vector representing up in relation to the face of the backdrop plane. Vector represented by array of 3 float values which define X, Y and Z coordinates.

See Also

Backdrop3DScene Class | Aspose.Slides Namespace


Backdrop3DScene Constructor

Initializes a new instance of the Backdrop3DScene class.

[Visual Basic]
Public Sub New()
[C#]
public Backdrop3DScene();

See Also

Backdrop3DScene Class | Aspose.Slides Namespace


Backdrop3DScene Properties

The properties of the Backdrop3DScene class are listed below. For a complete list of Backdrop3DScene class members, see the Backdrop3DScene Members topic.

Public Instance Properties

AnchorPoint | Returns or sets a point in 3D space. This point is the point in space that anchors the backdrop plane. 3D point represented by array of 3 float values which define X, Y and Z coordinates.
NormalVector | Returns or sets a normal vector. To be more precise, this attribute defines a vector normal to the face of the backdrop plane. Vector represented by array of 3 float values which define X, Y and Z coordinates.
UpVector | Returns or sets a vector representing up. To be more precise, this attribute defines a vector representing up in relation to the face of the backdrop plane. Vector represented by array of 3 float values which define X, Y and Z coordinates.

See Also

Backdrop3DScene Class | Aspose.Slides Namespace


AnchorPoint Property

Aspose.Slides Documentation

Backdrop3DScene.AnchorPoint Property

Returns or sets a point in 3D space. This point is the point in space that anchors the backdrop plane. 3D point represented by array of 3 float values which define X, Y and Z coordinates.

[Visual Basic]
NotOverridable Public Property AnchorPoint As Single() _
Implements IBackdrop3DScene.AnchorPoint
[C#]
public float[] AnchorPoint {get; set;}

Implements

IBackdrop3DScene.AnchorPoint

See Also

Backdrop3DScene Class | Aspose.Slides Namespace


NormalVector Property

Aspose.Slides Documentation

Backdrop3DScene.NormalVector Property

Returns or sets a normal vector. To be more precise, this attribute defines a vector normal to the face of the backdrop plane. Vector represented by array of 3 float values which define X, Y and Z coordinates.

[Visual Basic]
NotOverridable Public Property NormalVector As Single() _
Implements IBackdrop3DScene.NormalVector
[C#]
public float[] NormalVector {get; set;}

Implements

IBackdrop3DScene.NormalVector

See Also

Backdrop3DScene Class | Aspose.Slides Namespace


UpVector Property

Aspose.Slides Documentation

Backdrop3DScene.UpVector Property

Returns or sets a vector representing up. To be more precise, this attribute defines a vector representing up in relation to the face of the backdrop plane. Vector represented by array of 3 float values which define X, Y and Z coordinates.

[Visual Basic]
NotOverridable Public Property UpVector As Single() _
Implements IBackdrop3DScene.UpVector
[C#]
public float[] UpVector {get; set;}

Implements

IBackdrop3DScene.UpVector

See Also

Backdrop3DScene Class | Aspose.Slides Namespace


Background Class

Represents background of a slide.

For a list of all members of this type, see Background Members.

System.Object
Aspose.Slides.Background

[Visual Basic]
Public Class Background
Implements IBackground, ISlideComponent, IPresentationComponent
[C#]
public class Background : IBackground, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Background Members | Aspose.Slides Namespace


Background Members

Background overview

Public Instance Properties

FillFormat | Returns a FillFormat for BackgroundType.OwnBackground fill. Readonly IFillFormat.
Presentation | Returns the parent presentation of a slide. Read-only Presentation.
Slide | Returns the parent slide of a shape. Read-only BaseSlide.
StyleColor | Return a ColorFormat for a BackgroundType.Themed fill. Readonly IColorFormat.
StyleIndex | Returns an index of BackgroundType.Themed fill in background theme collection. 0 means no fill. 1..999 - index.
Type | Returns a type of background fill. Read/write BackgroundType.

See Also

Background Class | Aspose.Slides Namespace


Background Properties

The properties of the Background class are listed below. For a complete list of Background class members, see the Background Members topic.

Public Instance Properties

FillFormat | Returns a FillFormat for BackgroundType.OwnBackground fill. Readonly IFillFormat.
Presentation | Returns the parent presentation of a slide. Read-only Presentation.
Slide | Returns the parent slide of a shape. Read-only BaseSlide.
StyleColor | Return a ColorFormat for a BackgroundType.Themed fill. Readonly IColorFormat.
StyleIndex | Returns an index of BackgroundType.Themed fill in background theme collection. 0 means no fill. 1..999 - index.
Type | Returns a type of background fill. Read/write BackgroundType.

See Also

Background Class | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

Background.FillFormat Property

Returns a FillFormat for BackgroundType.OwnBackground fill. Readonly IFillFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property FillFormat As IFillFormat _
Implements IBackground.FillFormat
[C#]
public IFillFormat FillFormat {get;}

Implements

IBackground.FillFormat

See Also

Background Class | Aspose.Slides Namespace


Presentation Property

Aspose.Slides Documentation

Background.Presentation Property

Returns the parent presentation of a slide. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

Background Class | Aspose.Slides Namespace


Slide Property

Aspose.Slides Documentation

Background.Slide Property

Returns the parent slide of a shape. Read-only BaseSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As IBaseSlide _
Implements ISlideComponent.Slide
[C#]
public IBaseSlide Slide {get;}

Implements

ISlideComponent.Slide

See Also

Background Class | Aspose.Slides Namespace


StyleColor Property

Aspose.Slides Documentation

Background.StyleColor Property

Return a ColorFormat for a BackgroundType.Themed fill. Readonly IColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property StyleColor As IColorFormat _
Implements IBackground.StyleColor
[C#]
public IColorFormat StyleColor {get;}

Implements

IBackground.StyleColor

See Also

Background Class | Aspose.Slides Namespace


StyleIndex Property

Aspose.Slides Documentation

Background.StyleIndex Property

Returns an index of BackgroundType.Themed fill in background theme collection. 0 means no fill. 1..999 - index.

[Visual Basic]
NotOverridable Public Property StyleIndex As UInt16 _
Implements IBackground.StyleIndex
[C#]
public ushort StyleIndex {get; set;}

Implements

IBackground.StyleIndex

See Also

Background Class | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

Background.Type Property

Returns a type of background fill. Read/write BackgroundType.

[Visual Basic]
NotOverridable Public Property Type As BackgroundType _
Implements IBackground.Type
[C#]
public BackgroundType Type {get; set;}

Implements

IBackground.Type

See Also

Background Class | Aspose.Slides Namespace


BackgroundType Enumeration

[Visual Basic]
Public Enum BackgroundType
Inherits
[C#]
public enum BackgroundType

Members

Member Name | Description | Value
NotDefined |  | -1
Themed |  | 0
OwnBackground |  | 1

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


BaseShapeLock Class

Represents a base class for locks (disabled operation).

For a list of all members of this type, see BaseShapeLock Members.

System.Object
Aspose.Slides.BaseShapeLock
Aspose.Slides.AutoShapeLock
Aspose.Slides.ConnectorLock
Aspose.Slides.GraphicalObjectLock
Aspose.Slides.GroupShapeLock
Aspose.Slides.PictureFrameLock

[Visual Basic]
Public Class BaseShapeLock
Implements IBaseShapeLock
[C#]
public class BaseShapeLock : IBaseShapeLock

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BaseShapeLock Members | Aspose.Slides Namespace


BaseShapeLock Members

BaseShapeLock overview

Public Instance Properties

NoLocks Return true if all lock-flags are disabled.

See Also

BaseShapeLock Class | Aspose.Slides Namespace


BaseShapeLock Properties

The properties of the BaseShapeLock class are listed below. For a complete list of BaseShapeLock class members, see the BaseShapeLock Members topic.

Public Instance Properties

NoLocks Return true if all lock-flags are disabled.

See Also

BaseShapeLock Class | Aspose.Slides Namespace


NoLocks Property

Aspose.Slides Documentation

BaseShapeLock.NoLocks Property

Return true if all lock-flags are disabled.

[Visual Basic]
NotOverridable Public ReadOnly Property NoLocks As Boolean _
Implements IBaseShapeLock.NoLocks
[C#]
public bool NoLocks {get;}

Implements

IBaseShapeLock.NoLocks

See Also

BaseShapeLock Class | Aspose.Slides Namespace


BaseSlide Class

Represents common data for all slide types.

For a list of all members of this type, see BaseSlide Members.

System.Object
Aspose.Slides.BaseSlide
Derived types

[Visual Basic]
MustInherit Public Class BaseSlide
Implements IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent
[C#]
public abstract class BaseSlide : IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BaseSlide Members | Aspose.Slides Namespace


BaseSlide Members

BaseSlide overview

Public Instance Properties

Background | Returns slide's background. Read only Background.
Controls | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData | Returns the slide's custom data. Read-only ICustomData.
HyperlinkQueries | Provides easy access to contained hyperlinks.
Name | Returns or sets the name of a slide. Read/write String.
ParentPresentation | Obsolete. Returns the parent presentation. Read-only Presentation.
Presentation |
Shapes | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId | Returns the ID of a slide.
SlideShowTransition | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
Timeline | Returns animation timeline object. Read-only AnimationTimeLine.

Public Instance Methods

ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective | Returns an effective theme for this slide.
FindShapeByAltText | Finds first occurrence of a shape with the specified alternative text.

See Also

BaseSlide Class | Aspose.Slides Namespace


BaseSlide Properties

The properties of the BaseSlide class are listed below. For a complete list of BaseSlide class members, see the BaseSlide Members topic.

Public Instance Properties

Background | Returns slide's background. Read only Background.
Controls | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData | Returns the slide's custom data. Read-only ICustomData.
HyperlinkQueries | Provides easy access to contained hyperlinks.
Name | Returns or sets the name of a slide. Read/write String.
ParentPresentation | Obsolete. Returns the parent presentation. Read-only Presentation.
Presentation |
Shapes | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId | Returns the ID of a slide.
SlideShowTransition | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
Timeline | Returns animation timeline object. Read-only AnimationTimeLine.

See Also

BaseSlide Class | Aspose.Slides Namespace


Background Property

Aspose.Slides Documentation

BaseSlide.Background Property

Returns slide's background. Read only Background.

[Visual Basic]
NotOverridable Public ReadOnly Property Background As IBackground _
Implements IBaseSlide.Background
[C#]
public IBackground Background {get;}

Implements

IBaseSlide.Background

See Also

BaseSlide Class | Aspose.Slides Namespace


Controls Property

Aspose.Slides Documentation

BaseSlide.Controls Property

Returns the collection of ActiveX controls on a slide. Read-only IControlCollection

[Visual Basic]
NotOverridable Public ReadOnly Property Controls As IControlCollection _
Implements IBaseSlide.Controls
[C#]
public IControlCollection Controls {get;}

Implements

IBaseSlide.Controls

See Also

BaseSlide Class | Aspose.Slides Namespace


CustomData Property

Aspose.Slides Documentation

BaseSlide.CustomData Property

Returns the slide's custom data. Read-only ICustomData.

[Visual Basic]
NotOverridable Public ReadOnly Property CustomData As ICustomData _
Implements IBaseSlide.CustomData
[C#]
public ICustomData CustomData {get;}

Implements

IBaseSlide.CustomData

See Also

BaseSlide Class | Aspose.Slides Namespace


HyperlinkQueries Property

Aspose.Slides Documentation

BaseSlide.HyperlinkQueries Property

Provides easy access to contained hyperlinks.

[Visual Basic]
NotOverridable Public ReadOnly Property HyperlinkQueries As IHyperlinkQueries _
Implements IBaseSlide.HyperlinkQueries
[C#]
public IHyperlinkQueries HyperlinkQueries {get;}

Implements

IBaseSlide.HyperlinkQueries

See Also

BaseSlide Class | Aspose.Slides Namespace


Name Property

Aspose.Slides Documentation

BaseSlide.Name Property

Returns or sets the name of a slide. Read/write String.

[Visual Basic]
Overridable Public Property Name As String _
Implements IBaseSlide.Name
[C#]
public virtual string Name {get; set;}

Implements

IBaseSlide.Name

See Also

BaseSlide Class | Aspose.Slides Namespace


ParentPresentation Property

Aspose.Slides Documentation

BaseSlide.ParentPresentation Property

NOTE: This property is now obsolete.

Use Presentation property instead. Property will be removed after 01.09.2013.

Returns the parent presentation. Read-only Presentation.

[Visual Basic]
Public ReadOnly Property ParentPresentation As IPresentation
[C#]
public IPresentation ParentPresentation {get;}

See Also

BaseSlide Class | Aspose.Slides Namespace


Presentation Property

Aspose.Slides Documentation

BaseSlide.Presentation Property

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

BaseSlide Class | Aspose.Slides Namespace


Shapes Property

Aspose.Slides Documentation

BaseSlide.Shapes Property

Returns the shapes of a slide. Read-only ShapeCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Shapes As IShapeCollection _
Implements IBaseSlide.Shapes
[C#]
public IShapeCollection Shapes {get;}

Implements

IBaseSlide.Shapes

See Also

BaseSlide Class | Aspose.Slides Namespace


SlideId Property

Aspose.Slides Documentation

BaseSlide.SlideId Property

Returns the ID of a slide.

[Visual Basic]
NotOverridable Public ReadOnly Property SlideId As UInt32 _
Implements IBaseSlide.SlideId
[C#]
public uint SlideId {get;}

Implements

IBaseSlide.SlideId

See Also

BaseSlide Class | Aspose.Slides Namespace


SlideShowTransition Property

Aspose.Slides Documentation

BaseSlide.SlideShowTransition Property

Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.

[Visual Basic]
Overridable Public ReadOnly Property SlideShowTransition As ISlideShowTransition _
Implements IBaseSlide.SlideShowTransition
[C#]
public virtual ISlideShowTransition SlideShowTransition {get;}

Implements

IBaseSlide.SlideShowTransition

See Also

BaseSlide Class | Aspose.Slides Namespace


Tags Property

Aspose.Slides Documentation

BaseSlide.Tags Property

NOTE: This property is now obsolete.

Use CustomData.Tags instead. Will be removed after 01.09.2014.

Returns the slide's tags collection. Read-only TagCollection.

[Visual Basic]
Public ReadOnly Property Tags As ITagCollection
[C#]
public ITagCollection Tags {get;}

See Also

BaseSlide Class | Aspose.Slides Namespace


Timeline Property

Aspose.Slides Documentation

BaseSlide.Timeline Property

Returns animation timeline object. Read-only AnimationTimeLine.

[Visual Basic]
NotOverridable Public ReadOnly Property Timeline As IAnimationTimeLine _
Implements IBaseSlide.Timeline
[C#]
public IAnimationTimeLine Timeline {get;}

Implements

IBaseSlide.Timeline

See Also

BaseSlide Class | Aspose.Slides Namespace


BaseSlide Methods

The methods of the BaseSlide class are listed below. For a complete list of BaseSlide class members, see the BaseSlide Members topic.

Public Instance Methods

ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective | Returns an effective theme for this slide.
FindShapeByAltText | Finds first occurrence of a shape with the specified alternative text.

See Also

BaseSlide Class | Aspose.Slides Namespace


BaseSlide.ApplyColorScheme Method

NOTE: This method is now obsolete.

Use ThemeManager.ApplyColorScheme(..) method instead. Will be removed after 01.09.2013.

Applies extra color scheme to a slide.

[Visual Basic]
MustOverride Public Sub ApplyColorScheme( _
ByVal scheme As ExtraColorScheme _
)
[C#]
public abstract void ApplyColorScheme(
ExtraColorScheme scheme
);

Parameters

scheme

See Also

BaseSlide Class | Aspose.Slides Namespace


BaseSlide.CreateThemeEffective Method

Returns an effective theme for this slide.

[Visual Basic]
NotOverridable Public Function CreateThemeEffective() As IThemeEffectiveData _
Implements IThemeable.CreateThemeEffective
[C#]
public IThemeEffectiveData CreateThemeEffective();

Implements

IThemeable.CreateThemeEffective

See Also

BaseSlide Class | Aspose.Slides Namespace


BaseSlide.FindShapeByAltText Method

Finds first occurrence of a shape with the specified alternative text.

[Visual Basic]
NotOverridable Public Function FindShapeByAltText( _
ByVal altText As String _
) As IShape _
Implements IBaseSlide.FindShapeByAltText
[C#]
public IShape FindShapeByAltText(
string altText
);

Parameters

altText
Alternative text.

Return Value

Shape object or null.

Implements

IBaseSlide.FindShapeByAltText

See Also

BaseSlide Class | Aspose.Slides Namespace


BevelColorMode Enumeration

[Visual Basic]
Public Enum BevelColorMode
[C#]
public enum BevelColorMode

Members

Member Name | Description | Value
Contour |  | 0
Extrusion |  | 1

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


BevelPresetType Enumeration

[Visual Basic]
Public Enum BevelPresetType
[C#]
public enum BevelPresetType

Members

Member Name | Description | Value
NotDefined |  | -1
Angle |  | 0
ArtDeco |  | 1
Circle |  | 2
Convex |  | 3
CoolSlant |  | 4
Cross |  | 5
Divot |  | 6
HardEdge |  | 7
RelaxedInset |  | 8
Riblet |  | 9
Slope |  | 10
SoftRound |  | 11

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


BlackWhiteMode Enumeration

[Visual Basic]
Public Enum BlackWhiteMode
Inherits
[C#]
public enum BlackWhiteMode

Members

Member Name | Description | Value
NotDefined |  | -1
Color |  | 0
Automatic |  | 1
Gray |  | 2
LightGray |  | 3
InverseGray |  | 4
GrayWhite |  | 5
BlackGray |  | 6
BlackWhite |  | 7
Black |  | 8
White |  | 9
Hidden |  | 10

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


BuildVersionInfo Class

Contains information about version of Aspose.Slides.

For a list of all members of this type, see BuildVersionInfo Members.

System.Object
Aspose.Slides.BuildVersionInfo

[Visual Basic]
NotInheritable Public Class BuildVersionInfo
[C#]
public sealed class BuildVersionInfo

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BuildVersionInfo Members | Aspose.Slides Namespace


BuildVersionInfo Members

BuildVersionInfo overview

Public Static (Shared) Fields

AssemblyVersion | Version of Aspose.Slides assembly.
FileVersion | Version of assembly file.
Product | Product name of Aspose.Slides
ProductMajor | Major version number.
ProductMinor | Minor version number.
ReleaseDate | Release date of the assembly.

See Also

BuildVersionInfo Class | Aspose.Slides Namespace


BuildVersionInfo Fields

The fields of the BuildVersionInfo class are listed below. For a complete list of BuildVersionInfo class members, see the BuildVersionInfo Members topic.

Public Static (Shared) Fields

AssemblyVersion | Version of Aspose.Slides assembly.
FileVersion | Version of assembly file.
Product | Product name of Aspose.Slides
ProductMajor | Major version number.
ProductMinor | Minor version number.
ReleaseDate | Release date of the assembly.

See Also

BuildVersionInfo Class | Aspose.Slides Namespace


BuildVersionInfo.AssemblyVersion Field

Version of Aspose.Slides assembly.

[Visual Basic]
Public Shared ReadOnly AssemblyVersion As String
[C#]
public static readonly string AssemblyVersion;

See Also

BuildVersionInfo Class | Aspose.Slides Namespace


BuildVersionInfo.FileVersion Field

Version of assembly file.

[Visual Basic]
Public Shared ReadOnly FileVersion As String
[C#]
public static readonly string FileVersion;

See Also

BuildVersionInfo Class | Aspose.Slides Namespace


BuildVersionInfo.Product Field

Product name of Aspose.Slides

[Visual Basic]
Public Shared ReadOnly Product As String
[C#]
public static readonly string Product;

See Also

BuildVersionInfo Class | Aspose.Slides Namespace


BuildVersionInfo.ProductMajor Field

Major version number.

[Visual Basic]
Public Shared ReadOnly ProductMajor As Integer
[C#]
public static readonly int ProductMajor;

See Also

BuildVersionInfo Class | Aspose.Slides Namespace


BuildVersionInfo.ProductMinor Field

Minor version number.

[Visual Basic]
Public Shared ReadOnly ProductMinor As Integer
[C#]
public static readonly int ProductMinor;

See Also

BuildVersionInfo Class | Aspose.Slides Namespace


BuildVersionInfo.ReleaseDate Field

Release date of the assembly.

[Visual Basic]
Public Shared ReadOnly ReleaseDate As Date
[C#]
public static readonly DateTime ReleaseDate;

See Also

BuildVersionInfo Class | Aspose.Slides Namespace


BulletFormat Class

For a list of all members of this type, see BulletFormat Members.

System.Object
Aspose.Slides.BulletFormat

[Visual Basic]
NotInheritable Public Class BulletFormat
Implements IBulletFormat
[C#]
public sealed class BulletFormat : IBulletFormat

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BulletFormat Members | Aspose.Slides Namespace


BulletFormat Members

BulletFormat overview

Public Instance Properties

Char | Returns or sets the bullet char of a paragraph with no inheritance. Read/write Char.
Color | Returns the color format of a bullet of a paragraph with no inheritance. Read-only ColorFormat.
Font | Returns or sets the bullet font of a paragraph with no inheritance. Read/write FontData.
Height | Returns or sets the bullet height of a paragraph with no inheritance. Value float.NaN determines that bullet inherits height from the first portion in the paragraph. Read/write Single.
IsBulletHardColor | Determines whether the bullet has own color or inherits it from the first portion in the paragraph. NullableBool.True if bullet has own color and NullableBool.False if bullet inherits color from the first portion in the paragraph. Read/write NullableBool.
IsBulletHardFont | Determines whether the bullet has own font or inherits it from the first portion in the paragraph. NullableBool.True if bullet has own font and NullableBool.False if bullet inherits font from the first portion in the paragraph. Read/write NullableBool.
NumberedBulletStartWith | Returns or sets the first number which is used for group of numbered bullets with no inheritance. Read/write Int16.
NumberedBulletStyle | Returns or sets the style of a numbered bullet with no inheritance. Read/write NumberedBulletStyle.
Type | Returns or sets the bullet type of a paragraph with no inheritance. Read/write BulletType.

See Also

BulletFormat Class | Aspose.Slides Namespace


BulletFormat Properties

The properties of the BulletFormat class are listed below. For a complete list of BulletFormat class members, see the BulletFormat Members topic.

Public Instance Properties

Char | Returns or sets the bullet char of a paragraph with no inheritance. Read/write Char.
Color | Returns the color format of a bullet of a paragraph with no inheritance. Read-only ColorFormat.
Font | Returns or sets the bullet font of a paragraph with no inheritance. Read/write FontData.
Height | Returns or sets the bullet height of a paragraph with no inheritance. Value float.NaN determines that bullet inherits height from the first portion in the paragraph. Read/write Single.
IsBulletHardColor | Determines whether the bullet has own color or inherits it from the first portion in the paragraph. NullableBool.True if bullet has own color and NullableBool.False if bullet inherits color from the first portion in the paragraph. Read/write NullableBool.
IsBulletHardFont | Determines whether the bullet has own font or inherits it from the first portion in the paragraph. NullableBool.True if bullet has own font and NullableBool.False if bullet inherits font from the first portion in the paragraph. Read/write NullableBool.
NumberedBulletStartWith | Returns or sets the first number which is used for group of numbered bullets with no inheritance. Read/write Int16.
NumberedBulletStyle | Returns or sets the style of a numbered bullet with no inheritance. Read/write NumberedBulletStyle.
Type | Returns or sets the bullet type of a paragraph with no inheritance. Read/write BulletType.

See Also

BulletFormat Class | Aspose.Slides Namespace


Char Property

Aspose.Slides Documentation

BulletFormat.Char Property

Returns or sets the bullet char of a paragraph with no inheritance. Read/write Char.

[Visual Basic]
NotOverridable Public Property Char As Char _
Implements IBulletFormat.Char
[C#]
public char Char {get; set;}

Implements

IBulletFormat.Char

See Also

BulletFormat Class | Aspose.Slides Namespace


Color Property

Aspose.Slides Documentation

BulletFormat.Color Property

Returns the color format of a bullet of a paragraph with no inheritance. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Color As IColorFormat _
Implements IBulletFormat.Color
[C#]
public IColorFormat Color {get;}

Implements

IBulletFormat.Color

See Also

BulletFormat Class | Aspose.Slides Namespace


Font Property

Aspose.Slides Documentation

BulletFormat.Font Property

Returns or sets the bullet font of a paragraph with no inheritance. Read/write FontData.

[Visual Basic]
NotOverridable Public Property Font As IFontData _
Implements IBulletFormat.Font
[C#]
public IFontData Font {get; set;}

Implements

IBulletFormat.Font

See Also

BulletFormat Class | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

BulletFormat.Height Property

Returns or sets the bullet height of a paragraph with no inheritance. Value float.NaN determines that bullet inherits height from the first portion in the paragraph. Read/write Single.

[Visual Basic]
NotOverridable Public Property Height As Single _
Implements IBulletFormat.Height
[C#]
public float Height {get; set;}

Implements

IBulletFormat.Height

See Also

BulletFormat Class | Aspose.Slides Namespace


IsBulletHardColor Property

Aspose.Slides Documentation

BulletFormat.IsBulletHardColor Property

Determines whether the bullet has own color or inherits it from the first portion in the paragraph. NullableBool.True if bullet has own color and NullableBool.False if bullet inherits color from the first portion in the paragraph. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property IsBulletHardColor As NullableBool _
Implements IBulletFormat.IsBulletHardColor
[C#]
public NullableBool IsBulletHardColor {get; set;}

Implements

IBulletFormat.IsBulletHardColor

See Also

BulletFormat Class | Aspose.Slides Namespace


IsBulletHardFont Property

Aspose.Slides Documentation

BulletFormat.IsBulletHardFont Property

Determines whether the bullet has own font or inherits it from the first portion in the paragraph. NullableBool.True if bullet has own font and NullableBool.False if bullet inherits font from the first portion in the paragraph. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property IsBulletHardFont As NullableBool _
Implements IBulletFormat.IsBulletHardFont
[C#]
public NullableBool IsBulletHardFont {get; set;}

Implements

IBulletFormat.IsBulletHardFont

See Also

BulletFormat Class | Aspose.Slides Namespace


NumberedBulletStartWith Property

Aspose.Slides Documentation

BulletFormat.NumberedBulletStartWith Property

Returns or sets the first number which is used for group of numbered bullets with no inheritance. Read/write Int16.

[Visual Basic]
NotOverridable Public Property NumberedBulletStartWith As Short _
Implements IBulletFormat.NumberedBulletStartWith
[C#]
public short NumberedBulletStartWith {get; set;}

Implements

IBulletFormat.NumberedBulletStartWith

See Also

BulletFormat Class | Aspose.Slides Namespace


NumberedBulletStyle Property

Aspose.Slides Documentation

BulletFormat.NumberedBulletStyle Property

Returns or sets the style of a numbered bullet with no inheritance. Read/write NumberedBulletStyle.

[Visual Basic]
NotOverridable Public Property NumberedBulletStyle As NumberedBulletStyle _
Implements IBulletFormat.NumberedBulletStyle
[C#]
public NumberedBulletStyle NumberedBulletStyle {get; set;}

Implements

IBulletFormat.NumberedBulletStyle

See Also

BulletFormat Class | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

BulletFormat.Type Property

Returns or sets the bullet type of a paragraph with no inheritance. Read/write BulletType.

[Visual Basic]
NotOverridable Public Property Type As BulletType _
Implements IBulletFormat.Type
[C#]
public BulletType Type {get; set;}

Implements

IBulletFormat.Type

See Also

BulletFormat Class | Aspose.Slides Namespace


BulletFormatEffectiveData Class

Immutable object which contains the paragraph's formatting properties.

For a list of all members of this type, see BulletFormatEffectiveData Members.

System.Object
Aspose.Slides.BulletFormatEffectiveData

[Visual Basic]
Public Class BulletFormatEffectiveData
Implements IBulletFormatEffectiveData
[C#]
public class BulletFormatEffectiveData : IBulletFormatEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BulletFormatEffectiveData Members | Aspose.Slides Namespace


BulletFormatEffectiveData Members

BulletFormatEffectiveData overview

Public Instance Properties

Char | Returns the bullet char of a paragraph. Readonly Char.
Color | Returns or sets the color of a bullet. Read-only Color.
Font | Returns the bullet font of a paragraph. Readonly FontData.
Height | Returns the bullet height of a paragraph. Readonly Single.
NumberedBulletStartWith | Returns the first number which is used for group of numbered bullets. Readonly Int16.
NumberedBulletStyle | Returns the style of a numbered bullet. Readonly NumberedBulletStyle.
Type | Returns the bullet type of a paragraph. Readonly BulletType.

See Also

BulletFormatEffectiveData Class | Aspose.Slides Namespace


BulletFormatEffectiveData Properties

The properties of the BulletFormatEffectiveData class are listed below. For a complete list of BulletFormatEffectiveData class members, see the BulletFormatEffectiveData Members topic.

Public Instance Properties

Char | Returns the bullet char of a paragraph. Readonly Char.
Color | Returns or sets the color of a bullet. Read-only Color.
Font | Returns the bullet font of a paragraph. Readonly FontData.
Height | Returns the bullet height of a paragraph. Readonly Single.
NumberedBulletStartWith | Returns the first number which is used for group of numbered bullets. Readonly Int16.
NumberedBulletStyle | Returns the style of a numbered bullet. Readonly NumberedBulletStyle.
Type | Returns the bullet type of a paragraph. Readonly BulletType.

See Also

BulletFormatEffectiveData Class | Aspose.Slides Namespace


Char Property

Aspose.Slides Documentation

BulletFormatEffectiveData.Char Property

Returns the bullet char of a paragraph. Readonly Char.

[Visual Basic]
NotOverridable Public ReadOnly Property Char As Char _
Implements IBulletFormatEffectiveData.Char
[C#]
public char Char {get;}

Implements

IBulletFormatEffectiveData.Char

See Also

BulletFormatEffectiveData Class | Aspose.Slides Namespace


Color Property

Aspose.Slides Documentation

BulletFormatEffectiveData.Color Property

Returns or sets the color of a bullet. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Color As Color _
Implements IBulletFormatEffectiveData.Color
[C#]
public Color Color {get;}

Implements

IBulletFormatEffectiveData.Color

See Also

BulletFormatEffectiveData Class | Aspose.Slides Namespace


Font Property

Aspose.Slides Documentation

BulletFormatEffectiveData.Font Property

Returns the bullet font of a paragraph. Readonly FontData.

[Visual Basic]
NotOverridable Public ReadOnly Property Font As IFontData _
Implements IBulletFormatEffectiveData.Font
[C#]
public IFontData Font {get;}

Implements

IBulletFormatEffectiveData.Font

See Also

BulletFormatEffectiveData Class | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

BulletFormatEffectiveData.Height Property

Returns the bullet height of a paragraph. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Height As Single _
Implements IBulletFormatEffectiveData.Height
[C#]
public float Height {get;}

Implements

IBulletFormatEffectiveData.Height

See Also

BulletFormatEffectiveData Class | Aspose.Slides Namespace


NumberedBulletStartWith Property

Aspose.Slides Documentation

BulletFormatEffectiveData.NumberedBulletStartWith Property

Returns the first number which is used for group of numbered bullets. Readonly Int16.

[Visual Basic]
NotOverridable Public ReadOnly Property NumberedBulletStartWith As Short _
Implements IBulletFormatEffectiveData.NumberedBulletStartWith
[C#]
public short NumberedBulletStartWith {get;}

Implements

IBulletFormatEffectiveData.NumberedBulletStartWith

See Also

BulletFormatEffectiveData Class | Aspose.Slides Namespace


NumberedBulletStyle Property

Aspose.Slides Documentation

BulletFormatEffectiveData.NumberedBulletStyle Property

Returns the style of a numbered bullet. Readonly NumberedBulletStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property NumberedBulletStyle As NumberedBulletStyle _
Implements IBulletFormatEffectiveData.NumberedBulletStyle
[C#]
public NumberedBulletStyle NumberedBulletStyle {get;}

Implements

IBulletFormatEffectiveData.NumberedBulletStyle

See Also

BulletFormatEffectiveData Class | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

BulletFormatEffectiveData.Type Property

Returns the bullet type of a paragraph. Readonly BulletType.

[Visual Basic]
NotOverridable Public ReadOnly Property Type As BulletType _
Implements IBulletFormatEffectiveData.Type
[C#]
public BulletType Type {get;}

Implements

IBulletFormatEffectiveData.Type

See Also

BulletFormatEffectiveData Class | Aspose.Slides Namespace


BulletType Enumeration

[Visual Basic]
Public Enum BulletType
Inherits
[C#]
public enum BulletType

Members

Member Name | Description | Value
NotDefined |  | -1
None |  | 0
Symbol |  | 1
Numbered |  | 2
Picture |  | 3

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


Camera Class

Represents Camera.

For a list of all members of this type, see Camera Members.

System.Object
Aspose.Slides.Camera

[Visual Basic]
Public Class Camera
Implements ICamera
[C#]
public class Camera : ICamera

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Camera Members | Aspose.Slides Namespace


Camera Members

Camera overview

Public Instance Constructors

Camera Constructor Default constructor.

Public Instance Properties

CameraType | Camera type Read/write CameraPresetType
FieldOfViewAngle | Camera FOV (0-180 deg, field of View) Read/write Single
Zoom | Camera zoom (positive value in percentage) Read/write Single

Public Instance Methods

Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRotation | A rotation is defined through the use of a latitude coordinate, a longitude coordinate, and a revolution about the axis as the latitude and longitude coordinates. first element in return array - latitude, second - longitude, third - revolution. Returns null if no rotation defined.
SetRotation | A rotation is defined through the use of a latitude coordinate, a longitude coordinate, and a revolution about the axis as the latitude and longitude coordinates. If any of coordinate value is Float.NaN, all rotation is undefined.

See Also

Camera Class | Aspose.Slides Namespace


Camera Constructor

Default constructor.

[Visual Basic]
Public Sub New()
[C#]
public Camera();

See Also

Camera Class | Aspose.Slides Namespace


Camera Properties

The properties of the Camera class are listed below. For a complete list of Camera class members, see the Camera Members topic.

Public Instance Properties

CameraType | Camera type Read/write CameraPresetType
FieldOfViewAngle | Camera FOV (0-180 deg, field of View) Read/write Single
Zoom | Camera zoom (positive value in percentage) Read/write Single

See Also

Camera Class | Aspose.Slides Namespace


CameraType Property

Aspose.Slides Documentation

Camera.CameraType Property

Camera type Read/write CameraPresetType

[Visual Basic]
NotOverridable Public Property CameraType As CameraPresetType _
Implements ICamera.CameraType
[C#]
public CameraPresetType CameraType {get; set;}

Implements

ICamera.CameraType

See Also

Camera Class | Aspose.Slides Namespace


FieldOfViewAngle Property

Aspose.Slides Documentation

Camera.FieldOfViewAngle Property

Camera FOV (0-180 deg, field of View) Read/write Single

[Visual Basic]
NotOverridable Public Property FieldOfViewAngle As Single _
Implements ICamera.FieldOfViewAngle
[C#]
public float FieldOfViewAngle {get; set;}

Implements

ICamera.FieldOfViewAngle

See Also

Camera Class | Aspose.Slides Namespace


Zoom Property

Aspose.Slides Documentation

Camera.Zoom Property

Camera zoom (positive value in percentage) Read/write Single

[Visual Basic]
NotOverridable Public Property Zoom As Single _
Implements ICamera.Zoom
[C#]
public float Zoom {get; set;}

Implements

ICamera.Zoom

See Also

Camera Class | Aspose.Slides Namespace


Camera Methods

The methods of the Camera class are listed below. For a complete list of Camera class members, see the Camera Members topic.

Public Instance Methods

Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRotation | A rotation is defined through the use of a latitude coordinate, a longitude coordinate, and a revolution about the axis as the latitude and longitude coordinates. first element in return array - latitude, second - longitude, third - revolution. Returns null if no rotation defined.
SetRotation | A rotation is defined through the use of a latitude coordinate, a longitude coordinate, and a revolution about the axis as the latitude and longitude coordinates. If any of coordinate value is Float.NaN, all rotation is undefined.

See Also

Camera Class | Aspose.Slides Namespace


Camera.Equals Method

Determines whether two FillFormat instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

See Also

Camera Class | Aspose.Slides Namespace


Camera.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Remarks

Overriden to make compiler happy.

See Also

Camera Class | Aspose.Slides Namespace


Camera.GetRotation Method

A rotation is defined through the use of a latitude coordinate, a longitude coordinate, and a revolution about the axis as the latitude and longitude coordinates. first element in return array - latitude, second - longitude, third - revolution. Returns null if no rotation defined.

[Visual Basic]
NotOverridable Public Function GetRotation() As Single() _
Implements ICamera.GetRotation
[C#]
public float[] GetRotation();

Implements

ICamera.GetRotation

See Also

Camera Class | Aspose.Slides Namespace


Camera.SetRotation Method

A rotation is defined through the use of a latitude coordinate, a longitude coordinate, and a revolution about the axis as the latitude and longitude coordinates. If any of coordinate value is Float.NaN, all rotation is undefined.

[Visual Basic]
NotOverridable Public Sub SetRotation( _
ByVal latitude As Single, _
ByVal longitude As Single, _
ByVal revolution As Single _
) _
Implements ICamera.SetRotation
[C#]
public void SetRotation(
float latitude,
float longitude,
float revolution
);

Implements

ICamera.SetRotation

See Also

Camera Class | Aspose.Slides Namespace


CameraPresetType Enumeration

[Visual Basic]
Public Enum CameraPresetType
[C#]
public enum CameraPresetType

Members

Member Name | Description | Value
NotDefined |  | -1
IsometricBottomDown |  | 0
IsometricBottomUp |  | 1
IsometricLeftDown |  | 2
IsometricLeftUp |  | 3
IsometricOffAxis1Left |  | 4
IsometricOffAxis1Right |  | 5
IsometricOffAxis1Top |  | 6
IsometricOffAxis2Left |  | 7
IsometricOffAxis2Right |  | 8
IsometricOffAxis2Top |  | 9
IsometricOffAxis3Bottom |  | 10
IsometricOffAxis3Left |  | 11
IsometricOffAxis3Right |  | 12
IsometricOffAxis4Bottom |  | 13
IsometricOffAxis4Left |  | 14
IsometricOffAxis4Right |  | 15
IsometricRightDown |  | 16
IsometricRightUp |  | 17
IsometricTopDown |  | 18
IsometricTopUp |  | 19
LegacyObliqueBottom |  | 20
LegacyObliqueBottomLeft |  | 21
LegacyObliqueBottomRight |  | 22
LegacyObliqueFront |  | 23
LegacyObliqueLeft |  | 24
LegacyObliqueRight |  | 25
LegacyObliqueTop |  | 26
LegacyObliqueTopLeft |  | 27
LegacyObliqueTopRight |  | 28
LegacyPerspectiveBottom |  | 29
LegacyPerspectiveBottomLeft |  | 30
LegacyPerspectiveBottomRight |  | 31
LegacyPerspectiveFront |  | 32
LegacyPerspectiveLeft |  | 33
LegacyPerspectiveRight |  | 34
LegacyPerspectiveTop |  | 35
LegacyPerspectiveTopLeft |  | 36
LegacyPerspectiveTopRight |  | 37
ObliqueBottom |  | 38
ObliqueBottomLeft |  | 39
ObliqueBottomRight |  | 40
ObliqueLeft |  | 41
ObliqueRight |  | 42
ObliqueTop |  | 43
ObliqueTopLeft |  | 44
ObliqueTopRight |  | 45
OrthographicFront |  | 46
PerspectiveAbove |  | 47
PerspectiveAboveLeftFacing |  | 48
PerspectiveAboveRightFacing |  | 49
PerspectiveBelow |  | 50
PerspectiveContrastingLeftFacing |  | 51
PerspectiveContrastingRightFacing |  | 52
PerspectiveFront |  | 53
PerspectiveHeroicExtremeLeftFacing |  | 54
PerspectiveHeroicExtremeRightFacing |  | 55
PerspectiveHeroicLeftFacing |  | 56
PerspectiveHeroicRightFacing |  | 57
PerspectiveLeft |  | 58
PerspectiveRelaxed |  | 59
PerspectiveRelaxedModerately |  | 60
PerspectiveRight |  | 61

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


Cell Class

Represents a cell of a table.

For a list of all members of this type, see Cell Members.

System.Object
Aspose.Slides.Cell

[Visual Basic]
Public Class Cell
Implements ICell, ISlideComponent, IPresentationComponent
[C#]
public class Cell : ICell, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Cell Members | Aspose.Slides Namespace


Cell Members

Cell overview

Public Instance Properties

AnchorCenter | Determines whether or not text box centered inside a cell. Read/write Boolean.
BorderBottom | Returns a bottom border line properties object. Read-only LineFormat.
BorderDiagonalDown | Returns a top-left to bottom-right diagonal line properties object. Read-only LineFormat.
BorderDiagonalUp | Returns a bottom-left to top-right diagonal line properties object. Read-only LineFormat.
BorderLeft | Returns a left border line properties object. Read-only LineFormat.
BorderRight | Returns a right border line properties object. Read-only LineFormat.
BorderTop | Returns a top border line properties object. Read-only LineFormat.
ColSpan | Returns the number of grid columns in the parent table's table grid which shall be spanned by the current cell. This property allows cells to have the appearance of being merged, as they span vertical boundaries of other cells in the table. Read-only Int32.
FillFormat | Returns a cell fill properties object. Read-only FillFormat.
FirstColumn | Gets first column of cell.
FirstColumnIndex | Returns an index of first column, covered by the cell. Read-only Int32.
FirstRow | Gets first row of cell.
FirstRowIndex | Returns an index of first row, covered by the cell. Read-only Int32.
Height | Returns the height of the cell. Read-only Double.
MarginBottom | Returns or sets the bottom margin in a TextFrame. Read/write Double.
MarginLeft | Returns or sets the left margin in a TextFrame. Read/write Double.
MarginRight | Returns or sets the right margin in a TextFrame. Read/write Double.
MarginTop | Returns or sets the top margin in a TextFrame. Read/write Double.
MinimalHeight | Returns the minimum height of a cell. This is a sum of minimal heights of all rows cowered by the cell. Read-only Double.
OffsetX | Returns a distance from left side of a table to left side of a cell. Read-only Double.
OffsetY | Returns a distance from top side of a table to top side of a cell. Read-only Double.
Presentation | Returns the parent presentation of a cell. Read-only Presentation.
RowSpan | Returns the number of rows that a merged cell spans. This is used in combination with the vMerge attribute on other cells in order to specify the beginning cell of a horizontal merge. Read-only Int32.
Slide | Returns the parent slide of a cell. Read-only BaseSlide.
Table | Returns the parent Table object for a cell. Read-only Table.
TextAnchorType | Returns or sets the text anchor type. Read/write TextAnchorType.
TextFrame | Returns the text frame of a cell. Read-only TextFrame.
TextVerticalType | Returns or sets the type of vertical text. Read/write TextVerticalType.
Width | Returns the width of the cell. Read-only Double.

Public Instance Methods

SplitByColSpan | Splits the cell to two cells by index of column.
SplitByHeight | Splits the cell by height.
SplitByRowSpan | Splits the cell to two cells by index of row.
SplitByWidth | Splits the cell by width.

See Also

Cell Class | Aspose.Slides Namespace


Cell Properties

The properties of the Cell class are listed below. For a complete list of Cell class members, see the Cell Members topic.

Public Instance Properties

AnchorCenter | Determines whether or not text box centered inside a cell. Read/write Boolean.
BorderBottom | Returns a bottom border line properties object. Read-only LineFormat.
BorderDiagonalDown | Returns a top-left to bottom-right diagonal line properties object. Read-only LineFormat.
BorderDiagonalUp | Returns a bottom-left to top-right diagonal line properties object. Read-only LineFormat.
BorderLeft | Returns a left border line properties object. Read-only LineFormat.
BorderRight | Returns a right border line properties object. Read-only LineFormat.
BorderTop | Returns a top border line properties object. Read-only LineFormat.
ColSpan | Returns the number of grid columns in the parent table's table grid which shall be spanned by the current cell. This property allows cells to have the appearance of being merged, as they span vertical boundaries of other cells in the table. Read-only Int32.
FillFormat | Returns a cell fill properties object. Read-only FillFormat.
FirstColumn | Gets first column of cell.
FirstColumnIndex | Returns an index of first column, covered by the cell. Read-only Int32.
FirstRow | Gets first row of cell.
FirstRowIndex | Returns an index of first row, covered by the cell. Read-only Int32.
Height | Returns the height of the cell. Read-only Double.
MarginBottom | Returns or sets the bottom margin in a TextFrame. Read/write Double.
MarginLeft | Returns or sets the left margin in a TextFrame. Read/write Double.
MarginRight | Returns or sets the right margin in a TextFrame. Read/write Double.
MarginTop | Returns or sets the top margin in a TextFrame. Read/write Double.
MinimalHeight | Returns the minimum height of a cell. This is a sum of minimal heights of all rows cowered by the cell. Read-only Double.
OffsetX | Returns a distance from left side of a table to left side of a cell. Read-only Double.
OffsetY | Returns a distance from top side of a table to top side of a cell. Read-only Double.
Presentation | Returns the parent presentation of a cell. Read-only Presentation.
RowSpan | Returns the number of rows that a merged cell spans. This is used in combination with the vMerge attribute on other cells in order to specify the beginning cell of a horizontal merge. Read-only Int32.
Slide | Returns the parent slide of a cell. Read-only BaseSlide.
Table | Returns the parent Table object for a cell. Read-only Table.
TextAnchorType | Returns or sets the text anchor type. Read/write TextAnchorType.
TextFrame | Returns the text frame of a cell. Read-only TextFrame.
TextVerticalType | Returns or sets the type of vertical text. Read/write TextVerticalType.
Width | Returns the width of the cell. Read-only Double.

See Also

Cell Class | Aspose.Slides Namespace


AnchorCenter Property

Aspose.Slides Documentation

Cell.AnchorCenter Property

Determines whether or not text box centered inside a cell. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property AnchorCenter As Boolean _
Implements ICell.AnchorCenter
[C#]
public bool AnchorCenter {get; set;}

Implements

ICell.AnchorCenter

See Also

Cell Class | Aspose.Slides Namespace


BorderBottom Property

Aspose.Slides Documentation

Cell.BorderBottom Property

Returns a bottom border line properties object. Read-only LineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property BorderBottom As ILineFormat _
Implements ICell.BorderBottom
[C#]
public ILineFormat BorderBottom {get;}

Implements

ICell.BorderBottom

See Also

Cell Class | Aspose.Slides Namespace


BorderDiagonalDown Property

Aspose.Slides Documentation

Cell.BorderDiagonalDown Property

Returns a top-left to bottom-right diagonal line properties object. Read-only LineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property BorderDiagonalDown As ILineFormat _
Implements ICell.BorderDiagonalDown
[C#]
public ILineFormat BorderDiagonalDown {get;}

Implements

ICell.BorderDiagonalDown

See Also

Cell Class | Aspose.Slides Namespace


BorderDiagonalUp Property

Aspose.Slides Documentation

Cell.BorderDiagonalUp Property

Returns a bottom-left to top-right diagonal line properties object. Read-only LineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property BorderDiagonalUp As ILineFormat _
Implements ICell.BorderDiagonalUp
[C#]
public ILineFormat BorderDiagonalUp {get;}

Implements

ICell.BorderDiagonalUp

See Also

Cell Class | Aspose.Slides Namespace


BorderLeft Property

Aspose.Slides Documentation

Cell.BorderLeft Property

Returns a left border line properties object. Read-only LineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property BorderLeft As ILineFormat _
Implements ICell.BorderLeft
[C#]
public ILineFormat BorderLeft {get;}

Implements

ICell.BorderLeft

See Also

Cell Class | Aspose.Slides Namespace


BorderRight Property

Aspose.Slides Documentation

Cell.BorderRight Property

Returns a right border line properties object. Read-only LineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property BorderRight As ILineFormat _
Implements ICell.BorderRight
[C#]
public ILineFormat BorderRight {get;}

Implements

ICell.BorderRight

See Also

Cell Class | Aspose.Slides Namespace


BorderTop Property

Aspose.Slides Documentation

Cell.BorderTop Property

Returns a top border line properties object. Read-only LineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property BorderTop As ILineFormat _
Implements ICell.BorderTop
[C#]
public ILineFormat BorderTop {get;}

Implements

ICell.BorderTop

See Also

Cell Class | Aspose.Slides Namespace


ColSpan Property

Aspose.Slides Documentation

Cell.ColSpan Property

Returns the number of grid columns in the parent table's table grid which shall be spanned by the current cell. This property allows cells to have the appearance of being merged, as they span vertical boundaries of other cells in the table. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property ColSpan As Integer _
Implements ICell.ColSpan
[C#]
public int ColSpan {get;}

Implements

ICell.ColSpan

See Also

Cell Class | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

Cell.FillFormat Property

Returns a cell fill properties object. Read-only FillFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property FillFormat As IFillFormat _
Implements ICell.FillFormat
[C#]
public IFillFormat FillFormat {get;}

Implements

ICell.FillFormat

See Also

Cell Class | Aspose.Slides Namespace


FirstColumn Property

Aspose.Slides Documentation

Cell.FirstColumn Property

Gets first column of cell.

[Visual Basic]
NotOverridable Public ReadOnly Property FirstColumn As IColumn _
Implements ICell.FirstColumn
[C#]
public IColumn FirstColumn {get;}

Implements

ICell.FirstColumn

See Also

Cell Class | Aspose.Slides Namespace


FirstColumnIndex Property

Aspose.Slides Documentation

Cell.FirstColumnIndex Property

Returns an index of first column, covered by the cell. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property FirstColumnIndex As Integer _
Implements ICell.FirstColumnIndex
[C#]
public int FirstColumnIndex {get;}

Implements

ICell.FirstColumnIndex

See Also

Cell Class | Aspose.Slides Namespace


FirstRow Property

Aspose.Slides Documentation

Cell.FirstRow Property

Gets first row of cell.

[Visual Basic]
NotOverridable Public ReadOnly Property FirstRow As IRow _
Implements ICell.FirstRow
[C#]
public IRow FirstRow {get;}

Implements

ICell.FirstRow

See Also

Cell Class | Aspose.Slides Namespace


FirstRowIndex Property

Aspose.Slides Documentation

Cell.FirstRowIndex Property

Returns an index of first row, covered by the cell. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property FirstRowIndex As Integer _
Implements ICell.FirstRowIndex
[C#]
public int FirstRowIndex {get;}

Implements

ICell.FirstRowIndex

See Also

Cell Class | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

Cell.Height Property

Returns the height of the cell. Read-only Double.

[Visual Basic]
NotOverridable Public ReadOnly Property Height As Double _
Implements ICell.Height
[C#]
public double Height {get;}

Implements

ICell.Height

See Also

Cell Class | Aspose.Slides Namespace


MarginBottom Property

Aspose.Slides Documentation

Cell.MarginBottom Property

Returns or sets the bottom margin in a TextFrame. Read/write Double.

[Visual Basic]
NotOverridable Public Property MarginBottom As Double _
Implements ICell.MarginBottom
[C#]
public double MarginBottom {get; set;}

Implements

ICell.MarginBottom

See Also

Cell Class | Aspose.Slides Namespace


MarginLeft Property

Aspose.Slides Documentation

Cell.MarginLeft Property

Returns or sets the left margin in a TextFrame. Read/write Double.

[Visual Basic]
NotOverridable Public Property MarginLeft As Double _
Implements ICell.MarginLeft
[C#]
public double MarginLeft {get; set;}

Implements

ICell.MarginLeft

See Also

Cell Class | Aspose.Slides Namespace


MarginRight Property

Aspose.Slides Documentation

Cell.MarginRight Property

Returns or sets the right margin in a TextFrame. Read/write Double.

[Visual Basic]
NotOverridable Public Property MarginRight As Double _
Implements ICell.MarginRight
[C#]
public double MarginRight {get; set;}

Implements

ICell.MarginRight

See Also

Cell Class | Aspose.Slides Namespace


MarginTop Property

Aspose.Slides Documentation

Cell.MarginTop Property

Returns or sets the top margin in a TextFrame. Read/write Double.

[Visual Basic]
NotOverridable Public Property MarginTop As Double _
Implements ICell.MarginTop
[C#]
public double MarginTop {get; set;}

Implements

ICell.MarginTop

See Also

Cell Class | Aspose.Slides Namespace


MinimalHeight Property

Aspose.Slides Documentation

Cell.MinimalHeight Property

Returns the minimum height of a cell. This is a sum of minimal heights of all rows cowered by the cell. Read-only Double.

[Visual Basic]
NotOverridable Public ReadOnly Property MinimalHeight As Double _
Implements ICell.MinimalHeight
[C#]
public double MinimalHeight {get;}

Implements

ICell.MinimalHeight

See Also

Cell Class | Aspose.Slides Namespace


OffsetX Property

Aspose.Slides Documentation

Cell.OffsetX Property

Returns a distance from left side of a table to left side of a cell. Read-only Double.

[Visual Basic]
NotOverridable Public ReadOnly Property OffsetX As Double _
Implements ICell.OffsetX
[C#]
public double OffsetX {get;}

Implements

ICell.OffsetX

See Also

Cell Class | Aspose.Slides Namespace


OffsetY Property

Aspose.Slides Documentation

Cell.OffsetY Property

Returns a distance from top side of a table to top side of a cell. Read-only Double.

[Visual Basic]
NotOverridable Public ReadOnly Property OffsetY As Double _
Implements ICell.OffsetY
[C#]
public double OffsetY {get;}

Implements

ICell.OffsetY

See Also

Cell Class | Aspose.Slides Namespace


Presentation Property

Aspose.Slides Documentation

Cell.Presentation Property

Returns the parent presentation of a cell. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

Cell Class | Aspose.Slides Namespace


RowSpan Property

Aspose.Slides Documentation

Cell.RowSpan Property

Returns the number of rows that a merged cell spans. This is used in combination with the vMerge attribute on other cells in order to specify the beginning cell of a horizontal merge. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property RowSpan As Integer _
Implements ICell.RowSpan
[C#]
public int RowSpan {get;}

Implements

ICell.RowSpan

See Also

Cell Class | Aspose.Slides Namespace


Slide Property

Aspose.Slides Documentation

Cell.Slide Property

Returns the parent slide of a cell. Read-only BaseSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As IBaseSlide _
Implements ISlideComponent.Slide
[C#]
public IBaseSlide Slide {get;}

Implements

ISlideComponent.Slide

See Also

Cell Class | Aspose.Slides Namespace


Table Property

Aspose.Slides Documentation

Cell.Table Property

Returns the parent Table object for a cell. Read-only Table.

[Visual Basic]
NotOverridable Public ReadOnly Property Table As ITable _
Implements ICell.Table
[C#]
public ITable Table {get;}

Implements

ICell.Table

See Also

Cell Class | Aspose.Slides Namespace


TextAnchorType Property

Aspose.Slides Documentation

Cell.TextAnchorType Property

Returns or sets the text anchor type. Read/write TextAnchorType.

[Visual Basic]
NotOverridable Public Property TextAnchorType As TextAnchorType _
Implements ICell.TextAnchorType
[C#]
public TextAnchorType TextAnchorType {get; set;}

Implements

ICell.TextAnchorType

See Also

Cell Class | Aspose.Slides Namespace


TextFrame Property

Aspose.Slides Documentation

Cell.TextFrame Property

Returns the text frame of a cell. Read-only TextFrame.

[Visual Basic]
NotOverridable Public ReadOnly Property TextFrame As ITextFrame _
Implements ICell.TextFrame
[C#]
public ITextFrame TextFrame {get;}

Implements

ICell.TextFrame

See Also

Cell Class | Aspose.Slides Namespace


TextVerticalType Property

Aspose.Slides Documentation

Cell.TextVerticalType Property

Returns or sets the type of vertical text. Read/write TextVerticalType.

[Visual Basic]
NotOverridable Public Property TextVerticalType As TextVerticalType _
Implements ICell.TextVerticalType
[C#]
public TextVerticalType TextVerticalType {get; set;}

Implements

ICell.TextVerticalType

See Also

Cell Class | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

Cell.Width Property

Returns the width of the cell. Read-only Double.

[Visual Basic]
NotOverridable Public ReadOnly Property Width As Double _
Implements ICell.Width
[C#]
public double Width {get;}

Implements

ICell.Width

See Also

Cell Class | Aspose.Slides Namespace


Cell Methods

The methods of the Cell class are listed below. For a complete list of Cell class members, see the Cell Members topic.

Public Instance Methods

SplitByColSpan | Splits the cell to two cells by index of column.
SplitByHeight | Splits the cell by height.
SplitByRowSpan | Splits the cell to two cells by index of row.
SplitByWidth | Splits the cell by width.

See Also

Cell Class | Aspose.Slides Namespace


Cell.SplitByColSpan Method

Splits the cell to two cells by index of column.

[Visual Basic]
NotOverridable Public Sub SplitByColSpan( _
ByVal index As Integer _
) _
Implements ICell.SplitByColSpan
[C#]
public void SplitByColSpan(
int index
);

Parameters

index
Index of column.

Implements

ICell.SplitByColSpan

See Also

Cell Class | Aspose.Slides Namespace


Cell.SplitByHeight Method

Splits the cell by height.

[Visual Basic]
NotOverridable Public Sub SplitByHeight( _
ByVal height As Double _
) _
Implements ICell.SplitByHeight
[C#]
public void SplitByHeight(
double height
);

Parameters

height
Height of a row.

Implements

ICell.SplitByHeight

See Also

Cell Class | Aspose.Slides Namespace


Cell.SplitByRowSpan Method

Splits the cell to two cells by index of row.

[Visual Basic]
NotOverridable Public Sub SplitByRowSpan( _
ByVal index As Integer _
) _
Implements ICell.SplitByRowSpan
[C#]
public void SplitByRowSpan(
int index
);

Parameters

index
Index of row.

Implements

ICell.SplitByRowSpan

See Also

Cell Class | Aspose.Slides Namespace


Cell.SplitByWidth Method

Splits the cell by width.

[Visual Basic]
NotOverridable Public Sub SplitByWidth( _
ByVal width As Double _
) _
Implements ICell.SplitByWidth
[C#]
public void SplitByWidth(
double width
);

Parameters

width
Width of a column.

Implements

ICell.SplitByWidth

See Also

Cell Class | Aspose.Slides Namespace


CellCollection Class

Represents a collection of cells.

For a list of all members of this type, see CellCollection Members.

System.Object
Aspose.Slides.CellCollection
Aspose.Slides.Column
Aspose.Slides.Row

[Visual Basic]
MustInherit Public Class CellCollection
Implements ICellCollection, ISlideComponent, IPresentationComponent, ICollection, IEnumerable
[C#]
public abstract class CellCollection : ICellCollection, ISlideComponent, IPresentationComponent, ICollection, IEnumerable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

CellCollection Members | Aspose.Slides Namespace


CellCollection Members

CellCollection overview

Public Instance Properties

Count | Returns the number of cells in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns a cell by it's position. Read-only Cell.
Presentation | Returns the parent presentation of a CellCollection. Read-only Presentation.
Slide | Returns the parent slide of a CellCollection. Read-only BaseSlide.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for all cells which top-left corner belongs to this collection. Each cell returned only once.

See Also

CellCollection Class | Aspose.Slides Namespace


CellCollection Properties

The properties of the CellCollection class are listed below. For a complete list of CellCollection class members, see the CellCollection Members topic.

Public Instance Properties

Count | Returns the number of cells in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns a cell by it's position. Read-only Cell.
Presentation | Returns the parent presentation of a CellCollection. Read-only Presentation.
Slide | Returns the parent slide of a CellCollection. Read-only BaseSlide.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

CellCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

CellCollection.Count Property

Returns the number of cells in a collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

CellCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

CellCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

CellCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

CellCollection.Item Property

Returns a cell by it's position. Read-only Cell.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ICellCollection.Item
As ICell _
Implements ICellCollection.Item
[C#]
public ICell this[
int index
] {get;}

Implements

ICellCollection.Item

Remarks

One Cell object can be returned for several indexes in case cell is merged.

See Also

CellCollection Class | Aspose.Slides Namespace


Presentation Property

Aspose.Slides Documentation

CellCollection.Presentation Property

Returns the parent presentation of a CellCollection. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

CellCollection Class | Aspose.Slides Namespace


Slide Property

Aspose.Slides Documentation

CellCollection.Slide Property

Returns the parent slide of a CellCollection. Read-only BaseSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As IBaseSlide _
Implements ISlideComponent.Slide
[C#]
public IBaseSlide Slide {get;}

Implements

ISlideComponent.Slide

See Also

CellCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

CellCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

CellCollection Class | Aspose.Slides Namespace


CellCollection Methods

The methods of the CellCollection class are listed below. For a complete list of CellCollection class members, see the CellCollection Members topic.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for all cells which top-left corner belongs to this collection. Each cell returned only once.

See Also

CellCollection Class | Aspose.Slides Namespace


CellCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

CellCollection Class | Aspose.Slides Namespace


CellCollection.GetEnumerator Method

Returns an enumerator for all cells which top-left corner belongs to this collection. Each cell returned only once.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the collection.

Implements

IEnumerable.GetEnumerator

See Also

CellCollection Class | Aspose.Slides Namespace


ColorFormat Class

Represents a color used in a presentation.

For a list of all members of this type, see ColorFormat Members.

System.Object
Aspose.Slides.ColorFormat

[Visual Basic]
Public Class ColorFormat
Implements IColorFormat, IFillParamSource
[C#]
public class ColorFormat : IColorFormat, IFillParamSource

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ColorFormat Members | Aspose.Slides Namespace


ColorFormat Members

ColorFormat overview

Public Instance Properties

B | Returns or sets the blue component of a color. All color transformations are ignored. Read/write Byte.
Color | Returns resulting color (with all color transformations applied). Sets RGB colors and clears all color transformations. Read/write Color.
ColorTransform | Returns the collection of color transformations applied to a color. Read-only ColorOperationCollection.
ColorType | Returns or sets the color definition method. Read/write ColorType.
FloatB | Returns or sets the blue component of a color. All color transformations are ignored. Read/write Single.
FloatG | Returns or sets the green component of a color. All color transformations are ignored. Read/write Single.
FloatR | Returns or sets the red component of a color. All color transformations are ignored. Read/write Single.
G | Returns or sets the green component of a color. All color transformations are ignored. Read/write Byte.
Hue | Returns or sets the hue component of a color in HSL representation. All color transformations are ignored. Read/write Single.
Luminance | Returns or sets the luminance component of a color in HSL representation. All color transformations are ignored. Read/write Single.
PresetColor | Returns or sets the color preset. Read/write PresetColor.
R | Returns or sets the red component of a color. All color transformations are ignored. Read/write Byte.
Saturation | Returns or sets the saturation component of a color in HSL representation. All color transformations are ignored. Read/write Single.
SchemeColor | Returns or sets the color identified by a color scheme. Read/write SchemeColor.
SystemColor | Returns or sets the color identified by the system color table. Read/write SystemColor.

Public Instance Methods

CopyFrom | Copy color format from "color".
Equals | Determines whether the two ColorFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
ToString | Overloaded.

See Also

ColorFormat Class | Aspose.Slides Namespace


ColorFormat Properties

The properties of the ColorFormat class are listed below. For a complete list of ColorFormat class members, see the ColorFormat Members topic.

Public Instance Properties

B | Returns or sets the blue component of a color. All color transformations are ignored. Read/write Byte.
Color | Returns resulting color (with all color transformations applied). Sets RGB colors and clears all color transformations. Read/write Color.
ColorTransform | Returns the collection of color transformations applied to a color. Read-only ColorOperationCollection.
ColorType | Returns or sets the color definition method. Read/write ColorType.
FloatB | Returns or sets the blue component of a color. All color transformations are ignored. Read/write Single.
FloatG | Returns or sets the green component of a color. All color transformations are ignored. Read/write Single.
FloatR | Returns or sets the red component of a color. All color transformations are ignored. Read/write Single.
G | Returns or sets the green component of a color. All color transformations are ignored. Read/write Byte.
Hue | Returns or sets the hue component of a color in HSL representation. All color transformations are ignored. Read/write Single.
Luminance | Returns or sets the luminance component of a color in HSL representation. All color transformations are ignored. Read/write Single.
PresetColor | Returns or sets the color preset. Read/write PresetColor.
R | Returns or sets the red component of a color. All color transformations are ignored. Read/write Byte.
Saturation | Returns or sets the saturation component of a color in HSL representation. All color transformations are ignored. Read/write Single.
SchemeColor | Returns or sets the color identified by a color scheme. Read/write SchemeColor.
SystemColor | Returns or sets the color identified by the system color table. Read/write SystemColor.

See Also

ColorFormat Class | Aspose.Slides Namespace


B Property

Aspose.Slides Documentation

ColorFormat.B Property

Returns or sets the blue component of a color. All color transformations are ignored. Read/write Byte.

[Visual Basic]
NotOverridable Public Property B As Byte _
Implements IColorFormat.B
[C#]
public byte B {get; set;}

Implements

IColorFormat.B

See Also

ColorFormat Class | Aspose.Slides Namespace


Color Property

Aspose.Slides Documentation

ColorFormat.Color Property

Returns resulting color (with all color transformations applied). Sets RGB colors and clears all color transformations. Read/write Color.

[Visual Basic]
NotOverridable Public Property Color As Color _
Implements IColorFormat.Color
[C#]
public Color Color {get; set;}

Implements

IColorFormat.Color

See Also

ColorFormat Class | Aspose.Slides Namespace


ColorTransform Property

Aspose.Slides Documentation

ColorFormat.ColorTransform Property

Returns the collection of color transformations applied to a color. Read-only ColorOperationCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property ColorTransform As IColorOperationCollection _
Implements IColorFormat.ColorTransform
[C#]
public IColorOperationCollection ColorTransform {get;}

Implements

IColorFormat.ColorTransform

See Also

ColorFormat Class | Aspose.Slides Namespace


ColorType Property

Aspose.Slides Documentation

ColorFormat.ColorType Property

Returns or sets the color definition method. Read/write ColorType.

[Visual Basic]
NotOverridable Public Property ColorType As ColorType _
Implements IColorFormat.ColorType
[C#]
public ColorType ColorType {get; set;}

Implements

IColorFormat.ColorType

See Also

ColorFormat Class | Aspose.Slides Namespace


FloatB Property

Aspose.Slides Documentation

ColorFormat.FloatB Property

Returns or sets the blue component of a color. All color transformations are ignored. Read/write Single.

[Visual Basic]
NotOverridable Public Property FloatB As Single _
Implements IColorFormat.FloatB
[C#]
public float FloatB {get; set;}

Implements

IColorFormat.FloatB

See Also

ColorFormat Class | Aspose.Slides Namespace


FloatG Property

Aspose.Slides Documentation

ColorFormat.FloatG Property

Returns or sets the green component of a color. All color transformations are ignored. Read/write Single.

[Visual Basic]
NotOverridable Public Property FloatG As Single _
Implements IColorFormat.FloatG
[C#]
public float FloatG {get; set;}

Implements

IColorFormat.FloatG

See Also

ColorFormat Class | Aspose.Slides Namespace


FloatR Property

Aspose.Slides Documentation

ColorFormat.FloatR Property

Returns or sets the red component of a color. All color transformations are ignored. Read/write Single.

[Visual Basic]
NotOverridable Public Property FloatR As Single _
Implements IColorFormat.FloatR
[C#]
public float FloatR {get; set;}

Implements

IColorFormat.FloatR

See Also

ColorFormat Class | Aspose.Slides Namespace


G Property

Aspose.Slides Documentation

ColorFormat.G Property

Returns or sets the green component of a color. All color transformations are ignored. Read/write Byte.

[Visual Basic]
NotOverridable Public Property G As Byte _
Implements IColorFormat.G
[C#]
public byte G {get; set;}

Implements

IColorFormat.G

See Also

ColorFormat Class | Aspose.Slides Namespace


Hue Property

Aspose.Slides Documentation

ColorFormat.Hue Property

Returns or sets the hue component of a color in HSL representation. All color transformations are ignored. Read/write Single.

[Visual Basic]
NotOverridable Public Property Hue As Single _
Implements IColorFormat.Hue
[C#]
public float Hue {get; set;}

Implements

IColorFormat.Hue

See Also

ColorFormat Class | Aspose.Slides Namespace


Luminance Property

Aspose.Slides Documentation

ColorFormat.Luminance Property

Returns or sets the luminance component of a color in HSL representation. All color transformations are ignored. Read/write Single.

[Visual Basic]
NotOverridable Public Property Luminance As Single _
Implements IColorFormat.Luminance
[C#]
public float Luminance {get; set;}

Implements

IColorFormat.Luminance

See Also

ColorFormat Class | Aspose.Slides Namespace


PresetColor Property

Aspose.Slides Documentation

ColorFormat.PresetColor Property

Returns or sets the color preset. Read/write PresetColor.

[Visual Basic]
NotOverridable Public Property PresetColor As PresetColor _
Implements IColorFormat.PresetColor
[C#]
public PresetColor PresetColor {get; set;}

Implements

IColorFormat.PresetColor

See Also

ColorFormat Class | Aspose.Slides Namespace


R Property

Aspose.Slides Documentation

ColorFormat.R Property

Returns or sets the red component of a color. All color transformations are ignored. Read/write Byte.

[Visual Basic]
NotOverridable Public Property R As Byte _
Implements IColorFormat.R
[C#]
public byte R {get; set;}

Implements

IColorFormat.R

See Also

ColorFormat Class | Aspose.Slides Namespace


Saturation Property

Aspose.Slides Documentation

ColorFormat.Saturation Property

Returns or sets the saturation component of a color in HSL representation. All color transformations are ignored. Read/write Single.

[Visual Basic]
NotOverridable Public Property Saturation As Single _
Implements IColorFormat.Saturation
[C#]
public float Saturation {get; set;}

Implements

IColorFormat.Saturation

See Also

ColorFormat Class | Aspose.Slides Namespace


SchemeColor Property

Aspose.Slides Documentation

ColorFormat.SchemeColor Property

Returns or sets the color identified by a color scheme. Read/write SchemeColor.

[Visual Basic]
NotOverridable Public Property SchemeColor As SchemeColor _
Implements IColorFormat.SchemeColor
[C#]
public SchemeColor SchemeColor {get; set;}

Implements

IColorFormat.SchemeColor

See Also

ColorFormat Class | Aspose.Slides Namespace


SystemColor Property

Aspose.Slides Documentation

ColorFormat.SystemColor Property

Returns or sets the color identified by the system color table. Read/write SystemColor.

[Visual Basic]
NotOverridable Public Property SystemColor As SystemColor _
Implements IColorFormat.SystemColor
[C#]
public SystemColor SystemColor {get; set;}

Implements

IColorFormat.SystemColor

See Also

ColorFormat Class | Aspose.Slides Namespace


ColorFormat Methods

The methods of the ColorFormat class are listed below. For a complete list of ColorFormat class members, see the ColorFormat Members topic.

Public Instance Methods

CopyFrom | Copy color format from "color".
Equals | Determines whether the two ColorFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
ToString | Overloaded.

See Also

ColorFormat Class | Aspose.Slides Namespace


ColorFormat.CopyFrom Method

Copy color format from "color".

[Visual Basic]
NotOverridable Public Sub CopyFrom( _
ByVal color As IColorFormat _
) _
Implements IColorFormat.CopyFrom
[C#]
public void CopyFrom(
IColorFormat color
);

Implements

IColorFormat.CopyFrom

See Also

ColorFormat Class | Aspose.Slides Namespace


ColorFormat.Equals Method

Determines whether the two ColorFormat instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The ColorFormat to compare with the current ColorFormat.

Return Value

true if the specified ColorFormat is equal to the current ColorFormat; otherwise, false.

See Also

ColorFormat Class | Aspose.Slides Namespace


ColorFormat.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

23455

Remarks

Overriden to make compiler happy. Always returns constant because object is mutable.

See Also

ColorFormat Class | Aspose.Slides Namespace


ToString Method

Aspose.Slides Documentation

ColorFormat.ToString Method

Overload List

public override string ToString();

public string ToString(ColorStringFormat);

See Also

ColorFormat Class | Aspose.Slides Namespace


ColorFormat.ToString Method ()

[Visual Basic]
Overrides Overloads Public Function ToString() As String
[C#]
public override string ToString();

See Also

ColorFormat Class | Aspose.Slides Namespace | ColorFormat.ToString Overload List


ColorFormat.ToString Method (ColorStringFormat)

[Visual Basic]
NotOverridable Overloads Public Function ToString( _
ByVal format As ColorStringFormat _
) As String _
Implements IColorFormat.ToString
[C#]
public string ToString(
ColorStringFormat format
);

Implements

IColorFormat.ToString

See Also

ColorFormat Class | Aspose.Slides Namespace | ColorFormat.ToString Overload List


ColorOperation Class

Represents different color operations used for color transformations.

For a list of all members of this type, see ColorOperation Members.

System.Object
Aspose.Slides.ColorOperation

[Visual Basic]
Public Class ColorOperation
Implements IColorOperation
[C#]
public class ColorOperation : IColorOperation

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ColorOperation Members | Aspose.Slides Namespace


ColorOperation Members

ColorOperation overview

Public Instance Constructors

ColorOperation Overloaded. Initializes a new instance of the ColorOperation class.

Public Instance Properties

OperationType | Returns or sets the type of an operation. Read-only ColorTransformOperation.
Parameter | Returns a parameter of an operation. Read-only Single.

Public Instance Methods

Equals | Determines whether the two ColorOperation instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

ColorOperation Class | Aspose.Slides Namespace


ColorOperation Constructor

Creates new color transform operation.

Overload List

Creates new color transform operation.

public ColorOperation(ColorTransformOperation);

Creates new color transform operation.

public ColorOperation(ColorTransformOperation,float);

See Also

ColorOperation Class | Aspose.Slides Namespace


ColorOperation Constructor (ColorTransformOperation)

Creates new color transform operation.

[Visual Basic]
Overloads Public Sub New( _
ByVal op As ColorTransformOperation _
)
[C#]
public ColorOperation(
ColorTransformOperation op
);

Parameters

op
Operation type.

See Also

ColorOperation Class | Aspose.Slides Namespace | ColorOperation Constructor Overload List


ColorOperation Constructor (ColorTransformOperation, Single)

Creates new color transform operation.

[Visual Basic]
Overloads Public Sub New( _
ByVal op As ColorTransformOperation, _
ByVal parameter As Single _
)
[C#]
public ColorOperation(
ColorTransformOperation op,
float parameter
);

Parameters

op
Operation type.
parameter
Operation parameter.

See Also

ColorOperation Class | Aspose.Slides Namespace | ColorOperation Constructor Overload List


ColorOperation Properties

The properties of the ColorOperation class are listed below. For a complete list of ColorOperation class members, see the ColorOperation Members topic.

Public Instance Properties

OperationType | Returns or sets the type of an operation. Read-only ColorTransformOperation.
Parameter | Returns a parameter of an operation. Read-only Single.

See Also

ColorOperation Class | Aspose.Slides Namespace


OperationType Property

Aspose.Slides Documentation

ColorOperation.OperationType Property

Returns or sets the type of an operation. Read-only ColorTransformOperation.

[Visual Basic]
NotOverridable Public ReadOnly Property OperationType As ColorTransformOperation _
Implements IColorOperation.OperationType
[C#]
public ColorTransformOperation OperationType {get;}

Implements

IColorOperation.OperationType

See Also

ColorOperation Class | Aspose.Slides Namespace


Parameter Property

Aspose.Slides Documentation

ColorOperation.Parameter Property

Returns a parameter of an operation. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Parameter As Single _
Implements IColorOperation.Parameter
[C#]
public float Parameter {get;}

Implements

IColorOperation.Parameter

See Also

ColorOperation Class | Aspose.Slides Namespace


ColorOperation Methods

The methods of the ColorOperation class are listed below. For a complete list of ColorOperation class members, see the ColorOperation Members topic.

Public Instance Methods

Equals | Determines whether the two ColorOperation instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

ColorOperation Class | Aspose.Slides Namespace


ColorOperation.Equals Method

Determines whether the two ColorOperation instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The ColorOperation to compare with the current ColorOperation.

Return Value

true if the specified ColorOperation is equal to the current ColorOperation; otherwise, false.

See Also

ColorOperation Class | Aspose.Slides Namespace


ColorOperation.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

See Also

ColorOperation Class | Aspose.Slides Namespace


ColorOperationCollection Class

Represents a collection of color transform operations.

For a list of all members of this type, see ColorOperationCollection Members.

System.Object
Aspose.Slides.ColorOperationCollection

[Visual Basic]
NotInheritable Public Class ColorOperationCollection
Implements IColorOperationCollection, ICollection, IEnumerable, ICloneable, IEnumerable`1([Aspose.Slides.IColorOperation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public sealed class ColorOperationCollection : IColorOperationCollection, ICollection, IEnumerable, ICloneable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ColorOperationCollection Members | Aspose.Slides Namespace


ColorOperationCollection Members

ColorOperationCollection overview

Public Instance Properties

Count | Returns the number of operations in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns or sets the operation at the specified index. Read/write ColorOperation.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

Add | Overloaded. Adds a new operation to the end of collection.
Clear | Removes all color operations.
Clone | Creates a copy of a ColorOperationCollection collection.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator that iterates through the collection.
Insert | Overloaded. Inserts the new operation to a collection.
RemoveAt | Removes the color operation from a collection.

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


ColorOperationCollection Properties

The properties of the ColorOperationCollection class are listed below. For a complete list of ColorOperationCollection class members, see the ColorOperationCollection Members topic.

Public Instance Properties

Count | Returns the number of operations in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns or sets the operation at the specified index. Read/write ColorOperation.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

ColorOperationCollection.Count Property

Returns the number of operations in a collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

ColorOperationCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ColorOperationCollection.Item Property

Returns or sets the operation at the specified index. Read/write ColorOperation.

[Visual Basic]
NotOverridable Public Default Property Item( _
ByVal index As Integer _
) _
Implements IColorOperationCollection.Item
As IColorOperation _
Implements IColorOperationCollection.Item
[C#]
public IColorOperation this[
int index
] {get; set;}

Implements

IColorOperationCollection.Item

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

ColorOperationCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


ColorOperationCollection Methods

The methods of the ColorOperationCollection class are listed below. For a complete list of ColorOperationCollection class members, see the ColorOperationCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a new operation to the end of collection.
Clear | Removes all color operations.
Clone | Creates a copy of a ColorOperationCollection collection.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator that iterates through the collection.
Insert | Overloaded. Inserts the new operation to a collection.
RemoveAt | Removes the color operation from a collection.

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


Add Method

Aspose.Slides Documentation

ColorOperationCollection.Add Method

Adds a new operation to the end of collection.

Overload List

Adds a new operation to the end of collection.

public IColorOperation Add(ColorTransformOperation);

Adds a new operation to the end of collection.

public IColorOperation Add(ColorTransformOperation,float);

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


ColorOperationCollection.Add Method (ColorTransformOperation)

Adds a new operation to the end of collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal operation As ColorTransformOperation _
) As IColorOperation _
Implements IColorOperationCollection.Add
[C#]
public IColorOperation Add(
ColorTransformOperation operation
);

Parameters

operation
Operation type.

Return Value

Added operation.

Implements

IColorOperationCollection.Add

See Also

ColorOperationCollection Class | Aspose.Slides Namespace | ColorOperationCollection.Add Overload List


ColorOperationCollection.Add Method (ColorTransformOperation, Single)

Adds a new operation to the end of collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal operation As ColorTransformOperation, _
ByVal parameter As Single _
) As IColorOperation _
Implements IColorOperationCollection.Add
[C#]
public IColorOperation Add(
ColorTransformOperation operation,
float parameter
);

Parameters

operation
Operation type.
parameter
Operation's parameter.

Return Value

Added operation.

Implements

IColorOperationCollection.Add

See Also

ColorOperationCollection Class | Aspose.Slides Namespace | ColorOperationCollection.Add Overload List


ColorOperationCollection.Clear Method

Removes all color operations.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IColorOperationCollection.Clear
[C#]
public void Clear();

Implements

IColorOperationCollection.Clear

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


ColorOperationCollection.Clone Method

Creates a copy of a ColorOperationCollection collection.

[Visual Basic]
NotOverridable Public Function Clone() As Object _
Implements ICloneable.Clone
[C#]
public object Clone();

Return Value

New ColorOperationCollection collection.

Implements

ICloneable.Clone

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


ColorOperationCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


ColorOperationCollection.GetEnumerator Method

Returns an enumerator that iterates through the collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator(Of IColorOperation) _
Implements IEnumerable`1.GetEnumerator
[C#]
public IEnumerator<IColorOperation> GetEnumerator();

Return Value

A IEnumerator`1 that can be used to iterate through the collection.

Implements

IEnumerable`1.GetEnumerator

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


Insert Method

Aspose.Slides Documentation

ColorOperationCollection.Insert Method

Inserts the new operation to a collection.

Overload List

Inserts the new operation to a collection.

public IColorOperation Insert(int,ColorTransformOperation);

Inserts the new operation to a collection.

public IColorOperation Insert(int,ColorTransformOperation,float);

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


ColorOperationCollection.Insert Method (Int32, ColorTransformOperation)

Inserts the new operation to a collection.

[Visual Basic]
NotOverridable Overloads Public Function Insert( _
ByVal position As Integer, _
ByVal operation As ColorTransformOperation _
) As IColorOperation _
Implements IColorOperationCollection.Insert
[C#]
public IColorOperation Insert(
int position,
ColorTransformOperation operation
);

Parameters

position
The index at which the operation will be inserted.
operation
Operation type.

Return Value

Inserted operation.

Implements

IColorOperationCollection.Insert

See Also

ColorOperationCollection Class | Aspose.Slides Namespace | ColorOperationCollection.Insert Overload List


ColorOperationCollection.Insert Method (Int32, ColorTransformOperation, Single)

Inserts the new operation to a collection.

[Visual Basic]
NotOverridable Overloads Public Function Insert( _
ByVal position As Integer, _
ByVal operation As ColorTransformOperation, _
ByVal parameter As Single _
) As IColorOperation _
Implements IColorOperationCollection.Insert
[C#]
public IColorOperation Insert(
int position,
ColorTransformOperation operation,
float parameter
);

Parameters

position
The index at which the operation will be inserted.
operation
Operation type.
parameter
Operation's parameter.

Return Value

Inserted operation.

Implements

IColorOperationCollection.Insert

See Also

ColorOperationCollection Class | Aspose.Slides Namespace | ColorOperationCollection.Insert Overload List


ColorOperationCollection.RemoveAt Method

Removes the color operation from a collection.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IColorOperationCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
Index of a color operation to remove.

Implements

IColorOperationCollection.RemoveAt

See Also

ColorOperationCollection Class | Aspose.Slides Namespace


ColorSchemeIndex Enumeration

[Visual Basic]
Public Enum ColorSchemeIndex
Inherits
[C#]
public enum ColorSchemeIndex

Members

Member Name | Description | Value
Dark1 |  | 0
Light1 |  | 1
Dark2 |  | 2
Light2 |  | 3
Accent1 |  | 4
Accent2 |  | 5
Accent3 |  | 6
Accent4 |  | 7
Accent5 |  | 8
Accent6 |  | 9
Hyperlink |  | 10
FollowedHyperlink |  | 11

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


ColorStringFormat Enumeration

[Visual Basic]
Public Enum ColorStringFormat
[C#]
public enum ColorStringFormat

Members

Member Name | Description | Value
Vml |  | 0

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


ColorTransformOperation Enumeration

[Visual Basic]
Public Enum ColorTransformOperation
[C#]
public enum ColorTransformOperation

Members

Member Name | Description | Value
Tint |  | 0
Shade |  | 1
Complement |  | 2
Inverse |  | 3
Grayscale |  | 4
SetAlpha |  | 5
AddAlpha |  | 6
MultiplyAlpha |  | 7
SetHue |  | 8
AddHue |  | 9
MultiplyHue |  | 10
SetSaturation |  | 11
AddSaturation |  | 12
MultiplySaturation |  | 13
SetLuminance |  | 14
AddLuminance |  | 15
MultiplyLuminance |  | 16
SetRed |  | 17
AddRed |  | 18
MultiplyRed |  | 19
SetGreen |  | 20
AddGreen |  | 21
MultiplyGreen |  | 22
SetBlue |  | 23
AddBlue |  | 24
MultiplyBlue |  | 25
Gamma |  | 26
InverseGamma |  | 27

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


ColorType Enumeration

[Visual Basic]
Public Enum ColorType
[C#]
public enum ColorType

Members

Member Name | Description | Value
NotDefined |  | -1
RGB |  | 0
RGBPercentage |  | 1
HSL |  | 2
Scheme |  | 3
System |  | 4
Preset |  | 5

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


Column Class

Represents a column in a table.

For a list of all members of this type, see Column Members.

System.Object
Aspose.Slides.CellCollection
Aspose.Slides.Column

[Visual Basic]
NotInheritable Public Class Column
Inherits CellCollection
Implements IColumn
[C#]
public sealed class Column : CellCollection, IColumn

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Column Members | Aspose.Slides Namespace


Column Members

Column overview

Public Instance Properties

Count (inherited from CellCollection) | Returns the number of cells in a collection. Read-only Int32.
IsSynchronized (inherited from CellCollection) | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item (inherited from CellCollection) | Returns a cell by it's position. Read-only Cell.
Presentation (inherited from CellCollection) | Returns the parent presentation of a CellCollection. Read-only Presentation.
Slide (inherited from CellCollection) | Returns the parent slide of a CellCollection. Read-only BaseSlide.
SyncRoot (inherited from CellCollection) | Returns a synchronization root. Readonly Object.
Width | Returns or sets the width of a column. Read/Write Double.

Public Instance Methods

CopyTo (inherited from CellCollection) | Copies all elements from the collection to the specified array.
GetEnumerator (inherited from CellCollection) | Returns an enumerator for all cells which top-left corner belongs to this collection. Each cell returned only once.

See Also

Column Class | Aspose.Slides Namespace


Column Properties

The properties of the Column class are listed below. For a complete list of Column class members, see the Column Members topic.

Public Instance Properties

Count (inherited from CellCollection) | Returns the number of cells in a collection. Read-only Int32.
IsSynchronized (inherited from CellCollection) | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item (inherited from CellCollection) | Returns a cell by it's position. Read-only Cell.
Presentation (inherited from CellCollection) | Returns the parent presentation of a CellCollection. Read-only Presentation.
Slide (inherited from CellCollection) | Returns the parent slide of a CellCollection. Read-only BaseSlide.
SyncRoot (inherited from CellCollection) | Returns a synchronization root. Readonly Object.
Width | Returns or sets the width of a column. Read/Write Double.

See Also

Column Class | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

Column.Width Property

Returns or sets the width of a column. Read/Write Double.

[Visual Basic]
NotOverridable Public Property Width As Double _
Implements IColumn.Width
[C#]
public double Width {get; set;}

Implements

IColumn.Width

See Also

Column Class | Aspose.Slides Namespace


ColumnCollection Class

Represents collection of columns in a table.

For a list of all members of this type, see ColumnCollection Members.

System.Object
Aspose.Slides.ColumnCollection

[Visual Basic]
NotInheritable Public Class ColumnCollection
Implements IColumnCollection, ICollection, IEnumerable
[C#]
public sealed class ColumnCollection : IColumnCollection, ICollection, IEnumerable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ColumnCollection Members | Aspose.Slides Namespace


ColumnCollection Members

ColumnCollection overview

Public Instance Properties

Count | Returns the number of columns in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns the column at the specified index. Read-only Column.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

AddClone | Creates a copy of the specified template row and inserts it at the bottom of a table.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
InsertClone | Creates a copy of the specified template column and insert it at the specified position in a table.
RemoveAt | Removes a column at the specified position from a table.

See Also

ColumnCollection Class | Aspose.Slides Namespace


ColumnCollection Properties

The properties of the ColumnCollection class are listed below. For a complete list of ColumnCollection class members, see the ColumnCollection Members topic.

Public Instance Properties

Count | Returns the number of columns in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns the column at the specified index. Read-only Column.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

ColumnCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

ColumnCollection.Count Property

Returns the number of columns in a collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

ColumnCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

ColumnCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ColumnCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ColumnCollection.Item Property

Returns the column at the specified index. Read-only Column.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IColumnCollection.Item
As IColumn _
Implements IColumnCollection.Item
[C#]
public IColumn this[
int index
] {get;}

Implements

IColumnCollection.Item

See Also

ColumnCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

ColumnCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ColumnCollection Class | Aspose.Slides Namespace


ColumnCollection Methods

The methods of the ColumnCollection class are listed below. For a complete list of ColumnCollection class members, see the ColumnCollection Members topic.

Public Instance Methods

AddClone | Creates a copy of the specified template row and inserts it at the bottom of a table.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
InsertClone | Creates a copy of the specified template column and insert it at the specified position in a table.
RemoveAt | Removes a column at the specified position from a table.

See Also

ColumnCollection Class | Aspose.Slides Namespace


ColumnCollection.AddClone Method

Creates a copy of the specified template row and inserts it at the bottom of a table.

[Visual Basic]
NotOverridable Public Function AddClone( _
ByVal templ As IColumn, _
ByVal withAttachedColumns As Boolean _
) As IColumn() _
Implements IColumnCollection.AddClone
[C#]
public IColumn[] AddClone(
IColumn templ,
bool withAttachedColumns
);

Parameters

templ
Column which is used as a template.
withAttachedColumns
True to copy also all columns attached to the template row.

Return Value

Added columns.

Implements

IColumnCollection.AddClone

See Also

ColumnCollection Class | Aspose.Slides Namespace


ColumnCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

ColumnCollection Class | Aspose.Slides Namespace


ColumnCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

ColumnCollection Class | Aspose.Slides Namespace


ColumnCollection.InsertClone Method

Creates a copy of the specified template column and insert it at the specified position in a table.

[Visual Basic]
NotOverridable Public Function InsertClone( _
ByVal index As Integer, _
ByVal templ As IColumn, _
ByVal withAttachedColumns As Boolean _
) As IColumn() _
Implements IColumnCollection.InsertClone
[C#]
public IColumn[] InsertClone(
int index,
IColumn templ,
bool withAttachedColumns
);

Parameters

index
Index of a new column.
templ
Column which is used as a template.
withAttachedColumns
True to copy also all columns attached to the template column.

Return Value

Inserted columns.

Implements

IColumnCollection.InsertClone

See Also

ColumnCollection Class | Aspose.Slides Namespace


ColumnCollection.RemoveAt Method

Removes a column at the specified position from a table.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal firstColumnIndex As Integer, _
ByVal withAttachedRows As Boolean _
) _
Implements IColumnCollection.RemoveAt
[C#]
public void RemoveAt(
int firstColumnIndex,
bool withAttachedRows
);

Parameters

firstColumnIndex
Index of a column to delete.
withAttachedRows
True to delete also all attached columns.

Implements

IColumnCollection.RemoveAt

See Also

ColumnCollection Class | Aspose.Slides Namespace


Comment Class

Represents a comment on a slide.

For a list of all members of this type, see Comment Members.

System.Object
Aspose.Slides.Comment

[Visual Basic]
NotInheritable Public Class Comment
Implements IComment
[C#]
public sealed class Comment : IComment

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Comment Members | Aspose.Slides Namespace


Comment Members

Comment overview

Public Instance Properties

Author | Returns the author of a comment. Read-only CommentAuthor.
CreatedTime | Returns or sets the time of a comment creation. Read/write DateTime. Setting this property to MinValue means no comment time is set.
Position | Returns or sets the position of a comment on a slide. Read/write PointF.
Slide | Returns or sets the parent slide of a comment. Read-only Slide.
Text | Returns or sets the plain text of a slide comment. Read/write String.

See Also

Comment Class | Aspose.Slides Namespace


Comment Properties

The properties of the Comment class are listed below. For a complete list of Comment class members, see the Comment Members topic.

Public Instance Properties

Author | Returns the author of a comment. Read-only CommentAuthor.
CreatedTime | Returns or sets the time of a comment creation. Read/write DateTime. Setting this property to MinValue means no comment time is set.
Position | Returns or sets the position of a comment on a slide. Read/write PointF.
Slide | Returns or sets the parent slide of a comment. Read-only Slide.
Text | Returns or sets the plain text of a slide comment. Read/write String.

See Also

Comment Class | Aspose.Slides Namespace


Author Property

Aspose.Slides Documentation

Comment.Author Property

Returns the author of a comment. Read-only CommentAuthor.

[Visual Basic]
NotOverridable Public ReadOnly Property Author As ICommentAuthor _
Implements IComment.Author
[C#]
public ICommentAuthor Author {get;}

Implements

IComment.Author

See Also

Comment Class | Aspose.Slides Namespace


CreatedTime Property

Aspose.Slides Documentation

Comment.CreatedTime Property

Returns or sets the time of a comment creation. Read/write DateTime. Setting this property to MinValue means no comment time is set.

[Visual Basic]
NotOverridable Public Property CreatedTime As Date _
Implements IComment.CreatedTime
[C#]
public DateTime CreatedTime {get; set;}

Implements

IComment.CreatedTime

Remarks

Comment time is an optional parameter.

See Also

Comment Class | Aspose.Slides Namespace


Position Property

Aspose.Slides Documentation

Comment.Position Property

Returns or sets the position of a comment on a slide. Read/write PointF.

[Visual Basic]
NotOverridable Public Property Position As PointF _
Implements IComment.Position
[C#]
public PointF Position {get; set;}

Implements

IComment.Position

See Also

Comment Class | Aspose.Slides Namespace


Slide Property

Aspose.Slides Documentation

Comment.Slide Property

Returns or sets the parent slide of a comment. Read-only Slide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As ISlide _
Implements IComment.Slide
[C#]
public ISlide Slide {get;}

Implements

IComment.Slide

See Also

Comment Class | Aspose.Slides Namespace


Text Property

Aspose.Slides Documentation

Comment.Text Property

Returns or sets the plain text of a slide comment. Read/write String.

[Visual Basic]
NotOverridable Public Property Text As String _
Implements IComment.Text
[C#]
public string Text {get; set;}

Implements

IComment.Text

See Also

Comment Class | Aspose.Slides Namespace


CommentAuthor Class

Represents an author of comments.

For a list of all members of this type, see CommentAuthor Members.

System.Object
Aspose.Slides.CommentAuthor

[Visual Basic]
NotInheritable Public Class CommentAuthor
Implements ICommentAuthor
[C#]
public sealed class CommentAuthor : ICommentAuthor

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

CommentAuthor Members | Aspose.Slides Namespace


CommentAuthor Members

CommentAuthor overview

Public Instance Properties

Comments | Returns the collection of comments made by this author. Read-only CommentCollection.
Initials | Returns or sets the authors initials. Read/write String.
Name | Returns or sets the author's name. Read/write String.

See Also

CommentAuthor Class | Aspose.Slides Namespace


CommentAuthor Properties

The properties of the CommentAuthor class are listed below. For a complete list of CommentAuthor class members, see the CommentAuthor Members topic.

Public Instance Properties

Comments | Returns the collection of comments made by this author. Read-only CommentCollection.
Initials | Returns or sets the authors initials. Read/write String.
Name | Returns or sets the author's name. Read/write String.

See Also

CommentAuthor Class | Aspose.Slides Namespace


Comments Property

Aspose.Slides Documentation

CommentAuthor.Comments Property

Returns the collection of comments made by this author. Read-only CommentCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Comments As ICommentCollection _
Implements ICommentAuthor.Comments
[C#]
public ICommentCollection Comments {get;}

Implements

ICommentAuthor.Comments

See Also

CommentAuthor Class | Aspose.Slides Namespace


Initials Property

Aspose.Slides Documentation

CommentAuthor.Initials Property

Returns or sets the authors initials. Read/write String.

[Visual Basic]
NotOverridable Public Property Initials As String _
Implements ICommentAuthor.Initials
[C#]
public string Initials {get; set;}

Implements

ICommentAuthor.Initials

See Also

CommentAuthor Class | Aspose.Slides Namespace


Name Property

Aspose.Slides Documentation

CommentAuthor.Name Property

Returns or sets the author's name. Read/write String.

[Visual Basic]
NotOverridable Public Property Name As String _
Implements ICommentAuthor.Name
[C#]
public string Name {get; set;}

Implements

ICommentAuthor.Name

See Also

CommentAuthor Class | Aspose.Slides Namespace


CommentAuthorCollection Class

Represents a collection of comment authors.

For a list of all members of this type, see CommentAuthorCollection Members.

System.Object
Aspose.Slides.CommentAuthorCollection

[Visual Basic]
NotInheritable Public Class CommentAuthorCollection
Implements ICommentAuthorCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ICommentAuthor, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public sealed class CommentAuthorCollection : ICommentAuthorCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

CommentAuthorCollection Members | Aspose.Slides Namespace


CommentAuthorCollection Members

CommentAuthorCollection overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only ICommentAuthor.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

AddAuthor | Add new author at the end of a collection.
CopyTo | Copies all elements from the collection to the specified array.
FindByName | Find author in a collection by name.
FindByNameAndInitials | Find author in a collection by name and initials.
GetEnumerator | Returns an enumerator for the entire collection.
ToArray | Creates and returns an array with all authors.

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


CommentAuthorCollection Properties

The properties of the CommentAuthorCollection class are listed below. For a complete list of CommentAuthorCollection class members, see the CommentAuthorCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only ICommentAuthor.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

CommentAuthorCollection.Count Property

Gets the number of elements actually contained in the collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

CommentAuthorCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

CommentAuthorCollection.Item Property

Gets the element at the specified index. Read-only ICommentAuthor.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ICommentAuthorCollection.Item
As ICommentAuthor _
Implements ICommentAuthorCollection.Item
[C#]
public ICommentAuthor this[
int index
] {get;}

Implements

ICommentAuthorCollection.Item

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

CommentAuthorCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


CommentAuthorCollection Methods

The methods of the CommentAuthorCollection class are listed below. For a complete list of CommentAuthorCollection class members, see the CommentAuthorCollection Members topic.

Public Instance Methods

AddAuthor | Add new author at the end of a collection.
CopyTo | Copies all elements from the collection to the specified array.
FindByName | Find author in a collection by name.
FindByNameAndInitials | Find author in a collection by name and initials.
GetEnumerator | Returns an enumerator for the entire collection.
ToArray | Creates and returns an array with all authors.

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


CommentAuthorCollection.AddAuthor Method

Add new author at the end of a collection.

[Visual Basic]
NotOverridable Public Function AddAuthor( _
ByVal name As String, _
ByVal initials As String _
) As ICommentAuthor _
Implements ICommentAuthorCollection.AddAuthor
[C#]
public ICommentAuthor AddAuthor(
string name,
string initials
);

Parameters

name
Name of a new author.
initials
Initials of a new author.

Return Value

Implements

ICommentAuthorCollection.AddAuthor

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


CommentAuthorCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


CommentAuthorCollection.FindByName Method

Find author in a collection by name.

[Visual Basic]
NotOverridable Public Function FindByName( _
ByVal name As String _
) As ICommentAuthor() _
Implements ICommentAuthorCollection.FindByName
[C#]
public ICommentAuthor[] FindByName(
string name
);

Parameters

name
Name of an author to find.

Return Value

Author or null.

Implements

ICommentAuthorCollection.FindByName

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


CommentAuthorCollection.FindByNameAndInitials Method

Find author in a collection by name and initials.

[Visual Basic]
NotOverridable Public Function FindByNameAndInitials( _
ByVal name As String, _
ByVal initials As String _
) As ICommentAuthor() _
Implements ICommentAuthorCollection.FindByNameAndInitials
[C#]
public ICommentAuthor[] FindByNameAndInitials(
string name,
string initials
);

Parameters

name
Name of an author to find.
initials
Initials of an author to find.

Return Value

Author or null.

Implements

ICommentAuthorCollection.FindByNameAndInitials

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


CommentAuthorCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


CommentAuthorCollection.ToArray Method

Creates and returns an array with all authors.

[Visual Basic]
NotOverridable Public Function ToArray() As ICommentAuthor() _
Implements ICommentAuthorCollection.ToArray
[C#]
public ICommentAuthor[] ToArray();

Return Value

Array of ICommentAuthor

Implements

ICommentAuthorCollection.ToArray

See Also

CommentAuthorCollection Class | Aspose.Slides Namespace


CommentCollection Class

Represents a collection of comments of one author.

For a list of all members of this type, see CommentCollection Members.

System.Object
Aspose.Slides.CommentCollection

[Visual Basic]
NotInheritable Public Class CommentCollection
Implements ICommentCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IComment, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public sealed class CommentCollection : ICommentCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

CommentCollection Members | Aspose.Slides Namespace


CommentCollection Members

CommentCollection overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only Comment.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

AddComment | Add new comment at the end of a collection.
Clear | Removes all comments from a collection.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
InsertComment | Insert new comment to a collection at the specified index.
Remove | Removes the first occurrence of the specified comment in a collection.
RemoveAt | Removes the element at the specified index in a collection.
ToArray | Overloaded. Creates and returns an array with all comments.

See Also

CommentCollection Class | Aspose.Slides Namespace


CommentCollection Properties

The properties of the CommentCollection class are listed below. For a complete list of CommentCollection class members, see the CommentCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only Comment.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

CommentCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

CommentCollection.Count Property

Gets the number of elements actually contained in the collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

CommentCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

CommentCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

CommentCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

CommentCollection.Item Property

Gets the element at the specified index. Read-only Comment.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ICommentCollection.Item
As IComment _
Implements ICommentCollection.Item
[C#]
public IComment this[
int index
] {get;}

Implements

ICommentCollection.Item

See Also

CommentCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

CommentCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

CommentCollection Class | Aspose.Slides Namespace


CommentCollection Methods

The methods of the CommentCollection class are listed below. For a complete list of CommentCollection class members, see the CommentCollection Members topic.

Public Instance Methods

AddComment | Add new comment at the end of a collection.
Clear | Removes all comments from a collection.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
InsertComment | Insert new comment to a collection at the specified index.
Remove | Removes the first occurrence of the specified comment in a collection.
RemoveAt | Removes the element at the specified index in a collection.
ToArray | Overloaded. Creates and returns an array with all comments.

See Also

CommentCollection Class | Aspose.Slides Namespace


CommentCollection.AddComment Method

Add new comment at the end of a collection.

[Visual Basic]
NotOverridable Public Function AddComment( _
ByVal text As String, _
ByVal slide As ISlide, _
ByVal position As PointF, _
ByVal creationTime As Date _
) As IComment _
Implements ICommentCollection.AddComment
[C#]
public IComment AddComment(
string text,
ISlide slide,
PointF position,
DateTime creationTime
);

Parameters

text
Plain text of a new comment.
slide
Slide in a presentation where to add a new comment.
position
Position on a slide where to add a new comment.
creationTime
Time of a comment creation.

Return Value

Added comment.

Implements

ICommentCollection.AddComment

See Also

CommentCollection Class | Aspose.Slides Namespace


CommentCollection.Clear Method

Removes all comments from a collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements ICommentCollection.Clear
[C#]
public void Clear();

Implements

ICommentCollection.Clear

See Also

CommentCollection Class | Aspose.Slides Namespace


CommentCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

CommentCollection Class | Aspose.Slides Namespace


CommentCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

CommentCollection Class | Aspose.Slides Namespace


CommentCollection.InsertComment Method

Insert new comment to a collection at the specified index.

[Visual Basic]
NotOverridable Public Function InsertComment( _
ByVal index As Integer, _
ByVal text As String, _
ByVal slide As ISlide, _
ByVal position As PointF, _
ByVal creationTime As Date _
) As IComment _
Implements ICommentCollection.InsertComment
[C#]
public IComment InsertComment(
int index,
string text,
ISlide slide,
PointF position,
DateTime creationTime
);

Parameters

index
Index of the element in a collection at which comment should be inserted.
text
Plain text of a new comment.
slide
Slide in a presentation where to add a new comment.
position
Position on a slide where to add a new comment.
creationTime
Time of a comment creation.

Return Value

Inserted comment.

Implements

ICommentCollection.InsertComment

See Also

CommentCollection Class | Aspose.Slides Namespace


CommentCollection.Remove Method

Removes the first occurrence of the specified comment in a collection.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal comment As IComment _
) _
Implements ICommentCollection.Remove
[C#]
public void Remove(
IComment comment
);

Parameters

comment
The comment to remove from a collection.

Implements

ICommentCollection.Remove

See Also

CommentCollection Class | Aspose.Slides Namespace


CommentCollection.RemoveAt Method

Removes the element at the specified index in a collection.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements ICommentCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Implements

ICommentCollection.RemoveAt

See Also

CommentCollection Class | Aspose.Slides Namespace


ToArray Method

Aspose.Slides Documentation

CommentCollection.ToArray Method

Creates and returns an array with all comments.

Overload List

Creates and returns an array with all comments.

public IComment[] ToArray();

Creates and returns an array with all comments from the specified range. An index of a first comment to return.A number of comments to return.

public IComment[] ToArray(int,int);

See Also

CommentCollection Class | Aspose.Slides Namespace


CommentCollection.ToArray Method ()

Creates and returns an array with all comments.

[Visual Basic]
NotOverridable Overloads Public Function ToArray() As IComment() _
Implements ICommentCollection.ToArray
[C#]
public IComment[] ToArray();

Return Value

Array of Comment.

Implements

ICommentCollection.ToArray

See Also

CommentCollection Class | Aspose.Slides Namespace | CommentCollection.ToArray Overload List


CommentCollection.ToArray Method (Int32, Int32)

Creates and returns an array with all comments from the specified range. An index of a first comment to return.A number of comments to return.

[Visual Basic]
NotOverridable Overloads Public Function ToArray( _
ByVal startIndex As Integer, _
ByVal count As Integer _
) As IComment() _
Implements ICommentCollection.ToArray
[C#]
public IComment[] ToArray(
int startIndex,
int count
);

Return Value

Array of Comment.

Implements

ICommentCollection.ToArray

See Also

CommentCollection Class | Aspose.Slides Namespace | CommentCollection.ToArray Overload List


Connector Class

Represents a connector.

For a list of all members of this type, see Connector Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GeometryShape
Aspose.Slides.Connector

[Visual Basic]
Public Class Connector
Inherits GeometryShape
Implements IConnector
[C#]
public class Connector : GeometryShape, IConnector

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Connector Members | Aspose.Slides Namespace


Connector Members

Connector overview

Public Instance Properties

Adjustments (inherited from GeometryShape) | Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
EndShapeConnectedTo |
EndShapeConnectionSiteIndex |
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock | Overloaded. Returns shape's locks. Read-only ConnectorLock.
ShapeStyle (inherited from GeometryShape) | Returns shape's style object. Read-only ShapeStyle.
ShapeType | Returns or sets the AutoShape type. Read/write ShapeType.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
StartShapeConnectedTo |
StartShapeConnectionSiteIndex |
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateShapeElements (inherited from GeometryShape) | Creates and returns array of shape's elements.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

Connector Class | Aspose.Slides Namespace


Connector Properties

The properties of the Connector class are listed below. For a complete list of Connector class members, see the Connector Members topic.

Public Instance Properties

Adjustments (inherited from GeometryShape) | Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
EndShapeConnectedTo |
EndShapeConnectionSiteIndex |
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock | Overloaded. Returns shape's locks. Read-only ConnectorLock.
ShapeStyle (inherited from GeometryShape) | Returns shape's style object. Read-only ShapeStyle.
ShapeType | Returns or sets the AutoShape type. Read/write ShapeType.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
StartShapeConnectedTo |
StartShapeConnectionSiteIndex |
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

Connector Class | Aspose.Slides Namespace


EndShapeConnectedTo Property

Aspose.Slides Documentation

Connector.EndShapeConnectedTo Property

[Visual Basic]
NotOverridable Public Property EndShapeConnectedTo As IShape _
Implements IConnector.EndShapeConnectedTo
[C#]
public IShape EndShapeConnectedTo {get; set;}

Implements

IConnector.EndShapeConnectedTo

See Also

Connector Class | Aspose.Slides Namespace


EndShapeConnectionSiteIndex Property

Aspose.Slides Documentation

Connector.EndShapeConnectionSiteIndex Property

[Visual Basic]
NotOverridable Public Property EndShapeConnectionSiteIndex As UInt32 _
Implements IConnector.EndShapeConnectionSiteIndex
[C#]
public uint EndShapeConnectionSiteIndex {get; set;}

Implements

IConnector.EndShapeConnectionSiteIndex

See Also

Connector Class | Aspose.Slides Namespace


ShapeLock Property

Aspose.Slides Documentation

Connector.ShapeLock Property

Returns shape's locks. Read-only ConnectorLock.

[Visual Basic]
NotOverridable Overloads Public ReadOnly Property ShapeLock As IConnectorLock _
Implements IConnector.ShapeLock
[C#]
new public IConnectorLock ShapeLock {get;}

Implements

IConnector.ShapeLock

See Also

Connector Class | Aspose.Slides Namespace


ShapeType Property

Aspose.Slides Documentation

Connector.ShapeType Property

Returns or sets the AutoShape type. Read/write ShapeType.

[Visual Basic]
Overrides Public Property ShapeType As ShapeType _
Implements IGeometryShape.ShapeType
[C#]
public override ShapeType ShapeType {get; set;}

Implements

IGeometryShape.ShapeType

See Also

Connector Class | Aspose.Slides Namespace


StartShapeConnectedTo Property

Aspose.Slides Documentation

Connector.StartShapeConnectedTo Property

[Visual Basic]
NotOverridable Public Property StartShapeConnectedTo As IShape _
Implements IConnector.StartShapeConnectedTo
[C#]
public IShape StartShapeConnectedTo {get; set;}

Implements

IConnector.StartShapeConnectedTo

See Also

Connector Class | Aspose.Slides Namespace


StartShapeConnectionSiteIndex Property

Aspose.Slides Documentation

Connector.StartShapeConnectionSiteIndex Property

[Visual Basic]
NotOverridable Public Property StartShapeConnectionSiteIndex As UInt32 _
Implements IConnector.StartShapeConnectionSiteIndex
[C#]
public uint StartShapeConnectionSiteIndex {get; set;}

Implements

IConnector.StartShapeConnectionSiteIndex

See Also

Connector Class | Aspose.Slides Namespace


ConnectorLock Class

Determines which operations are disabled on the parent Connector.

For a list of all members of this type, see ConnectorLock Members.

System.Object
Aspose.Slides.BaseShapeLock
Aspose.Slides.ConnectorLock

[Visual Basic]
Public Class ConnectorLock
Inherits BaseShapeLock
Implements IConnectorLock
[C#]
public class ConnectorLock : BaseShapeLock, IConnectorLock

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ConnectorLock Members | Aspose.Slides Namespace


ConnectorLock Members

ConnectorLock overview

Public Instance Properties

AdjustHandlesLocked | Determines whether a changing adjust values is forbidden.
ArrowheadsLocked | Determines whether a changing arrowheads is forbidden.
AspectRatioLocked | Determines whether a shape have to preserve aspect ratio on resizing.
EditPointsLocked | Determines whether a direct changing of contour of this shape is forbidden.
GroupingLocked | Determines whether an adding this shape to a group is forbidden.
NoLocks (inherited from BaseShapeLock) | Return true if all lock-flags are disabled.
PositionMove | Determines whether a moving this shape is forbidden.
RotateLocked | Determines whether a changing rotation angle of this shape is forbidden.
SelectLocked | Determines whether a selecting this shape is forbidden.
ShapeTypeLocked | Determines whether a changing of a shape type is forbidden.
SizeLocked | Determines whether a resizing this shape is forbidden.

See Also

ConnectorLock Class | Aspose.Slides Namespace


ConnectorLock Properties

The properties of the ConnectorLock class are listed below. For a complete list of ConnectorLock class members, see the ConnectorLock Members topic.

Public Instance Properties

AdjustHandlesLocked | Determines whether a changing adjust values is forbidden.
ArrowheadsLocked | Determines whether a changing arrowheads is forbidden.
AspectRatioLocked | Determines whether a shape have to preserve aspect ratio on resizing.
EditPointsLocked | Determines whether a direct changing of contour of this shape is forbidden.
GroupingLocked | Determines whether an adding this shape to a group is forbidden.
NoLocks (inherited from BaseShapeLock) | Return true if all lock-flags are disabled.
PositionMove | Determines whether a moving this shape is forbidden.
RotateLocked | Determines whether a changing rotation angle of this shape is forbidden.
SelectLocked | Determines whether a selecting this shape is forbidden.
ShapeTypeLocked | Determines whether a changing of a shape type is forbidden.
SizeLocked | Determines whether a resizing this shape is forbidden.

See Also

ConnectorLock Class | Aspose.Slides Namespace


AdjustHandlesLocked Property

Aspose.Slides Documentation

ConnectorLock.AdjustHandlesLocked Property

Determines whether a changing adjust values is forbidden.

[Visual Basic]
NotOverridable Public Property AdjustHandlesLocked As Boolean _
Implements IConnectorLock.AdjustHandlesLocked
[C#]
public bool AdjustHandlesLocked {get; set;}

Implements

IConnectorLock.AdjustHandlesLocked

See Also

ConnectorLock Class | Aspose.Slides Namespace


ArrowheadsLocked Property

Aspose.Slides Documentation

ConnectorLock.ArrowheadsLocked Property

Determines whether a changing arrowheads is forbidden.

[Visual Basic]
NotOverridable Public Property ArrowheadsLocked As Boolean _
Implements IConnectorLock.ArrowheadsLocked
[C#]
public bool ArrowheadsLocked {get; set;}

Implements

IConnectorLock.ArrowheadsLocked

See Also

ConnectorLock Class | Aspose.Slides Namespace


AspectRatioLocked Property

Aspose.Slides Documentation

ConnectorLock.AspectRatioLocked Property

Determines whether a shape have to preserve aspect ratio on resizing.

[Visual Basic]
NotOverridable Public Property AspectRatioLocked As Boolean _
Implements IConnectorLock.AspectRatioLocked
[C#]
public bool AspectRatioLocked {get; set;}

Implements

IConnectorLock.AspectRatioLocked

See Also

ConnectorLock Class | Aspose.Slides Namespace


EditPointsLocked Property

Aspose.Slides Documentation

ConnectorLock.EditPointsLocked Property

Determines whether a direct changing of contour of this shape is forbidden.

[Visual Basic]
NotOverridable Public Property EditPointsLocked As Boolean _
Implements IConnectorLock.EditPointsLocked
[C#]
public bool EditPointsLocked {get; set;}

Implements

IConnectorLock.EditPointsLocked

See Also

ConnectorLock Class | Aspose.Slides Namespace


GroupingLocked Property

Aspose.Slides Documentation

ConnectorLock.GroupingLocked Property

Determines whether an adding this shape to a group is forbidden.

[Visual Basic]
NotOverridable Public Property GroupingLocked As Boolean _
Implements IConnectorLock.GroupingLocked
[C#]
public bool GroupingLocked {get; set;}

Implements

IConnectorLock.GroupingLocked

See Also

ConnectorLock Class | Aspose.Slides Namespace


PositionMove Property

Aspose.Slides Documentation

ConnectorLock.PositionMove Property

Determines whether a moving this shape is forbidden.

[Visual Basic]
NotOverridable Public Property PositionMove As Boolean _
Implements IConnectorLock.PositionMove
[C#]
public bool PositionMove {get; set;}

Implements

IConnectorLock.PositionMove

See Also

ConnectorLock Class | Aspose.Slides Namespace


RotateLocked Property

Aspose.Slides Documentation

ConnectorLock.RotateLocked Property

Determines whether a changing rotation angle of this shape is forbidden.

[Visual Basic]
NotOverridable Public Property RotateLocked As Boolean _
Implements IConnectorLock.RotateLocked
[C#]
public bool RotateLocked {get; set;}

Implements

IConnectorLock.RotateLocked

See Also

ConnectorLock Class | Aspose.Slides Namespace


SelectLocked Property

Aspose.Slides Documentation

ConnectorLock.SelectLocked Property

Determines whether a selecting this shape is forbidden.

[Visual Basic]
NotOverridable Public Property SelectLocked As Boolean _
Implements IConnectorLock.SelectLocked
[C#]
public bool SelectLocked {get; set;}

Implements

IConnectorLock.SelectLocked

See Also

ConnectorLock Class | Aspose.Slides Namespace


ShapeTypeLocked Property

Aspose.Slides Documentation

ConnectorLock.ShapeTypeLocked Property

Determines whether a changing of a shape type is forbidden.

[Visual Basic]
NotOverridable Public Property ShapeTypeLocked As Boolean _
Implements IConnectorLock.ShapeTypeLocked
[C#]
public bool ShapeTypeLocked {get; set;}

Implements

IConnectorLock.ShapeTypeLocked

See Also

ConnectorLock Class | Aspose.Slides Namespace


SizeLocked Property

Aspose.Slides Documentation

ConnectorLock.SizeLocked Property

Determines whether a resizing this shape is forbidden.

[Visual Basic]
NotOverridable Public Property SizeLocked As Boolean _
Implements IConnectorLock.SizeLocked
[C#]
public bool SizeLocked {get; set;}

Implements

IConnectorLock.SizeLocked

See Also

ConnectorLock Class | Aspose.Slides Namespace


Control Class

Represents an ActiveX control.

For a list of all members of this type, see Control Members.

System.Object
Aspose.Slides.Control

[Visual Basic]
Public Class Control
Implements IControl, ISlideComponent, IPresentationComponent
[C#]
public class Control : IControl, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Control Members | Aspose.Slides Namespace


Control Members

Control overview

Public Instance Properties

ClassId | Gets class id of this control.
Frame | Returns or sets control's frame. Read/write ShapeFrame.
Name | Gets or sets the name of this control.
Properties | Returns a collection of ActiveX properties. Readonly ControlPropertiesCollection. Note: Aspose.Slides supports only XML based ActiveX properties. If properties stored in binary format, this property will return null.
SubstitutePictureFormat | Returns Control image fill properties object. Readonly PictureFillFormat.

See Also

Control Class | Aspose.Slides Namespace


Control Properties

The properties of the Control class are listed below. For a complete list of Control class members, see the Control Members topic.

Public Instance Properties

ClassId | Gets class id of this control.
Frame | Returns or sets control's frame. Read/write ShapeFrame.
Name | Gets or sets the name of this control.
Properties | Returns a collection of ActiveX properties. Readonly ControlPropertiesCollection. Note: Aspose.Slides supports only XML based ActiveX properties. If properties stored in binary format, this property will return null.
SubstitutePictureFormat | Returns Control image fill properties object. Readonly PictureFillFormat.

See Also

Control Class | Aspose.Slides Namespace


ClassId Property

Aspose.Slides Documentation

Control.ClassId Property

Gets class id of this control.

[Visual Basic]
NotOverridable Public ReadOnly Property ClassId As Guid _
Implements IControl.ClassId
[C#]
public Guid ClassId {get;}

Implements

IControl.ClassId

See Also

Control Class | Aspose.Slides Namespace


Frame Property

Aspose.Slides Documentation

Control.Frame Property

Returns or sets control's frame. Read/write ShapeFrame.

[Visual Basic]
NotOverridable Public Property Frame As IShapeFrame _
Implements IControl.Frame
[C#]
public IShapeFrame Frame {get; set;}

Implements

IControl.Frame

See Also

Control Class | Aspose.Slides Namespace


Name Property

Aspose.Slides Documentation

Control.Name Property

Gets or sets the name of this control.

[Visual Basic]
NotOverridable Public Property Name As String _
Implements IControl.Name
[C#]
public string Name {get; set;}

Implements

IControl.Name

See Also

Control Class | Aspose.Slides Namespace


Properties Property

Aspose.Slides Documentation

Control.Properties Property

Returns a collection of ActiveX properties. Readonly ControlPropertiesCollection. Note: Aspose.Slides supports only XML based ActiveX properties. If properties stored in binary format, this property will return null.

[Visual Basic]
NotOverridable Public ReadOnly Property Properties As IControlPropertiesCollection _
Implements IControl.Properties
[C#]
public IControlPropertiesCollection Properties {get;}

Implements

IControl.Properties

See Also

Control Class | Aspose.Slides Namespace


SubstitutePictureFormat Property

Aspose.Slides Documentation

Control.SubstitutePictureFormat Property

Returns Control image fill properties object. Readonly PictureFillFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property SubstitutePictureFormat As IPictureFillFormat _
Implements IControl.SubstitutePictureFormat
[C#]
public IPictureFillFormat SubstitutePictureFormat {get;}

Implements

IControl.SubstitutePictureFormat

See Also

Control Class | Aspose.Slides Namespace


ControlCollection Class

A collection of ActiveX controls.

For a list of all members of this type, see ControlCollection Members.

System.Object
Aspose.Slides.ControlCollection

[Visual Basic]
Public Class ControlCollection
Implements IControlCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IControl, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class ControlCollection : IControlCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ControlCollection Members | Aspose.Slides Namespace


ControlCollection Members

ControlCollection overview

Public Instance Properties

Count | Returns a number of objects in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns a control at the specified position.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

AddControl | Creates and adds a new control to the collection.
Clear | Removes all controls from the collection.
CopyTo | Copies the entire collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
Remove | Removes an ActiveX control from the collection.
RemoveAt | Removes an ActiveX control stored at specified position from the collection.

See Also

ControlCollection Class | Aspose.Slides Namespace


ControlCollection Properties

The properties of the ControlCollection class are listed below. For a complete list of ControlCollection class members, see the ControlCollection Members topic.

Public Instance Properties

Count | Returns a number of objects in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns a control at the specified position.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

ControlCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

ControlCollection.Count Property

Returns a number of objects in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

ControlCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

ControlCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ControlCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ControlCollection.Item Property

Returns a control at the specified position.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IControlCollection.Item
As IControl _
Implements IControlCollection.Item
[C#]
public IControl this[
int index
] {get;}

Parameters

index
Index of a control.

Implements

IControlCollection.Item

See Also

ControlCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

ControlCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ControlCollection Class | Aspose.Slides Namespace


ControlCollection Methods

The methods of the ControlCollection class are listed below. For a complete list of ControlCollection class members, see the ControlCollection Members topic.

Public Instance Methods

AddControl | Creates and adds a new control to the collection.
Clear | Removes all controls from the collection.
CopyTo | Copies the entire collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
Remove | Removes an ActiveX control from the collection.
RemoveAt | Removes an ActiveX control stored at specified position from the collection.

See Also

ControlCollection Class | Aspose.Slides Namespace


ControlCollection.AddControl Method

Creates and adds a new control to the collection.

[Visual Basic]
NotOverridable Public Function AddControl( _
ByVal controlType As ControlType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IControl _
Implements IControlCollection.AddControl
[C#]
public IControl AddControl(
ControlType controlType,
float x,
float y,
float width,
float height
);

Parameters

controlType
Type of a control to add.
x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
width
The width of shape's frame.
height
The height of shape's frame.

Return Value

Created control.

Implements

IControlCollection.AddControl

See Also

ControlCollection Class | Aspose.Slides Namespace


ControlCollection.Clear Method

Removes all controls from the collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IControlCollection.Clear
[C#]
public void Clear();

Implements

IControlCollection.Clear

See Also

ControlCollection Class | Aspose.Slides Namespace


ControlCollection.CopyTo Method

Copies the entire collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array
index
Index in the target array.

Implements

ICollection.CopyTo

See Also

ControlCollection Class | Aspose.Slides Namespace


ControlCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

ControlCollection Class | Aspose.Slides Namespace


ControlCollection.Remove Method

Removes an ActiveX control from the collection.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal item As IControl _
) _
Implements IControlCollection.Remove
[C#]
public void Remove(
IControl item
);

Parameters

item
A control to remove.

Implements

IControlCollection.Remove

See Also

ControlCollection Class | Aspose.Slides Namespace


ControlCollection.RemoveAt Method

Removes an ActiveX control stored at specified position from the collection.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IControlCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
Index of a control to remove.

Implements

IControlCollection.RemoveAt

See Also

ControlCollection Class | Aspose.Slides Namespace


ControlPropertiesCollection Class

A collection of AcitveX properties.

For a list of all members of this type, see ControlPropertiesCollection Members.

System.Object
Aspose.Slides.ControlPropertiesCollection

[Visual Basic]
Public Class ControlPropertiesCollection
Implements IControlPropertiesCollection, IEnumerable`1([System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089),[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)), mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)), IEnumerable
[C#]
public class ControlPropertiesCollection : IControlPropertiesCollection, 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], IEnumerable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ControlPropertiesCollection Members | Aspose.Slides Namespace


ControlPropertiesCollection Members

ControlPropertiesCollection overview

Public Instance Properties

Count | Returns a number of properties in the collection.
Item | Returns or sets property.
NamesOfProperties |

Public Instance Methods

Add | Adds a property to the collection.
Clear | Removes all properties.
GetEnumerator | Returns an enumerator for entire collection.
Remove | Removes a property with the specified name.

See Also

ControlPropertiesCollection Class | Aspose.Slides Namespace


ControlPropertiesCollection Properties

The properties of the ControlPropertiesCollection class are listed below. For a complete list of ControlPropertiesCollection class members, see the ControlPropertiesCollection Members topic.

Public Instance Properties

Count | Returns a number of properties in the collection.
Item | Returns or sets property.
NamesOfProperties |

See Also

ControlPropertiesCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

ControlPropertiesCollection.Count Property

Returns a number of properties in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements IControlPropertiesCollection.Count
[C#]
public int Count {get;}

Implements

IControlPropertiesCollection.Count

See Also

ControlPropertiesCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ControlPropertiesCollection.Item Property

Returns or sets property.

[Visual Basic]
NotOverridable Public Default Property Item( _
ByVal name As String _
) _
Implements IControlPropertiesCollection.Item
As String _
Implements IControlPropertiesCollection.Item
[C#]
public string this[
string name
] {get; set;}

Parameters

name
Name of property.

Implements

IControlPropertiesCollection.Item

See Also

ControlPropertiesCollection Class | Aspose.Slides Namespace


NamesOfProperties Property

Aspose.Slides Documentation

ControlPropertiesCollection.NamesOfProperties Property

[Visual Basic]
NotOverridable Public ReadOnly Property NamesOfProperties As ICollection _
Implements IControlPropertiesCollection.NamesOfProperties
[C#]
public ICollection NamesOfProperties {get;}

Implements

IControlPropertiesCollection.NamesOfProperties

See Also

ControlPropertiesCollection Class | Aspose.Slides Namespace


ControlPropertiesCollection Methods

The methods of the ControlPropertiesCollection class are listed below. For a complete list of ControlPropertiesCollection class members, see the ControlPropertiesCollection Members topic.

Public Instance Methods

Add | Adds a property to the collection.
Clear | Removes all properties.
GetEnumerator | Returns an enumerator for entire collection.
Remove | Removes a property with the specified name.

See Also

ControlPropertiesCollection Class | Aspose.Slides Namespace


ControlPropertiesCollection.Add Method

Adds a property to the collection.

[Visual Basic]
NotOverridable Public Sub Add( _
ByVal name As String, _
ByVal value As String _
) _
Implements IControlPropertiesCollection.Add
[C#]
public void Add(
string name,
string value
);

Parameters

name
The name of the property.
value
The alue of the property.

Implements

IControlPropertiesCollection.Add

See Also

ControlPropertiesCollection Class | Aspose.Slides Namespace


ControlPropertiesCollection.Clear Method

Removes all properties.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IControlPropertiesCollection.Clear
[C#]
public void Clear();

Implements

IControlPropertiesCollection.Clear

See Also

ControlPropertiesCollection Class | Aspose.Slides Namespace


ControlPropertiesCollection.GetEnumerator Method

Returns an enumerator for entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

ControlPropertiesCollection Class | Aspose.Slides Namespace


ControlPropertiesCollection.Remove Method

Removes a property with the specified name.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal name As String _
) _
Implements IControlPropertiesCollection.Remove
[C#]
public void Remove(
string name
);

Parameters

name
The name of property to remove.

Implements

IControlPropertiesCollection.Remove

See Also

ControlPropertiesCollection Class | Aspose.Slides Namespace


ControlType Enumeration

[Visual Basic]
Public Enum ControlType
[C#]
public enum ControlType

Members

Member Name | Description | Value
WindowsMediaPlayer |  | 0

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


CustomData Class

For a list of all members of this type, see CustomData Members.

System.Object
Aspose.Slides.CustomData

[Visual Basic]
Public Class CustomData
Implements ICustomData
[C#]
public class CustomData : ICustomData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

CustomData Members | Aspose.Slides Namespace


CustomData Members

CustomData overview

Public Instance Properties

Tags Returns the Customer Data Tags collection. Read-only ITagCollection.

See Also

CustomData Class | Aspose.Slides Namespace


CustomData Properties

The properties of the CustomData class are listed below. For a complete list of CustomData class members, see the CustomData Members topic.

Public Instance Properties

Tags Returns the Customer Data Tags collection. Read-only ITagCollection.

See Also

CustomData Class | Aspose.Slides Namespace


Tags Property

Aspose.Slides Documentation

CustomData.Tags Property

Returns the Customer Data Tags collection. Read-only ITagCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Tags As ITagCollection _
Implements ICustomData.Tags
[C#]
public ITagCollection Tags {get;}

Implements

ICustomData.Tags

See Also

CustomData Class | Aspose.Slides Namespace


DocumentProperties Class

Represents properties of a presentation.

For a list of all members of this type, see DocumentProperties Members.

System.Object
Aspose.Slides.DocumentProperties

[Visual Basic]
Public Class DocumentProperties
Implements IDocumentProperties
[C#]
public class DocumentProperties : IDocumentProperties

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

DocumentProperties Members | Aspose.Slides Namespace


DocumentProperties Members

DocumentProperties overview

Public Instance Constructors

DocumentProperties Constructor Initializes a new instance of the DocumentProperties class.

Public Instance Properties

ApplicationTemplate | Returns or sets the template of a application. Read/write String.
Author | Returns or sets the author of a presentation. Read/write String.
Category | Returns or sets the category of a presentation. Read/write String.
Comments | Returns or sets the comments of a presentation. Read/write String.
Company | Returns or sets the company property. Read/write String.
ContentStatus | Returns or sets the content status of a presentation. Read/write String.
ContentType | Returns or sets the content type of a presentation. Read/write String.
Count | Returns the number of custom properties actually contained in a collection. Read-only Int32.
CreatedTime | Returns or sets the date when a presentation was created. Read/write DateTime.
HyperlinkBase | Returns or sets the HyperlinkBase document property.
Item | Returns or sets the custom property associated with a specified name. Read/write Object.
Keywords | Returns or sets the keywords of a presentation. Read/write String.
LastPrinted | Returns or sets the date when a presentation was printed last time. Read/write DateTime.
LastSavedBy | Returns or sets the name of a last person who modified a presentation. Read/write String.
LastSavedTime | Returns or sets the date when a presentation was modified last time. Read/write DateTime.
Manager | Returns or sets the manager property. Read/write String.
NameOfApplication | Returns or sets the name of the application. Read/write String.
PresentationFormat | Returns or sets the intended format of a presentation. Read/write String.
RevisionNumber | Returns or sets the presentation revision number. Read/write Int32.
SharedDoc | Determines whether the presentation is shared between multiple people. Read/write Boolean.
Subject | Returns or sets the subject of a presentation. Read/write String.
Title | Returns or sets the title of a presentation. Read/write String.
TotalEditingTime | Total editing time of a presentation. Read/write TimeSpan.

Public Instance Methods

Contains | Check presents of a custom property with a specified name.
GetPropertyName | Return a custom property name at the specified index.
Remove | Remove a custom property associated with a specified name.

See Also

DocumentProperties Class | Aspose.Slides Namespace


DocumentProperties Constructor

Initializes a new instance of the DocumentProperties class.

[Visual Basic]
Public Sub New()
[C#]
public DocumentProperties();

See Also

DocumentProperties Class | Aspose.Slides Namespace


DocumentProperties Properties

The properties of the DocumentProperties class are listed below. For a complete list of DocumentProperties class members, see the DocumentProperties Members topic.

Public Instance Properties

ApplicationTemplate | Returns or sets the template of a application. Read/write String.
Author | Returns or sets the author of a presentation. Read/write String.
Category | Returns or sets the category of a presentation. Read/write String.
Comments | Returns or sets the comments of a presentation. Read/write String.
Company | Returns or sets the company property. Read/write String.
ContentStatus | Returns or sets the content status of a presentation. Read/write String.
ContentType | Returns or sets the content type of a presentation. Read/write String.
Count | Returns the number of custom properties actually contained in a collection. Read-only Int32.
CreatedTime | Returns or sets the date when a presentation was created. Read/write DateTime.
HyperlinkBase | Returns or sets the HyperlinkBase document property.
Item | Returns or sets the custom property associated with a specified name. Read/write Object.
Keywords | Returns or sets the keywords of a presentation. Read/write String.
LastPrinted | Returns or sets the date when a presentation was printed last time. Read/write DateTime.
LastSavedBy | Returns or sets the name of a last person who modified a presentation. Read/write String.
LastSavedTime | Returns or sets the date when a presentation was modified last time. Read/write DateTime.
Manager | Returns or sets the manager property. Read/write String.
NameOfApplication | Returns or sets the name of the application. Read/write String.
PresentationFormat | Returns or sets the intended format of a presentation. Read/write String.
RevisionNumber | Returns or sets the presentation revision number. Read/write Int32.
SharedDoc | Determines whether the presentation is shared between multiple people. Read/write Boolean.
Subject | Returns or sets the subject of a presentation. Read/write String.
Title | Returns or sets the title of a presentation. Read/write String.
TotalEditingTime | Total editing time of a presentation. Read/write TimeSpan.

See Also

DocumentProperties Class | Aspose.Slides Namespace


ApplicationTemplate Property

Aspose.Slides Documentation

DocumentProperties.ApplicationTemplate Property

Returns or sets the template of a application. Read/write String.

[Visual Basic]
NotOverridable Public Property ApplicationTemplate As String _
Implements IDocumentProperties.ApplicationTemplate
[C#]
public string ApplicationTemplate {get; set;}

Implements

IDocumentProperties.ApplicationTemplate

See Also

DocumentProperties Class | Aspose.Slides Namespace


Author Property

Aspose.Slides Documentation

DocumentProperties.Author Property

Returns or sets the author of a presentation. Read/write String.

[Visual Basic]
NotOverridable Public Property Author As String _
Implements IDocumentProperties.Author
[C#]
public string Author {get; set;}

Implements

IDocumentProperties.Author

See Also

DocumentProperties Class | Aspose.Slides Namespace


Category Property

Aspose.Slides Documentation

DocumentProperties.Category Property

Returns or sets the category of a presentation. Read/write String.

[Visual Basic]
NotOverridable Public Property Category As String _
Implements IDocumentProperties.Category
[C#]
public string Category {get; set;}

Implements

IDocumentProperties.Category

See Also

DocumentProperties Class | Aspose.Slides Namespace


Comments Property

Aspose.Slides Documentation

DocumentProperties.Comments Property

Returns or sets the comments of a presentation. Read/write String.

[Visual Basic]
NotOverridable Public Property Comments As String _
Implements IDocumentProperties.Comments
[C#]
public string Comments {get; set;}

Implements

IDocumentProperties.Comments

See Also

DocumentProperties Class | Aspose.Slides Namespace


Company Property

Aspose.Slides Documentation

DocumentProperties.Company Property

Returns or sets the company property. Read/write String.

[Visual Basic]
NotOverridable Public Property Company As String _
Implements IDocumentProperties.Company
[C#]
public string Company {get; set;}

Implements

IDocumentProperties.Company

See Also

DocumentProperties Class | Aspose.Slides Namespace


ContentStatus Property

Aspose.Slides Documentation

DocumentProperties.ContentStatus Property

Returns or sets the content status of a presentation. Read/write String.

[Visual Basic]
NotOverridable Public Property ContentStatus As String _
Implements IDocumentProperties.ContentStatus
[C#]
public string ContentStatus {get; set;}

Implements

IDocumentProperties.ContentStatus

See Also

DocumentProperties Class | Aspose.Slides Namespace


ContentType Property

Aspose.Slides Documentation

DocumentProperties.ContentType Property

Returns or sets the content type of a presentation. Read/write String.

[Visual Basic]
NotOverridable Public Property ContentType As String _
Implements IDocumentProperties.ContentType
[C#]
public string ContentType {get; set;}

Implements

IDocumentProperties.ContentType

See Also

DocumentProperties Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

DocumentProperties.Count Property

Returns the number of custom properties actually contained in a collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements IDocumentProperties.Count
[C#]
public int Count {get;}

Implements

IDocumentProperties.Count

See Also

DocumentProperties Class | Aspose.Slides Namespace


CreatedTime Property

Aspose.Slides Documentation

DocumentProperties.CreatedTime Property

Returns or sets the date when a presentation was created. Read/write DateTime.

[Visual Basic]
NotOverridable Public Property CreatedTime As Date _
Implements IDocumentProperties.CreatedTime
[C#]
public DateTime CreatedTime {get; set;}

Implements

IDocumentProperties.CreatedTime

See Also

DocumentProperties Class | Aspose.Slides Namespace


HyperlinkBase Property

Aspose.Slides Documentation

DocumentProperties.HyperlinkBase Property

Returns or sets the HyperlinkBase document property.

[Visual Basic]
NotOverridable Public Property HyperlinkBase As String _
Implements IDocumentProperties.HyperlinkBase
[C#]
public string HyperlinkBase {get; set;}

Implements

IDocumentProperties.HyperlinkBase

See Also

DocumentProperties Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

DocumentProperties.Item Property

Returns or sets the custom property associated with a specified name. Read/write Object.

[Visual Basic]
NotOverridable Public Default Property Item( _
ByVal name As String _
) _
Implements IDocumentProperties.Item
As Object _
Implements IDocumentProperties.Item
[C#]
public object this[
string name
] {get; set;}

Implements

IDocumentProperties.Item

Remarks

Value can be int, float, string, bool or DateTime.

See Also

DocumentProperties Class | Aspose.Slides Namespace


Keywords Property

Aspose.Slides Documentation

DocumentProperties.Keywords Property

Returns or sets the keywords of a presentation. Read/write String.

[Visual Basic]
NotOverridable Public Property Keywords As String _
Implements IDocumentProperties.Keywords
[C#]
public string Keywords {get; set;}

Implements

IDocumentProperties.Keywords

See Also

DocumentProperties Class | Aspose.Slides Namespace


LastPrinted Property

Aspose.Slides Documentation

DocumentProperties.LastPrinted Property

Returns or sets the date when a presentation was printed last time. Read/write DateTime.

[Visual Basic]
NotOverridable Public Property LastPrinted As Date _
Implements IDocumentProperties.LastPrinted
[C#]
public DateTime LastPrinted {get; set;}

Implements

IDocumentProperties.LastPrinted

See Also

DocumentProperties Class | Aspose.Slides Namespace


LastSavedBy Property

Aspose.Slides Documentation

DocumentProperties.LastSavedBy Property

Returns or sets the name of a last person who modified a presentation. Read/write String.

[Visual Basic]
NotOverridable Public Property LastSavedBy As String _
Implements IDocumentProperties.LastSavedBy
[C#]
public string LastSavedBy {get; set;}

Implements

IDocumentProperties.LastSavedBy

See Also

DocumentProperties Class | Aspose.Slides Namespace


LastSavedTime Property

Aspose.Slides Documentation

DocumentProperties.LastSavedTime Property

Returns or sets the date when a presentation was modified last time. Read/write DateTime.

[Visual Basic]
NotOverridable Public Property LastSavedTime As Date _
Implements IDocumentProperties.LastSavedTime
[C#]
public DateTime LastSavedTime {get; set;}

Implements

IDocumentProperties.LastSavedTime

See Also

DocumentProperties Class | Aspose.Slides Namespace


Manager Property

Aspose.Slides Documentation

DocumentProperties.Manager Property

Returns or sets the manager property. Read/write String.

[Visual Basic]
NotOverridable Public Property Manager As String _
Implements IDocumentProperties.Manager
[C#]
public string Manager {get; set;}

Implements

IDocumentProperties.Manager

See Also

DocumentProperties Class | Aspose.Slides Namespace


NameOfApplication Property

Aspose.Slides Documentation

DocumentProperties.NameOfApplication Property

Returns or sets the name of the application. Read/write String.

[Visual Basic]
NotOverridable Public Property NameOfApplication As String _
Implements IDocumentProperties.NameOfApplication
[C#]
public string NameOfApplication {get; set;}

Implements

IDocumentProperties.NameOfApplication

See Also

DocumentProperties Class | Aspose.Slides Namespace


PresentationFormat Property

Aspose.Slides Documentation

DocumentProperties.PresentationFormat Property

Returns or sets the intended format of a presentation. Read/write String.

[Visual Basic]
NotOverridable Public Property PresentationFormat As String _
Implements IDocumentProperties.PresentationFormat
[C#]
public string PresentationFormat {get; set;}

Implements

IDocumentProperties.PresentationFormat

See Also

DocumentProperties Class | Aspose.Slides Namespace


RevisionNumber Property

Aspose.Slides Documentation

DocumentProperties.RevisionNumber Property

Returns or sets the presentation revision number. Read/write Int32.

[Visual Basic]
NotOverridable Public Property RevisionNumber As Integer _
Implements IDocumentProperties.RevisionNumber
[C#]
public int RevisionNumber {get; set;}

Implements

IDocumentProperties.RevisionNumber

See Also

DocumentProperties Class | Aspose.Slides Namespace


SharedDoc Property

Aspose.Slides Documentation

DocumentProperties.SharedDoc Property

Determines whether the presentation is shared between multiple people. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property SharedDoc As Boolean _
Implements IDocumentProperties.SharedDoc
[C#]
public bool SharedDoc {get; set;}

Implements

IDocumentProperties.SharedDoc

See Also

DocumentProperties Class | Aspose.Slides Namespace


Subject Property

Aspose.Slides Documentation

DocumentProperties.Subject Property

Returns or sets the subject of a presentation. Read/write String.

[Visual Basic]
NotOverridable Public Property Subject As String _
Implements IDocumentProperties.Subject
[C#]
public string Subject {get; set;}

Implements

IDocumentProperties.Subject

See Also

DocumentProperties Class | Aspose.Slides Namespace


Title Property

Aspose.Slides Documentation

DocumentProperties.Title Property

Returns or sets the title of a presentation. Read/write String.

[Visual Basic]
NotOverridable Public Property Title As String _
Implements IDocumentProperties.Title
[C#]
public string Title {get; set;}

Implements

IDocumentProperties.Title

See Also

DocumentProperties Class | Aspose.Slides Namespace


TotalEditingTime Property

Aspose.Slides Documentation

DocumentProperties.TotalEditingTime Property

Total editing time of a presentation. Read/write TimeSpan.

[Visual Basic]
NotOverridable Public Property TotalEditingTime As TimeSpan _
Implements IDocumentProperties.TotalEditingTime
[C#]
public TimeSpan TotalEditingTime {get; set;}

Implements

IDocumentProperties.TotalEditingTime

See Also

DocumentProperties Class | Aspose.Slides Namespace


DocumentProperties Methods

The methods of the DocumentProperties class are listed below. For a complete list of DocumentProperties class members, see the DocumentProperties Members topic.

Public Instance Methods

Contains | Check presents of a custom property with a specified name.
GetPropertyName | Return a custom property name at the specified index.
Remove | Remove a custom property associated with a specified name.

See Also

DocumentProperties Class | Aspose.Slides Namespace


DocumentProperties.Contains Method

Check presents of a custom property with a specified name.

[Visual Basic]
NotOverridable Public Function Contains( _
ByVal name As String _
) As Boolean _
Implements IDocumentProperties.Contains
[C#]
public bool Contains(
string name
);

Parameters

name
Name of a custom property to check.

Return Value

Return true if property exists, false overwise.

Implements

IDocumentProperties.Contains

See Also

DocumentProperties Class | Aspose.Slides Namespace


DocumentProperties.GetPropertyName Method

Return a custom property name at the specified index.

[Visual Basic]
NotOverridable Public Function GetPropertyName( _
ByVal index As Integer _
) As String _
Implements IDocumentProperties.GetPropertyName
[C#]
public string GetPropertyName(
int index
);

Parameters

index
The zero-based index of a custom property to get.

Return Value

Custom property name at the specified index.

Implements

IDocumentProperties.GetPropertyName

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Index is less than zero. Index is equal to or greater than Count.

See Also

DocumentProperties Class | Aspose.Slides Namespace


DocumentProperties.Remove Method

Remove a custom property associated with a specified name.

[Visual Basic]
NotOverridable Public Function Remove( _
ByVal name As String _
) As Boolean _
Implements IDocumentProperties.Remove
[C#]
public bool Remove(
string name
);

Parameters

name
Name of a custom property to remove.

Return Value

Return true if a property was removed, false overwise.

Implements

IDocumentProperties.Remove

See Also

DocumentProperties Class | Aspose.Slides Namespace


EffectFormat Class

Represents effect properties of shape.

For a list of all members of this type, see EffectFormat Members.

System.Object
Aspose.Slides.EffectFormat

[Visual Basic]
Public Class EffectFormat
Implements IEffectFormat, ISlideComponent, IPresentationComponent
[C#]
public class EffectFormat : IEffectFormat, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

EffectFormat Members | Aspose.Slides Namespace


EffectFormat Members

EffectFormat overview

Public Instance Properties

BlurEffect | Blur effect.
FillOverlayEffect | Fill overlay effect.
GlowEffect | Glow effect.
InnerShadowEffect | Inner shadow.
IsNoEffects | Returns true if all effects are disabled (as just created, default EffectFormat object).
OuterShadowEffect | Outer shadow.
PresetShadowEffect | Preset shadow.
ReflectionEffect | Reflection.
SoftEdgeEffect | Soft edge.

Public Instance Methods

DisableBlurEffect |
DisableFillOverlayEffect |
DisableGlowEffect |
DisableInnerShadowEffect |
DisableOuterShadowEffect |
DisablePresetShadowEffect |
DisableReflectionEffect |
DisableSoftEdgeEffect |
EnableFillOverlayEffect |
EnableGlowEffect |
EnableInnerShadowEffect |
EnableOuterShadowEffect |
EnablePresetShadowEffect |
EnableReflectionEffect |
EnableSoftEdgeEffect |
Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
SetBlurEffect |

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat Properties

The properties of the EffectFormat class are listed below. For a complete list of EffectFormat class members, see the EffectFormat Members topic.

Public Instance Properties

BlurEffect | Blur effect.
FillOverlayEffect | Fill overlay effect.
GlowEffect | Glow effect.
InnerShadowEffect | Inner shadow.
IsNoEffects | Returns true if all effects are disabled (as just created, default EffectFormat object).
OuterShadowEffect | Outer shadow.
PresetShadowEffect | Preset shadow.
ReflectionEffect | Reflection.
SoftEdgeEffect | Soft edge.

See Also

EffectFormat Class | Aspose.Slides Namespace


BlurEffect Property

Aspose.Slides Documentation

EffectFormat.BlurEffect Property

Blur effect.

[Visual Basic]
NotOverridable Public Property BlurEffect As IBlur _
Implements IEffectFormat.BlurEffect
[C#]
public IBlur BlurEffect {get; set;}

Implements

IEffectFormat.BlurEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


FillOverlayEffect Property

Aspose.Slides Documentation

EffectFormat.FillOverlayEffect Property

Fill overlay effect.

[Visual Basic]
NotOverridable Public Property FillOverlayEffect As IFillOverlay _
Implements IEffectFormat.FillOverlayEffect
[C#]
public IFillOverlay FillOverlayEffect {get; set;}

Implements

IEffectFormat.FillOverlayEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


GlowEffect Property

Aspose.Slides Documentation

EffectFormat.GlowEffect Property

Glow effect.

[Visual Basic]
NotOverridable Public Property GlowEffect As IGlow _
Implements IEffectFormat.GlowEffect
[C#]
public IGlow GlowEffect {get; set;}

Implements

IEffectFormat.GlowEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


InnerShadowEffect Property

Aspose.Slides Documentation

EffectFormat.InnerShadowEffect Property

Inner shadow.

[Visual Basic]
NotOverridable Public Property InnerShadowEffect As IInnerShadow _
Implements IEffectFormat.InnerShadowEffect
[C#]
public IInnerShadow InnerShadowEffect {get; set;}

Implements

IEffectFormat.InnerShadowEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


IsNoEffects Property

Aspose.Slides Documentation

EffectFormat.IsNoEffects Property

Returns true if all effects are disabled (as just created, default EffectFormat object).

[Visual Basic]
NotOverridable Public ReadOnly Property IsNoEffects As Boolean _
Implements IEffectFormat.IsNoEffects
[C#]
public bool IsNoEffects {get;}

Implements

IEffectFormat.IsNoEffects

See Also

EffectFormat Class | Aspose.Slides Namespace


OuterShadowEffect Property

Aspose.Slides Documentation

EffectFormat.OuterShadowEffect Property

Outer shadow.

[Visual Basic]
NotOverridable Public Property OuterShadowEffect As IOuterShadow _
Implements IEffectFormat.OuterShadowEffect
[C#]
public IOuterShadow OuterShadowEffect {get; set;}

Implements

IEffectFormat.OuterShadowEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


PresetShadowEffect Property

Aspose.Slides Documentation

EffectFormat.PresetShadowEffect Property

Preset shadow.

[Visual Basic]
NotOverridable Public Property PresetShadowEffect As IPresetShadow _
Implements IEffectFormat.PresetShadowEffect
[C#]
public IPresetShadow PresetShadowEffect {get; set;}

Implements

IEffectFormat.PresetShadowEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


ReflectionEffect Property

Aspose.Slides Documentation

EffectFormat.ReflectionEffect Property

Reflection.

[Visual Basic]
NotOverridable Public Property ReflectionEffect As IReflection _
Implements IEffectFormat.ReflectionEffect
[C#]
public IReflection ReflectionEffect {get; set;}

Implements

IEffectFormat.ReflectionEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


SoftEdgeEffect Property

Aspose.Slides Documentation

EffectFormat.SoftEdgeEffect Property

Soft edge.

[Visual Basic]
NotOverridable Public Property SoftEdgeEffect As ISoftEdge _
Implements IEffectFormat.SoftEdgeEffect
[C#]
public ISoftEdge SoftEdgeEffect {get; set;}

Implements

IEffectFormat.SoftEdgeEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat Methods

The methods of the EffectFormat class are listed below. For a complete list of EffectFormat class members, see the EffectFormat Members topic.

Public Instance Methods

DisableBlurEffect |
DisableFillOverlayEffect |
DisableGlowEffect |
DisableInnerShadowEffect |
DisableOuterShadowEffect |
DisablePresetShadowEffect |
DisableReflectionEffect |
DisableSoftEdgeEffect |
EnableFillOverlayEffect |
EnableGlowEffect |
EnableInnerShadowEffect |
EnableOuterShadowEffect |
EnablePresetShadowEffect |
EnableReflectionEffect |
EnableSoftEdgeEffect |
Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
SetBlurEffect |

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.DisableBlurEffect Method

[Visual Basic]
NotOverridable Public Sub DisableBlurEffect() _
Implements IEffectFormat.DisableBlurEffect
[C#]
public void DisableBlurEffect();

Implements

IEffectFormat.DisableBlurEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.DisableFillOverlayEffect Method

[Visual Basic]
NotOverridable Public Sub DisableFillOverlayEffect() _
Implements IEffectFormat.DisableFillOverlayEffect
[C#]
public void DisableFillOverlayEffect();

Implements

IEffectFormat.DisableFillOverlayEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.DisableGlowEffect Method

[Visual Basic]
NotOverridable Public Sub DisableGlowEffect() _
Implements IEffectFormat.DisableGlowEffect
[C#]
public void DisableGlowEffect();

Implements

IEffectFormat.DisableGlowEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.DisableInnerShadowEffect Method

[Visual Basic]
NotOverridable Public Sub DisableInnerShadowEffect() _
Implements IEffectFormat.DisableInnerShadowEffect
[C#]
public void DisableInnerShadowEffect();

Implements

IEffectFormat.DisableInnerShadowEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.DisableOuterShadowEffect Method

[Visual Basic]
NotOverridable Public Sub DisableOuterShadowEffect() _
Implements IEffectFormat.DisableOuterShadowEffect
[C#]
public void DisableOuterShadowEffect();

Implements

IEffectFormat.DisableOuterShadowEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.DisablePresetShadowEffect Method

[Visual Basic]
NotOverridable Public Sub DisablePresetShadowEffect() _
Implements IEffectFormat.DisablePresetShadowEffect
[C#]
public void DisablePresetShadowEffect();

Implements

IEffectFormat.DisablePresetShadowEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.DisableReflectionEffect Method

[Visual Basic]
NotOverridable Public Sub DisableReflectionEffect() _
Implements IEffectFormat.DisableReflectionEffect
[C#]
public void DisableReflectionEffect();

Implements

IEffectFormat.DisableReflectionEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.DisableSoftEdgeEffect Method

[Visual Basic]
NotOverridable Public Sub DisableSoftEdgeEffect() _
Implements IEffectFormat.DisableSoftEdgeEffect
[C#]
public void DisableSoftEdgeEffect();

Implements

IEffectFormat.DisableSoftEdgeEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.EnableFillOverlayEffect Method

[Visual Basic]
NotOverridable Public Sub EnableFillOverlayEffect() _
Implements IEffectFormat.EnableFillOverlayEffect
[C#]
public void EnableFillOverlayEffect();

Implements

IEffectFormat.EnableFillOverlayEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.EnableGlowEffect Method

[Visual Basic]
NotOverridable Public Sub EnableGlowEffect() _
Implements IEffectFormat.EnableGlowEffect
[C#]
public void EnableGlowEffect();

Implements

IEffectFormat.EnableGlowEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.EnableInnerShadowEffect Method

[Visual Basic]
NotOverridable Public Sub EnableInnerShadowEffect() _
Implements IEffectFormat.EnableInnerShadowEffect
[C#]
public void EnableInnerShadowEffect();

Implements

IEffectFormat.EnableInnerShadowEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.EnableOuterShadowEffect Method

[Visual Basic]
NotOverridable Public Sub EnableOuterShadowEffect() _
Implements IEffectFormat.EnableOuterShadowEffect
[C#]
public void EnableOuterShadowEffect();

Implements

IEffectFormat.EnableOuterShadowEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.EnablePresetShadowEffect Method

[Visual Basic]
NotOverridable Public Sub EnablePresetShadowEffect() _
Implements IEffectFormat.EnablePresetShadowEffect
[C#]
public void EnablePresetShadowEffect();

Implements

IEffectFormat.EnablePresetShadowEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.EnableReflectionEffect Method

[Visual Basic]
NotOverridable Public Sub EnableReflectionEffect() _
Implements IEffectFormat.EnableReflectionEffect
[C#]
public void EnableReflectionEffect();

Implements

IEffectFormat.EnableReflectionEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.EnableSoftEdgeEffect Method

[Visual Basic]
NotOverridable Public Sub EnableSoftEdgeEffect() _
Implements IEffectFormat.EnableSoftEdgeEffect
[C#]
public void EnableSoftEdgeEffect();

Implements

IEffectFormat.EnableSoftEdgeEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.Equals Method

Determines whether two FillFormat instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Remarks

Overriden to make compiler happy.

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormat.SetBlurEffect Method

[Visual Basic]
NotOverridable Public Sub SetBlurEffect( _
ByVal radius As Double, _
ByVal grow As Boolean _
) _
Implements IEffectFormat.SetBlurEffect
[C#]
public void SetBlurEffect(
double radius,
bool grow
);

Implements

IEffectFormat.SetBlurEffect

See Also

EffectFormat Class | Aspose.Slides Namespace


EffectFormatEffectiveData Class

Imutable object which contains effect properties.

For a list of all members of this type, see EffectFormatEffectiveData Members.

System.Object
Aspose.Slides.EffectFormatEffectiveData

[Visual Basic]
Public Class EffectFormatEffectiveData
Implements IEffectFormatEffectiveData
[C#]
public class EffectFormatEffectiveData : IEffectFormatEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

EffectFormatEffectiveData Members | Aspose.Slides Namespace


EffectFormatEffectiveData Members

EffectFormatEffectiveData overview

Public Instance Properties

BlurEffect | Blur effect.
FillOverlayEffect | Fill overlay effect.
GlowEffect | Glow effect.
InnerShadowEffect | Inner shadow.
IsNoEffects | Returns true if all effects are disabled (as just created, default EffectFormat object).
OuterShadowEffect | Outer shadow.
PresetShadowEffect | Preset shadow.
ReflectionEffect | Reflection.
SoftEdgeEffect | Soft edge.

See Also

EffectFormatEffectiveData Class | Aspose.Slides Namespace


EffectFormatEffectiveData Properties

The properties of the EffectFormatEffectiveData class are listed below. For a complete list of EffectFormatEffectiveData class members, see the EffectFormatEffectiveData Members topic.

Public Instance Properties

BlurEffect | Blur effect.
FillOverlayEffect | Fill overlay effect.
GlowEffect | Glow effect.
InnerShadowEffect | Inner shadow.
IsNoEffects | Returns true if all effects are disabled (as just created, default EffectFormat object).
OuterShadowEffect | Outer shadow.
PresetShadowEffect | Preset shadow.
ReflectionEffect | Reflection.
SoftEdgeEffect | Soft edge.

See Also

EffectFormatEffectiveData Class | Aspose.Slides Namespace


BlurEffect Property

Aspose.Slides Documentation

EffectFormatEffectiveData.BlurEffect Property

Blur effect.

[Visual Basic]
NotOverridable Public ReadOnly Property BlurEffect As IBlurEffectiveData _
Implements IEffectFormatEffectiveData.BlurEffect
[C#]
public IBlurEffectiveData BlurEffect {get;}

Implements

IEffectFormatEffectiveData.BlurEffect

See Also

EffectFormatEffectiveData Class | Aspose.Slides Namespace


FillOverlayEffect Property

Aspose.Slides Documentation

EffectFormatEffectiveData.FillOverlayEffect Property

Fill overlay effect.

[Visual Basic]
NotOverridable Public ReadOnly Property FillOverlayEffect As IFillOverlayEffectiveData _
Implements IEffectFormatEffectiveData.FillOverlayEffect
[C#]
public IFillOverlayEffectiveData FillOverlayEffect {get;}

Implements

IEffectFormatEffectiveData.FillOverlayEffect

See Also

EffectFormatEffectiveData Class | Aspose.Slides Namespace


GlowEffect Property

Aspose.Slides Documentation

EffectFormatEffectiveData.GlowEffect Property

Glow effect.

[Visual Basic]
NotOverridable Public ReadOnly Property GlowEffect As IGlowEffectiveData _
Implements IEffectFormatEffectiveData.GlowEffect
[C#]
public IGlowEffectiveData GlowEffect {get;}

Implements

IEffectFormatEffectiveData.GlowEffect

See Also

EffectFormatEffectiveData Class | Aspose.Slides Namespace


InnerShadowEffect Property

Aspose.Slides Documentation

EffectFormatEffectiveData.InnerShadowEffect Property

Inner shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property InnerShadowEffect As IInnerShadowEffectiveData _
Implements IEffectFormatEffectiveData.InnerShadowEffect
[C#]
public IInnerShadowEffectiveData InnerShadowEffect {get;}

Implements

IEffectFormatEffectiveData.InnerShadowEffect

See Also

EffectFormatEffectiveData Class | Aspose.Slides Namespace


IsNoEffects Property

Aspose.Slides Documentation

EffectFormatEffectiveData.IsNoEffects Property

Returns true if all effects are disabled (as just created, default EffectFormat object).

[Visual Basic]
NotOverridable Public ReadOnly Property IsNoEffects As Boolean _
Implements IEffectFormatEffectiveData.IsNoEffects
[C#]
public bool IsNoEffects {get;}

Implements

IEffectFormatEffectiveData.IsNoEffects

See Also

EffectFormatEffectiveData Class | Aspose.Slides Namespace


OuterShadowEffect Property

Aspose.Slides Documentation

EffectFormatEffectiveData.OuterShadowEffect Property

Outer shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property OuterShadowEffect As IOuterShadowEffectiveData _
Implements IEffectFormatEffectiveData.OuterShadowEffect
[C#]
public IOuterShadowEffectiveData OuterShadowEffect {get;}

Implements

IEffectFormatEffectiveData.OuterShadowEffect

See Also

EffectFormatEffectiveData Class | Aspose.Slides Namespace


PresetShadowEffect Property

Aspose.Slides Documentation

EffectFormatEffectiveData.PresetShadowEffect Property

Preset shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property PresetShadowEffect As IPresetShadowEffectiveData _
Implements IEffectFormatEffectiveData.PresetShadowEffect
[C#]
public IPresetShadowEffectiveData PresetShadowEffect {get;}

Implements

IEffectFormatEffectiveData.PresetShadowEffect

See Also

EffectFormatEffectiveData Class | Aspose.Slides Namespace


ReflectionEffect Property

Aspose.Slides Documentation

EffectFormatEffectiveData.ReflectionEffect Property

Reflection.

[Visual Basic]
NotOverridable Public ReadOnly Property ReflectionEffect As IReflectionEffectiveData _
Implements IEffectFormatEffectiveData.ReflectionEffect
[C#]
public IReflectionEffectiveData ReflectionEffect {get;}

Implements

IEffectFormatEffectiveData.ReflectionEffect

See Also

EffectFormatEffectiveData Class | Aspose.Slides Namespace


SoftEdgeEffect Property

Aspose.Slides Documentation

EffectFormatEffectiveData.SoftEdgeEffect Property

Soft edge.

[Visual Basic]
NotOverridable Public ReadOnly Property SoftEdgeEffect As ISoftEdgeEffectiveData _
Implements IEffectFormatEffectiveData.SoftEdgeEffect
[C#]
public ISoftEdgeEffectiveData SoftEdgeEffect {get;}

Implements

IEffectFormatEffectiveData.SoftEdgeEffect

See Also

EffectFormatEffectiveData Class | Aspose.Slides Namespace


Field Class

Represents a field.

For a list of all members of this type, see Field Members.

System.Object
Aspose.Slides.Field

[Visual Basic]
NotInheritable Public Class Field
Implements IField, ISlideComponent, IPresentationComponent
[C#]
public sealed class Field : IField, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Field Members | Aspose.Slides Namespace


Field Members

Field overview

Public Instance Properties

Type Returns or sets field's type. Read/write FieldType.

See Also

Field Class | Aspose.Slides Namespace


Field Properties

The properties of the Field class are listed below. For a complete list of Field class members, see the Field Members topic.

Public Instance Properties

Type Returns or sets field's type. Read/write FieldType.

See Also

Field Class | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

Field.Type Property

Returns or sets field's type. Read/write FieldType.

[Visual Basic]
NotOverridable Public Property Type As IFieldType _
Implements IField.Type
[C#]
public IFieldType Type {get; set;}

Implements

IField.Type

See Also

Field Class | Aspose.Slides Namespace


FieldType Class

Represents a type of field. This value determines which text will be set to the field portion when it will be updated.

For a list of all members of this type, see FieldType Members.

System.Object
Aspose.Slides.FieldType

[Visual Basic]
NotInheritable Public Class FieldType
Implements IFieldType
[C#]
public sealed class FieldType : IFieldType

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FieldType Members | Aspose.Slides Namespace


FieldType Members

FieldType overview

Public Static (Shared) Properties

DateTime | Current date and time in default date time format for the rendering application.
DateTime1 | Current date and time in a first predefined format (MM/DD/YYYY for english).
DateTime10 | Current date and time in a tenth predefined format (hh:mm for english).
DateTime11 | Current date and time in a eleventh predefined format (hh:mm:ss for english).
DateTime12 | Current date and time in a twelfth predefined format (hh:mm AM/PM for english)
DateTime13 | Current date and time in a thirteenth predefined format (hh:mm:ss AM/PM for english)
DateTime2 | Current date and time in a second predefined format (Day, Month DD, YYYY for english).
DateTime3 | Current date and time in a third predefined format (DD Month YYYY for english).
DateTime4 | Current date and time in a fourth predefined format (Month DD, YYYY for english).
DateTime5 | Current date and time in a fifth predefined format (DD-Mon-YY for english).
DateTime6 | Current date and time in a sixth predefined format (Month YY for english).
DateTime7 | Current date and time in a seventh predefined format (Mon-YY for english).
DateTime8 | Current date and time in a eighth predefined format (MM/DD/YYYY hh:mm AM/PM for english).
DateTime9 | Current date and time in a ninth predefined format (MM/DD/YYYY hh:mm:ss AM/PM for english).
SlideNumber | Current slide's number.

Public Static (Shared) Operators

Equality Operator | Checks if two FieldType objects is equal.
Inequality Operator | Checks if two FieldType objects is inequal.

Public Instance Constructors

FieldType Constructor Initializes a new instance of FieldType class.

Public Instance Properties

InternalString Returns the internal name of this FieldType object.

Public Instance Methods

Equals | Checks if this field is equal to another.
GetHashCode | Returns hashcode for this object.

See Also

FieldType Class | Aspose.Slides Namespace


FieldType Constructor

Initializes a new instance of FieldType class.

[Visual Basic]
Public Sub New( _
ByVal str As String _
)
[C#]
public FieldType(
string str
);

See Also

FieldType Class | Aspose.Slides Namespace


FieldType Properties

The properties of the FieldType class are listed below. For a complete list of FieldType class members, see the FieldType Members topic.

Public Static (Shared) Properties

DateTime | Current date and time in default date time format for the rendering application.
DateTime1 | Current date and time in a first predefined format (MM/DD/YYYY for english).
DateTime10 | Current date and time in a tenth predefined format (hh:mm for english).
DateTime11 | Current date and time in a eleventh predefined format (hh:mm:ss for english).
DateTime12 | Current date and time in a twelfth predefined format (hh:mm AM/PM for english)
DateTime13 | Current date and time in a thirteenth predefined format (hh:mm:ss AM/PM for english)
DateTime2 | Current date and time in a second predefined format (Day, Month DD, YYYY for english).
DateTime3 | Current date and time in a third predefined format (DD Month YYYY for english).
DateTime4 | Current date and time in a fourth predefined format (Month DD, YYYY for english).
DateTime5 | Current date and time in a fifth predefined format (DD-Mon-YY for english).
DateTime6 | Current date and time in a sixth predefined format (Month YY for english).
DateTime7 | Current date and time in a seventh predefined format (Mon-YY for english).
DateTime8 | Current date and time in a eighth predefined format (MM/DD/YYYY hh:mm AM/PM for english).
DateTime9 | Current date and time in a ninth predefined format (MM/DD/YYYY hh:mm:ss AM/PM for english).
SlideNumber | Current slide's number.

Public Instance Properties

InternalString Returns the internal name of this FieldType object.

See Also

FieldType Class | Aspose.Slides Namespace


DateTime Property

Aspose.Slides Documentation

FieldType.DateTime Property

Current date and time in default date time format for the rendering application.

[Visual Basic]
Public Shared ReadOnly Property DateTime As FieldType
[C#]
public static FieldType DateTime {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime1 Property

Aspose.Slides Documentation

FieldType.DateTime1 Property

Current date and time in a first predefined format (MM/DD/YYYY for english).

[Visual Basic]
Public Shared ReadOnly Property DateTime1 As FieldType
[C#]
public static FieldType DateTime1 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime10 Property

Aspose.Slides Documentation

FieldType.DateTime10 Property

Current date and time in a tenth predefined format (hh:mm for english).

[Visual Basic]
Public Shared ReadOnly Property DateTime10 As FieldType
[C#]
public static FieldType DateTime10 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime11 Property

Aspose.Slides Documentation

FieldType.DateTime11 Property

Current date and time in a eleventh predefined format (hh:mm:ss for english).

[Visual Basic]
Public Shared ReadOnly Property DateTime11 As FieldType
[C#]
public static FieldType DateTime11 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime12 Property

Aspose.Slides Documentation

FieldType.DateTime12 Property

Current date and time in a twelfth predefined format (hh:mm AM/PM for english)

[Visual Basic]
Public Shared ReadOnly Property DateTime12 As FieldType
[C#]
public static FieldType DateTime12 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime13 Property

Aspose.Slides Documentation

FieldType.DateTime13 Property

Current date and time in a thirteenth predefined format (hh:mm:ss AM/PM for english)

[Visual Basic]
Public Shared ReadOnly Property DateTime13 As FieldType
[C#]
public static FieldType DateTime13 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime2 Property

Aspose.Slides Documentation

FieldType.DateTime2 Property

Current date and time in a second predefined format (Day, Month DD, YYYY for english).

[Visual Basic]
Public Shared ReadOnly Property DateTime2 As FieldType
[C#]
public static FieldType DateTime2 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime3 Property

Aspose.Slides Documentation

FieldType.DateTime3 Property

Current date and time in a third predefined format (DD Month YYYY for english).

[Visual Basic]
Public Shared ReadOnly Property DateTime3 As FieldType
[C#]
public static FieldType DateTime3 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime4 Property

Aspose.Slides Documentation

FieldType.DateTime4 Property

Current date and time in a fourth predefined format (Month DD, YYYY for english).

[Visual Basic]
Public Shared ReadOnly Property DateTime4 As FieldType
[C#]
public static FieldType DateTime4 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime5 Property

Aspose.Slides Documentation

FieldType.DateTime5 Property

Current date and time in a fifth predefined format (DD-Mon-YY for english).

[Visual Basic]
Public Shared ReadOnly Property DateTime5 As FieldType
[C#]
public static FieldType DateTime5 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime6 Property

Aspose.Slides Documentation

FieldType.DateTime6 Property

Current date and time in a sixth predefined format (Month YY for english).

[Visual Basic]
Public Shared ReadOnly Property DateTime6 As FieldType
[C#]
public static FieldType DateTime6 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime7 Property

Aspose.Slides Documentation

FieldType.DateTime7 Property

Current date and time in a seventh predefined format (Mon-YY for english).

[Visual Basic]
Public Shared ReadOnly Property DateTime7 As FieldType
[C#]
public static FieldType DateTime7 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime8 Property

Aspose.Slides Documentation

FieldType.DateTime8 Property

Current date and time in a eighth predefined format (MM/DD/YYYY hh:mm AM/PM for english).

[Visual Basic]
Public Shared ReadOnly Property DateTime8 As FieldType
[C#]
public static FieldType DateTime8 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


DateTime9 Property

Aspose.Slides Documentation

FieldType.DateTime9 Property

Current date and time in a ninth predefined format (MM/DD/YYYY hh:mm:ss AM/PM for english).

[Visual Basic]
Public Shared ReadOnly Property DateTime9 As FieldType
[C#]
public static FieldType DateTime9 {get;}

See Also

FieldType Class | Aspose.Slides Namespace


InternalString Property

Aspose.Slides Documentation

FieldType.InternalString Property

Returns the internal name of this FieldType object.

[Visual Basic]
NotOverridable Public Property InternalString As String _
Implements IFieldType.InternalString
[C#]
public string InternalString {get; set;}

Implements

IFieldType.InternalString

See Also

FieldType Class | Aspose.Slides Namespace


SlideNumber Property

Aspose.Slides Documentation

FieldType.SlideNumber Property

Current slide's number.

[Visual Basic]
Public Shared ReadOnly Property SlideNumber As FieldType
[C#]
public static FieldType SlideNumber {get;}

See Also

FieldType Class | Aspose.Slides Namespace


FieldType Methods

The methods of the FieldType class are listed below. For a complete list of FieldType class members, see the FieldType Members topic.

Public Instance Methods

Equals | Checks if this field is equal to another.
GetHashCode | Returns hashcode for this object.

See Also

FieldType Class | Aspose.Slides Namespace


FieldType.Equals Method

Checks if this field is equal to another.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
Field to compare.

Return Value

True if fields are equal.

See Also

FieldType Class | Aspose.Slides Namespace


FieldType.GetHashCode Method

Returns hashcode for this object.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

Hashcode Int32.

See Also

FieldType Class | Aspose.Slides Namespace


FieldType Operators

The operators of the FieldType class are listed below. For a complete list of FieldType class members, see the FieldType Members topic.

Public Static (Shared) Operators

Equality Operator | Checks if two FieldType objects is equal.
Inequality Operator | Checks if two FieldType objects is inequal.

See Also

FieldType Class | FieldType Members | Aspose.Slides Namespace


FieldType Equality Operator

Checks if two FieldType objects is equal.

[Visual Basic]
returnValue = FieldType.op_Equality(a, b)
[C#]
public static bool operator ==(
FieldType a,
FieldType b
);

Parameters

a
First FieldType to compare.
b
Second FieldType to compare.

Return Value

True if FieldType objects are equal.

See Also

FieldType Class | Aspose.Slides Namespace


FieldType Inequality Operator

Checks if two FieldType objects is inequal.

[Visual Basic]
returnValue = FieldType.op_Inequality(a, b)
[C#]
public static bool operator !=(
FieldType a,
FieldType b
);

Parameters

a
First FieldType to compare.
b
Second FieldType to compare.

Return Value

True if FieldType objects aren't equal.

See Also

FieldType Class | Aspose.Slides Namespace


FillBlendMode Enumeration

[Visual Basic]
Public Enum FillBlendMode
[C#]
public enum FillBlendMode

Members

Member Name | Description | Value
Darken |  | 0
Lighten |  | 1
Multiply |  | 2
Overlay |  | 3
Screen |  | 4

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


FillFormat Class

Represents a fill formatting options.

For a list of all members of this type, see FillFormat Members.

System.Object
Aspose.Slides.FillFormat

[Visual Basic]
Public Class FillFormat
Implements IFillFormat, ISlideComponent, IPresentationComponent, IFillParamSource
[C#]
public class FillFormat : IFillFormat, ISlideComponent, IPresentationComponent, IFillParamSource

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FillFormat Members | Aspose.Slides Namespace


FillFormat Members

FillFormat overview

Public Instance Properties

FillType | Returns or sets the type of filling. Read/write FillType.
GradientFormat | Returns the gradient fill format. Read-only GradientFormat.
PatternFormat | Returns the pattern fill format. Read-only PatternFormat.
PictureFillFormat | Returns the picture fill format. Read-only PictureFillFormat.
RotateWithShape | Determines whether the fill should be rotated with shape. Read/write NullableBool.
SolidFillColor | Returns the fill color. Read-only ColorFormat.

Public Instance Methods

Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

FillFormat Class | Aspose.Slides Namespace


FillFormat Properties

The properties of the FillFormat class are listed below. For a complete list of FillFormat class members, see the FillFormat Members topic.

Public Instance Properties

FillType | Returns or sets the type of filling. Read/write FillType.
GradientFormat | Returns the gradient fill format. Read-only GradientFormat.
PatternFormat | Returns the pattern fill format. Read-only PatternFormat.
PictureFillFormat | Returns the picture fill format. Read-only PictureFillFormat.
RotateWithShape | Determines whether the fill should be rotated with shape. Read/write NullableBool.
SolidFillColor | Returns the fill color. Read-only ColorFormat.

See Also

FillFormat Class | Aspose.Slides Namespace


FillType Property

Aspose.Slides Documentation

FillFormat.FillType Property

Returns or sets the type of filling. Read/write FillType.

[Visual Basic]
NotOverridable Public Property FillType As FillType _
Implements IFillFormat.FillType
[C#]
public FillType FillType {get; set;}

Implements

IFillFormat.FillType

See Also

FillFormat Class | Aspose.Slides Namespace


GradientFormat Property

Aspose.Slides Documentation

FillFormat.GradientFormat Property

Returns the gradient fill format. Read-only GradientFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property GradientFormat As IGradientFormat _
Implements IFillFormat.GradientFormat
[C#]
public IGradientFormat GradientFormat {get;}

Implements

IFillFormat.GradientFormat

See Also

FillFormat Class | Aspose.Slides Namespace


PatternFormat Property

Aspose.Slides Documentation

FillFormat.PatternFormat Property

Returns the pattern fill format. Read-only PatternFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property PatternFormat As IPatternFormat _
Implements IFillFormat.PatternFormat
[C#]
public IPatternFormat PatternFormat {get;}

Implements

IFillFormat.PatternFormat

See Also

FillFormat Class | Aspose.Slides Namespace


PictureFillFormat Property

Aspose.Slides Documentation

FillFormat.PictureFillFormat Property

Returns the picture fill format. Read-only PictureFillFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property PictureFillFormat As IPictureFillFormat _
Implements IFillFormat.PictureFillFormat
[C#]
public IPictureFillFormat PictureFillFormat {get;}

Implements

IFillFormat.PictureFillFormat

See Also

FillFormat Class | Aspose.Slides Namespace


RotateWithShape Property

Aspose.Slides Documentation

FillFormat.RotateWithShape Property

Determines whether the fill should be rotated with shape. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property RotateWithShape As NullableBool _
Implements IFillFormat.RotateWithShape
[C#]
public NullableBool RotateWithShape {get; set;}

Implements

IFillFormat.RotateWithShape

See Also

FillFormat Class | Aspose.Slides Namespace


SolidFillColor Property

Aspose.Slides Documentation

FillFormat.SolidFillColor Property

Returns the fill color. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property SolidFillColor As IColorFormat _
Implements IFillFormat.SolidFillColor
[C#]
public IColorFormat SolidFillColor {get;}

Implements

IFillFormat.SolidFillColor

See Also

FillFormat Class | Aspose.Slides Namespace


FillFormat Methods

The methods of the FillFormat class are listed below. For a complete list of FillFormat class members, see the FillFormat Members topic.

Public Instance Methods

Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

FillFormat Class | Aspose.Slides Namespace


FillFormat.Equals Method

Determines whether two FillFormat instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The FillFormat to compare with the current FillFormat.

Return Value

true if the specified FillFormat is equal to the current FillFormat; otherwise, false.

See Also

FillFormat Class | Aspose.Slides Namespace


FillFormat.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

23454

Remarks

Overriden to make compiler happy. Always returns constant because object is mutable.

See Also

FillFormat Class | Aspose.Slides Namespace


FillFormatEffectiveData Class

Imutable object which contains fill properties.

For a list of all members of this type, see FillFormatEffectiveData Members.

System.Object
Aspose.Slides.FillFormatEffectiveData

[Visual Basic]
Public Class FillFormatEffectiveData
Implements IFillFormatEffectiveData
[C#]
public class FillFormatEffectiveData : IFillFormatEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FillFormatEffectiveData Members | Aspose.Slides Namespace


FillFormatEffectiveData Members

FillFormatEffectiveData overview

Public Instance Properties

FillType | Returns the type of filling. Read-only FillType.
GradientFormat | Returns the gradient fill format. Read-only GradientFormatEffectiveData.
PatternFormat | Returns the pattern fill format. Read-only PatternFormatEffectiveData.
PictureFillFormat | Returns the picture fill format. Read-only PictureFillFormatEffectiveData.
RotateWithShape | Determines whether the fill should be rotated with shape. Read-only.
SolidFillColor | Returns the fill color. Read-only Color.

Public Instance Methods

Equals | Determines whether two FillValueEx instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

FillFormatEffectiveData Class | Aspose.Slides Namespace


FillFormatEffectiveData Properties

The properties of the FillFormatEffectiveData class are listed below. For a complete list of FillFormatEffectiveData class members, see the FillFormatEffectiveData Members topic.

Public Instance Properties

FillType | Returns the type of filling. Read-only FillType.
GradientFormat | Returns the gradient fill format. Read-only GradientFormatEffectiveData.
PatternFormat | Returns the pattern fill format. Read-only PatternFormatEffectiveData.
PictureFillFormat | Returns the picture fill format. Read-only PictureFillFormatEffectiveData.
RotateWithShape | Determines whether the fill should be rotated with shape. Read-only.
SolidFillColor | Returns the fill color. Read-only Color.

See Also

FillFormatEffectiveData Class | Aspose.Slides Namespace


FillType Property

Aspose.Slides Documentation

FillFormatEffectiveData.FillType Property

Returns the type of filling. Read-only FillType.

[Visual Basic]
NotOverridable Public ReadOnly Property FillType As FillType _
Implements IFillFormatEffectiveData.FillType
[C#]
public FillType FillType {get;}

Implements

IFillFormatEffectiveData.FillType

See Also

FillFormatEffectiveData Class | Aspose.Slides Namespace


GradientFormat Property

Aspose.Slides Documentation

FillFormatEffectiveData.GradientFormat Property

Returns the gradient fill format. Read-only GradientFormatEffectiveData.

[Visual Basic]
NotOverridable Public ReadOnly Property GradientFormat As IGradientFormatEffectiveData _
Implements IFillFormatEffectiveData.GradientFormat
[C#]
public IGradientFormatEffectiveData GradientFormat {get;}

Implements

IFillFormatEffectiveData.GradientFormat

See Also

FillFormatEffectiveData Class | Aspose.Slides Namespace


PatternFormat Property

Aspose.Slides Documentation

FillFormatEffectiveData.PatternFormat Property

Returns the pattern fill format. Read-only PatternFormatEffectiveData.

[Visual Basic]
NotOverridable Public ReadOnly Property PatternFormat As IPatternFormatEffectiveData _
Implements IFillFormatEffectiveData.PatternFormat
[C#]
public IPatternFormatEffectiveData PatternFormat {get;}

Implements

IFillFormatEffectiveData.PatternFormat

See Also

FillFormatEffectiveData Class | Aspose.Slides Namespace


PictureFillFormat Property

Aspose.Slides Documentation

FillFormatEffectiveData.PictureFillFormat Property

Returns the picture fill format. Read-only PictureFillFormatEffectiveData.

[Visual Basic]
NotOverridable Public ReadOnly Property PictureFillFormat As IPictureFillFormatEffectiveData _
Implements IFillFormatEffectiveData.PictureFillFormat
[C#]
public IPictureFillFormatEffectiveData PictureFillFormat {get;}

Implements

IFillFormatEffectiveData.PictureFillFormat

See Also

FillFormatEffectiveData Class | Aspose.Slides Namespace


RotateWithShape Property

Aspose.Slides Documentation

FillFormatEffectiveData.RotateWithShape Property

Determines whether the fill should be rotated with shape. Read-only.

[Visual Basic]
NotOverridable Public ReadOnly Property RotateWithShape As Boolean _
Implements IFillFormatEffectiveData.RotateWithShape
[C#]
public bool RotateWithShape {get;}

Implements

IFillFormatEffectiveData.RotateWithShape

See Also

FillFormatEffectiveData Class | Aspose.Slides Namespace


SolidFillColor Property

Aspose.Slides Documentation

FillFormatEffectiveData.SolidFillColor Property

Returns the fill color. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property SolidFillColor As Color _
Implements IFillFormatEffectiveData.SolidFillColor
[C#]
public Color SolidFillColor {get;}

Implements

IFillFormatEffectiveData.SolidFillColor

See Also

FillFormatEffectiveData Class | Aspose.Slides Namespace


FillFormatEffectiveData Methods

The methods of the FillFormatEffectiveData class are listed below. For a complete list of FillFormatEffectiveData class members, see the FillFormatEffectiveData Members topic.

Public Instance Methods

Equals | Determines whether two FillValueEx instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

FillFormatEffectiveData Class | Aspose.Slides Namespace


FillFormatEffectiveData.Equals Method

Determines whether two FillValueEx instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The FillValueEx to compare with the current FillValueEx.

Return Value

true if the specified FillValueEx is equal to the current FillValueEx; otherwise, false.

See Also

FillFormatEffectiveData Class | Aspose.Slides Namespace


FillFormatEffectiveData.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

23454

Remarks

Overriden to make compiler happy. Always returns constant because object is mutable.

See Also

FillFormatEffectiveData Class | Aspose.Slides Namespace


FillType Enumeration

[Visual Basic]
Public Enum FillType
Inherits
[C#]
public enum FillType

Members

Member Name | Description | Value
NotDefined |  | -1
NoFill |  | 0
Solid |  | 1
Gradient |  | 2
Pattern |  | 3
Picture |  | 4
Group |  | 5

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


FontAlignment Enumeration

[Visual Basic]
Public Enum FontAlignment
[C#]
public enum FontAlignment

Members

Member Name | Description | Value
Default |  | -1
Automatic |  | 0
Top |  | 1
Center |  | 2
Bottom |  | 3
Baseline |  | 4

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


FontCollectionIndex Enumeration

[Visual Basic]
Public Enum FontCollectionIndex
Inherits
[C#]
public enum FontCollectionIndex

Members

Member Name | Description | Value
None |  | 0
Minor |  | 1
Major |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


FontData Class

Represents a font definition. Immutable.

For a list of all members of this type, see FontData Members.

System.Object
Aspose.Slides.FontData

[Visual Basic]
NotInheritable Public Class FontData
Implements IFontData
[C#]
public sealed class FontData : IFontData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FontData Members | Aspose.Slides Namespace


FontData Members

FontData overview

Public Instance Constructors

FontData Constructor Creates a new FontData object with the specified font name.

Public Instance Properties

FontName Returns the font name.String.

Public Instance Methods

Equals | Determines whether two FontData instances are equal.
GetFontName | Returns the font name, replacing theme referrence with an actual font used.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

FontData Class | Aspose.Slides Namespace


FontData Constructor

Creates a new FontData object with the specified font name.

[Visual Basic]
Overloads Public Sub New( _
ByVal fontName As String _
)
[C#]
public FontData(
string fontName
);

Parameters

fontName
Font name.

See Also

FontData Class | Aspose.Slides Namespace


FontData Properties

The properties of the FontData class are listed below. For a complete list of FontData class members, see the FontData Members topic.

Public Instance Properties

FontName Returns the font name.String.

See Also

FontData Class | Aspose.Slides Namespace


FontName Property

Aspose.Slides Documentation

FontData.FontName Property

Returns the font name.String.

[Visual Basic]
NotOverridable Public Property FontName As String _
Implements IFontData.FontName
[C#]
public string FontName {get; set;}

Implements

IFontData.FontName

See Also

FontData Class | Aspose.Slides Namespace


FontData Methods

The methods of the FontData class are listed below. For a complete list of FontData class members, see the FontData Members topic.

Public Instance Methods

Equals | Determines whether two FontData instances are equal.
GetFontName | Returns the font name, replacing theme referrence with an actual font used.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

FontData Class | Aspose.Slides Namespace


FontData.Equals Method

Determines whether two FontData instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The FontData to compare with the current FontData.

Return Value

true if the specified FontData is equal to the current FontData; otherwise, false.

See Also

FontData Class | Aspose.Slides Namespace


FontData.GetFontName Method

Returns the font name, replacing theme referrence with an actual font used.

[Visual Basic]
NotOverridable Public Function GetFontName( _
ByVal theme As IThemeEffectiveData _
) As String _
Implements IFontData.GetFontName
[C#]
public string GetFontName(
IThemeEffectiveData theme
);

Parameters

theme
Theme from which themed font name should be taken. Its up to caller to provide a correct value. See CreateThemeEffective

Return Value

Font name.

Implements

IFontData.GetFontName

See Also

FontData Class | Aspose.Slides Namespace


FontData.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

Hash code of the FontData.

See Also

FontData Class | Aspose.Slides Namespace


FontDataFactory Class

FontData factory

For a list of all members of this type, see FontDataFactory Members.

System.Object
Aspose.Slides.FontDataFactory

[Visual Basic]
Public Class FontDataFactory
Implements IFontDataFactory
[C#]
public class FontDataFactory : IFontDataFactory

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FontDataFactory Members | Aspose.Slides Namespace


FontDataFactory Members

FontDataFactory overview

Public Instance Constructors

FontDataFactory Constructor Initializes a new instance of the FontDataFactory class.

Public Instance Methods

CreateFontData Creates FontData with specified font name.

See Also

FontDataFactory Class | Aspose.Slides Namespace


FontDataFactory Constructor

Initializes a new instance of the FontDataFactory class.

[Visual Basic]
Public Sub New()
[C#]
public FontDataFactory();

See Also

FontDataFactory Class | Aspose.Slides Namespace


FontDataFactory Methods

The methods of the FontDataFactory class are listed below. For a complete list of FontDataFactory class members, see the FontDataFactory Members topic.

Public Instance Methods

CreateFontData Creates FontData with specified font name.

See Also

FontDataFactory Class | Aspose.Slides Namespace


FontDataFactory.CreateFontData Method

Creates FontData with specified font name.

[Visual Basic]
NotOverridable Public Function CreateFontData( _
ByVal fontName As String _
) As IFontData _
Implements IFontDataFactory.CreateFontData
[C#]
public IFontData CreateFontData(
string fontName
);

Parameters

fontName
Font name

Return Value

FontData

Implements

IFontDataFactory.CreateFontData

See Also

FontDataFactory Class | Aspose.Slides Namespace


Fonts Class

Fonts collection.

For a list of all members of this type, see Fonts Members.

System.Object
Aspose.Slides.Fonts

[Visual Basic]
Public Class Fonts
Implements IFonts
[C#]
public class Fonts : IFonts

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Fonts Members | Aspose.Slides Namespace


Fonts Members

Fonts overview

Public Instance Properties

ComplexScriptFont | Returns or sets the complex script font. Read/write FontData.
EastAsianFont | Returns or sets the East Asian font. Read/write FontData.
LatinFont | Returns or sets the Latin font. Read/write FontData.

See Also

Fonts Class | Aspose.Slides Namespace


Fonts Properties

The properties of the Fonts class are listed below. For a complete list of Fonts class members, see the Fonts Members topic.

Public Instance Properties

ComplexScriptFont | Returns or sets the complex script font. Read/write FontData.
EastAsianFont | Returns or sets the East Asian font. Read/write FontData.
LatinFont | Returns or sets the Latin font. Read/write FontData.

See Also

Fonts Class | Aspose.Slides Namespace


ComplexScriptFont Property

Aspose.Slides Documentation

Fonts.ComplexScriptFont Property

Returns or sets the complex script font. Read/write FontData.

[Visual Basic]
NotOverridable Public Property ComplexScriptFont As IFontData _
Implements IFonts.ComplexScriptFont
[C#]
public IFontData ComplexScriptFont {get; set;}

Implements

IFonts.ComplexScriptFont

See Also

Fonts Class | Aspose.Slides Namespace


EastAsianFont Property

Aspose.Slides Documentation

Fonts.EastAsianFont Property

Returns or sets the East Asian font. Read/write FontData.

[Visual Basic]
NotOverridable Public Property EastAsianFont As IFontData _
Implements IFonts.EastAsianFont
[C#]
public IFontData EastAsianFont {get; set;}

Implements

IFonts.EastAsianFont

See Also

Fonts Class | Aspose.Slides Namespace


LatinFont Property

Aspose.Slides Documentation

Fonts.LatinFont Property

Returns or sets the Latin font. Read/write FontData.

[Visual Basic]
NotOverridable Public Property LatinFont As IFontData _
Implements IFonts.LatinFont
[C#]
public IFontData LatinFont {get; set;}

Implements

IFonts.LatinFont

See Also

Fonts Class | Aspose.Slides Namespace


FontsEffectiveData Class

Immutable Fonts object.

For a list of all members of this type, see FontsEffectiveData Members.

System.Object
Aspose.Slides.FontsEffectiveData

[Visual Basic]
Public Class FontsEffectiveData
Implements IFontsEffectiveData
[C#]
public class FontsEffectiveData : IFontsEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FontsEffectiveData Members | Aspose.Slides Namespace


FontsEffectiveData Members

FontsEffectiveData overview

Public Instance Properties

ComplexScriptFont | Returns or sets the complex script font. Readonly IFontData.
EastAsianFont | Returns or sets the East Asian font. Readonly IFontData.
LatinFont | Returns or sets the Latin font. Readonly IFontData.

See Also

FontsEffectiveData Class | Aspose.Slides Namespace


FontsEffectiveData Properties

The properties of the FontsEffectiveData class are listed below. For a complete list of FontsEffectiveData class members, see the FontsEffectiveData Members topic.

Public Instance Properties

ComplexScriptFont | Returns or sets the complex script font. Readonly IFontData.
EastAsianFont | Returns or sets the East Asian font. Readonly IFontData.
LatinFont | Returns or sets the Latin font. Readonly IFontData.

See Also

FontsEffectiveData Class | Aspose.Slides Namespace


ComplexScriptFont Property

Aspose.Slides Documentation

FontsEffectiveData.ComplexScriptFont Property

Returns or sets the complex script font. Readonly IFontData.

[Visual Basic]
NotOverridable Public ReadOnly Property ComplexScriptFont As IFontData _
Implements IFontsEffectiveData.ComplexScriptFont
[C#]
public IFontData ComplexScriptFont {get;}

Implements

IFontsEffectiveData.ComplexScriptFont

See Also

FontsEffectiveData Class | Aspose.Slides Namespace


EastAsianFont Property

Aspose.Slides Documentation

FontsEffectiveData.EastAsianFont Property

Returns or sets the East Asian font. Readonly IFontData.

[Visual Basic]
NotOverridable Public ReadOnly Property EastAsianFont As IFontData _
Implements IFontsEffectiveData.EastAsianFont
[C#]
public IFontData EastAsianFont {get;}

Implements

IFontsEffectiveData.EastAsianFont

See Also

FontsEffectiveData Class | Aspose.Slides Namespace


LatinFont Property

Aspose.Slides Documentation

FontsEffectiveData.LatinFont Property

Returns or sets the Latin font. Readonly IFontData.

[Visual Basic]
NotOverridable Public ReadOnly Property LatinFont As IFontData _
Implements IFontsEffectiveData.LatinFont
[C#]
public IFontData LatinFont {get;}

Implements

IFontsEffectiveData.LatinFont

See Also

FontsEffectiveData Class | Aspose.Slides Namespace


FontsLoader Class

Class for loading custom fonts defined by user. Should be used before creating any presentation objects.

For a list of all members of this type, see FontsLoader Members.

System.Object
Aspose.Slides.FontsLoader

[Visual Basic]
NotInheritable Public Class FontsLoader
Implements IFontsLoader
[C#]
public sealed class FontsLoader : IFontsLoader

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FontsLoader Members | Aspose.Slides Namespace


FontsLoader Members

FontsLoader overview

Public Static (Shared) Methods

ClearCache | Releases all custom fonts defined by user
LoadExternalFonts | Adds additional folders to seek fonts.

See Also

FontsLoader Class | Aspose.Slides Namespace


FontsLoader Methods

The methods of the FontsLoader class are listed below. For a complete list of FontsLoader class members, see the FontsLoader Members topic.

Public Static (Shared) Methods

ClearCache | Releases all custom fonts defined by user
LoadExternalFonts | Adds additional folders to seek fonts.

See Also

FontsLoader Class | Aspose.Slides Namespace


FontsLoader.ClearCache Method

Releases all custom fonts defined by user

[Visual Basic]
Public Shared Sub ClearCache()
[C#]
public static void ClearCache();

Remarks

This method needs to clear cache with custom fonts defined by user.

See Also

FontsLoader Class | Aspose.Slides Namespace


FontsLoader.LoadExternalFonts Method

Adds additional folders to seek fonts.

[Visual Basic]
Public Shared Sub LoadExternalFonts( _
ByVal directories As String() _
)
[C#]
public static void LoadExternalFonts(
string[] directories
);

Parameters

directories
Directories to read additional fonts.

See Also

FontsLoader Class | Aspose.Slides Namespace


GeometryShape Class

Represents the parent class for all geometric shapes.

For a list of all members of this type, see GeometryShape Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GeometryShape
Aspose.Slides.AutoShape
Aspose.Slides.Connector
Aspose.Slides.PictureFrame

[Visual Basic]
MustInherit Public Class GeometryShape
Inherits Shape
Implements IGeometryShape
[C#]
public abstract class GeometryShape : Shape, IGeometryShape

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GeometryShape Members | Aspose.Slides Namespace


GeometryShape Members

GeometryShape overview

Public Instance Properties

Adjustments | Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock (inherited from Shape) | Returns shape's locks. Read-only IBaseShapeLock.
ShapeStyle | Returns shape's style object. Read-only ShapeStyle.
ShapeType | Returns or sets the geometry preset type. Note: on value changing all adjustment values will reset to their default values. Read/write ShapeType.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateShapeElements | Creates and returns array of shape's elements.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

GeometryShape Class | Aspose.Slides Namespace


GeometryShape Properties

The properties of the GeometryShape class are listed below. For a complete list of GeometryShape class members, see the GeometryShape Members topic.

Public Instance Properties

Adjustments | Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock (inherited from Shape) | Returns shape's locks. Read-only IBaseShapeLock.
ShapeStyle | Returns shape's style object. Read-only ShapeStyle.
ShapeType | Returns or sets the geometry preset type. Note: on value changing all adjustment values will reset to their default values. Read/write ShapeType.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

GeometryShape Class | Aspose.Slides Namespace


Adjustments Property

Aspose.Slides Documentation

GeometryShape.Adjustments Property

Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Adjustments As IAdjustValueCollection _
Implements IGeometryShape.Adjustments
[C#]
public IAdjustValueCollection Adjustments {get;}

Implements

IGeometryShape.Adjustments

See Also

GeometryShape Class | Aspose.Slides Namespace


ShapeStyle Property

Aspose.Slides Documentation

GeometryShape.ShapeStyle Property

Returns shape's style object. Read-only ShapeStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property ShapeStyle As IShapeStyle _
Implements IGeometryShape.ShapeStyle
[C#]
public IShapeStyle ShapeStyle {get;}

Implements

IGeometryShape.ShapeStyle

See Also

GeometryShape Class | Aspose.Slides Namespace


ShapeType Property

Aspose.Slides Documentation

GeometryShape.ShapeType Property

Returns or sets the geometry preset type. Note: on value changing all adjustment values will reset to their default values. Read/write ShapeType.

[Visual Basic]
Overridable Public Property ShapeType As ShapeType _
Implements IGeometryShape.ShapeType
[C#]
public virtual ShapeType ShapeType {get; set;}

Implements

IGeometryShape.ShapeType

See Also

GeometryShape Class | Aspose.Slides Namespace


GeometryShape Methods

The methods of the GeometryShape class are listed below. For a complete list of GeometryShape class members, see the GeometryShape Members topic.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateShapeElements | Creates and returns array of shape's elements.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

GeometryShape Class | Aspose.Slides Namespace


GeometryShape.CreateShapeElements Method

Creates and returns array of shape's elements.

[Visual Basic]
NotOverridable Public Function CreateShapeElements() As IShapeElement() _
Implements IGeometryShape.CreateShapeElements
[C#]
public IShapeElement[] CreateShapeElements();

Return Value

Array of ShapeElement

Implements

IGeometryShape.CreateShapeElements

See Also

GeometryShape Class | Aspose.Slides Namespace


GlobalLayoutSlideCollection Class

Represents a collection of all layout slides in presentation. Extends LayoutSlideCollection class with methods for adding/cloning layout slides in context of uniting of the individual collections of master's layout slides.

For a list of all members of this type, see GlobalLayoutSlideCollection Members.

System.Object
Aspose.Slides.LayoutSlideCollection
Aspose.Slides.GlobalLayoutSlideCollection

[Visual Basic]
NotInheritable Public Class GlobalLayoutSlideCollection
Inherits LayoutSlideCollection
Implements IGlobalLayoutSlideCollection
[C#]
public sealed class GlobalLayoutSlideCollection : LayoutSlideCollection, IGlobalLayoutSlideCollection

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GlobalLayoutSlideCollection Members | Aspose.Slides Namespace


GlobalLayoutSlideCollection Members

GlobalLayoutSlideCollection overview

Public Instance Properties

Count (inherited from LayoutSlideCollection) | Returns the number of layout slides in a collection. Read-only Int32.
IsSynchronized (inherited from LayoutSlideCollection) | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item (inherited from LayoutSlideCollection) | Returns the layout slide by index. Read-only LayoutSlide.
SyncRoot (inherited from LayoutSlideCollection) | Returns a synchronization root. Readonly Object.

Public Instance Methods

Add | Adds a new layout slide to the presentation.
AddClone | Overloaded. Adds a copy of a specified layout slide to the presentation.
CopyTo (inherited from LayoutSlideCollection) | Copies all elements from the collection to the specified array.
GetByType (inherited from LayoutSlideCollection) | Returns the first layout slide of specified type. A type of layout slide to find.LayoutSlide with specified type or null if no layouts found.
GetEnumerator (inherited from LayoutSlideCollection) | Returns an enumerator for the entire collection.
Remove (inherited from LayoutSlideCollection) | Removes a layout from the collection.
RemoveUnused (inherited from LayoutSlideCollection) | Removes unused layout slides (layout slides whose HasDependingSlides is false).

See Also

GlobalLayoutSlideCollection Class | Aspose.Slides Namespace


GlobalLayoutSlideCollection Methods

The methods of the GlobalLayoutSlideCollection class are listed below. For a complete list of GlobalLayoutSlideCollection class members, see the GlobalLayoutSlideCollection Members topic.

Public Instance Methods

Add | Adds a new layout slide to the presentation.
AddClone | Overloaded. Adds a copy of a specified layout slide to the presentation.
CopyTo (inherited from LayoutSlideCollection) | Copies all elements from the collection to the specified array.
GetByType (inherited from LayoutSlideCollection) | Returns the first layout slide of specified type. A type of layout slide to find.LayoutSlide with specified type or null if no layouts found.
GetEnumerator (inherited from LayoutSlideCollection) | Returns an enumerator for the entire collection.
Remove (inherited from LayoutSlideCollection) | Removes a layout from the collection.
RemoveUnused (inherited from LayoutSlideCollection) | Removes unused layout slides (layout slides whose HasDependingSlides is false).

See Also

GlobalLayoutSlideCollection Class | Aspose.Slides Namespace


GlobalLayoutSlideCollection.Add Method

Adds a new layout slide to the presentation.

[Visual Basic]
NotOverridable Public Function Add( _
ByVal master As IMasterSlide, _
ByVal layoutType As SlideLayoutType, _
ByVal layoutName As String _
) As ILayoutSlide _
Implements IGlobalLayoutSlideCollection.Add
[C#]
public ILayoutSlide Add(
IMasterSlide master,
SlideLayoutType layoutType,
string layoutName
);

Parameters

master
Master slide for a new layout.
layoutType
Layout type for a new layout. Supported layout types: Title, TitleOnly, Blank, TitleAndObject, VerticalText, VerticalTitleAndText, TwoObjects, SectionHeader, TwoTextAndTwoObjects, TitleObjectAndCaption, PictureAndCaption, Custom. Other layout types are not supported now: Text, TwoColumnText, Table, TextAndChart, ChartAndText, Diagram, Chart, TextAndClipArt, ClipArtAndText, TextAndObject, ObjectAndText, Object, TextAndMedia, MediaAndText, ObjectOverText, TextOverObject, TextAndTwoObjects, TwoObjectsAndText, TwoObjectsOverText, FourObjects, ClipArtAndVerticalText, VerticalTitleAndTextOverChart, ObjectAndTwoObject, TwoObjectsAndObject.
layoutName
Name for a new layout. If passed name is already in use the ArgumentException will be thrown. If null parameter is passed then name genarated atomatically in regards to passed layout type (for example "Title Slide" or "1_Title Slide", "2_..", etc.).

Return Value

Added slide.

Implements

IGlobalLayoutSlideCollection.Add

Remarks

1) Added layout for value SlideLayoutType.Custom of layoutType contains no placeholders and no shapes. 2) Analogue of this method is method Add accessed with LayoutSlides property.

Exceptions

Exception Type | Condition
NotImplementedException | Thrown if unsupported value of parameter layoutType is passed. Layout types that are not supported now: Text, TwoColumnText, Table, TextAndChart, ChartAndText, Diagram, Chart, TextAndClipArt, ClipArtAndText, TextAndObject, ObjectAndText, Object, TextAndMedia, MediaAndText, ObjectOverText, TextOverObject, TextAndTwoObjects, TwoObjectsAndText, TwoObjectsOverText, FourObjects, ClipArtAndVerticalText, VerticalTitleAndTextOverChart, ObjectAndTwoObject, TwoObjectsAndObject.
ArgumentNullException | Thrown if master is null.
ArgumentException | Thrown if master belongs to the other presentation.
ArgumentException | Thrown if layout name value layoutName is already in use in collection of the layouts of master.

See Also

GlobalLayoutSlideCollection Class | Aspose.Slides Namespace


AddClone Method

Aspose.Slides Documentation

GlobalLayoutSlideCollection.AddClone Method

Adds a copy of a specified layout slide to the presentation.

Overload List

Adds a copy of a specified layout slide to the presentation.

public ILayoutSlide AddClone(ILayoutSlide);

Adds a copy of a specified layout slide to the presentation.

public ILayoutSlide AddClone(ILayoutSlide,IMasterSlide);

See Also

GlobalLayoutSlideCollection Class | Aspose.Slides Namespace


GlobalLayoutSlideCollection.AddClone Method (ILayoutSlide)

Adds a copy of a specified layout slide to the presentation.

[Visual Basic]
NotOverridable Overloads Public Function AddClone( _
ByVal sourceLayout As ILayoutSlide _
) As ILayoutSlide _
Implements IGlobalLayoutSlideCollection.AddClone
[C#]
public ILayoutSlide AddClone(
ILayoutSlide sourceLayout
);

Parameters

sourceLayout
Slide to clone.

Return Value

Added slide.

Implements

IGlobalLayoutSlideCollection.AddClone

Remarks

When cloning a layout between different presentations layout's master can be cloned too to keep source formatting. Internal registry is used to track automatically cloned masters to prevent creation of multiple clones of the same master slide. Manual cloning of master slides will be neither prevented nor registered.

See Also

GlobalLayoutSlideCollection Class | Aspose.Slides Namespace | GlobalLayoutSlideCollection.AddClone Overload List


GlobalLayoutSlideCollection.AddClone Method (ILayoutSlide, IMasterSlide)

Adds a copy of a specified layout slide to the presentation.

[Visual Basic]
NotOverridable Overloads Public Function AddClone( _
ByVal sourceLayout As ILayoutSlide, _
ByVal destMaster As IMasterSlide _
) As ILayoutSlide _
Implements IGlobalLayoutSlideCollection.AddClone
[C#]
public ILayoutSlide AddClone(
ILayoutSlide sourceLayout,
IMasterSlide destMaster
);

Parameters

sourceLayout
Slide to clone.
destMaster
Master slide for a new layout.

Return Value

Added slide.

Implements

IGlobalLayoutSlideCollection.AddClone

Remarks

1) New layout will be linked with defined master in destination presentation. So this is analogue of copy/paste with "Use Destination Theme" option in PowerPoint. 2) Analogue of this method is method AddClone accessed with LayoutSlides property.

See Also

GlobalLayoutSlideCollection Class | Aspose.Slides Namespace | GlobalLayoutSlideCollection.AddClone Overload List


GradientDirection Enumeration

[Visual Basic]
Public Enum GradientDirection
[C#]
public enum GradientDirection

Members

Member Name | Description | Value
NotDefined |  | -1
FromCorner1 |  | 0
FromCorner2 |  | 1
FromCorner3 |  | 2
FromCorner4 |  | 3
FromCenter |  | 4

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


GradientFormat Class

Represent a gradient format.

For a list of all members of this type, see GradientFormat Members.

System.Object
Aspose.Slides.GradientFormat

[Visual Basic]
NotInheritable Public Class GradientFormat
Implements IGradientFormat, ISlideComponent, IPresentationComponent, IFillParamSource
[C#]
public sealed class GradientFormat : IGradientFormat, ISlideComponent, IPresentationComponent, IFillParamSource

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GradientFormat Members | Aspose.Slides Namespace


GradientFormat Members

GradientFormat overview

Public Instance Properties

GradientDirection | Returns or sets the style of a gradient. Read/write GradientDirection.
GradientShape | Returns or sets the shape of a gradient. Read/write GradientShape.
GradientStops | Returns the collection of gradient stops. Read-only GradientStopCollection.
LinearGradientAngle | Returns or sets the angle of a gradient. Read/write Single.
LinearGradientScaled | Determines whether a gradient is scaled. Read/write NullableBool.
TileFlip | Returns or sets the flipping mode for a gradient. Read/write TileFlip.

Public Instance Methods

Equals | Determines whether the two GradientFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

GradientFormat Class | Aspose.Slides Namespace


GradientFormat Properties

The properties of the GradientFormat class are listed below. For a complete list of GradientFormat class members, see the GradientFormat Members topic.

Public Instance Properties

GradientDirection | Returns or sets the style of a gradient. Read/write GradientDirection.
GradientShape | Returns or sets the shape of a gradient. Read/write GradientShape.
GradientStops | Returns the collection of gradient stops. Read-only GradientStopCollection.
LinearGradientAngle | Returns or sets the angle of a gradient. Read/write Single.
LinearGradientScaled | Determines whether a gradient is scaled. Read/write NullableBool.
TileFlip | Returns or sets the flipping mode for a gradient. Read/write TileFlip.

See Also

GradientFormat Class | Aspose.Slides Namespace


GradientDirection Property

Aspose.Slides Documentation

GradientFormat.GradientDirection Property

Returns or sets the style of a gradient. Read/write GradientDirection.

[Visual Basic]
NotOverridable Public Property GradientDirection As GradientDirection _
Implements IGradientFormat.GradientDirection
[C#]
public GradientDirection GradientDirection {get; set;}

Implements

IGradientFormat.GradientDirection

See Also

GradientFormat Class | Aspose.Slides Namespace


GradientShape Property

Aspose.Slides Documentation

GradientFormat.GradientShape Property

Returns or sets the shape of a gradient. Read/write GradientShape.

[Visual Basic]
NotOverridable Public Property GradientShape As GradientShape _
Implements IGradientFormat.GradientShape
[C#]
public GradientShape GradientShape {get; set;}

Implements

IGradientFormat.GradientShape

See Also

GradientFormat Class | Aspose.Slides Namespace


GradientStops Property

Aspose.Slides Documentation

GradientFormat.GradientStops Property

Returns the collection of gradient stops. Read-only GradientStopCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property GradientStops As IGradientStopCollection _
Implements IGradientFormat.GradientStops
[C#]
public IGradientStopCollection GradientStops {get;}

Implements

IGradientFormat.GradientStops

See Also

GradientFormat Class | Aspose.Slides Namespace


LinearGradientAngle Property

Aspose.Slides Documentation

GradientFormat.LinearGradientAngle Property

Returns or sets the angle of a gradient. Read/write Single.

[Visual Basic]
NotOverridable Public Property LinearGradientAngle As Single _
Implements IGradientFormat.LinearGradientAngle
[C#]
public float LinearGradientAngle {get; set;}

Implements

IGradientFormat.LinearGradientAngle

See Also

GradientFormat Class | Aspose.Slides Namespace


LinearGradientScaled Property

Aspose.Slides Documentation

GradientFormat.LinearGradientScaled Property

Determines whether a gradient is scaled. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property LinearGradientScaled As NullableBool _
Implements IGradientFormat.LinearGradientScaled
[C#]
public NullableBool LinearGradientScaled {get; set;}

Implements

IGradientFormat.LinearGradientScaled

See Also

GradientFormat Class | Aspose.Slides Namespace


TileFlip Property

Aspose.Slides Documentation

GradientFormat.TileFlip Property

Returns or sets the flipping mode for a gradient. Read/write TileFlip.

[Visual Basic]
NotOverridable Public Property TileFlip As TileFlip _
Implements IGradientFormat.TileFlip
[C#]
public TileFlip TileFlip {get; set;}

Implements

IGradientFormat.TileFlip

See Also

GradientFormat Class | Aspose.Slides Namespace


GradientFormat Methods

The methods of the GradientFormat class are listed below. For a complete list of GradientFormat class members, see the GradientFormat Members topic.

Public Instance Methods

Equals | Determines whether the two GradientFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

GradientFormat Class | Aspose.Slides Namespace


GradientFormat.Equals Method

Determines whether the two GradientFormat instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The GradientFormat to compare with the current GradientFormat.

Return Value

true if the specified GradientFormat is equal to the current GradientFormat; otherwise, false.

See Also

GradientFormat Class | Aspose.Slides Namespace


GradientFormat.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

Remarks

Overriden to make compiler happy. Always returns constant because object is mutable.

See Also

GradientFormat Class | Aspose.Slides Namespace


GradientFormatEffectiveData Class

Imutable object which contains gradient properties.

For a list of all members of this type, see GradientFormatEffectiveData Members.

System.Object
Aspose.Slides.GradientFormatEffectiveData

[Visual Basic]
NotInheritable Public Class GradientFormatEffectiveData
Implements IGradientFormatEffectiveData
[C#]
public sealed class GradientFormatEffectiveData : IGradientFormatEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GradientFormatEffectiveData Members | Aspose.Slides Namespace


GradientFormatEffectiveData Members

GradientFormatEffectiveData overview

Public Instance Properties

GradientDirection | Returns the style of a gradient. Read-only GradientDirection.
GradientShape | Returns the shape of a gradient. Read-only GradientShape.
GradientStops | Returns the collection of gradient stops. Read-only GradientStops.
LinearGradientAngle | Returns the angle of a gradient. Read-only Single.
LinearGradientScaled | Determines whether a gradient is scaled. Read-only Boolean.
TileFlip | Returns the flipping mode for a gradient. Read-only TileFlip.

Public Instance Methods

Equals | Determines whether the two GradientValueEx instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

GradientFormatEffectiveData Class | Aspose.Slides Namespace


GradientFormatEffectiveData Properties

The properties of the GradientFormatEffectiveData class are listed below. For a complete list of GradientFormatEffectiveData class members, see the GradientFormatEffectiveData Members topic.

Public Instance Properties

GradientDirection | Returns the style of a gradient. Read-only GradientDirection.
GradientShape | Returns the shape of a gradient. Read-only GradientShape.
GradientStops | Returns the collection of gradient stops. Read-only GradientStops.
LinearGradientAngle | Returns the angle of a gradient. Read-only Single.
LinearGradientScaled | Determines whether a gradient is scaled. Read-only Boolean.
TileFlip | Returns the flipping mode for a gradient. Read-only TileFlip.

See Also

GradientFormatEffectiveData Class | Aspose.Slides Namespace


GradientDirection Property

Aspose.Slides Documentation

GradientFormatEffectiveData.GradientDirection Property

Returns the style of a gradient. Read-only GradientDirection.

[Visual Basic]
NotOverridable Public ReadOnly Property GradientDirection As GradientDirection _
Implements IGradientFormatEffectiveData.GradientDirection
[C#]
public GradientDirection GradientDirection {get;}

Implements

IGradientFormatEffectiveData.GradientDirection

See Also

GradientFormatEffectiveData Class | Aspose.Slides Namespace


GradientShape Property

Aspose.Slides Documentation

GradientFormatEffectiveData.GradientShape Property

Returns the shape of a gradient. Read-only GradientShape.

[Visual Basic]
NotOverridable Public ReadOnly Property GradientShape As GradientShape _
Implements IGradientFormatEffectiveData.GradientShape
[C#]
public GradientShape GradientShape {get;}

Implements

IGradientFormatEffectiveData.GradientShape

See Also

GradientFormatEffectiveData Class | Aspose.Slides Namespace


GradientStops Property

Aspose.Slides Documentation

GradientFormatEffectiveData.GradientStops Property

Returns the collection of gradient stops. Read-only GradientStops.

[Visual Basic]
NotOverridable Public ReadOnly Property GradientStops As IGradientStopCollectionEffectiveData _
Implements IGradientFormatEffectiveData.GradientStops
[C#]
public IGradientStopCollectionEffectiveData GradientStops {get;}

Implements

IGradientFormatEffectiveData.GradientStops

See Also

GradientFormatEffectiveData Class | Aspose.Slides Namespace


LinearGradientAngle Property

Aspose.Slides Documentation

GradientFormatEffectiveData.LinearGradientAngle Property

Returns the angle of a gradient. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property LinearGradientAngle As Single _
Implements IGradientFormatEffectiveData.LinearGradientAngle
[C#]
public float LinearGradientAngle {get;}

Implements

IGradientFormatEffectiveData.LinearGradientAngle

See Also

GradientFormatEffectiveData Class | Aspose.Slides Namespace


LinearGradientScaled Property

Aspose.Slides Documentation

GradientFormatEffectiveData.LinearGradientScaled Property

Determines whether a gradient is scaled. Read-only Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property LinearGradientScaled As Boolean _
Implements IGradientFormatEffectiveData.LinearGradientScaled
[C#]
public bool LinearGradientScaled {get;}

Implements

IGradientFormatEffectiveData.LinearGradientScaled

See Also

GradientFormatEffectiveData Class | Aspose.Slides Namespace


TileFlip Property

Aspose.Slides Documentation

GradientFormatEffectiveData.TileFlip Property

Returns the flipping mode for a gradient. Read-only TileFlip.

[Visual Basic]
NotOverridable Public ReadOnly Property TileFlip As TileFlip _
Implements IGradientFormatEffectiveData.TileFlip
[C#]
public TileFlip TileFlip {get;}

Implements

IGradientFormatEffectiveData.TileFlip

See Also

GradientFormatEffectiveData Class | Aspose.Slides Namespace


GradientFormatEffectiveData Methods

The methods of the GradientFormatEffectiveData class are listed below. For a complete list of GradientFormatEffectiveData class members, see the GradientFormatEffectiveData Members topic.

Public Instance Methods

Equals | Determines whether the two GradientValueEx instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

GradientFormatEffectiveData Class | Aspose.Slides Namespace


GradientFormatEffectiveData.Equals Method

Determines whether the two GradientValueEx instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The GradientValueEx to compare with the current GradientValueEx.

Return Value

true if the specified GradientValueEx is equal to the current GradientValueEx; otherwise, false.

See Also

GradientFormatEffectiveData Class | Aspose.Slides Namespace


GradientFormatEffectiveData.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

Remarks

Overriden to make compiler happy. Always returns constant because object is mutable.

See Also

GradientFormatEffectiveData Class | Aspose.Slides Namespace


GradientShape Enumeration

[Visual Basic]
Public Enum GradientShape
Inherits
[C#]
public enum GradientShape

Members

Member Name | Description | Value
NotDefined |  | -1
Linear |  | 0
Rectangle |  | 1
Radial |  | 2
Path |  | 3

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


GradientStop Class

Represents a gradient stop.

For a list of all members of this type, see GradientStop Members.

System.Object
Aspose.Slides.GradientStop

[Visual Basic]
Public Class GradientStop
Implements IGradientStop
[C#]
public class GradientStop : IGradientStop

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GradientStop Members | Aspose.Slides Namespace


GradientStop Members

GradientStop overview

Public Instance Properties

Color | Returns the color of a gradient stop. Read-only ColorFormat.
Position | Returns or sets the position (0..1) of a gradient stop. Read/write Single.

Public Instance Methods

Equals |
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

GradientStop Class | Aspose.Slides Namespace


GradientStop Properties

The properties of the GradientStop class are listed below. For a complete list of GradientStop class members, see the GradientStop Members topic.

Public Instance Properties

Color | Returns the color of a gradient stop. Read-only ColorFormat.
Position | Returns or sets the position (0..1) of a gradient stop. Read/write Single.

See Also

GradientStop Class | Aspose.Slides Namespace


Color Property

Aspose.Slides Documentation

GradientStop.Color Property

Returns the color of a gradient stop. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Color As IColorFormat _
Implements IGradientStop.Color
[C#]
public IColorFormat Color {get;}

Implements

IGradientStop.Color

See Also

GradientStop Class | Aspose.Slides Namespace


Position Property

Aspose.Slides Documentation

GradientStop.Position Property

Returns or sets the position (0..1) of a gradient stop. Read/write Single.

[Visual Basic]
NotOverridable Public Property Position As Single _
Implements IGradientStop.Position
[C#]
public float Position {get; set;}

Implements

IGradientStop.Position

See Also

GradientStop Class | Aspose.Slides Namespace


GradientStop Methods

The methods of the GradientStop class are listed below. For a complete list of GradientStop class members, see the GradientStop Members topic.

Public Instance Methods

Equals |
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

GradientStop Class | Aspose.Slides Namespace


GradientStop.Equals Method

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

See Also

GradientStop Class | Aspose.Slides Namespace


GradientStop.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

Remarks

Overriden to make compiler happy. Always returns constant because object is mutable.

See Also

GradientStop Class | Aspose.Slides Namespace


GradientStopCollection Class

Represnts a collection of gradient stops.

For a list of all members of this type, see GradientStopCollection Members.

System.Object
Aspose.Slides.GradientStopCollection

[Visual Basic]
NotInheritable Public Class GradientStopCollection
Implements IGradientStopCollection, ICollection, IEnumerable, ISlideComponent, IPresentationComponent, IEnumerable`1([Aspose.Slides.IGradientStop, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public sealed class GradientStopCollection : IGradientStopCollection, ICollection, IEnumerable, ISlideComponent, IPresentationComponent, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GradientStopCollection Members | Aspose.Slides Namespace


GradientStopCollection Members

GradientStopCollection overview

Public Instance Properties

Count | Returns the number of gradient stops in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns the gradient stop by index.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

Add | Overloaded. Creates the new gradient stop and adds it to the end of collection.
Clear | Removes all gradient stops from a collection.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
Insert | Overloaded. Creates the new gradient stop and inserts it at the specified index to the collection.
RemoveAt | Removes a gradient stop at the specified index.

See Also

GradientStopCollection Class | Aspose.Slides Namespace


GradientStopCollection Properties

The properties of the GradientStopCollection class are listed below. For a complete list of GradientStopCollection class members, see the GradientStopCollection Members topic.

Public Instance Properties

Count | Returns the number of gradient stops in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns the gradient stop by index.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

GradientStopCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

GradientStopCollection.Count Property

Returns the number of gradient stops in a collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

GradientStopCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

GradientStopCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

GradientStopCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

GradientStopCollection.Item Property

Returns the gradient stop by index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IGradientStopCollection.Item
As IGradientStop _
Implements IGradientStopCollection.Item
[C#]
public IGradientStop this[
int index
] {get;}

Implements

IGradientStopCollection.Item

See Also

GradientStopCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

GradientStopCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

GradientStopCollection Class | Aspose.Slides Namespace


GradientStopCollection Methods

The methods of the GradientStopCollection class are listed below. For a complete list of GradientStopCollection class members, see the GradientStopCollection Members topic.

Public Instance Methods

Add | Overloaded. Creates the new gradient stop and adds it to the end of collection.
Clear | Removes all gradient stops from a collection.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
Insert | Overloaded. Creates the new gradient stop and inserts it at the specified index to the collection.
RemoveAt | Removes a gradient stop at the specified index.

See Also

GradientStopCollection Class | Aspose.Slides Namespace


Add Method

Aspose.Slides Documentation

GradientStopCollection.Add Method

Creates the new gradient stop and adds it to the end of collection.

Overload List

Creates the new gradient stop and adds it to the end of collection.

public IGradientStop Add(float,PresetColor);

Creates the new gradient stop and adds it to the end of collection.

public IGradientStop Add(float,SchemeColor);

Creates the new gradient stop and adds it to the end of collection.

public IGradientStop Add(float,Color);

See Also

GradientStopCollection Class | Aspose.Slides Namespace


GradientStopCollection.Add Method (Single, PresetColor)

Creates the new gradient stop and adds it to the end of collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal position As Single, _
ByVal presetColor As PresetColor _
) As IGradientStop _
Implements IGradientStopCollection.Add
[C#]
public IGradientStop Add(
float position,
PresetColor presetColor
);

Parameters

position
Position of the new gradient stop.
presetColor
Color of the new radient stop.

Return Value

Index of the new gradient stop in the collection.

Implements

IGradientStopCollection.Add

See Also

GradientStopCollection Class | Aspose.Slides Namespace | GradientStopCollection.Add Overload List


GradientStopCollection.Add Method (Single, SchemeColor)

Creates the new gradient stop and adds it to the end of collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal position As Single, _
ByVal schemeColor As SchemeColor _
) As IGradientStop _
Implements IGradientStopCollection.Add
[C#]
public IGradientStop Add(
float position,
SchemeColor schemeColor
);

Parameters

position
Position of the new gradient stop.
schemeColor
Color of the new radient stop.

Return Value

Index of the new gradient stop in the collection.

Implements

IGradientStopCollection.Add

See Also

GradientStopCollection Class | Aspose.Slides Namespace | GradientStopCollection.Add Overload List


GradientStopCollection.Add Method (Single, Color)

Creates the new gradient stop and adds it to the end of collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal position As Single, _
ByVal color As Color _
) As IGradientStop _
Implements IGradientStopCollection.Add
[C#]
public IGradientStop Add(
float position,
Color color
);

Parameters

position
Position of the new gradient stop.
color
Color of the new radient stop.

Return Value

Index of the new gradient stop in the collection.

Implements

IGradientStopCollection.Add

See Also

GradientStopCollection Class | Aspose.Slides Namespace | GradientStopCollection.Add Overload List


GradientStopCollection.Clear Method

Removes all gradient stops from a collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IGradientStopCollection.Clear
[C#]
public void Clear();

Implements

IGradientStopCollection.Clear

See Also

GradientStopCollection Class | Aspose.Slides Namespace


GradientStopCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

GradientStopCollection Class | Aspose.Slides Namespace


GradientStopCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

GradientStopCollection Class | Aspose.Slides Namespace


Insert Method

Aspose.Slides Documentation

GradientStopCollection.Insert Method

Creates the new gradient stop and inserts it at the specified index to the collection.

Overload List

Creates the new gradient stop and inserts it at the specified index to the collection.

public void Insert(int,float,PresetColor);

Creates the new gradient stop and inserts it at the specified index to the collection.

public void Insert(int,float,SchemeColor);

Creates the new gradient stop and inserts it at the specified index to the collection.

public void Insert(int,float,Color);

See Also

GradientStopCollection Class | Aspose.Slides Namespace


GradientStopCollection.Insert Method (Int32, Single, PresetColor)

Creates the new gradient stop and inserts it at the specified index to the collection.

[Visual Basic]
NotOverridable Overloads Public Sub Insert( _
ByVal index As Integer, _
ByVal position As Single, _
ByVal presetColor As PresetColor _
) _
Implements IGradientStopCollection.Insert
[C#]
public void Insert(
int index,
float position,
PresetColor presetColor
);

Parameters

index
Index in the collection where new gradient stop will be inserted.
position
Position of the new gradient stop.
presetColor
Color of the new radient stop.

Implements

IGradientStopCollection.Insert

See Also

GradientStopCollection Class | Aspose.Slides Namespace | GradientStopCollection.Insert Overload List


GradientStopCollection.Insert Method (Int32, Single, SchemeColor)

Creates the new gradient stop and inserts it at the specified index to the collection.

[Visual Basic]
NotOverridable Overloads Public Sub Insert( _
ByVal index As Integer, _
ByVal position As Single, _
ByVal schemeColor As SchemeColor _
) _
Implements IGradientStopCollection.Insert
[C#]
public void Insert(
int index,
float position,
SchemeColor schemeColor
);

Parameters

index
Index in the collection where new gradient stop will be inserted.
position
Position of the new gradient stop.
schemeColor
Color of the new radient stop.

Implements

IGradientStopCollection.Insert

See Also

GradientStopCollection Class | Aspose.Slides Namespace | GradientStopCollection.Insert Overload List


GradientStopCollection.Insert Method (Int32, Single, Color)

Creates the new gradient stop and inserts it at the specified index to the collection.

[Visual Basic]
NotOverridable Overloads Public Sub Insert( _
ByVal index As Integer, _
ByVal position As Single, _
ByVal color As Color _
) _
Implements IGradientStopCollection.Insert
[C#]
public void Insert(
int index,
float position,
Color color
);

Parameters

index
Index in the collection where new gradient stop will be inserted.
position
Position of the new gradient stop.
color
Color of the new radient stop.

Implements

IGradientStopCollection.Insert

See Also

GradientStopCollection Class | Aspose.Slides Namespace | GradientStopCollection.Insert Overload List


GradientStopCollection.RemoveAt Method

Removes a gradient stop at the specified index.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IGradientStopCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
Index of a gradient stop that should be deleted.

Implements

IGradientStopCollection.RemoveAt

See Also

GradientStopCollection Class | Aspose.Slides Namespace


GradientStopCollectionEffectiveData Class

Represents a collection of GradientStopData objects.

For a list of all members of this type, see GradientStopCollectionEffectiveData Members.

System.Object
Aspose.Slides.GradientStopCollectionEffectiveData

[Visual Basic]
Public Class GradientStopCollectionEffectiveData
Implements IGradientStopCollectionEffectiveData, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IGradientStopEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class GradientStopCollectionEffectiveData : IGradientStopCollectionEffectiveData, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GradientStopCollectionEffectiveData Members | Aspose.Slides Namespace


GradientStopCollectionEffectiveData Members

GradientStopCollectionEffectiveData overview

Public Instance Properties

Count | Returns the number of gradient stops in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns the gradient stop by index.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

GradientStopCollectionEffectiveData Class | Aspose.Slides Namespace


GradientStopCollectionEffectiveData Properties

The properties of the GradientStopCollectionEffectiveData class are listed below. For a complete list of GradientStopCollectionEffectiveData class members, see the GradientStopCollectionEffectiveData Members topic.

Public Instance Properties

Count | Returns the number of gradient stops in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns the gradient stop by index.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

GradientStopCollectionEffectiveData Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

GradientStopCollectionEffectiveData.Count Property

Returns the number of gradient stops in a collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

GradientStopCollectionEffectiveData Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

GradientStopCollectionEffectiveData.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

GradientStopCollectionEffectiveData Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

GradientStopCollectionEffectiveData.Item Property

Returns the gradient stop by index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IGradientStopCollectionEffectiveData.Item
As IGradientStopEffectiveData _
Implements IGradientStopCollectionEffectiveData.Item
[C#]
public IGradientStopEffectiveData this[
int index
] {get;}

Implements

IGradientStopCollectionEffectiveData.Item

See Also

GradientStopCollectionEffectiveData Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

GradientStopCollectionEffectiveData.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

GradientStopCollectionEffectiveData Class | Aspose.Slides Namespace


GradientStopCollectionEffectiveData Methods

The methods of the GradientStopCollectionEffectiveData class are listed below. For a complete list of GradientStopCollectionEffectiveData class members, see the GradientStopCollectionEffectiveData Members topic.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

GradientStopCollectionEffectiveData Class | Aspose.Slides Namespace


GradientStopCollectionEffectiveData.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

GradientStopCollectionEffectiveData Class | Aspose.Slides Namespace


GradientStopCollectionEffectiveData.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

GradientStopCollectionEffectiveData Class | Aspose.Slides Namespace


GradientStopEffectiveData Class

immutable object which represents a gradient stop.

For a list of all members of this type, see GradientStopEffectiveData Members.

System.Object
Aspose.Slides.GradientStopEffectiveData

[Visual Basic]
Public Class GradientStopEffectiveData
Implements IGradientStopEffectiveData
[C#]
public class GradientStopEffectiveData : IGradientStopEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GradientStopEffectiveData Members | Aspose.Slides Namespace


GradientStopEffectiveData Members

GradientStopEffectiveData overview

Public Instance Properties

Color | Returns the color of a gradient stop. Read-only Color.
Position | Returns the position (0..1) of a gradient stop. Readonly Single.

See Also

GradientStopEffectiveData Class | Aspose.Slides Namespace


GradientStopEffectiveData Properties

The properties of the GradientStopEffectiveData class are listed below. For a complete list of GradientStopEffectiveData class members, see the GradientStopEffectiveData Members topic.

Public Instance Properties

Color | Returns the color of a gradient stop. Read-only Color.
Position | Returns the position (0..1) of a gradient stop. Readonly Single.

See Also

GradientStopEffectiveData Class | Aspose.Slides Namespace


Color Property

Aspose.Slides Documentation

GradientStopEffectiveData.Color Property

Returns the color of a gradient stop. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Color As Color _
Implements IGradientStopEffectiveData.Color
[C#]
public Color Color {get;}

Implements

IGradientStopEffectiveData.Color

See Also

GradientStopEffectiveData Class | Aspose.Slides Namespace


Position Property

Aspose.Slides Documentation

GradientStopEffectiveData.Position Property

Returns the position (0..1) of a gradient stop. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Position As Single _
Implements IGradientStopEffectiveData.Position
[C#]
public float Position {get;}

Implements

IGradientStopEffectiveData.Position

See Also

GradientStopEffectiveData Class | Aspose.Slides Namespace


GraphicalObject Class

Represents abstract graphical object.

For a list of all members of this type, see GraphicalObject Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GraphicalObject
Aspose.Slides.Charts.Chart
Aspose.Slides.OleObjectFrame
Aspose.Slides.SmartArt.SmartArt
Aspose.Slides.Table

[Visual Basic]
Public Class GraphicalObject
Inherits Shape
Implements IGraphicalObject
[C#]
public class GraphicalObject : Shape, IGraphicalObject

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GraphicalObject Members | Aspose.Slides Namespace


GraphicalObject Members

GraphicalObject overview

Public Instance Properties

AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock | Overloaded. Returns shape's locks. Read-only GraphicalObjectLock.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

GraphicalObject Class | Aspose.Slides Namespace


GraphicalObject Properties

The properties of the GraphicalObject class are listed below. For a complete list of GraphicalObject class members, see the GraphicalObject Members topic.

Public Instance Properties

AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock | Overloaded. Returns shape's locks. Read-only GraphicalObjectLock.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

GraphicalObject Class | Aspose.Slides Namespace


ShapeLock Property

Aspose.Slides Documentation

GraphicalObject.ShapeLock Property

Returns shape's locks. Read-only GraphicalObjectLock.

[Visual Basic]
NotOverridable Overloads Public ReadOnly Property ShapeLock As IGraphicalObjectLock _
Implements IGraphicalObject.ShapeLock
[C#]
new public IGraphicalObjectLock ShapeLock {get;}

Implements

IGraphicalObject.ShapeLock

See Also

GraphicalObject Class | Aspose.Slides Namespace


GraphicalObjectLock Class

Determines which operations are disabled on the parent GraphicalObject.

For a list of all members of this type, see GraphicalObjectLock Members.

System.Object
Aspose.Slides.BaseShapeLock
Aspose.Slides.GraphicalObjectLock

[Visual Basic]
Public Class GraphicalObjectLock
Inherits BaseShapeLock
Implements IGraphicalObjectLock
[C#]
public class GraphicalObjectLock : BaseShapeLock, IGraphicalObjectLock

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GraphicalObjectLock Members | Aspose.Slides Namespace


GraphicalObjectLock Members

GraphicalObjectLock overview

Public Instance Properties

AspectRatioLocked | Determines whether shape have to preserve aspect ratio on resizing.
DrilldownLocked | Determines whether selecting subshapes of this object is forbidden.
GroupingLocked | Determines whether adding this shape to a group is forbidden.
NoLocks (inherited from BaseShapeLock) | Return true if all lock-flags are disabled.
PositionLocked | Determines whether moving this shape is forbidden.
SelectLocked | Determines whether selecting this shape is forbidden.
SizeLocked | Determines whether resizing this shape is forbidden.

See Also

GraphicalObjectLock Class | Aspose.Slides Namespace


GraphicalObjectLock Properties

The properties of the GraphicalObjectLock class are listed below. For a complete list of GraphicalObjectLock class members, see the GraphicalObjectLock Members topic.

Public Instance Properties

AspectRatioLocked | Determines whether shape have to preserve aspect ratio on resizing.
DrilldownLocked | Determines whether selecting subshapes of this object is forbidden.
GroupingLocked | Determines whether adding this shape to a group is forbidden.
NoLocks (inherited from BaseShapeLock) | Return true if all lock-flags are disabled.
PositionLocked | Determines whether moving this shape is forbidden.
SelectLocked | Determines whether selecting this shape is forbidden.
SizeLocked | Determines whether resizing this shape is forbidden.

See Also

GraphicalObjectLock Class | Aspose.Slides Namespace


AspectRatioLocked Property

Aspose.Slides Documentation

GraphicalObjectLock.AspectRatioLocked Property

Determines whether shape have to preserve aspect ratio on resizing.

[Visual Basic]
NotOverridable Public Property AspectRatioLocked As Boolean _
Implements IGraphicalObjectLock.AspectRatioLocked
[C#]
public bool AspectRatioLocked {get; set;}

Implements

IGraphicalObjectLock.AspectRatioLocked

See Also

GraphicalObjectLock Class | Aspose.Slides Namespace


DrilldownLocked Property

Aspose.Slides Documentation

GraphicalObjectLock.DrilldownLocked Property

Determines whether selecting subshapes of this object is forbidden.

[Visual Basic]
NotOverridable Public Property DrilldownLocked As Boolean _
Implements IGraphicalObjectLock.DrilldownLocked
[C#]
public bool DrilldownLocked {get; set;}

Implements

IGraphicalObjectLock.DrilldownLocked

See Also

GraphicalObjectLock Class | Aspose.Slides Namespace


GroupingLocked Property

Aspose.Slides Documentation

GraphicalObjectLock.GroupingLocked Property

Determines whether adding this shape to a group is forbidden.

[Visual Basic]
NotOverridable Public Property GroupingLocked As Boolean _
Implements IGraphicalObjectLock.GroupingLocked
[C#]
public bool GroupingLocked {get; set;}

Implements

IGraphicalObjectLock.GroupingLocked

See Also

GraphicalObjectLock Class | Aspose.Slides Namespace


PositionLocked Property

Aspose.Slides Documentation

GraphicalObjectLock.PositionLocked Property

Determines whether moving this shape is forbidden.

[Visual Basic]
NotOverridable Public Property PositionLocked As Boolean _
Implements IGraphicalObjectLock.PositionLocked
[C#]
public bool PositionLocked {get; set;}

Implements

IGraphicalObjectLock.PositionLocked

See Also

GraphicalObjectLock Class | Aspose.Slides Namespace


SelectLocked Property

Aspose.Slides Documentation

GraphicalObjectLock.SelectLocked Property

Determines whether selecting this shape is forbidden.

[Visual Basic]
NotOverridable Public Property SelectLocked As Boolean _
Implements IGraphicalObjectLock.SelectLocked
[C#]
public bool SelectLocked {get; set;}

Implements

IGraphicalObjectLock.SelectLocked

See Also

GraphicalObjectLock Class | Aspose.Slides Namespace


SizeLocked Property

Aspose.Slides Documentation

GraphicalObjectLock.SizeLocked Property

Determines whether resizing this shape is forbidden.

[Visual Basic]
NotOverridable Public Property SizeLocked As Boolean _
Implements IGraphicalObjectLock.SizeLocked
[C#]
public bool SizeLocked {get; set;}

Implements

IGraphicalObjectLock.SizeLocked

See Also

GraphicalObjectLock Class | Aspose.Slides Namespace


GroupShape Class

Represents a group of shapes on a slide.

For a list of all members of this type, see GroupShape Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GroupShape

[Visual Basic]
Public Class GroupShape
Inherits Shape
Implements IGroupShape
[C#]
public class GroupShape : Shape, IGroupShape

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GroupShape Members | Aspose.Slides Namespace


GroupShape Members

GroupShape overview

Public Instance Properties

AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
AsIShape | Allows to get base IShape interface.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: Returns null for GroupShape objects because they don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock | Overloaded. Returns shape's locks. Readonly GroupShapeLock.
Shapes | Returns the collection of shapes inside the group. Read-only ShapeCollection.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

GroupShape Class | Aspose.Slides Namespace


GroupShape Properties

The properties of the GroupShape class are listed below. For a complete list of GroupShape class members, see the GroupShape Members topic.

Public Instance Properties

AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
AsIShape | Allows to get base IShape interface.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: Returns null for GroupShape objects because they don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock | Overloaded. Returns shape's locks. Readonly GroupShapeLock.
Shapes | Returns the collection of shapes inside the group. Read-only ShapeCollection.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

GroupShape Class | Aspose.Slides Namespace


AsIShape Property

Aspose.Slides Documentation

GroupShape.AsIShape Property

Allows to get base IShape interface.

[Visual Basic]
NotOverridable Public ReadOnly Property AsIShape As IShape _
Implements IGroupShape.AsIShape
[C#]
public IShape AsIShape {get;}

Implements

IGroupShape.AsIShape

See Also

GroupShape Class | Aspose.Slides Namespace


LineFormat Property

Aspose.Slides Documentation

GroupShape.LineFormat Property

Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: Returns null for GroupShape objects because they don't have line properties.

[Visual Basic]
Overrides Public ReadOnly Property LineFormat As ILineFormat _
Implements IShape.LineFormat
[C#]
public override ILineFormat LineFormat {get;}

Implements

IShape.LineFormat

See Also

GroupShape Class | Aspose.Slides Namespace


ShapeLock Property

Aspose.Slides Documentation

GroupShape.ShapeLock Property

Returns shape's locks. Readonly GroupShapeLock.

[Visual Basic]
NotOverridable Overloads Public ReadOnly Property ShapeLock As IGroupShapeLock _
Implements IGroupShape.ShapeLock
[C#]
new public IGroupShapeLock ShapeLock {get;}

Implements

IGroupShape.ShapeLock

See Also

GroupShape Class | Aspose.Slides Namespace


Shapes Property

Aspose.Slides Documentation

GroupShape.Shapes Property

Returns the collection of shapes inside the group. Read-only ShapeCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Shapes As IShapeCollection _
Implements IGroupShape.Shapes
[C#]
public IShapeCollection Shapes {get;}

Implements

IGroupShape.Shapes

See Also

GroupShape Class | Aspose.Slides Namespace


GroupShapeLock Class

Determines which operations are disabled on the parent GroupShape.

For a list of all members of this type, see GroupShapeLock Members.

System.Object
Aspose.Slides.BaseShapeLock
Aspose.Slides.GroupShapeLock

[Visual Basic]
Public Class GroupShapeLock
Inherits BaseShapeLock
Implements IGroupShapeLock
[C#]
public class GroupShapeLock : BaseShapeLock, IGroupShapeLock

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GroupShapeLock Members | Aspose.Slides Namespace


GroupShapeLock Members

GroupShapeLock overview

Public Instance Properties

AspectRatioLocked | Determines whether shape have to preserve aspect ratio on resizing.
GroupingLocked | Determines whether adding this shape to a group is forbidden.
NoLocks (inherited from BaseShapeLock) | Return true if all lock-flags are disabled.
PositionLocked | Determines whether moving this shape is forbidden.
RotationLocked | Determines whether changing rotation angle of this shape is forbidden.
SelectLocked | Determines whether selecting this shape is forbidden.
SizeLocked | Determines whether resizing this shape is forbidden.
UngroupingLocked | Determines whether splitting this groupshape is forbidden.

See Also

GroupShapeLock Class | Aspose.Slides Namespace


GroupShapeLock Properties

The properties of the GroupShapeLock class are listed below. For a complete list of GroupShapeLock class members, see the GroupShapeLock Members topic.

Public Instance Properties

AspectRatioLocked | Determines whether shape have to preserve aspect ratio on resizing.
GroupingLocked | Determines whether adding this shape to a group is forbidden.
NoLocks (inherited from BaseShapeLock) | Return true if all lock-flags are disabled.
PositionLocked | Determines whether moving this shape is forbidden.
RotationLocked | Determines whether changing rotation angle of this shape is forbidden.
SelectLocked | Determines whether selecting this shape is forbidden.
SizeLocked | Determines whether resizing this shape is forbidden.
UngroupingLocked | Determines whether splitting this groupshape is forbidden.

See Also

GroupShapeLock Class | Aspose.Slides Namespace


AspectRatioLocked Property

Aspose.Slides Documentation

GroupShapeLock.AspectRatioLocked Property

Determines whether shape have to preserve aspect ratio on resizing.

[Visual Basic]
NotOverridable Public Property AspectRatioLocked As Boolean _
Implements IGroupShapeLock.AspectRatioLocked
[C#]
public bool AspectRatioLocked {get; set;}

Implements

IGroupShapeLock.AspectRatioLocked

See Also

GroupShapeLock Class | Aspose.Slides Namespace


GroupingLocked Property

Aspose.Slides Documentation

GroupShapeLock.GroupingLocked Property

Determines whether adding this shape to a group is forbidden.

[Visual Basic]
NotOverridable Public Property GroupingLocked As Boolean _
Implements IGroupShapeLock.GroupingLocked
[C#]
public bool GroupingLocked {get; set;}

Implements

IGroupShapeLock.GroupingLocked

See Also

GroupShapeLock Class | Aspose.Slides Namespace


PositionLocked Property

Aspose.Slides Documentation

GroupShapeLock.PositionLocked Property

Determines whether moving this shape is forbidden.

[Visual Basic]
NotOverridable Public Property PositionLocked As Boolean _
Implements IGroupShapeLock.PositionLocked
[C#]
public bool PositionLocked {get; set;}

Implements

IGroupShapeLock.PositionLocked

See Also

GroupShapeLock Class | Aspose.Slides Namespace


RotationLocked Property

Aspose.Slides Documentation

GroupShapeLock.RotationLocked Property

Determines whether changing rotation angle of this shape is forbidden.

[Visual Basic]
NotOverridable Public Property RotationLocked As Boolean _
Implements IGroupShapeLock.RotationLocked
[C#]
public bool RotationLocked {get; set;}

Implements

IGroupShapeLock.RotationLocked

See Also

GroupShapeLock Class | Aspose.Slides Namespace


SelectLocked Property

Aspose.Slides Documentation

GroupShapeLock.SelectLocked Property

Determines whether selecting this shape is forbidden.

[Visual Basic]
NotOverridable Public Property SelectLocked As Boolean _
Implements IGroupShapeLock.SelectLocked
[C#]
public bool SelectLocked {get; set;}

Implements

IGroupShapeLock.SelectLocked

See Also

GroupShapeLock Class | Aspose.Slides Namespace


SizeLocked Property

Aspose.Slides Documentation

GroupShapeLock.SizeLocked Property

Determines whether resizing this shape is forbidden.

[Visual Basic]
NotOverridable Public Property SizeLocked As Boolean _
Implements IGroupShapeLock.SizeLocked
[C#]
public bool SizeLocked {get; set;}

Implements

IGroupShapeLock.SizeLocked

See Also

GroupShapeLock Class | Aspose.Slides Namespace


UngroupingLocked Property

Aspose.Slides Documentation

GroupShapeLock.UngroupingLocked Property

Determines whether splitting this groupshape is forbidden.

[Visual Basic]
NotOverridable Public Property UngroupingLocked As Boolean _
Implements IGroupShapeLock.UngroupingLocked
[C#]
public bool UngroupingLocked {get; set;}

Implements

IGroupShapeLock.UngroupingLocked

See Also

GroupShapeLock Class | Aspose.Slides Namespace


HeaderFooterManager Class

Represents manager which holds behavior of a header\footer placeholders

For a list of all members of this type, see HeaderFooterManager Members.

System.Object
Aspose.Slides.HeaderFooterManager

[Visual Basic]
NotInheritable Public Class HeaderFooterManager
Implements IHeaderFooterManager
[C#]
public sealed class HeaderFooterManager : IHeaderFooterManager

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

HeaderFooterManager Members | Aspose.Slides Namespace


HeaderFooterManager Members

HeaderFooterManager overview

Public Instance Properties

IsDateTimeVisible | Gets or sets value indicating that a date-time placeholders should be present on a slides.
IsFooterVisible | Gets or sets value indicating that a footer placeholders should be present on a slides.
IsSlideNumberVisible | Gets or sets value indicating that a page number placeholders should be present on a slides.

Public Instance Methods

SetDateTimeText | Sets text to all date-time placeholders including master and layout.
SetFooterText | Sets text to all footer placeholders including master and layout.
SetVisibilityOnTitleSlide | Adds or removes header\footer placeholders from title slides (slides based on first layout).

See Also

HeaderFooterManager Class | Aspose.Slides Namespace


HeaderFooterManager Properties

The properties of the HeaderFooterManager class are listed below. For a complete list of HeaderFooterManager class members, see the HeaderFooterManager Members topic.

Public Instance Properties

IsDateTimeVisible | Gets or sets value indicating that a date-time placeholders should be present on a slides.
IsFooterVisible | Gets or sets value indicating that a footer placeholders should be present on a slides.
IsSlideNumberVisible | Gets or sets value indicating that a page number placeholders should be present on a slides.

See Also

HeaderFooterManager Class | Aspose.Slides Namespace


IsDateTimeVisible Property

Aspose.Slides Documentation

HeaderFooterManager.IsDateTimeVisible Property

Gets or sets value indicating that a date-time placeholders should be present on a slides.

[Visual Basic]
NotOverridable Public Property IsDateTimeVisible As Boolean _
Implements IHeaderFooterManager.IsDateTimeVisible
[C#]
public bool IsDateTimeVisible {get; set;}

Implements

IHeaderFooterManager.IsDateTimeVisible

See Also

HeaderFooterManager Class | Aspose.Slides Namespace


IsFooterVisible Property

Aspose.Slides Documentation

HeaderFooterManager.IsFooterVisible Property

Gets or sets value indicating that a footer placeholders should be present on a slides.

[Visual Basic]
NotOverridable Public Property IsFooterVisible As Boolean _
Implements IHeaderFooterManager.IsFooterVisible
[C#]
public bool IsFooterVisible {get; set;}

Implements

IHeaderFooterManager.IsFooterVisible

See Also

HeaderFooterManager Class | Aspose.Slides Namespace


IsSlideNumberVisible Property

Aspose.Slides Documentation

HeaderFooterManager.IsSlideNumberVisible Property

Gets or sets value indicating that a page number placeholders should be present on a slides.

[Visual Basic]
NotOverridable Public Property IsSlideNumberVisible As Boolean _
Implements IHeaderFooterManager.IsSlideNumberVisible
[C#]
public bool IsSlideNumberVisible {get; set;}

Implements

IHeaderFooterManager.IsSlideNumberVisible

See Also

HeaderFooterManager Class | Aspose.Slides Namespace


HeaderFooterManager Methods

The methods of the HeaderFooterManager class are listed below. For a complete list of HeaderFooterManager class members, see the HeaderFooterManager Members topic.

Public Instance Methods

SetDateTimeText | Sets text to all date-time placeholders including master and layout.
SetFooterText | Sets text to all footer placeholders including master and layout.
SetVisibilityOnTitleSlide | Adds or removes header\footer placeholders from title slides (slides based on first layout).

See Also

HeaderFooterManager Class | Aspose.Slides Namespace


HeaderFooterManager.SetDateTimeText Method

Sets text to all date-time placeholders including master and layout.

[Visual Basic]
NotOverridable Public Sub SetDateTimeText( _
ByVal date As String _
) _
Implements IHeaderFooterManager.SetDateTimeText
[C#]
public void SetDateTimeText(
string date
);

Parameters

date
Text to set.

Implements

IHeaderFooterManager.SetDateTimeText

See Also

HeaderFooterManager Class | Aspose.Slides Namespace


HeaderFooterManager.SetFooterText Method

Sets text to all footer placeholders including master and layout.

[Visual Basic]
NotOverridable Public Sub SetFooterText( _
ByVal text As String _
) _
Implements IHeaderFooterManager.SetFooterText
[C#]
public void SetFooterText(
string text
);

Parameters

text
Text to set.

Implements

IHeaderFooterManager.SetFooterText

See Also

HeaderFooterManager Class | Aspose.Slides Namespace


HeaderFooterManager.SetVisibilityOnTitleSlide Method

Adds or removes header\footer placeholders from title slides (slides based on first layout).

[Visual Basic]
NotOverridable Public Sub SetVisibilityOnTitleSlide( _
ByVal isPlaceholdersVisible As Boolean _
) _
Implements IHeaderFooterManager.SetVisibilityOnTitleSlide
[C#]
public void SetVisibilityOnTitleSlide(
bool isPlaceholdersVisible
);

Parameters

isPlaceholdersVisible
true - makes a header\footer placeholders visible on the title slide, otherwise - hides them.

Implements

IHeaderFooterManager.SetVisibilityOnTitleSlide

See Also

HeaderFooterManager Class | Aspose.Slides Namespace


Hyperlink Class

Represents a hyperlink. Immutable.

For a list of all members of this type, see Hyperlink Members.

System.Object
Aspose.Slides.Hyperlink

[Visual Basic]
Public Class Hyperlink
Implements IHyperlink
[C#]
public class Hyperlink : IHyperlink

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Hyperlink Members | Aspose.Slides Namespace


Hyperlink Members

Hyperlink overview

Public Static (Shared) Properties

EndShow | Returns a hyperlink which ends the show. Readonly Hyperlink.
FirstSlide | Returns a hyperlink to the first slide of the presentation. Readonly Hyperlink.
LastSlide | Returns a hyperlink to the last slide of the presentation. Readonly Hyperlink.
LastVievedSlide | Returns a hyperlink to the last viewed slide. Readonly Hyperlink.
Media | Returns a special "play mediafile" hyperlink. Used in AudioFrame and VideoFrame. Readonly Hyperlink.
NextSlide | Returns a hyperlink to the next slide. Readonly Hyperlink.
NoAction | Returns a special "do nothing" hyperlink. Readonly Hyperlink.
PreviousSlide | Returns a hyperlink to the previous slide. Readonly Hyperlink.

Public Static (Shared) Operators

Equality Operator | Tests two hyperlinks for equality.
Inequality Operator | Tests two hyperlinks for inequality.

Public Instance Constructors

Hyperlink Overloaded. Initializes a new instance of the Hyperlink class.

Public Instance Properties

ActionType | Returns type of HyperLinkEx's action. Readonly HyperlinkActionType.
ExternalUrl | Specifies the external URL
HighlightClick | Determines whether the hyperlink should be highlighted on click. Read-only Boolean.
History | Determines whether the target of the parent hyperlink shall be added to a list of viewed hyperlinks when it is invoked. Read-only Boolean.
StopSoundOnClick | Determines whether the sound should be stopped on hyperlink click. Read-only Boolean.
TargetFrame | Returns the frame within the parent HTML frameset for the target of the parent hyperlink when one exists. Read-only String.
TargetSlide | If the Hyperlink targets specific slide returns this slide.
Tooltip | Returns the string which may be surfaced in a user interface as associated with the parent hyperlink. Read-only String.

Public Instance Methods

Equals | Overloaded. Determines whether the two Hyperlink instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

Hyperlink Class | Aspose.Slides Namespace


Hyperlink Constructor

Creates an instance of a hyperlink.

Overload List

Creates an instance of a hyperlink using another hyperlink as source, overriding secondary properties.

public Hyperlink(Hyperlink,string,string,bool,bool,bool);

Creates an instance of a hyperlink which points to specific slide. Note: created hyperlink should be assigned to some object from the same presentation, otherwise link will be saved as NoAction.

public Hyperlink(ISlide);

Creates an instance of a hyperlink.

public Hyperlink(string);

See Also

Hyperlink Class | Aspose.Slides Namespace


Hyperlink Constructor (String)

Creates an instance of a hyperlink.

[Visual Basic]
Overloads Public Sub New( _
ByVal url As String _
)
[C#]
public Hyperlink(
string url
);

Parameters

url
Hyperlink URL.

See Also

Hyperlink Class | Aspose.Slides Namespace | Hyperlink Constructor Overload List


Hyperlink Constructor (ISlide)

Creates an instance of a hyperlink which points to specific slide. Note: created hyperlink should be assigned to some object from the same presentation, otherwise link will be saved as NoAction.

[Visual Basic]
Overloads Public Sub New( _
ByVal slide As ISlide _
)
[C#]
public Hyperlink(
ISlide slide
);

Parameters

slide
Target slide.

See Also

Hyperlink Class | Aspose.Slides Namespace | Hyperlink Constructor Overload List


Hyperlink Constructor (Hyperlink, String, String, Boolean, Boolean, Boolean)

Creates an instance of a hyperlink using another hyperlink as source, overriding secondary properties.

[Visual Basic]
Overloads Public Sub New( _
ByVal source As Hyperlink, _
ByVal targetFrame As String, _
ByVal tooltip As String, _
ByVal history As Boolean, _
ByVal stopSoundsOnClick As Boolean, _
ByVal highlightClick As Boolean _
)
[C#]
public Hyperlink(
Hyperlink source,
string targetFrame,
string tooltip,
bool history,
bool stopSoundsOnClick,
bool highlightClick
);

Parameters

source
Source hyperlink
targetFrame
Target frame
tooltip
Tooltip text
history
stopSoundsOnClick
highlightClick

See Also

Hyperlink Class | Aspose.Slides Namespace | Hyperlink Constructor Overload List


Hyperlink Properties

The properties of the Hyperlink class are listed below. For a complete list of Hyperlink class members, see the Hyperlink Members topic.

Public Static (Shared) Properties

EndShow | Returns a hyperlink which ends the show. Readonly Hyperlink.
FirstSlide | Returns a hyperlink to the first slide of the presentation. Readonly Hyperlink.
LastSlide | Returns a hyperlink to the last slide of the presentation. Readonly Hyperlink.
LastVievedSlide | Returns a hyperlink to the last viewed slide. Readonly Hyperlink.
Media | Returns a special "play mediafile" hyperlink. Used in AudioFrame and VideoFrame. Readonly Hyperlink.
NextSlide | Returns a hyperlink to the next slide. Readonly Hyperlink.
NoAction | Returns a special "do nothing" hyperlink. Readonly Hyperlink.
PreviousSlide | Returns a hyperlink to the previous slide. Readonly Hyperlink.

Public Instance Properties

ActionType | Returns type of HyperLinkEx's action. Readonly HyperlinkActionType.
ExternalUrl | Specifies the external URL
HighlightClick | Determines whether the hyperlink should be highlighted on click. Read-only Boolean.
History | Determines whether the target of the parent hyperlink shall be added to a list of viewed hyperlinks when it is invoked. Read-only Boolean.
StopSoundOnClick | Determines whether the sound should be stopped on hyperlink click. Read-only Boolean.
TargetFrame | Returns the frame within the parent HTML frameset for the target of the parent hyperlink when one exists. Read-only String.
TargetSlide | If the Hyperlink targets specific slide returns this slide.
Tooltip | Returns the string which may be surfaced in a user interface as associated with the parent hyperlink. Read-only String.

See Also

Hyperlink Class | Aspose.Slides Namespace


ActionType Property

Aspose.Slides Documentation

Hyperlink.ActionType Property

Returns type of HyperLinkEx's action. Readonly HyperlinkActionType.

[Visual Basic]
NotOverridable Public ReadOnly Property ActionType As HyperlinkActionType _
Implements IHyperlink.ActionType
[C#]
public HyperlinkActionType ActionType {get;}

Implements

IHyperlink.ActionType

See Also

Hyperlink Class | Aspose.Slides Namespace


EndShow Property

Aspose.Slides Documentation

Hyperlink.EndShow Property

Returns a hyperlink which ends the show. Readonly Hyperlink.

[Visual Basic]
Public Shared ReadOnly Property EndShow As Hyperlink
[C#]
public static Hyperlink EndShow {get;}

See Also

Hyperlink Class | Aspose.Slides Namespace


ExternalUrl Property

Aspose.Slides Documentation

Hyperlink.ExternalUrl Property

Specifies the external URL

[Visual Basic]
NotOverridable Public ReadOnly Property ExternalUrl As String _
Implements IHyperlink.ExternalUrl
[C#]
public string ExternalUrl {get;}

Implements

IHyperlink.ExternalUrl

See Also

Hyperlink Class | Aspose.Slides Namespace


FirstSlide Property

Aspose.Slides Documentation

Hyperlink.FirstSlide Property

Returns a hyperlink to the first slide of the presentation. Readonly Hyperlink.

[Visual Basic]
Public Shared ReadOnly Property FirstSlide As Hyperlink
[C#]
public static Hyperlink FirstSlide {get;}

See Also

Hyperlink Class | Aspose.Slides Namespace


HighlightClick Property

Aspose.Slides Documentation

Hyperlink.HighlightClick Property

Determines whether the hyperlink should be highlighted on click. Read-only Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property HighlightClick As Boolean _
Implements IHyperlink.HighlightClick
[C#]
public bool HighlightClick {get;}

Implements

IHyperlink.HighlightClick

See Also

Hyperlink Class | Aspose.Slides Namespace


History Property

Aspose.Slides Documentation

Hyperlink.History Property

Determines whether the target of the parent hyperlink shall be added to a list of viewed hyperlinks when it is invoked. Read-only Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property History As Boolean _
Implements IHyperlink.History
[C#]
public bool History {get;}

Implements

IHyperlink.History

See Also

Hyperlink Class | Aspose.Slides Namespace


LastSlide Property

Aspose.Slides Documentation

Hyperlink.LastSlide Property

Returns a hyperlink to the last slide of the presentation. Readonly Hyperlink.

[Visual Basic]
Public Shared ReadOnly Property LastSlide As Hyperlink
[C#]
public static Hyperlink LastSlide {get;}

See Also

Hyperlink Class | Aspose.Slides Namespace


LastVievedSlide Property

Aspose.Slides Documentation

Hyperlink.LastVievedSlide Property

Returns a hyperlink to the last viewed slide. Readonly Hyperlink.

[Visual Basic]
Public Shared ReadOnly Property LastVievedSlide As Hyperlink
[C#]
public static Hyperlink LastVievedSlide {get;}

See Also

Hyperlink Class | Aspose.Slides Namespace


Media Property

Aspose.Slides Documentation

Hyperlink.Media Property

Returns a special "play mediafile" hyperlink. Used in AudioFrame and VideoFrame. Readonly Hyperlink.

[Visual Basic]
Public Shared ReadOnly Property Media As Hyperlink
[C#]
public static Hyperlink Media {get;}

See Also

Hyperlink Class | Aspose.Slides Namespace


NextSlide Property

Aspose.Slides Documentation

Hyperlink.NextSlide Property

Returns a hyperlink to the next slide. Readonly Hyperlink.

[Visual Basic]
Public Shared ReadOnly Property NextSlide As Hyperlink
[C#]
public static Hyperlink NextSlide {get;}

See Also

Hyperlink Class | Aspose.Slides Namespace


NoAction Property

Aspose.Slides Documentation

Hyperlink.NoAction Property

Returns a special "do nothing" hyperlink. Readonly Hyperlink.

[Visual Basic]
Public Shared ReadOnly Property NoAction As Hyperlink
[C#]
public static Hyperlink NoAction {get;}

See Also

Hyperlink Class | Aspose.Slides Namespace


PreviousSlide Property

Aspose.Slides Documentation

Hyperlink.PreviousSlide Property

Returns a hyperlink to the previous slide. Readonly Hyperlink.

[Visual Basic]
Public Shared ReadOnly Property PreviousSlide As Hyperlink
[C#]
public static Hyperlink PreviousSlide {get;}

See Also

Hyperlink Class | Aspose.Slides Namespace


StopSoundOnClick Property

Aspose.Slides Documentation

Hyperlink.StopSoundOnClick Property

Determines whether the sound should be stopped on hyperlink click. Read-only Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property StopSoundOnClick As Boolean _
Implements IHyperlink.StopSoundOnClick
[C#]
public bool StopSoundOnClick {get;}

Implements

IHyperlink.StopSoundOnClick

See Also

Hyperlink Class | Aspose.Slides Namespace


TargetFrame Property

Aspose.Slides Documentation

Hyperlink.TargetFrame Property

Returns the frame within the parent HTML frameset for the target of the parent hyperlink when one exists. Read-only String.

[Visual Basic]
NotOverridable Public ReadOnly Property TargetFrame As String _
Implements IHyperlink.TargetFrame
[C#]
public string TargetFrame {get;}

Implements

IHyperlink.TargetFrame

See Also

Hyperlink Class | Aspose.Slides Namespace


TargetSlide Property

Aspose.Slides Documentation

Hyperlink.TargetSlide Property

If the Hyperlink targets specific slide returns this slide.

[Visual Basic]
NotOverridable Public ReadOnly Property TargetSlide As ISlide _
Implements IHyperlink.TargetSlide
[C#]
public ISlide TargetSlide {get;}

Implements

IHyperlink.TargetSlide

See Also

Hyperlink Class | Aspose.Slides Namespace


Tooltip Property

Aspose.Slides Documentation

Hyperlink.Tooltip Property

Returns the string which may be surfaced in a user interface as associated with the parent hyperlink. Read-only String.

[Visual Basic]
NotOverridable Public ReadOnly Property Tooltip As String _
Implements IHyperlink.Tooltip
[C#]
public string Tooltip {get;}

Implements

IHyperlink.Tooltip

See Also

Hyperlink Class | Aspose.Slides Namespace


Hyperlink Methods

The methods of the Hyperlink class are listed below. For a complete list of Hyperlink class members, see the Hyperlink Members topic.

Public Instance Methods

Equals | Overloaded. Determines whether the two Hyperlink instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

Hyperlink Class | Aspose.Slides Namespace


Equals Method

Aspose.Slides Documentation

Hyperlink.Equals Method

Determines whether the two Hyperlink instances are equal.

Overload List

Determines whether the two Hyperlink instances are equal.

public bool Equals(IHyperlink);

Determines whether the two Hyperlink instances are equal.

public override bool Equals(object);

See Also

Hyperlink Class | Aspose.Slides Namespace


Hyperlink.Equals Method (IHyperlink)

Determines whether the two Hyperlink instances are equal.

[Visual Basic]
NotOverridable Overloads Public Function Equals( _
ByVal hlink As IHyperlink _
) As Boolean _
Implements IHyperlink.Equals
[C#]
public bool Equals(
IHyperlink hlink
);

Parameters

hlink
The Hyperlink to compare with the current Hyperlink.

Return Value

true if the specified Hyperlink is equal to the current Hyperlink; otherwise, false.

Implements

IHyperlink.Equals

See Also

Hyperlink Class | Aspose.Slides Namespace | Hyperlink.Equals Overload List


Hyperlink.Equals Method (Object)

Determines whether the two Hyperlink instances are equal.

[Visual Basic]
Overrides Overloads Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The Hyperlink to compare with the current Hyperlink.

Return Value

true if the specified Hyperlink is equal to the current Hyperlink; otherwise, false.

See Also

Hyperlink Class | Aspose.Slides Namespace | Hyperlink.Equals Overload List


Hyperlink.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

Hash code for an URL.

See Also

Hyperlink Class | Aspose.Slides Namespace


Hyperlink Operators

The operators of the Hyperlink class are listed below. For a complete list of Hyperlink class members, see the Hyperlink Members topic.

Public Static (Shared) Operators

Equality Operator | Tests two hyperlinks for equality.
Inequality Operator | Tests two hyperlinks for inequality.

See Also

Hyperlink Class | Hyperlink Members | Aspose.Slides Namespace


Hyperlink Equality Operator

Tests two hyperlinks for equality.

[Visual Basic]
returnValue = Hyperlink.op_Equality(hlink1, hlink2)
[C#]
public static bool operator ==(
Hyperlink hlink1,
Hyperlink hlink2
);

Parameters

hlink1
First hyperlink to be tested.
hlink2
Second hyperlink to be tested.

Return Value

True if hyperlinks are equal.

See Also

Hyperlink Class | Aspose.Slides Namespace


Hyperlink Inequality Operator

Tests two hyperlinks for inequality.

[Visual Basic]
returnValue = Hyperlink.op_Inequality(hlink1, hlink2)
[C#]
public static bool operator !=(
Hyperlink hlink1,
Hyperlink hlink2
);

Parameters

hlink1
First hyperlink to be tested.
hlink2
Second hyperlink to be tested.

Return Value

False if hyperlinks are equal.

See Also

Hyperlink Class | Aspose.Slides Namespace


HyperlinkActionType Enumeration

[Visual Basic]
Public Enum HyperlinkActionType
[C#]
public enum HyperlinkActionType

Members

Member Name | Description | Value
Unknown |  | -1
NoAction |  | 0
Hyperlink |  | 1
JumpFirstSlide |  | 2
JumpPreviousSlide |  | 3
JumpNextSlide |  | 4
JumpLastSlide |  | 5
JumpEndShow |  | 6
JumpLastViewedSlide |  | 7
JumpSpecificSlide |  | 8
StartCustomSlideShow |  | 9
OpenFile |  | 10
OpenPresentation |  | 11
StartStopMedia |  | 12
StartMacro |  | 13
StartProgram |  | 14

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


HyperlinkManager Class

For a list of all members of this type, see HyperlinkManager Members.

System.Object
Aspose.Slides.HyperlinkManager

[Visual Basic]
NotInheritable Public Class HyperlinkManager
Implements IHyperlinkManager
[C#]
public sealed class HyperlinkManager : IHyperlinkManager

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

HyperlinkManager Members | Aspose.Slides Namespace


HyperlinkManager Members

HyperlinkManager overview

Public Instance Methods

RemoveHyperlinkClick
RemoveHyperlinkMouseOver
SetExternalHyperlinkClick
SetExternalHyperlinkMouseOver
SetInternalHyperlinkClick
SetInternalHyperlinkMouseOver

See Also

HyperlinkManager Class | Aspose.Slides Namespace


HyperlinkManager Methods

The methods of the HyperlinkManager class are listed below. For a complete list of HyperlinkManager class members, see the HyperlinkManager Members topic.

Public Instance Methods

RemoveHyperlinkClick
RemoveHyperlinkMouseOver
SetExternalHyperlinkClick
SetExternalHyperlinkMouseOver
SetInternalHyperlinkClick
SetInternalHyperlinkMouseOver

See Also

HyperlinkManager Class | Aspose.Slides Namespace


HyperlinkManager.RemoveHyperlinkClick Method

[Visual Basic]
NotOverridable Public Sub RemoveHyperlinkClick() _
Implements IHyperlinkManager.RemoveHyperlinkClick
[C#]
public void RemoveHyperlinkClick();

Implements

IHyperlinkManager.RemoveHyperlinkClick

See Also

HyperlinkManager Class | Aspose.Slides Namespace


HyperlinkManager.RemoveHyperlinkMouseOver Method

[Visual Basic]
NotOverridable Public Sub RemoveHyperlinkMouseOver() _
Implements IHyperlinkManager.RemoveHyperlinkMouseOver
[C#]
public void RemoveHyperlinkMouseOver();

Implements

IHyperlinkManager.RemoveHyperlinkMouseOver

See Also

HyperlinkManager Class | Aspose.Slides Namespace


HyperlinkManager.SetExternalHyperlinkClick Method

[Visual Basic]
NotOverridable Public Function SetExternalHyperlinkClick( _
ByVal url As String _
) As IHyperlink _
Implements IHyperlinkManager.SetExternalHyperlinkClick
[C#]
public IHyperlink SetExternalHyperlinkClick(
string url
);

Parameters

url
Hyperlink URL.

Implements

IHyperlinkManager.SetExternalHyperlinkClick

See Also

HyperlinkManager Class | Aspose.Slides Namespace


HyperlinkManager.SetExternalHyperlinkMouseOver Method

[Visual Basic]
NotOverridable Public Function SetExternalHyperlinkMouseOver( _
ByVal url As String _
) As IHyperlink _
Implements IHyperlinkManager.SetExternalHyperlinkMouseOver
[C#]
public IHyperlink SetExternalHyperlinkMouseOver(
string url
);

Parameters

url
Hyperlink URL.

Implements

IHyperlinkManager.SetExternalHyperlinkMouseOver

See Also

HyperlinkManager Class | Aspose.Slides Namespace


HyperlinkManager.SetInternalHyperlinkClick Method

[Visual Basic]
NotOverridable Public Function SetInternalHyperlinkClick( _
ByVal targetSlide As ISlide _
) As IHyperlink _
Implements IHyperlinkManager.SetInternalHyperlinkClick
[C#]
public IHyperlink SetInternalHyperlinkClick(
ISlide targetSlide
);

Implements

IHyperlinkManager.SetInternalHyperlinkClick

See Also

HyperlinkManager Class | Aspose.Slides Namespace


HyperlinkManager.SetInternalHyperlinkMouseOver Method

[Visual Basic]
NotOverridable Public Function SetInternalHyperlinkMouseOver( _
ByVal targetSlide As ISlide _
) As IHyperlink _
Implements IHyperlinkManager.SetInternalHyperlinkMouseOver
[C#]
public IHyperlink SetInternalHyperlinkMouseOver(
ISlide targetSlide
);

Implements

IHyperlinkManager.SetInternalHyperlinkMouseOver

See Also

HyperlinkManager Class | Aspose.Slides Namespace


HyperlinkQueries Class

For a list of all members of this type, see HyperlinkQueries Members.

System.Object
Aspose.Slides.HyperlinkQueries

[Visual Basic]
NotInheritable Public Class HyperlinkQueries
Implements IHyperlinkQueries
[C#]
public sealed class HyperlinkQueries : IHyperlinkQueries

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

HyperlinkQueries Members | Aspose.Slides Namespace


HyperlinkQueries Members

HyperlinkQueries overview

Public Instance Methods

GetAnyHyperlinks | Get all IHyperlinkContainer subobjects that contain not null HyperlinkMouseOver. With given IHyperlinkContainer object you can manage its hyperlink (read, update or remove). See IHyperlinkContainer interface.
GetHyperlinkClicks | Get all IHyperlinkContainer subobjects that contain not null HyperlinkClick. With given IHyperlinkContainer object you can manage its hyperlink (read, update or remove). See IHyperlinkContainer interface.
GetHyperlinkMouseOvers | Get all IHyperlinkContainer subobjects that contain not null HyperlinkMouseOver. With given IHyperlinkContainer object you can manage its hyperlink (read, update or remove). See IHyperlinkContainer interface.
RemoveAllHyperlinks | Removes all contained HyperlinkClick and HyperlinkMouseOver hyperlinks (in all IHyperlinkContainer subobjects).

See Also

HyperlinkQueries Class | Aspose.Slides Namespace


HyperlinkQueries Methods

The methods of the HyperlinkQueries class are listed below. For a complete list of HyperlinkQueries class members, see the HyperlinkQueries Members topic.

Public Instance Methods

GetAnyHyperlinks | Get all IHyperlinkContainer subobjects that contain not null HyperlinkMouseOver. With given IHyperlinkContainer object you can manage its hyperlink (read, update or remove). See IHyperlinkContainer interface.
GetHyperlinkClicks | Get all IHyperlinkContainer subobjects that contain not null HyperlinkClick. With given IHyperlinkContainer object you can manage its hyperlink (read, update or remove). See IHyperlinkContainer interface.
GetHyperlinkMouseOvers | Get all IHyperlinkContainer subobjects that contain not null HyperlinkMouseOver. With given IHyperlinkContainer object you can manage its hyperlink (read, update or remove). See IHyperlinkContainer interface.
RemoveAllHyperlinks | Removes all contained HyperlinkClick and HyperlinkMouseOver hyperlinks (in all IHyperlinkContainer subobjects).

See Also

HyperlinkQueries Class | Aspose.Slides Namespace


HyperlinkQueries.GetAnyHyperlinks Method

Get all IHyperlinkContainer subobjects that contain not null HyperlinkMouseOver. With given IHyperlinkContainer object you can manage its hyperlink (read, update or remove). See IHyperlinkContainer interface.

[Visual Basic]
NotOverridable Public Function GetAnyHyperlinks() As List(Of IHyperlinkContainer) _
Implements IHyperlinkQueries.GetAnyHyperlinks
[C#]
public List<IHyperlinkContainer> GetAnyHyperlinks();

Implements

IHyperlinkQueries.GetAnyHyperlinks

See Also

HyperlinkQueries Class | Aspose.Slides Namespace


HyperlinkQueries.GetHyperlinkClicks Method

Get all IHyperlinkContainer subobjects that contain not null HyperlinkClick. With given IHyperlinkContainer object you can manage its hyperlink (read, update or remove). See IHyperlinkContainer interface.

[Visual Basic]
NotOverridable Public Function GetHyperlinkClicks() As List(Of IHyperlinkContainer) _
Implements IHyperlinkQueries.GetHyperlinkClicks
[C#]
public List<IHyperlinkContainer> GetHyperlinkClicks();

Implements

IHyperlinkQueries.GetHyperlinkClicks

See Also

HyperlinkQueries Class | Aspose.Slides Namespace


HyperlinkQueries.GetHyperlinkMouseOvers Method

Get all IHyperlinkContainer subobjects that contain not null HyperlinkMouseOver. With given IHyperlinkContainer object you can manage its hyperlink (read, update or remove). See IHyperlinkContainer interface.

[Visual Basic]
NotOverridable Public Function GetHyperlinkMouseOvers() As List(Of IHyperlinkContainer) _
Implements IHyperlinkQueries.GetHyperlinkMouseOvers
[C#]
public List<IHyperlinkContainer> GetHyperlinkMouseOvers();

Implements

IHyperlinkQueries.GetHyperlinkMouseOvers

See Also

HyperlinkQueries Class | Aspose.Slides Namespace


HyperlinkQueries.RemoveAllHyperlinks Method

Removes all contained HyperlinkClick and HyperlinkMouseOver hyperlinks (in all IHyperlinkContainer subobjects).

[Visual Basic]
NotOverridable Public Sub RemoveAllHyperlinks() _
Implements IHyperlinkQueries.RemoveAllHyperlinks
[C#]
public void RemoveAllHyperlinks();

Implements

IHyperlinkQueries.RemoveAllHyperlinks

See Also

HyperlinkQueries Class | Aspose.Slides Namespace


IAdjustValue Interface

For a list of all members of this type, see IAdjustValue Members.

[Visual Basic]
Public Interface IAdjustValue
[C#]
public interface IAdjustValue

Types that implement IAdjustValue

Type | Description
AdjustValue | Represents a geometry shape's adjustment value. These values affect shape's form.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAdjustValue Members | Aspose.Slides Namespace


IAdjustValue Members

IAdjustValue overview

Public Instance Properties

AngleValue
Name
RawValue

See Also

IAdjustValue Interface | Aspose.Slides Namespace


IAdjustValue Properties

The properties of the IAdjustValue interface are listed below. For a complete list of IAdjustValue interface members, see the IAdjustValue Members topic.

Public Instance Properties

AngleValue
Name
RawValue

See Also

IAdjustValue Interface | Aspose.Slides Namespace


AngleValue Property

Aspose.Slides Documentation

IAdjustValue.AngleValue Property

[Visual Basic]
Property AngleValue As Single
[C#]
float AngleValue {get; set;}

See Also

IAdjustValue Interface | Aspose.Slides Namespace


Name Property

Aspose.Slides Documentation

IAdjustValue.Name Property

[Visual Basic]
Property Name As String
[C#]
string Name {get;}

See Also

IAdjustValue Interface | Aspose.Slides Namespace


RawValue Property

Aspose.Slides Documentation

IAdjustValue.RawValue Property

[Visual Basic]
Property RawValue As Long
[C#]
long RawValue {get; set;}

See Also

IAdjustValue Interface | Aspose.Slides Namespace


IAdjustValueCollection Interface

For a list of all members of this type, see IAdjustValueCollection Members.

[Visual Basic]
Public Interface IAdjustValueCollection
Implements ICollection, IEnumerable
[C#]
public interface IAdjustValueCollection : ICollection, IEnumerable

Types that implement IAdjustValueCollection

Type | Description
AdjustValueCollection | Reprasents a collection of shape's adjustments.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAdjustValueCollection Members | Aspose.Slides Namespace


IAdjustValueCollection Members

IAdjustValueCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IAdjustValueCollection Interface | Aspose.Slides Namespace


IAdjustValueCollection Properties

The properties of the IAdjustValueCollection interface are listed below. For a complete list of IAdjustValueCollection interface members, see the IAdjustValueCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IAdjustValueCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

IAdjustValueCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IAdjustValueCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IAdjustValueCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IAdjustValueCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IAdjustValueCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IAdjustValue
[C#]
IAdjustValue this[
int index
] {get;}

See Also

IAdjustValueCollection Interface | Aspose.Slides Namespace


IAnimationTimeLine Interface

For a list of all members of this type, see IAnimationTimeLine Members.

[Visual Basic]
Public Interface IAnimationTimeLine
[C#]
public interface IAnimationTimeLine

Types that implement IAnimationTimeLine

Type | Description
AnimationTimeLine | Represents timeline of animation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAnimationTimeLine Members | Aspose.Slides Namespace


IAnimationTimeLine Members

IAnimationTimeLine overview

Public Instance Properties

InteractiveSequences
MainSequence
TextAnimationCollection

See Also

IAnimationTimeLine Interface | Aspose.Slides Namespace


IAnimationTimeLine Properties

The properties of the IAnimationTimeLine interface are listed below. For a complete list of IAnimationTimeLine interface members, see the IAnimationTimeLine Members topic.

Public Instance Properties

InteractiveSequences
MainSequence
TextAnimationCollection

See Also

IAnimationTimeLine Interface | Aspose.Slides Namespace


InteractiveSequences Property

Aspose.Slides Documentation

IAnimationTimeLine.InteractiveSequences Property

[Visual Basic]
Property InteractiveSequences As ISequenceCollection
[C#]
ISequenceCollection InteractiveSequences {get;}

See Also

IAnimationTimeLine Interface | Aspose.Slides Namespace


MainSequence Property

Aspose.Slides Documentation

IAnimationTimeLine.MainSequence Property

[Visual Basic]
Property MainSequence As ISequence
[C#]
ISequence MainSequence {get;}

See Also

IAnimationTimeLine Interface | Aspose.Slides Namespace


TextAnimationCollection Property

Aspose.Slides Documentation

IAnimationTimeLine.TextAnimationCollection Property

[Visual Basic]
Property TextAnimationCollection As ITextAnimationCollection
[C#]
ITextAnimationCollection TextAnimationCollection {get;}

See Also

IAnimationTimeLine Interface | Aspose.Slides Namespace


IAudio Interface

For a list of all members of this type, see IAudio Members.

[Visual Basic]
Public Interface IAudio
[C#]
public interface IAudio

Types that implement IAudio

Type | Description
Audio | Represents an embedded audio file.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAudio Members | Aspose.Slides Namespace


IAudio Members

IAudio overview

Public Instance Properties

BinaryData
ContentType

See Also

IAudio Interface | Aspose.Slides Namespace


IAudio Properties

The properties of the IAudio interface are listed below. For a complete list of IAudio interface members, see the IAudio Members topic.

Public Instance Properties

BinaryData
ContentType

See Also

IAudio Interface | Aspose.Slides Namespace


BinaryData Property

Aspose.Slides Documentation

IAudio.BinaryData Property

[Visual Basic]
Property BinaryData As Byte()
[C#]
byte[] BinaryData {get;}

See Also

IAudio Interface | Aspose.Slides Namespace


ContentType Property

Aspose.Slides Documentation

IAudio.ContentType Property

[Visual Basic]
Property ContentType As String
[C#]
string ContentType {get;}

See Also

IAudio Interface | Aspose.Slides Namespace


IAudioCollection Interface

For a list of all members of this type, see IAudioCollection Members.

[Visual Basic]
Public Interface IAudioCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IAudio, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IAudioCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IAudioCollection

Type | Description
AudioCollection | Represents a collection of embedded audio files.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAudioCollection Members | Aspose.Slides Namespace


IAudioCollection Members

IAudioCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

AddAudio Overloaded.

See Also

IAudioCollection Interface | Aspose.Slides Namespace


IAudioCollection Properties

The properties of the IAudioCollection interface are listed below. For a complete list of IAudioCollection interface members, see the IAudioCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IAudioCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

IAudioCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IAudioCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IAudioCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IAudioCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IAudioCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IAudio
[C#]
IAudio this[
int index
] {get;}

See Also

IAudioCollection Interface | Aspose.Slides Namespace


IAudioCollection Methods

The methods of the IAudioCollection interface are listed below. For a complete list of IAudioCollection interface members, see the IAudioCollection Members topic.

Public Instance Methods

AddAudio Overloaded.

See Also

IAudioCollection Interface | Aspose.Slides Namespace


AddAudio Method

Aspose.Slides Documentation

IAudioCollection.AddAudio Method

Overload List

IAudio AddAudio(IAudio);

IAudio AddAudio(byte[]);

IAudio AddAudio(Stream);

See Also

IAudioCollection Interface | Aspose.Slides Namespace


IAudioCollection.AddAudio Method (IAudio)

[Visual Basic]
Function AddAudio( _
ByVal audio As IAudio _
) As IAudio
[C#]
IAudio AddAudio(
IAudio audio
);

See Also

IAudioCollection Interface | Aspose.Slides Namespace | IAudioCollection.AddAudio Overload List


IAudioCollection.AddAudio Method (Byte[])

[Visual Basic]
Function AddAudio( _
ByVal audioData As Byte() _
) As IAudio
[C#]
IAudio AddAudio(
byte[] audioData
);

See Also

IAudioCollection Interface | Aspose.Slides Namespace | IAudioCollection.AddAudio Overload List


IAudioCollection.AddAudio Method (Stream)

[Visual Basic]
Function AddAudio( _
ByVal stream As Stream _
) As IAudio
[C#]
IAudio AddAudio(
Stream stream
);

See Also

IAudioCollection Interface | Aspose.Slides Namespace | IAudioCollection.AddAudio Overload List


IAudioFrame Interface

For a list of all members of this type, see IAudioFrame Members.

[Visual Basic]
Public Interface IAudioFrame
Implements IPictureFrame, IGeometryShape, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public interface IAudioFrame : IPictureFrame, IGeometryShape, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer

Types that implement IAudioFrame

Type | Description
AudioFrame | Represents an audio clip on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAudioFrame Members | Aspose.Slides Namespace


IAudioFrame Members

IAudioFrame overview

Public Instance Properties

AsIPictureFrame
AudioCdEndTrack
AudioCdEndTrackTime
AudioCdStartTrack
AudioCdStartTrackTime
Embedded
EmbeddedAudio
HideAtShowing
LinkPathLong
PlayLoopMode
PlayMode
Volume

See Also

IAudioFrame Interface | Aspose.Slides Namespace


IAudioFrame Properties

The properties of the IAudioFrame interface are listed below. For a complete list of IAudioFrame interface members, see the IAudioFrame Members topic.

Public Instance Properties

AsIPictureFrame
AudioCdEndTrack
AudioCdEndTrackTime
AudioCdStartTrack
AudioCdStartTrackTime
Embedded
EmbeddedAudio
HideAtShowing
LinkPathLong
PlayLoopMode
PlayMode
Volume

See Also

IAudioFrame Interface | Aspose.Slides Namespace


AsIPictureFrame Property

Aspose.Slides Documentation

IAudioFrame.AsIPictureFrame Property

[Visual Basic]
Property AsIPictureFrame As IPictureFrame
[C#]
IPictureFrame AsIPictureFrame {get;}

See Also

IAudioFrame Interface | Aspose.Slides Namespace


AudioCdEndTrack Property

Aspose.Slides Documentation

IAudioFrame.AudioCdEndTrack Property

[Visual Basic]
Property AudioCdEndTrack As Integer
[C#]
int AudioCdEndTrack {get; set;}

See Also

IAudioFrame Interface | Aspose.Slides Namespace


AudioCdEndTrackTime Property

Aspose.Slides Documentation

IAudioFrame.AudioCdEndTrackTime Property

[Visual Basic]
Property AudioCdEndTrackTime As Integer
[C#]
int AudioCdEndTrackTime {get; set;}

See Also

IAudioFrame Interface | Aspose.Slides Namespace


AudioCdStartTrack Property

Aspose.Slides Documentation

IAudioFrame.AudioCdStartTrack Property

[Visual Basic]
Property AudioCdStartTrack As Integer
[C#]
int AudioCdStartTrack {get; set;}

See Also

IAudioFrame Interface | Aspose.Slides Namespace


AudioCdStartTrackTime Property

Aspose.Slides Documentation

IAudioFrame.AudioCdStartTrackTime Property

[Visual Basic]
Property AudioCdStartTrackTime As Integer
[C#]
int AudioCdStartTrackTime {get; set;}

See Also

IAudioFrame Interface | Aspose.Slides Namespace


Embedded Property

Aspose.Slides Documentation

IAudioFrame.Embedded Property

[Visual Basic]
Property Embedded As Boolean
[C#]
bool Embedded {get;}

See Also

IAudioFrame Interface | Aspose.Slides Namespace


EmbeddedAudio Property

Aspose.Slides Documentation

IAudioFrame.EmbeddedAudio Property

[Visual Basic]
Property EmbeddedAudio As IAudio
[C#]
IAudio EmbeddedAudio {get; set;}

See Also

IAudioFrame Interface | Aspose.Slides Namespace


HideAtShowing Property

Aspose.Slides Documentation

IAudioFrame.HideAtShowing Property

[Visual Basic]
Property HideAtShowing As Boolean
[C#]
bool HideAtShowing {get; set;}

See Also

IAudioFrame Interface | Aspose.Slides Namespace


LinkPathLong Property

Aspose.Slides Documentation

IAudioFrame.LinkPathLong Property

[Visual Basic]
Property LinkPathLong As String
[C#]
string LinkPathLong {get; set;}

See Also

IAudioFrame Interface | Aspose.Slides Namespace


PlayLoopMode Property

Aspose.Slides Documentation

IAudioFrame.PlayLoopMode Property

[Visual Basic]
Property PlayLoopMode As Boolean
[C#]
bool PlayLoopMode {get; set;}

See Also

IAudioFrame Interface | Aspose.Slides Namespace


PlayMode Property

Aspose.Slides Documentation

IAudioFrame.PlayMode Property

[Visual Basic]
Property PlayMode As AudioPlayModePreset
[C#]
AudioPlayModePreset PlayMode {get; set;}

See Also

IAudioFrame Interface | Aspose.Slides Namespace


Volume Property

Aspose.Slides Documentation

IAudioFrame.Volume Property

[Visual Basic]
Property Volume As AudioVolumeMode
[C#]
AudioVolumeMode Volume {get; set;}

See Also

IAudioFrame Interface | Aspose.Slides Namespace


IAutoShape Interface

For a list of all members of this type, see IAutoShape Members.

[Visual Basic]
Public Interface IAutoShape
Implements IGeometryShape, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public interface IAutoShape : IGeometryShape, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer

Types that implement IAutoShape

Type | Description
AutoShape | Represents an AutoShape.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAutoShape Members | Aspose.Slides Namespace


IAutoShape Members

IAutoShape overview

Public Instance Properties

AsIGeometryShape
ShapeLock
TextFrame
UseBackgroundFill

Public Instance Methods

AddTextFrame

See Also

IAutoShape Interface | Aspose.Slides Namespace


IAutoShape Properties

The properties of the IAutoShape interface are listed below. For a complete list of IAutoShape interface members, see the IAutoShape Members topic.

Public Instance Properties

AsIGeometryShape
ShapeLock
TextFrame
UseBackgroundFill

See Also

IAutoShape Interface | Aspose.Slides Namespace


AsIGeometryShape Property

Aspose.Slides Documentation

IAutoShape.AsIGeometryShape Property

[Visual Basic]
Property AsIGeometryShape As IGeometryShape
[C#]
IGeometryShape AsIGeometryShape {get;}

See Also

IAutoShape Interface | Aspose.Slides Namespace


ShapeLock Property

Aspose.Slides Documentation

IAutoShape.ShapeLock Property

[Visual Basic]
Property ShapeLock As IAutoShapeLock
[C#]
IAutoShapeLock ShapeLock {get;}

See Also

IAutoShape Interface | Aspose.Slides Namespace


TextFrame Property

Aspose.Slides Documentation

IAutoShape.TextFrame Property

[Visual Basic]
Property TextFrame As ITextFrame
[C#]
ITextFrame TextFrame {get;}

See Also

IAutoShape Interface | Aspose.Slides Namespace


UseBackgroundFill Property

Aspose.Slides Documentation

IAutoShape.UseBackgroundFill Property

[Visual Basic]
Property UseBackgroundFill As Boolean
[C#]
bool UseBackgroundFill {get; set;}

See Also

IAutoShape Interface | Aspose.Slides Namespace


IAutoShape Methods

The methods of the IAutoShape interface are listed below. For a complete list of IAutoShape interface members, see the IAutoShape Members topic.

Public Instance Methods

AddTextFrame

See Also

IAutoShape Interface | Aspose.Slides Namespace


IAutoShape.AddTextFrame Method

[Visual Basic]
Function AddTextFrame( _
ByVal text As String _
) As ITextFrame
[C#]
ITextFrame AddTextFrame(
string text
);

See Also

IAutoShape Interface | Aspose.Slides Namespace


IAutoShapeLock Interface

For a list of all members of this type, see IAutoShapeLock Members.

[Visual Basic]
Public Interface IAutoShapeLock
Implements IBaseShapeLock
[C#]
public interface IAutoShapeLock : IBaseShapeLock

Types that implement IAutoShapeLock

Type | Description
AutoShapeLock | Determines which operations are disabled on the parent AutoshapeEx.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAutoShapeLock Members | Aspose.Slides Namespace


IAutoShapeLock Members

IAutoShapeLock overview

Public Instance Properties

AdjustHandlesLocked
ArrowheadsLocked
AsIBaseShapeLock
AspectRatioLocked
EditPointsLocked
GroupingLocked
PositionLocked
RotateLocked
SelectLocked
ShapeTypeLocked
SizeLocked
TextLocked

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


IAutoShapeLock Properties

The properties of the IAutoShapeLock interface are listed below. For a complete list of IAutoShapeLock interface members, see the IAutoShapeLock Members topic.

Public Instance Properties

AdjustHandlesLocked
ArrowheadsLocked
AsIBaseShapeLock
AspectRatioLocked
EditPointsLocked
GroupingLocked
PositionLocked
RotateLocked
SelectLocked
ShapeTypeLocked
SizeLocked
TextLocked

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


AdjustHandlesLocked Property

Aspose.Slides Documentation

IAutoShapeLock.AdjustHandlesLocked Property

[Visual Basic]
Property AdjustHandlesLocked As Boolean
[C#]
bool AdjustHandlesLocked {get; set;}

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


ArrowheadsLocked Property

Aspose.Slides Documentation

IAutoShapeLock.ArrowheadsLocked Property

[Visual Basic]
Property ArrowheadsLocked As Boolean
[C#]
bool ArrowheadsLocked {get; set;}

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


AsIBaseShapeLock Property

Aspose.Slides Documentation

IAutoShapeLock.AsIBaseShapeLock Property

[Visual Basic]
Property AsIBaseShapeLock As IBaseShapeLock
[C#]
IBaseShapeLock AsIBaseShapeLock {get;}

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


AspectRatioLocked Property

Aspose.Slides Documentation

IAutoShapeLock.AspectRatioLocked Property

[Visual Basic]
Property AspectRatioLocked As Boolean
[C#]
bool AspectRatioLocked {get; set;}

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


EditPointsLocked Property

Aspose.Slides Documentation

IAutoShapeLock.EditPointsLocked Property

[Visual Basic]
Property EditPointsLocked As Boolean
[C#]
bool EditPointsLocked {get; set;}

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


GroupingLocked Property

Aspose.Slides Documentation

IAutoShapeLock.GroupingLocked Property

[Visual Basic]
Property GroupingLocked As Boolean
[C#]
bool GroupingLocked {get; set;}

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


PositionLocked Property

Aspose.Slides Documentation

IAutoShapeLock.PositionLocked Property

[Visual Basic]
Property PositionLocked As Boolean
[C#]
bool PositionLocked {get; set;}

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


RotateLocked Property

Aspose.Slides Documentation

IAutoShapeLock.RotateLocked Property

[Visual Basic]
Property RotateLocked As Boolean
[C#]
bool RotateLocked {get; set;}

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


SelectLocked Property

Aspose.Slides Documentation

IAutoShapeLock.SelectLocked Property

[Visual Basic]
Property SelectLocked As Boolean
[C#]
bool SelectLocked {get; set;}

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


ShapeTypeLocked Property

Aspose.Slides Documentation

IAutoShapeLock.ShapeTypeLocked Property

[Visual Basic]
Property ShapeTypeLocked As Boolean
[C#]
bool ShapeTypeLocked {get; set;}

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


SizeLocked Property

Aspose.Slides Documentation

IAutoShapeLock.SizeLocked Property

[Visual Basic]
Property SizeLocked As Boolean
[C#]
bool SizeLocked {get; set;}

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


TextLocked Property

Aspose.Slides Documentation

IAutoShapeLock.TextLocked Property

[Visual Basic]
Property TextLocked As Boolean
[C#]
bool TextLocked {get; set;}

See Also

IAutoShapeLock Interface | Aspose.Slides Namespace


IBackdrop3DScene Interface

For a list of all members of this type, see IBackdrop3DScene Members.

[Visual Basic]
Public Interface IBackdrop3DScene
[C#]
public interface IBackdrop3DScene

Types that implement IBackdrop3DScene

Type | Description
Backdrop3DScene | Defines a plane in which effects, such as glow and shadow, are applied in relation to the shape they are being applied to

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBackdrop3DScene Members | Aspose.Slides Namespace


IBackdrop3DScene Members

IBackdrop3DScene overview

Public Instance Properties

AnchorPoint
NormalVector
UpVector

See Also

IBackdrop3DScene Interface | Aspose.Slides Namespace


IBackdrop3DScene Properties

The properties of the IBackdrop3DScene interface are listed below. For a complete list of IBackdrop3DScene interface members, see the IBackdrop3DScene Members topic.

Public Instance Properties

AnchorPoint
NormalVector
UpVector

See Also

IBackdrop3DScene Interface | Aspose.Slides Namespace


AnchorPoint Property

Aspose.Slides Documentation

IBackdrop3DScene.AnchorPoint Property

[Visual Basic]
Property AnchorPoint As Single()
[C#]
float[] AnchorPoint {get; set;}

See Also

IBackdrop3DScene Interface | Aspose.Slides Namespace


NormalVector Property

Aspose.Slides Documentation

IBackdrop3DScene.NormalVector Property

[Visual Basic]
Property NormalVector As Single()
[C#]
float[] NormalVector {get; set;}

See Also

IBackdrop3DScene Interface | Aspose.Slides Namespace


UpVector Property

Aspose.Slides Documentation

IBackdrop3DScene.UpVector Property

[Visual Basic]
Property UpVector As Single()
[C#]
float[] UpVector {get; set;}

See Also

IBackdrop3DScene Interface | Aspose.Slides Namespace


IBackground Interface

For a list of all members of this type, see IBackground Members.

[Visual Basic]
Public Interface IBackground
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IBackground : ISlideComponent, IPresentationComponent

Types that implement IBackground

Type | Description
Background | Represents background of a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBackground Members | Aspose.Slides Namespace


IBackground Members

IBackground overview

Public Instance Properties

AsISlideComponent
FillFormat
StyleColor
StyleIndex
Type

See Also

IBackground Interface | Aspose.Slides Namespace


IBackground Properties

The properties of the IBackground interface are listed below. For a complete list of IBackground interface members, see the IBackground Members topic.

Public Instance Properties

AsISlideComponent
FillFormat
StyleColor
StyleIndex
Type

See Also

IBackground Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IBackground.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IBackground Interface | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

IBackground.FillFormat Property

[Visual Basic]
Property FillFormat As IFillFormat
[C#]
IFillFormat FillFormat {get;}

See Also

IBackground Interface | Aspose.Slides Namespace


StyleColor Property

Aspose.Slides Documentation

IBackground.StyleColor Property

[Visual Basic]
Property StyleColor As IColorFormat
[C#]
IColorFormat StyleColor {get;}

See Also

IBackground Interface | Aspose.Slides Namespace


StyleIndex Property

Aspose.Slides Documentation

IBackground.StyleIndex Property

[Visual Basic]
Property StyleIndex As UInt16
[C#]
ushort StyleIndex {get; set;}

See Also

IBackground Interface | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

IBackground.Type Property

[Visual Basic]
Property Type As BackgroundType
[C#]
BackgroundType Type {get; set;}

See Also

IBackground Interface | Aspose.Slides Namespace


IBaseShapeLock Interface

For a list of all members of this type, see IBaseShapeLock Members.

Aspose.Slides.IBaseShapeLock
Aspose.Slides.IAutoShapeLock
Aspose.Slides.IConnectorLock
Aspose.Slides.IGraphicalObjectLock
Aspose.Slides.IGroupShapeLock
Aspose.Slides.IPictureFrameLock

[Visual Basic]
Public Interface IBaseShapeLock
[C#]
public interface IBaseShapeLock

Types that implement IBaseShapeLock

Type | Description
AutoShapeLock | Determines which operations are disabled on the parent AutoshapeEx.
BaseShapeLock | Represents a base class for locks (disabled operation).
ConnectorLock | Determines which operations are disabled on the parent Connector.
GraphicalObjectLock | Determines which operations are disabled on the parent GraphicalObject.
GroupShapeLock | Determines which operations are disabled on the parent GroupShape.
PictureFrameLock | Determines which operations are disabled on the parent PictureFrame.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBaseShapeLock Members | Aspose.Slides Namespace


IBaseShapeLock Members

IBaseShapeLock overview

Public Instance Properties

NoLocks

See Also

IBaseShapeLock Interface | Aspose.Slides Namespace


IBaseShapeLock Properties

The properties of the IBaseShapeLock interface are listed below. For a complete list of IBaseShapeLock interface members, see the IBaseShapeLock Members topic.

Public Instance Properties

NoLocks

See Also

IBaseShapeLock Interface | Aspose.Slides Namespace


NoLocks Property

Aspose.Slides Documentation

IBaseShapeLock.NoLocks Property

[Visual Basic]
Property NoLocks As Boolean
[C#]
bool NoLocks {get;}

See Also

IBaseShapeLock Interface | Aspose.Slides Namespace


IBaseSlide Interface

For a list of all members of this type, see IBaseSlide Members.

Aspose.Slides.IBaseSlide
Derived interfaces

[Visual Basic]
Public Interface IBaseSlide
Implements IThemeable, ISlideComponent, IPresentationComponent
[C#]
public interface IBaseSlide : IThemeable, ISlideComponent, IPresentationComponent

Types that implement IBaseSlide

Type | Description
BaseSlide | Represents common data for all slide types.
LayoutSlide | Represents a layout slide.
MasterHandoutSlide | Represents master slide for handouts.
MasterNotesSlide | Represents master slide for notes.
MasterSlide | Represents a master slide in a presentation.
NotesSlide | Represents a notes slide in a presentation.
Slide | Represents a slide in a presentation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBaseSlide Members | Aspose.Slides Namespace


IBaseSlide Members

IBaseSlide overview

Public Instance Properties

AsIThemeable
Background
Controls
CustomData
HyperlinkQueries
Name
Shapes
SlideId
SlideShowTransition
Timeline

Public Instance Methods

FindShapeByAltText

See Also

IBaseSlide Interface | Aspose.Slides Namespace


IBaseSlide Properties

The properties of the IBaseSlide interface are listed below. For a complete list of IBaseSlide interface members, see the IBaseSlide Members topic.

Public Instance Properties

AsIThemeable
Background
Controls
CustomData
HyperlinkQueries
Name
Shapes
SlideId
SlideShowTransition
Timeline

See Also

IBaseSlide Interface | Aspose.Slides Namespace


AsIThemeable Property

Aspose.Slides Documentation

IBaseSlide.AsIThemeable Property

[Visual Basic]
Property AsIThemeable As IThemeable
[C#]
IThemeable AsIThemeable {get;}

See Also

IBaseSlide Interface | Aspose.Slides Namespace


Background Property

Aspose.Slides Documentation

IBaseSlide.Background Property

[Visual Basic]
Property Background As IBackground
[C#]
IBackground Background {get;}

See Also

IBaseSlide Interface | Aspose.Slides Namespace


Controls Property

Aspose.Slides Documentation

IBaseSlide.Controls Property

[Visual Basic]
Property Controls As IControlCollection
[C#]
IControlCollection Controls {get;}

See Also

IBaseSlide Interface | Aspose.Slides Namespace


CustomData Property

Aspose.Slides Documentation

IBaseSlide.CustomData Property

[Visual Basic]
Property CustomData As ICustomData
[C#]
ICustomData CustomData {get;}

See Also

IBaseSlide Interface | Aspose.Slides Namespace


HyperlinkQueries Property

Aspose.Slides Documentation

IBaseSlide.HyperlinkQueries Property

[Visual Basic]
Property HyperlinkQueries As IHyperlinkQueries
[C#]
IHyperlinkQueries HyperlinkQueries {get;}

See Also

IBaseSlide Interface | Aspose.Slides Namespace


Name Property

Aspose.Slides Documentation

IBaseSlide.Name Property

[Visual Basic]
Property Name As String
[C#]
string Name {get; set;}

See Also

IBaseSlide Interface | Aspose.Slides Namespace


Shapes Property

Aspose.Slides Documentation

IBaseSlide.Shapes Property

[Visual Basic]
Property Shapes As IShapeCollection
[C#]
IShapeCollection Shapes {get;}

See Also

IBaseSlide Interface | Aspose.Slides Namespace


SlideId Property

Aspose.Slides Documentation

IBaseSlide.SlideId Property

[Visual Basic]
Property SlideId As UInt32
[C#]
uint SlideId {get;}

See Also

IBaseSlide Interface | Aspose.Slides Namespace


SlideShowTransition Property

Aspose.Slides Documentation

IBaseSlide.SlideShowTransition Property

[Visual Basic]
Property SlideShowTransition As ISlideShowTransition
[C#]
ISlideShowTransition SlideShowTransition {get;}

See Also

IBaseSlide Interface | Aspose.Slides Namespace


Timeline Property

Aspose.Slides Documentation

IBaseSlide.Timeline Property

[Visual Basic]
Property Timeline As IAnimationTimeLine
[C#]
IAnimationTimeLine Timeline {get;}

See Also

IBaseSlide Interface | Aspose.Slides Namespace


IBaseSlide Methods

The methods of the IBaseSlide interface are listed below. For a complete list of IBaseSlide interface members, see the IBaseSlide Members topic.

Public Instance Methods

FindShapeByAltText

See Also

IBaseSlide Interface | Aspose.Slides Namespace


IBaseSlide.FindShapeByAltText Method

[Visual Basic]
Function FindShapeByAltText( _
ByVal altText As String _
) As IShape
[C#]
IShape FindShapeByAltText(
string altText
);

See Also

IBaseSlide Interface | Aspose.Slides Namespace


IBulletFormat Interface

For a list of all members of this type, see IBulletFormat Members.

[Visual Basic]
Public Interface IBulletFormat
[C#]
public interface IBulletFormat

Types that implement IBulletFormat

Type | Description
BulletFormat |

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBulletFormat Members | Aspose.Slides Namespace


IBulletFormat Members

IBulletFormat overview

Public Instance Properties

Char
Color
Font
Height
IsBulletHardColor
IsBulletHardFont
NumberedBulletStartWith
NumberedBulletStyle
Type

See Also

IBulletFormat Interface | Aspose.Slides Namespace


IBulletFormat Properties

The properties of the IBulletFormat interface are listed below. For a complete list of IBulletFormat interface members, see the IBulletFormat Members topic.

Public Instance Properties

Char
Color
Font
Height
IsBulletHardColor
IsBulletHardFont
NumberedBulletStartWith
NumberedBulletStyle
Type

See Also

IBulletFormat Interface | Aspose.Slides Namespace


Char Property

Aspose.Slides Documentation

IBulletFormat.Char Property

[Visual Basic]
Property Char As Char
[C#]
char Char {get; set;}

See Also

IBulletFormat Interface | Aspose.Slides Namespace


Color Property

Aspose.Slides Documentation

IBulletFormat.Color Property

[Visual Basic]
Property Color As IColorFormat
[C#]
IColorFormat Color {get;}

See Also

IBulletFormat Interface | Aspose.Slides Namespace


Font Property

Aspose.Slides Documentation

IBulletFormat.Font Property

[Visual Basic]
Property Font As IFontData
[C#]
IFontData Font {get; set;}

See Also

IBulletFormat Interface | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

IBulletFormat.Height Property

[Visual Basic]
Property Height As Single
[C#]
float Height {get; set;}

See Also

IBulletFormat Interface | Aspose.Slides Namespace


IsBulletHardColor Property

Aspose.Slides Documentation

IBulletFormat.IsBulletHardColor Property

[Visual Basic]
Property IsBulletHardColor As NullableBool
[C#]
NullableBool IsBulletHardColor {get; set;}

See Also

IBulletFormat Interface | Aspose.Slides Namespace


IsBulletHardFont Property

Aspose.Slides Documentation

IBulletFormat.IsBulletHardFont Property

[Visual Basic]
Property IsBulletHardFont As NullableBool
[C#]
NullableBool IsBulletHardFont {get; set;}

See Also

IBulletFormat Interface | Aspose.Slides Namespace


NumberedBulletStartWith Property

Aspose.Slides Documentation

IBulletFormat.NumberedBulletStartWith Property

[Visual Basic]
Property NumberedBulletStartWith As Short
[C#]
short NumberedBulletStartWith {get; set;}

See Also

IBulletFormat Interface | Aspose.Slides Namespace


NumberedBulletStyle Property

Aspose.Slides Documentation

IBulletFormat.NumberedBulletStyle Property

[Visual Basic]
Property NumberedBulletStyle As NumberedBulletStyle
[C#]
NumberedBulletStyle NumberedBulletStyle {get; set;}

See Also

IBulletFormat Interface | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

IBulletFormat.Type Property

[Visual Basic]
Property Type As BulletType
[C#]
BulletType Type {get; set;}

See Also

IBulletFormat Interface | Aspose.Slides Namespace


IBulletFormatEffectiveData Interface

For a list of all members of this type, see IBulletFormatEffectiveData Members.

[Visual Basic]
Public Interface IBulletFormatEffectiveData
[C#]
public interface IBulletFormatEffectiveData

Types that implement IBulletFormatEffectiveData

Type | Description
BulletFormatEffectiveData | Immutable object which contains the paragraph's formatting properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBulletFormatEffectiveData Members | Aspose.Slides Namespace


IBulletFormatEffectiveData Members

IBulletFormatEffectiveData overview

Public Instance Properties

Char
Color
Font
Height
NumberedBulletStartWith
NumberedBulletStyle
Type

See Also

IBulletFormatEffectiveData Interface | Aspose.Slides Namespace


IBulletFormatEffectiveData Properties

The properties of the IBulletFormatEffectiveData interface are listed below. For a complete list of IBulletFormatEffectiveData interface members, see the IBulletFormatEffectiveData Members topic.

Public Instance Properties

Char
Color
Font
Height
NumberedBulletStartWith
NumberedBulletStyle
Type

See Also

IBulletFormatEffectiveData Interface | Aspose.Slides Namespace


Char Property

Aspose.Slides Documentation

IBulletFormatEffectiveData.Char Property

[Visual Basic]
Property Char As Char
[C#]
char Char {get;}

See Also

IBulletFormatEffectiveData Interface | Aspose.Slides Namespace


Color Property

Aspose.Slides Documentation

IBulletFormatEffectiveData.Color Property

[Visual Basic]
Property Color As Color
[C#]
Color Color {get;}

See Also

IBulletFormatEffectiveData Interface | Aspose.Slides Namespace


Font Property

Aspose.Slides Documentation

IBulletFormatEffectiveData.Font Property

[Visual Basic]
Property Font As IFontData
[C#]
IFontData Font {get;}

See Also

IBulletFormatEffectiveData Interface | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

IBulletFormatEffectiveData.Height Property

[Visual Basic]
Property Height As Single
[C#]
float Height {get;}

See Also

IBulletFormatEffectiveData Interface | Aspose.Slides Namespace


NumberedBulletStartWith Property

Aspose.Slides Documentation

IBulletFormatEffectiveData.NumberedBulletStartWith Property

[Visual Basic]
Property NumberedBulletStartWith As Short
[C#]
short NumberedBulletStartWith {get;}

See Also

IBulletFormatEffectiveData Interface | Aspose.Slides Namespace


NumberedBulletStyle Property

Aspose.Slides Documentation

IBulletFormatEffectiveData.NumberedBulletStyle Property

[Visual Basic]
Property NumberedBulletStyle As NumberedBulletStyle
[C#]
NumberedBulletStyle NumberedBulletStyle {get;}

See Also

IBulletFormatEffectiveData Interface | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

IBulletFormatEffectiveData.Type Property

[Visual Basic]
Property Type As BulletType
[C#]
BulletType Type {get;}

See Also

IBulletFormatEffectiveData Interface | Aspose.Slides Namespace


ICamera Interface

For a list of all members of this type, see ICamera Members.

[Visual Basic]
Public Interface ICamera
[C#]
public interface ICamera

Types that implement ICamera

Type | Description
Camera | Represents Camera.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ICamera Members | Aspose.Slides Namespace


ICamera Members

ICamera overview

Public Instance Properties

CameraType
FieldOfViewAngle
Zoom

Public Instance Methods

GetRotation
SetRotation

See Also

ICamera Interface | Aspose.Slides Namespace


ICamera Properties

The properties of the ICamera interface are listed below. For a complete list of ICamera interface members, see the ICamera Members topic.

Public Instance Properties

CameraType
FieldOfViewAngle
Zoom

See Also

ICamera Interface | Aspose.Slides Namespace


CameraType Property

Aspose.Slides Documentation

ICamera.CameraType Property

[Visual Basic]
Property CameraType As CameraPresetType
[C#]
CameraPresetType CameraType {get; set;}

See Also

ICamera Interface | Aspose.Slides Namespace


FieldOfViewAngle Property

Aspose.Slides Documentation

ICamera.FieldOfViewAngle Property

[Visual Basic]
Property FieldOfViewAngle As Single
[C#]
float FieldOfViewAngle {get; set;}

See Also

ICamera Interface | Aspose.Slides Namespace


Zoom Property

Aspose.Slides Documentation

ICamera.Zoom Property

[Visual Basic]
Property Zoom As Single
[C#]
float Zoom {get; set;}

See Also

ICamera Interface | Aspose.Slides Namespace


ICamera Methods

The methods of the ICamera interface are listed below. For a complete list of ICamera interface members, see the ICamera Members topic.

Public Instance Methods

GetRotation
SetRotation

See Also

ICamera Interface | Aspose.Slides Namespace


ICamera.GetRotation Method

[Visual Basic]
Function GetRotation() As Single()
[C#]
float[] GetRotation();

See Also

ICamera Interface | Aspose.Slides Namespace


ICamera.SetRotation Method

[Visual Basic]
Sub SetRotation( _
ByVal latitude As Single, _
ByVal longitude As Single, _
ByVal revolution As Single _
)
[C#]
void SetRotation(
float latitude,
float longitude,
float revolution
);

See Also

ICamera Interface | Aspose.Slides Namespace


ICameraEffectiveData Interface

[Visual Basic]
Public Interface ICameraEffectiveData
[C#]
public interface ICameraEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


ICell Interface

For a list of all members of this type, see ICell Members.

[Visual Basic]
Public Interface ICell
Implements ISlideComponent, IPresentationComponent
[C#]
public interface ICell : ISlideComponent, IPresentationComponent

Types that implement ICell

Type | Description
Cell | Represents a cell of a table.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ICell Members | Aspose.Slides Namespace


ICell Members

ICell overview

Public Instance Properties

AnchorCenter
AsISlideComponent
BorderBottom
BorderDiagonalDown
BorderDiagonalUp
BorderLeft
BorderRight
BorderTop
ColSpan
FillFormat
FirstColumn
FirstColumnIndex
FirstRow
FirstRowIndex
Height
MarginBottom
MarginLeft
MarginRight
MarginTop
MinimalHeight
OffsetX
OffsetY
RowSpan
Table
TextAnchorType
TextFrame
TextVerticalType
Width

Public Instance Methods

SplitByColSpan
SplitByHeight
SplitByRowSpan
SplitByWidth

See Also

ICell Interface | Aspose.Slides Namespace


ICell Properties

The properties of the ICell interface are listed below. For a complete list of ICell interface members, see the ICell Members topic.

Public Instance Properties

AnchorCenter
AsISlideComponent
BorderBottom
BorderDiagonalDown
BorderDiagonalUp
BorderLeft
BorderRight
BorderTop
ColSpan
FillFormat
FirstColumn
FirstColumnIndex
FirstRow
FirstRowIndex
Height
MarginBottom
MarginLeft
MarginRight
MarginTop
MinimalHeight
OffsetX
OffsetY
RowSpan
Table
TextAnchorType
TextFrame
TextVerticalType
Width

See Also

ICell Interface | Aspose.Slides Namespace


AnchorCenter Property

Aspose.Slides Documentation

ICell.AnchorCenter Property

[Visual Basic]
Property AnchorCenter As Boolean
[C#]
bool AnchorCenter {get; set;}

See Also

ICell Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

ICell.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

ICell Interface | Aspose.Slides Namespace


BorderBottom Property

Aspose.Slides Documentation

ICell.BorderBottom Property

[Visual Basic]
Property BorderBottom As ILineFormat
[C#]
ILineFormat BorderBottom {get;}

See Also

ICell Interface | Aspose.Slides Namespace


BorderDiagonalDown Property

Aspose.Slides Documentation

ICell.BorderDiagonalDown Property

[Visual Basic]
Property BorderDiagonalDown As ILineFormat
[C#]
ILineFormat BorderDiagonalDown {get;}

See Also

ICell Interface | Aspose.Slides Namespace


BorderDiagonalUp Property

Aspose.Slides Documentation

ICell.BorderDiagonalUp Property

[Visual Basic]
Property BorderDiagonalUp As ILineFormat
[C#]
ILineFormat BorderDiagonalUp {get;}

See Also

ICell Interface | Aspose.Slides Namespace


BorderLeft Property

Aspose.Slides Documentation

ICell.BorderLeft Property

[Visual Basic]
Property BorderLeft As ILineFormat
[C#]
ILineFormat BorderLeft {get;}

See Also

ICell Interface | Aspose.Slides Namespace


BorderRight Property

Aspose.Slides Documentation

ICell.BorderRight Property

[Visual Basic]
Property BorderRight As ILineFormat
[C#]
ILineFormat BorderRight {get;}

See Also

ICell Interface | Aspose.Slides Namespace


BorderTop Property

Aspose.Slides Documentation

ICell.BorderTop Property

[Visual Basic]
Property BorderTop As ILineFormat
[C#]
ILineFormat BorderTop {get;}

See Also

ICell Interface | Aspose.Slides Namespace


ColSpan Property

Aspose.Slides Documentation

ICell.ColSpan Property

[Visual Basic]
Property ColSpan As Integer
[C#]
int ColSpan {get;}

See Also

ICell Interface | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

ICell.FillFormat Property

[Visual Basic]
Property FillFormat As IFillFormat
[C#]
IFillFormat FillFormat {get;}

See Also

ICell Interface | Aspose.Slides Namespace


FirstColumn Property

Aspose.Slides Documentation

ICell.FirstColumn Property

[Visual Basic]
Property FirstColumn As IColumn
[C#]
IColumn FirstColumn {get;}

See Also

ICell Interface | Aspose.Slides Namespace


FirstColumnIndex Property

Aspose.Slides Documentation

ICell.FirstColumnIndex Property

[Visual Basic]
Property FirstColumnIndex As Integer
[C#]
int FirstColumnIndex {get;}

See Also

ICell Interface | Aspose.Slides Namespace


FirstRow Property

Aspose.Slides Documentation

ICell.FirstRow Property

[Visual Basic]
Property FirstRow As IRow
[C#]
IRow FirstRow {get;}

See Also

ICell Interface | Aspose.Slides Namespace


FirstRowIndex Property

Aspose.Slides Documentation

ICell.FirstRowIndex Property

[Visual Basic]
Property FirstRowIndex As Integer
[C#]
int FirstRowIndex {get;}

See Also

ICell Interface | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

ICell.Height Property

[Visual Basic]
Property Height As Double
[C#]
double Height {get;}

See Also

ICell Interface | Aspose.Slides Namespace


MarginBottom Property

Aspose.Slides Documentation

ICell.MarginBottom Property

[Visual Basic]
Property MarginBottom As Double
[C#]
double MarginBottom {get; set;}

See Also

ICell Interface | Aspose.Slides Namespace


MarginLeft Property

Aspose.Slides Documentation

ICell.MarginLeft Property

[Visual Basic]
Property MarginLeft As Double
[C#]
double MarginLeft {get; set;}

See Also

ICell Interface | Aspose.Slides Namespace


MarginRight Property

Aspose.Slides Documentation

ICell.MarginRight Property

[Visual Basic]
Property MarginRight As Double
[C#]
double MarginRight {get; set;}

See Also

ICell Interface | Aspose.Slides Namespace


MarginTop Property

Aspose.Slides Documentation

ICell.MarginTop Property

[Visual Basic]
Property MarginTop As Double
[C#]
double MarginTop {get; set;}

See Also

ICell Interface | Aspose.Slides Namespace


MinimalHeight Property

Aspose.Slides Documentation

ICell.MinimalHeight Property

[Visual Basic]
Property MinimalHeight As Double
[C#]
double MinimalHeight {get;}

See Also

ICell Interface | Aspose.Slides Namespace


OffsetX Property

Aspose.Slides Documentation

ICell.OffsetX Property

[Visual Basic]
Property OffsetX As Double
[C#]
double OffsetX {get;}

See Also

ICell Interface | Aspose.Slides Namespace


OffsetY Property

Aspose.Slides Documentation

ICell.OffsetY Property

[Visual Basic]
Property OffsetY As Double
[C#]
double OffsetY {get;}

See Also

ICell Interface | Aspose.Slides Namespace


RowSpan Property

Aspose.Slides Documentation

ICell.RowSpan Property

[Visual Basic]
Property RowSpan As Integer
[C#]
int RowSpan {get;}

See Also

ICell Interface | Aspose.Slides Namespace


Table Property

Aspose.Slides Documentation

ICell.Table Property

[Visual Basic]
Property Table As ITable
[C#]
ITable Table {get;}

See Also

ICell Interface | Aspose.Slides Namespace


TextAnchorType Property

Aspose.Slides Documentation

ICell.TextAnchorType Property

[Visual Basic]
Property TextAnchorType As TextAnchorType
[C#]
TextAnchorType TextAnchorType {get; set;}

See Also

ICell Interface | Aspose.Slides Namespace


TextFrame Property

Aspose.Slides Documentation

ICell.TextFrame Property

[Visual Basic]
Property TextFrame As ITextFrame
[C#]
ITextFrame TextFrame {get;}

See Also

ICell Interface | Aspose.Slides Namespace


TextVerticalType Property

Aspose.Slides Documentation

ICell.TextVerticalType Property

[Visual Basic]
Property TextVerticalType As TextVerticalType
[C#]
TextVerticalType TextVerticalType {get; set;}

See Also

ICell Interface | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

ICell.Width Property

[Visual Basic]
Property Width As Double
[C#]
double Width {get;}

See Also

ICell Interface | Aspose.Slides Namespace


ICell Methods

The methods of the ICell interface are listed below. For a complete list of ICell interface members, see the ICell Members topic.

Public Instance Methods

SplitByColSpan
SplitByHeight
SplitByRowSpan
SplitByWidth

See Also

ICell Interface | Aspose.Slides Namespace


ICell.SplitByColSpan Method

[Visual Basic]
Sub SplitByColSpan( _
ByVal index As Integer _
)
[C#]
void SplitByColSpan(
int index
);

See Also

ICell Interface | Aspose.Slides Namespace


ICell.SplitByHeight Method

[Visual Basic]
Sub SplitByHeight( _
ByVal height As Double _
)
[C#]
void SplitByHeight(
double height
);

See Also

ICell Interface | Aspose.Slides Namespace


ICell.SplitByRowSpan Method

[Visual Basic]
Sub SplitByRowSpan( _
ByVal index As Integer _
)
[C#]
void SplitByRowSpan(
int index
);

See Also

ICell Interface | Aspose.Slides Namespace


ICell.SplitByWidth Method

[Visual Basic]
Sub SplitByWidth( _
ByVal width As Double _
)
[C#]
void SplitByWidth(
double width
);

See Also

ICell Interface | Aspose.Slides Namespace


ICellCollection Interface

For a list of all members of this type, see ICellCollection Members.

Aspose.Slides.ICellCollection
Aspose.Slides.IColumn
Aspose.Slides.IRow

[Visual Basic]
Public Interface ICellCollection
Implements ISlideComponent, IPresentationComponent, ICollection, IEnumerable
[C#]
public interface ICellCollection : ISlideComponent, IPresentationComponent, ICollection, IEnumerable

Types that implement ICellCollection

Type | Description
CellCollection | Represents a collection of cells.
Column | Represents a column in a table.
Row | Represents a row in a table.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ICellCollection Members | Aspose.Slides Namespace


ICellCollection Members

ICellCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
AsISlideComponent
Item

See Also

ICellCollection Interface | Aspose.Slides Namespace


ICellCollection Properties

The properties of the ICellCollection interface are listed below. For a complete list of ICellCollection interface members, see the ICellCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
AsISlideComponent
Item

See Also

ICellCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

ICellCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

ICellCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ICellCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ICellCollection Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

ICellCollection.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

ICellCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ICellCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As ICell
[C#]
ICell this[
int index
] {get;}

See Also

ICellCollection Interface | Aspose.Slides Namespace


IColorFormat Interface

For a list of all members of this type, see IColorFormat Members.

[Visual Basic]
Public Interface IColorFormat
Implements IFillParamSource
[C#]
public interface IColorFormat : IFillParamSource

Types that implement IColorFormat

Type | Description
ColorFormat | Represents a color used in a presentation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColorFormat Members | Aspose.Slides Namespace


IColorFormat Members

IColorFormat overview

Public Instance Properties

AsIFillParamSource
B
Color
ColorTransform
ColorType
FloatB
FloatG
FloatR
G
Hue
Luminance
PresetColor
R
Saturation
SchemeColor
SystemColor

Public Instance Methods

CopyFrom
ToString

See Also

IColorFormat Interface | Aspose.Slides Namespace


IColorFormat Properties

The properties of the IColorFormat interface are listed below. For a complete list of IColorFormat interface members, see the IColorFormat Members topic.

Public Instance Properties

AsIFillParamSource
B
Color
ColorTransform
ColorType
FloatB
FloatG
FloatR
G
Hue
Luminance
PresetColor
R
Saturation
SchemeColor
SystemColor

See Also

IColorFormat Interface | Aspose.Slides Namespace


AsIFillParamSource Property

Aspose.Slides Documentation

IColorFormat.AsIFillParamSource Property

[Visual Basic]
Property AsIFillParamSource As IFillParamSource
[C#]
IFillParamSource AsIFillParamSource {get;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


B Property

Aspose.Slides Documentation

IColorFormat.B Property

[Visual Basic]
Property B As Byte
[C#]
byte B {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


Color Property

Aspose.Slides Documentation

IColorFormat.Color Property

[Visual Basic]
Property Color As Color
[C#]
Color Color {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


ColorTransform Property

Aspose.Slides Documentation

IColorFormat.ColorTransform Property

[Visual Basic]
Property ColorTransform As IColorOperationCollection
[C#]
IColorOperationCollection ColorTransform {get;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


ColorType Property

Aspose.Slides Documentation

IColorFormat.ColorType Property

[Visual Basic]
Property ColorType As ColorType
[C#]
ColorType ColorType {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


FloatB Property

Aspose.Slides Documentation

IColorFormat.FloatB Property

[Visual Basic]
Property FloatB As Single
[C#]
float FloatB {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


FloatG Property

Aspose.Slides Documentation

IColorFormat.FloatG Property

[Visual Basic]
Property FloatG As Single
[C#]
float FloatG {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


FloatR Property

Aspose.Slides Documentation

IColorFormat.FloatR Property

[Visual Basic]
Property FloatR As Single
[C#]
float FloatR {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


G Property

Aspose.Slides Documentation

IColorFormat.G Property

[Visual Basic]
Property G As Byte
[C#]
byte G {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


Hue Property

Aspose.Slides Documentation

IColorFormat.Hue Property

[Visual Basic]
Property Hue As Single
[C#]
float Hue {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


Luminance Property

Aspose.Slides Documentation

IColorFormat.Luminance Property

[Visual Basic]
Property Luminance As Single
[C#]
float Luminance {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


PresetColor Property

Aspose.Slides Documentation

IColorFormat.PresetColor Property

[Visual Basic]
Property PresetColor As PresetColor
[C#]
PresetColor PresetColor {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


R Property

Aspose.Slides Documentation

IColorFormat.R Property

[Visual Basic]
Property R As Byte
[C#]
byte R {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


Saturation Property

Aspose.Slides Documentation

IColorFormat.Saturation Property

[Visual Basic]
Property Saturation As Single
[C#]
float Saturation {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


SchemeColor Property

Aspose.Slides Documentation

IColorFormat.SchemeColor Property

[Visual Basic]
Property SchemeColor As SchemeColor
[C#]
SchemeColor SchemeColor {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


SystemColor Property

Aspose.Slides Documentation

IColorFormat.SystemColor Property

[Visual Basic]
Property SystemColor As SystemColor
[C#]
SystemColor SystemColor {get; set;}

See Also

IColorFormat Interface | Aspose.Slides Namespace


IColorFormat Methods

The methods of the IColorFormat interface are listed below. For a complete list of IColorFormat interface members, see the IColorFormat Members topic.

Public Instance Methods

CopyFrom
ToString

See Also

IColorFormat Interface | Aspose.Slides Namespace


IColorFormat.CopyFrom Method

[Visual Basic]
Sub CopyFrom( _
ByVal color As IColorFormat _
)
[C#]
void CopyFrom(
IColorFormat color
);

See Also

IColorFormat Interface | Aspose.Slides Namespace


IColorFormat.ToString Method

[Visual Basic]
Function ToString( _
ByVal format As ColorStringFormat _
) As String
[C#]
string ToString(
ColorStringFormat format
);

See Also

IColorFormat Interface | Aspose.Slides Namespace


IColorOperation Interface

For a list of all members of this type, see IColorOperation Members.

[Visual Basic]
Public Interface IColorOperation
[C#]
public interface IColorOperation

Types that implement IColorOperation

Type | Description
ColorOperation | Represents different color operations used for color transformations.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColorOperation Members | Aspose.Slides Namespace


IColorOperation Members

IColorOperation overview

Public Instance Properties

OperationType
Parameter

See Also

IColorOperation Interface | Aspose.Slides Namespace


IColorOperation Properties

The properties of the IColorOperation interface are listed below. For a complete list of IColorOperation interface members, see the IColorOperation Members topic.

Public Instance Properties

OperationType
Parameter

See Also

IColorOperation Interface | Aspose.Slides Namespace


OperationType Property

Aspose.Slides Documentation

IColorOperation.OperationType Property

[Visual Basic]
Property OperationType As ColorTransformOperation
[C#]
ColorTransformOperation OperationType {get;}

See Also

IColorOperation Interface | Aspose.Slides Namespace


Parameter Property

Aspose.Slides Documentation

IColorOperation.Parameter Property

[Visual Basic]
Property Parameter As Single
[C#]
float Parameter {get;}

See Also

IColorOperation Interface | Aspose.Slides Namespace


IColorOperationCollection Interface

For a list of all members of this type, see IColorOperationCollection Members.

[Visual Basic]
Public Interface IColorOperationCollection
Implements ICollection, IEnumerable, ICloneable, IEnumerable`1([Aspose.Slides.IColorOperation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IColorOperationCollection : ICollection, IEnumerable, ICloneable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IColorOperationCollection

Type | Description
ColorOperationCollection | Represents a collection of color transform operations.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColorOperationCollection Members | Aspose.Slides Namespace


IColorOperationCollection Members

IColorOperationCollection overview

Public Instance Properties

AsICloneable
AsICollection
AsIEnumerable
Item

Public Instance Methods

Add | Overloaded.
Clear |
Insert | Overloaded.
RemoveAt |

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace


IColorOperationCollection Properties

The properties of the IColorOperationCollection interface are listed below. For a complete list of IColorOperationCollection interface members, see the IColorOperationCollection Members topic.

Public Instance Properties

AsICloneable
AsICollection
AsIEnumerable
Item

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace


AsICloneable Property

Aspose.Slides Documentation

IColorOperationCollection.AsICloneable Property

[Visual Basic]
Property AsICloneable As ICloneable
[C#]
ICloneable AsICloneable {get;}

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

IColorOperationCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IColorOperationCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IColorOperationCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IColorOperation
[C#]
IColorOperation this[
int index
] {get; set;}

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace


IColorOperationCollection Methods

The methods of the IColorOperationCollection interface are listed below. For a complete list of IColorOperationCollection interface members, see the IColorOperationCollection Members topic.

Public Instance Methods

Add | Overloaded.
Clear |
Insert | Overloaded.
RemoveAt |

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace


Add Method

Aspose.Slides Documentation

IColorOperationCollection.Add Method

Overload List

IColorOperation Add(ColorTransformOperation);

IColorOperation Add(ColorTransformOperation,float);

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace


IColorOperationCollection.Add Method (ColorTransformOperation)

[Visual Basic]
Function Add( _
ByVal operation As ColorTransformOperation _
) As IColorOperation
[C#]
IColorOperation Add(
ColorTransformOperation operation
);

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace | IColorOperationCollection.Add Overload List


IColorOperationCollection.Add Method (ColorTransformOperation, Single)

[Visual Basic]
Function Add( _
ByVal operation As ColorTransformOperation, _
ByVal parameter As Single _
) As IColorOperation
[C#]
IColorOperation Add(
ColorTransformOperation operation,
float parameter
);

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace | IColorOperationCollection.Add Overload List


IColorOperationCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace


Insert Method

Aspose.Slides Documentation

IColorOperationCollection.Insert Method

Overload List

IColorOperation Insert(int,ColorTransformOperation);

IColorOperation Insert(int,ColorTransformOperation,float);

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace


IColorOperationCollection.Insert Method (Int32, ColorTransformOperation)

[Visual Basic]
Function Insert( _
ByVal position As Integer, _
ByVal operation As ColorTransformOperation _
) As IColorOperation
[C#]
IColorOperation Insert(
int position,
ColorTransformOperation operation
);

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace | IColorOperationCollection.Insert Overload List


IColorOperationCollection.Insert Method (Int32, ColorTransformOperation, Single)

[Visual Basic]
Function Insert( _
ByVal position As Integer, _
ByVal operation As ColorTransformOperation, _
ByVal parameter As Single _
) As IColorOperation
[C#]
IColorOperation Insert(
int position,
ColorTransformOperation operation,
float parameter
);

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace | IColorOperationCollection.Insert Overload List


IColorOperationCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IColorOperationCollection Interface | Aspose.Slides Namespace


IColumn Interface

For a list of all members of this type, see IColumn Members.

[Visual Basic]
Public Interface IColumn
Implements ICellCollection, ISlideComponent, IPresentationComponent, ICollection, IEnumerable
[C#]
public interface IColumn : ICellCollection, ISlideComponent, IPresentationComponent, ICollection, IEnumerable

Types that implement IColumn

Type | Description
Column | Represents a column in a table.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColumn Members | Aspose.Slides Namespace


IColumn Members

IColumn overview

Public Instance Properties

AsICellCollection
Width

See Also

IColumn Interface | Aspose.Slides Namespace


IColumn Properties

The properties of the IColumn interface are listed below. For a complete list of IColumn interface members, see the IColumn Members topic.

Public Instance Properties

AsICellCollection
Width

See Also

IColumn Interface | Aspose.Slides Namespace


AsICellCollection Property

Aspose.Slides Documentation

IColumn.AsICellCollection Property

[Visual Basic]
Property AsICellCollection As ICellCollection
[C#]
ICellCollection AsICellCollection {get;}

See Also

IColumn Interface | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

IColumn.Width Property

[Visual Basic]
Property Width As Double
[C#]
double Width {get; set;}

See Also

IColumn Interface | Aspose.Slides Namespace


IColumnCollection Interface

For a list of all members of this type, see IColumnCollection Members.

[Visual Basic]
Public Interface IColumnCollection
Implements ICollection, IEnumerable
[C#]
public interface IColumnCollection : ICollection, IEnumerable

Types that implement IColumnCollection

Type | Description
ColumnCollection | Represents collection of columns in a table.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColumnCollection Members | Aspose.Slides Namespace


IColumnCollection Members

IColumnCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

AddClone
InsertClone
RemoveAt

See Also

IColumnCollection Interface | Aspose.Slides Namespace


IColumnCollection Properties

The properties of the IColumnCollection interface are listed below. For a complete list of IColumnCollection interface members, see the IColumnCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IColumnCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

IColumnCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IColumnCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IColumnCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IColumnCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IColumnCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IColumn
[C#]
IColumn this[
int index
] {get;}

See Also

IColumnCollection Interface | Aspose.Slides Namespace


IColumnCollection Methods

The methods of the IColumnCollection interface are listed below. For a complete list of IColumnCollection interface members, see the IColumnCollection Members topic.

Public Instance Methods

AddClone
InsertClone
RemoveAt

See Also

IColumnCollection Interface | Aspose.Slides Namespace


IColumnCollection.AddClone Method

[Visual Basic]
Function AddClone( _
ByVal templ As IColumn, _
ByVal withAttachedColumns As Boolean _
) As IColumn()
[C#]
IColumn[] AddClone(
IColumn templ,
bool withAttachedColumns
);

See Also

IColumnCollection Interface | Aspose.Slides Namespace


IColumnCollection.InsertClone Method

[Visual Basic]
Function InsertClone( _
ByVal index As Integer, _
ByVal templ As IColumn, _
ByVal withAttachedColumns As Boolean _
) As IColumn()
[C#]
IColumn[] InsertClone(
int index,
IColumn templ,
bool withAttachedColumns
);

See Also

IColumnCollection Interface | Aspose.Slides Namespace


IColumnCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal firstColumnIndex As Integer, _
ByVal withAttachedRows As Boolean _
)
[C#]
void RemoveAt(
int firstColumnIndex,
bool withAttachedRows
);

See Also

IColumnCollection Interface | Aspose.Slides Namespace


IComment Interface

For a list of all members of this type, see IComment Members.

[Visual Basic]
Public Interface IComment
[C#]
public interface IComment

Types that implement IComment

Type | Description
Comment | Represents a comment on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IComment Members | Aspose.Slides Namespace


IComment Members

IComment overview

Public Instance Properties

Author
CreatedTime
Position
Slide
Text

See Also

IComment Interface | Aspose.Slides Namespace


IComment Properties

The properties of the IComment interface are listed below. For a complete list of IComment interface members, see the IComment Members topic.

Public Instance Properties

Author
CreatedTime
Position
Slide
Text

See Also

IComment Interface | Aspose.Slides Namespace


Author Property

Aspose.Slides Documentation

IComment.Author Property

[Visual Basic]
Property Author As ICommentAuthor
[C#]
ICommentAuthor Author {get;}

See Also

IComment Interface | Aspose.Slides Namespace


CreatedTime Property

Aspose.Slides Documentation

IComment.CreatedTime Property

[Visual Basic]
Property CreatedTime As Date
[C#]
DateTime CreatedTime {get; set;}

See Also

IComment Interface | Aspose.Slides Namespace


Position Property

Aspose.Slides Documentation

IComment.Position Property

[Visual Basic]
Property Position As PointF
[C#]
PointF Position {get; set;}

See Also

IComment Interface | Aspose.Slides Namespace


Slide Property

Aspose.Slides Documentation

IComment.Slide Property

[Visual Basic]
Property Slide As ISlide
[C#]
ISlide Slide {get;}

See Also

IComment Interface | Aspose.Slides Namespace


Text Property

Aspose.Slides Documentation

IComment.Text Property

[Visual Basic]
Property Text As String
[C#]
string Text {get; set;}

See Also

IComment Interface | Aspose.Slides Namespace


ICommentAuthor Interface

For a list of all members of this type, see ICommentAuthor Members.

[Visual Basic]
Public Interface ICommentAuthor
[C#]
public interface ICommentAuthor

Types that implement ICommentAuthor

Type | Description
CommentAuthor | Represents an author of comments.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ICommentAuthor Members | Aspose.Slides Namespace


ICommentAuthor Members

ICommentAuthor overview

Public Instance Properties

Comments
Initials
Name

See Also

ICommentAuthor Interface | Aspose.Slides Namespace


ICommentAuthor Properties

The properties of the ICommentAuthor interface are listed below. For a complete list of ICommentAuthor interface members, see the ICommentAuthor Members topic.

Public Instance Properties

Comments
Initials
Name

See Also

ICommentAuthor Interface | Aspose.Slides Namespace


Comments Property

Aspose.Slides Documentation

ICommentAuthor.Comments Property

[Visual Basic]
Property Comments As ICommentCollection
[C#]
ICommentCollection Comments {get;}

See Also

ICommentAuthor Interface | Aspose.Slides Namespace


Initials Property

Aspose.Slides Documentation

ICommentAuthor.Initials Property

[Visual Basic]
Property Initials As String
[C#]
string Initials {get; set;}

See Also

ICommentAuthor Interface | Aspose.Slides Namespace


Name Property

Aspose.Slides Documentation

ICommentAuthor.Name Property

[Visual Basic]
Property Name As String
[C#]
string Name {get; set;}

See Also

ICommentAuthor Interface | Aspose.Slides Namespace


ICommentAuthorCollection Interface

For a list of all members of this type, see ICommentAuthorCollection Members.

[Visual Basic]
Public Interface ICommentAuthorCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ICommentAuthor, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface ICommentAuthorCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement ICommentAuthorCollection

Type | Description
CommentAuthorCollection | Represents a collection of comment authors.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ICommentAuthorCollection Members | Aspose.Slides Namespace


ICommentAuthorCollection Members

ICommentAuthorCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

AddAuthor
FindByName
FindByNameAndInitials
ToArray

See Also

ICommentAuthorCollection Interface | Aspose.Slides Namespace


ICommentAuthorCollection Properties

The properties of the ICommentAuthorCollection interface are listed below. For a complete list of ICommentAuthorCollection interface members, see the ICommentAuthorCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

ICommentAuthorCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

ICommentAuthorCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

ICommentAuthorCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ICommentAuthorCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ICommentAuthorCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ICommentAuthorCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As ICommentAuthor
[C#]
ICommentAuthor this[
int index
] {get;}

See Also

ICommentAuthorCollection Interface | Aspose.Slides Namespace


ICommentAuthorCollection Methods

The methods of the ICommentAuthorCollection interface are listed below. For a complete list of ICommentAuthorCollection interface members, see the ICommentAuthorCollection Members topic.

Public Instance Methods

AddAuthor
FindByName
FindByNameAndInitials
ToArray

See Also

ICommentAuthorCollection Interface | Aspose.Slides Namespace


ICommentAuthorCollection.AddAuthor Method

[Visual Basic]
Function AddAuthor( _
ByVal name As String, _
ByVal initials As String _
) As ICommentAuthor
[C#]
ICommentAuthor AddAuthor(
string name,
string initials
);

See Also

ICommentAuthorCollection Interface | Aspose.Slides Namespace


ICommentAuthorCollection.FindByName Method

[Visual Basic]
Function FindByName( _
ByVal name As String _
) As ICommentAuthor()
[C#]
ICommentAuthor[] FindByName(
string name
);

See Also

ICommentAuthorCollection Interface | Aspose.Slides Namespace


ICommentAuthorCollection.FindByNameAndInitials Method

[Visual Basic]
Function FindByNameAndInitials( _
ByVal name As String, _
ByVal initials As String _
) As ICommentAuthor()
[C#]
ICommentAuthor[] FindByNameAndInitials(
string name,
string initials
);

See Also

ICommentAuthorCollection Interface | Aspose.Slides Namespace


ICommentAuthorCollection.ToArray Method

[Visual Basic]
Function ToArray() As ICommentAuthor()
[C#]
ICommentAuthor[] ToArray();

See Also

ICommentAuthorCollection Interface | Aspose.Slides Namespace


ICommentCollection Interface

For a list of all members of this type, see ICommentCollection Members.

[Visual Basic]
Public Interface ICommentCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IComment, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface ICommentCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement ICommentCollection

Type | Description
CommentCollection | Represents a collection of comments of one author.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ICommentCollection Members | Aspose.Slides Namespace


ICommentCollection Members

ICommentCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

AddComment |
Clear |
InsertComment |
Remove |
RemoveAt |
ToArray | Overloaded.

See Also

ICommentCollection Interface | Aspose.Slides Namespace


ICommentCollection Properties

The properties of the ICommentCollection interface are listed below. For a complete list of ICommentCollection interface members, see the ICommentCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

ICommentCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

ICommentCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

ICommentCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ICommentCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ICommentCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ICommentCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IComment
[C#]
IComment this[
int index
] {get;}

See Also

ICommentCollection Interface | Aspose.Slides Namespace


ICommentCollection Methods

The methods of the ICommentCollection interface are listed below. For a complete list of ICommentCollection interface members, see the ICommentCollection Members topic.

Public Instance Methods

AddComment |
Clear |
InsertComment |
Remove |
RemoveAt |
ToArray | Overloaded.

See Also

ICommentCollection Interface | Aspose.Slides Namespace


ICommentCollection.AddComment Method

[Visual Basic]
Function AddComment( _
ByVal text As String, _
ByVal slide As ISlide, _
ByVal position As PointF, _
ByVal creationTime As Date _
) As IComment
[C#]
IComment AddComment(
string text,
ISlide slide,
PointF position,
DateTime creationTime
);

See Also

ICommentCollection Interface | Aspose.Slides Namespace


ICommentCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

ICommentCollection Interface | Aspose.Slides Namespace


ICommentCollection.InsertComment Method

[Visual Basic]
Function InsertComment( _
ByVal index As Integer, _
ByVal text As String, _
ByVal slide As ISlide, _
ByVal position As PointF, _
ByVal creationTime As Date _
) As IComment
[C#]
IComment InsertComment(
int index,
string text,
ISlide slide,
PointF position,
DateTime creationTime
);

See Also

ICommentCollection Interface | Aspose.Slides Namespace


ICommentCollection.Remove Method

[Visual Basic]
Sub Remove( _
ByVal comment As IComment _
)
[C#]
void Remove(
IComment comment
);

See Also

ICommentCollection Interface | Aspose.Slides Namespace


ICommentCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

ICommentCollection Interface | Aspose.Slides Namespace


ToArray Method

Aspose.Slides Documentation

ICommentCollection.ToArray Method

Overload List

IComment[] ToArray();

IComment[] ToArray(int,int);

See Also

ICommentCollection Interface | Aspose.Slides Namespace


ICommentCollection.ToArray Method ()

[Visual Basic]
Function ToArray() As IComment()
[C#]
IComment[] ToArray();

See Also

ICommentCollection Interface | Aspose.Slides Namespace | ICommentCollection.ToArray Overload List


ICommentCollection.ToArray Method (Int32, Int32)

[Visual Basic]
Function ToArray( _
ByVal startIndex As Integer, _
ByVal count As Integer _
) As IComment()
[C#]
IComment[] ToArray(
int startIndex,
int count
);

See Also

ICommentCollection Interface | Aspose.Slides Namespace | ICommentCollection.ToArray Overload List


IConnector Interface

For a list of all members of this type, see IConnector Members.

[Visual Basic]
Public Interface IConnector
Implements IGeometryShape, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public interface IConnector : IGeometryShape, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer

Types that implement IConnector

Type | Description
Connector | Represents a connector.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IConnector Members | Aspose.Slides Namespace


IConnector Members

IConnector overview

Public Instance Properties

AsIGeometryShape
EndShapeConnectedTo
EndShapeConnectionSiteIndex
ShapeLock
StartShapeConnectedTo
StartShapeConnectionSiteIndex

See Also

IConnector Interface | Aspose.Slides Namespace


IConnector Properties

The properties of the IConnector interface are listed below. For a complete list of IConnector interface members, see the IConnector Members topic.

Public Instance Properties

AsIGeometryShape
EndShapeConnectedTo
EndShapeConnectionSiteIndex
ShapeLock
StartShapeConnectedTo
StartShapeConnectionSiteIndex

See Also

IConnector Interface | Aspose.Slides Namespace


AsIGeometryShape Property

Aspose.Slides Documentation

IConnector.AsIGeometryShape Property

[Visual Basic]
Property AsIGeometryShape As IGeometryShape
[C#]
IGeometryShape AsIGeometryShape {get;}

See Also

IConnector Interface | Aspose.Slides Namespace


EndShapeConnectedTo Property

Aspose.Slides Documentation

IConnector.EndShapeConnectedTo Property

[Visual Basic]
Property EndShapeConnectedTo As IShape
[C#]
IShape EndShapeConnectedTo {get; set;}

See Also

IConnector Interface | Aspose.Slides Namespace


EndShapeConnectionSiteIndex Property

Aspose.Slides Documentation

IConnector.EndShapeConnectionSiteIndex Property

[Visual Basic]
Property EndShapeConnectionSiteIndex As UInt32
[C#]
uint EndShapeConnectionSiteIndex {get; set;}

See Also

IConnector Interface | Aspose.Slides Namespace


ShapeLock Property

Aspose.Slides Documentation

IConnector.ShapeLock Property

[Visual Basic]
Property ShapeLock As IConnectorLock
[C#]
IConnectorLock ShapeLock {get;}

See Also

IConnector Interface | Aspose.Slides Namespace


StartShapeConnectedTo Property

Aspose.Slides Documentation

IConnector.StartShapeConnectedTo Property

[Visual Basic]
Property StartShapeConnectedTo As IShape
[C#]
IShape StartShapeConnectedTo {get; set;}

See Also

IConnector Interface | Aspose.Slides Namespace


StartShapeConnectionSiteIndex Property

Aspose.Slides Documentation

IConnector.StartShapeConnectionSiteIndex Property

[Visual Basic]
Property StartShapeConnectionSiteIndex As UInt32
[C#]
uint StartShapeConnectionSiteIndex {get; set;}

See Also

IConnector Interface | Aspose.Slides Namespace


IConnectorLock Interface

For a list of all members of this type, see IConnectorLock Members.

[Visual Basic]
Public Interface IConnectorLock
Implements IBaseShapeLock
[C#]
public interface IConnectorLock : IBaseShapeLock

Types that implement IConnectorLock

Type | Description
ConnectorLock | Determines which operations are disabled on the parent Connector.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IConnectorLock Members | Aspose.Slides Namespace


IConnectorLock Members

IConnectorLock overview

Public Instance Properties

AdjustHandlesLocked
ArrowheadsLocked
AsIBaseShapeLock
AspectRatioLocked
EditPointsLocked
GroupingLocked
PositionMove
RotateLocked
SelectLocked
ShapeTypeLocked
SizeLocked

See Also

IConnectorLock Interface | Aspose.Slides Namespace


IConnectorLock Properties

The properties of the IConnectorLock interface are listed below. For a complete list of IConnectorLock interface members, see the IConnectorLock Members topic.

Public Instance Properties

AdjustHandlesLocked
ArrowheadsLocked
AsIBaseShapeLock
AspectRatioLocked
EditPointsLocked
GroupingLocked
PositionMove
RotateLocked
SelectLocked
ShapeTypeLocked
SizeLocked

See Also

IConnectorLock Interface | Aspose.Slides Namespace


AdjustHandlesLocked Property

Aspose.Slides Documentation

IConnectorLock.AdjustHandlesLocked Property

[Visual Basic]
Property AdjustHandlesLocked As Boolean
[C#]
bool AdjustHandlesLocked {get; set;}

See Also

IConnectorLock Interface | Aspose.Slides Namespace


ArrowheadsLocked Property

Aspose.Slides Documentation

IConnectorLock.ArrowheadsLocked Property

[Visual Basic]
Property ArrowheadsLocked As Boolean
[C#]
bool ArrowheadsLocked {get; set;}

See Also

IConnectorLock Interface | Aspose.Slides Namespace


AsIBaseShapeLock Property

Aspose.Slides Documentation

IConnectorLock.AsIBaseShapeLock Property

[Visual Basic]
Property AsIBaseShapeLock As IBaseShapeLock
[C#]
IBaseShapeLock AsIBaseShapeLock {get;}

See Also

IConnectorLock Interface | Aspose.Slides Namespace


AspectRatioLocked Property

Aspose.Slides Documentation

IConnectorLock.AspectRatioLocked Property

[Visual Basic]
Property AspectRatioLocked As Boolean
[C#]
bool AspectRatioLocked {get; set;}

See Also

IConnectorLock Interface | Aspose.Slides Namespace


EditPointsLocked Property

Aspose.Slides Documentation

IConnectorLock.EditPointsLocked Property

[Visual Basic]
Property EditPointsLocked As Boolean
[C#]
bool EditPointsLocked {get; set;}

See Also

IConnectorLock Interface | Aspose.Slides Namespace


GroupingLocked Property

Aspose.Slides Documentation

IConnectorLock.GroupingLocked Property

[Visual Basic]
Property GroupingLocked As Boolean
[C#]
bool GroupingLocked {get; set;}

See Also

IConnectorLock Interface | Aspose.Slides Namespace


PositionMove Property

Aspose.Slides Documentation

IConnectorLock.PositionMove Property

[Visual Basic]
Property PositionMove As Boolean
[C#]
bool PositionMove {get; set;}

See Also

IConnectorLock Interface | Aspose.Slides Namespace


RotateLocked Property

Aspose.Slides Documentation

IConnectorLock.RotateLocked Property

[Visual Basic]
Property RotateLocked As Boolean
[C#]
bool RotateLocked {get; set;}

See Also

IConnectorLock Interface | Aspose.Slides Namespace


SelectLocked Property

Aspose.Slides Documentation

IConnectorLock.SelectLocked Property

[Visual Basic]
Property SelectLocked As Boolean
[C#]
bool SelectLocked {get; set;}

See Also

IConnectorLock Interface | Aspose.Slides Namespace


ShapeTypeLocked Property

Aspose.Slides Documentation

IConnectorLock.ShapeTypeLocked Property

[Visual Basic]
Property ShapeTypeLocked As Boolean
[C#]
bool ShapeTypeLocked {get; set;}

See Also

IConnectorLock Interface | Aspose.Slides Namespace


SizeLocked Property

Aspose.Slides Documentation

IConnectorLock.SizeLocked Property

[Visual Basic]
Property SizeLocked As Boolean
[C#]
bool SizeLocked {get; set;}

See Also

IConnectorLock Interface | Aspose.Slides Namespace


IControl Interface

For a list of all members of this type, see IControl Members.

[Visual Basic]
Public Interface IControl
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IControl : ISlideComponent, IPresentationComponent

Types that implement IControl

Type | Description
Control | Represents an ActiveX control.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IControl Members | Aspose.Slides Namespace


IControl Members

IControl overview

Public Instance Properties

AsISlideComponent
ClassId
Frame
Name
Properties
SubstitutePictureFormat

See Also

IControl Interface | Aspose.Slides Namespace


IControl Properties

The properties of the IControl interface are listed below. For a complete list of IControl interface members, see the IControl Members topic.

Public Instance Properties

AsISlideComponent
ClassId
Frame
Name
Properties
SubstitutePictureFormat

See Also

IControl Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IControl.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IControl Interface | Aspose.Slides Namespace


ClassId Property

Aspose.Slides Documentation

IControl.ClassId Property

[Visual Basic]
Property ClassId As Guid
[C#]
Guid ClassId {get;}

See Also

IControl Interface | Aspose.Slides Namespace


Frame Property

Aspose.Slides Documentation

IControl.Frame Property

[Visual Basic]
Property Frame As IShapeFrame
[C#]
IShapeFrame Frame {get; set;}

See Also

IControl Interface | Aspose.Slides Namespace


Name Property

Aspose.Slides Documentation

IControl.Name Property

[Visual Basic]
Property Name As String
[C#]
string Name {get; set;}

See Also

IControl Interface | Aspose.Slides Namespace


Properties Property

Aspose.Slides Documentation

IControl.Properties Property

[Visual Basic]
Property Properties As IControlPropertiesCollection
[C#]
IControlPropertiesCollection Properties {get;}

See Also

IControl Interface | Aspose.Slides Namespace


SubstitutePictureFormat Property

Aspose.Slides Documentation

IControl.SubstitutePictureFormat Property

[Visual Basic]
Property SubstitutePictureFormat As IPictureFillFormat
[C#]
IPictureFillFormat SubstitutePictureFormat {get;}

See Also

IControl Interface | Aspose.Slides Namespace


IControlCollection Interface

For a list of all members of this type, see IControlCollection Members.

[Visual Basic]
Public Interface IControlCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IControl, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IControlCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IControlCollection

Type | Description
ControlCollection | A collection of ActiveX controls.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IControlCollection Members | Aspose.Slides Namespace


IControlCollection Members

IControlCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

AddControl
Clear
Remove
RemoveAt

See Also

IControlCollection Interface | Aspose.Slides Namespace


IControlCollection Properties

The properties of the IControlCollection interface are listed below. For a complete list of IControlCollection interface members, see the IControlCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IControlCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

IControlCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IControlCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IControlCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IControlCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IControlCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IControl
[C#]
IControl this[
int index
] {get;}

See Also

IControlCollection Interface | Aspose.Slides Namespace


IControlCollection Methods

The methods of the IControlCollection interface are listed below. For a complete list of IControlCollection interface members, see the IControlCollection Members topic.

Public Instance Methods

AddControl
Clear
Remove
RemoveAt

See Also

IControlCollection Interface | Aspose.Slides Namespace


IControlCollection.AddControl Method

[Visual Basic]
Function AddControl( _
ByVal controlType As ControlType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IControl
[C#]
IControl AddControl(
ControlType controlType,
float x,
float y,
float width,
float height
);

See Also

IControlCollection Interface | Aspose.Slides Namespace


IControlCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

IControlCollection Interface | Aspose.Slides Namespace


IControlCollection.Remove Method

[Visual Basic]
Sub Remove( _
ByVal item As IControl _
)
[C#]
void Remove(
IControl item
);

See Also

IControlCollection Interface | Aspose.Slides Namespace


IControlCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IControlCollection Interface | Aspose.Slides Namespace


IControlPropertiesCollection Interface

For a list of all members of this type, see IControlPropertiesCollection Members.

[Visual Basic]
Public Interface IControlPropertiesCollection
Implements IEnumerable`1([System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089),[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)), mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)), IEnumerable
[C#]
public interface IControlPropertiesCollection : 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], IEnumerable

Types that implement IControlPropertiesCollection

Type | Description
ControlPropertiesCollection | A collection of AcitveX properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IControlPropertiesCollection Members | Aspose.Slides Namespace


IControlPropertiesCollection Members

IControlPropertiesCollection overview

Public Instance Properties

AsIEnumerable
Count
Item
NamesOfProperties

Public Instance Methods

Add
Clear
Remove

See Also

IControlPropertiesCollection Interface | Aspose.Slides Namespace


IControlPropertiesCollection Properties

The properties of the IControlPropertiesCollection interface are listed below. For a complete list of IControlPropertiesCollection interface members, see the IControlPropertiesCollection Members topic.

Public Instance Properties

AsIEnumerable
Count
Item
NamesOfProperties

See Also

IControlPropertiesCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IControlPropertiesCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IControlPropertiesCollection Interface | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

IControlPropertiesCollection.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

IControlPropertiesCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IControlPropertiesCollection.Item Property

[Visual Basic]
Property Item( _
ByVal name As String _
) As String
[C#]
string this[
string name
] {get; set;}

See Also

IControlPropertiesCollection Interface | Aspose.Slides Namespace


NamesOfProperties Property

Aspose.Slides Documentation

IControlPropertiesCollection.NamesOfProperties Property

[Visual Basic]
Property NamesOfProperties As ICollection
[C#]
ICollection NamesOfProperties {get;}

See Also

IControlPropertiesCollection Interface | Aspose.Slides Namespace


IControlPropertiesCollection Methods

The methods of the IControlPropertiesCollection interface are listed below. For a complete list of IControlPropertiesCollection interface members, see the IControlPropertiesCollection Members topic.

Public Instance Methods

Add
Clear
Remove

See Also

IControlPropertiesCollection Interface | Aspose.Slides Namespace


IControlPropertiesCollection.Add Method

[Visual Basic]
Sub Add( _
ByVal name As String, _
ByVal value As String _
)
[C#]
void Add(
string name,
string value
);

See Also

IControlPropertiesCollection Interface | Aspose.Slides Namespace


IControlPropertiesCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

IControlPropertiesCollection Interface | Aspose.Slides Namespace


IControlPropertiesCollection.Remove Method

[Visual Basic]
Sub Remove( _
ByVal name As String _
)
[C#]
void Remove(
string name
);

See Also

IControlPropertiesCollection Interface | Aspose.Slides Namespace


ICustomData Interface

For a list of all members of this type, see ICustomData Members.

[Visual Basic]
Public Interface ICustomData
[C#]
public interface ICustomData

Types that implement ICustomData

Type | Description
CustomData |

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ICustomData Members | Aspose.Slides Namespace


ICustomData Members

ICustomData overview

Public Instance Properties

Tags

See Also

ICustomData Interface | Aspose.Slides Namespace


ICustomData Properties

The properties of the ICustomData interface are listed below. For a complete list of ICustomData interface members, see the ICustomData Members topic.

Public Instance Properties

Tags

See Also

ICustomData Interface | Aspose.Slides Namespace


Tags Property

Aspose.Slides Documentation

ICustomData.Tags Property

[Visual Basic]
Property Tags As ITagCollection
[C#]
ITagCollection Tags {get;}

See Also

ICustomData Interface | Aspose.Slides Namespace


IDocumentProperties Interface

For a list of all members of this type, see IDocumentProperties Members.

[Visual Basic]
Public Interface IDocumentProperties
[C#]
public interface IDocumentProperties

Types that implement IDocumentProperties

Type | Description
DocumentProperties | Represents properties of a presentation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IDocumentProperties Members | Aspose.Slides Namespace


IDocumentProperties Members

IDocumentProperties overview

Public Instance Properties

ApplicationTemplate
Author
Category
Comments
Company
ContentStatus
ContentType
Count
CreatedTime
HyperlinkBase
Item
Keywords
LastPrinted
LastSavedBy
LastSavedTime
Manager
NameOfApplication
PresentationFormat
RevisionNumber
SharedDoc
Subject
Title
TotalEditingTime

Public Instance Methods

Contains
GetPropertyName
Remove

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


IDocumentProperties Properties

The properties of the IDocumentProperties interface are listed below. For a complete list of IDocumentProperties interface members, see the IDocumentProperties Members topic.

Public Instance Properties

ApplicationTemplate
Author
Category
Comments
Company
ContentStatus
ContentType
Count
CreatedTime
HyperlinkBase
Item
Keywords
LastPrinted
LastSavedBy
LastSavedTime
Manager
NameOfApplication
PresentationFormat
RevisionNumber
SharedDoc
Subject
Title
TotalEditingTime

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


ApplicationTemplate Property

Aspose.Slides Documentation

IDocumentProperties.ApplicationTemplate Property

[Visual Basic]
Property ApplicationTemplate As String
[C#]
string ApplicationTemplate {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


Author Property

Aspose.Slides Documentation

IDocumentProperties.Author Property

[Visual Basic]
Property Author As String
[C#]
string Author {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


Category Property

Aspose.Slides Documentation

IDocumentProperties.Category Property

[Visual Basic]
Property Category As String
[C#]
string Category {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


Comments Property

Aspose.Slides Documentation

IDocumentProperties.Comments Property

[Visual Basic]
Property Comments As String
[C#]
string Comments {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


Company Property

Aspose.Slides Documentation

IDocumentProperties.Company Property

[Visual Basic]
Property Company As String
[C#]
string Company {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


ContentStatus Property

Aspose.Slides Documentation

IDocumentProperties.ContentStatus Property

[Visual Basic]
Property ContentStatus As String
[C#]
string ContentStatus {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


ContentType Property

Aspose.Slides Documentation

IDocumentProperties.ContentType Property

[Visual Basic]
Property ContentType As String
[C#]
string ContentType {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

IDocumentProperties.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


CreatedTime Property

Aspose.Slides Documentation

IDocumentProperties.CreatedTime Property

[Visual Basic]
Property CreatedTime As Date
[C#]
DateTime CreatedTime {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


HyperlinkBase Property

Aspose.Slides Documentation

IDocumentProperties.HyperlinkBase Property

[Visual Basic]
Property HyperlinkBase As String
[C#]
string HyperlinkBase {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IDocumentProperties.Item Property

[Visual Basic]
Property Item( _
ByVal name As String _
) As Object
[C#]
object this[
string name
] {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


Keywords Property

Aspose.Slides Documentation

IDocumentProperties.Keywords Property

[Visual Basic]
Property Keywords As String
[C#]
string Keywords {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


LastPrinted Property

Aspose.Slides Documentation

IDocumentProperties.LastPrinted Property

[Visual Basic]
Property LastPrinted As Date
[C#]
DateTime LastPrinted {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


LastSavedBy Property

Aspose.Slides Documentation

IDocumentProperties.LastSavedBy Property

[Visual Basic]
Property LastSavedBy As String
[C#]
string LastSavedBy {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


LastSavedTime Property

Aspose.Slides Documentation

IDocumentProperties.LastSavedTime Property

[Visual Basic]
Property LastSavedTime As Date
[C#]
DateTime LastSavedTime {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


Manager Property

Aspose.Slides Documentation

IDocumentProperties.Manager Property

[Visual Basic]
Property Manager As String
[C#]
string Manager {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


NameOfApplication Property

Aspose.Slides Documentation

IDocumentProperties.NameOfApplication Property

[Visual Basic]
Property NameOfApplication As String
[C#]
string NameOfApplication {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


PresentationFormat Property

Aspose.Slides Documentation

IDocumentProperties.PresentationFormat Property

[Visual Basic]
Property PresentationFormat As String
[C#]
string PresentationFormat {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


RevisionNumber Property

Aspose.Slides Documentation

IDocumentProperties.RevisionNumber Property

[Visual Basic]
Property RevisionNumber As Integer
[C#]
int RevisionNumber {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


SharedDoc Property

Aspose.Slides Documentation

IDocumentProperties.SharedDoc Property

[Visual Basic]
Property SharedDoc As Boolean
[C#]
bool SharedDoc {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


Subject Property

Aspose.Slides Documentation

IDocumentProperties.Subject Property

[Visual Basic]
Property Subject As String
[C#]
string Subject {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


Title Property

Aspose.Slides Documentation

IDocumentProperties.Title Property

[Visual Basic]
Property Title As String
[C#]
string Title {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


TotalEditingTime Property

Aspose.Slides Documentation

IDocumentProperties.TotalEditingTime Property

[Visual Basic]
Property TotalEditingTime As TimeSpan
[C#]
TimeSpan TotalEditingTime {get; set;}

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


IDocumentProperties Methods

The methods of the IDocumentProperties interface are listed below. For a complete list of IDocumentProperties interface members, see the IDocumentProperties Members topic.

Public Instance Methods

Contains
GetPropertyName
Remove

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


IDocumentProperties.Contains Method

[Visual Basic]
Function Contains( _
ByVal name As String _
) As Boolean
[C#]
bool Contains(
string name
);

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


IDocumentProperties.GetPropertyName Method

[Visual Basic]
Function GetPropertyName( _
ByVal index As Integer _
) As String
[C#]
string GetPropertyName(
int index
);

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


IDocumentProperties.Remove Method

[Visual Basic]
Function Remove( _
ByVal name As String _
) As Boolean
[C#]
bool Remove(
string name
);

See Also

IDocumentProperties Interface | Aspose.Slides Namespace


IEffectFormat Interface

For a list of all members of this type, see IEffectFormat Members.

[Visual Basic]
Public Interface IEffectFormat
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IEffectFormat : ISlideComponent, IPresentationComponent

Types that implement IEffectFormat

Type | Description
EffectFormat | Represents effect properties of shape.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IEffectFormat Members | Aspose.Slides Namespace


IEffectFormat Members

IEffectFormat overview

Public Instance Properties

AsISlideComponent
BlurEffect
FillOverlayEffect
GlowEffect
InnerShadowEffect
IsNoEffects
OuterShadowEffect
PresetShadowEffect
ReflectionEffect
SoftEdgeEffect

Public Instance Methods

DisableBlurEffect
DisableFillOverlayEffect
DisableGlowEffect
DisableInnerShadowEffect
DisableOuterShadowEffect
DisablePresetShadowEffect
DisableReflectionEffect
DisableSoftEdgeEffect
EnableFillOverlayEffect
EnableGlowEffect
EnableInnerShadowEffect
EnableOuterShadowEffect
EnablePresetShadowEffect
EnableReflectionEffect
EnableSoftEdgeEffect
SetBlurEffect

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat Properties

The properties of the IEffectFormat interface are listed below. For a complete list of IEffectFormat interface members, see the IEffectFormat Members topic.

Public Instance Properties

AsISlideComponent
BlurEffect
FillOverlayEffect
GlowEffect
InnerShadowEffect
IsNoEffects
OuterShadowEffect
PresetShadowEffect
ReflectionEffect
SoftEdgeEffect

See Also

IEffectFormat Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IEffectFormat.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IEffectFormat Interface | Aspose.Slides Namespace


BlurEffect Property

Aspose.Slides Documentation

IEffectFormat.BlurEffect Property

[Visual Basic]
Property BlurEffect As IBlur
[C#]
IBlur BlurEffect {get; set;}

See Also

IEffectFormat Interface | Aspose.Slides Namespace


FillOverlayEffect Property

Aspose.Slides Documentation

IEffectFormat.FillOverlayEffect Property

[Visual Basic]
Property FillOverlayEffect As IFillOverlay
[C#]
IFillOverlay FillOverlayEffect {get; set;}

See Also

IEffectFormat Interface | Aspose.Slides Namespace


GlowEffect Property

Aspose.Slides Documentation

IEffectFormat.GlowEffect Property

[Visual Basic]
Property GlowEffect As IGlow
[C#]
IGlow GlowEffect {get; set;}

See Also

IEffectFormat Interface | Aspose.Slides Namespace


InnerShadowEffect Property

Aspose.Slides Documentation

IEffectFormat.InnerShadowEffect Property

[Visual Basic]
Property InnerShadowEffect As IInnerShadow
[C#]
IInnerShadow InnerShadowEffect {get; set;}

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IsNoEffects Property

Aspose.Slides Documentation

IEffectFormat.IsNoEffects Property

[Visual Basic]
Property IsNoEffects As Boolean
[C#]
bool IsNoEffects {get;}

See Also

IEffectFormat Interface | Aspose.Slides Namespace


OuterShadowEffect Property

Aspose.Slides Documentation

IEffectFormat.OuterShadowEffect Property

[Visual Basic]
Property OuterShadowEffect As IOuterShadow
[C#]
IOuterShadow OuterShadowEffect {get; set;}

See Also

IEffectFormat Interface | Aspose.Slides Namespace


PresetShadowEffect Property

Aspose.Slides Documentation

IEffectFormat.PresetShadowEffect Property

[Visual Basic]
Property PresetShadowEffect As IPresetShadow
[C#]
IPresetShadow PresetShadowEffect {get; set;}

See Also

IEffectFormat Interface | Aspose.Slides Namespace


ReflectionEffect Property

Aspose.Slides Documentation

IEffectFormat.ReflectionEffect Property

[Visual Basic]
Property ReflectionEffect As IReflection
[C#]
IReflection ReflectionEffect {get; set;}

See Also

IEffectFormat Interface | Aspose.Slides Namespace


SoftEdgeEffect Property

Aspose.Slides Documentation

IEffectFormat.SoftEdgeEffect Property

[Visual Basic]
Property SoftEdgeEffect As ISoftEdge
[C#]
ISoftEdge SoftEdgeEffect {get; set;}

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat Methods

The methods of the IEffectFormat interface are listed below. For a complete list of IEffectFormat interface members, see the IEffectFormat Members topic.

Public Instance Methods

DisableBlurEffect
DisableFillOverlayEffect
DisableGlowEffect
DisableInnerShadowEffect
DisableOuterShadowEffect
DisablePresetShadowEffect
DisableReflectionEffect
DisableSoftEdgeEffect
EnableFillOverlayEffect
EnableGlowEffect
EnableInnerShadowEffect
EnableOuterShadowEffect
EnablePresetShadowEffect
EnableReflectionEffect
EnableSoftEdgeEffect
SetBlurEffect

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.DisableBlurEffect Method

[Visual Basic]
Sub DisableBlurEffect()
[C#]
void DisableBlurEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.DisableFillOverlayEffect Method

[Visual Basic]
Sub DisableFillOverlayEffect()
[C#]
void DisableFillOverlayEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.DisableGlowEffect Method

[Visual Basic]
Sub DisableGlowEffect()
[C#]
void DisableGlowEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.DisableInnerShadowEffect Method

[Visual Basic]
Sub DisableInnerShadowEffect()
[C#]
void DisableInnerShadowEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.DisableOuterShadowEffect Method

[Visual Basic]
Sub DisableOuterShadowEffect()
[C#]
void DisableOuterShadowEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.DisablePresetShadowEffect Method

[Visual Basic]
Sub DisablePresetShadowEffect()
[C#]
void DisablePresetShadowEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.DisableReflectionEffect Method

[Visual Basic]
Sub DisableReflectionEffect()
[C#]
void DisableReflectionEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.DisableSoftEdgeEffect Method

[Visual Basic]
Sub DisableSoftEdgeEffect()
[C#]
void DisableSoftEdgeEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.EnableFillOverlayEffect Method

[Visual Basic]
Sub EnableFillOverlayEffect()
[C#]
void EnableFillOverlayEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.EnableGlowEffect Method

[Visual Basic]
Sub EnableGlowEffect()
[C#]
void EnableGlowEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.EnableInnerShadowEffect Method

[Visual Basic]
Sub EnableInnerShadowEffect()
[C#]
void EnableInnerShadowEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.EnableOuterShadowEffect Method

[Visual Basic]
Sub EnableOuterShadowEffect()
[C#]
void EnableOuterShadowEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.EnablePresetShadowEffect Method

[Visual Basic]
Sub EnablePresetShadowEffect()
[C#]
void EnablePresetShadowEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.EnableReflectionEffect Method

[Visual Basic]
Sub EnableReflectionEffect()
[C#]
void EnableReflectionEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.EnableSoftEdgeEffect Method

[Visual Basic]
Sub EnableSoftEdgeEffect()
[C#]
void EnableSoftEdgeEffect();

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormat.SetBlurEffect Method

[Visual Basic]
Sub SetBlurEffect( _
ByVal radius As Double, _
ByVal grow As Boolean _
)
[C#]
void SetBlurEffect(
double radius,
bool grow
);

See Also

IEffectFormat Interface | Aspose.Slides Namespace


IEffectFormatEffectiveData Interface

For a list of all members of this type, see IEffectFormatEffectiveData Members.

[Visual Basic]
Public Interface IEffectFormatEffectiveData
[C#]
public interface IEffectFormatEffectiveData

Types that implement IEffectFormatEffectiveData

Type | Description
EffectFormatEffectiveData | Imutable object which contains effect properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IEffectFormatEffectiveData Members | Aspose.Slides Namespace


IEffectFormatEffectiveData Members

IEffectFormatEffectiveData overview

Public Instance Properties

BlurEffect
FillOverlayEffect
GlowEffect
InnerShadowEffect
IsNoEffects
OuterShadowEffect
PresetShadowEffect
ReflectionEffect
SoftEdgeEffect

See Also

IEffectFormatEffectiveData Interface | Aspose.Slides Namespace


IEffectFormatEffectiveData Properties

The properties of the IEffectFormatEffectiveData interface are listed below. For a complete list of IEffectFormatEffectiveData interface members, see the IEffectFormatEffectiveData Members topic.

Public Instance Properties

BlurEffect
FillOverlayEffect
GlowEffect
InnerShadowEffect
IsNoEffects
OuterShadowEffect
PresetShadowEffect
ReflectionEffect
SoftEdgeEffect

See Also

IEffectFormatEffectiveData Interface | Aspose.Slides Namespace


BlurEffect Property

Aspose.Slides Documentation

IEffectFormatEffectiveData.BlurEffect Property

[Visual Basic]
Property BlurEffect As IBlurEffectiveData
[C#]
IBlurEffectiveData BlurEffect {get;}

See Also

IEffectFormatEffectiveData Interface | Aspose.Slides Namespace


FillOverlayEffect Property

Aspose.Slides Documentation

IEffectFormatEffectiveData.FillOverlayEffect Property

[Visual Basic]
Property FillOverlayEffect As IFillOverlayEffectiveData
[C#]
IFillOverlayEffectiveData FillOverlayEffect {get;}

See Also

IEffectFormatEffectiveData Interface | Aspose.Slides Namespace


GlowEffect Property

Aspose.Slides Documentation

IEffectFormatEffectiveData.GlowEffect Property

[Visual Basic]
Property GlowEffect As IGlowEffectiveData
[C#]
IGlowEffectiveData GlowEffect {get;}

See Also

IEffectFormatEffectiveData Interface | Aspose.Slides Namespace


InnerShadowEffect Property

Aspose.Slides Documentation

IEffectFormatEffectiveData.InnerShadowEffect Property

[Visual Basic]
Property InnerShadowEffect As IInnerShadowEffectiveData
[C#]
IInnerShadowEffectiveData InnerShadowEffect {get;}

See Also

IEffectFormatEffectiveData Interface | Aspose.Slides Namespace


IsNoEffects Property

Aspose.Slides Documentation

IEffectFormatEffectiveData.IsNoEffects Property

[Visual Basic]
Property IsNoEffects As Boolean
[C#]
bool IsNoEffects {get;}

See Also

IEffectFormatEffectiveData Interface | Aspose.Slides Namespace


OuterShadowEffect Property

Aspose.Slides Documentation

IEffectFormatEffectiveData.OuterShadowEffect Property

[Visual Basic]
Property OuterShadowEffect As IOuterShadowEffectiveData
[C#]
IOuterShadowEffectiveData OuterShadowEffect {get;}

See Also

IEffectFormatEffectiveData Interface | Aspose.Slides Namespace


PresetShadowEffect Property

Aspose.Slides Documentation

IEffectFormatEffectiveData.PresetShadowEffect Property

[Visual Basic]
Property PresetShadowEffect As IPresetShadowEffectiveData
[C#]
IPresetShadowEffectiveData PresetShadowEffect {get;}

See Also

IEffectFormatEffectiveData Interface | Aspose.Slides Namespace


ReflectionEffect Property

Aspose.Slides Documentation

IEffectFormatEffectiveData.ReflectionEffect Property

[Visual Basic]
Property ReflectionEffect As IReflectionEffectiveData
[C#]
IReflectionEffectiveData ReflectionEffect {get;}

See Also

IEffectFormatEffectiveData Interface | Aspose.Slides Namespace


SoftEdgeEffect Property

Aspose.Slides Documentation

IEffectFormatEffectiveData.SoftEdgeEffect Property

[Visual Basic]
Property SoftEdgeEffect As ISoftEdgeEffectiveData
[C#]
ISoftEdgeEffectiveData SoftEdgeEffect {get;}

See Also

IEffectFormatEffectiveData Interface | Aspose.Slides Namespace


IField Interface

For a list of all members of this type, see IField Members.

[Visual Basic]
Public Interface IField
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IField : ISlideComponent, IPresentationComponent

Types that implement IField

Type | Description
Field | Represents a field.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IField Members | Aspose.Slides Namespace


IField Members

IField overview

Public Instance Properties

AsISlideComponent
Type

See Also

IField Interface | Aspose.Slides Namespace


IField Properties

The properties of the IField interface are listed below. For a complete list of IField interface members, see the IField Members topic.

Public Instance Properties

AsISlideComponent
Type

See Also

IField Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IField.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IField Interface | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

IField.Type Property

[Visual Basic]
Property Type As IFieldType
[C#]
IFieldType Type {get; set;}

See Also

IField Interface | Aspose.Slides Namespace


IFieldType Interface

For a list of all members of this type, see IFieldType Members.

[Visual Basic]
Public Interface IFieldType
[C#]
public interface IFieldType

Types that implement IFieldType

Type | Description
FieldType | Represents a type of field. This value determines which text will be set to the field portion when it will be updated.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFieldType Members | Aspose.Slides Namespace


IFieldType Members

IFieldType overview

Public Instance Properties

InternalString

See Also

IFieldType Interface | Aspose.Slides Namespace


IFieldType Properties

The properties of the IFieldType interface are listed below. For a complete list of IFieldType interface members, see the IFieldType Members topic.

Public Instance Properties

InternalString

See Also

IFieldType Interface | Aspose.Slides Namespace


InternalString Property

Aspose.Slides Documentation

IFieldType.InternalString Property

[Visual Basic]
Property InternalString As String
[C#]
string InternalString {get; set;}

See Also

IFieldType Interface | Aspose.Slides Namespace


IFillFormat Interface

For a list of all members of this type, see IFillFormat Members.

[Visual Basic]
Public Interface IFillFormat
Implements ISlideComponent, IPresentationComponent, IFillParamSource
[C#]
public interface IFillFormat : ISlideComponent, IPresentationComponent, IFillParamSource

Types that implement IFillFormat

Type | Description
FillFormat | Represents a fill formatting options.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFillFormat Members | Aspose.Slides Namespace


IFillFormat Members

IFillFormat overview

Public Instance Properties

AsIFillParamSource
AsISlideComponent
FillType
GradientFormat
PatternFormat
PictureFillFormat
RotateWithShape
SolidFillColor

See Also

IFillFormat Interface | Aspose.Slides Namespace


IFillFormat Properties

The properties of the IFillFormat interface are listed below. For a complete list of IFillFormat interface members, see the IFillFormat Members topic.

Public Instance Properties

AsIFillParamSource
AsISlideComponent
FillType
GradientFormat
PatternFormat
PictureFillFormat
RotateWithShape
SolidFillColor

See Also

IFillFormat Interface | Aspose.Slides Namespace


AsIFillParamSource Property

Aspose.Slides Documentation

IFillFormat.AsIFillParamSource Property

[Visual Basic]
Property AsIFillParamSource As IFillParamSource
[C#]
IFillParamSource AsIFillParamSource {get;}

See Also

IFillFormat Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IFillFormat.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IFillFormat Interface | Aspose.Slides Namespace


FillType Property

Aspose.Slides Documentation

IFillFormat.FillType Property

[Visual Basic]
Property FillType As FillType
[C#]
FillType FillType {get; set;}

See Also

IFillFormat Interface | Aspose.Slides Namespace


GradientFormat Property

Aspose.Slides Documentation

IFillFormat.GradientFormat Property

[Visual Basic]
Property GradientFormat As IGradientFormat
[C#]
IGradientFormat GradientFormat {get;}

See Also

IFillFormat Interface | Aspose.Slides Namespace


PatternFormat Property

Aspose.Slides Documentation

IFillFormat.PatternFormat Property

[Visual Basic]
Property PatternFormat As IPatternFormat
[C#]
IPatternFormat PatternFormat {get;}

See Also

IFillFormat Interface | Aspose.Slides Namespace


PictureFillFormat Property

Aspose.Slides Documentation

IFillFormat.PictureFillFormat Property

[Visual Basic]
Property PictureFillFormat As IPictureFillFormat
[C#]
IPictureFillFormat PictureFillFormat {get;}

See Also

IFillFormat Interface | Aspose.Slides Namespace


RotateWithShape Property

Aspose.Slides Documentation

IFillFormat.RotateWithShape Property

[Visual Basic]
Property RotateWithShape As NullableBool
[C#]
NullableBool RotateWithShape {get; set;}

See Also

IFillFormat Interface | Aspose.Slides Namespace


SolidFillColor Property

Aspose.Slides Documentation

IFillFormat.SolidFillColor Property

[Visual Basic]
Property SolidFillColor As IColorFormat
[C#]
IColorFormat SolidFillColor {get;}

See Also

IFillFormat Interface | Aspose.Slides Namespace


IFillFormatEffectiveData Interface

For a list of all members of this type, see IFillFormatEffectiveData Members.

[Visual Basic]
Public Interface IFillFormatEffectiveData
[C#]
public interface IFillFormatEffectiveData

Types that implement IFillFormatEffectiveData

Type | Description
FillFormatEffectiveData | Imutable object which contains fill properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFillFormatEffectiveData Members | Aspose.Slides Namespace


IFillFormatEffectiveData Members

IFillFormatEffectiveData overview

Public Instance Properties

FillType
GradientFormat
PatternFormat
PictureFillFormat
RotateWithShape
SolidFillColor

See Also

IFillFormatEffectiveData Interface | Aspose.Slides Namespace


IFillFormatEffectiveData Properties

The properties of the IFillFormatEffectiveData interface are listed below. For a complete list of IFillFormatEffectiveData interface members, see the IFillFormatEffectiveData Members topic.

Public Instance Properties

FillType
GradientFormat
PatternFormat
PictureFillFormat
RotateWithShape
SolidFillColor

See Also

IFillFormatEffectiveData Interface | Aspose.Slides Namespace


FillType Property

Aspose.Slides Documentation

IFillFormatEffectiveData.FillType Property

[Visual Basic]
Property FillType As FillType
[C#]
FillType FillType {get;}

See Also

IFillFormatEffectiveData Interface | Aspose.Slides Namespace


GradientFormat Property

Aspose.Slides Documentation

IFillFormatEffectiveData.GradientFormat Property

[Visual Basic]
Property GradientFormat As IGradientFormatEffectiveData
[C#]
IGradientFormatEffectiveData GradientFormat {get;}

See Also

IFillFormatEffectiveData Interface | Aspose.Slides Namespace


PatternFormat Property

Aspose.Slides Documentation

IFillFormatEffectiveData.PatternFormat Property

[Visual Basic]
Property PatternFormat As IPatternFormatEffectiveData
[C#]
IPatternFormatEffectiveData PatternFormat {get;}

See Also

IFillFormatEffectiveData Interface | Aspose.Slides Namespace


PictureFillFormat Property

Aspose.Slides Documentation

IFillFormatEffectiveData.PictureFillFormat Property

[Visual Basic]
Property PictureFillFormat As IPictureFillFormatEffectiveData
[C#]
IPictureFillFormatEffectiveData PictureFillFormat {get;}

See Also

IFillFormatEffectiveData Interface | Aspose.Slides Namespace


RotateWithShape Property

Aspose.Slides Documentation

IFillFormatEffectiveData.RotateWithShape Property

[Visual Basic]
Property RotateWithShape As Boolean
[C#]
bool RotateWithShape {get;}

See Also

IFillFormatEffectiveData Interface | Aspose.Slides Namespace


SolidFillColor Property

Aspose.Slides Documentation

IFillFormatEffectiveData.SolidFillColor Property

[Visual Basic]
Property SolidFillColor As Color
[C#]
Color SolidFillColor {get;}

See Also

IFillFormatEffectiveData Interface | Aspose.Slides Namespace


IFillParamSource Interface

Aspose.Slides.IFillParamSource
Derived interfaces

[Visual Basic]
Public Interface IFillParamSource
[C#]
public interface IFillParamSource

Types that implement IFillParamSource

Type | Description
ColorFormat | Represents a color used in a presentation.
FillFormat | Represents a fill formatting options.
GradientFormat | Represent a gradient format.
LineFillFormat | Represents properties for lines filling.
LineFillFormatEffectiveData | Immutable object which represents properties for lines filling.
PictureFillFormat | Represents a picture fill style.
PictureFillFormatEffectiveData | Immutable object which contains the properties of picture fill.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


IFontData Interface

For a list of all members of this type, see IFontData Members.

[Visual Basic]
Public Interface IFontData
[C#]
public interface IFontData

Types that implement IFontData

Type | Description
FontData | Represents a font definition. Immutable.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFontData Members | Aspose.Slides Namespace


IFontData Members

IFontData overview

Public Instance Properties

FontName

Public Instance Methods

GetFontName

See Also

IFontData Interface | Aspose.Slides Namespace


IFontData Properties

The properties of the IFontData interface are listed below. For a complete list of IFontData interface members, see the IFontData Members topic.

Public Instance Properties

FontName

See Also

IFontData Interface | Aspose.Slides Namespace


FontName Property

Aspose.Slides Documentation

IFontData.FontName Property

[Visual Basic]
Property FontName As String
[C#]
string FontName {get;}

See Also

IFontData Interface | Aspose.Slides Namespace


IFontData Methods

The methods of the IFontData interface are listed below. For a complete list of IFontData interface members, see the IFontData Members topic.

Public Instance Methods

GetFontName

See Also

IFontData Interface | Aspose.Slides Namespace


IFontData.GetFontName Method

[Visual Basic]
Function GetFontName( _
ByVal theme As IThemeEffectiveData _
) As String
[C#]
string GetFontName(
IThemeEffectiveData theme
);

See Also

IFontData Interface | Aspose.Slides Namespace


IFontDataFactory Interface

For a list of all members of this type, see IFontDataFactory Members.

[Visual Basic]
Public Interface IFontDataFactory
[C#]
public interface IFontDataFactory

Types that implement IFontDataFactory

Type | Description
FontDataFactory | FontData factory

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFontDataFactory Members | Aspose.Slides Namespace


IFontDataFactory Members

IFontDataFactory overview

Public Instance Methods

CreateFontData

See Also

IFontDataFactory Interface | Aspose.Slides Namespace


IFontDataFactory Methods

The methods of the IFontDataFactory interface are listed below. For a complete list of IFontDataFactory interface members, see the IFontDataFactory Members topic.

Public Instance Methods

CreateFontData

See Also

IFontDataFactory Interface | Aspose.Slides Namespace


IFontDataFactory.CreateFontData Method

[Visual Basic]
Function CreateFontData( _
ByVal fontName As String _
) As IFontData
[C#]
IFontData CreateFontData(
string fontName
);

See Also

IFontDataFactory Interface | Aspose.Slides Namespace


IFonts Interface

For a list of all members of this type, see IFonts Members.

[Visual Basic]
Public Interface IFonts
[C#]
public interface IFonts

Types that implement IFonts

Type | Description
Fonts | Fonts collection.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFonts Members | Aspose.Slides Namespace


IFonts Members

IFonts overview

Public Instance Properties

ComplexScriptFont
EastAsianFont
LatinFont

See Also

IFonts Interface | Aspose.Slides Namespace


IFonts Properties

The properties of the IFonts interface are listed below. For a complete list of IFonts interface members, see the IFonts Members topic.

Public Instance Properties

ComplexScriptFont
EastAsianFont
LatinFont

See Also

IFonts Interface | Aspose.Slides Namespace


ComplexScriptFont Property

Aspose.Slides Documentation

IFonts.ComplexScriptFont Property

[Visual Basic]
Property ComplexScriptFont As IFontData
[C#]
IFontData ComplexScriptFont {get; set;}

See Also

IFonts Interface | Aspose.Slides Namespace


EastAsianFont Property

Aspose.Slides Documentation

IFonts.EastAsianFont Property

[Visual Basic]
Property EastAsianFont As IFontData
[C#]
IFontData EastAsianFont {get; set;}

See Also

IFonts Interface | Aspose.Slides Namespace


LatinFont Property

Aspose.Slides Documentation

IFonts.LatinFont Property

[Visual Basic]
Property LatinFont As IFontData
[C#]
IFontData LatinFont {get; set;}

See Also

IFonts Interface | Aspose.Slides Namespace


IFontsEffectiveData Interface

For a list of all members of this type, see IFontsEffectiveData Members.

[Visual Basic]
Public Interface IFontsEffectiveData
[C#]
public interface IFontsEffectiveData

Types that implement IFontsEffectiveData

Type | Description
FontsEffectiveData | Immutable Fonts object.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFontsEffectiveData Members | Aspose.Slides Namespace


IFontsEffectiveData Members

IFontsEffectiveData overview

Public Instance Properties

ComplexScriptFont
EastAsianFont
LatinFont

See Also

IFontsEffectiveData Interface | Aspose.Slides Namespace


IFontsEffectiveData Properties

The properties of the IFontsEffectiveData interface are listed below. For a complete list of IFontsEffectiveData interface members, see the IFontsEffectiveData Members topic.

Public Instance Properties

ComplexScriptFont
EastAsianFont
LatinFont

See Also

IFontsEffectiveData Interface | Aspose.Slides Namespace


ComplexScriptFont Property

Aspose.Slides Documentation

IFontsEffectiveData.ComplexScriptFont Property

[Visual Basic]
Property ComplexScriptFont As IFontData
[C#]
IFontData ComplexScriptFont {get;}

See Also

IFontsEffectiveData Interface | Aspose.Slides Namespace


EastAsianFont Property

Aspose.Slides Documentation

IFontsEffectiveData.EastAsianFont Property

[Visual Basic]
Property EastAsianFont As IFontData
[C#]
IFontData EastAsianFont {get;}

See Also

IFontsEffectiveData Interface | Aspose.Slides Namespace


LatinFont Property

Aspose.Slides Documentation

IFontsEffectiveData.LatinFont Property

[Visual Basic]
Property LatinFont As IFontData
[C#]
IFontData LatinFont {get;}

See Also

IFontsEffectiveData Interface | Aspose.Slides Namespace


IFontsLoader Interface

[Visual Basic]
Public Interface IFontsLoader
[C#]
public interface IFontsLoader

Types that implement IFontsLoader

Type | Description
FontsLoader | Class for loading custom fonts defined by user. Should be used before creating any presentation objects.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


IGeometryShape Interface

For a list of all members of this type, see IGeometryShape Members.

Aspose.Slides.IGeometryShape
Aspose.Slides.IAudioFrame
Aspose.Slides.IAutoShape
Aspose.Slides.IConnector
Aspose.Slides.IPictureFrame
Aspose.Slides.IVideoFrame

[Visual Basic]
Public Interface IGeometryShape
Implements IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public interface IGeometryShape : IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer

Types that implement IGeometryShape

Type | Description
AudioFrame | Represents an audio clip on a slide.
AutoShape | Represents an AutoShape.
Connector | Represents a connector.
GeometryShape | Represents the parent class for all geometric shapes.
PictureFrame | Represents a frame with a picture inside.
VideoFrame | Represents a video clip on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGeometryShape Members | Aspose.Slides Namespace


IGeometryShape Members

IGeometryShape overview

Public Instance Properties

Adjustments
AsIShape
ShapeStyle
ShapeType

Public Instance Methods

CreateShapeElements

See Also

IGeometryShape Interface | Aspose.Slides Namespace


IGeometryShape Properties

The properties of the IGeometryShape interface are listed below. For a complete list of IGeometryShape interface members, see the IGeometryShape Members topic.

Public Instance Properties

Adjustments
AsIShape
ShapeStyle
ShapeType

See Also

IGeometryShape Interface | Aspose.Slides Namespace


Adjustments Property

Aspose.Slides Documentation

IGeometryShape.Adjustments Property

[Visual Basic]
Property Adjustments As IAdjustValueCollection
[C#]
IAdjustValueCollection Adjustments {get;}

See Also

IGeometryShape Interface | Aspose.Slides Namespace


AsIShape Property

Aspose.Slides Documentation

IGeometryShape.AsIShape Property

[Visual Basic]
Property AsIShape As IShape
[C#]
IShape AsIShape {get;}

See Also

IGeometryShape Interface | Aspose.Slides Namespace


ShapeStyle Property

Aspose.Slides Documentation

IGeometryShape.ShapeStyle Property

[Visual Basic]
Property ShapeStyle As IShapeStyle
[C#]
IShapeStyle ShapeStyle {get;}

See Also

IGeometryShape Interface | Aspose.Slides Namespace


ShapeType Property

Aspose.Slides Documentation

IGeometryShape.ShapeType Property

[Visual Basic]
Property ShapeType As ShapeType
[C#]
ShapeType ShapeType {get; set;}

See Also

IGeometryShape Interface | Aspose.Slides Namespace


IGeometryShape Methods

The methods of the IGeometryShape interface are listed below. For a complete list of IGeometryShape interface members, see the IGeometryShape Members topic.

Public Instance Methods

CreateShapeElements

See Also

IGeometryShape Interface | Aspose.Slides Namespace


IGeometryShape.CreateShapeElements Method

[Visual Basic]
Function CreateShapeElements() As IShapeElement()
[C#]
IShapeElement[] CreateShapeElements();

See Also

IGeometryShape Interface | Aspose.Slides Namespace


IGlobalLayoutSlideCollection Interface

For a list of all members of this type, see IGlobalLayoutSlideCollection Members.

[Visual Basic]
Public Interface IGlobalLayoutSlideCollection
Implements ILayoutSlideCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ILayoutSlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IGlobalLayoutSlideCollection : ILayoutSlideCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IGlobalLayoutSlideCollection

Type | Description
GlobalLayoutSlideCollection | Represents a collection of all layout slides in presentation. Extends LayoutSlideCollection class with methods for adding/cloning layout slides in context of uniting of the individual collections of master's layout slides.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGlobalLayoutSlideCollection Members | Aspose.Slides Namespace


IGlobalLayoutSlideCollection Members

IGlobalLayoutSlideCollection overview

Public Instance Methods

Add |
AddClone | Overloaded.

See Also

IGlobalLayoutSlideCollection Interface | Aspose.Slides Namespace


IGlobalLayoutSlideCollection Methods

The methods of the IGlobalLayoutSlideCollection interface are listed below. For a complete list of IGlobalLayoutSlideCollection interface members, see the IGlobalLayoutSlideCollection Members topic.

Public Instance Methods

Add |
AddClone | Overloaded.

See Also

IGlobalLayoutSlideCollection Interface | Aspose.Slides Namespace


IGlobalLayoutSlideCollection.Add Method

[Visual Basic]
Function Add( _
ByVal master As IMasterSlide, _
ByVal layoutType As SlideLayoutType, _
ByVal layoutName As String _
) As ILayoutSlide
[C#]
ILayoutSlide Add(
IMasterSlide master,
SlideLayoutType layoutType,
string layoutName
);

See Also

IGlobalLayoutSlideCollection Interface | Aspose.Slides Namespace


AddClone Method

Aspose.Slides Documentation

IGlobalLayoutSlideCollection.AddClone Method

Overload List

ILayoutSlide AddClone(ILayoutSlide);

ILayoutSlide AddClone(ILayoutSlide,IMasterSlide);

See Also

IGlobalLayoutSlideCollection Interface | Aspose.Slides Namespace


IGlobalLayoutSlideCollection.AddClone Method (ILayoutSlide)

[Visual Basic]
Function AddClone( _
ByVal sourceLayout As ILayoutSlide _
) As ILayoutSlide
[C#]
ILayoutSlide AddClone(
ILayoutSlide sourceLayout
);

See Also

IGlobalLayoutSlideCollection Interface | Aspose.Slides Namespace | IGlobalLayoutSlideCollection.AddClone Overload List


IGlobalLayoutSlideCollection.AddClone Method (ILayoutSlide, IMasterSlide)

[Visual Basic]
Function AddClone( _
ByVal sourceLayout As ILayoutSlide, _
ByVal destMaster As IMasterSlide _
) As ILayoutSlide
[C#]
ILayoutSlide AddClone(
ILayoutSlide sourceLayout,
IMasterSlide destMaster
);

See Also

IGlobalLayoutSlideCollection Interface | Aspose.Slides Namespace | IGlobalLayoutSlideCollection.AddClone Overload List


IGradientFormat Interface

For a list of all members of this type, see IGradientFormat Members.

[Visual Basic]
Public Interface IGradientFormat
Implements ISlideComponent, IPresentationComponent, IFillParamSource
[C#]
public interface IGradientFormat : ISlideComponent, IPresentationComponent, IFillParamSource

Types that implement IGradientFormat

Type | Description
GradientFormat | Represent a gradient format.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGradientFormat Members | Aspose.Slides Namespace


IGradientFormat Members

IGradientFormat overview

Public Instance Properties

AsIFillParamSource
AsISlideComponent
GradientDirection
GradientShape
GradientStops
LinearGradientAngle
LinearGradientScaled
TileFlip

See Also

IGradientFormat Interface | Aspose.Slides Namespace


IGradientFormat Properties

The properties of the IGradientFormat interface are listed below. For a complete list of IGradientFormat interface members, see the IGradientFormat Members topic.

Public Instance Properties

AsIFillParamSource
AsISlideComponent
GradientDirection
GradientShape
GradientStops
LinearGradientAngle
LinearGradientScaled
TileFlip

See Also

IGradientFormat Interface | Aspose.Slides Namespace


AsIFillParamSource Property

Aspose.Slides Documentation

IGradientFormat.AsIFillParamSource Property

[Visual Basic]
Property AsIFillParamSource As IFillParamSource
[C#]
IFillParamSource AsIFillParamSource {get;}

See Also

IGradientFormat Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IGradientFormat.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IGradientFormat Interface | Aspose.Slides Namespace


GradientDirection Property

Aspose.Slides Documentation

IGradientFormat.GradientDirection Property

[Visual Basic]
Property GradientDirection As GradientDirection
[C#]
GradientDirection GradientDirection {get; set;}

See Also

IGradientFormat Interface | Aspose.Slides Namespace


GradientShape Property

Aspose.Slides Documentation

IGradientFormat.GradientShape Property

[Visual Basic]
Property GradientShape As GradientShape
[C#]
GradientShape GradientShape {get; set;}

See Also

IGradientFormat Interface | Aspose.Slides Namespace


GradientStops Property

Aspose.Slides Documentation

IGradientFormat.GradientStops Property

[Visual Basic]
Property GradientStops As IGradientStopCollection
[C#]
IGradientStopCollection GradientStops {get;}

See Also

IGradientFormat Interface | Aspose.Slides Namespace


LinearGradientAngle Property

Aspose.Slides Documentation

IGradientFormat.LinearGradientAngle Property

[Visual Basic]
Property LinearGradientAngle As Single
[C#]
float LinearGradientAngle {get; set;}

See Also

IGradientFormat Interface | Aspose.Slides Namespace


LinearGradientScaled Property

Aspose.Slides Documentation

IGradientFormat.LinearGradientScaled Property

[Visual Basic]
Property LinearGradientScaled As NullableBool
[C#]
NullableBool LinearGradientScaled {get; set;}

See Also

IGradientFormat Interface | Aspose.Slides Namespace


TileFlip Property

Aspose.Slides Documentation

IGradientFormat.TileFlip Property

[Visual Basic]
Property TileFlip As TileFlip
[C#]
TileFlip TileFlip {get; set;}

See Also

IGradientFormat Interface | Aspose.Slides Namespace


IGradientFormatEffectiveData Interface

For a list of all members of this type, see IGradientFormatEffectiveData Members.

[Visual Basic]
Public Interface IGradientFormatEffectiveData
[C#]
public interface IGradientFormatEffectiveData

Types that implement IGradientFormatEffectiveData

Type | Description
GradientFormatEffectiveData | Imutable object which contains gradient properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGradientFormatEffectiveData Members | Aspose.Slides Namespace


IGradientFormatEffectiveData Members

IGradientFormatEffectiveData overview

Public Instance Properties

GradientDirection
GradientShape
GradientStops
LinearGradientAngle
LinearGradientScaled
TileFlip

See Also

IGradientFormatEffectiveData Interface | Aspose.Slides Namespace


IGradientFormatEffectiveData Properties

The properties of the IGradientFormatEffectiveData interface are listed below. For a complete list of IGradientFormatEffectiveData interface members, see the IGradientFormatEffectiveData Members topic.

Public Instance Properties

GradientDirection
GradientShape
GradientStops
LinearGradientAngle
LinearGradientScaled
TileFlip

See Also

IGradientFormatEffectiveData Interface | Aspose.Slides Namespace


GradientDirection Property

Aspose.Slides Documentation

IGradientFormatEffectiveData.GradientDirection Property

[Visual Basic]
Property GradientDirection As GradientDirection
[C#]
GradientDirection GradientDirection {get;}

See Also

IGradientFormatEffectiveData Interface | Aspose.Slides Namespace


GradientShape Property

Aspose.Slides Documentation

IGradientFormatEffectiveData.GradientShape Property

[Visual Basic]
Property GradientShape As GradientShape
[C#]
GradientShape GradientShape {get;}

See Also

IGradientFormatEffectiveData Interface | Aspose.Slides Namespace


GradientStops Property

Aspose.Slides Documentation

IGradientFormatEffectiveData.GradientStops Property

[Visual Basic]
Property GradientStops As IGradientStopCollectionEffectiveData
[C#]
IGradientStopCollectionEffectiveData GradientStops {get;}

See Also

IGradientFormatEffectiveData Interface | Aspose.Slides Namespace


LinearGradientAngle Property

Aspose.Slides Documentation

IGradientFormatEffectiveData.LinearGradientAngle Property

[Visual Basic]
Property LinearGradientAngle As Single
[C#]
float LinearGradientAngle {get;}

See Also

IGradientFormatEffectiveData Interface | Aspose.Slides Namespace


LinearGradientScaled Property

Aspose.Slides Documentation

IGradientFormatEffectiveData.LinearGradientScaled Property

[Visual Basic]
Property LinearGradientScaled As Boolean
[C#]
bool LinearGradientScaled {get;}

See Also

IGradientFormatEffectiveData Interface | Aspose.Slides Namespace


TileFlip Property

Aspose.Slides Documentation

IGradientFormatEffectiveData.TileFlip Property

[Visual Basic]
Property TileFlip As TileFlip
[C#]
TileFlip TileFlip {get;}

See Also

IGradientFormatEffectiveData Interface | Aspose.Slides Namespace


IGradientStop Interface

For a list of all members of this type, see IGradientStop Members.

[Visual Basic]
Public Interface IGradientStop
[C#]
public interface IGradientStop

Types that implement IGradientStop

Type | Description
GradientStop | Represents a gradient stop.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGradientStop Members | Aspose.Slides Namespace


IGradientStop Members

IGradientStop overview

Public Instance Properties

Color
Position

See Also

IGradientStop Interface | Aspose.Slides Namespace


IGradientStop Properties

The properties of the IGradientStop interface are listed below. For a complete list of IGradientStop interface members, see the IGradientStop Members topic.

Public Instance Properties

Color
Position

See Also

IGradientStop Interface | Aspose.Slides Namespace


Color Property

Aspose.Slides Documentation

IGradientStop.Color Property

[Visual Basic]
Property Color As IColorFormat
[C#]
IColorFormat Color {get;}

See Also

IGradientStop Interface | Aspose.Slides Namespace


Position Property

Aspose.Slides Documentation

IGradientStop.Position Property

[Visual Basic]
Property Position As Single
[C#]
float Position {get; set;}

See Also

IGradientStop Interface | Aspose.Slides Namespace


IGradientStopCollection Interface

For a list of all members of this type, see IGradientStopCollection Members.

[Visual Basic]
Public Interface IGradientStopCollection
Implements ICollection, IEnumerable, ISlideComponent, IPresentationComponent, IEnumerable`1([Aspose.Slides.IGradientStop, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IGradientStopCollection : ICollection, IEnumerable, ISlideComponent, IPresentationComponent, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IGradientStopCollection

Type | Description
GradientStopCollection | Represnts a collection of gradient stops.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGradientStopCollection Members | Aspose.Slides Namespace


IGradientStopCollection Members

IGradientStopCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
AsISlideComponent
Item

Public Instance Methods

Add | Overloaded.
Clear |
Insert | Overloaded.
RemoveAt |

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace


IGradientStopCollection Properties

The properties of the IGradientStopCollection interface are listed below. For a complete list of IGradientStopCollection interface members, see the IGradientStopCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
AsISlideComponent
Item

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

IGradientStopCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IGradientStopCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IGradientStopCollection.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IGradientStopCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IGradientStop
[C#]
IGradientStop this[
int index
] {get;}

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace


IGradientStopCollection Methods

The methods of the IGradientStopCollection interface are listed below. For a complete list of IGradientStopCollection interface members, see the IGradientStopCollection Members topic.

Public Instance Methods

Add | Overloaded.
Clear |
Insert | Overloaded.
RemoveAt |

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace


Add Method

Aspose.Slides Documentation

IGradientStopCollection.Add Method

Overload List

IGradientStop Add(float,PresetColor);

IGradientStop Add(float,SchemeColor);

IGradientStop Add(float,Color);

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace


IGradientStopCollection.Add Method (Single, PresetColor)

[Visual Basic]
Function Add( _
ByVal position As Single, _
ByVal presetColor As PresetColor _
) As IGradientStop
[C#]
IGradientStop Add(
float position,
PresetColor presetColor
);

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace | IGradientStopCollection.Add Overload List


IGradientStopCollection.Add Method (Single, SchemeColor)

[Visual Basic]
Function Add( _
ByVal position As Single, _
ByVal schemeColor As SchemeColor _
) As IGradientStop
[C#]
IGradientStop Add(
float position,
SchemeColor schemeColor
);

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace | IGradientStopCollection.Add Overload List


IGradientStopCollection.Add Method (Single, Color)

[Visual Basic]
Function Add( _
ByVal position As Single, _
ByVal color As Color _
) As IGradientStop
[C#]
IGradientStop Add(
float position,
Color color
);

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace | IGradientStopCollection.Add Overload List


IGradientStopCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace


Insert Method

Aspose.Slides Documentation

IGradientStopCollection.Insert Method

Overload List

void Insert(int,float,PresetColor);

void Insert(int,float,SchemeColor);

void Insert(int,float,Color);

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace


IGradientStopCollection.Insert Method (Int32, Single, PresetColor)

[Visual Basic]
Sub Insert( _
ByVal index As Integer, _
ByVal position As Single, _
ByVal presetColor As PresetColor _
)
[C#]
void Insert(
int index,
float position,
PresetColor presetColor
);

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace | IGradientStopCollection.Insert Overload List


IGradientStopCollection.Insert Method (Int32, Single, SchemeColor)

[Visual Basic]
Sub Insert( _
ByVal index As Integer, _
ByVal position As Single, _
ByVal schemeColor As SchemeColor _
)
[C#]
void Insert(
int index,
float position,
SchemeColor schemeColor
);

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace | IGradientStopCollection.Insert Overload List


IGradientStopCollection.Insert Method (Int32, Single, Color)

[Visual Basic]
Sub Insert( _
ByVal index As Integer, _
ByVal position As Single, _
ByVal color As Color _
)
[C#]
void Insert(
int index,
float position,
Color color
);

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace | IGradientStopCollection.Insert Overload List


IGradientStopCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IGradientStopCollection Interface | Aspose.Slides Namespace


IGradientStopCollectionEffectiveData Interface

For a list of all members of this type, see IGradientStopCollectionEffectiveData Members.

[Visual Basic]
Public Interface IGradientStopCollectionEffectiveData
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IGradientStopEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IGradientStopCollectionEffectiveData : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IGradientStopCollectionEffectiveData

Type | Description
GradientStopCollectionEffectiveData | Represents a collection of GradientStopData objects.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGradientStopCollectionEffectiveData Members | Aspose.Slides Namespace


IGradientStopCollectionEffectiveData Members

IGradientStopCollectionEffectiveData overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IGradientStopCollectionEffectiveData Interface | Aspose.Slides Namespace


IGradientStopCollectionEffectiveData Properties

The properties of the IGradientStopCollectionEffectiveData interface are listed below. For a complete list of IGradientStopCollectionEffectiveData interface members, see the IGradientStopCollectionEffectiveData Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IGradientStopCollectionEffectiveData Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

IGradientStopCollectionEffectiveData.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IGradientStopCollectionEffectiveData Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IGradientStopCollectionEffectiveData.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IGradientStopCollectionEffectiveData Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IGradientStopCollectionEffectiveData.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IGradientStopEffectiveData
[C#]
IGradientStopEffectiveData this[
int index
] {get;}

See Also

IGradientStopCollectionEffectiveData Interface | Aspose.Slides Namespace


IGradientStopEffectiveData Interface

For a list of all members of this type, see IGradientStopEffectiveData Members.

[Visual Basic]
Public Interface IGradientStopEffectiveData
[C#]
public interface IGradientStopEffectiveData

Types that implement IGradientStopEffectiveData

Type | Description
GradientStopEffectiveData | immutable object which represents a gradient stop.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGradientStopEffectiveData Members | Aspose.Slides Namespace


IGradientStopEffectiveData Members

IGradientStopEffectiveData overview

Public Instance Properties

Color
Position

See Also

IGradientStopEffectiveData Interface | Aspose.Slides Namespace


IGradientStopEffectiveData Properties

The properties of the IGradientStopEffectiveData interface are listed below. For a complete list of IGradientStopEffectiveData interface members, see the IGradientStopEffectiveData Members topic.

Public Instance Properties

Color
Position

See Also

IGradientStopEffectiveData Interface | Aspose.Slides Namespace


Color Property

Aspose.Slides Documentation

IGradientStopEffectiveData.Color Property

[Visual Basic]
Property Color As Color
[C#]
Color Color {get;}

See Also

IGradientStopEffectiveData Interface | Aspose.Slides Namespace


Position Property

Aspose.Slides Documentation

IGradientStopEffectiveData.Position Property

[Visual Basic]
Property Position As Single
[C#]
float Position {get;}

See Also

IGradientStopEffectiveData Interface | Aspose.Slides Namespace


IGraphicalObject Interface

For a list of all members of this type, see IGraphicalObject Members.

Aspose.Slides.IGraphicalObject
Aspose.Slides.Charts.IChart
Aspose.Slides.IOleObjectFrame
Aspose.Slides.ITable
Aspose.Slides.SmartArt.ISmartArt

[Visual Basic]
Public Interface IGraphicalObject
Implements IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public interface IGraphicalObject : IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer

Types that implement IGraphicalObject

Type | Description
Chart | Represents an graphic chart on a slide.
GraphicalObject | Represents abstract graphical object.
OleObjectFrame | Represents an OLE object on a slide.
SmartArt | Represents SmartArt object on a slide.
Table | Represents a table on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGraphicalObject Members | Aspose.Slides Namespace


IGraphicalObject Members

IGraphicalObject overview

Public Instance Properties

AsIShape
ShapeLock

See Also

IGraphicalObject Interface | Aspose.Slides Namespace


IGraphicalObject Properties

The properties of the IGraphicalObject interface are listed below. For a complete list of IGraphicalObject interface members, see the IGraphicalObject Members topic.

Public Instance Properties

AsIShape
ShapeLock

See Also

IGraphicalObject Interface | Aspose.Slides Namespace


AsIShape Property

Aspose.Slides Documentation

IGraphicalObject.AsIShape Property

[Visual Basic]
Property AsIShape As IShape
[C#]
IShape AsIShape {get;}

See Also

IGraphicalObject Interface | Aspose.Slides Namespace


ShapeLock Property

Aspose.Slides Documentation

IGraphicalObject.ShapeLock Property

[Visual Basic]
Property ShapeLock As IGraphicalObjectLock
[C#]
IGraphicalObjectLock ShapeLock {get;}

See Also

IGraphicalObject Interface | Aspose.Slides Namespace


IGraphicalObjectLock Interface

For a list of all members of this type, see IGraphicalObjectLock Members.

[Visual Basic]
Public Interface IGraphicalObjectLock
Implements IBaseShapeLock
[C#]
public interface IGraphicalObjectLock : IBaseShapeLock

Types that implement IGraphicalObjectLock

Type | Description
GraphicalObjectLock | Determines which operations are disabled on the parent GraphicalObject.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGraphicalObjectLock Members | Aspose.Slides Namespace


IGraphicalObjectLock Members

IGraphicalObjectLock overview

Public Instance Properties

AsIBaseShapeLock
AspectRatioLocked
DrilldownLocked
GroupingLocked
PositionLocked
SelectLocked
SizeLocked

See Also

IGraphicalObjectLock Interface | Aspose.Slides Namespace


IGraphicalObjectLock Properties

The properties of the IGraphicalObjectLock interface are listed below. For a complete list of IGraphicalObjectLock interface members, see the IGraphicalObjectLock Members topic.

Public Instance Properties

AsIBaseShapeLock
AspectRatioLocked
DrilldownLocked
GroupingLocked
PositionLocked
SelectLocked
SizeLocked

See Also

IGraphicalObjectLock Interface | Aspose.Slides Namespace


AsIBaseShapeLock Property

Aspose.Slides Documentation

IGraphicalObjectLock.AsIBaseShapeLock Property

[Visual Basic]
Property AsIBaseShapeLock As IBaseShapeLock
[C#]
IBaseShapeLock AsIBaseShapeLock {get;}

See Also

IGraphicalObjectLock Interface | Aspose.Slides Namespace


AspectRatioLocked Property

Aspose.Slides Documentation

IGraphicalObjectLock.AspectRatioLocked Property

[Visual Basic]
Property AspectRatioLocked As Boolean
[C#]
bool AspectRatioLocked {get; set;}

See Also

IGraphicalObjectLock Interface | Aspose.Slides Namespace


DrilldownLocked Property

Aspose.Slides Documentation

IGraphicalObjectLock.DrilldownLocked Property

[Visual Basic]
Property DrilldownLocked As Boolean
[C#]
bool DrilldownLocked {get; set;}

See Also

IGraphicalObjectLock Interface | Aspose.Slides Namespace


GroupingLocked Property

Aspose.Slides Documentation

IGraphicalObjectLock.GroupingLocked Property

[Visual Basic]
Property GroupingLocked As Boolean
[C#]
bool GroupingLocked {get; set;}

See Also

IGraphicalObjectLock Interface | Aspose.Slides Namespace


PositionLocked Property

Aspose.Slides Documentation

IGraphicalObjectLock.PositionLocked Property

[Visual Basic]
Property PositionLocked As Boolean
[C#]
bool PositionLocked {get; set;}

See Also

IGraphicalObjectLock Interface | Aspose.Slides Namespace


SelectLocked Property

Aspose.Slides Documentation

IGraphicalObjectLock.SelectLocked Property

[Visual Basic]
Property SelectLocked As Boolean
[C#]
bool SelectLocked {get; set;}

See Also

IGraphicalObjectLock Interface | Aspose.Slides Namespace


SizeLocked Property

Aspose.Slides Documentation

IGraphicalObjectLock.SizeLocked Property

[Visual Basic]
Property SizeLocked As Boolean
[C#]
bool SizeLocked {get; set;}

See Also

IGraphicalObjectLock Interface | Aspose.Slides Namespace


IGroupShape Interface

For a list of all members of this type, see IGroupShape Members.

[Visual Basic]
Public Interface IGroupShape
Implements IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public interface IGroupShape : IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer

Types that implement IGroupShape

Type | Description
GroupShape | Represents a group of shapes on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGroupShape Members | Aspose.Slides Namespace


IGroupShape Members

IGroupShape overview

Public Instance Properties

AsIShape
ShapeLock
Shapes

See Also

IGroupShape Interface | Aspose.Slides Namespace


IGroupShape Properties

The properties of the IGroupShape interface are listed below. For a complete list of IGroupShape interface members, see the IGroupShape Members topic.

Public Instance Properties

AsIShape
ShapeLock
Shapes

See Also

IGroupShape Interface | Aspose.Slides Namespace


AsIShape Property

Aspose.Slides Documentation

IGroupShape.AsIShape Property

[Visual Basic]
Property AsIShape As IShape
[C#]
IShape AsIShape {get;}

See Also

IGroupShape Interface | Aspose.Slides Namespace


ShapeLock Property

Aspose.Slides Documentation

IGroupShape.ShapeLock Property

[Visual Basic]
Property ShapeLock As IGroupShapeLock
[C#]
IGroupShapeLock ShapeLock {get;}

See Also

IGroupShape Interface | Aspose.Slides Namespace


Shapes Property

Aspose.Slides Documentation

IGroupShape.Shapes Property

[Visual Basic]
Property Shapes As IShapeCollection
[C#]
IShapeCollection Shapes {get;}

See Also

IGroupShape Interface | Aspose.Slides Namespace


IGroupShapeLock Interface

For a list of all members of this type, see IGroupShapeLock Members.

[Visual Basic]
Public Interface IGroupShapeLock
Implements IBaseShapeLock
[C#]
public interface IGroupShapeLock : IBaseShapeLock

Types that implement IGroupShapeLock

Type | Description
GroupShapeLock | Determines which operations are disabled on the parent GroupShape.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGroupShapeLock Members | Aspose.Slides Namespace


IGroupShapeLock Members

IGroupShapeLock overview

Public Instance Properties

AsIBaseShapeLock
AspectRatioLocked
GroupingLocked
PositionLocked
RotationLocked
SelectLocked
SizeLocked
UngroupingLocked

See Also

IGroupShapeLock Interface | Aspose.Slides Namespace


IGroupShapeLock Properties

The properties of the IGroupShapeLock interface are listed below. For a complete list of IGroupShapeLock interface members, see the IGroupShapeLock Members topic.

Public Instance Properties

AsIBaseShapeLock
AspectRatioLocked
GroupingLocked
PositionLocked
RotationLocked
SelectLocked
SizeLocked
UngroupingLocked

See Also

IGroupShapeLock Interface | Aspose.Slides Namespace


AsIBaseShapeLock Property

Aspose.Slides Documentation

IGroupShapeLock.AsIBaseShapeLock Property

[Visual Basic]
Property AsIBaseShapeLock As IBaseShapeLock
[C#]
IBaseShapeLock AsIBaseShapeLock {get;}

See Also

IGroupShapeLock Interface | Aspose.Slides Namespace


AspectRatioLocked Property

Aspose.Slides Documentation

IGroupShapeLock.AspectRatioLocked Property

[Visual Basic]
Property AspectRatioLocked As Boolean
[C#]
bool AspectRatioLocked {get; set;}

See Also

IGroupShapeLock Interface | Aspose.Slides Namespace


GroupingLocked Property

Aspose.Slides Documentation

IGroupShapeLock.GroupingLocked Property

[Visual Basic]
Property GroupingLocked As Boolean
[C#]
bool GroupingLocked {get; set;}

See Also

IGroupShapeLock Interface | Aspose.Slides Namespace


PositionLocked Property

Aspose.Slides Documentation

IGroupShapeLock.PositionLocked Property

[Visual Basic]
Property PositionLocked As Boolean
[C#]
bool PositionLocked {get; set;}

See Also

IGroupShapeLock Interface | Aspose.Slides Namespace


RotationLocked Property

Aspose.Slides Documentation

IGroupShapeLock.RotationLocked Property

[Visual Basic]
Property RotationLocked As Boolean
[C#]
bool RotationLocked {get; set;}

See Also

IGroupShapeLock Interface | Aspose.Slides Namespace


SelectLocked Property

Aspose.Slides Documentation

IGroupShapeLock.SelectLocked Property

[Visual Basic]
Property SelectLocked As Boolean
[C#]
bool SelectLocked {get; set;}

See Also

IGroupShapeLock Interface | Aspose.Slides Namespace


SizeLocked Property

Aspose.Slides Documentation

IGroupShapeLock.SizeLocked Property

[Visual Basic]
Property SizeLocked As Boolean
[C#]
bool SizeLocked {get; set;}

See Also

IGroupShapeLock Interface | Aspose.Slides Namespace


UngroupingLocked Property

Aspose.Slides Documentation

IGroupShapeLock.UngroupingLocked Property

[Visual Basic]
Property UngroupingLocked As Boolean
[C#]
bool UngroupingLocked {get; set;}

See Also

IGroupShapeLock Interface | Aspose.Slides Namespace


IHeaderFooterManager Interface

For a list of all members of this type, see IHeaderFooterManager Members.

[Visual Basic]
Public Interface IHeaderFooterManager
[C#]
public interface IHeaderFooterManager

Types that implement IHeaderFooterManager

Type | Description
HeaderFooterManager | Represents manager which holds behavior of a header\footer placeholders

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IHeaderFooterManager Members | Aspose.Slides Namespace


IHeaderFooterManager Members

IHeaderFooterManager overview

Public Instance Properties

IsDateTimeVisible
IsFooterVisible
IsSlideNumberVisible

Public Instance Methods

SetDateTimeText
SetFooterText
SetVisibilityOnTitleSlide

See Also

IHeaderFooterManager Interface | Aspose.Slides Namespace


IHeaderFooterManager Properties

The properties of the IHeaderFooterManager interface are listed below. For a complete list of IHeaderFooterManager interface members, see the IHeaderFooterManager Members topic.

Public Instance Properties

IsDateTimeVisible
IsFooterVisible
IsSlideNumberVisible

See Also

IHeaderFooterManager Interface | Aspose.Slides Namespace


IsDateTimeVisible Property

Aspose.Slides Documentation

IHeaderFooterManager.IsDateTimeVisible Property

[Visual Basic]
Property IsDateTimeVisible As Boolean
[C#]
bool IsDateTimeVisible {get; set;}

See Also

IHeaderFooterManager Interface | Aspose.Slides Namespace


IsFooterVisible Property

Aspose.Slides Documentation

IHeaderFooterManager.IsFooterVisible Property

[Visual Basic]
Property IsFooterVisible As Boolean
[C#]
bool IsFooterVisible {get; set;}

See Also

IHeaderFooterManager Interface | Aspose.Slides Namespace


IsSlideNumberVisible Property

Aspose.Slides Documentation

IHeaderFooterManager.IsSlideNumberVisible Property

[Visual Basic]
Property IsSlideNumberVisible As Boolean
[C#]
bool IsSlideNumberVisible {get; set;}

See Also

IHeaderFooterManager Interface | Aspose.Slides Namespace


IHeaderFooterManager Methods

The methods of the IHeaderFooterManager interface are listed below. For a complete list of IHeaderFooterManager interface members, see the IHeaderFooterManager Members topic.

Public Instance Methods

SetDateTimeText
SetFooterText
SetVisibilityOnTitleSlide

See Also

IHeaderFooterManager Interface | Aspose.Slides Namespace


IHeaderFooterManager.SetDateTimeText Method

[Visual Basic]
Sub SetDateTimeText( _
ByVal date As String _
)
[C#]
void SetDateTimeText(
string date
);

See Also

IHeaderFooterManager Interface | Aspose.Slides Namespace


IHeaderFooterManager.SetFooterText Method

[Visual Basic]
Sub SetFooterText( _
ByVal text As String _
)
[C#]
void SetFooterText(
string text
);

See Also

IHeaderFooterManager Interface | Aspose.Slides Namespace


IHeaderFooterManager.SetVisibilityOnTitleSlide Method

[Visual Basic]
Sub SetVisibilityOnTitleSlide( _
ByVal isPlaceholdersVisible As Boolean _
)
[C#]
void SetVisibilityOnTitleSlide(
bool isPlaceholdersVisible
);

See Also

IHeaderFooterManager Interface | Aspose.Slides Namespace


IHyperlink Interface

For a list of all members of this type, see IHyperlink Members.

[Visual Basic]
Public Interface IHyperlink
[C#]
public interface IHyperlink

Types that implement IHyperlink

Type | Description
Hyperlink | Represents a hyperlink. Immutable.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IHyperlink Members | Aspose.Slides Namespace


IHyperlink Members

IHyperlink overview

Public Instance Properties

ActionType
ExternalUrl
HighlightClick
History
StopSoundOnClick
TargetFrame
TargetSlide
Tooltip

Public Instance Methods

Equals

See Also

IHyperlink Interface | Aspose.Slides Namespace


IHyperlink Properties

The properties of the IHyperlink interface are listed below. For a complete list of IHyperlink interface members, see the IHyperlink Members topic.

Public Instance Properties

ActionType
ExternalUrl
HighlightClick
History
StopSoundOnClick
TargetFrame
TargetSlide
Tooltip

See Also

IHyperlink Interface | Aspose.Slides Namespace


ActionType Property

Aspose.Slides Documentation

IHyperlink.ActionType Property

[Visual Basic]
Property ActionType As HyperlinkActionType
[C#]
HyperlinkActionType ActionType {get;}

See Also

IHyperlink Interface | Aspose.Slides Namespace


ExternalUrl Property

Aspose.Slides Documentation

IHyperlink.ExternalUrl Property

[Visual Basic]
Property ExternalUrl As String
[C#]
string ExternalUrl {get;}

See Also

IHyperlink Interface | Aspose.Slides Namespace


HighlightClick Property

Aspose.Slides Documentation

IHyperlink.HighlightClick Property

[Visual Basic]
Property HighlightClick As Boolean
[C#]
bool HighlightClick {get;}

See Also

IHyperlink Interface | Aspose.Slides Namespace


History Property

Aspose.Slides Documentation

IHyperlink.History Property

[Visual Basic]
Property History As Boolean
[C#]
bool History {get;}

See Also

IHyperlink Interface | Aspose.Slides Namespace


StopSoundOnClick Property

Aspose.Slides Documentation

IHyperlink.StopSoundOnClick Property

[Visual Basic]
Property StopSoundOnClick As Boolean
[C#]
bool StopSoundOnClick {get;}

See Also

IHyperlink Interface | Aspose.Slides Namespace


TargetFrame Property

Aspose.Slides Documentation

IHyperlink.TargetFrame Property

[Visual Basic]
Property TargetFrame As String
[C#]
string TargetFrame {get;}

See Also

IHyperlink Interface | Aspose.Slides Namespace


TargetSlide Property

Aspose.Slides Documentation

IHyperlink.TargetSlide Property

[Visual Basic]
Property TargetSlide As ISlide
[C#]
ISlide TargetSlide {get;}

See Also

IHyperlink Interface | Aspose.Slides Namespace


Tooltip Property

Aspose.Slides Documentation

IHyperlink.Tooltip Property

[Visual Basic]
Property Tooltip As String
[C#]
string Tooltip {get;}

See Also

IHyperlink Interface | Aspose.Slides Namespace


IHyperlink Methods

The methods of the IHyperlink interface are listed below. For a complete list of IHyperlink interface members, see the IHyperlink Members topic.

Public Instance Methods

Equals

See Also

IHyperlink Interface | Aspose.Slides Namespace


IHyperlink.Equals Method

[Visual Basic]
Function Equals( _
ByVal hlink As IHyperlink _
) As Boolean
[C#]
bool Equals(
IHyperlink hlink
);

See Also

IHyperlink Interface | Aspose.Slides Namespace


IHyperlinkContainer Interface

For a list of all members of this type, see IHyperlinkContainer Members.

Aspose.Slides.IHyperlinkContainer
Derived interfaces

[Visual Basic]
Public Interface IHyperlinkContainer
[C#]
public interface IHyperlinkContainer

Types that implement IHyperlinkContainer

Type | Description
AudioFrame | Represents an audio clip on a slide.
AutoShape | Represents an AutoShape.
Chart | Represents an graphic chart on a slide.
Connector | Represents a connector.
GeometryShape | Represents the parent class for all geometric shapes.
GraphicalObject | Represents abstract graphical object.
GroupShape | Represents a group of shapes on a slide.
OleObjectFrame | Represents an OLE object on a slide.
PictureFrame | Represents a frame with a picture inside.
PortionFormat | This class contains the text portion formatting properties. Unlike PortionFormatEffectiveData, all properties of this class are writeable.
Shape | Represents a shape on a slide.
SmartArt | Represents SmartArt object on a slide.
Table | Represents a table on a slide.
VideoFrame | Represents a video clip on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IHyperlinkContainer Members | Aspose.Slides Namespace


IHyperlinkContainer Members

IHyperlinkContainer overview

Public Instance Properties

HyperlinkClick
HyperlinkManager
HyperlinkMouseOver

See Also

IHyperlinkContainer Interface | Aspose.Slides Namespace


IHyperlinkContainer Properties

The properties of the IHyperlinkContainer interface are listed below. For a complete list of IHyperlinkContainer interface members, see the IHyperlinkContainer Members topic.

Public Instance Properties

HyperlinkClick
HyperlinkManager
HyperlinkMouseOver

See Also

IHyperlinkContainer Interface | Aspose.Slides Namespace


HyperlinkClick Property

Aspose.Slides Documentation

IHyperlinkContainer.HyperlinkClick Property

[Visual Basic]
Property HyperlinkClick As IHyperlink
[C#]
IHyperlink HyperlinkClick {get; set;}

See Also

IHyperlinkContainer Interface | Aspose.Slides Namespace


HyperlinkManager Property

Aspose.Slides Documentation

IHyperlinkContainer.HyperlinkManager Property

[Visual Basic]
Property HyperlinkManager As IHyperlinkManager
[C#]
IHyperlinkManager HyperlinkManager {get;}

See Also

IHyperlinkContainer Interface | Aspose.Slides Namespace


HyperlinkMouseOver Property

Aspose.Slides Documentation

IHyperlinkContainer.HyperlinkMouseOver Property

[Visual Basic]
Property HyperlinkMouseOver As IHyperlink
[C#]
IHyperlink HyperlinkMouseOver {get; set;}

See Also

IHyperlinkContainer Interface | Aspose.Slides Namespace


IHyperlinkManager Interface

For a list of all members of this type, see IHyperlinkManager Members.

[Visual Basic]
Public Interface IHyperlinkManager
[C#]
public interface IHyperlinkManager

Types that implement IHyperlinkManager

Type | Description
HyperlinkManager |

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IHyperlinkManager Members | Aspose.Slides Namespace


IHyperlinkManager Members

IHyperlinkManager overview

Public Instance Methods

RemoveHyperlinkClick
RemoveHyperlinkMouseOver
SetExternalHyperlinkClick
SetExternalHyperlinkMouseOver
SetInternalHyperlinkClick
SetInternalHyperlinkMouseOver

See Also

IHyperlinkManager Interface | Aspose.Slides Namespace


IHyperlinkManager Methods

The methods of the IHyperlinkManager interface are listed below. For a complete list of IHyperlinkManager interface members, see the IHyperlinkManager Members topic.

Public Instance Methods

RemoveHyperlinkClick
RemoveHyperlinkMouseOver
SetExternalHyperlinkClick
SetExternalHyperlinkMouseOver
SetInternalHyperlinkClick
SetInternalHyperlinkMouseOver

See Also

IHyperlinkManager Interface | Aspose.Slides Namespace


IHyperlinkManager.RemoveHyperlinkClick Method

[Visual Basic]
Sub RemoveHyperlinkClick()
[C#]
void RemoveHyperlinkClick();

See Also

IHyperlinkManager Interface | Aspose.Slides Namespace


IHyperlinkManager.RemoveHyperlinkMouseOver Method

[Visual Basic]
Sub RemoveHyperlinkMouseOver()
[C#]
void RemoveHyperlinkMouseOver();

See Also

IHyperlinkManager Interface | Aspose.Slides Namespace


IHyperlinkManager.SetExternalHyperlinkClick Method

[Visual Basic]
Function SetExternalHyperlinkClick( _
ByVal url As String _
) As IHyperlink
[C#]
IHyperlink SetExternalHyperlinkClick(
string url
);

See Also

IHyperlinkManager Interface | Aspose.Slides Namespace


IHyperlinkManager.SetExternalHyperlinkMouseOver Method

[Visual Basic]
Function SetExternalHyperlinkMouseOver( _
ByVal url As String _
) As IHyperlink
[C#]
IHyperlink SetExternalHyperlinkMouseOver(
string url
);

See Also

IHyperlinkManager Interface | Aspose.Slides Namespace


IHyperlinkManager.SetInternalHyperlinkClick Method

[Visual Basic]
Function SetInternalHyperlinkClick( _
ByVal targetSlide As ISlide _
) As IHyperlink
[C#]
IHyperlink SetInternalHyperlinkClick(
ISlide targetSlide
);

See Also

IHyperlinkManager Interface | Aspose.Slides Namespace


IHyperlinkManager.SetInternalHyperlinkMouseOver Method

[Visual Basic]
Function SetInternalHyperlinkMouseOver( _
ByVal targetSlide As ISlide _
) As IHyperlink
[C#]
IHyperlink SetInternalHyperlinkMouseOver(
ISlide targetSlide
);

See Also

IHyperlinkManager Interface | Aspose.Slides Namespace


IHyperlinkQueries Interface

For a list of all members of this type, see IHyperlinkQueries Members.

[Visual Basic]
Public Interface IHyperlinkQueries
[C#]
public interface IHyperlinkQueries

Types that implement IHyperlinkQueries

Type | Description
HyperlinkQueries |

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IHyperlinkQueries Members | Aspose.Slides Namespace


IHyperlinkQueries Members

IHyperlinkQueries overview

Public Instance Methods

GetAnyHyperlinks
GetHyperlinkClicks
GetHyperlinkMouseOvers
RemoveAllHyperlinks

See Also

IHyperlinkQueries Interface | Aspose.Slides Namespace


IHyperlinkQueries Methods

The methods of the IHyperlinkQueries interface are listed below. For a complete list of IHyperlinkQueries interface members, see the IHyperlinkQueries Members topic.

Public Instance Methods

GetAnyHyperlinks
GetHyperlinkClicks
GetHyperlinkMouseOvers
RemoveAllHyperlinks

See Also

IHyperlinkQueries Interface | Aspose.Slides Namespace


IHyperlinkQueries.GetAnyHyperlinks Method

[Visual Basic]
Function GetAnyHyperlinks() As List(Of IHyperlinkContainer)
[C#]
List<IHyperlinkContainer> GetAnyHyperlinks();

See Also

IHyperlinkQueries Interface | Aspose.Slides Namespace


IHyperlinkQueries.GetHyperlinkClicks Method

[Visual Basic]
Function GetHyperlinkClicks() As List(Of IHyperlinkContainer)
[C#]
List<IHyperlinkContainer> GetHyperlinkClicks();

See Also

IHyperlinkQueries Interface | Aspose.Slides Namespace


IHyperlinkQueries.GetHyperlinkMouseOvers Method

[Visual Basic]
Function GetHyperlinkMouseOvers() As List(Of IHyperlinkContainer)
[C#]
List<IHyperlinkContainer> GetHyperlinkMouseOvers();

See Also

IHyperlinkQueries Interface | Aspose.Slides Namespace


IHyperlinkQueries.RemoveAllHyperlinks Method

[Visual Basic]
Sub RemoveAllHyperlinks()
[C#]
void RemoveAllHyperlinks();

See Also

IHyperlinkQueries Interface | Aspose.Slides Namespace


IImageCollection Interface

For a list of all members of this type, see IImageCollection Members.

[Visual Basic]
Public Interface IImageCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IPPImage, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IImageCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IImageCollection

Type | Description
ImageCollection | Represents collection of PPImage.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IImageCollection Members | Aspose.Slides Namespace


IImageCollection Members

IImageCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

AddImage Overloaded.

See Also

IImageCollection Interface | Aspose.Slides Namespace


IImageCollection Properties

The properties of the IImageCollection interface are listed below. For a complete list of IImageCollection interface members, see the IImageCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IImageCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

IImageCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IImageCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IImageCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IImageCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IImageCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IPPImage
[C#]
IPPImage this[
int index
] {get;}

See Also

IImageCollection Interface | Aspose.Slides Namespace


IImageCollection Methods

The methods of the IImageCollection interface are listed below. For a complete list of IImageCollection interface members, see the IImageCollection Members topic.

Public Instance Methods

AddImage Overloaded.

See Also

IImageCollection Interface | Aspose.Slides Namespace


AddImage Method

Aspose.Slides Documentation

IImageCollection.AddImage Method

Overload List

IPPImage AddImage(IPPImage);

IPPImage AddImage(byte[]);

IPPImage AddImage(Image);

IPPImage AddImage(MemoryStream);

IPPImage AddImage(Stream);

See Also

IImageCollection Interface | Aspose.Slides Namespace


IImageCollection.AddImage Method (IPPImage)

[Visual Basic]
Function AddImage( _
ByVal imageSource As IPPImage _
) As IPPImage
[C#]
IPPImage AddImage(
IPPImage imageSource
);

See Also

IImageCollection Interface | Aspose.Slides Namespace | IImageCollection.AddImage Overload List


IImageCollection.AddImage Method (Byte[])

[Visual Basic]
Function AddImage( _
ByVal buffer As Byte() _
) As IPPImage
[C#]
IPPImage AddImage(
byte[] buffer
);

See Also

IImageCollection Interface | Aspose.Slides Namespace | IImageCollection.AddImage Overload List


IImageCollection.AddImage Method (Image)

[Visual Basic]
Function AddImage( _
ByVal image As Image _
) As IPPImage
[C#]
IPPImage AddImage(
Image image
);

See Also

IImageCollection Interface | Aspose.Slides Namespace | IImageCollection.AddImage Overload List


IImageCollection.AddImage Method (MemoryStream)

[Visual Basic]
Function AddImage( _
ByVal stream As MemoryStream _
) As IPPImage
[C#]
IPPImage AddImage(
MemoryStream stream
);

See Also

IImageCollection Interface | Aspose.Slides Namespace | IImageCollection.AddImage Overload List


IImageCollection.AddImage Method (Stream)

[Visual Basic]
Function AddImage( _
ByVal stream As Stream _
) As IPPImage
[C#]
IPPImage AddImage(
Stream stream
);

See Also

IImageCollection Interface | Aspose.Slides Namespace | IImageCollection.AddImage Overload List


IImageWrapper Interface

For a list of all members of this type, see IImageWrapper Members.

[Visual Basic]
Public Interface IImageWrapper
Implements IDisposable
[C#]
public interface IImageWrapper : IDisposable

Types that implement IImageWrapper

Type | Description
ImageWrapper | System.Drawing.Image wrapper for COM interface.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IImageWrapper Members | Aspose.Slides Namespace


IImageWrapper Members

IImageWrapper overview

Public Instance Properties

AsIDisposable
Image
Size

Public Instance Methods

Save Overloaded.

See Also

IImageWrapper Interface | Aspose.Slides Namespace


IImageWrapper Properties

The properties of the IImageWrapper interface are listed below. For a complete list of IImageWrapper interface members, see the IImageWrapper Members topic.

Public Instance Properties

AsIDisposable
Image
Size

See Also

IImageWrapper Interface | Aspose.Slides Namespace


AsIDisposable Property

Aspose.Slides Documentation

IImageWrapper.AsIDisposable Property

[Visual Basic]
Property AsIDisposable As IDisposable
[C#]
IDisposable AsIDisposable {get;}

See Also

IImageWrapper Interface | Aspose.Slides Namespace


Image Property

Aspose.Slides Documentation

IImageWrapper.Image Property

[Visual Basic]
Property Image As Image
[C#]
Image Image {get;}

See Also

IImageWrapper Interface | Aspose.Slides Namespace


Size Property

Aspose.Slides Documentation

IImageWrapper.Size Property

[Visual Basic]
Property Size As Size
[C#]
Size Size {get;}

See Also

IImageWrapper Interface | Aspose.Slides Namespace


IImageWrapper Methods

The methods of the IImageWrapper interface are listed below. For a complete list of IImageWrapper interface members, see the IImageWrapper Members topic.

Public Instance Methods

Save Overloaded.

See Also

IImageWrapper Interface | Aspose.Slides Namespace


Save Method

Aspose.Slides Documentation

IImageWrapper.Save Method

Overload List

void Save(Stream,PPImageFormat);

void Save(string);

void Save(string,PPImageFormat);

See Also

IImageWrapper Interface | Aspose.Slides Namespace


IImageWrapper.Save Method (Stream, PPImageFormat)

[Visual Basic]
Sub Save( _
ByVal stream As Stream, _
ByVal imageFormat As PPImageFormat _
)
[C#]
void Save(
Stream stream,
PPImageFormat imageFormat
);

See Also

IImageWrapper Interface | Aspose.Slides Namespace | IImageWrapper.Save Overload List


IImageWrapper.Save Method (String)

[Visual Basic]
Sub Save( _
ByVal fileName As String _
)
[C#]
void Save(
string fileName
);

See Also

IImageWrapper Interface | Aspose.Slides Namespace | IImageWrapper.Save Overload List


IImageWrapper.Save Method (String, PPImageFormat)

[Visual Basic]
Sub Save( _
ByVal fileName As String, _
ByVal imageFormat As PPImageFormat _
)
[C#]
void Save(
string fileName,
PPImageFormat imageFormat
);

See Also

IImageWrapper Interface | Aspose.Slides Namespace | IImageWrapper.Save Overload List


IImageWrapperFactory Interface

For a list of all members of this type, see IImageWrapperFactory Members.

[Visual Basic]
Public Interface IImageWrapperFactory
[C#]
public interface IImageWrapperFactory

Types that implement IImageWrapperFactory

Type | Description
ImageWrapperFactory | This class allows to initialize IBitmapWrapper.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IImageWrapperFactory Members | Aspose.Slides Namespace


IImageWrapperFactory Members

IImageWrapperFactory overview

Public Instance Methods

CreateImageWrapper Overloaded.

See Also

IImageWrapperFactory Interface | Aspose.Slides Namespace


IImageWrapperFactory Methods

The methods of the IImageWrapperFactory interface are listed below. For a complete list of IImageWrapperFactory interface members, see the IImageWrapperFactory Members topic.

Public Instance Methods

CreateImageWrapper Overloaded.

See Also

IImageWrapperFactory Interface | Aspose.Slides Namespace


CreateImageWrapper Method

Aspose.Slides Documentation

IImageWrapperFactory.CreateImageWrapper Method

Overload List

IImageWrapper CreateImageWrapper(Image);

IImageWrapper CreateImageWrapper(Stream);

IImageWrapper CreateImageWrapper(string);

See Also

IImageWrapperFactory Interface | Aspose.Slides Namespace


IImageWrapperFactory.CreateImageWrapper Method (Image)

[Visual Basic]
Function CreateImageWrapper( _
ByVal image As Image _
) As IImageWrapper
[C#]
IImageWrapper CreateImageWrapper(
Image image
);

See Also

IImageWrapperFactory Interface | Aspose.Slides Namespace | IImageWrapperFactory.CreateImageWrapper Overload List


IImageWrapperFactory.CreateImageWrapper Method (Stream)

[Visual Basic]
Function CreateImageWrapper( _
ByVal stream As Stream _
) As IImageWrapper
[C#]
IImageWrapper CreateImageWrapper(
Stream stream
);

See Also

IImageWrapperFactory Interface | Aspose.Slides Namespace | IImageWrapperFactory.CreateImageWrapper Overload List


IImageWrapperFactory.CreateImageWrapper Method (String)

[Visual Basic]
Function CreateImageWrapper( _
ByVal fileName As String _
) As IImageWrapper
[C#]
IImageWrapper CreateImageWrapper(
string fileName
);

See Also

IImageWrapperFactory Interface | Aspose.Slides Namespace | IImageWrapperFactory.CreateImageWrapper Overload List


ILayoutSlide Interface

For a list of all members of this type, see ILayoutSlide Members.

[Visual Basic]
Public Interface ILayoutSlide
Implements IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent, IOverrideThemeable
[C#]
public interface ILayoutSlide : IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent, IOverrideThemeable

Types that implement ILayoutSlide

Type | Description
LayoutSlide | Represents a layout slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILayoutSlide Members | Aspose.Slides Namespace


ILayoutSlide Members

ILayoutSlide overview

Public Instance Properties

AsIBaseSlide
AsIOverrideThemeable
HasDependingSlides
LayoutType
MasterSlide

Public Instance Methods

GetDependingSlides
Remove

See Also

ILayoutSlide Interface | Aspose.Slides Namespace


ILayoutSlide Properties

The properties of the ILayoutSlide interface are listed below. For a complete list of ILayoutSlide interface members, see the ILayoutSlide Members topic.

Public Instance Properties

AsIBaseSlide
AsIOverrideThemeable
HasDependingSlides
LayoutType
MasterSlide

See Also

ILayoutSlide Interface | Aspose.Slides Namespace


AsIBaseSlide Property

Aspose.Slides Documentation

ILayoutSlide.AsIBaseSlide Property

[Visual Basic]
Property AsIBaseSlide As IBaseSlide
[C#]
IBaseSlide AsIBaseSlide {get;}

See Also

ILayoutSlide Interface | Aspose.Slides Namespace


AsIOverrideThemeable Property

Aspose.Slides Documentation

ILayoutSlide.AsIOverrideThemeable Property

[Visual Basic]
Property AsIOverrideThemeable As IOverrideThemeable
[C#]
IOverrideThemeable AsIOverrideThemeable {get;}

See Also

ILayoutSlide Interface | Aspose.Slides Namespace


HasDependingSlides Property

Aspose.Slides Documentation

ILayoutSlide.HasDependingSlides Property

[Visual Basic]
Property HasDependingSlides As Boolean
[C#]
bool HasDependingSlides {get;}

See Also

ILayoutSlide Interface | Aspose.Slides Namespace


LayoutType Property

Aspose.Slides Documentation

ILayoutSlide.LayoutType Property

[Visual Basic]
Property LayoutType As SlideLayoutType
[C#]
SlideLayoutType LayoutType {get;}

See Also

ILayoutSlide Interface | Aspose.Slides Namespace


MasterSlide Property

Aspose.Slides Documentation

ILayoutSlide.MasterSlide Property

[Visual Basic]
Property MasterSlide As IMasterSlide
[C#]
IMasterSlide MasterSlide {get; set;}

See Also

ILayoutSlide Interface | Aspose.Slides Namespace


ILayoutSlide Methods

The methods of the ILayoutSlide interface are listed below. For a complete list of ILayoutSlide interface members, see the ILayoutSlide Members topic.

Public Instance Methods

GetDependingSlides
Remove

See Also

ILayoutSlide Interface | Aspose.Slides Namespace


ILayoutSlide.GetDependingSlides Method

[Visual Basic]
Function GetDependingSlides() As ISlide()
[C#]
ISlide[] GetDependingSlides();

See Also

ILayoutSlide Interface | Aspose.Slides Namespace


ILayoutSlide.Remove Method

[Visual Basic]
Sub Remove()
[C#]
void Remove();

See Also

ILayoutSlide Interface | Aspose.Slides Namespace


ILayoutSlideCollection Interface

For a list of all members of this type, see ILayoutSlideCollection Members.

Aspose.Slides.ILayoutSlideCollection
Aspose.Slides.IGlobalLayoutSlideCollection
Aspose.Slides.IMasterLayoutSlideCollection

[Visual Basic]
Public Interface ILayoutSlideCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ILayoutSlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface ILayoutSlideCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement ILayoutSlideCollection

Type | Description
GlobalLayoutSlideCollection | Represents a collection of all layout slides in presentation. Extends LayoutSlideCollection class with methods for adding/cloning layout slides in context of uniting of the individual collections of master's layout slides.
LayoutSlideCollection | Represents a base class for collection of a layout slides.
MasterLayoutSlideCollection | Represents a collections of all layout slides of defined master slide. Extends LayoutSlideCollection class with methods for adding/inserting/removing/cloning/reordering layout slides in context of the individual collections of master's layout slides.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILayoutSlideCollection Members | Aspose.Slides Namespace


ILayoutSlideCollection Members

ILayoutSlideCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

GetByType
Remove
RemoveUnused

See Also

ILayoutSlideCollection Interface | Aspose.Slides Namespace


ILayoutSlideCollection Properties

The properties of the ILayoutSlideCollection interface are listed below. For a complete list of ILayoutSlideCollection interface members, see the ILayoutSlideCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

ILayoutSlideCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

ILayoutSlideCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

ILayoutSlideCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ILayoutSlideCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ILayoutSlideCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ILayoutSlideCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As ILayoutSlide
[C#]
ILayoutSlide this[
int index
] {get;}

See Also

ILayoutSlideCollection Interface | Aspose.Slides Namespace


ILayoutSlideCollection Methods

The methods of the ILayoutSlideCollection interface are listed below. For a complete list of ILayoutSlideCollection interface members, see the ILayoutSlideCollection Members topic.

Public Instance Methods

GetByType
Remove
RemoveUnused

See Also

ILayoutSlideCollection Interface | Aspose.Slides Namespace


ILayoutSlideCollection.GetByType Method

[Visual Basic]
Function GetByType( _
ByVal type As SlideLayoutType _
) As ILayoutSlide
[C#]
ILayoutSlide GetByType(
SlideLayoutType type
);

See Also

ILayoutSlideCollection Interface | Aspose.Slides Namespace


ILayoutSlideCollection.Remove Method

[Visual Basic]
Sub Remove( _
ByVal value As ILayoutSlide _
)
[C#]
void Remove(
ILayoutSlide value
);

See Also

ILayoutSlideCollection Interface | Aspose.Slides Namespace


ILayoutSlideCollection.RemoveUnused Method

[Visual Basic]
Sub RemoveUnused()
[C#]
void RemoveUnused();

See Also

ILayoutSlideCollection Interface | Aspose.Slides Namespace


ILightRig Interface

For a list of all members of this type, see ILightRig Members.

[Visual Basic]
Public Interface ILightRig
[C#]
public interface ILightRig

Types that implement ILightRig

Type | Description
LightRig | Represents LightRig.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILightRig Members | Aspose.Slides Namespace


ILightRig Members

ILightRig overview

Public Instance Properties

Direction
LightType

Public Instance Methods

GetRotation
SetRotation

See Also

ILightRig Interface | Aspose.Slides Namespace


ILightRig Properties

The properties of the ILightRig interface are listed below. For a complete list of ILightRig interface members, see the ILightRig Members topic.

Public Instance Properties

Direction
LightType

See Also

ILightRig Interface | Aspose.Slides Namespace


Direction Property

Aspose.Slides Documentation

ILightRig.Direction Property

[Visual Basic]
Property Direction As LightingDirection
[C#]
LightingDirection Direction {get; set;}

See Also

ILightRig Interface | Aspose.Slides Namespace


LightType Property

Aspose.Slides Documentation

ILightRig.LightType Property

[Visual Basic]
Property LightType As LightRigPresetType
[C#]
LightRigPresetType LightType {get; set;}

See Also

ILightRig Interface | Aspose.Slides Namespace


ILightRig Methods

The methods of the ILightRig interface are listed below. For a complete list of ILightRig interface members, see the ILightRig Members topic.

Public Instance Methods

GetRotation
SetRotation

See Also

ILightRig Interface | Aspose.Slides Namespace


ILightRig.GetRotation Method

[Visual Basic]
Function GetRotation() As Single()
[C#]
float[] GetRotation();

See Also

ILightRig Interface | Aspose.Slides Namespace


ILightRig.SetRotation Method

[Visual Basic]
Sub SetRotation( _
ByVal latitude As Single, _
ByVal longitude As Single, _
ByVal revolution As Single _
)
[C#]
void SetRotation(
float latitude,
float longitude,
float revolution
);

See Also

ILightRig Interface | Aspose.Slides Namespace


ILightRigEffectiveData Interface

[Visual Basic]
Public Interface ILightRigEffectiveData
[C#]
public interface ILightRigEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


ILineFillFormat Interface

For a list of all members of this type, see ILineFillFormat Members.

[Visual Basic]
Public Interface ILineFillFormat
Implements IFillParamSource, ISlideComponent, IPresentationComponent
[C#]
public interface ILineFillFormat : IFillParamSource, ISlideComponent, IPresentationComponent

Types that implement ILineFillFormat

Type | Description
LineFillFormat | Represents properties for lines filling.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILineFillFormat Members | Aspose.Slides Namespace


ILineFillFormat Members

ILineFillFormat overview

Public Instance Properties

AsIFillParamSource
AsISlideComponent
FillType
GradientFormat
PatternFormat
RotateWithShape
SolidFillColor

See Also

ILineFillFormat Interface | Aspose.Slides Namespace


ILineFillFormat Properties

The properties of the ILineFillFormat interface are listed below. For a complete list of ILineFillFormat interface members, see the ILineFillFormat Members topic.

Public Instance Properties

AsIFillParamSource
AsISlideComponent
FillType
GradientFormat
PatternFormat
RotateWithShape
SolidFillColor

See Also

ILineFillFormat Interface | Aspose.Slides Namespace


AsIFillParamSource Property

Aspose.Slides Documentation

ILineFillFormat.AsIFillParamSource Property

[Visual Basic]
Property AsIFillParamSource As IFillParamSource
[C#]
IFillParamSource AsIFillParamSource {get;}

See Also

ILineFillFormat Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

ILineFillFormat.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

ILineFillFormat Interface | Aspose.Slides Namespace


FillType Property

Aspose.Slides Documentation

ILineFillFormat.FillType Property

[Visual Basic]
Property FillType As FillType
[C#]
FillType FillType {get; set;}

See Also

ILineFillFormat Interface | Aspose.Slides Namespace


GradientFormat Property

Aspose.Slides Documentation

ILineFillFormat.GradientFormat Property

[Visual Basic]
Property GradientFormat As IGradientFormat
[C#]
IGradientFormat GradientFormat {get;}

See Also

ILineFillFormat Interface | Aspose.Slides Namespace


PatternFormat Property

Aspose.Slides Documentation

ILineFillFormat.PatternFormat Property

[Visual Basic]
Property PatternFormat As IPatternFormat
[C#]
IPatternFormat PatternFormat {get;}

See Also

ILineFillFormat Interface | Aspose.Slides Namespace


RotateWithShape Property

Aspose.Slides Documentation

ILineFillFormat.RotateWithShape Property

[Visual Basic]
Property RotateWithShape As NullableBool
[C#]
NullableBool RotateWithShape {get; set;}

See Also

ILineFillFormat Interface | Aspose.Slides Namespace


SolidFillColor Property

Aspose.Slides Documentation

ILineFillFormat.SolidFillColor Property

[Visual Basic]
Property SolidFillColor As IColorFormat
[C#]
IColorFormat SolidFillColor {get;}

See Also

ILineFillFormat Interface | Aspose.Slides Namespace


ILineFillFormatEffectiveData Interface

For a list of all members of this type, see ILineFillFormatEffectiveData Members.

[Visual Basic]
Public Interface ILineFillFormatEffectiveData
Implements IFillParamSource
[C#]
public interface ILineFillFormatEffectiveData : IFillParamSource

Types that implement ILineFillFormatEffectiveData

Type | Description
LineFillFormatEffectiveData | Immutable object which represents properties for lines filling.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILineFillFormatEffectiveData Members | Aspose.Slides Namespace


ILineFillFormatEffectiveData Members

ILineFillFormatEffectiveData overview

Public Instance Properties

AsIFillParamSource
FillType
GradientFormat
PatternFormat
RotateWithShape
SolidFillColor

See Also

ILineFillFormatEffectiveData Interface | Aspose.Slides Namespace


ILineFillFormatEffectiveData Properties

The properties of the ILineFillFormatEffectiveData interface are listed below. For a complete list of ILineFillFormatEffectiveData interface members, see the ILineFillFormatEffectiveData Members topic.

Public Instance Properties

AsIFillParamSource
FillType
GradientFormat
PatternFormat
RotateWithShape
SolidFillColor

See Also

ILineFillFormatEffectiveData Interface | Aspose.Slides Namespace


AsIFillParamSource Property

Aspose.Slides Documentation

ILineFillFormatEffectiveData.AsIFillParamSource Property

[Visual Basic]
Property AsIFillParamSource As IFillParamSource
[C#]
IFillParamSource AsIFillParamSource {get;}

See Also

ILineFillFormatEffectiveData Interface | Aspose.Slides Namespace


FillType Property

Aspose.Slides Documentation

ILineFillFormatEffectiveData.FillType Property

[Visual Basic]
Property FillType As FillType
[C#]
FillType FillType {get;}

See Also

ILineFillFormatEffectiveData Interface | Aspose.Slides Namespace


GradientFormat Property

Aspose.Slides Documentation

ILineFillFormatEffectiveData.GradientFormat Property

[Visual Basic]
Property GradientFormat As IGradientFormatEffectiveData
[C#]
IGradientFormatEffectiveData GradientFormat {get;}

See Also

ILineFillFormatEffectiveData Interface | Aspose.Slides Namespace


PatternFormat Property

Aspose.Slides Documentation

ILineFillFormatEffectiveData.PatternFormat Property

[Visual Basic]
Property PatternFormat As IPatternFormatEffectiveData
[C#]
IPatternFormatEffectiveData PatternFormat {get;}

See Also

ILineFillFormatEffectiveData Interface | Aspose.Slides Namespace


RotateWithShape Property

Aspose.Slides Documentation

ILineFillFormatEffectiveData.RotateWithShape Property

[Visual Basic]
Property RotateWithShape As Boolean
[C#]
bool RotateWithShape {get;}

See Also

ILineFillFormatEffectiveData Interface | Aspose.Slides Namespace


SolidFillColor Property

Aspose.Slides Documentation

ILineFillFormatEffectiveData.SolidFillColor Property

[Visual Basic]
Property SolidFillColor As Color
[C#]
Color SolidFillColor {get;}

See Also

ILineFillFormatEffectiveData Interface | Aspose.Slides Namespace


ILineFormat Interface

For a list of all members of this type, see ILineFormat Members.

[Visual Basic]
Public Interface ILineFormat
Implements ISlideComponent, IPresentationComponent
[C#]
public interface ILineFormat : ISlideComponent, IPresentationComponent

Types that implement ILineFormat

Type | Description
LineFormat | Represents format of a line.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILineFormat Members | Aspose.Slides Namespace


ILineFormat Members

ILineFormat overview

Public Instance Properties

Alignment
AsISlideComponent
BeginArrowheadLength
BeginArrowheadStyle
BeginArrowheadWidth
CapStyle
CustomDashPattern
DashStyle
EndArrowheadLength
EndArrowheadStyle
EndArrowheadWidth
FillFormat
IsFormatNotDefined
JoinStyle
MiterLimit
Style
Width

Public Instance Methods

Equals

See Also

ILineFormat Interface | Aspose.Slides Namespace


ILineFormat Properties

The properties of the ILineFormat interface are listed below. For a complete list of ILineFormat interface members, see the ILineFormat Members topic.

Public Instance Properties

Alignment
AsISlideComponent
BeginArrowheadLength
BeginArrowheadStyle
BeginArrowheadWidth
CapStyle
CustomDashPattern
DashStyle
EndArrowheadLength
EndArrowheadStyle
EndArrowheadWidth
FillFormat
IsFormatNotDefined
JoinStyle
MiterLimit
Style
Width

See Also

ILineFormat Interface | Aspose.Slides Namespace


Alignment Property

Aspose.Slides Documentation

ILineFormat.Alignment Property

[Visual Basic]
Property Alignment As LineAlignment
[C#]
LineAlignment Alignment {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

ILineFormat.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


BeginArrowheadLength Property

Aspose.Slides Documentation

ILineFormat.BeginArrowheadLength Property

[Visual Basic]
Property BeginArrowheadLength As LineArrowheadLength
[C#]
LineArrowheadLength BeginArrowheadLength {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


BeginArrowheadStyle Property

Aspose.Slides Documentation

ILineFormat.BeginArrowheadStyle Property

[Visual Basic]
Property BeginArrowheadStyle As LineArrowheadStyle
[C#]
LineArrowheadStyle BeginArrowheadStyle {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


BeginArrowheadWidth Property

Aspose.Slides Documentation

ILineFormat.BeginArrowheadWidth Property

[Visual Basic]
Property BeginArrowheadWidth As LineArrowheadWidth
[C#]
LineArrowheadWidth BeginArrowheadWidth {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


CapStyle Property

Aspose.Slides Documentation

ILineFormat.CapStyle Property

[Visual Basic]
Property CapStyle As LineCapStyle
[C#]
LineCapStyle CapStyle {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


CustomDashPattern Property

Aspose.Slides Documentation

ILineFormat.CustomDashPattern Property

[Visual Basic]
Property CustomDashPattern As Single()
[C#]
float[] CustomDashPattern {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


DashStyle Property

Aspose.Slides Documentation

ILineFormat.DashStyle Property

[Visual Basic]
Property DashStyle As LineDashStyle
[C#]
LineDashStyle DashStyle {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


EndArrowheadLength Property

Aspose.Slides Documentation

ILineFormat.EndArrowheadLength Property

[Visual Basic]
Property EndArrowheadLength As LineArrowheadLength
[C#]
LineArrowheadLength EndArrowheadLength {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


EndArrowheadStyle Property

Aspose.Slides Documentation

ILineFormat.EndArrowheadStyle Property

[Visual Basic]
Property EndArrowheadStyle As LineArrowheadStyle
[C#]
LineArrowheadStyle EndArrowheadStyle {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


EndArrowheadWidth Property

Aspose.Slides Documentation

ILineFormat.EndArrowheadWidth Property

[Visual Basic]
Property EndArrowheadWidth As LineArrowheadWidth
[C#]
LineArrowheadWidth EndArrowheadWidth {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

ILineFormat.FillFormat Property

[Visual Basic]
Property FillFormat As ILineFillFormat
[C#]
ILineFillFormat FillFormat {get;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


IsFormatNotDefined Property

Aspose.Slides Documentation

ILineFormat.IsFormatNotDefined Property

[Visual Basic]
Property IsFormatNotDefined As Boolean
[C#]
bool IsFormatNotDefined {get;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


JoinStyle Property

Aspose.Slides Documentation

ILineFormat.JoinStyle Property

[Visual Basic]
Property JoinStyle As LineJoinStyle
[C#]
LineJoinStyle JoinStyle {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


MiterLimit Property

Aspose.Slides Documentation

ILineFormat.MiterLimit Property

[Visual Basic]
Property MiterLimit As Single
[C#]
float MiterLimit {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


Style Property

Aspose.Slides Documentation

ILineFormat.Style Property

[Visual Basic]
Property Style As LineStyle
[C#]
LineStyle Style {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

ILineFormat.Width Property

[Visual Basic]
Property Width As Double
[C#]
double Width {get; set;}

See Also

ILineFormat Interface | Aspose.Slides Namespace


ILineFormat Methods

The methods of the ILineFormat interface are listed below. For a complete list of ILineFormat interface members, see the ILineFormat Members topic.

Public Instance Methods

Equals

See Also

ILineFormat Interface | Aspose.Slides Namespace


ILineFormat.Equals Method

[Visual Basic]
Function Equals( _
ByVal lineFormat As ILineFormat _
) As Boolean
[C#]
bool Equals(
ILineFormat lineFormat
);

See Also

ILineFormat Interface | Aspose.Slides Namespace


ILineFormatEffectiveData Interface

For a list of all members of this type, see ILineFormatEffectiveData Members.

[Visual Basic]
Public Interface ILineFormatEffectiveData
[C#]
public interface ILineFormatEffectiveData

Types that implement ILineFormatEffectiveData

Type | Description
LineFormatEffectiveData | Immutable object which contains line properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILineFormatEffectiveData Members | Aspose.Slides Namespace


ILineFormatEffectiveData Members

ILineFormatEffectiveData overview

Public Instance Properties

Alignment
BeginArrowheadLength
BeginArrowheadStyle
BeginArrowheadWidth
CapStyle
CustomDashPattern
DashStyle
EndArrowheadLength
EndArrowheadStyle
EndArrowheadWidth
FillFormat
JoinStyle
MiterLimit
Style
Width

Public Instance Methods

Equals

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


ILineFormatEffectiveData Properties

The properties of the ILineFormatEffectiveData interface are listed below. For a complete list of ILineFormatEffectiveData interface members, see the ILineFormatEffectiveData Members topic.

Public Instance Properties

Alignment
BeginArrowheadLength
BeginArrowheadStyle
BeginArrowheadWidth
CapStyle
CustomDashPattern
DashStyle
EndArrowheadLength
EndArrowheadStyle
EndArrowheadWidth
FillFormat
JoinStyle
MiterLimit
Style
Width

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


Alignment Property

Aspose.Slides Documentation

ILineFormatEffectiveData.Alignment Property

[Visual Basic]
Property Alignment As LineAlignment
[C#]
LineAlignment Alignment {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


BeginArrowheadLength Property

Aspose.Slides Documentation

ILineFormatEffectiveData.BeginArrowheadLength Property

[Visual Basic]
Property BeginArrowheadLength As LineArrowheadLength
[C#]
LineArrowheadLength BeginArrowheadLength {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


BeginArrowheadStyle Property

Aspose.Slides Documentation

ILineFormatEffectiveData.BeginArrowheadStyle Property

[Visual Basic]
Property BeginArrowheadStyle As LineArrowheadStyle
[C#]
LineArrowheadStyle BeginArrowheadStyle {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


BeginArrowheadWidth Property

Aspose.Slides Documentation

ILineFormatEffectiveData.BeginArrowheadWidth Property

[Visual Basic]
Property BeginArrowheadWidth As LineArrowheadWidth
[C#]
LineArrowheadWidth BeginArrowheadWidth {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


CapStyle Property

Aspose.Slides Documentation

ILineFormatEffectiveData.CapStyle Property

[Visual Basic]
Property CapStyle As LineCapStyle
[C#]
LineCapStyle CapStyle {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


CustomDashPattern Property

Aspose.Slides Documentation

ILineFormatEffectiveData.CustomDashPattern Property

[Visual Basic]
Property CustomDashPattern As Single()
[C#]
float[] CustomDashPattern {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


DashStyle Property

Aspose.Slides Documentation

ILineFormatEffectiveData.DashStyle Property

[Visual Basic]
Property DashStyle As LineDashStyle
[C#]
LineDashStyle DashStyle {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


EndArrowheadLength Property

Aspose.Slides Documentation

ILineFormatEffectiveData.EndArrowheadLength Property

[Visual Basic]
Property EndArrowheadLength As LineArrowheadLength
[C#]
LineArrowheadLength EndArrowheadLength {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


EndArrowheadStyle Property

Aspose.Slides Documentation

ILineFormatEffectiveData.EndArrowheadStyle Property

[Visual Basic]
Property EndArrowheadStyle As LineArrowheadStyle
[C#]
LineArrowheadStyle EndArrowheadStyle {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


EndArrowheadWidth Property

Aspose.Slides Documentation

ILineFormatEffectiveData.EndArrowheadWidth Property

[Visual Basic]
Property EndArrowheadWidth As LineArrowheadWidth
[C#]
LineArrowheadWidth EndArrowheadWidth {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

ILineFormatEffectiveData.FillFormat Property

[Visual Basic]
Property FillFormat As ILineFillFormatEffectiveData
[C#]
ILineFillFormatEffectiveData FillFormat {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


JoinStyle Property

Aspose.Slides Documentation

ILineFormatEffectiveData.JoinStyle Property

[Visual Basic]
Property JoinStyle As LineJoinStyle
[C#]
LineJoinStyle JoinStyle {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


MiterLimit Property

Aspose.Slides Documentation

ILineFormatEffectiveData.MiterLimit Property

[Visual Basic]
Property MiterLimit As Single
[C#]
float MiterLimit {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


Style Property

Aspose.Slides Documentation

ILineFormatEffectiveData.Style Property

[Visual Basic]
Property Style As LineStyle
[C#]
LineStyle Style {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

ILineFormatEffectiveData.Width Property

[Visual Basic]
Property Width As Double
[C#]
double Width {get;}

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


ILineFormatEffectiveData Methods

The methods of the ILineFormatEffectiveData interface are listed below. For a complete list of ILineFormatEffectiveData interface members, see the ILineFormatEffectiveData Members topic.

Public Instance Methods

Equals

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


ILineFormatEffectiveData.Equals Method

[Visual Basic]
Function Equals( _
ByVal lf As ILineFormatEffectiveData _
) As Boolean
[C#]
bool Equals(
ILineFormatEffectiveData lf
);

See Also

ILineFormatEffectiveData Interface | Aspose.Slides Namespace


ILoadOptions Interface

For a list of all members of this type, see ILoadOptions Members.

[Visual Basic]
Public Interface ILoadOptions
[C#]
public interface ILoadOptions

Types that implement ILoadOptions

Type | Description
LoadOptions | Allows to specify additional options (such as format or default font) when loading a presentation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILoadOptions Members | Aspose.Slides Namespace


ILoadOptions Members

ILoadOptions overview

Public Instance Properties

DefaultAsianFont
DefaultRegularFont
DefaultSymbolFont
LoadFormat
OnlyLoadDocumentProperties
Password
WarningCallback

See Also

ILoadOptions Interface | Aspose.Slides Namespace


ILoadOptions Properties

The properties of the ILoadOptions interface are listed below. For a complete list of ILoadOptions interface members, see the ILoadOptions Members topic.

Public Instance Properties

DefaultAsianFont
DefaultRegularFont
DefaultSymbolFont
LoadFormat
OnlyLoadDocumentProperties
Password
WarningCallback

See Also

ILoadOptions Interface | Aspose.Slides Namespace


DefaultAsianFont Property

Aspose.Slides Documentation

ILoadOptions.DefaultAsianFont Property

[Visual Basic]
Property DefaultAsianFont As String
[C#]
string DefaultAsianFont {get; set;}

See Also

ILoadOptions Interface | Aspose.Slides Namespace


DefaultRegularFont Property

Aspose.Slides Documentation

ILoadOptions.DefaultRegularFont Property

[Visual Basic]
Property DefaultRegularFont As String
[C#]
string DefaultRegularFont {get; set;}

See Also

ILoadOptions Interface | Aspose.Slides Namespace


DefaultSymbolFont Property

Aspose.Slides Documentation

ILoadOptions.DefaultSymbolFont Property

[Visual Basic]
Property DefaultSymbolFont As String
[C#]
string DefaultSymbolFont {get; set;}

See Also

ILoadOptions Interface | Aspose.Slides Namespace


LoadFormat Property

Aspose.Slides Documentation

ILoadOptions.LoadFormat Property

[Visual Basic]
Property LoadFormat As LoadFormat
[C#]
LoadFormat LoadFormat {get; set;}

See Also

ILoadOptions Interface | Aspose.Slides Namespace


OnlyLoadDocumentProperties Property

Aspose.Slides Documentation

ILoadOptions.OnlyLoadDocumentProperties Property

[Visual Basic]
Property OnlyLoadDocumentProperties As Boolean
[C#]
bool OnlyLoadDocumentProperties {get; set;}

See Also

ILoadOptions Interface | Aspose.Slides Namespace


Password Property

Aspose.Slides Documentation

ILoadOptions.Password Property

[Visual Basic]
Property Password As String
[C#]
string Password {get; set;}

See Also

ILoadOptions Interface | Aspose.Slides Namespace


WarningCallback Property

Aspose.Slides Documentation

ILoadOptions.WarningCallback Property

[Visual Basic]
Property WarningCallback As IWarningCallback
[C#]
IWarningCallback WarningCallback {get; set;}

See Also

ILoadOptions Interface | Aspose.Slides Namespace


ImageCollection Class

Represents collection of PPImage.

For a list of all members of this type, see ImageCollection Members.

System.Object
Aspose.Slides.ImageCollection

[Visual Basic]
NotInheritable Public Class ImageCollection
Implements IImageCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IPPImage, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public sealed class ImageCollection : IImageCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ImageCollection Members | Aspose.Slides Namespace


ImageCollection Members

ImageCollection overview

Public Instance Properties

Count | Returns a number of images in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only PPImage.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

AddImage | Overloaded. Adds a copy of an image from an another presentation.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

ImageCollection Class | Aspose.Slides Namespace


ImageCollection Properties

The properties of the ImageCollection class are listed below. For a complete list of ImageCollection class members, see the ImageCollection Members topic.

Public Instance Properties

Count | Returns a number of images in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only PPImage.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

ImageCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

ImageCollection.Count Property

Returns a number of images in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

ImageCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

ImageCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ImageCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ImageCollection.Item Property

Gets the element at the specified index. Read-only PPImage.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IImageCollection.Item
As IPPImage _
Implements IImageCollection.Item
[C#]
public IPPImage this[
int index
] {get;}

Implements

IImageCollection.Item

See Also

ImageCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

ImageCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ImageCollection Class | Aspose.Slides Namespace


ImageCollection Methods

The methods of the ImageCollection class are listed below. For a complete list of ImageCollection class members, see the ImageCollection Members topic.

Public Instance Methods

AddImage | Overloaded. Adds a copy of an image from an another presentation.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

ImageCollection Class | Aspose.Slides Namespace


AddImage Method

Aspose.Slides Documentation

ImageCollection.AddImage Method

Adds a copy of an image from an another presentation.

Overload List

Adds a copy of an image from an another presentation.

public IPPImage AddImage(IPPImage);

public IPPImage AddImage(byte[]);

Add an image to a presentation.

public IPPImage AddImage(Image);

Add an image to a presentation from stream.

public IPPImage AddImage(MemoryStream);

Add an image to a presentation from stream.

public IPPImage AddImage(Stream);

See Also

ImageCollection Class | Aspose.Slides Namespace


ImageCollection.AddImage Method (IPPImage)

Adds a copy of an image from an another presentation.

[Visual Basic]
NotOverridable Overloads Public Function AddImage( _
ByVal imageSource As IPPImage _
) As IPPImage _
Implements IImageCollection.AddImage
[C#]
public IPPImage AddImage(
IPPImage imageSource
);

Parameters

imageSource
Source image.

Return Value

Added image.

Implements

IImageCollection.AddImage

See Also

ImageCollection Class | Aspose.Slides Namespace | ImageCollection.AddImage Overload List


ImageCollection.AddImage Method (Byte[])

[Visual Basic]
NotOverridable Overloads Public Function AddImage( _
ByVal buffer As Byte() _
) As IPPImage _
Implements IImageCollection.AddImage
[C#]
public IPPImage AddImage(
byte[] buffer
);

Implements

IImageCollection.AddImage

See Also

ImageCollection Class | Aspose.Slides Namespace | ImageCollection.AddImage Overload List


ImageCollection.AddImage Method (Image)

Add an image to a presentation.

[Visual Basic]
NotOverridable Overloads Public Function AddImage( _
ByVal image As Image _
) As IPPImage _
Implements IImageCollection.AddImage
[C#]
public IPPImage AddImage(
Image image
);

Parameters

image
Image to add.

Return Value

Added image.

Implements

IImageCollection.AddImage

Remarks

This method converts WMF/EMF metafiles to raster PNG image before inserting to a presentation.

See Also

ImageCollection Class | Aspose.Slides Namespace | ImageCollection.AddImage Overload List


ImageCollection.AddImage Method (MemoryStream)

Add an image to a presentation from stream.

[Visual Basic]
NotOverridable Overloads Public Function AddImage( _
ByVal stream As MemoryStream _
) As IPPImage _
Implements IImageCollection.AddImage
[C#]
public IPPImage AddImage(
MemoryStream stream
);

Parameters

stream
Stream to add image from.

Return Value

Added image.

Implements

IImageCollection.AddImage

Remarks

This method can add WMF/EMF metafiles to a presentation without converting them to raster PNG image.

See Also

ImageCollection Class | Aspose.Slides Namespace | ImageCollection.AddImage Overload List


ImageCollection.AddImage Method (Stream)

Add an image to a presentation from stream.

[Visual Basic]
NotOverridable Overloads Public Function AddImage( _
ByVal stream As Stream _
) As IPPImage _
Implements IImageCollection.AddImage
[C#]
public IPPImage AddImage(
Stream stream
);

Parameters

stream
Stream to add image from.

Return Value

Added image.

Implements

IImageCollection.AddImage

Remarks

This method can add WMF/EMF metafiles to a presentation without converting them to raster PNG image.

See Also

ImageCollection Class | Aspose.Slides Namespace | ImageCollection.AddImage Overload List


ImageCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

ImageCollection Class | Aspose.Slides Namespace


ImageCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

ImageCollection Class | Aspose.Slides Namespace


ImageWrapper Class

System.Drawing.Image wrapper for COM interface.

For a list of all members of this type, see ImageWrapper Members.

System.Object
Aspose.Slides.ImageWrapper

[Visual Basic]
Public Class ImageWrapper
Implements IImageWrapper, IDisposable
[C#]
public class ImageWrapper : IImageWrapper, IDisposable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ImageWrapper Members | Aspose.Slides Namespace


ImageWrapper Members

ImageWrapper overview

Public Instance Properties

Image | Gets Image
Size | Gets the width and height, in pixels, of the Image

Public Instance Methods

Dispose |
Save | Overloaded. Saves Image to the specified file

See Also

ImageWrapper Class | Aspose.Slides Namespace


ImageWrapper Properties

The properties of the ImageWrapper class are listed below. For a complete list of ImageWrapper class members, see the ImageWrapper Members topic.

Public Instance Properties

Image | Gets Image
Size | Gets the width and height, in pixels, of the Image

See Also

ImageWrapper Class | Aspose.Slides Namespace


Image Property

Aspose.Slides Documentation

ImageWrapper.Image Property

Gets Image

[Visual Basic]
NotOverridable Public ReadOnly Property Image As Image _
Implements IImageWrapper.Image
[C#]
public Image Image {get;}

Implements

IImageWrapper.Image

See Also

ImageWrapper Class | Aspose.Slides Namespace


Size Property

Aspose.Slides Documentation

ImageWrapper.Size Property

Gets the width and height, in pixels, of the Image

[Visual Basic]
NotOverridable Public ReadOnly Property Size As Size _
Implements IImageWrapper.Size
[C#]
public Size Size {get;}

Implements

IImageWrapper.Size

See Also

ImageWrapper Class | Aspose.Slides Namespace


ImageWrapper Methods

The methods of the ImageWrapper class are listed below. For a complete list of ImageWrapper class members, see the ImageWrapper Members topic.

Public Instance Methods

Dispose |
Save | Overloaded. Saves Image to the specified file

See Also

ImageWrapper Class | Aspose.Slides Namespace


ImageWrapper.Dispose Method

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

ImageWrapper Class | Aspose.Slides Namespace


Save Method

Aspose.Slides Documentation

ImageWrapper.Save Method

Saves the Image to the specified stream in the specified format.

Overload List

Saves the Image to the specified stream in the specified format.

public void Save(Stream,PPImageFormat);

Saves Image to the specified file

public void Save(string);

Saves the Image to the specified file in the specified format.

public void Save(string,PPImageFormat);

See Also

ImageWrapper Class | Aspose.Slides Namespace


ImageWrapper.Save Method (Stream, PPImageFormat)

Saves the Image to the specified stream in the specified format.

[Visual Basic]
NotOverridable Overloads Public Sub Save( _
ByVal stream As Stream, _
ByVal imageFormat As PPImageFormat _
) _
Implements IImageWrapper.Save
[C#]
public void Save(
Stream stream,
PPImageFormat imageFormat
);

Implements

IImageWrapper.Save

See Also

ImageWrapper Class | Aspose.Slides Namespace | ImageWrapper.Save Overload List


ImageWrapper.Save Method (String)

Saves Image to the specified file

[Visual Basic]
NotOverridable Overloads Public Sub Save( _
ByVal fileName As String _
) _
Implements IImageWrapper.Save
[C#]
public void Save(
string fileName
);

Implements

IImageWrapper.Save

See Also

ImageWrapper Class | Aspose.Slides Namespace | ImageWrapper.Save Overload List


ImageWrapper.Save Method (String, PPImageFormat)

Saves the Image to the specified file in the specified format.

[Visual Basic]
NotOverridable Overloads Public Sub Save( _
ByVal fileName As String, _
ByVal imageFormat As PPImageFormat _
) _
Implements IImageWrapper.Save
[C#]
public void Save(
string fileName,
PPImageFormat imageFormat
);

Implements

IImageWrapper.Save

See Also

ImageWrapper Class | Aspose.Slides Namespace | ImageWrapper.Save Overload List


ImageWrapperFactory Class

This class allows to initialize IBitmapWrapper.

For a list of all members of this type, see ImageWrapperFactory Members.

System.Object
Aspose.Slides.ImageWrapperFactory

[Visual Basic]
Public Class ImageWrapperFactory
Implements IImageWrapperFactory
[C#]
public class ImageWrapperFactory : IImageWrapperFactory

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ImageWrapperFactory Members | Aspose.Slides Namespace


ImageWrapperFactory Members

ImageWrapperFactory overview

Public Instance Constructors

ImageWrapperFactory Constructor Initializes a new instance of the ImageWrapperFactory class.

Public Instance Methods

CreateImageWrapper Overloaded. Initializes a new instance of the BitmapWrapper class from the specified existing image.

See Also

ImageWrapperFactory Class | Aspose.Slides Namespace


ImageWrapperFactory Constructor

Initializes a new instance of the ImageWrapperFactory class.

[Visual Basic]
Public Sub New()
[C#]
public ImageWrapperFactory();

See Also

ImageWrapperFactory Class | Aspose.Slides Namespace


ImageWrapperFactory Methods

The methods of the ImageWrapperFactory class are listed below. For a complete list of ImageWrapperFactory class members, see the ImageWrapperFactory Members topic.

Public Instance Methods

CreateImageWrapper Overloaded. Initializes a new instance of the BitmapWrapper class from the specified existing image.

See Also

ImageWrapperFactory Class | Aspose.Slides Namespace


CreateImageWrapper Method

Aspose.Slides Documentation

ImageWrapperFactory.CreateImageWrapper Method

Initializes a new instance of the BitmapWrapper class from the specified existing image.

Overload List

Initializes a new instance of the BitmapWrapper class from the specified existing image.

public IImageWrapper CreateImageWrapper(Image);

Initializes a new instance of the BitmapWrapper class from the specified data stream.

public IImageWrapper CreateImageWrapper(Stream);

Initializes a new instance of the BitmapWrapper class from the specified file.

public IImageWrapper CreateImageWrapper(string);

See Also

ImageWrapperFactory Class | Aspose.Slides Namespace


ImageWrapperFactory.CreateImageWrapper Method (Image)

Initializes a new instance of the BitmapWrapper class from the specified existing image.

[Visual Basic]
NotOverridable Overloads Public Function CreateImageWrapper( _
ByVal image As Image _
) As IImageWrapper _
Implements IImageWrapperFactory.CreateImageWrapper
[C#]
public IImageWrapper CreateImageWrapper(
Image image
);

Implements

IImageWrapperFactory.CreateImageWrapper

See Also

ImageWrapperFactory Class | Aspose.Slides Namespace | ImageWrapperFactory.CreateImageWrapper Overload List


ImageWrapperFactory.CreateImageWrapper Method (Stream)

Initializes a new instance of the BitmapWrapper class from the specified data stream.

[Visual Basic]
NotOverridable Overloads Public Function CreateImageWrapper( _
ByVal stream As Stream _
) As IImageWrapper _
Implements IImageWrapperFactory.CreateImageWrapper
[C#]
public IImageWrapper CreateImageWrapper(
Stream stream
);

Implements

IImageWrapperFactory.CreateImageWrapper

See Also

ImageWrapperFactory Class | Aspose.Slides Namespace | ImageWrapperFactory.CreateImageWrapper Overload List


ImageWrapperFactory.CreateImageWrapper Method (String)

Initializes a new instance of the BitmapWrapper class from the specified file.

[Visual Basic]
NotOverridable Overloads Public Function CreateImageWrapper( _
ByVal fileName As String _
) As IImageWrapper _
Implements IImageWrapperFactory.CreateImageWrapper
[C#]
public IImageWrapper CreateImageWrapper(
string fileName
);

Implements

IImageWrapperFactory.CreateImageWrapper

See Also

ImageWrapperFactory Class | Aspose.Slides Namespace | ImageWrapperFactory.CreateImageWrapper Overload List


IMasterHandoutSlide Interface

For a list of all members of this type, see IMasterHandoutSlide Members.

[Visual Basic]
Public Interface IMasterHandoutSlide
Implements IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent, IMasterThemeable
[C#]
public interface IMasterHandoutSlide : IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent, IMasterThemeable

Types that implement IMasterHandoutSlide

Type | Description
MasterHandoutSlide | Represents master slide for handouts.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMasterHandoutSlide Members | Aspose.Slides Namespace


IMasterHandoutSlide Members

IMasterHandoutSlide overview

Public Instance Properties

AsIBaseSlide
AsIMasterThemeable

See Also

IMasterHandoutSlide Interface | Aspose.Slides Namespace


IMasterHandoutSlide Properties

The properties of the IMasterHandoutSlide interface are listed below. For a complete list of IMasterHandoutSlide interface members, see the IMasterHandoutSlide Members topic.

Public Instance Properties

AsIBaseSlide
AsIMasterThemeable

See Also

IMasterHandoutSlide Interface | Aspose.Slides Namespace


AsIBaseSlide Property

Aspose.Slides Documentation

IMasterHandoutSlide.AsIBaseSlide Property

[Visual Basic]
Property AsIBaseSlide As IBaseSlide
[C#]
IBaseSlide AsIBaseSlide {get;}

See Also

IMasterHandoutSlide Interface | Aspose.Slides Namespace


AsIMasterThemeable Property

Aspose.Slides Documentation

IMasterHandoutSlide.AsIMasterThemeable Property

[Visual Basic]
Property AsIMasterThemeable As IMasterThemeable
[C#]
IMasterThemeable AsIMasterThemeable {get;}

See Also

IMasterHandoutSlide Interface | Aspose.Slides Namespace


IMasterHandoutSlideManager Interface

For a list of all members of this type, see IMasterHandoutSlideManager Members.

[Visual Basic]
Public Interface IMasterHandoutSlideManager
[C#]
public interface IMasterHandoutSlideManager

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMasterHandoutSlideManager Members | Aspose.Slides Namespace


IMasterHandoutSlideManager Members

IMasterHandoutSlideManager overview

Public Instance Properties

MasterHandoutSlide

Public Instance Methods

RemoveMasterHandoutSlide
SetDefaultMasterHandoutSlide

See Also

IMasterHandoutSlideManager Interface | Aspose.Slides Namespace


IMasterHandoutSlideManager Properties

The properties of the IMasterHandoutSlideManager interface are listed below. For a complete list of IMasterHandoutSlideManager interface members, see the IMasterHandoutSlideManager Members topic.

Public Instance Properties

MasterHandoutSlide

See Also

IMasterHandoutSlideManager Interface | Aspose.Slides Namespace


MasterHandoutSlide Property

Aspose.Slides Documentation

IMasterHandoutSlideManager.MasterHandoutSlide Property

[Visual Basic]
Property MasterHandoutSlide As IMasterHandoutSlide
[C#]
IMasterHandoutSlide MasterHandoutSlide {get;}

See Also

IMasterHandoutSlideManager Interface | Aspose.Slides Namespace


IMasterHandoutSlideManager Methods

The methods of the IMasterHandoutSlideManager interface are listed below. For a complete list of IMasterHandoutSlideManager interface members, see the IMasterHandoutSlideManager Members topic.

Public Instance Methods

RemoveMasterHandoutSlide
SetDefaultMasterHandoutSlide

See Also

IMasterHandoutSlideManager Interface | Aspose.Slides Namespace


IMasterHandoutSlideManager.RemoveMasterHandoutSlide Method

[Visual Basic]
Sub RemoveMasterHandoutSlide()
[C#]
void RemoveMasterHandoutSlide();

See Also

IMasterHandoutSlideManager Interface | Aspose.Slides Namespace


IMasterHandoutSlideManager.SetDefaultMasterHandoutSlide Method

[Visual Basic]
Function SetDefaultMasterHandoutSlide() As IMasterHandoutSlide
[C#]
IMasterHandoutSlide SetDefaultMasterHandoutSlide();

See Also

IMasterHandoutSlideManager Interface | Aspose.Slides Namespace


IMasterLayoutSlideCollection Interface

For a list of all members of this type, see IMasterLayoutSlideCollection Members.

[Visual Basic]
Public Interface IMasterLayoutSlideCollection
Implements ILayoutSlideCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ILayoutSlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IMasterLayoutSlideCollection : ILayoutSlideCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IMasterLayoutSlideCollection

Type | Description
MasterLayoutSlideCollection | Represents a collections of all layout slides of defined master slide. Extends LayoutSlideCollection class with methods for adding/inserting/removing/cloning/reordering layout slides in context of the individual collections of master's layout slides.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMasterLayoutSlideCollection Members | Aspose.Slides Namespace


IMasterLayoutSlideCollection Members

IMasterLayoutSlideCollection overview

Public Instance Methods

Add
AddClone
Insert
InsertClone
RemoveAt
Reorder

See Also

IMasterLayoutSlideCollection Interface | Aspose.Slides Namespace


IMasterLayoutSlideCollection Methods

The methods of the IMasterLayoutSlideCollection interface are listed below. For a complete list of IMasterLayoutSlideCollection interface members, see the IMasterLayoutSlideCollection Members topic.

Public Instance Methods

Add
AddClone
Insert
InsertClone
RemoveAt
Reorder

See Also

IMasterLayoutSlideCollection Interface | Aspose.Slides Namespace


IMasterLayoutSlideCollection.Add Method

[Visual Basic]
Function Add( _
ByVal layoutType As SlideLayoutType, _
ByVal layoutName As String _
) As ILayoutSlide
[C#]
ILayoutSlide Add(
SlideLayoutType layoutType,
string layoutName
);

See Also

IMasterLayoutSlideCollection Interface | Aspose.Slides Namespace


IMasterLayoutSlideCollection.AddClone Method

[Visual Basic]
Function AddClone( _
ByVal sourceLayout As ILayoutSlide _
) As ILayoutSlide
[C#]
ILayoutSlide AddClone(
ILayoutSlide sourceLayout
);

See Also

IMasterLayoutSlideCollection Interface | Aspose.Slides Namespace


IMasterLayoutSlideCollection.Insert Method

[Visual Basic]
Function Insert( _
ByVal index As Integer, _
ByVal layoutType As SlideLayoutType, _
ByVal layoutName As String _
) As ILayoutSlide
[C#]
ILayoutSlide Insert(
int index,
SlideLayoutType layoutType,
string layoutName
);

See Also

IMasterLayoutSlideCollection Interface | Aspose.Slides Namespace


IMasterLayoutSlideCollection.InsertClone Method

[Visual Basic]
Function InsertClone( _
ByVal index As Integer, _
ByVal sourceLayout As ILayoutSlide _
) As ILayoutSlide
[C#]
ILayoutSlide InsertClone(
int index,
ILayoutSlide sourceLayout
);

See Also

IMasterLayoutSlideCollection Interface | Aspose.Slides Namespace


IMasterLayoutSlideCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IMasterLayoutSlideCollection Interface | Aspose.Slides Namespace


IMasterLayoutSlideCollection.Reorder Method

[Visual Basic]
Sub Reorder( _
ByVal index As Integer, _
ByVal layoutSlide As ILayoutSlide _
)
[C#]
void Reorder(
int index,
ILayoutSlide layoutSlide
);

See Also

IMasterLayoutSlideCollection Interface | Aspose.Slides Namespace


IMasterNotesSlide Interface

For a list of all members of this type, see IMasterNotesSlide Members.

[Visual Basic]
Public Interface IMasterNotesSlide
Implements IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent, IMasterThemeable
[C#]
public interface IMasterNotesSlide : IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent, IMasterThemeable

Types that implement IMasterNotesSlide

Type | Description
MasterNotesSlide | Represents master slide for notes.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMasterNotesSlide Members | Aspose.Slides Namespace


IMasterNotesSlide Members

IMasterNotesSlide overview

Public Instance Properties

AsIBaseSlide
AsIMasterThemeable

See Also

IMasterNotesSlide Interface | Aspose.Slides Namespace


IMasterNotesSlide Properties

The properties of the IMasterNotesSlide interface are listed below. For a complete list of IMasterNotesSlide interface members, see the IMasterNotesSlide Members topic.

Public Instance Properties

AsIBaseSlide
AsIMasterThemeable

See Also

IMasterNotesSlide Interface | Aspose.Slides Namespace


AsIBaseSlide Property

Aspose.Slides Documentation

IMasterNotesSlide.AsIBaseSlide Property

[Visual Basic]
Property AsIBaseSlide As IBaseSlide
[C#]
IBaseSlide AsIBaseSlide {get;}

See Also

IMasterNotesSlide Interface | Aspose.Slides Namespace


AsIMasterThemeable Property

Aspose.Slides Documentation

IMasterNotesSlide.AsIMasterThemeable Property

[Visual Basic]
Property AsIMasterThemeable As IMasterThemeable
[C#]
IMasterThemeable AsIMasterThemeable {get;}

See Also

IMasterNotesSlide Interface | Aspose.Slides Namespace


IMasterNotesSlideManager Interface

For a list of all members of this type, see IMasterNotesSlideManager Members.

[Visual Basic]
Public Interface IMasterNotesSlideManager
[C#]
public interface IMasterNotesSlideManager

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMasterNotesSlideManager Members | Aspose.Slides Namespace


IMasterNotesSlideManager Members

IMasterNotesSlideManager overview

Public Instance Properties

MasterNotesSlide

Public Instance Methods

RemoveMasterNotesSlide
SetDefaultMasterNotesSlide

See Also

IMasterNotesSlideManager Interface | Aspose.Slides Namespace


IMasterNotesSlideManager Properties

The properties of the IMasterNotesSlideManager interface are listed below. For a complete list of IMasterNotesSlideManager interface members, see the IMasterNotesSlideManager Members topic.

Public Instance Properties

MasterNotesSlide

See Also

IMasterNotesSlideManager Interface | Aspose.Slides Namespace


MasterNotesSlide Property

Aspose.Slides Documentation

IMasterNotesSlideManager.MasterNotesSlide Property

[Visual Basic]
Property MasterNotesSlide As IMasterNotesSlide
[C#]
IMasterNotesSlide MasterNotesSlide {get;}

See Also

IMasterNotesSlideManager Interface | Aspose.Slides Namespace


IMasterNotesSlideManager Methods

The methods of the IMasterNotesSlideManager interface are listed below. For a complete list of IMasterNotesSlideManager interface members, see the IMasterNotesSlideManager Members topic.

Public Instance Methods

RemoveMasterNotesSlide
SetDefaultMasterNotesSlide

See Also

IMasterNotesSlideManager Interface | Aspose.Slides Namespace


IMasterNotesSlideManager.RemoveMasterNotesSlide Method

[Visual Basic]
Sub RemoveMasterNotesSlide()
[C#]
void RemoveMasterNotesSlide();

See Also

IMasterNotesSlideManager Interface | Aspose.Slides Namespace


IMasterNotesSlideManager.SetDefaultMasterNotesSlide Method

[Visual Basic]
Function SetDefaultMasterNotesSlide() As IMasterNotesSlide
[C#]
IMasterNotesSlide SetDefaultMasterNotesSlide();

See Also

IMasterNotesSlideManager Interface | Aspose.Slides Namespace


IMasterSlide Interface

For a list of all members of this type, see IMasterSlide Members.

[Visual Basic]
Public Interface IMasterSlide
Implements IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent, IMasterThemeable
[C#]
public interface IMasterSlide : IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent, IMasterThemeable

Types that implement IMasterSlide

Type | Description
MasterSlide | Represents a master slide in a presentation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMasterSlide Members | Aspose.Slides Namespace


IMasterSlide Members

IMasterSlide overview

Public Instance Properties

AsIBaseSlide
AsIMasterThemeable
BodyStyle
HasDependingSlides
LayoutSlides
OtherStyle
Preserve
TitleStyle

Public Instance Methods

GetDependingSlides

See Also

IMasterSlide Interface | Aspose.Slides Namespace


IMasterSlide Properties

The properties of the IMasterSlide interface are listed below. For a complete list of IMasterSlide interface members, see the IMasterSlide Members topic.

Public Instance Properties

AsIBaseSlide
AsIMasterThemeable
BodyStyle
HasDependingSlides
LayoutSlides
OtherStyle
Preserve
TitleStyle

See Also

IMasterSlide Interface | Aspose.Slides Namespace


AsIBaseSlide Property

Aspose.Slides Documentation

IMasterSlide.AsIBaseSlide Property

[Visual Basic]
Property AsIBaseSlide As IBaseSlide
[C#]
IBaseSlide AsIBaseSlide {get;}

See Also

IMasterSlide Interface | Aspose.Slides Namespace


AsIMasterThemeable Property

Aspose.Slides Documentation

IMasterSlide.AsIMasterThemeable Property

[Visual Basic]
Property AsIMasterThemeable As IMasterThemeable
[C#]
IMasterThemeable AsIMasterThemeable {get;}

See Also

IMasterSlide Interface | Aspose.Slides Namespace


BodyStyle Property

Aspose.Slides Documentation

IMasterSlide.BodyStyle Property

[Visual Basic]
Property BodyStyle As ITextStyle
[C#]
ITextStyle BodyStyle {get;}

See Also

IMasterSlide Interface | Aspose.Slides Namespace


HasDependingSlides Property

Aspose.Slides Documentation

IMasterSlide.HasDependingSlides Property

[Visual Basic]
Property HasDependingSlides As Boolean
[C#]
bool HasDependingSlides {get;}

See Also

IMasterSlide Interface | Aspose.Slides Namespace


LayoutSlides Property

Aspose.Slides Documentation

IMasterSlide.LayoutSlides Property

[Visual Basic]
Property LayoutSlides As IMasterLayoutSlideCollection
[C#]
IMasterLayoutSlideCollection LayoutSlides {get;}

See Also

IMasterSlide Interface | Aspose.Slides Namespace


OtherStyle Property

Aspose.Slides Documentation

IMasterSlide.OtherStyle Property

[Visual Basic]
Property OtherStyle As ITextStyle
[C#]
ITextStyle OtherStyle {get;}

See Also

IMasterSlide Interface | Aspose.Slides Namespace


Preserve Property

Aspose.Slides Documentation

IMasterSlide.Preserve Property

[Visual Basic]
Property Preserve As Boolean
[C#]
bool Preserve {get; set;}

See Also

IMasterSlide Interface | Aspose.Slides Namespace


TitleStyle Property

Aspose.Slides Documentation

IMasterSlide.TitleStyle Property

[Visual Basic]
Property TitleStyle As ITextStyle
[C#]
ITextStyle TitleStyle {get;}

See Also

IMasterSlide Interface | Aspose.Slides Namespace


IMasterSlide Methods

The methods of the IMasterSlide interface are listed below. For a complete list of IMasterSlide interface members, see the IMasterSlide Members topic.

Public Instance Methods

GetDependingSlides

See Also

IMasterSlide Interface | Aspose.Slides Namespace


IMasterSlide.GetDependingSlides Method

[Visual Basic]
Function GetDependingSlides() As ISlide()
[C#]
ISlide[] GetDependingSlides();

See Also

IMasterSlide Interface | Aspose.Slides Namespace


IMasterSlideCollection Interface

For a list of all members of this type, see IMasterSlideCollection Members.

[Visual Basic]
Public Interface IMasterSlideCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IMasterSlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IMasterSlideCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IMasterSlideCollection

Type | Description
MasterSlideCollection | Represents a collection of master slides.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMasterSlideCollection Members | Aspose.Slides Namespace


IMasterSlideCollection Members

IMasterSlideCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

AddClone
InsertClone
Remove
RemoveAt
RemoveUnused

See Also

IMasterSlideCollection Interface | Aspose.Slides Namespace


IMasterSlideCollection Properties

The properties of the IMasterSlideCollection interface are listed below. For a complete list of IMasterSlideCollection interface members, see the IMasterSlideCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IMasterSlideCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

IMasterSlideCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IMasterSlideCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IMasterSlideCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IMasterSlideCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IMasterSlideCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IMasterSlide
[C#]
IMasterSlide this[
int index
] {get;}

See Also

IMasterSlideCollection Interface | Aspose.Slides Namespace


IMasterSlideCollection Methods

The methods of the IMasterSlideCollection interface are listed below. For a complete list of IMasterSlideCollection interface members, see the IMasterSlideCollection Members topic.

Public Instance Methods

AddClone
InsertClone
Remove
RemoveAt
RemoveUnused

See Also

IMasterSlideCollection Interface | Aspose.Slides Namespace


IMasterSlideCollection.AddClone Method

[Visual Basic]
Function AddClone( _
ByVal sourceMaster As IMasterSlide _
) As IMasterSlide
[C#]
IMasterSlide AddClone(
IMasterSlide sourceMaster
);

See Also

IMasterSlideCollection Interface | Aspose.Slides Namespace


IMasterSlideCollection.InsertClone Method

[Visual Basic]
Function InsertClone( _
ByVal index As Integer, _
ByVal sourceMaster As IMasterSlide _
) As IMasterSlide
[C#]
IMasterSlide InsertClone(
int index,
IMasterSlide sourceMaster
);

See Also

IMasterSlideCollection Interface | Aspose.Slides Namespace


IMasterSlideCollection.Remove Method

[Visual Basic]
Sub Remove( _
ByVal value As IMasterSlide _
)
[C#]
void Remove(
IMasterSlide value
);

See Also

IMasterSlideCollection Interface | Aspose.Slides Namespace


IMasterSlideCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IMasterSlideCollection Interface | Aspose.Slides Namespace


IMasterSlideCollection.RemoveUnused Method

[Visual Basic]
Sub RemoveUnused( _
ByVal ignorePreserveField As Boolean _
)
[C#]
void RemoveUnused(
bool ignorePreserveField
);

See Also

IMasterSlideCollection Interface | Aspose.Slides Namespace


INotesSlide Interface

For a list of all members of this type, see INotesSlide Members.

[Visual Basic]
Public Interface INotesSlide
Implements IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent, IOverrideThemeable
[C#]
public interface INotesSlide : IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent, IOverrideThemeable

Types that implement INotesSlide

Type | Description
NotesSlide | Represents a notes slide in a presentation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

INotesSlide Members | Aspose.Slides Namespace


INotesSlide Members

INotesSlide overview

Public Instance Properties

AsIBaseSlide
AsIOverrideThemeable
NotesTextFrame
ParentSlide

Public Instance Methods

GetThumbnail Overloaded.

See Also

INotesSlide Interface | Aspose.Slides Namespace


INotesSlide Properties

The properties of the INotesSlide interface are listed below. For a complete list of INotesSlide interface members, see the INotesSlide Members topic.

Public Instance Properties

AsIBaseSlide
AsIOverrideThemeable
NotesTextFrame
ParentSlide

See Also

INotesSlide Interface | Aspose.Slides Namespace


AsIBaseSlide Property

Aspose.Slides Documentation

INotesSlide.AsIBaseSlide Property

[Visual Basic]
Property AsIBaseSlide As IBaseSlide
[C#]
IBaseSlide AsIBaseSlide {get;}

See Also

INotesSlide Interface | Aspose.Slides Namespace


AsIOverrideThemeable Property

Aspose.Slides Documentation

INotesSlide.AsIOverrideThemeable Property

[Visual Basic]
Property AsIOverrideThemeable As IOverrideThemeable
[C#]
IOverrideThemeable AsIOverrideThemeable {get;}

See Also

INotesSlide Interface | Aspose.Slides Namespace


NotesTextFrame Property

Aspose.Slides Documentation

INotesSlide.NotesTextFrame Property

[Visual Basic]
Property NotesTextFrame As ITextFrame
[C#]
ITextFrame NotesTextFrame {get;}

See Also

INotesSlide Interface | Aspose.Slides Namespace


ParentSlide Property

Aspose.Slides Documentation

INotesSlide.ParentSlide Property

[Visual Basic]
Property ParentSlide As ISlide
[C#]
ISlide ParentSlide {get;}

See Also

INotesSlide Interface | Aspose.Slides Namespace


INotesSlide Methods

The methods of the INotesSlide interface are listed below. For a complete list of INotesSlide interface members, see the INotesSlide Members topic.

Public Instance Methods

GetThumbnail Overloaded.

See Also

INotesSlide Interface | Aspose.Slides Namespace


GetThumbnail Method

Aspose.Slides Documentation

INotesSlide.GetThumbnail Method

Overload List

Bitmap GetThumbnail(Size);

Bitmap GetThumbnail(float,float);

See Also

INotesSlide Interface | Aspose.Slides Namespace


INotesSlide.GetThumbnail Method (Size)

[Visual Basic]
Function GetThumbnail( _
ByVal imageSize As Size _
) As Bitmap
[C#]
Bitmap GetThumbnail(
Size imageSize
);

See Also

INotesSlide Interface | Aspose.Slides Namespace | INotesSlide.GetThumbnail Overload List


INotesSlide.GetThumbnail Method (Single, Single)

[Visual Basic]
Function GetThumbnail( _
ByVal scaleX As Single, _
ByVal scaleY As Single _
) As Bitmap
[C#]
Bitmap GetThumbnail(
float scaleX,
float scaleY
);

See Also

INotesSlide Interface | Aspose.Slides Namespace | INotesSlide.GetThumbnail Overload List


InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException Members.

System.Object
System.Exception
Aspose.Slides.InvalidPasswordException

[Visual Basic]
Public Class InvalidPasswordException
Inherits Exception
[C#]
public class InvalidPasswordException : Exception

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

InvalidPasswordException Members | Aspose.Slides Namespace


InvalidPasswordException Members

InvalidPasswordException overview

Public Instance Constructors

InvalidPasswordException Overloaded. Initializes a new instance of the InvalidPasswordException class.

See Also

InvalidPasswordException Class | Aspose.Slides Namespace


InvalidPasswordException Constructor

Initializes a new instance of the InvalidPasswordException class.

Overload List

Initializes a new instance of the InvalidPasswordException class.

public InvalidPasswordException();

public InvalidPasswordException(string);

public InvalidPasswordException(string,Exception);

See Also

InvalidPasswordException Class | Aspose.Slides Namespace


InvalidPasswordException Constructor ()

Initializes a new instance of the InvalidPasswordException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InvalidPasswordException();

See Also

InvalidPasswordException Class | Aspose.Slides Namespace | InvalidPasswordException Constructor Overload List


InvalidPasswordException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public InvalidPasswordException(
string message
);

See Also

InvalidPasswordException Class | Aspose.Slides Namespace | InvalidPasswordException Constructor Overload List


InvalidPasswordException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public InvalidPasswordException(
string message,
Exception exception
);

See Also

InvalidPasswordException Class | Aspose.Slides Namespace | InvalidPasswordException Constructor Overload List


IOleObjectFrame Interface

For a list of all members of this type, see IOleObjectFrame Members.

[Visual Basic]
Public Interface IOleObjectFrame
Implements IGraphicalObject, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public interface IOleObjectFrame : IGraphicalObject, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer

Types that implement IOleObjectFrame

Type | Description
OleObjectFrame | Represents an OLE object on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IOleObjectFrame Members | Aspose.Slides Namespace


IOleObjectFrame Members

IOleObjectFrame overview

Public Instance Properties

AsIGraphicalObject
IsObjectIcon
IsObjectLink
LinkFileName
LinkPathLong
ObjectData
ObjectName
ObjectProgId
SubstitutePictureFormat
UpdateAutomatic

See Also

IOleObjectFrame Interface | Aspose.Slides Namespace


IOleObjectFrame Properties

The properties of the IOleObjectFrame interface are listed below. For a complete list of IOleObjectFrame interface members, see the IOleObjectFrame Members topic.

Public Instance Properties

AsIGraphicalObject
IsObjectIcon
IsObjectLink
LinkFileName
LinkPathLong
ObjectData
ObjectName
ObjectProgId
SubstitutePictureFormat
UpdateAutomatic

See Also

IOleObjectFrame Interface | Aspose.Slides Namespace


AsIGraphicalObject Property

Aspose.Slides Documentation

IOleObjectFrame.AsIGraphicalObject Property

[Visual Basic]
Property AsIGraphicalObject As IGraphicalObject
[C#]
IGraphicalObject AsIGraphicalObject {get;}

See Also

IOleObjectFrame Interface | Aspose.Slides Namespace


IsObjectIcon Property

Aspose.Slides Documentation

IOleObjectFrame.IsObjectIcon Property

[Visual Basic]
Property IsObjectIcon As Boolean
[C#]
bool IsObjectIcon {get; set;}

See Also

IOleObjectFrame Interface | Aspose.Slides Namespace


IsObjectLink Property

Aspose.Slides Documentation

IOleObjectFrame.IsObjectLink Property

[Visual Basic]
Property IsObjectLink As Boolean
[C#]
bool IsObjectLink {get;}

See Also

IOleObjectFrame Interface | Aspose.Slides Namespace


LinkFileName Property

Aspose.Slides Documentation

IOleObjectFrame.LinkFileName Property

[Visual Basic]
Property LinkFileName As String
[C#]
string LinkFileName {get;}

See Also

IOleObjectFrame Interface | Aspose.Slides Namespace


LinkPathLong Property

Aspose.Slides Documentation

IOleObjectFrame.LinkPathLong Property

[Visual Basic]
Property LinkPathLong As String
[C#]
string LinkPathLong {get; set;}

See Also

IOleObjectFrame Interface | Aspose.Slides Namespace


ObjectData Property

Aspose.Slides Documentation

IOleObjectFrame.ObjectData Property

[Visual Basic]
Property ObjectData As Byte()
[C#]
byte[] ObjectData {get; set;}

See Also

IOleObjectFrame Interface | Aspose.Slides Namespace


ObjectName Property

Aspose.Slides Documentation

IOleObjectFrame.ObjectName Property

[Visual Basic]
Property ObjectName As String
[C#]
string ObjectName {get; set;}

See Also

IOleObjectFrame Interface | Aspose.Slides Namespace


ObjectProgId Property

Aspose.Slides Documentation

IOleObjectFrame.ObjectProgId Property

[Visual Basic]
Property ObjectProgId As String
[C#]
string ObjectProgId {get; set;}

See Also

IOleObjectFrame Interface | Aspose.Slides Namespace


SubstitutePictureFormat Property

Aspose.Slides Documentation

IOleObjectFrame.SubstitutePictureFormat Property

[Visual Basic]
Property SubstitutePictureFormat As IPictureFillFormat
[C#]
IPictureFillFormat SubstitutePictureFormat {get;}

See Also

IOleObjectFrame Interface | Aspose.Slides Namespace


UpdateAutomatic Property

Aspose.Slides Documentation

IOleObjectFrame.UpdateAutomatic Property

[Visual Basic]
Property UpdateAutomatic As Boolean
[C#]
bool UpdateAutomatic {get; set;}

See Also

IOleObjectFrame Interface | Aspose.Slides Namespace


IParagraph Interface

For a list of all members of this type, see IParagraph Members.

[Visual Basic]
Public Interface IParagraph
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IParagraph : ISlideComponent, IPresentationComponent

Types that implement IParagraph

Type | Description
Paragraph | Represents a paragraph of text.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IParagraph Members | Aspose.Slides Namespace


IParagraph Members

IParagraph overview

Public Instance Properties

AsISlideComponent
ParagraphFormat
Portions
Text

Public Instance Methods

CreateParagraphFormatEffective

See Also

IParagraph Interface | Aspose.Slides Namespace


IParagraph Properties

The properties of the IParagraph interface are listed below. For a complete list of IParagraph interface members, see the IParagraph Members topic.

Public Instance Properties

AsISlideComponent
ParagraphFormat
Portions
Text

See Also

IParagraph Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IParagraph.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IParagraph Interface | Aspose.Slides Namespace


ParagraphFormat Property

Aspose.Slides Documentation

IParagraph.ParagraphFormat Property

[Visual Basic]
Property ParagraphFormat As IParagraphFormat
[C#]
IParagraphFormat ParagraphFormat {get;}

See Also

IParagraph Interface | Aspose.Slides Namespace


Portions Property

Aspose.Slides Documentation

IParagraph.Portions Property

[Visual Basic]
Property Portions As IPortionCollection
[C#]
IPortionCollection Portions {get;}

See Also

IParagraph Interface | Aspose.Slides Namespace


Text Property

Aspose.Slides Documentation

IParagraph.Text Property

[Visual Basic]
Property Text As String
[C#]
string Text {get; set;}

See Also

IParagraph Interface | Aspose.Slides Namespace


IParagraph Methods

The methods of the IParagraph interface are listed below. For a complete list of IParagraph interface members, see the IParagraph Members topic.

Public Instance Methods

CreateParagraphFormatEffective

See Also

IParagraph Interface | Aspose.Slides Namespace


IParagraph.CreateParagraphFormatEffective Method

[Visual Basic]
Function CreateParagraphFormatEffective() As IParagraphFormatEffectiveData
[C#]
IParagraphFormatEffectiveData CreateParagraphFormatEffective();

See Also

IParagraph Interface | Aspose.Slides Namespace


IParagraphCollection Interface

For a list of all members of this type, see IParagraphCollection Members.

[Visual Basic]
Public Interface IParagraphCollection
Implements IEnumerable`1([Aspose.Slides.IParagraph, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable, ISlideComponent, IPresentationComponent
[C#]
public interface IParagraphCollection : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable, ISlideComponent, IPresentationComponent

Types that implement IParagraphCollection

Type | Description
ParagraphCollection | Represents a collection of a paragraphs.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IParagraphCollection Members | Aspose.Slides Namespace


IParagraphCollection Members

IParagraphCollection overview

Public Instance Properties

AsIEnumerable
AsISlideComponent
Count
Item

Public Instance Methods

Add | Overloaded.
AddFromHtml | Overloaded.
Clear |
ExportToHtml |
Insert | Overloaded.
Remove |
RemoveAt |

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


IParagraphCollection Properties

The properties of the IParagraphCollection interface are listed below. For a complete list of IParagraphCollection interface members, see the IParagraphCollection Members topic.

Public Instance Properties

AsIEnumerable
AsISlideComponent
Count
Item

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IParagraphCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IParagraphCollection.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

IParagraphCollection.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IParagraphCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IParagraph
[C#]
IParagraph this[
int index
] {get;}

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


IParagraphCollection Methods

The methods of the IParagraphCollection interface are listed below. For a complete list of IParagraphCollection interface members, see the IParagraphCollection Members topic.

Public Instance Methods

Add | Overloaded.
AddFromHtml | Overloaded.
Clear |
ExportToHtml |
Insert | Overloaded.
Remove |
RemoveAt |

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


Add Method

Aspose.Slides Documentation

IParagraphCollection.Add Method

Overload List

void Add(IParagraph);

int Add(IParagraphCollection);

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


IParagraphCollection.Add Method (IParagraph)

[Visual Basic]
Sub Add( _
ByVal value As IParagraph _
)
[C#]
void Add(
IParagraph value
);

See Also

IParagraphCollection Interface | Aspose.Slides Namespace | IParagraphCollection.Add Overload List


IParagraphCollection.Add Method (IParagraphCollection)

[Visual Basic]
Function Add( _
ByVal value As IParagraphCollection _
) As Integer
[C#]
int Add(
IParagraphCollection value
);

See Also

IParagraphCollection Interface | Aspose.Slides Namespace | IParagraphCollection.Add Overload List


AddFromHtml Method

Aspose.Slides Documentation

IParagraphCollection.AddFromHtml Method

Overload List

void AddFromHtml(string);

void AddFromHtml(string,IHtmlExternalResolver,string);

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


IParagraphCollection.AddFromHtml Method (String)

[Visual Basic]
Sub AddFromHtml( _
ByVal text As String _
)
[C#]
void AddFromHtml(
string text
);

See Also

IParagraphCollection Interface | Aspose.Slides Namespace | IParagraphCollection.AddFromHtml Overload List


IParagraphCollection.AddFromHtml Method (String, IHtmlExternalResolver, String)

[Visual Basic]
Sub AddFromHtml( _
ByVal text As String, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
)
[C#]
void AddFromHtml(
string text,
IHtmlExternalResolver resolver,
string uri
);

See Also

IParagraphCollection Interface | Aspose.Slides Namespace | IParagraphCollection.AddFromHtml Overload List


IParagraphCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


IParagraphCollection.ExportToHtml Method

[Visual Basic]
Function ExportToHtml( _
ByVal firstParagraphIndex As Integer, _
ByVal paragraphsCount As Integer, _
ByVal options As ITextToHtmlConversionOptions _
) As String
[C#]
string ExportToHtml(
int firstParagraphIndex,
int paragraphsCount,
ITextToHtmlConversionOptions options
);

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


Insert Method

Aspose.Slides Documentation

IParagraphCollection.Insert Method

Overload List

void Insert(int,IParagraph);

void Insert(int,IParagraphCollection);

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


IParagraphCollection.Insert Method (Int32, IParagraph)

[Visual Basic]
Sub Insert( _
ByVal index As Integer, _
ByVal value As IParagraph _
)
[C#]
void Insert(
int index,
IParagraph value
);

See Also

IParagraphCollection Interface | Aspose.Slides Namespace | IParagraphCollection.Insert Overload List


IParagraphCollection.Insert Method (Int32, IParagraphCollection)

[Visual Basic]
Sub Insert( _
ByVal index As Integer, _
ByVal value As IParagraphCollection _
)
[C#]
void Insert(
int index,
IParagraphCollection value
);

See Also

IParagraphCollection Interface | Aspose.Slides Namespace | IParagraphCollection.Insert Overload List


IParagraphCollection.Remove Method

[Visual Basic]
Function Remove( _
ByVal item As IParagraph _
) As Boolean
[C#]
bool Remove(
IParagraph item
);

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


IParagraphCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IParagraphCollection Interface | Aspose.Slides Namespace


IParagraphFactory Interface

For a list of all members of this type, see IParagraphFactory Members.

[Visual Basic]
Public Interface IParagraphFactory
[C#]
public interface IParagraphFactory

Types that implement IParagraphFactory

Type | Description
ParagraphFactory | Allows to create paragraphs

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IParagraphFactory Members | Aspose.Slides Namespace


IParagraphFactory Members

IParagraphFactory overview

Public Instance Methods

CreateParagraph Overloaded.

See Also

IParagraphFactory Interface | Aspose.Slides Namespace


IParagraphFactory Methods

The methods of the IParagraphFactory interface are listed below. For a complete list of IParagraphFactory interface members, see the IParagraphFactory Members topic.

Public Instance Methods

CreateParagraph Overloaded.

See Also

IParagraphFactory Interface | Aspose.Slides Namespace


CreateParagraph Method

Aspose.Slides Documentation

IParagraphFactory.CreateParagraph Method

Overload List

IParagraph CreateParagraph();

IParagraph CreateParagraph(IParagraph);

See Also

IParagraphFactory Interface | Aspose.Slides Namespace


IParagraphFactory.CreateParagraph Method ()

[Visual Basic]
Function CreateParagraph() As IParagraph
[C#]
IParagraph CreateParagraph();

See Also

IParagraphFactory Interface | Aspose.Slides Namespace | IParagraphFactory.CreateParagraph Overload List


IParagraphFactory.CreateParagraph Method (IParagraph)

[Visual Basic]
Function CreateParagraph( _
ByVal paragraph As IParagraph _
) As IParagraph
[C#]
IParagraph CreateParagraph(
IParagraph paragraph
);

See Also

IParagraphFactory Interface | Aspose.Slides Namespace | IParagraphFactory.CreateParagraph Overload List


IParagraphFormat Interface

For a list of all members of this type, see IParagraphFormat Members.

[Visual Basic]
Public Interface IParagraphFormat
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IParagraphFormat : ISlideComponent, IPresentationComponent

Types that implement IParagraphFormat

Type | Description
ParagraphFormat | This class contains the paragraph formatting properties. Unlike ParagraphFormatEffectiveData, all properties of this class are writeable.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IParagraphFormat Members | Aspose.Slides Namespace


IParagraphFormat Members

IParagraphFormat overview

Public Instance Properties

Alignment
AsISlideComponent
Bullet
DefaultPortionFormat
DefaultTabSize
Depth
EastAsianLineBreak
FontAlignment
HangingPunctuation
Indent
LatinLineBreak
MarginLeft
MarginRight
RightToLeft
SpaceAfter
SpaceBefore
SpaceWithin
Tabs

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


IParagraphFormat Properties

The properties of the IParagraphFormat interface are listed below. For a complete list of IParagraphFormat interface members, see the IParagraphFormat Members topic.

Public Instance Properties

Alignment
AsISlideComponent
Bullet
DefaultPortionFormat
DefaultTabSize
Depth
EastAsianLineBreak
FontAlignment
HangingPunctuation
Indent
LatinLineBreak
MarginLeft
MarginRight
RightToLeft
SpaceAfter
SpaceBefore
SpaceWithin
Tabs

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


Alignment Property

Aspose.Slides Documentation

IParagraphFormat.Alignment Property

[Visual Basic]
Property Alignment As TextAlignment
[C#]
TextAlignment Alignment {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IParagraphFormat.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


Bullet Property

Aspose.Slides Documentation

IParagraphFormat.Bullet Property

[Visual Basic]
Property Bullet As IBulletFormat
[C#]
IBulletFormat Bullet {get;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


DefaultPortionFormat Property

Aspose.Slides Documentation

IParagraphFormat.DefaultPortionFormat Property

[Visual Basic]
Property DefaultPortionFormat As IPortionFormat
[C#]
IPortionFormat DefaultPortionFormat {get;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


DefaultTabSize Property

Aspose.Slides Documentation

IParagraphFormat.DefaultTabSize Property

[Visual Basic]
Property DefaultTabSize As Single
[C#]
float DefaultTabSize {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


Depth Property

Aspose.Slides Documentation

IParagraphFormat.Depth Property

[Visual Basic]
Property Depth As Short
[C#]
short Depth {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


EastAsianLineBreak Property

Aspose.Slides Documentation

IParagraphFormat.EastAsianLineBreak Property

[Visual Basic]
Property EastAsianLineBreak As NullableBool
[C#]
NullableBool EastAsianLineBreak {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


FontAlignment Property

Aspose.Slides Documentation

IParagraphFormat.FontAlignment Property

[Visual Basic]
Property FontAlignment As FontAlignment
[C#]
FontAlignment FontAlignment {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


HangingPunctuation Property

Aspose.Slides Documentation

IParagraphFormat.HangingPunctuation Property

[Visual Basic]
Property HangingPunctuation As NullableBool
[C#]
NullableBool HangingPunctuation {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


Indent Property

Aspose.Slides Documentation

IParagraphFormat.Indent Property

[Visual Basic]
Property Indent As Single
[C#]
float Indent {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


LatinLineBreak Property

Aspose.Slides Documentation

IParagraphFormat.LatinLineBreak Property

[Visual Basic]
Property LatinLineBreak As NullableBool
[C#]
NullableBool LatinLineBreak {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


MarginLeft Property

Aspose.Slides Documentation

IParagraphFormat.MarginLeft Property

[Visual Basic]
Property MarginLeft As Single
[C#]
float MarginLeft {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


MarginRight Property

Aspose.Slides Documentation

IParagraphFormat.MarginRight Property

[Visual Basic]
Property MarginRight As Single
[C#]
float MarginRight {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


RightToLeft Property

Aspose.Slides Documentation

IParagraphFormat.RightToLeft Property

[Visual Basic]
Property RightToLeft As NullableBool
[C#]
NullableBool RightToLeft {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


SpaceAfter Property

Aspose.Slides Documentation

IParagraphFormat.SpaceAfter Property

[Visual Basic]
Property SpaceAfter As Single
[C#]
float SpaceAfter {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


SpaceBefore Property

Aspose.Slides Documentation

IParagraphFormat.SpaceBefore Property

[Visual Basic]
Property SpaceBefore As Single
[C#]
float SpaceBefore {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


SpaceWithin Property

Aspose.Slides Documentation

IParagraphFormat.SpaceWithin Property

[Visual Basic]
Property SpaceWithin As Single
[C#]
float SpaceWithin {get; set;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


Tabs Property

Aspose.Slides Documentation

IParagraphFormat.Tabs Property

[Visual Basic]
Property Tabs As ITabCollection
[C#]
ITabCollection Tabs {get;}

See Also

IParagraphFormat Interface | Aspose.Slides Namespace


IParagraphFormatEffectiveData Interface

For a list of all members of this type, see IParagraphFormatEffectiveData Members.

[Visual Basic]
Public Interface IParagraphFormatEffectiveData
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IParagraphFormatEffectiveData : ISlideComponent, IPresentationComponent

Types that implement IParagraphFormatEffectiveData

Type | Description
ParagraphFormatEffectiveData | Immutable object which contains paragraph formatting properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IParagraphFormatEffectiveData Members | Aspose.Slides Namespace


IParagraphFormatEffectiveData Members

IParagraphFormatEffectiveData overview

Public Instance Properties

Alignment
AsISlideComponent
Bullet
DefaultPortionFormat
DefaultTabSize
Depth
EastAsianLineBreak
FontAlignment
HangingPunctuation
Indent
LatinLineBreak
MarginLeft
MarginRight
RightToLeft
SpaceAfter
SpaceBefore
SpaceWithin
Tabs

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


IParagraphFormatEffectiveData Properties

The properties of the IParagraphFormatEffectiveData interface are listed below. For a complete list of IParagraphFormatEffectiveData interface members, see the IParagraphFormatEffectiveData Members topic.

Public Instance Properties

Alignment
AsISlideComponent
Bullet
DefaultPortionFormat
DefaultTabSize
Depth
EastAsianLineBreak
FontAlignment
HangingPunctuation
Indent
LatinLineBreak
MarginLeft
MarginRight
RightToLeft
SpaceAfter
SpaceBefore
SpaceWithin
Tabs

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


Alignment Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.Alignment Property

[Visual Basic]
Property Alignment As TextAlignment
[C#]
TextAlignment Alignment {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


Bullet Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.Bullet Property

[Visual Basic]
Property Bullet As IBulletFormatEffectiveData
[C#]
IBulletFormatEffectiveData Bullet {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


DefaultPortionFormat Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.DefaultPortionFormat Property

[Visual Basic]
Property DefaultPortionFormat As IPortionFormatEffectiveData
[C#]
IPortionFormatEffectiveData DefaultPortionFormat {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


DefaultTabSize Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.DefaultTabSize Property

[Visual Basic]
Property DefaultTabSize As Single
[C#]
float DefaultTabSize {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


Depth Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.Depth Property

[Visual Basic]
Property Depth As Short
[C#]
short Depth {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


EastAsianLineBreak Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.EastAsianLineBreak Property

[Visual Basic]
Property EastAsianLineBreak As Boolean
[C#]
bool EastAsianLineBreak {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


FontAlignment Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.FontAlignment Property

[Visual Basic]
Property FontAlignment As FontAlignment
[C#]
FontAlignment FontAlignment {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


HangingPunctuation Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.HangingPunctuation Property

[Visual Basic]
Property HangingPunctuation As Boolean
[C#]
bool HangingPunctuation {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


Indent Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.Indent Property

[Visual Basic]
Property Indent As Single
[C#]
float Indent {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


LatinLineBreak Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.LatinLineBreak Property

[Visual Basic]
Property LatinLineBreak As Boolean
[C#]
bool LatinLineBreak {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


MarginLeft Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.MarginLeft Property

[Visual Basic]
Property MarginLeft As Single
[C#]
float MarginLeft {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


MarginRight Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.MarginRight Property

[Visual Basic]
Property MarginRight As Single
[C#]
float MarginRight {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


RightToLeft Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.RightToLeft Property

[Visual Basic]
Property RightToLeft As Boolean
[C#]
bool RightToLeft {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


SpaceAfter Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.SpaceAfter Property

[Visual Basic]
Property SpaceAfter As Single
[C#]
float SpaceAfter {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


SpaceBefore Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.SpaceBefore Property

[Visual Basic]
Property SpaceBefore As Single
[C#]
float SpaceBefore {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


SpaceWithin Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.SpaceWithin Property

[Visual Basic]
Property SpaceWithin As Single
[C#]
float SpaceWithin {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


Tabs Property

Aspose.Slides Documentation

IParagraphFormatEffectiveData.Tabs Property

[Visual Basic]
Property Tabs As ITabEffectiveData()
[C#]
ITabEffectiveData[] Tabs {get;}

See Also

IParagraphFormatEffectiveData Interface | Aspose.Slides Namespace


IPatternFormat Interface

For a list of all members of this type, see IPatternFormat Members.

[Visual Basic]
Public Interface IPatternFormat
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IPatternFormat : ISlideComponent, IPresentationComponent

Types that implement IPatternFormat

Type | Description
PatternFormat | Represents a pattern to fill a shape.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPatternFormat Members | Aspose.Slides Namespace


IPatternFormat Members

IPatternFormat overview

Public Instance Properties

AsISlideComponent
BackColor
ForeColor
PatternStyle

Public Instance Methods

GetTileImage Overloaded.

See Also

IPatternFormat Interface | Aspose.Slides Namespace


IPatternFormat Properties

The properties of the IPatternFormat interface are listed below. For a complete list of IPatternFormat interface members, see the IPatternFormat Members topic.

Public Instance Properties

AsISlideComponent
BackColor
ForeColor
PatternStyle

See Also

IPatternFormat Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IPatternFormat.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IPatternFormat Interface | Aspose.Slides Namespace


BackColor Property

Aspose.Slides Documentation

IPatternFormat.BackColor Property

[Visual Basic]
Property BackColor As IColorFormat
[C#]
IColorFormat BackColor {get;}

See Also

IPatternFormat Interface | Aspose.Slides Namespace


ForeColor Property

Aspose.Slides Documentation

IPatternFormat.ForeColor Property

[Visual Basic]
Property ForeColor As IColorFormat
[C#]
IColorFormat ForeColor {get;}

See Also

IPatternFormat Interface | Aspose.Slides Namespace


PatternStyle Property

Aspose.Slides Documentation

IPatternFormat.PatternStyle Property

[Visual Basic]
Property PatternStyle As PatternStyle
[C#]
PatternStyle PatternStyle {get; set;}

See Also

IPatternFormat Interface | Aspose.Slides Namespace


IPatternFormat Methods

The methods of the IPatternFormat interface are listed below. For a complete list of IPatternFormat interface members, see the IPatternFormat Members topic.

Public Instance Methods

GetTileImage Overloaded.

See Also

IPatternFormat Interface | Aspose.Slides Namespace


GetTileImage Method

Aspose.Slides Documentation

IPatternFormat.GetTileImage Method

Overload List

Bitmap GetTileImage(Color);

Bitmap GetTileImage(Color,Color);

See Also

IPatternFormat Interface | Aspose.Slides Namespace


IPatternFormat.GetTileImage Method (Color)

[Visual Basic]
Function GetTileImage( _
ByVal styleColor As Color _
) As Bitmap
[C#]
Bitmap GetTileImage(
Color styleColor
);

See Also

IPatternFormat Interface | Aspose.Slides Namespace | IPatternFormat.GetTileImage Overload List


IPatternFormat.GetTileImage Method (Color, Color)

[Visual Basic]
Function GetTileImage( _
ByVal background As Color, _
ByVal foreground As Color _
) As Bitmap
[C#]
Bitmap GetTileImage(
Color background,
Color foreground
);

See Also

IPatternFormat Interface | Aspose.Slides Namespace | IPatternFormat.GetTileImage Overload List


IPatternFormatEffectiveData Interface

For a list of all members of this type, see IPatternFormatEffectiveData Members.

[Visual Basic]
Public Interface IPatternFormatEffectiveData
[C#]
public interface IPatternFormatEffectiveData

Types that implement IPatternFormatEffectiveData

Type | Description
PatternFormatEffectiveData | Immutable object which represents a pattern to fill a shape.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPatternFormatEffectiveData Members | Aspose.Slides Namespace


IPatternFormatEffectiveData Members

IPatternFormatEffectiveData overview

Public Instance Properties

BackColor
ForeColor
PatternStyle

Public Instance Methods

GetTileImage

See Also

IPatternFormatEffectiveData Interface | Aspose.Slides Namespace


IPatternFormatEffectiveData Properties

The properties of the IPatternFormatEffectiveData interface are listed below. For a complete list of IPatternFormatEffectiveData interface members, see the IPatternFormatEffectiveData Members topic.

Public Instance Properties

BackColor
ForeColor
PatternStyle

See Also

IPatternFormatEffectiveData Interface | Aspose.Slides Namespace


BackColor Property

Aspose.Slides Documentation

IPatternFormatEffectiveData.BackColor Property

[Visual Basic]
Property BackColor As Color
[C#]
Color BackColor {get;}

See Also

IPatternFormatEffectiveData Interface | Aspose.Slides Namespace


ForeColor Property

Aspose.Slides Documentation

IPatternFormatEffectiveData.ForeColor Property

[Visual Basic]
Property ForeColor As Color
[C#]
Color ForeColor {get;}

See Also

IPatternFormatEffectiveData Interface | Aspose.Slides Namespace


PatternStyle Property

Aspose.Slides Documentation

IPatternFormatEffectiveData.PatternStyle Property

[Visual Basic]
Property PatternStyle As PatternStyle
[C#]
PatternStyle PatternStyle {get;}

See Also

IPatternFormatEffectiveData Interface | Aspose.Slides Namespace


IPatternFormatEffectiveData Methods

The methods of the IPatternFormatEffectiveData interface are listed below. For a complete list of IPatternFormatEffectiveData interface members, see the IPatternFormatEffectiveData Members topic.

Public Instance Methods

GetTileImage

See Also

IPatternFormatEffectiveData Interface | Aspose.Slides Namespace


IPatternFormatEffectiveData.GetTileImage Method

[Visual Basic]
Function GetTileImage( _
ByVal background As Color, _
ByVal foreground As Color _
) As Bitmap
[C#]
Bitmap GetTileImage(
Color background,
Color foreground
);

See Also

IPatternFormatEffectiveData Interface | Aspose.Slides Namespace


IPictureEffectiveData Interface

For a list of all members of this type, see IPictureEffectiveData Members.

[Visual Basic]
Public Interface IPictureEffectiveData
[C#]
public interface IPictureEffectiveData

Types that implement IPictureEffectiveData

Type | Description
PictureEffectiveData | Immutable object which represents a picture in a presentation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPictureEffectiveData Members | Aspose.Slides Namespace


IPictureEffectiveData Members

IPictureEffectiveData overview

Public Instance Properties

Image
ImageTransform
LinkPathLong

See Also

IPictureEffectiveData Interface | Aspose.Slides Namespace


IPictureEffectiveData Properties

The properties of the IPictureEffectiveData interface are listed below. For a complete list of IPictureEffectiveData interface members, see the IPictureEffectiveData Members topic.

Public Instance Properties

Image
ImageTransform
LinkPathLong

See Also

IPictureEffectiveData Interface | Aspose.Slides Namespace


Image Property

Aspose.Slides Documentation

IPictureEffectiveData.Image Property

[Visual Basic]
Property Image As IPPImage
[C#]
IPPImage Image {get;}

See Also

IPictureEffectiveData Interface | Aspose.Slides Namespace


ImageTransform Property

Aspose.Slides Documentation

IPictureEffectiveData.ImageTransform Property

[Visual Basic]
Property ImageTransform As IImageTransformOCollectionEffectiveData
[C#]
IImageTransformOCollectionEffectiveData ImageTransform {get;}

See Also

IPictureEffectiveData Interface | Aspose.Slides Namespace


LinkPathLong Property

Aspose.Slides Documentation

IPictureEffectiveData.LinkPathLong Property

[Visual Basic]
Property LinkPathLong As String
[C#]
string LinkPathLong {get;}

See Also

IPictureEffectiveData Interface | Aspose.Slides Namespace


IPictureFillFormat Interface

For a list of all members of this type, see IPictureFillFormat Members.

[Visual Basic]
Public Interface IPictureFillFormat
Implements ISlideComponent, IPresentationComponent, IFillParamSource
[C#]
public interface IPictureFillFormat : ISlideComponent, IPresentationComponent, IFillParamSource

Types that implement IPictureFillFormat

Type | Description
PictureFillFormat | Represents a picture fill style.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPictureFillFormat Members | Aspose.Slides Namespace


IPictureFillFormat Members

IPictureFillFormat overview

Public Instance Properties

AsIFillParamSource
AsISlideComponent
CropBottom
CropLeft
CropRight
CropTop
Dpi
Picture
PictureFillMode

See Also

IPictureFillFormat Interface | Aspose.Slides Namespace


IPictureFillFormat Properties

The properties of the IPictureFillFormat interface are listed below. For a complete list of IPictureFillFormat interface members, see the IPictureFillFormat Members topic.

Public Instance Properties

AsIFillParamSource
AsISlideComponent
CropBottom
CropLeft
CropRight
CropTop
Dpi
Picture
PictureFillMode

See Also

IPictureFillFormat Interface | Aspose.Slides Namespace


AsIFillParamSource Property

Aspose.Slides Documentation

IPictureFillFormat.AsIFillParamSource Property

[Visual Basic]
Property AsIFillParamSource As IFillParamSource
[C#]
IFillParamSource AsIFillParamSource {get;}

See Also

IPictureFillFormat Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IPictureFillFormat.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IPictureFillFormat Interface | Aspose.Slides Namespace


CropBottom Property

Aspose.Slides Documentation

IPictureFillFormat.CropBottom Property

[Visual Basic]
Property CropBottom As Single
[C#]
float CropBottom {get; set;}

See Also

IPictureFillFormat Interface | Aspose.Slides Namespace


CropLeft Property

Aspose.Slides Documentation

IPictureFillFormat.CropLeft Property

[Visual Basic]
Property CropLeft As Single
[C#]
float CropLeft {get; set;}

See Also

IPictureFillFormat Interface | Aspose.Slides Namespace


CropRight Property

Aspose.Slides Documentation

IPictureFillFormat.CropRight Property

[Visual Basic]
Property CropRight As Single
[C#]
float CropRight {get; set;}

See Also

IPictureFillFormat Interface | Aspose.Slides Namespace


CropTop Property

Aspose.Slides Documentation

IPictureFillFormat.CropTop Property

[Visual Basic]
Property CropTop As Single
[C#]
float CropTop {get; set;}

See Also

IPictureFillFormat Interface | Aspose.Slides Namespace


Dpi Property

Aspose.Slides Documentation

IPictureFillFormat.Dpi Property

[Visual Basic]
Property Dpi As Integer
[C#]
int Dpi {get; set;}

See Also

IPictureFillFormat Interface | Aspose.Slides Namespace


Picture Property

Aspose.Slides Documentation

IPictureFillFormat.Picture Property

[Visual Basic]
Property Picture As ISlidesPicture
[C#]
ISlidesPicture Picture {get;}

See Also

IPictureFillFormat Interface | Aspose.Slides Namespace


PictureFillMode Property

Aspose.Slides Documentation

IPictureFillFormat.PictureFillMode Property

[Visual Basic]
Property PictureFillMode As PictureFillMode
[C#]
PictureFillMode PictureFillMode {get; set;}

See Also

IPictureFillFormat Interface | Aspose.Slides Namespace


IPictureFillFormatEffectiveData Interface

For a list of all members of this type, see IPictureFillFormatEffectiveData Members.

[Visual Basic]
Public Interface IPictureFillFormatEffectiveData
Implements IFillParamSource
[C#]
public interface IPictureFillFormatEffectiveData : IFillParamSource

Types that implement IPictureFillFormatEffectiveData

Type | Description
PictureFillFormatEffectiveData | Immutable object which contains the properties of picture fill.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPictureFillFormatEffectiveData Members | Aspose.Slides Namespace


IPictureFillFormatEffectiveData Members

IPictureFillFormatEffectiveData overview

Public Instance Properties

AsIFillParamSource
CropBottom
CropLeft
CropRight
CropTop
Dpi
Picture
PictureFillMode

See Also

IPictureFillFormatEffectiveData Interface | Aspose.Slides Namespace


IPictureFillFormatEffectiveData Properties

The properties of the IPictureFillFormatEffectiveData interface are listed below. For a complete list of IPictureFillFormatEffectiveData interface members, see the IPictureFillFormatEffectiveData Members topic.

Public Instance Properties

AsIFillParamSource
CropBottom
CropLeft
CropRight
CropTop
Dpi
Picture
PictureFillMode

See Also

IPictureFillFormatEffectiveData Interface | Aspose.Slides Namespace


AsIFillParamSource Property

Aspose.Slides Documentation

IPictureFillFormatEffectiveData.AsIFillParamSource Property

[Visual Basic]
Property AsIFillParamSource As IFillParamSource
[C#]
IFillParamSource AsIFillParamSource {get;}

See Also

IPictureFillFormatEffectiveData Interface | Aspose.Slides Namespace


CropBottom Property

Aspose.Slides Documentation

IPictureFillFormatEffectiveData.CropBottom Property

[Visual Basic]
Property CropBottom As Single
[C#]
float CropBottom {get;}

See Also

IPictureFillFormatEffectiveData Interface | Aspose.Slides Namespace


CropLeft Property

Aspose.Slides Documentation

IPictureFillFormatEffectiveData.CropLeft Property

[Visual Basic]
Property CropLeft As Single
[C#]
float CropLeft {get;}

See Also

IPictureFillFormatEffectiveData Interface | Aspose.Slides Namespace


CropRight Property

Aspose.Slides Documentation

IPictureFillFormatEffectiveData.CropRight Property

[Visual Basic]
Property CropRight As Single
[C#]
float CropRight {get;}

See Also

IPictureFillFormatEffectiveData Interface | Aspose.Slides Namespace


CropTop Property

Aspose.Slides Documentation

IPictureFillFormatEffectiveData.CropTop Property

[Visual Basic]
Property CropTop As Single
[C#]
float CropTop {get;}

See Also

IPictureFillFormatEffectiveData Interface | Aspose.Slides Namespace


Dpi Property

Aspose.Slides Documentation

IPictureFillFormatEffectiveData.Dpi Property

[Visual Basic]
Property Dpi As Integer
[C#]
int Dpi {get;}

See Also

IPictureFillFormatEffectiveData Interface | Aspose.Slides Namespace


Picture Property

Aspose.Slides Documentation

IPictureFillFormatEffectiveData.Picture Property

[Visual Basic]
Property Picture As IPictureEffectiveData
[C#]
IPictureEffectiveData Picture {get;}

See Also

IPictureFillFormatEffectiveData Interface | Aspose.Slides Namespace


PictureFillMode Property

Aspose.Slides Documentation

IPictureFillFormatEffectiveData.PictureFillMode Property

[Visual Basic]
Property PictureFillMode As PictureFillMode
[C#]
PictureFillMode PictureFillMode {get;}

See Also

IPictureFillFormatEffectiveData Interface | Aspose.Slides Namespace


IPictureFrame Interface

For a list of all members of this type, see IPictureFrame Members.

Aspose.Slides.IPictureFrame
Aspose.Slides.IAudioFrame
Aspose.Slides.IVideoFrame

[Visual Basic]
Public Interface IPictureFrame
Implements IGeometryShape, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public interface IPictureFrame : IGeometryShape, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer

Types that implement IPictureFrame

Type | Description
AudioFrame | Represents an audio clip on a slide.
PictureFrame | Represents a frame with a picture inside.
VideoFrame | Represents a video clip on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPictureFrame Members | Aspose.Slides Namespace


IPictureFrame Members

IPictureFrame overview

Public Instance Properties

AsIGeometryShape
PictureFormat
RelativeScaleHeight
RelativeScaleWidth
ShapeLock

See Also

IPictureFrame Interface | Aspose.Slides Namespace


IPictureFrame Properties

The properties of the IPictureFrame interface are listed below. For a complete list of IPictureFrame interface members, see the IPictureFrame Members topic.

Public Instance Properties

AsIGeometryShape
PictureFormat
RelativeScaleHeight
RelativeScaleWidth
ShapeLock

See Also

IPictureFrame Interface | Aspose.Slides Namespace


AsIGeometryShape Property

Aspose.Slides Documentation

IPictureFrame.AsIGeometryShape Property

[Visual Basic]
Property AsIGeometryShape As IGeometryShape
[C#]
IGeometryShape AsIGeometryShape {get;}

See Also

IPictureFrame Interface | Aspose.Slides Namespace


PictureFormat Property

Aspose.Slides Documentation

IPictureFrame.PictureFormat Property

[Visual Basic]
Property PictureFormat As IPictureFillFormat
[C#]
IPictureFillFormat PictureFormat {get;}

See Also

IPictureFrame Interface | Aspose.Slides Namespace


RelativeScaleHeight Property

Aspose.Slides Documentation

IPictureFrame.RelativeScaleHeight Property

[Visual Basic]
Property RelativeScaleHeight As Single
[C#]
float RelativeScaleHeight {get; set;}

See Also

IPictureFrame Interface | Aspose.Slides Namespace


RelativeScaleWidth Property

Aspose.Slides Documentation

IPictureFrame.RelativeScaleWidth Property

[Visual Basic]
Property RelativeScaleWidth As Single
[C#]
float RelativeScaleWidth {get; set;}

See Also

IPictureFrame Interface | Aspose.Slides Namespace


ShapeLock Property

Aspose.Slides Documentation

IPictureFrame.ShapeLock Property

[Visual Basic]
Property ShapeLock As IPictureFrameLock
[C#]
IPictureFrameLock ShapeLock {get;}

See Also

IPictureFrame Interface | Aspose.Slides Namespace


IPictureFrameLock Interface

For a list of all members of this type, see IPictureFrameLock Members.

[Visual Basic]
Public Interface IPictureFrameLock
Implements IBaseShapeLock
[C#]
public interface IPictureFrameLock : IBaseShapeLock

Types that implement IPictureFrameLock

Type | Description
PictureFrameLock | Determines which operations are disabled on the parent PictureFrame.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPictureFrameLock Members | Aspose.Slides Namespace


IPictureFrameLock Members

IPictureFrameLock overview

Public Instance Properties

AdjustHandlesLocked
ArrowheadsLocked
AsIBaseShapeLock
AspectRatioLocked
CropLocked
EditPointsLocked
GroupingLocked
PositionLocked
RotationLocked
SelectLocked
ShapeTypeLocked
SizeLocked

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


IPictureFrameLock Properties

The properties of the IPictureFrameLock interface are listed below. For a complete list of IPictureFrameLock interface members, see the IPictureFrameLock Members topic.

Public Instance Properties

AdjustHandlesLocked
ArrowheadsLocked
AsIBaseShapeLock
AspectRatioLocked
CropLocked
EditPointsLocked
GroupingLocked
PositionLocked
RotationLocked
SelectLocked
ShapeTypeLocked
SizeLocked

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


AdjustHandlesLocked Property

Aspose.Slides Documentation

IPictureFrameLock.AdjustHandlesLocked Property

[Visual Basic]
Property AdjustHandlesLocked As Boolean
[C#]
bool AdjustHandlesLocked {get; set;}

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


ArrowheadsLocked Property

Aspose.Slides Documentation

IPictureFrameLock.ArrowheadsLocked Property

[Visual Basic]
Property ArrowheadsLocked As Boolean
[C#]
bool ArrowheadsLocked {get; set;}

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


AsIBaseShapeLock Property

Aspose.Slides Documentation

IPictureFrameLock.AsIBaseShapeLock Property

[Visual Basic]
Property AsIBaseShapeLock As IBaseShapeLock
[C#]
IBaseShapeLock AsIBaseShapeLock {get;}

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


AspectRatioLocked Property

Aspose.Slides Documentation

IPictureFrameLock.AspectRatioLocked Property

[Visual Basic]
Property AspectRatioLocked As Boolean
[C#]
bool AspectRatioLocked {get; set;}

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


CropLocked Property

Aspose.Slides Documentation

IPictureFrameLock.CropLocked Property

[Visual Basic]
Property CropLocked As Boolean
[C#]
bool CropLocked {get; set;}

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


EditPointsLocked Property

Aspose.Slides Documentation

IPictureFrameLock.EditPointsLocked Property

[Visual Basic]
Property EditPointsLocked As Boolean
[C#]
bool EditPointsLocked {get; set;}

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


GroupingLocked Property

Aspose.Slides Documentation

IPictureFrameLock.GroupingLocked Property

[Visual Basic]
Property GroupingLocked As Boolean
[C#]
bool GroupingLocked {get; set;}

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


PositionLocked Property

Aspose.Slides Documentation

IPictureFrameLock.PositionLocked Property

[Visual Basic]
Property PositionLocked As Boolean
[C#]
bool PositionLocked {get; set;}

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


RotationLocked Property

Aspose.Slides Documentation

IPictureFrameLock.RotationLocked Property

[Visual Basic]
Property RotationLocked As Boolean
[C#]
bool RotationLocked {get; set;}

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


SelectLocked Property

Aspose.Slides Documentation

IPictureFrameLock.SelectLocked Property

[Visual Basic]
Property SelectLocked As Boolean
[C#]
bool SelectLocked {get; set;}

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


ShapeTypeLocked Property

Aspose.Slides Documentation

IPictureFrameLock.ShapeTypeLocked Property

[Visual Basic]
Property ShapeTypeLocked As Boolean
[C#]
bool ShapeTypeLocked {get; set;}

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


SizeLocked Property

Aspose.Slides Documentation

IPictureFrameLock.SizeLocked Property

[Visual Basic]
Property SizeLocked As Boolean
[C#]
bool SizeLocked {get; set;}

See Also

IPictureFrameLock Interface | Aspose.Slides Namespace


IPlaceholder Interface

For a list of all members of this type, see IPlaceholder Members.

[Visual Basic]
Public Interface IPlaceholder
[C#]
public interface IPlaceholder

Types that implement IPlaceholder

Type | Description
Placeholder | Represents a placeholder on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPlaceholder Members | Aspose.Slides Namespace


IPlaceholder Members

IPlaceholder overview

Public Instance Properties

Index
Orientation
Size
Type

See Also

IPlaceholder Interface | Aspose.Slides Namespace


IPlaceholder Properties

The properties of the IPlaceholder interface are listed below. For a complete list of IPlaceholder interface members, see the IPlaceholder Members topic.

Public Instance Properties

Index
Orientation
Size
Type

See Also

IPlaceholder Interface | Aspose.Slides Namespace


Index Property

Aspose.Slides Documentation

IPlaceholder.Index Property

[Visual Basic]
Property Index As UInt32
[C#]
uint Index {get;}

See Also

IPlaceholder Interface | Aspose.Slides Namespace


Orientation Property

Aspose.Slides Documentation

IPlaceholder.Orientation Property

[Visual Basic]
Property Orientation As Orientation
[C#]
Orientation Orientation {get;}

See Also

IPlaceholder Interface | Aspose.Slides Namespace


Size Property

Aspose.Slides Documentation

IPlaceholder.Size Property

[Visual Basic]
Property Size As PlaceholderSize
[C#]
PlaceholderSize Size {get;}

See Also

IPlaceholder Interface | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

IPlaceholder.Type Property

[Visual Basic]
Property Type As PlaceholderType
[C#]
PlaceholderType Type {get;}

See Also

IPlaceholder Interface | Aspose.Slides Namespace


IPortion Interface

For a list of all members of this type, see IPortion Members.

[Visual Basic]
Public Interface IPortion
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IPortion : ISlideComponent, IPresentationComponent

Types that implement IPortion

Type | Description
Portion | Represents a portion of text inside a text paragraph.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPortion Members | Aspose.Slides Namespace


IPortion Members

IPortion overview

Public Instance Properties

AsISlideComponent
Field
PortionFormat
Text

Public Instance Methods

AddField | Overloaded.
CreatePortionFormatEffective |
RemoveField |

See Also

IPortion Interface | Aspose.Slides Namespace


IPortion Properties

The properties of the IPortion interface are listed below. For a complete list of IPortion interface members, see the IPortion Members topic.

Public Instance Properties

AsISlideComponent
Field
PortionFormat
Text

See Also

IPortion Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IPortion.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IPortion Interface | Aspose.Slides Namespace


Field Property

Aspose.Slides Documentation

IPortion.Field Property

[Visual Basic]
Property Field As IField
[C#]
IField Field {get;}

See Also

IPortion Interface | Aspose.Slides Namespace


PortionFormat Property

Aspose.Slides Documentation

IPortion.PortionFormat Property

[Visual Basic]
Property PortionFormat As IPortionFormat
[C#]
IPortionFormat PortionFormat {get;}

See Also

IPortion Interface | Aspose.Slides Namespace


Text Property

Aspose.Slides Documentation

IPortion.Text Property

[Visual Basic]
Property Text As String
[C#]
string Text {get; set;}

See Also

IPortion Interface | Aspose.Slides Namespace


IPortion Methods

The methods of the IPortion interface are listed below. For a complete list of IPortion interface members, see the IPortion Members topic.

Public Instance Methods

AddField | Overloaded.
CreatePortionFormatEffective |
RemoveField |

See Also

IPortion Interface | Aspose.Slides Namespace


AddField Method

Aspose.Slides Documentation

IPortion.AddField Method

Overload List

void AddField(IFieldType);

void AddField(string);

See Also

IPortion Interface | Aspose.Slides Namespace


IPortion.AddField Method (IFieldType)

[Visual Basic]
Sub AddField( _
ByVal fieldType As IFieldType _
)
[C#]
void AddField(
IFieldType fieldType
);

See Also

IPortion Interface | Aspose.Slides Namespace | IPortion.AddField Overload List


IPortion.AddField Method (String)

[Visual Basic]
Sub AddField( _
ByVal internalString As String _
)
[C#]
void AddField(
string internalString
);

See Also

IPortion Interface | Aspose.Slides Namespace | IPortion.AddField Overload List


IPortion.CreatePortionFormatEffective Method

[Visual Basic]
Function CreatePortionFormatEffective() As IPortionFormatEffectiveData
[C#]
IPortionFormatEffectiveData CreatePortionFormatEffective();

See Also

IPortion Interface | Aspose.Slides Namespace


IPortion.RemoveField Method

[Visual Basic]
Sub RemoveField()
[C#]
void RemoveField();

See Also

IPortion Interface | Aspose.Slides Namespace


IPortionCollection Interface

For a list of all members of this type, see IPortionCollection Members.

[Visual Basic]
Public Interface IPortionCollection
Implements IEnumerable`1([Aspose.Slides.IPortion, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public interface IPortionCollection : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Types that implement IPortionCollection

Type | Description
PortionCollection | Represents a collection of a portions.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPortionCollection Members | Aspose.Slides Namespace


IPortionCollection Members

IPortionCollection overview

Public Instance Properties

AsIEnumerable
Count
Item

Public Instance Methods

Add
Clear
Contains
IndexOf
Insert
Remove
RemoveAt

See Also

IPortionCollection Interface | Aspose.Slides Namespace


IPortionCollection Properties

The properties of the IPortionCollection interface are listed below. For a complete list of IPortionCollection interface members, see the IPortionCollection Members topic.

Public Instance Properties

AsIEnumerable
Count
Item

See Also

IPortionCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IPortionCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IPortionCollection Interface | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

IPortionCollection.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

IPortionCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IPortionCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IPortion
[C#]
IPortion this[
int index
] {get;}

See Also

IPortionCollection Interface | Aspose.Slides Namespace


IPortionCollection Methods

The methods of the IPortionCollection interface are listed below. For a complete list of IPortionCollection interface members, see the IPortionCollection Members topic.

Public Instance Methods

Add
Clear
Contains
IndexOf
Insert
Remove
RemoveAt

See Also

IPortionCollection Interface | Aspose.Slides Namespace


IPortionCollection.Add Method

[Visual Basic]
Sub Add( _
ByVal value As IPortion _
)
[C#]
void Add(
IPortion value
);

See Also

IPortionCollection Interface | Aspose.Slides Namespace


IPortionCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

IPortionCollection Interface | Aspose.Slides Namespace


IPortionCollection.Contains Method

[Visual Basic]
Function Contains( _
ByVal item As IPortion _
) As Boolean
[C#]
bool Contains(
IPortion item
);

See Also

IPortionCollection Interface | Aspose.Slides Namespace


IPortionCollection.IndexOf Method

[Visual Basic]
Function IndexOf( _
ByVal item As IPortion _
) As Integer
[C#]
int IndexOf(
IPortion item
);

See Also

IPortionCollection Interface | Aspose.Slides Namespace


IPortionCollection.Insert Method

[Visual Basic]
Sub Insert( _
ByVal index As Integer, _
ByVal value As IPortion _
)
[C#]
void Insert(
int index,
IPortion value
);

See Also

IPortionCollection Interface | Aspose.Slides Namespace


IPortionCollection.Remove Method

[Visual Basic]
Function Remove( _
ByVal item As IPortion _
) As Boolean
[C#]
bool Remove(
IPortion item
);

See Also

IPortionCollection Interface | Aspose.Slides Namespace


IPortionCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IPortionCollection Interface | Aspose.Slides Namespace


IPortionFactory Interface

For a list of all members of this type, see IPortionFactory Members.

[Visual Basic]
Public Interface IPortionFactory
[C#]
public interface IPortionFactory

Types that implement IPortionFactory

Type | Description
PortionFactory | Allows to create test portions

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPortionFactory Members | Aspose.Slides Namespace


IPortionFactory Members

IPortionFactory overview

Public Instance Methods

CreatePortion Overloaded.

See Also

IPortionFactory Interface | Aspose.Slides Namespace


IPortionFactory Methods

The methods of the IPortionFactory interface are listed below. For a complete list of IPortionFactory interface members, see the IPortionFactory Members topic.

Public Instance Methods

CreatePortion Overloaded.

See Also

IPortionFactory Interface | Aspose.Slides Namespace


CreatePortion Method

Aspose.Slides Documentation

IPortionFactory.CreatePortion Method

Overload List

IPortion CreatePortion();

IPortion CreatePortion(IPortion);

IPortion CreatePortion(string);

See Also

IPortionFactory Interface | Aspose.Slides Namespace


IPortionFactory.CreatePortion Method ()

[Visual Basic]
Function CreatePortion() As IPortion
[C#]
IPortion CreatePortion();

See Also

IPortionFactory Interface | Aspose.Slides Namespace | IPortionFactory.CreatePortion Overload List


IPortionFactory.CreatePortion Method (IPortion)

[Visual Basic]
Function CreatePortion( _
ByVal portion As IPortion _
) As IPortion
[C#]
IPortion CreatePortion(
IPortion portion
);

See Also

IPortionFactory Interface | Aspose.Slides Namespace | IPortionFactory.CreatePortion Overload List


IPortionFactory.CreatePortion Method (String)

[Visual Basic]
Function CreatePortion( _
ByVal str As String _
) As IPortion
[C#]
IPortion CreatePortion(
string str
);

See Also

IPortionFactory Interface | Aspose.Slides Namespace | IPortionFactory.CreatePortion Overload List


IPortionFormat Interface

For a list of all members of this type, see IPortionFormat Members.

[Visual Basic]
Public Interface IPortionFormat
Implements IHyperlinkContainer
[C#]
public interface IPortionFormat : IHyperlinkContainer

Types that implement IPortionFormat

Type | Description
PortionFormat | This class contains the text portion formatting properties. Unlike PortionFormatEffectiveData, all properties of this class are writeable.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPortionFormat Members | Aspose.Slides Namespace


IPortionFormat Members

IPortionFormat overview

Public Instance Properties

AlternativeLanguageId
AsIHyperlinkContainer
BookmarkId
ComplexScriptFont
EastAsianFont
EffectFormat
Escapement
FillFormat
FontBold
FontHeight
FontItalic
FontUnderline
HighlightColor
IsHardUnderlineFill
IsHardUnderlineLine
KerningMinimalSize
Kumimoji
LanguageId
LatinFont
LineFormat
NormaliseHeight
ProofDisabled
SmartTagClean
Spacing
StrikethroughType
SymbolFont
TextCapType
UnderlineFillFormat
UnderlineLineFormat

See Also

IPortionFormat Interface | Aspose.Slides Namespace


IPortionFormat Properties

The properties of the IPortionFormat interface are listed below. For a complete list of IPortionFormat interface members, see the IPortionFormat Members topic.

Public Instance Properties

AlternativeLanguageId
AsIHyperlinkContainer
BookmarkId
ComplexScriptFont
EastAsianFont
EffectFormat
Escapement
FillFormat
FontBold
FontHeight
FontItalic
FontUnderline
HighlightColor
IsHardUnderlineFill
IsHardUnderlineLine
KerningMinimalSize
Kumimoji
LanguageId
LatinFont
LineFormat
NormaliseHeight
ProofDisabled
SmartTagClean
Spacing
StrikethroughType
SymbolFont
TextCapType
UnderlineFillFormat
UnderlineLineFormat

See Also

IPortionFormat Interface | Aspose.Slides Namespace


AlternativeLanguageId Property

Aspose.Slides Documentation

IPortionFormat.AlternativeLanguageId Property

[Visual Basic]
Property AlternativeLanguageId As String
[C#]
string AlternativeLanguageId {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


AsIHyperlinkContainer Property

Aspose.Slides Documentation

IPortionFormat.AsIHyperlinkContainer Property

[Visual Basic]
Property AsIHyperlinkContainer As IHyperlinkContainer
[C#]
IHyperlinkContainer AsIHyperlinkContainer {get;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


BookmarkId Property

Aspose.Slides Documentation

IPortionFormat.BookmarkId Property

[Visual Basic]
Property BookmarkId As String
[C#]
string BookmarkId {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


ComplexScriptFont Property

Aspose.Slides Documentation

IPortionFormat.ComplexScriptFont Property

[Visual Basic]
Property ComplexScriptFont As IFontData
[C#]
IFontData ComplexScriptFont {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


EastAsianFont Property

Aspose.Slides Documentation

IPortionFormat.EastAsianFont Property

[Visual Basic]
Property EastAsianFont As IFontData
[C#]
IFontData EastAsianFont {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


EffectFormat Property

Aspose.Slides Documentation

IPortionFormat.EffectFormat Property

[Visual Basic]
Property EffectFormat As IEffectFormat
[C#]
IEffectFormat EffectFormat {get;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


Escapement Property

Aspose.Slides Documentation

IPortionFormat.Escapement Property

[Visual Basic]
Property Escapement As Single
[C#]
float Escapement {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

IPortionFormat.FillFormat Property

[Visual Basic]
Property FillFormat As IFillFormat
[C#]
IFillFormat FillFormat {get;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


FontBold Property

Aspose.Slides Documentation

IPortionFormat.FontBold Property

[Visual Basic]
Property FontBold As NullableBool
[C#]
NullableBool FontBold {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


FontHeight Property

Aspose.Slides Documentation

IPortionFormat.FontHeight Property

[Visual Basic]
Property FontHeight As Single
[C#]
float FontHeight {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


FontItalic Property

Aspose.Slides Documentation

IPortionFormat.FontItalic Property

[Visual Basic]
Property FontItalic As NullableBool
[C#]
NullableBool FontItalic {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


FontUnderline Property

Aspose.Slides Documentation

IPortionFormat.FontUnderline Property

[Visual Basic]
Property FontUnderline As TextUnderlineType
[C#]
TextUnderlineType FontUnderline {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


HighlightColor Property

Aspose.Slides Documentation

IPortionFormat.HighlightColor Property

[Visual Basic]
Property HighlightColor As IColorFormat
[C#]
IColorFormat HighlightColor {get;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


IsHardUnderlineFill Property

Aspose.Slides Documentation

IPortionFormat.IsHardUnderlineFill Property

[Visual Basic]
Property IsHardUnderlineFill As NullableBool
[C#]
NullableBool IsHardUnderlineFill {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


IsHardUnderlineLine Property

Aspose.Slides Documentation

IPortionFormat.IsHardUnderlineLine Property

[Visual Basic]
Property IsHardUnderlineLine As NullableBool
[C#]
NullableBool IsHardUnderlineLine {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


KerningMinimalSize Property

Aspose.Slides Documentation

IPortionFormat.KerningMinimalSize Property

[Visual Basic]
Property KerningMinimalSize As Single
[C#]
float KerningMinimalSize {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


Kumimoji Property

Aspose.Slides Documentation

IPortionFormat.Kumimoji Property

[Visual Basic]
Property Kumimoji As NullableBool
[C#]
NullableBool Kumimoji {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


LanguageId Property

Aspose.Slides Documentation

IPortionFormat.LanguageId Property

[Visual Basic]
Property LanguageId As String
[C#]
string LanguageId {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


LatinFont Property

Aspose.Slides Documentation

IPortionFormat.LatinFont Property

[Visual Basic]
Property LatinFont As IFontData
[C#]
IFontData LatinFont {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


LineFormat Property

Aspose.Slides Documentation

IPortionFormat.LineFormat Property

[Visual Basic]
Property LineFormat As ILineFormat
[C#]
ILineFormat LineFormat {get;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


NormaliseHeight Property

Aspose.Slides Documentation

IPortionFormat.NormaliseHeight Property

[Visual Basic]
Property NormaliseHeight As NullableBool
[C#]
NullableBool NormaliseHeight {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


ProofDisabled Property

Aspose.Slides Documentation

IPortionFormat.ProofDisabled Property

[Visual Basic]
Property ProofDisabled As NullableBool
[C#]
NullableBool ProofDisabled {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


SmartTagClean Property

Aspose.Slides Documentation

IPortionFormat.SmartTagClean Property

[Visual Basic]
Property SmartTagClean As Boolean
[C#]
bool SmartTagClean {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


Spacing Property

Aspose.Slides Documentation

IPortionFormat.Spacing Property

[Visual Basic]
Property Spacing As Single
[C#]
float Spacing {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


StrikethroughType Property

Aspose.Slides Documentation

IPortionFormat.StrikethroughType Property

[Visual Basic]
Property StrikethroughType As TextStrikethroughType
[C#]
TextStrikethroughType StrikethroughType {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


SymbolFont Property

Aspose.Slides Documentation

IPortionFormat.SymbolFont Property

[Visual Basic]
Property SymbolFont As IFontData
[C#]
IFontData SymbolFont {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


TextCapType Property

Aspose.Slides Documentation

IPortionFormat.TextCapType Property

[Visual Basic]
Property TextCapType As TextCapType
[C#]
TextCapType TextCapType {get; set;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


UnderlineFillFormat Property

Aspose.Slides Documentation

IPortionFormat.UnderlineFillFormat Property

[Visual Basic]
Property UnderlineFillFormat As IFillFormat
[C#]
IFillFormat UnderlineFillFormat {get;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


UnderlineLineFormat Property

Aspose.Slides Documentation

IPortionFormat.UnderlineLineFormat Property

[Visual Basic]
Property UnderlineLineFormat As ILineFormat
[C#]
ILineFormat UnderlineLineFormat {get;}

See Also

IPortionFormat Interface | Aspose.Slides Namespace


IPortionFormatEffectiveData Interface

For a list of all members of this type, see IPortionFormatEffectiveData Members.

[Visual Basic]
Public Interface IPortionFormatEffectiveData
[C#]
public interface IPortionFormatEffectiveData

Types that implement IPortionFormatEffectiveData

Type | Description
PortionFormatEffectiveData | Immutable object which contains text portion formatting properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPortionFormatEffectiveData Members | Aspose.Slides Namespace


IPortionFormatEffectiveData Members

IPortionFormatEffectiveData overview

Public Instance Properties

AlternativeLanguageId
BookmarkId
ComplexScriptFont
EastAsianFont
EffectFormat
Escapement
FillFormat
FontBold
FontHeight
FontItalic
FontUnderline
HighlightColor
HyperlinkClick
HyperlinkMouseOver
IsHardUnderlineFill
IsHardUnderlineLine
KerningMinimalSize
Kumimoji
LanguageId
LatinFont
LineFormat
NormaliseHeight
ProofDisabled
SmartTagClean
Spacing
StrikethroughType
SymbolFont
TextCapType
UnderlineFillFormat
UnderlineLineFormat

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


IPortionFormatEffectiveData Properties

The properties of the IPortionFormatEffectiveData interface are listed below. For a complete list of IPortionFormatEffectiveData interface members, see the IPortionFormatEffectiveData Members topic.

Public Instance Properties

AlternativeLanguageId
BookmarkId
ComplexScriptFont
EastAsianFont
EffectFormat
Escapement
FillFormat
FontBold
FontHeight
FontItalic
FontUnderline
HighlightColor
HyperlinkClick
HyperlinkMouseOver
IsHardUnderlineFill
IsHardUnderlineLine
KerningMinimalSize
Kumimoji
LanguageId
LatinFont
LineFormat
NormaliseHeight
ProofDisabled
SmartTagClean
Spacing
StrikethroughType
SymbolFont
TextCapType
UnderlineFillFormat
UnderlineLineFormat

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


AlternativeLanguageId Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.AlternativeLanguageId Property

[Visual Basic]
Property AlternativeLanguageId As String
[C#]
string AlternativeLanguageId {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


BookmarkId Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.BookmarkId Property

[Visual Basic]
Property BookmarkId As String
[C#]
string BookmarkId {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


ComplexScriptFont Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.ComplexScriptFont Property

[Visual Basic]
Property ComplexScriptFont As IFontData
[C#]
IFontData ComplexScriptFont {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


EastAsianFont Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.EastAsianFont Property

[Visual Basic]
Property EastAsianFont As IFontData
[C#]
IFontData EastAsianFont {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


EffectFormat Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.EffectFormat Property

[Visual Basic]
Property EffectFormat As IEffectFormatEffectiveData
[C#]
IEffectFormatEffectiveData EffectFormat {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


Escapement Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.Escapement Property

[Visual Basic]
Property Escapement As Single
[C#]
float Escapement {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.FillFormat Property

[Visual Basic]
Property FillFormat As IFillFormatEffectiveData
[C#]
IFillFormatEffectiveData FillFormat {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


FontBold Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.FontBold Property

[Visual Basic]
Property FontBold As Boolean
[C#]
bool FontBold {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


FontHeight Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.FontHeight Property

[Visual Basic]
Property FontHeight As Single
[C#]
float FontHeight {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


FontItalic Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.FontItalic Property

[Visual Basic]
Property FontItalic As Boolean
[C#]
bool FontItalic {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


FontUnderline Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.FontUnderline Property

[Visual Basic]
Property FontUnderline As TextUnderlineType
[C#]
TextUnderlineType FontUnderline {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


HighlightColor Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.HighlightColor Property

[Visual Basic]
Property HighlightColor As Color
[C#]
Color HighlightColor {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


HyperlinkClick Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.HyperlinkClick Property

[Visual Basic]
Property HyperlinkClick As IHyperlink
[C#]
IHyperlink HyperlinkClick {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


HyperlinkMouseOver Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.HyperlinkMouseOver Property

[Visual Basic]
Property HyperlinkMouseOver As IHyperlink
[C#]
IHyperlink HyperlinkMouseOver {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


IsHardUnderlineFill Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.IsHardUnderlineFill Property

[Visual Basic]
Property IsHardUnderlineFill As Boolean
[C#]
bool IsHardUnderlineFill {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


IsHardUnderlineLine Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.IsHardUnderlineLine Property

[Visual Basic]
Property IsHardUnderlineLine As Boolean
[C#]
bool IsHardUnderlineLine {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


KerningMinimalSize Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.KerningMinimalSize Property

[Visual Basic]
Property KerningMinimalSize As Single
[C#]
float KerningMinimalSize {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


Kumimoji Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.Kumimoji Property

[Visual Basic]
Property Kumimoji As Boolean
[C#]
bool Kumimoji {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


LanguageId Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.LanguageId Property

[Visual Basic]
Property LanguageId As String
[C#]
string LanguageId {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


LatinFont Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.LatinFont Property

[Visual Basic]
Property LatinFont As IFontData
[C#]
IFontData LatinFont {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


LineFormat Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.LineFormat Property

[Visual Basic]
Property LineFormat As ILineFormatEffectiveData
[C#]
ILineFormatEffectiveData LineFormat {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


NormaliseHeight Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.NormaliseHeight Property

[Visual Basic]
Property NormaliseHeight As Boolean
[C#]
bool NormaliseHeight {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


ProofDisabled Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.ProofDisabled Property

[Visual Basic]
Property ProofDisabled As Boolean
[C#]
bool ProofDisabled {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


SmartTagClean Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.SmartTagClean Property

[Visual Basic]
Property SmartTagClean As Boolean
[C#]
bool SmartTagClean {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


Spacing Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.Spacing Property

[Visual Basic]
Property Spacing As Single
[C#]
float Spacing {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


StrikethroughType Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.StrikethroughType Property

[Visual Basic]
Property StrikethroughType As TextStrikethroughType
[C#]
TextStrikethroughType StrikethroughType {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


SymbolFont Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.SymbolFont Property

[Visual Basic]
Property SymbolFont As IFontData
[C#]
IFontData SymbolFont {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


TextCapType Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.TextCapType Property

[Visual Basic]
Property TextCapType As TextCapType
[C#]
TextCapType TextCapType {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


UnderlineFillFormat Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.UnderlineFillFormat Property

[Visual Basic]
Property UnderlineFillFormat As IFillFormatEffectiveData
[C#]
IFillFormatEffectiveData UnderlineFillFormat {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


UnderlineLineFormat Property

Aspose.Slides Documentation

IPortionFormatEffectiveData.UnderlineLineFormat Property

[Visual Basic]
Property UnderlineLineFormat As ILineFormatEffectiveData
[C#]
ILineFormatEffectiveData UnderlineLineFormat {get;}

See Also

IPortionFormatEffectiveData Interface | Aspose.Slides Namespace


IPPImage Interface

For a list of all members of this type, see IPPImage Members.

[Visual Basic]
Public Interface IPPImage
[C#]
public interface IPPImage

Types that implement IPPImage

Type | Description
PPImage | Represents an image in a presentation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPPImage Members | Aspose.Slides Namespace


IPPImage Members

IPPImage overview

Public Instance Properties

BinaryData
ContentType
Height
SystemImage
Width
X
Y

See Also

IPPImage Interface | Aspose.Slides Namespace


IPPImage Properties

The properties of the IPPImage interface are listed below. For a complete list of IPPImage interface members, see the IPPImage Members topic.

Public Instance Properties

BinaryData
ContentType
Height
SystemImage
Width
X
Y

See Also

IPPImage Interface | Aspose.Slides Namespace


BinaryData Property

Aspose.Slides Documentation

IPPImage.BinaryData Property

[Visual Basic]
Property BinaryData As Byte()
[C#]
byte[] BinaryData {get;}

See Also

IPPImage Interface | Aspose.Slides Namespace


ContentType Property

Aspose.Slides Documentation

IPPImage.ContentType Property

[Visual Basic]
Property ContentType As String
[C#]
string ContentType {get;}

See Also

IPPImage Interface | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

IPPImage.Height Property

[Visual Basic]
Property Height As Integer
[C#]
int Height {get;}

See Also

IPPImage Interface | Aspose.Slides Namespace


SystemImage Property

Aspose.Slides Documentation

IPPImage.SystemImage Property

[Visual Basic]
Property SystemImage As Image
[C#]
Image SystemImage {get;}

See Also

IPPImage Interface | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

IPPImage.Width Property

[Visual Basic]
Property Width As Integer
[C#]
int Width {get;}

See Also

IPPImage Interface | Aspose.Slides Namespace


X Property

Aspose.Slides Documentation

IPPImage.X Property

[Visual Basic]
Property X As Integer
[C#]
int X {get;}

See Also

IPPImage Interface | Aspose.Slides Namespace


Y Property

Aspose.Slides Documentation

IPPImage.Y Property

[Visual Basic]
Property Y As Integer
[C#]
int Y {get;}

See Also

IPPImage Interface | Aspose.Slides Namespace


IPresentation Interface

For a list of all members of this type, see IPresentation Members.

[Visual Basic]
Public Interface IPresentation
Implements IDisposable
[C#]
public interface IPresentation : IDisposable

Types that implement IPresentation

Type | Description
Presentation | Represents a Microsoft PowerPoint presentation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPresentation Members | Aspose.Slides Namespace


IPresentation Members

IPresentation overview

Public Instance Properties

Audios
CommentAuthors
CurrentDateTime
CustomData
DefaultTextStyle
DocumentProperties
HeaderFooterManager
HyperlinkQueries
Images
LayoutSlides
MasterHandoutSlideManager
MasterNotesSlideManager
Masters
MasterTheme
ProtectionManager
Slides
SlideSize
SourceFormat
UpdateDateTimeFields
UpdateSlideNumberFields
VbaProject
Videos

Public Instance Methods

Print | Overloaded.
Save | Overloaded.

See Also

IPresentation Interface | Aspose.Slides Namespace


IPresentation Properties

The properties of the IPresentation interface are listed below. For a complete list of IPresentation interface members, see the IPresentation Members topic.

Public Instance Properties

Audios
CommentAuthors
CurrentDateTime
CustomData
DefaultTextStyle
DocumentProperties
HeaderFooterManager
HyperlinkQueries
Images
LayoutSlides
MasterHandoutSlideManager
MasterNotesSlideManager
Masters
MasterTheme
ProtectionManager
Slides
SlideSize
SourceFormat
UpdateDateTimeFields
UpdateSlideNumberFields
VbaProject
Videos

See Also

IPresentation Interface | Aspose.Slides Namespace


Audios Property

Aspose.Slides Documentation

IPresentation.Audios Property

[Visual Basic]
Property Audios As IAudioCollection
[C#]
IAudioCollection Audios {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


CommentAuthors Property

Aspose.Slides Documentation

IPresentation.CommentAuthors Property

[Visual Basic]
Property CommentAuthors As ICommentAuthorCollection
[C#]
ICommentAuthorCollection CommentAuthors {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


CurrentDateTime Property

Aspose.Slides Documentation

IPresentation.CurrentDateTime Property

[Visual Basic]
Property CurrentDateTime As Date
[C#]
DateTime CurrentDateTime {get; set;}

See Also

IPresentation Interface | Aspose.Slides Namespace


CustomData Property

Aspose.Slides Documentation

IPresentation.CustomData Property

[Visual Basic]
Property CustomData As ICustomData
[C#]
ICustomData CustomData {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


DefaultTextStyle Property

Aspose.Slides Documentation

IPresentation.DefaultTextStyle Property

[Visual Basic]
Property DefaultTextStyle As ITextStyle
[C#]
ITextStyle DefaultTextStyle {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


DocumentProperties Property

Aspose.Slides Documentation

IPresentation.DocumentProperties Property

[Visual Basic]
Property DocumentProperties As IDocumentProperties
[C#]
IDocumentProperties DocumentProperties {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


HeaderFooterManager Property

Aspose.Slides Documentation

IPresentation.HeaderFooterManager Property

[Visual Basic]
Property HeaderFooterManager As IHeaderFooterManager
[C#]
IHeaderFooterManager HeaderFooterManager {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


HyperlinkQueries Property

Aspose.Slides Documentation

IPresentation.HyperlinkQueries Property

[Visual Basic]
Property HyperlinkQueries As IHyperlinkQueries
[C#]
IHyperlinkQueries HyperlinkQueries {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


Images Property

Aspose.Slides Documentation

IPresentation.Images Property

[Visual Basic]
Property Images As IImageCollection
[C#]
IImageCollection Images {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


LayoutSlides Property

Aspose.Slides Documentation

IPresentation.LayoutSlides Property

[Visual Basic]
Property LayoutSlides As IGlobalLayoutSlideCollection
[C#]
IGlobalLayoutSlideCollection LayoutSlides {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


MasterHandoutSlideManager Property

Aspose.Slides Documentation

IPresentation.MasterHandoutSlideManager Property

[Visual Basic]
Property MasterHandoutSlideManager As IMasterHandoutSlideManager
[C#]
IMasterHandoutSlideManager MasterHandoutSlideManager {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


MasterNotesSlideManager Property

Aspose.Slides Documentation

IPresentation.MasterNotesSlideManager Property

[Visual Basic]
Property MasterNotesSlideManager As IMasterNotesSlideManager
[C#]
IMasterNotesSlideManager MasterNotesSlideManager {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


Masters Property

Aspose.Slides Documentation

IPresentation.Masters Property

[Visual Basic]
Property Masters As IMasterSlideCollection
[C#]
IMasterSlideCollection Masters {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


MasterTheme Property

Aspose.Slides Documentation

IPresentation.MasterTheme Property

[Visual Basic]
Property MasterTheme As IMasterTheme
[C#]
IMasterTheme MasterTheme {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


ProtectionManager Property

Aspose.Slides Documentation

IPresentation.ProtectionManager Property

[Visual Basic]
Property ProtectionManager As IProtectionManager
[C#]
IProtectionManager ProtectionManager {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


Slides Property

Aspose.Slides Documentation

IPresentation.Slides Property

[Visual Basic]
Property Slides As ISlideCollection
[C#]
ISlideCollection Slides {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


SlideSize Property

Aspose.Slides Documentation

IPresentation.SlideSize Property

[Visual Basic]
Property SlideSize As ISlideSize
[C#]
ISlideSize SlideSize {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


SourceFormat Property

Aspose.Slides Documentation

IPresentation.SourceFormat Property

[Visual Basic]
Property SourceFormat As SourceFormat
[C#]
SourceFormat SourceFormat {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


UpdateDateTimeFields Property

Aspose.Slides Documentation

IPresentation.UpdateDateTimeFields Property

[Visual Basic]
Property UpdateDateTimeFields As Boolean
[C#]
bool UpdateDateTimeFields {get; set;}

See Also

IPresentation Interface | Aspose.Slides Namespace


UpdateSlideNumberFields Property

Aspose.Slides Documentation

IPresentation.UpdateSlideNumberFields Property

[Visual Basic]
Property UpdateSlideNumberFields As Boolean
[C#]
bool UpdateSlideNumberFields {get; set;}

See Also

IPresentation Interface | Aspose.Slides Namespace


VbaProject Property

Aspose.Slides Documentation

IPresentation.VbaProject Property

[Visual Basic]
Property VbaProject As Byte()
[C#]
byte[] VbaProject {get; set;}

See Also

IPresentation Interface | Aspose.Slides Namespace


Videos Property

Aspose.Slides Documentation

IPresentation.Videos Property

[Visual Basic]
Property Videos As IVideoCollection
[C#]
IVideoCollection Videos {get;}

See Also

IPresentation Interface | Aspose.Slides Namespace


IPresentation Methods

The methods of the IPresentation interface are listed below. For a complete list of IPresentation interface members, see the IPresentation Members topic.

Public Instance Methods

Print | Overloaded.
Save | Overloaded.

See Also

IPresentation Interface | Aspose.Slides Namespace


Print Method

Aspose.Slides Documentation

IPresentation.Print Method

Overload List

void Print();

void Print(PrinterSettings);

void Print(PrinterSettings,string);

void Print(string);

See Also

IPresentation Interface | Aspose.Slides Namespace


IPresentation.Print Method ()

[Visual Basic]
Sub Print()
[C#]
void Print();

See Also

IPresentation Interface | Aspose.Slides Namespace | IPresentation.Print Overload List


IPresentation.Print Method (PrinterSettings)

[Visual Basic]
Sub Print( _
ByVal printerSettings As PrinterSettings _
)
[C#]
void Print(
PrinterSettings printerSettings
);

See Also

IPresentation Interface | Aspose.Slides Namespace | IPresentation.Print Overload List


IPresentation.Print Method (PrinterSettings, String)

[Visual Basic]
Sub Print( _
ByVal printerSettings As PrinterSettings, _
ByVal presName As String _
)
[C#]
void Print(
PrinterSettings printerSettings,
string presName
);

See Also

IPresentation Interface | Aspose.Slides Namespace | IPresentation.Print Overload List


IPresentation.Print Method (String)

[Visual Basic]
Sub Print( _
ByVal printerName As String _
)
[C#]
void Print(
string printerName
);

See Also

IPresentation Interface | Aspose.Slides Namespace | IPresentation.Print Overload List


Save Method

Aspose.Slides Documentation

IPresentation.Save Method

Overload List

void Save(Stream,SaveFormat);

void Save(Stream,SaveFormat,ISaveOptions);

void Save(string,SaveFormat);

void Save(string,SaveFormat,ISaveOptions);

void Save(string,SaveFormat,ISaveOptions,HttpResponse,bool);

void Save(string,SaveFormat,HttpResponse,bool);

See Also

IPresentation Interface | Aspose.Slides Namespace


IPresentation.Save Method (Stream, SaveFormat)

[Visual Basic]
Sub Save( _
ByVal stream As Stream, _
ByVal format As SaveFormat _
)
[C#]
void Save(
Stream stream,
SaveFormat format
);

See Also

IPresentation Interface | Aspose.Slides Namespace | IPresentation.Save Overload List


IPresentation.Save Method (Stream, SaveFormat, ISaveOptions)

[Visual Basic]
Sub Save( _
ByVal stream As Stream, _
ByVal format As SaveFormat, _
ByVal options As ISaveOptions _
)
[C#]
void Save(
Stream stream,
SaveFormat format,
ISaveOptions options
);

See Also

IPresentation Interface | Aspose.Slides Namespace | IPresentation.Save Overload List


IPresentation.Save Method (String, SaveFormat)

[Visual Basic]
Sub Save( _
ByVal fname As String, _
ByVal format As SaveFormat _
)
[C#]
void Save(
string fname,
SaveFormat format
);

See Also

IPresentation Interface | Aspose.Slides Namespace | IPresentation.Save Overload List


IPresentation.Save Method (String, SaveFormat, ISaveOptions)

[Visual Basic]
Sub Save( _
ByVal fname As String, _
ByVal format As SaveFormat, _
ByVal options As ISaveOptions _
)
[C#]
void Save(
string fname,
SaveFormat format,
ISaveOptions options
);

See Also

IPresentation Interface | Aspose.Slides Namespace | IPresentation.Save Overload List


IPresentation.Save Method (String, SaveFormat, ISaveOptions, HttpResponse, Boolean)

[Visual Basic]
Sub Save( _
ByVal fname As String, _
ByVal format As SaveFormat, _
ByVal options As ISaveOptions, _
ByVal response As HttpResponse, _
ByVal showInline As Boolean _
)
[C#]
void Save(
string fname,
SaveFormat format,
ISaveOptions options,
HttpResponse response,
bool showInline
);

See Also

IPresentation Interface | Aspose.Slides Namespace | IPresentation.Save Overload List


IPresentation.Save Method (String, SaveFormat, HttpResponse, Boolean)

[Visual Basic]
Sub Save( _
ByVal fname As String, _
ByVal format As SaveFormat, _
ByVal response As HttpResponse, _
ByVal showInline As Boolean _
)
[C#]
void Save(
string fname,
SaveFormat format,
HttpResponse response,
bool showInline
);

See Also

IPresentation Interface | Aspose.Slides Namespace | IPresentation.Save Overload List


IPresentationComponent Interface

For a list of all members of this type, see IPresentationComponent Members.

Aspose.Slides.IPresentationComponent
Derived interfaces

[Visual Basic]
Public Interface IPresentationComponent
[C#]
public interface IPresentationComponent

Types that implement IPresentationComponent

Type | Description
AudioFrame | Represents an audio clip on a slide.
AutoShape | Represents an AutoShape.
Background | Represents background of a slide.
BaseSlide | Represents common data for all slide types.
Cell | Represents a cell of a table.
CellCollection | Represents a collection of cells.
Chart | Represents an graphic chart on a slide.
Column | Represents a column in a table.
Connector | Represents a connector.
Control | Represents an ActiveX control.
EffectFormat | Represents effect properties of shape.
AlphaBiLevel | Represents an Alpha Bi-Level effect. Alpha (Opacity) values less than the threshold are changed to 0 (fully transparent) and alpha values greater than or equal to the threshold are changed to 100% (fully opaque).
AlphaCeiling | Represents an Alpha Ceiling effect. Alpha (opacity) values greater than zero are changed to 100%. In other words, anything partially opaque becomes fully opaque.
AlphaFloor | Represents an Alpha Floor effect. Alpha (opacity) values less than 100% are changed to zero. In other words, anything partially transparent becomes fully transparent.
AlphaInverse | Represents an Alpha Inverse effect. Alpha (opacity) values are inverted by subtracting from 100%.
AlphaModulate | Represents an Alpha Modulate effect. Effect alpha (opacity) values are multiplied by a fixed percentage. The effect container specifies an effect containing alpha values to modulate.
AlphaModulateFixed | Represents an Alpha Modulate Fixed effect. Effect alpha (opacity) values are multiplied by a fixed percentage.
AlphaReplace | Represents and Alpha Replace effect. Effect alpha (opacity) values are replaced by a fixed alpha.
BiLevel | Represents a Bi-Level (black/white) effect. Input colors whose luminance is less than the specified threshold value are changed to black. Input colors whose luminance are greater than or equal the specified value are set to white. The alpha effect values are unaffected by this effect.
Blur | Represents a Blur effect that is applied to the entire shape, including its fill. All color channels, including alpha, are affected.
ColorChange | Represents a Color Change effect. Instances of FromColor are replaced with instances of ToColor.
ColorReplace | Represents a Color Replacement effect. All effect colors are changed to a fixed color. Alpha values are unaffected.
Duotone | Represents a Duotone effect. For each pixel, combines Color1 and Color2 through a linear interpolation to determine the new color for that pixel.
FillOverlay | Represents a Fill Overlay effect. A fill overlay may be used to specify an additional fill for an object and blend the two fills together.
GrayScale | Represents a Gray Scale effect. Converts all effect color values to a shade of gray, corresponding to their luminance. Effect alpha (opacity) values are unaffected.
HSL | Represents a Hue/Saturation/Luminance effect. The hue, saturation, and luminance may each be adjusted relative to its current value.
ImageTransformOperation | Represents abstract image transformation effect.
ImageTransformOperationCollection | Represents a collection of effects apllied to an image.
Luminance | Represents a Luminance effect. Brightness linearly shifts all colors closer to white or black. Contrast scales all colors to be either closer or further apart.
Tint | Represents a Tint effect. Shifts effect color values towards/away from hue by the specified amount.
Field | Represents a field.
FillFormat | Represents a fill formatting options.
GeometryShape | Represents the parent class for all geometric shapes.
GradientFormat | Represent a gradient format.
GradientStopCollection | Represnts a collection of gradient stops.
GraphicalObject | Represents abstract graphical object.
GroupShape | Represents a group of shapes on a slide.
LayoutSlide | Represents a layout slide.
LineFillFormat | Represents properties for lines filling.
LineFormat | Represents format of a line.
MasterHandoutSlide | Represents master slide for handouts.
MasterNotesSlide | Represents master slide for notes.
MasterSlide | Represents a master slide in a presentation.
NotesSlide | Represents a notes slide in a presentation.
OleObjectFrame | Represents an OLE object on a slide.
Paragraph | Represents a paragraph of text.
ParagraphCollection | Represents a collection of a paragraphs.
ParagraphFormat | This class contains the paragraph formatting properties. Unlike ParagraphFormatEffectiveData, all properties of this class are writeable.
ParagraphFormatEffectiveData | Immutable object which contains paragraph formatting properties.
PatternFormat | Represents a pattern to fill a shape.
Picture | Represents a picture in a presentation.
PictureFillFormat | Represents a picture fill style.
PictureFrame | Represents a frame with a picture inside.
Portion | Represents a portion of text inside a text paragraph.
Row | Represents a row in a table.
Shape | Represents a shape on a slide.
ShapeStyle | Represent shape's style reference.
Slide | Represents a slide in a presentation.
SmartArt | Represents SmartArt object on a slide.
Table | Represents a table on a slide.
TextFrame | Represents a TextFrame.
TextFrameFormat | Contains the TextFrame's formatting properties.
TextStyle | Summary description for TextStyle.
ColorScheme | Stores theme-defined colors.
FormatScheme | Stores theme-defined formats for the shapes.
MasterTheme | Represents a master theme.
OverrideTheme | Represents a overriding theme.
Theme | Represents a theme.
ThreeDFormat | Represents 3-D properties.
VideoFrame | Represents a video clip on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPresentationComponent Members | Aspose.Slides Namespace


IPresentationComponent Members

IPresentationComponent overview

Public Instance Properties

Presentation

See Also

IPresentationComponent Interface | Aspose.Slides Namespace


IPresentationComponent Properties

The properties of the IPresentationComponent interface are listed below. For a complete list of IPresentationComponent interface members, see the IPresentationComponent Members topic.

Public Instance Properties

Presentation

See Also

IPresentationComponent Interface | Aspose.Slides Namespace


Presentation Property

Aspose.Slides Documentation

IPresentationComponent.Presentation Property

[Visual Basic]
Property Presentation As IPresentation
[C#]
IPresentation Presentation {get;}

See Also

IPresentationComponent Interface | Aspose.Slides Namespace


IPresentationFactory Interface

For a list of all members of this type, see IPresentationFactory Members.

[Visual Basic]
Public Interface IPresentationFactory
[C#]
public interface IPresentationFactory

Types that implement IPresentationFactory

Type | Description
PresentationFactory | Allows to create presentation via COM interface

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPresentationFactory Members | Aspose.Slides Namespace


IPresentationFactory Members

IPresentationFactory overview

Public Instance Methods

CreatePresentation | Overloaded.
ReadPresentation | Overloaded.

See Also

IPresentationFactory Interface | Aspose.Slides Namespace


IPresentationFactory Methods

The methods of the IPresentationFactory interface are listed below. For a complete list of IPresentationFactory interface members, see the IPresentationFactory Members topic.

Public Instance Methods

CreatePresentation | Overloaded.
ReadPresentation | Overloaded.

See Also

IPresentationFactory Interface | Aspose.Slides Namespace


CreatePresentation Method

Aspose.Slides Documentation

IPresentationFactory.CreatePresentation Method

Overload List

IPresentation CreatePresentation();

IPresentation CreatePresentation(ILoadOptions);

See Also

IPresentationFactory Interface | Aspose.Slides Namespace


IPresentationFactory.CreatePresentation Method ()

[Visual Basic]
Function CreatePresentation() As IPresentation
[C#]
IPresentation CreatePresentation();

See Also

IPresentationFactory Interface | Aspose.Slides Namespace | IPresentationFactory.CreatePresentation Overload List


IPresentationFactory.CreatePresentation Method (ILoadOptions)

[Visual Basic]
Function CreatePresentation( _
ByVal options As ILoadOptions _
) As IPresentation
[C#]
IPresentation CreatePresentation(
ILoadOptions options
);

See Also

IPresentationFactory Interface | Aspose.Slides Namespace | IPresentationFactory.CreatePresentation Overload List


ReadPresentation Method

Aspose.Slides Documentation

IPresentationFactory.ReadPresentation Method

Overload List

IPresentation ReadPresentation(byte[]);

IPresentation ReadPresentation(byte[],ILoadOptions);

IPresentation ReadPresentation(Stream);

IPresentation ReadPresentation(Stream,ILoadOptions);

IPresentation ReadPresentation(string);

IPresentation ReadPresentation(string,ILoadOptions);

See Also

IPresentationFactory Interface | Aspose.Slides Namespace


IPresentationFactory.ReadPresentation Method (Byte[])

[Visual Basic]
Function ReadPresentation( _
ByVal data As Byte() _
) As IPresentation
[C#]
IPresentation ReadPresentation(
byte[] data
);

See Also

IPresentationFactory Interface | Aspose.Slides Namespace | IPresentationFactory.ReadPresentation Overload List


IPresentationFactory.ReadPresentation Method (Byte[], ILoadOptions)

[Visual Basic]
Function ReadPresentation( _
ByVal data As Byte(), _
ByVal options As ILoadOptions _
) As IPresentation
[C#]
IPresentation ReadPresentation(
byte[] data,
ILoadOptions options
);

See Also

IPresentationFactory Interface | Aspose.Slides Namespace | IPresentationFactory.ReadPresentation Overload List


IPresentationFactory.ReadPresentation Method (Stream)

[Visual Basic]
Function ReadPresentation( _
ByVal stream As Stream _
) As IPresentation
[C#]
IPresentation ReadPresentation(
Stream stream
);

See Also

IPresentationFactory Interface | Aspose.Slides Namespace | IPresentationFactory.ReadPresentation Overload List


IPresentationFactory.ReadPresentation Method (Stream, ILoadOptions)

[Visual Basic]
Function ReadPresentation( _
ByVal stream As Stream, _
ByVal options As ILoadOptions _
) As IPresentation
[C#]
IPresentation ReadPresentation(
Stream stream,
ILoadOptions options
);

See Also

IPresentationFactory Interface | Aspose.Slides Namespace | IPresentationFactory.ReadPresentation Overload List


IPresentationFactory.ReadPresentation Method (String)

[Visual Basic]
Function ReadPresentation( _
ByVal file As String _
) As IPresentation
[C#]
IPresentation ReadPresentation(
string file
);

See Also

IPresentationFactory Interface | Aspose.Slides Namespace | IPresentationFactory.ReadPresentation Overload List


IPresentationFactory.ReadPresentation Method (String, ILoadOptions)

[Visual Basic]
Function ReadPresentation( _
ByVal file As String, _
ByVal options As ILoadOptions _
) As IPresentation
[C#]
IPresentation ReadPresentation(
string file,
ILoadOptions options
);

See Also

IPresentationFactory Interface | Aspose.Slides Namespace | IPresentationFactory.ReadPresentation Overload List


IProtectionManager Interface

For a list of all members of this type, see IProtectionManager Members.

[Visual Basic]
Public Interface IProtectionManager
[C#]
public interface IProtectionManager

Types that implement IProtectionManager

Type | Description
ProtectionManager |

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IProtectionManager Members | Aspose.Slides Namespace


IProtectionManager Members

IProtectionManager overview

Public Instance Properties

EncryptDocumentProperties
EncryptionPassword
IsEncrypted
IsOnlyDocumentPropertiesLoaded
IsWriteProtected

Public Instance Methods

Encrypt
RemoveEncryption
RemoveWriteProtection
SetWriteProtection

See Also

IProtectionManager Interface | Aspose.Slides Namespace


IProtectionManager Properties

The properties of the IProtectionManager interface are listed below. For a complete list of IProtectionManager interface members, see the IProtectionManager Members topic.

Public Instance Properties

EncryptDocumentProperties
EncryptionPassword
IsEncrypted
IsOnlyDocumentPropertiesLoaded
IsWriteProtected

See Also

IProtectionManager Interface | Aspose.Slides Namespace


EncryptDocumentProperties Property

Aspose.Slides Documentation

IProtectionManager.EncryptDocumentProperties Property

[Visual Basic]
Property EncryptDocumentProperties As Boolean
[C#]
bool EncryptDocumentProperties {get; set;}

See Also

IProtectionManager Interface | Aspose.Slides Namespace


EncryptionPassword Property

Aspose.Slides Documentation

IProtectionManager.EncryptionPassword Property

[Visual Basic]
Property EncryptionPassword As String
[C#]
string EncryptionPassword {get;}

See Also

IProtectionManager Interface | Aspose.Slides Namespace


IsEncrypted Property

Aspose.Slides Documentation

IProtectionManager.IsEncrypted Property

[Visual Basic]
Property IsEncrypted As Boolean
[C#]
bool IsEncrypted {get;}

See Also

IProtectionManager Interface | Aspose.Slides Namespace


IsOnlyDocumentPropertiesLoaded Property

Aspose.Slides Documentation

IProtectionManager.IsOnlyDocumentPropertiesLoaded Property

[Visual Basic]
Property IsOnlyDocumentPropertiesLoaded As Boolean
[C#]
bool IsOnlyDocumentPropertiesLoaded {get;}

See Also

IProtectionManager Interface | Aspose.Slides Namespace


IsWriteProtected Property

Aspose.Slides Documentation

IProtectionManager.IsWriteProtected Property

[Visual Basic]
Property IsWriteProtected As Boolean
[C#]
bool IsWriteProtected {get;}

See Also

IProtectionManager Interface | Aspose.Slides Namespace


IProtectionManager Methods

The methods of the IProtectionManager interface are listed below. For a complete list of IProtectionManager interface members, see the IProtectionManager Members topic.

Public Instance Methods

Encrypt
RemoveEncryption
RemoveWriteProtection
SetWriteProtection

See Also

IProtectionManager Interface | Aspose.Slides Namespace


IProtectionManager.Encrypt Method

[Visual Basic]
Sub Encrypt( _
ByVal encryptionPassword As String _
)
[C#]
void Encrypt(
string encryptionPassword
);

See Also

IProtectionManager Interface | Aspose.Slides Namespace


IProtectionManager.RemoveEncryption Method

[Visual Basic]
Sub RemoveEncryption()
[C#]
void RemoveEncryption();

See Also

IProtectionManager Interface | Aspose.Slides Namespace


IProtectionManager.RemoveWriteProtection Method

[Visual Basic]
Sub RemoveWriteProtection()
[C#]
void RemoveWriteProtection();

See Also

IProtectionManager Interface | Aspose.Slides Namespace


IProtectionManager.SetWriteProtection Method

[Visual Basic]
Sub SetWriteProtection( _
ByVal password As String _
)
[C#]
void SetWriteProtection(
string password
);

See Also

IProtectionManager Interface | Aspose.Slides Namespace


IRow Interface

For a list of all members of this type, see IRow Members.

[Visual Basic]
Public Interface IRow
Implements ICellCollection, ISlideComponent, IPresentationComponent, ICollection, IEnumerable
[C#]
public interface IRow : ICellCollection, ISlideComponent, IPresentationComponent, ICollection, IEnumerable

Types that implement IRow

Type | Description
Row | Represents a row in a table.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IRow Members | Aspose.Slides Namespace


IRow Members

IRow overview

Public Instance Properties

AsICellCollection
Height
MinimalHeight

See Also

IRow Interface | Aspose.Slides Namespace


IRow Properties

The properties of the IRow interface are listed below. For a complete list of IRow interface members, see the IRow Members topic.

Public Instance Properties

AsICellCollection
Height
MinimalHeight

See Also

IRow Interface | Aspose.Slides Namespace


AsICellCollection Property

Aspose.Slides Documentation

IRow.AsICellCollection Property

[Visual Basic]
Property AsICellCollection As ICellCollection
[C#]
ICellCollection AsICellCollection {get;}

See Also

IRow Interface | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

IRow.Height Property

[Visual Basic]
Property Height As Double
[C#]
double Height {get;}

See Also

IRow Interface | Aspose.Slides Namespace


MinimalHeight Property

Aspose.Slides Documentation

IRow.MinimalHeight Property

[Visual Basic]
Property MinimalHeight As Double
[C#]
double MinimalHeight {get; set;}

See Also

IRow Interface | Aspose.Slides Namespace


IRowCollection Interface

For a list of all members of this type, see IRowCollection Members.

[Visual Basic]
Public Interface IRowCollection
Implements ICollection, IEnumerable
[C#]
public interface IRowCollection : ICollection, IEnumerable

Types that implement IRowCollection

Type | Description
RowCollection | Represents a collection of rows.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IRowCollection Members | Aspose.Slides Namespace


IRowCollection Members

IRowCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

AddClone
InsertClone
RemoveAt

See Also

IRowCollection Interface | Aspose.Slides Namespace


IRowCollection Properties

The properties of the IRowCollection interface are listed below. For a complete list of IRowCollection interface members, see the IRowCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IRowCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

IRowCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IRowCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IRowCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IRowCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IRowCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IRow
[C#]
IRow this[
int index
] {get;}

See Also

IRowCollection Interface | Aspose.Slides Namespace


IRowCollection Methods

The methods of the IRowCollection interface are listed below. For a complete list of IRowCollection interface members, see the IRowCollection Members topic.

Public Instance Methods

AddClone
InsertClone
RemoveAt

See Also

IRowCollection Interface | Aspose.Slides Namespace


IRowCollection.AddClone Method

[Visual Basic]
Function AddClone( _
ByVal templ As IRow, _
ByVal withAttachedRows As Boolean _
) As IRow()
[C#]
IRow[] AddClone(
IRow templ,
bool withAttachedRows
);

See Also

IRowCollection Interface | Aspose.Slides Namespace


IRowCollection.InsertClone Method

[Visual Basic]
Function InsertClone( _
ByVal index As Integer, _
ByVal templ As IRow, _
ByVal withAttachedRows As Boolean _
) As IRow()
[C#]
IRow[] InsertClone(
int index,
IRow templ,
bool withAttachedRows
);

See Also

IRowCollection Interface | Aspose.Slides Namespace


IRowCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal firstRowIndex As Integer, _
ByVal withAttachedRows As Boolean _
)
[C#]
void RemoveAt(
int firstRowIndex,
bool withAttachedRows
);

See Also

IRowCollection Interface | Aspose.Slides Namespace


IShape Interface

For a list of all members of this type, see IShape Members.

Aspose.Slides.IShape
Derived interfaces

[Visual Basic]
Public Interface IShape
Implements ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public interface IShape : ISlideComponent, IPresentationComponent, IHyperlinkContainer

Types that implement IShape

Type | Description
AudioFrame | Represents an audio clip on a slide.
AutoShape | Represents an AutoShape.
Chart | Represents an graphic chart on a slide.
Connector | Represents a connector.
GeometryShape | Represents the parent class for all geometric shapes.
GraphicalObject | Represents abstract graphical object.
GroupShape | Represents a group of shapes on a slide.
OleObjectFrame | Represents an OLE object on a slide.
PictureFrame | Represents a frame with a picture inside.
Shape | Represents a shape on a slide.
SmartArt | Represents SmartArt object on a slide.
Table | Represents a table on a slide.
VideoFrame | Represents a video clip on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IShape Members | Aspose.Slides Namespace


IShape Members

IShape overview

Public Instance Properties

AlternativeText
AsIHyperlinkContainer
AsISlideComponent
CustomData
EffectFormat
FillFormat
Frame
Height
Hidden
IsTextHolder
LineFormat
Name
Placeholder
RawFrame
Rotation
ShapeLock
ThreeDFormat
UniqueId
Width
X
Y
ZOrderPosition

Public Instance Methods

AddPlaceholder |
CreateEffectFormatEffective |
CreateFillFormatEffective |
CreateLineFormatEffective |
CreateThreeDFormatEffective |
GetThumbnail | Overloaded.
RemovePlaceholder |

See Also

IShape Interface | Aspose.Slides Namespace


IShape Properties

The properties of the IShape interface are listed below. For a complete list of IShape interface members, see the IShape Members topic.

Public Instance Properties

AlternativeText
AsIHyperlinkContainer
AsISlideComponent
CustomData
EffectFormat
FillFormat
Frame
Height
Hidden
IsTextHolder
LineFormat
Name
Placeholder
RawFrame
Rotation
ShapeLock
ThreeDFormat
UniqueId
Width
X
Y
ZOrderPosition

See Also

IShape Interface | Aspose.Slides Namespace


AlternativeText Property

Aspose.Slides Documentation

IShape.AlternativeText Property

[Visual Basic]
Property AlternativeText As String
[C#]
string AlternativeText {get; set;}

See Also

IShape Interface | Aspose.Slides Namespace


AsIHyperlinkContainer Property

Aspose.Slides Documentation

IShape.AsIHyperlinkContainer Property

[Visual Basic]
Property AsIHyperlinkContainer As IHyperlinkContainer
[C#]
IHyperlinkContainer AsIHyperlinkContainer {get;}

See Also

IShape Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IShape.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IShape Interface | Aspose.Slides Namespace


CustomData Property

Aspose.Slides Documentation

IShape.CustomData Property

[Visual Basic]
Property CustomData As ICustomData
[C#]
ICustomData CustomData {get;}

See Also

IShape Interface | Aspose.Slides Namespace


EffectFormat Property

Aspose.Slides Documentation

IShape.EffectFormat Property

[Visual Basic]
Property EffectFormat As IEffectFormat
[C#]
IEffectFormat EffectFormat {get;}

See Also

IShape Interface | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

IShape.FillFormat Property

[Visual Basic]
Property FillFormat As IFillFormat
[C#]
IFillFormat FillFormat {get;}

See Also

IShape Interface | Aspose.Slides Namespace


Frame Property

Aspose.Slides Documentation

IShape.Frame Property

[Visual Basic]
Property Frame As IShapeFrame
[C#]
IShapeFrame Frame {get; set;}

See Also

IShape Interface | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

IShape.Height Property

[Visual Basic]
Property Height As Single
[C#]
float Height {get; set;}

See Also

IShape Interface | Aspose.Slides Namespace


Hidden Property

Aspose.Slides Documentation

IShape.Hidden Property

[Visual Basic]
Property Hidden As Boolean
[C#]
bool Hidden {get; set;}

See Also

IShape Interface | Aspose.Slides Namespace


IsTextHolder Property

Aspose.Slides Documentation

IShape.IsTextHolder Property

[Visual Basic]
Property IsTextHolder As Boolean
[C#]
bool IsTextHolder {get;}

See Also

IShape Interface | Aspose.Slides Namespace


LineFormat Property

Aspose.Slides Documentation

IShape.LineFormat Property

[Visual Basic]
Property LineFormat As ILineFormat
[C#]
ILineFormat LineFormat {get;}

See Also

IShape Interface | Aspose.Slides Namespace


Name Property

Aspose.Slides Documentation

IShape.Name Property

[Visual Basic]
Property Name As String
[C#]
string Name {get; set;}

See Also

IShape Interface | Aspose.Slides Namespace


Placeholder Property

Aspose.Slides Documentation

IShape.Placeholder Property

[Visual Basic]
Property Placeholder As IPlaceholder
[C#]
IPlaceholder Placeholder {get;}

See Also

IShape Interface | Aspose.Slides Namespace


RawFrame Property

Aspose.Slides Documentation

IShape.RawFrame Property

[Visual Basic]
Property RawFrame As IShapeFrame
[C#]
IShapeFrame RawFrame {get; set;}

See Also

IShape Interface | Aspose.Slides Namespace


Rotation Property

Aspose.Slides Documentation

IShape.Rotation Property

[Visual Basic]
Property Rotation As Single
[C#]
float Rotation {get; set;}

See Also

IShape Interface | Aspose.Slides Namespace


ShapeLock Property

Aspose.Slides Documentation

IShape.ShapeLock Property

[Visual Basic]
Property ShapeLock As IBaseShapeLock
[C#]
IBaseShapeLock ShapeLock {get;}

See Also

IShape Interface | Aspose.Slides Namespace


ThreeDFormat Property

Aspose.Slides Documentation

IShape.ThreeDFormat Property

[Visual Basic]
Property ThreeDFormat As IThreeDFormat
[C#]
IThreeDFormat ThreeDFormat {get;}

See Also

IShape Interface | Aspose.Slides Namespace


UniqueId Property

Aspose.Slides Documentation

IShape.UniqueId Property

[Visual Basic]
Property UniqueId As UInt32
[C#]
uint UniqueId {get;}

See Also

IShape Interface | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

IShape.Width Property

[Visual Basic]
Property Width As Single
[C#]
float Width {get; set;}

See Also

IShape Interface | Aspose.Slides Namespace


X Property

Aspose.Slides Documentation

IShape.X Property

[Visual Basic]
Property X As Single
[C#]
float X {get; set;}

See Also

IShape Interface | Aspose.Slides Namespace


Y Property

Aspose.Slides Documentation

IShape.Y Property

[Visual Basic]
Property Y As Single
[C#]
float Y {get; set;}

See Also

IShape Interface | Aspose.Slides Namespace


ZOrderPosition Property

Aspose.Slides Documentation

IShape.ZOrderPosition Property

[Visual Basic]
Property ZOrderPosition As Integer
[C#]
int ZOrderPosition {get;}

See Also

IShape Interface | Aspose.Slides Namespace


IShape Methods

The methods of the IShape interface are listed below. For a complete list of IShape interface members, see the IShape Members topic.

Public Instance Methods

AddPlaceholder |
CreateEffectFormatEffective |
CreateFillFormatEffective |
CreateLineFormatEffective |
CreateThreeDFormatEffective |
GetThumbnail | Overloaded.
RemovePlaceholder |

See Also

IShape Interface | Aspose.Slides Namespace


IShape.AddPlaceholder Method

[Visual Basic]
Function AddPlaceholder( _
ByVal placeholderToCopyFrom As IPlaceholder _
) As IPlaceholder
[C#]
IPlaceholder AddPlaceholder(
IPlaceholder placeholderToCopyFrom
);

See Also

IShape Interface | Aspose.Slides Namespace


IShape.CreateEffectFormatEffective Method

[Visual Basic]
Function CreateEffectFormatEffective() As IEffectFormatEffectiveData
[C#]
IEffectFormatEffectiveData CreateEffectFormatEffective();

See Also

IShape Interface | Aspose.Slides Namespace


IShape.CreateFillFormatEffective Method

[Visual Basic]
Function CreateFillFormatEffective() As IFillFormatEffectiveData
[C#]
IFillFormatEffectiveData CreateFillFormatEffective();

See Also

IShape Interface | Aspose.Slides Namespace


IShape.CreateLineFormatEffective Method

[Visual Basic]
Function CreateLineFormatEffective() As ILineFormatEffectiveData
[C#]
ILineFormatEffectiveData CreateLineFormatEffective();

See Also

IShape Interface | Aspose.Slides Namespace


IShape.CreateThreeDFormatEffective Method

[Visual Basic]
Function CreateThreeDFormatEffective() As IThreeDFormatEffectiveData
[C#]
IThreeDFormatEffectiveData CreateThreeDFormatEffective();

See Also

IShape Interface | Aspose.Slides Namespace


GetThumbnail Method

Aspose.Slides Documentation

IShape.GetThumbnail Method

Overload List

Bitmap GetThumbnail();

Bitmap GetThumbnail(ShapeThumbnailBounds,float,float);

See Also

IShape Interface | Aspose.Slides Namespace


IShape.GetThumbnail Method ()

[Visual Basic]
Function GetThumbnail() As Bitmap
[C#]
Bitmap GetThumbnail();

See Also

IShape Interface | Aspose.Slides Namespace | IShape.GetThumbnail Overload List


IShape.GetThumbnail Method (ShapeThumbnailBounds, Single, Single)

[Visual Basic]
Function GetThumbnail( _
ByVal bounds As ShapeThumbnailBounds, _
ByVal scaleX As Single, _
ByVal scaleY As Single _
) As Bitmap
[C#]
Bitmap GetThumbnail(
ShapeThumbnailBounds bounds,
float scaleX,
float scaleY
);

See Also

IShape Interface | Aspose.Slides Namespace | IShape.GetThumbnail Overload List


IShape.RemovePlaceholder Method

[Visual Basic]
Sub RemovePlaceholder()
[C#]
void RemovePlaceholder();

See Also

IShape Interface | Aspose.Slides Namespace


IShapeBevel Interface

For a list of all members of this type, see IShapeBevel Members.

[Visual Basic]
Public Interface IShapeBevel
[C#]
public interface IShapeBevel

Types that implement IShapeBevel

Type | Description
ShapeBevel | Contains the properties of shape's main face relief.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IShapeBevel Members | Aspose.Slides Namespace


IShapeBevel Members

IShapeBevel overview

Public Instance Properties

BevelType
Height
Width

See Also

IShapeBevel Interface | Aspose.Slides Namespace


IShapeBevel Properties

The properties of the IShapeBevel interface are listed below. For a complete list of IShapeBevel interface members, see the IShapeBevel Members topic.

Public Instance Properties

BevelType
Height
Width

See Also

IShapeBevel Interface | Aspose.Slides Namespace


BevelType Property

Aspose.Slides Documentation

IShapeBevel.BevelType Property

[Visual Basic]
Property BevelType As BevelPresetType
[C#]
BevelPresetType BevelType {get; set;}

See Also

IShapeBevel Interface | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

IShapeBevel.Height Property

[Visual Basic]
Property Height As Double
[C#]
double Height {get; set;}

See Also

IShapeBevel Interface | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

IShapeBevel.Width Property

[Visual Basic]
Property Width As Double
[C#]
double Width {get; set;}

See Also

IShapeBevel Interface | Aspose.Slides Namespace


IShapeBevelEffectiveData Interface

[Visual Basic]
Public Interface IShapeBevelEffectiveData
[C#]
public interface IShapeBevelEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


IShapeCollection Interface

For a list of all members of this type, see IShapeCollection Members.

[Visual Basic]
Public Interface IShapeCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IShape, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IShapeCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IShapeCollection

Type | Description
ShapeCollection | Represents a collection of a shapes.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IShapeCollection Members | Aspose.Slides Namespace


IShapeCollection Members

IShapeCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item
Parent

Public Instance Methods

AddAudioFrameCD |
AddAudioFrameEmbedded | Overloaded.
AddAudioFrameLinked |
AddAutoShape | Overloaded.
AddChart | Overloaded.
AddConnector | Overloaded.
AddOleObjectFrame | Overloaded.
AddPictureFrame |
AddSmartArt |
AddTable |
AddVideoFrame | Overloaded.
IndexOf |
InsertAudioFrameCD |
InsertAudioFrameEmbedded | Overloaded.
InsertAudioFrameLinked |
InsertAutoShape | Overloaded.
InsertChart | Overloaded.
InsertConnector | Overloaded.
InsertOleObjectFrame | Overloaded.
InsertPictureFrame |
InsertTable |
InsertVideoFrame |
Remove |
RemoveAt |
Reorder | Overloaded.
ToArray | Overloaded.

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection Properties

The properties of the IShapeCollection interface are listed below. For a complete list of IShapeCollection interface members, see the IShapeCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item
Parent

See Also

IShapeCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

IShapeCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IShapeCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IShapeCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IShapeCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IShapeCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IShape
[C#]
IShape this[
int index
] {get;}

See Also

IShapeCollection Interface | Aspose.Slides Namespace


Parent Property

Aspose.Slides Documentation

IShapeCollection.Parent Property

[Visual Basic]
Property Parent As ISlideComponent
[C#]
ISlideComponent Parent {get;}

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection Methods

The methods of the IShapeCollection interface are listed below. For a complete list of IShapeCollection interface members, see the IShapeCollection Members topic.

Public Instance Methods

AddAudioFrameCD |
AddAudioFrameEmbedded | Overloaded.
AddAudioFrameLinked |
AddAutoShape | Overloaded.
AddChart | Overloaded.
AddConnector | Overloaded.
AddOleObjectFrame | Overloaded.
AddPictureFrame |
AddSmartArt |
AddTable |
AddVideoFrame | Overloaded.
IndexOf |
InsertAudioFrameCD |
InsertAudioFrameEmbedded | Overloaded.
InsertAudioFrameLinked |
InsertAutoShape | Overloaded.
InsertChart | Overloaded.
InsertConnector | Overloaded.
InsertOleObjectFrame | Overloaded.
InsertPictureFrame |
InsertTable |
InsertVideoFrame |
Remove |
RemoveAt |
Reorder | Overloaded.
ToArray | Overloaded.

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.AddAudioFrameCD Method

[Visual Basic]
Function AddAudioFrameCD( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IAudioFrame
[C#]
IAudioFrame AddAudioFrameCD(
float x,
float y,
float width,
float height
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


AddAudioFrameEmbedded Method

Aspose.Slides Documentation

IShapeCollection.AddAudioFrameEmbedded Method

Overload List

IAudioFrame AddAudioFrameEmbedded(float,float,float,float,IAudio);

IAudioFrame AddAudioFrameEmbedded(float,float,float,float,Stream);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.AddAudioFrameEmbedded Method (Single, Single, Single, Single, IAudio)

[Visual Basic]
Function AddAudioFrameEmbedded( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal audio As IAudio _
) As IAudioFrame
[C#]
IAudioFrame AddAudioFrameEmbedded(
float x,
float y,
float width,
float height,
IAudio audio
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.AddAudioFrameEmbedded Overload List


IShapeCollection.AddAudioFrameEmbedded Method (Single, Single, Single, Single, Stream)

[Visual Basic]
Function AddAudioFrameEmbedded( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal audio_stream As Stream _
) As IAudioFrame
[C#]
IAudioFrame AddAudioFrameEmbedded(
float x,
float y,
float width,
float height,
Stream audio_stream
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.AddAudioFrameEmbedded Overload List


IShapeCollection.AddAudioFrameLinked Method

[Visual Basic]
Function AddAudioFrameLinked( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal fname As String _
) As IAudioFrame
[C#]
IAudioFrame AddAudioFrameLinked(
float x,
float y,
float width,
float height,
string fname
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


AddAutoShape Method

Aspose.Slides Documentation

IShapeCollection.AddAutoShape Method

Overload List

IAutoShape AddAutoShape(ShapeType,float,float,float,float);

IAutoShape AddAutoShape(ShapeType,float,float,float,float,bool);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.AddAutoShape Method (ShapeType, Single, Single, Single, Single)

[Visual Basic]
Function AddAutoShape( _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IAutoShape
[C#]
IAutoShape AddAutoShape(
ShapeType shapeType,
float x,
float y,
float width,
float height
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.AddAutoShape Overload List


IShapeCollection.AddAutoShape Method (ShapeType, Single, Single, Single, Single, Boolean)

[Visual Basic]
Function AddAutoShape( _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal createFromTemplate As Boolean _
) As IAutoShape
[C#]
IAutoShape AddAutoShape(
ShapeType shapeType,
float x,
float y,
float width,
float height,
bool createFromTemplate
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.AddAutoShape Overload List


AddChart Method

Aspose.Slides Documentation

IShapeCollection.AddChart Method

Overload List

IChart AddChart(ChartType,float,float,float,float);

IChart AddChart(ChartType,float,float,float,float,bool);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.AddChart Method (ChartType, Single, Single, Single, Single)

[Visual Basic]
Function AddChart( _
ByVal type As ChartType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IChart
[C#]
IChart AddChart(
ChartType type,
float x,
float y,
float width,
float height
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.AddChart Overload List


IShapeCollection.AddChart Method (ChartType, Single, Single, Single, Single, Boolean)

[Visual Basic]
Function AddChart( _
ByVal type As ChartType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal initWithSample As Boolean _
) As IChart
[C#]
IChart AddChart(
ChartType type,
float x,
float y,
float width,
float height,
bool initWithSample
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.AddChart Overload List


AddConnector Method

Aspose.Slides Documentation

IShapeCollection.AddConnector Method

Overload List

IConnector AddConnector(ShapeType,float,float,float,float);

IConnector AddConnector(ShapeType,float,float,float,float,bool);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.AddConnector Method (ShapeType, Single, Single, Single, Single)

[Visual Basic]
Function AddConnector( _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IConnector
[C#]
IConnector AddConnector(
ShapeType shapeType,
float x,
float y,
float width,
float height
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.AddConnector Overload List


IShapeCollection.AddConnector Method (ShapeType, Single, Single, Single, Single, Boolean)

[Visual Basic]
Function AddConnector( _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal createFromTemplate As Boolean _
) As IConnector
[C#]
IConnector AddConnector(
ShapeType shapeType,
float x,
float y,
float width,
float height,
bool createFromTemplate
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.AddConnector Overload List


AddOleObjectFrame Method

Aspose.Slides Documentation

IShapeCollection.AddOleObjectFrame Method

Overload List

IOleObjectFrame AddOleObjectFrame(float,float,float,float,string,byte[]);

IOleObjectFrame AddOleObjectFrame(float,float,float,float,string,string);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.AddOleObjectFrame Method (Single, Single, Single, Single, String, Byte[])

[Visual Basic]
Function AddOleObjectFrame( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal className As String, _
ByVal objectData As Byte() _
) As IOleObjectFrame
[C#]
IOleObjectFrame AddOleObjectFrame(
float x,
float y,
float width,
float height,
string className,
byte[] objectData
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.AddOleObjectFrame Overload List


IShapeCollection.AddOleObjectFrame Method (Single, Single, Single, Single, String, String)

[Visual Basic]
Function AddOleObjectFrame( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal className As String, _
ByVal path As String _
) As IOleObjectFrame
[C#]
IOleObjectFrame AddOleObjectFrame(
float x,
float y,
float width,
float height,
string className,
string path
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.AddOleObjectFrame Overload List


IShapeCollection.AddPictureFrame Method

[Visual Basic]
Function AddPictureFrame( _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal image As IPPImage _
) As IPictureFrame
[C#]
IPictureFrame AddPictureFrame(
ShapeType shapeType,
float x,
float y,
float width,
float height,
IPPImage image
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.AddSmartArt Method

[Visual Basic]
Function AddSmartArt( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal layoutType As SmartArtLayoutType _
) As ISmartArt
[C#]
ISmartArt AddSmartArt(
float x,
float y,
float width,
float height,
SmartArtLayoutType layoutType
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.AddTable Method

[Visual Basic]
Function AddTable( _
ByVal x As Single, _
ByVal y As Single, _
ByVal columnWidths As Double(), _
ByVal rowHeights As Double() _
) As ITable
[C#]
ITable AddTable(
float x,
float y,
double[] columnWidths,
double[] rowHeights
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


AddVideoFrame Method

Aspose.Slides Documentation

IShapeCollection.AddVideoFrame Method

Overload List

IVideoFrame AddVideoFrame(float,float,float,float,IVideo);

IVideoFrame AddVideoFrame(float,float,float,float,string);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.AddVideoFrame Method (Single, Single, Single, Single, IVideo)

[Visual Basic]
Function AddVideoFrame( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal video As IVideo _
) As IVideoFrame
[C#]
IVideoFrame AddVideoFrame(
float x,
float y,
float width,
float height,
IVideo video
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.AddVideoFrame Overload List


IShapeCollection.AddVideoFrame Method (Single, Single, Single, Single, String)

[Visual Basic]
Function AddVideoFrame( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal fname As String _
) As IVideoFrame
[C#]
IVideoFrame AddVideoFrame(
float x,
float y,
float width,
float height,
string fname
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.AddVideoFrame Overload List


IShapeCollection.IndexOf Method

[Visual Basic]
Function IndexOf( _
ByVal shape As IShape _
) As Integer
[C#]
int IndexOf(
IShape shape
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.InsertAudioFrameCD Method

[Visual Basic]
Function InsertAudioFrameCD( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IAudioFrame
[C#]
IAudioFrame InsertAudioFrameCD(
int index,
float x,
float y,
float width,
float height
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


InsertAudioFrameEmbedded Method

Aspose.Slides Documentation

IShapeCollection.InsertAudioFrameEmbedded Method

Overload List

IAudioFrame InsertAudioFrameEmbedded(int,float,float,float,float,IAudio);

IAudioFrame InsertAudioFrameEmbedded(int,float,float,float,float,Stream);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.InsertAudioFrameEmbedded Method (Int32, Single, Single, Single, Single, IAudio)

[Visual Basic]
Function InsertAudioFrameEmbedded( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal audio As IAudio _
) As IAudioFrame
[C#]
IAudioFrame InsertAudioFrameEmbedded(
int index,
float x,
float y,
float width,
float height,
IAudio audio
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.InsertAudioFrameEmbedded Overload List


IShapeCollection.InsertAudioFrameEmbedded Method (Int32, Single, Single, Single, Single, Stream)

[Visual Basic]
Function InsertAudioFrameEmbedded( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal audio_stream As Stream _
) As IAudioFrame
[C#]
IAudioFrame InsertAudioFrameEmbedded(
int index,
float x,
float y,
float width,
float height,
Stream audio_stream
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.InsertAudioFrameEmbedded Overload List


IShapeCollection.InsertAudioFrameLinked Method

[Visual Basic]
Function InsertAudioFrameLinked( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal fname As String _
) As IAudioFrame
[C#]
IAudioFrame InsertAudioFrameLinked(
int index,
float x,
float y,
float width,
float height,
string fname
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


InsertAutoShape Method

Aspose.Slides Documentation

IShapeCollection.InsertAutoShape Method

Overload List

IAutoShape InsertAutoShape(int,ShapeType,float,float,float,float);

IAutoShape InsertAutoShape(int,ShapeType,float,float,float,float,bool);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.InsertAutoShape Method (Int32, ShapeType, Single, Single, Single, Single)

[Visual Basic]
Function InsertAutoShape( _
ByVal index As Integer, _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IAutoShape
[C#]
IAutoShape InsertAutoShape(
int index,
ShapeType shapeType,
float x,
float y,
float width,
float height
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.InsertAutoShape Overload List


IShapeCollection.InsertAutoShape Method (Int32, ShapeType, Single, Single, Single, Single, Boolean)

[Visual Basic]
Function InsertAutoShape( _
ByVal index As Integer, _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal createFromTemplate As Boolean _
) As IAutoShape
[C#]
IAutoShape InsertAutoShape(
int index,
ShapeType shapeType,
float x,
float y,
float width,
float height,
bool createFromTemplate
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.InsertAutoShape Overload List


InsertChart Method

Aspose.Slides Documentation

IShapeCollection.InsertChart Method

Overload List

IChart InsertChart(ChartType,float,float,float,float,int);

IChart InsertChart(ChartType,float,float,float,float,int,bool);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.InsertChart Method (ChartType, Single, Single, Single, Single, Int32)

[Visual Basic]
Function InsertChart( _
ByVal type As ChartType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal index As Integer _
) As IChart
[C#]
IChart InsertChart(
ChartType type,
float x,
float y,
float width,
float height,
int index
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.InsertChart Overload List


IShapeCollection.InsertChart Method (ChartType, Single, Single, Single, Single, Int32, Boolean)

[Visual Basic]
Function InsertChart( _
ByVal type As ChartType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal index As Integer, _
ByVal initWithSample As Boolean _
) As IChart
[C#]
IChart InsertChart(
ChartType type,
float x,
float y,
float width,
float height,
int index,
bool initWithSample
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.InsertChart Overload List


InsertConnector Method

Aspose.Slides Documentation

IShapeCollection.InsertConnector Method

Overload List

IConnector InsertConnector(int,ShapeType,float,float,float,float);

IConnector InsertConnector(int,ShapeType,float,float,float,float,bool);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.InsertConnector Method (Int32, ShapeType, Single, Single, Single, Single)

[Visual Basic]
Function InsertConnector( _
ByVal index As Integer, _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IConnector
[C#]
IConnector InsertConnector(
int index,
ShapeType shapeType,
float x,
float y,
float width,
float height
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.InsertConnector Overload List


IShapeCollection.InsertConnector Method (Int32, ShapeType, Single, Single, Single, Single, Boolean)

[Visual Basic]
Function InsertConnector( _
ByVal index As Integer, _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal createFromTemplate As Boolean _
) As IConnector
[C#]
IConnector InsertConnector(
int index,
ShapeType shapeType,
float x,
float y,
float width,
float height,
bool createFromTemplate
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.InsertConnector Overload List


InsertOleObjectFrame Method

Aspose.Slides Documentation

IShapeCollection.InsertOleObjectFrame Method

Overload List

IOleObjectFrame InsertOleObjectFrame(int,float,float,float,float,string,byte[]);

IOleObjectFrame InsertOleObjectFrame(int,float,float,float,float,string,string);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.InsertOleObjectFrame Method (Int32, Single, Single, Single, Single, String, Byte[])

[Visual Basic]
Function InsertOleObjectFrame( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal className As String, _
ByVal objectData As Byte() _
) As IOleObjectFrame
[C#]
IOleObjectFrame InsertOleObjectFrame(
int index,
float x,
float y,
float width,
float height,
string className,
byte[] objectData
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.InsertOleObjectFrame Overload List


IShapeCollection.InsertOleObjectFrame Method (Int32, Single, Single, Single, Single, String, String)

[Visual Basic]
Function InsertOleObjectFrame( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal className As String, _
ByVal path As String _
) As IOleObjectFrame
[C#]
IOleObjectFrame InsertOleObjectFrame(
int index,
float x,
float y,
float width,
float height,
string className,
string path
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.InsertOleObjectFrame Overload List


IShapeCollection.InsertPictureFrame Method

[Visual Basic]
Function InsertPictureFrame( _
ByVal index As Integer, _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal image As IPPImage _
) As IPictureFrame
[C#]
IPictureFrame InsertPictureFrame(
int index,
ShapeType shapeType,
float x,
float y,
float width,
float height,
IPPImage image
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.InsertTable Method

[Visual Basic]
Function InsertTable( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal columnWidths As Double(), _
ByVal rowHeights As Double() _
) As ITable
[C#]
ITable InsertTable(
int index,
float x,
float y,
double[] columnWidths,
double[] rowHeights
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.InsertVideoFrame Method

[Visual Basic]
Function InsertVideoFrame( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal fname As String _
) As IVideoFrame
[C#]
IVideoFrame InsertVideoFrame(
int index,
float x,
float y,
float width,
float height,
string fname
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.Remove Method

[Visual Basic]
Sub Remove( _
ByVal shape As IShape _
)
[C#]
void Remove(
IShape shape
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


Reorder Method

Aspose.Slides Documentation

IShapeCollection.Reorder Method

Overload List

void Reorder(int,IShape);

void Reorder(int,params IShape[]);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.Reorder Method (Int32, IShape)

[Visual Basic]
Sub Reorder( _
ByVal index As Integer, _
ByVal shape As IShape _
)
[C#]
void Reorder(
int index,
IShape shape
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.Reorder Overload List


IShapeCollection.Reorder Method (Int32, IShape[])

[Visual Basic]
Sub Reorder( _
ByVal index As Integer, _
ParamArray shapes As IShape() _
)
[C#]
void Reorder(
int index,
params IShape[] shapes
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.Reorder Overload List


ToArray Method

Aspose.Slides Documentation

IShapeCollection.ToArray Method

Overload List

IShape[] ToArray();

IShape[] ToArray(int,int);

See Also

IShapeCollection Interface | Aspose.Slides Namespace


IShapeCollection.ToArray Method ()

[Visual Basic]
Function ToArray() As IShape()
[C#]
IShape[] ToArray();

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.ToArray Overload List


IShapeCollection.ToArray Method (Int32, Int32)

[Visual Basic]
Function ToArray( _
ByVal startIndex As Integer, _
ByVal count As Integer _
) As IShape()
[C#]
IShape[] ToArray(
int startIndex,
int count
);

See Also

IShapeCollection Interface | Aspose.Slides Namespace | IShapeCollection.ToArray Overload List


IShapeElement Interface

[Visual Basic]
Public Interface IShapeElement
[C#]
public interface IShapeElement

Types that implement IShapeElement

Type | Description
ShapeElement | Represents a part of shape with same outline and fill properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


IShapeFrame Interface

For a list of all members of this type, see IShapeFrame Members.

[Visual Basic]
Public Interface IShapeFrame
Implements ICloneable
[C#]
public interface IShapeFrame : ICloneable

Types that implement IShapeFrame

Type | Description
ShapeFrame | Represents shape frame's properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IShapeFrame Members | Aspose.Slides Namespace


IShapeFrame Members

IShapeFrame overview

Public Instance Properties

CenterX
CenterY
FlipH
FlipV
Height
Rectangle
Rotation
Width
X
Y

Public Instance Methods

CloneShapeFrame

See Also

IShapeFrame Interface | Aspose.Slides Namespace


IShapeFrame Properties

The properties of the IShapeFrame interface are listed below. For a complete list of IShapeFrame interface members, see the IShapeFrame Members topic.

Public Instance Properties

CenterX
CenterY
FlipH
FlipV
Height
Rectangle
Rotation
Width
X
Y

See Also

IShapeFrame Interface | Aspose.Slides Namespace


CenterX Property

Aspose.Slides Documentation

IShapeFrame.CenterX Property

[Visual Basic]
Property CenterX As Single
[C#]
float CenterX {get;}

See Also

IShapeFrame Interface | Aspose.Slides Namespace


CenterY Property

Aspose.Slides Documentation

IShapeFrame.CenterY Property

[Visual Basic]
Property CenterY As Single
[C#]
float CenterY {get;}

See Also

IShapeFrame Interface | Aspose.Slides Namespace


FlipH Property

Aspose.Slides Documentation

IShapeFrame.FlipH Property

[Visual Basic]
Property FlipH As Boolean
[C#]
bool FlipH {get;}

See Also

IShapeFrame Interface | Aspose.Slides Namespace


FlipV Property

Aspose.Slides Documentation

IShapeFrame.FlipV Property

[Visual Basic]
Property FlipV As Boolean
[C#]
bool FlipV {get;}

See Also

IShapeFrame Interface | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

IShapeFrame.Height Property

[Visual Basic]
Property Height As Single
[C#]
float Height {get;}

See Also

IShapeFrame Interface | Aspose.Slides Namespace


Rectangle Property

Aspose.Slides Documentation

IShapeFrame.Rectangle Property

[Visual Basic]
Property Rectangle As RectangleF
[C#]
RectangleF Rectangle {get;}

See Also

IShapeFrame Interface | Aspose.Slides Namespace


Rotation Property

Aspose.Slides Documentation

IShapeFrame.Rotation Property

[Visual Basic]
Property Rotation As Single
[C#]
float Rotation {get;}

See Also

IShapeFrame Interface | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

IShapeFrame.Width Property

[Visual Basic]
Property Width As Single
[C#]
float Width {get;}

See Also

IShapeFrame Interface | Aspose.Slides Namespace


X Property

Aspose.Slides Documentation

IShapeFrame.X Property

[Visual Basic]
Property X As Single
[C#]
float X {get;}

See Also

IShapeFrame Interface | Aspose.Slides Namespace


Y Property

Aspose.Slides Documentation

IShapeFrame.Y Property

[Visual Basic]
Property Y As Single
[C#]
float Y {get;}

See Also

IShapeFrame Interface | Aspose.Slides Namespace


IShapeFrame Methods

The methods of the IShapeFrame interface are listed below. For a complete list of IShapeFrame interface members, see the IShapeFrame Members topic.

Public Instance Methods

CloneShapeFrame

See Also

IShapeFrame Interface | Aspose.Slides Namespace


IShapeFrame.CloneShapeFrame Method

[Visual Basic]
Function CloneShapeFrame() As IShapeFrame
[C#]
IShapeFrame CloneShapeFrame();

See Also

IShapeFrame Interface | Aspose.Slides Namespace


IShapeStyle Interface

For a list of all members of this type, see IShapeStyle Members.

[Visual Basic]
Public Interface IShapeStyle
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IShapeStyle : ISlideComponent, IPresentationComponent

Types that implement IShapeStyle

Type | Description
ShapeStyle | Represent shape's style reference.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IShapeStyle Members | Aspose.Slides Namespace


IShapeStyle Members

IShapeStyle overview

Public Instance Properties

AsISlideComponent
EffectColor
EffectStyleIndex
FillColor
FillStyleIndex
FontCollectionIndex
FontColor
LineColor
LineStyleIndex

See Also

IShapeStyle Interface | Aspose.Slides Namespace


IShapeStyle Properties

The properties of the IShapeStyle interface are listed below. For a complete list of IShapeStyle interface members, see the IShapeStyle Members topic.

Public Instance Properties

AsISlideComponent
EffectColor
EffectStyleIndex
FillColor
FillStyleIndex
FontCollectionIndex
FontColor
LineColor
LineStyleIndex

See Also

IShapeStyle Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IShapeStyle.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IShapeStyle Interface | Aspose.Slides Namespace


EffectColor Property

Aspose.Slides Documentation

IShapeStyle.EffectColor Property

[Visual Basic]
Property EffectColor As IColorFormat
[C#]
IColorFormat EffectColor {get;}

See Also

IShapeStyle Interface | Aspose.Slides Namespace


EffectStyleIndex Property

Aspose.Slides Documentation

IShapeStyle.EffectStyleIndex Property

[Visual Basic]
Property EffectStyleIndex As UInt32
[C#]
uint EffectStyleIndex {get; set;}

See Also

IShapeStyle Interface | Aspose.Slides Namespace


FillColor Property

Aspose.Slides Documentation

IShapeStyle.FillColor Property

[Visual Basic]
Property FillColor As IColorFormat
[C#]
IColorFormat FillColor {get;}

See Also

IShapeStyle Interface | Aspose.Slides Namespace


FillStyleIndex Property

Aspose.Slides Documentation

IShapeStyle.FillStyleIndex Property

[Visual Basic]
Property FillStyleIndex As Short
[C#]
short FillStyleIndex {get; set;}

See Also

IShapeStyle Interface | Aspose.Slides Namespace


FontCollectionIndex Property

Aspose.Slides Documentation

IShapeStyle.FontCollectionIndex Property

[Visual Basic]
Property FontCollectionIndex As FontCollectionIndex
[C#]
FontCollectionIndex FontCollectionIndex {get; set;}

See Also

IShapeStyle Interface | Aspose.Slides Namespace


FontColor Property

Aspose.Slides Documentation

IShapeStyle.FontColor Property

[Visual Basic]
Property FontColor As IColorFormat
[C#]
IColorFormat FontColor {get;}

See Also

IShapeStyle Interface | Aspose.Slides Namespace


LineColor Property

Aspose.Slides Documentation

IShapeStyle.LineColor Property

[Visual Basic]
Property LineColor As IColorFormat
[C#]
IColorFormat LineColor {get;}

See Also

IShapeStyle Interface | Aspose.Slides Namespace


LineStyleIndex Property

Aspose.Slides Documentation

IShapeStyle.LineStyleIndex Property

[Visual Basic]
Property LineStyleIndex As UInt16
[C#]
ushort LineStyleIndex {get; set;}

See Also

IShapeStyle Interface | Aspose.Slides Namespace


ISlide Interface

For a list of all members of this type, see ISlide Members.

[Visual Basic]
Public Interface ISlide
Implements IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent, IOverrideThemeable
[C#]
public interface ISlide : IBaseSlide, IThemeable, ISlideComponent, IPresentationComponent, IOverrideThemeable

Types that implement ISlide

Type | Description
Slide | Represents a slide in a presentation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISlide Members | Aspose.Slides Namespace


ISlide Members

ISlide overview

Public Instance Properties

AsIBaseSlide
AsIOverrideThemeable
Hidden
LayoutSlide
NotesSlide
SlideNumber

Public Instance Methods

AddNotesSlide |
GetSlideComments |
GetThumbnail | Overloaded.
Remove |
WriteAsSvg |

See Also

ISlide Interface | Aspose.Slides Namespace


ISlide Properties

The properties of the ISlide interface are listed below. For a complete list of ISlide interface members, see the ISlide Members topic.

Public Instance Properties

AsIBaseSlide
AsIOverrideThemeable
Hidden
LayoutSlide
NotesSlide
SlideNumber

See Also

ISlide Interface | Aspose.Slides Namespace


AsIBaseSlide Property

Aspose.Slides Documentation

ISlide.AsIBaseSlide Property

[Visual Basic]
Property AsIBaseSlide As IBaseSlide
[C#]
IBaseSlide AsIBaseSlide {get;}

See Also

ISlide Interface | Aspose.Slides Namespace


AsIOverrideThemeable Property

Aspose.Slides Documentation

ISlide.AsIOverrideThemeable Property

[Visual Basic]
Property AsIOverrideThemeable As IOverrideThemeable
[C#]
IOverrideThemeable AsIOverrideThemeable {get;}

See Also

ISlide Interface | Aspose.Slides Namespace


Hidden Property

Aspose.Slides Documentation

ISlide.Hidden Property

[Visual Basic]
Property Hidden As Boolean
[C#]
bool Hidden {get; set;}

See Also

ISlide Interface | Aspose.Slides Namespace


LayoutSlide Property

Aspose.Slides Documentation

ISlide.LayoutSlide Property

[Visual Basic]
Property LayoutSlide As ILayoutSlide
[C#]
ILayoutSlide LayoutSlide {get; set;}

See Also

ISlide Interface | Aspose.Slides Namespace


NotesSlide Property

Aspose.Slides Documentation

ISlide.NotesSlide Property

[Visual Basic]
Property NotesSlide As INotesSlide
[C#]
INotesSlide NotesSlide {get;}

See Also

ISlide Interface | Aspose.Slides Namespace


SlideNumber Property

Aspose.Slides Documentation

ISlide.SlideNumber Property

[Visual Basic]
Property SlideNumber As Integer
[C#]
int SlideNumber {get; set;}

See Also

ISlide Interface | Aspose.Slides Namespace


ISlide Methods

The methods of the ISlide interface are listed below. For a complete list of ISlide interface members, see the ISlide Members topic.

Public Instance Methods

AddNotesSlide |
GetSlideComments |
GetThumbnail | Overloaded.
Remove |
WriteAsSvg |

See Also

ISlide Interface | Aspose.Slides Namespace


ISlide.AddNotesSlide Method

[Visual Basic]
Function AddNotesSlide() As INotesSlide
[C#]
INotesSlide AddNotesSlide();

See Also

ISlide Interface | Aspose.Slides Namespace


ISlide.GetSlideComments Method

[Visual Basic]
Function GetSlideComments( _
ByVal author As ICommentAuthor _
) As IComment()
[C#]
IComment[] GetSlideComments(
ICommentAuthor author
);

See Also

ISlide Interface | Aspose.Slides Namespace


GetThumbnail Method

Aspose.Slides Documentation

ISlide.GetThumbnail Method

Overload List

Bitmap GetThumbnail();

Bitmap GetThumbnail(Size);

Bitmap GetThumbnail(float,float);

See Also

ISlide Interface | Aspose.Slides Namespace


ISlide.GetThumbnail Method ()

[Visual Basic]
Function GetThumbnail() As Bitmap
[C#]
Bitmap GetThumbnail();

See Also

ISlide Interface | Aspose.Slides Namespace | ISlide.GetThumbnail Overload List


ISlide.GetThumbnail Method (Size)

[Visual Basic]
Function GetThumbnail( _
ByVal imageSize As Size _
) As Bitmap
[C#]
Bitmap GetThumbnail(
Size imageSize
);

See Also

ISlide Interface | Aspose.Slides Namespace | ISlide.GetThumbnail Overload List


ISlide.GetThumbnail Method (Single, Single)

[Visual Basic]
Function GetThumbnail( _
ByVal scaleX As Single, _
ByVal scaleY As Single _
) As Bitmap
[C#]
Bitmap GetThumbnail(
float scaleX,
float scaleY
);

See Also

ISlide Interface | Aspose.Slides Namespace | ISlide.GetThumbnail Overload List


ISlide.Remove Method

[Visual Basic]
Sub Remove()
[C#]
void Remove();

See Also

ISlide Interface | Aspose.Slides Namespace


ISlide.WriteAsSvg Method

[Visual Basic]
Sub WriteAsSvg( _
ByVal stream As Stream _
)
[C#]
void WriteAsSvg(
Stream stream
);

See Also

ISlide Interface | Aspose.Slides Namespace


ISlideCollection Interface

For a list of all members of this type, see ISlideCollection Members.

[Visual Basic]
Public Interface ISlideCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ISlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface ISlideCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement ISlideCollection

Type | Description
SlideCollection | Represents a collection of a slides.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISlideCollection Members | Aspose.Slides Namespace


ISlideCollection Members

ISlideCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

AddClone | Overloaded.
AddEmptySlide |
AddFromHtml | Overloaded.
IndexOf |
InsertClone | Overloaded.
InsertEmptySlide |
InsertFromHtml | Overloaded.
Remove |
RemoveAt |
Reorder | Overloaded.
ToArray | Overloaded.

See Also

ISlideCollection Interface | Aspose.Slides Namespace


ISlideCollection Properties

The properties of the ISlideCollection interface are listed below. For a complete list of ISlideCollection interface members, see the ISlideCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

ISlideCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

ISlideCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

ISlideCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ISlideCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ISlideCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ISlideCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As ISlide
[C#]
ISlide this[
int index
] {get;}

See Also

ISlideCollection Interface | Aspose.Slides Namespace


ISlideCollection Methods

The methods of the ISlideCollection interface are listed below. For a complete list of ISlideCollection interface members, see the ISlideCollection Members topic.

Public Instance Methods

AddClone | Overloaded.
AddEmptySlide |
AddFromHtml | Overloaded.
IndexOf |
InsertClone | Overloaded.
InsertEmptySlide |
InsertFromHtml | Overloaded.
Remove |
RemoveAt |
Reorder | Overloaded.
ToArray | Overloaded.

See Also

ISlideCollection Interface | Aspose.Slides Namespace


AddClone Method

Aspose.Slides Documentation

ISlideCollection.AddClone Method

Overload List

ISlide AddClone(ISlide);

ISlide AddClone(ISlide,ILayoutSlide);

Obsolete.

ISlide AddClone(ISlide,IMasterSlide);

ISlide AddClone(ISlide,IMasterSlide,bool);

See Also

ISlideCollection Interface | Aspose.Slides Namespace


ISlideCollection.AddClone Method (ISlide)

[Visual Basic]
Function AddClone( _
ByVal sourceSlide As ISlide _
) As ISlide
[C#]
ISlide AddClone(
ISlide sourceSlide
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.AddClone Overload List


ISlideCollection.AddClone Method (ISlide, ILayoutSlide)

[Visual Basic]
Function AddClone( _
ByVal sourceSlide As ISlide, _
ByVal destLayout As ILayoutSlide _
) As ISlide
[C#]
ISlide AddClone(
ISlide sourceSlide,
ILayoutSlide destLayout
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.AddClone Overload List


ISlideCollection.AddClone Method (ISlide, IMasterSlide)

NOTE: This method is now obsolete.

Use AddClone(ISlide sourceSlide, IMasterSlide destMaster, bool allowCloneMissingLayout) method instead. Will be removed after 01.08.2014.

[Visual Basic]
Function AddClone( _
ByVal sourceSlide As ISlide, _
ByVal destMaster As IMasterSlide _
) As ISlide
[C#]
ISlide AddClone(
ISlide sourceSlide,
IMasterSlide destMaster
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.AddClone Overload List


ISlideCollection.AddClone Method (ISlide, IMasterSlide, Boolean)

[Visual Basic]
Function AddClone( _
ByVal sourceSlide As ISlide, _
ByVal destMaster As IMasterSlide, _
ByVal allowCloneMissingLayout As Boolean _
) As ISlide
[C#]
ISlide AddClone(
ISlide sourceSlide,
IMasterSlide destMaster,
bool allowCloneMissingLayout
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.AddClone Overload List


ISlideCollection.AddEmptySlide Method

[Visual Basic]
Function AddEmptySlide( _
ByVal layout As ILayoutSlide _
) As ISlide
[C#]
ISlide AddEmptySlide(
ILayoutSlide layout
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace


AddFromHtml Method

Aspose.Slides Documentation

ISlideCollection.AddFromHtml Method

Overload List

ISlide[] AddFromHtml(Stream);

ISlide[] AddFromHtml(Stream,IHtmlExternalResolver,string);

ISlide[] AddFromHtml(TextReader);

ISlide[] AddFromHtml(TextReader,IHtmlExternalResolver,string);

ISlide[] AddFromHtml(string);

ISlide[] AddFromHtml(string,IHtmlExternalResolver,string);

See Also

ISlideCollection Interface | Aspose.Slides Namespace


ISlideCollection.AddFromHtml Method (Stream)

[Visual Basic]
Function AddFromHtml( _
ByVal htmlStream As Stream _
) As ISlide()
[C#]
ISlide[] AddFromHtml(
Stream htmlStream
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.AddFromHtml Overload List


ISlideCollection.AddFromHtml Method (Stream, IHtmlExternalResolver, String)

[Visual Basic]
Function AddFromHtml( _
ByVal htmlStream As Stream, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) As ISlide()
[C#]
ISlide[] AddFromHtml(
Stream htmlStream,
IHtmlExternalResolver resolver,
string uri
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.AddFromHtml Overload List


ISlideCollection.AddFromHtml Method (TextReader)

[Visual Basic]
Function AddFromHtml( _
ByVal htmlReader As TextReader _
) As ISlide()
[C#]
ISlide[] AddFromHtml(
TextReader htmlReader
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.AddFromHtml Overload List


ISlideCollection.AddFromHtml Method (TextReader, IHtmlExternalResolver, String)

[Visual Basic]
Function AddFromHtml( _
ByVal htmlReader As TextReader, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) As ISlide()
[C#]
ISlide[] AddFromHtml(
TextReader htmlReader,
IHtmlExternalResolver resolver,
string uri
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.AddFromHtml Overload List


ISlideCollection.AddFromHtml Method (String)

[Visual Basic]
Function AddFromHtml( _
ByVal htmlText As String _
) As ISlide()
[C#]
ISlide[] AddFromHtml(
string htmlText
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.AddFromHtml Overload List


ISlideCollection.AddFromHtml Method (String, IHtmlExternalResolver, String)

[Visual Basic]
Function AddFromHtml( _
ByVal htmlText As String, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) As ISlide()
[C#]
ISlide[] AddFromHtml(
string htmlText,
IHtmlExternalResolver resolver,
string uri
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.AddFromHtml Overload List


ISlideCollection.IndexOf Method

[Visual Basic]
Function IndexOf( _
ByVal slide As ISlide _
) As Integer
[C#]
int IndexOf(
ISlide slide
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace


InsertClone Method

Aspose.Slides Documentation

ISlideCollection.InsertClone Method

Overload List

ISlide InsertClone(int,ISlide);

ISlide InsertClone(int,ISlide,ILayoutSlide);

Obsolete.

ISlide InsertClone(int,ISlide,IMasterSlide);

ISlide InsertClone(int,ISlide,IMasterSlide,bool);

See Also

ISlideCollection Interface | Aspose.Slides Namespace


ISlideCollection.InsertClone Method (Int32, ISlide)

[Visual Basic]
Function InsertClone( _
ByVal index As Integer, _
ByVal sourceSlide As ISlide _
) As ISlide
[C#]
ISlide InsertClone(
int index,
ISlide sourceSlide
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.InsertClone Overload List


ISlideCollection.InsertClone Method (Int32, ISlide, ILayoutSlide)

[Visual Basic]
Function InsertClone( _
ByVal index As Integer, _
ByVal sourceSlide As ISlide, _
ByVal destLayout As ILayoutSlide _
) As ISlide
[C#]
ISlide InsertClone(
int index,
ISlide sourceSlide,
ILayoutSlide destLayout
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.InsertClone Overload List


ISlideCollection.InsertClone Method (Int32, ISlide, IMasterSlide)

NOTE: This method is now obsolete.

Use InsertClone(int index, ISlide sourceSlide, IMasterSlide destMaster, bool allowCloneMissingLayout) method instead. Will be removed after 01.08.2014.

[Visual Basic]
Function InsertClone( _
ByVal index As Integer, _
ByVal sourceSlide As ISlide, _
ByVal destMaster As IMasterSlide _
) As ISlide
[C#]
ISlide InsertClone(
int index,
ISlide sourceSlide,
IMasterSlide destMaster
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.InsertClone Overload List


ISlideCollection.InsertClone Method (Int32, ISlide, IMasterSlide, Boolean)

[Visual Basic]
Function InsertClone( _
ByVal index As Integer, _
ByVal sourceSlide As ISlide, _
ByVal destMaster As IMasterSlide, _
ByVal allowCloneMissingLayout As Boolean _
) As ISlide
[C#]
ISlide InsertClone(
int index,
ISlide sourceSlide,
IMasterSlide destMaster,
bool allowCloneMissingLayout
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.InsertClone Overload List


ISlideCollection.InsertEmptySlide Method

[Visual Basic]
Function InsertEmptySlide( _
ByVal index As Integer, _
ByVal layout As ILayoutSlide _
) As ISlide
[C#]
ISlide InsertEmptySlide(
int index,
ILayoutSlide layout
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace


InsertFromHtml Method

Aspose.Slides Documentation

ISlideCollection.InsertFromHtml Method

Overload List

ISlide[] InsertFromHtml(int,Stream);

ISlide[] InsertFromHtml(int,Stream,IHtmlExternalResolver,string);

ISlide[] InsertFromHtml(int,TextReader);

ISlide[] InsertFromHtml(int,TextReader,IHtmlExternalResolver,string);

ISlide[] InsertFromHtml(int,string);

ISlide[] InsertFromHtml(int,string,IHtmlExternalResolver,string);

See Also

ISlideCollection Interface | Aspose.Slides Namespace


ISlideCollection.InsertFromHtml Method (Int32, Stream)

[Visual Basic]
Function InsertFromHtml( _
ByVal index As Integer, _
ByVal htmlStream As Stream _
) As ISlide()
[C#]
ISlide[] InsertFromHtml(
int index,
Stream htmlStream
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.InsertFromHtml Overload List


ISlideCollection.InsertFromHtml Method (Int32, Stream, IHtmlExternalResolver, String)

[Visual Basic]
Function InsertFromHtml( _
ByVal index As Integer, _
ByVal htmlStream As Stream, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) As ISlide()
[C#]
ISlide[] InsertFromHtml(
int index,
Stream htmlStream,
IHtmlExternalResolver resolver,
string uri
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.InsertFromHtml Overload List


ISlideCollection.InsertFromHtml Method (Int32, TextReader)

[Visual Basic]
Function InsertFromHtml( _
ByVal index As Integer, _
ByVal htmlReader As TextReader _
) As ISlide()
[C#]
ISlide[] InsertFromHtml(
int index,
TextReader htmlReader
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.InsertFromHtml Overload List


ISlideCollection.InsertFromHtml Method (Int32, TextReader, IHtmlExternalResolver, String)

[Visual Basic]
Function InsertFromHtml( _
ByVal index As Integer, _
ByVal htmlReader As TextReader, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) As ISlide()
[C#]
ISlide[] InsertFromHtml(
int index,
TextReader htmlReader,
IHtmlExternalResolver resolver,
string uri
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.InsertFromHtml Overload List


ISlideCollection.InsertFromHtml Method (Int32, String)

[Visual Basic]
Function InsertFromHtml( _
ByVal index As Integer, _
ByVal htmlText As String _
) As ISlide()
[C#]
ISlide[] InsertFromHtml(
int index,
string htmlText
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.InsertFromHtml Overload List


ISlideCollection.InsertFromHtml Method (Int32, String, IHtmlExternalResolver, String)

[Visual Basic]
Function InsertFromHtml( _
ByVal index As Integer, _
ByVal htmlText As String, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) As ISlide()
[C#]
ISlide[] InsertFromHtml(
int index,
string htmlText,
IHtmlExternalResolver resolver,
string uri
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.InsertFromHtml Overload List


ISlideCollection.Remove Method

[Visual Basic]
Sub Remove( _
ByVal value As ISlide _
)
[C#]
void Remove(
ISlide value
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace


ISlideCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace


Reorder Method

Aspose.Slides Documentation

ISlideCollection.Reorder Method

Overload List

void Reorder(int,ISlide);

void Reorder(int,params ISlide[]);

See Also

ISlideCollection Interface | Aspose.Slides Namespace


ISlideCollection.Reorder Method (Int32, ISlide)

[Visual Basic]
Sub Reorder( _
ByVal index As Integer, _
ByVal slide As ISlide _
)
[C#]
void Reorder(
int index,
ISlide slide
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.Reorder Overload List


ISlideCollection.Reorder Method (Int32, ISlide[])

[Visual Basic]
Sub Reorder( _
ByVal index As Integer, _
ParamArray slides As ISlide() _
)
[C#]
void Reorder(
int index,
params ISlide[] slides
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.Reorder Overload List


ToArray Method

Aspose.Slides Documentation

ISlideCollection.ToArray Method

Overload List

ISlide[] ToArray();

ISlide[] ToArray(int,int);

See Also

ISlideCollection Interface | Aspose.Slides Namespace


ISlideCollection.ToArray Method ()

[Visual Basic]
Function ToArray() As ISlide()
[C#]
ISlide[] ToArray();

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.ToArray Overload List


ISlideCollection.ToArray Method (Int32, Int32)

[Visual Basic]
Function ToArray( _
ByVal startIndex As Integer, _
ByVal count As Integer _
) As ISlide()
[C#]
ISlide[] ToArray(
int startIndex,
int count
);

See Also

ISlideCollection Interface | Aspose.Slides Namespace | ISlideCollection.ToArray Overload List


ISlideComponent Interface

For a list of all members of this type, see ISlideComponent Members.

Aspose.Slides.ISlideComponent
Derived interfaces

[Visual Basic]
Public Interface ISlideComponent
Implements IPresentationComponent
[C#]
public interface ISlideComponent : IPresentationComponent

Types that implement ISlideComponent

Type | Description
AudioFrame | Represents an audio clip on a slide.
AutoShape | Represents an AutoShape.
Background | Represents background of a slide.
BaseSlide | Represents common data for all slide types.
Cell | Represents a cell of a table.
CellCollection | Represents a collection of cells.
Chart | Represents an graphic chart on a slide.
Column | Represents a column in a table.
Connector | Represents a connector.
Control | Represents an ActiveX control.
EffectFormat | Represents effect properties of shape.
AlphaBiLevel | Represents an Alpha Bi-Level effect. Alpha (Opacity) values less than the threshold are changed to 0 (fully transparent) and alpha values greater than or equal to the threshold are changed to 100% (fully opaque).
AlphaCeiling | Represents an Alpha Ceiling effect. Alpha (opacity) values greater than zero are changed to 100%. In other words, anything partially opaque becomes fully opaque.
AlphaFloor | Represents an Alpha Floor effect. Alpha (opacity) values less than 100% are changed to zero. In other words, anything partially transparent becomes fully transparent.
AlphaInverse | Represents an Alpha Inverse effect. Alpha (opacity) values are inverted by subtracting from 100%.
AlphaModulate | Represents an Alpha Modulate effect. Effect alpha (opacity) values are multiplied by a fixed percentage. The effect container specifies an effect containing alpha values to modulate.
AlphaModulateFixed | Represents an Alpha Modulate Fixed effect. Effect alpha (opacity) values are multiplied by a fixed percentage.
AlphaReplace | Represents and Alpha Replace effect. Effect alpha (opacity) values are replaced by a fixed alpha.
BiLevel | Represents a Bi-Level (black/white) effect. Input colors whose luminance is less than the specified threshold value are changed to black. Input colors whose luminance are greater than or equal the specified value are set to white. The alpha effect values are unaffected by this effect.
Blur | Represents a Blur effect that is applied to the entire shape, including its fill. All color channels, including alpha, are affected.
ColorChange | Represents a Color Change effect. Instances of FromColor are replaced with instances of ToColor.
ColorReplace | Represents a Color Replacement effect. All effect colors are changed to a fixed color. Alpha values are unaffected.
Duotone | Represents a Duotone effect. For each pixel, combines Color1 and Color2 through a linear interpolation to determine the new color for that pixel.
FillOverlay | Represents a Fill Overlay effect. A fill overlay may be used to specify an additional fill for an object and blend the two fills together.
GrayScale | Represents a Gray Scale effect. Converts all effect color values to a shade of gray, corresponding to their luminance. Effect alpha (opacity) values are unaffected.
HSL | Represents a Hue/Saturation/Luminance effect. The hue, saturation, and luminance may each be adjusted relative to its current value.
ImageTransformOperation | Represents abstract image transformation effect.
ImageTransformOperationCollection | Represents a collection of effects apllied to an image.
Luminance | Represents a Luminance effect. Brightness linearly shifts all colors closer to white or black. Contrast scales all colors to be either closer or further apart.
Tint | Represents a Tint effect. Shifts effect color values towards/away from hue by the specified amount.
Field | Represents a field.
FillFormat | Represents a fill formatting options.
GeometryShape | Represents the parent class for all geometric shapes.
GradientFormat | Represent a gradient format.
GradientStopCollection | Represnts a collection of gradient stops.
GraphicalObject | Represents abstract graphical object.
GroupShape | Represents a group of shapes on a slide.
LayoutSlide | Represents a layout slide.
LineFillFormat | Represents properties for lines filling.
LineFormat | Represents format of a line.
MasterHandoutSlide | Represents master slide for handouts.
MasterNotesSlide | Represents master slide for notes.
MasterSlide | Represents a master slide in a presentation.
NotesSlide | Represents a notes slide in a presentation.
OleObjectFrame | Represents an OLE object on a slide.
Paragraph | Represents a paragraph of text.
ParagraphCollection | Represents a collection of a paragraphs.
ParagraphFormat | This class contains the paragraph formatting properties. Unlike ParagraphFormatEffectiveData, all properties of this class are writeable.
ParagraphFormatEffectiveData | Immutable object which contains paragraph formatting properties.
PatternFormat | Represents a pattern to fill a shape.
Picture | Represents a picture in a presentation.
PictureFillFormat | Represents a picture fill style.
PictureFrame | Represents a frame with a picture inside.
Portion | Represents a portion of text inside a text paragraph.
Row | Represents a row in a table.
Shape | Represents a shape on a slide.
ShapeStyle | Represent shape's style reference.
Slide | Represents a slide in a presentation.
SmartArt | Represents SmartArt object on a slide.
Table | Represents a table on a slide.
TextFrame | Represents a TextFrame.
TextFrameFormat | Contains the TextFrame's formatting properties.
TextStyle | Summary description for TextStyle.
ColorScheme | Stores theme-defined colors.
FormatScheme | Stores theme-defined formats for the shapes.
ThreeDFormat | Represents 3-D properties.
VideoFrame | Represents a video clip on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISlideComponent Members | Aspose.Slides Namespace


ISlideComponent Members

ISlideComponent overview

Public Instance Properties

AsIPresentationComponent
Slide

See Also

ISlideComponent Interface | Aspose.Slides Namespace


ISlideComponent Properties

The properties of the ISlideComponent interface are listed below. For a complete list of ISlideComponent interface members, see the ISlideComponent Members topic.

Public Instance Properties

AsIPresentationComponent
Slide

See Also

ISlideComponent Interface | Aspose.Slides Namespace


AsIPresentationComponent Property

Aspose.Slides Documentation

ISlideComponent.AsIPresentationComponent Property

[Visual Basic]
Property AsIPresentationComponent As IPresentationComponent
[C#]
IPresentationComponent AsIPresentationComponent {get;}

See Also

ISlideComponent Interface | Aspose.Slides Namespace


Slide Property

Aspose.Slides Documentation

ISlideComponent.Slide Property

[Visual Basic]
Property Slide As IBaseSlide
[C#]
IBaseSlide Slide {get;}

See Also

ISlideComponent Interface | Aspose.Slides Namespace


ISlideShowTransition Interface

For a list of all members of this type, see ISlideShowTransition Members.

[Visual Basic]
Public Interface ISlideShowTransition
[C#]
public interface ISlideShowTransition

Types that implement ISlideShowTransition

Type | Description
SlideShowTransition | Represents slide show transition.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISlideShowTransition Members | Aspose.Slides Namespace


ISlideShowTransition Members

ISlideShowTransition overview

Public Instance Properties

AdvanceAfterTime
AdvanceOnClick
Sound
SoundIsBuiltIn
SoundLoop
SoundMode
SoundName
Speed
Type
Value

See Also

ISlideShowTransition Interface | Aspose.Slides Namespace


ISlideShowTransition Properties

The properties of the ISlideShowTransition interface are listed below. For a complete list of ISlideShowTransition interface members, see the ISlideShowTransition Members topic.

Public Instance Properties

AdvanceAfterTime
AdvanceOnClick
Sound
SoundIsBuiltIn
SoundLoop
SoundMode
SoundName
Speed
Type
Value

See Also

ISlideShowTransition Interface | Aspose.Slides Namespace


AdvanceAfterTime Property

Aspose.Slides Documentation

ISlideShowTransition.AdvanceAfterTime Property

[Visual Basic]
Property AdvanceAfterTime As UInt32
[C#]
uint AdvanceAfterTime {get; set;}

See Also

ISlideShowTransition Interface | Aspose.Slides Namespace


AdvanceOnClick Property

Aspose.Slides Documentation

ISlideShowTransition.AdvanceOnClick Property

[Visual Basic]
Property AdvanceOnClick As Boolean
[C#]
bool AdvanceOnClick {get; set;}

See Also

ISlideShowTransition Interface | Aspose.Slides Namespace


Sound Property

Aspose.Slides Documentation

ISlideShowTransition.Sound Property

[Visual Basic]
Property Sound As IAudio
[C#]
IAudio Sound {get; set;}

See Also

ISlideShowTransition Interface | Aspose.Slides Namespace


SoundIsBuiltIn Property

Aspose.Slides Documentation

ISlideShowTransition.SoundIsBuiltIn Property

[Visual Basic]
Property SoundIsBuiltIn As Boolean
[C#]
bool SoundIsBuiltIn {get; set;}

See Also

ISlideShowTransition Interface | Aspose.Slides Namespace


SoundLoop Property

Aspose.Slides Documentation

ISlideShowTransition.SoundLoop Property

[Visual Basic]
Property SoundLoop As Boolean
[C#]
bool SoundLoop {get; set;}

See Also

ISlideShowTransition Interface | Aspose.Slides Namespace


SoundMode Property

Aspose.Slides Documentation

ISlideShowTransition.SoundMode Property

[Visual Basic]
Property SoundMode As TransitionSoundMode
[C#]
TransitionSoundMode SoundMode {get; set;}

See Also

ISlideShowTransition Interface | Aspose.Slides Namespace


SoundName Property

Aspose.Slides Documentation

ISlideShowTransition.SoundName Property

[Visual Basic]
Property SoundName As String
[C#]
string SoundName {get; set;}

See Also

ISlideShowTransition Interface | Aspose.Slides Namespace


Speed Property

Aspose.Slides Documentation

ISlideShowTransition.Speed Property

[Visual Basic]
Property Speed As TransitionSpeed
[C#]
TransitionSpeed Speed {get; set;}

See Also

ISlideShowTransition Interface | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

ISlideShowTransition.Type Property

[Visual Basic]
Property Type As TransitionType
[C#]
TransitionType Type {get; set;}

See Also

ISlideShowTransition Interface | Aspose.Slides Namespace


Value Property

Aspose.Slides Documentation

ISlideShowTransition.Value Property

[Visual Basic]
Property Value As ITransitionValueBase
[C#]
ITransitionValueBase Value {get;}

See Also

ISlideShowTransition Interface | Aspose.Slides Namespace


ISlideSize Interface

For a list of all members of this type, see ISlideSize Members.

[Visual Basic]
Public Interface ISlideSize
[C#]
public interface ISlideSize

Types that implement ISlideSize

Type | Description
SlideSize | Represents a size of slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISlideSize Members | Aspose.Slides Namespace


ISlideSize Members

ISlideSize overview

Public Instance Properties

Orientation
Size
Type

See Also

ISlideSize Interface | Aspose.Slides Namespace


ISlideSize Properties

The properties of the ISlideSize interface are listed below. For a complete list of ISlideSize interface members, see the ISlideSize Members topic.

Public Instance Properties

Orientation
Size
Type

See Also

ISlideSize Interface | Aspose.Slides Namespace


Orientation Property

Aspose.Slides Documentation

ISlideSize.Orientation Property

[Visual Basic]
Property Orientation As SlideOrienation
[C#]
SlideOrienation Orientation {get; set;}

See Also

ISlideSize Interface | Aspose.Slides Namespace


Size Property

Aspose.Slides Documentation

ISlideSize.Size Property

[Visual Basic]
Property Size As SizeF
[C#]
SizeF Size {get; set;}

See Also

ISlideSize Interface | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

ISlideSize.Type Property

[Visual Basic]
Property Type As SlideSizeType
[C#]
SlideSizeType Type {get; set;}

See Also

ISlideSize Interface | Aspose.Slides Namespace


ISlidesPicture Interface

For a list of all members of this type, see ISlidesPicture Members.

[Visual Basic]
Public Interface ISlidesPicture
Implements ISlideComponent, IPresentationComponent
[C#]
public interface ISlidesPicture : ISlideComponent, IPresentationComponent

Types that implement ISlidesPicture

Type | Description
Picture | Represents a picture in a presentation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISlidesPicture Members | Aspose.Slides Namespace


ISlidesPicture Members

ISlidesPicture overview

Public Instance Properties

AsISlideComponent
Image
ImageTransform
LinkPathLong

See Also

ISlidesPicture Interface | Aspose.Slides Namespace


ISlidesPicture Properties

The properties of the ISlidesPicture interface are listed below. For a complete list of ISlidesPicture interface members, see the ISlidesPicture Members topic.

Public Instance Properties

AsISlideComponent
Image
ImageTransform
LinkPathLong

See Also

ISlidesPicture Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

ISlidesPicture.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

ISlidesPicture Interface | Aspose.Slides Namespace


Image Property

Aspose.Slides Documentation

ISlidesPicture.Image Property

[Visual Basic]
Property Image As IPPImage
[C#]
IPPImage Image {get; set;}

See Also

ISlidesPicture Interface | Aspose.Slides Namespace


ImageTransform Property

Aspose.Slides Documentation

ISlidesPicture.ImageTransform Property

[Visual Basic]
Property ImageTransform As IImageTransformOperationCollection
[C#]
IImageTransformOperationCollection ImageTransform {get;}

See Also

ISlidesPicture Interface | Aspose.Slides Namespace


LinkPathLong Property

Aspose.Slides Documentation

ISlidesPicture.LinkPathLong Property

[Visual Basic]
Property LinkPathLong As String
[C#]
string LinkPathLong {get; set;}

See Also

ISlidesPicture Interface | Aspose.Slides Namespace


IStreamWrapper Interface

For a list of all members of this type, see IStreamWrapper Members.

[Visual Basic]
Public Interface IStreamWrapper
Implements IDisposable
[C#]
public interface IStreamWrapper : IDisposable

Types that implement IStreamWrapper

Type | Description
StreamWrapper | Aspose.IO.Stream wrapper for COM interface.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IStreamWrapper Members | Aspose.Slides Namespace


IStreamWrapper Members

IStreamWrapper overview

Public Instance Properties

AsIDisposable
CanRead
CanSeek
CanWrite
Length
Position
Stream

Public Instance Methods

Close
Flush
Read
ReadByte
Seek
Write
WriteByte

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


IStreamWrapper Properties

The properties of the IStreamWrapper interface are listed below. For a complete list of IStreamWrapper interface members, see the IStreamWrapper Members topic.

Public Instance Properties

AsIDisposable
CanRead
CanSeek
CanWrite
Length
Position
Stream

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


AsIDisposable Property

Aspose.Slides Documentation

IStreamWrapper.AsIDisposable Property

[Visual Basic]
Property AsIDisposable As IDisposable
[C#]
IDisposable AsIDisposable {get;}

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


CanRead Property

Aspose.Slides Documentation

IStreamWrapper.CanRead Property

[Visual Basic]
Property CanRead As Boolean
[C#]
bool CanRead {get;}

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


CanSeek Property

Aspose.Slides Documentation

IStreamWrapper.CanSeek Property

[Visual Basic]
Property CanSeek As Boolean
[C#]
bool CanSeek {get;}

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


CanWrite Property

Aspose.Slides Documentation

IStreamWrapper.CanWrite Property

[Visual Basic]
Property CanWrite As Boolean
[C#]
bool CanWrite {get;}

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


Length Property

Aspose.Slides Documentation

IStreamWrapper.Length Property

[Visual Basic]
Property Length As Long
[C#]
long Length {get;}

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


Position Property

Aspose.Slides Documentation

IStreamWrapper.Position Property

[Visual Basic]
Property Position As Long
[C#]
long Position {get;}

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


Stream Property

Aspose.Slides Documentation

IStreamWrapper.Stream Property

[Visual Basic]
Property Stream As Stream
[C#]
Stream Stream {get;}

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


IStreamWrapper Methods

The methods of the IStreamWrapper interface are listed below. For a complete list of IStreamWrapper interface members, see the IStreamWrapper Members topic.

Public Instance Methods

Close
Flush
Read
ReadByte
Seek
Write
WriteByte

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


IStreamWrapper.Close Method

[Visual Basic]
Sub Close()
[C#]
void Close();

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


IStreamWrapper.Flush Method

[Visual Basic]
Sub Flush()
[C#]
void Flush();

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


IStreamWrapper.Read Method

[Visual Basic]
Sub Read( _
ByVal buffer As Byte(), _
ByVal offset As Integer, _
ByVal count As Integer _
)
[C#]
void Read(
byte[] buffer,
int offset,
int count
);

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


IStreamWrapper.ReadByte Method

[Visual Basic]
Function ReadByte() As Integer
[C#]
int ReadByte();

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


IStreamWrapper.Seek Method

[Visual Basic]
Function Seek( _
ByVal offset As Long, _
ByVal origin As SeekOrigin _
) As Long
[C#]
long Seek(
long offset,
SeekOrigin origin
);

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


IStreamWrapper.Write Method

[Visual Basic]
Sub Write( _
ByVal buffer As Byte(), _
ByVal offset As Integer, _
ByVal count As Integer _
)
[C#]
void Write(
byte[] buffer,
int offset,
int count
);

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


IStreamWrapper.WriteByte Method

[Visual Basic]
Sub WriteByte( _
ByVal value As Byte _
)
[C#]
void WriteByte(
byte value
);

See Also

IStreamWrapper Interface | Aspose.Slides Namespace


IStreamWrapperFactory Interface

For a list of all members of this type, see IStreamWrapperFactory Members.

[Visual Basic]
Public Interface IStreamWrapperFactory
[C#]
public interface IStreamWrapperFactory

Types that implement IStreamWrapperFactory

Type | Description
StreamWrapperFactory | Factory of StreamWrappers. For COM interface.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IStreamWrapperFactory Members | Aspose.Slides Namespace


IStreamWrapperFactory Members

IStreamWrapperFactory overview

Public Instance Methods

CreateFileStreamWrapper | Overloaded.
CreateMemoryStreamWrapper | Overloaded.

See Also

IStreamWrapperFactory Interface | Aspose.Slides Namespace


IStreamWrapperFactory Methods

The methods of the IStreamWrapperFactory interface are listed below. For a complete list of IStreamWrapperFactory interface members, see the IStreamWrapperFactory Members topic.

Public Instance Methods

CreateFileStreamWrapper | Overloaded.
CreateMemoryStreamWrapper | Overloaded.

See Also

IStreamWrapperFactory Interface | Aspose.Slides Namespace


CreateFileStreamWrapper Method

Aspose.Slides Documentation

IStreamWrapperFactory.CreateFileStreamWrapper Method

Overload List

IStreamWrapper CreateFileStreamWrapper(string,FileMode);

IStreamWrapper CreateFileStreamWrapper(string,FileMode,FileAccess);

See Also

IStreamWrapperFactory Interface | Aspose.Slides Namespace


IStreamWrapperFactory.CreateFileStreamWrapper Method (String, FileMode)

[Visual Basic]
Function CreateFileStreamWrapper( _
ByVal fileName As String, _
ByVal fileMode As FileMode _
) As IStreamWrapper
[C#]
IStreamWrapper CreateFileStreamWrapper(
string fileName,
FileMode fileMode
);

See Also

IStreamWrapperFactory Interface | Aspose.Slides Namespace | IStreamWrapperFactory.CreateFileStreamWrapper Overload List


IStreamWrapperFactory.CreateFileStreamWrapper Method (String, FileMode, FileAccess)

[Visual Basic]
Function CreateFileStreamWrapper( _
ByVal fileName As String, _
ByVal fileMode As FileMode, _
ByVal fileAccess As FileAccess _
) As IStreamWrapper
[C#]
IStreamWrapper CreateFileStreamWrapper(
string fileName,
FileMode fileMode,
FileAccess fileAccess
);

See Also

IStreamWrapperFactory Interface | Aspose.Slides Namespace | IStreamWrapperFactory.CreateFileStreamWrapper Overload List


CreateMemoryStreamWrapper Method

Aspose.Slides Documentation

IStreamWrapperFactory.CreateMemoryStreamWrapper Method

Overload List

IStreamWrapper CreateMemoryStreamWrapper();

IStreamWrapper CreateMemoryStreamWrapper(byte[]);

See Also

IStreamWrapperFactory Interface | Aspose.Slides Namespace


IStreamWrapperFactory.CreateMemoryStreamWrapper Method ()

[Visual Basic]
Function CreateMemoryStreamWrapper() As IStreamWrapper
[C#]
IStreamWrapper CreateMemoryStreamWrapper();

See Also

IStreamWrapperFactory Interface | Aspose.Slides Namespace | IStreamWrapperFactory.CreateMemoryStreamWrapper Overload List


IStreamWrapperFactory.CreateMemoryStreamWrapper Method (Byte[])

[Visual Basic]
Function CreateMemoryStreamWrapper( _
ByVal buffer As Byte() _
) As IStreamWrapper
[C#]
IStreamWrapper CreateMemoryStreamWrapper(
byte[] buffer
);

See Also

IStreamWrapperFactory Interface | Aspose.Slides Namespace | IStreamWrapperFactory.CreateMemoryStreamWrapper Overload List


ITab Interface

For a list of all members of this type, see ITab Members.

[Visual Basic]
Public Interface ITab
Implements IComparable
[C#]
public interface ITab : IComparable

Types that implement ITab

Type | Description
Tab | Represents a tabulation for a text.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITab Members | Aspose.Slides Namespace


ITab Members

ITab overview

Public Instance Properties

Alignment
AsIComparable
Position

See Also

ITab Interface | Aspose.Slides Namespace


ITab Properties

The properties of the ITab interface are listed below. For a complete list of ITab interface members, see the ITab Members topic.

Public Instance Properties

Alignment
AsIComparable
Position

See Also

ITab Interface | Aspose.Slides Namespace


Alignment Property

Aspose.Slides Documentation

ITab.Alignment Property

[Visual Basic]
Property Alignment As TabAlignment
[C#]
TabAlignment Alignment {get; set;}

See Also

ITab Interface | Aspose.Slides Namespace


AsIComparable Property

Aspose.Slides Documentation

ITab.AsIComparable Property

[Visual Basic]
Property AsIComparable As IComparable
[C#]
IComparable AsIComparable {get;}

See Also

ITab Interface | Aspose.Slides Namespace


Position Property

Aspose.Slides Documentation

ITab.Position Property

[Visual Basic]
Property Position As Double
[C#]
double Position {get; set;}

See Also

ITab Interface | Aspose.Slides Namespace


ITabCollection Interface

For a list of all members of this type, see ITabCollection Members.

[Visual Basic]
Public Interface ITabCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ITab, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface ITabCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement ITabCollection

Type | Description
TabCollection | Represents a collection of tabs.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITabCollection Members | Aspose.Slides Namespace


ITabCollection Members

ITabCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

Add | Overloaded.
Clear |
RemoveAt |

See Also

ITabCollection Interface | Aspose.Slides Namespace


ITabCollection Properties

The properties of the ITabCollection interface are listed below. For a complete list of ITabCollection interface members, see the ITabCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

ITabCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

ITabCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

ITabCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ITabCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ITabCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ITabCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As ITab
[C#]
ITab this[
int index
] {get;}

See Also

ITabCollection Interface | Aspose.Slides Namespace


ITabCollection Methods

The methods of the ITabCollection interface are listed below. For a complete list of ITabCollection interface members, see the ITabCollection Members topic.

Public Instance Methods

Add | Overloaded.
Clear |
RemoveAt |

See Also

ITabCollection Interface | Aspose.Slides Namespace


Add Method

Aspose.Slides Documentation

ITabCollection.Add Method

Overload List

int Add(ITab);

ITab Add(double,TabAlignment);

See Also

ITabCollection Interface | Aspose.Slides Namespace


ITabCollection.Add Method (ITab)

[Visual Basic]
Function Add( _
ByVal value As ITab _
) As Integer
[C#]
int Add(
ITab value
);

See Also

ITabCollection Interface | Aspose.Slides Namespace | ITabCollection.Add Overload List


ITabCollection.Add Method (Double, TabAlignment)

[Visual Basic]
Function Add( _
ByVal position As Double, _
ByVal align As TabAlignment _
) As ITab
[C#]
ITab Add(
double position,
TabAlignment align
);

See Also

ITabCollection Interface | Aspose.Slides Namespace | ITabCollection.Add Overload List


ITabCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

ITabCollection Interface | Aspose.Slides Namespace


ITabCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

ITabCollection Interface | Aspose.Slides Namespace


ITabEffectiveData Interface

For a list of all members of this type, see ITabEffectiveData Members.

[Visual Basic]
Public Interface ITabEffectiveData
Implements IComparable
[C#]
public interface ITabEffectiveData : IComparable

Types that implement ITabEffectiveData

Type | Description
TabEffectiveData | Immutable object which represents a text's tabulation stop.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITabEffectiveData Members | Aspose.Slides Namespace


ITabEffectiveData Members

ITabEffectiveData overview

Public Instance Properties

Alignment
AsIComparable
Position

See Also

ITabEffectiveData Interface | Aspose.Slides Namespace


ITabEffectiveData Properties

The properties of the ITabEffectiveData interface are listed below. For a complete list of ITabEffectiveData interface members, see the ITabEffectiveData Members topic.

Public Instance Properties

Alignment
AsIComparable
Position

See Also

ITabEffectiveData Interface | Aspose.Slides Namespace


Alignment Property

Aspose.Slides Documentation

ITabEffectiveData.Alignment Property

[Visual Basic]
Property Alignment As TabAlignment
[C#]
TabAlignment Alignment {get;}

See Also

ITabEffectiveData Interface | Aspose.Slides Namespace


AsIComparable Property

Aspose.Slides Documentation

ITabEffectiveData.AsIComparable Property

[Visual Basic]
Property AsIComparable As IComparable
[C#]
IComparable AsIComparable {get;}

See Also

ITabEffectiveData Interface | Aspose.Slides Namespace


Position Property

Aspose.Slides Documentation

ITabEffectiveData.Position Property

[Visual Basic]
Property Position As Double
[C#]
double Position {get;}

See Also

ITabEffectiveData Interface | Aspose.Slides Namespace


ITabFactory Interface

For a list of all members of this type, see ITabFactory Members.

[Visual Basic]
Public Interface ITabFactory
[C#]
public interface ITabFactory

Types that implement ITabFactory

Type | Description
TabFactory | Allowa to create ITab instances

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITabFactory Members | Aspose.Slides Namespace


ITabFactory Members

ITabFactory overview

Public Instance Methods

CreateTab

See Also

ITabFactory Interface | Aspose.Slides Namespace


ITabFactory Methods

The methods of the ITabFactory interface are listed below. For a complete list of ITabFactory interface members, see the ITabFactory Members topic.

Public Instance Methods

CreateTab

See Also

ITabFactory Interface | Aspose.Slides Namespace


ITabFactory.CreateTab Method

[Visual Basic]
Function CreateTab( _
ByVal position As Double, _
ByVal align As TabAlignment _
) As ITab
[C#]
ITab CreateTab(
double position,
TabAlignment align
);

See Also

ITabFactory Interface | Aspose.Slides Namespace


ITable Interface

For a list of all members of this type, see ITable Members.

[Visual Basic]
Public Interface ITable
Implements IGraphicalObject, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public interface ITable : IGraphicalObject, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer

Types that implement ITable

Type | Description
Table | Represents a table on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITable Members | Aspose.Slides Namespace


ITable Members

ITable overview

Public Instance Properties

AsIGraphicalObject
Columns
FirstCol
FirstRow
HorizontalBanding
Item
LastCol
LastRow
RightToLeft
Rows
StylePreset
VerticalBanding

Public Instance Methods

MergeCells

See Also

ITable Interface | Aspose.Slides Namespace


ITable Properties

The properties of the ITable interface are listed below. For a complete list of ITable interface members, see the ITable Members topic.

Public Instance Properties

AsIGraphicalObject
Columns
FirstCol
FirstRow
HorizontalBanding
Item
LastCol
LastRow
RightToLeft
Rows
StylePreset
VerticalBanding

See Also

ITable Interface | Aspose.Slides Namespace


AsIGraphicalObject Property

Aspose.Slides Documentation

ITable.AsIGraphicalObject Property

[Visual Basic]
Property AsIGraphicalObject As IGraphicalObject
[C#]
IGraphicalObject AsIGraphicalObject {get;}

See Also

ITable Interface | Aspose.Slides Namespace


Columns Property

Aspose.Slides Documentation

ITable.Columns Property

[Visual Basic]
Property Columns As IColumnCollection
[C#]
IColumnCollection Columns {get;}

See Also

ITable Interface | Aspose.Slides Namespace


FirstCol Property

Aspose.Slides Documentation

ITable.FirstCol Property

[Visual Basic]
Property FirstCol As Boolean
[C#]
bool FirstCol {get; set;}

See Also

ITable Interface | Aspose.Slides Namespace


FirstRow Property

Aspose.Slides Documentation

ITable.FirstRow Property

[Visual Basic]
Property FirstRow As Boolean
[C#]
bool FirstRow {get; set;}

See Also

ITable Interface | Aspose.Slides Namespace


HorizontalBanding Property

Aspose.Slides Documentation

ITable.HorizontalBanding Property

[Visual Basic]
Property HorizontalBanding As Boolean
[C#]
bool HorizontalBanding {get; set;}

See Also

ITable Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ITable.Item Property

[Visual Basic]
Property Item( _
ByVal columnIndex As Integer, _
ByVal rowIndex As Integer _
) As ICell
[C#]
ICell this[
int columnIndex,
int rowIndex
] {get;}

See Also

ITable Interface | Aspose.Slides Namespace


LastCol Property

Aspose.Slides Documentation

ITable.LastCol Property

[Visual Basic]
Property LastCol As Boolean
[C#]
bool LastCol {get; set;}

See Also

ITable Interface | Aspose.Slides Namespace


LastRow Property

Aspose.Slides Documentation

ITable.LastRow Property

[Visual Basic]
Property LastRow As Boolean
[C#]
bool LastRow {get; set;}

See Also

ITable Interface | Aspose.Slides Namespace


RightToLeft Property

Aspose.Slides Documentation

ITable.RightToLeft Property

[Visual Basic]
Property RightToLeft As Boolean
[C#]
bool RightToLeft {get; set;}

See Also

ITable Interface | Aspose.Slides Namespace


Rows Property

Aspose.Slides Documentation

ITable.Rows Property

[Visual Basic]
Property Rows As IRowCollection
[C#]
IRowCollection Rows {get;}

See Also

ITable Interface | Aspose.Slides Namespace


StylePreset Property

Aspose.Slides Documentation

ITable.StylePreset Property

[Visual Basic]
Property StylePreset As TableStylePreset
[C#]
TableStylePreset StylePreset {get; set;}

See Also

ITable Interface | Aspose.Slides Namespace


VerticalBanding Property

Aspose.Slides Documentation

ITable.VerticalBanding Property

[Visual Basic]
Property VerticalBanding As Boolean
[C#]
bool VerticalBanding {get; set;}

See Also

ITable Interface | Aspose.Slides Namespace


ITable Methods

The methods of the ITable interface are listed below. For a complete list of ITable interface members, see the ITable Members topic.

Public Instance Methods

MergeCells

See Also

ITable Interface | Aspose.Slides Namespace


ITable.MergeCells Method

[Visual Basic]
Function MergeCells( _
ByVal cell1 As ICell, _
ByVal cell2 As ICell, _
ByVal allowSplitting As Boolean _
) As ICell
[C#]
ICell MergeCells(
ICell cell1,
ICell cell2,
bool allowSplitting
);

See Also

ITable Interface | Aspose.Slides Namespace


ITagCollection Interface

For a list of all members of this type, see ITagCollection Members.

[Visual Basic]
Public Interface ITagCollection
Implements ICollection, IEnumerable, IEnumerable`1([System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089),[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)), mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089))
[C#]
public interface ITagCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]

Types that implement ITagCollection

Type | Description
TagCollection | Represents the collection of tags (user defined pairs of strings)

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITagCollection Members | Aspose.Slides Namespace


ITagCollection Members

ITagCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

Add
Clear
Contains
GetNameByIndex
GetNamesOfTags
GetValueByIndex
IndexOfName
Remove
RemoveAt

See Also

ITagCollection Interface | Aspose.Slides Namespace


ITagCollection Properties

The properties of the ITagCollection interface are listed below. For a complete list of ITagCollection interface members, see the ITagCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

ITagCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

ITagCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

ITagCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ITagCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ITagCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ITagCollection.Item Property

[Visual Basic]
Property Item( _
ByVal name As String _
) As String
[C#]
string this[
string name
] {get; set;}

See Also

ITagCollection Interface | Aspose.Slides Namespace


ITagCollection Methods

The methods of the ITagCollection interface are listed below. For a complete list of ITagCollection interface members, see the ITagCollection Members topic.

Public Instance Methods

Add
Clear
Contains
GetNameByIndex
GetNamesOfTags
GetValueByIndex
IndexOfName
Remove
RemoveAt

See Also

ITagCollection Interface | Aspose.Slides Namespace


ITagCollection.Add Method

[Visual Basic]
Function Add( _
ByVal name As String, _
ByVal value As String _
) As Integer
[C#]
int Add(
string name,
string value
);

See Also

ITagCollection Interface | Aspose.Slides Namespace


ITagCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

ITagCollection Interface | Aspose.Slides Namespace


ITagCollection.Contains Method

[Visual Basic]
Function Contains( _
ByVal name As String _
) As Boolean
[C#]
bool Contains(
string name
);

See Also

ITagCollection Interface | Aspose.Slides Namespace


ITagCollection.GetNameByIndex Method

[Visual Basic]
Function GetNameByIndex( _
ByVal index As Integer _
) As String
[C#]
string GetNameByIndex(
int index
);

See Also

ITagCollection Interface | Aspose.Slides Namespace


ITagCollection.GetNamesOfTags Method

[Visual Basic]
Function GetNamesOfTags() As String()
[C#]
string[] GetNamesOfTags();

See Also

ITagCollection Interface | Aspose.Slides Namespace


ITagCollection.GetValueByIndex Method

[Visual Basic]
Function GetValueByIndex( _
ByVal index As Integer _
) As String
[C#]
string GetValueByIndex(
int index
);

See Also

ITagCollection Interface | Aspose.Slides Namespace


ITagCollection.IndexOfName Method

[Visual Basic]
Function IndexOfName( _
ByVal name As String _
) As Integer
[C#]
int IndexOfName(
string name
);

See Also

ITagCollection Interface | Aspose.Slides Namespace


ITagCollection.Remove Method

[Visual Basic]
Sub Remove( _
ByVal name As String _
)
[C#]
void Remove(
string name
);

See Also

ITagCollection Interface | Aspose.Slides Namespace


ITagCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

ITagCollection Interface | Aspose.Slides Namespace


ITextFrame Interface

For a list of all members of this type, see ITextFrame Members.

[Visual Basic]
Public Interface ITextFrame
Implements ISlideComponent, IPresentationComponent
[C#]
public interface ITextFrame : ISlideComponent, IPresentationComponent

Types that implement ITextFrame

Type | Description
TextFrame | Represents a TextFrame.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITextFrame Members | Aspose.Slides Namespace


ITextFrame Members

ITextFrame overview

Public Instance Properties

AsISlideComponent
HyperlinkQueries
Paragraphs
Text
TextFrameFormat

See Also

ITextFrame Interface | Aspose.Slides Namespace


ITextFrame Properties

The properties of the ITextFrame interface are listed below. For a complete list of ITextFrame interface members, see the ITextFrame Members topic.

Public Instance Properties

AsISlideComponent
HyperlinkQueries
Paragraphs
Text
TextFrameFormat

See Also

ITextFrame Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

ITextFrame.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

ITextFrame Interface | Aspose.Slides Namespace


HyperlinkQueries Property

Aspose.Slides Documentation

ITextFrame.HyperlinkQueries Property

[Visual Basic]
Property HyperlinkQueries As IHyperlinkQueries
[C#]
IHyperlinkQueries HyperlinkQueries {get;}

See Also

ITextFrame Interface | Aspose.Slides Namespace


Paragraphs Property

Aspose.Slides Documentation

ITextFrame.Paragraphs Property

[Visual Basic]
Property Paragraphs As IParagraphCollection
[C#]
IParagraphCollection Paragraphs {get;}

See Also

ITextFrame Interface | Aspose.Slides Namespace


Text Property

Aspose.Slides Documentation

ITextFrame.Text Property

[Visual Basic]
Property Text As String
[C#]
string Text {get; set;}

See Also

ITextFrame Interface | Aspose.Slides Namespace


TextFrameFormat Property

Aspose.Slides Documentation

ITextFrame.TextFrameFormat Property

[Visual Basic]
Property TextFrameFormat As ITextFrameFormat
[C#]
ITextFrameFormat TextFrameFormat {get;}

See Also

ITextFrame Interface | Aspose.Slides Namespace


ITextFrameFormat Interface

For a list of all members of this type, see ITextFrameFormat Members.

[Visual Basic]
Public Interface ITextFrameFormat
Implements ISlideComponent, IPresentationComponent
[C#]
public interface ITextFrameFormat : ISlideComponent, IPresentationComponent

Types that implement ITextFrameFormat

Type | Description
TextFrameFormat | Contains the TextFrame's formatting properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITextFrameFormat Members | Aspose.Slides Namespace


ITextFrameFormat Members

ITextFrameFormat overview

Public Instance Properties

AnchoringType
AsISlideComponent
AutofitType
CenterText
MarginBottom
MarginLeft
MarginRight
MarginTop
TextStyle
TextVerticalType
WrapText

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


ITextFrameFormat Properties

The properties of the ITextFrameFormat interface are listed below. For a complete list of ITextFrameFormat interface members, see the ITextFrameFormat Members topic.

Public Instance Properties

AnchoringType
AsISlideComponent
AutofitType
CenterText
MarginBottom
MarginLeft
MarginRight
MarginTop
TextStyle
TextVerticalType
WrapText

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


AnchoringType Property

Aspose.Slides Documentation

ITextFrameFormat.AnchoringType Property

[Visual Basic]
Property AnchoringType As TextAnchorType
[C#]
TextAnchorType AnchoringType {get; set;}

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

ITextFrameFormat.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


AutofitType Property

Aspose.Slides Documentation

ITextFrameFormat.AutofitType Property

[Visual Basic]
Property AutofitType As TextAutofitType
[C#]
TextAutofitType AutofitType {get; set;}

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


CenterText Property

Aspose.Slides Documentation

ITextFrameFormat.CenterText Property

[Visual Basic]
Property CenterText As NullableBool
[C#]
NullableBool CenterText {get; set;}

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


MarginBottom Property

Aspose.Slides Documentation

ITextFrameFormat.MarginBottom Property

[Visual Basic]
Property MarginBottom As Double
[C#]
double MarginBottom {get; set;}

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


MarginLeft Property

Aspose.Slides Documentation

ITextFrameFormat.MarginLeft Property

[Visual Basic]
Property MarginLeft As Double
[C#]
double MarginLeft {get; set;}

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


MarginRight Property

Aspose.Slides Documentation

ITextFrameFormat.MarginRight Property

[Visual Basic]
Property MarginRight As Double
[C#]
double MarginRight {get; set;}

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


MarginTop Property

Aspose.Slides Documentation

ITextFrameFormat.MarginTop Property

[Visual Basic]
Property MarginTop As Double
[C#]
double MarginTop {get; set;}

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


TextStyle Property

Aspose.Slides Documentation

ITextFrameFormat.TextStyle Property

[Visual Basic]
Property TextStyle As ITextStyle
[C#]
ITextStyle TextStyle {get;}

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


TextVerticalType Property

Aspose.Slides Documentation

ITextFrameFormat.TextVerticalType Property

[Visual Basic]
Property TextVerticalType As TextVerticalType
[C#]
TextVerticalType TextVerticalType {get; set;}

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


WrapText Property

Aspose.Slides Documentation

ITextFrameFormat.WrapText Property

[Visual Basic]
Property WrapText As NullableBool
[C#]
NullableBool WrapText {get; set;}

See Also

ITextFrameFormat Interface | Aspose.Slides Namespace


ITextStyle Interface

For a list of all members of this type, see ITextStyle Members.

[Visual Basic]
Public Interface ITextStyle
Implements ISlideComponent, IPresentationComponent
[C#]
public interface ITextStyle : ISlideComponent, IPresentationComponent

Types that implement ITextStyle

Type | Description
TextStyle | Summary description for TextStyle.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITextStyle Members | Aspose.Slides Namespace


ITextStyle Members

ITextStyle overview

Public Instance Properties

AsISlideComponent
DefaultParagraphFormat

Public Instance Methods

GetLevel

See Also

ITextStyle Interface | Aspose.Slides Namespace


ITextStyle Properties

The properties of the ITextStyle interface are listed below. For a complete list of ITextStyle interface members, see the ITextStyle Members topic.

Public Instance Properties

AsISlideComponent
DefaultParagraphFormat

See Also

ITextStyle Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

ITextStyle.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

ITextStyle Interface | Aspose.Slides Namespace


DefaultParagraphFormat Property

Aspose.Slides Documentation

ITextStyle.DefaultParagraphFormat Property

[Visual Basic]
Property DefaultParagraphFormat As IParagraphFormat
[C#]
IParagraphFormat DefaultParagraphFormat {get;}

See Also

ITextStyle Interface | Aspose.Slides Namespace


ITextStyle Methods

The methods of the ITextStyle interface are listed below. For a complete list of ITextStyle interface members, see the ITextStyle Members topic.

Public Instance Methods

GetLevel

See Also

ITextStyle Interface | Aspose.Slides Namespace


ITextStyle.GetLevel Method

[Visual Basic]
Function GetLevel( _
ByVal index As Integer _
) As IParagraphFormat
[C#]
IParagraphFormat GetLevel(
int index
);

See Also

ITextStyle Interface | Aspose.Slides Namespace


IThreeDFormat Interface

For a list of all members of this type, see IThreeDFormat Members.

[Visual Basic]
Public Interface IThreeDFormat
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IThreeDFormat : ISlideComponent, IPresentationComponent

Types that implement IThreeDFormat

Type | Description
ThreeDFormat | Represents 3-D properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IThreeDFormat Members | Aspose.Slides Namespace


IThreeDFormat Members

IThreeDFormat overview

Public Instance Properties

AsISlideComponent
BevelBottom
BevelTop
Camera
ContourColor
ContourWidth
Depth
ExtrusionColor
ExtrusionHeight
LightRig
Material

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


IThreeDFormat Properties

The properties of the IThreeDFormat interface are listed below. For a complete list of IThreeDFormat interface members, see the IThreeDFormat Members topic.

Public Instance Properties

AsISlideComponent
BevelBottom
BevelTop
Camera
ContourColor
ContourWidth
Depth
ExtrusionColor
ExtrusionHeight
LightRig
Material

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IThreeDFormat.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


BevelBottom Property

Aspose.Slides Documentation

IThreeDFormat.BevelBottom Property

[Visual Basic]
Property BevelBottom As IShapeBevel
[C#]
IShapeBevel BevelBottom {get;}

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


BevelTop Property

Aspose.Slides Documentation

IThreeDFormat.BevelTop Property

[Visual Basic]
Property BevelTop As IShapeBevel
[C#]
IShapeBevel BevelTop {get;}

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


Camera Property

Aspose.Slides Documentation

IThreeDFormat.Camera Property

[Visual Basic]
Property Camera As ICamera
[C#]
ICamera Camera {get; set;}

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


ContourColor Property

Aspose.Slides Documentation

IThreeDFormat.ContourColor Property

[Visual Basic]
Property ContourColor As IColorFormat
[C#]
IColorFormat ContourColor {get; set;}

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


ContourWidth Property

Aspose.Slides Documentation

IThreeDFormat.ContourWidth Property

[Visual Basic]
Property ContourWidth As Double
[C#]
double ContourWidth {get; set;}

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


Depth Property

Aspose.Slides Documentation

IThreeDFormat.Depth Property

[Visual Basic]
Property Depth As Double
[C#]
double Depth {get; set;}

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


ExtrusionColor Property

Aspose.Slides Documentation

IThreeDFormat.ExtrusionColor Property

[Visual Basic]
Property ExtrusionColor As IColorFormat
[C#]
IColorFormat ExtrusionColor {get; set;}

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


ExtrusionHeight Property

Aspose.Slides Documentation

IThreeDFormat.ExtrusionHeight Property

[Visual Basic]
Property ExtrusionHeight As Double
[C#]
double ExtrusionHeight {get; set;}

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


LightRig Property

Aspose.Slides Documentation

IThreeDFormat.LightRig Property

[Visual Basic]
Property LightRig As ILightRig
[C#]
ILightRig LightRig {get; set;}

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


Material Property

Aspose.Slides Documentation

IThreeDFormat.Material Property

[Visual Basic]
Property Material As MaterialPresetType
[C#]
MaterialPresetType Material {get; set;}

See Also

IThreeDFormat Interface | Aspose.Slides Namespace


IThreeDFormatEffectiveData Interface

For a list of all members of this type, see IThreeDFormatEffectiveData Members.

[Visual Basic]
Public Interface IThreeDFormatEffectiveData
[C#]
public interface IThreeDFormatEffectiveData

Types that implement IThreeDFormatEffectiveData

Type | Description
ThreeDFormatEffectiveData | Immutable object which represents 3-D properties.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IThreeDFormatEffectiveData Members | Aspose.Slides Namespace


IThreeDFormatEffectiveData Members

IThreeDFormatEffectiveData overview

Public Instance Properties

BevelBottom
BevelTop
Camera
ContourColor
ContourWidth
Depth
ExtrusionColor
ExtrusionHeight
LightRig
Material

See Also

IThreeDFormatEffectiveData Interface | Aspose.Slides Namespace


IThreeDFormatEffectiveData Properties

The properties of the IThreeDFormatEffectiveData interface are listed below. For a complete list of IThreeDFormatEffectiveData interface members, see the IThreeDFormatEffectiveData Members topic.

Public Instance Properties

BevelBottom
BevelTop
Camera
ContourColor
ContourWidth
Depth
ExtrusionColor
ExtrusionHeight
LightRig
Material

See Also

IThreeDFormatEffectiveData Interface | Aspose.Slides Namespace


BevelBottom Property

Aspose.Slides Documentation

IThreeDFormatEffectiveData.BevelBottom Property

[Visual Basic]
Property BevelBottom As IShapeBevelEffectiveData
[C#]
IShapeBevelEffectiveData BevelBottom {get;}

See Also

IThreeDFormatEffectiveData Interface | Aspose.Slides Namespace


BevelTop Property

Aspose.Slides Documentation

IThreeDFormatEffectiveData.BevelTop Property

[Visual Basic]
Property BevelTop As IShapeBevelEffectiveData
[C#]
IShapeBevelEffectiveData BevelTop {get;}

See Also

IThreeDFormatEffectiveData Interface | Aspose.Slides Namespace


Camera Property

Aspose.Slides Documentation

IThreeDFormatEffectiveData.Camera Property

[Visual Basic]
Property Camera As ICameraEffectiveData
[C#]
ICameraEffectiveData Camera {get;}

See Also

IThreeDFormatEffectiveData Interface | Aspose.Slides Namespace


ContourColor Property

Aspose.Slides Documentation

IThreeDFormatEffectiveData.ContourColor Property

[Visual Basic]
Property ContourColor As Color
[C#]
Color ContourColor {get;}

See Also

IThreeDFormatEffectiveData Interface | Aspose.Slides Namespace


ContourWidth Property

Aspose.Slides Documentation

IThreeDFormatEffectiveData.ContourWidth Property

[Visual Basic]
Property ContourWidth As Double
[C#]
double ContourWidth {get;}

See Also

IThreeDFormatEffectiveData Interface | Aspose.Slides Namespace


Depth Property

Aspose.Slides Documentation

IThreeDFormatEffectiveData.Depth Property

[Visual Basic]
Property Depth As Double
[C#]
double Depth {get;}

See Also

IThreeDFormatEffectiveData Interface | Aspose.Slides Namespace


ExtrusionColor Property

Aspose.Slides Documentation

IThreeDFormatEffectiveData.ExtrusionColor Property

[Visual Basic]
Property ExtrusionColor As Color
[C#]
Color ExtrusionColor {get;}

See Also

IThreeDFormatEffectiveData Interface | Aspose.Slides Namespace


ExtrusionHeight Property

Aspose.Slides Documentation

IThreeDFormatEffectiveData.ExtrusionHeight Property

[Visual Basic]
Property ExtrusionHeight As Double
[C#]
double ExtrusionHeight {get;}

See Also

IThreeDFormatEffectiveData Interface | Aspose.Slides Namespace


LightRig Property

Aspose.Slides Documentation

IThreeDFormatEffectiveData.LightRig Property

[Visual Basic]
Property LightRig As ILightRigEffectiveData
[C#]
ILightRigEffectiveData LightRig {get;}

See Also

IThreeDFormatEffectiveData Interface | Aspose.Slides Namespace


Material Property

Aspose.Slides Documentation

IThreeDFormatEffectiveData.Material Property

[Visual Basic]
Property Material As MaterialPresetType
[C#]
MaterialPresetType Material {get;}

See Also

IThreeDFormatEffectiveData Interface | Aspose.Slides Namespace


IVideo Interface

For a list of all members of this type, see IVideo Members.

[Visual Basic]
Public Interface IVideo
[C#]
public interface IVideo

Types that implement IVideo

Type | Description
Video | Represents an image embedded into a presentation.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IVideo Members | Aspose.Slides Namespace


IVideo Members

IVideo overview

Public Instance Properties

BinaryData
ContentType

See Also

IVideo Interface | Aspose.Slides Namespace


IVideo Properties

The properties of the IVideo interface are listed below. For a complete list of IVideo interface members, see the IVideo Members topic.

Public Instance Properties

BinaryData
ContentType

See Also

IVideo Interface | Aspose.Slides Namespace


BinaryData Property

Aspose.Slides Documentation

IVideo.BinaryData Property

[Visual Basic]
Property BinaryData As Byte()
[C#]
byte[] BinaryData {get;}

See Also

IVideo Interface | Aspose.Slides Namespace


ContentType Property

Aspose.Slides Documentation

IVideo.ContentType Property

[Visual Basic]
Property ContentType As String
[C#]
string ContentType {get;}

See Also

IVideo Interface | Aspose.Slides Namespace


IVideoCollection Interface

For a list of all members of this type, see IVideoCollection Members.

[Visual Basic]
Public Interface IVideoCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IVideo, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IVideoCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IVideoCollection

Type | Description
VideoCollection | Represents a collection of Video objects.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IVideoCollection Members | Aspose.Slides Namespace


IVideoCollection Members

IVideoCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

AddVideo Overloaded.

See Also

IVideoCollection Interface | Aspose.Slides Namespace


IVideoCollection Properties

The properties of the IVideoCollection interface are listed below. For a complete list of IVideoCollection interface members, see the IVideoCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IVideoCollection Interface | Aspose.Slides Namespace


AsICollection Property

Aspose.Slides Documentation

IVideoCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IVideoCollection Interface | Aspose.Slides Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IVideoCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IVideoCollection Interface | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

IVideoCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IVideo
[C#]
IVideo this[
int index
] {get;}

See Also

IVideoCollection Interface | Aspose.Slides Namespace


IVideoCollection Methods

The methods of the IVideoCollection interface are listed below. For a complete list of IVideoCollection interface members, see the IVideoCollection Members topic.

Public Instance Methods

AddVideo Overloaded.

See Also

IVideoCollection Interface | Aspose.Slides Namespace


AddVideo Method

Aspose.Slides Documentation

IVideoCollection.AddVideo Method

Overload List

IVideo AddVideo(IVideo);

IVideo AddVideo(byte[]);

IVideo AddVideo(Stream);

See Also

IVideoCollection Interface | Aspose.Slides Namespace


IVideoCollection.AddVideo Method (IVideo)

[Visual Basic]
Function AddVideo( _
ByVal video As IVideo _
) As IVideo
[C#]
IVideo AddVideo(
IVideo video
);

See Also

IVideoCollection Interface | Aspose.Slides Namespace | IVideoCollection.AddVideo Overload List


IVideoCollection.AddVideo Method (Byte[])

[Visual Basic]
Function AddVideo( _
ByVal videoData As Byte() _
) As IVideo
[C#]
IVideo AddVideo(
byte[] videoData
);

See Also

IVideoCollection Interface | Aspose.Slides Namespace | IVideoCollection.AddVideo Overload List


IVideoCollection.AddVideo Method (Stream)

[Visual Basic]
Function AddVideo( _
ByVal stream As Stream _
) As IVideo
[C#]
IVideo AddVideo(
Stream stream
);

See Also

IVideoCollection Interface | Aspose.Slides Namespace | IVideoCollection.AddVideo Overload List


IVideoFrame Interface

For a list of all members of this type, see IVideoFrame Members.

[Visual Basic]
Public Interface IVideoFrame
Implements IPictureFrame, IGeometryShape, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public interface IVideoFrame : IPictureFrame, IGeometryShape, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer

Types that implement IVideoFrame

Type | Description
VideoFrame | Represents a video clip on a slide.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IVideoFrame Members | Aspose.Slides Namespace


IVideoFrame Members

IVideoFrame overview

Public Instance Properties

AsIPictureFrame
EmbeddedVideo
FullScreenMode
HideAtShowing
LinkPathLong
PlayLoopMode
PlayMode
RewindVideo
Volume

See Also

IVideoFrame Interface | Aspose.Slides Namespace


IVideoFrame Properties

The properties of the IVideoFrame interface are listed below. For a complete list of IVideoFrame interface members, see the IVideoFrame Members topic.

Public Instance Properties

AsIPictureFrame
EmbeddedVideo
FullScreenMode
HideAtShowing
LinkPathLong
PlayLoopMode
PlayMode
RewindVideo
Volume

See Also

IVideoFrame Interface | Aspose.Slides Namespace


AsIPictureFrame Property

Aspose.Slides Documentation

IVideoFrame.AsIPictureFrame Property

[Visual Basic]
Property AsIPictureFrame As IPictureFrame
[C#]
IPictureFrame AsIPictureFrame {get;}

See Also

IVideoFrame Interface | Aspose.Slides Namespace


EmbeddedVideo Property

Aspose.Slides Documentation

IVideoFrame.EmbeddedVideo Property

[Visual Basic]
Property EmbeddedVideo As IVideo
[C#]
IVideo EmbeddedVideo {get; set;}

See Also

IVideoFrame Interface | Aspose.Slides Namespace


FullScreenMode Property

Aspose.Slides Documentation

IVideoFrame.FullScreenMode Property

[Visual Basic]
Property FullScreenMode As Boolean
[C#]
bool FullScreenMode {get; set;}

See Also

IVideoFrame Interface | Aspose.Slides Namespace


HideAtShowing Property

Aspose.Slides Documentation

IVideoFrame.HideAtShowing Property

[Visual Basic]
Property HideAtShowing As Boolean
[C#]
bool HideAtShowing {get; set;}

See Also

IVideoFrame Interface | Aspose.Slides Namespace


LinkPathLong Property

Aspose.Slides Documentation

IVideoFrame.LinkPathLong Property

[Visual Basic]
Property LinkPathLong As String
[C#]
string LinkPathLong {get; set;}

See Also

IVideoFrame Interface | Aspose.Slides Namespace


PlayLoopMode Property

Aspose.Slides Documentation

IVideoFrame.PlayLoopMode Property

[Visual Basic]
Property PlayLoopMode As Boolean
[C#]
bool PlayLoopMode {get; set;}

See Also

IVideoFrame Interface | Aspose.Slides Namespace


PlayMode Property

Aspose.Slides Documentation

IVideoFrame.PlayMode Property

[Visual Basic]
Property PlayMode As VideoPlayModePreset
[C#]
VideoPlayModePreset PlayMode {get; set;}

See Also

IVideoFrame Interface | Aspose.Slides Namespace


RewindVideo Property

Aspose.Slides Documentation

IVideoFrame.RewindVideo Property

[Visual Basic]
Property RewindVideo As Boolean
[C#]
bool RewindVideo {get; set;}

See Also

IVideoFrame Interface | Aspose.Slides Namespace


Volume Property

Aspose.Slides Documentation

IVideoFrame.Volume Property

[Visual Basic]
Property Volume As AudioVolumeMode
[C#]
AudioVolumeMode Volume {get; set;}

See Also

IVideoFrame Interface | Aspose.Slides Namespace


LayoutSlide Class

Represents a layout slide.

For a list of all members of this type, see LayoutSlide Members.

System.Object
Aspose.Slides.BaseSlide
Aspose.Slides.LayoutSlide

[Visual Basic]
NotInheritable Public Class LayoutSlide
Inherits BaseSlide
Implements ILayoutSlide, IOverrideThemeable
[C#]
public sealed class LayoutSlide : BaseSlide, ILayoutSlide, IOverrideThemeable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LayoutSlide Members | Aspose.Slides Namespace


LayoutSlide Members

LayoutSlide overview

Public Instance Properties

Background (inherited from BaseSlide) | Returns slide's background. Read only Background.
Controls (inherited from BaseSlide) | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData (inherited from BaseSlide) | Returns the slide's custom data. Read-only ICustomData.
HasDependingSlides | Returns true if there exists at least one slide that depends on this layout slide.
HyperlinkQueries (inherited from BaseSlide) | Provides easy access to contained hyperlinks.
LayoutType | Returns layout type of this layout slide. Readonly SlideLayoutType.
MasterSlide | Returns or sets the master slide for a layout. Read/write MasterSlide.
Name (inherited from BaseSlide) | Returns or sets the name of a slide. Read/write String.
OverrideTheme | Obsolete. Returns the overriding theme object.
ParentPresentation (inherited from BaseSlide) | Obsolete. Returns the parent presentation. Read-only Presentation.
Presentation (inherited from BaseSlide) |
Shapes (inherited from BaseSlide) | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId (inherited from BaseSlide) | Returns the ID of a slide.
SlideShowTransition (inherited from BaseSlide) | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags (inherited from BaseSlide) | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
ThemeManager |
Timeline (inherited from BaseSlide) | Returns animation timeline object. Read-only AnimationTimeLine.

Public Instance Methods

ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseSlide) | Returns an effective theme for this slide.
FindShapeByAltText (inherited from BaseSlide) | Finds first occurrence of a shape with the specified alternative text.
GetDependingSlides | Returns an array with all slides, which depend on this layout slide.
Remove | Removes layout from presentation.

See Also

LayoutSlide Class | Aspose.Slides Namespace


LayoutSlide Properties

The properties of the LayoutSlide class are listed below. For a complete list of LayoutSlide class members, see the LayoutSlide Members topic.

Public Instance Properties

Background (inherited from BaseSlide) | Returns slide's background. Read only Background.
Controls (inherited from BaseSlide) | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData (inherited from BaseSlide) | Returns the slide's custom data. Read-only ICustomData.
HasDependingSlides | Returns true if there exists at least one slide that depends on this layout slide.
HyperlinkQueries (inherited from BaseSlide) | Provides easy access to contained hyperlinks.
LayoutType | Returns layout type of this layout slide. Readonly SlideLayoutType.
MasterSlide | Returns or sets the master slide for a layout. Read/write MasterSlide.
Name (inherited from BaseSlide) | Returns or sets the name of a slide. Read/write String.
OverrideTheme | Obsolete. Returns the overriding theme object.
ParentPresentation (inherited from BaseSlide) | Obsolete. Returns the parent presentation. Read-only Presentation.
Presentation (inherited from BaseSlide) |
Shapes (inherited from BaseSlide) | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId (inherited from BaseSlide) | Returns the ID of a slide.
SlideShowTransition (inherited from BaseSlide) | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags (inherited from BaseSlide) | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
ThemeManager |
Timeline (inherited from BaseSlide) | Returns animation timeline object. Read-only AnimationTimeLine.

See Also

LayoutSlide Class | Aspose.Slides Namespace


HasDependingSlides Property

Aspose.Slides Documentation

LayoutSlide.HasDependingSlides Property

Returns true if there exists at least one slide that depends on this layout slide.

[Visual Basic]
NotOverridable Public ReadOnly Property HasDependingSlides As Boolean _
Implements ILayoutSlide.HasDependingSlides
[C#]
public bool HasDependingSlides {get;}

Implements

ILayoutSlide.HasDependingSlides

See Also

LayoutSlide Class | Aspose.Slides Namespace


LayoutType Property

Aspose.Slides Documentation

LayoutSlide.LayoutType Property

Returns layout type of this layout slide. Readonly SlideLayoutType.

[Visual Basic]
NotOverridable Public ReadOnly Property LayoutType As SlideLayoutType _
Implements ILayoutSlide.LayoutType
[C#]
public SlideLayoutType LayoutType {get;}

Implements

ILayoutSlide.LayoutType

See Also

LayoutSlide Class | Aspose.Slides Namespace


MasterSlide Property

Aspose.Slides Documentation

LayoutSlide.MasterSlide Property

Returns or sets the master slide for a layout. Read/write MasterSlide.

[Visual Basic]
NotOverridable Public Property MasterSlide As IMasterSlide _
Implements ILayoutSlide.MasterSlide
[C#]
public IMasterSlide MasterSlide {get; set;}

Implements

ILayoutSlide.MasterSlide

See Also

LayoutSlide Class | Aspose.Slides Namespace


OverrideTheme Property

Aspose.Slides Documentation

LayoutSlide.OverrideTheme Property

NOTE: This property is now obsolete.

Use ThemeManager.OverrideTheme property instead. Property will be removed after 01.09.2013.

Returns the overriding theme object.

[Visual Basic]
Public ReadOnly Property OverrideTheme As OverrideTheme
[C#]
public OverrideTheme OverrideTheme {get;}

See Also

LayoutSlide Class | Aspose.Slides Namespace


ThemeManager Property

Aspose.Slides Documentation

LayoutSlide.ThemeManager Property

[Visual Basic]
NotOverridable Public ReadOnly Property ThemeManager As IOverrideThemeManager _
Implements IOverrideThemeable.ThemeManager
[C#]
public IOverrideThemeManager ThemeManager {get;}

Implements

IOverrideThemeable.ThemeManager

See Also

LayoutSlide Class | Aspose.Slides Namespace


LayoutSlide Methods

The methods of the LayoutSlide class are listed below. For a complete list of LayoutSlide class members, see the LayoutSlide Members topic.

Public Instance Methods

ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseSlide) | Returns an effective theme for this slide.
FindShapeByAltText (inherited from BaseSlide) | Finds first occurrence of a shape with the specified alternative text.
GetDependingSlides | Returns an array with all slides, which depend on this layout slide.
Remove | Removes layout from presentation.

See Also

LayoutSlide Class | Aspose.Slides Namespace


LayoutSlide.ApplyColorScheme Method

NOTE: This method is now obsolete.

Use ThemeManager.ApplyColorScheme(..) method instead. Will be removed after 01.09.2013.

Applies extra color scheme to a slide.

[Visual Basic]
Overrides Public Sub ApplyColorScheme( _
ByVal scheme As ExtraColorScheme _
)
[C#]
public override void ApplyColorScheme(
ExtraColorScheme scheme
);

Parameters

scheme

See Also

LayoutSlide Class | Aspose.Slides Namespace


LayoutSlide.GetDependingSlides Method

Returns an array with all slides, which depend on this layout slide.

[Visual Basic]
NotOverridable Public Function GetDependingSlides() As ISlide() _
Implements ILayoutSlide.GetDependingSlides
[C#]
public ISlide[] GetDependingSlides();

Return Value

Implements

ILayoutSlide.GetDependingSlides

See Also

LayoutSlide Class | Aspose.Slides Namespace


LayoutSlide.Remove Method

Removes layout from presentation.

[Visual Basic]
NotOverridable Public Sub Remove() _
Implements ILayoutSlide.Remove
[C#]
public void Remove();

Implements

ILayoutSlide.Remove

Remarks

To avoid throwing of the PptxEditException check layout's HasDependingSlides property before.

Exceptions

Exception Type | Condition
PptxEditException | Thrown if layout is already removed from presentation or if layout is used in presentation (its HasDependingSlides property is true).

See Also

LayoutSlide Class | Aspose.Slides Namespace


LayoutSlideCollection Class

Represents a base class for collection of a layout slides.

For a list of all members of this type, see LayoutSlideCollection Members.

System.Object
Aspose.Slides.LayoutSlideCollection
Aspose.Slides.GlobalLayoutSlideCollection
Aspose.Slides.MasterLayoutSlideCollection

[Visual Basic]
Public Class LayoutSlideCollection
Implements ILayoutSlideCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ILayoutSlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class LayoutSlideCollection : ILayoutSlideCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LayoutSlideCollection Members | Aspose.Slides Namespace


LayoutSlideCollection Members

LayoutSlideCollection overview

Public Instance Properties

Count | Returns the number of layout slides in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns the layout slide by index. Read-only LayoutSlide.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetByType | Returns the first layout slide of specified type. A type of layout slide to find.LayoutSlide with specified type or null if no layouts found.
GetEnumerator | Returns an enumerator for the entire collection.
Remove | Removes a layout from the collection.
RemoveUnused | Removes unused layout slides (layout slides whose HasDependingSlides is false).

See Also

LayoutSlideCollection Class | Aspose.Slides Namespace


LayoutSlideCollection Properties

The properties of the LayoutSlideCollection class are listed below. For a complete list of LayoutSlideCollection class members, see the LayoutSlideCollection Members topic.

Public Instance Properties

Count | Returns the number of layout slides in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns the layout slide by index. Read-only LayoutSlide.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

LayoutSlideCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

LayoutSlideCollection.Count Property

Returns the number of layout slides in a collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

LayoutSlideCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

LayoutSlideCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

LayoutSlideCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

LayoutSlideCollection.Item Property

Returns the layout slide by index. Read-only LayoutSlide.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ILayoutSlideCollection.Item
As ILayoutSlide _
Implements ILayoutSlideCollection.Item
[C#]
public ILayoutSlide this[
int index
] {get;}

Implements

ILayoutSlideCollection.Item

See Also

LayoutSlideCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

LayoutSlideCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

LayoutSlideCollection Class | Aspose.Slides Namespace


LayoutSlideCollection Methods

The methods of the LayoutSlideCollection class are listed below. For a complete list of LayoutSlideCollection class members, see the LayoutSlideCollection Members topic.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetByType | Returns the first layout slide of specified type. A type of layout slide to find.LayoutSlide with specified type or null if no layouts found.
GetEnumerator | Returns an enumerator for the entire collection.
Remove | Removes a layout from the collection.
RemoveUnused | Removes unused layout slides (layout slides whose HasDependingSlides is false).

See Also

LayoutSlideCollection Class | Aspose.Slides Namespace


LayoutSlideCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

LayoutSlideCollection Class | Aspose.Slides Namespace


LayoutSlideCollection.GetByType Method

Returns the first layout slide of specified type. A type of layout slide to find.LayoutSlide with specified type or null if no layouts found.

[Visual Basic]
NotOverridable Public Function GetByType( _
ByVal type As SlideLayoutType _
) As ILayoutSlide _
Implements ILayoutSlideCollection.GetByType
[C#]
public ILayoutSlide GetByType(
SlideLayoutType type
);

Implements

ILayoutSlideCollection.GetByType

See Also

LayoutSlideCollection Class | Aspose.Slides Namespace


LayoutSlideCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

LayoutSlideCollection Class | Aspose.Slides Namespace


LayoutSlideCollection.Remove Method

Removes a layout from the collection.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal value As ILayoutSlide _
) _
Implements ILayoutSlideCollection.Remove
[C#]
public void Remove(
ILayoutSlide value
);

Parameters

value
The layout slide to remove from the collection.

Implements

ILayoutSlideCollection.Remove

Remarks

1) To avoid throwing of the PptxEditException check layout's HasDependingSlides property before. 2) You can use also Remove method to simplify code.

Exceptions

Exception Type | Condition
PptxEditException | Thrown if layout is used in presentation (its HasDependingSlides property is true).

See Also

LayoutSlideCollection Class | Aspose.Slides Namespace


LayoutSlideCollection.RemoveUnused Method

Removes unused layout slides (layout slides whose HasDependingSlides is false).

[Visual Basic]
NotOverridable Public Sub RemoveUnused() _
Implements ILayoutSlideCollection.RemoveUnused
[C#]
public void RemoveUnused();

Implements

ILayoutSlideCollection.RemoveUnused

See Also

LayoutSlideCollection Class | Aspose.Slides Namespace


License Class

Provides methods to license the component.

For a list of all members of this type, see License Members.

System.Object
Aspose.Slides.License

[Visual Basic]
Public Class License
[C#]
public class License

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As license = New license
License.SetLicense("MyLicense.lic")

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

License Members | Aspose.Slides Namespace


License Members

License overview

Public Instance Constructors

License Constructor Initializes a new instance of this class.

Public Instance Methods

IsLicensed | Check if licence is applied to component
ResetLicense | Reset the license
SetLicense | Overloaded. Licenses the component.

See Also

License Class | Aspose.Slides Namespace


License Constructor

Initializes a new instance of this class.

[Visual Basic]
Public Sub New()
[C#]
public License();

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As license = New license
License.SetLicense("MyLicense.lic")

See Also

License Class | Aspose.Slides Namespace


License Methods

The methods of the License class are listed below. For a complete list of License class members, see the License Members topic.

Public Instance Methods

IsLicensed | Check if licence is applied to component
ResetLicense | Reset the license
SetLicense | Overloaded. Licenses the component.

See Also

License Class | Aspose.Slides Namespace


License.IsLicensed Method

Check if licence is applied to component

[Visual Basic]
Public Function IsLicensed() As Boolean
[C#]
public bool IsLicensed();

Return Value

True if component is licensed, otherwise false

See Also

License Class | Aspose.Slides Namespace


License.ResetLicense Method

Reset the license

[Visual Basic]
Public Sub ResetLicense()
[C#]
public void ResetLicense();

Remarks

Use this method to reset license in component

Example

[C#]

License license = new License();
license.ResetLicense();

[Visual Basic]

Dim license as License = new License
license.ResetLicense()

See Also

License Class | Aspose.Slides Namespace


SetLicense Method

Aspose.Slides Documentation

License.SetLicense Method

Licenses the component.

Overload List

Licenses the component.

public void SetLicense(Stream);

Licenses the component.

public void SetLicense(string);

See Also

License Class | Aspose.Slides Namespace


License.SetLicense Method (Stream)

Licenses the component.

[Visual Basic]
Overloads Public Sub SetLicense( _
ByVal stream As Stream _
)
[C#]
public void SetLicense(
Stream stream
);

Parameters

stream
A stream that contains the license.

Remarks

Use this method to load a license from a stream.

Example

[C#]

License license = new License();
license.SetLicense(myStream);

[Visual Basic]

Dim license as License = new License
license.SetLicense(myStream)

See Also

License Class | Aspose.Slides Namespace | License.SetLicense Overload List


License.SetLicense Method (String)

Licenses the component.

[Visual Basic]
Overloads Public Sub SetLicense( _
ByVal licenseName As String _
)
[C#]
public void SetLicense(
string licenseName
);

Parameters

licenseName
Can be a full or short file name or name of an embedded resource. Use an empty string to switch to evaluation mode.

Remarks

Tries to find the license in the following locations:

1. Explicit path.

2. The folder of the component assembly.

3. The folder of the client's calling assembly.

4. The folder of the entry assembly.

5. An embedded resource in the client's calling assembly.

Note:On the .NET Compact Framework, tries to find the license only in these locations:

1. Explicit path.

2. An embedded resource in the client's calling assembly.

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As License = New License
license.SetLicense("MyLicense.lic")

See Also

License Class | Aspose.Slides Namespace | License.SetLicense Overload List


LightingDirection Enumeration

[Visual Basic]
Public Enum LightingDirection
[C#]
public enum LightingDirection

Members

Member Name | Description | Value
NotDefined |  | -1
TopLeft |  | 0
Top |  | 1
TopRight |  | 2
Right |  | 3
BottomRight |  | 4
Bottom |  | 5
BottomLeft |  | 6
Left |  | 7

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


LightRig Class

Represents LightRig.

For a list of all members of this type, see LightRig Members.

System.Object
Aspose.Slides.LightRig

[Visual Basic]
Public Class LightRig
Implements ILightRig
[C#]
public class LightRig : ILightRig

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LightRig Members | Aspose.Slides Namespace


LightRig Members

LightRig overview

Public Instance Constructors

LightRig Constructor Default constructor.

Public Instance Properties

Direction | Light direction Read/write LightingDirection
LightType | Represents a preset light right that can be applied to a shape. The light rig represents a group of lights oriented in a specific way relative to a 3D scene. Read/write LightRigPresetType

Public Instance Methods

Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRotation | A rotation is defined through the use of a latitude coordinate, a longitude coordinate, and a revolution about the axis as the latitude and longitude coordinates. first element in return array - latitude, second - longitude, third - revolution.
SetRotation | A rotation is defined through the use of a latitude coordinate, a longitude coordinate, and a revolution about the axis as the latitude and longitude coordinates.

See Also

LightRig Class | Aspose.Slides Namespace


LightRig Constructor

Default constructor.

[Visual Basic]
Public Sub New()
[C#]
public LightRig();

See Also

LightRig Class | Aspose.Slides Namespace


LightRig Properties

The properties of the LightRig class are listed below. For a complete list of LightRig class members, see the LightRig Members topic.

Public Instance Properties

Direction | Light direction Read/write LightingDirection
LightType | Represents a preset light right that can be applied to a shape. The light rig represents a group of lights oriented in a specific way relative to a 3D scene. Read/write LightRigPresetType

See Also

LightRig Class | Aspose.Slides Namespace


Direction Property

Aspose.Slides Documentation

LightRig.Direction Property

Light direction Read/write LightingDirection

[Visual Basic]
NotOverridable Public Property Direction As LightingDirection _
Implements ILightRig.Direction
[C#]
public LightingDirection Direction {get; set;}

Implements

ILightRig.Direction

See Also

LightRig Class | Aspose.Slides Namespace


LightType Property

Aspose.Slides Documentation

LightRig.LightType Property

Represents a preset light right that can be applied to a shape. The light rig represents a group of lights oriented in a specific way relative to a 3D scene. Read/write LightRigPresetType

[Visual Basic]
NotOverridable Public Property LightType As LightRigPresetType _
Implements ILightRig.LightType
[C#]
public LightRigPresetType LightType {get; set;}

Implements

ILightRig.LightType

See Also

LightRig Class | Aspose.Slides Namespace


LightRig Methods

The methods of the LightRig class are listed below. For a complete list of LightRig class members, see the LightRig Members topic.

Public Instance Methods

Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRotation | A rotation is defined through the use of a latitude coordinate, a longitude coordinate, and a revolution about the axis as the latitude and longitude coordinates. first element in return array - latitude, second - longitude, third - revolution.
SetRotation | A rotation is defined through the use of a latitude coordinate, a longitude coordinate, and a revolution about the axis as the latitude and longitude coordinates.

See Also

LightRig Class | Aspose.Slides Namespace


LightRig.Equals Method

Determines whether two FillFormat instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

See Also

LightRig Class | Aspose.Slides Namespace


LightRig.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Remarks

Overriden to make compiler happy.

See Also

LightRig Class | Aspose.Slides Namespace


LightRig.GetRotation Method

A rotation is defined through the use of a latitude coordinate, a longitude coordinate, and a revolution about the axis as the latitude and longitude coordinates. first element in return array - latitude, second - longitude, third - revolution.

[Visual Basic]
NotOverridable Public Function GetRotation() As Single() _
Implements ILightRig.GetRotation
[C#]
public float[] GetRotation();

Implements

ILightRig.GetRotation

See Also

LightRig Class | Aspose.Slides Namespace


LightRig.SetRotation Method

A rotation is defined through the use of a latitude coordinate, a longitude coordinate, and a revolution about the axis as the latitude and longitude coordinates.

[Visual Basic]
NotOverridable Public Sub SetRotation( _
ByVal latitude As Single, _
ByVal longitude As Single, _
ByVal revolution As Single _
) _
Implements ILightRig.SetRotation
[C#]
public void SetRotation(
float latitude,
float longitude,
float revolution
);

Implements

ILightRig.SetRotation

See Also

LightRig Class | Aspose.Slides Namespace


LightRigPresetType Enumeration

[Visual Basic]
Public Enum LightRigPresetType
[C#]
public enum LightRigPresetType

Members

Member Name | Description | Value
NotDefined |  | -1
Balanced |  | 0
BrightRoom |  | 1
Chilly |  | 2
Contrasting |  | 3
Flat |  | 4
Flood |  | 5
Freezing |  | 6
Glow |  | 7
Harsh |  | 8
LegacyFlat1 |  | 9
LegacyFlat2 |  | 10
LegacyFlat3 |  | 11
LegacyFlat4 |  | 12
LegacyHarsh1 |  | 13
LegacyHarsh2 |  | 14
LegacyHarsh3 |  | 15
LegacyHarsh4 |  | 16
LegacyNormal1 |  | 17
LegacyNormal2 |  | 18
LegacyNormal3 |  | 19
LegacyNormal4 |  | 20
Morning |  | 21
Soft |  | 22
Sunrise |  | 23
Sunset |  | 24
ThreePt |  | 25
TwoPt |  | 26

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


LineAlignment Enumeration

[Visual Basic]
Public Enum LineAlignment
Inherits
[C#]
public enum LineAlignment

Members

Member Name | Description | Value
NotDefined |  | -1
Center |  | 0
Inset |  | 1

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


LineArrowheadLength Enumeration

[Visual Basic]
Public Enum LineArrowheadLength
Inherits
[C#]
public enum LineArrowheadLength

Members

Member Name | Description | Value
NotDefined |  | -1
Short |  | 0
Medium |  | 1
Long |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


LineArrowheadStyle Enumeration

[Visual Basic]
Public Enum LineArrowheadStyle
Inherits
[C#]
public enum LineArrowheadStyle

Members

Member Name | Description | Value
NotDefined |  | -1
None |  | 0
Triangle |  | 1
Stealth |  | 2
Diamond |  | 3
Oval |  | 4
Open |  | 5

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


LineArrowheadWidth Enumeration

[Visual Basic]
Public Enum LineArrowheadWidth
Inherits
[C#]
public enum LineArrowheadWidth

Members

Member Name | Description | Value
NotDefined |  | -1
Narrow |  | 0
Medium |  | 1
Wide |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


LineCapStyle Enumeration

[Visual Basic]
Public Enum LineCapStyle
Inherits
[C#]
public enum LineCapStyle

Members

Member Name | Description | Value
NotDefined |  | -1
Round |  | 0
Square |  | 1
Flat |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


LineDashStyle Enumeration

[Visual Basic]
Public Enum LineDashStyle
Inherits
[C#]
public enum LineDashStyle

Members

Member Name | Description | Value
NotDefined |  | -1
Solid |  | 0
Dot |  | 1
Dash |  | 2
LargeDash |  | 3
DashDot |  | 4
LargeDashDot |  | 5
LargeDashDotDot |  | 6
SystemDash |  | 7
SystemDot |  | 8
SystemDashDot |  | 9
SystemDashDotDot |  | 10
Custom |  | 11

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


LineFillFormat Class

Represents properties for lines filling.

For a list of all members of this type, see LineFillFormat Members.

System.Object
Aspose.Slides.LineFillFormat

[Visual Basic]
Public Class LineFillFormat
Implements ILineFillFormat, IFillParamSource, ISlideComponent, IPresentationComponent
[C#]
public class LineFillFormat : ILineFillFormat, IFillParamSource, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LineFillFormat Members | Aspose.Slides Namespace


LineFillFormat Members

LineFillFormat overview

Public Instance Properties

FillType | Returns or sets the fill type. Read/write FillType.
GradientFormat | Returns the gradient fill format. Read-only GradientFormat.
PatternFormat | Returns the pattern fill format. Read-only PatternFormat.
RotateWithShape | Determines whether the fill should be rotated with a shape. Read/write NullableBool.
SolidFillColor | Returns the color of a solid fill. Read-only ColorFormat.

Public Instance Methods

Equals | Determines whether the two LineFillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

LineFillFormat Class | Aspose.Slides Namespace


LineFillFormat Properties

The properties of the LineFillFormat class are listed below. For a complete list of LineFillFormat class members, see the LineFillFormat Members topic.

Public Instance Properties

FillType | Returns or sets the fill type. Read/write FillType.
GradientFormat | Returns the gradient fill format. Read-only GradientFormat.
PatternFormat | Returns the pattern fill format. Read-only PatternFormat.
RotateWithShape | Determines whether the fill should be rotated with a shape. Read/write NullableBool.
SolidFillColor | Returns the color of a solid fill. Read-only ColorFormat.

See Also

LineFillFormat Class | Aspose.Slides Namespace


FillType Property

Aspose.Slides Documentation

LineFillFormat.FillType Property

Returns or sets the fill type. Read/write FillType.

[Visual Basic]
NotOverridable Public Property FillType As FillType _
Implements ILineFillFormat.FillType
[C#]
public FillType FillType {get; set;}

Implements

ILineFillFormat.FillType

See Also

LineFillFormat Class | Aspose.Slides Namespace


GradientFormat Property

Aspose.Slides Documentation

LineFillFormat.GradientFormat Property

Returns the gradient fill format. Read-only GradientFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property GradientFormat As IGradientFormat _
Implements ILineFillFormat.GradientFormat
[C#]
public IGradientFormat GradientFormat {get;}

Implements

ILineFillFormat.GradientFormat

See Also

LineFillFormat Class | Aspose.Slides Namespace


PatternFormat Property

Aspose.Slides Documentation

LineFillFormat.PatternFormat Property

Returns the pattern fill format. Read-only PatternFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property PatternFormat As IPatternFormat _
Implements ILineFillFormat.PatternFormat
[C#]
public IPatternFormat PatternFormat {get;}

Implements

ILineFillFormat.PatternFormat

See Also

LineFillFormat Class | Aspose.Slides Namespace


RotateWithShape Property

Aspose.Slides Documentation

LineFillFormat.RotateWithShape Property

Determines whether the fill should be rotated with a shape. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property RotateWithShape As NullableBool _
Implements ILineFillFormat.RotateWithShape
[C#]
public NullableBool RotateWithShape {get; set;}

Implements

ILineFillFormat.RotateWithShape

See Also

LineFillFormat Class | Aspose.Slides Namespace


SolidFillColor Property

Aspose.Slides Documentation

LineFillFormat.SolidFillColor Property

Returns the color of a solid fill. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property SolidFillColor As IColorFormat _
Implements ILineFillFormat.SolidFillColor
[C#]
public IColorFormat SolidFillColor {get;}

Implements

ILineFillFormat.SolidFillColor

See Also

LineFillFormat Class | Aspose.Slides Namespace


LineFillFormat Methods

The methods of the LineFillFormat class are listed below. For a complete list of LineFillFormat class members, see the LineFillFormat Members topic.

Public Instance Methods

Equals | Determines whether the two LineFillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

LineFillFormat Class | Aspose.Slides Namespace


LineFillFormat.Equals Method

Determines whether the two LineFillFormat instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The LineFillFormat to compare with the current LineFillFormat.

Return Value

true if the specified LineFillFormat is equal to the current LineFillFormat; otherwise, false.

See Also

LineFillFormat Class | Aspose.Slides Namespace


LineFillFormat.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

23453

Remarks

Overriden to make compiler happy. Always returns constant because object is mutable.

See Also

LineFillFormat Class | Aspose.Slides Namespace


LineFillFormatEffectiveData Class

Immutable object which represents properties for lines filling.

For a list of all members of this type, see LineFillFormatEffectiveData Members.

System.Object
Aspose.Slides.LineFillFormatEffectiveData

[Visual Basic]
Public Class LineFillFormatEffectiveData
Implements ILineFillFormatEffectiveData, IFillParamSource
[C#]
public class LineFillFormatEffectiveData : ILineFillFormatEffectiveData, IFillParamSource

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LineFillFormatEffectiveData Members | Aspose.Slides Namespace


LineFillFormatEffectiveData Members

LineFillFormatEffectiveData overview

Public Instance Properties

FillType | Returns the fill type. Read-only FillType.
GradientFormat | Returns the gradient fill format. Read-only IGradientFormatEffectiveData.
PatternFormat | Returns the pattern fill format. Read-only IPatternFormatEffectiveData.
RotateWithShape | Determines whether the fill should be rotated with a shape. Read-only Boolean.
SolidFillColor | Returns the color of a solid fill. Read-only Color.

Public Instance Methods

Equals | Determines whether the two LineFillValueEx instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

LineFillFormatEffectiveData Class | Aspose.Slides Namespace


LineFillFormatEffectiveData Properties

The properties of the LineFillFormatEffectiveData class are listed below. For a complete list of LineFillFormatEffectiveData class members, see the LineFillFormatEffectiveData Members topic.

Public Instance Properties

FillType | Returns the fill type. Read-only FillType.
GradientFormat | Returns the gradient fill format. Read-only IGradientFormatEffectiveData.
PatternFormat | Returns the pattern fill format. Read-only IPatternFormatEffectiveData.
RotateWithShape | Determines whether the fill should be rotated with a shape. Read-only Boolean.
SolidFillColor | Returns the color of a solid fill. Read-only Color.

See Also

LineFillFormatEffectiveData Class | Aspose.Slides Namespace


FillType Property

Aspose.Slides Documentation

LineFillFormatEffectiveData.FillType Property

Returns the fill type. Read-only FillType.

[Visual Basic]
NotOverridable Public ReadOnly Property FillType As FillType _
Implements ILineFillFormatEffectiveData.FillType
[C#]
public FillType FillType {get;}

Implements

ILineFillFormatEffectiveData.FillType

See Also

LineFillFormatEffectiveData Class | Aspose.Slides Namespace


GradientFormat Property

Aspose.Slides Documentation

LineFillFormatEffectiveData.GradientFormat Property

Returns the gradient fill format. Read-only IGradientFormatEffectiveData.

[Visual Basic]
NotOverridable Public ReadOnly Property GradientFormat As IGradientFormatEffectiveData _
Implements ILineFillFormatEffectiveData.GradientFormat
[C#]
public IGradientFormatEffectiveData GradientFormat {get;}

Implements

ILineFillFormatEffectiveData.GradientFormat

See Also

LineFillFormatEffectiveData Class | Aspose.Slides Namespace


PatternFormat Property

Aspose.Slides Documentation

LineFillFormatEffectiveData.PatternFormat Property

Returns the pattern fill format. Read-only IPatternFormatEffectiveData.

[Visual Basic]
NotOverridable Public ReadOnly Property PatternFormat As IPatternFormatEffectiveData _
Implements ILineFillFormatEffectiveData.PatternFormat
[C#]
public IPatternFormatEffectiveData PatternFormat {get;}

Implements

ILineFillFormatEffectiveData.PatternFormat

See Also

LineFillFormatEffectiveData Class | Aspose.Slides Namespace


RotateWithShape Property

Aspose.Slides Documentation

LineFillFormatEffectiveData.RotateWithShape Property

Determines whether the fill should be rotated with a shape. Read-only Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property RotateWithShape As Boolean _
Implements ILineFillFormatEffectiveData.RotateWithShape
[C#]
public bool RotateWithShape {get;}

Implements

ILineFillFormatEffectiveData.RotateWithShape

See Also

LineFillFormatEffectiveData Class | Aspose.Slides Namespace


SolidFillColor Property

Aspose.Slides Documentation

LineFillFormatEffectiveData.SolidFillColor Property

Returns the color of a solid fill. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property SolidFillColor As Color _
Implements ILineFillFormatEffectiveData.SolidFillColor
[C#]
public Color SolidFillColor {get;}

Implements

ILineFillFormatEffectiveData.SolidFillColor

See Also

LineFillFormatEffectiveData Class | Aspose.Slides Namespace


LineFillFormatEffectiveData Methods

The methods of the LineFillFormatEffectiveData class are listed below. For a complete list of LineFillFormatEffectiveData class members, see the LineFillFormatEffectiveData Members topic.

Public Instance Methods

Equals | Determines whether the two LineFillValueEx instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

LineFillFormatEffectiveData Class | Aspose.Slides Namespace


LineFillFormatEffectiveData.Equals Method

Determines whether the two LineFillValueEx instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The LineFillValueEx to compare with the current LineFillValueEx.

Return Value

true if the specified LineFillValueEx is equal to the current LineFillValueEx; otherwise, false.

See Also

LineFillFormatEffectiveData Class | Aspose.Slides Namespace


LineFillFormatEffectiveData.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

23453

Remarks

Overriden to make compiler happy. Always returns constant because object is mutable.

See Also

LineFillFormatEffectiveData Class | Aspose.Slides Namespace


LineFormat Class

Represents format of a line.

For a list of all members of this type, see LineFormat Members.

System.Object
Aspose.Slides.LineFormat

[Visual Basic]
Public Class LineFormat
Implements ILineFormat, ISlideComponent, IPresentationComponent
[C#]
public class LineFormat : ILineFormat, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LineFormat Members | Aspose.Slides Namespace


LineFormat Members

LineFormat overview

Public Instance Properties

Alignment | Returns or sets the line alignment. Read/write LineAlignment.
BeginArrowheadLength | Returns or sets the arrowhead length at the beginning of a line. Read/write LineArrowheadLength.
BeginArrowheadStyle | Returns or sets the arrowhead style at the beginning of a line. Read/write LineArrowheadStyle.
BeginArrowheadWidth | Returns or sets the arrowhead width at the beginning of a line. Read/write LineArrowheadWidth.
CapStyle | Returns or sets the line cap style. Read/write LineCapStyle.
CustomDashPattern | Returns or sets the custom dash pattern. Read/write Single[].
DashStyle | Returns or sets the line dash style. Read/write LineDashStyle.
EndArrowheadLength | Returns or sets the arrowhead length at the end of a line. Read/write LineArrowheadLength.
EndArrowheadStyle | Returns or sets the arrowhead style at the end of a line. Read/write LineArrowheadStyle.
EndArrowheadWidth | Returns or sets the arrowhead width at the end of a line. Read/write LineArrowheadWidth.
FillFormat | Returns the fill format of a line. Read-only LineFillFormat .
IsFormatNotDefined | Returns true if line format is not defined (as just created, default).
JoinStyle | Returns or sets the lines join style. Read/write LineJoinStyle.
MiterLimit | Returns or sets the miter limit of a line. Read/write Single.
Style | Returns or sets the line style. Read/write LineStyle.
Width | Returns or sets the width of a line. Read/write Double.

Public Instance Methods

Equals | Overloaded. Determines whether the two LineFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

LineFormat Class | Aspose.Slides Namespace


LineFormat Properties

The properties of the LineFormat class are listed below. For a complete list of LineFormat class members, see the LineFormat Members topic.

Public Instance Properties

Alignment | Returns or sets the line alignment. Read/write LineAlignment.
BeginArrowheadLength | Returns or sets the arrowhead length at the beginning of a line. Read/write LineArrowheadLength.
BeginArrowheadStyle | Returns or sets the arrowhead style at the beginning of a line. Read/write LineArrowheadStyle.
BeginArrowheadWidth | Returns or sets the arrowhead width at the beginning of a line. Read/write LineArrowheadWidth.
CapStyle | Returns or sets the line cap style. Read/write LineCapStyle.
CustomDashPattern | Returns or sets the custom dash pattern. Read/write Single[].
DashStyle | Returns or sets the line dash style. Read/write LineDashStyle.
EndArrowheadLength | Returns or sets the arrowhead length at the end of a line. Read/write LineArrowheadLength.
EndArrowheadStyle | Returns or sets the arrowhead style at the end of a line. Read/write LineArrowheadStyle.
EndArrowheadWidth | Returns or sets the arrowhead width at the end of a line. Read/write LineArrowheadWidth.
FillFormat | Returns the fill format of a line. Read-only LineFillFormat .
IsFormatNotDefined | Returns true if line format is not defined (as just created, default).
JoinStyle | Returns or sets the lines join style. Read/write LineJoinStyle.
MiterLimit | Returns or sets the miter limit of a line. Read/write Single.
Style | Returns or sets the line style. Read/write LineStyle.
Width | Returns or sets the width of a line. Read/write Double.

See Also

LineFormat Class | Aspose.Slides Namespace


Alignment Property

Aspose.Slides Documentation

LineFormat.Alignment Property

Returns or sets the line alignment. Read/write LineAlignment.

[Visual Basic]
NotOverridable Public Property Alignment As LineAlignment _
Implements ILineFormat.Alignment
[C#]
public LineAlignment Alignment {get; set;}

Implements

ILineFormat.Alignment

See Also

LineFormat Class | Aspose.Slides Namespace


BeginArrowheadLength Property

Aspose.Slides Documentation

LineFormat.BeginArrowheadLength Property

Returns or sets the arrowhead length at the beginning of a line. Read/write LineArrowheadLength.

[Visual Basic]
NotOverridable Public Property BeginArrowheadLength As LineArrowheadLength _
Implements ILineFormat.BeginArrowheadLength
[C#]
public LineArrowheadLength BeginArrowheadLength {get; set;}

Implements

ILineFormat.BeginArrowheadLength

See Also

LineFormat Class | Aspose.Slides Namespace


BeginArrowheadStyle Property

Aspose.Slides Documentation

LineFormat.BeginArrowheadStyle Property

Returns or sets the arrowhead style at the beginning of a line. Read/write LineArrowheadStyle.

[Visual Basic]
NotOverridable Public Property BeginArrowheadStyle As LineArrowheadStyle _
Implements ILineFormat.BeginArrowheadStyle
[C#]
public LineArrowheadStyle BeginArrowheadStyle {get; set;}

Implements

ILineFormat.BeginArrowheadStyle

See Also

LineFormat Class | Aspose.Slides Namespace


BeginArrowheadWidth Property

Aspose.Slides Documentation

LineFormat.BeginArrowheadWidth Property

Returns or sets the arrowhead width at the beginning of a line. Read/write LineArrowheadWidth.

[Visual Basic]
NotOverridable Public Property BeginArrowheadWidth As LineArrowheadWidth _
Implements ILineFormat.BeginArrowheadWidth
[C#]
public LineArrowheadWidth BeginArrowheadWidth {get; set;}

Implements

ILineFormat.BeginArrowheadWidth

See Also

LineFormat Class | Aspose.Slides Namespace


CapStyle Property

Aspose.Slides Documentation

LineFormat.CapStyle Property

Returns or sets the line cap style. Read/write LineCapStyle.

[Visual Basic]
NotOverridable Public Property CapStyle As LineCapStyle _
Implements ILineFormat.CapStyle
[C#]
public LineCapStyle CapStyle {get; set;}

Implements

ILineFormat.CapStyle

See Also

LineFormat Class | Aspose.Slides Namespace


CustomDashPattern Property

Aspose.Slides Documentation

LineFormat.CustomDashPattern Property

Returns or sets the custom dash pattern. Read/write Single[].

[Visual Basic]
NotOverridable Public Property CustomDashPattern As Single() _
Implements ILineFormat.CustomDashPattern
[C#]
public float[] CustomDashPattern {get; set;}

Implements

ILineFormat.CustomDashPattern

See Also

LineFormat Class | Aspose.Slides Namespace


DashStyle Property

Aspose.Slides Documentation

LineFormat.DashStyle Property

Returns or sets the line dash style. Read/write LineDashStyle.

[Visual Basic]
NotOverridable Public Property DashStyle As LineDashStyle _
Implements ILineFormat.DashStyle
[C#]
public LineDashStyle DashStyle {get; set;}

Implements

ILineFormat.DashStyle

See Also

LineFormat Class | Aspose.Slides Namespace


EndArrowheadLength Property

Aspose.Slides Documentation

LineFormat.EndArrowheadLength Property

Returns or sets the arrowhead length at the end of a line. Read/write LineArrowheadLength.

[Visual Basic]
NotOverridable Public Property EndArrowheadLength As LineArrowheadLength _
Implements ILineFormat.EndArrowheadLength
[C#]
public LineArrowheadLength EndArrowheadLength {get; set;}

Implements

ILineFormat.EndArrowheadLength

See Also

LineFormat Class | Aspose.Slides Namespace


EndArrowheadStyle Property

Aspose.Slides Documentation

LineFormat.EndArrowheadStyle Property

Returns or sets the arrowhead style at the end of a line. Read/write LineArrowheadStyle.

[Visual Basic]
NotOverridable Public Property EndArrowheadStyle As LineArrowheadStyle _
Implements ILineFormat.EndArrowheadStyle
[C#]
public LineArrowheadStyle EndArrowheadStyle {get; set;}

Implements

ILineFormat.EndArrowheadStyle

See Also

LineFormat Class | Aspose.Slides Namespace


EndArrowheadWidth Property

Aspose.Slides Documentation

LineFormat.EndArrowheadWidth Property

Returns or sets the arrowhead width at the end of a line. Read/write LineArrowheadWidth.

[Visual Basic]
NotOverridable Public Property EndArrowheadWidth As LineArrowheadWidth _
Implements ILineFormat.EndArrowheadWidth
[C#]
public LineArrowheadWidth EndArrowheadWidth {get; set;}

Implements

ILineFormat.EndArrowheadWidth

See Also

LineFormat Class | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

LineFormat.FillFormat Property

Returns the fill format of a line. Read-only LineFillFormat .

[Visual Basic]
NotOverridable Public ReadOnly Property FillFormat As ILineFillFormat _
Implements ILineFormat.FillFormat
[C#]
public ILineFillFormat FillFormat {get;}

Implements

ILineFormat.FillFormat

See Also

LineFormat Class | Aspose.Slides Namespace


IsFormatNotDefined Property

Aspose.Slides Documentation

LineFormat.IsFormatNotDefined Property

Returns true if line format is not defined (as just created, default).

[Visual Basic]
NotOverridable Public ReadOnly Property IsFormatNotDefined As Boolean _
Implements ILineFormat.IsFormatNotDefined
[C#]
public bool IsFormatNotDefined {get;}

Implements

ILineFormat.IsFormatNotDefined

See Also

LineFormat Class | Aspose.Slides Namespace


JoinStyle Property

Aspose.Slides Documentation

LineFormat.JoinStyle Property

Returns or sets the lines join style. Read/write LineJoinStyle.

[Visual Basic]
NotOverridable Public Property JoinStyle As LineJoinStyle _
Implements ILineFormat.JoinStyle
[C#]
public LineJoinStyle JoinStyle {get; set;}

Implements

ILineFormat.JoinStyle

See Also

LineFormat Class | Aspose.Slides Namespace


MiterLimit Property

Aspose.Slides Documentation

LineFormat.MiterLimit Property

Returns or sets the miter limit of a line. Read/write Single.

[Visual Basic]
NotOverridable Public Property MiterLimit As Single _
Implements ILineFormat.MiterLimit
[C#]
public float MiterLimit {get; set;}

Implements

ILineFormat.MiterLimit

See Also

LineFormat Class | Aspose.Slides Namespace


Style Property

Aspose.Slides Documentation

LineFormat.Style Property

Returns or sets the line style. Read/write LineStyle.

[Visual Basic]
NotOverridable Public Property Style As LineStyle _
Implements ILineFormat.Style
[C#]
public LineStyle Style {get; set;}

Implements

ILineFormat.Style

See Also

LineFormat Class | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

LineFormat.Width Property

Returns or sets the width of a line. Read/write Double.

[Visual Basic]
NotOverridable Public Property Width As Double _
Implements ILineFormat.Width
[C#]
public double Width {get; set;}

Implements

ILineFormat.Width

See Also

LineFormat Class | Aspose.Slides Namespace


LineFormat Methods

The methods of the LineFormat class are listed below. For a complete list of LineFormat class members, see the LineFormat Members topic.

Public Instance Methods

Equals | Overloaded. Determines whether the two LineFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

LineFormat Class | Aspose.Slides Namespace


Equals Method

Aspose.Slides Documentation

LineFormat.Equals Method

Determines whether the two LineFormat instances are equal.

Overload List

Determines whether the two LineFormat instances are equal.

public bool Equals(ILineFormat);

Determines whether the two LineFormat instances are equal.

public override bool Equals(object);

See Also

LineFormat Class | Aspose.Slides Namespace


LineFormat.Equals Method (ILineFormat)

Determines whether the two LineFormat instances are equal.

[Visual Basic]
NotOverridable Overloads Public Function Equals( _
ByVal lineFormat As ILineFormat _
) As Boolean _
Implements ILineFormat.Equals
[C#]
public bool Equals(
ILineFormat lineFormat
);

Parameters

lineFormat
The LineFormat to compare with the current LineFormat.

Return Value

true if the specified LineFormat is equal to the current LineFormat; otherwise, false.

Implements

ILineFormat.Equals

See Also

LineFormat Class | Aspose.Slides Namespace | LineFormat.Equals Overload List


LineFormat.Equals Method (Object)

Determines whether the two LineFormat instances are equal.

[Visual Basic]
Overrides Overloads Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The LineFormat to compare with the current LineFormat.

Return Value

true if the specified LineFormat is equal to the current LineFormat; otherwise, false.

See Also

LineFormat Class | Aspose.Slides Namespace | LineFormat.Equals Overload List


LineFormat.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

23456

Remarks

Overriden to make compiler happy. Always returns constant because object is mutable.

See Also

LineFormat Class | Aspose.Slides Namespace


LineFormatEffectiveData Class

Immutable object which contains line properties.

For a list of all members of this type, see LineFormatEffectiveData Members.

System.Object
Aspose.Slides.LineFormatEffectiveData

[Visual Basic]
Public Class LineFormatEffectiveData
Implements ILineFormatEffectiveData
[C#]
public class LineFormatEffectiveData : ILineFormatEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LineFormatEffectiveData Members | Aspose.Slides Namespace


LineFormatEffectiveData Members

LineFormatEffectiveData overview

Public Instance Properties

Alignment | Returns the line alignment. Read-only LineAlignment.
BeginArrowheadLength | Returns the arrowhead length at the beginning of a line. Read-only LineArrowheadLength.
BeginArrowheadStyle | Returns the arrowhead style at the beginning of a line. Read-only LineArrowheadStyle.
BeginArrowheadWidth | Returns the arrowhead width at the beginning of a line. Read-only LineArrowheadWidth.
CapStyle | Returns the line cap style. Read-only LineCapStyle.
CustomDashPattern | Returns the custom dash pattern. Read-only Single[].
DashStyle | Returns the line dash style. Read-only LineDashStyle.
EndArrowheadLength | Returns the arrowhead length at the end of a line. Read-only LineArrowheadLength.
EndArrowheadStyle | Returns the arrowhead style at the end of a line. Read-only LineArrowheadStyle.
EndArrowheadWidth | Returns the arrowhead width at the end of a line. Read-only LineArrowheadWidth.
FillFormat | Returns the fill format of a line. Read-only ILineFillFormatEffectiveData .
JoinStyle | Returns the lines join style. Read-only LineJoinStyle.
MiterLimit | Returns the miter limit of a line. Read-only Single.
Style | Returns the line style. Read-only LineStyle.
Width | Returns the width of a line. Read-only Double.

Public Instance Methods

Equals | Overloaded. Determines whether the two LineValueEx instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


LineFormatEffectiveData Properties

The properties of the LineFormatEffectiveData class are listed below. For a complete list of LineFormatEffectiveData class members, see the LineFormatEffectiveData Members topic.

Public Instance Properties

Alignment | Returns the line alignment. Read-only LineAlignment.
BeginArrowheadLength | Returns the arrowhead length at the beginning of a line. Read-only LineArrowheadLength.
BeginArrowheadStyle | Returns the arrowhead style at the beginning of a line. Read-only LineArrowheadStyle.
BeginArrowheadWidth | Returns the arrowhead width at the beginning of a line. Read-only LineArrowheadWidth.
CapStyle | Returns the line cap style. Read-only LineCapStyle.
CustomDashPattern | Returns the custom dash pattern. Read-only Single[].
DashStyle | Returns the line dash style. Read-only LineDashStyle.
EndArrowheadLength | Returns the arrowhead length at the end of a line. Read-only LineArrowheadLength.
EndArrowheadStyle | Returns the arrowhead style at the end of a line. Read-only LineArrowheadStyle.
EndArrowheadWidth | Returns the arrowhead width at the end of a line. Read-only LineArrowheadWidth.
FillFormat | Returns the fill format of a line. Read-only ILineFillFormatEffectiveData .
JoinStyle | Returns the lines join style. Read-only LineJoinStyle.
MiterLimit | Returns the miter limit of a line. Read-only Single.
Style | Returns the line style. Read-only LineStyle.
Width | Returns the width of a line. Read-only Double.

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


Alignment Property

Aspose.Slides Documentation

LineFormatEffectiveData.Alignment Property

Returns the line alignment. Read-only LineAlignment.

[Visual Basic]
NotOverridable Public ReadOnly Property Alignment As LineAlignment _
Implements ILineFormatEffectiveData.Alignment
[C#]
public LineAlignment Alignment {get;}

Implements

ILineFormatEffectiveData.Alignment

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


BeginArrowheadLength Property

Aspose.Slides Documentation

LineFormatEffectiveData.BeginArrowheadLength Property

Returns the arrowhead length at the beginning of a line. Read-only LineArrowheadLength.

[Visual Basic]
NotOverridable Public ReadOnly Property BeginArrowheadLength As LineArrowheadLength _
Implements ILineFormatEffectiveData.BeginArrowheadLength
[C#]
public LineArrowheadLength BeginArrowheadLength {get;}

Implements

ILineFormatEffectiveData.BeginArrowheadLength

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


BeginArrowheadStyle Property

Aspose.Slides Documentation

LineFormatEffectiveData.BeginArrowheadStyle Property

Returns the arrowhead style at the beginning of a line. Read-only LineArrowheadStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property BeginArrowheadStyle As LineArrowheadStyle _
Implements ILineFormatEffectiveData.BeginArrowheadStyle
[C#]
public LineArrowheadStyle BeginArrowheadStyle {get;}

Implements

ILineFormatEffectiveData.BeginArrowheadStyle

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


BeginArrowheadWidth Property

Aspose.Slides Documentation

LineFormatEffectiveData.BeginArrowheadWidth Property

Returns the arrowhead width at the beginning of a line. Read-only LineArrowheadWidth.

[Visual Basic]
NotOverridable Public ReadOnly Property BeginArrowheadWidth As LineArrowheadWidth _
Implements ILineFormatEffectiveData.BeginArrowheadWidth
[C#]
public LineArrowheadWidth BeginArrowheadWidth {get;}

Implements

ILineFormatEffectiveData.BeginArrowheadWidth

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


CapStyle Property

Aspose.Slides Documentation

LineFormatEffectiveData.CapStyle Property

Returns the line cap style. Read-only LineCapStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property CapStyle As LineCapStyle _
Implements ILineFormatEffectiveData.CapStyle
[C#]
public LineCapStyle CapStyle {get;}

Implements

ILineFormatEffectiveData.CapStyle

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


CustomDashPattern Property

Aspose.Slides Documentation

LineFormatEffectiveData.CustomDashPattern Property

Returns the custom dash pattern. Read-only Single[].

[Visual Basic]
NotOverridable Public ReadOnly Property CustomDashPattern As Single() _
Implements ILineFormatEffectiveData.CustomDashPattern
[C#]
public float[] CustomDashPattern {get;}

Implements

ILineFormatEffectiveData.CustomDashPattern

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


DashStyle Property

Aspose.Slides Documentation

LineFormatEffectiveData.DashStyle Property

Returns the line dash style. Read-only LineDashStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property DashStyle As LineDashStyle _
Implements ILineFormatEffectiveData.DashStyle
[C#]
public LineDashStyle DashStyle {get;}

Implements

ILineFormatEffectiveData.DashStyle

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


EndArrowheadLength Property

Aspose.Slides Documentation

LineFormatEffectiveData.EndArrowheadLength Property

Returns the arrowhead length at the end of a line. Read-only LineArrowheadLength.

[Visual Basic]
NotOverridable Public ReadOnly Property EndArrowheadLength As LineArrowheadLength _
Implements ILineFormatEffectiveData.EndArrowheadLength
[C#]
public LineArrowheadLength EndArrowheadLength {get;}

Implements

ILineFormatEffectiveData.EndArrowheadLength

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


EndArrowheadStyle Property

Aspose.Slides Documentation

LineFormatEffectiveData.EndArrowheadStyle Property

Returns the arrowhead style at the end of a line. Read-only LineArrowheadStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property EndArrowheadStyle As LineArrowheadStyle _
Implements ILineFormatEffectiveData.EndArrowheadStyle
[C#]
public LineArrowheadStyle EndArrowheadStyle {get;}

Implements

ILineFormatEffectiveData.EndArrowheadStyle

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


EndArrowheadWidth Property

Aspose.Slides Documentation

LineFormatEffectiveData.EndArrowheadWidth Property

Returns the arrowhead width at the end of a line. Read-only LineArrowheadWidth.

[Visual Basic]
NotOverridable Public ReadOnly Property EndArrowheadWidth As LineArrowheadWidth _
Implements ILineFormatEffectiveData.EndArrowheadWidth
[C#]
public LineArrowheadWidth EndArrowheadWidth {get;}

Implements

ILineFormatEffectiveData.EndArrowheadWidth

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

LineFormatEffectiveData.FillFormat Property

Returns the fill format of a line. Read-only ILineFillFormatEffectiveData .

[Visual Basic]
NotOverridable Public ReadOnly Property FillFormat As ILineFillFormatEffectiveData _
Implements ILineFormatEffectiveData.FillFormat
[C#]
public ILineFillFormatEffectiveData FillFormat {get;}

Implements

ILineFormatEffectiveData.FillFormat

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


JoinStyle Property

Aspose.Slides Documentation

LineFormatEffectiveData.JoinStyle Property

Returns the lines join style. Read-only LineJoinStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property JoinStyle As LineJoinStyle _
Implements ILineFormatEffectiveData.JoinStyle
[C#]
public LineJoinStyle JoinStyle {get;}

Implements

ILineFormatEffectiveData.JoinStyle

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


MiterLimit Property

Aspose.Slides Documentation

LineFormatEffectiveData.MiterLimit Property

Returns the miter limit of a line. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property MiterLimit As Single _
Implements ILineFormatEffectiveData.MiterLimit
[C#]
public float MiterLimit {get;}

Implements

ILineFormatEffectiveData.MiterLimit

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


Style Property

Aspose.Slides Documentation

LineFormatEffectiveData.Style Property

Returns the line style. Read-only LineStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property Style As LineStyle _
Implements ILineFormatEffectiveData.Style
[C#]
public LineStyle Style {get;}

Implements

ILineFormatEffectiveData.Style

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

LineFormatEffectiveData.Width Property

Returns the width of a line. Read-only Double.

[Visual Basic]
NotOverridable Public ReadOnly Property Width As Double _
Implements ILineFormatEffectiveData.Width
[C#]
public double Width {get;}

Implements

ILineFormatEffectiveData.Width

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


LineFormatEffectiveData Methods

The methods of the LineFormatEffectiveData class are listed below. For a complete list of LineFormatEffectiveData class members, see the LineFormatEffectiveData Members topic.

Public Instance Methods

Equals | Overloaded. Determines whether the two LineValueEx instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


Equals Method

Aspose.Slides Documentation

LineFormatEffectiveData.Equals Method

Determines whether the two LineValueEx instances are equal.

Overload List

Determines whether the two LineValueEx instances are equal.

public bool Equals(ILineFormatEffectiveData);

Determines whether the two LineValueEx instances are equal.

public override bool Equals(object);

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


LineFormatEffectiveData.Equals Method (ILineFormatEffectiveData)

Determines whether the two LineValueEx instances are equal.

[Visual Basic]
NotOverridable Overloads Public Function Equals( _
ByVal lf As ILineFormatEffectiveData _
) As Boolean _
Implements ILineFormatEffectiveData.Equals
[C#]
public bool Equals(
ILineFormatEffectiveData lf
);

Parameters

lf
The LineValueEx to compare with the current LineValueEx.

Return Value

true if the specified LineValueEx is equal to the current LineValueEx; otherwise, false.

Implements

ILineFormatEffectiveData.Equals

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace | LineFormatEffectiveData.Equals Overload List


LineFormatEffectiveData.Equals Method (Object)

Determines whether the two LineValueEx instances are equal.

[Visual Basic]
Overrides Overloads Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The LineValueEx to compare with the current LineValueEx.

Return Value

true if the specified LineValueEx is equal to the current LineValueEx; otherwise, false.

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace | LineFormatEffectiveData.Equals Overload List


LineFormatEffectiveData.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

23456

Remarks

Overriden to make compiler happy. Always returns constant because object is mutable.

See Also

LineFormatEffectiveData Class | Aspose.Slides Namespace


LineJoinStyle Enumeration

[Visual Basic]
Public Enum LineJoinStyle
Inherits
[C#]
public enum LineJoinStyle

Members

Member Name | Description | Value
NotDefined |  | -1
Round |  | 0
Bevel |  | 1
Miter |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


LineStyle Enumeration

[Visual Basic]
Public Enum LineStyle
Inherits
[C#]
public enum LineStyle

Members

Member Name | Description | Value
NotDefined |  | -1
Single |  | 0
ThinThin |  | 1
ThickThin |  | 2
ThinThick |  | 3
ThickBetweenThin |  | 4

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


LoadFormat Enumeration

[Visual Basic]
Public Enum LoadFormat
[C#]
public enum LoadFormat

Members

Member Name | Description | Value
Auto |  | 0
Ppt |  | 1
Pps |  | 2
Pptx |  | 3
Ppsx |  | 4
Odp |  | 5

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


LoadOptions Class

Allows to specify additional options (such as format or default font) when loading a presentation.

For a list of all members of this type, see LoadOptions Members.

System.Object
Aspose.Slides.LoadOptions

[Visual Basic]
Public Class LoadOptions
Implements ILoadOptions
[C#]
public class LoadOptions : ILoadOptions

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LoadOptions Members | Aspose.Slides Namespace


LoadOptions Members

LoadOptions overview

Public Instance Constructors

LoadOptions Overloaded. Initializes a new instance of the LoadOptions class.

Public Instance Properties

DefaultAsianFont | Returns or sets Asian font used in case source font is not found.
DefaultRegularFont | Returns or sets Regular font used in case source font is not found.
DefaultSymbolFont | Returns or sets Symbol font used in case source font is not found.
LoadFormat | Returns or sets format of a presentation to load. Read/write LoadFormat.
OnlyLoadDocumentProperties | This property makes sense, if presentation file is password protected. Value of true means that only document properties must be loaded from an encrypted presentation file and password must be ignored. Value of false means that entire encrypted presentation must be loaded with use of right password. If presentation isn't encrypted then property value is always ignored. If document properties of an encrypted file aren't public and property value is true then document properties cannot be loaded and exception will be thrown.
Password | Gets or sets the password.
WarningCallback | Returns or sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

LoadOptions Class | Aspose.Slides Namespace


LoadOptions Constructor

Creates new default load options.

Overload List

Creates new default load options.

public LoadOptions();

Creates new load options.

public LoadOptions(LoadFormat);

See Also

LoadOptions Class | Aspose.Slides Namespace


LoadOptions Constructor ()

Creates new default load options.

[Visual Basic]
Overloads Public Sub New()
[C#]
public LoadOptions();

See Also

LoadOptions Class | Aspose.Slides Namespace | LoadOptions Constructor Overload List


LoadOptions Constructor (LoadFormat)

Creates new load options.

[Visual Basic]
Overloads Public Sub New( _
ByVal loadFormat As LoadFormat _
)
[C#]
public LoadOptions(
LoadFormat loadFormat
);

Parameters

loadFormat
Format of a presentation to load.

See Also

LoadOptions Class | Aspose.Slides Namespace | LoadOptions Constructor Overload List


LoadOptions Properties

The properties of the LoadOptions class are listed below. For a complete list of LoadOptions class members, see the LoadOptions Members topic.

Public Instance Properties

DefaultAsianFont | Returns or sets Asian font used in case source font is not found.
DefaultRegularFont | Returns or sets Regular font used in case source font is not found.
DefaultSymbolFont | Returns or sets Symbol font used in case source font is not found.
LoadFormat | Returns or sets format of a presentation to load. Read/write LoadFormat.
OnlyLoadDocumentProperties | This property makes sense, if presentation file is password protected. Value of true means that only document properties must be loaded from an encrypted presentation file and password must be ignored. Value of false means that entire encrypted presentation must be loaded with use of right password. If presentation isn't encrypted then property value is always ignored. If document properties of an encrypted file aren't public and property value is true then document properties cannot be loaded and exception will be thrown.
Password | Gets or sets the password.
WarningCallback | Returns or sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

LoadOptions Class | Aspose.Slides Namespace


DefaultAsianFont Property

Aspose.Slides Documentation

LoadOptions.DefaultAsianFont Property

Returns or sets Asian font used in case source font is not found.

[Visual Basic]
NotOverridable Public Property DefaultAsianFont As String _
Implements ILoadOptions.DefaultAsianFont
[C#]
public string DefaultAsianFont {get; set;}

Implements

ILoadOptions.DefaultAsianFont

See Also

LoadOptions Class | Aspose.Slides Namespace


DefaultRegularFont Property

Aspose.Slides Documentation

LoadOptions.DefaultRegularFont Property

Returns or sets Regular font used in case source font is not found.

[Visual Basic]
NotOverridable Public Property DefaultRegularFont As String _
Implements ILoadOptions.DefaultRegularFont
[C#]
public string DefaultRegularFont {get; set;}

Implements

ILoadOptions.DefaultRegularFont

See Also

LoadOptions Class | Aspose.Slides Namespace


DefaultSymbolFont Property

Aspose.Slides Documentation

LoadOptions.DefaultSymbolFont Property

Returns or sets Symbol font used in case source font is not found.

[Visual Basic]
NotOverridable Public Property DefaultSymbolFont As String _
Implements ILoadOptions.DefaultSymbolFont
[C#]
public string DefaultSymbolFont {get; set;}

Implements

ILoadOptions.DefaultSymbolFont

See Also

LoadOptions Class | Aspose.Slides Namespace


LoadFormat Property

Aspose.Slides Documentation

LoadOptions.LoadFormat Property

Returns or sets format of a presentation to load. Read/write LoadFormat.

[Visual Basic]
NotOverridable Public Property LoadFormat As LoadFormat _
Implements ILoadOptions.LoadFormat
[C#]
public LoadFormat LoadFormat {get; set;}

Implements

ILoadOptions.LoadFormat

See Also

LoadOptions Class | Aspose.Slides Namespace


OnlyLoadDocumentProperties Property

Aspose.Slides Documentation

LoadOptions.OnlyLoadDocumentProperties Property

This property makes sense, if presentation file is password protected. Value of true means that only document properties must be loaded from an encrypted presentation file and password must be ignored. Value of false means that entire encrypted presentation must be loaded with use of right password. If presentation isn't encrypted then property value is always ignored. If document properties of an encrypted file aren't public and property value is true then document properties cannot be loaded and exception will be thrown.

[Visual Basic]
NotOverridable Public Property OnlyLoadDocumentProperties As Boolean _
Implements ILoadOptions.OnlyLoadDocumentProperties
[C#]
public bool OnlyLoadDocumentProperties {get; set;}

Implements

ILoadOptions.OnlyLoadDocumentProperties

See Also

LoadOptions Class | Aspose.Slides Namespace


Password Property

Aspose.Slides Documentation

LoadOptions.Password Property

Gets or sets the password.

[Visual Basic]
NotOverridable Public Property Password As String _
Implements ILoadOptions.Password
[C#]
public string Password {get; set;}

Property Value

The password.

Implements

ILoadOptions.Password

See Also

LoadOptions Class | Aspose.Slides Namespace


WarningCallback Property

Aspose.Slides Documentation

LoadOptions.WarningCallback Property

Returns or sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

[Visual Basic]
NotOverridable Public Property WarningCallback As IWarningCallback _
Implements ILoadOptions.WarningCallback
[C#]
public IWarningCallback WarningCallback {get; set;}

Implements

ILoadOptions.WarningCallback

See Also

LoadOptions Class | Aspose.Slides Namespace


MasterHandoutSlide Class

Represents master slide for handouts.

For a list of all members of this type, see MasterHandoutSlide Members.

System.Object
Aspose.Slides.BaseSlide
Aspose.Slides.MasterHandoutSlide

[Visual Basic]
Public Class MasterHandoutSlide
Inherits BaseSlide
Implements IMasterHandoutSlide, IMasterThemeable
[C#]
public class MasterHandoutSlide : BaseSlide, IMasterHandoutSlide, IMasterThemeable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

MasterHandoutSlide Members | Aspose.Slides Namespace


MasterHandoutSlide Members

MasterHandoutSlide overview

Public Instance Properties

Background (inherited from BaseSlide) | Returns slide's background. Read only Background.
Controls (inherited from BaseSlide) | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData (inherited from BaseSlide) | Returns the slide's custom data. Read-only ICustomData.
HyperlinkQueries (inherited from BaseSlide) | Provides easy access to contained hyperlinks.
Name (inherited from BaseSlide) | Returns or sets the name of a slide. Read/write String.
ParentPresentation (inherited from BaseSlide) | Obsolete. Returns the parent presentation. Read-only Presentation.
Presentation (inherited from BaseSlide) |
Shapes (inherited from BaseSlide) | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId (inherited from BaseSlide) | Returns the ID of a slide.
SlideShowTransition (inherited from BaseSlide) | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags (inherited from BaseSlide) | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
ThemeManager |
Timeline (inherited from BaseSlide) | Returns animation timeline object. Read-only AnimationTimeLine.

Public Instance Methods

ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseSlide) | Returns an effective theme for this slide.
FindShapeByAltText (inherited from BaseSlide) | Finds first occurrence of a shape with the specified alternative text.

See Also

MasterHandoutSlide Class | Aspose.Slides Namespace


MasterHandoutSlide Properties

The properties of the MasterHandoutSlide class are listed below. For a complete list of MasterHandoutSlide class members, see the MasterHandoutSlide Members topic.

Public Instance Properties

Background (inherited from BaseSlide) | Returns slide's background. Read only Background.
Controls (inherited from BaseSlide) | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData (inherited from BaseSlide) | Returns the slide's custom data. Read-only ICustomData.
HyperlinkQueries (inherited from BaseSlide) | Provides easy access to contained hyperlinks.
Name (inherited from BaseSlide) | Returns or sets the name of a slide. Read/write String.
ParentPresentation (inherited from BaseSlide) | Obsolete. Returns the parent presentation. Read-only Presentation.
Presentation (inherited from BaseSlide) |
Shapes (inherited from BaseSlide) | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId (inherited from BaseSlide) | Returns the ID of a slide.
SlideShowTransition (inherited from BaseSlide) | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags (inherited from BaseSlide) | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
ThemeManager |
Timeline (inherited from BaseSlide) | Returns animation timeline object. Read-only AnimationTimeLine.

See Also

MasterHandoutSlide Class | Aspose.Slides Namespace


ThemeManager Property

Aspose.Slides Documentation

MasterHandoutSlide.ThemeManager Property

[Visual Basic]
NotOverridable Public ReadOnly Property ThemeManager As IMasterThemeManager _
Implements IMasterThemeable.ThemeManager
[C#]
public IMasterThemeManager ThemeManager {get;}

Implements

IMasterThemeable.ThemeManager

See Also

MasterHandoutSlide Class | Aspose.Slides Namespace


MasterHandoutSlide Methods

The methods of the MasterHandoutSlide class are listed below. For a complete list of MasterHandoutSlide class members, see the MasterHandoutSlide Members topic.

Public Instance Methods

ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseSlide) | Returns an effective theme for this slide.
FindShapeByAltText (inherited from BaseSlide) | Finds first occurrence of a shape with the specified alternative text.

See Also

MasterHandoutSlide Class | Aspose.Slides Namespace


MasterHandoutSlide.ApplyColorScheme Method

NOTE: This method is now obsolete.

Use ThemeManager.ApplyColorScheme(..) method instead. Will be removed after 01.09.2013.

Applies extra color scheme to a slide.

[Visual Basic]
Overrides Public Sub ApplyColorScheme( _
ByVal scheme As ExtraColorScheme _
)
[C#]
public override void ApplyColorScheme(
ExtraColorScheme scheme
);

Parameters

scheme

See Also

MasterHandoutSlide Class | Aspose.Slides Namespace


MasterLayoutSlideCollection Class

Represents a collections of all layout slides of defined master slide. Extends LayoutSlideCollection class with methods for adding/inserting/removing/cloning/reordering layout slides in context of the individual collections of master's layout slides.

For a list of all members of this type, see MasterLayoutSlideCollection Members.

System.Object
Aspose.Slides.LayoutSlideCollection
Aspose.Slides.MasterLayoutSlideCollection

[Visual Basic]
NotInheritable Public Class MasterLayoutSlideCollection
Inherits LayoutSlideCollection
Implements IMasterLayoutSlideCollection
[C#]
public sealed class MasterLayoutSlideCollection : LayoutSlideCollection, IMasterLayoutSlideCollection

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

MasterLayoutSlideCollection Members | Aspose.Slides Namespace


MasterLayoutSlideCollection Members

MasterLayoutSlideCollection overview

Public Instance Properties

Count (inherited from LayoutSlideCollection) | Returns the number of layout slides in a collection. Read-only Int32.
IsSynchronized (inherited from LayoutSlideCollection) | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item (inherited from LayoutSlideCollection) | Returns the layout slide by index. Read-only LayoutSlide.
SyncRoot (inherited from LayoutSlideCollection) | Returns a synchronization root. Readonly Object.

Public Instance Methods

Add | Adds a new layout slide to the end of the collection.
AddClone | Adds a copy of a specified layout slide to the end of the collection.
CopyTo (inherited from LayoutSlideCollection) | Copies all elements from the collection to the specified array.
GetByType (inherited from LayoutSlideCollection) | Returns the first layout slide of specified type. A type of layout slide to find.LayoutSlide with specified type or null if no layouts found.
GetEnumerator (inherited from LayoutSlideCollection) | Returns an enumerator for the entire collection.
Insert | Inserts a new layout slide to specified position of the collection.
InsertClone | Inserts a copy of a specified layout slide to specified position of the collection.
Remove (inherited from LayoutSlideCollection) | Removes a layout from the collection.
RemoveAt | Removes the element at the specified index of the collection.
RemoveUnused (inherited from LayoutSlideCollection) | Removes unused layout slides (layout slides whose HasDependingSlides is false).
Reorder | Moves layout slide from the collection to the specified position.

See Also

MasterLayoutSlideCollection Class | Aspose.Slides Namespace


MasterLayoutSlideCollection Methods

The methods of the MasterLayoutSlideCollection class are listed below. For a complete list of MasterLayoutSlideCollection class members, see the MasterLayoutSlideCollection Members topic.

Public Instance Methods

Add | Adds a new layout slide to the end of the collection.
AddClone | Adds a copy of a specified layout slide to the end of the collection.
CopyTo (inherited from LayoutSlideCollection) | Copies all elements from the collection to the specified array.
GetByType (inherited from LayoutSlideCollection) | Returns the first layout slide of specified type. A type of layout slide to find.LayoutSlide with specified type or null if no layouts found.
GetEnumerator (inherited from LayoutSlideCollection) | Returns an enumerator for the entire collection.
Insert | Inserts a new layout slide to specified position of the collection.
InsertClone | Inserts a copy of a specified layout slide to specified position of the collection.
Remove (inherited from LayoutSlideCollection) | Removes a layout from the collection.
RemoveAt | Removes the element at the specified index of the collection.
RemoveUnused (inherited from LayoutSlideCollection) | Removes unused layout slides (layout slides whose HasDependingSlides is false).
Reorder | Moves layout slide from the collection to the specified position.

See Also

MasterLayoutSlideCollection Class | Aspose.Slides Namespace


MasterLayoutSlideCollection.Add Method

Adds a new layout slide to the end of the collection.

[Visual Basic]
NotOverridable Public Function Add( _
ByVal layoutType As SlideLayoutType, _
ByVal layoutName As String _
) As ILayoutSlide _
Implements IMasterLayoutSlideCollection.Add
[C#]
public ILayoutSlide Add(
SlideLayoutType layoutType,
string layoutName
);

Parameters

layoutType
Layout type for a new layout. Supported layout types: Title, TitleOnly, Blank, TitleAndObject, VerticalText, VerticalTitleAndText, TwoObjects, SectionHeader, TwoTextAndTwoObjects, TitleObjectAndCaption, PictureAndCaption, Custom. Other layout types are not supported now: Text, TwoColumnText, Table, TextAndChart, ChartAndText, Diagram, Chart, TextAndClipArt, ClipArtAndText, TextAndObject, ObjectAndText, Object, TextAndMedia, MediaAndText, ObjectOverText, TextOverObject, TextAndTwoObjects, TwoObjectsAndText, TwoObjectsOverText, FourObjects, ClipArtAndVerticalText, VerticalTitleAndTextOverChart, ObjectAndTwoObject, TwoObjectsAndObject.
layoutName
Name for a new layout. If passed name is already in use the ArgumentException will be thrown. If null parameter is passed then name genarated atomatically in regards to passed layout type (for example "Title Slide" or "1_Title Slide", "2_..", etc.).

Return Value

Added slide.

Implements

IMasterLayoutSlideCollection.Add

Remarks

1) Added layout for value SlideLayoutType.Custom of layoutType contains no placeholders and no shapes. 2) Analogue of this method is method Add accessed with LayoutSlides property.

Exceptions

Exception Type | Condition
NotImplementedException | Thrown if unsupported value of parameter layoutType is passed. Layout types that are not supported now: Text, TwoColumnText, Table, TextAndChart, ChartAndText, Diagram, Chart, TextAndClipArt, ClipArtAndText, TextAndObject, ObjectAndText, Object, TextAndMedia, MediaAndText, ObjectOverText, TextOverObject, TextAndTwoObjects, TwoObjectsAndText, TwoObjectsOverText, FourObjects, ClipArtAndVerticalText, VerticalTitleAndTextOverChart, ObjectAndTwoObject, TwoObjectsAndObject.
ArgumentException | Thrown if layout name value layoutName is already in use in this collection of the layouts.

See Also

MasterLayoutSlideCollection Class | Aspose.Slides Namespace


MasterLayoutSlideCollection.AddClone Method

Adds a copy of a specified layout slide to the end of the collection.

[Visual Basic]
NotOverridable Public Function AddClone( _
ByVal sourceLayout As ILayoutSlide _
) As ILayoutSlide _
Implements IMasterLayoutSlideCollection.AddClone
[C#]
public ILayoutSlide AddClone(
ILayoutSlide sourceLayout
);

Parameters

sourceLayout
Slide to clone.

Return Value

Added slide.

Implements

IMasterLayoutSlideCollection.AddClone

Remarks

1) New layout will be linked with parent master slide for this layout slides collection. So this is analogue of copy/paste with "Use Destination Theme" option in PowerPoint. 2) Analogue of this method is method AddClone accessed with LayoutSlides property.

See Also

MasterLayoutSlideCollection Class | Aspose.Slides Namespace


MasterLayoutSlideCollection.Insert Method

Inserts a new layout slide to specified position of the collection.

[Visual Basic]
NotOverridable Public Function Insert( _
ByVal index As Integer, _
ByVal layoutType As SlideLayoutType, _
ByVal layoutName As String _
) As ILayoutSlide _
Implements IMasterLayoutSlideCollection.Insert
[C#]
public ILayoutSlide Insert(
int index,
SlideLayoutType layoutType,
string layoutName
);

Parameters

index
Index of new slide.
layoutType
Layout type for a new layout. Supported layout types: Title, TitleOnly, Blank, TitleAndObject, VerticalText, VerticalTitleAndText, TwoObjects, SectionHeader, TwoTextAndTwoObjects, TitleObjectAndCaption, PictureAndCaption, Custom. Other layout types are not supported now: Text, TwoColumnText, Table, TextAndChart, ChartAndText, Diagram, Chart, TextAndClipArt, ClipArtAndText, TextAndObject, ObjectAndText, Object, TextAndMedia, MediaAndText, ObjectOverText, TextOverObject, TextAndTwoObjects, TwoObjectsAndText, TwoObjectsOverText, FourObjects, ClipArtAndVerticalText, VerticalTitleAndTextOverChart, ObjectAndTwoObject, TwoObjectsAndObject.
layoutName
Name for a new layout. If passed name is already in use the ArgumentException will be thrown. If null parameter is passed then name genarated atomatically in regards to passed layout type (for example "Title Slide" or "1_Title Slide", "2_..", etc.).

Return Value

Inserted slide.

Implements

IMasterLayoutSlideCollection.Insert

Remarks

Inserted layout for value SlideLayoutType.Custom of layoutType contains no placeholders and no shapes.

Exceptions

Exception Type | Condition
NotImplementedException | Thrown if unsupported value of parameter layoutType is passed. Layout types that are not supported now: Text, TwoColumnText, Table, TextAndChart, ChartAndText, Diagram, Chart, TextAndClipArt, ClipArtAndText, TextAndObject, ObjectAndText, Object, TextAndMedia, MediaAndText, ObjectOverText, TextOverObject, TextAndTwoObjects, TwoObjectsAndText, TwoObjectsOverText, FourObjects, ClipArtAndVerticalText, VerticalTitleAndTextOverChart, ObjectAndTwoObject, TwoObjectsAndObject.
ArgumentException | Thrown if layout name value layoutName is already in use in this collection of the layouts.

See Also

MasterLayoutSlideCollection Class | Aspose.Slides Namespace


MasterLayoutSlideCollection.InsertClone Method

Inserts a copy of a specified layout slide to specified position of the collection.

[Visual Basic]
NotOverridable Public Function InsertClone( _
ByVal index As Integer, _
ByVal sourceLayout As ILayoutSlide _
) As ILayoutSlide _
Implements IMasterLayoutSlideCollection.InsertClone
[C#]
public ILayoutSlide InsertClone(
int index,
ILayoutSlide sourceLayout
);

Parameters

index
Index of new slide.
sourceLayout
Slide to clone.

Return Value

Inserted slide.

Implements

IMasterLayoutSlideCollection.InsertClone

Remarks

New layout will be linked with parent master slide for this layout slides collection. So this is analogue of copy/paste with "Use Destination Theme" option in PowerPoint.

See Also

MasterLayoutSlideCollection Class | Aspose.Slides Namespace


MasterLayoutSlideCollection.RemoveAt Method

Removes the element at the specified index of the collection.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IMasterLayoutSlideCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Implements

IMasterLayoutSlideCollection.RemoveAt

Remarks

1) To avoid throwing of the PptxEditException check layout's HasDependingSlides property before. 2) You can use also Remove method to simplify code.

Exceptions

Exception Type | Condition
PptxEditException | Thrown if layout is used in presentation (its HasDependingSlides property is true).

See Also

MasterLayoutSlideCollection Class | Aspose.Slides Namespace


MasterLayoutSlideCollection.Reorder Method

Moves layout slide from the collection to the specified position.

[Visual Basic]
NotOverridable Public Sub Reorder( _
ByVal index As Integer, _
ByVal layoutSlide As ILayoutSlide _
) _
Implements IMasterLayoutSlideCollection.Reorder
[C#]
public void Reorder(
int index,
ILayoutSlide layoutSlide
);

Parameters

index
Target index.
layoutSlide
Slide to move.

Implements

IMasterLayoutSlideCollection.Reorder

See Also

MasterLayoutSlideCollection Class | Aspose.Slides Namespace


MasterNotesSlide Class

Represents master slide for notes.

For a list of all members of this type, see MasterNotesSlide Members.

System.Object
Aspose.Slides.BaseSlide
Aspose.Slides.MasterNotesSlide

[Visual Basic]
Public Class MasterNotesSlide
Inherits BaseSlide
Implements IMasterNotesSlide, IMasterThemeable
[C#]
public class MasterNotesSlide : BaseSlide, IMasterNotesSlide, IMasterThemeable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

MasterNotesSlide Members | Aspose.Slides Namespace


MasterNotesSlide Members

MasterNotesSlide overview

Public Instance Properties

Background (inherited from BaseSlide) | Returns slide's background. Read only Background.
Controls (inherited from BaseSlide) | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData (inherited from BaseSlide) | Returns the slide's custom data. Read-only ICustomData.
HyperlinkQueries (inherited from BaseSlide) | Provides easy access to contained hyperlinks.
Name (inherited from BaseSlide) | Returns or sets the name of a slide. Read/write String.
ParentPresentation (inherited from BaseSlide) | Obsolete. Returns the parent presentation. Read-only Presentation.
Presentation (inherited from BaseSlide) |
Shapes (inherited from BaseSlide) | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId (inherited from BaseSlide) | Returns the ID of a slide.
SlideShowTransition (inherited from BaseSlide) | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags (inherited from BaseSlide) | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
ThemeManager |
Timeline (inherited from BaseSlide) | Returns animation timeline object. Read-only AnimationTimeLine.

Public Instance Methods

ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseSlide) | Returns an effective theme for this slide.
FindShapeByAltText (inherited from BaseSlide) | Finds first occurrence of a shape with the specified alternative text.

See Also

MasterNotesSlide Class | Aspose.Slides Namespace


MasterNotesSlide Properties

The properties of the MasterNotesSlide class are listed below. For a complete list of MasterNotesSlide class members, see the MasterNotesSlide Members topic.

Public Instance Properties

Background (inherited from BaseSlide) | Returns slide's background. Read only Background.
Controls (inherited from BaseSlide) | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData (inherited from BaseSlide) | Returns the slide's custom data. Read-only ICustomData.
HyperlinkQueries (inherited from BaseSlide) | Provides easy access to contained hyperlinks.
Name (inherited from BaseSlide) | Returns or sets the name of a slide. Read/write String.
ParentPresentation (inherited from BaseSlide) | Obsolete. Returns the parent presentation. Read-only Presentation.
Presentation (inherited from BaseSlide) |
Shapes (inherited from BaseSlide) | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId (inherited from BaseSlide) | Returns the ID of a slide.
SlideShowTransition (inherited from BaseSlide) | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags (inherited from BaseSlide) | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
ThemeManager |
Timeline (inherited from BaseSlide) | Returns animation timeline object. Read-only AnimationTimeLine.

See Also

MasterNotesSlide Class | Aspose.Slides Namespace


ThemeManager Property

Aspose.Slides Documentation

MasterNotesSlide.ThemeManager Property

[Visual Basic]
NotOverridable Public ReadOnly Property ThemeManager As IMasterThemeManager _
Implements IMasterThemeable.ThemeManager
[C#]
public IMasterThemeManager ThemeManager {get;}

Implements

IMasterThemeable.ThemeManager

See Also

MasterNotesSlide Class | Aspose.Slides Namespace


MasterNotesSlide Methods

The methods of the MasterNotesSlide class are listed below. For a complete list of MasterNotesSlide class members, see the MasterNotesSlide Members topic.

Public Instance Methods

ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseSlide) | Returns an effective theme for this slide.
FindShapeByAltText (inherited from BaseSlide) | Finds first occurrence of a shape with the specified alternative text.

See Also

MasterNotesSlide Class | Aspose.Slides Namespace


MasterNotesSlide.ApplyColorScheme Method

NOTE: This method is now obsolete.

Use ThemeManager.ApplyColorScheme(..) method instead. Will be removed after 01.09.2013.

Applies extra color scheme to a slide.

[Visual Basic]
Overrides Public Sub ApplyColorScheme( _
ByVal scheme As ExtraColorScheme _
)
[C#]
public override void ApplyColorScheme(
ExtraColorScheme scheme
);

Parameters

scheme

See Also

MasterNotesSlide Class | Aspose.Slides Namespace


MasterSlide Class

Represents a master slide in a presentation.

For a list of all members of this type, see MasterSlide Members.

System.Object
Aspose.Slides.BaseSlide
Aspose.Slides.MasterSlide

[Visual Basic]
Public Class MasterSlide
Inherits BaseSlide
Implements IMasterSlide, IMasterThemeable
[C#]
public class MasterSlide : BaseSlide, IMasterSlide, IMasterThemeable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

MasterSlide Members | Aspose.Slides Namespace


MasterSlide Members

MasterSlide overview

Public Instance Properties

Background (inherited from BaseSlide) | Returns slide's background. Read only Background.
BodyStyle | Returns the style of a body text. Read-only TextStyle.
Controls (inherited from BaseSlide) | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData (inherited from BaseSlide) | Returns the slide's custom data. Read-only ICustomData.
HasDependingSlides | Returns true if there exists at least one slide that depends on this master slide.
HyperlinkQueries (inherited from BaseSlide) | Provides easy access to contained hyperlinks.
LayoutSlides | Returns the collection of child layout slides for this master slide. Read-only ILayoutSlideCollection.
Name (inherited from BaseSlide) | Returns or sets the name of a slide. Read/write String.
OtherStyle | Returns the style of an other text. Read-only TextStyle.
ParentPresentation (inherited from BaseSlide) | Obsolete. Returns the parent presentation. Read-only Presentation.
Presentation (inherited from BaseSlide) |
Preserve | Determines whether the corresponding master is deleted when all the slides that follow that master are deleted. Note: Aspose.Slides will never remove any unused master by itself, to actually remove unused masters call RemoveUnused
Shapes (inherited from BaseSlide) | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId (inherited from BaseSlide) | Returns the ID of a slide.
SlideShowTransition (inherited from BaseSlide) | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags (inherited from BaseSlide) | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
ThemeManager |
Timeline (inherited from BaseSlide) | Returns animation timeline object. Read-only AnimationTimeLine.
TitleStyle | Returns the style of a title text. Read-only TextStyle.

Public Instance Methods

ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseSlide) | Returns an effective theme for this slide.
FindShapeByAltText (inherited from BaseSlide) | Finds first occurrence of a shape with the specified alternative text.
GetDependingSlides | Returns an array with all slides, which depend on this master slide.

See Also

MasterSlide Class | Aspose.Slides Namespace


MasterSlide Properties

The properties of the MasterSlide class are listed below. For a complete list of MasterSlide class members, see the MasterSlide Members topic.

Public Instance Properties

Background (inherited from BaseSlide) | Returns slide's background. Read only Background.
BodyStyle | Returns the style of a body text. Read-only TextStyle.
Controls (inherited from BaseSlide) | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData (inherited from BaseSlide) | Returns the slide's custom data. Read-only ICustomData.
HasDependingSlides | Returns true if there exists at least one slide that depends on this master slide.
HyperlinkQueries (inherited from BaseSlide) | Provides easy access to contained hyperlinks.
LayoutSlides | Returns the collection of child layout slides for this master slide. Read-only ILayoutSlideCollection.
Name (inherited from BaseSlide) | Returns or sets the name of a slide. Read/write String.
OtherStyle | Returns the style of an other text. Read-only TextStyle.
ParentPresentation (inherited from BaseSlide) | Obsolete. Returns the parent presentation. Read-only Presentation.
Presentation (inherited from BaseSlide) |
Preserve | Determines whether the corresponding master is deleted when all the slides that follow that master are deleted. Note: Aspose.Slides will never remove any unused master by itself, to actually remove unused masters call RemoveUnused
Shapes (inherited from BaseSlide) | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId (inherited from BaseSlide) | Returns the ID of a slide.
SlideShowTransition (inherited from BaseSlide) | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags (inherited from BaseSlide) | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
ThemeManager |
Timeline (inherited from BaseSlide) | Returns animation timeline object. Read-only AnimationTimeLine.
TitleStyle | Returns the style of a title text. Read-only TextStyle.

See Also

MasterSlide Class | Aspose.Slides Namespace


BodyStyle Property

Aspose.Slides Documentation

MasterSlide.BodyStyle Property

Returns the style of a body text. Read-only TextStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property BodyStyle As ITextStyle _
Implements IMasterSlide.BodyStyle
[C#]
public ITextStyle BodyStyle {get;}

Implements

IMasterSlide.BodyStyle

See Also

MasterSlide Class | Aspose.Slides Namespace


HasDependingSlides Property

Aspose.Slides Documentation

MasterSlide.HasDependingSlides Property

Returns true if there exists at least one slide that depends on this master slide.

[Visual Basic]
NotOverridable Public ReadOnly Property HasDependingSlides As Boolean _
Implements IMasterSlide.HasDependingSlides
[C#]
public bool HasDependingSlides {get;}

Implements

IMasterSlide.HasDependingSlides

See Also

MasterSlide Class | Aspose.Slides Namespace


LayoutSlides Property

Aspose.Slides Documentation

MasterSlide.LayoutSlides Property

Returns the collection of child layout slides for this master slide. Read-only ILayoutSlideCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property LayoutSlides As IMasterLayoutSlideCollection _
Implements IMasterSlide.LayoutSlides
[C#]
public IMasterLayoutSlideCollection LayoutSlides {get;}

Implements

IMasterSlide.LayoutSlides

Remarks

You can access to alternative API for adding/inserting/removing/cloning layout slides by using LayoutSlides property.

See Also

MasterSlide Class | Aspose.Slides Namespace


OtherStyle Property

Aspose.Slides Documentation

MasterSlide.OtherStyle Property

Returns the style of an other text. Read-only TextStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property OtherStyle As ITextStyle _
Implements IMasterSlide.OtherStyle
[C#]
public ITextStyle OtherStyle {get;}

Implements

IMasterSlide.OtherStyle

See Also

MasterSlide Class | Aspose.Slides Namespace


Preserve Property

Aspose.Slides Documentation

MasterSlide.Preserve Property

Determines whether the corresponding master is deleted when all the slides that follow that master are deleted. Note: Aspose.Slides will never remove any unused master by itself, to actually remove unused masters call RemoveUnused

[Visual Basic]
NotOverridable Public Property Preserve As Boolean _
Implements IMasterSlide.Preserve
[C#]
public bool Preserve {get; set;}

Implements

IMasterSlide.Preserve

See Also

MasterSlide Class | Aspose.Slides Namespace


ThemeManager Property

Aspose.Slides Documentation

MasterSlide.ThemeManager Property

[Visual Basic]
NotOverridable Public ReadOnly Property ThemeManager As IMasterThemeManager _
Implements IMasterThemeable.ThemeManager
[C#]
public IMasterThemeManager ThemeManager {get;}

Implements

IMasterThemeable.ThemeManager

See Also

MasterSlide Class | Aspose.Slides Namespace


TitleStyle Property

Aspose.Slides Documentation

MasterSlide.TitleStyle Property

Returns the style of a title text. Read-only TextStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property TitleStyle As ITextStyle _
Implements IMasterSlide.TitleStyle
[C#]
public ITextStyle TitleStyle {get;}

Implements

IMasterSlide.TitleStyle

See Also

MasterSlide Class | Aspose.Slides Namespace


MasterSlide Methods

The methods of the MasterSlide class are listed below. For a complete list of MasterSlide class members, see the MasterSlide Members topic.

Public Instance Methods

ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseSlide) | Returns an effective theme for this slide.
FindShapeByAltText (inherited from BaseSlide) | Finds first occurrence of a shape with the specified alternative text.
GetDependingSlides | Returns an array with all slides, which depend on this master slide.

See Also

MasterSlide Class | Aspose.Slides Namespace


MasterSlide.ApplyColorScheme Method

NOTE: This method is now obsolete.

Use ThemeManager.ApplyColorScheme(..) method instead. Will be removed after 01.09.2013.

Applies extra color scheme to a slide.

[Visual Basic]
Overrides Public Sub ApplyColorScheme( _
ByVal scheme As ExtraColorScheme _
)
[C#]
public override void ApplyColorScheme(
ExtraColorScheme scheme
);

Parameters

scheme

See Also

MasterSlide Class | Aspose.Slides Namespace


MasterSlide.GetDependingSlides Method

Returns an array with all slides, which depend on this master slide.

[Visual Basic]
NotOverridable Public Function GetDependingSlides() As ISlide() _
Implements IMasterSlide.GetDependingSlides
[C#]
public ISlide[] GetDependingSlides();

Return Value

Implements

IMasterSlide.GetDependingSlides

See Also

MasterSlide Class | Aspose.Slides Namespace


MasterSlideCollection Class

Represents a collection of master slides.

For a list of all members of this type, see MasterSlideCollection Members.

System.Object
Aspose.Slides.MasterSlideCollection

[Visual Basic]
NotInheritable Public Class MasterSlideCollection
Implements IMasterSlideCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IMasterSlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public sealed class MasterSlideCollection : IMasterSlideCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

MasterSlideCollection Members | Aspose.Slides Namespace


MasterSlideCollection Members

MasterSlideCollection overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only MasterSlide.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

AddClone | Adds a copy of a specified master slide to the end of the collection. Linked layout slides will be copied too.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
InsertClone | Inserts a copy of a specified master slide to specified position of the collection. Linked layout slides will be copied too.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.
RemoveUnused | Removes unused master slides.

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


MasterSlideCollection Properties

The properties of the MasterSlideCollection class are listed below. For a complete list of MasterSlideCollection class members, see the MasterSlideCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only MasterSlide.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

MasterSlideCollection.Count Property

Gets the number of elements actually contained in the collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

MasterSlideCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

MasterSlideCollection.Item Property

Gets the element at the specified index. Read-only MasterSlide.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IMasterSlideCollection.Item
As IMasterSlide _
Implements IMasterSlideCollection.Item
[C#]
public IMasterSlide this[
int index
] {get;}

Implements

IMasterSlideCollection.Item

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

MasterSlideCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


MasterSlideCollection Methods

The methods of the MasterSlideCollection class are listed below. For a complete list of MasterSlideCollection class members, see the MasterSlideCollection Members topic.

Public Instance Methods

AddClone | Adds a copy of a specified master slide to the end of the collection. Linked layout slides will be copied too.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
InsertClone | Inserts a copy of a specified master slide to specified position of the collection. Linked layout slides will be copied too.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.
RemoveUnused | Removes unused master slides.

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


MasterSlideCollection.AddClone Method

Adds a copy of a specified master slide to the end of the collection. Linked layout slides will be copied too.

[Visual Basic]
NotOverridable Public Function AddClone( _
ByVal sourceMaster As IMasterSlide _
) As IMasterSlide _
Implements IMasterSlideCollection.AddClone
[C#]
public IMasterSlide AddClone(
IMasterSlide sourceMaster
);

Parameters

sourceMaster
Slide to clone.

Return Value

Added slide.

Implements

IMasterSlideCollection.AddClone

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


MasterSlideCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


MasterSlideCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


MasterSlideCollection.InsertClone Method

Inserts a copy of a specified master slide to specified position of the collection. Linked layout slides will be copied too.

[Visual Basic]
NotOverridable Public Function InsertClone( _
ByVal index As Integer, _
ByVal sourceMaster As IMasterSlide _
) As IMasterSlide _
Implements IMasterSlideCollection.InsertClone
[C#]
public IMasterSlide InsertClone(
int index,
IMasterSlide sourceMaster
);

Parameters

index
Index of new slide.
sourceMaster
Slide to clone.

Return Value

Inserted master slide.

Implements

IMasterSlideCollection.InsertClone

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


MasterSlideCollection.Remove Method

Removes the first occurrence of a specific object from the collection.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal value As IMasterSlide _
) _
Implements IMasterSlideCollection.Remove
[C#]
public void Remove(
IMasterSlide value
);

Parameters

value
The master slide to remove from the collection.

Implements

IMasterSlideCollection.Remove

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


MasterSlideCollection.RemoveAt Method

Removes the element at the specified index of the collection.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IMasterSlideCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Implements

IMasterSlideCollection.RemoveAt

Remarks

To avoid throwing of the PptxEditException check master's HasDependingSlides property before.

Exceptions

Exception Type | Condition
PptxEditException | Thrown if the master to remove is used in presentation (its HasDependingSlides property is true).

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


MasterSlideCollection.RemoveUnused Method

Removes unused master slides.

[Visual Basic]
NotOverridable Public Sub RemoveUnused( _
ByVal ignorePreserveField As Boolean _
) _
Implements IMasterSlideCollection.RemoveUnused
[C#]
public void RemoveUnused(
bool ignorePreserveField
);

Parameters

ignorePreserveField
Determines, whether this method should remove unused master even if its Preserve property is set to true.

Implements

IMasterSlideCollection.RemoveUnused

See Also

MasterSlideCollection Class | Aspose.Slides Namespace


MaterialPresetType Enumeration

[Visual Basic]
Public Enum MaterialPresetType
[C#]
public enum MaterialPresetType

Members

Member Name | Description | Value
NotDefined |  | -1
Clear |  | 0
DkEdge |  | 1
Flat |  | 2
LegacyMatte |  | 3
LegacyMetal |  | 4
LegacyPlastic |  | 5
LegacyWireframe |  | 6
Matte |  | 7
Metal |  | 8
Plastic |  | 9
Powder |  | 10
SoftEdge |  | 11
Softmetal |  | 12
TranslucentPowder |  | 13
WarmMatte |  | 14

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


NotesSlide Class

Represents a notes slide in a presentation.

For a list of all members of this type, see NotesSlide Members.

System.Object
Aspose.Slides.BaseSlide
Aspose.Slides.NotesSlide

[Visual Basic]
Public Class NotesSlide
Inherits BaseSlide
Implements INotesSlide, IOverrideThemeable
[C#]
public class NotesSlide : BaseSlide, INotesSlide, IOverrideThemeable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

NotesSlide Members | Aspose.Slides Namespace


NotesSlide Members

NotesSlide overview

Public Instance Properties

Background (inherited from BaseSlide) | Returns slide's background. Read only Background.
Controls (inherited from BaseSlide) | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData (inherited from BaseSlide) | Returns the slide's custom data. Read-only ICustomData.
HyperlinkQueries (inherited from BaseSlide) | Provides easy access to contained hyperlinks.
Name (inherited from BaseSlide) | Returns or sets the name of a slide. Read/write String.
NotesTextFrame | Returns a TextFrame with notes' text if there is one. Readonly TextFrame.
OverrideTheme | Obsolete. Returns the overriding theme object.
ParentPresentation (inherited from BaseSlide) | Obsolete. Returns the parent presentation. Read-only Presentation.
ParentSlide |
Presentation (inherited from BaseSlide) |
Shapes (inherited from BaseSlide) | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId (inherited from BaseSlide) | Returns the ID of a slide.
SlideShowTransition (inherited from BaseSlide) | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags (inherited from BaseSlide) | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
ThemeManager |
Timeline (inherited from BaseSlide) | Returns animation timeline object. Read-only AnimationTimeLine.

Public Instance Methods

ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseSlide) | Returns an effective theme for this slide.
FindShapeByAltText (inherited from BaseSlide) | Finds first occurrence of a shape with the specified alternative text.
GetThumbnail | Overloaded. Returns a Thumbnail Bitmap object with custom scaling.

See Also

NotesSlide Class | Aspose.Slides Namespace


NotesSlide Properties

The properties of the NotesSlide class are listed below. For a complete list of NotesSlide class members, see the NotesSlide Members topic.

Public Instance Properties

Background (inherited from BaseSlide) | Returns slide's background. Read only Background.
Controls (inherited from BaseSlide) | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData (inherited from BaseSlide) | Returns the slide's custom data. Read-only ICustomData.
HyperlinkQueries (inherited from BaseSlide) | Provides easy access to contained hyperlinks.
Name (inherited from BaseSlide) | Returns or sets the name of a slide. Read/write String.
NotesTextFrame | Returns a TextFrame with notes' text if there is one. Readonly TextFrame.
OverrideTheme | Obsolete. Returns the overriding theme object.
ParentPresentation (inherited from BaseSlide) | Obsolete. Returns the parent presentation. Read-only Presentation.
ParentSlide |
Presentation (inherited from BaseSlide) |
Shapes (inherited from BaseSlide) | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId (inherited from BaseSlide) | Returns the ID of a slide.
SlideShowTransition (inherited from BaseSlide) | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags (inherited from BaseSlide) | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
ThemeManager |
Timeline (inherited from BaseSlide) | Returns animation timeline object. Read-only AnimationTimeLine.

See Also

NotesSlide Class | Aspose.Slides Namespace


NotesTextFrame Property

Aspose.Slides Documentation

NotesSlide.NotesTextFrame Property

Returns a TextFrame with notes' text if there is one. Readonly TextFrame.

[Visual Basic]
NotOverridable Public ReadOnly Property NotesTextFrame As ITextFrame _
Implements INotesSlide.NotesTextFrame
[C#]
public ITextFrame NotesTextFrame {get;}

Implements

INotesSlide.NotesTextFrame

See Also

NotesSlide Class | Aspose.Slides Namespace


OverrideTheme Property

Aspose.Slides Documentation

NotesSlide.OverrideTheme Property

NOTE: This property is now obsolete.

Use ThemeManager.OverrideTheme property instead. Property will be removed after 01.09.2013.

Returns the overriding theme object.

[Visual Basic]
Public ReadOnly Property OverrideTheme As OverrideTheme
[C#]
public OverrideTheme OverrideTheme {get;}

See Also

NotesSlide Class | Aspose.Slides Namespace


ParentSlide Property

Aspose.Slides Documentation

NotesSlide.ParentSlide Property

[Visual Basic]
NotOverridable Public ReadOnly Property ParentSlide As ISlide _
Implements INotesSlide.ParentSlide
[C#]
public ISlide ParentSlide {get;}

Implements

INotesSlide.ParentSlide

See Also

NotesSlide Class | Aspose.Slides Namespace


ThemeManager Property

Aspose.Slides Documentation

NotesSlide.ThemeManager Property

[Visual Basic]
NotOverridable Public ReadOnly Property ThemeManager As IOverrideThemeManager _
Implements IOverrideThemeable.ThemeManager
[C#]
public IOverrideThemeManager ThemeManager {get;}

Implements

IOverrideThemeable.ThemeManager

See Also

NotesSlide Class | Aspose.Slides Namespace


NotesSlide Methods

The methods of the NotesSlide class are listed below. For a complete list of NotesSlide class members, see the NotesSlide Members topic.

Public Instance Methods

ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseSlide) | Returns an effective theme for this slide.
FindShapeByAltText (inherited from BaseSlide) | Finds first occurrence of a shape with the specified alternative text.
GetThumbnail | Overloaded. Returns a Thumbnail Bitmap object with custom scaling.

See Also

NotesSlide Class | Aspose.Slides Namespace


NotesSlide.ApplyColorScheme Method

NOTE: This method is now obsolete.

Use ThemeManager.ApplyColorScheme(..) method instead. Will be removed after 01.09.2013.

Applies extra color scheme to a slide.

[Visual Basic]
Overrides Public Sub ApplyColorScheme( _
ByVal scheme As ExtraColorScheme _
)
[C#]
public override void ApplyColorScheme(
ExtraColorScheme scheme
);

Parameters

scheme

See Also

NotesSlide Class | Aspose.Slides Namespace


GetThumbnail Method

Aspose.Slides Documentation

NotesSlide.GetThumbnail Method

Returns a Thumbnail Bitmap object with specified size.

Overload List

Returns a Thumbnail Bitmap object with specified size.

public Bitmap GetThumbnail(Size);

Returns a Thumbnail Bitmap object with custom scaling.

public Bitmap GetThumbnail(float,float);

See Also

NotesSlide Class | Aspose.Slides Namespace


NotesSlide.GetThumbnail Method (Size)

Returns a Thumbnail Bitmap object with specified size.

[Visual Basic]
NotOverridable Overloads Public Function GetThumbnail( _
ByVal imageSize As Size _
) As Bitmap _
Implements INotesSlide.GetThumbnail
[C#]
public Bitmap GetThumbnail(
Size imageSize
);

Parameters

imageSize
Size of the image to create.

Return Value

Bitmap object.

Implements

INotesSlide.GetThumbnail

See Also

NotesSlide Class | Aspose.Slides Namespace | NotesSlide.GetThumbnail Overload List


NotesSlide.GetThumbnail Method (Single, Single)

Returns a Thumbnail Bitmap object with custom scaling.

[Visual Basic]
NotOverridable Overloads Public Function GetThumbnail( _
ByVal scaleX As Single, _
ByVal scaleY As Single _
) As Bitmap _
Implements INotesSlide.GetThumbnail
[C#]
public Bitmap GetThumbnail(
float scaleX,
float scaleY
);

Parameters

scaleX
The value by which to scale this Thumbnail in the x-axis direction.
scaleY
The value by which to scale this Thumbnail in the y-axis direction.

Return Value

Bitmap object.

Implements

INotesSlide.GetThumbnail

See Also

NotesSlide Class | Aspose.Slides Namespace | NotesSlide.GetThumbnail Overload List


NullableBool Enumeration

[Visual Basic]
Public Enum NullableBool
Inherits
[C#]
public enum NullableBool

Members

Member Name | Description | Value
NotDefined |  | -1
False |  | 0
True |  | 1

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


NumberedBulletStyle Enumeration

[Visual Basic]
Public Enum NumberedBulletStyle
Inherits
[C#]
public enum NumberedBulletStyle

Members

Member Name | Description | Value
NotDefined |  | -1
BulletAlphaLCPeriod |  | 0
BulletAlphaUCPeriod |  | 1
BulletArabicParenRight |  | 2
BulletArabicPeriod |  | 3
BulletRomanLCParenBoth |  | 4
BulletRomanLCParenRight |  | 5
BulletRomanLCPeriod |  | 6
BulletRomanUCPeriod |  | 7
BulletAlphaLCParenBoth |  | 8
BulletAlphaLCParenRight |  | 9
BulletAlphaUCParenBoth |  | 10
BulletAlphaUCParenRight |  | 11
BulletArabicParenBoth |  | 12
BulletArabicPlain |  | 13
BulletRomanUCParenBoth |  | 14
BulletRomanUCParenRight |  | 15
BulletSimpChinPlain |  | 16
BulletSimpChinPeriod |  | 17
BulletCircleNumDBPlain |  | 18
BulletCircleNumWDWhitePlain |  | 19
BulletCircleNumWDBlackPlain |  | 20
BulletTradChinPlain |  | 21
BulletTradChinPeriod |  | 22
BulletArabicAlphaDash |  | 23
BulletArabicAbjadDash |  | 24
BulletHebrewAlphaDash |  | 25
BulletKanjiKoreanPlain |  | 26
BulletKanjiKoreanPeriod |  | 27
BulletArabicDBPlain |  | 28
BulletArabicDBPeriod |  | 29
BulletThaiAlphaPeriod |  | 30
BulletThaiAlphaParenRight |  | 31
BulletThaiAlphaParenBoth |  | 32
BulletThaiNumPeriod |  | 33
BulletThaiNumParenRight |  | 34
BulletThaiNumParenBoth |  | 35
BulletHindiAlphaPeriod |  | 36
BulletHindiNumPeriod |  | 37
BulletKanjiSimpChinDBPeriod |  | 38
BulletHindiNumParenRight |  | 39
BulletHindiAlpha1Period |  | 40

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


OleObjectFrame Class

Represents an OLE object on a slide.

For a list of all members of this type, see OleObjectFrame Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GraphicalObject
Aspose.Slides.OleObjectFrame

[Visual Basic]
Public Class OleObjectFrame
Inherits GraphicalObject
Implements IOleObjectFrame
[C#]
public class OleObjectFrame : GraphicalObject, IOleObjectFrame

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

OleObjectFrame Members | Aspose.Slides Namespace


OleObjectFrame Members

OleObjectFrame overview

Public Instance Properties

AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
AsIGraphicalObject | Allows to get base IGraphicalObject interface.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsObjectIcon | Determines whether an object is visible as icon. Read/write Boolean.
IsObjectLink | Determines whether an object is linked to external file. Read-only Boolean.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
LinkFileName | Returns the full path to a linked file. Short file name will be used. Read-only String.
LinkPathLong | Returns the full path to a linked file. Long file name will be used. Read-only String.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
ObjectData | Returns or sets embedded object as byte array. Read/write Byte[].
ObjectName | Returns or sets the name of an object. Read/write String.
ObjectProgId | Returns or sets the ProgID of an object. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock (inherited from GraphicalObject) | Returns shape's locks. Read-only GraphicalObjectLock.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
SubstitutePictureFormat | Returns OleObject image fill properties object. Readonly PictureFillFormat.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
UpdateAutomatic | Determines if the linked embedded object is automatically updated when the presentation is opened or printed. Read/write Boolean.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

OleObjectFrame Class | Aspose.Slides Namespace


OleObjectFrame Properties

The properties of the OleObjectFrame class are listed below. For a complete list of OleObjectFrame class members, see the OleObjectFrame Members topic.

Public Instance Properties

AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
AsIGraphicalObject | Allows to get base IGraphicalObject interface.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsObjectIcon | Determines whether an object is visible as icon. Read/write Boolean.
IsObjectLink | Determines whether an object is linked to external file. Read-only Boolean.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
LinkFileName | Returns the full path to a linked file. Short file name will be used. Read-only String.
LinkPathLong | Returns the full path to a linked file. Long file name will be used. Read-only String.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
ObjectData | Returns or sets embedded object as byte array. Read/write Byte[].
ObjectName | Returns or sets the name of an object. Read/write String.
ObjectProgId | Returns or sets the ProgID of an object. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock (inherited from GraphicalObject) | Returns shape's locks. Read-only GraphicalObjectLock.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
SubstitutePictureFormat | Returns OleObject image fill properties object. Readonly PictureFillFormat.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
UpdateAutomatic | Determines if the linked embedded object is automatically updated when the presentation is opened or printed. Read/write Boolean.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

OleObjectFrame Class | Aspose.Slides Namespace


AsIGraphicalObject Property

Aspose.Slides Documentation

OleObjectFrame.AsIGraphicalObject Property

Allows to get base IGraphicalObject interface.

[Visual Basic]
NotOverridable Public ReadOnly Property AsIGraphicalObject As IGraphicalObject _
Implements IOleObjectFrame.AsIGraphicalObject
[C#]
public IGraphicalObject AsIGraphicalObject {get;}

Implements

IOleObjectFrame.AsIGraphicalObject

See Also

OleObjectFrame Class | Aspose.Slides Namespace


IsObjectIcon Property

Aspose.Slides Documentation

OleObjectFrame.IsObjectIcon Property

Determines whether an object is visible as icon. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property IsObjectIcon As Boolean _
Implements IOleObjectFrame.IsObjectIcon
[C#]
public bool IsObjectIcon {get; set;}

Implements

IOleObjectFrame.IsObjectIcon

See Also

OleObjectFrame Class | Aspose.Slides Namespace


IsObjectLink Property

Aspose.Slides Documentation

OleObjectFrame.IsObjectLink Property

Determines whether an object is linked to external file. Read-only Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property IsObjectLink As Boolean _
Implements IOleObjectFrame.IsObjectLink
[C#]
public bool IsObjectLink {get;}

Implements

IOleObjectFrame.IsObjectLink

See Also

OleObjectFrame Class | Aspose.Slides Namespace


LinkFileName Property

Aspose.Slides Documentation

OleObjectFrame.LinkFileName Property

Returns the full path to a linked file. Short file name will be used. Read-only String.

[Visual Basic]
NotOverridable Public ReadOnly Property LinkFileName As String _
Implements IOleObjectFrame.LinkFileName
[C#]
public string LinkFileName {get;}

Implements

IOleObjectFrame.LinkFileName

See Also

OleObjectFrame Class | Aspose.Slides Namespace


LinkPathLong Property

Aspose.Slides Documentation

OleObjectFrame.LinkPathLong Property

Returns the full path to a linked file. Long file name will be used. Read-only String.

[Visual Basic]
NotOverridable Public Property LinkPathLong As String _
Implements IOleObjectFrame.LinkPathLong
[C#]
public string LinkPathLong {get; set;}

Implements

IOleObjectFrame.LinkPathLong

See Also

OleObjectFrame Class | Aspose.Slides Namespace


ObjectData Property

Aspose.Slides Documentation

OleObjectFrame.ObjectData Property

Returns or sets embedded object as byte array. Read/write Byte[].

[Visual Basic]
NotOverridable Public Property ObjectData As Byte() _
Implements IOleObjectFrame.ObjectData
[C#]
public byte[] ObjectData {get; set;}

Implements

IOleObjectFrame.ObjectData

See Also

OleObjectFrame Class | Aspose.Slides Namespace


ObjectName Property

Aspose.Slides Documentation

OleObjectFrame.ObjectName Property

Returns or sets the name of an object. Read/write String.

[Visual Basic]
NotOverridable Public Property ObjectName As String _
Implements IOleObjectFrame.ObjectName
[C#]
public string ObjectName {get; set;}

Implements

IOleObjectFrame.ObjectName

See Also

OleObjectFrame Class | Aspose.Slides Namespace


ObjectProgId Property

Aspose.Slides Documentation

OleObjectFrame.ObjectProgId Property

Returns or sets the ProgID of an object. Read/write String.

[Visual Basic]
NotOverridable Public Property ObjectProgId As String _
Implements IOleObjectFrame.ObjectProgId
[C#]
public string ObjectProgId {get; set;}

Implements

IOleObjectFrame.ObjectProgId

See Also

OleObjectFrame Class | Aspose.Slides Namespace


SubstitutePictureFormat Property

Aspose.Slides Documentation

OleObjectFrame.SubstitutePictureFormat Property

Returns OleObject image fill properties object. Readonly PictureFillFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property SubstitutePictureFormat As IPictureFillFormat _
Implements IOleObjectFrame.SubstitutePictureFormat
[C#]
public IPictureFillFormat SubstitutePictureFormat {get;}

Implements

IOleObjectFrame.SubstitutePictureFormat

See Also

OleObjectFrame Class | Aspose.Slides Namespace


UpdateAutomatic Property

Aspose.Slides Documentation

OleObjectFrame.UpdateAutomatic Property

Determines if the linked embedded object is automatically updated when the presentation is opened or printed. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property UpdateAutomatic As Boolean _
Implements IOleObjectFrame.UpdateAutomatic
[C#]
public bool UpdateAutomatic {get; set;}

Implements

IOleObjectFrame.UpdateAutomatic

See Also

OleObjectFrame Class | Aspose.Slides Namespace


OOXMLCorruptFileException Class

For a list of all members of this type, see OOXMLCorruptFileException Members.

System.Object
System.Exception
Aspose.Slides.OOXMLException
Aspose.Slides.OOXMLCorruptFileException

[Visual Basic]
Public Class OOXMLCorruptFileException
Inherits OOXMLException
[C#]
public class OOXMLCorruptFileException : OOXMLException

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

OOXMLCorruptFileException Members | Aspose.Slides Namespace


OOXMLCorruptFileException Members

OOXMLCorruptFileException overview

Public Instance Constructors

OOXMLCorruptFileException Overloaded. Initializes a new instance of the OOXMLCorruptFileException class.

See Also

OOXMLCorruptFileException Class | Aspose.Slides Namespace


OOXMLCorruptFileException Constructor

Initializes a new instance of the OOXMLCorruptFileException class.

Overload List

Initializes a new instance of the OOXMLCorruptFileException class.

public OOXMLCorruptFileException();

public OOXMLCorruptFileException(string);

public OOXMLCorruptFileException(string,Exception);

See Also

OOXMLCorruptFileException Class | Aspose.Slides Namespace


OOXMLCorruptFileException Constructor ()

Initializes a new instance of the OOXMLCorruptFileException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public OOXMLCorruptFileException();

See Also

OOXMLCorruptFileException Class | Aspose.Slides Namespace | OOXMLCorruptFileException Constructor Overload List


OOXMLCorruptFileException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public OOXMLCorruptFileException(
string message
);

See Also

OOXMLCorruptFileException Class | Aspose.Slides Namespace | OOXMLCorruptFileException Constructor Overload List


OOXMLCorruptFileException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public OOXMLCorruptFileException(
string message,
Exception exception
);

See Also

OOXMLCorruptFileException Class | Aspose.Slides Namespace | OOXMLCorruptFileException Constructor Overload List


OOXMLException Class

For a list of all members of this type, see OOXMLException Members.

System.Object
System.Exception
Aspose.Slides.OOXMLException
Aspose.Slides.OOXMLCorruptFileException
Aspose.Slides.PptxException

[Visual Basic]
Public Class OOXMLException
Inherits Exception
[C#]
public class OOXMLException : Exception

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

OOXMLException Members | Aspose.Slides Namespace


OOXMLException Members

OOXMLException overview

Public Instance Constructors

OOXMLException Overloaded. Initializes a new instance of the OOXMLException class.

See Also

OOXMLException Class | Aspose.Slides Namespace


OOXMLException Constructor

Initializes a new instance of the OOXMLException class.

Overload List

Initializes a new instance of the OOXMLException class.

public OOXMLException();

public OOXMLException(string);

public OOXMLException(string,Exception);

See Also

OOXMLException Class | Aspose.Slides Namespace


OOXMLException Constructor ()

Initializes a new instance of the OOXMLException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public OOXMLException();

See Also

OOXMLException Class | Aspose.Slides Namespace | OOXMLException Constructor Overload List


OOXMLException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public OOXMLException(
string message
);

See Also

OOXMLException Class | Aspose.Slides Namespace | OOXMLException Constructor Overload List


OOXMLException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public OOXMLException(
string message,
Exception exception
);

See Also

OOXMLException Class | Aspose.Slides Namespace | OOXMLException Constructor Overload List


Orientation Enumeration

[Visual Basic]
Public Enum Orientation
Inherits
[C#]
public enum Orientation

Members

Member Name | Description | Value
Horizontal |  | 0
Vertical |  | 1

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


Paragraph Class

Represents a paragraph of text.

For a list of all members of this type, see Paragraph Members.

System.Object
Aspose.Slides.Paragraph

[Visual Basic]
NotInheritable Public Class Paragraph
Implements IParagraph, ISlideComponent, IPresentationComponent
[C#]
public sealed class Paragraph : IParagraph, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Paragraph Members | Aspose.Slides Namespace


Paragraph Members

Paragraph overview

Public Instance Constructors

Paragraph Overloaded. Initializes a new instance of the Paragraph class.

Public Instance Properties

ParagraphFormat | Returns the formatting object for this paragraph. Read-only ParagraphFormat.
Portions | Returns the collection of a text portions. Read-only PortionCollection.
Text | Gets or sets the the plain text of a paragraph.

Public Instance Methods

CreateParagraphFormatEffective Creates immutable object which contains effective paragraph formatting properties with the inheritance applied.

See Also

Paragraph Class | Aspose.Slides Namespace


Paragraph Constructor

Initializes a new instance of the Paragraph class with default properties.

Overload List

Initializes a new instance of the Paragraph class with default properties.

public Paragraph();

Copy constructor that initializes a new instance of a Paragraph class.

public Paragraph(Paragraph);

See Also

Paragraph Class | Aspose.Slides Namespace


Paragraph Constructor ()

Initializes a new instance of the Paragraph class with default properties.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Paragraph();

See Also

Paragraph Class | Aspose.Slides Namespace | Paragraph Constructor Overload List


Paragraph Constructor (Paragraph)

Copy constructor that initializes a new instance of a Paragraph class.

[Visual Basic]
Overloads Public Sub New( _
ByVal para As Paragraph _
)
[C#]
public Paragraph(
Paragraph para
);

See Also

Paragraph Class | Aspose.Slides Namespace | Paragraph Constructor Overload List


Paragraph Properties

The properties of the Paragraph class are listed below. For a complete list of Paragraph class members, see the Paragraph Members topic.

Public Instance Properties

ParagraphFormat | Returns the formatting object for this paragraph. Read-only ParagraphFormat.
Portions | Returns the collection of a text portions. Read-only PortionCollection.
Text | Gets or sets the the plain text of a paragraph.

See Also

Paragraph Class | Aspose.Slides Namespace


ParagraphFormat Property

Aspose.Slides Documentation

Paragraph.ParagraphFormat Property

Returns the formatting object for this paragraph. Read-only ParagraphFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property ParagraphFormat As IParagraphFormat _
Implements IParagraph.ParagraphFormat
[C#]
public IParagraphFormat ParagraphFormat {get;}

Implements

IParagraph.ParagraphFormat

Remarks

The formatting object contains the formatting parameters defined for the current paragraph only, inherited data is not applied.

In order to get the effective values including inherited ones use the CreateParagraphFormatEffective method.

See Also

Paragraph Class | Aspose.Slides Namespace


Portions Property

Aspose.Slides Documentation

Paragraph.Portions Property

Returns the collection of a text portions. Read-only PortionCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Portions As IPortionCollection _
Implements IParagraph.Portions
[C#]
public IPortionCollection Portions {get;}

Implements

IParagraph.Portions

See Also

Paragraph Class | Aspose.Slides Namespace


Text Property

Aspose.Slides Documentation

Paragraph.Text Property

Gets or sets the the plain text of a paragraph.

[Visual Basic]
NotOverridable Public Property Text As String _
Implements IParagraph.Text
[C#]
public string Text {get; set;}

Property Value

The text.

Implements

IParagraph.Text

See Also

Paragraph Class | Aspose.Slides Namespace


Paragraph Methods

The methods of the Paragraph class are listed below. For a complete list of Paragraph class members, see the Paragraph Members topic.

Public Instance Methods

CreateParagraphFormatEffective Creates immutable object which contains effective paragraph formatting properties with the inheritance applied.

See Also

Paragraph Class | Aspose.Slides Namespace


Paragraph.CreateParagraphFormatEffective Method

Creates immutable object which contains effective paragraph formatting properties with the inheritance applied.

[Visual Basic]
NotOverridable Public Function CreateParagraphFormatEffective() As IParagraphFormatEffectiveData _
Implements IParagraph.CreateParagraphFormatEffective
[C#]
public IParagraphFormatEffectiveData CreateParagraphFormatEffective();

Return Value

A ParagraphFormatEffectiveData.

Implements

IParagraph.CreateParagraphFormatEffective

See Also

Paragraph Class | Aspose.Slides Namespace


ParagraphCollection Class

Represents a collection of a paragraphs.

For a list of all members of this type, see ParagraphCollection Members.

System.Object
Aspose.Slides.ParagraphCollection

[Visual Basic]
NotInheritable Public Class ParagraphCollection
Implements IParagraphCollection, IEnumerable`1([Aspose.Slides.IParagraph, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable, ISlideComponent, IPresentationComponent
[C#]
public sealed class ParagraphCollection : IParagraphCollection, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ParagraphCollection Members | Aspose.Slides Namespace


ParagraphCollection Members

ParagraphCollection overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsReadOnly | Gets a value indicating whether the ICollection`1 is read-only.
Item | Gets the element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a Paragraph to the end of collection.
AddFromHtml | Overloaded. Adds text from specified html string to the collection.
Clear | Removes all elements from the collection.
Contains | Determines whether the ICollection`1 contains a specific value.
CopyTo | Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.
ExportToHtml | Converts specifying paragraphs to the HTML and returns it as String object.
GetEnumerator | Returns an enumerator for the entire collection.
IndexOf | Determines the index of a specific item in the IList`1.
Insert | Overloaded. Inserts a Paragraph into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the ICollection`1.
RemoveAt | Removes the element at the specified index of the collection.

See Also

ParagraphCollection Class | Aspose.Slides Namespace


ParagraphCollection Properties

The properties of the ParagraphCollection class are listed below. For a complete list of ParagraphCollection class members, see the ParagraphCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsReadOnly | Gets a value indicating whether the ICollection`1 is read-only.
Item | Gets the element at the specified index.

See Also

ParagraphCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

ParagraphCollection.Count Property

Gets the number of elements actually contained in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements IParagraphCollection.Count
[C#]
public int Count {get;}

Implements

IParagraphCollection.Count

See Also

ParagraphCollection Class | Aspose.Slides Namespace


IsReadOnly Property

Aspose.Slides Documentation

ParagraphCollection.IsReadOnly Property

Gets a value indicating whether the ICollection`1 is read-only.

[Visual Basic]
Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {get;}

See Also

ParagraphCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ParagraphCollection.Item Property

Gets the element at the specified index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IParagraphCollection.Item
As IParagraph _
Implements IParagraphCollection.Item
[C#]
public IParagraph this[
int index
] {get;}

Implements

IParagraphCollection.Item

See Also

ParagraphCollection Class | Aspose.Slides Namespace


ParagraphCollection Methods

The methods of the ParagraphCollection class are listed below. For a complete list of ParagraphCollection class members, see the ParagraphCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a Paragraph to the end of collection.
AddFromHtml | Overloaded. Adds text from specified html string to the collection.
Clear | Removes all elements from the collection.
Contains | Determines whether the ICollection`1 contains a specific value.
CopyTo | Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.
ExportToHtml | Converts specifying paragraphs to the HTML and returns it as String object.
GetEnumerator | Returns an enumerator for the entire collection.
IndexOf | Determines the index of a specific item in the IList`1.
Insert | Overloaded. Inserts a Paragraph into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the ICollection`1.
RemoveAt | Removes the element at the specified index of the collection.

See Also

ParagraphCollection Class | Aspose.Slides Namespace


Add Method

Aspose.Slides Documentation

ParagraphCollection.Add Method

Adds a Paragraph to the end of collection.

Overload List

Adds a Paragraph to the end of collection.

public void Add(IParagraph);

Adds a content of ParagraphCollection to the end of collection.

public int Add(IParagraphCollection);

See Also

ParagraphCollection Class | Aspose.Slides Namespace


ParagraphCollection.Add Method (IParagraph)

Adds a Paragraph to the end of collection.

[Visual Basic]
NotOverridable Overloads Public Sub Add( _
ByVal value As IParagraph _
) _
Implements IParagraphCollection.Add
[C#]
public void Add(
IParagraph value
);

Parameters

value
The Paragraph to be added to the end of the collection.

Implements

IParagraphCollection.Add

See Also

ParagraphCollection Class | Aspose.Slides Namespace | ParagraphCollection.Add Overload List


ParagraphCollection.Add Method (IParagraphCollection)

Adds a content of ParagraphCollection to the end of collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal value As IParagraphCollection _
) As Integer _
Implements IParagraphCollection.Add
[C#]
public int Add(
IParagraphCollection value
);

Parameters

value
The ParagraphCollection to be added to the end of the collection.

Return Value

The index at which the Paragraph has been added or -1 if there are nothing to add.

Implements

IParagraphCollection.Add

See Also

ParagraphCollection Class | Aspose.Slides Namespace | ParagraphCollection.Add Overload List


AddFromHtml Method

Aspose.Slides Documentation

ParagraphCollection.AddFromHtml Method

Adds text from specified html string to the collection.

Overload List

Adds text from specified html string to the collection.

public void AddFromHtml(string);

Adds text from specified html string to the collection.

public void AddFromHtml(string,IHtmlExternalResolver,string);

See Also

ParagraphCollection Class | Aspose.Slides Namespace


ParagraphCollection.AddFromHtml Method (String)

Adds text from specified html string to the collection.

[Visual Basic]
NotOverridable Overloads Public Sub AddFromHtml( _
ByVal text As String _
) _
Implements IParagraphCollection.AddFromHtml
[C#]
public void AddFromHtml(
string text
);

Parameters

text
HTML text.

Implements

IParagraphCollection.AddFromHtml

See Also

ParagraphCollection Class | Aspose.Slides Namespace | ParagraphCollection.AddFromHtml Overload List


ParagraphCollection.AddFromHtml Method (String, IHtmlExternalResolver, String)

Adds text from specified html string to the collection.

[Visual Basic]
NotOverridable Overloads Public Sub AddFromHtml( _
ByVal text As String, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) _
Implements IParagraphCollection.AddFromHtml
[C#]
public void AddFromHtml(
string text,
IHtmlExternalResolver resolver,
string uri
);

Parameters

text
HTML text.
resolver
Resolver callback object which resolves URIs and fetches referrenced objects.
uri
URI for adding HTML document. Used for resolving relative links.

Implements

IParagraphCollection.AddFromHtml

Remarks

Specifying resolver can potentially introduce a vulnurability. Use with caution.

See Also

ParagraphCollection Class | Aspose.Slides Namespace | ParagraphCollection.AddFromHtml Overload List


ParagraphCollection.Clear Method

Removes all elements from the collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IParagraphCollection.Clear
[C#]
public void Clear();

Implements

IParagraphCollection.Clear

See Also

ParagraphCollection Class | Aspose.Slides Namespace


ParagraphCollection.Contains Method

Determines whether the ICollection`1 contains a specific value.

[Visual Basic]
Public Function Contains( _
ByVal item As IParagraph _
) As Boolean
[C#]
public bool Contains(
IParagraph item
);

Parameters

item
The object to locate in the ICollection`1.

Return Value

true if item is found in the ICollection`1; otherwise, false.

See Also

ParagraphCollection Class | Aspose.Slides Namespace


ParagraphCollection.CopyTo Method

Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As IParagraph(), _
ByVal arrayIndex As Integer _
)
[C#]
public void CopyTo(
IParagraph[] array,
int arrayIndex
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from ICollection`1. The Array must have zero-based indexing.
arrayIndex
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | The number of elements in the source ICollection`1 is greater than the available space from arrayIndex to the end of the destination array.

See Also

ParagraphCollection Class | Aspose.Slides Namespace


ParagraphCollection.ExportToHtml Method

Converts specifying paragraphs to the HTML and returns it as String object.

[Visual Basic]
NotOverridable Public Function ExportToHtml( _
ByVal firstParagraphIndex As Integer, _
ByVal paragraphsCount As Integer, _
ByVal options As ITextToHtmlConversionOptions _
) As String _
Implements IParagraphCollection.ExportToHtml
[C#]
public string ExportToHtml(
int firstParagraphIndex,
int paragraphsCount,
ITextToHtmlConversionOptions options
);

Parameters

firstParagraphIndex
paragraphsCount
options

Return Value

Generated HTML.

Implements

IParagraphCollection.ExportToHtml

See Also

ParagraphCollection Class | Aspose.Slides Namespace


ParagraphCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

ParagraphCollection Class | Aspose.Slides Namespace


ParagraphCollection.IndexOf Method

Determines the index of a specific item in the IList`1.

[Visual Basic]
Public Function IndexOf( _
ByVal item As IParagraph _
) As Integer
[C#]
public int IndexOf(
IParagraph item
);

Parameters

item
The object to locate in the IList`1.

Return Value

The index of item if found in the list; otherwise, -1.

See Also

ParagraphCollection Class | Aspose.Slides Namespace


Insert Method

Aspose.Slides Documentation

ParagraphCollection.Insert Method

Inserts a Paragraph into the collection at the specified index.

Overload List

Inserts a Paragraph into the collection at the specified index.

public void Insert(int,IParagraph);

Inserts a content of ParagraphCollection into the collection at the specified index.

public void Insert(int,IParagraphCollection);

See Also

ParagraphCollection Class | Aspose.Slides Namespace


ParagraphCollection.Insert Method (Int32, IParagraph)

Inserts a Paragraph into the collection at the specified index.

[Visual Basic]
NotOverridable Overloads Public Sub Insert( _
ByVal index As Integer, _
ByVal value As IParagraph _
) _
Implements IParagraphCollection.Insert
[C#]
public void Insert(
int index,
IParagraph value
);

Parameters

index
The zero-based index at which Paragraph should be inserted.
value
The Paragraph to insert.

Implements

IParagraphCollection.Insert

See Also

ParagraphCollection Class | Aspose.Slides Namespace | ParagraphCollection.Insert Overload List


ParagraphCollection.Insert Method (Int32, IParagraphCollection)

Inserts a content of ParagraphCollection into the collection at the specified index.

[Visual Basic]
NotOverridable Overloads Public Sub Insert( _
ByVal index As Integer, _
ByVal value As IParagraphCollection _
) _
Implements IParagraphCollection.Insert
[C#]
public void Insert(
int index,
IParagraphCollection value
);

Parameters

index
The zero-based index at which paragraphs should be inserted.
value
The paragraphs to insert.

Implements

IParagraphCollection.Insert

See Also

ParagraphCollection Class | Aspose.Slides Namespace | ParagraphCollection.Insert Overload List


ParagraphCollection.Remove Method

Removes the first occurrence of a specific object from the ICollection`1.

[Visual Basic]
NotOverridable Public Function Remove( _
ByVal item As IParagraph _
) As Boolean _
Implements IParagraphCollection.Remove
[C#]
public bool Remove(
IParagraph item
);

Parameters

item
The object to remove from the ICollection`1.

Return Value

true if item was successfully removed from the ICollection`1; otherwise, false. This method also returns false if item is not found in the original ICollection`1.

Implements

IParagraphCollection.Remove

Exceptions

Exception Type | Condition
NotSupportedException | The ICollection`1 is read-only.

See Also

ParagraphCollection Class | Aspose.Slides Namespace


ParagraphCollection.RemoveAt Method

Removes the element at the specified index of the collection.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IParagraphCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Implements

IParagraphCollection.RemoveAt

See Also

ParagraphCollection Class | Aspose.Slides Namespace


ParagraphFactory Class

Allows to create paragraphs

For a list of all members of this type, see ParagraphFactory Members.

System.Object
Aspose.Slides.ParagraphFactory

[Visual Basic]
Public Class ParagraphFactory
Implements IParagraphFactory
[C#]
public class ParagraphFactory : IParagraphFactory

Remarks

For COM compatibility

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ParagraphFactory Members | Aspose.Slides Namespace


ParagraphFactory Members

ParagraphFactory overview

Public Instance Constructors

ParagraphFactory Constructor Initializes a new instance of the ParagraphFactory class.

Public Instance Methods

CreateParagraph Overloaded.

See Also

ParagraphFactory Class | Aspose.Slides Namespace


ParagraphFactory Constructor

Initializes a new instance of the ParagraphFactory class.

[Visual Basic]
Public Sub New()
[C#]
public ParagraphFactory();

See Also

ParagraphFactory Class | Aspose.Slides Namespace


ParagraphFactory Methods

The methods of the ParagraphFactory class are listed below. For a complete list of ParagraphFactory class members, see the ParagraphFactory Members topic.

Public Instance Methods

CreateParagraph Overloaded.

See Also

ParagraphFactory Class | Aspose.Slides Namespace


CreateParagraph Method

Aspose.Slides Documentation

ParagraphFactory.CreateParagraph Method

Overload List

public IParagraph CreateParagraph();

public IParagraph CreateParagraph(IParagraph);

See Also

ParagraphFactory Class | Aspose.Slides Namespace


ParagraphFactory.CreateParagraph Method ()

[Visual Basic]
NotOverridable Overloads Public Function CreateParagraph() As IParagraph _
Implements IParagraphFactory.CreateParagraph
[C#]
public IParagraph CreateParagraph();

Implements

IParagraphFactory.CreateParagraph

See Also

ParagraphFactory Class | Aspose.Slides Namespace | ParagraphFactory.CreateParagraph Overload List


ParagraphFactory.CreateParagraph Method (IParagraph)

[Visual Basic]
NotOverridable Overloads Public Function CreateParagraph( _
ByVal paragraph As IParagraph _
) As IParagraph _
Implements IParagraphFactory.CreateParagraph
[C#]
public IParagraph CreateParagraph(
IParagraph paragraph
);

Implements

IParagraphFactory.CreateParagraph

See Also

ParagraphFactory Class | Aspose.Slides Namespace | ParagraphFactory.CreateParagraph Overload List


ParagraphFormat Class

This class contains the paragraph formatting properties. Unlike ParagraphFormatEffectiveData, all properties of this class are writeable.

For a list of all members of this type, see ParagraphFormat Members.

System.Object
Aspose.Slides.ParagraphFormat

[Visual Basic]
Public Class ParagraphFormat
Implements IParagraphFormat, ISlideComponent, IPresentationComponent, IChartParagraphFormat
[C#]
public class ParagraphFormat : IParagraphFormat, ISlideComponent, IPresentationComponent, IChartParagraphFormat

Remarks

This class is used to return and manipulate paragraph formatting properties defined for the particular paragraph. This means that no inheritance is applied when getting values so for the majority of cases you will get values meaning "undefined".

In order to get the effective formatting parameter values including inherited you need to use CreateParagraphFormatEffective method which returns a ParagraphFormatEffectiveData instance.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ParagraphFormat Members | Aspose.Slides Namespace


ParagraphFormat Members

ParagraphFormat overview

Public Instance Properties

Alignment | Returns or sets the text alignment in a paragraph with no inheritance. Read/write TextAlignment.
BulletChar | Obsolete. Returns or sets the bullet char of a paragraph. Read/write Char.
BulletColor | Obsolete. Returns the color format of a bullet of a paragraph. Read-only ColorFormat.
BulletColorFormat | Obsolete. Returns or sets the color of a bullet. Read-only ColorFormat.
BulletFont | Obsolete. Returns or sets the bullet font of a paragraph. Read/write FontData.
BulletHeight | Obsolete. Returns or sets the bullet height of a paragraph. Read/write Single.
BulletType | Obsolete. Returns or sets the bullet type of a paragraph. Read/write BulletType.
DefaultTabSize | Returns or sets default tabulation size with no inheritance. Read/write Single.
EastAsianLineBreak | Determines whether the East Asian line break is used in a paragraph. No inheritance applied. Read/write NullableBool.
FontAlignment | Returns or sets a font alignment in a paragraph with no inheritance. Read/write FontAlignment.
HangingPunctuation | Determines whether the hanging punctuation is used in a paragraph. No inheritance applied. Read/write NullableBool.
Indent | Returns or sets text indentation in a paragraph with no inheritance. Read/write Single.
IsBulletHardColor | Obsolete. Determines whether the bullet has own color or inherits it from the first portion in the paragraph. NullableBool.True if bullet has own color and NullableBool.False if bullet inherits color from the first portion in the paragraph. Read/write NullableBool.
IsBulletHardFont | Obsolete. Determines whether the bullet has own font or inherits it from the first portion in the paragraph. NullableBool.True if bullet has own font and NullableBool.False if bullet inherits font from the first portion in the paragraph. Read/write NullableBool.
LatinLineBreak | Determines whether the Latin line break is used in a paragraph. No inheritance applied. Read/write NullableBool.
MarginLeft | Returns or sets the left margin in a paragraph with no inheritance. Read/write Single.
MarginRight | Returns or sets the right margin in a paragraph with no inheritance. Read/write Single.
NumberedBulletStartWith | Obsolete. Returns or sets the first number which is used for group of numbered bullets. Read/write Int16.
NumberedBulletStyle | Obsolete. Returns or sets the style of a numbered bullet. Read/write NumberedBulletStyle.
RightToLeft | Determines whether the Right to Left writing is used in a paragraph. No inheritance applied. Read/write NullableBool.
SpaceAfter | Returns or sets the amount of space after the last line in a paragraph with no inheritance. Read/write Single.
SpaceBefore | Returns or sets the amount of space before the first line in a paragraph with no inheritance. Read/write Single.
SpaceWithin | Returns or sets the amount of space between base lines in a paragraph. Positive value means percentage, negative - size in points. No inheritance applied. Read/write Single.
Tabs | Returns tabulations of a paragraph. No inheritance applied. Read-only TabCollection.

See Also

ParagraphFormat Class | Aspose.Slides Namespace


ParagraphFormat Properties

The properties of the ParagraphFormat class are listed below. For a complete list of ParagraphFormat class members, see the ParagraphFormat Members topic.

Public Instance Properties

Alignment | Returns or sets the text alignment in a paragraph with no inheritance. Read/write TextAlignment.
BulletChar | Obsolete. Returns or sets the bullet char of a paragraph. Read/write Char.
BulletColor | Obsolete. Returns the color format of a bullet of a paragraph. Read-only ColorFormat.
BulletColorFormat | Obsolete. Returns or sets the color of a bullet. Read-only ColorFormat.
BulletFont | Obsolete. Returns or sets the bullet font of a paragraph. Read/write FontData.
BulletHeight | Obsolete. Returns or sets the bullet height of a paragraph. Read/write Single.
BulletType | Obsolete. Returns or sets the bullet type of a paragraph. Read/write BulletType.
DefaultTabSize | Returns or sets default tabulation size with no inheritance. Read/write Single.
EastAsianLineBreak | Determines whether the East Asian line break is used in a paragraph. No inheritance applied. Read/write NullableBool.
FontAlignment | Returns or sets a font alignment in a paragraph with no inheritance. Read/write FontAlignment.
HangingPunctuation | Determines whether the hanging punctuation is used in a paragraph. No inheritance applied. Read/write NullableBool.
Indent | Returns or sets text indentation in a paragraph with no inheritance. Read/write Single.
IsBulletHardColor | Obsolete. Determines whether the bullet has own color or inherits it from the first portion in the paragraph. NullableBool.True if bullet has own color and NullableBool.False if bullet inherits color from the first portion in the paragraph. Read/write NullableBool.
IsBulletHardFont | Obsolete. Determines whether the bullet has own font or inherits it from the first portion in the paragraph. NullableBool.True if bullet has own font and NullableBool.False if bullet inherits font from the first portion in the paragraph. Read/write NullableBool.
LatinLineBreak | Determines whether the Latin line break is used in a paragraph. No inheritance applied. Read/write NullableBool.
MarginLeft | Returns or sets the left margin in a paragraph with no inheritance. Read/write Single.
MarginRight | Returns or sets the right margin in a paragraph with no inheritance. Read/write Single.
NumberedBulletStartWith | Obsolete. Returns or sets the first number which is used for group of numbered bullets. Read/write Int16.
NumberedBulletStyle | Obsolete. Returns or sets the style of a numbered bullet. Read/write NumberedBulletStyle.
RightToLeft | Determines whether the Right to Left writing is used in a paragraph. No inheritance applied. Read/write NullableBool.
SpaceAfter | Returns or sets the amount of space after the last line in a paragraph with no inheritance. Read/write Single.
SpaceBefore | Returns or sets the amount of space before the first line in a paragraph with no inheritance. Read/write Single.
SpaceWithin | Returns or sets the amount of space between base lines in a paragraph. Positive value means percentage, negative - size in points. No inheritance applied. Read/write Single.
Tabs | Returns tabulations of a paragraph. No inheritance applied. Read-only TabCollection.

See Also

ParagraphFormat Class | Aspose.Slides Namespace


Alignment Property

Aspose.Slides Documentation

ParagraphFormat.Alignment Property

Returns or sets the text alignment in a paragraph with no inheritance. Read/write TextAlignment.

[Visual Basic]
NotOverridable Public Property Alignment As TextAlignment _
Implements IChartParagraphFormat.Alignment
[C#]
public TextAlignment Alignment {get; set;}

Implements

IChartParagraphFormat.Alignment

See Also

ParagraphFormat Class | Aspose.Slides Namespace


BulletChar Property

Aspose.Slides Documentation

ParagraphFormat.BulletChar Property

NOTE: This property is now obsolete.

Use Bullet.Char property instead. Property will be removed after 01.09.2013.

Returns or sets the bullet char of a paragraph. Read/write Char.

[Visual Basic]
Public Property BulletChar As Char
[C#]
public char BulletChar {get; set;}

See Also

ParagraphFormat Class | Aspose.Slides Namespace


BulletColor Property

Aspose.Slides Documentation

ParagraphFormat.BulletColor Property

NOTE: This property is now obsolete.

Use Bullet.Color property instead. Property will be removed after 01.09.2013.

Returns the color format of a bullet of a paragraph. Read-only ColorFormat.

[Visual Basic]
Public ReadOnly Property BulletColor As IColorFormat
[C#]
public IColorFormat BulletColor {get;}

See Also

ParagraphFormat Class | Aspose.Slides Namespace


BulletColorFormat Property

Aspose.Slides Documentation

ParagraphFormat.BulletColorFormat Property

NOTE: This property is now obsolete.

Use Bullet.Color property instead. Property will be removed after 01.09.2013.

Returns or sets the color of a bullet. Read-only ColorFormat.

[Visual Basic]
Public ReadOnly Property BulletColorFormat As IColorFormat
[C#]
public IColorFormat BulletColorFormat {get;}

See Also

ParagraphFormat Class | Aspose.Slides Namespace


BulletFont Property

Aspose.Slides Documentation

ParagraphFormat.BulletFont Property

NOTE: This property is now obsolete.

Use Bullet.Font property instead. Property will be removed after 01.09.2013.

Returns or sets the bullet font of a paragraph. Read/write FontData.

[Visual Basic]
Public Property BulletFont As IFontData
[C#]
public IFontData BulletFont {get; set;}

See Also

ParagraphFormat Class | Aspose.Slides Namespace


BulletHeight Property

Aspose.Slides Documentation

ParagraphFormat.BulletHeight Property

NOTE: This property is now obsolete.

Use Bullet.Height property instead. Property will be removed after 01.09.2013.

Returns or sets the bullet height of a paragraph. Read/write Single.

[Visual Basic]
Public Property BulletHeight As Single
[C#]
public float BulletHeight {get; set;}

See Also

ParagraphFormat Class | Aspose.Slides Namespace


BulletType Property

Aspose.Slides Documentation

ParagraphFormat.BulletType Property

NOTE: This property is now obsolete.

Use Bullet.Type property instead. Property will be removed after 01.09.2013.

Returns or sets the bullet type of a paragraph. Read/write BulletType.

[Visual Basic]
Public Property BulletType As BulletType
[C#]
public BulletType BulletType {get; set;}

See Also

ParagraphFormat Class | Aspose.Slides Namespace


DefaultTabSize Property

Aspose.Slides Documentation

ParagraphFormat.DefaultTabSize Property

Returns or sets default tabulation size with no inheritance. Read/write Single.

[Visual Basic]
NotOverridable Public Property DefaultTabSize As Single _
Implements IChartParagraphFormat.DefaultTabSize
[C#]
public float DefaultTabSize {get; set;}

Implements

IChartParagraphFormat.DefaultTabSize

See Also

ParagraphFormat Class | Aspose.Slides Namespace


EastAsianLineBreak Property

Aspose.Slides Documentation

ParagraphFormat.EastAsianLineBreak Property

Determines whether the East Asian line break is used in a paragraph. No inheritance applied. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property EastAsianLineBreak As NullableBool _
Implements IChartParagraphFormat.EastAsianLineBreak
[C#]
public NullableBool EastAsianLineBreak {get; set;}

Implements

IChartParagraphFormat.EastAsianLineBreak

See Also

ParagraphFormat Class | Aspose.Slides Namespace


FontAlignment Property

Aspose.Slides Documentation

ParagraphFormat.FontAlignment Property

Returns or sets a font alignment in a paragraph with no inheritance. Read/write FontAlignment.

[Visual Basic]
NotOverridable Public Property FontAlignment As FontAlignment _
Implements IChartParagraphFormat.FontAlignment
[C#]
public FontAlignment FontAlignment {get; set;}

Implements

IChartParagraphFormat.FontAlignment

See Also

ParagraphFormat Class | Aspose.Slides Namespace


HangingPunctuation Property

Aspose.Slides Documentation

ParagraphFormat.HangingPunctuation Property

Determines whether the hanging punctuation is used in a paragraph. No inheritance applied. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property HangingPunctuation As NullableBool _
Implements IChartParagraphFormat.HangingPunctuation
[C#]
public NullableBool HangingPunctuation {get; set;}

Implements

IChartParagraphFormat.HangingPunctuation

See Also

ParagraphFormat Class | Aspose.Slides Namespace


Indent Property

Aspose.Slides Documentation

ParagraphFormat.Indent Property

Returns or sets text indentation in a paragraph with no inheritance. Read/write Single.

[Visual Basic]
NotOverridable Public Property Indent As Single _
Implements IChartParagraphFormat.Indent
[C#]
public float Indent {get; set;}

Implements

IChartParagraphFormat.Indent

See Also

ParagraphFormat Class | Aspose.Slides Namespace


IsBulletHardColor Property

Aspose.Slides Documentation

ParagraphFormat.IsBulletHardColor Property

NOTE: This property is now obsolete.

Use Bullet.IsBulletHardColor property instead. Property will be removed after 01.09.2013.

Determines whether the bullet has own color or inherits it from the first portion in the paragraph. NullableBool.True if bullet has own color and NullableBool.False if bullet inherits color from the first portion in the paragraph. Read/write NullableBool.

[Visual Basic]
Public Property IsBulletHardColor As NullableBool
[C#]
public NullableBool IsBulletHardColor {get; set;}

See Also

ParagraphFormat Class | Aspose.Slides Namespace


IsBulletHardFont Property

Aspose.Slides Documentation

ParagraphFormat.IsBulletHardFont Property

NOTE: This property is now obsolete.

Use Bullet.IsBulletHardFont property instead. Property will be removed after 01.09.2013.

Determines whether the bullet has own font or inherits it from the first portion in the paragraph. NullableBool.True if bullet has own font and NullableBool.False if bullet inherits font from the first portion in the paragraph. Read/write NullableBool.

[Visual Basic]
Public Property IsBulletHardFont As NullableBool
[C#]
public NullableBool IsBulletHardFont {get; set;}

See Also

ParagraphFormat Class | Aspose.Slides Namespace


LatinLineBreak Property

Aspose.Slides Documentation

ParagraphFormat.LatinLineBreak Property

Determines whether the Latin line break is used in a paragraph. No inheritance applied. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property LatinLineBreak As NullableBool _
Implements IChartParagraphFormat.LatinLineBreak
[C#]
public NullableBool LatinLineBreak {get; set;}

Implements

IChartParagraphFormat.LatinLineBreak

See Also

ParagraphFormat Class | Aspose.Slides Namespace


MarginLeft Property

Aspose.Slides Documentation

ParagraphFormat.MarginLeft Property

Returns or sets the left margin in a paragraph with no inheritance. Read/write Single.

[Visual Basic]
NotOverridable Public Property MarginLeft As Single _
Implements IChartParagraphFormat.MarginLeft
[C#]
public float MarginLeft {get; set;}

Implements

IChartParagraphFormat.MarginLeft

See Also

ParagraphFormat Class | Aspose.Slides Namespace


MarginRight Property

Aspose.Slides Documentation

ParagraphFormat.MarginRight Property

Returns or sets the right margin in a paragraph with no inheritance. Read/write Single.

[Visual Basic]
NotOverridable Public Property MarginRight As Single _
Implements IChartParagraphFormat.MarginRight
[C#]
public float MarginRight {get; set;}

Implements

IChartParagraphFormat.MarginRight

See Also

ParagraphFormat Class | Aspose.Slides Namespace


NumberedBulletStartWith Property

Aspose.Slides Documentation

ParagraphFormat.NumberedBulletStartWith Property

NOTE: This property is now obsolete.

Use Bullet.NumberedBulletStartWith property instead. Property will be removed after 01.09.2013.

Returns or sets the first number which is used for group of numbered bullets. Read/write Int16.

[Visual Basic]
Public Property NumberedBulletStartWith As Short
[C#]
public short NumberedBulletStartWith {get; set;}

See Also

ParagraphFormat Class | Aspose.Slides Namespace


NumberedBulletStyle Property

Aspose.Slides Documentation

ParagraphFormat.NumberedBulletStyle Property

NOTE: This property is now obsolete.

Use Bullet.NumberedBulletStyle property instead. Property will be removed after 01.09.2013.

Returns or sets the style of a numbered bullet. Read/write NumberedBulletStyle.

[Visual Basic]
Public Property NumberedBulletStyle As NumberedBulletStyle
[C#]
public NumberedBulletStyle NumberedBulletStyle {get; set;}

See Also

ParagraphFormat Class | Aspose.Slides Namespace


RightToLeft Property

Aspose.Slides Documentation

ParagraphFormat.RightToLeft Property

Determines whether the Right to Left writing is used in a paragraph. No inheritance applied. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property RightToLeft As NullableBool _
Implements IChartParagraphFormat.RightToLeft
[C#]
public NullableBool RightToLeft {get; set;}

Implements

IChartParagraphFormat.RightToLeft

See Also

ParagraphFormat Class | Aspose.Slides Namespace


SpaceAfter Property

Aspose.Slides Documentation

ParagraphFormat.SpaceAfter Property

Returns or sets the amount of space after the last line in a paragraph with no inheritance. Read/write Single.

[Visual Basic]
NotOverridable Public Property SpaceAfter As Single _
Implements IChartParagraphFormat.SpaceAfter
[C#]
public float SpaceAfter {get; set;}

Implements

IChartParagraphFormat.SpaceAfter

See Also

ParagraphFormat Class | Aspose.Slides Namespace


SpaceBefore Property

Aspose.Slides Documentation

ParagraphFormat.SpaceBefore Property

Returns or sets the amount of space before the first line in a paragraph with no inheritance. Read/write Single.

[Visual Basic]
NotOverridable Public Property SpaceBefore As Single _
Implements IChartParagraphFormat.SpaceBefore
[C#]
public float SpaceBefore {get; set;}

Implements

IChartParagraphFormat.SpaceBefore

See Also

ParagraphFormat Class | Aspose.Slides Namespace


SpaceWithin Property

Aspose.Slides Documentation

ParagraphFormat.SpaceWithin Property

Returns or sets the amount of space between base lines in a paragraph. Positive value means percentage, negative - size in points. No inheritance applied. Read/write Single.

[Visual Basic]
NotOverridable Public Property SpaceWithin As Single _
Implements IChartParagraphFormat.SpaceWithin
[C#]
public float SpaceWithin {get; set;}

Implements

IChartParagraphFormat.SpaceWithin

See Also

ParagraphFormat Class | Aspose.Slides Namespace


Tabs Property

Aspose.Slides Documentation

ParagraphFormat.Tabs Property

Returns tabulations of a paragraph. No inheritance applied. Read-only TabCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Tabs As ITabCollection _
Implements IChartParagraphFormat.Tabs
[C#]
public ITabCollection Tabs {get;}

Implements

IChartParagraphFormat.Tabs

See Also

ParagraphFormat Class | Aspose.Slides Namespace


ParagraphFormatEffectiveData Class

Immutable object which contains paragraph formatting properties.

For a list of all members of this type, see ParagraphFormatEffectiveData Members.

System.Object
Aspose.Slides.ParagraphFormatEffectiveData

[Visual Basic]
Public Class ParagraphFormatEffectiveData
Implements IParagraphFormatEffectiveData, ISlideComponent, IPresentationComponent
[C#]
public class ParagraphFormatEffectiveData : IParagraphFormatEffectiveData, ISlideComponent, IPresentationComponent

Remarks

This class is used together with the Paragraph class to return effective formatting values with inheritance applied.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ParagraphFormatEffectiveData Members | Aspose.Slides Namespace | CreateParagraphFormatEffective


ParagraphFormatEffectiveData Members

ParagraphFormatEffectiveData overview

Public Instance Properties

Alignment | Returns or sets the text alignment in a paragraph. Readonly TextAlignment.
Bullet |
BulletChar | Obsolete. Returns or sets the bullet char of a paragraph. Readonly Char.
BulletColor | Obsolete. Returns or sets the color of a bullet. Read-only Color.
BulletFont | Obsolete. Returns or sets the bullet font of a paragraph. Readonly FontData.
BulletHeight | Obsolete. Returns or sets the bullet height of a paragraph. Readonly Single.
BulletType | Obsolete. Returns or sets the bullet type of a paragraph. Readonly BulletType.
DefaultPortionFormat | Returns default portion format of a paragraph. Read-only PortionFormatEffectiveData.
DefaultTabSize | Returns or sets default tabulation size. Readonly Single.
Depth | Returns or sets a depth of a paragraph. Readonly Int16.
EastAsianLineBreak | Determines whether the East Asian line break is used in a paragraph. Readonly Boolean.
FontAlignment | Returns or sets a font alignment in a paragraph. Readonly FontAlignment.
HangingPunctuation | Determines whether the hanging punctuation is used in a paragraph. Readonly Boolean.
Indent | Returns or sets text indentation in a paragraph. Readonly Single.
LatinLineBreak | Determines whether the Latin line break is used in a paragraph. Readonly Boolean.
MarginLeft | Returns or sets the left margin in a paragraph. Readonly Single.
MarginRight | Returns or sets the right margin in a paragraph. Readonly Single.
NumberedBulletStartWith | Obsolete. Returns or sets the first number which is used for group of numbered bullets. Readonly Int16.
NumberedBulletStyle | Obsolete. Returns or sets the style of a numbered bullet. Readonly NumberedBulletStyle.
RightToLeft | Determines whether the Right to Left writing is used in a paragraph. Readonly Boolean.
SpaceAfter | Returns or sets the amount of space after the last line in a paragraph. Readonly Single.
SpaceBefore | Returns or sets the amount of space before the first line in a paragraph. Readonly Single.
SpaceWithin | Returns or sets the amount of space between base lines in a paragraph. Readonly Single.
Tabs | Returns tabulations of a paragraph. Readonly array of Tab.

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace | CreateParagraphFormatEffective


ParagraphFormatEffectiveData Properties

The properties of the ParagraphFormatEffectiveData class are listed below. For a complete list of ParagraphFormatEffectiveData class members, see the ParagraphFormatEffectiveData Members topic.

Public Instance Properties

Alignment | Returns or sets the text alignment in a paragraph. Readonly TextAlignment.
Bullet |
BulletChar | Obsolete. Returns or sets the bullet char of a paragraph. Readonly Char.
BulletColor | Obsolete. Returns or sets the color of a bullet. Read-only Color.
BulletFont | Obsolete. Returns or sets the bullet font of a paragraph. Readonly FontData.
BulletHeight | Obsolete. Returns or sets the bullet height of a paragraph. Readonly Single.
BulletType | Obsolete. Returns or sets the bullet type of a paragraph. Readonly BulletType.
DefaultPortionFormat | Returns default portion format of a paragraph. Read-only PortionFormatEffectiveData.
DefaultTabSize | Returns or sets default tabulation size. Readonly Single.
Depth | Returns or sets a depth of a paragraph. Readonly Int16.
EastAsianLineBreak | Determines whether the East Asian line break is used in a paragraph. Readonly Boolean.
FontAlignment | Returns or sets a font alignment in a paragraph. Readonly FontAlignment.
HangingPunctuation | Determines whether the hanging punctuation is used in a paragraph. Readonly Boolean.
Indent | Returns or sets text indentation in a paragraph. Readonly Single.
LatinLineBreak | Determines whether the Latin line break is used in a paragraph. Readonly Boolean.
MarginLeft | Returns or sets the left margin in a paragraph. Readonly Single.
MarginRight | Returns or sets the right margin in a paragraph. Readonly Single.
NumberedBulletStartWith | Obsolete. Returns or sets the first number which is used for group of numbered bullets. Readonly Int16.
NumberedBulletStyle | Obsolete. Returns or sets the style of a numbered bullet. Readonly NumberedBulletStyle.
RightToLeft | Determines whether the Right to Left writing is used in a paragraph. Readonly Boolean.
SpaceAfter | Returns or sets the amount of space after the last line in a paragraph. Readonly Single.
SpaceBefore | Returns or sets the amount of space before the first line in a paragraph. Readonly Single.
SpaceWithin | Returns or sets the amount of space between base lines in a paragraph. Readonly Single.
Tabs | Returns tabulations of a paragraph. Readonly array of Tab.

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace | CreateParagraphFormatEffective


Alignment Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.Alignment Property

Returns or sets the text alignment in a paragraph. Readonly TextAlignment.

[Visual Basic]
NotOverridable Public ReadOnly Property Alignment As TextAlignment _
Implements IParagraphFormatEffectiveData.Alignment
[C#]
public TextAlignment Alignment {get;}

Implements

IParagraphFormatEffectiveData.Alignment

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


Bullet Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.Bullet Property

[Visual Basic]
NotOverridable Public ReadOnly Property Bullet As IBulletFormatEffectiveData _
Implements IParagraphFormatEffectiveData.Bullet
[C#]
public IBulletFormatEffectiveData Bullet {get;}

Implements

IParagraphFormatEffectiveData.Bullet

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


BulletChar Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.BulletChar Property

NOTE: This property is now obsolete.

Use Bullet.Char property instead. Property will be removed after 01.09.2013.

Returns or sets the bullet char of a paragraph. Readonly Char.

[Visual Basic]
Public ReadOnly Property BulletChar As Char
[C#]
public char BulletChar {get;}

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


BulletColor Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.BulletColor Property

NOTE: This property is now obsolete.

Use Bullet.Color property instead. Property will be removed after 01.09.2013.

Returns or sets the color of a bullet. Read-only Color.

[Visual Basic]
Public ReadOnly Property BulletColor As Color
[C#]
public Color BulletColor {get;}

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


BulletFont Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.BulletFont Property

NOTE: This property is now obsolete.

Use Bullet.Font property instead. Property will be removed after 01.09.2013.

Returns or sets the bullet font of a paragraph. Readonly FontData.

[Visual Basic]
Public ReadOnly Property BulletFont As FontData
[C#]
public FontData BulletFont {get;}

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


BulletHeight Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.BulletHeight Property

NOTE: This property is now obsolete.

Use Bullet.Height property instead. Property will be removed after 01.09.2013.

Returns or sets the bullet height of a paragraph. Readonly Single.

[Visual Basic]
Public ReadOnly Property BulletHeight As Single
[C#]
public float BulletHeight {get;}

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


BulletType Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.BulletType Property

NOTE: This property is now obsolete.

Use Bullet.Type property instead. Property will be removed after 01.09.2013.

Returns or sets the bullet type of a paragraph. Readonly BulletType.

[Visual Basic]
Public ReadOnly Property BulletType As BulletType
[C#]
public BulletType BulletType {get;}

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


DefaultPortionFormat Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.DefaultPortionFormat Property

Returns default portion format of a paragraph. Read-only PortionFormatEffectiveData.

[Visual Basic]
NotOverridable Public ReadOnly Property DefaultPortionFormat As IPortionFormatEffectiveData _
Implements IParagraphFormatEffectiveData.DefaultPortionFormat
[C#]
public IPortionFormatEffectiveData DefaultPortionFormat {get;}

Implements

IParagraphFormatEffectiveData.DefaultPortionFormat

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


DefaultTabSize Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.DefaultTabSize Property

Returns or sets default tabulation size. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property DefaultTabSize As Single _
Implements IParagraphFormatEffectiveData.DefaultTabSize
[C#]
public float DefaultTabSize {get;}

Implements

IParagraphFormatEffectiveData.DefaultTabSize

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


Depth Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.Depth Property

Returns or sets a depth of a paragraph. Readonly Int16.

[Visual Basic]
NotOverridable Public ReadOnly Property Depth As Short _
Implements IParagraphFormatEffectiveData.Depth
[C#]
public short Depth {get;}

Implements

IParagraphFormatEffectiveData.Depth

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


EastAsianLineBreak Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.EastAsianLineBreak Property

Determines whether the East Asian line break is used in a paragraph. Readonly Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property EastAsianLineBreak As Boolean _
Implements IParagraphFormatEffectiveData.EastAsianLineBreak
[C#]
public bool EastAsianLineBreak {get;}

Implements

IParagraphFormatEffectiveData.EastAsianLineBreak

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


FontAlignment Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.FontAlignment Property

Returns or sets a font alignment in a paragraph. Readonly FontAlignment.

[Visual Basic]
NotOverridable Public ReadOnly Property FontAlignment As FontAlignment _
Implements IParagraphFormatEffectiveData.FontAlignment
[C#]
public FontAlignment FontAlignment {get;}

Implements

IParagraphFormatEffectiveData.FontAlignment

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


HangingPunctuation Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.HangingPunctuation Property

Determines whether the hanging punctuation is used in a paragraph. Readonly Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property HangingPunctuation As Boolean _
Implements IParagraphFormatEffectiveData.HangingPunctuation
[C#]
public bool HangingPunctuation {get;}

Implements

IParagraphFormatEffectiveData.HangingPunctuation

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


Indent Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.Indent Property

Returns or sets text indentation in a paragraph. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Indent As Single _
Implements IParagraphFormatEffectiveData.Indent
[C#]
public float Indent {get;}

Implements

IParagraphFormatEffectiveData.Indent

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


LatinLineBreak Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.LatinLineBreak Property

Determines whether the Latin line break is used in a paragraph. Readonly Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property LatinLineBreak As Boolean _
Implements IParagraphFormatEffectiveData.LatinLineBreak
[C#]
public bool LatinLineBreak {get;}

Implements

IParagraphFormatEffectiveData.LatinLineBreak

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


MarginLeft Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.MarginLeft Property

Returns or sets the left margin in a paragraph. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property MarginLeft As Single _
Implements IParagraphFormatEffectiveData.MarginLeft
[C#]
public float MarginLeft {get;}

Implements

IParagraphFormatEffectiveData.MarginLeft

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


MarginRight Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.MarginRight Property

Returns or sets the right margin in a paragraph. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property MarginRight As Single _
Implements IParagraphFormatEffectiveData.MarginRight
[C#]
public float MarginRight {get;}

Implements

IParagraphFormatEffectiveData.MarginRight

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


NumberedBulletStartWith Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.NumberedBulletStartWith Property

NOTE: This property is now obsolete.

Use Bullet.NumberedBulletStartWith property instead. Property will be removed after 01.09.2013.

Returns or sets the first number which is used for group of numbered bullets. Readonly Int16.

[Visual Basic]
Public ReadOnly Property NumberedBulletStartWith As Short
[C#]
public short NumberedBulletStartWith {get;}

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


NumberedBulletStyle Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.NumberedBulletStyle Property

NOTE: This property is now obsolete.

Use Bullet.NumberedBulletStyle property instead. Property will be removed after 01.09.2013.

Returns or sets the style of a numbered bullet. Readonly NumberedBulletStyle.

[Visual Basic]
Public ReadOnly Property NumberedBulletStyle As NumberedBulletStyle
[C#]
public NumberedBulletStyle NumberedBulletStyle {get;}

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


RightToLeft Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.RightToLeft Property

Determines whether the Right to Left writing is used in a paragraph. Readonly Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property RightToLeft As Boolean _
Implements IParagraphFormatEffectiveData.RightToLeft
[C#]
public bool RightToLeft {get;}

Implements

IParagraphFormatEffectiveData.RightToLeft

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


SpaceAfter Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.SpaceAfter Property

Returns or sets the amount of space after the last line in a paragraph. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property SpaceAfter As Single _
Implements IParagraphFormatEffectiveData.SpaceAfter
[C#]
public float SpaceAfter {get;}

Implements

IParagraphFormatEffectiveData.SpaceAfter

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


SpaceBefore Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.SpaceBefore Property

Returns or sets the amount of space before the first line in a paragraph. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property SpaceBefore As Single _
Implements IParagraphFormatEffectiveData.SpaceBefore
[C#]
public float SpaceBefore {get;}

Implements

IParagraphFormatEffectiveData.SpaceBefore

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


SpaceWithin Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.SpaceWithin Property

Returns or sets the amount of space between base lines in a paragraph. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property SpaceWithin As Single _
Implements IParagraphFormatEffectiveData.SpaceWithin
[C#]
public float SpaceWithin {get;}

Implements

IParagraphFormatEffectiveData.SpaceWithin

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


Tabs Property

Aspose.Slides Documentation

ParagraphFormatEffectiveData.Tabs Property

Returns tabulations of a paragraph. Readonly array of Tab.

[Visual Basic]
NotOverridable Public ReadOnly Property Tabs As ITabEffectiveData() _
Implements IParagraphFormatEffectiveData.Tabs
[C#]
public ITabEffectiveData[] Tabs {get;}

Implements

IParagraphFormatEffectiveData.Tabs

See Also

ParagraphFormatEffectiveData Class | Aspose.Slides Namespace


PatternFormat Class

Represents a pattern to fill a shape.

For a list of all members of this type, see PatternFormat Members.

System.Object
Aspose.Slides.PatternFormat

[Visual Basic]
Public Class PatternFormat
Implements IPatternFormat, ISlideComponent, IPresentationComponent
[C#]
public class PatternFormat : IPatternFormat, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PatternFormat Members | Aspose.Slides Namespace


PatternFormat Members

PatternFormat overview

Public Instance Properties

BackColor | Returns the background pattern color. Read-only ColorFormat.
ForeColor | Returns the foreground pattern color. Read-only ColorFormat.
PatternStyle | Returns or sets the pattern style. Read/write PatternStyle.

Public Instance Methods

Equals | Determines whether the two PatternFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTileImage | Overloaded. Creates a tile image for the pattern fill with a specified colors.

See Also

PatternFormat Class | Aspose.Slides Namespace


PatternFormat Properties

The properties of the PatternFormat class are listed below. For a complete list of PatternFormat class members, see the PatternFormat Members topic.

Public Instance Properties

BackColor | Returns the background pattern color. Read-only ColorFormat.
ForeColor | Returns the foreground pattern color. Read-only ColorFormat.
PatternStyle | Returns or sets the pattern style. Read/write PatternStyle.

See Also

PatternFormat Class | Aspose.Slides Namespace


BackColor Property

Aspose.Slides Documentation

PatternFormat.BackColor Property

Returns the background pattern color. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property BackColor As IColorFormat _
Implements IPatternFormat.BackColor
[C#]
public IColorFormat BackColor {get;}

Implements

IPatternFormat.BackColor

See Also

PatternFormat Class | Aspose.Slides Namespace


ForeColor Property

Aspose.Slides Documentation

PatternFormat.ForeColor Property

Returns the foreground pattern color. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property ForeColor As IColorFormat _
Implements IPatternFormat.ForeColor
[C#]
public IColorFormat ForeColor {get;}

Implements

IPatternFormat.ForeColor

See Also

PatternFormat Class | Aspose.Slides Namespace


PatternStyle Property

Aspose.Slides Documentation

PatternFormat.PatternStyle Property

Returns or sets the pattern style. Read/write PatternStyle.

[Visual Basic]
NotOverridable Public Property PatternStyle As PatternStyle _
Implements IPatternFormat.PatternStyle
[C#]
public PatternStyle PatternStyle {get; set;}

Implements

IPatternFormat.PatternStyle

See Also

PatternFormat Class | Aspose.Slides Namespace


PatternFormat Methods

The methods of the PatternFormat class are listed below. For a complete list of PatternFormat class members, see the PatternFormat Members topic.

Public Instance Methods

Equals | Determines whether the two PatternFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTileImage | Overloaded. Creates a tile image for the pattern fill with a specified colors.

See Also

PatternFormat Class | Aspose.Slides Namespace


PatternFormat.Equals Method

Determines whether the two PatternFormat instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The PatternFormat to compare with the current PatternFormat.

Return Value

true if the specified PatternFormat is equal to the current PatternFormat; otherwise, false.

See Also

PatternFormat Class | Aspose.Slides Namespace


PatternFormat.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

Remarks

Overriden to make compiler happy. Always returns constant because object is mutable.

See Also

PatternFormat Class | Aspose.Slides Namespace


GetTileImage Method

Aspose.Slides Documentation

PatternFormat.GetTileImage Method

Creates a tile image for the pattern fill.

Overload List

Creates a tile image for the pattern fill.

public Bitmap GetTileImage(Color);

Creates a tile image for the pattern fill with a specified colors.

public Bitmap GetTileImage(Color,Color);

See Also

PatternFormat Class | Aspose.Slides Namespace


PatternFormat.GetTileImage Method (Color)

Creates a tile image for the pattern fill.

[Visual Basic]
NotOverridable Overloads Public Function GetTileImage( _
ByVal styleColor As Color _
) As Bitmap _
Implements IPatternFormat.GetTileImage
[C#]
public Bitmap GetTileImage(
Color styleColor
);

Parameters

styleColor
The default Color, defined in Shape's StyleEx object. Fill's colors can depend on this.

Return Value

Tile Bitmap.

Implements

IPatternFormat.GetTileImage

See Also

PatternFormat Class | Aspose.Slides Namespace | PatternFormat.GetTileImage Overload List


PatternFormat.GetTileImage Method (Color, Color)

Creates a tile image for the pattern fill with a specified colors.

[Visual Basic]
NotOverridable Overloads Public Function GetTileImage( _
ByVal background As Color, _
ByVal foreground As Color _
) As Bitmap _
Implements IPatternFormat.GetTileImage
[C#]
public Bitmap GetTileImage(
Color background,
Color foreground
);

Parameters

background
The background Color for the pattern.
foreground
The foreground Color for the pattern.

Return Value

Tile Bitmap.

Implements

IPatternFormat.GetTileImage

See Also

PatternFormat Class | Aspose.Slides Namespace | PatternFormat.GetTileImage Overload List


PatternFormatEffectiveData Class

Immutable object which represents a pattern to fill a shape.

For a list of all members of this type, see PatternFormatEffectiveData Members.

System.Object
Aspose.Slides.PatternFormatEffectiveData

[Visual Basic]
Public Class PatternFormatEffectiveData
Implements IPatternFormatEffectiveData
[C#]
public class PatternFormatEffectiveData : IPatternFormatEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PatternFormatEffectiveData Members | Aspose.Slides Namespace


PatternFormatEffectiveData Members

PatternFormatEffectiveData overview

Public Instance Properties

BackColor | Returns the background pattern color. Read-only Color.
ForeColor | Returns the foreground pattern color. Read-only Color.
PatternStyle | Returns the pattern style. Read-only PatternStyle.

Public Instance Methods

GetTileImage Creates a tile image for the pattern fill with a specified colors.

See Also

PatternFormatEffectiveData Class | Aspose.Slides Namespace


PatternFormatEffectiveData Properties

The properties of the PatternFormatEffectiveData class are listed below. For a complete list of PatternFormatEffectiveData class members, see the PatternFormatEffectiveData Members topic.

Public Instance Properties

BackColor | Returns the background pattern color. Read-only Color.
ForeColor | Returns the foreground pattern color. Read-only Color.
PatternStyle | Returns the pattern style. Read-only PatternStyle.

See Also

PatternFormatEffectiveData Class | Aspose.Slides Namespace


BackColor Property

Aspose.Slides Documentation

PatternFormatEffectiveData.BackColor Property

Returns the background pattern color. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property BackColor As Color _
Implements IPatternFormatEffectiveData.BackColor
[C#]
public Color BackColor {get;}

Implements

IPatternFormatEffectiveData.BackColor

See Also

PatternFormatEffectiveData Class | Aspose.Slides Namespace


ForeColor Property

Aspose.Slides Documentation

PatternFormatEffectiveData.ForeColor Property

Returns the foreground pattern color. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property ForeColor As Color _
Implements IPatternFormatEffectiveData.ForeColor
[C#]
public Color ForeColor {get;}

Implements

IPatternFormatEffectiveData.ForeColor

See Also

PatternFormatEffectiveData Class | Aspose.Slides Namespace


PatternStyle Property

Aspose.Slides Documentation

PatternFormatEffectiveData.PatternStyle Property

Returns the pattern style. Read-only PatternStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property PatternStyle As PatternStyle _
Implements IPatternFormatEffectiveData.PatternStyle
[C#]
public PatternStyle PatternStyle {get;}

Implements

IPatternFormatEffectiveData.PatternStyle

See Also

PatternFormatEffectiveData Class | Aspose.Slides Namespace


PatternFormatEffectiveData Methods

The methods of the PatternFormatEffectiveData class are listed below. For a complete list of PatternFormatEffectiveData class members, see the PatternFormatEffectiveData Members topic.

Public Instance Methods

GetTileImage Creates a tile image for the pattern fill with a specified colors.

See Also

PatternFormatEffectiveData Class | Aspose.Slides Namespace


PatternFormatEffectiveData.GetTileImage Method

Creates a tile image for the pattern fill with a specified colors.

[Visual Basic]
NotOverridable Public Function GetTileImage( _
ByVal background As Color, _
ByVal foreground As Color _
) As Bitmap _
Implements IPatternFormatEffectiveData.GetTileImage
[C#]
public Bitmap GetTileImage(
Color background,
Color foreground
);

Parameters

background
The background Color for the pattern.
foreground
The foreground Color for the pattern.

Return Value

Tile Bitmap.

Implements

IPatternFormatEffectiveData.GetTileImage

See Also

PatternFormatEffectiveData Class | Aspose.Slides Namespace


PatternStyle Enumeration

[Visual Basic]
Public Enum PatternStyle
Inherits
[C#]
public enum PatternStyle

Members

Member Name | Description | Value
NotDefined |  | -1
Unknown |  | 0
Percent05 |  | 1
Percent10 |  | 2
Percent20 |  | 3
Percent25 |  | 4
Percent30 |  | 5
Percent40 |  | 6
Percent50 |  | 7
Percent60 |  | 8
Percent70 |  | 9
Percent75 |  | 10
Percent80 |  | 11
Percent90 |  | 12
DarkHorizontal |  | 13
DarkVertical |  | 14
DarkDownwardDiagonal |  | 15
DarkUpwardDiagonal |  | 16
SmallCheckerBoard |  | 17
Trellis |  | 18
LightHorizontal |  | 19
LightVertical |  | 20
LightDownwardDiagonal |  | 21
LightUpwardDiagonal |  | 22
SmallGrid |  | 23
DottedDiamond |  | 24
WideDownwardDiagonal |  | 25
WideUpwardDiagonal |  | 26
DashedDownwardDiagonal |  | 27
DashedUpwardDiagonal |  | 28
NarrowVertical |  | 29
NarrowHorizontal |  | 30
DashedVertical |  | 31
DashedHorizontal |  | 32
LargeConfetti |  | 33
LargeGrid |  | 34
HorizontalBrick |  | 35
LargeCheckerBoard |  | 36
SmallConfetti |  | 37
Zigzag |  | 38
SolidDiamond |  | 39
DiagonalBrick |  | 40
OutlinedDiamond |  | 41
Plaid |  | 42
Sphere |  | 43
Weave |  | 44
DottedGrid |  | 45
Divot |  | 46
Shingle |  | 47
Wave |  | 48
Horizontal |  | 49
Vertical |  | 50
Cross |  | 51
DownwardDiagonal |  | 52
UpwardDiagonal |  | 53
DiagonalCross |  | 54

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


Picture Class

Represents a picture in a presentation.

For a list of all members of this type, see Picture Members.

System.Object
Aspose.Slides.Picture

[Visual Basic]
Public Class Picture
Implements ISlidesPicture, ISlideComponent, IPresentationComponent
[C#]
public class Picture : ISlidesPicture, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Picture Members | Aspose.Slides Namespace


Picture Members

Picture overview

Public Instance Properties

Image | Returns or sets the embedded image. Read/write Image.
ImageTransform | Returns the collection of image transform effects. Read-only ImageTransformOperationCollection.
LinkPathLong | Returns of sets linked image's URL. Read/write String.
Presentation | Returns the parent presentation of a picture. Read-only Presentation.
Slide | Returns the parent slide of a picture. Read-only BaseSlide.

See Also

Picture Class | Aspose.Slides Namespace


Picture Properties

The properties of the Picture class are listed below. For a complete list of Picture class members, see the Picture Members topic.

Public Instance Properties

Image | Returns or sets the embedded image. Read/write Image.
ImageTransform | Returns the collection of image transform effects. Read-only ImageTransformOperationCollection.
LinkPathLong | Returns of sets linked image's URL. Read/write String.
Presentation | Returns the parent presentation of a picture. Read-only Presentation.
Slide | Returns the parent slide of a picture. Read-only BaseSlide.

See Also

Picture Class | Aspose.Slides Namespace


Image Property

Aspose.Slides Documentation

Picture.Image Property

Returns or sets the embedded image. Read/write Image.

[Visual Basic]
NotOverridable Public Property Image As IPPImage _
Implements ISlidesPicture.Image
[C#]
public IPPImage Image {get; set;}

Implements

ISlidesPicture.Image

See Also

Picture Class | Aspose.Slides Namespace


ImageTransform Property

Aspose.Slides Documentation

Picture.ImageTransform Property

Returns the collection of image transform effects. Read-only ImageTransformOperationCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property ImageTransform As IImageTransformOperationCollection _
Implements ISlidesPicture.ImageTransform
[C#]
public IImageTransformOperationCollection ImageTransform {get;}

Implements

ISlidesPicture.ImageTransform

See Also

Picture Class | Aspose.Slides Namespace


LinkPathLong Property

Aspose.Slides Documentation

Picture.LinkPathLong Property

Returns of sets linked image's URL. Read/write String.

[Visual Basic]
NotOverridable Public Property LinkPathLong As String _
Implements ISlidesPicture.LinkPathLong
[C#]
public string LinkPathLong {get; set;}

Implements

ISlidesPicture.LinkPathLong

See Also

Picture Class | Aspose.Slides Namespace


Presentation Property

Aspose.Slides Documentation

Picture.Presentation Property

Returns the parent presentation of a picture. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

Picture Class | Aspose.Slides Namespace


Slide Property

Aspose.Slides Documentation

Picture.Slide Property

Returns the parent slide of a picture. Read-only BaseSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As IBaseSlide _
Implements ISlideComponent.Slide
[C#]
public IBaseSlide Slide {get;}

Implements

ISlideComponent.Slide

See Also

Picture Class | Aspose.Slides Namespace


PictureEffectiveData Class

Immutable object which represents a picture in a presentation.

For a list of all members of this type, see PictureEffectiveData Members.

System.Object
Aspose.Slides.PictureEffectiveData

[Visual Basic]
Public Class PictureEffectiveData
Implements IPictureEffectiveData
[C#]
public class PictureEffectiveData : IPictureEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PictureEffectiveData Members | Aspose.Slides Namespace


PictureEffectiveData Members

PictureEffectiveData overview

Public Instance Properties

Image | Returns or sets the embedded image. Readonly PPImage.
ImageTransform | Returns the collection of image transform effects. Read-only ImageTransform.
LinkPathLong | Returns of sets linked image's URL. Readonly String.

See Also

PictureEffectiveData Class | Aspose.Slides Namespace


PictureEffectiveData Properties

The properties of the PictureEffectiveData class are listed below. For a complete list of PictureEffectiveData class members, see the PictureEffectiveData Members topic.

Public Instance Properties

Image | Returns or sets the embedded image. Readonly PPImage.
ImageTransform | Returns the collection of image transform effects. Read-only ImageTransform.
LinkPathLong | Returns of sets linked image's URL. Readonly String.

See Also

PictureEffectiveData Class | Aspose.Slides Namespace


Image Property

Aspose.Slides Documentation

PictureEffectiveData.Image Property

Returns or sets the embedded image. Readonly PPImage.

[Visual Basic]
NotOverridable Public ReadOnly Property Image As IPPImage _
Implements IPictureEffectiveData.Image
[C#]
public IPPImage Image {get;}

Implements

IPictureEffectiveData.Image

See Also

PictureEffectiveData Class | Aspose.Slides Namespace


ImageTransform Property

Aspose.Slides Documentation

PictureEffectiveData.ImageTransform Property

Returns the collection of image transform effects. Read-only ImageTransform.

[Visual Basic]
NotOverridable Public ReadOnly Property ImageTransform As IImageTransformOCollectionEffectiveData _
Implements IPictureEffectiveData.ImageTransform
[C#]
public IImageTransformOCollectionEffectiveData ImageTransform {get;}

Implements

IPictureEffectiveData.ImageTransform

See Also

PictureEffectiveData Class | Aspose.Slides Namespace


LinkPathLong Property

Aspose.Slides Documentation

PictureEffectiveData.LinkPathLong Property

Returns of sets linked image's URL. Readonly String.

[Visual Basic]
NotOverridable Public ReadOnly Property LinkPathLong As String _
Implements IPictureEffectiveData.LinkPathLong
[C#]
public string LinkPathLong {get;}

Implements

IPictureEffectiveData.LinkPathLong

See Also

PictureEffectiveData Class | Aspose.Slides Namespace


PictureFillFormat Class

Represents a picture fill style.

For a list of all members of this type, see PictureFillFormat Members.

System.Object
Aspose.Slides.PictureFillFormat

[Visual Basic]
Public Class PictureFillFormat
Implements IPictureFillFormat, ISlideComponent, IPresentationComponent, IFillParamSource
[C#]
public class PictureFillFormat : IPictureFillFormat, ISlideComponent, IPresentationComponent, IFillParamSource

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PictureFillFormat Members | Aspose.Slides Namespace


PictureFillFormat Members

PictureFillFormat overview

Public Instance Properties

CropBottom | Returns or sets the number of percents of real image height that are cropped off the bottom of the picture. Read/write Single.
CropLeft | Returns or sets the number of percents of real image width that are cropped off the left of the picture. Read/write Single.
CropRight | Returns or sets the number of percents of real image width that are cropped off the right of the picture. Read/write Single.
CropTop | Returns or sets the number of percents of real image height that are cropped off the top of the picture. Read/write Single.
Dpi | Returns or sets the dpi which is used to fill a picture. Read/write Int32.
Picture | Returns the picture. Readonly Picture
PictureFillMode | Returns or sets the picture fill mode. Read/write PictureFillMode.
Presentation | Returns the parent presentation of a picture. Read-only Presentation.
Slide | Returns the parent slide of a picture. Read-only BaseSlide.

See Also

PictureFillFormat Class | Aspose.Slides Namespace


PictureFillFormat Properties

The properties of the PictureFillFormat class are listed below. For a complete list of PictureFillFormat class members, see the PictureFillFormat Members topic.

Public Instance Properties

CropBottom | Returns or sets the number of percents of real image height that are cropped off the bottom of the picture. Read/write Single.
CropLeft | Returns or sets the number of percents of real image width that are cropped off the left of the picture. Read/write Single.
CropRight | Returns or sets the number of percents of real image width that are cropped off the right of the picture. Read/write Single.
CropTop | Returns or sets the number of percents of real image height that are cropped off the top of the picture. Read/write Single.
Dpi | Returns or sets the dpi which is used to fill a picture. Read/write Int32.
Picture | Returns the picture. Readonly Picture
PictureFillMode | Returns or sets the picture fill mode. Read/write PictureFillMode.
Presentation | Returns the parent presentation of a picture. Read-only Presentation.
Slide | Returns the parent slide of a picture. Read-only BaseSlide.

See Also

PictureFillFormat Class | Aspose.Slides Namespace


CropBottom Property

Aspose.Slides Documentation

PictureFillFormat.CropBottom Property

Returns or sets the number of percents of real image height that are cropped off the bottom of the picture. Read/write Single.

[Visual Basic]
NotOverridable Public Property CropBottom As Single _
Implements IPictureFillFormat.CropBottom
[C#]
public float CropBottom {get; set;}

Implements

IPictureFillFormat.CropBottom

See Also

PictureFillFormat Class | Aspose.Slides Namespace


CropLeft Property

Aspose.Slides Documentation

PictureFillFormat.CropLeft Property

Returns or sets the number of percents of real image width that are cropped off the left of the picture. Read/write Single.

[Visual Basic]
NotOverridable Public Property CropLeft As Single _
Implements IPictureFillFormat.CropLeft
[C#]
public float CropLeft {get; set;}

Implements

IPictureFillFormat.CropLeft

See Also

PictureFillFormat Class | Aspose.Slides Namespace


CropRight Property

Aspose.Slides Documentation

PictureFillFormat.CropRight Property

Returns or sets the number of percents of real image width that are cropped off the right of the picture. Read/write Single.

[Visual Basic]
NotOverridable Public Property CropRight As Single _
Implements IPictureFillFormat.CropRight
[C#]
public float CropRight {get; set;}

Implements

IPictureFillFormat.CropRight

See Also

PictureFillFormat Class | Aspose.Slides Namespace


CropTop Property

Aspose.Slides Documentation

PictureFillFormat.CropTop Property

Returns or sets the number of percents of real image height that are cropped off the top of the picture. Read/write Single.

[Visual Basic]
NotOverridable Public Property CropTop As Single _
Implements IPictureFillFormat.CropTop
[C#]
public float CropTop {get; set;}

Implements

IPictureFillFormat.CropTop

See Also

PictureFillFormat Class | Aspose.Slides Namespace


Dpi Property

Aspose.Slides Documentation

PictureFillFormat.Dpi Property

Returns or sets the dpi which is used to fill a picture. Read/write Int32.

[Visual Basic]
NotOverridable Public Property Dpi As Integer _
Implements IPictureFillFormat.Dpi
[C#]
public int Dpi {get; set;}

Implements

IPictureFillFormat.Dpi

See Also

PictureFillFormat Class | Aspose.Slides Namespace


Picture Property

Aspose.Slides Documentation

PictureFillFormat.Picture Property

Returns the picture. Readonly Picture

[Visual Basic]
NotOverridable Public ReadOnly Property Picture As ISlidesPicture _
Implements IPictureFillFormat.Picture
[C#]
public ISlidesPicture Picture {get;}

Implements

IPictureFillFormat.Picture

See Also

PictureFillFormat Class | Aspose.Slides Namespace


PictureFillMode Property

Aspose.Slides Documentation

PictureFillFormat.PictureFillMode Property

Returns or sets the picture fill mode. Read/write PictureFillMode.

[Visual Basic]
NotOverridable Public Property PictureFillMode As PictureFillMode _
Implements IPictureFillFormat.PictureFillMode
[C#]
public PictureFillMode PictureFillMode {get; set;}

Implements

IPictureFillFormat.PictureFillMode

See Also

PictureFillFormat Class | Aspose.Slides Namespace


Presentation Property

Aspose.Slides Documentation

PictureFillFormat.Presentation Property

Returns the parent presentation of a picture. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

PictureFillFormat Class | Aspose.Slides Namespace


Slide Property

Aspose.Slides Documentation

PictureFillFormat.Slide Property

Returns the parent slide of a picture. Read-only BaseSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As IBaseSlide _
Implements ISlideComponent.Slide
[C#]
public IBaseSlide Slide {get;}

Implements

ISlideComponent.Slide

See Also

PictureFillFormat Class | Aspose.Slides Namespace


PictureFillFormatEffectiveData Class

Immutable object which contains the properties of picture fill.

For a list of all members of this type, see PictureFillFormatEffectiveData Members.

System.Object
Aspose.Slides.PictureFillFormatEffectiveData

[Visual Basic]
Public Class PictureFillFormatEffectiveData
Implements IPictureFillFormatEffectiveData, IFillParamSource
[C#]
public class PictureFillFormatEffectiveData : IPictureFillFormatEffectiveData, IFillParamSource

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PictureFillFormatEffectiveData Members | Aspose.Slides Namespace


PictureFillFormatEffectiveData Members

PictureFillFormatEffectiveData overview

Public Instance Properties

CropBottom | Returns the number of percents of real image height that are cropped off the bottom of the picture. Read-only Single.
CropLeft | Returns the number of percents of real image width that are cropped off the left of the picture. Read-only Single.
CropRight | Returns the number of percents of real image width that are cropped off the right of the picture. Read-only Single.
CropTop | Returns the number of percents of real image height that are cropped off the top of the picture. Read-only Single.
Dpi | Returns the dpi which is used to fill a picture. Read-only Int32.
Picture | Returns the picture. Read-only PictureEffectiveData
PictureFillMode | Returns the picture fill mode. Read-only PictureFillMode.

See Also

PictureFillFormatEffectiveData Class | Aspose.Slides Namespace


PictureFillFormatEffectiveData Properties

The properties of the PictureFillFormatEffectiveData class are listed below. For a complete list of PictureFillFormatEffectiveData class members, see the PictureFillFormatEffectiveData Members topic.

Public Instance Properties

CropBottom | Returns the number of percents of real image height that are cropped off the bottom of the picture. Read-only Single.
CropLeft | Returns the number of percents of real image width that are cropped off the left of the picture. Read-only Single.
CropRight | Returns the number of percents of real image width that are cropped off the right of the picture. Read-only Single.
CropTop | Returns the number of percents of real image height that are cropped off the top of the picture. Read-only Single.
Dpi | Returns the dpi which is used to fill a picture. Read-only Int32.
Picture | Returns the picture. Read-only PictureEffectiveData
PictureFillMode | Returns the picture fill mode. Read-only PictureFillMode.

See Also

PictureFillFormatEffectiveData Class | Aspose.Slides Namespace


CropBottom Property

Aspose.Slides Documentation

PictureFillFormatEffectiveData.CropBottom Property

Returns the number of percents of real image height that are cropped off the bottom of the picture. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property CropBottom As Single _
Implements IPictureFillFormatEffectiveData.CropBottom
[C#]
public float CropBottom {get;}

Implements

IPictureFillFormatEffectiveData.CropBottom

See Also

PictureFillFormatEffectiveData Class | Aspose.Slides Namespace


CropLeft Property

Aspose.Slides Documentation

PictureFillFormatEffectiveData.CropLeft Property

Returns the number of percents of real image width that are cropped off the left of the picture. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property CropLeft As Single _
Implements IPictureFillFormatEffectiveData.CropLeft
[C#]
public float CropLeft {get;}

Implements

IPictureFillFormatEffectiveData.CropLeft

See Also

PictureFillFormatEffectiveData Class | Aspose.Slides Namespace


CropRight Property

Aspose.Slides Documentation

PictureFillFormatEffectiveData.CropRight Property

Returns the number of percents of real image width that are cropped off the right of the picture. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property CropRight As Single _
Implements IPictureFillFormatEffectiveData.CropRight
[C#]
public float CropRight {get;}

Implements

IPictureFillFormatEffectiveData.CropRight

See Also

PictureFillFormatEffectiveData Class | Aspose.Slides Namespace


CropTop Property

Aspose.Slides Documentation

PictureFillFormatEffectiveData.CropTop Property

Returns the number of percents of real image height that are cropped off the top of the picture. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property CropTop As Single _
Implements IPictureFillFormatEffectiveData.CropTop
[C#]
public float CropTop {get;}

Implements

IPictureFillFormatEffectiveData.CropTop

See Also

PictureFillFormatEffectiveData Class | Aspose.Slides Namespace


Dpi Property

Aspose.Slides Documentation

PictureFillFormatEffectiveData.Dpi Property

Returns the dpi which is used to fill a picture. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Dpi As Integer _
Implements IPictureFillFormatEffectiveData.Dpi
[C#]
public int Dpi {get;}

Implements

IPictureFillFormatEffectiveData.Dpi

See Also

PictureFillFormatEffectiveData Class | Aspose.Slides Namespace


Picture Property

Aspose.Slides Documentation

PictureFillFormatEffectiveData.Picture Property

Returns the picture. Read-only PictureEffectiveData

[Visual Basic]
NotOverridable Public ReadOnly Property Picture As IPictureEffectiveData _
Implements IPictureFillFormatEffectiveData.Picture
[C#]
public IPictureEffectiveData Picture {get;}

Implements

IPictureFillFormatEffectiveData.Picture

See Also

PictureFillFormatEffectiveData Class | Aspose.Slides Namespace


PictureFillMode Property

Aspose.Slides Documentation

PictureFillFormatEffectiveData.PictureFillMode Property

Returns the picture fill mode. Read-only PictureFillMode.

[Visual Basic]
NotOverridable Public ReadOnly Property PictureFillMode As PictureFillMode _
Implements IPictureFillFormatEffectiveData.PictureFillMode
[C#]
public PictureFillMode PictureFillMode {get;}

Implements

IPictureFillFormatEffectiveData.PictureFillMode

See Also

PictureFillFormatEffectiveData Class | Aspose.Slides Namespace


PictureFillMode Enumeration

[Visual Basic]
Public Enum PictureFillMode
[C#]
public enum PictureFillMode

Members

Member Name | Description | Value
Tile |  | 0
Stretch |  | 1

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


PictureFrame Class

Represents a frame with a picture inside.

For a list of all members of this type, see PictureFrame Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GeometryShape
Aspose.Slides.PictureFrame
Aspose.Slides.AudioFrame
Aspose.Slides.VideoFrame

[Visual Basic]
Public Class PictureFrame
Inherits GeometryShape
Implements IPictureFrame
[C#]
public class PictureFrame : GeometryShape, IPictureFrame

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PictureFrame Members | Aspose.Slides Namespace


PictureFrame Members

PictureFrame overview

Public Instance Properties

Adjustments (inherited from GeometryShape) | Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
PictureFormat | Returns the PictureFillFormat object for a picture frame. Read-only PictureFillFormat.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
RelativeScaleHeight | Returns or sets the scale of height(relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.
RelativeScaleWidth | Returns or sets the scale of width (relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock | Overloaded. Returns shape's locks. Readonly PictureFrameLock.
ShapeStyle (inherited from GeometryShape) | Returns shape's style object. Read-only ShapeStyle.
ShapeType | Returns or sets the AutoShape type for a PictureFrame. There are allowable all items of the set ShapeType, except all sorts of lines: ShapeType.Line, ShapeType.StraightConnector1, ShapeType.BentConnector2, ShapeType.BentConnector3, ShapeType.BentConnector4, ShapeType.BentConnector5, ShapeType.CurvedConnector2, ShapeType.CurvedConnector3, ShapeType.CurvedConnector4, ShapeType.CurvedConnector5. Read/write ShapeType.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateShapeElements (inherited from GeometryShape) | Creates and returns array of shape's elements.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

PictureFrame Class | Aspose.Slides Namespace


PictureFrame Properties

The properties of the PictureFrame class are listed below. For a complete list of PictureFrame class members, see the PictureFrame Members topic.

Public Instance Properties

Adjustments (inherited from GeometryShape) | Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
PictureFormat | Returns the PictureFillFormat object for a picture frame. Read-only PictureFillFormat.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
RelativeScaleHeight | Returns or sets the scale of height(relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.
RelativeScaleWidth | Returns or sets the scale of width (relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock | Overloaded. Returns shape's locks. Readonly PictureFrameLock.
ShapeStyle (inherited from GeometryShape) | Returns shape's style object. Read-only ShapeStyle.
ShapeType | Returns or sets the AutoShape type for a PictureFrame. There are allowable all items of the set ShapeType, except all sorts of lines: ShapeType.Line, ShapeType.StraightConnector1, ShapeType.BentConnector2, ShapeType.BentConnector3, ShapeType.BentConnector4, ShapeType.BentConnector5, ShapeType.CurvedConnector2, ShapeType.CurvedConnector3, ShapeType.CurvedConnector4, ShapeType.CurvedConnector5. Read/write ShapeType.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

PictureFrame Class | Aspose.Slides Namespace


PictureFormat Property

Aspose.Slides Documentation

PictureFrame.PictureFormat Property

Returns the PictureFillFormat object for a picture frame. Read-only PictureFillFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property PictureFormat As IPictureFillFormat _
Implements IPictureFrame.PictureFormat
[C#]
public IPictureFillFormat PictureFormat {get;}

Implements

IPictureFrame.PictureFormat

See Also

PictureFrame Class | Aspose.Slides Namespace


RelativeScaleHeight Property

Aspose.Slides Documentation

PictureFrame.RelativeScaleHeight Property

Returns or sets the scale of height(relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.

[Visual Basic]
NotOverridable Public Property RelativeScaleHeight As Single _
Implements IPictureFrame.RelativeScaleHeight
[C#]
public float RelativeScaleHeight {get; set;}

Implements

IPictureFrame.RelativeScaleHeight

See Also

PictureFrame Class | Aspose.Slides Namespace


RelativeScaleWidth Property

Aspose.Slides Documentation

PictureFrame.RelativeScaleWidth Property

Returns or sets the scale of width (relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.

[Visual Basic]
NotOverridable Public Property RelativeScaleWidth As Single _
Implements IPictureFrame.RelativeScaleWidth
[C#]
public float RelativeScaleWidth {get; set;}

Implements

IPictureFrame.RelativeScaleWidth

See Also

PictureFrame Class | Aspose.Slides Namespace


ShapeLock Property

Aspose.Slides Documentation

PictureFrame.ShapeLock Property

Returns shape's locks. Readonly PictureFrameLock.

[Visual Basic]
NotOverridable Overloads Public ReadOnly Property ShapeLock As IPictureFrameLock _
Implements IPictureFrame.ShapeLock
[C#]
new public IPictureFrameLock ShapeLock {get;}

Implements

IPictureFrame.ShapeLock

See Also

PictureFrame Class | Aspose.Slides Namespace


ShapeType Property

Aspose.Slides Documentation

PictureFrame.ShapeType Property

Returns or sets the AutoShape type for a PictureFrame. There are allowable all items of the set ShapeType, except all sorts of lines:

ShapeType.Line,

ShapeType.StraightConnector1,

ShapeType.BentConnector2,

ShapeType.BentConnector3,

ShapeType.BentConnector4,

ShapeType.BentConnector5,

ShapeType.CurvedConnector2,

ShapeType.CurvedConnector3,

ShapeType.CurvedConnector4,

ShapeType.CurvedConnector5.

Read/write ShapeType.

[Visual Basic]
Overrides Public Property ShapeType As ShapeType _
Implements IGeometryShape.ShapeType
[C#]
public override ShapeType ShapeType {get; set;}

Implements

IGeometryShape.ShapeType

See Also

PictureFrame Class | Aspose.Slides Namespace


PictureFrameLock Class

Determines which operations are disabled on the parent PictureFrame.

For a list of all members of this type, see PictureFrameLock Members.

System.Object
Aspose.Slides.BaseShapeLock
Aspose.Slides.PictureFrameLock

[Visual Basic]
Public Class PictureFrameLock
Inherits BaseShapeLock
Implements IPictureFrameLock
[C#]
public class PictureFrameLock : BaseShapeLock, IPictureFrameLock

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PictureFrameLock Members | Aspose.Slides Namespace


PictureFrameLock Members

PictureFrameLock overview

Public Instance Properties

AdjustHandlesLocked | Determines whether a changing adjust values is forbidden.
ArrowheadsLocked | Determines whether a changing arrowheads is forbidden.
AspectRatioLocked | Determines whether a shape have to preserve aspect ratio on resizing.
CropLocked | Determines whether an image cropping is forbidden.
EditPointsLocked | Determines whether a direct changing of contour of this shape is forbidden.
GroupingLocked | Determines whether an adding this shape to a group is forbidden.
NoLocks (inherited from BaseShapeLock) | Return true if all lock-flags are disabled.
PositionLocked | Determines whether a moving this shape is forbidden.
RotationLocked | Determines whether a changing rotation angle of this shape is forbidden.
SelectLocked | Determines whether a selecting this shape is forbidden.
ShapeTypeLocked | Determines whether a changing of a shape type is forbidden.
SizeLocked | Determines whether a resizing this shape is forbidden.

See Also

PictureFrameLock Class | Aspose.Slides Namespace


PictureFrameLock Properties

The properties of the PictureFrameLock class are listed below. For a complete list of PictureFrameLock class members, see the PictureFrameLock Members topic.

Public Instance Properties

AdjustHandlesLocked | Determines whether a changing adjust values is forbidden.
ArrowheadsLocked | Determines whether a changing arrowheads is forbidden.
AspectRatioLocked | Determines whether a shape have to preserve aspect ratio on resizing.
CropLocked | Determines whether an image cropping is forbidden.
EditPointsLocked | Determines whether a direct changing of contour of this shape is forbidden.
GroupingLocked | Determines whether an adding this shape to a group is forbidden.
NoLocks (inherited from BaseShapeLock) | Return true if all lock-flags are disabled.
PositionLocked | Determines whether a moving this shape is forbidden.
RotationLocked | Determines whether a changing rotation angle of this shape is forbidden.
SelectLocked | Determines whether a selecting this shape is forbidden.
ShapeTypeLocked | Determines whether a changing of a shape type is forbidden.
SizeLocked | Determines whether a resizing this shape is forbidden.

See Also

PictureFrameLock Class | Aspose.Slides Namespace


AdjustHandlesLocked Property

Aspose.Slides Documentation

PictureFrameLock.AdjustHandlesLocked Property

Determines whether a changing adjust values is forbidden.

[Visual Basic]
NotOverridable Public Property AdjustHandlesLocked As Boolean _
Implements IPictureFrameLock.AdjustHandlesLocked
[C#]
public bool AdjustHandlesLocked {get; set;}

Implements

IPictureFrameLock.AdjustHandlesLocked

See Also

PictureFrameLock Class | Aspose.Slides Namespace


ArrowheadsLocked Property

Aspose.Slides Documentation

PictureFrameLock.ArrowheadsLocked Property

Determines whether a changing arrowheads is forbidden.

[Visual Basic]
NotOverridable Public Property ArrowheadsLocked As Boolean _
Implements IPictureFrameLock.ArrowheadsLocked
[C#]
public bool ArrowheadsLocked {get; set;}

Implements

IPictureFrameLock.ArrowheadsLocked

See Also

PictureFrameLock Class | Aspose.Slides Namespace


AspectRatioLocked Property

Aspose.Slides Documentation

PictureFrameLock.AspectRatioLocked Property

Determines whether a shape have to preserve aspect ratio on resizing.

[Visual Basic]
NotOverridable Public Property AspectRatioLocked As Boolean _
Implements IPictureFrameLock.AspectRatioLocked
[C#]
public bool AspectRatioLocked {get; set;}

Implements

IPictureFrameLock.AspectRatioLocked

See Also

PictureFrameLock Class | Aspose.Slides Namespace


CropLocked Property

Aspose.Slides Documentation

PictureFrameLock.CropLocked Property

Determines whether an image cropping is forbidden.

[Visual Basic]
NotOverridable Public Property CropLocked As Boolean _
Implements IPictureFrameLock.CropLocked
[C#]
public bool CropLocked {get; set;}

Implements

IPictureFrameLock.CropLocked

See Also

PictureFrameLock Class | Aspose.Slides Namespace


EditPointsLocked Property

Aspose.Slides Documentation

PictureFrameLock.EditPointsLocked Property

Determines whether a direct changing of contour of this shape is forbidden.

[Visual Basic]
NotOverridable Public Property EditPointsLocked As Boolean _
Implements IPictureFrameLock.EditPointsLocked
[C#]
public bool EditPointsLocked {get; set;}

Implements

IPictureFrameLock.EditPointsLocked

See Also

PictureFrameLock Class | Aspose.Slides Namespace


GroupingLocked Property

Aspose.Slides Documentation

PictureFrameLock.GroupingLocked Property

Determines whether an adding this shape to a group is forbidden.

[Visual Basic]
NotOverridable Public Property GroupingLocked As Boolean _
Implements IPictureFrameLock.GroupingLocked
[C#]
public bool GroupingLocked {get; set;}

Implements

IPictureFrameLock.GroupingLocked

See Also

PictureFrameLock Class | Aspose.Slides Namespace


PositionLocked Property

Aspose.Slides Documentation

PictureFrameLock.PositionLocked Property

Determines whether a moving this shape is forbidden.

[Visual Basic]
NotOverridable Public Property PositionLocked As Boolean _
Implements IPictureFrameLock.PositionLocked
[C#]
public bool PositionLocked {get; set;}

Implements

IPictureFrameLock.PositionLocked

See Also

PictureFrameLock Class | Aspose.Slides Namespace


RotationLocked Property

Aspose.Slides Documentation

PictureFrameLock.RotationLocked Property

Determines whether a changing rotation angle of this shape is forbidden.

[Visual Basic]
NotOverridable Public Property RotationLocked As Boolean _
Implements IPictureFrameLock.RotationLocked
[C#]
public bool RotationLocked {get; set;}

Implements

IPictureFrameLock.RotationLocked

See Also

PictureFrameLock Class | Aspose.Slides Namespace


SelectLocked Property

Aspose.Slides Documentation

PictureFrameLock.SelectLocked Property

Determines whether a selecting this shape is forbidden.

[Visual Basic]
NotOverridable Public Property SelectLocked As Boolean _
Implements IPictureFrameLock.SelectLocked
[C#]
public bool SelectLocked {get; set;}

Implements

IPictureFrameLock.SelectLocked

See Also

PictureFrameLock Class | Aspose.Slides Namespace


ShapeTypeLocked Property

Aspose.Slides Documentation

PictureFrameLock.ShapeTypeLocked Property

Determines whether a changing of a shape type is forbidden.

[Visual Basic]
NotOverridable Public Property ShapeTypeLocked As Boolean _
Implements IPictureFrameLock.ShapeTypeLocked
[C#]
public bool ShapeTypeLocked {get; set;}

Implements

IPictureFrameLock.ShapeTypeLocked

See Also

PictureFrameLock Class | Aspose.Slides Namespace


SizeLocked Property

Aspose.Slides Documentation

PictureFrameLock.SizeLocked Property

Determines whether a resizing this shape is forbidden.

[Visual Basic]
NotOverridable Public Property SizeLocked As Boolean _
Implements IPictureFrameLock.SizeLocked
[C#]
public bool SizeLocked {get; set;}

Implements

IPictureFrameLock.SizeLocked

See Also

PictureFrameLock Class | Aspose.Slides Namespace


Placeholder Class

Represents a placeholder on a slide.

For a list of all members of this type, see Placeholder Members.

System.Object
Aspose.Slides.Placeholder

[Visual Basic]
Public Class Placeholder
Implements IPlaceholder
[C#]
public class Placeholder : IPlaceholder

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Placeholder Members | Aspose.Slides Namespace


Placeholder Members

Placeholder overview

Public Instance Properties

Index | Gets or sets the index of a placeholder.
Orientation | Gets or sets the orientation of a placeholder.
Size | Gets or sets the size of a placeholder.
Type | Gets or sets the type of a placeholder.

See Also

Placeholder Class | Aspose.Slides Namespace


Placeholder Properties

The properties of the Placeholder class are listed below. For a complete list of Placeholder class members, see the Placeholder Members topic.

Public Instance Properties

Index | Gets or sets the index of a placeholder.
Orientation | Gets or sets the orientation of a placeholder.
Size | Gets or sets the size of a placeholder.
Type | Gets or sets the type of a placeholder.

See Also

Placeholder Class | Aspose.Slides Namespace


Index Property

Aspose.Slides Documentation

Placeholder.Index Property

Gets or sets the index of a placeholder.

[Visual Basic]
NotOverridable Public ReadOnly Property Index As UInt32 _
Implements IPlaceholder.Index
[C#]
public uint Index {get;}

Implements

IPlaceholder.Index

See Also

Placeholder Class | Aspose.Slides Namespace


Orientation Property

Aspose.Slides Documentation

Placeholder.Orientation Property

Gets or sets the orientation of a placeholder.

[Visual Basic]
NotOverridable Public ReadOnly Property Orientation As Orientation _
Implements IPlaceholder.Orientation
[C#]
public Orientation Orientation {get;}

Implements

IPlaceholder.Orientation

See Also

Placeholder Class | Aspose.Slides Namespace


Size Property

Aspose.Slides Documentation

Placeholder.Size Property

Gets or sets the size of a placeholder.

[Visual Basic]
NotOverridable Public ReadOnly Property Size As PlaceholderSize _
Implements IPlaceholder.Size
[C#]
public PlaceholderSize Size {get;}

Implements

IPlaceholder.Size

See Also

Placeholder Class | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

Placeholder.Type Property

Gets or sets the type of a placeholder.

[Visual Basic]
NotOverridable Public ReadOnly Property Type As PlaceholderType _
Implements IPlaceholder.Type
[C#]
public PlaceholderType Type {get;}

Implements

IPlaceholder.Type

See Also

Placeholder Class | Aspose.Slides Namespace


PlaceholderSize Enumeration

[Visual Basic]
Public Enum PlaceholderSize
Inherits
[C#]
public enum PlaceholderSize

Members

Member Name | Description | Value
Full |  | 0
Half |  | 1
Quarter |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


PlaceholderType Enumeration

[Visual Basic]
Public Enum PlaceholderType
Inherits
[C#]
public enum PlaceholderType

Members

Member Name | Description | Value
Title |  | 0
Body |  | 1
CenteredTitle |  | 2
Subtitle |  | 3
DateAndTime |  | 4
SlideNumber |  | 5
Footer |  | 6
Header |  | 7
Object |  | 8
Chart |  | 9
Table |  | 10
ClipArt |  | 11
Diagram |  | 12
Media |  | 13
SlideImage |  | 14
Picture |  | 15

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


Portion Class

Represents a portion of text inside a text paragraph.

For a list of all members of this type, see Portion Members.

System.Object
Aspose.Slides.Portion

[Visual Basic]
NotInheritable Public Class Portion
Implements IPortion, ISlideComponent, IPresentationComponent
[C#]
public sealed class Portion : IPortion, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Portion Members | Aspose.Slides Namespace


Portion Members

Portion overview

Public Instance Constructors

Portion Overloaded. Initializes a new instance of the Portion class.

Public Instance Properties

Field | Returns a field of this portion. Readonly Field.
PortionFormat | Returns oformatting bject which contains explicitly set formatting properties of the text portion with no inheritance applied. Readonly PortionFormat.
Text | Gets or sets the plain text of a portion..

Public Instance Methods

AddField | Overloaded. Converts this portion to the automaticaly updated field.
CreatePortionFormatEffective | Creates and returns PortionFormatEffectiveData object which contains current portion formatting properties, including inherited.
RemoveField | Converts this field portion to the simple portion.

See Also

Portion Class | Aspose.Slides Namespace


Portion Constructor

Initializes a new instance of the Portion class.

Overload List

Initializes a new instance of the Portion class.

public Portion();

Initializes a new instance of the Portion class.

public Portion(Portion);

Initializes a new instance of the Portion class.

public Portion(string);

See Also

Portion Class | Aspose.Slides Namespace


Portion Constructor ()

Initializes a new instance of the Portion class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Portion();

See Also

Portion Class | Aspose.Slides Namespace | Portion Constructor Overload List


Portion Constructor (String)

Initializes a new instance of the Portion class.

[Visual Basic]
Overloads Public Sub New( _
ByVal str As String _
)
[C#]
public Portion(
string str
);

See Also

Portion Class | Aspose.Slides Namespace | Portion Constructor Overload List


Portion Constructor (Portion)

Initializes a new instance of the Portion class.

[Visual Basic]
Overloads Public Sub New( _
ByVal portion As Portion _
)
[C#]
public Portion(
Portion portion
);

See Also

Portion Class | Aspose.Slides Namespace | Portion Constructor Overload List


Portion Properties

The properties of the Portion class are listed below. For a complete list of Portion class members, see the Portion Members topic.

Public Instance Properties

Field | Returns a field of this portion. Readonly Field.
PortionFormat | Returns oformatting bject which contains explicitly set formatting properties of the text portion with no inheritance applied. Readonly PortionFormat.
Text | Gets or sets the plain text of a portion..

See Also

Portion Class | Aspose.Slides Namespace


Field Property

Aspose.Slides Documentation

Portion.Field Property

Returns a field of this portion. Readonly Field.

[Visual Basic]
NotOverridable Public ReadOnly Property Field As IField _
Implements IPortion.Field
[C#]
public IField Field {get;}

Implements

IPortion.Field

See Also

Portion Class | Aspose.Slides Namespace


PortionFormat Property

Aspose.Slides Documentation

Portion.PortionFormat Property

Returns oformatting bject which contains explicitly set formatting properties of the text portion with no inheritance applied. Readonly PortionFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property PortionFormat As IPortionFormat _
Implements IPortion.PortionFormat
[C#]
public IPortionFormat PortionFormat {get;}

Implements

IPortion.PortionFormat

Remarks

The formatting object contains the formatting parameters defined for the current portion only, inherited data is not applied.

In order to get the effective values including inherited ones use the CreatePortionFormatEffective method.

See Also

Portion Class | Aspose.Slides Namespace


Text Property

Aspose.Slides Documentation

Portion.Text Property

Gets or sets the plain text of a portion..

[Visual Basic]
NotOverridable Public Property Text As String _
Implements IPortion.Text
[C#]
public string Text {get; set;}

Property Value

The text.

Implements

IPortion.Text

See Also

Portion Class | Aspose.Slides Namespace


Portion Methods

The methods of the Portion class are listed below. For a complete list of Portion class members, see the Portion Members topic.

Public Instance Methods

AddField | Overloaded. Converts this portion to the automaticaly updated field.
CreatePortionFormatEffective | Creates and returns PortionFormatEffectiveData object which contains current portion formatting properties, including inherited.
RemoveField | Converts this field portion to the simple portion.

See Also

Portion Class | Aspose.Slides Namespace


AddField Method

Aspose.Slides Documentation

Portion.AddField Method

Converts this portion to the automaticaly updated field.

Overload List

Converts this portion to the automaticaly updated field.

public void AddField(IFieldType);

Converts this portion to the automaticaly updated field.

public void AddField(string);

See Also

Portion Class | Aspose.Slides Namespace


Portion.AddField Method (IFieldType)

Converts this portion to the automaticaly updated field.

[Visual Basic]
NotOverridable Overloads Public Sub AddField( _
ByVal fieldType As IFieldType _
) _
Implements IPortion.AddField
[C#]
public void AddField(
IFieldType fieldType
);

Implements

IPortion.AddField

See Also

Portion Class | Aspose.Slides Namespace | Portion.AddField Overload List


Portion.AddField Method (String)

Converts this portion to the automaticaly updated field.

[Visual Basic]
NotOverridable Overloads Public Sub AddField( _
ByVal internalString As String _
) _
Implements IPortion.AddField
[C#]
public void AddField(
string internalString
);

Parameters

internalString
Internal name of FieldType.

Implements

IPortion.AddField

See Also

Portion Class | Aspose.Slides Namespace | Portion.AddField Overload List


Portion.CreatePortionFormatEffective Method

Creates and returns PortionFormatEffectiveData object which contains current portion formatting properties, including inherited.

[Visual Basic]
NotOverridable Public Function CreatePortionFormatEffective() As IPortionFormatEffectiveData _
Implements IPortion.CreatePortionFormatEffective
[C#]
public IPortionFormatEffectiveData CreatePortionFormatEffective();

Return Value

A PortionFormatEffectiveData instance.

Implements

IPortion.CreatePortionFormatEffective

See Also

Portion Class | Aspose.Slides Namespace


Portion.RemoveField Method

Converts this field portion to the simple portion.

[Visual Basic]
NotOverridable Public Sub RemoveField() _
Implements IPortion.RemoveField
[C#]
public void RemoveField();

Implements

IPortion.RemoveField

See Also

Portion Class | Aspose.Slides Namespace


PortionCollection Class

Represents a collection of a portions.

For a list of all members of this type, see PortionCollection Members.

System.Object
Aspose.Slides.PortionCollection

[Visual Basic]
NotInheritable Public Class PortionCollection
Implements IPortionCollection, IEnumerable`1([Aspose.Slides.IPortion, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public sealed class PortionCollection : IPortionCollection, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PortionCollection Members | Aspose.Slides Namespace


PortionCollection Members

PortionCollection overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsReadOnly | Gets a value indicating whether the ICollection`1 is read-only.
Item | Gets the element at the specified index.

Public Instance Methods

Add | Adds a Portion to the end of collection.
Clear | Removes all elements from the collection.
Contains | Determines whether the ICollection`1 contains a specific value.
CopyTo | Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.
GetEnumerator | Returns an enumerator for the entire collection.
IndexOf | Determines the index of a specific item in the IList`1.
Insert | Inserts a Portion into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the ICollection`1.
RemoveAt | Removes the element at the specified index of the collection.

See Also

PortionCollection Class | Aspose.Slides Namespace


PortionCollection Properties

The properties of the PortionCollection class are listed below. For a complete list of PortionCollection class members, see the PortionCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsReadOnly | Gets a value indicating whether the ICollection`1 is read-only.
Item | Gets the element at the specified index.

See Also

PortionCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

PortionCollection.Count Property

Gets the number of elements actually contained in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements IPortionCollection.Count
[C#]
public int Count {get;}

Implements

IPortionCollection.Count

See Also

PortionCollection Class | Aspose.Slides Namespace


IsReadOnly Property

Aspose.Slides Documentation

PortionCollection.IsReadOnly Property

Gets a value indicating whether the ICollection`1 is read-only.

[Visual Basic]
Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {get;}

See Also

PortionCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

PortionCollection.Item Property

Gets the element at the specified index.

[Visual Basic]
NotOverridable Public Default Property Item( _
ByVal index As Integer _
) _
Implements IPortionCollection.Item
As IPortion _
Implements IPortionCollection.Item
[C#]
public IPortion this[
int index
] {get; set;}

Implements

IPortionCollection.Item

See Also

PortionCollection Class | Aspose.Slides Namespace


PortionCollection Methods

The methods of the PortionCollection class are listed below. For a complete list of PortionCollection class members, see the PortionCollection Members topic.

Public Instance Methods

Add | Adds a Portion to the end of collection.
Clear | Removes all elements from the collection.
Contains | Determines whether the ICollection`1 contains a specific value.
CopyTo | Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.
GetEnumerator | Returns an enumerator for the entire collection.
IndexOf | Determines the index of a specific item in the IList`1.
Insert | Inserts a Portion into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the ICollection`1.
RemoveAt | Removes the element at the specified index of the collection.

See Also

PortionCollection Class | Aspose.Slides Namespace


PortionCollection.Add Method

Adds a Portion to the end of collection.

[Visual Basic]
NotOverridable Public Sub Add( _
ByVal value As IPortion _
) _
Implements IPortionCollection.Add
[C#]
public void Add(
IPortion value
);

Parameters

value
The Portion to be added to the end of the collection.

Return Value

The index at which the Portion has been added.

Implements

IPortionCollection.Add

See Also

PortionCollection Class | Aspose.Slides Namespace


PortionCollection.Clear Method

Removes all elements from the collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IPortionCollection.Clear
[C#]
public void Clear();

Implements

IPortionCollection.Clear

See Also

PortionCollection Class | Aspose.Slides Namespace


PortionCollection.Contains Method

Determines whether the ICollection`1 contains a specific value.

[Visual Basic]
NotOverridable Public Function Contains( _
ByVal item As IPortion _
) As Boolean _
Implements IPortionCollection.Contains
[C#]
public bool Contains(
IPortion item
);

Parameters

item
The object to locate in the ICollection`1.

Return Value

true if item is found in the ICollection`1; otherwise, false.

Implements

IPortionCollection.Contains

See Also

PortionCollection Class | Aspose.Slides Namespace


PortionCollection.CopyTo Method

Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As IPortion(), _
ByVal arrayIndex As Integer _
)
[C#]
public void CopyTo(
IPortion[] array,
int arrayIndex
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from ICollection`1. The Array must have zero-based indexing.
arrayIndex
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | The number of elements in the source ICollection`1 is greater than the available space from arrayIndex to the end of the destination array.

See Also

PortionCollection Class | Aspose.Slides Namespace


PortionCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

PortionCollection Class | Aspose.Slides Namespace


PortionCollection.IndexOf Method

Determines the index of a specific item in the IList`1.

[Visual Basic]
NotOverridable Public Function IndexOf( _
ByVal item As IPortion _
) As Integer _
Implements IPortionCollection.IndexOf
[C#]
public int IndexOf(
IPortion item
);

Parameters

item
The object to locate in the IList`1.

Return Value

The index of item if found in the list; otherwise, -1.

Implements

IPortionCollection.IndexOf

See Also

PortionCollection Class | Aspose.Slides Namespace


PortionCollection.Insert Method

Inserts a Portion into the collection at the specified index.

[Visual Basic]
NotOverridable Public Sub Insert( _
ByVal index As Integer, _
ByVal value As IPortion _
) _
Implements IPortionCollection.Insert
[C#]
public void Insert(
int index,
IPortion value
);

Parameters

index
The zero-based index at which Portion should be inserted.
value
The Portion to insert.

Implements

IPortionCollection.Insert

See Also

PortionCollection Class | Aspose.Slides Namespace


PortionCollection.Remove Method

Removes the first occurrence of a specific object from the ICollection`1.

[Visual Basic]
NotOverridable Public Function Remove( _
ByVal item As IPortion _
) As Boolean _
Implements IPortionCollection.Remove
[C#]
public bool Remove(
IPortion item
);

Parameters

item
The object to remove from the ICollection`1.

Return Value

true if item was successfully removed from the ICollection`1; otherwise, false. This method also returns false if item is not found in the original ICollection`1.

Implements

IPortionCollection.Remove

Exceptions

Exception Type | Condition
NotSupportedException | The ICollection`1 is read-only.

See Also

PortionCollection Class | Aspose.Slides Namespace


PortionCollection.RemoveAt Method

Removes the element at the specified index of the collection.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IPortionCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Implements

IPortionCollection.RemoveAt

See Also

PortionCollection Class | Aspose.Slides Namespace


PortionFactory Class

Allows to create test portions

For a list of all members of this type, see PortionFactory Members.

System.Object
Aspose.Slides.PortionFactory

[Visual Basic]
Public Class PortionFactory
Implements IPortionFactory
[C#]
public class PortionFactory : IPortionFactory

Remarks

For COM comparibility

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PortionFactory Members | Aspose.Slides Namespace


PortionFactory Members

PortionFactory overview

Public Instance Constructors

PortionFactory Constructor Initializes a new instance of the PortionFactory class.

Public Instance Methods

CreatePortion Overloaded.

See Also

PortionFactory Class | Aspose.Slides Namespace


PortionFactory Constructor

Initializes a new instance of the PortionFactory class.

[Visual Basic]
Public Sub New()
[C#]
public PortionFactory();

See Also

PortionFactory Class | Aspose.Slides Namespace


PortionFactory Methods

The methods of the PortionFactory class are listed below. For a complete list of PortionFactory class members, see the PortionFactory Members topic.

Public Instance Methods

CreatePortion Overloaded.

See Also

PortionFactory Class | Aspose.Slides Namespace


CreatePortion Method

Aspose.Slides Documentation

PortionFactory.CreatePortion Method

Overload List

public IPortion CreatePortion();

public IPortion CreatePortion(IPortion);

public IPortion CreatePortion(string);

See Also

PortionFactory Class | Aspose.Slides Namespace


PortionFactory.CreatePortion Method ()

[Visual Basic]
NotOverridable Overloads Public Function CreatePortion() As IPortion _
Implements IPortionFactory.CreatePortion
[C#]
public IPortion CreatePortion();

Implements

IPortionFactory.CreatePortion

See Also

PortionFactory Class | Aspose.Slides Namespace | PortionFactory.CreatePortion Overload List


PortionFactory.CreatePortion Method (IPortion)

[Visual Basic]
NotOverridable Overloads Public Function CreatePortion( _
ByVal portion As IPortion _
) As IPortion _
Implements IPortionFactory.CreatePortion
[C#]
public IPortion CreatePortion(
IPortion portion
);

Implements

IPortionFactory.CreatePortion

See Also

PortionFactory Class | Aspose.Slides Namespace | PortionFactory.CreatePortion Overload List


PortionFactory.CreatePortion Method (String)

[Visual Basic]
NotOverridable Overloads Public Function CreatePortion( _
ByVal str As String _
) As IPortion _
Implements IPortionFactory.CreatePortion
[C#]
public IPortion CreatePortion(
string str
);

Implements

IPortionFactory.CreatePortion

See Also

PortionFactory Class | Aspose.Slides Namespace | PortionFactory.CreatePortion Overload List


PortionFormat Class

This class contains the text portion formatting properties. Unlike PortionFormatEffectiveData, all properties of this class are writeable.

For a list of all members of this type, see PortionFormat Members.

System.Object
Aspose.Slides.PortionFormat

[Visual Basic]
Public Class PortionFormat
Implements IPortionFormat, IHyperlinkContainer, IChartPortionFormat
[C#]
public class PortionFormat : IPortionFormat, IHyperlinkContainer, IChartPortionFormat

Remarks

This class is used to return and manipulate text portion formatting properties defined for the particular portion. This means that no inheritance is applied when getting values so for the majority of cases you will get values meaning "undefined".

In order to get the effective formatting parameter values including inherited you need to use CreatePortionFormatEffective method which returns a CreatePortionFormatEffective instance.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PortionFormat Members | Aspose.Slides Namespace


PortionFormat Members

PortionFormat overview

Public Instance Constructors

PortionFormat Overloaded. Initializes a new instance of the PortionFormat class.

Public Instance Properties

AlternativeLanguageId | Returns or sets the Id of an alternative language. Read/write String.
ComplexScriptFont | Returns or sets the complex script font info. Null means font is undefined and should be inherited from the Master. Read/write FontData.
EastAsianFont | Returns or sets the East Asian font info. Null means font is undefined and should be inherited from the Master. Read/write FontData.
EffectFormat | Returns the text EffectFormat properties. No inheritance applied. Read-only EffectFormat.
Escapement | Returns or sets the superscript or subscript text. Value from -100% (subscript) to 100% (superscript). float.NaN means value is undefined and should be inherited from the Master. Read/write Int16.
FillFormat | Returns the text FillFormat properties. No inheritance applied. Read-only FillFormat.
FontBold | Determines whether the font is bold. No inheritance applied. Read/write NullableBool.
FontHeight | Returns or sets the font height of a portion. float.NaN means height is undefined and should be inherited from the Master. Read/write Int16.
FontItalic | Determines whether the font is itallic. No inheritance applied. Read/write NullableBool.
FontUnderline | Returns or sets the text underline type. No inheritance applied. Read/write TextUnderlineType.
HighlightColor | Returns the color used to highlight a text. No inheritance applied. Read-only ColorFormat.
HLinkClick | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsHardUnderlineFill | Determines whether the underline style has own FillFormat properties or inherits it from the FillFormat properties of the text. Read/write NullableBool.
IsHardUnderlineLine | Determines whether the underline style has own LineFormat properties or inherits it from the LineFormat properties of the text. Read/write NullableBool.
KerningMinimalSize | Returns or sets the minimal font size, for which kerning should be switched on. float.NaN means value is undefined and should be inherited from the Master. Read/write Single.
Kumimoji | Determines whether the numbers should ignore text eastern language-specific vertical text layout. No inheritance applied. Read/write NullableBool.
LanguageId | Returns or sets the Id of a language. Read/write String.
LatinFont | Returns or sets the Latin font info. Null means font is undefined and should be inherited from the Master. Read/write FontData.
LineFormat | Returns the LineFormat properties for text outlining. No inheritance applied. Read-only LineFormat.
NormaliseHeight | Determines whether the height of a text should be normalized. No inheritance applied. Read/write NullableBool.
ProofDisabled | Determines whether the text shouldn't be proofed. No inheritance applied. Read/write NullableBool.
Spacing | Returns or sets the intercharacter spacing increment. float.NaN means value is undefined and should be inherited from the Master. Read/write Single.
StrikethroughType | Returns or sets the strikethrough type of a text. No inheritance applied. Read/write TextStrikethroughType.
SymbolFont | Returns or sets the symbolic font info. Null means font is undefined and should be inherited from the Master. Read/write FontData.
TextCapType | Returns or sets the type of text capitalization. No inheritance applied. Read/write TextCapType.
UnderlineFillFormat | Returns the underline line FillFormat properties. No inheritance applied. Read-only FillFormat.
UnderlineLineFormat | Returns the LineFormat properties used to outline underline line. No inheritance applied. Read-only LineFormat.

See Also

PortionFormat Class | Aspose.Slides Namespace


PortionFormat Constructor

Initializes a new instance of the TextCharacterPropertiesEx class.

Overload List

Initializes a new instance of the TextCharacterPropertiesEx class.

public PortionFormat(ParagraphFormat);

Initializes a new instance of the TextCharacterPropertiesEx class.

public PortionFormat(Portion);

Initializes a new instance of the TextCharacterPropertiesEx class.

public PortionFormat(PortionFormat);

See Also

PortionFormat Class | Aspose.Slides Namespace


PortionFormat Constructor (Portion)

Initializes a new instance of the TextCharacterPropertiesEx class.

[Visual Basic]
Overloads Public Sub New( _
ByVal parentPortion As Portion _
)
[C#]
public PortionFormat(
Portion parentPortion
);

See Also

PortionFormat Class | Aspose.Slides Namespace | PortionFormat Constructor Overload List


PortionFormat Constructor (PortionFormat)

Initializes a new instance of the TextCharacterPropertiesEx class.

[Visual Basic]
Overloads Public Sub New( _
ByVal props As PortionFormat _
)
[C#]
public PortionFormat(
PortionFormat props
);

See Also

PortionFormat Class | Aspose.Slides Namespace | PortionFormat Constructor Overload List


PortionFormat Constructor (ParagraphFormat)

Initializes a new instance of the TextCharacterPropertiesEx class.

[Visual Basic]
Overloads Public Sub New( _
ByVal parentParagraphFormat As ParagraphFormat _
)
[C#]
public PortionFormat(
ParagraphFormat parentParagraphFormat
);

See Also

PortionFormat Class | Aspose.Slides Namespace | PortionFormat Constructor Overload List


PortionFormat Properties

The properties of the PortionFormat class are listed below. For a complete list of PortionFormat class members, see the PortionFormat Members topic.

Public Instance Properties

AlternativeLanguageId | Returns or sets the Id of an alternative language. Read/write String.
ComplexScriptFont | Returns or sets the complex script font info. Null means font is undefined and should be inherited from the Master. Read/write FontData.
EastAsianFont | Returns or sets the East Asian font info. Null means font is undefined and should be inherited from the Master. Read/write FontData.
EffectFormat | Returns the text EffectFormat properties. No inheritance applied. Read-only EffectFormat.
Escapement | Returns or sets the superscript or subscript text. Value from -100% (subscript) to 100% (superscript). float.NaN means value is undefined and should be inherited from the Master. Read/write Int16.
FillFormat | Returns the text FillFormat properties. No inheritance applied. Read-only FillFormat.
FontBold | Determines whether the font is bold. No inheritance applied. Read/write NullableBool.
FontHeight | Returns or sets the font height of a portion. float.NaN means height is undefined and should be inherited from the Master. Read/write Int16.
FontItalic | Determines whether the font is itallic. No inheritance applied. Read/write NullableBool.
FontUnderline | Returns or sets the text underline type. No inheritance applied. Read/write TextUnderlineType.
HighlightColor | Returns the color used to highlight a text. No inheritance applied. Read-only ColorFormat.
HLinkClick | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsHardUnderlineFill | Determines whether the underline style has own FillFormat properties or inherits it from the FillFormat properties of the text. Read/write NullableBool.
IsHardUnderlineLine | Determines whether the underline style has own LineFormat properties or inherits it from the LineFormat properties of the text. Read/write NullableBool.
KerningMinimalSize | Returns or sets the minimal font size, for which kerning should be switched on. float.NaN means value is undefined and should be inherited from the Master. Read/write Single.
Kumimoji | Determines whether the numbers should ignore text eastern language-specific vertical text layout. No inheritance applied. Read/write NullableBool.
LanguageId | Returns or sets the Id of a language. Read/write String.
LatinFont | Returns or sets the Latin font info. Null means font is undefined and should be inherited from the Master. Read/write FontData.
LineFormat | Returns the LineFormat properties for text outlining. No inheritance applied. Read-only LineFormat.
NormaliseHeight | Determines whether the height of a text should be normalized. No inheritance applied. Read/write NullableBool.
ProofDisabled | Determines whether the text shouldn't be proofed. No inheritance applied. Read/write NullableBool.
Spacing | Returns or sets the intercharacter spacing increment. float.NaN means value is undefined and should be inherited from the Master. Read/write Single.
StrikethroughType | Returns or sets the strikethrough type of a text. No inheritance applied. Read/write TextStrikethroughType.
SymbolFont | Returns or sets the symbolic font info. Null means font is undefined and should be inherited from the Master. Read/write FontData.
TextCapType | Returns or sets the type of text capitalization. No inheritance applied. Read/write TextCapType.
UnderlineFillFormat | Returns the underline line FillFormat properties. No inheritance applied. Read-only FillFormat.
UnderlineLineFormat | Returns the LineFormat properties used to outline underline line. No inheritance applied. Read-only LineFormat.

See Also

PortionFormat Class | Aspose.Slides Namespace


AlternativeLanguageId Property

Aspose.Slides Documentation

PortionFormat.AlternativeLanguageId Property

Returns or sets the Id of an alternative language. Read/write String.

[Visual Basic]
NotOverridable Public Property AlternativeLanguageId As String _
Implements IChartPortionFormat.AlternativeLanguageId
[C#]
public string AlternativeLanguageId {get; set;}

Implements

IChartPortionFormat.AlternativeLanguageId

See Also

PortionFormat Class | Aspose.Slides Namespace


ComplexScriptFont Property

Aspose.Slides Documentation

PortionFormat.ComplexScriptFont Property

Returns or sets the complex script font info. Null means font is undefined and should be inherited from the Master. Read/write FontData.

[Visual Basic]
NotOverridable Public Property ComplexScriptFont As IFontData _
Implements IChartPortionFormat.ComplexScriptFont
[C#]
public IFontData ComplexScriptFont {get; set;}

Implements

IChartPortionFormat.ComplexScriptFont

See Also

PortionFormat Class | Aspose.Slides Namespace


EastAsianFont Property

Aspose.Slides Documentation

PortionFormat.EastAsianFont Property

Returns or sets the East Asian font info. Null means font is undefined and should be inherited from the Master. Read/write FontData.

[Visual Basic]
NotOverridable Public Property EastAsianFont As IFontData _
Implements IChartPortionFormat.EastAsianFont
[C#]
public IFontData EastAsianFont {get; set;}

Implements

IChartPortionFormat.EastAsianFont

See Also

PortionFormat Class | Aspose.Slides Namespace


EffectFormat Property

Aspose.Slides Documentation

PortionFormat.EffectFormat Property

Returns the text EffectFormat properties. No inheritance applied. Read-only EffectFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property EffectFormat As IEffectFormat _
Implements IChartPortionFormat.EffectFormat
[C#]
public IEffectFormat EffectFormat {get;}

Implements

IChartPortionFormat.EffectFormat

See Also

PortionFormat Class | Aspose.Slides Namespace


Escapement Property

Aspose.Slides Documentation

PortionFormat.Escapement Property

Returns or sets the superscript or subscript text. Value from -100% (subscript) to 100% (superscript). float.NaN means value is undefined and should be inherited from the Master. Read/write Int16.

[Visual Basic]
NotOverridable Public Property Escapement As Single _
Implements IChartPortionFormat.Escapement
[C#]
public float Escapement {get; set;}

Implements

IChartPortionFormat.Escapement

See Also

PortionFormat Class | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

PortionFormat.FillFormat Property

Returns the text FillFormat properties. No inheritance applied. Read-only FillFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property FillFormat As IFillFormat _
Implements IChartPortionFormat.FillFormat
[C#]
public IFillFormat FillFormat {get;}

Implements

IChartPortionFormat.FillFormat

See Also

PortionFormat Class | Aspose.Slides Namespace


FontBold Property

Aspose.Slides Documentation

PortionFormat.FontBold Property

Determines whether the font is bold. No inheritance applied. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property FontBold As NullableBool _
Implements IChartPortionFormat.FontBold
[C#]
public NullableBool FontBold {get; set;}

Implements

IChartPortionFormat.FontBold

See Also

PortionFormat Class | Aspose.Slides Namespace


FontHeight Property

Aspose.Slides Documentation

PortionFormat.FontHeight Property

Returns or sets the font height of a portion. float.NaN means height is undefined and should be inherited from the Master. Read/write Int16.

[Visual Basic]
NotOverridable Public Property FontHeight As Single _
Implements IChartPortionFormat.FontHeight
[C#]
public float FontHeight {get; set;}

Implements

IChartPortionFormat.FontHeight

See Also

PortionFormat Class | Aspose.Slides Namespace


FontItalic Property

Aspose.Slides Documentation

PortionFormat.FontItalic Property

Determines whether the font is itallic. No inheritance applied. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property FontItalic As NullableBool _
Implements IChartPortionFormat.FontItalic
[C#]
public NullableBool FontItalic {get; set;}

Implements

IChartPortionFormat.FontItalic

See Also

PortionFormat Class | Aspose.Slides Namespace


FontUnderline Property

Aspose.Slides Documentation

PortionFormat.FontUnderline Property

Returns or sets the text underline type. No inheritance applied. Read/write TextUnderlineType.

[Visual Basic]
NotOverridable Public Property FontUnderline As TextUnderlineType _
Implements IChartPortionFormat.FontUnderline
[C#]
public TextUnderlineType FontUnderline {get; set;}

Implements

IChartPortionFormat.FontUnderline

See Also

PortionFormat Class | Aspose.Slides Namespace


HighlightColor Property

Aspose.Slides Documentation

PortionFormat.HighlightColor Property

Returns the color used to highlight a text. No inheritance applied. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property HighlightColor As IColorFormat _
Implements IChartPortionFormat.HighlightColor
[C#]
public IColorFormat HighlightColor {get;}

Implements

IChartPortionFormat.HighlightColor

See Also

PortionFormat Class | Aspose.Slides Namespace


HLinkClick Property

Aspose.Slides Documentation

PortionFormat.HLinkClick Property

NOTE: This property is now obsolete.

Use HyperlinkClick property instead. Property will be removed after 01.09.2013.

Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.

[Visual Basic]
Public Property HLinkClick As Hyperlink
[C#]
public Hyperlink HLinkClick {get; set;}

See Also

PortionFormat Class | Aspose.Slides Namespace


HLinkMouseOver Property

Aspose.Slides Documentation

PortionFormat.HLinkMouseOver Property

NOTE: This property is now obsolete.

Use HyperlinkMouseOver property instead. Property will be removed after 01.09.2013.

Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.

[Visual Basic]
Public Property HLinkMouseOver As Hyperlink
[C#]
public Hyperlink HLinkMouseOver {get; set;}

See Also

PortionFormat Class | Aspose.Slides Namespace


IsHardUnderlineFill Property

Aspose.Slides Documentation

PortionFormat.IsHardUnderlineFill Property

Determines whether the underline style has own FillFormat properties or inherits it from the FillFormat properties of the text. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property IsHardUnderlineFill As NullableBool _
Implements IChartPortionFormat.IsHardUnderlineFill
[C#]
public NullableBool IsHardUnderlineFill {get; set;}

Implements

IChartPortionFormat.IsHardUnderlineFill

See Also

PortionFormat Class | Aspose.Slides Namespace


IsHardUnderlineLine Property

Aspose.Slides Documentation

PortionFormat.IsHardUnderlineLine Property

Determines whether the underline style has own LineFormat properties or inherits it from the LineFormat properties of the text. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property IsHardUnderlineLine As NullableBool _
Implements IChartPortionFormat.IsHardUnderlineLine
[C#]
public NullableBool IsHardUnderlineLine {get; set;}

Implements

IChartPortionFormat.IsHardUnderlineLine

See Also

PortionFormat Class | Aspose.Slides Namespace


KerningMinimalSize Property

Aspose.Slides Documentation

PortionFormat.KerningMinimalSize Property

Returns or sets the minimal font size, for which kerning should be switched on. float.NaN means value is undefined and should be inherited from the Master. Read/write Single.

[Visual Basic]
NotOverridable Public Property KerningMinimalSize As Single _
Implements IChartPortionFormat.KerningMinimalSize
[C#]
public float KerningMinimalSize {get; set;}

Implements

IChartPortionFormat.KerningMinimalSize

See Also

PortionFormat Class | Aspose.Slides Namespace


Kumimoji Property

Aspose.Slides Documentation

PortionFormat.Kumimoji Property

Determines whether the numbers should ignore text eastern language-specific vertical text layout. No inheritance applied. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property Kumimoji As NullableBool _
Implements IChartPortionFormat.Kumimoji
[C#]
public NullableBool Kumimoji {get; set;}

Implements

IChartPortionFormat.Kumimoji

See Also

PortionFormat Class | Aspose.Slides Namespace


LanguageId Property

Aspose.Slides Documentation

PortionFormat.LanguageId Property

Returns or sets the Id of a language. Read/write String.

[Visual Basic]
NotOverridable Public Property LanguageId As String _
Implements IChartPortionFormat.LanguageId
[C#]
public string LanguageId {get; set;}

Implements

IChartPortionFormat.LanguageId

See Also

PortionFormat Class | Aspose.Slides Namespace


LatinFont Property

Aspose.Slides Documentation

PortionFormat.LatinFont Property

Returns or sets the Latin font info. Null means font is undefined and should be inherited from the Master. Read/write FontData.

[Visual Basic]
NotOverridable Public Property LatinFont As IFontData _
Implements IChartPortionFormat.LatinFont
[C#]
public IFontData LatinFont {get; set;}

Implements

IChartPortionFormat.LatinFont

See Also

PortionFormat Class | Aspose.Slides Namespace


LineFormat Property

Aspose.Slides Documentation

PortionFormat.LineFormat Property

Returns the LineFormat properties for text outlining. No inheritance applied. Read-only LineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property LineFormat As ILineFormat _
Implements IChartPortionFormat.LineFormat
[C#]
public ILineFormat LineFormat {get;}

Implements

IChartPortionFormat.LineFormat

See Also

PortionFormat Class | Aspose.Slides Namespace


NormaliseHeight Property

Aspose.Slides Documentation

PortionFormat.NormaliseHeight Property

Determines whether the height of a text should be normalized. No inheritance applied. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property NormaliseHeight As NullableBool _
Implements IChartPortionFormat.NormaliseHeight
[C#]
public NullableBool NormaliseHeight {get; set;}

Implements

IChartPortionFormat.NormaliseHeight

See Also

PortionFormat Class | Aspose.Slides Namespace


ProofDisabled Property

Aspose.Slides Documentation

PortionFormat.ProofDisabled Property

Determines whether the text shouldn't be proofed. No inheritance applied. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property ProofDisabled As NullableBool _
Implements IChartPortionFormat.ProofDisabled
[C#]
public NullableBool ProofDisabled {get; set;}

Implements

IChartPortionFormat.ProofDisabled

See Also

PortionFormat Class | Aspose.Slides Namespace


Spacing Property

Aspose.Slides Documentation

PortionFormat.Spacing Property

Returns or sets the intercharacter spacing increment. float.NaN means value is undefined and should be inherited from the Master. Read/write Single.

[Visual Basic]
NotOverridable Public Property Spacing As Single _
Implements IChartPortionFormat.Spacing
[C#]
public float Spacing {get; set;}

Implements

IChartPortionFormat.Spacing

See Also

PortionFormat Class | Aspose.Slides Namespace


StrikethroughType Property

Aspose.Slides Documentation

PortionFormat.StrikethroughType Property

Returns or sets the strikethrough type of a text. No inheritance applied. Read/write TextStrikethroughType.

[Visual Basic]
NotOverridable Public Property StrikethroughType As TextStrikethroughType _
Implements IChartPortionFormat.StrikethroughType
[C#]
public TextStrikethroughType StrikethroughType {get; set;}

Implements

IChartPortionFormat.StrikethroughType

See Also

PortionFormat Class | Aspose.Slides Namespace


SymbolFont Property

Aspose.Slides Documentation

PortionFormat.SymbolFont Property

Returns or sets the symbolic font info. Null means font is undefined and should be inherited from the Master. Read/write FontData.

[Visual Basic]
NotOverridable Public Property SymbolFont As IFontData _
Implements IChartPortionFormat.SymbolFont
[C#]
public IFontData SymbolFont {get; set;}

Implements

IChartPortionFormat.SymbolFont

See Also

PortionFormat Class | Aspose.Slides Namespace


TextCapType Property

Aspose.Slides Documentation

PortionFormat.TextCapType Property

Returns or sets the type of text capitalization. No inheritance applied. Read/write TextCapType.

[Visual Basic]
NotOverridable Public Property TextCapType As TextCapType _
Implements IChartPortionFormat.TextCapType
[C#]
public TextCapType TextCapType {get; set;}

Implements

IChartPortionFormat.TextCapType

See Also

PortionFormat Class | Aspose.Slides Namespace


UnderlineFillFormat Property

Aspose.Slides Documentation

PortionFormat.UnderlineFillFormat Property

Returns the underline line FillFormat properties. No inheritance applied. Read-only FillFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property UnderlineFillFormat As IFillFormat _
Implements IChartPortionFormat.UnderlineFillFormat
[C#]
public IFillFormat UnderlineFillFormat {get;}

Implements

IChartPortionFormat.UnderlineFillFormat

See Also

PortionFormat Class | Aspose.Slides Namespace


UnderlineLineFormat Property

Aspose.Slides Documentation

PortionFormat.UnderlineLineFormat Property

Returns the LineFormat properties used to outline underline line. No inheritance applied. Read-only LineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property UnderlineLineFormat As ILineFormat _
Implements IChartPortionFormat.UnderlineLineFormat
[C#]
public ILineFormat UnderlineLineFormat {get;}

Implements

IChartPortionFormat.UnderlineLineFormat

See Also

PortionFormat Class | Aspose.Slides Namespace


PortionFormatEffectiveData Class

Immutable object which contains text portion formatting properties.

For a list of all members of this type, see PortionFormatEffectiveData Members.

System.Object
Aspose.Slides.PortionFormatEffectiveData

[Visual Basic]
Public Class PortionFormatEffectiveData
Implements IPortionFormatEffectiveData
[C#]
public class PortionFormatEffectiveData : IPortionFormatEffectiveData

Remarks

This class is used together with the Portion class to return effective formatting values with inheritance applied.

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PortionFormatEffectiveData Members | Aspose.Slides Namespace | CreatePortionFormatEffective


PortionFormatEffectiveData Members

PortionFormatEffectiveData overview

Public Instance Properties

AlternativeLanguageId | Returns or sets the Id of an alternative language. Readonly String.
BookmarkId | Returns or sets bookmark identifier. Readonly String.
ComplexScriptFont | Returns or sets the complex script font info. Null means font is undefined and should be inherited from the Master. Readonly FontData.
EastAsianFont | Returns or sets the East Asian font info. Null means font is undefined and should be inherited from the Master. Readonly FontData.
EffectFormat | Returns the text EffectFormat properties. Read-only EffectFormat.
Escapement | Returns or sets the superscript or subscript text. Value from -100% (subscript) to 100% (superscript). float.NaN means value is undefined and should be inherited from the Master. Readonly Int16.
FillFormat | Returns the text FillFormat properties. Read-only FillFormat.
FontBold | Determines whether the font is bold. Readonly NullableBool.
FontHeight | Returns or sets the font height of a portion. float.NaN means height is undefined and should be inherited from the Master. Readonly Int16.
FontItalic | Determines whether the font is itallic. Readonly NullableBool.
FontUnderline | Returns or sets the text underline type. Readonly TextUnderlineType.
HighlightColor | Returns the color used to highlight a text. Read-only Color.
HLinkClick | Obsolete. Returns or sets the hyperlink defined for mouse click. Readonly Hyperlink.
HLinkMouseOver | Obsolete. Returns or sets the hyperlink defined for mouse over. Readonly Hyperlink.
HyperlinkClick | Returns or sets the hyperlink defined for mouse click. Readonly Hyperlink.
HyperlinkMouseOver | Returns or sets the hyperlink defined for mouse over. Readonly Hyperlink.
IsHardUnderlineFill | Determines whether the underline style has own FillFormat properties or inherits it from the FillFormat properties of the text. Readonly NullableBool.
IsHardUnderlineLine | Determines whether the underline style has own LineFormat properties or inherits it from the LineFormat properties of the text. Readonly NullableBool.
KerningMinimalSize | Returns or sets the minimal font size, for which kerning should be switched on. float.NaN means value is undefined and should be inherited from the Master. Readonly Single.
Kumimoji | Determines whether the numbers should ignore text eastern language-specific vertical text layout. Readonly NullableBool.
LanguageId | Returns or sets the Id of a language. Readonly String.
LatinFont | Returns or sets the Latin font info. Null means font is undefined and should be inherited from the Master. Readonly FontData.
LineFormat | Returns the LineFormat properties for text outlining. Read-only LineFormat.
NormaliseHeight | Determines whether the height of a text should be normalized. Readonly NullableBool.
ProofDisabled | Determines whether the text shouldn't be proofed. Readonly NullableBool.
SmartTagClean | Determines whether the smart tag should be cleaned. Readonly Boolean.
Spacing | Returns or sets the intercharacter spacing increment. float.NaN means value is undefined and should be inherited from the Master. Readonly Single.
StrikethroughType | Returns or sets the strikethrough type of a text. Readonly TextStrikethroughType.
SymbolFont | Returns or sets the symbolic font info. Null means font is undefined and should be inherited from the Master. Readonly FontData.
TextCapType | Returns or sets the type of text capitalization. Readonly TextCapType.
UnderlineFillFormat | Returns the underline line FillFormat properties. Read-only FillFormat.
UnderlineLineFormat | Returns the LineFormat properties used to outline underline line. Read-only LineFormat.

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace | CreatePortionFormatEffective


PortionFormatEffectiveData Properties

The properties of the PortionFormatEffectiveData class are listed below. For a complete list of PortionFormatEffectiveData class members, see the PortionFormatEffectiveData Members topic.

Public Instance Properties

AlternativeLanguageId | Returns or sets the Id of an alternative language. Readonly String.
BookmarkId | Returns or sets bookmark identifier. Readonly String.
ComplexScriptFont | Returns or sets the complex script font info. Null means font is undefined and should be inherited from the Master. Readonly FontData.
EastAsianFont | Returns or sets the East Asian font info. Null means font is undefined and should be inherited from the Master. Readonly FontData.
EffectFormat | Returns the text EffectFormat properties. Read-only EffectFormat.
Escapement | Returns or sets the superscript or subscript text. Value from -100% (subscript) to 100% (superscript). float.NaN means value is undefined and should be inherited from the Master. Readonly Int16.
FillFormat | Returns the text FillFormat properties. Read-only FillFormat.
FontBold | Determines whether the font is bold. Readonly NullableBool.
FontHeight | Returns or sets the font height of a portion. float.NaN means height is undefined and should be inherited from the Master. Readonly Int16.
FontItalic | Determines whether the font is itallic. Readonly NullableBool.
FontUnderline | Returns or sets the text underline type. Readonly TextUnderlineType.
HighlightColor | Returns the color used to highlight a text. Read-only Color.
HLinkClick | Obsolete. Returns or sets the hyperlink defined for mouse click. Readonly Hyperlink.
HLinkMouseOver | Obsolete. Returns or sets the hyperlink defined for mouse over. Readonly Hyperlink.
HyperlinkClick | Returns or sets the hyperlink defined for mouse click. Readonly Hyperlink.
HyperlinkMouseOver | Returns or sets the hyperlink defined for mouse over. Readonly Hyperlink.
IsHardUnderlineFill | Determines whether the underline style has own FillFormat properties or inherits it from the FillFormat properties of the text. Readonly NullableBool.
IsHardUnderlineLine | Determines whether the underline style has own LineFormat properties or inherits it from the LineFormat properties of the text. Readonly NullableBool.
KerningMinimalSize | Returns or sets the minimal font size, for which kerning should be switched on. float.NaN means value is undefined and should be inherited from the Master. Readonly Single.
Kumimoji | Determines whether the numbers should ignore text eastern language-specific vertical text layout. Readonly NullableBool.
LanguageId | Returns or sets the Id of a language. Readonly String.
LatinFont | Returns or sets the Latin font info. Null means font is undefined and should be inherited from the Master. Readonly FontData.
LineFormat | Returns the LineFormat properties for text outlining. Read-only LineFormat.
NormaliseHeight | Determines whether the height of a text should be normalized. Readonly NullableBool.
ProofDisabled | Determines whether the text shouldn't be proofed. Readonly NullableBool.
SmartTagClean | Determines whether the smart tag should be cleaned. Readonly Boolean.
Spacing | Returns or sets the intercharacter spacing increment. float.NaN means value is undefined and should be inherited from the Master. Readonly Single.
StrikethroughType | Returns or sets the strikethrough type of a text. Readonly TextStrikethroughType.
SymbolFont | Returns or sets the symbolic font info. Null means font is undefined and should be inherited from the Master. Readonly FontData.
TextCapType | Returns or sets the type of text capitalization. Readonly TextCapType.
UnderlineFillFormat | Returns the underline line FillFormat properties. Read-only FillFormat.
UnderlineLineFormat | Returns the LineFormat properties used to outline underline line. Read-only LineFormat.

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace | CreatePortionFormatEffective


AlternativeLanguageId Property

Aspose.Slides Documentation

PortionFormatEffectiveData.AlternativeLanguageId Property

Returns or sets the Id of an alternative language. Readonly String.

[Visual Basic]
NotOverridable Public ReadOnly Property AlternativeLanguageId As String _
Implements IPortionFormatEffectiveData.AlternativeLanguageId
[C#]
public string AlternativeLanguageId {get;}

Implements

IPortionFormatEffectiveData.AlternativeLanguageId

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


BookmarkId Property

Aspose.Slides Documentation

PortionFormatEffectiveData.BookmarkId Property

Returns or sets bookmark identifier. Readonly String.

[Visual Basic]
NotOverridable Public ReadOnly Property BookmarkId As String _
Implements IPortionFormatEffectiveData.BookmarkId
[C#]
public string BookmarkId {get;}

Implements

IPortionFormatEffectiveData.BookmarkId

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


ComplexScriptFont Property

Aspose.Slides Documentation

PortionFormatEffectiveData.ComplexScriptFont Property

Returns or sets the complex script font info. Null means font is undefined and should be inherited from the Master. Readonly FontData.

[Visual Basic]
NotOverridable Public ReadOnly Property ComplexScriptFont As IFontData _
Implements IPortionFormatEffectiveData.ComplexScriptFont
[C#]
public IFontData ComplexScriptFont {get;}

Implements

IPortionFormatEffectiveData.ComplexScriptFont

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


EastAsianFont Property

Aspose.Slides Documentation

PortionFormatEffectiveData.EastAsianFont Property

Returns or sets the East Asian font info. Null means font is undefined and should be inherited from the Master. Readonly FontData.

[Visual Basic]
NotOverridable Public ReadOnly Property EastAsianFont As IFontData _
Implements IPortionFormatEffectiveData.EastAsianFont
[C#]
public IFontData EastAsianFont {get;}

Implements

IPortionFormatEffectiveData.EastAsianFont

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


EffectFormat Property

Aspose.Slides Documentation

PortionFormatEffectiveData.EffectFormat Property

Returns the text EffectFormat properties. Read-only EffectFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property EffectFormat As IEffectFormatEffectiveData _
Implements IPortionFormatEffectiveData.EffectFormat
[C#]
public IEffectFormatEffectiveData EffectFormat {get;}

Implements

IPortionFormatEffectiveData.EffectFormat

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


Escapement Property

Aspose.Slides Documentation

PortionFormatEffectiveData.Escapement Property

Returns or sets the superscript or subscript text. Value from -100% (subscript) to 100% (superscript). float.NaN means value is undefined and should be inherited from the Master. Readonly Int16.

[Visual Basic]
NotOverridable Public ReadOnly Property Escapement As Single _
Implements IPortionFormatEffectiveData.Escapement
[C#]
public float Escapement {get;}

Implements

IPortionFormatEffectiveData.Escapement

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

PortionFormatEffectiveData.FillFormat Property

Returns the text FillFormat properties. Read-only FillFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property FillFormat As IFillFormatEffectiveData _
Implements IPortionFormatEffectiveData.FillFormat
[C#]
public IFillFormatEffectiveData FillFormat {get;}

Implements

IPortionFormatEffectiveData.FillFormat

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


FontBold Property

Aspose.Slides Documentation

PortionFormatEffectiveData.FontBold Property

Determines whether the font is bold. Readonly NullableBool.

[Visual Basic]
NotOverridable Public ReadOnly Property FontBold As Boolean _
Implements IPortionFormatEffectiveData.FontBold
[C#]
public bool FontBold {get;}

Implements

IPortionFormatEffectiveData.FontBold

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


FontHeight Property

Aspose.Slides Documentation

PortionFormatEffectiveData.FontHeight Property

Returns or sets the font height of a portion. float.NaN means height is undefined and should be inherited from the Master. Readonly Int16.

[Visual Basic]
NotOverridable Public ReadOnly Property FontHeight As Single _
Implements IPortionFormatEffectiveData.FontHeight
[C#]
public float FontHeight {get;}

Implements

IPortionFormatEffectiveData.FontHeight

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


FontItalic Property

Aspose.Slides Documentation

PortionFormatEffectiveData.FontItalic Property

Determines whether the font is itallic. Readonly NullableBool.

[Visual Basic]
NotOverridable Public ReadOnly Property FontItalic As Boolean _
Implements IPortionFormatEffectiveData.FontItalic
[C#]
public bool FontItalic {get;}

Implements

IPortionFormatEffectiveData.FontItalic

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


FontUnderline Property

Aspose.Slides Documentation

PortionFormatEffectiveData.FontUnderline Property

Returns or sets the text underline type. Readonly TextUnderlineType.

[Visual Basic]
NotOverridable Public ReadOnly Property FontUnderline As TextUnderlineType _
Implements IPortionFormatEffectiveData.FontUnderline
[C#]
public TextUnderlineType FontUnderline {get;}

Implements

IPortionFormatEffectiveData.FontUnderline

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


HighlightColor Property

Aspose.Slides Documentation

PortionFormatEffectiveData.HighlightColor Property

Returns the color used to highlight a text. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property HighlightColor As Color _
Implements IPortionFormatEffectiveData.HighlightColor
[C#]
public Color HighlightColor {get;}

Implements

IPortionFormatEffectiveData.HighlightColor

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


HLinkClick Property

Aspose.Slides Documentation

PortionFormatEffectiveData.HLinkClick Property

NOTE: This property is now obsolete.

Use HyperlinkClick property instead. Property will be removed after 01.09.2013.

Returns or sets the hyperlink defined for mouse click. Readonly Hyperlink.

[Visual Basic]
Public ReadOnly Property HLinkClick As Hyperlink
[C#]
public Hyperlink HLinkClick {get;}

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


HLinkMouseOver Property

Aspose.Slides Documentation

PortionFormatEffectiveData.HLinkMouseOver Property

NOTE: This property is now obsolete.

Use HyperlinkMouseOver property instead. Property will be removed after 01.09.2013.

Returns or sets the hyperlink defined for mouse over. Readonly Hyperlink.

[Visual Basic]
Public ReadOnly Property HLinkMouseOver As Hyperlink
[C#]
public Hyperlink HLinkMouseOver {get;}

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


HyperlinkClick Property

Aspose.Slides Documentation

PortionFormatEffectiveData.HyperlinkClick Property

Returns or sets the hyperlink defined for mouse click. Readonly Hyperlink.

[Visual Basic]
NotOverridable Public ReadOnly Property HyperlinkClick As IHyperlink _
Implements IPortionFormatEffectiveData.HyperlinkClick
[C#]
public IHyperlink HyperlinkClick {get;}

Implements

IPortionFormatEffectiveData.HyperlinkClick

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


HyperlinkMouseOver Property

Aspose.Slides Documentation

PortionFormatEffectiveData.HyperlinkMouseOver Property

Returns or sets the hyperlink defined for mouse over. Readonly Hyperlink.

[Visual Basic]
NotOverridable Public ReadOnly Property HyperlinkMouseOver As IHyperlink _
Implements IPortionFormatEffectiveData.HyperlinkMouseOver
[C#]
public IHyperlink HyperlinkMouseOver {get;}

Implements

IPortionFormatEffectiveData.HyperlinkMouseOver

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


IsHardUnderlineFill Property

Aspose.Slides Documentation

PortionFormatEffectiveData.IsHardUnderlineFill Property

Determines whether the underline style has own FillFormat properties or inherits it from the FillFormat properties of the text. Readonly NullableBool.

[Visual Basic]
NotOverridable Public ReadOnly Property IsHardUnderlineFill As Boolean _
Implements IPortionFormatEffectiveData.IsHardUnderlineFill
[C#]
public bool IsHardUnderlineFill {get;}

Implements

IPortionFormatEffectiveData.IsHardUnderlineFill

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


IsHardUnderlineLine Property

Aspose.Slides Documentation

PortionFormatEffectiveData.IsHardUnderlineLine Property

Determines whether the underline style has own LineFormat properties or inherits it from the LineFormat properties of the text. Readonly NullableBool.

[Visual Basic]
NotOverridable Public ReadOnly Property IsHardUnderlineLine As Boolean _
Implements IPortionFormatEffectiveData.IsHardUnderlineLine
[C#]
public bool IsHardUnderlineLine {get;}

Implements

IPortionFormatEffectiveData.IsHardUnderlineLine

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


KerningMinimalSize Property

Aspose.Slides Documentation

PortionFormatEffectiveData.KerningMinimalSize Property

Returns or sets the minimal font size, for which kerning should be switched on. float.NaN means value is undefined and should be inherited from the Master. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property KerningMinimalSize As Single _
Implements IPortionFormatEffectiveData.KerningMinimalSize
[C#]
public float KerningMinimalSize {get;}

Implements

IPortionFormatEffectiveData.KerningMinimalSize

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


Kumimoji Property

Aspose.Slides Documentation

PortionFormatEffectiveData.Kumimoji Property

Determines whether the numbers should ignore text eastern language-specific vertical text layout. Readonly NullableBool.

[Visual Basic]
NotOverridable Public ReadOnly Property Kumimoji As Boolean _
Implements IPortionFormatEffectiveData.Kumimoji
[C#]
public bool Kumimoji {get;}

Implements

IPortionFormatEffectiveData.Kumimoji

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


LanguageId Property

Aspose.Slides Documentation

PortionFormatEffectiveData.LanguageId Property

Returns or sets the Id of a language. Readonly String.

[Visual Basic]
NotOverridable Public ReadOnly Property LanguageId As String _
Implements IPortionFormatEffectiveData.LanguageId
[C#]
public string LanguageId {get;}

Implements

IPortionFormatEffectiveData.LanguageId

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


LatinFont Property

Aspose.Slides Documentation

PortionFormatEffectiveData.LatinFont Property

Returns or sets the Latin font info. Null means font is undefined and should be inherited from the Master. Readonly FontData.

[Visual Basic]
NotOverridable Public ReadOnly Property LatinFont As IFontData _
Implements IPortionFormatEffectiveData.LatinFont
[C#]
public IFontData LatinFont {get;}

Implements

IPortionFormatEffectiveData.LatinFont

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


LineFormat Property

Aspose.Slides Documentation

PortionFormatEffectiveData.LineFormat Property

Returns the LineFormat properties for text outlining. Read-only LineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property LineFormat As ILineFormatEffectiveData _
Implements IPortionFormatEffectiveData.LineFormat
[C#]
public ILineFormatEffectiveData LineFormat {get;}

Implements

IPortionFormatEffectiveData.LineFormat

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


NormaliseHeight Property

Aspose.Slides Documentation

PortionFormatEffectiveData.NormaliseHeight Property

Determines whether the height of a text should be normalized. Readonly NullableBool.

[Visual Basic]
NotOverridable Public ReadOnly Property NormaliseHeight As Boolean _
Implements IPortionFormatEffectiveData.NormaliseHeight
[C#]
public bool NormaliseHeight {get;}

Implements

IPortionFormatEffectiveData.NormaliseHeight

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


ProofDisabled Property

Aspose.Slides Documentation

PortionFormatEffectiveData.ProofDisabled Property

Determines whether the text shouldn't be proofed. Readonly NullableBool.

[Visual Basic]
NotOverridable Public ReadOnly Property ProofDisabled As Boolean _
Implements IPortionFormatEffectiveData.ProofDisabled
[C#]
public bool ProofDisabled {get;}

Implements

IPortionFormatEffectiveData.ProofDisabled

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


SmartTagClean Property

Aspose.Slides Documentation

PortionFormatEffectiveData.SmartTagClean Property

Determines whether the smart tag should be cleaned. Readonly Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property SmartTagClean As Boolean _
Implements IPortionFormatEffectiveData.SmartTagClean
[C#]
public bool SmartTagClean {get;}

Implements

IPortionFormatEffectiveData.SmartTagClean

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


Spacing Property

Aspose.Slides Documentation

PortionFormatEffectiveData.Spacing Property

Returns or sets the intercharacter spacing increment. float.NaN means value is undefined and should be inherited from the Master. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Spacing As Single _
Implements IPortionFormatEffectiveData.Spacing
[C#]
public float Spacing {get;}

Implements

IPortionFormatEffectiveData.Spacing

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


StrikethroughType Property

Aspose.Slides Documentation

PortionFormatEffectiveData.StrikethroughType Property

Returns or sets the strikethrough type of a text. Readonly TextStrikethroughType.

[Visual Basic]
NotOverridable Public ReadOnly Property StrikethroughType As TextStrikethroughType _
Implements IPortionFormatEffectiveData.StrikethroughType
[C#]
public TextStrikethroughType StrikethroughType {get;}

Implements

IPortionFormatEffectiveData.StrikethroughType

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


SymbolFont Property

Aspose.Slides Documentation

PortionFormatEffectiveData.SymbolFont Property

Returns or sets the symbolic font info. Null means font is undefined and should be inherited from the Master. Readonly FontData.

[Visual Basic]
NotOverridable Public ReadOnly Property SymbolFont As IFontData _
Implements IPortionFormatEffectiveData.SymbolFont
[C#]
public IFontData SymbolFont {get;}

Implements

IPortionFormatEffectiveData.SymbolFont

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


TextCapType Property

Aspose.Slides Documentation

PortionFormatEffectiveData.TextCapType Property

Returns or sets the type of text capitalization. Readonly TextCapType.

[Visual Basic]
NotOverridable Public ReadOnly Property TextCapType As TextCapType _
Implements IPortionFormatEffectiveData.TextCapType
[C#]
public TextCapType TextCapType {get;}

Implements

IPortionFormatEffectiveData.TextCapType

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


UnderlineFillFormat Property

Aspose.Slides Documentation

PortionFormatEffectiveData.UnderlineFillFormat Property

Returns the underline line FillFormat properties. Read-only FillFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property UnderlineFillFormat As IFillFormatEffectiveData _
Implements IPortionFormatEffectiveData.UnderlineFillFormat
[C#]
public IFillFormatEffectiveData UnderlineFillFormat {get;}

Implements

IPortionFormatEffectiveData.UnderlineFillFormat

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


UnderlineLineFormat Property

Aspose.Slides Documentation

PortionFormatEffectiveData.UnderlineLineFormat Property

Returns the LineFormat properties used to outline underline line. Read-only LineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property UnderlineLineFormat As ILineFormatEffectiveData _
Implements IPortionFormatEffectiveData.UnderlineLineFormat
[C#]
public ILineFormatEffectiveData UnderlineLineFormat {get;}

Implements

IPortionFormatEffectiveData.UnderlineLineFormat

See Also

PortionFormatEffectiveData Class | Aspose.Slides Namespace


PPImage Class

Represents an image in a presentation.

For a list of all members of this type, see PPImage Members.

System.Object
Aspose.Slides.PPImage

[Visual Basic]
Public Class PPImage
Implements IPPImage
[C#]
public class PPImage : IPPImage

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PPImage Members | Aspose.Slides Namespace


PPImage Members

PPImage overview

Public Instance Properties

BinaryData | Returns the copy of an image's data. Read-only Byte[].
ContentType | Returns a MIME type of an image, encoded in BinaryData. Read-only String.
Height | Returns a height of an image. Read-only Int32.
SystemImage | Returns the copy of an image. Read-only SystemImage.
Width | Returns a width of an image. Read-only Int32.
X | Returns a X-offset of an image. Read-only Int32.
Y | Returns a Y-offset of an image. Read-only Int32.

Public Instance Methods

GetHashCode Returns the hash code of an image.

See Also

PPImage Class | Aspose.Slides Namespace


PPImage Properties

The properties of the PPImage class are listed below. For a complete list of PPImage class members, see the PPImage Members topic.

Public Instance Properties

BinaryData | Returns the copy of an image's data. Read-only Byte[].
ContentType | Returns a MIME type of an image, encoded in BinaryData. Read-only String.
Height | Returns a height of an image. Read-only Int32.
SystemImage | Returns the copy of an image. Read-only SystemImage.
Width | Returns a width of an image. Read-only Int32.
X | Returns a X-offset of an image. Read-only Int32.
Y | Returns a Y-offset of an image. Read-only Int32.

See Also

PPImage Class | Aspose.Slides Namespace


BinaryData Property

Aspose.Slides Documentation

PPImage.BinaryData Property

Returns the copy of an image's data. Read-only Byte[].

[Visual Basic]
NotOverridable Public ReadOnly Property BinaryData As Byte() _
Implements IPPImage.BinaryData
[C#]
public byte[] BinaryData {get;}

Implements

IPPImage.BinaryData

See Also

PPImage Class | Aspose.Slides Namespace


ContentType Property

Aspose.Slides Documentation

PPImage.ContentType Property

Returns a MIME type of an image, encoded in BinaryData. Read-only String.

[Visual Basic]
NotOverridable Public ReadOnly Property ContentType As String _
Implements IPPImage.ContentType
[C#]
public string ContentType {get;}

Implements

IPPImage.ContentType

See Also

PPImage Class | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

PPImage.Height Property

Returns a height of an image. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Height As Integer _
Implements IPPImage.Height
[C#]
public int Height {get;}

Implements

IPPImage.Height

See Also

PPImage Class | Aspose.Slides Namespace


SystemImage Property

Aspose.Slides Documentation

PPImage.SystemImage Property

Returns the copy of an image. Read-only SystemImage.

[Visual Basic]
NotOverridable Public ReadOnly Property SystemImage As Image _
Implements IPPImage.SystemImage
[C#]
public Image SystemImage {get;}

Implements

IPPImage.SystemImage

See Also

PPImage Class | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

PPImage.Width Property

Returns a width of an image. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Width As Integer _
Implements IPPImage.Width
[C#]
public int Width {get;}

Implements

IPPImage.Width

See Also

PPImage Class | Aspose.Slides Namespace


X Property

Aspose.Slides Documentation

PPImage.X Property

Returns a X-offset of an image. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property X As Integer _
Implements IPPImage.X
[C#]
public int X {get;}

Implements

IPPImage.X

See Also

PPImage Class | Aspose.Slides Namespace


Y Property

Aspose.Slides Documentation

PPImage.Y Property

Returns a Y-offset of an image. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Y As Integer _
Implements IPPImage.Y
[C#]
public int Y {get;}

Implements

IPPImage.Y

See Also

PPImage Class | Aspose.Slides Namespace


PPImage Methods

The methods of the PPImage class are listed below. For a complete list of PPImage class members, see the PPImage Members topic.

Public Instance Methods

GetHashCode Returns the hash code of an image.

See Also

PPImage Class | Aspose.Slides Namespace


PPImage.GetHashCode Method

Returns the hash code of an image.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

Hash code.

See Also

PPImage Class | Aspose.Slides Namespace


PPImageFormat Enumeration

[Visual Basic]
Public Enum PPImageFormat
[C#]
public enum PPImageFormat

Members

Member Name | Description | Value
Bmp |  | 0
Emf |  | 1
Exif |  | 2
Gif |  | 3
Icon |  | 4
Jpeg |  | 5
MemoryBmp |  | 6
Png |  | 7
Tiff |  | 8
Wmf |  | 9

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


PptCorruptFileException Class

For a list of all members of this type, see PptCorruptFileException Members.

System.Object
System.Exception
Aspose.Slides.PptException
Aspose.Slides.PptReadException
Aspose.Slides.PptCorruptFileException

[Visual Basic]
Public Class PptCorruptFileException
Inherits PptReadException
[C#]
public class PptCorruptFileException : PptReadException

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PptCorruptFileException Members | Aspose.Slides Namespace


PptCorruptFileException Members

PptCorruptFileException overview

Public Instance Constructors

PptCorruptFileException Overloaded. Initializes a new instance of the PptCorruptFileException class.

See Also

PptCorruptFileException Class | Aspose.Slides Namespace


PptCorruptFileException Constructor

Initializes a new instance of the PptCorruptFileException class.

Overload List

Initializes a new instance of the PptCorruptFileException class.

public PptCorruptFileException();

public PptCorruptFileException(string);

public PptCorruptFileException(string,Exception);

See Also

PptCorruptFileException Class | Aspose.Slides Namespace


PptCorruptFileException Constructor ()

Initializes a new instance of the PptCorruptFileException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PptCorruptFileException();

See Also

PptCorruptFileException Class | Aspose.Slides Namespace | PptCorruptFileException Constructor Overload List


PptCorruptFileException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public PptCorruptFileException(
string message
);

See Also

PptCorruptFileException Class | Aspose.Slides Namespace | PptCorruptFileException Constructor Overload List


PptCorruptFileException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public PptCorruptFileException(
string message,
Exception exception
);

See Also

PptCorruptFileException Class | Aspose.Slides Namespace | PptCorruptFileException Constructor Overload List


PptEditException Class

For a list of all members of this type, see PptEditException Members.

System.Object
System.Exception
Aspose.Slides.PptException
Aspose.Slides.PptEditException

[Visual Basic]
Public Class PptEditException
Inherits PptException
[C#]
public class PptEditException : PptException

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PptEditException Members | Aspose.Slides Namespace


PptEditException Members

PptEditException overview

Public Instance Constructors

PptEditException Overloaded. Initializes a new instance of the PptEditException class.

See Also

PptEditException Class | Aspose.Slides Namespace


PptEditException Constructor

Initializes a new instance of the PptEditException class.

Overload List

Initializes a new instance of the PptEditException class.

public PptEditException();

public PptEditException(string);

public PptEditException(string,Exception);

See Also

PptEditException Class | Aspose.Slides Namespace


PptEditException Constructor ()

Initializes a new instance of the PptEditException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PptEditException();

See Also

PptEditException Class | Aspose.Slides Namespace | PptEditException Constructor Overload List


PptEditException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public PptEditException(
string message
);

See Also

PptEditException Class | Aspose.Slides Namespace | PptEditException Constructor Overload List


PptEditException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public PptEditException(
string message,
Exception exception
);

See Also

PptEditException Class | Aspose.Slides Namespace | PptEditException Constructor Overload List


PptException Class

For a list of all members of this type, see PptException Members.

System.Object
System.Exception
Aspose.Slides.PptException
Aspose.Slides.PptEditException
Aspose.Slides.PptReadException

[Visual Basic]
Public Class PptException
Inherits Exception
[C#]
public class PptException : Exception

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PptException Members | Aspose.Slides Namespace


PptException Members

PptException overview

Public Instance Constructors

PptException Overloaded. Initializes a new instance of the PptException class.

See Also

PptException Class | Aspose.Slides Namespace


PptException Constructor

Initializes a new instance of the PptException class.

Overload List

Initializes a new instance of the PptException class.

public PptException();

public PptException(string);

public PptException(string,Exception);

See Also

PptException Class | Aspose.Slides Namespace


PptException Constructor ()

Initializes a new instance of the PptException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PptException();

See Also

PptException Class | Aspose.Slides Namespace | PptException Constructor Overload List


PptException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public PptException(
string message
);

See Also

PptException Class | Aspose.Slides Namespace | PptException Constructor Overload List


PptException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public PptException(
string message,
Exception exception
);

See Also

PptException Class | Aspose.Slides Namespace | PptException Constructor Overload List


PptReadException Class

For a list of all members of this type, see PptReadException Members.

System.Object
System.Exception
Aspose.Slides.PptException
Aspose.Slides.PptReadException
Aspose.Slides.PptCorruptFileException
Aspose.Slides.PptUnsupportedFormatException

[Visual Basic]
Public Class PptReadException
Inherits PptException
[C#]
public class PptReadException : PptException

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PptReadException Members | Aspose.Slides Namespace


PptReadException Members

PptReadException overview

Public Instance Constructors

PptReadException Overloaded. Initializes a new instance of the PptReadException class.

See Also

PptReadException Class | Aspose.Slides Namespace


PptReadException Constructor

Initializes a new instance of the PptReadException class.

Overload List

Initializes a new instance of the PptReadException class.

public PptReadException();

public PptReadException(string);

public PptReadException(string,Exception);

See Also

PptReadException Class | Aspose.Slides Namespace


PptReadException Constructor ()

Initializes a new instance of the PptReadException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PptReadException();

See Also

PptReadException Class | Aspose.Slides Namespace | PptReadException Constructor Overload List


PptReadException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public PptReadException(
string message
);

See Also

PptReadException Class | Aspose.Slides Namespace | PptReadException Constructor Overload List


PptReadException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public PptReadException(
string message,
Exception exception
);

See Also

PptReadException Class | Aspose.Slides Namespace | PptReadException Constructor Overload List


PptUnsupportedFormatException Class

For a list of all members of this type, see PptUnsupportedFormatException Members.

System.Object
System.Exception
Aspose.Slides.PptException
Aspose.Slides.PptReadException
Aspose.Slides.PptUnsupportedFormatException

[Visual Basic]
Public Class PptUnsupportedFormatException
Inherits PptReadException
[C#]
public class PptUnsupportedFormatException : PptReadException

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PptUnsupportedFormatException Members | Aspose.Slides Namespace


PptUnsupportedFormatException Members

PptUnsupportedFormatException overview

Public Instance Constructors

PptUnsupportedFormatException Overloaded. Initializes a new instance of the PptUnsupportedFormatException class.

See Also

PptUnsupportedFormatException Class | Aspose.Slides Namespace


PptUnsupportedFormatException Constructor

Initializes a new instance of the PptUnsupportedFormatException class.

Overload List

Initializes a new instance of the PptUnsupportedFormatException class.

public PptUnsupportedFormatException();

public PptUnsupportedFormatException(string);

public PptUnsupportedFormatException(string,Exception);

See Also

PptUnsupportedFormatException Class | Aspose.Slides Namespace


PptUnsupportedFormatException Constructor ()

Initializes a new instance of the PptUnsupportedFormatException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PptUnsupportedFormatException();

See Also

PptUnsupportedFormatException Class | Aspose.Slides Namespace | PptUnsupportedFormatException Constructor Overload List


PptUnsupportedFormatException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public PptUnsupportedFormatException(
string message
);

See Also

PptUnsupportedFormatException Class | Aspose.Slides Namespace | PptUnsupportedFormatException Constructor Overload List


PptUnsupportedFormatException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public PptUnsupportedFormatException(
string message,
Exception exception
);

See Also

PptUnsupportedFormatException Class | Aspose.Slides Namespace | PptUnsupportedFormatException Constructor Overload List


PptxEditException Class

For a list of all members of this type, see PptxEditException Members.

System.Object
System.Exception
Aspose.Slides.OOXMLException
Aspose.Slides.PptxException
Aspose.Slides.PptxEditException

[Visual Basic]
Public Class PptxEditException
Inherits PptxException
[C#]
public class PptxEditException : PptxException

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PptxEditException Members | Aspose.Slides Namespace


PptxEditException Members

PptxEditException overview

Public Instance Constructors

PptxEditException Overloaded. Initializes a new instance of the PptxEditException class.

See Also

PptxEditException Class | Aspose.Slides Namespace


PptxEditException Constructor

Initializes a new instance of the PptxEditException class.

Overload List

Initializes a new instance of the PptxEditException class.

public PptxEditException();

public PptxEditException(string);

public PptxEditException(string,Exception);

See Also

PptxEditException Class | Aspose.Slides Namespace


PptxEditException Constructor ()

Initializes a new instance of the PptxEditException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PptxEditException();

See Also

PptxEditException Class | Aspose.Slides Namespace | PptxEditException Constructor Overload List


PptxEditException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public PptxEditException(
string message
);

See Also

PptxEditException Class | Aspose.Slides Namespace | PptxEditException Constructor Overload List


PptxEditException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public PptxEditException(
string message,
Exception exception
);

See Also

PptxEditException Class | Aspose.Slides Namespace | PptxEditException Constructor Overload List


PptxException Class

For a list of all members of this type, see PptxException Members.

System.Object
System.Exception
Aspose.Slides.OOXMLException
Aspose.Slides.PptxException
Aspose.Slides.PptxEditException
Aspose.Slides.PptxReadException

[Visual Basic]
Public Class PptxException
Inherits OOXMLException
[C#]
public class PptxException : OOXMLException

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PptxException Members | Aspose.Slides Namespace


PptxException Members

PptxException overview

Public Instance Constructors

PptxException Overloaded. Initializes a new instance of the PptxException class.

See Also

PptxException Class | Aspose.Slides Namespace


PptxException Constructor

Initializes a new instance of the PptxException class.

Overload List

Initializes a new instance of the PptxException class.

public PptxException();

public PptxException(string);

public PptxException(string,Exception);

See Also

PptxException Class | Aspose.Slides Namespace


PptxException Constructor ()

Initializes a new instance of the PptxException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PptxException();

See Also

PptxException Class | Aspose.Slides Namespace | PptxException Constructor Overload List


PptxException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public PptxException(
string message
);

See Also

PptxException Class | Aspose.Slides Namespace | PptxException Constructor Overload List


PptxException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public PptxException(
string message,
Exception exception
);

See Also

PptxException Class | Aspose.Slides Namespace | PptxException Constructor Overload List


PptxReadException Class

For a list of all members of this type, see PptxReadException Members.

System.Object
System.Exception
Aspose.Slides.OOXMLException
Aspose.Slides.PptxException
Aspose.Slides.PptxReadException
Aspose.Slides.PptxUnsupportedFormatException

[Visual Basic]
Public Class PptxReadException
Inherits PptxException
[C#]
public class PptxReadException : PptxException

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PptxReadException Members | Aspose.Slides Namespace


PptxReadException Members

PptxReadException overview

Public Instance Constructors

PptxReadException Overloaded. Initializes a new instance of the PptxReadException class.

See Also

PptxReadException Class | Aspose.Slides Namespace


PptxReadException Constructor

Initializes a new instance of the PptxReadException class.

Overload List

Initializes a new instance of the PptxReadException class.

public PptxReadException();

public PptxReadException(string);

public PptxReadException(string,Exception);

See Also

PptxReadException Class | Aspose.Slides Namespace


PptxReadException Constructor ()

Initializes a new instance of the PptxReadException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PptxReadException();

See Also

PptxReadException Class | Aspose.Slides Namespace | PptxReadException Constructor Overload List


PptxReadException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public PptxReadException(
string message
);

See Also

PptxReadException Class | Aspose.Slides Namespace | PptxReadException Constructor Overload List


PptxReadException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public PptxReadException(
string message,
Exception exception
);

See Also

PptxReadException Class | Aspose.Slides Namespace | PptxReadException Constructor Overload List


PptxUnsupportedFormatException Class

For a list of all members of this type, see PptxUnsupportedFormatException Members.

System.Object
System.Exception
Aspose.Slides.OOXMLException
Aspose.Slides.PptxException
Aspose.Slides.PptxReadException
Aspose.Slides.PptxUnsupportedFormatException

[Visual Basic]
Public Class PptxUnsupportedFormatException
Inherits PptxReadException
[C#]
public class PptxUnsupportedFormatException : PptxReadException

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PptxUnsupportedFormatException Members | Aspose.Slides Namespace


PptxUnsupportedFormatException Members

PptxUnsupportedFormatException overview

Public Instance Constructors

PptxUnsupportedFormatException Overloaded. Initializes a new instance of the PptxUnsupportedFormatException class.

See Also

PptxUnsupportedFormatException Class | Aspose.Slides Namespace


PptxUnsupportedFormatException Constructor

Initializes a new instance of the PptxUnsupportedFormatException class.

Overload List

Initializes a new instance of the PptxUnsupportedFormatException class.

public PptxUnsupportedFormatException();

public PptxUnsupportedFormatException(string);

public PptxUnsupportedFormatException(string,Exception);

See Also

PptxUnsupportedFormatException Class | Aspose.Slides Namespace


PptxUnsupportedFormatException Constructor ()

Initializes a new instance of the PptxUnsupportedFormatException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PptxUnsupportedFormatException();

See Also

PptxUnsupportedFormatException Class | Aspose.Slides Namespace | PptxUnsupportedFormatException Constructor Overload List


PptxUnsupportedFormatException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public PptxUnsupportedFormatException(
string message
);

See Also

PptxUnsupportedFormatException Class | Aspose.Slides Namespace | PptxUnsupportedFormatException Constructor Overload List


PptxUnsupportedFormatException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public PptxUnsupportedFormatException(
string message,
Exception exception
);

See Also

PptxUnsupportedFormatException Class | Aspose.Slides Namespace | PptxUnsupportedFormatException Constructor Overload List


Presentation Class

Represents a Microsoft PowerPoint presentation.

For a list of all members of this type, see Presentation Members.

System.Object
Aspose.Slides.Presentation

[Visual Basic]
NotInheritable Public Class Presentation
Implements IPresentation, IDisposable
[C#]
public sealed class Presentation : IPresentation, IDisposable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Presentation Members | Aspose.Slides Namespace


Presentation Members

Presentation overview

Public Instance Constructors

Presentation Overloaded. Initializes a new instance of the Presentation class.

Public Instance Properties

Audios | Returns the collection of all embedded audio files in the presentation. Read-only AudioCollection
CommentAuthors | Returns the collection of comments autors. Readonly CommentAuthorCollection.
CurrentDateTime | Returns or sets date and time which will substitute content of datetime fields, if UpdateDateTimeFields is true. Time of this Presentation object creation by default. Read/write DateTime.
CustomData | Returns the presentation's custom data. Read-only ICustomData.
DefaultTextStyle | Returns default text style for shapes. Readonly TextStyle.
DocumentProperties | Returns DocumentProperties object which contains standard and custom document properties. Read-only DocumentProperties.
EncryptDocumentProperties | Obsolete. This property makes sense, if presentation is password protected. If true then document properties is encrypted in presentation file. If false then document properties is public while presentation is encrypted.
HeaderFooterManager | Returns actual HeaderFooter manager.
HyperlinkQueries | Provides easy access to all hyperlinks contained in all presentation slides (not in master, layout, notes slides).
Images | Returns the collection of all images in the presentation. Read-only ImageCollection
IsEncrypted | Obsolete. Gets a value indicating whether this instance is encrypted.
IsOnlyDocumentPropertiesLoaded | Obsolete. This property makes sense, if presentation file is password protected and document properties of this file are public. Value of true means that only document properties are loaded from an encrypted presentation file without use of password. Value of false means that entire encrypted presentation is loaded with use of right password, not only document properties are loaded. If presentation isn't encrypted then property value is always false. If document properties of an encrypted file aren't public then property value is always false. If Presentation.EncryptDocumentProperties is true than IsOnlyDocumentPropertiesLoaded property value is always false.
IsWriteProtected | Obsolete. Gets a value indicating whether this presentation is write protected.
LayoutSlides | Returns a list of all layout slides that are defined in the presentation. Read-only IGlobalLayoutSlideCollection.
MasterHandoutSlideManager |
MasterNotesSlideManager |
Masters | Returns a list of all master slides that are defined in the presentation. Read-only MasterSlideCollection.
MasterTheme |
ProtectionManager | Gets manager of the permissions for this presentation.
Slides | Returns a list of all slides that are defined in the presentation. Read-only SlideCollection.
SlideSize | Returns slide size object. Readonly SlideSize.
SourceFormat | Returns information about from which format presentation was loaded.
Tags | Obsolete. Returns the presentation's tags collection. Read-only TagCollection.
UpdateDateTimeFields | Determines wheather Aspose.Slides should update date and time fields. False by default. Read/write Boolean.
UpdateSlideNumberFields | Determines wheather Aspose.Slides should update slide number fields. True by default. Read/write Boolean.
VbaProject | Gets VBA project with presentation macros in binary format (as OLE container).
Videos | Returns the collection of all embedded video files in the presentation. Read-only VideoCollection

Public Instance Methods

Dispose | Releases all resources used by this Aspose.Slides.Pptx.PrentationEx object.
Encrypt | Obsolete. Encrypts Presentation with specified password.
Print | Overloaded. Prints the whole presentation to the default printer.
RemoveEncryption | Obsolete. Removes the encryption.
RemoveWriteProtection | Obsolete. Removes write protection for this presentation.
Save | Overloaded. Saves all slides of a presentation to a file with the specified format.
SetWriteProtection | Obsolete. Set write protection for this presentation with specified password.

See Also

Presentation Class | Aspose.Slides Namespace


Presentation Constructor

This constructor creates new presentation from scratch. Created presentation has one empty slide.

Overload List

This constructor creates new presentation from scratch. Created presentation has one empty slide.

public Presentation();

This constructor creates new presentation from scratch. Created presentation has one empty slide.

public Presentation(LoadOptions);

This constructor is the primary mechanism for reading an existing Presentation.

public Presentation(Stream);

This constructor is the primary mechanism for reading an existing Presentation.

public Presentation(Stream,LoadOptions);

This constructor gets a source file path from which the contents of the Presentation are read.

public Presentation(string);

This constructor gets a source file path from which the contents of the Presentation are read.

public Presentation(string,LoadOptions);

See Also

Presentation Class | Aspose.Slides Namespace


Presentation Constructor ()

This constructor creates new presentation from scratch. Created presentation has one empty slide.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Presentation();

See Also

Presentation Class | Aspose.Slides Namespace | Presentation Constructor Overload List


Presentation Constructor (LoadOptions)

This constructor creates new presentation from scratch. Created presentation has one empty slide.

[Visual Basic]
Overloads Public Sub New( _
ByVal loadOptions As LoadOptions _
)
[C#]
public Presentation(
LoadOptions loadOptions
);

Parameters

loadOptions
Additional load options.

See Also

Presentation Class | Aspose.Slides Namespace | Presentation Constructor Overload List


Presentation Constructor (Stream)

This constructor is the primary mechanism for reading an existing Presentation.

[Visual Basic]
Overloads Public Sub New( _
ByVal stream As Stream _
)
[C#]
public Presentation(
Stream stream
);

Parameters

stream
Input stream.

Example

[C#]

 FileStream fis = new FileStream("demo.pptx", FileMode.Open, FileAccess.Read);
 Presentation pres = new Presentation(fis);
 fis.Close();

 [Visual Basic]

 Dim fis As FileStream = New FileStream("demo.pptx", FileMode.Open, FileAccess.Read)
 Dim pres As Presentation = New Presentation(fis)
 fis.Close()

See Also

Presentation Class | Aspose.Slides Namespace | Presentation Constructor Overload List


Presentation Constructor (Stream, LoadOptions)

This constructor is the primary mechanism for reading an existing Presentation.

[Visual Basic]
Overloads Public Sub New( _
ByVal stream As Stream, _
ByVal loadOptions As LoadOptions _
)
[C#]
public Presentation(
Stream stream,
LoadOptions loadOptions
);

Parameters

stream
Input stream.
loadOptions
Additional load options.

See Also

Presentation Class | Aspose.Slides Namespace | Presentation Constructor Overload List


Presentation Constructor (String)

This constructor gets a source file path from which the contents of the Presentation are read.

[Visual Basic]
Overloads Public Sub New( _
ByVal file As String _
)
[C#]
public Presentation(
string file
);

Parameters

file
Input file.

Example

[C#]

 Presentation pres = new Presentation("demo.pptx");

 [Visual Basic]

 Dim pres As Presentation = New Presentation("demo.pptx")

See Also

Presentation Class | Aspose.Slides Namespace | Presentation Constructor Overload List


Presentation Constructor (String, LoadOptions)

This constructor gets a source file path from which the contents of the Presentation are read.

[Visual Basic]
Overloads Public Sub New( _
ByVal file As String, _
ByVal loadOptions As LoadOptions _
)
[C#]
public Presentation(
string file,
LoadOptions loadOptions
);

Parameters

file
Input file.
loadOptions
Additional load options.

See Also

Presentation Class | Aspose.Slides Namespace | Presentation Constructor Overload List


Presentation Properties

The properties of the Presentation class are listed below. For a complete list of Presentation class members, see the Presentation Members topic.

Public Instance Properties

Audios | Returns the collection of all embedded audio files in the presentation. Read-only AudioCollection
CommentAuthors | Returns the collection of comments autors. Readonly CommentAuthorCollection.
CurrentDateTime | Returns or sets date and time which will substitute content of datetime fields, if UpdateDateTimeFields is true. Time of this Presentation object creation by default. Read/write DateTime.
CustomData | Returns the presentation's custom data. Read-only ICustomData.
DefaultTextStyle | Returns default text style for shapes. Readonly TextStyle.
DocumentProperties | Returns DocumentProperties object which contains standard and custom document properties. Read-only DocumentProperties.
EncryptDocumentProperties | Obsolete. This property makes sense, if presentation is password protected. If true then document properties is encrypted in presentation file. If false then document properties is public while presentation is encrypted.
HeaderFooterManager | Returns actual HeaderFooter manager.
HyperlinkQueries | Provides easy access to all hyperlinks contained in all presentation slides (not in master, layout, notes slides).
Images | Returns the collection of all images in the presentation. Read-only ImageCollection
IsEncrypted | Obsolete. Gets a value indicating whether this instance is encrypted.
IsOnlyDocumentPropertiesLoaded | Obsolete. This property makes sense, if presentation file is password protected and document properties of this file are public. Value of true means that only document properties are loaded from an encrypted presentation file without use of password. Value of false means that entire encrypted presentation is loaded with use of right password, not only document properties are loaded. If presentation isn't encrypted then property value is always false. If document properties of an encrypted file aren't public then property value is always false. If Presentation.EncryptDocumentProperties is true than IsOnlyDocumentPropertiesLoaded property value is always false.
IsWriteProtected | Obsolete. Gets a value indicating whether this presentation is write protected.
LayoutSlides | Returns a list of all layout slides that are defined in the presentation. Read-only IGlobalLayoutSlideCollection.
MasterHandoutSlideManager |
MasterNotesSlideManager |
Masters | Returns a list of all master slides that are defined in the presentation. Read-only MasterSlideCollection.
MasterTheme |
ProtectionManager | Gets manager of the permissions for this presentation.
Slides | Returns a list of all slides that are defined in the presentation. Read-only SlideCollection.
SlideSize | Returns slide size object. Readonly SlideSize.
SourceFormat | Returns information about from which format presentation was loaded.
Tags | Obsolete. Returns the presentation's tags collection. Read-only TagCollection.
UpdateDateTimeFields | Determines wheather Aspose.Slides should update date and time fields. False by default. Read/write Boolean.
UpdateSlideNumberFields | Determines wheather Aspose.Slides should update slide number fields. True by default. Read/write Boolean.
VbaProject | Gets VBA project with presentation macros in binary format (as OLE container).
Videos | Returns the collection of all embedded video files in the presentation. Read-only VideoCollection

See Also

Presentation Class | Aspose.Slides Namespace


Audios Property

Aspose.Slides Documentation

Presentation.Audios Property

Returns the collection of all embedded audio files in the presentation. Read-only AudioCollection

[Visual Basic]
NotOverridable Public ReadOnly Property Audios As IAudioCollection _
Implements IPresentation.Audios
[C#]
public IAudioCollection Audios {get;}

Implements

IPresentation.Audios

See Also

Presentation Class | Aspose.Slides Namespace


CommentAuthors Property

Aspose.Slides Documentation

Presentation.CommentAuthors Property

Returns the collection of comments autors. Readonly CommentAuthorCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property CommentAuthors As ICommentAuthorCollection _
Implements IPresentation.CommentAuthors
[C#]
public ICommentAuthorCollection CommentAuthors {get;}

Implements

IPresentation.CommentAuthors

See Also

Presentation Class | Aspose.Slides Namespace


CurrentDateTime Property

Aspose.Slides Documentation

Presentation.CurrentDateTime Property

Returns or sets date and time which will substitute content of datetime fields, if UpdateDateTimeFields is true. Time of this Presentation object creation by default. Read/write DateTime.

[Visual Basic]
NotOverridable Public Property CurrentDateTime As Date _
Implements IPresentation.CurrentDateTime
[C#]
public DateTime CurrentDateTime {get; set;}

Implements

IPresentation.CurrentDateTime

See Also

Presentation Class | Aspose.Slides Namespace


CustomData Property

Aspose.Slides Documentation

Presentation.CustomData Property

Returns the presentation's custom data. Read-only ICustomData.

[Visual Basic]
NotOverridable Public ReadOnly Property CustomData As ICustomData _
Implements IPresentation.CustomData
[C#]
public ICustomData CustomData {get;}

Implements

IPresentation.CustomData

See Also

Presentation Class | Aspose.Slides Namespace


DefaultTextStyle Property

Aspose.Slides Documentation

Presentation.DefaultTextStyle Property

Returns default text style for shapes. Readonly TextStyle.

[Visual Basic]
NotOverridable Public ReadOnly Property DefaultTextStyle As ITextStyle _
Implements IPresentation.DefaultTextStyle
[C#]
public ITextStyle DefaultTextStyle {get;}

Implements

IPresentation.DefaultTextStyle

See Also

Presentation Class | Aspose.Slides Namespace


DocumentProperties Property

Aspose.Slides Documentation

Presentation.DocumentProperties Property

Returns DocumentProperties object which contains standard and custom document properties. Read-only DocumentProperties.

[Visual Basic]
NotOverridable Public ReadOnly Property DocumentProperties As IDocumentProperties _
Implements IPresentation.DocumentProperties
[C#]
public IDocumentProperties DocumentProperties {get;}

Implements

IPresentation.DocumentProperties

See Also

Presentation Class | Aspose.Slides Namespace


EncryptDocumentProperties Property

Aspose.Slides Documentation

Presentation.EncryptDocumentProperties Property

NOTE: This property is now obsolete.

Use ProtectionManager.EncryptDocumentProperties property instead. Property will be removed after 01.09.2013.

This property makes sense, if presentation is password protected. If true then document properties is encrypted in presentation file. If false then document properties is public while presentation is encrypted.

[Visual Basic]
Public Property EncryptDocumentProperties As Boolean
[C#]
public bool EncryptDocumentProperties {get; set;}

See Also

Presentation Class | Aspose.Slides Namespace


HeaderFooterManager Property

Aspose.Slides Documentation

Presentation.HeaderFooterManager Property

Returns actual HeaderFooter manager.

[Visual Basic]
NotOverridable Public ReadOnly Property HeaderFooterManager As IHeaderFooterManager _
Implements IPresentation.HeaderFooterManager
[C#]
public IHeaderFooterManager HeaderFooterManager {get;}

Implements

IPresentation.HeaderFooterManager

See Also

Presentation Class | Aspose.Slides Namespace


HyperlinkQueries Property

Aspose.Slides Documentation

Presentation.HyperlinkQueries Property

Provides easy access to all hyperlinks contained in all presentation slides (not in master, layout, notes slides).

[Visual Basic]
NotOverridable Public ReadOnly Property HyperlinkQueries As IHyperlinkQueries _
Implements IPresentation.HyperlinkQueries
[C#]
public IHyperlinkQueries HyperlinkQueries {get;}

Implements

IPresentation.HyperlinkQueries

See Also

Presentation Class | Aspose.Slides Namespace


Images Property

Aspose.Slides Documentation

Presentation.Images Property

Returns the collection of all images in the presentation. Read-only ImageCollection

[Visual Basic]
NotOverridable Public ReadOnly Property Images As IImageCollection _
Implements IPresentation.Images
[C#]
public IImageCollection Images {get;}

Implements

IPresentation.Images

See Also

Presentation Class | Aspose.Slides Namespace


IsEncrypted Property

Aspose.Slides Documentation

Presentation.IsEncrypted Property

NOTE: This property is now obsolete.

Use ProtectionManager.IsEncrypted property instead. Property will be removed after 01.09.2013.

Gets a value indicating whether this instance is encrypted.

[Visual Basic]
Public ReadOnly Property IsEncrypted As Boolean
[C#]
public bool IsEncrypted {get;}

Property Value

true if presentation was loaded from encrypted file or Encrypt method was called ; otherwise, false.

See Also

Presentation Class | Aspose.Slides Namespace


IsOnlyDocumentPropertiesLoaded Property

Aspose.Slides Documentation

Presentation.IsOnlyDocumentPropertiesLoaded Property

NOTE: This property is now obsolete.

Use ProtectionManager.IsOnlyDocumentPropertiesLoaded property instead. Property will be removed after 01.09.2013.

This property makes sense, if presentation file is password protected and document properties of this file are public. Value of true means that only document properties are loaded from an encrypted presentation file without use of password. Value of false means that entire encrypted presentation is loaded with use of right password, not only document properties are loaded. If presentation isn't encrypted then property value is always false. If document properties of an encrypted file aren't public then property value is always false. If Presentation.EncryptDocumentProperties is true than IsOnlyDocumentPropertiesLoaded property value is always false.

[Visual Basic]
Public ReadOnly Property IsOnlyDocumentPropertiesLoaded As Boolean
[C#]
public bool IsOnlyDocumentPropertiesLoaded {get;}

See Also

Presentation Class | Aspose.Slides Namespace


IsWriteProtected Property

Aspose.Slides Documentation

Presentation.IsWriteProtected Property

NOTE: This property is now obsolete.

Use ProtectionManager.IsWriteProtected property instead. Property will be removed after 01.09.2013.

Gets a value indicating whether this presentation is write protected.

[Visual Basic]
Public ReadOnly Property IsWriteProtected As Boolean
[C#]
public bool IsWriteProtected {get;}

See Also

Presentation Class | Aspose.Slides Namespace


LayoutSlides Property

Aspose.Slides Documentation

Presentation.LayoutSlides Property

Returns a list of all layout slides that are defined in the presentation. Read-only IGlobalLayoutSlideCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property LayoutSlides As IGlobalLayoutSlideCollection _
Implements IPresentation.LayoutSlides
[C#]
public IGlobalLayoutSlideCollection LayoutSlides {get;}

Implements

IPresentation.LayoutSlides

Remarks

You can access to alternative API for adding/inserting/removing/cloning layout slides by using IMasterSlide.LayoutSlides property.

See Also

Presentation Class | Aspose.Slides Namespace


MasterHandoutSlideManager Property

Aspose.Slides Documentation

Presentation.MasterHandoutSlideManager Property

[Visual Basic]
NotOverridable Public ReadOnly Property MasterHandoutSlideManager As IMasterHandoutSlideManager _
Implements IPresentation.MasterHandoutSlideManager
[C#]
public IMasterHandoutSlideManager MasterHandoutSlideManager {get;}

Implements

IPresentation.MasterHandoutSlideManager

See Also

Presentation Class | Aspose.Slides Namespace


MasterNotesSlideManager Property

Aspose.Slides Documentation

Presentation.MasterNotesSlideManager Property

[Visual Basic]
NotOverridable Public ReadOnly Property MasterNotesSlideManager As IMasterNotesSlideManager _
Implements IPresentation.MasterNotesSlideManager
[C#]
public IMasterNotesSlideManager MasterNotesSlideManager {get;}

Implements

IPresentation.MasterNotesSlideManager

See Also

Presentation Class | Aspose.Slides Namespace


Masters Property

Aspose.Slides Documentation

Presentation.Masters Property

Returns a list of all master slides that are defined in the presentation. Read-only MasterSlideCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Masters As IMasterSlideCollection _
Implements IPresentation.Masters
[C#]
public IMasterSlideCollection Masters {get;}

Implements

IPresentation.Masters

See Also

Presentation Class | Aspose.Slides Namespace


MasterTheme Property

Aspose.Slides Documentation

Presentation.MasterTheme Property

[Visual Basic]
NotOverridable Public ReadOnly Property MasterTheme As IMasterTheme _
Implements IPresentation.MasterTheme
[C#]
public IMasterTheme MasterTheme {get;}

Implements

IPresentation.MasterTheme

See Also

Presentation Class | Aspose.Slides Namespace


ProtectionManager Property

Aspose.Slides Documentation

Presentation.ProtectionManager Property

Gets manager of the permissions for this presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property ProtectionManager As IProtectionManager _
Implements IPresentation.ProtectionManager
[C#]
public IProtectionManager ProtectionManager {get;}

Implements

IPresentation.ProtectionManager

See Also

Presentation Class | Aspose.Slides Namespace


Slides Property

Aspose.Slides Documentation

Presentation.Slides Property

Returns a list of all slides that are defined in the presentation. Read-only SlideCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Slides As ISlideCollection _
Implements IPresentation.Slides
[C#]
public ISlideCollection Slides {get;}

Implements

IPresentation.Slides

See Also

Presentation Class | Aspose.Slides Namespace


SlideSize Property

Aspose.Slides Documentation

Presentation.SlideSize Property

Returns slide size object. Readonly SlideSize.

[Visual Basic]
NotOverridable Public ReadOnly Property SlideSize As ISlideSize _
Implements IPresentation.SlideSize
[C#]
public ISlideSize SlideSize {get;}

Implements

IPresentation.SlideSize

See Also

Presentation Class | Aspose.Slides Namespace


SourceFormat Property

Aspose.Slides Documentation

Presentation.SourceFormat Property

Returns information about from which format presentation was loaded.

[Visual Basic]
NotOverridable Public ReadOnly Property SourceFormat As SourceFormat _
Implements IPresentation.SourceFormat
[C#]
public SourceFormat SourceFormat {get;}

Implements

IPresentation.SourceFormat

See Also

Presentation Class | Aspose.Slides Namespace


Tags Property

Aspose.Slides Documentation

Presentation.Tags Property

NOTE: This property is now obsolete.

Use CustomData.Tags instead. Will be removed after 01.09.2014.

Returns the presentation's tags collection. Read-only TagCollection.

[Visual Basic]
Public ReadOnly Property Tags As ITagCollection
[C#]
public ITagCollection Tags {get;}

See Also

Presentation Class | Aspose.Slides Namespace


UpdateDateTimeFields Property

Aspose.Slides Documentation

Presentation.UpdateDateTimeFields Property

Determines wheather Aspose.Slides should update date and time fields. False by default. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property UpdateDateTimeFields As Boolean _
Implements IPresentation.UpdateDateTimeFields
[C#]
public bool UpdateDateTimeFields {get; set;}

Implements

IPresentation.UpdateDateTimeFields

See Also

Presentation Class | Aspose.Slides Namespace


UpdateSlideNumberFields Property

Aspose.Slides Documentation

Presentation.UpdateSlideNumberFields Property

Determines wheather Aspose.Slides should update slide number fields. True by default. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property UpdateSlideNumberFields As Boolean _
Implements IPresentation.UpdateSlideNumberFields
[C#]
public bool UpdateSlideNumberFields {get; set;}

Implements

IPresentation.UpdateSlideNumberFields

See Also

Presentation Class | Aspose.Slides Namespace


VbaProject Property

Aspose.Slides Documentation

Presentation.VbaProject Property

Gets VBA project with presentation macros in binary format (as OLE container).

[Visual Basic]
NotOverridable Public Property VbaProject As Byte() _
Implements IPresentation.VbaProject
[C#]
public byte[] VbaProject {get; set;}

Implements

IPresentation.VbaProject

See Also

Presentation Class | Aspose.Slides Namespace


Videos Property

Aspose.Slides Documentation

Presentation.Videos Property

Returns the collection of all embedded video files in the presentation. Read-only VideoCollection

[Visual Basic]
NotOverridable Public ReadOnly Property Videos As IVideoCollection _
Implements IPresentation.Videos
[C#]
public IVideoCollection Videos {get;}

Implements

IPresentation.Videos

See Also

Presentation Class | Aspose.Slides Namespace


Presentation Methods

The methods of the Presentation class are listed below. For a complete list of Presentation class members, see the Presentation Members topic.

Public Instance Methods

Dispose | Releases all resources used by this Aspose.Slides.Pptx.PrentationEx object.
Encrypt | Obsolete. Encrypts Presentation with specified password.
Print | Overloaded. Prints the whole presentation to the default printer.
RemoveEncryption | Obsolete. Removes the encryption.
RemoveWriteProtection | Obsolete. Removes write protection for this presentation.
Save | Overloaded. Saves all slides of a presentation to a file with the specified format.
SetWriteProtection | Obsolete. Set write protection for this presentation with specified password.

See Also

Presentation Class | Aspose.Slides Namespace


Presentation.Dispose Method

Releases all resources used by this Aspose.Slides.Pptx.PrentationEx object.

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

Presentation Class | Aspose.Slides Namespace


Presentation.Encrypt Method

NOTE: This method is now obsolete.

Use ProtectionManager.Encrypt(..) method instead. Will be removed after 01.09.2013.

Encrypts Presentation with specified password.

[Visual Basic]
Public Sub Encrypt( _
ByVal password As String _
)
[C#]
public void Encrypt(
string password
);

Parameters

password
The password.

See Also

Presentation Class | Aspose.Slides Namespace


Print Method

Aspose.Slides Documentation

Presentation.Print Method

Prints the whole presentation to the default printer.

Overload List

Prints the whole presentation to the default printer.

public void Print();

Prints the presentation according to the specified printer settings, using the standard (no User Interface) print controller.

public void Print(PrinterSettings);

Prints the document according to the specified printer settings, using the standard (no User Interface) print controller and a presentation name.

public void Print(PrinterSettings,string);

Print the whole presentation to the specified printer, using the standard (no User Interface) print controller.

public void Print(string);

See Also

Presentation Class | Aspose.Slides Namespace


Presentation.Print Method ()

Prints the whole presentation to the default printer.

[Visual Basic]
NotOverridable Overloads Public Sub Print() _
Implements IPresentation.Print
[C#]
public void Print();

Implements

IPresentation.Print

See Also

Presentation Class | Aspose.Slides Namespace | Presentation.Print Overload List


Presentation.Print Method (PrinterSettings)

Prints the presentation according to the specified printer settings, using the standard (no User Interface) print controller.

[Visual Basic]
NotOverridable Overloads Public Sub Print( _
ByVal printerSettings As PrinterSettings _
) _
Implements IPresentation.Print
[C#]
public void Print(
PrinterSettings printerSettings
);

Parameters

printerSettings
The .NET printer settings to use.

Implements

IPresentation.Print

See Also

Presentation Class | Aspose.Slides Namespace | Presentation.Print Overload List


Presentation.Print Method (PrinterSettings, String)

Prints the document according to the specified printer settings, using the standard (no User Interface) print controller and a presentation name.

[Visual Basic]
NotOverridable Overloads Public Sub Print( _
ByVal printerSettings As PrinterSettings, _
ByVal presName As String _
) _
Implements IPresentation.Print
[C#]
public void Print(
PrinterSettings printerSettings,
string presName
);

Parameters

printerSettings
The .NET printer settings to use.
presName
The presentation name to display (for example, in a print status dialog box or printer queue) while printing the presentation.

Implements

IPresentation.Print

See Also

Presentation Class | Aspose.Slides Namespace | Presentation.Print Overload List


Presentation.Print Method (String)

Print the whole presentation to the specified printer, using the standard (no User Interface) print controller.

[Visual Basic]
NotOverridable Overloads Public Sub Print( _
ByVal printerName As String _
) _
Implements IPresentation.Print
[C#]
public void Print(
string printerName
);

Parameters

printerName
The name of the printer.

Implements

IPresentation.Print

See Also

Presentation Class | Aspose.Slides Namespace | Presentation.Print Overload List


Presentation.RemoveEncryption Method

NOTE: This method is now obsolete.

Use ProtectionManager.RemoveEncryption() method instead. Will be removed after 01.09.2013.

Removes the encryption.

[Visual Basic]
Public Sub RemoveEncryption()
[C#]
public void RemoveEncryption();

See Also

Presentation Class | Aspose.Slides Namespace


Presentation.RemoveWriteProtection Method

NOTE: This method is now obsolete.

Use ProtectionManager.RemoveWriteProtection() method instead. Will be removed after 01.09.2013.

Removes write protection for this presentation.

[Visual Basic]
Public Sub RemoveWriteProtection()
[C#]
public void RemoveWriteProtection();

See Also

Presentation Class | Aspose.Slides Namespace


Save Method

Aspose.Slides Documentation

Presentation.Save Method

Saves all slides of a presentation to a stream in the specified format.

Overload List

Saves all slides of a presentation to a stream in the specified format.

public void Save(Stream,SaveFormat);

Saves all slides of a presentation to a stream in the specified format and with additional options.

public void Save(Stream,SaveFormat,ISaveOptions);

Saves all slides of a presentation to a file with the specified format.

public void Save(string,SaveFormat);

Saves all slides of a presentation to a file with the specified format and with additional options.

public void Save(string,SaveFormat,ISaveOptions);

Sends the presentation to the client browser.

public void Save(string,SaveFormat,ISaveOptions,HttpResponse,bool);

Sends the presentation to the client browser.

public void Save(string,SaveFormat,HttpResponse,bool);

See Also

Presentation Class | Aspose.Slides Namespace


Presentation.Save Method (Stream, SaveFormat)

Saves all slides of a presentation to a stream in the specified format.

[Visual Basic]
NotOverridable Overloads Public Sub Save( _
ByVal stream As Stream, _
ByVal format As SaveFormat _
) _
Implements IPresentation.Save
[C#]
public void Save(
Stream stream,
SaveFormat format
);

Parameters

stream
Output stream.
format
Format of the exported data.

Implements

IPresentation.Save

See Also

Presentation Class | Aspose.Slides Namespace | Presentation.Save Overload List


Presentation.Save Method (Stream, SaveFormat, ISaveOptions)

Saves all slides of a presentation to a stream in the specified format and with additional options.

[Visual Basic]
NotOverridable Overloads Public Sub Save( _
ByVal stream As Stream, _
ByVal format As SaveFormat, _
ByVal options As ISaveOptions _
) _
Implements IPresentation.Save
[C#]
public void Save(
Stream stream,
SaveFormat format,
ISaveOptions options
);

Parameters

stream
Output stream.
format
Format of the exported data.
options
Additional format options.

Implements

IPresentation.Save

Exceptions

Exception Type | Condition
NotSupportedException | If you try to save encrypted file in none Office 2007-2010 format

See Also

Presentation Class | Aspose.Slides Namespace | Presentation.Save Overload List


Presentation.Save Method (String, SaveFormat)

Saves all slides of a presentation to a file with the specified format.

[Visual Basic]
NotOverridable Overloads Public Sub Save( _
ByVal fname As String, _
ByVal format As SaveFormat _
) _
Implements IPresentation.Save
[C#]
public void Save(
string fname,
SaveFormat format
);

Parameters

fname
Path to the created file.
format
Format of the exported data.

Implements

IPresentation.Save

See Also

Presentation Class | Aspose.Slides Namespace | Presentation.Save Overload List


Presentation.Save Method (String, SaveFormat, ISaveOptions)

Saves all slides of a presentation to a file with the specified format and with additional options.

[Visual Basic]
NotOverridable Overloads Public Sub Save( _
ByVal fname As String, _
ByVal format As SaveFormat, _
ByVal options As ISaveOptions _
) _
Implements IPresentation.Save
[C#]
public void Save(
string fname,
SaveFormat format,
ISaveOptions options
);

Parameters

fname
Path to the created file.
format
Format of the exported data.
options
Additional format options.

Implements

IPresentation.Save

See Also

Presentation Class | Aspose.Slides Namespace | Presentation.Save Overload List


Presentation.Save Method (String, SaveFormat, ISaveOptions, HttpResponse, Boolean)

Sends the presentation to the client browser.

[Visual Basic]
NotOverridable Overloads Public Sub Save( _
ByVal fname As String, _
ByVal format As SaveFormat, _
ByVal options As ISaveOptions, _
ByVal response As HttpResponse, _
ByVal showInline As Boolean _
) _
Implements IPresentation.Save
[C#]
public void Save(
string fname,
SaveFormat format,
ISaveOptions options,
HttpResponse response,
bool showInline
);

Parameters

fname
The name for the presentation that will appear at the client browser. The name should not contain path.
format
Format of the exported data.
options
Additional format options.
response
Response object where to save the document.
showInline
True to show an option to open the presentation inside the browser.

Implements

IPresentation.Save

See Also

Presentation Class | Aspose.Slides Namespace | Presentation.Save Overload List


Presentation.Save Method (String, SaveFormat, HttpResponse, Boolean)

Sends the presentation to the client browser.

[Visual Basic]
NotOverridable Overloads Public Sub Save( _
ByVal fname As String, _
ByVal format As SaveFormat, _
ByVal response As HttpResponse, _
ByVal showInline As Boolean _
) _
Implements IPresentation.Save
[C#]
public void Save(
string fname,
SaveFormat format,
HttpResponse response,
bool showInline
);

Parameters

fname
The name for the presentation that will appear at the client browser. The name should not contain path.
format
Format of the exported data.
response
Response object where to save the document.
showInline
True to show an option to open the presentation inside the browser.

Implements

IPresentation.Save

See Also

Presentation Class | Aspose.Slides Namespace | Presentation.Save Overload List


Presentation.SetWriteProtection Method

NOTE: This method is now obsolete.

Use ProtectionManager.SetWriteProtection(..) method instead. Will be removed after 01.09.2013.

Set write protection for this presentation with specified password.

[Visual Basic]
Public Sub SetWriteProtection( _
ByVal password As String _
)
[C#]
public void SetWriteProtection(
string password
);

Parameters

password
The password.

See Also

Presentation Class | Aspose.Slides Namespace


PresentationFactory Class

Allows to create presentation via COM interface

For a list of all members of this type, see PresentationFactory Members.

System.Object
Aspose.Slides.PresentationFactory

[Visual Basic]
Public Class PresentationFactory
Implements IPresentationFactory
[C#]
public class PresentationFactory : IPresentationFactory

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PresentationFactory Members | Aspose.Slides Namespace


PresentationFactory Members

PresentationFactory overview

Public Instance Constructors

PresentationFactory Constructor Initializes a new instance of the PresentationFactory class.

Public Instance Methods

CreatePresentation | Overloaded. Creates new presentation.
ReadPresentation | Overloaded. Reads an existing presentation from array

See Also

PresentationFactory Class | Aspose.Slides Namespace


PresentationFactory Constructor

Initializes a new instance of the PresentationFactory class.

[Visual Basic]
Public Sub New()
[C#]
public PresentationFactory();

See Also

PresentationFactory Class | Aspose.Slides Namespace


PresentationFactory Methods

The methods of the PresentationFactory class are listed below. For a complete list of PresentationFactory class members, see the PresentationFactory Members topic.

Public Instance Methods

CreatePresentation | Overloaded. Creates new presentation.
ReadPresentation | Overloaded. Reads an existing presentation from array

See Also

PresentationFactory Class | Aspose.Slides Namespace


CreatePresentation Method

Aspose.Slides Documentation

PresentationFactory.CreatePresentation Method

Creates new presentation.

Overload List

Creates new presentation.

public IPresentation CreatePresentation();

Creates new presentation with additional load options

public IPresentation CreatePresentation(ILoadOptions);

See Also

PresentationFactory Class | Aspose.Slides Namespace


PresentationFactory.CreatePresentation Method ()

Creates new presentation.

[Visual Basic]
NotOverridable Overloads Public Function CreatePresentation() As IPresentation _
Implements IPresentationFactory.CreatePresentation
[C#]
public IPresentation CreatePresentation();

Return Value

New presentation

Implements

IPresentationFactory.CreatePresentation

See Also

PresentationFactory Class | Aspose.Slides Namespace | PresentationFactory.CreatePresentation Overload List


PresentationFactory.CreatePresentation Method (ILoadOptions)

Creates new presentation with additional load options

[Visual Basic]
NotOverridable Overloads Public Function CreatePresentation( _
ByVal options As ILoadOptions _
) As IPresentation _
Implements IPresentationFactory.CreatePresentation
[C#]
public IPresentation CreatePresentation(
ILoadOptions options
);

Parameters

options
Load options

Return Value

New presentation

Implements

IPresentationFactory.CreatePresentation

See Also

PresentationFactory Class | Aspose.Slides Namespace | PresentationFactory.CreatePresentation Overload List


ReadPresentation Method

Aspose.Slides Documentation

PresentationFactory.ReadPresentation Method

Reads an existing presentation from array

Overload List

Reads an existing presentation from array

public IPresentation ReadPresentation(byte[]);

Reads an existing presentation from array with additional load options

public IPresentation ReadPresentation(byte[],ILoadOptions);

Reads an existing presentation from stream

public IPresentation ReadPresentation(Stream);

Reads an existing presentation from stream with additional load options

public IPresentation ReadPresentation(Stream,ILoadOptions);

Reads an existing presentation from file

public IPresentation ReadPresentation(string);

Reads an existing presentation from stream with additional load options

public IPresentation ReadPresentation(string,ILoadOptions);

See Also

PresentationFactory Class | Aspose.Slides Namespace


PresentationFactory.ReadPresentation Method (Byte[])

Reads an existing presentation from array

[Visual Basic]
NotOverridable Overloads Public Function ReadPresentation( _
ByVal data As Byte() _
) As IPresentation _
Implements IPresentationFactory.ReadPresentation
[C#]
public IPresentation ReadPresentation(
byte[] data
);

Parameters

data
Array to read

Return Value

Read presentation

Implements

IPresentationFactory.ReadPresentation

See Also

PresentationFactory Class | Aspose.Slides Namespace | PresentationFactory.ReadPresentation Overload List


PresentationFactory.ReadPresentation Method (Byte[], ILoadOptions)

Reads an existing presentation from array with additional load options

[Visual Basic]
NotOverridable Overloads Public Function ReadPresentation( _
ByVal data As Byte(), _
ByVal options As ILoadOptions _
) As IPresentation _
Implements IPresentationFactory.ReadPresentation
[C#]
public IPresentation ReadPresentation(
byte[] data,
ILoadOptions options
);

Parameters

data
Array to read
options
Load options

Return Value

Read presentation

Implements

IPresentationFactory.ReadPresentation

See Also

PresentationFactory Class | Aspose.Slides Namespace | PresentationFactory.ReadPresentation Overload List


PresentationFactory.ReadPresentation Method (Stream)

Reads an existing presentation from stream

[Visual Basic]
NotOverridable Overloads Public Function ReadPresentation( _
ByVal stream As Stream _
) As IPresentation _
Implements IPresentationFactory.ReadPresentation
[C#]
public IPresentation ReadPresentation(
Stream stream
);

Parameters

stream
Input stream to read

Return Value

Read presentation

Implements

IPresentationFactory.ReadPresentation

See Also

PresentationFactory Class | Aspose.Slides Namespace | PresentationFactory.ReadPresentation Overload List


PresentationFactory.ReadPresentation Method (Stream, ILoadOptions)

Reads an existing presentation from stream with additional load options

[Visual Basic]
NotOverridable Overloads Public Function ReadPresentation( _
ByVal stream As Stream, _
ByVal options As ILoadOptions _
) As IPresentation _
Implements IPresentationFactory.ReadPresentation
[C#]
public IPresentation ReadPresentation(
Stream stream,
ILoadOptions options
);

Parameters

stream
Input stream to read
options
Load options

Return Value

Read presentation

Implements

IPresentationFactory.ReadPresentation

See Also

PresentationFactory Class | Aspose.Slides Namespace | PresentationFactory.ReadPresentation Overload List


PresentationFactory.ReadPresentation Method (String)

Reads an existing presentation from file

[Visual Basic]
NotOverridable Overloads Public Function ReadPresentation( _
ByVal file As String _
) As IPresentation _
Implements IPresentationFactory.ReadPresentation
[C#]
public IPresentation ReadPresentation(
string file
);

Parameters

file
File name

Return Value

Read presentation

Implements

IPresentationFactory.ReadPresentation

See Also

PresentationFactory Class | Aspose.Slides Namespace | PresentationFactory.ReadPresentation Overload List


PresentationFactory.ReadPresentation Method (String, ILoadOptions)

Reads an existing presentation from stream with additional load options

[Visual Basic]
NotOverridable Overloads Public Function ReadPresentation( _
ByVal file As String, _
ByVal options As ILoadOptions _
) As IPresentation _
Implements IPresentationFactory.ReadPresentation
[C#]
public IPresentation ReadPresentation(
string file,
ILoadOptions options
);

Parameters

file
File name
options
Load options

Return Value

Read presentation

Implements

IPresentationFactory.ReadPresentation

See Also

PresentationFactory Class | Aspose.Slides Namespace | PresentationFactory.ReadPresentation Overload List


PresetColor Enumeration

[Visual Basic]
Public Enum PresetColor
[C#]
public enum PresetColor

Members

Member Name | Description | Value
NotDefined |  | -1
AliceBlue |  | 0
AntiqueWhite |  | 1
Aqua |  | 2
Aquamarine |  | 3
Azure |  | 4
Beige |  | 5
Bisque |  | 6
Black |  | 7
BlanchedAlmond |  | 8
Blue |  | 9
BlueViolet |  | 10
Brown |  | 11
BurlyWood |  | 12
CadetBlue |  | 13
Chartreuse |  | 14
Chocolate |  | 15
Coral |  | 16
CornflowerBlue |  | 17
Cornsilk |  | 18
Crimson |  | 19
Cyan |  | 20
DarkBlue |  | 21
DarkCyan |  | 22
DarkGoldenrod |  | 23
DarkGray |  | 24
DarkGreen |  | 25
DarkKhaki |  | 26
DarkMagenta |  | 27
DarkOliveGreen |  | 28
DarkOrange |  | 29
DarkOrchid |  | 30
DarkRed |  | 31
DarkSalmon |  | 32
DarkSeaGreen |  | 33
DarkSlateBlue |  | 34
DarkSlateGray |  | 35
DarkTurquoise |  | 36
DarkViolet |  | 37
DeepPink |  | 38
DeepSkyBlue |  | 39
DimGray |  | 40
DodgerBlue |  | 41
Firebrick |  | 42
FloralWhite |  | 43
ForestGreen |  | 44
Fuchsia |  | 45
Gainsboro |  | 46
GhostWhite |  | 47
Gold |  | 48
Goldenrod |  | 49
Gray |  | 50
Green |  | 51
GreenYellow |  | 52
Honeydew |  | 53
HotPink |  | 54
IndianRed |  | 55
Indigo |  | 56
Ivory |  | 57
Khaki |  | 58
Lavender |  | 59
LavenderBlush |  | 60
LawnGreen |  | 61
LemonChiffon |  | 62
LightBlue |  | 63
LightCoral |  | 64
LightCyan |  | 65
LightGoldenrodYellow |  | 66
LightGray |  | 67
LightGreen |  | 68
LightPink |  | 69
LightSalmon |  | 70
LightSeaGreen |  | 71
LightSkyBlue |  | 72
LightSlateGray |  | 73
LightSteelBlue |  | 74
LightYellow |  | 75
Lime |  | 76
LimeGreen |  | 77
Linen |  | 78
Magenta |  | 79
Maroon |  | 80
MediumAquamarine |  | 81
MediumBlue |  | 82
MediumOrchid |  | 83
MediumPurple |  | 84
MediumSeaGreen |  | 85
MediumSlateBlue |  | 86
MediumSpringGreen |  | 87
MediumTurquoise |  | 88
MediumVioletRed |  | 89
MidnightBlue |  | 90
MintCream |  | 91
MistyRose |  | 92
Moccasin |  | 93
NavajoWhite |  | 94
Navy |  | 95
OldLace |  | 96
Olive |  | 97
OliveDrab |  | 98
Orange |  | 99
OrangeRed |  | 100
Orchid |  | 101
PaleGoldenrod |  | 102
PaleGreen |  | 103
PaleTurquoise |  | 104
PaleVioletRed |  | 105
PapayaWhip |  | 106
PeachPuff |  | 107
Peru |  | 108
Pink |  | 109
Plum |  | 110
PowderBlue |  | 111
Purple |  | 112
Red |  | 113
RosyBrown |  | 114
RoyalBlue |  | 115
SaddleBrown |  | 116
Salmon |  | 117
SandyBrown |  | 118
SeaGreen |  | 119
SeaShell |  | 120
Sienna |  | 121
Silver |  | 122
SkyBlue |  | 123
SlateBlue |  | 124
SlateGray |  | 125
Snow |  | 126
SpringGreen |  | 127
SteelBlue |  | 128
Tan |  | 129
Teal |  | 130
Thistle |  | 131
Tomato |  | 132
Turquoise |  | 133
Violet |  | 134
Wheat |  | 135
White |  | 136
WhiteSmoke |  | 137
Yellow |  | 138
YellowGreen |  | 139

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


PresetShadowType Enumeration

[Visual Basic]
Public Enum PresetShadowType
[C#]
public enum PresetShadowType

Members

Member Name | Description | Value
TopLeftDropShadow |  | 0
TopLeftLargeDropShadow |  | 1
BackLeftLongPerspectiveShadow |  | 2
BackRightLongPerspectiveShadow |  | 3
TopLeftDoubleDropShadow |  | 4
BottomRightSmallDropShadow |  | 5
FrontLeftLongPerspectiveShadow |  | 6
FrontRightLongPerspectiveShadow |  | 7
OuterBoxShadow3D |  | 8
InnerBoxShadow3D |  | 9
BackCenterPerspectiveShadow |  | 10
TopRightDropShadow |  | 11
FrontBottomShadow |  | 12
BackLeftPerspectiveShadow |  | 13
BackRightPerspectiveShadow |  | 14
BottomLeftDropShadow |  | 15
BottomRightDropShadow |  | 16
FrontLeftPerspectiveShadow |  | 17
FrontRightPerspectiveShadow |  | 18
TopLeftSmallDropShadow |  | 19

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


ProtectionManager Class

For a list of all members of this type, see ProtectionManager Members.

System.Object
Aspose.Slides.ProtectionManager

[Visual Basic]
NotInheritable Public Class ProtectionManager
Implements IProtectionManager
[C#]
public sealed class ProtectionManager : IProtectionManager

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ProtectionManager Members | Aspose.Slides Namespace


ProtectionManager Members

ProtectionManager overview

Public Instance Properties

EncryptDocumentProperties | This property makes sense, if presentation is password protected. If true then document properties is encrypted in presentation file. If false then document properties is public while presentation is encrypted.
EncryptionPassword |
IsEncrypted | Gets a value indicating whether this instance is encrypted.
IsOnlyDocumentPropertiesLoaded | This property makes sense, if presentation file is password protected and document properties of this file are public. Value of true means that only document properties are loaded from an encrypted presentation file without use of password. Value of false means that entire encrypted presentation is loaded with use of right password, not only document properties are loaded. If presentation isn't encrypted then property value is always false. If document properties of an encrypted file aren't public then property value is always false. If Presentation.EncryptDocumentProperties is true than IsOnlyDocumentPropertiesLoaded property value is always false.
IsWriteProtected | Gets a value indicating whether this presentation is write protected.

Public Instance Methods

Encrypt | Encrypts Presentation with specified password.
RemoveEncryption | Removes the encryption.
RemoveWriteProtection | Removes write protection for this presentation.
SetWriteProtection | Set write protection for this presentation with specified password.

See Also

ProtectionManager Class | Aspose.Slides Namespace


ProtectionManager Properties

The properties of the ProtectionManager class are listed below. For a complete list of ProtectionManager class members, see the ProtectionManager Members topic.

Public Instance Properties

EncryptDocumentProperties | This property makes sense, if presentation is password protected. If true then document properties is encrypted in presentation file. If false then document properties is public while presentation is encrypted.
EncryptionPassword |
IsEncrypted | Gets a value indicating whether this instance is encrypted.
IsOnlyDocumentPropertiesLoaded | This property makes sense, if presentation file is password protected and document properties of this file are public. Value of true means that only document properties are loaded from an encrypted presentation file without use of password. Value of false means that entire encrypted presentation is loaded with use of right password, not only document properties are loaded. If presentation isn't encrypted then property value is always false. If document properties of an encrypted file aren't public then property value is always false. If Presentation.EncryptDocumentProperties is true than IsOnlyDocumentPropertiesLoaded property value is always false.
IsWriteProtected | Gets a value indicating whether this presentation is write protected.

See Also

ProtectionManager Class | Aspose.Slides Namespace


EncryptDocumentProperties Property

Aspose.Slides Documentation

ProtectionManager.EncryptDocumentProperties Property

This property makes sense, if presentation is password protected. If true then document properties is encrypted in presentation file. If false then document properties is public while presentation is encrypted.

[Visual Basic]
NotOverridable Public Property EncryptDocumentProperties As Boolean _
Implements IProtectionManager.EncryptDocumentProperties
[C#]
public bool EncryptDocumentProperties {get; set;}

Implements

IProtectionManager.EncryptDocumentProperties

See Also

ProtectionManager Class | Aspose.Slides Namespace


EncryptionPassword Property

Aspose.Slides Documentation

ProtectionManager.EncryptionPassword Property

[Visual Basic]
NotOverridable Public ReadOnly Property EncryptionPassword As String _
Implements IProtectionManager.EncryptionPassword
[C#]
public string EncryptionPassword {get;}

Implements

IProtectionManager.EncryptionPassword

See Also

ProtectionManager Class | Aspose.Slides Namespace


IsEncrypted Property

Aspose.Slides Documentation

ProtectionManager.IsEncrypted Property

Gets a value indicating whether this instance is encrypted.

[Visual Basic]
NotOverridable Public ReadOnly Property IsEncrypted As Boolean _
Implements IProtectionManager.IsEncrypted
[C#]
public bool IsEncrypted {get;}

Property Value

true if presentation was loaded from encrypted file or Encrypt method was called ; otherwise, false.

Implements

IProtectionManager.IsEncrypted

See Also

ProtectionManager Class | Aspose.Slides Namespace


IsOnlyDocumentPropertiesLoaded Property

Aspose.Slides Documentation

ProtectionManager.IsOnlyDocumentPropertiesLoaded Property

This property makes sense, if presentation file is password protected and document properties of this file are public. Value of true means that only document properties are loaded from an encrypted presentation file without use of password. Value of false means that entire encrypted presentation is loaded with use of right password, not only document properties are loaded. If presentation isn't encrypted then property value is always false. If document properties of an encrypted file aren't public then property value is always false. If Presentation.EncryptDocumentProperties is true than IsOnlyDocumentPropertiesLoaded property value is always false.

[Visual Basic]
NotOverridable Public ReadOnly Property IsOnlyDocumentPropertiesLoaded As Boolean _
Implements IProtectionManager.IsOnlyDocumentPropertiesLoaded
[C#]
public bool IsOnlyDocumentPropertiesLoaded {get;}

Implements

IProtectionManager.IsOnlyDocumentPropertiesLoaded

See Also

ProtectionManager Class | Aspose.Slides Namespace


IsWriteProtected Property

Aspose.Slides Documentation

ProtectionManager.IsWriteProtected Property

Gets a value indicating whether this presentation is write protected.

[Visual Basic]
NotOverridable Public ReadOnly Property IsWriteProtected As Boolean _
Implements IProtectionManager.IsWriteProtected
[C#]
public bool IsWriteProtected {get;}

Implements

IProtectionManager.IsWriteProtected

See Also

ProtectionManager Class | Aspose.Slides Namespace


ProtectionManager Methods

The methods of the ProtectionManager class are listed below. For a complete list of ProtectionManager class members, see the ProtectionManager Members topic.

Public Instance Methods

Encrypt | Encrypts Presentation with specified password.
RemoveEncryption | Removes the encryption.
RemoveWriteProtection | Removes write protection for this presentation.
SetWriteProtection | Set write protection for this presentation with specified password.

See Also

ProtectionManager Class | Aspose.Slides Namespace


ProtectionManager.Encrypt Method

Encrypts Presentation with specified password.

[Visual Basic]
NotOverridable Public Sub Encrypt( _
ByVal encryptionPassword As String _
) _
Implements IProtectionManager.Encrypt
[C#]
public void Encrypt(
string encryptionPassword
);

Parameters

encryptionPassword
The password.

Implements

IProtectionManager.Encrypt

See Also

ProtectionManager Class | Aspose.Slides Namespace


ProtectionManager.RemoveEncryption Method

Removes the encryption.

[Visual Basic]
NotOverridable Public Sub RemoveEncryption() _
Implements IProtectionManager.RemoveEncryption
[C#]
public void RemoveEncryption();

Implements

IProtectionManager.RemoveEncryption

See Also

ProtectionManager Class | Aspose.Slides Namespace


ProtectionManager.RemoveWriteProtection Method

Removes write protection for this presentation.

[Visual Basic]
NotOverridable Public Sub RemoveWriteProtection() _
Implements IProtectionManager.RemoveWriteProtection
[C#]
public void RemoveWriteProtection();

Implements

IProtectionManager.RemoveWriteProtection

See Also

ProtectionManager Class | Aspose.Slides Namespace


ProtectionManager.SetWriteProtection Method

Set write protection for this presentation with specified password.

[Visual Basic]
NotOverridable Public Sub SetWriteProtection( _
ByVal password As String _
) _
Implements IProtectionManager.SetWriteProtection
[C#]
public void SetWriteProtection(
string password
);

Parameters

password
The password.

Implements

IProtectionManager.SetWriteProtection

See Also

ProtectionManager Class | Aspose.Slides Namespace


RectangleAlignment Enumeration

[Visual Basic]
Public Enum RectangleAlignment
Inherits
[C#]
public enum RectangleAlignment

Members

Member Name | Description | Value
NotDefined |  | -1
TopLeft |  | 0
Top |  | 1
TopRight |  | 2
Left |  | 3
Center |  | 4
Right |  | 5
BottomLeft |  | 6
Bottom |  | 7
BottomRight |  | 8

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


Row Class

Represents a row in a table.

For a list of all members of this type, see Row Members.

System.Object
Aspose.Slides.CellCollection
Aspose.Slides.Row

[Visual Basic]
NotInheritable Public Class Row
Inherits CellCollection
Implements IRow
[C#]
public sealed class Row : CellCollection, IRow

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Row Members | Aspose.Slides Namespace


Row Members

Row overview

Public Instance Properties

Count (inherited from CellCollection) | Returns the number of cells in a collection. Read-only Int32.
Height | Returns the height of a row. Read-only Double.
IsSynchronized (inherited from CellCollection) | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item (inherited from CellCollection) | Returns a cell by it's position. Read-only Cell.
MinimalHeight | Returns or sets the minimal possible height of a row. Read/write Double.
Presentation (inherited from CellCollection) | Returns the parent presentation of a CellCollection. Read-only Presentation.
Slide (inherited from CellCollection) | Returns the parent slide of a CellCollection. Read-only BaseSlide.
SyncRoot (inherited from CellCollection) | Returns a synchronization root. Readonly Object.

Public Instance Methods

CopyTo (inherited from CellCollection) | Copies all elements from the collection to the specified array.
GetEnumerator (inherited from CellCollection) | Returns an enumerator for all cells which top-left corner belongs to this collection. Each cell returned only once.

See Also

Row Class | Aspose.Slides Namespace


Row Properties

The properties of the Row class are listed below. For a complete list of Row class members, see the Row Members topic.

Public Instance Properties

Count (inherited from CellCollection) | Returns the number of cells in a collection. Read-only Int32.
Height | Returns the height of a row. Read-only Double.
IsSynchronized (inherited from CellCollection) | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item (inherited from CellCollection) | Returns a cell by it's position. Read-only Cell.
MinimalHeight | Returns or sets the minimal possible height of a row. Read/write Double.
Presentation (inherited from CellCollection) | Returns the parent presentation of a CellCollection. Read-only Presentation.
Slide (inherited from CellCollection) | Returns the parent slide of a CellCollection. Read-only BaseSlide.
SyncRoot (inherited from CellCollection) | Returns a synchronization root. Readonly Object.

See Also

Row Class | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

Row.Height Property

Returns the height of a row. Read-only Double.

[Visual Basic]
NotOverridable Public ReadOnly Property Height As Double _
Implements IRow.Height
[C#]
public double Height {get;}

Implements

IRow.Height

See Also

Row Class | Aspose.Slides Namespace


MinimalHeight Property

Aspose.Slides Documentation

Row.MinimalHeight Property

Returns or sets the minimal possible height of a row. Read/write Double.

[Visual Basic]
NotOverridable Public Property MinimalHeight As Double _
Implements IRow.MinimalHeight
[C#]
public double MinimalHeight {get; set;}

Implements

IRow.MinimalHeight

See Also

Row Class | Aspose.Slides Namespace


RowCollection Class

Represents a collection of rows.

For a list of all members of this type, see RowCollection Members.

System.Object
Aspose.Slides.RowCollection

[Visual Basic]
NotInheritable Public Class RowCollection
Implements IRowCollection, ICollection, IEnumerable
[C#]
public sealed class RowCollection : IRowCollection, ICollection, IEnumerable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

RowCollection Members | Aspose.Slides Namespace


RowCollection Members

RowCollection overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

AddClone | Creates a copy of the specified template row and inserts it at the bottom of a table.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
InsertClone | Creates a copy of the specified template row and insert it at the specified position in a table.
RemoveAt | Removes a row at the specified position from a table.

See Also

RowCollection Class | Aspose.Slides Namespace


RowCollection Properties

The properties of the RowCollection class are listed below. For a complete list of RowCollection class members, see the RowCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

RowCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

RowCollection.Count Property

Gets the number of elements actually contained in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

RowCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

RowCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

RowCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

RowCollection.Item Property

Gets the element at the specified index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IRowCollection.Item
As IRow _
Implements IRowCollection.Item
[C#]
public IRow this[
int index
] {get;}

Implements

IRowCollection.Item

See Also

RowCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

RowCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

RowCollection Class | Aspose.Slides Namespace


RowCollection Methods

The methods of the RowCollection class are listed below. For a complete list of RowCollection class members, see the RowCollection Members topic.

Public Instance Methods

AddClone | Creates a copy of the specified template row and inserts it at the bottom of a table.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
InsertClone | Creates a copy of the specified template row and insert it at the specified position in a table.
RemoveAt | Removes a row at the specified position from a table.

See Also

RowCollection Class | Aspose.Slides Namespace


RowCollection.AddClone Method

Creates a copy of the specified template row and inserts it at the bottom of a table.

[Visual Basic]
NotOverridable Public Function AddClone( _
ByVal templ As IRow, _
ByVal withAttachedRows As Boolean _
) As IRow() _
Implements IRowCollection.AddClone
[C#]
public IRow[] AddClone(
IRow templ,
bool withAttachedRows
);

Parameters

templ
Row which is used as a template.
withAttachedRows
True to copy also all rows attached to the template row.

Return Value

Added rows.

Implements

IRowCollection.AddClone

See Also

RowCollection Class | Aspose.Slides Namespace


RowCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

RowCollection Class | Aspose.Slides Namespace


RowCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

RowCollection Class | Aspose.Slides Namespace


RowCollection.InsertClone Method

Creates a copy of the specified template row and insert it at the specified position in a table.

[Visual Basic]
NotOverridable Public Function InsertClone( _
ByVal index As Integer, _
ByVal templ As IRow, _
ByVal withAttachedRows As Boolean _
) As IRow() _
Implements IRowCollection.InsertClone
[C#]
public IRow[] InsertClone(
int index,
IRow templ,
bool withAttachedRows
);

Parameters

index
Index of a new row.
templ
Row which is used as a template.
withAttachedRows
True to copy also all rows attached to the template row.

Return Value

Inserted rows.

Implements

IRowCollection.InsertClone

See Also

RowCollection Class | Aspose.Slides Namespace


RowCollection.RemoveAt Method

Removes a row at the specified position from a table.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal firstRowIndex As Integer, _
ByVal withAttachedRows As Boolean _
) _
Implements IRowCollection.RemoveAt
[C#]
public void RemoveAt(
int firstRowIndex,
bool withAttachedRows
);

Parameters

firstRowIndex
Index of a row to delete.
withAttachedRows
True to delete also all attached rows.

Implements

IRowCollection.RemoveAt

See Also

RowCollection Class | Aspose.Slides Namespace


SchemeColor Enumeration

[Visual Basic]
Public Enum SchemeColor
[C#]
public enum SchemeColor

Members

Member Name | Description | Value
NotDefined |  | -1
Background1 |  | 0
Text1 |  | 1
Background2 |  | 2
Text2 |  | 3
Accent1 |  | 4
Accent2 |  | 5
Accent3 |  | 6
Accent4 |  | 7
Accent5 |  | 8
Accent6 |  | 9
Hyperlink |  | 10
FollowedHyperlink |  | 11
StyleColor |  | 12
Dark1 |  | 13
Light1 |  | 14
Dark2 |  | 15
Light2 |  | 16

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


Shape Class

Represents a shape on a slide.

For a list of all members of this type, see Shape Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GeometryShape
Aspose.Slides.GraphicalObject
Aspose.Slides.GroupShape

[Visual Basic]
Public Class Shape
Implements IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public class Shape : IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Shape Members | Aspose.Slides Namespace


Shape Members

Shape overview

Public Instance Properties

AlternativeText | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData | Returns the shape's custom data. Read-only ICustomData.
EffectFormat | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height | Returns or sets the height of the shape. Read/write Int32.
Hidden | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager |
HyperlinkMouseOver | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock | Returns shape's locks. Read-only IBaseShapeLock.
Slide | Returns the parent slide of a shape. Read-only BaseSlide.
Tags | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId | Gets unique shape identifier in presentation scope.
Width | Returns or sets the width of the shape. Read/write Int32.
X | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateThreeDFormatEffective | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail | Overloaded.
RemovePlaceholder | Defines that this shape isn't a placeholder.

See Also

Shape Class | Aspose.Slides Namespace


Shape Properties

The properties of the Shape class are listed below. For a complete list of Shape class members, see the Shape Members topic.

Public Instance Properties

AlternativeText | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData | Returns the shape's custom data. Read-only ICustomData.
EffectFormat | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height | Returns or sets the height of the shape. Read/write Int32.
Hidden | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager |
HyperlinkMouseOver | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock | Returns shape's locks. Read-only IBaseShapeLock.
Slide | Returns the parent slide of a shape. Read-only BaseSlide.
Tags | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId | Gets unique shape identifier in presentation scope.
Width | Returns or sets the width of the shape. Read/write Int32.
X | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

Shape Class | Aspose.Slides Namespace


AlternativeText Property

Aspose.Slides Documentation

Shape.AlternativeText Property

Returns or sets the alternative text associated with a shape. Read/write String.

[Visual Basic]
Overridable Public Property AlternativeText As String _
Implements IShape.AlternativeText
[C#]
public virtual string AlternativeText {get; set;}

Implements

IShape.AlternativeText

See Also

Shape Class | Aspose.Slides Namespace


CustomData Property

Aspose.Slides Documentation

Shape.CustomData Property

Returns the shape's custom data. Read-only ICustomData.

[Visual Basic]
NotOverridable Public ReadOnly Property CustomData As ICustomData _
Implements IShape.CustomData
[C#]
public ICustomData CustomData {get;}

Implements

IShape.CustomData

See Also

Shape Class | Aspose.Slides Namespace


EffectFormat Property

Aspose.Slides Documentation

Shape.EffectFormat Property

Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.

[Visual Basic]
Overridable Public ReadOnly Property EffectFormat As IEffectFormat _
Implements IShape.EffectFormat
[C#]
public virtual IEffectFormat EffectFormat {get;}

Implements

IShape.EffectFormat

See Also

Shape Class | Aspose.Slides Namespace


FillFormat Property

Aspose.Slides Documentation

Shape.FillFormat Property

Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.

[Visual Basic]
Overridable Public ReadOnly Property FillFormat As IFillFormat _
Implements IShape.FillFormat
[C#]
public virtual IFillFormat FillFormat {get;}

Implements

IShape.FillFormat

See Also

Shape Class | Aspose.Slides Namespace


Frame Property

Aspose.Slides Documentation

Shape.Frame Property

Returns or sets the shape frame's properties. Read/write ShapeFrame.

[Visual Basic]
NotOverridable Public Property Frame As IShapeFrame _
Implements IShape.Frame
[C#]
public IShapeFrame Frame {get; set;}

Implements

IShape.Frame

See Also

Shape Class | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

Shape.Height Property

Returns or sets the height of the shape. Read/write Int32.

[Visual Basic]
NotOverridable Public Property Height As Single _
Implements IShape.Height
[C#]
public float Height {get; set;}

Implements

IShape.Height

See Also

Shape Class | Aspose.Slides Namespace


Hidden Property

Aspose.Slides Documentation

Shape.Hidden Property

Determines whether the shape is hidden. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property Hidden As Boolean _
Implements IShape.Hidden
[C#]
public bool Hidden {get; set;}

Implements

IShape.Hidden

See Also

Shape Class | Aspose.Slides Namespace


HLinkClick Property

Aspose.Slides Documentation

Shape.HLinkClick Property

NOTE: This property is now obsolete.

Use HyperlinkClick property instead. Property will be removed after 01.09.2013.

Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.

[Visual Basic]
Public Property HLinkClick As Hyperlink
[C#]
public Hyperlink HLinkClick {get; set;}

See Also

Shape Class | Aspose.Slides Namespace


HLinkMouseOver Property

Aspose.Slides Documentation

Shape.HLinkMouseOver Property

NOTE: This property is now obsolete.

Use HyperlinkMouseOver property instead. Property will be removed after 01.09.2013.

Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.

[Visual Basic]
Public Property HLinkMouseOver As Hyperlink
[C#]
public Hyperlink HLinkMouseOver {get; set;}

See Also

Shape Class | Aspose.Slides Namespace


HyperlinkClick Property

Aspose.Slides Documentation

Shape.HyperlinkClick Property

Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.

[Visual Basic]
NotOverridable Public Property HyperlinkClick As IHyperlink _
Implements IHyperlinkContainer.HyperlinkClick
[C#]
public IHyperlink HyperlinkClick {get; set;}

Implements

IHyperlinkContainer.HyperlinkClick

See Also

Shape Class | Aspose.Slides Namespace


HyperlinkManager Property

Aspose.Slides Documentation

Shape.HyperlinkManager Property

[Visual Basic]
NotOverridable Public ReadOnly Property HyperlinkManager As IHyperlinkManager _
Implements IHyperlinkContainer.HyperlinkManager
[C#]
public IHyperlinkManager HyperlinkManager {get;}

Implements

IHyperlinkContainer.HyperlinkManager

See Also

Shape Class | Aspose.Slides Namespace


HyperlinkMouseOver Property

Aspose.Slides Documentation

Shape.HyperlinkMouseOver Property

Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.

[Visual Basic]
NotOverridable Public Property HyperlinkMouseOver As IHyperlink _
Implements IHyperlinkContainer.HyperlinkMouseOver
[C#]
public IHyperlink HyperlinkMouseOver {get; set;}

Implements

IHyperlinkContainer.HyperlinkMouseOver

See Also

Shape Class | Aspose.Slides Namespace


IsTextHolder Property

Aspose.Slides Documentation

Shape.IsTextHolder Property

Determines whether the shape is TextHolder_PPT. Read-only Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property IsTextHolder As Boolean _
Implements IShape.IsTextHolder
[C#]
public bool IsTextHolder {get;}

Implements

IShape.IsTextHolder

See Also

Shape Class | Aspose.Slides Namespace


LineFormat Property

Aspose.Slides Documentation

Shape.LineFormat Property

Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.

[Visual Basic]
Overridable Public ReadOnly Property LineFormat As ILineFormat _
Implements IShape.LineFormat
[C#]
public virtual ILineFormat LineFormat {get;}

Implements

IShape.LineFormat

See Also

Shape Class | Aspose.Slides Namespace


Name Property

Aspose.Slides Documentation

Shape.Name Property

Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.

[Visual Basic]
Overridable Public Property Name As String _
Implements IShape.Name
[C#]
public virtual string Name {get; set;}

Implements

IShape.Name

See Also

Shape Class | Aspose.Slides Namespace


Placeholder Property

Aspose.Slides Documentation

Shape.Placeholder Property

Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.

[Visual Basic]
NotOverridable Public ReadOnly Property Placeholder As IPlaceholder _
Implements IShape.Placeholder
[C#]
public IPlaceholder Placeholder {get;}

Implements

IShape.Placeholder

See Also

Shape Class | Aspose.Slides Namespace


Presentation Property

Aspose.Slides Documentation

Shape.Presentation Property

Returns the parent presentation of a slide. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

Shape Class | Aspose.Slides Namespace


RawFrame Property

Aspose.Slides Documentation

Shape.RawFrame Property

Returns or sets the raw shape frame's properties. Read/write ShapeFrame.

[Visual Basic]
NotOverridable Public Property RawFrame As IShapeFrame _
Implements IShape.RawFrame
[C#]
public IShapeFrame RawFrame {get; set;}

Implements

IShape.RawFrame

See Also

Shape Class | Aspose.Slides Namespace


Rotation Property

Aspose.Slides Documentation

Shape.Rotation Property

Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.

[Visual Basic]
Overridable Public Property Rotation As Single _
Implements IShape.Rotation
[C#]
public virtual float Rotation {get; set;}

Implements

IShape.Rotation

See Also

Shape Class | Aspose.Slides Namespace


ShapeLock Property

Aspose.Slides Documentation

Shape.ShapeLock Property

Returns shape's locks. Read-only IBaseShapeLock.

[Visual Basic]
NotOverridable Public Property ShapeLock As IBaseShapeLock _
Implements IShape.ShapeLock
[C#]
public IBaseShapeLock ShapeLock {get; set;}

Implements

IShape.ShapeLock

See Also

Shape Class | Aspose.Slides Namespace


Slide Property

Aspose.Slides Documentation

Shape.Slide Property

Returns the parent slide of a shape. Read-only BaseSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As IBaseSlide _
Implements ISlideComponent.Slide
[C#]
public IBaseSlide Slide {get;}

Implements

ISlideComponent.Slide

See Also

Shape Class | Aspose.Slides Namespace


Tags Property

Aspose.Slides Documentation

Shape.Tags Property

NOTE: This property is now obsolete.

Use CustomData.Tags instead. Will be removed after 01.09.2014.

Returns the shape's tags collection. Read-only ITagCollection.

[Visual Basic]
Public ReadOnly Property Tags As ITagCollection
[C#]
public ITagCollection Tags {get;}

See Also

Shape Class | Aspose.Slides Namespace


ThreeDFormat Property

Aspose.Slides Documentation

Shape.ThreeDFormat Property

Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.

[Visual Basic]
Overridable Public ReadOnly Property ThreeDFormat As IThreeDFormat _
Implements IShape.ThreeDFormat
[C#]
public virtual IThreeDFormat ThreeDFormat {get;}

Implements

IShape.ThreeDFormat

See Also

Shape Class | Aspose.Slides Namespace


UniqueId Property

Aspose.Slides Documentation

Shape.UniqueId Property

Gets unique shape identifier in presentation scope.

[Visual Basic]
NotOverridable Public ReadOnly Property UniqueId As UInt32 _
Implements IShape.UniqueId
[C#]
public uint UniqueId {get;}

Implements

IShape.UniqueId

See Also

Shape Class | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

Shape.Width Property

Returns or sets the width of the shape. Read/write Int32.

[Visual Basic]
NotOverridable Public Property Width As Single _
Implements IShape.Width
[C#]
public float Width {get; set;}

Implements

IShape.Width

See Also

Shape Class | Aspose.Slides Namespace


X Property

Aspose.Slides Documentation

Shape.X Property

Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.

[Visual Basic]
Overridable Public Property X As Single _
Implements IShape.X
[C#]
public virtual float X {get; set;}

Implements

IShape.X

See Also

Shape Class | Aspose.Slides Namespace


Y Property

Aspose.Slides Documentation

Shape.Y Property

Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.

[Visual Basic]
Overridable Public Property Y As Single _
Implements IShape.Y
[C#]
public virtual float Y {get; set;}

Implements

IShape.Y

See Also

Shape Class | Aspose.Slides Namespace


ZOrderPosition Property

Aspose.Slides Documentation

Shape.ZOrderPosition Property

Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

[Visual Basic]
Overridable Public ReadOnly Property ZOrderPosition As Integer _
Implements IShape.ZOrderPosition
[C#]
public virtual int ZOrderPosition {get;}

Implements

IShape.ZOrderPosition

See Also

Shape Class | Aspose.Slides Namespace


Shape Methods

The methods of the Shape class are listed below. For a complete list of Shape class members, see the Shape Members topic.

Public Instance Methods

AddPlaceholder | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateThreeDFormatEffective | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail | Overloaded.
RemovePlaceholder | Defines that this shape isn't a placeholder.

See Also

Shape Class | Aspose.Slides Namespace


Shape.AddPlaceholder Method

Adds a new placeholder if there is no and sets placeholder properties to a specified one.

[Visual Basic]
NotOverridable Public Function AddPlaceholder( _
ByVal placeholderToCopyFrom As IPlaceholder _
) As IPlaceholder _
Implements IShape.AddPlaceholder
[C#]
public IPlaceholder AddPlaceholder(
IPlaceholder placeholderToCopyFrom
);

Parameters

placeholderToCopyFrom
Placeholder to copy content from.

Return Value

New Placeholder.

Implements

IShape.AddPlaceholder

See Also

Shape Class | Aspose.Slides Namespace


Shape.CreateEffectFormatEffective Method

Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.

[Visual Basic]
NotOverridable Public Function CreateEffectFormatEffective() As IEffectFormatEffectiveData _
Implements IShape.CreateEffectFormatEffective
[C#]
public IEffectFormatEffectiveData CreateEffectFormatEffective();

Return Value

EffectFormatEffectiveData.

Implements

IShape.CreateEffectFormatEffective

See Also

Shape Class | Aspose.Slides Namespace


Shape.CreateFillFormatEffective Method

Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.

[Visual Basic]
NotOverridable Public Function CreateFillFormatEffective() As IFillFormatEffectiveData _
Implements IShape.CreateFillFormatEffective
[C#]
public IFillFormatEffectiveData CreateFillFormatEffective();

Return Value

FillFormatEffectiveData.

Implements

IShape.CreateFillFormatEffective

See Also

Shape Class | Aspose.Slides Namespace


Shape.CreateLineFormatEffective Method

Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.

[Visual Basic]
NotOverridable Public Function CreateLineFormatEffective() As ILineFormatEffectiveData _
Implements IShape.CreateLineFormatEffective
[C#]
public ILineFormatEffectiveData CreateLineFormatEffective();

Return Value

LineFormatEffectiveData.

Implements

IShape.CreateLineFormatEffective

See Also

Shape Class | Aspose.Slides Namespace


Shape.CreateThreeDFormatEffective Method

Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.

[Visual Basic]
NotOverridable Public Function CreateThreeDFormatEffective() As IThreeDFormatEffectiveData _
Implements IShape.CreateThreeDFormatEffective
[C#]
public IThreeDFormatEffectiveData CreateThreeDFormatEffective();

Return Value

FillFormatEffectiveData.

Implements

IShape.CreateThreeDFormatEffective

See Also

Shape Class | Aspose.Slides Namespace


GetThumbnail Method

Aspose.Slides Documentation

Shape.GetThumbnail Method

Overload List

public Bitmap GetThumbnail();

public Bitmap GetThumbnail(ShapeThumbnailBounds,float,float);

See Also

Shape Class | Aspose.Slides Namespace


Shape.GetThumbnail Method ()

[Visual Basic]
NotOverridable Overloads Public Function GetThumbnail() As Bitmap _
Implements IShape.GetThumbnail
[C#]
public Bitmap GetThumbnail();

Implements

IShape.GetThumbnail

See Also

Shape Class | Aspose.Slides Namespace | Shape.GetThumbnail Overload List


Shape.GetThumbnail Method (ShapeThumbnailBounds, Single, Single)

[Visual Basic]
NotOverridable Overloads Public Function GetThumbnail( _
ByVal bounds As ShapeThumbnailBounds, _
ByVal scaleX As Single, _
ByVal scaleY As Single _
) As Bitmap _
Implements IShape.GetThumbnail
[C#]
public Bitmap GetThumbnail(
ShapeThumbnailBounds bounds,
float scaleX,
float scaleY
);

Implements

IShape.GetThumbnail

See Also

Shape Class | Aspose.Slides Namespace | Shape.GetThumbnail Overload List


Shape.RemovePlaceholder Method

Defines that this shape isn't a placeholder.

[Visual Basic]
NotOverridable Public Sub RemovePlaceholder() _
Implements IShape.RemovePlaceholder
[C#]
public void RemovePlaceholder();

Implements

IShape.RemovePlaceholder

See Also

Shape Class | Aspose.Slides Namespace


ShapeBevel Class

Contains the properties of shape's main face relief.

For a list of all members of this type, see ShapeBevel Members.

System.Object
Aspose.Slides.ShapeBevel

[Visual Basic]
Public Class ShapeBevel
Implements IShapeBevel
[C#]
public class ShapeBevel : IShapeBevel

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ShapeBevel Members | Aspose.Slides Namespace


ShapeBevel Members

ShapeBevel overview

Public Instance Constructors

ShapeBevel Constructor Shape bevel constructor.

Public Instance Properties

BevelType | Bevel type. Read/write BevelPresetType
Height | Bevel height. Read/write Double
Width | Bevel width. Read/write Double

Public Instance Methods

Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

ShapeBevel Class | Aspose.Slides Namespace


ShapeBevel Constructor

Shape bevel constructor.

[Visual Basic]
Public Sub New( _
ByVal bIsTopBevel As Boolean _
)
[C#]
public ShapeBevel(
bool bIsTopBevel
);

Parameters

bIsTopBevel
True to create top bevel.

See Also

ShapeBevel Class | Aspose.Slides Namespace


ShapeBevel Properties

The properties of the ShapeBevel class are listed below. For a complete list of ShapeBevel class members, see the ShapeBevel Members topic.

Public Instance Properties

BevelType | Bevel type. Read/write BevelPresetType
Height | Bevel height. Read/write Double
Width | Bevel width. Read/write Double

See Also

ShapeBevel Class | Aspose.Slides Namespace


BevelType Property

Aspose.Slides Documentation

ShapeBevel.BevelType Property

Bevel type. Read/write BevelPresetType

[Visual Basic]
NotOverridable Public Property BevelType As BevelPresetType _
Implements IShapeBevel.BevelType
[C#]
public BevelPresetType BevelType {get; set;}

Implements

IShapeBevel.BevelType

See Also

ShapeBevel Class | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

ShapeBevel.Height Property

Bevel height. Read/write Double

[Visual Basic]
NotOverridable Public Property Height As Double _
Implements IShapeBevel.Height
[C#]
public double Height {get; set;}

Implements

IShapeBevel.Height

See Also

ShapeBevel Class | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

ShapeBevel.Width Property

Bevel width. Read/write Double

[Visual Basic]
NotOverridable Public Property Width As Double _
Implements IShapeBevel.Width
[C#]
public double Width {get; set;}

Implements

IShapeBevel.Width

See Also

ShapeBevel Class | Aspose.Slides Namespace


ShapeBevel Methods

The methods of the ShapeBevel class are listed below. For a complete list of ShapeBevel class members, see the ShapeBevel Members topic.

Public Instance Methods

Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

ShapeBevel Class | Aspose.Slides Namespace


ShapeBevel.Equals Method

Determines whether two FillFormat instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

See Also

ShapeBevel Class | Aspose.Slides Namespace


ShapeBevel.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Remarks

Overriden to make compiler happy.

See Also

ShapeBevel Class | Aspose.Slides Namespace


ShapeCollection Class

Represents a collection of a shapes.

For a list of all members of this type, see ShapeCollection Members.

System.Object
Aspose.Slides.ShapeCollection

[Visual Basic]
NotInheritable Public Class ShapeCollection
Implements IShapeCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IShape, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public sealed class ShapeCollection : IShapeCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ShapeCollection Members | Aspose.Slides Namespace


ShapeCollection Members

ShapeCollection overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only Shape.
Parent | Returns parent object for a Shapes collection. Read-only Object. See also IPresentationComponent.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

AddAudioFrameCD | Adds an AudioFrame with CD to the end of collection.
AddAudioFrameEmbedded | Overloaded. Adds a new audio frame with embedded audio file to the end of a collection. Embedded audio file can be a WAV only. It adds new audio into Presentation.Audios list.
AddAudioFrameLinked | Adds a new audio frame with linked audio file to the end of a collection.
AddAutoShape | Overloaded. Creates a new AutoShape, tunes it from default template and adds it to the end of the collection.
AddChart | Overloaded. Creates a new Chart, initialize it with sample series data and settings and adds it to the end of the collection.
AddConnector | Overloaded. Creates a new Connector, tunes it from default template and adds it to the end of the collection.
AddOleObjectFrame | Overloaded. Adds a new OLE object to the end of a collection.
AddPictureFrame | Creates a new PictureFrame and adds it to the end of the collection.
AddSmartArt Add SmartArt object Example:
[C#]
Presentation pres = new Presentation();
Slide slide = pres.Slides[0];
SmartArt smart = slide.Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.BasicBlockList);

[Visual Basic]
Private pres As New Presentation()
Private slide As Slide = pres.Slides(0)
Private smart As SmartArt = slide.Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.BasicBlockList)
AddTable | Creates a new Table and adds it to the end of the collection.
AddVideoFrame | Overloaded. Adds a new video frame to the end of a collection.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
IndexOf | Returns the zero-based index of the first occurrence of a shape in the collection.
InsertAudioFrameCD | Insert an AudioFrame with CD.
InsertAudioFrameEmbedded | Overloaded. Insert an AudioFrame with embedded audio file. Embedded audio file sound can be a WAV only.
InsertAudioFrameLinked | Creates a new audio frame with linked audio file and inserts it to a collection at the specified index.
InsertAutoShape | Overloaded. Creates a new AutoShape, tunes it from default template and inserts it to the collection at the specified index. Note: the type of the shape will be determined by the shapeType parameter.
InsertChart | Overloaded. Creates a new Chart, initialize it with sample series data and settings and inserts it to the specified position in the collection.
InsertConnector | Overloaded. Creates a new Connector, tunes it from default template and inserts it to the collection at the specified index.
InsertOleObjectFrame | Overloaded. Creates a new OLE object and inserts it to a collection at the specified index.
InsertPictureFrame | Creates a new PictureFrame and inserts it to the collection at the specified index.
InsertTable | Creates a new Table and inserts it to the collection at the specified index.
InsertVideoFrame | Creates a new video frame and inserts it to a collection at the specified index.
Remove | Removes the first occurrence of a specific shape from the collection.
RemoveAt | Removes the element at the specified index of the collection.
Reorder | Overloaded. Moves a shape from the collection to the specified position.
ToArray | Overloaded. Creates and returns an array with all shapse in it.

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection Properties

The properties of the ShapeCollection class are listed below. For a complete list of ShapeCollection class members, see the ShapeCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only Shape.
Parent | Returns parent object for a Shapes collection. Read-only Object. See also IPresentationComponent.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

ShapeCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

ShapeCollection.Count Property

Gets the number of elements actually contained in the collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

ShapeCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

ShapeCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ShapeCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

ShapeCollection.Item Property

Gets the element at the specified index. Read-only Shape.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IShapeCollection.Item
As IShape _
Implements IShapeCollection.Item
[C#]
public IShape this[
int index
] {get;}

Implements

IShapeCollection.Item

See Also

ShapeCollection Class | Aspose.Slides Namespace


Parent Property

Aspose.Slides Documentation

ShapeCollection.Parent Property

Returns parent object for a Shapes collection. Read-only Object. See also IPresentationComponent.

[Visual Basic]
NotOverridable Public ReadOnly Property Parent As ISlideComponent _
Implements IShapeCollection.Parent
[C#]
public ISlideComponent Parent {get;}

Implements

IShapeCollection.Parent

See Also

ShapeCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

ShapeCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection Methods

The methods of the ShapeCollection class are listed below. For a complete list of ShapeCollection class members, see the ShapeCollection Members topic.

Public Instance Methods

AddAudioFrameCD | Adds an AudioFrame with CD to the end of collection.
AddAudioFrameEmbedded | Overloaded. Adds a new audio frame with embedded audio file to the end of a collection. Embedded audio file can be a WAV only. It adds new audio into Presentation.Audios list.
AddAudioFrameLinked | Adds a new audio frame with linked audio file to the end of a collection.
AddAutoShape | Overloaded. Creates a new AutoShape, tunes it from default template and adds it to the end of the collection.
AddChart | Overloaded. Creates a new Chart, initialize it with sample series data and settings and adds it to the end of the collection.
AddConnector | Overloaded. Creates a new Connector, tunes it from default template and adds it to the end of the collection.
AddOleObjectFrame | Overloaded. Adds a new OLE object to the end of a collection.
AddPictureFrame | Creates a new PictureFrame and adds it to the end of the collection.
AddSmartArt Add SmartArt object Example:
[C#]
Presentation pres = new Presentation();
Slide slide = pres.Slides[0];
SmartArt smart = slide.Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.BasicBlockList);

[Visual Basic]
Private pres As New Presentation()
Private slide As Slide = pres.Slides(0)
Private smart As SmartArt = slide.Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.BasicBlockList)
AddTable | Creates a new Table and adds it to the end of the collection.
AddVideoFrame | Overloaded. Adds a new video frame to the end of a collection.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
IndexOf | Returns the zero-based index of the first occurrence of a shape in the collection.
InsertAudioFrameCD | Insert an AudioFrame with CD.
InsertAudioFrameEmbedded | Overloaded. Insert an AudioFrame with embedded audio file. Embedded audio file sound can be a WAV only.
InsertAudioFrameLinked | Creates a new audio frame with linked audio file and inserts it to a collection at the specified index.
InsertAutoShape | Overloaded. Creates a new AutoShape, tunes it from default template and inserts it to the collection at the specified index. Note: the type of the shape will be determined by the shapeType parameter.
InsertChart | Overloaded. Creates a new Chart, initialize it with sample series data and settings and inserts it to the specified position in the collection.
InsertConnector | Overloaded. Creates a new Connector, tunes it from default template and inserts it to the collection at the specified index.
InsertOleObjectFrame | Overloaded. Creates a new OLE object and inserts it to a collection at the specified index.
InsertPictureFrame | Creates a new PictureFrame and inserts it to the collection at the specified index.
InsertTable | Creates a new Table and inserts it to the collection at the specified index.
InsertVideoFrame | Creates a new video frame and inserts it to a collection at the specified index.
Remove | Removes the first occurrence of a specific shape from the collection.
RemoveAt | Removes the element at the specified index of the collection.
Reorder | Overloaded. Moves a shape from the collection to the specified position.
ToArray | Overloaded. Creates and returns an array with all shapse in it.

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.AddAudioFrameCD Method

Adds an AudioFrame with CD to the end of collection.

[Visual Basic]
NotOverridable Public Function AddAudioFrameCD( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IAudioFrame _
Implements IShapeCollection.AddAudioFrameCD
[C#]
public IAudioFrame AddAudioFrameCD(
float x,
float y,
float width,
float height
);

Parameters

x
X coordinate of a new audio frame.
y
Y coordinate of a new audio frame.
width
Width of a new audio frame.
height
Height of a new audio frame.

Return Value

Created AudioFrame object.

Implements

IShapeCollection.AddAudioFrameCD

See Also

ShapeCollection Class | Aspose.Slides Namespace


AddAudioFrameEmbedded Method

Aspose.Slides Documentation

ShapeCollection.AddAudioFrameEmbedded Method

Adds a new audio frame with embedded audio file to the end of a collection. It uses audio file from Presentation.Audios list.

Overload List

Adds a new audio frame with embedded audio file to the end of a collection. It uses audio file from Presentation.Audios list.

public IAudioFrame AddAudioFrameEmbedded(float,float,float,float,IAudio);

Adds a new audio frame with embedded audio file to the end of a collection. Embedded audio file can be a WAV only. It adds new audio into Presentation.Audios list.

public IAudioFrame AddAudioFrameEmbedded(float,float,float,float,Stream);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.AddAudioFrameEmbedded Method (Single, Single, Single, Single, IAudio)

Adds a new audio frame with embedded audio file to the end of a collection. It uses audio file from Presentation.Audios list.

[Visual Basic]
NotOverridable Overloads Public Function AddAudioFrameEmbedded( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal audio As IAudio _
) As IAudioFrame _
Implements IShapeCollection.AddAudioFrameEmbedded
[C#]
public IAudioFrame AddAudioFrameEmbedded(
float x,
float y,
float width,
float height,
IAudio audio
);

Parameters

x
X coordinate of a new audio frame.
y
Y coordinate of a new audio frame.
width
Width of a new audio frame.
height
Height of a new audio frame.
audio
Audio from Presentation.Audios list.

Return Value

Created AudioFrame object.

Implements

IShapeCollection.AddAudioFrameEmbedded

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.AddAudioFrameEmbedded Overload List


ShapeCollection.AddAudioFrameEmbedded Method (Single, Single, Single, Single, Stream)

Adds a new audio frame with embedded audio file to the end of a collection. Embedded audio file can be a WAV only. It adds new audio into Presentation.Audios list.

[Visual Basic]
NotOverridable Overloads Public Function AddAudioFrameEmbedded( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal audio_stream As Stream _
) As IAudioFrame _
Implements IShapeCollection.AddAudioFrameEmbedded
[C#]
public IAudioFrame AddAudioFrameEmbedded(
float x,
float y,
float width,
float height,
Stream audio_stream
);

Parameters

x
X coordinate of a new audio frame.
y
Y coordinate of a new audio frame.
width
Width of a new audio frame.
height
Height of a new audio frame.
audio_stream
Inout stream with audio data.

Return Value

Created AudioFrame object.

Implements

IShapeCollection.AddAudioFrameEmbedded

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.AddAudioFrameEmbedded Overload List


ShapeCollection.AddAudioFrameLinked Method

Adds a new audio frame with linked audio file to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddAudioFrameLinked( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal fname As String _
) As IAudioFrame _
Implements IShapeCollection.AddAudioFrameLinked
[C#]
public IAudioFrame AddAudioFrameLinked(
float x,
float y,
float width,
float height,
string fname
);

Parameters

x
X coordinate of a new audio frame.
y
Y coordinate of a new audio frame.
width
Width of a new audio frame.
height
Height of a new audio frame.
fname
Audio file name.

Return Value

Created AudioFrame object.

Implements

IShapeCollection.AddAudioFrameLinked

See Also

ShapeCollection Class | Aspose.Slides Namespace


AddAutoShape Method

Aspose.Slides Documentation

ShapeCollection.AddAutoShape Method

Creates a new AutoShape, tunes it from default template and adds it to the end of the collection.

Overload List

Creates a new AutoShape, tunes it from default template and adds it to the end of the collection.

public IAutoShape AddAutoShape(ShapeType,float,float,float,float);

Creates a new AutoShape and adds it to the end of the collection.

public IAutoShape AddAutoShape(ShapeType,float,float,float,float,bool);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.AddAutoShape Method (ShapeType, Single, Single, Single, Single)

Creates a new AutoShape, tunes it from default template and adds it to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddAutoShape( _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IAutoShape _
Implements IShapeCollection.AddAutoShape
[C#]
public IAutoShape AddAutoShape(
ShapeType shapeType,
float x,
float y,
float width,
float height
);

Parameters

shapeType
The ShapeType of shape.
x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
width
The width of shape's frame.
height
The height of shape's frame.

Return Value

Created AutoShape object.

Implements

IShapeCollection.AddAutoShape

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.AddAutoShape Overload List


ShapeCollection.AddAutoShape Method (ShapeType, Single, Single, Single, Single, Boolean)

Creates a new AutoShape and adds it to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddAutoShape( _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal createFromTemplate As Boolean _
) As IAutoShape _
Implements IShapeCollection.AddAutoShape
[C#]
public IAutoShape AddAutoShape(
ShapeType shapeType,
float x,
float y,
float width,
float height,
bool createFromTemplate
);

Parameters

shapeType
The ShapeType of shape.
x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
width
The width of shape's frame.
height
The height of shape's frame.
createFromTemplate
If true then new shape will be tuned from default template. Not empty name, simple style, text centered will be assined to the new shape. If false then all values of the properties of the new shape will have default values.

Return Value

Created AutoShape object.

Implements

IShapeCollection.AddAutoShape

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.AddAutoShape Overload List


AddChart Method

Aspose.Slides Documentation

ShapeCollection.AddChart Method

Creates a new Chart, initialize it with sample series data and settings and adds it to the end of the collection.

Overload List

Creates a new Chart, initialize it with sample series data and settings and adds it to the end of the collection.

public IChart AddChart(ChartType,float,float,float,float);

Creates a new Chart and adds it to the end of the collection.

public IChart AddChart(ChartType,float,float,float,float,bool);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.AddChart Method (ChartType, Single, Single, Single, Single)

Creates a new Chart, initialize it with sample series data and settings and adds it to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddChart( _
ByVal type As ChartType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IChart _
Implements IShapeCollection.AddChart
[C#]
public IChart AddChart(
ChartType type,
float x,
float y,
float width,
float height
);

Parameters

type
Type of chart.
x
X coordinate of a new chart.
y
Y coordinate of a new chart.
width
Chart's width.
height
Chart's height.

Return Value

Created chart.

Implements

IShapeCollection.AddChart

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.AddChart Overload List


ShapeCollection.AddChart Method (ChartType, Single, Single, Single, Single, Boolean)

Creates a new Chart and adds it to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddChart( _
ByVal type As ChartType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal initWithSample As Boolean _
) As IChart _
Implements IShapeCollection.AddChart
[C#]
public IChart AddChart(
ChartType type,
float x,
float y,
float width,
float height,
bool initWithSample
);

Parameters

type
Type of chart.
x
X coordinate of a new chart.
y
Y coordinate of a new chart.
width
Chart's width.
height
Chart's height.
initWithSample
If true then new chart will be initialized with sample series data and settings. If false then new chart will have no series and minimum settings. In this case chart creation will be more fast.

Return Value

Created chart.

Implements

IShapeCollection.AddChart

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.AddChart Overload List


AddConnector Method

Aspose.Slides Documentation

ShapeCollection.AddConnector Method

Creates a new Connector, tunes it from default template and adds it to the end of the collection.

Overload List

Creates a new Connector, tunes it from default template and adds it to the end of the collection.

public IConnector AddConnector(ShapeType,float,float,float,float);

Creates a new Connector and adds it to the end of the collection.

public IConnector AddConnector(ShapeType,float,float,float,float,bool);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.AddConnector Method (ShapeType, Single, Single, Single, Single)

Creates a new Connector, tunes it from default template and adds it to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddConnector( _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IConnector _
Implements IShapeCollection.AddConnector
[C#]
public IConnector AddConnector(
ShapeType shapeType,
float x,
float y,
float width,
float height
);

Parameters

shapeType
The ShapeType of shape.
x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
width
The width of shape's frame.
height
The height of shape's frame.

Return Value

The zero-based index of the created shape.Created Connector object.

Implements

IShapeCollection.AddConnector

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.AddConnector Overload List


ShapeCollection.AddConnector Method (ShapeType, Single, Single, Single, Single, Boolean)

Creates a new Connector and adds it to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddConnector( _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal createFromTemplate As Boolean _
) As IConnector _
Implements IShapeCollection.AddConnector
[C#]
public IConnector AddConnector(
ShapeType shapeType,
float x,
float y,
float width,
float height,
bool createFromTemplate
);

Parameters

shapeType
The ShapeType of shape.
x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
width
The width of shape's frame.
height
The height of shape's frame.
createFromTemplate
If true then new shape will be tuned from default template. Not empty name, simple style, text centered will be assined to the new shape. If false then all values of the properties of the new shape will have default values.

Return Value

The zero-based index of the created shape.Created Connector object.

Implements

IShapeCollection.AddConnector

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.AddConnector Overload List


AddOleObjectFrame Method

Aspose.Slides Documentation

ShapeCollection.AddOleObjectFrame Method

Adds a new OLE object to the end of a collection.

Overload List

Adds a new OLE object to the end of a collection.

public IOleObjectFrame AddOleObjectFrame(float,float,float,float,string,byte[]);

Adds a new OLE object to the end of a collection.

public IOleObjectFrame AddOleObjectFrame(float,float,float,float,string,string);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.AddOleObjectFrame Method (Single, Single, Single, Single, String, Byte[])

Adds a new OLE object to the end of a collection.

[Visual Basic]
NotOverridable Overloads Public Function AddOleObjectFrame( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal className As String, _
ByVal objectData As Byte() _
) As IOleObjectFrame _
Implements IShapeCollection.AddOleObjectFrame
[C#]
public IOleObjectFrame AddOleObjectFrame(
float x,
float y,
float width,
float height,
string className,
byte[] objectData
);

Parameters

x
X coordinate of a new OLE frame.
y
Y coordinate of a new OLE frame.
width
Width of a new OLE frame.
height
Height of a new OLE frame.
className
Name of an OLE class.
objectData
OLE object's data.

Return Value

Created OLE object.

Implements

IShapeCollection.AddOleObjectFrame

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.AddOleObjectFrame Overload List


ShapeCollection.AddOleObjectFrame Method (Single, Single, Single, Single, String, String)

Adds a new OLE object to the end of a collection.

[Visual Basic]
NotOverridable Overloads Public Function AddOleObjectFrame( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal className As String, _
ByVal path As String _
) As IOleObjectFrame _
Implements IShapeCollection.AddOleObjectFrame
[C#]
public IOleObjectFrame AddOleObjectFrame(
float x,
float y,
float width,
float height,
string className,
string path
);

Parameters

x
X coordinate of a new OLE frame.
y
Y coordinate of a new OLE frame.
width
Width of a new OLE frame.
height
Height of a new OLE frame.
className
Name of an OLE class.
path
Path to the linked file.

The path is stored in the presentation as is. If a relative path is specified the corresponding file will be inaccessible when opening the presentation from a different directory.

Return Value

Created OLE object.

Implements

IShapeCollection.AddOleObjectFrame

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.AddOleObjectFrame Overload List


ShapeCollection.AddPictureFrame Method

Creates a new PictureFrame and adds it to the end of the collection.

[Visual Basic]
NotOverridable Public Function AddPictureFrame( _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal image As IPPImage _
) As IPictureFrame _
Implements IShapeCollection.AddPictureFrame
[C#]
public IPictureFrame AddPictureFrame(
ShapeType shapeType,
float x,
float y,
float width,
float height,
IPPImage image
);

Parameters

shapeType

The shape contained in the set ShapeType of shapes, except all sorts of lines:

ShapeType.Line,

ShapeType.StraightConnector1,

ShapeType.BentConnector2,

ShapeType.BentConnector3,

ShapeType.BentConnector4,

ShapeType.BentConnector5,

ShapeType.CurvedConnector2,

ShapeType.CurvedConnector3,

ShapeType.CurvedConnector4,

ShapeType.CurvedConnector5.

x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
width
The width of shape's frame.
height
The height of shape's frame.
image
The image of picture frame.

Return Value

Created PictureFrame object.

Implements

IShapeCollection.AddPictureFrame

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.AddSmartArt Method

Add SmartArt object Example:

[C#]
Presentation pres = new Presentation();
Slide slide = pres.Slides[0];
SmartArt smart = slide.Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.BasicBlockList);

[Visual Basic]
Private pres As New Presentation()
Private slide As Slide = pres.Slides(0)
Private smart As SmartArt = slide.Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.BasicBlockList)

[Visual Basic]
NotOverridable Public Function AddSmartArt( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal layoutType As SmartArtLayoutType _
) As ISmartArt _
Implements IShapeCollection.AddSmartArt
[C#]
public ISmartArt AddSmartArt(
float x,
float y,
float width,
float height,
SmartArtLayoutType layoutType
);

Parameters

x
y
width
height
layoutType

Return Value

Implements

IShapeCollection.AddSmartArt

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.AddTable Method

Creates a new Table and adds it to the end of the collection.

[Visual Basic]
NotOverridable Public Function AddTable( _
ByVal x As Single, _
ByVal y As Single, _
ByVal columnWidths As Double(), _
ByVal rowHeights As Double() _
) As ITable _
Implements IShapeCollection.AddTable
[C#]
public ITable AddTable(
float x,
float y,
double[] columnWidths,
double[] rowHeights
);

Parameters

x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
columnWidths
Array of doubles which represents widths of columns in the table.
rowHeights
Array of doubles which represents heights of rows in the table.

Return Value

Created Table object.

Implements

IShapeCollection.AddTable

See Also

ShapeCollection Class | Aspose.Slides Namespace


AddVideoFrame Method

Aspose.Slides Documentation

ShapeCollection.AddVideoFrame Method

Adds a new video frame to the end of a collection.

Overload List

Adds a new video frame to the end of a collection.

public IVideoFrame AddVideoFrame(float,float,float,float,IVideo);

Adds a new video frame to the end of a collection.

public IVideoFrame AddVideoFrame(float,float,float,float,string);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.AddVideoFrame Method (Single, Single, Single, Single, IVideo)

Adds a new video frame to the end of a collection.

[Visual Basic]
NotOverridable Overloads Public Function AddVideoFrame( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal video As IVideo _
) As IVideoFrame _
Implements IShapeCollection.AddVideoFrame
[C#]
public IVideoFrame AddVideoFrame(
float x,
float y,
float width,
float height,
IVideo video
);

Parameters

x
X coordinate of a new video frame.
y
Y coordinate of a new video frame.
width
Width of a new video frame.
height
Height of a new video frame.
video
Video to add.

Return Value

Created VideoFrame object.

Implements

IShapeCollection.AddVideoFrame

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.AddVideoFrame Overload List


ShapeCollection.AddVideoFrame Method (Single, Single, Single, Single, String)

Adds a new video frame to the end of a collection.

[Visual Basic]
NotOverridable Overloads Public Function AddVideoFrame( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal fname As String _
) As IVideoFrame _
Implements IShapeCollection.AddVideoFrame
[C#]
public IVideoFrame AddVideoFrame(
float x,
float y,
float width,
float height,
string fname
);

Parameters

x
X coordinate of a new video frame.
y
Y coordinate of a new video frame.
width
Width of a new video frame.
height
Height of a new video frame.
fname
Video file name.

Return Value

Created VideoFrame object.

Implements

IShapeCollection.AddVideoFrame

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.AddVideoFrame Overload List


ShapeCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a shape in the collection.

[Visual Basic]
NotOverridable Public Function IndexOf( _
ByVal shape As IShape _
) As Integer _
Implements IShapeCollection.IndexOf
[C#]
public int IndexOf(
IShape shape
);

Parameters

shape
The shape to locate in the collection.

Return Value

The zero-based index of the first occurrence of shape within the collection, if found; otherwise, -1.

Implements

IShapeCollection.IndexOf

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.InsertAudioFrameCD Method

Insert an AudioFrame with CD.

[Visual Basic]
NotOverridable Public Function InsertAudioFrameCD( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IAudioFrame _
Implements IShapeCollection.InsertAudioFrameCD
[C#]
public IAudioFrame InsertAudioFrameCD(
int index,
float x,
float y,
float width,
float height
);

Parameters

index
The zero-based index at which video frame should be inserted.
x
X coordinate of a new audio frame.
y
Y coordinate of a new audio frame.
width
Width of a new audio frame.
height
Height of a new audio frame.

Return Value

Created AudioFrame object.

Implements

IShapeCollection.InsertAudioFrameCD

See Also

ShapeCollection Class | Aspose.Slides Namespace


InsertAudioFrameEmbedded Method

Aspose.Slides Documentation

ShapeCollection.InsertAudioFrameEmbedded Method

Insert an AudioFrame with embedded audio file. It uses audio file from Presentation.Audios list.

Overload List

Insert an AudioFrame with embedded audio file. It uses audio file from Presentation.Audios list.

public IAudioFrame InsertAudioFrameEmbedded(int,float,float,float,float,IAudio);

Insert an AudioFrame with embedded audio file. Embedded audio file sound can be a WAV only.

public IAudioFrame InsertAudioFrameEmbedded(int,float,float,float,float,Stream);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.InsertAudioFrameEmbedded Method (Int32, Single, Single, Single, Single, IAudio)

Insert an AudioFrame with embedded audio file. It uses audio file from Presentation.Audios list.

[Visual Basic]
NotOverridable Overloads Public Function InsertAudioFrameEmbedded( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal audio As IAudio _
) As IAudioFrame _
Implements IShapeCollection.InsertAudioFrameEmbedded
[C#]
public IAudioFrame InsertAudioFrameEmbedded(
int index,
float x,
float y,
float width,
float height,
IAudio audio
);

Parameters

index
The zero-based index at which value should be inserted.
x
X coordinate of a new audio frame.
y
Y coordinate of a new audio frame.
width
Width of a new audio frame.
height
Height of a new audio frame.
audio
Audio from Presentation.Audios list.

Return Value

Created AudioFrame object.

Implements

IShapeCollection.InsertAudioFrameEmbedded

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.InsertAudioFrameEmbedded Overload List


ShapeCollection.InsertAudioFrameEmbedded Method (Int32, Single, Single, Single, Single, Stream)

Insert an AudioFrame with embedded audio file. Embedded audio file sound can be a WAV only.

[Visual Basic]
NotOverridable Overloads Public Function InsertAudioFrameEmbedded( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal audio_stream As Stream _
) As IAudioFrame _
Implements IShapeCollection.InsertAudioFrameEmbedded
[C#]
public IAudioFrame InsertAudioFrameEmbedded(
int index,
float x,
float y,
float width,
float height,
Stream audio_stream
);

Parameters

index
The zero-based index at which value should be inserted.
x
X coordinate of a new audio frame.
y
Y coordinate of a new audio frame.
width
Width of a new audio frame.
height
Height of a new audio frame.
audio_stream
Audio stream.

Return Value

Created AudioFrame object.

Implements

IShapeCollection.InsertAudioFrameEmbedded

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.InsertAudioFrameEmbedded Overload List


ShapeCollection.InsertAudioFrameLinked Method

Creates a new audio frame with linked audio file and inserts it to a collection at the specified index.

[Visual Basic]
NotOverridable Public Function InsertAudioFrameLinked( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal fname As String _
) As IAudioFrame _
Implements IShapeCollection.InsertAudioFrameLinked
[C#]
public IAudioFrame InsertAudioFrameLinked(
int index,
float x,
float y,
float width,
float height,
string fname
);

Parameters

index
The zero-based index at which audio frame should be inserted.
x
X coordinate of a new audio frame.
y
Y coordinate of a new audio frame.
width
Width of a new audio frame.
height
Height of a new audio frame.
fname
Audio file name.

Return Value

Created AudioFrame object.

Implements

IShapeCollection.InsertAudioFrameLinked

See Also

ShapeCollection Class | Aspose.Slides Namespace


InsertAutoShape Method

Aspose.Slides Documentation

ShapeCollection.InsertAutoShape Method

Creates a new AutoShape, tunes it from default template and inserts it to the collection at the specified index. Note: the type of the shape will be determined by the shapeType parameter.

Overload List

Creates a new AutoShape, tunes it from default template and inserts it to the collection at the specified index. Note: the type of the shape will be determined by the shapeType parameter.

public IAutoShape InsertAutoShape(int,ShapeType,float,float,float,float);

Creates a new AutoShape and inserts it to the collection at the specified index. Note: the type of the shape will be determined by the shapeType parameter.

public IAutoShape InsertAutoShape(int,ShapeType,float,float,float,float,bool);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.InsertAutoShape Method (Int32, ShapeType, Single, Single, Single, Single)

Creates a new AutoShape, tunes it from default template and inserts it to the collection at the specified index. Note: the type of the shape will be determined by the shapeType parameter.

[Visual Basic]
NotOverridable Overloads Public Function InsertAutoShape( _
ByVal index As Integer, _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IAutoShape _
Implements IShapeCollection.InsertAutoShape
[C#]
public IAutoShape InsertAutoShape(
int index,
ShapeType shapeType,
float x,
float y,
float width,
float height
);

Parameters

index
The zero-based index at which value should be inserted.
shapeType
An ShapeType of shape.
x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
width
The width of shape's frame.
height
The height of shape's frame.

Return Value

Created AutoShape object.

Implements

IShapeCollection.InsertAutoShape

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.InsertAutoShape Overload List


ShapeCollection.InsertAutoShape Method (Int32, ShapeType, Single, Single, Single, Single, Boolean)

Creates a new AutoShape and inserts it to the collection at the specified index. Note: the type of the shape will be determined by the shapeType parameter.

[Visual Basic]
NotOverridable Overloads Public Function InsertAutoShape( _
ByVal index As Integer, _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal createFromTemplate As Boolean _
) As IAutoShape _
Implements IShapeCollection.InsertAutoShape
[C#]
public IAutoShape InsertAutoShape(
int index,
ShapeType shapeType,
float x,
float y,
float width,
float height,
bool createFromTemplate
);

Parameters

index
The zero-based index at which value should be inserted.
shapeType
An ShapeType of shape.
x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
width
The width of shape's frame.
height
The height of shape's frame.
createFromTemplate
If true then new shape will be tuned from default template. Not empty name, simple style, text centered will be assined to the new shape. If false then all values of the properties of the new shape will have default values.

Return Value

Created AutoShape object.

Implements

IShapeCollection.InsertAutoShape

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.InsertAutoShape Overload List


InsertChart Method

Aspose.Slides Documentation

ShapeCollection.InsertChart Method

Creates a new Chart, initialize it with sample series data and settings and inserts it to the specified position in the collection.

Overload List

Creates a new Chart, initialize it with sample series data and settings and inserts it to the specified position in the collection.

public IChart InsertChart(ChartType,float,float,float,float,int);

Creates a new Chart and inserts it to the specified position in the collection.

public IChart InsertChart(ChartType,float,float,float,float,int,bool);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.InsertChart Method (ChartType, Single, Single, Single, Single, Int32)

Creates a new Chart, initialize it with sample series data and settings and inserts it to the specified position in the collection.

[Visual Basic]
NotOverridable Overloads Public Function InsertChart( _
ByVal type As ChartType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal index As Integer _
) As IChart _
Implements IShapeCollection.InsertChart
[C#]
public IChart InsertChart(
ChartType type,
float x,
float y,
float width,
float height,
int index
);

Parameters

type
Type of chart.
x
X coordinate of a new chart.
y
Y coordinate of a new chart.
width
Chart's width.
height
Chart's height.
index
Chart's position in the collection.

Return Value

Created chart.

Implements

IShapeCollection.InsertChart

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.InsertChart Overload List


ShapeCollection.InsertChart Method (ChartType, Single, Single, Single, Single, Int32, Boolean)

Creates a new Chart and inserts it to the specified position in the collection.

[Visual Basic]
NotOverridable Overloads Public Function InsertChart( _
ByVal type As ChartType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal index As Integer, _
ByVal initWithSample As Boolean _
) As IChart _
Implements IShapeCollection.InsertChart
[C#]
public IChart InsertChart(
ChartType type,
float x,
float y,
float width,
float height,
int index,
bool initWithSample
);

Parameters

type
Type of chart.
x
X coordinate of a new chart.
y
Y coordinate of a new chart.
width
Chart's width.
height
Chart's height.
index
Chart's position in the collection.
initWithSample
If true then new chart will be initialized with sample series data and settings. If false then new chart will have no series and minimum settings. In this case chart creation will be more fast.

Return Value

Created chart.

Implements

IShapeCollection.InsertChart

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.InsertChart Overload List


InsertConnector Method

Aspose.Slides Documentation

ShapeCollection.InsertConnector Method

Creates a new Connector, tunes it from default template and inserts it to the collection at the specified index.

Overload List

Creates a new Connector, tunes it from default template and inserts it to the collection at the specified index.

public IConnector InsertConnector(int,ShapeType,float,float,float,float);

Creates a new Connector and inserts it to the collection at the specified index.

public IConnector InsertConnector(int,ShapeType,float,float,float,float,bool);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.InsertConnector Method (Int32, ShapeType, Single, Single, Single, Single)

Creates a new Connector, tunes it from default template and inserts it to the collection at the specified index.

[Visual Basic]
NotOverridable Overloads Public Function InsertConnector( _
ByVal index As Integer, _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As IConnector _
Implements IShapeCollection.InsertConnector
[C#]
public IConnector InsertConnector(
int index,
ShapeType shapeType,
float x,
float y,
float width,
float height
);

Parameters

index
The zero-based index at which value should be inserted.
shapeType
An ShapeType of shape.
x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
width
The width of shape's frame.
height
The height of shape's frame.

Return Value

Created Connector object.

Implements

IShapeCollection.InsertConnector

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.InsertConnector Overload List


ShapeCollection.InsertConnector Method (Int32, ShapeType, Single, Single, Single, Single, Boolean)

Creates a new Connector and inserts it to the collection at the specified index.

[Visual Basic]
NotOverridable Overloads Public Function InsertConnector( _
ByVal index As Integer, _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal createFromTemplate As Boolean _
) As IConnector _
Implements IShapeCollection.InsertConnector
[C#]
public IConnector InsertConnector(
int index,
ShapeType shapeType,
float x,
float y,
float width,
float height,
bool createFromTemplate
);

Parameters

index
The zero-based index at which value should be inserted.
shapeType
An ShapeType of shape.
x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
width
The width of shape's frame.
height
The height of shape's frame.
createFromTemplate
If true then new shape will be tuned from default template. Not empty name, simple style, text centered will be assined to the new shape. If false then all values of the properties of the new shape will have default values.

Return Value

Created Connector object.

Implements

IShapeCollection.InsertConnector

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.InsertConnector Overload List


InsertOleObjectFrame Method

Aspose.Slides Documentation

ShapeCollection.InsertOleObjectFrame Method

Creates a new OLE object and inserts it to a collection at the specified index.

Overload List

Creates a new OLE object and inserts it to a collection at the specified index.

public IOleObjectFrame InsertOleObjectFrame(int,float,float,float,float,string,byte[]);

Creates a new OLE object and inserts it to a collection at the specified index.

public IOleObjectFrame InsertOleObjectFrame(int,float,float,float,float,string,string);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.InsertOleObjectFrame Method (Int32, Single, Single, Single, Single, String, Byte[])

Creates a new OLE object and inserts it to a collection at the specified index.

[Visual Basic]
NotOverridable Overloads Public Function InsertOleObjectFrame( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal className As String, _
ByVal objectData As Byte() _
) As IOleObjectFrame _
Implements IShapeCollection.InsertOleObjectFrame
[C#]
public IOleObjectFrame InsertOleObjectFrame(
int index,
float x,
float y,
float width,
float height,
string className,
byte[] objectData
);

Parameters

index
The zero-based index at which OLE object should be inserted.
x
X coordinate of a new OLE frame.
y
Y coordinate of a new OLE frame.
width
Width of a new OLE frame.
height
Height of a new OLE frame.
className
Name of an OLE class.
objectData
OLE object's data.

Return Value

Created OLE object.

Implements

IShapeCollection.InsertOleObjectFrame

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.InsertOleObjectFrame Overload List


ShapeCollection.InsertOleObjectFrame Method (Int32, Single, Single, Single, Single, String, String)

Creates a new OLE object and inserts it to a collection at the specified index.

[Visual Basic]
NotOverridable Overloads Public Function InsertOleObjectFrame( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal className As String, _
ByVal path As String _
) As IOleObjectFrame _
Implements IShapeCollection.InsertOleObjectFrame
[C#]
public IOleObjectFrame InsertOleObjectFrame(
int index,
float x,
float y,
float width,
float height,
string className,
string path
);

Parameters

index
The zero-based index at which OLE object should be inserted.
x
X coordinate of a new OLE frame.
y
Y coordinate of a new OLE frame.
width
Width of a new OLE frame.
height
Height of a new OLE frame.
className
Name of an OLE class.
path
Path to the linked file.

Return Value

Created OLE object.

Implements

IShapeCollection.InsertOleObjectFrame

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.InsertOleObjectFrame Overload List


ShapeCollection.InsertPictureFrame Method

Creates a new PictureFrame and inserts it to the collection at the specified index.

[Visual Basic]
NotOverridable Public Function InsertPictureFrame( _
ByVal index As Integer, _
ByVal shapeType As ShapeType, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal image As IPPImage _
) As IPictureFrame _
Implements IShapeCollection.InsertPictureFrame
[C#]
public IPictureFrame InsertPictureFrame(
int index,
ShapeType shapeType,
float x,
float y,
float width,
float height,
IPPImage image
);

Parameters

index
The zero-based index at which value should be inserted.
shapeType

The shape contained in the set ShapeType of shapes, except all sorts of lines:

ShapeType.Line,

ShapeType.StraightConnector1,

ShapeType.BentConnector2,

ShapeType.BentConnector3,

ShapeType.BentConnector4,

ShapeType.BentConnector5,

ShapeType.CurvedConnector2,

ShapeType.CurvedConnector3,

ShapeType.CurvedConnector4,

ShapeType.CurvedConnector5.

x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
width
The width of shape's frame.
height
The height of shape's frame.
image
The image of picture frame.

Return Value

Created PictureFrame object.

Implements

IShapeCollection.InsertPictureFrame

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.InsertTable Method

Creates a new Table and inserts it to the collection at the specified index.

[Visual Basic]
NotOverridable Public Function InsertTable( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal columnWidths As Double(), _
ByVal rowHeights As Double() _
) As ITable _
Implements IShapeCollection.InsertTable
[C#]
public ITable InsertTable(
int index,
float x,
float y,
double[] columnWidths,
double[] rowHeights
);

Parameters

index
The zero-based index at which value should be inserted.
x
The X-coordinate for a left side of shape's frame.
y
The Y-coordinate for a top side of shape's frame.
columnWidths
Array of doubles which represents widths of columns in the table.
rowHeights
Array of doubles which represents heights of rows in the table.

Return Value

Created Table object.

Implements

IShapeCollection.InsertTable

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.InsertVideoFrame Method

Creates a new video frame and inserts it to a collection at the specified index.

[Visual Basic]
NotOverridable Public Function InsertVideoFrame( _
ByVal index As Integer, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal fname As String _
) As IVideoFrame _
Implements IShapeCollection.InsertVideoFrame
[C#]
public IVideoFrame InsertVideoFrame(
int index,
float x,
float y,
float width,
float height,
string fname
);

Parameters

index
The zero-based index at which video frame should be inserted.
x
X coordinate of a new video frame.
y
Y coordinate of a new video frame.
width
Width of a new video frame.
height
Height of a new video frame.
fname
Video file name.

Return Value

Created VideoFrame object.

Implements

IShapeCollection.InsertVideoFrame

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.Remove Method

Removes the first occurrence of a specific shape from the collection.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal shape As IShape _
) _
Implements IShapeCollection.Remove
[C#]
public void Remove(
IShape shape
);

Parameters

shape
The shape to remove from the collection.

Implements

IShapeCollection.Remove

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.RemoveAt Method

Removes the element at the specified index of the collection.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IShapeCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Implements

IShapeCollection.RemoveAt

See Also

ShapeCollection Class | Aspose.Slides Namespace


Reorder Method

Aspose.Slides Documentation

ShapeCollection.Reorder Method

Moves a shape from the collection to the specified position.

Overload List

Moves a shape from the collection to the specified position.

public void Reorder(int,IShape);

Moves shapes from the collection to the specified position. Shapes will be placed starting from index in order they appear in list.

public void Reorder(int,params IShape[]);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.Reorder Method (Int32, IShape)

Moves a shape from the collection to the specified position.

[Visual Basic]
NotOverridable Overloads Public Sub Reorder( _
ByVal index As Integer, _
ByVal shape As IShape _
) _
Implements IShapeCollection.Reorder
[C#]
public void Reorder(
int index,
IShape shape
);

Parameters

index
Target index.
shape
Shape to move.

Implements

IShapeCollection.Reorder

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.Reorder Overload List


ShapeCollection.Reorder Method (Int32, IShape[])

Moves shapes from the collection to the specified position. Shapes will be placed starting from index in order they appear in list.

[Visual Basic]
NotOverridable Overloads Public Sub Reorder( _
ByVal index As Integer, _
ParamArray shapes As IShape() _
) _
Implements IShapeCollection.Reorder
[C#]
public void Reorder(
int index,
params IShape[] shapes
);

Parameters

index
Target index.
shapes
Shapes to move.

Implements

IShapeCollection.Reorder

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.Reorder Overload List


ToArray Method

Aspose.Slides Documentation

ShapeCollection.ToArray Method

Creates and returns an array with all shapse in it.

Overload List

Creates and returns an array with all shapse in it.

public IShape[] ToArray();

Creates and returns an array with all shapes from the specified range in it. An index of a first shape to return.A number of shapes to return.

public IShape[] ToArray(int,int);

See Also

ShapeCollection Class | Aspose.Slides Namespace


ShapeCollection.ToArray Method ()

Creates and returns an array with all shapse in it.

[Visual Basic]
NotOverridable Overloads Public Function ToArray() As IShape() _
Implements IShapeCollection.ToArray
[C#]
public IShape[] ToArray();

Return Value

Array of Shape

Implements

IShapeCollection.ToArray

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.ToArray Overload List


ShapeCollection.ToArray Method (Int32, Int32)

Creates and returns an array with all shapes from the specified range in it. An index of a first shape to return.A number of shapes to return.

[Visual Basic]
NotOverridable Overloads Public Function ToArray( _
ByVal startIndex As Integer, _
ByVal count As Integer _
) As IShape() _
Implements IShapeCollection.ToArray
[C#]
public IShape[] ToArray(
int startIndex,
int count
);

Return Value

Array of Shape

Implements

IShapeCollection.ToArray

See Also

ShapeCollection Class | Aspose.Slides Namespace | ShapeCollection.ToArray Overload List


ShapeElement Class

Represents a part of shape with same outline and fill properties.

For a list of all members of this type, see ShapeElement Members.

System.Object
Aspose.Slides.ShapeElement

[Visual Basic]
Public Class ShapeElement
Implements IShapeElement
[C#]
public class ShapeElement : IShapeElement

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ShapeElement Members | Aspose.Slides Namespace


ShapeElement Members

ShapeElement overview

Public Instance Properties

FillSource | Returns information about how to fill an element. Readonly ShapeElementFillSource.
GraphicsPath | Returns an element's path. Read-only GraphicsPath.
ParentShape | Returns a Shape_PPT for which element was created. Read-only Shape.
StrokeSource | Returns information about how to stroke an element. Read-only ShapeElementStrokeSource.

See Also

ShapeElement Class | Aspose.Slides Namespace


ShapeElement Properties

The properties of the ShapeElement class are listed below. For a complete list of ShapeElement class members, see the ShapeElement Members topic.

Public Instance Properties

FillSource | Returns information about how to fill an element. Readonly ShapeElementFillSource.
GraphicsPath | Returns an element's path. Read-only GraphicsPath.
ParentShape | Returns a Shape_PPT for which element was created. Read-only Shape.
StrokeSource | Returns information about how to stroke an element. Read-only ShapeElementStrokeSource.

See Also

ShapeElement Class | Aspose.Slides Namespace


FillSource Property

Aspose.Slides Documentation

ShapeElement.FillSource Property

Returns information about how to fill an element. Readonly ShapeElementFillSource.

[Visual Basic]
Public ReadOnly Property FillSource As ShapeElementFillSource
[C#]
public ShapeElementFillSource FillSource {get;}

See Also

ShapeElement Class | Aspose.Slides Namespace


GraphicsPath Property

Aspose.Slides Documentation

ShapeElement.GraphicsPath Property

Returns an element's path. Read-only GraphicsPath.

[Visual Basic]
Public ReadOnly Property GraphicsPath As GraphicsPath
[C#]
public GraphicsPath GraphicsPath {get;}

See Also

ShapeElement Class | Aspose.Slides Namespace


ParentShape Property

Aspose.Slides Documentation

ShapeElement.ParentShape Property

Returns a Shape_PPT for which element was created. Read-only Shape.

[Visual Basic]
Public ReadOnly Property ParentShape As Shape
[C#]
public Shape ParentShape {get;}

See Also

ShapeElement Class | Aspose.Slides Namespace


StrokeSource Property

Aspose.Slides Documentation

ShapeElement.StrokeSource Property

Returns information about how to stroke an element. Read-only ShapeElementStrokeSource.

[Visual Basic]
Public ReadOnly Property StrokeSource As ShapeElementStrokeSource
[C#]
public ShapeElementStrokeSource StrokeSource {get;}

See Also

ShapeElement Class | Aspose.Slides Namespace


ShapeElementFillSource Enumeration

[Visual Basic]
Public Enum ShapeElementFillSource
Inherits
[C#]
public enum ShapeElementFillSource

Members

Member Name | Description | Value
NoFill |  | 0
Shape |  | 1
Lighten |  | 2
LightenLess |  | 3
Darken |  | 4
DarkenLess |  | 5
OwnFill |  | 6

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


ShapeElementStrokeSource Enumeration

[Visual Basic]
Public Enum ShapeElementStrokeSource
Inherits
[C#]
public enum ShapeElementStrokeSource

Members

Member Name | Description | Value
NoStroke |  | 0
Shape |  | 1
OwnStroke |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


ShapeFrame Class

Represents shape frame's properties.

For a list of all members of this type, see ShapeFrame Members.

System.Object
Aspose.Slides.ShapeFrame

[Visual Basic]
Public Class ShapeFrame
Implements IShapeFrame, ICloneable
[C#]
public class ShapeFrame : IShapeFrame, ICloneable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ShapeFrame Members | Aspose.Slides Namespace


ShapeFrame Members

ShapeFrame overview

Public Instance Constructors

ShapeFrame Constructor Creates new shape frame's properties.

Public Instance Properties

CenterX | Returns the X coordinate of a frame's center. Read-only Single.
CenterY | Returns the Y coordinate of a frame's center. Read-only Single.
FlipH | Determines whether a frame is flipped horizontally. Read-only Boolean.
FlipV | Determines whether a frame is flipped vertically. Read-only Boolean.
Height | Returns the height of a frame. Read-only Single.
Rectangle | Returns the coordinates of a frame. Read-only RectangleF.
Rotation | Returns the number of degrees a frame is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read-only Single.
Width | Returns the width of a frame. Read-only Single.
X | Returns the X coordinate of the upper-left corner of a frame. Read-only Single.
Y | Returns the Y coordinate of the upper-left corner of a frame. Read-only Single.

Public Instance Methods

Clone |
CloneShapeFrame |
Equals | Overloaded. Returns a value indicating whether this instance is equal to a specified object.
GetHashCode | Returns a hash code for this object.

See Also

ShapeFrame Class | Aspose.Slides Namespace


ShapeFrame Constructor

Creates new shape frame's properties.

[Visual Basic]
Overloads Public Sub New( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single, _
ByVal flipH As Boolean, _
ByVal flipV As Boolean, _
ByVal rotationAngle As Single _
)
[C#]
public ShapeFrame(
float x,
float y,
float width,
float height,
bool flipH,
bool flipV,
float rotationAngle
);

Parameters

x
X coordinate of a frame.
y
Y coordinate of a frame.
width
Width of a frame.
height
Height of a frame.
flipH
True if a frame flipped horizontally.
flipV
True if a frame flipped vertivally.
rotationAngle
Number of degrees a frame is rotated.

See Also

ShapeFrame Class | Aspose.Slides Namespace


ShapeFrame Properties

The properties of the ShapeFrame class are listed below. For a complete list of ShapeFrame class members, see the ShapeFrame Members topic.

Public Instance Properties

CenterX | Returns the X coordinate of a frame's center. Read-only Single.
CenterY | Returns the Y coordinate of a frame's center. Read-only Single.
FlipH | Determines whether a frame is flipped horizontally. Read-only Boolean.
FlipV | Determines whether a frame is flipped vertically. Read-only Boolean.
Height | Returns the height of a frame. Read-only Single.
Rectangle | Returns the coordinates of a frame. Read-only RectangleF.
Rotation | Returns the number of degrees a frame is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read-only Single.
Width | Returns the width of a frame. Read-only Single.
X | Returns the X coordinate of the upper-left corner of a frame. Read-only Single.
Y | Returns the Y coordinate of the upper-left corner of a frame. Read-only Single.

See Also

ShapeFrame Class | Aspose.Slides Namespace


CenterX Property

Aspose.Slides Documentation

ShapeFrame.CenterX Property

Returns the X coordinate of a frame's center. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property CenterX As Single _
Implements IShapeFrame.CenterX
[C#]
public float CenterX {get;}

Implements

IShapeFrame.CenterX

See Also

ShapeFrame Class | Aspose.Slides Namespace


CenterY Property

Aspose.Slides Documentation

ShapeFrame.CenterY Property

Returns the Y coordinate of a frame's center. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property CenterY As Single _
Implements IShapeFrame.CenterY
[C#]
public float CenterY {get;}

Implements

IShapeFrame.CenterY

See Also

ShapeFrame Class | Aspose.Slides Namespace


FlipH Property

Aspose.Slides Documentation

ShapeFrame.FlipH Property

Determines whether a frame is flipped horizontally. Read-only Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property FlipH As Boolean _
Implements IShapeFrame.FlipH
[C#]
public bool FlipH {get;}

Implements

IShapeFrame.FlipH

See Also

ShapeFrame Class | Aspose.Slides Namespace


FlipV Property

Aspose.Slides Documentation

ShapeFrame.FlipV Property

Determines whether a frame is flipped vertically. Read-only Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property FlipV As Boolean _
Implements IShapeFrame.FlipV
[C#]
public bool FlipV {get;}

Implements

IShapeFrame.FlipV

See Also

ShapeFrame Class | Aspose.Slides Namespace


Height Property

Aspose.Slides Documentation

ShapeFrame.Height Property

Returns the height of a frame. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Height As Single _
Implements IShapeFrame.Height
[C#]
public float Height {get;}

Implements

IShapeFrame.Height

See Also

ShapeFrame Class | Aspose.Slides Namespace


Rectangle Property

Aspose.Slides Documentation

ShapeFrame.Rectangle Property

Returns the coordinates of a frame. Read-only RectangleF.

[Visual Basic]
NotOverridable Public ReadOnly Property Rectangle As RectangleF _
Implements IShapeFrame.Rectangle
[C#]
public RectangleF Rectangle {get;}

Implements

IShapeFrame.Rectangle

See Also

ShapeFrame Class | Aspose.Slides Namespace


Rotation Property

Aspose.Slides Documentation

ShapeFrame.Rotation Property

Returns the number of degrees a frame is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Rotation As Single _
Implements IShapeFrame.Rotation
[C#]
public float Rotation {get;}

Implements

IShapeFrame.Rotation

See Also

ShapeFrame Class | Aspose.Slides Namespace


Width Property

Aspose.Slides Documentation

ShapeFrame.Width Property

Returns the width of a frame. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Width As Single _
Implements IShapeFrame.Width
[C#]
public float Width {get;}

Implements

IShapeFrame.Width

See Also

ShapeFrame Class | Aspose.Slides Namespace


X Property

Aspose.Slides Documentation

ShapeFrame.X Property

Returns the X coordinate of the upper-left corner of a frame. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property X As Single _
Implements IShapeFrame.X
[C#]
public float X {get;}

Implements

IShapeFrame.X

See Also

ShapeFrame Class | Aspose.Slides Namespace


Y Property

Aspose.Slides Documentation

ShapeFrame.Y Property

Returns the Y coordinate of the upper-left corner of a frame. Read-only Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Y As Single _
Implements IShapeFrame.Y
[C#]
public float Y {get;}

Implements

IShapeFrame.Y

See Also

ShapeFrame Class | Aspose.Slides Namespace


ShapeFrame Methods

The methods of the ShapeFrame class are listed below. For a complete list of ShapeFrame class members, see the ShapeFrame Members topic.

Public Instance Methods

Clone |
CloneShapeFrame |
Equals | Overloaded. Returns a value indicating whether this instance is equal to a specified object.
GetHashCode | Returns a hash code for this object.

See Also

ShapeFrame Class | Aspose.Slides Namespace


ShapeFrame.Clone Method

[Visual Basic]
NotOverridable Public Function Clone() As Object _
Implements ICloneable.Clone
[C#]
public object Clone();

Implements

ICloneable.Clone

See Also

ShapeFrame Class | Aspose.Slides Namespace


ShapeFrame.CloneShapeFrame Method

[Visual Basic]
NotOverridable Public Function CloneShapeFrame() As IShapeFrame _
Implements IShapeFrame.CloneShapeFrame
[C#]
public IShapeFrame CloneShapeFrame();

Implements

IShapeFrame.CloneShapeFrame

See Also

ShapeFrame Class | Aspose.Slides Namespace


Equals Method

Aspose.Slides Documentation

ShapeFrame.Equals Method

Returns a value indicating whether this instance is equal to a specified object.

Overload List

Returns a value indicating whether this instance is equal to a specified object.

public bool Equals(ShapeFrame);

Returns a value indicating whether this instance is equal to a specified object.

public override bool Equals(object);

See Also

ShapeFrame Class | Aspose.Slides Namespace


ShapeFrame.Equals Method (ShapeFrame)

Returns a value indicating whether this instance is equal to a specified object.

[Visual Basic]
Overloads Public Function Equals( _
ByVal value As ShapeFrame _
) As Boolean
[C#]
public bool Equals(
ShapeFrame value
);

Parameters

value
The ShapeFRameEx to compare with this instance.

Return Value

True if value is a ShapeFrame that has the same value as this instance; otherwise, false.

See Also

ShapeFrame Class | Aspose.Slides Namespace | ShapeFrame.Equals Overload List


ShapeFrame.Equals Method (Object)

Returns a value indicating whether this instance is equal to a specified object.

[Visual Basic]
Overrides Overloads Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The object to compare with this instance.

Return Value

True if obj is a ShapeFrame that has the same value as this instance; otherwise, false.

See Also

ShapeFrame Class | Aspose.Slides Namespace | ShapeFrame.Equals Overload List


ShapeFrame.GetHashCode Method

Returns a hash code for this object.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

See Also

ShapeFrame Class | Aspose.Slides Namespace


ShapeStyle Class

Represent shape's style reference.

For a list of all members of this type, see ShapeStyle Members.

System.Object
Aspose.Slides.ShapeStyle

[Visual Basic]
Public Class ShapeStyle
Implements IShapeStyle, ISlideComponent, IPresentationComponent
[C#]
public class ShapeStyle : IShapeStyle, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ShapeStyle Members | Aspose.Slides Namespace


ShapeStyle Members

ShapeStyle overview

Public Instance Properties

EffectColor | Returns a shape's effect color. Readonly ColorFormat.
EffectStyleIndex | Returns or sets shape's effect column index in a style matrix.
FillColor | Returns a shape's fill color. Readonly ColorFormat.
FillStyleIndex | Returns or sets shape's fill column index in style matrices. 0 means no fill, positive value - index in theme's fill styles, negative value - index in theme's background styles.
FontCollectionIndex | Returns or sets shape's font index in a font collection. Read/write FontCollectionIndex.
FontColor | Returns a shape's font color. Readonly ColorFormat.
LineColor | Returns a shape's outline color. Readonly ColorFormat.
LineStyleIndex | Returns or sets line's column index in a style matrix.
Presentation | Returns the parent presentation of a shape style. Read-only Presentation.
Slide | Returns the parent slide of a shape style. Read-only BaseSlide.

See Also

ShapeStyle Class | Aspose.Slides Namespace


ShapeStyle Properties

The properties of the ShapeStyle class are listed below. For a complete list of ShapeStyle class members, see the ShapeStyle Members topic.

Public Instance Properties

EffectColor | Returns a shape's effect color. Readonly ColorFormat.
EffectStyleIndex | Returns or sets shape's effect column index in a style matrix.
FillColor | Returns a shape's fill color. Readonly ColorFormat.
FillStyleIndex | Returns or sets shape's fill column index in style matrices. 0 means no fill, positive value - index in theme's fill styles, negative value - index in theme's background styles.
FontCollectionIndex | Returns or sets shape's font index in a font collection. Read/write FontCollectionIndex.
FontColor | Returns a shape's font color. Readonly ColorFormat.
LineColor | Returns a shape's outline color. Readonly ColorFormat.
LineStyleIndex | Returns or sets line's column index in a style matrix.
Presentation | Returns the parent presentation of a shape style. Read-only Presentation.
Slide | Returns the parent slide of a shape style. Read-only BaseSlide.

See Also

ShapeStyle Class | Aspose.Slides Namespace


EffectColor Property

Aspose.Slides Documentation

ShapeStyle.EffectColor Property

Returns a shape's effect color. Readonly ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property EffectColor As IColorFormat _
Implements IShapeStyle.EffectColor
[C#]
public IColorFormat EffectColor {get;}

Implements

IShapeStyle.EffectColor

See Also

ShapeStyle Class | Aspose.Slides Namespace


EffectStyleIndex Property

Aspose.Slides Documentation

ShapeStyle.EffectStyleIndex Property

Returns or sets shape's effect column index in a style matrix.

[Visual Basic]
NotOverridable Public Property EffectStyleIndex As UInt32 _
Implements IShapeStyle.EffectStyleIndex
[C#]
public uint EffectStyleIndex {get; set;}

Implements

IShapeStyle.EffectStyleIndex

See Also

ShapeStyle Class | Aspose.Slides Namespace


FillColor Property

Aspose.Slides Documentation

ShapeStyle.FillColor Property

Returns a shape's fill color. Readonly ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property FillColor As IColorFormat _
Implements IShapeStyle.FillColor
[C#]
public IColorFormat FillColor {get;}

Implements

IShapeStyle.FillColor

See Also

ShapeStyle Class | Aspose.Slides Namespace


FillStyleIndex Property

Aspose.Slides Documentation

ShapeStyle.FillStyleIndex Property

Returns or sets shape's fill column index in style matrices. 0 means no fill, positive value - index in theme's fill styles, negative value - index in theme's background styles.

[Visual Basic]
NotOverridable Public Property FillStyleIndex As Short _
Implements IShapeStyle.FillStyleIndex
[C#]
public short FillStyleIndex {get; set;}

Implements

IShapeStyle.FillStyleIndex

See Also

ShapeStyle Class | Aspose.Slides Namespace


FontCollectionIndex Property

Aspose.Slides Documentation

ShapeStyle.FontCollectionIndex Property

Returns or sets shape's font index in a font collection. Read/write FontCollectionIndex.

[Visual Basic]
NotOverridable Public Property FontCollectionIndex As FontCollectionIndex _
Implements IShapeStyle.FontCollectionIndex
[C#]
public FontCollectionIndex FontCollectionIndex {get; set;}

Implements

IShapeStyle.FontCollectionIndex

See Also

ShapeStyle Class | Aspose.Slides Namespace


FontColor Property

Aspose.Slides Documentation

ShapeStyle.FontColor Property

Returns a shape's font color. Readonly ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property FontColor As IColorFormat _
Implements IShapeStyle.FontColor
[C#]
public IColorFormat FontColor {get;}

Implements

IShapeStyle.FontColor

See Also

ShapeStyle Class | Aspose.Slides Namespace


LineColor Property

Aspose.Slides Documentation

ShapeStyle.LineColor Property

Returns a shape's outline color. Readonly ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property LineColor As IColorFormat _
Implements IShapeStyle.LineColor
[C#]
public IColorFormat LineColor {get;}

Implements

IShapeStyle.LineColor

See Also

ShapeStyle Class | Aspose.Slides Namespace


LineStyleIndex Property

Aspose.Slides Documentation

ShapeStyle.LineStyleIndex Property

Returns or sets line's column index in a style matrix.

[Visual Basic]
NotOverridable Public Property LineStyleIndex As UInt16 _
Implements IShapeStyle.LineStyleIndex
[C#]
public ushort LineStyleIndex {get; set;}

Implements

IShapeStyle.LineStyleIndex

See Also

ShapeStyle Class | Aspose.Slides Namespace


Presentation Property

Aspose.Slides Documentation

ShapeStyle.Presentation Property

Returns the parent presentation of a shape style. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

ShapeStyle Class | Aspose.Slides Namespace


Slide Property

Aspose.Slides Documentation

ShapeStyle.Slide Property

Returns the parent slide of a shape style. Read-only BaseSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As IBaseSlide _
Implements ISlideComponent.Slide
[C#]
public IBaseSlide Slide {get;}

Implements

ISlideComponent.Slide

See Also

ShapeStyle Class | Aspose.Slides Namespace


ShapeThumbnailBounds Enumeration

[Visual Basic]
Public Enum ShapeThumbnailBounds
[C#]
public enum ShapeThumbnailBounds

Members

Member Name | Description | Value
Slide |  | 0
Shape |  | 1

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


ShapeType Enumeration

[Visual Basic]
Public Enum ShapeType
[C#]
public enum ShapeType

Members

Member Name | Description | Value
NotDefined |  | -1
Custom |  | 0
Line |  | 1
LineInverse |  | 2
Triangle |  | 3
RightTriangle |  | 4
Rectangle |  | 5
Diamond |  | 6
Parallelogram |  | 7
Trapezoid |  | 8
NonIsoscelesTrapezoid |  | 9
Pentagon |  | 10
Hexagon |  | 11
Heptagon |  | 12
Octagon |  | 13
Decagon |  | 14
Dodecagon |  | 15
FourPointedStar |  | 16
FivePointedStar |  | 17
SixPointedStar |  | 18
SevenPointedStar |  | 19
EightPointedStar |  | 20
TenPointedStar |  | 21
TwelvePointedStar |  | 22
SixteenPointedStar |  | 23
TwentyFourPointedStar |  | 24
ThirtyTwoPointedStar |  | 25
RoundCornerRectangle |  | 26
OneRoundCornerRectangle |  | 27
TwoSamesideRoundCornerRectangle |  | 28
TwoDiagonalRoundCornerRectangle |  | 29
OneSnipOneRoundCornerRectangle |  | 30
OneSnipCornerRectangle |  | 31
TwoSamesideSnipCornerRectangle |  | 32
TwoDiagonalSnipCornerRectangle |  | 33
Plaque |  | 34
Ellipse |  | 35
Teardrop |  | 36
HomePlate |  | 37
Chevron |  | 38
PieWedge |  | 39
Pie |  | 40
BlockArc |  | 41
Donut |  | 42
NoSmoking |  | 43
RightArrow |  | 44
LeftArrow |  | 45
UpArrow |  | 46
DownArrow |  | 47
StripedRightArrow |  | 48
NotchedRightArrow |  | 49
BentUpArrow |  | 50
LeftRightArrow |  | 51
UpDownArrow |  | 52
LeftUpArrow |  | 53
LeftRightUpArrow |  | 54
QuadArrow |  | 55
CalloutLeftArrow |  | 56
CalloutRightArrow |  | 57
CalloutUpArrow |  | 58
CalloutDownArrow |  | 59
CalloutLeftRightArrow |  | 60
CalloutUpDownArrow |  | 61
CalloutQuadArrow |  | 62
BentArrow |  | 63
UTurnArrow |  | 64
CircularArrow |  | 65
LeftCircularArrow |  | 66
LeftRightCircularArrow |  | 67
CurvedRightArrow |  | 68
CurvedLeftArrow |  | 69
CurvedUpArrow |  | 70
CurvedDownArrow |  | 71
SwooshArrow |  | 72
Cube |  | 73
Can |  | 74
LightningBolt |  | 75
Heart |  | 76
Sun |  | 77
Moon |  | 78
SmileyFace |  | 79
IrregularSeal1 |  | 80
IrregularSeal2 |  | 81
FoldedCorner |  | 82
Bevel |  | 83
Frame |  | 84
HalfFrame |  | 85
Corner |  | 86
DiagonalStripe |  | 87
Chord |  | 88
CurvedArc |  | 89
LeftBracket |  | 90
RightBracket |  | 91
LeftBrace |  | 92
RightBrace |  | 93
BracketPair |  | 94
BracePair |  | 95
StraightConnector1 |  | 96
BentConnector2 |  | 97
BentConnector3 |  | 98
BentConnector4 |  | 99
BentConnector5 |  | 100
CurvedConnector2 |  | 101
CurvedConnector3 |  | 102
CurvedConnector4 |  | 103
CurvedConnector5 |  | 104
Callout1 |  | 105
Callout2 |  | 106
Callout3 |  | 107
Callout1WithAccent |  | 108
Callout2WithAccent |  | 109
Callout3WithAccent |  | 110
Callout1WithBorder |  | 111
Callout2WithBorder |  | 112
Callout3WithBorder |  | 113
Callout1WithBorderAndAccent |  | 114
Callout2WithBorderAndAccent |  | 115
Callout3WithBorderAndAccent |  | 116
CalloutWedgeRectangle |  | 117
CalloutWedgeRoundRectangle |  | 118
CalloutWedgeEllipse |  | 119
CalloutCloud |  | 120
Cloud |  | 121
Ribbon |  | 122
Ribbon2 |  | 123
EllipseRibbon |  | 124
EllipseRibbon2 |  | 125
LeftRightRibbon |  | 126
VerticalScroll |  | 127
HorizontalScroll |  | 128
Wave |  | 129
DoubleWave |  | 130
Plus |  | 131
ProcessFlow |  | 132
DecisionFlow |  | 133
InputOutputFlow |  | 134
PredefinedProcessFlow |  | 135
InternalStorageFlow |  | 136
DocumentFlow |  | 137
MultiDocumentFlow |  | 138
TerminatorFlow |  | 139
PreparationFlow |  | 140
ManualInputFlow |  | 141
ManualOperationFlow |  | 142
ConnectorFlow |  | 143
PunchedCardFlow |  | 144
PunchedTapeFlow |  | 145
SummingJunctionFlow |  | 146
OrFlow |  | 147
CollateFlow |  | 148
SortFlow |  | 149
ExtractFlow |  | 150
MergeFlow |  | 151
OfflineStorageFlow |  | 152
OnlineStorageFlow |  | 153
MagneticTapeFlow |  | 154
MagneticDiskFlow |  | 155
MagneticDrumFlow |  | 156
DisplayFlow |  | 157
DelayFlow |  | 158
AlternateProcessFlow |  | 159
OffPageConnectorFlow |  | 160
BlankButton |  | 161
HomeButton |  | 162
HelpButton |  | 163
InformationButton |  | 164
ForwardOrNextButton |  | 165
BackOrPreviousButton |  | 166
EndButton |  | 167
BeginningButton |  | 168
ReturnButton |  | 169
DocumentButton |  | 170
SoundButton |  | 171
MovieButton |  | 172
Gear6 |  | 173
Gear9 |  | 174
Funnel |  | 175
PlusMath |  | 176
MinusMath |  | 177
MultiplyMath |  | 178
DivideMath |  | 179
EqualMath |  | 180
NotEqualMath |  | 181
CornerTabs |  | 182
SquareTabs |  | 183
PlaqueTabs |  | 184
ChartX |  | 185
ChartStar |  | 186
ChartPlus |  | 187

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


Slide Class

Represents a slide in a presentation.

For a list of all members of this type, see Slide Members.

System.Object
Aspose.Slides.BaseSlide
Aspose.Slides.Slide

[Visual Basic]
NotInheritable Public Class Slide
Inherits BaseSlide
Implements ISlide, IOverrideThemeable
[C#]
public sealed class Slide : BaseSlide, ISlide, IOverrideThemeable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Slide Members | Aspose.Slides Namespace


Slide Members

Slide overview

Public Instance Properties

Background (inherited from BaseSlide) | Returns slide's background. Read only Background.
Controls (inherited from BaseSlide) | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData (inherited from BaseSlide) | Returns the slide's custom data. Read-only ICustomData.
Hidden | Determines whether the specified slide is hidden during a slide show. Read/write Boolean.
HyperlinkQueries (inherited from BaseSlide) | Provides easy access to contained hyperlinks.
LayoutSlide | Returns or sets the layout slide for the current slide. Read/write LayoutSlide.
Name (inherited from BaseSlide) | Returns or sets the name of a slide. Read/write String.
NotesSlide | Returns the notes slide for the current slide. Read-only NotesSlide.
OverrideTheme | Obsolete. Returns the overriding theme object.
ParentPresentation (inherited from BaseSlide) | Obsolete. Returns the parent presentation. Read-only Presentation.
Presentation (inherited from BaseSlide) |
Shapes (inherited from BaseSlide) | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId (inherited from BaseSlide) | Returns the ID of a slide.
SlideNumber | Returns a number of slide. Index of slide in Slides collection is always equal to SlideNumber - 1.
SlideShowTransition (inherited from BaseSlide) | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags (inherited from BaseSlide) | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
ThemeManager |
Timeline (inherited from BaseSlide) | Returns animation timeline object. Read-only AnimationTimeLine.

Public Instance Methods

AddNotesSlide | Returns the notes slide for the current slide, creating one if there isn't.
ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseSlide) | Returns an effective theme for this slide.
FindShapeByAltText (inherited from BaseSlide) | Finds first occurrence of a shape with the specified alternative text.
GetSlideComments | Returns all slide comments added by specific author.
GetThumbnail | Overloaded. Returns a Thumbnail Bitmap object with custom scaling.
Remove | Removes slide from presentation.
WriteAsSvg | Overloaded. Saves content of slide as SVG file.

See Also

Slide Class | Aspose.Slides Namespace


Slide Properties

The properties of the Slide class are listed below. For a complete list of Slide class members, see the Slide Members topic.

Public Instance Properties

Background (inherited from BaseSlide) | Returns slide's background. Read only Background.
Controls (inherited from BaseSlide) | Returns the collection of ActiveX controls on a slide. Read-only IControlCollection
CustomData (inherited from BaseSlide) | Returns the slide's custom data. Read-only ICustomData.
Hidden | Determines whether the specified slide is hidden during a slide show. Read/write Boolean.
HyperlinkQueries (inherited from BaseSlide) | Provides easy access to contained hyperlinks.
LayoutSlide | Returns or sets the layout slide for the current slide. Read/write LayoutSlide.
Name (inherited from BaseSlide) | Returns or sets the name of a slide. Read/write String.
NotesSlide | Returns the notes slide for the current slide. Read-only NotesSlide.
OverrideTheme | Obsolete. Returns the overriding theme object.
ParentPresentation (inherited from BaseSlide) | Obsolete. Returns the parent presentation. Read-only Presentation.
Presentation (inherited from BaseSlide) |
Shapes (inherited from BaseSlide) | Returns the shapes of a slide. Read-only ShapeCollection.
SlideId (inherited from BaseSlide) | Returns the ID of a slide.
SlideNumber | Returns a number of slide. Index of slide in Slides collection is always equal to SlideNumber - 1.
SlideShowTransition (inherited from BaseSlide) | Returns the Transition object which contains information about how the specified slide advances during a slide show. Read-only ISlideShowTransition.
Tags (inherited from BaseSlide) | Obsolete. Returns the slide's tags collection. Read-only TagCollection.
ThemeManager |
Timeline (inherited from BaseSlide) | Returns animation timeline object. Read-only AnimationTimeLine.

See Also

Slide Class | Aspose.Slides Namespace


Hidden Property

Aspose.Slides Documentation

Slide.Hidden Property

Determines whether the specified slide is hidden during a slide show. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property Hidden As Boolean _
Implements ISlide.Hidden
[C#]
public bool Hidden {get; set;}

Implements

ISlide.Hidden

See Also

Slide Class | Aspose.Slides Namespace


LayoutSlide Property

Aspose.Slides Documentation

Slide.LayoutSlide Property

Returns or sets the layout slide for the current slide. Read/write LayoutSlide.

[Visual Basic]
NotOverridable Public Property LayoutSlide As ILayoutSlide _
Implements ISlide.LayoutSlide
[C#]
public ILayoutSlide LayoutSlide {get; set;}

Implements

ISlide.LayoutSlide

See Also

Slide Class | Aspose.Slides Namespace


NotesSlide Property

Aspose.Slides Documentation

Slide.NotesSlide Property

Returns the notes slide for the current slide. Read-only NotesSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property NotesSlide As INotesSlide _
Implements ISlide.NotesSlide
[C#]
public INotesSlide NotesSlide {get;}

Implements

ISlide.NotesSlide

See Also

Slide Class | Aspose.Slides Namespace


OverrideTheme Property

Aspose.Slides Documentation

Slide.OverrideTheme Property

NOTE: This property is now obsolete.

Use ThemeManager.OverrideTheme property instead. Property will be removed after 01.09.2013.

Returns the overriding theme object.

[Visual Basic]
Public ReadOnly Property OverrideTheme As OverrideTheme
[C#]
public OverrideTheme OverrideTheme {get;}

See Also

Slide Class | Aspose.Slides Namespace


SlideNumber Property

Aspose.Slides Documentation

Slide.SlideNumber Property

Returns a number of slide. Index of slide in Slides collection is always equal to SlideNumber - 1.

[Visual Basic]
NotOverridable Public Property SlideNumber As Integer _
Implements ISlide.SlideNumber
[C#]
public int SlideNumber {get; set;}

Implements

ISlide.SlideNumber

See Also

Slide Class | Aspose.Slides Namespace


ThemeManager Property

Aspose.Slides Documentation

Slide.ThemeManager Property

[Visual Basic]
NotOverridable Public ReadOnly Property ThemeManager As IOverrideThemeManager _
Implements IOverrideThemeable.ThemeManager
[C#]
public IOverrideThemeManager ThemeManager {get;}

Implements

IOverrideThemeable.ThemeManager

See Also

Slide Class | Aspose.Slides Namespace


Slide Methods

The methods of the Slide class are listed below. For a complete list of Slide class members, see the Slide Members topic.

Public Instance Methods

AddNotesSlide | Returns the notes slide for the current slide, creating one if there isn't.
ApplyColorScheme | Obsolete. Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseSlide) | Returns an effective theme for this slide.
FindShapeByAltText (inherited from BaseSlide) | Finds first occurrence of a shape with the specified alternative text.
GetSlideComments | Returns all slide comments added by specific author.
GetThumbnail | Overloaded. Returns a Thumbnail Bitmap object with custom scaling.
Remove | Removes slide from presentation.
WriteAsSvg | Overloaded. Saves content of slide as SVG file.

See Also

Slide Class | Aspose.Slides Namespace


Slide.AddNotesSlide Method

Returns the notes slide for the current slide, creating one if there isn't.

[Visual Basic]
NotOverridable Public Function AddNotesSlide() As INotesSlide _
Implements ISlide.AddNotesSlide
[C#]
public INotesSlide AddNotesSlide();

Return Value

NotesSlide for this slide.

Implements

ISlide.AddNotesSlide

See Also

Slide Class | Aspose.Slides Namespace


Slide.ApplyColorScheme Method

NOTE: This method is now obsolete.

Use ThemeManager.ApplyColorScheme(..) method instead. Will be removed after 01.09.2013.

Applies extra color scheme to a slide.

[Visual Basic]
Overrides Public Sub ApplyColorScheme( _
ByVal scheme As ExtraColorScheme _
)
[C#]
public override void ApplyColorScheme(
ExtraColorScheme scheme
);

Parameters

scheme

See Also

Slide Class | Aspose.Slides Namespace


Slide.GetSlideComments Method

Returns all slide comments added by specific author.

[Visual Basic]
NotOverridable Public Function GetSlideComments( _
ByVal author As ICommentAuthor _
) As IComment() _
Implements ISlide.GetSlideComments
[C#]
public IComment[] GetSlideComments(
ICommentAuthor author
);

Parameters

author
Author of comments to find or null to return all comments.

Return Value

Array of Comment.

Implements

ISlide.GetSlideComments

See Also

Slide Class | Aspose.Slides Namespace


GetThumbnail Method

Aspose.Slides Documentation

Slide.GetThumbnail Method

Returns a Thumbnail Image object (20% of real size).

Overload List

Returns a Thumbnail Image object (20% of real size).

public Bitmap GetThumbnail();

Returns a Thumbnail tiff bitmap object with specified parameters.

public Bitmap GetThumbnail(TiffOptions);

Returns a Thumbnail Bitmap object with specified size.

public Bitmap GetThumbnail(Size);

Returns a Thumbnail Bitmap object with custom scaling.

public Bitmap GetThumbnail(float,float);

See Also

Slide Class | Aspose.Slides Namespace


Slide.GetThumbnail Method ()

Returns a Thumbnail Image object (20% of real size).

[Visual Basic]
NotOverridable Overloads Public Function GetThumbnail() As Bitmap _
Implements ISlide.GetThumbnail
[C#]
public Bitmap GetThumbnail();

Implements

ISlide.GetThumbnail

See Also

Slide Class | Aspose.Slides Namespace | Slide.GetThumbnail Overload List


Slide.GetThumbnail Method (TiffOptions)

Returns a Thumbnail tiff bitmap object with specified parameters.

[Visual Basic]
Overloads Public Function GetThumbnail( _
ByVal options As TiffOptions _
) As Bitmap
[C#]
public Bitmap GetThumbnail(
TiffOptions options
);

Parameters

options
Tiff options.

Return Value

Bitmap object.

See Also

Slide Class | Aspose.Slides Namespace | Slide.GetThumbnail Overload List


Slide.GetThumbnail Method (Size)

Returns a Thumbnail Bitmap object with specified size.

[Visual Basic]
NotOverridable Overloads Public Function GetThumbnail( _
ByVal imageSize As Size _
) As Bitmap _
Implements ISlide.GetThumbnail
[C#]
public Bitmap GetThumbnail(
Size imageSize
);

Parameters

imageSize
Size of the image to create.

Return Value

Bitmap object.

Implements

ISlide.GetThumbnail

See Also

Slide Class | Aspose.Slides Namespace | Slide.GetThumbnail Overload List


Slide.GetThumbnail Method (Single, Single)

Returns a Thumbnail Bitmap object with custom scaling.

[Visual Basic]
NotOverridable Overloads Public Function GetThumbnail( _
ByVal scaleX As Single, _
ByVal scaleY As Single _
) As Bitmap _
Implements ISlide.GetThumbnail
[C#]
public Bitmap GetThumbnail(
float scaleX,
float scaleY
);

Parameters

scaleX
The value by which to scale this Thumbnail in the x-axis direction.
scaleY
The value by which to scale this Thumbnail in the y-axis direction.

Return Value

Bitmap object.

Implements

ISlide.GetThumbnail

See Also

Slide Class | Aspose.Slides Namespace | Slide.GetThumbnail Overload List


Slide.Remove Method

Removes slide from presentation.

[Visual Basic]
NotOverridable Public Sub Remove() _
Implements ISlide.Remove
[C#]
public void Remove();

Implements

ISlide.Remove

Exceptions

Exception Type | Condition
PptxEditException | Thrown if slide is already removed from presentation.

See Also

Slide Class | Aspose.Slides Namespace


WriteAsSvg Method

Aspose.Slides Documentation

Slide.WriteAsSvg Method

Saves content of slide as SVG file.

Overload List

Saves content of slide as SVG file.

public void WriteAsSvg(Stream);

Saves content of slide as SVG file.

public void WriteAsSvg(Stream,SVGOptions);

See Also

Slide Class | Aspose.Slides Namespace


Slide.WriteAsSvg Method (Stream)

Saves content of slide as SVG file.

[Visual Basic]
NotOverridable Overloads Public Sub WriteAsSvg( _
ByVal stream As Stream _
) _
Implements ISlide.WriteAsSvg
[C#]
public void WriteAsSvg(
Stream stream
);

Parameters

stream
Target stream

Implements

ISlide.WriteAsSvg

See Also

Slide Class | Aspose.Slides Namespace | Slide.WriteAsSvg Overload List


Slide.WriteAsSvg Method (Stream, SVGOptions)

Saves content of slide as SVG file.

[Visual Basic]
Overloads Public Sub WriteAsSvg( _
ByVal stream As Stream, _
ByVal svgOptions As SVGOptions _
)
[C#]
public void WriteAsSvg(
Stream stream,
SVGOptions svgOptions
);

Parameters

stream
Target stream
svgOptions
SVG generation options

See Also

Slide Class | Aspose.Slides Namespace | Slide.WriteAsSvg Overload List


SlideCollection Class

Represents a collection of a slides.

For a list of all members of this type, see SlideCollection Members.

System.Object
Aspose.Slides.SlideCollection

[Visual Basic]
NotInheritable Public Class SlideCollection
Implements ISlideCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ISlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public sealed class SlideCollection : ISlideCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SlideCollection Members | Aspose.Slides Namespace


SlideCollection Members

SlideCollection overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only Slide.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

AddClone | Overloaded. Adds a copy of a specified slide to the end of the collection.
AddEmptySlide | Adds a new empty slide to the end of the collection.
AddFromHtml | Overloaded. Creates slides from HTML text and adds them to the end of the collection.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
IndexOf | Returns an index of the specified slide in the collection.
InsertClone | Overloaded. Inserts a copy of a specified slide to specified position of the collection.
InsertEmptySlide | Inserts a copy of a specified slide to specified position of the collection.
InsertFromHtml | Overloaded. Creates slides from HTML text and inserts them to the collection at the specified position.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.
Reorder | Overloaded. Moves slide from the collection to the specified position.
ToArray | Overloaded. Creates and returns an array with all slides in it.

See Also

SlideCollection Class | Aspose.Slides Namespace


SlideCollection Properties

The properties of the SlideCollection class are listed below. For a complete list of SlideCollection class members, see the SlideCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only Slide.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

SlideCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

SlideCollection.Count Property

Gets the number of elements actually contained in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

SlideCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

SlideCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

SlideCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

SlideCollection.Item Property

Gets the element at the specified index. Read-only Slide.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ISlideCollection.Item
As ISlide _
Implements ISlideCollection.Item
[C#]
public ISlide this[
int index
] {get;}

Implements

ISlideCollection.Item

See Also

SlideCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

SlideCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

SlideCollection Class | Aspose.Slides Namespace


SlideCollection Methods

The methods of the SlideCollection class are listed below. For a complete list of SlideCollection class members, see the SlideCollection Members topic.

Public Instance Methods

AddClone | Overloaded. Adds a copy of a specified slide to the end of the collection.
AddEmptySlide | Adds a new empty slide to the end of the collection.
AddFromHtml | Overloaded. Creates slides from HTML text and adds them to the end of the collection.
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
IndexOf | Returns an index of the specified slide in the collection.
InsertClone | Overloaded. Inserts a copy of a specified slide to specified position of the collection.
InsertEmptySlide | Inserts a copy of a specified slide to specified position of the collection.
InsertFromHtml | Overloaded. Creates slides from HTML text and inserts them to the collection at the specified position.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.
Reorder | Overloaded. Moves slide from the collection to the specified position.
ToArray | Overloaded. Creates and returns an array with all slides in it.

See Also

SlideCollection Class | Aspose.Slides Namespace


AddClone Method

Aspose.Slides Documentation

SlideCollection.AddClone Method

Adds a copy of a specified slide to the end of the collection.

Overload List

Adds a copy of a specified slide to the end of the collection.

public ISlide AddClone(ISlide);

Adds a copy of a specified slide to the end of the collection.

public ISlide AddClone(ISlide,ILayoutSlide);

Obsolete. Adds a copy of a specified slide to the end of the collection. Layout will be selected automatically from the specified master.

public ISlide AddClone(ISlide,IMasterSlide);

Adds a copy of a specified source slide to the end of the collection. Appropriate layout will be selected automatically from the specified master (appropriate layout is the layout with the same Type or Name as of layout of the source slide). If there is no appropriate layout then layout of the source slide will be cloned (if allowCloneMissingLayout is true) or PptxEditException will be thrown (if allowCloneMissingLayout is false).

public ISlide AddClone(ISlide,IMasterSlide,bool);

See Also

SlideCollection Class | Aspose.Slides Namespace


SlideCollection.AddClone Method (ISlide)

Adds a copy of a specified slide to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddClone( _
ByVal sourceSlide As ISlide _
) As ISlide _
Implements ISlideCollection.AddClone
[C#]
public ISlide AddClone(
ISlide sourceSlide
);

Parameters

sourceSlide
Slide to clone.

Return Value

New slide.

Implements

ISlideCollection.AddClone

Remarks

When cloning a slide between different presentations slide's master can be cloned too. Internal registry is used to track automatically cloned masters to prevent creation of multiple clones of the same master slide. Manual cloning of master slides will be neither prevented nor registered. If you need more control over cloning process use AddClone or AddClone for cloning slides, AddClone or AddClone for cloning layouts and AddClone for cloning masters.

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.AddClone Overload List


SlideCollection.AddClone Method (ISlide, ILayoutSlide)

Adds a copy of a specified slide to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddClone( _
ByVal sourceSlide As ISlide, _
ByVal destLayout As ILayoutSlide _
) As ISlide _
Implements ISlideCollection.AddClone
[C#]
public ISlide AddClone(
ISlide sourceSlide,
ILayoutSlide destLayout
);

Parameters

sourceSlide
Slide to clone.
destLayout
Layout slide for a new slide.

Return Value

New slide.

Implements

ISlideCollection.AddClone

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.AddClone Overload List


SlideCollection.AddClone Method (ISlide, IMasterSlide)

NOTE: This method is now obsolete.

Use AddClone(ISlide sourceSlide, IMasterSlide destMaster, bool allowCloneMissingLayout) method instead. Will be removed after 01.08.2014.

Adds a copy of a specified slide to the end of the collection. Layout will be selected automatically from the specified master.

[Visual Basic]
NotOverridable Overloads Public Function AddClone( _
ByVal sourceSlide As ISlide, _
ByVal destMaster As IMasterSlide _
) As ISlide _
Implements ISlideCollection.AddClone
[C#]
public ISlide AddClone(
ISlide sourceSlide,
IMasterSlide destMaster
);

Parameters

sourceSlide
Slide to clone.
destMaster
Master slide for a new slide.

Return Value

New slide.

Implements

ISlideCollection.AddClone

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.AddClone Overload List


SlideCollection.AddClone Method (ISlide, IMasterSlide, Boolean)

Adds a copy of a specified source slide to the end of the collection. Appropriate layout will be selected automatically from the specified master (appropriate layout is the layout with the same Type or Name as of layout of the source slide). If there is no appropriate layout then layout of the source slide will be cloned (if allowCloneMissingLayout is true) or PptxEditException will be thrown (if allowCloneMissingLayout is false).

[Visual Basic]
NotOverridable Overloads Public Function AddClone( _
ByVal sourceSlide As ISlide, _
ByVal destMaster As IMasterSlide, _
ByVal allowCloneMissingLayout As Boolean _
) As ISlide _
Implements ISlideCollection.AddClone
[C#]
public ISlide AddClone(
ISlide sourceSlide,
IMasterSlide destMaster,
bool allowCloneMissingLayout
);

Parameters

sourceSlide
Slide to clone.
destMaster
Master slide for a new slide.
allowCloneMissingLayout
If there is no appropriate layout in specified master then layout of the source slide will be cloned (if allowCloneMissingLayout is true) or PptxEditException will be thrown (if allowCloneMissingLayout is false).

Return Value

New slide.

Implements

ISlideCollection.AddClone

Exceptions

Exception Type | Condition
PptxEditException | Thrown if there is no appropriate layout in specified master and allowCloneMissingLayout is false.

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.AddClone Overload List


SlideCollection.AddEmptySlide Method

Adds a new empty slide to the end of the collection.

[Visual Basic]
NotOverridable Public Function AddEmptySlide( _
ByVal layout As ILayoutSlide _
) As ISlide _
Implements ISlideCollection.AddEmptySlide
[C#]
public ISlide AddEmptySlide(
ILayoutSlide layout
);

Parameters

layout
Layout for a slide.

Return Value

Added slide.

Implements

ISlideCollection.AddEmptySlide

See Also

SlideCollection Class | Aspose.Slides Namespace


AddFromHtml Method

Aspose.Slides Documentation

SlideCollection.AddFromHtml Method

Creates slides from HTML text and adds them to the end of the collection.

Overload List

Creates slides from HTML text and adds them to the end of the collection.

public ISlide[] AddFromHtml(Stream);

Creates slides from HTML text and adds them to the end of the collection.

public ISlide[] AddFromHtml(Stream,IHtmlExternalResolver,string);

Creates slides from HTML text and adds them to the end of the collection.

public ISlide[] AddFromHtml(TextReader);

Creates slides from HTML text and adds them to the end of the collection.

public ISlide[] AddFromHtml(TextReader,IHtmlExternalResolver,string);

Creates slides from HTML text and adds them to the end of the collection.

public ISlide[] AddFromHtml(string);

Creates slides from HTML text and adds them to the end of the collection.

public ISlide[] AddFromHtml(string,IHtmlExternalResolver,string);

See Also

SlideCollection Class | Aspose.Slides Namespace


SlideCollection.AddFromHtml Method (Stream)

Creates slides from HTML text and adds them to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddFromHtml( _
ByVal htmlStream As Stream _
) As ISlide() _
Implements ISlideCollection.AddFromHtml
[C#]
public ISlide[] AddFromHtml(
Stream htmlStream
);

Parameters

htmlStream
A Stream object which will be used as a source of a HTML file.

Return Value

Added slides

Implements

ISlideCollection.AddFromHtml

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.AddFromHtml Overload List


SlideCollection.AddFromHtml Method (Stream, IHtmlExternalResolver, String)

Creates slides from HTML text and adds them to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddFromHtml( _
ByVal htmlStream As Stream, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) As ISlide() _
Implements ISlideCollection.AddFromHtml
[C#]
public ISlide[] AddFromHtml(
Stream htmlStream,
IHtmlExternalResolver resolver,
string uri
);

Parameters

htmlStream
A Stream object which will be used as a source of a HTML file.
resolver
A callback object used to fetch external objects. If this parameter is null all external objects will be ignored.
uri
An URI of the specified HTML. Used to resolve relative links.

Return Value

Added slides.

Implements

ISlideCollection.AddFromHtml

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.AddFromHtml Overload List


SlideCollection.AddFromHtml Method (TextReader)

Creates slides from HTML text and adds them to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddFromHtml( _
ByVal htmlReader As TextReader _
) As ISlide() _
Implements ISlideCollection.AddFromHtml
[C#]
public ISlide[] AddFromHtml(
TextReader htmlReader
);

Parameters

htmlReader
TextReader object which will be used as a source of a HTML file.

Return Value

Added slides

Implements

ISlideCollection.AddFromHtml

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.AddFromHtml Overload List


SlideCollection.AddFromHtml Method (TextReader, IHtmlExternalResolver, String)

Creates slides from HTML text and adds them to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddFromHtml( _
ByVal htmlReader As TextReader, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) As ISlide() _
Implements ISlideCollection.AddFromHtml
[C#]
public ISlide[] AddFromHtml(
TextReader htmlReader,
IHtmlExternalResolver resolver,
string uri
);

Parameters

htmlReader
TextReader object which will be used as a source of a HTML file.
resolver
A callback object used to fetch external objects. If this parameter is null all external objects will be ignored.
uri
An URI of the specified HTML. Used to resolve relative links.

Return Value

Added slides.

Implements

ISlideCollection.AddFromHtml

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.AddFromHtml Overload List


SlideCollection.AddFromHtml Method (String)

Creates slides from HTML text and adds them to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddFromHtml( _
ByVal htmlText As String _
) As ISlide() _
Implements ISlideCollection.AddFromHtml
[C#]
public ISlide[] AddFromHtml(
string htmlText
);

Parameters

htmlText
Html to add.

Return Value

Added slides

Implements

ISlideCollection.AddFromHtml

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.AddFromHtml Overload List


SlideCollection.AddFromHtml Method (String, IHtmlExternalResolver, String)

Creates slides from HTML text and adds them to the end of the collection.

[Visual Basic]
NotOverridable Overloads Public Function AddFromHtml( _
ByVal htmlText As String, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) As ISlide() _
Implements ISlideCollection.AddFromHtml
[C#]
public ISlide[] AddFromHtml(
string htmlText,
IHtmlExternalResolver resolver,
string uri
);

Parameters

htmlText
Html to add.
resolver
A callback object used to fetch external objects. If this parameter is null all external objects will be ignored.
uri
An URI of the specified HTML. Used to resolve relative links.

Return Value

Added slides.

Implements

ISlideCollection.AddFromHtml

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.AddFromHtml Overload List


SlideCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

SlideCollection Class | Aspose.Slides Namespace


SlideCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

SlideCollection Class | Aspose.Slides Namespace


SlideCollection.IndexOf Method

Returns an index of the specified slide in the collection.

[Visual Basic]
NotOverridable Public Function IndexOf( _
ByVal slide As ISlide _
) As Integer _
Implements ISlideCollection.IndexOf
[C#]
public int IndexOf(
ISlide slide
);

Parameters

slide
Slide to find.

Return Value

Index of a slide or -1 if slide not from this collection.

Implements

ISlideCollection.IndexOf

See Also

SlideCollection Class | Aspose.Slides Namespace


InsertClone Method

Aspose.Slides Documentation

SlideCollection.InsertClone Method

Inserts a copy of a specified slide to specified position of the collection.

Overload List

Inserts a copy of a specified slide to specified position of the collection.

public ISlide InsertClone(int,ISlide);

Inserts a copy of a specified slide to specified position of the collection.

public ISlide InsertClone(int,ISlide,ILayoutSlide);

Obsolete. Inserts a copy of a specified slide to specified position of the collection. Layout will be selected automatically from the specified master.

public ISlide InsertClone(int,ISlide,IMasterSlide);

Inserts a copy of a specified source slide to specified position of the collection. Appropriate layout will be selected automatically from the specified master (appropriate layout is the layout with the same Type or Name as of layout of the source slide). If there is no appropriate layout then layout of the source slide will be cloned (if allowCloneMissingLayout is true) or PptxEditException will be thrown (if allowCloneMissingLayout is false).

public ISlide InsertClone(int,ISlide,IMasterSlide,bool);

See Also

SlideCollection Class | Aspose.Slides Namespace


SlideCollection.InsertClone Method (Int32, ISlide)

Inserts a copy of a specified slide to specified position of the collection.

[Visual Basic]
NotOverridable Overloads Public Function InsertClone( _
ByVal index As Integer, _
ByVal sourceSlide As ISlide _
) As ISlide _
Implements ISlideCollection.InsertClone
[C#]
public ISlide InsertClone(
int index,
ISlide sourceSlide
);

Parameters

index
Index of new slide.
sourceSlide
Slide to clone.

Return Value

Inserted slide.

Implements

ISlideCollection.InsertClone

Remarks

When cloning a slide between different presentations slide's master can be cloned too. Internal registry is used to track automatically cloned masters to prevent creation of multiple clones of the same master slide. Manual cloning of master slides will be neither prevented nor registered. If you need more control over cloning process use InsertClone or InsertClone for cloning slides and AddClone for cloning masters.

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.InsertClone Overload List


SlideCollection.InsertClone Method (Int32, ISlide, ILayoutSlide)

Inserts a copy of a specified slide to specified position of the collection.

[Visual Basic]
NotOverridable Overloads Public Function InsertClone( _
ByVal index As Integer, _
ByVal sourceSlide As ISlide, _
ByVal destLayout As ILayoutSlide _
) As ISlide _
Implements ISlideCollection.InsertClone
[C#]
public ISlide InsertClone(
int index,
ISlide sourceSlide,
ILayoutSlide destLayout
);

Parameters

index
Index of new slide.
sourceSlide
Slide to clone.
destLayout
Layout slide for a new slide.

Return Value

Inserted slide.

Implements

ISlideCollection.InsertClone

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.InsertClone Overload List


SlideCollection.InsertClone Method (Int32, ISlide, IMasterSlide)

NOTE: This method is now obsolete.

Use InsertClone(int index, ISlide sourceSlide, IMasterSlide destMaster, bool allowCloneMissingLayout) method instead. Will be removed after 01.08.2014.

Inserts a copy of a specified slide to specified position of the collection. Layout will be selected automatically from the specified master.

[Visual Basic]
NotOverridable Overloads Public Function InsertClone( _
ByVal index As Integer, _
ByVal sourceSlide As ISlide, _
ByVal destMaster As IMasterSlide _
) As ISlide _
Implements ISlideCollection.InsertClone
[C#]
public ISlide InsertClone(
int index,
ISlide sourceSlide,
IMasterSlide destMaster
);

Parameters

index
Index of new slide.
sourceSlide
Slide to clone.
destMaster
Master slide for a new slide.

Return Value

Inserted slide.

Implements

ISlideCollection.InsertClone

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.InsertClone Overload List


SlideCollection.InsertClone Method (Int32, ISlide, IMasterSlide, Boolean)

Inserts a copy of a specified source slide to specified position of the collection. Appropriate layout will be selected automatically from the specified master (appropriate layout is the layout with the same Type or Name as of layout of the source slide). If there is no appropriate layout then layout of the source slide will be cloned (if allowCloneMissingLayout is true) or PptxEditException will be thrown (if allowCloneMissingLayout is false).

[Visual Basic]
NotOverridable Overloads Public Function InsertClone( _
ByVal index As Integer, _
ByVal sourceSlide As ISlide, _
ByVal destMaster As IMasterSlide, _
ByVal allowCloneMissingLayout As Boolean _
) As ISlide _
Implements ISlideCollection.InsertClone
[C#]
public ISlide InsertClone(
int index,
ISlide sourceSlide,
IMasterSlide destMaster,
bool allowCloneMissingLayout
);

Parameters

index
Index of new slide.
sourceSlide
Slide to clone.
destMaster
Master slide for a new slide.
allowCloneMissingLayout
If there is no appropriate layout in specified master then layout of the source slide will be cloned (if allowCloneMissingLayout is true) or PptxEditException will be thrown (if allowCloneMissingLayout is false).

Return Value

Inserted slide.

Implements

ISlideCollection.InsertClone

Exceptions

Exception Type | Condition
PptxEditException | Thrown if there is no appropriate layout in specified master and allowCloneMissingLayout is false.

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.InsertClone Overload List


SlideCollection.InsertEmptySlide Method

Inserts a copy of a specified slide to specified position of the collection.

[Visual Basic]
NotOverridable Public Function InsertEmptySlide( _
ByVal index As Integer, _
ByVal layout As ILayoutSlide _
) As ISlide _
Implements ISlideCollection.InsertEmptySlide
[C#]
public ISlide InsertEmptySlide(
int index,
ILayoutSlide layout
);

Parameters

index
Index of a new slide.
layout
Layout for a slide.

Return Value

Inserted slide.

Implements

ISlideCollection.InsertEmptySlide

See Also

SlideCollection Class | Aspose.Slides Namespace


InsertFromHtml Method

Aspose.Slides Documentation

SlideCollection.InsertFromHtml Method

Creates slides from HTML text and inserts them to the collection at the specified position.

Overload List

Creates slides from HTML text and inserts them to the collection at the specified position.

public ISlide[] InsertFromHtml(int,Stream);

Creates slides from HTML text and inserts them to the collection at the specified position.

public ISlide[] InsertFromHtml(int,Stream,IHtmlExternalResolver,string);

Creates slides from HTML text and inserts them to the collection at the specified position.

public ISlide[] InsertFromHtml(int,TextReader);

Creates slides from HTML text and inserts them to the collection at the specified position.

public ISlide[] InsertFromHtml(int,TextReader,IHtmlExternalResolver,string);

Creates slides from HTML text and inserts them to the collection at the specified position.

public ISlide[] InsertFromHtml(int,string);

Creates slides from HTML text and inserts them to the collection at the specified position.

public ISlide[] InsertFromHtml(int,string,IHtmlExternalResolver,string);

See Also

SlideCollection Class | Aspose.Slides Namespace


SlideCollection.InsertFromHtml Method (Int32, Stream)

Creates slides from HTML text and inserts them to the collection at the specified position.

[Visual Basic]
NotOverridable Overloads Public Function InsertFromHtml( _
ByVal index As Integer, _
ByVal htmlStream As Stream _
) As ISlide() _
Implements ISlideCollection.InsertFromHtml
[C#]
public ISlide[] InsertFromHtml(
int index,
Stream htmlStream
);

Parameters

index
Position to insert.
htmlStream
A Stream object which will be used as a source of a HTML file.

Return Value

Added slides

Implements

ISlideCollection.InsertFromHtml

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.InsertFromHtml Overload List


SlideCollection.InsertFromHtml Method (Int32, Stream, IHtmlExternalResolver, String)

Creates slides from HTML text and inserts them to the collection at the specified position.

[Visual Basic]
NotOverridable Overloads Public Function InsertFromHtml( _
ByVal index As Integer, _
ByVal htmlStream As Stream, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) As ISlide() _
Implements ISlideCollection.InsertFromHtml
[C#]
public ISlide[] InsertFromHtml(
int index,
Stream htmlStream,
IHtmlExternalResolver resolver,
string uri
);

Parameters

index
Position to insert.
htmlStream
A Stream object which will be used as a source of a HTML file.
resolver
A callback object used to fetch external objects. If this parameter is null all external objects will be ignored.
uri
An URI of the specified HTML. Used to resolve relative links.

Return Value

Added slides.

Implements

ISlideCollection.InsertFromHtml

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.InsertFromHtml Overload List


SlideCollection.InsertFromHtml Method (Int32, TextReader)

Creates slides from HTML text and inserts them to the collection at the specified position.

[Visual Basic]
NotOverridable Overloads Public Function InsertFromHtml( _
ByVal index As Integer, _
ByVal htmlReader As TextReader _
) As ISlide() _
Implements ISlideCollection.InsertFromHtml
[C#]
public ISlide[] InsertFromHtml(
int index,
TextReader htmlReader
);

Parameters

index
Position to insert.
htmlReader
TextReader object which will be used as a source of a HTML file.

Return Value

Added slides

Implements

ISlideCollection.InsertFromHtml

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.InsertFromHtml Overload List


SlideCollection.InsertFromHtml Method (Int32, TextReader, IHtmlExternalResolver, String)

Creates slides from HTML text and inserts them to the collection at the specified position.

[Visual Basic]
NotOverridable Overloads Public Function InsertFromHtml( _
ByVal index As Integer, _
ByVal htmlReader As TextReader, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) As ISlide() _
Implements ISlideCollection.InsertFromHtml
[C#]
public ISlide[] InsertFromHtml(
int index,
TextReader htmlReader,
IHtmlExternalResolver resolver,
string uri
);

Parameters

index
Position to insert.
htmlReader
TextReader object which will be used as a source of a HTML file.
resolver
A callback object used to fetch external objects. If this parameter is null all external objects will be ignored.
uri
An URI of the specified HTML. Used to resolve relative links.

Return Value

Added slides.

Implements

ISlideCollection.InsertFromHtml

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.InsertFromHtml Overload List


SlideCollection.InsertFromHtml Method (Int32, String)

Creates slides from HTML text and inserts them to the collection at the specified position.

[Visual Basic]
NotOverridable Overloads Public Function InsertFromHtml( _
ByVal index As Integer, _
ByVal htmlText As String _
) As ISlide() _
Implements ISlideCollection.InsertFromHtml
[C#]
public ISlide[] InsertFromHtml(
int index,
string htmlText
);

Parameters

index
Position to insert.
htmlText
Html to add.

Return Value

Added slides

Implements

ISlideCollection.InsertFromHtml

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.InsertFromHtml Overload List


SlideCollection.InsertFromHtml Method (Int32, String, IHtmlExternalResolver, String)

Creates slides from HTML text and inserts them to the collection at the specified position.

[Visual Basic]
NotOverridable Overloads Public Function InsertFromHtml( _
ByVal index As Integer, _
ByVal htmlText As String, _
ByVal resolver As IHtmlExternalResolver, _
ByVal uri As String _
) As ISlide() _
Implements ISlideCollection.InsertFromHtml
[C#]
public ISlide[] InsertFromHtml(
int index,
string htmlText,
IHtmlExternalResolver resolver,
string uri
);

Parameters

index
Position to insert.
htmlText
Html to add.
resolver
A callback object used to fetch external objects. If this parameter is null all external objects will be ignored.
uri
An URI of the specified HTML. Used to resolve relative links.

Return Value

Added slides.

Implements

ISlideCollection.InsertFromHtml

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.InsertFromHtml Overload List


SlideCollection.Remove Method

Removes the first occurrence of a specific object from the collection.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal value As ISlide _
) _
Implements ISlideCollection.Remove
[C#]
public void Remove(
ISlide value
);

Parameters

value
The slide to remove from the collection.

Implements

ISlideCollection.Remove

See Also

SlideCollection Class | Aspose.Slides Namespace


SlideCollection.RemoveAt Method

Removes the element at the specified index of the collection.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements ISlideCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Implements

ISlideCollection.RemoveAt

See Also

SlideCollection Class | Aspose.Slides Namespace


Reorder Method

Aspose.Slides Documentation

SlideCollection.Reorder Method

Moves slide from the collection to the specified position.

Overload List

Moves slide from the collection to the specified position.

public void Reorder(int,ISlide);

Moves slides from the collection to the specified position. Slides will be placed starting from index in order they appear in list.

public void Reorder(int,params ISlide[]);

See Also

SlideCollection Class | Aspose.Slides Namespace


SlideCollection.Reorder Method (Int32, ISlide)

Moves slide from the collection to the specified position.

[Visual Basic]
NotOverridable Overloads Public Sub Reorder( _
ByVal index As Integer, _
ByVal slide As ISlide _
) _
Implements ISlideCollection.Reorder
[C#]
public void Reorder(
int index,
ISlide slide
);

Parameters

index
Target index.
slide
Slide to move.

Implements

ISlideCollection.Reorder

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.Reorder Overload List


SlideCollection.Reorder Method (Int32, ISlide[])

Moves slides from the collection to the specified position. Slides will be placed starting from index in order they appear in list.

[Visual Basic]
NotOverridable Overloads Public Sub Reorder( _
ByVal index As Integer, _
ParamArray slides As ISlide() _
) _
Implements ISlideCollection.Reorder
[C#]
public void Reorder(
int index,
params ISlide[] slides
);

Parameters

index
Target index.
slides
Slides to move.

Implements

ISlideCollection.Reorder

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.Reorder Overload List


ToArray Method

Aspose.Slides Documentation

SlideCollection.ToArray Method

Creates and returns an array with all slides in it.

Overload List

Creates and returns an array with all slides in it.

public ISlide[] ToArray();

Creates and returns an array with all slides from the specified range in it. An index of a first slide to add.A number of slides to add.

public ISlide[] ToArray(int,int);

See Also

SlideCollection Class | Aspose.Slides Namespace


SlideCollection.ToArray Method ()

Creates and returns an array with all slides in it.

[Visual Basic]
NotOverridable Overloads Public Function ToArray() As ISlide() _
Implements ISlideCollection.ToArray
[C#]
public ISlide[] ToArray();

Return Value

Array of Slide

Implements

ISlideCollection.ToArray

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.ToArray Overload List


SlideCollection.ToArray Method (Int32, Int32)

Creates and returns an array with all slides from the specified range in it. An index of a first slide to add.A number of slides to add.

[Visual Basic]
NotOverridable Overloads Public Function ToArray( _
ByVal startIndex As Integer, _
ByVal count As Integer _
) As ISlide() _
Implements ISlideCollection.ToArray
[C#]
public ISlide[] ToArray(
int startIndex,
int count
);

Return Value

Array of Slide

Implements

ISlideCollection.ToArray

See Also

SlideCollection Class | Aspose.Slides Namespace | SlideCollection.ToArray Overload List


SlideLayoutType Enumeration

[Visual Basic]
Public Enum SlideLayoutType
Inherits
[C#]
public enum SlideLayoutType

Members

Member Name | Description | Value
Custom |  | -1
Title |  | 0
Text |  | 1
TwoColumnText |  | 2
Table |  | 3
TextAndChart |  | 4
ChartAndText |  | 5
Diagram |  | 6
Chart |  | 7
TextAndClipArt |  | 8
ClipArtAndText |  | 9
TitleOnly |  | 10
Blank |  | 11
TextAndObject |  | 12
ObjectAndText |  | 13
Object |  | 14
TitleAndObject |  | 15
TextAndMedia |  | 16
MediaAndText |  | 17
ObjectOverText |  | 18
TextOverObject |  | 19
TextAndTwoObjects |  | 20
TwoObjectsAndText |  | 21
TwoObjectsOverText |  | 22
FourObjects |  | 23
VerticalText |  | 24
ClipArtAndVerticalText |  | 25
VerticalTitleAndText |  | 26
VerticalTitleAndTextOverChart |  | 27
TwoObjects |  | 28
ObjectAndTwoObject |  | 29
TwoObjectsAndObject |  | 30
SectionHeader |  | 31
TwoTextAndTwoObjects |  | 32
TitleObjectAndCaption |  | 33
PictureAndCaption |  | 34

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


SlideOrienation Enumeration

[Visual Basic]
Public Enum SlideOrienation
[C#]
public enum SlideOrienation

Members

Member Name | Description | Value
Landscape |  | 0
Portrait |  | 1

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


SlideSize Class

Represents a size of slide.

For a list of all members of this type, see SlideSize Members.

System.Object
Aspose.Slides.SlideSize

[Visual Basic]
Public Class SlideSize
Implements ISlideSize
[C#]
public class SlideSize : ISlideSize

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SlideSize Members | Aspose.Slides Namespace


SlideSize Members

SlideSize overview

Public Instance Constructors

SlideSize Constructor Initializes a new instance of the SlideSize class.

Public Instance Properties

Orientation | Returns or sets the slide orientation. Read/Write SlideOrienation. Changing this value will swap slide's dimensions.
Size | Returns or sets the size in points. Read/Write SizeF. Assigning any value will reset Type property to Custom and set Orientation.
Type | Returns or sets the type of slide size. Read/Write SlideSizeType. Assigning any value except Custom will change Size accordingly, but will keep Orientation intact.

See Also

SlideSize Class | Aspose.Slides Namespace


SlideSize Constructor

Initializes a new instance of the SlideSize class.

[Visual Basic]
Public Sub New()
[C#]
public SlideSize();

See Also

SlideSize Class | Aspose.Slides Namespace


SlideSize Properties

The properties of the SlideSize class are listed below. For a complete list of SlideSize class members, see the SlideSize Members topic.

Public Instance Properties

Orientation | Returns or sets the slide orientation. Read/Write SlideOrienation. Changing this value will swap slide's dimensions.
Size | Returns or sets the size in points. Read/Write SizeF. Assigning any value will reset Type property to Custom and set Orientation.
Type | Returns or sets the type of slide size. Read/Write SlideSizeType. Assigning any value except Custom will change Size accordingly, but will keep Orientation intact.

See Also

SlideSize Class | Aspose.Slides Namespace


Orientation Property

Aspose.Slides Documentation

SlideSize.Orientation Property

Returns or sets the slide orientation. Read/Write SlideOrienation. Changing this value will swap slide's dimensions.

[Visual Basic]
NotOverridable Public Property Orientation As SlideOrienation _
Implements ISlideSize.Orientation
[C#]
public SlideOrienation Orientation {get; set;}

Implements

ISlideSize.Orientation

See Also

SlideSize Class | Aspose.Slides Namespace


Size Property

Aspose.Slides Documentation

SlideSize.Size Property

Returns or sets the size in points. Read/Write SizeF. Assigning any value will reset Type property to Custom and set Orientation.

[Visual Basic]
NotOverridable Public Property Size As SizeF _
Implements ISlideSize.Size
[C#]
public SizeF Size {get; set;}

Implements

ISlideSize.Size

See Also

SlideSize Class | Aspose.Slides Namespace


Type Property

Aspose.Slides Documentation

SlideSize.Type Property

Returns or sets the type of slide size. Read/Write SlideSizeType. Assigning any value except Custom will change Size accordingly, but will keep Orientation intact.

[Visual Basic]
NotOverridable Public Property Type As SlideSizeType _
Implements ISlideSize.Type
[C#]
public SlideSizeType Type {get; set;}

Implements

ISlideSize.Type

See Also

SlideSize Class | Aspose.Slides Namespace


SlideSizeType Enumeration

[Visual Basic]
Public Enum SlideSizeType
[C#]
public enum SlideSizeType

Members

Member Name | Description | Value
OnScreen |  | 0
LetterPaper |  | 1
A4Paper |  | 2
Slide35mm |  | 3
Overhead |  | 4
Banner |  | 5
Custom |  | 6
Ledger |  | 7
A3Paper |  | 8
B4IsoPaper |  | 9
B5IsoPaper |  | 10
B4JisPaper |  | 11
B5JisPaper |  | 12
HagakiCard |  | 13
OnScreen16x9 |  | 14
OnScreen16x10 |  | 15

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


SourceFormat Enumeration

[Visual Basic]
Public Enum SourceFormat
[C#]
public enum SourceFormat

Members

Member Name | Description | Value
Ppt |  | 0
Pptx |  | 1
Odp |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


StreamWrapper Class

Aspose.IO.Stream wrapper for COM interface.

For a list of all members of this type, see StreamWrapper Members.

System.Object
Aspose.Slides.StreamWrapper

[Visual Basic]
Public Class StreamWrapper
Implements IStreamWrapper, IDisposable
[C#]
public class StreamWrapper : IStreamWrapper, IDisposable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

StreamWrapper Members | Aspose.Slides Namespace


StreamWrapper Members

StreamWrapper overview

Public Instance Properties

AsIDisposable | Gets IDisposable interface. For COM compatibility.
CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Length | Gets the length in bytes of the stream.
Position | Gets or sets the position within the current stream.
Stream |

Public Instance Methods

Close | Closes the current stream and releases any resources.
Dispose |
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
Read | Reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.
ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.
Seek | Sets the position within the current stream
Write | writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.
WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte.

See Also

StreamWrapper Class | Aspose.Slides Namespace


StreamWrapper Properties

The properties of the StreamWrapper class are listed below. For a complete list of StreamWrapper class members, see the StreamWrapper Members topic.

Public Instance Properties

AsIDisposable | Gets IDisposable interface. For COM compatibility.
CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Length | Gets the length in bytes of the stream.
Position | Gets or sets the position within the current stream.
Stream |

See Also

StreamWrapper Class | Aspose.Slides Namespace


AsIDisposable Property

Aspose.Slides Documentation

StreamWrapper.AsIDisposable Property

Gets IDisposable interface. For COM compatibility.

[Visual Basic]
NotOverridable Public ReadOnly Property AsIDisposable As IDisposable _
Implements IStreamWrapper.AsIDisposable
[C#]
public IDisposable AsIDisposable {get;}

Implements

IStreamWrapper.AsIDisposable

See Also

StreamWrapper Class | Aspose.Slides Namespace


CanRead Property

Aspose.Slides Documentation

StreamWrapper.CanRead Property

Gets a value indicating whether the current stream supports reading.

[Visual Basic]
NotOverridable Public ReadOnly Property CanRead As Boolean _
Implements IStreamWrapper.CanRead
[C#]
public bool CanRead {get;}

Implements

IStreamWrapper.CanRead

See Also

StreamWrapper Class | Aspose.Slides Namespace


CanSeek Property

Aspose.Slides Documentation

StreamWrapper.CanSeek Property

Gets a value indicating whether the current stream supports seeking.

[Visual Basic]
NotOverridable Public ReadOnly Property CanSeek As Boolean _
Implements IStreamWrapper.CanSeek
[C#]
public bool CanSeek {get;}

Implements

IStreamWrapper.CanSeek

See Also

StreamWrapper Class | Aspose.Slides Namespace


CanWrite Property

Aspose.Slides Documentation

StreamWrapper.CanWrite Property

Gets a value indicating whether the current stream supports writing.

[Visual Basic]
NotOverridable Public ReadOnly Property CanWrite As Boolean _
Implements IStreamWrapper.CanWrite
[C#]
public bool CanWrite {get;}

Implements

IStreamWrapper.CanWrite

See Also

StreamWrapper Class | Aspose.Slides Namespace


Length Property

Aspose.Slides Documentation

StreamWrapper.Length Property

Gets the length in bytes of the stream.

[Visual Basic]
NotOverridable Public ReadOnly Property Length As Long _
Implements IStreamWrapper.Length
[C#]
public long Length {get;}

Implements

IStreamWrapper.Length

See Also

StreamWrapper Class | Aspose.Slides Namespace


Position Property

Aspose.Slides Documentation

StreamWrapper.Position Property

Gets or sets the position within the current stream.

[Visual Basic]
NotOverridable Public ReadOnly Property Position As Long _
Implements IStreamWrapper.Position
[C#]
public long Position {get;}

Implements

IStreamWrapper.Position

See Also

StreamWrapper Class | Aspose.Slides Namespace


Stream Property

Aspose.Slides Documentation

StreamWrapper.Stream Property

[Visual Basic]
NotOverridable Public ReadOnly Property Stream As Stream _
Implements IStreamWrapper.Stream
[C#]
public Stream Stream {get;}

Implements

IStreamWrapper.Stream

See Also

StreamWrapper Class | Aspose.Slides Namespace


StreamWrapper Methods

The methods of the StreamWrapper class are listed below. For a complete list of StreamWrapper class members, see the StreamWrapper Members topic.

Public Instance Methods

Close | Closes the current stream and releases any resources.
Dispose |
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
Read | Reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.
ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.
Seek | Sets the position within the current stream
Write | writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.
WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte.

See Also

StreamWrapper Class | Aspose.Slides Namespace


StreamWrapper.Close Method

Closes the current stream and releases any resources.

[Visual Basic]
NotOverridable Public Sub Close() _
Implements IStreamWrapper.Close
[C#]
public void Close();

Implements

IStreamWrapper.Close

See Also

StreamWrapper Class | Aspose.Slides Namespace


StreamWrapper.Dispose Method

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

StreamWrapper Class | Aspose.Slides Namespace


StreamWrapper.Flush Method

Clears all buffers for this stream and causes any buffered data to be written to the underlying device.

[Visual Basic]
NotOverridable Public Sub Flush() _
Implements IStreamWrapper.Flush
[C#]
public void Flush();

Implements

IStreamWrapper.Flush

See Also

StreamWrapper Class | Aspose.Slides Namespace


StreamWrapper.Read Method

Reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.

[Visual Basic]
NotOverridable Public Sub Read( _
ByVal buffer As Byte(), _
ByVal offset As Integer, _
ByVal count As Integer _
) _
Implements IStreamWrapper.Read
[C#]
public void Read(
byte[] buffer,
int offset,
int count
);

Implements

IStreamWrapper.Read

See Also

StreamWrapper Class | Aspose.Slides Namespace


StreamWrapper.ReadByte Method

Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.

[Visual Basic]
NotOverridable Public Function ReadByte() As Integer _
Implements IStreamWrapper.ReadByte
[C#]
public int ReadByte();

Return Value

Implements

IStreamWrapper.ReadByte

See Also

StreamWrapper Class | Aspose.Slides Namespace


StreamWrapper.Seek Method

Sets the position within the current stream

[Visual Basic]
NotOverridable Public Function Seek( _
ByVal offset As Long, _
ByVal origin As SeekOrigin _
) As Long _
Implements IStreamWrapper.Seek
[C#]
public long Seek(
long offset,
SeekOrigin origin
);

Implements

IStreamWrapper.Seek

See Also

StreamWrapper Class | Aspose.Slides Namespace


StreamWrapper.Write Method

writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.

[Visual Basic]
NotOverridable Public Sub Write( _
ByVal buffer As Byte(), _
ByVal offset As Integer, _
ByVal count As Integer _
) _
Implements IStreamWrapper.Write
[C#]
public void Write(
byte[] buffer,
int offset,
int count
);

Implements

IStreamWrapper.Write

See Also

StreamWrapper Class | Aspose.Slides Namespace


StreamWrapper.WriteByte Method

Writes a byte to the current position in the stream and advances the position within the stream by one byte.

[Visual Basic]
NotOverridable Public Sub WriteByte( _
ByVal value As Byte _
) _
Implements IStreamWrapper.WriteByte
[C#]
public void WriteByte(
byte value
);

Parameters

value

Implements

IStreamWrapper.WriteByte

See Also

StreamWrapper Class | Aspose.Slides Namespace


StreamWrapperFactory Class

Factory of StreamWrappers. For COM interface.

For a list of all members of this type, see StreamWrapperFactory Members.

System.Object
Aspose.Slides.StreamWrapperFactory

[Visual Basic]
Public Class StreamWrapperFactory
Implements IStreamWrapperFactory
[C#]
public class StreamWrapperFactory : IStreamWrapperFactory

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

StreamWrapperFactory Members | Aspose.Slides Namespace


StreamWrapperFactory Members

StreamWrapperFactory overview

Public Instance Constructors

StreamWrapperFactory Constructor Initializes a new instance of the StreamWrapperFactory class.

Public Instance Methods

CreateFileStreamWrapper | Overloaded. Creates FileStream with the specified path and creation mode.
CreateMemoryStreamWrapper | Overloaded. Creates MemoryStream wrapper.

See Also

StreamWrapperFactory Class | Aspose.Slides Namespace


StreamWrapperFactory Constructor

Initializes a new instance of the StreamWrapperFactory class.

[Visual Basic]
Public Sub New()
[C#]
public StreamWrapperFactory();

See Also

StreamWrapperFactory Class | Aspose.Slides Namespace


StreamWrapperFactory Methods

The methods of the StreamWrapperFactory class are listed below. For a complete list of StreamWrapperFactory class members, see the StreamWrapperFactory Members topic.

Public Instance Methods

CreateFileStreamWrapper | Overloaded. Creates FileStream with the specified path and creation mode.
CreateMemoryStreamWrapper | Overloaded. Creates MemoryStream wrapper.

See Also

StreamWrapperFactory Class | Aspose.Slides Namespace


CreateFileStreamWrapper Method

Aspose.Slides Documentation

StreamWrapperFactory.CreateFileStreamWrapper Method

Creates FileStream with the specified path and creation mode.

Overload List

Creates FileStream with the specified path and creation mode.

public IStreamWrapper CreateFileStreamWrapper(string,FileMode);

Creates FileStream with the specified path, creation mode, and read/write permission.

public IStreamWrapper CreateFileStreamWrapper(string,FileMode,FileAccess);

See Also

StreamWrapperFactory Class | Aspose.Slides Namespace


StreamWrapperFactory.CreateFileStreamWrapper Method (String, FileMode)

Creates FileStream with the specified path and creation mode.

[Visual Basic]
NotOverridable Overloads Public Function CreateFileStreamWrapper( _
ByVal fileName As String, _
ByVal fileMode As FileMode _
) As IStreamWrapper _
Implements IStreamWrapperFactory.CreateFileStreamWrapper
[C#]
public IStreamWrapper CreateFileStreamWrapper(
string fileName,
FileMode fileMode
);

Implements

IStreamWrapperFactory.CreateFileStreamWrapper

See Also

StreamWrapperFactory Class | Aspose.Slides Namespace | StreamWrapperFactory.CreateFileStreamWrapper Overload List


StreamWrapperFactory.CreateFileStreamWrapper Method (String, FileMode, FileAccess)

Creates FileStream with the specified path, creation mode, and read/write permission.

[Visual Basic]
NotOverridable Overloads Public Function CreateFileStreamWrapper( _
ByVal fileName As String, _
ByVal fileMode As FileMode, _
ByVal fileAccess As FileAccess _
) As IStreamWrapper _
Implements IStreamWrapperFactory.CreateFileStreamWrapper
[C#]
public IStreamWrapper CreateFileStreamWrapper(
string fileName,
FileMode fileMode,
FileAccess fileAccess
);

Implements

IStreamWrapperFactory.CreateFileStreamWrapper

See Also

StreamWrapperFactory Class | Aspose.Slides Namespace | StreamWrapperFactory.CreateFileStreamWrapper Overload List


CreateMemoryStreamWrapper Method

Aspose.Slides Documentation

StreamWrapperFactory.CreateMemoryStreamWrapper Method

Creates MemoryStream wrapper.

Overload List

Creates MemoryStream wrapper.

public IStreamWrapper CreateMemoryStreamWrapper();

Creates MemoryStream wrapper based on the specified byte array.

public IStreamWrapper CreateMemoryStreamWrapper(byte[]);

See Also

StreamWrapperFactory Class | Aspose.Slides Namespace


StreamWrapperFactory.CreateMemoryStreamWrapper Method ()

Creates MemoryStream wrapper.

[Visual Basic]
NotOverridable Overloads Public Function CreateMemoryStreamWrapper() As IStreamWrapper _
Implements IStreamWrapperFactory.CreateMemoryStreamWrapper
[C#]
public IStreamWrapper CreateMemoryStreamWrapper();

Implements

IStreamWrapperFactory.CreateMemoryStreamWrapper

See Also

StreamWrapperFactory Class | Aspose.Slides Namespace | StreamWrapperFactory.CreateMemoryStreamWrapper Overload List


StreamWrapperFactory.CreateMemoryStreamWrapper Method (Byte[])

Creates MemoryStream wrapper based on the specified byte array.

[Visual Basic]
NotOverridable Overloads Public Function CreateMemoryStreamWrapper( _
ByVal buffer As Byte() _
) As IStreamWrapper _
Implements IStreamWrapperFactory.CreateMemoryStreamWrapper
[C#]
public IStreamWrapper CreateMemoryStreamWrapper(
byte[] buffer
);

Implements

IStreamWrapperFactory.CreateMemoryStreamWrapper

See Also

StreamWrapperFactory Class | Aspose.Slides Namespace | StreamWrapperFactory.CreateMemoryStreamWrapper Overload List


SystemColor Enumeration

[Visual Basic]
Public Enum SystemColor
[C#]
public enum SystemColor

Members

Member Name | Description | Value
NotDefined |  | -1
ScrollBar |  | 0
Background |  | 1
ActiveCaption |  | 2
InactiveCaption |  | 3
Menu |  | 4
Window |  | 5
WindowFrame |  | 6
MenuText |  | 7
WindowText |  | 8
CaptionText |  | 9
ActiveBorder |  | 10
InactiveBorder |  | 11
AppWorkspace |  | 12
Highlight |  | 13
HighlightText |  | 14
BtnFace |  | 15
BtnShadow |  | 16
GrayText |  | 17
BtnText |  | 18
InactiveCaptionText |  | 19
BtnHighlight |  | 20
ThreeDDkShadow |  | 21
ThreeDLight |  | 22
InfoText |  | 23
InfoBk |  | 24
HotLight |  | 26
GradientActiveCaption |  | 27
GradientInactiveCaption |  | 28
MenuHighlight |  | 29
MenuBar |  | 30

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


Tab Class

Represents a tabulation for a text.

For a list of all members of this type, see Tab Members.

System.Object
Aspose.Slides.Tab

[Visual Basic]
NotInheritable Public Class Tab
Implements ITab, IComparable
[C#]
public sealed class Tab : ITab, IComparable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Tab Members | Aspose.Slides Namespace


Tab Members

Tab overview

Public Instance Constructors

Tab Constructor Initializes a new instance of the Tab class.

Public Instance Properties

Alignment | Returns or sets align style of a tab. Read/write TabAlignment.
Position | Returns or sets position of a tab. Assigning this property can change tab's index in collection and invalidate Enumerator. Read/write Double.

Public Instance Methods

CompareTo Compares the current instance with another object of the same type.

See Also

Tab Class | Aspose.Slides Namespace


Tab Constructor

Initializes a new instance of the Tab class.

[Visual Basic]
Public Sub New( _
ByVal position As Double, _
ByVal align As TabAlignment _
)
[C#]
public Tab(
double position,
TabAlignment align
);

Parameters

position
Position of the new tab.
align
Align style of the new tab.

See Also

Tab Class | Aspose.Slides Namespace


Tab Properties

The properties of the Tab class are listed below. For a complete list of Tab class members, see the Tab Members topic.

Public Instance Properties

Alignment | Returns or sets align style of a tab. Read/write TabAlignment.
Position | Returns or sets position of a tab. Assigning this property can change tab's index in collection and invalidate Enumerator. Read/write Double.

See Also

Tab Class | Aspose.Slides Namespace


Alignment Property

Aspose.Slides Documentation

Tab.Alignment Property

Returns or sets align style of a tab. Read/write TabAlignment.

[Visual Basic]
NotOverridable Public Property Alignment As TabAlignment _
Implements ITab.Alignment
[C#]
public TabAlignment Alignment {get; set;}

Implements

ITab.Alignment

See Also

Tab Class | Aspose.Slides Namespace


Position Property

Aspose.Slides Documentation

Tab.Position Property

Returns or sets position of a tab. Assigning this property can change tab's index in collection and invalidate Enumerator. Read/write Double.

[Visual Basic]
NotOverridable Public Property Position As Double _
Implements ITab.Position
[C#]
public double Position {get; set;}

Implements

ITab.Position

See Also

Tab Class | Aspose.Slides Namespace


Tab Methods

The methods of the Tab class are listed below. For a complete list of Tab class members, see the Tab Members topic.

Public Instance Methods

CompareTo Compares the current instance with another object of the same type.

See Also

Tab Class | Aspose.Slides Namespace


Tab.CompareTo Method

Compares the current instance with another object of the same type.

[Visual Basic]
NotOverridable Public Function CompareTo( _
ByVal obj As Object _
) As Integer _
Implements IComparable.CompareTo
[C#]
public int CompareTo(
object obj
);

Parameters

obj
An object to compare with this instance.

Return Value

A 32-bit integer that indicates the relative order of the comparands. The return value has these meanings:

  • < 0 - This instance is less than obj.
  • = 0 - This instance is equal to obj.
  • > 0 - This instance is greater than obj.

Implements

IComparable.CompareTo

See Also

Tab Class | Aspose.Slides Namespace


TabAlignment Enumeration

[Visual Basic]
Public Enum TabAlignment
[C#]
public enum TabAlignment

Members

Member Name | Description | Value
Left |  | 0
Center |  | 1
Right |  | 2
Decimal |  | 3

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


TabCollection Class

Represents a collection of tabs.

For a list of all members of this type, see TabCollection Members.

System.Object
Aspose.Slides.TabCollection

[Visual Basic]
NotInheritable Public Class TabCollection
Implements ITabCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ITab, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public sealed class TabCollection : ITabCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TabCollection Members | Aspose.Slides Namespace


TabCollection Members

TabCollection overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only Tab.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

Add | Overloaded. Adds a Tab to the collection.
Clear | Removes all elements from the collection.
CopyTo | Copies all elements from the collection to the specified array.
Equals | Determines whether two TabsEx instances are equal.
GetEnumerator | Returns an enumerator for the entire collection.
GetHashCode | Returns hash code for this object.
RemoveAt | Removes the element at the specified index of the collection.

See Also

TabCollection Class | Aspose.Slides Namespace


TabCollection Properties

The properties of the TabCollection class are listed below. For a complete list of TabCollection class members, see the TabCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only Tab.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

TabCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

TabCollection.Count Property

Gets the number of elements actually contained in the collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

TabCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

TabCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

TabCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

TabCollection.Item Property

Gets the element at the specified index. Read-only Tab.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ITabCollection.Item
As ITab _
Implements ITabCollection.Item
[C#]
public ITab this[
int index
] {get;}

Implements

ITabCollection.Item

See Also

TabCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

TabCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

TabCollection Class | Aspose.Slides Namespace


TabCollection Methods

The methods of the TabCollection class are listed below. For a complete list of TabCollection class members, see the TabCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a Tab to the collection.
Clear | Removes all elements from the collection.
CopyTo | Copies all elements from the collection to the specified array.
Equals | Determines whether two TabsEx instances are equal.
GetEnumerator | Returns an enumerator for the entire collection.
GetHashCode | Returns hash code for this object.
RemoveAt | Removes the element at the specified index of the collection.

See Also

TabCollection Class | Aspose.Slides Namespace


Add Method

Aspose.Slides Documentation

TabCollection.Add Method

Adds a Tab to the collection.

Overload List

Adds a Tab to the collection.

public int Add(ITab);

Adds a Tab to the collection.

public ITab Add(double,TabAlignment);

See Also

TabCollection Class | Aspose.Slides Namespace


TabCollection.Add Method (ITab)

Adds a Tab to the collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal value As ITab _
) As Integer _
Implements ITabCollection.Add
[C#]
public int Add(
ITab value
);

Parameters

value
The Tab object to be added at the end of the collection.

Return Value

The index at which the tab was added.

Implements

ITabCollection.Add

See Also

TabCollection Class | Aspose.Slides Namespace | TabCollection.Add Overload List


TabCollection.Add Method (Double, TabAlignment)

Adds a Tab to the collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal position As Double, _
ByVal align As TabAlignment _
) As ITab _
Implements ITabCollection.Add
[C#]
public ITab Add(
double position,
TabAlignment align
);

Return Value

Added tab.

Implements

ITabCollection.Add

See Also

TabCollection Class | Aspose.Slides Namespace | TabCollection.Add Overload List


TabCollection.Clear Method

Removes all elements from the collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements ITabCollection.Clear
[C#]
public void Clear();

Implements

ITabCollection.Clear

See Also

TabCollection Class | Aspose.Slides Namespace


TabCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

TabCollection Class | Aspose.Slides Namespace


TabCollection.Equals Method

Determines whether two TabsEx instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The TabsEx to compare with the current TabsEx.

Return Value

true if the specified TabsEx is equal to the current TabsEx; otherwise, false.

See Also

TabCollection Class | Aspose.Slides Namespace


TabCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

TabCollection Class | Aspose.Slides Namespace


TabCollection.GetHashCode Method

Returns hash code for this object.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

See Also

TabCollection Class | Aspose.Slides Namespace


TabCollection.RemoveAt Method

Removes the element at the specified index of the collection.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements ITabCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Implements

ITabCollection.RemoveAt

See Also

TabCollection Class | Aspose.Slides Namespace


TabEffectiveData Class

Immutable object which represents a text's tabulation stop.

For a list of all members of this type, see TabEffectiveData Members.

System.Object
Aspose.Slides.TabEffectiveData

[Visual Basic]
NotInheritable Public Class TabEffectiveData
Implements ITabEffectiveData, IComparable
[C#]
public sealed class TabEffectiveData : ITabEffectiveData, IComparable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TabEffectiveData Members | Aspose.Slides Namespace


TabEffectiveData Members

TabEffectiveData overview

Public Instance Properties

Alignment | Returns or sets align style of a tab. Readonly TabAlignment.
Position | Returns or sets position of a tab. Assigning this property can change tab's index in collection and invalidate Enumerator. Readonly Double.

Public Instance Methods

CompareTo Compares the current instance with another object of the same type.

See Also

TabEffectiveData Class | Aspose.Slides Namespace


TabEffectiveData Properties

The properties of the TabEffectiveData class are listed below. For a complete list of TabEffectiveData class members, see the TabEffectiveData Members topic.

Public Instance Properties

Alignment | Returns or sets align style of a tab. Readonly TabAlignment.
Position | Returns or sets position of a tab. Assigning this property can change tab's index in collection and invalidate Enumerator. Readonly Double.

See Also

TabEffectiveData Class | Aspose.Slides Namespace


Alignment Property

Aspose.Slides Documentation

TabEffectiveData.Alignment Property

Returns or sets align style of a tab. Readonly TabAlignment.

[Visual Basic]
NotOverridable Public ReadOnly Property Alignment As TabAlignment _
Implements ITabEffectiveData.Alignment
[C#]
public TabAlignment Alignment {get;}

Implements

ITabEffectiveData.Alignment

See Also

TabEffectiveData Class | Aspose.Slides Namespace


Position Property

Aspose.Slides Documentation

TabEffectiveData.Position Property

Returns or sets position of a tab. Assigning this property can change tab's index in collection and invalidate Enumerator. Readonly Double.

[Visual Basic]
NotOverridable Public ReadOnly Property Position As Double _
Implements ITabEffectiveData.Position
[C#]
public double Position {get;}

Implements

ITabEffectiveData.Position

See Also

TabEffectiveData Class | Aspose.Slides Namespace


TabEffectiveData Methods

The methods of the TabEffectiveData class are listed below. For a complete list of TabEffectiveData class members, see the TabEffectiveData Members topic.

Public Instance Methods

CompareTo Compares the current instance with another object of the same type.

See Also

TabEffectiveData Class | Aspose.Slides Namespace


TabEffectiveData.CompareTo Method

Compares the current instance with another object of the same type.

[Visual Basic]
NotOverridable Public Function CompareTo( _
ByVal obj As Object _
) As Integer _
Implements IComparable.CompareTo
[C#]
public int CompareTo(
object obj
);

Parameters

obj
An object to compare with this instance.

Return Value

A 32-bit integer that indicates the relative order of the comparands. The return value has these meanings:

  • < 0 - This instance is less than obj.
  • = 0 - This instance is equal to obj.
  • > 0 - This instance is greater than obj.

Implements

IComparable.CompareTo

See Also

TabEffectiveData Class | Aspose.Slides Namespace


TabFactory Class

Allowa to create ITab instances

For a list of all members of this type, see TabFactory Members.

System.Object
Aspose.Slides.TabFactory

[Visual Basic]
Public Class TabFactory
Implements ITabFactory
[C#]
public class TabFactory : ITabFactory

Remarks

For COM compatibility

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TabFactory Members | Aspose.Slides Namespace


TabFactory Members

TabFactory overview

Public Instance Constructors

TabFactory Constructor Initializes a new instance of the TabFactory class.

Public Instance Methods

CreateTab

See Also

TabFactory Class | Aspose.Slides Namespace


TabFactory Constructor

Initializes a new instance of the TabFactory class.

[Visual Basic]
Public Sub New()
[C#]
public TabFactory();

See Also

TabFactory Class | Aspose.Slides Namespace


TabFactory Methods

The methods of the TabFactory class are listed below. For a complete list of TabFactory class members, see the TabFactory Members topic.

Public Instance Methods

CreateTab

See Also

TabFactory Class | Aspose.Slides Namespace


TabFactory.CreateTab Method

[Visual Basic]
NotOverridable Public Function CreateTab( _
ByVal position As Double, _
ByVal align As TabAlignment _
) As ITab _
Implements ITabFactory.CreateTab
[C#]
public ITab CreateTab(
double position,
TabAlignment align
);

Implements

ITabFactory.CreateTab

See Also

TabFactory Class | Aspose.Slides Namespace


Table Class

Represents a table on a slide.

For a list of all members of this type, see Table Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GraphicalObject
Aspose.Slides.Table

[Visual Basic]
NotInheritable Public Class Table
Inherits GraphicalObject
Implements ITable
[C#]
public sealed class Table : GraphicalObject, ITable

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Table Members | Aspose.Slides Namespace


Table Members

Table overview

Public Instance Properties

AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
Columns | Returns the collectoin of columns. Read-only ColumnCollection.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
FirstCol | Determines whether the first column of a table has to be drawn with a special formatting. Read/write Boolean.
FirstRow | Determines whether the first row of a table has to be drawn with a special formatting. Read/write Boolean.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HorizontalBanding | Determines whether the even rows has to be drawn with a different formatting. Read/write Boolean.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
Item | Returns the cell at the specified column and row indexes. Read-only Cell.
LastCol | Determines whether the last column of a table has to be drawn with a special formatting. Read/write Boolean.
LastRow | Determines whether the last row of a table has to be drawn with a special formatting. Read/write Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
RightToLeft | Determines whether the table has right to left reading order. Read-write Boolean.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
Rows | Returns the collectoin of rows. Read-only RowCollection.
ShapeLock (inherited from GraphicalObject) | Returns shape's locks. Read-only GraphicalObjectLock.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
StylePreset | Get's or sets builtin table style. Read/write TableStylePreset.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
VerticalBanding | Determines whether the even columns has to be drawn with a different formatting. Read/write Boolean.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
MergeCells | Merges neighbour cells.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

Table Class | Aspose.Slides Namespace


Table Properties

The properties of the Table class are listed below. For a complete list of Table class members, see the Table Members topic.

Public Instance Properties

AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
Columns | Returns the collectoin of columns. Read-only ColumnCollection.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
FirstCol | Determines whether the first column of a table has to be drawn with a special formatting. Read/write Boolean.
FirstRow | Determines whether the first row of a table has to be drawn with a special formatting. Read/write Boolean.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HorizontalBanding | Determines whether the even rows has to be drawn with a different formatting. Read/write Boolean.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
Item | Returns the cell at the specified column and row indexes. Read-only Cell.
LastCol | Determines whether the last column of a table has to be drawn with a special formatting. Read/write Boolean.
LastRow | Determines whether the last row of a table has to be drawn with a special formatting. Read/write Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
RightToLeft | Determines whether the table has right to left reading order. Read-write Boolean.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
Rows | Returns the collectoin of rows. Read-only RowCollection.
ShapeLock (inherited from GraphicalObject) | Returns shape's locks. Read-only GraphicalObjectLock.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
StylePreset | Get's or sets builtin table style. Read/write TableStylePreset.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
VerticalBanding | Determines whether the even columns has to be drawn with a different formatting. Read/write Boolean.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

Table Class | Aspose.Slides Namespace


Columns Property

Aspose.Slides Documentation

Table.Columns Property

Returns the collectoin of columns. Read-only ColumnCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Columns As IColumnCollection _
Implements ITable.Columns
[C#]
public IColumnCollection Columns {get;}

Implements

ITable.Columns

See Also

Table Class | Aspose.Slides Namespace


FirstCol Property

Aspose.Slides Documentation

Table.FirstCol Property

Determines whether the first column of a table has to be drawn with a special formatting. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property FirstCol As Boolean _
Implements ITable.FirstCol
[C#]
public bool FirstCol {get; set;}

Implements

ITable.FirstCol

See Also

Table Class | Aspose.Slides Namespace


FirstRow Property

Aspose.Slides Documentation

Table.FirstRow Property

Determines whether the first row of a table has to be drawn with a special formatting. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property FirstRow As Boolean _
Implements ITable.FirstRow
[C#]
public bool FirstRow {get; set;}

Implements

ITable.FirstRow

See Also

Table Class | Aspose.Slides Namespace


HorizontalBanding Property

Aspose.Slides Documentation

Table.HorizontalBanding Property

Determines whether the even rows has to be drawn with a different formatting. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property HorizontalBanding As Boolean _
Implements ITable.HorizontalBanding
[C#]
public bool HorizontalBanding {get; set;}

Implements

ITable.HorizontalBanding

See Also

Table Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

Table.Item Property

Returns the cell at the specified column and row indexes. Read-only Cell.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal columnIndex As Integer, _
ByVal rowIndex As Integer _
) _
Implements ITable.Item
As ICell _
Implements ITable.Item
[C#]
public ICell this[
int columnIndex,
int rowIndex
] {get;}

Implements

ITable.Item

See Also

Table Class | Aspose.Slides Namespace


LastCol Property

Aspose.Slides Documentation

Table.LastCol Property

Determines whether the last column of a table has to be drawn with a special formatting. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property LastCol As Boolean _
Implements ITable.LastCol
[C#]
public bool LastCol {get; set;}

Implements

ITable.LastCol

See Also

Table Class | Aspose.Slides Namespace


LastRow Property

Aspose.Slides Documentation

Table.LastRow Property

Determines whether the last row of a table has to be drawn with a special formatting. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property LastRow As Boolean _
Implements ITable.LastRow
[C#]
public bool LastRow {get; set;}

Implements

ITable.LastRow

See Also

Table Class | Aspose.Slides Namespace


RightToLeft Property

Aspose.Slides Documentation

Table.RightToLeft Property

Determines whether the table has right to left reading order. Read-write Boolean.

[Visual Basic]
NotOverridable Public Property RightToLeft As Boolean _
Implements ITable.RightToLeft
[C#]
public bool RightToLeft {get; set;}

Implements

ITable.RightToLeft

See Also

Table Class | Aspose.Slides Namespace


Rows Property

Aspose.Slides Documentation

Table.Rows Property

Returns the collectoin of rows. Read-only RowCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Rows As IRowCollection _
Implements ITable.Rows
[C#]
public IRowCollection Rows {get;}

Implements

ITable.Rows

See Also

Table Class | Aspose.Slides Namespace


StylePreset Property

Aspose.Slides Documentation

Table.StylePreset Property

Get's or sets builtin table style. Read/write TableStylePreset.

[Visual Basic]
NotOverridable Public Property StylePreset As TableStylePreset _
Implements ITable.StylePreset
[C#]
public TableStylePreset StylePreset {get; set;}

Implements

ITable.StylePreset

See Also

Table Class | Aspose.Slides Namespace


VerticalBanding Property

Aspose.Slides Documentation

Table.VerticalBanding Property

Determines whether the even columns has to be drawn with a different formatting. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property VerticalBanding As Boolean _
Implements ITable.VerticalBanding
[C#]
public bool VerticalBanding {get; set;}

Implements

ITable.VerticalBanding

See Also

Table Class | Aspose.Slides Namespace


Table Methods

The methods of the Table class are listed below. For a complete list of Table class members, see the Table Members topic.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
MergeCells | Merges neighbour cells.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

Table Class | Aspose.Slides Namespace


Table.MergeCells Method

Merges neighbour cells.

[Visual Basic]
NotOverridable Public Function MergeCells( _
ByVal cell1 As ICell, _
ByVal cell2 As ICell, _
ByVal allowSplitting As Boolean _
) As ICell _
Implements ITable.MergeCells
[C#]
public ICell MergeCells(
ICell cell1,
ICell cell2,
bool allowSplitting
);

Parameters

cell1
Cell to merge.
cell2
Cell to merge.
allowSplitting
True to allow cells splitting.

Return Value

Merged cell.

Implements

ITable.MergeCells

See Also

Table Class | Aspose.Slides Namespace


TableStylePreset Enumeration

[Visual Basic]
Public Enum TableStylePreset
[C#]
public enum TableStylePreset

Members

Member Name | Description | Value
Custom |  | -1
None |  | 0
MediumStyle2Accent1 |  | 1
MediumStyle2 |  | 2
NoStyleNoGrid |  | 3
ThemedStyle1Accent1 |  | 4
ThemedStyle1Accent2 |  | 5
ThemedStyle1Accent3 |  | 6
ThemedStyle1Accent4 |  | 7
ThemedStyle1Accent5 |  | 8
ThemedStyle1Accent6 |  | 9
NoStyleTableGrid |  | 10
ThemedStyle2Accent1 |  | 11
ThemedStyle2Accent2 |  | 12
ThemedStyle2Accent3 |  | 13
ThemedStyle2Accent4 |  | 14
ThemedStyle2Accent5 |  | 15
ThemedStyle2Accent6 |  | 16
LightStyle1 |  | 17
LightStyle1Accent1 |  | 18
LightStyle1Accent2 |  | 19
LightStyle1Accent3 |  | 20
LightStyle1Accent4 |  | 21
LightStyle2Accent5 |  | 22
LightStyle1Accent6 |  | 23
LightStyle2 |  | 24
LightStyle2Accent1 |  | 25
LightStyle2Accent2 |  | 26
LightStyle2Accent3 |  | 27
MediumStyle2Accent3 |  | 28
MediumStyle2Accent4 |  | 29
MediumStyle2Accent5 |  | 30
LightStyle2Accent6 |  | 31
LightStyle2Accent4 |  | 32
LightStyle3 |  | 33
LightStyle3Accent1 |  | 34
MediumStyle2Accent2 |  | 35
LightStyle3Accent2 |  | 36
LightStyle3Accent3 |  | 37
LightStyle3Accent4 |  | 38
LightStyle3Accent5 |  | 39
LightStyle3Accent6 |  | 40
MediumStyle1 |  | 41
MediumStyle1Accent1 |  | 42
MediumStyle1Accent2 |  | 43
MediumStyle1Accent3 |  | 44
MediumStyle1Accent4 |  | 45
MediumStyle1Accent5 |  | 46
MediumStyle1Accent6 |  | 47
MediumStyle2Accent6 |  | 48
MediumStyle3 |  | 49
MediumStyle3Accent1 |  | 50
MediumStyle3Accent2 |  | 51
MediumStyle3Accent3 |  | 52
MediumStyle3Accent4 |  | 53
MediumStyle3Accent5 |  | 54
MediumStyle3Accent6 |  | 55
MediumStyle4 |  | 56
MediumStyle4Accent1 |  | 57
MediumStyle4Accent2 |  | 58
MediumStyle4Accent3 |  | 59
MediumStyle4Accent4 |  | 60
MediumStyle4Accent5 |  | 61
MediumStyle4Accent6 |  | 62
DarkStyle1 |  | 63
DarkStyle1Accent1 |  | 64
DarkStyle1Accent2 |  | 65
DarkStyle1Accent3 |  | 66
DarkStyle1Accent4 |  | 67
DarkStyle1Accent5 |  | 68
DarkStyle1Accent6 |  | 69
DarkStyle2 |  | 70
DarkStyle2Accent1Accent2 |  | 71
DarkStyle2Accent3Accent4 |  | 72
DarkStyle2Accent5Accent6 |  | 73

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


TagCollection Class

Represents the collection of tags (user defined pairs of strings)

For a list of all members of this type, see TagCollection Members.

System.Object
Aspose.Slides.TagCollection

[Visual Basic]
NotInheritable Public Class TagCollection
Implements ITagCollection, ICollection, IEnumerable, IEnumerable`1([System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089),[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)), mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089))
[C#]
public sealed class TagCollection : ITagCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TagCollection Members | Aspose.Slides Namespace


TagCollection Members

TagCollection overview

Public Instance Properties

Count | Returns a number of tags in the collectoin.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns or sets a key and a value pair of a tag.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

Add | Adds a new tag to collection.
Clear | Removes all tags from the collection.
Contains | Determines whether the collection contains a specific name.
CopyTo | Copies all elements from the collection into the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
GetNameByIndex | Returns key of a tag at the specified index.
GetNamesOfTags |
GetValueByIndex | Returns value of a tag at the specified index.
IndexOfName | Returns the zero-based index of the specified key in the collection.
Remove | Removes the tag with a specified name from the collection.
RemoveAt | Removes the tag at the specified index.

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection Properties

The properties of the TagCollection class are listed below. For a complete list of TagCollection class members, see the TagCollection Members topic.

Public Instance Properties

Count | Returns a number of tags in the collectoin.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns or sets a key and a value pair of a tag.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

TagCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

TagCollection.Count Property

Returns a number of tags in the collectoin.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

TagCollection Class | Aspose.Slides Namespace


IsSynchronized Property

Aspose.Slides Documentation

TagCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

TagCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

TagCollection.Item Property

Returns or sets a key and a value pair of a tag.

[Visual Basic]
NotOverridable Public Default Property Item( _
ByVal name As String _
) _
Implements ITagCollection.Item
As String _
Implements ITagCollection.Item
[C#]
public string this[
string name
] {get; set;}

Parameters

name
Key of a tag.

Implements

ITagCollection.Item

See Also

TagCollection Class | Aspose.Slides Namespace


SyncRoot Property

Aspose.Slides Documentation

TagCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection Methods

The methods of the TagCollection class are listed below. For a complete list of TagCollection class members, see the TagCollection Members topic.

Public Instance Methods

Add | Adds a new tag to collection.
Clear | Removes all tags from the collection.
Contains | Determines whether the collection contains a specific name.
CopyTo | Copies all elements from the collection into the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
GetNameByIndex | Returns key of a tag at the specified index.
GetNamesOfTags |
GetValueByIndex | Returns value of a tag at the specified index.
IndexOfName | Returns the zero-based index of the specified key in the collection.
Remove | Removes the tag with a specified name from the collection.
RemoveAt | Removes the tag at the specified index.

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection.Add Method

Adds a new tag to collection.

[Visual Basic]
NotOverridable Public Function Add( _
ByVal name As String, _
ByVal value As String _
) As Integer _
Implements ITagCollection.Add
[C#]
public int Add(
string name,
string value
);

Parameters

name
The name of the tag.
value
The value of the tag.

Return Value

The index of the added tag.

Implements

ITagCollection.Add

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection.Clear Method

Removes all tags from the collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements ITagCollection.Clear
[C#]
public void Clear();

Implements

ITagCollection.Clear

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection.Contains Method

Determines whether the collection contains a specific name.

[Visual Basic]
NotOverridable Public Function Contains( _
ByVal name As String _
) As Boolean _
Implements ITagCollection.Contains
[C#]
public bool Contains(
string name
);

Parameters

name
The key to locate.

Return Value

True if the collection contains an tag with the specified key; otherwise, false.

Implements

ITagCollection.Contains

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection.CopyTo Method

Copies all elements from the collection into the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Array to fill.
index
Starting position in target array.

Implements

ICollection.CopyTo

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection.GetNameByIndex Method

Returns key of a tag at the specified index.

[Visual Basic]
NotOverridable Public Function GetNameByIndex( _
ByVal index As Integer _
) As String _
Implements ITagCollection.GetNameByIndex
[C#]
public string GetNameByIndex(
int index
);

Parameters

index
Index of a tag to return.

Return Value

Key of a tag.

Implements

ITagCollection.GetNameByIndex

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection.GetNamesOfTags Method

[Visual Basic]
NotOverridable Public Function GetNamesOfTags() As String() _
Implements ITagCollection.GetNamesOfTags
[C#]
public string[] GetNamesOfTags();

Implements

ITagCollection.GetNamesOfTags

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection.GetValueByIndex Method

Returns value of a tag at the specified index.

[Visual Basic]
NotOverridable Public Function GetValueByIndex( _
ByVal index As Integer _
) As String _
Implements ITagCollection.GetValueByIndex
[C#]
public string GetValueByIndex(
int index
);

Parameters

index
Index of a tag to return.

Return Value

Value of a tag.

Implements

ITagCollection.GetValueByIndex

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection.IndexOfName Method

Returns the zero-based index of the specified key in the collection.

[Visual Basic]
NotOverridable Public Function IndexOfName( _
ByVal name As String _
) As Integer _
Implements ITagCollection.IndexOfName
[C#]
public int IndexOfName(
string name
);

Parameters

name
The name to locate in the collection.

Return Value

The zero-based index of key, if key is found in the collection; otherwise, -1.

Implements

ITagCollection.IndexOfName

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection.Remove Method

Removes the tag with a specified name from the collection.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal name As String _
) _
Implements ITagCollection.Remove
[C#]
public void Remove(
string name
);

Parameters

name
The name of tag to remove.

Implements

ITagCollection.Remove

See Also

TagCollection Class | Aspose.Slides Namespace


TagCollection.RemoveAt Method

Removes the tag at the specified index.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements ITagCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the tag to remove.

Implements

ITagCollection.RemoveAt

See Also

TagCollection Class | Aspose.Slides Namespace


TextAlignment Enumeration

[Visual Basic]
Public Enum TextAlignment
[C#]
public enum TextAlignment

Members

Member Name | Description | Value
NotDefined |  | -1
Left |  | 0
Center |  | 1
Right |  | 2
Justify |  | 3

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


TextAnchorType Enumeration

[Visual Basic]
Public Enum TextAnchorType
Inherits
[C#]
public enum TextAnchorType

Members

Member Name | Description | Value
NotDefined |  | -1
Top |  | 0
Center |  | 1
Bottom |  | 2
Justified |  | 3
Distributed |  | 4

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


TextAutofitType Enumeration

[Visual Basic]
Public Enum TextAutofitType
Inherits
[C#]
public enum TextAutofitType

Members

Member Name | Description | Value
NotDefined |  | -1
None |  | 0
Normal |  | 1
Shape |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


TextCapType Enumeration

[Visual Basic]
Public Enum TextCapType
Inherits
[C#]
public enum TextCapType

Members

Member Name | Description | Value
NotDefined |  | -1
None |  | 0
Small |  | 1
All |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


TextFrame Class

Represents a TextFrame.

For a list of all members of this type, see TextFrame Members.

System.Object
Aspose.Slides.TextFrame

[Visual Basic]
NotInheritable Public Class TextFrame
Implements ITextFrame, ISlideComponent, IPresentationComponent
[C#]
public sealed class TextFrame : ITextFrame, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TextFrame Members | Aspose.Slides Namespace


TextFrame Members

TextFrame overview

Public Instance Properties

HyperlinkQueries | Provides easy access to contained hyperlinks.
Paragraphs | Returns the list of all paragraphs in a frame. Read-only ParagraphCollection.
Presentation | Returns the parent presentation of a TextFrame. Read-only Presentation.
Slide | Returns the parent slide of a TextFrame. Read-only BaseSlide.
Text | Gets or sets the plain text for a TextFrame.
TextFrameFormat | Returns the formatting object for this TextFrame object. Readonly ITextFrameFormat.

See Also

TextFrame Class | Aspose.Slides Namespace


TextFrame Properties

The properties of the TextFrame class are listed below. For a complete list of TextFrame class members, see the TextFrame Members topic.

Public Instance Properties

HyperlinkQueries | Provides easy access to contained hyperlinks.
Paragraphs | Returns the list of all paragraphs in a frame. Read-only ParagraphCollection.
Presentation | Returns the parent presentation of a TextFrame. Read-only Presentation.
Slide | Returns the parent slide of a TextFrame. Read-only BaseSlide.
Text | Gets or sets the plain text for a TextFrame.
TextFrameFormat | Returns the formatting object for this TextFrame object. Readonly ITextFrameFormat.

See Also

TextFrame Class | Aspose.Slides Namespace


HyperlinkQueries Property

Aspose.Slides Documentation

TextFrame.HyperlinkQueries Property

Provides easy access to contained hyperlinks.

[Visual Basic]
NotOverridable Public ReadOnly Property HyperlinkQueries As IHyperlinkQueries _
Implements ITextFrame.HyperlinkQueries
[C#]
public IHyperlinkQueries HyperlinkQueries {get;}

Implements

ITextFrame.HyperlinkQueries

See Also

TextFrame Class | Aspose.Slides Namespace


Paragraphs Property

Aspose.Slides Documentation

TextFrame.Paragraphs Property

Returns the list of all paragraphs in a frame. Read-only ParagraphCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Paragraphs As IParagraphCollection _
Implements ITextFrame.Paragraphs
[C#]
public IParagraphCollection Paragraphs {get;}

Implements

ITextFrame.Paragraphs

See Also

TextFrame Class | Aspose.Slides Namespace


Presentation Property

Aspose.Slides Documentation

TextFrame.Presentation Property

Returns the parent presentation of a TextFrame. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

TextFrame Class | Aspose.Slides Namespace


Slide Property

Aspose.Slides Documentation

TextFrame.Slide Property

Returns the parent slide of a TextFrame. Read-only BaseSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As IBaseSlide _
Implements ISlideComponent.Slide
[C#]
public IBaseSlide Slide {get;}

Implements

ISlideComponent.Slide

See Also

TextFrame Class | Aspose.Slides Namespace


Text Property

Aspose.Slides Documentation

TextFrame.Text Property

Gets or sets the plain text for a TextFrame.

[Visual Basic]
NotOverridable Public Property Text As String _
Implements ITextFrame.Text
[C#]
public string Text {get; set;}

Property Value

The text.

Implements

ITextFrame.Text

See Also

TextFrame Class | Aspose.Slides Namespace


TextFrameFormat Property

Aspose.Slides Documentation

TextFrame.TextFrameFormat Property

Returns the formatting object for this TextFrame object. Readonly ITextFrameFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property TextFrameFormat As ITextFrameFormat _
Implements ITextFrame.TextFrameFormat
[C#]
public ITextFrameFormat TextFrameFormat {get;}

Implements

ITextFrame.TextFrameFormat

See Also

TextFrame Class | Aspose.Slides Namespace


TextFrameFormat Class

Contains the TextFrame's formatting properties.

For a list of all members of this type, see TextFrameFormat Members.

System.Object
Aspose.Slides.TextFrameFormat

[Visual Basic]
NotInheritable Public Class TextFrameFormat
Implements ITextFrameFormat, ISlideComponent, IPresentationComponent, IChartTextBlockFormat
[C#]
public sealed class TextFrameFormat : ITextFrameFormat, ISlideComponent, IPresentationComponent, IChartTextBlockFormat

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TextFrameFormat Members | Aspose.Slides Namespace


TextFrameFormat Members

TextFrameFormat overview

Public Instance Properties

AnchoringType | Returns or sets vertical anchor text in a TextFrame. Read/write TextAnchorType.
CenterText | If NullableBool.True then text should be centered in box horizontally. Read/write NullableBool.
Presentation | Returns the parent presentation of a TextFrame. Read-only Presentation.
Slide | Returns the parent slide of a TextFrame. Read-only BaseSlide.
TextVerticalType | Determines text orientation. Read/write TextVerticalType.

See Also

TextFrameFormat Class | Aspose.Slides Namespace


TextFrameFormat Properties

The properties of the TextFrameFormat class are listed below. For a complete list of TextFrameFormat class members, see the TextFrameFormat Members topic.

Public Instance Properties

AnchoringType | Returns or sets vertical anchor text in a TextFrame. Read/write TextAnchorType.
CenterText | If NullableBool.True then text should be centered in box horizontally. Read/write NullableBool.
Presentation | Returns the parent presentation of a TextFrame. Read-only Presentation.
Slide | Returns the parent slide of a TextFrame. Read-only BaseSlide.
TextVerticalType | Determines text orientation. Read/write TextVerticalType.

See Also

TextFrameFormat Class | Aspose.Slides Namespace


AnchoringType Property

Aspose.Slides Documentation

TextFrameFormat.AnchoringType Property

Returns or sets vertical anchor text in a TextFrame. Read/write TextAnchorType.

[Visual Basic]
NotOverridable Public Property AnchoringType As TextAnchorType _
Implements IChartTextBlockFormat.AnchoringType
[C#]
public TextAnchorType AnchoringType {get; set;}

Implements

IChartTextBlockFormat.AnchoringType

See Also

TextFrameFormat Class | Aspose.Slides Namespace


CenterText Property

Aspose.Slides Documentation

TextFrameFormat.CenterText Property

If NullableBool.True then text should be centered in box horizontally. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property CenterText As NullableBool _
Implements IChartTextBlockFormat.CenterText
[C#]
public NullableBool CenterText {get; set;}

Implements

IChartTextBlockFormat.CenterText

See Also

TextFrameFormat Class | Aspose.Slides Namespace


Presentation Property

Aspose.Slides Documentation

TextFrameFormat.Presentation Property

Returns the parent presentation of a TextFrame. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

TextFrameFormat Class | Aspose.Slides Namespace


Slide Property

Aspose.Slides Documentation

TextFrameFormat.Slide Property

Returns the parent slide of a TextFrame. Read-only BaseSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As IBaseSlide _
Implements ISlideComponent.Slide
[C#]
public IBaseSlide Slide {get;}

Implements

ISlideComponent.Slide

See Also

TextFrameFormat Class | Aspose.Slides Namespace


TextVerticalType Property

Aspose.Slides Documentation

TextFrameFormat.TextVerticalType Property

Determines text orientation. Read/write TextVerticalType.

[Visual Basic]
NotOverridable Public Property TextVerticalType As TextVerticalType _
Implements IChartTextBlockFormat.TextVerticalType
[C#]
public TextVerticalType TextVerticalType {get; set;}

Implements

IChartTextBlockFormat.TextVerticalType

See Also

TextFrameFormat Class | Aspose.Slides Namespace


TextShapeType Enumeration

[Visual Basic]
Public Enum TextShapeType
Inherits
[C#]
public enum TextShapeType

Members

Member Name | Description | Value
NotDefined |  | -1
None |  | 0
Plain |  | 1
Stop |  | 2
Triangle |  | 3
TriangleInverted |  | 4
Chevron |  | 5
ChevronInverted |  | 6
RingInside |  | 7
RingOutside |  | 8
ArchUp |  | 9
ArchDown |  | 10
Circle |  | 11
Button |  | 12
ArchUpPour |  | 13
ArchDownPour |  | 14
CirclePour |  | 15
ButtonPour |  | 16
CurveUp |  | 17
CurveDown |  | 18
CanUp |  | 19
CanDown |  | 20
Wave1 |  | 21
Wave2 |  | 22
DoubleWave1 |  | 23
Wave4 |  | 24
Inflate |  | 25
Deflate |  | 26
InflateBottom |  | 27
DeflateBottom |  | 28
InflateTop |  | 29
DeflateTop |  | 30
DeflateInflate |  | 31
DeflateInflateDeflate |  | 32
FadeRight |  | 33
FadeLeft |  | 34
FadeUp |  | 35
FadeDown |  | 36
SlantUp |  | 37
SlantDown |  | 38
CascadeUp |  | 39
CascadeDown |  | 40
Custom |  | 41

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


TextStrikethroughType Enumeration

[Visual Basic]
Public Enum TextStrikethroughType
Inherits
[C#]
public enum TextStrikethroughType

Members

Member Name | Description | Value
NotDefined |  | -1
None |  | 0
Single |  | 1
Double |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


TextStyle Class

Summary description for TextStyle.

For a list of all members of this type, see TextStyle Members.

System.Object
Aspose.Slides.TextStyle

[Visual Basic]
Public Class TextStyle
Implements ITextStyle, ISlideComponent, IPresentationComponent
[C#]
public class TextStyle : ITextStyle, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TextStyle Members | Aspose.Slides Namespace


TextStyle Members

TextStyle overview

Public Instance Fields

MaxLevelCount Maximum count of style levels that can be defined. Use it with GetLevel(int index)

Public Instance Properties

DefaultParagraphFormat Default paragraph propertiies.

Public Instance Methods

GetLevel If level of style exist returns it, otherwise returns null.

See Also

TextStyle Class | Aspose.Slides Namespace


TextStyle Fields

The fields of the TextStyle class are listed below. For a complete list of TextStyle class members, see the TextStyle Members topic.

Public Instance Fields

MaxLevelCount Maximum count of style levels that can be defined. Use it with GetLevel(int index)

See Also

TextStyle Class | Aspose.Slides Namespace


TextStyle.MaxLevelCount Field

Maximum count of style levels that can be defined. Use it with GetLevel(int index)

[Visual Basic]
Public ReadOnly MaxLevelCount As Byte
[C#]
public readonly byte MaxLevelCount;

Example

See Also
TextStyle Class | Aspose.Slides Namespace


TextStyle Properties

The properties of the TextStyle class are listed below. For a complete list of TextStyle class members, see the TextStyle Members topic.

Public Instance Properties

DefaultParagraphFormat Default paragraph propertiies.

See Also

TextStyle Class | Aspose.Slides Namespace


DefaultParagraphFormat Property

Aspose.Slides Documentation

TextStyle.DefaultParagraphFormat Property

Default paragraph propertiies.

[Visual Basic]
NotOverridable Public ReadOnly Property DefaultParagraphFormat As IParagraphFormat _
Implements ITextStyle.DefaultParagraphFormat
[C#]
public IParagraphFormat DefaultParagraphFormat {get;}

Implements

ITextStyle.DefaultParagraphFormat

See Also

TextStyle Class | Aspose.Slides Namespace


TextStyle Methods

The methods of the TextStyle class are listed below. For a complete list of TextStyle class members, see the TextStyle Members topic.

Public Instance Methods

GetLevel If level of style exist returns it, otherwise returns null.

See Also

TextStyle Class | Aspose.Slides Namespace


TextStyle.GetLevel Method

If level of style exist returns it, otherwise returns null.

[Visual Basic]
NotOverridable Public Function GetLevel( _
ByVal index As Integer _
) As IParagraphFormat _
Implements ITextStyle.GetLevel
[C#]
public IParagraphFormat GetLevel(
int index
);

Parameters

index
Zero-based index of level. Must lay in 0..8 interval.

Return Value

Formatting of level ParagraphFormat.

Implements

ITextStyle.GetLevel

See Also

TextStyle Class | Aspose.Slides Namespace


TextUnderlineType Enumeration

[Visual Basic]
Public Enum TextUnderlineType
Inherits
[C#]
public enum TextUnderlineType

Members

Member Name | Description | Value
NotDefined |  | -1
None |  | 0
Words |  | 1
Single |  | 2
Double |  | 3
Heavy |  | 4
Dotted |  | 5
HeavyDotted |  | 6
Dashed |  | 7
HeavyDashed |  | 8
LongDashed |  | 9
HeavyLongDashed |  | 10
DotDash |  | 11
HeavyDotDash |  | 12
DotDotDash |  | 13
HeavyDotDotDash |  | 14
Wavy |  | 15
HeavyWavy |  | 16
DoubleWavy |  | 17

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


TextVerticalOverflowType Enumeration

[Visual Basic]
Public Enum TextVerticalOverflowType
Inherits
[C#]
public enum TextVerticalOverflowType

Members

Member Name | Description | Value
NotDefined |  | -1
Overflow |  | 0
Ellipsis |  | 1
Clip |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


TextVerticalType Enumeration

[Visual Basic]
Public Enum TextVerticalType
Inherits
[C#]
public enum TextVerticalType

Members

Member Name | Description | Value
NotDefined |  | -1
Horizontal |  | 0
Vertical |  | 1
Vertical270 |  | 2
WordArtVertical |  | 3
EastAsianVertical |  | 4
MongolianVertical |  | 5
WordArtVerticalRightToLeft |  | 6

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


ThreeDFormat Class

Represents 3-D properties.

For a list of all members of this type, see ThreeDFormat Members.

System.Object
Aspose.Slides.ThreeDFormat

[Visual Basic]
Public Class ThreeDFormat
Implements IThreeDFormat, ISlideComponent, IPresentationComponent
[C#]
public class ThreeDFormat : IThreeDFormat, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ThreeDFormat Members | Aspose.Slides Namespace


ThreeDFormat Members

ThreeDFormat overview

Public Instance Properties

BevelBottom | Returns or sets the type of a bottom 3D bevel. Read ShapeBevel.
BevelTop | Returns or sets the type of a top 3D bevel. Read ShapeBevel,
Camera | Returns or sets the settings of a camera. Read/write Camera.
ContourColor | Returns or sets the color of a contour. Read/write ColorFormat.
ContourWidth | Returns or sets the width of a 3D contour. Read/write Double.
Depth | Returns or sets the depth of a 3D shape. Read/write Double.
ExtrusionColor | Returns or sets the color of an extrusion. Read/write ColorFormat
ExtrusionHeight | Returns or sets the height of an extrusion effect. Read/write Double.
LightRig | Returns or sets the type of a light. Read/write LightRig.
Material | Returns or sets the type of a material. Read/write MaterialPresetType.

Public Instance Methods

Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

ThreeDFormat Class | Aspose.Slides Namespace


ThreeDFormat Properties

The properties of the ThreeDFormat class are listed below. For a complete list of ThreeDFormat class members, see the ThreeDFormat Members topic.

Public Instance Properties

BevelBottom | Returns or sets the type of a bottom 3D bevel. Read ShapeBevel.
BevelTop | Returns or sets the type of a top 3D bevel. Read ShapeBevel,
Camera | Returns or sets the settings of a camera. Read/write Camera.
ContourColor | Returns or sets the color of a contour. Read/write ColorFormat.
ContourWidth | Returns or sets the width of a 3D contour. Read/write Double.
Depth | Returns or sets the depth of a 3D shape. Read/write Double.
ExtrusionColor | Returns or sets the color of an extrusion. Read/write ColorFormat
ExtrusionHeight | Returns or sets the height of an extrusion effect. Read/write Double.
LightRig | Returns or sets the type of a light. Read/write LightRig.
Material | Returns or sets the type of a material. Read/write MaterialPresetType.

See Also

ThreeDFormat Class | Aspose.Slides Namespace


BevelBottom Property

Aspose.Slides Documentation

ThreeDFormat.BevelBottom Property

Returns or sets the type of a bottom 3D bevel. Read ShapeBevel.

[Visual Basic]
NotOverridable Public ReadOnly Property BevelBottom As IShapeBevel _
Implements IThreeDFormat.BevelBottom
[C#]
public IShapeBevel BevelBottom {get;}

Implements

IThreeDFormat.BevelBottom

See Also

ThreeDFormat Class | Aspose.Slides Namespace


BevelTop Property

Aspose.Slides Documentation

ThreeDFormat.BevelTop Property

Returns or sets the type of a top 3D bevel. Read ShapeBevel,

[Visual Basic]
NotOverridable Public ReadOnly Property BevelTop As IShapeBevel _
Implements IThreeDFormat.BevelTop
[C#]
public IShapeBevel BevelTop {get;}

Implements

IThreeDFormat.BevelTop

See Also

ThreeDFormat Class | Aspose.Slides Namespace


Camera Property

Aspose.Slides Documentation

ThreeDFormat.Camera Property

Returns or sets the settings of a camera. Read/write Camera.

[Visual Basic]
NotOverridable Public Property Camera As ICamera _
Implements IThreeDFormat.Camera
[C#]
public ICamera Camera {get; set;}

Implements

IThreeDFormat.Camera

See Also

ThreeDFormat Class | Aspose.Slides Namespace


ContourColor Property

Aspose.Slides Documentation

ThreeDFormat.ContourColor Property

Returns or sets the color of a contour. Read/write ColorFormat.

[Visual Basic]
NotOverridable Public Property ContourColor As IColorFormat _
Implements IThreeDFormat.ContourColor
[C#]
public IColorFormat ContourColor {get; set;}

Implements

IThreeDFormat.ContourColor

See Also

ThreeDFormat Class | Aspose.Slides Namespace


ContourWidth Property

Aspose.Slides Documentation

ThreeDFormat.ContourWidth Property

Returns or sets the width of a 3D contour. Read/write Double.

[Visual Basic]
NotOverridable Public Property ContourWidth As Double _
Implements IThreeDFormat.ContourWidth
[C#]
public double ContourWidth {get; set;}

Implements

IThreeDFormat.ContourWidth

See Also

ThreeDFormat Class | Aspose.Slides Namespace


Depth Property

Aspose.Slides Documentation

ThreeDFormat.Depth Property

Returns or sets the depth of a 3D shape. Read/write Double.

[Visual Basic]
NotOverridable Public Property Depth As Double _
Implements IThreeDFormat.Depth
[C#]
public double Depth {get; set;}

Implements

IThreeDFormat.Depth

See Also

ThreeDFormat Class | Aspose.Slides Namespace


ExtrusionColor Property

Aspose.Slides Documentation

ThreeDFormat.ExtrusionColor Property

Returns or sets the color of an extrusion. Read/write ColorFormat

[Visual Basic]
NotOverridable Public Property ExtrusionColor As IColorFormat _
Implements IThreeDFormat.ExtrusionColor
[C#]
public IColorFormat ExtrusionColor {get; set;}

Implements

IThreeDFormat.ExtrusionColor

See Also

ThreeDFormat Class | Aspose.Slides Namespace


ExtrusionHeight Property

Aspose.Slides Documentation

ThreeDFormat.ExtrusionHeight Property

Returns or sets the height of an extrusion effect. Read/write Double.

[Visual Basic]
NotOverridable Public Property ExtrusionHeight As Double _
Implements IThreeDFormat.ExtrusionHeight
[C#]
public double ExtrusionHeight {get; set;}

Implements

IThreeDFormat.ExtrusionHeight

See Also

ThreeDFormat Class | Aspose.Slides Namespace


LightRig Property

Aspose.Slides Documentation

ThreeDFormat.LightRig Property

Returns or sets the type of a light. Read/write LightRig.

[Visual Basic]
NotOverridable Public Property LightRig As ILightRig _
Implements IThreeDFormat.LightRig
[C#]
public ILightRig LightRig {get; set;}

Implements

IThreeDFormat.LightRig

See Also

ThreeDFormat Class | Aspose.Slides Namespace


Material Property

Aspose.Slides Documentation

ThreeDFormat.Material Property

Returns or sets the type of a material. Read/write MaterialPresetType.

[Visual Basic]
NotOverridable Public Property Material As MaterialPresetType _
Implements IThreeDFormat.Material
[C#]
public MaterialPresetType Material {get; set;}

Implements

IThreeDFormat.Material

See Also

ThreeDFormat Class | Aspose.Slides Namespace


ThreeDFormat Methods

The methods of the ThreeDFormat class are listed below. For a complete list of ThreeDFormat class members, see the ThreeDFormat Members topic.

Public Instance Methods

Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

ThreeDFormat Class | Aspose.Slides Namespace


ThreeDFormat.Equals Method

Determines whether two FillFormat instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

See Also

ThreeDFormat Class | Aspose.Slides Namespace


ThreeDFormat.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Remarks

Overriden to make compiler happy.

See Also

ThreeDFormat Class | Aspose.Slides Namespace


ThreeDFormatEffectiveData Class

Immutable object which represents 3-D properties.

For a list of all members of this type, see ThreeDFormatEffectiveData Members.

System.Object
Aspose.Slides.ThreeDFormatEffectiveData

[Visual Basic]
Public Class ThreeDFormatEffectiveData
Implements IThreeDFormatEffectiveData
[C#]
public class ThreeDFormatEffectiveData : IThreeDFormatEffectiveData

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ThreeDFormatEffectiveData Members | Aspose.Slides Namespace


ThreeDFormatEffectiveData Members

ThreeDFormatEffectiveData overview

Public Instance Properties

BevelBottom | Returns the type of a bottom 3D bevel. Read-only ShapeBevel.
BevelColorMode | Returns the color mode used for 3D effects. Read-only BevelColorMode.
BevelTop | Returns the type of a top 3D bevel. Read-only ShapeBevel,
Camera | Returns the settings of a camera. Read-only Camera.
ContourColor | Returns the color of a contour. Read-only Color.
ContourWidth | Returns the width of a 3D contour. Read-only Double.
Depth | Returns the depth of a 3D shape. Read-only Double.
ExtrusionColor | Returns the color of an extrusion. Read-only Color
ExtrusionHeight | Returns the height of an extrusion effect. Read-only Double.
LightRig | Returns the type of a light. Read-only LightRig.
Material | Returns the type of a material. Read-only MaterialPresetType.

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


ThreeDFormatEffectiveData Properties

The properties of the ThreeDFormatEffectiveData class are listed below. For a complete list of ThreeDFormatEffectiveData class members, see the ThreeDFormatEffectiveData Members topic.

Public Instance Properties

BevelBottom | Returns the type of a bottom 3D bevel. Read-only ShapeBevel.
BevelColorMode | Returns the color mode used for 3D effects. Read-only BevelColorMode.
BevelTop | Returns the type of a top 3D bevel. Read-only ShapeBevel,
Camera | Returns the settings of a camera. Read-only Camera.
ContourColor | Returns the color of a contour. Read-only Color.
ContourWidth | Returns the width of a 3D contour. Read-only Double.
Depth | Returns the depth of a 3D shape. Read-only Double.
ExtrusionColor | Returns the color of an extrusion. Read-only Color
ExtrusionHeight | Returns the height of an extrusion effect. Read-only Double.
LightRig | Returns the type of a light. Read-only LightRig.
Material | Returns the type of a material. Read-only MaterialPresetType.

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


BevelBottom Property

Aspose.Slides Documentation

ThreeDFormatEffectiveData.BevelBottom Property

Returns the type of a bottom 3D bevel. Read-only ShapeBevel.

[Visual Basic]
NotOverridable Public ReadOnly Property BevelBottom As IShapeBevelEffectiveData _
Implements IThreeDFormatEffectiveData.BevelBottom
[C#]
public IShapeBevelEffectiveData BevelBottom {get;}

Implements

IThreeDFormatEffectiveData.BevelBottom

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


BevelColorMode Property

Aspose.Slides Documentation

ThreeDFormatEffectiveData.BevelColorMode Property

Returns the color mode used for 3D effects. Read-only BevelColorMode.

[Visual Basic]
Public ReadOnly Property BevelColorMode As BevelColorMode
[C#]
public BevelColorMode BevelColorMode {get;}

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


BevelTop Property

Aspose.Slides Documentation

ThreeDFormatEffectiveData.BevelTop Property

Returns the type of a top 3D bevel. Read-only ShapeBevel,

[Visual Basic]
NotOverridable Public ReadOnly Property BevelTop As IShapeBevelEffectiveData _
Implements IThreeDFormatEffectiveData.BevelTop
[C#]
public IShapeBevelEffectiveData BevelTop {get;}

Implements

IThreeDFormatEffectiveData.BevelTop

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


Camera Property

Aspose.Slides Documentation

ThreeDFormatEffectiveData.Camera Property

Returns the settings of a camera. Read-only Camera.

[Visual Basic]
NotOverridable Public ReadOnly Property Camera As ICameraEffectiveData _
Implements IThreeDFormatEffectiveData.Camera
[C#]
public ICameraEffectiveData Camera {get;}

Implements

IThreeDFormatEffectiveData.Camera

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


ContourColor Property

Aspose.Slides Documentation

ThreeDFormatEffectiveData.ContourColor Property

Returns the color of a contour. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property ContourColor As Color _
Implements IThreeDFormatEffectiveData.ContourColor
[C#]
public Color ContourColor {get;}

Implements

IThreeDFormatEffectiveData.ContourColor

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


ContourWidth Property

Aspose.Slides Documentation

ThreeDFormatEffectiveData.ContourWidth Property

Returns the width of a 3D contour. Read-only Double.

[Visual Basic]
NotOverridable Public ReadOnly Property ContourWidth As Double _
Implements IThreeDFormatEffectiveData.ContourWidth
[C#]
public double ContourWidth {get;}

Implements

IThreeDFormatEffectiveData.ContourWidth

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


Depth Property

Aspose.Slides Documentation

ThreeDFormatEffectiveData.Depth Property

Returns the depth of a 3D shape. Read-only Double.

[Visual Basic]
NotOverridable Public ReadOnly Property Depth As Double _
Implements IThreeDFormatEffectiveData.Depth
[C#]
public double Depth {get;}

Implements

IThreeDFormatEffectiveData.Depth

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


ExtrusionColor Property

Aspose.Slides Documentation

ThreeDFormatEffectiveData.ExtrusionColor Property

Returns the color of an extrusion. Read-only Color

[Visual Basic]
NotOverridable Public ReadOnly Property ExtrusionColor As Color _
Implements IThreeDFormatEffectiveData.ExtrusionColor
[C#]
public Color ExtrusionColor {get;}

Implements

IThreeDFormatEffectiveData.ExtrusionColor

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


ExtrusionHeight Property

Aspose.Slides Documentation

ThreeDFormatEffectiveData.ExtrusionHeight Property

Returns the height of an extrusion effect. Read-only Double.

[Visual Basic]
NotOverridable Public ReadOnly Property ExtrusionHeight As Double _
Implements IThreeDFormatEffectiveData.ExtrusionHeight
[C#]
public double ExtrusionHeight {get;}

Implements

IThreeDFormatEffectiveData.ExtrusionHeight

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


LightRig Property

Aspose.Slides Documentation

ThreeDFormatEffectiveData.LightRig Property

Returns the type of a light. Read-only LightRig.

[Visual Basic]
NotOverridable Public ReadOnly Property LightRig As ILightRigEffectiveData _
Implements IThreeDFormatEffectiveData.LightRig
[C#]
public ILightRigEffectiveData LightRig {get;}

Implements

IThreeDFormatEffectiveData.LightRig

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


Material Property

Aspose.Slides Documentation

ThreeDFormatEffectiveData.Material Property

Returns the type of a material. Read-only MaterialPresetType.

[Visual Basic]
NotOverridable Public ReadOnly Property Material As MaterialPresetType _
Implements IThreeDFormatEffectiveData.Material
[C#]
public MaterialPresetType Material {get;}

Implements

IThreeDFormatEffectiveData.Material

See Also

ThreeDFormatEffectiveData Class | Aspose.Slides Namespace


TileFlip Enumeration

[Visual Basic]
Public Enum TileFlip
[C#]
public enum TileFlip

Members

Member Name | Description | Value
NotDefined |  | -1
NoFlip |  | 0
FlipX |  | 1
FlipY |  | 2
FlipBoth |  | 3

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


Video Class

Represents an image embedded into a presentation.

For a list of all members of this type, see Video Members.

System.Object
Aspose.Slides.Video

[Visual Basic]
Public Class Video
Implements IVideo
[C#]
public class Video : IVideo

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Video Members | Aspose.Slides Namespace


Video Members

Video overview

Public Instance Properties

BinaryData | Returns the copy of an audio's data. Read-only Byte[].
ContentType | Returns a MIME type of an video, encoded in BinaryData. Read-only String.

See Also

Video Class | Aspose.Slides Namespace


Video Properties

The properties of the Video class are listed below. For a complete list of Video class members, see the Video Members topic.

Public Instance Properties

BinaryData | Returns the copy of an audio's data. Read-only Byte[].
ContentType | Returns a MIME type of an video, encoded in BinaryData. Read-only String.

See Also

Video Class | Aspose.Slides Namespace


BinaryData Property

Aspose.Slides Documentation

Video.BinaryData Property

Returns the copy of an audio's data. Read-only Byte[].

[Visual Basic]
NotOverridable Public ReadOnly Property BinaryData As Byte() _
Implements IVideo.BinaryData
[C#]
public byte[] BinaryData {get;}

Implements

IVideo.BinaryData

See Also

Video Class | Aspose.Slides Namespace


ContentType Property

Aspose.Slides Documentation

Video.ContentType Property

Returns a MIME type of an video, encoded in BinaryData. Read-only String.

[Visual Basic]
NotOverridable Public ReadOnly Property ContentType As String _
Implements IVideo.ContentType
[C#]
public string ContentType {get;}

Implements

IVideo.ContentType

See Also

Video Class | Aspose.Slides Namespace


VideoCollection Class

Represents a collection of Video objects.

For a list of all members of this type, see VideoCollection Members.

System.Object
Aspose.Slides.VideoCollection

[Visual Basic]
Public Class VideoCollection
Implements IVideoCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IVideo, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class VideoCollection : IVideoCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

VideoCollection Members | Aspose.Slides Namespace


VideoCollection Members

VideoCollection overview

Public Instance Properties

Count | Returns a number of video files in the collection.
Item | Gets the element at the specified index. Read-only IVideo.

Public Instance Methods

AddVideo | Overloaded. Adds a copy of an video file from an another presentation.
GetEnumerator | Returns an enumerator that iterates through the collection.

See Also

VideoCollection Class | Aspose.Slides Namespace


VideoCollection Properties

The properties of the VideoCollection class are listed below. For a complete list of VideoCollection class members, see the VideoCollection Members topic.

Public Instance Properties

Count | Returns a number of video files in the collection.
Item | Gets the element at the specified index. Read-only IVideo.

See Also

VideoCollection Class | Aspose.Slides Namespace


Count Property

Aspose.Slides Documentation

VideoCollection.Count Property

Returns a number of video files in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

VideoCollection Class | Aspose.Slides Namespace


Item Property

Aspose.Slides Documentation

VideoCollection.Item Property

Gets the element at the specified index. Read-only IVideo.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IVideoCollection.Item
As IVideo _
Implements IVideoCollection.Item
[C#]
public IVideo this[
int index
] {get;}

Implements

IVideoCollection.Item

See Also

VideoCollection Class | Aspose.Slides Namespace


VideoCollection Methods

The methods of the VideoCollection class are listed below. For a complete list of VideoCollection class members, see the VideoCollection Members topic.

Public Instance Methods

AddVideo | Overloaded. Adds a copy of an video file from an another presentation.
GetEnumerator | Returns an enumerator that iterates through the collection.

See Also

VideoCollection Class | Aspose.Slides Namespace


AddVideo Method

Aspose.Slides Documentation

VideoCollection.AddVideo Method

Adds a copy of an video file from an another presentation.

Overload List

Adds a copy of an video file from an another presentation.

public IVideo AddVideo(IVideo);

Creates and adds a video to a presentation from byte array.

public IVideo AddVideo(byte[]);

Creates and adds a video to a presentation from stream.

public IVideo AddVideo(Stream);

See Also

VideoCollection Class | Aspose.Slides Namespace


VideoCollection.AddVideo Method (IVideo)

Adds a copy of an video file from an another presentation.

[Visual Basic]
NotOverridable Overloads Public Function AddVideo( _
ByVal video As IVideo _
) As IVideo _
Implements IVideoCollection.AddVideo
[C#]
public IVideo AddVideo(
IVideo video
);

Parameters

video
Source video.

Return Value

Added video.

Implements

IVideoCollection.AddVideo

See Also

VideoCollection Class | Aspose.Slides Namespace | VideoCollection.AddVideo Overload List


VideoCollection.AddVideo Method (Byte[])

Creates and adds a video to a presentation from byte array.

[Visual Basic]
NotOverridable Overloads Public Function AddVideo( _
ByVal videoData As Byte() _
) As IVideo _
Implements IVideoCollection.AddVideo
[C#]
public IVideo AddVideo(
byte[] videoData
);

Parameters

videoData
Video bytes.

Return Value

Added video.

Implements

IVideoCollection.AddVideo

See Also

VideoCollection Class | Aspose.Slides Namespace | VideoCollection.AddVideo Overload List


VideoCollection.AddVideo Method (Stream)

Creates and adds a video to a presentation from stream.

[Visual Basic]
NotOverridable Overloads Public Function AddVideo( _
ByVal stream As Stream _
) As IVideo _
Implements IVideoCollection.AddVideo
[C#]
public IVideo AddVideo(
Stream stream
);

Parameters

stream
Stream to add video file from.

Return Value

Added Video.

Implements

IVideoCollection.AddVideo

See Also

VideoCollection Class | Aspose.Slides Namespace | VideoCollection.AddVideo Overload List


VideoCollection.GetEnumerator Method

Returns an enumerator that iterates through the collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator(Of IVideo) _
Implements IEnumerable`1.GetEnumerator
[C#]
public IEnumerator<IVideo> GetEnumerator();

Return Value

A IEnumerator`1 that can be used to iterate through the collection.

Implements

IEnumerable`1.GetEnumerator

See Also

VideoCollection Class | Aspose.Slides Namespace


VideoFrame Class

Represents a video clip on a slide.

For a list of all members of this type, see VideoFrame Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GeometryShape
Aspose.Slides.PictureFrame
Aspose.Slides.VideoFrame

[Visual Basic]
Public Class VideoFrame
Inherits PictureFrame
Implements IVideoFrame
[C#]
public class VideoFrame : PictureFrame, IVideoFrame

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

VideoFrame Members | Aspose.Slides Namespace


VideoFrame Members

VideoFrame overview

Public Instance Properties

Adjustments (inherited from GeometryShape) | Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
EmbeddedVideo | Returns or sets embedded video object. Read/write Video.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
FullScreenMode | Determines whether a video is shown in full screen mode. Read/write Boolean.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HideAtShowing | Determines whether a VideoFrame is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
LinkPathLong | Returns or sets the name of an video file which is linked to a VideoFrame. Read/write String.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
PictureFormat (inherited from PictureFrame) | Returns the PictureFillFormat object for a picture frame. Read-only PictureFillFormat.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
PlayLoopMode | Determines whether a video is looped. Read/write Boolean.
PlayMode | Returns or sets the video play mode. Read/write VideoPlayModePreset.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
RelativeScaleHeight (inherited from PictureFrame) | Returns or sets the scale of height(relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.
RelativeScaleWidth (inherited from PictureFrame) | Returns or sets the scale of width (relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.
RewindVideo | Determines whether a video is automatically rewinded to start as soon as the movie has finished playing. Read/write Boolean.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock (inherited from PictureFrame) | Returns shape's locks. Readonly PictureFrameLock.
ShapeStyle (inherited from GeometryShape) | Returns shape's style object. Read-only ShapeStyle.
ShapeType (inherited from PictureFrame) | Returns or sets the AutoShape type for a PictureFrame. There are allowable all items of the set ShapeType, except all sorts of lines: ShapeType.Line, ShapeType.StraightConnector1, ShapeType.BentConnector2, ShapeType.BentConnector3, ShapeType.BentConnector4, ShapeType.BentConnector5, ShapeType.CurvedConnector2, ShapeType.CurvedConnector3, ShapeType.CurvedConnector4, ShapeType.CurvedConnector5. Read/write ShapeType.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Volume | Returns or sets the audio volume. Read/write AudioVolumeMode.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateShapeElements (inherited from GeometryShape) | Creates and returns array of shape's elements.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

VideoFrame Class | Aspose.Slides Namespace


VideoFrame Properties

The properties of the VideoFrame class are listed below. For a complete list of VideoFrame class members, see the VideoFrame Members topic.

Public Instance Properties

Adjustments (inherited from GeometryShape) | Returns a collection of shape's adjustment values. Readonly AdjustValueCollection.
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
EmbeddedVideo | Returns or sets embedded video object. Read/write Video.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
FullScreenMode | Determines whether a video is shown in full screen mode. Read/write Boolean.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HideAtShowing | Determines whether a VideoFrame is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
LinkPathLong | Returns or sets the name of an video file which is linked to a VideoFrame. Read/write String.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
PictureFormat (inherited from PictureFrame) | Returns the PictureFillFormat object for a picture frame. Read-only PictureFillFormat.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
PlayLoopMode | Determines whether a video is looped. Read/write Boolean.
PlayMode | Returns or sets the video play mode. Read/write VideoPlayModePreset.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
RelativeScaleHeight (inherited from PictureFrame) | Returns or sets the scale of height(relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.
RelativeScaleWidth (inherited from PictureFrame) | Returns or sets the scale of width (relative to original picture size) of the picture frame. Value 1.0 corresponds to 100%.
RewindVideo | Determines whether a video is automatically rewinded to start as soon as the movie has finished playing. Read/write Boolean.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock (inherited from PictureFrame) | Returns shape's locks. Readonly PictureFrameLock.
ShapeStyle (inherited from GeometryShape) | Returns shape's style object. Read-only ShapeStyle.
ShapeType (inherited from PictureFrame) | Returns or sets the AutoShape type for a PictureFrame. There are allowable all items of the set ShapeType, except all sorts of lines: ShapeType.Line, ShapeType.StraightConnector1, ShapeType.BentConnector2, ShapeType.BentConnector3, ShapeType.BentConnector4, ShapeType.BentConnector5, ShapeType.CurvedConnector2, ShapeType.CurvedConnector3, ShapeType.CurvedConnector4, ShapeType.CurvedConnector5. Read/write ShapeType.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Volume | Returns or sets the audio volume. Read/write AudioVolumeMode.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

VideoFrame Class | Aspose.Slides Namespace


EmbeddedVideo Property

Aspose.Slides Documentation

VideoFrame.EmbeddedVideo Property

Returns or sets embedded video object. Read/write Video.

[Visual Basic]
NotOverridable Public Property EmbeddedVideo As IVideo _
Implements IVideoFrame.EmbeddedVideo
[C#]
public IVideo EmbeddedVideo {get; set;}

Implements

IVideoFrame.EmbeddedVideo

See Also

VideoFrame Class | Aspose.Slides Namespace


FullScreenMode Property

Aspose.Slides Documentation

VideoFrame.FullScreenMode Property

Determines whether a video is shown in full screen mode. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property FullScreenMode As Boolean _
Implements IVideoFrame.FullScreenMode
[C#]
public bool FullScreenMode {get; set;}

Implements

IVideoFrame.FullScreenMode

See Also

VideoFrame Class | Aspose.Slides Namespace


HideAtShowing Property

Aspose.Slides Documentation

VideoFrame.HideAtShowing Property

Determines whether a VideoFrame is hidden. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property HideAtShowing As Boolean _
Implements IVideoFrame.HideAtShowing
[C#]
public bool HideAtShowing {get; set;}

Implements

IVideoFrame.HideAtShowing

See Also

VideoFrame Class | Aspose.Slides Namespace


LinkPathLong Property

Aspose.Slides Documentation

VideoFrame.LinkPathLong Property

Returns or sets the name of an video file which is linked to a VideoFrame. Read/write String.

[Visual Basic]
NotOverridable Public Property LinkPathLong As String _
Implements IVideoFrame.LinkPathLong
[C#]
public string LinkPathLong {get; set;}

Implements

IVideoFrame.LinkPathLong

See Also

VideoFrame Class | Aspose.Slides Namespace


PlayLoopMode Property

Aspose.Slides Documentation

VideoFrame.PlayLoopMode Property

Determines whether a video is looped. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property PlayLoopMode As Boolean _
Implements IVideoFrame.PlayLoopMode
[C#]
public bool PlayLoopMode {get; set;}

Implements

IVideoFrame.PlayLoopMode

See Also

VideoFrame Class | Aspose.Slides Namespace


PlayMode Property

Aspose.Slides Documentation

VideoFrame.PlayMode Property

Returns or sets the video play mode. Read/write VideoPlayModePreset.

[Visual Basic]
NotOverridable Public Property PlayMode As VideoPlayModePreset _
Implements IVideoFrame.PlayMode
[C#]
public VideoPlayModePreset PlayMode {get; set;}

Implements

IVideoFrame.PlayMode

See Also

VideoFrame Class | Aspose.Slides Namespace


RewindVideo Property

Aspose.Slides Documentation

VideoFrame.RewindVideo Property

Determines whether a video is automatically rewinded to start as soon as the movie has finished playing. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property RewindVideo As Boolean _
Implements IVideoFrame.RewindVideo
[C#]
public bool RewindVideo {get; set;}

Implements

IVideoFrame.RewindVideo

See Also

VideoFrame Class | Aspose.Slides Namespace


Volume Property

Aspose.Slides Documentation

VideoFrame.Volume Property

Returns or sets the audio volume. Read/write AudioVolumeMode.

[Visual Basic]
NotOverridable Public Property Volume As AudioVolumeMode _
Implements IVideoFrame.Volume
[C#]
public AudioVolumeMode Volume {get; set;}

Implements

IVideoFrame.Volume

See Also

VideoFrame Class | Aspose.Slides Namespace


VideoPlayModePreset Enumeration

[Visual Basic]
Public Enum VideoPlayModePreset
[C#]
public enum VideoPlayModePreset

Members

Member Name | Description | Value
Mixed |  | -1
Auto |  | 0
OnClick |  | 1
AllSlides |  | 2

Requirements

Namespace: Aspose.Slides

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides Namespace


Aspose.Slides.Animation

Aspose.Slides Documentation

Aspose.Slides.Animation Namespace

Namespace hierarchy

Classes

Class | Description
AnimationTimeLine | Represents timeline of animation.
Behavior | Represent base class behavior of effect.
BehaviorCollection | Represents collection of behavior effects.
BehaviorFactory | Allows to create animation effects
BehaviorProperties | Represents timing properties for the effect behavior.
ColorEffect | Represents a color effect for an animation behavior.
ColorOffset | Represent color offset.
CommandEffect | Represents a command effect for an animation behavior.
Effect | Represent animation effect.
FilterEffect | Represent filter effect of behavior.
MotionCmdPath | Represent one command of a path.
MotionEffect | Represent motion effect behavior of effect.
MotionPath | Represent motion path.
Point | Represent animation point.
PointCollection | Represent collection of animation points.
PropertyEffect | Represent property effect behavior.
RotationEffect | Represent rotation behavior of effect.
ScaleEffect | Represents animation scale effect.
Sequence | Represent sequence (collection of effects).
SequenceCollection | Represent collection of interactive sequences.
SetEffect | Represents a set effect for an animation behavior.
TextAnimation | Represent text animation.
TextAnimationCollection | Represent collection of text animations.
Timing | Represents animation timing.

Interfaces

Interface | Description
IBehavior |
IBehaviorCollection |
IBehaviorFactory |
IBehaviorProperties |
IColorEffect |
IColorOffset |
ICommandEffect |
IEffect |
IFilterEffect |
IMotionCmdPath |
IMotionEffect |
IMotionPath |
IPoint |
IPointCollection |
IPropertyEffect |
IRotationEffect |
IScaleEffect |
ISequence |
ISequenceCollection |
ISetEffect |
ITextAnimation |
ITextAnimationCollection |
ITiming |

Enumerations

Enumeration | Description
BehaviorAccumulateType |
BehaviorAdditiveType |
BuildType |
ColorDirection |
ColorSpace |
CommandEffectType |
EffectFillType |
EffectPresetClassType |
EffectRestartType |
EffectSubtype |
EffectTriggerType |
EffectType |
FilterEffectRevealType |
FilterEffectSubtype |
FilterEffectType |
MotionCommandPathType |
MotionOriginType |
MotionPathEditMode |
MotionPathPointsType |
PropertyCalcModeType |
PropertyType |
PropertyValueType |


AnimationTimeLine Class

Represents timeline of animation.

For a list of all members of this type, see AnimationTimeLine Members.

System.Object
Aspose.Slides.Animation.AnimationTimeLine

[Visual Basic]
Public Class AnimationTimeLine
Implements IAnimationTimeLine
[C#]
public class AnimationTimeLine : IAnimationTimeLine

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AnimationTimeLine Members | Aspose.Slides.Animation Namespace


AnimationTimeLine Members

AnimationTimeLine overview

Public Instance Properties

InteractiveSequences | Returns collection of interactive sequences. This sequences may contain only effects by "click on shape" with specifies target shape. Read-only SequenceCollection.
MainSequence | Returns main sequence which may contain only main effects collection. Read-only Sequence.
TextAnimationCollection | Returns collection of text animations. Read-only TextAnimationCollection.

See Also

AnimationTimeLine Class | Aspose.Slides.Animation Namespace


AnimationTimeLine Properties

The properties of the AnimationTimeLine class are listed below. For a complete list of AnimationTimeLine class members, see the AnimationTimeLine Members topic.

Public Instance Properties

InteractiveSequences | Returns collection of interactive sequences. This sequences may contain only effects by "click on shape" with specifies target shape. Read-only SequenceCollection.
MainSequence | Returns main sequence which may contain only main effects collection. Read-only Sequence.
TextAnimationCollection | Returns collection of text animations. Read-only TextAnimationCollection.

See Also

AnimationTimeLine Class | Aspose.Slides.Animation Namespace


InteractiveSequences Property

Aspose.Slides Documentation

AnimationTimeLine.InteractiveSequences Property

Returns collection of interactive sequences. This sequences may contain only effects by "click on shape" with specifies target shape. Read-only SequenceCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property InteractiveSequences As ISequenceCollection _
Implements IAnimationTimeLine.InteractiveSequences
[C#]
public ISequenceCollection InteractiveSequences {get;}

Implements

IAnimationTimeLine.InteractiveSequences

See Also

AnimationTimeLine Class | Aspose.Slides.Animation Namespace


MainSequence Property

Aspose.Slides Documentation

AnimationTimeLine.MainSequence Property

Returns main sequence which may contain only main effects collection. Read-only Sequence.

[Visual Basic]
NotOverridable Public ReadOnly Property MainSequence As ISequence _
Implements IAnimationTimeLine.MainSequence
[C#]
public ISequence MainSequence {get;}

Implements

IAnimationTimeLine.MainSequence

See Also

AnimationTimeLine Class | Aspose.Slides.Animation Namespace


TextAnimationCollection Property

Aspose.Slides Documentation

AnimationTimeLine.TextAnimationCollection Property

Returns collection of text animations. Read-only TextAnimationCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property TextAnimationCollection As ITextAnimationCollection _
Implements IAnimationTimeLine.TextAnimationCollection
[C#]
public ITextAnimationCollection TextAnimationCollection {get;}

Implements

IAnimationTimeLine.TextAnimationCollection

See Also

AnimationTimeLine Class | Aspose.Slides.Animation Namespace


Behavior Class

Represent base class behavior of effect.

For a list of all members of this type, see Behavior Members.

System.Object
Aspose.Slides.Animation.Behavior
Derived types

[Visual Basic]
MustInherit Public Class Behavior
Implements IBehavior
[C#]
public abstract class Behavior : IBehavior

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Behavior Members | Aspose.Slides.Animation Namespace


Behavior Members

Behavior overview

Public Instance Properties

Accumulate | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
Properties | Represents properties of behavior. Read-only BehaviorProperties.
Timing | Represents timing properties for the effect behavior. Read/write Timing.

See Also

Behavior Class | Aspose.Slides.Animation Namespace


Behavior Properties

The properties of the Behavior class are listed below. For a complete list of Behavior class members, see the Behavior Members topic.

Public Instance Properties

Accumulate | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
Properties | Represents properties of behavior. Read-only BehaviorProperties.
Timing | Represents timing properties for the effect behavior. Read/write Timing.

See Also

Behavior Class | Aspose.Slides.Animation Namespace


Accumulate Property

Aspose.Slides Documentation

Behavior.Accumulate Property

Represents whether animation behaviors are accumulated. Read/write NullableBool.

[Visual Basic]
NotOverridable Public Property Accumulate As NullableBool _
Implements IBehavior.Accumulate
[C#]
public NullableBool Accumulate {get; set;}

Implements

IBehavior.Accumulate

See Also

Behavior Class | Aspose.Slides.Animation Namespace


Additive Property

Aspose.Slides Documentation

Behavior.Additive Property

Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.

[Visual Basic]
NotOverridable Public Property Additive As BehaviorAdditiveType _
Implements IBehavior.Additive
[C#]
public BehaviorAdditiveType Additive {get; set;}

Implements

IBehavior.Additive

See Also

Behavior Class | Aspose.Slides.Animation Namespace


Properties Property

Aspose.Slides Documentation

Behavior.Properties Property

Represents properties of behavior. Read-only BehaviorProperties.

[Visual Basic]
NotOverridable Public ReadOnly Property Properties As IBehaviorProperties _
Implements IBehavior.Properties
[C#]
public IBehaviorProperties Properties {get;}

Implements

IBehavior.Properties

See Also

Behavior Class | Aspose.Slides.Animation Namespace


Timing Property

Aspose.Slides Documentation

Behavior.Timing Property

Represents timing properties for the effect behavior. Read/write Timing.

[Visual Basic]
NotOverridable Public Property Timing As ITiming _
Implements IBehavior.Timing
[C#]
public ITiming Timing {get; set;}

Implements

IBehavior.Timing

See Also

Behavior Class | Aspose.Slides.Animation Namespace


BehaviorAccumulateType Enumeration

[Visual Basic]
Public Enum BehaviorAccumulateType
[C#]
public enum BehaviorAccumulateType

Members

Member Name | Description | Value
NotDefined |  | -1
Always |  | 0
None |  | 1

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


BehaviorAdditiveType Enumeration

[Visual Basic]
Public Enum BehaviorAdditiveType
[C#]
public enum BehaviorAdditiveType

Members

Member Name | Description | Value
NotDefined |  | -1
None |  | 0
Base |  | 1
Sum |  | 2
Replace |  | 3
Multiply |  | 4

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


BehaviorCollection Class

Represents collection of behavior effects.

For a list of all members of this type, see BehaviorCollection Members.

System.Object
Aspose.Slides.Animation.BehaviorCollection

[Visual Basic]
Public Class BehaviorCollection
Implements IBehaviorCollection, IEnumerable`1([Aspose.Slides.Animation.IBehavior, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public class BehaviorCollection : IBehaviorCollection, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BehaviorCollection Members | Aspose.Slides.Animation Namespace


BehaviorCollection Members

BehaviorCollection overview

Public Instance Properties

Count | Returns the number of behaviors in a collection.
IsReadOnly | Gets a value indicating whether the ICollection`1 is read-only.
Item | Retirns a behavior at the specified index.

Public Instance Methods

Add | Add new behavior to a collection.
Clear | Removes all behaviors from a collection.
Contains | Determines whether the ICollection`1 contains a specific value.
CopyTo | Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.
GetEnumerator | Returns an iterator for the entire collection.
IndexOf | Determines the index of a specific item in the IList`1.
Insert | Inserts new behavior to a collection at the specified index.
Remove | Removes specified behavior from a collection.
RemoveAt | Removes behavior from a collection at the specified index.

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


BehaviorCollection Properties

The properties of the BehaviorCollection class are listed below. For a complete list of BehaviorCollection class members, see the BehaviorCollection Members topic.

Public Instance Properties

Count | Returns the number of behaviors in a collection.
IsReadOnly | Gets a value indicating whether the ICollection`1 is read-only.
Item | Retirns a behavior at the specified index.

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


Count Property

Aspose.Slides Documentation

BehaviorCollection.Count Property

Returns the number of behaviors in a collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements IBehaviorCollection.Count
[C#]
public int Count {get;}

Implements

IBehaviorCollection.Count

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


IsReadOnly Property

Aspose.Slides Documentation

BehaviorCollection.IsReadOnly Property

Gets a value indicating whether the ICollection`1 is read-only.

[Visual Basic]
Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {get;}

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

BehaviorCollection.Item Property

Retirns a behavior at the specified index.

[Visual Basic]
NotOverridable Public Default Property Item( _
ByVal index As Integer _
) _
Implements IBehaviorCollection.Item
As IBehavior _
Implements IBehaviorCollection.Item
[C#]
public IBehavior this[
int index
] {get; set;}

Parameters

index
Index of a behavior to return.

Implements

IBehaviorCollection.Item

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


BehaviorCollection Methods

The methods of the BehaviorCollection class are listed below. For a complete list of BehaviorCollection class members, see the BehaviorCollection Members topic.

Public Instance Methods

Add | Add new behavior to a collection.
Clear | Removes all behaviors from a collection.
Contains | Determines whether the ICollection`1 contains a specific value.
CopyTo | Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.
GetEnumerator | Returns an iterator for the entire collection.
IndexOf | Determines the index of a specific item in the IList`1.
Insert | Inserts new behavior to a collection at the specified index.
Remove | Removes specified behavior from a collection.
RemoveAt | Removes behavior from a collection at the specified index.

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


BehaviorCollection.Add Method

Add new behavior to a collection.

[Visual Basic]
NotOverridable Public Sub Add( _
ByVal item As IBehavior _
) _
Implements IBehaviorCollection.Add
[C#]
public void Add(
IBehavior item
);

Parameters

item
Behavior to add.

Return Value

Index of a new behavior in a collection.

Implements

IBehaviorCollection.Add

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


BehaviorCollection.Clear Method

Removes all behaviors from a collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IBehaviorCollection.Clear
[C#]
public void Clear();

Implements

IBehaviorCollection.Clear

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


BehaviorCollection.Contains Method

Determines whether the ICollection`1 contains a specific value.

[Visual Basic]
NotOverridable Public Function Contains( _
ByVal item As IBehavior _
) As Boolean _
Implements IBehaviorCollection.Contains
[C#]
public bool Contains(
IBehavior item
);

Parameters

item
The object to locate in the ICollection`1.

Return Value

true if item is found in the ICollection`1; otherwise, false.

Implements

IBehaviorCollection.Contains

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


BehaviorCollection.CopyTo Method

Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As IBehavior(), _
ByVal arrayIndex As Integer _
)
[C#]
public void CopyTo(
IBehavior[] array,
int arrayIndex
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from ICollection`1. The Array must have zero-based indexing.
arrayIndex
The zero-based index in array at which copying begins.

Exceptions

Exception Type | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | The number of elements in the source ICollection`1 is greater than the available space from arrayIndex to the end of the destination array.

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


BehaviorCollection.GetEnumerator Method

Returns an iterator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Iterator.

Implements

IEnumerable.GetEnumerator

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


BehaviorCollection.IndexOf Method

Determines the index of a specific item in the IList`1.

[Visual Basic]
NotOverridable Public Function IndexOf( _
ByVal item As IBehavior _
) As Integer _
Implements IBehaviorCollection.IndexOf
[C#]
public int IndexOf(
IBehavior item
);

Parameters

item
The object to locate in the IList`1.

Return Value

The index of item if found in the list; otherwise, -1.

Implements

IBehaviorCollection.IndexOf

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


BehaviorCollection.Insert Method

Inserts new behavior to a collection at the specified index.

[Visual Basic]
NotOverridable Public Sub Insert( _
ByVal index As Integer, _
ByVal item As IBehavior _
) _
Implements IBehaviorCollection.Insert
[C#]
public void Insert(
int index,
IBehavior item
);

Parameters

index
Index where new behavior should be inserted.
item
Behavior to insert.

Implements

IBehaviorCollection.Insert

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


BehaviorCollection.Remove Method

Removes specified behavior from a collection.

[Visual Basic]
NotOverridable Public Function Remove( _
ByVal item As IBehavior _
) As Boolean _
Implements IBehaviorCollection.Remove
[C#]
public bool Remove(
IBehavior item
);

Parameters

item
Behavior to remove.

Implements

IBehaviorCollection.Remove

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


BehaviorCollection.RemoveAt Method

Removes behavior from a collection at the specified index.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IBehaviorCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
Index of a behavior to remove.

Implements

IBehaviorCollection.RemoveAt

See Also

BehaviorCollection Class | Aspose.Slides.Animation Namespace


BehaviorFactory Class

Allows to create animation effects

For a list of all members of this type, see BehaviorFactory Members.

System.Object
Aspose.Slides.Animation.BehaviorFactory

[Visual Basic]
Public Class BehaviorFactory
Implements IBehaviorFactory
[C#]
public class BehaviorFactory : IBehaviorFactory

Remarks

For COM compatibility

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BehaviorFactory Members | Aspose.Slides.Animation Namespace


BehaviorFactory Members

BehaviorFactory overview

Public Instance Constructors

BehaviorFactory Constructor Initializes a new instance of the BehaviorFactory class.

Public Instance Methods

CreateColorEffect
CreateCommandEffect
CreateFilterEffect
CreateMotionEffect
CreatePropertyEffect
CreateRotationEffect
CreateScaleEffect
CreateSetEffect

See Also

BehaviorFactory Class | Aspose.Slides.Animation Namespace


BehaviorFactory Constructor

Initializes a new instance of the BehaviorFactory class.

[Visual Basic]
Public Sub New()
[C#]
public BehaviorFactory();

See Also

BehaviorFactory Class | Aspose.Slides.Animation Namespace


BehaviorFactory Methods

The methods of the BehaviorFactory class are listed below. For a complete list of BehaviorFactory class members, see the BehaviorFactory Members topic.

Public Instance Methods

CreateColorEffect
CreateCommandEffect
CreateFilterEffect
CreateMotionEffect
CreatePropertyEffect
CreateRotationEffect
CreateScaleEffect
CreateSetEffect

See Also

BehaviorFactory Class | Aspose.Slides.Animation Namespace


BehaviorFactory.CreateColorEffect Method

[Visual Basic]
NotOverridable Public Function CreateColorEffect() As IColorEffect _
Implements IBehaviorFactory.CreateColorEffect
[C#]
public IColorEffect CreateColorEffect();

Implements

IBehaviorFactory.CreateColorEffect

See Also

BehaviorFactory Class | Aspose.Slides.Animation Namespace


BehaviorFactory.CreateCommandEffect Method

[Visual Basic]
NotOverridable Public Function CreateCommandEffect() As ICommandEffect _
Implements IBehaviorFactory.CreateCommandEffect
[C#]
public ICommandEffect CreateCommandEffect();

Implements

IBehaviorFactory.CreateCommandEffect

See Also

BehaviorFactory Class | Aspose.Slides.Animation Namespace


BehaviorFactory.CreateFilterEffect Method

[Visual Basic]
NotOverridable Public Function CreateFilterEffect() As IFilterEffect _
Implements IBehaviorFactory.CreateFilterEffect
[C#]
public IFilterEffect CreateFilterEffect();

Implements

IBehaviorFactory.CreateFilterEffect

See Also

BehaviorFactory Class | Aspose.Slides.Animation Namespace


BehaviorFactory.CreateMotionEffect Method

[Visual Basic]
NotOverridable Public Function CreateMotionEffect() As IMotionEffect _
Implements IBehaviorFactory.CreateMotionEffect
[C#]
public IMotionEffect CreateMotionEffect();

Implements

IBehaviorFactory.CreateMotionEffect

See Also

BehaviorFactory Class | Aspose.Slides.Animation Namespace


BehaviorFactory.CreatePropertyEffect Method

[Visual Basic]
NotOverridable Public Function CreatePropertyEffect() As IPropertyEffect _
Implements IBehaviorFactory.CreatePropertyEffect
[C#]
public IPropertyEffect CreatePropertyEffect();

Implements

IBehaviorFactory.CreatePropertyEffect

See Also

BehaviorFactory Class | Aspose.Slides.Animation Namespace


BehaviorFactory.CreateRotationEffect Method

[Visual Basic]
NotOverridable Public Function CreateRotationEffect() As IRotationEffect _
Implements IBehaviorFactory.CreateRotationEffect
[C#]
public IRotationEffect CreateRotationEffect();

Implements

IBehaviorFactory.CreateRotationEffect

See Also

BehaviorFactory Class | Aspose.Slides.Animation Namespace


BehaviorFactory.CreateScaleEffect Method

[Visual Basic]
NotOverridable Public Function CreateScaleEffect() As IScaleEffect _
Implements IBehaviorFactory.CreateScaleEffect
[C#]
public IScaleEffect CreateScaleEffect();

Implements

IBehaviorFactory.CreateScaleEffect

See Also

BehaviorFactory Class | Aspose.Slides.Animation Namespace


BehaviorFactory.CreateSetEffect Method

[Visual Basic]
NotOverridable Public Function CreateSetEffect() As ISetEffect _
Implements IBehaviorFactory.CreateSetEffect
[C#]
public ISetEffect CreateSetEffect();

Implements

IBehaviorFactory.CreateSetEffect

See Also

BehaviorFactory Class | Aspose.Slides.Animation Namespace


BehaviorProperties Class

Represents timing properties for the effect behavior.

For a list of all members of this type, see BehaviorProperties Members.

System.Object
Aspose.Slides.Animation.BehaviorProperties

[Visual Basic]
Public Class BehaviorProperties
Implements IBehaviorProperties, IList`1([Aspose.Slides.Animation.PropertyType, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), ICollection`1([Aspose.Slides.Animation.PropertyType, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable`1([Aspose.Slides.Animation.PropertyType, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public class BehaviorProperties : IBehaviorProperties, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BehaviorProperties Members | Aspose.Slides.Animation Namespace


BehaviorProperties Members

BehaviorProperties overview

Public Instance Properties

Count | Returns the number of properties stored in the collection.
IsReadOnly | Gets a value indicating whether the ICollection`1 is read-only.
Item | Returns a property at the specified index.

Public Instance Methods

Add | Adds a new property to the collection.
Clear | Removes all properties from the collection.
Contains | Determines whether the ICollection`1 contains a specific value.
CopyTo | Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.
GetEnumerator | Returns an iterator for the collection.
IndexOf | Determines the index of a specific item in the IList`1.
Insert | Inserts a new property to the collection at the specified index.
Remove | Removes specified property from the collection.
RemoveAt | Removes property at the specified index.

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


BehaviorProperties Properties

The properties of the BehaviorProperties class are listed below. For a complete list of BehaviorProperties class members, see the BehaviorProperties Members topic.

Public Instance Properties

Count | Returns the number of properties stored in the collection.
IsReadOnly | Gets a value indicating whether the ICollection`1 is read-only.
Item | Returns a property at the specified index.

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


Count Property

Aspose.Slides Documentation

BehaviorProperties.Count Property

Returns the number of properties stored in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection`1.Count
[C#]
public int Count {get;}

Implements

ICollection`1.Count

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


IsReadOnly Property

Aspose.Slides Documentation

BehaviorProperties.IsReadOnly Property

Gets a value indicating whether the ICollection`1 is read-only.

[Visual Basic]
NotOverridable Public ReadOnly Property IsReadOnly As Boolean _
Implements ICollection`1.IsReadOnly
[C#]
public bool IsReadOnly {get;}

Implements

ICollection`1.IsReadOnly

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

BehaviorProperties.Item Property

Returns a property at the specified index.

[Visual Basic]
NotOverridable Public Default Property Item( _
ByVal index As Integer _
) _
Implements IList`1.Item
As PropertyType _
Implements IList`1.Item
[C#]
public PropertyType this[
int index
] {get; set;}

Parameters

index
Index of a property to return.

Implements

IList`1.Item

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


BehaviorProperties Methods

The methods of the BehaviorProperties class are listed below. For a complete list of BehaviorProperties class members, see the BehaviorProperties Members topic.

Public Instance Methods

Add | Adds a new property to the collection.
Clear | Removes all properties from the collection.
Contains | Determines whether the ICollection`1 contains a specific value.
CopyTo | Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.
GetEnumerator | Returns an iterator for the collection.
IndexOf | Determines the index of a specific item in the IList`1.
Insert | Inserts a new property to the collection at the specified index.
Remove | Removes specified property from the collection.
RemoveAt | Removes property at the specified index.

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


BehaviorProperties.Add Method

Adds a new property to the collection.

[Visual Basic]
NotOverridable Public Sub Add( _
ByVal item As PropertyType _
) _
Implements ICollection`1.Add
[C#]
public void Add(
PropertyType item
);

Parameters

item
Property to add.

Return Value

Index in the collection where a new property is added.

Implements

ICollection`1.Add

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


BehaviorProperties.Clear Method

Removes all properties from the collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements ICollection`1.Clear
[C#]
public void Clear();

Implements

ICollection`1.Clear

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


BehaviorProperties.Contains Method

Determines whether the ICollection`1 contains a specific value.

[Visual Basic]
NotOverridable Public Function Contains( _
ByVal item As PropertyType _
) As Boolean _
Implements ICollection`1.Contains
[C#]
public bool Contains(
PropertyType item
);

Parameters

item
The object to locate in the ICollection`1.

Return Value

true if item is found in the ICollection`1; otherwise, false.

Implements

ICollection`1.Contains

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


BehaviorProperties.CopyTo Method

Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As PropertyType(), _
ByVal arrayIndex As Integer _
) _
Implements ICollection`1.CopyTo
[C#]
public void CopyTo(
PropertyType[] array,
int arrayIndex
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from ICollection`1. The Array must have zero-based indexing.
arrayIndex
The zero-based index in array at which copying begins.

Implements

ICollection`1.CopyTo

Exceptions

Exception Type | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | The number of elements in the source ICollection`1 is greater than the available space from arrayIndex to the end of the destination array.

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


BehaviorProperties.GetEnumerator Method

Returns an iterator for the collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Iterator.

Implements

IEnumerable.GetEnumerator

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


BehaviorProperties.IndexOf Method

Determines the index of a specific item in the IList`1.

[Visual Basic]
NotOverridable Public Function IndexOf( _
ByVal item As PropertyType _
) As Integer _
Implements IList`1.IndexOf
[C#]
public int IndexOf(
PropertyType item
);

Parameters

item
The object to locate in the IList`1.

Return Value

The index of item if found in the list; otherwise, -1.

Implements

IList`1.IndexOf

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


BehaviorProperties.Insert Method

Inserts a new property to the collection at the specified index.

[Visual Basic]
NotOverridable Public Sub Insert( _
ByVal index As Integer, _
ByVal item As PropertyType _
) _
Implements IList`1.Insert
[C#]
public void Insert(
int index,
PropertyType item
);

Parameters

index
Index where a new property should be inserted.
item
Property to add.

Implements

IList`1.Insert

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


BehaviorProperties.Remove Method

Removes specified property from the collection.

[Visual Basic]
NotOverridable Public Function Remove( _
ByVal item As PropertyType _
) As Boolean _
Implements ICollection`1.Remove
[C#]
public bool Remove(
PropertyType item
);

Parameters

item
Property to remove.

Implements

ICollection`1.Remove

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


BehaviorProperties.RemoveAt Method

Removes property at the specified index.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IList`1.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
Index of the property which should be deleted.

Implements

IList`1.RemoveAt

See Also

BehaviorProperties Class | Aspose.Slides.Animation Namespace


BuildType Enumeration

[Visual Basic]
Public Enum BuildType
[C#]
public enum BuildType

Members

Member Name | Description | Value
AsOneObject |  | 0
AllParagraphsAtOnce |  | 1
ByLevelParagraphs1 |  | 2
ByLevelParagraphs2 |  | 3
ByLevelParagraphs3 |  | 4
ByLevelParagraphs4 |  | 5
ByLevelParagraphs5 |  | 6

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


ColorDirection Enumeration

[Visual Basic]
Public Enum ColorDirection
[C#]
public enum ColorDirection

Members

Member Name | Description | Value
NotDefined |  | -1
Clockwise |  | 0
CounterClockwise |  | 1

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


ColorEffect Class

Represents a color effect for an animation behavior.

For a list of all members of this type, see ColorEffect Members.

System.Object
Aspose.Slides.Animation.Behavior
Aspose.Slides.Animation.ColorEffect

[Visual Basic]
Public Class ColorEffect
Inherits Behavior
Implements IColorEffect
[C#]
public class ColorEffect : Behavior, IColorEffect

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ColorEffect Members | Aspose.Slides.Animation Namespace


ColorEffect Members

ColorEffect overview

Public Instance Constructors

ColorEffect Constructor Initializes a new instance of the ColorEffect class.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
By | Describes the relative offset value for the color animation. Read/write ColorFormat.
ColorSpace | Represent color space of behavior. Read/write ColorSpace.
Direction | Specifies which direction to cycle the hue around the color wheel. Read/write ColorDirection.
From | This value is used to specify the starting color of behavior. Read/write ColorFormat.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
To | Describes resulting color for the animation color change. Read/write ColorFormat.

See Also

ColorEffect Class | Aspose.Slides.Animation Namespace


ColorEffect Constructor

Initializes a new instance of the ColorEffect class.

[Visual Basic]
Public Sub New()
[C#]
public ColorEffect();

See Also

ColorEffect Class | Aspose.Slides.Animation Namespace


ColorEffect Properties

The properties of the ColorEffect class are listed below. For a complete list of ColorEffect class members, see the ColorEffect Members topic.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
By | Describes the relative offset value for the color animation. Read/write ColorFormat.
ColorSpace | Represent color space of behavior. Read/write ColorSpace.
Direction | Specifies which direction to cycle the hue around the color wheel. Read/write ColorDirection.
From | This value is used to specify the starting color of behavior. Read/write ColorFormat.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
To | Describes resulting color for the animation color change. Read/write ColorFormat.

See Also

ColorEffect Class | Aspose.Slides.Animation Namespace


By Property

Aspose.Slides Documentation

ColorEffect.By Property

Describes the relative offset value for the color animation. Read/write ColorFormat.

[Visual Basic]
NotOverridable Public Property By As IColorOffset _
Implements IColorEffect.By
[C#]
public IColorOffset By {get; set;}

Implements

IColorEffect.By

See Also

ColorEffect Class | Aspose.Slides.Animation Namespace


ColorSpace Property

Aspose.Slides Documentation

ColorEffect.ColorSpace Property

Represent color space of behavior. Read/write ColorSpace.

[Visual Basic]
NotOverridable Public Property ColorSpace As ColorSpace _
Implements IColorEffect.ColorSpace
[C#]
public ColorSpace ColorSpace {get; set;}

Implements

IColorEffect.ColorSpace

See Also

ColorEffect Class | Aspose.Slides.Animation Namespace


Direction Property

Aspose.Slides Documentation

ColorEffect.Direction Property

Specifies which direction to cycle the hue around the color wheel. Read/write ColorDirection.

[Visual Basic]
NotOverridable Public Property Direction As ColorDirection _
Implements IColorEffect.Direction
[C#]
public ColorDirection Direction {get; set;}

Implements

IColorEffect.Direction

See Also

ColorEffect Class | Aspose.Slides.Animation Namespace


From Property

Aspose.Slides Documentation

ColorEffect.From Property

This value is used to specify the starting color of behavior. Read/write ColorFormat.

[Visual Basic]
NotOverridable Public Property From As IColorFormat _
Implements IColorEffect.From
[C#]
public IColorFormat From {get; set;}

Implements

IColorEffect.From

See Also

ColorEffect Class | Aspose.Slides.Animation Namespace


To Property

Aspose.Slides Documentation

ColorEffect.To Property

Describes resulting color for the animation color change. Read/write ColorFormat.

[Visual Basic]
NotOverridable Public Property To As IColorFormat _
Implements IColorEffect.To
[C#]
public IColorFormat To {get; set;}

Implements

IColorEffect.To

See Also

ColorEffect Class | Aspose.Slides.Animation Namespace


ColorOffset Class

Represent color offset.

For a list of all members of this type, see ColorOffset Members.

System.Object
Aspose.Slides.Animation.ColorOffset

[Visual Basic]
Public Class ColorOffset
Implements IColorOffset
[C#]
public class ColorOffset : IColorOffset

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ColorOffset Members | Aspose.Slides.Animation Namespace


ColorOffset Members

ColorOffset overview

Public Instance Constructors

ColorOffset Constructor Initializes a new instance of the ColorOffset class.

Public Instance Properties

Value0 | Defines first value of offset. Read/write Single.
Value1 | Defines second value of offset. Read/write Single.
Value2 | Defines third value of offset. Read/write Single.

See Also

ColorOffset Class | Aspose.Slides.Animation Namespace


ColorOffset Constructor

Initializes a new instance of the ColorOffset class.

[Visual Basic]
Public Sub New()
[C#]
public ColorOffset();

See Also

ColorOffset Class | Aspose.Slides.Animation Namespace


ColorOffset Properties

The properties of the ColorOffset class are listed below. For a complete list of ColorOffset class members, see the ColorOffset Members topic.

Public Instance Properties

Value0 | Defines first value of offset. Read/write Single.
Value1 | Defines second value of offset. Read/write Single.
Value2 | Defines third value of offset. Read/write Single.

See Also

ColorOffset Class | Aspose.Slides.Animation Namespace


Value0 Property

Aspose.Slides Documentation

ColorOffset.Value0 Property

Defines first value of offset. Read/write Single.

[Visual Basic]
NotOverridable Public Property Value0 As Single _
Implements IColorOffset.Value0
[C#]
public float Value0 {get; set;}

Implements

IColorOffset.Value0

See Also

ColorOffset Class | Aspose.Slides.Animation Namespace


Value1 Property

Aspose.Slides Documentation

ColorOffset.Value1 Property

Defines second value of offset. Read/write Single.

[Visual Basic]
NotOverridable Public Property Value1 As Single _
Implements IColorOffset.Value1
[C#]
public float Value1 {get; set;}

Implements

IColorOffset.Value1

See Also

ColorOffset Class | Aspose.Slides.Animation Namespace


Value2 Property

Aspose.Slides Documentation

ColorOffset.Value2 Property

Defines third value of offset. Read/write Single.

[Visual Basic]
NotOverridable Public Property Value2 As Single _
Implements IColorOffset.Value2
[C#]
public float Value2 {get; set;}

Implements

IColorOffset.Value2

See Also

ColorOffset Class | Aspose.Slides.Animation Namespace


ColorSpace Enumeration

[Visual Basic]
Public Enum ColorSpace
[C#]
public enum ColorSpace

Members

Member Name | Description | Value
NotDefined |  | -1
RGB |  | 0
HSL |  | 1

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


CommandEffect Class

Represents a command effect for an animation behavior.

For a list of all members of this type, see CommandEffect Members.

System.Object
Aspose.Slides.Animation.Behavior
Aspose.Slides.Animation.CommandEffect

[Visual Basic]
Public Class CommandEffect
Inherits Behavior
Implements ICommandEffect
[C#]
public class CommandEffect : Behavior, ICommandEffect

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

CommandEffect Members | Aspose.Slides.Animation Namespace


CommandEffect Members

CommandEffect overview

Public Instance Constructors

CommandEffect Constructor Initializes a new instance of the CommandEffect class.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
CommandString | Defines command string. Read/write String.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
ShapeTarget | Defines shape target of command effect. Read/write IShape.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
Type | Defines command effect type of behavior. Read/write CommandEffectType.

See Also

CommandEffect Class | Aspose.Slides.Animation Namespace


CommandEffect Constructor

Initializes a new instance of the CommandEffect class.

[Visual Basic]
Public Sub New()
[C#]
public CommandEffect();

See Also

CommandEffect Class | Aspose.Slides.Animation Namespace


CommandEffect Properties

The properties of the CommandEffect class are listed below. For a complete list of CommandEffect class members, see the CommandEffect Members topic.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
CommandString | Defines command string. Read/write String.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
ShapeTarget | Defines shape target of command effect. Read/write IShape.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
Type | Defines command effect type of behavior. Read/write CommandEffectType.

See Also

CommandEffect Class | Aspose.Slides.Animation Namespace


CommandString Property

Aspose.Slides Documentation

CommandEffect.CommandString Property

Defines command string. Read/write String.

[Visual Basic]
NotOverridable Public Property CommandString As String _
Implements ICommandEffect.CommandString
[C#]
public string CommandString {get; set;}

Implements

ICommandEffect.CommandString

See Also

CommandEffect Class | Aspose.Slides.Animation Namespace


ShapeTarget Property

Aspose.Slides Documentation

CommandEffect.ShapeTarget Property

Defines shape target of command effect. Read/write IShape.

[Visual Basic]
NotOverridable Public Property ShapeTarget As IShape _
Implements ICommandEffect.ShapeTarget
[C#]
public IShape ShapeTarget {get; set;}

Implements

ICommandEffect.ShapeTarget

See Also

CommandEffect Class | Aspose.Slides.Animation Namespace


Type Property

Aspose.Slides Documentation

CommandEffect.Type Property

Defines command effect type of behavior. Read/write CommandEffectType.

[Visual Basic]
NotOverridable Public Property Type As CommandEffectType _
Implements ICommandEffect.Type
[C#]
public CommandEffectType Type {get; set;}

Implements

ICommandEffect.Type

See Also

CommandEffect Class | Aspose.Slides.Animation Namespace


CommandEffectType Enumeration

[Visual Basic]
Public Enum CommandEffectType
Inherits
[C#]
public enum CommandEffectType

Members

Member Name | Description | Value
NotDefined |  | -1
Event |  | 0
Call |  | 1
Verb |  | 2

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


Effect Class

Represent animation effect.

For a list of all members of this type, see Effect Members.

System.Object
Aspose.Slides.Animation.Effect

[Visual Basic]
Public Class Effect
Implements IEffect
[C#]
public class Effect : IEffect

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Effect Members | Aspose.Slides.Animation Namespace


Effect Members

Effect overview

Public Instance Properties

Behaviors | Returns collection of behavior for effect. Read/write m_behaviorCollection.
PresetClassType | Defines class of effect. Read/write EffectPresetClassType.
Sequence | Returns a sequence for an effect. Read-only Sequence.
Subtype | Defines subtype of effect. Read/write EffectSubtype.
TextAnimation |
Timing | Defines timing value for effect. Read/write Timing.
Type | Defines type of effect. Read/write EffectType.

See Also

Effect Class | Aspose.Slides.Animation Namespace


Effect Properties

The properties of the Effect class are listed below. For a complete list of Effect class members, see the Effect Members topic.

Public Instance Properties

Behaviors | Returns collection of behavior for effect. Read/write m_behaviorCollection.
PresetClassType | Defines class of effect. Read/write EffectPresetClassType.
Sequence | Returns a sequence for an effect. Read-only Sequence.
Subtype | Defines subtype of effect. Read/write EffectSubtype.
TextAnimation |
Timing | Defines timing value for effect. Read/write Timing.
Type | Defines type of effect. Read/write EffectType.

See Also

Effect Class | Aspose.Slides.Animation Namespace


Behaviors Property

Aspose.Slides Documentation

Effect.Behaviors Property

Returns collection of behavior for effect. Read/write m_behaviorCollection.

[Visual Basic]
NotOverridable Public Property Behaviors As IBehaviorCollection _
Implements IEffect.Behaviors
[C#]
public IBehaviorCollection Behaviors {get; set;}

Implements

IEffect.Behaviors

See Also

Effect Class | Aspose.Slides.Animation Namespace


PresetClassType Property

Aspose.Slides Documentation

Effect.PresetClassType Property

Defines class of effect. Read/write EffectPresetClassType.

[Visual Basic]
NotOverridable Public Property PresetClassType As EffectPresetClassType _
Implements IEffect.PresetClassType
[C#]
public EffectPresetClassType PresetClassType {get; set;}

Implements

IEffect.PresetClassType

See Also

Effect Class | Aspose.Slides.Animation Namespace


Sequence Property

Aspose.Slides Documentation

Effect.Sequence Property

Returns a sequence for an effect. Read-only Sequence.

[Visual Basic]
NotOverridable Public ReadOnly Property Sequence As ISequence _
Implements IEffect.Sequence
[C#]
public ISequence Sequence {get;}

Implements

IEffect.Sequence

See Also

Effect Class | Aspose.Slides.Animation Namespace


Subtype Property

Aspose.Slides Documentation

Effect.Subtype Property

Defines subtype of effect. Read/write EffectSubtype.

[Visual Basic]
NotOverridable Public Property Subtype As EffectSubtype _
Implements IEffect.Subtype
[C#]
public EffectSubtype Subtype {get; set;}

Implements

IEffect.Subtype

See Also

Effect Class | Aspose.Slides.Animation Namespace


TextAnimation Property

Aspose.Slides Documentation

Effect.TextAnimation Property

[Visual Basic]
NotOverridable Public ReadOnly Property TextAnimation As ITextAnimation _
Implements IEffect.TextAnimation
[C#]
public ITextAnimation TextAnimation {get;}

Implements

IEffect.TextAnimation

See Also

Effect Class | Aspose.Slides.Animation Namespace


Timing Property

Aspose.Slides Documentation

Effect.Timing Property

Defines timing value for effect. Read/write Timing.

[Visual Basic]
NotOverridable Public Property Timing As ITiming _
Implements IEffect.Timing
[C#]
public ITiming Timing {get; set;}

Implements

IEffect.Timing

See Also

Effect Class | Aspose.Slides.Animation Namespace


Type Property

Aspose.Slides Documentation

Effect.Type Property

Defines type of effect. Read/write EffectType.

[Visual Basic]
NotOverridable Public Property Type As EffectType _
Implements IEffect.Type
[C#]
public EffectType Type {get; set;}

Implements

IEffect.Type

See Also

Effect Class | Aspose.Slides.Animation Namespace


EffectFillType Enumeration

[Visual Basic]
Public Enum EffectFillType
[C#]
public enum EffectFillType

Members

Member Name | Description | Value
NotDefined |  | -1
Remove |  | 0
Freeze |  | 1
Hold |  | 2
Transition |  | 3

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


EffectPresetClassType Enumeration

[Visual Basic]
Public Enum EffectPresetClassType
[C#]
public enum EffectPresetClassType

Members

Member Name | Description | Value
Entrance |  | 0
Exit |  | 1
Emphasis |  | 2
Path |  | 3
MediaCall |  | 4

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


EffectRestartType Enumeration

[Visual Basic]
Public Enum EffectRestartType
[C#]
public enum EffectRestartType

Members

Member Name | Description | Value
NotDefined |  | -1
Always |  | 0
WhenNotActive |  | 1
Never |  | 2

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


EffectSubtype Enumeration

[Visual Basic]
Public Enum EffectSubtype
[C#]
public enum EffectSubtype

Members

Member Name | Description | Value
None |  | 0
Across |  | 1
Bottom |  | 2
BottomLeft |  | 3
BottomRight |  | 4
Center |  | 5
Clockwise |  | 6
CounterClockwise |  | 7
GradualAndCycleClockwise |  | 8
GradualAndCycleCounterClockwise |  | 9
Down |  | 10
DownLeft |  | 11
DownRight |  | 12
FontAllCaps |  | 13
FontBold |  | 14
FontItalic |  | 15
FontShadow |  | 16
FontStrikethrough |  | 17
FontUnderline |  | 18
Gradual |  | 19
Horizontal |  | 20
HorizontalIn |  | 21
HorizontalOut |  | 22
In |  | 23
InBottom |  | 24
InCenter |  | 25
InSlightly |  | 26
Instant |  | 27
Left |  | 28
OrdinalMask |  | 29
Out |  | 30
OutBottom |  | 31
OutCenter |  | 32
OutSlightly |  | 33
Right |  | 34
Slightly |  | 35
Top |  | 36
TopLeft |  | 37
TopRight |  | 38
Up |  | 39
UpLeft |  | 40
UpRight |  | 41
Vertical |  | 42
VerticalIn |  | 43
VerticalOut |  | 44
Wheel1 |  | 45
Wheel2 |  | 46
Wheel3 |  | 47
Wheel4 |  | 48
Wheel8 |  | 49

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


EffectTriggerType Enumeration

[Visual Basic]
Public Enum EffectTriggerType
[C#]
public enum EffectTriggerType

Members

Member Name | Description | Value
AfterPrevious |  | 0
OnClick |  | 1
WithPrevious |  | 2

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


EffectType Enumeration

[Visual Basic]
Public Enum EffectType
[C#]
public enum EffectType

Members

Member Name | Description | Value
Appear |  | 0
CurveUpDown |  | 1
Ascend |  | 2
Blast |  | 3
Blinds |  | 4
Blink |  | 5
BoldFlash |  | 6
BoldReveal |  | 7
Boomerang |  | 8
Bounce |  | 9
Box |  | 10
BrushOnColor |  | 11
BrushOnUnderline |  | 12
CenterRevolve |  | 13
ChangeFillColor |  | 14
ChangeFont |  | 15
ChangeFontColor |  | 16
ChangeFontSize |  | 17
ChangeFontStyle |  | 18
ChangeLineColor |  | 19
Checkerboard |  | 20
Circle |  | 21
ColorBlend |  | 22
ColorTypewriter |  | 23
ColorWave |  | 24
ComplementaryColor |  | 25
ComplementaryColor2 |  | 26
Compress |  | 27
ContrastingColor |  | 28
Crawl |  | 29
Credits |  | 30
Custom |  | 31
Darken |  | 32
Desaturate |  | 33
Descend |  | 34
Diamond |  | 35
Dissolve |  | 36
EaseInOut |  | 37
Expand |  | 38
Fade |  | 39
FadedSwivel |  | 40
FadedZoom |  | 41
FlashBulb |  | 42
FlashOnce |  | 43
Flicker |  | 44
Flip |  | 45
Float |  | 46
Fly |  | 47
Fold |  | 48
Glide |  | 49
GrowAndTurn |  | 50
GrowShrink |  | 51
GrowWithColor |  | 52
Lighten |  | 53
LightSpeed |  | 54
MediaPause |  | 55
MediaPlay |  | 56
MediaStop |  | 57
Path4PointStar |  | 58
Path5PointStar |  | 59
Path6PointStar |  | 60
Path8PointStar |  | 61
PathArcDown |  | 62
PathArcLeft |  | 63
PathArcRight |  | 64
PathArcUp |  | 65
PathBean |  | 66
PathBounceLeft |  | 67
PathBounceRight |  | 68
PathBuzzsaw |  | 69
PathCircle |  | 70
PathCrescentMoon |  | 71
PathCurvedSquare |  | 72
PathCurvedX |  | 73
PathCurvyLeft |  | 74
PathCurvyRight |  | 75
PathCurvyStar |  | 76
PathDecayingWave |  | 77
PathDiagonalDownRight |  | 78
PathDiagonalUpRight |  | 79
PathDiamond |  | 80
PathDown |  | 81
PathEqualTriangle |  | 82
PathFigure8Four |  | 83
PathFootball |  | 84
PathFunnel |  | 85
PathHeart |  | 86
PathHeartbeat |  | 87
PathHexagon |  | 88
PathHorizontalFigure8 |  | 89
PathInvertedSquare |  | 90
PathInvertedTriangle |  | 91
PathLeft |  | 92
PathLoopdeLoop |  | 93
PathNeutron |  | 94
PathOctagon |  | 95
PathParallelogram |  | 96
PathPeanut |  | 97
PathPentagon |  | 98
PathPlus |  | 99
PathPointyStar |  | 100
PathRight |  | 101
PathRightTriangle |  | 102
PathSCurve1 |  | 103
PathSCurve2 |  | 104
PathSineWave |  | 105
PathSpiralLeft |  | 106
PathSpiralRight |  | 107
PathSpring |  | 108
PathSquare |  | 109
PathStairsDown |  | 110
PathSwoosh |  | 111
PathTeardrop |  | 112
PathTrapezoid |  | 113
PathTurnDown |  | 114
PathTurnRight |  | 115
PathTurnUp |  | 116
PathTurnUpRight |  | 117
PathUp |  | 118
PathUser |  | 119
PathVerticalFigure8 |  | 120
PathWave |  | 121
PathZigzag |  | 122
Peek |  | 123
Pinwheel |  | 124
Plus |  | 125
RandomBars |  | 126
RandomEffects |  | 127
RiseUp |  | 128
Shimmer |  | 129
Sling |  | 130
Spin |  | 131
Spinner |  | 132
Spiral |  | 133
Split |  | 134
Stretch |  | 135
Strips |  | 136
StyleEmphasis |  | 137
Swish |  | 138
Swivel |  | 139
Teeter |  | 140
Thread |  | 141
Transparency |  | 142
Unfold |  | 143
VerticalGrow |  | 144
Wave |  | 145
Wedge |  | 146
Wheel |  | 147
Whip |  | 148
Wipe |  | 149
Magnify |  | 150
Zoom |  | 151

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


FilterEffect Class

Represent filter effect of behavior.

For a list of all members of this type, see FilterEffect Members.

System.Object
Aspose.Slides.Animation.Behavior
Aspose.Slides.Animation.FilterEffect

[Visual Basic]
Public Class FilterEffect
Inherits Behavior
Implements IFilterEffect
[C#]
public class FilterEffect : Behavior, IFilterEffect

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FilterEffect Members | Aspose.Slides.Animation Namespace


FilterEffect Members

FilterEffect overview

Public Instance Constructors

FilterEffect Constructor Default constructor.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
Reveal | Represents that effect with behavior must reveal (in/out) Read/write FilterEffectRevealType.
Subtype | Represents subtype of filter effect. Read/write FilterEffectSubtype.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
Type | Represents type of filter effect. Read/write FilterEffectType.

See Also

FilterEffect Class | Aspose.Slides.Animation Namespace


FilterEffect Constructor

Default constructor.

[Visual Basic]
Public Sub New()
[C#]
public FilterEffect();

See Also

FilterEffect Class | Aspose.Slides.Animation Namespace


FilterEffect Properties

The properties of the FilterEffect class are listed below. For a complete list of FilterEffect class members, see the FilterEffect Members topic.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
Reveal | Represents that effect with behavior must reveal (in/out) Read/write FilterEffectRevealType.
Subtype | Represents subtype of filter effect. Read/write FilterEffectSubtype.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
Type | Represents type of filter effect. Read/write FilterEffectType.

See Also

FilterEffect Class | Aspose.Slides.Animation Namespace


Reveal Property

Aspose.Slides Documentation

FilterEffect.Reveal Property

Represents that effect with behavior must reveal (in/out) Read/write FilterEffectRevealType.

[Visual Basic]
NotOverridable Public Property Reveal As FilterEffectRevealType _
Implements IFilterEffect.Reveal
[C#]
public FilterEffectRevealType Reveal {get; set;}

Implements

IFilterEffect.Reveal

See Also

FilterEffect Class | Aspose.Slides.Animation Namespace


Subtype Property

Aspose.Slides Documentation

FilterEffect.Subtype Property

Represents subtype of filter effect. Read/write FilterEffectSubtype.

[Visual Basic]
NotOverridable Public Property Subtype As FilterEffectSubtype _
Implements IFilterEffect.Subtype
[C#]
public FilterEffectSubtype Subtype {get; set;}

Implements

IFilterEffect.Subtype

See Also

FilterEffect Class | Aspose.Slides.Animation Namespace


Type Property

Aspose.Slides Documentation

FilterEffect.Type Property

Represents type of filter effect. Read/write FilterEffectType.

[Visual Basic]
NotOverridable Public Property Type As FilterEffectType _
Implements IFilterEffect.Type
[C#]
public FilterEffectType Type {get; set;}

Implements

IFilterEffect.Type

See Also

FilterEffect Class | Aspose.Slides.Animation Namespace


FilterEffectRevealType Enumeration

[Visual Basic]
Public Enum FilterEffectRevealType
[C#]
public enum FilterEffectRevealType

Members

Member Name | Description | Value
NotDefined |  | -1
None |  | 0
In |  | 1
Out |  | 2

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


FilterEffectSubtype Enumeration

[Visual Basic]
Public Enum FilterEffectSubtype
[C#]
public enum FilterEffectSubtype

Members

Member Name | Description | Value
None |  | 0
Across |  | 1
Down |  | 2
DownLeft |  | 3
DownRight |  | 4
FromBottom |  | 5
FromLeft |  | 6
FromRight |  | 7
FromTop |  | 8
Horizontal |  | 9
In |  | 10
InHorizontal |  | 11
InVertical |  | 12
Left |  | 13
Out |  | 14
OutHorizontal |  | 15
OutVertical |  | 16
Right |  | 17
Spokes1 |  | 18
Spokes2 |  | 19
Spokes3 |  | 20
Spokes4 |  | 21
Spokes8 |  | 22
Up |  | 23
UpLeft |  | 24
UpRight |  | 25
Vertical |  | 26

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


FilterEffectType Enumeration

[Visual Basic]
Public Enum FilterEffectType
[C#]
public enum FilterEffectType

Members

Member Name | Description | Value
None |  | 0
Barn |  | 1
Blinds |  | 2
Box |  | 3
Checkerboard |  | 4
Circle |  | 5
Diamond |  | 6
Dissolve |  | 7
Fade |  | 8
Image |  | 9
Pixelate |  | 10
Plus |  | 11
RandomBar |  | 12
Slide |  | 13
Stretch |  | 14
Strips |  | 15
Wedge |  | 16
Wheel |  | 17
Wipe |  | 18

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


IBehavior Interface

For a list of all members of this type, see IBehavior Members.

Aspose.Slides.Animation.IBehavior
Derived interfaces

[Visual Basic]
Public Interface IBehavior
[C#]
public interface IBehavior

Types that implement IBehavior

Type | Description
Behavior | Represent base class behavior of effect.
ColorEffect | Represents a color effect for an animation behavior.
CommandEffect | Represents a command effect for an animation behavior.
FilterEffect | Represent filter effect of behavior.
MotionEffect | Represent motion effect behavior of effect.
PropertyEffect | Represent property effect behavior.
RotationEffect | Represent rotation behavior of effect.
ScaleEffect | Represents animation scale effect.
SetEffect | Represents a set effect for an animation behavior.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBehavior Members | Aspose.Slides.Animation Namespace


IBehavior Members

IBehavior overview

Public Instance Properties

Accumulate
Additive
Properties
Timing

See Also

IBehavior Interface | Aspose.Slides.Animation Namespace


IBehavior Properties

The properties of the IBehavior interface are listed below. For a complete list of IBehavior interface members, see the IBehavior Members topic.

Public Instance Properties

Accumulate
Additive
Properties
Timing

See Also

IBehavior Interface | Aspose.Slides.Animation Namespace


Accumulate Property

Aspose.Slides Documentation

IBehavior.Accumulate Property

[Visual Basic]
Property Accumulate As NullableBool
[C#]
NullableBool Accumulate {get; set;}

See Also

IBehavior Interface | Aspose.Slides.Animation Namespace


Additive Property

Aspose.Slides Documentation

IBehavior.Additive Property

[Visual Basic]
Property Additive As BehaviorAdditiveType
[C#]
BehaviorAdditiveType Additive {get; set;}

See Also

IBehavior Interface | Aspose.Slides.Animation Namespace


Properties Property

Aspose.Slides Documentation

IBehavior.Properties Property

[Visual Basic]
Property Properties As IBehaviorProperties
[C#]
IBehaviorProperties Properties {get;}

See Also

IBehavior Interface | Aspose.Slides.Animation Namespace


Timing Property

Aspose.Slides Documentation

IBehavior.Timing Property

[Visual Basic]
Property Timing As ITiming
[C#]
ITiming Timing {get; set;}

See Also

IBehavior Interface | Aspose.Slides.Animation Namespace


IBehaviorCollection Interface

For a list of all members of this type, see IBehaviorCollection Members.

[Visual Basic]
Public Interface IBehaviorCollection
Implements IEnumerable`1([Aspose.Slides.Animation.IBehavior, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public interface IBehaviorCollection : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Types that implement IBehaviorCollection

Type | Description
BehaviorCollection | Represents collection of behavior effects.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBehaviorCollection Members | Aspose.Slides.Animation Namespace


IBehaviorCollection Members

IBehaviorCollection overview

Public Instance Properties

AsIEnumerable
Count
Item

Public Instance Methods

Add
Clear
Contains
IndexOf
Insert
Remove
RemoveAt

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


IBehaviorCollection Properties

The properties of the IBehaviorCollection interface are listed below. For a complete list of IBehaviorCollection interface members, see the IBehaviorCollection Members topic.

Public Instance Properties

AsIEnumerable
Count
Item

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IBehaviorCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


Count Property

Aspose.Slides Documentation

IBehaviorCollection.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

IBehaviorCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IBehavior
[C#]
IBehavior this[
int index
] {get; set;}

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


IBehaviorCollection Methods

The methods of the IBehaviorCollection interface are listed below. For a complete list of IBehaviorCollection interface members, see the IBehaviorCollection Members topic.

Public Instance Methods

Add
Clear
Contains
IndexOf
Insert
Remove
RemoveAt

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


IBehaviorCollection.Add Method

[Visual Basic]
Sub Add( _
ByVal item As IBehavior _
)
[C#]
void Add(
IBehavior item
);

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


IBehaviorCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


IBehaviorCollection.Contains Method

[Visual Basic]
Function Contains( _
ByVal item As IBehavior _
) As Boolean
[C#]
bool Contains(
IBehavior item
);

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


IBehaviorCollection.IndexOf Method

[Visual Basic]
Function IndexOf( _
ByVal item As IBehavior _
) As Integer
[C#]
int IndexOf(
IBehavior item
);

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


IBehaviorCollection.Insert Method

[Visual Basic]
Sub Insert( _
ByVal index As Integer, _
ByVal item As IBehavior _
)
[C#]
void Insert(
int index,
IBehavior item
);

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


IBehaviorCollection.Remove Method

[Visual Basic]
Function Remove( _
ByVal item As IBehavior _
) As Boolean
[C#]
bool Remove(
IBehavior item
);

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


IBehaviorCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IBehaviorCollection Interface | Aspose.Slides.Animation Namespace


IBehaviorFactory Interface

For a list of all members of this type, see IBehaviorFactory Members.

[Visual Basic]
Public Interface IBehaviorFactory
[C#]
public interface IBehaviorFactory

Types that implement IBehaviorFactory

Type | Description
BehaviorFactory | Allows to create animation effects

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBehaviorFactory Members | Aspose.Slides.Animation Namespace


IBehaviorFactory Members

IBehaviorFactory overview

Public Instance Methods

CreateColorEffect
CreateCommandEffect
CreateFilterEffect
CreateMotionEffect
CreatePropertyEffect
CreateRotationEffect
CreateScaleEffect
CreateSetEffect

See Also

IBehaviorFactory Interface | Aspose.Slides.Animation Namespace


IBehaviorFactory Methods

The methods of the IBehaviorFactory interface are listed below. For a complete list of IBehaviorFactory interface members, see the IBehaviorFactory Members topic.

Public Instance Methods

CreateColorEffect
CreateCommandEffect
CreateFilterEffect
CreateMotionEffect
CreatePropertyEffect
CreateRotationEffect
CreateScaleEffect
CreateSetEffect

See Also

IBehaviorFactory Interface | Aspose.Slides.Animation Namespace


IBehaviorFactory.CreateColorEffect Method

[Visual Basic]
Function CreateColorEffect() As IColorEffect
[C#]
IColorEffect CreateColorEffect();

See Also

IBehaviorFactory Interface | Aspose.Slides.Animation Namespace


IBehaviorFactory.CreateCommandEffect Method

[Visual Basic]
Function CreateCommandEffect() As ICommandEffect
[C#]
ICommandEffect CreateCommandEffect();

See Also

IBehaviorFactory Interface | Aspose.Slides.Animation Namespace


IBehaviorFactory.CreateFilterEffect Method

[Visual Basic]
Function CreateFilterEffect() As IFilterEffect
[C#]
IFilterEffect CreateFilterEffect();

See Also

IBehaviorFactory Interface | Aspose.Slides.Animation Namespace


IBehaviorFactory.CreateMotionEffect Method

[Visual Basic]
Function CreateMotionEffect() As IMotionEffect
[C#]
IMotionEffect CreateMotionEffect();

See Also

IBehaviorFactory Interface | Aspose.Slides.Animation Namespace


IBehaviorFactory.CreatePropertyEffect Method

[Visual Basic]
Function CreatePropertyEffect() As IPropertyEffect
[C#]
IPropertyEffect CreatePropertyEffect();

See Also

IBehaviorFactory Interface | Aspose.Slides.Animation Namespace


IBehaviorFactory.CreateRotationEffect Method

[Visual Basic]
Function CreateRotationEffect() As IRotationEffect
[C#]
IRotationEffect CreateRotationEffect();

See Also

IBehaviorFactory Interface | Aspose.Slides.Animation Namespace


IBehaviorFactory.CreateScaleEffect Method

[Visual Basic]
Function CreateScaleEffect() As IScaleEffect
[C#]
IScaleEffect CreateScaleEffect();

See Also

IBehaviorFactory Interface | Aspose.Slides.Animation Namespace


IBehaviorFactory.CreateSetEffect Method

[Visual Basic]
Function CreateSetEffect() As ISetEffect
[C#]
ISetEffect CreateSetEffect();

See Also

IBehaviorFactory Interface | Aspose.Slides.Animation Namespace


IBehaviorProperties Interface

For a list of all members of this type, see IBehaviorProperties Members.

[Visual Basic]
Public Interface IBehaviorProperties
Implements IList`1([Aspose.Slides.Animation.PropertyType, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), ICollection`1([Aspose.Slides.Animation.PropertyType, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable`1([Aspose.Slides.Animation.PropertyType, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public interface IBehaviorProperties : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Types that implement IBehaviorProperties

Type | Description
BehaviorProperties | Represents timing properties for the effect behavior.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBehaviorProperties Members | Aspose.Slides.Animation Namespace


IBehaviorProperties Members

IBehaviorProperties overview

Public Instance Properties

AsIEnumerable

See Also

IBehaviorProperties Interface | Aspose.Slides.Animation Namespace


IBehaviorProperties Properties

The properties of the IBehaviorProperties interface are listed below. For a complete list of IBehaviorProperties interface members, see the IBehaviorProperties Members topic.

Public Instance Properties

AsIEnumerable

See Also

IBehaviorProperties Interface | Aspose.Slides.Animation Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IBehaviorProperties.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IBehaviorProperties Interface | Aspose.Slides.Animation Namespace


IColorEffect Interface

For a list of all members of this type, see IColorEffect Members.

[Visual Basic]
Public Interface IColorEffect
Implements IBehavior
[C#]
public interface IColorEffect : IBehavior

Types that implement IColorEffect

Type | Description
ColorEffect | Represents a color effect for an animation behavior.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColorEffect Members | Aspose.Slides.Animation Namespace


IColorEffect Members

IColorEffect overview

Public Instance Properties

AsIBehavior
By
ColorSpace
Direction
From
To

See Also

IColorEffect Interface | Aspose.Slides.Animation Namespace


IColorEffect Properties

The properties of the IColorEffect interface are listed below. For a complete list of IColorEffect interface members, see the IColorEffect Members topic.

Public Instance Properties

AsIBehavior
By
ColorSpace
Direction
From
To

See Also

IColorEffect Interface | Aspose.Slides.Animation Namespace


AsIBehavior Property

Aspose.Slides Documentation

IColorEffect.AsIBehavior Property

[Visual Basic]
Property AsIBehavior As IBehavior
[C#]
IBehavior AsIBehavior {get;}

See Also

IColorEffect Interface | Aspose.Slides.Animation Namespace


By Property

Aspose.Slides Documentation

IColorEffect.By Property

[Visual Basic]
Property By As IColorOffset
[C#]
IColorOffset By {get; set;}

See Also

IColorEffect Interface | Aspose.Slides.Animation Namespace


ColorSpace Property

Aspose.Slides Documentation

IColorEffect.ColorSpace Property

[Visual Basic]
Property ColorSpace As ColorSpace
[C#]
ColorSpace ColorSpace {get; set;}

See Also

IColorEffect Interface | Aspose.Slides.Animation Namespace


Direction Property

Aspose.Slides Documentation

IColorEffect.Direction Property

[Visual Basic]
Property Direction As ColorDirection
[C#]
ColorDirection Direction {get; set;}

See Also

IColorEffect Interface | Aspose.Slides.Animation Namespace


From Property

Aspose.Slides Documentation

IColorEffect.From Property

[Visual Basic]
Property From As IColorFormat
[C#]
IColorFormat From {get; set;}

See Also

IColorEffect Interface | Aspose.Slides.Animation Namespace


To Property

Aspose.Slides Documentation

IColorEffect.To Property

[Visual Basic]
Property To As IColorFormat
[C#]
IColorFormat To {get; set;}

See Also

IColorEffect Interface | Aspose.Slides.Animation Namespace


IColorOffset Interface

For a list of all members of this type, see IColorOffset Members.

[Visual Basic]
Public Interface IColorOffset
[C#]
public interface IColorOffset

Types that implement IColorOffset

Type | Description
ColorOffset | Represent color offset.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColorOffset Members | Aspose.Slides.Animation Namespace


IColorOffset Members

IColorOffset overview

Public Instance Properties

Value0
Value1
Value2

See Also

IColorOffset Interface | Aspose.Slides.Animation Namespace


IColorOffset Properties

The properties of the IColorOffset interface are listed below. For a complete list of IColorOffset interface members, see the IColorOffset Members topic.

Public Instance Properties

Value0
Value1
Value2

See Also

IColorOffset Interface | Aspose.Slides.Animation Namespace


Value0 Property

Aspose.Slides Documentation

IColorOffset.Value0 Property

[Visual Basic]
Property Value0 As Single
[C#]
float Value0 {get; set;}

See Also

IColorOffset Interface | Aspose.Slides.Animation Namespace


Value1 Property

Aspose.Slides Documentation

IColorOffset.Value1 Property

[Visual Basic]
Property Value1 As Single
[C#]
float Value1 {get; set;}

See Also

IColorOffset Interface | Aspose.Slides.Animation Namespace


Value2 Property

Aspose.Slides Documentation

IColorOffset.Value2 Property

[Visual Basic]
Property Value2 As Single
[C#]
float Value2 {get; set;}

See Also

IColorOffset Interface | Aspose.Slides.Animation Namespace


ICommandEffect Interface

For a list of all members of this type, see ICommandEffect Members.

[Visual Basic]
Public Interface ICommandEffect
Implements IBehavior
[C#]
public interface ICommandEffect : IBehavior

Types that implement ICommandEffect

Type | Description
CommandEffect | Represents a command effect for an animation behavior.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ICommandEffect Members | Aspose.Slides.Animation Namespace


ICommandEffect Members

ICommandEffect overview

Public Instance Properties

AsIBehavior
CommandString
ShapeTarget
Type

See Also

ICommandEffect Interface | Aspose.Slides.Animation Namespace


ICommandEffect Properties

The properties of the ICommandEffect interface are listed below. For a complete list of ICommandEffect interface members, see the ICommandEffect Members topic.

Public Instance Properties

AsIBehavior
CommandString
ShapeTarget
Type

See Also

ICommandEffect Interface | Aspose.Slides.Animation Namespace


AsIBehavior Property

Aspose.Slides Documentation

ICommandEffect.AsIBehavior Property

[Visual Basic]
Property AsIBehavior As IBehavior
[C#]
IBehavior AsIBehavior {get;}

See Also

ICommandEffect Interface | Aspose.Slides.Animation Namespace


CommandString Property

Aspose.Slides Documentation

ICommandEffect.CommandString Property

[Visual Basic]
Property CommandString As String
[C#]
string CommandString {get; set;}

See Also

ICommandEffect Interface | Aspose.Slides.Animation Namespace


ShapeTarget Property

Aspose.Slides Documentation

ICommandEffect.ShapeTarget Property

[Visual Basic]
Property ShapeTarget As IShape
[C#]
IShape ShapeTarget {get; set;}

See Also

ICommandEffect Interface | Aspose.Slides.Animation Namespace


Type Property

Aspose.Slides Documentation

ICommandEffect.Type Property

[Visual Basic]
Property Type As CommandEffectType
[C#]
CommandEffectType Type {get; set;}

See Also

ICommandEffect Interface | Aspose.Slides.Animation Namespace


IEffect Interface

For a list of all members of this type, see IEffect Members.

[Visual Basic]
Public Interface IEffect
[C#]
public interface IEffect

Types that implement IEffect

Type | Description
Effect | Represent animation effect.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IEffect Members | Aspose.Slides.Animation Namespace


IEffect Members

IEffect overview

Public Instance Properties

Behaviors
PresetClassType
Sequence
Subtype
TextAnimation
Timing
Type

See Also

IEffect Interface | Aspose.Slides.Animation Namespace


IEffect Properties

The properties of the IEffect interface are listed below. For a complete list of IEffect interface members, see the IEffect Members topic.

Public Instance Properties

Behaviors
PresetClassType
Sequence
Subtype
TextAnimation
Timing
Type

See Also

IEffect Interface | Aspose.Slides.Animation Namespace


Behaviors Property

Aspose.Slides Documentation

IEffect.Behaviors Property

[Visual Basic]
Property Behaviors As IBehaviorCollection
[C#]
IBehaviorCollection Behaviors {get; set;}

See Also

IEffect Interface | Aspose.Slides.Animation Namespace


PresetClassType Property

Aspose.Slides Documentation

IEffect.PresetClassType Property

[Visual Basic]
Property PresetClassType As EffectPresetClassType
[C#]
EffectPresetClassType PresetClassType {get; set;}

See Also

IEffect Interface | Aspose.Slides.Animation Namespace


Sequence Property

Aspose.Slides Documentation

IEffect.Sequence Property

[Visual Basic]
Property Sequence As ISequence
[C#]
ISequence Sequence {get;}

See Also

IEffect Interface | Aspose.Slides.Animation Namespace


Subtype Property

Aspose.Slides Documentation

IEffect.Subtype Property

[Visual Basic]
Property Subtype As EffectSubtype
[C#]
EffectSubtype Subtype {get; set;}

See Also

IEffect Interface | Aspose.Slides.Animation Namespace


TextAnimation Property

Aspose.Slides Documentation

IEffect.TextAnimation Property

[Visual Basic]
Property TextAnimation As ITextAnimation
[C#]
ITextAnimation TextAnimation {get;}

See Also

IEffect Interface | Aspose.Slides.Animation Namespace


Timing Property

Aspose.Slides Documentation

IEffect.Timing Property

[Visual Basic]
Property Timing As ITiming
[C#]
ITiming Timing {get; set;}

See Also

IEffect Interface | Aspose.Slides.Animation Namespace


Type Property

Aspose.Slides Documentation

IEffect.Type Property

[Visual Basic]
Property Type As EffectType
[C#]
EffectType Type {get; set;}

See Also

IEffect Interface | Aspose.Slides.Animation Namespace


IFilterEffect Interface

For a list of all members of this type, see IFilterEffect Members.

[Visual Basic]
Public Interface IFilterEffect
Implements IBehavior
[C#]
public interface IFilterEffect : IBehavior

Types that implement IFilterEffect

Type | Description
FilterEffect | Represent filter effect of behavior.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFilterEffect Members | Aspose.Slides.Animation Namespace


IFilterEffect Members

IFilterEffect overview

Public Instance Properties

AsIBehavior
Reveal
Subtype
Type

See Also

IFilterEffect Interface | Aspose.Slides.Animation Namespace


IFilterEffect Properties

The properties of the IFilterEffect interface are listed below. For a complete list of IFilterEffect interface members, see the IFilterEffect Members topic.

Public Instance Properties

AsIBehavior
Reveal
Subtype
Type

See Also

IFilterEffect Interface | Aspose.Slides.Animation Namespace


AsIBehavior Property

Aspose.Slides Documentation

IFilterEffect.AsIBehavior Property

[Visual Basic]
Property AsIBehavior As IBehavior
[C#]
IBehavior AsIBehavior {get;}

See Also

IFilterEffect Interface | Aspose.Slides.Animation Namespace


Reveal Property

Aspose.Slides Documentation

IFilterEffect.Reveal Property

[Visual Basic]
Property Reveal As FilterEffectRevealType
[C#]
FilterEffectRevealType Reveal {get; set;}

See Also

IFilterEffect Interface | Aspose.Slides.Animation Namespace


Subtype Property

Aspose.Slides Documentation

IFilterEffect.Subtype Property

[Visual Basic]
Property Subtype As FilterEffectSubtype
[C#]
FilterEffectSubtype Subtype {get; set;}

See Also

IFilterEffect Interface | Aspose.Slides.Animation Namespace


Type Property

Aspose.Slides Documentation

IFilterEffect.Type Property

[Visual Basic]
Property Type As FilterEffectType
[C#]
FilterEffectType Type {get; set;}

See Also

IFilterEffect Interface | Aspose.Slides.Animation Namespace


IMotionCmdPath Interface

For a list of all members of this type, see IMotionCmdPath Members.

[Visual Basic]
Public Interface IMotionCmdPath
[C#]
public interface IMotionCmdPath

Types that implement IMotionCmdPath

Type | Description
MotionCmdPath | Represent one command of a path.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMotionCmdPath Members | Aspose.Slides.Animation Namespace


IMotionCmdPath Members

IMotionCmdPath overview

Public Instance Properties

CommandType
IsRelative
Points
PointsType

See Also

IMotionCmdPath Interface | Aspose.Slides.Animation Namespace


IMotionCmdPath Properties

The properties of the IMotionCmdPath interface are listed below. For a complete list of IMotionCmdPath interface members, see the IMotionCmdPath Members topic.

Public Instance Properties

CommandType
IsRelative
Points
PointsType

See Also

IMotionCmdPath Interface | Aspose.Slides.Animation Namespace


CommandType Property

Aspose.Slides Documentation

IMotionCmdPath.CommandType Property

[Visual Basic]
Property CommandType As MotionCommandPathType
[C#]
MotionCommandPathType CommandType {get; set;}

See Also

IMotionCmdPath Interface | Aspose.Slides.Animation Namespace


IsRelative Property

Aspose.Slides Documentation

IMotionCmdPath.IsRelative Property

[Visual Basic]
Property IsRelative As Boolean
[C#]
bool IsRelative {get; set;}

See Also

IMotionCmdPath Interface | Aspose.Slides.Animation Namespace


Points Property

Aspose.Slides Documentation

IMotionCmdPath.Points Property

[Visual Basic]
Property Points As PointF()
[C#]
PointF[] Points {get; set;}

See Also

IMotionCmdPath Interface | Aspose.Slides.Animation Namespace


PointsType Property

Aspose.Slides Documentation

IMotionCmdPath.PointsType Property

[Visual Basic]
Property PointsType As MotionPathPointsType
[C#]
MotionPathPointsType PointsType {get; set;}

See Also

IMotionCmdPath Interface | Aspose.Slides.Animation Namespace


IMotionEffect Interface

For a list of all members of this type, see IMotionEffect Members.

[Visual Basic]
Public Interface IMotionEffect
Implements IBehavior
[C#]
public interface IMotionEffect : IBehavior

Types that implement IMotionEffect

Type | Description
MotionEffect | Represent motion effect behavior of effect.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMotionEffect Members | Aspose.Slides.Animation Namespace


IMotionEffect Members

IMotionEffect overview

Public Instance Properties

Angle
AsIBehavior
By
From
Origin
Path
PathEditMode
RotationCenter
To

See Also

IMotionEffect Interface | Aspose.Slides.Animation Namespace


IMotionEffect Properties

The properties of the IMotionEffect interface are listed below. For a complete list of IMotionEffect interface members, see the IMotionEffect Members topic.

Public Instance Properties

Angle
AsIBehavior
By
From
Origin
Path
PathEditMode
RotationCenter
To

See Also

IMotionEffect Interface | Aspose.Slides.Animation Namespace


Angle Property

Aspose.Slides Documentation

IMotionEffect.Angle Property

[Visual Basic]
Property Angle As Single
[C#]
float Angle {get; set;}

See Also

IMotionEffect Interface | Aspose.Slides.Animation Namespace


AsIBehavior Property

Aspose.Slides Documentation

IMotionEffect.AsIBehavior Property

[Visual Basic]
Property AsIBehavior As IBehavior
[C#]
IBehavior AsIBehavior {get;}

See Also

IMotionEffect Interface | Aspose.Slides.Animation Namespace


By Property

Aspose.Slides Documentation

IMotionEffect.By Property

[Visual Basic]
Property By As PointF
[C#]
PointF By {get; set;}

See Also

IMotionEffect Interface | Aspose.Slides.Animation Namespace


From Property

Aspose.Slides Documentation

IMotionEffect.From Property

[Visual Basic]
Property From As PointF
[C#]
PointF From {get; set;}

See Also

IMotionEffect Interface | Aspose.Slides.Animation Namespace


Origin Property

Aspose.Slides Documentation

IMotionEffect.Origin Property

[Visual Basic]
Property Origin As MotionOriginType
[C#]
MotionOriginType Origin {get; set;}

See Also

IMotionEffect Interface | Aspose.Slides.Animation Namespace


Path Property

Aspose.Slides Documentation

IMotionEffect.Path Property

[Visual Basic]
Property Path As IMotionPath
[C#]
IMotionPath Path {get; set;}

See Also

IMotionEffect Interface | Aspose.Slides.Animation Namespace


PathEditMode Property

Aspose.Slides Documentation

IMotionEffect.PathEditMode Property

[Visual Basic]
Property PathEditMode As MotionPathEditMode
[C#]
MotionPathEditMode PathEditMode {get; set;}

See Also

IMotionEffect Interface | Aspose.Slides.Animation Namespace


RotationCenter Property

Aspose.Slides Documentation

IMotionEffect.RotationCenter Property

[Visual Basic]
Property RotationCenter As PointF
[C#]
PointF RotationCenter {get; set;}

See Also

IMotionEffect Interface | Aspose.Slides.Animation Namespace


To Property

Aspose.Slides Documentation

IMotionEffect.To Property

[Visual Basic]
Property To As PointF
[C#]
PointF To {get; set;}

See Also

IMotionEffect Interface | Aspose.Slides.Animation Namespace


IMotionPath Interface

For a list of all members of this type, see IMotionPath Members.

[Visual Basic]
Public Interface IMotionPath
Implements IEnumerable`1([Aspose.Slides.Animation.IMotionCmdPath, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public interface IMotionPath : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Types that implement IMotionPath

Type | Description
MotionPath | Represent motion path.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMotionPath Members | Aspose.Slides.Animation Namespace


IMotionPath Members

IMotionPath overview

Public Instance Properties

AsIEnumerable
Count
Item

Public Instance Methods

Add
Clear
Insert
Remove
RemoveAt

See Also

IMotionPath Interface | Aspose.Slides.Animation Namespace


IMotionPath Properties

The properties of the IMotionPath interface are listed below. For a complete list of IMotionPath interface members, see the IMotionPath Members topic.

Public Instance Properties

AsIEnumerable
Count
Item

See Also

IMotionPath Interface | Aspose.Slides.Animation Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IMotionPath.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IMotionPath Interface | Aspose.Slides.Animation Namespace


Count Property

Aspose.Slides Documentation

IMotionPath.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

IMotionPath Interface | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

IMotionPath.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IMotionCmdPath
[C#]
IMotionCmdPath this[
int index
] {get;}

See Also

IMotionPath Interface | Aspose.Slides.Animation Namespace


IMotionPath Methods

The methods of the IMotionPath interface are listed below. For a complete list of IMotionPath interface members, see the IMotionPath Members topic.

Public Instance Methods

Add
Clear
Insert
Remove
RemoveAt

See Also

IMotionPath Interface | Aspose.Slides.Animation Namespace


IMotionPath.Add Method

[Visual Basic]
Function Add( _
ByVal type As MotionCommandPathType, _
ByVal pts As PointF(), _
ByVal ptsType As MotionPathPointsType, _
ByVal bRelativeCoord As Boolean _
) As IMotionCmdPath
[C#]
IMotionCmdPath Add(
MotionCommandPathType type,
PointF[] pts,
MotionPathPointsType ptsType,
bool bRelativeCoord
);

See Also

IMotionPath Interface | Aspose.Slides.Animation Namespace


IMotionPath.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

IMotionPath Interface | Aspose.Slides.Animation Namespace


IMotionPath.Insert Method

[Visual Basic]
Sub Insert( _
ByVal index As Integer, _
ByVal type As MotionCommandPathType, _
ByVal pts As PointF(), _
ByVal ptsType As MotionPathPointsType, _
ByVal bRelativeCoord As Boolean _
)
[C#]
void Insert(
int index,
MotionCommandPathType type,
PointF[] pts,
MotionPathPointsType ptsType,
bool bRelativeCoord
);

See Also

IMotionPath Interface | Aspose.Slides.Animation Namespace


IMotionPath.Remove Method

[Visual Basic]
Sub Remove( _
ByVal item As IMotionCmdPath _
)
[C#]
void Remove(
IMotionCmdPath item
);

See Also

IMotionPath Interface | Aspose.Slides.Animation Namespace


IMotionPath.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IMotionPath Interface | Aspose.Slides.Animation Namespace


IPoint Interface

For a list of all members of this type, see IPoint Members.

[Visual Basic]
Public Interface IPoint
[C#]
public interface IPoint

Types that implement IPoint

Type | Description
Point | Represent animation point.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPoint Members | Aspose.Slides.Animation Namespace


IPoint Members

IPoint overview

Public Instance Properties

Formula
Time
Value

See Also

IPoint Interface | Aspose.Slides.Animation Namespace


IPoint Properties

The properties of the IPoint interface are listed below. For a complete list of IPoint interface members, see the IPoint Members topic.

Public Instance Properties

Formula
Time
Value

See Also

IPoint Interface | Aspose.Slides.Animation Namespace


Formula Property

Aspose.Slides Documentation

IPoint.Formula Property

[Visual Basic]
Property Formula As String
[C#]
string Formula {get; set;}

See Also

IPoint Interface | Aspose.Slides.Animation Namespace


Time Property

Aspose.Slides Documentation

IPoint.Time Property

[Visual Basic]
Property Time As Single
[C#]
float Time {get; set;}

See Also

IPoint Interface | Aspose.Slides.Animation Namespace


Value Property

Aspose.Slides Documentation

IPoint.Value Property

[Visual Basic]
Property Value As Object
[C#]
object Value {get; set;}

See Also

IPoint Interface | Aspose.Slides.Animation Namespace


IPointCollection Interface

For a list of all members of this type, see IPointCollection Members.

[Visual Basic]
Public Interface IPointCollection
Implements IEnumerable`1([Aspose.Slides.Animation.IPoint, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public interface IPointCollection : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Types that implement IPointCollection

Type | Description
PointCollection | Represent collection of animation points.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPointCollection Members | Aspose.Slides.Animation Namespace


IPointCollection Members

IPointCollection overview

Public Instance Properties

AsIEnumerable
Count
Item

See Also

IPointCollection Interface | Aspose.Slides.Animation Namespace


IPointCollection Properties

The properties of the IPointCollection interface are listed below. For a complete list of IPointCollection interface members, see the IPointCollection Members topic.

Public Instance Properties

AsIEnumerable
Count
Item

See Also

IPointCollection Interface | Aspose.Slides.Animation Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IPointCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IPointCollection Interface | Aspose.Slides.Animation Namespace


Count Property

Aspose.Slides Documentation

IPointCollection.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

IPointCollection Interface | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

IPointCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IPoint
[C#]
IPoint this[
int index
] {get;}

See Also

IPointCollection Interface | Aspose.Slides.Animation Namespace


IPropertyEffect Interface

For a list of all members of this type, see IPropertyEffect Members.

[Visual Basic]
Public Interface IPropertyEffect
Implements IBehavior
[C#]
public interface IPropertyEffect : IBehavior

Types that implement IPropertyEffect

Type | Description
PropertyEffect | Represent property effect behavior.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPropertyEffect Members | Aspose.Slides.Animation Namespace


IPropertyEffect Members

IPropertyEffect overview

Public Instance Properties

AsIBehavior
By
CalcMode
From
Points
To
ValueType

See Also

IPropertyEffect Interface | Aspose.Slides.Animation Namespace


IPropertyEffect Properties

The properties of the IPropertyEffect interface are listed below. For a complete list of IPropertyEffect interface members, see the IPropertyEffect Members topic.

Public Instance Properties

AsIBehavior
By
CalcMode
From
Points
To
ValueType

See Also

IPropertyEffect Interface | Aspose.Slides.Animation Namespace


AsIBehavior Property

Aspose.Slides Documentation

IPropertyEffect.AsIBehavior Property

[Visual Basic]
Property AsIBehavior As IBehavior
[C#]
IBehavior AsIBehavior {get;}

See Also

IPropertyEffect Interface | Aspose.Slides.Animation Namespace


By Property

Aspose.Slides Documentation

IPropertyEffect.By Property

[Visual Basic]
Property By As String
[C#]
string By {get; set;}

See Also

IPropertyEffect Interface | Aspose.Slides.Animation Namespace


CalcMode Property

Aspose.Slides Documentation

IPropertyEffect.CalcMode Property

[Visual Basic]
Property CalcMode As PropertyCalcModeType
[C#]
PropertyCalcModeType CalcMode {get; set;}

See Also

IPropertyEffect Interface | Aspose.Slides.Animation Namespace


From Property

Aspose.Slides Documentation

IPropertyEffect.From Property

[Visual Basic]
Property From As String
[C#]
string From {get; set;}

See Also

IPropertyEffect Interface | Aspose.Slides.Animation Namespace


Points Property

Aspose.Slides Documentation

IPropertyEffect.Points Property

[Visual Basic]
Property Points As IPointCollection
[C#]
IPointCollection Points {get; set;}

See Also

IPropertyEffect Interface | Aspose.Slides.Animation Namespace


To Property

Aspose.Slides Documentation

IPropertyEffect.To Property

[Visual Basic]
Property To As String
[C#]
string To {get; set;}

See Also

IPropertyEffect Interface | Aspose.Slides.Animation Namespace


ValueType Property

Aspose.Slides Documentation

IPropertyEffect.ValueType Property

[Visual Basic]
Property ValueType As PropertyValueType
[C#]
PropertyValueType ValueType {get; set;}

See Also

IPropertyEffect Interface | Aspose.Slides.Animation Namespace


IRotationEffect Interface

For a list of all members of this type, see IRotationEffect Members.

[Visual Basic]
Public Interface IRotationEffect
Implements IBehavior
[C#]
public interface IRotationEffect : IBehavior

Types that implement IRotationEffect

Type | Description
RotationEffect | Represent rotation behavior of effect.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IRotationEffect Members | Aspose.Slides.Animation Namespace


IRotationEffect Members

IRotationEffect overview

Public Instance Properties

AsIBehavior
By
From
To

See Also

IRotationEffect Interface | Aspose.Slides.Animation Namespace


IRotationEffect Properties

The properties of the IRotationEffect interface are listed below. For a complete list of IRotationEffect interface members, see the IRotationEffect Members topic.

Public Instance Properties

AsIBehavior
By
From
To

See Also

IRotationEffect Interface | Aspose.Slides.Animation Namespace


AsIBehavior Property

Aspose.Slides Documentation

IRotationEffect.AsIBehavior Property

[Visual Basic]
Property AsIBehavior As IBehavior
[C#]
IBehavior AsIBehavior {get;}

See Also

IRotationEffect Interface | Aspose.Slides.Animation Namespace


By Property

Aspose.Slides Documentation

IRotationEffect.By Property

[Visual Basic]
Property By As Single
[C#]
float By {get; set;}

See Also

IRotationEffect Interface | Aspose.Slides.Animation Namespace


From Property

Aspose.Slides Documentation

IRotationEffect.From Property

[Visual Basic]
Property From As Single
[C#]
float From {get; set;}

See Also

IRotationEffect Interface | Aspose.Slides.Animation Namespace


To Property

Aspose.Slides Documentation

IRotationEffect.To Property

[Visual Basic]
Property To As Single
[C#]
float To {get; set;}

See Also

IRotationEffect Interface | Aspose.Slides.Animation Namespace


IScaleEffect Interface

For a list of all members of this type, see IScaleEffect Members.

[Visual Basic]
Public Interface IScaleEffect
Implements IBehavior
[C#]
public interface IScaleEffect : IBehavior

Types that implement IScaleEffect

Type | Description
ScaleEffect | Represents animation scale effect.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IScaleEffect Members | Aspose.Slides.Animation Namespace


IScaleEffect Members

IScaleEffect overview

Public Instance Properties

AsIBehavior
By
From
To
ZoomContent

See Also

IScaleEffect Interface | Aspose.Slides.Animation Namespace


IScaleEffect Properties

The properties of the IScaleEffect interface are listed below. For a complete list of IScaleEffect interface members, see the IScaleEffect Members topic.

Public Instance Properties

AsIBehavior
By
From
To
ZoomContent

See Also

IScaleEffect Interface | Aspose.Slides.Animation Namespace


AsIBehavior Property

Aspose.Slides Documentation

IScaleEffect.AsIBehavior Property

[Visual Basic]
Property AsIBehavior As IBehavior
[C#]
IBehavior AsIBehavior {get;}

See Also

IScaleEffect Interface | Aspose.Slides.Animation Namespace


By Property

Aspose.Slides Documentation

IScaleEffect.By Property

[Visual Basic]
Property By As PointF
[C#]
PointF By {get; set;}

See Also

IScaleEffect Interface | Aspose.Slides.Animation Namespace


From Property

Aspose.Slides Documentation

IScaleEffect.From Property

[Visual Basic]
Property From As PointF
[C#]
PointF From {get; set;}

See Also

IScaleEffect Interface | Aspose.Slides.Animation Namespace


To Property

Aspose.Slides Documentation

IScaleEffect.To Property

[Visual Basic]
Property To As PointF
[C#]
PointF To {get; set;}

See Also

IScaleEffect Interface | Aspose.Slides.Animation Namespace


ZoomContent Property

Aspose.Slides Documentation

IScaleEffect.ZoomContent Property

[Visual Basic]
Property ZoomContent As NullableBool
[C#]
NullableBool ZoomContent {get; set;}

See Also

IScaleEffect Interface | Aspose.Slides.Animation Namespace


ISequence Interface

For a list of all members of this type, see ISequence Members.

[Visual Basic]
Public Interface ISequence
Implements IEnumerable
[C#]
public interface ISequence : IEnumerable

Types that implement ISequence

Type | Description
Sequence | Represent sequence (collection of effects).

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISequence Members | Aspose.Slides.Animation Namespace


ISequence Members

ISequence overview

Public Instance Properties

AsIEnumerable
Count
Item
TriggerShape

Public Instance Methods

AddEffect
Clear
GetCount
GetEffectsByShape
Remove
RemoveAt
RemoveByShape

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


ISequence Properties

The properties of the ISequence interface are listed below. For a complete list of ISequence interface members, see the ISequence Members topic.

Public Instance Properties

AsIEnumerable
Count
Item
TriggerShape

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ISequence.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


Count Property

Aspose.Slides Documentation

ISequence.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

ISequence.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IEffect
[C#]
IEffect this[
int index
] {get;}

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


TriggerShape Property

Aspose.Slides Documentation

ISequence.TriggerShape Property

[Visual Basic]
Property TriggerShape As IShape
[C#]
IShape TriggerShape {get; set;}

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


ISequence Methods

The methods of the ISequence interface are listed below. For a complete list of ISequence interface members, see the ISequence Members topic.

Public Instance Methods

AddEffect
Clear
GetCount
GetEffectsByShape
Remove
RemoveAt
RemoveByShape

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


ISequence.AddEffect Method

[Visual Basic]
Function AddEffect( _
ByVal shape As IShape, _
ByVal effectType As EffectType, _
ByVal subtype As EffectSubtype, _
ByVal triggerType As EffectTriggerType _
) As IEffect
[C#]
IEffect AddEffect(
IShape shape,
EffectType effectType,
EffectSubtype subtype,
EffectTriggerType triggerType
);

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


ISequence.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


ISequence.GetCount Method

[Visual Basic]
Function GetCount( _
ByVal shape As IShape _
) As Integer
[C#]
int GetCount(
IShape shape
);

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


ISequence.GetEffectsByShape Method

[Visual Basic]
Function GetEffectsByShape( _
ByVal shape As IShape _
) As IEffect()
[C#]
IEffect[] GetEffectsByShape(
IShape shape
);

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


ISequence.Remove Method

[Visual Basic]
Sub Remove( _
ByVal item As IEffect _
)
[C#]
void Remove(
IEffect item
);

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


ISequence.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


ISequence.RemoveByShape Method

[Visual Basic]
Sub RemoveByShape( _
ByVal shape As IShape _
)
[C#]
void RemoveByShape(
IShape shape
);

See Also

ISequence Interface | Aspose.Slides.Animation Namespace


ISequenceCollection Interface

For a list of all members of this type, see ISequenceCollection Members.

[Visual Basic]
Public Interface ISequenceCollection
Implements IEnumerable`1([Aspose.Slides.Animation.ISequence, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public interface ISequenceCollection : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Types that implement ISequenceCollection

Type | Description
SequenceCollection | Represent collection of interactive sequences.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISequenceCollection Members | Aspose.Slides.Animation Namespace


ISequenceCollection Members

ISequenceCollection overview

Public Instance Properties

AsIEnumerable
Count
Item

Public Instance Methods

Add
Clear
Remove
RemoveAt

See Also

ISequenceCollection Interface | Aspose.Slides.Animation Namespace


ISequenceCollection Properties

The properties of the ISequenceCollection interface are listed below. For a complete list of ISequenceCollection interface members, see the ISequenceCollection Members topic.

Public Instance Properties

AsIEnumerable
Count
Item

See Also

ISequenceCollection Interface | Aspose.Slides.Animation Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ISequenceCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ISequenceCollection Interface | Aspose.Slides.Animation Namespace


Count Property

Aspose.Slides Documentation

ISequenceCollection.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

ISequenceCollection Interface | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

ISequenceCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As ISequence
[C#]
ISequence this[
int index
] {get;}

See Also

ISequenceCollection Interface | Aspose.Slides.Animation Namespace


ISequenceCollection Methods

The methods of the ISequenceCollection interface are listed below. For a complete list of ISequenceCollection interface members, see the ISequenceCollection Members topic.

Public Instance Methods

Add
Clear
Remove
RemoveAt

See Also

ISequenceCollection Interface | Aspose.Slides.Animation Namespace


ISequenceCollection.Add Method

[Visual Basic]
Function Add( _
ByVal shapeTrigger As IShape _
) As ISequence
[C#]
ISequence Add(
IShape shapeTrigger
);

See Also

ISequenceCollection Interface | Aspose.Slides.Animation Namespace


ISequenceCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

ISequenceCollection Interface | Aspose.Slides.Animation Namespace


ISequenceCollection.Remove Method

[Visual Basic]
Sub Remove( _
ByVal item As ISequence _
)
[C#]
void Remove(
ISequence item
);

See Also

ISequenceCollection Interface | Aspose.Slides.Animation Namespace


ISequenceCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

ISequenceCollection Interface | Aspose.Slides.Animation Namespace


ISetEffect Interface

For a list of all members of this type, see ISetEffect Members.

[Visual Basic]
Public Interface ISetEffect
Implements IBehavior
[C#]
public interface ISetEffect : IBehavior

Types that implement ISetEffect

Type | Description
SetEffect | Represents a set effect for an animation behavior.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISetEffect Members | Aspose.Slides.Animation Namespace


ISetEffect Members

ISetEffect overview

Public Instance Properties

AsIBehavior
To

See Also

ISetEffect Interface | Aspose.Slides.Animation Namespace


ISetEffect Properties

The properties of the ISetEffect interface are listed below. For a complete list of ISetEffect interface members, see the ISetEffect Members topic.

Public Instance Properties

AsIBehavior
To

See Also

ISetEffect Interface | Aspose.Slides.Animation Namespace


AsIBehavior Property

Aspose.Slides Documentation

ISetEffect.AsIBehavior Property

[Visual Basic]
Property AsIBehavior As IBehavior
[C#]
IBehavior AsIBehavior {get;}

See Also

ISetEffect Interface | Aspose.Slides.Animation Namespace


To Property

Aspose.Slides Documentation

ISetEffect.To Property

[Visual Basic]
Property To As Object
[C#]
object To {get; set;}

See Also

ISetEffect Interface | Aspose.Slides.Animation Namespace


ITextAnimation Interface

For a list of all members of this type, see ITextAnimation Members.

[Visual Basic]
Public Interface ITextAnimation
[C#]
public interface ITextAnimation

Types that implement ITextAnimation

Type | Description
TextAnimation | Represent text animation.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITextAnimation Members | Aspose.Slides.Animation Namespace


ITextAnimation Members

ITextAnimation overview

Public Instance Properties

BuildType
EffectAnimateBackgroundShape

Public Instance Methods

AddEffect

See Also

ITextAnimation Interface | Aspose.Slides.Animation Namespace


ITextAnimation Properties

The properties of the ITextAnimation interface are listed below. For a complete list of ITextAnimation interface members, see the ITextAnimation Members topic.

Public Instance Properties

BuildType
EffectAnimateBackgroundShape

See Also

ITextAnimation Interface | Aspose.Slides.Animation Namespace


BuildType Property

Aspose.Slides Documentation

ITextAnimation.BuildType Property

[Visual Basic]
Property BuildType As BuildType
[C#]
BuildType BuildType {get; set;}

See Also

ITextAnimation Interface | Aspose.Slides.Animation Namespace


EffectAnimateBackgroundShape Property

Aspose.Slides Documentation

ITextAnimation.EffectAnimateBackgroundShape Property

[Visual Basic]
Property EffectAnimateBackgroundShape As IEffect
[C#]
IEffect EffectAnimateBackgroundShape {get; set;}

See Also

ITextAnimation Interface | Aspose.Slides.Animation Namespace


ITextAnimation Methods

The methods of the ITextAnimation interface are listed below. For a complete list of ITextAnimation interface members, see the ITextAnimation Members topic.

Public Instance Methods

AddEffect

See Also

ITextAnimation Interface | Aspose.Slides.Animation Namespace


ITextAnimation.AddEffect Method

[Visual Basic]
Function AddEffect( _
ByVal effectType As EffectType, _
ByVal subtype As EffectSubtype, _
ByVal triggerType As EffectTriggerType _
) As IEffect
[C#]
IEffect AddEffect(
EffectType effectType,
EffectSubtype subtype,
EffectTriggerType triggerType
);

See Also

ITextAnimation Interface | Aspose.Slides.Animation Namespace


ITextAnimationCollection Interface

For a list of all members of this type, see ITextAnimationCollection Members.

[Visual Basic]
Public Interface ITextAnimationCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Animation.ITextAnimation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface ITextAnimationCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement ITextAnimationCollection

Type | Description
TextAnimationCollection | Represent collection of text animations.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITextAnimationCollection Members | Aspose.Slides.Animation Namespace


ITextAnimationCollection Members

ITextAnimationCollection overview

Public Instance Properties

AsICollection |
AsIEnumerable |
Item | Overloaded.

See Also

ITextAnimationCollection Interface | Aspose.Slides.Animation Namespace


ITextAnimationCollection Properties

The properties of the ITextAnimationCollection interface are listed below. For a complete list of ITextAnimationCollection interface members, see the ITextAnimationCollection Members topic.

Public Instance Properties

AsICollection |
AsIEnumerable |
Item | Overloaded.

See Also

ITextAnimationCollection Interface | Aspose.Slides.Animation Namespace


AsICollection Property

Aspose.Slides Documentation

ITextAnimationCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

ITextAnimationCollection Interface | Aspose.Slides.Animation Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ITextAnimationCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ITextAnimationCollection Interface | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

ITextAnimationCollection.Item Property

Overload List

ITextAnimation[] this[Aspose.Slides.IShape] {get;}

ITextAnimation this[int] {get;}

See Also

ITextAnimationCollection Interface | Aspose.Slides.Animation Namespace


Item Property (IShape)

Aspose.Slides Documentation

ITextAnimationCollection.Item Property (IShape)

[Visual Basic]
Property Item( _
ByVal shape As IShape _
) As ITextAnimation()
[C#]
ITextAnimation[] this[
Aspose.Slides.IShape shape
] {get;}

See Also

ITextAnimationCollection Interface | Aspose.Slides.Animation Namespace | ITextAnimationCollection.Item Overload List


Item Property (Int32)

Aspose.Slides Documentation

ITextAnimationCollection.Item Property (Int32)

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As ITextAnimation
[C#]
ITextAnimation this[
int index
] {get;}

See Also

ITextAnimationCollection Interface | Aspose.Slides.Animation Namespace | ITextAnimationCollection.Item Overload List


ITiming Interface

For a list of all members of this type, see ITiming Members.

[Visual Basic]
Public Interface ITiming
[C#]
public interface ITiming

Types that implement ITiming

Type | Description
Timing | Represents animation timing.

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITiming Members | Aspose.Slides.Animation Namespace


ITiming Members

ITiming overview

Public Instance Properties

Accelerate
AutoReverse
Decelerate
Duration
RepeatCount
RepeatDuration
Restart
Speed
TriggerDelayTime
TriggerType

See Also

ITiming Interface | Aspose.Slides.Animation Namespace


ITiming Properties

The properties of the ITiming interface are listed below. For a complete list of ITiming interface members, see the ITiming Members topic.

Public Instance Properties

Accelerate
AutoReverse
Decelerate
Duration
RepeatCount
RepeatDuration
Restart
Speed
TriggerDelayTime
TriggerType

See Also

ITiming Interface | Aspose.Slides.Animation Namespace


Accelerate Property

Aspose.Slides Documentation

ITiming.Accelerate Property

[Visual Basic]
Property Accelerate As Single
[C#]
float Accelerate {get; set;}

See Also

ITiming Interface | Aspose.Slides.Animation Namespace


AutoReverse Property

Aspose.Slides Documentation

ITiming.AutoReverse Property

[Visual Basic]
Property AutoReverse As Boolean
[C#]
bool AutoReverse {get; set;}

See Also

ITiming Interface | Aspose.Slides.Animation Namespace


Decelerate Property

Aspose.Slides Documentation

ITiming.Decelerate Property

[Visual Basic]
Property Decelerate As Single
[C#]
float Decelerate {get; set;}

See Also

ITiming Interface | Aspose.Slides.Animation Namespace


Duration Property

Aspose.Slides Documentation

ITiming.Duration Property

[Visual Basic]
Property Duration As Single
[C#]
float Duration {get; set;}

See Also

ITiming Interface | Aspose.Slides.Animation Namespace


RepeatCount Property

Aspose.Slides Documentation

ITiming.RepeatCount Property

[Visual Basic]
Property RepeatCount As Single
[C#]
float RepeatCount {get; set;}

See Also

ITiming Interface | Aspose.Slides.Animation Namespace


RepeatDuration Property

Aspose.Slides Documentation

ITiming.RepeatDuration Property

[Visual Basic]
Property RepeatDuration As Single
[C#]
float RepeatDuration {get; set;}

See Also

ITiming Interface | Aspose.Slides.Animation Namespace


Restart Property

Aspose.Slides Documentation

ITiming.Restart Property

[Visual Basic]
Property Restart As EffectRestartType
[C#]
EffectRestartType Restart {get; set;}

See Also

ITiming Interface | Aspose.Slides.Animation Namespace


Speed Property

Aspose.Slides Documentation

ITiming.Speed Property

[Visual Basic]
Property Speed As Single
[C#]
float Speed {get; set;}

See Also

ITiming Interface | Aspose.Slides.Animation Namespace


TriggerDelayTime Property

Aspose.Slides Documentation

ITiming.TriggerDelayTime Property

[Visual Basic]
Property TriggerDelayTime As Single
[C#]
float TriggerDelayTime {get; set;}

See Also

ITiming Interface | Aspose.Slides.Animation Namespace


TriggerType Property

Aspose.Slides Documentation

ITiming.TriggerType Property

[Visual Basic]
Property TriggerType As EffectTriggerType
[C#]
EffectTriggerType TriggerType {get; set;}

See Also

ITiming Interface | Aspose.Slides.Animation Namespace


MotionCmdPath Class

Represent one command of a path.

For a list of all members of this type, see MotionCmdPath Members.

System.Object
Aspose.Slides.Animation.MotionCmdPath

[Visual Basic]
Public Class MotionCmdPath
Implements IMotionCmdPath
[C#]
public class MotionCmdPath : IMotionCmdPath

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

MotionCmdPath Members | Aspose.Slides.Animation Namespace


MotionCmdPath Members

MotionCmdPath overview

Public Instance Properties

CommandType | Specifies command type. Read/write MotionCommandPathType.
IsRelative | Determine command coordinates relative or not. Read/write Boolean.
Points | Specifies points of command. Read/write PointF[].
PointsType | Specifies command points type Read/write MotionPathPointsType.

See Also

MotionCmdPath Class | Aspose.Slides.Animation Namespace


MotionCmdPath Properties

The properties of the MotionCmdPath class are listed below. For a complete list of MotionCmdPath class members, see the MotionCmdPath Members topic.

Public Instance Properties

CommandType | Specifies command type. Read/write MotionCommandPathType.
IsRelative | Determine command coordinates relative or not. Read/write Boolean.
Points | Specifies points of command. Read/write PointF[].
PointsType | Specifies command points type Read/write MotionPathPointsType.

See Also

MotionCmdPath Class | Aspose.Slides.Animation Namespace


CommandType Property

Aspose.Slides Documentation

MotionCmdPath.CommandType Property

Specifies command type. Read/write MotionCommandPathType.

[Visual Basic]
NotOverridable Public Property CommandType As MotionCommandPathType _
Implements IMotionCmdPath.CommandType
[C#]
public MotionCommandPathType CommandType {get; set;}

Implements

IMotionCmdPath.CommandType

See Also

MotionCmdPath Class | Aspose.Slides.Animation Namespace


IsRelative Property

Aspose.Slides Documentation

MotionCmdPath.IsRelative Property

Determine command coordinates relative or not. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property IsRelative As Boolean _
Implements IMotionCmdPath.IsRelative
[C#]
public bool IsRelative {get; set;}

Implements

IMotionCmdPath.IsRelative

See Also

MotionCmdPath Class | Aspose.Slides.Animation Namespace


Points Property

Aspose.Slides Documentation

MotionCmdPath.Points Property

Specifies points of command. Read/write PointF[].

[Visual Basic]
NotOverridable Public Property Points As PointF() _
Implements IMotionCmdPath.Points
[C#]
public PointF[] Points {get; set;}

Implements

IMotionCmdPath.Points

See Also

MotionCmdPath Class | Aspose.Slides.Animation Namespace


PointsType Property

Aspose.Slides Documentation

MotionCmdPath.PointsType Property

Specifies command points type Read/write MotionPathPointsType.

[Visual Basic]
NotOverridable Public Property PointsType As MotionPathPointsType _
Implements IMotionCmdPath.PointsType
[C#]
public MotionPathPointsType PointsType {get; set;}

Implements

IMotionCmdPath.PointsType

See Also

MotionCmdPath Class | Aspose.Slides.Animation Namespace


MotionCommandPathType Enumeration

[Visual Basic]
Public Enum MotionCommandPathType
[C#]
public enum MotionCommandPathType

Members

Member Name | Description | Value
MoveTo |  | 0
LineTo |  | 1
CurveTo |  | 2
CloseLoop |  | 3
End |  | 4

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


MotionEffect Class

Represent motion effect behavior of effect.

For a list of all members of this type, see MotionEffect Members.

System.Object
Aspose.Slides.Animation.Behavior
Aspose.Slides.Animation.MotionEffect

[Visual Basic]
Public Class MotionEffect
Inherits Behavior
Implements IMotionEffect
[C#]
public class MotionEffect : Behavior, IMotionEffect

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

MotionEffect Members | Aspose.Slides.Animation Namespace


MotionEffect Members

MotionEffect overview

Public Instance Constructors

MotionEffect Constructor Initializes a new instance of the MotionEffect class.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
Angle | Describes the relative angle of the motion path. Read/write Single.
By | Describes the relative offset value for the animation (in percents). Read/write PointF.
From | Specifies an x/y co-ordinate to start the animation from (in percents). Read/write PointF.
Origin | Specifies what the origin of the motion path is relative to such as the layout of the slide, or the parent. Read/write MotionOriginType.
Path | Specifies the path primitive followed by coordinates for the animation motion. Read/write MotionPath.
PathEditMode | Specifies how the motion path moves when shape is moved. Read/write MotionPathEditMode.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
RotationCenter | Describes the center of the rotation used to rotate a motion path by X angle. Read/write PointF.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
To | Specifies the target location for an animation motion effect (in percents). Read/write PointF.

See Also

MotionEffect Class | Aspose.Slides.Animation Namespace


MotionEffect Constructor

Initializes a new instance of the MotionEffect class.

[Visual Basic]
Public Sub New()
[C#]
public MotionEffect();

See Also

MotionEffect Class | Aspose.Slides.Animation Namespace


MotionEffect Properties

The properties of the MotionEffect class are listed below. For a complete list of MotionEffect class members, see the MotionEffect Members topic.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
Angle | Describes the relative angle of the motion path. Read/write Single.
By | Describes the relative offset value for the animation (in percents). Read/write PointF.
From | Specifies an x/y co-ordinate to start the animation from (in percents). Read/write PointF.
Origin | Specifies what the origin of the motion path is relative to such as the layout of the slide, or the parent. Read/write MotionOriginType.
Path | Specifies the path primitive followed by coordinates for the animation motion. Read/write MotionPath.
PathEditMode | Specifies how the motion path moves when shape is moved. Read/write MotionPathEditMode.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
RotationCenter | Describes the center of the rotation used to rotate a motion path by X angle. Read/write PointF.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
To | Specifies the target location for an animation motion effect (in percents). Read/write PointF.

See Also

MotionEffect Class | Aspose.Slides.Animation Namespace


Angle Property

Aspose.Slides Documentation

MotionEffect.Angle Property

Describes the relative angle of the motion path. Read/write Single.

[Visual Basic]
NotOverridable Public Property Angle As Single _
Implements IMotionEffect.Angle
[C#]
public float Angle {get; set;}

Implements

IMotionEffect.Angle

See Also

MotionEffect Class | Aspose.Slides.Animation Namespace


By Property

Aspose.Slides Documentation

MotionEffect.By Property

Describes the relative offset value for the animation (in percents). Read/write PointF.

[Visual Basic]
NotOverridable Public Property By As PointF _
Implements IMotionEffect.By
[C#]
public PointF By {get; set;}

Implements

IMotionEffect.By

See Also

MotionEffect Class | Aspose.Slides.Animation Namespace


From Property

Aspose.Slides Documentation

MotionEffect.From Property

Specifies an x/y co-ordinate to start the animation from (in percents). Read/write PointF.

[Visual Basic]
NotOverridable Public Property From As PointF _
Implements IMotionEffect.From
[C#]
public PointF From {get; set;}

Implements

IMotionEffect.From

See Also

MotionEffect Class | Aspose.Slides.Animation Namespace


Origin Property

Aspose.Slides Documentation

MotionEffect.Origin Property

Specifies what the origin of the motion path is relative to such as the layout of the slide, or the parent. Read/write MotionOriginType.

[Visual Basic]
NotOverridable Public Property Origin As MotionOriginType _
Implements IMotionEffect.Origin
[C#]
public MotionOriginType Origin {get; set;}

Implements

IMotionEffect.Origin

See Also

MotionEffect Class | Aspose.Slides.Animation Namespace


Path Property

Aspose.Slides Documentation

MotionEffect.Path Property

Specifies the path primitive followed by coordinates for the animation motion. Read/write MotionPath.

[Visual Basic]
NotOverridable Public Property Path As IMotionPath _
Implements IMotionEffect.Path
[C#]
public IMotionPath Path {get; set;}

Implements

IMotionEffect.Path

See Also

MotionEffect Class | Aspose.Slides.Animation Namespace


PathEditMode Property

Aspose.Slides Documentation

MotionEffect.PathEditMode Property

Specifies how the motion path moves when shape is moved. Read/write MotionPathEditMode.

[Visual Basic]
NotOverridable Public Property PathEditMode As MotionPathEditMode _
Implements IMotionEffect.PathEditMode
[C#]
public MotionPathEditMode PathEditMode {get; set;}

Implements

IMotionEffect.PathEditMode

See Also

MotionEffect Class | Aspose.Slides.Animation Namespace


RotationCenter Property

Aspose.Slides Documentation

MotionEffect.RotationCenter Property

Describes the center of the rotation used to rotate a motion path by X angle. Read/write PointF.

[Visual Basic]
NotOverridable Public Property RotationCenter As PointF _
Implements IMotionEffect.RotationCenter
[C#]
public PointF RotationCenter {get; set;}

Implements

IMotionEffect.RotationCenter

See Also

MotionEffect Class | Aspose.Slides.Animation Namespace


To Property

Aspose.Slides Documentation

MotionEffect.To Property

Specifies the target location for an animation motion effect (in percents). Read/write PointF.

[Visual Basic]
NotOverridable Public Property To As PointF _
Implements IMotionEffect.To
[C#]
public PointF To {get; set;}

Implements

IMotionEffect.To

See Also

MotionEffect Class | Aspose.Slides.Animation Namespace


MotionOriginType Enumeration

[Visual Basic]
Public Enum MotionOriginType
[C#]
public enum MotionOriginType

Members

Member Name | Description | Value
NotDefined |  | -1
Parent |  | 0
Layout |  | 1

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


MotionPath Class

Represent motion path.

For a list of all members of this type, see MotionPath Members.

System.Object
Aspose.Slides.Animation.MotionPath

[Visual Basic]
Public Class MotionPath
Implements IMotionPath, IEnumerable`1([Aspose.Slides.Animation.IMotionCmdPath, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public class MotionPath : IMotionPath, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

MotionPath Members | Aspose.Slides.Animation Namespace


MotionPath Members

MotionPath overview

Public Instance Constructors

MotionPath Constructor Initializes a new instance of the MotionPath class.

Public Instance Properties

Count | Returns the number of paths in the collection.
Item | Returns a command at the specified index.

Public Instance Methods

Add | Add new command to path
Clear | Removes all commands from the collection.
GetEnumerator | Returns an iterator for the collection.
Insert | Insert new command to path
Remove | Removes specified commans from the collection.
RemoveAt | Removes a command at the specified index.

See Also

MotionPath Class | Aspose.Slides.Animation Namespace


MotionPath Constructor

Initializes a new instance of the MotionPath class.

[Visual Basic]
Public Sub New()
[C#]
public MotionPath();

See Also

MotionPath Class | Aspose.Slides.Animation Namespace


MotionPath Properties

The properties of the MotionPath class are listed below. For a complete list of MotionPath class members, see the MotionPath Members topic.

Public Instance Properties

Count | Returns the number of paths in the collection.
Item | Returns a command at the specified index.

See Also

MotionPath Class | Aspose.Slides.Animation Namespace


Count Property

Aspose.Slides Documentation

MotionPath.Count Property

Returns the number of paths in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements IMotionPath.Count
[C#]
public int Count {get;}

Implements

IMotionPath.Count

See Also

MotionPath Class | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

MotionPath.Item Property

Returns a command at the specified index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IMotionPath.Item
As IMotionCmdPath _
Implements IMotionPath.Item
[C#]
public IMotionCmdPath this[
int index
] {get;}

Parameters

index

Implements

IMotionPath.Item

See Also

MotionPath Class | Aspose.Slides.Animation Namespace


MotionPath Methods

The methods of the MotionPath class are listed below. For a complete list of MotionPath class members, see the MotionPath Members topic.

Public Instance Methods

Add | Add new command to path
Clear | Removes all commands from the collection.
GetEnumerator | Returns an iterator for the collection.
Insert | Insert new command to path
Remove | Removes specified commans from the collection.
RemoveAt | Removes a command at the specified index.

See Also

MotionPath Class | Aspose.Slides.Animation Namespace


MotionPath.Add Method

Add new command to path

[Visual Basic]
NotOverridable Public Function Add( _
ByVal type As MotionCommandPathType, _
ByVal pts As PointF(), _
ByVal ptsType As MotionPathPointsType, _
ByVal bRelativeCoord As Boolean _
) As IMotionCmdPath _
Implements IMotionPath.Add
[C#]
public IMotionCmdPath Add(
MotionCommandPathType type,
PointF[] pts,
MotionPathPointsType ptsType,
bool bRelativeCoord
);

Parameters

type
pts
ptsType
bRelativeCoord

Implements

IMotionPath.Add

See Also

MotionPath Class | Aspose.Slides.Animation Namespace


MotionPath.Clear Method

Removes all commands from the collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IMotionPath.Clear
[C#]
public void Clear();

Implements

IMotionPath.Clear

See Also

MotionPath Class | Aspose.Slides.Animation Namespace


MotionPath.GetEnumerator Method

Returns an iterator for the collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Iterator.

Implements

IEnumerable.GetEnumerator

See Also

MotionPath Class | Aspose.Slides.Animation Namespace


MotionPath.Insert Method

Insert new command to path

[Visual Basic]
NotOverridable Public Sub Insert( _
ByVal index As Integer, _
ByVal type As MotionCommandPathType, _
ByVal pts As PointF(), _
ByVal ptsType As MotionPathPointsType, _
ByVal bRelativeCoord As Boolean _
) _
Implements IMotionPath.Insert
[C#]
public void Insert(
int index,
MotionCommandPathType type,
PointF[] pts,
MotionPathPointsType ptsType,
bool bRelativeCoord
);

Parameters

index
type
pts
ptsType
bRelativeCoord

Implements

IMotionPath.Insert

See Also

MotionPath Class | Aspose.Slides.Animation Namespace


MotionPath.Remove Method

Removes specified commans from the collection.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal item As IMotionCmdPath _
) _
Implements IMotionPath.Remove
[C#]
public void Remove(
IMotionCmdPath item
);

Parameters

item
Motion path to remove.

Implements

IMotionPath.Remove

See Also

MotionPath Class | Aspose.Slides.Animation Namespace


MotionPath.RemoveAt Method

Removes a command at the specified index.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IMotionPath.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index

Implements

IMotionPath.RemoveAt

See Also

MotionPath Class | Aspose.Slides.Animation Namespace


MotionPathEditMode Enumeration

[Visual Basic]
Public Enum MotionPathEditMode
[C#]
public enum MotionPathEditMode

Members

Member Name | Description | Value
NotDefined |  | -1
Relative |  | 0
Fixed |  | 1

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


MotionPathPointsType Enumeration

[Visual Basic]
Public Enum MotionPathPointsType
[C#]
public enum MotionPathPointsType

Members

Member Name | Description | Value
None |  | 0
Auto |  | 1
Corner |  | 2
Straight |  | 3
Smooth |  | 4
CurveAuto |  | 5
CurveCorner |  | 6
CurveStraight |  | 7
CurveSmooth |  | 8

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


Point Class

Represent animation point.

For a list of all members of this type, see Point Members.

System.Object
Aspose.Slides.Animation.Point

[Visual Basic]
Public Class Point
Implements IPoint
[C#]
public class Point : IPoint

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Point Members | Aspose.Slides.Animation Namespace


Point Members

Point overview

Public Instance Constructors

Point Overloaded. Initializes a new instance of the Point class.

Public Instance Properties

Formula | Formulas within values, from, to, by attributes can be made up of these: Standard arithmetic operators: ‘+’, ‘-‘, ‘*’, ‘/’, ‘^’, ‘%’ (mod) Constants: ‘pi’ ‘e’ Conditional operators: ‘abs’, ‘min’, ‘max’, ‘?’ (if) Comparison operators: '==', '>=', '', '!=', '!' Trigonometric operators: ‘sin()’, ‘cos()’, ‘tan()’, ‘asin()’, ‘acos()’, ‘atan()’ Natural logarithm ‘ln()’ Property references (host supported properties) for example: "#ppt_x+(cos(-2*pi*(1-$))*-#ppt_x-sin(-2*pi*(1-$))*(1-#ppt_y))*(1-$)" Read/write String.
Time | Represents time value. Read/write Single.
Value | Represents point value. Only: bool, ColorFormat, float, int, string.

See Also

Point Class | Aspose.Slides.Animation Namespace


Point Constructor

Default constructor.

Overload List

Default constructor.

public Point();

Create animation point with time, value and formula.

public Point(float,object,string);

See Also

Point Class | Aspose.Slides.Animation Namespace


Point Constructor ()

Default constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Point();

See Also

Point Class | Aspose.Slides.Animation Namespace | Point Constructor Overload List


Point Constructor (Single, Object, String)

Create animation point with time, value and formula.

[Visual Basic]
Overloads Public Sub New( _
ByVal time As Single, _
ByVal value As Object, _
ByVal formula As String _
)
[C#]
public Point(
float time,
object value,
string formula
);

Parameters

time
value
formula

See Also

Point Class | Aspose.Slides.Animation Namespace | Point Constructor Overload List


Point Properties

The properties of the Point class are listed below. For a complete list of Point class members, see the Point Members topic.

Public Instance Properties

Formula | Formulas within values, from, to, by attributes can be made up of these: Standard arithmetic operators: ‘+’, ‘-‘, ‘*’, ‘/’, ‘^’, ‘%’ (mod) Constants: ‘pi’ ‘e’ Conditional operators: ‘abs’, ‘min’, ‘max’, ‘?’ (if) Comparison operators: '==', '>=', '', '!=', '!' Trigonometric operators: ‘sin()’, ‘cos()’, ‘tan()’, ‘asin()’, ‘acos()’, ‘atan()’ Natural logarithm ‘ln()’ Property references (host supported properties) for example: "#ppt_x+(cos(-2*pi*(1-$))*-#ppt_x-sin(-2*pi*(1-$))*(1-#ppt_y))*(1-$)" Read/write String.
Time | Represents time value. Read/write Single.
Value | Represents point value. Only: bool, ColorFormat, float, int, string.

See Also

Point Class | Aspose.Slides.Animation Namespace


Formula Property

Aspose.Slides Documentation

Point.Formula Property

Formulas within values, from, to, by attributes can be made up of these: Standard arithmetic operators: ‘+’, ‘-‘, ‘*’, ‘/’, ‘^’, ‘%’ (mod) Constants: ‘pi’ ‘e’ Conditional operators: ‘abs’, ‘min’, ‘max’, ‘?’ (if) Comparison operators: '==', '>=', '', '!=', '!' Trigonometric operators: ‘sin()’, ‘cos()’, ‘tan()’, ‘asin()’, ‘acos()’, ‘atan()’ Natural logarithm ‘ln()’ Property references (host supported properties) for example: "#ppt_x+(cos(-2*pi*(1-$))*-#ppt_x-sin(-2*pi*(1-$))*(1-#ppt_y))*(1-$)" Read/write String.

[Visual Basic]
NotOverridable Public Property Formula As String _
Implements IPoint.Formula
[C#]
public string Formula {get; set;}

Implements

IPoint.Formula

See Also

Point Class | Aspose.Slides.Animation Namespace


Time Property

Aspose.Slides Documentation

Point.Time Property

Represents time value. Read/write Single.

[Visual Basic]
NotOverridable Public Property Time As Single _
Implements IPoint.Time
[C#]
public float Time {get; set;}

Implements

IPoint.Time

See Also

Point Class | Aspose.Slides.Animation Namespace


Value Property

Aspose.Slides Documentation

Point.Value Property

Represents point value. Only: bool, ColorFormat, float, int, string.

[Visual Basic]
NotOverridable Public Property Value As Object _
Implements IPoint.Value
[C#]
public object Value {get; set;}

Implements

IPoint.Value

See Also

Point Class | Aspose.Slides.Animation Namespace


PointCollection Class

Represent collection of animation points.

For a list of all members of this type, see PointCollection Members.

System.Object
Aspose.Slides.Animation.PointCollection

[Visual Basic]
Public Class PointCollection
Implements IPointCollection, IEnumerable`1([Aspose.Slides.Animation.IPoint, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public class PointCollection : IPointCollection, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PointCollection Members | Aspose.Slides.Animation Namespace


PointCollection Members

PointCollection overview

Public Instance Constructors

PointCollection Constructor Initializes a new instance of the PointCollection class.

Public Instance Properties

Count | Returns the number of points in the collection.
Item | Returns a point at the specified index.

Public Instance Methods

GetEnumerator Returns an iterator for the collection.

See Also

PointCollection Class | Aspose.Slides.Animation Namespace


PointCollection Constructor

Initializes a new instance of the PointCollection class.

[Visual Basic]
Public Sub New()
[C#]
public PointCollection();

See Also

PointCollection Class | Aspose.Slides.Animation Namespace


PointCollection Properties

The properties of the PointCollection class are listed below. For a complete list of PointCollection class members, see the PointCollection Members topic.

Public Instance Properties

Count | Returns the number of points in the collection.
Item | Returns a point at the specified index.

See Also

PointCollection Class | Aspose.Slides.Animation Namespace


Count Property

Aspose.Slides Documentation

PointCollection.Count Property

Returns the number of points in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements IPointCollection.Count
[C#]
public int Count {get;}

Implements

IPointCollection.Count

See Also

PointCollection Class | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

PointCollection.Item Property

Returns a point at the specified index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IPointCollection.Item
As IPoint _
Implements IPointCollection.Item
[C#]
public IPoint this[
int index
] {get;}

Parameters

index

Implements

IPointCollection.Item

See Also

PointCollection Class | Aspose.Slides.Animation Namespace


PointCollection Methods

The methods of the PointCollection class are listed below. For a complete list of PointCollection class members, see the PointCollection Members topic.

Public Instance Methods

GetEnumerator Returns an iterator for the collection.

See Also

PointCollection Class | Aspose.Slides.Animation Namespace


PointCollection.GetEnumerator Method

Returns an iterator for the collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Iterator.

Implements

IEnumerable.GetEnumerator

See Also

PointCollection Class | Aspose.Slides.Animation Namespace


PropertyCalcModeType Enumeration

[Visual Basic]
Public Enum PropertyCalcModeType
[C#]
public enum PropertyCalcModeType

Members

Member Name | Description | Value
NotDefined |  | -1
Discrete |  | 0
Linear |  | 1
Formula |  | 2

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


PropertyEffect Class

Represent property effect behavior.

For a list of all members of this type, see PropertyEffect Members.

System.Object
Aspose.Slides.Animation.Behavior
Aspose.Slides.Animation.PropertyEffect

[Visual Basic]
Public Class PropertyEffect
Inherits Behavior
Implements IPropertyEffect
[C#]
public class PropertyEffect : Behavior, IPropertyEffect

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PropertyEffect Members | Aspose.Slides.Animation Namespace


PropertyEffect Members

PropertyEffect overview

Public Instance Constructors

PropertyEffect Constructor Initializes a new instance of the PropertyEffect class.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
By | Specifies a relative offset value for the animation with respect to its position before the start of the animation. Read/write String.
CalcMode | Specifies the interpolation mode for the animation Read/write PropertyCalcModeType.
From | Specifies the starting value of the animation. Read/write String.
Points | Specifies the points of the animation. Read/write PointCollection.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
To | Specifies the ending value for the animation. Read/write String.
ValueType | Specifies the type of a property value. Read/write PropertyValueType.

See Also

PropertyEffect Class | Aspose.Slides.Animation Namespace


PropertyEffect Constructor

Initializes a new instance of the PropertyEffect class.

[Visual Basic]
Public Sub New()
[C#]
public PropertyEffect();

See Also

PropertyEffect Class | Aspose.Slides.Animation Namespace


PropertyEffect Properties

The properties of the PropertyEffect class are listed below. For a complete list of PropertyEffect class members, see the PropertyEffect Members topic.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
By | Specifies a relative offset value for the animation with respect to its position before the start of the animation. Read/write String.
CalcMode | Specifies the interpolation mode for the animation Read/write PropertyCalcModeType.
From | Specifies the starting value of the animation. Read/write String.
Points | Specifies the points of the animation. Read/write PointCollection.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
To | Specifies the ending value for the animation. Read/write String.
ValueType | Specifies the type of a property value. Read/write PropertyValueType.

See Also

PropertyEffect Class | Aspose.Slides.Animation Namespace


By Property

Aspose.Slides Documentation

PropertyEffect.By Property

Specifies a relative offset value for the animation with respect to its position before the start of the animation. Read/write String.

[Visual Basic]
NotOverridable Public Property By As String _
Implements IPropertyEffect.By
[C#]
public string By {get; set;}

Implements

IPropertyEffect.By

See Also

PropertyEffect Class | Aspose.Slides.Animation Namespace


CalcMode Property

Aspose.Slides Documentation

PropertyEffect.CalcMode Property

Specifies the interpolation mode for the animation Read/write PropertyCalcModeType.

[Visual Basic]
NotOverridable Public Property CalcMode As PropertyCalcModeType _
Implements IPropertyEffect.CalcMode
[C#]
public PropertyCalcModeType CalcMode {get; set;}

Implements

IPropertyEffect.CalcMode

See Also

PropertyEffect Class | Aspose.Slides.Animation Namespace


From Property

Aspose.Slides Documentation

PropertyEffect.From Property

Specifies the starting value of the animation. Read/write String.

[Visual Basic]
NotOverridable Public Property From As String _
Implements IPropertyEffect.From
[C#]
public string From {get; set;}

Implements

IPropertyEffect.From

See Also

PropertyEffect Class | Aspose.Slides.Animation Namespace


Points Property

Aspose.Slides Documentation

PropertyEffect.Points Property

Specifies the points of the animation. Read/write PointCollection.

[Visual Basic]
NotOverridable Public Property Points As IPointCollection _
Implements IPropertyEffect.Points
[C#]
public IPointCollection Points {get; set;}

Implements

IPropertyEffect.Points

See Also

PropertyEffect Class | Aspose.Slides.Animation Namespace


To Property

Aspose.Slides Documentation

PropertyEffect.To Property

Specifies the ending value for the animation. Read/write String.

[Visual Basic]
NotOverridable Public Property To As String _
Implements IPropertyEffect.To
[C#]
public string To {get; set;}

Implements

IPropertyEffect.To

See Also

PropertyEffect Class | Aspose.Slides.Animation Namespace


ValueType Property

Aspose.Slides Documentation

PropertyEffect.ValueType Property

Specifies the type of a property value. Read/write PropertyValueType.

[Visual Basic]
NotOverridable Public Property ValueType As PropertyValueType _
Implements IPropertyEffect.ValueType
[C#]
public PropertyValueType ValueType {get; set;}

Implements

IPropertyEffect.ValueType

See Also

PropertyEffect Class | Aspose.Slides.Animation Namespace


PropertyType Enumeration

[Visual Basic]
Public Enum PropertyType
[C#]
public enum PropertyType

Members

Member Name | Description | Value
NotDefined |  | -1
Color |  | 0
PptHeight |  | 1
Opacity |  | 2
Rotation |  | 3
RotationPPT |  | 4
ShapeStrokeColor |  | 5
StrokeOn |  | 6
ShapeFillType |  | 7
ShapeFillBackColor |  | 8
ShapeFillColor |  | 9
ShapeFillColor2 |  | 10
ShapeFillOn |  | 11
ShapeFillOpacity |  | 12
ShapeLineColor |  | 13
ShapeLineOn |  | 14
ShapePictureBrightness |  | 15
ShapePictureContrast |  | 16
ShapePictureGamma |  | 17
ShapePictureGrayscale |  | 18
ShapeShadowColor |  | 19
ShapeShadowOffsetX |  | 20
ShapeShadowOffsetY |  | 21
ShapeShadowOn |  | 22
ShapeShadowOpacity |  | 23
ShapeShadowType |  | 24
TextBulletCharacter |  | 25
TextBulletColor |  | 26
TextBulletFontName |  | 27
TextBulletNumber |  | 28
TextBulletRelativeSize |  | 29
TextBulletStyle |  | 30
TextBulletType |  | 31
TextFontBold |  | 32
TextFontColor |  | 33
TextFontEmboss |  | 34
TextFontItalic |  | 35
TextFontName |  | 36
TextFontShadow |  | 37
TextFontSize |  | 38
TextFontStyle |  | 39
TextFontWeight |  | 40
TextFontStrikeThrough |  | 41
TextFontSubscript |  | 42
TextFontSuperscript |  | 43
TextFontUnderline |  | 44
Visibility |  | 45
PptWidth |  | 46
PptX |  | 47
PptY |  | 48
XShear |  | 49

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


PropertyValueType Enumeration

[Visual Basic]
Public Enum PropertyValueType
[C#]
public enum PropertyValueType

Members

Member Name | Description | Value
NotDefined |  | -1
String |  | 0
Number |  | 1
Color |  | 2

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Animation Namespace


RotationEffect Class

Represent rotation behavior of effect.

For a list of all members of this type, see RotationEffect Members.

System.Object
Aspose.Slides.Animation.Behavior
Aspose.Slides.Animation.RotationEffect

[Visual Basic]
Public Class RotationEffect
Inherits Behavior
Implements IRotationEffect
[C#]
public class RotationEffect : Behavior, IRotationEffect

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

RotationEffect Members | Aspose.Slides.Animation Namespace


RotationEffect Members

RotationEffect overview

Public Instance Constructors

RotationEffect Constructor Initializes a new instance of the RotationEffect class.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
By | Describes the relative offset value for the animation. Read/write Single.
From | Describes the starting value for the animation. Read/write Single.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
To | Describes the ending value for the animation. Read/write Single.

See Also

RotationEffect Class | Aspose.Slides.Animation Namespace


RotationEffect Constructor

Initializes a new instance of the RotationEffect class.

[Visual Basic]
Public Sub New()
[C#]
public RotationEffect();

See Also

RotationEffect Class | Aspose.Slides.Animation Namespace


RotationEffect Properties

The properties of the RotationEffect class are listed below. For a complete list of RotationEffect class members, see the RotationEffect Members topic.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
By | Describes the relative offset value for the animation. Read/write Single.
From | Describes the starting value for the animation. Read/write Single.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
To | Describes the ending value for the animation. Read/write Single.

See Also

RotationEffect Class | Aspose.Slides.Animation Namespace


By Property

Aspose.Slides Documentation

RotationEffect.By Property

Describes the relative offset value for the animation. Read/write Single.

[Visual Basic]
NotOverridable Public Property By As Single _
Implements IRotationEffect.By
[C#]
public float By {get; set;}

Implements

IRotationEffect.By

See Also

RotationEffect Class | Aspose.Slides.Animation Namespace


From Property

Aspose.Slides Documentation

RotationEffect.From Property

Describes the starting value for the animation. Read/write Single.

[Visual Basic]
NotOverridable Public Property From As Single _
Implements IRotationEffect.From
[C#]
public float From {get; set;}

Implements

IRotationEffect.From

See Also

RotationEffect Class | Aspose.Slides.Animation Namespace


To Property

Aspose.Slides Documentation

RotationEffect.To Property

Describes the ending value for the animation. Read/write Single.

[Visual Basic]
NotOverridable Public Property To As Single _
Implements IRotationEffect.To
[C#]
public float To {get; set;}

Implements

IRotationEffect.To

See Also

RotationEffect Class | Aspose.Slides.Animation Namespace


ScaleEffect Class

Represents animation scale effect.

For a list of all members of this type, see ScaleEffect Members.

System.Object
Aspose.Slides.Animation.Behavior
Aspose.Slides.Animation.ScaleEffect

[Visual Basic]
Public Class ScaleEffect
Inherits Behavior
Implements IScaleEffect
[C#]
public class ScaleEffect : Behavior, IScaleEffect

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ScaleEffect Members | Aspose.Slides.Animation Namespace


ScaleEffect Members

ScaleEffect overview

Public Instance Constructors

ScaleEffect Constructor Initializes a new instance of the ScaleEffect class.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
By | describes the relative offset value for the animation (in percents). Read/write PointF.
From | Specifies an x/y co-ordinate to start the animation from (in percents). Read/write PointF.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
To | Specifies the target location for an animation scale effect (in percents). Read/write PointF.
ZoomContent | Determines whether a content should be zoomed.

See Also

ScaleEffect Class | Aspose.Slides.Animation Namespace


ScaleEffect Constructor

Initializes a new instance of the ScaleEffect class.

[Visual Basic]
Public Sub New()
[C#]
public ScaleEffect();

See Also

ScaleEffect Class | Aspose.Slides.Animation Namespace


ScaleEffect Properties

The properties of the ScaleEffect class are listed below. For a complete list of ScaleEffect class members, see the ScaleEffect Members topic.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
By | describes the relative offset value for the animation (in percents). Read/write PointF.
From | Specifies an x/y co-ordinate to start the animation from (in percents). Read/write PointF.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
To | Specifies the target location for an animation scale effect (in percents). Read/write PointF.
ZoomContent | Determines whether a content should be zoomed.

See Also

ScaleEffect Class | Aspose.Slides.Animation Namespace


By Property

Aspose.Slides Documentation

ScaleEffect.By Property

describes the relative offset value for the animation (in percents). Read/write PointF.

[Visual Basic]
NotOverridable Public Property By As PointF _
Implements IScaleEffect.By
[C#]
public PointF By {get; set;}

Implements

IScaleEffect.By

See Also

ScaleEffect Class | Aspose.Slides.Animation Namespace


From Property

Aspose.Slides Documentation

ScaleEffect.From Property

Specifies an x/y co-ordinate to start the animation from (in percents). Read/write PointF.

[Visual Basic]
NotOverridable Public Property From As PointF _
Implements IScaleEffect.From
[C#]
public PointF From {get; set;}

Implements

IScaleEffect.From

See Also

ScaleEffect Class | Aspose.Slides.Animation Namespace


To Property

Aspose.Slides Documentation

ScaleEffect.To Property

Specifies the target location for an animation scale effect (in percents). Read/write PointF.

[Visual Basic]
NotOverridable Public Property To As PointF _
Implements IScaleEffect.To
[C#]
public PointF To {get; set;}

Implements

IScaleEffect.To

See Also

ScaleEffect Class | Aspose.Slides.Animation Namespace


ZoomContent Property

Aspose.Slides Documentation

ScaleEffect.ZoomContent Property

Determines whether a content should be zoomed.

[Visual Basic]
NotOverridable Public Property ZoomContent As NullableBool _
Implements IScaleEffect.ZoomContent
[C#]
public NullableBool ZoomContent {get; set;}

Implements

IScaleEffect.ZoomContent

See Also

ScaleEffect Class | Aspose.Slides.Animation Namespace


Sequence Class

Represent sequence (collection of effects).

For a list of all members of this type, see Sequence Members.

System.Object
Aspose.Slides.Animation.Sequence

[Visual Basic]
NotInheritable Public Class Sequence
Implements ISequence, IEnumerable
[C#]
public sealed class Sequence : ISequence, IEnumerable

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Sequence Members | Aspose.Slides.Animation Namespace


Sequence Members

Sequence overview

Public Instance Properties

Count | Returns the number of effects in a sequense.
Item | Returns an effect at the specified index.
TriggerShape | Returns or set shape target for INTERACTIVE sequence. If sequence is not interactive then returns null. Read/write Shape.

Public Instance Methods

AddEffect | Add new effect to the end of sequence.
Clear | Removes all effects from a collection.
GetCount | Returns count of effects for the specified shape.
GetEffectsByShape | Returns array of effects by specify shape.
GetEnumerator | Returns an iterator for a collection.
Remove | Removes specified effect from a collection.
RemoveAt | Removes an effect from a collection.
RemoveByShape | Remove effect by specify shape.

See Also

Sequence Class | Aspose.Slides.Animation Namespace


Sequence Properties

The properties of the Sequence class are listed below. For a complete list of Sequence class members, see the Sequence Members topic.

Public Instance Properties

Count | Returns the number of effects in a sequense.
Item | Returns an effect at the specified index.
TriggerShape | Returns or set shape target for INTERACTIVE sequence. If sequence is not interactive then returns null. Read/write Shape.

See Also

Sequence Class | Aspose.Slides.Animation Namespace


Count Property

Aspose.Slides Documentation

Sequence.Count Property

Returns the number of effects in a sequense.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ISequence.Count
[C#]
public int Count {get;}

Implements

ISequence.Count

See Also

Sequence Class | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

Sequence.Item Property

Returns an effect at the specified index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ISequence.Item
As IEffect _
Implements ISequence.Item
[C#]
public IEffect this[
int index
] {get;}

Parameters

index

Implements

ISequence.Item

See Also

Sequence Class | Aspose.Slides.Animation Namespace


TriggerShape Property

Aspose.Slides Documentation

Sequence.TriggerShape Property

Returns or set shape target for INTERACTIVE sequence. If sequence is not interactive then returns null. Read/write Shape.

[Visual Basic]
NotOverridable Public Property TriggerShape As IShape _
Implements ISequence.TriggerShape
[C#]
public IShape TriggerShape {get; set;}

Implements

ISequence.TriggerShape

See Also

Sequence Class | Aspose.Slides.Animation Namespace


Sequence Methods

The methods of the Sequence class are listed below. For a complete list of Sequence class members, see the Sequence Members topic.

Public Instance Methods

AddEffect | Add new effect to the end of sequence.
Clear | Removes all effects from a collection.
GetCount | Returns count of effects for the specified shape.
GetEffectsByShape | Returns array of effects by specify shape.
GetEnumerator | Returns an iterator for a collection.
Remove | Removes specified effect from a collection.
RemoveAt | Removes an effect from a collection.
RemoveByShape | Remove effect by specify shape.

See Also

Sequence Class | Aspose.Slides.Animation Namespace


Sequence.AddEffect Method

Add new effect to the end of sequence.

[Visual Basic]
NotOverridable Public Function AddEffect( _
ByVal shape As IShape, _
ByVal effectType As EffectType, _
ByVal subtype As EffectSubtype, _
ByVal triggerType As EffectTriggerType _
) As IEffect _
Implements ISequence.AddEffect
[C#]
public IEffect AddEffect(
IShape shape,
EffectType effectType,
EffectSubtype subtype,
EffectTriggerType triggerType
);

Implements

ISequence.AddEffect

See Also

Sequence Class | Aspose.Slides.Animation Namespace


Sequence.Clear Method

Removes all effects from a collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements ISequence.Clear
[C#]
public void Clear();

Implements

ISequence.Clear

See Also

Sequence Class | Aspose.Slides.Animation Namespace


Sequence.GetCount Method

Returns count of effects for the specified shape.

[Visual Basic]
NotOverridable Public Function GetCount( _
ByVal shape As IShape _
) As Integer _
Implements ISequence.GetCount
[C#]
public int GetCount(
IShape shape
);

Implements

ISequence.GetCount

See Also

Sequence Class | Aspose.Slides.Animation Namespace


Sequence.GetEffectsByShape Method

Returns array of effects by specify shape.

[Visual Basic]
NotOverridable Public Function GetEffectsByShape( _
ByVal shape As IShape _
) As IEffect() _
Implements ISequence.GetEffectsByShape
[C#]
public IEffect[] GetEffectsByShape(
IShape shape
);

Implements

ISequence.GetEffectsByShape

See Also

Sequence Class | Aspose.Slides.Animation Namespace


Sequence.GetEnumerator Method

Returns an iterator for a collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

Sequence Class | Aspose.Slides.Animation Namespace


Sequence.Remove Method

Removes specified effect from a collection.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal item As IEffect _
) _
Implements ISequence.Remove
[C#]
public void Remove(
IEffect item
);

Parameters

item
Effect to remove.

Implements

ISequence.Remove

See Also

Sequence Class | Aspose.Slides.Animation Namespace


Sequence.RemoveAt Method

Removes an effect from a collection.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements ISequence.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index

Implements

ISequence.RemoveAt

See Also

Sequence Class | Aspose.Slides.Animation Namespace


Sequence.RemoveByShape Method

Remove effect by specify shape.

[Visual Basic]
NotOverridable Public Sub RemoveByShape( _
ByVal shape As IShape _
) _
Implements ISequence.RemoveByShape
[C#]
public void RemoveByShape(
IShape shape
);

Implements

ISequence.RemoveByShape

See Also

Sequence Class | Aspose.Slides.Animation Namespace


SequenceCollection Class

Represent collection of interactive sequences.

For a list of all members of this type, see SequenceCollection Members.

System.Object
Aspose.Slides.Animation.SequenceCollection

[Visual Basic]
Public Class SequenceCollection
Implements ISequenceCollection, IEnumerable`1([Aspose.Slides.Animation.ISequence, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public class SequenceCollection : ISequenceCollection, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SequenceCollection Members | Aspose.Slides.Animation Namespace


SequenceCollection Members

SequenceCollection overview

Public Instance Properties

Count | Returns the number of elements in a collection
Item | Returns a sequense at the specified index.

Public Instance Methods

Add | Add new interactive sequence. Read/write Sequence.
Clear | Removes all sequences from a collection.
GetEnumerator | Returns an iterator for a collection.
Remove | Removes specified sequence from a collection.
RemoveAt | Removes sequence at the specified index.

See Also

SequenceCollection Class | Aspose.Slides.Animation Namespace


SequenceCollection Properties

The properties of the SequenceCollection class are listed below. For a complete list of SequenceCollection class members, see the SequenceCollection Members topic.

Public Instance Properties

Count | Returns the number of elements in a collection
Item | Returns a sequense at the specified index.

See Also

SequenceCollection Class | Aspose.Slides.Animation Namespace


Count Property

Aspose.Slides Documentation

SequenceCollection.Count Property

Returns the number of elements in a collection

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ISequenceCollection.Count
[C#]
public int Count {get;}

Implements

ISequenceCollection.Count

See Also

SequenceCollection Class | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

SequenceCollection.Item Property

Returns a sequense at the specified index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ISequenceCollection.Item
As ISequence _
Implements ISequenceCollection.Item
[C#]
public ISequence this[
int index
] {get;}

Parameters

index

Implements

ISequenceCollection.Item

See Also

SequenceCollection Class | Aspose.Slides.Animation Namespace


SequenceCollection Methods

The methods of the SequenceCollection class are listed below. For a complete list of SequenceCollection class members, see the SequenceCollection Members topic.

Public Instance Methods

Add | Add new interactive sequence. Read/write Sequence.
Clear | Removes all sequences from a collection.
GetEnumerator | Returns an iterator for a collection.
Remove | Removes specified sequence from a collection.
RemoveAt | Removes sequence at the specified index.

See Also

SequenceCollection Class | Aspose.Slides.Animation Namespace


SequenceCollection.Add Method

Add new interactive sequence. Read/write Sequence.

[Visual Basic]
NotOverridable Public Function Add( _
ByVal shapeTrigger As IShape _
) As ISequence _
Implements ISequenceCollection.Add
[C#]
public ISequence Add(
IShape shapeTrigger
);

Implements

ISequenceCollection.Add

See Also

SequenceCollection Class | Aspose.Slides.Animation Namespace


SequenceCollection.Clear Method

Removes all sequences from a collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements ISequenceCollection.Clear
[C#]
public void Clear();

Implements

ISequenceCollection.Clear

See Also

SequenceCollection Class | Aspose.Slides.Animation Namespace


SequenceCollection.GetEnumerator Method

Returns an iterator for a collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

SequenceCollection Class | Aspose.Slides.Animation Namespace


SequenceCollection.Remove Method

Removes specified sequence from a collection.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal item As ISequence _
) _
Implements ISequenceCollection.Remove
[C#]
public void Remove(
ISequence item
);

Parameters

item
Sequence to remove.

Implements

ISequenceCollection.Remove

See Also

SequenceCollection Class | Aspose.Slides.Animation Namespace


SequenceCollection.RemoveAt Method

Removes sequence at the specified index.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements ISequenceCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index

Implements

ISequenceCollection.RemoveAt

See Also

SequenceCollection Class | Aspose.Slides.Animation Namespace


SetEffect Class

Represents a set effect for an animation behavior.

For a list of all members of this type, see SetEffect Members.

System.Object
Aspose.Slides.Animation.Behavior
Aspose.Slides.Animation.SetEffect

[Visual Basic]
Public Class SetEffect
Inherits Behavior
Implements ISetEffect
[C#]
public class SetEffect : Behavior, ISetEffect

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SetEffect Members | Aspose.Slides.Animation Namespace


SetEffect Members

SetEffect overview

Public Instance Constructors

SetEffect Constructor Initializes a new instance of the SetEffect class.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
To | Specifies the certain attribute of a effect after an animation effect. Represents point value. Only: bool, ColorFormat, float, int, string. Read/write Object.

See Also

SetEffect Class | Aspose.Slides.Animation Namespace


SetEffect Constructor

Initializes a new instance of the SetEffect class.

[Visual Basic]
Public Sub New()
[C#]
public SetEffect();

See Also

SetEffect Class | Aspose.Slides.Animation Namespace


SetEffect Properties

The properties of the SetEffect class are listed below. For a complete list of SetEffect class members, see the SetEffect Members topic.

Public Instance Properties

Accumulate (inherited from Behavior) | Represents whether animation behaviors are accumulated. Read/write NullableBool.
Additive (inherited from Behavior) | Represents whether the current animation behavior is combined with other running animations. Read/write BehaviorAdditiveType.
Properties (inherited from Behavior) | Represents properties of behavior. Read-only BehaviorProperties.
Timing (inherited from Behavior) | Represents timing properties for the effect behavior. Read/write Timing.
To | Specifies the certain attribute of a effect after an animation effect. Represents point value. Only: bool, ColorFormat, float, int, string. Read/write Object.

See Also

SetEffect Class | Aspose.Slides.Animation Namespace


To Property

Aspose.Slides Documentation

SetEffect.To Property

Specifies the certain attribute of a effect after an animation effect. Represents point value. Only: bool, ColorFormat, float, int, string. Read/write Object.

[Visual Basic]
NotOverridable Public Property To As Object _
Implements ISetEffect.To
[C#]
public object To {get; set;}

Implements

ISetEffect.To

See Also

SetEffect Class | Aspose.Slides.Animation Namespace


TextAnimation Class

Represent text animation.

For a list of all members of this type, see TextAnimation Members.

System.Object
Aspose.Slides.Animation.TextAnimation

[Visual Basic]
Public Class TextAnimation
Implements ITextAnimation
[C#]
public class TextAnimation : ITextAnimation

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TextAnimation Members | Aspose.Slides.Animation Namespace


TextAnimation Members

TextAnimation overview

Public Instance Constructors

TextAnimation Constructor Initializes a new instance of the TextAnimation class.

Public Instance Properties

BuildType | List of build type (for exp. Paragraph 1,2,3, All at Once) of text animation.
EffectAnimateBackgroundShape | Linked shape effect with group or not (null)

Public Instance Methods

AddEffect Add new effect to the end of current sequence to end of group text animations. Only valid if count of text paragraphs equal or greater of counts effect of this group!

See Also

TextAnimation Class | Aspose.Slides.Animation Namespace


TextAnimation Constructor

Initializes a new instance of the TextAnimation class.

[Visual Basic]
Public Sub New()
[C#]
public TextAnimation();

See Also

TextAnimation Class | Aspose.Slides.Animation Namespace


TextAnimation Properties

The properties of the TextAnimation class are listed below. For a complete list of TextAnimation class members, see the TextAnimation Members topic.

Public Instance Properties

BuildType | List of build type (for exp. Paragraph 1,2,3, All at Once) of text animation.
EffectAnimateBackgroundShape | Linked shape effect with group or not (null)

See Also

TextAnimation Class | Aspose.Slides.Animation Namespace


BuildType Property

Aspose.Slides Documentation

TextAnimation.BuildType Property

List of build type (for exp. Paragraph 1,2,3, All at Once) of text animation.

[Visual Basic]
NotOverridable Public Property BuildType As BuildType _
Implements ITextAnimation.BuildType
[C#]
public BuildType BuildType {get; set;}

Implements

ITextAnimation.BuildType

See Also

TextAnimation Class | Aspose.Slides.Animation Namespace


EffectAnimateBackgroundShape Property

Aspose.Slides Documentation

TextAnimation.EffectAnimateBackgroundShape Property

Linked shape effect with group or not (null)

[Visual Basic]
NotOverridable Public Property EffectAnimateBackgroundShape As IEffect _
Implements ITextAnimation.EffectAnimateBackgroundShape
[C#]
public IEffect EffectAnimateBackgroundShape {get; set;}

Implements

ITextAnimation.EffectAnimateBackgroundShape

See Also

TextAnimation Class | Aspose.Slides.Animation Namespace


TextAnimation Methods

The methods of the TextAnimation class are listed below. For a complete list of TextAnimation class members, see the TextAnimation Members topic.

Public Instance Methods

AddEffect Add new effect to the end of current sequence to end of group text animations. Only valid if count of text paragraphs equal or greater of counts effect of this group!

See Also

TextAnimation Class | Aspose.Slides.Animation Namespace


TextAnimation.AddEffect Method

Add new effect to the end of current sequence to end of group text animations. Only valid if count of text paragraphs equal or greater of counts effect of this group!

[Visual Basic]
NotOverridable Public Function AddEffect( _
ByVal effectType As EffectType, _
ByVal subtype As EffectSubtype, _
ByVal triggerType As EffectTriggerType _
) As IEffect _
Implements ITextAnimation.AddEffect
[C#]
public IEffect AddEffect(
EffectType effectType,
EffectSubtype subtype,
EffectTriggerType triggerType
);

Implements

ITextAnimation.AddEffect

See Also

TextAnimation Class | Aspose.Slides.Animation Namespace


TextAnimationCollection Class

Represent collection of text animations.

For a list of all members of this type, see TextAnimationCollection Members.

System.Object
Aspose.Slides.Animation.TextAnimationCollection

[Visual Basic]
Public Class TextAnimationCollection
Implements ITextAnimationCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Animation.ITextAnimation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class TextAnimationCollection : ITextAnimationCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TextAnimationCollection Members | Aspose.Slides.Animation Namespace


TextAnimationCollection Members

TextAnimationCollection overview

Public Instance Constructors

TextAnimationCollection Constructor Initializes a new instance of the TextAnimationCollection class.

Public Instance Properties

Count | Returns a number of elements in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Overloaded. Returns element by index.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

Add |
CopyTo | Copies all elements from the collection into the specified array.
GetEnumerator | Returns an iterator for a collection.

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace


TextAnimationCollection Constructor

Initializes a new instance of the TextAnimationCollection class.

[Visual Basic]
Public Sub New()
[C#]
public TextAnimationCollection();

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace


TextAnimationCollection Properties

The properties of the TextAnimationCollection class are listed below. For a complete list of TextAnimationCollection class members, see the TextAnimationCollection Members topic.

Public Instance Properties

Count | Returns a number of elements in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Overloaded. Returns element by index.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace


Count Property

Aspose.Slides Documentation

TextAnimationCollection.Count Property

Returns a number of elements in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace


IsSynchronized Property

Aspose.Slides Documentation

TextAnimationCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace


Item Property

Aspose.Slides Documentation

TextAnimationCollection.Item Property

Returns all elements

Overload List

Returns all elements

public ITextAnimation[] this[Aspose.Slides.IShape] {get;}

Returns element by index.

public ITextAnimation this[int] {get;}

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace


Item Property (IShape)

Aspose.Slides Documentation

TextAnimationCollection.Item Property (IShape)

Returns all elements

[Visual Basic]
NotOverridable Overloads Public Default ReadOnly Property Item( _
ByVal shape As IShape _
) _
Implements ITextAnimationCollection.Item
As ITextAnimation() _
Implements ITextAnimationCollection.Item
[C#]
public ITextAnimation[] this[
Aspose.Slides.IShape shape
] {get;}

Parameters

shape

Implements

ITextAnimationCollection.Item

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace | TextAnimationCollection.Item Overload List


Item Property (Int32)

Aspose.Slides Documentation

TextAnimationCollection.Item Property (Int32)

Returns element by index.

[Visual Basic]
NotOverridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ITextAnimationCollection.Item
As ITextAnimation _
Implements ITextAnimationCollection.Item
[C#]
public ITextAnimation this[
int index
] {get;}

Implements

ITextAnimationCollection.Item

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace | TextAnimationCollection.Item Overload List


SyncRoot Property

Aspose.Slides Documentation

TextAnimationCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace


TextAnimationCollection Methods

The methods of the TextAnimationCollection class are listed below. For a complete list of TextAnimationCollection class members, see the TextAnimationCollection Members topic.

Public Instance Methods

Add |
CopyTo | Copies all elements from the collection into the specified array.
GetEnumerator | Returns an iterator for a collection.

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace


TextAnimationCollection.Add Method

[Visual Basic]
Public Function Add() As TextAnimation
[C#]
public TextAnimation Add();

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace


TextAnimationCollection.CopyTo Method

Copies all elements from the collection into the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Array to fill.
index
Starting position in target array.

Implements

ICollection.CopyTo

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace


TextAnimationCollection.GetEnumerator Method

Returns an iterator for a collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

TextAnimationCollection Class | Aspose.Slides.Animation Namespace


Timing Class

Represents animation timing.

For a list of all members of this type, see Timing Members.

System.Object
Aspose.Slides.Animation.Timing

[Visual Basic]
Public Class Timing
Implements ITiming
[C#]
public class Timing : ITiming

Requirements

Namespace: Aspose.Slides.Animation

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Timing Members | Aspose.Slides.Animation Namespace


Timing Members

Timing overview

Public Instance Constructors

Timing Constructor Initializes a new instance of the Timing class.

Public Instance Properties

Accelerate | Describes the percentage of duration accelerate behavior effect. Read/write Single.
AutoReverse | Describes whether to automatically play the animation in reverse after playing it in the forward direction. Read/write Boolean.
Decelerate | Describes the percentage of duration decelerate behavior effect. Read/write Single.
Duration | Describes the duration of animation effect. Read/write Single.
RepeatCount | Describes the number of times the effect should repeat. Read/write Single.
RepeatDuration | Describes the number of times the effect should repeat. Read/write Single.
Restart | Specifies if a effect is to restart after complete. Read/write Single.
Speed | Specifies the percentage by which to speed up (or slow down) the timing. Read/write Single.
TriggerDelayTime | Describes delay time after trigger. Read/write Single.
TriggerType | Describes trigger type. Read/write EffectTriggerType.

See Also

Timing Class | Aspose.Slides.Animation Namespace


Timing Constructor

Initializes a new instance of the Timing class.

[Visual Basic]
Public Sub New()
[C#]
public Timing();

See Also

Timing Class | Aspose.Slides.Animation Namespace


Timing Properties

The properties of the Timing class are listed below. For a complete list of Timing class members, see the Timing Members topic.

Public Instance Properties

Accelerate | Describes the percentage of duration accelerate behavior effect. Read/write Single.
AutoReverse | Describes whether to automatically play the animation in reverse after playing it in the forward direction. Read/write Boolean.
Decelerate | Describes the percentage of duration decelerate behavior effect. Read/write Single.
Duration | Describes the duration of animation effect. Read/write Single.
RepeatCount | Describes the number of times the effect should repeat. Read/write Single.
RepeatDuration | Describes the number of times the effect should repeat. Read/write Single.
Restart | Specifies if a effect is to restart after complete. Read/write Single.
Speed | Specifies the percentage by which to speed up (or slow down) the timing. Read/write Single.
TriggerDelayTime | Describes delay time after trigger. Read/write Single.
TriggerType | Describes trigger type. Read/write EffectTriggerType.

See Also

Timing Class | Aspose.Slides.Animation Namespace


Accelerate Property

Aspose.Slides Documentation

Timing.Accelerate Property

Describes the percentage of duration accelerate behavior effect. Read/write Single.

[Visual Basic]
NotOverridable Public Property Accelerate As Single _
Implements ITiming.Accelerate
[C#]
public float Accelerate {get; set;}

Implements

ITiming.Accelerate

See Also

Timing Class | Aspose.Slides.Animation Namespace


AutoReverse Property

Aspose.Slides Documentation

Timing.AutoReverse Property

Describes whether to automatically play the animation in reverse after playing it in the forward direction. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property AutoReverse As Boolean _
Implements ITiming.AutoReverse
[C#]
public bool AutoReverse {get; set;}

Implements

ITiming.AutoReverse

See Also

Timing Class | Aspose.Slides.Animation Namespace


Decelerate Property

Aspose.Slides Documentation

Timing.Decelerate Property

Describes the percentage of duration decelerate behavior effect. Read/write Single.

[Visual Basic]
NotOverridable Public Property Decelerate As Single _
Implements ITiming.Decelerate
[C#]
public float Decelerate {get; set;}

Implements

ITiming.Decelerate

See Also

Timing Class | Aspose.Slides.Animation Namespace


Duration Property

Aspose.Slides Documentation

Timing.Duration Property

Describes the duration of animation effect. Read/write Single.

[Visual Basic]
NotOverridable Public Property Duration As Single _
Implements ITiming.Duration
[C#]
public float Duration {get; set;}

Implements

ITiming.Duration

See Also

Timing Class | Aspose.Slides.Animation Namespace


RepeatCount Property

Aspose.Slides Documentation

Timing.RepeatCount Property

Describes the number of times the effect should repeat. Read/write Single.

[Visual Basic]
NotOverridable Public Property RepeatCount As Single _
Implements ITiming.RepeatCount
[C#]
public float RepeatCount {get; set;}

Implements

ITiming.RepeatCount

See Also

Timing Class | Aspose.Slides.Animation Namespace


RepeatDuration Property

Aspose.Slides Documentation

Timing.RepeatDuration Property

Describes the number of times the effect should repeat. Read/write Single.

[Visual Basic]
NotOverridable Public Property RepeatDuration As Single _
Implements ITiming.RepeatDuration
[C#]
public float RepeatDuration {get; set;}

Implements

ITiming.RepeatDuration

See Also

Timing Class | Aspose.Slides.Animation Namespace


Restart Property

Aspose.Slides Documentation

Timing.Restart Property

Specifies if a effect is to restart after complete. Read/write Single.

[Visual Basic]
NotOverridable Public Property Restart As EffectRestartType _
Implements ITiming.Restart
[C#]
public EffectRestartType Restart {get; set;}

Implements

ITiming.Restart

See Also

Timing Class | Aspose.Slides.Animation Namespace


Speed Property

Aspose.Slides Documentation

Timing.Speed Property

Specifies the percentage by which to speed up (or slow down) the timing. Read/write Single.

[Visual Basic]
NotOverridable Public Property Speed As Single _
Implements ITiming.Speed
[C#]
public float Speed {get; set;}

Implements

ITiming.Speed

See Also

Timing Class | Aspose.Slides.Animation Namespace


TriggerDelayTime Property

Aspose.Slides Documentation

Timing.TriggerDelayTime Property

Describes delay time after trigger. Read/write Single.

[Visual Basic]
NotOverridable Public Property TriggerDelayTime As Single _
Implements ITiming.TriggerDelayTime
[C#]
public float TriggerDelayTime {get; set;}

Implements

ITiming.TriggerDelayTime

See Also

Timing Class | Aspose.Slides.Animation Namespace


TriggerType Property

Aspose.Slides Documentation

Timing.TriggerType Property

Describes trigger type. Read/write EffectTriggerType.

[Visual Basic]
NotOverridable Public Property TriggerType As EffectTriggerType _
Implements ITiming.TriggerType
[C#]
public EffectTriggerType TriggerType {get; set;}

Implements

ITiming.TriggerType

See Also

Timing Class | Aspose.Slides.Animation Namespace


Aspose.Slides.Charts

Aspose.Slides Documentation

Aspose.Slides.Charts Namespace

Namespace hierarchy

Classes

Class | Description
AxesManager | Provide access to chart axes.
Axis | Encapsulates the object that represents a chart's axis.
AxisFormat | Represents chart format properties.
BaseChartValue |
CannotCombine2DAnd3DChartsException |
Chart | Represents an graphic chart on a slide.
ChartCategory | Represents chart categories.
ChartCategoryCollection | Represents collection of ChartCategory
ChartCategoryLevelsManager | Managed container of the values of the chart category levels.
ChartCellCollection | Represents collection of a cells with data.
ChartData | Represents data used for a chart plotting.
ChartDataCell | Represents cell for chart data
ChartDataPoint | Represents series data point.
ChartDataPointCollection | Represents collection of a series data point.
ChartDataWorkbook | Provides access to embedded Excel workbook
ChartDataWorksheet | Represents worksheet associated with IChartDataCell
ChartLinesFormat | Represents gridlines format properties.
ChartPlotArea | Represents rectangle where chart should be plotted.
ChartSeries | Represents a chart series.
ChartSeriesCollection | Represents collection of ChartSeries
ChartSeriesGroup | Represents group of series.
ChartTextFormat | Specifies default text formatting for chart text elements.
ChartTitle | Represents chart title properties.
ChartTypeCharacterizer |
ChartWall | Represents walls on 3d charts.
DataLabel | Represents a series labels.
DataLabelCollection | Represents a series labels.
DataLabelFormat |
DataTable | Represents data table properties.
DoubleChartValue | Represent double value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.
Format | Represents chart format properties.
Legend | Represents chart's legend properties.
LegendEntryCollection |
LegendEntryProperties |
Marker |
PreferredAxesCompositionIsNotCombinableException |
Rotation3D | Represents 3D rotation of a chart.
StringChartValue | Represent string value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.
StringOrDoubleChartValue | Represent string or double value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.
Trendline | Class represents trend line of chart series
TrendlineCollection | Represents a collection of Trendline
UpDownBarsManager | Provide access to up/down bars of Line- or Stock-chart.

Interfaces

Interface | Description
IAxesManager |
IAxis |
IAxisFormat |
IBaseChartValue |
IChart |
IChartCategory |
IChartCategoryCollection |
IChartCategoryLevelsManager |
IChartCellCollection |
IChartComponent |
IChartData |
IChartDataCell |
IChartDataPoint |
IChartDataPointCollection |
IChartDataWorkbook |
IChartDataWorksheet |
IChartLinesFormat |
IChartParagraphFormat |
IChartPlotArea |
IChartPortionFormat |
IChartSeries |
IChartSeriesCollection |
IChartSeriesGroup |
IChartSeriesGroupCollection |
IChartSeriesReadonlyCollection |
IChartTextBlockFormat |
IChartTextFormat |
IChartTitle |
IChartWall |
IDataLabel |
IDataLabelCollection |
IDataLabelFormat |
IDataTable |
IDoubleChartValue |
IFormat |
IFormattedTextContainer |
ILayoutable |
ILegend |
ILegendEntryCollection |
ILegendEntryProperties |
IMarker |
IMultipleCellChartValue |
IOverridableText |
IRotation3D |
ISingleCellChartValue |
IStringChartValue |
IStringOrDoubleChartValue |
ITrendline |
ITrendlineCollection |
IUpDownBarsManager |

Enumerations

Enumeration | Description
AxisPositionType |
ChartShapeType |
ChartType |
CombinableSeriesTypesGroup |
CrossesType |
DataSourceType |
DisplayBlanksAsType |
DisplayUnitType |
LegendDataLabelPosition |
LegendPositionType |
MarkerStyleType |
PictureType |
StyleType |
TickLabelPositionType |
TickMarkType |
TimeUnitType |
TrendlineType |


AxesManager Class

Provide access to chart axes.

For a list of all members of this type, see AxesManager Members.

System.Object
Aspose.Slides.Charts.AxesManager

[Visual Basic]
Public Class AxesManager
Implements IAxesManager
[C#]
public class AxesManager : IAxesManager

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AxesManager Members | Aspose.Slides.Charts Namespace


AxesManager Members

AxesManager overview

Public Instance Properties

HorizontalAxis | Gets the chart's horizontal axis.
SecondaryHorizontalAxis | Gets the chart's secondary horizontal axis.
SecondaryVerticalAxis | Gets the chart's secondary vertical axis.
SeriesAxis | Gets the chart's series axis.
VerticalAxis | Gets the chart's vertical axis.

See Also

AxesManager Class | Aspose.Slides.Charts Namespace


AxesManager Properties

The properties of the AxesManager class are listed below. For a complete list of AxesManager class members, see the AxesManager Members topic.

Public Instance Properties

HorizontalAxis | Gets the chart's horizontal axis.
SecondaryHorizontalAxis | Gets the chart's secondary horizontal axis.
SecondaryVerticalAxis | Gets the chart's secondary vertical axis.
SeriesAxis | Gets the chart's series axis.
VerticalAxis | Gets the chart's vertical axis.

See Also

AxesManager Class | Aspose.Slides.Charts Namespace


HorizontalAxis Property

Aspose.Slides Documentation

AxesManager.HorizontalAxis Property

Gets the chart's horizontal axis.

[Visual Basic]
NotOverridable Public ReadOnly Property HorizontalAxis As IAxis _
Implements IAxesManager.HorizontalAxis
[C#]
public IAxis HorizontalAxis {get;}

Implements

IAxesManager.HorizontalAxis

See Also

AxesManager Class | Aspose.Slides.Charts Namespace


SecondaryHorizontalAxis Property

Aspose.Slides Documentation

AxesManager.SecondaryHorizontalAxis Property

Gets the chart's secondary horizontal axis.

[Visual Basic]
NotOverridable Public ReadOnly Property SecondaryHorizontalAxis As IAxis _
Implements IAxesManager.SecondaryHorizontalAxis
[C#]
public IAxis SecondaryHorizontalAxis {get;}

Implements

IAxesManager.SecondaryHorizontalAxis

See Also

AxesManager Class | Aspose.Slides.Charts Namespace


SecondaryVerticalAxis Property

Aspose.Slides Documentation

AxesManager.SecondaryVerticalAxis Property

Gets the chart's secondary vertical axis.

[Visual Basic]
NotOverridable Public ReadOnly Property SecondaryVerticalAxis As IAxis _
Implements IAxesManager.SecondaryVerticalAxis
[C#]
public IAxis SecondaryVerticalAxis {get;}

Implements

IAxesManager.SecondaryVerticalAxis

See Also

AxesManager Class | Aspose.Slides.Charts Namespace


SeriesAxis Property

Aspose.Slides Documentation

AxesManager.SeriesAxis Property

Gets the chart's series axis.

[Visual Basic]
NotOverridable Public ReadOnly Property SeriesAxis As IAxis _
Implements IAxesManager.SeriesAxis
[C#]
public IAxis SeriesAxis {get;}

Implements

IAxesManager.SeriesAxis

See Also

AxesManager Class | Aspose.Slides.Charts Namespace


VerticalAxis Property

Aspose.Slides Documentation

AxesManager.VerticalAxis Property

Gets the chart's vertical axis.

[Visual Basic]
NotOverridable Public ReadOnly Property VerticalAxis As IAxis _
Implements IAxesManager.VerticalAxis
[C#]
public IAxis VerticalAxis {get;}

Implements

IAxesManager.VerticalAxis

See Also

AxesManager Class | Aspose.Slides.Charts Namespace


Axis Class

Encapsulates the object that represents a chart's axis.

For a list of all members of this type, see Axis Members.

System.Object
Aspose.Slides.Charts.Axis

[Visual Basic]
Public Class Axis
Implements IAxis, IChartComponent, IFormattedTextContainer
[C#]
public class Axis : IAxis, IChartComponent, IFormattedTextContainer

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Axis Members | Aspose.Slides.Charts Namespace


Axis Members

Axis overview

Public Instance Properties

AxisBetweenCategories | Represents if the value axis crosses the category axis between categories.
BaseUnitScale | Specifies the smallest time unit that is represented on the date axis.
Chart | Returns the parent chart. Read-only IChart.
CrossAt | Represents the point on the axis where the perpendicular axis crosses it.
CrossType | Represents the CrossType on the specified axis where the other axis crosses.
DisplayUnit | Specifies the scaling value of the display units for the value axis.
Format | Represents format of axis
HasTitle | Determines whether a axis has a visible title. Read/write Boolean.
IsAutomaticMajorUnit | Indicates whether the major unit of the axis is automatically assigned.
IsAutomaticMaxValue | Indicates whether the max value is automatically assigned.
IsAutomaticMinorUnit | Indicates whether the minor unit of the axis is automatically assigned.
IsAutomaticMinValue | Indicates whether the min value is automatically assigned.
IsAutomaticTickLabelSpacing | Specifies automatic tick label spacing value. If false: use TickLabelSpacing property.
IsLogarithmic | Represents if the value axis scale type is logarithmic or not.
IsNumberFormatLinkedToSource | Indicates whether the format is linked source data.
IsPlotOrderReversed | Represents if MS PowerPoint plots data points from last to first.
IsVisible | Represents if the axis is visible.
LogBase | Represents the logarithmic base. Default value is 10.
MajorGridLinesFormat | Represents major gridlines format on a chart axis.
MajorTickMark | Represents the type of major tick mark for the specified axis.
MajorUnit | Represents the major units for the date or value axis.
MajorUnitScale | Represents the major unit scale for the date axis.
MaxValue | Represents the maximum value on the value axis.
MinorGridLinesFormat | Represents minor gridlines format on a chart axis.
MinorTickMark | Represents the type of minor tick mark for the specified axis.
MinorUnit | Represents the minor units for the date or value axis.
MinorUnitScale | Represents the major unit scale for the date axis.
MinValue | Represents the minimum value on the value axis.
NumberFormat | Represents the format string for the Axis Labels.
Position | Represents position of axis
RotationAngle | Obsolete. Represents the rotation angle of tick labels
ShowMajorGridLines | To hide major gridline set MajorGridLinesFormat.Line.FillFormat.FillType to FillType.NoFill.
ShowMinorGridLines | To hide minor gridline set MinorGridLinesFormat.Line.FillFormat.FillType to FillType.NoFill.
SourceLinked | Obsolete. Indicates whether the format is linked source data.
TextFormat |
TickLabelPosition | Represents the position of tick-mark labels on the specified axis.
TickLabelRotationAngle | Represents the rotation angle of tick labels
TickLabelSpacing | Specifies how many tick labels to skip between label that is drawn. Applied to category or series axis.
Title | Gets the axis' title.

See Also

Axis Class | Aspose.Slides.Charts Namespace


Axis Properties

The properties of the Axis class are listed below. For a complete list of Axis class members, see the Axis Members topic.

Public Instance Properties

AxisBetweenCategories | Represents if the value axis crosses the category axis between categories.
BaseUnitScale | Specifies the smallest time unit that is represented on the date axis.
Chart | Returns the parent chart. Read-only IChart.
CrossAt | Represents the point on the axis where the perpendicular axis crosses it.
CrossType | Represents the CrossType on the specified axis where the other axis crosses.
DisplayUnit | Specifies the scaling value of the display units for the value axis.
Format | Represents format of axis
HasTitle | Determines whether a axis has a visible title. Read/write Boolean.
IsAutomaticMajorUnit | Indicates whether the major unit of the axis is automatically assigned.
IsAutomaticMaxValue | Indicates whether the max value is automatically assigned.
IsAutomaticMinorUnit | Indicates whether the minor unit of the axis is automatically assigned.
IsAutomaticMinValue | Indicates whether the min value is automatically assigned.
IsAutomaticTickLabelSpacing | Specifies automatic tick label spacing value. If false: use TickLabelSpacing property.
IsLogarithmic | Represents if the value axis scale type is logarithmic or not.
IsNumberFormatLinkedToSource | Indicates whether the format is linked source data.
IsPlotOrderReversed | Represents if MS PowerPoint plots data points from last to first.
IsVisible | Represents if the axis is visible.
LogBase | Represents the logarithmic base. Default value is 10.
MajorGridLinesFormat | Represents major gridlines format on a chart axis.
MajorTickMark | Represents the type of major tick mark for the specified axis.
MajorUnit | Represents the major units for the date or value axis.
MajorUnitScale | Represents the major unit scale for the date axis.
MaxValue | Represents the maximum value on the value axis.
MinorGridLinesFormat | Represents minor gridlines format on a chart axis.
MinorTickMark | Represents the type of minor tick mark for the specified axis.
MinorUnit | Represents the minor units for the date or value axis.
MinorUnitScale | Represents the major unit scale for the date axis.
MinValue | Represents the minimum value on the value axis.
NumberFormat | Represents the format string for the Axis Labels.
Position | Represents position of axis
RotationAngle | Obsolete. Represents the rotation angle of tick labels
ShowMajorGridLines | To hide major gridline set MajorGridLinesFormat.Line.FillFormat.FillType to FillType.NoFill.
ShowMinorGridLines | To hide minor gridline set MinorGridLinesFormat.Line.FillFormat.FillType to FillType.NoFill.
SourceLinked | Obsolete. Indicates whether the format is linked source data.
TextFormat |
TickLabelPosition | Represents the position of tick-mark labels on the specified axis.
TickLabelRotationAngle | Represents the rotation angle of tick labels
TickLabelSpacing | Specifies how many tick labels to skip between label that is drawn. Applied to category or series axis.
Title | Gets the axis' title.

See Also

Axis Class | Aspose.Slides.Charts Namespace


AxisBetweenCategories Property

Aspose.Slides Documentation

Axis.AxisBetweenCategories Property

Represents if the value axis crosses the category axis between categories.

[Visual Basic]
NotOverridable Public Property AxisBetweenCategories As Boolean _
Implements IAxis.AxisBetweenCategories
[C#]
public bool AxisBetweenCategories {get; set;}

Implements

IAxis.AxisBetweenCategories

See Also

Axis Class | Aspose.Slides.Charts Namespace


BaseUnitScale Property

Aspose.Slides Documentation

Axis.BaseUnitScale Property

Specifies the smallest time unit that is represented on the date axis.

[Visual Basic]
NotOverridable Public Property BaseUnitScale As TimeUnitType _
Implements IAxis.BaseUnitScale
[C#]
public TimeUnitType BaseUnitScale {get; set;}

Implements

IAxis.BaseUnitScale

See Also

Axis Class | Aspose.Slides.Charts Namespace


Chart Property

Aspose.Slides Documentation

Axis.Chart Property

Returns the parent chart. Read-only IChart.

[Visual Basic]
NotOverridable Public ReadOnly Property Chart As IChart _
Implements IChartComponent.Chart
[C#]
public IChart Chart {get;}

Implements

IChartComponent.Chart

See Also

Axis Class | Aspose.Slides.Charts Namespace


CrossAt Property

Aspose.Slides Documentation

Axis.CrossAt Property

Represents the point on the axis where the perpendicular axis crosses it.

[Visual Basic]
NotOverridable Public Property CrossAt As Single _
Implements IAxis.CrossAt
[C#]
public float CrossAt {get; set;}

Implements

IAxis.CrossAt

See Also

Axis Class | Aspose.Slides.Charts Namespace


CrossType Property

Aspose.Slides Documentation

Axis.CrossType Property

Represents the CrossType on the specified axis where the other axis crosses.

[Visual Basic]
NotOverridable Public Property CrossType As CrossesType _
Implements IAxis.CrossType
[C#]
public CrossesType CrossType {get; set;}

Implements

IAxis.CrossType

See Also

Axis Class | Aspose.Slides.Charts Namespace


DisplayUnit Property

Aspose.Slides Documentation

Axis.DisplayUnit Property

Specifies the scaling value of the display units for the value axis.

[Visual Basic]
NotOverridable Public Property DisplayUnit As DisplayUnitType _
Implements IAxis.DisplayUnit
[C#]
public DisplayUnitType DisplayUnit {get; set;}

Implements

IAxis.DisplayUnit

See Also

Axis Class | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

Axis.Format Property

Represents format of axis

[Visual Basic]
NotOverridable Public ReadOnly Property Format As IAxisFormat _
Implements IAxis.Format
[C#]
public IAxisFormat Format {get;}

Implements

IAxis.Format

See Also

Axis Class | Aspose.Slides.Charts Namespace


HasTitle Property

Aspose.Slides Documentation

Axis.HasTitle Property

Determines whether a axis has a visible title. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property HasTitle As Boolean _
Implements IAxis.HasTitle
[C#]
public bool HasTitle {get; set;}

Implements

IAxis.HasTitle

See Also

Axis Class | Aspose.Slides.Charts Namespace


IsAutomaticMajorUnit Property

Aspose.Slides Documentation

Axis.IsAutomaticMajorUnit Property

Indicates whether the major unit of the axis is automatically assigned.

[Visual Basic]
NotOverridable Public Property IsAutomaticMajorUnit As Boolean _
Implements IAxis.IsAutomaticMajorUnit
[C#]
public bool IsAutomaticMajorUnit {get; set;}

Implements

IAxis.IsAutomaticMajorUnit

See Also

Axis Class | Aspose.Slides.Charts Namespace


IsAutomaticMaxValue Property

Aspose.Slides Documentation

Axis.IsAutomaticMaxValue Property

Indicates whether the max value is automatically assigned.

[Visual Basic]
NotOverridable Public Property IsAutomaticMaxValue As Boolean _
Implements IAxis.IsAutomaticMaxValue
[C#]
public bool IsAutomaticMaxValue {get; set;}

Implements

IAxis.IsAutomaticMaxValue

See Also

Axis Class | Aspose.Slides.Charts Namespace


IsAutomaticMinorUnit Property

Aspose.Slides Documentation

Axis.IsAutomaticMinorUnit Property

Indicates whether the minor unit of the axis is automatically assigned.

[Visual Basic]
NotOverridable Public Property IsAutomaticMinorUnit As Boolean _
Implements IAxis.IsAutomaticMinorUnit
[C#]
public bool IsAutomaticMinorUnit {get; set;}

Implements

IAxis.IsAutomaticMinorUnit

See Also

Axis Class | Aspose.Slides.Charts Namespace


IsAutomaticMinValue Property

Aspose.Slides Documentation

Axis.IsAutomaticMinValue Property

Indicates whether the min value is automatically assigned.

[Visual Basic]
NotOverridable Public Property IsAutomaticMinValue As Boolean _
Implements IAxis.IsAutomaticMinValue
[C#]
public bool IsAutomaticMinValue {get; set;}

Implements

IAxis.IsAutomaticMinValue

See Also

Axis Class | Aspose.Slides.Charts Namespace


IsAutomaticTickLabelSpacing Property

Aspose.Slides Documentation

Axis.IsAutomaticTickLabelSpacing Property

Specifies automatic tick label spacing value. If false: use TickLabelSpacing property.

[Visual Basic]
NotOverridable Public Property IsAutomaticTickLabelSpacing As Boolean _
Implements IAxis.IsAutomaticTickLabelSpacing
[C#]
public bool IsAutomaticTickLabelSpacing {get; set;}

Implements

IAxis.IsAutomaticTickLabelSpacing

See Also

Axis Class | Aspose.Slides.Charts Namespace


IsLogarithmic Property

Aspose.Slides Documentation

Axis.IsLogarithmic Property

Represents if the value axis scale type is logarithmic or not.

[Visual Basic]
NotOverridable Public Property IsLogarithmic As Boolean _
Implements IAxis.IsLogarithmic
[C#]
public bool IsLogarithmic {get; set;}

Implements

IAxis.IsLogarithmic

See Also

Axis Class | Aspose.Slides.Charts Namespace


IsNumberFormatLinkedToSource Property

Aspose.Slides Documentation

Axis.IsNumberFormatLinkedToSource Property

Indicates whether the format is linked source data.

[Visual Basic]
NotOverridable Public Property IsNumberFormatLinkedToSource As Boolean _
Implements IAxis.IsNumberFormatLinkedToSource
[C#]
public bool IsNumberFormatLinkedToSource {get; set;}

Implements

IAxis.IsNumberFormatLinkedToSource

See Also

Axis Class | Aspose.Slides.Charts Namespace


IsPlotOrderReversed Property

Aspose.Slides Documentation

Axis.IsPlotOrderReversed Property

Represents if MS PowerPoint plots data points from last to first.

[Visual Basic]
NotOverridable Public Property IsPlotOrderReversed As Boolean _
Implements IAxis.IsPlotOrderReversed
[C#]
public bool IsPlotOrderReversed {get; set;}

Implements

IAxis.IsPlotOrderReversed

See Also

Axis Class | Aspose.Slides.Charts Namespace


IsVisible Property

Aspose.Slides Documentation

Axis.IsVisible Property

Represents if the axis is visible.

[Visual Basic]
NotOverridable Public Property IsVisible As Boolean _
Implements IAxis.IsVisible
[C#]
public bool IsVisible {get; set;}

Implements

IAxis.IsVisible

See Also

Axis Class | Aspose.Slides.Charts Namespace


LogBase Property

Aspose.Slides Documentation

Axis.LogBase Property

Represents the logarithmic base. Default value is 10.

[Visual Basic]
NotOverridable Public Property LogBase As Double _
Implements IAxis.LogBase
[C#]
public double LogBase {get; set;}

Implements

IAxis.LogBase

See Also

Axis Class | Aspose.Slides.Charts Namespace


MajorGridLinesFormat Property

Aspose.Slides Documentation

Axis.MajorGridLinesFormat Property

Represents major gridlines format on a chart axis.

[Visual Basic]
NotOverridable Public ReadOnly Property MajorGridLinesFormat As IChartLinesFormat _
Implements IAxis.MajorGridLinesFormat
[C#]
public IChartLinesFormat MajorGridLinesFormat {get;}

Implements

IAxis.MajorGridLinesFormat

See Also

Axis Class | Aspose.Slides.Charts Namespace


MajorTickMark Property

Aspose.Slides Documentation

Axis.MajorTickMark Property

Represents the type of major tick mark for the specified axis.

[Visual Basic]
NotOverridable Public Property MajorTickMark As TickMarkType _
Implements IAxis.MajorTickMark
[C#]
public TickMarkType MajorTickMark {get; set;}

Implements

IAxis.MajorTickMark

See Also

Axis Class | Aspose.Slides.Charts Namespace


MajorUnit Property

Aspose.Slides Documentation

Axis.MajorUnit Property

Represents the major units for the date or value axis.

[Visual Basic]
NotOverridable Public Property MajorUnit As Double _
Implements IAxis.MajorUnit
[C#]
public double MajorUnit {get; set;}

Implements

IAxis.MajorUnit

See Also

Axis Class | Aspose.Slides.Charts Namespace


MajorUnitScale Property

Aspose.Slides Documentation

Axis.MajorUnitScale Property

Represents the major unit scale for the date axis.

[Visual Basic]
NotOverridable Public Property MajorUnitScale As TimeUnitType _
Implements IAxis.MajorUnitScale
[C#]
public TimeUnitType MajorUnitScale {get; set;}

Implements

IAxis.MajorUnitScale

See Also

Axis Class | Aspose.Slides.Charts Namespace


MaxValue Property

Aspose.Slides Documentation

Axis.MaxValue Property

Represents the maximum value on the value axis.

[Visual Basic]
NotOverridable Public Property MaxValue As Double _
Implements IAxis.MaxValue
[C#]
public double MaxValue {get; set;}

Implements

IAxis.MaxValue

See Also

Axis Class | Aspose.Slides.Charts Namespace


MinorGridLinesFormat Property

Aspose.Slides Documentation

Axis.MinorGridLinesFormat Property

Represents minor gridlines format on a chart axis.

[Visual Basic]
NotOverridable Public ReadOnly Property MinorGridLinesFormat As IChartLinesFormat _
Implements IAxis.MinorGridLinesFormat
[C#]
public IChartLinesFormat MinorGridLinesFormat {get;}

Implements

IAxis.MinorGridLinesFormat

See Also

Axis Class | Aspose.Slides.Charts Namespace


MinorTickMark Property

Aspose.Slides Documentation

Axis.MinorTickMark Property

Represents the type of minor tick mark for the specified axis.

[Visual Basic]
NotOverridable Public Property MinorTickMark As TickMarkType _
Implements IAxis.MinorTickMark
[C#]
public TickMarkType MinorTickMark {get; set;}

Implements

IAxis.MinorTickMark

See Also

Axis Class | Aspose.Slides.Charts Namespace


MinorUnit Property

Aspose.Slides Documentation

Axis.MinorUnit Property

Represents the minor units for the date or value axis.

[Visual Basic]
NotOverridable Public Property MinorUnit As Double _
Implements IAxis.MinorUnit
[C#]
public double MinorUnit {get; set;}

Implements

IAxis.MinorUnit

See Also

Axis Class | Aspose.Slides.Charts Namespace


MinorUnitScale Property

Aspose.Slides Documentation

Axis.MinorUnitScale Property

Represents the major unit scale for the date axis.

[Visual Basic]
NotOverridable Public Property MinorUnitScale As TimeUnitType _
Implements IAxis.MinorUnitScale
[C#]
public TimeUnitType MinorUnitScale {get; set;}

Implements

IAxis.MinorUnitScale

See Also

Axis Class | Aspose.Slides.Charts Namespace


MinValue Property

Aspose.Slides Documentation

Axis.MinValue Property

Represents the minimum value on the value axis.

[Visual Basic]
NotOverridable Public Property MinValue As Double _
Implements IAxis.MinValue
[C#]
public double MinValue {get; set;}

Implements

IAxis.MinValue

See Also

Axis Class | Aspose.Slides.Charts Namespace


NumberFormat Property

Aspose.Slides Documentation

Axis.NumberFormat Property

Represents the format string for the Axis Labels.

[Visual Basic]
NotOverridable Public Property NumberFormat As String _
Implements IAxis.NumberFormat
[C#]
public string NumberFormat {get; set;}

Implements

IAxis.NumberFormat

See Also

Axis Class | Aspose.Slides.Charts Namespace


Position Property

Aspose.Slides Documentation

Axis.Position Property

Represents position of axis

[Visual Basic]
NotOverridable Public Property Position As AxisPositionType _
Implements IAxis.Position
[C#]
public AxisPositionType Position {get; set;}

Implements

IAxis.Position

See Also

Axis Class | Aspose.Slides.Charts Namespace


RotationAngle Property

Aspose.Slides Documentation

Axis.RotationAngle Property

NOTE: This property is now obsolete.

Use TickLabelRotationAngle property instead. Property will be removed after 01.09.2013.

Represents the rotation angle of tick labels

[Visual Basic]
Public Property RotationAngle As Single
[C#]
public float RotationAngle {get; set;}

See Also

Axis Class | Aspose.Slides.Charts Namespace


ShowMajorGridLines Property

Aspose.Slides Documentation

Axis.ShowMajorGridLines Property

To hide major gridline set MajorGridLinesFormat.Line.FillFormat.FillType to FillType.NoFill.

[Visual Basic]
NotOverridable Public ReadOnly Property ShowMajorGridLines As Boolean _
Implements IAxis.ShowMajorGridLines
[C#]
public bool ShowMajorGridLines {get;}

Implements

IAxis.ShowMajorGridLines

See Also

Axis Class | Aspose.Slides.Charts Namespace


ShowMinorGridLines Property

Aspose.Slides Documentation

Axis.ShowMinorGridLines Property

To hide minor gridline set MinorGridLinesFormat.Line.FillFormat.FillType to FillType.NoFill.

[Visual Basic]
NotOverridable Public ReadOnly Property ShowMinorGridLines As Boolean _
Implements IAxis.ShowMinorGridLines
[C#]
public bool ShowMinorGridLines {get;}

Implements

IAxis.ShowMinorGridLines

See Also

Axis Class | Aspose.Slides.Charts Namespace


SourceLinked Property

Aspose.Slides Documentation

Axis.SourceLinked Property

NOTE: This property is now obsolete.

Use IsNumberFormatLinkedToSource property instead. Property will be removed after 01.09.2013.

Indicates whether the format is linked source data.

[Visual Basic]
Public Property SourceLinked As Boolean
[C#]
public bool SourceLinked {get; set;}

See Also

Axis Class | Aspose.Slides.Charts Namespace


TextFormat Property

Aspose.Slides Documentation

Axis.TextFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property TextFormat As IChartTextFormat _
Implements IFormattedTextContainer.TextFormat
[C#]
public IChartTextFormat TextFormat {get;}

Implements

IFormattedTextContainer.TextFormat

See Also

Axis Class | Aspose.Slides.Charts Namespace


TickLabelPosition Property

Aspose.Slides Documentation

Axis.TickLabelPosition Property

Represents the position of tick-mark labels on the specified axis.

[Visual Basic]
NotOverridable Public Property TickLabelPosition As TickLabelPositionType _
Implements IAxis.TickLabelPosition
[C#]
public TickLabelPositionType TickLabelPosition {get; set;}

Implements

IAxis.TickLabelPosition

See Also

Axis Class | Aspose.Slides.Charts Namespace


TickLabelRotationAngle Property

Aspose.Slides Documentation

Axis.TickLabelRotationAngle Property

Represents the rotation angle of tick labels

[Visual Basic]
NotOverridable Public Property TickLabelRotationAngle As Single _
Implements IAxis.TickLabelRotationAngle
[C#]
public float TickLabelRotationAngle {get; set;}

Implements

IAxis.TickLabelRotationAngle

See Also

Axis Class | Aspose.Slides.Charts Namespace


TickLabelSpacing Property

Aspose.Slides Documentation

Axis.TickLabelSpacing Property

Specifies how many tick labels to skip between label that is drawn. Applied to category or series axis.

[Visual Basic]
NotOverridable Public Property TickLabelSpacing As UInt32 _
Implements IAxis.TickLabelSpacing
[C#]
public uint TickLabelSpacing {get; set;}

Implements

IAxis.TickLabelSpacing

See Also

Axis Class | Aspose.Slides.Charts Namespace


Title Property

Aspose.Slides Documentation

Axis.Title Property

Gets the axis' title.

[Visual Basic]
NotOverridable Public ReadOnly Property Title As IChartTitle _
Implements IAxis.Title
[C#]
public IChartTitle Title {get;}

Implements

IAxis.Title

See Also

Axis Class | Aspose.Slides.Charts Namespace


AxisFormat Class

Represents chart format properties.

For a list of all members of this type, see AxisFormat Members.

System.Object
Aspose.Slides.Charts.AxisFormat

[Visual Basic]
Public Class AxisFormat
Implements IAxisFormat
[C#]
public class AxisFormat : IAxisFormat

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AxisFormat Members | Aspose.Slides.Charts Namespace


AxisFormat Members

AxisFormat overview

Public Instance Properties

Effect | Returns effects used for an axis. Read-only IEffectFormat.
Fill | Returns fill style properties of an axis. Read-only IFillFormat.
Line | Returns line style properties of an axis. Read-only ILineFormat.

See Also

AxisFormat Class | Aspose.Slides.Charts Namespace


AxisFormat Properties

The properties of the AxisFormat class are listed below. For a complete list of AxisFormat class members, see the AxisFormat Members topic.

Public Instance Properties

Effect | Returns effects used for an axis. Read-only IEffectFormat.
Fill | Returns fill style properties of an axis. Read-only IFillFormat.
Line | Returns line style properties of an axis. Read-only ILineFormat.

See Also

AxisFormat Class | Aspose.Slides.Charts Namespace


Effect Property

Aspose.Slides Documentation

AxisFormat.Effect Property

Returns effects used for an axis. Read-only IEffectFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Effect As IEffectFormat _
Implements IAxisFormat.Effect
[C#]
public IEffectFormat Effect {get;}

Implements

IAxisFormat.Effect

See Also

AxisFormat Class | Aspose.Slides.Charts Namespace


Fill Property

Aspose.Slides Documentation

AxisFormat.Fill Property

Returns fill style properties of an axis. Read-only IFillFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Fill As IFillFormat _
Implements IAxisFormat.Fill
[C#]
public IFillFormat Fill {get;}

Implements

IAxisFormat.Fill

See Also

AxisFormat Class | Aspose.Slides.Charts Namespace


Line Property

Aspose.Slides Documentation

AxisFormat.Line Property

Returns line style properties of an axis. Read-only ILineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Line As ILineFormat _
Implements IAxisFormat.Line
[C#]
public ILineFormat Line {get;}

Implements

IAxisFormat.Line

See Also

AxisFormat Class | Aspose.Slides.Charts Namespace


AxisPositionType Enumeration

[Visual Basic]
Public Enum AxisPositionType
[C#]
public enum AxisPositionType

Members

Member Name | Description | Value
Bottom |  | 0
Left |  | 1
Right |  | 2
Top |  | 3

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


BaseChartValue Class

For a list of all members of this type, see BaseChartValue Members.

System.Object
Aspose.Slides.Charts.BaseChartValue
Aspose.Slides.Charts.DoubleChartValue
Aspose.Slides.Charts.StringChartValue
Aspose.Slides.Charts.StringOrDoubleChartValue

[Visual Basic]
MustInherit Public Class BaseChartValue
Implements IBaseChartValue
[C#]
public abstract class BaseChartValue : IBaseChartValue

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BaseChartValue Members | Aspose.Slides.Charts Namespace


BaseChartValue Members

BaseChartValue overview

Public Instance Properties

Data |
DataSourceType | Specifies whether AsCell, AsCells, AsLiteralString or AsLiteralDouble property is actual in descendants. In other words it specifies the type of value of the Data property.

See Also

BaseChartValue Class | Aspose.Slides.Charts Namespace


BaseChartValue Properties

The properties of the BaseChartValue class are listed below. For a complete list of BaseChartValue class members, see the BaseChartValue Members topic.

Public Instance Properties

Data |
DataSourceType | Specifies whether AsCell, AsCells, AsLiteralString or AsLiteralDouble property is actual in descendants. In other words it specifies the type of value of the Data property.

See Also

BaseChartValue Class | Aspose.Slides.Charts Namespace


Data Property

Aspose.Slides Documentation

BaseChartValue.Data Property

[Visual Basic]
MustOverride Public Property Data As Object _
Implements IBaseChartValue.Data
[C#]
public abstract object Data {get; set;}

Implements

IBaseChartValue.Data

See Also

BaseChartValue Class | Aspose.Slides.Charts Namespace


DataSourceType Property

Aspose.Slides Documentation

BaseChartValue.DataSourceType Property

Specifies whether AsCell, AsCells, AsLiteralString or AsLiteralDouble property is actual in descendants. In other words it specifies the type of value of the Data property.

[Visual Basic]
NotOverridable Public Property DataSourceType As DataSourceType _
Implements IBaseChartValue.DataSourceType
[C#]
public DataSourceType DataSourceType {get; set;}

Implements

IBaseChartValue.DataSourceType

Remarks

For points in ChartDataPointCollection this property is read-only. In this case for changing value of this property you can use one of the ChartDataPointCollection.DataSourceTypeFor<...> properties.

See Also

BaseChartValue Class | Aspose.Slides.Charts Namespace


CannotCombine2DAnd3DChartsException Class

For a list of all members of this type, see CannotCombine2DAnd3DChartsException Members.

System.Object
System.Exception
System.SystemException
System.InvalidOperationException
Aspose.Slides.Charts.CannotCombine2DAnd3DChartsException

[Visual Basic]
Public Class CannotCombine2DAnd3DChartsException
Inherits InvalidOperationException
[C#]
public class CannotCombine2DAnd3DChartsException : InvalidOperationException

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

CannotCombine2DAnd3DChartsException Members | Aspose.Slides.Charts Namespace


CannotCombine2DAnd3DChartsException Members

CannotCombine2DAnd3DChartsException overview

Public Instance Constructors

CannotCombine2DAnd3DChartsException Overloaded. Initializes a new instance of the CannotCombine2DAnd3DChartsException class.

See Also

CannotCombine2DAnd3DChartsException Class | Aspose.Slides.Charts Namespace


CannotCombine2DAnd3DChartsException Constructor

Initializes a new instance of the CannotCombine2DAnd3DChartsException class.

Overload List

Initializes a new instance of the CannotCombine2DAnd3DChartsException class.

public CannotCombine2DAnd3DChartsException();

public CannotCombine2DAnd3DChartsException(string);

public CannotCombine2DAnd3DChartsException(string,Exception);

See Also

CannotCombine2DAnd3DChartsException Class | Aspose.Slides.Charts Namespace


CannotCombine2DAnd3DChartsException Constructor ()

Initializes a new instance of the CannotCombine2DAnd3DChartsException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CannotCombine2DAnd3DChartsException();

See Also

CannotCombine2DAnd3DChartsException Class | Aspose.Slides.Charts Namespace | CannotCombine2DAnd3DChartsException Constructor Overload List


CannotCombine2DAnd3DChartsException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public CannotCombine2DAnd3DChartsException(
string message
);

See Also

CannotCombine2DAnd3DChartsException Class | Aspose.Slides.Charts Namespace | CannotCombine2DAnd3DChartsException Constructor Overload List


CannotCombine2DAnd3DChartsException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public CannotCombine2DAnd3DChartsException(
string message,
Exception exception
);

See Also

CannotCombine2DAnd3DChartsException Class | Aspose.Slides.Charts Namespace | CannotCombine2DAnd3DChartsException Constructor Overload List


Chart Class

Represents an graphic chart on a slide.

For a list of all members of this type, see Chart Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GraphicalObject
Aspose.Slides.Charts.Chart

[Visual Basic]
Public Class Chart
Inherits GraphicalObject
Implements IChart, IFormattedTextContainer, IOverrideThemeable, IThemeable
[C#]
public class Chart : GraphicalObject, IChart, IFormattedTextContainer, IOverrideThemeable, IThemeable

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Chart Members | Aspose.Slides.Charts Namespace


Chart Members

Chart overview

Public Instance Properties

AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
AsIFormattedTextContainer | Allows to get base IFormattedTextContainer interface.
AsIThemeable | Allows to get base IFormattedTextContainer interface.
Axes | Provide access to chart axes.
BackWall | Returns an object which allows to change format of the back wall of a 3D chart. Read-only ChartWall.
ChartData | Returns information about the linked or embedded data associated with a chart. Read-only ChartData.
ChartDataTable | Returns a data table of a chart. Read-only DataTable.
ChartTitle | Returns or sets a chart title
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
DisplayBlanksAs | Returns or sets the way to plot blank cells on a chart. Read/write DisplayBlanksAsType.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Floor | Returns an object which allows to change format of the floor of a 3D chart. Read-only ChartWall.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
HasDataTable | Determines whether a chart has a data table. Read/write Boolean.
HasLegend | Determines whether a chart has a legend. Read/write Boolean.
HasTitle | Determines whether a chart has a visible title. Read/write Boolean.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
Legend | Returns or sets a legend for a chart. Read/write Legend.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
PlotArea | Represents the plot area of a chart. Read-only ChartPlotArea.
PlotVisibleCellsOnly | Determines whether the only visible cells are plotted. False to plot both visible and hidden cells. Read/write Boolean.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
Rotation3D | Returns a 3D rotation of a chart. Read-only Rotation3D.
ShapeLock (inherited from GraphicalObject) | Returns shape's locks. Read-only GraphicalObjectLock.
SideWall | Returns an object which allows to change format of the side wall of a 3D chart. Read-only ChartWall.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Style | Returns or sets the chart style. Read/write StyleType.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
TextFormat |
ThemeManager |
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
Type | Returns or sets the chart type. Read/write ChartType.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
UserShapes | Specify the shapes drawn on top of the chart.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateThemeEffective | Returns an effective theme for this chart.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

Chart Class | Aspose.Slides.Charts Namespace


Chart Properties

The properties of the Chart class are listed below. For a complete list of Chart class members, see the Chart Members topic.

Public Instance Properties

AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
AsIFormattedTextContainer | Allows to get base IFormattedTextContainer interface.
AsIThemeable | Allows to get base IFormattedTextContainer interface.
Axes | Provide access to chart axes.
BackWall | Returns an object which allows to change format of the back wall of a 3D chart. Read-only ChartWall.
ChartData | Returns information about the linked or embedded data associated with a chart. Read-only ChartData.
ChartDataTable | Returns a data table of a chart. Read-only DataTable.
ChartTitle | Returns or sets a chart title
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
DisplayBlanksAs | Returns or sets the way to plot blank cells on a chart. Read/write DisplayBlanksAsType.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Floor | Returns an object which allows to change format of the floor of a 3D chart. Read-only ChartWall.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
HasDataTable | Determines whether a chart has a data table. Read/write Boolean.
HasLegend | Determines whether a chart has a legend. Read/write Boolean.
HasTitle | Determines whether a chart has a visible title. Read/write Boolean.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
Legend | Returns or sets a legend for a chart. Read/write Legend.
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
PlotArea | Represents the plot area of a chart. Read-only ChartPlotArea.
PlotVisibleCellsOnly | Determines whether the only visible cells are plotted. False to plot both visible and hidden cells. Read/write Boolean.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
Rotation3D | Returns a 3D rotation of a chart. Read-only Rotation3D.
ShapeLock (inherited from GraphicalObject) | Returns shape's locks. Read-only GraphicalObjectLock.
SideWall | Returns an object which allows to change format of the side wall of a 3D chart. Read-only ChartWall.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Style | Returns or sets the chart style. Read/write StyleType.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
TextFormat |
ThemeManager |
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
Type | Returns or sets the chart type. Read/write ChartType.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
UserShapes | Specify the shapes drawn on top of the chart.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

Chart Class | Aspose.Slides.Charts Namespace


AsIFormattedTextContainer Property

Aspose.Slides Documentation

Chart.AsIFormattedTextContainer Property

Allows to get base IFormattedTextContainer interface.

[Visual Basic]
NotOverridable Public ReadOnly Property AsIFormattedTextContainer As IFormattedTextContainer _
Implements IChart.AsIFormattedTextContainer
[C#]
public IFormattedTextContainer AsIFormattedTextContainer {get;}

Implements

IChart.AsIFormattedTextContainer

See Also

Chart Class | Aspose.Slides.Charts Namespace


AsIThemeable Property

Aspose.Slides Documentation

Chart.AsIThemeable Property

Allows to get base IFormattedTextContainer interface.

[Visual Basic]
Public ReadOnly Property AsIThemeable As IThemeable
[C#]
public IThemeable AsIThemeable {get;}

See Also

Chart Class | Aspose.Slides.Charts Namespace


Axes Property

Aspose.Slides Documentation

Chart.Axes Property

Provide access to chart axes.

[Visual Basic]
NotOverridable Public ReadOnly Property Axes As IAxesManager _
Implements IChart.Axes
[C#]
public IAxesManager Axes {get;}

Implements

IChart.Axes

See Also

Chart Class | Aspose.Slides.Charts Namespace


BackWall Property

Aspose.Slides Documentation

Chart.BackWall Property

Returns an object which allows to change format of the back wall of a 3D chart. Read-only ChartWall.

[Visual Basic]
NotOverridable Public ReadOnly Property BackWall As IChartWall _
Implements IChart.BackWall
[C#]
public IChartWall BackWall {get;}

Implements

IChart.BackWall

See Also

Chart Class | Aspose.Slides.Charts Namespace


ChartData Property

Aspose.Slides Documentation

Chart.ChartData Property

Returns information about the linked or embedded data associated with a chart. Read-only ChartData.

[Visual Basic]
NotOverridable Public ReadOnly Property ChartData As IChartData _
Implements IChart.ChartData
[C#]
public IChartData ChartData {get;}

Implements

IChart.ChartData

See Also

Chart Class | Aspose.Slides.Charts Namespace


ChartDataTable Property

Aspose.Slides Documentation

Chart.ChartDataTable Property

Returns a data table of a chart. Read-only DataTable.

[Visual Basic]
NotOverridable Public ReadOnly Property ChartDataTable As IDataTable _
Implements IChart.ChartDataTable
[C#]
public IDataTable ChartDataTable {get;}

Implements

IChart.ChartDataTable

See Also

Chart Class | Aspose.Slides.Charts Namespace


ChartTitle Property

Aspose.Slides Documentation

Chart.ChartTitle Property

Returns or sets a chart title

[Visual Basic]
NotOverridable Public ReadOnly Property ChartTitle As IChartTitle _
Implements IChart.ChartTitle
[C#]
public IChartTitle ChartTitle {get;}

Implements

IChart.ChartTitle

See Also

Chart Class | Aspose.Slides.Charts Namespace


DisplayBlanksAs Property

Aspose.Slides Documentation

Chart.DisplayBlanksAs Property

Returns or sets the way to plot blank cells on a chart. Read/write DisplayBlanksAsType.

[Visual Basic]
NotOverridable Public Property DisplayBlanksAs As DisplayBlanksAsType _
Implements IChart.DisplayBlanksAs
[C#]
public DisplayBlanksAsType DisplayBlanksAs {get; set;}

Implements

IChart.DisplayBlanksAs

See Also

Chart Class | Aspose.Slides.Charts Namespace


Floor Property

Aspose.Slides Documentation

Chart.Floor Property

Returns an object which allows to change format of the floor of a 3D chart. Read-only ChartWall.

[Visual Basic]
NotOverridable Public ReadOnly Property Floor As IChartWall _
Implements IChart.Floor
[C#]
public IChartWall Floor {get;}

Implements

IChart.Floor

See Also

Chart Class | Aspose.Slides.Charts Namespace


HasDataTable Property

Aspose.Slides Documentation

Chart.HasDataTable Property

Determines whether a chart has a data table. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property HasDataTable As Boolean _
Implements IChart.HasDataTable
[C#]
public bool HasDataTable {get; set;}

Implements

IChart.HasDataTable

See Also

Chart Class | Aspose.Slides.Charts Namespace


HasLegend Property

Aspose.Slides Documentation

Chart.HasLegend Property

Determines whether a chart has a legend. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property HasLegend As Boolean _
Implements IChart.HasLegend
[C#]
public bool HasLegend {get; set;}

Implements

IChart.HasLegend

See Also

Chart Class | Aspose.Slides.Charts Namespace


HasTitle Property

Aspose.Slides Documentation

Chart.HasTitle Property

Determines whether a chart has a visible title. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property HasTitle As Boolean _
Implements IChart.HasTitle
[C#]
public bool HasTitle {get; set;}

Implements

IChart.HasTitle

See Also

Chart Class | Aspose.Slides.Charts Namespace


Legend Property

Aspose.Slides Documentation

Chart.Legend Property

Returns or sets a legend for a chart. Read/write Legend.

[Visual Basic]
NotOverridable Public ReadOnly Property Legend As ILegend _
Implements IChart.Legend
[C#]
public ILegend Legend {get;}

Implements

IChart.Legend

See Also

Chart Class | Aspose.Slides.Charts Namespace


PlotArea Property

Aspose.Slides Documentation

Chart.PlotArea Property

Represents the plot area of a chart. Read-only ChartPlotArea.

[Visual Basic]
NotOverridable Public ReadOnly Property PlotArea As IChartPlotArea _
Implements IChart.PlotArea
[C#]
public IChartPlotArea PlotArea {get;}

Implements

IChart.PlotArea

See Also

Chart Class | Aspose.Slides.Charts Namespace


PlotVisibleCellsOnly Property

Aspose.Slides Documentation

Chart.PlotVisibleCellsOnly Property

Determines whether the only visible cells are plotted. False to plot both visible and hidden cells. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property PlotVisibleCellsOnly As Boolean _
Implements IChart.PlotVisibleCellsOnly
[C#]
public bool PlotVisibleCellsOnly {get; set;}

Implements

IChart.PlotVisibleCellsOnly

See Also

Chart Class | Aspose.Slides.Charts Namespace


Rotation3D Property

Aspose.Slides Documentation

Chart.Rotation3D Property

Returns a 3D rotation of a chart. Read-only Rotation3D.

[Visual Basic]
NotOverridable Public ReadOnly Property Rotation3D As IRotation3D _
Implements IChart.Rotation3D
[C#]
public IRotation3D Rotation3D {get;}

Implements

IChart.Rotation3D

See Also

Chart Class | Aspose.Slides.Charts Namespace


SideWall Property

Aspose.Slides Documentation

Chart.SideWall Property

Returns an object which allows to change format of the side wall of a 3D chart. Read-only ChartWall.

[Visual Basic]
NotOverridable Public ReadOnly Property SideWall As IChartWall _
Implements IChart.SideWall
[C#]
public IChartWall SideWall {get;}

Implements

IChart.SideWall

See Also

Chart Class | Aspose.Slides.Charts Namespace


Style Property

Aspose.Slides Documentation

Chart.Style Property

Returns or sets the chart style. Read/write StyleType.

[Visual Basic]
NotOverridable Public Property Style As StyleType _
Implements IChart.Style
[C#]
public StyleType Style {get; set;}

Implements

IChart.Style

See Also

Chart Class | Aspose.Slides.Charts Namespace


TextFormat Property

Aspose.Slides Documentation

Chart.TextFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property TextFormat As IChartTextFormat _
Implements IFormattedTextContainer.TextFormat
[C#]
public IChartTextFormat TextFormat {get;}

Implements

IFormattedTextContainer.TextFormat

See Also

Chart Class | Aspose.Slides.Charts Namespace


ThemeManager Property

Aspose.Slides Documentation

Chart.ThemeManager Property

[Visual Basic]
NotOverridable Public ReadOnly Property ThemeManager As IOverrideThemeManager _
Implements IOverrideThemeable.ThemeManager
[C#]
public IOverrideThemeManager ThemeManager {get;}

Implements

IOverrideThemeable.ThemeManager

See Also

Chart Class | Aspose.Slides.Charts Namespace


Type Property

Aspose.Slides Documentation

Chart.Type Property

Returns or sets the chart type. Read/write ChartType.

[Visual Basic]
NotOverridable Public Property Type As ChartType _
Implements IChart.Type
[C#]
public ChartType Type {get; set;}

Implements

IChart.Type

See Also

Chart Class | Aspose.Slides.Charts Namespace


UserShapes Property

Aspose.Slides Documentation

Chart.UserShapes Property

Specify the shapes drawn on top of the chart.

[Visual Basic]
NotOverridable Public ReadOnly Property UserShapes As IGroupShape _
Implements IChart.UserShapes
[C#]
public IGroupShape UserShapes {get;}

Implements

IChart.UserShapes

See Also

Chart Class | Aspose.Slides.Charts Namespace


Chart Methods

The methods of the Chart class are listed below. For a complete list of Chart class members, see the Chart Members topic.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateThemeEffective | Returns an effective theme for this chart.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

Chart Class | Aspose.Slides.Charts Namespace


Chart.CreateThemeEffective Method

Returns an effective theme for this chart.

[Visual Basic]
NotOverridable Public Function CreateThemeEffective() As IThemeEffectiveData _
Implements IThemeable.CreateThemeEffective
[C#]
public IThemeEffectiveData CreateThemeEffective();

Implements

IThemeable.CreateThemeEffective

See Also

Chart Class | Aspose.Slides.Charts Namespace


ChartCategory Class

Represents chart categories.

For a list of all members of this type, see ChartCategory Members.

System.Object
Aspose.Slides.Charts.ChartCategory

[Visual Basic]
Public Class ChartCategory
Implements IChartCategory
[C#]
public class ChartCategory : IChartCategory

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartCategory Members | Aspose.Slides.Charts Namespace


ChartCategory Members

ChartCategory overview

Public Instance Properties

AsCell | Returns or sets Aspose.Cells.Cell object. If category is multi-level then used Aspose.Cells.Cell object for level "0".
AsLiteral |
GroupingLevels | Managed container of the values of the chart category grouping levels. Multi-level category contain more then one grouping level. Grouping levels indexing is zero-based.
Levels | Obsolete. Managed container of the values of the chart category grouping levels. Multi-level category contain more then one grouping level. Grouping levels indexing is zero-based.
UseCell | If true then AsCell property is actual. In other words, worksheet is used for storing category (this case supports a multi-level category). If false then AsLiteral property is actual. In other words, worksheet is NOT used for storing category (and this case doesn't support a multi-level categories)
Value | If UseCell is true then this property represents AsCell.Value property. If UseCell is false then this property represents AsLiteral property.

See Also

ChartCategory Class | Aspose.Slides.Charts Namespace


ChartCategory Properties

The properties of the ChartCategory class are listed below. For a complete list of ChartCategory class members, see the ChartCategory Members topic.

Public Instance Properties

AsCell | Returns or sets Aspose.Cells.Cell object. If category is multi-level then used Aspose.Cells.Cell object for level "0".
AsLiteral |
GroupingLevels | Managed container of the values of the chart category grouping levels. Multi-level category contain more then one grouping level. Grouping levels indexing is zero-based.
Levels | Obsolete. Managed container of the values of the chart category grouping levels. Multi-level category contain more then one grouping level. Grouping levels indexing is zero-based.
UseCell | If true then AsCell property is actual. In other words, worksheet is used for storing category (this case supports a multi-level category). If false then AsLiteral property is actual. In other words, worksheet is NOT used for storing category (and this case doesn't support a multi-level categories)
Value | If UseCell is true then this property represents AsCell.Value property. If UseCell is false then this property represents AsLiteral property.

See Also

ChartCategory Class | Aspose.Slides.Charts Namespace


AsCell Property

Aspose.Slides Documentation

ChartCategory.AsCell Property

Returns or sets Aspose.Cells.Cell object. If category is multi-level then used Aspose.Cells.Cell object for level "0".

[Visual Basic]
NotOverridable Public Property AsCell As IChartDataCell _
Implements IChartCategory.AsCell
[C#]
public IChartDataCell AsCell {get; set;}

Implements

IChartCategory.AsCell

See Also

ChartCategory Class | Aspose.Slides.Charts Namespace


AsLiteral Property

Aspose.Slides Documentation

ChartCategory.AsLiteral Property

[Visual Basic]
NotOverridable Public Property AsLiteral As Object _
Implements IChartCategory.AsLiteral
[C#]
public object AsLiteral {get; set;}

Implements

IChartCategory.AsLiteral

See Also

ChartCategory Class | Aspose.Slides.Charts Namespace


GroupingLevels Property

Aspose.Slides Documentation

ChartCategory.GroupingLevels Property

Managed container of the values of the chart category grouping levels. Multi-level category contain more then one grouping level. Grouping levels indexing is zero-based.

[Visual Basic]
NotOverridable Public ReadOnly Property GroupingLevels As IChartCategoryLevelsManager _
Implements IChartCategory.GroupingLevels
[C#]
public IChartCategoryLevelsManager GroupingLevels {get;}

Implements

IChartCategory.GroupingLevels

See Also

ChartCategory Class | Aspose.Slides.Charts Namespace


Levels Property

Aspose.Slides Documentation

ChartCategory.Levels Property

NOTE: This property is now obsolete.

Use GroupingLevels property instead. Will be removed after 01.05.2014.

Managed container of the values of the chart category grouping levels. Multi-level category contain more then one grouping level. Grouping levels indexing is zero-based.

[Visual Basic]
NotOverridable Public ReadOnly Property Levels As IChartCategoryLevelsManager _
Implements IChartCategory.Levels
[C#]
public IChartCategoryLevelsManager Levels {get;}

Implements

IChartCategory.Levels

See Also

ChartCategory Class | Aspose.Slides.Charts Namespace


UseCell Property

Aspose.Slides Documentation

ChartCategory.UseCell Property

If true then AsCell property is actual. In other words, worksheet is used for storing category (this case supports a multi-level category). If false then AsLiteral property is actual. In other words, worksheet is NOT used for storing category (and this case doesn't support a multi-level categories)

[Visual Basic]
NotOverridable Public ReadOnly Property UseCell As Boolean _
Implements IChartCategory.UseCell
[C#]
public bool UseCell {get;}

Implements

IChartCategory.UseCell

Remarks

For change value of this property (for all categories in collection) set new value to ChartCategoryCollection.UseCells property.

See Also

ChartCategory Class | Aspose.Slides.Charts Namespace


Value Property

Aspose.Slides Documentation

ChartCategory.Value Property

If UseCell is true then this property represents AsCell.Value property. If UseCell is false then this property represents AsLiteral property.

[Visual Basic]
NotOverridable Public Property Value As Object _
Implements IChartCategory.Value
[C#]
public object Value {get; set;}

Implements

IChartCategory.Value

See Also

ChartCategory Class | Aspose.Slides.Charts Namespace


ChartCategoryCollection Class

Represents collection of ChartCategory

For a list of all members of this type, see ChartCategoryCollection Members.

System.Object
Aspose.Slides.Charts.ChartCategoryCollection

[Visual Basic]
Public Class ChartCategoryCollection
Implements IChartCategoryCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Charts.IChartCategory, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class ChartCategoryCollection : IChartCategoryCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartCategoryCollection Members | Aspose.Slides.Charts Namespace


ChartCategoryCollection Members

ChartCategoryCollection overview

Public Instance Properties

Count | Returns a number of elements int the collection. Readonly Int32.
GroupingLevelCount | Returns count of category grouping levels used. Is more then one for multilevel categories.
IsSynchronized | Returns a value indicating whether access to the ArrayList is synchronized (thread safe). Readonly Boolean.
Item | Gets the element at the specified index.
LevelCount | Obsolete. Returns count of category grouping levels used. Is more then one for multilevel categories.
SyncRoot | Returns an object that can be used to synchronize access to the collection. Readonly Object.
UseCells | If true then worksheet is used for storing categories (this case supports a multi-level categories). If false then worksheet is NOT used for storing values (and this case doesn't support a multi-level categories).

Public Instance Methods

Add | Overloaded. If category exists in collection, return it. Else creates new chart category from IChartDataCell and adds it to the collection.
Clear | Removes all coomments from the slide.
CopyTo | Copies all elements of the collection to the specified array.
GetEnumerator | Returns an enumerator, which can be used to iterate through the collection.
IndexOf | Searches for the specified ChartCategory and returns the zero-based index of the first occurrence within the entire Collection
Remove | Removes the specified value.

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


ChartCategoryCollection Properties

The properties of the ChartCategoryCollection class are listed below. For a complete list of ChartCategoryCollection class members, see the ChartCategoryCollection Members topic.

Public Instance Properties

Count | Returns a number of elements int the collection. Readonly Int32.
GroupingLevelCount | Returns count of category grouping levels used. Is more then one for multilevel categories.
IsSynchronized | Returns a value indicating whether access to the ArrayList is synchronized (thread safe). Readonly Boolean.
Item | Gets the element at the specified index.
LevelCount | Obsolete. Returns count of category grouping levels used. Is more then one for multilevel categories.
SyncRoot | Returns an object that can be used to synchronize access to the collection. Readonly Object.
UseCells | If true then worksheet is used for storing categories (this case supports a multi-level categories). If false then worksheet is NOT used for storing values (and this case doesn't support a multi-level categories).

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


Count Property

Aspose.Slides Documentation

ChartCategoryCollection.Count Property

Returns a number of elements int the collection. Readonly Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


GroupingLevelCount Property

Aspose.Slides Documentation

ChartCategoryCollection.GroupingLevelCount Property

Returns count of category grouping levels used. Is more then one for multilevel categories.

[Visual Basic]
NotOverridable Public ReadOnly Property GroupingLevelCount As Integer _
Implements IChartCategoryCollection.GroupingLevelCount
[C#]
public int GroupingLevelCount {get;}

Implements

IChartCategoryCollection.GroupingLevelCount

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


IsSynchronized Property

Aspose.Slides Documentation

ChartCategoryCollection.IsSynchronized Property

Returns a value indicating whether access to the ArrayList is synchronized (thread safe). Readonly Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

ChartCategoryCollection.Item Property

Gets the element at the specified index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IChartCategoryCollection.Item
As IChartCategory _
Implements IChartCategoryCollection.Item
[C#]
public IChartCategory this[
int index
] {get;}

Implements

IChartCategoryCollection.Item

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the IList.

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


LevelCount Property

Aspose.Slides Documentation

ChartCategoryCollection.LevelCount Property

NOTE: This property is now obsolete.

Use GroupingLevelCount property instead. Will be removed after 01.05.2014.

Returns count of category grouping levels used. Is more then one for multilevel categories.

[Visual Basic]
NotOverridable Public ReadOnly Property LevelCount As Integer _
Implements IChartCategoryCollection.LevelCount
[C#]
public int LevelCount {get;}

Implements

IChartCategoryCollection.LevelCount

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


SyncRoot Property

Aspose.Slides Documentation

ChartCategoryCollection.SyncRoot Property

Returns an object that can be used to synchronize access to the collection. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


UseCells Property

Aspose.Slides Documentation

ChartCategoryCollection.UseCells Property

If true then worksheet is used for storing categories (this case supports a multi-level categories). If false then worksheet is NOT used for storing values (and this case doesn't support a multi-level categories).

[Visual Basic]
NotOverridable Public Property UseCells As Boolean _
Implements IChartCategoryCollection.UseCells
[C#]
public bool UseCells {get; set;}

Implements

IChartCategoryCollection.UseCells

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


ChartCategoryCollection Methods

The methods of the ChartCategoryCollection class are listed below. For a complete list of ChartCategoryCollection class members, see the ChartCategoryCollection Members topic.

Public Instance Methods

Add | Overloaded. If category exists in collection, return it. Else creates new chart category from IChartDataCell and adds it to the collection.
Clear | Removes all coomments from the slide.
CopyTo | Copies all elements of the collection to the specified array.
GetEnumerator | Returns an enumerator, which can be used to iterate through the collection.
IndexOf | Searches for the specified ChartCategory and returns the zero-based index of the first occurrence within the entire Collection
Remove | Removes the specified value.

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


Add Method

Aspose.Slides Documentation

ChartCategoryCollection.Add Method

If category exists in collection, return it. Else creates new chart category from IChartDataCell and adds it to the collection.

Overload List

If category exists in collection, return it. Else creates new chart category from IChartDataCell and adds it to the collection.

public IChartCategory Add(IChartDataCell);

Creates new ChartCategory from value and adds it to the collection.

public IChartCategory Add(object);

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


ChartCategoryCollection.Add Method (IChartDataCell)

If category exists in collection, return it. Else creates new chart category from IChartDataCell and adds it to the collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal chartDataCell As IChartDataCell _
) As IChartCategory _
Implements IChartCategoryCollection.Add
[C#]
public IChartCategory Add(
IChartDataCell chartDataCell
);

Parameters

chartDataCell
Cell used to create chart category.

Return Value

Added or existing category.

Implements

IChartCategoryCollection.Add

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace | ChartCategoryCollection.Add Overload List


ChartCategoryCollection.Add Method (Object)

Creates new ChartCategory from value and adds it to the collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal value As Object _
) As IChartCategory _
Implements IChartCategoryCollection.Add
[C#]
public IChartCategory Add(
object value
);

Parameters

value
The value.

Return Value

Added IChartCategory.

Implements

IChartCategoryCollection.Add

Remarks

This method adds worksheet with name AUTO_DATA and adds all values there. If you use ChartDataWorkbook to add or edit cell values, be sure that you do not use this worksheet Maximum number of values added using this method must not exceed 16711680

Exceptions

Exception Type | Condition
InvalidOperationException | if limit exceeded

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace | ChartCategoryCollection.Add Overload List


ChartCategoryCollection.Clear Method

Removes all coomments from the slide.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IChartCategoryCollection.Clear
[C#]
public void Clear();

Implements

IChartCategoryCollection.Clear

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


ChartCategoryCollection.CopyTo Method

Copies all elements of the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the array.

Implements

ICollection.CopyTo

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


ChartCategoryCollection.GetEnumerator Method

Returns an enumerator, which can be used to iterate through the collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Enumeraton IEnumerator.

Implements

IEnumerable.GetEnumerator

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


ChartCategoryCollection.IndexOf Method

Searches for the specified ChartCategory and returns the zero-based index of the first occurrence within the entire Collection

[Visual Basic]
NotOverridable Public Function IndexOf( _
ByVal value As IChartCategory _
) As Integer _
Implements IChartCategoryCollection.IndexOf
[C#]
public int IndexOf(
IChartCategory value
);

Parameters

value
Chart category.

Return Value

The zero-based index of the first occurrence of value within the entire CollectionBase, if found; otherwise, -1.

Implements

IChartCategoryCollection.IndexOf

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


ChartCategoryCollection.Remove Method

Removes the specified value.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal value As IChartCategory _
) _
Implements IChartCategoryCollection.Remove
[C#]
public void Remove(
IChartCategory value
);

Parameters

value
The value.

Implements

IChartCategoryCollection.Remove

Exceptions

Exception Type | Condition
ArgumentException | The value parameter was not found in the collection.

See Also

ChartCategoryCollection Class | Aspose.Slides.Charts Namespace


ChartCategoryLevelsManager Class

Managed container of the values of the chart category levels.

For a list of all members of this type, see ChartCategoryLevelsManager Members.

System.Object
Aspose.Slides.Charts.ChartCategoryLevelsManager

[Visual Basic]
Public Class ChartCategoryLevelsManager
Implements IChartCategoryLevelsManager
[C#]
public class ChartCategoryLevelsManager : IChartCategoryLevelsManager

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartCategoryLevelsManager Members | Aspose.Slides.Charts Namespace


ChartCategoryLevelsManager Members

ChartCategoryLevelsManager overview

Public Instance Properties

Item Returns IChartDataCell object for defined level.

Public Instance Methods

DeleteGroupingItem | Delete grouping item for defined level.
DeleteValueOfLevel | Obsolete. Delete grouping item for defined level.
SetGroupingItem | Overloaded. Sets grouping item for defined level.
SetValueOfLevel | Obsolete. Sets grouping item for defined level.

See Also

ChartCategoryLevelsManager Class | Aspose.Slides.Charts Namespace


ChartCategoryLevelsManager Properties

The properties of the ChartCategoryLevelsManager class are listed below. For a complete list of ChartCategoryLevelsManager class members, see the ChartCategoryLevelsManager Members topic.

Public Instance Properties

Item Returns IChartDataCell object for defined level.

See Also

ChartCategoryLevelsManager Class | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

ChartCategoryLevelsManager.Item Property

Returns IChartDataCell object for defined level.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal level As Integer _
) _
Implements IChartCategoryLevelsManager.Item
As IChartDataCell _
Implements IChartCategoryLevelsManager.Item
[C#]
public IChartDataCell this[
int level
] {get;}

Implements

IChartCategoryLevelsManager.Item

See Also

ChartCategoryLevelsManager Class | Aspose.Slides.Charts Namespace


ChartCategoryLevelsManager Methods

The methods of the ChartCategoryLevelsManager class are listed below. For a complete list of ChartCategoryLevelsManager class members, see the ChartCategoryLevelsManager Members topic.

Public Instance Methods

DeleteGroupingItem | Delete grouping item for defined level.
DeleteValueOfLevel | Obsolete. Delete grouping item for defined level.
SetGroupingItem | Overloaded. Sets grouping item for defined level.
SetValueOfLevel | Obsolete. Sets grouping item for defined level.

See Also

ChartCategoryLevelsManager Class | Aspose.Slides.Charts Namespace


ChartCategoryLevelsManager.DeleteGroupingItem Method

Delete grouping item for defined level.

[Visual Basic]
NotOverridable Public Sub DeleteGroupingItem( _
ByVal level As Integer _
) _
Implements IChartCategoryLevelsManager.DeleteGroupingItem
[C#]
public void DeleteGroupingItem(
int level
);

Implements

IChartCategoryLevelsManager.DeleteGroupingItem

See Also

ChartCategoryLevelsManager Class | Aspose.Slides.Charts Namespace


ChartCategoryLevelsManager.DeleteValueOfLevel Method

NOTE: This method is now obsolete.

Use DeleteGroupingItem method instead. Will be removed after 01.05.2014.

Delete grouping item for defined level.

[Visual Basic]
NotOverridable Public Sub DeleteValueOfLevel( _
ByVal level As Integer _
) _
Implements IChartCategoryLevelsManager.DeleteValueOfLevel
[C#]
public void DeleteValueOfLevel(
int level
);

Implements

IChartCategoryLevelsManager.DeleteValueOfLevel

See Also

ChartCategoryLevelsManager Class | Aspose.Slides.Charts Namespace


SetGroupingItem Method

Aspose.Slides Documentation

ChartCategoryLevelsManager.SetGroupingItem Method

NOTE: This method is now obsolete.

Use SetGroupingItem(int level, object value) method instead. Will be removed after 01.05.2014.

Sets grouping item for defined level.

Overload List

Obsolete. Sets grouping item for defined level.

public void SetGroupingItem(int,IChartDataCell);

Sets grouping item for defined level.

public void SetGroupingItem(int,object);

See Also

ChartCategoryLevelsManager Class | Aspose.Slides.Charts Namespace


ChartCategoryLevelsManager.SetGroupingItem Method (Int32, IChartDataCell)

NOTE: This method is now obsolete.

Use SetGroupingItem(int level, object value) method instead. Will be removed after 01.05.2014.

Sets grouping item for defined level.

[Visual Basic]
NotOverridable Overloads Public Sub SetGroupingItem( _
ByVal level As Integer, _
ByVal value As IChartDataCell _
) _
Implements IChartCategoryLevelsManager.SetGroupingItem
[C#]
public void SetGroupingItem(
int level,
IChartDataCell value
);

Implements

IChartCategoryLevelsManager.SetGroupingItem

See Also

ChartCategoryLevelsManager Class | Aspose.Slides.Charts Namespace | ChartCategoryLevelsManager.SetGroupingItem Overload List


ChartCategoryLevelsManager.SetGroupingItem Method (Int32, Object)

Sets grouping item for defined level.

[Visual Basic]
NotOverridable Overloads Public Sub SetGroupingItem( _
ByVal level As Integer, _
ByVal value As Object _
) _
Implements IChartCategoryLevelsManager.SetGroupingItem
[C#]
public void SetGroupingItem(
int level,
object value
);

Implements

IChartCategoryLevelsManager.SetGroupingItem

See Also

ChartCategoryLevelsManager Class | Aspose.Slides.Charts Namespace | ChartCategoryLevelsManager.SetGroupingItem Overload List


ChartCategoryLevelsManager.SetValueOfLevel Method

NOTE: This method is now obsolete.

Use SetGroupingItem(int level, object value) method instead. Will be removed after 01.05.2014.

Sets grouping item for defined level.

[Visual Basic]
NotOverridable Public Sub SetValueOfLevel( _
ByVal level As Integer, _
ByVal value As IChartDataCell _
) _
Implements IChartCategoryLevelsManager.SetValueOfLevel
[C#]
public void SetValueOfLevel(
int level,
IChartDataCell value
);

Implements

IChartCategoryLevelsManager.SetValueOfLevel

See Also

ChartCategoryLevelsManager Class | Aspose.Slides.Charts Namespace


ChartCellCollection Class

Represents collection of a cells with data.

For a list of all members of this type, see ChartCellCollection Members.

System.Object
Aspose.Slides.Charts.ChartCellCollection

[Visual Basic]
Public Class ChartCellCollection
Implements IChartCellCollection, IEnumerable`1([Aspose.Slides.Charts.IChartDataCell, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public class ChartCellCollection : IChartCellCollection, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartCellCollection Members | Aspose.Slides.Charts Namespace


ChartCellCollection Members

ChartCellCollection overview

Public Instance Properties

Count | Gets the count of cells in collection.
GetConcateNameFromCells | Obsolete. Concatenation names from all cells names values.
Item | Returns a cell (Aspose.Cells.Cell) by index.

Public Instance Methods

Add | Overloaded. Creates ChartDataCell from specified value and adds it to the collection.
GetCellsAddress | Returns address of the set of cells in workbook.
GetConcatenatedValuesFromCells | Concatenation string from all cells string values.
GetEnumerator | Returns an enumerator for the entire collection.
RemoveAt | Removes a cell from the collection by index.

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace


ChartCellCollection Properties

The properties of the ChartCellCollection class are listed below. For a complete list of ChartCellCollection class members, see the ChartCellCollection Members topic.

Public Instance Properties

Count | Gets the count of cells in collection.
GetConcateNameFromCells | Obsolete. Concatenation names from all cells names values.
Item | Returns a cell (Aspose.Cells.Cell) by index.

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace


Count Property

Aspose.Slides Documentation

ChartCellCollection.Count Property

Gets the count of cells in collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements IChartCellCollection.Count
[C#]
public int Count {get;}

Implements

IChartCellCollection.Count

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace


GetConcateNameFromCells Property

Aspose.Slides Documentation

ChartCellCollection.GetConcateNameFromCells Property

NOTE: This property is now obsolete.

Use GetConcatenatedValuesFromCells() method instead. Will be removed after 01.09.2013.

Concatenation names from all cells names values.

[Visual Basic]
Public ReadOnly Property GetConcateNameFromCells As String
[C#]
public string GetConcateNameFromCells {get;}

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

ChartCellCollection.Item Property

Returns a cell (Aspose.Cells.Cell) by index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IChartCellCollection.Item
As IChartDataCell _
Implements IChartCellCollection.Item
[C#]
public IChartDataCell this[
int index
] {get;}

Parameters

index
Index of a cell.

Implements

IChartCellCollection.Item

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace


ChartCellCollection Methods

The methods of the ChartCellCollection class are listed below. For a complete list of ChartCellCollection class members, see the ChartCellCollection Members topic.

Public Instance Methods

Add | Overloaded. Creates ChartDataCell from specified value and adds it to the collection.
GetCellsAddress | Returns address of the set of cells in workbook.
GetConcatenatedValuesFromCells | Concatenation string from all cells string values.
GetEnumerator | Returns an enumerator for the entire collection.
RemoveAt | Removes a cell from the collection by index.

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace


Add Method

Aspose.Slides Documentation

ChartCellCollection.Add Method

Add new cell to the collection.

Overload List

Add new cell to the collection.

public void Add(IChartDataCell);

Creates ChartDataCell from specified value and adds it to the collection.

public void Add(object);

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace


ChartCellCollection.Add Method (IChartDataCell)

Add new cell to the collection.

[Visual Basic]
NotOverridable Overloads Public Sub Add( _
ByVal cell As IChartDataCell _
) _
Implements IChartCellCollection.Add
[C#]
public void Add(
IChartDataCell cell
);

Parameters

cell

Return Value

Index of a new added ChartDataCell.

Implements

IChartCellCollection.Add

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace | ChartCellCollection.Add Overload List


ChartCellCollection.Add Method (Object)

Creates ChartDataCell from specified value and adds it to the collection.

[Visual Basic]
NotOverridable Overloads Public Sub Add( _
ByVal value As Object _
) _
Implements IChartCellCollection.Add
[C#]
public void Add(
object value
);

Parameters

value
The value.

Return Value

Index of a new added ChartDataCell.

Implements

IChartCellCollection.Add

Remarks

This method adds worksheet with name AUTO_DATA and adds all values there. If you use ChartDataWorkbook to add or edit Cell values, be sure that you do not use this worksheet Maximum number of values added using this method must not exceed 16711680

Exceptions

Exception Type | Condition
InvalidOperationException | if limit exceeded

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace | ChartCellCollection.Add Overload List


ChartCellCollection.GetCellsAddress Method

Returns address of the set of cells in workbook.

[Visual Basic]
NotOverridable Public Function GetCellsAddress() As String _
Implements IChartCellCollection.GetCellsAddress
[C#]
public string GetCellsAddress();

Implements

IChartCellCollection.GetCellsAddress

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace


ChartCellCollection.GetConcatenatedValuesFromCells Method

Concatenation string from all cells string values.

[Visual Basic]
NotOverridable Public Function GetConcatenatedValuesFromCells() As String _
Implements IChartCellCollection.GetConcatenatedValuesFromCells
[C#]
public string GetConcatenatedValuesFromCells();

Implements

IChartCellCollection.GetConcatenatedValuesFromCells

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace


ChartCellCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace


ChartCellCollection.RemoveAt Method

Removes a cell from the collection by index.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IChartCellCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
Index of a cell to remove.

Implements

IChartCellCollection.RemoveAt

See Also

ChartCellCollection Class | Aspose.Slides.Charts Namespace


ChartData Class

Represents data used for a chart plotting.

For a list of all members of this type, see ChartData Members.

System.Object
Aspose.Slides.Charts.ChartData

[Visual Basic]
Public Class ChartData
Implements IChartData
[C#]
public class ChartData : IChartData

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartData Members | Aspose.Slides.Charts Namespace


ChartData Members

ChartData overview

Public Instance Properties

Categories | Gets the primary categories (or both primary and secondary categories if UseSecondaryCategories property is false).
ChartDataWorkbook | Gets the cells factory to create cells used for chart series or categories
SecondaryCategories | Gets the secondary categories if UseSecondaryCategories property is true.
Series | Gets the series.
SeriesGroups | Gets the groups of series.
UseSecondaryCategories If false then SecondaryCategories property return null and data in Categories property is used both for primary and secondary series. If true then data in SecondaryCategories property is used for secondary series and data in Categories property is used for primary series. Example. What categories are related to series - ChartData.Categories or ChartData.SecondaryCategories?

Public Instance Methods
GetEnumerator | Returns an enumerator for the entire collection.
ReadWorkbookStream | Writes the internally contained Excel workbook it into an in-memory stream.
WriteWorkbookStream | Initializes the internally contained Excel workbook with user-specified value.
See Also
ChartData Class | Aspose.Slides.Charts Namespace


ChartData Properties

The properties of the ChartData class are listed below. For a complete list of ChartData class members, see the ChartData Members topic.

Public Instance Properties

Categories | Gets the primary categories (or both primary and secondary categories if UseSecondaryCategories property is false).
ChartDataWorkbook | Gets the cells factory to create cells used for chart series or categories
SecondaryCategories | Gets the secondary categories if UseSecondaryCategories property is true.
Series | Gets the series.
SeriesGroups | Gets the groups of series.
UseSecondaryCategories If false then SecondaryCategories property return null and data in Categories property is used both for primary and secondary series. If true then data in SecondaryCategories property is used for secondary series and data in Categories property is used for primary series. Example. What categories are related to series - ChartData.Categories or ChartData.SecondaryCategories?

See Also
ChartData Class | Aspose.Slides.Charts Namespace


Categories Property

Aspose.Slides Documentation

ChartData.Categories Property

Gets the primary categories (or both primary and secondary categories if UseSecondaryCategories property is false).

[Visual Basic]
NotOverridable Public ReadOnly Property Categories As IChartCategoryCollection _
Implements IChartData.Categories
[C#]
public IChartCategoryCollection Categories {get;}

Implements

IChartData.Categories

Remarks

If UseSecondaryCategories property is false then SecondaryCategories property return null and data in this Categories property is used both for primary and secondary series. If UseSecondaryCategories property is true then data in SecondaryCategories property is used for secondary series and data in this Categories property is used for primary series. Example. What categories are related to series - ChartData.Categories or ChartData.SecondaryCategories?

See Also
ChartData Class | Aspose.Slides.Charts Namespace


ChartDataWorkbook Property

Aspose.Slides Documentation

ChartData.ChartDataWorkbook Property

Gets the cells factory to create cells used for chart series or categories

[Visual Basic]
NotOverridable Public ReadOnly Property ChartDataWorkbook As IChartDataWorkbook _
Implements IChartData.ChartDataWorkbook
[C#]
public IChartDataWorkbook ChartDataWorkbook {get;}

Implements

IChartData.ChartDataWorkbook

See Also

ChartData Class | Aspose.Slides.Charts Namespace


SecondaryCategories Property

Aspose.Slides Documentation

ChartData.SecondaryCategories Property

Gets the secondary categories if UseSecondaryCategories property is true.

[Visual Basic]
NotOverridable Public ReadOnly Property SecondaryCategories As IChartCategoryCollection _
Implements IChartData.SecondaryCategories
[C#]
public IChartCategoryCollection SecondaryCategories {get;}

Implements

IChartData.SecondaryCategories

Remarks

If UseSecondaryCategories property is false then this SecondaryCategories property return null and data in Categories property is used both for primary and secondary series. If UseSecondaryCategories property is true then data in this SecondaryCategories property is used for secondary series and data in Categories property is used for primary series. Example. What categories are related to series - ChartData.Categories or ChartData.SecondaryCategories?

See Also
ChartData Class | Aspose.Slides.Charts Namespace


Series Property

Aspose.Slides Documentation

ChartData.Series Property

Gets the series.

[Visual Basic]
NotOverridable Public ReadOnly Property Series As IChartSeriesCollection _
Implements IChartData.Series
[C#]
public IChartSeriesCollection Series {get;}

Implements

IChartData.Series

See Also

ChartData Class | Aspose.Slides.Charts Namespace


SeriesGroups Property

Aspose.Slides Documentation

ChartData.SeriesGroups Property

Gets the groups of series.

[Visual Basic]
NotOverridable Public ReadOnly Property SeriesGroups As IChartSeriesGroupCollection _
Implements IChartData.SeriesGroups
[C#]
public IChartSeriesGroupCollection SeriesGroups {get;}

Implements

IChartData.SeriesGroups

Remarks

1) Each group of series contains series with combinable types. Groups of combinable series types defined and described with CombinableSeriesTypesGroup enum. Also each group of series contains series witch is plotted whether on primary axes or on secondary axes (not both cases in one group). So, principle of series grouping is a grouping by type groups mentioned above and by primary/secondary plotting type. 2) Group of series contains some series properies whitch is common for each series in group ("series group properties"). "Series group properties" in ChartSeriesGroup class is read/write. Each of "series group properties" can have a read-only projection in ChartSeries class.

See Also

ChartData Class | Aspose.Slides.Charts Namespace


UseSecondaryCategories Property

Aspose.Slides Documentation

ChartData.UseSecondaryCategories Property

If false then SecondaryCategories property return null and data in Categories property is used both for primary and secondary series. If true then data in SecondaryCategories property is used for secondary series and data in Categories property is used for primary series. Example. What categories are related to series - ChartData.Categories or ChartData.SecondaryCategories?

[Visual Basic]
NotOverridable Public Property UseSecondaryCategories As Boolean _
    Implements IChartData.UseSecondaryCategories
[C#]
public bool UseSecondaryCategories {get; set;}
Implements
IChartData.UseSecondaryCategories
See Also
ChartData Class | Aspose.Slides.Charts Namespace


ChartData Methods

The methods of the ChartData class are listed below. For a complete list of ChartData class members, see the ChartData Members topic.

Public Instance Methods

GetEnumerator | Returns an enumerator for the entire collection.
ReadWorkbookStream | Writes the internally contained Excel workbook it into an in-memory stream.
WriteWorkbookStream | Initializes the internally contained Excel workbook with user-specified value.

See Also

ChartData Class | Aspose.Slides.Charts Namespace


ChartData.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();

See Also

ChartData Class | Aspose.Slides.Charts Namespace


ChartData.ReadWorkbookStream Method

Writes the internally contained Excel workbook it into an in-memory stream.

[Visual Basic]
NotOverridable Public Function ReadWorkbookStream() As MemoryStream _
Implements IChartData.ReadWorkbookStream
[C#]
public MemoryStream ReadWorkbookStream();

Return Value

Returns an instance of MemoryStream containing a copy of the internally contained Excel workbook.

Implements

IChartData.ReadWorkbookStream

See Also

ChartData Class | Aspose.Slides.Charts Namespace


ChartData.WriteWorkbookStream Method

Initializes the internally contained Excel workbook with user-specified value.

[Visual Basic]
NotOverridable Public Sub WriteWorkbookStream( _
ByVal ms As MemoryStream _
) _
Implements IChartData.WriteWorkbookStream
[C#]
public void WriteWorkbookStream(
MemoryStream ms
);

Parameters

ms
The user-supplied stream containing the entire Excel workbook.

Implements

IChartData.WriteWorkbookStream

See Also

ChartData Class | Aspose.Slides.Charts Namespace


ChartDataCell Class

Represents cell for chart data

For a list of all members of this type, see ChartDataCell Members.

System.Object
Aspose.Slides.Charts.ChartDataCell

[Visual Basic]
Public Class ChartDataCell
Implements IChartDataCell
[C#]
public class ChartDataCell : IChartDataCell

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartDataCell Members | Aspose.Slides.Charts Namespace


ChartDataCell Members

ChartDataCell overview

Public Instance Properties

ChartDataWorksheet | Returns the parent worksheet.
Column | Returns the index of the column of worksheet in which the cell is located
CustomNumberFormat | Gets or sets the custom display format of numbers and dates. If value is empty will be used PresetNumberFormat value.
IsHidden
PresetNumberFormat Gets or sets the built-in display format of numbers and dates. Preset number must be in [0..22] or [37..49]"

  Row  |  Returns the index of the row of worksheet in which the cell is located

  Value  |  Gets or sets the value of cell.
See Also
ChartDataCell Class | Aspose.Slides.Charts Namespace


ChartDataCell Properties

The properties of the ChartDataCell class are listed below. For a complete list of ChartDataCell class members, see the ChartDataCell Members topic.

Public Instance Properties

ChartDataWorksheet | Returns the parent worksheet.
Column | Returns the index of the column of worksheet in which the cell is located
CustomNumberFormat | Gets or sets the custom display format of numbers and dates. If value is empty will be used PresetNumberFormat value.
IsHidden
PresetNumberFormat Gets or sets the built-in display format of numbers and dates. Preset number must be in [0..22] or [37..49]"

  Row  |  Returns the index of the row of worksheet in which the cell is located

  Value  |  Gets or sets the value of cell.
See Also
ChartDataCell Class | Aspose.Slides.Charts Namespace


ChartDataWorksheet Property

Aspose.Slides Documentation

ChartDataCell.ChartDataWorksheet Property

Returns the parent worksheet.

[Visual Basic]
NotOverridable Public ReadOnly Property ChartDataWorksheet As IChartDataWorksheet _
Implements IChartDataCell.ChartDataWorksheet
[C#]
public IChartDataWorksheet ChartDataWorksheet {get;}

Implements

IChartDataCell.ChartDataWorksheet

See Also

ChartDataCell Class | Aspose.Slides.Charts Namespace


Column Property

Aspose.Slides Documentation

ChartDataCell.Column Property

Returns the index of the column of worksheet in which the cell is located

[Visual Basic]
NotOverridable Public ReadOnly Property Column As Integer _
Implements IChartDataCell.Column
[C#]
public int Column {get;}

Implements

IChartDataCell.Column

See Also

ChartDataCell Class | Aspose.Slides.Charts Namespace


CustomNumberFormat Property

Aspose.Slides Documentation

ChartDataCell.CustomNumberFormat Property

Gets or sets the custom display format of numbers and dates. If value is empty will be used PresetNumberFormat value.

[Visual Basic]
NotOverridable Public Property CustomNumberFormat As String _
Implements IChartDataCell.CustomNumberFormat
[C#]
public string CustomNumberFormat {get; set;}

Implements

IChartDataCell.CustomNumberFormat

See Also

ChartDataCell Class | Aspose.Slides.Charts Namespace


IsHidden Property

Aspose.Slides Documentation

ChartDataCell.IsHidden Property

[Visual Basic]
NotOverridable Public Property IsHidden As Boolean _
Implements IChartDataCell.IsHidden
[C#]
public bool IsHidden {get; set;}

Implements

IChartDataCell.IsHidden

See Also

ChartDataCell Class | Aspose.Slides.Charts Namespace


PresetNumberFormat Property

Aspose.Slides Documentation

ChartDataCell.PresetNumberFormat Property

Gets or sets the built-in display format of numbers and dates. Preset number must be in [0..22] or [37..49]"

[Visual Basic]
NotOverridable Public Property PresetNumberFormat As Byte _
    Implements IChartDataCell.PresetNumberFormat
[C#]
public byte PresetNumberFormat {get; set;}
Implements
IChartDataCell.PresetNumberFormat
See Also
ChartDataCell Class | Aspose.Slides.Charts Namespace


Row Property

Aspose.Slides Documentation

ChartDataCell.Row Property

Returns the index of the row of worksheet in which the cell is located

[Visual Basic]
NotOverridable Public ReadOnly Property Row As Integer _
Implements IChartDataCell.Row
[C#]
public int Row {get;}

Implements

IChartDataCell.Row

See Also

ChartDataCell Class | Aspose.Slides.Charts Namespace


Value Property

Aspose.Slides Documentation

ChartDataCell.Value Property

Gets or sets the value of cell.

[Visual Basic]
NotOverridable Public Property Value As Object _
Implements IChartDataCell.Value
[C#]
public object Value {get; set;}

Property Value

The value.

Implements

IChartDataCell.Value

See Also

ChartDataCell Class | Aspose.Slides.Charts Namespace


ChartDataPoint Class

Represents series data point.

For a list of all members of this type, see ChartDataPoint Members.

System.Object
Aspose.Slides.Charts.ChartDataPoint

[Visual Basic]
Public Class ChartDataPoint
Implements IChartDataPoint
[C#]
public class ChartDataPoint : IChartDataPoint

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartDataPoint Members | Aspose.Slides.Charts Namespace


ChartDataPoint Members

ChartDataPoint overview

Public Instance Properties

BubbleSize |
Explosion | Specifies the amount the data point shall be moved from the center of the pie.
Format | Represents the formatting properties.
IsBubble3D | Specifies that the bubbles have a 3-D effect applied to them.
Label |
Marker | Specifies a data marker.
Value |
XValue |
YValue |

See Also

ChartDataPoint Class | Aspose.Slides.Charts Namespace


ChartDataPoint Properties

The properties of the ChartDataPoint class are listed below. For a complete list of ChartDataPoint class members, see the ChartDataPoint Members topic.

Public Instance Properties

BubbleSize |
Explosion | Specifies the amount the data point shall be moved from the center of the pie.
Format | Represents the formatting properties.
IsBubble3D | Specifies that the bubbles have a 3-D effect applied to them.
Label |
Marker | Specifies a data marker.
Value |
XValue |
YValue |

See Also

ChartDataPoint Class | Aspose.Slides.Charts Namespace


BubbleSize Property

Aspose.Slides Documentation

ChartDataPoint.BubbleSize Property

[Visual Basic]
NotOverridable Public ReadOnly Property BubbleSize As IDoubleChartValue _
Implements IChartDataPoint.BubbleSize
[C#]
public IDoubleChartValue BubbleSize {get;}

Implements

IChartDataPoint.BubbleSize

See Also

ChartDataPoint Class | Aspose.Slides.Charts Namespace


Explosion Property

Aspose.Slides Documentation

ChartDataPoint.Explosion Property

Specifies the amount the data point shall be moved from the center of the pie.

[Visual Basic]
NotOverridable Public Property Explosion As Integer _
Implements IChartDataPoint.Explosion
[C#]
public int Explosion {get; set;}

Implements

IChartDataPoint.Explosion

See Also

ChartDataPoint Class | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

ChartDataPoint.Format Property

Represents the formatting properties.

[Visual Basic]
NotOverridable Public Property Format As IFormat _
Implements IChartDataPoint.Format
[C#]
public IFormat Format {get; set;}

Implements

IChartDataPoint.Format

See Also

ChartDataPoint Class | Aspose.Slides.Charts Namespace


IsBubble3D Property

Aspose.Slides Documentation

ChartDataPoint.IsBubble3D Property

Specifies that the bubbles have a 3-D effect applied to them.

[Visual Basic]
NotOverridable Public Property IsBubble3D As Boolean _
Implements IChartDataPoint.IsBubble3D
[C#]
public bool IsBubble3D {get; set;}

Implements

IChartDataPoint.IsBubble3D

See Also

ChartDataPoint Class | Aspose.Slides.Charts Namespace


Label Property

Aspose.Slides Documentation

ChartDataPoint.Label Property

[Visual Basic]
NotOverridable Public ReadOnly Property Label As IDataLabel _
Implements IChartDataPoint.Label
[C#]
public IDataLabel Label {get;}

Implements

IChartDataPoint.Label

See Also

ChartDataPoint Class | Aspose.Slides.Charts Namespace


Marker Property

Aspose.Slides Documentation

ChartDataPoint.Marker Property

Specifies a data marker.

[Visual Basic]
NotOverridable Public ReadOnly Property Marker As IMarker _
Implements IChartDataPoint.Marker
[C#]
public IMarker Marker {get;}

Implements

IChartDataPoint.Marker

See Also

ChartDataPoint Class | Aspose.Slides.Charts Namespace


Value Property

Aspose.Slides Documentation

ChartDataPoint.Value Property

[Visual Basic]
NotOverridable Public ReadOnly Property Value As IDoubleChartValue _
Implements IChartDataPoint.Value
[C#]
public IDoubleChartValue Value {get;}

Implements

IChartDataPoint.Value

See Also

ChartDataPoint Class | Aspose.Slides.Charts Namespace


XValue Property

Aspose.Slides Documentation

ChartDataPoint.XValue Property

[Visual Basic]
NotOverridable Public ReadOnly Property XValue As IStringOrDoubleChartValue _
Implements IChartDataPoint.XValue
[C#]
public IStringOrDoubleChartValue XValue {get;}

Implements

IChartDataPoint.XValue

See Also

ChartDataPoint Class | Aspose.Slides.Charts Namespace


YValue Property

Aspose.Slides Documentation

ChartDataPoint.YValue Property

[Visual Basic]
NotOverridable Public ReadOnly Property YValue As IDoubleChartValue _
Implements IChartDataPoint.YValue
[C#]
public IDoubleChartValue YValue {get;}

Implements

IChartDataPoint.YValue

See Also

ChartDataPoint Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection Class

Represents collection of a series data point.

For a list of all members of this type, see ChartDataPointCollection Members.

System.Object
Aspose.Slides.Charts.ChartDataPointCollection

[Visual Basic]
Public Class ChartDataPointCollection
Implements IChartDataPointCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Charts.IChartDataPoint, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class ChartDataPointCollection : IChartDataPointCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartDataPointCollection Members | Aspose.Slides.Charts Namespace


ChartDataPointCollection Members

ChartDataPointCollection overview

Public Instance Properties

Count |
DataSourceTypeForBubbleSizes | Specifies whether AsCell or AsLiteralString or AsLiteralDouble property is actual in data points BubbleSize property object. In other words it specifies the type of value of ChartDataPoint.BubbleSize.Data property.
DataSourceTypeForValues | Specifies whether AsCell or AsLiteralString or AsLiteralDouble property is actual in data points Value property object. In other words it specifies the type of value of ChartDataPoint.Value.Data property.
DataSourceTypeForXValues | Specifies whether AsCell or AsLiteralString or AsLiteralDouble property is actual in data points XValue property object. In other words it specifies the type of value of ChartDataPoint.XValue.Data property.
DataSourceTypeForYValues | Specifies whether AsCell or AsLiteralString or AsLiteralDouble property is actual in data points YValue property object. In other words it specifies the type of value of ChartDataPoint.YValue.Data property.
IsSynchronized |
Item | Overloaded.
SyncRoot |

Public Instance Methods

AddDataPointForAreaSeries | Overloaded.
AddDataPointForBarSeries | Overloaded.
AddDataPointForBubbleSeries | Overloaded.
AddDataPointForLineSeries | Overloaded.
AddDataPointForPieSeries | Overloaded.
AddDataPointForRadarSeries | Overloaded.
AddDataPointForScatterSeries | Overloaded.
AddDataPointForSurfaceSeries | Overloaded.
Clear | Removes all elements from the collection.
CopyTo |
GetEnumerator |
GetOrCreateDataPointByIdx |

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection Properties

The properties of the ChartDataPointCollection class are listed below. For a complete list of ChartDataPointCollection class members, see the ChartDataPointCollection Members topic.

Public Instance Properties

Count |
DataSourceTypeForBubbleSizes | Specifies whether AsCell or AsLiteralString or AsLiteralDouble property is actual in data points BubbleSize property object. In other words it specifies the type of value of ChartDataPoint.BubbleSize.Data property.
DataSourceTypeForValues | Specifies whether AsCell or AsLiteralString or AsLiteralDouble property is actual in data points Value property object. In other words it specifies the type of value of ChartDataPoint.Value.Data property.
DataSourceTypeForXValues | Specifies whether AsCell or AsLiteralString or AsLiteralDouble property is actual in data points XValue property object. In other words it specifies the type of value of ChartDataPoint.XValue.Data property.
DataSourceTypeForYValues | Specifies whether AsCell or AsLiteralString or AsLiteralDouble property is actual in data points YValue property object. In other words it specifies the type of value of ChartDataPoint.YValue.Data property.
IsSynchronized |
Item | Overloaded.
SyncRoot |

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


Count Property

Aspose.Slides Documentation

ChartDataPointCollection.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


DataSourceTypeForBubbleSizes Property

Aspose.Slides Documentation

ChartDataPointCollection.DataSourceTypeForBubbleSizes Property

Specifies whether AsCell or AsLiteralString or AsLiteralDouble property is actual in data points BubbleSize property object. In other words it specifies the type of value of ChartDataPoint.BubbleSize.Data property.

[Visual Basic]
NotOverridable Public Property DataSourceTypeForBubbleSizes As DataSourceType _
Implements IChartDataPointCollection.DataSourceTypeForBubbleSizes
[C#]
public DataSourceType DataSourceTypeForBubbleSizes {get; set;}

Implements

IChartDataPointCollection.DataSourceTypeForBubbleSizes

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


DataSourceTypeForValues Property

Aspose.Slides Documentation

ChartDataPointCollection.DataSourceTypeForValues Property

Specifies whether AsCell or AsLiteralString or AsLiteralDouble property is actual in data points Value property object. In other words it specifies the type of value of ChartDataPoint.Value.Data property.

[Visual Basic]
NotOverridable Public Property DataSourceTypeForValues As DataSourceType _
Implements IChartDataPointCollection.DataSourceTypeForValues
[C#]
public DataSourceType DataSourceTypeForValues {get; set;}

Implements

IChartDataPointCollection.DataSourceTypeForValues

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


DataSourceTypeForXValues Property

Aspose.Slides Documentation

ChartDataPointCollection.DataSourceTypeForXValues Property

Specifies whether AsCell or AsLiteralString or AsLiteralDouble property is actual in data points XValue property object. In other words it specifies the type of value of ChartDataPoint.XValue.Data property.

[Visual Basic]
NotOverridable Public Property DataSourceTypeForXValues As DataSourceType _
Implements IChartDataPointCollection.DataSourceTypeForXValues
[C#]
public DataSourceType DataSourceTypeForXValues {get; set;}

Implements

IChartDataPointCollection.DataSourceTypeForXValues

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


DataSourceTypeForYValues Property

Aspose.Slides Documentation

ChartDataPointCollection.DataSourceTypeForYValues Property

Specifies whether AsCell or AsLiteralString or AsLiteralDouble property is actual in data points YValue property object. In other words it specifies the type of value of ChartDataPoint.YValue.Data property.

[Visual Basic]
NotOverridable Public Property DataSourceTypeForYValues As DataSourceType _
Implements IChartDataPointCollection.DataSourceTypeForYValues
[C#]
public DataSourceType DataSourceTypeForYValues {get; set;}

Implements

IChartDataPointCollection.DataSourceTypeForYValues

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


IsSynchronized Property

Aspose.Slides Documentation

ChartDataPointCollection.IsSynchronized Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

ChartDataPointCollection.Item Property

Return index of data point in this collection.

Overload List

Return index of data point in this collection.

public int this[Aspose.Slides.Charts.IChartDataPoint] {get;}

public IChartDataPoint this[int] {get;}

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


Item Property (IChartDataPoint)

Aspose.Slides Documentation

ChartDataPointCollection.Item Property (IChartDataPoint)

Return index of data point in this collection.

[Visual Basic]
NotOverridable Overloads Public Default ReadOnly Property Item( _
ByVal pt As IChartDataPoint _
) _
Implements IChartDataPointCollection.Item
As Integer _
Implements IChartDataPointCollection.Item
[C#]
public int this[
Aspose.Slides.Charts.IChartDataPoint pt
] {get;}

Implements

IChartDataPointCollection.Item

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.Item Overload List


Item Property (Int32)

Aspose.Slides Documentation

ChartDataPointCollection.Item Property (Int32)

[Visual Basic]
NotOverridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IChartDataPointCollection.Item
As IChartDataPoint _
Implements IChartDataPointCollection.Item
[C#]
public IChartDataPoint this[
int index
] {get;}

Implements

IChartDataPointCollection.Item

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.Item Overload List


SyncRoot Property

Aspose.Slides Documentation

ChartDataPointCollection.SyncRoot Property

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection Methods

The methods of the ChartDataPointCollection class are listed below. For a complete list of ChartDataPointCollection class members, see the ChartDataPointCollection Members topic.

Public Instance Methods

AddDataPointForAreaSeries | Overloaded.
AddDataPointForBarSeries | Overloaded.
AddDataPointForBubbleSeries | Overloaded.
AddDataPointForLineSeries | Overloaded.
AddDataPointForPieSeries | Overloaded.
AddDataPointForRadarSeries | Overloaded.
AddDataPointForScatterSeries | Overloaded.
AddDataPointForSurfaceSeries | Overloaded.
Clear | Removes all elements from the collection.
CopyTo |
GetEnumerator |
GetOrCreateDataPointByIdx |

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


AddDataPointForAreaSeries Method

Aspose.Slides Documentation

ChartDataPointCollection.AddDataPointForAreaSeries Method

Overload List

public IChartDataPoint AddDataPointForAreaSeries(IChartDataCell);

public IChartDataPoint AddDataPointForAreaSeries(double);

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection.AddDataPointForAreaSeries Method (IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForAreaSeries( _
ByVal value As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForAreaSeries
[C#]
public IChartDataPoint AddDataPointForAreaSeries(
IChartDataCell value
);

Implements

IChartDataPointCollection.AddDataPointForAreaSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForAreaSeries Overload List


ChartDataPointCollection.AddDataPointForAreaSeries Method (Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForAreaSeries( _
ByVal value As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForAreaSeries
[C#]
public IChartDataPoint AddDataPointForAreaSeries(
double value
);

Implements

IChartDataPointCollection.AddDataPointForAreaSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForAreaSeries Overload List


AddDataPointForBarSeries Method

Aspose.Slides Documentation

ChartDataPointCollection.AddDataPointForBarSeries Method

Overload List

public IChartDataPoint AddDataPointForBarSeries(IChartDataCell);

public IChartDataPoint AddDataPointForBarSeries(double);

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection.AddDataPointForBarSeries Method (IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBarSeries( _
ByVal value As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBarSeries
[C#]
public IChartDataPoint AddDataPointForBarSeries(
IChartDataCell value
);

Implements

IChartDataPointCollection.AddDataPointForBarSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBarSeries Overload List


ChartDataPointCollection.AddDataPointForBarSeries Method (Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBarSeries( _
ByVal value As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBarSeries
[C#]
public IChartDataPoint AddDataPointForBarSeries(
double value
);

Implements

IChartDataPointCollection.AddDataPointForBarSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBarSeries Overload List


AddDataPointForBubbleSeries Method

Aspose.Slides Documentation

ChartDataPointCollection.AddDataPointForBubbleSeries Method

Overload List

public IChartDataPoint AddDataPointForBubbleSeries(IChartDataCell,IChartDataCell,IChartDataCell);

public IChartDataPoint AddDataPointForBubbleSeries(IChartDataCell,IChartDataCell,double);

public IChartDataPoint AddDataPointForBubbleSeries(IChartDataCell,double,IChartDataCell);

public IChartDataPoint AddDataPointForBubbleSeries(IChartDataCell,double,double);

public IChartDataPoint AddDataPointForBubbleSeries(double,IChartDataCell,IChartDataCell);

public IChartDataPoint AddDataPointForBubbleSeries(double,IChartDataCell,double);

public IChartDataPoint AddDataPointForBubbleSeries(double,double,IChartDataCell);

public IChartDataPoint AddDataPointForBubbleSeries(double,double,double);

public IChartDataPoint AddDataPointForBubbleSeries(string,IChartDataCell,IChartDataCell);

public IChartDataPoint AddDataPointForBubbleSeries(string,IChartDataCell,double);

public IChartDataPoint AddDataPointForBubbleSeries(string,double,IChartDataCell);

public IChartDataPoint AddDataPointForBubbleSeries(string,double,double);

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection.AddDataPointForBubbleSeries Method (IChartDataCell, IChartDataCell, IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBubbleSeries( _
ByVal xValue As IChartDataCell, _
ByVal yValue As IChartDataCell, _
ByVal bubbleSize As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBubbleSeries
[C#]
public IChartDataPoint AddDataPointForBubbleSeries(
IChartDataCell xValue,
IChartDataCell yValue,
IChartDataCell bubbleSize
);

Implements

IChartDataPointCollection.AddDataPointForBubbleSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBubbleSeries Overload List


ChartDataPointCollection.AddDataPointForBubbleSeries Method (IChartDataCell, IChartDataCell, Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBubbleSeries( _
ByVal xValue As IChartDataCell, _
ByVal yValue As IChartDataCell, _
ByVal bubbleSize As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBubbleSeries
[C#]
public IChartDataPoint AddDataPointForBubbleSeries(
IChartDataCell xValue,
IChartDataCell yValue,
double bubbleSize
);

Implements

IChartDataPointCollection.AddDataPointForBubbleSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBubbleSeries Overload List


ChartDataPointCollection.AddDataPointForBubbleSeries Method (IChartDataCell, Double, IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBubbleSeries( _
ByVal xValue As IChartDataCell, _
ByVal yValue As Double, _
ByVal bubbleSize As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBubbleSeries
[C#]
public IChartDataPoint AddDataPointForBubbleSeries(
IChartDataCell xValue,
double yValue,
IChartDataCell bubbleSize
);

Implements

IChartDataPointCollection.AddDataPointForBubbleSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBubbleSeries Overload List


ChartDataPointCollection.AddDataPointForBubbleSeries Method (IChartDataCell, Double, Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBubbleSeries( _
ByVal xValue As IChartDataCell, _
ByVal yValue As Double, _
ByVal bubbleSize As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBubbleSeries
[C#]
public IChartDataPoint AddDataPointForBubbleSeries(
IChartDataCell xValue,
double yValue,
double bubbleSize
);

Implements

IChartDataPointCollection.AddDataPointForBubbleSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBubbleSeries Overload List


ChartDataPointCollection.AddDataPointForBubbleSeries Method (Double, IChartDataCell, IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBubbleSeries( _
ByVal xValue As Double, _
ByVal yValue As IChartDataCell, _
ByVal bubbleSize As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBubbleSeries
[C#]
public IChartDataPoint AddDataPointForBubbleSeries(
double xValue,
IChartDataCell yValue,
IChartDataCell bubbleSize
);

Implements

IChartDataPointCollection.AddDataPointForBubbleSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBubbleSeries Overload List


ChartDataPointCollection.AddDataPointForBubbleSeries Method (Double, IChartDataCell, Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBubbleSeries( _
ByVal xValue As Double, _
ByVal yValue As IChartDataCell, _
ByVal bubbleSize As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBubbleSeries
[C#]
public IChartDataPoint AddDataPointForBubbleSeries(
double xValue,
IChartDataCell yValue,
double bubbleSize
);

Implements

IChartDataPointCollection.AddDataPointForBubbleSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBubbleSeries Overload List


ChartDataPointCollection.AddDataPointForBubbleSeries Method (Double, Double, IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBubbleSeries( _
ByVal xValue As Double, _
ByVal yValue As Double, _
ByVal bubbleSize As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBubbleSeries
[C#]
public IChartDataPoint AddDataPointForBubbleSeries(
double xValue,
double yValue,
IChartDataCell bubbleSize
);

Implements

IChartDataPointCollection.AddDataPointForBubbleSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBubbleSeries Overload List


ChartDataPointCollection.AddDataPointForBubbleSeries Method (Double, Double, Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBubbleSeries( _
ByVal xValue As Double, _
ByVal yValue As Double, _
ByVal bubbleSize As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBubbleSeries
[C#]
public IChartDataPoint AddDataPointForBubbleSeries(
double xValue,
double yValue,
double bubbleSize
);

Implements

IChartDataPointCollection.AddDataPointForBubbleSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBubbleSeries Overload List


ChartDataPointCollection.AddDataPointForBubbleSeries Method (String, IChartDataCell, IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBubbleSeries( _
ByVal xValue As String, _
ByVal yValue As IChartDataCell, _
ByVal bubbleSize As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBubbleSeries
[C#]
public IChartDataPoint AddDataPointForBubbleSeries(
string xValue,
IChartDataCell yValue,
IChartDataCell bubbleSize
);

Implements

IChartDataPointCollection.AddDataPointForBubbleSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBubbleSeries Overload List


ChartDataPointCollection.AddDataPointForBubbleSeries Method (String, IChartDataCell, Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBubbleSeries( _
ByVal xValue As String, _
ByVal yValue As IChartDataCell, _
ByVal bubbleSize As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBubbleSeries
[C#]
public IChartDataPoint AddDataPointForBubbleSeries(
string xValue,
IChartDataCell yValue,
double bubbleSize
);

Implements

IChartDataPointCollection.AddDataPointForBubbleSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBubbleSeries Overload List


ChartDataPointCollection.AddDataPointForBubbleSeries Method (String, Double, IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBubbleSeries( _
ByVal xValue As String, _
ByVal yValue As Double, _
ByVal bubbleSize As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBubbleSeries
[C#]
public IChartDataPoint AddDataPointForBubbleSeries(
string xValue,
double yValue,
IChartDataCell bubbleSize
);

Implements

IChartDataPointCollection.AddDataPointForBubbleSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBubbleSeries Overload List


ChartDataPointCollection.AddDataPointForBubbleSeries Method (String, Double, Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForBubbleSeries( _
ByVal xValue As String, _
ByVal yValue As Double, _
ByVal bubbleSize As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForBubbleSeries
[C#]
public IChartDataPoint AddDataPointForBubbleSeries(
string xValue,
double yValue,
double bubbleSize
);

Implements

IChartDataPointCollection.AddDataPointForBubbleSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForBubbleSeries Overload List


AddDataPointForLineSeries Method

Aspose.Slides Documentation

ChartDataPointCollection.AddDataPointForLineSeries Method

Overload List

public IChartDataPoint AddDataPointForLineSeries(IChartDataCell);

public IChartDataPoint AddDataPointForLineSeries(double);

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection.AddDataPointForLineSeries Method (IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForLineSeries( _
ByVal value As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForLineSeries
[C#]
public IChartDataPoint AddDataPointForLineSeries(
IChartDataCell value
);

Implements

IChartDataPointCollection.AddDataPointForLineSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForLineSeries Overload List


ChartDataPointCollection.AddDataPointForLineSeries Method (Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForLineSeries( _
ByVal value As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForLineSeries
[C#]
public IChartDataPoint AddDataPointForLineSeries(
double value
);

Implements

IChartDataPointCollection.AddDataPointForLineSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForLineSeries Overload List


AddDataPointForPieSeries Method

Aspose.Slides Documentation

ChartDataPointCollection.AddDataPointForPieSeries Method

Overload List

public IChartDataPoint AddDataPointForPieSeries(IChartDataCell);

public IChartDataPoint AddDataPointForPieSeries(double);

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection.AddDataPointForPieSeries Method (IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForPieSeries( _
ByVal value As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForPieSeries
[C#]
public IChartDataPoint AddDataPointForPieSeries(
IChartDataCell value
);

Implements

IChartDataPointCollection.AddDataPointForPieSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForPieSeries Overload List


ChartDataPointCollection.AddDataPointForPieSeries Method (Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForPieSeries( _
ByVal value As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForPieSeries
[C#]
public IChartDataPoint AddDataPointForPieSeries(
double value
);

Implements

IChartDataPointCollection.AddDataPointForPieSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForPieSeries Overload List


AddDataPointForRadarSeries Method

Aspose.Slides Documentation

ChartDataPointCollection.AddDataPointForRadarSeries Method

Overload List

public IChartDataPoint AddDataPointForRadarSeries(IChartDataCell);

public IChartDataPoint AddDataPointForRadarSeries(double);

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection.AddDataPointForRadarSeries Method (IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForRadarSeries( _
ByVal value As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForRadarSeries
[C#]
public IChartDataPoint AddDataPointForRadarSeries(
IChartDataCell value
);

Implements

IChartDataPointCollection.AddDataPointForRadarSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForRadarSeries Overload List


ChartDataPointCollection.AddDataPointForRadarSeries Method (Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForRadarSeries( _
ByVal value As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForRadarSeries
[C#]
public IChartDataPoint AddDataPointForRadarSeries(
double value
);

Implements

IChartDataPointCollection.AddDataPointForRadarSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForRadarSeries Overload List


AddDataPointForScatterSeries Method

Aspose.Slides Documentation

ChartDataPointCollection.AddDataPointForScatterSeries Method

Overload List

public IChartDataPoint AddDataPointForScatterSeries(IChartDataCell,IChartDataCell);

public IChartDataPoint AddDataPointForScatterSeries(IChartDataCell,double);

public IChartDataPoint AddDataPointForScatterSeries(double,IChartDataCell);

public IChartDataPoint AddDataPointForScatterSeries(double,double);

public IChartDataPoint AddDataPointForScatterSeries(string,IChartDataCell);

public IChartDataPoint AddDataPointForScatterSeries(string,double);

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection.AddDataPointForScatterSeries Method (IChartDataCell, IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForScatterSeries( _
ByVal xValue As IChartDataCell, _
ByVal yValue As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForScatterSeries
[C#]
public IChartDataPoint AddDataPointForScatterSeries(
IChartDataCell xValue,
IChartDataCell yValue
);

Implements

IChartDataPointCollection.AddDataPointForScatterSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForScatterSeries Overload List


ChartDataPointCollection.AddDataPointForScatterSeries Method (IChartDataCell, Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForScatterSeries( _
ByVal xValue As IChartDataCell, _
ByVal yValue As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForScatterSeries
[C#]
public IChartDataPoint AddDataPointForScatterSeries(
IChartDataCell xValue,
double yValue
);

Implements

IChartDataPointCollection.AddDataPointForScatterSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForScatterSeries Overload List


ChartDataPointCollection.AddDataPointForScatterSeries Method (Double, IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForScatterSeries( _
ByVal xValue As Double, _
ByVal yValue As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForScatterSeries
[C#]
public IChartDataPoint AddDataPointForScatterSeries(
double xValue,
IChartDataCell yValue
);

Implements

IChartDataPointCollection.AddDataPointForScatterSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForScatterSeries Overload List


ChartDataPointCollection.AddDataPointForScatterSeries Method (Double, Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForScatterSeries( _
ByVal xValue As Double, _
ByVal yValue As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForScatterSeries
[C#]
public IChartDataPoint AddDataPointForScatterSeries(
double xValue,
double yValue
);

Implements

IChartDataPointCollection.AddDataPointForScatterSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForScatterSeries Overload List


ChartDataPointCollection.AddDataPointForScatterSeries Method (String, IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForScatterSeries( _
ByVal xValue As String, _
ByVal yValue As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForScatterSeries
[C#]
public IChartDataPoint AddDataPointForScatterSeries(
string xValue,
IChartDataCell yValue
);

Implements

IChartDataPointCollection.AddDataPointForScatterSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForScatterSeries Overload List


ChartDataPointCollection.AddDataPointForScatterSeries Method (String, Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForScatterSeries( _
ByVal xValue As String, _
ByVal yValue As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForScatterSeries
[C#]
public IChartDataPoint AddDataPointForScatterSeries(
string xValue,
double yValue
);

Implements

IChartDataPointCollection.AddDataPointForScatterSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForScatterSeries Overload List


AddDataPointForSurfaceSeries Method

Aspose.Slides Documentation

ChartDataPointCollection.AddDataPointForSurfaceSeries Method

Overload List

public IChartDataPoint AddDataPointForSurfaceSeries(IChartDataCell);

public IChartDataPoint AddDataPointForSurfaceSeries(double);

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection.AddDataPointForSurfaceSeries Method (IChartDataCell)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForSurfaceSeries( _
ByVal value As IChartDataCell _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForSurfaceSeries
[C#]
public IChartDataPoint AddDataPointForSurfaceSeries(
IChartDataCell value
);

Implements

IChartDataPointCollection.AddDataPointForSurfaceSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForSurfaceSeries Overload List


ChartDataPointCollection.AddDataPointForSurfaceSeries Method (Double)

[Visual Basic]
NotOverridable Overloads Public Function AddDataPointForSurfaceSeries( _
ByVal value As Double _
) As IChartDataPoint _
Implements IChartDataPointCollection.AddDataPointForSurfaceSeries
[C#]
public IChartDataPoint AddDataPointForSurfaceSeries(
double value
);

Implements

IChartDataPointCollection.AddDataPointForSurfaceSeries

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace | ChartDataPointCollection.AddDataPointForSurfaceSeries Overload List


ChartDataPointCollection.Clear Method

Removes all elements from the collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IChartDataPointCollection.Clear
[C#]
public void Clear();

Implements

IChartDataPointCollection.Clear

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection.CopyTo Method

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal arrayIndex As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int arrayIndex
);

Implements

ICollection.CopyTo

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection.GetEnumerator Method

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataPointCollection.GetOrCreateDataPointByIdx Method

[Visual Basic]
NotOverridable Public Function GetOrCreateDataPointByIdx( _
ByVal idx As UInt32 _
) As IChartDataPoint _
Implements IChartDataPointCollection.GetOrCreateDataPointByIdx
[C#]
public IChartDataPoint GetOrCreateDataPointByIdx(
uint idx
);

Implements

IChartDataPointCollection.GetOrCreateDataPointByIdx

See Also

ChartDataPointCollection Class | Aspose.Slides.Charts Namespace


ChartDataWorkbook Class

Provides access to embedded Excel workbook

For a list of all members of this type, see ChartDataWorkbook Members.

System.Object
Aspose.Slides.Charts.ChartDataWorkbook

[Visual Basic]
Public Class ChartDataWorkbook
Implements IChartDataWorkbook
[C#]
public class ChartDataWorkbook : IChartDataWorkbook

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartDataWorkbook Members | Aspose.Slides.Charts Namespace


ChartDataWorkbook Members

ChartDataWorkbook overview

Public Instance Methods

Clear | Clear all cells values on sheet
GetCell | Overloaded. Gets the cell that can be used for chart series or categories
GetCellCollection | Gets the set of cells.

See Also

ChartDataWorkbook Class | Aspose.Slides.Charts Namespace


ChartDataWorkbook Methods

The methods of the ChartDataWorkbook class are listed below. For a complete list of ChartDataWorkbook class members, see the ChartDataWorkbook Members topic.

Public Instance Methods

Clear | Clear all cells values on sheet
GetCell | Overloaded. Gets the cell that can be used for chart series or categories
GetCellCollection | Gets the set of cells.

See Also

ChartDataWorkbook Class | Aspose.Slides.Charts Namespace


ChartDataWorkbook.Clear Method

Clear all cells values on sheet

[Visual Basic]
NotOverridable Public Sub Clear( _
ByVal sheetIndex As Integer _
) _
Implements IChartDataWorkbook.Clear
[C#]
public void Clear(
int sheetIndex
);

Parameters

sheetIndex
Index of sheet

Implements

IChartDataWorkbook.Clear

See Also

ChartDataWorkbook Class | Aspose.Slides.Charts Namespace


GetCell Method

Aspose.Slides Documentation

ChartDataWorkbook.GetCell Method

Gets the cell that can be used for chart series or categories

Overload List

Gets the cell that can be used for chart series or categories

public IChartDataCell GetCell(int,int,int);

Gets the cell that can be used for chart series or categories

public IChartDataCell GetCell(int,int,int,object);

Gets the cell that can be used for chart series or categories

public IChartDataCell GetCell(int,string);

Gets the cell that can be used for chart series or categories

public IChartDataCell GetCell(int,string,object);

Gets the cell that can be used for chart series or categories

public IChartDataCell GetCell(string,int,int);

See Also

ChartDataWorkbook Class | Aspose.Slides.Charts Namespace


ChartDataWorkbook.GetCell Method (Int32, Int32, Int32)

Gets the cell that can be used for chart series or categories

[Visual Basic]
NotOverridable Overloads Public Function GetCell( _
ByVal worksheetIndex As Integer, _
ByVal row As Integer, _
ByVal column As Integer _
) As IChartDataCell _
Implements IChartDataWorkbook.GetCell
[C#]
public IChartDataCell GetCell(
int worksheetIndex,
int row,
int column
);

Parameters

worksheetIndex
Index of the worksheet.
row
The row.
column
The column.

Return Value

Cell object

Implements

IChartDataWorkbook.GetCell

See Also

ChartDataWorkbook Class | Aspose.Slides.Charts Namespace | ChartDataWorkbook.GetCell Overload List


ChartDataWorkbook.GetCell Method (Int32, Int32, Int32, Object)

Gets the cell that can be used for chart series or categories

[Visual Basic]
NotOverridable Overloads Public Function GetCell( _
ByVal worksheetIndex As Integer, _
ByVal row As Integer, _
ByVal column As Integer, _
ByVal value As Object _
) As IChartDataCell _
Implements IChartDataWorkbook.GetCell
[C#]
public IChartDataCell GetCell(
int worksheetIndex,
int row,
int column,
object value
);

Parameters

worksheetIndex
Index of the worksheet.
row
The row.
column
The column.
value
The value.

Return Value

Cell object

Implements

IChartDataWorkbook.GetCell

See Also

ChartDataWorkbook Class | Aspose.Slides.Charts Namespace | ChartDataWorkbook.GetCell Overload List


ChartDataWorkbook.GetCell Method (Int32, String)

Gets the cell that can be used for chart series or categories

[Visual Basic]
NotOverridable Overloads Public Function GetCell( _
ByVal worksheetIndex As Integer, _
ByVal cellName As String _
) As IChartDataCell _
Implements IChartDataWorkbook.GetCell
[C#]
public IChartDataCell GetCell(
int worksheetIndex,
string cellName
);

Parameters

worksheetIndex
Index of the worksheet.
cellName
Name of the cell.

Return Value

Cell object

Implements

IChartDataWorkbook.GetCell

See Also

ChartDataWorkbook Class | Aspose.Slides.Charts Namespace | ChartDataWorkbook.GetCell Overload List


ChartDataWorkbook.GetCell Method (Int32, String, Object)

Gets the cell that can be used for chart series or categories

[Visual Basic]
NotOverridable Overloads Public Function GetCell( _
ByVal worksheetIndex As Integer, _
ByVal cellName As String, _
ByVal value As Object _
) As IChartDataCell _
Implements IChartDataWorkbook.GetCell
[C#]
public IChartDataCell GetCell(
int worksheetIndex,
string cellName,
object value
);

Parameters

worksheetIndex
Index of the worksheet.
cellName
Name of the cell.
value
The value.

Return Value

Cell object

Implements

IChartDataWorkbook.GetCell

See Also

ChartDataWorkbook Class | Aspose.Slides.Charts Namespace | ChartDataWorkbook.GetCell Overload List


ChartDataWorkbook.GetCell Method (String, Int32, Int32)

Gets the cell that can be used for chart series or categories

[Visual Basic]
NotOverridable Overloads Public Function GetCell( _
ByVal worksheetName As String, _
ByVal row As Integer, _
ByVal column As Integer _
) As IChartDataCell _
Implements IChartDataWorkbook.GetCell
[C#]
public IChartDataCell GetCell(
string worksheetName,
int row,
int column
);

Parameters

worksheetName
Name of the worksheet.
row
The row.
column
The column.

Return Value

Cell object

Implements

IChartDataWorkbook.GetCell

See Also

ChartDataWorkbook Class | Aspose.Slides.Charts Namespace | ChartDataWorkbook.GetCell Overload List


ChartDataWorkbook.GetCellCollection Method

Gets the set of cells.

[Visual Basic]
NotOverridable Public Function GetCellCollection( _
ByVal formula As String, _
ByVal skipHiddenCells As Boolean _
) As IChartCellCollection _
Implements IChartDataWorkbook.GetCellCollection
[C#]
public IChartCellCollection GetCellCollection(
string formula,
bool skipHiddenCells
);

Parameters

formula
Excel formula like "Sheet1!$A$2:$A$5".
skipHiddenCells
If true then method returns collection without hidden cells.

Implements

IChartDataWorkbook.GetCellCollection

See Also

ChartDataWorkbook Class | Aspose.Slides.Charts Namespace


ChartDataWorksheet Class

Represents worksheet associated with IChartDataCell

For a list of all members of this type, see ChartDataWorksheet Members.

System.Object
Aspose.Slides.Charts.ChartDataWorksheet

[Visual Basic]
Public Class ChartDataWorksheet
Implements IChartDataWorksheet
[C#]
public class ChartDataWorksheet : IChartDataWorksheet

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartDataWorksheet Members | Aspose.Slides.Charts Namespace


ChartDataWorksheet Members

ChartDataWorksheet overview

Public Instance Properties

Index | Gets the index of the worksheet
Name | Returns the name of the worksheet

See Also

ChartDataWorksheet Class | Aspose.Slides.Charts Namespace


ChartDataWorksheet Properties

The properties of the ChartDataWorksheet class are listed below. For a complete list of ChartDataWorksheet class members, see the ChartDataWorksheet Members topic.

Public Instance Properties

Index | Gets the index of the worksheet
Name | Returns the name of the worksheet

See Also

ChartDataWorksheet Class | Aspose.Slides.Charts Namespace


Index Property

Aspose.Slides Documentation

ChartDataWorksheet.Index Property

Gets the index of the worksheet

[Visual Basic]
NotOverridable Public ReadOnly Property Index As Integer _
Implements IChartDataWorksheet.Index
[C#]
public int Index {get;}

Implements

IChartDataWorksheet.Index

See Also

ChartDataWorksheet Class | Aspose.Slides.Charts Namespace


Name Property

Aspose.Slides Documentation

ChartDataWorksheet.Name Property

Returns the name of the worksheet

[Visual Basic]
NotOverridable Public ReadOnly Property Name As String _
Implements IChartDataWorksheet.Name
[C#]
public string Name {get;}

Implements

IChartDataWorksheet.Name

See Also

ChartDataWorksheet Class | Aspose.Slides.Charts Namespace


ChartLinesFormat Class

Represents gridlines format properties.

For a list of all members of this type, see ChartLinesFormat Members.

System.Object
Aspose.Slides.Charts.ChartLinesFormat

[Visual Basic]
Public Class ChartLinesFormat
Implements IChartLinesFormat
[C#]
public class ChartLinesFormat : IChartLinesFormat

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartLinesFormat Members | Aspose.Slides.Charts Namespace


ChartLinesFormat Members

ChartLinesFormat overview

Public Instance Properties

Effect | Returns effects used for a chart line. Read-only IEffectFormat.
Line | Returns line style properties of a chart line. Read-only ILineFormat.

See Also

ChartLinesFormat Class | Aspose.Slides.Charts Namespace


ChartLinesFormat Properties

The properties of the ChartLinesFormat class are listed below. For a complete list of ChartLinesFormat class members, see the ChartLinesFormat Members topic.

Public Instance Properties

Effect | Returns effects used for a chart line. Read-only IEffectFormat.
Line | Returns line style properties of a chart line. Read-only ILineFormat.

See Also

ChartLinesFormat Class | Aspose.Slides.Charts Namespace


Effect Property

Aspose.Slides Documentation

ChartLinesFormat.Effect Property

Returns effects used for a chart line. Read-only IEffectFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Effect As IEffectFormat _
Implements IChartLinesFormat.Effect
[C#]
public IEffectFormat Effect {get;}

Implements

IChartLinesFormat.Effect

See Also

ChartLinesFormat Class | Aspose.Slides.Charts Namespace


Line Property

Aspose.Slides Documentation

ChartLinesFormat.Line Property

Returns line style properties of a chart line. Read-only ILineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Line As ILineFormat _
Implements IChartLinesFormat.Line
[C#]
public ILineFormat Line {get;}

Implements

IChartLinesFormat.Line

See Also

ChartLinesFormat Class | Aspose.Slides.Charts Namespace


ChartPlotArea Class

Represents rectangle where chart should be plotted.

For a list of all members of this type, see ChartPlotArea Members.

System.Object
Aspose.Slides.Charts.ChartPlotArea

[Visual Basic]
Public Class ChartPlotArea
Implements IChartPlotArea, ILayoutable, IChartComponent
[C#]
public class ChartPlotArea : IChartPlotArea, ILayoutable, IChartComponent

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartPlotArea Members | Aspose.Slides.Charts Namespace


ChartPlotArea Members

ChartPlotArea overview

Public Instance Properties

Bottom |
Chart |
Format | Returns the format of a plot area. Read-only Format.
Height | Returns or sets the height of a plot area bounding box as a fraction of the height of the chart (from 0 to 1). Read/write Single.
IsLocationAutocalculated | Defines how location should be calculated: true – calculated automatically; defined by the X, Y, Width, Height properties.
Right |
Width | Returns or sets the width of a plot area bounding box as a fraction of the width of the chart (from 0 to 1). Read/write Single.
X | Returns or sets the x coordinate of the upper left corner of plot area bounding box as a fraction of the width of the chart (from 0 to 1). Read/write Single.
Y | Returns or sets the y coordinate of the upper left corner of plot area bounding box as a fraction of the height of the chart (from 0 to 1). Read/write Single.

See Also

ChartPlotArea Class | Aspose.Slides.Charts Namespace


ChartPlotArea Properties

The properties of the ChartPlotArea class are listed below. For a complete list of ChartPlotArea class members, see the ChartPlotArea Members topic.

Public Instance Properties

Bottom |
Chart |
Format | Returns the format of a plot area. Read-only Format.
Height | Returns or sets the height of a plot area bounding box as a fraction of the height of the chart (from 0 to 1). Read/write Single.
IsLocationAutocalculated | Defines how location should be calculated: true – calculated automatically; defined by the X, Y, Width, Height properties.
Right |
Width | Returns or sets the width of a plot area bounding box as a fraction of the width of the chart (from 0 to 1). Read/write Single.
X | Returns or sets the x coordinate of the upper left corner of plot area bounding box as a fraction of the width of the chart (from 0 to 1). Read/write Single.
Y | Returns or sets the y coordinate of the upper left corner of plot area bounding box as a fraction of the height of the chart (from 0 to 1). Read/write Single.

See Also

ChartPlotArea Class | Aspose.Slides.Charts Namespace


Bottom Property

Aspose.Slides Documentation

ChartPlotArea.Bottom Property

[Visual Basic]
NotOverridable Public ReadOnly Property Bottom As Single _
Implements ILayoutable.Bottom
[C#]
public float Bottom {get;}

Implements

ILayoutable.Bottom

See Also

ChartPlotArea Class | Aspose.Slides.Charts Namespace


Chart Property

Aspose.Slides Documentation

ChartPlotArea.Chart Property

[Visual Basic]
NotOverridable Public ReadOnly Property Chart As IChart _
Implements IChartComponent.Chart
[C#]
public IChart Chart {get;}

Implements

IChartComponent.Chart

See Also

ChartPlotArea Class | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

ChartPlotArea.Format Property

Returns the format of a plot area. Read-only Format.

[Visual Basic]
NotOverridable Public ReadOnly Property Format As IFormat _
Implements IChartPlotArea.Format
[C#]
public IFormat Format {get;}

Implements

IChartPlotArea.Format

See Also

ChartPlotArea Class | Aspose.Slides.Charts Namespace


Height Property

Aspose.Slides Documentation

ChartPlotArea.Height Property

Returns or sets the height of a plot area bounding box as a fraction of the height of the chart (from 0 to 1). Read/write Single.

[Visual Basic]
NotOverridable Public Property Height As Single _
Implements ILayoutable.Height
[C#]
public float Height {get; set;}

Implements

ILayoutable.Height

See Also

ChartPlotArea Class | Aspose.Slides.Charts Namespace


IsLocationAutocalculated Property

Aspose.Slides Documentation

ChartPlotArea.IsLocationAutocalculated Property

Defines how location should be calculated: true – calculated automatically; defined by the X, Y, Width, Height properties.

[Visual Basic]
Public Property IsLocationAutocalculated As Boolean
[C#]
public bool IsLocationAutocalculated {get; set;}

See Also

ChartPlotArea Class | Aspose.Slides.Charts Namespace


Right Property

Aspose.Slides Documentation

ChartPlotArea.Right Property

[Visual Basic]
NotOverridable Public ReadOnly Property Right As Single _
Implements ILayoutable.Right
[C#]
public float Right {get;}

Implements

ILayoutable.Right

See Also

ChartPlotArea Class | Aspose.Slides.Charts Namespace


Width Property

Aspose.Slides Documentation

ChartPlotArea.Width Property

Returns or sets the width of a plot area bounding box as a fraction of the width of the chart (from 0 to 1). Read/write Single.

[Visual Basic]
NotOverridable Public Property Width As Single _
Implements ILayoutable.Width
[C#]
public float Width {get; set;}

Implements

ILayoutable.Width

See Also

ChartPlotArea Class | Aspose.Slides.Charts Namespace


X Property

Aspose.Slides Documentation

ChartPlotArea.X Property

Returns or sets the x coordinate of the upper left corner of plot area bounding box as a fraction of the width of the chart (from 0 to 1). Read/write Single.

[Visual Basic]
NotOverridable Public Property X As Single _
Implements ILayoutable.X
[C#]
public float X {get; set;}

Implements

ILayoutable.X

See Also

ChartPlotArea Class | Aspose.Slides.Charts Namespace


Y Property

Aspose.Slides Documentation

ChartPlotArea.Y Property

Returns or sets the y coordinate of the upper left corner of plot area bounding box as a fraction of the height of the chart (from 0 to 1). Read/write Single.

[Visual Basic]
NotOverridable Public Property Y As Single _
Implements ILayoutable.Y
[C#]
public float Y {get; set;}

Implements

ILayoutable.Y

See Also

ChartPlotArea Class | Aspose.Slides.Charts Namespace


ChartSeries Class

Represents a chart series.

For a list of all members of this type, see ChartSeries Members.

System.Object
Aspose.Slides.Charts.ChartSeries

[Visual Basic]
Public Class ChartSeries
Implements IChartSeries, IChartComponent
[C#]
public class ChartSeries : IChartSeries, IChartComponent

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartSeries Members | Aspose.Slides.Charts Namespace


ChartSeries Members

ChartSeries overview

Public Instance Properties

Bar3DShape | Specifies the shape of a series of a 3-D bar chart. Changing of value of this property can cause to automatically changing Type of series.
Chart | Returns the parent chart. Read-only IChart.
DataPoints | Returns collection of data points of this series.
Explosion | The distance of an open pie slice from the center of the pie chart is expressed as a percentage of the pie diameter.
Format | Returns the format of a series. Read-only Format.
GapDepth | Returns or sets the distance, as a percentage of the marker width, between the data series in a 3D chart. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.GapDepth read/write property for change value.
GapWidth | Specifies the space between bar or column clusters, as a percentage of the bar or column width. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.GapWidth read/write property for change value.
HasSeriesLines | Determines whether there are series lines for this series and kindred series. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.HasSeriesLines read/write property for change value. Use ParentSeriesGroup.SeriesLinesFormat property for format series lines.
HasUpDownBars | Determines whether Line- or Stock-chart has a up/down bars. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.UpDownBars.HasUpDownBars read/write property for change value. Use ParentSeriesGroup.UpDownBars property for format up/down bars.
InvertIfNegative | Specifies the bar, column or bubble series shall invert its colors if the value is negative.
IsColorVaried | Specifies that each data marker in the series has a different color. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.IsColorVaried read/write property for change value.
Labels | Returns the Labels of a series. Read-only DataLabelCollection.
Marker |
MarkerFill | Obsolete. Gets or sets the marker fill
MarkerSize | Obsolete. Represents the marker size in a line chart, scatter chart, or radar chart.
MarkerSymbol | Obsolete. Represents the marker style in a line chart, scatter chart, or radar chart.
Name | Return series name.
NameCells | Obsolete. Returns collection of cells with series names. Read-only IChartCellCollection.
NumberFormatOfBubbleSizes |
NumberFormatOfValues |
NumberFormatOfXValues |
NumberFormatOfYValues |
Order | Returns the order of a series.
ParentSeriesGroup |
PlotOnSecondAxis | Indicates if this series is plotted on secondary axis.
Smooth | Represents curve smoothing. True if curve smoothing is turned on for the line chart or scatter chart. Applies only to line and scatter connected by lines charts.
TrendLines | Collection of series trend lines.
Type | Returns a type of this series.

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


ChartSeries Properties

The properties of the ChartSeries class are listed below. For a complete list of ChartSeries class members, see the ChartSeries Members topic.

Public Instance Properties

Bar3DShape | Specifies the shape of a series of a 3-D bar chart. Changing of value of this property can cause to automatically changing Type of series.
Chart | Returns the parent chart. Read-only IChart.
DataPoints | Returns collection of data points of this series.
Explosion | The distance of an open pie slice from the center of the pie chart is expressed as a percentage of the pie diameter.
Format | Returns the format of a series. Read-only Format.
GapDepth | Returns or sets the distance, as a percentage of the marker width, between the data series in a 3D chart. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.GapDepth read/write property for change value.
GapWidth | Specifies the space between bar or column clusters, as a percentage of the bar or column width. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.GapWidth read/write property for change value.
HasSeriesLines | Determines whether there are series lines for this series and kindred series. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.HasSeriesLines read/write property for change value. Use ParentSeriesGroup.SeriesLinesFormat property for format series lines.
HasUpDownBars | Determines whether Line- or Stock-chart has a up/down bars. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.UpDownBars.HasUpDownBars read/write property for change value. Use ParentSeriesGroup.UpDownBars property for format up/down bars.
InvertIfNegative | Specifies the bar, column or bubble series shall invert its colors if the value is negative.
IsColorVaried | Specifies that each data marker in the series has a different color. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.IsColorVaried read/write property for change value.
Labels | Returns the Labels of a series. Read-only DataLabelCollection.
Marker |
MarkerFill | Obsolete. Gets or sets the marker fill
MarkerSize | Obsolete. Represents the marker size in a line chart, scatter chart, or radar chart.
MarkerSymbol | Obsolete. Represents the marker style in a line chart, scatter chart, or radar chart.
Name | Return series name.
NameCells | Obsolete. Returns collection of cells with series names. Read-only IChartCellCollection.
NumberFormatOfBubbleSizes |
NumberFormatOfValues |
NumberFormatOfXValues |
NumberFormatOfYValues |
Order | Returns the order of a series.
ParentSeriesGroup |
PlotOnSecondAxis | Indicates if this series is plotted on secondary axis.
Smooth | Represents curve smoothing. True if curve smoothing is turned on for the line chart or scatter chart. Applies only to line and scatter connected by lines charts.
TrendLines | Collection of series trend lines.
Type | Returns a type of this series.

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


Bar3DShape Property

Aspose.Slides Documentation

ChartSeries.Bar3DShape Property

Specifies the shape of a series of a 3-D bar chart. Changing of value of this property can cause to automatically changing Type of series.

[Visual Basic]
NotOverridable Public Property Bar3DShape As ChartShapeType _
Implements IChartSeries.Bar3DShape
[C#]
public ChartShapeType Bar3DShape {get; set;}

Implements

IChartSeries.Bar3DShape

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


Chart Property

Aspose.Slides Documentation

ChartSeries.Chart Property

Returns the parent chart. Read-only IChart.

[Visual Basic]
NotOverridable Public ReadOnly Property Chart As IChart _
Implements IChartComponent.Chart
[C#]
public IChart Chart {get;}

Implements

IChartComponent.Chart

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


DataPoints Property

Aspose.Slides Documentation

ChartSeries.DataPoints Property

Returns collection of data points of this series.

[Visual Basic]
NotOverridable Public ReadOnly Property DataPoints As IChartDataPointCollection _
Implements IChartSeries.DataPoints
[C#]
public IChartDataPointCollection DataPoints {get;}

Implements

IChartSeries.DataPoints

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


Explosion Property

Aspose.Slides Documentation

ChartSeries.Explosion Property

The distance of an open pie slice from the center of the pie chart is expressed as a percentage of the pie diameter.

[Visual Basic]
NotOverridable Public Property Explosion As Integer _
Implements IChartSeries.Explosion
[C#]
public int Explosion {get; set;}

Implements

IChartSeries.Explosion

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

ChartSeries.Format Property

Returns the format of a series. Read-only Format.

[Visual Basic]
NotOverridable Public ReadOnly Property Format As IFormat _
Implements IChartSeries.Format
[C#]
public IFormat Format {get;}

Implements

IChartSeries.Format

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


GapDepth Property

Aspose.Slides Documentation

ChartSeries.GapDepth Property

Returns or sets the distance, as a percentage of the marker width, between the data series in a 3D chart. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.GapDepth read/write property for change value.

[Visual Basic]
NotOverridable Public ReadOnly Property GapDepth As Integer _
Implements IChartSeries.GapDepth
[C#]
public int GapDepth {get;}

Implements

IChartSeries.GapDepth

Remarks

This is the projection of the property ParentSeriesGroup.GapDepth.

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


GapWidth Property

Aspose.Slides Documentation

ChartSeries.GapWidth Property

Specifies the space between bar or column clusters, as a percentage of the bar or column width. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.GapWidth read/write property for change value.

[Visual Basic]
NotOverridable Public ReadOnly Property GapWidth As Integer _
Implements IChartSeries.GapWidth
[C#]
public int GapWidth {get;}

Implements

IChartSeries.GapWidth

Remarks

This is the projection of the property ParentSeriesGroup.GapWidth.

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


HasSeriesLines Property

Aspose.Slides Documentation

ChartSeries.HasSeriesLines Property

Determines whether there are series lines for this series and kindred series. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.HasSeriesLines read/write property for change value. Use ParentSeriesGroup.SeriesLinesFormat property for format series lines.

[Visual Basic]
NotOverridable Public ReadOnly Property HasSeriesLines As Boolean _
Implements IChartSeries.HasSeriesLines
[C#]
public bool HasSeriesLines {get;}

Implements

IChartSeries.HasSeriesLines

Remarks

This is the projection of the property ParentSeriesGroup.HasSeriesLines.

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


HasUpDownBars Property

Aspose.Slides Documentation

ChartSeries.HasUpDownBars Property

Determines whether Line- or Stock-chart has a up/down bars. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.UpDownBars.HasUpDownBars read/write property for change value. Use ParentSeriesGroup.UpDownBars property for format up/down bars.

[Visual Basic]
NotOverridable Public ReadOnly Property HasUpDownBars As Boolean _
Implements IChartSeries.HasUpDownBars
[C#]
public bool HasUpDownBars {get;}

Implements

IChartSeries.HasUpDownBars

Remarks

This is the projection of the property ParentSeriesGroup.UpDownBars.HasUpDownBars.

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


InvertIfNegative Property

Aspose.Slides Documentation

ChartSeries.InvertIfNegative Property

Specifies the bar, column or bubble series shall invert its colors if the value is negative.

[Visual Basic]
NotOverridable Public Property InvertIfNegative As Boolean _
Implements IChartSeries.InvertIfNegative
[C#]
public bool InvertIfNegative {get; set;}

Implements

IChartSeries.InvertIfNegative

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


IsColorVaried Property

Aspose.Slides Documentation

ChartSeries.IsColorVaried Property

Specifies that each data marker in the series has a different color. This is the property not only of this series but of all series of parent series group - this is projection of appropriate group property. And so this property is read-only. Use ParentSeriesGroup property for access to parent series group. Use ParentSeriesGroup.IsColorVaried read/write property for change value.

[Visual Basic]
NotOverridable Public ReadOnly Property IsColorVaried As Boolean _
Implements IChartSeries.IsColorVaried
[C#]
public bool IsColorVaried {get;}

Implements

IChartSeries.IsColorVaried

Remarks

This is the projection of the property ParentSeriesGroup.IsColorVaried.

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


Labels Property

Aspose.Slides Documentation

ChartSeries.Labels Property

Returns the Labels of a series. Read-only DataLabelCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Labels As IDataLabelCollection _
Implements IChartSeries.Labels
[C#]
public IDataLabelCollection Labels {get;}

Implements

IChartSeries.Labels

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


Marker Property

Aspose.Slides Documentation

ChartSeries.Marker Property

[Visual Basic]
NotOverridable Public ReadOnly Property Marker As IMarker _
Implements IChartSeries.Marker
[C#]
public IMarker Marker {get;}

Implements

IChartSeries.Marker

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


MarkerFill Property

Aspose.Slides Documentation

ChartSeries.MarkerFill Property

NOTE: This property is now obsolete.

Use Marker property instead. Property will be removed after 01.09.2013.

Gets or sets the marker fill

[Visual Basic]
Public ReadOnly Property MarkerFill As IFormat
[C#]
public IFormat MarkerFill {get;}

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


MarkerSize Property

Aspose.Slides Documentation

ChartSeries.MarkerSize Property

NOTE: This property is now obsolete.

Use Marker property instead. Property will be removed after 01.09.2013.

Represents the marker size in a line chart, scatter chart, or radar chart.

[Visual Basic]
Public Property MarkerSize As Integer
[C#]
public int MarkerSize {get; set;}

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


MarkerSymbol Property

Aspose.Slides Documentation

ChartSeries.MarkerSymbol Property

NOTE: This property is now obsolete.

Use Marker property instead. Property will be removed after 01.09.2013.

Represents the marker style in a line chart, scatter chart, or radar chart.

[Visual Basic]
Public Property MarkerSymbol As MarkerStyleType
[C#]
public MarkerStyleType MarkerSymbol {get; set;}

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


Name Property

Aspose.Slides Documentation

ChartSeries.Name Property

Return series name.

[Visual Basic]
NotOverridable Public ReadOnly Property Name As IStringChartValue _
Implements IChartSeries.Name
[C#]
public IStringChartValue Name {get;}

Implements

IChartSeries.Name

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


NameCells Property

Aspose.Slides Documentation

ChartSeries.NameCells Property

NOTE: This property is now obsolete.

Use Name property instead. Property will be removed after 01.09.2013.

Returns collection of cells with series names. Read-only IChartCellCollection.

[Visual Basic]
Public ReadOnly Property NameCells As IChartCellCollection
[C#]
public IChartCellCollection NameCells {get;}

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


NumberFormatOfBubbleSizes Property

Aspose.Slides Documentation

ChartSeries.NumberFormatOfBubbleSizes Property

[Visual Basic]
NotOverridable Public Property NumberFormatOfBubbleSizes As String _
Implements IChartSeries.NumberFormatOfBubbleSizes
[C#]
public string NumberFormatOfBubbleSizes {get; set;}

Implements

IChartSeries.NumberFormatOfBubbleSizes

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


NumberFormatOfValues Property

Aspose.Slides Documentation

ChartSeries.NumberFormatOfValues Property

[Visual Basic]
NotOverridable Public Property NumberFormatOfValues As String _
Implements IChartSeries.NumberFormatOfValues
[C#]
public string NumberFormatOfValues {get; set;}

Implements

IChartSeries.NumberFormatOfValues

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


NumberFormatOfXValues Property

Aspose.Slides Documentation

ChartSeries.NumberFormatOfXValues Property

[Visual Basic]
NotOverridable Public Property NumberFormatOfXValues As String _
Implements IChartSeries.NumberFormatOfXValues
[C#]
public string NumberFormatOfXValues {get; set;}

Implements

IChartSeries.NumberFormatOfXValues

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


NumberFormatOfYValues Property

Aspose.Slides Documentation

ChartSeries.NumberFormatOfYValues Property

[Visual Basic]
NotOverridable Public Property NumberFormatOfYValues As String _
Implements IChartSeries.NumberFormatOfYValues
[C#]
public string NumberFormatOfYValues {get; set;}

Implements

IChartSeries.NumberFormatOfYValues

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


Order Property

Aspose.Slides Documentation

ChartSeries.Order Property

Returns the order of a series.

[Visual Basic]
NotOverridable Public Property Order As Integer _
Implements IChartSeries.Order
[C#]
public int Order {get; set;}

Implements

IChartSeries.Order

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


ParentSeriesGroup Property

Aspose.Slides Documentation

ChartSeries.ParentSeriesGroup Property

[Visual Basic]
NotOverridable Public ReadOnly Property ParentSeriesGroup As IChartSeriesGroup _
Implements IChartSeries.ParentSeriesGroup
[C#]
public IChartSeriesGroup ParentSeriesGroup {get;}

Implements

IChartSeries.ParentSeriesGroup

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


PlotOnSecondAxis Property

Aspose.Slides Documentation

ChartSeries.PlotOnSecondAxis Property

Indicates if this series is plotted on secondary axis.

[Visual Basic]
NotOverridable Public Property PlotOnSecondAxis As Boolean _
Implements IChartSeries.PlotOnSecondAxis
[C#]
public bool PlotOnSecondAxis {get; set;}

Implements

IChartSeries.PlotOnSecondAxis

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


Smooth Property

Aspose.Slides Documentation

ChartSeries.Smooth Property

Represents curve smoothing. True if curve smoothing is turned on for the line chart or scatter chart. Applies only to line and scatter connected by lines charts.

[Visual Basic]
NotOverridable Public Property Smooth As Boolean _
Implements IChartSeries.Smooth
[C#]
public bool Smooth {get; set;}

Implements

IChartSeries.Smooth

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


TrendLines Property

Aspose.Slides Documentation

ChartSeries.TrendLines Property

Collection of series trend lines.

[Visual Basic]
NotOverridable Public ReadOnly Property TrendLines As ITrendlineCollection _
Implements IChartSeries.TrendLines
[C#]
public ITrendlineCollection TrendLines {get;}

Implements

IChartSeries.TrendLines

Remarks

TrendLines are available (not null) for data series in unstacked 2-D area, bar, column, line, stock, xy (scatter), and bubble charts. A trendline are not available for data series in any chart type that is stacked or 3-D. Trendlines are also not available for radar, pie, surface, or doughnut charts.

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


Type Property

Aspose.Slides Documentation

ChartSeries.Type Property

Returns a type of this series.

[Visual Basic]
NotOverridable Public Property Type As ChartType _
Implements IChartSeries.Type
[C#]
public ChartType Type {get; set;}

Implements

IChartSeries.Type

See Also

ChartSeries Class | Aspose.Slides.Charts Namespace


ChartSeriesCollection Class

Represents collection of ChartSeries

For a list of all members of this type, see ChartSeriesCollection Members.

System.Object
Aspose.Slides.Charts.ChartSeriesCollection

[Visual Basic]
Public Class ChartSeriesCollection
Implements IChartSeriesCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Charts.IChartSeries, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class ChartSeriesCollection : IChartSeriesCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartSeriesCollection Members | Aspose.Slides.Charts Namespace


ChartSeriesCollection Members

ChartSeriesCollection overview

Public Instance Properties

Count | Returns a number of objects in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

Add | Overloaded. Creates new chart series and adds it to the collection.
Clear | Removes all controls from the collection.
CopyTo | Copies the entire collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
IndexOf | Searches for the specified ChartSeries and returns the zero-based index of the first occurrence within the entire Collection
Insert | Creates new chart series and insertss it into the collection.
Remove | Removes the specified value.
RemoveAt | Removes an ActiveX control stored at specified position from the collection.

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


ChartSeriesCollection Properties

The properties of the ChartSeriesCollection class are listed below. For a complete list of ChartSeriesCollection class members, see the ChartSeriesCollection Members topic.

Public Instance Properties

Count | Returns a number of objects in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


Count Property

Aspose.Slides Documentation

ChartSeriesCollection.Count Property

Returns a number of objects in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


IsSynchronized Property

Aspose.Slides Documentation

ChartSeriesCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

ChartSeriesCollection.Item Property

Gets the element at the specified index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IChartSeriesCollection.Item
As IChartSeries _
Implements IChartSeriesCollection.Item
[C#]
public IChartSeries this[
int index
] {get;}

Implements

IChartSeriesCollection.Item

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is not a valid index in the IList.

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


SyncRoot Property

Aspose.Slides Documentation

ChartSeriesCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


ChartSeriesCollection Methods

The methods of the ChartSeriesCollection class are listed below. For a complete list of ChartSeriesCollection class members, see the ChartSeriesCollection Members topic.

Public Instance Methods

Add | Overloaded. Creates new chart series and adds it to the collection.
Clear | Removes all controls from the collection.
CopyTo | Copies the entire collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
IndexOf | Searches for the specified ChartSeries and returns the zero-based index of the first occurrence within the entire Collection
Insert | Creates new chart series and insertss it into the collection.
Remove | Removes the specified value.
RemoveAt | Removes an ActiveX control stored at specified position from the collection.

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


Add Method

Aspose.Slides Documentation

ChartSeriesCollection.Add Method

Creates new chart series and adds it to the collection.

Overload List

Creates new chart series and adds it to the collection.

public IChartSeries Add(ChartType);

Creates new chart series from ChartCellCollection and adds it to the collection.

public IChartSeries Add(IChartCellCollection,ChartType);

Creates new chart series from ChartDataCell and adds it to the collection.

public IChartSeries Add(IChartDataCell,ChartType);

Creates new chart series from value and adds it to the collection.

public IChartSeries Add(string,ChartType);

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


ChartSeriesCollection.Add Method (ChartType)

Creates new chart series and adds it to the collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal type As ChartType _
) As IChartSeries _
Implements IChartSeriesCollection.Add
[C#]
public IChartSeries Add(
ChartType type
);

Parameters

type
Type of series

Return Value

New chart series.

Implements

IChartSeriesCollection.Add

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace | ChartSeriesCollection.Add Overload List


ChartSeriesCollection.Add Method (IChartCellCollection, ChartType)

Creates new chart series from ChartCellCollection and adds it to the collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal cellsWithSeriesName As IChartCellCollection, _
ByVal type As ChartType _
) As IChartSeries _
Implements IChartSeriesCollection.Add
[C#]
public IChartSeries Add(
IChartCellCollection cellsWithSeriesName,
ChartType type
);

Parameters

cellsWithSeriesName
Cells which contain series name.
type
Type set type of series

Return Value

Added chart series or series that already is in collection.

Implements

IChartSeriesCollection.Add

Remarks

If chart series careted from same cell already in collection then method adds nothing and returns it's index.

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace | ChartSeriesCollection.Add Overload List


ChartSeriesCollection.Add Method (IChartDataCell, ChartType)

Creates new chart series from ChartDataCell and adds it to the collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal cellWithSeriesName As IChartDataCell, _
ByVal type As ChartType _
) As IChartSeries _
Implements IChartSeriesCollection.Add
[C#]
public IChartSeries Add(
IChartDataCell cellWithSeriesName,
ChartType type
);

Parameters

cellWithSeriesName
Cell which contain series name.
type
Type set type of series

Return Value

Added chart series or series that already is in collection.

Implements

IChartSeriesCollection.Add

Remarks

If chart series careted from same cell already in collection then method adds nothing and returns it's index.

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace | ChartSeriesCollection.Add Overload List


ChartSeriesCollection.Add Method (String, ChartType)

Creates new chart series from value and adds it to the collection.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal name As String, _
ByVal type As ChartType _
) As IChartSeries _
Implements IChartSeriesCollection.Add
[C#]
public IChartSeries Add(
string name,
ChartType type
);

Parameters

name
Series name.
type
Type set type of series

Return Value

Added chart series.

Implements

IChartSeriesCollection.Add

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace | ChartSeriesCollection.Add Overload List


ChartSeriesCollection.Clear Method

Removes all controls from the collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IChartSeriesCollection.Clear
[C#]
public void Clear();

Implements

IChartSeriesCollection.Clear

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


ChartSeriesCollection.CopyTo Method

Copies the entire collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array
index
Index in the target array.

Implements

ICollection.CopyTo

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


ChartSeriesCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


ChartSeriesCollection.IndexOf Method

Searches for the specified ChartSeries and returns the zero-based index of the first occurrence within the entire Collection

[Visual Basic]
NotOverridable Public Function IndexOf( _
ByVal value As IChartSeries _
) As Integer _
Implements IChartSeriesCollection.IndexOf
[C#]
public int IndexOf(
IChartSeries value
);

Parameters

value
Chart series value.

Return Value

The zero-based index of the first occurrence of value within the entire CollectionBase, if found; otherwise, -1.

Implements

IChartSeriesCollection.IndexOf

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


ChartSeriesCollection.Insert Method

Creates new chart series and insertss it into the collection.

[Visual Basic]
NotOverridable Public Function Insert( _
ByVal index As Integer, _
ByVal type As ChartType _
) As IChartSeries _
Implements IChartSeriesCollection.Insert
[C#]
public IChartSeries Insert(
int index,
ChartType type
);

Implements

IChartSeriesCollection.Insert

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


ChartSeriesCollection.Remove Method

Removes the specified value.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal value As IChartSeries _
) _
Implements IChartSeriesCollection.Remove
[C#]
public void Remove(
IChartSeries value
);

Parameters

value
The value.

Implements

IChartSeriesCollection.Remove

Exceptions

Exception Type | Condition
ArgumentException | The value parameter was not found in the collection.

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


ChartSeriesCollection.RemoveAt Method

Removes an ActiveX control stored at specified position from the collection.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IChartSeriesCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
Index of a control to remove.

Implements

IChartSeriesCollection.RemoveAt

See Also

ChartSeriesCollection Class | Aspose.Slides.Charts Namespace


ChartSeriesGroup Class

Represents group of series.

For a list of all members of this type, see ChartSeriesGroup Members.

System.Object
Aspose.Slides.Charts.ChartSeriesGroup

[Visual Basic]
Public Class ChartSeriesGroup
Implements IChartSeriesGroup
[C#]
public class ChartSeriesGroup : IChartSeriesGroup

Remarks

1) See summary and remarks for ChartSeriesGroupCollection class and CombinableSeriesTypesGroup enum. 2) Group of series contains some series properies whitch is common for each series in group ("series group properties"). "Series group properties" in ChartSeriesGroup class is read/write. Each of "series group properties" can have a read-only projection in ChartSeries class.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartSeriesGroup Members | Aspose.Slides.Charts Namespace


ChartSeriesGroup Members

ChartSeriesGroup overview

Public Instance Properties

FirstSliceAngle | Gets or sets the angle of the first pie or doughnut chart slice, in degrees (clockwise from up, from 0 to 360 degrees).
GapDepth | Returns or sets the distance, as a percentage of the marker width, between the data series in a 3D chart. Read/write Int32.
GapWidth | Specifies the space between bar or column clusters, as a percentage of the bar or column width.
HasSeriesLines | True if chart has series lines. Applied to stacked bar and OfPie charts.
IsColorVaried | Specifies that each data marker in the series has a different color.
Item | Gets the element at the specified index.
PlotOnSecondAxis | Indicates if series of this group is plotted on secondary axis.
Series |
Type | Returns a type of this series group.
UpDownBars | Provede access to up/down bars of Line- or Stock-chart.

See Also

ChartSeriesGroup Class | Aspose.Slides.Charts Namespace


ChartSeriesGroup Properties

The properties of the ChartSeriesGroup class are listed below. For a complete list of ChartSeriesGroup class members, see the ChartSeriesGroup Members topic.

Public Instance Properties

FirstSliceAngle | Gets or sets the angle of the first pie or doughnut chart slice, in degrees (clockwise from up, from 0 to 360 degrees).
GapDepth | Returns or sets the distance, as a percentage of the marker width, between the data series in a 3D chart. Read/write Int32.
GapWidth | Specifies the space between bar or column clusters, as a percentage of the bar or column width.
HasSeriesLines | True if chart has series lines. Applied to stacked bar and OfPie charts.
IsColorVaried | Specifies that each data marker in the series has a different color.
Item | Gets the element at the specified index.
PlotOnSecondAxis | Indicates if series of this group is plotted on secondary axis.
Series |
Type | Returns a type of this series group.
UpDownBars | Provede access to up/down bars of Line- or Stock-chart.

See Also

ChartSeriesGroup Class | Aspose.Slides.Charts Namespace


FirstSliceAngle Property

Aspose.Slides Documentation

ChartSeriesGroup.FirstSliceAngle Property

Gets or sets the angle of the first pie or doughnut chart slice, in degrees (clockwise from up, from 0 to 360 degrees).

[Visual Basic]
NotOverridable Public Property FirstSliceAngle As UInt16 _
Implements IChartSeriesGroup.FirstSliceAngle
[C#]
public ushort FirstSliceAngle {get; set;}

Implements

IChartSeriesGroup.FirstSliceAngle

See Also

ChartSeriesGroup Class | Aspose.Slides.Charts Namespace


GapDepth Property

Aspose.Slides Documentation

ChartSeriesGroup.GapDepth Property

Returns or sets the distance, as a percentage of the marker width, between the data series in a 3D chart. Read/write Int32.

[Visual Basic]
NotOverridable Public Property GapDepth As UInt16 _
Implements IChartSeriesGroup.GapDepth
[C#]
public ushort GapDepth {get; set;}

Implements

IChartSeriesGroup.GapDepth

See Also

ChartSeriesGroup Class | Aspose.Slides.Charts Namespace


GapWidth Property

Aspose.Slides Documentation

ChartSeriesGroup.GapWidth Property

Specifies the space between bar or column clusters, as a percentage of the bar or column width.

[Visual Basic]
NotOverridable Public Property GapWidth As UInt16 _
Implements IChartSeriesGroup.GapWidth
[C#]
public ushort GapWidth {get; set;}

Implements

IChartSeriesGroup.GapWidth

See Also

ChartSeriesGroup Class | Aspose.Slides.Charts Namespace


HasSeriesLines Property

Aspose.Slides Documentation

ChartSeriesGroup.HasSeriesLines Property

True if chart has series lines. Applied to stacked bar and OfPie charts.

[Visual Basic]
NotOverridable Public Property HasSeriesLines As Boolean _
Implements IChartSeriesGroup.HasSeriesLines
[C#]
public bool HasSeriesLines {get; set;}

Implements

IChartSeriesGroup.HasSeriesLines

See Also

ChartSeriesGroup Class | Aspose.Slides.Charts Namespace


IsColorVaried Property

Aspose.Slides Documentation

ChartSeriesGroup.IsColorVaried Property

Specifies that each data marker in the series has a different color.

[Visual Basic]
NotOverridable Public Property IsColorVaried As Boolean _
Implements IChartSeriesGroup.IsColorVaried
[C#]
public bool IsColorVaried {get; set;}

Implements

IChartSeriesGroup.IsColorVaried

See Also

ChartSeriesGroup Class | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

ChartSeriesGroup.Item Property

Gets the element at the specified index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IChartSeriesGroup.Item
As IChartSeries _
Implements IChartSeriesGroup.Item
[C#]
public IChartSeries this[
int index
] {get;}

Implements

IChartSeriesGroup.Item

See Also

ChartSeriesGroup Class | Aspose.Slides.Charts Namespace


PlotOnSecondAxis Property

Aspose.Slides Documentation

ChartSeriesGroup.PlotOnSecondAxis Property

Indicates if series of this group is plotted on secondary axis.

[Visual Basic]
NotOverridable Public ReadOnly Property PlotOnSecondAxis As Boolean _
Implements IChartSeriesGroup.PlotOnSecondAxis
[C#]
public bool PlotOnSecondAxis {get;}

Implements

IChartSeriesGroup.PlotOnSecondAxis

See Also

ChartSeriesGroup Class | Aspose.Slides.Charts Namespace


Series Property

Aspose.Slides Documentation

ChartSeriesGroup.Series Property

[Visual Basic]
NotOverridable Public ReadOnly Property Series As IChartSeriesReadonlyCollection _
Implements IChartSeriesGroup.Series
[C#]
public IChartSeriesReadonlyCollection Series {get;}

Implements

IChartSeriesGroup.Series

See Also

ChartSeriesGroup Class | Aspose.Slides.Charts Namespace


Type Property

Aspose.Slides Documentation

ChartSeriesGroup.Type Property

Returns a type of this series group.

[Visual Basic]
NotOverridable Public ReadOnly Property Type As CombinableSeriesTypesGroup _
Implements IChartSeriesGroup.Type
[C#]
public CombinableSeriesTypesGroup Type {get;}

Implements

IChartSeriesGroup.Type

See Also

ChartSeriesGroup Class | Aspose.Slides.Charts Namespace


UpDownBars Property

Aspose.Slides Documentation

ChartSeriesGroup.UpDownBars Property

Provede access to up/down bars of Line- or Stock-chart.

[Visual Basic]
NotOverridable Public ReadOnly Property UpDownBars As IUpDownBarsManager _
Implements IChartSeriesGroup.UpDownBars
[C#]
public IUpDownBarsManager UpDownBars {get;}

Implements

IChartSeriesGroup.UpDownBars

See Also

ChartSeriesGroup Class | Aspose.Slides.Charts Namespace


ChartShapeType Enumeration

[Visual Basic]
Public Enum ChartShapeType
[C#]
public enum ChartShapeType

Members

Member Name | Description | Value
NotDefined |  | -1
Box |  | 0
Cone |  | 1
ConeToMax |  | 2
Cylinder |  | 3
Pyramid |  | 4
PyramidToMaximum |  | 5

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


ChartTextFormat Class

Specifies default text formatting for chart text elements.

For a list of all members of this type, see ChartTextFormat Members.

System.Object
Aspose.Slides.Charts.ChartTextFormat

[Visual Basic]
Public Class ChartTextFormat
Implements IChartTextFormat
[C#]
public class ChartTextFormat : IChartTextFormat

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartTextFormat Members | Aspose.Slides.Charts Namespace


ChartTextFormat Members

ChartTextFormat overview

Public Instance Properties

ParagraphFormat
PortionFormat
TextBlockFormat

Public Instance Methods

CopyFrom
CopyTo

See Also

ChartTextFormat Class | Aspose.Slides.Charts Namespace


ChartTextFormat Properties

The properties of the ChartTextFormat class are listed below. For a complete list of ChartTextFormat class members, see the ChartTextFormat Members topic.

Public Instance Properties

ParagraphFormat
PortionFormat
TextBlockFormat

See Also

ChartTextFormat Class | Aspose.Slides.Charts Namespace


ParagraphFormat Property

Aspose.Slides Documentation

ChartTextFormat.ParagraphFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property ParagraphFormat As IChartParagraphFormat _
Implements IChartTextFormat.ParagraphFormat
[C#]
public IChartParagraphFormat ParagraphFormat {get;}

Implements

IChartTextFormat.ParagraphFormat

See Also

ChartTextFormat Class | Aspose.Slides.Charts Namespace


PortionFormat Property

Aspose.Slides Documentation

ChartTextFormat.PortionFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property PortionFormat As IChartPortionFormat _
Implements IChartTextFormat.PortionFormat
[C#]
public IChartPortionFormat PortionFormat {get;}

Implements

IChartTextFormat.PortionFormat

See Also

ChartTextFormat Class | Aspose.Slides.Charts Namespace


TextBlockFormat Property

Aspose.Slides Documentation

ChartTextFormat.TextBlockFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property TextBlockFormat As IChartTextBlockFormat _
Implements IChartTextFormat.TextBlockFormat
[C#]
public IChartTextBlockFormat TextBlockFormat {get;}

Implements

IChartTextFormat.TextBlockFormat

See Also

ChartTextFormat Class | Aspose.Slides.Charts Namespace


ChartTextFormat Methods

The methods of the ChartTextFormat class are listed below. For a complete list of ChartTextFormat class members, see the ChartTextFormat Members topic.

Public Instance Methods

CopyFrom
CopyTo

See Also

ChartTextFormat Class | Aspose.Slides.Charts Namespace


ChartTextFormat.CopyFrom Method

[Visual Basic]
NotOverridable Public Sub CopyFrom( _
ByVal sourceTextFrame As ITextFrame _
) _
Implements IChartTextFormat.CopyFrom
[C#]
public void CopyFrom(
ITextFrame sourceTextFrame
);

Implements

IChartTextFormat.CopyFrom

See Also

ChartTextFormat Class | Aspose.Slides.Charts Namespace


ChartTextFormat.CopyTo Method

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal destTextFrame As ITextFrame _
) _
Implements IChartTextFormat.CopyTo
[C#]
public void CopyTo(
ITextFrame destTextFrame
);

Implements

IChartTextFormat.CopyTo

See Also

ChartTextFormat Class | Aspose.Slides.Charts Namespace


ChartTitle Class

Represents chart title properties.

For a list of all members of this type, see ChartTitle Members.

System.Object
Aspose.Slides.Charts.ChartTitle

[Visual Basic]
Public Class ChartTitle
Implements IChartTitle, ILayoutable, IChartComponent, IOverridableText, IFormattedTextContainer
[C#]
public class ChartTitle : IChartTitle, ILayoutable, IChartComponent, IOverridableText, IFormattedTextContainer

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartTitle Members | Aspose.Slides.Charts Namespace


ChartTitle Members

ChartTitle overview

Public Instance Properties

Bottom |
Chart | Returns the parent chart. Read-only IChart.
Format | Returns the fill, line, effect styles of a title.
Height | Returns or sets the height of a title as a fraction of the height of the chart. Read/write Single.
Overlay | Determines whether other chart elements shall be allowed to overlap title. Read/write Boolean.
Right |
Text | Obsolete. Returns text frame of a chart title.
TextFormat |
TextFrameForOverriding | Can contain a rich formatted text. If this property is not null then this formatted text value overrides auto-generated text. Auto-generated text is an implicit property of the data label, the display unit label of the value axis, the axis title, the chart title, the label of the trendline. Auto-generated text is formatted with the IFormattedTextContainer.TextFormat property.
Width | Returns or sets the width of a title as a fraction of the width of the chart. Read/write Single.
X | Returns or sets the x coordinate of a title as a fraction of the width of the chart. Read/write Single.
Y | Returns or sets the y coordinate of a title as a fraction of the height of the chart. Read/write Single.

Public Instance Methods

AddTextFrameForOverriding Initialize TextFrameForOverriding with the text in paramener "text". If TextFrameForOverriding is already initialized then simply changes its text.

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


ChartTitle Properties

The properties of the ChartTitle class are listed below. For a complete list of ChartTitle class members, see the ChartTitle Members topic.

Public Instance Properties

Bottom |
Chart | Returns the parent chart. Read-only IChart.
Format | Returns the fill, line, effect styles of a title.
Height | Returns or sets the height of a title as a fraction of the height of the chart. Read/write Single.
Overlay | Determines whether other chart elements shall be allowed to overlap title. Read/write Boolean.
Right |
Text | Obsolete. Returns text frame of a chart title.
TextFormat |
TextFrameForOverriding | Can contain a rich formatted text. If this property is not null then this formatted text value overrides auto-generated text. Auto-generated text is an implicit property of the data label, the display unit label of the value axis, the axis title, the chart title, the label of the trendline. Auto-generated text is formatted with the IFormattedTextContainer.TextFormat property.
Width | Returns or sets the width of a title as a fraction of the width of the chart. Read/write Single.
X | Returns or sets the x coordinate of a title as a fraction of the width of the chart. Read/write Single.
Y | Returns or sets the y coordinate of a title as a fraction of the height of the chart. Read/write Single.

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


Bottom Property

Aspose.Slides Documentation

ChartTitle.Bottom Property

[Visual Basic]
NotOverridable Public ReadOnly Property Bottom As Single _
Implements ILayoutable.Bottom
[C#]
public float Bottom {get;}

Implements

ILayoutable.Bottom

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


Chart Property

Aspose.Slides Documentation

ChartTitle.Chart Property

Returns the parent chart. Read-only IChart.

[Visual Basic]
NotOverridable Public ReadOnly Property Chart As IChart _
Implements IChartComponent.Chart
[C#]
public IChart Chart {get;}

Implements

IChartComponent.Chart

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

ChartTitle.Format Property

Returns the fill, line, effect styles of a title.

[Visual Basic]
NotOverridable Public ReadOnly Property Format As IFormat _
Implements IChartTitle.Format
[C#]
public IFormat Format {get;}

Implements

IChartTitle.Format

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


Height Property

Aspose.Slides Documentation

ChartTitle.Height Property

Returns or sets the height of a title as a fraction of the height of the chart. Read/write Single.

[Visual Basic]
NotOverridable Public Property Height As Single _
Implements ILayoutable.Height
[C#]
public float Height {get; set;}

Implements

ILayoutable.Height

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


Overlay Property

Aspose.Slides Documentation

ChartTitle.Overlay Property

Determines whether other chart elements shall be allowed to overlap title. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property Overlay As Boolean _
Implements IChartTitle.Overlay
[C#]
public bool Overlay {get; set;}

Implements

IChartTitle.Overlay

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


Right Property

Aspose.Slides Documentation

ChartTitle.Right Property

[Visual Basic]
NotOverridable Public ReadOnly Property Right As Single _
Implements ILayoutable.Right
[C#]
public float Right {get;}

Implements

ILayoutable.Right

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


Text Property

Aspose.Slides Documentation

ChartTitle.Text Property

NOTE: This property is now obsolete.

Use TextFrameForOverriding property instead. Property will be removed after 01.07.2013.

Returns text frame of a chart title.

[Visual Basic]
Public ReadOnly Property Text As TextFrame
[C#]
public TextFrame Text {get;}

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


TextFormat Property

Aspose.Slides Documentation

ChartTitle.TextFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property TextFormat As IChartTextFormat _
Implements IFormattedTextContainer.TextFormat
[C#]
public IChartTextFormat TextFormat {get;}

Implements

IFormattedTextContainer.TextFormat

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


TextFrameForOverriding Property

Aspose.Slides Documentation

ChartTitle.TextFrameForOverriding Property

Can contain a rich formatted text. If this property is not null then this formatted text value overrides auto-generated text. Auto-generated text is an implicit property of the data label, the display unit label of the value axis, the axis title, the chart title, the label of the trendline. Auto-generated text is formatted with the IFormattedTextContainer.TextFormat property.

[Visual Basic]
NotOverridable Public ReadOnly Property TextFrameForOverriding As ITextFrame _
Implements IOverridableText.TextFrameForOverriding
[C#]
public ITextFrame TextFrameForOverriding {get;}

Implements

IOverridableText.TextFrameForOverriding

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


Width Property

Aspose.Slides Documentation

ChartTitle.Width Property

Returns or sets the width of a title as a fraction of the width of the chart. Read/write Single.

[Visual Basic]
NotOverridable Public Property Width As Single _
Implements ILayoutable.Width
[C#]
public float Width {get; set;}

Implements

ILayoutable.Width

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


X Property

Aspose.Slides Documentation

ChartTitle.X Property

Returns or sets the x coordinate of a title as a fraction of the width of the chart. Read/write Single.

[Visual Basic]
NotOverridable Public Property X As Single _
Implements ILayoutable.X
[C#]
public float X {get; set;}

Implements

ILayoutable.X

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


Y Property

Aspose.Slides Documentation

ChartTitle.Y Property

Returns or sets the y coordinate of a title as a fraction of the height of the chart. Read/write Single.

[Visual Basic]
NotOverridable Public Property Y As Single _
Implements ILayoutable.Y
[C#]
public float Y {get; set;}

Implements

ILayoutable.Y

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


ChartTitle Methods

The methods of the ChartTitle class are listed below. For a complete list of ChartTitle class members, see the ChartTitle Members topic.

Public Instance Methods

AddTextFrameForOverriding Initialize TextFrameForOverriding with the text in paramener "text". If TextFrameForOverriding is already initialized then simply changes its text.

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


ChartTitle.AddTextFrameForOverriding Method

Initialize TextFrameForOverriding with the text in paramener "text". If TextFrameForOverriding is already initialized then simply changes its text.

[Visual Basic]
NotOverridable Public Function AddTextFrameForOverriding( _
ByVal text As String _
) As ITextFrame _
Implements IOverridableText.AddTextFrameForOverriding
[C#]
public ITextFrame AddTextFrameForOverriding(
string text
);

Parameters

text
Text for a new TextFrameForOverriding.

Implements

IOverridableText.AddTextFrameForOverriding

See Also

ChartTitle Class | Aspose.Slides.Charts Namespace


ChartType Enumeration

[Visual Basic]
Public Enum ChartType
[C#]
public enum ChartType

Members

Member Name | Description | Value
ClusteredColumn |  | 0
StackedColumn |  | 1
PercentsStackedColumn |  | 2
ClusteredColumn3D |  | 3
StackedColumn3D |  | 4
PercentsStackedColumn3D |  | 5
Column3D |  | 6
ClusteredCylinder |  | 7
StackedCylinder |  | 8
PercentsStackedCylinder |  | 9
Cylinder3D |  | 10
ClusteredCone |  | 11
StackedCone |  | 12
PercentsStackedCone |  | 13
Cone3D |  | 14
ClusteredPyramid |  | 15
StackedPyramid |  | 16
PercentsStackedPyramid |  | 17
Pyramid3D |  | 18
Line |  | 19
StackedLine |  | 20
PercentsStackedLine |  | 21
LineWithMarkers |  | 22
StackedLineWithMarkers |  | 23
PercentsStackedLineWithMarkers |  | 24
Line3D |  | 25
Pie |  | 26
Pie3D |  | 27
PieOfPie |  | 28
ExplodedPie |  | 29
ExplodedPie3D |  | 30
BarOfPie |  | 31
PercentsStackedBar |  | 32
ClusteredBar3D |  | 33
ClusteredBar |  | 34
StackedBar |  | 35
StackedBar3D |  | 36
PercentsStackedBar3D |  | 37
ClusteredHorizontalCylinder |  | 38
StackedHorizontalCylinder |  | 39
PercentsStackedHorizontalCylinder |  | 40
ClusteredHorizontalCone |  | 41
StackedHorizontalCone |  | 42
PercentsStackedHorizontalCone |  | 43
ClusteredHorizontalPyramid |  | 44
StackedHorizontalPyramid |  | 45
PercentsStackedHorizontalPyramid |  | 46
Area |  | 47
StackedArea |  | 48
PercentsStackedArea |  | 49
Area3D |  | 50
StackedArea3D |  | 51
PercentsStackedArea3D |  | 52
ScatterWithMarkers |  | 53
ScatterWithSmoothLinesAndMarkers |  | 54
ScatterWithSmoothLines |  | 55
ScatterWithStraightLinesAndMarkers |  | 56
ScatterWithStraightLines |  | 57
HighLowClose |  | 58
OpenHighLowClose |  | 59
VolumeHighLowClose |  | 60
VolumeOpenHighLowClose |  | 61
Surface3D |  | 62
WireframeSurface3D |  | 63
Contour |  | 64
WireframeContour |  | 65
Doughnut |  | 66
ExplodedDoughnut |  | 67
Bubble |  | 68
BubbleWith3D |  | 69
Radar |  | 70
RadarWithMarkers |  | 71
FilledRadar |  | 72
SeriesOfMixedTypes |  | 73

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


ChartTypeCharacterizer Class

For a list of all members of this type, see ChartTypeCharacterizer Members.

System.Object
Aspose.Slides.Charts.ChartTypeCharacterizer

[Visual Basic]
Public Class ChartTypeCharacterizer
[C#]
public class ChartTypeCharacterizer

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartTypeCharacterizer Members | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer Members

ChartTypeCharacterizer overview

Public Static (Shared) Methods

HasSeriesTrendLines |
Is2DChart | Return true if chartType is one of 2D chart types.
Is3DChart | Return true if chartType is one of 3D chart types.
IsBar3DChart | Return true if chartType is one of bar3DChart subtypes (3D columns or bars).
IsChartTypeArea | Return true if chartType is one of Area subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeBar | Return true if chartType is one of Bar subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeBubble | Return true if chartType is one of Bubble subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeColumn | Return true if chartType is one of Column subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeDoughnut | Return true if chartType is one of Doughnut subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeLine | Return true if chartType is one of Line subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypePie | Return true if chartType is one of Pie subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeRadar | Return true if chartType is one of Radar subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeScatter | Return true if chartType is one of Scatter subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeStock | Return true if chartType is one of Stock subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeSurface | Return true if chartType is one of Surface subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsSeriesUsesBubbleSizeCoordinate |
IsSeriesUsesValueCoordinate |
IsSeriesUsesXValueCoordinate |
IsSeriesUsesYValueCoordinate |

Public Instance Constructors

ChartTypeCharacterizer Constructor Initializes a new instance of the ChartTypeCharacterizer class.

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer Constructor

Initializes a new instance of the ChartTypeCharacterizer class.

[Visual Basic]
Public Sub New()
[C#]
public ChartTypeCharacterizer();

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer Methods

The methods of the ChartTypeCharacterizer class are listed below. For a complete list of ChartTypeCharacterizer class members, see the ChartTypeCharacterizer Members topic.

Public Static (Shared) Methods

HasSeriesTrendLines |
Is2DChart | Return true if chartType is one of 2D chart types.
Is3DChart | Return true if chartType is one of 3D chart types.
IsBar3DChart | Return true if chartType is one of bar3DChart subtypes (3D columns or bars).
IsChartTypeArea | Return true if chartType is one of Area subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeBar | Return true if chartType is one of Bar subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeBubble | Return true if chartType is one of Bubble subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeColumn | Return true if chartType is one of Column subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeDoughnut | Return true if chartType is one of Doughnut subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeLine | Return true if chartType is one of Line subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypePie | Return true if chartType is one of Pie subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeRadar | Return true if chartType is one of Radar subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeScatter | Return true if chartType is one of Scatter subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeStock | Return true if chartType is one of Stock subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsChartTypeSurface | Return true if chartType is one of Surface subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).
IsSeriesUsesBubbleSizeCoordinate |
IsSeriesUsesValueCoordinate |
IsSeriesUsesXValueCoordinate |
IsSeriesUsesYValueCoordinate |

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.HasSeriesTrendLines Method

[Visual Basic]
Public Shared Function HasSeriesTrendLines( _
ByVal seriesType As ChartType _
) As Boolean
[C#]
public static bool HasSeriesTrendLines(
ChartType seriesType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.Is2DChart Method

Return true if chartType is one of 2D chart types.

[Visual Basic]
Public Shared Function Is2DChart( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool Is2DChart(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.Is3DChart Method

Return true if chartType is one of 3D chart types.

[Visual Basic]
Public Shared Function Is3DChart( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool Is3DChart(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsBar3DChart Method

Return true if chartType is one of bar3DChart subtypes (3D columns or bars).

[Visual Basic]
Public Shared Function IsBar3DChart( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool IsBar3DChart(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsChartTypeArea Method

Return true if chartType is one of Area subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).

[Visual Basic]
Public Shared Function IsChartTypeArea( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool IsChartTypeArea(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsChartTypeBar Method

Return true if chartType is one of Bar subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).

[Visual Basic]
Public Shared Function IsChartTypeBar( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool IsChartTypeBar(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsChartTypeBubble Method

Return true if chartType is one of Bubble subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).

[Visual Basic]
Public Shared Function IsChartTypeBubble( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool IsChartTypeBubble(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsChartTypeColumn Method

Return true if chartType is one of Column subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).

[Visual Basic]
Public Shared Function IsChartTypeColumn( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool IsChartTypeColumn(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsChartTypeDoughnut Method

Return true if chartType is one of Doughnut subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).

[Visual Basic]
Public Shared Function IsChartTypeDoughnut( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool IsChartTypeDoughnut(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsChartTypeLine Method

Return true if chartType is one of Line subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).

[Visual Basic]
Public Shared Function IsChartTypeLine( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool IsChartTypeLine(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsChartTypePie Method

Return true if chartType is one of Pie subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).

[Visual Basic]
Public Shared Function IsChartTypePie( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool IsChartTypePie(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsChartTypeRadar Method

Return true if chartType is one of Radar subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).

[Visual Basic]
Public Shared Function IsChartTypeRadar( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool IsChartTypeRadar(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsChartTypeScatter Method

Return true if chartType is one of Scatter subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).

[Visual Basic]
Public Shared Function IsChartTypeScatter( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool IsChartTypeScatter(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsChartTypeStock Method

Return true if chartType is one of Stock subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).

[Visual Basic]
Public Shared Function IsChartTypeStock( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool IsChartTypeStock(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsChartTypeSurface Method

Return true if chartType is one of Surface subtypes. Subtypes set corresponds to the appropriate set in PowerPoint (see "Change Chart Type" dialog in PowerPoint).

[Visual Basic]
Public Shared Function IsChartTypeSurface( _
ByVal chartType As ChartType _
) As Boolean
[C#]
public static bool IsChartTypeSurface(
ChartType chartType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsSeriesUsesBubbleSizeCoordinate Method

[Visual Basic]
Public Shared Function IsSeriesUsesBubbleSizeCoordinate( _
ByVal seriesType As ChartType _
) As Boolean
[C#]
public static bool IsSeriesUsesBubbleSizeCoordinate(
ChartType seriesType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsSeriesUsesValueCoordinate Method

[Visual Basic]
Public Shared Function IsSeriesUsesValueCoordinate( _
ByVal seriesType As ChartType _
) As Boolean
[C#]
public static bool IsSeriesUsesValueCoordinate(
ChartType seriesType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsSeriesUsesXValueCoordinate Method

[Visual Basic]
Public Shared Function IsSeriesUsesXValueCoordinate( _
ByVal seriesType As ChartType _
) As Boolean
[C#]
public static bool IsSeriesUsesXValueCoordinate(
ChartType seriesType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartTypeCharacterizer.IsSeriesUsesYValueCoordinate Method

[Visual Basic]
Public Shared Function IsSeriesUsesYValueCoordinate( _
ByVal seriesType As ChartType _
) As Boolean
[C#]
public static bool IsSeriesUsesYValueCoordinate(
ChartType seriesType
);

See Also

ChartTypeCharacterizer Class | Aspose.Slides.Charts Namespace


ChartWall Class

Represents walls on 3d charts.

For a list of all members of this type, see ChartWall Members.

System.Object
Aspose.Slides.Charts.ChartWall

[Visual Basic]
Public Class ChartWall
Implements IChartWall
[C#]
public class ChartWall : IChartWall

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartWall Members | Aspose.Slides.Charts Namespace


ChartWall Members

ChartWall overview

Public Instance Properties

Format | Returns the wall fill, line, effect, 3d styles.
PictureType | Return or sets the picture type.
Thickness | Returns or sets the walls thickness as a percentage of the largest dimension of the plot volume.

See Also

ChartWall Class | Aspose.Slides.Charts Namespace


ChartWall Properties

The properties of the ChartWall class are listed below. For a complete list of ChartWall class members, see the ChartWall Members topic.

Public Instance Properties

Format | Returns the wall fill, line, effect, 3d styles.
PictureType | Return or sets the picture type.
Thickness | Returns or sets the walls thickness as a percentage of the largest dimension of the plot volume.

See Also

ChartWall Class | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

ChartWall.Format Property

Returns the wall fill, line, effect, 3d styles.

[Visual Basic]
NotOverridable Public ReadOnly Property Format As IFormat _
Implements IChartWall.Format
[C#]
public IFormat Format {get;}

Implements

IChartWall.Format

See Also

ChartWall Class | Aspose.Slides.Charts Namespace


PictureType Property

Aspose.Slides Documentation

ChartWall.PictureType Property

Return or sets the picture type.

[Visual Basic]
NotOverridable Public Property PictureType As PictureType _
Implements IChartWall.PictureType
[C#]
public PictureType PictureType {get; set;}

Implements

IChartWall.PictureType

See Also

ChartWall Class | Aspose.Slides.Charts Namespace


Thickness Property

Aspose.Slides Documentation

ChartWall.Thickness Property

Returns or sets the walls thickness as a percentage of the largest dimension of the plot volume.

[Visual Basic]
NotOverridable Public Property Thickness As Integer _
Implements IChartWall.Thickness
[C#]
public int Thickness {get; set;}

Implements

IChartWall.Thickness

See Also

ChartWall Class | Aspose.Slides.Charts Namespace


CombinableSeriesTypesGroup Enumeration

[Visual Basic]
Public Enum CombinableSeriesTypesGroup
[C#]
public enum CombinableSeriesTypesGroup

Members

Member Name | Description | Value
AreaChart_Area |  | 0
AreaChart_PercentsStackedArea |  | 1
AreaChart_StackedArea |  | 2
AreaChart_Area3D |  | 3
AreaChart_StackedArea3D |  | 4
AreaChart_PercentsStackedArea3D |  | 5
LineChart_Line |  | 6
LineChart_StackedLine |  | 7
LineChart_PercentsStackedLine |  | 8
Line3DChart |  | 9
StockHighLowClose |  | 10
StockOpenHighLowClose |  | 11
StockVolumeHighLowClose |  | 12
StockVolumeOpenHighLowClose |  | 13
RadarChart |  | 14
FilledRadarChart |  | 15
ScatterStraightMarker |  | 16
ScatterSmoothMarker |  | 17
PieChart |  | 18
Pie3DChart |  | 19
DoughnutChart |  | 20
BarChart_VertClustered |  | 21
BarChart_VertStacked |  | 22
BarChart_VertPercentsStacked |  | 23
BarChart_HorizClustered |  | 24
BarChart_HorizStacked |  | 25
BarChart_HorizPercentsStacked |  | 26
Bar3DChart_Vert |  | 27
Bar3DChart_VertClustered |  | 28
Bar3DChart_VertPercentsStackedColumn3D |  | 29
Bar3DChart_VertPercentsStackedCone |  | 30
Bar3DChart_VertPercentsStackedCylinder |  | 31
Bar3DChart_VertPercentsStackedPyramid |  | 32
Bar3DChart_VertStackedColumn3D |  | 33
Bar3DChart_VertStackedCone |  | 34
Bar3DChart_VertStackedCylinder |  | 35
Bar3DChart_VertStackedPyramid |  | 36
Bar3DChart_HorizClustered |  | 37
Bar3DChart_HorizStackedBar3D |  | 38
Bar3DChart_HorizStackedCone |  | 39
Bar3DChart_HorizStackedCylinder |  | 40
Bar3DChart_HorizStackedPyramid |  | 41
Bar3DChart_HorizPercentsStackedBar3D |  | 42
Bar3DChart_HorizPercentsStackedCone |  | 43
Bar3DChart_HorizPercentsStackedCylinder |  | 44
Bar3DChart_HorizPercentsStackedPyramid |  | 45
BarOfPieChart |  | 46
PieOfPieChart |  | 47
SurfaceChart_Contour |  | 48
SurfaceChart_WireframeContour |  | 49
SurfaceChart_Surface3D |  | 50
SurfaceChart_WireframeSurface3D |  | 51
BubbleChart |  | 52

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


CrossesType Enumeration

[Visual Basic]
Public Enum CrossesType
[C#]
public enum CrossesType

Members

Member Name | Description | Value
AxisCrossesAtZero |  | 0
Maximum |  | 1
Custom |  | 2

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


DataLabel Class

Represents a series labels.

For a list of all members of this type, see DataLabel Members.

System.Object
Aspose.Slides.Charts.DataLabel

[Visual Basic]
Public Class DataLabel
Implements IDataLabel, ILayoutable, IChartComponent, IOverridableText, IFormattedTextContainer
[C#]
public class DataLabel : IDataLabel, ILayoutable, IChartComponent, IOverridableText, IFormattedTextContainer

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

DataLabel Members | Aspose.Slides.Charts Namespace


DataLabel Members

DataLabel overview

Public Instance Constructors

DataLabel Constructor Creates a new instance of DataLabel class.

Public Instance Properties

Bottom |
Chart | Returns the parent chart. Read-only IChart.
DataLabelFormat |
Height | Returns or sets the height of a title as a fraction of the height of the chart. Read/write Single.
IsVisible | False means that data label is not visible (and so all Show*-flags (ShowValue, ...) are false).
LinkedSource | Obsolete. Gets and sets a reference to the worksheet
Right |
TextFormat |
TextFrame | Obsolete. Returns a textframe of this data label.
TextFrameForOverriding | Can contain a rich formatted text. If this property is not null then this formatted text value overrides auto-generated text of data label. Auto-generated text of data label means text that is managed by ShowSeriesName, ShowValue, ... properties and is formatted with the TextFormatManager.TextFormat property.
Width | Returns or sets the width of a title as a fraction of the width of the chart. Read/write Single.
X | Returns or sets the x coordinate of a title as a fraction of the width of the chart. Read/write Single.
Y | Returns or sets the y coordinate of a title as a fraction of the height of the chart. Read/write Single.

Public Instance Methods

AddTextFrameForOverriding | Initialize TextFrameForOverriding with the text in paramener "text". If TextFrameForOverriding is already initialized then simply changes its text.
Hide | Make data label hidden by setting all Show*-flags (ShowValue, ...) to false state. IsVisible will be false after this.

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


DataLabel Constructor

Creates a new instance of DataLabel class.

[Visual Basic]
Public Sub New( _
ByVal parent As IChartSeries _
)
[C#]
public DataLabel(
IChartSeries parent
);

Parameters

parent
Parent series.

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


DataLabel Properties

The properties of the DataLabel class are listed below. For a complete list of DataLabel class members, see the DataLabel Members topic.

Public Instance Properties

Bottom |
Chart | Returns the parent chart. Read-only IChart.
DataLabelFormat |
Height | Returns or sets the height of a title as a fraction of the height of the chart. Read/write Single.
IsVisible | False means that data label is not visible (and so all Show*-flags (ShowValue, ...) are false).
LinkedSource | Obsolete. Gets and sets a reference to the worksheet
Right |
TextFormat |
TextFrame | Obsolete. Returns a textframe of this data label.
TextFrameForOverriding | Can contain a rich formatted text. If this property is not null then this formatted text value overrides auto-generated text of data label. Auto-generated text of data label means text that is managed by ShowSeriesName, ShowValue, ... properties and is formatted with the TextFormatManager.TextFormat property.
Width | Returns or sets the width of a title as a fraction of the width of the chart. Read/write Single.
X | Returns or sets the x coordinate of a title as a fraction of the width of the chart. Read/write Single.
Y | Returns or sets the y coordinate of a title as a fraction of the height of the chart. Read/write Single.

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


Bottom Property

Aspose.Slides Documentation

DataLabel.Bottom Property

[Visual Basic]
NotOverridable Public ReadOnly Property Bottom As Single _
Implements ILayoutable.Bottom
[C#]
public float Bottom {get;}

Implements

ILayoutable.Bottom

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


Chart Property

Aspose.Slides Documentation

DataLabel.Chart Property

Returns the parent chart. Read-only IChart.

[Visual Basic]
NotOverridable Public ReadOnly Property Chart As IChart _
Implements IChartComponent.Chart
[C#]
public IChart Chart {get;}

Implements

IChartComponent.Chart

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


DataLabelFormat Property

Aspose.Slides Documentation

DataLabel.DataLabelFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property DataLabelFormat As IDataLabelFormat _
Implements IDataLabel.DataLabelFormat
[C#]
public IDataLabelFormat DataLabelFormat {get;}

Implements

IDataLabel.DataLabelFormat

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


Height Property

Aspose.Slides Documentation

DataLabel.Height Property

Returns or sets the height of a title as a fraction of the height of the chart. Read/write Single.

[Visual Basic]
NotOverridable Public Property Height As Single _
Implements ILayoutable.Height
[C#]
public float Height {get; set;}

Implements

ILayoutable.Height

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


IsVisible Property

Aspose.Slides Documentation

DataLabel.IsVisible Property

False means that data label is not visible (and so all Show*-flags (ShowValue, ...) are false).

[Visual Basic]
NotOverridable Public ReadOnly Property IsVisible As Boolean _
Implements IDataLabel.IsVisible
[C#]
public bool IsVisible {get;}

Implements

IDataLabel.IsVisible

Remarks

If data label is visible you can make it hidden with Hide() method. But if data label is not visible (IsVisible is false) you can make data label visible with setting Show*-flags (ShowValue, ...) to true state.

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


LinkedSource Property

Aspose.Slides Documentation

DataLabel.LinkedSource Property

NOTE: This property is now obsolete.

Use DataLabelFormat.IsNumberFormatLinkedToSource property instead. Property will be removed after 01.09.2013.

Gets and sets a reference to the worksheet

[Visual Basic]
Public Property LinkedSource As Boolean
[C#]
public bool LinkedSource {get; set;}

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


Right Property

Aspose.Slides Documentation

DataLabel.Right Property

[Visual Basic]
NotOverridable Public ReadOnly Property Right As Single _
Implements ILayoutable.Right
[C#]
public float Right {get;}

Implements

ILayoutable.Right

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


TextFormat Property

Aspose.Slides Documentation

DataLabel.TextFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property TextFormat As IChartTextFormat _
Implements IFormattedTextContainer.TextFormat
[C#]
public IChartTextFormat TextFormat {get;}

Implements

IFormattedTextContainer.TextFormat

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


TextFrame Property

Aspose.Slides Documentation

DataLabel.TextFrame Property

NOTE: This property is now obsolete.

Use TextFrameForOverriding property instead. Property will be removed after 01.07.2013.

Returns a textframe of this data label.

[Visual Basic]
Public Property TextFrame As TextFrame
[C#]
public TextFrame TextFrame {get; set;}

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


TextFrameForOverriding Property

Aspose.Slides Documentation

DataLabel.TextFrameForOverriding Property

Can contain a rich formatted text. If this property is not null then this formatted text value overrides auto-generated text of data label. Auto-generated text of data label means text that is managed by ShowSeriesName, ShowValue, ... properties and is formatted with the TextFormatManager.TextFormat property.

[Visual Basic]
NotOverridable Public ReadOnly Property TextFrameForOverriding As ITextFrame _
Implements IOverridableText.TextFrameForOverriding
[C#]
public ITextFrame TextFrameForOverriding {get;}

Implements

IOverridableText.TextFrameForOverriding

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


Width Property

Aspose.Slides Documentation

DataLabel.Width Property

Returns or sets the width of a title as a fraction of the width of the chart. Read/write Single.

[Visual Basic]
NotOverridable Public Property Width As Single _
Implements ILayoutable.Width
[C#]
public float Width {get; set;}

Implements

ILayoutable.Width

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


X Property

Aspose.Slides Documentation

DataLabel.X Property

Returns or sets the x coordinate of a title as a fraction of the width of the chart. Read/write Single.

[Visual Basic]
NotOverridable Public Property X As Single _
Implements ILayoutable.X
[C#]
public float X {get; set;}

Implements

ILayoutable.X

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


Y Property

Aspose.Slides Documentation

DataLabel.Y Property

Returns or sets the y coordinate of a title as a fraction of the height of the chart. Read/write Single.

[Visual Basic]
NotOverridable Public Property Y As Single _
Implements ILayoutable.Y
[C#]
public float Y {get; set;}

Implements

ILayoutable.Y

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


DataLabel Methods

The methods of the DataLabel class are listed below. For a complete list of DataLabel class members, see the DataLabel Members topic.

Public Instance Methods

AddTextFrameForOverriding | Initialize TextFrameForOverriding with the text in paramener "text". If TextFrameForOverriding is already initialized then simply changes its text.
Hide | Make data label hidden by setting all Show*-flags (ShowValue, ...) to false state. IsVisible will be false after this.

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


DataLabel.AddTextFrameForOverriding Method

Initialize TextFrameForOverriding with the text in paramener "text". If TextFrameForOverriding is already initialized then simply changes its text.

[Visual Basic]
NotOverridable Public Function AddTextFrameForOverriding( _
ByVal text As String _
) As ITextFrame _
Implements IOverridableText.AddTextFrameForOverriding
[C#]
public ITextFrame AddTextFrameForOverriding(
string text
);

Parameters

text
Text for a new TextFrameForOverriding.

Implements

IOverridableText.AddTextFrameForOverriding

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


DataLabel.Hide Method

Make data label hidden by setting all Show*-flags (ShowValue, ...) to false state. IsVisible will be false after this.

[Visual Basic]
NotOverridable Public Sub Hide() _
Implements IDataLabel.Hide
[C#]
public void Hide();

Implements

IDataLabel.Hide

Remarks

If data label is not visible (IsVisible is false) you can make data label visible with setting Show*-flags (ShowValue, ...) to true state.

See Also

DataLabel Class | Aspose.Slides.Charts Namespace


DataLabelCollection Class

Represents a series labels.

For a list of all members of this type, see DataLabelCollection Members.

System.Object
Aspose.Slides.Charts.DataLabelCollection

[Visual Basic]
Public Class DataLabelCollection
Implements IDataLabelCollection, IEnumerable, IChartComponent
[C#]
public class DataLabelCollection : IDataLabelCollection, IEnumerable, IChartComponent

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

DataLabelCollection Members | Aspose.Slides.Charts Namespace


DataLabelCollection Members

DataLabelCollection overview

Public Instance Properties

Chart | Returns the parent chart. Read-only IChart.
Count | Gets the number of all data labels in the collection. Read-only Int32.
CountOfVisibleDataLabels | Gets the number of visible data labels in the collection. Read-only Int32.
DefaultDataLabelFormat |
Delete | Obsolete. Returns or sets delete flag. True means that data label is not visible by default (and so all Show*-flags (ShowValue, ...) of the DefaultDataLabelFormat property are false).
Format | Obsolete. Represents the format of the data labels. Read/write Format.
IsVisible | False means that data label is not visible by default (and so all Show*-flags (ShowValue, ...) of the DefaultDataLabelFormat property are false).
Item | Gets the data label for the data point with the specified index.
LinkedSource | Obsolete. Gets and sets a reference to the worksheet
NumberFormat | Obsolete. Represents the format string for the DataLabels object. Read/write String.
ParentSeries |
Position | Obsolete. Represents the position of the data lable. Read/write LegendDataLabelPosition.
Separator | Obsolete. Sets or returns a Variant representing the separator used for the data labels on a chart. Read/write String.
ShowBubbleSize | Obsolete. Represents a specified chart's data label bubble size value display behavior. True displays the bubble size value. False to hide. Read/write Boolean.
ShowCategoryName | Obsolete. Represents a specified chart's data label category name display behavior.True to display the category name for the data labels on a chart. False to hide. Read/write Boolean.
ShowLeaderLines | Obsolete. Represents a specified chart's data label leader line display behavior. True if the data label leader line is visible. Read/write Boolean.
ShowLegendKey | Obsolete. Represents a specified chart's data label legend key display behavior. True if the data label legend key is visible. Read/write Boolean.
ShowPercentage | Obsolete. Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide. Read/write Boolean.
ShowSeriesName | Obsolete. Returns or sets a Boolean to indicate the series name display behavior for the data labels on a chart. True to show the series name. False to hide. Read/write Boolean.
ShowValue | Obsolete. Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide. Read/write Boolean.

Public Instance Methods

GetEnumerator | Returns an enumerator for the entire collection.
Hide | Make data label hidden by default by setting all Show*-flags (ShowValue, ...) of the DefaultDataLabelFormat property to false state. IsVisible will be false after this.
IndexOf | Returns an index of the specified DataLabel in the collection.

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


DataLabelCollection Properties

The properties of the DataLabelCollection class are listed below. For a complete list of DataLabelCollection class members, see the DataLabelCollection Members topic.

Public Instance Properties

Chart | Returns the parent chart. Read-only IChart.
Count | Gets the number of all data labels in the collection. Read-only Int32.
CountOfVisibleDataLabels | Gets the number of visible data labels in the collection. Read-only Int32.
DefaultDataLabelFormat |
Delete | Obsolete. Returns or sets delete flag. True means that data label is not visible by default (and so all Show*-flags (ShowValue, ...) of the DefaultDataLabelFormat property are false).
Format | Obsolete. Represents the format of the data labels. Read/write Format.
IsVisible | False means that data label is not visible by default (and so all Show*-flags (ShowValue, ...) of the DefaultDataLabelFormat property are false).
Item | Gets the data label for the data point with the specified index.
LinkedSource | Obsolete. Gets and sets a reference to the worksheet
NumberFormat | Obsolete. Represents the format string for the DataLabels object. Read/write String.
ParentSeries |
Position | Obsolete. Represents the position of the data lable. Read/write LegendDataLabelPosition.
Separator | Obsolete. Sets or returns a Variant representing the separator used for the data labels on a chart. Read/write String.
ShowBubbleSize | Obsolete. Represents a specified chart's data label bubble size value display behavior. True displays the bubble size value. False to hide. Read/write Boolean.
ShowCategoryName | Obsolete. Represents a specified chart's data label category name display behavior.True to display the category name for the data labels on a chart. False to hide. Read/write Boolean.
ShowLeaderLines | Obsolete. Represents a specified chart's data label leader line display behavior. True if the data label leader line is visible. Read/write Boolean.
ShowLegendKey | Obsolete. Represents a specified chart's data label legend key display behavior. True if the data label legend key is visible. Read/write Boolean.
ShowPercentage | Obsolete. Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide. Read/write Boolean.
ShowSeriesName | Obsolete. Returns or sets a Boolean to indicate the series name display behavior for the data labels on a chart. True to show the series name. False to hide. Read/write Boolean.
ShowValue | Obsolete. Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide. Read/write Boolean.

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


Chart Property

Aspose.Slides Documentation

DataLabelCollection.Chart Property

Returns the parent chart. Read-only IChart.

[Visual Basic]
NotOverridable Public ReadOnly Property Chart As IChart _
Implements IChartComponent.Chart
[C#]
public IChart Chart {get;}

Implements

IChartComponent.Chart

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


Count Property

Aspose.Slides Documentation

DataLabelCollection.Count Property

Gets the number of all data labels in the collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements IDataLabelCollection.Count
[C#]
public int Count {get;}

Implements

IDataLabelCollection.Count

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


CountOfVisibleDataLabels Property

Aspose.Slides Documentation

DataLabelCollection.CountOfVisibleDataLabels Property

Gets the number of visible data labels in the collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property CountOfVisibleDataLabels As Integer _
Implements IDataLabelCollection.CountOfVisibleDataLabels
[C#]
public int CountOfVisibleDataLabels {get;}

Implements

IDataLabelCollection.CountOfVisibleDataLabels

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


DefaultDataLabelFormat Property

Aspose.Slides Documentation

DataLabelCollection.DefaultDataLabelFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property DefaultDataLabelFormat As IDataLabelFormat _
Implements IDataLabelCollection.DefaultDataLabelFormat
[C#]
public IDataLabelFormat DefaultDataLabelFormat {get;}

Implements

IDataLabelCollection.DefaultDataLabelFormat

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


Delete Property

Aspose.Slides Documentation

DataLabelCollection.Delete Property

NOTE: This property is now obsolete.

Use IsVisible property instead. Property will be removed after 01.09.2013.

Returns or sets delete flag. True means that data label is not visible by default (and so all Show*-flags (ShowValue, ...) of the DefaultDataLabelFormat property are false).

[Visual Basic]
Public Property Delete As Boolean
[C#]
public bool Delete {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

DataLabelCollection.Format Property

NOTE: This property is now obsolete.

Use DefaultDataLabelFormat.Format property instead. Property will be removed after 01.09.2013.

Represents the format of the data labels. Read/write Format.

[Visual Basic]
Public Property Format As Format
[C#]
public Format Format {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


IsVisible Property

Aspose.Slides Documentation

DataLabelCollection.IsVisible Property

False means that data label is not visible by default (and so all Show*-flags (ShowValue, ...) of the DefaultDataLabelFormat property are false).

[Visual Basic]
NotOverridable Public ReadOnly Property IsVisible As Boolean _
Implements IDataLabelCollection.IsVisible
[C#]
public bool IsVisible {get;}

Implements

IDataLabelCollection.IsVisible

Remarks

If data label is visible by default you can make it hidden by default with Hide() method. But if data label is not visible by default (IsVisible is false) you can make data label "visible by default" with setting Show*-flags (ShowValue, ...) of the DefaultDataLabelFormat property to true state.

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

DataLabelCollection.Item Property

Gets the data label for the data point with the specified index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IDataLabelCollection.Item
As IDataLabel _
Implements IDataLabelCollection.Item
[C#]
public IDataLabel this[
int index
] {get;}

Implements

IDataLabelCollection.Item

Remarks

Alternate way to access data label is: - SeriesEx.DataPoints[i].Label - manage label properties.

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


LinkedSource Property

Aspose.Slides Documentation

DataLabelCollection.LinkedSource Property

NOTE: This property is now obsolete.

Use DefaultDataLabelFormat.IsNumberFormatLinkedToSource property instead. Property will be removed after 01.07.2013.

Gets and sets a reference to the worksheet

[Visual Basic]
Public Property LinkedSource As Boolean
[C#]
public bool LinkedSource {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


NumberFormat Property

Aspose.Slides Documentation

DataLabelCollection.NumberFormat Property

NOTE: This property is now obsolete.

Use DefaultDataLabelFormat.NumberFormat property instead. Property will be removed after 01.07.2013.

Represents the format string for the DataLabels object. Read/write String.

[Visual Basic]
Public Property NumberFormat As String
[C#]
public string NumberFormat {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


ParentSeries Property

Aspose.Slides Documentation

DataLabelCollection.ParentSeries Property

[Visual Basic]
NotOverridable Public ReadOnly Property ParentSeries As IChartSeries _
Implements IDataLabelCollection.ParentSeries
[C#]
public IChartSeries ParentSeries {get;}

Implements

IDataLabelCollection.ParentSeries

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


Position Property

Aspose.Slides Documentation

DataLabelCollection.Position Property

NOTE: This property is now obsolete.

Use DefaultDataLabelFormat.Position property instead. Property will be removed after 01.09.2013.

Represents the position of the data lable. Read/write LegendDataLabelPosition.

[Visual Basic]
Public Property Position As LegendDataLabelPosition
[C#]
public LegendDataLabelPosition Position {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


Separator Property

Aspose.Slides Documentation

DataLabelCollection.Separator Property

NOTE: This property is now obsolete.

Use DefaultDataLabelFormat.Separator property instead. Property will be removed after 01.09.2013.

Sets or returns a Variant representing the separator used for the data labels on a chart. Read/write String.

[Visual Basic]
Public Property Separator As String
[C#]
public string Separator {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


ShowBubbleSize Property

Aspose.Slides Documentation

DataLabelCollection.ShowBubbleSize Property

NOTE: This property is now obsolete.

Use DefaultDataLabelFormat.ShowBubbleSize property instead. Property will be removed after 01.09.2013.

Represents a specified chart's data label bubble size value display behavior. True displays the bubble size value. False to hide. Read/write Boolean.

[Visual Basic]
Public Property ShowBubbleSize As Boolean
[C#]
public bool ShowBubbleSize {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


ShowCategoryName Property

Aspose.Slides Documentation

DataLabelCollection.ShowCategoryName Property

NOTE: This property is now obsolete.

Use DefaultDataLabelFormat.ShowCategoryName property instead. Property will be removed after 01.09.2013.

Represents a specified chart's data label category name display behavior.True to display the category name for the data labels on a chart. False to hide. Read/write Boolean.

[Visual Basic]
Public Property ShowCategoryName As Boolean
[C#]
public bool ShowCategoryName {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


ShowLeaderLines Property

Aspose.Slides Documentation

DataLabelCollection.ShowLeaderLines Property

NOTE: This property is now obsolete.

Use DefaultDataLabelFormat.ShowLeaderLines property instead. Property will be removed after 01.09.2013.

Represents a specified chart's data label leader line display behavior. True if the data label leader line is visible. Read/write Boolean.

[Visual Basic]
Public Property ShowLeaderLines As Boolean
[C#]
public bool ShowLeaderLines {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


ShowLegendKey Property

Aspose.Slides Documentation

DataLabelCollection.ShowLegendKey Property

NOTE: This property is now obsolete.

Use DefaultDataLabelFormat.ShowLegendKey property instead. Property will be removed after 01.09.2013.

Represents a specified chart's data label legend key display behavior. True if the data label legend key is visible. Read/write Boolean.

[Visual Basic]
Public Property ShowLegendKey As Boolean
[C#]
public bool ShowLegendKey {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


ShowPercentage Property

Aspose.Slides Documentation

DataLabelCollection.ShowPercentage Property

NOTE: This property is now obsolete.

Use DefaultDataLabelFormat.ShowPercentage property instead. Property will be removed after 01.09.2013.

Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide. Read/write Boolean.

[Visual Basic]
Public Property ShowPercentage As Boolean
[C#]
public bool ShowPercentage {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


ShowSeriesName Property

Aspose.Slides Documentation

DataLabelCollection.ShowSeriesName Property

NOTE: This property is now obsolete.

Use DefaultDataLabelFormat.ShowSeriesName property instead. Property will be removed after 01.09.2013.

Returns or sets a Boolean to indicate the series name display behavior for the data labels on a chart. True to show the series name. False to hide. Read/write Boolean.

[Visual Basic]
Public Property ShowSeriesName As Boolean
[C#]
public bool ShowSeriesName {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


ShowValue Property

Aspose.Slides Documentation

DataLabelCollection.ShowValue Property

NOTE: This property is now obsolete.

Use DefaultDataLabelFormat.ShowValue property instead. Property will be removed after 01.09.2013.

Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide. Read/write Boolean.

[Visual Basic]
Public Property ShowValue As Boolean
[C#]
public bool ShowValue {get; set;}

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


DataLabelCollection Methods

The methods of the DataLabelCollection class are listed below. For a complete list of DataLabelCollection class members, see the DataLabelCollection Members topic.

Public Instance Methods

GetEnumerator | Returns an enumerator for the entire collection.
Hide | Make data label hidden by default by setting all Show*-flags (ShowValue, ...) of the DefaultDataLabelFormat property to false state. IsVisible will be false after this.
IndexOf | Returns an index of the specified DataLabel in the collection.

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


DataLabelCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


DataLabelCollection.Hide Method

Make data label hidden by default by setting all Show*-flags (ShowValue, ...) of the DefaultDataLabelFormat property to false state. IsVisible will be false after this.

[Visual Basic]
NotOverridable Public Sub Hide() _
Implements IDataLabelCollection.Hide
[C#]
public void Hide();

Implements

IDataLabelCollection.Hide

Remarks

If data label is not visible by default (IsVisible is false) you can make data label "visible by default" with setting Show*-flags (ShowValue, ...) of the DefaultDataLabelFormat property to true state.

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


DataLabelCollection.IndexOf Method

Returns an index of the specified DataLabel in the collection.

[Visual Basic]
NotOverridable Public Function IndexOf( _
ByVal value As IDataLabel _
) As Integer _
Implements IDataLabelCollection.IndexOf
[C#]
public int IndexOf(
IDataLabel value
);

Parameters

value
DataLabel to find.

Return Value

Index of a DataLabel or -1 if DataLabel not from this collection.

Implements

IDataLabelCollection.IndexOf

See Also

DataLabelCollection Class | Aspose.Slides.Charts Namespace


DataLabelFormat Class

For a list of all members of this type, see DataLabelFormat Members.

System.Object
Aspose.Slides.Charts.DataLabelFormat

[Visual Basic]
Public Class DataLabelFormat
Implements IDataLabelFormat, IChartComponent, IFormattedTextContainer
[C#]
public class DataLabelFormat : IDataLabelFormat, IChartComponent, IFormattedTextContainer

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

DataLabelFormat Members | Aspose.Slides.Charts Namespace


DataLabelFormat Members

DataLabelFormat overview

Public Instance Properties

Chart | Returns the parent chart. Read-only IChart.
Format | Represents the format of the data label. Read/write Format.
IsNumberFormatLinkedToSource |
NumberFormat | Represents the format string for the DataLabels object. Read/write String.
Position | Represents the position of the data label. Read/write LegendDataLabelPosition.
Separator | Sets or returns a Variant representing the separator used for the data labels on a chart. Read/write String.
ShowBubbleSize | Represents a specified chart's data label bubble size value display behavior. True displays the bubble size value. False to hide. Read/write Boolean.
ShowCategoryName | Represents a specified chart's data label category name display behavior. True to display the category name for the data labels on a chart. False to hide. Read/write Boolean.
ShowLeaderLines | Represents a specified chart's data label leader lines display behavior. True displays the leader lines. False to hide. Read/write Boolean.
ShowLegendKey | Represents a specified chart's data label legend key display behavior. True if the data label legend key is visible. Read/write Boolean.
ShowPercentage | Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide. Read/write Boolean.
ShowSeriesName | Returns or sets a Boolean to indicate the series name display behavior for the data labels on a chart. True to show the series name. False to hide. Read/write Boolean.
ShowValue | Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide. Read/write Boolean.
TextFormat |

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


DataLabelFormat Properties

The properties of the DataLabelFormat class are listed below. For a complete list of DataLabelFormat class members, see the DataLabelFormat Members topic.

Public Instance Properties

Chart | Returns the parent chart. Read-only IChart.
Format | Represents the format of the data label. Read/write Format.
IsNumberFormatLinkedToSource |
NumberFormat | Represents the format string for the DataLabels object. Read/write String.
Position | Represents the position of the data label. Read/write LegendDataLabelPosition.
Separator | Sets or returns a Variant representing the separator used for the data labels on a chart. Read/write String.
ShowBubbleSize | Represents a specified chart's data label bubble size value display behavior. True displays the bubble size value. False to hide. Read/write Boolean.
ShowCategoryName | Represents a specified chart's data label category name display behavior. True to display the category name for the data labels on a chart. False to hide. Read/write Boolean.
ShowLeaderLines | Represents a specified chart's data label leader lines display behavior. True displays the leader lines. False to hide. Read/write Boolean.
ShowLegendKey | Represents a specified chart's data label legend key display behavior. True if the data label legend key is visible. Read/write Boolean.
ShowPercentage | Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide. Read/write Boolean.
ShowSeriesName | Returns or sets a Boolean to indicate the series name display behavior for the data labels on a chart. True to show the series name. False to hide. Read/write Boolean.
ShowValue | Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide. Read/write Boolean.
TextFormat |

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


Chart Property

Aspose.Slides Documentation

DataLabelFormat.Chart Property

Returns the parent chart. Read-only IChart.

[Visual Basic]
NotOverridable Public ReadOnly Property Chart As IChart _
Implements IChartComponent.Chart
[C#]
public IChart Chart {get;}

Implements

IChartComponent.Chart

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

DataLabelFormat.Format Property

Represents the format of the data label. Read/write Format.

[Visual Basic]
NotOverridable Public ReadOnly Property Format As IFormat _
Implements IDataLabelFormat.Format
[C#]
public IFormat Format {get;}

Implements

IDataLabelFormat.Format

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property represents the default format for the new data labels in the DataLabelCollection collection.

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


IsNumberFormatLinkedToSource Property

Aspose.Slides Documentation

DataLabelFormat.IsNumberFormatLinkedToSource Property

[Visual Basic]
NotOverridable Public Property IsNumberFormatLinkedToSource As Boolean _
Implements IDataLabelFormat.IsNumberFormatLinkedToSource
[C#]
public bool IsNumberFormatLinkedToSource {get; set;}

Implements

IDataLabelFormat.IsNumberFormatLinkedToSource

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property gets or sets the default value of the IsNumberFormatLinkedToSource property for the new data labels in the DataLabelCollection collection. Set this property with value also sets this value to the IsNumberFormatLinkedToSource property for all data labels in the DataLabelCollection collection (i.e. "DataLabels.DefaultDataLabelFormat.IsNumberFormatLinkedToSource = val;" cause to all DataLabels[i].IsNumberFormatLinkedToSource is equal to val). Read/write Boolean.

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


NumberFormat Property

Aspose.Slides Documentation

DataLabelFormat.NumberFormat Property

Represents the format string for the DataLabels object. Read/write String.

[Visual Basic]
NotOverridable Public Property NumberFormat As String _
Implements IDataLabelFormat.NumberFormat
[C#]
public string NumberFormat {get; set;}

Implements

IDataLabelFormat.NumberFormat

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property gets or sets the default value of the NumberFormat property for the new data labels in the DataLabelCollection collection. Represents the format string for the DataLabel objects. Set this property with value also sets this value to the NumberFormat property for all data labels in the DataLabelCollection collection (i.e. "DataLabels.DefaultDataLabelFormat.NumberFormat = val;" cause to all DataLabels[i].NumberFormat is equal to val).

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


Position Property

Aspose.Slides Documentation

DataLabelFormat.Position Property

Represents the position of the data label. Read/write LegendDataLabelPosition.

[Visual Basic]
NotOverridable Public Property Position As LegendDataLabelPosition _
Implements IDataLabelFormat.Position
[C#]
public LegendDataLabelPosition Position {get; set;}

Implements

IDataLabelFormat.Position

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property gets or sets the default value of the Position property for the new data labels in the DataLabelCollection collection. Represents the position for the DataLabel objects. Set this property with value also sets this value to the Position property for all data labels in the DataLabelCollection collection (i.e. "DataLabels.DefaultDataLabelFormat.Position = val;" cause to all DataLabels[i].Position is equal to val).

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


Separator Property

Aspose.Slides Documentation

DataLabelFormat.Separator Property

Sets or returns a Variant representing the separator used for the data labels on a chart. Read/write String.

[Visual Basic]
NotOverridable Public Property Separator As String _
Implements IDataLabelFormat.Separator
[C#]
public string Separator {get; set;}

Implements

IDataLabelFormat.Separator

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property gets or sets the default value of the Separator property for the new data labels in the DataLabelCollection collection. Set this property with value also sets this value to the Separator property for all data labels in the DataLabelCollection collection (i.e. "DataLabels.DefaultDataLabelFormat.Separator = val;" cause to all DataLabels[i].Separator is equal to val).

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


ShowBubbleSize Property

Aspose.Slides Documentation

DataLabelFormat.ShowBubbleSize Property

Represents a specified chart's data label bubble size value display behavior. True displays the bubble size value. False to hide. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property ShowBubbleSize As Boolean _
Implements IDataLabelFormat.ShowBubbleSize
[C#]
public bool ShowBubbleSize {get; set;}

Implements

IDataLabelFormat.ShowBubbleSize

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property gets or sets the default value of the ShowBubbleSize property for the new data labels in the DataLabelCollection collection. Set this property with value also sets this value to the ShowBubbleSize property for all data labels in the DataLabelCollection collection (i.e. "DataLabels.DefaultDataLabelFormat.ShowBubbleSize = val;" cause to all DataLabels[i].ShowBubbleSize is equal to val).

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


ShowCategoryName Property

Aspose.Slides Documentation

DataLabelFormat.ShowCategoryName Property

Represents a specified chart's data label category name display behavior. True to display the category name for the data labels on a chart. False to hide. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property ShowCategoryName As Boolean _
Implements IDataLabelFormat.ShowCategoryName
[C#]
public bool ShowCategoryName {get; set;}

Implements

IDataLabelFormat.ShowCategoryName

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property gets or sets the default value of the ShowCategoryName property for the new data labels in the DataLabelCollection collection. Set this property with value also sets this value to the ShowCategoryName property for all data labels in the DataLabelCollection collection (i.e. "DataLabels.DefaultDataLabelFormat.ShowCategoryName = val;" cause to all DataLabels[i].ShowCategoryName is equal to val).

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


ShowLeaderLines Property

Aspose.Slides Documentation

DataLabelFormat.ShowLeaderLines Property

Represents a specified chart's data label leader lines display behavior. True displays the leader lines. False to hide. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property ShowLeaderLines As Boolean _
Implements IDataLabelFormat.ShowLeaderLines
[C#]
public bool ShowLeaderLines {get; set;}

Implements

IDataLabelFormat.ShowLeaderLines

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property gets or sets the default value of the ShowLeaderLines property for the new data labels in the DataLabelCollection collection. Set this property with value also sets this value to the ShowLeaderLines property for all data labels in the DataLabelCollection collection (i.e. "DataLabels.DefaultDataLabelFormat.ShowLeaderLines = val;" cause to all DataLabels[i].ShowLeaderLines is equal to val).

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


ShowLegendKey Property

Aspose.Slides Documentation

DataLabelFormat.ShowLegendKey Property

Represents a specified chart's data label legend key display behavior. True if the data label legend key is visible. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property ShowLegendKey As Boolean _
Implements IDataLabelFormat.ShowLegendKey
[C#]
public bool ShowLegendKey {get; set;}

Implements

IDataLabelFormat.ShowLegendKey

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property gets or sets the default value of the ShowLegendKey property for the new data labels in the DataLabelCollection collection. Set this property with value also sets this value to the ShowLegendKey property for all data labels in the DataLabelCollection collection (i.e. "DataLabels.DefaultDataLabelFormat.ShowLegendKey = val;" cause to all DataLabels[i].ShowLegendKey is equal to val).

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


ShowPercentage Property

Aspose.Slides Documentation

DataLabelFormat.ShowPercentage Property

Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property ShowPercentage As Boolean _
Implements IDataLabelFormat.ShowPercentage
[C#]
public bool ShowPercentage {get; set;}

Implements

IDataLabelFormat.ShowPercentage

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property gets or sets the default value of the ShowPercentage property for the new data labels in the DataLabelCollection collection. Set this property with value also sets this value to the ShowPercentage property for all data labels in the DataLabelCollection collection (i.e. "DataLabels.DefaultDataLabelFormat.ShowPercentage = val;" cause to all DataLabels[i].ShowPercentage is equal to val).

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


ShowSeriesName Property

Aspose.Slides Documentation

DataLabelFormat.ShowSeriesName Property

Returns or sets a Boolean to indicate the series name display behavior for the data labels on a chart. True to show the series name. False to hide. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property ShowSeriesName As Boolean _
Implements IDataLabelFormat.ShowSeriesName
[C#]
public bool ShowSeriesName {get; set;}

Implements

IDataLabelFormat.ShowSeriesName

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property gets or sets the default value of the ShowSeriesName property for the new data labels in the DataLabelCollection collection. Set this property with value also sets this value to the ShowSeriesName property for all data labels in the DataLabelCollection collection (i.e. "DataLabels.DefaultDataLabelFormat.ShowSeriesName = val;" cause to all DataLabels[i].ShowSeriesName is equal to val).

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


ShowValue Property

Aspose.Slides Documentation

DataLabelFormat.ShowValue Property

Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property ShowValue As Boolean _
Implements IDataLabelFormat.ShowValue
[C#]
public bool ShowValue {get; set;}

Implements

IDataLabelFormat.ShowValue

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property gets or sets the default value of the ShowValue property for the new data labels in the DataLabelCollection collection. Set this property with value also sets this value to the ShowValue property for all data labels in the DataLabelCollection collection (i.e. "DataLabels.DefaultDataLabelFormat.ShowValue = val;" cause to all DataLabels[i].ShowValue is equal to val).

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


TextFormat Property

Aspose.Slides Documentation

DataLabelFormat.TextFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property TextFormat As IChartTextFormat _
Implements IFormattedTextContainer.TextFormat
[C#]
public IChartTextFormat TextFormat {get;}

Implements

IFormattedTextContainer.TextFormat

Remarks

If parent of this DataLabelFormat object is a DataLabelCollection collection of data labels then this property represents the default text format for the new data labels in the DataLabelCollection collection. Read Format.

See Also

DataLabelFormat Class | Aspose.Slides.Charts Namespace


DataSourceType Enumeration

[Visual Basic]
Public Enum DataSourceType
[C#]
public enum DataSourceType

Members

Member Name | Description | Value
Worksheet |  | 0
StringLiterals |  | 1
DoubleLiterals |  | 2

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


DataTable Class

Represents data table properties.

For a list of all members of this type, see DataTable Members.

System.Object
Aspose.Slides.Charts.DataTable

[Visual Basic]
Public Class DataTable
Implements IDataTable, IChartComponent, IFormattedTextContainer
[C#]
public class DataTable : IDataTable, IChartComponent, IFormattedTextContainer

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

DataTable Members | Aspose.Slides.Charts Namespace


DataTable Members

DataTable overview

Public Instance Properties

Chart |
Format | Returns the line, fill, and effect styles of an object.
HasBorderHorizontal | True if the chart data table has horizontal cell borders.
HasBorderOutline | True if the chart data table has outline borders.
HasBorderVertical | True if the chart data table has vertical cell borders.
ShowLegendKey | True if the data label legend key is visible.
TextFormat |

See Also

DataTable Class | Aspose.Slides.Charts Namespace


DataTable Properties

The properties of the DataTable class are listed below. For a complete list of DataTable class members, see the DataTable Members topic.

Public Instance Properties

Chart |
Format | Returns the line, fill, and effect styles of an object.
HasBorderHorizontal | True if the chart data table has horizontal cell borders.
HasBorderOutline | True if the chart data table has outline borders.
HasBorderVertical | True if the chart data table has vertical cell borders.
ShowLegendKey | True if the data label legend key is visible.
TextFormat |

See Also

DataTable Class | Aspose.Slides.Charts Namespace


Chart Property

Aspose.Slides Documentation

DataTable.Chart Property

[Visual Basic]
NotOverridable Public ReadOnly Property Chart As IChart _
Implements IChartComponent.Chart
[C#]
public IChart Chart {get;}

Implements

IChartComponent.Chart

See Also

DataTable Class | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

DataTable.Format Property

Returns the line, fill, and effect styles of an object.

[Visual Basic]
NotOverridable Public ReadOnly Property Format As IFormat _
Implements IDataTable.Format
[C#]
public IFormat Format {get;}

Implements

IDataTable.Format

See Also

DataTable Class | Aspose.Slides.Charts Namespace


HasBorderHorizontal Property

Aspose.Slides Documentation

DataTable.HasBorderHorizontal Property

True if the chart data table has horizontal cell borders.

[Visual Basic]
NotOverridable Public Property HasBorderHorizontal As Boolean _
Implements IDataTable.HasBorderHorizontal
[C#]
public bool HasBorderHorizontal {get; set;}

Implements

IDataTable.HasBorderHorizontal

See Also

DataTable Class | Aspose.Slides.Charts Namespace


HasBorderOutline Property

Aspose.Slides Documentation

DataTable.HasBorderOutline Property

True if the chart data table has outline borders.

[Visual Basic]
NotOverridable Public Property HasBorderOutline As Boolean _
Implements IDataTable.HasBorderOutline
[C#]
public bool HasBorderOutline {get; set;}

Implements

IDataTable.HasBorderOutline

See Also

DataTable Class | Aspose.Slides.Charts Namespace


HasBorderVertical Property

Aspose.Slides Documentation

DataTable.HasBorderVertical Property

True if the chart data table has vertical cell borders.

[Visual Basic]
NotOverridable Public Property HasBorderVertical As Boolean _
Implements IDataTable.HasBorderVertical
[C#]
public bool HasBorderVertical {get; set;}

Implements

IDataTable.HasBorderVertical

See Also

DataTable Class | Aspose.Slides.Charts Namespace


ShowLegendKey Property

Aspose.Slides Documentation

DataTable.ShowLegendKey Property

True if the data label legend key is visible.

[Visual Basic]
NotOverridable Public Property ShowLegendKey As Boolean _
Implements IDataTable.ShowLegendKey
[C#]
public bool ShowLegendKey {get; set;}

Implements

IDataTable.ShowLegendKey

See Also

DataTable Class | Aspose.Slides.Charts Namespace


TextFormat Property

Aspose.Slides Documentation

DataTable.TextFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property TextFormat As IChartTextFormat _
Implements IFormattedTextContainer.TextFormat
[C#]
public IChartTextFormat TextFormat {get;}

Implements

IFormattedTextContainer.TextFormat

See Also

DataTable Class | Aspose.Slides.Charts Namespace


DisplayBlanksAsType Enumeration

[Visual Basic]
Public Enum DisplayBlanksAsType
[C#]
public enum DisplayBlanksAsType

Members

Member Name | Description | Value
Gap |  | 0
Span |  | 1
Zero |  | 2

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


DisplayUnitType Enumeration

[Visual Basic]
Public Enum DisplayUnitType
[C#]
public enum DisplayUnitType

Members

Member Name | Description | Value
None |  | 0
Hundreds |  | 1
Thousands |  | 2
TenThousands |  | 3
HundredThousands |  | 4
Millions |  | 5
TenMillions |  | 6
HundredMillions |  | 7
Billions |  | 8
Trillions |  | 9
CustomValue |  | 10

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


DoubleChartValue Class

Represent double value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.

For a list of all members of this type, see DoubleChartValue Members.

System.Object
Aspose.Slides.Charts.BaseChartValue
Aspose.Slides.Charts.DoubleChartValue

[Visual Basic]
Public Class DoubleChartValue
Inherits BaseChartValue
Implements IDoubleChartValue, ISingleCellChartValue
[C#]
public class DoubleChartValue : BaseChartValue, IDoubleChartValue, ISingleCellChartValue

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

DoubleChartValue Members | Aspose.Slides.Charts Namespace


DoubleChartValue Members

DoubleChartValue overview

Public Instance Properties

AsCell |
AsLiteralDouble |
Data |
DataSourceType (inherited from BaseChartValue) | Specifies whether AsCell, AsCells, AsLiteralString or AsLiteralDouble property is actual in descendants. In other words it specifies the type of value of the Data property.

Public Instance Methods

ToDouble

See Also

DoubleChartValue Class | Aspose.Slides.Charts Namespace


DoubleChartValue Properties

The properties of the DoubleChartValue class are listed below. For a complete list of DoubleChartValue class members, see the DoubleChartValue Members topic.

Public Instance Properties

AsCell |
AsLiteralDouble |
Data |
DataSourceType (inherited from BaseChartValue) | Specifies whether AsCell, AsCells, AsLiteralString or AsLiteralDouble property is actual in descendants. In other words it specifies the type of value of the Data property.

See Also

DoubleChartValue Class | Aspose.Slides.Charts Namespace


AsCell Property

Aspose.Slides Documentation

DoubleChartValue.AsCell Property

[Visual Basic]
NotOverridable Public Property AsCell As IChartDataCell _
Implements ISingleCellChartValue.AsCell
[C#]
public IChartDataCell AsCell {get; set;}

Implements

ISingleCellChartValue.AsCell

See Also

DoubleChartValue Class | Aspose.Slides.Charts Namespace


AsLiteralDouble Property

Aspose.Slides Documentation

DoubleChartValue.AsLiteralDouble Property

[Visual Basic]
NotOverridable Public Property AsLiteralDouble As Double _
Implements IDoubleChartValue.AsLiteralDouble
[C#]
public double AsLiteralDouble {get; set;}

Implements

IDoubleChartValue.AsLiteralDouble

See Also

DoubleChartValue Class | Aspose.Slides.Charts Namespace


Data Property

Aspose.Slides Documentation

DoubleChartValue.Data Property

[Visual Basic]
Overrides Public Property Data As Object _
Implements IBaseChartValue.Data
[C#]
public override object Data {get; set;}

Implements

IBaseChartValue.Data

See Also

DoubleChartValue Class | Aspose.Slides.Charts Namespace


DoubleChartValue Methods

The methods of the DoubleChartValue class are listed below. For a complete list of DoubleChartValue class members, see the DoubleChartValue Members topic.

Public Instance Methods

ToDouble

See Also

DoubleChartValue Class | Aspose.Slides.Charts Namespace


DoubleChartValue.ToDouble Method

[Visual Basic]
NotOverridable Public Function ToDouble() As Double _
Implements IDoubleChartValue.ToDouble
[C#]
public double ToDouble();

Implements

IDoubleChartValue.ToDouble

See Also

DoubleChartValue Class | Aspose.Slides.Charts Namespace


Format Class

Represents chart format properties.

For a list of all members of this type, see Format Members.

System.Object
Aspose.Slides.Charts.Format

[Visual Basic]
Public Class Format
Implements IFormat
[C#]
public class Format : IFormat

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Format Members | Aspose.Slides.Charts Namespace


Format Members

Format overview

Public Instance Properties

Effect | Returns effects used for a chart. Read-only IEffectFormat.
Effect3D | Returns 3D format of a chart. Read-only IThreeDFormat.
Fill | Returns fill style properties of a chart. Read-only IFillFormat.
Line | Returns line style properties of a chart. Read-only ILineFormat.

Public Instance Methods

Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

Format Class | Aspose.Slides.Charts Namespace


Format Properties

The properties of the Format class are listed below. For a complete list of Format class members, see the Format Members topic.

Public Instance Properties

Effect | Returns effects used for a chart. Read-only IEffectFormat.
Effect3D | Returns 3D format of a chart. Read-only IThreeDFormat.
Fill | Returns fill style properties of a chart. Read-only IFillFormat.
Line | Returns line style properties of a chart. Read-only ILineFormat.

See Also

Format Class | Aspose.Slides.Charts Namespace


Effect Property

Aspose.Slides Documentation

Format.Effect Property

Returns effects used for a chart. Read-only IEffectFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Effect As IEffectFormat _
Implements IFormat.Effect
[C#]
public IEffectFormat Effect {get;}

Implements

IFormat.Effect

See Also

Format Class | Aspose.Slides.Charts Namespace


Effect3D Property

Aspose.Slides Documentation

Format.Effect3D Property

Returns 3D format of a chart. Read-only IThreeDFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Effect3D As IThreeDFormat _
Implements IFormat.Effect3D
[C#]
public IThreeDFormat Effect3D {get;}

Implements

IFormat.Effect3D

See Also

Format Class | Aspose.Slides.Charts Namespace


Fill Property

Aspose.Slides Documentation

Format.Fill Property

Returns fill style properties of a chart. Read-only IFillFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Fill As IFillFormat _
Implements IFormat.Fill
[C#]
public IFillFormat Fill {get;}

Implements

IFormat.Fill

See Also

Format Class | Aspose.Slides.Charts Namespace


Line Property

Aspose.Slides Documentation

Format.Line Property

Returns line style properties of a chart. Read-only ILineFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Line As ILineFormat _
Implements IFormat.Line
[C#]
public ILineFormat Line {get;}

Implements

IFormat.Line

See Also

Format Class | Aspose.Slides.Charts Namespace


Format Methods

The methods of the Format class are listed below. For a complete list of Format class members, see the Format Members topic.

Public Instance Methods

Equals | Determines whether two FillFormat instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

Format Class | Aspose.Slides.Charts Namespace


Format.Equals Method

Determines whether two FillFormat instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

See Also

Format Class | Aspose.Slides.Charts Namespace


Format.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Remarks

Overriden to make compiler happy.

See Also

Format Class | Aspose.Slides.Charts Namespace


IAxesManager Interface

For a list of all members of this type, see IAxesManager Members.

[Visual Basic]
Public Interface IAxesManager
[C#]
public interface IAxesManager

Types that implement IAxesManager

Type | Description
AxesManager | Provide access to chart axes.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAxesManager Members | Aspose.Slides.Charts Namespace


IAxesManager Members

IAxesManager overview

Public Instance Properties

HorizontalAxis
SecondaryHorizontalAxis
SecondaryVerticalAxis
SeriesAxis
VerticalAxis

See Also

IAxesManager Interface | Aspose.Slides.Charts Namespace


IAxesManager Properties

The properties of the IAxesManager interface are listed below. For a complete list of IAxesManager interface members, see the IAxesManager Members topic.

Public Instance Properties

HorizontalAxis
SecondaryHorizontalAxis
SecondaryVerticalAxis
SeriesAxis
VerticalAxis

See Also

IAxesManager Interface | Aspose.Slides.Charts Namespace


HorizontalAxis Property

Aspose.Slides Documentation

IAxesManager.HorizontalAxis Property

[Visual Basic]
Property HorizontalAxis As IAxis
[C#]
IAxis HorizontalAxis {get;}

See Also

IAxesManager Interface | Aspose.Slides.Charts Namespace


SecondaryHorizontalAxis Property

Aspose.Slides Documentation

IAxesManager.SecondaryHorizontalAxis Property

[Visual Basic]
Property SecondaryHorizontalAxis As IAxis
[C#]
IAxis SecondaryHorizontalAxis {get;}

See Also

IAxesManager Interface | Aspose.Slides.Charts Namespace


SecondaryVerticalAxis Property

Aspose.Slides Documentation

IAxesManager.SecondaryVerticalAxis Property

[Visual Basic]
Property SecondaryVerticalAxis As IAxis
[C#]
IAxis SecondaryVerticalAxis {get;}

See Also

IAxesManager Interface | Aspose.Slides.Charts Namespace


SeriesAxis Property

Aspose.Slides Documentation

IAxesManager.SeriesAxis Property

[Visual Basic]
Property SeriesAxis As IAxis
[C#]
IAxis SeriesAxis {get;}

See Also

IAxesManager Interface | Aspose.Slides.Charts Namespace


VerticalAxis Property

Aspose.Slides Documentation

IAxesManager.VerticalAxis Property

[Visual Basic]
Property VerticalAxis As IAxis
[C#]
IAxis VerticalAxis {get;}

See Also

IAxesManager Interface | Aspose.Slides.Charts Namespace


IAxis Interface

For a list of all members of this type, see IAxis Members.

[Visual Basic]
Public Interface IAxis
Implements IChartComponent, IFormattedTextContainer
[C#]
public interface IAxis : IChartComponent, IFormattedTextContainer

Types that implement IAxis

Type | Description
Axis | Encapsulates the object that represents a chart's axis.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAxis Members | Aspose.Slides.Charts Namespace


IAxis Members

IAxis overview

Public Instance Properties

AsIChartComponent
AsIFormattedTextContainer
AxisBetweenCategories
BaseUnitScale
CrossAt
CrossType
DisplayUnit
Format
HasTitle
IsAutomaticMajorUnit
IsAutomaticMaxValue
IsAutomaticMinorUnit
IsAutomaticMinValue
IsAutomaticTickLabelSpacing
IsLogarithmic
IsNumberFormatLinkedToSource
IsPlotOrderReversed
IsVisible
LogBase
MajorGridLinesFormat
MajorTickMark
MajorUnit
MajorUnitScale
MaxValue
MinorGridLinesFormat
MinorTickMark
MinorUnit
MinorUnitScale
MinValue
NumberFormat
Position
ShowMajorGridLines
ShowMinorGridLines
TickLabelPosition
TickLabelRotationAngle
TickLabelSpacing
Title

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


IAxis Properties

The properties of the IAxis interface are listed below. For a complete list of IAxis interface members, see the IAxis Members topic.

Public Instance Properties

AsIChartComponent
AsIFormattedTextContainer
AxisBetweenCategories
BaseUnitScale
CrossAt
CrossType
DisplayUnit
Format
HasTitle
IsAutomaticMajorUnit
IsAutomaticMaxValue
IsAutomaticMinorUnit
IsAutomaticMinValue
IsAutomaticTickLabelSpacing
IsLogarithmic
IsNumberFormatLinkedToSource
IsPlotOrderReversed
IsVisible
LogBase
MajorGridLinesFormat
MajorTickMark
MajorUnit
MajorUnitScale
MaxValue
MinorGridLinesFormat
MinorTickMark
MinorUnit
MinorUnitScale
MinValue
NumberFormat
Position
ShowMajorGridLines
ShowMinorGridLines
TickLabelPosition
TickLabelRotationAngle
TickLabelSpacing
Title

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


AsIChartComponent Property

Aspose.Slides Documentation

IAxis.AsIChartComponent Property

[Visual Basic]
Property AsIChartComponent As IChartComponent
[C#]
IChartComponent AsIChartComponent {get;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


AsIFormattedTextContainer Property

Aspose.Slides Documentation

IAxis.AsIFormattedTextContainer Property

[Visual Basic]
Property AsIFormattedTextContainer As IFormattedTextContainer
[C#]
IFormattedTextContainer AsIFormattedTextContainer {get;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


AxisBetweenCategories Property

Aspose.Slides Documentation

IAxis.AxisBetweenCategories Property

[Visual Basic]
Property AxisBetweenCategories As Boolean
[C#]
bool AxisBetweenCategories {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


BaseUnitScale Property

Aspose.Slides Documentation

IAxis.BaseUnitScale Property

[Visual Basic]
Property BaseUnitScale As TimeUnitType
[C#]
TimeUnitType BaseUnitScale {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


CrossAt Property

Aspose.Slides Documentation

IAxis.CrossAt Property

[Visual Basic]
Property CrossAt As Single
[C#]
float CrossAt {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


CrossType Property

Aspose.Slides Documentation

IAxis.CrossType Property

[Visual Basic]
Property CrossType As CrossesType
[C#]
CrossesType CrossType {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


DisplayUnit Property

Aspose.Slides Documentation

IAxis.DisplayUnit Property

[Visual Basic]
Property DisplayUnit As DisplayUnitType
[C#]
DisplayUnitType DisplayUnit {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

IAxis.Format Property

[Visual Basic]
Property Format As IAxisFormat
[C#]
IAxisFormat Format {get;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


HasTitle Property

Aspose.Slides Documentation

IAxis.HasTitle Property

[Visual Basic]
Property HasTitle As Boolean
[C#]
bool HasTitle {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


IsAutomaticMajorUnit Property

Aspose.Slides Documentation

IAxis.IsAutomaticMajorUnit Property

[Visual Basic]
Property IsAutomaticMajorUnit As Boolean
[C#]
bool IsAutomaticMajorUnit {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


IsAutomaticMaxValue Property

Aspose.Slides Documentation

IAxis.IsAutomaticMaxValue Property

[Visual Basic]
Property IsAutomaticMaxValue As Boolean
[C#]
bool IsAutomaticMaxValue {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


IsAutomaticMinorUnit Property

Aspose.Slides Documentation

IAxis.IsAutomaticMinorUnit Property

[Visual Basic]
Property IsAutomaticMinorUnit As Boolean
[C#]
bool IsAutomaticMinorUnit {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


IsAutomaticMinValue Property

Aspose.Slides Documentation

IAxis.IsAutomaticMinValue Property

[Visual Basic]
Property IsAutomaticMinValue As Boolean
[C#]
bool IsAutomaticMinValue {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


IsAutomaticTickLabelSpacing Property

Aspose.Slides Documentation

IAxis.IsAutomaticTickLabelSpacing Property

[Visual Basic]
Property IsAutomaticTickLabelSpacing As Boolean
[C#]
bool IsAutomaticTickLabelSpacing {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


IsLogarithmic Property

Aspose.Slides Documentation

IAxis.IsLogarithmic Property

[Visual Basic]
Property IsLogarithmic As Boolean
[C#]
bool IsLogarithmic {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


IsNumberFormatLinkedToSource Property

Aspose.Slides Documentation

IAxis.IsNumberFormatLinkedToSource Property

[Visual Basic]
Property IsNumberFormatLinkedToSource As Boolean
[C#]
bool IsNumberFormatLinkedToSource {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


IsPlotOrderReversed Property

Aspose.Slides Documentation

IAxis.IsPlotOrderReversed Property

[Visual Basic]
Property IsPlotOrderReversed As Boolean
[C#]
bool IsPlotOrderReversed {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


IsVisible Property

Aspose.Slides Documentation

IAxis.IsVisible Property

[Visual Basic]
Property IsVisible As Boolean
[C#]
bool IsVisible {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


LogBase Property

Aspose.Slides Documentation

IAxis.LogBase Property

[Visual Basic]
Property LogBase As Double
[C#]
double LogBase {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


MajorGridLinesFormat Property

Aspose.Slides Documentation

IAxis.MajorGridLinesFormat Property

[Visual Basic]
Property MajorGridLinesFormat As IChartLinesFormat
[C#]
IChartLinesFormat MajorGridLinesFormat {get;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


MajorTickMark Property

Aspose.Slides Documentation

IAxis.MajorTickMark Property

[Visual Basic]
Property MajorTickMark As TickMarkType
[C#]
TickMarkType MajorTickMark {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


MajorUnit Property

Aspose.Slides Documentation

IAxis.MajorUnit Property

[Visual Basic]
Property MajorUnit As Double
[C#]
double MajorUnit {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


MajorUnitScale Property

Aspose.Slides Documentation

IAxis.MajorUnitScale Property

[Visual Basic]
Property MajorUnitScale As TimeUnitType
[C#]
TimeUnitType MajorUnitScale {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


MaxValue Property

Aspose.Slides Documentation

IAxis.MaxValue Property

[Visual Basic]
Property MaxValue As Double
[C#]
double MaxValue {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


MinorGridLinesFormat Property

Aspose.Slides Documentation

IAxis.MinorGridLinesFormat Property

[Visual Basic]
Property MinorGridLinesFormat As IChartLinesFormat
[C#]
IChartLinesFormat MinorGridLinesFormat {get;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


MinorTickMark Property

Aspose.Slides Documentation

IAxis.MinorTickMark Property

[Visual Basic]
Property MinorTickMark As TickMarkType
[C#]
TickMarkType MinorTickMark {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


MinorUnit Property

Aspose.Slides Documentation

IAxis.MinorUnit Property

[Visual Basic]
Property MinorUnit As Double
[C#]
double MinorUnit {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


MinorUnitScale Property

Aspose.Slides Documentation

IAxis.MinorUnitScale Property

[Visual Basic]
Property MinorUnitScale As TimeUnitType
[C#]
TimeUnitType MinorUnitScale {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


MinValue Property

Aspose.Slides Documentation

IAxis.MinValue Property

[Visual Basic]
Property MinValue As Double
[C#]
double MinValue {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


NumberFormat Property

Aspose.Slides Documentation

IAxis.NumberFormat Property

[Visual Basic]
Property NumberFormat As String
[C#]
string NumberFormat {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


Position Property

Aspose.Slides Documentation

IAxis.Position Property

[Visual Basic]
Property Position As AxisPositionType
[C#]
AxisPositionType Position {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


ShowMajorGridLines Property

Aspose.Slides Documentation

IAxis.ShowMajorGridLines Property

[Visual Basic]
Property ShowMajorGridLines As Boolean
[C#]
bool ShowMajorGridLines {get;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


ShowMinorGridLines Property

Aspose.Slides Documentation

IAxis.ShowMinorGridLines Property

[Visual Basic]
Property ShowMinorGridLines As Boolean
[C#]
bool ShowMinorGridLines {get;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


TickLabelPosition Property

Aspose.Slides Documentation

IAxis.TickLabelPosition Property

[Visual Basic]
Property TickLabelPosition As TickLabelPositionType
[C#]
TickLabelPositionType TickLabelPosition {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


TickLabelRotationAngle Property

Aspose.Slides Documentation

IAxis.TickLabelRotationAngle Property

[Visual Basic]
Property TickLabelRotationAngle As Single
[C#]
float TickLabelRotationAngle {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


TickLabelSpacing Property

Aspose.Slides Documentation

IAxis.TickLabelSpacing Property

[Visual Basic]
Property TickLabelSpacing As UInt32
[C#]
uint TickLabelSpacing {get; set;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


Title Property

Aspose.Slides Documentation

IAxis.Title Property

[Visual Basic]
Property Title As IChartTitle
[C#]
IChartTitle Title {get;}

See Also

IAxis Interface | Aspose.Slides.Charts Namespace


IAxisFormat Interface

For a list of all members of this type, see IAxisFormat Members.

[Visual Basic]
Public Interface IAxisFormat
[C#]
public interface IAxisFormat

Types that implement IAxisFormat

Type | Description
AxisFormat | Represents chart format properties.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAxisFormat Members | Aspose.Slides.Charts Namespace


IAxisFormat Members

IAxisFormat overview

Public Instance Properties

Effect
Fill
Line

See Also

IAxisFormat Interface | Aspose.Slides.Charts Namespace


IAxisFormat Properties

The properties of the IAxisFormat interface are listed below. For a complete list of IAxisFormat interface members, see the IAxisFormat Members topic.

Public Instance Properties

Effect
Fill
Line

See Also

IAxisFormat Interface | Aspose.Slides.Charts Namespace


Effect Property

Aspose.Slides Documentation

IAxisFormat.Effect Property

[Visual Basic]
Property Effect As IEffectFormat
[C#]
IEffectFormat Effect {get;}

See Also

IAxisFormat Interface | Aspose.Slides.Charts Namespace


Fill Property

Aspose.Slides Documentation

IAxisFormat.Fill Property

[Visual Basic]
Property Fill As IFillFormat
[C#]
IFillFormat Fill {get;}

See Also

IAxisFormat Interface | Aspose.Slides.Charts Namespace


Line Property

Aspose.Slides Documentation

IAxisFormat.Line Property

[Visual Basic]
Property Line As ILineFormat
[C#]
ILineFormat Line {get;}

See Also

IAxisFormat Interface | Aspose.Slides.Charts Namespace


IBaseChartValue Interface

For a list of all members of this type, see IBaseChartValue Members.

Aspose.Slides.Charts.IBaseChartValue
Aspose.Slides.Charts.IDoubleChartValue
Aspose.Slides.Charts.IMultipleCellChartValue
Aspose.Slides.Charts.ISingleCellChartValue
Aspose.Slides.Charts.IStringChartValue
Aspose.Slides.Charts.IStringOrDoubleChartValue

[Visual Basic]
Public Interface IBaseChartValue
[C#]
public interface IBaseChartValue

Types that implement IBaseChartValue

Type | Description
BaseChartValue |
DoubleChartValue | Represent double value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.
StringChartValue | Represent string value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.
StringOrDoubleChartValue | Represent string or double value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBaseChartValue Members | Aspose.Slides.Charts Namespace


IBaseChartValue Members

IBaseChartValue overview

Public Instance Properties

Data
DataSourceType

See Also

IBaseChartValue Interface | Aspose.Slides.Charts Namespace


IBaseChartValue Properties

The properties of the IBaseChartValue interface are listed below. For a complete list of IBaseChartValue interface members, see the IBaseChartValue Members topic.

Public Instance Properties

Data
DataSourceType

See Also

IBaseChartValue Interface | Aspose.Slides.Charts Namespace


Data Property

Aspose.Slides Documentation

IBaseChartValue.Data Property

[Visual Basic]
Property Data As Object
[C#]
object Data {get; set;}

See Also

IBaseChartValue Interface | Aspose.Slides.Charts Namespace


DataSourceType Property

Aspose.Slides Documentation

IBaseChartValue.DataSourceType Property

[Visual Basic]
Property DataSourceType As DataSourceType
[C#]
DataSourceType DataSourceType {get; set;}

See Also

IBaseChartValue Interface | Aspose.Slides.Charts Namespace


IChart Interface

For a list of all members of this type, see IChart Members.

[Visual Basic]
Public Interface IChart
Implements IGraphicalObject, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer, IFormattedTextContainer, IOverrideThemeable, IThemeable
[C#]
public interface IChart : IGraphicalObject, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer, IFormattedTextContainer, IOverrideThemeable, IThemeable

Types that implement IChart

Type | Description
Chart | Represents an graphic chart on a slide.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChart Members | Aspose.Slides.Charts Namespace


IChart Members

IChart overview

Public Instance Properties

AsIFormattedTextContainer
AsIGraphicalObject
AsIOverrideThemeable
Axes
BackWall
ChartData
ChartDataTable
ChartTitle
DisplayBlanksAs
Floor
HasDataTable
HasLegend
HasTitle
Legend
PlotArea
PlotVisibleCellsOnly
Rotation3D
SideWall
Style
Type
UserShapes

See Also

IChart Interface | Aspose.Slides.Charts Namespace


IChart Properties

The properties of the IChart interface are listed below. For a complete list of IChart interface members, see the IChart Members topic.

Public Instance Properties

AsIFormattedTextContainer
AsIGraphicalObject
AsIOverrideThemeable
Axes
BackWall
ChartData
ChartDataTable
ChartTitle
DisplayBlanksAs
Floor
HasDataTable
HasLegend
HasTitle
Legend
PlotArea
PlotVisibleCellsOnly
Rotation3D
SideWall
Style
Type
UserShapes

See Also

IChart Interface | Aspose.Slides.Charts Namespace


AsIFormattedTextContainer Property

Aspose.Slides Documentation

IChart.AsIFormattedTextContainer Property

[Visual Basic]
Property AsIFormattedTextContainer As IFormattedTextContainer
[C#]
IFormattedTextContainer AsIFormattedTextContainer {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


AsIGraphicalObject Property

Aspose.Slides Documentation

IChart.AsIGraphicalObject Property

[Visual Basic]
Property AsIGraphicalObject As IGraphicalObject
[C#]
IGraphicalObject AsIGraphicalObject {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


AsIOverrideThemeable Property

Aspose.Slides Documentation

IChart.AsIOverrideThemeable Property

[Visual Basic]
Property AsIOverrideThemeable As IOverrideThemeable
[C#]
IOverrideThemeable AsIOverrideThemeable {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


Axes Property

Aspose.Slides Documentation

IChart.Axes Property

[Visual Basic]
Property Axes As IAxesManager
[C#]
IAxesManager Axes {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


BackWall Property

Aspose.Slides Documentation

IChart.BackWall Property

[Visual Basic]
Property BackWall As IChartWall
[C#]
IChartWall BackWall {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


ChartData Property

Aspose.Slides Documentation

IChart.ChartData Property

[Visual Basic]
Property ChartData As IChartData
[C#]
IChartData ChartData {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


ChartDataTable Property

Aspose.Slides Documentation

IChart.ChartDataTable Property

[Visual Basic]
Property ChartDataTable As IDataTable
[C#]
IDataTable ChartDataTable {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


ChartTitle Property

Aspose.Slides Documentation

IChart.ChartTitle Property

[Visual Basic]
Property ChartTitle As IChartTitle
[C#]
IChartTitle ChartTitle {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


DisplayBlanksAs Property

Aspose.Slides Documentation

IChart.DisplayBlanksAs Property

[Visual Basic]
Property DisplayBlanksAs As DisplayBlanksAsType
[C#]
DisplayBlanksAsType DisplayBlanksAs {get; set;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


Floor Property

Aspose.Slides Documentation

IChart.Floor Property

[Visual Basic]
Property Floor As IChartWall
[C#]
IChartWall Floor {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


HasDataTable Property

Aspose.Slides Documentation

IChart.HasDataTable Property

[Visual Basic]
Property HasDataTable As Boolean
[C#]
bool HasDataTable {get; set;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


HasLegend Property

Aspose.Slides Documentation

IChart.HasLegend Property

[Visual Basic]
Property HasLegend As Boolean
[C#]
bool HasLegend {get; set;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


HasTitle Property

Aspose.Slides Documentation

IChart.HasTitle Property

[Visual Basic]
Property HasTitle As Boolean
[C#]
bool HasTitle {get; set;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


Legend Property

Aspose.Slides Documentation

IChart.Legend Property

[Visual Basic]
Property Legend As ILegend
[C#]
ILegend Legend {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


PlotArea Property

Aspose.Slides Documentation

IChart.PlotArea Property

[Visual Basic]
Property PlotArea As IChartPlotArea
[C#]
IChartPlotArea PlotArea {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


PlotVisibleCellsOnly Property

Aspose.Slides Documentation

IChart.PlotVisibleCellsOnly Property

[Visual Basic]
Property PlotVisibleCellsOnly As Boolean
[C#]
bool PlotVisibleCellsOnly {get; set;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


Rotation3D Property

Aspose.Slides Documentation

IChart.Rotation3D Property

[Visual Basic]
Property Rotation3D As IRotation3D
[C#]
IRotation3D Rotation3D {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


SideWall Property

Aspose.Slides Documentation

IChart.SideWall Property

[Visual Basic]
Property SideWall As IChartWall
[C#]
IChartWall SideWall {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


Style Property

Aspose.Slides Documentation

IChart.Style Property

[Visual Basic]
Property Style As StyleType
[C#]
StyleType Style {get; set;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


Type Property

Aspose.Slides Documentation

IChart.Type Property

[Visual Basic]
Property Type As ChartType
[C#]
ChartType Type {get; set;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


UserShapes Property

Aspose.Slides Documentation

IChart.UserShapes Property

[Visual Basic]
Property UserShapes As IGroupShape
[C#]
IGroupShape UserShapes {get;}

See Also

IChart Interface | Aspose.Slides.Charts Namespace


IChartCategory Interface

For a list of all members of this type, see IChartCategory Members.

[Visual Basic]
Public Interface IChartCategory
[C#]
public interface IChartCategory

Types that implement IChartCategory

Type | Description
ChartCategory | Represents chart categories.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartCategory Members | Aspose.Slides.Charts Namespace


IChartCategory Members

IChartCategory overview

Public Instance Properties

AsCell |
AsLiteral |
GroupingLevels |
Levels | Obsolete.
UseCell |
Value |

See Also

IChartCategory Interface | Aspose.Slides.Charts Namespace


IChartCategory Properties

The properties of the IChartCategory interface are listed below. For a complete list of IChartCategory interface members, see the IChartCategory Members topic.

Public Instance Properties

AsCell |
AsLiteral |
GroupingLevels |
Levels | Obsolete.
UseCell |
Value |

See Also

IChartCategory Interface | Aspose.Slides.Charts Namespace


AsCell Property

Aspose.Slides Documentation

IChartCategory.AsCell Property

[Visual Basic]
Property AsCell As IChartDataCell
[C#]
IChartDataCell AsCell {get; set;}

See Also

IChartCategory Interface | Aspose.Slides.Charts Namespace


AsLiteral Property

Aspose.Slides Documentation

IChartCategory.AsLiteral Property

[Visual Basic]
Property AsLiteral As Object
[C#]
object AsLiteral {get; set;}

See Also

IChartCategory Interface | Aspose.Slides.Charts Namespace


GroupingLevels Property

Aspose.Slides Documentation

IChartCategory.GroupingLevels Property

[Visual Basic]
Property GroupingLevels As IChartCategoryLevelsManager
[C#]
IChartCategoryLevelsManager GroupingLevels {get;}

See Also

IChartCategory Interface | Aspose.Slides.Charts Namespace


Levels Property

Aspose.Slides Documentation

IChartCategory.Levels Property

NOTE: This property is now obsolete.

Use GroupingLevels property instead. Will be removed after 01.05.2014.

[Visual Basic]
Property Levels As IChartCategoryLevelsManager
[C#]
IChartCategoryLevelsManager Levels {get;}

See Also

IChartCategory Interface | Aspose.Slides.Charts Namespace


UseCell Property

Aspose.Slides Documentation

IChartCategory.UseCell Property

[Visual Basic]
Property UseCell As Boolean
[C#]
bool UseCell {get;}

See Also

IChartCategory Interface | Aspose.Slides.Charts Namespace


Value Property

Aspose.Slides Documentation

IChartCategory.Value Property

[Visual Basic]
Property Value As Object
[C#]
object Value {get; set;}

See Also

IChartCategory Interface | Aspose.Slides.Charts Namespace


IChartCategoryCollection Interface

For a list of all members of this type, see IChartCategoryCollection Members.

[Visual Basic]
Public Interface IChartCategoryCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Charts.IChartCategory, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IChartCategoryCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IChartCategoryCollection

Type | Description
ChartCategoryCollection | Represents collection of ChartCategory

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartCategoryCollection Members | Aspose.Slides.Charts Namespace


IChartCategoryCollection Members

IChartCategoryCollection overview

Public Instance Properties

AsICollection |
AsIEnumerable |
GroupingLevelCount |
Item |
LevelCount | Obsolete.
UseCells |

Public Instance Methods

Add | Overloaded.
Clear |
IndexOf |
Remove |

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


IChartCategoryCollection Properties

The properties of the IChartCategoryCollection interface are listed below. For a complete list of IChartCategoryCollection interface members, see the IChartCategoryCollection Members topic.

Public Instance Properties

AsICollection |
AsIEnumerable |
GroupingLevelCount |
Item |
LevelCount | Obsolete.
UseCells |

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


AsICollection Property

Aspose.Slides Documentation

IChartCategoryCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IChartCategoryCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


GroupingLevelCount Property

Aspose.Slides Documentation

IChartCategoryCollection.GroupingLevelCount Property

[Visual Basic]
Property GroupingLevelCount As Integer
[C#]
int GroupingLevelCount {get;}

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

IChartCategoryCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IChartCategory
[C#]
IChartCategory this[
int index
] {get;}

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


LevelCount Property

Aspose.Slides Documentation

IChartCategoryCollection.LevelCount Property

NOTE: This property is now obsolete.

Use GroupingLevelCount property instead. Will be removed after 01.05.2014.

[Visual Basic]
Property LevelCount As Integer
[C#]
int LevelCount {get;}

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


UseCells Property

Aspose.Slides Documentation

IChartCategoryCollection.UseCells Property

[Visual Basic]
Property UseCells As Boolean
[C#]
bool UseCells {get; set;}

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


IChartCategoryCollection Methods

The methods of the IChartCategoryCollection interface are listed below. For a complete list of IChartCategoryCollection interface members, see the IChartCategoryCollection Members topic.

Public Instance Methods

Add | Overloaded.
Clear |
IndexOf |
Remove |

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


Add Method

Aspose.Slides Documentation

IChartCategoryCollection.Add Method

Overload List

IChartCategory Add(IChartDataCell);

IChartCategory Add(object);

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


IChartCategoryCollection.Add Method (IChartDataCell)

[Visual Basic]
Function Add( _
ByVal chartDataCell As IChartDataCell _
) As IChartCategory
[C#]
IChartCategory Add(
IChartDataCell chartDataCell
);

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace | IChartCategoryCollection.Add Overload List


IChartCategoryCollection.Add Method (Object)

[Visual Basic]
Function Add( _
ByVal value As Object _
) As IChartCategory
[C#]
IChartCategory Add(
object value
);

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace | IChartCategoryCollection.Add Overload List


IChartCategoryCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


IChartCategoryCollection.IndexOf Method

[Visual Basic]
Function IndexOf( _
ByVal value As IChartCategory _
) As Integer
[C#]
int IndexOf(
IChartCategory value
);

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


IChartCategoryCollection.Remove Method

[Visual Basic]
Sub Remove( _
ByVal value As IChartCategory _
)
[C#]
void Remove(
IChartCategory value
);

See Also

IChartCategoryCollection Interface | Aspose.Slides.Charts Namespace


IChartCategoryLevelsManager Interface

For a list of all members of this type, see IChartCategoryLevelsManager Members.

[Visual Basic]
Public Interface IChartCategoryLevelsManager
[C#]
public interface IChartCategoryLevelsManager

Types that implement IChartCategoryLevelsManager

Type | Description
ChartCategoryLevelsManager | Managed container of the values of the chart category levels.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartCategoryLevelsManager Members | Aspose.Slides.Charts Namespace


IChartCategoryLevelsManager Members

IChartCategoryLevelsManager overview

Public Instance Properties

Item

Public Instance Methods

DeleteGroupingItem |
DeleteValueOfLevel | Obsolete.
SetGroupingItem | Overloaded.
SetValueOfLevel | Obsolete.

See Also

IChartCategoryLevelsManager Interface | Aspose.Slides.Charts Namespace


IChartCategoryLevelsManager Properties

The properties of the IChartCategoryLevelsManager interface are listed below. For a complete list of IChartCategoryLevelsManager interface members, see the IChartCategoryLevelsManager Members topic.

Public Instance Properties

Item

See Also

IChartCategoryLevelsManager Interface | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

IChartCategoryLevelsManager.Item Property

[Visual Basic]
Property Item( _
ByVal level As Integer _
) As IChartDataCell
[C#]
IChartDataCell this[
int level
] {get;}

See Also

IChartCategoryLevelsManager Interface | Aspose.Slides.Charts Namespace


IChartCategoryLevelsManager Methods

The methods of the IChartCategoryLevelsManager interface are listed below. For a complete list of IChartCategoryLevelsManager interface members, see the IChartCategoryLevelsManager Members topic.

Public Instance Methods

DeleteGroupingItem |
DeleteValueOfLevel | Obsolete.
SetGroupingItem | Overloaded.
SetValueOfLevel | Obsolete.

See Also

IChartCategoryLevelsManager Interface | Aspose.Slides.Charts Namespace


IChartCategoryLevelsManager.DeleteGroupingItem Method

[Visual Basic]
Sub DeleteGroupingItem( _
ByVal level As Integer _
)
[C#]
void DeleteGroupingItem(
int level
);

See Also

IChartCategoryLevelsManager Interface | Aspose.Slides.Charts Namespace


IChartCategoryLevelsManager.DeleteValueOfLevel Method

NOTE: This method is now obsolete.

Use DeleteGroupingItem method instead. Will be removed after 01.05.2014.

[Visual Basic]
Sub DeleteValueOfLevel( _
ByVal level As Integer _
)
[C#]
void DeleteValueOfLevel(
int level
);

See Also

IChartCategoryLevelsManager Interface | Aspose.Slides.Charts Namespace


SetGroupingItem Method

Aspose.Slides Documentation

IChartCategoryLevelsManager.SetGroupingItem Method

NOTE: This method is now obsolete.

Use SetGroupingItem(int level, object value) method instead. Will be removed after 01.05.2014.

Overload List

Obsolete.

void SetGroupingItem(int,IChartDataCell);

void SetGroupingItem(int,object);

See Also

IChartCategoryLevelsManager Interface | Aspose.Slides.Charts Namespace


IChartCategoryLevelsManager.SetGroupingItem Method (Int32, IChartDataCell)

NOTE: This method is now obsolete.

Use SetGroupingItem(int level, object value) method instead. Will be removed after 01.05.2014.

[Visual Basic]
Sub SetGroupingItem( _
ByVal level As Integer, _
ByVal value As IChartDataCell _
)
[C#]
void SetGroupingItem(
int level,
IChartDataCell value
);

See Also

IChartCategoryLevelsManager Interface | Aspose.Slides.Charts Namespace | IChartCategoryLevelsManager.SetGroupingItem Overload List


IChartCategoryLevelsManager.SetGroupingItem Method (Int32, Object)

[Visual Basic]
Sub SetGroupingItem( _
ByVal level As Integer, _
ByVal value As Object _
)
[C#]
void SetGroupingItem(
int level,
object value
);

See Also

IChartCategoryLevelsManager Interface | Aspose.Slides.Charts Namespace | IChartCategoryLevelsManager.SetGroupingItem Overload List


IChartCategoryLevelsManager.SetValueOfLevel Method

NOTE: This method is now obsolete.

Use SetGroupingItem(int level, object value) method instead. Will be removed after 01.05.2014.

[Visual Basic]
Sub SetValueOfLevel( _
ByVal level As Integer, _
ByVal value As IChartDataCell _
)
[C#]
void SetValueOfLevel(
int level,
IChartDataCell value
);

See Also

IChartCategoryLevelsManager Interface | Aspose.Slides.Charts Namespace


IChartCellCollection Interface

For a list of all members of this type, see IChartCellCollection Members.

[Visual Basic]
Public Interface IChartCellCollection
Implements IEnumerable`1([Aspose.Slides.Charts.IChartDataCell, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public interface IChartCellCollection : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Types that implement IChartCellCollection

Type | Description
ChartCellCollection | Represents collection of a cells with data.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartCellCollection Members | Aspose.Slides.Charts Namespace


IChartCellCollection Members

IChartCellCollection overview

Public Instance Properties

AsIEnumerable
Count
Item

Public Instance Methods

Add | Overloaded.
GetCellsAddress |
GetConcatenatedValuesFromCells |
RemoveAt |

See Also

IChartCellCollection Interface | Aspose.Slides.Charts Namespace


IChartCellCollection Properties

The properties of the IChartCellCollection interface are listed below. For a complete list of IChartCellCollection interface members, see the IChartCellCollection Members topic.

Public Instance Properties

AsIEnumerable
Count
Item

See Also

IChartCellCollection Interface | Aspose.Slides.Charts Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IChartCellCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IChartCellCollection Interface | Aspose.Slides.Charts Namespace


Count Property

Aspose.Slides Documentation

IChartCellCollection.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

IChartCellCollection Interface | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

IChartCellCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IChartDataCell
[C#]
IChartDataCell this[
int index
] {get;}

See Also

IChartCellCollection Interface | Aspose.Slides.Charts Namespace


IChartCellCollection Methods

The methods of the IChartCellCollection interface are listed below. For a complete list of IChartCellCollection interface members, see the IChartCellCollection Members topic.

Public Instance Methods

Add | Overloaded.
GetCellsAddress |
GetConcatenatedValuesFromCells |
RemoveAt |

See Also

IChartCellCollection Interface | Aspose.Slides.Charts Namespace


Add Method

Aspose.Slides Documentation

IChartCellCollection.Add Method

Overload List

void Add(IChartDataCell);

void Add(object);

See Also

IChartCellCollection Interface | Aspose.Slides.Charts Namespace


IChartCellCollection.Add Method (IChartDataCell)

[Visual Basic]
Sub Add( _
ByVal chartDataCell As IChartDataCell _
)
[C#]
void Add(
IChartDataCell chartDataCell
);

See Also

IChartCellCollection Interface | Aspose.Slides.Charts Namespace | IChartCellCollection.Add Overload List


IChartCellCollection.Add Method (Object)

[Visual Basic]
Sub Add( _
ByVal value As Object _
)
[C#]
void Add(
object value
);

See Also

IChartCellCollection Interface | Aspose.Slides.Charts Namespace | IChartCellCollection.Add Overload List


IChartCellCollection.GetCellsAddress Method

[Visual Basic]
Function GetCellsAddress() As String
[C#]
string GetCellsAddress();

See Also

IChartCellCollection Interface | Aspose.Slides.Charts Namespace


IChartCellCollection.GetConcatenatedValuesFromCells Method

[Visual Basic]
Function GetConcatenatedValuesFromCells() As String
[C#]
string GetConcatenatedValuesFromCells();

See Also

IChartCellCollection Interface | Aspose.Slides.Charts Namespace


IChartCellCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IChartCellCollection Interface | Aspose.Slides.Charts Namespace


IChartComponent Interface

For a list of all members of this type, see IChartComponent Members.

Aspose.Slides.Charts.IChartComponent
Derived interfaces

[Visual Basic]
Public Interface IChartComponent
[C#]
public interface IChartComponent

Types that implement IChartComponent

Type | Description
Axis | Encapsulates the object that represents a chart's axis.
ChartPlotArea | Represents rectangle where chart should be plotted.
ChartSeries | Represents a chart series.
ChartTitle | Represents chart title properties.
DataLabel | Represents a series labels.
DataLabelCollection | Represents a series labels.
DataLabelFormat |
DataTable | Represents data table properties.
Legend | Represents chart's legend properties.
LegendEntryProperties |
Trendline | Class represents trend line of chart series

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartComponent Members | Aspose.Slides.Charts Namespace


IChartComponent Members

IChartComponent overview

Public Instance Properties

Chart

See Also

IChartComponent Interface | Aspose.Slides.Charts Namespace


IChartComponent Properties

The properties of the IChartComponent interface are listed below. For a complete list of IChartComponent interface members, see the IChartComponent Members topic.

Public Instance Properties

Chart

See Also

IChartComponent Interface | Aspose.Slides.Charts Namespace


Chart Property

Aspose.Slides Documentation

IChartComponent.Chart Property

[Visual Basic]
Property Chart As IChart
[C#]
IChart Chart {get;}

See Also

IChartComponent Interface | Aspose.Slides.Charts Namespace


IChartData Interface

For a list of all members of this type, see IChartData Members.

[Visual Basic]
Public Interface IChartData
[C#]
public interface IChartData

Types that implement IChartData

Type | Description
ChartData | Represents data used for a chart plotting.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartData Members | Aspose.Slides.Charts Namespace


IChartData Members

IChartData overview

Public Instance Properties

Categories
ChartDataWorkbook
SecondaryCategories
Series
SeriesGroups
UseSecondaryCategories

Public Instance Methods

ReadWorkbookStream
WriteWorkbookStream

See Also

IChartData Interface | Aspose.Slides.Charts Namespace


IChartData Properties

The properties of the IChartData interface are listed below. For a complete list of IChartData interface members, see the IChartData Members topic.

Public Instance Properties

Categories
ChartDataWorkbook
SecondaryCategories
Series
SeriesGroups
UseSecondaryCategories

See Also

IChartData Interface | Aspose.Slides.Charts Namespace


Categories Property

Aspose.Slides Documentation

IChartData.Categories Property

[Visual Basic]
Property Categories As IChartCategoryCollection
[C#]
IChartCategoryCollection Categories {get;}

See Also

IChartData Interface | Aspose.Slides.Charts Namespace


ChartDataWorkbook Property

Aspose.Slides Documentation

IChartData.ChartDataWorkbook Property

[Visual Basic]
Property ChartDataWorkbook As IChartDataWorkbook
[C#]
IChartDataWorkbook ChartDataWorkbook {get;}

See Also

IChartData Interface | Aspose.Slides.Charts Namespace


SecondaryCategories Property

Aspose.Slides Documentation

IChartData.SecondaryCategories Property

[Visual Basic]
Property SecondaryCategories As IChartCategoryCollection
[C#]
IChartCategoryCollection SecondaryCategories {get;}

See Also

IChartData Interface | Aspose.Slides.Charts Namespace


Series Property

Aspose.Slides Documentation

IChartData.Series Property

[Visual Basic]
Property Series As IChartSeriesCollection
[C#]
IChartSeriesCollection Series {get;}

See Also

IChartData Interface | Aspose.Slides.Charts Namespace


SeriesGroups Property

Aspose.Slides Documentation

IChartData.SeriesGroups Property

[Visual Basic]
Property SeriesGroups As IChartSeriesGroupCollection
[C#]
IChartSeriesGroupCollection SeriesGroups {get;}

See Also

IChartData Interface | Aspose.Slides.Charts Namespace


UseSecondaryCategories Property

Aspose.Slides Documentation

IChartData.UseSecondaryCategories Property

[Visual Basic]
Property UseSecondaryCategories As Boolean
[C#]
bool UseSecondaryCategories {get; set;}

See Also

IChartData Interface | Aspose.Slides.Charts Namespace


IChartData Methods

The methods of the IChartData interface are listed below. For a complete list of IChartData interface members, see the IChartData Members topic.

Public Instance Methods

ReadWorkbookStream
WriteWorkbookStream

See Also

IChartData Interface | Aspose.Slides.Charts Namespace


IChartData.ReadWorkbookStream Method

[Visual Basic]
Function ReadWorkbookStream() As MemoryStream
[C#]
MemoryStream ReadWorkbookStream();

See Also

IChartData Interface | Aspose.Slides.Charts Namespace


IChartData.WriteWorkbookStream Method

[Visual Basic]
Sub WriteWorkbookStream( _
ByVal ms As MemoryStream _
)
[C#]
void WriteWorkbookStream(
MemoryStream ms
);

See Also

IChartData Interface | Aspose.Slides.Charts Namespace


IChartDataCell Interface

For a list of all members of this type, see IChartDataCell Members.

[Visual Basic]
Public Interface IChartDataCell
[C#]
public interface IChartDataCell

Types that implement IChartDataCell

Type | Description
ChartDataCell | Represents cell for chart data

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartDataCell Members | Aspose.Slides.Charts Namespace


IChartDataCell Members

IChartDataCell overview

Public Instance Properties

ChartDataWorksheet
Column
CustomNumberFormat
IsHidden
PresetNumberFormat
Row
Value

See Also

IChartDataCell Interface | Aspose.Slides.Charts Namespace


IChartDataCell Properties

The properties of the IChartDataCell interface are listed below. For a complete list of IChartDataCell interface members, see the IChartDataCell Members topic.

Public Instance Properties

ChartDataWorksheet
Column
CustomNumberFormat
IsHidden
PresetNumberFormat
Row
Value

See Also

IChartDataCell Interface | Aspose.Slides.Charts Namespace


ChartDataWorksheet Property

Aspose.Slides Documentation

IChartDataCell.ChartDataWorksheet Property

[Visual Basic]
Property ChartDataWorksheet As IChartDataWorksheet
[C#]
IChartDataWorksheet ChartDataWorksheet {get;}

See Also

IChartDataCell Interface | Aspose.Slides.Charts Namespace


Column Property

Aspose.Slides Documentation

IChartDataCell.Column Property

[Visual Basic]
Property Column As Integer
[C#]
int Column {get;}

See Also

IChartDataCell Interface | Aspose.Slides.Charts Namespace


CustomNumberFormat Property

Aspose.Slides Documentation

IChartDataCell.CustomNumberFormat Property

[Visual Basic]
Property CustomNumberFormat As String
[C#]
string CustomNumberFormat {get; set;}

See Also

IChartDataCell Interface | Aspose.Slides.Charts Namespace


IsHidden Property

Aspose.Slides Documentation

IChartDataCell.IsHidden Property

[Visual Basic]
Property IsHidden As Boolean
[C#]
bool IsHidden {get;}

See Also

IChartDataCell Interface | Aspose.Slides.Charts Namespace


PresetNumberFormat Property

Aspose.Slides Documentation

IChartDataCell.PresetNumberFormat Property

[Visual Basic]
Property PresetNumberFormat As Byte
[C#]
byte PresetNumberFormat {get; set;}

See Also

IChartDataCell Interface | Aspose.Slides.Charts Namespace


Row Property

Aspose.Slides Documentation

IChartDataCell.Row Property

[Visual Basic]
Property Row As Integer
[C#]
int Row {get;}

See Also

IChartDataCell Interface | Aspose.Slides.Charts Namespace


Value Property

Aspose.Slides Documentation

IChartDataCell.Value Property

[Visual Basic]
Property Value As Object
[C#]
object Value {get; set;}

See Also

IChartDataCell Interface | Aspose.Slides.Charts Namespace


IChartDataPoint Interface

For a list of all members of this type, see IChartDataPoint Members.

[Visual Basic]
Public Interface IChartDataPoint
[C#]
public interface IChartDataPoint

Types that implement IChartDataPoint

Type | Description
ChartDataPoint | Represents series data point.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartDataPoint Members | Aspose.Slides.Charts Namespace


IChartDataPoint Members

IChartDataPoint overview

Public Instance Properties

BubbleSize
Explosion
Format
IsBubble3D
Label
Marker
Value
XValue
YValue

See Also

IChartDataPoint Interface | Aspose.Slides.Charts Namespace


IChartDataPoint Properties

The properties of the IChartDataPoint interface are listed below. For a complete list of IChartDataPoint interface members, see the IChartDataPoint Members topic.

Public Instance Properties

BubbleSize
Explosion
Format
IsBubble3D
Label
Marker
Value
XValue
YValue

See Also

IChartDataPoint Interface | Aspose.Slides.Charts Namespace


BubbleSize Property

Aspose.Slides Documentation

IChartDataPoint.BubbleSize Property

[Visual Basic]
Property BubbleSize As IDoubleChartValue
[C#]
IDoubleChartValue BubbleSize {get;}

See Also

IChartDataPoint Interface | Aspose.Slides.Charts Namespace


Explosion Property

Aspose.Slides Documentation

IChartDataPoint.Explosion Property

[Visual Basic]
Property Explosion As Integer
[C#]
int Explosion {get; set;}

See Also

IChartDataPoint Interface | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

IChartDataPoint.Format Property

[Visual Basic]
Property Format As IFormat
[C#]
IFormat Format {get; set;}

See Also

IChartDataPoint Interface | Aspose.Slides.Charts Namespace


IsBubble3D Property

Aspose.Slides Documentation

IChartDataPoint.IsBubble3D Property

[Visual Basic]
Property IsBubble3D As Boolean
[C#]
bool IsBubble3D {get; set;}

See Also

IChartDataPoint Interface | Aspose.Slides.Charts Namespace


Label Property

Aspose.Slides Documentation

IChartDataPoint.Label Property

[Visual Basic]
Property Label As IDataLabel
[C#]
IDataLabel Label {get;}

See Also

IChartDataPoint Interface | Aspose.Slides.Charts Namespace


Marker Property

Aspose.Slides Documentation

IChartDataPoint.Marker Property

[Visual Basic]
Property Marker As IMarker
[C#]
IMarker Marker {get;}

See Also

IChartDataPoint Interface | Aspose.Slides.Charts Namespace


Value Property

Aspose.Slides Documentation

IChartDataPoint.Value Property

[Visual Basic]
Property Value As IDoubleChartValue
[C#]
IDoubleChartValue Value {get;}

See Also

IChartDataPoint Interface | Aspose.Slides.Charts Namespace


XValue Property

Aspose.Slides Documentation

IChartDataPoint.XValue Property

[Visual Basic]
Property XValue As IStringOrDoubleChartValue
[C#]
IStringOrDoubleChartValue XValue {get;}

See Also

IChartDataPoint Interface | Aspose.Slides.Charts Namespace


YValue Property

Aspose.Slides Documentation

IChartDataPoint.YValue Property

[Visual Basic]
Property YValue As IDoubleChartValue
[C#]
IDoubleChartValue YValue {get;}

See Also

IChartDataPoint Interface | Aspose.Slides.Charts Namespace


IChartDataPointCollection Interface

For a list of all members of this type, see IChartDataPointCollection Members.

[Visual Basic]
Public Interface IChartDataPointCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Charts.IChartDataPoint, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IChartDataPointCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IChartDataPointCollection

Type | Description
ChartDataPointCollection | Represents collection of a series data point.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartDataPointCollection Members | Aspose.Slides.Charts Namespace


IChartDataPointCollection Members

IChartDataPointCollection overview

Public Instance Properties

AsICollection |
AsIEnumerable |
DataSourceTypeForBubbleSizes |
DataSourceTypeForValues |
DataSourceTypeForXValues |
DataSourceTypeForYValues |
Item | Overloaded.

Public Instance Methods

AddDataPointForAreaSeries | Overloaded.
AddDataPointForBarSeries | Overloaded.
AddDataPointForBubbleSeries | Overloaded.
AddDataPointForLineSeries | Overloaded.
AddDataPointForPieSeries | Overloaded.
AddDataPointForRadarSeries | Overloaded.
AddDataPointForScatterSeries | Overloaded.
AddDataPointForSurfaceSeries | Overloaded.
Clear |
GetOrCreateDataPointByIdx |

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


IChartDataPointCollection Properties

The properties of the IChartDataPointCollection interface are listed below. For a complete list of IChartDataPointCollection interface members, see the IChartDataPointCollection Members topic.

Public Instance Properties

AsICollection |
AsIEnumerable |
DataSourceTypeForBubbleSizes |
DataSourceTypeForValues |
DataSourceTypeForXValues |
DataSourceTypeForYValues |
Item | Overloaded.

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


AsICollection Property

Aspose.Slides Documentation

IChartDataPointCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IChartDataPointCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


DataSourceTypeForBubbleSizes Property

Aspose.Slides Documentation

IChartDataPointCollection.DataSourceTypeForBubbleSizes Property

[Visual Basic]
Property DataSourceTypeForBubbleSizes As DataSourceType
[C#]
DataSourceType DataSourceTypeForBubbleSizes {get; set;}

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


DataSourceTypeForValues Property

Aspose.Slides Documentation

IChartDataPointCollection.DataSourceTypeForValues Property

[Visual Basic]
Property DataSourceTypeForValues As DataSourceType
[C#]
DataSourceType DataSourceTypeForValues {get; set;}

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


DataSourceTypeForXValues Property

Aspose.Slides Documentation

IChartDataPointCollection.DataSourceTypeForXValues Property

[Visual Basic]
Property DataSourceTypeForXValues As DataSourceType
[C#]
DataSourceType DataSourceTypeForXValues {get; set;}

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


DataSourceTypeForYValues Property

Aspose.Slides Documentation

IChartDataPointCollection.DataSourceTypeForYValues Property

[Visual Basic]
Property DataSourceTypeForYValues As DataSourceType
[C#]
DataSourceType DataSourceTypeForYValues {get; set;}

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

IChartDataPointCollection.Item Property

Overload List

int this[Aspose.Slides.Charts.IChartDataPoint] {get;}

IChartDataPoint this[int] {get;}

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


Item Property (IChartDataPoint)

Aspose.Slides Documentation

IChartDataPointCollection.Item Property (IChartDataPoint)

[Visual Basic]
Property Item( _
ByVal pt As IChartDataPoint _
) As Integer
[C#]
int this[
Aspose.Slides.Charts.IChartDataPoint pt
] {get;}

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.Item Overload List


Item Property (Int32)

Aspose.Slides Documentation

IChartDataPointCollection.Item Property (Int32)

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IChartDataPoint
[C#]
IChartDataPoint this[
int index
] {get;}

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.Item Overload List


IChartDataPointCollection Methods

The methods of the IChartDataPointCollection interface are listed below. For a complete list of IChartDataPointCollection interface members, see the IChartDataPointCollection Members topic.

Public Instance Methods

AddDataPointForAreaSeries | Overloaded.
AddDataPointForBarSeries | Overloaded.
AddDataPointForBubbleSeries | Overloaded.
AddDataPointForLineSeries | Overloaded.
AddDataPointForPieSeries | Overloaded.
AddDataPointForRadarSeries | Overloaded.
AddDataPointForScatterSeries | Overloaded.
AddDataPointForSurfaceSeries | Overloaded.
Clear |
GetOrCreateDataPointByIdx |

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


AddDataPointForAreaSeries Method

Aspose.Slides Documentation

IChartDataPointCollection.AddDataPointForAreaSeries Method

Overload List

IChartDataPoint AddDataPointForAreaSeries(IChartDataCell);

IChartDataPoint AddDataPointForAreaSeries(double);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


IChartDataPointCollection.AddDataPointForAreaSeries Method (IChartDataCell)

[Visual Basic]
Function AddDataPointForAreaSeries( _
ByVal value As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForAreaSeries(
IChartDataCell value
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForAreaSeries Overload List


IChartDataPointCollection.AddDataPointForAreaSeries Method (Double)

[Visual Basic]
Function AddDataPointForAreaSeries( _
ByVal value As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForAreaSeries(
double value
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForAreaSeries Overload List


AddDataPointForBarSeries Method

Aspose.Slides Documentation

IChartDataPointCollection.AddDataPointForBarSeries Method

Overload List

IChartDataPoint AddDataPointForBarSeries(IChartDataCell);

IChartDataPoint AddDataPointForBarSeries(double);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


IChartDataPointCollection.AddDataPointForBarSeries Method (IChartDataCell)

[Visual Basic]
Function AddDataPointForBarSeries( _
ByVal value As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBarSeries(
IChartDataCell value
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBarSeries Overload List


IChartDataPointCollection.AddDataPointForBarSeries Method (Double)

[Visual Basic]
Function AddDataPointForBarSeries( _
ByVal value As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBarSeries(
double value
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBarSeries Overload List


AddDataPointForBubbleSeries Method

Aspose.Slides Documentation

IChartDataPointCollection.AddDataPointForBubbleSeries Method

Overload List

IChartDataPoint AddDataPointForBubbleSeries(IChartDataCell,IChartDataCell,IChartDataCell);

IChartDataPoint AddDataPointForBubbleSeries(IChartDataCell,IChartDataCell,double);

IChartDataPoint AddDataPointForBubbleSeries(IChartDataCell,double,IChartDataCell);

IChartDataPoint AddDataPointForBubbleSeries(IChartDataCell,double,double);

IChartDataPoint AddDataPointForBubbleSeries(double,IChartDataCell,IChartDataCell);

IChartDataPoint AddDataPointForBubbleSeries(double,IChartDataCell,double);

IChartDataPoint AddDataPointForBubbleSeries(double,double,IChartDataCell);

IChartDataPoint AddDataPointForBubbleSeries(double,double,double);

IChartDataPoint AddDataPointForBubbleSeries(string,IChartDataCell,IChartDataCell);

IChartDataPoint AddDataPointForBubbleSeries(string,IChartDataCell,double);

IChartDataPoint AddDataPointForBubbleSeries(string,double,IChartDataCell);

IChartDataPoint AddDataPointForBubbleSeries(string,double,double);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


IChartDataPointCollection.AddDataPointForBubbleSeries Method (IChartDataCell, IChartDataCell, IChartDataCell)

[Visual Basic]
Function AddDataPointForBubbleSeries( _
ByVal xValue As IChartDataCell, _
ByVal yValue As IChartDataCell, _
ByVal bubbleSize As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBubbleSeries(
IChartDataCell xValue,
IChartDataCell yValue,
IChartDataCell bubbleSize
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBubbleSeries Overload List


IChartDataPointCollection.AddDataPointForBubbleSeries Method (IChartDataCell, IChartDataCell, Double)

[Visual Basic]
Function AddDataPointForBubbleSeries( _
ByVal xValue As IChartDataCell, _
ByVal yValue As IChartDataCell, _
ByVal bubbleSize As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBubbleSeries(
IChartDataCell xValue,
IChartDataCell yValue,
double bubbleSize
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBubbleSeries Overload List


IChartDataPointCollection.AddDataPointForBubbleSeries Method (IChartDataCell, Double, IChartDataCell)

[Visual Basic]
Function AddDataPointForBubbleSeries( _
ByVal xValue As IChartDataCell, _
ByVal yValue As Double, _
ByVal bubbleSize As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBubbleSeries(
IChartDataCell xValue,
double yValue,
IChartDataCell bubbleSize
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBubbleSeries Overload List


IChartDataPointCollection.AddDataPointForBubbleSeries Method (IChartDataCell, Double, Double)

[Visual Basic]
Function AddDataPointForBubbleSeries( _
ByVal xValue As IChartDataCell, _
ByVal yValue As Double, _
ByVal bubbleSize As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBubbleSeries(
IChartDataCell xValue,
double yValue,
double bubbleSize
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBubbleSeries Overload List


IChartDataPointCollection.AddDataPointForBubbleSeries Method (Double, IChartDataCell, IChartDataCell)

[Visual Basic]
Function AddDataPointForBubbleSeries( _
ByVal xValue As Double, _
ByVal yValue As IChartDataCell, _
ByVal bubbleSize As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBubbleSeries(
double xValue,
IChartDataCell yValue,
IChartDataCell bubbleSize
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBubbleSeries Overload List


IChartDataPointCollection.AddDataPointForBubbleSeries Method (Double, IChartDataCell, Double)

[Visual Basic]
Function AddDataPointForBubbleSeries( _
ByVal xValue As Double, _
ByVal yValue As IChartDataCell, _
ByVal bubbleSize As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBubbleSeries(
double xValue,
IChartDataCell yValue,
double bubbleSize
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBubbleSeries Overload List


IChartDataPointCollection.AddDataPointForBubbleSeries Method (Double, Double, IChartDataCell)

[Visual Basic]
Function AddDataPointForBubbleSeries( _
ByVal xValue As Double, _
ByVal yValue As Double, _
ByVal bubbleSize As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBubbleSeries(
double xValue,
double yValue,
IChartDataCell bubbleSize
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBubbleSeries Overload List


IChartDataPointCollection.AddDataPointForBubbleSeries Method (Double, Double, Double)

[Visual Basic]
Function AddDataPointForBubbleSeries( _
ByVal xValue As Double, _
ByVal yValue As Double, _
ByVal bubbleSize As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBubbleSeries(
double xValue,
double yValue,
double bubbleSize
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBubbleSeries Overload List


IChartDataPointCollection.AddDataPointForBubbleSeries Method (String, IChartDataCell, IChartDataCell)

[Visual Basic]
Function AddDataPointForBubbleSeries( _
ByVal xValue As String, _
ByVal yValue As IChartDataCell, _
ByVal bubbleSize As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBubbleSeries(
string xValue,
IChartDataCell yValue,
IChartDataCell bubbleSize
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBubbleSeries Overload List


IChartDataPointCollection.AddDataPointForBubbleSeries Method (String, IChartDataCell, Double)

[Visual Basic]
Function AddDataPointForBubbleSeries( _
ByVal xValue As String, _
ByVal yValue As IChartDataCell, _
ByVal bubbleSize As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBubbleSeries(
string xValue,
IChartDataCell yValue,
double bubbleSize
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBubbleSeries Overload List


IChartDataPointCollection.AddDataPointForBubbleSeries Method (String, Double, IChartDataCell)

[Visual Basic]
Function AddDataPointForBubbleSeries( _
ByVal xValue As String, _
ByVal yValue As Double, _
ByVal bubbleSize As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBubbleSeries(
string xValue,
double yValue,
IChartDataCell bubbleSize
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBubbleSeries Overload List


IChartDataPointCollection.AddDataPointForBubbleSeries Method (String, Double, Double)

[Visual Basic]
Function AddDataPointForBubbleSeries( _
ByVal xValue As String, _
ByVal yValue As Double, _
ByVal bubbleSize As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForBubbleSeries(
string xValue,
double yValue,
double bubbleSize
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForBubbleSeries Overload List


AddDataPointForLineSeries Method

Aspose.Slides Documentation

IChartDataPointCollection.AddDataPointForLineSeries Method

Overload List

IChartDataPoint AddDataPointForLineSeries(IChartDataCell);

IChartDataPoint AddDataPointForLineSeries(double);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


IChartDataPointCollection.AddDataPointForLineSeries Method (IChartDataCell)

[Visual Basic]
Function AddDataPointForLineSeries( _
ByVal value As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForLineSeries(
IChartDataCell value
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForLineSeries Overload List


IChartDataPointCollection.AddDataPointForLineSeries Method (Double)

[Visual Basic]
Function AddDataPointForLineSeries( _
ByVal value As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForLineSeries(
double value
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForLineSeries Overload List


AddDataPointForPieSeries Method

Aspose.Slides Documentation

IChartDataPointCollection.AddDataPointForPieSeries Method

Overload List

IChartDataPoint AddDataPointForPieSeries(IChartDataCell);

IChartDataPoint AddDataPointForPieSeries(double);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


IChartDataPointCollection.AddDataPointForPieSeries Method (IChartDataCell)

[Visual Basic]
Function AddDataPointForPieSeries( _
ByVal value As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForPieSeries(
IChartDataCell value
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForPieSeries Overload List


IChartDataPointCollection.AddDataPointForPieSeries Method (Double)

[Visual Basic]
Function AddDataPointForPieSeries( _
ByVal value As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForPieSeries(
double value
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForPieSeries Overload List


AddDataPointForRadarSeries Method

Aspose.Slides Documentation

IChartDataPointCollection.AddDataPointForRadarSeries Method

Overload List

IChartDataPoint AddDataPointForRadarSeries(IChartDataCell);

IChartDataPoint AddDataPointForRadarSeries(double);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


IChartDataPointCollection.AddDataPointForRadarSeries Method (IChartDataCell)

[Visual Basic]
Function AddDataPointForRadarSeries( _
ByVal value As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForRadarSeries(
IChartDataCell value
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForRadarSeries Overload List


IChartDataPointCollection.AddDataPointForRadarSeries Method (Double)

[Visual Basic]
Function AddDataPointForRadarSeries( _
ByVal value As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForRadarSeries(
double value
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForRadarSeries Overload List


AddDataPointForScatterSeries Method

Aspose.Slides Documentation

IChartDataPointCollection.AddDataPointForScatterSeries Method

Overload List

IChartDataPoint AddDataPointForScatterSeries(IChartDataCell,IChartDataCell);

IChartDataPoint AddDataPointForScatterSeries(IChartDataCell,double);

IChartDataPoint AddDataPointForScatterSeries(double,IChartDataCell);

IChartDataPoint AddDataPointForScatterSeries(double,double);

IChartDataPoint AddDataPointForScatterSeries(string,IChartDataCell);

IChartDataPoint AddDataPointForScatterSeries(string,double);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


IChartDataPointCollection.AddDataPointForScatterSeries Method (IChartDataCell, IChartDataCell)

[Visual Basic]
Function AddDataPointForScatterSeries( _
ByVal xValue As IChartDataCell, _
ByVal yValue As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForScatterSeries(
IChartDataCell xValue,
IChartDataCell yValue
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForScatterSeries Overload List


IChartDataPointCollection.AddDataPointForScatterSeries Method (IChartDataCell, Double)

[Visual Basic]
Function AddDataPointForScatterSeries( _
ByVal xValue As IChartDataCell, _
ByVal yValue As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForScatterSeries(
IChartDataCell xValue,
double yValue
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForScatterSeries Overload List


IChartDataPointCollection.AddDataPointForScatterSeries Method (Double, IChartDataCell)

[Visual Basic]
Function AddDataPointForScatterSeries( _
ByVal xValue As Double, _
ByVal yValue As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForScatterSeries(
double xValue,
IChartDataCell yValue
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForScatterSeries Overload List


IChartDataPointCollection.AddDataPointForScatterSeries Method (Double, Double)

[Visual Basic]
Function AddDataPointForScatterSeries( _
ByVal xValue As Double, _
ByVal yValue As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForScatterSeries(
double xValue,
double yValue
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForScatterSeries Overload List


IChartDataPointCollection.AddDataPointForScatterSeries Method (String, IChartDataCell)

[Visual Basic]
Function AddDataPointForScatterSeries( _
ByVal xValue As String, _
ByVal yValue As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForScatterSeries(
string xValue,
IChartDataCell yValue
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForScatterSeries Overload List


IChartDataPointCollection.AddDataPointForScatterSeries Method (String, Double)

[Visual Basic]
Function AddDataPointForScatterSeries( _
ByVal xValue As String, _
ByVal yValue As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForScatterSeries(
string xValue,
double yValue
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForScatterSeries Overload List


AddDataPointForSurfaceSeries Method

Aspose.Slides Documentation

IChartDataPointCollection.AddDataPointForSurfaceSeries Method

Overload List

IChartDataPoint AddDataPointForSurfaceSeries(IChartDataCell);

IChartDataPoint AddDataPointForSurfaceSeries(double);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


IChartDataPointCollection.AddDataPointForSurfaceSeries Method (IChartDataCell)

[Visual Basic]
Function AddDataPointForSurfaceSeries( _
ByVal value As IChartDataCell _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForSurfaceSeries(
IChartDataCell value
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForSurfaceSeries Overload List


IChartDataPointCollection.AddDataPointForSurfaceSeries Method (Double)

[Visual Basic]
Function AddDataPointForSurfaceSeries( _
ByVal value As Double _
) As IChartDataPoint
[C#]
IChartDataPoint AddDataPointForSurfaceSeries(
double value
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace | IChartDataPointCollection.AddDataPointForSurfaceSeries Overload List


IChartDataPointCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


IChartDataPointCollection.GetOrCreateDataPointByIdx Method

[Visual Basic]
Function GetOrCreateDataPointByIdx( _
ByVal idx As UInt32 _
) As IChartDataPoint
[C#]
IChartDataPoint GetOrCreateDataPointByIdx(
uint idx
);

See Also

IChartDataPointCollection Interface | Aspose.Slides.Charts Namespace


IChartDataWorkbook Interface

For a list of all members of this type, see IChartDataWorkbook Members.

[Visual Basic]
Public Interface IChartDataWorkbook
[C#]
public interface IChartDataWorkbook

Types that implement IChartDataWorkbook

Type | Description
ChartDataWorkbook | Provides access to embedded Excel workbook

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartDataWorkbook Members | Aspose.Slides.Charts Namespace


IChartDataWorkbook Members

IChartDataWorkbook overview

Public Instance Methods

Clear |
GetCell | Overloaded.
GetCellCollection |

See Also

IChartDataWorkbook Interface | Aspose.Slides.Charts Namespace


IChartDataWorkbook Methods

The methods of the IChartDataWorkbook interface are listed below. For a complete list of IChartDataWorkbook interface members, see the IChartDataWorkbook Members topic.

Public Instance Methods

Clear |
GetCell | Overloaded.
GetCellCollection |

See Also

IChartDataWorkbook Interface | Aspose.Slides.Charts Namespace


IChartDataWorkbook.Clear Method

[Visual Basic]
Sub Clear( _
ByVal sheetIndex As Integer _
)
[C#]
void Clear(
int sheetIndex
);

See Also

IChartDataWorkbook Interface | Aspose.Slides.Charts Namespace


GetCell Method

Aspose.Slides Documentation

IChartDataWorkbook.GetCell Method

Overload List

IChartDataCell GetCell(int,int,int);

IChartDataCell GetCell(int,int,int,object);

IChartDataCell GetCell(int,string);

IChartDataCell GetCell(int,string,object);

IChartDataCell GetCell(string,int,int);

See Also

IChartDataWorkbook Interface | Aspose.Slides.Charts Namespace


IChartDataWorkbook.GetCell Method (Int32, Int32, Int32)

[Visual Basic]
Function GetCell( _
ByVal worksheetIndex As Integer, _
ByVal row As Integer, _
ByVal column As Integer _
) As IChartDataCell
[C#]
IChartDataCell GetCell(
int worksheetIndex,
int row,
int column
);

See Also

IChartDataWorkbook Interface | Aspose.Slides.Charts Namespace | IChartDataWorkbook.GetCell Overload List


IChartDataWorkbook.GetCell Method (Int32, Int32, Int32, Object)

[Visual Basic]
Function GetCell( _
ByVal worksheetIndex As Integer, _
ByVal row As Integer, _
ByVal column As Integer, _
ByVal value As Object _
) As IChartDataCell
[C#]
IChartDataCell GetCell(
int worksheetIndex,
int row,
int column,
object value
);

See Also

IChartDataWorkbook Interface | Aspose.Slides.Charts Namespace | IChartDataWorkbook.GetCell Overload List


IChartDataWorkbook.GetCell Method (Int32, String)

[Visual Basic]
Function GetCell( _
ByVal worksheetIndex As Integer, _
ByVal cellName As String _
) As IChartDataCell
[C#]
IChartDataCell GetCell(
int worksheetIndex,
string cellName
);

See Also

IChartDataWorkbook Interface | Aspose.Slides.Charts Namespace | IChartDataWorkbook.GetCell Overload List


IChartDataWorkbook.GetCell Method (Int32, String, Object)

[Visual Basic]
Function GetCell( _
ByVal worksheetIndex As Integer, _
ByVal cellName As String, _
ByVal value As Object _
) As IChartDataCell
[C#]
IChartDataCell GetCell(
int worksheetIndex,
string cellName,
object value
);

See Also

IChartDataWorkbook Interface | Aspose.Slides.Charts Namespace | IChartDataWorkbook.GetCell Overload List


IChartDataWorkbook.GetCell Method (String, Int32, Int32)

[Visual Basic]
Function GetCell( _
ByVal worksheetName As String, _
ByVal row As Integer, _
ByVal column As Integer _
) As IChartDataCell
[C#]
IChartDataCell GetCell(
string worksheetName,
int row,
int column
);

See Also

IChartDataWorkbook Interface | Aspose.Slides.Charts Namespace | IChartDataWorkbook.GetCell Overload List


IChartDataWorkbook.GetCellCollection Method

[Visual Basic]
Function GetCellCollection( _
ByVal formula As String, _
ByVal skipHiddenCells As Boolean _
) As IChartCellCollection
[C#]
IChartCellCollection GetCellCollection(
string formula,
bool skipHiddenCells
);

See Also

IChartDataWorkbook Interface | Aspose.Slides.Charts Namespace


IChartDataWorksheet Interface

For a list of all members of this type, see IChartDataWorksheet Members.

[Visual Basic]
Public Interface IChartDataWorksheet
[C#]
public interface IChartDataWorksheet

Types that implement IChartDataWorksheet

Type | Description
ChartDataWorksheet | Represents worksheet associated with IChartDataCell

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartDataWorksheet Members | Aspose.Slides.Charts Namespace


IChartDataWorksheet Members

IChartDataWorksheet overview

Public Instance Properties

Index
Name

See Also

IChartDataWorksheet Interface | Aspose.Slides.Charts Namespace


IChartDataWorksheet Properties

The properties of the IChartDataWorksheet interface are listed below. For a complete list of IChartDataWorksheet interface members, see the IChartDataWorksheet Members topic.

Public Instance Properties

Index
Name

See Also

IChartDataWorksheet Interface | Aspose.Slides.Charts Namespace


Index Property

Aspose.Slides Documentation

IChartDataWorksheet.Index Property

[Visual Basic]
Property Index As Integer
[C#]
int Index {get;}

See Also

IChartDataWorksheet Interface | Aspose.Slides.Charts Namespace


Name Property

Aspose.Slides Documentation

IChartDataWorksheet.Name Property

[Visual Basic]
Property Name As String
[C#]
string Name {get;}

See Also

IChartDataWorksheet Interface | Aspose.Slides.Charts Namespace


IChartLinesFormat Interface

For a list of all members of this type, see IChartLinesFormat Members.

[Visual Basic]
Public Interface IChartLinesFormat
[C#]
public interface IChartLinesFormat

Types that implement IChartLinesFormat

Type | Description
ChartLinesFormat | Represents gridlines format properties.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartLinesFormat Members | Aspose.Slides.Charts Namespace


IChartLinesFormat Members

IChartLinesFormat overview

Public Instance Properties

Effect
Line

See Also

IChartLinesFormat Interface | Aspose.Slides.Charts Namespace


IChartLinesFormat Properties

The properties of the IChartLinesFormat interface are listed below. For a complete list of IChartLinesFormat interface members, see the IChartLinesFormat Members topic.

Public Instance Properties

Effect
Line

See Also

IChartLinesFormat Interface | Aspose.Slides.Charts Namespace


Effect Property

Aspose.Slides Documentation

IChartLinesFormat.Effect Property

[Visual Basic]
Property Effect As IEffectFormat
[C#]
IEffectFormat Effect {get;}

See Also

IChartLinesFormat Interface | Aspose.Slides.Charts Namespace


Line Property

Aspose.Slides Documentation

IChartLinesFormat.Line Property

[Visual Basic]
Property Line As ILineFormat
[C#]
ILineFormat Line {get;}

See Also

IChartLinesFormat Interface | Aspose.Slides.Charts Namespace


IChartParagraphFormat Interface

For a list of all members of this type, see IChartParagraphFormat Members.

[Visual Basic]
Public Interface IChartParagraphFormat
[C#]
public interface IChartParagraphFormat

Types that implement IChartParagraphFormat

Type | Description
ParagraphFormat | This class contains the paragraph formatting properties. Unlike ParagraphFormatEffectiveData, all properties of this class are writeable.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartParagraphFormat Members | Aspose.Slides.Charts Namespace


IChartParagraphFormat Members

IChartParagraphFormat overview

Public Instance Properties

Alignment
DefaultTabSize
EastAsianLineBreak
FontAlignment
HangingPunctuation
Indent
LatinLineBreak
MarginLeft
MarginRight
RightToLeft
SpaceAfter
SpaceBefore
SpaceWithin
Tabs

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


IChartParagraphFormat Properties

The properties of the IChartParagraphFormat interface are listed below. For a complete list of IChartParagraphFormat interface members, see the IChartParagraphFormat Members topic.

Public Instance Properties

Alignment
DefaultTabSize
EastAsianLineBreak
FontAlignment
HangingPunctuation
Indent
LatinLineBreak
MarginLeft
MarginRight
RightToLeft
SpaceAfter
SpaceBefore
SpaceWithin
Tabs

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


Alignment Property

Aspose.Slides Documentation

IChartParagraphFormat.Alignment Property

[Visual Basic]
Property Alignment As TextAlignment
[C#]
TextAlignment Alignment {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


DefaultTabSize Property

Aspose.Slides Documentation

IChartParagraphFormat.DefaultTabSize Property

[Visual Basic]
Property DefaultTabSize As Single
[C#]
float DefaultTabSize {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


EastAsianLineBreak Property

Aspose.Slides Documentation

IChartParagraphFormat.EastAsianLineBreak Property

[Visual Basic]
Property EastAsianLineBreak As NullableBool
[C#]
NullableBool EastAsianLineBreak {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


FontAlignment Property

Aspose.Slides Documentation

IChartParagraphFormat.FontAlignment Property

[Visual Basic]
Property FontAlignment As FontAlignment
[C#]
FontAlignment FontAlignment {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


HangingPunctuation Property

Aspose.Slides Documentation

IChartParagraphFormat.HangingPunctuation Property

[Visual Basic]
Property HangingPunctuation As NullableBool
[C#]
NullableBool HangingPunctuation {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


Indent Property

Aspose.Slides Documentation

IChartParagraphFormat.Indent Property

[Visual Basic]
Property Indent As Single
[C#]
float Indent {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


LatinLineBreak Property

Aspose.Slides Documentation

IChartParagraphFormat.LatinLineBreak Property

[Visual Basic]
Property LatinLineBreak As NullableBool
[C#]
NullableBool LatinLineBreak {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


MarginLeft Property

Aspose.Slides Documentation

IChartParagraphFormat.MarginLeft Property

[Visual Basic]
Property MarginLeft As Single
[C#]
float MarginLeft {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


MarginRight Property

Aspose.Slides Documentation

IChartParagraphFormat.MarginRight Property

[Visual Basic]
Property MarginRight As Single
[C#]
float MarginRight {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


RightToLeft Property

Aspose.Slides Documentation

IChartParagraphFormat.RightToLeft Property

[Visual Basic]
Property RightToLeft As NullableBool
[C#]
NullableBool RightToLeft {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


SpaceAfter Property

Aspose.Slides Documentation

IChartParagraphFormat.SpaceAfter Property

[Visual Basic]
Property SpaceAfter As Single
[C#]
float SpaceAfter {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


SpaceBefore Property

Aspose.Slides Documentation

IChartParagraphFormat.SpaceBefore Property

[Visual Basic]
Property SpaceBefore As Single
[C#]
float SpaceBefore {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


SpaceWithin Property

Aspose.Slides Documentation

IChartParagraphFormat.SpaceWithin Property

[Visual Basic]
Property SpaceWithin As Single
[C#]
float SpaceWithin {get; set;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


Tabs Property

Aspose.Slides Documentation

IChartParagraphFormat.Tabs Property

[Visual Basic]
Property Tabs As ITabCollection
[C#]
ITabCollection Tabs {get;}

See Also

IChartParagraphFormat Interface | Aspose.Slides.Charts Namespace


IChartPlotArea Interface

For a list of all members of this type, see IChartPlotArea Members.

[Visual Basic]
Public Interface IChartPlotArea
Implements ILayoutable, IChartComponent
[C#]
public interface IChartPlotArea : ILayoutable, IChartComponent

Types that implement IChartPlotArea

Type | Description
ChartPlotArea | Represents rectangle where chart should be plotted.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartPlotArea Members | Aspose.Slides.Charts Namespace


IChartPlotArea Members

IChartPlotArea overview

Public Instance Properties

AsILayoutable
Format

See Also

IChartPlotArea Interface | Aspose.Slides.Charts Namespace


IChartPlotArea Properties

The properties of the IChartPlotArea interface are listed below. For a complete list of IChartPlotArea interface members, see the IChartPlotArea Members topic.

Public Instance Properties

AsILayoutable
Format

See Also

IChartPlotArea Interface | Aspose.Slides.Charts Namespace


AsILayoutable Property

Aspose.Slides Documentation

IChartPlotArea.AsILayoutable Property

[Visual Basic]
Property AsILayoutable As ILayoutable
[C#]
ILayoutable AsILayoutable {get;}

See Also

IChartPlotArea Interface | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

IChartPlotArea.Format Property

[Visual Basic]
Property Format As IFormat
[C#]
IFormat Format {get;}

See Also

IChartPlotArea Interface | Aspose.Slides.Charts Namespace


IChartPortionFormat Interface

For a list of all members of this type, see IChartPortionFormat Members.

[Visual Basic]
Public Interface IChartPortionFormat
[C#]
public interface IChartPortionFormat

Types that implement IChartPortionFormat

Type | Description
PortionFormat | This class contains the text portion formatting properties. Unlike PortionFormatEffectiveData, all properties of this class are writeable.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartPortionFormat Members | Aspose.Slides.Charts Namespace


IChartPortionFormat Members

IChartPortionFormat overview

Public Instance Properties

AlternativeLanguageId
ComplexScriptFont
EastAsianFont
EffectFormat
Escapement
FillFormat
FontBold
FontHeight
FontItalic
FontUnderline
HighlightColor
IsHardUnderlineFill
IsHardUnderlineLine
KerningMinimalSize
Kumimoji
LanguageId
LatinFont
LineFormat
NormaliseHeight
ProofDisabled
Spacing
StrikethroughType
SymbolFont
TextCapType
UnderlineFillFormat
UnderlineLineFormat

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


IChartPortionFormat Properties

The properties of the IChartPortionFormat interface are listed below. For a complete list of IChartPortionFormat interface members, see the IChartPortionFormat Members topic.

Public Instance Properties

AlternativeLanguageId
ComplexScriptFont
EastAsianFont
EffectFormat
Escapement
FillFormat
FontBold
FontHeight
FontItalic
FontUnderline
HighlightColor
IsHardUnderlineFill
IsHardUnderlineLine
KerningMinimalSize
Kumimoji
LanguageId
LatinFont
LineFormat
NormaliseHeight
ProofDisabled
Spacing
StrikethroughType
SymbolFont
TextCapType
UnderlineFillFormat
UnderlineLineFormat

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


AlternativeLanguageId Property

Aspose.Slides Documentation

IChartPortionFormat.AlternativeLanguageId Property

[Visual Basic]
Property AlternativeLanguageId As String
[C#]
string AlternativeLanguageId {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


ComplexScriptFont Property

Aspose.Slides Documentation

IChartPortionFormat.ComplexScriptFont Property

[Visual Basic]
Property ComplexScriptFont As IFontData
[C#]
IFontData ComplexScriptFont {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


EastAsianFont Property

Aspose.Slides Documentation

IChartPortionFormat.EastAsianFont Property

[Visual Basic]
Property EastAsianFont As IFontData
[C#]
IFontData EastAsianFont {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


EffectFormat Property

Aspose.Slides Documentation

IChartPortionFormat.EffectFormat Property

[Visual Basic]
Property EffectFormat As IEffectFormat
[C#]
IEffectFormat EffectFormat {get;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


Escapement Property

Aspose.Slides Documentation

IChartPortionFormat.Escapement Property

[Visual Basic]
Property Escapement As Single
[C#]
float Escapement {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


FillFormat Property

Aspose.Slides Documentation

IChartPortionFormat.FillFormat Property

[Visual Basic]
Property FillFormat As IFillFormat
[C#]
IFillFormat FillFormat {get;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


FontBold Property

Aspose.Slides Documentation

IChartPortionFormat.FontBold Property

[Visual Basic]
Property FontBold As NullableBool
[C#]
NullableBool FontBold {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


FontHeight Property

Aspose.Slides Documentation

IChartPortionFormat.FontHeight Property

[Visual Basic]
Property FontHeight As Single
[C#]
float FontHeight {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


FontItalic Property

Aspose.Slides Documentation

IChartPortionFormat.FontItalic Property

[Visual Basic]
Property FontItalic As NullableBool
[C#]
NullableBool FontItalic {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


FontUnderline Property

Aspose.Slides Documentation

IChartPortionFormat.FontUnderline Property

[Visual Basic]
Property FontUnderline As TextUnderlineType
[C#]
TextUnderlineType FontUnderline {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


HighlightColor Property

Aspose.Slides Documentation

IChartPortionFormat.HighlightColor Property

[Visual Basic]
Property HighlightColor As IColorFormat
[C#]
IColorFormat HighlightColor {get;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


IsHardUnderlineFill Property

Aspose.Slides Documentation

IChartPortionFormat.IsHardUnderlineFill Property

[Visual Basic]
Property IsHardUnderlineFill As NullableBool
[C#]
NullableBool IsHardUnderlineFill {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


IsHardUnderlineLine Property

Aspose.Slides Documentation

IChartPortionFormat.IsHardUnderlineLine Property

[Visual Basic]
Property IsHardUnderlineLine As NullableBool
[C#]
NullableBool IsHardUnderlineLine {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


KerningMinimalSize Property

Aspose.Slides Documentation

IChartPortionFormat.KerningMinimalSize Property

[Visual Basic]
Property KerningMinimalSize As Single
[C#]
float KerningMinimalSize {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


Kumimoji Property

Aspose.Slides Documentation

IChartPortionFormat.Kumimoji Property

[Visual Basic]
Property Kumimoji As NullableBool
[C#]
NullableBool Kumimoji {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


LanguageId Property

Aspose.Slides Documentation

IChartPortionFormat.LanguageId Property

[Visual Basic]
Property LanguageId As String
[C#]
string LanguageId {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


LatinFont Property

Aspose.Slides Documentation

IChartPortionFormat.LatinFont Property

[Visual Basic]
Property LatinFont As IFontData
[C#]
IFontData LatinFont {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


LineFormat Property

Aspose.Slides Documentation

IChartPortionFormat.LineFormat Property

[Visual Basic]
Property LineFormat As ILineFormat
[C#]
ILineFormat LineFormat {get;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


NormaliseHeight Property

Aspose.Slides Documentation

IChartPortionFormat.NormaliseHeight Property

[Visual Basic]
Property NormaliseHeight As NullableBool
[C#]
NullableBool NormaliseHeight {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


ProofDisabled Property

Aspose.Slides Documentation

IChartPortionFormat.ProofDisabled Property

[Visual Basic]
Property ProofDisabled As NullableBool
[C#]
NullableBool ProofDisabled {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


Spacing Property

Aspose.Slides Documentation

IChartPortionFormat.Spacing Property

[Visual Basic]
Property Spacing As Single
[C#]
float Spacing {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


StrikethroughType Property

Aspose.Slides Documentation

IChartPortionFormat.StrikethroughType Property

[Visual Basic]
Property StrikethroughType As TextStrikethroughType
[C#]
TextStrikethroughType StrikethroughType {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


SymbolFont Property

Aspose.Slides Documentation

IChartPortionFormat.SymbolFont Property

[Visual Basic]
Property SymbolFont As IFontData
[C#]
IFontData SymbolFont {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


TextCapType Property

Aspose.Slides Documentation

IChartPortionFormat.TextCapType Property

[Visual Basic]
Property TextCapType As TextCapType
[C#]
TextCapType TextCapType {get; set;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


UnderlineFillFormat Property

Aspose.Slides Documentation

IChartPortionFormat.UnderlineFillFormat Property

[Visual Basic]
Property UnderlineFillFormat As IFillFormat
[C#]
IFillFormat UnderlineFillFormat {get;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


UnderlineLineFormat Property

Aspose.Slides Documentation

IChartPortionFormat.UnderlineLineFormat Property

[Visual Basic]
Property UnderlineLineFormat As ILineFormat
[C#]
ILineFormat UnderlineLineFormat {get;}

See Also

IChartPortionFormat Interface | Aspose.Slides.Charts Namespace


IChartSeries Interface

For a list of all members of this type, see IChartSeries Members.

[Visual Basic]
Public Interface IChartSeries
Implements IChartComponent
[C#]
public interface IChartSeries : IChartComponent

Types that implement IChartSeries

Type | Description
ChartSeries | Represents a chart series.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartSeries Members | Aspose.Slides.Charts Namespace


IChartSeries Members

IChartSeries overview

Public Instance Properties

AsIChartComponent
Bar3DShape
DataPoints
Explosion
Format
GapDepth
GapWidth
HasSeriesLines
HasUpDownBars
InvertIfNegative
IsColorVaried
Labels
Marker
Name
NumberFormatOfBubbleSizes
NumberFormatOfValues
NumberFormatOfXValues
NumberFormatOfYValues
Order
ParentSeriesGroup
PlotOnSecondAxis
Smooth
TrendLines
Type

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


IChartSeries Properties

The properties of the IChartSeries interface are listed below. For a complete list of IChartSeries interface members, see the IChartSeries Members topic.

Public Instance Properties

AsIChartComponent
Bar3DShape
DataPoints
Explosion
Format
GapDepth
GapWidth
HasSeriesLines
HasUpDownBars
InvertIfNegative
IsColorVaried
Labels
Marker
Name
NumberFormatOfBubbleSizes
NumberFormatOfValues
NumberFormatOfXValues
NumberFormatOfYValues
Order
ParentSeriesGroup
PlotOnSecondAxis
Smooth
TrendLines
Type

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


AsIChartComponent Property

Aspose.Slides Documentation

IChartSeries.AsIChartComponent Property

[Visual Basic]
Property AsIChartComponent As IChartComponent
[C#]
IChartComponent AsIChartComponent {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


Bar3DShape Property

Aspose.Slides Documentation

IChartSeries.Bar3DShape Property

[Visual Basic]
Property Bar3DShape As ChartShapeType
[C#]
ChartShapeType Bar3DShape {get; set;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


DataPoints Property

Aspose.Slides Documentation

IChartSeries.DataPoints Property

[Visual Basic]
Property DataPoints As IChartDataPointCollection
[C#]
IChartDataPointCollection DataPoints {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


Explosion Property

Aspose.Slides Documentation

IChartSeries.Explosion Property

[Visual Basic]
Property Explosion As Integer
[C#]
int Explosion {get; set;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

IChartSeries.Format Property

[Visual Basic]
Property Format As IFormat
[C#]
IFormat Format {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


GapDepth Property

Aspose.Slides Documentation

IChartSeries.GapDepth Property

[Visual Basic]
Property GapDepth As Integer
[C#]
int GapDepth {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


GapWidth Property

Aspose.Slides Documentation

IChartSeries.GapWidth Property

[Visual Basic]
Property GapWidth As Integer
[C#]
int GapWidth {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


HasSeriesLines Property

Aspose.Slides Documentation

IChartSeries.HasSeriesLines Property

[Visual Basic]
Property HasSeriesLines As Boolean
[C#]
bool HasSeriesLines {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


HasUpDownBars Property

Aspose.Slides Documentation

IChartSeries.HasUpDownBars Property

[Visual Basic]
Property HasUpDownBars As Boolean
[C#]
bool HasUpDownBars {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


InvertIfNegative Property

Aspose.Slides Documentation

IChartSeries.InvertIfNegative Property

[Visual Basic]
Property InvertIfNegative As Boolean
[C#]
bool InvertIfNegative {get; set;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


IsColorVaried Property

Aspose.Slides Documentation

IChartSeries.IsColorVaried Property

[Visual Basic]
Property IsColorVaried As Boolean
[C#]
bool IsColorVaried {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


Labels Property

Aspose.Slides Documentation

IChartSeries.Labels Property

[Visual Basic]
Property Labels As IDataLabelCollection
[C#]
IDataLabelCollection Labels {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


Marker Property

Aspose.Slides Documentation

IChartSeries.Marker Property

[Visual Basic]
Property Marker As IMarker
[C#]
IMarker Marker {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


Name Property

Aspose.Slides Documentation

IChartSeries.Name Property

[Visual Basic]
Property Name As IStringChartValue
[C#]
IStringChartValue Name {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


NumberFormatOfBubbleSizes Property

Aspose.Slides Documentation

IChartSeries.NumberFormatOfBubbleSizes Property

[Visual Basic]
Property NumberFormatOfBubbleSizes As String
[C#]
string NumberFormatOfBubbleSizes {get; set;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


NumberFormatOfValues Property

Aspose.Slides Documentation

IChartSeries.NumberFormatOfValues Property

[Visual Basic]
Property NumberFormatOfValues As String
[C#]
string NumberFormatOfValues {get; set;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


NumberFormatOfXValues Property

Aspose.Slides Documentation

IChartSeries.NumberFormatOfXValues Property

[Visual Basic]
Property NumberFormatOfXValues As String
[C#]
string NumberFormatOfXValues {get; set;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


NumberFormatOfYValues Property

Aspose.Slides Documentation

IChartSeries.NumberFormatOfYValues Property

[Visual Basic]
Property NumberFormatOfYValues As String
[C#]
string NumberFormatOfYValues {get; set;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


Order Property

Aspose.Slides Documentation

IChartSeries.Order Property

[Visual Basic]
Property Order As Integer
[C#]
int Order {get; set;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


ParentSeriesGroup Property

Aspose.Slides Documentation

IChartSeries.ParentSeriesGroup Property

[Visual Basic]
Property ParentSeriesGroup As IChartSeriesGroup
[C#]
IChartSeriesGroup ParentSeriesGroup {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


PlotOnSecondAxis Property

Aspose.Slides Documentation

IChartSeries.PlotOnSecondAxis Property

[Visual Basic]
Property PlotOnSecondAxis As Boolean
[C#]
bool PlotOnSecondAxis {get; set;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


Smooth Property

Aspose.Slides Documentation

IChartSeries.Smooth Property

[Visual Basic]
Property Smooth As Boolean
[C#]
bool Smooth {get; set;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


TrendLines Property

Aspose.Slides Documentation

IChartSeries.TrendLines Property

[Visual Basic]
Property TrendLines As ITrendlineCollection
[C#]
ITrendlineCollection TrendLines {get;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


Type Property

Aspose.Slides Documentation

IChartSeries.Type Property

[Visual Basic]
Property Type As ChartType
[C#]
ChartType Type {get; set;}

See Also

IChartSeries Interface | Aspose.Slides.Charts Namespace


IChartSeriesCollection Interface

For a list of all members of this type, see IChartSeriesCollection Members.

[Visual Basic]
Public Interface IChartSeriesCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Charts.IChartSeries, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IChartSeriesCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IChartSeriesCollection

Type | Description
ChartSeriesCollection | Represents collection of ChartSeries

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartSeriesCollection Members | Aspose.Slides.Charts Namespace


IChartSeriesCollection Members

IChartSeriesCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

Public Instance Methods

Add | Overloaded.
Clear |
IndexOf |
Insert |
Remove |
RemoveAt |

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace


IChartSeriesCollection Properties

The properties of the IChartSeriesCollection interface are listed below. For a complete list of IChartSeriesCollection interface members, see the IChartSeriesCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace


AsICollection Property

Aspose.Slides Documentation

IChartSeriesCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IChartSeriesCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

IChartSeriesCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IChartSeries
[C#]
IChartSeries this[
int index
] {get;}

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace


IChartSeriesCollection Methods

The methods of the IChartSeriesCollection interface are listed below. For a complete list of IChartSeriesCollection interface members, see the IChartSeriesCollection Members topic.

Public Instance Methods

Add | Overloaded.
Clear |
IndexOf |
Insert |
Remove |
RemoveAt |

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace


Add Method

Aspose.Slides Documentation

IChartSeriesCollection.Add Method

Overload List

IChartSeries Add(ChartType);

IChartSeries Add(IChartCellCollection,ChartType);

IChartSeries Add(IChartDataCell,ChartType);

IChartSeries Add(string,ChartType);

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace


IChartSeriesCollection.Add Method (ChartType)

[Visual Basic]
Function Add( _
ByVal type As ChartType _
) As IChartSeries
[C#]
IChartSeries Add(
ChartType type
);

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace | IChartSeriesCollection.Add Overload List


IChartSeriesCollection.Add Method (IChartCellCollection, ChartType)

[Visual Basic]
Function Add( _
ByVal cellsWithSeriesName As IChartCellCollection, _
ByVal type As ChartType _
) As IChartSeries
[C#]
IChartSeries Add(
IChartCellCollection cellsWithSeriesName,
ChartType type
);

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace | IChartSeriesCollection.Add Overload List


IChartSeriesCollection.Add Method (IChartDataCell, ChartType)

[Visual Basic]
Function Add( _
ByVal cellWithSeriesName As IChartDataCell, _
ByVal type As ChartType _
) As IChartSeries
[C#]
IChartSeries Add(
IChartDataCell cellWithSeriesName,
ChartType type
);

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace | IChartSeriesCollection.Add Overload List


IChartSeriesCollection.Add Method (String, ChartType)

[Visual Basic]
Function Add( _
ByVal name As String, _
ByVal type As ChartType _
) As IChartSeries
[C#]
IChartSeries Add(
string name,
ChartType type
);

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace | IChartSeriesCollection.Add Overload List


IChartSeriesCollection.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace


IChartSeriesCollection.IndexOf Method

[Visual Basic]
Function IndexOf( _
ByVal value As IChartSeries _
) As Integer
[C#]
int IndexOf(
IChartSeries value
);

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace


IChartSeriesCollection.Insert Method

[Visual Basic]
Function Insert( _
ByVal index As Integer, _
ByVal type As ChartType _
) As IChartSeries
[C#]
IChartSeries Insert(
int index,
ChartType type
);

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace


IChartSeriesCollection.Remove Method

[Visual Basic]
Sub Remove( _
ByVal value As IChartSeries _
)
[C#]
void Remove(
IChartSeries value
);

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace


IChartSeriesCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IChartSeriesCollection Interface | Aspose.Slides.Charts Namespace


IChartSeriesGroup Interface

For a list of all members of this type, see IChartSeriesGroup Members.

[Visual Basic]
Public Interface IChartSeriesGroup
[C#]
public interface IChartSeriesGroup

Types that implement IChartSeriesGroup

Type | Description
ChartSeriesGroup | Represents group of series.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartSeriesGroup Members | Aspose.Slides.Charts Namespace


IChartSeriesGroup Members

IChartSeriesGroup overview

Public Instance Properties

FirstSliceAngle
GapDepth
GapWidth
HasSeriesLines
IsColorVaried
Item
PlotOnSecondAxis
Series
Type
UpDownBars

See Also

IChartSeriesGroup Interface | Aspose.Slides.Charts Namespace


IChartSeriesGroup Properties

The properties of the IChartSeriesGroup interface are listed below. For a complete list of IChartSeriesGroup interface members, see the IChartSeriesGroup Members topic.

Public Instance Properties

FirstSliceAngle
GapDepth
GapWidth
HasSeriesLines
IsColorVaried
Item
PlotOnSecondAxis
Series
Type
UpDownBars

See Also

IChartSeriesGroup Interface | Aspose.Slides.Charts Namespace


FirstSliceAngle Property

Aspose.Slides Documentation

IChartSeriesGroup.FirstSliceAngle Property

[Visual Basic]
Property FirstSliceAngle As UInt16
[C#]
ushort FirstSliceAngle {get; set;}

See Also

IChartSeriesGroup Interface | Aspose.Slides.Charts Namespace


GapDepth Property

Aspose.Slides Documentation

IChartSeriesGroup.GapDepth Property

[Visual Basic]
Property GapDepth As UInt16
[C#]
ushort GapDepth {get; set;}

See Also

IChartSeriesGroup Interface | Aspose.Slides.Charts Namespace


GapWidth Property

Aspose.Slides Documentation

IChartSeriesGroup.GapWidth Property

[Visual Basic]
Property GapWidth As UInt16
[C#]
ushort GapWidth {get; set;}

See Also

IChartSeriesGroup Interface | Aspose.Slides.Charts Namespace


HasSeriesLines Property

Aspose.Slides Documentation

IChartSeriesGroup.HasSeriesLines Property

[Visual Basic]
Property HasSeriesLines As Boolean
[C#]
bool HasSeriesLines {get; set;}

See Also

IChartSeriesGroup Interface | Aspose.Slides.Charts Namespace


IsColorVaried Property

Aspose.Slides Documentation

IChartSeriesGroup.IsColorVaried Property

[Visual Basic]
Property IsColorVaried As Boolean
[C#]
bool IsColorVaried {get; set;}

See Also

IChartSeriesGroup Interface | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

IChartSeriesGroup.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IChartSeries
[C#]
IChartSeries this[
int index
] {get;}

See Also

IChartSeriesGroup Interface | Aspose.Slides.Charts Namespace


PlotOnSecondAxis Property

Aspose.Slides Documentation

IChartSeriesGroup.PlotOnSecondAxis Property

[Visual Basic]
Property PlotOnSecondAxis As Boolean
[C#]
bool PlotOnSecondAxis {get;}

See Also

IChartSeriesGroup Interface | Aspose.Slides.Charts Namespace


Series Property

Aspose.Slides Documentation

IChartSeriesGroup.Series Property

[Visual Basic]
Property Series As IChartSeriesReadonlyCollection
[C#]
IChartSeriesReadonlyCollection Series {get;}

See Also

IChartSeriesGroup Interface | Aspose.Slides.Charts Namespace


Type Property

Aspose.Slides Documentation

IChartSeriesGroup.Type Property

[Visual Basic]
Property Type As CombinableSeriesTypesGroup
[C#]
CombinableSeriesTypesGroup Type {get;}

See Also

IChartSeriesGroup Interface | Aspose.Slides.Charts Namespace


UpDownBars Property

Aspose.Slides Documentation

IChartSeriesGroup.UpDownBars Property

[Visual Basic]
Property UpDownBars As IUpDownBarsManager
[C#]
IUpDownBarsManager UpDownBars {get;}

See Also

IChartSeriesGroup Interface | Aspose.Slides.Charts Namespace


IChartSeriesGroupCollection Interface

For a list of all members of this type, see IChartSeriesGroupCollection Members.

[Visual Basic]
Public Interface IChartSeriesGroupCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Charts.IChartSeriesGroup, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IChartSeriesGroupCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartSeriesGroupCollection Members | Aspose.Slides.Charts Namespace


IChartSeriesGroupCollection Members

IChartSeriesGroupCollection overview

Public Instance Properties

AsICollection |
AsIEnumerable |
Item | Overloaded.

See Also

IChartSeriesGroupCollection Interface | Aspose.Slides.Charts Namespace


IChartSeriesGroupCollection Properties

The properties of the IChartSeriesGroupCollection interface are listed below. For a complete list of IChartSeriesGroupCollection interface members, see the IChartSeriesGroupCollection Members topic.

Public Instance Properties

AsICollection |
AsIEnumerable |
Item | Overloaded.

See Also

IChartSeriesGroupCollection Interface | Aspose.Slides.Charts Namespace


AsICollection Property

Aspose.Slides Documentation

IChartSeriesGroupCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IChartSeriesGroupCollection Interface | Aspose.Slides.Charts Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IChartSeriesGroupCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IChartSeriesGroupCollection Interface | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

IChartSeriesGroupCollection.Item Property

Overload List

IChartSeriesGroup this[Aspose.Slides.Charts.IChartSeries] {get;}

IChartSeriesGroup this[int] {get;}

See Also

IChartSeriesGroupCollection Interface | Aspose.Slides.Charts Namespace


Item Property (IChartSeries)

Aspose.Slides Documentation

IChartSeriesGroupCollection.Item Property (IChartSeries)

[Visual Basic]
Property Item( _
ByVal ofSeries As IChartSeries _
) As IChartSeriesGroup
[C#]
IChartSeriesGroup this[
Aspose.Slides.Charts.IChartSeries ofSeries
] {get;}

See Also

IChartSeriesGroupCollection Interface | Aspose.Slides.Charts Namespace | IChartSeriesGroupCollection.Item Overload List


Item Property (Int32)

Aspose.Slides Documentation

IChartSeriesGroupCollection.Item Property (Int32)

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IChartSeriesGroup
[C#]
IChartSeriesGroup this[
int index
] {get;}

See Also

IChartSeriesGroupCollection Interface | Aspose.Slides.Charts Namespace | IChartSeriesGroupCollection.Item Overload List


IChartSeriesReadonlyCollection Interface

For a list of all members of this type, see IChartSeriesReadonlyCollection Members.

[Visual Basic]
Public Interface IChartSeriesReadonlyCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Charts.IChartSeries, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IChartSeriesReadonlyCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartSeriesReadonlyCollection Members | Aspose.Slides.Charts Namespace


IChartSeriesReadonlyCollection Members

IChartSeriesReadonlyCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IChartSeriesReadonlyCollection Interface | Aspose.Slides.Charts Namespace


IChartSeriesReadonlyCollection Properties

The properties of the IChartSeriesReadonlyCollection interface are listed below. For a complete list of IChartSeriesReadonlyCollection interface members, see the IChartSeriesReadonlyCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IChartSeriesReadonlyCollection Interface | Aspose.Slides.Charts Namespace


AsICollection Property

Aspose.Slides Documentation

IChartSeriesReadonlyCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IChartSeriesReadonlyCollection Interface | Aspose.Slides.Charts Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IChartSeriesReadonlyCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IChartSeriesReadonlyCollection Interface | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

IChartSeriesReadonlyCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IChartSeries
[C#]
IChartSeries this[
int index
] {get;}

See Also

IChartSeriesReadonlyCollection Interface | Aspose.Slides.Charts Namespace


IChartTextBlockFormat Interface

For a list of all members of this type, see IChartTextBlockFormat Members.

[Visual Basic]
Public Interface IChartTextBlockFormat
[C#]
public interface IChartTextBlockFormat

Types that implement IChartTextBlockFormat

Type | Description
TextFrameFormat | Contains the TextFrame's formatting properties.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartTextBlockFormat Members | Aspose.Slides.Charts Namespace


IChartTextBlockFormat Members

IChartTextBlockFormat overview

Public Instance Properties

AnchoringType
CenterText
TextVerticalType

See Also

IChartTextBlockFormat Interface | Aspose.Slides.Charts Namespace


IChartTextBlockFormat Properties

The properties of the IChartTextBlockFormat interface are listed below. For a complete list of IChartTextBlockFormat interface members, see the IChartTextBlockFormat Members topic.

Public Instance Properties

AnchoringType
CenterText
TextVerticalType

See Also

IChartTextBlockFormat Interface | Aspose.Slides.Charts Namespace


AnchoringType Property

Aspose.Slides Documentation

IChartTextBlockFormat.AnchoringType Property

[Visual Basic]
Property AnchoringType As TextAnchorType
[C#]
TextAnchorType AnchoringType {get; set;}

See Also

IChartTextBlockFormat Interface | Aspose.Slides.Charts Namespace


CenterText Property

Aspose.Slides Documentation

IChartTextBlockFormat.CenterText Property

[Visual Basic]
Property CenterText As NullableBool
[C#]
NullableBool CenterText {get; set;}

See Also

IChartTextBlockFormat Interface | Aspose.Slides.Charts Namespace


TextVerticalType Property

Aspose.Slides Documentation

IChartTextBlockFormat.TextVerticalType Property

[Visual Basic]
Property TextVerticalType As TextVerticalType
[C#]
TextVerticalType TextVerticalType {get; set;}

See Also

IChartTextBlockFormat Interface | Aspose.Slides.Charts Namespace


IChartTextFormat Interface

For a list of all members of this type, see IChartTextFormat Members.

[Visual Basic]
Public Interface IChartTextFormat
[C#]
public interface IChartTextFormat

Types that implement IChartTextFormat

Type | Description
ChartTextFormat | Specifies default text formatting for chart text elements.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartTextFormat Members | Aspose.Slides.Charts Namespace


IChartTextFormat Members

IChartTextFormat overview

Public Instance Properties

ParagraphFormat
PortionFormat
TextBlockFormat

Public Instance Methods

CopyFrom
CopyTo

See Also

IChartTextFormat Interface | Aspose.Slides.Charts Namespace


IChartTextFormat Properties

The properties of the IChartTextFormat interface are listed below. For a complete list of IChartTextFormat interface members, see the IChartTextFormat Members topic.

Public Instance Properties

ParagraphFormat
PortionFormat
TextBlockFormat

See Also

IChartTextFormat Interface | Aspose.Slides.Charts Namespace


ParagraphFormat Property

Aspose.Slides Documentation

IChartTextFormat.ParagraphFormat Property

[Visual Basic]
Property ParagraphFormat As IChartParagraphFormat
[C#]
IChartParagraphFormat ParagraphFormat {get;}

See Also

IChartTextFormat Interface | Aspose.Slides.Charts Namespace


PortionFormat Property

Aspose.Slides Documentation

IChartTextFormat.PortionFormat Property

[Visual Basic]
Property PortionFormat As IChartPortionFormat
[C#]
IChartPortionFormat PortionFormat {get;}

See Also

IChartTextFormat Interface | Aspose.Slides.Charts Namespace


TextBlockFormat Property

Aspose.Slides Documentation

IChartTextFormat.TextBlockFormat Property

[Visual Basic]
Property TextBlockFormat As IChartTextBlockFormat
[C#]
IChartTextBlockFormat TextBlockFormat {get;}

See Also

IChartTextFormat Interface | Aspose.Slides.Charts Namespace


IChartTextFormat Methods

The methods of the IChartTextFormat interface are listed below. For a complete list of IChartTextFormat interface members, see the IChartTextFormat Members topic.

Public Instance Methods

CopyFrom
CopyTo

See Also

IChartTextFormat Interface | Aspose.Slides.Charts Namespace


IChartTextFormat.CopyFrom Method

[Visual Basic]
Sub CopyFrom( _
ByVal sourceTextFrame As ITextFrame _
)
[C#]
void CopyFrom(
ITextFrame sourceTextFrame
);

See Also

IChartTextFormat Interface | Aspose.Slides.Charts Namespace


IChartTextFormat.CopyTo Method

[Visual Basic]
Sub CopyTo( _
ByVal destTextFrame As ITextFrame _
)
[C#]
void CopyTo(
ITextFrame destTextFrame
);

See Also

IChartTextFormat Interface | Aspose.Slides.Charts Namespace


IChartTitle Interface

For a list of all members of this type, see IChartTitle Members.

[Visual Basic]
Public Interface IChartTitle
Implements ILayoutable, IChartComponent, IOverridableText, IFormattedTextContainer
[C#]
public interface IChartTitle : ILayoutable, IChartComponent, IOverridableText, IFormattedTextContainer

Types that implement IChartTitle

Type | Description
ChartTitle | Represents chart title properties.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartTitle Members | Aspose.Slides.Charts Namespace


IChartTitle Members

IChartTitle overview

Public Instance Properties

AsILayoutable
AsIOverridableText
Format
Overlay

See Also

IChartTitle Interface | Aspose.Slides.Charts Namespace


IChartTitle Properties

The properties of the IChartTitle interface are listed below. For a complete list of IChartTitle interface members, see the IChartTitle Members topic.

Public Instance Properties

AsILayoutable
AsIOverridableText
Format
Overlay

See Also

IChartTitle Interface | Aspose.Slides.Charts Namespace


AsILayoutable Property

Aspose.Slides Documentation

IChartTitle.AsILayoutable Property

[Visual Basic]
Property AsILayoutable As ILayoutable
[C#]
ILayoutable AsILayoutable {get;}

See Also

IChartTitle Interface | Aspose.Slides.Charts Namespace


AsIOverridableText Property

Aspose.Slides Documentation

IChartTitle.AsIOverridableText Property

[Visual Basic]
Property AsIOverridableText As IOverridableText
[C#]
IOverridableText AsIOverridableText {get;}

See Also

IChartTitle Interface | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

IChartTitle.Format Property

[Visual Basic]
Property Format As IFormat
[C#]
IFormat Format {get;}

See Also

IChartTitle Interface | Aspose.Slides.Charts Namespace


Overlay Property

Aspose.Slides Documentation

IChartTitle.Overlay Property

[Visual Basic]
Property Overlay As Boolean
[C#]
bool Overlay {get; set;}

See Also

IChartTitle Interface | Aspose.Slides.Charts Namespace


IChartWall Interface

For a list of all members of this type, see IChartWall Members.

[Visual Basic]
Public Interface IChartWall
[C#]
public interface IChartWall

Types that implement IChartWall

Type | Description
ChartWall | Represents walls on 3d charts.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IChartWall Members | Aspose.Slides.Charts Namespace


IChartWall Members

IChartWall overview

Public Instance Properties

Format
PictureType
Thickness

See Also

IChartWall Interface | Aspose.Slides.Charts Namespace


IChartWall Properties

The properties of the IChartWall interface are listed below. For a complete list of IChartWall interface members, see the IChartWall Members topic.

Public Instance Properties

Format
PictureType
Thickness

See Also

IChartWall Interface | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

IChartWall.Format Property

[Visual Basic]
Property Format As IFormat
[C#]
IFormat Format {get;}

See Also

IChartWall Interface | Aspose.Slides.Charts Namespace


PictureType Property

Aspose.Slides Documentation

IChartWall.PictureType Property

[Visual Basic]
Property PictureType As PictureType
[C#]
PictureType PictureType {get; set;}

See Also

IChartWall Interface | Aspose.Slides.Charts Namespace


Thickness Property

Aspose.Slides Documentation

IChartWall.Thickness Property

[Visual Basic]
Property Thickness As Integer
[C#]
int Thickness {get; set;}

See Also

IChartWall Interface | Aspose.Slides.Charts Namespace


IDataLabel Interface

For a list of all members of this type, see IDataLabel Members.

[Visual Basic]
Public Interface IDataLabel
Implements ILayoutable, IChartComponent, IOverridableText, IFormattedTextContainer
[C#]
public interface IDataLabel : ILayoutable, IChartComponent, IOverridableText, IFormattedTextContainer

Types that implement IDataLabel

Type | Description
DataLabel | Represents a series labels.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IDataLabel Members | Aspose.Slides.Charts Namespace


IDataLabel Members

IDataLabel overview

Public Instance Properties

AsILayoutable
AsIOverridableText
DataLabelFormat
IsVisible

Public Instance Methods

Hide

See Also

IDataLabel Interface | Aspose.Slides.Charts Namespace


IDataLabel Properties

The properties of the IDataLabel interface are listed below. For a complete list of IDataLabel interface members, see the IDataLabel Members topic.

Public Instance Properties

AsILayoutable
AsIOverridableText
DataLabelFormat
IsVisible

See Also

IDataLabel Interface | Aspose.Slides.Charts Namespace


AsILayoutable Property

Aspose.Slides Documentation

IDataLabel.AsILayoutable Property

[Visual Basic]
Property AsILayoutable As ILayoutable
[C#]
ILayoutable AsILayoutable {get;}

See Also

IDataLabel Interface | Aspose.Slides.Charts Namespace


AsIOverridableText Property

Aspose.Slides Documentation

IDataLabel.AsIOverridableText Property

[Visual Basic]
Property AsIOverridableText As IOverridableText
[C#]
IOverridableText AsIOverridableText {get;}

See Also

IDataLabel Interface | Aspose.Slides.Charts Namespace


DataLabelFormat Property

Aspose.Slides Documentation

IDataLabel.DataLabelFormat Property

[Visual Basic]
Property DataLabelFormat As IDataLabelFormat
[C#]
IDataLabelFormat DataLabelFormat {get;}

See Also

IDataLabel Interface | Aspose.Slides.Charts Namespace


IsVisible Property

Aspose.Slides Documentation

IDataLabel.IsVisible Property

[Visual Basic]
Property IsVisible As Boolean
[C#]
bool IsVisible {get;}

See Also

IDataLabel Interface | Aspose.Slides.Charts Namespace


IDataLabel Methods

The methods of the IDataLabel interface are listed below. For a complete list of IDataLabel interface members, see the IDataLabel Members topic.

Public Instance Methods

Hide

See Also

IDataLabel Interface | Aspose.Slides.Charts Namespace


IDataLabel.Hide Method

[Visual Basic]
Sub Hide()
[C#]
void Hide();

See Also

IDataLabel Interface | Aspose.Slides.Charts Namespace


IDataLabelCollection Interface

For a list of all members of this type, see IDataLabelCollection Members.

[Visual Basic]
Public Interface IDataLabelCollection
Implements IEnumerable, IChartComponent
[C#]
public interface IDataLabelCollection : IEnumerable, IChartComponent

Types that implement IDataLabelCollection

Type | Description
DataLabelCollection | Represents a series labels.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IDataLabelCollection Members | Aspose.Slides.Charts Namespace


IDataLabelCollection Members

IDataLabelCollection overview

Public Instance Properties

AsIChartComponent
AsIEnumerable
Count
CountOfVisibleDataLabels
DefaultDataLabelFormat
IsVisible
Item
ParentSeries

Public Instance Methods

Hide
IndexOf

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


IDataLabelCollection Properties

The properties of the IDataLabelCollection interface are listed below. For a complete list of IDataLabelCollection interface members, see the IDataLabelCollection Members topic.

Public Instance Properties

AsIChartComponent
AsIEnumerable
Count
CountOfVisibleDataLabels
DefaultDataLabelFormat
IsVisible
Item
ParentSeries

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


AsIChartComponent Property

Aspose.Slides Documentation

IDataLabelCollection.AsIChartComponent Property

[Visual Basic]
Property AsIChartComponent As IChartComponent
[C#]
IChartComponent AsIChartComponent {get;}

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IDataLabelCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


Count Property

Aspose.Slides Documentation

IDataLabelCollection.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


CountOfVisibleDataLabels Property

Aspose.Slides Documentation

IDataLabelCollection.CountOfVisibleDataLabels Property

[Visual Basic]
Property CountOfVisibleDataLabels As Integer
[C#]
int CountOfVisibleDataLabels {get;}

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


DefaultDataLabelFormat Property

Aspose.Slides Documentation

IDataLabelCollection.DefaultDataLabelFormat Property

[Visual Basic]
Property DefaultDataLabelFormat As IDataLabelFormat
[C#]
IDataLabelFormat DefaultDataLabelFormat {get;}

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


IsVisible Property

Aspose.Slides Documentation

IDataLabelCollection.IsVisible Property

[Visual Basic]
Property IsVisible As Boolean
[C#]
bool IsVisible {get;}

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

IDataLabelCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IDataLabel
[C#]
IDataLabel this[
int index
] {get;}

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


ParentSeries Property

Aspose.Slides Documentation

IDataLabelCollection.ParentSeries Property

[Visual Basic]
Property ParentSeries As IChartSeries
[C#]
IChartSeries ParentSeries {get;}

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


IDataLabelCollection Methods

The methods of the IDataLabelCollection interface are listed below. For a complete list of IDataLabelCollection interface members, see the IDataLabelCollection Members topic.

Public Instance Methods

Hide
IndexOf

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


IDataLabelCollection.Hide Method

[Visual Basic]
Sub Hide()
[C#]
void Hide();

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


IDataLabelCollection.IndexOf Method

[Visual Basic]
Function IndexOf( _
ByVal value As IDataLabel _
) As Integer
[C#]
int IndexOf(
IDataLabel value
);

See Also

IDataLabelCollection Interface | Aspose.Slides.Charts Namespace


IDataLabelFormat Interface

For a list of all members of this type, see IDataLabelFormat Members.

[Visual Basic]
Public Interface IDataLabelFormat
Implements IChartComponent, IFormattedTextContainer
[C#]
public interface IDataLabelFormat : IChartComponent, IFormattedTextContainer

Types that implement IDataLabelFormat

Type | Description
DataLabelFormat |

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IDataLabelFormat Members | Aspose.Slides.Charts Namespace


IDataLabelFormat Members

IDataLabelFormat overview

Public Instance Properties

AsIChartComponent
AsIFormattedTextContainer
Format
IsNumberFormatLinkedToSource
NumberFormat
Position
Separator
ShowBubbleSize
ShowCategoryName
ShowLeaderLines
ShowLegendKey
ShowPercentage
ShowSeriesName
ShowValue

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


IDataLabelFormat Properties

The properties of the IDataLabelFormat interface are listed below. For a complete list of IDataLabelFormat interface members, see the IDataLabelFormat Members topic.

Public Instance Properties

AsIChartComponent
AsIFormattedTextContainer
Format
IsNumberFormatLinkedToSource
NumberFormat
Position
Separator
ShowBubbleSize
ShowCategoryName
ShowLeaderLines
ShowLegendKey
ShowPercentage
ShowSeriesName
ShowValue

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


AsIChartComponent Property

Aspose.Slides Documentation

IDataLabelFormat.AsIChartComponent Property

[Visual Basic]
Property AsIChartComponent As IChartComponent
[C#]
IChartComponent AsIChartComponent {get;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


AsIFormattedTextContainer Property

Aspose.Slides Documentation

IDataLabelFormat.AsIFormattedTextContainer Property

[Visual Basic]
Property AsIFormattedTextContainer As IFormattedTextContainer
[C#]
IFormattedTextContainer AsIFormattedTextContainer {get;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

IDataLabelFormat.Format Property

[Visual Basic]
Property Format As IFormat
[C#]
IFormat Format {get;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


IsNumberFormatLinkedToSource Property

Aspose.Slides Documentation

IDataLabelFormat.IsNumberFormatLinkedToSource Property

[Visual Basic]
Property IsNumberFormatLinkedToSource As Boolean
[C#]
bool IsNumberFormatLinkedToSource {get; set;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


NumberFormat Property

Aspose.Slides Documentation

IDataLabelFormat.NumberFormat Property

[Visual Basic]
Property NumberFormat As String
[C#]
string NumberFormat {get; set;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


Position Property

Aspose.Slides Documentation

IDataLabelFormat.Position Property

[Visual Basic]
Property Position As LegendDataLabelPosition
[C#]
LegendDataLabelPosition Position {get; set;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


Separator Property

Aspose.Slides Documentation

IDataLabelFormat.Separator Property

[Visual Basic]
Property Separator As String
[C#]
string Separator {get; set;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


ShowBubbleSize Property

Aspose.Slides Documentation

IDataLabelFormat.ShowBubbleSize Property

[Visual Basic]
Property ShowBubbleSize As Boolean
[C#]
bool ShowBubbleSize {get; set;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


ShowCategoryName Property

Aspose.Slides Documentation

IDataLabelFormat.ShowCategoryName Property

[Visual Basic]
Property ShowCategoryName As Boolean
[C#]
bool ShowCategoryName {get; set;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


ShowLeaderLines Property

Aspose.Slides Documentation

IDataLabelFormat.ShowLeaderLines Property

[Visual Basic]
Property ShowLeaderLines As Boolean
[C#]
bool ShowLeaderLines {get; set;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


ShowLegendKey Property

Aspose.Slides Documentation

IDataLabelFormat.ShowLegendKey Property

[Visual Basic]
Property ShowLegendKey As Boolean
[C#]
bool ShowLegendKey {get; set;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


ShowPercentage Property

Aspose.Slides Documentation

IDataLabelFormat.ShowPercentage Property

[Visual Basic]
Property ShowPercentage As Boolean
[C#]
bool ShowPercentage {get; set;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


ShowSeriesName Property

Aspose.Slides Documentation

IDataLabelFormat.ShowSeriesName Property

[Visual Basic]
Property ShowSeriesName As Boolean
[C#]
bool ShowSeriesName {get; set;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


ShowValue Property

Aspose.Slides Documentation

IDataLabelFormat.ShowValue Property

[Visual Basic]
Property ShowValue As Boolean
[C#]
bool ShowValue {get; set;}

See Also

IDataLabelFormat Interface | Aspose.Slides.Charts Namespace


IDataTable Interface

For a list of all members of this type, see IDataTable Members.

[Visual Basic]
Public Interface IDataTable
Implements IChartComponent, IFormattedTextContainer
[C#]
public interface IDataTable : IChartComponent, IFormattedTextContainer

Types that implement IDataTable

Type | Description
DataTable | Represents data table properties.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IDataTable Members | Aspose.Slides.Charts Namespace


IDataTable Members

IDataTable overview

Public Instance Properties

AsIChartComponent
AsIFormattedTextContainer
Format
HasBorderHorizontal
HasBorderOutline
HasBorderVertical
ShowLegendKey

See Also

IDataTable Interface | Aspose.Slides.Charts Namespace


IDataTable Properties

The properties of the IDataTable interface are listed below. For a complete list of IDataTable interface members, see the IDataTable Members topic.

Public Instance Properties

AsIChartComponent
AsIFormattedTextContainer
Format
HasBorderHorizontal
HasBorderOutline
HasBorderVertical
ShowLegendKey

See Also

IDataTable Interface | Aspose.Slides.Charts Namespace


AsIChartComponent Property

Aspose.Slides Documentation

IDataTable.AsIChartComponent Property

[Visual Basic]
Property AsIChartComponent As IChartComponent
[C#]
IChartComponent AsIChartComponent {get;}

See Also

IDataTable Interface | Aspose.Slides.Charts Namespace


AsIFormattedTextContainer Property

Aspose.Slides Documentation

IDataTable.AsIFormattedTextContainer Property

[Visual Basic]
Property AsIFormattedTextContainer As IFormattedTextContainer
[C#]
IFormattedTextContainer AsIFormattedTextContainer {get;}

See Also

IDataTable Interface | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

IDataTable.Format Property

[Visual Basic]
Property Format As IFormat
[C#]
IFormat Format {get;}

See Also

IDataTable Interface | Aspose.Slides.Charts Namespace


HasBorderHorizontal Property

Aspose.Slides Documentation

IDataTable.HasBorderHorizontal Property

[Visual Basic]
Property HasBorderHorizontal As Boolean
[C#]
bool HasBorderHorizontal {get; set;}

See Also

IDataTable Interface | Aspose.Slides.Charts Namespace


HasBorderOutline Property

Aspose.Slides Documentation

IDataTable.HasBorderOutline Property

[Visual Basic]
Property HasBorderOutline As Boolean
[C#]
bool HasBorderOutline {get; set;}

See Also

IDataTable Interface | Aspose.Slides.Charts Namespace


HasBorderVertical Property

Aspose.Slides Documentation

IDataTable.HasBorderVertical Property

[Visual Basic]
Property HasBorderVertical As Boolean
[C#]
bool HasBorderVertical {get; set;}

See Also

IDataTable Interface | Aspose.Slides.Charts Namespace


ShowLegendKey Property

Aspose.Slides Documentation

IDataTable.ShowLegendKey Property

[Visual Basic]
Property ShowLegendKey As Boolean
[C#]
bool ShowLegendKey {get; set;}

See Also

IDataTable Interface | Aspose.Slides.Charts Namespace


IDoubleChartValue Interface

For a list of all members of this type, see IDoubleChartValue Members.

[Visual Basic]
Public Interface IDoubleChartValue
Implements ISingleCellChartValue, IBaseChartValue
[C#]
public interface IDoubleChartValue : ISingleCellChartValue, IBaseChartValue

Types that implement IDoubleChartValue

Type | Description
DoubleChartValue | Represent double value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IDoubleChartValue Members | Aspose.Slides.Charts Namespace


IDoubleChartValue Members

IDoubleChartValue overview

Public Instance Properties

AsISingleCellChartValue
AsLiteralDouble

Public Instance Methods

ToDouble

See Also

IDoubleChartValue Interface | Aspose.Slides.Charts Namespace


IDoubleChartValue Properties

The properties of the IDoubleChartValue interface are listed below. For a complete list of IDoubleChartValue interface members, see the IDoubleChartValue Members topic.

Public Instance Properties

AsISingleCellChartValue
AsLiteralDouble

See Also

IDoubleChartValue Interface | Aspose.Slides.Charts Namespace


AsISingleCellChartValue Property

Aspose.Slides Documentation

IDoubleChartValue.AsISingleCellChartValue Property

[Visual Basic]
Property AsISingleCellChartValue As ISingleCellChartValue
[C#]
ISingleCellChartValue AsISingleCellChartValue {get;}

See Also

IDoubleChartValue Interface | Aspose.Slides.Charts Namespace


AsLiteralDouble Property

Aspose.Slides Documentation

IDoubleChartValue.AsLiteralDouble Property

[Visual Basic]
Property AsLiteralDouble As Double
[C#]
double AsLiteralDouble {get; set;}

See Also

IDoubleChartValue Interface | Aspose.Slides.Charts Namespace


IDoubleChartValue Methods

The methods of the IDoubleChartValue interface are listed below. For a complete list of IDoubleChartValue interface members, see the IDoubleChartValue Members topic.

Public Instance Methods

ToDouble

See Also

IDoubleChartValue Interface | Aspose.Slides.Charts Namespace


IDoubleChartValue.ToDouble Method

[Visual Basic]
Function ToDouble() As Double
[C#]
double ToDouble();

See Also

IDoubleChartValue Interface | Aspose.Slides.Charts Namespace


IFormat Interface

For a list of all members of this type, see IFormat Members.

[Visual Basic]
Public Interface IFormat
[C#]
public interface IFormat

Types that implement IFormat

Type | Description
Format | Represents chart format properties.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFormat Members | Aspose.Slides.Charts Namespace


IFormat Members

IFormat overview

Public Instance Properties

Effect
Effect3D
Fill
Line

See Also

IFormat Interface | Aspose.Slides.Charts Namespace


IFormat Properties

The properties of the IFormat interface are listed below. For a complete list of IFormat interface members, see the IFormat Members topic.

Public Instance Properties

Effect
Effect3D
Fill
Line

See Also

IFormat Interface | Aspose.Slides.Charts Namespace


Effect Property

Aspose.Slides Documentation

IFormat.Effect Property

[Visual Basic]
Property Effect As IEffectFormat
[C#]
IEffectFormat Effect {get;}

See Also

IFormat Interface | Aspose.Slides.Charts Namespace


Effect3D Property

Aspose.Slides Documentation

IFormat.Effect3D Property

[Visual Basic]
Property Effect3D As IThreeDFormat
[C#]
IThreeDFormat Effect3D {get;}

See Also

IFormat Interface | Aspose.Slides.Charts Namespace


Fill Property

Aspose.Slides Documentation

IFormat.Fill Property

[Visual Basic]
Property Fill As IFillFormat
[C#]
IFillFormat Fill {get;}

See Also

IFormat Interface | Aspose.Slides.Charts Namespace


Line Property

Aspose.Slides Documentation

IFormat.Line Property

[Visual Basic]
Property Line As ILineFormat
[C#]
ILineFormat Line {get;}

See Also

IFormat Interface | Aspose.Slides.Charts Namespace


IFormattedTextContainer Interface

For a list of all members of this type, see IFormattedTextContainer Members.

Aspose.Slides.Charts.IFormattedTextContainer
Derived interfaces

[Visual Basic]
Public Interface IFormattedTextContainer
[C#]
public interface IFormattedTextContainer

Types that implement IFormattedTextContainer

Type | Description
Axis | Encapsulates the object that represents a chart's axis.
Chart | Represents an graphic chart on a slide.
ChartTitle | Represents chart title properties.
DataLabel | Represents a series labels.
DataLabelFormat |
DataTable | Represents data table properties.
Legend | Represents chart's legend properties.
LegendEntryProperties |
Trendline | Class represents trend line of chart series

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFormattedTextContainer Members | Aspose.Slides.Charts Namespace


IFormattedTextContainer Members

IFormattedTextContainer overview

Public Instance Properties

TextFormat

See Also

IFormattedTextContainer Interface | Aspose.Slides.Charts Namespace


IFormattedTextContainer Properties

The properties of the IFormattedTextContainer interface are listed below. For a complete list of IFormattedTextContainer interface members, see the IFormattedTextContainer Members topic.

Public Instance Properties

TextFormat

See Also

IFormattedTextContainer Interface | Aspose.Slides.Charts Namespace


TextFormat Property

Aspose.Slides Documentation

IFormattedTextContainer.TextFormat Property

[Visual Basic]
Property TextFormat As IChartTextFormat
[C#]
IChartTextFormat TextFormat {get;}

See Also

IFormattedTextContainer Interface | Aspose.Slides.Charts Namespace


ILayoutable Interface

For a list of all members of this type, see ILayoutable Members.

Aspose.Slides.Charts.ILayoutable
Aspose.Slides.Charts.IChartPlotArea
Aspose.Slides.Charts.IChartTitle
Aspose.Slides.Charts.IDataLabel
Aspose.Slides.Charts.ILegend

[Visual Basic]
Public Interface ILayoutable
Implements IChartComponent
[C#]
public interface ILayoutable : IChartComponent

Types that implement ILayoutable

Type | Description
ChartPlotArea | Represents rectangle where chart should be plotted.
ChartTitle | Represents chart title properties.
DataLabel | Represents a series labels.
Legend | Represents chart's legend properties.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILayoutable Members | Aspose.Slides.Charts Namespace


ILayoutable Members

ILayoutable overview

Public Instance Properties

AsIChartComponent
Bottom
Height
Right
Width
X
Y

See Also

ILayoutable Interface | Aspose.Slides.Charts Namespace


ILayoutable Properties

The properties of the ILayoutable interface are listed below. For a complete list of ILayoutable interface members, see the ILayoutable Members topic.

Public Instance Properties

AsIChartComponent
Bottom
Height
Right
Width
X
Y

See Also

ILayoutable Interface | Aspose.Slides.Charts Namespace


AsIChartComponent Property

Aspose.Slides Documentation

ILayoutable.AsIChartComponent Property

[Visual Basic]
Property AsIChartComponent As IChartComponent
[C#]
IChartComponent AsIChartComponent {get;}

See Also

ILayoutable Interface | Aspose.Slides.Charts Namespace


Bottom Property

Aspose.Slides Documentation

ILayoutable.Bottom Property

[Visual Basic]
Property Bottom As Single
[C#]
float Bottom {get;}

See Also

ILayoutable Interface | Aspose.Slides.Charts Namespace


Height Property

Aspose.Slides Documentation

ILayoutable.Height Property

[Visual Basic]
Property Height As Single
[C#]
float Height {get; set;}

See Also

ILayoutable Interface | Aspose.Slides.Charts Namespace


Right Property

Aspose.Slides Documentation

ILayoutable.Right Property

[Visual Basic]
Property Right As Single
[C#]
float Right {get;}

See Also

ILayoutable Interface | Aspose.Slides.Charts Namespace


Width Property

Aspose.Slides Documentation

ILayoutable.Width Property

[Visual Basic]
Property Width As Single
[C#]
float Width {get; set;}

See Also

ILayoutable Interface | Aspose.Slides.Charts Namespace


X Property

Aspose.Slides Documentation

ILayoutable.X Property

[Visual Basic]
Property X As Single
[C#]
float X {get; set;}

See Also

ILayoutable Interface | Aspose.Slides.Charts Namespace


Y Property

Aspose.Slides Documentation

ILayoutable.Y Property

[Visual Basic]
Property Y As Single
[C#]
float Y {get; set;}

See Also

ILayoutable Interface | Aspose.Slides.Charts Namespace


ILegend Interface

For a list of all members of this type, see ILegend Members.

[Visual Basic]
Public Interface ILegend
Implements ILayoutable, IChartComponent, IFormattedTextContainer
[C#]
public interface ILegend : ILayoutable, IChartComponent, IFormattedTextContainer

Types that implement ILegend

Type | Description
Legend | Represents chart's legend properties.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILegend Members | Aspose.Slides.Charts Namespace


ILegend Members

ILegend overview

Public Instance Properties

AsIFormattedTextContainer
AsILayoutable
Entries
Format
Overlay
Position

See Also

ILegend Interface | Aspose.Slides.Charts Namespace


ILegend Properties

The properties of the ILegend interface are listed below. For a complete list of ILegend interface members, see the ILegend Members topic.

Public Instance Properties

AsIFormattedTextContainer
AsILayoutable
Entries
Format
Overlay
Position

See Also

ILegend Interface | Aspose.Slides.Charts Namespace


AsIFormattedTextContainer Property

Aspose.Slides Documentation

ILegend.AsIFormattedTextContainer Property

[Visual Basic]
Property AsIFormattedTextContainer As IFormattedTextContainer
[C#]
IFormattedTextContainer AsIFormattedTextContainer {get;}

See Also

ILegend Interface | Aspose.Slides.Charts Namespace


AsILayoutable Property

Aspose.Slides Documentation

ILegend.AsILayoutable Property

[Visual Basic]
Property AsILayoutable As ILayoutable
[C#]
ILayoutable AsILayoutable {get;}

See Also

ILegend Interface | Aspose.Slides.Charts Namespace


Entries Property

Aspose.Slides Documentation

ILegend.Entries Property

[Visual Basic]
Property Entries As ILegendEntryCollection
[C#]
ILegendEntryCollection Entries {get;}

See Also

ILegend Interface | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

ILegend.Format Property

[Visual Basic]
Property Format As IFormat
[C#]
IFormat Format {get;}

See Also

ILegend Interface | Aspose.Slides.Charts Namespace


Overlay Property

Aspose.Slides Documentation

ILegend.Overlay Property

[Visual Basic]
Property Overlay As Boolean
[C#]
bool Overlay {get; set;}

See Also

ILegend Interface | Aspose.Slides.Charts Namespace


Position Property

Aspose.Slides Documentation

ILegend.Position Property

[Visual Basic]
Property Position As LegendPositionType
[C#]
LegendPositionType Position {get; set;}

See Also

ILegend Interface | Aspose.Slides.Charts Namespace


ILegendEntryCollection Interface

For a list of all members of this type, see ILegendEntryCollection Members.

[Visual Basic]
Public Interface ILegendEntryCollection
[C#]
public interface ILegendEntryCollection

Types that implement ILegendEntryCollection

Type | Description
LegendEntryCollection |

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILegendEntryCollection Members | Aspose.Slides.Charts Namespace


ILegendEntryCollection Members

ILegendEntryCollection overview

Public Instance Properties

Count
Item

See Also

ILegendEntryCollection Interface | Aspose.Slides.Charts Namespace


ILegendEntryCollection Properties

The properties of the ILegendEntryCollection interface are listed below. For a complete list of ILegendEntryCollection interface members, see the ILegendEntryCollection Members topic.

Public Instance Properties

Count
Item

See Also

ILegendEntryCollection Interface | Aspose.Slides.Charts Namespace


Count Property

Aspose.Slides Documentation

ILegendEntryCollection.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

ILegendEntryCollection Interface | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

ILegendEntryCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As ILegendEntryProperties
[C#]
ILegendEntryProperties this[
int index
] {get;}

See Also

ILegendEntryCollection Interface | Aspose.Slides.Charts Namespace


ILegendEntryProperties Interface

For a list of all members of this type, see ILegendEntryProperties Members.

[Visual Basic]
Public Interface ILegendEntryProperties
Implements IChartComponent, IFormattedTextContainer
[C#]
public interface ILegendEntryProperties : IChartComponent, IFormattedTextContainer

Types that implement ILegendEntryProperties

Type | Description
LegendEntryProperties |

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILegendEntryProperties Members | Aspose.Slides.Charts Namespace


ILegendEntryProperties Members

ILegendEntryProperties overview

Public Instance Properties

AsIChartComponent
AsIFormattedTextContainer
Hide

See Also

ILegendEntryProperties Interface | Aspose.Slides.Charts Namespace


ILegendEntryProperties Properties

The properties of the ILegendEntryProperties interface are listed below. For a complete list of ILegendEntryProperties interface members, see the ILegendEntryProperties Members topic.

Public Instance Properties

AsIChartComponent
AsIFormattedTextContainer
Hide

See Also

ILegendEntryProperties Interface | Aspose.Slides.Charts Namespace


AsIChartComponent Property

Aspose.Slides Documentation

ILegendEntryProperties.AsIChartComponent Property

[Visual Basic]
Property AsIChartComponent As IChartComponent
[C#]
IChartComponent AsIChartComponent {get;}

See Also

ILegendEntryProperties Interface | Aspose.Slides.Charts Namespace


AsIFormattedTextContainer Property

Aspose.Slides Documentation

ILegendEntryProperties.AsIFormattedTextContainer Property

[Visual Basic]
Property AsIFormattedTextContainer As IFormattedTextContainer
[C#]
IFormattedTextContainer AsIFormattedTextContainer {get;}

See Also

ILegendEntryProperties Interface | Aspose.Slides.Charts Namespace


Hide Property

Aspose.Slides Documentation

ILegendEntryProperties.Hide Property

[Visual Basic]
Property Hide As Boolean
[C#]
bool Hide {get; set;}

See Also

ILegendEntryProperties Interface | Aspose.Slides.Charts Namespace


IMarker Interface

For a list of all members of this type, see IMarker Members.

[Visual Basic]
Public Interface IMarker
[C#]
public interface IMarker

Types that implement IMarker

Type | Description
Marker |

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMarker Members | Aspose.Slides.Charts Namespace


IMarker Members

IMarker overview

Public Instance Properties

Format
Size
Symbol

See Also

IMarker Interface | Aspose.Slides.Charts Namespace


IMarker Properties

The properties of the IMarker interface are listed below. For a complete list of IMarker interface members, see the IMarker Members topic.

Public Instance Properties

Format
Size
Symbol

See Also

IMarker Interface | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

IMarker.Format Property

[Visual Basic]
Property Format As IFormat
[C#]
IFormat Format {get;}

See Also

IMarker Interface | Aspose.Slides.Charts Namespace


Size Property

Aspose.Slides Documentation

IMarker.Size Property

[Visual Basic]
Property Size As Integer
[C#]
int Size {get; set;}

See Also

IMarker Interface | Aspose.Slides.Charts Namespace


Symbol Property

Aspose.Slides Documentation

IMarker.Symbol Property

[Visual Basic]
Property Symbol As MarkerStyleType
[C#]
MarkerStyleType Symbol {get; set;}

See Also

IMarker Interface | Aspose.Slides.Charts Namespace


IMultipleCellChartValue Interface

For a list of all members of this type, see IMultipleCellChartValue Members.

Aspose.Slides.Charts.IMultipleCellChartValue
Aspose.Slides.Charts.IStringChartValue

[Visual Basic]
Public Interface IMultipleCellChartValue
Implements IBaseChartValue
[C#]
public interface IMultipleCellChartValue : IBaseChartValue

Types that implement IMultipleCellChartValue

Type | Description
StringChartValue | Represent string value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMultipleCellChartValue Members | Aspose.Slides.Charts Namespace


IMultipleCellChartValue Members

IMultipleCellChartValue overview

Public Instance Properties

AsCells
AsIBaseChartValue

See Also

IMultipleCellChartValue Interface | Aspose.Slides.Charts Namespace


IMultipleCellChartValue Properties

The properties of the IMultipleCellChartValue interface are listed below. For a complete list of IMultipleCellChartValue interface members, see the IMultipleCellChartValue Members topic.

Public Instance Properties

AsCells
AsIBaseChartValue

See Also

IMultipleCellChartValue Interface | Aspose.Slides.Charts Namespace


AsCells Property

Aspose.Slides Documentation

IMultipleCellChartValue.AsCells Property

[Visual Basic]
Property AsCells As IChartCellCollection
[C#]
IChartCellCollection AsCells {get; set;}

See Also

IMultipleCellChartValue Interface | Aspose.Slides.Charts Namespace


AsIBaseChartValue Property

Aspose.Slides Documentation

IMultipleCellChartValue.AsIBaseChartValue Property

[Visual Basic]
Property AsIBaseChartValue As IBaseChartValue
[C#]
IBaseChartValue AsIBaseChartValue {get;}

See Also

IMultipleCellChartValue Interface | Aspose.Slides.Charts Namespace


IOverridableText Interface

For a list of all members of this type, see IOverridableText Members.

Aspose.Slides.Charts.IOverridableText
Aspose.Slides.Charts.IChartTitle
Aspose.Slides.Charts.IDataLabel
Aspose.Slides.Charts.ITrendline

[Visual Basic]
Public Interface IOverridableText
Implements IFormattedTextContainer
[C#]
public interface IOverridableText : IFormattedTextContainer

Types that implement IOverridableText

Type | Description
ChartTitle | Represents chart title properties.
DataLabel | Represents a series labels.
Trendline | Class represents trend line of chart series

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IOverridableText Members | Aspose.Slides.Charts Namespace


IOverridableText Members

IOverridableText overview

Public Instance Properties

AsIFormattedTextContainer
TextFrameForOverriding

Public Instance Methods

AddTextFrameForOverriding

See Also

IOverridableText Interface | Aspose.Slides.Charts Namespace


IOverridableText Properties

The properties of the IOverridableText interface are listed below. For a complete list of IOverridableText interface members, see the IOverridableText Members topic.

Public Instance Properties

AsIFormattedTextContainer
TextFrameForOverriding

See Also

IOverridableText Interface | Aspose.Slides.Charts Namespace


AsIFormattedTextContainer Property

Aspose.Slides Documentation

IOverridableText.AsIFormattedTextContainer Property

[Visual Basic]
Property AsIFormattedTextContainer As IFormattedTextContainer
[C#]
IFormattedTextContainer AsIFormattedTextContainer {get;}

See Also

IOverridableText Interface | Aspose.Slides.Charts Namespace


TextFrameForOverriding Property

Aspose.Slides Documentation

IOverridableText.TextFrameForOverriding Property

[Visual Basic]
Property TextFrameForOverriding As ITextFrame
[C#]
ITextFrame TextFrameForOverriding {get;}

See Also

IOverridableText Interface | Aspose.Slides.Charts Namespace


IOverridableText Methods

The methods of the IOverridableText interface are listed below. For a complete list of IOverridableText interface members, see the IOverridableText Members topic.

Public Instance Methods

AddTextFrameForOverriding

See Also

IOverridableText Interface | Aspose.Slides.Charts Namespace


IOverridableText.AddTextFrameForOverriding Method

[Visual Basic]
Function AddTextFrameForOverriding( _
ByVal text As String _
) As ITextFrame
[C#]
ITextFrame AddTextFrameForOverriding(
string text
);

See Also

IOverridableText Interface | Aspose.Slides.Charts Namespace


IRotation3D Interface

For a list of all members of this type, see IRotation3D Members.

[Visual Basic]
Public Interface IRotation3D
[C#]
public interface IRotation3D

Types that implement IRotation3D

Type | Description
Rotation3D | Represents 3D rotation of a chart.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IRotation3D Members | Aspose.Slides.Charts Namespace


IRotation3D Members

IRotation3D overview

Public Instance Properties

DepthPercents
HeightPercents
Perspective
RightAngleAxes
RotationX
RotationY

See Also

IRotation3D Interface | Aspose.Slides.Charts Namespace


IRotation3D Properties

The properties of the IRotation3D interface are listed below. For a complete list of IRotation3D interface members, see the IRotation3D Members topic.

Public Instance Properties

DepthPercents
HeightPercents
Perspective
RightAngleAxes
RotationX
RotationY

See Also

IRotation3D Interface | Aspose.Slides.Charts Namespace


DepthPercents Property

Aspose.Slides Documentation

IRotation3D.DepthPercents Property

[Visual Basic]
Property DepthPercents As UInt16
[C#]
ushort DepthPercents {get; set;}

See Also

IRotation3D Interface | Aspose.Slides.Charts Namespace


HeightPercents Property

Aspose.Slides Documentation

IRotation3D.HeightPercents Property

[Visual Basic]
Property HeightPercents As UInt16
[C#]
ushort HeightPercents {get; set;}

See Also

IRotation3D Interface | Aspose.Slides.Charts Namespace


Perspective Property

Aspose.Slides Documentation

IRotation3D.Perspective Property

[Visual Basic]
Property Perspective As Byte
[C#]
byte Perspective {get; set;}

See Also

IRotation3D Interface | Aspose.Slides.Charts Namespace


RightAngleAxes Property

Aspose.Slides Documentation

IRotation3D.RightAngleAxes Property

[Visual Basic]
Property RightAngleAxes As Boolean
[C#]
bool RightAngleAxes {get; set;}

See Also

IRotation3D Interface | Aspose.Slides.Charts Namespace


RotationX Property

Aspose.Slides Documentation

IRotation3D.RotationX Property

[Visual Basic]
Property RotationX As SByte
[C#]
sbyte RotationX {get; set;}

See Also

IRotation3D Interface | Aspose.Slides.Charts Namespace


RotationY Property

Aspose.Slides Documentation

IRotation3D.RotationY Property

[Visual Basic]
Property RotationY As UInt16
[C#]
ushort RotationY {get; set;}

See Also

IRotation3D Interface | Aspose.Slides.Charts Namespace


ISingleCellChartValue Interface

For a list of all members of this type, see ISingleCellChartValue Members.

Aspose.Slides.Charts.ISingleCellChartValue
Aspose.Slides.Charts.IDoubleChartValue
Aspose.Slides.Charts.IStringOrDoubleChartValue

[Visual Basic]
Public Interface ISingleCellChartValue
Implements IBaseChartValue
[C#]
public interface ISingleCellChartValue : IBaseChartValue

Types that implement ISingleCellChartValue

Type | Description
DoubleChartValue | Represent double value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.
StringOrDoubleChartValue | Represent string or double value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISingleCellChartValue Members | Aspose.Slides.Charts Namespace


ISingleCellChartValue Members

ISingleCellChartValue overview

Public Instance Properties

AsCell
AsIBaseChartValue

See Also

ISingleCellChartValue Interface | Aspose.Slides.Charts Namespace


ISingleCellChartValue Properties

The properties of the ISingleCellChartValue interface are listed below. For a complete list of ISingleCellChartValue interface members, see the ISingleCellChartValue Members topic.

Public Instance Properties

AsCell
AsIBaseChartValue

See Also

ISingleCellChartValue Interface | Aspose.Slides.Charts Namespace


AsCell Property

Aspose.Slides Documentation

ISingleCellChartValue.AsCell Property

[Visual Basic]
Property AsCell As IChartDataCell
[C#]
IChartDataCell AsCell {get; set;}

See Also

ISingleCellChartValue Interface | Aspose.Slides.Charts Namespace


AsIBaseChartValue Property

Aspose.Slides Documentation

ISingleCellChartValue.AsIBaseChartValue Property

[Visual Basic]
Property AsIBaseChartValue As IBaseChartValue
[C#]
IBaseChartValue AsIBaseChartValue {get;}

See Also

ISingleCellChartValue Interface | Aspose.Slides.Charts Namespace


IStringChartValue Interface

For a list of all members of this type, see IStringChartValue Members.

[Visual Basic]
Public Interface IStringChartValue
Implements IMultipleCellChartValue, IBaseChartValue
[C#]
public interface IStringChartValue : IMultipleCellChartValue, IBaseChartValue

Types that implement IStringChartValue

Type | Description
StringChartValue | Represent string value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IStringChartValue Members | Aspose.Slides.Charts Namespace


IStringChartValue Members

IStringChartValue overview

Public Instance Properties

AsIMultipleCellChartValue
AsLiteralString

Public Instance Methods

GetCellsAddressInWorkbook
SetFromOneCell
ToString

See Also

IStringChartValue Interface | Aspose.Slides.Charts Namespace


IStringChartValue Properties

The properties of the IStringChartValue interface are listed below. For a complete list of IStringChartValue interface members, see the IStringChartValue Members topic.

Public Instance Properties

AsIMultipleCellChartValue
AsLiteralString

See Also

IStringChartValue Interface | Aspose.Slides.Charts Namespace


AsIMultipleCellChartValue Property

Aspose.Slides Documentation

IStringChartValue.AsIMultipleCellChartValue Property

[Visual Basic]
Property AsIMultipleCellChartValue As IMultipleCellChartValue
[C#]
IMultipleCellChartValue AsIMultipleCellChartValue {get;}

See Also

IStringChartValue Interface | Aspose.Slides.Charts Namespace


AsLiteralString Property

Aspose.Slides Documentation

IStringChartValue.AsLiteralString Property

[Visual Basic]
Property AsLiteralString As String
[C#]
string AsLiteralString {get; set;}

See Also

IStringChartValue Interface | Aspose.Slides.Charts Namespace


IStringChartValue Methods

The methods of the IStringChartValue interface are listed below. For a complete list of IStringChartValue interface members, see the IStringChartValue Members topic.

Public Instance Methods

GetCellsAddressInWorkbook
SetFromOneCell
ToString

See Also

IStringChartValue Interface | Aspose.Slides.Charts Namespace


IStringChartValue.GetCellsAddressInWorkbook Method

[Visual Basic]
Function GetCellsAddressInWorkbook() As String
[C#]
string GetCellsAddressInWorkbook();

See Also

IStringChartValue Interface | Aspose.Slides.Charts Namespace


IStringChartValue.SetFromOneCell Method

[Visual Basic]
Sub SetFromOneCell( _
ByVal cell As IChartDataCell _
)
[C#]
void SetFromOneCell(
IChartDataCell cell
);

See Also

IStringChartValue Interface | Aspose.Slides.Charts Namespace


IStringChartValue.ToString Method

[Visual Basic]
Function ToString() As String
[C#]
string ToString();

See Also

IStringChartValue Interface | Aspose.Slides.Charts Namespace


IStringOrDoubleChartValue Interface

For a list of all members of this type, see IStringOrDoubleChartValue Members.

[Visual Basic]
Public Interface IStringOrDoubleChartValue
Implements ISingleCellChartValue, IBaseChartValue
[C#]
public interface IStringOrDoubleChartValue : ISingleCellChartValue, IBaseChartValue

Types that implement IStringOrDoubleChartValue

Type | Description
StringOrDoubleChartValue | Represent string or double value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IStringOrDoubleChartValue Members | Aspose.Slides.Charts Namespace


IStringOrDoubleChartValue Members

IStringOrDoubleChartValue overview

Public Instance Properties

AsISingleCellChartValue
AsLiteralDouble
AsLiteralString

Public Instance Methods

ToDouble

See Also

IStringOrDoubleChartValue Interface | Aspose.Slides.Charts Namespace


IStringOrDoubleChartValue Properties

The properties of the IStringOrDoubleChartValue interface are listed below. For a complete list of IStringOrDoubleChartValue interface members, see the IStringOrDoubleChartValue Members topic.

Public Instance Properties

AsISingleCellChartValue
AsLiteralDouble
AsLiteralString

See Also

IStringOrDoubleChartValue Interface | Aspose.Slides.Charts Namespace


AsISingleCellChartValue Property

Aspose.Slides Documentation

IStringOrDoubleChartValue.AsISingleCellChartValue Property

[Visual Basic]
Property AsISingleCellChartValue As ISingleCellChartValue
[C#]
ISingleCellChartValue AsISingleCellChartValue {get;}

See Also

IStringOrDoubleChartValue Interface | Aspose.Slides.Charts Namespace


AsLiteralDouble Property

Aspose.Slides Documentation

IStringOrDoubleChartValue.AsLiteralDouble Property

[Visual Basic]
Property AsLiteralDouble As Double
[C#]
double AsLiteralDouble {get; set;}

See Also

IStringOrDoubleChartValue Interface | Aspose.Slides.Charts Namespace


AsLiteralString Property

Aspose.Slides Documentation

IStringOrDoubleChartValue.AsLiteralString Property

[Visual Basic]
Property AsLiteralString As String
[C#]
string AsLiteralString {get; set;}

See Also

IStringOrDoubleChartValue Interface | Aspose.Slides.Charts Namespace


IStringOrDoubleChartValue Methods

The methods of the IStringOrDoubleChartValue interface are listed below. For a complete list of IStringOrDoubleChartValue interface members, see the IStringOrDoubleChartValue Members topic.

Public Instance Methods

ToDouble

See Also

IStringOrDoubleChartValue Interface | Aspose.Slides.Charts Namespace


IStringOrDoubleChartValue.ToDouble Method

[Visual Basic]
Function ToDouble() As Double
[C#]
double ToDouble();

See Also

IStringOrDoubleChartValue Interface | Aspose.Slides.Charts Namespace


ITrendline Interface

For a list of all members of this type, see ITrendline Members.

[Visual Basic]
Public Interface ITrendline
Implements IChartComponent, IOverridableText, IFormattedTextContainer
[C#]
public interface ITrendline : IChartComponent, IOverridableText, IFormattedTextContainer

Types that implement ITrendline

Type | Description
Trendline | Class represents trend line of chart series

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITrendline Members | Aspose.Slides.Charts Namespace


ITrendline Members

ITrendline overview

Public Instance Properties

AsIChartComponent
AsIOverridableText
Backward
DisplayEquation
DisplayRSquaredValue
Format
Forward
Intercept
Order
Period
TrendlineName
TrendlineType

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


ITrendline Properties

The properties of the ITrendline interface are listed below. For a complete list of ITrendline interface members, see the ITrendline Members topic.

Public Instance Properties

AsIChartComponent
AsIOverridableText
Backward
DisplayEquation
DisplayRSquaredValue
Format
Forward
Intercept
Order
Period
TrendlineName
TrendlineType

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


AsIChartComponent Property

Aspose.Slides Documentation

ITrendline.AsIChartComponent Property

[Visual Basic]
Property AsIChartComponent As IChartComponent
[C#]
IChartComponent AsIChartComponent {get;}

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


AsIOverridableText Property

Aspose.Slides Documentation

ITrendline.AsIOverridableText Property

[Visual Basic]
Property AsIOverridableText As IOverridableText
[C#]
IOverridableText AsIOverridableText {get;}

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


Backward Property

Aspose.Slides Documentation

ITrendline.Backward Property

[Visual Basic]
Property Backward As Double
[C#]
double Backward {get; set;}

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


DisplayEquation Property

Aspose.Slides Documentation

ITrendline.DisplayEquation Property

[Visual Basic]
Property DisplayEquation As Boolean
[C#]
bool DisplayEquation {get; set;}

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


DisplayRSquaredValue Property

Aspose.Slides Documentation

ITrendline.DisplayRSquaredValue Property

[Visual Basic]
Property DisplayRSquaredValue As Boolean
[C#]
bool DisplayRSquaredValue {get; set;}

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

ITrendline.Format Property

[Visual Basic]
Property Format As IFormat
[C#]
IFormat Format {get; set;}

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


Forward Property

Aspose.Slides Documentation

ITrendline.Forward Property

[Visual Basic]
Property Forward As Double
[C#]
double Forward {get; set;}

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


Intercept Property

Aspose.Slides Documentation

ITrendline.Intercept Property

[Visual Basic]
Property Intercept As Double
[C#]
double Intercept {get; set;}

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


Order Property

Aspose.Slides Documentation

ITrendline.Order Property

[Visual Basic]
Property Order As Byte
[C#]
byte Order {get; set;}

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


Period Property

Aspose.Slides Documentation

ITrendline.Period Property

[Visual Basic]
Property Period As Byte
[C#]
byte Period {get; set;}

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


TrendlineName Property

Aspose.Slides Documentation

ITrendline.TrendlineName Property

[Visual Basic]
Property TrendlineName As String
[C#]
string TrendlineName {get; set;}

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


TrendlineType Property

Aspose.Slides Documentation

ITrendline.TrendlineType Property

[Visual Basic]
Property TrendlineType As TrendlineType
[C#]
TrendlineType TrendlineType {get; set;}

See Also

ITrendline Interface | Aspose.Slides.Charts Namespace


ITrendlineCollection Interface

For a list of all members of this type, see ITrendlineCollection Members.

[Visual Basic]
Public Interface ITrendlineCollection
Implements IEnumerable`1([Aspose.Slides.Charts.ITrendline, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public interface ITrendlineCollection : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Types that implement ITrendlineCollection

Type | Description
TrendlineCollection | Represents a collection of Trendline

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITrendlineCollection Members | Aspose.Slides.Charts Namespace


ITrendlineCollection Members

ITrendlineCollection overview

Public Instance Properties

AsIEnumerable
Count
Item

Public Instance Methods

Add
Remove

See Also

ITrendlineCollection Interface | Aspose.Slides.Charts Namespace


ITrendlineCollection Properties

The properties of the ITrendlineCollection interface are listed below. For a complete list of ITrendlineCollection interface members, see the ITrendlineCollection Members topic.

Public Instance Properties

AsIEnumerable
Count
Item

See Also

ITrendlineCollection Interface | Aspose.Slides.Charts Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ITrendlineCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ITrendlineCollection Interface | Aspose.Slides.Charts Namespace


Count Property

Aspose.Slides Documentation

ITrendlineCollection.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

ITrendlineCollection Interface | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

ITrendlineCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As ITrendline
[C#]
ITrendline this[
int index
] {get;}

See Also

ITrendlineCollection Interface | Aspose.Slides.Charts Namespace


ITrendlineCollection Methods

The methods of the ITrendlineCollection interface are listed below. For a complete list of ITrendlineCollection interface members, see the ITrendlineCollection Members topic.

Public Instance Methods

Add
Remove

See Also

ITrendlineCollection Interface | Aspose.Slides.Charts Namespace


ITrendlineCollection.Add Method

[Visual Basic]
Function Add( _
ByVal trendlineType As TrendlineType _
) As ITrendline
[C#]
ITrendline Add(
TrendlineType trendlineType
);

See Also

ITrendlineCollection Interface | Aspose.Slides.Charts Namespace


ITrendlineCollection.Remove Method

[Visual Basic]
Sub Remove( _
ByVal value As ITrendline _
)
[C#]
void Remove(
ITrendline value
);

See Also

ITrendlineCollection Interface | Aspose.Slides.Charts Namespace


IUpDownBarsManager Interface

For a list of all members of this type, see IUpDownBarsManager Members.

[Visual Basic]
Public Interface IUpDownBarsManager
[C#]
public interface IUpDownBarsManager

Types that implement IUpDownBarsManager

Type | Description
UpDownBarsManager | Provide access to up/down bars of Line- or Stock-chart.

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IUpDownBarsManager Members | Aspose.Slides.Charts Namespace


IUpDownBarsManager Members

IUpDownBarsManager overview

Public Instance Properties

DownBarsFormat
GapWidth
HasUpDownBars
UpBarsFormat

See Also

IUpDownBarsManager Interface | Aspose.Slides.Charts Namespace


IUpDownBarsManager Properties

The properties of the IUpDownBarsManager interface are listed below. For a complete list of IUpDownBarsManager interface members, see the IUpDownBarsManager Members topic.

Public Instance Properties

DownBarsFormat
GapWidth
HasUpDownBars
UpBarsFormat

See Also

IUpDownBarsManager Interface | Aspose.Slides.Charts Namespace


DownBarsFormat Property

Aspose.Slides Documentation

IUpDownBarsManager.DownBarsFormat Property

[Visual Basic]
Property DownBarsFormat As IFormat
[C#]
IFormat DownBarsFormat {get;}

See Also

IUpDownBarsManager Interface | Aspose.Slides.Charts Namespace


GapWidth Property

Aspose.Slides Documentation

IUpDownBarsManager.GapWidth Property

[Visual Basic]
Property GapWidth As Integer
[C#]
int GapWidth {get; set;}

See Also

IUpDownBarsManager Interface | Aspose.Slides.Charts Namespace


HasUpDownBars Property

Aspose.Slides Documentation

IUpDownBarsManager.HasUpDownBars Property

[Visual Basic]
Property HasUpDownBars As Boolean
[C#]
bool HasUpDownBars {get; set;}

See Also

IUpDownBarsManager Interface | Aspose.Slides.Charts Namespace


UpBarsFormat Property

Aspose.Slides Documentation

IUpDownBarsManager.UpBarsFormat Property

[Visual Basic]
Property UpBarsFormat As IFormat
[C#]
IFormat UpBarsFormat {get;}

See Also

IUpDownBarsManager Interface | Aspose.Slides.Charts Namespace


Legend Class

Represents chart's legend properties.

For a list of all members of this type, see Legend Members.

System.Object
Aspose.Slides.Charts.Legend

[Visual Basic]
Public Class Legend
Implements ILegend, ILayoutable, IChartComponent, IFormattedTextContainer
[C#]
public class Legend : ILegend, ILayoutable, IChartComponent, IFormattedTextContainer

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Legend Members | Aspose.Slides.Charts Namespace


Legend Members

Legend overview

Public Instance Properties

Bottom |
Chart |
Entries | Gets legend entries.
Format | Returns the format of a legend. Read-only Format.
Height | Returns or sets the height of a legend as a fraction of the height of the chart. Read/write Single.
Overlay | Determines whether other chart elements shall be allowed to overlap legend. Read/write Boolean.
Position | Specifies the position of the legend on a chart. Non-NaN values of X, Y, Width, Heigt properties override effect of this property. Read/write LegendPositionType.
Right |
TextFormat |
Width | Returns or sets the width of a legend as a fraction of the width of the chart. Read/write Single.
X | Returns or sets the x coordinate of a legend as a fraction of the width of the chart. Read/write Single.
Y | Returns or sets the y coordinate of a legend as a fraction of the height of the chart. Read/write Single.

See Also

Legend Class | Aspose.Slides.Charts Namespace


Legend Properties

The properties of the Legend class are listed below. For a complete list of Legend class members, see the Legend Members topic.

Public Instance Properties

Bottom |
Chart |
Entries | Gets legend entries.
Format | Returns the format of a legend. Read-only Format.
Height | Returns or sets the height of a legend as a fraction of the height of the chart. Read/write Single.
Overlay | Determines whether other chart elements shall be allowed to overlap legend. Read/write Boolean.
Position | Specifies the position of the legend on a chart. Non-NaN values of X, Y, Width, Heigt properties override effect of this property. Read/write LegendPositionType.
Right |
TextFormat |
Width | Returns or sets the width of a legend as a fraction of the width of the chart. Read/write Single.
X | Returns or sets the x coordinate of a legend as a fraction of the width of the chart. Read/write Single.
Y | Returns or sets the y coordinate of a legend as a fraction of the height of the chart. Read/write Single.

See Also

Legend Class | Aspose.Slides.Charts Namespace


Bottom Property

Aspose.Slides Documentation

Legend.Bottom Property

[Visual Basic]
NotOverridable Public ReadOnly Property Bottom As Single _
Implements ILayoutable.Bottom
[C#]
public float Bottom {get;}

Implements

ILayoutable.Bottom

See Also

Legend Class | Aspose.Slides.Charts Namespace


Chart Property

Aspose.Slides Documentation

Legend.Chart Property

[Visual Basic]
NotOverridable Public ReadOnly Property Chart As IChart _
Implements IChartComponent.Chart
[C#]
public IChart Chart {get;}

Implements

IChartComponent.Chart

See Also

Legend Class | Aspose.Slides.Charts Namespace


Entries Property

Aspose.Slides Documentation

Legend.Entries Property

Gets legend entries.

[Visual Basic]
NotOverridable Public ReadOnly Property Entries As ILegendEntryCollection _
Implements ILegend.Entries
[C#]
public ILegendEntryCollection Entries {get;}

Implements

ILegend.Entries

See Also

Legend Class | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

Legend.Format Property

Returns the format of a legend. Read-only Format.

[Visual Basic]
NotOverridable Public ReadOnly Property Format As IFormat _
Implements ILegend.Format
[C#]
public IFormat Format {get;}

Implements

ILegend.Format

See Also

Legend Class | Aspose.Slides.Charts Namespace


Height Property

Aspose.Slides Documentation

Legend.Height Property

Returns or sets the height of a legend as a fraction of the height of the chart. Read/write Single.

[Visual Basic]
NotOverridable Public Property Height As Single _
Implements ILayoutable.Height
[C#]
public float Height {get; set;}

Implements

ILayoutable.Height

See Also

Legend Class | Aspose.Slides.Charts Namespace


Overlay Property

Aspose.Slides Documentation

Legend.Overlay Property

Determines whether other chart elements shall be allowed to overlap legend. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property Overlay As Boolean _
Implements ILegend.Overlay
[C#]
public bool Overlay {get; set;}

Implements

ILegend.Overlay

See Also

Legend Class | Aspose.Slides.Charts Namespace


Position Property

Aspose.Slides Documentation

Legend.Position Property

Specifies the position of the legend on a chart. Non-NaN values of X, Y, Width, Heigt properties override effect of this property. Read/write LegendPositionType.

[Visual Basic]
NotOverridable Public Property Position As LegendPositionType _
Implements ILegend.Position
[C#]
public LegendPositionType Position {get; set;}

Implements

ILegend.Position

See Also

Legend Class | Aspose.Slides.Charts Namespace


Right Property

Aspose.Slides Documentation

Legend.Right Property

[Visual Basic]
NotOverridable Public ReadOnly Property Right As Single _
Implements ILayoutable.Right
[C#]
public float Right {get;}

Implements

ILayoutable.Right

See Also

Legend Class | Aspose.Slides.Charts Namespace


TextFormat Property

Aspose.Slides Documentation

Legend.TextFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property TextFormat As IChartTextFormat _
Implements IFormattedTextContainer.TextFormat
[C#]
public IChartTextFormat TextFormat {get;}

Implements

IFormattedTextContainer.TextFormat

See Also

Legend Class | Aspose.Slides.Charts Namespace


Width Property

Aspose.Slides Documentation

Legend.Width Property

Returns or sets the width of a legend as a fraction of the width of the chart. Read/write Single.

[Visual Basic]
NotOverridable Public Property Width As Single _
Implements ILayoutable.Width
[C#]
public float Width {get; set;}

Implements

ILayoutable.Width

See Also

Legend Class | Aspose.Slides.Charts Namespace


X Property

Aspose.Slides Documentation

Legend.X Property

Returns or sets the x coordinate of a legend as a fraction of the width of the chart. Read/write Single.

[Visual Basic]
NotOverridable Public Property X As Single _
Implements ILayoutable.X
[C#]
public float X {get; set;}

Implements

ILayoutable.X

See Also

Legend Class | Aspose.Slides.Charts Namespace


Y Property

Aspose.Slides Documentation

Legend.Y Property

Returns or sets the y coordinate of a legend as a fraction of the height of the chart. Read/write Single.

[Visual Basic]
NotOverridable Public Property Y As Single _
Implements ILayoutable.Y
[C#]
public float Y {get; set;}

Implements

ILayoutable.Y

See Also

Legend Class | Aspose.Slides.Charts Namespace


LegendDataLabelPosition Enumeration

[Visual Basic]
Public Enum LegendDataLabelPosition
[C#]
public enum LegendDataLabelPosition

Members

Member Name | Description | Value
NotDefined |  | -1
Bottom |  | 0
BestFit |  | 1
Center |  | 2
InsideBase |  | 3
InsideEnd |  | 4
Left |  | 5
OutsideEnd |  | 6
Right |  | 7
Top |  | 8

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


LegendEntryCollection Class

For a list of all members of this type, see LegendEntryCollection Members.

System.Object
Aspose.Slides.Charts.LegendEntryCollection

[Visual Basic]
Public Class LegendEntryCollection
Implements ILegendEntryCollection
[C#]
public class LegendEntryCollection : ILegendEntryCollection

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LegendEntryCollection Members | Aspose.Slides.Charts Namespace


LegendEntryCollection Members

LegendEntryCollection overview

Public Instance Properties

Count | Gets the number of legend entries. Read-only Int32.
Item | Gets properties of the legend entry corresponding to Chart.ChartData.Series[0].DataPoints[index] in case of chart type from this list: ChartType.BarOfPie, ChartType.ExplodedPie, ChartType.ExplodedPie3D, ChartType.Pie, ChartType.Pie3D, ChartType.PieOfPie; or corresponding to Chart.ChartData.Series[index] for other chart types.

See Also

LegendEntryCollection Class | Aspose.Slides.Charts Namespace


LegendEntryCollection Properties

The properties of the LegendEntryCollection class are listed below. For a complete list of LegendEntryCollection class members, see the LegendEntryCollection Members topic.

Public Instance Properties

Count | Gets the number of legend entries. Read-only Int32.
Item | Gets properties of the legend entry corresponding to Chart.ChartData.Series[0].DataPoints[index] in case of chart type from this list: ChartType.BarOfPie, ChartType.ExplodedPie, ChartType.ExplodedPie3D, ChartType.Pie, ChartType.Pie3D, ChartType.PieOfPie; or corresponding to Chart.ChartData.Series[index] for other chart types.

See Also

LegendEntryCollection Class | Aspose.Slides.Charts Namespace


Count Property

Aspose.Slides Documentation

LegendEntryCollection.Count Property

Gets the number of legend entries. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ILegendEntryCollection.Count
[C#]
public int Count {get;}

Implements

ILegendEntryCollection.Count

See Also

LegendEntryCollection Class | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

LegendEntryCollection.Item Property

Gets properties of the legend entry corresponding to Chart.ChartData.Series[0].DataPoints[index] in case of chart type from this list: ChartType.BarOfPie, ChartType.ExplodedPie, ChartType.ExplodedPie3D, ChartType.Pie, ChartType.Pie3D, ChartType.PieOfPie; or corresponding to Chart.ChartData.Series[index] for other chart types.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ILegendEntryCollection.Item
As ILegendEntryProperties _
Implements ILegendEntryCollection.Item
[C#]
public ILegendEntryProperties this[
int index
] {get;}

Implements

ILegendEntryCollection.Item

See Also

LegendEntryCollection Class | Aspose.Slides.Charts Namespace


LegendEntryProperties Class

For a list of all members of this type, see LegendEntryProperties Members.

System.Object
Aspose.Slides.Charts.LegendEntryProperties

[Visual Basic]
Public Class LegendEntryProperties
Implements ILegendEntryProperties, IChartComponent, IFormattedTextContainer
[C#]
public class LegendEntryProperties : ILegendEntryProperties, IChartComponent, IFormattedTextContainer

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LegendEntryProperties Members | Aspose.Slides.Charts Namespace


LegendEntryProperties Members

LegendEntryProperties overview

Public Instance Properties

Chart
Hide
TextFormat

See Also

LegendEntryProperties Class | Aspose.Slides.Charts Namespace


LegendEntryProperties Properties

The properties of the LegendEntryProperties class are listed below. For a complete list of LegendEntryProperties class members, see the LegendEntryProperties Members topic.

Public Instance Properties

Chart
Hide
TextFormat

See Also

LegendEntryProperties Class | Aspose.Slides.Charts Namespace


Chart Property

Aspose.Slides Documentation

LegendEntryProperties.Chart Property

[Visual Basic]
NotOverridable Public ReadOnly Property Chart As IChart _
Implements IChartComponent.Chart
[C#]
public IChart Chart {get;}

Implements

IChartComponent.Chart

See Also

LegendEntryProperties Class | Aspose.Slides.Charts Namespace


Hide Property

Aspose.Slides Documentation

LegendEntryProperties.Hide Property

[Visual Basic]
NotOverridable Public Property Hide As Boolean _
Implements ILegendEntryProperties.Hide
[C#]
public bool Hide {get; set;}

Implements

ILegendEntryProperties.Hide

See Also

LegendEntryProperties Class | Aspose.Slides.Charts Namespace


TextFormat Property

Aspose.Slides Documentation

LegendEntryProperties.TextFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property TextFormat As IChartTextFormat _
Implements IFormattedTextContainer.TextFormat
[C#]
public IChartTextFormat TextFormat {get;}

Implements

IFormattedTextContainer.TextFormat

See Also

LegendEntryProperties Class | Aspose.Slides.Charts Namespace


LegendPositionType Enumeration

[Visual Basic]
Public Enum LegendPositionType
[C#]
public enum LegendPositionType

Members

Member Name | Description | Value
Bottom |  | 0
Left |  | 1
Right |  | 2
Top |  | 3
TopRight |  | 4

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


Marker Class

For a list of all members of this type, see Marker Members.

System.Object
Aspose.Slides.Charts.Marker

[Visual Basic]
Public Class Marker
Implements IMarker
[C#]
public class Marker : IMarker

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Marker Members | Aspose.Slides.Charts Namespace


Marker Members

Marker overview

Public Instance Properties

Format | Gets or sets the marker fill
Size | Represents the marker size in a line chart, scatter chart, or radar chart.
Symbol | Represents the marker style in a line chart, scatter chart, or radar chart.

See Also

Marker Class | Aspose.Slides.Charts Namespace


Marker Properties

The properties of the Marker class are listed below. For a complete list of Marker class members, see the Marker Members topic.

Public Instance Properties

Format | Gets or sets the marker fill
Size | Represents the marker size in a line chart, scatter chart, or radar chart.
Symbol | Represents the marker style in a line chart, scatter chart, or radar chart.

See Also

Marker Class | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

Marker.Format Property

Gets or sets the marker fill

[Visual Basic]
NotOverridable Public ReadOnly Property Format As IFormat _
Implements IMarker.Format
[C#]
public IFormat Format {get;}

Implements

IMarker.Format

See Also

Marker Class | Aspose.Slides.Charts Namespace


Size Property

Aspose.Slides Documentation

Marker.Size Property

Represents the marker size in a line chart, scatter chart, or radar chart.

[Visual Basic]
NotOverridable Public Property Size As Integer _
Implements IMarker.Size
[C#]
public int Size {get; set;}

Implements

IMarker.Size

See Also

Marker Class | Aspose.Slides.Charts Namespace


Symbol Property

Aspose.Slides Documentation

Marker.Symbol Property

Represents the marker style in a line chart, scatter chart, or radar chart.

[Visual Basic]
NotOverridable Public Property Symbol As MarkerStyleType _
Implements IMarker.Symbol
[C#]
public MarkerStyleType Symbol {get; set;}

Implements

IMarker.Symbol

See Also

Marker Class | Aspose.Slides.Charts Namespace


MarkerStyleType Enumeration

[Visual Basic]
Public Enum MarkerStyleType
[C#]
public enum MarkerStyleType

Members

Member Name | Description | Value
NotDefined |  | -1
Circle |  | 0
Dash |  | 1
Diamond |  | 2
Dot |  | 3
None |  | 4
Picture |  | 5
Plus |  | 6
Square |  | 7
Star |  | 8
Triangle |  | 9
X |  | 10

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


PictureType Enumeration

[Visual Basic]
Public Enum PictureType
[C#]
public enum PictureType

Members

Member Name | Description | Value
NotDefined |  | -1
Stack |  | 0
StackScale |  | 1
Stretch |  | 2

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


PreferredAxesCompositionIsNotCombinableException Class

For a list of all members of this type, see PreferredAxesCompositionIsNotCombinableException Members.

System.Object
System.Exception
System.SystemException
System.InvalidOperationException
Aspose.Slides.Charts.PreferredAxesCompositionIsNotCombinableException

[Visual Basic]
Public Class PreferredAxesCompositionIsNotCombinableException
Inherits InvalidOperationException
[C#]
public class PreferredAxesCompositionIsNotCombinableException : InvalidOperationException

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PreferredAxesCompositionIsNotCombinableException Members | Aspose.Slides.Charts Namespace


PreferredAxesCompositionIsNotCombinableException Members

PreferredAxesCompositionIsNotCombinableException overview

Public Instance Constructors

PreferredAxesCompositionIsNotCombinableException Overloaded. Initializes a new instance of the PreferredAxesCompositionIsNotCombinableException class.

See Also

PreferredAxesCompositionIsNotCombinableException Class | Aspose.Slides.Charts Namespace


PreferredAxesCompositionIsNotCombinableException Constructor

Initializes a new instance of the PreferredAxesCompositionIsNotCombinableException class.

Overload List

Initializes a new instance of the PreferredAxesCompositionIsNotCombinableException class.

public PreferredAxesCompositionIsNotCombinableException();

public PreferredAxesCompositionIsNotCombinableException(string);

public PreferredAxesCompositionIsNotCombinableException(string,Exception);

See Also

PreferredAxesCompositionIsNotCombinableException Class | Aspose.Slides.Charts Namespace


PreferredAxesCompositionIsNotCombinableException Constructor ()

Initializes a new instance of the PreferredAxesCompositionIsNotCombinableException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PreferredAxesCompositionIsNotCombinableException();

See Also

PreferredAxesCompositionIsNotCombinableException Class | Aspose.Slides.Charts Namespace | PreferredAxesCompositionIsNotCombinableException Constructor Overload List


PreferredAxesCompositionIsNotCombinableException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public PreferredAxesCompositionIsNotCombinableException(
string message
);

See Also

PreferredAxesCompositionIsNotCombinableException Class | Aspose.Slides.Charts Namespace | PreferredAxesCompositionIsNotCombinableException Constructor Overload List


PreferredAxesCompositionIsNotCombinableException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public PreferredAxesCompositionIsNotCombinableException(
string message,
Exception exception
);

See Also

PreferredAxesCompositionIsNotCombinableException Class | Aspose.Slides.Charts Namespace | PreferredAxesCompositionIsNotCombinableException Constructor Overload List


Rotation3D Class

Represents 3D rotation of a chart.

For a list of all members of this type, see Rotation3D Members.

System.Object
Aspose.Slides.Charts.Rotation3D

[Visual Basic]
Public Class Rotation3D
Implements IRotation3D
[C#]
public class Rotation3D : IRotation3D

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Rotation3D Members | Aspose.Slides.Charts Namespace


Rotation3D Members

Rotation3D overview

Public Instance Properties

DepthPercents | Returns or sets the depth of a 3D chart as a percentage of a chart width (between 20 and 2000 percent). Read/write Int32.
HeightPercents | Specifies the height of a 3-D chart as a percentage of the chart width (between 5 and 500 percent).
Perspective | Returns or sets the perspective value (field of view angle) for 3D charts (between 0 and 100). Ignored if RightAngleAxes property value is true. Read/write Int32.
RightAngleAxes | Determines whether the chart axes are at right angles, rather than drawn in perspective. In other words it determines whether the chart angles of axes are independent from chart rotation or elevation. Read/write Boolean.
RotationX | Returns or sets the rotation degree in the X direction for 3D charts (between -90 and 90 degrees). Read/write Int32.
RotationY | Returns or sets the rotation degree in the Y direction for 3D charts (between 0 and 360 degrees). Read/write Int32.

See Also

Rotation3D Class | Aspose.Slides.Charts Namespace


Rotation3D Properties

The properties of the Rotation3D class are listed below. For a complete list of Rotation3D class members, see the Rotation3D Members topic.

Public Instance Properties

DepthPercents | Returns or sets the depth of a 3D chart as a percentage of a chart width (between 20 and 2000 percent). Read/write Int32.
HeightPercents | Specifies the height of a 3-D chart as a percentage of the chart width (between 5 and 500 percent).
Perspective | Returns or sets the perspective value (field of view angle) for 3D charts (between 0 and 100). Ignored if RightAngleAxes property value is true. Read/write Int32.
RightAngleAxes | Determines whether the chart axes are at right angles, rather than drawn in perspective. In other words it determines whether the chart angles of axes are independent from chart rotation or elevation. Read/write Boolean.
RotationX | Returns or sets the rotation degree in the X direction for 3D charts (between -90 and 90 degrees). Read/write Int32.
RotationY | Returns or sets the rotation degree in the Y direction for 3D charts (between 0 and 360 degrees). Read/write Int32.

See Also

Rotation3D Class | Aspose.Slides.Charts Namespace


DepthPercents Property

Aspose.Slides Documentation

Rotation3D.DepthPercents Property

Returns or sets the depth of a 3D chart as a percentage of a chart width (between 20 and 2000 percent). Read/write Int32.

[Visual Basic]
NotOverridable Public Property DepthPercents As UInt16 _
Implements IRotation3D.DepthPercents
[C#]
public ushort DepthPercents {get; set;}

Implements

IRotation3D.DepthPercents

See Also

Rotation3D Class | Aspose.Slides.Charts Namespace


HeightPercents Property

Aspose.Slides Documentation

Rotation3D.HeightPercents Property

Specifies the height of a 3-D chart as a percentage of the chart width (between 5 and 500 percent).

[Visual Basic]
NotOverridable Public Property HeightPercents As UInt16 _
Implements IRotation3D.HeightPercents
[C#]
public ushort HeightPercents {get; set;}

Implements

IRotation3D.HeightPercents

See Also

Rotation3D Class | Aspose.Slides.Charts Namespace


Perspective Property

Aspose.Slides Documentation

Rotation3D.Perspective Property

Returns or sets the perspective value (field of view angle) for 3D charts (between 0 and 100). Ignored if RightAngleAxes property value is true. Read/write Int32.

[Visual Basic]
NotOverridable Public Property Perspective As Byte _
Implements IRotation3D.Perspective
[C#]
public byte Perspective {get; set;}

Implements

IRotation3D.Perspective

See Also

Rotation3D Class | Aspose.Slides.Charts Namespace


RightAngleAxes Property

Aspose.Slides Documentation

Rotation3D.RightAngleAxes Property

Determines whether the chart axes are at right angles, rather than drawn in perspective. In other words it determines whether the chart angles of axes are independent from chart rotation or elevation. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property RightAngleAxes As Boolean _
Implements IRotation3D.RightAngleAxes
[C#]
public bool RightAngleAxes {get; set;}

Implements

IRotation3D.RightAngleAxes

See Also

Rotation3D Class | Aspose.Slides.Charts Namespace


RotationX Property

Aspose.Slides Documentation

Rotation3D.RotationX Property

Returns or sets the rotation degree in the X direction for 3D charts (between -90 and 90 degrees). Read/write Int32.

[Visual Basic]
NotOverridable Public Property RotationX As SByte _
Implements IRotation3D.RotationX
[C#]
public sbyte RotationX {get; set;}

Implements

IRotation3D.RotationX

See Also

Rotation3D Class | Aspose.Slides.Charts Namespace


RotationY Property

Aspose.Slides Documentation

Rotation3D.RotationY Property

Returns or sets the rotation degree in the Y direction for 3D charts (between 0 and 360 degrees). Read/write Int32.

[Visual Basic]
NotOverridable Public Property RotationY As UInt16 _
Implements IRotation3D.RotationY
[C#]
public ushort RotationY {get; set;}

Implements

IRotation3D.RotationY

See Also

Rotation3D Class | Aspose.Slides.Charts Namespace


StringChartValue Class

Represent string value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.

For a list of all members of this type, see StringChartValue Members.

System.Object
Aspose.Slides.Charts.BaseChartValue
Aspose.Slides.Charts.StringChartValue

[Visual Basic]
Public Class StringChartValue
Inherits BaseChartValue
Implements IStringChartValue, IMultipleCellChartValue
[C#]
public class StringChartValue : BaseChartValue, IStringChartValue, IMultipleCellChartValue

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

StringChartValue Members | Aspose.Slides.Charts Namespace


StringChartValue Members

StringChartValue overview

Public Instance Properties

AsCells |
AsLiteralString |
Data |
DataSourceType (inherited from BaseChartValue) | Specifies whether AsCell, AsCells, AsLiteralString or AsLiteralDouble property is actual in descendants. In other words it specifies the type of value of the Data property.

Public Instance Methods

GetCellsAddressInWorkbook | If DataSourceType property is DataSourceType.Worksheet then this method returns address of the cells in workbook which represent the string data. Otherwise return empty string.
SetFromOneCell |
ToString | Returns string value data. Return null if DataSourceType is false and no string value was assigned.

See Also

StringChartValue Class | Aspose.Slides.Charts Namespace


StringChartValue Properties

The properties of the StringChartValue class are listed below. For a complete list of StringChartValue class members, see the StringChartValue Members topic.

Public Instance Properties

AsCells |
AsLiteralString |
Data |
DataSourceType (inherited from BaseChartValue) | Specifies whether AsCell, AsCells, AsLiteralString or AsLiteralDouble property is actual in descendants. In other words it specifies the type of value of the Data property.

See Also

StringChartValue Class | Aspose.Slides.Charts Namespace


AsCells Property

Aspose.Slides Documentation

StringChartValue.AsCells Property

[Visual Basic]
NotOverridable Public Property AsCells As IChartCellCollection _
Implements IMultipleCellChartValue.AsCells
[C#]
public IChartCellCollection AsCells {get; set;}

Implements

IMultipleCellChartValue.AsCells

Remarks

Null value assigning is not allowed. Returning value always is not null.

See Also

StringChartValue Class | Aspose.Slides.Charts Namespace


AsLiteralString Property

Aspose.Slides Documentation

StringChartValue.AsLiteralString Property

[Visual Basic]
NotOverridable Public Property AsLiteralString As String _
Implements IStringChartValue.AsLiteralString
[C#]
public string AsLiteralString {get; set;}

Implements

IStringChartValue.AsLiteralString

See Also

StringChartValue Class | Aspose.Slides.Charts Namespace


Data Property

Aspose.Slides Documentation

StringChartValue.Data Property

[Visual Basic]
Overrides Public Property Data As Object _
Implements IBaseChartValue.Data
[C#]
public override object Data {get; set;}

Implements

IBaseChartValue.Data

See Also

StringChartValue Class | Aspose.Slides.Charts Namespace


StringChartValue Methods

The methods of the StringChartValue class are listed below. For a complete list of StringChartValue class members, see the StringChartValue Members topic.

Public Instance Methods

GetCellsAddressInWorkbook | If DataSourceType property is DataSourceType.Worksheet then this method returns address of the cells in workbook which represent the string data. Otherwise return empty string.
SetFromOneCell |
ToString | Returns string value data. Return null if DataSourceType is false and no string value was assigned.

See Also

StringChartValue Class | Aspose.Slides.Charts Namespace


StringChartValue.GetCellsAddressInWorkbook Method

If DataSourceType property is DataSourceType.Worksheet then this method returns address of the cells in workbook which represent the string data. Otherwise return empty string.

[Visual Basic]
NotOverridable Public Function GetCellsAddressInWorkbook() As String _
Implements IStringChartValue.GetCellsAddressInWorkbook
[C#]
public string GetCellsAddressInWorkbook();

Implements

IStringChartValue.GetCellsAddressInWorkbook

See Also

StringChartValue Class | Aspose.Slides.Charts Namespace


StringChartValue.SetFromOneCell Method

[Visual Basic]
NotOverridable Public Sub SetFromOneCell( _
ByVal cell As IChartDataCell _
) _
Implements IStringChartValue.SetFromOneCell
[C#]
public void SetFromOneCell(
IChartDataCell cell
);

Implements

IStringChartValue.SetFromOneCell

See Also

StringChartValue Class | Aspose.Slides.Charts Namespace


StringChartValue.ToString Method

Returns string value data. Return null if DataSourceType is false and no string value was assigned.

[Visual Basic]
Overrides Public Function ToString() As String _
Implements IStringChartValue.ToString
[C#]
public override string ToString();

Implements

IStringChartValue.ToString

See Also

StringChartValue Class | Aspose.Slides.Charts Namespace


StringOrDoubleChartValue Class

Represent string or double value which can be stored in pptx presentation document in two ways: 1) in cell/cells of workbook related to chart; 2) as literal value.

For a list of all members of this type, see StringOrDoubleChartValue Members.

System.Object
Aspose.Slides.Charts.BaseChartValue
Aspose.Slides.Charts.StringOrDoubleChartValue

[Visual Basic]
Public Class StringOrDoubleChartValue
Inherits BaseChartValue
Implements IStringOrDoubleChartValue, ISingleCellChartValue
[C#]
public class StringOrDoubleChartValue : BaseChartValue, IStringOrDoubleChartValue, ISingleCellChartValue

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

StringOrDoubleChartValue Members | Aspose.Slides.Charts Namespace


StringOrDoubleChartValue Members

StringOrDoubleChartValue overview

Public Instance Properties

AsCell |
AsLiteralDouble |
AsLiteralString |
Data |
DataSourceType (inherited from BaseChartValue) | Specifies whether AsCell, AsCells, AsLiteralString or AsLiteralDouble property is actual in descendants. In other words it specifies the type of value of the Data property.

Public Instance Methods

ToDouble

See Also

StringOrDoubleChartValue Class | Aspose.Slides.Charts Namespace


StringOrDoubleChartValue Properties

The properties of the StringOrDoubleChartValue class are listed below. For a complete list of StringOrDoubleChartValue class members, see the StringOrDoubleChartValue Members topic.

Public Instance Properties

AsCell |
AsLiteralDouble |
AsLiteralString |
Data |
DataSourceType (inherited from BaseChartValue) | Specifies whether AsCell, AsCells, AsLiteralString or AsLiteralDouble property is actual in descendants. In other words it specifies the type of value of the Data property.

See Also

StringOrDoubleChartValue Class | Aspose.Slides.Charts Namespace


AsCell Property

Aspose.Slides Documentation

StringOrDoubleChartValue.AsCell Property

[Visual Basic]
NotOverridable Public Property AsCell As IChartDataCell _
Implements ISingleCellChartValue.AsCell
[C#]
public IChartDataCell AsCell {get; set;}

Implements

ISingleCellChartValue.AsCell

See Also

StringOrDoubleChartValue Class | Aspose.Slides.Charts Namespace


AsLiteralDouble Property

Aspose.Slides Documentation

StringOrDoubleChartValue.AsLiteralDouble Property

[Visual Basic]
NotOverridable Public Property AsLiteralDouble As Double _
Implements IStringOrDoubleChartValue.AsLiteralDouble
[C#]
public double AsLiteralDouble {get; set;}

Implements

IStringOrDoubleChartValue.AsLiteralDouble

See Also

StringOrDoubleChartValue Class | Aspose.Slides.Charts Namespace


AsLiteralString Property

Aspose.Slides Documentation

StringOrDoubleChartValue.AsLiteralString Property

[Visual Basic]
NotOverridable Public Property AsLiteralString As String _
Implements IStringOrDoubleChartValue.AsLiteralString
[C#]
public string AsLiteralString {get; set;}

Implements

IStringOrDoubleChartValue.AsLiteralString

See Also

StringOrDoubleChartValue Class | Aspose.Slides.Charts Namespace


Data Property

Aspose.Slides Documentation

StringOrDoubleChartValue.Data Property

[Visual Basic]
Overrides Public Property Data As Object _
Implements IBaseChartValue.Data
[C#]
public override object Data {get; set;}

Implements

IBaseChartValue.Data

See Also

StringOrDoubleChartValue Class | Aspose.Slides.Charts Namespace


StringOrDoubleChartValue Methods

The methods of the StringOrDoubleChartValue class are listed below. For a complete list of StringOrDoubleChartValue class members, see the StringOrDoubleChartValue Members topic.

Public Instance Methods

ToDouble

See Also

StringOrDoubleChartValue Class | Aspose.Slides.Charts Namespace


StringOrDoubleChartValue.ToDouble Method

[Visual Basic]
NotOverridable Public Function ToDouble() As Double _
Implements IStringOrDoubleChartValue.ToDouble
[C#]
public double ToDouble();

Implements

IStringOrDoubleChartValue.ToDouble

See Also

StringOrDoubleChartValue Class | Aspose.Slides.Charts Namespace


StyleType Enumeration

[Visual Basic]
Public Enum StyleType
[C#]
public enum StyleType

Members

Member Name | Description | Value
Style1 |  | 0
Style2 |  | 1
Style3 |  | 2
Style4 |  | 3
Style5 |  | 4
Style6 |  | 5
Style7 |  | 6
Style8 |  | 7
Style9 |  | 8
Style10 |  | 9
Style11 |  | 10
Style12 |  | 11
Style13 |  | 12
Style14 |  | 13
Style15 |  | 14
Style16 |  | 15
Style17 |  | 16
Style18 |  | 17
Style19 |  | 18
Style20 |  | 19
Style21 |  | 20
Style22 |  | 21
Style23 |  | 22
Style24 |  | 23
Style25 |  | 24
Style26 |  | 25
Style27 |  | 26
Style28 |  | 27
Style29 |  | 28
Style30 |  | 29
Style31 |  | 30
Style32 |  | 31
Style33 |  | 32
Style34 |  | 33
Style35 |  | 34
Style36 |  | 35
Style37 |  | 36
Style38 |  | 37
Style39 |  | 38
Style40 |  | 39
Style41 |  | 40
Style42 |  | 41
Style43 |  | 42
Style44 |  | 43
Style45 |  | 44
Style46 |  | 45
Style47 |  | 46
Style48 |  | 47

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


TickLabelPositionType Enumeration

[Visual Basic]
Public Enum TickLabelPositionType
[C#]
public enum TickLabelPositionType

Members

Member Name | Description | Value
High |  | 0
Low |  | 1
NextTo |  | 2
None |  | 3

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


TickMarkType Enumeration

[Visual Basic]
Public Enum TickMarkType
[C#]
public enum TickMarkType

Members

Member Name | Description | Value
Cross |  | 0
Inside |  | 1
None |  | 2
Outside |  | 3

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


TimeUnitType Enumeration

[Visual Basic]
Public Enum TimeUnitType
[C#]
public enum TimeUnitType

Members

Member Name | Description | Value
Days |  | 0
Months |  | 1
Years |  | 2

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


Trendline Class

Class represents trend line of chart series

For a list of all members of this type, see Trendline Members.

System.Object
Aspose.Slides.Charts.Trendline

[Visual Basic]
Public Class Trendline
Implements ITrendline, IChartComponent, IOverridableText, IFormattedTextContainer
[C#]
public class Trendline : ITrendline, IChartComponent, IOverridableText, IFormattedTextContainer

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Trendline Members | Aspose.Slides.Charts Namespace


Trendline Members

Trendline overview

Public Instance Properties

Backward | Specifies the number of categories (or units on a scatter chart) that the trend line extends before the data for the series that is being trended. On scatter and non-scatter charts, the value shall be any nonnegative value.
Chart | Returns the parent chart. Read-only IChart.
DisplayEquation | Specifies that the equation for the trendline is displayed on the chart (in the same label as the Rsquaredvalue).
DisplayRSquaredValue | Specifies that the R-squared value of the trendline is displayed on the chart (in the same label as the equation).
Format | Represents the format of the trend line. Read/write Format.
Forward | Specifies the number of categories (or units on a scatter chart) that the trendline extends after the data for the series that is being trended. On scatter and non-scatter charts, the value shall be any non-negative value.
Intercept | Specifies the value where the trendline shall cross the y axis. This property shall be supported only when the trendline type is exp, linear, or poly.
Order | Specifies the order of the polynomial trend line. It is ignored for other trend line types. Value must be between 2 and 6.
Period | Specifies the period of the trend line for a moving average trend line. It is ignored for other trend line variants. Value must be between 2 and 255.
TextFormat |
TextFrame | Obsolete. Returns a text frame of the trend line.
TextFrameForOverriding | Can contain a rich formatted text. If this property is not null then this formatted text value overrides auto-generated text of data label. Auto-generated text of data label means text that is managed by ShowSeriesName, ShowValue, ... properties and is formatted with the TextFormatManager.TextFormat property.
TrendlineName | Gets or sets name of the trendline
TrendlineType | Gets or sets type of trend line.

Public Instance Methods

AddTextFrameForOverriding Initialize TextFrameForOverriding with the text in paramener "text". If TextFrameForOverriding is already initialized then simply changes its text.

See Also

Trendline Class | Aspose.Slides.Charts Namespace


Trendline Properties

The properties of the Trendline class are listed below. For a complete list of Trendline class members, see the Trendline Members topic.

Public Instance Properties

Backward | Specifies the number of categories (or units on a scatter chart) that the trend line extends before the data for the series that is being trended. On scatter and non-scatter charts, the value shall be any nonnegative value.
Chart | Returns the parent chart. Read-only IChart.
DisplayEquation | Specifies that the equation for the trendline is displayed on the chart (in the same label as the Rsquaredvalue).
DisplayRSquaredValue | Specifies that the R-squared value of the trendline is displayed on the chart (in the same label as the equation).
Format | Represents the format of the trend line. Read/write Format.
Forward | Specifies the number of categories (or units on a scatter chart) that the trendline extends after the data for the series that is being trended. On scatter and non-scatter charts, the value shall be any non-negative value.
Intercept | Specifies the value where the trendline shall cross the y axis. This property shall be supported only when the trendline type is exp, linear, or poly.
Order | Specifies the order of the polynomial trend line. It is ignored for other trend line types. Value must be between 2 and 6.
Period | Specifies the period of the trend line for a moving average trend line. It is ignored for other trend line variants. Value must be between 2 and 255.
TextFormat |
TextFrame | Obsolete. Returns a text frame of the trend line.
TextFrameForOverriding | Can contain a rich formatted text. If this property is not null then this formatted text value overrides auto-generated text of data label. Auto-generated text of data label means text that is managed by ShowSeriesName, ShowValue, ... properties and is formatted with the TextFormatManager.TextFormat property.
TrendlineName | Gets or sets name of the trendline
TrendlineType | Gets or sets type of trend line.

See Also

Trendline Class | Aspose.Slides.Charts Namespace


Backward Property

Aspose.Slides Documentation

Trendline.Backward Property

Specifies the number of categories (or units on a scatter chart) that the trend line extends before the data for the series that is being trended. On scatter and non-scatter charts, the value shall be any nonnegative value.

[Visual Basic]
NotOverridable Public Property Backward As Double _
Implements ITrendline.Backward
[C#]
public double Backward {get; set;}

Implements

ITrendline.Backward

See Also

Trendline Class | Aspose.Slides.Charts Namespace


Chart Property

Aspose.Slides Documentation

Trendline.Chart Property

Returns the parent chart. Read-only IChart.

[Visual Basic]
NotOverridable Public ReadOnly Property Chart As IChart _
Implements IChartComponent.Chart
[C#]
public IChart Chart {get;}

Implements

IChartComponent.Chart

See Also

Trendline Class | Aspose.Slides.Charts Namespace


DisplayEquation Property

Aspose.Slides Documentation

Trendline.DisplayEquation Property

Specifies that the equation for the trendline is displayed on the chart (in the same label as the Rsquaredvalue).

[Visual Basic]
NotOverridable Public Property DisplayEquation As Boolean _
Implements ITrendline.DisplayEquation
[C#]
public bool DisplayEquation {get; set;}

Implements

ITrendline.DisplayEquation

See Also

Trendline Class | Aspose.Slides.Charts Namespace


DisplayRSquaredValue Property

Aspose.Slides Documentation

Trendline.DisplayRSquaredValue Property

Specifies that the R-squared value of the trendline is displayed on the chart (in the same label as the equation).

[Visual Basic]
NotOverridable Public Property DisplayRSquaredValue As Boolean _
Implements ITrendline.DisplayRSquaredValue
[C#]
public bool DisplayRSquaredValue {get; set;}

Implements

ITrendline.DisplayRSquaredValue

See Also

Trendline Class | Aspose.Slides.Charts Namespace


Format Property

Aspose.Slides Documentation

Trendline.Format Property

Represents the format of the trend line. Read/write Format.

[Visual Basic]
NotOverridable Public Property Format As IFormat _
Implements ITrendline.Format
[C#]
public IFormat Format {get; set;}

Implements

ITrendline.Format

See Also

Trendline Class | Aspose.Slides.Charts Namespace


Forward Property

Aspose.Slides Documentation

Trendline.Forward Property

Specifies the number of categories (or units on a scatter chart) that the trendline extends after the data for the series that is being trended. On scatter and non-scatter charts, the value shall be any non-negative value.

[Visual Basic]
NotOverridable Public Property Forward As Double _
Implements ITrendline.Forward
[C#]
public double Forward {get; set;}

Implements

ITrendline.Forward

See Also

Trendline Class | Aspose.Slides.Charts Namespace


Intercept Property

Aspose.Slides Documentation

Trendline.Intercept Property

Specifies the value where the trendline shall cross the y axis. This property shall be supported only when the trendline type is exp, linear, or poly.

[Visual Basic]
NotOverridable Public Property Intercept As Double _
Implements ITrendline.Intercept
[C#]
public double Intercept {get; set;}

Implements

ITrendline.Intercept

See Also

Trendline Class | Aspose.Slides.Charts Namespace


Order Property

Aspose.Slides Documentation

Trendline.Order Property

Specifies the order of the polynomial trend line. It is ignored for other trend line types. Value must be between 2 and 6.

[Visual Basic]
NotOverridable Public Property Order As Byte _
Implements ITrendline.Order
[C#]
public byte Order {get; set;}

Implements

ITrendline.Order

See Also

Trendline Class | Aspose.Slides.Charts Namespace


Period Property

Aspose.Slides Documentation

Trendline.Period Property

Specifies the period of the trend line for a moving average trend line. It is ignored for other trend line variants. Value must be between 2 and 255.

[Visual Basic]
NotOverridable Public Property Period As Byte _
Implements ITrendline.Period
[C#]
public byte Period {get; set;}

Implements

ITrendline.Period

See Also

Trendline Class | Aspose.Slides.Charts Namespace


TextFormat Property

Aspose.Slides Documentation

Trendline.TextFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property TextFormat As IChartTextFormat _
Implements IFormattedTextContainer.TextFormat
[C#]
public IChartTextFormat TextFormat {get;}

Implements

IFormattedTextContainer.TextFormat

See Also

Trendline Class | Aspose.Slides.Charts Namespace


TextFrame Property

Aspose.Slides Documentation

Trendline.TextFrame Property

NOTE: This property is now obsolete.

Use TextFrameForOverriding property instead. Property will be removed after 01.07.2013.

Returns a text frame of the trend line.

[Visual Basic]
Public Property TextFrame As TextFrame
[C#]
public TextFrame TextFrame {get; set;}

See Also

Trendline Class | Aspose.Slides.Charts Namespace


TextFrameForOverriding Property

Aspose.Slides Documentation

Trendline.TextFrameForOverriding Property

Can contain a rich formatted text. If this property is not null then this formatted text value overrides auto-generated text of data label. Auto-generated text of data label means text that is managed by ShowSeriesName, ShowValue, ... properties and is formatted with the TextFormatManager.TextFormat property.

[Visual Basic]
NotOverridable Public ReadOnly Property TextFrameForOverriding As ITextFrame _
Implements IOverridableText.TextFrameForOverriding
[C#]
public ITextFrame TextFrameForOverriding {get;}

Implements

IOverridableText.TextFrameForOverriding

See Also

Trendline Class | Aspose.Slides.Charts Namespace


TrendlineName Property

Aspose.Slides Documentation

Trendline.TrendlineName Property

Gets or sets name of the trendline

[Visual Basic]
NotOverridable Public Property TrendlineName As String _
Implements ITrendline.TrendlineName
[C#]
public string TrendlineName {get; set;}

Implements

ITrendline.TrendlineName

See Also

Trendline Class | Aspose.Slides.Charts Namespace


TrendlineType Property

Aspose.Slides Documentation

Trendline.TrendlineType Property

Gets or sets type of trend line.

[Visual Basic]
NotOverridable Public Property TrendlineType As TrendlineType _
Implements ITrendline.TrendlineType
[C#]
public TrendlineType TrendlineType {get; set;}

Implements

ITrendline.TrendlineType

See Also

Trendline Class | Aspose.Slides.Charts Namespace


Trendline Methods

The methods of the Trendline class are listed below. For a complete list of Trendline class members, see the Trendline Members topic.

Public Instance Methods

AddTextFrameForOverriding Initialize TextFrameForOverriding with the text in paramener "text". If TextFrameForOverriding is already initialized then simply changes its text.

See Also

Trendline Class | Aspose.Slides.Charts Namespace


Trendline.AddTextFrameForOverriding Method

Initialize TextFrameForOverriding with the text in paramener "text". If TextFrameForOverriding is already initialized then simply changes its text.

[Visual Basic]
NotOverridable Public Function AddTextFrameForOverriding( _
ByVal text As String _
) As ITextFrame _
Implements IOverridableText.AddTextFrameForOverriding
[C#]
public ITextFrame AddTextFrameForOverriding(
string text
);

Parameters

text
Text for a new TextFrameForOverriding.

Implements

IOverridableText.AddTextFrameForOverriding

See Also

Trendline Class | Aspose.Slides.Charts Namespace


TrendlineCollection Class

Represents a collection of Trendline

For a list of all members of this type, see TrendlineCollection Members.

System.Object
Aspose.Slides.Charts.TrendlineCollection

[Visual Basic]
Public Class TrendlineCollection
Implements ITrendlineCollection, IEnumerable`1([Aspose.Slides.Charts.ITrendline, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable
[C#]
public class TrendlineCollection : ITrendlineCollection, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TrendlineCollection Members | Aspose.Slides.Charts Namespace


TrendlineCollection Members

TrendlineCollection overview

Public Instance Constructors

TrendlineCollection Constructor Creates a new instance of Trendline class.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection. Read-only Int32.
Item | Gets the element at the specified index. Read-only Trendline.

Public Instance Methods

Add | Overloaded. Adds the new Trendline at the end of a collection and return it.
GetEnumerator | Returns an enumerator for the entire collection.
Remove | Removes the specified value.

See Also

TrendlineCollection Class | Aspose.Slides.Charts Namespace


TrendlineCollection Constructor

Creates a new instance of Trendline class.

[Visual Basic]
Public Sub New( _
ByVal parent As ChartSeries _
)
[C#]
public TrendlineCollection(
ChartSeries parent
);

See Also

TrendlineCollection Class | Aspose.Slides.Charts Namespace


TrendlineCollection Properties

The properties of the TrendlineCollection class are listed below. For a complete list of TrendlineCollection class members, see the TrendlineCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection. Read-only Int32.
Item | Gets the element at the specified index. Read-only Trendline.

See Also

TrendlineCollection Class | Aspose.Slides.Charts Namespace


Count Property

Aspose.Slides Documentation

TrendlineCollection.Count Property

Gets the number of elements actually contained in the collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ITrendlineCollection.Count
[C#]
public int Count {get;}

Implements

ITrendlineCollection.Count

See Also

TrendlineCollection Class | Aspose.Slides.Charts Namespace


Item Property

Aspose.Slides Documentation

TrendlineCollection.Item Property

Gets the element at the specified index. Read-only Trendline.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ITrendlineCollection.Item
As ITrendline _
Implements ITrendlineCollection.Item
[C#]
public ITrendline this[
int index
] {get;}

Implements

ITrendlineCollection.Item

See Also

TrendlineCollection Class | Aspose.Slides.Charts Namespace


TrendlineCollection Methods

The methods of the TrendlineCollection class are listed below. For a complete list of TrendlineCollection class members, see the TrendlineCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds the new Trendline at the end of a collection and return it.
GetEnumerator | Returns an enumerator for the entire collection.
Remove | Removes the specified value.

See Also

TrendlineCollection Class | Aspose.Slides.Charts Namespace


Add Method

Aspose.Slides Documentation

TrendlineCollection.Add Method

NOTE: This method is now obsolete.

Use Add(TrendlineType) method instead. Property will be removed after 01.09.2013.

Adds the new Trendline at the end of a collection.

Overload List

Obsolete. Adds the new Trendline at the end of a collection.

public void Add(ITrendline);

Adds the new Trendline at the end of a collection and return it.

public ITrendline Add(TrendlineType);

See Also

TrendlineCollection Class | Aspose.Slides.Charts Namespace


TrendlineCollection.Add Method (ITrendline)

NOTE: This method is now obsolete.

Use Add(TrendlineType) method instead. Property will be removed after 01.09.2013.

Adds the new Trendline at the end of a collection.

[Visual Basic]
Overloads Public Sub Add( _
ByVal value As ITrendline _
)
[C#]
public void Add(
ITrendline value
);

Parameters

value
The Trendline to be added to the end of the collection.

Return Value

See Also

TrendlineCollection Class | Aspose.Slides.Charts Namespace | TrendlineCollection.Add Overload List


TrendlineCollection.Add Method (TrendlineType)

Adds the new Trendline at the end of a collection and return it.

[Visual Basic]
NotOverridable Overloads Public Function Add( _
ByVal trendlineType As TrendlineType _
) As ITrendline _
Implements ITrendlineCollection.Add
[C#]
public ITrendline Add(
TrendlineType trendlineType
);

Implements

ITrendlineCollection.Add

See Also

TrendlineCollection Class | Aspose.Slides.Charts Namespace | TrendlineCollection.Add Overload List


TrendlineCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

TrendlineCollection Class | Aspose.Slides.Charts Namespace


TrendlineCollection.Remove Method

Removes the specified value.

[Visual Basic]
NotOverridable Public Sub Remove( _
ByVal value As ITrendline _
) _
Implements ITrendlineCollection.Remove
[C#]
public void Remove(
ITrendline value
);

Implements

ITrendlineCollection.Remove

See Also

TrendlineCollection Class | Aspose.Slides.Charts Namespace


TrendlineType Enumeration

[Visual Basic]
Public Enum TrendlineType
[C#]
public enum TrendlineType

Members

Member Name | Description | Value
Exponential |  | 0
Linear |  | 1
Logarithmic |  | 2
MovingAverage |  | 3
Polynomial |  | 4
Power |  | 5

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Charts Namespace


UpDownBarsManager Class

Provide access to up/down bars of Line- or Stock-chart.

For a list of all members of this type, see UpDownBarsManager Members.

System.Object
Aspose.Slides.Charts.UpDownBarsManager

[Visual Basic]
Public Class UpDownBarsManager
Implements IUpDownBarsManager
[C#]
public class UpDownBarsManager : IUpDownBarsManager

Requirements

Namespace: Aspose.Slides.Charts

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

UpDownBarsManager Members | Aspose.Slides.Charts Namespace


UpDownBarsManager Members

UpDownBarsManager overview

Public Instance Properties

DownBarsFormat
GapWidth
HasUpDownBars
UpBarsFormat

See Also

UpDownBarsManager Class | Aspose.Slides.Charts Namespace


UpDownBarsManager Properties

The properties of the UpDownBarsManager class are listed below. For a complete list of UpDownBarsManager class members, see the UpDownBarsManager Members topic.

Public Instance Properties

DownBarsFormat
GapWidth
HasUpDownBars
UpBarsFormat

See Also

UpDownBarsManager Class | Aspose.Slides.Charts Namespace


DownBarsFormat Property

Aspose.Slides Documentation

UpDownBarsManager.DownBarsFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property DownBarsFormat As IFormat _
Implements IUpDownBarsManager.DownBarsFormat
[C#]
public IFormat DownBarsFormat {get;}

Implements

IUpDownBarsManager.DownBarsFormat

See Also

UpDownBarsManager Class | Aspose.Slides.Charts Namespace


GapWidth Property

Aspose.Slides Documentation

UpDownBarsManager.GapWidth Property

[Visual Basic]
NotOverridable Public Property GapWidth As Integer _
Implements IUpDownBarsManager.GapWidth
[C#]
public int GapWidth {get; set;}

Implements

IUpDownBarsManager.GapWidth

See Also

UpDownBarsManager Class | Aspose.Slides.Charts Namespace


HasUpDownBars Property

Aspose.Slides Documentation

UpDownBarsManager.HasUpDownBars Property

[Visual Basic]
NotOverridable Public Property HasUpDownBars As Boolean _
Implements IUpDownBarsManager.HasUpDownBars
[C#]
public bool HasUpDownBars {get; set;}

Implements

IUpDownBarsManager.HasUpDownBars

See Also

UpDownBarsManager Class | Aspose.Slides.Charts Namespace


UpBarsFormat Property

Aspose.Slides Documentation

UpDownBarsManager.UpBarsFormat Property

[Visual Basic]
NotOverridable Public ReadOnly Property UpBarsFormat As IFormat _
Implements IUpDownBarsManager.UpBarsFormat
[C#]
public IFormat UpBarsFormat {get;}

Implements

IUpDownBarsManager.UpBarsFormat

See Also

UpDownBarsManager Class | Aspose.Slides.Charts Namespace


Aspose.Slides.Effects

Aspose.Slides Documentation

Aspose.Slides.Effects Namespace

Namespace hierarchy

Classes

Class | Description
AlphaBiLevel | Represents an Alpha Bi-Level effect. Alpha (Opacity) values less than the threshold are changed to 0 (fully transparent) and alpha values greater than or equal to the threshold are changed to 100% (fully opaque).
AlphaBiLevelEffectiveData | Immutable object which represents an Alpha Bi-Level effect. Alpha (Opacity) values less than the threshold are changed to 0 (fully transparent) and alpha values greater than or equal to the threshold are changed to 100% (fully opaque).
AlphaCeiling | Represents an Alpha Ceiling effect. Alpha (opacity) values greater than zero are changed to 100%. In other words, anything partially opaque becomes fully opaque.
AlphaCeilingEffectiveData | Immutable object which represents an Alpha Ceiling effect. Alpha (opacity) values greater than zero are changed to 100%. In other words, anything partially opaque becomes fully opaque.
AlphaFloor | Represents an Alpha Floor effect. Alpha (opacity) values less than 100% are changed to zero. In other words, anything partially transparent becomes fully transparent.
AlphaFloorEffectiveData | Immutable object which represents an Alpha Floor effect. Alpha (opacity) values less than 100% are changed to zero. In other words, anything partially transparent becomes fully transparent.
AlphaInverse | Represents an Alpha Inverse effect. Alpha (opacity) values are inverted by subtracting from 100%.
AlphaInverseEffectiveData | Immutable object which represents an Alpha Inverse effect. Alpha (opacity) values are inverted by subtracting from 100%.
AlphaModulate | Represents an Alpha Modulate effect. Effect alpha (opacity) values are multiplied by a fixed percentage. The effect container specifies an effect containing alpha values to modulate.
AlphaModulateEffectiveData | Immutable object which represents an Alpha Modulate effect. Effect alpha (opacity) values are multiplied by a fixed percentage. The effect container specifies an effect containing alpha values to modulate.
AlphaModulateFixed | Represents an Alpha Modulate Fixed effect. Effect alpha (opacity) values are multiplied by a fixed percentage.
AlphaModulateFixedEffectiveData | Immutable object which represents an Alpha Modulate Fixed effect. Effect alpha (opacity) values are multiplied by a fixed percentage.
AlphaReplace | Represents and Alpha Replace effect. Effect alpha (opacity) values are replaced by a fixed alpha.
AlphaReplaceEffectiveData | Immutable object which represents and Alpha Replace effect. Effect alpha (opacity) values are replaced by a fixed alpha.
BiLevel | Represents a Bi-Level (black/white) effect. Input colors whose luminance is less than the specified threshold value are changed to black. Input colors whose luminance are greater than or equal the specified value are set to white. The alpha effect values are unaffected by this effect.
BiLevelEffectiveData | Immutable object which represents a Bi-Level (black/white) effect. Input colors whose luminance is less than the specified threshold value are changed to black. Input colors whose luminance are greater than or equal the specified value are set to white. The alpha effect values are unaffected by this effect.
Blur | Represents a Blur effect that is applied to the entire shape, including its fill. All color channels, including alpha, are affected.
BlurEffectiveData | Immutable object which represents a Blur effect that is applied to the entire shape, including its fill. All color channels, including alpha, are affected.
ColorChange | Represents a Color Change effect. Instances of FromColor are replaced with instances of ToColor.
ColorChangeEffectiveData | Immutable object which represents a Color Change effect. Instances of FromColor are replaced with instances of ToColor.
ColorReplace | Represents a Color Replacement effect. All effect colors are changed to a fixed color. Alpha values are unaffected.
ColorReplaceEffectiveData | Immutable object which represents a Color Replacement effect. All effect colors are changed to a fixed color. Alpha values are unaffected.
Duotone | Represents a Duotone effect. For each pixel, combines Color1 and Color2 through a linear interpolation to determine the new color for that pixel.
DuotoneEffectiveData | Immutable object which represents a Duotone effect. For each pixel, combines clr1 and clr2 through a linear interpolation to determine the new color for that pixel.
EffectEffectiveData | Base class for immutable objects, which represent effect.
EffectFactory | Allows to create effects
FillOverlay | Represents a Fill Overlay effect. A fill overlay may be used to specify an additional fill for an object and blend the two fills together.
FillOverlayEffectiveData | Immutable object which represents a Fill Overlay effect. A fill overlay may be used to specify an additional fill for an object and blend the two fills together.
Glow | Represents a glow effect, in which a color blurred outline is added outside the edges of the object.
GlowEffectiveData | Immutable object which represents a glow effect, in which a color blurred outline is added outside the edges of the object.
GrayScale | Represents a Gray Scale effect. Converts all effect color values to a shade of gray, corresponding to their luminance. Effect alpha (opacity) values are unaffected.
GrayScaleEffectiveData | Immutable object which representsepresents a Gray Scale effect. Converts all effect color values to a shade of gray, corresponding to their luminance. Effect alpha (opacity) values are unaffected.
HSL | Represents a Hue/Saturation/Luminance effect. The hue, saturation, and luminance may each be adjusted relative to its current value.
HSLEffectiveData | Represents a Hue/Saturation/Luminance effect. The hue, saturation, and luminance may each be adjusted relative to its current value.
ImageTransformOCollectionEffectiveData | Immutable object which represents a readonly collection of EffectData objects.
ImageTransformOperation | Represents abstract image transformation effect.
ImageTransformOperationCollection | Represents a collection of effects apllied to an image.
ImageTransformOperationFactory | Allows to create image transform operations
InnerShadow | Represents a inner shadow effect.
InnerShadowEffectiveData | Immutable object which represents a inner shadow effect.
Luminance | Represents a Luminance effect. Brightness linearly shifts all colors closer to white or black. Contrast scales all colors to be either closer or further apart.
LuminanceEffectiveData | Represents a Luminance effect. Brightness linearly shifts all colors closer to white or black. Contrast scales all colors to be either closer or further apart.
OuterShadow | Represents a outer shadow effect.
OuterShadowEffectiveData | Immutable object which represents a outer shadow effect.
PresetShadow | Represents a preset shadow effect.
PresetShadowEffectiveData | Immutable object which represents a preset shadow effect.
Reflection | Represents a reflection effect.
ReflectionEffectiveData | Immutable object which represents a reflection effect.
SoftEdge | Represents a soft edge effect. The edges of the shape are blurred, while the fill is not affected.
SoftEdgeEffectiveData | Immutable object which represents a soft edge effect. The edges of the shape are blurred, while the fill is not affected.
Tint | Represents a Tint effect. Shifts effect color values towards/away from hue by the specified amount.
TintEffectiveData | Immutable object which represents a Tint effect. Shifts effect color values towards/away from hue by the specified amount.

Interfaces

Interface | Description
IAlphaBiLevel |
IAlphaBiLevelEffectiveData |
IAlphaCeiling |
IAlphaCeilingEffectiveData |
IAlphaFloor |
IAlphaFloorEffectiveData |
IAlphaInverse |
IAlphaInverseEffectiveData |
IAlphaModulate |
IAlphaModulateEffectiveData |
IAlphaModulateFixed |
IAlphaModulateFixedEffectiveData |
IAlphaReplace |
IAlphaReplaceEffectiveData |
IBiLevel |
IBiLevelEffectiveData |
IBlur |
IBlurEffectiveData |
IColorChange |
IColorChangeEffectiveData |
IColorReplace |
IColorReplaceEffectiveData |
IDuotone |
IDuotoneEffectiveData |
IEffectEffectiveData |
IEffectFactory |
IFillOverlay |
IFillOverlayEffectiveData |
IGlow |
IGlowEffectiveData |
IGrayScale |
IGrayScaleEffectiveData |
IHSL |
IHSLEffectiveData |
IImageTransformOCollectionEffectiveData |
IImageTransformOperation |
IImageTransformOperationCollection |
IImageTransformOperationFactory |
IInnerShadow |
IInnerShadowEffectiveData |
ILuminance |
ILuminanceEffectiveData |
IOuterShadow |
IOuterShadowEffectiveData |
IPresetShadow |
IPresetShadowEffectiveData |
IReflection |
IReflectionEffectiveData |
ISoftEdge |
ISoftEdgeEffectiveData |
ITint |
ITintEffectiveData |


AlphaBiLevel Class

Represents an Alpha Bi-Level effect. Alpha (Opacity) values less than the threshold are changed to 0 (fully transparent) and alpha values greater than or equal to the threshold are changed to 100% (fully opaque).

For a list of all members of this type, see AlphaBiLevel Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.AlphaBiLevel

[Visual Basic]
Public Class AlphaBiLevel
Inherits ImageTransformOperation
Implements IAlphaBiLevel
[C#]
public class AlphaBiLevel : ImageTransformOperation, IAlphaBiLevel

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AlphaBiLevel Members | Aspose.Slides.Effects Namespace


AlphaBiLevel Members

AlphaBiLevel overview

Public Instance Constructors

AlphaBiLevel Constructor Alpha Bi-Level effect constructor.

Public Instance Properties

Threshold Returns effect threshold. Readonly Single.

See Also

AlphaBiLevel Class | Aspose.Slides.Effects Namespace


AlphaBiLevel Constructor

Alpha Bi-Level effect constructor.

[Visual Basic]
Overloads Public Sub New( _
ByVal threshold As Single _
)
[C#]
public AlphaBiLevel(
float threshold
);

Parameters

threshold
The threshold value for the alpha bi-level effect.

See Also

AlphaBiLevel Class | Aspose.Slides.Effects Namespace


AlphaBiLevel Properties

The properties of the AlphaBiLevel class are listed below. For a complete list of AlphaBiLevel class members, see the AlphaBiLevel Members topic.

Public Instance Properties

Threshold Returns effect threshold. Readonly Single.

See Also

AlphaBiLevel Class | Aspose.Slides.Effects Namespace


Threshold Property

Aspose.Slides Documentation

AlphaBiLevel.Threshold Property

Returns effect threshold. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Threshold As Single _
Implements IAlphaBiLevel.Threshold
[C#]
public float Threshold {get;}

Implements

IAlphaBiLevel.Threshold

See Also

AlphaBiLevel Class | Aspose.Slides.Effects Namespace


AlphaBiLevelEffectiveData Class

Immutable object which represents an Alpha Bi-Level effect. Alpha (Opacity) values less than the threshold are changed to 0 (fully transparent) and alpha values greater than or equal to the threshold are changed to 100% (fully opaque).

For a list of all members of this type, see AlphaBiLevelEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.AlphaBiLevelEffectiveData

[Visual Basic]
Public Class AlphaBiLevelEffectiveData
Inherits EffectEffectiveData
Implements IAlphaBiLevelEffectiveData
[C#]
public class AlphaBiLevelEffectiveData : EffectEffectiveData, IAlphaBiLevelEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AlphaBiLevelEffectiveData Members | Aspose.Slides.Effects Namespace


AlphaBiLevelEffectiveData Members

AlphaBiLevelEffectiveData overview

Public Instance Properties

Threshold Returns a threshold. Readonly Single.

See Also

AlphaBiLevelEffectiveData Class | Aspose.Slides.Effects Namespace


AlphaBiLevelEffectiveData Properties

The properties of the AlphaBiLevelEffectiveData class are listed below. For a complete list of AlphaBiLevelEffectiveData class members, see the AlphaBiLevelEffectiveData Members topic.

Public Instance Properties

Threshold Returns a threshold. Readonly Single.

See Also

AlphaBiLevelEffectiveData Class | Aspose.Slides.Effects Namespace


Threshold Property

Aspose.Slides Documentation

AlphaBiLevelEffectiveData.Threshold Property

Returns a threshold. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Threshold As Single _
Implements IAlphaBiLevelEffectiveData.Threshold
[C#]
public float Threshold {get;}

Implements

IAlphaBiLevelEffectiveData.Threshold

See Also

AlphaBiLevelEffectiveData Class | Aspose.Slides.Effects Namespace


AlphaCeiling Class

Represents an Alpha Ceiling effect. Alpha (opacity) values greater than zero are changed to 100%. In other words, anything partially opaque becomes fully opaque.

For a list of all members of this type, see AlphaCeiling Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.AlphaCeiling

[Visual Basic]
Public Class AlphaCeiling
Inherits ImageTransformOperation
Implements IAlphaCeiling
[C#]
public class AlphaCeiling : ImageTransformOperation, IAlphaCeiling

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AlphaCeiling Members | Aspose.Slides.Effects Namespace


AlphaCeiling Members

AlphaCeiling overview

Public Instance Constructors

AlphaCeiling Constructor Alpha Ceiling effect constructor.

See Also

AlphaCeiling Class | Aspose.Slides.Effects Namespace


AlphaCeiling Constructor

Alpha Ceiling effect constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AlphaCeiling();

See Also

AlphaCeiling Class | Aspose.Slides.Effects Namespace


AlphaCeilingEffectiveData Class

Immutable object which represents an Alpha Ceiling effect. Alpha (opacity) values greater than zero are changed to 100%. In other words, anything partially opaque becomes fully opaque.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.AlphaCeilingEffectiveData

[Visual Basic]
Public Class AlphaCeilingEffectiveData
Inherits EffectEffectiveData
Implements IAlphaCeilingEffectiveData
[C#]
public class AlphaCeilingEffectiveData : EffectEffectiveData, IAlphaCeilingEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


AlphaFloor Class

Represents an Alpha Floor effect. Alpha (opacity) values less than 100% are changed to zero. In other words, anything partially transparent becomes fully transparent.

For a list of all members of this type, see AlphaFloor Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.AlphaFloor

[Visual Basic]
Public Class AlphaFloor
Inherits ImageTransformOperation
Implements IAlphaFloor
[C#]
public class AlphaFloor : ImageTransformOperation, IAlphaFloor

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AlphaFloor Members | Aspose.Slides.Effects Namespace


AlphaFloor Members

AlphaFloor overview

Public Instance Constructors

AlphaFloor Constructor Default constructor.

See Also

AlphaFloor Class | Aspose.Slides.Effects Namespace


AlphaFloor Constructor

Default constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AlphaFloor();

See Also

AlphaFloor Class | Aspose.Slides.Effects Namespace


AlphaFloorEffectiveData Class

Immutable object which represents an Alpha Floor effect. Alpha (opacity) values less than 100% are changed to zero. In other words, anything partially transparent becomes fully transparent.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.AlphaFloorEffectiveData

[Visual Basic]
Public Class AlphaFloorEffectiveData
Inherits EffectEffectiveData
Implements IAlphaFloorEffectiveData
[C#]
public class AlphaFloorEffectiveData : EffectEffectiveData, IAlphaFloorEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


AlphaInverse Class

Represents an Alpha Inverse effect. Alpha (opacity) values are inverted by subtracting from 100%.

For a list of all members of this type, see AlphaInverse Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.AlphaInverse

[Visual Basic]
Public Class AlphaInverse
Inherits ImageTransformOperation
Implements IAlphaInverse
[C#]
public class AlphaInverse : ImageTransformOperation, IAlphaInverse

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AlphaInverse Members | Aspose.Slides.Effects Namespace


AlphaInverse Members

AlphaInverse overview

Public Instance Constructors

AlphaInverse Constructor Alpha Inverse effect constructor.

See Also

AlphaInverse Class | Aspose.Slides.Effects Namespace


AlphaInverse Constructor

Alpha Inverse effect constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AlphaInverse();

See Also

AlphaInverse Class | Aspose.Slides.Effects Namespace


AlphaInverseEffectiveData Class

Immutable object which represents an Alpha Inverse effect. Alpha (opacity) values are inverted by subtracting from 100%.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.AlphaInverseEffectiveData

[Visual Basic]
Public Class AlphaInverseEffectiveData
Inherits EffectEffectiveData
Implements IAlphaInverseEffectiveData
[C#]
public class AlphaInverseEffectiveData : EffectEffectiveData, IAlphaInverseEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


AlphaModulate Class

Represents an Alpha Modulate effect. Effect alpha (opacity) values are multiplied by a fixed percentage. The effect container specifies an effect containing alpha values to modulate.

For a list of all members of this type, see AlphaModulate Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.AlphaModulate

[Visual Basic]
Public Class AlphaModulate
Inherits ImageTransformOperation
Implements IAlphaModulate
[C#]
public class AlphaModulate : ImageTransformOperation, IAlphaModulate

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AlphaModulate Members | Aspose.Slides.Effects Namespace


AlphaModulate Members

AlphaModulate overview

Public Instance Constructors

AlphaModulate Constructor Alpha Modulate effect constructor.

See Also

AlphaModulate Class | Aspose.Slides.Effects Namespace


AlphaModulate Constructor

Alpha Modulate effect constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AlphaModulate();

See Also

AlphaModulate Class | Aspose.Slides.Effects Namespace


AlphaModulateEffectiveData Class

Immutable object which represents an Alpha Modulate effect. Effect alpha (opacity) values are multiplied by a fixed percentage. The effect container specifies an effect containing alpha values to modulate.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.AlphaModulateEffectiveData

[Visual Basic]
Public Class AlphaModulateEffectiveData
Inherits EffectEffectiveData
Implements IAlphaModulateEffectiveData
[C#]
public class AlphaModulateEffectiveData : EffectEffectiveData, IAlphaModulateEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


AlphaModulateFixed Class

Represents an Alpha Modulate Fixed effect. Effect alpha (opacity) values are multiplied by a fixed percentage.

For a list of all members of this type, see AlphaModulateFixed Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.AlphaModulateFixed

[Visual Basic]
Public Class AlphaModulateFixed
Inherits ImageTransformOperation
Implements IAlphaModulateFixed
[C#]
public class AlphaModulateFixed : ImageTransformOperation, IAlphaModulateFixed

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AlphaModulateFixed Members | Aspose.Slides.Effects Namespace


AlphaModulateFixed Members

AlphaModulateFixed overview

Public Instance Constructors

AlphaModulateFixed Constructor Alpha Modulate Fixed effect constructor.

Public Instance Properties

Amount Returns an amount of effect in percents.

See Also

AlphaModulateFixed Class | Aspose.Slides.Effects Namespace


AlphaModulateFixed Constructor

Alpha Modulate Fixed effect constructor.

[Visual Basic]
Overloads Public Sub New( _
ByVal amount As Single _
)
[C#]
public AlphaModulateFixed(
float amount
);

Parameters

amount
The percentage amount to scale the alpha.

See Also

AlphaModulateFixed Class | Aspose.Slides.Effects Namespace


AlphaModulateFixed Properties

The properties of the AlphaModulateFixed class are listed below. For a complete list of AlphaModulateFixed class members, see the AlphaModulateFixed Members topic.

Public Instance Properties

Amount Returns an amount of effect in percents.

See Also

AlphaModulateFixed Class | Aspose.Slides.Effects Namespace


Amount Property

Aspose.Slides Documentation

AlphaModulateFixed.Amount Property

Returns an amount of effect in percents.

[Visual Basic]
NotOverridable Public Property Amount As Single _
Implements IAlphaModulateFixed.Amount
[C#]
public float Amount {get; set;}

Implements

IAlphaModulateFixed.Amount

See Also

AlphaModulateFixed Class | Aspose.Slides.Effects Namespace


AlphaModulateFixedEffectiveData Class

Immutable object which represents an Alpha Modulate Fixed effect. Effect alpha (opacity) values are multiplied by a fixed percentage.

For a list of all members of this type, see AlphaModulateFixedEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.AlphaModulateFixedEffectiveData

[Visual Basic]
Public Class AlphaModulateFixedEffectiveData
Inherits EffectEffectiveData
Implements IAlphaModulateFixedEffectiveData
[C#]
public class AlphaModulateFixedEffectiveData : EffectEffectiveData, IAlphaModulateFixedEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AlphaModulateFixedEffectiveData Members | Aspose.Slides.Effects Namespace


AlphaModulateFixedEffectiveData Members

AlphaModulateFixedEffectiveData overview

Public Instance Properties

Amount Returns the effect amount. Readonly Single.

See Also

AlphaModulateFixedEffectiveData Class | Aspose.Slides.Effects Namespace


AlphaModulateFixedEffectiveData Properties

The properties of the AlphaModulateFixedEffectiveData class are listed below. For a complete list of AlphaModulateFixedEffectiveData class members, see the AlphaModulateFixedEffectiveData Members topic.

Public Instance Properties

Amount Returns the effect amount. Readonly Single.

See Also

AlphaModulateFixedEffectiveData Class | Aspose.Slides.Effects Namespace


Amount Property

Aspose.Slides Documentation

AlphaModulateFixedEffectiveData.Amount Property

Returns the effect amount. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Amount As Single _
Implements IAlphaModulateFixedEffectiveData.Amount
[C#]
public float Amount {get;}

Implements

IAlphaModulateFixedEffectiveData.Amount

See Also

AlphaModulateFixedEffectiveData Class | Aspose.Slides.Effects Namespace


AlphaReplace Class

Represents and Alpha Replace effect. Effect alpha (opacity) values are replaced by a fixed alpha.

For a list of all members of this type, see AlphaReplace Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.AlphaReplace

[Visual Basic]
Public Class AlphaReplace
Inherits ImageTransformOperation
Implements IAlphaReplace
[C#]
public class AlphaReplace : ImageTransformOperation, IAlphaReplace

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AlphaReplace Members | Aspose.Slides.Effects Namespace


AlphaReplace Members

AlphaReplace overview

Public Instance Constructors

AlphaReplace Constructor Alpha Replace effect constructor.

See Also

AlphaReplace Class | Aspose.Slides.Effects Namespace


AlphaReplace Constructor

Alpha Replace effect constructor.

[Visual Basic]
Overloads Public Sub New( _
ByVal alpha As Single _
)
[C#]
public AlphaReplace(
float alpha
);

Parameters

alpha
The new opacity value.

See Also

AlphaReplace Class | Aspose.Slides.Effects Namespace


AlphaReplaceEffectiveData Class

Immutable object which represents and Alpha Replace effect. Effect alpha (opacity) values are replaced by a fixed alpha.

For a list of all members of this type, see AlphaReplaceEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.AlphaReplaceEffectiveData

[Visual Basic]
Public Class AlphaReplaceEffectiveData
Inherits EffectEffectiveData
Implements IAlphaReplaceEffectiveData
[C#]
public class AlphaReplaceEffectiveData : EffectEffectiveData, IAlphaReplaceEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

AlphaReplaceEffectiveData Members | Aspose.Slides.Effects Namespace


AlphaReplaceEffectiveData Members

AlphaReplaceEffectiveData overview

Public Instance Properties

Alpha Returns new alpha value in the interval [0..1] Readonly Single.

See Also

AlphaReplaceEffectiveData Class | Aspose.Slides.Effects Namespace


AlphaReplaceEffectiveData Properties

The properties of the AlphaReplaceEffectiveData class are listed below. For a complete list of AlphaReplaceEffectiveData class members, see the AlphaReplaceEffectiveData Members topic.

Public Instance Properties

Alpha Returns new alpha value in the interval [0..1] Readonly Single.

See Also

AlphaReplaceEffectiveData Class | Aspose.Slides.Effects Namespace


Alpha Property

Aspose.Slides Documentation

AlphaReplaceEffectiveData.Alpha Property

Returns new alpha value in the interval [0..1] Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Alpha As Single _
Implements IAlphaReplaceEffectiveData.Alpha
[C#]
public float Alpha {get;}

Implements

IAlphaReplaceEffectiveData.Alpha

See Also

AlphaReplaceEffectiveData Class | Aspose.Slides.Effects Namespace


BiLevel Class

Represents a Bi-Level (black/white) effect. Input colors whose luminance is less than the specified threshold value are changed to black. Input colors whose luminance are greater than or equal the specified value are set to white. The alpha effect values are unaffected by this effect.

For a list of all members of this type, see BiLevel Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.BiLevel

[Visual Basic]
Public Class BiLevel
Inherits ImageTransformOperation
Implements IBiLevel
[C#]
public class BiLevel : ImageTransformOperation, IBiLevel

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BiLevel Members | Aspose.Slides.Effects Namespace


BiLevel Members

BiLevel overview

Public Instance Constructors

BiLevel Constructor Bi-Level effect constructor.

See Also

BiLevel Class | Aspose.Slides.Effects Namespace


BiLevel Constructor

Bi-Level effect constructor.

[Visual Basic]
Overloads Public Sub New( _
ByVal threshold As Single _
)
[C#]
public BiLevel(
float threshold
);

Parameters

threshold
the luminance threshold for the Bi-Level effect. Values greater than or equal to the threshold are set to white. Values lesser than the threshold are set to black.

See Also

BiLevel Class | Aspose.Slides.Effects Namespace


BiLevelEffectiveData Class

Immutable object which represents a Bi-Level (black/white) effect. Input colors whose luminance is less than the specified threshold value are changed to black. Input colors whose luminance are greater than or equal the specified value are set to white. The alpha effect values are unaffected by this effect.

For a list of all members of this type, see BiLevelEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.BiLevelEffectiveData

[Visual Basic]
Public Class BiLevelEffectiveData
Inherits EffectEffectiveData
Implements IBiLevelEffectiveData
[C#]
public class BiLevelEffectiveData : EffectEffectiveData, IBiLevelEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BiLevelEffectiveData Members | Aspose.Slides.Effects Namespace


BiLevelEffectiveData Members

BiLevelEffectiveData overview

Public Instance Properties

Threshold Returns the threshold value. Readonly Single.

See Also

BiLevelEffectiveData Class | Aspose.Slides.Effects Namespace


BiLevelEffectiveData Properties

The properties of the BiLevelEffectiveData class are listed below. For a complete list of BiLevelEffectiveData class members, see the BiLevelEffectiveData Members topic.

Public Instance Properties

Threshold Returns the threshold value. Readonly Single.

See Also

BiLevelEffectiveData Class | Aspose.Slides.Effects Namespace


Threshold Property

Aspose.Slides Documentation

BiLevelEffectiveData.Threshold Property

Returns the threshold value. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Threshold As Single _
Implements IBiLevelEffectiveData.Threshold
[C#]
public float Threshold {get;}

Implements

IBiLevelEffectiveData.Threshold

See Also

BiLevelEffectiveData Class | Aspose.Slides.Effects Namespace


Blur Class

Represents a Blur effect that is applied to the entire shape, including its fill. All color channels, including alpha, are affected.

For a list of all members of this type, see Blur Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.Blur

[Visual Basic]
Public Class Blur
Inherits ImageTransformOperation
Implements IBlur
[C#]
public class Blur : ImageTransformOperation, IBlur

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Blur Members | Aspose.Slides.Effects Namespace


Blur Members

Blur overview

Public Instance Constructors

Blur Constructor Blur effect constructor.

Public Instance Properties

Grow | Determines whether the bounds of the object should be grown as a result of the blurring. True indicates the bounds are grown while false indicates that they are not.
Radius | Returns or sets blur radius. Read/write Double.

See Also

Blur Class | Aspose.Slides.Effects Namespace


Blur Constructor

Blur effect constructor.

[Visual Basic]
Overloads Public Sub New( _
ByVal radius As Double, _
ByVal grow As Boolean _
)
[C#]
public Blur(
double radius,
bool grow
);

Parameters

radius
The radius of blur.
grow
Specifies whether the bounds of the object should be grown as a result of the blurring. True indicates the bounds are grown while false indicates that they are not.

See Also

Blur Class | Aspose.Slides.Effects Namespace


Blur Properties

The properties of the Blur class are listed below. For a complete list of Blur class members, see the Blur Members topic.

Public Instance Properties

Grow | Determines whether the bounds of the object should be grown as a result of the blurring. True indicates the bounds are grown while false indicates that they are not.
Radius | Returns or sets blur radius. Read/write Double.

See Also

Blur Class | Aspose.Slides.Effects Namespace


Grow Property

Aspose.Slides Documentation

Blur.Grow Property

Determines whether the bounds of the object should be grown as a result of the blurring. True indicates the bounds are grown while false indicates that they are not.

[Visual Basic]
NotOverridable Public Property Grow As Boolean _
Implements IBlur.Grow
[C#]
public bool Grow {get; set;}

Implements

IBlur.Grow

See Also

Blur Class | Aspose.Slides.Effects Namespace


Radius Property

Aspose.Slides Documentation

Blur.Radius Property

Returns or sets blur radius. Read/write Double.

[Visual Basic]
NotOverridable Public Property Radius As Double _
Implements IBlur.Radius
[C#]
public double Radius {get; set;}

Implements

IBlur.Radius

See Also

Blur Class | Aspose.Slides.Effects Namespace


BlurEffectiveData Class

Immutable object which represents a Blur effect that is applied to the entire shape, including its fill. All color channels, including alpha, are affected.

For a list of all members of this type, see BlurEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.BlurEffectiveData

[Visual Basic]
Public Class BlurEffectiveData
Inherits EffectEffectiveData
Implements IBlurEffectiveData
[C#]
public class BlurEffectiveData : EffectEffectiveData, IBlurEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BlurEffectiveData Members | Aspose.Slides.Effects Namespace


BlurEffectiveData Members

BlurEffectiveData overview

Public Instance Properties

Grow | Determines whether effect spreads beyond shape border. Readonly Boolean.
Radius | Blur radius. Readonly Double.

See Also

BlurEffectiveData Class | Aspose.Slides.Effects Namespace


BlurEffectiveData Properties

The properties of the BlurEffectiveData class are listed below. For a complete list of BlurEffectiveData class members, see the BlurEffectiveData Members topic.

Public Instance Properties

Grow | Determines whether effect spreads beyond shape border. Readonly Boolean.
Radius | Blur radius. Readonly Double.

See Also

BlurEffectiveData Class | Aspose.Slides.Effects Namespace


Grow Property

Aspose.Slides Documentation

BlurEffectiveData.Grow Property

Determines whether effect spreads beyond shape border. Readonly Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property Grow As Boolean _
Implements IBlurEffectiveData.Grow
[C#]
public bool Grow {get;}

Implements

IBlurEffectiveData.Grow

See Also

BlurEffectiveData Class | Aspose.Slides.Effects Namespace


Radius Property

Aspose.Slides Documentation

BlurEffectiveData.Radius Property

Blur radius. Readonly Double.

[Visual Basic]
NotOverridable Public ReadOnly Property Radius As Double _
Implements IBlurEffectiveData.Radius
[C#]
public double Radius {get;}

Implements

IBlurEffectiveData.Radius

See Also

BlurEffectiveData Class | Aspose.Slides.Effects Namespace


ColorChange Class

Represents a Color Change effect. Instances of FromColor are replaced with instances of ToColor.

For a list of all members of this type, see ColorChange Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.ColorChange

[Visual Basic]
Public Class ColorChange
Inherits ImageTransformOperation
Implements IColorChange
[C#]
public class ColorChange : ImageTransformOperation, IColorChange

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ColorChange Members | Aspose.Slides.Effects Namespace


ColorChange Members

ColorChange overview

Public Instance Constructors

ColorChange Constructor Color Change effect constructor.

Public Instance Properties

FromColor | Color which will be replaced. Readonly ColorFormat.
ToColor | Color which will replace. Readonly ColorFormat.

See Also

ColorChange Class | Aspose.Slides.Effects Namespace


ColorChange Constructor

Color Change effect constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ColorChange();

See Also

ColorChange Class | Aspose.Slides.Effects Namespace


ColorChange Properties

The properties of the ColorChange class are listed below. For a complete list of ColorChange class members, see the ColorChange Members topic.

Public Instance Properties

FromColor | Color which will be replaced. Readonly ColorFormat.
ToColor | Color which will replace. Readonly ColorFormat.

See Also

ColorChange Class | Aspose.Slides.Effects Namespace


FromColor Property

Aspose.Slides Documentation

ColorChange.FromColor Property

Color which will be replaced. Readonly ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property FromColor As IColorFormat _
Implements IColorChange.FromColor
[C#]
public IColorFormat FromColor {get;}

Implements

IColorChange.FromColor

See Also

ColorChange Class | Aspose.Slides.Effects Namespace


ToColor Property

Aspose.Slides Documentation

ColorChange.ToColor Property

Color which will replace. Readonly ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property ToColor As IColorFormat _
Implements IColorChange.ToColor
[C#]
public IColorFormat ToColor {get;}

Implements

IColorChange.ToColor

See Also

ColorChange Class | Aspose.Slides.Effects Namespace


ColorChangeEffectiveData Class

Immutable object which represents a Color Change effect. Instances of FromColor are replaced with instances of ToColor.

For a list of all members of this type, see ColorChangeEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.ColorChangeEffectiveData

[Visual Basic]
Public Class ColorChangeEffectiveData
Inherits EffectEffectiveData
Implements IColorChangeEffectiveData
[C#]
public class ColorChangeEffectiveData : EffectEffectiveData, IColorChangeEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ColorChangeEffectiveData Members | Aspose.Slides.Effects Namespace


ColorChangeEffectiveData Members

ColorChangeEffectiveData overview

Public Instance Properties

FromColor | Returns color which will be replaced. Readonly Color.
ToColor | Returns color which will replace. Readonly Color.
UseAlpha | Returns a boolean value which determines if alpha component should be used. Readonly Boolean.

See Also

ColorChangeEffectiveData Class | Aspose.Slides.Effects Namespace


ColorChangeEffectiveData Properties

The properties of the ColorChangeEffectiveData class are listed below. For a complete list of ColorChangeEffectiveData class members, see the ColorChangeEffectiveData Members topic.

Public Instance Properties

FromColor | Returns color which will be replaced. Readonly Color.
ToColor | Returns color which will replace. Readonly Color.
UseAlpha | Returns a boolean value which determines if alpha component should be used. Readonly Boolean.

See Also

ColorChangeEffectiveData Class | Aspose.Slides.Effects Namespace


FromColor Property

Aspose.Slides Documentation

ColorChangeEffectiveData.FromColor Property

Returns color which will be replaced. Readonly Color.

[Visual Basic]
NotOverridable Public ReadOnly Property FromColor As Color _
Implements IColorChangeEffectiveData.FromColor
[C#]
public Color FromColor {get;}

Implements

IColorChangeEffectiveData.FromColor

See Also

ColorChangeEffectiveData Class | Aspose.Slides.Effects Namespace


ToColor Property

Aspose.Slides Documentation

ColorChangeEffectiveData.ToColor Property

Returns color which will replace. Readonly Color.

[Visual Basic]
NotOverridable Public ReadOnly Property ToColor As Color _
Implements IColorChangeEffectiveData.ToColor
[C#]
public Color ToColor {get;}

Implements

IColorChangeEffectiveData.ToColor

See Also

ColorChangeEffectiveData Class | Aspose.Slides.Effects Namespace


UseAlpha Property

Aspose.Slides Documentation

ColorChangeEffectiveData.UseAlpha Property

Returns a boolean value which determines if alpha component should be used. Readonly Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property UseAlpha As Boolean _
Implements IColorChangeEffectiveData.UseAlpha
[C#]
public bool UseAlpha {get;}

Implements

IColorChangeEffectiveData.UseAlpha

See Also

ColorChangeEffectiveData Class | Aspose.Slides.Effects Namespace


ColorReplace Class

Represents a Color Replacement effect. All effect colors are changed to a fixed color. Alpha values are unaffected.

For a list of all members of this type, see ColorReplace Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.ColorReplace

[Visual Basic]
Public Class ColorReplace
Inherits ImageTransformOperation
Implements IColorReplace
[C#]
public class ColorReplace : ImageTransformOperation, IColorReplace

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ColorReplace Members | Aspose.Slides.Effects Namespace


ColorReplace Members

ColorReplace overview

Public Instance Constructors

ColorReplace Constructor Color Replace effect consructor.

Public Instance Properties

Color Returns color format which will replace color of every pixel.

See Also

ColorReplace Class | Aspose.Slides.Effects Namespace


ColorReplace Constructor

Color Replace effect consructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ColorReplace();

See Also

ColorReplace Class | Aspose.Slides.Effects Namespace


ColorReplace Properties

The properties of the ColorReplace class are listed below. For a complete list of ColorReplace class members, see the ColorReplace Members topic.

Public Instance Properties

Color Returns color format which will replace color of every pixel.

See Also

ColorReplace Class | Aspose.Slides.Effects Namespace


Color Property

Aspose.Slides Documentation

ColorReplace.Color Property

Returns color format which will replace color of every pixel.

[Visual Basic]
NotOverridable Public ReadOnly Property Color As IColorFormat _
Implements IColorReplace.Color
[C#]
public IColorFormat Color {get;}

Implements

IColorReplace.Color

See Also

ColorReplace Class | Aspose.Slides.Effects Namespace


ColorReplaceEffectiveData Class

Immutable object which represents a Color Replacement effect. All effect colors are changed to a fixed color. Alpha values are unaffected.

For a list of all members of this type, see ColorReplaceEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.ColorReplaceEffectiveData

[Visual Basic]
Public Class ColorReplaceEffectiveData
Inherits EffectEffectiveData
Implements IColorReplaceEffectiveData
[C#]
public class ColorReplaceEffectiveData : EffectEffectiveData, IColorReplaceEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ColorReplaceEffectiveData Members | Aspose.Slides.Effects Namespace


ColorReplaceEffectiveData Members

ColorReplaceEffectiveData overview

Public Instance Properties

Color Returns color. Readonly Color.

See Also

ColorReplaceEffectiveData Class | Aspose.Slides.Effects Namespace


ColorReplaceEffectiveData Properties

The properties of the ColorReplaceEffectiveData class are listed below. For a complete list of ColorReplaceEffectiveData class members, see the ColorReplaceEffectiveData Members topic.

Public Instance Properties

Color Returns color. Readonly Color.

See Also

ColorReplaceEffectiveData Class | Aspose.Slides.Effects Namespace


Color Property

Aspose.Slides Documentation

ColorReplaceEffectiveData.Color Property

Returns color. Readonly Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Color As Color _
Implements IColorReplaceEffectiveData.Color
[C#]
public Color Color {get;}

Implements

IColorReplaceEffectiveData.Color

See Also

ColorReplaceEffectiveData Class | Aspose.Slides.Effects Namespace


Duotone Class

Represents a Duotone effect. For each pixel, combines Color1 and Color2 through a linear interpolation to determine the new color for that pixel.

For a list of all members of this type, see Duotone Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.Duotone

[Visual Basic]
Public Class Duotone
Inherits ImageTransformOperation
Implements IDuotone
[C#]
public class Duotone : ImageTransformOperation, IDuotone

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Duotone Members | Aspose.Slides.Effects Namespace


Duotone Members

Duotone overview

Public Instance Constructors

Duotone Constructor Duotone effect constructor.

Public Instance Properties

Color1 | Returns target color format for dark pixels. Readonly ColorFormat.
Color2 | Returns target color format for light pixels. Readonly ColorFormat.

See Also

Duotone Class | Aspose.Slides.Effects Namespace


Duotone Constructor

Duotone effect constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Duotone();

See Also

Duotone Class | Aspose.Slides.Effects Namespace


Duotone Properties

The properties of the Duotone class are listed below. For a complete list of Duotone class members, see the Duotone Members topic.

Public Instance Properties

Color1 | Returns target color format for dark pixels. Readonly ColorFormat.
Color2 | Returns target color format for light pixels. Readonly ColorFormat.

See Also

Duotone Class | Aspose.Slides.Effects Namespace


Color1 Property

Aspose.Slides Documentation

Duotone.Color1 Property

Returns target color format for dark pixels. Readonly ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Color1 As IColorFormat _
Implements IDuotone.Color1
[C#]
public IColorFormat Color1 {get;}

Implements

IDuotone.Color1

See Also

Duotone Class | Aspose.Slides.Effects Namespace


Color2 Property

Aspose.Slides Documentation

Duotone.Color2 Property

Returns target color format for light pixels. Readonly ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Color2 As IColorFormat _
Implements IDuotone.Color2
[C#]
public IColorFormat Color2 {get;}

Implements

IDuotone.Color2

See Also

Duotone Class | Aspose.Slides.Effects Namespace


DuotoneEffectiveData Class

Immutable object which represents a Duotone effect. For each pixel, combines clr1 and clr2 through a linear interpolation to determine the new color for that pixel.

For a list of all members of this type, see DuotoneEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.DuotoneEffectiveData

[Visual Basic]
Public Class DuotoneEffectiveData
Inherits EffectEffectiveData
Implements IDuotoneEffectiveData
[C#]
public class DuotoneEffectiveData : EffectEffectiveData, IDuotoneEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

DuotoneEffectiveData Members | Aspose.Slides.Effects Namespace


DuotoneEffectiveData Members

DuotoneEffectiveData overview

Public Instance Properties

Color1 | Returns a first color. Readonly Color.
Color2 | Returns a second color. Readonly Color.

See Also

DuotoneEffectiveData Class | Aspose.Slides.Effects Namespace


DuotoneEffectiveData Properties

The properties of the DuotoneEffectiveData class are listed below. For a complete list of DuotoneEffectiveData class members, see the DuotoneEffectiveData Members topic.

Public Instance Properties

Color1 | Returns a first color. Readonly Color.
Color2 | Returns a second color. Readonly Color.

See Also

DuotoneEffectiveData Class | Aspose.Slides.Effects Namespace


Color1 Property

Aspose.Slides Documentation

DuotoneEffectiveData.Color1 Property

Returns a first color. Readonly Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Color1 As Color _
Implements IDuotoneEffectiveData.Color1
[C#]
public Color Color1 {get;}

Implements

IDuotoneEffectiveData.Color1

See Also

DuotoneEffectiveData Class | Aspose.Slides.Effects Namespace


Color2 Property

Aspose.Slides Documentation

DuotoneEffectiveData.Color2 Property

Returns a second color. Readonly Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Color2 As Color _
Implements IDuotoneEffectiveData.Color2
[C#]
public Color Color2 {get;}

Implements

IDuotoneEffectiveData.Color2

See Also

DuotoneEffectiveData Class | Aspose.Slides.Effects Namespace


EffectEffectiveData Class

Base class for immutable objects, which represent effect.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Derived types

[Visual Basic]
MustInherit Public Class EffectEffectiveData
Implements IEffectEffectiveData
[C#]
public abstract class EffectEffectiveData : IEffectEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


EffectFactory Class

Allows to create effects

For a list of all members of this type, see EffectFactory Members.

System.Object
Aspose.Slides.Effects.EffectFactory

[Visual Basic]
Public Class EffectFactory
Implements IEffectFactory
[C#]
public class EffectFactory : IEffectFactory

Remarks

For COM compatibility

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

EffectFactory Members | Aspose.Slides.Effects Namespace


EffectFactory Members

EffectFactory overview

Public Instance Constructors

EffectFactory Constructor Initializes a new instance of the EffectFactory class.

Public Instance Properties

ImageTransformOperationFactory

Public Instance Methods

CreateInnerShadow
CreateOuterShadow
CreatePresetShadow
CreateReflection
CreateSoftEdge

See Also

EffectFactory Class | Aspose.Slides.Effects Namespace


EffectFactory Constructor

Initializes a new instance of the EffectFactory class.

[Visual Basic]
Public Sub New()
[C#]
public EffectFactory();

See Also

EffectFactory Class | Aspose.Slides.Effects Namespace


EffectFactory Properties

The properties of the EffectFactory class are listed below. For a complete list of EffectFactory class members, see the EffectFactory Members topic.

Public Instance Properties

ImageTransformOperationFactory

See Also

EffectFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory Property

Aspose.Slides Documentation

EffectFactory.ImageTransformOperationFactory Property

[Visual Basic]
NotOverridable Public ReadOnly Property ImageTransformOperationFactory As IImageTransformOperationFactory _
Implements IEffectFactory.ImageTransformOperationFactory
[C#]
public IImageTransformOperationFactory ImageTransformOperationFactory {get;}

Implements

IEffectFactory.ImageTransformOperationFactory

See Also

EffectFactory Class | Aspose.Slides.Effects Namespace


EffectFactory Methods

The methods of the EffectFactory class are listed below. For a complete list of EffectFactory class members, see the EffectFactory Members topic.

Public Instance Methods

CreateInnerShadow
CreateOuterShadow
CreatePresetShadow
CreateReflection
CreateSoftEdge

See Also

EffectFactory Class | Aspose.Slides.Effects Namespace


EffectFactory.CreateInnerShadow Method

[Visual Basic]
NotOverridable Public Function CreateInnerShadow() As IInnerShadow _
Implements IEffectFactory.CreateInnerShadow
[C#]
public IInnerShadow CreateInnerShadow();

Implements

IEffectFactory.CreateInnerShadow

See Also

EffectFactory Class | Aspose.Slides.Effects Namespace


EffectFactory.CreateOuterShadow Method

[Visual Basic]
NotOverridable Public Function CreateOuterShadow() As IOuterShadow _
Implements IEffectFactory.CreateOuterShadow
[C#]
public IOuterShadow CreateOuterShadow();

Implements

IEffectFactory.CreateOuterShadow

See Also

EffectFactory Class | Aspose.Slides.Effects Namespace


EffectFactory.CreatePresetShadow Method

[Visual Basic]
NotOverridable Public Function CreatePresetShadow() As IPresetShadow _
Implements IEffectFactory.CreatePresetShadow
[C#]
public IPresetShadow CreatePresetShadow();

Implements

IEffectFactory.CreatePresetShadow

See Also

EffectFactory Class | Aspose.Slides.Effects Namespace


EffectFactory.CreateReflection Method

[Visual Basic]
NotOverridable Public Function CreateReflection() As IReflection _
Implements IEffectFactory.CreateReflection
[C#]
public IReflection CreateReflection();

Implements

IEffectFactory.CreateReflection

See Also

EffectFactory Class | Aspose.Slides.Effects Namespace


EffectFactory.CreateSoftEdge Method

[Visual Basic]
NotOverridable Public Function CreateSoftEdge() As ISoftEdge _
Implements IEffectFactory.CreateSoftEdge
[C#]
public ISoftEdge CreateSoftEdge();

Implements

IEffectFactory.CreateSoftEdge

See Also

EffectFactory Class | Aspose.Slides.Effects Namespace


FillOverlay Class

Represents a Fill Overlay effect. A fill overlay may be used to specify an additional fill for an object and blend the two fills together.

For a list of all members of this type, see FillOverlay Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.FillOverlay

[Visual Basic]
Public Class FillOverlay
Inherits ImageTransformOperation
Implements IFillOverlay
[C#]
public class FillOverlay : ImageTransformOperation, IFillOverlay

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FillOverlay Members | Aspose.Slides.Effects Namespace


FillOverlay Members

FillOverlay overview

Public Instance Constructors

FillOverlay Constructor Fill Overlay effect constructor.

Public Instance Properties

Blend | FillBlendMode.
FillFormat | Fill format.

See Also

FillOverlay Class | Aspose.Slides.Effects Namespace


FillOverlay Constructor

Fill Overlay effect constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FillOverlay();

See Also

FillOverlay Class | Aspose.Slides.Effects Namespace


FillOverlay Properties

The properties of the FillOverlay class are listed below. For a complete list of FillOverlay class members, see the FillOverlay Members topic.

Public Instance Properties

Blend | FillBlendMode.
FillFormat | Fill format.

See Also

FillOverlay Class | Aspose.Slides.Effects Namespace


Blend Property

Aspose.Slides Documentation

FillOverlay.Blend Property

FillBlendMode.

[Visual Basic]
NotOverridable Public Property Blend As FillBlendMode _
Implements IFillOverlay.Blend
[C#]
public FillBlendMode Blend {get; set;}

Implements

IFillOverlay.Blend

See Also

FillOverlay Class | Aspose.Slides.Effects Namespace


FillFormat Property

Aspose.Slides Documentation

FillOverlay.FillFormat Property

Fill format.

[Visual Basic]
NotOverridable Public Property FillFormat As IFillFormat _
Implements IFillOverlay.FillFormat
[C#]
public IFillFormat FillFormat {get; set;}

Implements

IFillOverlay.FillFormat

See Also

FillOverlay Class | Aspose.Slides.Effects Namespace


FillOverlayEffectiveData Class

Immutable object which represents a Fill Overlay effect. A fill overlay may be used to specify an additional fill for an object and blend the two fills together.

For a list of all members of this type, see FillOverlayEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.FillOverlayEffectiveData

[Visual Basic]
Public Class FillOverlayEffectiveData
Inherits EffectEffectiveData
Implements IFillOverlayEffectiveData
[C#]
public class FillOverlayEffectiveData : EffectEffectiveData, IFillOverlayEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FillOverlayEffectiveData Members | Aspose.Slides.Effects Namespace


FillOverlayEffectiveData Members

FillOverlayEffectiveData overview

Public Instance Properties

Blend | Determines how one fill drawn over another. Readonly FillBlendMode.
FillFormat | Returns a overlaying fill properties. Readonly FillBlendMode.

See Also

FillOverlayEffectiveData Class | Aspose.Slides.Effects Namespace


FillOverlayEffectiveData Properties

The properties of the FillOverlayEffectiveData class are listed below. For a complete list of FillOverlayEffectiveData class members, see the FillOverlayEffectiveData Members topic.

Public Instance Properties

Blend | Determines how one fill drawn over another. Readonly FillBlendMode.
FillFormat | Returns a overlaying fill properties. Readonly FillBlendMode.

See Also

FillOverlayEffectiveData Class | Aspose.Slides.Effects Namespace


Blend Property

Aspose.Slides Documentation

FillOverlayEffectiveData.Blend Property

Determines how one fill drawn over another. Readonly FillBlendMode.

[Visual Basic]
NotOverridable Public ReadOnly Property Blend As FillBlendMode _
Implements IFillOverlayEffectiveData.Blend
[C#]
public FillBlendMode Blend {get;}

Implements

IFillOverlayEffectiveData.Blend

See Also

FillOverlayEffectiveData Class | Aspose.Slides.Effects Namespace


FillFormat Property

Aspose.Slides Documentation

FillOverlayEffectiveData.FillFormat Property

Returns a overlaying fill properties. Readonly FillBlendMode.

[Visual Basic]
NotOverridable Public ReadOnly Property FillFormat As IFillFormatEffectiveData _
Implements IFillOverlayEffectiveData.FillFormat
[C#]
public IFillFormatEffectiveData FillFormat {get;}

Implements

IFillOverlayEffectiveData.FillFormat

See Also

FillOverlayEffectiveData Class | Aspose.Slides.Effects Namespace


Glow Class

Represents a glow effect, in which a color blurred outline is added outside the edges of the object.

For a list of all members of this type, see Glow Members.

System.Object
Aspose.Slides.Effects.Glow

[Visual Basic]
Public Class Glow
Implements IGlow
[C#]
public class Glow : IGlow

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Glow Members | Aspose.Slides.Effects Namespace


Glow Members

Glow overview

Public Instance Constructors

Glow Constructor Creates a new instance of the Glow class.

Public Instance Properties

Color | Color format.
Radius | Radius.

See Also

Glow Class | Aspose.Slides.Effects Namespace


Glow Constructor

Creates a new instance of the Glow class.

[Visual Basic]
Public Sub New()
[C#]
public Glow();

See Also

Glow Class | Aspose.Slides.Effects Namespace


Glow Properties

The properties of the Glow class are listed below. For a complete list of Glow class members, see the Glow Members topic.

Public Instance Properties

Color | Color format.
Radius | Radius.

See Also

Glow Class | Aspose.Slides.Effects Namespace


Color Property

Aspose.Slides Documentation

Glow.Color Property

Color format.

[Visual Basic]
NotOverridable Public ReadOnly Property Color As IColorFormat _
Implements IGlow.Color
[C#]
public IColorFormat Color {get;}

Implements

IGlow.Color

See Also

Glow Class | Aspose.Slides.Effects Namespace


Radius Property

Aspose.Slides Documentation

Glow.Radius Property

Radius.

[Visual Basic]
NotOverridable Public Property Radius As Double _
Implements IGlow.Radius
[C#]
public double Radius {get; set;}

Implements

IGlow.Radius

See Also

Glow Class | Aspose.Slides.Effects Namespace


GlowEffectiveData Class

Immutable object which represents a glow effect, in which a color blurred outline is added outside the edges of the object.

For a list of all members of this type, see GlowEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.GlowEffectiveData

[Visual Basic]
Public Class GlowEffectiveData
Inherits EffectEffectiveData
Implements IGlowEffectiveData
[C#]
public class GlowEffectiveData : EffectEffectiveData, IGlowEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GlowEffectiveData Members | Aspose.Slides.Effects Namespace


GlowEffectiveData Members

GlowEffectiveData overview

Public Instance Properties

Color | Color.
Radius | Radius.

See Also

GlowEffectiveData Class | Aspose.Slides.Effects Namespace


GlowEffectiveData Properties

The properties of the GlowEffectiveData class are listed below. For a complete list of GlowEffectiveData class members, see the GlowEffectiveData Members topic.

Public Instance Properties

Color | Color.
Radius | Radius.

See Also

GlowEffectiveData Class | Aspose.Slides.Effects Namespace


Color Property

Aspose.Slides Documentation

GlowEffectiveData.Color Property

Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Color As Color _
Implements IGlowEffectiveData.Color
[C#]
public Color Color {get;}

Implements

IGlowEffectiveData.Color

See Also

GlowEffectiveData Class | Aspose.Slides.Effects Namespace


Radius Property

Aspose.Slides Documentation

GlowEffectiveData.Radius Property

Radius.

[Visual Basic]
NotOverridable Public ReadOnly Property Radius As Double _
Implements IGlowEffectiveData.Radius
[C#]
public double Radius {get;}

Implements

IGlowEffectiveData.Radius

See Also

GlowEffectiveData Class | Aspose.Slides.Effects Namespace


GrayScale Class

Represents a Gray Scale effect. Converts all effect color values to a shade of gray, corresponding to their luminance. Effect alpha (opacity) values are unaffected.

For a list of all members of this type, see GrayScale Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.GrayScale

[Visual Basic]
Public Class GrayScale
Inherits ImageTransformOperation
Implements IGrayScale
[C#]
public class GrayScale : ImageTransformOperation, IGrayScale

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

GrayScale Members | Aspose.Slides.Effects Namespace


GrayScale Members

GrayScale overview

Public Instance Constructors

GrayScale Constructor Gray Scale effect constructor.

See Also

GrayScale Class | Aspose.Slides.Effects Namespace


GrayScale Constructor

Gray Scale effect constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public GrayScale();

See Also

GrayScale Class | Aspose.Slides.Effects Namespace


GrayScaleEffectiveData Class

Immutable object which representsepresents a Gray Scale effect. Converts all effect color values to a shade of gray, corresponding to their luminance. Effect alpha (opacity) values are unaffected.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.GrayScaleEffectiveData

[Visual Basic]
Public Class GrayScaleEffectiveData
Inherits EffectEffectiveData
Implements IGrayScaleEffectiveData
[C#]
public class GrayScaleEffectiveData : EffectEffectiveData, IGrayScaleEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


HSL Class

Represents a Hue/Saturation/Luminance effect. The hue, saturation, and luminance may each be adjusted relative to its current value.

For a list of all members of this type, see HSL Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.HSL

[Visual Basic]
Public Class HSL
Inherits ImageTransformOperation
Implements IHSL
[C#]
public class HSL : ImageTransformOperation, IHSL

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

HSL Members | Aspose.Slides.Effects Namespace


HSL Members

HSL overview

Public Instance Constructors

HSL Constructor Hue/Saturation/Luminance effect constructor.

See Also

HSL Class | Aspose.Slides.Effects Namespace


HSL Constructor

Hue/Saturation/Luminance effect constructor.

[Visual Basic]
Overloads Public Sub New( _
ByVal hue As Single, _
ByVal saturation As Single, _
ByVal luminance As Single _
)
[C#]
public HSL(
float hue,
float saturation,
float luminance
);

Parameters

hue
The number of degrees by which the hue is adjusted.
saturation
The percentage by which the saturation is adjusted.
luminance
The percentage by which the luminance is adjusted.

See Also

HSL Class | Aspose.Slides.Effects Namespace


HSLEffectiveData Class

Represents a Hue/Saturation/Luminance effect. The hue, saturation, and luminance may each be adjusted relative to its current value.

For a list of all members of this type, see HSLEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.HSLEffectiveData

[Visual Basic]
Public Class HSLEffectiveData
Inherits EffectEffectiveData
Implements IHSLEffectiveData
[C#]
public class HSLEffectiveData : EffectEffectiveData, IHSLEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

HSLEffectiveData Members | Aspose.Slides.Effects Namespace


HSLEffectiveData Members

HSLEffectiveData overview

Public Instance Properties

Hue | Returns hue percentage. Readonly Single.
Luminance | Returns luminance percentage. Readonly Single.
Saturation | Returns saturation percentage. Readonly Single.

See Also

HSLEffectiveData Class | Aspose.Slides.Effects Namespace


HSLEffectiveData Properties

The properties of the HSLEffectiveData class are listed below. For a complete list of HSLEffectiveData class members, see the HSLEffectiveData Members topic.

Public Instance Properties

Hue | Returns hue percentage. Readonly Single.
Luminance | Returns luminance percentage. Readonly Single.
Saturation | Returns saturation percentage. Readonly Single.

See Also

HSLEffectiveData Class | Aspose.Slides.Effects Namespace


Hue Property

Aspose.Slides Documentation

HSLEffectiveData.Hue Property

Returns hue percentage. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Hue As Single _
Implements IHSLEffectiveData.Hue
[C#]
public float Hue {get;}

Implements

IHSLEffectiveData.Hue

See Also

HSLEffectiveData Class | Aspose.Slides.Effects Namespace


Luminance Property

Aspose.Slides Documentation

HSLEffectiveData.Luminance Property

Returns luminance percentage. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Luminance As Single _
Implements IHSLEffectiveData.Luminance
[C#]
public float Luminance {get;}

Implements

IHSLEffectiveData.Luminance

See Also

HSLEffectiveData Class | Aspose.Slides.Effects Namespace


Saturation Property

Aspose.Slides Documentation

HSLEffectiveData.Saturation Property

Returns saturation percentage. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Saturation As Single _
Implements IHSLEffectiveData.Saturation
[C#]
public float Saturation {get;}

Implements

IHSLEffectiveData.Saturation

See Also

HSLEffectiveData Class | Aspose.Slides.Effects Namespace


IAlphaBiLevel Interface

For a list of all members of this type, see IAlphaBiLevel Members.

[Visual Basic]
Public Interface IAlphaBiLevel
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IAlphaBiLevel : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IAlphaBiLevel

Type | Description
AlphaBiLevel | Represents an Alpha Bi-Level effect. Alpha (Opacity) values less than the threshold are changed to 0 (fully transparent) and alpha values greater than or equal to the threshold are changed to 100% (fully opaque).

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAlphaBiLevel Members | Aspose.Slides.Effects Namespace


IAlphaBiLevel Members

IAlphaBiLevel overview

Public Instance Properties

AsIImageTransformOperation
Threshold

See Also

IAlphaBiLevel Interface | Aspose.Slides.Effects Namespace


IAlphaBiLevel Properties

The properties of the IAlphaBiLevel interface are listed below. For a complete list of IAlphaBiLevel interface members, see the IAlphaBiLevel Members topic.

Public Instance Properties

AsIImageTransformOperation
Threshold

See Also

IAlphaBiLevel Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IAlphaBiLevel.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IAlphaBiLevel Interface | Aspose.Slides.Effects Namespace


Threshold Property

Aspose.Slides Documentation

IAlphaBiLevel.Threshold Property

[Visual Basic]
Property Threshold As Single
[C#]
float Threshold {get;}

See Also

IAlphaBiLevel Interface | Aspose.Slides.Effects Namespace


IAlphaBiLevelEffectiveData Interface

For a list of all members of this type, see IAlphaBiLevelEffectiveData Members.

[Visual Basic]
Public Interface IAlphaBiLevelEffectiveData
[C#]
public interface IAlphaBiLevelEffectiveData

Types that implement IAlphaBiLevelEffectiveData

Type | Description
AlphaBiLevelEffectiveData | Immutable object which represents an Alpha Bi-Level effect. Alpha (Opacity) values less than the threshold are changed to 0 (fully transparent) and alpha values greater than or equal to the threshold are changed to 100% (fully opaque).

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAlphaBiLevelEffectiveData Members | Aspose.Slides.Effects Namespace


IAlphaBiLevelEffectiveData Members

IAlphaBiLevelEffectiveData overview

Public Instance Properties

Threshold

See Also

IAlphaBiLevelEffectiveData Interface | Aspose.Slides.Effects Namespace


IAlphaBiLevelEffectiveData Properties

The properties of the IAlphaBiLevelEffectiveData interface are listed below. For a complete list of IAlphaBiLevelEffectiveData interface members, see the IAlphaBiLevelEffectiveData Members topic.

Public Instance Properties

Threshold

See Also

IAlphaBiLevelEffectiveData Interface | Aspose.Slides.Effects Namespace


Threshold Property

Aspose.Slides Documentation

IAlphaBiLevelEffectiveData.Threshold Property

[Visual Basic]
Property Threshold As Single
[C#]
float Threshold {get;}

See Also

IAlphaBiLevelEffectiveData Interface | Aspose.Slides.Effects Namespace


IAlphaCeiling Interface

For a list of all members of this type, see IAlphaCeiling Members.

[Visual Basic]
Public Interface IAlphaCeiling
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IAlphaCeiling : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IAlphaCeiling

Type | Description
AlphaCeiling | Represents an Alpha Ceiling effect. Alpha (opacity) values greater than zero are changed to 100%. In other words, anything partially opaque becomes fully opaque.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAlphaCeiling Members | Aspose.Slides.Effects Namespace


IAlphaCeiling Members

IAlphaCeiling overview

Public Instance Properties

AsIImageTransformOperation

See Also

IAlphaCeiling Interface | Aspose.Slides.Effects Namespace


IAlphaCeiling Properties

The properties of the IAlphaCeiling interface are listed below. For a complete list of IAlphaCeiling interface members, see the IAlphaCeiling Members topic.

Public Instance Properties

AsIImageTransformOperation

See Also

IAlphaCeiling Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IAlphaCeiling.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IAlphaCeiling Interface | Aspose.Slides.Effects Namespace


IAlphaCeilingEffectiveData Interface

[Visual Basic]
Public Interface IAlphaCeilingEffectiveData
[C#]
public interface IAlphaCeilingEffectiveData

Types that implement IAlphaCeilingEffectiveData

Type | Description
AlphaCeilingEffectiveData | Immutable object which represents an Alpha Ceiling effect. Alpha (opacity) values greater than zero are changed to 100%. In other words, anything partially opaque becomes fully opaque.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


IAlphaFloor Interface

For a list of all members of this type, see IAlphaFloor Members.

[Visual Basic]
Public Interface IAlphaFloor
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IAlphaFloor : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IAlphaFloor

Type | Description
AlphaFloor | Represents an Alpha Floor effect. Alpha (opacity) values less than 100% are changed to zero. In other words, anything partially transparent becomes fully transparent.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAlphaFloor Members | Aspose.Slides.Effects Namespace


IAlphaFloor Members

IAlphaFloor overview

Public Instance Properties

AsIImageTransformOperation

See Also

IAlphaFloor Interface | Aspose.Slides.Effects Namespace


IAlphaFloor Properties

The properties of the IAlphaFloor interface are listed below. For a complete list of IAlphaFloor interface members, see the IAlphaFloor Members topic.

Public Instance Properties

AsIImageTransformOperation

See Also

IAlphaFloor Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IAlphaFloor.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IAlphaFloor Interface | Aspose.Slides.Effects Namespace


IAlphaFloorEffectiveData Interface

[Visual Basic]
Public Interface IAlphaFloorEffectiveData
[C#]
public interface IAlphaFloorEffectiveData

Types that implement IAlphaFloorEffectiveData

Type | Description
AlphaFloorEffectiveData | Immutable object which represents an Alpha Floor effect. Alpha (opacity) values less than 100% are changed to zero. In other words, anything partially transparent becomes fully transparent.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


IAlphaInverse Interface

For a list of all members of this type, see IAlphaInverse Members.

[Visual Basic]
Public Interface IAlphaInverse
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IAlphaInverse : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IAlphaInverse

Type | Description
AlphaInverse | Represents an Alpha Inverse effect. Alpha (opacity) values are inverted by subtracting from 100%.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAlphaInverse Members | Aspose.Slides.Effects Namespace


IAlphaInverse Members

IAlphaInverse overview

Public Instance Properties

AsIImageTransformOperation

See Also

IAlphaInverse Interface | Aspose.Slides.Effects Namespace


IAlphaInverse Properties

The properties of the IAlphaInverse interface are listed below. For a complete list of IAlphaInverse interface members, see the IAlphaInverse Members topic.

Public Instance Properties

AsIImageTransformOperation

See Also

IAlphaInverse Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IAlphaInverse.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IAlphaInverse Interface | Aspose.Slides.Effects Namespace


IAlphaInverseEffectiveData Interface

[Visual Basic]
Public Interface IAlphaInverseEffectiveData
[C#]
public interface IAlphaInverseEffectiveData

Types that implement IAlphaInverseEffectiveData

Type | Description
AlphaInverseEffectiveData | Immutable object which represents an Alpha Inverse effect. Alpha (opacity) values are inverted by subtracting from 100%.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


IAlphaModulate Interface

For a list of all members of this type, see IAlphaModulate Members.

[Visual Basic]
Public Interface IAlphaModulate
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IAlphaModulate : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IAlphaModulate

Type | Description
AlphaModulate | Represents an Alpha Modulate effect. Effect alpha (opacity) values are multiplied by a fixed percentage. The effect container specifies an effect containing alpha values to modulate.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAlphaModulate Members | Aspose.Slides.Effects Namespace


IAlphaModulate Members

IAlphaModulate overview

Public Instance Properties

AsIImageTransformOperation

See Also

IAlphaModulate Interface | Aspose.Slides.Effects Namespace


IAlphaModulate Properties

The properties of the IAlphaModulate interface are listed below. For a complete list of IAlphaModulate interface members, see the IAlphaModulate Members topic.

Public Instance Properties

AsIImageTransformOperation

See Also

IAlphaModulate Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IAlphaModulate.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IAlphaModulate Interface | Aspose.Slides.Effects Namespace


IAlphaModulateEffectiveData Interface

[Visual Basic]
Public Interface IAlphaModulateEffectiveData
[C#]
public interface IAlphaModulateEffectiveData

Types that implement IAlphaModulateEffectiveData

Type | Description
AlphaModulateEffectiveData | Immutable object which represents an Alpha Modulate effect. Effect alpha (opacity) values are multiplied by a fixed percentage. The effect container specifies an effect containing alpha values to modulate.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


IAlphaModulateFixed Interface

For a list of all members of this type, see IAlphaModulateFixed Members.

[Visual Basic]
Public Interface IAlphaModulateFixed
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IAlphaModulateFixed : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IAlphaModulateFixed

Type | Description
AlphaModulateFixed | Represents an Alpha Modulate Fixed effect. Effect alpha (opacity) values are multiplied by a fixed percentage.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAlphaModulateFixed Members | Aspose.Slides.Effects Namespace


IAlphaModulateFixed Members

IAlphaModulateFixed overview

Public Instance Properties

Amount
AsIImageTransformOperation

See Also

IAlphaModulateFixed Interface | Aspose.Slides.Effects Namespace


IAlphaModulateFixed Properties

The properties of the IAlphaModulateFixed interface are listed below. For a complete list of IAlphaModulateFixed interface members, see the IAlphaModulateFixed Members topic.

Public Instance Properties

Amount
AsIImageTransformOperation

See Also

IAlphaModulateFixed Interface | Aspose.Slides.Effects Namespace


Amount Property

Aspose.Slides Documentation

IAlphaModulateFixed.Amount Property

[Visual Basic]
Property Amount As Single
[C#]
float Amount {get; set;}

See Also

IAlphaModulateFixed Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IAlphaModulateFixed.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IAlphaModulateFixed Interface | Aspose.Slides.Effects Namespace


IAlphaModulateFixedEffectiveData Interface

For a list of all members of this type, see IAlphaModulateFixedEffectiveData Members.

[Visual Basic]
Public Interface IAlphaModulateFixedEffectiveData
[C#]
public interface IAlphaModulateFixedEffectiveData

Types that implement IAlphaModulateFixedEffectiveData

Type | Description
AlphaModulateFixedEffectiveData | Immutable object which represents an Alpha Modulate Fixed effect. Effect alpha (opacity) values are multiplied by a fixed percentage.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAlphaModulateFixedEffectiveData Members | Aspose.Slides.Effects Namespace


IAlphaModulateFixedEffectiveData Members

IAlphaModulateFixedEffectiveData overview

Public Instance Properties

Amount

See Also

IAlphaModulateFixedEffectiveData Interface | Aspose.Slides.Effects Namespace


IAlphaModulateFixedEffectiveData Properties

The properties of the IAlphaModulateFixedEffectiveData interface are listed below. For a complete list of IAlphaModulateFixedEffectiveData interface members, see the IAlphaModulateFixedEffectiveData Members topic.

Public Instance Properties

Amount

See Also

IAlphaModulateFixedEffectiveData Interface | Aspose.Slides.Effects Namespace


Amount Property

Aspose.Slides Documentation

IAlphaModulateFixedEffectiveData.Amount Property

[Visual Basic]
Property Amount As Single
[C#]
float Amount {get;}

See Also

IAlphaModulateFixedEffectiveData Interface | Aspose.Slides.Effects Namespace


IAlphaReplace Interface

For a list of all members of this type, see IAlphaReplace Members.

[Visual Basic]
Public Interface IAlphaReplace
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IAlphaReplace : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IAlphaReplace

Type | Description
AlphaReplace | Represents and Alpha Replace effect. Effect alpha (opacity) values are replaced by a fixed alpha.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAlphaReplace Members | Aspose.Slides.Effects Namespace


IAlphaReplace Members

IAlphaReplace overview

Public Instance Properties

AsIImageTransformOperation

See Also

IAlphaReplace Interface | Aspose.Slides.Effects Namespace


IAlphaReplace Properties

The properties of the IAlphaReplace interface are listed below. For a complete list of IAlphaReplace interface members, see the IAlphaReplace Members topic.

Public Instance Properties

AsIImageTransformOperation

See Also

IAlphaReplace Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IAlphaReplace.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IAlphaReplace Interface | Aspose.Slides.Effects Namespace


IAlphaReplaceEffectiveData Interface

For a list of all members of this type, see IAlphaReplaceEffectiveData Members.

[Visual Basic]
Public Interface IAlphaReplaceEffectiveData
[C#]
public interface IAlphaReplaceEffectiveData

Types that implement IAlphaReplaceEffectiveData

Type | Description
AlphaReplaceEffectiveData | Immutable object which represents and Alpha Replace effect. Effect alpha (opacity) values are replaced by a fixed alpha.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IAlphaReplaceEffectiveData Members | Aspose.Slides.Effects Namespace


IAlphaReplaceEffectiveData Members

IAlphaReplaceEffectiveData overview

Public Instance Properties

Alpha

See Also

IAlphaReplaceEffectiveData Interface | Aspose.Slides.Effects Namespace


IAlphaReplaceEffectiveData Properties

The properties of the IAlphaReplaceEffectiveData interface are listed below. For a complete list of IAlphaReplaceEffectiveData interface members, see the IAlphaReplaceEffectiveData Members topic.

Public Instance Properties

Alpha

See Also

IAlphaReplaceEffectiveData Interface | Aspose.Slides.Effects Namespace


Alpha Property

Aspose.Slides Documentation

IAlphaReplaceEffectiveData.Alpha Property

[Visual Basic]
Property Alpha As Single
[C#]
float Alpha {get;}

See Also

IAlphaReplaceEffectiveData Interface | Aspose.Slides.Effects Namespace


IBiLevel Interface

For a list of all members of this type, see IBiLevel Members.

[Visual Basic]
Public Interface IBiLevel
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IBiLevel : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IBiLevel

Type | Description
BiLevel | Represents a Bi-Level (black/white) effect. Input colors whose luminance is less than the specified threshold value are changed to black. Input colors whose luminance are greater than or equal the specified value are set to white. The alpha effect values are unaffected by this effect.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBiLevel Members | Aspose.Slides.Effects Namespace


IBiLevel Members

IBiLevel overview

Public Instance Properties

AsIImageTransformOperation

See Also

IBiLevel Interface | Aspose.Slides.Effects Namespace


IBiLevel Properties

The properties of the IBiLevel interface are listed below. For a complete list of IBiLevel interface members, see the IBiLevel Members topic.

Public Instance Properties

AsIImageTransformOperation

See Also

IBiLevel Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IBiLevel.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IBiLevel Interface | Aspose.Slides.Effects Namespace


IBiLevelEffectiveData Interface

For a list of all members of this type, see IBiLevelEffectiveData Members.

[Visual Basic]
Public Interface IBiLevelEffectiveData
[C#]
public interface IBiLevelEffectiveData

Types that implement IBiLevelEffectiveData

Type | Description
BiLevelEffectiveData | Immutable object which represents a Bi-Level (black/white) effect. Input colors whose luminance is less than the specified threshold value are changed to black. Input colors whose luminance are greater than or equal the specified value are set to white. The alpha effect values are unaffected by this effect.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBiLevelEffectiveData Members | Aspose.Slides.Effects Namespace


IBiLevelEffectiveData Members

IBiLevelEffectiveData overview

Public Instance Properties

Threshold

See Also

IBiLevelEffectiveData Interface | Aspose.Slides.Effects Namespace


IBiLevelEffectiveData Properties

The properties of the IBiLevelEffectiveData interface are listed below. For a complete list of IBiLevelEffectiveData interface members, see the IBiLevelEffectiveData Members topic.

Public Instance Properties

Threshold

See Also

IBiLevelEffectiveData Interface | Aspose.Slides.Effects Namespace


Threshold Property

Aspose.Slides Documentation

IBiLevelEffectiveData.Threshold Property

[Visual Basic]
Property Threshold As Single
[C#]
float Threshold {get;}

See Also

IBiLevelEffectiveData Interface | Aspose.Slides.Effects Namespace


IBlur Interface

For a list of all members of this type, see IBlur Members.

[Visual Basic]
Public Interface IBlur
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IBlur : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IBlur

Type | Description
Blur | Represents a Blur effect that is applied to the entire shape, including its fill. All color channels, including alpha, are affected.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBlur Members | Aspose.Slides.Effects Namespace


IBlur Members

IBlur overview

Public Instance Properties

AsIImageTransformOperation
Grow
Radius

See Also

IBlur Interface | Aspose.Slides.Effects Namespace


IBlur Properties

The properties of the IBlur interface are listed below. For a complete list of IBlur interface members, see the IBlur Members topic.

Public Instance Properties

AsIImageTransformOperation
Grow
Radius

See Also

IBlur Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IBlur.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IBlur Interface | Aspose.Slides.Effects Namespace


Grow Property

Aspose.Slides Documentation

IBlur.Grow Property

[Visual Basic]
Property Grow As Boolean
[C#]
bool Grow {get; set;}

See Also

IBlur Interface | Aspose.Slides.Effects Namespace


Radius Property

Aspose.Slides Documentation

IBlur.Radius Property

[Visual Basic]
Property Radius As Double
[C#]
double Radius {get; set;}

See Also

IBlur Interface | Aspose.Slides.Effects Namespace


IBlurEffectiveData Interface

For a list of all members of this type, see IBlurEffectiveData Members.

[Visual Basic]
Public Interface IBlurEffectiveData
[C#]
public interface IBlurEffectiveData

Types that implement IBlurEffectiveData

Type | Description
BlurEffectiveData | Immutable object which represents a Blur effect that is applied to the entire shape, including its fill. All color channels, including alpha, are affected.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IBlurEffectiveData Members | Aspose.Slides.Effects Namespace


IBlurEffectiveData Members

IBlurEffectiveData overview

Public Instance Properties

Grow
Radius

See Also

IBlurEffectiveData Interface | Aspose.Slides.Effects Namespace


IBlurEffectiveData Properties

The properties of the IBlurEffectiveData interface are listed below. For a complete list of IBlurEffectiveData interface members, see the IBlurEffectiveData Members topic.

Public Instance Properties

Grow
Radius

See Also

IBlurEffectiveData Interface | Aspose.Slides.Effects Namespace


Grow Property

Aspose.Slides Documentation

IBlurEffectiveData.Grow Property

[Visual Basic]
Property Grow As Boolean
[C#]
bool Grow {get;}

See Also

IBlurEffectiveData Interface | Aspose.Slides.Effects Namespace


Radius Property

Aspose.Slides Documentation

IBlurEffectiveData.Radius Property

[Visual Basic]
Property Radius As Double
[C#]
double Radius {get;}

See Also

IBlurEffectiveData Interface | Aspose.Slides.Effects Namespace


IColorChange Interface

For a list of all members of this type, see IColorChange Members.

[Visual Basic]
Public Interface IColorChange
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IColorChange : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IColorChange

Type | Description
ColorChange | Represents a Color Change effect. Instances of FromColor are replaced with instances of ToColor.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColorChange Members | Aspose.Slides.Effects Namespace


IColorChange Members

IColorChange overview

Public Instance Properties

AsIImageTransformOperation
FromColor
ToColor

See Also

IColorChange Interface | Aspose.Slides.Effects Namespace


IColorChange Properties

The properties of the IColorChange interface are listed below. For a complete list of IColorChange interface members, see the IColorChange Members topic.

Public Instance Properties

AsIImageTransformOperation
FromColor
ToColor

See Also

IColorChange Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IColorChange.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IColorChange Interface | Aspose.Slides.Effects Namespace


FromColor Property

Aspose.Slides Documentation

IColorChange.FromColor Property

[Visual Basic]
Property FromColor As IColorFormat
[C#]
IColorFormat FromColor {get;}

See Also

IColorChange Interface | Aspose.Slides.Effects Namespace


ToColor Property

Aspose.Slides Documentation

IColorChange.ToColor Property

[Visual Basic]
Property ToColor As IColorFormat
[C#]
IColorFormat ToColor {get;}

See Also

IColorChange Interface | Aspose.Slides.Effects Namespace


IColorChangeEffectiveData Interface

For a list of all members of this type, see IColorChangeEffectiveData Members.

[Visual Basic]
Public Interface IColorChangeEffectiveData
[C#]
public interface IColorChangeEffectiveData

Types that implement IColorChangeEffectiveData

Type | Description
ColorChangeEffectiveData | Immutable object which represents a Color Change effect. Instances of FromColor are replaced with instances of ToColor.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColorChangeEffectiveData Members | Aspose.Slides.Effects Namespace


IColorChangeEffectiveData Members

IColorChangeEffectiveData overview

Public Instance Properties

FromColor
ToColor
UseAlpha

See Also

IColorChangeEffectiveData Interface | Aspose.Slides.Effects Namespace


IColorChangeEffectiveData Properties

The properties of the IColorChangeEffectiveData interface are listed below. For a complete list of IColorChangeEffectiveData interface members, see the IColorChangeEffectiveData Members topic.

Public Instance Properties

FromColor
ToColor
UseAlpha

See Also

IColorChangeEffectiveData Interface | Aspose.Slides.Effects Namespace


FromColor Property

Aspose.Slides Documentation

IColorChangeEffectiveData.FromColor Property

[Visual Basic]
Property FromColor As Color
[C#]
Color FromColor {get;}

See Also

IColorChangeEffectiveData Interface | Aspose.Slides.Effects Namespace


ToColor Property

Aspose.Slides Documentation

IColorChangeEffectiveData.ToColor Property

[Visual Basic]
Property ToColor As Color
[C#]
Color ToColor {get;}

See Also

IColorChangeEffectiveData Interface | Aspose.Slides.Effects Namespace


UseAlpha Property

Aspose.Slides Documentation

IColorChangeEffectiveData.UseAlpha Property

[Visual Basic]
Property UseAlpha As Boolean
[C#]
bool UseAlpha {get;}

See Also

IColorChangeEffectiveData Interface | Aspose.Slides.Effects Namespace


IColorReplace Interface

For a list of all members of this type, see IColorReplace Members.

[Visual Basic]
Public Interface IColorReplace
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IColorReplace : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IColorReplace

Type | Description
ColorReplace | Represents a Color Replacement effect. All effect colors are changed to a fixed color. Alpha values are unaffected.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColorReplace Members | Aspose.Slides.Effects Namespace


IColorReplace Members

IColorReplace overview

Public Instance Properties

AsIImageTransformOperation
Color

See Also

IColorReplace Interface | Aspose.Slides.Effects Namespace


IColorReplace Properties

The properties of the IColorReplace interface are listed below. For a complete list of IColorReplace interface members, see the IColorReplace Members topic.

Public Instance Properties

AsIImageTransformOperation
Color

See Also

IColorReplace Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IColorReplace.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IColorReplace Interface | Aspose.Slides.Effects Namespace


Color Property

Aspose.Slides Documentation

IColorReplace.Color Property

[Visual Basic]
Property Color As IColorFormat
[C#]
IColorFormat Color {get;}

See Also

IColorReplace Interface | Aspose.Slides.Effects Namespace


IColorReplaceEffectiveData Interface

For a list of all members of this type, see IColorReplaceEffectiveData Members.

[Visual Basic]
Public Interface IColorReplaceEffectiveData
[C#]
public interface IColorReplaceEffectiveData

Types that implement IColorReplaceEffectiveData

Type | Description
ColorReplaceEffectiveData | Immutable object which represents a Color Replacement effect. All effect colors are changed to a fixed color. Alpha values are unaffected.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColorReplaceEffectiveData Members | Aspose.Slides.Effects Namespace


IColorReplaceEffectiveData Members

IColorReplaceEffectiveData overview

Public Instance Properties

Color

See Also

IColorReplaceEffectiveData Interface | Aspose.Slides.Effects Namespace


IColorReplaceEffectiveData Properties

The properties of the IColorReplaceEffectiveData interface are listed below. For a complete list of IColorReplaceEffectiveData interface members, see the IColorReplaceEffectiveData Members topic.

Public Instance Properties

Color

See Also

IColorReplaceEffectiveData Interface | Aspose.Slides.Effects Namespace


Color Property

Aspose.Slides Documentation

IColorReplaceEffectiveData.Color Property

[Visual Basic]
Property Color As Color
[C#]
Color Color {get;}

See Also

IColorReplaceEffectiveData Interface | Aspose.Slides.Effects Namespace


IDuotone Interface

For a list of all members of this type, see IDuotone Members.

[Visual Basic]
Public Interface IDuotone
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IDuotone : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IDuotone

Type | Description
Duotone | Represents a Duotone effect. For each pixel, combines Color1 and Color2 through a linear interpolation to determine the new color for that pixel.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IDuotone Members | Aspose.Slides.Effects Namespace


IDuotone Members

IDuotone overview

Public Instance Properties

AsIImageTransformOperation
Color1
Color2

See Also

IDuotone Interface | Aspose.Slides.Effects Namespace


IDuotone Properties

The properties of the IDuotone interface are listed below. For a complete list of IDuotone interface members, see the IDuotone Members topic.

Public Instance Properties

AsIImageTransformOperation
Color1
Color2

See Also

IDuotone Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IDuotone.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IDuotone Interface | Aspose.Slides.Effects Namespace


Color1 Property

Aspose.Slides Documentation

IDuotone.Color1 Property

[Visual Basic]
Property Color1 As IColorFormat
[C#]
IColorFormat Color1 {get;}

See Also

IDuotone Interface | Aspose.Slides.Effects Namespace


Color2 Property

Aspose.Slides Documentation

IDuotone.Color2 Property

[Visual Basic]
Property Color2 As IColorFormat
[C#]
IColorFormat Color2 {get;}

See Also

IDuotone Interface | Aspose.Slides.Effects Namespace


IDuotoneEffectiveData Interface

For a list of all members of this type, see IDuotoneEffectiveData Members.

[Visual Basic]
Public Interface IDuotoneEffectiveData
[C#]
public interface IDuotoneEffectiveData

Types that implement IDuotoneEffectiveData

Type | Description
DuotoneEffectiveData | Immutable object which represents a Duotone effect. For each pixel, combines clr1 and clr2 through a linear interpolation to determine the new color for that pixel.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IDuotoneEffectiveData Members | Aspose.Slides.Effects Namespace


IDuotoneEffectiveData Members

IDuotoneEffectiveData overview

Public Instance Properties

Color1
Color2

See Also

IDuotoneEffectiveData Interface | Aspose.Slides.Effects Namespace


IDuotoneEffectiveData Properties

The properties of the IDuotoneEffectiveData interface are listed below. For a complete list of IDuotoneEffectiveData interface members, see the IDuotoneEffectiveData Members topic.

Public Instance Properties

Color1
Color2

See Also

IDuotoneEffectiveData Interface | Aspose.Slides.Effects Namespace


Color1 Property

Aspose.Slides Documentation

IDuotoneEffectiveData.Color1 Property

[Visual Basic]
Property Color1 As Color
[C#]
Color Color1 {get;}

See Also

IDuotoneEffectiveData Interface | Aspose.Slides.Effects Namespace


Color2 Property

Aspose.Slides Documentation

IDuotoneEffectiveData.Color2 Property

[Visual Basic]
Property Color2 As Color
[C#]
Color Color2 {get;}

See Also

IDuotoneEffectiveData Interface | Aspose.Slides.Effects Namespace


IEffectEffectiveData Interface

[Visual Basic]
Public Interface IEffectEffectiveData
[C#]
public interface IEffectEffectiveData

Types that implement IEffectEffectiveData

Type | Description
AlphaBiLevelEffectiveData | Immutable object which represents an Alpha Bi-Level effect. Alpha (Opacity) values less than the threshold are changed to 0 (fully transparent) and alpha values greater than or equal to the threshold are changed to 100% (fully opaque).
AlphaCeilingEffectiveData | Immutable object which represents an Alpha Ceiling effect. Alpha (opacity) values greater than zero are changed to 100%. In other words, anything partially opaque becomes fully opaque.
AlphaFloorEffectiveData | Immutable object which represents an Alpha Floor effect. Alpha (opacity) values less than 100% are changed to zero. In other words, anything partially transparent becomes fully transparent.
AlphaInverseEffectiveData | Immutable object which represents an Alpha Inverse effect. Alpha (opacity) values are inverted by subtracting from 100%.
AlphaModulateEffectiveData | Immutable object which represents an Alpha Modulate effect. Effect alpha (opacity) values are multiplied by a fixed percentage. The effect container specifies an effect containing alpha values to modulate.
AlphaModulateFixedEffectiveData | Immutable object which represents an Alpha Modulate Fixed effect. Effect alpha (opacity) values are multiplied by a fixed percentage.
AlphaReplaceEffectiveData | Immutable object which represents and Alpha Replace effect. Effect alpha (opacity) values are replaced by a fixed alpha.
BiLevelEffectiveData | Immutable object which represents a Bi-Level (black/white) effect. Input colors whose luminance is less than the specified threshold value are changed to black. Input colors whose luminance are greater than or equal the specified value are set to white. The alpha effect values are unaffected by this effect.
BlurEffectiveData | Immutable object which represents a Blur effect that is applied to the entire shape, including its fill. All color channels, including alpha, are affected.
ColorChangeEffectiveData | Immutable object which represents a Color Change effect. Instances of FromColor are replaced with instances of ToColor.
ColorReplaceEffectiveData | Immutable object which represents a Color Replacement effect. All effect colors are changed to a fixed color. Alpha values are unaffected.
DuotoneEffectiveData | Immutable object which represents a Duotone effect. For each pixel, combines clr1 and clr2 through a linear interpolation to determine the new color for that pixel.
EffectEffectiveData | Base class for immutable objects, which represent effect.
FillOverlayEffectiveData | Immutable object which represents a Fill Overlay effect. A fill overlay may be used to specify an additional fill for an object and blend the two fills together.
GlowEffectiveData | Immutable object which represents a glow effect, in which a color blurred outline is added outside the edges of the object.
GrayScaleEffectiveData | Immutable object which representsepresents a Gray Scale effect. Converts all effect color values to a shade of gray, corresponding to their luminance. Effect alpha (opacity) values are unaffected.
HSLEffectiveData | Represents a Hue/Saturation/Luminance effect. The hue, saturation, and luminance may each be adjusted relative to its current value.
InnerShadowEffectiveData | Immutable object which represents a inner shadow effect.
LuminanceEffectiveData | Represents a Luminance effect. Brightness linearly shifts all colors closer to white or black. Contrast scales all colors to be either closer or further apart.
OuterShadowEffectiveData | Immutable object which represents a outer shadow effect.
PresetShadowEffectiveData | Immutable object which represents a preset shadow effect.
ReflectionEffectiveData | Immutable object which represents a reflection effect.
SoftEdgeEffectiveData | Immutable object which represents a soft edge effect. The edges of the shape are blurred, while the fill is not affected.
TintEffectiveData | Immutable object which represents a Tint effect. Shifts effect color values towards/away from hue by the specified amount.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


IEffectFactory Interface

For a list of all members of this type, see IEffectFactory Members.

[Visual Basic]
Public Interface IEffectFactory
[C#]
public interface IEffectFactory

Types that implement IEffectFactory

Type | Description
EffectFactory | Allows to create effects

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IEffectFactory Members | Aspose.Slides.Effects Namespace


IEffectFactory Members

IEffectFactory overview

Public Instance Properties

ImageTransformOperationFactory

Public Instance Methods

CreateInnerShadow
CreateOuterShadow
CreatePresetShadow
CreateReflection
CreateSoftEdge

See Also

IEffectFactory Interface | Aspose.Slides.Effects Namespace


IEffectFactory Properties

The properties of the IEffectFactory interface are listed below. For a complete list of IEffectFactory interface members, see the IEffectFactory Members topic.

Public Instance Properties

ImageTransformOperationFactory

See Also

IEffectFactory Interface | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory Property

Aspose.Slides Documentation

IEffectFactory.ImageTransformOperationFactory Property

[Visual Basic]
Property ImageTransformOperationFactory As IImageTransformOperationFactory
[C#]
IImageTransformOperationFactory ImageTransformOperationFactory {get;}

See Also

IEffectFactory Interface | Aspose.Slides.Effects Namespace


IEffectFactory Methods

The methods of the IEffectFactory interface are listed below. For a complete list of IEffectFactory interface members, see the IEffectFactory Members topic.

Public Instance Methods

CreateInnerShadow
CreateOuterShadow
CreatePresetShadow
CreateReflection
CreateSoftEdge

See Also

IEffectFactory Interface | Aspose.Slides.Effects Namespace


IEffectFactory.CreateInnerShadow Method

[Visual Basic]
Function CreateInnerShadow() As IInnerShadow
[C#]
IInnerShadow CreateInnerShadow();

See Also

IEffectFactory Interface | Aspose.Slides.Effects Namespace


IEffectFactory.CreateOuterShadow Method

[Visual Basic]
Function CreateOuterShadow() As IOuterShadow
[C#]
IOuterShadow CreateOuterShadow();

See Also

IEffectFactory Interface | Aspose.Slides.Effects Namespace


IEffectFactory.CreatePresetShadow Method

[Visual Basic]
Function CreatePresetShadow() As IPresetShadow
[C#]
IPresetShadow CreatePresetShadow();

See Also

IEffectFactory Interface | Aspose.Slides.Effects Namespace


IEffectFactory.CreateReflection Method

[Visual Basic]
Function CreateReflection() As IReflection
[C#]
IReflection CreateReflection();

See Also

IEffectFactory Interface | Aspose.Slides.Effects Namespace


IEffectFactory.CreateSoftEdge Method

[Visual Basic]
Function CreateSoftEdge() As ISoftEdge
[C#]
ISoftEdge CreateSoftEdge();

See Also

IEffectFactory Interface | Aspose.Slides.Effects Namespace


IFillOverlay Interface

For a list of all members of this type, see IFillOverlay Members.

[Visual Basic]
Public Interface IFillOverlay
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IFillOverlay : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IFillOverlay

Type | Description
FillOverlay | Represents a Fill Overlay effect. A fill overlay may be used to specify an additional fill for an object and blend the two fills together.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFillOverlay Members | Aspose.Slides.Effects Namespace


IFillOverlay Members

IFillOverlay overview

Public Instance Properties

AsIImageTransformOperation
Blend
FillFormat

See Also

IFillOverlay Interface | Aspose.Slides.Effects Namespace


IFillOverlay Properties

The properties of the IFillOverlay interface are listed below. For a complete list of IFillOverlay interface members, see the IFillOverlay Members topic.

Public Instance Properties

AsIImageTransformOperation
Blend
FillFormat

See Also

IFillOverlay Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IFillOverlay.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IFillOverlay Interface | Aspose.Slides.Effects Namespace


Blend Property

Aspose.Slides Documentation

IFillOverlay.Blend Property

[Visual Basic]
Property Blend As FillBlendMode
[C#]
FillBlendMode Blend {get; set;}

See Also

IFillOverlay Interface | Aspose.Slides.Effects Namespace


FillFormat Property

Aspose.Slides Documentation

IFillOverlay.FillFormat Property

[Visual Basic]
Property FillFormat As IFillFormat
[C#]
IFillFormat FillFormat {get; set;}

See Also

IFillOverlay Interface | Aspose.Slides.Effects Namespace


IFillOverlayEffectiveData Interface

For a list of all members of this type, see IFillOverlayEffectiveData Members.

[Visual Basic]
Public Interface IFillOverlayEffectiveData
[C#]
public interface IFillOverlayEffectiveData

Types that implement IFillOverlayEffectiveData

Type | Description
FillOverlayEffectiveData | Immutable object which represents a Fill Overlay effect. A fill overlay may be used to specify an additional fill for an object and blend the two fills together.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFillOverlayEffectiveData Members | Aspose.Slides.Effects Namespace


IFillOverlayEffectiveData Members

IFillOverlayEffectiveData overview

Public Instance Properties

Blend
FillFormat

See Also

IFillOverlayEffectiveData Interface | Aspose.Slides.Effects Namespace


IFillOverlayEffectiveData Properties

The properties of the IFillOverlayEffectiveData interface are listed below. For a complete list of IFillOverlayEffectiveData interface members, see the IFillOverlayEffectiveData Members topic.

Public Instance Properties

Blend
FillFormat

See Also

IFillOverlayEffectiveData Interface | Aspose.Slides.Effects Namespace


Blend Property

Aspose.Slides Documentation

IFillOverlayEffectiveData.Blend Property

[Visual Basic]
Property Blend As FillBlendMode
[C#]
FillBlendMode Blend {get;}

See Also

IFillOverlayEffectiveData Interface | Aspose.Slides.Effects Namespace


FillFormat Property

Aspose.Slides Documentation

IFillOverlayEffectiveData.FillFormat Property

[Visual Basic]
Property FillFormat As IFillFormatEffectiveData
[C#]
IFillFormatEffectiveData FillFormat {get;}

See Also

IFillOverlayEffectiveData Interface | Aspose.Slides.Effects Namespace


IGlow Interface

For a list of all members of this type, see IGlow Members.

[Visual Basic]
Public Interface IGlow
[C#]
public interface IGlow

Types that implement IGlow

Type | Description
Glow | Represents a glow effect, in which a color blurred outline is added outside the edges of the object.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGlow Members | Aspose.Slides.Effects Namespace


IGlow Members

IGlow overview

Public Instance Properties

Color
Radius

See Also

IGlow Interface | Aspose.Slides.Effects Namespace


IGlow Properties

The properties of the IGlow interface are listed below. For a complete list of IGlow interface members, see the IGlow Members topic.

Public Instance Properties

Color
Radius

See Also

IGlow Interface | Aspose.Slides.Effects Namespace


Color Property

Aspose.Slides Documentation

IGlow.Color Property

[Visual Basic]
Property Color As IColorFormat
[C#]
IColorFormat Color {get;}

See Also

IGlow Interface | Aspose.Slides.Effects Namespace


Radius Property

Aspose.Slides Documentation

IGlow.Radius Property

[Visual Basic]
Property Radius As Double
[C#]
double Radius {get; set;}

See Also

IGlow Interface | Aspose.Slides.Effects Namespace


IGlowEffectiveData Interface

For a list of all members of this type, see IGlowEffectiveData Members.

[Visual Basic]
Public Interface IGlowEffectiveData
[C#]
public interface IGlowEffectiveData

Types that implement IGlowEffectiveData

Type | Description
GlowEffectiveData | Immutable object which represents a glow effect, in which a color blurred outline is added outside the edges of the object.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGlowEffectiveData Members | Aspose.Slides.Effects Namespace


IGlowEffectiveData Members

IGlowEffectiveData overview

Public Instance Properties

Color
Radius

See Also

IGlowEffectiveData Interface | Aspose.Slides.Effects Namespace


IGlowEffectiveData Properties

The properties of the IGlowEffectiveData interface are listed below. For a complete list of IGlowEffectiveData interface members, see the IGlowEffectiveData Members topic.

Public Instance Properties

Color
Radius

See Also

IGlowEffectiveData Interface | Aspose.Slides.Effects Namespace


Color Property

Aspose.Slides Documentation

IGlowEffectiveData.Color Property

[Visual Basic]
Property Color As Color
[C#]
Color Color {get;}

See Also

IGlowEffectiveData Interface | Aspose.Slides.Effects Namespace


Radius Property

Aspose.Slides Documentation

IGlowEffectiveData.Radius Property

[Visual Basic]
Property Radius As Double
[C#]
double Radius {get;}

See Also

IGlowEffectiveData Interface | Aspose.Slides.Effects Namespace


IGrayScale Interface

For a list of all members of this type, see IGrayScale Members.

[Visual Basic]
Public Interface IGrayScale
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IGrayScale : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IGrayScale

Type | Description
GrayScale | Represents a Gray Scale effect. Converts all effect color values to a shade of gray, corresponding to their luminance. Effect alpha (opacity) values are unaffected.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IGrayScale Members | Aspose.Slides.Effects Namespace


IGrayScale Members

IGrayScale overview

Public Instance Properties

AsIImageTransformOperation

See Also

IGrayScale Interface | Aspose.Slides.Effects Namespace


IGrayScale Properties

The properties of the IGrayScale interface are listed below. For a complete list of IGrayScale interface members, see the IGrayScale Members topic.

Public Instance Properties

AsIImageTransformOperation

See Also

IGrayScale Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IGrayScale.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IGrayScale Interface | Aspose.Slides.Effects Namespace


IGrayScaleEffectiveData Interface

[Visual Basic]
Public Interface IGrayScaleEffectiveData
[C#]
public interface IGrayScaleEffectiveData

Types that implement IGrayScaleEffectiveData

Type | Description
GrayScaleEffectiveData | Immutable object which representsepresents a Gray Scale effect. Converts all effect color values to a shade of gray, corresponding to their luminance. Effect alpha (opacity) values are unaffected.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


IHSL Interface

For a list of all members of this type, see IHSL Members.

[Visual Basic]
Public Interface IHSL
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface IHSL : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement IHSL

Type | Description
HSL | Represents a Hue/Saturation/Luminance effect. The hue, saturation, and luminance may each be adjusted relative to its current value.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IHSL Members | Aspose.Slides.Effects Namespace


IHSL Members

IHSL overview

Public Instance Properties

AsIImageTransformOperation

See Also

IHSL Interface | Aspose.Slides.Effects Namespace


IHSL Properties

The properties of the IHSL interface are listed below. For a complete list of IHSL interface members, see the IHSL Members topic.

Public Instance Properties

AsIImageTransformOperation

See Also

IHSL Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

IHSL.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

IHSL Interface | Aspose.Slides.Effects Namespace


IHSLEffectiveData Interface

For a list of all members of this type, see IHSLEffectiveData Members.

[Visual Basic]
Public Interface IHSLEffectiveData
[C#]
public interface IHSLEffectiveData

Types that implement IHSLEffectiveData

Type | Description
HSLEffectiveData | Represents a Hue/Saturation/Luminance effect. The hue, saturation, and luminance may each be adjusted relative to its current value.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IHSLEffectiveData Members | Aspose.Slides.Effects Namespace


IHSLEffectiveData Members

IHSLEffectiveData overview

Public Instance Properties

Hue
Luminance
Saturation

See Also

IHSLEffectiveData Interface | Aspose.Slides.Effects Namespace


IHSLEffectiveData Properties

The properties of the IHSLEffectiveData interface are listed below. For a complete list of IHSLEffectiveData interface members, see the IHSLEffectiveData Members topic.

Public Instance Properties

Hue
Luminance
Saturation

See Also

IHSLEffectiveData Interface | Aspose.Slides.Effects Namespace


Hue Property

Aspose.Slides Documentation

IHSLEffectiveData.Hue Property

[Visual Basic]
Property Hue As Single
[C#]
float Hue {get;}

See Also

IHSLEffectiveData Interface | Aspose.Slides.Effects Namespace


Luminance Property

Aspose.Slides Documentation

IHSLEffectiveData.Luminance Property

[Visual Basic]
Property Luminance As Single
[C#]
float Luminance {get;}

See Also

IHSLEffectiveData Interface | Aspose.Slides.Effects Namespace


Saturation Property

Aspose.Slides Documentation

IHSLEffectiveData.Saturation Property

[Visual Basic]
Property Saturation As Single
[C#]
float Saturation {get;}

See Also

IHSLEffectiveData Interface | Aspose.Slides.Effects Namespace


IImageTransformOCollectionEffectiveData Interface

For a list of all members of this type, see IImageTransformOCollectionEffectiveData Members.

[Visual Basic]
Public Interface IImageTransformOCollectionEffectiveData
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Effects.IEffectEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IImageTransformOCollectionEffectiveData : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IImageTransformOCollectionEffectiveData

Type | Description
ImageTransformOCollectionEffectiveData | Immutable object which represents a readonly collection of EffectData objects.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IImageTransformOCollectionEffectiveData Members | Aspose.Slides.Effects Namespace


IImageTransformOCollectionEffectiveData Members

IImageTransformOCollectionEffectiveData overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IImageTransformOCollectionEffectiveData Interface | Aspose.Slides.Effects Namespace


IImageTransformOCollectionEffectiveData Properties

The properties of the IImageTransformOCollectionEffectiveData interface are listed below. For a complete list of IImageTransformOCollectionEffectiveData interface members, see the IImageTransformOCollectionEffectiveData Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IImageTransformOCollectionEffectiveData Interface | Aspose.Slides.Effects Namespace


AsICollection Property

Aspose.Slides Documentation

IImageTransformOCollectionEffectiveData.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IImageTransformOCollectionEffectiveData Interface | Aspose.Slides.Effects Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IImageTransformOCollectionEffectiveData.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IImageTransformOCollectionEffectiveData Interface | Aspose.Slides.Effects Namespace


Item Property

Aspose.Slides Documentation

IImageTransformOCollectionEffectiveData.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IEffectEffectiveData
[C#]
IEffectEffectiveData this[
int index
] {get;}

See Also

IImageTransformOCollectionEffectiveData Interface | Aspose.Slides.Effects Namespace


IImageTransformOperation Interface

For a list of all members of this type, see IImageTransformOperation Members.

Aspose.Slides.Effects.IImageTransformOperation
Derived interfaces

[Visual Basic]
Public Interface IImageTransformOperation
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IImageTransformOperation : ISlideComponent, IPresentationComponent

Types that implement IImageTransformOperation

Type | Description
AlphaBiLevel | Represents an Alpha Bi-Level effect. Alpha (Opacity) values less than the threshold are changed to 0 (fully transparent) and alpha values greater than or equal to the threshold are changed to 100% (fully opaque).
AlphaCeiling | Represents an Alpha Ceiling effect. Alpha (opacity) values greater than zero are changed to 100%. In other words, anything partially opaque becomes fully opaque.
AlphaFloor | Represents an Alpha Floor effect. Alpha (opacity) values less than 100% are changed to zero. In other words, anything partially transparent becomes fully transparent.
AlphaInverse | Represents an Alpha Inverse effect. Alpha (opacity) values are inverted by subtracting from 100%.
AlphaModulate | Represents an Alpha Modulate effect. Effect alpha (opacity) values are multiplied by a fixed percentage. The effect container specifies an effect containing alpha values to modulate.
AlphaModulateFixed | Represents an Alpha Modulate Fixed effect. Effect alpha (opacity) values are multiplied by a fixed percentage.
AlphaReplace | Represents and Alpha Replace effect. Effect alpha (opacity) values are replaced by a fixed alpha.
BiLevel | Represents a Bi-Level (black/white) effect. Input colors whose luminance is less than the specified threshold value are changed to black. Input colors whose luminance are greater than or equal the specified value are set to white. The alpha effect values are unaffected by this effect.
Blur | Represents a Blur effect that is applied to the entire shape, including its fill. All color channels, including alpha, are affected.
ColorChange | Represents a Color Change effect. Instances of FromColor are replaced with instances of ToColor.
ColorReplace | Represents a Color Replacement effect. All effect colors are changed to a fixed color. Alpha values are unaffected.
Duotone | Represents a Duotone effect. For each pixel, combines Color1 and Color2 through a linear interpolation to determine the new color for that pixel.
FillOverlay | Represents a Fill Overlay effect. A fill overlay may be used to specify an additional fill for an object and blend the two fills together.
GrayScale | Represents a Gray Scale effect. Converts all effect color values to a shade of gray, corresponding to their luminance. Effect alpha (opacity) values are unaffected.
HSL | Represents a Hue/Saturation/Luminance effect. The hue, saturation, and luminance may each be adjusted relative to its current value.
ImageTransformOperation | Represents abstract image transformation effect.
Luminance | Represents a Luminance effect. Brightness linearly shifts all colors closer to white or black. Contrast scales all colors to be either closer or further apart.
Tint | Represents a Tint effect. Shifts effect color values towards/away from hue by the specified amount.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IImageTransformOperation Members | Aspose.Slides.Effects Namespace


IImageTransformOperation Members

IImageTransformOperation overview

Public Instance Properties

AsISlideComponent

See Also

IImageTransformOperation Interface | Aspose.Slides.Effects Namespace


IImageTransformOperation Properties

The properties of the IImageTransformOperation interface are listed below. For a complete list of IImageTransformOperation interface members, see the IImageTransformOperation Members topic.

Public Instance Properties

AsISlideComponent

See Also

IImageTransformOperation Interface | Aspose.Slides.Effects Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IImageTransformOperation.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IImageTransformOperation Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection Interface

For a list of all members of this type, see IImageTransformOperationCollection Members.

[Visual Basic]
Public Interface IImageTransformOperationCollection
Implements ICollection`1([Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable`1([Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable, ISlideComponent, IPresentationComponent
[C#]
public interface IImageTransformOperationCollection : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable, ISlideComponent, IPresentationComponent

Types that implement IImageTransformOperationCollection

Type | Description
ImageTransformOperationCollection | Represents a collection of effects apllied to an image.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IImageTransformOperationCollection Members | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection Members

IImageTransformOperationCollection overview

Public Instance Properties

AsIEnumerable
AsISlideComponent
Item

Public Instance Methods

AddAlphaBiLevelEffect
AddAlphaCeilingEffect
AddAlphaFloorEffect
AddAlphaInverseEffect
AddAlphaModulateEffect
AddAlphaModulateFixedEffect
AddAlphaReplaceEffect
AddBiLevelEffect
AddBlurEffect
AddColorChangeEffect
AddColorReplaceEffect
AddDuotoneEffect
AddFillOverlayEffect
AddGrayScaleEffect
AddHSLEffect
AddLuminanceEffect
AddTintEffect
RemoveAt

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection Properties

The properties of the IImageTransformOperationCollection interface are listed below. For a complete list of IImageTransformOperationCollection interface members, see the IImageTransformOperationCollection Members topic.

Public Instance Properties

AsIEnumerable
AsISlideComponent
Item

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IImageTransformOperationCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IImageTransformOperationCollection.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


Item Property

Aspose.Slides Documentation

IImageTransformOperationCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IImageTransformOperation
[C#]
IImageTransformOperation this[
int index
] {get;}

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection Methods

The methods of the IImageTransformOperationCollection interface are listed below. For a complete list of IImageTransformOperationCollection interface members, see the IImageTransformOperationCollection Members topic.

Public Instance Methods

AddAlphaBiLevelEffect
AddAlphaCeilingEffect
AddAlphaFloorEffect
AddAlphaInverseEffect
AddAlphaModulateEffect
AddAlphaModulateFixedEffect
AddAlphaReplaceEffect
AddBiLevelEffect
AddBlurEffect
AddColorChangeEffect
AddColorReplaceEffect
AddDuotoneEffect
AddFillOverlayEffect
AddGrayScaleEffect
AddHSLEffect
AddLuminanceEffect
AddTintEffect
RemoveAt

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddAlphaBiLevelEffect Method

[Visual Basic]
Function AddAlphaBiLevelEffect( _
ByVal threshold As Single _
) As IAlphaBiLevel
[C#]
IAlphaBiLevel AddAlphaBiLevelEffect(
float threshold
);

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddAlphaCeilingEffect Method

[Visual Basic]
Function AddAlphaCeilingEffect() As IAlphaCeiling
[C#]
IAlphaCeiling AddAlphaCeilingEffect();

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddAlphaFloorEffect Method

[Visual Basic]
Function AddAlphaFloorEffect() As IAlphaFloor
[C#]
IAlphaFloor AddAlphaFloorEffect();

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddAlphaInverseEffect Method

[Visual Basic]
Function AddAlphaInverseEffect() As IAlphaInverse
[C#]
IAlphaInverse AddAlphaInverseEffect();

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddAlphaModulateEffect Method

[Visual Basic]
Function AddAlphaModulateEffect() As IAlphaModulate
[C#]
IAlphaModulate AddAlphaModulateEffect();

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddAlphaModulateFixedEffect Method

[Visual Basic]
Function AddAlphaModulateFixedEffect( _
ByVal amount As Single _
) As IAlphaModulateFixed
[C#]
IAlphaModulateFixed AddAlphaModulateFixedEffect(
float amount
);

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddAlphaReplaceEffect Method

[Visual Basic]
Function AddAlphaReplaceEffect( _
ByVal alpha As Single _
) As IAlphaReplace
[C#]
IAlphaReplace AddAlphaReplaceEffect(
float alpha
);

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddBiLevelEffect Method

[Visual Basic]
Function AddBiLevelEffect( _
ByVal threshold As Single _
) As IBiLevel
[C#]
IBiLevel AddBiLevelEffect(
float threshold
);

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddBlurEffect Method

[Visual Basic]
Function AddBlurEffect( _
ByVal radius As Double, _
ByVal grow As Boolean _
) As IBlur
[C#]
IBlur AddBlurEffect(
double radius,
bool grow
);

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddColorChangeEffect Method

[Visual Basic]
Function AddColorChangeEffect() As IColorChange
[C#]
IColorChange AddColorChangeEffect();

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddColorReplaceEffect Method

[Visual Basic]
Function AddColorReplaceEffect() As IColorReplace
[C#]
IColorReplace AddColorReplaceEffect();

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddDuotoneEffect Method

[Visual Basic]
Function AddDuotoneEffect() As IDuotone
[C#]
IDuotone AddDuotoneEffect();

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddFillOverlayEffect Method

[Visual Basic]
Function AddFillOverlayEffect() As IFillOverlay
[C#]
IFillOverlay AddFillOverlayEffect();

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddGrayScaleEffect Method

[Visual Basic]
Function AddGrayScaleEffect() As IGrayScale
[C#]
IGrayScale AddGrayScaleEffect();

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddHSLEffect Method

[Visual Basic]
Function AddHSLEffect( _
ByVal hue As Single, _
ByVal saturation As Single, _
ByVal luminance As Single _
) As IHSL
[C#]
IHSL AddHSLEffect(
float hue,
float saturation,
float luminance
);

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddLuminanceEffect Method

[Visual Basic]
Function AddLuminanceEffect( _
ByVal brightness As Single, _
ByVal contrast As Single _
) As ILuminance
[C#]
ILuminance AddLuminanceEffect(
float brightness,
float contrast
);

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.AddTintEffect Method

[Visual Basic]
Function AddTintEffect( _
ByVal hue As Single, _
ByVal amount As Single _
) As ITint
[C#]
ITint AddTintEffect(
float hue,
float amount
);

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationCollection.RemoveAt Method

[Visual Basic]
Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
void RemoveAt(
int index
);

See Also

IImageTransformOperationCollection Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory Interface

For a list of all members of this type, see IImageTransformOperationFactory Members.

[Visual Basic]
Public Interface IImageTransformOperationFactory
[C#]
public interface IImageTransformOperationFactory

Types that implement IImageTransformOperationFactory

Type | Description
ImageTransformOperationFactory | Allows to create image transform operations

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IImageTransformOperationFactory Members | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory Members

IImageTransformOperationFactory overview

Public Instance Methods

CreateAlphaBiLevel
CreateAlphaFloor
CreateAlphaInverse
CreateAlphaModulate
CreateAlphaModulateFixed
CreateAlphaReplace
CreateAlphCeiling
CreateBiLevel
CreateBlur
CreateColorChange
CreateColorReplace
CreateDuotone
CreateFillOverlay
CreateGlow
CreateGrayScale
CreateHSL
CreateLuminance
CreateTint

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory Methods

The methods of the IImageTransformOperationFactory interface are listed below. For a complete list of IImageTransformOperationFactory interface members, see the IImageTransformOperationFactory Members topic.

Public Instance Methods

CreateAlphaBiLevel
CreateAlphaFloor
CreateAlphaInverse
CreateAlphaModulate
CreateAlphaModulateFixed
CreateAlphaReplace
CreateAlphCeiling
CreateBiLevel
CreateBlur
CreateColorChange
CreateColorReplace
CreateDuotone
CreateFillOverlay
CreateGlow
CreateGrayScale
CreateHSL
CreateLuminance
CreateTint

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateAlphaBiLevel Method

[Visual Basic]
Function CreateAlphaBiLevel( _
ByVal threshold As Single _
) As IAlphaBiLevel
[C#]
IAlphaBiLevel CreateAlphaBiLevel(
float threshold
);

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateAlphaFloor Method

[Visual Basic]
Function CreateAlphaFloor() As IAlphaFloor
[C#]
IAlphaFloor CreateAlphaFloor();

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateAlphaInverse Method

[Visual Basic]
Function CreateAlphaInverse() As IAlphaInverse
[C#]
IAlphaInverse CreateAlphaInverse();

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateAlphaModulate Method

[Visual Basic]
Function CreateAlphaModulate() As IAlphaModulate
[C#]
IAlphaModulate CreateAlphaModulate();

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateAlphaModulateFixed Method

[Visual Basic]
Function CreateAlphaModulateFixed( _
ByVal amount As Single _
) As IAlphaModulateFixed
[C#]
IAlphaModulateFixed CreateAlphaModulateFixed(
float amount
);

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateAlphaReplace Method

[Visual Basic]
Function CreateAlphaReplace( _
ByVal alpha As Single _
) As IAlphaReplace
[C#]
IAlphaReplace CreateAlphaReplace(
float alpha
);

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateAlphCeiling Method

[Visual Basic]
Function CreateAlphCeiling() As IAlphaCeiling
[C#]
IAlphaCeiling CreateAlphCeiling();

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateBiLevel Method

[Visual Basic]
Function CreateBiLevel( _
ByVal threshold As Single _
) As IBiLevel
[C#]
IBiLevel CreateBiLevel(
float threshold
);

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateBlur Method

[Visual Basic]
Function CreateBlur( _
ByVal radius As Double, _
ByVal grow As Boolean _
) As IBlur
[C#]
IBlur CreateBlur(
double radius,
bool grow
);

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateColorChange Method

[Visual Basic]
Function CreateColorChange() As IColorChange
[C#]
IColorChange CreateColorChange();

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateColorReplace Method

[Visual Basic]
Function CreateColorReplace() As IColorReplace
[C#]
IColorReplace CreateColorReplace();

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateDuotone Method

[Visual Basic]
Function CreateDuotone() As IDuotone
[C#]
IDuotone CreateDuotone();

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateFillOverlay Method

[Visual Basic]
Function CreateFillOverlay() As IFillOverlay
[C#]
IFillOverlay CreateFillOverlay();

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateGlow Method

[Visual Basic]
Function CreateGlow() As IGlow
[C#]
IGlow CreateGlow();

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateGrayScale Method

[Visual Basic]
Function CreateGrayScale() As IGrayScale
[C#]
IGrayScale CreateGrayScale();

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateHSL Method

[Visual Basic]
Function CreateHSL( _
ByVal hue As Single, _
ByVal saturation As Single, _
ByVal luminance As Single _
) As IHSL
[C#]
IHSL CreateHSL(
float hue,
float saturation,
float luminance
);

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateLuminance Method

[Visual Basic]
Function CreateLuminance( _
ByVal brightness As Single, _
ByVal contrast As Single _
) As ILuminance
[C#]
ILuminance CreateLuminance(
float brightness,
float contrast
);

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IImageTransformOperationFactory.CreateTint Method

[Visual Basic]
Function CreateTint( _
ByVal hue As Single, _
ByVal amount As Single _
) As ITint
[C#]
ITint CreateTint(
float hue,
float amount
);

See Also

IImageTransformOperationFactory Interface | Aspose.Slides.Effects Namespace


IInnerShadow Interface

For a list of all members of this type, see IInnerShadow Members.

[Visual Basic]
Public Interface IInnerShadow
[C#]
public interface IInnerShadow

Types that implement IInnerShadow

Type | Description
InnerShadow | Represents a inner shadow effect.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IInnerShadow Members | Aspose.Slides.Effects Namespace


IInnerShadow Members

IInnerShadow overview

Public Instance Properties

BlurRadius
Direction
Distance
ShadowColor

See Also

IInnerShadow Interface | Aspose.Slides.Effects Namespace


IInnerShadow Properties

The properties of the IInnerShadow interface are listed below. For a complete list of IInnerShadow interface members, see the IInnerShadow Members topic.

Public Instance Properties

BlurRadius
Direction
Distance
ShadowColor

See Also

IInnerShadow Interface | Aspose.Slides.Effects Namespace


BlurRadius Property

Aspose.Slides Documentation

IInnerShadow.BlurRadius Property

[Visual Basic]
Property BlurRadius As Double
[C#]
double BlurRadius {get; set;}

See Also

IInnerShadow Interface | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

IInnerShadow.Direction Property

[Visual Basic]
Property Direction As Single
[C#]
float Direction {get; set;}

See Also

IInnerShadow Interface | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

IInnerShadow.Distance Property

[Visual Basic]
Property Distance As Double
[C#]
double Distance {get; set;}

See Also

IInnerShadow Interface | Aspose.Slides.Effects Namespace


ShadowColor Property

Aspose.Slides Documentation

IInnerShadow.ShadowColor Property

[Visual Basic]
Property ShadowColor As IColorFormat
[C#]
IColorFormat ShadowColor {get;}

See Also

IInnerShadow Interface | Aspose.Slides.Effects Namespace


IInnerShadowEffectiveData Interface

For a list of all members of this type, see IInnerShadowEffectiveData Members.

[Visual Basic]
Public Interface IInnerShadowEffectiveData
[C#]
public interface IInnerShadowEffectiveData

Types that implement IInnerShadowEffectiveData

Type | Description
InnerShadowEffectiveData | Immutable object which represents a inner shadow effect.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IInnerShadowEffectiveData Members | Aspose.Slides.Effects Namespace


IInnerShadowEffectiveData Members

IInnerShadowEffectiveData overview

Public Instance Properties

BlurRadius
Direction
Distance
ShadowColor

See Also

IInnerShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


IInnerShadowEffectiveData Properties

The properties of the IInnerShadowEffectiveData interface are listed below. For a complete list of IInnerShadowEffectiveData interface members, see the IInnerShadowEffectiveData Members topic.

Public Instance Properties

BlurRadius
Direction
Distance
ShadowColor

See Also

IInnerShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


BlurRadius Property

Aspose.Slides Documentation

IInnerShadowEffectiveData.BlurRadius Property

[Visual Basic]
Property BlurRadius As Double
[C#]
double BlurRadius {get;}

See Also

IInnerShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

IInnerShadowEffectiveData.Direction Property

[Visual Basic]
Property Direction As Single
[C#]
float Direction {get;}

See Also

IInnerShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

IInnerShadowEffectiveData.Distance Property

[Visual Basic]
Property Distance As Double
[C#]
double Distance {get;}

See Also

IInnerShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


ShadowColor Property

Aspose.Slides Documentation

IInnerShadowEffectiveData.ShadowColor Property

[Visual Basic]
Property ShadowColor As Color
[C#]
Color ShadowColor {get;}

See Also

IInnerShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


ILuminance Interface

For a list of all members of this type, see ILuminance Members.

[Visual Basic]
Public Interface ILuminance
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface ILuminance : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement ILuminance

Type | Description
Luminance | Represents a Luminance effect. Brightness linearly shifts all colors closer to white or black. Contrast scales all colors to be either closer or further apart.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILuminance Members | Aspose.Slides.Effects Namespace


ILuminance Members

ILuminance overview

Public Instance Properties

AsIImageTransformOperation

See Also

ILuminance Interface | Aspose.Slides.Effects Namespace


ILuminance Properties

The properties of the ILuminance interface are listed below. For a complete list of ILuminance interface members, see the ILuminance Members topic.

Public Instance Properties

AsIImageTransformOperation

See Also

ILuminance Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

ILuminance.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

ILuminance Interface | Aspose.Slides.Effects Namespace


ILuminanceEffectiveData Interface

For a list of all members of this type, see ILuminanceEffectiveData Members.

[Visual Basic]
Public Interface ILuminanceEffectiveData
[C#]
public interface ILuminanceEffectiveData

Types that implement ILuminanceEffectiveData

Type | Description
LuminanceEffectiveData | Represents a Luminance effect. Brightness linearly shifts all colors closer to white or black. Contrast scales all colors to be either closer or further apart.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILuminanceEffectiveData Members | Aspose.Slides.Effects Namespace


ILuminanceEffectiveData Members

ILuminanceEffectiveData overview

Public Instance Properties

Brightness
Contrast

See Also

ILuminanceEffectiveData Interface | Aspose.Slides.Effects Namespace


ILuminanceEffectiveData Properties

The properties of the ILuminanceEffectiveData interface are listed below. For a complete list of ILuminanceEffectiveData interface members, see the ILuminanceEffectiveData Members topic.

Public Instance Properties

Brightness
Contrast

See Also

ILuminanceEffectiveData Interface | Aspose.Slides.Effects Namespace


Brightness Property

Aspose.Slides Documentation

ILuminanceEffectiveData.Brightness Property

[Visual Basic]
Property Brightness As Single
[C#]
float Brightness {get;}

See Also

ILuminanceEffectiveData Interface | Aspose.Slides.Effects Namespace


Contrast Property

Aspose.Slides Documentation

ILuminanceEffectiveData.Contrast Property

[Visual Basic]
Property Contrast As Single
[C#]
float Contrast {get;}

See Also

ILuminanceEffectiveData Interface | Aspose.Slides.Effects Namespace


ImageTransformOCollectionEffectiveData Class

Immutable object which represents a readonly collection of EffectData objects.

For a list of all members of this type, see ImageTransformOCollectionEffectiveData Members.

System.Object
Aspose.Slides.Effects.ImageTransformOCollectionEffectiveData

[Visual Basic]
Public Class ImageTransformOCollectionEffectiveData
Implements IImageTransformOCollectionEffectiveData, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Effects.IEffectEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class ImageTransformOCollectionEffectiveData : IImageTransformOCollectionEffectiveData, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Remarks

Name IImageTransformOperationCollectionEffectiveData truncuted to IImageTransformOCollectionEffectiveData becouse of COM names length cannot be more then 39.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ImageTransformOCollectionEffectiveData Members | Aspose.Slides.Effects Namespace


ImageTransformOCollectionEffectiveData Members

ImageTransformOCollectionEffectiveData overview

Public Instance Constructors

ImageTransformOCollectionEffectiveData Constructor Initializes a new instance of the ImageTransformOCollectionEffectiveData class.

Public Instance Properties

Count | Returns the number of image effects in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns element by index.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

CopyTo | Copies all elements from the collection into the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

ImageTransformOCollectionEffectiveData Class | Aspose.Slides.Effects Namespace


ImageTransformOCollectionEffectiveData Constructor

Initializes a new instance of the ImageTransformOCollectionEffectiveData class.

[Visual Basic]
Public Sub New()
[C#]
public ImageTransformOCollectionEffectiveData();

See Also

ImageTransformOCollectionEffectiveData Class | Aspose.Slides.Effects Namespace


ImageTransformOCollectionEffectiveData Properties

The properties of the ImageTransformOCollectionEffectiveData class are listed below. For a complete list of ImageTransformOCollectionEffectiveData class members, see the ImageTransformOCollectionEffectiveData Members topic.

Public Instance Properties

Count | Returns the number of image effects in a collection. Read-only Int32.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns element by index.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

ImageTransformOCollectionEffectiveData Class | Aspose.Slides.Effects Namespace


Count Property

Aspose.Slides Documentation

ImageTransformOCollectionEffectiveData.Count Property

Returns the number of image effects in a collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

ImageTransformOCollectionEffectiveData Class | Aspose.Slides.Effects Namespace


IsSynchronized Property

Aspose.Slides Documentation

ImageTransformOCollectionEffectiveData.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ImageTransformOCollectionEffectiveData Class | Aspose.Slides.Effects Namespace


Item Property

Aspose.Slides Documentation

ImageTransformOCollectionEffectiveData.Item Property

Returns element by index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IImageTransformOCollectionEffectiveData.Item
As IEffectEffectiveData _
Implements IImageTransformOCollectionEffectiveData.Item
[C#]
public IEffectEffectiveData this[
int index
] {get;}

Parameters

index

Implements

IImageTransformOCollectionEffectiveData.Item

See Also

ImageTransformOCollectionEffectiveData Class | Aspose.Slides.Effects Namespace


SyncRoot Property

Aspose.Slides Documentation

ImageTransformOCollectionEffectiveData.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ImageTransformOCollectionEffectiveData Class | Aspose.Slides.Effects Namespace


ImageTransformOCollectionEffectiveData Methods

The methods of the ImageTransformOCollectionEffectiveData class are listed below. For a complete list of ImageTransformOCollectionEffectiveData class members, see the ImageTransformOCollectionEffectiveData Members topic.

Public Instance Methods

CopyTo | Copies all elements from the collection into the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

ImageTransformOCollectionEffectiveData Class | Aspose.Slides.Effects Namespace


ImageTransformOCollectionEffectiveData.CopyTo Method

Copies all elements from the collection into the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Array to fill.
index
Starting position in target array.

Implements

ICollection.CopyTo

See Also

ImageTransformOCollectionEffectiveData Class | Aspose.Slides.Effects Namespace


ImageTransformOCollectionEffectiveData.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

ImageTransformOCollectionEffectiveData Class | Aspose.Slides.Effects Namespace


ImageTransformOperation Class

Represents abstract image transformation effect.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Derived types

[Visual Basic]
MustInherit Public Class ImageTransformOperation
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public abstract class ImageTransformOperation : IImageTransformOperation, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Effects Namespace


ImageTransformOperationCollection Class

Represents a collection of effects apllied to an image.

For a list of all members of this type, see ImageTransformOperationCollection Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperationCollection

[Visual Basic]
NotInheritable Public Class ImageTransformOperationCollection
Implements IImageTransformOperationCollection, ICollection`1([Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable`1([Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56)), IEnumerable, ISlideComponent, IPresentationComponent
[C#]
public sealed class ImageTransformOperationCollection : IImageTransformOperationCollection, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ImageTransformOperationCollection Members | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection Members

ImageTransformOperationCollection overview

Public Instance Properties

Count | Returns the number of image effects in a collection. Read-only Int32.
IsReadOnly | Gets a value indicating whether the ICollection`1 is read-only.
Item | Returns an ImageTransformOperation from the collection by it's index.
Presentation | Returns the parent presentation for an ImageTransformEx collection. Read-only Presentation.
Slide | Returns the parent slide for an ImageTransformEx collection. Read-only BaseSlide.

Public Instance Methods

Add | Adds the new image effect to the end of a collection.
AddAlphaBiLevelEffect | Adds the new Alpha Bi-Level effect to the end of a collection.
AddAlphaCeilingEffect | Adds the new Alpha Ceiling effect to the end of a collection.
AddAlphaFloorEffect | Adds the new Alpha Floor effect to the end of a collection.
AddAlphaInverseEffect | Adds the new Alpha Inverse effect to the end of a collection.
AddAlphaModulateEffect | Adds the new Alpha Modulate effect to the end of a collection.
AddAlphaModulateFixedEffect | Adds the new Alpha Modulate Fixed effect to the end of a collection.
AddAlphaReplaceEffect | Adds the new Alpha Replace effect to the end of a collection.
AddBiLevelEffect | Adds the new Bi-Level (black/white) effect to the end of a collection.
AddBlurEffect | Adds the new Blur effect to the end of a collection.
AddColorChangeEffect | Adds the new Color Change effect to the end of a collection.
AddColorReplaceEffect | Adds the new Color Replacement effect to the end of a collection.
AddDuotoneEffect | Adds the new Duotone effect to the end of a collection.
AddFillOverlayEffect | Adds the new Fill Overlay effect to the end of a collection.
AddGrayScaleEffect | Adds the new Gray Scale effect to the end of a collection.
AddHSLEffect | Adds the new Hue/Saturation/Luminance effect to the end of a collection.
AddLuminanceEffect | Adds the new Luminance effect to the end of a collection.
AddTintEffect | Adds the new Tint effect to the end of a collection.
Clear | Removes all image effects from a collection.
Contains | Determines whether the ICollection`1 contains a specific value.
CopyTo | Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.
GetEnumerator | Returns an enumerator for the entire collection.
Remove | Removes the first occurrence of a specific object from the ICollection`1.
RemoveAt | Removes an image effect from a collection at the specified index.

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection Properties

The properties of the ImageTransformOperationCollection class are listed below. For a complete list of ImageTransformOperationCollection class members, see the ImageTransformOperationCollection Members topic.

Public Instance Properties

Count | Returns the number of image effects in a collection. Read-only Int32.
IsReadOnly | Gets a value indicating whether the ICollection`1 is read-only.
Item | Returns an ImageTransformOperation from the collection by it's index.
Presentation | Returns the parent presentation for an ImageTransformEx collection. Read-only Presentation.
Slide | Returns the parent slide for an ImageTransformEx collection. Read-only BaseSlide.

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


Count Property

Aspose.Slides Documentation

ImageTransformOperationCollection.Count Property

Returns the number of image effects in a collection. Read-only Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection`1.Count
[C#]
public int Count {get;}

Implements

ICollection`1.Count

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


IsReadOnly Property

Aspose.Slides Documentation

ImageTransformOperationCollection.IsReadOnly Property

Gets a value indicating whether the ICollection`1 is read-only.

[Visual Basic]
NotOverridable Public ReadOnly Property IsReadOnly As Boolean _
Implements ICollection`1.IsReadOnly
[C#]
public bool IsReadOnly {get;}

Implements

ICollection`1.IsReadOnly

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


Item Property

Aspose.Slides Documentation

ImageTransformOperationCollection.Item Property

Returns an ImageTransformOperation from the collection by it's index.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IImageTransformOperationCollection.Item
As IImageTransformOperation _
Implements IImageTransformOperationCollection.Item
[C#]
public IImageTransformOperation this[
int index
] {get;}

Parameters

index

Implements

IImageTransformOperationCollection.Item

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


Presentation Property

Aspose.Slides Documentation

ImageTransformOperationCollection.Presentation Property

Returns the parent presentation for an ImageTransformEx collection. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


Slide Property

Aspose.Slides Documentation

ImageTransformOperationCollection.Slide Property

Returns the parent slide for an ImageTransformEx collection. Read-only BaseSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As IBaseSlide _
Implements ISlideComponent.Slide
[C#]
public IBaseSlide Slide {get;}

Implements

ISlideComponent.Slide

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection Methods

The methods of the ImageTransformOperationCollection class are listed below. For a complete list of ImageTransformOperationCollection class members, see the ImageTransformOperationCollection Members topic.

Public Instance Methods

Add | Adds the new image effect to the end of a collection.
AddAlphaBiLevelEffect | Adds the new Alpha Bi-Level effect to the end of a collection.
AddAlphaCeilingEffect | Adds the new Alpha Ceiling effect to the end of a collection.
AddAlphaFloorEffect | Adds the new Alpha Floor effect to the end of a collection.
AddAlphaInverseEffect | Adds the new Alpha Inverse effect to the end of a collection.
AddAlphaModulateEffect | Adds the new Alpha Modulate effect to the end of a collection.
AddAlphaModulateFixedEffect | Adds the new Alpha Modulate Fixed effect to the end of a collection.
AddAlphaReplaceEffect | Adds the new Alpha Replace effect to the end of a collection.
AddBiLevelEffect | Adds the new Bi-Level (black/white) effect to the end of a collection.
AddBlurEffect | Adds the new Blur effect to the end of a collection.
AddColorChangeEffect | Adds the new Color Change effect to the end of a collection.
AddColorReplaceEffect | Adds the new Color Replacement effect to the end of a collection.
AddDuotoneEffect | Adds the new Duotone effect to the end of a collection.
AddFillOverlayEffect | Adds the new Fill Overlay effect to the end of a collection.
AddGrayScaleEffect | Adds the new Gray Scale effect to the end of a collection.
AddHSLEffect | Adds the new Hue/Saturation/Luminance effect to the end of a collection.
AddLuminanceEffect | Adds the new Luminance effect to the end of a collection.
AddTintEffect | Adds the new Tint effect to the end of a collection.
Clear | Removes all image effects from a collection.
Contains | Determines whether the ICollection`1 contains a specific value.
CopyTo | Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.
GetEnumerator | Returns an enumerator for the entire collection.
Remove | Removes the first occurrence of a specific object from the ICollection`1.
RemoveAt | Removes an image effect from a collection at the specified index.

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.Add Method

Adds the new image effect to the end of a collection.

[Visual Basic]
NotOverridable Public Sub Add( _
ByVal operation As IImageTransformOperation _
) _
Implements ICollection`1.Add
[C#]
public void Add(
IImageTransformOperation operation
);

Parameters

operation
The image effect to add to the end of a collection.

Return Value

Index of the new image effect in a collection.

Implements

ICollection`1.Add

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddAlphaBiLevelEffect Method

Adds the new Alpha Bi-Level effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddAlphaBiLevelEffect( _
ByVal threshold As Single _
) As IAlphaBiLevel _
Implements IImageTransformOperationCollection.AddAlphaBiLevelEffect
[C#]
public IAlphaBiLevel AddAlphaBiLevelEffect(
float threshold
);

Parameters

threshold
The threshold value for the alpha bi-level effect.

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddAlphaBiLevelEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddAlphaCeilingEffect Method

Adds the new Alpha Ceiling effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddAlphaCeilingEffect() As IAlphaCeiling _
Implements IImageTransformOperationCollection.AddAlphaCeilingEffect
[C#]
public IAlphaCeiling AddAlphaCeilingEffect();

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddAlphaCeilingEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddAlphaFloorEffect Method

Adds the new Alpha Floor effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddAlphaFloorEffect() As IAlphaFloor _
Implements IImageTransformOperationCollection.AddAlphaFloorEffect
[C#]
public IAlphaFloor AddAlphaFloorEffect();

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddAlphaFloorEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddAlphaInverseEffect Method

Adds the new Alpha Inverse effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddAlphaInverseEffect() As IAlphaInverse _
Implements IImageTransformOperationCollection.AddAlphaInverseEffect
[C#]
public IAlphaInverse AddAlphaInverseEffect();

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddAlphaInverseEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddAlphaModulateEffect Method

Adds the new Alpha Modulate effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddAlphaModulateEffect() As IAlphaModulate _
Implements IImageTransformOperationCollection.AddAlphaModulateEffect
[C#]
public IAlphaModulate AddAlphaModulateEffect();

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddAlphaModulateEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddAlphaModulateFixedEffect Method

Adds the new Alpha Modulate Fixed effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddAlphaModulateFixedEffect( _
ByVal amount As Single _
) As IAlphaModulateFixed _
Implements IImageTransformOperationCollection.AddAlphaModulateFixedEffect
[C#]
public IAlphaModulateFixed AddAlphaModulateFixedEffect(
float amount
);

Parameters

amount
The percentage amount to scale the alpha.

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddAlphaModulateFixedEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddAlphaReplaceEffect Method

Adds the new Alpha Replace effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddAlphaReplaceEffect( _
ByVal alpha As Single _
) As IAlphaReplace _
Implements IImageTransformOperationCollection.AddAlphaReplaceEffect
[C#]
public IAlphaReplace AddAlphaReplaceEffect(
float alpha
);

Parameters

alpha
The new opacity value.

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddAlphaReplaceEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddBiLevelEffect Method

Adds the new Bi-Level (black/white) effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddBiLevelEffect( _
ByVal threshold As Single _
) As IBiLevel _
Implements IImageTransformOperationCollection.AddBiLevelEffect
[C#]
public IBiLevel AddBiLevelEffect(
float threshold
);

Parameters

threshold
the luminance threshold for the Bi-Level effect. Values greater than or equal to the threshold are set to white. Values lesser than the threshold are set to black.

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddBiLevelEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddBlurEffect Method

Adds the new Blur effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddBlurEffect( _
ByVal radius As Double, _
ByVal grow As Boolean _
) As IBlur _
Implements IImageTransformOperationCollection.AddBlurEffect
[C#]
public IBlur AddBlurEffect(
double radius,
bool grow
);

Parameters

radius
The radius of blur.
grow
Specifies whether the bounds of the object should be grown as a result of the blurring. True indicates the bounds are grown while false indicates that they are not.

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddBlurEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddColorChangeEffect Method

Adds the new Color Change effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddColorChangeEffect() As IColorChange _
Implements IImageTransformOperationCollection.AddColorChangeEffect
[C#]
public IColorChange AddColorChangeEffect();

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddColorChangeEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddColorReplaceEffect Method

Adds the new Color Replacement effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddColorReplaceEffect() As IColorReplace _
Implements IImageTransformOperationCollection.AddColorReplaceEffect
[C#]
public IColorReplace AddColorReplaceEffect();

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddColorReplaceEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddDuotoneEffect Method

Adds the new Duotone effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddDuotoneEffect() As IDuotone _
Implements IImageTransformOperationCollection.AddDuotoneEffect
[C#]
public IDuotone AddDuotoneEffect();

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddDuotoneEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddFillOverlayEffect Method

Adds the new Fill Overlay effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddFillOverlayEffect() As IFillOverlay _
Implements IImageTransformOperationCollection.AddFillOverlayEffect
[C#]
public IFillOverlay AddFillOverlayEffect();

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddFillOverlayEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddGrayScaleEffect Method

Adds the new Gray Scale effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddGrayScaleEffect() As IGrayScale _
Implements IImageTransformOperationCollection.AddGrayScaleEffect
[C#]
public IGrayScale AddGrayScaleEffect();

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddGrayScaleEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddHSLEffect Method

Adds the new Hue/Saturation/Luminance effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddHSLEffect( _
ByVal hue As Single, _
ByVal saturation As Single, _
ByVal luminance As Single _
) As IHSL _
Implements IImageTransformOperationCollection.AddHSLEffect
[C#]
public IHSL AddHSLEffect(
float hue,
float saturation,
float luminance
);

Parameters

hue
The number of degrees by which the hue is adjusted.
saturation
The percentage by which the saturation is adjusted.
luminance
The percentage by which the luminance is adjusted.

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddHSLEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddLuminanceEffect Method

Adds the new Luminance effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddLuminanceEffect( _
ByVal brightness As Single, _
ByVal contrast As Single _
) As ILuminance _
Implements IImageTransformOperationCollection.AddLuminanceEffect
[C#]
public ILuminance AddLuminanceEffect(
float brightness,
float contrast
);

Parameters

brightness
The percent to change the brightness.
contrast
The percent to change the contrast.

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddLuminanceEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.AddTintEffect Method

Adds the new Tint effect to the end of a collection.

[Visual Basic]
NotOverridable Public Function AddTintEffect( _
ByVal hue As Single, _
ByVal amount As Single _
) As ITint _
Implements IImageTransformOperationCollection.AddTintEffect
[C#]
public ITint AddTintEffect(
float hue,
float amount
);

Parameters

hue
The hue towards which to tint.
amount
Specifies by how much the color value is shifted.

Return Value

Index of the new image effect in a collection.

Implements

IImageTransformOperationCollection.AddTintEffect

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.Clear Method

Removes all image effects from a collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements ICollection`1.Clear
[C#]
public void Clear();

Implements

ICollection`1.Clear

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.Contains Method

Determines whether the ICollection`1 contains a specific value.

[Visual Basic]
NotOverridable Public Function Contains( _
ByVal item As IImageTransformOperation _
) As Boolean _
Implements ICollection`1.Contains
[C#]
public bool Contains(
IImageTransformOperation item
);

Parameters

item
The object to locate in the ICollection`1.

Return Value

true if item is found in the ICollection`1; otherwise, false.

Implements

ICollection`1.Contains

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.CopyTo Method

Copies the elements of the ICollection`1 to an Array, starting at a particular Array index.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As IImageTransformOperation(), _
ByVal arrayIndex As Integer _
) _
Implements ICollection`1.CopyTo
[C#]
public void CopyTo(
IImageTransformOperation[] array,
int arrayIndex
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from ICollection`1. The Array must have zero-based indexing.
arrayIndex
The zero-based index in array at which copying begins.

Implements

ICollection`1.CopyTo

Exceptions

Exception Type | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | The number of elements in the source ICollection`1 is greater than the available space from arrayIndex to the end of the destination array.

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.Remove Method

Removes the first occurrence of a specific object from the ICollection`1.

[Visual Basic]
NotOverridable Public Function Remove( _
ByVal item As IImageTransformOperation _
) As Boolean _
Implements ICollection`1.Remove
[C#]
public bool Remove(
IImageTransformOperation item
);

Parameters

item
The object to remove from the ICollection`1.

Return Value

true if item was successfully removed from the ICollection`1; otherwise, false. This method also returns false if item is not found in the original ICollection`1.

Implements

ICollection`1.Remove

Exceptions

Exception Type | Condition
NotSupportedException | The ICollection`1 is read-only.

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationCollection.RemoveAt Method

Removes an image effect from a collection at the specified index.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IImageTransformOperationCollection.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
Index of an image effect that should be deleted.

Implements

IImageTransformOperationCollection.RemoveAt

See Also

ImageTransformOperationCollection Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory Class

Allows to create image transform operations

For a list of all members of this type, see ImageTransformOperationFactory Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperationFactory

[Visual Basic]
Public Class ImageTransformOperationFactory
Implements IImageTransformOperationFactory
[C#]
public class ImageTransformOperationFactory : IImageTransformOperationFactory

Remarks

For COM compatibility

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ImageTransformOperationFactory Members | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory Members

ImageTransformOperationFactory overview

Public Instance Constructors

ImageTransformOperationFactory Constructor Initializes a new instance of the ImageTransformOperationFactory class.

Public Instance Methods

CreateAlphaBiLevel
CreateAlphaFloor
CreateAlphaInverse
CreateAlphaModulate
CreateAlphaModulateFixed
CreateAlphaReplace
CreateAlphCeiling
CreateBiLevel
CreateBlur
CreateColorChange
CreateColorReplace
CreateDuotone
CreateFillOverlay
CreateGlow
CreateGrayScale
CreateHSL
CreateLuminance
CreateTint

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory Constructor

Initializes a new instance of the ImageTransformOperationFactory class.

[Visual Basic]
Public Sub New()
[C#]
public ImageTransformOperationFactory();

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory Methods

The methods of the ImageTransformOperationFactory class are listed below. For a complete list of ImageTransformOperationFactory class members, see the ImageTransformOperationFactory Members topic.

Public Instance Methods

CreateAlphaBiLevel
CreateAlphaFloor
CreateAlphaInverse
CreateAlphaModulate
CreateAlphaModulateFixed
CreateAlphaReplace
CreateAlphCeiling
CreateBiLevel
CreateBlur
CreateColorChange
CreateColorReplace
CreateDuotone
CreateFillOverlay
CreateGlow
CreateGrayScale
CreateHSL
CreateLuminance
CreateTint

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateAlphaBiLevel Method

[Visual Basic]
NotOverridable Public Function CreateAlphaBiLevel( _
ByVal threshold As Single _
) As IAlphaBiLevel _
Implements IImageTransformOperationFactory.CreateAlphaBiLevel
[C#]
public IAlphaBiLevel CreateAlphaBiLevel(
float threshold
);

Implements

IImageTransformOperationFactory.CreateAlphaBiLevel

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateAlphaFloor Method

[Visual Basic]
NotOverridable Public Function CreateAlphaFloor() As IAlphaFloor _
Implements IImageTransformOperationFactory.CreateAlphaFloor
[C#]
public IAlphaFloor CreateAlphaFloor();

Implements

IImageTransformOperationFactory.CreateAlphaFloor

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateAlphaInverse Method

[Visual Basic]
NotOverridable Public Function CreateAlphaInverse() As IAlphaInverse _
Implements IImageTransformOperationFactory.CreateAlphaInverse
[C#]
public IAlphaInverse CreateAlphaInverse();

Implements

IImageTransformOperationFactory.CreateAlphaInverse

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateAlphaModulate Method

[Visual Basic]
NotOverridable Public Function CreateAlphaModulate() As IAlphaModulate _
Implements IImageTransformOperationFactory.CreateAlphaModulate
[C#]
public IAlphaModulate CreateAlphaModulate();

Implements

IImageTransformOperationFactory.CreateAlphaModulate

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateAlphaModulateFixed Method

[Visual Basic]
NotOverridable Public Function CreateAlphaModulateFixed( _
ByVal amount As Single _
) As IAlphaModulateFixed _
Implements IImageTransformOperationFactory.CreateAlphaModulateFixed
[C#]
public IAlphaModulateFixed CreateAlphaModulateFixed(
float amount
);

Implements

IImageTransformOperationFactory.CreateAlphaModulateFixed

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateAlphaReplace Method

[Visual Basic]
NotOverridable Public Function CreateAlphaReplace( _
ByVal alpha As Single _
) As IAlphaReplace _
Implements IImageTransformOperationFactory.CreateAlphaReplace
[C#]
public IAlphaReplace CreateAlphaReplace(
float alpha
);

Implements

IImageTransformOperationFactory.CreateAlphaReplace

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateAlphCeiling Method

[Visual Basic]
NotOverridable Public Function CreateAlphCeiling() As IAlphaCeiling _
Implements IImageTransformOperationFactory.CreateAlphCeiling
[C#]
public IAlphaCeiling CreateAlphCeiling();

Implements

IImageTransformOperationFactory.CreateAlphCeiling

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateBiLevel Method

[Visual Basic]
NotOverridable Public Function CreateBiLevel( _
ByVal threshold As Single _
) As IBiLevel _
Implements IImageTransformOperationFactory.CreateBiLevel
[C#]
public IBiLevel CreateBiLevel(
float threshold
);

Implements

IImageTransformOperationFactory.CreateBiLevel

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateBlur Method

[Visual Basic]
NotOverridable Public Function CreateBlur( _
ByVal radius As Double, _
ByVal grow As Boolean _
) As IBlur _
Implements IImageTransformOperationFactory.CreateBlur
[C#]
public IBlur CreateBlur(
double radius,
bool grow
);

Implements

IImageTransformOperationFactory.CreateBlur

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateColorChange Method

[Visual Basic]
NotOverridable Public Function CreateColorChange() As IColorChange _
Implements IImageTransformOperationFactory.CreateColorChange
[C#]
public IColorChange CreateColorChange();

Implements

IImageTransformOperationFactory.CreateColorChange

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateColorReplace Method

[Visual Basic]
NotOverridable Public Function CreateColorReplace() As IColorReplace _
Implements IImageTransformOperationFactory.CreateColorReplace
[C#]
public IColorReplace CreateColorReplace();

Implements

IImageTransformOperationFactory.CreateColorReplace

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateDuotone Method

[Visual Basic]
NotOverridable Public Function CreateDuotone() As IDuotone _
Implements IImageTransformOperationFactory.CreateDuotone
[C#]
public IDuotone CreateDuotone();

Implements

IImageTransformOperationFactory.CreateDuotone

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateFillOverlay Method

[Visual Basic]
NotOverridable Public Function CreateFillOverlay() As IFillOverlay _
Implements IImageTransformOperationFactory.CreateFillOverlay
[C#]
public IFillOverlay CreateFillOverlay();

Implements

IImageTransformOperationFactory.CreateFillOverlay

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateGlow Method

[Visual Basic]
NotOverridable Public Function CreateGlow() As IGlow _
Implements IImageTransformOperationFactory.CreateGlow
[C#]
public IGlow CreateGlow();

Implements

IImageTransformOperationFactory.CreateGlow

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateGrayScale Method

[Visual Basic]
NotOverridable Public Function CreateGrayScale() As IGrayScale _
Implements IImageTransformOperationFactory.CreateGrayScale
[C#]
public IGrayScale CreateGrayScale();

Implements

IImageTransformOperationFactory.CreateGrayScale

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateHSL Method

[Visual Basic]
NotOverridable Public Function CreateHSL( _
ByVal hue As Single, _
ByVal saturation As Single, _
ByVal luminance As Single _
) As IHSL _
Implements IImageTransformOperationFactory.CreateHSL
[C#]
public IHSL CreateHSL(
float hue,
float saturation,
float luminance
);

Implements

IImageTransformOperationFactory.CreateHSL

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateLuminance Method

[Visual Basic]
NotOverridable Public Function CreateLuminance( _
ByVal brightness As Single, _
ByVal contrast As Single _
) As ILuminance _
Implements IImageTransformOperationFactory.CreateLuminance
[C#]
public ILuminance CreateLuminance(
float brightness,
float contrast
);

Implements

IImageTransformOperationFactory.CreateLuminance

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


ImageTransformOperationFactory.CreateTint Method

[Visual Basic]
NotOverridable Public Function CreateTint( _
ByVal hue As Single, _
ByVal amount As Single _
) As ITint _
Implements IImageTransformOperationFactory.CreateTint
[C#]
public ITint CreateTint(
float hue,
float amount
);

Implements

IImageTransformOperationFactory.CreateTint

See Also

ImageTransformOperationFactory Class | Aspose.Slides.Effects Namespace


InnerShadow Class

Represents a inner shadow effect.

For a list of all members of this type, see InnerShadow Members.

System.Object
Aspose.Slides.Effects.InnerShadow

[Visual Basic]
Public Class InnerShadow
Implements IInnerShadow
[C#]
public class InnerShadow : IInnerShadow

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

InnerShadow Members | Aspose.Slides.Effects Namespace


InnerShadow Members

InnerShadow overview

Public Instance Constructors

InnerShadow Constructor Creates new instance of InnerShadow class.

Public Instance Properties

BlurRadius | Blur radius.
Direction | Direction of shadow.
Distance | Distance of shadow.
ShadowColor | Color of shadow.

See Also

InnerShadow Class | Aspose.Slides.Effects Namespace


InnerShadow Constructor

Creates new instance of InnerShadow class.

[Visual Basic]
Public Sub New()
[C#]
public InnerShadow();

See Also

InnerShadow Class | Aspose.Slides.Effects Namespace


InnerShadow Properties

The properties of the InnerShadow class are listed below. For a complete list of InnerShadow class members, see the InnerShadow Members topic.

Public Instance Properties

BlurRadius | Blur radius.
Direction | Direction of shadow.
Distance | Distance of shadow.
ShadowColor | Color of shadow.

See Also

InnerShadow Class | Aspose.Slides.Effects Namespace


BlurRadius Property

Aspose.Slides Documentation

InnerShadow.BlurRadius Property

Blur radius.

[Visual Basic]
NotOverridable Public Property BlurRadius As Double _
Implements IInnerShadow.BlurRadius
[C#]
public double BlurRadius {get; set;}

Implements

IInnerShadow.BlurRadius

See Also

InnerShadow Class | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

InnerShadow.Direction Property

Direction of shadow.

[Visual Basic]
NotOverridable Public Property Direction As Single _
Implements IInnerShadow.Direction
[C#]
public float Direction {get; set;}

Implements

IInnerShadow.Direction

See Also

InnerShadow Class | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

InnerShadow.Distance Property

Distance of shadow.

[Visual Basic]
NotOverridable Public Property Distance As Double _
Implements IInnerShadow.Distance
[C#]
public double Distance {get; set;}

Implements

IInnerShadow.Distance

See Also

InnerShadow Class | Aspose.Slides.Effects Namespace


ShadowColor Property

Aspose.Slides Documentation

InnerShadow.ShadowColor Property

Color of shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property ShadowColor As IColorFormat _
Implements IInnerShadow.ShadowColor
[C#]
public IColorFormat ShadowColor {get;}

Implements

IInnerShadow.ShadowColor

See Also

InnerShadow Class | Aspose.Slides.Effects Namespace


InnerShadowEffectiveData Class

Immutable object which represents a inner shadow effect.

For a list of all members of this type, see InnerShadowEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.InnerShadowEffectiveData

[Visual Basic]
Public Class InnerShadowEffectiveData
Inherits EffectEffectiveData
Implements IInnerShadowEffectiveData
[C#]
public class InnerShadowEffectiveData : EffectEffectiveData, IInnerShadowEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

InnerShadowEffectiveData Members | Aspose.Slides.Effects Namespace


InnerShadowEffectiveData Members

InnerShadowEffectiveData overview

Public Instance Properties

BlurRadius | Blur radius.
Direction | Direction of shadow.
Distance | Distance of shadow.
ShadowColor | Color of shadow.

See Also

InnerShadowEffectiveData Class | Aspose.Slides.Effects Namespace


InnerShadowEffectiveData Properties

The properties of the InnerShadowEffectiveData class are listed below. For a complete list of InnerShadowEffectiveData class members, see the InnerShadowEffectiveData Members topic.

Public Instance Properties

BlurRadius | Blur radius.
Direction | Direction of shadow.
Distance | Distance of shadow.
ShadowColor | Color of shadow.

See Also

InnerShadowEffectiveData Class | Aspose.Slides.Effects Namespace


BlurRadius Property

Aspose.Slides Documentation

InnerShadowEffectiveData.BlurRadius Property

Blur radius.

[Visual Basic]
NotOverridable Public ReadOnly Property BlurRadius As Double _
Implements IInnerShadowEffectiveData.BlurRadius
[C#]
public double BlurRadius {get;}

Implements

IInnerShadowEffectiveData.BlurRadius

See Also

InnerShadowEffectiveData Class | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

InnerShadowEffectiveData.Direction Property

Direction of shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property Direction As Single _
Implements IInnerShadowEffectiveData.Direction
[C#]
public float Direction {get;}

Implements

IInnerShadowEffectiveData.Direction

See Also

InnerShadowEffectiveData Class | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

InnerShadowEffectiveData.Distance Property

Distance of shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property Distance As Double _
Implements IInnerShadowEffectiveData.Distance
[C#]
public double Distance {get;}

Implements

IInnerShadowEffectiveData.Distance

See Also

InnerShadowEffectiveData Class | Aspose.Slides.Effects Namespace


ShadowColor Property

Aspose.Slides Documentation

InnerShadowEffectiveData.ShadowColor Property

Color of shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property ShadowColor As Color _
Implements IInnerShadowEffectiveData.ShadowColor
[C#]
public Color ShadowColor {get;}

Implements

IInnerShadowEffectiveData.ShadowColor

See Also

InnerShadowEffectiveData Class | Aspose.Slides.Effects Namespace


IOuterShadow Interface

For a list of all members of this type, see IOuterShadow Members.

[Visual Basic]
Public Interface IOuterShadow
[C#]
public interface IOuterShadow

Types that implement IOuterShadow

Type | Description
OuterShadow | Represents a outer shadow effect.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IOuterShadow Members | Aspose.Slides.Effects Namespace


IOuterShadow Members

IOuterShadow overview

Public Instance Properties

BlurRadius
Direction
Distance
RectangleAlign
RotateShadowWithShape
ScaleHorizontal
ScaleVertical
ShadowColor
SkewHorizontal
SkewVertical

See Also

IOuterShadow Interface | Aspose.Slides.Effects Namespace


IOuterShadow Properties

The properties of the IOuterShadow interface are listed below. For a complete list of IOuterShadow interface members, see the IOuterShadow Members topic.

Public Instance Properties

BlurRadius
Direction
Distance
RectangleAlign
RotateShadowWithShape
ScaleHorizontal
ScaleVertical
ShadowColor
SkewHorizontal
SkewVertical

See Also

IOuterShadow Interface | Aspose.Slides.Effects Namespace


BlurRadius Property

Aspose.Slides Documentation

IOuterShadow.BlurRadius Property

[Visual Basic]
Property BlurRadius As Double
[C#]
double BlurRadius {get; set;}

See Also

IOuterShadow Interface | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

IOuterShadow.Direction Property

[Visual Basic]
Property Direction As Single
[C#]
float Direction {get; set;}

See Also

IOuterShadow Interface | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

IOuterShadow.Distance Property

[Visual Basic]
Property Distance As Double
[C#]
double Distance {get; set;}

See Also

IOuterShadow Interface | Aspose.Slides.Effects Namespace


RectangleAlign Property

Aspose.Slides Documentation

IOuterShadow.RectangleAlign Property

[Visual Basic]
Property RectangleAlign As RectangleAlignment
[C#]
RectangleAlignment RectangleAlign {get; set;}

See Also

IOuterShadow Interface | Aspose.Slides.Effects Namespace


RotateShadowWithShape Property

Aspose.Slides Documentation

IOuterShadow.RotateShadowWithShape Property

[Visual Basic]
Property RotateShadowWithShape As Boolean
[C#]
bool RotateShadowWithShape {get; set;}

See Also

IOuterShadow Interface | Aspose.Slides.Effects Namespace


ScaleHorizontal Property

Aspose.Slides Documentation

IOuterShadow.ScaleHorizontal Property

[Visual Basic]
Property ScaleHorizontal As Double
[C#]
double ScaleHorizontal {get; set;}

See Also

IOuterShadow Interface | Aspose.Slides.Effects Namespace


ScaleVertical Property

Aspose.Slides Documentation

IOuterShadow.ScaleVertical Property

[Visual Basic]
Property ScaleVertical As Double
[C#]
double ScaleVertical {get; set;}

See Also

IOuterShadow Interface | Aspose.Slides.Effects Namespace


ShadowColor Property

Aspose.Slides Documentation

IOuterShadow.ShadowColor Property

[Visual Basic]
Property ShadowColor As IColorFormat
[C#]
IColorFormat ShadowColor {get;}

See Also

IOuterShadow Interface | Aspose.Slides.Effects Namespace


SkewHorizontal Property

Aspose.Slides Documentation

IOuterShadow.SkewHorizontal Property

[Visual Basic]
Property SkewHorizontal As Double
[C#]
double SkewHorizontal {get; set;}

See Also

IOuterShadow Interface | Aspose.Slides.Effects Namespace


SkewVertical Property

Aspose.Slides Documentation

IOuterShadow.SkewVertical Property

[Visual Basic]
Property SkewVertical As Double
[C#]
double SkewVertical {get; set;}

See Also

IOuterShadow Interface | Aspose.Slides.Effects Namespace


IOuterShadowEffectiveData Interface

For a list of all members of this type, see IOuterShadowEffectiveData Members.

[Visual Basic]
Public Interface IOuterShadowEffectiveData
[C#]
public interface IOuterShadowEffectiveData

Types that implement IOuterShadowEffectiveData

Type | Description
OuterShadowEffectiveData | Immutable object which represents a outer shadow effect.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IOuterShadowEffectiveData Members | Aspose.Slides.Effects Namespace


IOuterShadowEffectiveData Members

IOuterShadowEffectiveData overview

Public Instance Properties

BlurRadius
Direction
Distance
RectangleAlign
RotateShadowWithShape
ScaleHorizontal
ScaleVertical
ShadowColor
SkewHorizontal
SkewVertical

See Also

IOuterShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


IOuterShadowEffectiveData Properties

The properties of the IOuterShadowEffectiveData interface are listed below. For a complete list of IOuterShadowEffectiveData interface members, see the IOuterShadowEffectiveData Members topic.

Public Instance Properties

BlurRadius
Direction
Distance
RectangleAlign
RotateShadowWithShape
ScaleHorizontal
ScaleVertical
ShadowColor
SkewHorizontal
SkewVertical

See Also

IOuterShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


BlurRadius Property

Aspose.Slides Documentation

IOuterShadowEffectiveData.BlurRadius Property

[Visual Basic]
Property BlurRadius As Double
[C#]
double BlurRadius {get;}

See Also

IOuterShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

IOuterShadowEffectiveData.Direction Property

[Visual Basic]
Property Direction As Single
[C#]
float Direction {get;}

See Also

IOuterShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

IOuterShadowEffectiveData.Distance Property

[Visual Basic]
Property Distance As Double
[C#]
double Distance {get;}

See Also

IOuterShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


RectangleAlign Property

Aspose.Slides Documentation

IOuterShadowEffectiveData.RectangleAlign Property

[Visual Basic]
Property RectangleAlign As RectangleAlignment
[C#]
RectangleAlignment RectangleAlign {get;}

See Also

IOuterShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


RotateShadowWithShape Property

Aspose.Slides Documentation

IOuterShadowEffectiveData.RotateShadowWithShape Property

[Visual Basic]
Property RotateShadowWithShape As Boolean
[C#]
bool RotateShadowWithShape {get;}

See Also

IOuterShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


ScaleHorizontal Property

Aspose.Slides Documentation

IOuterShadowEffectiveData.ScaleHorizontal Property

[Visual Basic]
Property ScaleHorizontal As Double
[C#]
double ScaleHorizontal {get;}

See Also

IOuterShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


ScaleVertical Property

Aspose.Slides Documentation

IOuterShadowEffectiveData.ScaleVertical Property

[Visual Basic]
Property ScaleVertical As Double
[C#]
double ScaleVertical {get;}

See Also

IOuterShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


ShadowColor Property

Aspose.Slides Documentation

IOuterShadowEffectiveData.ShadowColor Property

[Visual Basic]
Property ShadowColor As Color
[C#]
Color ShadowColor {get;}

See Also

IOuterShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


SkewHorizontal Property

Aspose.Slides Documentation

IOuterShadowEffectiveData.SkewHorizontal Property

[Visual Basic]
Property SkewHorizontal As Double
[C#]
double SkewHorizontal {get;}

See Also

IOuterShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


SkewVertical Property

Aspose.Slides Documentation

IOuterShadowEffectiveData.SkewVertical Property

[Visual Basic]
Property SkewVertical As Double
[C#]
double SkewVertical {get;}

See Also

IOuterShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


IPresetShadow Interface

For a list of all members of this type, see IPresetShadow Members.

[Visual Basic]
Public Interface IPresetShadow
[C#]
public interface IPresetShadow

Types that implement IPresetShadow

Type | Description
PresetShadow | Represents a preset shadow effect.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPresetShadow Members | Aspose.Slides.Effects Namespace


IPresetShadow Members

IPresetShadow overview

Public Instance Properties

Direction
Distance
Preset
ShadowColor

See Also

IPresetShadow Interface | Aspose.Slides.Effects Namespace


IPresetShadow Properties

The properties of the IPresetShadow interface are listed below. For a complete list of IPresetShadow interface members, see the IPresetShadow Members topic.

Public Instance Properties

Direction
Distance
Preset
ShadowColor

See Also

IPresetShadow Interface | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

IPresetShadow.Direction Property

[Visual Basic]
Property Direction As Single
[C#]
float Direction {get; set;}

See Also

IPresetShadow Interface | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

IPresetShadow.Distance Property

[Visual Basic]
Property Distance As Double
[C#]
double Distance {get; set;}

See Also

IPresetShadow Interface | Aspose.Slides.Effects Namespace


Preset Property

Aspose.Slides Documentation

IPresetShadow.Preset Property

[Visual Basic]
Property Preset As PresetShadowType
[C#]
PresetShadowType Preset {get; set;}

See Also

IPresetShadow Interface | Aspose.Slides.Effects Namespace


ShadowColor Property

Aspose.Slides Documentation

IPresetShadow.ShadowColor Property

[Visual Basic]
Property ShadowColor As IColorFormat
[C#]
IColorFormat ShadowColor {get;}

See Also

IPresetShadow Interface | Aspose.Slides.Effects Namespace


IPresetShadowEffectiveData Interface

For a list of all members of this type, see IPresetShadowEffectiveData Members.

[Visual Basic]
Public Interface IPresetShadowEffectiveData
[C#]
public interface IPresetShadowEffectiveData

Types that implement IPresetShadowEffectiveData

Type | Description
PresetShadowEffectiveData | Immutable object which represents a preset shadow effect.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPresetShadowEffectiveData Members | Aspose.Slides.Effects Namespace


IPresetShadowEffectiveData Members

IPresetShadowEffectiveData overview

Public Instance Properties

Direction
Distance
Preset
ShadowColor

See Also

IPresetShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


IPresetShadowEffectiveData Properties

The properties of the IPresetShadowEffectiveData interface are listed below. For a complete list of IPresetShadowEffectiveData interface members, see the IPresetShadowEffectiveData Members topic.

Public Instance Properties

Direction
Distance
Preset
ShadowColor

See Also

IPresetShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

IPresetShadowEffectiveData.Direction Property

[Visual Basic]
Property Direction As Single
[C#]
float Direction {get;}

See Also

IPresetShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

IPresetShadowEffectiveData.Distance Property

[Visual Basic]
Property Distance As Double
[C#]
double Distance {get;}

See Also

IPresetShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


Preset Property

Aspose.Slides Documentation

IPresetShadowEffectiveData.Preset Property

[Visual Basic]
Property Preset As PresetShadowType
[C#]
PresetShadowType Preset {get;}

See Also

IPresetShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


ShadowColor Property

Aspose.Slides Documentation

IPresetShadowEffectiveData.ShadowColor Property

[Visual Basic]
Property ShadowColor As Color
[C#]
Color ShadowColor {get;}

See Also

IPresetShadowEffectiveData Interface | Aspose.Slides.Effects Namespace


IReflection Interface

For a list of all members of this type, see IReflection Members.

[Visual Basic]
Public Interface IReflection
[C#]
public interface IReflection

Types that implement IReflection

Type | Description
Reflection | Represents a reflection effect.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IReflection Members | Aspose.Slides.Effects Namespace


IReflection Members

IReflection overview

Public Instance Properties

BlurRadius
Direction
Distance
EndPosAlpha
EndReflectionOpacity
FadeDirection
RectangleAlign
RotateShadowWithShape
ScaleHorizontal
ScaleVertical
SkewHorizontal
SkewVertical
StartPosAlpha
StartReflectionOpacity

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


IReflection Properties

The properties of the IReflection interface are listed below. For a complete list of IReflection interface members, see the IReflection Members topic.

Public Instance Properties

BlurRadius
Direction
Distance
EndPosAlpha
EndReflectionOpacity
FadeDirection
RectangleAlign
RotateShadowWithShape
ScaleHorizontal
ScaleVertical
SkewHorizontal
SkewVertical
StartPosAlpha
StartReflectionOpacity

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


BlurRadius Property

Aspose.Slides Documentation

IReflection.BlurRadius Property

[Visual Basic]
Property BlurRadius As Double
[C#]
double BlurRadius {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

IReflection.Direction Property

[Visual Basic]
Property Direction As Single
[C#]
float Direction {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

IReflection.Distance Property

[Visual Basic]
Property Distance As Double
[C#]
double Distance {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


EndPosAlpha Property

Aspose.Slides Documentation

IReflection.EndPosAlpha Property

[Visual Basic]
Property EndPosAlpha As Single
[C#]
float EndPosAlpha {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


EndReflectionOpacity Property

Aspose.Slides Documentation

IReflection.EndReflectionOpacity Property

[Visual Basic]
Property EndReflectionOpacity As Single
[C#]
float EndReflectionOpacity {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


FadeDirection Property

Aspose.Slides Documentation

IReflection.FadeDirection Property

[Visual Basic]
Property FadeDirection As Single
[C#]
float FadeDirection {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


RectangleAlign Property

Aspose.Slides Documentation

IReflection.RectangleAlign Property

[Visual Basic]
Property RectangleAlign As RectangleAlignment
[C#]
RectangleAlignment RectangleAlign {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


RotateShadowWithShape Property

Aspose.Slides Documentation

IReflection.RotateShadowWithShape Property

[Visual Basic]
Property RotateShadowWithShape As Boolean
[C#]
bool RotateShadowWithShape {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


ScaleHorizontal Property

Aspose.Slides Documentation

IReflection.ScaleHorizontal Property

[Visual Basic]
Property ScaleHorizontal As Double
[C#]
double ScaleHorizontal {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


ScaleVertical Property

Aspose.Slides Documentation

IReflection.ScaleVertical Property

[Visual Basic]
Property ScaleVertical As Double
[C#]
double ScaleVertical {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


SkewHorizontal Property

Aspose.Slides Documentation

IReflection.SkewHorizontal Property

[Visual Basic]
Property SkewHorizontal As Double
[C#]
double SkewHorizontal {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


SkewVertical Property

Aspose.Slides Documentation

IReflection.SkewVertical Property

[Visual Basic]
Property SkewVertical As Double
[C#]
double SkewVertical {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


StartPosAlpha Property

Aspose.Slides Documentation

IReflection.StartPosAlpha Property

[Visual Basic]
Property StartPosAlpha As Single
[C#]
float StartPosAlpha {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


StartReflectionOpacity Property

Aspose.Slides Documentation

IReflection.StartReflectionOpacity Property

[Visual Basic]
Property StartReflectionOpacity As Single
[C#]
float StartReflectionOpacity {get; set;}

See Also

IReflection Interface | Aspose.Slides.Effects Namespace


IReflectionEffectiveData Interface

For a list of all members of this type, see IReflectionEffectiveData Members.

[Visual Basic]
Public Interface IReflectionEffectiveData
[C#]
public interface IReflectionEffectiveData

Types that implement IReflectionEffectiveData

Type | Description
ReflectionEffectiveData | Immutable object which represents a reflection effect.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IReflectionEffectiveData Members | Aspose.Slides.Effects Namespace


IReflectionEffectiveData Members

IReflectionEffectiveData overview

Public Instance Properties

BlurRadius
Direction
Distance
EndPosAlpha
EndReflectionOpacity
FadeDirection
RectangleAlign
RotateShadowWithShape
ScaleHorizontal
ScaleVertical
SkewHorizontal
SkewVertical
StartPosAlpha
StartReflectionOpacity

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


IReflectionEffectiveData Properties

The properties of the IReflectionEffectiveData interface are listed below. For a complete list of IReflectionEffectiveData interface members, see the IReflectionEffectiveData Members topic.

Public Instance Properties

BlurRadius
Direction
Distance
EndPosAlpha
EndReflectionOpacity
FadeDirection
RectangleAlign
RotateShadowWithShape
ScaleHorizontal
ScaleVertical
SkewHorizontal
SkewVertical
StartPosAlpha
StartReflectionOpacity

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


BlurRadius Property

Aspose.Slides Documentation

IReflectionEffectiveData.BlurRadius Property

[Visual Basic]
Property BlurRadius As Double
[C#]
double BlurRadius {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

IReflectionEffectiveData.Direction Property

[Visual Basic]
Property Direction As Single
[C#]
float Direction {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

IReflectionEffectiveData.Distance Property

[Visual Basic]
Property Distance As Double
[C#]
double Distance {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


EndPosAlpha Property

Aspose.Slides Documentation

IReflectionEffectiveData.EndPosAlpha Property

[Visual Basic]
Property EndPosAlpha As Single
[C#]
float EndPosAlpha {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


EndReflectionOpacity Property

Aspose.Slides Documentation

IReflectionEffectiveData.EndReflectionOpacity Property

[Visual Basic]
Property EndReflectionOpacity As Single
[C#]
float EndReflectionOpacity {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


FadeDirection Property

Aspose.Slides Documentation

IReflectionEffectiveData.FadeDirection Property

[Visual Basic]
Property FadeDirection As Single
[C#]
float FadeDirection {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


RectangleAlign Property

Aspose.Slides Documentation

IReflectionEffectiveData.RectangleAlign Property

[Visual Basic]
Property RectangleAlign As RectangleAlignment
[C#]
RectangleAlignment RectangleAlign {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


RotateShadowWithShape Property

Aspose.Slides Documentation

IReflectionEffectiveData.RotateShadowWithShape Property

[Visual Basic]
Property RotateShadowWithShape As Boolean
[C#]
bool RotateShadowWithShape {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


ScaleHorizontal Property

Aspose.Slides Documentation

IReflectionEffectiveData.ScaleHorizontal Property

[Visual Basic]
Property ScaleHorizontal As Double
[C#]
double ScaleHorizontal {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


ScaleVertical Property

Aspose.Slides Documentation

IReflectionEffectiveData.ScaleVertical Property

[Visual Basic]
Property ScaleVertical As Double
[C#]
double ScaleVertical {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


SkewHorizontal Property

Aspose.Slides Documentation

IReflectionEffectiveData.SkewHorizontal Property

[Visual Basic]
Property SkewHorizontal As Double
[C#]
double SkewHorizontal {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


SkewVertical Property

Aspose.Slides Documentation

IReflectionEffectiveData.SkewVertical Property

[Visual Basic]
Property SkewVertical As Double
[C#]
double SkewVertical {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


StartPosAlpha Property

Aspose.Slides Documentation

IReflectionEffectiveData.StartPosAlpha Property

[Visual Basic]
Property StartPosAlpha As Single
[C#]
float StartPosAlpha {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


StartReflectionOpacity Property

Aspose.Slides Documentation

IReflectionEffectiveData.StartReflectionOpacity Property

[Visual Basic]
Property StartReflectionOpacity As Single
[C#]
float StartReflectionOpacity {get;}

See Also

IReflectionEffectiveData Interface | Aspose.Slides.Effects Namespace


ISoftEdge Interface

For a list of all members of this type, see ISoftEdge Members.

[Visual Basic]
Public Interface ISoftEdge
[C#]
public interface ISoftEdge

Types that implement ISoftEdge

Type | Description
SoftEdge | Represents a soft edge effect. The edges of the shape are blurred, while the fill is not affected.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISoftEdge Members | Aspose.Slides.Effects Namespace


ISoftEdge Members

ISoftEdge overview

Public Instance Properties

Radius

See Also

ISoftEdge Interface | Aspose.Slides.Effects Namespace


ISoftEdge Properties

The properties of the ISoftEdge interface are listed below. For a complete list of ISoftEdge interface members, see the ISoftEdge Members topic.

Public Instance Properties

Radius

See Also

ISoftEdge Interface | Aspose.Slides.Effects Namespace


Radius Property

Aspose.Slides Documentation

ISoftEdge.Radius Property

[Visual Basic]
Property Radius As Double
[C#]
double Radius {get; set;}

See Also

ISoftEdge Interface | Aspose.Slides.Effects Namespace


ISoftEdgeEffectiveData Interface

For a list of all members of this type, see ISoftEdgeEffectiveData Members.

[Visual Basic]
Public Interface ISoftEdgeEffectiveData
[C#]
public interface ISoftEdgeEffectiveData

Types that implement ISoftEdgeEffectiveData

Type | Description
SoftEdgeEffectiveData | Immutable object which represents a soft edge effect. The edges of the shape are blurred, while the fill is not affected.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISoftEdgeEffectiveData Members | Aspose.Slides.Effects Namespace


ISoftEdgeEffectiveData Members

ISoftEdgeEffectiveData overview

Public Instance Properties

Radius

See Also

ISoftEdgeEffectiveData Interface | Aspose.Slides.Effects Namespace


ISoftEdgeEffectiveData Properties

The properties of the ISoftEdgeEffectiveData interface are listed below. For a complete list of ISoftEdgeEffectiveData interface members, see the ISoftEdgeEffectiveData Members topic.

Public Instance Properties

Radius

See Also

ISoftEdgeEffectiveData Interface | Aspose.Slides.Effects Namespace


Radius Property

Aspose.Slides Documentation

ISoftEdgeEffectiveData.Radius Property

[Visual Basic]
Property Radius As Double
[C#]
double Radius {get;}

See Also

ISoftEdgeEffectiveData Interface | Aspose.Slides.Effects Namespace


ITint Interface

For a list of all members of this type, see ITint Members.

[Visual Basic]
Public Interface ITint
Implements IImageTransformOperation, ISlideComponent, IPresentationComponent
[C#]
public interface ITint : IImageTransformOperation, ISlideComponent, IPresentationComponent

Types that implement ITint

Type | Description
Tint | Represents a Tint effect. Shifts effect color values towards/away from hue by the specified amount.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITint Members | Aspose.Slides.Effects Namespace


ITint Members

ITint overview

Public Instance Properties

AsIImageTransformOperation

See Also

ITint Interface | Aspose.Slides.Effects Namespace


ITint Properties

The properties of the ITint interface are listed below. For a complete list of ITint interface members, see the ITint Members topic.

Public Instance Properties

AsIImageTransformOperation

See Also

ITint Interface | Aspose.Slides.Effects Namespace


AsIImageTransformOperation Property

Aspose.Slides Documentation

ITint.AsIImageTransformOperation Property

[Visual Basic]
Property AsIImageTransformOperation As IImageTransformOperation
[C#]
IImageTransformOperation AsIImageTransformOperation {get;}

See Also

ITint Interface | Aspose.Slides.Effects Namespace


ITintEffectiveData Interface

For a list of all members of this type, see ITintEffectiveData Members.

[Visual Basic]
Public Interface ITintEffectiveData
[C#]
public interface ITintEffectiveData

Types that implement ITintEffectiveData

Type | Description
TintEffectiveData | Immutable object which represents a Tint effect. Shifts effect color values towards/away from hue by the specified amount.

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITintEffectiveData Members | Aspose.Slides.Effects Namespace


ITintEffectiveData Members

ITintEffectiveData overview

Public Instance Properties

Amount
Hue

See Also

ITintEffectiveData Interface | Aspose.Slides.Effects Namespace


ITintEffectiveData Properties

The properties of the ITintEffectiveData interface are listed below. For a complete list of ITintEffectiveData interface members, see the ITintEffectiveData Members topic.

Public Instance Properties

Amount
Hue

See Also

ITintEffectiveData Interface | Aspose.Slides.Effects Namespace


Amount Property

Aspose.Slides Documentation

ITintEffectiveData.Amount Property

[Visual Basic]
Property Amount As Single
[C#]
float Amount {get;}

See Also

ITintEffectiveData Interface | Aspose.Slides.Effects Namespace


Hue Property

Aspose.Slides Documentation

ITintEffectiveData.Hue Property

[Visual Basic]
Property Hue As Single
[C#]
float Hue {get;}

See Also

ITintEffectiveData Interface | Aspose.Slides.Effects Namespace


Luminance Class

Represents a Luminance effect. Brightness linearly shifts all colors closer to white or black. Contrast scales all colors to be either closer or further apart.

For a list of all members of this type, see Luminance Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.Luminance

[Visual Basic]
Public Class Luminance
Inherits ImageTransformOperation
Implements ILuminance
[C#]
public class Luminance : ImageTransformOperation, ILuminance

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Luminance Members | Aspose.Slides.Effects Namespace


Luminance Members

Luminance overview

Public Instance Constructors

Luminance Constructor Luminance effect constructor.

See Also

Luminance Class | Aspose.Slides.Effects Namespace


Luminance Constructor

Luminance effect constructor.

[Visual Basic]
Overloads Public Sub New( _
ByVal brightness As Single, _
ByVal contrast As Single _
)
[C#]
public Luminance(
float brightness,
float contrast
);

Parameters

brightness
The percent to change the brightness.
contrast
The percent to change the contrast.

See Also

Luminance Class | Aspose.Slides.Effects Namespace


LuminanceEffectiveData Class

Represents a Luminance effect. Brightness linearly shifts all colors closer to white or black. Contrast scales all colors to be either closer or further apart.

For a list of all members of this type, see LuminanceEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.LuminanceEffectiveData

[Visual Basic]
Public Class LuminanceEffectiveData
Inherits EffectEffectiveData
Implements ILuminanceEffectiveData
[C#]
public class LuminanceEffectiveData : EffectEffectiveData, ILuminanceEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LuminanceEffectiveData Members | Aspose.Slides.Effects Namespace


LuminanceEffectiveData Members

LuminanceEffectiveData overview

Public Instance Properties

Brightness | Brightness.
Contrast | Contrast.

See Also

LuminanceEffectiveData Class | Aspose.Slides.Effects Namespace


LuminanceEffectiveData Properties

The properties of the LuminanceEffectiveData class are listed below. For a complete list of LuminanceEffectiveData class members, see the LuminanceEffectiveData Members topic.

Public Instance Properties

Brightness | Brightness.
Contrast | Contrast.

See Also

LuminanceEffectiveData Class | Aspose.Slides.Effects Namespace


Brightness Property

Aspose.Slides Documentation

LuminanceEffectiveData.Brightness Property

Brightness.

[Visual Basic]
NotOverridable Public ReadOnly Property Brightness As Single _
Implements ILuminanceEffectiveData.Brightness
[C#]
public float Brightness {get;}

Implements

ILuminanceEffectiveData.Brightness

See Also

LuminanceEffectiveData Class | Aspose.Slides.Effects Namespace


Contrast Property

Aspose.Slides Documentation

LuminanceEffectiveData.Contrast Property

Contrast.

[Visual Basic]
NotOverridable Public ReadOnly Property Contrast As Single _
Implements ILuminanceEffectiveData.Contrast
[C#]
public float Contrast {get;}

Implements

ILuminanceEffectiveData.Contrast

See Also

LuminanceEffectiveData Class | Aspose.Slides.Effects Namespace


OuterShadow Class

Represents a outer shadow effect.

For a list of all members of this type, see OuterShadow Members.

System.Object
Aspose.Slides.Effects.OuterShadow

[Visual Basic]
Public Class OuterShadow
Implements IOuterShadow
[C#]
public class OuterShadow : IOuterShadow

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

OuterShadow Members | Aspose.Slides.Effects Namespace


OuterShadow Members

OuterShadow overview

Public Instance Constructors

OuterShadow Constructor Default constructor.

Public Instance Properties

BlurRadius | Blur radius.
Direction | Direction of shadow.
Distance | Distance of shadow.
RectangleAlign | Rectangle alignment.
RotateShadowWithShape | Specifies whether the shadow should rotate with the shape if the shape is rotated.
ScaleHorizontal | Specifies the horizontal scaling factor, negative scaling causes a flip.
ScaleVertical | Specifies the vertical scaling factor, negative scaling causes a flip.
ShadowColor | Color of shadow.
SkewHorizontal | Specifies the horizontal skew angle (in degrees).
SkewVertical | Specifies the vertical skew angle (in degrees).

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


OuterShadow Constructor

Default constructor.

[Visual Basic]
Public Sub New()
[C#]
public OuterShadow();

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


OuterShadow Properties

The properties of the OuterShadow class are listed below. For a complete list of OuterShadow class members, see the OuterShadow Members topic.

Public Instance Properties

BlurRadius | Blur radius.
Direction | Direction of shadow.
Distance | Distance of shadow.
RectangleAlign | Rectangle alignment.
RotateShadowWithShape | Specifies whether the shadow should rotate with the shape if the shape is rotated.
ScaleHorizontal | Specifies the horizontal scaling factor, negative scaling causes a flip.
ScaleVertical | Specifies the vertical scaling factor, negative scaling causes a flip.
ShadowColor | Color of shadow.
SkewHorizontal | Specifies the horizontal skew angle (in degrees).
SkewVertical | Specifies the vertical skew angle (in degrees).

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


BlurRadius Property

Aspose.Slides Documentation

OuterShadow.BlurRadius Property

Blur radius.

[Visual Basic]
NotOverridable Public Property BlurRadius As Double _
Implements IOuterShadow.BlurRadius
[C#]
public double BlurRadius {get; set;}

Implements

IOuterShadow.BlurRadius

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

OuterShadow.Direction Property

Direction of shadow.

[Visual Basic]
NotOverridable Public Property Direction As Single _
Implements IOuterShadow.Direction
[C#]
public float Direction {get; set;}

Implements

IOuterShadow.Direction

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

OuterShadow.Distance Property

Distance of shadow.

[Visual Basic]
NotOverridable Public Property Distance As Double _
Implements IOuterShadow.Distance
[C#]
public double Distance {get; set;}

Implements

IOuterShadow.Distance

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


RectangleAlign Property

Aspose.Slides Documentation

OuterShadow.RectangleAlign Property

Rectangle alignment.

[Visual Basic]
NotOverridable Public Property RectangleAlign As RectangleAlignment _
Implements IOuterShadow.RectangleAlign
[C#]
public RectangleAlignment RectangleAlign {get; set;}

Implements

IOuterShadow.RectangleAlign

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


RotateShadowWithShape Property

Aspose.Slides Documentation

OuterShadow.RotateShadowWithShape Property

Specifies whether the shadow should rotate with the shape if the shape is rotated.

[Visual Basic]
NotOverridable Public Property RotateShadowWithShape As Boolean _
Implements IOuterShadow.RotateShadowWithShape
[C#]
public bool RotateShadowWithShape {get; set;}

Implements

IOuterShadow.RotateShadowWithShape

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


ScaleHorizontal Property

Aspose.Slides Documentation

OuterShadow.ScaleHorizontal Property

Specifies the horizontal scaling factor, negative scaling causes a flip.

[Visual Basic]
NotOverridable Public Property ScaleHorizontal As Double _
Implements IOuterShadow.ScaleHorizontal
[C#]
public double ScaleHorizontal {get; set;}

Implements

IOuterShadow.ScaleHorizontal

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


ScaleVertical Property

Aspose.Slides Documentation

OuterShadow.ScaleVertical Property

Specifies the vertical scaling factor, negative scaling causes a flip.

[Visual Basic]
NotOverridable Public Property ScaleVertical As Double _
Implements IOuterShadow.ScaleVertical
[C#]
public double ScaleVertical {get; set;}

Implements

IOuterShadow.ScaleVertical

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


ShadowColor Property

Aspose.Slides Documentation

OuterShadow.ShadowColor Property

Color of shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property ShadowColor As IColorFormat _
Implements IOuterShadow.ShadowColor
[C#]
public IColorFormat ShadowColor {get;}

Implements

IOuterShadow.ShadowColor

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


SkewHorizontal Property

Aspose.Slides Documentation

OuterShadow.SkewHorizontal Property

Specifies the horizontal skew angle (in degrees).

[Visual Basic]
NotOverridable Public Property SkewHorizontal As Double _
Implements IOuterShadow.SkewHorizontal
[C#]
public double SkewHorizontal {get; set;}

Implements

IOuterShadow.SkewHorizontal

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


SkewVertical Property

Aspose.Slides Documentation

OuterShadow.SkewVertical Property

Specifies the vertical skew angle (in degrees).

[Visual Basic]
NotOverridable Public Property SkewVertical As Double _
Implements IOuterShadow.SkewVertical
[C#]
public double SkewVertical {get; set;}

Implements

IOuterShadow.SkewVertical

See Also

OuterShadow Class | Aspose.Slides.Effects Namespace


OuterShadowEffectiveData Class

Immutable object which represents a outer shadow effect.

For a list of all members of this type, see OuterShadowEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.OuterShadowEffectiveData

[Visual Basic]
Public Class OuterShadowEffectiveData
Inherits EffectEffectiveData
Implements IOuterShadowEffectiveData
[C#]
public class OuterShadowEffectiveData : EffectEffectiveData, IOuterShadowEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

OuterShadowEffectiveData Members | Aspose.Slides.Effects Namespace


OuterShadowEffectiveData Members

OuterShadowEffectiveData overview

Public Instance Properties

BlurRadius | Blur radius.
Direction | Direction of shadow.
Distance | Distance of shadow.
RectangleAlign | Rectangle alignment.
RotateShadowWithShape | Specifies whether the shadow should rotate with the shape if the shape is rotated.
ScaleHorizontal | Specifies the horizontal scaling factor, negative scaling causes a flip.
ScaleVertical | Specifies the vertical scaling factor, negative scaling causes a flip.
ShadowColor | Color of shadow.
SkewHorizontal | Specifies the horizontal skew angle.
SkewVertical | Specifies the vertical skew angle.

See Also

OuterShadowEffectiveData Class | Aspose.Slides.Effects Namespace


OuterShadowEffectiveData Properties

The properties of the OuterShadowEffectiveData class are listed below. For a complete list of OuterShadowEffectiveData class members, see the OuterShadowEffectiveData Members topic.

Public Instance Properties

BlurRadius | Blur radius.
Direction | Direction of shadow.
Distance | Distance of shadow.
RectangleAlign | Rectangle alignment.
RotateShadowWithShape | Specifies whether the shadow should rotate with the shape if the shape is rotated.
ScaleHorizontal | Specifies the horizontal scaling factor, negative scaling causes a flip.
ScaleVertical | Specifies the vertical scaling factor, negative scaling causes a flip.
ShadowColor | Color of shadow.
SkewHorizontal | Specifies the horizontal skew angle.
SkewVertical | Specifies the vertical skew angle.

See Also

OuterShadowEffectiveData Class | Aspose.Slides.Effects Namespace


BlurRadius Property

Aspose.Slides Documentation

OuterShadowEffectiveData.BlurRadius Property

Blur radius.

[Visual Basic]
NotOverridable Public ReadOnly Property BlurRadius As Double _
Implements IOuterShadowEffectiveData.BlurRadius
[C#]
public double BlurRadius {get;}

Implements

IOuterShadowEffectiveData.BlurRadius

See Also

OuterShadowEffectiveData Class | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

OuterShadowEffectiveData.Direction Property

Direction of shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property Direction As Single _
Implements IOuterShadowEffectiveData.Direction
[C#]
public float Direction {get;}

Implements

IOuterShadowEffectiveData.Direction

See Also

OuterShadowEffectiveData Class | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

OuterShadowEffectiveData.Distance Property

Distance of shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property Distance As Double _
Implements IOuterShadowEffectiveData.Distance
[C#]
public double Distance {get;}

Implements

IOuterShadowEffectiveData.Distance

See Also

OuterShadowEffectiveData Class | Aspose.Slides.Effects Namespace


RectangleAlign Property

Aspose.Slides Documentation

OuterShadowEffectiveData.RectangleAlign Property

Rectangle alignment.

[Visual Basic]
NotOverridable Public ReadOnly Property RectangleAlign As RectangleAlignment _
Implements IOuterShadowEffectiveData.RectangleAlign
[C#]
public RectangleAlignment RectangleAlign {get;}

Implements

IOuterShadowEffectiveData.RectangleAlign

See Also

OuterShadowEffectiveData Class | Aspose.Slides.Effects Namespace


RotateShadowWithShape Property

Aspose.Slides Documentation

OuterShadowEffectiveData.RotateShadowWithShape Property

Specifies whether the shadow should rotate with the shape if the shape is rotated.

[Visual Basic]
NotOverridable Public ReadOnly Property RotateShadowWithShape As Boolean _
Implements IOuterShadowEffectiveData.RotateShadowWithShape
[C#]
public bool RotateShadowWithShape {get;}

Implements

IOuterShadowEffectiveData.RotateShadowWithShape

See Also

OuterShadowEffectiveData Class | Aspose.Slides.Effects Namespace


ScaleHorizontal Property

Aspose.Slides Documentation

OuterShadowEffectiveData.ScaleHorizontal Property

Specifies the horizontal scaling factor, negative scaling causes a flip.

[Visual Basic]
NotOverridable Public ReadOnly Property ScaleHorizontal As Double _
Implements IOuterShadowEffectiveData.ScaleHorizontal
[C#]
public double ScaleHorizontal {get;}

Implements

IOuterShadowEffectiveData.ScaleHorizontal

See Also

OuterShadowEffectiveData Class | Aspose.Slides.Effects Namespace


ScaleVertical Property

Aspose.Slides Documentation

OuterShadowEffectiveData.ScaleVertical Property

Specifies the vertical scaling factor, negative scaling causes a flip.

[Visual Basic]
NotOverridable Public ReadOnly Property ScaleVertical As Double _
Implements IOuterShadowEffectiveData.ScaleVertical
[C#]
public double ScaleVertical {get;}

Implements

IOuterShadowEffectiveData.ScaleVertical

See Also

OuterShadowEffectiveData Class | Aspose.Slides.Effects Namespace


ShadowColor Property

Aspose.Slides Documentation

OuterShadowEffectiveData.ShadowColor Property

Color of shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property ShadowColor As Color _
Implements IOuterShadowEffectiveData.ShadowColor
[C#]
public Color ShadowColor {get;}

Implements

IOuterShadowEffectiveData.ShadowColor

See Also

OuterShadowEffectiveData Class | Aspose.Slides.Effects Namespace


SkewHorizontal Property

Aspose.Slides Documentation

OuterShadowEffectiveData.SkewHorizontal Property

Specifies the horizontal skew angle.

[Visual Basic]
NotOverridable Public ReadOnly Property SkewHorizontal As Double _
Implements IOuterShadowEffectiveData.SkewHorizontal
[C#]
public double SkewHorizontal {get;}

Implements

IOuterShadowEffectiveData.SkewHorizontal

See Also

OuterShadowEffectiveData Class | Aspose.Slides.Effects Namespace


SkewVertical Property

Aspose.Slides Documentation

OuterShadowEffectiveData.SkewVertical Property

Specifies the vertical skew angle.

[Visual Basic]
NotOverridable Public ReadOnly Property SkewVertical As Double _
Implements IOuterShadowEffectiveData.SkewVertical
[C#]
public double SkewVertical {get;}

Implements

IOuterShadowEffectiveData.SkewVertical

See Also

OuterShadowEffectiveData Class | Aspose.Slides.Effects Namespace


PresetShadow Class

Represents a preset shadow effect.

For a list of all members of this type, see PresetShadow Members.

System.Object
Aspose.Slides.Effects.PresetShadow

[Visual Basic]
Public Class PresetShadow
Implements IPresetShadow
[C#]
public class PresetShadow : IPresetShadow

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PresetShadow Members | Aspose.Slides.Effects Namespace


PresetShadow Members

PresetShadow overview

Public Instance Constructors

PresetShadow Constructor Creates a new instance of the PresetShadow class.

Public Instance Properties

Direction | Direction of shadow.
Distance | Distance of shadow.
Preset | Preset.
ShadowColor | Color of shadow.

See Also

PresetShadow Class | Aspose.Slides.Effects Namespace


PresetShadow Constructor

Creates a new instance of the PresetShadow class.

[Visual Basic]
Public Sub New()
[C#]
public PresetShadow();

See Also

PresetShadow Class | Aspose.Slides.Effects Namespace


PresetShadow Properties

The properties of the PresetShadow class are listed below. For a complete list of PresetShadow class members, see the PresetShadow Members topic.

Public Instance Properties

Direction | Direction of shadow.
Distance | Distance of shadow.
Preset | Preset.
ShadowColor | Color of shadow.

See Also

PresetShadow Class | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

PresetShadow.Direction Property

Direction of shadow.

[Visual Basic]
NotOverridable Public Property Direction As Single _
Implements IPresetShadow.Direction
[C#]
public float Direction {get; set;}

Implements

IPresetShadow.Direction

See Also

PresetShadow Class | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

PresetShadow.Distance Property

Distance of shadow.

[Visual Basic]
NotOverridable Public Property Distance As Double _
Implements IPresetShadow.Distance
[C#]
public double Distance {get; set;}

Implements

IPresetShadow.Distance

See Also

PresetShadow Class | Aspose.Slides.Effects Namespace


Preset Property

Aspose.Slides Documentation

PresetShadow.Preset Property

Preset.

[Visual Basic]
NotOverridable Public Property Preset As PresetShadowType _
Implements IPresetShadow.Preset
[C#]
public PresetShadowType Preset {get; set;}

Implements

IPresetShadow.Preset

See Also

PresetShadow Class | Aspose.Slides.Effects Namespace


ShadowColor Property

Aspose.Slides Documentation

PresetShadow.ShadowColor Property

Color of shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property ShadowColor As IColorFormat _
Implements IPresetShadow.ShadowColor
[C#]
public IColorFormat ShadowColor {get;}

Implements

IPresetShadow.ShadowColor

See Also

PresetShadow Class | Aspose.Slides.Effects Namespace


PresetShadowEffectiveData Class

Immutable object which represents a preset shadow effect.

For a list of all members of this type, see PresetShadowEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.PresetShadowEffectiveData

[Visual Basic]
Public Class PresetShadowEffectiveData
Inherits EffectEffectiveData
Implements IPresetShadowEffectiveData
[C#]
public class PresetShadowEffectiveData : EffectEffectiveData, IPresetShadowEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PresetShadowEffectiveData Members | Aspose.Slides.Effects Namespace


PresetShadowEffectiveData Members

PresetShadowEffectiveData overview

Public Instance Properties

Direction | Direction of shadow.
Distance | Distance of shadow.
Preset | Preset.
ShadowColor | Color of shadow.

See Also

PresetShadowEffectiveData Class | Aspose.Slides.Effects Namespace


PresetShadowEffectiveData Properties

The properties of the PresetShadowEffectiveData class are listed below. For a complete list of PresetShadowEffectiveData class members, see the PresetShadowEffectiveData Members topic.

Public Instance Properties

Direction | Direction of shadow.
Distance | Distance of shadow.
Preset | Preset.
ShadowColor | Color of shadow.

See Also

PresetShadowEffectiveData Class | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

PresetShadowEffectiveData.Direction Property

Direction of shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property Direction As Single _
Implements IPresetShadowEffectiveData.Direction
[C#]
public float Direction {get;}

Implements

IPresetShadowEffectiveData.Direction

See Also

PresetShadowEffectiveData Class | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

PresetShadowEffectiveData.Distance Property

Distance of shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property Distance As Double _
Implements IPresetShadowEffectiveData.Distance
[C#]
public double Distance {get;}

Implements

IPresetShadowEffectiveData.Distance

See Also

PresetShadowEffectiveData Class | Aspose.Slides.Effects Namespace


Preset Property

Aspose.Slides Documentation

PresetShadowEffectiveData.Preset Property

Preset.

[Visual Basic]
NotOverridable Public ReadOnly Property Preset As PresetShadowType _
Implements IPresetShadowEffectiveData.Preset
[C#]
public PresetShadowType Preset {get;}

Implements

IPresetShadowEffectiveData.Preset

See Also

PresetShadowEffectiveData Class | Aspose.Slides.Effects Namespace


ShadowColor Property

Aspose.Slides Documentation

PresetShadowEffectiveData.ShadowColor Property

Color of shadow.

[Visual Basic]
NotOverridable Public ReadOnly Property ShadowColor As Color _
Implements IPresetShadowEffectiveData.ShadowColor
[C#]
public Color ShadowColor {get;}

Implements

IPresetShadowEffectiveData.ShadowColor

See Also

PresetShadowEffectiveData Class | Aspose.Slides.Effects Namespace


Reflection Class

Represents a reflection effect.

For a list of all members of this type, see Reflection Members.

System.Object
Aspose.Slides.Effects.Reflection

[Visual Basic]
Public Class Reflection
Implements IReflection
[C#]
public class Reflection : IReflection

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Reflection Members | Aspose.Slides.Effects Namespace


Reflection Members

Reflection overview

Public Instance Constructors

Reflection Constructor Creates a new instance of Reflection effect class.

Public Instance Properties

BlurRadius | Blur radius.
Direction | Direction of reflection.
Distance | Distance of reflection.
EndPosAlpha | Specifies the end position (along the alpha gradient ramp) of the end alpha value (percents).
EndReflectionOpacity | End reflection opacity. (percents).
FadeDirection | Specifies the direction to offset the reflection. (angle).
RectangleAlign | Rectangle alignment.
RotateShadowWithShape | Specifies whether the reflection should rotate with the shape if the shape is rotated.
ScaleH | Obsolete. Specifies the horizontal scaling factor, negative scaling causes a flip. (percents)
ScaleHorizontal | Specifies the horizontal scaling factor, negative scaling causes a flip. (percents)
ScaleV | Obsolete. Specifies the vertical scaling factor, negative scaling causes a flip. (percents)
ScaleVertical | Specifies the vertical scaling factor, negative scaling causes a flip. (percents)
SkewH | Obsolete. Specifies the horizontal skew angle.
SkewHorizontal | Specifies the horizontal skew angle.
SkewV | Obsolete. Specifies the vertical skew angle.
SkewVertical | Specifies the vertical skew angle.
StartPosAlpha | Specifies the start position (along the alpha gradient ramp) of the start alpha value (percents).
StartReflectionOpacity | Starting reflection opacity. (percents).

See Also

Reflection Class | Aspose.Slides.Effects Namespace


Reflection Constructor

Creates a new instance of Reflection effect class.

[Visual Basic]
Public Sub New()
[C#]
public Reflection();

See Also

Reflection Class | Aspose.Slides.Effects Namespace


Reflection Properties

The properties of the Reflection class are listed below. For a complete list of Reflection class members, see the Reflection Members topic.

Public Instance Properties

BlurRadius | Blur radius.
Direction | Direction of reflection.
Distance | Distance of reflection.
EndPosAlpha | Specifies the end position (along the alpha gradient ramp) of the end alpha value (percents).
EndReflectionOpacity | End reflection opacity. (percents).
FadeDirection | Specifies the direction to offset the reflection. (angle).
RectangleAlign | Rectangle alignment.
RotateShadowWithShape | Specifies whether the reflection should rotate with the shape if the shape is rotated.
ScaleH | Obsolete. Specifies the horizontal scaling factor, negative scaling causes a flip. (percents)
ScaleHorizontal | Specifies the horizontal scaling factor, negative scaling causes a flip. (percents)
ScaleV | Obsolete. Specifies the vertical scaling factor, negative scaling causes a flip. (percents)
ScaleVertical | Specifies the vertical scaling factor, negative scaling causes a flip. (percents)
SkewH | Obsolete. Specifies the horizontal skew angle.
SkewHorizontal | Specifies the horizontal skew angle.
SkewV | Obsolete. Specifies the vertical skew angle.
SkewVertical | Specifies the vertical skew angle.
StartPosAlpha | Specifies the start position (along the alpha gradient ramp) of the start alpha value (percents).
StartReflectionOpacity | Starting reflection opacity. (percents).

See Also

Reflection Class | Aspose.Slides.Effects Namespace


BlurRadius Property

Aspose.Slides Documentation

Reflection.BlurRadius Property

Blur radius.

[Visual Basic]
NotOverridable Public Property BlurRadius As Double _
Implements IReflection.BlurRadius
[C#]
public double BlurRadius {get; set;}

Implements

IReflection.BlurRadius

See Also

Reflection Class | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

Reflection.Direction Property

Direction of reflection.

[Visual Basic]
NotOverridable Public Property Direction As Single _
Implements IReflection.Direction
[C#]
public float Direction {get; set;}

Implements

IReflection.Direction

See Also

Reflection Class | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

Reflection.Distance Property

Distance of reflection.

[Visual Basic]
NotOverridable Public Property Distance As Double _
Implements IReflection.Distance
[C#]
public double Distance {get; set;}

Implements

IReflection.Distance

See Also

Reflection Class | Aspose.Slides.Effects Namespace


EndPosAlpha Property

Aspose.Slides Documentation

Reflection.EndPosAlpha Property

Specifies the end position (along the alpha gradient ramp) of the end alpha value (percents).

[Visual Basic]
NotOverridable Public Property EndPosAlpha As Single _
Implements IReflection.EndPosAlpha
[C#]
public float EndPosAlpha {get; set;}

Implements

IReflection.EndPosAlpha

See Also

Reflection Class | Aspose.Slides.Effects Namespace


EndReflectionOpacity Property

Aspose.Slides Documentation

Reflection.EndReflectionOpacity Property

End reflection opacity. (percents).

[Visual Basic]
NotOverridable Public Property EndReflectionOpacity As Single _
Implements IReflection.EndReflectionOpacity
[C#]
public float EndReflectionOpacity {get; set;}

Implements

IReflection.EndReflectionOpacity

See Also

Reflection Class | Aspose.Slides.Effects Namespace


FadeDirection Property

Aspose.Slides Documentation

Reflection.FadeDirection Property

Specifies the direction to offset the reflection. (angle).

[Visual Basic]
NotOverridable Public Property FadeDirection As Single _
Implements IReflection.FadeDirection
[C#]
public float FadeDirection {get; set;}

Implements

IReflection.FadeDirection

See Also

Reflection Class | Aspose.Slides.Effects Namespace


RectangleAlign Property

Aspose.Slides Documentation

Reflection.RectangleAlign Property

Rectangle alignment.

[Visual Basic]
NotOverridable Public Property RectangleAlign As RectangleAlignment _
Implements IReflection.RectangleAlign
[C#]
public RectangleAlignment RectangleAlign {get; set;}

Implements

IReflection.RectangleAlign

See Also

Reflection Class | Aspose.Slides.Effects Namespace


RotateShadowWithShape Property

Aspose.Slides Documentation

Reflection.RotateShadowWithShape Property

Specifies whether the reflection should rotate with the shape if the shape is rotated.

[Visual Basic]
NotOverridable Public Property RotateShadowWithShape As Boolean _
Implements IReflection.RotateShadowWithShape
[C#]
public bool RotateShadowWithShape {get; set;}

Implements

IReflection.RotateShadowWithShape

See Also

Reflection Class | Aspose.Slides.Effects Namespace


ScaleH Property

Aspose.Slides Documentation

Reflection.ScaleH Property

NOTE: This property is now obsolete.

Use ScaleHorizontal property instead. Property will be removed after 01.09.2013.

Specifies the horizontal scaling factor, negative scaling causes a flip. (percents)

[Visual Basic]
Public Property ScaleH As Double
[C#]
public double ScaleH {get; set;}

See Also

Reflection Class | Aspose.Slides.Effects Namespace


ScaleHorizontal Property

Aspose.Slides Documentation

Reflection.ScaleHorizontal Property

Specifies the horizontal scaling factor, negative scaling causes a flip. (percents)

[Visual Basic]
NotOverridable Public Property ScaleHorizontal As Double _
Implements IReflection.ScaleHorizontal
[C#]
public double ScaleHorizontal {get; set;}

Implements

IReflection.ScaleHorizontal

See Also

Reflection Class | Aspose.Slides.Effects Namespace


ScaleV Property

Aspose.Slides Documentation

Reflection.ScaleV Property

NOTE: This property is now obsolete.

Use ScaleVertical property instead. Property will be removed after 01.09.2013.

Specifies the vertical scaling factor, negative scaling causes a flip. (percents)

[Visual Basic]
Public Property ScaleV As Double
[C#]
public double ScaleV {get; set;}

See Also

Reflection Class | Aspose.Slides.Effects Namespace


ScaleVertical Property

Aspose.Slides Documentation

Reflection.ScaleVertical Property

Specifies the vertical scaling factor, negative scaling causes a flip. (percents)

[Visual Basic]
NotOverridable Public Property ScaleVertical As Double _
Implements IReflection.ScaleVertical
[C#]
public double ScaleVertical {get; set;}

Implements

IReflection.ScaleVertical

See Also

Reflection Class | Aspose.Slides.Effects Namespace


SkewH Property

Aspose.Slides Documentation

Reflection.SkewH Property

NOTE: This property is now obsolete.

Use SkewHorizontal property instead. Property will be removed after 01.09.2013.

Specifies the horizontal skew angle.

[Visual Basic]
Public Property SkewH As Double
[C#]
public double SkewH {get; set;}

See Also

Reflection Class | Aspose.Slides.Effects Namespace


SkewHorizontal Property

Aspose.Slides Documentation

Reflection.SkewHorizontal Property

Specifies the horizontal skew angle.

[Visual Basic]
NotOverridable Public Property SkewHorizontal As Double _
Implements IReflection.SkewHorizontal
[C#]
public double SkewHorizontal {get; set;}

Implements

IReflection.SkewHorizontal

See Also

Reflection Class | Aspose.Slides.Effects Namespace


SkewV Property

Aspose.Slides Documentation

Reflection.SkewV Property

NOTE: This property is now obsolete.

Use SkewVertical property instead. Property will be removed after 01.09.2013.

Specifies the vertical skew angle.

[Visual Basic]
Public Property SkewV As Double
[C#]
public double SkewV {get; set;}

See Also

Reflection Class | Aspose.Slides.Effects Namespace


SkewVertical Property

Aspose.Slides Documentation

Reflection.SkewVertical Property

Specifies the vertical skew angle.

[Visual Basic]
NotOverridable Public Property SkewVertical As Double _
Implements IReflection.SkewVertical
[C#]
public double SkewVertical {get; set;}

Implements

IReflection.SkewVertical

See Also

Reflection Class | Aspose.Slides.Effects Namespace


StartPosAlpha Property

Aspose.Slides Documentation

Reflection.StartPosAlpha Property

Specifies the start position (along the alpha gradient ramp) of the start alpha value (percents).

[Visual Basic]
NotOverridable Public Property StartPosAlpha As Single _
Implements IReflection.StartPosAlpha
[C#]
public float StartPosAlpha {get; set;}

Implements

IReflection.StartPosAlpha

See Also

Reflection Class | Aspose.Slides.Effects Namespace


StartReflectionOpacity Property

Aspose.Slides Documentation

Reflection.StartReflectionOpacity Property

Starting reflection opacity. (percents).

[Visual Basic]
NotOverridable Public Property StartReflectionOpacity As Single _
Implements IReflection.StartReflectionOpacity
[C#]
public float StartReflectionOpacity {get; set;}

Implements

IReflection.StartReflectionOpacity

See Also

Reflection Class | Aspose.Slides.Effects Namespace


ReflectionEffectiveData Class

Immutable object which represents a reflection effect.

For a list of all members of this type, see ReflectionEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.ReflectionEffectiveData

[Visual Basic]
Public Class ReflectionEffectiveData
Inherits EffectEffectiveData
Implements IReflectionEffectiveData
[C#]
public class ReflectionEffectiveData : EffectEffectiveData, IReflectionEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ReflectionEffectiveData Members | Aspose.Slides.Effects Namespace


ReflectionEffectiveData Members

ReflectionEffectiveData overview

Public Instance Properties

BlurRadius | Blur radius.
Direction | Direction of reflection.
Distance | Distance of reflection.
EndPosAlpha | Specifies the end position (along the alpha gradient ramp) of the end alpha value (percents).
EndReflectionOpacity | End reflection opacity. (percents).
FadeDirection | Specifies the direction to offset the reflection. (angle).
RectangleAlign | Rectangle alignment.
RotateShadowWithShape | Specifies whether the reflection should rotate with the shape if the shape is rotated.
ScaleH | Obsolete. Specifies the horizontal scaling factor, negative scaling causes a flip. (percents)
ScaleHorizontal | Specifies the horizontal scaling factor, negative scaling causes a flip. (percents)
ScaleV | Obsolete. Specifies the vertical scaling factor, negative scaling causes a flip. (percents)
ScaleVertical | Specifies the vertical scaling factor, negative scaling causes a flip. (percents)
SkewH | Obsolete. Specifies the horizontal skew angle.
SkewHorizontal | Specifies the horizontal skew angle.
SkewV | Obsolete. Specifies the vertical skew angle.
SkewVertical | Specifies the vertical skew angle.
StartPosAlpha | Specifies the start position (along the alpha gradient ramp) of the start alpha value (percents).
StartReflectionOpacity | Starting reflection opacity. (percents).

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


ReflectionEffectiveData Properties

The properties of the ReflectionEffectiveData class are listed below. For a complete list of ReflectionEffectiveData class members, see the ReflectionEffectiveData Members topic.

Public Instance Properties

BlurRadius | Blur radius.
Direction | Direction of reflection.
Distance | Distance of reflection.
EndPosAlpha | Specifies the end position (along the alpha gradient ramp) of the end alpha value (percents).
EndReflectionOpacity | End reflection opacity. (percents).
FadeDirection | Specifies the direction to offset the reflection. (angle).
RectangleAlign | Rectangle alignment.
RotateShadowWithShape | Specifies whether the reflection should rotate with the shape if the shape is rotated.
ScaleH | Obsolete. Specifies the horizontal scaling factor, negative scaling causes a flip. (percents)
ScaleHorizontal | Specifies the horizontal scaling factor, negative scaling causes a flip. (percents)
ScaleV | Obsolete. Specifies the vertical scaling factor, negative scaling causes a flip. (percents)
ScaleVertical | Specifies the vertical scaling factor, negative scaling causes a flip. (percents)
SkewH | Obsolete. Specifies the horizontal skew angle.
SkewHorizontal | Specifies the horizontal skew angle.
SkewV | Obsolete. Specifies the vertical skew angle.
SkewVertical | Specifies the vertical skew angle.
StartPosAlpha | Specifies the start position (along the alpha gradient ramp) of the start alpha value (percents).
StartReflectionOpacity | Starting reflection opacity. (percents).

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


BlurRadius Property

Aspose.Slides Documentation

ReflectionEffectiveData.BlurRadius Property

Blur radius.

[Visual Basic]
NotOverridable Public ReadOnly Property BlurRadius As Double _
Implements IReflectionEffectiveData.BlurRadius
[C#]
public double BlurRadius {get;}

Implements

IReflectionEffectiveData.BlurRadius

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


Direction Property

Aspose.Slides Documentation

ReflectionEffectiveData.Direction Property

Direction of reflection.

[Visual Basic]
NotOverridable Public ReadOnly Property Direction As Single _
Implements IReflectionEffectiveData.Direction
[C#]
public float Direction {get;}

Implements

IReflectionEffectiveData.Direction

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


Distance Property

Aspose.Slides Documentation

ReflectionEffectiveData.Distance Property

Distance of reflection.

[Visual Basic]
NotOverridable Public ReadOnly Property Distance As Double _
Implements IReflectionEffectiveData.Distance
[C#]
public double Distance {get;}

Implements

IReflectionEffectiveData.Distance

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


EndPosAlpha Property

Aspose.Slides Documentation

ReflectionEffectiveData.EndPosAlpha Property

Specifies the end position (along the alpha gradient ramp) of the end alpha value (percents).

[Visual Basic]
NotOverridable Public ReadOnly Property EndPosAlpha As Single _
Implements IReflectionEffectiveData.EndPosAlpha
[C#]
public float EndPosAlpha {get;}

Implements

IReflectionEffectiveData.EndPosAlpha

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


EndReflectionOpacity Property

Aspose.Slides Documentation

ReflectionEffectiveData.EndReflectionOpacity Property

End reflection opacity. (percents).

[Visual Basic]
NotOverridable Public ReadOnly Property EndReflectionOpacity As Single _
Implements IReflectionEffectiveData.EndReflectionOpacity
[C#]
public float EndReflectionOpacity {get;}

Implements

IReflectionEffectiveData.EndReflectionOpacity

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


FadeDirection Property

Aspose.Slides Documentation

ReflectionEffectiveData.FadeDirection Property

Specifies the direction to offset the reflection. (angle).

[Visual Basic]
NotOverridable Public ReadOnly Property FadeDirection As Single _
Implements IReflectionEffectiveData.FadeDirection
[C#]
public float FadeDirection {get;}

Implements

IReflectionEffectiveData.FadeDirection

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


RectangleAlign Property

Aspose.Slides Documentation

ReflectionEffectiveData.RectangleAlign Property

Rectangle alignment.

[Visual Basic]
NotOverridable Public ReadOnly Property RectangleAlign As RectangleAlignment _
Implements IReflectionEffectiveData.RectangleAlign
[C#]
public RectangleAlignment RectangleAlign {get;}

Implements

IReflectionEffectiveData.RectangleAlign

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


RotateShadowWithShape Property

Aspose.Slides Documentation

ReflectionEffectiveData.RotateShadowWithShape Property

Specifies whether the reflection should rotate with the shape if the shape is rotated.

[Visual Basic]
NotOverridable Public ReadOnly Property RotateShadowWithShape As Boolean _
Implements IReflectionEffectiveData.RotateShadowWithShape
[C#]
public bool RotateShadowWithShape {get;}

Implements

IReflectionEffectiveData.RotateShadowWithShape

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


ScaleH Property

Aspose.Slides Documentation

ReflectionEffectiveData.ScaleH Property

NOTE: This property is now obsolete.

Use ScaleHorizontal property instead. Property will be removed after 01.09.2013.

Specifies the horizontal scaling factor, negative scaling causes a flip. (percents)

[Visual Basic]
Public ReadOnly Property ScaleH As Double
[C#]
public double ScaleH {get;}

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


ScaleHorizontal Property

Aspose.Slides Documentation

ReflectionEffectiveData.ScaleHorizontal Property

Specifies the horizontal scaling factor, negative scaling causes a flip. (percents)

[Visual Basic]
NotOverridable Public ReadOnly Property ScaleHorizontal As Double _
Implements IReflectionEffectiveData.ScaleHorizontal
[C#]
public double ScaleHorizontal {get;}

Implements

IReflectionEffectiveData.ScaleHorizontal

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


ScaleV Property

Aspose.Slides Documentation

ReflectionEffectiveData.ScaleV Property

NOTE: This property is now obsolete.

Use ScaleVertical property instead. Property will be removed after 01.09.2013.

Specifies the vertical scaling factor, negative scaling causes a flip. (percents)

[Visual Basic]
Public ReadOnly Property ScaleV As Double
[C#]
public double ScaleV {get;}

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


ScaleVertical Property

Aspose.Slides Documentation

ReflectionEffectiveData.ScaleVertical Property

Specifies the vertical scaling factor, negative scaling causes a flip. (percents)

[Visual Basic]
NotOverridable Public ReadOnly Property ScaleVertical As Double _
Implements IReflectionEffectiveData.ScaleVertical
[C#]
public double ScaleVertical {get;}

Implements

IReflectionEffectiveData.ScaleVertical

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


SkewH Property

Aspose.Slides Documentation

ReflectionEffectiveData.SkewH Property

NOTE: This property is now obsolete.

Use SkewHorizontal property instead. Property will be removed after 01.09.2013.

Specifies the horizontal skew angle.

[Visual Basic]
Public ReadOnly Property SkewH As Double
[C#]
public double SkewH {get;}

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


SkewHorizontal Property

Aspose.Slides Documentation

ReflectionEffectiveData.SkewHorizontal Property

Specifies the horizontal skew angle.

[Visual Basic]
NotOverridable Public ReadOnly Property SkewHorizontal As Double _
Implements IReflectionEffectiveData.SkewHorizontal
[C#]
public double SkewHorizontal {get;}

Implements

IReflectionEffectiveData.SkewHorizontal

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


SkewV Property

Aspose.Slides Documentation

ReflectionEffectiveData.SkewV Property

NOTE: This property is now obsolete.

Use SkewVertical property instead. Property will be removed after 01.09.2013.

Specifies the vertical skew angle.

[Visual Basic]
Public ReadOnly Property SkewV As Double
[C#]
public double SkewV {get;}

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


SkewVertical Property

Aspose.Slides Documentation

ReflectionEffectiveData.SkewVertical Property

Specifies the vertical skew angle.

[Visual Basic]
NotOverridable Public ReadOnly Property SkewVertical As Double _
Implements IReflectionEffectiveData.SkewVertical
[C#]
public double SkewVertical {get;}

Implements

IReflectionEffectiveData.SkewVertical

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


StartPosAlpha Property

Aspose.Slides Documentation

ReflectionEffectiveData.StartPosAlpha Property

Specifies the start position (along the alpha gradient ramp) of the start alpha value (percents).

[Visual Basic]
NotOverridable Public ReadOnly Property StartPosAlpha As Single _
Implements IReflectionEffectiveData.StartPosAlpha
[C#]
public float StartPosAlpha {get;}

Implements

IReflectionEffectiveData.StartPosAlpha

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


StartReflectionOpacity Property

Aspose.Slides Documentation

ReflectionEffectiveData.StartReflectionOpacity Property

Starting reflection opacity. (percents).

[Visual Basic]
NotOverridable Public ReadOnly Property StartReflectionOpacity As Single _
Implements IReflectionEffectiveData.StartReflectionOpacity
[C#]
public float StartReflectionOpacity {get;}

Implements

IReflectionEffectiveData.StartReflectionOpacity

See Also

ReflectionEffectiveData Class | Aspose.Slides.Effects Namespace


SoftEdge Class

Represents a soft edge effect. The edges of the shape are blurred, while the fill is not affected.

For a list of all members of this type, see SoftEdge Members.

System.Object
Aspose.Slides.Effects.SoftEdge

[Visual Basic]
Public Class SoftEdge
Implements ISoftEdge
[C#]
public class SoftEdge : ISoftEdge

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SoftEdge Members | Aspose.Slides.Effects Namespace


SoftEdge Members

SoftEdge overview

Public Instance Constructors

SoftEdge Constructor Creates new instance of SoftEdge class.

Public Instance Properties

Radius Specifies the radius of blur to apply to the edges.

See Also

SoftEdge Class | Aspose.Slides.Effects Namespace


SoftEdge Constructor

Creates new instance of SoftEdge class.

[Visual Basic]
Public Sub New()
[C#]
public SoftEdge();

See Also

SoftEdge Class | Aspose.Slides.Effects Namespace


SoftEdge Properties

The properties of the SoftEdge class are listed below. For a complete list of SoftEdge class members, see the SoftEdge Members topic.

Public Instance Properties

Radius Specifies the radius of blur to apply to the edges.

See Also

SoftEdge Class | Aspose.Slides.Effects Namespace


Radius Property

Aspose.Slides Documentation

SoftEdge.Radius Property

Specifies the radius of blur to apply to the edges.

[Visual Basic]
NotOverridable Public Property Radius As Double _
Implements ISoftEdge.Radius
[C#]
public double Radius {get; set;}

Implements

ISoftEdge.Radius

See Also

SoftEdge Class | Aspose.Slides.Effects Namespace


SoftEdgeEffectiveData Class

Immutable object which represents a soft edge effect. The edges of the shape are blurred, while the fill is not affected.

For a list of all members of this type, see SoftEdgeEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.SoftEdgeEffectiveData

[Visual Basic]
Public Class SoftEdgeEffectiveData
Inherits EffectEffectiveData
Implements ISoftEdgeEffectiveData
[C#]
public class SoftEdgeEffectiveData : EffectEffectiveData, ISoftEdgeEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SoftEdgeEffectiveData Members | Aspose.Slides.Effects Namespace


SoftEdgeEffectiveData Members

SoftEdgeEffectiveData overview

Public Instance Properties

Radius Specifies the radius of blur to apply to the edges.

See Also

SoftEdgeEffectiveData Class | Aspose.Slides.Effects Namespace


SoftEdgeEffectiveData Properties

The properties of the SoftEdgeEffectiveData class are listed below. For a complete list of SoftEdgeEffectiveData class members, see the SoftEdgeEffectiveData Members topic.

Public Instance Properties

Radius Specifies the radius of blur to apply to the edges.

See Also

SoftEdgeEffectiveData Class | Aspose.Slides.Effects Namespace


Radius Property

Aspose.Slides Documentation

SoftEdgeEffectiveData.Radius Property

Specifies the radius of blur to apply to the edges.

[Visual Basic]
NotOverridable Public ReadOnly Property Radius As Double _
Implements ISoftEdgeEffectiveData.Radius
[C#]
public double Radius {get;}

Implements

ISoftEdgeEffectiveData.Radius

See Also

SoftEdgeEffectiveData Class | Aspose.Slides.Effects Namespace


Tint Class

Represents a Tint effect. Shifts effect color values towards/away from hue by the specified amount.

For a list of all members of this type, see Tint Members.

System.Object
Aspose.Slides.Effects.ImageTransformOperation
Aspose.Slides.Effects.Tint

[Visual Basic]
Public Class Tint
Inherits ImageTransformOperation
Implements ITint
[C#]
public class Tint : ImageTransformOperation, ITint

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Tint Members | Aspose.Slides.Effects Namespace


Tint Members

Tint overview

Public Instance Constructors

Tint Constructor Tint effect constructor.

See Also

Tint Class | Aspose.Slides.Effects Namespace


Tint Constructor

Tint effect constructor.

[Visual Basic]
Overloads Public Sub New( _
ByVal hue As Single, _
ByVal amount As Single _
)
[C#]
public Tint(
float hue,
float amount
);

Parameters

hue
The hue towards which to tint.
amount
Specifies by how much the color value is shifted.

See Also

Tint Class | Aspose.Slides.Effects Namespace


TintEffectiveData Class

Immutable object which represents a Tint effect. Shifts effect color values towards/away from hue by the specified amount.

For a list of all members of this type, see TintEffectiveData Members.

System.Object
Aspose.Slides.Effects.EffectEffectiveData
Aspose.Slides.Effects.TintEffectiveData

[Visual Basic]
Public Class TintEffectiveData
Inherits EffectEffectiveData
Implements ITintEffectiveData
[C#]
public class TintEffectiveData : EffectEffectiveData, ITintEffectiveData

Requirements

Namespace: Aspose.Slides.Effects

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TintEffectiveData Members | Aspose.Slides.Effects Namespace


TintEffectiveData Members

TintEffectiveData overview

Public Instance Properties

Amount | Returns effect amount. Readonly Single.
Hue | Returns hue. Readonly Single.

See Also

TintEffectiveData Class | Aspose.Slides.Effects Namespace


TintEffectiveData Properties

The properties of the TintEffectiveData class are listed below. For a complete list of TintEffectiveData class members, see the TintEffectiveData Members topic.

Public Instance Properties

Amount | Returns effect amount. Readonly Single.
Hue | Returns hue. Readonly Single.

See Also

TintEffectiveData Class | Aspose.Slides.Effects Namespace


Amount Property

Aspose.Slides Documentation

TintEffectiveData.Amount Property

Returns effect amount. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Amount As Single _
Implements ITintEffectiveData.Amount
[C#]
public float Amount {get;}

Implements

ITintEffectiveData.Amount

See Also

TintEffectiveData Class | Aspose.Slides.Effects Namespace


Hue Property

Aspose.Slides Documentation

TintEffectiveData.Hue Property

Returns hue. Readonly Single.

[Visual Basic]
NotOverridable Public ReadOnly Property Hue As Single _
Implements ITintEffectiveData.Hue
[C#]
public float Hue {get;}

Implements

ITintEffectiveData.Hue

See Also

TintEffectiveData Class | Aspose.Slides.Effects Namespace


Aspose.Slides.Export

Aspose.Slides Documentation

Aspose.Slides.Export Namespace

Namespace hierarchy

Classes

Class | Description
HtmlFormatter | Represents HTML file template.
HtmlGenerator | Html generator.
HtmlOptions | Represents a HTML exporting options.
PdfOptions | Provides options that control how a presentation is saved in Pdf format.
PptOptions | Provides options that control how a presentation is saved in PPT format.
PptxOptions | Represents options for saving OpenXml presentations (PPTX, PPSX, POTX, PPTM, PPSM, POTM).
PresentationPrintDocument | Provides a default implementation for printing of a Presentation within the .NET printing framework.
SaveOptions | Abstract class with options that control how a presentation is saved.
SaveOptionsFactory |
SlideImageFormat | Determines format in which slide image will be saved for presentation to HTML export.
SVGOptions | Represents an SVG options.
SvgShape | Represents options for SVG shape.
TextToHtmlConversionOptions | Options for extracting HTML from the Pptx text.
TiffOptions | Provides options that control how a presentation is saved in TIFF format.
XpsOptions | Provides options that control how a presentation is saved in XPS format.

Interfaces

Interface | Description
IHtmlFormatter |
IHtmlFormattingController |
IHtmlGenerator |
IHtmlOptions |
ILinkEmbedController |
IPdfOptions |
IPptOptions |
IPptxOptions |
ISaveOptions |
ISaveOptionsFactory |
ISlideImageFormat |
ISVGOptions |
ISvgShape |
ISvgShapeFormattingController |
ITextToHtmlConversionOptions |
ITiffOptions |
IXpsOptions |

Enumerations

Enumeration | Description
LinkEmbedDecision |
PdfCompliance |
PdfTextCompression |
SaveFormat |
SvgCoordinateUnit |
SvgEvent |
TextInheritanceLimit |
TiffCompressionTypes |


HtmlFormatter Class

Represents HTML file template.

For a list of all members of this type, see HtmlFormatter Members.

System.Object
Aspose.Slides.Export.HtmlFormatter

[Visual Basic]
NotInheritable Public Class HtmlFormatter
Implements IHtmlFormatter
[C#]
public sealed class HtmlFormatter : IHtmlFormatter

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

HtmlFormatter Members | Aspose.Slides.Export Namespace


HtmlFormatter Members

HtmlFormatter overview

Public Static (Shared) Methods

CreateCustomFormatter | Creates and returns HTML formatter for custom callback-driven html generation.
CreateDocumentFormatter | Creates and returns HTML formatter for a simple document view which consists of sequences of slides one below another.
CreateSlideShowFormatter | Creates and returns HTML formatter for a simple slide show html which shows slides one after another.

See Also

HtmlFormatter Class | Aspose.Slides.Export Namespace


HtmlFormatter Methods

The methods of the HtmlFormatter class are listed below. For a complete list of HtmlFormatter class members, see the HtmlFormatter Members topic.

Public Static (Shared) Methods

CreateCustomFormatter | Creates and returns HTML formatter for custom callback-driven html generation.
CreateDocumentFormatter | Creates and returns HTML formatter for a simple document view which consists of sequences of slides one below another.
CreateSlideShowFormatter | Creates and returns HTML formatter for a simple slide show html which shows slides one after another.

See Also

HtmlFormatter Class | Aspose.Slides.Export Namespace


HtmlFormatter.CreateCustomFormatter Method

Creates and returns HTML formatter for custom callback-driven html generation.

[Visual Basic]
Public Shared Function CreateCustomFormatter( _
ByVal formattingController As IHtmlFormattingController _
) As HtmlFormatter
[C#]
public static HtmlFormatter CreateCustomFormatter(
IHtmlFormattingController formattingController
);

Parameters

formattingController
Callback interface which controls html file generation.

Return Value

See Also

HtmlFormatter Class | Aspose.Slides.Export Namespace


HtmlFormatter.CreateDocumentFormatter Method

Creates and returns HTML formatter for a simple document view which consists of sequences of slides one below another.

[Visual Basic]
Public Shared Function CreateDocumentFormatter( _
ByVal css As String, _
ByVal showSlideTitle As Boolean _
) As HtmlFormatter
[C#]
public static HtmlFormatter CreateDocumentFormatter(
string css,
bool showSlideTitle
);

Parameters

css
Specifies CSS for this file.
showSlideTitle
Add slide title if there is one above slide image.

Return Value

See Also

HtmlFormatter Class | Aspose.Slides.Export Namespace


HtmlFormatter.CreateSlideShowFormatter Method

Creates and returns HTML formatter for a simple slide show html which shows slides one after another.

[Visual Basic]
Public Shared Function CreateSlideShowFormatter( _
ByVal css As String, _
ByVal showSlideTitle As Boolean _
) As HtmlFormatter
[C#]
public static HtmlFormatter CreateSlideShowFormatter(
string css,
bool showSlideTitle
);

Parameters

css
Specifies URL of CCS file used.
showSlideTitle
Add slide title if there is one above slide image.

Return Value

See Also

HtmlFormatter Class | Aspose.Slides.Export Namespace


HtmlGenerator Class

Html generator.

For a list of all members of this type, see HtmlGenerator Members.

System.Object
Aspose.Slides.Export.HtmlGenerator

[Visual Basic]
NotInheritable Public Class HtmlGenerator
Implements IHtmlGenerator
[C#]
public sealed class HtmlGenerator : IHtmlGenerator

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

HtmlGenerator Members | Aspose.Slides.Export Namespace


HtmlGenerator Members

HtmlGenerator overview

Public Instance Properties

NextSlideIndex | Returns index of a slide, which will be rendered after the current slide or -1 if currently rendering last slide. Readonly Int32.
PreviousSlideIndex | Returns index of previously rendered slide or -1 if first slide is rendering. Readonly Int32.
SlideImageSize | Returns slide image size. Readonly SizeF.
SlideImageSizeUnit | Returns a unit in which slide image size is specified. Readonly SvgCoordinateUnit.
SlideImageSizeUnitCode | Returns a css code of unit in which slide image size is specified. Readonly String.
SlideIndex | Returns index of currently rendering slide. Readonly Int32.

Public Instance Methods

AddAttributeValue | Overloaded. Quotes attribute value and adds it to the html file.
AddHtml | Overloaded. Adds formatted HTML text.
AddText | Overloaded. Adds plain text to the html files, replacing special characters with html entities. Linebreaks and whitespaces aren't replaced.

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace


HtmlGenerator Properties

The properties of the HtmlGenerator class are listed below. For a complete list of HtmlGenerator class members, see the HtmlGenerator Members topic.

Public Instance Properties

NextSlideIndex | Returns index of a slide, which will be rendered after the current slide or -1 if currently rendering last slide. Readonly Int32.
PreviousSlideIndex | Returns index of previously rendered slide or -1 if first slide is rendering. Readonly Int32.
SlideImageSize | Returns slide image size. Readonly SizeF.
SlideImageSizeUnit | Returns a unit in which slide image size is specified. Readonly SvgCoordinateUnit.
SlideImageSizeUnitCode | Returns a css code of unit in which slide image size is specified. Readonly String.
SlideIndex | Returns index of currently rendering slide. Readonly Int32.

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace


NextSlideIndex Property

Aspose.Slides Documentation

HtmlGenerator.NextSlideIndex Property

Returns index of a slide, which will be rendered after the current slide or -1 if currently rendering last slide. Readonly Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property NextSlideIndex As Integer _
Implements IHtmlGenerator.NextSlideIndex
[C#]
public int NextSlideIndex {get;}

Implements

IHtmlGenerator.NextSlideIndex

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace


PreviousSlideIndex Property

Aspose.Slides Documentation

HtmlGenerator.PreviousSlideIndex Property

Returns index of previously rendered slide or -1 if first slide is rendering. Readonly Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property PreviousSlideIndex As Integer _
Implements IHtmlGenerator.PreviousSlideIndex
[C#]
public int PreviousSlideIndex {get;}

Implements

IHtmlGenerator.PreviousSlideIndex

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace


SlideImageSize Property

Aspose.Slides Documentation

HtmlGenerator.SlideImageSize Property

Returns slide image size. Readonly SizeF.

[Visual Basic]
NotOverridable Public ReadOnly Property SlideImageSize As SizeF _
Implements IHtmlGenerator.SlideImageSize
[C#]
public SizeF SlideImageSize {get;}

Implements

IHtmlGenerator.SlideImageSize

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace


SlideImageSizeUnit Property

Aspose.Slides Documentation

HtmlGenerator.SlideImageSizeUnit Property

Returns a unit in which slide image size is specified. Readonly SvgCoordinateUnit.

[Visual Basic]
NotOverridable Public ReadOnly Property SlideImageSizeUnit As SvgCoordinateUnit _
Implements IHtmlGenerator.SlideImageSizeUnit
[C#]
public SvgCoordinateUnit SlideImageSizeUnit {get;}

Implements

IHtmlGenerator.SlideImageSizeUnit

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace


SlideImageSizeUnitCode Property

Aspose.Slides Documentation

HtmlGenerator.SlideImageSizeUnitCode Property

Returns a css code of unit in which slide image size is specified. Readonly String.

[Visual Basic]
NotOverridable Public ReadOnly Property SlideImageSizeUnitCode As String _
Implements IHtmlGenerator.SlideImageSizeUnitCode
[C#]
public string SlideImageSizeUnitCode {get;}

Implements

IHtmlGenerator.SlideImageSizeUnitCode

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace


SlideIndex Property

Aspose.Slides Documentation

HtmlGenerator.SlideIndex Property

Returns index of currently rendering slide. Readonly Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property SlideIndex As Integer _
Implements IHtmlGenerator.SlideIndex
[C#]
public int SlideIndex {get;}

Implements

IHtmlGenerator.SlideIndex

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace


HtmlGenerator Methods

The methods of the HtmlGenerator class are listed below. For a complete list of HtmlGenerator class members, see the HtmlGenerator Members topic.

Public Instance Methods

AddAttributeValue | Overloaded. Quotes attribute value and adds it to the html file.
AddHtml | Overloaded. Adds formatted HTML text.
AddText | Overloaded. Adds plain text to the html files, replacing special characters with html entities. Linebreaks and whitespaces aren't replaced.

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace


AddAttributeValue Method

Aspose.Slides Documentation

HtmlGenerator.AddAttributeValue Method

Quotes attribute value and adds it to the html file.

Overload List

Quotes attribute value and adds it to the html file.

public void AddAttributeValue(char[]);

Quotes attribute value and adds it to the html file.

public void AddAttributeValue(char[],int,int);

Quotes attribute value and adds it to the html file.

public void AddAttributeValue(string);

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace


HtmlGenerator.AddAttributeValue Method (Char[])

Quotes attribute value and adds it to the html file.

[Visual Basic]
NotOverridable Overloads Public Sub AddAttributeValue( _
ByVal value As Char() _
) _
Implements IHtmlGenerator.AddAttributeValue
[C#]
public void AddAttributeValue(
char[] value
);

Parameters

value
Attribute value string.

Implements

IHtmlGenerator.AddAttributeValue

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace | HtmlGenerator.AddAttributeValue Overload List


HtmlGenerator.AddAttributeValue Method (Char[], Int32, Int32)

Quotes attribute value and adds it to the html file.

[Visual Basic]
NotOverridable Overloads Public Sub AddAttributeValue( _
ByVal value As Char(), _
ByVal startIndex As Integer, _
ByVal length As Integer _
) _
Implements IHtmlGenerator.AddAttributeValue
[C#]
public void AddAttributeValue(
char[] value,
int startIndex,
int length
);

Parameters

value
Attribute value string.
startIndex
Start index of the portion to add.
length
Length of the portion to add.

Implements

IHtmlGenerator.AddAttributeValue

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace | HtmlGenerator.AddAttributeValue Overload List


HtmlGenerator.AddAttributeValue Method (String)

Quotes attribute value and adds it to the html file.

[Visual Basic]
NotOverridable Overloads Public Sub AddAttributeValue( _
ByVal value As String _
) _
Implements IHtmlGenerator.AddAttributeValue
[C#]
public void AddAttributeValue(
string value
);

Parameters

value
Attribute value string.

Implements

IHtmlGenerator.AddAttributeValue

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace | HtmlGenerator.AddAttributeValue Overload List


AddHtml Method

Aspose.Slides Documentation

HtmlGenerator.AddHtml Method

Adds formatted HTML text.

Overload List

Adds formatted HTML text.

public void AddHtml(char[]);

Adds formatted HTML text.

public void AddHtml(char[],int,int);

Adds formatted HTML text.

public void AddHtml(string);

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace


HtmlGenerator.AddHtml Method (Char[])

Adds formatted HTML text.

[Visual Basic]
NotOverridable Overloads Public Sub AddHtml( _
ByVal html As Char() _
) _
Implements IHtmlGenerator.AddHtml
[C#]
public void AddHtml(
char[] html
);

Parameters

html
Text to add.

Implements

IHtmlGenerator.AddHtml

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace | HtmlGenerator.AddHtml Overload List


HtmlGenerator.AddHtml Method (Char[], Int32, Int32)

Adds formatted HTML text.

[Visual Basic]
NotOverridable Overloads Public Sub AddHtml( _
ByVal html As Char(), _
ByVal startIndex As Integer, _
ByVal length As Integer _
) _
Implements IHtmlGenerator.AddHtml
[C#]
public void AddHtml(
char[] html,
int startIndex,
int length
);

Parameters

html
Text to add.
startIndex
Start index of the portion to add.
length
Length of the portion to add.

Implements

IHtmlGenerator.AddHtml

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace | HtmlGenerator.AddHtml Overload List


HtmlGenerator.AddHtml Method (String)

Adds formatted HTML text.

[Visual Basic]
NotOverridable Overloads Public Sub AddHtml( _
ByVal html As String _
) _
Implements IHtmlGenerator.AddHtml
[C#]
public void AddHtml(
string html
);

Parameters

html
Text to add.

Implements

IHtmlGenerator.AddHtml

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace | HtmlGenerator.AddHtml Overload List


AddText Method

Aspose.Slides Documentation

HtmlGenerator.AddText Method

Adds plain text to the html files, replacing special characters with html entities. Linebreaks and whitespaces aren't replaced.

Overload List

Adds plain text to the html files, replacing special characters with html entities. Linebreaks and whitespaces aren't replaced.

public void AddText(char[]);

Adds plain text to the html files, replacing special characters with html entities. Linebreaks and whitespaces aren't replaced.

public void AddText(char[],int,int);

Adds plain text to the html files, replacing special characters with html entities. Linebreaks and whitespaces aren't replaced.

public void AddText(string);

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace


HtmlGenerator.AddText Method (Char[])

Adds plain text to the html files, replacing special characters with html entities. Linebreaks and whitespaces aren't replaced.

[Visual Basic]
NotOverridable Overloads Public Sub AddText( _
ByVal text As Char() _
) _
Implements IHtmlGenerator.AddText
[C#]
public void AddText(
char[] text
);

Parameters

text
Text to add.

Implements

IHtmlGenerator.AddText

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace | HtmlGenerator.AddText Overload List


HtmlGenerator.AddText Method (Char[], Int32, Int32)

Adds plain text to the html files, replacing special characters with html entities. Linebreaks and whitespaces aren't replaced.

[Visual Basic]
NotOverridable Overloads Public Sub AddText( _
ByVal text As Char(), _
ByVal startIndex As Integer, _
ByVal length As Integer _
) _
Implements IHtmlGenerator.AddText
[C#]
public void AddText(
char[] text,
int startIndex,
int length
);

Parameters

text
Text to add.
startIndex
Start index of the portion to add.
length
Length of the portion to add.

Implements

IHtmlGenerator.AddText

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace | HtmlGenerator.AddText Overload List


HtmlGenerator.AddText Method (String)

Adds plain text to the html files, replacing special characters with html entities. Linebreaks and whitespaces aren't replaced.

[Visual Basic]
NotOverridable Overloads Public Sub AddText( _
ByVal text As String _
) _
Implements IHtmlGenerator.AddText
[C#]
public void AddText(
string text
);

Parameters

text
Text to add.

Implements

IHtmlGenerator.AddText

See Also

HtmlGenerator Class | Aspose.Slides.Export Namespace | HtmlGenerator.AddText Overload List


HtmlOptions Class

Represents a HTML exporting options.

For a list of all members of this type, see HtmlOptions Members.

System.Object
Aspose.Slides.Export.SaveOptions
Aspose.Slides.Export.HtmlOptions

[Visual Basic]
Public Class HtmlOptions
Inherits SaveOptions
Implements IHtmlOptions
[C#]
public class HtmlOptions : SaveOptions, IHtmlOptions

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

HtmlOptions Members | Aspose.Slides.Export Namespace


HtmlOptions Members

HtmlOptions overview

Public Instance Constructors

HtmlOptions Overloaded. Initializes a new instance of the HtmlOptions class.

Public Instance Properties

HtmlFormatter | Returns or sets HTML template. Read/write HtmlFormatter.
JpegQuality | Returns or sets a value determining the quality of the JPEG images inside PDF document.
SlideImageFormat | Returns or sets slide image format options. Read/write SlideImageFormat.
WarningCallback (inherited from SaveOptions) | Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

HtmlOptions Class | Aspose.Slides.Export Namespace


HtmlOptions Constructor

Creates a new HtmlOptions object specifiing callback.

Overload List

Creates a new HtmlOptions object for saving into single HTML file.

public HtmlOptions();

Creates a new HtmlOptions object specifiing callback.

public HtmlOptions(ILinkEmbedController);

See Also

HtmlOptions Class | Aspose.Slides.Export Namespace


HtmlOptions Constructor (ILinkEmbedController)

Creates a new HtmlOptions object specifiing callback.

[Visual Basic]
Overloads Public Sub New( _
ByVal linkEmbedController As ILinkEmbedController _
)
[C#]
public HtmlOptions(
ILinkEmbedController linkEmbedController
);

Parameters

linkEmbedController
Callback object which controls saving project.

See Also

HtmlOptions Class | Aspose.Slides.Export Namespace | HtmlOptions Constructor Overload List


HtmlOptions Constructor ()

Creates a new HtmlOptions object for saving into single HTML file.

[Visual Basic]
Overloads Public Sub New()
[C#]
public HtmlOptions();

See Also

HtmlOptions Class | Aspose.Slides.Export Namespace | HtmlOptions Constructor Overload List


HtmlOptions Properties

The properties of the HtmlOptions class are listed below. For a complete list of HtmlOptions class members, see the HtmlOptions Members topic.

Public Instance Properties

HtmlFormatter | Returns or sets HTML template. Read/write HtmlFormatter.
JpegQuality | Returns or sets a value determining the quality of the JPEG images inside PDF document.
SlideImageFormat | Returns or sets slide image format options. Read/write SlideImageFormat.
WarningCallback (inherited from SaveOptions) | Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

HtmlOptions Class | Aspose.Slides.Export Namespace


HtmlFormatter Property

Aspose.Slides Documentation

HtmlOptions.HtmlFormatter Property

Returns or sets HTML template. Read/write HtmlFormatter.

[Visual Basic]
NotOverridable Public Property HtmlFormatter As IHtmlFormatter _
Implements IHtmlOptions.HtmlFormatter
[C#]
public IHtmlFormatter HtmlFormatter {get; set;}

Implements

IHtmlOptions.HtmlFormatter

See Also

HtmlOptions Class | Aspose.Slides.Export Namespace


JpegQuality Property

Aspose.Slides Documentation

HtmlOptions.JpegQuality Property

Returns or sets a value determining the quality of the JPEG images inside PDF document.

[Visual Basic]
NotOverridable Public Property JpegQuality As Byte _
Implements IHtmlOptions.JpegQuality
[C#]
public byte JpegQuality {get; set;}

Implements

IHtmlOptions.JpegQuality

Remarks

Has effect only when a document contains JPEG images.

Use this property to get or set the quality of the images inside a document when saving in PDF format. The value may vary from 0 to 100 where 0 means worst quality but maximum compression and 100 means best quality but minimum compression.

The default value is 95.

See Also

HtmlOptions Class | Aspose.Slides.Export Namespace


SlideImageFormat Property

Aspose.Slides Documentation

HtmlOptions.SlideImageFormat Property

Returns or sets slide image format options. Read/write SlideImageFormat.

[Visual Basic]
NotOverridable Public Property SlideImageFormat As ISlideImageFormat _
Implements IHtmlOptions.SlideImageFormat
[C#]
public ISlideImageFormat SlideImageFormat {get; set;}

Implements

IHtmlOptions.SlideImageFormat

See Also

HtmlOptions Class | Aspose.Slides.Export Namespace


IHtmlFormatter Interface

[Visual Basic]
Public Interface IHtmlFormatter
[C#]
public interface IHtmlFormatter

Types that implement IHtmlFormatter

Type | Description
HtmlFormatter | Represents HTML file template.

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Export Namespace


IHtmlFormattingController Interface

For a list of all members of this type, see IHtmlFormattingController Members.

[Visual Basic]
Public Interface IHtmlFormattingController
[C#]
public interface IHtmlFormattingController

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IHtmlFormattingController Members | Aspose.Slides.Export Namespace


IHtmlFormattingController Members

IHtmlFormattingController overview

Public Instance Methods

WriteDocumentEnd
WriteDocumentStart
WriteShapeEnd
WriteShapeStart
WriteSlideEnd
WriteSlideStart

See Also

IHtmlFormattingController Interface | Aspose.Slides.Export Namespace


IHtmlFormattingController Methods

The methods of the IHtmlFormattingController interface are listed below. For a complete list of IHtmlFormattingController interface members, see the IHtmlFormattingController Members topic.

Public Instance Methods

WriteDocumentEnd
WriteDocumentStart
WriteShapeEnd
WriteShapeStart
WriteSlideEnd
WriteSlideStart

See Also

IHtmlFormattingController Interface | Aspose.Slides.Export Namespace


IHtmlFormattingController.WriteDocumentEnd Method

[Visual Basic]
Sub WriteDocumentEnd( _
ByVal generator As IHtmlGenerator, _
ByVal presentation As IPresentation _
)
[C#]
void WriteDocumentEnd(
IHtmlGenerator generator,
IPresentation presentation
);

See Also

IHtmlFormattingController Interface | Aspose.Slides.Export Namespace


IHtmlFormattingController.WriteDocumentStart Method

[Visual Basic]
Sub WriteDocumentStart( _
ByVal generator As IHtmlGenerator, _
ByVal presentation As IPresentation _
)
[C#]
void WriteDocumentStart(
IHtmlGenerator generator,
IPresentation presentation
);

See Also

IHtmlFormattingController Interface | Aspose.Slides.Export Namespace


IHtmlFormattingController.WriteShapeEnd Method

[Visual Basic]
Sub WriteShapeEnd( _
ByVal generator As IHtmlGenerator, _
ByVal shape As IShape _
)
[C#]
void WriteShapeEnd(
IHtmlGenerator generator,
IShape shape
);

See Also

IHtmlFormattingController Interface | Aspose.Slides.Export Namespace


IHtmlFormattingController.WriteShapeStart Method

[Visual Basic]
Sub WriteShapeStart( _
ByVal generator As IHtmlGenerator, _
ByVal shape As IShape _
)
[C#]
void WriteShapeStart(
IHtmlGenerator generator,
IShape shape
);

See Also

IHtmlFormattingController Interface | Aspose.Slides.Export Namespace


IHtmlFormattingController.WriteSlideEnd Method

[Visual Basic]
Sub WriteSlideEnd( _
ByVal generator As IHtmlGenerator, _
ByVal slide As ISlide _
)
[C#]
void WriteSlideEnd(
IHtmlGenerator generator,
ISlide slide
);

See Also

IHtmlFormattingController Interface | Aspose.Slides.Export Namespace


IHtmlFormattingController.WriteSlideStart Method

[Visual Basic]
Sub WriteSlideStart( _
ByVal generator As IHtmlGenerator, _
ByVal slide As ISlide _
)
[C#]
void WriteSlideStart(
IHtmlGenerator generator,
ISlide slide
);

See Also

IHtmlFormattingController Interface | Aspose.Slides.Export Namespace


IHtmlGenerator Interface

For a list of all members of this type, see IHtmlGenerator Members.

[Visual Basic]
Public Interface IHtmlGenerator
[C#]
public interface IHtmlGenerator

Types that implement IHtmlGenerator

Type | Description
HtmlGenerator | Html generator.

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IHtmlGenerator Members | Aspose.Slides.Export Namespace


IHtmlGenerator Members

IHtmlGenerator overview

Public Instance Properties

NextSlideIndex
PreviousSlideIndex
SlideImageSize
SlideImageSizeUnit
SlideImageSizeUnitCode
SlideIndex

Public Instance Methods

AddAttributeValue | Overloaded.
AddHtml | Overloaded.
AddText | Overloaded.

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace


IHtmlGenerator Properties

The properties of the IHtmlGenerator interface are listed below. For a complete list of IHtmlGenerator interface members, see the IHtmlGenerator Members topic.

Public Instance Properties

NextSlideIndex
PreviousSlideIndex
SlideImageSize
SlideImageSizeUnit
SlideImageSizeUnitCode
SlideIndex

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace


NextSlideIndex Property

Aspose.Slides Documentation

IHtmlGenerator.NextSlideIndex Property

[Visual Basic]
Property NextSlideIndex As Integer
[C#]
int NextSlideIndex {get;}

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace


PreviousSlideIndex Property

Aspose.Slides Documentation

IHtmlGenerator.PreviousSlideIndex Property

[Visual Basic]
Property PreviousSlideIndex As Integer
[C#]
int PreviousSlideIndex {get;}

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace


SlideImageSize Property

Aspose.Slides Documentation

IHtmlGenerator.SlideImageSize Property

[Visual Basic]
Property SlideImageSize As SizeF
[C#]
SizeF SlideImageSize {get;}

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace


SlideImageSizeUnit Property

Aspose.Slides Documentation

IHtmlGenerator.SlideImageSizeUnit Property

[Visual Basic]
Property SlideImageSizeUnit As SvgCoordinateUnit
[C#]
SvgCoordinateUnit SlideImageSizeUnit {get;}

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace


SlideImageSizeUnitCode Property

Aspose.Slides Documentation

IHtmlGenerator.SlideImageSizeUnitCode Property

[Visual Basic]
Property SlideImageSizeUnitCode As String
[C#]
string SlideImageSizeUnitCode {get;}

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace


SlideIndex Property

Aspose.Slides Documentation

IHtmlGenerator.SlideIndex Property

[Visual Basic]
Property SlideIndex As Integer
[C#]
int SlideIndex {get;}

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace


IHtmlGenerator Methods

The methods of the IHtmlGenerator interface are listed below. For a complete list of IHtmlGenerator interface members, see the IHtmlGenerator Members topic.

Public Instance Methods

AddAttributeValue | Overloaded.
AddHtml | Overloaded.
AddText | Overloaded.

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace


AddAttributeValue Method

Aspose.Slides Documentation

IHtmlGenerator.AddAttributeValue Method

Overload List

void AddAttributeValue(char[]);

void AddAttributeValue(char[],int,int);

void AddAttributeValue(string);

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace


IHtmlGenerator.AddAttributeValue Method (Char[])

[Visual Basic]
Sub AddAttributeValue( _
ByVal value As Char() _
)
[C#]
void AddAttributeValue(
char[] value
);

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace | IHtmlGenerator.AddAttributeValue Overload List


IHtmlGenerator.AddAttributeValue Method (Char[], Int32, Int32)

[Visual Basic]
Sub AddAttributeValue( _
ByVal value As Char(), _
ByVal startIndex As Integer, _
ByVal length As Integer _
)
[C#]
void AddAttributeValue(
char[] value,
int startIndex,
int length
);

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace | IHtmlGenerator.AddAttributeValue Overload List


IHtmlGenerator.AddAttributeValue Method (String)

[Visual Basic]
Sub AddAttributeValue( _
ByVal value As String _
)
[C#]
void AddAttributeValue(
string value
);

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace | IHtmlGenerator.AddAttributeValue Overload List


AddHtml Method

Aspose.Slides Documentation

IHtmlGenerator.AddHtml Method

Overload List

void AddHtml(char[]);

void AddHtml(char[],int,int);

void AddHtml(string);

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace


IHtmlGenerator.AddHtml Method (Char[])

[Visual Basic]
Sub AddHtml( _
ByVal html As Char() _
)
[C#]
void AddHtml(
char[] html
);

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace | IHtmlGenerator.AddHtml Overload List


IHtmlGenerator.AddHtml Method (Char[], Int32, Int32)

[Visual Basic]
Sub AddHtml( _
ByVal html As Char(), _
ByVal startIndex As Integer, _
ByVal length As Integer _
)
[C#]
void AddHtml(
char[] html,
int startIndex,
int length
);

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace | IHtmlGenerator.AddHtml Overload List


IHtmlGenerator.AddHtml Method (String)

[Visual Basic]
Sub AddHtml( _
ByVal html As String _
)
[C#]
void AddHtml(
string html
);

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace | IHtmlGenerator.AddHtml Overload List


AddText Method

Aspose.Slides Documentation

IHtmlGenerator.AddText Method

Overload List

void AddText(char[]);

void AddText(char[],int,int);

void AddText(string);

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace


IHtmlGenerator.AddText Method (Char[])

[Visual Basic]
Sub AddText( _
ByVal text As Char() _
)
[C#]
void AddText(
char[] text
);

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace | IHtmlGenerator.AddText Overload List


IHtmlGenerator.AddText Method (Char[], Int32, Int32)

[Visual Basic]
Sub AddText( _
ByVal text As Char(), _
ByVal startIndex As Integer, _
ByVal length As Integer _
)
[C#]
void AddText(
char[] text,
int startIndex,
int length
);

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace | IHtmlGenerator.AddText Overload List


IHtmlGenerator.AddText Method (String)

[Visual Basic]
Sub AddText( _
ByVal text As String _
)
[C#]
void AddText(
string text
);

See Also

IHtmlGenerator Interface | Aspose.Slides.Export Namespace | IHtmlGenerator.AddText Overload List


IHtmlOptions Interface

For a list of all members of this type, see IHtmlOptions Members.

[Visual Basic]
Public Interface IHtmlOptions
Implements ISaveOptions
[C#]
public interface IHtmlOptions : ISaveOptions

Types that implement IHtmlOptions

Type | Description
HtmlOptions | Represents a HTML exporting options.

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IHtmlOptions Members | Aspose.Slides.Export Namespace


IHtmlOptions Members

IHtmlOptions overview

Public Instance Properties

AsISaveOptions
HtmlFormatter
JpegQuality
SlideImageFormat

See Also

IHtmlOptions Interface | Aspose.Slides.Export Namespace


IHtmlOptions Properties

The properties of the IHtmlOptions interface are listed below. For a complete list of IHtmlOptions interface members, see the IHtmlOptions Members topic.

Public Instance Properties

AsISaveOptions
HtmlFormatter
JpegQuality
SlideImageFormat

See Also

IHtmlOptions Interface | Aspose.Slides.Export Namespace


AsISaveOptions Property

Aspose.Slides Documentation

IHtmlOptions.AsISaveOptions Property

[Visual Basic]
Property AsISaveOptions As ISaveOptions
[C#]
ISaveOptions AsISaveOptions {get;}

See Also

IHtmlOptions Interface | Aspose.Slides.Export Namespace


HtmlFormatter Property

Aspose.Slides Documentation

IHtmlOptions.HtmlFormatter Property

[Visual Basic]
Property HtmlFormatter As IHtmlFormatter
[C#]
IHtmlFormatter HtmlFormatter {get; set;}

See Also

IHtmlOptions Interface | Aspose.Slides.Export Namespace


JpegQuality Property

Aspose.Slides Documentation

IHtmlOptions.JpegQuality Property

[Visual Basic]
Property JpegQuality As Byte
[C#]
byte JpegQuality {get; set;}

See Also

IHtmlOptions Interface | Aspose.Slides.Export Namespace


SlideImageFormat Property

Aspose.Slides Documentation

IHtmlOptions.SlideImageFormat Property

[Visual Basic]
Property SlideImageFormat As ISlideImageFormat
[C#]
ISlideImageFormat SlideImageFormat {get; set;}

See Also

IHtmlOptions Interface | Aspose.Slides.Export Namespace


ILinkEmbedController Interface

For a list of all members of this type, see ILinkEmbedController Members.

[Visual Basic]
Public Interface ILinkEmbedController
[C#]
public interface ILinkEmbedController

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILinkEmbedController Members | Aspose.Slides.Export Namespace


ILinkEmbedController Members

ILinkEmbedController overview

Public Instance Methods

GetObjectStoringLocation
GetUrl
SaveExternal

See Also

ILinkEmbedController Interface | Aspose.Slides.Export Namespace


ILinkEmbedController Methods

The methods of the ILinkEmbedController interface are listed below. For a complete list of ILinkEmbedController interface members, see the ILinkEmbedController Members topic.

Public Instance Methods

GetObjectStoringLocation
GetUrl
SaveExternal

See Also

ILinkEmbedController Interface | Aspose.Slides.Export Namespace


ILinkEmbedController.GetObjectStoringLocation Method

[Visual Basic]
Function GetObjectStoringLocation( _
ByVal id As Integer, _
ByVal entityData As Byte(), _
ByVal semanticName As String, _
ByVal contentType As String, _
ByVal recomendedExtension As String _
) As LinkEmbedDecision
[C#]
LinkEmbedDecision GetObjectStoringLocation(
int id,
byte[] entityData,
string semanticName,
string contentType,
string recomendedExtension
);

See Also

ILinkEmbedController Interface | Aspose.Slides.Export Namespace


ILinkEmbedController.GetUrl Method

[Visual Basic]
Function GetUrl( _
ByVal id As Integer, _
ByVal referrer As Integer _
) As String
[C#]
string GetUrl(
int id,
int referrer
);

See Also

ILinkEmbedController Interface | Aspose.Slides.Export Namespace


ILinkEmbedController.SaveExternal Method

[Visual Basic]
Sub SaveExternal( _
ByVal id As Integer, _
ByVal entityData As Byte() _
)
[C#]
void SaveExternal(
int id,
byte[] entityData
);

See Also

ILinkEmbedController Interface | Aspose.Slides.Export Namespace


IPdfOptions Interface

For a list of all members of this type, see IPdfOptions Members.

[Visual Basic]
Public Interface IPdfOptions
Implements ISaveOptions
[C#]
public interface IPdfOptions : ISaveOptions

Types that implement IPdfOptions

Type | Description
PdfOptions | Provides options that control how a presentation is saved in Pdf format.

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPdfOptions Members | Aspose.Slides.Export Namespace


IPdfOptions Members

IPdfOptions overview

Public Instance Properties

AdditionalCommonFontFamilies
AsISaveOptions
Compliance
EmbedFullFonts
EmbedTrueTypeFontsForASCII
JpegQuality
Password
SaveMetafilesAsPng
SufficientResolution
TextCompression

See Also

IPdfOptions Interface | Aspose.Slides.Export Namespace


IPdfOptions Properties

The properties of the IPdfOptions interface are listed below. For a complete list of IPdfOptions interface members, see the IPdfOptions Members topic.

Public Instance Properties

AdditionalCommonFontFamilies
AsISaveOptions
Compliance
EmbedFullFonts
EmbedTrueTypeFontsForASCII
JpegQuality
Password
SaveMetafilesAsPng
SufficientResolution
TextCompression

See Also

IPdfOptions Interface | Aspose.Slides.Export Namespace


AdditionalCommonFontFamilies Property

Aspose.Slides Documentation

IPdfOptions.AdditionalCommonFontFamilies Property

[Visual Basic]
Property AdditionalCommonFontFamilies As String()
[C#]
string[] AdditionalCommonFontFamilies {get; set;}

See Also

IPdfOptions Interface | Aspose.Slides.Export Namespace


AsISaveOptions Property

Aspose.Slides Documentation

IPdfOptions.AsISaveOptions Property

[Visual Basic]
Property AsISaveOptions As ISaveOptions
[C#]
ISaveOptions AsISaveOptions {get;}

See Also

IPdfOptions Interface | Aspose.Slides.Export Namespace


Compliance Property

Aspose.Slides Documentation

IPdfOptions.Compliance Property

[Visual Basic]
Property Compliance As PdfCompliance
[C#]
PdfCompliance Compliance {get; set;}

See Also

IPdfOptions Interface | Aspose.Slides.Export Namespace


EmbedFullFonts Property

Aspose.Slides Documentation

IPdfOptions.EmbedFullFonts Property

[Visual Basic]
Property EmbedFullFonts As Boolean
[C#]
bool EmbedFullFonts {get; set;}

See Also

IPdfOptions Interface | Aspose.Slides.Export Namespace


EmbedTrueTypeFontsForASCII Property

Aspose.Slides Documentation

IPdfOptions.EmbedTrueTypeFontsForASCII Property

[Visual Basic]
Property EmbedTrueTypeFontsForASCII As Boolean
[C#]
bool EmbedTrueTypeFontsForASCII {get; set;}

See Also

IPdfOptions Interface | Aspose.Slides.Export Namespace


JpegQuality Property

Aspose.Slides Documentation

IPdfOptions.JpegQuality Property

[Visual Basic]
Property JpegQuality As Byte
[C#]
byte JpegQuality {get; set;}

See Also

IPdfOptions Interface | Aspose.Slides.Export Namespace


Password Property

Aspose.Slides Documentation

IPdfOptions.Password Property

[Visual Basic]
Property Password As String
[C#]
string Password {get; set;}

See Also

IPdfOptions Interface | Aspose.Slides.Export Namespace


SaveMetafilesAsPng Property

Aspose.Slides Documentation

IPdfOptions.SaveMetafilesAsPng Property

[Visual Basic]
Property SaveMetafilesAsPng As Boolean
[C#]
bool SaveMetafilesAsPng {get; set;}

See Also

IPdfOptions Interface | Aspose.Slides.Export Namespace


SufficientResolution Property

Aspose.Slides Documentation

IPdfOptions.SufficientResolution Property

[Visual Basic]
Property SufficientResolution As Single
[C#]
float SufficientResolution {get; set;}

See Also

IPdfOptions Interface | Aspose.Slides.Export Namespace


TextCompression Property

Aspose.Slides Documentation

IPdfOptions.TextCompression Property

[Visual Basic]
Property TextCompression As PdfTextCompression
[C#]
PdfTextCompression TextCompression {get; set;}

See Also

IPdfOptions Interface | Aspose.Slides.Export Namespace


IPptOptions Interface

For a list of all members of this type, see IPptOptions Members.

[Visual Basic]
Public Interface IPptOptions
Implements ISaveOptions
[C#]
public interface IPptOptions : ISaveOptions

Types that implement IPptOptions

Type | Description
PptOptions | Provides options that control how a presentation is saved in PPT format.

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPptOptions Members | Aspose.Slides.Export Namespace


IPptOptions Members

IPptOptions overview

Public Instance Properties

AsISaveOptions

See Also

IPptOptions Interface | Aspose.Slides.Export Namespace


IPptOptions Properties

The properties of the IPptOptions interface are listed below. For a complete list of IPptOptions interface members, see the IPptOptions Members topic.

Public Instance Properties

AsISaveOptions

See Also

IPptOptions Interface | Aspose.Slides.Export Namespace


AsISaveOptions Property

Aspose.Slides Documentation

IPptOptions.AsISaveOptions Property

[Visual Basic]
Property AsISaveOptions As ISaveOptions
[C#]
ISaveOptions AsISaveOptions {get;}

See Also

IPptOptions Interface | Aspose.Slides.Export Namespace


IPptxOptions Interface

For a list of all members of this type, see IPptxOptions Members.

[Visual Basic]
Public Interface IPptxOptions
Implements ISaveOptions
[C#]
public interface IPptxOptions : ISaveOptions

Types that implement IPptxOptions

Type | Description
PptxOptions | Represents options for saving OpenXml presentations (PPTX, PPSX, POTX, PPTM, PPSM, POTM).

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPptxOptions Members | Aspose.Slides.Export Namespace


IPptxOptions Members

IPptxOptions overview

Public Instance Properties

AsISaveOptions

See Also

IPptxOptions Interface | Aspose.Slides.Export Namespace


IPptxOptions Properties

The properties of the IPptxOptions interface are listed below. For a complete list of IPptxOptions interface members, see the IPptxOptions Members topic.

Public Instance Properties

AsISaveOptions

See Also

IPptxOptions Interface | Aspose.Slides.Export Namespace


AsISaveOptions Property

Aspose.Slides Documentation

IPptxOptions.AsISaveOptions Property

[Visual Basic]
Property AsISaveOptions As ISaveOptions
[C#]
ISaveOptions AsISaveOptions {get;}

See Also

IPptxOptions Interface | Aspose.Slides.Export Namespace


ISaveOptions Interface

For a list of all members of this type, see ISaveOptions Members.

Aspose.Slides.Export.ISaveOptions
Derived interfaces

[Visual Basic]
Public Interface ISaveOptions
[C#]
public interface ISaveOptions

Types that implement ISaveOptions

Type | Description
HtmlOptions | Represents a HTML exporting options.
PdfOptions | Provides options that control how a presentation is saved in Pdf format.
PptOptions | Provides options that control how a presentation is saved in PPT format.
PptxOptions | Represents options for saving OpenXml presentations (PPTX, PPSX, POTX, PPTM, PPSM, POTM).
SaveOptions | Abstract class with options that control how a presentation is saved.
SVGOptions | Represents an SVG options.
TiffOptions | Provides options that control how a presentation is saved in TIFF format.
XpsOptions | Provides options that control how a presentation is saved in XPS format.

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISaveOptions Members | Aspose.Slides.Export Namespace


ISaveOptions Members

ISaveOptions overview

Public Instance Properties

WarningCallback

See Also

ISaveOptions Interface | Aspose.Slides.Export Namespace


ISaveOptions Properties

The properties of the ISaveOptions interface are listed below. For a complete list of ISaveOptions interface members, see the ISaveOptions Members topic.

Public Instance Properties

WarningCallback

See Also

ISaveOptions Interface | Aspose.Slides.Export Namespace


WarningCallback Property

Aspose.Slides Documentation

ISaveOptions.WarningCallback Property

[Visual Basic]
Property WarningCallback As IWarningCallback
[C#]
IWarningCallback WarningCallback {get; set;}

See Also

ISaveOptions Interface | Aspose.Slides.Export Namespace


ISaveOptionsFactory Interface

For a list of all members of this type, see ISaveOptionsFactory Members.

[Visual Basic]
Public Interface ISaveOptionsFactory
[C#]
public interface ISaveOptionsFactory

Types that implement ISaveOptionsFactory

Type | Description
SaveOptionsFactory |

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISaveOptionsFactory Members | Aspose.Slides.Export Namespace


ISaveOptionsFactory Members

ISaveOptionsFactory overview

Public Instance Methods

CreatePptxOptions

See Also

ISaveOptionsFactory Interface | Aspose.Slides.Export Namespace


ISaveOptionsFactory Methods

The methods of the ISaveOptionsFactory interface are listed below. For a complete list of ISaveOptionsFactory interface members, see the ISaveOptionsFactory Members topic.

Public Instance Methods

CreatePptxOptions

See Also

ISaveOptionsFactory Interface | Aspose.Slides.Export Namespace


ISaveOptionsFactory.CreatePptxOptions Method

[Visual Basic]
Function CreatePptxOptions() As IPptxOptions
[C#]
IPptxOptions CreatePptxOptions();

See Also

ISaveOptionsFactory Interface | Aspose.Slides.Export Namespace


ISlideImageFormat Interface

[Visual Basic]
Public Interface ISlideImageFormat
[C#]
public interface ISlideImageFormat

Types that implement ISlideImageFormat

Type | Description
SlideImageFormat | Determines format in which slide image will be saved for presentation to HTML export.

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Export Namespace


ISVGOptions Interface

For a list of all members of this type, see ISVGOptions Members.

[Visual Basic]
Public Interface ISVGOptions
Implements ISaveOptions
[C#]
public interface ISVGOptions : ISaveOptions

Types that implement ISVGOptions

Type | Description
SVGOptions | Represents an SVG options.

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISVGOptions Members | Aspose.Slides.Export Namespace


ISVGOptions Members

ISVGOptions overview

Public Instance Properties

AsISaveOptions
Disable3DText
DisableGradientSplit
DisableLineEndCropping
JpegQuality
MetafileRasterizationDpi
ShapeFormattingController
VectorizeText

See Also

ISVGOptions Interface | Aspose.Slides.Export Namespace


ISVGOptions Properties

The properties of the ISVGOptions interface are listed below. For a complete list of ISVGOptions interface members, see the ISVGOptions Members topic.

Public Instance Properties

AsISaveOptions
Disable3DText
DisableGradientSplit
DisableLineEndCropping
JpegQuality
MetafileRasterizationDpi
ShapeFormattingController
VectorizeText

See Also

ISVGOptions Interface | Aspose.Slides.Export Namespace


AsISaveOptions Property

Aspose.Slides Documentation

ISVGOptions.AsISaveOptions Property

[Visual Basic]
Property AsISaveOptions As ISaveOptions
[C#]
ISaveOptions AsISaveOptions {get;}

See Also

ISVGOptions Interface | Aspose.Slides.Export Namespace


Disable3DText Property

Aspose.Slides Documentation

ISVGOptions.Disable3DText Property

[Visual Basic]
Property Disable3DText As Boolean
[C#]
bool Disable3DText {get; set;}

See Also

ISVGOptions Interface | Aspose.Slides.Export Namespace


DisableGradientSplit Property

Aspose.Slides Documentation

ISVGOptions.DisableGradientSplit Property

[Visual Basic]
Property DisableGradientSplit As Boolean
[C#]
bool DisableGradientSplit {get; set;}

See Also

ISVGOptions Interface | Aspose.Slides.Export Namespace


DisableLineEndCropping Property

Aspose.Slides Documentation

ISVGOptions.DisableLineEndCropping Property

[Visual Basic]
Property DisableLineEndCropping As Boolean
[C#]
bool DisableLineEndCropping {get; set;}

See Also

ISVGOptions Interface | Aspose.Slides.Export Namespace


JpegQuality Property

Aspose.Slides Documentation

ISVGOptions.JpegQuality Property

[Visual Basic]
Property JpegQuality As Integer
[C#]
int JpegQuality {get; set;}

See Also

ISVGOptions Interface | Aspose.Slides.Export Namespace


MetafileRasterizationDpi Property

Aspose.Slides Documentation

ISVGOptions.MetafileRasterizationDpi Property

[Visual Basic]
Property MetafileRasterizationDpi As Integer
[C#]
int MetafileRasterizationDpi {get; set;}

See Also

ISVGOptions Interface | Aspose.Slides.Export Namespace


ShapeFormattingController Property

Aspose.Slides Documentation

ISVGOptions.ShapeFormattingController Property

[Visual Basic]
Property ShapeFormattingController As ISvgShapeFormattingController
[C#]
ISvgShapeFormattingController ShapeFormattingController {get; set;}

See Also

ISVGOptions Interface | Aspose.Slides.Export Namespace


VectorizeText Property

Aspose.Slides Documentation

ISVGOptions.VectorizeText Property

[Visual Basic]
Property VectorizeText As Boolean
[C#]
bool VectorizeText {get; set;}

See Also

ISVGOptions Interface | Aspose.Slides.Export Namespace


ISvgShape Interface

For a list of all members of this type, see ISvgShape Members.

[Visual Basic]
Public Interface ISvgShape
[C#]
public interface ISvgShape

Types that implement ISvgShape

Type | Description
SvgShape | Represents options for SVG shape.

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISvgShape Members | Aspose.Slides.Export Namespace


ISvgShape Members

ISvgShape overview

Public Instance Methods

SetEventHandler

See Also

ISvgShape Interface | Aspose.Slides.Export Namespace


ISvgShape Methods

The methods of the ISvgShape interface are listed below. For a complete list of ISvgShape interface members, see the ISvgShape Members topic.

Public Instance Methods

SetEventHandler

See Also

ISvgShape Interface | Aspose.Slides.Export Namespace


ISvgShape.SetEventHandler Method

[Visual Basic]
Sub SetEventHandler( _
ByVal eventType As SvgEvent, _
ByVal handler As String _
)
[C#]
void SetEventHandler(
SvgEvent eventType,
string handler
);

See Also

ISvgShape Interface | Aspose.Slides.Export Namespace


ISvgShapeFormattingController Interface

For a list of all members of this type, see ISvgShapeFormattingController Members.

[Visual Basic]
Public Interface ISvgShapeFormattingController
[C#]
public interface ISvgShapeFormattingController

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISvgShapeFormattingController Members | Aspose.Slides.Export Namespace


ISvgShapeFormattingController Members

ISvgShapeFormattingController overview

Public Instance Methods

FormatShape

See Also

ISvgShapeFormattingController Interface | Aspose.Slides.Export Namespace


ISvgShapeFormattingController Methods

The methods of the ISvgShapeFormattingController interface are listed below. For a complete list of ISvgShapeFormattingController interface members, see the ISvgShapeFormattingController Members topic.

Public Instance Methods

FormatShape

See Also

ISvgShapeFormattingController Interface | Aspose.Slides.Export Namespace


ISvgShapeFormattingController.FormatShape Method

[Visual Basic]
Sub FormatShape( _
ByVal svgShape As ISvgShape, _
ByVal shape As IShape _
)
[C#]
void FormatShape(
ISvgShape svgShape,
IShape shape
);

See Also

ISvgShapeFormattingController Interface | Aspose.Slides.Export Namespace


ITextToHtmlConversionOptions Interface

For a list of all members of this type, see ITextToHtmlConversionOptions Members.

[Visual Basic]
Public Interface ITextToHtmlConversionOptions
[C#]
public interface ITextToHtmlConversionOptions

Types that implement ITextToHtmlConversionOptions

Type | Description
TextToHtmlConversionOptions | Options for extracting HTML from the Pptx text.

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITextToHtmlConversionOptions Members | Aspose.Slides.Export Namespace


ITextToHtmlConversionOptions Members

ITextToHtmlConversionOptions overview

Public Instance Properties

AddClipboardFragmentHeader
EncodingName
LinkEmbedController
TextInheritanceLimit

See Also

ITextToHtmlConversionOptions Interface | Aspose.Slides.Export Namespace


ITextToHtmlConversionOptions Properties

The properties of the ITextToHtmlConversionOptions interface are listed below. For a complete list of ITextToHtmlConversionOptions interface members, see the ITextToHtmlConversionOptions Members topic.

Public Instance Properties

AddClipboardFragmentHeader
EncodingName
LinkEmbedController
TextInheritanceLimit

See Also

ITextToHtmlConversionOptions Interface | Aspose.Slides.Export Namespace


AddClipboardFragmentHeader Property

Aspose.Slides Documentation

ITextToHtmlConversionOptions.AddClipboardFragmentHeader Property

[Visual Basic]
Property AddClipboardFragmentHeader As Boolean
[C#]
bool AddClipboardFragmentHeader {get; set;}

See Also

ITextToHtmlConversionOptions Interface | Aspose.Slides.Export Namespace


EncodingName Property

Aspose.Slides Documentation

ITextToHtmlConversionOptions.EncodingName Property

[Visual Basic]
Property EncodingName As String
[C#]
string EncodingName {get; set;}

See Also

ITextToHtmlConversionOptions Interface | Aspose.Slides.Export Namespace


LinkEmbedController Property

Aspose.Slides Documentation

ITextToHtmlConversionOptions.LinkEmbedController Property

[Visual Basic]
Property LinkEmbedController As ILinkEmbedController
[C#]
ILinkEmbedController LinkEmbedController {get; set;}

See Also

ITextToHtmlConversionOptions Interface | Aspose.Slides.Export Namespace


TextInheritanceLimit Property

Aspose.Slides Documentation

ITextToHtmlConversionOptions.TextInheritanceLimit Property

[Visual Basic]
Property TextInheritanceLimit As TextInheritanceLimit
[C#]
TextInheritanceLimit TextInheritanceLimit {get; set;}

See Also

ITextToHtmlConversionOptions Interface | Aspose.Slides.Export Namespace


ITiffOptions Interface

For a list of all members of this type, see ITiffOptions Members.

[Visual Basic]
Public Interface ITiffOptions
Implements ISaveOptions
[C#]
public interface ITiffOptions : ISaveOptions

Types that implement ITiffOptions

Type | Description
TiffOptions | Provides options that control how a presentation is saved in TIFF format.

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITiffOptions Members | Aspose.Slides.Export Namespace


ITiffOptions Members

ITiffOptions overview

Public Instance Properties

AsISaveOptions
CompressionType
DpiX
DpiY
ImageSize

See Also

ITiffOptions Interface | Aspose.Slides.Export Namespace


ITiffOptions Properties

The properties of the ITiffOptions interface are listed below. For a complete list of ITiffOptions interface members, see the ITiffOptions Members topic.

Public Instance Properties

AsISaveOptions
CompressionType
DpiX
DpiY
ImageSize

See Also

ITiffOptions Interface | Aspose.Slides.Export Namespace


AsISaveOptions Property

Aspose.Slides Documentation

ITiffOptions.AsISaveOptions Property

[Visual Basic]
Property AsISaveOptions As ISaveOptions
[C#]
ISaveOptions AsISaveOptions {get;}

See Also

ITiffOptions Interface | Aspose.Slides.Export Namespace


CompressionType Property

Aspose.Slides Documentation

ITiffOptions.CompressionType Property

[Visual Basic]
Property CompressionType As TiffCompressionTypes
[C#]
TiffCompressionTypes CompressionType {get; set;}

See Also

ITiffOptions Interface | Aspose.Slides.Export Namespace


DpiX Property

Aspose.Slides Documentation

ITiffOptions.DpiX Property

[Visual Basic]
Property DpiX As UInt32
[C#]
uint DpiX {get; set;}

See Also

ITiffOptions Interface | Aspose.Slides.Export Namespace


DpiY Property

Aspose.Slides Documentation

ITiffOptions.DpiY Property

[Visual Basic]
Property DpiY As UInt32
[C#]
uint DpiY {get; set;}

See Also

ITiffOptions Interface | Aspose.Slides.Export Namespace


ImageSize Property

Aspose.Slides Documentation

ITiffOptions.ImageSize Property

[Visual Basic]
Property ImageSize As Size
[C#]
Size ImageSize {get; set;}

See Also

ITiffOptions Interface | Aspose.Slides.Export Namespace


IXpsOptions Interface

For a list of all members of this type, see IXpsOptions Members.

[Visual Basic]
Public Interface IXpsOptions
Implements ISaveOptions
[C#]
public interface IXpsOptions : ISaveOptions

Types that implement IXpsOptions

Type | Description
XpsOptions | Provides options that control how a presentation is saved in XPS format.

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IXpsOptions Members | Aspose.Slides.Export Namespace


IXpsOptions Members

IXpsOptions overview

Public Instance Properties

AsISaveOptions
SaveMetafilesAsPng

See Also

IXpsOptions Interface | Aspose.Slides.Export Namespace


IXpsOptions Properties

The properties of the IXpsOptions interface are listed below. For a complete list of IXpsOptions interface members, see the IXpsOptions Members topic.

Public Instance Properties

AsISaveOptions
SaveMetafilesAsPng

See Also

IXpsOptions Interface | Aspose.Slides.Export Namespace


AsISaveOptions Property

Aspose.Slides Documentation

IXpsOptions.AsISaveOptions Property

[Visual Basic]
Property AsISaveOptions As ISaveOptions
[C#]
ISaveOptions AsISaveOptions {get;}

See Also

IXpsOptions Interface | Aspose.Slides.Export Namespace


SaveMetafilesAsPng Property

Aspose.Slides Documentation

IXpsOptions.SaveMetafilesAsPng Property

[Visual Basic]
Property SaveMetafilesAsPng As Boolean
[C#]
bool SaveMetafilesAsPng {get; set;}

See Also

IXpsOptions Interface | Aspose.Slides.Export Namespace


LinkEmbedDecision Enumeration

[Visual Basic]
Public Enum LinkEmbedDecision
[C#]
public enum LinkEmbedDecision

Members

Member Name | Description | Value
Link |  | 0
Embed |  | 1
Ignore |  | 2

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Export Namespace


PdfCompliance Enumeration

[Visual Basic]
Public Enum PdfCompliance
[C#]
public enum PdfCompliance

Members

Member Name | Description | Value
Pdf15 |  | 0
PdfA1b |  | 1

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Export Namespace


PdfOptions Class

Provides options that control how a presentation is saved in Pdf format.

For a list of all members of this type, see PdfOptions Members.

System.Object
Aspose.Slides.Export.SaveOptions
Aspose.Slides.Export.PdfOptions

[Visual Basic]
Public Class PdfOptions
Inherits SaveOptions
Implements IPdfOptions
[C#]
public class PdfOptions : SaveOptions, IPdfOptions

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PdfOptions Members | Aspose.Slides.Export Namespace


PdfOptions Members

PdfOptions overview

Public Instance Constructors

PdfOptions Constructor Default constructor.

Public Instance Properties

AdditionalCommonFontFamilies | Returns or sets an array of user-defined names of font families which Aspose.Slides should consider common.
Compliance | Desired conformance level for generated PDF document.
EmbedFullFonts | Determines if all characters of font should be embedded or only used subset.
EmbedTrueTypeFontsForASCII | Determines if Aspose.Slides will embed common fonts for ASCII (33..127 code range) text. Fonts for character codes greater than 127 are always embedded. Common fonts list includes PDF's base 14 fonts and additional user specified fonts.
JpegQuality | Returns or sets a value determining the quality of the JPEG images inside PDF document.
Password | Setting user password to protect the PDF document.
SaveMetafilesAsPng | True to convert all metafiles used in a presentation to the PNG images.
SufficientResolution | Returns or sets a value determining resolution of images inside PDF document. Property affects on file size, time of export and image quality. The default value is 96. Effect of this parameter depends on few factors. Algorithm tries to get best output image size according to the property value, source image size and image frame size. Using of similar property values may give the same result. Recommended to use step 16 or 32 to get visible effect.
TextCompression | Specifies compression type to be used for all textual content in the document.
WarningCallback (inherited from SaveOptions) | Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

PdfOptions Class | Aspose.Slides.Export Namespace


PdfOptions Constructor

Default constructor.

[Visual Basic]
Public Sub New()
[C#]
public PdfOptions();

See Also

PdfOptions Class | Aspose.Slides.Export Namespace


PdfOptions Properties

The properties of the PdfOptions class are listed below. For a complete list of PdfOptions class members, see the PdfOptions Members topic.

Public Instance Properties

AdditionalCommonFontFamilies | Returns or sets an array of user-defined names of font families which Aspose.Slides should consider common.
Compliance | Desired conformance level for generated PDF document.
EmbedFullFonts | Determines if all characters of font should be embedded or only used subset.
EmbedTrueTypeFontsForASCII | Determines if Aspose.Slides will embed common fonts for ASCII (33..127 code range) text. Fonts for character codes greater than 127 are always embedded. Common fonts list includes PDF's base 14 fonts and additional user specified fonts.
JpegQuality | Returns or sets a value determining the quality of the JPEG images inside PDF document.
Password | Setting user password to protect the PDF document.
SaveMetafilesAsPng | True to convert all metafiles used in a presentation to the PNG images.
SufficientResolution | Returns or sets a value determining resolution of images inside PDF document. Property affects on file size, time of export and image quality. The default value is 96. Effect of this parameter depends on few factors. Algorithm tries to get best output image size according to the property value, source image size and image frame size. Using of similar property values may give the same result. Recommended to use step 16 or 32 to get visible effect.
TextCompression | Specifies compression type to be used for all textual content in the document.
WarningCallback (inherited from SaveOptions) | Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

PdfOptions Class | Aspose.Slides.Export Namespace


AdditionalCommonFontFamilies Property

Aspose.Slides Documentation

PdfOptions.AdditionalCommonFontFamilies Property

Returns or sets an array of user-defined names of font families which Aspose.Slides should consider common.

[Visual Basic]
NotOverridable Public Property AdditionalCommonFontFamilies As String() _
Implements IPdfOptions.AdditionalCommonFontFamilies
[C#]
public string[] AdditionalCommonFontFamilies {get; set;}

Implements

IPdfOptions.AdditionalCommonFontFamilies

See Also

PdfOptions Class | Aspose.Slides.Export Namespace


Compliance Property

Aspose.Slides Documentation

PdfOptions.Compliance Property

Desired conformance level for generated PDF document.

[Visual Basic]
NotOverridable Public Property Compliance As PdfCompliance _
Implements IPdfOptions.Compliance
[C#]
public PdfCompliance Compliance {get; set;}

Implements

IPdfOptions.Compliance

Remarks

Default is Pdf15.

See Also

PdfOptions Class | Aspose.Slides.Export Namespace


EmbedFullFonts Property

Aspose.Slides Documentation

PdfOptions.EmbedFullFonts Property

Determines if all characters of font should be embedded or only used subset.

[Visual Basic]
NotOverridable Public Property EmbedFullFonts As Boolean _
Implements IPdfOptions.EmbedFullFonts
[C#]
public bool EmbedFullFonts {get; set;}

Implements

IPdfOptions.EmbedFullFonts

Remarks

Default is false.

See Also

PdfOptions Class | Aspose.Slides.Export Namespace


EmbedTrueTypeFontsForASCII Property

Aspose.Slides Documentation

PdfOptions.EmbedTrueTypeFontsForASCII Property

Determines if Aspose.Slides will embed common fonts for ASCII (33..127 code range) text. Fonts for character codes greater than 127 are always embedded. Common fonts list includes PDF's base 14 fonts and additional user specified fonts.

[Visual Basic]
NotOverridable Public Property EmbedTrueTypeFontsForASCII As Boolean _
Implements IPdfOptions.EmbedTrueTypeFontsForASCII
[C#]
public bool EmbedTrueTypeFontsForASCII {get; set;}

Implements

IPdfOptions.EmbedTrueTypeFontsForASCII

Remarks

Default is true.

See Also

PdfOptions Class | Aspose.Slides.Export Namespace


JpegQuality Property

Aspose.Slides Documentation

PdfOptions.JpegQuality Property

Returns or sets a value determining the quality of the JPEG images inside PDF document.

[Visual Basic]
NotOverridable Public Property JpegQuality As Byte _
Implements IPdfOptions.JpegQuality
[C#]
public byte JpegQuality {get; set;}

Implements

IPdfOptions.JpegQuality

Remarks

Has effect only when a document contains JPEG images.

Use this property to get or set the quality of the images inside a document when saving in PDF format. The value may vary from 0 to 100 where 0 means worst quality but maximum compression and 100 means best quality but minimum compression.

The default value is 100.

See Also

PdfOptions Class | Aspose.Slides.Export Namespace


Password Property

Aspose.Slides Documentation

PdfOptions.Password Property

Setting user password to protect the PDF document.

[Visual Basic]
NotOverridable Public Property Password As String _
Implements IPdfOptions.Password
[C#]
public string Password {get; set;}

Implements

IPdfOptions.Password

See Also

PdfOptions Class | Aspose.Slides.Export Namespace


SaveMetafilesAsPng Property

Aspose.Slides Documentation

PdfOptions.SaveMetafilesAsPng Property

True to convert all metafiles used in a presentation to the PNG images.

[Visual Basic]
NotOverridable Public Property SaveMetafilesAsPng As Boolean _
Implements IPdfOptions.SaveMetafilesAsPng
[C#]
public bool SaveMetafilesAsPng {get; set;}

Implements

IPdfOptions.SaveMetafilesAsPng

Remarks

Default is true.

See Also

PdfOptions Class | Aspose.Slides.Export Namespace


SufficientResolution Property

Aspose.Slides Documentation

PdfOptions.SufficientResolution Property

Returns or sets a value determining resolution of images inside PDF document.

Property affects on file size, time of export and image quality.

The default value is 96.

Effect of this parameter depends on few factors. Algorithm tries to get best output image size according to the property value, source image size and image frame size. Using of similar property values may give the same result. Recommended to use step 16 or 32 to get visible effect.

[Visual Basic]
NotOverridable Public Property SufficientResolution As Single _
Implements IPdfOptions.SufficientResolution
[C#]
public float SufficientResolution {get; set;}

Implements

IPdfOptions.SufficientResolution

See Also

PdfOptions Class | Aspose.Slides.Export Namespace


TextCompression Property

Aspose.Slides Documentation

PdfOptions.TextCompression Property

Specifies compression type to be used for all textual content in the document.

[Visual Basic]
NotOverridable Public Property TextCompression As PdfTextCompression _
Implements IPdfOptions.TextCompression
[C#]
public PdfTextCompression TextCompression {get; set;}

Implements

IPdfOptions.TextCompression

Remarks

Default is Flate.

See Also

PdfOptions Class | Aspose.Slides.Export Namespace


PdfTextCompression Enumeration

[Visual Basic]
Public Enum PdfTextCompression
[C#]
public enum PdfTextCompression

Members

Member Name | Description | Value
None |  | 0
Flate |  | 1

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Export Namespace


PptOptions Class

Provides options that control how a presentation is saved in PPT format.

For a list of all members of this type, see PptOptions Members.

System.Object
Aspose.Slides.Export.SaveOptions
Aspose.Slides.Export.PptOptions

[Visual Basic]
Public Class PptOptions
Inherits SaveOptions
Implements IPptOptions
[C#]
public class PptOptions : SaveOptions, IPptOptions

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PptOptions Members | Aspose.Slides.Export Namespace


PptOptions Members

PptOptions overview

Public Instance Constructors

PptOptions Constructor Initializes a new instance of the PptOptions class.

Public Instance Properties

WarningCallback (inherited from SaveOptions) Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

PptOptions Class | Aspose.Slides.Export Namespace


PptOptions Constructor

Initializes a new instance of the PptOptions class.

[Visual Basic]
Public Sub New()
[C#]
public PptOptions();

See Also

PptOptions Class | Aspose.Slides.Export Namespace


PptxOptions Class

Represents options for saving OpenXml presentations (PPTX, PPSX, POTX, PPTM, PPSM, POTM).

For a list of all members of this type, see PptxOptions Members.

System.Object
Aspose.Slides.Export.SaveOptions
Aspose.Slides.Export.PptxOptions

[Visual Basic]
NotInheritable Public Class PptxOptions
Inherits SaveOptions
Implements IPptxOptions
[C#]
public sealed class PptxOptions : SaveOptions, IPptxOptions

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PptxOptions Members | Aspose.Slides.Export Namespace


PptxOptions Members

PptxOptions overview

Public Instance Constructors

PptxOptions Constructor Creates new instance of PptxOptions

Public Instance Properties

WarningCallback (inherited from SaveOptions) Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

PptxOptions Class | Aspose.Slides.Export Namespace


PptxOptions Constructor

Creates new instance of PptxOptions

[Visual Basic]
Public Sub New()
[C#]
public PptxOptions();

See Also

PptxOptions Class | Aspose.Slides.Export Namespace


PresentationPrintDocument Class

Provides a default implementation for printing of a Presentation within the .NET printing framework.

For a list of all members of this type, see PresentationPrintDocument Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Drawing.Printing.PrintDocument
Aspose.Slides.Export.PresentationPrintDocument

[Visual Basic]
Public Class PresentationPrintDocument
Inherits PrintDocument
[C#]
public class PresentationPrintDocument : PrintDocument

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PresentationPrintDocument Members | Aspose.Slides.Export Namespace


PresentationPrintDocument Members

PresentationPrintDocument overview

Public Instance Constructors

PresentationPrintDocument Constructor Creates PresentationPrintDocument for a PPTX presentation.

See Also

PresentationPrintDocument Class | Aspose.Slides.Export Namespace


PresentationPrintDocument Constructor

Creates PresentationPrintDocument for a PPTX presentation.

[Visual Basic]
Public Sub New( _
ByVal presentation As Presentation _
)
[C#]
public PresentationPrintDocument(
Presentation presentation
);

Parameters

presentation
PPTX presentation.

See Also

PresentationPrintDocument Class | Aspose.Slides.Export Namespace


SaveFormat Enumeration

[Visual Basic]
Public Enum SaveFormat
[C#]
public enum SaveFormat

Members

Member Name | Description | Value
Ppt |  | 0
Pps |  | 0
Pdf |  | 1
Xps |  | 2
Pptx |  | 3
Ppsx |  | 4
Tiff |  | 5
Odp |  | 6
Pptm |  | 7
Ppsm |  | 9
Potx |  | 10
Potm |  | 11
PdfNotes |  | 12
Html |  | 13
TiffNotes |  | 14

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Export Namespace


SaveOptions Class

Abstract class with options that control how a presentation is saved.

For a list of all members of this type, see SaveOptions Members.

System.Object
Aspose.Slides.Export.SaveOptions
Derived types

[Visual Basic]
MustInherit Public Class SaveOptions
Implements ISaveOptions
[C#]
public abstract class SaveOptions : ISaveOptions

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SaveOptions Members | Aspose.Slides.Export Namespace


SaveOptions Members

SaveOptions overview

Public Instance Properties

WarningCallback Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

SaveOptions Class | Aspose.Slides.Export Namespace


SaveOptions Properties

The properties of the SaveOptions class are listed below. For a complete list of SaveOptions class members, see the SaveOptions Members topic.

Public Instance Properties

WarningCallback Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

SaveOptions Class | Aspose.Slides.Export Namespace


WarningCallback Property

Aspose.Slides Documentation

SaveOptions.WarningCallback Property

Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

[Visual Basic]
NotOverridable Public Property WarningCallback As IWarningCallback _
Implements ISaveOptions.WarningCallback
[C#]
public IWarningCallback WarningCallback {get; set;}

Implements

ISaveOptions.WarningCallback

See Also

SaveOptions Class | Aspose.Slides.Export Namespace


SaveOptionsFactory Class

For a list of all members of this type, see SaveOptionsFactory Members.

System.Object
Aspose.Slides.Export.SaveOptionsFactory

[Visual Basic]
Public Class SaveOptionsFactory
Implements ISaveOptionsFactory
[C#]
public class SaveOptionsFactory : ISaveOptionsFactory

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SaveOptionsFactory Members | Aspose.Slides.Export Namespace


SaveOptionsFactory Members

SaveOptionsFactory overview

Public Instance Constructors

SaveOptionsFactory Constructor Initializes a new instance of the SaveOptionsFactory class.

Public Instance Methods

CreatePptxOptions

See Also

SaveOptionsFactory Class | Aspose.Slides.Export Namespace


SaveOptionsFactory Constructor

Initializes a new instance of the SaveOptionsFactory class.

[Visual Basic]
Public Sub New()
[C#]
public SaveOptionsFactory();

See Also

SaveOptionsFactory Class | Aspose.Slides.Export Namespace


SaveOptionsFactory Methods

The methods of the SaveOptionsFactory class are listed below. For a complete list of SaveOptionsFactory class members, see the SaveOptionsFactory Members topic.

Public Instance Methods

CreatePptxOptions

See Also

SaveOptionsFactory Class | Aspose.Slides.Export Namespace


SaveOptionsFactory.CreatePptxOptions Method

[Visual Basic]
NotOverridable Public Function CreatePptxOptions() As IPptxOptions _
Implements ISaveOptionsFactory.CreatePptxOptions
[C#]
public IPptxOptions CreatePptxOptions();

Implements

ISaveOptionsFactory.CreatePptxOptions

See Also

SaveOptionsFactory Class | Aspose.Slides.Export Namespace


SlideImageFormat Class

Determines format in which slide image will be saved for presentation to HTML export.

For a list of all members of this type, see SlideImageFormat Members.

System.Object
Aspose.Slides.Export.SlideImageFormat

[Visual Basic]
Public Class SlideImageFormat
Implements ISlideImageFormat
[C#]
public class SlideImageFormat : ISlideImageFormat

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SlideImageFormat Members | Aspose.Slides.Export Namespace


SlideImageFormat Members

SlideImageFormat overview

Public Static (Shared) Methods

Bitmap | Slides should be converted to a raster image.
Svg | Slides should converted to a SVG format.

Public Instance Constructors

SlideImageFormat Constructor Initializes a new instance of the SlideImageFormat class.

See Also

SlideImageFormat Class | Aspose.Slides.Export Namespace


SlideImageFormat Constructor

Initializes a new instance of the SlideImageFormat class.

[Visual Basic]
Public Sub New()
[C#]
public SlideImageFormat();

See Also

SlideImageFormat Class | Aspose.Slides.Export Namespace


SlideImageFormat Methods

The methods of the SlideImageFormat class are listed below. For a complete list of SlideImageFormat class members, see the SlideImageFormat Members topic.

Public Static (Shared) Methods

Bitmap | Slides should be converted to a raster image.
Svg | Slides should converted to a SVG format.

See Also

SlideImageFormat Class | Aspose.Slides.Export Namespace


SlideImageFormat.Bitmap Method

Slides should be converted to a raster image.

[Visual Basic]
Public Shared Function Bitmap( _
ByVal scale As Single, _
ByVal imgFormat As ImageFormat _
) As SlideImageFormat
[C#]
public static SlideImageFormat Bitmap(
float scale,
ImageFormat imgFormat
);

Parameters

scale
Image scale factor.
imgFormat
Image format.

Return Value

See Also

SlideImageFormat Class | Aspose.Slides.Export Namespace


SlideImageFormat.Svg Method

Slides should converted to a SVG format.

[Visual Basic]
Public Shared Function Svg( _
ByVal options As SVGOptions _
) As SlideImageFormat
[C#]
public static SlideImageFormat Svg(
SVGOptions options
);

Parameters

options
Options for SVG export.

Return Value

See Also

SlideImageFormat Class | Aspose.Slides.Export Namespace


SvgCoordinateUnit Enumeration

[Visual Basic]
Public Enum SvgCoordinateUnit
[C#]
public enum SvgCoordinateUnit

Members

Member Name | Description | Value
Inch |  | 0
Centimeter |  | 1
Millimeter |  | 2
Point |  | 3
Pica |  | 4
Em |  | 5
Ex |  | 6
Pixel |  | 7
Percent |  | 8

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Export Namespace


SvgEvent Enumeration

[Visual Basic]
Public Enum SvgEvent
[C#]
public enum SvgEvent

Members

Member Name | Description | Value
OnFocusIn |  | 0
OnFocusOut |  | 1
OnActivate |  | 2
OnClick |  | 3
OnMouseDown |  | 4
OnMouseUp |  | 5
OnMouseOver |  | 6
OnMouseMove |  | 7
OnMouseOut |  | 8
OnLoad |  | 9
OnUnload |  | 10
OnAbort |  | 11
OnError |  | 12
OnResize |  | 13
OnScroll |  | 14
OnZoom |  | 15
OnBegin |  | 16
OnEnd |  | 17
OnRepeat |  | 18

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Export Namespace


SVGOptions Class

Represents an SVG options.

For a list of all members of this type, see SVGOptions Members.

System.Object
Aspose.Slides.Export.SaveOptions
Aspose.Slides.Export.SVGOptions

[Visual Basic]
NotInheritable Public Class SVGOptions
Inherits SaveOptions
Implements ISVGOptions
[C#]
public sealed class SVGOptions : SaveOptions, ISVGOptions

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SVGOptions Members | Aspose.Slides.Export Namespace


SVGOptions Members

SVGOptions overview

Public Static (Shared) Properties

Default | Returns default settings.
Simple | Returns settings for simpliest and smallest SVG file generation.
WYSIWYG | Returns settings for most accurate SVG file generation.

Public Instance Constructors

SVGOptions Overloaded. Initializes a new instance of the SVGOptions class.

Public Instance Properties

Disable3DText | Determines whether the 3D text is disabled in SVG. Read/write Boolean.
DisableGradientSplit | Disables splitting FromCornerX and FromCenter gradients. Read/write Boolean.
DisableLineEndCropping | SVG 1.1 lacks ability to define insets for markers. Aspose.Slides SVG writing engine has workaround for that problem: it crops end of line with arrow, so, line doesn't overlap markers. This option switches off such behavior.
JpegQuality | Determines JPEG encoding quality
MetafileRasterizationDpi | Returns or sets the lower resolution limit for metafile rasterization. Read/write Int32.
ShapeFormattingController | Returns and sets a callback interface which allows user to control shape conversion.
VectorizeText | Determines whether the text on a slide will be saved as graphics. Read/write Boolean.
WarningCallback (inherited from SaveOptions) | Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


SVGOptions Constructor

Initializes a new instance of the SVGOptions class.

Overload List

Initializes a new instance of the SVGOptions class.

public SVGOptions();

Initializes a new instance of the SVGOptions class specifying the link embedding controller object.

public SVGOptions(ILinkEmbedController);

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


SVGOptions Constructor ()

Initializes a new instance of the SVGOptions class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SVGOptions();

See Also

SVGOptions Class | Aspose.Slides.Export Namespace | SVGOptions Constructor Overload List


SVGOptions Constructor (ILinkEmbedController)

Initializes a new instance of the SVGOptions class specifying the link embedding controller object.

[Visual Basic]
Overloads Public Sub New( _
ByVal linkEmbedController As ILinkEmbedController _
)
[C#]
public SVGOptions(
ILinkEmbedController linkEmbedController
);

Parameters

linkEmbedController
The link embedding controller reference.

Remarks

Link embedding controller is a delegate object that is responsible for making decisions if resources (such as images) need to be embedded or referenced as external resources.

See Also

SVGOptions Class | Aspose.Slides.Export Namespace | SVGOptions Constructor Overload List | ILinkEmbedController


SVGOptions Properties

The properties of the SVGOptions class are listed below. For a complete list of SVGOptions class members, see the SVGOptions Members topic.

Public Static (Shared) Properties

Default | Returns default settings.
Simple | Returns settings for simpliest and smallest SVG file generation.
WYSIWYG | Returns settings for most accurate SVG file generation.

Public Instance Properties

Disable3DText | Determines whether the 3D text is disabled in SVG. Read/write Boolean.
DisableGradientSplit | Disables splitting FromCornerX and FromCenter gradients. Read/write Boolean.
DisableLineEndCropping | SVG 1.1 lacks ability to define insets for markers. Aspose.Slides SVG writing engine has workaround for that problem: it crops end of line with arrow, so, line doesn't overlap markers. This option switches off such behavior.
JpegQuality | Determines JPEG encoding quality
MetafileRasterizationDpi | Returns or sets the lower resolution limit for metafile rasterization. Read/write Int32.
ShapeFormattingController | Returns and sets a callback interface which allows user to control shape conversion.
VectorizeText | Determines whether the text on a slide will be saved as graphics. Read/write Boolean.
WarningCallback (inherited from SaveOptions) | Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


Default Property

Aspose.Slides Documentation

SVGOptions.Default Property

Returns default settings.

[Visual Basic]
Public Shared ReadOnly Property Default As SVGOptions
[C#]
public static SVGOptions Default {get;}

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


Disable3DText Property

Aspose.Slides Documentation

SVGOptions.Disable3DText Property

Determines whether the 3D text is disabled in SVG. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property Disable3DText As Boolean _
Implements ISVGOptions.Disable3DText
[C#]
public bool Disable3DText {get; set;}

Implements

ISVGOptions.Disable3DText

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


DisableGradientSplit Property

Aspose.Slides Documentation

SVGOptions.DisableGradientSplit Property

Disables splitting FromCornerX and FromCenter gradients. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property DisableGradientSplit As Boolean _
Implements ISVGOptions.DisableGradientSplit
[C#]
public bool DisableGradientSplit {get; set;}

Implements

ISVGOptions.DisableGradientSplit

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


DisableLineEndCropping Property

Aspose.Slides Documentation

SVGOptions.DisableLineEndCropping Property

SVG 1.1 lacks ability to define insets for markers. Aspose.Slides SVG writing engine has workaround for that problem: it crops end of line with arrow, so, line doesn't overlap markers. This option switches off such behavior.

[Visual Basic]
NotOverridable Public Property DisableLineEndCropping As Boolean _
Implements ISVGOptions.DisableLineEndCropping
[C#]
public bool DisableLineEndCropping {get; set;}

Implements

ISVGOptions.DisableLineEndCropping

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


JpegQuality Property

Aspose.Slides Documentation

SVGOptions.JpegQuality Property

Determines JPEG encoding quality

[Visual Basic]
NotOverridable Public Property JpegQuality As Integer _
Implements ISVGOptions.JpegQuality
[C#]
public int JpegQuality {get; set;}

Implements

ISVGOptions.JpegQuality

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


MetafileRasterizationDpi Property

Aspose.Slides Documentation

SVGOptions.MetafileRasterizationDpi Property

Returns or sets the lower resolution limit for metafile rasterization. Read/write Int32.

[Visual Basic]
NotOverridable Public Property MetafileRasterizationDpi As Integer _
Implements ISVGOptions.MetafileRasterizationDpi
[C#]
public int MetafileRasterizationDpi {get; set;}

Implements

ISVGOptions.MetafileRasterizationDpi

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


ShapeFormattingController Property

Aspose.Slides Documentation

SVGOptions.ShapeFormattingController Property

Returns and sets a callback interface which allows user to control shape conversion.

[Visual Basic]
NotOverridable Public Property ShapeFormattingController As ISvgShapeFormattingController _
Implements ISVGOptions.ShapeFormattingController
[C#]
public ISvgShapeFormattingController ShapeFormattingController {get; set;}

Implements

ISVGOptions.ShapeFormattingController

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


Simple Property

Aspose.Slides Documentation

SVGOptions.Simple Property

Returns settings for simpliest and smallest SVG file generation.

[Visual Basic]
Public Shared ReadOnly Property Simple As SVGOptions
[C#]
public static SVGOptions Simple {get;}

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


VectorizeText Property

Aspose.Slides Documentation

SVGOptions.VectorizeText Property

Determines whether the text on a slide will be saved as graphics. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property VectorizeText As Boolean _
Implements ISVGOptions.VectorizeText
[C#]
public bool VectorizeText {get; set;}

Implements

ISVGOptions.VectorizeText

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


WYSIWYG Property

Aspose.Slides Documentation

SVGOptions.WYSIWYG Property

Returns settings for most accurate SVG file generation.

[Visual Basic]
Public Shared ReadOnly Property WYSIWYG As SVGOptions
[C#]
public static SVGOptions WYSIWYG {get;}

See Also

SVGOptions Class | Aspose.Slides.Export Namespace


SvgShape Class

Represents options for SVG shape.

For a list of all members of this type, see SvgShape Members.

System.Object
Aspose.Slides.Export.SvgShape

[Visual Basic]
NotInheritable Public Class SvgShape
Implements ISvgShape
[C#]
public sealed class SvgShape : ISvgShape

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SvgShape Members | Aspose.Slides.Export Namespace


SvgShape Members

SvgShape overview

Public Instance Methods

SetEventHandler Sets event handler for the shape

See Also

SvgShape Class | Aspose.Slides.Export Namespace


SvgShape Methods

The methods of the SvgShape class are listed below. For a complete list of SvgShape class members, see the SvgShape Members topic.

Public Instance Methods

SetEventHandler Sets event handler for the shape

See Also

SvgShape Class | Aspose.Slides.Export Namespace


SvgShape.SetEventHandler Method

Sets event handler for the shape

[Visual Basic]
NotOverridable Public Sub SetEventHandler( _
ByVal eventType As SvgEvent, _
ByVal handler As String _
) _
Implements ISvgShape.SetEventHandler
[C#]
public void SetEventHandler(
SvgEvent eventType,
string handler
);

Parameters

eventType
Type of event.
handler
Javascript function to handle event. Null value removes handler.

Implements

ISvgShape.SetEventHandler

See Also

SvgShape Class | Aspose.Slides.Export Namespace


TextInheritanceLimit Enumeration

[Visual Basic]
Public Enum TextInheritanceLimit
[C#]
public enum TextInheritanceLimit

Members

Member Name | Description | Value
All |  | 0
TextBox |  | 1
ParagraphOnly |  | 2

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Export Namespace


TextToHtmlConversionOptions Class

Options for extracting HTML from the Pptx text.

For a list of all members of this type, see TextToHtmlConversionOptions Members.

System.Object
Aspose.Slides.Export.TextToHtmlConversionOptions

[Visual Basic]
NotInheritable Public Class TextToHtmlConversionOptions
Implements ITextToHtmlConversionOptions
[C#]
public sealed class TextToHtmlConversionOptions : ITextToHtmlConversionOptions

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TextToHtmlConversionOptions Members | Aspose.Slides.Export Namespace


TextToHtmlConversionOptions Members

TextToHtmlConversionOptions overview

Public Instance Constructors

TextToHtmlConversionOptions Constructor Initializes a new instance of the TextToHtmlConversionOptions class.

Public Instance Properties

AddClipboardFragmentHeader | Returns or sets value, indicating if Clipboard headers should be added. Read/write Boolean.
EncodingName | Returns or sets html encoding name. This value will be saved to the generated HTML file, but its up to caller to ensure that file will be saved in this encoding.
LinkEmbedController | Returns or sets a callback object which controlls how external object will be stored. Read/write ILinkEmbedController.
TextInheritanceLimit | Returns or sets inhering depth for text properties. Read/write TextInheritanceLimit.

See Also

TextToHtmlConversionOptions Class | Aspose.Slides.Export Namespace


TextToHtmlConversionOptions Constructor

Initializes a new instance of the TextToHtmlConversionOptions class.

[Visual Basic]
Public Sub New()
[C#]
public TextToHtmlConversionOptions();

See Also

TextToHtmlConversionOptions Class | Aspose.Slides.Export Namespace


TextToHtmlConversionOptions Properties

The properties of the TextToHtmlConversionOptions class are listed below. For a complete list of TextToHtmlConversionOptions class members, see the TextToHtmlConversionOptions Members topic.

Public Instance Properties

AddClipboardFragmentHeader | Returns or sets value, indicating if Clipboard headers should be added. Read/write Boolean.
EncodingName | Returns or sets html encoding name. This value will be saved to the generated HTML file, but its up to caller to ensure that file will be saved in this encoding.
LinkEmbedController | Returns or sets a callback object which controlls how external object will be stored. Read/write ILinkEmbedController.
TextInheritanceLimit | Returns or sets inhering depth for text properties. Read/write TextInheritanceLimit.

See Also

TextToHtmlConversionOptions Class | Aspose.Slides.Export Namespace


AddClipboardFragmentHeader Property

Aspose.Slides Documentation

TextToHtmlConversionOptions.AddClipboardFragmentHeader Property

Returns or sets value, indicating if Clipboard headers should be added. Read/write Boolean.

[Visual Basic]
NotOverridable Public Property AddClipboardFragmentHeader As Boolean _
Implements ITextToHtmlConversionOptions.AddClipboardFragmentHeader
[C#]
public bool AddClipboardFragmentHeader {get; set;}

Implements

ITextToHtmlConversionOptions.AddClipboardFragmentHeader

See Also

TextToHtmlConversionOptions Class | Aspose.Slides.Export Namespace


EncodingName Property

Aspose.Slides Documentation

TextToHtmlConversionOptions.EncodingName Property

Returns or sets html encoding name. This value will be saved to the generated HTML file, but its up to caller to ensure that file will be saved in this encoding.

[Visual Basic]
NotOverridable Public Property EncodingName As String _
Implements ITextToHtmlConversionOptions.EncodingName
[C#]
public string EncodingName {get; set;}

Implements

ITextToHtmlConversionOptions.EncodingName

See Also

TextToHtmlConversionOptions Class | Aspose.Slides.Export Namespace


LinkEmbedController Property

Aspose.Slides Documentation

TextToHtmlConversionOptions.LinkEmbedController Property

Returns or sets a callback object which controlls how external object will be stored. Read/write ILinkEmbedController.

[Visual Basic]
NotOverridable Public Property LinkEmbedController As ILinkEmbedController _
Implements ITextToHtmlConversionOptions.LinkEmbedController
[C#]
public ILinkEmbedController LinkEmbedController {get; set;}

Implements

ITextToHtmlConversionOptions.LinkEmbedController

See Also

TextToHtmlConversionOptions Class | Aspose.Slides.Export Namespace


TextInheritanceLimit Property

Aspose.Slides Documentation

TextToHtmlConversionOptions.TextInheritanceLimit Property

Returns or sets inhering depth for text properties. Read/write TextInheritanceLimit.

[Visual Basic]
NotOverridable Public Property TextInheritanceLimit As TextInheritanceLimit _
Implements ITextToHtmlConversionOptions.TextInheritanceLimit
[C#]
public TextInheritanceLimit TextInheritanceLimit {get; set;}

Implements

ITextToHtmlConversionOptions.TextInheritanceLimit

See Also

TextToHtmlConversionOptions Class | Aspose.Slides.Export Namespace


TiffCompressionTypes Enumeration

[Visual Basic]
Public Enum TiffCompressionTypes
[C#]
public enum TiffCompressionTypes

Members

Member Name | Description | Value
Default |  | 0
None |  | 1
CCITT3 |  | 2
CCITT4 |  | 3
LZW |  | 4
RLE |  | 5

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Export Namespace


TiffOptions Class

Provides options that control how a presentation is saved in TIFF format.

For a list of all members of this type, see TiffOptions Members.

System.Object
Aspose.Slides.Export.SaveOptions
Aspose.Slides.Export.TiffOptions

[Visual Basic]
Public Class TiffOptions
Inherits SaveOptions
Implements ITiffOptions
[C#]
public class TiffOptions : SaveOptions, ITiffOptions

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TiffOptions Members | Aspose.Slides.Export Namespace


TiffOptions Members

TiffOptions overview

Public Instance Constructors

TiffOptions Constructor Default constructor.

Public Instance Properties

CompressionType | specifies the compression type.
DpiX | Specifies the horizontal resolution in dots per inch.
DpiY | Specifies the vertical resolution in dots per inch.
ImageSize | Specifies size of a generated TIFF image.
WarningCallback (inherited from SaveOptions) | Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

TiffOptions Class | Aspose.Slides.Export Namespace


TiffOptions Constructor

Default constructor.

[Visual Basic]
Public Sub New()
[C#]
public TiffOptions();

See Also

TiffOptions Class | Aspose.Slides.Export Namespace


TiffOptions Properties

The properties of the TiffOptions class are listed below. For a complete list of TiffOptions class members, see the TiffOptions Members topic.

Public Instance Properties

CompressionType | specifies the compression type.
DpiX | Specifies the horizontal resolution in dots per inch.
DpiY | Specifies the vertical resolution in dots per inch.
ImageSize | Specifies size of a generated TIFF image.
WarningCallback (inherited from SaveOptions) | Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

TiffOptions Class | Aspose.Slides.Export Namespace


CompressionType Property

Aspose.Slides Documentation

TiffOptions.CompressionType Property

specifies the compression type.

[Visual Basic]
NotOverridable Public Property CompressionType As TiffCompressionTypes _
Implements ITiffOptions.CompressionType
[C#]
public TiffCompressionTypes CompressionType {get; set;}

Implements

ITiffOptions.CompressionType

See Also

TiffOptions Class | Aspose.Slides.Export Namespace


DpiX Property

Aspose.Slides Documentation

TiffOptions.DpiX Property

Specifies the horizontal resolution in dots per inch.

[Visual Basic]
NotOverridable Public Property DpiX As UInt32 _
Implements ITiffOptions.DpiX
[C#]
public uint DpiX {get; set;}

Implements

ITiffOptions.DpiX

See Also

TiffOptions Class | Aspose.Slides.Export Namespace


DpiY Property

Aspose.Slides Documentation

TiffOptions.DpiY Property

Specifies the vertical resolution in dots per inch.

[Visual Basic]
NotOverridable Public Property DpiY As UInt32 _
Implements ITiffOptions.DpiY
[C#]
public uint DpiY {get; set;}

Implements

ITiffOptions.DpiY

See Also

TiffOptions Class | Aspose.Slides.Export Namespace


ImageSize Property

Aspose.Slides Documentation

TiffOptions.ImageSize Property

Specifies size of a generated TIFF image.

[Visual Basic]
NotOverridable Public Property ImageSize As Size _
Implements ITiffOptions.ImageSize
[C#]
public Size ImageSize {get; set;}

Implements

ITiffOptions.ImageSize

Remarks

Default value is 720x540 points.

See Also

TiffOptions Class | Aspose.Slides.Export Namespace


XpsOptions Class

Provides options that control how a presentation is saved in XPS format.

For a list of all members of this type, see XpsOptions Members.

System.Object
Aspose.Slides.Export.SaveOptions
Aspose.Slides.Export.XpsOptions

[Visual Basic]
Public Class XpsOptions
Inherits SaveOptions
Implements IXpsOptions
[C#]
public class XpsOptions : SaveOptions, IXpsOptions

Requirements

Namespace: Aspose.Slides.Export

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

XpsOptions Members | Aspose.Slides.Export Namespace


XpsOptions Members

XpsOptions overview

Public Instance Constructors

XpsOptions Constructor Default constructor.

Public Instance Properties

SaveMetafilesAsPng | True to convert all metafiles used in a presentation to the PNG images.
WarningCallback (inherited from SaveOptions) | Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

XpsOptions Class | Aspose.Slides.Export Namespace


XpsOptions Constructor

Default constructor.

[Visual Basic]
Public Sub New()
[C#]
public XpsOptions();

See Also

XpsOptions Class | Aspose.Slides.Export Namespace


XpsOptions Properties

The properties of the XpsOptions class are listed below. For a complete list of XpsOptions class members, see the XpsOptions Members topic.

Public Instance Properties

SaveMetafilesAsPng | True to convert all metafiles used in a presentation to the PNG images.
WarningCallback (inherited from SaveOptions) | Returns of sets an object which receives warnings and decides whether loading process will continue or will be aborted. Read/write IWarningCallback.

See Also

XpsOptions Class | Aspose.Slides.Export Namespace


SaveMetafilesAsPng Property

Aspose.Slides Documentation

XpsOptions.SaveMetafilesAsPng Property

True to convert all metafiles used in a presentation to the PNG images.

[Visual Basic]
NotOverridable Public Property SaveMetafilesAsPng As Boolean _
Implements IXpsOptions.SaveMetafilesAsPng
[C#]
public bool SaveMetafilesAsPng {get; set;}

Implements

IXpsOptions.SaveMetafilesAsPng

Remarks

Default is true.

See Also

XpsOptions Class | Aspose.Slides.Export Namespace


Aspose.Slides.Import

Aspose.Slides Documentation

Aspose.Slides.Import Namespace

Namespace hierarchy

Classes

Class | Description
HtmlExternalResolver | Callback object used by HTML import routine to obtain referrenced objects such as images. Supports "data:" "file:" and "http:" url schemes. Using this resolver could create a vulnurability when client provided HTML file will make server software to obtain local or network file. Use with caution. It is recommended not to specify HtmlExternalResolver at all (only embedded objects will be read) or create some subclass which checks if specified uri is valid.

Interfaces

Interface | Description
IHtmlExternalResolver |


HtmlExternalResolver Class

Callback object used by HTML import routine to obtain referrenced objects such as images. Supports "data:" "file:" and "http:" url schemes. Using this resolver could create a vulnurability when client provided HTML file will make server software to obtain local or network file. Use with caution. It is recommended not to specify HtmlExternalResolver at all (only embedded objects will be read) or create some subclass which checks if specified uri is valid.

For a list of all members of this type, see HtmlExternalResolver Members.

System.Object
Aspose.Slides.Import.HtmlExternalResolver

[Visual Basic]
Public Class HtmlExternalResolver
Implements IHtmlExternalResolver
[C#]
public class HtmlExternalResolver : IHtmlExternalResolver

Requirements

Namespace: Aspose.Slides.Import

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

HtmlExternalResolver Members | Aspose.Slides.Import Namespace


HtmlExternalResolver Members

HtmlExternalResolver overview

Public Instance Constructors

HtmlExternalResolver Constructor Initializes a new instance of the HtmlExternalResolver class.

Public Instance Methods

GetEntity | Fetches linked object.
ResolveUri | Resolves URI.

See Also

HtmlExternalResolver Class | Aspose.Slides.Import Namespace


HtmlExternalResolver Constructor

Initializes a new instance of the HtmlExternalResolver class.

[Visual Basic]
Public Sub New()
[C#]
public HtmlExternalResolver();

See Also

HtmlExternalResolver Class | Aspose.Slides.Import Namespace


HtmlExternalResolver Methods

The methods of the HtmlExternalResolver class are listed below. For a complete list of HtmlExternalResolver class members, see the HtmlExternalResolver Members topic.

Public Instance Methods

GetEntity | Fetches linked object.
ResolveUri | Resolves URI.

See Also

HtmlExternalResolver Class | Aspose.Slides.Import Namespace


HtmlExternalResolver.GetEntity Method

Fetches linked object.

[Visual Basic]
Overridable Public Function GetEntity( _
ByVal absoluteUri As String _
) As Stream _
Implements IHtmlExternalResolver.GetEntity
[C#]
public virtual Stream GetEntity(
string absoluteUri
);

Parameters

absoluteUri
Absolute URI to the object (returned by ResolveUri method.

Return Value

Stream object with the linked object data or null if object can't or shouldn't be loaded.

Implements

IHtmlExternalResolver.GetEntity

See Also

HtmlExternalResolver Class | Aspose.Slides.Import Namespace


HtmlExternalResolver.ResolveUri Method

Resolves URI.

[Visual Basic]
Overridable Public Function ResolveUri( _
ByVal baseUri As String, _
ByVal relativeUri As String _
) As String _
Implements IHtmlExternalResolver.ResolveUri
[C#]
public virtual string ResolveUri(
string baseUri,
string relativeUri
);

Parameters

baseUri
absolute URI of linking objects
relativeUri
URI to the linked object.

Return Value

absolute URI to the linked object. Returning null will prevent object from loading.

Implements

IHtmlExternalResolver.ResolveUri

See Also

HtmlExternalResolver Class | Aspose.Slides.Import Namespace


IHtmlExternalResolver Interface

For a list of all members of this type, see IHtmlExternalResolver Members.

[Visual Basic]
Public Interface IHtmlExternalResolver
[C#]
public interface IHtmlExternalResolver

Types that implement IHtmlExternalResolver

Type | Description
HtmlExternalResolver | Callback object used by HTML import routine to obtain referrenced objects such as images. Supports "data:" "file:" and "http:" url schemes. Using this resolver could create a vulnurability when client provided HTML file will make server software to obtain local or network file. Use with caution. It is recommended not to specify HtmlExternalResolver at all (only embedded objects will be read) or create some subclass which checks if specified uri is valid.

Requirements

Namespace: Aspose.Slides.Import

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IHtmlExternalResolver Members | Aspose.Slides.Import Namespace


IHtmlExternalResolver Members

IHtmlExternalResolver overview

Public Instance Methods

GetEntity
ResolveUri

See Also

IHtmlExternalResolver Interface | Aspose.Slides.Import Namespace


IHtmlExternalResolver Methods

The methods of the IHtmlExternalResolver interface are listed below. For a complete list of IHtmlExternalResolver interface members, see the IHtmlExternalResolver Members topic.

Public Instance Methods

GetEntity
ResolveUri

See Also

IHtmlExternalResolver Interface | Aspose.Slides.Import Namespace


IHtmlExternalResolver.GetEntity Method

[Visual Basic]
Function GetEntity( _
ByVal absoluteUri As String _
) As Stream
[C#]
Stream GetEntity(
string absoluteUri
);

See Also

IHtmlExternalResolver Interface | Aspose.Slides.Import Namespace


IHtmlExternalResolver.ResolveUri Method

[Visual Basic]
Function ResolveUri( _
ByVal baseUri As String, _
ByVal relativeUri As String _
) As String
[C#]
string ResolveUri(
string baseUri,
string relativeUri
);

See Also

IHtmlExternalResolver Interface | Aspose.Slides.Import Namespace


Aspose.Slides.Odp

Aspose.Slides Documentation

Aspose.Slides.Odp Namespace

Namespace hierarchy

Classes

Class | Description
OdpException | Represents a standard internal exception type.
OdpReadException | Represents an exception which thrown on presentation reading errors.


OdpException Class

Represents a standard internal exception type.

For a list of all members of this type, see OdpException Members.

System.Object
System.Exception
Aspose.Slides.Odp.OdpException
Aspose.Slides.Odp.OdpReadException

[Visual Basic]
Public Class OdpException
Inherits Exception
[C#]
public class OdpException : Exception

Requirements

Namespace: Aspose.Slides.Odp

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

OdpException Members | Aspose.Slides.Odp Namespace


OdpException Members

OdpException overview

Public Instance Constructors

OdpException Overloaded. Initializes a new instance of the OdpException class.

See Also

OdpException Class | Aspose.Slides.Odp Namespace


OdpException Constructor

Constructor allowing a message to be added to this exception.

Overload List

Constructor allowing a message to be added to this exception.

public OdpException(string);

Constructor for an exception containing a message and an embedded exception.

public OdpException(string,Exception);

See Also

OdpException Class | Aspose.Slides.Odp Namespace


OdpException Constructor (String)

Constructor allowing a message to be added to this exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public OdpException(
string message
);

Parameters

message
message

See Also

OdpException Class | Aspose.Slides.Odp Namespace | OdpException Constructor Overload List


OdpException Constructor (String, Exception)

Constructor for an exception containing a message and an embedded exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public OdpException(
string message,
Exception exception
);

Parameters

message
message
exception
original exception

See Also

OdpException Class | Aspose.Slides.Odp Namespace | OdpException Constructor Overload List


OdpReadException Class

Represents an exception which thrown on presentation reading errors.

For a list of all members of this type, see OdpReadException Members.

System.Object
System.Exception
Aspose.Slides.Odp.OdpException
Aspose.Slides.Odp.OdpReadException

[Visual Basic]
Public Class OdpReadException
Inherits OdpException
[C#]
public class OdpReadException : OdpException

Requirements

Namespace: Aspose.Slides.Odp

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

OdpReadException Members | Aspose.Slides.Odp Namespace


OdpReadException Members

OdpReadException overview

Public Instance Constructors

OdpReadException Overloaded. Initializes a new instance of the OdpReadException class.

See Also

OdpReadException Class | Aspose.Slides.Odp Namespace


OdpReadException Constructor

Constructor allowing a message to be added to this exception.

Overload List

Constructor allowing a message to be added to this exception.

public OdpReadException(string);

Constructor for an exception containing a message and an embedded exception.

public OdpReadException(string,Exception);

See Also

OdpReadException Class | Aspose.Slides.Odp Namespace


OdpReadException Constructor (String)

Constructor allowing a message to be added to this exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public OdpReadException(
string message
);

Parameters

message
message

See Also

OdpReadException Class | Aspose.Slides.Odp Namespace | OdpReadException Constructor Overload List


OdpReadException Constructor (String, Exception)

Constructor for an exception containing a message and an embedded exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal exception As Exception _
)
[C#]
public OdpReadException(
string message,
Exception exception
);

Parameters

message
message
exception
original exception

See Also

OdpReadException Class | Aspose.Slides.Odp Namespace | OdpReadException Constructor Overload List


Aspose.Slides.SlideShow

Aspose.Slides Documentation

Aspose.Slides.SlideShow Namespace

Namespace hierarchy

Classes

Class | Description
CornerDirectionTransition | Corner direction slide transition effect.
EightDirectionTransition | Eight direction slide transition effect.
EmptyTransition | Empty slide transition effect.
InOutTransition | In-Out slide transition effect.
OptionalBlackTransition | Optional black slide transition effect.
OrientationTransition | Orientation slide transition effect.
SideDirectionTransition | Side direction slide transition effect.
SlideShowTransition | Represents slide show transition.
SplitTransition | Split slide transition effect.
TransitionValueBase | Base class for slide transition effects.
TransitionValueFactory | Allows to create instances of classes inherited from ITransitionValueBase
WheelTransition | Wheel slide transition effect.

Interfaces

Interface | Description
ICornerDirectionTransition |
IEightDirectionTransition |
IEmptyTransition |
IInOutTransition |
IOptionalBlackTransition |
IOrientationTransition |
ISideDirectionTransition |
ISplitTransition |
ITransitionValueBase |
ITransitionValueFactory |
IWheelTransition |

Enumerations

Enumeration | Description
TransitionCornerDirectionType |
TransitionEightDirectionType |
TransitionInOutDirectionType |
TransitionSideDirectionType |
TransitionSoundMode |
TransitionSpeed |
TransitionType |


CornerDirectionTransition Class

Corner direction slide transition effect.

For a list of all members of this type, see CornerDirectionTransition Members.

System.Object
Aspose.Slides.SlideShow.TransitionValueBase
Aspose.Slides.SlideShow.CornerDirectionTransition

[Visual Basic]
Public Class CornerDirectionTransition
Inherits TransitionValueBase
Implements ICornerDirectionTransition
[C#]
public class CornerDirectionTransition : TransitionValueBase, ICornerDirectionTransition

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

CornerDirectionTransition Members | Aspose.Slides.SlideShow Namespace


CornerDirectionTransition Members

CornerDirectionTransition overview

Public Instance Constructors

CornerDirectionTransition Constructor Constructor for corner direction transition effects.

Public Instance Properties

Direction Direction of transition.

See Also

CornerDirectionTransition Class | Aspose.Slides.SlideShow Namespace


CornerDirectionTransition Constructor

Constructor for corner direction transition effects.

[Visual Basic]
Public Sub New( _
ByVal type As TransitionType _
)
[C#]
public CornerDirectionTransition(
TransitionType type
);

Parameters

type
Type of a transition effect.

See Also

CornerDirectionTransition Class | Aspose.Slides.SlideShow Namespace


CornerDirectionTransition Properties

The properties of the CornerDirectionTransition class are listed below. For a complete list of CornerDirectionTransition class members, see the CornerDirectionTransition Members topic.

Public Instance Properties

Direction Direction of transition.

See Also

CornerDirectionTransition Class | Aspose.Slides.SlideShow Namespace


Direction Property

Aspose.Slides Documentation

CornerDirectionTransition.Direction Property

Direction of transition.

[Visual Basic]
NotOverridable Public Property Direction As TransitionCornerDirectionType _
Implements ICornerDirectionTransition.Direction
[C#]
public TransitionCornerDirectionType Direction {get; set;}

Implements

ICornerDirectionTransition.Direction

See Also

CornerDirectionTransition Class | Aspose.Slides.SlideShow Namespace


EightDirectionTransition Class

Eight direction slide transition effect.

For a list of all members of this type, see EightDirectionTransition Members.

System.Object
Aspose.Slides.SlideShow.TransitionValueBase
Aspose.Slides.SlideShow.EightDirectionTransition

[Visual Basic]
Public Class EightDirectionTransition
Inherits TransitionValueBase
Implements IEightDirectionTransition
[C#]
public class EightDirectionTransition : TransitionValueBase, IEightDirectionTransition

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

EightDirectionTransition Members | Aspose.Slides.SlideShow Namespace


EightDirectionTransition Members

EightDirectionTransition overview

Public Instance Constructors

EightDirectionTransition Constructor Constructor for eight direction slide transition effects.

Public Instance Properties

Direction Direction of transition.

See Also

EightDirectionTransition Class | Aspose.Slides.SlideShow Namespace


EightDirectionTransition Constructor

Constructor for eight direction slide transition effects.

[Visual Basic]
Public Sub New( _
ByVal type As TransitionType _
)
[C#]
public EightDirectionTransition(
TransitionType type
);

Parameters

type
Type of a transition effect.

See Also

EightDirectionTransition Class | Aspose.Slides.SlideShow Namespace


EightDirectionTransition Properties

The properties of the EightDirectionTransition class are listed below. For a complete list of EightDirectionTransition class members, see the EightDirectionTransition Members topic.

Public Instance Properties

Direction Direction of transition.

See Also

EightDirectionTransition Class | Aspose.Slides.SlideShow Namespace


Direction Property

Aspose.Slides Documentation

EightDirectionTransition.Direction Property

Direction of transition.

[Visual Basic]
NotOverridable Public Property Direction As TransitionEightDirectionType _
Implements IEightDirectionTransition.Direction
[C#]
public TransitionEightDirectionType Direction {get; set;}

Implements

IEightDirectionTransition.Direction

See Also

EightDirectionTransition Class | Aspose.Slides.SlideShow Namespace


EmptyTransition Class

Empty slide transition effect.

For a list of all members of this type, see EmptyTransition Members.

System.Object
Aspose.Slides.SlideShow.TransitionValueBase
Aspose.Slides.SlideShow.EmptyTransition

[Visual Basic]
Public Class EmptyTransition
Inherits TransitionValueBase
Implements IEmptyTransition
[C#]
public class EmptyTransition : TransitionValueBase, IEmptyTransition

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

EmptyTransition Members | Aspose.Slides.SlideShow Namespace


EmptyTransition Members

EmptyTransition overview

Public Instance Constructors

EmptyTransition Constructor Constructor for empty slide transition effects.

See Also

EmptyTransition Class | Aspose.Slides.SlideShow Namespace


EmptyTransition Constructor

Constructor for empty slide transition effects.

[Visual Basic]
Public Sub New( _
ByVal type As TransitionType _
)
[C#]
public EmptyTransition(
TransitionType type
);

Parameters

type
Type of an empty transition effects.

See Also

EmptyTransition Class | Aspose.Slides.SlideShow Namespace


ICornerDirectionTransition Interface

For a list of all members of this type, see ICornerDirectionTransition Members.

[Visual Basic]
Public Interface ICornerDirectionTransition
Implements ITransitionValueBase
[C#]
public interface ICornerDirectionTransition : ITransitionValueBase

Types that implement ICornerDirectionTransition

Type | Description
CornerDirectionTransition | Corner direction slide transition effect.

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ICornerDirectionTransition Members | Aspose.Slides.SlideShow Namespace


ICornerDirectionTransition Members

ICornerDirectionTransition overview

Public Instance Properties

AsITransitionValueBase
Direction

See Also

ICornerDirectionTransition Interface | Aspose.Slides.SlideShow Namespace


ICornerDirectionTransition Properties

The properties of the ICornerDirectionTransition interface are listed below. For a complete list of ICornerDirectionTransition interface members, see the ICornerDirectionTransition Members topic.

Public Instance Properties

AsITransitionValueBase
Direction

See Also

ICornerDirectionTransition Interface | Aspose.Slides.SlideShow Namespace


AsITransitionValueBase Property

Aspose.Slides Documentation

ICornerDirectionTransition.AsITransitionValueBase Property

[Visual Basic]
Property AsITransitionValueBase As ITransitionValueBase
[C#]
ITransitionValueBase AsITransitionValueBase {get;}

See Also

ICornerDirectionTransition Interface | Aspose.Slides.SlideShow Namespace


Direction Property

Aspose.Slides Documentation

ICornerDirectionTransition.Direction Property

[Visual Basic]
Property Direction As TransitionCornerDirectionType
[C#]
TransitionCornerDirectionType Direction {get; set;}

See Also

ICornerDirectionTransition Interface | Aspose.Slides.SlideShow Namespace


IEightDirectionTransition Interface

For a list of all members of this type, see IEightDirectionTransition Members.

[Visual Basic]
Public Interface IEightDirectionTransition
Implements ITransitionValueBase
[C#]
public interface IEightDirectionTransition : ITransitionValueBase

Types that implement IEightDirectionTransition

Type | Description
EightDirectionTransition | Eight direction slide transition effect.

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IEightDirectionTransition Members | Aspose.Slides.SlideShow Namespace


IEightDirectionTransition Members

IEightDirectionTransition overview

Public Instance Properties

AsITransitionValueBase
Direction

See Also

IEightDirectionTransition Interface | Aspose.Slides.SlideShow Namespace


IEightDirectionTransition Properties

The properties of the IEightDirectionTransition interface are listed below. For a complete list of IEightDirectionTransition interface members, see the IEightDirectionTransition Members topic.

Public Instance Properties

AsITransitionValueBase
Direction

See Also

IEightDirectionTransition Interface | Aspose.Slides.SlideShow Namespace


AsITransitionValueBase Property

Aspose.Slides Documentation

IEightDirectionTransition.AsITransitionValueBase Property

[Visual Basic]
Property AsITransitionValueBase As ITransitionValueBase
[C#]
ITransitionValueBase AsITransitionValueBase {get;}

See Also

IEightDirectionTransition Interface | Aspose.Slides.SlideShow Namespace


Direction Property

Aspose.Slides Documentation

IEightDirectionTransition.Direction Property

[Visual Basic]
Property Direction As TransitionEightDirectionType
[C#]
TransitionEightDirectionType Direction {get; set;}

See Also

IEightDirectionTransition Interface | Aspose.Slides.SlideShow Namespace


IEmptyTransition Interface

For a list of all members of this type, see IEmptyTransition Members.

[Visual Basic]
Public Interface IEmptyTransition
Implements ITransitionValueBase
[C#]
public interface IEmptyTransition : ITransitionValueBase

Types that implement IEmptyTransition

Type | Description
EmptyTransition | Empty slide transition effect.

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IEmptyTransition Members | Aspose.Slides.SlideShow Namespace


IEmptyTransition Members

IEmptyTransition overview

Public Instance Properties

AsITransitionValueBase

See Also

IEmptyTransition Interface | Aspose.Slides.SlideShow Namespace


IEmptyTransition Properties

The properties of the IEmptyTransition interface are listed below. For a complete list of IEmptyTransition interface members, see the IEmptyTransition Members topic.

Public Instance Properties

AsITransitionValueBase

See Also

IEmptyTransition Interface | Aspose.Slides.SlideShow Namespace


AsITransitionValueBase Property

Aspose.Slides Documentation

IEmptyTransition.AsITransitionValueBase Property

[Visual Basic]
Property AsITransitionValueBase As ITransitionValueBase
[C#]
ITransitionValueBase AsITransitionValueBase {get;}

See Also

IEmptyTransition Interface | Aspose.Slides.SlideShow Namespace


IInOutTransition Interface

For a list of all members of this type, see IInOutTransition Members.

[Visual Basic]
Public Interface IInOutTransition
Implements ITransitionValueBase
[C#]
public interface IInOutTransition : ITransitionValueBase

Types that implement IInOutTransition

Type | Description
InOutTransition | In-Out slide transition effect.

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IInOutTransition Members | Aspose.Slides.SlideShow Namespace


IInOutTransition Members

IInOutTransition overview

Public Instance Properties

AsITransitionValueBase
Direction

See Also

IInOutTransition Interface | Aspose.Slides.SlideShow Namespace


IInOutTransition Properties

The properties of the IInOutTransition interface are listed below. For a complete list of IInOutTransition interface members, see the IInOutTransition Members topic.

Public Instance Properties

AsITransitionValueBase
Direction

See Also

IInOutTransition Interface | Aspose.Slides.SlideShow Namespace


AsITransitionValueBase Property

Aspose.Slides Documentation

IInOutTransition.AsITransitionValueBase Property

[Visual Basic]
Property AsITransitionValueBase As ITransitionValueBase
[C#]
ITransitionValueBase AsITransitionValueBase {get;}

See Also

IInOutTransition Interface | Aspose.Slides.SlideShow Namespace


Direction Property

Aspose.Slides Documentation

IInOutTransition.Direction Property

[Visual Basic]
Property Direction As TransitionInOutDirectionType
[C#]
TransitionInOutDirectionType Direction {get; set;}

See Also

IInOutTransition Interface | Aspose.Slides.SlideShow Namespace


InOutTransition Class

In-Out slide transition effect.

For a list of all members of this type, see InOutTransition Members.

System.Object
Aspose.Slides.SlideShow.TransitionValueBase
Aspose.Slides.SlideShow.InOutTransition

[Visual Basic]
Public Class InOutTransition
Inherits TransitionValueBase
Implements IInOutTransition
[C#]
public class InOutTransition : TransitionValueBase, IInOutTransition

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

InOutTransition Members | Aspose.Slides.SlideShow Namespace


InOutTransition Members

InOutTransition overview

Public Instance Constructors

InOutTransition Constructor Constructor for in/out slide transition effects.

Public Instance Properties

Direction Direction of a transition effect. Read/write TransitionInOutDirectionType.

See Also

InOutTransition Class | Aspose.Slides.SlideShow Namespace


InOutTransition Constructor

Constructor for in/out slide transition effects.

[Visual Basic]
Public Sub New( _
ByVal type As TransitionType _
)
[C#]
public InOutTransition(
TransitionType type
);

Parameters

type
Type of an in/out transition effect.

See Also

InOutTransition Class | Aspose.Slides.SlideShow Namespace


InOutTransition Properties

The properties of the InOutTransition class are listed below. For a complete list of InOutTransition class members, see the InOutTransition Members topic.

Public Instance Properties

Direction Direction of a transition effect. Read/write TransitionInOutDirectionType.

See Also

InOutTransition Class | Aspose.Slides.SlideShow Namespace


Direction Property

Aspose.Slides Documentation

InOutTransition.Direction Property

Direction of a transition effect. Read/write TransitionInOutDirectionType.

[Visual Basic]
NotOverridable Public Property Direction As TransitionInOutDirectionType _
Implements IInOutTransition.Direction
[C#]
public TransitionInOutDirectionType Direction {get; set;}

Implements

IInOutTransition.Direction

See Also

InOutTransition Class | Aspose.Slides.SlideShow Namespace


IOptionalBlackTransition Interface

For a list of all members of this type, see IOptionalBlackTransition Members.

[Visual Basic]
Public Interface IOptionalBlackTransition
Implements ITransitionValueBase
[C#]
public interface IOptionalBlackTransition : ITransitionValueBase

Types that implement IOptionalBlackTransition

Type | Description
OptionalBlackTransition | Optional black slide transition effect.

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IOptionalBlackTransition Members | Aspose.Slides.SlideShow Namespace


IOptionalBlackTransition Members

IOptionalBlackTransition overview

Public Instance Properties

AsITransitionValueBase
FromBlack

See Also

IOptionalBlackTransition Interface | Aspose.Slides.SlideShow Namespace


IOptionalBlackTransition Properties

The properties of the IOptionalBlackTransition interface are listed below. For a complete list of IOptionalBlackTransition interface members, see the IOptionalBlackTransition Members topic.

Public Instance Properties

AsITransitionValueBase
FromBlack

See Also

IOptionalBlackTransition Interface | Aspose.Slides.SlideShow Namespace


AsITransitionValueBase Property

Aspose.Slides Documentation

IOptionalBlackTransition.AsITransitionValueBase Property

[Visual Basic]
Property AsITransitionValueBase As ITransitionValueBase
[C#]
ITransitionValueBase AsITransitionValueBase {get;}

See Also

IOptionalBlackTransition Interface | Aspose.Slides.SlideShow Namespace


FromBlack Property

Aspose.Slides Documentation

IOptionalBlackTransition.FromBlack Property

[Visual Basic]
Property FromBlack As Boolean
[C#]
bool FromBlack {get; set;}

See Also

IOptionalBlackTransition Interface | Aspose.Slides.SlideShow Namespace


IOrientationTransition Interface

For a list of all members of this type, see IOrientationTransition Members.

[Visual Basic]
Public Interface IOrientationTransition
Implements ITransitionValueBase
[C#]
public interface IOrientationTransition : ITransitionValueBase

Types that implement IOrientationTransition

Type | Description
OrientationTransition | Orientation slide transition effect.

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IOrientationTransition Members | Aspose.Slides.SlideShow Namespace


IOrientationTransition Members

IOrientationTransition overview

Public Instance Properties

AsITransitionValueBase
Direction

See Also

IOrientationTransition Interface | Aspose.Slides.SlideShow Namespace


IOrientationTransition Properties

The properties of the IOrientationTransition interface are listed below. For a complete list of IOrientationTransition interface members, see the IOrientationTransition Members topic.

Public Instance Properties

AsITransitionValueBase
Direction

See Also

IOrientationTransition Interface | Aspose.Slides.SlideShow Namespace


AsITransitionValueBase Property

Aspose.Slides Documentation

IOrientationTransition.AsITransitionValueBase Property

[Visual Basic]
Property AsITransitionValueBase As ITransitionValueBase
[C#]
ITransitionValueBase AsITransitionValueBase {get;}

See Also

IOrientationTransition Interface | Aspose.Slides.SlideShow Namespace


Direction Property

Aspose.Slides Documentation

IOrientationTransition.Direction Property

[Visual Basic]
Property Direction As Orientation
[C#]
Orientation Direction {get; set;}

See Also

IOrientationTransition Interface | Aspose.Slides.SlideShow Namespace


ISideDirectionTransition Interface

For a list of all members of this type, see ISideDirectionTransition Members.

[Visual Basic]
Public Interface ISideDirectionTransition
Implements ITransitionValueBase
[C#]
public interface ISideDirectionTransition : ITransitionValueBase

Types that implement ISideDirectionTransition

Type | Description
SideDirectionTransition | Side direction slide transition effect.

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISideDirectionTransition Members | Aspose.Slides.SlideShow Namespace


ISideDirectionTransition Members

ISideDirectionTransition overview

Public Instance Properties

AsITransitionValueBase
Direction

See Also

ISideDirectionTransition Interface | Aspose.Slides.SlideShow Namespace


ISideDirectionTransition Properties

The properties of the ISideDirectionTransition interface are listed below. For a complete list of ISideDirectionTransition interface members, see the ISideDirectionTransition Members topic.

Public Instance Properties

AsITransitionValueBase
Direction

See Also

ISideDirectionTransition Interface | Aspose.Slides.SlideShow Namespace


AsITransitionValueBase Property

Aspose.Slides Documentation

ISideDirectionTransition.AsITransitionValueBase Property

[Visual Basic]
Property AsITransitionValueBase As ITransitionValueBase
[C#]
ITransitionValueBase AsITransitionValueBase {get;}

See Also

ISideDirectionTransition Interface | Aspose.Slides.SlideShow Namespace


Direction Property

Aspose.Slides Documentation

ISideDirectionTransition.Direction Property

[Visual Basic]
Property Direction As TransitionSideDirectionType
[C#]
TransitionSideDirectionType Direction {get; set;}

See Also

ISideDirectionTransition Interface | Aspose.Slides.SlideShow Namespace


ISplitTransition Interface

For a list of all members of this type, see ISplitTransition Members.

[Visual Basic]
Public Interface ISplitTransition
Implements ITransitionValueBase
[C#]
public interface ISplitTransition : ITransitionValueBase

Types that implement ISplitTransition

Type | Description
SplitTransition | Split slide transition effect.

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISplitTransition Members | Aspose.Slides.SlideShow Namespace


ISplitTransition Members

ISplitTransition overview

Public Instance Properties

AsITransitionValueBase
Direction
Orientation

See Also

ISplitTransition Interface | Aspose.Slides.SlideShow Namespace


ISplitTransition Properties

The properties of the ISplitTransition interface are listed below. For a complete list of ISplitTransition interface members, see the ISplitTransition Members topic.

Public Instance Properties

AsITransitionValueBase
Direction
Orientation

See Also

ISplitTransition Interface | Aspose.Slides.SlideShow Namespace


AsITransitionValueBase Property

Aspose.Slides Documentation

ISplitTransition.AsITransitionValueBase Property

[Visual Basic]
Property AsITransitionValueBase As ITransitionValueBase
[C#]
ITransitionValueBase AsITransitionValueBase {get;}

See Also

ISplitTransition Interface | Aspose.Slides.SlideShow Namespace


Direction Property

Aspose.Slides Documentation

ISplitTransition.Direction Property

[Visual Basic]
Property Direction As TransitionInOutDirectionType
[C#]
TransitionInOutDirectionType Direction {get; set;}

See Also

ISplitTransition Interface | Aspose.Slides.SlideShow Namespace


Orientation Property

Aspose.Slides Documentation

ISplitTransition.Orientation Property

[Visual Basic]
Property Orientation As Orientation
[C#]
Orientation Orientation {get; set;}

See Also

ISplitTransition Interface | Aspose.Slides.SlideShow Namespace


ITransitionValueBase Interface

Aspose.Slides.SlideShow.ITransitionValueBase
Derived interfaces

[Visual Basic]
Public Interface ITransitionValueBase
[C#]
public interface ITransitionValueBase

Types that implement ITransitionValueBase

Type | Description
CornerDirectionTransition | Corner direction slide transition effect.
EightDirectionTransition | Eight direction slide transition effect.
EmptyTransition | Empty slide transition effect.
InOutTransition | In-Out slide transition effect.
OptionalBlackTransition | Optional black slide transition effect.
OrientationTransition | Orientation slide transition effect.
SideDirectionTransition | Side direction slide transition effect.
SplitTransition | Split slide transition effect.
TransitionValueBase | Base class for slide transition effects.
WheelTransition | Wheel slide transition effect.

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.SlideShow Namespace


ITransitionValueFactory Interface

For a list of all members of this type, see ITransitionValueFactory Members.

[Visual Basic]
Public Interface ITransitionValueFactory
[C#]
public interface ITransitionValueFactory

Types that implement ITransitionValueFactory

Type | Description
TransitionValueFactory | Allows to create instances of classes inherited from ITransitionValueBase

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITransitionValueFactory Members | Aspose.Slides.SlideShow Namespace


ITransitionValueFactory Members

ITransitionValueFactory overview

Public Instance Methods

CreateCornerDirectionTransition
CreateEightDirectionTransition
CreateEmptyTransition
CreateInOutTransition
CreateOptionalBlackTransition
CreateOrientationTransition
CreateSideDirectionTransition
CreateSplitTransition
CreateWheelTransition

See Also

ITransitionValueFactory Interface | Aspose.Slides.SlideShow Namespace


ITransitionValueFactory Methods

The methods of the ITransitionValueFactory interface are listed below. For a complete list of ITransitionValueFactory interface members, see the ITransitionValueFactory Members topic.

Public Instance Methods

CreateCornerDirectionTransition
CreateEightDirectionTransition
CreateEmptyTransition
CreateInOutTransition
CreateOptionalBlackTransition
CreateOrientationTransition
CreateSideDirectionTransition
CreateSplitTransition
CreateWheelTransition

See Also

ITransitionValueFactory Interface | Aspose.Slides.SlideShow Namespace


ITransitionValueFactory.CreateCornerDirectionTransition Method

[Visual Basic]
Function CreateCornerDirectionTransition( _
ByVal type As TransitionType _
) As ICornerDirectionTransition
[C#]
ICornerDirectionTransition CreateCornerDirectionTransition(
TransitionType type
);

See Also

ITransitionValueFactory Interface | Aspose.Slides.SlideShow Namespace


ITransitionValueFactory.CreateEightDirectionTransition Method

[Visual Basic]
Function CreateEightDirectionTransition( _
ByVal type As TransitionType _
) As IEightDirectionTransition
[C#]
IEightDirectionTransition CreateEightDirectionTransition(
TransitionType type
);

See Also

ITransitionValueFactory Interface | Aspose.Slides.SlideShow Namespace


ITransitionValueFactory.CreateEmptyTransition Method

[Visual Basic]
Function CreateEmptyTransition( _
ByVal type As TransitionType _
) As IEmptyTransition
[C#]
IEmptyTransition CreateEmptyTransition(
TransitionType type
);

See Also

ITransitionValueFactory Interface | Aspose.Slides.SlideShow Namespace


ITransitionValueFactory.CreateInOutTransition Method

[Visual Basic]
Function CreateInOutTransition( _
ByVal type As TransitionType _
) As IInOutTransition
[C#]
IInOutTransition CreateInOutTransition(
TransitionType type
);

See Also

ITransitionValueFactory Interface | Aspose.Slides.SlideShow Namespace


ITransitionValueFactory.CreateOptionalBlackTransition Method

[Visual Basic]
Function CreateOptionalBlackTransition( _
ByVal type As TransitionType _
) As IOptionalBlackTransition
[C#]
IOptionalBlackTransition CreateOptionalBlackTransition(
TransitionType type
);

See Also

ITransitionValueFactory Interface | Aspose.Slides.SlideShow Namespace


ITransitionValueFactory.CreateOrientationTransition Method

[Visual Basic]
Function CreateOrientationTransition( _
ByVal type As TransitionType _
) As IOrientationTransition
[C#]
IOrientationTransition CreateOrientationTransition(
TransitionType type
);

See Also

ITransitionValueFactory Interface | Aspose.Slides.SlideShow Namespace


ITransitionValueFactory.CreateSideDirectionTransition Method

[Visual Basic]
Function CreateSideDirectionTransition( _
ByVal type As TransitionType _
) As ISideDirectionTransition
[C#]
ISideDirectionTransition CreateSideDirectionTransition(
TransitionType type
);

See Also

ITransitionValueFactory Interface | Aspose.Slides.SlideShow Namespace


ITransitionValueFactory.CreateSplitTransition Method

[Visual Basic]
Function CreateSplitTransition( _
ByVal type As TransitionType _
) As ISplitTransition
[C#]
ISplitTransition CreateSplitTransition(
TransitionType type
);

See Also

ITransitionValueFactory Interface | Aspose.Slides.SlideShow Namespace


ITransitionValueFactory.CreateWheelTransition Method

[Visual Basic]
Function CreateWheelTransition( _
ByVal type As TransitionType _
) As IWheelTransition
[C#]
IWheelTransition CreateWheelTransition(
TransitionType type
);

See Also

ITransitionValueFactory Interface | Aspose.Slides.SlideShow Namespace


IWheelTransition Interface

For a list of all members of this type, see IWheelTransition Members.

[Visual Basic]
Public Interface IWheelTransition
Implements ITransitionValueBase
[C#]
public interface IWheelTransition : ITransitionValueBase

Types that implement IWheelTransition

Type | Description
WheelTransition | Wheel slide transition effect.

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IWheelTransition Members | Aspose.Slides.SlideShow Namespace


IWheelTransition Members

IWheelTransition overview

Public Instance Properties

AsITransitionValueBase
Spokes

See Also

IWheelTransition Interface | Aspose.Slides.SlideShow Namespace


IWheelTransition Properties

The properties of the IWheelTransition interface are listed below. For a complete list of IWheelTransition interface members, see the IWheelTransition Members topic.

Public Instance Properties

AsITransitionValueBase
Spokes

See Also

IWheelTransition Interface | Aspose.Slides.SlideShow Namespace


AsITransitionValueBase Property

Aspose.Slides Documentation

IWheelTransition.AsITransitionValueBase Property

[Visual Basic]
Property AsITransitionValueBase As ITransitionValueBase
[C#]
ITransitionValueBase AsITransitionValueBase {get;}

See Also

IWheelTransition Interface | Aspose.Slides.SlideShow Namespace


Spokes Property

Aspose.Slides Documentation

IWheelTransition.Spokes Property

[Visual Basic]
Property Spokes As UInt32
[C#]
uint Spokes {get; set;}

See Also

IWheelTransition Interface | Aspose.Slides.SlideShow Namespace


OptionalBlackTransition Class

Optional black slide transition effect.

For a list of all members of this type, see OptionalBlackTransition Members.

System.Object
Aspose.Slides.SlideShow.TransitionValueBase
Aspose.Slides.SlideShow.OptionalBlackTransition

[Visual Basic]
Public Class OptionalBlackTransition
Inherits TransitionValueBase
Implements IOptionalBlackTransition
[C#]
public class OptionalBlackTransition : TransitionValueBase, IOptionalBlackTransition

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

OptionalBlackTransition Members | Aspose.Slides.SlideShow Namespace


OptionalBlackTransition Members

OptionalBlackTransition overview

Public Instance Constructors

OptionalBlackTransition Constructor Constructor for optional black slide transition effects.

Public Instance Properties

FromBlack This attribute specifies if the transition will start from a black screen (and then transition the new slide over black).

See Also

OptionalBlackTransition Class | Aspose.Slides.SlideShow Namespace


OptionalBlackTransition Constructor

Constructor for optional black slide transition effects.

[Visual Basic]
Public Sub New( _
ByVal type As TransitionType _
)
[C#]
public OptionalBlackTransition(
TransitionType type
);

Parameters

type
Type of an optional black transition effect.

See Also

OptionalBlackTransition Class | Aspose.Slides.SlideShow Namespace


OptionalBlackTransition Properties

The properties of the OptionalBlackTransition class are listed below. For a complete list of OptionalBlackTransition class members, see the OptionalBlackTransition Members topic.

Public Instance Properties

FromBlack This attribute specifies if the transition will start from a black screen (and then transition the new slide over black).

See Also

OptionalBlackTransition Class | Aspose.Slides.SlideShow Namespace


FromBlack Property

Aspose.Slides Documentation

OptionalBlackTransition.FromBlack Property

This attribute specifies if the transition will start from a black screen (and then transition the new slide over black).

[Visual Basic]
NotOverridable Public Property FromBlack As Boolean _
Implements IOptionalBlackTransition.FromBlack
[C#]
public bool FromBlack {get; set;}

Implements

IOptionalBlackTransition.FromBlack

See Also

OptionalBlackTransition Class | Aspose.Slides.SlideShow Namespace


OrientationTransition Class

Orientation slide transition effect.

For a list of all members of this type, see OrientationTransition Members.

System.Object
Aspose.Slides.SlideShow.TransitionValueBase
Aspose.Slides.SlideShow.OrientationTransition

[Visual Basic]
Public Class OrientationTransition
Inherits TransitionValueBase
Implements IOrientationTransition
[C#]
public class OrientationTransition : TransitionValueBase, IOrientationTransition

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

OrientationTransition Members | Aspose.Slides.SlideShow Namespace


OrientationTransition Members

OrientationTransition overview

Public Instance Constructors

OrientationTransition Constructor Constructor for orientation slide transition effects.

Public Instance Properties

Direction Direction of transition.

See Also

OrientationTransition Class | Aspose.Slides.SlideShow Namespace


OrientationTransition Constructor

Constructor for orientation slide transition effects.

[Visual Basic]
Public Sub New( _
ByVal type As TransitionType _
)
[C#]
public OrientationTransition(
TransitionType type
);

Parameters

type
Type of a transition effect.

See Also

OrientationTransition Class | Aspose.Slides.SlideShow Namespace


OrientationTransition Properties

The properties of the OrientationTransition class are listed below. For a complete list of OrientationTransition class members, see the OrientationTransition Members topic.

Public Instance Properties

Direction Direction of transition.

See Also

OrientationTransition Class | Aspose.Slides.SlideShow Namespace


Direction Property

Aspose.Slides Documentation

OrientationTransition.Direction Property

Direction of transition.

[Visual Basic]
NotOverridable Public Property Direction As Orientation _
Implements IOrientationTransition.Direction
[C#]
public Orientation Direction {get; set;}

Implements

IOrientationTransition.Direction

See Also

OrientationTransition Class | Aspose.Slides.SlideShow Namespace


SideDirectionTransition Class

Side direction slide transition effect.

For a list of all members of this type, see SideDirectionTransition Members.

System.Object
Aspose.Slides.SlideShow.TransitionValueBase
Aspose.Slides.SlideShow.SideDirectionTransition

[Visual Basic]
Public Class SideDirectionTransition
Inherits TransitionValueBase
Implements ISideDirectionTransition
[C#]
public class SideDirectionTransition : TransitionValueBase, ISideDirectionTransition

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SideDirectionTransition Members | Aspose.Slides.SlideShow Namespace


SideDirectionTransition Members

SideDirectionTransition overview

Public Instance Constructors

SideDirectionTransition Constructor Constructor for side direction slide transition effects.

Public Instance Properties

Direction Direction of transition.

See Also

SideDirectionTransition Class | Aspose.Slides.SlideShow Namespace


SideDirectionTransition Constructor

Constructor for side direction slide transition effects.

[Visual Basic]
Public Sub New( _
ByVal type As TransitionType _
)
[C#]
public SideDirectionTransition(
TransitionType type
);

Parameters

type
Type of a transition effect.

See Also

SideDirectionTransition Class | Aspose.Slides.SlideShow Namespace


SideDirectionTransition Properties

The properties of the SideDirectionTransition class are listed below. For a complete list of SideDirectionTransition class members, see the SideDirectionTransition Members topic.

Public Instance Properties

Direction Direction of transition.

See Also

SideDirectionTransition Class | Aspose.Slides.SlideShow Namespace


Direction Property

Aspose.Slides Documentation

SideDirectionTransition.Direction Property

Direction of transition.

[Visual Basic]
NotOverridable Public Property Direction As TransitionSideDirectionType _
Implements ISideDirectionTransition.Direction
[C#]
public TransitionSideDirectionType Direction {get; set;}

Implements

ISideDirectionTransition.Direction

See Also

SideDirectionTransition Class | Aspose.Slides.SlideShow Namespace


SlideShowTransition Class

Represents slide show transition.

For a list of all members of this type, see SlideShowTransition Members.

System.Object
Aspose.Slides.SlideShow.SlideShowTransition

[Visual Basic]
Public Class SlideShowTransition
Implements ISlideShowTransition
[C#]
public class SlideShowTransition : ISlideShowTransition

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SlideShowTransition Members | Aspose.Slides.SlideShow Namespace


SlideShowTransition Members

SlideShowTransition overview

Public Instance Properties

AdvanceAfterTime | Specifies the time, in milliseconds, after which the transition should start. This setting may be used in conjunction with the advClick attribute. If this attribute is not specified then it is assumed that no auto-advance will occur.
AdvanceOnClick | Specifies whether a mouse click will advance the slide or not. If this attribute is not specified then a value of true is assumed
BuiltInSound | Obsolete. Specifies whether or not this sound is a built-in sound. If this attribute is set to true then the generating application is alerted to check the name attribute specified for this sound in it's list of built-in sounds and can then surface a custom name or UI as needed.
Sound | Returns or sets the embedded audio data. Read-only Byte[].
SoundIsBuiltIn | Specifies whether or not this sound is a built-in sound. If this attribute is set to true then the generating application is alerted to check the name attribute specified for this sound in it's list of built-in sounds and can then surface a custom name or UI as needed. Read-write Boolean.
SoundLoop | This attribute specifies if the sound will loop until the next sound event occurs in slideshow.
SoundMode | Set or returns sound mode for slide transition.
SoundName | Specifies a human readable name for the sound of the transition. The Sound property must be assigned to get or set the sound name. Read-write String.
Speed | Specifies the transition speed that is to be used when transitioning from the current slide to the next.
Type | Type of transition
Value | Slide show transition value.

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


SlideShowTransition Properties

The properties of the SlideShowTransition class are listed below. For a complete list of SlideShowTransition class members, see the SlideShowTransition Members topic.

Public Instance Properties

AdvanceAfterTime | Specifies the time, in milliseconds, after which the transition should start. This setting may be used in conjunction with the advClick attribute. If this attribute is not specified then it is assumed that no auto-advance will occur.
AdvanceOnClick | Specifies whether a mouse click will advance the slide or not. If this attribute is not specified then a value of true is assumed
BuiltInSound | Obsolete. Specifies whether or not this sound is a built-in sound. If this attribute is set to true then the generating application is alerted to check the name attribute specified for this sound in it's list of built-in sounds and can then surface a custom name or UI as needed.
Sound | Returns or sets the embedded audio data. Read-only Byte[].
SoundIsBuiltIn | Specifies whether or not this sound is a built-in sound. If this attribute is set to true then the generating application is alerted to check the name attribute specified for this sound in it's list of built-in sounds and can then surface a custom name or UI as needed. Read-write Boolean.
SoundLoop | This attribute specifies if the sound will loop until the next sound event occurs in slideshow.
SoundMode | Set or returns sound mode for slide transition.
SoundName | Specifies a human readable name for the sound of the transition. The Sound property must be assigned to get or set the sound name. Read-write String.
Speed | Specifies the transition speed that is to be used when transitioning from the current slide to the next.
Type | Type of transition
Value | Slide show transition value.

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


AdvanceAfterTime Property

Aspose.Slides Documentation

SlideShowTransition.AdvanceAfterTime Property

Specifies the time, in milliseconds, after which the transition should start. This setting may be used in conjunction with the advClick attribute. If this attribute is not specified then it is assumed that no auto-advance will occur.

[Visual Basic]
NotOverridable Public Property AdvanceAfterTime As UInt32 _
Implements ISlideShowTransition.AdvanceAfterTime
[C#]
public uint AdvanceAfterTime {get; set;}

Implements

ISlideShowTransition.AdvanceAfterTime

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


AdvanceOnClick Property

Aspose.Slides Documentation

SlideShowTransition.AdvanceOnClick Property

Specifies whether a mouse click will advance the slide or not. If this attribute is not specified then a value of true is assumed

[Visual Basic]
NotOverridable Public Property AdvanceOnClick As Boolean _
Implements ISlideShowTransition.AdvanceOnClick
[C#]
public bool AdvanceOnClick {get; set;}

Implements

ISlideShowTransition.AdvanceOnClick

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


BuiltInSound Property

Aspose.Slides Documentation

SlideShowTransition.BuiltInSound Property

NOTE: This property is now obsolete.

Use SoundIsBuiltIn property instead. Property will be removed after 01.09.2013.

Specifies whether or not this sound is a built-in sound. If this attribute is set to true then the generating application is alerted to check the name attribute specified for this sound in it's list of built-in sounds and can then surface a custom name or UI as needed.

[Visual Basic]
Public Property BuiltInSound As Boolean
[C#]
public bool BuiltInSound {get; set;}

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


Sound Property

Aspose.Slides Documentation

SlideShowTransition.Sound Property

Returns or sets the embedded audio data. Read-only Byte[].

[Visual Basic]
NotOverridable Public Property Sound As IAudio _
Implements ISlideShowTransition.Sound
[C#]
public IAudio Sound {get; set;}

Implements

ISlideShowTransition.Sound

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


SoundIsBuiltIn Property

Aspose.Slides Documentation

SlideShowTransition.SoundIsBuiltIn Property

Specifies whether or not this sound is a built-in sound. If this attribute is set to true then the generating application is alerted to check the name attribute specified for this sound in it's list of built-in sounds and can then surface a custom name or UI as needed.

Read-write Boolean.

[Visual Basic]
NotOverridable Public Property SoundIsBuiltIn As Boolean _
Implements ISlideShowTransition.SoundIsBuiltIn
[C#]
public bool SoundIsBuiltIn {get; set;}

Implements

ISlideShowTransition.SoundIsBuiltIn

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


SoundLoop Property

Aspose.Slides Documentation

SlideShowTransition.SoundLoop Property

This attribute specifies if the sound will loop until the next sound event occurs in slideshow.

[Visual Basic]
NotOverridable Public Property SoundLoop As Boolean _
Implements ISlideShowTransition.SoundLoop
[C#]
public bool SoundLoop {get; set;}

Implements

ISlideShowTransition.SoundLoop

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


SoundMode Property

Aspose.Slides Documentation

SlideShowTransition.SoundMode Property

Set or returns sound mode for slide transition.

[Visual Basic]
NotOverridable Public Property SoundMode As TransitionSoundMode _
Implements ISlideShowTransition.SoundMode
[C#]
public TransitionSoundMode SoundMode {get; set;}

Implements

ISlideShowTransition.SoundMode

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


SoundName Property

Aspose.Slides Documentation

SlideShowTransition.SoundName Property

Specifies a human readable name for the sound of the transition. The Sound property must be assigned to get or set the sound name.

Read-write String.

[Visual Basic]
NotOverridable Public Property SoundName As String _
Implements ISlideShowTransition.SoundName
[C#]
public string SoundName {get; set;}

Implements

ISlideShowTransition.SoundName

Remarks

This name appears in the PowerPoint user interface when configuring the transition sound manually.

Exceptions

Exception Type | Condition
PptxException | When Sound property is not assigned.

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


Speed Property

Aspose.Slides Documentation

SlideShowTransition.Speed Property

Specifies the transition speed that is to be used when transitioning from the current slide to the next.

[Visual Basic]
NotOverridable Public Property Speed As TransitionSpeed _
Implements ISlideShowTransition.Speed
[C#]
public TransitionSpeed Speed {get; set;}

Implements

ISlideShowTransition.Speed

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


Type Property

Aspose.Slides Documentation

SlideShowTransition.Type Property

Type of transition

[Visual Basic]
NotOverridable Public Property Type As TransitionType _
Implements ISlideShowTransition.Type
[C#]
public TransitionType Type {get; set;}

Implements

ISlideShowTransition.Type

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


Value Property

Aspose.Slides Documentation

SlideShowTransition.Value Property

Slide show transition value.

[Visual Basic]
NotOverridable Public ReadOnly Property Value As ITransitionValueBase _
Implements ISlideShowTransition.Value
[C#]
public ITransitionValueBase Value {get;}

Implements

ISlideShowTransition.Value

See Also

SlideShowTransition Class | Aspose.Slides.SlideShow Namespace


SplitTransition Class

Split slide transition effect.

For a list of all members of this type, see SplitTransition Members.

System.Object
Aspose.Slides.SlideShow.TransitionValueBase
Aspose.Slides.SlideShow.SplitTransition

[Visual Basic]
Public Class SplitTransition
Inherits TransitionValueBase
Implements ISplitTransition
[C#]
public class SplitTransition : TransitionValueBase, ISplitTransition

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SplitTransition Members | Aspose.Slides.SlideShow Namespace


SplitTransition Members

SplitTransition overview

Public Instance Constructors

SplitTransition Constructor Constructor for split slide transition effects.

Public Instance Properties

Direction | Direction of transition split. Read/write TransitionInOutDirectionType.
Orientation | Orientation of transition split. Read/write Orientation.

See Also

SplitTransition Class | Aspose.Slides.SlideShow Namespace


SplitTransition Constructor

Constructor for split slide transition effects.

[Visual Basic]
Public Sub New( _
ByVal type As TransitionType _
)
[C#]
public SplitTransition(
TransitionType type
);

Parameters

type
Type of a split transition effect.

See Also

SplitTransition Class | Aspose.Slides.SlideShow Namespace


SplitTransition Properties

The properties of the SplitTransition class are listed below. For a complete list of SplitTransition class members, see the SplitTransition Members topic.

Public Instance Properties

Direction | Direction of transition split. Read/write TransitionInOutDirectionType.
Orientation | Orientation of transition split. Read/write Orientation.

See Also

SplitTransition Class | Aspose.Slides.SlideShow Namespace


Direction Property

Aspose.Slides Documentation

SplitTransition.Direction Property

Direction of transition split. Read/write TransitionInOutDirectionType.

[Visual Basic]
NotOverridable Public Property Direction As TransitionInOutDirectionType _
Implements ISplitTransition.Direction
[C#]
public TransitionInOutDirectionType Direction {get; set;}

Implements

ISplitTransition.Direction

See Also

SplitTransition Class | Aspose.Slides.SlideShow Namespace


Orientation Property

Aspose.Slides Documentation

SplitTransition.Orientation Property

Orientation of transition split. Read/write Orientation.

[Visual Basic]
NotOverridable Public Property Orientation As Orientation _
Implements ISplitTransition.Orientation
[C#]
public Orientation Orientation {get; set;}

Implements

ISplitTransition.Orientation

See Also

SplitTransition Class | Aspose.Slides.SlideShow Namespace


TransitionCornerDirectionType Enumeration

[Visual Basic]
Public Enum TransitionCornerDirectionType
[C#]
public enum TransitionCornerDirectionType

Members

Member Name | Description | Value
LeftDown |  | 0
LeftUp |  | 1
RightDown |  | 2
RightUp |  | 3

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.SlideShow Namespace


TransitionEightDirectionType Enumeration

[Visual Basic]
Public Enum TransitionEightDirectionType
[C#]
public enum TransitionEightDirectionType

Members

Member Name | Description | Value
LeftDown |  | 0
LeftUp |  | 1
RightDown |  | 2
RightUp |  | 3
Left |  | 4
Up |  | 5
Down |  | 6
Right |  | 7

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.SlideShow Namespace


TransitionInOutDirectionType Enumeration

[Visual Basic]
Public Enum TransitionInOutDirectionType
[C#]
public enum TransitionInOutDirectionType

Members

Member Name | Description | Value
In |  | 0
Out |  | 1

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.SlideShow Namespace


TransitionSideDirectionType Enumeration

[Visual Basic]
Public Enum TransitionSideDirectionType
[C#]
public enum TransitionSideDirectionType

Members

Member Name | Description | Value
Left |  | 0
Up |  | 1
Down |  | 2
Right |  | 3

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.SlideShow Namespace


TransitionSoundMode Enumeration

[Visual Basic]
Public Enum TransitionSoundMode
[C#]
public enum TransitionSoundMode

Members

Member Name | Description | Value
NotDefined |  | -1
StartSound |  | 0
StopPrevoiusSound |  | 1

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.SlideShow Namespace


TransitionSpeed Enumeration

[Visual Basic]
Public Enum TransitionSpeed
[C#]
public enum TransitionSpeed

Members

Member Name | Description | Value
Fast |  | 0
Medium |  | 1
Slow |  | 2

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.SlideShow Namespace


TransitionType Enumeration

[Visual Basic]
Public Enum TransitionType
[C#]
public enum TransitionType

Members

Member Name | Description | Value
None |  | 0
Blinds |  | 1
Checker |  | 2
Circle |  | 3
Comb |  | 4
Cover |  | 5
Cut |  | 6
Diamond |  | 7
Dissolve |  | 8
Fade |  | 9
Newsflash |  | 10
Plus |  | 11
Pull |  | 12
Push |  | 13
Random |  | 14
RandomBar |  | 15
SoundAction |  | 16
Split |  | 17
Strips |  | 18
Wedge |  | 19
Wheel |  | 20
Wipe |  | 21
Zoom |  | 22

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.SlideShow Namespace


TransitionValueBase Class

Base class for slide transition effects.

For a list of all members of this type, see TransitionValueBase Members.

System.Object
Aspose.Slides.SlideShow.TransitionValueBase
Derived types

[Visual Basic]
Public Class TransitionValueBase
Implements ITransitionValueBase
[C#]
public class TransitionValueBase : ITransitionValueBase

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TransitionValueBase Members | Aspose.Slides.SlideShow Namespace


TransitionValueBase Members

TransitionValueBase overview

Public Instance Constructors

TransitionValueBase Constructor Slide transition effect constructor.

See Also

TransitionValueBase Class | Aspose.Slides.SlideShow Namespace


TransitionValueBase Constructor

Slide transition effect constructor.

[Visual Basic]
Public Sub New( _
ByVal type As TransitionType _
)
[C#]
public TransitionValueBase(
TransitionType type
);

Parameters

type
Type of a transition effect.

See Also

TransitionValueBase Class | Aspose.Slides.SlideShow Namespace


TransitionValueFactory Class

Allows to create instances of classes inherited from ITransitionValueBase

For a list of all members of this type, see TransitionValueFactory Members.

System.Object
Aspose.Slides.SlideShow.TransitionValueFactory

[Visual Basic]
Public Class TransitionValueFactory
Implements ITransitionValueFactory
[C#]
public class TransitionValueFactory : ITransitionValueFactory

Remarks

For COM compatibility

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

TransitionValueFactory Members | Aspose.Slides.SlideShow Namespace


TransitionValueFactory Members

TransitionValueFactory overview

Public Instance Constructors

TransitionValueFactory Constructor Initializes a new instance of the TransitionValueFactory class.

Public Instance Methods

CreateCornerDirectionTransition
CreateEightDirectionTransition
CreateEmptyTransition
CreateInOutTransition
CreateOptionalBlackTransition
CreateOrientationTransition
CreateSideDirectionTransition
CreateSplitTransition
CreateWheelTransition

See Also

TransitionValueFactory Class | Aspose.Slides.SlideShow Namespace


TransitionValueFactory Constructor

Initializes a new instance of the TransitionValueFactory class.

[Visual Basic]
Public Sub New()
[C#]
public TransitionValueFactory();

See Also

TransitionValueFactory Class | Aspose.Slides.SlideShow Namespace


TransitionValueFactory Methods

The methods of the TransitionValueFactory class are listed below. For a complete list of TransitionValueFactory class members, see the TransitionValueFactory Members topic.

Public Instance Methods

CreateCornerDirectionTransition
CreateEightDirectionTransition
CreateEmptyTransition
CreateInOutTransition
CreateOptionalBlackTransition
CreateOrientationTransition
CreateSideDirectionTransition
CreateSplitTransition
CreateWheelTransition

See Also

TransitionValueFactory Class | Aspose.Slides.SlideShow Namespace


TransitionValueFactory.CreateCornerDirectionTransition Method

[Visual Basic]
NotOverridable Public Function CreateCornerDirectionTransition( _
ByVal type As TransitionType _
) As ICornerDirectionTransition _
Implements ITransitionValueFactory.CreateCornerDirectionTransition
[C#]
public ICornerDirectionTransition CreateCornerDirectionTransition(
TransitionType type
);

Implements

ITransitionValueFactory.CreateCornerDirectionTransition

See Also

TransitionValueFactory Class | Aspose.Slides.SlideShow Namespace


TransitionValueFactory.CreateEightDirectionTransition Method

[Visual Basic]
NotOverridable Public Function CreateEightDirectionTransition( _
ByVal type As TransitionType _
) As IEightDirectionTransition _
Implements ITransitionValueFactory.CreateEightDirectionTransition
[C#]
public IEightDirectionTransition CreateEightDirectionTransition(
TransitionType type
);

Implements

ITransitionValueFactory.CreateEightDirectionTransition

See Also

TransitionValueFactory Class | Aspose.Slides.SlideShow Namespace


TransitionValueFactory.CreateEmptyTransition Method

[Visual Basic]
NotOverridable Public Function CreateEmptyTransition( _
ByVal type As TransitionType _
) As IEmptyTransition _
Implements ITransitionValueFactory.CreateEmptyTransition
[C#]
public IEmptyTransition CreateEmptyTransition(
TransitionType type
);

Implements

ITransitionValueFactory.CreateEmptyTransition

See Also

TransitionValueFactory Class | Aspose.Slides.SlideShow Namespace


TransitionValueFactory.CreateInOutTransition Method

[Visual Basic]
NotOverridable Public Function CreateInOutTransition( _
ByVal type As TransitionType _
) As IInOutTransition _
Implements ITransitionValueFactory.CreateInOutTransition
[C#]
public IInOutTransition CreateInOutTransition(
TransitionType type
);

Implements

ITransitionValueFactory.CreateInOutTransition

See Also

TransitionValueFactory Class | Aspose.Slides.SlideShow Namespace


TransitionValueFactory.CreateOptionalBlackTransition Method

[Visual Basic]
NotOverridable Public Function CreateOptionalBlackTransition( _
ByVal type As TransitionType _
) As IOptionalBlackTransition _
Implements ITransitionValueFactory.CreateOptionalBlackTransition
[C#]
public IOptionalBlackTransition CreateOptionalBlackTransition(
TransitionType type
);

Implements

ITransitionValueFactory.CreateOptionalBlackTransition

See Also

TransitionValueFactory Class | Aspose.Slides.SlideShow Namespace


TransitionValueFactory.CreateOrientationTransition Method

[Visual Basic]
NotOverridable Public Function CreateOrientationTransition( _
ByVal type As TransitionType _
) As IOrientationTransition _
Implements ITransitionValueFactory.CreateOrientationTransition
[C#]
public IOrientationTransition CreateOrientationTransition(
TransitionType type
);

Implements

ITransitionValueFactory.CreateOrientationTransition

See Also

TransitionValueFactory Class | Aspose.Slides.SlideShow Namespace


TransitionValueFactory.CreateSideDirectionTransition Method

[Visual Basic]
NotOverridable Public Function CreateSideDirectionTransition( _
ByVal type As TransitionType _
) As ISideDirectionTransition _
Implements ITransitionValueFactory.CreateSideDirectionTransition
[C#]
public ISideDirectionTransition CreateSideDirectionTransition(
TransitionType type
);

Implements

ITransitionValueFactory.CreateSideDirectionTransition

See Also

TransitionValueFactory Class | Aspose.Slides.SlideShow Namespace


TransitionValueFactory.CreateSplitTransition Method

[Visual Basic]
NotOverridable Public Function CreateSplitTransition( _
ByVal type As TransitionType _
) As ISplitTransition _
Implements ITransitionValueFactory.CreateSplitTransition
[C#]
public ISplitTransition CreateSplitTransition(
TransitionType type
);

Implements

ITransitionValueFactory.CreateSplitTransition

See Also

TransitionValueFactory Class | Aspose.Slides.SlideShow Namespace


TransitionValueFactory.CreateWheelTransition Method

[Visual Basic]
NotOverridable Public Function CreateWheelTransition( _
ByVal type As TransitionType _
) As IWheelTransition _
Implements ITransitionValueFactory.CreateWheelTransition
[C#]
public IWheelTransition CreateWheelTransition(
TransitionType type
);

Implements

ITransitionValueFactory.CreateWheelTransition

See Also

TransitionValueFactory Class | Aspose.Slides.SlideShow Namespace


WheelTransition Class

Wheel slide transition effect.

For a list of all members of this type, see WheelTransition Members.

System.Object
Aspose.Slides.SlideShow.TransitionValueBase
Aspose.Slides.SlideShow.WheelTransition

[Visual Basic]
Public Class WheelTransition
Inherits TransitionValueBase
Implements IWheelTransition
[C#]
public class WheelTransition : TransitionValueBase, IWheelTransition

Requirements

Namespace: Aspose.Slides.SlideShow

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

WheelTransition Members | Aspose.Slides.SlideShow Namespace


WheelTransition Members

WheelTransition overview

Public Instance Constructors

WheelTransition Constructor Creates wheel

Public Instance Properties

Spokes Number spokes of wheel transition.

See Also

WheelTransition Class | Aspose.Slides.SlideShow Namespace


WheelTransition Constructor

Creates wheel

[Visual Basic]
Public Sub New( _
ByVal type As TransitionType _
)
[C#]
public WheelTransition(
TransitionType type
);

Parameters

type

See Also

WheelTransition Class | Aspose.Slides.SlideShow Namespace


WheelTransition Properties

The properties of the WheelTransition class are listed below. For a complete list of WheelTransition class members, see the WheelTransition Members topic.

Public Instance Properties

Spokes Number spokes of wheel transition.

See Also

WheelTransition Class | Aspose.Slides.SlideShow Namespace


Spokes Property

Aspose.Slides Documentation

WheelTransition.Spokes Property

Number spokes of wheel transition.

[Visual Basic]
NotOverridable Public Property Spokes As UInt32 _
Implements IWheelTransition.Spokes
[C#]
public uint Spokes {get; set;}

Implements

IWheelTransition.Spokes

See Also

WheelTransition Class | Aspose.Slides.SlideShow Namespace


Aspose.Slides.SmartArt

Aspose.Slides Documentation

Aspose.Slides.SmartArt Namespace

Namespace hierarchy

Classes

Class | Description
SmartArt | Represents SmartArt object on a slide.
SmartArtNode | Represents node of SmartArt object
SmartArtNodeCollection | Represents a collection of a SmartArt nodes.

Interfaces

Interface | Description
ISmartArt |
ISmartArtNode |
ISmartArtNodeCollection |

Enumerations

Enumeration | Description
SmartArtColorType |
SmartArtLayoutType |
SmartArtQuickStyleType |


ISmartArt Interface

For a list of all members of this type, see ISmartArt Members.

[Visual Basic]
Public Interface ISmartArt
Implements IGraphicalObject, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer
[C#]
public interface ISmartArt : IGraphicalObject, IShape, ISlideComponent, IPresentationComponent, IHyperlinkContainer

Types that implement ISmartArt

Type | Description
SmartArt | Represents SmartArt object on a slide.

Requirements

Namespace: Aspose.Slides.SmartArt

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISmartArt Members | Aspose.Slides.SmartArt Namespace


ISmartArt Members

ISmartArt overview

Public Instance Properties

AllNodes
AsIGraphicalObject
ColorStyle
Layout
QuickStyle

See Also

ISmartArt Interface | Aspose.Slides.SmartArt Namespace


ISmartArt Properties

The properties of the ISmartArt interface are listed below. For a complete list of ISmartArt interface members, see the ISmartArt Members topic.

Public Instance Properties

AllNodes
AsIGraphicalObject
ColorStyle
Layout
QuickStyle

See Also

ISmartArt Interface | Aspose.Slides.SmartArt Namespace


AllNodes Property

Aspose.Slides Documentation

ISmartArt.AllNodes Property

[Visual Basic]
Property AllNodes As ISmartArtNodeCollection
[C#]
ISmartArtNodeCollection AllNodes {get;}

See Also

ISmartArt Interface | Aspose.Slides.SmartArt Namespace


AsIGraphicalObject Property

Aspose.Slides Documentation

ISmartArt.AsIGraphicalObject Property

[Visual Basic]
Property AsIGraphicalObject As IGraphicalObject
[C#]
IGraphicalObject AsIGraphicalObject {get;}

See Also

ISmartArt Interface | Aspose.Slides.SmartArt Namespace


ColorStyle Property

Aspose.Slides Documentation

ISmartArt.ColorStyle Property

[Visual Basic]
Property ColorStyle As SmartArtColorType
[C#]
SmartArtColorType ColorStyle {get; set;}

See Also

ISmartArt Interface | Aspose.Slides.SmartArt Namespace


Layout Property

Aspose.Slides Documentation

ISmartArt.Layout Property

[Visual Basic]
Property Layout As SmartArtLayoutType
[C#]
SmartArtLayoutType Layout {get;}

See Also

ISmartArt Interface | Aspose.Slides.SmartArt Namespace


QuickStyle Property

Aspose.Slides Documentation

ISmartArt.QuickStyle Property

[Visual Basic]
Property QuickStyle As SmartArtQuickStyleType
[C#]
SmartArtQuickStyleType QuickStyle {get; set;}

See Also

ISmartArt Interface | Aspose.Slides.SmartArt Namespace


ISmartArtNode Interface

For a list of all members of this type, see ISmartArtNode Members.

[Visual Basic]
Public Interface ISmartArtNode
[C#]
public interface ISmartArtNode

Types that implement ISmartArtNode

Type | Description
SmartArtNode | Represents node of SmartArt object

Requirements

Namespace: Aspose.Slides.SmartArt

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISmartArtNode Members | Aspose.Slides.SmartArt Namespace


ISmartArtNode Members

ISmartArtNode overview

Public Instance Properties

BulletFillFormat
ChildNodes
IsAssistant
Level
Position
TextFrame

Public Instance Methods

Remove

See Also

ISmartArtNode Interface | Aspose.Slides.SmartArt Namespace


ISmartArtNode Properties

The properties of the ISmartArtNode interface are listed below. For a complete list of ISmartArtNode interface members, see the ISmartArtNode Members topic.

Public Instance Properties

BulletFillFormat
ChildNodes
IsAssistant
Level
Position
TextFrame

See Also

ISmartArtNode Interface | Aspose.Slides.SmartArt Namespace


BulletFillFormat Property

Aspose.Slides Documentation

ISmartArtNode.BulletFillFormat Property

[Visual Basic]
Property BulletFillFormat As IFillFormat
[C#]
IFillFormat BulletFillFormat {get;}

See Also

ISmartArtNode Interface | Aspose.Slides.SmartArt Namespace


ChildNodes Property

Aspose.Slides Documentation

ISmartArtNode.ChildNodes Property

[Visual Basic]
Property ChildNodes As ISmartArtNodeCollection
[C#]
ISmartArtNodeCollection ChildNodes {get;}

See Also

ISmartArtNode Interface | Aspose.Slides.SmartArt Namespace


IsAssistant Property

Aspose.Slides Documentation

ISmartArtNode.IsAssistant Property

[Visual Basic]
Property IsAssistant As Boolean
[C#]
bool IsAssistant {get; set;}

See Also

ISmartArtNode Interface | Aspose.Slides.SmartArt Namespace


Level Property

Aspose.Slides Documentation

ISmartArtNode.Level Property

[Visual Basic]
Property Level As Integer
[C#]
int Level {get;}

See Also

ISmartArtNode Interface | Aspose.Slides.SmartArt Namespace


Position Property

Aspose.Slides Documentation

ISmartArtNode.Position Property

[Visual Basic]
Property Position As Integer
[C#]
int Position {get; set;}

See Also

ISmartArtNode Interface | Aspose.Slides.SmartArt Namespace


TextFrame Property

Aspose.Slides Documentation

ISmartArtNode.TextFrame Property

[Visual Basic]
Property TextFrame As ITextFrame
[C#]
ITextFrame TextFrame {get; set;}

See Also

ISmartArtNode Interface | Aspose.Slides.SmartArt Namespace


ISmartArtNode Methods

The methods of the ISmartArtNode interface are listed below. For a complete list of ISmartArtNode interface members, see the ISmartArtNode Members topic.

Public Instance Methods

Remove

See Also

ISmartArtNode Interface | Aspose.Slides.SmartArt Namespace


ISmartArtNode.Remove Method

[Visual Basic]
Function Remove() As Boolean
[C#]
bool Remove();

See Also

ISmartArtNode Interface | Aspose.Slides.SmartArt Namespace


ISmartArtNodeCollection Interface

For a list of all members of this type, see ISmartArtNodeCollection Members.

[Visual Basic]
Public Interface ISmartArtNodeCollection
Implements IEnumerable
[C#]
public interface ISmartArtNodeCollection : IEnumerable

Types that implement ISmartArtNodeCollection

Type | Description
SmartArtNodeCollection | Represents a collection of a SmartArt nodes.

Requirements

Namespace: Aspose.Slides.SmartArt

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ISmartArtNodeCollection Members | Aspose.Slides.SmartArt Namespace


ISmartArtNodeCollection Members

ISmartArtNodeCollection overview

Public Instance Properties

AsIEnumerable
Count
Item

Public Instance Methods

AddNode |
AddNodeByPosition |
GetNodeByPosition |
RemoveNode | Overloaded.
RemoveNodeByPosition |

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace


ISmartArtNodeCollection Properties

The properties of the ISmartArtNodeCollection interface are listed below. For a complete list of ISmartArtNodeCollection interface members, see the ISmartArtNodeCollection Members topic.

Public Instance Properties

AsIEnumerable
Count
Item

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ISmartArtNodeCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace


Count Property

Aspose.Slides Documentation

ISmartArtNodeCollection.Count Property

[Visual Basic]
Property Count As Integer
[C#]
int Count {get;}

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace


Item Property

Aspose.Slides Documentation

ISmartArtNodeCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As ISmartArtNode
[C#]
ISmartArtNode this[
int index
] {get;}

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace


ISmartArtNodeCollection Methods

The methods of the ISmartArtNodeCollection interface are listed below. For a complete list of ISmartArtNodeCollection interface members, see the ISmartArtNodeCollection Members topic.

Public Instance Methods

AddNode |
AddNodeByPosition |
GetNodeByPosition |
RemoveNode | Overloaded.
RemoveNodeByPosition |

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace


ISmartArtNodeCollection.AddNode Method

[Visual Basic]
Function AddNode() As ISmartArtNode
[C#]
ISmartArtNode AddNode();

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace


ISmartArtNodeCollection.AddNodeByPosition Method

[Visual Basic]
Function AddNodeByPosition( _
ByVal position As Integer _
) As ISmartArtNode
[C#]
ISmartArtNode AddNodeByPosition(
int position
);

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace


ISmartArtNodeCollection.GetNodeByPosition Method

[Visual Basic]
Function GetNodeByPosition( _
ByVal position As Integer _
) As ISmartArtNode
[C#]
ISmartArtNode GetNodeByPosition(
int position
);

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace


RemoveNode Method

Aspose.Slides Documentation

ISmartArtNodeCollection.RemoveNode Method

Overload List

void RemoveNode(ISmartArtNode);

void RemoveNode(int);

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace


ISmartArtNodeCollection.RemoveNode Method (ISmartArtNode)

[Visual Basic]
Sub RemoveNode( _
ByVal nodeObj As ISmartArtNode _
)
[C#]
void RemoveNode(
ISmartArtNode nodeObj
);

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace | ISmartArtNodeCollection.RemoveNode Overload List


ISmartArtNodeCollection.RemoveNode Method (Int32)

[Visual Basic]
Sub RemoveNode( _
ByVal index As Integer _
)
[C#]
void RemoveNode(
int index
);

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace | ISmartArtNodeCollection.RemoveNode Overload List


ISmartArtNodeCollection.RemoveNodeByPosition Method

[Visual Basic]
Function RemoveNodeByPosition( _
ByVal position As Integer _
) As Boolean
[C#]
bool RemoveNodeByPosition(
int position
);

See Also

ISmartArtNodeCollection Interface | Aspose.Slides.SmartArt Namespace


SmartArt Class

Represents SmartArt object on a slide.

For a list of all members of this type, see SmartArt Members.

System.Object
Aspose.Slides.Shape
Aspose.Slides.GraphicalObject
Aspose.Slides.SmartArt.SmartArt

[Visual Basic]
Public Class SmartArt
Inherits GraphicalObject
Implements ISmartArt
[C#]
public class SmartArt : GraphicalObject, ISmartArt

Example

Example:

[C#]
Presentation pres = new Presentation();
Slide slide = pres.Slides[0];
SmartArt smart = slide.Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.BasicBlockList);

[Visual Basic]
Private pres As New Presentation()
Private slide As Slide = pres.Slides(0)
Private smart As SmartArt = slide.Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.BasicBlockList)

[C#]
Presentation pres = new Presentation("demo.pptx");
foreach (Shape shape in pres.Slides[0].Shapes)
           {
               if (shape is SmartArt)
                SmartArt smart = (SmartArt) pres.Slides[0].Shapes[0];
           }

[Visual Basic]
Dim pres As New Presentation("demo.pptx")
For Each shape As Shape In pres.Slides(0).Shapes
If TypeOf shape Is SmartArt Then
    Dim smart As SmartArt = DirectCast(pres.Slides(0).Shapes(0), SmartArt)
End If
Next

Requirements

Namespace: Aspose.Slides.SmartArt

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SmartArt Members | Aspose.Slides.SmartArt Namespace


SmartArt Members

SmartArt overview

Public Instance Properties

AllNodes | Returns collections of all nodes in SmartArt object
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
ColorStyle | Return or set color style of smart art object
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
Layout | Return layout of smartart object
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
QuickStyle | Return or set quick style of smartart object
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock (inherited from GraphicalObject) | Returns shape's locks. Read-only GraphicalObjectLock.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

Public Instance Methods

AddPlaceholder (inherited from Shape) | Adds a new placeholder if there is no and sets placeholder properties to a specified one.
CreateEffectFormatEffective (inherited from Shape) | Creates the EffectFormatData object that contains all effects applyed to a shape, included inherited.
CreateFillFormatEffective (inherited from Shape) | Creates the FillFormatData object that contains all fill formatting properties for a shape, included inherited.
CreateLineFormatEffective (inherited from Shape) | Creates the LineFormatData object that contains all line formatting properties for a shape, included inherited.
CreateThreeDFormatEffective (inherited from Shape) | Creates the ThreeDFormatData object that contains volume properties and 3D transformation of a shape, included inherited.
GetThumbnail (inherited from Shape) | Overloaded.
RemovePlaceholder (inherited from Shape) | Defines that this shape isn't a placeholder.

See Also

SmartArt Class | Aspose.Slides.SmartArt Namespace


SmartArt Properties

The properties of the SmartArt class are listed below. For a complete list of SmartArt class members, see the SmartArt Members topic.

Public Instance Properties

AllNodes | Returns collections of all nodes in SmartArt object
AlternativeText (inherited from Shape) | Returns or sets the alternative text associated with a shape. Read/write String.
ColorStyle | Return or set color style of smart art object
CustomData (inherited from Shape) | Returns the shape's custom data. Read-only ICustomData.
EffectFormat (inherited from Shape) | Returns the EffectFormat object which contains pixel effects applied to a shape. Read-only EffectFormat Note: can return null for certain types of shapes which don't have effect properties.
FillFormat (inherited from Shape) | Returns the FillFormat object that contains fill formatting properties for a shape. Read-only FillFormat. Note: can return null for certain types of shapes which don't have fill properties.
Frame (inherited from Shape) | Returns or sets the shape frame's properties. Read/write ShapeFrame.
Height (inherited from Shape) | Returns or sets the height of the shape. Read/write Int32.
Hidden (inherited from Shape) | Determines whether the shape is hidden. Read/write Boolean.
HLinkClick (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HLinkMouseOver (inherited from Shape) | Obsolete. Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
HyperlinkClick (inherited from Shape) | Returns or sets the hyperlink defined for mouse click. Read/write Hyperlink.
HyperlinkManager (inherited from Shape) |
HyperlinkMouseOver (inherited from Shape) | Returns or sets the hyperlink defined for mouse over. Read/write Hyperlink.
IsTextHolder (inherited from Shape) | Determines whether the shape is TextHolder_PPT. Read-only Boolean.
Layout | Return layout of smartart object
LineFormat (inherited from Shape) | Returns the LineFormat object that contains line formatting properties for a shape. Read-only LineFormat. Note: can return null for certain types of shapes which don't have line properties.
Name (inherited from Shape) | Returns or sets the name of a shape. Must be not null. Use empty string value if needed. Read/write String.
Placeholder (inherited from Shape) | Returns the placeholder for a shape. Returns null if the shape has no placeholder. Read-only Placeholder.
Presentation (inherited from Shape) | Returns the parent presentation of a slide. Read-only Presentation.
QuickStyle | Return or set quick style of smartart object
RawFrame (inherited from Shape) | Returns or sets the raw shape frame's properties. Read/write ShapeFrame.
Rotation (inherited from Shape) | Returns or sets the number of degrees the specified shape is rotated around the z-axis. A positive value indicates clockwise rotation; a negative value indicates counterclockwise rotation. Read/write Single.
ShapeLock (inherited from GraphicalObject) | Returns shape's locks. Read-only GraphicalObjectLock.
Slide (inherited from Shape) | Returns the parent slide of a shape. Read-only BaseSlide.
Tags (inherited from Shape) | Obsolete. Returns the shape's tags collection. Read-only ITagCollection.
ThreeDFormat (inherited from Shape) | Returns the ThreeDFormat object that 3d effect properties for a shape. Read-only ThreeDFormat. Note: can return null for certain types of shapes which don't have 3d properties.
UniqueId (inherited from Shape) | Gets unique shape identifier in presentation scope.
Width (inherited from Shape) | Returns or sets the width of the shape. Read/write Int32.
X (inherited from Shape) | Returns or sets the x-coordinate of the upper-left corner of the shape. Read/write Int32.
Y (inherited from Shape) | Returns or sets the y-coordinate of the upper-left corner of the shape. Read/write Int32.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order. Shapes[0] returns the shape at the back of the z-order, and Shapes[Shapes.Count - 1] returns the shape at the front of the z-order. Read-only Int32.

See Also

SmartArt Class | Aspose.Slides.SmartArt Namespace


AllNodes Property

Aspose.Slides Documentation

SmartArt.AllNodes Property

Returns collections of all nodes in SmartArt object

[Visual Basic]
NotOverridable Public ReadOnly Property AllNodes As ISmartArtNodeCollection _
Implements ISmartArt.AllNodes
[C#]
public ISmartArtNodeCollection AllNodes {get;}

Implements

ISmartArt.AllNodes

Example

[C#]
Presentation pres = new Presentation("demo.pptx");
SmartArt smart = (SmartArt)pres.Slides[0].Shapes[0];
for ( int i = 0; i < smart.AllNodes.Count; i++)
{
    SmartArtNode node = smart.AllNodes[i];
    string outString = string.Format("i = {0}, Text = {1},  Level = {2}, Position = {3}", i, node.TextFrame.Text,
    node.Level, node.Position);
    Console.WriteLine(outString);
}

[Visual Basic]
Dim pres As New Presentation("demo.pptx")
Dim smart As SmartArt = DirectCast(pres.Slides(0).Shapes(0), SmartArt)
Dim i As Integer = 0
While i < smart.AllNodes.Count
Dim node As SmartArtNode = smart.AllNodes(i)
Dim outString As String = String.Format("i = {0}, Text = {1},  Level = {2}, Position = {3}", i, node.TextFrame.Text, node.Level, node.Position)
Console.WriteLine(outString)
System.Math.Max(System.Threading.Interlocked.Increment(i),i - 1)
End While

See Also

SmartArt Class | Aspose.Slides.SmartArt Namespace


ColorStyle Property

Aspose.Slides Documentation

SmartArt.ColorStyle Property

Return or set color style of smart art object

[Visual Basic]
NotOverridable Public Property ColorStyle As SmartArtColorType _
Implements ISmartArt.ColorStyle
[C#]
public SmartArtColorType ColorStyle {get; set;}

Implements

ISmartArt.ColorStyle

Example

[C#]
Presentation pres = new Presentation("demo.pptx");
foreach (Shape shape in pres.Slides[0].Shapes)
           {
               if (shape is SmartArt)
               {
                    SmartArt smart = (SmartArt) pres.Slides[0].Shapes[0];
                    if (smart.ColorStyle == SmartArtColorType.ColoredFillAccent1)
                    {smart.ColorStyle =SmartArtColorType.TransparentGradientRangeAccent1;}
               }
           }

[Visual Basic]
Dim pres As New Presentation("demo.pptx")
For Each shape As Shape In pres.Slides(0).Shapes
    If TypeOf shape Is SmartArt Then
        Dim smart As SmartArt = DirectCast(pres.Slides(0).Shapes(0), SmartArt)
        If smart.ColorStyle = SmartArtColorType.ColoredFillAccent1 Then
        smart.ColorStyle = SmartArtColorType.TransparentGradientRangeAccent1
        End If
    End If
Next

See Also

SmartArt Class | Aspose.Slides.SmartArt Namespace


Layout Property

Aspose.Slides Documentation

SmartArt.Layout Property

Return layout of smartart object

[Visual Basic]
NotOverridable Public ReadOnly Property Layout As SmartArtLayoutType _
Implements ISmartArt.Layout
[C#]
public SmartArtLayoutType Layout {get;}

Implements

ISmartArt.Layout

Example

[C#]
Presentation pres = new Presentation("demo.pptx");
foreach (Shape shape in pres.Slides[0].Shapes)
           {
               if (shape is SmartArt)
                {
                    SmartArt smart = (SmartArt) pres.Slides[0].Shapes[0];
                    if (smart.Layout == SmartArtLayoutType.BasicBlockList)
                    {...do something }
                }
           }

[Visual Basic]
Dim pres As New Presentation("demo.pptx")
For Each shape As Shape In pres.Slides(0).Shapes
    If TypeOf shape Is SmartArt Then
    Dim smart As SmartArt = DirectCast(pres.Slides(0).Shapes(0), SmartArt)
        If smart.Layout = SmartArtLayoutType.BasicBlockList Then
        ...do something
        End If
    End If
Next

See Also

SmartArt Class | Aspose.Slides.SmartArt Namespace


QuickStyle Property

Aspose.Slides Documentation

SmartArt.QuickStyle Property

Return or set quick style of smartart object

[Visual Basic]
NotOverridable Public Property QuickStyle As SmartArtQuickStyleType _
Implements ISmartArt.QuickStyle
[C#]
public SmartArtQuickStyleType QuickStyle {get; set;}

Implements

ISmartArt.QuickStyle

Example

[C#]
Presentation pres = new Presentation("demo.pptx");
foreach (Shape shape in pres.Slides[0].Shapes)
           {
               if (shape is SmartArt)
                {
                    SmartArt smart = (SmartArt) pres.Slides[0].Shapes[0];
                    if (smart.QuickStyle == SmartArtQuickStyleType.BirdsEyeScene)
                    {smart.QuickStyle = SmartArtQuickStyleType.Cartoon;}
                }
           }

[Visual Basic]
Dim pres As New Presentation("demo.pptx")
For Each shape As Shape In pres.Slides(0).Shapes
    If TypeOf shape Is SmartArt Then
        Dim smart As SmartArt = DirectCast(pres.Slides(0).Shapes(0), SmartArt)
        If smart.QuickStyle = SmartArtQuickStyleType.BirdsEyeScene Then
        smart.QuickStyle = SmartArtQuickStyleType.Cartoon
        End If
    End If
Next

See Also

SmartArt Class | Aspose.Slides.SmartArt Namespace


SmartArtColorType Enumeration

[Visual Basic]
Public Enum SmartArtColorType
[C#]
public enum SmartArtColorType

Members

Member Name | Description | Value
Dark1Outline |  | 0
Dark2Outline |  | 1
DarkFill |  | 2
ColorfulAccentColors |  | 3
ColorfulAccentColors2to3 |  | 4
ColorfulAccentColors3to4 |  | 5
ColorfulAccentColors4to5 |  | 6
ColorfulAccentColors5to6 |  | 7
ColoredOutlineAccent1 |  | 8
ColoredFillAccent1 |  | 9
GradientRangeAccent1 |  | 10
GradientLoopAccent1 |  | 11
TransparentGradientRangeAccent1 |  | 12
ColoredOutlineAccent2 |  | 13
ColoredFillAccent2 |  | 14
GradientRangeAccent2 |  | 15
GradientLoopAccent2 |  | 16
TransparentGradientRangeAccent2 |  | 17
ColoredOutlineAccent3 |  | 18
ColoredFillAccent3 |  | 19
GradientRangeAccent3 |  | 20
GradientLoopAccent3 |  | 21
TransparentGradientRangeAccent3 |  | 22
ColoredOutlineAccent4 |  | 23
ColoredFillAccent4 |  | 24
GradientRangeAccent4 |  | 25
GradientLoopAccent4 |  | 26
TransparentGradientRangeAccent4 |  | 27
ColoredOutlineAccent5 |  | 28
ColoredFillAccent5 |  | 29
GradientRangeAccent5 |  | 30
GradientLoopAccent5 |  | 31
TransparentGradientRangeAccent5 |  | 32
ColoredOutlineAccent6 |  | 33
ColoredFillAccent6 |  | 34
GradientRangeAccent6 |  | 35
GradientLoopAccent6 |  | 36
TransparentGradientRangeAccent6 |  | 37

Requirements

Namespace: Aspose.Slides.SmartArt

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.SmartArt Namespace


SmartArtLayoutType Enumeration

[Visual Basic]
Public Enum SmartArtLayoutType
[C#]
public enum SmartArtLayoutType

Members

Member Name | Description | Value
AccentProcess |  | 0
AccentedPicture |  | 1
AlternatingFlow |  | 2
AlternatingHexagons |  | 3
AlternatingPictureBlocks |  | 4
AlternatingPictureCircles |  | 5
ArrowRibbon |  | 6
AscendingPictureAccentProcess |  | 7
Balance |  | 8
BasicBendingProcess |  | 9
BasicBlockList |  | 10
BasicChevronProcess |  | 11
BasicCycle |  | 12
BasicMatrix |  | 13
BasicPie |  | 14
BasicProcess |  | 15
BasicPyramid |  | 16
BasicRadial |  | 17
BasicTarget |  | 18
BasicTimeline |  | 19
BasicVenn |  | 20
BendingPictureAccentList |  | 21
BendingPictureBlocks |  | 22
BendingPictureCaption |  | 23
BendingPictureCaptionList |  | 24
BendingPictureSemiTransparentText |  | 25
BlockCycle |  | 26
BubblePictureList |  | 27
CaptionedPictures |  | 28
ChevronList |  | 29
CircleAccentTimeline |  | 30
CircleArrowProcess |  | 31
CirclePictureHierarchy |  | 32
CircleRelationship |  | 33
CircularBendingProcess |  | 34
CircularPictureCallout |  | 35
ClosedChevronProcess |  | 36
ContinuousArrowProcess |  | 37
ContinuousBlockProcess |  | 38
ContinuousCycle |  | 39
ContinuousPictureList |  | 40
ConvergingArrows |  | 41
ConvergingRadial |  | 42
CounterbalanceArrows |  | 43
CycleMatrix |  | 44
DescendingBlockList |  | 45
DescendingProcess |  | 46
DetailedProcess |  | 47
DivergingArrows |  | 48
DivergingRadial |  | 49
Equation |  | 50
FramedTextPicture |  | 51
Funnel |  | 52
Gear |  | 53
GridMatrix |  | 54
GroupedList |  | 55
HalfCircleOrganizationChart |  | 56
HexagonCluster |  | 57
Hierarchy |  | 58
HierarchyList |  | 59
HorizontalBulletList |  | 60
HorizontalHierarchy |  | 61
HorizontalLabeledHierarchy |  | 62
HorizontalMultiLevelHierarchy |  | 63
HorizontalOrganizationChart |  | 64
HorizontalPictureList |  | 65
IncreasingArrowsProcess |  | 66
IncreasingCircleProcess |  | 67
InvertedPyramid |  | 68
LabeledHierarchy |  | 69
LinearVenn |  | 70
LinedList |  | 71
MultidirectionalCycle |  | 72
NameandTitleOrganizationChart |  | 73
NestedTarget |  | 74
NondirectionalCycle |  | 75
OpposingArrows |  | 76
OpposingIdeas |  | 77
OrganizationChart |  | 78
PhasedProcess |  | 79
PictureAccentBlocks |  | 80
PictureAccentList |  | 81
PictureAccentProcess |  | 82
PictureCaptionList |  | 83
PictureGrid |  | 84
PictureLineup |  | 85
PictureStrips |  | 86
PieProcess |  | 87
PlusandMinus |  | 88
ProcessArrows |  | 89
ProcessList |  | 90
PyramidList |  | 91
RadialCluster |  | 92
RadialCycle |  | 93
RadialList |  | 94
RadialVenn |  | 95
RandomToResultProcess |  | 96
RepeatingBendingProcess |  | 97
ReverseList |  | 98
SegmentedCycle |  | 99
SegmentedProcess |  | 100
SegmentedPyramid |  | 101
SnapshotPictureList |  | 102
SpiralPicture |  | 103
SquareAccentList |  | 104
StackedList |  | 105
StackedVenn |  | 106
StaggeredProcess |  | 107
StepDownProcess |  | 108
StepUpProcess |  | 109
SubStepProcess |  | 110
TableHierarchy |  | 111
TableList |  | 112
TargetList |  | 113
TextCycle |  | 114
TitlePictureLineup |  | 115
TitledMatrix |  | 116
TitledPictureAccentList |  | 117
TitledPictureBlocks |  | 118
TrapezoidList |  | 119
UpwardArrow |  | 120
VerticalAccentList |  | 121
VerticalArrowList |  | 122
VerticalBendingProcess |  | 123
VerticalBlockList |  | 124
VerticalBoxList |  | 125
VerticalBulletList |  | 126
VerticalChevronList |  | 127
VerticalCircleList |  | 128
VerticalCurvedList |  | 129
VerticalEquation |  | 130
VerticalPictureAccentList |  | 131
VerticalPictureList |  | 132
VerticalProcess |  | 133

Requirements

Namespace: Aspose.Slides.SmartArt

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.SmartArt Namespace


SmartArtNode Class

Represents node of SmartArt object

For a list of all members of this type, see SmartArtNode Members.

System.Object
Aspose.Slides.SmartArt.SmartArtNode

[Visual Basic]
Public Class SmartArtNode
Implements ISmartArtNode
[C#]
public class SmartArtNode : ISmartArtNode

Requirements

Namespace: Aspose.Slides.SmartArt

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SmartArtNode Members | Aspose.Slides.SmartArt Namespace


SmartArtNode Members

SmartArtNode overview

Public Instance Properties

BulletFillFormat | Returns the FillFormat object that contains fill formatting properties for a node bullet Read-only FillFormat. Note: can return null for certain types of SmartArt layout which does not provide bullets for nodes
ChildNodes | Returns collections of all child nodes of the current node Read-only SmartArtNodeCollection.
IsAssistant | Return or set node as assistant. Read/write Boolean
Level | Nesting level of node Read-only Int32
Position | Zero-based position of node among sibling nodes. Read/write Int32
TextFrame | Return or set text of the SmartArt node. Read/write TextFrame

Public Instance Methods

Remove Remove current node.

See Also

SmartArtNode Class | Aspose.Slides.SmartArt Namespace


SmartArtNode Properties

The properties of the SmartArtNode class are listed below. For a complete list of SmartArtNode class members, see the SmartArtNode Members topic.

Public Instance Properties

BulletFillFormat | Returns the FillFormat object that contains fill formatting properties for a node bullet Read-only FillFormat. Note: can return null for certain types of SmartArt layout which does not provide bullets for nodes
ChildNodes | Returns collections of all child nodes of the current node Read-only SmartArtNodeCollection.
IsAssistant | Return or set node as assistant. Read/write Boolean
Level | Nesting level of node Read-only Int32
Position | Zero-based position of node among sibling nodes. Read/write Int32
TextFrame | Return or set text of the SmartArt node. Read/write TextFrame

See Also

SmartArtNode Class | Aspose.Slides.SmartArt Namespace


BulletFillFormat Property

Aspose.Slides Documentation

SmartArtNode.BulletFillFormat Property

Returns the FillFormat object that contains fill formatting properties for a node bullet Read-only FillFormat. Note: can return null for certain types of SmartArt layout which does not provide bullets for nodes

[Visual Basic]
NotOverridable Public ReadOnly Property BulletFillFormat As IFillFormat _
Implements ISmartArtNode.BulletFillFormat
[C#]
public IFillFormat BulletFillFormat {get;}

Implements

ISmartArtNode.BulletFillFormat

See Also

SmartArtNode Class | Aspose.Slides.SmartArt Namespace


ChildNodes Property

Aspose.Slides Documentation

SmartArtNode.ChildNodes Property

Returns collections of all child nodes of the current node Read-only SmartArtNodeCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property ChildNodes As ISmartArtNodeCollection _
Implements ISmartArtNode.ChildNodes
[C#]
public ISmartArtNodeCollection ChildNodes {get;}

Implements

ISmartArtNode.ChildNodes

Example

[C#]
Presentation pres = new Presentation("demo.pptx");
SmartArt smart = (SmartArt)pres.Slides[0].Shapes[0];
SmartArtNode node0 = smart.AllNodes[0];
for ( int i = 0; i < node0.ChildNodes.Count; i++)
{
    SmartArtNode node = node0.ChildNodes[i];
    string outString = string.Format("i = {0}, Text = {1},  Level = {2}, Position = {3}", i, node.TextFrame.Text,
    node.Level, node.Position);
    Console.WriteLine(outString);
}

[Visual Basic]
Dim pres As New Presentation("demo.pptx")
Dim smart As SmartArt = DirectCast(pres.Slides(0).Shapes(0), SmartArt)
Dim node0 As SmartArtNode = smart.AllNodes(0);
Dim i As Integer = 0
While i < node0.ChildNodes.Count
Dim node As SmartArtNode = node0.ChildNodes(i)
Dim outString As String = String.Format("i = {0}, Text = {1},  Level = {2}, Position = {3}", i, node.TextFrame.Text, node.Level, node.Position)
Console.WriteLine(outString)
System.Math.Max(System.Threading.Interlocked.Increment(i),i - 1)
End While

See Also

SmartArtNode Class | Aspose.Slides.SmartArt Namespace


IsAssistant Property

Aspose.Slides Documentation

SmartArtNode.IsAssistant Property

Return or set node as assistant. Read/write Boolean

[Visual Basic]
NotOverridable Public Property IsAssistant As Boolean _
Implements ISmartArtNode.IsAssistant
[C#]
public bool IsAssistant {get; set;}

Implements

ISmartArtNode.IsAssistant

Example

[C#]
Presentation pres = new Presentation();
Slide slide = pres.Slides[0];
SmartArt smart = slide.Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutTypeEx.Hierarchy);
foreach (SmartArtNode node in smart.AllNodes)
{
      if (node.IsAssistant) node.IsAssistant = false;
}

[Visual Basic]
Dim pres As New Presentation()
Dim slide As SlideE = pres.Slides(0)
Dim smart As SmartArt = slide.Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutTypeEx.Hierarchy)
For Each node As SmartArtNode In smart.AllNodes
    If node.IsAssistant Then
    node.IsAssistant = False
    End If
Next

See Also

SmartArtNode Class | Aspose.Slides.SmartArt Namespace


Level Property

Aspose.Slides Documentation

SmartArtNode.Level Property

Nesting level of node Read-only Int32

[Visual Basic]
NotOverridable Public ReadOnly Property Level As Integer _
Implements ISmartArtNode.Level
[C#]
public int Level {get;}

Implements

ISmartArtNode.Level

Example

[C#]
Presentation pres = new Presentation("demo.pptx");
SmartArt smart = (SmartArt)pres.Slides[0].Shapes[0];
for ( int i = 0; i < smart.AllNodes.Count; i++)
{
   if (smart.AllNodes[i].Level == 2)
   Console.WriteLine(smart.AllNodes[i].Level + " " + smart.AllNodes[i].TextFrame.Text);
}

[Visual Basic]
Dim pres As New Presentation("demo.pptx")
Dim smart As SmartArt = DirectCast(pres.Slides(0).Shapes(0), SmartArt)
Dim i As Integer = 0
While i < smart.AllNodes.Count
If smart.AllNodes(i).Level = 2 Then
Console.WriteLine(smart.AllNodes(i).Level + " " + smart.AllNodes(i).TextFrame.Text)
End If
System.Math.Max(System.Threading.Interlocked.Increment(i),i - 1)
End While

See Also

SmartArtNode Class | Aspose.Slides.SmartArt Namespace


Position Property

Aspose.Slides Documentation

SmartArtNode.Position Property

Zero-based position of node among sibling nodes. Read/write Int32

[Visual Basic]
NotOverridable Public Property Position As Integer _
Implements ISmartArtNode.Position
[C#]
public int Position {get; set;}

Implements

ISmartArtNode.Position

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | value is less than 0. -or- value is equal to or greater than siblings count

Example

[C#]
Presentation pres = new Presentation("demo.pptx");
SmartArt smart = (SmartArt)pres.Slides[0].Shapes[0];
SmartArtNode node = smart.AllNodes[0];
if (node.ChildNodes.Count > 3)
    node.ChildNodes[0].Position = node.ChildNodes[0].Position + 1;

[Visual Basic]
Dim pres As New Presentation("demo.pptx")
Dim smart As SmartArt = DirectCast(pres.Slides(0).Shapes(0), SmartArt)
Dim node As SmartArtNode = smart.AllNodes(0)
If node.ChildNodes.Count > 3 Then
    node.ChildNodes(0).Position = node.ChildNodes(0).Position + 1
End If

See Also

SmartArtNode Class | Aspose.Slides.SmartArt Namespace


TextFrame Property

Aspose.Slides Documentation

SmartArtNode.TextFrame Property

Return or set text of the SmartArt node. Read/write TextFrame

[Visual Basic]
NotOverridable Public Property TextFrame As ITextFrame _
Implements ISmartArtNode.TextFrame
[C#]
public ITextFrame TextFrame {get; set;}

Implements

ISmartArtNode.TextFrame

Example

[C#]
Presentation pres = new Presentation("demo.pptx");
SmartArt smart = (SmartArt)pres.Slides[0].Shapes[0];
SmartArtNode node0 = smart.AllNodes[0];
for ( int i = 0; i < node0.ChildNodes.Count; i++)
{
    SmartArtNode node = node0.ChildNodes[i];
    Console.WriteLine(node.TextFrame.Text);
    node.TextFrame.Text = "New text " + i;
}

[Visual Basic]
Dim pres As New Presentation("demo.pptx")
Dim smart As SmartArt = DirectCast(pres.Slides(0).Shapes(0), SmartArt)
Dim node0 As SmartArtNode = smart.AllNodes(0)
Dim i As Integer = 0
While i < node0.ChildNodes.Count
    Dim node As SmartArtNode = node0.ChildNodes(i)
    Console.WriteLine(node.TextFrame.Text)
    node.TextFrame.Text = "New text " + i
    System.Math.Max(System.Threading.Interlocked.Increment(i),i - 1)
End While

See Also

SmartArtNode Class | Aspose.Slides.SmartArt Namespace


SmartArtNode Methods

The methods of the SmartArtNode class are listed below. For a complete list of SmartArtNode class members, see the SmartArtNode Members topic.

Public Instance Methods

Remove Remove current node.

See Also

SmartArtNode Class | Aspose.Slides.SmartArt Namespace


SmartArtNode.Remove Method

Remove current node.

[Visual Basic]
NotOverridable Public Function Remove() As Boolean _
Implements ISmartArtNode.Remove
[C#]
public bool Remove();

Return Value

True if removed succesfully, otherwise false

Implements

ISmartArtNode.Remove

Example

[Visual Basic]
Dim pres As New Presentation("demo.pptx")
Dim smart As SmartArt = DirectCast(pres.Slides(0).Shapes(0), SmartArt)
Dim node As SmartArtNode = smart.AllNodes(0)
node.Remove()

See Also
SmartArtNode Class | Aspose.Slides.SmartArt Namespace


SmartArtNodeCollection Class

Represents a collection of a SmartArt nodes.

For a list of all members of this type, see SmartArtNodeCollection Members.

System.Object
Aspose.Slides.SmartArt.SmartArtNodeCollection

[Visual Basic]
Public Class SmartArtNodeCollection
Implements ISmartArtNodeCollection, IEnumerable
[C#]
public class SmartArtNodeCollection : ISmartArtNodeCollection, IEnumerable

Requirements

Namespace: Aspose.Slides.SmartArt

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SmartArtNodeCollection Members | Aspose.Slides.SmartArt Namespace


SmartArtNodeCollection Members

SmartArtNodeCollection overview

Public Instance Properties

Count | Returns count of nodes in collection
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns node by index
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

AddNode | Add new smart art node or sub node.
AddNodeByPosition | Add new node in the selected position of nodes collection
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
GetNodeByPosition | Get node by position between siblings
RemoveNode | Overloaded. Remove node or sub node by index
RemoveNodeByPosition | Remove node from selected position

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


SmartArtNodeCollection Properties

The properties of the SmartArtNodeCollection class are listed below. For a complete list of SmartArtNodeCollection class members, see the SmartArtNodeCollection Members topic.

Public Instance Properties

Count | Returns count of nodes in collection
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns node by index
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


Count Property

Aspose.Slides Documentation

SmartArtNodeCollection.Count Property

Returns count of nodes in collection

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ISmartArtNodeCollection.Count
[C#]
public int Count {get;}

Implements

ISmartArtNodeCollection.Count

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


IsSynchronized Property

Aspose.Slides Documentation

SmartArtNodeCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {get;}

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


Item Property

Aspose.Slides Documentation

SmartArtNodeCollection.Item Property

Returns node by index

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ISmartArtNodeCollection.Item
As ISmartArtNode _
Implements ISmartArtNodeCollection.Item
[C#]
public ISmartArtNode this[
int index
] {get;}

Parameters

index
The zero-based index of the element

Implements

ISmartArtNodeCollection.Item

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


SyncRoot Property

Aspose.Slides Documentation

SmartArtNodeCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {get;}

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


SmartArtNodeCollection Methods

The methods of the SmartArtNodeCollection class are listed below. For a complete list of SmartArtNodeCollection class members, see the SmartArtNodeCollection Members topic.

Public Instance Methods

AddNode | Add new smart art node or sub node.
AddNodeByPosition | Add new node in the selected position of nodes collection
CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.
GetNodeByPosition | Get node by position between siblings
RemoveNode | Overloaded. Remove node or sub node by index
RemoveNodeByPosition | Remove node from selected position

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


SmartArtNodeCollection.AddNode Method

Add new smart art node or sub node.

[Visual Basic]
NotOverridable Public Function AddNode() As ISmartArtNode _
Implements ISmartArtNodeCollection.AddNode
[C#]
public ISmartArtNode AddNode();

Return Value

Added node

Implements

ISmartArtNodeCollection.AddNode

Example

[C#]
Presentation pres = new Presentation("demo.pptx");
SmartArt smart = (SmartArt) pres.Slides[0].Shapes[0];
SmartArtNode exNode = smart.AllNodes[0];
SmartArtNode newNode = exNode.ChildNodes.AddNode();

[Visual Basic]
Private pres As New Presentation("demo.pptx")
Private smart As SmartArt = DirectCast(pres.Slides(0).Shapes(0), SmartArt)
Private exNode As SmartArtNode = smart.AllNodes(0)
Private newNode As SmartArtNode = exNode.ChildNodes.AddNode()

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


SmartArtNodeCollection.AddNodeByPosition Method

Add new node in the selected position of nodes collection

[Visual Basic]
NotOverridable Public Function AddNodeByPosition( _
ByVal position As Integer _
) As ISmartArtNode _
Implements ISmartArtNodeCollection.AddNodeByPosition
[C#]
public ISmartArtNode AddNodeByPosition(
int position
);

Parameters

position
Zero-base node position

Return Value

Added node

Implements

ISmartArtNodeCollection.AddNodeByPosition

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | position is less than 0

Example

[C#]
SmartArt smart = pres.Slides[0].Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.StackedList);
SmartArtNode node = smart.AllNodes[0];
SmartArtNode chNode = node.ChildNodes.AddNodeByPosition(2);

[Visual Basic]
Private smart As SmartArt = pres.Slides(0).Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.StackedList)
Private node As SmartArtNode = smart.AllNodes(0)
Private chNode As SmartArtNode = node.ChildNodes.AddNodeByPosition(2)

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


SmartArtNodeCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
index

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


SmartArtNodeCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


SmartArtNodeCollection.GetNodeByPosition Method

Get node by position between siblings

[Visual Basic]
NotOverridable Public Function GetNodeByPosition( _
ByVal position As Integer _
) As ISmartArtNode _
Implements ISmartArtNodeCollection.GetNodeByPosition
[C#]
public ISmartArtNode GetNodeByPosition(
int position
);

Parameters

position
Zero-based position

Return Value

First matched node, -or- null if node with this position does not exist

Implements

ISmartArtNodeCollection.GetNodeByPosition

Example

[C#]
SmartArt smart = pres.Slides[0].Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.StackedList);
SmartArtNode node = smart.AllNodes[0];
SmartArtNode chNode = node.ChildNodes.GetNodeByPosition(3);

[Visual Basic]
Private smart As SmartArt = pres.Slides(0).Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.StackedList)
Private node As SmartArtNode = smart.AllNodes(0)
Private chNode As SmartArtNode = node.ChildNodes.GetNodeByPosition(3)

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


RemoveNode Method

Aspose.Slides Documentation

SmartArtNodeCollection.RemoveNode Method

Remove node or sub node

Overload List

Remove node or sub node

public void RemoveNode(ISmartArtNode);

Remove node or sub node by index

public void RemoveNode(int);

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


SmartArtNodeCollection.RemoveNode Method (ISmartArtNode)

Remove node or sub node

[Visual Basic]
NotOverridable Overloads Public Sub RemoveNode( _
ByVal node As ISmartArtNode _
) _
Implements ISmartArtNodeCollection.RemoveNode
[C#]
public void RemoveNode(
ISmartArtNode node
);

Parameters

node
Node to remove

Implements

ISmartArtNodeCollection.RemoveNode

Example

[C#]
Presentation pres = new Presentation("demo.pptx");
SmartArt smart = (SmartArt) pres.Slides[0].Shapes[0];
if (smart.AllNodes.Count > 0 )
       {
           SmartArtNode node =  smart.AllNodes[0];
           smart.AllNodes.RemoveNode(node);
       }

[Visual Basic]
Dim pres As New Presentation("demo.pptx")
Dim smart As SmartArt = DirectCast(pres.Slides(0).Shapes(0), SmartArt)
If smart.AllNodes.Count > 0 Then
    Dim node As SmartArtNode = smart.AllNodes(0)
    smart.AllNodes.RemoveNode(node)
End If

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace | SmartArtNodeCollection.RemoveNode Overload List


SmartArtNodeCollection.RemoveNode Method (Int32)

Remove node or sub node by index

[Visual Basic]
NotOverridable Overloads Public Sub RemoveNode( _
ByVal index As Integer _
) _
Implements ISmartArtNodeCollection.RemoveNode
[C#]
public void RemoveNode(
int index
);

Parameters

index
Zero-based index of node

Implements

ISmartArtNodeCollection.RemoveNode

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than 0. -or- index is equal to or greater than siblings count

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace | SmartArtNodeCollection.RemoveNode Overload List


SmartArtNodeCollection.RemoveNodeByPosition Method

Remove node from selected position

[Visual Basic]
NotOverridable Public Function RemoveNodeByPosition( _
ByVal position As Integer _
) As Boolean _
Implements ISmartArtNodeCollection.RemoveNodeByPosition
[C#]
public bool RemoveNodeByPosition(
int position
);

Parameters

position

Return Value

True if removed successfully, otherwise false

Implements

ISmartArtNodeCollection.RemoveNodeByPosition

Example

[C#]
SmartArt smart = pres.Slides[0].Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.StackedList);
SmartArtNode node = smart.AllNodes[0];
if (node.ChildNodes.Count >=5)
{
  node.ChildNodes.RemoveNodeByPosition(3);
}

[Visual Basic]
Dim smart As SmartArt = pres.Slides(0).Shapes.AddSmartArt(0, 0, 400, 400, SmartArtLayoutType.StackedList)
Dim node As SmartArtNode = smart.AllNodes(0)
If node.ChildNodes.Count >= 5 Then
    node.ChildNodes.RemoveNodeByPosition(3)
End If

See Also

SmartArtNodeCollection Class | Aspose.Slides.SmartArt Namespace


SmartArtQuickStyleType Enumeration

[Visual Basic]
Public Enum SmartArtQuickStyleType
[C#]
public enum SmartArtQuickStyleType

Members

Member Name | Description | Value
SimpleFill |  | 0
WhiteOutline |  | 1
SubtleEffect |  | 2
ModerateEffect |  | 3
IntenceEffect |  | 4
Polished |  | 5
Inset |  | 6
Cartoon |  | 7
Powder |  | 8
BrickScene |  | 9
FlatScene |  | 10
MetallicScene |  | 11
SunsetScene |  | 12
BirdsEyeScene |  | 13

Requirements

Namespace: Aspose.Slides.SmartArt

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.SmartArt Namespace


Aspose.Slides.Theme

Aspose.Slides Documentation

Aspose.Slides.Theme Namespace

Namespace hierarchy

Classes

Class | Description
BaseOverrideThemeManager |
BaseThemeManager |
ChartThemeManager |
ColorScheme | Stores theme-defined colors.
ColorSchemeEffectiveData | Immutable ColorScheme object.
EffectStyle | Represents an effect style.
EffectStyleCollection | Represents a collection of effect styles.
EffectStyleCollectionEffectiveData | Immutable EffectStyleCollection object.
EffectStyleEffectiveData | Immutable EffectStyle object.
ExtraColorScheme | Represents an additional color scheme which can be assigned to a slide.
ExtraColorSchemeCollection | Represents a collection of additional color schemes.
FillFormatCollection | Represents the collection of fill styles.
FillFormatCollectionEffectiveData | Immutable FillFormatCollection object.
FontScheme | Stores theme-defined fonts.
FontSchemeEffectiveData | Immutable FontScheme object.
FormatScheme | Stores theme-defined formats for the shapes.
FormatSchemeEffectiveData | Immutable FormatScheme object.
LayoutSlideThemeManager |
LineFormatCollection | Represents the collection of line styles.
LineFormatCollectionEffectiveData | Immutable LineFormatCollection object.
MasterTheme | Represents a master theme.
MasterThemeManager |
NotesSlideThemeManager |
OverrideTheme | Represents a overriding theme.
SlideThemeManager |
Theme | Represents a theme.
ThemeEffectiveData | Immutable Theme object.

Interfaces

Interface | Description
IColorScheme |
IColorSchemeEffectiveData |
IEffectStyle |
IEffectStyleCollection |
IEffectStyleCollectionEffectiveData |
IEffectStyleEffectiveData |
IExtraColorScheme |
IExtraColorSchemeCollection |
IFillFormatCollection |
IFillFormatCollectionEffectiveData |
IFontScheme |
IFontSchemeEffectiveData |
IFormatScheme |
IFormatSchemeEffectiveData |
ILineFormatCollection |
ILineFormatCollectionEffectiveData |
IMasterTheme |
IMasterThemeable |
IMasterThemeManager |
IOverrideTheme |
IOverrideThemeable |
IOverrideThemeManager |
ITheme |
IThemeable |
IThemeEffectiveData |
IThemeManager |


BaseOverrideThemeManager Class

For a list of all members of this type, see BaseOverrideThemeManager Members.

System.Object
Aspose.Slides.Theme.BaseThemeManager
Aspose.Slides.Theme.BaseOverrideThemeManager
Aspose.Slides.Theme.ChartThemeManager
Aspose.Slides.Theme.LayoutSlideThemeManager
Aspose.Slides.Theme.NotesSlideThemeManager
Aspose.Slides.Theme.SlideThemeManager

[Visual Basic]
MustInherit Public Class BaseOverrideThemeManager
Inherits BaseThemeManager
Implements IOverrideThemeManager, IThemeManager
[C#]
public abstract class BaseOverrideThemeManager : BaseThemeManager, IOverrideThemeManager, IThemeManager

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

BaseOverrideThemeManager Members | Aspose.Slides.Theme Namespace


BaseOverrideThemeManager Members

BaseOverrideThemeManager overview

Public Instance Properties

IsOverrideThemeEnabled | Determines whether OverrideTheme overrides inherited effective theme or not. To enable OverrideTheme for overriding use OverrideTheme.Init*() methods. To disable OverrideTheme from overriding use OverrideTheme.Clear() method.
OverrideTheme | Returns the overriding theme object.

Public Instance Methods

ApplyColorScheme | Applies extra color scheme to a slide.
CreateThemeEffective | Returns the theme object.

See Also

BaseOverrideThemeManager Class | Aspose.Slides.Theme Namespace


BaseOverrideThemeManager Properties

The properties of the BaseOverrideThemeManager class are listed below. For a complete list of BaseOverrideThemeManager class members, see the BaseOverrideThemeManager Members topic.

Public Instance Properties

IsOverrideThemeEnabled | Determines whether OverrideTheme overrides inherited effective theme or not. To enable OverrideTheme for overriding use OverrideTheme.Init*() methods. To disable OverrideTheme from overriding use OverrideTheme.Clear() method.
OverrideTheme | Returns the overriding theme object.

See Also

BaseOverrideThemeManager Class | Aspose.Slides.Theme Namespace


IsOverrideThemeEnabled Property

Aspose.Slides Documentation

BaseOverrideThemeManager.IsOverrideThemeEnabled Property

Determines whether OverrideTheme overrides inherited effective theme or not. To enable OverrideTheme for overriding use OverrideTheme.Init*() methods. To disable OverrideTheme from overriding use OverrideTheme.Clear() method.

[Visual Basic]
NotOverridable Public ReadOnly Property IsOverrideThemeEnabled As Boolean _
Implements IOverrideThemeManager.IsOverrideThemeEnabled
[C#]
public bool IsOverrideThemeEnabled {get;}

Implements

IOverrideThemeManager.IsOverrideThemeEnabled

See Also

BaseOverrideThemeManager Class | Aspose.Slides.Theme Namespace


OverrideTheme Property

Aspose.Slides Documentation

BaseOverrideThemeManager.OverrideTheme Property

Returns the overriding theme object.

[Visual Basic]
NotOverridable Public Property OverrideTheme As IOverrideTheme _
Implements IOverrideThemeManager.OverrideTheme
[C#]
public IOverrideTheme OverrideTheme {get; set;}

Implements

IOverrideThemeManager.OverrideTheme

See Also

BaseOverrideThemeManager Class | Aspose.Slides.Theme Namespace


BaseOverrideThemeManager Methods

The methods of the BaseOverrideThemeManager class are listed below. For a complete list of BaseOverrideThemeManager class members, see the BaseOverrideThemeManager Members topic.

Public Instance Methods

ApplyColorScheme | Applies extra color scheme to a slide.
CreateThemeEffective | Returns the theme object.

See Also

BaseOverrideThemeManager Class | Aspose.Slides.Theme Namespace


BaseOverrideThemeManager.ApplyColorScheme Method

Applies extra color scheme to a slide.

[Visual Basic]
NotOverridable Public Sub ApplyColorScheme( _
ByVal scheme As IExtraColorScheme _
) _
Implements IThemeManager.ApplyColorScheme
[C#]
public void ApplyColorScheme(
IExtraColorScheme scheme
);

Parameters

scheme

Implements

IThemeManager.ApplyColorScheme

See Also

BaseOverrideThemeManager Class | Aspose.Slides.Theme Namespace


BaseOverrideThemeManager.CreateThemeEffective Method

Returns the theme object.

[Visual Basic]
NotOverridable Public Function CreateThemeEffective() As IThemeEffectiveData _
Implements IThemeManager.CreateThemeEffective
[C#]
public IThemeEffectiveData CreateThemeEffective();

Implements

IThemeManager.CreateThemeEffective

See Also

BaseOverrideThemeManager Class | Aspose.Slides.Theme Namespace


BaseThemeManager Class

System.Object
Aspose.Slides.Theme.BaseThemeManager
Aspose.Slides.Theme.BaseOverrideThemeManager
Aspose.Slides.Theme.MasterThemeManager

[Visual Basic]
MustInherit Public Class BaseThemeManager
[C#]
public abstract class BaseThemeManager

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Theme Namespace


ChartThemeManager Class

For a list of all members of this type, see ChartThemeManager Members.

System.Object
Aspose.Slides.Theme.BaseThemeManager
Aspose.Slides.Theme.BaseOverrideThemeManager
Aspose.Slides.Theme.ChartThemeManager

[Visual Basic]
Public Class ChartThemeManager
Inherits BaseOverrideThemeManager
[C#]
public class ChartThemeManager : BaseOverrideThemeManager

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ChartThemeManager Members | Aspose.Slides.Theme Namespace


ChartThemeManager Members

ChartThemeManager overview

Public Instance Properties

IsOverrideThemeEnabled (inherited from BaseOverrideThemeManager) | Determines whether OverrideTheme overrides inherited effective theme or not. To enable OverrideTheme for overriding use OverrideTheme.Init*() methods. To disable OverrideTheme from overriding use OverrideTheme.Clear() method.
OverrideTheme (inherited from BaseOverrideThemeManager) | Returns the overriding theme object.

Public Instance Methods

ApplyColorScheme (inherited from BaseOverrideThemeManager) | Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseOverrideThemeManager) | Returns the theme object.

See Also

ChartThemeManager Class | Aspose.Slides.Theme Namespace


ColorScheme Class

Stores theme-defined colors.

For a list of all members of this type, see ColorScheme Members.

System.Object
Aspose.Slides.Theme.ColorScheme

[Visual Basic]
Public Class ColorScheme
Implements IColorScheme, ISlideComponent, IPresentationComponent
[C#]
public class ColorScheme : IColorScheme, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ColorScheme Members | Aspose.Slides.Theme Namespace


ColorScheme Members

ColorScheme overview

Public Instance Properties

Accent1 | First accent color in the scheme. Read-only ColorFormat.
Accent2 | Second accent color in the scheme. Read-only ColorFormat.
Accent3 | Third accent color in the scheme. Read-only ColorFormat.
Accent4 | Fourth accent color in the scheme. Read-only ColorFormat.
Accent5 | Fifth accent color in the scheme. Read-only ColorFormat.
Accent6 | Sixth accent color in the scheme. Read-only ColorFormat.
Dark1 | First dark color in the scheme. Read-only ColorFormat.
Dark2 | Second dark color in the scheme. Read-only ColorFormat.
FollowedHyperlink | Color for the visited hyperlinks. Read-only ColorFormat.
Hyperlink | Color for the hyperlinks. Read-only ColorFormat.
Item | Gets the element at the specified index. Read-only ColorFormat.
Light1 | First light color in the scheme. Read-only ColorFormat.
Light2 | Second light color in the scheme. Read-only ColorFormat.
Presentation | Returns the parent presentation. Read-only Presentation.
Slide | Returns the parent slide. Read-only BaseSlide.

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


ColorScheme Properties

The properties of the ColorScheme class are listed below. For a complete list of ColorScheme class members, see the ColorScheme Members topic.

Public Instance Properties

Accent1 | First accent color in the scheme. Read-only ColorFormat.
Accent2 | Second accent color in the scheme. Read-only ColorFormat.
Accent3 | Third accent color in the scheme. Read-only ColorFormat.
Accent4 | Fourth accent color in the scheme. Read-only ColorFormat.
Accent5 | Fifth accent color in the scheme. Read-only ColorFormat.
Accent6 | Sixth accent color in the scheme. Read-only ColorFormat.
Dark1 | First dark color in the scheme. Read-only ColorFormat.
Dark2 | Second dark color in the scheme. Read-only ColorFormat.
FollowedHyperlink | Color for the visited hyperlinks. Read-only ColorFormat.
Hyperlink | Color for the hyperlinks. Read-only ColorFormat.
Item | Gets the element at the specified index. Read-only ColorFormat.
Light1 | First light color in the scheme. Read-only ColorFormat.
Light2 | Second light color in the scheme. Read-only ColorFormat.
Presentation | Returns the parent presentation. Read-only Presentation.
Slide | Returns the parent slide. Read-only BaseSlide.

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Accent1 Property

Aspose.Slides Documentation

ColorScheme.Accent1 Property

First accent color in the scheme. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Accent1 As IColorFormat _
Implements IColorScheme.Accent1
[C#]
public IColorFormat Accent1 {get;}

Implements

IColorScheme.Accent1

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Accent2 Property

Aspose.Slides Documentation

ColorScheme.Accent2 Property

Second accent color in the scheme. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Accent2 As IColorFormat _
Implements IColorScheme.Accent2
[C#]
public IColorFormat Accent2 {get;}

Implements

IColorScheme.Accent2

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Accent3 Property

Aspose.Slides Documentation

ColorScheme.Accent3 Property

Third accent color in the scheme. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Accent3 As IColorFormat _
Implements IColorScheme.Accent3
[C#]
public IColorFormat Accent3 {get;}

Implements

IColorScheme.Accent3

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Accent4 Property

Aspose.Slides Documentation

ColorScheme.Accent4 Property

Fourth accent color in the scheme. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Accent4 As IColorFormat _
Implements IColorScheme.Accent4
[C#]
public IColorFormat Accent4 {get;}

Implements

IColorScheme.Accent4

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Accent5 Property

Aspose.Slides Documentation

ColorScheme.Accent5 Property

Fifth accent color in the scheme. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Accent5 As IColorFormat _
Implements IColorScheme.Accent5
[C#]
public IColorFormat Accent5 {get;}

Implements

IColorScheme.Accent5

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Accent6 Property

Aspose.Slides Documentation

ColorScheme.Accent6 Property

Sixth accent color in the scheme. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Accent6 As IColorFormat _
Implements IColorScheme.Accent6
[C#]
public IColorFormat Accent6 {get;}

Implements

IColorScheme.Accent6

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Dark1 Property

Aspose.Slides Documentation

ColorScheme.Dark1 Property

First dark color in the scheme. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Dark1 As IColorFormat _
Implements IColorScheme.Dark1
[C#]
public IColorFormat Dark1 {get;}

Implements

IColorScheme.Dark1

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Dark2 Property

Aspose.Slides Documentation

ColorScheme.Dark2 Property

Second dark color in the scheme. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Dark2 As IColorFormat _
Implements IColorScheme.Dark2
[C#]
public IColorFormat Dark2 {get;}

Implements

IColorScheme.Dark2

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


FollowedHyperlink Property

Aspose.Slides Documentation

ColorScheme.FollowedHyperlink Property

Color for the visited hyperlinks. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property FollowedHyperlink As IColorFormat _
Implements IColorScheme.FollowedHyperlink
[C#]
public IColorFormat FollowedHyperlink {get;}

Implements

IColorScheme.FollowedHyperlink

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Hyperlink Property

Aspose.Slides Documentation

ColorScheme.Hyperlink Property

Color for the hyperlinks. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Hyperlink As IColorFormat _
Implements IColorScheme.Hyperlink
[C#]
public IColorFormat Hyperlink {get;}

Implements

IColorScheme.Hyperlink

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

ColorScheme.Item Property

Gets the element at the specified index. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As ColorSchemeIndex _
) _
Implements IColorScheme.Item
As IColorFormat _
Implements IColorScheme.Item
[C#]
public IColorFormat this[
Aspose.Slides.ColorSchemeIndex index
] {get;}

Implements

IColorScheme.Item

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Light1 Property

Aspose.Slides Documentation

ColorScheme.Light1 Property

First light color in the scheme. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Light1 As IColorFormat _
Implements IColorScheme.Light1
[C#]
public IColorFormat Light1 {get;}

Implements

IColorScheme.Light1

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Light2 Property

Aspose.Slides Documentation

ColorScheme.Light2 Property

Second light color in the scheme. Read-only ColorFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property Light2 As IColorFormat _
Implements IColorScheme.Light2
[C#]
public IColorFormat Light2 {get;}

Implements

IColorScheme.Light2

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Presentation Property

Aspose.Slides Documentation

ColorScheme.Presentation Property

Returns the parent presentation. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


Slide Property

Aspose.Slides Documentation

ColorScheme.Slide Property

Returns the parent slide. Read-only BaseSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As IBaseSlide _
Implements ISlideComponent.Slide
[C#]
public IBaseSlide Slide {get;}

Implements

ISlideComponent.Slide

See Also

ColorScheme Class | Aspose.Slides.Theme Namespace


ColorSchemeEffectiveData Class

Immutable ColorScheme object.

For a list of all members of this type, see ColorSchemeEffectiveData Members.

System.Object
Aspose.Slides.Theme.ColorSchemeEffectiveData

[Visual Basic]
Public Class ColorSchemeEffectiveData
Implements IColorSchemeEffectiveData
[C#]
public class ColorSchemeEffectiveData : IColorSchemeEffectiveData

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ColorSchemeEffectiveData Members | Aspose.Slides.Theme Namespace


ColorSchemeEffectiveData Members

ColorSchemeEffectiveData overview

Public Instance Properties

Accent1 | First accent color in the scheme. Read-only Color.
Accent2 | Second accent color in the scheme. Read-only Color.
Accent3 | Third accent color in the scheme. Read-only Color.
Accent4 | Fourth accent color in the scheme. Read-only Color.
Accent5 | Fifth accent color in the scheme. Read-only Color.
Accent6 | Sixth accent color in the scheme. Read-only Color.
Dark1 | First dark color in the scheme. Read-only Color.
Dark2 | Second dark color in the scheme. Read-only Color.
FollowedHyperlink | Color for the visited hyperlinks. Read-only Color.
Hyperlink | Color for the hyperlinks. Read-only Color.
Item | Gets the element at the specified index. Read-only Color.
Light1 | First light color in the scheme. Read-only Color.
Light2 | Second light color in the scheme. Read-only Color.

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


ColorSchemeEffectiveData Properties

The properties of the ColorSchemeEffectiveData class are listed below. For a complete list of ColorSchemeEffectiveData class members, see the ColorSchemeEffectiveData Members topic.

Public Instance Properties

Accent1 | First accent color in the scheme. Read-only Color.
Accent2 | Second accent color in the scheme. Read-only Color.
Accent3 | Third accent color in the scheme. Read-only Color.
Accent4 | Fourth accent color in the scheme. Read-only Color.
Accent5 | Fifth accent color in the scheme. Read-only Color.
Accent6 | Sixth accent color in the scheme. Read-only Color.
Dark1 | First dark color in the scheme. Read-only Color.
Dark2 | Second dark color in the scheme. Read-only Color.
FollowedHyperlink | Color for the visited hyperlinks. Read-only Color.
Hyperlink | Color for the hyperlinks. Read-only Color.
Item | Gets the element at the specified index. Read-only Color.
Light1 | First light color in the scheme. Read-only Color.
Light2 | Second light color in the scheme. Read-only Color.

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Accent1 Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.Accent1 Property

First accent color in the scheme. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Accent1 As Color _
Implements IColorSchemeEffectiveData.Accent1
[C#]
public Color Accent1 {get;}

Implements

IColorSchemeEffectiveData.Accent1

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Accent2 Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.Accent2 Property

Second accent color in the scheme. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Accent2 As Color _
Implements IColorSchemeEffectiveData.Accent2
[C#]
public Color Accent2 {get;}

Implements

IColorSchemeEffectiveData.Accent2

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Accent3 Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.Accent3 Property

Third accent color in the scheme. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Accent3 As Color _
Implements IColorSchemeEffectiveData.Accent3
[C#]
public Color Accent3 {get;}

Implements

IColorSchemeEffectiveData.Accent3

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Accent4 Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.Accent4 Property

Fourth accent color in the scheme. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Accent4 As Color _
Implements IColorSchemeEffectiveData.Accent4
[C#]
public Color Accent4 {get;}

Implements

IColorSchemeEffectiveData.Accent4

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Accent5 Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.Accent5 Property

Fifth accent color in the scheme. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Accent5 As Color _
Implements IColorSchemeEffectiveData.Accent5
[C#]
public Color Accent5 {get;}

Implements

IColorSchemeEffectiveData.Accent5

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Accent6 Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.Accent6 Property

Sixth accent color in the scheme. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Accent6 As Color _
Implements IColorSchemeEffectiveData.Accent6
[C#]
public Color Accent6 {get;}

Implements

IColorSchemeEffectiveData.Accent6

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Dark1 Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.Dark1 Property

First dark color in the scheme. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Dark1 As Color _
Implements IColorSchemeEffectiveData.Dark1
[C#]
public Color Dark1 {get;}

Implements

IColorSchemeEffectiveData.Dark1

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Dark2 Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.Dark2 Property

Second dark color in the scheme. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Dark2 As Color _
Implements IColorSchemeEffectiveData.Dark2
[C#]
public Color Dark2 {get;}

Implements

IColorSchemeEffectiveData.Dark2

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


FollowedHyperlink Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.FollowedHyperlink Property

Color for the visited hyperlinks. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property FollowedHyperlink As Color _
Implements IColorSchemeEffectiveData.FollowedHyperlink
[C#]
public Color FollowedHyperlink {get;}

Implements

IColorSchemeEffectiveData.FollowedHyperlink

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Hyperlink Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.Hyperlink Property

Color for the hyperlinks. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Hyperlink As Color _
Implements IColorSchemeEffectiveData.Hyperlink
[C#]
public Color Hyperlink {get;}

Implements

IColorSchemeEffectiveData.Hyperlink

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.Item Property

Gets the element at the specified index. Read-only Color.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As ColorSchemeIndex _
) _
Implements IColorSchemeEffectiveData.Item
As Color _
Implements IColorSchemeEffectiveData.Item
[C#]
public Color this[
Aspose.Slides.ColorSchemeIndex index
] {get;}

Implements

IColorSchemeEffectiveData.Item

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Light1 Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.Light1 Property

First light color in the scheme. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Light1 As Color _
Implements IColorSchemeEffectiveData.Light1
[C#]
public Color Light1 {get;}

Implements

IColorSchemeEffectiveData.Light1

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Light2 Property

Aspose.Slides Documentation

ColorSchemeEffectiveData.Light2 Property

Second light color in the scheme. Read-only Color.

[Visual Basic]
NotOverridable Public ReadOnly Property Light2 As Color _
Implements IColorSchemeEffectiveData.Light2
[C#]
public Color Light2 {get;}

Implements

IColorSchemeEffectiveData.Light2

See Also

ColorSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


EffectStyle Class

Represents an effect style.

For a list of all members of this type, see EffectStyle Members.

System.Object
Aspose.Slides.Theme.EffectStyle

[Visual Basic]
Public Class EffectStyle
Implements IEffectStyle
[C#]
public class EffectStyle : IEffectStyle

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

EffectStyle Members | Aspose.Slides.Theme Namespace


EffectStyle Members

EffectStyle overview

Public Instance Properties

EffectFormat | Returns an effect format. Readonly EffectFormat.
ThreeDFormat | Returns an 3d format. Readonly ThreeDFormat.

See Also

EffectStyle Class | Aspose.Slides.Theme Namespace


EffectStyle Properties

The properties of the EffectStyle class are listed below. For a complete list of EffectStyle class members, see the EffectStyle Members topic.

Public Instance Properties

EffectFormat | Returns an effect format. Readonly EffectFormat.
ThreeDFormat | Returns an 3d format. Readonly ThreeDFormat.

See Also

EffectStyle Class | Aspose.Slides.Theme Namespace


EffectFormat Property

Aspose.Slides Documentation

EffectStyle.EffectFormat Property

Returns an effect format. Readonly EffectFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property EffectFormat As IEffectFormat _
Implements IEffectStyle.EffectFormat
[C#]
public IEffectFormat EffectFormat {get;}

Implements

IEffectStyle.EffectFormat

See Also

EffectStyle Class | Aspose.Slides.Theme Namespace


ThreeDFormat Property

Aspose.Slides Documentation

EffectStyle.ThreeDFormat Property

Returns an 3d format. Readonly ThreeDFormat.

[Visual Basic]
NotOverridable Public ReadOnly Property ThreeDFormat As IThreeDFormat _
Implements IEffectStyle.ThreeDFormat
[C#]
public IThreeDFormat ThreeDFormat {get;}

Implements

IEffectStyle.ThreeDFormat

See Also

EffectStyle Class | Aspose.Slides.Theme Namespace


EffectStyleCollection Class

Represents a collection of effect styles.

For a list of all members of this type, see EffectStyleCollection Members.

System.Object
Aspose.Slides.Theme.EffectStyleCollection

[Visual Basic]
NotInheritable Public Class EffectStyleCollection
Implements IEffectStyleCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Theme.IEffectStyle, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public sealed class EffectStyleCollection : IEffectStyleCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

EffectStyleCollection Members | Aspose.Slides.Theme Namespace


EffectStyleCollection Members

EffectStyleCollection overview

Public Instance Properties

Count | Returns a number of elements in the collection. Readonly Int32,
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns an element at specified position. Readonly EffectStyle.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

EffectStyleCollection Class | Aspose.Slides.Theme Namespace


EffectStyleCollection Properties

The properties of the EffectStyleCollection class are listed below. For a complete list of EffectStyleCollection class members, see the EffectStyleCollection Members topic.

Public Instance Properties

Count | Returns a number of elements in the collection. Readonly Int32,
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Returns an element at specified position. Readonly EffectStyle.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

EffectStyleCollection Class | Aspose.Slides.Theme Namespace


Count Property

Aspose.Slides Documentation

EffectStyleCollection.Count Property

Returns a number of elements in the collection. Readonly Int32,

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

EffectStyleCollection Class | Aspose.Slides.Theme Namespace


IsSynchronized Property

Aspose.Slides Documentation

EffectStyleCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

EffectStyleCollection Class | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

EffectStyleCollection.Item Property

Returns an element at specified position. Readonly EffectStyle.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IEffectStyleCollection.Item
As IEffectStyle _
Implements IEffectStyleCollection.Item
[C#]
public IEffectStyle this[
int index
] {get;}

Parameters

index
Position of element.

Implements

IEffectStyleCollection.Item

See Also

EffectStyleCollection Class | Aspose.Slides.Theme Namespace


SyncRoot Property

Aspose.Slides Documentation

EffectStyleCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

EffectStyleCollection Class | Aspose.Slides.Theme Namespace


EffectStyleCollection Methods

The methods of the EffectStyleCollection class are listed below. For a complete list of EffectStyleCollection class members, see the EffectStyleCollection Members topic.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

EffectStyleCollection Class | Aspose.Slides.Theme Namespace


EffectStyleCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

EffectStyleCollection Class | Aspose.Slides.Theme Namespace


EffectStyleCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

EffectStyleCollection Class | Aspose.Slides.Theme Namespace


EffectStyleCollectionEffectiveData Class

Immutable EffectStyleCollection object.

For a list of all members of this type, see EffectStyleCollectionEffectiveData Members.

System.Object
Aspose.Slides.Theme.EffectStyleCollectionEffectiveData

[Visual Basic]
Public Class EffectStyleCollectionEffectiveData
Implements IEffectStyleCollectionEffectiveData, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Theme.IEffectStyleEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class EffectStyleCollectionEffectiveData : IEffectStyleCollectionEffectiveData, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

EffectStyleCollectionEffectiveData Members | Aspose.Slides.Theme Namespace


EffectStyleCollectionEffectiveData Members

EffectStyleCollectionEffectiveData overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only IEffectStyleEffectiveData.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

EffectStyleCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


EffectStyleCollectionEffectiveData Properties

The properties of the EffectStyleCollectionEffectiveData class are listed below. For a complete list of EffectStyleCollectionEffectiveData class members, see the EffectStyleCollectionEffectiveData Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only IEffectStyleEffectiveData.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

EffectStyleCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


Count Property

Aspose.Slides Documentation

EffectStyleCollectionEffectiveData.Count Property

Gets the number of elements actually contained in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

EffectStyleCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


IsSynchronized Property

Aspose.Slides Documentation

EffectStyleCollectionEffectiveData.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

EffectStyleCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

EffectStyleCollectionEffectiveData.Item Property

Gets the element at the specified index. Read-only IEffectStyleEffectiveData.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IEffectStyleCollectionEffectiveData.Item
As IEffectStyleEffectiveData _
Implements IEffectStyleCollectionEffectiveData.Item
[C#]
public IEffectStyleEffectiveData this[
int index
] {get;}

Implements

IEffectStyleCollectionEffectiveData.Item

See Also

EffectStyleCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


SyncRoot Property

Aspose.Slides Documentation

EffectStyleCollectionEffectiveData.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

EffectStyleCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


EffectStyleCollectionEffectiveData Methods

The methods of the EffectStyleCollectionEffectiveData class are listed below. For a complete list of EffectStyleCollectionEffectiveData class members, see the EffectStyleCollectionEffectiveData Members topic.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

EffectStyleCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


EffectStyleCollectionEffectiveData.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

EffectStyleCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


EffectStyleCollectionEffectiveData.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

EffectStyleCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


EffectStyleEffectiveData Class

Immutable EffectStyle object.

For a list of all members of this type, see EffectStyleEffectiveData Members.

System.Object
Aspose.Slides.Theme.EffectStyleEffectiveData

[Visual Basic]
Public Class EffectStyleEffectiveData
Implements IEffectStyleEffectiveData
[C#]
public class EffectStyleEffectiveData : IEffectStyleEffectiveData

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

EffectStyleEffectiveData Members | Aspose.Slides.Theme Namespace


EffectStyleEffectiveData Members

EffectStyleEffectiveData overview

Public Instance Properties

EffectFormat | Returns an effect format. Readonly EffectFormatEffectiveData.
ThreeDFormat | Returns an 3d format. Readonly ThreeDFormatEffectiveData.

See Also

EffectStyleEffectiveData Class | Aspose.Slides.Theme Namespace


EffectStyleEffectiveData Properties

The properties of the EffectStyleEffectiveData class are listed below. For a complete list of EffectStyleEffectiveData class members, see the EffectStyleEffectiveData Members topic.

Public Instance Properties

EffectFormat | Returns an effect format. Readonly EffectFormatEffectiveData.
ThreeDFormat | Returns an 3d format. Readonly ThreeDFormatEffectiveData.

See Also

EffectStyleEffectiveData Class | Aspose.Slides.Theme Namespace


EffectFormat Property

Aspose.Slides Documentation

EffectStyleEffectiveData.EffectFormat Property

Returns an effect format. Readonly EffectFormatEffectiveData.

[Visual Basic]
NotOverridable Public ReadOnly Property EffectFormat As IEffectFormatEffectiveData _
Implements IEffectStyleEffectiveData.EffectFormat
[C#]
public IEffectFormatEffectiveData EffectFormat {get;}

Implements

IEffectStyleEffectiveData.EffectFormat

See Also

EffectStyleEffectiveData Class | Aspose.Slides.Theme Namespace


ThreeDFormat Property

Aspose.Slides Documentation

EffectStyleEffectiveData.ThreeDFormat Property

Returns an 3d format. Readonly ThreeDFormatEffectiveData.

[Visual Basic]
NotOverridable Public ReadOnly Property ThreeDFormat As IThreeDFormatEffectiveData _
Implements IEffectStyleEffectiveData.ThreeDFormat
[C#]
public IThreeDFormatEffectiveData ThreeDFormat {get;}

Implements

IEffectStyleEffectiveData.ThreeDFormat

See Also

EffectStyleEffectiveData Class | Aspose.Slides.Theme Namespace


ExtraColorScheme Class

Represents an additional color scheme which can be assigned to a slide.

For a list of all members of this type, see ExtraColorScheme Members.

System.Object
Aspose.Slides.Theme.ExtraColorScheme

[Visual Basic]
Public Class ExtraColorScheme
Implements IExtraColorScheme
[C#]
public class ExtraColorScheme : IExtraColorScheme

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ExtraColorScheme Members | Aspose.Slides.Theme Namespace


ExtraColorScheme Members

ExtraColorScheme overview

Public Instance Properties

ColorScheme | Returns a color scheme. Readonly ColorScheme.
Name | Returns a name of this scheme.

See Also

ExtraColorScheme Class | Aspose.Slides.Theme Namespace


ExtraColorScheme Properties

The properties of the ExtraColorScheme class are listed below. For a complete list of ExtraColorScheme class members, see the ExtraColorScheme Members topic.

Public Instance Properties

ColorScheme | Returns a color scheme. Readonly ColorScheme.
Name | Returns a name of this scheme.

See Also

ExtraColorScheme Class | Aspose.Slides.Theme Namespace


ColorScheme Property

Aspose.Slides Documentation

ExtraColorScheme.ColorScheme Property

Returns a color scheme. Readonly ColorScheme.

[Visual Basic]
NotOverridable Public ReadOnly Property ColorScheme As IColorScheme _
Implements IExtraColorScheme.ColorScheme
[C#]
public IColorScheme ColorScheme {get;}

Implements

IExtraColorScheme.ColorScheme

See Also

ExtraColorScheme Class | Aspose.Slides.Theme Namespace


Name Property

Aspose.Slides Documentation

ExtraColorScheme.Name Property

Returns a name of this scheme.

[Visual Basic]
NotOverridable Public ReadOnly Property Name As String _
Implements IExtraColorScheme.Name
[C#]
public string Name {get;}

Implements

IExtraColorScheme.Name

See Also

ExtraColorScheme Class | Aspose.Slides.Theme Namespace


ExtraColorSchemeCollection Class

Represents a collection of additional color schemes.

For a list of all members of this type, see ExtraColorSchemeCollection Members.

System.Object
Aspose.Slides.Theme.ExtraColorSchemeCollection

[Visual Basic]
Public Class ExtraColorSchemeCollection
Implements IExtraColorSchemeCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Theme.IExtraColorScheme, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class ExtraColorSchemeCollection : IExtraColorSchemeCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ExtraColorSchemeCollection Members | Aspose.Slides.Theme Namespace


ExtraColorSchemeCollection Members

ExtraColorSchemeCollection overview

Public Instance Properties

Count | Returns a number of elements int the collection. Readonly Int32.
IsSynchronized | Returns a value indicating whether access to the ArrayList is synchronized (thread safe). Readonly Boolean.
Item | Returns an color scheme by index. Readonly ExtraColorScheme.
SyncRoot | Returns an object that can be used to synchronize access to the collection. Readonly Object.

Public Instance Methods

CopyTo | Copies all elements of the collection to the specified array.
GetEnumerator | Returns an enumerator, which can be used to iterate through the collection.

See Also

ExtraColorSchemeCollection Class | Aspose.Slides.Theme Namespace


ExtraColorSchemeCollection Properties

The properties of the ExtraColorSchemeCollection class are listed below. For a complete list of ExtraColorSchemeCollection class members, see the ExtraColorSchemeCollection Members topic.

Public Instance Properties

Count | Returns a number of elements int the collection. Readonly Int32.
IsSynchronized | Returns a value indicating whether access to the ArrayList is synchronized (thread safe). Readonly Boolean.
Item | Returns an color scheme by index. Readonly ExtraColorScheme.
SyncRoot | Returns an object that can be used to synchronize access to the collection. Readonly Object.

See Also

ExtraColorSchemeCollection Class | Aspose.Slides.Theme Namespace


Count Property

Aspose.Slides Documentation

ExtraColorSchemeCollection.Count Property

Returns a number of elements int the collection. Readonly Int32.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

ExtraColorSchemeCollection Class | Aspose.Slides.Theme Namespace


IsSynchronized Property

Aspose.Slides Documentation

ExtraColorSchemeCollection.IsSynchronized Property

Returns a value indicating whether access to the ArrayList is synchronized (thread safe). Readonly Boolean.

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ExtraColorSchemeCollection Class | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

ExtraColorSchemeCollection.Item Property

Returns an color scheme by index. Readonly ExtraColorScheme.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IExtraColorSchemeCollection.Item
As IExtraColorScheme _
Implements IExtraColorSchemeCollection.Item
[C#]
public IExtraColorScheme this[
int index
] {get;}

Implements

IExtraColorSchemeCollection.Item

See Also

ExtraColorSchemeCollection Class | Aspose.Slides.Theme Namespace


SyncRoot Property

Aspose.Slides Documentation

ExtraColorSchemeCollection.SyncRoot Property

Returns an object that can be used to synchronize access to the collection. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ExtraColorSchemeCollection Class | Aspose.Slides.Theme Namespace


ExtraColorSchemeCollection Methods

The methods of the ExtraColorSchemeCollection class are listed below. For a complete list of ExtraColorSchemeCollection class members, see the ExtraColorSchemeCollection Members topic.

Public Instance Methods

CopyTo | Copies all elements of the collection to the specified array.
GetEnumerator | Returns an enumerator, which can be used to iterate through the collection.

See Also

ExtraColorSchemeCollection Class | Aspose.Slides.Theme Namespace


ExtraColorSchemeCollection.CopyTo Method

Copies all elements of the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the array.

Implements

ICollection.CopyTo

See Also

ExtraColorSchemeCollection Class | Aspose.Slides.Theme Namespace


ExtraColorSchemeCollection.GetEnumerator Method

Returns an enumerator, which can be used to iterate through the collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

Enumeraton IEnumerator.

Implements

IEnumerable.GetEnumerator

See Also

ExtraColorSchemeCollection Class | Aspose.Slides.Theme Namespace


FillFormatCollection Class

Represents the collection of fill styles.

For a list of all members of this type, see FillFormatCollection Members.

System.Object
Aspose.Slides.Theme.FillFormatCollection

[Visual Basic]
NotInheritable Public Class FillFormatCollection
Implements IFillFormatCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IFillFormat, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public sealed class FillFormatCollection : IFillFormatCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FillFormatCollection Members | Aspose.Slides.Theme Namespace


FillFormatCollection Members

FillFormatCollection overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only IFillFormat.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

FillFormatCollection Class | Aspose.Slides.Theme Namespace


FillFormatCollection Properties

The properties of the FillFormatCollection class are listed below. For a complete list of FillFormatCollection class members, see the FillFormatCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only IFillFormat.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

FillFormatCollection Class | Aspose.Slides.Theme Namespace


Count Property

Aspose.Slides Documentation

FillFormatCollection.Count Property

Gets the number of elements actually contained in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

FillFormatCollection Class | Aspose.Slides.Theme Namespace


IsSynchronized Property

Aspose.Slides Documentation

FillFormatCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

FillFormatCollection Class | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

FillFormatCollection.Item Property

Gets the element at the specified index. Read-only IFillFormat.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IFillFormatCollection.Item
As IFillFormat _
Implements IFillFormatCollection.Item
[C#]
public IFillFormat this[
int index
] {get;}

Implements

IFillFormatCollection.Item

See Also

FillFormatCollection Class | Aspose.Slides.Theme Namespace


SyncRoot Property

Aspose.Slides Documentation

FillFormatCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

FillFormatCollection Class | Aspose.Slides.Theme Namespace


FillFormatCollection Methods

The methods of the FillFormatCollection class are listed below. For a complete list of FillFormatCollection class members, see the FillFormatCollection Members topic.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

FillFormatCollection Class | Aspose.Slides.Theme Namespace


FillFormatCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

FillFormatCollection Class | Aspose.Slides.Theme Namespace


FillFormatCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

FillFormatCollection Class | Aspose.Slides.Theme Namespace


FillFormatCollectionEffectiveData Class

Immutable FillFormatCollection object.

For a list of all members of this type, see FillFormatCollectionEffectiveData Members.

System.Object
Aspose.Slides.Theme.FillFormatCollectionEffectiveData

[Visual Basic]
Public Class FillFormatCollectionEffectiveData
Implements IFillFormatCollectionEffectiveData, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IFillFormatEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class FillFormatCollectionEffectiveData : IFillFormatCollectionEffectiveData, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FillFormatCollectionEffectiveData Members | Aspose.Slides.Theme Namespace


FillFormatCollectionEffectiveData Members

FillFormatCollectionEffectiveData overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only IFillFormatEffectiveData.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

FillFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


FillFormatCollectionEffectiveData Properties

The properties of the FillFormatCollectionEffectiveData class are listed below. For a complete list of FillFormatCollectionEffectiveData class members, see the FillFormatCollectionEffectiveData Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only IFillFormatEffectiveData.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

FillFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


Count Property

Aspose.Slides Documentation

FillFormatCollectionEffectiveData.Count Property

Gets the number of elements actually contained in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

FillFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


IsSynchronized Property

Aspose.Slides Documentation

FillFormatCollectionEffectiveData.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

FillFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

FillFormatCollectionEffectiveData.Item Property

Gets the element at the specified index. Read-only IFillFormatEffectiveData.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements IFillFormatCollectionEffectiveData.Item
As IFillFormatEffectiveData _
Implements IFillFormatCollectionEffectiveData.Item
[C#]
public IFillFormatEffectiveData this[
int index
] {get;}

Implements

IFillFormatCollectionEffectiveData.Item

See Also

FillFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


SyncRoot Property

Aspose.Slides Documentation

FillFormatCollectionEffectiveData.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

FillFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


FillFormatCollectionEffectiveData Methods

The methods of the FillFormatCollectionEffectiveData class are listed below. For a complete list of FillFormatCollectionEffectiveData class members, see the FillFormatCollectionEffectiveData Members topic.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

FillFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


FillFormatCollectionEffectiveData.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

FillFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


FillFormatCollectionEffectiveData.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

FillFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


FontScheme Class

Stores theme-defined fonts.

For a list of all members of this type, see FontScheme Members.

System.Object
Aspose.Slides.Theme.FontScheme

[Visual Basic]
Public Class FontScheme
Implements IFontScheme
[C#]
public class FontScheme : IFontScheme

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FontScheme Members | Aspose.Slides.Theme Namespace


FontScheme Members

FontScheme overview

Public Instance Properties

Major | Returns the fonts collection for a "heading" part of the slide. Readonly Fonts.
Minor | Returns the fonts collection for a "body" part of the slide. Readonly Fonts.
Name | Returns the font scheme name. Read/write string.

See Also

FontScheme Class | Aspose.Slides.Theme Namespace


FontScheme Properties

The properties of the FontScheme class are listed below. For a complete list of FontScheme class members, see the FontScheme Members topic.

Public Instance Properties

Major | Returns the fonts collection for a "heading" part of the slide. Readonly Fonts.
Minor | Returns the fonts collection for a "body" part of the slide. Readonly Fonts.
Name | Returns the font scheme name. Read/write string.

See Also

FontScheme Class | Aspose.Slides.Theme Namespace


Major Property

Aspose.Slides Documentation

FontScheme.Major Property

Returns the fonts collection for a "heading" part of the slide. Readonly Fonts.

[Visual Basic]
NotOverridable Public ReadOnly Property Major As IFonts _
Implements IFontScheme.Major
[C#]
public IFonts Major {get;}

Implements

IFontScheme.Major

See Also

FontScheme Class | Aspose.Slides.Theme Namespace


Minor Property

Aspose.Slides Documentation

FontScheme.Minor Property

Returns the fonts collection for a "body" part of the slide. Readonly Fonts.

[Visual Basic]
NotOverridable Public ReadOnly Property Minor As IFonts _
Implements IFontScheme.Minor
[C#]
public IFonts Minor {get;}

Implements

IFontScheme.Minor

See Also

FontScheme Class | Aspose.Slides.Theme Namespace


Name Property

Aspose.Slides Documentation

FontScheme.Name Property

Returns the font scheme name. Read/write string.

[Visual Basic]
NotOverridable Public Property Name As String _
Implements IFontScheme.Name
[C#]
public string Name {get; set;}

Implements

IFontScheme.Name

See Also

FontScheme Class | Aspose.Slides.Theme Namespace


FontSchemeEffectiveData Class

Immutable FontScheme object.

For a list of all members of this type, see FontSchemeEffectiveData Members.

System.Object
Aspose.Slides.Theme.FontSchemeEffectiveData

[Visual Basic]
Public Class FontSchemeEffectiveData
Implements IFontSchemeEffectiveData
[C#]
public class FontSchemeEffectiveData : IFontSchemeEffectiveData

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FontSchemeEffectiveData Members | Aspose.Slides.Theme Namespace


FontSchemeEffectiveData Members

FontSchemeEffectiveData overview

Public Instance Properties

Major | Returns the fonts collection for a "heading" part of the slide. Readonly IFontsEffectiveData.
Minor | Returns the fonts collection for a "body" part of the slide. Readonly IFontsEffectiveData.
Name | Returns the font scheme name. Readonly string.

See Also

FontSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


FontSchemeEffectiveData Properties

The properties of the FontSchemeEffectiveData class are listed below. For a complete list of FontSchemeEffectiveData class members, see the FontSchemeEffectiveData Members topic.

Public Instance Properties

Major | Returns the fonts collection for a "heading" part of the slide. Readonly IFontsEffectiveData.
Minor | Returns the fonts collection for a "body" part of the slide. Readonly IFontsEffectiveData.
Name | Returns the font scheme name. Readonly string.

See Also

FontSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Major Property

Aspose.Slides Documentation

FontSchemeEffectiveData.Major Property

Returns the fonts collection for a "heading" part of the slide. Readonly IFontsEffectiveData.

[Visual Basic]
NotOverridable Public ReadOnly Property Major As IFontsEffectiveData _
Implements IFontSchemeEffectiveData.Major
[C#]
public IFontsEffectiveData Major {get;}

Implements

IFontSchemeEffectiveData.Major

See Also

FontSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Minor Property

Aspose.Slides Documentation

FontSchemeEffectiveData.Minor Property

Returns the fonts collection for a "body" part of the slide. Readonly IFontsEffectiveData.

[Visual Basic]
NotOverridable Public ReadOnly Property Minor As IFontsEffectiveData _
Implements IFontSchemeEffectiveData.Minor
[C#]
public IFontsEffectiveData Minor {get;}

Implements

IFontSchemeEffectiveData.Minor

See Also

FontSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


Name Property

Aspose.Slides Documentation

FontSchemeEffectiveData.Name Property

Returns the font scheme name. Readonly string.

[Visual Basic]
NotOverridable Public ReadOnly Property Name As String _
Implements IFontSchemeEffectiveData.Name
[C#]
public string Name {get;}

Implements

IFontSchemeEffectiveData.Name

See Also

FontSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


FormatScheme Class

Stores theme-defined formats for the shapes.

For a list of all members of this type, see FormatScheme Members.

System.Object
Aspose.Slides.Theme.FormatScheme

[Visual Basic]
Public Class FormatScheme
Implements IFormatScheme, ISlideComponent, IPresentationComponent
[C#]
public class FormatScheme : IFormatScheme, ISlideComponent, IPresentationComponent

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FormatScheme Members | Aspose.Slides.Theme Namespace


FormatScheme Members

FormatScheme overview

Public Instance Properties

BackgroundFillStyles | Returns a collection of theme defined background fill styles. Readonly FillFormatCollection.
EffectStyles | Returns a collection of theme defined effect styles. Readonly EffectStyleCollection.
FillStyles | Returns a collection of theme defined fill styles. Readonly FillFormatCollection.
LineStyles | Returns a collection of theme defined line styles. Readonly LineFormatCollection.
Presentation | Returns the parent presentation. Read-only Presentation.
Slide | Returns the parent slide. Read-only BaseSlide.

See Also

FormatScheme Class | Aspose.Slides.Theme Namespace


FormatScheme Properties

The properties of the FormatScheme class are listed below. For a complete list of FormatScheme class members, see the FormatScheme Members topic.

Public Instance Properties

BackgroundFillStyles | Returns a collection of theme defined background fill styles. Readonly FillFormatCollection.
EffectStyles | Returns a collection of theme defined effect styles. Readonly EffectStyleCollection.
FillStyles | Returns a collection of theme defined fill styles. Readonly FillFormatCollection.
LineStyles | Returns a collection of theme defined line styles. Readonly LineFormatCollection.
Presentation | Returns the parent presentation. Read-only Presentation.
Slide | Returns the parent slide. Read-only BaseSlide.

See Also

FormatScheme Class | Aspose.Slides.Theme Namespace


BackgroundFillStyles Property

Aspose.Slides Documentation

FormatScheme.BackgroundFillStyles Property

Returns a collection of theme defined background fill styles. Readonly FillFormatCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property BackgroundFillStyles As IFillFormatCollection _
Implements IFormatScheme.BackgroundFillStyles
[C#]
public IFillFormatCollection BackgroundFillStyles {get;}

Implements

IFormatScheme.BackgroundFillStyles

See Also

FormatScheme Class | Aspose.Slides.Theme Namespace


EffectStyles Property

Aspose.Slides Documentation

FormatScheme.EffectStyles Property

Returns a collection of theme defined effect styles. Readonly EffectStyleCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property EffectStyles As IEffectStyleCollection _
Implements IFormatScheme.EffectStyles
[C#]
public IEffectStyleCollection EffectStyles {get;}

Implements

IFormatScheme.EffectStyles

See Also

FormatScheme Class | Aspose.Slides.Theme Namespace


FillStyles Property

Aspose.Slides Documentation

FormatScheme.FillStyles Property

Returns a collection of theme defined fill styles. Readonly FillFormatCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property FillStyles As IFillFormatCollection _
Implements IFormatScheme.FillStyles
[C#]
public IFillFormatCollection FillStyles {get;}

Implements

IFormatScheme.FillStyles

See Also

FormatScheme Class | Aspose.Slides.Theme Namespace


LineStyles Property

Aspose.Slides Documentation

FormatScheme.LineStyles Property

Returns a collection of theme defined line styles. Readonly LineFormatCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property LineStyles As ILineFormatCollection _
Implements IFormatScheme.LineStyles
[C#]
public ILineFormatCollection LineStyles {get;}

Implements

IFormatScheme.LineStyles

See Also

FormatScheme Class | Aspose.Slides.Theme Namespace


Presentation Property

Aspose.Slides Documentation

FormatScheme.Presentation Property

Returns the parent presentation. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

FormatScheme Class | Aspose.Slides.Theme Namespace


Slide Property

Aspose.Slides Documentation

FormatScheme.Slide Property

Returns the parent slide. Read-only BaseSlide.

[Visual Basic]
NotOverridable Public ReadOnly Property Slide As IBaseSlide _
Implements ISlideComponent.Slide
[C#]
public IBaseSlide Slide {get;}

Implements

ISlideComponent.Slide

See Also

FormatScheme Class | Aspose.Slides.Theme Namespace


FormatSchemeEffectiveData Class

Immutable FormatScheme object.

For a list of all members of this type, see FormatSchemeEffectiveData Members.

System.Object
Aspose.Slides.Theme.FormatSchemeEffectiveData

[Visual Basic]
Public Class FormatSchemeEffectiveData
Implements IFormatSchemeEffectiveData
[C#]
public class FormatSchemeEffectiveData : IFormatSchemeEffectiveData

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

FormatSchemeEffectiveData Members | Aspose.Slides.Theme Namespace


FormatSchemeEffectiveData Members

FormatSchemeEffectiveData overview

Public Instance Methods

GetBackgroundFillStyles | Returns a collection of theme defined background fill styles.
GetEffectStyles | Returns a collection of theme defined effect styles.
GetFillStyles | Returns a collection of theme defined fill styles.
GetLineStyles | Returns a collection of theme defined line styles.

See Also

FormatSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


FormatSchemeEffectiveData Methods

The methods of the FormatSchemeEffectiveData class are listed below. For a complete list of FormatSchemeEffectiveData class members, see the FormatSchemeEffectiveData Members topic.

Public Instance Methods

GetBackgroundFillStyles | Returns a collection of theme defined background fill styles.
GetEffectStyles | Returns a collection of theme defined effect styles.
GetFillStyles | Returns a collection of theme defined fill styles.
GetLineStyles | Returns a collection of theme defined line styles.

See Also

FormatSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


FormatSchemeEffectiveData.GetBackgroundFillStyles Method

Returns a collection of theme defined background fill styles.

[Visual Basic]
NotOverridable Public Function GetBackgroundFillStyles( _
ByVal styleColor As Color _
) As IFillFormatCollectionEffectiveData _
Implements IFormatSchemeEffectiveData.GetBackgroundFillStyles
[C#]
public IFillFormatCollectionEffectiveData GetBackgroundFillStyles(
Color styleColor
);

Implements

IFormatSchemeEffectiveData.GetBackgroundFillStyles

See Also

FormatSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


FormatSchemeEffectiveData.GetEffectStyles Method

Returns a collection of theme defined effect styles.

[Visual Basic]
NotOverridable Public Function GetEffectStyles( _
ByVal styleColor As Color _
) As IEffectStyleCollectionEffectiveData _
Implements IFormatSchemeEffectiveData.GetEffectStyles
[C#]
public IEffectStyleCollectionEffectiveData GetEffectStyles(
Color styleColor
);

Implements

IFormatSchemeEffectiveData.GetEffectStyles

See Also

FormatSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


FormatSchemeEffectiveData.GetFillStyles Method

Returns a collection of theme defined fill styles.

[Visual Basic]
NotOverridable Public Function GetFillStyles( _
ByVal styleColor As Color _
) As IFillFormatCollectionEffectiveData _
Implements IFormatSchemeEffectiveData.GetFillStyles
[C#]
public IFillFormatCollectionEffectiveData GetFillStyles(
Color styleColor
);

Implements

IFormatSchemeEffectiveData.GetFillStyles

See Also

FormatSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


FormatSchemeEffectiveData.GetLineStyles Method

Returns a collection of theme defined line styles.

[Visual Basic]
NotOverridable Public Function GetLineStyles( _
ByVal styleColor As Color _
) As ILineFormatCollectionEffectiveData _
Implements IFormatSchemeEffectiveData.GetLineStyles
[C#]
public ILineFormatCollectionEffectiveData GetLineStyles(
Color styleColor
);

Implements

IFormatSchemeEffectiveData.GetLineStyles

See Also

FormatSchemeEffectiveData Class | Aspose.Slides.Theme Namespace


IColorScheme Interface

For a list of all members of this type, see IColorScheme Members.

[Visual Basic]
Public Interface IColorScheme
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IColorScheme : ISlideComponent, IPresentationComponent

Types that implement IColorScheme

Type | Description
ColorScheme | Stores theme-defined colors.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColorScheme Members | Aspose.Slides.Theme Namespace


IColorScheme Members

IColorScheme overview

Public Instance Properties

Accent1
Accent2
Accent3
Accent4
Accent5
Accent6
AsISlideComponent
Dark1
Dark2
FollowedHyperlink
Hyperlink
Item
Light1
Light2

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


IColorScheme Properties

The properties of the IColorScheme interface are listed below. For a complete list of IColorScheme interface members, see the IColorScheme Members topic.

Public Instance Properties

Accent1
Accent2
Accent3
Accent4
Accent5
Accent6
AsISlideComponent
Dark1
Dark2
FollowedHyperlink
Hyperlink
Item
Light1
Light2

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


Accent1 Property

Aspose.Slides Documentation

IColorScheme.Accent1 Property

[Visual Basic]
Property Accent1 As IColorFormat
[C#]
IColorFormat Accent1 {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


Accent2 Property

Aspose.Slides Documentation

IColorScheme.Accent2 Property

[Visual Basic]
Property Accent2 As IColorFormat
[C#]
IColorFormat Accent2 {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


Accent3 Property

Aspose.Slides Documentation

IColorScheme.Accent3 Property

[Visual Basic]
Property Accent3 As IColorFormat
[C#]
IColorFormat Accent3 {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


Accent4 Property

Aspose.Slides Documentation

IColorScheme.Accent4 Property

[Visual Basic]
Property Accent4 As IColorFormat
[C#]
IColorFormat Accent4 {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


Accent5 Property

Aspose.Slides Documentation

IColorScheme.Accent5 Property

[Visual Basic]
Property Accent5 As IColorFormat
[C#]
IColorFormat Accent5 {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


Accent6 Property

Aspose.Slides Documentation

IColorScheme.Accent6 Property

[Visual Basic]
Property Accent6 As IColorFormat
[C#]
IColorFormat Accent6 {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IColorScheme.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


Dark1 Property

Aspose.Slides Documentation

IColorScheme.Dark1 Property

[Visual Basic]
Property Dark1 As IColorFormat
[C#]
IColorFormat Dark1 {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


Dark2 Property

Aspose.Slides Documentation

IColorScheme.Dark2 Property

[Visual Basic]
Property Dark2 As IColorFormat
[C#]
IColorFormat Dark2 {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


FollowedHyperlink Property

Aspose.Slides Documentation

IColorScheme.FollowedHyperlink Property

[Visual Basic]
Property FollowedHyperlink As IColorFormat
[C#]
IColorFormat FollowedHyperlink {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


Hyperlink Property

Aspose.Slides Documentation

IColorScheme.Hyperlink Property

[Visual Basic]
Property Hyperlink As IColorFormat
[C#]
IColorFormat Hyperlink {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

IColorScheme.Item Property

[Visual Basic]
Property Item( _
ByVal index As ColorSchemeIndex _
) As IColorFormat
[C#]
IColorFormat this[
Aspose.Slides.ColorSchemeIndex index
] {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


Light1 Property

Aspose.Slides Documentation

IColorScheme.Light1 Property

[Visual Basic]
Property Light1 As IColorFormat
[C#]
IColorFormat Light1 {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


Light2 Property

Aspose.Slides Documentation

IColorScheme.Light2 Property

[Visual Basic]
Property Light2 As IColorFormat
[C#]
IColorFormat Light2 {get;}

See Also

IColorScheme Interface | Aspose.Slides.Theme Namespace


IColorSchemeEffectiveData Interface

For a list of all members of this type, see IColorSchemeEffectiveData Members.

[Visual Basic]
Public Interface IColorSchemeEffectiveData
[C#]
public interface IColorSchemeEffectiveData

Types that implement IColorSchemeEffectiveData

Type | Description
ColorSchemeEffectiveData | Immutable ColorScheme object.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IColorSchemeEffectiveData Members | Aspose.Slides.Theme Namespace


IColorSchemeEffectiveData Members

IColorSchemeEffectiveData overview

Public Instance Properties

Accent1
Accent2
Accent3
Accent4
Accent5
Accent6
Dark1
Dark2
FollowedHyperlink
Hyperlink
Item
Light1
Light2

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IColorSchemeEffectiveData Properties

The properties of the IColorSchemeEffectiveData interface are listed below. For a complete list of IColorSchemeEffectiveData interface members, see the IColorSchemeEffectiveData Members topic.

Public Instance Properties

Accent1
Accent2
Accent3
Accent4
Accent5
Accent6
Dark1
Dark2
FollowedHyperlink
Hyperlink
Item
Light1
Light2

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Accent1 Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.Accent1 Property

[Visual Basic]
Property Accent1 As Color
[C#]
Color Accent1 {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Accent2 Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.Accent2 Property

[Visual Basic]
Property Accent2 As Color
[C#]
Color Accent2 {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Accent3 Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.Accent3 Property

[Visual Basic]
Property Accent3 As Color
[C#]
Color Accent3 {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Accent4 Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.Accent4 Property

[Visual Basic]
Property Accent4 As Color
[C#]
Color Accent4 {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Accent5 Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.Accent5 Property

[Visual Basic]
Property Accent5 As Color
[C#]
Color Accent5 {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Accent6 Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.Accent6 Property

[Visual Basic]
Property Accent6 As Color
[C#]
Color Accent6 {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Dark1 Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.Dark1 Property

[Visual Basic]
Property Dark1 As Color
[C#]
Color Dark1 {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Dark2 Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.Dark2 Property

[Visual Basic]
Property Dark2 As Color
[C#]
Color Dark2 {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


FollowedHyperlink Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.FollowedHyperlink Property

[Visual Basic]
Property FollowedHyperlink As Color
[C#]
Color FollowedHyperlink {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Hyperlink Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.Hyperlink Property

[Visual Basic]
Property Hyperlink As Color
[C#]
Color Hyperlink {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.Item Property

[Visual Basic]
Property Item( _
ByVal index As ColorSchemeIndex _
) As Color
[C#]
Color this[
Aspose.Slides.ColorSchemeIndex index
] {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Light1 Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.Light1 Property

[Visual Basic]
Property Light1 As Color
[C#]
Color Light1 {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Light2 Property

Aspose.Slides Documentation

IColorSchemeEffectiveData.Light2 Property

[Visual Basic]
Property Light2 As Color
[C#]
Color Light2 {get;}

See Also

IColorSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IEffectStyle Interface

For a list of all members of this type, see IEffectStyle Members.

[Visual Basic]
Public Interface IEffectStyle
[C#]
public interface IEffectStyle

Types that implement IEffectStyle

Type | Description
EffectStyle | Represents an effect style.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IEffectStyle Members | Aspose.Slides.Theme Namespace


IEffectStyle Members

IEffectStyle overview

Public Instance Properties

EffectFormat
ThreeDFormat

See Also

IEffectStyle Interface | Aspose.Slides.Theme Namespace


IEffectStyle Properties

The properties of the IEffectStyle interface are listed below. For a complete list of IEffectStyle interface members, see the IEffectStyle Members topic.

Public Instance Properties

EffectFormat
ThreeDFormat

See Also

IEffectStyle Interface | Aspose.Slides.Theme Namespace


EffectFormat Property

Aspose.Slides Documentation

IEffectStyle.EffectFormat Property

[Visual Basic]
Property EffectFormat As IEffectFormat
[C#]
IEffectFormat EffectFormat {get;}

See Also

IEffectStyle Interface | Aspose.Slides.Theme Namespace


ThreeDFormat Property

Aspose.Slides Documentation

IEffectStyle.ThreeDFormat Property

[Visual Basic]
Property ThreeDFormat As IThreeDFormat
[C#]
IThreeDFormat ThreeDFormat {get;}

See Also

IEffectStyle Interface | Aspose.Slides.Theme Namespace


IEffectStyleCollection Interface

For a list of all members of this type, see IEffectStyleCollection Members.

[Visual Basic]
Public Interface IEffectStyleCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Theme.IEffectStyle, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IEffectStyleCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IEffectStyleCollection

Type | Description
EffectStyleCollection | Represents a collection of effect styles.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IEffectStyleCollection Members | Aspose.Slides.Theme Namespace


IEffectStyleCollection Members

IEffectStyleCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IEffectStyleCollection Interface | Aspose.Slides.Theme Namespace


IEffectStyleCollection Properties

The properties of the IEffectStyleCollection interface are listed below. For a complete list of IEffectStyleCollection interface members, see the IEffectStyleCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IEffectStyleCollection Interface | Aspose.Slides.Theme Namespace


AsICollection Property

Aspose.Slides Documentation

IEffectStyleCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IEffectStyleCollection Interface | Aspose.Slides.Theme Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IEffectStyleCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IEffectStyleCollection Interface | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

IEffectStyleCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IEffectStyle
[C#]
IEffectStyle this[
int index
] {get;}

See Also

IEffectStyleCollection Interface | Aspose.Slides.Theme Namespace


IEffectStyleCollectionEffectiveData Interface

For a list of all members of this type, see IEffectStyleCollectionEffectiveData Members.

[Visual Basic]
Public Interface IEffectStyleCollectionEffectiveData
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Theme.IEffectStyleEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IEffectStyleCollectionEffectiveData : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IEffectStyleCollectionEffectiveData

Type | Description
EffectStyleCollectionEffectiveData | Immutable EffectStyleCollection object.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IEffectStyleCollectionEffectiveData Members | Aspose.Slides.Theme Namespace


IEffectStyleCollectionEffectiveData Members

IEffectStyleCollectionEffectiveData overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IEffectStyleCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


IEffectStyleCollectionEffectiveData Properties

The properties of the IEffectStyleCollectionEffectiveData interface are listed below. For a complete list of IEffectStyleCollectionEffectiveData interface members, see the IEffectStyleCollectionEffectiveData Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IEffectStyleCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


AsICollection Property

Aspose.Slides Documentation

IEffectStyleCollectionEffectiveData.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IEffectStyleCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IEffectStyleCollectionEffectiveData.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IEffectStyleCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

IEffectStyleCollectionEffectiveData.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IEffectStyleEffectiveData
[C#]
IEffectStyleEffectiveData this[
int index
] {get;}

See Also

IEffectStyleCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


IEffectStyleEffectiveData Interface

For a list of all members of this type, see IEffectStyleEffectiveData Members.

[Visual Basic]
Public Interface IEffectStyleEffectiveData
[C#]
public interface IEffectStyleEffectiveData

Types that implement IEffectStyleEffectiveData

Type | Description
EffectStyleEffectiveData | Immutable EffectStyle object.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IEffectStyleEffectiveData Members | Aspose.Slides.Theme Namespace


IEffectStyleEffectiveData Members

IEffectStyleEffectiveData overview

Public Instance Properties

EffectFormat
ThreeDFormat

See Also

IEffectStyleEffectiveData Interface | Aspose.Slides.Theme Namespace


IEffectStyleEffectiveData Properties

The properties of the IEffectStyleEffectiveData interface are listed below. For a complete list of IEffectStyleEffectiveData interface members, see the IEffectStyleEffectiveData Members topic.

Public Instance Properties

EffectFormat
ThreeDFormat

See Also

IEffectStyleEffectiveData Interface | Aspose.Slides.Theme Namespace


EffectFormat Property

Aspose.Slides Documentation

IEffectStyleEffectiveData.EffectFormat Property

[Visual Basic]
Property EffectFormat As IEffectFormatEffectiveData
[C#]
IEffectFormatEffectiveData EffectFormat {get;}

See Also

IEffectStyleEffectiveData Interface | Aspose.Slides.Theme Namespace


ThreeDFormat Property

Aspose.Slides Documentation

IEffectStyleEffectiveData.ThreeDFormat Property

[Visual Basic]
Property ThreeDFormat As IThreeDFormatEffectiveData
[C#]
IThreeDFormatEffectiveData ThreeDFormat {get;}

See Also

IEffectStyleEffectiveData Interface | Aspose.Slides.Theme Namespace


IExtraColorScheme Interface

For a list of all members of this type, see IExtraColorScheme Members.

[Visual Basic]
Public Interface IExtraColorScheme
[C#]
public interface IExtraColorScheme

Types that implement IExtraColorScheme

Type | Description
ExtraColorScheme | Represents an additional color scheme which can be assigned to a slide.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IExtraColorScheme Members | Aspose.Slides.Theme Namespace


IExtraColorScheme Members

IExtraColorScheme overview

Public Instance Properties

ColorScheme
Name

See Also

IExtraColorScheme Interface | Aspose.Slides.Theme Namespace


IExtraColorScheme Properties

The properties of the IExtraColorScheme interface are listed below. For a complete list of IExtraColorScheme interface members, see the IExtraColorScheme Members topic.

Public Instance Properties

ColorScheme
Name

See Also

IExtraColorScheme Interface | Aspose.Slides.Theme Namespace


ColorScheme Property

Aspose.Slides Documentation

IExtraColorScheme.ColorScheme Property

[Visual Basic]
Property ColorScheme As IColorScheme
[C#]
IColorScheme ColorScheme {get;}

See Also

IExtraColorScheme Interface | Aspose.Slides.Theme Namespace


Name Property

Aspose.Slides Documentation

IExtraColorScheme.Name Property

[Visual Basic]
Property Name As String
[C#]
string Name {get;}

See Also

IExtraColorScheme Interface | Aspose.Slides.Theme Namespace


IExtraColorSchemeCollection Interface

For a list of all members of this type, see IExtraColorSchemeCollection Members.

[Visual Basic]
Public Interface IExtraColorSchemeCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.Theme.IExtraColorScheme, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IExtraColorSchemeCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IExtraColorSchemeCollection

Type | Description
ExtraColorSchemeCollection | Represents a collection of additional color schemes.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IExtraColorSchemeCollection Members | Aspose.Slides.Theme Namespace


IExtraColorSchemeCollection Members

IExtraColorSchemeCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IExtraColorSchemeCollection Interface | Aspose.Slides.Theme Namespace


IExtraColorSchemeCollection Properties

The properties of the IExtraColorSchemeCollection interface are listed below. For a complete list of IExtraColorSchemeCollection interface members, see the IExtraColorSchemeCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IExtraColorSchemeCollection Interface | Aspose.Slides.Theme Namespace


AsICollection Property

Aspose.Slides Documentation

IExtraColorSchemeCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IExtraColorSchemeCollection Interface | Aspose.Slides.Theme Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IExtraColorSchemeCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IExtraColorSchemeCollection Interface | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

IExtraColorSchemeCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IExtraColorScheme
[C#]
IExtraColorScheme this[
int index
] {get;}

See Also

IExtraColorSchemeCollection Interface | Aspose.Slides.Theme Namespace


IFillFormatCollection Interface

For a list of all members of this type, see IFillFormatCollection Members.

[Visual Basic]
Public Interface IFillFormatCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IFillFormat, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IFillFormatCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IFillFormatCollection

Type | Description
FillFormatCollection | Represents the collection of fill styles.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFillFormatCollection Members | Aspose.Slides.Theme Namespace


IFillFormatCollection Members

IFillFormatCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IFillFormatCollection Interface | Aspose.Slides.Theme Namespace


IFillFormatCollection Properties

The properties of the IFillFormatCollection interface are listed below. For a complete list of IFillFormatCollection interface members, see the IFillFormatCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IFillFormatCollection Interface | Aspose.Slides.Theme Namespace


AsICollection Property

Aspose.Slides Documentation

IFillFormatCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IFillFormatCollection Interface | Aspose.Slides.Theme Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IFillFormatCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IFillFormatCollection Interface | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

IFillFormatCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IFillFormat
[C#]
IFillFormat this[
int index
] {get;}

See Also

IFillFormatCollection Interface | Aspose.Slides.Theme Namespace


IFillFormatCollectionEffectiveData Interface

For a list of all members of this type, see IFillFormatCollectionEffectiveData Members.

[Visual Basic]
Public Interface IFillFormatCollectionEffectiveData
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.IFillFormatEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface IFillFormatCollectionEffectiveData : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement IFillFormatCollectionEffectiveData

Type | Description
FillFormatCollectionEffectiveData | Immutable FillFormatCollection object.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFillFormatCollectionEffectiveData Members | Aspose.Slides.Theme Namespace


IFillFormatCollectionEffectiveData Members

IFillFormatCollectionEffectiveData overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IFillFormatCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


IFillFormatCollectionEffectiveData Properties

The properties of the IFillFormatCollectionEffectiveData interface are listed below. For a complete list of IFillFormatCollectionEffectiveData interface members, see the IFillFormatCollectionEffectiveData Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

IFillFormatCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


AsICollection Property

Aspose.Slides Documentation

IFillFormatCollectionEffectiveData.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

IFillFormatCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


AsIEnumerable Property

Aspose.Slides Documentation

IFillFormatCollectionEffectiveData.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

IFillFormatCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

IFillFormatCollectionEffectiveData.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As IFillFormatEffectiveData
[C#]
IFillFormatEffectiveData this[
int index
] {get;}

See Also

IFillFormatCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


IFontScheme Interface

For a list of all members of this type, see IFontScheme Members.

[Visual Basic]
Public Interface IFontScheme
[C#]
public interface IFontScheme

Types that implement IFontScheme

Type | Description
FontScheme | Stores theme-defined fonts.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFontScheme Members | Aspose.Slides.Theme Namespace


IFontScheme Members

IFontScheme overview

Public Instance Properties

Major
Minor
Name

See Also

IFontScheme Interface | Aspose.Slides.Theme Namespace


IFontScheme Properties

The properties of the IFontScheme interface are listed below. For a complete list of IFontScheme interface members, see the IFontScheme Members topic.

Public Instance Properties

Major
Minor
Name

See Also

IFontScheme Interface | Aspose.Slides.Theme Namespace


Major Property

Aspose.Slides Documentation

IFontScheme.Major Property

[Visual Basic]
Property Major As IFonts
[C#]
IFonts Major {get;}

See Also

IFontScheme Interface | Aspose.Slides.Theme Namespace


Minor Property

Aspose.Slides Documentation

IFontScheme.Minor Property

[Visual Basic]
Property Minor As IFonts
[C#]
IFonts Minor {get;}

See Also

IFontScheme Interface | Aspose.Slides.Theme Namespace


Name Property

Aspose.Slides Documentation

IFontScheme.Name Property

[Visual Basic]
Property Name As String
[C#]
string Name {get; set;}

See Also

IFontScheme Interface | Aspose.Slides.Theme Namespace


IFontSchemeEffectiveData Interface

For a list of all members of this type, see IFontSchemeEffectiveData Members.

[Visual Basic]
Public Interface IFontSchemeEffectiveData
[C#]
public interface IFontSchemeEffectiveData

Types that implement IFontSchemeEffectiveData

Type | Description
FontSchemeEffectiveData | Immutable FontScheme object.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFontSchemeEffectiveData Members | Aspose.Slides.Theme Namespace


IFontSchemeEffectiveData Members

IFontSchemeEffectiveData overview

Public Instance Properties

Major
Minor
Name

See Also

IFontSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IFontSchemeEffectiveData Properties

The properties of the IFontSchemeEffectiveData interface are listed below. For a complete list of IFontSchemeEffectiveData interface members, see the IFontSchemeEffectiveData Members topic.

Public Instance Properties

Major
Minor
Name

See Also

IFontSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Major Property

Aspose.Slides Documentation

IFontSchemeEffectiveData.Major Property

[Visual Basic]
Property Major As IFontsEffectiveData
[C#]
IFontsEffectiveData Major {get;}

See Also

IFontSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Minor Property

Aspose.Slides Documentation

IFontSchemeEffectiveData.Minor Property

[Visual Basic]
Property Minor As IFontsEffectiveData
[C#]
IFontsEffectiveData Minor {get;}

See Also

IFontSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


Name Property

Aspose.Slides Documentation

IFontSchemeEffectiveData.Name Property

[Visual Basic]
Property Name As String
[C#]
string Name {get;}

See Also

IFontSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IFormatScheme Interface

For a list of all members of this type, see IFormatScheme Members.

[Visual Basic]
Public Interface IFormatScheme
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IFormatScheme : ISlideComponent, IPresentationComponent

Types that implement IFormatScheme

Type | Description
FormatScheme | Stores theme-defined formats for the shapes.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFormatScheme Members | Aspose.Slides.Theme Namespace


IFormatScheme Members

IFormatScheme overview

Public Instance Properties

AsISlideComponent
BackgroundFillStyles
EffectStyles
FillStyles
LineStyles

See Also

IFormatScheme Interface | Aspose.Slides.Theme Namespace


IFormatScheme Properties

The properties of the IFormatScheme interface are listed below. For a complete list of IFormatScheme interface members, see the IFormatScheme Members topic.

Public Instance Properties

AsISlideComponent
BackgroundFillStyles
EffectStyles
FillStyles
LineStyles

See Also

IFormatScheme Interface | Aspose.Slides.Theme Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IFormatScheme.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IFormatScheme Interface | Aspose.Slides.Theme Namespace


BackgroundFillStyles Property

Aspose.Slides Documentation

IFormatScheme.BackgroundFillStyles Property

[Visual Basic]
Property BackgroundFillStyles As IFillFormatCollection
[C#]
IFillFormatCollection BackgroundFillStyles {get;}

See Also

IFormatScheme Interface | Aspose.Slides.Theme Namespace


EffectStyles Property

Aspose.Slides Documentation

IFormatScheme.EffectStyles Property

[Visual Basic]
Property EffectStyles As IEffectStyleCollection
[C#]
IEffectStyleCollection EffectStyles {get;}

See Also

IFormatScheme Interface | Aspose.Slides.Theme Namespace


FillStyles Property

Aspose.Slides Documentation

IFormatScheme.FillStyles Property

[Visual Basic]
Property FillStyles As IFillFormatCollection
[C#]
IFillFormatCollection FillStyles {get;}

See Also

IFormatScheme Interface | Aspose.Slides.Theme Namespace


LineStyles Property

Aspose.Slides Documentation

IFormatScheme.LineStyles Property

[Visual Basic]
Property LineStyles As ILineFormatCollection
[C#]
ILineFormatCollection LineStyles {get;}

See Also

IFormatScheme Interface | Aspose.Slides.Theme Namespace


IFormatSchemeEffectiveData Interface

For a list of all members of this type, see IFormatSchemeEffectiveData Members.

[Visual Basic]
Public Interface IFormatSchemeEffectiveData
[C#]
public interface IFormatSchemeEffectiveData

Types that implement IFormatSchemeEffectiveData

Type | Description
FormatSchemeEffectiveData | Immutable FormatScheme object.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IFormatSchemeEffectiveData Members | Aspose.Slides.Theme Namespace


IFormatSchemeEffectiveData Members

IFormatSchemeEffectiveData overview

Public Instance Methods

GetBackgroundFillStyles
GetEffectStyles
GetFillStyles
GetLineStyles

See Also

IFormatSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IFormatSchemeEffectiveData Methods

The methods of the IFormatSchemeEffectiveData interface are listed below. For a complete list of IFormatSchemeEffectiveData interface members, see the IFormatSchemeEffectiveData Members topic.

Public Instance Methods

GetBackgroundFillStyles
GetEffectStyles
GetFillStyles
GetLineStyles

See Also

IFormatSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IFormatSchemeEffectiveData.GetBackgroundFillStyles Method

[Visual Basic]
Function GetBackgroundFillStyles( _
ByVal styleColor As Color _
) As IFillFormatCollectionEffectiveData
[C#]
IFillFormatCollectionEffectiveData GetBackgroundFillStyles(
Color styleColor
);

See Also

IFormatSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IFormatSchemeEffectiveData.GetEffectStyles Method

[Visual Basic]
Function GetEffectStyles( _
ByVal styleColor As Color _
) As IEffectStyleCollectionEffectiveData
[C#]
IEffectStyleCollectionEffectiveData GetEffectStyles(
Color styleColor
);

See Also

IFormatSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IFormatSchemeEffectiveData.GetFillStyles Method

[Visual Basic]
Function GetFillStyles( _
ByVal styleColor As Color _
) As IFillFormatCollectionEffectiveData
[C#]
IFillFormatCollectionEffectiveData GetFillStyles(
Color styleColor
);

See Also

IFormatSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IFormatSchemeEffectiveData.GetLineStyles Method

[Visual Basic]
Function GetLineStyles( _
ByVal styleColor As Color _
) As ILineFormatCollectionEffectiveData
[C#]
ILineFormatCollectionEffectiveData GetLineStyles(
Color styleColor
);

See Also

IFormatSchemeEffectiveData Interface | Aspose.Slides.Theme Namespace


ILineFormatCollection Interface

For a list of all members of this type, see ILineFormatCollection Members.

[Visual Basic]
Public Interface ILineFormatCollection
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ILineFormat, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface ILineFormatCollection : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement ILineFormatCollection

Type | Description
LineFormatCollection | Represents the collection of line styles.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILineFormatCollection Members | Aspose.Slides.Theme Namespace


ILineFormatCollection Members

ILineFormatCollection overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

ILineFormatCollection Interface | Aspose.Slides.Theme Namespace


ILineFormatCollection Properties

The properties of the ILineFormatCollection interface are listed below. For a complete list of ILineFormatCollection interface members, see the ILineFormatCollection Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

ILineFormatCollection Interface | Aspose.Slides.Theme Namespace


AsICollection Property

Aspose.Slides Documentation

ILineFormatCollection.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

ILineFormatCollection Interface | Aspose.Slides.Theme Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ILineFormatCollection.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ILineFormatCollection Interface | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

ILineFormatCollection.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As ILineFormat
[C#]
ILineFormat this[
int index
] {get;}

See Also

ILineFormatCollection Interface | Aspose.Slides.Theme Namespace


ILineFormatCollectionEffectiveData Interface

For a list of all members of this type, see ILineFormatCollectionEffectiveData Members.

[Visual Basic]
Public Interface ILineFormatCollectionEffectiveData
Implements ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ILineFormatEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public interface ILineFormatCollectionEffectiveData : ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Types that implement ILineFormatCollectionEffectiveData

Type | Description
LineFormatCollectionEffectiveData | Immutable LineFormatCollection object.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ILineFormatCollectionEffectiveData Members | Aspose.Slides.Theme Namespace


ILineFormatCollectionEffectiveData Members

ILineFormatCollectionEffectiveData overview

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

ILineFormatCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


ILineFormatCollectionEffectiveData Properties

The properties of the ILineFormatCollectionEffectiveData interface are listed below. For a complete list of ILineFormatCollectionEffectiveData interface members, see the ILineFormatCollectionEffectiveData Members topic.

Public Instance Properties

AsICollection
AsIEnumerable
Item

See Also

ILineFormatCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


AsICollection Property

Aspose.Slides Documentation

ILineFormatCollectionEffectiveData.AsICollection Property

[Visual Basic]
Property AsICollection As ICollection
[C#]
ICollection AsICollection {get;}

See Also

ILineFormatCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


AsIEnumerable Property

Aspose.Slides Documentation

ILineFormatCollectionEffectiveData.AsIEnumerable Property

[Visual Basic]
Property AsIEnumerable As IEnumerable
[C#]
IEnumerable AsIEnumerable {get;}

See Also

ILineFormatCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

ILineFormatCollectionEffectiveData.Item Property

[Visual Basic]
Property Item( _
ByVal index As Integer _
) As ILineFormatEffectiveData
[C#]
ILineFormatEffectiveData this[
int index
] {get;}

See Also

ILineFormatCollectionEffectiveData Interface | Aspose.Slides.Theme Namespace


IMasterTheme Interface

For a list of all members of this type, see IMasterTheme Members.

[Visual Basic]
Public Interface IMasterTheme
Implements ITheme, IPresentationComponent
[C#]
public interface IMasterTheme : ITheme, IPresentationComponent

Types that implement IMasterTheme

Type | Description
MasterTheme | Represents a master theme.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMasterTheme Members | Aspose.Slides.Theme Namespace


IMasterTheme Members

IMasterTheme overview

Public Instance Properties

AsITheme
ExtraColorSchemes
Name

See Also

IMasterTheme Interface | Aspose.Slides.Theme Namespace


IMasterTheme Properties

The properties of the IMasterTheme interface are listed below. For a complete list of IMasterTheme interface members, see the IMasterTheme Members topic.

Public Instance Properties

AsITheme
ExtraColorSchemes
Name

See Also

IMasterTheme Interface | Aspose.Slides.Theme Namespace


AsITheme Property

Aspose.Slides Documentation

IMasterTheme.AsITheme Property

[Visual Basic]
Property AsITheme As ITheme
[C#]
ITheme AsITheme {get;}

See Also

IMasterTheme Interface | Aspose.Slides.Theme Namespace


ExtraColorSchemes Property

Aspose.Slides Documentation

IMasterTheme.ExtraColorSchemes Property

[Visual Basic]
Property ExtraColorSchemes As IExtraColorSchemeCollection
[C#]
IExtraColorSchemeCollection ExtraColorSchemes {get;}

See Also

IMasterTheme Interface | Aspose.Slides.Theme Namespace


Name Property

Aspose.Slides Documentation

IMasterTheme.Name Property

[Visual Basic]
Property Name As String
[C#]
string Name {get; set;}

See Also

IMasterTheme Interface | Aspose.Slides.Theme Namespace


IMasterThemeable Interface

For a list of all members of this type, see IMasterThemeable Members.

Aspose.Slides.Theme.IMasterThemeable
Aspose.Slides.IMasterHandoutSlide
Aspose.Slides.IMasterNotesSlide
Aspose.Slides.IMasterSlide

[Visual Basic]
Public Interface IMasterThemeable
Implements IThemeable, ISlideComponent, IPresentationComponent
[C#]
public interface IMasterThemeable : IThemeable, ISlideComponent, IPresentationComponent

Types that implement IMasterThemeable

Type | Description
MasterHandoutSlide | Represents master slide for handouts.
MasterNotesSlide | Represents master slide for notes.
MasterSlide | Represents a master slide in a presentation.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMasterThemeable Members | Aspose.Slides.Theme Namespace


IMasterThemeable Members

IMasterThemeable overview

Public Instance Properties

AsIThemeable
ThemeManager

See Also

IMasterThemeable Interface | Aspose.Slides.Theme Namespace


IMasterThemeable Properties

The properties of the IMasterThemeable interface are listed below. For a complete list of IMasterThemeable interface members, see the IMasterThemeable Members topic.

Public Instance Properties

AsIThemeable
ThemeManager

See Also

IMasterThemeable Interface | Aspose.Slides.Theme Namespace


AsIThemeable Property

Aspose.Slides Documentation

IMasterThemeable.AsIThemeable Property

[Visual Basic]
Property AsIThemeable As IThemeable
[C#]
IThemeable AsIThemeable {get;}

See Also

IMasterThemeable Interface | Aspose.Slides.Theme Namespace


ThemeManager Property

Aspose.Slides Documentation

IMasterThemeable.ThemeManager Property

[Visual Basic]
Property ThemeManager As IMasterThemeManager
[C#]
IMasterThemeManager ThemeManager {get;}

See Also

IMasterThemeable Interface | Aspose.Slides.Theme Namespace


IMasterThemeManager Interface

For a list of all members of this type, see IMasterThemeManager Members.

[Visual Basic]
Public Interface IMasterThemeManager
Implements IThemeManager
[C#]
public interface IMasterThemeManager : IThemeManager

Types that implement IMasterThemeManager

Type | Description
MasterThemeManager |

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IMasterThemeManager Members | Aspose.Slides.Theme Namespace


IMasterThemeManager Members

IMasterThemeManager overview

Public Instance Properties

AsIThemeManager
IsOverrideThemeEnabled
OverrideTheme

See Also

IMasterThemeManager Interface | Aspose.Slides.Theme Namespace


IMasterThemeManager Properties

The properties of the IMasterThemeManager interface are listed below. For a complete list of IMasterThemeManager interface members, see the IMasterThemeManager Members topic.

Public Instance Properties

AsIThemeManager
IsOverrideThemeEnabled
OverrideTheme

See Also

IMasterThemeManager Interface | Aspose.Slides.Theme Namespace


AsIThemeManager Property

Aspose.Slides Documentation

IMasterThemeManager.AsIThemeManager Property

[Visual Basic]
Property AsIThemeManager As IThemeManager
[C#]
IThemeManager AsIThemeManager {get;}

See Also

IMasterThemeManager Interface | Aspose.Slides.Theme Namespace


IsOverrideThemeEnabled Property

Aspose.Slides Documentation

IMasterThemeManager.IsOverrideThemeEnabled Property

[Visual Basic]
Property IsOverrideThemeEnabled As Boolean
[C#]
bool IsOverrideThemeEnabled {get; set;}

See Also

IMasterThemeManager Interface | Aspose.Slides.Theme Namespace


OverrideTheme Property

Aspose.Slides Documentation

IMasterThemeManager.OverrideTheme Property

[Visual Basic]
Property OverrideTheme As IMasterTheme
[C#]
IMasterTheme OverrideTheme {get; set;}

See Also

IMasterThemeManager Interface | Aspose.Slides.Theme Namespace


IOverrideTheme Interface

For a list of all members of this type, see IOverrideTheme Members.

[Visual Basic]
Public Interface IOverrideTheme
Implements ITheme, IPresentationComponent
[C#]
public interface IOverrideTheme : ITheme, IPresentationComponent

Types that implement IOverrideTheme

Type | Description
OverrideTheme | Represents a overriding theme.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IOverrideTheme Members | Aspose.Slides.Theme Namespace


IOverrideTheme Members

IOverrideTheme overview

Public Instance Properties

AsITheme
IsEmpty

Public Instance Methods

Clear
InitColorScheme
InitColorSchemeFrom
InitColorSchemeFromInherited
InitFontScheme
InitFontSchemeFrom
InitFontSchemeFromInherited
InitFormatScheme
InitFormatSchemeFrom
InitFormatSchemeFromInherited

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideTheme Properties

The properties of the IOverrideTheme interface are listed below. For a complete list of IOverrideTheme interface members, see the IOverrideTheme Members topic.

Public Instance Properties

AsITheme
IsEmpty

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


AsITheme Property

Aspose.Slides Documentation

IOverrideTheme.AsITheme Property

[Visual Basic]
Property AsITheme As ITheme
[C#]
ITheme AsITheme {get;}

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IsEmpty Property

Aspose.Slides Documentation

IOverrideTheme.IsEmpty Property

[Visual Basic]
Property IsEmpty As Boolean
[C#]
bool IsEmpty {get;}

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideTheme Methods

The methods of the IOverrideTheme interface are listed below. For a complete list of IOverrideTheme interface members, see the IOverrideTheme Members topic.

Public Instance Methods

Clear
InitColorScheme
InitColorSchemeFrom
InitColorSchemeFromInherited
InitFontScheme
InitFontSchemeFrom
InitFontSchemeFromInherited
InitFormatScheme
InitFormatSchemeFrom
InitFormatSchemeFromInherited

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideTheme.Clear Method

[Visual Basic]
Sub Clear()
[C#]
void Clear();

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideTheme.InitColorScheme Method

[Visual Basic]
Sub InitColorScheme()
[C#]
void InitColorScheme();

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideTheme.InitColorSchemeFrom Method

[Visual Basic]
Sub InitColorSchemeFrom( _
ByVal colorScheme As IColorScheme _
)
[C#]
void InitColorSchemeFrom(
IColorScheme colorScheme
);

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideTheme.InitColorSchemeFromInherited Method

[Visual Basic]
Sub InitColorSchemeFromInherited()
[C#]
void InitColorSchemeFromInherited();

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideTheme.InitFontScheme Method

[Visual Basic]
Sub InitFontScheme()
[C#]
void InitFontScheme();

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideTheme.InitFontSchemeFrom Method

[Visual Basic]
Sub InitFontSchemeFrom( _
ByVal fontScheme As IFontScheme _
)
[C#]
void InitFontSchemeFrom(
IFontScheme fontScheme
);

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideTheme.InitFontSchemeFromInherited Method

[Visual Basic]
Sub InitFontSchemeFromInherited()
[C#]
void InitFontSchemeFromInherited();

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideTheme.InitFormatScheme Method

[Visual Basic]
Sub InitFormatScheme()
[C#]
void InitFormatScheme();

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideTheme.InitFormatSchemeFrom Method

[Visual Basic]
Sub InitFormatSchemeFrom( _
ByVal formatScheme As IFormatScheme _
)
[C#]
void InitFormatSchemeFrom(
IFormatScheme formatScheme
);

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideTheme.InitFormatSchemeFromInherited Method

[Visual Basic]
Sub InitFormatSchemeFromInherited()
[C#]
void InitFormatSchemeFromInherited();

See Also

IOverrideTheme Interface | Aspose.Slides.Theme Namespace


IOverrideThemeable Interface

For a list of all members of this type, see IOverrideThemeable Members.

Aspose.Slides.Theme.IOverrideThemeable
Aspose.Slides.Charts.IChart
Aspose.Slides.ILayoutSlide
Aspose.Slides.INotesSlide
Aspose.Slides.ISlide

[Visual Basic]
Public Interface IOverrideThemeable
Implements IThemeable, ISlideComponent, IPresentationComponent
[C#]
public interface IOverrideThemeable : IThemeable, ISlideComponent, IPresentationComponent

Types that implement IOverrideThemeable

Type | Description
Chart | Represents an graphic chart on a slide.
LayoutSlide | Represents a layout slide.
NotesSlide | Represents a notes slide in a presentation.
Slide | Represents a slide in a presentation.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IOverrideThemeable Members | Aspose.Slides.Theme Namespace


IOverrideThemeable Members

IOverrideThemeable overview

Public Instance Properties

AsIThemeable
ThemeManager

See Also

IOverrideThemeable Interface | Aspose.Slides.Theme Namespace


IOverrideThemeable Properties

The properties of the IOverrideThemeable interface are listed below. For a complete list of IOverrideThemeable interface members, see the IOverrideThemeable Members topic.

Public Instance Properties

AsIThemeable
ThemeManager

See Also

IOverrideThemeable Interface | Aspose.Slides.Theme Namespace


AsIThemeable Property

Aspose.Slides Documentation

IOverrideThemeable.AsIThemeable Property

[Visual Basic]
Property AsIThemeable As IThemeable
[C#]
IThemeable AsIThemeable {get;}

See Also

IOverrideThemeable Interface | Aspose.Slides.Theme Namespace


ThemeManager Property

Aspose.Slides Documentation

IOverrideThemeable.ThemeManager Property

[Visual Basic]
Property ThemeManager As IOverrideThemeManager
[C#]
IOverrideThemeManager ThemeManager {get;}

See Also

IOverrideThemeable Interface | Aspose.Slides.Theme Namespace


IOverrideThemeManager Interface

For a list of all members of this type, see IOverrideThemeManager Members.

[Visual Basic]
Public Interface IOverrideThemeManager
Implements IThemeManager
[C#]
public interface IOverrideThemeManager : IThemeManager

Types that implement IOverrideThemeManager

Type | Description
BaseOverrideThemeManager |
ChartThemeManager |
LayoutSlideThemeManager |
NotesSlideThemeManager |
SlideThemeManager |

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IOverrideThemeManager Members | Aspose.Slides.Theme Namespace


IOverrideThemeManager Members

IOverrideThemeManager overview

Public Instance Properties

AsIThemeManager
IsOverrideThemeEnabled
OverrideTheme

See Also

IOverrideThemeManager Interface | Aspose.Slides.Theme Namespace


IOverrideThemeManager Properties

The properties of the IOverrideThemeManager interface are listed below. For a complete list of IOverrideThemeManager interface members, see the IOverrideThemeManager Members topic.

Public Instance Properties

AsIThemeManager
IsOverrideThemeEnabled
OverrideTheme

See Also

IOverrideThemeManager Interface | Aspose.Slides.Theme Namespace


AsIThemeManager Property

Aspose.Slides Documentation

IOverrideThemeManager.AsIThemeManager Property

[Visual Basic]
Property AsIThemeManager As IThemeManager
[C#]
IThemeManager AsIThemeManager {get;}

See Also

IOverrideThemeManager Interface | Aspose.Slides.Theme Namespace


IsOverrideThemeEnabled Property

Aspose.Slides Documentation

IOverrideThemeManager.IsOverrideThemeEnabled Property

[Visual Basic]
Property IsOverrideThemeEnabled As Boolean
[C#]
bool IsOverrideThemeEnabled {get;}

See Also

IOverrideThemeManager Interface | Aspose.Slides.Theme Namespace


OverrideTheme Property

Aspose.Slides Documentation

IOverrideThemeManager.OverrideTheme Property

[Visual Basic]
Property OverrideTheme As IOverrideTheme
[C#]
IOverrideTheme OverrideTheme {get; set;}

See Also

IOverrideThemeManager Interface | Aspose.Slides.Theme Namespace


ITheme Interface

For a list of all members of this type, see ITheme Members.

Aspose.Slides.Theme.ITheme
Aspose.Slides.Theme.IMasterTheme
Aspose.Slides.Theme.IOverrideTheme

[Visual Basic]
Public Interface ITheme
Implements IPresentationComponent
[C#]
public interface ITheme : IPresentationComponent

Types that implement ITheme

Type | Description
MasterTheme | Represents a master theme.
OverrideTheme | Represents a overriding theme.
Theme | Represents a theme.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ITheme Members | Aspose.Slides.Theme Namespace


ITheme Members

ITheme overview

Public Instance Properties

AsIPresentationComponent
ColorScheme
FontScheme
FormatScheme

See Also

ITheme Interface | Aspose.Slides.Theme Namespace


ITheme Properties

The properties of the ITheme interface are listed below. For a complete list of ITheme interface members, see the ITheme Members topic.

Public Instance Properties

AsIPresentationComponent
ColorScheme
FontScheme
FormatScheme

See Also

ITheme Interface | Aspose.Slides.Theme Namespace


AsIPresentationComponent Property

Aspose.Slides Documentation

ITheme.AsIPresentationComponent Property

[Visual Basic]
Property AsIPresentationComponent As IPresentationComponent
[C#]
IPresentationComponent AsIPresentationComponent {get;}

See Also

ITheme Interface | Aspose.Slides.Theme Namespace


ColorScheme Property

Aspose.Slides Documentation

ITheme.ColorScheme Property

[Visual Basic]
Property ColorScheme As IColorScheme
[C#]
IColorScheme ColorScheme {get;}

See Also

ITheme Interface | Aspose.Slides.Theme Namespace


FontScheme Property

Aspose.Slides Documentation

ITheme.FontScheme Property

[Visual Basic]
Property FontScheme As IFontScheme
[C#]
IFontScheme FontScheme {get;}

See Also

ITheme Interface | Aspose.Slides.Theme Namespace


FormatScheme Property

Aspose.Slides Documentation

ITheme.FormatScheme Property

[Visual Basic]
Property FormatScheme As IFormatScheme
[C#]
IFormatScheme FormatScheme {get;}

See Also

ITheme Interface | Aspose.Slides.Theme Namespace


IThemeable Interface

For a list of all members of this type, see IThemeable Members.

Aspose.Slides.Theme.IThemeable
Derived interfaces

[Visual Basic]
Public Interface IThemeable
Implements ISlideComponent, IPresentationComponent
[C#]
public interface IThemeable : ISlideComponent, IPresentationComponent

Types that implement IThemeable

Type | Description
BaseSlide | Represents common data for all slide types.
Chart | Represents an graphic chart on a slide.
LayoutSlide | Represents a layout slide.
MasterHandoutSlide | Represents master slide for handouts.
MasterNotesSlide | Represents master slide for notes.
MasterSlide | Represents a master slide in a presentation.
NotesSlide | Represents a notes slide in a presentation.
Slide | Represents a slide in a presentation.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IThemeable Members | Aspose.Slides.Theme Namespace


IThemeable Members

IThemeable overview

Public Instance Properties

AsISlideComponent

Public Instance Methods

CreateThemeEffective

See Also

IThemeable Interface | Aspose.Slides.Theme Namespace


IThemeable Properties

The properties of the IThemeable interface are listed below. For a complete list of IThemeable interface members, see the IThemeable Members topic.

Public Instance Properties

AsISlideComponent

See Also

IThemeable Interface | Aspose.Slides.Theme Namespace


AsISlideComponent Property

Aspose.Slides Documentation

IThemeable.AsISlideComponent Property

[Visual Basic]
Property AsISlideComponent As ISlideComponent
[C#]
ISlideComponent AsISlideComponent {get;}

See Also

IThemeable Interface | Aspose.Slides.Theme Namespace


IThemeable Methods

The methods of the IThemeable interface are listed below. For a complete list of IThemeable interface members, see the IThemeable Members topic.

Public Instance Methods

CreateThemeEffective

See Also

IThemeable Interface | Aspose.Slides.Theme Namespace


IThemeable.CreateThemeEffective Method

[Visual Basic]
Function CreateThemeEffective() As IThemeEffectiveData
[C#]
IThemeEffectiveData CreateThemeEffective();

See Also

IThemeable Interface | Aspose.Slides.Theme Namespace


IThemeEffectiveData Interface

For a list of all members of this type, see IThemeEffectiveData Members.

[Visual Basic]
Public Interface IThemeEffectiveData
[C#]
public interface IThemeEffectiveData

Types that implement IThemeEffectiveData

Type | Description
ThemeEffectiveData | Immutable Theme object.

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IThemeEffectiveData Members | Aspose.Slides.Theme Namespace


IThemeEffectiveData Members

IThemeEffectiveData overview

Public Instance Properties

FontScheme
FormatScheme

Public Instance Methods

GetColorScheme

See Also

IThemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IThemeEffectiveData Properties

The properties of the IThemeEffectiveData interface are listed below. For a complete list of IThemeEffectiveData interface members, see the IThemeEffectiveData Members topic.

Public Instance Properties

FontScheme
FormatScheme

See Also

IThemeEffectiveData Interface | Aspose.Slides.Theme Namespace


FontScheme Property

Aspose.Slides Documentation

IThemeEffectiveData.FontScheme Property

[Visual Basic]
Property FontScheme As IFontSchemeEffectiveData
[C#]
IFontSchemeEffectiveData FontScheme {get;}

See Also

IThemeEffectiveData Interface | Aspose.Slides.Theme Namespace


FormatScheme Property

Aspose.Slides Documentation

IThemeEffectiveData.FormatScheme Property

[Visual Basic]
Property FormatScheme As IFormatSchemeEffectiveData
[C#]
IFormatSchemeEffectiveData FormatScheme {get;}

See Also

IThemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IThemeEffectiveData Methods

The methods of the IThemeEffectiveData interface are listed below. For a complete list of IThemeEffectiveData interface members, see the IThemeEffectiveData Members topic.

Public Instance Methods

GetColorScheme

See Also

IThemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IThemeEffectiveData.GetColorScheme Method

[Visual Basic]
Function GetColorScheme( _
ByVal styleColor As Color _
) As IColorSchemeEffectiveData
[C#]
IColorSchemeEffectiveData GetColorScheme(
Color styleColor
);

See Also

IThemeEffectiveData Interface | Aspose.Slides.Theme Namespace


IThemeManager Interface

For a list of all members of this type, see IThemeManager Members.

Aspose.Slides.Theme.IThemeManager
Aspose.Slides.Theme.IMasterThemeManager
Aspose.Slides.Theme.IOverrideThemeManager

[Visual Basic]
Public Interface IThemeManager
[C#]
public interface IThemeManager

Types that implement IThemeManager

Type | Description
BaseOverrideThemeManager |
ChartThemeManager |
LayoutSlideThemeManager |
MasterThemeManager |
NotesSlideThemeManager |
SlideThemeManager |

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IThemeManager Members | Aspose.Slides.Theme Namespace


IThemeManager Members

IThemeManager overview

Public Instance Methods

ApplyColorScheme
CreateThemeEffective

See Also

IThemeManager Interface | Aspose.Slides.Theme Namespace


IThemeManager Methods

The methods of the IThemeManager interface are listed below. For a complete list of IThemeManager interface members, see the IThemeManager Members topic.

Public Instance Methods

ApplyColorScheme
CreateThemeEffective

See Also

IThemeManager Interface | Aspose.Slides.Theme Namespace


IThemeManager.ApplyColorScheme Method

[Visual Basic]
Sub ApplyColorScheme( _
ByVal scheme As IExtraColorScheme _
)
[C#]
void ApplyColorScheme(
IExtraColorScheme scheme
);

See Also

IThemeManager Interface | Aspose.Slides.Theme Namespace


IThemeManager.CreateThemeEffective Method

[Visual Basic]
Function CreateThemeEffective() As IThemeEffectiveData
[C#]
IThemeEffectiveData CreateThemeEffective();

See Also

IThemeManager Interface | Aspose.Slides.Theme Namespace


LayoutSlideThemeManager Class

For a list of all members of this type, see LayoutSlideThemeManager Members.

System.Object
Aspose.Slides.Theme.BaseThemeManager
Aspose.Slides.Theme.BaseOverrideThemeManager
Aspose.Slides.Theme.LayoutSlideThemeManager

[Visual Basic]
Public Class LayoutSlideThemeManager
Inherits BaseOverrideThemeManager
[C#]
public class LayoutSlideThemeManager : BaseOverrideThemeManager

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LayoutSlideThemeManager Members | Aspose.Slides.Theme Namespace


LayoutSlideThemeManager Members

LayoutSlideThemeManager overview

Public Instance Properties

IsOverrideThemeEnabled (inherited from BaseOverrideThemeManager) | Determines whether OverrideTheme overrides inherited effective theme or not. To enable OverrideTheme for overriding use OverrideTheme.Init*() methods. To disable OverrideTheme from overriding use OverrideTheme.Clear() method.
OverrideTheme (inherited from BaseOverrideThemeManager) | Returns the overriding theme object.

Public Instance Methods

ApplyColorScheme (inherited from BaseOverrideThemeManager) | Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseOverrideThemeManager) | Returns the theme object.

See Also

LayoutSlideThemeManager Class | Aspose.Slides.Theme Namespace


LineFormatCollection Class

Represents the collection of line styles.

For a list of all members of this type, see LineFormatCollection Members.

System.Object
Aspose.Slides.Theme.LineFormatCollection

[Visual Basic]
NotInheritable Public Class LineFormatCollection
Implements ILineFormatCollection, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ILineFormat, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public sealed class LineFormatCollection : ILineFormatCollection, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LineFormatCollection Members | Aspose.Slides.Theme Namespace


LineFormatCollection Members

LineFormatCollection overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only LineFormat.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

LineFormatCollection Class | Aspose.Slides.Theme Namespace


LineFormatCollection Properties

The properties of the LineFormatCollection class are listed below. For a complete list of LineFormatCollection class members, see the LineFormatCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only LineFormat.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

LineFormatCollection Class | Aspose.Slides.Theme Namespace


Count Property

Aspose.Slides Documentation

LineFormatCollection.Count Property

Gets the number of elements actually contained in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

LineFormatCollection Class | Aspose.Slides.Theme Namespace


IsSynchronized Property

Aspose.Slides Documentation

LineFormatCollection.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

LineFormatCollection Class | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

LineFormatCollection.Item Property

Gets the element at the specified index. Read-only LineFormat.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ILineFormatCollection.Item
As ILineFormat _
Implements ILineFormatCollection.Item
[C#]
public ILineFormat this[
int index
] {get;}

Implements

ILineFormatCollection.Item

See Also

LineFormatCollection Class | Aspose.Slides.Theme Namespace


SyncRoot Property

Aspose.Slides Documentation

LineFormatCollection.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

LineFormatCollection Class | Aspose.Slides.Theme Namespace


LineFormatCollection Methods

The methods of the LineFormatCollection class are listed below. For a complete list of LineFormatCollection class members, see the LineFormatCollection Members topic.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

LineFormatCollection Class | Aspose.Slides.Theme Namespace


LineFormatCollection.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

LineFormatCollection Class | Aspose.Slides.Theme Namespace


LineFormatCollection.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

LineFormatCollection Class | Aspose.Slides.Theme Namespace


LineFormatCollectionEffectiveData Class

Immutable LineFormatCollection object.

For a list of all members of this type, see LineFormatCollectionEffectiveData Members.

System.Object
Aspose.Slides.Theme.LineFormatCollectionEffectiveData

[Visual Basic]
Public Class LineFormatCollectionEffectiveData
Implements ILineFormatCollectionEffectiveData, ICollection, IEnumerable, IEnumerable`1([Aspose.Slides.ILineFormatEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56))
[C#]
public class LineFormatCollectionEffectiveData : ILineFormatCollectionEffectiveData, ICollection, IEnumerable, 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]]

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

LineFormatCollectionEffectiveData Members | Aspose.Slides.Theme Namespace


LineFormatCollectionEffectiveData Members

LineFormatCollectionEffectiveData overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only IFillFormatEffectiveData.
SyncRoot | Returns a synchronization root. Readonly Object.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

LineFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


LineFormatCollectionEffectiveData Properties

The properties of the LineFormatCollectionEffectiveData class are listed below. For a complete list of LineFormatCollectionEffectiveData class members, see the LineFormatCollectionEffectiveData Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
IsSynchronized | Returns a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets the element at the specified index. Read-only IFillFormatEffectiveData.
SyncRoot | Returns a synchronization root. Readonly Object.

See Also

LineFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


Count Property

Aspose.Slides Documentation

LineFormatCollectionEffectiveData.Count Property

Gets the number of elements actually contained in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

LineFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


IsSynchronized Property

Aspose.Slides Documentation

LineFormatCollectionEffectiveData.IsSynchronized Property

Returns a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

LineFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


Item Property

Aspose.Slides Documentation

LineFormatCollectionEffectiveData.Item Property

Gets the element at the specified index. Read-only IFillFormatEffectiveData.

[Visual Basic]
NotOverridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) _
Implements ILineFormatCollectionEffectiveData.Item
As ILineFormatEffectiveData _
Implements ILineFormatCollectionEffectiveData.Item
[C#]
public ILineFormatEffectiveData this[
int index
] {get;}

Implements

ILineFormatCollectionEffectiveData.Item

See Also

LineFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


SyncRoot Property

Aspose.Slides Documentation

LineFormatCollectionEffectiveData.SyncRoot Property

Returns a synchronization root. Readonly Object.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

LineFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


LineFormatCollectionEffectiveData Methods

The methods of the LineFormatCollectionEffectiveData class are listed below. For a complete list of LineFormatCollectionEffectiveData class members, see the LineFormatCollectionEffectiveData Members topic.

Public Instance Methods

CopyTo | Copies all elements from the collection to the specified array.
GetEnumerator | Returns an enumerator for the entire collection.

See Also

LineFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


LineFormatCollectionEffectiveData.CopyTo Method

Copies all elements from the collection to the specified array.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
Target array.
index
Starting index in the target array.

Implements

ICollection.CopyTo

See Also

LineFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


LineFormatCollectionEffectiveData.GetEnumerator Method

Returns an enumerator for the entire collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable.GetEnumerator

See Also

LineFormatCollectionEffectiveData Class | Aspose.Slides.Theme Namespace


MasterTheme Class

Represents a master theme.

For a list of all members of this type, see MasterTheme Members.

System.Object
Aspose.Slides.Theme.Theme
Aspose.Slides.Theme.MasterTheme

[Visual Basic]
Public Class MasterTheme
Inherits Theme
Implements IMasterTheme
[C#]
public class MasterTheme : Theme, IMasterTheme

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

MasterTheme Members | Aspose.Slides.Theme Namespace


MasterTheme Members

MasterTheme overview

Public Instance Properties

ColorScheme | Returns the color scheme. Read-only ColorScheme.
ExtraColorSchemes | Returns the collection of additional color schemes. These schemes don't affect presentation's look, they can be selected as main color scheme for a slide. Read-only ExtraColorSchemeCollection.
FontScheme | Returns the font scheme. Read-only FontScheme.
FormatScheme | Returns the shape format scheme. Read-only FormatScheme.
Name | Returns the name of a theme. Read/write String.
Presentation (inherited from Theme) | Returns the parent presentation. Read-only Presentation.

See Also

MasterTheme Class | Aspose.Slides.Theme Namespace


MasterTheme Properties

The properties of the MasterTheme class are listed below. For a complete list of MasterTheme class members, see the MasterTheme Members topic.

Public Instance Properties

ColorScheme | Returns the color scheme. Read-only ColorScheme.
ExtraColorSchemes | Returns the collection of additional color schemes. These schemes don't affect presentation's look, they can be selected as main color scheme for a slide. Read-only ExtraColorSchemeCollection.
FontScheme | Returns the font scheme. Read-only FontScheme.
FormatScheme | Returns the shape format scheme. Read-only FormatScheme.
Name | Returns the name of a theme. Read/write String.
Presentation (inherited from Theme) | Returns the parent presentation. Read-only Presentation.

See Also

MasterTheme Class | Aspose.Slides.Theme Namespace


ColorScheme Property

Aspose.Slides Documentation

MasterTheme.ColorScheme Property

Returns the color scheme. Read-only ColorScheme.

[Visual Basic]
Overrides Public ReadOnly Property ColorScheme As IColorScheme _
Implements ITheme.ColorScheme
[C#]
public override IColorScheme ColorScheme {get;}

Implements

ITheme.ColorScheme

See Also

MasterTheme Class | Aspose.Slides.Theme Namespace


ExtraColorSchemes Property

Aspose.Slides Documentation

MasterTheme.ExtraColorSchemes Property

Returns the collection of additional color schemes. These schemes don't affect presentation's look, they can be selected as main color scheme for a slide. Read-only ExtraColorSchemeCollection.

[Visual Basic]
NotOverridable Public ReadOnly Property ExtraColorSchemes As IExtraColorSchemeCollection _
Implements IMasterTheme.ExtraColorSchemes
[C#]
public IExtraColorSchemeCollection ExtraColorSchemes {get;}

Implements

IMasterTheme.ExtraColorSchemes

See Also

MasterTheme Class | Aspose.Slides.Theme Namespace


FontScheme Property

Aspose.Slides Documentation

MasterTheme.FontScheme Property

Returns the font scheme. Read-only FontScheme.

[Visual Basic]
Overrides Public ReadOnly Property FontScheme As IFontScheme _
Implements ITheme.FontScheme
[C#]
public override IFontScheme FontScheme {get;}

Implements

ITheme.FontScheme

See Also

MasterTheme Class | Aspose.Slides.Theme Namespace


FormatScheme Property

Aspose.Slides Documentation

MasterTheme.FormatScheme Property

Returns the shape format scheme. Read-only FormatScheme.

[Visual Basic]
Overrides Public ReadOnly Property FormatScheme As IFormatScheme _
Implements ITheme.FormatScheme
[C#]
public override IFormatScheme FormatScheme {get;}

Implements

ITheme.FormatScheme

See Also

MasterTheme Class | Aspose.Slides.Theme Namespace


Name Property

Aspose.Slides Documentation

MasterTheme.Name Property

Returns the name of a theme. Read/write String.

[Visual Basic]
NotOverridable Public Property Name As String _
Implements IMasterTheme.Name
[C#]
public string Name {get; set;}

Implements

IMasterTheme.Name

See Also

MasterTheme Class | Aspose.Slides.Theme Namespace


MasterThemeManager Class

For a list of all members of this type, see MasterThemeManager Members.

System.Object
Aspose.Slides.Theme.BaseThemeManager
Aspose.Slides.Theme.MasterThemeManager

[Visual Basic]
Public Class MasterThemeManager
Inherits BaseThemeManager
Implements IMasterThemeManager, IThemeManager
[C#]
public class MasterThemeManager : BaseThemeManager, IMasterThemeManager, IThemeManager

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

MasterThemeManager Members | Aspose.Slides.Theme Namespace


MasterThemeManager Members

MasterThemeManager overview

Public Instance Properties

IsOverrideThemeEnabled | Determines whether OverrideTheme overrides inherited effective theme (Presentation.MasterTheme) or not.
OverrideTheme | Returns the overriding theme object.

Public Instance Methods

ApplyColorScheme | Applies extra color scheme to a slide.
CreateThemeEffective | Returns the theme object.

See Also

MasterThemeManager Class | Aspose.Slides.Theme Namespace


MasterThemeManager Properties

The properties of the MasterThemeManager class are listed below. For a complete list of MasterThemeManager class members, see the MasterThemeManager Members topic.

Public Instance Properties

IsOverrideThemeEnabled | Determines whether OverrideTheme overrides inherited effective theme (Presentation.MasterTheme) or not.
OverrideTheme | Returns the overriding theme object.

See Also

MasterThemeManager Class | Aspose.Slides.Theme Namespace


IsOverrideThemeEnabled Property

Aspose.Slides Documentation

MasterThemeManager.IsOverrideThemeEnabled Property

Determines whether OverrideTheme overrides inherited effective theme (Presentation.MasterTheme) or not.

[Visual Basic]
NotOverridable Public Property IsOverrideThemeEnabled As Boolean _
Implements IMasterThemeManager.IsOverrideThemeEnabled
[C#]
public bool IsOverrideThemeEnabled {get; set;}

Implements

IMasterThemeManager.IsOverrideThemeEnabled

See Also

MasterThemeManager Class | Aspose.Slides.Theme Namespace


OverrideTheme Property

Aspose.Slides Documentation

MasterThemeManager.OverrideTheme Property

Returns the overriding theme object.

[Visual Basic]
NotOverridable Public Property OverrideTheme As IMasterTheme _
Implements IMasterThemeManager.OverrideTheme
[C#]
public IMasterTheme OverrideTheme {get; set;}

Implements

IMasterThemeManager.OverrideTheme

See Also

MasterThemeManager Class | Aspose.Slides.Theme Namespace


MasterThemeManager Methods

The methods of the MasterThemeManager class are listed below. For a complete list of MasterThemeManager class members, see the MasterThemeManager Members topic.

Public Instance Methods

ApplyColorScheme | Applies extra color scheme to a slide.
CreateThemeEffective | Returns the theme object.

See Also

MasterThemeManager Class | Aspose.Slides.Theme Namespace


MasterThemeManager.ApplyColorScheme Method

Applies extra color scheme to a slide.

[Visual Basic]
NotOverridable Public Sub ApplyColorScheme( _
ByVal scheme As IExtraColorScheme _
) _
Implements IThemeManager.ApplyColorScheme
[C#]
public void ApplyColorScheme(
IExtraColorScheme scheme
);

Parameters

scheme

Implements

IThemeManager.ApplyColorScheme

See Also

MasterThemeManager Class | Aspose.Slides.Theme Namespace


MasterThemeManager.CreateThemeEffective Method

Returns the theme object.

[Visual Basic]
NotOverridable Public Function CreateThemeEffective() As IThemeEffectiveData _
Implements IThemeManager.CreateThemeEffective
[C#]
public IThemeEffectiveData CreateThemeEffective();

Implements

IThemeManager.CreateThemeEffective

See Also

MasterThemeManager Class | Aspose.Slides.Theme Namespace


NotesSlideThemeManager Class

For a list of all members of this type, see NotesSlideThemeManager Members.

System.Object
Aspose.Slides.Theme.BaseThemeManager
Aspose.Slides.Theme.BaseOverrideThemeManager
Aspose.Slides.Theme.NotesSlideThemeManager

[Visual Basic]
Public Class NotesSlideThemeManager
Inherits BaseOverrideThemeManager
[C#]
public class NotesSlideThemeManager : BaseOverrideThemeManager

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

NotesSlideThemeManager Members | Aspose.Slides.Theme Namespace


NotesSlideThemeManager Members

NotesSlideThemeManager overview

Public Instance Properties

IsOverrideThemeEnabled (inherited from BaseOverrideThemeManager) | Determines whether OverrideTheme overrides inherited effective theme or not. To enable OverrideTheme for overriding use OverrideTheme.Init*() methods. To disable OverrideTheme from overriding use OverrideTheme.Clear() method.
OverrideTheme (inherited from BaseOverrideThemeManager) | Returns the overriding theme object.

Public Instance Methods

ApplyColorScheme (inherited from BaseOverrideThemeManager) | Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseOverrideThemeManager) | Returns the theme object.

See Also

NotesSlideThemeManager Class | Aspose.Slides.Theme Namespace


OverrideTheme Class

Represents a overriding theme.

For a list of all members of this type, see OverrideTheme Members.

System.Object
Aspose.Slides.Theme.Theme
Aspose.Slides.Theme.OverrideTheme

[Visual Basic]
Public Class OverrideTheme
Inherits Theme
Implements IOverrideTheme
[C#]
public class OverrideTheme : Theme, IOverrideTheme

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

OverrideTheme Members | Aspose.Slides.Theme Namespace


OverrideTheme Members

OverrideTheme overview

Public Instance Properties

ColorScheme | Returns the color scheme. Read-only ColorScheme.
FontScheme | Returns the font scheme. Read-only FontScheme.
FormatScheme | Returns the shape format scheme. Read-only FormatScheme.
IsEmpty | True value means that ColorScheme, FontScheme, FormatScheme is null and any overriding with this theme object are disabled.
Presentation (inherited from Theme) | Returns the parent presentation. Read-only Presentation.

Public Instance Methods

Clear | Set ColorScheme, FontScheme, FormatScheme to null to disable any overriding with this theme object.
InitColorScheme | Init ColorScheme with new object for overriding ColorScheme of InheritedTheme.
InitColorSchemeFrom | Init ColorScheme with new object for overriding ColorScheme of InheritedTheme.
InitColorSchemeFromInherited | Init ColorScheme with new object for overriding ColorScheme of InheritedTheme. And initialize data of this new object with data of the ColorScheme of InheritedTheme.
InitFontScheme | Init FontScheme with new object for overriding FontScheme of InheritedTheme.
InitFontSchemeFrom | Init FontScheme with new object for overriding FontScheme of InheritedTheme.
InitFontSchemeFromInherited | Init FontScheme with new object for overriding FontScheme of InheritedTheme. And initialize data of this new object with data of the FontScheme of InheritedTheme.
InitFormatScheme | Init FormatScheme with new object for overriding FormatScheme of InheritedTheme.
InitFormatSchemeFrom | Init FormatScheme with new object for overriding FormatScheme of InheritedTheme.
InitFormatSchemeFromInherited | Init FormatScheme with new object for overriding FormatScheme of InheritedTheme. And initialize data of this new object with data of the FormatScheme of InheritedTheme.

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


OverrideTheme Properties

The properties of the OverrideTheme class are listed below. For a complete list of OverrideTheme class members, see the OverrideTheme Members topic.

Public Instance Properties

ColorScheme | Returns the color scheme. Read-only ColorScheme.
FontScheme | Returns the font scheme. Read-only FontScheme.
FormatScheme | Returns the shape format scheme. Read-only FormatScheme.
IsEmpty | True value means that ColorScheme, FontScheme, FormatScheme is null and any overriding with this theme object are disabled.
Presentation (inherited from Theme) | Returns the parent presentation. Read-only Presentation.

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


ColorScheme Property

Aspose.Slides Documentation

OverrideTheme.ColorScheme Property

Returns the color scheme. Read-only ColorScheme.

[Visual Basic]
Overrides Public ReadOnly Property ColorScheme As IColorScheme _
Implements ITheme.ColorScheme
[C#]
public override IColorScheme ColorScheme {get;}

Implements

ITheme.ColorScheme

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


FontScheme Property

Aspose.Slides Documentation

OverrideTheme.FontScheme Property

Returns the font scheme. Read-only FontScheme.

[Visual Basic]
Overrides Public ReadOnly Property FontScheme As IFontScheme _
Implements ITheme.FontScheme
[C#]
public override IFontScheme FontScheme {get;}

Implements

ITheme.FontScheme

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


FormatScheme Property

Aspose.Slides Documentation

OverrideTheme.FormatScheme Property

Returns the shape format scheme. Read-only FormatScheme.

[Visual Basic]
Overrides Public ReadOnly Property FormatScheme As IFormatScheme _
Implements ITheme.FormatScheme
[C#]
public override IFormatScheme FormatScheme {get;}

Implements

ITheme.FormatScheme

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


IsEmpty Property

Aspose.Slides Documentation

OverrideTheme.IsEmpty Property

True value means that ColorScheme, FontScheme, FormatScheme is null and any overriding with this theme object are disabled.

[Visual Basic]
NotOverridable Public ReadOnly Property IsEmpty As Boolean _
Implements IOverrideTheme.IsEmpty
[C#]
public bool IsEmpty {get;}

Implements

IOverrideTheme.IsEmpty

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


OverrideTheme Methods

The methods of the OverrideTheme class are listed below. For a complete list of OverrideTheme class members, see the OverrideTheme Members topic.

Public Instance Methods

Clear | Set ColorScheme, FontScheme, FormatScheme to null to disable any overriding with this theme object.
InitColorScheme | Init ColorScheme with new object for overriding ColorScheme of InheritedTheme.
InitColorSchemeFrom | Init ColorScheme with new object for overriding ColorScheme of InheritedTheme.
InitColorSchemeFromInherited | Init ColorScheme with new object for overriding ColorScheme of InheritedTheme. And initialize data of this new object with data of the ColorScheme of InheritedTheme.
InitFontScheme | Init FontScheme with new object for overriding FontScheme of InheritedTheme.
InitFontSchemeFrom | Init FontScheme with new object for overriding FontScheme of InheritedTheme.
InitFontSchemeFromInherited | Init FontScheme with new object for overriding FontScheme of InheritedTheme. And initialize data of this new object with data of the FontScheme of InheritedTheme.
InitFormatScheme | Init FormatScheme with new object for overriding FormatScheme of InheritedTheme.
InitFormatSchemeFrom | Init FormatScheme with new object for overriding FormatScheme of InheritedTheme.
InitFormatSchemeFromInherited | Init FormatScheme with new object for overriding FormatScheme of InheritedTheme. And initialize data of this new object with data of the FormatScheme of InheritedTheme.

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


OverrideTheme.Clear Method

Set ColorScheme, FontScheme, FormatScheme to null to disable any overriding with this theme object.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IOverrideTheme.Clear
[C#]
public void Clear();

Implements

IOverrideTheme.Clear

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


OverrideTheme.InitColorScheme Method

Init ColorScheme with new object for overriding ColorScheme of InheritedTheme.

[Visual Basic]
NotOverridable Public Sub InitColorScheme() _
Implements IOverrideTheme.InitColorScheme
[C#]
public void InitColorScheme();

Implements

IOverrideTheme.InitColorScheme

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the ColorScheme is already initialized (not null).

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


OverrideTheme.InitColorSchemeFrom Method

Init ColorScheme with new object for overriding ColorScheme of InheritedTheme.

[Visual Basic]
NotOverridable Public Sub InitColorSchemeFrom( _
ByVal colorScheme As IColorScheme _
) _
Implements IOverrideTheme.InitColorSchemeFrom
[C#]
public void InitColorSchemeFrom(
IColorScheme colorScheme
);

Parameters

colorScheme
Data to initialize from.

Implements

IOverrideTheme.InitColorSchemeFrom

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the ColorScheme is already initialized (not null).
ArgumentNullException | Thrown if the colorScheme parameter is null.

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


OverrideTheme.InitColorSchemeFromInherited Method

Init ColorScheme with new object for overriding ColorScheme of InheritedTheme. And initialize data of this new object with data of the ColorScheme of InheritedTheme.

[Visual Basic]
NotOverridable Public Sub InitColorSchemeFromInherited() _
Implements IOverrideTheme.InitColorSchemeFromInherited
[C#]
public void InitColorSchemeFromInherited();

Implements

IOverrideTheme.InitColorSchemeFromInherited

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the ColorScheme is already initialized (not null).

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


OverrideTheme.InitFontScheme Method

Init FontScheme with new object for overriding FontScheme of InheritedTheme.

[Visual Basic]
NotOverridable Public Sub InitFontScheme() _
Implements IOverrideTheme.InitFontScheme
[C#]
public void InitFontScheme();

Implements

IOverrideTheme.InitFontScheme

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the FontScheme is already initialized (not null).

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


OverrideTheme.InitFontSchemeFrom Method

Init FontScheme with new object for overriding FontScheme of InheritedTheme.

[Visual Basic]
NotOverridable Public Sub InitFontSchemeFrom( _
ByVal fontScheme As IFontScheme _
) _
Implements IOverrideTheme.InitFontSchemeFrom
[C#]
public void InitFontSchemeFrom(
IFontScheme fontScheme
);

Parameters

fontScheme
Data to initialize from.

Implements

IOverrideTheme.InitFontSchemeFrom

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the FontScheme is already initialized (not null).
ArgumentNullException | Thrown if the fontScheme parameter is null.

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


OverrideTheme.InitFontSchemeFromInherited Method

Init FontScheme with new object for overriding FontScheme of InheritedTheme. And initialize data of this new object with data of the FontScheme of InheritedTheme.

[Visual Basic]
NotOverridable Public Sub InitFontSchemeFromInherited() _
Implements IOverrideTheme.InitFontSchemeFromInherited
[C#]
public void InitFontSchemeFromInherited();

Implements

IOverrideTheme.InitFontSchemeFromInherited

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the FontScheme is already initialized (not null).

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


OverrideTheme.InitFormatScheme Method

Init FormatScheme with new object for overriding FormatScheme of InheritedTheme.

[Visual Basic]
NotOverridable Public Sub InitFormatScheme() _
Implements IOverrideTheme.InitFormatScheme
[C#]
public void InitFormatScheme();

Implements

IOverrideTheme.InitFormatScheme

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the FormatScheme is already initialized (not null).

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


OverrideTheme.InitFormatSchemeFrom Method

Init FormatScheme with new object for overriding FormatScheme of InheritedTheme.

[Visual Basic]
NotOverridable Public Sub InitFormatSchemeFrom( _
ByVal formatScheme As IFormatScheme _
) _
Implements IOverrideTheme.InitFormatSchemeFrom
[C#]
public void InitFormatSchemeFrom(
IFormatScheme formatScheme
);

Parameters

formatScheme
Data to initialize from.

Implements

IOverrideTheme.InitFormatSchemeFrom

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the FormatScheme is already initialized (not null).
ArgumentNullException | Thrown if the formatScheme parameter is null.

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


OverrideTheme.InitFormatSchemeFromInherited Method

Init FormatScheme with new object for overriding FormatScheme of InheritedTheme. And initialize data of this new object with data of the FormatScheme of InheritedTheme.

[Visual Basic]
NotOverridable Public Sub InitFormatSchemeFromInherited() _
Implements IOverrideTheme.InitFormatSchemeFromInherited
[C#]
public void InitFormatSchemeFromInherited();

Implements

IOverrideTheme.InitFormatSchemeFromInherited

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the FormatScheme is already initialized (not null).

See Also

OverrideTheme Class | Aspose.Slides.Theme Namespace


SlideThemeManager Class

For a list of all members of this type, see SlideThemeManager Members.

System.Object
Aspose.Slides.Theme.BaseThemeManager
Aspose.Slides.Theme.BaseOverrideThemeManager
Aspose.Slides.Theme.SlideThemeManager

[Visual Basic]
Public Class SlideThemeManager
Inherits BaseOverrideThemeManager
[C#]
public class SlideThemeManager : BaseOverrideThemeManager

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SlideThemeManager Members | Aspose.Slides.Theme Namespace


SlideThemeManager Members

SlideThemeManager overview

Public Instance Properties

IsOverrideThemeEnabled (inherited from BaseOverrideThemeManager) | Determines whether OverrideTheme overrides inherited effective theme or not. To enable OverrideTheme for overriding use OverrideTheme.Init*() methods. To disable OverrideTheme from overriding use OverrideTheme.Clear() method.
OverrideTheme (inherited from BaseOverrideThemeManager) | Returns the overriding theme object.

Public Instance Methods

ApplyColorScheme (inherited from BaseOverrideThemeManager) | Applies extra color scheme to a slide.
CreateThemeEffective (inherited from BaseOverrideThemeManager) | Returns the theme object.

See Also

SlideThemeManager Class | Aspose.Slides.Theme Namespace


Theme Class

Represents a theme.

For a list of all members of this type, see Theme Members.

System.Object
Aspose.Slides.Theme.Theme
Aspose.Slides.Theme.MasterTheme
Aspose.Slides.Theme.OverrideTheme

[Visual Basic]
MustInherit Public Class Theme
Implements ITheme, IPresentationComponent
[C#]
public abstract class Theme : ITheme, IPresentationComponent

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Theme Members | Aspose.Slides.Theme Namespace


Theme Members

Theme overview

Public Instance Properties

ColorScheme | Returns the color scheme. Read-only ColorScheme.
FontScheme | Returns the font scheme. Read-only FontScheme.
FormatScheme | Returns the shape format scheme. Read-only FormatScheme.
Presentation | Returns the parent presentation. Read-only Presentation.

See Also

Theme Class | Aspose.Slides.Theme Namespace


Theme Properties

The properties of the Theme class are listed below. For a complete list of Theme class members, see the Theme Members topic.

Public Instance Properties

ColorScheme | Returns the color scheme. Read-only ColorScheme.
FontScheme | Returns the font scheme. Read-only FontScheme.
FormatScheme | Returns the shape format scheme. Read-only FormatScheme.
Presentation | Returns the parent presentation. Read-only Presentation.

See Also

Theme Class | Aspose.Slides.Theme Namespace


ColorScheme Property

Aspose.Slides Documentation

Theme.ColorScheme Property

Returns the color scheme. Read-only ColorScheme.

[Visual Basic]
MustOverride Public ReadOnly Property ColorScheme As IColorScheme _
Implements ITheme.ColorScheme
[C#]
public abstract IColorScheme ColorScheme {get;}

Implements

ITheme.ColorScheme

See Also

Theme Class | Aspose.Slides.Theme Namespace


FontScheme Property

Aspose.Slides Documentation

Theme.FontScheme Property

Returns the font scheme. Read-only FontScheme.

[Visual Basic]
MustOverride Public ReadOnly Property FontScheme As IFontScheme _
Implements ITheme.FontScheme
[C#]
public abstract IFontScheme FontScheme {get;}

Implements

ITheme.FontScheme

See Also

Theme Class | Aspose.Slides.Theme Namespace


FormatScheme Property

Aspose.Slides Documentation

Theme.FormatScheme Property

Returns the shape format scheme. Read-only FormatScheme.

[Visual Basic]
MustOverride Public ReadOnly Property FormatScheme As IFormatScheme _
Implements ITheme.FormatScheme
[C#]
public abstract IFormatScheme FormatScheme {get;}

Implements

ITheme.FormatScheme

See Also

Theme Class | Aspose.Slides.Theme Namespace


Presentation Property

Aspose.Slides Documentation

Theme.Presentation Property

Returns the parent presentation. Read-only Presentation.

[Visual Basic]
NotOverridable Public ReadOnly Property Presentation As IPresentation _
Implements IPresentationComponent.Presentation
[C#]
public IPresentation Presentation {get;}

Implements

IPresentationComponent.Presentation

See Also

Theme Class | Aspose.Slides.Theme Namespace


ThemeEffectiveData Class

Immutable Theme object.

For a list of all members of this type, see ThemeEffectiveData Members.

System.Object
Aspose.Slides.Theme.ThemeEffectiveData

[Visual Basic]
Public Class ThemeEffectiveData
Implements IThemeEffectiveData
[C#]
public class ThemeEffectiveData : IThemeEffectiveData

Requirements

Namespace: Aspose.Slides.Theme

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

ThemeEffectiveData Members | Aspose.Slides.Theme Namespace


ThemeEffectiveData Members

ThemeEffectiveData overview

Public Instance Properties

FontScheme
FormatScheme

Public Instance Methods

GetColorScheme

See Also

ThemeEffectiveData Class | Aspose.Slides.Theme Namespace


ThemeEffectiveData Properties

The properties of the ThemeEffectiveData class are listed below. For a complete list of ThemeEffectiveData class members, see the ThemeEffectiveData Members topic.

Public Instance Properties

FontScheme
FormatScheme

See Also

ThemeEffectiveData Class | Aspose.Slides.Theme Namespace


FontScheme Property

Aspose.Slides Documentation

ThemeEffectiveData.FontScheme Property

[Visual Basic]
NotOverridable Public ReadOnly Property FontScheme As IFontSchemeEffectiveData _
Implements IThemeEffectiveData.FontScheme
[C#]
public IFontSchemeEffectiveData FontScheme {get;}

Implements

IThemeEffectiveData.FontScheme

See Also

ThemeEffectiveData Class | Aspose.Slides.Theme Namespace


FormatScheme Property

Aspose.Slides Documentation

ThemeEffectiveData.FormatScheme Property

[Visual Basic]
NotOverridable Public ReadOnly Property FormatScheme As IFormatSchemeEffectiveData _
Implements IThemeEffectiveData.FormatScheme
[C#]
public IFormatSchemeEffectiveData FormatScheme {get;}

Implements

IThemeEffectiveData.FormatScheme

See Also

ThemeEffectiveData Class | Aspose.Slides.Theme Namespace


ThemeEffectiveData Methods

The methods of the ThemeEffectiveData class are listed below. For a complete list of ThemeEffectiveData class members, see the ThemeEffectiveData Members topic.

Public Instance Methods

GetColorScheme

See Also

ThemeEffectiveData Class | Aspose.Slides.Theme Namespace


ThemeEffectiveData.GetColorScheme Method

[Visual Basic]
NotOverridable Public Function GetColorScheme( _
ByVal styleColor As Color _
) As IColorSchemeEffectiveData _
Implements IThemeEffectiveData.GetColorScheme
[C#]
public IColorSchemeEffectiveData GetColorScheme(
Color styleColor
);

Implements

IThemeEffectiveData.GetColorScheme

See Also

ThemeEffectiveData Class | Aspose.Slides.Theme Namespace


Aspose.Slides.Util

Aspose.Slides Documentation

Aspose.Slides.Util Namespace

Namespace hierarchy

Classes

Class | Description
SlideUtil | Offer methods which help to search shapes and text in a presentation.


SlideUtil Class

Offer methods which help to search shapes and text in a presentation.

For a list of all members of this type, see SlideUtil Members.

System.Object
Aspose.Slides.Util.SlideUtil

[Visual Basic]
Public Class SlideUtil
[C#]
public class SlideUtil

Requirements

Namespace: Aspose.Slides.Util

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

SlideUtil Members | Aspose.Slides.Util Namespace


SlideUtil Members

SlideUtil overview

Public Static (Shared) Methods

FindShape | Overloaded. Find shape by alternative text in a PPTX presentation.
GetAllTextBoxes | Returns all text frames on a slide in a PPTX presentation.
GetAllTextFrames | Returns all text frames in a PPTX presentation.

See Also

SlideUtil Class | Aspose.Slides.Util Namespace


SlideUtil Methods

The methods of the SlideUtil class are listed below. For a complete list of SlideUtil class members, see the SlideUtil Members topic.

Public Static (Shared) Methods

FindShape | Overloaded. Find shape by alternative text in a PPTX presentation.
GetAllTextBoxes | Returns all text frames on a slide in a PPTX presentation.
GetAllTextFrames | Returns all text frames in a PPTX presentation.

See Also

SlideUtil Class | Aspose.Slides.Util Namespace


FindShape Method

Aspose.Slides Documentation

SlideUtil.FindShape Method

Find shape by alternative text on a slide in a PPTX presentation.

Overload List

Find shape by alternative text on a slide in a PPTX presentation.

public static IShape FindShape(IBaseSlide,string);

Find shape by alternative text in a PPTX presentation.

public static IShape FindShape(IPresentation,string);

See Also

SlideUtil Class | Aspose.Slides.Util Namespace


SlideUtil.FindShape Method (IBaseSlide, String)

Find shape by alternative text on a slide in a PPTX presentation.

[Visual Basic]
Overloads Public Shared Function FindShape( _
ByVal slide As IBaseSlide, _
ByVal altText As String _
) As IShape
[C#]
public static IShape FindShape(
IBaseSlide slide,
string altText
);

Parameters

slide
Scanned slide.
altText
Alternative text of a shape.

Return Value

Shape or null.

See Also

SlideUtil Class | Aspose.Slides.Util Namespace | SlideUtil.FindShape Overload List


SlideUtil.FindShape Method (IPresentation, String)

Find shape by alternative text in a PPTX presentation.

[Visual Basic]
Overloads Public Shared Function FindShape( _
ByVal pres As IPresentation, _
ByVal altText As String _
) As IShape
[C#]
public static IShape FindShape(
IPresentation pres,
string altText
);

Parameters

pres
Scanned presentation.
altText
Alternative text of a shape.

Return Value

Shape or null.

See Also

SlideUtil Class | Aspose.Slides.Util Namespace | SlideUtil.FindShape Overload List


SlideUtil.GetAllTextBoxes Method

Returns all text frames on a slide in a PPTX presentation.

[Visual Basic]
Public Shared Function GetAllTextBoxes( _
ByVal slide As IBaseSlide _
) As ITextFrame()
[C#]
public static ITextFrame[] GetAllTextBoxes(
IBaseSlide slide
);

Parameters

slide
Scanned slide.

Return Value

Array of TextFrame objects.

See Also

SlideUtil Class | Aspose.Slides.Util Namespace


SlideUtil.GetAllTextFrames Method

Returns all text frames in a PPTX presentation.

[Visual Basic]
Public Shared Function GetAllTextFrames( _
ByVal pres As IPresentation, _
ByVal withMasters As Boolean _
) As ITextFrame()
[C#]
public static ITextFrame[] GetAllTextFrames(
IPresentation pres,
bool withMasters
);

Parameters

pres
Scanned presentation.
withMasters
Determines whether master slides should be scanned.

Return Value

Array of TextFrame objects.

See Also

SlideUtil Class | Aspose.Slides.Util Namespace


Aspose.Slides.Warnings

Aspose.Slides Documentation

Aspose.Slides.Warnings Namespace

Namespace hierarchy

Interfaces

Interface | Description
IKnownIssueWarningInfo |
INotImplementedWarningInfo |
IPresentationSignedWarningInfo |
IWarningCallback |
IWarningInfo |

Enumerations

Enumeration | Description
ReturnAction |
WarningType |


IKnownIssueWarningInfo Interface

For a list of all members of this type, see IKnownIssueWarningInfo Members.

[Visual Basic]
Public Interface IKnownIssueWarningInfo
Implements IWarningInfo
[C#]
public interface IKnownIssueWarningInfo : IWarningInfo

Requirements

Namespace: Aspose.Slides.Warnings

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IKnownIssueWarningInfo Members | Aspose.Slides.Warnings Namespace


IKnownIssueWarningInfo Members

IKnownIssueWarningInfo overview

Public Instance Properties

AsIWarningInfo

See Also

IKnownIssueWarningInfo Interface | Aspose.Slides.Warnings Namespace


IKnownIssueWarningInfo Properties

The properties of the IKnownIssueWarningInfo interface are listed below. For a complete list of IKnownIssueWarningInfo interface members, see the IKnownIssueWarningInfo Members topic.

Public Instance Properties

AsIWarningInfo

See Also

IKnownIssueWarningInfo Interface | Aspose.Slides.Warnings Namespace


AsIWarningInfo Property

Aspose.Slides Documentation

IKnownIssueWarningInfo.AsIWarningInfo Property

[Visual Basic]
Property AsIWarningInfo As IWarningInfo
[C#]
IWarningInfo AsIWarningInfo {get;}

See Also

IKnownIssueWarningInfo Interface | Aspose.Slides.Warnings Namespace


INotImplementedWarningInfo Interface

For a list of all members of this type, see INotImplementedWarningInfo Members.

[Visual Basic]
Public Interface INotImplementedWarningInfo
Implements IWarningInfo
[C#]
public interface INotImplementedWarningInfo : IWarningInfo

Requirements

Namespace: Aspose.Slides.Warnings

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

INotImplementedWarningInfo Members | Aspose.Slides.Warnings Namespace


INotImplementedWarningInfo Members

INotImplementedWarningInfo overview

Public Instance Properties

AsIWarningInfo

See Also

INotImplementedWarningInfo Interface | Aspose.Slides.Warnings Namespace


INotImplementedWarningInfo Properties

The properties of the INotImplementedWarningInfo interface are listed below. For a complete list of INotImplementedWarningInfo interface members, see the INotImplementedWarningInfo Members topic.

Public Instance Properties

AsIWarningInfo

See Also

INotImplementedWarningInfo Interface | Aspose.Slides.Warnings Namespace


AsIWarningInfo Property

Aspose.Slides Documentation

INotImplementedWarningInfo.AsIWarningInfo Property

[Visual Basic]
Property AsIWarningInfo As IWarningInfo
[C#]
IWarningInfo AsIWarningInfo {get;}

See Also

INotImplementedWarningInfo Interface | Aspose.Slides.Warnings Namespace


IPresentationSignedWarningInfo Interface

For a list of all members of this type, see IPresentationSignedWarningInfo Members.

[Visual Basic]
Public Interface IPresentationSignedWarningInfo
Implements IWarningInfo
[C#]
public interface IPresentationSignedWarningInfo : IWarningInfo

Requirements

Namespace: Aspose.Slides.Warnings

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IPresentationSignedWarningInfo Members | Aspose.Slides.Warnings Namespace


IPresentationSignedWarningInfo Members

IPresentationSignedWarningInfo overview

Public Instance Properties

AsIWarningInfo

See Also

IPresentationSignedWarningInfo Interface | Aspose.Slides.Warnings Namespace


IPresentationSignedWarningInfo Properties

The properties of the IPresentationSignedWarningInfo interface are listed below. For a complete list of IPresentationSignedWarningInfo interface members, see the IPresentationSignedWarningInfo Members topic.

Public Instance Properties

AsIWarningInfo

See Also

IPresentationSignedWarningInfo Interface | Aspose.Slides.Warnings Namespace


AsIWarningInfo Property

Aspose.Slides Documentation

IPresentationSignedWarningInfo.AsIWarningInfo Property

[Visual Basic]
Property AsIWarningInfo As IWarningInfo
[C#]
IWarningInfo AsIWarningInfo {get;}

See Also

IPresentationSignedWarningInfo Interface | Aspose.Slides.Warnings Namespace


IWarningCallback Interface

For a list of all members of this type, see IWarningCallback Members.

[Visual Basic]
Public Interface IWarningCallback
[C#]
public interface IWarningCallback

Requirements

Namespace: Aspose.Slides.Warnings

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IWarningCallback Members | Aspose.Slides.Warnings Namespace


IWarningCallback Members

IWarningCallback overview

Public Instance Methods

Warning

See Also

IWarningCallback Interface | Aspose.Slides.Warnings Namespace


IWarningCallback Methods

The methods of the IWarningCallback interface are listed below. For a complete list of IWarningCallback interface members, see the IWarningCallback Members topic.

Public Instance Methods

Warning

See Also

IWarningCallback Interface | Aspose.Slides.Warnings Namespace


IWarningCallback.Warning Method

[Visual Basic]
Function Warning( _
ByVal warning As IWarningInfo _
) As ReturnAction
[C#]
ReturnAction Warning(
IWarningInfo warning
);

See Also

IWarningCallback Interface | Aspose.Slides.Warnings Namespace


IWarningInfo Interface

For a list of all members of this type, see IWarningInfo Members.

Aspose.Slides.Warnings.IWarningInfo
Aspose.Slides.Warnings.IKnownIssueWarningInfo
Aspose.Slides.Warnings.INotImplementedWarningInfo
Aspose.Slides.Warnings.IPresentationSignedWarningInfo

[Visual Basic]
Public Interface IWarningInfo
[C#]
public interface IWarningInfo

Requirements

Namespace: Aspose.Slides.Warnings

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

IWarningInfo Members | Aspose.Slides.Warnings Namespace


IWarningInfo Members

IWarningInfo overview

Public Instance Properties

Description
WarningType

Public Instance Methods

SendWarning

See Also

IWarningInfo Interface | Aspose.Slides.Warnings Namespace


IWarningInfo Properties

The properties of the IWarningInfo interface are listed below. For a complete list of IWarningInfo interface members, see the IWarningInfo Members topic.

Public Instance Properties

Description
WarningType

See Also

IWarningInfo Interface | Aspose.Slides.Warnings Namespace


Description Property

Aspose.Slides Documentation

IWarningInfo.Description Property

[Visual Basic]
Property Description As String
[C#]
string Description {get;}

See Also

IWarningInfo Interface | Aspose.Slides.Warnings Namespace


WarningType Property

Aspose.Slides Documentation

IWarningInfo.WarningType Property

[Visual Basic]
Property WarningType As WarningType
[C#]
WarningType WarningType {get;}

See Also

IWarningInfo Interface | Aspose.Slides.Warnings Namespace


IWarningInfo Methods

The methods of the IWarningInfo interface are listed below. For a complete list of IWarningInfo interface members, see the IWarningInfo Members topic.

Public Instance Methods

SendWarning

See Also

IWarningInfo Interface | Aspose.Slides.Warnings Namespace


IWarningInfo.SendWarning Method

[Visual Basic]
Sub SendWarning( _
ByVal receiver As IWarningCallback _
)
[C#]
void SendWarning(
IWarningCallback receiver
);

See Also

IWarningInfo Interface | Aspose.Slides.Warnings Namespace


ReturnAction Enumeration

[Visual Basic]
Public Enum ReturnAction
[C#]
public enum ReturnAction

Members

Member Name | Description | Value
Continue |  | 0
Abort |  | 1

Requirements

Namespace: Aspose.Slides.Warnings

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Warnings Namespace


WarningType Enumeration

[Visual Basic]
Public Enum WarningType
[C#]
public enum WarningType

Members

Member Name | Description | Value
SourceFileCorruption |  | 0
DataLoss |  | 1
MajorFormattingLoss |  | 2
MinorFormattingLoss |  | 3
CompatibilityIssue |  | 4
UnexpectedContent |  | 99

Requirements

Namespace: Aspose.Slides.Warnings

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

Aspose.Slides.Warnings Namespace


SmartAssembly.Attributes

Aspose.Slides Documentation

SmartAssembly.Attributes Namespace

Namespace hierarchy

Classes

Class | Description
PoweredByAttribute |


PoweredByAttribute Class

For a list of all members of this type, see PoweredByAttribute Members.

System.Object
System.Attribute
SmartAssembly.Attributes.PoweredByAttribute

[Visual Basic]
NotInheritable Public Class PoweredByAttribute
Inherits Attribute
[C#]
public sealed class PoweredByAttribute : Attribute

Requirements

Namespace: SmartAssembly.Attributes

Assembly: Aspose.Slides (in Aspose.Slides)

See Also

PoweredByAttribute Members | SmartAssembly.Attributes Namespace


PoweredByAttribute Members

PoweredByAttribute overview

Public Instance Constructors

PoweredByAttribute Constructor

See Also

PoweredByAttribute Class | SmartAssembly.Attributes Namespace


PoweredByAttribute Constructor

[Visual Basic]
Public Sub New( _
ByVal s As String _
)
[C#]
public PoweredByAttribute(
string s
);

See Also

PoweredByAttribute Class | SmartAssembly.Attributes Namespace


Behavior Hierarchy

System.Object
Behavior
ColorEffect
CommandEffect
FilterEffect
MotionEffect
PropertyEffect
RotationEffect
ScaleEffect
SetEffect

See Also

Behavior Class | Behavior Members | Aspose.Slides.Animation Namespace


IBehavior Hierarchy

Aspose.Slides.Animation.IBehavior
IColorEffect
ICommandEffect
IFilterEffect
IMotionEffect
IPropertyEffect
IRotationEffect
IScaleEffect
ISetEffect

See Also

IBehavior Interface | IBehavior Members | Aspose.Slides.Animation Namespace


Aspose.Slides.AnimationHierarchy

Aspose.Slides Documentation

Aspose.Slides.Animation Hierarchy

System.Object
Aspose.Slides.Animation.AnimationTimeLine ---- Aspose.Slides.IAnimationTimeLine
Aspose.Slides.Animation.Behavior ---- Aspose.Slides.Animation.IBehavior
Aspose.Slides.Animation.ColorEffect ---- Aspose.Slides.Animation.IColorEffect
Aspose.Slides.Animation.CommandEffect ---- Aspose.Slides.Animation.ICommandEffect
Aspose.Slides.Animation.FilterEffect ---- Aspose.Slides.Animation.IFilterEffect
Aspose.Slides.Animation.MotionEffect ---- Aspose.Slides.Animation.IMotionEffect
Aspose.Slides.Animation.PropertyEffect ---- Aspose.Slides.Animation.IPropertyEffect
Aspose.Slides.Animation.RotationEffect ---- Aspose.Slides.Animation.IRotationEffect
Aspose.Slides.Animation.ScaleEffect ---- Aspose.Slides.Animation.IScaleEffect
Aspose.Slides.Animation.SetEffect ---- Aspose.Slides.Animation.ISetEffect
Aspose.Slides.Animation.BehaviorCollection ---- Aspose.Slides.Animation.IBehaviorCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Animation.IBehavior, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Animation.BehaviorFactory ---- Aspose.Slides.Animation.IBehaviorFactory
Aspose.Slides.Animation.BehaviorProperties ---- Aspose.Slides.Animation.IBehaviorProperties, System.Collections.Generic.ICollection`1[[Aspose.Slides.Animation.PropertyType, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Animation.PropertyType, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IList`1[[Aspose.Slides.Animation.PropertyType, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Animation.ColorOffset ---- Aspose.Slides.Animation.IColorOffset
Aspose.Slides.Animation.Effect ---- Aspose.Slides.Animation.IEffect
Aspose.Slides.Animation.IBehavior
Aspose.Slides.Animation.IBehaviorCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Animation.IBehavior, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Animation.IBehaviorFactory
Aspose.Slides.Animation.IBehaviorProperties ---- System.Collections.Generic.ICollection`1[[Aspose.Slides.Animation.PropertyType, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Animation.PropertyType, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IList`1[[Aspose.Slides.Animation.PropertyType, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Animation.IColorEffect ---- Aspose.Slides.Animation.IBehavior
Aspose.Slides.Animation.IColorOffset
Aspose.Slides.Animation.ICommandEffect ---- Aspose.Slides.Animation.IBehavior
Aspose.Slides.Animation.IEffect
Aspose.Slides.Animation.IFilterEffect ---- Aspose.Slides.Animation.IBehavior
Aspose.Slides.Animation.IMotionCmdPath
Aspose.Slides.Animation.IMotionEffect ---- Aspose.Slides.Animation.IBehavior
Aspose.Slides.Animation.IMotionPath ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Animation.IMotionCmdPath, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Animation.IPoint
Aspose.Slides.Animation.IPointCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Animation.IPoint, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Animation.IPropertyEffect ---- Aspose.Slides.Animation.IBehavior
Aspose.Slides.Animation.IRotationEffect ---- Aspose.Slides.Animation.IBehavior
Aspose.Slides.Animation.IScaleEffect ---- Aspose.Slides.Animation.IBehavior
Aspose.Slides.Animation.ISequence ---- System.Collections.IEnumerable
Aspose.Slides.Animation.ISequenceCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Animation.ISequence, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Animation.ISetEffect ---- Aspose.Slides.Animation.IBehavior
Aspose.Slides.Animation.ITextAnimation
Aspose.Slides.Animation.ITextAnimationCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Animation.ITextAnimation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Animation.ITiming
Aspose.Slides.Animation.MotionCmdPath ---- Aspose.Slides.Animation.IMotionCmdPath
Aspose.Slides.Animation.MotionPath ---- Aspose.Slides.Animation.IMotionPath, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Animation.IMotionCmdPath, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Animation.Point ---- Aspose.Slides.Animation.IPoint
Aspose.Slides.Animation.PointCollection ---- Aspose.Slides.Animation.IPointCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Animation.IPoint, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Animation.Sequence ---- Aspose.Slides.Animation.ISequence, System.Collections.IEnumerable
Aspose.Slides.Animation.SequenceCollection ---- Aspose.Slides.Animation.ISequenceCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Animation.ISequence, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Animation.TextAnimation ---- Aspose.Slides.Animation.ITextAnimation
Aspose.Slides.Animation.TextAnimationCollection ---- Aspose.Slides.Animation.ITextAnimationCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Animation.ITextAnimation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Animation.Timing ---- Aspose.Slides.Animation.ITiming
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Slides.Animation.BehaviorAccumulateType
Aspose.Slides.Animation.BehaviorAdditiveType
Aspose.Slides.Animation.BuildType
Aspose.Slides.Animation.ColorDirection
Aspose.Slides.Animation.ColorSpace
Aspose.Slides.Animation.CommandEffectType
Aspose.Slides.Animation.EffectFillType
Aspose.Slides.Animation.EffectPresetClassType
Aspose.Slides.Animation.EffectRestartType
Aspose.Slides.Animation.EffectSubtype
Aspose.Slides.Animation.EffectTriggerType
Aspose.Slides.Animation.EffectType
Aspose.Slides.Animation.FilterEffectRevealType
Aspose.Slides.Animation.FilterEffectSubtype
Aspose.Slides.Animation.FilterEffectType
Aspose.Slides.Animation.MotionCommandPathType
Aspose.Slides.Animation.MotionOriginType
Aspose.Slides.Animation.MotionPathEditMode
Aspose.Slides.Animation.MotionPathPointsType
Aspose.Slides.Animation.PropertyCalcModeType
Aspose.Slides.Animation.PropertyType
Aspose.Slides.Animation.PropertyValueType

See Also

Aspose.Slides.Animation Namespace


BaseSlide Hierarchy

System.Object
BaseSlide
LayoutSlide
MasterHandoutSlide
MasterNotesSlide
MasterSlide
NotesSlide
Slide

See Also

BaseSlide Class | BaseSlide Members | Aspose.Slides Namespace


IChartComponent Hierarchy

Aspose.Slides.Charts.IChartComponent
IAxis
IChartPlotArea
IChartSeries
IChartTitle
IDataLabel
IDataLabelCollection
IDataLabelFormat
IDataTable
ILayoutable
ILegend
ILegendEntryProperties
ITrendline

See Also

IChartComponent Interface | IChartComponent Members | Aspose.Slides.Charts Namespace


IFormattedTextContainer Hierarchy

Aspose.Slides.Charts.IFormattedTextContainer
IAxis
IChart
IChartTitle
IDataLabel
IDataLabelFormat
IDataTable
ILegend
ILegendEntryProperties
IOverridableText
ITrendline

See Also

IFormattedTextContainer Interface | IFormattedTextContainer Members | Aspose.Slides.Charts Namespace


Aspose.Slides.ChartsHierarchy

Aspose.Slides Documentation

Aspose.Slides.Charts Hierarchy

System.Object
Aspose.Slides.Charts.AxesManager ---- Aspose.Slides.Charts.IAxesManager
Aspose.Slides.Charts.Axis ---- Aspose.Slides.Charts.IAxis, Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IFormattedTextContainer
Aspose.Slides.Charts.AxisFormat ---- Aspose.Slides.Charts.IAxisFormat
Aspose.Slides.Charts.BaseChartValue ---- Aspose.Slides.Charts.IBaseChartValue
Aspose.Slides.Charts.DoubleChartValue ---- Aspose.Slides.Charts.IDoubleChartValue, Aspose.Slides.Charts.ISingleCellChartValue
Aspose.Slides.Charts.StringChartValue ---- Aspose.Slides.Charts.IMultipleCellChartValue, Aspose.Slides.Charts.IStringChartValue
Aspose.Slides.Charts.StringOrDoubleChartValue ---- Aspose.Slides.Charts.ISingleCellChartValue, Aspose.Slides.Charts.IStringOrDoubleChartValue
Aspose.Slides.Charts.ChartCategory ---- Aspose.Slides.Charts.IChartCategory
Aspose.Slides.Charts.ChartCategoryCollection ---- Aspose.Slides.Charts.IChartCategoryCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Charts.IChartCategory, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Charts.ChartCategoryLevelsManager ---- Aspose.Slides.Charts.IChartCategoryLevelsManager
Aspose.Slides.Charts.ChartCellCollection ---- Aspose.Slides.Charts.IChartCellCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Charts.IChartDataCell, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Charts.ChartData ---- Aspose.Slides.Charts.IChartData
Aspose.Slides.Charts.ChartDataCell ---- Aspose.Slides.Charts.IChartDataCell
Aspose.Slides.Charts.ChartDataPoint ---- Aspose.Slides.Charts.IChartDataPoint
Aspose.Slides.Charts.ChartDataPointCollection ---- Aspose.Slides.Charts.IChartDataPointCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Charts.IChartDataPoint, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Charts.ChartDataWorkbook ---- Aspose.Slides.Charts.IChartDataWorkbook
Aspose.Slides.Charts.ChartDataWorksheet ---- Aspose.Slides.Charts.IChartDataWorksheet
Aspose.Slides.Charts.ChartLinesFormat ---- Aspose.Slides.Charts.IChartLinesFormat
Aspose.Slides.Charts.ChartPlotArea ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IChartPlotArea, Aspose.Slides.Charts.ILayoutable
Aspose.Slides.Charts.ChartSeries ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IChartSeries
Aspose.Slides.Charts.ChartSeriesCollection ---- Aspose.Slides.Charts.IChartSeriesCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Charts.IChartSeries, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Charts.ChartSeriesGroup ---- Aspose.Slides.Charts.IChartSeriesGroup
Aspose.Slides.Charts.ChartTextFormat ---- Aspose.Slides.Charts.IChartTextFormat
Aspose.Slides.Charts.ChartTitle ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IChartTitle, Aspose.Slides.Charts.IFormattedTextContainer, Aspose.Slides.Charts.ILayoutable, Aspose.Slides.Charts.IOverridableText
Aspose.Slides.Charts.ChartTypeCharacterizer
Aspose.Slides.Charts.ChartWall ---- Aspose.Slides.Charts.IChartWall
Aspose.Slides.Charts.DataLabel ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IDataLabel, Aspose.Slides.Charts.IFormattedTextContainer, Aspose.Slides.Charts.ILayoutable, Aspose.Slides.Charts.IOverridableText
Aspose.Slides.Charts.DataLabelCollection ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IDataLabelCollection, System.Collections.IEnumerable
Aspose.Slides.Charts.DataLabelFormat ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IDataLabelFormat, Aspose.Slides.Charts.IFormattedTextContainer
Aspose.Slides.Charts.DataTable ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IDataTable, Aspose.Slides.Charts.IFormattedTextContainer
Aspose.Slides.Charts.Format ---- Aspose.Slides.Charts.IFormat
Aspose.Slides.Charts.IAxesManager
Aspose.Slides.Charts.IAxis ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IFormattedTextContainer
Aspose.Slides.Charts.IAxisFormat
Aspose.Slides.Charts.IBaseChartValue
Aspose.Slides.Charts.IChart ---- Aspose.Slides.Charts.IFormattedTextContainer, Aspose.Slides.IGraphicalObject, Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IOverrideThemeable, Aspose.Slides.Theme.IThemeable
Aspose.Slides.Charts.IChartCategory
Aspose.Slides.Charts.IChartCategoryCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Charts.IChartCategory, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Charts.IChartCategoryLevelsManager
Aspose.Slides.Charts.IChartCellCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Charts.IChartDataCell, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Charts.IChartComponent
Aspose.Slides.Charts.IChartData
Aspose.Slides.Charts.IChartDataCell
Aspose.Slides.Charts.IChartDataPoint
Aspose.Slides.Charts.IChartDataPointCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Charts.IChartDataPoint, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Charts.IChartDataWorkbook
Aspose.Slides.Charts.IChartDataWorksheet
Aspose.Slides.Charts.IChartLinesFormat
Aspose.Slides.Charts.IChartParagraphFormat
Aspose.Slides.Charts.IChartPlotArea ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.ILayoutable
Aspose.Slides.Charts.IChartPortionFormat
Aspose.Slides.Charts.IChartSeries ---- Aspose.Slides.Charts.IChartComponent
Aspose.Slides.Charts.IChartSeriesCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Charts.IChartSeries, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Charts.IChartSeriesGroup
Aspose.Slides.Charts.IChartSeriesGroupCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Charts.IChartSeriesGroup, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Charts.IChartSeriesReadonlyCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Charts.IChartSeries, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Charts.IChartTextBlockFormat
Aspose.Slides.Charts.IChartTextFormat
Aspose.Slides.Charts.IChartTitle ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IFormattedTextContainer, Aspose.Slides.Charts.ILayoutable, Aspose.Slides.Charts.IOverridableText
Aspose.Slides.Charts.IChartWall
Aspose.Slides.Charts.IDataLabel ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IFormattedTextContainer, Aspose.Slides.Charts.ILayoutable, Aspose.Slides.Charts.IOverridableText
Aspose.Slides.Charts.IDataLabelCollection ---- Aspose.Slides.Charts.IChartComponent, System.Collections.IEnumerable
Aspose.Slides.Charts.IDataLabelFormat ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IFormattedTextContainer
Aspose.Slides.Charts.IDataTable ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IFormattedTextContainer
Aspose.Slides.Charts.IDoubleChartValue ---- Aspose.Slides.Charts.IBaseChartValue, Aspose.Slides.Charts.ISingleCellChartValue
Aspose.Slides.Charts.IFormat
Aspose.Slides.Charts.IFormattedTextContainer
Aspose.Slides.Charts.ILayoutable ---- Aspose.Slides.Charts.IChartComponent
Aspose.Slides.Charts.ILegend ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IFormattedTextContainer, Aspose.Slides.Charts.ILayoutable
Aspose.Slides.Charts.ILegendEntryCollection
Aspose.Slides.Charts.ILegendEntryProperties ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IFormattedTextContainer
Aspose.Slides.Charts.IMarker
Aspose.Slides.Charts.IMultipleCellChartValue ---- Aspose.Slides.Charts.IBaseChartValue
Aspose.Slides.Charts.IOverridableText ---- Aspose.Slides.Charts.IFormattedTextContainer
Aspose.Slides.Charts.IRotation3D
Aspose.Slides.Charts.ISingleCellChartValue ---- Aspose.Slides.Charts.IBaseChartValue
Aspose.Slides.Charts.IStringChartValue ---- Aspose.Slides.Charts.IBaseChartValue, Aspose.Slides.Charts.IMultipleCellChartValue
Aspose.Slides.Charts.IStringOrDoubleChartValue ---- Aspose.Slides.Charts.IBaseChartValue, Aspose.Slides.Charts.ISingleCellChartValue
Aspose.Slides.Charts.ITrendline ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IFormattedTextContainer, Aspose.Slides.Charts.IOverridableText
Aspose.Slides.Charts.ITrendlineCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Charts.ITrendline, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Charts.IUpDownBarsManager
Aspose.Slides.Charts.Legend ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IFormattedTextContainer, Aspose.Slides.Charts.ILayoutable, Aspose.Slides.Charts.ILegend
Aspose.Slides.Charts.LegendEntryCollection ---- Aspose.Slides.Charts.ILegendEntryCollection
Aspose.Slides.Charts.LegendEntryProperties ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IFormattedTextContainer, Aspose.Slides.Charts.ILegendEntryProperties
Aspose.Slides.Charts.Marker ---- Aspose.Slides.Charts.IMarker
Aspose.Slides.Charts.Rotation3D ---- Aspose.Slides.Charts.IRotation3D
Aspose.Slides.Charts.Trendline ---- Aspose.Slides.Charts.IChartComponent, Aspose.Slides.Charts.IFormattedTextContainer, Aspose.Slides.Charts.IOverridableText, Aspose.Slides.Charts.ITrendline
Aspose.Slides.Charts.TrendlineCollection ---- Aspose.Slides.Charts.ITrendlineCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Charts.ITrendline, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Charts.UpDownBarsManager ---- Aspose.Slides.Charts.IUpDownBarsManager
Aspose.Slides.Shape ---- Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.GraphicalObject ---- Aspose.Slides.IGraphicalObject
Aspose.Slides.Charts.Chart ---- Aspose.Slides.Charts.IChart, Aspose.Slides.Charts.IFormattedTextContainer, Aspose.Slides.Theme.IOverrideThemeable, Aspose.Slides.Theme.IThemeable
System.Exception ---- System.Runtime.Serialization.ISerializable
System.SystemException
System.InvalidOperationException
Aspose.Slides.Charts.CannotCombine2DAnd3DChartsException
Aspose.Slides.Charts.PreferredAxesCompositionIsNotCombinableException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Slides.Charts.AxisPositionType
Aspose.Slides.Charts.ChartShapeType
Aspose.Slides.Charts.ChartType
Aspose.Slides.Charts.CombinableSeriesTypesGroup
Aspose.Slides.Charts.CrossesType
Aspose.Slides.Charts.DataSourceType
Aspose.Slides.Charts.DisplayBlanksAsType
Aspose.Slides.Charts.DisplayUnitType
Aspose.Slides.Charts.LegendDataLabelPosition
Aspose.Slides.Charts.LegendPositionType
Aspose.Slides.Charts.MarkerStyleType
Aspose.Slides.Charts.PictureType
Aspose.Slides.Charts.StyleType
Aspose.Slides.Charts.TickLabelPositionType
Aspose.Slides.Charts.TickMarkType
Aspose.Slides.Charts.TimeUnitType
Aspose.Slides.Charts.TrendlineType

See Also

Aspose.Slides.Charts Namespace


EffectEffectiveData Hierarchy

System.Object
EffectEffectiveData
AlphaBiLevelEffectiveData
AlphaCeilingEffectiveData
AlphaFloorEffectiveData
AlphaInverseEffectiveData
AlphaModulateEffectiveData
AlphaModulateFixedEffectiveData
AlphaReplaceEffectiveData
BiLevelEffectiveData
BlurEffectiveData
ColorChangeEffectiveData
ColorReplaceEffectiveData
DuotoneEffectiveData
FillOverlayEffectiveData
GlowEffectiveData
GrayScaleEffectiveData
HSLEffectiveData
InnerShadowEffectiveData
LuminanceEffectiveData
OuterShadowEffectiveData
PresetShadowEffectiveData
ReflectionEffectiveData
SoftEdgeEffectiveData
TintEffectiveData

See Also

EffectEffectiveData Class | Aspose.Slides.Effects Namespace


IImageTransformOperation Hierarchy

Aspose.Slides.Effects.IImageTransformOperation
IAlphaBiLevel
IAlphaCeiling
IAlphaFloor
IAlphaInverse
IAlphaModulate
IAlphaModulateFixed
IAlphaReplace
IBiLevel
IBlur
IColorChange
IColorReplace
IDuotone
IFillOverlay
IGrayScale
IHSL
ILuminance
ITint

See Also

IImageTransformOperation Interface | IImageTransformOperation Members | Aspose.Slides.Effects Namespace


ImageTransformOperation Hierarchy

System.Object
ImageTransformOperation
AlphaBiLevel
AlphaCeiling
AlphaFloor
AlphaInverse
AlphaModulate
AlphaModulateFixed
AlphaReplace
BiLevel
Blur
ColorChange
ColorReplace
Duotone
FillOverlay
GrayScale
HSL
Luminance
Tint

See Also

ImageTransformOperation Class | Aspose.Slides.Effects Namespace


Aspose.Slides.EffectsHierarchy

Aspose.Slides Documentation

Aspose.Slides.Effects Hierarchy

System.Object
Aspose.Slides.Effects.EffectEffectiveData ---- Aspose.Slides.Effects.IEffectEffectiveData
Aspose.Slides.Effects.AlphaBiLevelEffectiveData ---- Aspose.Slides.Effects.IAlphaBiLevelEffectiveData
Aspose.Slides.Effects.AlphaCeilingEffectiveData ---- Aspose.Slides.Effects.IAlphaCeilingEffectiveData
Aspose.Slides.Effects.AlphaFloorEffectiveData ---- Aspose.Slides.Effects.IAlphaFloorEffectiveData
Aspose.Slides.Effects.AlphaInverseEffectiveData ---- Aspose.Slides.Effects.IAlphaInverseEffectiveData
Aspose.Slides.Effects.AlphaModulateEffectiveData ---- Aspose.Slides.Effects.IAlphaModulateEffectiveData
Aspose.Slides.Effects.AlphaModulateFixedEffectiveData ---- Aspose.Slides.Effects.IAlphaModulateFixedEffectiveData
Aspose.Slides.Effects.AlphaReplaceEffectiveData ---- Aspose.Slides.Effects.IAlphaReplaceEffectiveData
Aspose.Slides.Effects.BiLevelEffectiveData ---- Aspose.Slides.Effects.IBiLevelEffectiveData
Aspose.Slides.Effects.BlurEffectiveData ---- Aspose.Slides.Effects.IBlurEffectiveData
Aspose.Slides.Effects.ColorChangeEffectiveData ---- Aspose.Slides.Effects.IColorChangeEffectiveData
Aspose.Slides.Effects.ColorReplaceEffectiveData ---- Aspose.Slides.Effects.IColorReplaceEffectiveData
Aspose.Slides.Effects.DuotoneEffectiveData ---- Aspose.Slides.Effects.IDuotoneEffectiveData
Aspose.Slides.Effects.FillOverlayEffectiveData ---- Aspose.Slides.Effects.IFillOverlayEffectiveData
Aspose.Slides.Effects.GlowEffectiveData ---- Aspose.Slides.Effects.IGlowEffectiveData
Aspose.Slides.Effects.GrayScaleEffectiveData ---- Aspose.Slides.Effects.IGrayScaleEffectiveData
Aspose.Slides.Effects.HSLEffectiveData ---- Aspose.Slides.Effects.IHSLEffectiveData
Aspose.Slides.Effects.InnerShadowEffectiveData ---- Aspose.Slides.Effects.IInnerShadowEffectiveData
Aspose.Slides.Effects.LuminanceEffectiveData ---- Aspose.Slides.Effects.ILuminanceEffectiveData
Aspose.Slides.Effects.OuterShadowEffectiveData ---- Aspose.Slides.Effects.IOuterShadowEffectiveData
Aspose.Slides.Effects.PresetShadowEffectiveData ---- Aspose.Slides.Effects.IPresetShadowEffectiveData
Aspose.Slides.Effects.ReflectionEffectiveData ---- Aspose.Slides.Effects.IReflectionEffectiveData
Aspose.Slides.Effects.SoftEdgeEffectiveData ---- Aspose.Slides.Effects.ISoftEdgeEffectiveData
Aspose.Slides.Effects.TintEffectiveData ---- Aspose.Slides.Effects.ITintEffectiveData
Aspose.Slides.Effects.EffectFactory ---- Aspose.Slides.Effects.IEffectFactory
Aspose.Slides.Effects.Glow ---- Aspose.Slides.Effects.IGlow
Aspose.Slides.Effects.IAlphaBiLevel ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IAlphaBiLevelEffectiveData
Aspose.Slides.Effects.IAlphaCeiling ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IAlphaCeilingEffectiveData
Aspose.Slides.Effects.IAlphaFloor ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IAlphaFloorEffectiveData
Aspose.Slides.Effects.IAlphaInverse ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IAlphaInverseEffectiveData
Aspose.Slides.Effects.IAlphaModulate ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IAlphaModulateEffectiveData
Aspose.Slides.Effects.IAlphaModulateFixed ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IAlphaModulateFixedEffectiveData
Aspose.Slides.Effects.IAlphaReplace ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IAlphaReplaceEffectiveData
Aspose.Slides.Effects.IBiLevel ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IBiLevelEffectiveData
Aspose.Slides.Effects.IBlur ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IBlurEffectiveData
Aspose.Slides.Effects.IColorChange ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IColorChangeEffectiveData
Aspose.Slides.Effects.IColorReplace ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IColorReplaceEffectiveData
Aspose.Slides.Effects.IDuotone ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IDuotoneEffectiveData
Aspose.Slides.Effects.IEffectEffectiveData
Aspose.Slides.Effects.IEffectFactory
Aspose.Slides.Effects.IFillOverlay ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IFillOverlayEffectiveData
Aspose.Slides.Effects.IGlow
Aspose.Slides.Effects.IGlowEffectiveData
Aspose.Slides.Effects.IGrayScale ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IGrayScaleEffectiveData
Aspose.Slides.Effects.IHSL ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IHSLEffectiveData
Aspose.Slides.Effects.IImageTransformOCollectionEffectiveData ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Effects.IEffectEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Effects.IImageTransformOperation ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.IImageTransformOperationCollection ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, System.Collections.Generic.ICollection`1[[Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Effects.IImageTransformOperationFactory
Aspose.Slides.Effects.IInnerShadow
Aspose.Slides.Effects.IInnerShadowEffectiveData
Aspose.Slides.Effects.ILuminance ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.ILuminanceEffectiveData
Aspose.Slides.Effects.ImageTransformOCollectionEffectiveData ---- Aspose.Slides.Effects.IImageTransformOCollectionEffectiveData, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Effects.IEffectEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Effects.ImageTransformOperation ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.AlphaBiLevel ---- Aspose.Slides.Effects.IAlphaBiLevel
Aspose.Slides.Effects.AlphaCeiling ---- Aspose.Slides.Effects.IAlphaCeiling
Aspose.Slides.Effects.AlphaFloor ---- Aspose.Slides.Effects.IAlphaFloor
Aspose.Slides.Effects.AlphaInverse ---- Aspose.Slides.Effects.IAlphaInverse
Aspose.Slides.Effects.AlphaModulate ---- Aspose.Slides.Effects.IAlphaModulate
Aspose.Slides.Effects.AlphaModulateFixed ---- Aspose.Slides.Effects.IAlphaModulateFixed
Aspose.Slides.Effects.AlphaReplace ---- Aspose.Slides.Effects.IAlphaReplace
Aspose.Slides.Effects.BiLevel ---- Aspose.Slides.Effects.IBiLevel
Aspose.Slides.Effects.Blur ---- Aspose.Slides.Effects.IBlur
Aspose.Slides.Effects.ColorChange ---- Aspose.Slides.Effects.IColorChange
Aspose.Slides.Effects.ColorReplace ---- Aspose.Slides.Effects.IColorReplace
Aspose.Slides.Effects.Duotone ---- Aspose.Slides.Effects.IDuotone
Aspose.Slides.Effects.FillOverlay ---- Aspose.Slides.Effects.IFillOverlay
Aspose.Slides.Effects.GrayScale ---- Aspose.Slides.Effects.IGrayScale
Aspose.Slides.Effects.HSL ---- Aspose.Slides.Effects.IHSL
Aspose.Slides.Effects.Luminance ---- Aspose.Slides.Effects.ILuminance
Aspose.Slides.Effects.Tint ---- Aspose.Slides.Effects.ITint
Aspose.Slides.Effects.ImageTransformOperationCollection ---- Aspose.Slides.Effects.IImageTransformOperationCollection, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, System.Collections.Generic.ICollection`1[[Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.Effects.ImageTransformOperationFactory ---- Aspose.Slides.Effects.IImageTransformOperationFactory
Aspose.Slides.Effects.InnerShadow ---- Aspose.Slides.Effects.IInnerShadow
Aspose.Slides.Effects.IOuterShadow
Aspose.Slides.Effects.IOuterShadowEffectiveData
Aspose.Slides.Effects.IPresetShadow
Aspose.Slides.Effects.IPresetShadowEffectiveData
Aspose.Slides.Effects.IReflection
Aspose.Slides.Effects.IReflectionEffectiveData
Aspose.Slides.Effects.ISoftEdge
Aspose.Slides.Effects.ISoftEdgeEffectiveData
Aspose.Slides.Effects.ITint ---- Aspose.Slides.Effects.IImageTransformOperation, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Effects.ITintEffectiveData
Aspose.Slides.Effects.OuterShadow ---- Aspose.Slides.Effects.IOuterShadow
Aspose.Slides.Effects.PresetShadow ---- Aspose.Slides.Effects.IPresetShadow
Aspose.Slides.Effects.Reflection ---- Aspose.Slides.Effects.IReflection
Aspose.Slides.Effects.SoftEdge ---- Aspose.Slides.Effects.ISoftEdge

See Also

Aspose.Slides.Effects Namespace


ISaveOptions Hierarchy

Aspose.Slides.Export.ISaveOptions
IHtmlOptions
IPdfOptions
IPptOptions
IPptxOptions
ISVGOptions
ITiffOptions
IXpsOptions

See Also

ISaveOptions Interface | ISaveOptions Members | Aspose.Slides.Export Namespace


SaveOptions Hierarchy

System.Object
SaveOptions
HtmlOptions
PdfOptions
PptOptions
PptxOptions
SVGOptions
TiffOptions
XpsOptions

See Also

SaveOptions Class | SaveOptions Members | Aspose.Slides.Export Namespace


Aspose.Slides.ExportHierarchy

Aspose.Slides Documentation

Aspose.Slides.Export Hierarchy

System.Object
Aspose.Slides.Export.HtmlFormatter ---- Aspose.Slides.Export.IHtmlFormatter
Aspose.Slides.Export.HtmlGenerator ---- Aspose.Slides.Export.IHtmlGenerator
Aspose.Slides.Export.IHtmlFormatter
Aspose.Slides.Export.IHtmlFormattingController
Aspose.Slides.Export.IHtmlGenerator
Aspose.Slides.Export.IHtmlOptions ---- Aspose.Slides.Export.ISaveOptions
Aspose.Slides.Export.ILinkEmbedController
Aspose.Slides.Export.IPdfOptions ---- Aspose.Slides.Export.ISaveOptions
Aspose.Slides.Export.IPptOptions ---- Aspose.Slides.Export.ISaveOptions
Aspose.Slides.Export.IPptxOptions ---- Aspose.Slides.Export.ISaveOptions
Aspose.Slides.Export.ISaveOptions
Aspose.Slides.Export.ISaveOptionsFactory
Aspose.Slides.Export.ISlideImageFormat
Aspose.Slides.Export.ISVGOptions ---- Aspose.Slides.Export.ISaveOptions
Aspose.Slides.Export.ISvgShape
Aspose.Slides.Export.ISvgShapeFormattingController
Aspose.Slides.Export.ITextToHtmlConversionOptions
Aspose.Slides.Export.ITiffOptions ---- Aspose.Slides.Export.ISaveOptions
Aspose.Slides.Export.IXpsOptions ---- Aspose.Slides.Export.ISaveOptions
Aspose.Slides.Export.SaveOptions ---- Aspose.Slides.Export.ISaveOptions
Aspose.Slides.Export.HtmlOptions ---- Aspose.Slides.Export.IHtmlOptions
Aspose.Slides.Export.PdfOptions ---- Aspose.Slides.Export.IPdfOptions
Aspose.Slides.Export.PptOptions ---- Aspose.Slides.Export.IPptOptions
Aspose.Slides.Export.PptxOptions ---- Aspose.Slides.Export.IPptxOptions
Aspose.Slides.Export.SVGOptions ---- Aspose.Slides.Export.ISVGOptions
Aspose.Slides.Export.TiffOptions ---- Aspose.Slides.Export.ITiffOptions
Aspose.Slides.Export.XpsOptions ---- Aspose.Slides.Export.IXpsOptions
Aspose.Slides.Export.SaveOptionsFactory ---- Aspose.Slides.Export.ISaveOptionsFactory
Aspose.Slides.Export.SlideImageFormat ---- Aspose.Slides.Export.ISlideImageFormat
Aspose.Slides.Export.SvgShape ---- Aspose.Slides.Export.ISvgShape
Aspose.Slides.Export.TextToHtmlConversionOptions ---- Aspose.Slides.Export.ITextToHtmlConversionOptions
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Drawing.Printing.PrintDocument
Aspose.Slides.Export.PresentationPrintDocument
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Slides.Export.LinkEmbedDecision
Aspose.Slides.Export.PdfCompliance
Aspose.Slides.Export.PdfTextCompression
Aspose.Slides.Export.SaveFormat
Aspose.Slides.Export.SvgCoordinateUnit
Aspose.Slides.Export.SvgEvent
Aspose.Slides.Export.TextInheritanceLimit
Aspose.Slides.Export.TiffCompressionTypes

See Also

Aspose.Slides.Export Namespace


IBaseSlide Hierarchy

Aspose.Slides.IBaseSlide
ILayoutSlide
IMasterHandoutSlide
IMasterNotesSlide
IMasterSlide
INotesSlide
ISlide

See Also

IBaseSlide Interface | IBaseSlide Members | Aspose.Slides Namespace


IFillParamSource Hierarchy

Aspose.Slides.IFillParamSource
IColorFormat
IFillFormat
IGradientFormat
ILineFillFormat
ILineFillFormatEffectiveData
IPictureFillFormat
IPictureFillFormatEffectiveData

See Also

IFillParamSource Interface | Aspose.Slides Namespace


IHyperlinkContainer Hierarchy

Aspose.Slides.IHyperlinkContainer
IChart
IAudioFrame
IAutoShape
IConnector
IGeometryShape
IGraphicalObject
IGroupShape
IOleObjectFrame
IPictureFrame
IPortionFormat
IShape
ITable
IVideoFrame
ISmartArt

See Also

IHyperlinkContainer Interface | IHyperlinkContainer Members | Aspose.Slides Namespace


Aspose.Slides.ImportHierarchy

Aspose.Slides Documentation

Aspose.Slides.Import Hierarchy

System.Object
Aspose.Slides.Import.HtmlExternalResolver ---- Aspose.Slides.Import.IHtmlExternalResolver
Aspose.Slides.Import.IHtmlExternalResolver

See Also

Aspose.Slides.Import Namespace


IPresentationComponent Hierarchy

Aspose.Slides.IPresentationComponent
IChart
IAlphaBiLevel
IAlphaCeiling
IAlphaFloor
IAlphaInverse
IAlphaModulate
IAlphaModulateFixed
IAlphaReplace
IBiLevel
IBlur
IColorChange
IColorReplace
IDuotone
IFillOverlay
IGrayScale
IHSL
IImageTransformOperation
IImageTransformOperationCollection
ILuminance
ITint
IAudioFrame
IAutoShape
IBackground
IBaseSlide
ICell
ICellCollection
IColumn
IConnector
IControl
IEffectFormat
IField
IFillFormat
IGeometryShape
IGradientFormat
IGradientStopCollection
IGraphicalObject
IGroupShape
ILayoutSlide
ILineFillFormat
ILineFormat
IMasterHandoutSlide
IMasterNotesSlide
IMasterSlide
INotesSlide
IOleObjectFrame
IParagraph
IParagraphCollection
IParagraphFormat
IParagraphFormatEffectiveData
IPatternFormat
IPictureFillFormat
IPictureFrame
IPortion
IRow
IShape
IShapeStyle
ISlide
ISlideComponent
ISlidesPicture
ITable
ITextFrame
ITextFrameFormat
ITextStyle
IThreeDFormat
IVideoFrame
ISmartArt
IColorScheme
IFormatScheme
IMasterTheme
IMasterThemeable
IOverrideTheme
IOverrideThemeable
ITheme
IThemeable

See Also

IPresentationComponent Interface | IPresentationComponent Members | Aspose.Slides Namespace


IShape Hierarchy

Aspose.Slides.IShape
IChart
IAudioFrame
IAutoShape
IConnector
IGeometryShape
IGraphicalObject
IGroupShape
IOleObjectFrame
IPictureFrame
ITable
IVideoFrame
ISmartArt

See Also

IShape Interface | IShape Members | Aspose.Slides Namespace


ISlideComponent Hierarchy

Aspose.Slides.ISlideComponent
IChart
IAlphaBiLevel
IAlphaCeiling
IAlphaFloor
IAlphaInverse
IAlphaModulate
IAlphaModulateFixed
IAlphaReplace
IBiLevel
IBlur
IColorChange
IColorReplace
IDuotone
IFillOverlay
IGrayScale
IHSL
IImageTransformOperation
IImageTransformOperationCollection
ILuminance
ITint
IAudioFrame
IAutoShape
IBackground
IBaseSlide
ICell
ICellCollection
IColumn
IConnector
IControl
IEffectFormat
IField
IFillFormat
IGeometryShape
IGradientFormat
IGradientStopCollection
IGraphicalObject
IGroupShape
ILayoutSlide
ILineFillFormat
ILineFormat
IMasterHandoutSlide
IMasterNotesSlide
IMasterSlide
INotesSlide
IOleObjectFrame
IParagraph
IParagraphCollection
IParagraphFormat
IParagraphFormatEffectiveData
IPatternFormat
IPictureFillFormat
IPictureFrame
IPortion
IRow
IShape
IShapeStyle
ISlide
ISlidesPicture
ITable
ITextFrame
ITextFrameFormat
ITextStyle
IThreeDFormat
IVideoFrame
ISmartArt
IColorScheme
IFormatScheme
IMasterThemeable
IOverrideThemeable
IThemeable

See Also

ISlideComponent Interface | ISlideComponent Members | Aspose.Slides Namespace


Aspose.Slides.OdpHierarchy

Aspose.Slides Documentation

Aspose.Slides.Odp Hierarchy

System.Object
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Slides.Odp.OdpException
Aspose.Slides.Odp.OdpReadException

See Also

Aspose.Slides.Odp Namespace


ITransitionValueBase Hierarchy

Aspose.Slides.SlideShow.ITransitionValueBase
ICornerDirectionTransition
IEightDirectionTransition
IEmptyTransition
IInOutTransition
IOptionalBlackTransition
IOrientationTransition
ISideDirectionTransition
ISplitTransition
IWheelTransition

See Also

ITransitionValueBase Interface | Aspose.Slides.SlideShow Namespace


TransitionValueBase Hierarchy

System.Object
TransitionValueBase
CornerDirectionTransition
EightDirectionTransition
EmptyTransition
InOutTransition
OptionalBlackTransition
OrientationTransition
SideDirectionTransition
SplitTransition
WheelTransition

See Also

TransitionValueBase Class | TransitionValueBase Members | Aspose.Slides.SlideShow Namespace


Aspose.Slides.SlideShowHierarchy

Aspose.Slides Documentation

Aspose.Slides.SlideShow Hierarchy

System.Object
Aspose.Slides.SlideShow.ICornerDirectionTransition ---- Aspose.Slides.SlideShow.ITransitionValueBase
Aspose.Slides.SlideShow.IEightDirectionTransition ---- Aspose.Slides.SlideShow.ITransitionValueBase
Aspose.Slides.SlideShow.IEmptyTransition ---- Aspose.Slides.SlideShow.ITransitionValueBase
Aspose.Slides.SlideShow.IInOutTransition ---- Aspose.Slides.SlideShow.ITransitionValueBase
Aspose.Slides.SlideShow.IOptionalBlackTransition ---- Aspose.Slides.SlideShow.ITransitionValueBase
Aspose.Slides.SlideShow.IOrientationTransition ---- Aspose.Slides.SlideShow.ITransitionValueBase
Aspose.Slides.SlideShow.ISideDirectionTransition ---- Aspose.Slides.SlideShow.ITransitionValueBase
Aspose.Slides.SlideShow.ISplitTransition ---- Aspose.Slides.SlideShow.ITransitionValueBase
Aspose.Slides.SlideShow.ITransitionValueBase
Aspose.Slides.SlideShow.ITransitionValueFactory
Aspose.Slides.SlideShow.IWheelTransition ---- Aspose.Slides.SlideShow.ITransitionValueBase
Aspose.Slides.SlideShow.SlideShowTransition ---- Aspose.Slides.ISlideShowTransition
Aspose.Slides.SlideShow.TransitionValueBase ---- Aspose.Slides.SlideShow.ITransitionValueBase
Aspose.Slides.SlideShow.CornerDirectionTransition ---- Aspose.Slides.SlideShow.ICornerDirectionTransition
Aspose.Slides.SlideShow.EightDirectionTransition ---- Aspose.Slides.SlideShow.IEightDirectionTransition
Aspose.Slides.SlideShow.EmptyTransition ---- Aspose.Slides.SlideShow.IEmptyTransition
Aspose.Slides.SlideShow.InOutTransition ---- Aspose.Slides.SlideShow.IInOutTransition
Aspose.Slides.SlideShow.OptionalBlackTransition ---- Aspose.Slides.SlideShow.IOptionalBlackTransition
Aspose.Slides.SlideShow.OrientationTransition ---- Aspose.Slides.SlideShow.IOrientationTransition
Aspose.Slides.SlideShow.SideDirectionTransition ---- Aspose.Slides.SlideShow.ISideDirectionTransition
Aspose.Slides.SlideShow.SplitTransition ---- Aspose.Slides.SlideShow.ISplitTransition
Aspose.Slides.SlideShow.WheelTransition ---- Aspose.Slides.SlideShow.IWheelTransition
Aspose.Slides.SlideShow.TransitionValueFactory ---- Aspose.Slides.SlideShow.ITransitionValueFactory
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Slides.SlideShow.TransitionCornerDirectionType
Aspose.Slides.SlideShow.TransitionEightDirectionType
Aspose.Slides.SlideShow.TransitionInOutDirectionType
Aspose.Slides.SlideShow.TransitionSideDirectionType
Aspose.Slides.SlideShow.TransitionSoundMode
Aspose.Slides.SlideShow.TransitionSpeed
Aspose.Slides.SlideShow.TransitionType

See Also

Aspose.Slides.SlideShow Namespace


Aspose.Slides.SmartArtHierarchy

Aspose.Slides Documentation

Aspose.Slides.SmartArt Hierarchy

System.Object
Aspose.Slides.Shape ---- Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.GraphicalObject ---- Aspose.Slides.IGraphicalObject
Aspose.Slides.SmartArt.SmartArt ---- Aspose.Slides.SmartArt.ISmartArt
Aspose.Slides.SmartArt.ISmartArt ---- Aspose.Slides.IGraphicalObject, Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.SmartArt.ISmartArtNode
Aspose.Slides.SmartArt.ISmartArtNodeCollection ---- System.Collections.IEnumerable
Aspose.Slides.SmartArt.SmartArtNode ---- Aspose.Slides.SmartArt.ISmartArtNode
Aspose.Slides.SmartArt.SmartArtNodeCollection ---- Aspose.Slides.SmartArt.ISmartArtNodeCollection, System.Collections.IEnumerable
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Slides.SmartArt.SmartArtColorType
Aspose.Slides.SmartArt.SmartArtLayoutType
Aspose.Slides.SmartArt.SmartArtQuickStyleType

See Also

Aspose.Slides.SmartArt Namespace


IThemeable Hierarchy

Aspose.Slides.Theme.IThemeable
IChart
IBaseSlide
ILayoutSlide
IMasterHandoutSlide
IMasterNotesSlide
IMasterSlide
INotesSlide
ISlide
IMasterThemeable
IOverrideThemeable

See Also

IThemeable Interface | IThemeable Members | Aspose.Slides.Theme Namespace


Aspose.Slides.ThemeHierarchy

Aspose.Slides Documentation

Aspose.Slides.Theme Hierarchy

System.Object
Aspose.Slides.Theme.BaseThemeManager
Aspose.Slides.Theme.BaseOverrideThemeManager ---- Aspose.Slides.Theme.IOverrideThemeManager, Aspose.Slides.Theme.IThemeManager
Aspose.Slides.Theme.ChartThemeManager
Aspose.Slides.Theme.LayoutSlideThemeManager
Aspose.Slides.Theme.NotesSlideThemeManager
Aspose.Slides.Theme.SlideThemeManager
Aspose.Slides.Theme.MasterThemeManager ---- Aspose.Slides.Theme.IMasterThemeManager, Aspose.Slides.Theme.IThemeManager
Aspose.Slides.Theme.ColorScheme ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IColorScheme
Aspose.Slides.Theme.ColorSchemeEffectiveData ---- Aspose.Slides.Theme.IColorSchemeEffectiveData
Aspose.Slides.Theme.EffectStyle ---- Aspose.Slides.Theme.IEffectStyle
Aspose.Slides.Theme.EffectStyleCollection ---- Aspose.Slides.Theme.IEffectStyleCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Theme.IEffectStyle, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.EffectStyleCollectionEffectiveData ---- Aspose.Slides.Theme.IEffectStyleCollectionEffectiveData, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Theme.IEffectStyleEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.EffectStyleEffectiveData ---- Aspose.Slides.Theme.IEffectStyleEffectiveData
Aspose.Slides.Theme.ExtraColorScheme ---- Aspose.Slides.Theme.IExtraColorScheme
Aspose.Slides.Theme.ExtraColorSchemeCollection ---- Aspose.Slides.Theme.IExtraColorSchemeCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Theme.IExtraColorScheme, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.FillFormatCollection ---- Aspose.Slides.Theme.IFillFormatCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IFillFormat, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.FillFormatCollectionEffectiveData ---- Aspose.Slides.Theme.IFillFormatCollectionEffectiveData, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IFillFormatEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.FontScheme ---- Aspose.Slides.Theme.IFontScheme
Aspose.Slides.Theme.FontSchemeEffectiveData ---- Aspose.Slides.Theme.IFontSchemeEffectiveData
Aspose.Slides.Theme.FormatScheme ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IFormatScheme
Aspose.Slides.Theme.FormatSchemeEffectiveData ---- Aspose.Slides.Theme.IFormatSchemeEffectiveData
Aspose.Slides.Theme.IColorScheme ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Theme.IColorSchemeEffectiveData
Aspose.Slides.Theme.IEffectStyle
Aspose.Slides.Theme.IEffectStyleCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Theme.IEffectStyle, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.IEffectStyleCollectionEffectiveData ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Theme.IEffectStyleEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.IEffectStyleEffectiveData
Aspose.Slides.Theme.IExtraColorScheme
Aspose.Slides.Theme.IExtraColorSchemeCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.Theme.IExtraColorScheme, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.IFillFormatCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IFillFormat, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.IFillFormatCollectionEffectiveData ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IFillFormatEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.IFontScheme
Aspose.Slides.Theme.IFontSchemeEffectiveData
Aspose.Slides.Theme.IFormatScheme ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Theme.IFormatSchemeEffectiveData
Aspose.Slides.Theme.ILineFormatCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ILineFormat, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.ILineFormatCollectionEffectiveData ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ILineFormatEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.IMasterTheme ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.Theme.ITheme
Aspose.Slides.Theme.IMasterThemeable ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IThemeable
Aspose.Slides.Theme.IMasterThemeManager ---- Aspose.Slides.Theme.IThemeManager
Aspose.Slides.Theme.IOverrideTheme ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.Theme.ITheme
Aspose.Slides.Theme.IOverrideThemeable ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IThemeable
Aspose.Slides.Theme.IOverrideThemeManager ---- Aspose.Slides.Theme.IThemeManager
Aspose.Slides.Theme.ITheme ---- Aspose.Slides.IPresentationComponent
Aspose.Slides.Theme.IThemeable ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.Theme.IThemeEffectiveData
Aspose.Slides.Theme.IThemeManager
Aspose.Slides.Theme.LineFormatCollection ---- Aspose.Slides.Theme.ILineFormatCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ILineFormat, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.LineFormatCollectionEffectiveData ---- Aspose.Slides.Theme.ILineFormatCollectionEffectiveData, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ILineFormatEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Theme.Theme ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.Theme.ITheme
Aspose.Slides.Theme.MasterTheme ---- Aspose.Slides.Theme.IMasterTheme
Aspose.Slides.Theme.OverrideTheme ---- Aspose.Slides.Theme.IOverrideTheme
Aspose.Slides.Theme.ThemeEffectiveData ---- Aspose.Slides.Theme.IThemeEffectiveData

See Also

Aspose.Slides.Theme Namespace


Aspose.Slides.UtilHierarchy

Aspose.Slides Documentation

Aspose.Slides.Util Hierarchy

System.Object
Aspose.Slides.Util.SlideUtil

See Also

Aspose.Slides.Util Namespace


Aspose.Slides.WarningsHierarchy

Aspose.Slides Documentation

Aspose.Slides.Warnings Hierarchy

System.Object
Aspose.Slides.Warnings.IKnownIssueWarningInfo ---- Aspose.Slides.Warnings.IWarningInfo
Aspose.Slides.Warnings.INotImplementedWarningInfo ---- Aspose.Slides.Warnings.IWarningInfo
Aspose.Slides.Warnings.IPresentationSignedWarningInfo ---- Aspose.Slides.Warnings.IWarningInfo
Aspose.Slides.Warnings.IWarningCallback
Aspose.Slides.Warnings.IWarningInfo
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Slides.Warnings.ReturnAction
Aspose.Slides.Warnings.WarningType

See Also

Aspose.Slides.Warnings Namespace


Aspose.SlidesHierarchy

Aspose.Slides Documentation

Aspose.Slides Hierarchy

System.Object
Aspose.Slides.AdjustValue ---- Aspose.Slides.IAdjustValue
Aspose.Slides.AdjustValueCollection ---- Aspose.Slides.IAdjustValueCollection, System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Audio ---- Aspose.Slides.IAudio
Aspose.Slides.AudioCollection ---- Aspose.Slides.IAudioCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IAudio, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Backdrop3DScene ---- Aspose.Slides.IBackdrop3DScene
Aspose.Slides.Background ---- Aspose.Slides.IBackground, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.BaseShapeLock ---- Aspose.Slides.IBaseShapeLock
Aspose.Slides.AutoShapeLock ---- Aspose.Slides.IAutoShapeLock
Aspose.Slides.ConnectorLock ---- Aspose.Slides.IConnectorLock
Aspose.Slides.GraphicalObjectLock ---- Aspose.Slides.IGraphicalObjectLock
Aspose.Slides.GroupShapeLock ---- Aspose.Slides.IGroupShapeLock
Aspose.Slides.PictureFrameLock ---- Aspose.Slides.IPictureFrameLock
Aspose.Slides.BaseSlide ---- Aspose.Slides.IBaseSlide, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IThemeable
Aspose.Slides.LayoutSlide ---- Aspose.Slides.ILayoutSlide, Aspose.Slides.Theme.IOverrideThemeable
Aspose.Slides.MasterHandoutSlide ---- Aspose.Slides.IMasterHandoutSlide, Aspose.Slides.Theme.IMasterThemeable
Aspose.Slides.MasterNotesSlide ---- Aspose.Slides.IMasterNotesSlide, Aspose.Slides.Theme.IMasterThemeable
Aspose.Slides.MasterSlide ---- Aspose.Slides.IMasterSlide, Aspose.Slides.Theme.IMasterThemeable
Aspose.Slides.NotesSlide ---- Aspose.Slides.INotesSlide, Aspose.Slides.Theme.IOverrideThemeable
Aspose.Slides.Slide ---- Aspose.Slides.ISlide, Aspose.Slides.Theme.IOverrideThemeable
Aspose.Slides.BuildVersionInfo
Aspose.Slides.BulletFormat ---- Aspose.Slides.IBulletFormat
Aspose.Slides.BulletFormatEffectiveData ---- Aspose.Slides.IBulletFormatEffectiveData
Aspose.Slides.Camera ---- Aspose.Slides.ICamera
Aspose.Slides.Cell ---- Aspose.Slides.ICell, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.CellCollection ---- Aspose.Slides.ICellCollection, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Column ---- Aspose.Slides.IColumn
Aspose.Slides.Row ---- Aspose.Slides.IRow
Aspose.Slides.ColorFormat ---- Aspose.Slides.IColorFormat, Aspose.Slides.IFillParamSource
Aspose.Slides.ColorOperation ---- Aspose.Slides.IColorOperation
Aspose.Slides.ColorOperationCollection ---- Aspose.Slides.IColorOperationCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IColorOperation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable, System.ICloneable
Aspose.Slides.ColumnCollection ---- Aspose.Slides.IColumnCollection, System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Comment ---- Aspose.Slides.IComment
Aspose.Slides.CommentAuthor ---- Aspose.Slides.ICommentAuthor
Aspose.Slides.CommentAuthorCollection ---- Aspose.Slides.ICommentAuthorCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ICommentAuthor, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.CommentCollection ---- Aspose.Slides.ICommentCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IComment, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Control ---- Aspose.Slides.IControl, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.ControlCollection ---- Aspose.Slides.IControlCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IControl, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.ControlPropertiesCollection ---- Aspose.Slides.IControlPropertiesCollection, System.Collections.Generic.IEnumerable`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.IEnumerable
Aspose.Slides.CustomData ---- Aspose.Slides.ICustomData
Aspose.Slides.DocumentProperties ---- Aspose.Slides.IDocumentProperties
Aspose.Slides.EffectFormat ---- Aspose.Slides.IEffectFormat, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.EffectFormatEffectiveData ---- Aspose.Slides.IEffectFormatEffectiveData
Aspose.Slides.Field ---- Aspose.Slides.IField, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.FieldType ---- Aspose.Slides.IFieldType
Aspose.Slides.FillFormat ---- Aspose.Slides.IFillFormat, Aspose.Slides.IFillParamSource, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.FillFormatEffectiveData ---- Aspose.Slides.IFillFormatEffectiveData
Aspose.Slides.FontData ---- Aspose.Slides.IFontData
Aspose.Slides.FontDataFactory ---- Aspose.Slides.IFontDataFactory
Aspose.Slides.Fonts ---- Aspose.Slides.IFonts
Aspose.Slides.FontsEffectiveData ---- Aspose.Slides.IFontsEffectiveData
Aspose.Slides.FontsLoader ---- Aspose.Slides.IFontsLoader
Aspose.Slides.GradientFormat ---- Aspose.Slides.IFillParamSource, Aspose.Slides.IGradientFormat, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.GradientFormatEffectiveData ---- Aspose.Slides.IGradientFormatEffectiveData
Aspose.Slides.GradientStop ---- Aspose.Slides.IGradientStop
Aspose.Slides.GradientStopCollection ---- Aspose.Slides.IGradientStopCollection, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IGradientStop, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.GradientStopCollectionEffectiveData ---- Aspose.Slides.IGradientStopCollectionEffectiveData, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IGradientStopEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.GradientStopEffectiveData ---- Aspose.Slides.IGradientStopEffectiveData
Aspose.Slides.HeaderFooterManager ---- Aspose.Slides.IHeaderFooterManager
Aspose.Slides.Hyperlink ---- Aspose.Slides.IHyperlink
Aspose.Slides.HyperlinkManager ---- Aspose.Slides.IHyperlinkManager
Aspose.Slides.HyperlinkQueries ---- Aspose.Slides.IHyperlinkQueries
Aspose.Slides.IAdjustValue
Aspose.Slides.IAdjustValueCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IAnimationTimeLine
Aspose.Slides.IAudio
Aspose.Slides.IAudioCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IAudio, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IAudioFrame ---- Aspose.Slides.IGeometryShape, Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPictureFrame, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.IAutoShape ---- Aspose.Slides.IGeometryShape, Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.IAutoShapeLock ---- Aspose.Slides.IBaseShapeLock
Aspose.Slides.IBackdrop3DScene
Aspose.Slides.IBackground ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IBaseShapeLock
Aspose.Slides.IBaseSlide ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IThemeable
Aspose.Slides.IBulletFormat
Aspose.Slides.IBulletFormatEffectiveData
Aspose.Slides.ICamera
Aspose.Slides.ICameraEffectiveData
Aspose.Slides.ICell ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.ICellCollection ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IColorFormat ---- Aspose.Slides.IFillParamSource
Aspose.Slides.IColorOperation
Aspose.Slides.IColorOperationCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IColorOperation, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable, System.ICloneable
Aspose.Slides.IColumn ---- Aspose.Slides.ICellCollection, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IColumnCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IComment
Aspose.Slides.ICommentAuthor
Aspose.Slides.ICommentAuthorCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ICommentAuthor, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.ICommentCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IComment, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IConnector ---- Aspose.Slides.IGeometryShape, Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.IConnectorLock ---- Aspose.Slides.IBaseShapeLock
Aspose.Slides.IControl ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IControlCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IControl, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IControlPropertiesCollection ---- System.Collections.Generic.IEnumerable`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.IEnumerable
Aspose.Slides.ICustomData
Aspose.Slides.IDocumentProperties
Aspose.Slides.IEffectFormat ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IEffectFormatEffectiveData
Aspose.Slides.IField ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IFieldType
Aspose.Slides.IFillFormat ---- Aspose.Slides.IFillParamSource, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IFillFormatEffectiveData
Aspose.Slides.IFillParamSource
Aspose.Slides.IFontData
Aspose.Slides.IFontDataFactory
Aspose.Slides.IFonts
Aspose.Slides.IFontsEffectiveData
Aspose.Slides.IFontsLoader
Aspose.Slides.IGeometryShape ---- Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.IGlobalLayoutSlideCollection ---- Aspose.Slides.ILayoutSlideCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ILayoutSlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IGradientFormat ---- Aspose.Slides.IFillParamSource, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IGradientFormatEffectiveData
Aspose.Slides.IGradientStop
Aspose.Slides.IGradientStopCollection ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IGradientStop, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IGradientStopCollectionEffectiveData ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IGradientStopEffectiveData, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IGradientStopEffectiveData
Aspose.Slides.IGraphicalObject ---- Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.IGraphicalObjectLock ---- Aspose.Slides.IBaseShapeLock
Aspose.Slides.IGroupShape ---- Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.IGroupShapeLock ---- Aspose.Slides.IBaseShapeLock
Aspose.Slides.IHeaderFooterManager
Aspose.Slides.IHyperlink
Aspose.Slides.IHyperlinkContainer
Aspose.Slides.IHyperlinkManager
Aspose.Slides.IHyperlinkQueries
Aspose.Slides.IImageCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IPPImage, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IImageWrapper ---- System.IDisposable
Aspose.Slides.IImageWrapperFactory
Aspose.Slides.ILayoutSlide ---- Aspose.Slides.IBaseSlide, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IOverrideThemeable, Aspose.Slides.Theme.IThemeable
Aspose.Slides.ILayoutSlideCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ILayoutSlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.ILightRig
Aspose.Slides.ILightRigEffectiveData
Aspose.Slides.ILineFillFormat ---- Aspose.Slides.IFillParamSource, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.ILineFillFormatEffectiveData ---- Aspose.Slides.IFillParamSource
Aspose.Slides.ILineFormat ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.ILineFormatEffectiveData
Aspose.Slides.ILoadOptions
Aspose.Slides.ImageCollection ---- Aspose.Slides.IImageCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IPPImage, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.ImageWrapper ---- Aspose.Slides.IImageWrapper, System.IDisposable
Aspose.Slides.ImageWrapperFactory ---- Aspose.Slides.IImageWrapperFactory
Aspose.Slides.IMasterHandoutSlide ---- Aspose.Slides.IBaseSlide, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IMasterThemeable, Aspose.Slides.Theme.IThemeable
Aspose.Slides.IMasterHandoutSlideManager
Aspose.Slides.IMasterLayoutSlideCollection ---- Aspose.Slides.ILayoutSlideCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ILayoutSlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IMasterNotesSlide ---- Aspose.Slides.IBaseSlide, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IMasterThemeable, Aspose.Slides.Theme.IThemeable
Aspose.Slides.IMasterNotesSlideManager
Aspose.Slides.IMasterSlide ---- Aspose.Slides.IBaseSlide, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IMasterThemeable, Aspose.Slides.Theme.IThemeable
Aspose.Slides.IMasterSlideCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IMasterSlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.INotesSlide ---- Aspose.Slides.IBaseSlide, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IOverrideThemeable, Aspose.Slides.Theme.IThemeable
Aspose.Slides.IOleObjectFrame ---- Aspose.Slides.IGraphicalObject, Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.IParagraph ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IParagraphCollection ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IParagraph, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.IParagraphFactory
Aspose.Slides.IParagraphFormat ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IParagraphFormatEffectiveData ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IPatternFormat ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IPatternFormatEffectiveData
Aspose.Slides.IPictureEffectiveData
Aspose.Slides.IPictureFillFormat ---- Aspose.Slides.IFillParamSource, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IPictureFillFormatEffectiveData ---- Aspose.Slides.IFillParamSource
Aspose.Slides.IPictureFrame ---- Aspose.Slides.IGeometryShape, Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.IPictureFrameLock ---- Aspose.Slides.IBaseShapeLock
Aspose.Slides.IPlaceholder
Aspose.Slides.IPortion ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IPortionCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IPortion, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.IPortionFactory
Aspose.Slides.IPortionFormat ---- Aspose.Slides.IHyperlinkContainer
Aspose.Slides.IPortionFormatEffectiveData
Aspose.Slides.IPPImage
Aspose.Slides.IPresentation ---- System.IDisposable
Aspose.Slides.IPresentationComponent
Aspose.Slides.IPresentationFactory
Aspose.Slides.IProtectionManager
Aspose.Slides.IRow ---- Aspose.Slides.ICellCollection, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IRowCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IShape ---- Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IShapeBevel
Aspose.Slides.IShapeBevelEffectiveData
Aspose.Slides.IShapeCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IShape, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IShapeElement
Aspose.Slides.IShapeFrame ---- System.ICloneable
Aspose.Slides.IShapeStyle ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.ISlide ---- Aspose.Slides.IBaseSlide, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.Theme.IOverrideThemeable, Aspose.Slides.Theme.IThemeable
Aspose.Slides.ISlideCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ISlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.ISlideComponent ---- Aspose.Slides.IPresentationComponent
Aspose.Slides.ISlideShowTransition
Aspose.Slides.ISlideSize
Aspose.Slides.ISlidesPicture ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IStreamWrapper ---- System.IDisposable
Aspose.Slides.IStreamWrapperFactory
Aspose.Slides.ITab ---- System.IComparable
Aspose.Slides.ITabCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ITab, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.ITabEffectiveData ---- System.IComparable
Aspose.Slides.ITabFactory
Aspose.Slides.ITable ---- Aspose.Slides.IGraphicalObject, Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.ITagCollection ---- System.Collections.Generic.IEnumerable`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.ITextFrame ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.ITextFrameFormat ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.ITextStyle ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IThreeDFormat ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.IThreeDFormatEffectiveData
Aspose.Slides.IVideo
Aspose.Slides.IVideoCollection ---- System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IVideo, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.IVideoFrame ---- Aspose.Slides.IGeometryShape, Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPictureFrame, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.LayoutSlideCollection ---- Aspose.Slides.ILayoutSlideCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ILayoutSlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.GlobalLayoutSlideCollection ---- Aspose.Slides.IGlobalLayoutSlideCollection
Aspose.Slides.MasterLayoutSlideCollection ---- Aspose.Slides.IMasterLayoutSlideCollection
Aspose.Slides.License
Aspose.Slides.LightRig ---- Aspose.Slides.ILightRig
Aspose.Slides.LineFillFormat ---- Aspose.Slides.IFillParamSource, Aspose.Slides.ILineFillFormat, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.LineFillFormatEffectiveData ---- Aspose.Slides.IFillParamSource, Aspose.Slides.ILineFillFormatEffectiveData
Aspose.Slides.LineFormat ---- Aspose.Slides.ILineFormat, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.LineFormatEffectiveData ---- Aspose.Slides.ILineFormatEffectiveData
Aspose.Slides.LoadOptions ---- Aspose.Slides.ILoadOptions
Aspose.Slides.MasterSlideCollection ---- Aspose.Slides.IMasterSlideCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IMasterSlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Paragraph ---- Aspose.Slides.IParagraph, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.ParagraphCollection ---- Aspose.Slides.IParagraphCollection, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IParagraph, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.ParagraphFactory ---- Aspose.Slides.IParagraphFactory
Aspose.Slides.ParagraphFormat ---- Aspose.Slides.Charts.IChartParagraphFormat, Aspose.Slides.IParagraphFormat, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.ParagraphFormatEffectiveData ---- Aspose.Slides.IParagraphFormatEffectiveData, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.PatternFormat ---- Aspose.Slides.IPatternFormat, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.PatternFormatEffectiveData ---- Aspose.Slides.IPatternFormatEffectiveData
Aspose.Slides.Picture ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.ISlidesPicture
Aspose.Slides.PictureEffectiveData ---- Aspose.Slides.IPictureEffectiveData
Aspose.Slides.PictureFillFormat ---- Aspose.Slides.IFillParamSource, Aspose.Slides.IPictureFillFormat, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.PictureFillFormatEffectiveData ---- Aspose.Slides.IFillParamSource, Aspose.Slides.IPictureFillFormatEffectiveData
Aspose.Slides.Placeholder ---- Aspose.Slides.IPlaceholder
Aspose.Slides.Portion ---- Aspose.Slides.IPortion, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent
Aspose.Slides.PortionCollection ---- Aspose.Slides.IPortionCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IPortion, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Slides.PortionFactory ---- Aspose.Slides.IPortionFactory
Aspose.Slides.PortionFormat ---- Aspose.Slides.Charts.IChartPortionFormat, Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPortionFormat
Aspose.Slides.PortionFormatEffectiveData ---- Aspose.Slides.IPortionFormatEffectiveData
Aspose.Slides.PPImage ---- Aspose.Slides.IPPImage
Aspose.Slides.Presentation ---- Aspose.Slides.IPresentation, System.IDisposable
Aspose.Slides.PresentationFactory ---- Aspose.Slides.IPresentationFactory
Aspose.Slides.ProtectionManager ---- Aspose.Slides.IProtectionManager
Aspose.Slides.RowCollection ---- Aspose.Slides.IRowCollection, System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.Shape ---- Aspose.Slides.IHyperlinkContainer, Aspose.Slides.IPresentationComponent, Aspose.Slides.IShape, Aspose.Slides.ISlideComponent
Aspose.Slides.GeometryShape ---- Aspose.Slides.IGeometryShape
Aspose.Slides.AutoShape ---- Aspose.Slides.IAutoShape
Aspose.Slides.Connector ---- Aspose.Slides.IConnector
Aspose.Slides.PictureFrame ---- Aspose.Slides.IPictureFrame
Aspose.Slides.AudioFrame ---- Aspose.Slides.IAudioFrame
Aspose.Slides.VideoFrame ---- Aspose.Slides.IVideoFrame
Aspose.Slides.GraphicalObject ---- Aspose.Slides.IGraphicalObject
Aspose.Slides.OleObjectFrame ---- Aspose.Slides.IOleObjectFrame
Aspose.Slides.Table ---- Aspose.Slides.ITable
Aspose.Slides.GroupShape ---- Aspose.Slides.IGroupShape
Aspose.Slides.ShapeBevel ---- Aspose.Slides.IShapeBevel
Aspose.Slides.ShapeCollection ---- Aspose.Slides.IShapeCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IShape, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.ShapeElement ---- Aspose.Slides.IShapeElement
Aspose.Slides.ShapeFrame ---- Aspose.Slides.IShapeFrame, System.ICloneable
Aspose.Slides.ShapeStyle ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.IShapeStyle, Aspose.Slides.ISlideComponent
Aspose.Slides.SlideCollection ---- Aspose.Slides.ISlideCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ISlide, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.SlideSize ---- Aspose.Slides.ISlideSize
Aspose.Slides.StreamWrapper ---- Aspose.Slides.IStreamWrapper, System.IDisposable
Aspose.Slides.StreamWrapperFactory ---- Aspose.Slides.IStreamWrapperFactory
Aspose.Slides.Tab ---- Aspose.Slides.ITab, System.IComparable
Aspose.Slides.TabCollection ---- Aspose.Slides.ITabCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.ITab, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.TabEffectiveData ---- Aspose.Slides.ITabEffectiveData, System.IComparable
Aspose.Slides.TabFactory ---- Aspose.Slides.ITabFactory
Aspose.Slides.TagCollection ---- Aspose.Slides.ITagCollection, System.Collections.Generic.IEnumerable`1[[System.Collections.Generic.KeyValuePair`2[[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[System.String, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Slides.TextFrame ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.ITextFrame
Aspose.Slides.TextFrameFormat ---- Aspose.Slides.Charts.IChartTextBlockFormat, Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.ITextFrameFormat
Aspose.Slides.TextStyle ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.ITextStyle
Aspose.Slides.ThreeDFormat ---- Aspose.Slides.IPresentationComponent, Aspose.Slides.ISlideComponent, Aspose.Slides.IThreeDFormat
Aspose.Slides.ThreeDFormatEffectiveData ---- Aspose.Slides.IThreeDFormatEffectiveData
Aspose.Slides.Video ---- Aspose.Slides.IVideo
Aspose.Slides.VideoCollection ---- Aspose.Slides.IVideoCollection, System.Collections.Generic.IEnumerable`1[[Aspose.Slides.IVideo, Aspose.Slides, Version=14.4.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.ICollection, System.Collections.IEnumerable
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Slides.InvalidPasswordException
Aspose.Slides.OOXMLException
Aspose.Slides.OOXMLCorruptFileException
Aspose.Slides.PptxException
Aspose.Slides.PptxEditException
Aspose.Slides.PptxReadException
Aspose.Slides.PptxUnsupportedFormatException
Aspose.Slides.PptException
Aspose.Slides.PptEditException
Aspose.Slides.PptReadException
Aspose.Slides.PptCorruptFileException
Aspose.Slides.PptUnsupportedFormatException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Slides.AudioPlayModePreset
Aspose.Slides.AudioVolumeMode
Aspose.Slides.BackgroundType
Aspose.Slides.BevelColorMode
Aspose.Slides.BevelPresetType
Aspose.Slides.BlackWhiteMode
Aspose.Slides.BulletType
Aspose.Slides.CameraPresetType
Aspose.Slides.ColorSchemeIndex
Aspose.Slides.ColorStringFormat
Aspose.Slides.ColorTransformOperation
Aspose.Slides.ColorType
Aspose.Slides.ControlType
Aspose.Slides.FillBlendMode
Aspose.Slides.FillType
Aspose.Slides.FontAlignment
Aspose.Slides.FontCollectionIndex
Aspose.Slides.GradientDirection
Aspose.Slides.GradientShape
Aspose.Slides.HyperlinkActionType
Aspose.Slides.LightingDirection
Aspose.Slides.LightRigPresetType
Aspose.Slides.LineAlignment
Aspose.Slides.LineArrowheadLength
Aspose.Slides.LineArrowheadStyle
Aspose.Slides.LineArrowheadWidth
Aspose.Slides.LineCapStyle
Aspose.Slides.LineDashStyle
Aspose.Slides.LineJoinStyle
Aspose.Slides.LineStyle
Aspose.Slides.LoadFormat
Aspose.Slides.MaterialPresetType
Aspose.Slides.NullableBool
Aspose.Slides.NumberedBulletStyle
Aspose.Slides.Orientation
Aspose.Slides.PatternStyle
Aspose.Slides.PictureFillMode
Aspose.Slides.PlaceholderSize
Aspose.Slides.PlaceholderType
Aspose.Slides.PPImageFormat
Aspose.Slides.PresetColor
Aspose.Slides.PresetShadowType
Aspose.Slides.RectangleAlignment
Aspose.Slides.SchemeColor
Aspose.Slides.ShapeElementFillSource
Aspose.Slides.ShapeElementStrokeSource
Aspose.Slides.ShapeThumbnailBounds
Aspose.Slides.ShapeType
Aspose.Slides.SlideLayoutType
Aspose.Slides.SlideOrienation
Aspose.Slides.SlideSizeType
Aspose.Slides.SourceFormat
Aspose.Slides.SystemColor
Aspose.Slides.TabAlignment
Aspose.Slides.TableStylePreset
Aspose.Slides.TextAlignment
Aspose.Slides.TextAnchorType
Aspose.Slides.TextAutofitType
Aspose.Slides.TextCapType
Aspose.Slides.TextShapeType
Aspose.Slides.TextStrikethroughType
Aspose.Slides.TextUnderlineType
Aspose.Slides.TextVerticalOverflowType
Aspose.Slides.TextVerticalType
Aspose.Slides.TileFlip
Aspose.Slides.VideoPlayModePreset

See Also

Aspose.Slides Namespace


SmartAssembly.AttributesHierarchy

Aspose.Slides Documentation

SmartAssembly.Attributes Hierarchy

System.Object
System.Attribute
SmartAssembly.Attributes.PoweredByAttribute

See Also

SmartAssembly.Attributes Namespace