Aspose.Tasks for .NET API Reference

The Aspose.Tasks class library provides the following namespaces:

Aspose.Tasks
Contains classes for work with Microsoft Project documents without utilizing Microsoft Project.
Aspose.Tasks.Saving
Contains classes for saving a project to different formats.
Aspose.Tasks.Util
Contains helper classes for project structures management.
Aspose.Tasks.Visualization
Contains helper classes for Gantt chart rendering.

We guarantee a prompt response to any inquiry!

© 2003-2013 Aspose Pty Ltd. All rights reserved.


Aspose.Tasks

Aspose.Tasks Documentation

Aspose.Tasks Namespace

Namespace hierarchy

Classes

Class | Description
AssignmentBaseline | Represents Baseline of a resource assignment.
AvailabilityPeriod | Represents a period when a resource is available.
Baseline | Represents baseline values of a resource.
BuildVersionInfo | Contains build version and product information.
Calendar | Represents a calendar used in a project.
CalendarException | Represent exceptional time periods in a calendar.
ExtendedAttribute | Represents extended attributes.
ExtendedAttributeDefinition | Represents an extended attribute definition associated with a project.
Filter | Represents a filter in Project.
FilterCriteria | Defines the criteria that tasks or resources must meet to be displayed in MSP view.
Filters | Contains a list of Filter objects. Implements ICollection<Filter> interface.
GanttChartView | Represents a GanttChart view.
Group | Represents a group definition. A Group object is a member of the ResourceGroups collection or the TaskGroups collection.
GroupCriteria | Contains a collection of GroupCriterion objects. Implements ICollection<GroupCriterion> interface.
GroupCriterion | Represents a criterion in a group definition. The GroupCriterion object is a member of the GroupCriteria collection.
Groups | Contains a list of Group objects. Implements ICollection<Group> interface.
License | Provides methods to license the component.
OutlineCode | Represents a value of an outline code.
OutlineCodeDefinition | Represents an outline code definition.
OutlineMask | Represents four elements of a mask which defines an outline code format.
OutlineValue | Represents an outline value.
Project | Represents a project.
ProjectFileInfo | The class instance contains information about project file format and version of Microsoft Project where the file was created.
ProjectReader | Represents a class to read Project files in MPP, XML and MPX formats.
ProjectWriter | Represents a class to write Project to various file formats. Currently the only XML format is supported for writing.
Rate | Represents a definition of a time period and rates applicable for a resource during that period.
Resource | Represents a resource in a project.
ResourceAssignment | Represents a resource assignment.
SplitPart | Represents a task portion. The SplitPart is a member of the task's SplitParts collection.
SplitPartCollection | Collection that represents the portions of a task.
Table | Represents a table in Project
TableField | Represents a field of a table in Project.
TableFields | Contains a list of TableField objects. Implements IList<TableField> interface.
Tables | Contains a list of Table objects. Implements ICollection<Table> interface.
Task | Represents a task in a project.
TaskBaseline | Represents Baseline of a Task.
TaskLink | Represents a predecessor link.
TasksException | Represents the standard internal exception type.
TasksReadingException | Represents the standard internal reading exception type.
TasksWritingException | Represents the standard internal writing exception type.
TimephasedData | Represents a time phased data.
Value | Represents a value in a value list.
View | Represents a view in Project.
Views | Contains a list of View objects. Implements ICollection<View> interface.
WeekDay | Represents a weekday which either defines regular days of a week or exception days in a calendar.
WorkDay | Represents a work day.
WorkingTime | Represents a working time during a weekday.
WorkUnit | Represents working hours.
WorkWeek | Represents a work week.

Delegates

Delegate | Description
ProjectXMLCreationFinished | Project XML data creation finished delegate for XML data postprocessing.
ProjectXMLParsingStarted | Project's XML parsing start delegate for XML data preprocessing.
TaskXMLCreationFinished | Task's XML element creation finished delegate for XML data postprocessing.
TaskXMLParsingFinished | Task's XML parsing finish delegate for task's XML custom data processing.

Enumerations

Enumeration | Description
ApplicationInfo | Specifies the project version where the file was created.
BackgroundPattern | Specifies the background pattern.
BaselineType | Specifies the baseline type used to calculate Variance values.
BookingType | Specifies the booking type of a resource.
CalculationType | Specifies the calculation type.
CalendarExceptionType | Specifies the calendar exception type.
ConstraintType | Specifies the constraint on the start or finish date of a task.
CostAccrualType | Specifies the type of an accrual cost.
CurrencySymbolPositionType | Specifies the position of a currency symbol.
CustomFieldType | Specifies the type of a custom field.
DayType | Specifies the day of a week.
EarnedValueMethodType | Specifies the method used for calculating earned value.
ElementType | Specifies the type of an element.
ExtendedAttributeResource | Specifies the extended attributes FieldId used in a resource.
ExtendedAttributeTask | Specifies the extended attributes FieldId used in a task.
Field | Specifies a field in the Microsoft Office Project.
FileFormat | Specifies the project's file format.
FilterComparisonType | The type of comparison made between FieldName and Value that acts as selection criteria for the filter.
FilterOperation | Specifies how the criterion established with FieldName, FilterComparisonType, and Value relates to other criteria in the filter.
GanttBarSize | Specifies the height of a bar in points.
GroupOn | Specifes the type of grouping.
ItemType | Specifies the type of an item.
MaskType | Specifies the type of a mask.
Month | Specifies the month.
MonthItemType | Specifies the month item for which an exception recurrence is scheduled.
MonthPosition | Specifies the position of a month item within a month.
OutlineValueType | Specifies the type of an outline value.
RateFormatType | Specifies the units used by Microsoft Project to display a rate.
RateType | Specifies the unique identifiers of a rate table.
ResourceType | Specifies the type of a resource.
RollupType | Specifies the rollup type.
TaskLinkType | Specifies the type of tasks dependency.
TasksDataFormat | Specifies the project data formats.
TaskStartDateType | Specifies the type of a task's start date.
TaskType | Specifies the type of a task.
TimephasedDataType | Specifies the type of timephased data.
TimeUnitType | Specifies the type of a time unit.
ViewScreen | Specifies the screen type for a view.
WorkContourType | Specifies the contour of a work.
WorkGroupType | Specifies the type of a workgroup.

Generated:2014-05-29 02:20:43,version:1.3.49.0


ApplicationInfo Enumeration

Specifies the project version where the file was created.

public enum ApplicationInfo

Members

Member Name | Description | Value
Undefined | Can not be defined. | 0
MSP2000 | File was created in Microsoft Project 2000/2002. | 1
MSP2003 | File was created in Microsoft Project 2003. | 2
MSP2007 | File was created in Microsoft Project 2007. | 3
MSP2010 | File was created in Microsoft Project 2010. | 4
MSP2013 | File was created in Microsoft Project 2013. | 5

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


AssignmentBaseline Class

Represents Baseline of a resource assignment.

For a list of all members of this type, see AssignmentBaseline Members.

System.Object
Aspose.Tasks.Baseline
Aspose.Tasks.AssignmentBaseline

public class AssignmentBaseline : Baseline

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

AssignmentBaseline Members | Aspose.Tasks Namespace


AssignmentBaseline Members

AssignmentBaseline overview

Public Instance Constructors

AssignmentBaseline Constructor Initializes a new instance of the AssignmentBaseline class.

Public Instance Properties

BaselineNumber (inherited from Baseline) | The unique number of a baseline data record. Read/write BaselineType.
Bcwp (inherited from Baseline) | The budgeted cost of a work performed by a resource for a project to-date. Read/write Double.
Bcws (inherited from Baseline) | The budget cost of a work scheduled for a resource. Read/write Double.
Cost (inherited from Baseline) | The projected cost of a resource when the baseline is saved. Read/write Decimal.
Finish | The scheduled finish date of the resource assignment when the baseline was saved.
Number (inherited from Baseline) | Obsolete. The unique number of a baseline data record. Read/write Int32.
Start | The scheduled start date of the resource assignment when the baseline was saved.
TimephasedData | Returns List<TimephasedData> TimephasedData. The timephased data associated with the resource assignment baseline. List of TimephasedData.
Work (inherited from Baseline) | The work assigned to a resource when the baseline is saved. Read/write TimeSpan.

Public Instance Methods

CompareTo (inherited from Baseline) |
Equals |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssignmentBaseline Class | Aspose.Tasks Namespace


AssignmentBaseline Constructor

Initializes a new instance of the AssignmentBaseline class.

public AssignmentBaseline();

See Also

AssignmentBaseline Class | Aspose.Tasks Namespace


AssignmentBaseline Properties

The properties of the AssignmentBaseline class are listed below. For a complete list of AssignmentBaseline class members, see the AssignmentBaseline Members topic.

Public Instance Properties

BaselineNumber (inherited from Baseline) | The unique number of a baseline data record. Read/write BaselineType.
Bcwp (inherited from Baseline) | The budgeted cost of a work performed by a resource for a project to-date. Read/write Double.
Bcws (inherited from Baseline) | The budget cost of a work scheduled for a resource. Read/write Double.
Cost (inherited from Baseline) | The projected cost of a resource when the baseline is saved. Read/write Decimal.
Finish | The scheduled finish date of the resource assignment when the baseline was saved.
Number (inherited from Baseline) | Obsolete. The unique number of a baseline data record. Read/write Int32.
Start | The scheduled start date of the resource assignment when the baseline was saved.
TimephasedData | Returns List<TimephasedData> TimephasedData. The timephased data associated with the resource assignment baseline. List of TimephasedData.
Work (inherited from Baseline) | The work assigned to a resource when the baseline is saved. Read/write TimeSpan.

See Also

AssignmentBaseline Class | Aspose.Tasks Namespace


Finish Property

AssignmentBaseline.Finish Property

The scheduled finish date of the resource assignment when the baseline was saved.

public DateTime Finish {get; set;}

See Also

AssignmentBaseline Class | Aspose.Tasks Namespace


Start Property

AssignmentBaseline.Start Property

The scheduled start date of the resource assignment when the baseline was saved.

public DateTime Start {get; set;}

See Also

AssignmentBaseline Class | Aspose.Tasks Namespace


TimephasedData Property

AssignmentBaseline.TimephasedData Property

Returns List<TimephasedData> TimephasedData. The timephased data associated with the resource assignment baseline. List of TimephasedData.

public TimephasedData} TimephasedData {get; set;}

See Also

AssignmentBaseline Class | Aspose.Tasks Namespace


AssignmentBaseline Methods

The methods of the AssignmentBaseline class are listed below. For a complete list of AssignmentBaseline class members, see the AssignmentBaseline Members topic.

Public Instance Methods

CompareTo (inherited from Baseline) |
Equals |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssignmentBaseline Class | Aspose.Tasks Namespace


AssignmentBaseline.Equals Method

public override bool Equals(
object obj
);

See Also

AssignmentBaseline Class | Aspose.Tasks Namespace


AvailabilityPeriod Class

Represents a period when a resource is available.

For a list of all members of this type, see AvailabilityPeriod Members.

System.Object
Aspose.Tasks.AvailabilityPeriod

public class AvailabilityPeriod

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

AvailabilityPeriod Members | Aspose.Tasks Namespace


AvailabilityPeriod Members

AvailabilityPeriod overview

Public Instance Constructors

AvailabilityPeriod Constructor Default constructor.

Public Instance Properties

AvailableFrom | The date when a resource becomes available for the specified period. Read/write DateTime.
AvailableTo | The last date when a resource is available for the specified period. Read/write DateTime.
AvailableUnits | The percentage of a resource which is available during the specified period. Read/write Double.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AvailabilityPeriod Class | Aspose.Tasks Namespace


AvailabilityPeriod Constructor

Default constructor.

public AvailabilityPeriod();

See Also

AvailabilityPeriod Class | Aspose.Tasks Namespace


AvailabilityPeriod Properties

The properties of the AvailabilityPeriod class are listed below. For a complete list of AvailabilityPeriod class members, see the AvailabilityPeriod Members topic.

Public Instance Properties

AvailableFrom | The date when a resource becomes available for the specified period. Read/write DateTime.
AvailableTo | The last date when a resource is available for the specified period. Read/write DateTime.
AvailableUnits | The percentage of a resource which is available during the specified period. Read/write Double.

See Also

AvailabilityPeriod Class | Aspose.Tasks Namespace


AvailableFrom Property

AvailabilityPeriod.AvailableFrom Property

The date when a resource becomes available for the specified period. Read/write DateTime.

public DateTime AvailableFrom {get; set;}

See Also

AvailabilityPeriod Class | Aspose.Tasks Namespace


AvailableTo Property

AvailabilityPeriod.AvailableTo Property

The last date when a resource is available for the specified period. Read/write DateTime.

public DateTime AvailableTo {get; set;}

See Also

AvailabilityPeriod Class | Aspose.Tasks Namespace


AvailableUnits Property

AvailabilityPeriod.AvailableUnits Property

The percentage of a resource which is available during the specified period. Read/write Double.

public double AvailableUnits {get; set;}

See Also

AvailabilityPeriod Class | Aspose.Tasks Namespace


BackgroundPattern Enumeration

Specifies the background pattern.

public enum BackgroundPattern

Members

Member Name | Description | Value
DarkDiagonalLeft | Dark diagonal left. | 7
DarkDiagonalRight | Dark diagonal right. | 8
DarkDither | Dark dither. | 13
DarkFill | Dark fill. | 4
DiagonalLeft | Diagonal left. | 5
DiagonalRight | Diagonal right. | 6
Hollow | Hollow. | 0
LightDither | Light dither. | 11
LightFill | Light fill. | 2
MediumDither | Medium dither. | 12
MediumFill | Medium fill. | 3
MediumVerticalStripe | Medium vertical stripe. | 10
SolidFill | Solid fill. | 1
ThinVerticalStripe | Thin vertical stripe. | 9

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


Baseline Class

Represents baseline values of a resource.

For a list of all members of this type, see Baseline Members.

System.Object
Aspose.Tasks.Baseline
Aspose.Tasks.AssignmentBaseline
Aspose.Tasks.TaskBaseline

public class Baseline : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Baseline Members | Aspose.Tasks Namespace


Baseline Members

Baseline overview

Public Instance Constructors

Baseline Constructor Default constructor.

Public Instance Properties

BaselineNumber | The unique number of a baseline data record. Read/write BaselineType.
Bcwp | The budgeted cost of a work performed by a resource for a project to-date. Read/write Double.
Bcws | The budget cost of a work scheduled for a resource. Read/write Double.
Cost | The projected cost of a resource when the baseline is saved. Read/write Decimal.
Number | Obsolete. The unique number of a baseline data record. Read/write Int32.
Work | The work assigned to a resource when the baseline is saved. Read/write TimeSpan.

Public Instance Methods

CompareTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Baseline Class | Aspose.Tasks Namespace


Baseline Constructor

Default constructor.

public Baseline();

See Also

Baseline Class | Aspose.Tasks Namespace


Baseline Properties

The properties of the Baseline class are listed below. For a complete list of Baseline class members, see the Baseline Members topic.

Public Instance Properties

BaselineNumber | The unique number of a baseline data record. Read/write BaselineType.
Bcwp | The budgeted cost of a work performed by a resource for a project to-date. Read/write Double.
Bcws | The budget cost of a work scheduled for a resource. Read/write Double.
Cost | The projected cost of a resource when the baseline is saved. Read/write Decimal.
Number | Obsolete. The unique number of a baseline data record. Read/write Int32.
Work | The work assigned to a resource when the baseline is saved. Read/write TimeSpan.

See Also

Baseline Class | Aspose.Tasks Namespace


BaselineNumber Property

Baseline.BaselineNumber Property

The unique number of a baseline data record. Read/write BaselineType.

public BaselineType BaselineNumber {get; set;}

See Also

Baseline Class | Aspose.Tasks Namespace


Bcwp Property

Baseline.Bcwp Property

The budgeted cost of a work performed by a resource for a project to-date. Read/write Double.

public double Bcwp {get; set;}

See Also

Baseline Class | Aspose.Tasks Namespace


Bcws Property

Baseline.Bcws Property

The budget cost of a work scheduled for a resource. Read/write Double.

public double Bcws {get; set;}

See Also

Baseline Class | Aspose.Tasks Namespace


Cost Property

Baseline.Cost Property

The projected cost of a resource when the baseline is saved. Read/write Decimal.

public decimal Cost {get; set;}

See Also

Baseline Class | Aspose.Tasks Namespace


Number Property

Baseline.Number Property

NOTE: This property is now obsolete.

Use BaselineNumber instead.

The unique number of a baseline data record. Read/write Int32.

public int Number {get; set;}

See Also

Baseline Class | Aspose.Tasks Namespace


Work Property

Baseline.Work Property

The work assigned to a resource when the baseline is saved. Read/write TimeSpan.

public TimeSpan Work {get; set;}

See Also

Baseline Class | Aspose.Tasks Namespace


Baseline Methods

The methods of the Baseline class are listed below. For a complete list of Baseline class members, see the Baseline Members topic.

Public Instance Methods

CompareTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Baseline Class | Aspose.Tasks Namespace


Baseline.CompareTo Method

public int CompareTo(
object obj
);

Implements

IComparable.CompareTo

See Also

Baseline Class | Aspose.Tasks Namespace


BaselineType Enumeration

Specifies the baseline type used to calculate Variance values.

public enum BaselineType

Remarks

While exporting into XML the Undefined values will be eliminated from resulting XML.

Members

Member Name | Description | Value
Undefined | The field was not defined in original project file. | -1
Baseline |  | 0
Baseline1 |  | 1
Baseline2 |  | 2
Baseline3 |  | 3
Baseline4 |  | 4
Baseline5 |  | 5
Baseline6 |  | 6
Baseline7 |  | 7
Baseline8 |  | 8
Baseline9 |  | 9
Baseline10 |  | 10

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


BookingType Enumeration

Specifies the booking type of a resource.

public enum BookingType

Remarks

While exporting into XML the Undefined values will be eliminated from resulting XML.

Members

Member Name | Description | Value
Undefined | The value was not defined in original project file. | -1
Committed | Committed | 0
Proposed | Proposed | 1

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


BuildVersionInfo Class

Contains build version and product information.

For a list of all members of this type, see BuildVersionInfo Members.

System.Object
Aspose.Tasks.BuildVersionInfo

public sealed class BuildVersionInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

BuildVersionInfo Members | Aspose.Tasks Namespace


BuildVersionInfo Members

BuildVersionInfo overview

Public Static Fields

AssemblyVersion | Assembly version, read only string.
FileVersion | File version, read only string.
Product | Product name, read only string.

Public Instance Constructors

BuildVersionInfo Constructor Initializes a new instance of the BuildVersionInfo class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BuildVersionInfo Class | Aspose.Tasks Namespace


BuildVersionInfo Constructor

Initializes a new instance of the BuildVersionInfo class.

public BuildVersionInfo();

See Also

BuildVersionInfo Class | Aspose.Tasks Namespace


BuildVersionInfo Fields

The fields of the BuildVersionInfo class are listed below. For a complete list of BuildVersionInfo class members, see the BuildVersionInfo Members topic.

Public Static Fields

AssemblyVersion | Assembly version, read only string.
FileVersion | File version, read only string.
Product | Product name, read only string.

See Also

BuildVersionInfo Class | Aspose.Tasks Namespace


BuildVersionInfo.AssemblyVersion Field

Assembly version, read only string.

public static readonly string AssemblyVersion;

See Also

BuildVersionInfo Class | Aspose.Tasks Namespace


BuildVersionInfo.FileVersion Field

File version, read only string.

public static readonly string FileVersion;

See Also

BuildVersionInfo Class | Aspose.Tasks Namespace


BuildVersionInfo.Product Field

Product name, read only string.

public static readonly string Product;

See Also

BuildVersionInfo Class | Aspose.Tasks Namespace


CalculationType Enumeration

Specifies the calculation type.

public enum CalculationType

Members

Member Name | Description | Value
Null |  | 0
None |  | 1
Rollup |  | 2
Calculation |  | 3

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


Calendar Class

Represents a calendar used in a project.

For a list of all members of this type, see Calendar Members.

System.Object
Aspose.Tasks.Calendar

public class Calendar

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Calendars are used to define standard working and non-working times. Projects must have one base calendar. Tasks and resources can have their own non-base calendars that are based on a base calendar.

Example

How to create simple calendar from scratch.

[C#]
// create empty calendar
Calendar calendar = new Calendar();
// adds default working days (8 working hours from 9:00 to 17:00)
calendar.Days.Add(WeekDay.CreateDefaultWorkingDay(DayType.Monday));
calendar.Days.Add(WeekDay.CreateDefaultWorkingDay(DayType.Tuesday));
calendar.Days.Add(WeekDay.CreateDefaultWorkingDay(DayType.Wednesday));
// create new new working day
WeekDay myWeekDay = new WeekDay(DayType.Thursday);
// Sets working time. Only time part of DateTime is important
    WorkingTime wt1 = new WorkingTime();
    wt1.FromTime = new DateTime(1, 1, 1, 6, 0, 0, 0);
    wt1.ToTime = new DateTime(1, 1, 1, 12, 0, 0, 0);
    WorkingTime wt2 = new WorkingTime();
    wt2.FromTime = new DateTime(1, 1, 1, 14, 0, 0, 0);
    wt2.ToTime = new DateTime(1, 1, 1, 18, 0, 0, 0);
    myWeekDay.WorkingTimes.Add(wt1);
    myWeekDay.WorkingTimes.Add(wt2);
    myWeekDay.DayWorking = true;
calendar.Days.Add(myWeekDay);
calendar.Days.Add(WeekDay.CreateDefaultWorkingDay(DayType.Friday));
// adds weekend
calendar.Days.Add(new WeekDay(DayType.Saturday));
calendar.Days.Add(new WeekDay(DayType.Sunday));

[VB]
' create empty calendar
Dim calendar As Calendar =  New Calendar()
' adds default working days (8 working hours from 9:00 to 17:00)
calendar.Days.Add(WeekDay.CreateDefaultWorkingDay(DayType.Monday))
calendar.Days.Add(WeekDay.CreateDefaultWorkingDay(DayType.Tuesday))
calendar.Days.Add(WeekDay.CreateDefaultWorkingDay(DayType.Wednesday))
' create new new working day
Dim myWeekDay As WeekDay =  New WeekDay(DayType.Thursday)
' Sets working time. Only time part of DateTime is important
    Dim wt1 As WorkingTime =  New WorkingTime()
    wt1.FromTime = New DateTime(1, 1, 1, 6, 0, 0, 0)
    wt1.ToTime = New DateTime(1, 1, 1, 12, 0, 0, 0)
    Dim wt2 As WorkingTime =  New WorkingTime()
    wt2.FromTime = New DateTime(1, 1, 1, 14, 0, 0, 0)
    wt2.ToTime = New DateTime(1, 1, 1, 18, 0, 0, 0)
    myWeekDay.WorkingTimes.Add(wt1)
    myWeekDay.WorkingTimes.Add(wt2)
    myWeekDay.DayWorking = True
calendar.Days.Add(myWeekDay)
calendar.Days.Add(WeekDay.CreateDefaultWorkingDay(DayType.Friday))
' adds weekend
calendar.Days.Add(New WeekDay(DayType.Saturday))
calendar.Days.Add(New WeekDay(DayType.Sunday))

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Calendar Members | Aspose.Tasks Namespace


Calendar Members

Calendar overview

Public Static Methods

Make24HourCalendar | Overloaded. Creates 24Hours Calendar named "24 Hours". 24Hours Calendar is a Calendar in which every day of week is working with Round-the-clock working hours.
MakeNightShiftCalendar | Overloaded. Creates Night Shift Calendar named "Night shift".
MakeStandardCalendar | Overloaded. Creates default standard calendar.

Public Instance Constructors

Calendar Overloaded. Initializes a new instance of the Calendar class.

Public Instance Properties

BaseCalendar | The base calendar on which this calendar depends. Only applicable if the calendar is not a base calendar. Read/write Calendar.
Days | Returns List<WeekDay> Days. The collection of weekdays that defines the calendar. Read/write List of WeekDay.
Exceptions | Returns List<CalendarException> Exceptions. The collection of exceptions that is associated with the calendar. Read/write List of CalendarException.
IsBaseCalendar | Determines whether the calendar is a base calendar. Read-only Boolean.
IsBaselineCalendar | Specifies whether the calendar is a baseline calendar. Read/write Boolean.
Name | The name of the calendar. Read/write String.
Uid | The unique identifier of the calendar. Read/write Int32.
WorkWeeks | The collection of effective work weeks associated with the calendar. Read/write ArrayList.

Public Instance Methods

Equals | Returns a value indicating whether this instance is equal to a specified object.
GetFinishDateByStartAndWork | Calculates the date when the specified amount of work time will pass according to the calendar.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNextWorkingDayStart | Calculates next working day start from the date.
GetPreviousWorkingDayEnd | Calculates previous working date end from the date.
GetStartDateFromFinishAndDuration | Returns StartDate based on specified FinishDate and Duration.
GetTaskFinishDateFromDuration | Calculates the task finish date and time from its start date, split parts and the duration.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWorkingHours | Overloaded. Return working hours for the specified dates.
GetWorkingTimes | Returns List<WorkingTime> of working times.
IsDayWorking | Determines whether the day is working day.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar Constructor

Default constructor.

Overload List

Default constructor.

public Calendar();

Constructs calendar and sets Id value.

public Calendar(int);

Constructs calendar with a name.

public Calendar(string);

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar Constructor ()

Default constructor.

public Calendar();

See Also

Calendar Class | Aspose.Tasks Namespace | Calendar Constructor Overload List


Calendar Constructor (Int32)

Constructs calendar and sets Id value.

public Calendar(
int id
);

Parameters

id
Unique identifier.

See Also

Calendar Class | Aspose.Tasks Namespace | Calendar Constructor Overload List


Calendar Constructor (String)

Constructs calendar with a name.

public Calendar(
string name
);

Parameters

name
The name of the created calendar.

See Also

Calendar Class | Aspose.Tasks Namespace | Calendar Constructor Overload List


Calendar Properties

The properties of the Calendar class are listed below. For a complete list of Calendar class members, see the Calendar Members topic.

Public Instance Properties

BaseCalendar | The base calendar on which this calendar depends. Only applicable if the calendar is not a base calendar. Read/write Calendar.
Days | Returns List<WeekDay> Days. The collection of weekdays that defines the calendar. Read/write List of WeekDay.
Exceptions | Returns List<CalendarException> Exceptions. The collection of exceptions that is associated with the calendar. Read/write List of CalendarException.
IsBaseCalendar | Determines whether the calendar is a base calendar. Read-only Boolean.
IsBaselineCalendar | Specifies whether the calendar is a baseline calendar. Read/write Boolean.
Name | The name of the calendar. Read/write String.
Uid | The unique identifier of the calendar. Read/write Int32.
WorkWeeks | The collection of effective work weeks associated with the calendar. Read/write ArrayList.

See Also

Calendar Class | Aspose.Tasks Namespace


BaseCalendar Property

Calendar.BaseCalendar Property

The base calendar on which this calendar depends. Only applicable if the calendar is not a base calendar. Read/write Calendar.

public Calendar BaseCalendar {get; set;}

See Also

Calendar Class | Aspose.Tasks Namespace


Days Property

Calendar.Days Property

Returns List<WeekDay> Days. The collection of weekdays that defines the calendar. Read/write List of WeekDay.

public WeekDay} Days {get; set;}

See Also

Calendar Class | Aspose.Tasks Namespace


Exceptions Property

Calendar.Exceptions Property

Returns List<CalendarException> Exceptions. The collection of exceptions that is associated with the calendar. Read/write List of CalendarException.

public CalendarException} Exceptions {get; set;}

See Also

Calendar Class | Aspose.Tasks Namespace


IsBaseCalendar Property

Calendar.IsBaseCalendar Property

Determines whether the calendar is a base calendar. Read-only Boolean.

public bool IsBaseCalendar {get;}

See Also

Calendar Class | Aspose.Tasks Namespace


IsBaselineCalendar Property

Calendar.IsBaselineCalendar Property

Specifies whether the calendar is a baseline calendar. Read/write Boolean.

public bool IsBaselineCalendar {get; set;}

Remarks

This is a new for MS Project 2010 property. Reading supported for XML format only. Returns false if not defined.

See Also

Calendar Class | Aspose.Tasks Namespace


Name Property

Calendar.Name Property

The name of the calendar. Read/write String.

public string Name {get; set;}

See Also

Calendar Class | Aspose.Tasks Namespace


Uid Property

Calendar.Uid Property

The unique identifier of the calendar. Read/write Int32.

public int Uid {get; set;}

See Also

Calendar Class | Aspose.Tasks Namespace


WorkWeeks Property

Calendar.WorkWeeks Property

The collection of effective work weeks associated with the calendar. Read/write ArrayList.

public ArrayList WorkWeeks {get; set;}

Remarks

Not supported now.

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar Methods

The methods of the Calendar class are listed below. For a complete list of Calendar class members, see the Calendar Members topic.

Public Static Methods

Make24HourCalendar | Overloaded. Creates 24Hours Calendar named "24 Hours". 24Hours Calendar is a Calendar in which every day of week is working with Round-the-clock working hours.
MakeNightShiftCalendar | Overloaded. Creates Night Shift Calendar named "Night shift".
MakeStandardCalendar | Overloaded. Creates default standard calendar.

Public Instance Methods

Equals | Returns a value indicating whether this instance is equal to a specified object.
GetFinishDateByStartAndWork | Calculates the date when the specified amount of work time will pass according to the calendar.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNextWorkingDayStart | Calculates next working day start from the date.
GetPreviousWorkingDayEnd | Calculates previous working date end from the date.
GetStartDateFromFinishAndDuration | Returns StartDate based on specified FinishDate and Duration.
GetTaskFinishDateFromDuration | Calculates the task finish date and time from its start date, split parts and the duration.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWorkingHours | Overloaded. Return working hours for the specified dates.
GetWorkingTimes | Returns List<WorkingTime> of working times.
IsDayWorking | Determines whether the day is working day.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar.Equals Method

Returns a value indicating whether this instance is equal to a specified object.

public override bool Equals(
object obj
);

Parameters

obj
The object to compare with this instance.

Return Value

True if o is a Calendar that has the same Uid value as this instance; otherwise, false.

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar.GetFinishDateByStartAndWork Method

Calculates the date when the specified amount of work time will pass according to the calendar.

public DateTime GetFinishDateByStartAndWork(
DateTime start,
TimeSpan work
);

Parameters

start
Start date.
work
Work duration.

Return Value

Finish date.

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar.GetNextWorkingDayStart Method

Calculates next working day start from the date.

public DateTime GetNextWorkingDayStart(
DateTime date
);

Parameters

date
The date.

Return Value

Next working day start DateTime.

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar.GetPreviousWorkingDayEnd Method

Calculates previous working date end from the date.

public DateTime GetPreviousWorkingDayEnd(
DateTime date
);

Parameters

date
The date.

Return Value

Previous working day start DateTime

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar.GetStartDateFromFinishAndDuration Method

Returns StartDate based on specified FinishDate and Duration.

public DateTime GetStartDateFromFinishAndDuration(
DateTime finish,
TimeSpan duration
);

Parameters

finish
FinishDate.
duration
Duration.

Return Value

Calculated StartDate.

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar.GetTaskFinishDateFromDuration Method

Calculates the task finish date and time from its start date, split parts and the duration.

public DateTime GetTaskFinishDateFromDuration(
Task task,
TimeSpan duration
);

Parameters

task
Task.
duration
New task duration.

Return Value

Task's finish date.

Remarks

Returns DatiTime.MinValue if task is summary, null or its start date is not set.

See Also

Calendar Class | Aspose.Tasks Namespace


GetWorkingHours Method

Calendar.GetWorkingHours Method

Returns amount of working hours at the date.

Overload List

Returns amount of working hours at the date.

public TimeSpan GetWorkingHours(DateTime);

Return working hours for the specified dates.

public WorkUnit GetWorkingHours(DateTime,DateTime);

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar.GetWorkingHours Method (DateTime)

Returns amount of working hours at the date.

public TimeSpan GetWorkingHours(
DateTime dt
);

Parameters

dt
The date.

Return Value

Working hours.

See Also

Calendar Class | Aspose.Tasks Namespace | Calendar.GetWorkingHours Overload List


Calendar.GetWorkingHours Method (DateTime, DateTime)

Return working hours for the specified dates.

public WorkUnit GetWorkingHours(
DateTime start,
DateTime finish
);

Parameters

start
Start date.
finish
Finish date.

Return Value

Working hours.

See Also

Calendar Class | Aspose.Tasks Namespace | Calendar.GetWorkingHours Overload List


Calendar.GetWorkingTimes Method

Returns List<WorkingTime> of working times.

public List<WorkingTime> GetWorkingTimes(
DateTime dt
);

Parameters

dt
The date

Return Value

List of WorkingTime.

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar.IsDayWorking Method

Determines whether the day is working day.

public bool IsDayWorking(
DateTime dt
);

Parameters

dt
the date

Return Value

True if the day is working day.

See Also

Calendar Class | Aspose.Tasks Namespace


Make24HourCalendar Method

Calendar.Make24HourCalendar Method

Creates 24Hours Calendar named "24 Hours". 24Hours Calendar is a Calendar in which every day of week is working with Round-the-clock working hours.

Overload List

Creates 24Hours Calendar named "24 Hours". 24Hours Calendar is a Calendar in which every day of week is working with Round-the-clock working hours.

public static Calendar Make24HourCalendar();

Makes a given Calendar to be a 24Hour Calendar. 24Hours Calendar is a Calendar in which every day of week is working with Round-the-clock working hours.

public static Calendar Make24HourCalendar(Calendar);

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar.Make24HourCalendar Method ()

Creates 24Hours Calendar named "24 Hours". 24Hours Calendar is a Calendar in which every day of week is working with Round-the-clock working hours.

public static Calendar Make24HourCalendar();

Return Value

Created 24Hour Calendar.

See Also

Calendar Class | Aspose.Tasks Namespace | Calendar.Make24HourCalendar Overload List


Calendar.Make24HourCalendar Method (Calendar)

Makes a given Calendar to be a 24Hour Calendar. 24Hours Calendar is a Calendar in which every day of week is working with Round-the-clock working hours.

public static Calendar Make24HourCalendar(
Calendar calendar
);

Parameters

calendar
Calendar to make 24 Hours Calendar from.

Return Value

24Hour Calendar.

See Also

Calendar Class | Aspose.Tasks Namespace | Calendar.Make24HourCalendar Overload List


MakeNightShiftCalendar Method

Calendar.MakeNightShiftCalendar Method

Creates Night Shift Calendar named "Night shift".

Overload List

Creates Night Shift Calendar named "Night shift".

public static Calendar MakeNightShiftCalendar();

Makes a given Calendar as Night Shift Calendar.

public static Calendar MakeNightShiftCalendar(Calendar);

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar.MakeNightShiftCalendar Method ()

Creates Night Shift Calendar named "Night shift".

public static Calendar MakeNightShiftCalendar();

Return Value

Created Night Shift Calendar.

See Also

Calendar Class | Aspose.Tasks Namespace | Calendar.MakeNightShiftCalendar Overload List


Calendar.MakeNightShiftCalendar Method (Calendar)

Makes a given Calendar as Night Shift Calendar.

public static Calendar MakeNightShiftCalendar(
Calendar calendar
);

Parameters

calendar
Calendar to make Night Shift Calendar.

Return Value

Night Shift Calendar.

See Also

Calendar Class | Aspose.Tasks Namespace | Calendar.MakeNightShiftCalendar Overload List


MakeStandardCalendar Method

Calendar.MakeStandardCalendar Method

Creates default standard calendar.

Overload List

Creates default standard calendar.

public static Calendar MakeStandardCalendar();

Creates default standard calendar.

public static Calendar MakeStandardCalendar(Calendar);

See Also

Calendar Class | Aspose.Tasks Namespace


Calendar.MakeStandardCalendar Method ()

Creates default standard calendar.

public static Calendar MakeStandardCalendar();

Return Value

Created calendar.

See Also

Calendar Class | Aspose.Tasks Namespace | Calendar.MakeStandardCalendar Overload List


Calendar.MakeStandardCalendar Method (Calendar)

Creates default standard calendar.

public static Calendar MakeStandardCalendar(
Calendar calendar
);

Return Value

Created calendar.

See Also

Calendar Class | Aspose.Tasks Namespace | Calendar.MakeStandardCalendar Overload List


CalendarException Class

Represent exceptional time periods in a calendar.

For a list of all members of this type, see CalendarException Members.

System.Object
Aspose.Tasks.CalendarException

public class CalendarException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

CalendarException Members | Aspose.Tasks Namespace


CalendarException Members

CalendarException overview

Public Instance Constructors

CalendarException Constructor Default constructor.

Public Instance Properties

DaysOfWeek | Returns List<DayType> DaysOfWeek. The days of the week on which the exception is valid. Read/write List of DayType.
DayWorking | Determines whether the specified date or day type is working. Read/write Boolean.
EnteredByOccurrences | Determines whether the range of recurrence is defined by entering a number of occurrences. False specifies that the range of recurrence is defined by entering a finish date. Read/write Boolean.
FromDate | The beginning of the exception time. Read/write DateTime.
Month | The month for which an exception recurrence is scheduled. Read/write Month.
MonthDay | The day of a month on which an exception recurrence is scheduled. Read/write Int32.
MonthItem | The month item for which an exception recurrence is scheduled. Read/write MonthItemType.
MonthPosition | The position of a month item within a month. Read/write MonthPosition.
Name | The name of the exception. Read/write String.
Occurrences | The number of occurrences for which the calendar exception is valid. Read/write Int32.
Period | The period of recurrence for the exception. Read/write Int32.
ToDate | The end of the exception time. Read/write DateTime.
Type | The exception type. Read/write CalendarExceptionType.
WorkingTimes | Returns List<WoringTime> WorkingTimes. The collection of working times that defines the time worked on the weekday. At least one working time must present, and there can't be more than five. Read/write Listof WorkingTime.

Public Instance Methods

CheckException | Returns true if dt is the exception day
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWorkingTime | Returns the working time for a calendar exception.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarException Class | Aspose.Tasks Namespace


CalendarException Constructor

Default constructor.

public CalendarException();

See Also

CalendarException Class | Aspose.Tasks Namespace


CalendarException Properties

The properties of the CalendarException class are listed below. For a complete list of CalendarException class members, see the CalendarException Members topic.

Public Instance Properties

DaysOfWeek | Returns List<DayType> DaysOfWeek. The days of the week on which the exception is valid. Read/write List of DayType.
DayWorking | Determines whether the specified date or day type is working. Read/write Boolean.
EnteredByOccurrences | Determines whether the range of recurrence is defined by entering a number of occurrences. False specifies that the range of recurrence is defined by entering a finish date. Read/write Boolean.
FromDate | The beginning of the exception time. Read/write DateTime.
Month | The month for which an exception recurrence is scheduled. Read/write Month.
MonthDay | The day of a month on which an exception recurrence is scheduled. Read/write Int32.
MonthItem | The month item for which an exception recurrence is scheduled. Read/write MonthItemType.
MonthPosition | The position of a month item within a month. Read/write MonthPosition.
Name | The name of the exception. Read/write String.
Occurrences | The number of occurrences for which the calendar exception is valid. Read/write Int32.
Period | The period of recurrence for the exception. Read/write Int32.
ToDate | The end of the exception time. Read/write DateTime.
Type | The exception type. Read/write CalendarExceptionType.
WorkingTimes | Returns List<WoringTime> WorkingTimes. The collection of working times that defines the time worked on the weekday. At least one working time must present, and there can't be more than five. Read/write Listof WorkingTime.

See Also

CalendarException Class | Aspose.Tasks Namespace


DaysOfWeek Property

CalendarException.DaysOfWeek Property

Returns List<DayType> DaysOfWeek. The days of the week on which the exception is valid. Read/write List of DayType.

public DayType} DaysOfWeek {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


DayWorking Property

CalendarException.DayWorking Property

Determines whether the specified date or day type is working. Read/write Boolean.

public bool DayWorking {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


EnteredByOccurrences Property

CalendarException.EnteredByOccurrences Property

Determines whether the range of recurrence is defined by entering a number of occurrences. False specifies that the range of recurrence is defined by entering a finish date. Read/write Boolean.

public bool EnteredByOccurrences {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


FromDate Property

CalendarException.FromDate Property

The beginning of the exception time. Read/write DateTime.

public DateTime FromDate {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


Month Property

CalendarException.Month Property

The month for which an exception recurrence is scheduled. Read/write Month.

public Month Month {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


MonthDay Property

CalendarException.MonthDay Property

The day of a month on which an exception recurrence is scheduled. Read/write Int32.

public int MonthDay {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


MonthItem Property

CalendarException.MonthItem Property

The month item for which an exception recurrence is scheduled. Read/write MonthItemType.

public MonthItemType MonthItem {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


MonthPosition Property

CalendarException.MonthPosition Property

The position of a month item within a month. Read/write MonthPosition.

public MonthPosition MonthPosition {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


Name Property

CalendarException.Name Property

The name of the exception. Read/write String.

public string Name {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


Occurrences Property

CalendarException.Occurrences Property

The number of occurrences for which the calendar exception is valid. Read/write Int32.

public int Occurrences {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


Period Property

CalendarException.Period Property

The period of recurrence for the exception. Read/write Int32.

public int Period {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


ToDate Property

CalendarException.ToDate Property

The end of the exception time. Read/write DateTime.

public DateTime ToDate {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


Type Property

CalendarException.Type Property

The exception type. Read/write CalendarExceptionType.

public CalendarExceptionType Type {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


WorkingTimes Property

CalendarException.WorkingTimes Property

Returns List<WoringTime> WorkingTimes. The collection of working times that defines the time worked on the weekday. At least one working time must present, and there can't be more than five. Read/write Listof WorkingTime.

public WorkingTime} WorkingTimes {get; set;}

See Also

CalendarException Class | Aspose.Tasks Namespace


CalendarException Methods

The methods of the CalendarException class are listed below. For a complete list of CalendarException class members, see the CalendarException Members topic.

Public Instance Methods

CheckException | Returns true if dt is the exception day
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWorkingTime | Returns the working time for a calendar exception.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarException Class | Aspose.Tasks Namespace


CalendarException.CheckException Method

Returns true if dt is the exception day

public bool CheckException(
DateTime dt
);

Parameters

dt

Return Value

See Also

CalendarException Class | Aspose.Tasks Namespace


CalendarException.GetWorkingTime Method

Returns the working time for a calendar exception.

public TimeSpan GetWorkingTime();

Return Value

Working time.

See Also

CalendarException Class | Aspose.Tasks Namespace


CalendarExceptionType Enumeration

Specifies the calendar exception type.

public enum CalendarExceptionType

Members

Member Name | Description | Value
Daily | Daily | 0
YearlyByDay | Yearly by day of the month | 1
YearlyByPosition | Yearly by position | 2
MonthlyByDay | Monthly by day of the month | 3
MonthlyByPosition | Monthly by position | 4
Weekly | Weekly | 5
ByDayCount | By day count | 6
ByWeekDayCount | By weekday count | 7
NoExceptionType | No exception type | 8

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


ConstraintType Enumeration

Specifies the constraint on the start or finish date of a task.

public enum ConstraintType

Remarks

While exporting into XML the Undefined values will be eliminated from resulting XML.

Members

Member Name | Description | Value
Undefined | The value was not defined in original project file. | -1
AsSoonAsPossible | As Soon As Possible | 0
AsLateAsPossible | As Late As Possible | 1
MustStartOn | Must Start On | 2
MustFinishOn | Must Finish On | 3
StartNoEarlierThan | Start No Earlier Than | 4
StartNoLaterThan | Start No Later Than | 5
FinishNoEarlierThan | Finish No Earlier Than | 6
FinishNoLaterThan | Finish No Later Than | 7

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


CostAccrualType Enumeration

Specifies the type of an accrual cost.

public enum CostAccrualType

Remarks

While exporting into XML the Undefined values will be eliminated from resulting XML.

Members

Member Name | Description | Value
Undefined | Undefined value means that the field was not defined in original project file. | -1
Start | Start | 0
Prorated | Prorated | 1
End | End | 2
Invalid | Invalid type | 3

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


CurrencySymbolPositionType Enumeration

Specifies the position of a currency symbol.

public enum CurrencySymbolPositionType

Remarks

While exporting into XML the Undefined values will be eliminated from resulting XML.

Members

Member Name | Description | Value
Undefined | Undefined value means that the field was not defined in original project file. | -1
Before |  | 0
After |  | 1
BeforeWithSpace |  | 2
AfterWithSpace |  | 3

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


CustomFieldType Enumeration

Specifies the type of a custom field.

public enum CustomFieldType

Members

Member Name | Description | Value
Null |  | 0
Cost | Cost field | 1
Date | Date field | 2
Duration | Duration field | 3
Finish | Finish field | 4
Flag | Flag field | 5
Number | Number field | 6
Start | Start field | 7
Text | Text field | 8

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


DayType Enumeration

Specifies the day of a week.

public enum DayType

Members

Member Name | Description | Value
Exception | Exception | 0
Sunday | Sunday | 1
Monday | Monday | 2
Tuesday | Tuesday | 3
Wednesday | Wednesday | 4
Thursday | Thursday | 5
Friday | Friday | 6
Saturday | Saturday | 7

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


EarnedValueMethodType Enumeration

Specifies the method used for calculating earned value.

public enum EarnedValueMethodType

Remarks

While exporting into XML the Undefined values will be eliminated from resulting XML.

Members

Member Name | Description | Value
Undefined | The field was not defined in original project file. | -1
PercentComplete | Percent complete | 0
PhysicalPercentComplete | Physical percent complete | 1

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


ElementType Enumeration

Specifies the type of an element.

public enum ElementType

Members

Member Name | Description | Value
Null | Null | 0
Task | Task | 1
Resource | Resource | 2
Calendar | Calendar | 3
Assignment | Assignment | 4

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


ExtendedAttribute Class

Represents extended attributes.

For a list of all members of this type, see ExtendedAttribute Members.

System.Object
Aspose.Tasks.ExtendedAttribute

public class ExtendedAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Currently supported all types of Extended attributes reading from MSP Xml 2003/2007 and mpp 2003. For MSP mpp 2007 all Extended attributes reading supported except durations and flags.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ExtendedAttribute Members | Aspose.Tasks Namespace


ExtendedAttribute Members

ExtendedAttribute overview

Public Instance Constructors

ExtendedAttribute Constructor Initializes a new instance of the ExtendedAttribute class.

Public Instance Properties

AttributeDefinition | Returns of sets the attribute definition
DurationFormat | Returns or sets the duration format. Read/write TimeUnitType.
FieldId | Returns or sets the id of a field. Read/write String.
Value | Returns or sets the value of a field. Read/write String.
ValueGuid | Returns or sets the guid of a value. Read/write String.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedAttribute Class | Aspose.Tasks Namespace


ExtendedAttribute Constructor

Initializes a new instance of the ExtendedAttribute class.

public ExtendedAttribute();

See Also

ExtendedAttribute Class | Aspose.Tasks Namespace


ExtendedAttribute Properties

The properties of the ExtendedAttribute class are listed below. For a complete list of ExtendedAttribute class members, see the ExtendedAttribute Members topic.

Public Instance Properties

AttributeDefinition | Returns of sets the attribute definition
DurationFormat | Returns or sets the duration format. Read/write TimeUnitType.
FieldId | Returns or sets the id of a field. Read/write String.
Value | Returns or sets the value of a field. Read/write String.
ValueGuid | Returns or sets the guid of a value. Read/write String.

See Also

ExtendedAttribute Class | Aspose.Tasks Namespace


AttributeDefinition Property

ExtendedAttribute.AttributeDefinition Property

Returns of sets the attribute definition

public ExtendedAttributeDefinition AttributeDefinition {get; set;}

See Also

ExtendedAttribute Class | Aspose.Tasks Namespace


DurationFormat Property

ExtendedAttribute.DurationFormat Property

Returns or sets the duration format. Read/write TimeUnitType.

public TimeUnitType DurationFormat {get; set;}

See Also

ExtendedAttribute Class | Aspose.Tasks Namespace


FieldId Property

ExtendedAttribute.FieldId Property

Returns or sets the id of a field. Read/write String.

public string FieldId {get; set;}

See Also

ExtendedAttribute Class | Aspose.Tasks Namespace


Value Property

ExtendedAttribute.Value Property

Returns or sets the value of a field. Read/write String.

public string Value {get; set;}

See Also

ExtendedAttribute Class | Aspose.Tasks Namespace


ValueGuid Property

ExtendedAttribute.ValueGuid Property

Returns or sets the guid of a value. Read/write String.

public string ValueGuid {get; set;}

See Also

ExtendedAttribute Class | Aspose.Tasks Namespace


ExtendedAttributeDefinition Class

Represents an extended attribute definition associated with a project.

For a list of all members of this type, see ExtendedAttributeDefinition Members.

System.Object
Aspose.Tasks.ExtendedAttributeDefinition

public class ExtendedAttributeDefinition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ExtendedAttributeDefinition Members | Aspose.Tasks Namespace


ExtendedAttributeDefinition Members

ExtendedAttributeDefinition overview

Public Instance Constructors

ExtendedAttributeDefinition Constructor Default constructor.

Public Instance Properties

Alias | The alias of a custom field. Read/write String.
AppendNewValues | Determines whether new values added to a project are automatically added to the list. Read/write Boolean.
AutoRollDown | Determines whether an automatic rolldown to assignments is enabled. Read/write Boolean.
CalculationType | Determines whether rollups are calculated for a task and group summary rows. Read/write CalculationType.
CfType | The type of a custom field. Read/write CustomFieldType.
Default | The default value in the list. Read/write String.
DefaultGuid | The Guid of the default lookup table entry. Read/write String.
ElementType | Determines whether the extended attribute is associated with a task, a resource, or an assignment. Read/write ElementType.
FieldId | Corresponds to the Pid of a custom field. Read/write String.
FieldName | The name of a custom field. Read/write String.
Formula | The formula that Microsoft Project uses to populate a custom task field. Read/write String.
Guid | The Guid of a custom field. Read/write String.
LookupUid | The Guid of the lookup table associated with a custom field. Read/write String.
MaxMultiValues | The maximum number of values you can set in a picklist. Read/write Int32.
PhoneticsAlias | The phonetic pronunciation of the alias of a custom field. Read/write String.
RestrictValues | Determines whether only values in the list are allowed in a file. Read/write Boolean.
RollupType | The way rollups are calculated. Read/write RollupType.
SecondaryGuid | Secondary guid of extended attribute. Read/write String.
SecondaryPid | The secondary Pid of a custom field. Read/write String.
UserDef | Determines whether a custom field is user defined. Read/write Boolean.
ValueList | Returns List<Value> ValueList. Read/write List of Value.
ValuelistSortOrder | The way value lists are sorted. Values are: 0=Descending, 1=Ascending. Read/write Int32.

Public Instance Methods

CreateExtendedAttribute | Creates new extended attribute with specified fieldID
Equals |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


ExtendedAttributeDefinition Constructor

Default constructor.

public ExtendedAttributeDefinition();

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


ExtendedAttributeDefinition Properties

The properties of the ExtendedAttributeDefinition class are listed below. For a complete list of ExtendedAttributeDefinition class members, see the ExtendedAttributeDefinition Members topic.

Public Instance Properties

Alias | The alias of a custom field. Read/write String.
AppendNewValues | Determines whether new values added to a project are automatically added to the list. Read/write Boolean.
AutoRollDown | Determines whether an automatic rolldown to assignments is enabled. Read/write Boolean.
CalculationType | Determines whether rollups are calculated for a task and group summary rows. Read/write CalculationType.
CfType | The type of a custom field. Read/write CustomFieldType.
Default | The default value in the list. Read/write String.
DefaultGuid | The Guid of the default lookup table entry. Read/write String.
ElementType | Determines whether the extended attribute is associated with a task, a resource, or an assignment. Read/write ElementType.
FieldId | Corresponds to the Pid of a custom field. Read/write String.
FieldName | The name of a custom field. Read/write String.
Formula | The formula that Microsoft Project uses to populate a custom task field. Read/write String.
Guid | The Guid of a custom field. Read/write String.
LookupUid | The Guid of the lookup table associated with a custom field. Read/write String.
MaxMultiValues | The maximum number of values you can set in a picklist. Read/write Int32.
PhoneticsAlias | The phonetic pronunciation of the alias of a custom field. Read/write String.
RestrictValues | Determines whether only values in the list are allowed in a file. Read/write Boolean.
RollupType | The way rollups are calculated. Read/write RollupType.
SecondaryGuid | Secondary guid of extended attribute. Read/write String.
SecondaryPid | The secondary Pid of a custom field. Read/write String.
UserDef | Determines whether a custom field is user defined. Read/write Boolean.
ValueList | Returns List<Value> ValueList. Read/write List of Value.
ValuelistSortOrder | The way value lists are sorted. Values are: 0=Descending, 1=Ascending. Read/write Int32.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


Alias Property

ExtendedAttributeDefinition.Alias Property

The alias of a custom field. Read/write String.

public string Alias {get; set;}

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


AppendNewValues Property

ExtendedAttributeDefinition.AppendNewValues Property

Determines whether new values added to a project are automatically added to the list. Read/write Boolean.

public bool AppendNewValues {get; set;}

Remarks

Currently supported for MSP 2003/2007 Xml and MSP 2003 mpp formats.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


AutoRollDown Property

ExtendedAttributeDefinition.AutoRollDown Property

Determines whether an automatic rolldown to assignments is enabled. Read/write Boolean.

public bool AutoRollDown {get; set;}

Remarks

Currently supported for Xml format only.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


CalculationType Property

ExtendedAttributeDefinition.CalculationType Property

Determines whether rollups are calculated for a task and group summary rows. Read/write CalculationType.

public CalculationType CalculationType {get; set;}

Remarks

Currently supported for Xml format only.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


CfType Property

ExtendedAttributeDefinition.CfType Property

The type of a custom field. Read/write CustomFieldType.

public CustomFieldType CfType {get; set;}

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


Default Property

ExtendedAttributeDefinition.Default Property

The default value in the list. Read/write String.

public string Default {get; set;}

Remarks

Currently supported for MSP 2003/2007 Xml and MSP 2003 mpp formats.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


DefaultGuid Property

ExtendedAttributeDefinition.DefaultGuid Property

The Guid of the default lookup table entry. Read/write String.

public string DefaultGuid {get; set;}

Remarks

Currently supported for Xml format only.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


ElementType Property

ExtendedAttributeDefinition.ElementType Property

Determines whether the extended attribute is associated with a task, a resource, or an assignment. Read/write ElementType.

public ElementType ElementType {get; set;}

Remarks

Currently supported for Xml format only.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


FieldId Property

ExtendedAttributeDefinition.FieldId Property

Corresponds to the Pid of a custom field. Read/write String.

public string FieldId {get; set;}

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


FieldName Property

ExtendedAttributeDefinition.FieldName Property

The name of a custom field. Read/write String.

public string FieldName {get; set;}

Remarks

Currently supported for MSP 2003/2007 Xml and MSP 2003 mpp formats.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


Formula Property

ExtendedAttributeDefinition.Formula Property

The formula that Microsoft Project uses to populate a custom task field. Read/write String.

public string Formula {get; set;}

Remarks

Currently supported for Xml format only.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


Guid Property

ExtendedAttributeDefinition.Guid Property

The Guid of a custom field. Read/write String.

public string Guid {get; set;}

Remarks

Currently supported for Xml format only.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


LookupUid Property

ExtendedAttributeDefinition.LookupUid Property

The Guid of the lookup table associated with a custom field. Read/write String.

public string LookupUid {get; set;}

Remarks

Currently supported for Xml format only.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


MaxMultiValues Property

ExtendedAttributeDefinition.MaxMultiValues Property

The maximum number of values you can set in a picklist. Read/write Int32.

public int MaxMultiValues {get; set;}

Remarks

Currently supported for Xml format only.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


PhoneticsAlias Property

ExtendedAttributeDefinition.PhoneticsAlias Property

The phonetic pronunciation of the alias of a custom field. Read/write String.

public string PhoneticsAlias {get; set;}

Remarks

Currently supported for Xml format only.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


RestrictValues Property

ExtendedAttributeDefinition.RestrictValues Property

Determines whether only values in the list are allowed in a file. Read/write Boolean.

public bool RestrictValues {get; set;}

Remarks

Currently supported for MSP 2003/2007 Xml and MSP 2003 mpp formats.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


RollupType Property

ExtendedAttributeDefinition.RollupType Property

The way rollups are calculated. Read/write RollupType.

public RollupType RollupType {get; set;}

Remarks

Currently supported for Xml format only.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


SecondaryGuid Property

ExtendedAttributeDefinition.SecondaryGuid Property

Secondary guid of extended attribute. Read/write String.

public string SecondaryGuid {get; set;}

Remarks

This is new for MS Project 2010 property.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


SecondaryPid Property

ExtendedAttributeDefinition.SecondaryPid Property

The secondary Pid of a custom field. Read/write String.

public string SecondaryPid {get; set;}

Remarks

Currently supported for Xml format only.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


UserDef Property

ExtendedAttributeDefinition.UserDef Property

Determines whether a custom field is user defined. Read/write Boolean.

public bool UserDef {get; set;}

Remarks

Currently supported for Xml format only.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


ValueList Property

ExtendedAttributeDefinition.ValueList Property

Returns List<Value> ValueList. Read/write List of Value.

public Value} ValueList {get; set;}

Remarks

When values of extended attributes are specified as properties of elements in the schema, they may either be specified by values or by references to the values contained in this list. Applications may assume ordering of the list by ordering specified here. Currently supported for MSP 2003/2007 Xml and MSP 2003 mpp formats.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


ValuelistSortOrder Property

ExtendedAttributeDefinition.ValuelistSortOrder Property

The way value lists are sorted. Values are: 0=Descending, 1=Ascending. Read/write Int32.

public int ValuelistSortOrder {get; set;}

Remarks

Currently supported for MSP 2003/2007 Xml and MSP 2003 mpp formats.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


ExtendedAttributeDefinition Methods

The methods of the ExtendedAttributeDefinition class are listed below. For a complete list of ExtendedAttributeDefinition class members, see the ExtendedAttributeDefinition Members topic.

Public Instance Methods

CreateExtendedAttribute | Creates new extended attribute with specified fieldID
Equals |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


ExtendedAttributeDefinition.CreateExtendedAttribute Method

Creates new extended attribute with specified fieldID

public ExtendedAttribute CreateExtendedAttribute();

Return Value

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


ExtendedAttributeDefinition.Equals Method

public override bool Equals(
object obj
);

See Also

ExtendedAttributeDefinition Class | Aspose.Tasks Namespace


ExtendedAttributeResource Enumeration

Specifies the extended attributes FieldId used in a resource.

public enum ExtendedAttributeResource

Members

Member Name | Description | Value
Cost1 |  | 205521019
Cost2 |  | 205521020
Cost3 |  | 205521021
Cost4 |  | 205521062
Cost5 |  | 205521063
Cost6 |  | 205521064
Cost7 |  | 205521065
Cost8 |  | 205521066
Cost9 |  | 205521067
Cost10 |  | 205521068
Date1 |  | 205521069
Date2 |  | 205521070
Date3 |  | 205521071
Date4 |  | 205521072
Date5 |  | 205521073
Date6 |  | 205521074
Date7 |  | 205521075
Date8 |  | 205521076
Date9 |  | 205521077
Date10 |  | 205521078
Duration1 |  | 205521013
Duration2 |  | 205521014
Duration3 |  | 205521015
Duration4 |  | 205521079
Duration5 |  | 205521080
Duration6 |  | 205521081
Duration7 |  | 205521082
Duration8 |  | 205521083
Duration9 |  | 205521084
Duration10 |  | 205521085
Finish1 |  | 205521003
Finish2 |  | 205521004
Finish3 |  | 205521005
Finish4 |  | 205521006
Finish5 |  | 205521007
Finish6 |  | 205521086
Finish7 |  | 205521087
Finish8 |  | 205521088
Finish9 |  | 205521089
Finish10 |  | 205521090
Flag1 |  | 205521023
Flag2 |  | 205521024
Flag3 |  | 205521025
Flag4 |  | 205521026
Flag5 |  | 205521027
Flag6 |  | 205521028
Flag7 |  | 205521029
Flag8 |  | 205521030
Flag9 |  | 205521031
Flag10 |  | 205521022
Flag11 |  | 205521091
Flag12 |  | 205521092
Flag13 |  | 205521093
Flag14 |  | 205521094
Flag15 |  | 205521095
Flag16 |  | 205521096
Flag17 |  | 205521097
Flag18 |  | 205521098
Flag19 |  | 205521099
Flag20 |  | 205521100
Number1 |  | 205521008
Number2 |  | 205521009
Number3 |  | 205521010
Number4 |  | 205521011
Number5 |  | 205521012
Number6 |  | 205521101
Number7 |  | 205521102
Number8 |  | 205521103
Number9 |  | 205521104
Number10 |  | 205521105
Number11 |  | 205521106
Number12 |  | 205521107
Number13 |  | 205521108
Number14 |  | 205521109
Number15 |  | 205521110
Number16 |  | 205521111
Number17 |  | 205521112
Number18 |  | 205521113
Number19 |  | 205521114
Number20 |  | 205521115
Start1 |  | 205520998
Start2 |  | 205520999
Start3 |  | 205521000
Start4 |  | 205521001
Start5 |  | 205521002
Start6 |  | 205521116
Start7 |  | 205521117
Start8 |  | 205521118
Start9 |  | 205521119
Start10 |  | 205521120
Text1 |  | 205520904
Text2 |  | 205520905
Text3 |  | 205520926
Text4 |  | 205520927
Text5 |  | 205520928
Text6 |  | 205520993
Text7 |  | 205520994
Text8 |  | 205520995
Text9 |  | 205520996
Text10 |  | 205520997
Text11 |  | 205521121
Text12 |  | 205521122
Text13 |  | 205521123
Text14 |  | 205521124
Text15 |  | 205521125
Text16 |  | 205521126
Text17 |  | 205521127
Text18 |  | 205521128
Text19 |  | 205521129
Text20 |  | 205521130
Text21 |  | 205521131
Text22 |  | 205521132
Text23 |  | 205521133
Text24 |  | 205521134
Text25 |  | 205521135
Text26 |  | 205521136
Text27 |  | 205521137
Text28 |  | 205521138
Text29 |  | 205521139
Text30 |  | 205521140
OutlineCode1 |  | 205521174
OutlineCode2 |  | 205521176
OutlineCode3 |  | 205521178
OutlineCode4 |  | 205521180
OutlineCode5 |  | 205521182
OutlineCode6 |  | 205521184
OutlineCode7 |  | 205521186
OutlineCode8 |  | 205521188
OutlineCode9 |  | 205521190
OutlineCode10 |  | 205521192

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


ExtendedAttributeTask Enumeration

Specifies the extended attributes FieldId used in a task.

public enum ExtendedAttributeTask

Members

Member Name | Description | Value
Cost1 |  | 188743786
Cost2 |  | 188743787
Cost3 |  | 188743788
Cost4 |  | 188743938
Cost5 |  | 188743939
Cost6 |  | 188743940
Cost7 |  | 188743941
Cost8 |  | 188743942
Cost9 |  | 188743943
Cost10 |  | 188743944
Date1 |  | 188743945
Date2 |  | 188743946
Date3 |  | 188743947
Date4 |  | 188743948
Date5 |  | 188743949
Date6 |  | 188743950
Date7 |  | 188743951
Date8 |  | 188743952
Date9 |  | 188743953
Date10 |  | 188743954
Duration1 |  | 188743783
Duration2 |  | 188743784
Duration3 |  | 188743785
Duration4 |  | 188743955
Duration5 |  | 188743956
Duration6 |  | 188743957
Duration7 |  | 188743958
Duration8 |  | 188743959
Duration9 |  | 188743960
Duration10 |  | 188743961
Finish1 |  | 188743733
Finish2 |  | 188743736
Finish3 |  | 188743739
Finish4 |  | 188743742
Finish5 |  | 188743745
Finish6 |  | 188743963
Finish7 |  | 188743965
Finish8 |  | 188743967
Finish9 |  | 188743969
Finish10 |  | 188743971
Flag1 |  | 188743752
Flag2 |  | 188743753
Flag3 |  | 188743754
Flag4 |  | 188743755
Flag5 |  | 188743756
Flag6 |  | 188743757
Flag7 |  | 188743758
Flag8 |  | 188743759
Flag9 |  | 188743760
Flag10 |  | 188743761
Flag11 |  | 188743972
Flag12 |  | 188743973
Flag13 |  | 188743974
Flag14 |  | 188743975
Flag15 |  | 188743976
Flag16 |  | 188743977
Flag17 |  | 188743978
Flag18 |  | 188743979
Flag19 |  | 188743980
Flag20 |  | 188743981
Number1 |  | 188743767
Number2 |  | 188743768
Number3 |  | 188743769
Number4 |  | 188743770
Number5 |  | 188743771
Number6 |  | 188743982
Number7 |  | 188743983
Number8 |  | 188743984
Number9 |  | 188743985
Number10 |  | 188743986
Number11 |  | 188743987
Number12 |  | 188743988
Number13 |  | 188743989
Number14 |  | 188743990
Number15 |  | 188743991
Number16 |  | 188743992
Number17 |  | 188743993
Number18 |  | 188743994
Number19 |  | 188743995
Number20 |  | 188743996
Start1 |  | 188743732
Start2 |  | 188743735
Start3 |  | 188743738
Start4 |  | 188743741
Start5 |  | 188743744
Start6 |  | 188743962
Start7 |  | 188743964
Start8 |  | 188743966
Start9 |  | 188743968
Start10 |  | 188743970
Text1 |  | 188743731
Text2 |  | 188743734
Text3 |  | 188743737
Text4 |  | 188743740
Text5 |  | 188743743
Text6 |  | 188743746
Text7 |  | 188743747
Text8 |  | 188743748
Text9 |  | 188743749
Text10 |  | 188743750
Text11 |  | 188743997
Text12 |  | 188743998
Text13 |  | 188743999
Text14 |  | 188744000
Text15 |  | 188744001
Text16 |  | 188744002
Text17 |  | 188744003
Text18 |  | 188744004
Text19 |  | 188744005
Text20 |  | 188744006
Text21 |  | 188744007
Text22 |  | 188744008
Text23 |  | 188744009
Text24 |  | 188744010
Text25 |  | 188744011
Text26 |  | 188744012
Text27 |  | 188744013
Text28 |  | 188744014
Text29 |  | 188744015
Text30 |  | 188744016
OutlineCode1 |  | 188744096
OutlineCode2 |  | 188744098
OutlineCode3 |  | 188744100
OutlineCode4 |  | 188744102
OutlineCode5 |  | 188744104
OutlineCode6 |  | 188744106
OutlineCode7 |  | 188744108
OutlineCode8 |  | 188744110
OutlineCode9 |  | 188744112
OutlineCode10 |  | 188744114

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


Field Enumeration

Specifies a field in the Microsoft Office Project.

public enum Field

Members

Member Name | Description | Value
Undefined | Undefined field. | 0
ImportResource | Represents the Import (Resource) field. | 205521651
ResourceAccrueAt | Represents the Accrue At (Resource) field. | 205520915
ResourceActualCost | Represents the Actual Cost (Resource) field. | 205520907
ResourceActualOvertimeCost | Represents the Actual Overtime Cost (Resource) field. | 205520944
ResourceActualOvertimeWork | Represents the Actual Overtime Work (Resource) field. | 205520935
ResourceActualOvertimeWorkProtected | Represents the Actual Overtime Work Protected (Resource) field. | 205521617
ResourceActualWork | Represents the Actual Work (Resource) field. | 205520910
ResourceActualWorkProtected | Represents the Actual Work Protected (Resource) field. | 205521616
ResourceACWP | Represents the ACWP (Resource) field. | 205520949
ResourceAssignmentDelay | Represents the Assignment Delay (Resource) field. | 205521153
ResourceAssignmentUnits | Represents the Assignment Units (Resource) field. | 205521154
ResourceAvailableFrom | Represents the Available From (Resource) field. | 205520953
ResourceAvailableTo | Represents the Available To (Resource) field. | 205520954
ResourceBaseCalendar | Represents the Base Calendar (Resource) field. | 205520901
ResourceBaseline10BudgetCost | Represents the Baseline10 Budget Cost (Resource) field. | 205521693
ResourceBaseline10BudgetWork | Represents the Baseline10 Budget Work (Resource) field. | 205521692
ResourceBaseline10Cost | Represents the Baseline10 Cost (Resource) field. | 205521329
ResourceBaseline10Finish | Represents the Baseline10 Finish (Resource) field. | 205521335
ResourceBaseline10Start | Represents the Baseline10 Start (Resource) field. | 205521334
ResourceBaseline10Work | Represents the Baseline10 Work (Resource) field. | 205521328
ResourceBaseline1BudgetCost | Represents the Baseline1 Cost Budget (Resource) field. | 205521657
ResourceBaseline1BudgetWork | Represents the Baseline1 Budget Work (Resource) field. | 205521656
ResourceBaseline1Cost | Represents the Baseline1 Cost (Resource) field. | 205521239
ResourceBaseline1Finish | Represents the Baseline1 Finish (Resource) field. | 205521245
ResourceBaseline1Start | Represents the Baseline1 Start (Resource) field. | 205521244
ResourceBaseline1Work | Represents the Baseline1 Work (Resource) field. | 205521238
ResourceBaseline2BudgetCost | Represents the Baseline2 Budget Cost (Resource) field. | 205521661
ResourceBaseline2BudgetWork | Represents the Baseline2 Budget Work (Resource) field. | 205521660
ResourceBaseline2Cost | Represents the Baseline2 Cost (Resource) field. | 205521249
ResourceBaseline2Finish | Represents the Baseline2 Finish (Resource) field. | 205521255
ResourceBaseline2Start | Represents the Baseline2 Start (Resource) field. | 205521254
ResourceBaseline2Work | Represents the Baseline2 Work (Resource) field. | 205521248
ResourceBaseline3BudgetCost | Represents the Baseline3 Cost Budget (Resource) field. | 205521665
ResourceBaseline3BudgetWork | Represents the Baseline3 Budget Work (Resource) field. | 205521664
ResourceBaseline3Cost | Represents the Baseline3 Cost (Resource) field. | 205521259
ResourceBaseline3Finish | Represents the Baseline3 Finish (Resource) field. | 205521265
ResourceBaseline3Start | Represents the Baseline3 Start (Resource) field. | 205521264
ResourceBaseline3Work | Represents the Baseline3 Work (Resource) field. | 205521258
ResourceBaseline4BudgetCost | Represents the Baseline4 Cost Budget (Resource) field. | 205521669
ResourceBaseline4BudgetWork | Represents the Baseline4 Budget Work (Resource) field. | 205521668
ResourceBaseline4Cost | Represents the Baseline4 Cost (Resource) field. | 205521269
ResourceBaseline4Finish | Represents the Baseline4 Finish (Resource) field. | 205521275
ResourceBaseline4Start | Represents the Baseline4 Start (Resource) field. | 205521274
ResourceBaseline4Work | Represents the Baseline5 Work (Resource) field. | 205521268
ResourceBaseline5BudgetCost | Represents the Baseline5 Budget Cost (Resource) field. | 205521673
ResourceBaseline5BudgetWork | Represents the Baseline5 Budget Work (Resource) field. | 205521672
ResourceBaseline5Cost | Represents the Baseline5 Cost (Resource) field. | 205521279
ResourceBaseline5Finish | Represents the Baseline5 Finish (Resource) field. | 205521285
ResourceBaseline5Start | Represents the Baseline5 Start (Resource) field. | 205521284
ResourceBaseline5Work | Represents the Baseline5 Work (Resource) field. | 205521278
ResourceBaseline6BudgetCost | Represents the Baseline6 Budget Cost (Resource) field. | 205521677
ResourceBaseline6BudgetWork | Represents the Baseline6 Budget Work (Resource) field. | 205521676
ResourceBaseline6Cost | Represents the Baseline6 Cost (Resource) field. | 205521289
ResourceBaseline6Finish | Represents the Baseline6 Finish (Resource) field. | 205521295
ResourceBaseline6Start | Represents the Baseline6 Start (Resource) field. | 205521294
ResourceBaseline6Work | Represents the Baseline6 Work (Resource) field. | 205521288
ResourceBaseline7BudgetCost | Represents the Baseline7 Budget Cost (Resource) field. | 205521681
ResourceBaseline7BudgetWork | Represents the Baselin7 Budget Work (Resource) field. | 205521680
ResourceBaseline7Cost | Represents the Baseline7 Cost (Resource) field. | 205521299
ResourceBaseline7Finish | Represents the Baseline7 Finish (Resource) field. | 205521305
ResourceBaseline7Start | Represents the Baseline7 Start (Resource) field. | 205521304
ResourceBaseline7Work | Represents the Baseline7 Work (Resource) field. | 205521298
ResourceBaseline8BudgetCost | Represents the Baseline8 Budget Cost (Resource) field. | 205521685
ResourceBaseline8BudgetWork | Represents the Baseline8 Budget Work (Resource) field. | 205521684
ResourceBaseline8Cost | Represents the Baseline8 Cost (Resource) field. | 205521309
ResourceBaseline8Finish | Represents the Baseline8 Finish (Resource) field. | 205521315
ResourceBaseline8Start | Represents the Baseline8 Start (Resource) field. | 205521314
ResourceBaseline8Work | Represents the Baseline8 Work (Resource) field. | 205521308
ResourceBaseline9BudgetCost | Represents the Baseline9 Budget Cost (Resource) field. | 205521689
ResourceBaseline9BudgetWork | Represents the Baseline9 Budget Work (Resource) field. | 205521688
ResourceBaseline9Cost | Represents the Baseline9 Cost (Resource) field. | 205521319
ResourceBaseline9Finish | Represents the Baseline9 Finish (Resource) field. | 205521325
ResourceBaseline9Start | Represents the Baseline9 Start (Resource) field. | 205521324
ResourceBaseline9Work | Represents the Baseline9 Work (Resource) field. | 205521318
ResourceBaselineBudgetCost | Represents the Baseline Budget Cost (Resource) field. | 205521653
ResourceBaselineBudgetWork | Represents the Baseline Budget Work (Resource) field. | 205521652
ResourceBaselineCost | Represents the Baseline Cost (Resource) field. | 205520913
ResourceBaselineFinish | Represents the Baseline Finish (Resource) field. | 205521156
ResourceBaselineStart | Represents the Baseline Start (Resource) field. | 205521155
ResourceBaselineWork | Represents the Baseline Work (Resource) field. | 205520911
ResourceBCWP | Represents the BCWP (Resource) field. | 205520948
ResourceBCWS | Represents the BCWS (Resource) field. | 205520947
ResourceBookingType | Represents the Booking Type (Resource) field. | 205521595
ResourceBudget | Represents the Budget (Resource) field. | 205521648
ResourceBudgetCost | Represents the Budget Cost (Resource) field. | 205521650
ResourceBudgetWork | Represents the Budget Work (Resource) field. | 205521649
ResourceCalendarGuid | Represents the Calendar GUID (Resource) field. | 205521625
ResourceCanLevel | Represents the Can Level (Resource) field. | 205521059
ResourceCode | Represents the Code (Resource) field. | 205520906
ResourceConfirmed | Represents the Confirmed (Resource) field. | 205521157
ResourceCost | Represents the Cost (Resource) field. | 205520908
ResourceCost1 | Represents the Cost1 (Resource) field. | 205521019
ResourceCost10 | Represents the Cost10 (Resource) field. | 205521068
ResourceCost2 | Represents the Cost2 (Resource) field. | 205521020
ResourceCost3 | Represents the Cost3 (Resource) field. | 205521021
ResourceCost4 | Represents the Cost4 (Resource) field. | 205521062
ResourceCost5 | Represents the Cost5 (Resource) field. | 205521063
ResourceCost6 | Represents the Cost6 (Resource) field. | 205521064
ResourceCost7 | Represents the Cost7 (Resource) field. | 205521065
ResourceCost8 | Represents the Cost8 (Resource) field. | 205521066
ResourceCost9 | Represents the Cost9 (Resource) field. | 205521067
ResourceCostCenter | Represents the Cost Center (Resource) field. | 205521697
ResourceCostPerUse | Represents the Cost Per Use (Resource) field. | 205520914
ResourceCostRateTable | Represents the Cost Rate Table (Resource) field. | 205521165
ResourceCostVariance | Represents the Cost Variance (Resource) field. | 205520920
ResourceCreated | Represents the Created (Resource) field. | 205521622
ResourceCV | Represents the CV (Resource) field. | 205521164
ResourceDate1 | Represents the Date1 (Resource) field. | 205521069
ResourceDate10 | Represents the Date10 (Resource) field. | 205521078
ResourceDate2 | Represents the Date2 (Resource) field. | 205521070
ResourceDate3 | Represents the Date3 (Resource) field. | 205521071
ResourceDate4 | Represents the Date4 (Resource) field. | 205521072
ResourceDate5 | Represents the Date5 (Resource) field. | 205521073
ResourceDate6 | Represents the Date6 (Resource) field. | 205521074
ResourceDate7 | Represents the Date7 (Resource) field. | 205521075
ResourceDate8 | Represents the Date8 (Resource) field. | 205521076
ResourceDate9 | Represents the Date9 (Resource) field. | 205521077
ResourceDefaultAssignmentOwner | Represents the Default Assignment Owner (Resource) field. | 205521636
ResourceDemandedRequested | Represents the Demanded Requested (Resource) field. | 205521586
ResourceDuration1 | Represents the Duration1 (Resource) field. | 205521013
ResourceDuration10 | Represents the Duration10 (Resource) field. | 205521085
ResourceDuration2 | Represents the Duration2 (Resource) field. | 205521014
ResourceDuration3 | Represents the Duration3 (Resource) field. | 205521015
ResourceDuration4 | Represents the Duration4 (Resource) field. | 205521079
ResourceDuration5 | Represents the Duration5 (Resource) field. | 205521080
ResourceDuration6 | Represents the Duration6 (Resource) field. | 205521081
ResourceDuration7 | Represents the Duration7 (Resource) field. | 205521082
ResourceDuration8 | Represents the Duration8 (Resource) field. | 205521083
ResourceDuration9 | Represents the Duration9 (Resource) field. | 205521084
ResourceEMailAddress | Represents the EMail Address (Resource) field. | 205520931
ResourceEnterprise | Represents the Enterprise (Resource) field. | 205521587
ResourceEnterpriseBaseCalendar | Represents the Enterprise Base Calendar (Resource) field. | 205521583
ResourceEnterpriseCheckedOutBy | Represents the Enterprise Checked Out By (Resource) field. | 205521589
ResourceEnterpriseCost1 | Represents the Enterprise Cost1 (Resource) field. | 205521342
ResourceEnterpriseCost10 | Represents the Enterprise Cost10 (Resource) field. | 205521351
ResourceEnterpriseCost2 | Represents the Enterprise Cost2 (Resource) field. | 205521343
ResourceEnterpriseCost3 | Represents the Enterprise Cost3 (Resource) field. | 205521344
ResourceEnterpriseCost4 | Represents the Enterprise Cost4 (Resource) field. | 205521345
ResourceEnterpriseCost5 | Represents the Enterprise Cost5 (Resource) field. | 205521346
ResourceEnterpriseCost6 | Represents the Enterprise Cost6 (Resource) field. | 205521347
ResourceEnterpriseCost7 | Represents the Enterprise Cost7 (Resource) field. | 205521348
ResourceEnterpriseCost8 | Represents the Enterprise Cost8 (Resource) field. | 205521349
ResourceEnterpriseCost9 | Represents the Enterprise Cost9 (Resource) field. | 205521350
ResourceEnterpriseDate1 | Represents the Enterprise Date1 (Resource) field. | 205521352
ResourceEnterpriseDate10 | Represents the Enterprise Date10 (Resource) field. | 205521361
ResourceEnterpriseDate11 | Represents the Enterprise Date11 (Resource) field. | 205521362
ResourceEnterpriseDate12 | Represents the Enterprise Date12 (Resource) field. | 205521363
ResourceEnterpriseDate13 | Represents the Enterprise Date13 (Resource) field. | 205521364
ResourceEnterpriseDate14 | Represents the Enterprise Date14 (Resource) field. | 205521365
ResourceEnterpriseDate15 | Represents the Enterprise Date15 (Resource) field. | 205521366
ResourceEnterpriseDate16 | Represents the Enterprise Date16 (Resource) field. | 205521367
ResourceEnterpriseDate17 | Represents the Enterprise Date17 (Resource) field. | 205521368
ResourceEnterpriseDate18 | Represents the Enterprise Date18 (Resource) field. | 205521369
ResourceEnterpriseDate19 | Represents the Enterprise Date19 (Resource) field. | 205521370
ResourceEnterpriseDate2 | Represents the Enterprise Date2 (Resource) field. | 205521353
ResourceEnterpriseDate20 | Represents the Enterprise Date20 (Resource) field. | 205521371
ResourceEnterpriseDate21 | Represents the Enterprise Date21 (Resource) field. | 205521372
ResourceEnterpriseDate22 | Represents the Enterprise Date22 (Resource) field. | 205521373
ResourceEnterpriseDate23 | Represents the Enterprise Date23 (Resource) field. | 205521374
ResourceEnterpriseDate24 | Represents the Enterprise Date24 (Resource) field. | 205521375
ResourceEnterpriseDate25 | Represents the Enterprise Date25 (Resource) field. | 205521376
ResourceEnterpriseDate26 | Represents the Enterprise Date26 (Resource) field. | 205521377
ResourceEnterpriseDate27 | Represents the Enterprise Date27 (Resource) field. | 205521378
ResourceEnterpriseDate28 | Represents the Enterprise Date28 (Resource) field. | 205521379
ResourceEnterpriseDate29 | Represents the Enterprise Date29 (Resource) field. | 205521380
ResourceEnterpriseDate3 | Represents the Enterprise Date3 (Resource) field. | 205521354
ResourceEnterpriseDate30 | Represents the Enterprise Date30 (Resource) field. | 205521381
ResourceEnterpriseDate4 | Represents the Enterprise Date4 (Resource) field. | 205521355
ResourceEnterpriseDate5 | Represents the Enterprise Date5 (Resource) field. | 205521356
ResourceEnterpriseDate6 | Represents the Enterprise Date6 (Resource) field. | 205521357
ResourceEnterpriseDate7 | Represents the Enterprise Date7 (Resource) field. | 205521358
ResourceEnterpriseDate8 | Represents the Enterprise Date8 (Resource) field. | 205521359
ResourceEnterpriseDate9 | Represents the Enterprise Date9 (Resource) field. | 205521360
ResourceEnterpriseDuration1 | Represents the Enterprise Duration1 (Resource) field. | 205521382
ResourceEnterpriseDuration10 | Represents the Enterprise Duration10 (Resource) field. | 205521391
ResourceEnterpriseDuration2 | Represents the Enterprise Duration2 (Resource) field. | 205521383
ResourceEnterpriseDuration3 | Represents the Enterprise Duration3 (Resource) field. | 205521384
ResourceEnterpriseDuration4 | Represents the Enterprise Duration4 (Resource) field. | 205521385
ResourceEnterpriseDuration5 | Represents the Enterprise Duration5 (Resource) field. | 205521386
ResourceEnterpriseDuration6 | Represents the Enterprise Duration6 (Resource) field. | 205521387
ResourceEnterpriseDuration7 | Represents the Enterprise Duration7 (Resource) field. | 205521388
ResourceEnterpriseDuration8 | Represents the Enterprise Duration8 (Resource) field. | 205521389
ResourceEnterpriseDuration9 | Represents the Enterprise Duration9 (Resource) field. | 205521390
ResourceEnterpriseFlag1 | Represents the Enterprise Flag1 (Resource) field. | 205521402
ResourceEnterpriseFlag10 | Represents the Enterprise Flag10 (Resource) field. | 205521411
ResourceEnterpriseFlag11 | Represents the Enterprise Flag11 (Resource) field. | 205521412
ResourceEnterpriseFlag12 | Represents the Enterprise Flag12 (Resource) field. | 205521413
ResourceEnterpriseFlag13 | Represents the Enterprise Flag13 (Resource) field. | 205521414
ResourceEnterpriseFlag14 | Represents the Enterprise Flag14 (Resource) field. | 205521415
ResourceEnterpriseFlag15 | Represents the Enterprise Flag15 (Resource) field. | 205521416
ResourceEnterpriseFlag16 | Represents the Enterprise Flag16 (Resource) field. | 205521417
ResourceEnterpriseFlag17 | Represents the Enterprise Flag17 (Resource) field. | 205521418
ResourceEnterpriseFlag18 | Represents the Enterprise Flag18 (Resource) field. | 205521419
ResourceEnterpriseFlag19 | Represents the Enterprise Flag19 (Resource) field. | 205521420
ResourceEnterpriseFlag2 | Represents the Enterprise Flag2 (Resource) field. | 205521403
ResourceEnterpriseFlag20 | Represents the Enterprise Flag20 (Resource) field. | 205521421
ResourceEnterpriseFlag3 | Represents the Enterprise Flag3 (Resource) field. | 205521404
ResourceEnterpriseFlag4 | Represents the Enterprise Flag4 (Resource) field. | 205521405
ResourceEnterpriseFlag5 | Represents the Enterprise Flag5 (Resource) field. | 205521406
ResourceEnterpriseFlag6 | Represents the Enterprise Flag6 (Resource) field. | 205521407
ResourceEnterpriseFlag7 | Represents the Enterprise Flag7 (Resource) field. | 205521408
ResourceEnterpriseFlag8 | Represents the Enterprise Flag8 (Resource) field. | 205521409
ResourceEnterpriseFlag9 | Represents the Enterprise Flag9 (Resource) field. | 205521410
ResourceEnterpriseGeneric | Represents the Enterprise Generic (Resource) field. | 205521582
ResourceEnterpriseInactive | Represents the Enterprise Inactive (Resource) field. | 205521592
ResourceEnterpriseIsCheckedOut | Represents the Enterprise Is Checked Out (Resource) field. | 205521588
ResourceEnterpriseLastModifiedDate | Represents the Enterprise Date1 (Resource) field. | 205521590
ResourceEnterpriseMultiValue20 | Represents the Enterprise MultiValue20 (Resource) field. | 205521596
ResourceEnterpriseMultiValue21 | Represents the Enterprise MultiValue21 (Resource) field. | 205521598
ResourceEnterpriseMultiValue22 | Represents the Enterprise MultiValue22 (Resource) field. | 205521600
ResourceEnterpriseMultiValue23 | Represents the Enterprise MultiValue23 (Resource) field. | 205521602
ResourceEnterpriseMultiValue24 | Represents the Enterprise MultiValue24 (Resource) field. | 205521604
ResourceEnterpriseMultiValue25 | Represents the Enterprise MultiValue25 (Resource) field. | 205521606
ResourceEnterpriseMultiValue26 | Represents the Enterprise MultiValue26 (Resource) field. | 205521608
ResourceEnterpriseMultiValue27 | Represents the Enterprise MultiValue27 (Resource) field. | 205521610
ResourceEnterpriseMultiValue28 | Represents the Enterprise MultiValue28 (Resource) field. | 205521612
ResourceEnterpriseMultiValue29 | Represents the Enterprise MultiValue29 (Resource) field. | 205521614
ResourceEnterpriseNameUsed | Represents the Enterprise Name Used (Resource) field. | 205521585
ResourceEnterpriseNumber1 | Represents the Enterprise Number1 (Resource) field. | 205521442
ResourceEnterpriseNumber10 | Represents the Enterprise Number10 (Resource) field. | 205521451
ResourceEnterpriseNumber11 | Represents the Enterprise Number11 (Resource) field. | 205521452
ResourceEnterpriseNumber12 | Represents the Enterprise Number12 (Resource) field. | 205521453
ResourceEnterpriseNumber13 | Represents the Enterprise Number13 (Resource) field. | 205521454
ResourceEnterpriseNumber14 | Represents the Enterprise Number14 (Resource) field. | 205521455
ResourceEnterpriseNumber15 | Represents the Enterprise Number15 (Resource) field. | 205521456
ResourceEnterpriseNumber16 | Represents the Enterprise Number16 (Resource) field. | 205521457
ResourceEnterpriseNumber17 | Represents the Enterprise Number17 (Resource) field. | 205521458
ResourceEnterpriseNumber18 | Represents the Enterprise Number18 (Resource) field. | 205521459
ResourceEnterpriseNumber19 | Represents the Enterprise Number19 (Resource) field. | 205521460
ResourceEnterpriseNumber2 | Represents the Enterprise Number2 (Resource) field. | 205521443
ResourceEnterpriseNumber20 | Represents the Enterprise Number20 (Resource) field. | 205521461
ResourceEnterpriseNumber21 | Represents the Enterprise Number21 (Resource) field. | 205521462
ResourceEnterpriseNumber22 | Represents the Enterprise Number22 (Resource) field. | 205521463
ResourceEnterpriseNumber23 | Represents the Enterprise Number23 (Resource) field. | 205521464
ResourceEnterpriseNumber24 | Represents the Enterprise Number24 (Resource) field. | 205521465
ResourceEnterpriseNumber25 | Represents the Enterprise Number25 (Resource) field. | 205521466
ResourceEnterpriseNumber26 | Represents the Enterprise Number26 (Resource) field. | 205521467
ResourceEnterpriseNumber27 | Represents the Enterprise Number27 (Resource) field. | 205521468
ResourceEnterpriseNumber28 | Represents the Enterprise Number28 (Resource) field. | 205521469
ResourceEnterpriseNumber29 | Represents the Enterprise Number29 (Resource) field. | 205521470
ResourceEnterpriseNumber3 | Represents the Enterprise Number3 (Resource) field. | 205521444
ResourceEnterpriseNumber30 | Represents the Enterprise Number30 (Resource) field. | 205521471
ResourceEnterpriseNumber31 | Represents the Enterprise Number31 (Resource) field. | 205521472
ResourceEnterpriseNumber32 | Represents the Enterprise Number32 (Resource) field. | 205521473
ResourceEnterpriseNumber33 | Represents the Enterprise Number33 (Resource) field. | 205521474
ResourceEnterpriseNumber34 | Represents the Enterprise Number34 (Resource) field. | 205521475
ResourceEnterpriseNumber35 | Represents the Enterprise Number35 (Resource) field. | 205521476
ResourceEnterpriseNumber36 | Represents the Enterprise Number36 (Resource) field. | 205521477
ResourceEnterpriseNumber37 | Represents the Enterprise Number37 (Resource) field. | 205521478
ResourceEnterpriseNumber38 | Represents the Enterprise Number38 (Resource) field. | 205521479
ResourceEnterpriseNumber39 | Represents the Enterprise Number39 (Resource) field. | 205521480
ResourceEnterpriseNumber4 | Represents the Enterprise Number4 (Resource) field. | 205521445
ResourceEnterpriseNumber40 | Represents the Enterprise Number40 (Resource) field. | 205521481
ResourceEnterpriseNumber5 | Represents the Enterprise Number5 (Resource) field. | 205521446
ResourceEnterpriseNumber6 | Represents the Enterprise Number6 (Resource) field. | 205521447
ResourceEnterpriseNumber7 | Represents the Enterprise Number7 (Resource) field. | 205521448
ResourceEnterpriseNumber8 | Represents the Enterprise Number8 (Resource) field. | 205521449
ResourceEnterpriseNumber9 | Represents the Enterprise Number9 (Resource) field. | 205521450
ResourceEnterpriseOutlineCode1 | Represents the Enterprise Outline Code1 (Resource) field. | 205521482
ResourceEnterpriseOutlineCode10 | Represents the Enterprise Outline Code10 (Resource) field. | 205521500
ResourceEnterpriseOutlineCode11 | Represents the Enterprise Outline Code11 (Resource) field. | 205521502
ResourceEnterpriseOutlineCode12 | Represents the Enterprise Outline Code12 (Resource) field. | 205521504
ResourceEnterpriseOutlineCode13 | Represents the Enterprise Outline Code13 (Resource) field. | 205521506
ResourceEnterpriseOutlineCode14 | Represents the Enterprise Outline Code14 (Resource) field. | 205521508
ResourceEnterpriseOutlineCode15 | Represents the Enterprise Outline Code15 (Resource) field. | 205521510
ResourceEnterpriseOutlineCode16 | Represents the Enterprise Outline Code16 (Resource) field. | 205521512
ResourceEnterpriseOutlineCode17 | Represents the Enterprise Outline Code17 (Resource) field. | 205521514
ResourceEnterpriseOutlineCode18 | Represents the Enterprise Outline Code18 (Resource) field. | 205521516
ResourceEnterpriseOutlineCode19 | Represents the Enterprise Outline Code19 (Resource) field. | 205521518
ResourceEnterpriseOutlineCode2 | Represents the Enterprise Outline Code2 (Resource) field. | 205521484
ResourceEnterpriseOutlineCode20 | Represents the Enterprise Outline Code20 (Resource) field. | 205521520
ResourceEnterpriseOutlineCode21 | Represents the Enterprise Outline Code21 (Resource) field. | 205521522
ResourceEnterpriseOutlineCode22 | Represents the Enterprise Outline Code22 (Resource) field. | 205521524
ResourceEnterpriseOutlineCode23 | Represents the Enterprise Outline Code23 (Resource) field. | 205521526
ResourceEnterpriseOutlineCode24 | Represents the Enterprise Outline Code24 (Resource) field. | 205521528
ResourceEnterpriseOutlineCode25 | Represents the Enterprise Outline Code25 (Resource) field. | 205521530
ResourceEnterpriseOutlineCode26 | Represents the Enterprise Outline Code26 (Resource) field. | 205521532
ResourceEnterpriseOutlineCode27 | Represents the Enterprise Outline Code27 (Resource) field. | 205521534
ResourceEnterpriseOutlineCode28 | Represents the Enterprise Outline Code28 (Resource) field. | 205521536
ResourceEnterpriseOutlineCode29 | Represents the Enterprise Outline Code29 (Resource) field. | 205521538
ResourceEnterpriseOutlineCode3 | Represents the Enterprise Outline Code3 (Resource) field. | 205521486
ResourceEnterpriseOutlineCode4 | Represents the Enterprise Outline Code4 (Resource) field. | 205521488
ResourceEnterpriseOutlineCode5 | Represents the Enterprise Outline Code5 (Resource) field. | 205521490
ResourceEnterpriseOutlineCode6 | Represents the Enterprise Outline Code6 (Resource) field. | 205521492
ResourceEnterpriseOutlineCode7 | Represents the Enterprise Outline Code7 (Resource) field. | 205521494
ResourceEnterpriseOutlineCode8 | Represents the Enterprise Outline Code8 (Resource) field. | 205521496
ResourceEnterpriseOutlineCode9 | Represents the Enterprise Outline Code9 (Resource) field. | 205521498
ResourceEnterpriseRBS | Represents the Enterprise RBS (Resource) field. | 205521540
ResourceEnterpriseRequiredValues | Represents the Enterprise Required Values (Resource) field. | 205521584
ResourceEnterpriseTeamMember | Represents the Enterprise Team Member (Resource) field. | 205521591
ResourceEnterpriseText1 | Represents the Enterprise Text1 (Resource) field. | 205521542
ResourceEnterpriseText10 | Represents the Enterprise Text10 (Resource) field. | 205521551
ResourceEnterpriseText11 | Represents the Enterprise Text11 (Resource) field. | 205521552
ResourceEnterpriseText12 | Represents the Enterprise Text12 (Resource) field. | 205521553
ResourceEnterpriseText13 | Represents the Enterprise Text13 (Resource) field. | 205521554
ResourceEnterpriseText14 | Represents the Enterprise Text14 (Resource) field. | 205521555
ResourceEnterpriseText15 | Represents the Enterprise Text15 (Resource) field. | 205521556
ResourceEnterpriseText16 | Represents the Enterprise Text16 (Resource) field. | 205521557
ResourceEnterpriseText17 | Represents the Enterprise Text17 (Resource) field. | 205521558
ResourceEnterpriseText18 | Represents the Enterprise Text18 (Resource) field. | 205521559
ResourceEnterpriseText19 | Represents the Enterprise Text19 (Resource) field. | 205521560
ResourceEnterpriseText2 | Represents the Enterprise Text2 (Resource) field. | 205521543
ResourceEnterpriseText20 | Represents the Enterprise Text20 (Resource) field. | 205521561
ResourceEnterpriseText21 | Represents the Enterprise Text21 (Resource) field. | 205521562
ResourceEnterpriseText22 | Represents the Enterprise Text22 (Resource) field. | 205521563
ResourceEnterpriseText23 | Represents the Enterprise Text23 (Resource) field. | 205521564
ResourceEnterpriseText24 | Represents the Enterprise Text24 (Resource) field. | 205521565
ResourceEnterpriseText25 | Represents the Enterprise Text25 (Resource) field. | 205521566
ResourceEnterpriseText26 | Represents the Enterprise Text26 (Resource) field. | 205521567
ResourceEnterpriseText27 | Represents the Enterprise Text27 (Resource) field. | 205521568
ResourceEnterpriseText28 | Represents the Enterprise Text28 (Resource) field. | 205521569
ResourceEnterpriseText29 | Represents the Enterprise Text29 (Resource) field. | 205521570
ResourceEnterpriseText3 | Represents the Enterprise Text3 (Resource) field. | 205521544
ResourceEnterpriseText30 | Represents the Enterprise Text30 (Resource) field. | 205521571
ResourceEnterpriseText31 | Represents the Enterprise Text31 (Resource) field. | 205521572
ResourceEnterpriseText32 | Represents the Enterprise Text32 (Resource) field. | 205521573
ResourceEnterpriseText33 | Represents the Enterprise Text33 (Resource) field. | 205521574
ResourceEnterpriseText34 | Represents the Enterprise Text34 (Resource) field. | 205521575
ResourceEnterpriseText35 | Represents the Enterprise Text35 (Resource) field. | 205521576
ResourceEnterpriseText36 | Represents the Enterprise Text36 (Resource) field. | 205521577
ResourceEnterpriseText37 | Represents the Enterprise Text37 (Resource) field. | 205521578
ResourceEnterpriseText38 | Represents the Enterprise Text38 (Resource) field. | 205521579
ResourceEnterpriseText39 | Represents the Enterprise Text39 (Resource) field. | 205521580
ResourceEnterpriseText4 | Represents the Enterprise Text4 (Resource) field. | 205521545
ResourceEnterpriseText40 | Represents the Enterprise Text40 (Resource) field. | 205521581
ResourceEnterpriseText5 | Represents the Enterprise Text5 (Resource) field. | 205521546
ResourceEnterpriseText6 | Represents the Enterprise Text6 (Resource) field. | 205521547
ResourceEnterpriseText7 | Represents the Enterprise Text7 (Resource) field. | 205521548
ResourceEnterpriseText8 | Represents the Enterprise Text8 (Resource) field. | 205521549
ResourceEnterpriseText9 | Represents the Enterprise Text9 (Resource) field. | 205521550
ResourceEnterpriseUniqueID | Represents the Enterprise Unique ID (Resource) field. | 205521339
ResourceErrorMessage | Represents the Enterprise Error Message (Resource) field. | 205521634
ResourceFinish | Represents the Finish (Resource) field. | 205521158
ResourceFinish1 | Represents the Finish1 (Resource) field. | 205521003
ResourceFinish10 | Represents the Finish10 (Resource) field. | 205521090
ResourceFinish2 | Represents the Finish2 (Resource) field. | 205521004
ResourceFinish3 | Represents the Finish3 (Resource) field. | 205521005
ResourceFinish4 | Represents the Finish4 (Resource) field. | 205521006
ResourceFinish5 | Represents the Finish5 (Resource) field. | 205521007
ResourceFinish6 | Represents the Finish6 (Resource) field. | 205521086
ResourceFinish7 | Represents the Finish7 (Resource) field. | 205521087
ResourceFinish8 | Represents the Finish8 (Resource) field. | 205521088
ResourceFinish9 | Represents the Finish9 (Resource) field. | 205521089
ResourceFlag1 | Represents the Flag (Resource) field. | 205521023
ResourceFlag10 | Represents the Flag10 (Resource) field. | 205521022
ResourceFlag11 | Represents the Flag11 (Resource) field. | 205521091
ResourceFlag12 | Represents the Flag12 (Resource) field. | 205521092
ResourceFlag13 | Represents the Flag13 (Resource) field. | 205521093
ResourceFlag14 | Represents the Flag14 (Resource) field. | 205521094
ResourceFlag15 | Represents the Flag15 (Resource) field. | 205521095
ResourceFlag16 | Represents the Flag16 (Resource) field. | 205521096
ResourceFlag17 | Represents the Flag17 (Resource) field. | 205521097
ResourceFlag18 | Represents the Flag18 (Resource) field. | 205521098
ResourceFlag19 | Represents the Flag19 (Resource) field. | 205521099
ResourceFlag2 | Represents the Flag2 (Resource) field. | 205521024
ResourceFlag20 | Represents the Flag20 (Resource) field. | 205521100
ResourceFlag3 | Represents the Flag3 (Resource) field. | 205521025
ResourceFlag4 | Represents the Flag4 (Resource) field. | 205521026
ResourceFlag5 | Represents the Flag5 (Resource) field. | 205521027
ResourceFlag6 | Represents the Flag6 (Resource) field. | 205521028
ResourceFlag7 | Represents the Flag7 (Resource) field. | 205521029
ResourceFlag8 | Represents the Flag8 (Resource) field. | 205521030
ResourceFlag9 | Represents the Flag9 (Resource) field. | 205521031
ResourceGroup | Represents the Group (Resource) field. | 205520899
ResourceGroupbySummary | Represents the Group by Summary (Resource) field. | 205521202
ResourceGuid | Represents the Resource GUID (Resource) field. | 205521624
ResourceHyperlink | Represents the Hyperlink (Resource) field. | 205521034
ResourceHyperlinkAddress | Represents the Hyperlink Address (Resource) field. | 205521035
ResourceHyperlinkHref | Represents the Hyperlink HRef (Resource) field. | 205521037
ResourceHyperlinkScreenTip | Represents the Hyperlink ScreenTip (Resource) field. | 205521208
ResourceHyperlinkSubAddress | Represents the Hyperlink Sub Address (Resource) field. | 205521036
ResourceID | Represents the ID (Resource) field. | 205520896
ResourceIndex | Represents the Index (Resource) field. | 205521149
ResourceIndicators | Represents the Indicators (Resource) field. | 205520982
ResourceInitials | Represents the Initials (Resource) field. | 205520898
ResourceIsAssignment | Represents the Is Assignment (Resource) field. | 205521040
ResourceIsTeam | Represents the Is Team (Resource) field. | 205521696
ResourceLevelingDelay | Represents the Leveling Delay (Resource) field. | 205521159
ResourceLinkedFields | Represents the Linked Fields (Resource) field. | 205520930
ResourceMaterialLabel | Represents the Material Label (Resource) field. | 205521195
ResourceMaxUnits | Represents the Max Units (Resource) field. | 205520900
ResourceName | Represents the Name (Resource) field. | 205520897
ResourceNotes | Represents the Notes (Resource) field. | 205520916
ResourceNumber1 | Represents the Number1 (Resource) field. | 205521008
ResourceNumber10 | Represents the Number10 (Resource) field. | 205521105
ResourceNumber11 | Represents the Number11 (Resource) field. | 205521106
ResourceNumber12 | Represents the Number12 (Resource) field. | 205521107
ResourceNumber13 | Represents the Number13 (Resource) field. | 205521108
ResourceNumber14 | Represents the Number14 (Resource) field. | 205521109
ResourceNumber15 | Represents the Number15 (Resource) field. | 205521110
ResourceNumber16 | Represents the Number16 (Resource) field. | 205521111
ResourceNumber17 | Represents the Number17 (Resource) field. | 205521112
ResourceNumber18 | Represents the Number18 (Resource) field. | 205521113
ResourceNumber19 | Represents the Number19 (Resource) field. | 205521114
ResourceNumber2 | Represents the Number2 (Resource) field. | 205521009
ResourceNumber20 | Represents the Number20 (Resource) field. | 205521115
ResourceNumber3 | Represents the Number3 (Resource) field. | 205521010
ResourceNumber4 | Represents the Number4 (Resource) field. | 205521011
ResourceNumber5 | Represents the Number5 (Resource) field. | 205521012
ResourceNumber6 | Represents the Number6 (Resource) field. | 205521101
ResourceNumber7 | Represents the Number7 (Resource) field. | 205521102
ResourceNumber8 | Represents the Number8 (Resource) field. | 205521103
ResourceNumber9 | Represents the Number9 (Resource) field. | 205521104
ResourceObjects | Represents the Objects (Resource) field. | 205520929
ResourceOutlineCode1 | Represents the OutlineCode1 (Resource) field. | 205521174
ResourceOutlineCode10 | Represents the OutlineCode10 (Resource) field. | 205521192
ResourceOutlineCode2 | Represents the OutlineCode2 (Resource) field. | 205521176
ResourceOutlineCode3 | Represents the OutlineCode3(Resource) field. | 205521178
ResourceOutlineCode4 | Represents the OutlineCode4 (Resource) field. | 205521180
ResourceOutlineCode5 | Represents the OutlineCode5 (Resource) field. | 205521182
ResourceOutlineCode6 | Represents the OutlineCode6 (Resource) field. | 205521184
ResourceOutlineCode7 | Represents the OutlineCode7 (Resource) field. | 205521186
ResourceOutlineCode8 | Represents the OutlineCode8 (Resource) field. | 205521188
ResourceOutlineCode9 | Represents the OutlineCode9 (Resource) field. | 205521190
ResourceOverallocated | Represents the Overallocated (Resource) field. | 205520921
ResourceOvertimeCost | Represents the Overtime Cost (Resource) field. | 205520943
ResourceOvertimeRate | Represents the Overtime Rate (Resource) field. | 205520903
ResourceOvertimeWork | Represents the Overtime Work (Resource) field. | 205520912
ResourcePeakUnits | Represents the Peak Units (Resource) field. | 205520922
ResourcePercentWorkComplete | Represents the Percent Work Complete (Resource) field. | 205520925
ResourcePhonetics | Represents the Phonetics (Resource) field. | 205521148
ResourceProject | Represents the Project (Resource) field. | 205521169
ResourceRegularWork | Represents the Regular Work (Resource) field. | 205520934
ResourceRemainingCost | Represents the Remaining Cost (Resource) field. | 205520917
ResourceRemainingOvertimeCost | Represents the Remaining Overtime Cost (Resource) field. | 205520945
ResourceRemainingOvertimeWork | Represents the Remaining Overtime Work (Resource) field. | 205520936
ResourceRemainingWork | Represents the Remaining Work (Resource) field. | 205520918
ResourceResponsePending | Represents the Response Pending (Resource) field. | 205521160
ResourceSheetNotes | Represents the Sheet Notes (Resource) field. | 205520924
ResourceStandardRate | Represents the Standard Rate (Resource) field. | 205520902
ResourceStart | Represents the Start (Resource) field. | 205521161
ResourceStart1 | Represents the Start1 (Resource) field. | 205520998
ResourceStart10 | Represents the Start10 (Resource) field. | 205521120
ResourceStart2 | Represents the Start2 (Resource) field. | 205520999
ResourceStart3 | Represents the Start3 (Resource) field. | 205521000
ResourceStart4 | Represents the Start4 (Resource) field. | 205521001
ResourceStart5 | Represents the Start5 (Resource) field. | 205521002
ResourceStart6 | Represents the Start6 (Resource) field. | 205521116
ResourceStart7 | Represents the Start7 (Resource) field. | 205521117
ResourceStart8 | Represents the Start8 (Resource) field. | 205521118
ResourceStart9 | Represents the Start9 (Resource) field. | 205521119
ResourceSV | Represents the SV (Resource) field. | 205520950
ResourceTaskSummaryName | Represents the Task Summary Name (Resource) field. | 205521055
ResourceTeamStatusPending | Represents the Team Status Pending (Resource) field. | 205521162
ResourceText1 | Represents the Text1 (Resource) field. | 205520904
ResourceText10 | Represents the Text10 (Resource) field. | 205520997
ResourceText11 | Represents the Text11 (Resource) field. | 205521121
ResourceText12 | Represents the Text12 (Resource) field. | 205521122
ResourceText13 | Represents the Text13 (Resource) field. | 205521123
ResourceText14 | Represents the Text14 (Resource) field. | 205521124
ResourceText15 | Represents the Text15 (Resource) field. | 205521125
ResourceText16 | Represents the Text16 (Resource) field. | 205521126
ResourceText17 | Represents the Text17 (Resource) field. | 205521127
ResourceText18 | Represents the Text18 (Resource) field. | 205521128
ResourceText19 | Represents the Text19 (Resource) field. | 205521129
ResourceText2 | Represents the Text2 (Resource) field. | 205520905
ResourceText20 | Represents the Text20 (Resource) field. | 205521130
ResourceText21 | Represents the Text21 (Resource) field. | 205521131
ResourceText22 | Represents the Text22 (Resource) field. | 205521132
ResourceText23 | Represents the Text23 (Resource) field. | 205521133
ResourceText24 | Represents the Text24 (Resource) field. | 205521134
ResourceText25 | Represents the Text25 (Resource) field. | 205521135
ResourceText26 | Represents the Text26 (Resource) field. | 205521136
ResourceText27 | Represents the Text27 (Resource) field. | 205521137
ResourceText28 | Represents the Text28 (Resource) field. | 205521138
ResourceText29 | Represents the Text29 (Resource) field. | 205521139
ResourceText3 | Represents the Text3 (Resource) field. | 205520926
ResourceText30 | Represents the Text30 (Resource) field. | 205521140
ResourceText4 | Represents the Text4 (Resource) field. | 205520927
ResourceText5 | Represents the Text5 (Resource) field. | 205520928
ResourceText6 | Represents the Text6 (Resource) field. | 205520993
ResourceText7 | Represents the Text7 (Resource) field. | 205520994
ResourceText8 | Represents the Text8 (Resource) field. | 205520995
ResourceText9 | Represents the Text9 (Resource) field. | 205520996
ResourceType | Represents the Type (Resource) field. | 205521196
ResourceUniqueID | Represents the UniqueID (Resource) field. | 205520923
ResourceUpdateNeeded | Represents the Update Needed (Resource) field. | 205521163
ResourceVAC | Represents the VAC (Resource) field. | 205521197
ResourceWBS | Represents the WBS (Resource) field. | 205521236
ResourceWindowsUserAccount | Represents the Windows User Account (Resource) field. | 205521207
ResourceWork | Represents the Work (Resource) field. | 205520909
ResourceWorkContour | Represents the Work Contour (Resource) field. | 205521060
ResourceWorkgroup | Represents the Workgroup (Resource) field. | 205521168
ResourceWorkVariance | Represents the Work Variance (Resource) field. | 205520919
TaskActive | Represents the Active Task (Task) field. | 188744959
TaskActualCost | Represents the ActualCost (Task) field. | 188743687
TaskActualDuration | Represents the Actual Duration (Task) field. | 188743708
TaskActualFinish | Represents the Actual Finish (Task) field. | 188743722
TaskActualOvertimeCost | Represents the Actual Overtime Cost (Task) field. | 188743849
TaskActualOvertimeWork | Represents the Actual Overtime Work (Task) field. | 188743844
TaskActualOvertimeWorkProtected | Represents the Actual Overtime Work Protected (Task) field. | 188744820
TaskActualStart | Represents the Actual Start (Task) field. | 188743721
TaskActualWork | Represents the Actual Work (Task) field. | 188743682
TaskActualWorkProtected | Represents the Actual Work Protected (Task) field. | 188744819
TaskACWP | Represents the ACWP (Task) field. | 188743800
TaskAssignmentDelay | Represents the Assignment Delay (Task) field. | 188744046
TaskAssignmentPeakUnits | Represents the Assignment Peak Units (Task) field. | 188745015
TaskAssignmentUnits | Represents the Assignment Units (Task) field. | 188744047
TaskBaseline10BudgetCost | Represents the Baseline10 Budget Cost (Task) field. | 188744927
TaskBaseline10BudgetWork | Represents the Baseline10 Budget Work (Task) field. | 188744926
TaskBaseline10Cost | Represents the Baseline10 Cost (Task) field | 188744270
TaskBaseline10DeliverableFinish | Represents the Baseline10 Deliverable Finish (Task) field. | 188744925
TaskBaseline10DeliverableStart | Represents the Baseline10 Deliverable Start (Task) field. | 188744924
TaskBaseline10Duration | Represents the Baseline10 Duration (Task) field. | 188744273
TaskBaseline10DurationEstimated | Represents the Baseline10 Duration Estimated (Task) field. | 188744528
TaskBaseline10DurationText | Represents the Baseline10 Duration Text (Task) field. | 188745011
TaskBaseline10Finish | Represents the Baseline10 Finish (Task) field. | 188744269
TaskBaseline10FinishText | Represents the Baseline10 Finish Text (Task) field. | 188745010
TaskBaseline10FixedCostAccrual | Represents the Baseline10 Fixed Cost Accrual (Task) field. | 188744923
TaskBaseline10Start | Represents the Baseline10 Start (Task) field. | 188744268
TaskBaseline10StartText | Represents the Baseline10 Start Text (Task) field. | 188745009
TaskBaseline10Work | Represents the Baseline10 Work (Task) field. | 188744271
TaskBaseline1BudgetCost | Represents the Baseline1 Budget Cost (Task) field. | 188744864
TaskBaseline1BudgetWork | Represents the Baseline1 Budget Work (Task) field. | 188744863
TaskBaseline1Cost | Represents the Baseline1 Cost (Task) field. | 188744164
TaskBaseline1DeliverableFinish | Represents the Baseline1 Deliverable Finish (Task) field. | 188744862
TaskBaseline1DeliverableStart | Represents the Baseline1 Deliverable Start (Task) field. | 188744861
TaskBaseline1Duration | Represents the Baseline1 Duration (Task) field. | 188744167
TaskBaseline1DurationEstimated | Represents the Baseline1 Duration Estimated (Task) field. | 188744519
TaskBaseline1DurationText | Represents the Baseline1 Duration Text (Task) field. | 188744984
TaskBaseline1Finish | Represents the Baseline1 Finish (Task) field. | 188744163
TaskBaseline1FinishText | Represents the Baseline1 Finish Text (Task) field. | 188744983
TaskBaseline1FixedCostAccrual | Represents the Baseline1 Fixed Cost Accrual (Task) field. | 188744860
TaskBaseline1Start | Represents the Baseline1 Start (Task) field. | 188744162
TaskBaseline1StartText | Represents the Baseline1 Start Text (Task) field. | 188744982
TaskBaseline1Work | Represents the Baseline1 Budget Work (Task) field. | 188744165
TaskBaseline2BudgetCost | Represents the Baseline2 Budget Cost (Task) field. | 188744871
TaskBaseline2BudgetWork | Represents the Baseline2 Budget Work (Task) field. | 188744870
TaskBaseline2Cost | Represents the Baseline2 Cost (Task) field. | 188744175
TaskBaseline2DeliverableFinish | Represents the Baseline2 Deliverable Finish (Task) field. | 188744869
TaskBaseline2DeliverableStart | Represents the Baseline2 Deliverable Start (Task) field. | 188744868
TaskBaseline2Duration | Represents the Baseline2 Duration (Task) field. | 188744178
TaskBaseline2DurationEstimated | Represents the Baseline2 Duration Estimated (Task) field. | 188744520
TaskBaseline2DurationText | Represents the Baseline2 Duration Text (Task) field. | 188744987
TaskBaseline2Finish | Represents the Baseline2 Finish (Task) field. | 188744174
TaskBaseline2FinishText | Represents the Baseline2 Finish Text (Task) field. | 188744986
TaskBaseline2FixedCostAccrual | Represents the Baseline2 Fixed Cost Accrual (Task) field. | 188744867
TaskBaseline2Start | Represents the Baseline2 Start (Task) field. | 188744173
TaskBaseline2StartText | Represents the Baseline2 Start Text (Task) field. | 188744985
TaskBaseline2Work | Represents the Baseline2 Work (Task) field. | 188744176
TaskBaseline3BudgetCost | Represents the Baseline3 Budget Cost (Task) field. | 188744878
TaskBaseline3BudgetWork | Represents the Baseline3 Budget Work (Task) field. | 188744877
TaskBaseline3Cost | Represents the Baseline3 Cost (Task) field. | 188744186
TaskBaseline3DeliverableFinish | Represents the Baseline3 Deliverable Finish (Task) field. | 188744876
TaskBaseline3DeliverableStart | Represents the Baseline3 Deliverable Start (Task) field. | 188744875
TaskBaseline3Duration | Represents the Baseline3 Duration (Task) field. | 188744189
TaskBaseline3DurationEstimated | Represents the Baseline3 Duration Estimated (Task) field. | 188744521
TaskBaseline3DurationText | Represents the Baseline3 Duration Text (Task) field. | 188744990
TaskBaseline3Finish | Represents the Baseline3 Finish (Task) field. | 188744185
TaskBaseline3FinishText | Represents the Baseline3 Finish Text (Task) field. | 188744989
TaskBaseline3FixedCostAccrual | Represents the Baseline3 Fixed Cost Accrual (Task) field. | 188744874
TaskBaseline3Start | Represents the Baseline3 Start (Task) field. | 188744184
TaskBaseline3StartText | Represents the Baseline3 Start Text (Task) field. | 188744988
TaskBaseline3Work | Represents the Baseline3 Work (Task) field. | 188744187
TaskBaseline4BudgetCost | Represents the Baseline4 Budget Cost (Task) field. | 188744885
TaskBaseline4BudgetWork | Represents the Baseline4 Budget Work (Task) field. | 188744884
TaskBaseline4Cost | Represents the Baseline4 Cost (Task) field. | 188744197
TaskBaseline4DeliverableFinish | Represents the Baseline4 Deliverable Finish (Task) field. | 188744883
TaskBaseline4DeliverableStart | Represents the Baseline4 Deliverable Start (Task) field. | 188744882
TaskBaseline4Duration | Represents the Baseline4 Duration (Task) field. | 188744200
TaskBaseline4DurationEstimated | Represents the Baseline4 Duration Estimated (Task) field. | 188744522
TaskBaseline4DurationText | Represents the Baseline4 Duration Text (Task) field. | 188744993
TaskBaseline4Finish | Represents the Baseline4 Finish (Task) field. | 188744196
TaskBaseline4FinishText | Represents the Baseline4 Finish Text (Task) field. | 188744992
TaskBaseline4FixedCostAccrual | Represents the Baseline4 Fixed Cost Accrual (Task) field | 188744881
TaskBaseline4Start | Represents the Baseline4 Start (Task) field. | 188744195
TaskBaseline4StartText | Represents the Baseline4 Start Text (Task) field. | 188744991
TaskBaseline4Work | Represents the Baseline4 Work (Task) field. | 188744198
TaskBaseline5BudgetCost | Represents the Baseline5 Budget Cost (Task) field. | 188744892
TaskBaseline5BudgetWork | Represents the Baseline5 Budget Work (Task) field. | 188744891
TaskBaseline5Cost | Represents the Baseline5 Cost (Task) field. | 188744208
TaskBaseline5DeliverableFinish | Represents the Baseline5 Deliverable Finish (Task) field. | 188744890
TaskBaseline5DeliverableStart | Represents the Baseline5 Deliverable Start (Task) field. | 188744889
TaskBaseline5Duration | Represents the Baseline5 Duration (Task) field. | 188744211
TaskBaseline5DurationEstimated | Represents the Baseline5 Duration Estimated (Task) field. | 188744523
TaskBaseline5DurationText | Represents the Baseline5 Duration Text (Task) field. | 188744996
TaskBaseline5Finish | Represents the Baseline5 Finish (Task) field. | 188744207
TaskBaseline5FinishText | Represents the Baseline5 Finish Text (Task) field. | 188744995
TaskBaseline5FixedCostAccrual | Represents the Baseline5 Fixed Cost Accrual (Task) field. | 188744888
TaskBaseline5Start | Represents the Baseline5 Start (Task) field. | 188744206
TaskBaseline5StartText | Represents the Baseline5 Start Text (Task) field. | 188744994
TaskBaseline5Work | Represents the Baseline5 Work (Task) field. | 188744209
TaskBaseline6BudgetCost | Represents the Baseline6 Budget Cost (Task) field. | 188744899
TaskBaseline6BudgetWork | Represents the Baseline6 Budget Work (Task) field. | 188744898
TaskBaseline6Cost | Represents the Baseline6 Cost (Task) field. | 188744226
TaskBaseline6DeliverableFinish | Represents the Baseline6 Deliverable Finish (Task) field. | 188744897
TaskBaseline6DeliverableStart | Represents the Baseline6 Deliverable Start (Task) field. | 188744896
TaskBaseline6Duration | Represents the Baseline6 Duration (Task) field. | 188744229
TaskBaseline6DurationEstimated | Represents the Baseline6 Duration Estimated (Task) field. | 188744524
TaskBaseline6DurationText | Represents the Baseline6 Duration Text (Task) field. | 188744999
TaskBaseline6Finish | Represents the Baseline6 Finish (Task) field. | 188744225
TaskBaseline6FinishText | Represents the Baseline6 Finish Text (Task) field. | 188744998
TaskBaseline6FixedCostAccrual | Represents the Baseline6 Fixed Cost Accrual (Task) field. | 188744895
TaskBaseline6Start | Represents the Baseline6 Start (Task) field. | 188744224
TaskBaseline6StartText | Represents the Baseline6 Start Text (Task) field. | 188744997
TaskBaseline6Work | Represents the Baseline6 Work (Task) field. | 188744227
TaskBaseline7BudgetCost | Represents the Baseline7 Budget Cost (Task) field. | 188744906
TaskBaseline7BudgetWork | Represents the Baseline7 Budget Work (Task) field. | 188744905
TaskBaseline7Cost | Represents the Baseline7 Cost (Task) field. | 188744237
TaskBaseline7DeliverableFinish | Represents the Baseline7 Deliverable Finish (Task) field. | 188744904
TaskBaseline7DeliverableStart | Represents the Baseline7 Deliverable Start (Task) field. | 188744903
TaskBaseline7Duration | Represents the Baseline7 Duration (Task) field. | 188744240
TaskBaseline7DurationEstimated | Represents the Baseline7 Duration Estimated (Task) field. | 188744525
TaskBaseline7DurationText | Represents the Baseline7 Duration Text (Task) field. | 188745002
TaskBaseline7Finish | Represents the Baseline7 Finish (Task) field. | 188744236
TaskBaseline7FinishText | Represents the Baseline7 Finish Text (Task) field. | 188745001
TaskBaseline7FixedCostAccrual | Represents the Baseline7 Fixed Cost Accrual (Task) field. | 188744902
TaskBaseline7Start | Represents the Baseline7 Start (Task) field. | 188744235
TaskBaseline7StartText | Represents the Baseline7 Start Text (Task) field. | 188745000
TaskBaseline7Work | Represents the Baseline7 Work (Task) field. | 188744238
TaskBaseline8BudgetCost | Represents the Baseline8 Budget Cost (Task) field. | 188744913
TaskBaseline8BudgetWork | Represents the Baseline8 Budget Work (Task) field. | 188744912
TaskBaseline8Cost | Represents the Baseline8 Cost (Task) field. | 188744248
TaskBaseline8DeliverableFinish | Represents the Baseline8 Deliverable Finish (Task) field. | 188744911
TaskBaseline8DeliverableStart | Represents the Baseline8 Deliverable Start (Task) field. | 188744910
TaskBaseline8Duration | Represents the Baseline8 Duration (Task) field. | 188744251
TaskBaseline8DurationEstimated | Represents the Baseline8 Duration Estimated (Task) field. | 188744526
TaskBaseline8DurationText | Represents the Baseline8 Duration Text (Task) field. | 188745005
TaskBaseline8Finish | Represents the Baseline8 Finish (Task) field. | 188744247
TaskBaseline8FinishText | Represents the Baseline8 Finish Text (Task) field. | 188745004
TaskBaseline8FixedCostAccrual | Represents the Baseline8 Fixed Cost Accrual (Task) field. | 188744909
TaskBaseline8Start | Represents the Baseline8 Start (Task) field. | 188744246
TaskBaseline8StartText | Represents the Baseline8 Start Text (Task) field. | 188745003
TaskBaseline8Work | Represents the Baseline8 Work (Task) field. | 188744249
TaskBaseline9BudgetCost | Represents the Baseline9 Budget Cost (Task) field. | 188744920
TaskBaseline9BudgetWork | Represents the Baseline9 Budget Work (Task) field. | 188744919
TaskBaseline9Cost | Represents the Baseline9 Cost (Task) field. | 188744259
TaskBaseline9DeliverableFinish | Represents the Baseline9 Deliverable Finish (Task) field. | 188744918
TaskBaseline9DeliverableStart | Represents the Baseline9 Deliverable Start (Task) field. | 188744917
TaskBaseline9Duration | Represents the Baseline9 Duration (Task) field. | 188744262
TaskBaseline9DurationEstimated | Represents the Baseline9 Duration Estimated (Task) field. | 188744527
TaskBaseline9DurationText | Represents the Baseline9 Duration Text (Task) field. | 188745008
TaskBaseline9Finish | Represents the Baseline9 Finish (Task) field. | 188744258
TaskBaseline9FinishText | Represents the Baseline9 Finish Text (Task) field. | 188745007
TaskBaseline9FixedCostAccrual | Represents the Baseline9 Fixed Cost Accrual (Task) field. | 188744916
TaskBaseline9Start | Represents the Baseline9 Start (Task) field. | 188744257
TaskBaseline9StartText | Represents the Baseline9 Start Text (Task) field. | 188745006
TaskBaseline9Work | Represents the Baseline9 Work (Task) field. | 188744260
TaskBaselineBudgetCost | Represents the Baseline Budget Cost (Task) field. | 188744857
TaskBaselineBudgetWork | Represents the Baseline Budget Work (Task) field. | 188744856
TaskBaselineCost | Represents the Baseline Cost (Task) field. | 188743686
TaskBaselineDeliverableFinish | Represents the Baseline Deliverable Finish (Task) field. | 188744855
TaskBaselineDeliverableStart | Represents the Baseline Deliverable Start (Task) field. | 188744854
TaskBaselineDuration | Represents the Baseline Duration (Task) field. | 188743707
TaskBaselineDurationEstimated | Represents the Baseline Duration Estimated (Task) field. | 188744093
TaskBaselineDurationText | Represents the Baseline Duration Text (Task) field. | 188744981
TaskBaselineFinish | Represents the Baseline Finish (Task) field. | 188743724
TaskBaselineFinishText | Represents the Baseline Finish Text (Task) field. | 188744980
TaskBaselineFixedCostAccrual | Represents the Baseline Fixed Cost Accrual (Task) field. | 188744853
TaskBaselineStart | Represents the Baseline Start (Task) field. | 188743723
TaskBaselineStartText | Represents the Baseline Start Text (Task) field. | 188744979
TaskBaselineWork | Represents the Baseline Work (Task) field. | 188743681
TaskBCWP | Represents the BCWP (Task) field. | 188743691
TaskBCWS | Represents the BCWS (Task) field. | 188743692
TaskBudgetCost | Represents the Budget Cost (Task) field. | 188744852
TaskBudgetWork | Represents the Budget Work (Task) field. | 188744851
TaskCalendar | Represents the Calendar (Task) field. | 188744082
TaskCalendarGuid | Represents the Calendar GUID (Task) field. | 188744824
TaskConfirmed | Represents the Confirmed (Task) field. | 188743790
TaskConstraintDate | Represents the Constraint Date (Task) field. | 188743698
TaskConstraintType | Represents the Constraint Type (Task) field. | 188743697
TaskContact | Represents the Contact (Task) field. | 188743792
TaskCost | Represents the Cost (Task) field. | 188743685
TaskCost1 | Represents the Cost1 (Task) field. | 188743786
TaskCost10 | Represents the Cost10 (Task) field. | 188743944
TaskCost2 | Represents the Cost2 (Task) field. | 188743787
TaskCost3 | Represents the Cost3 (Task) field. | 188743788
TaskCost4 | Represents the Cost4 (Task) field. | 188743938
TaskCost5 | Represents the Cost5 (Task) field. | 188743939
TaskCost6 | Represents the Cost6 (Task) field. | 188743940
TaskCost7 | Represents the Cost7 (Task) field. | 188743941
TaskCost8 | Represents the Cost8 (Task) field. | 188743942
TaskCost9 | Represents the Cost9 (Task) field. | 188743943
TaskCostRateTable | Represents the Cost Rate Table (Task) field. | 188744048
TaskCostVariance | Represents the Cost Variance (Task) field. | 188743689
TaskCPI | Represents the CPI (Task) field. | 188744217
TaskCreated | Represents the Created (Task) field. | 188743773
TaskCritical | Represents the Critical (Task) field. | 188743699
TaskCV | Represents the CV (Task) field. | 188743763
TaskCVPercent | Represents the CV Percent (Task) field. | 188744219
TaskDate1 | Represents the Date1 (Task) field. | 188743945
TaskDate10 | Represents the Date10 (Task) field. | 188743954
TaskDate2 | Represents the Date2 (Task) field. | 188743946
TaskDate3 | Represents the Date3 (Task) field. | 188743947
TaskDate4 | Represents the Date4 (Task) field. | 188743948
TaskDate5 | Represents the Date5 (Task) field. | 188743949
TaskDate6 | Represents the Date6 (Task) field. | 188743950
TaskDate7 | Represents the Date7 (Task) field. | 188743951
TaskDate8 | Represents the Date8 (Task) field. | 188743952
TaskDate9 | Represents the Date9 (Task) field. | 188743953
TaskDeadline | Represents the Deadline (Task) field. | 188744117
TaskDelay | Represents the Delay (Task) field. | 188743700
TaskDeliverableFinish | Represents the Deliverable Finish (Task) field. | 188744833
TaskDeliverableGuid | Represents the Deliverable GUID (Task) field. | 188744826
TaskDeliverableName | Represents the Deliverable Start (Task) field. | 188744956
TaskDeliverableStart | Represents the Deliverable Start (Task) field. | 188744832
TaskDeliverableType | Represents the Deliverable Type (Task) field. | 188744827
TaskDemandedRequested | Represents the Demanded Requested (Task) field. | 188744800
TaskDuration | Represents the Duration (Task) field. | 188743709
TaskDuration1 | Represents the Duration1 (Task) field. | 188743783
TaskDuration10 | Represents the Duration10 (Task) field. | 188743961
TaskDuration10Estimated | Represents the Duration10 Estimated (Task) field. | 188744092
TaskDuration1Estimated | Represents the Duration11 Estimated (Task) field. | 188744083
TaskDuration2 | Represents the Duration2 (Task) field. | 188743784
TaskDuration2Estimated | Represents the Duration2 Estimated (Task) field. | 188744084
TaskDuration3 | Represents the Duration3 (Task) field. | 188743785
TaskDuration3Estimated | Represents the Duration3 Estimated (Task) field. | 188744085
TaskDuration4 | Represents the Duration4 (Task) field. | 188743955
TaskDuration4Estimated | Represents the Duration4 Estimated (Task) field. | 188744086
TaskDuration5 | Represents the Duration5 (Task) field. | 188743956
TaskDuration5Estimated | Represents the Duration5 (Estimated Task) field. | 188744087
TaskDuration6 | Represents the Duration6 (Task) field. | 188743957
TaskDuration6Estimated | Represents the Duration6 Estimated (Task) field. | 188744088
TaskDuration7 | Represents the Duration7 (Task) field. | 188743958
TaskDuration7Estimated | Represents the Duration7 Estimated (Task) field. | 188744089
TaskDuration8 | Represents the Duration8 (Task) field. | 188743959
TaskDuration8Estimated | Represents the Duration8 Estimated (Task) field. | 188744090
TaskDuration9 | Represents the Duration9 (Task) field. | 188743960
TaskDuration9Estimated | Represents the Duration9 Estimated (Task) field. | 188744091
TaskDurationText | Represents the Task Duration Text (Task) field. | 188744967
TaskDurationVariance | Represents the Duration Variance (Task) field. | 188743710
TaskEAC | Represents the EAC (Task) field. | 188744221
TaskEarlyFinish | Represents the Early Finish (Task) field. | 188743718
TaskEarlyStart | Represents the Early Start (Task) field. | 188743717
TaskEarnedValueMethod | Represents the Earned Value Method (Task) field. | 188744802
TaskEffortDriven | Represents the Effort Driven (Task) field. | 188743812
TaskEnterpriseCost1 | Represents the Enterprise Cost1 (Task) field. | 188744279
TaskEnterpriseCost10 | Represents the Enterprise Cost10 (Task) field. | 188744288
TaskEnterpriseCost2 | Represents the Enterprise Cost2 (Task) field. | 188744280
TaskEnterpriseCost3 | Represents the Enterprise Cost3 (Task) field. | 188744281
TaskEnterpriseCost4 | Represents the Enterprise Cost4 (Task) field. | 188744282
TaskEnterpriseCost5 | Represents the Enterprise Cost5 (Task) field. | 188744283
TaskEnterpriseCost6 | Represents the Enterprise Cost6 (Task) field. | 188744284
TaskEnterpriseCost7 | Represents the Enterprise Cost7 (Task) field. | 188744285
TaskEnterpriseCost8 | Represents the Enterprise Cost8 (Task) field. | 188744286
TaskEnterpriseCost9 | Represents the Enterprise Cost9 (Task) field. | 188744287
TaskEnterpriseDate1 | Represents the Enterprise Date1 (Task) field. | 188744289
TaskEnterpriseDate10 | Represents the Enterprise Date10 (Task) field. | 188744298
TaskEnterpriseDate11 | Represents the Enterprise Date11 (Task) field. | 188744299
TaskEnterpriseDate12 | Represents the Enterprise Date12 (Task) field. | 188744300
TaskEnterpriseDate13 | Represents the Enterprise Date13 (Task) field. | 188744301
TaskEnterpriseDate14 | Represents the Enterprise Date14 (Task) field. | 188744302
TaskEnterpriseDate15 | Represents the Enterprise Date15 (Task) field. | 188744303
TaskEnterpriseDate16 | Represents the Enterprise Date16 (Task) field. | 188744304
TaskEnterpriseDate17 | Represents the Enterprise Date17 (Task) field. | 188744305
TaskEnterpriseDate18 | Represents the Enterprise Date18 (Task) field. | 188744306
TaskEnterpriseDate19 | Represents the Enterprise Date19 (Task) field. | 188744307
TaskEnterpriseDate2 | Represents the Enterprise Date2(Task) field. | 188744290
TaskEnterpriseDate20 | Represents the Enterprise Date20 (Task) field. | 188744308
TaskEnterpriseDate21 | Represents the Enterprise Date21 (Task) field. | 188744309
TaskEnterpriseDate22 | Represents the Enterprise Date22 (Task) field. | 188744310
TaskEnterpriseDate23 | Represents the Enterprise Date23 (Task) field. | 188744311
TaskEnterpriseDate24 | Represents the Enterprise Date24 (Task) field. | 188744312
TaskEnterpriseDate25 | Represents the Enterprise Date25 (Task) field. | 188744313
TaskEnterpriseDate26 | Represents the Enterprise Date26 (Task) field. | 188744314
TaskEnterpriseDate27 | Represents the Enterprise Date27 (Task) field. | 188744315
TaskEnterpriseDate28 | Represents the Enterprise Date28 (Task) field. | 188744316
TaskEnterpriseDate29 | Represents the Enterprise Date29 (Task) field. | 188744317
TaskEnterpriseDate3 | Represents the Enterprise Date3 (Task) field. | 188744291
TaskEnterpriseDate30 | Represents the Enterprise Date30 (Task) field. | 188744318
TaskEnterpriseDate4 | Represents the Enterprise Date4 (Task) field. | 188744292
TaskEnterpriseDate5 | Represents the Enterprise Date5 (Task) field. | 188744293
TaskEnterpriseDate6 | Represents the Enterprise Date6 (Task) field. | 188744294
TaskEnterpriseDate7 | Represents the Enterprise Date7 (Task) field. | 188744295
TaskEnterpriseDate8 | Represents the Enterprise Date8 (Task) field. | 188744296
TaskEnterpriseDate9 | Represents the Enterprise Date9 (Task) field. | 188744297
TaskEnterpriseDuration1 | Represents the Enterprise Duration1 (Task) field. | 188744319
TaskEnterpriseDuration10 | Represents the Enterprise Duration10 (Task) field. | 188744328
TaskEnterpriseDuration2 | Represents the Enterprise Duration2 (Task) field. | 188744320
TaskEnterpriseDuration3 | Represents the Enterprise Duration3 (Task) field. | 188744321
TaskEnterpriseDuration4 | Represents the Enterprise Duration4 (Task) field. | 188744322
TaskEnterpriseDuration5 | Represents the Enterprise Duration5 (Task) field. | 188744323
TaskEnterpriseDuration6 | Represents the Enterprise Duration6 (Task) field. | 188744324
TaskEnterpriseDuration7 | Represents the Enterprise Duration7 (Task) field. | 188744325
TaskEnterpriseDuration8 | Represents the Enterprise Duration8 (Task) field. | 188744326
TaskEnterpriseDuration9 | Represents the Enterprise Duration9 (Task) field. | 188744327
TaskEnterpriseFlag1 | Represents the Enterprise Flag1 (Task) field. | 188744339
TaskEnterpriseFlag10 | Represents the Enterprise Flag10 (Task) field. | 188744348
TaskEnterpriseFlag11 | Represents the Enterprise Flag11 (Task) field. | 188744349
TaskEnterpriseFlag12 | Represents the Enterprise Flag12 (Task) field. | 188744350
TaskEnterpriseFlag13 | Represents the Enterprise Flag13 (Task) field. | 188744351
TaskEnterpriseFlag14 | Represents the Enterprise Flag14 (Task) field. | 188744352
TaskEnterpriseFlag15 | Represents the Enterprise Flag15 (Task) field. | 188744353
TaskEnterpriseFlag16 | Represents the Enterprise Flag16 (Task) field. | 188744354
TaskEnterpriseFlag17 | Represents the Enterprise Flag17 (Task) field. | 188744355
TaskEnterpriseFlag18 | Represents the Enterprise Flag18 (Task) field. | 188744356
TaskEnterpriseFlag19 | Represents the Enterprise Flag19 (Task) field. | 188744357
TaskEnterpriseFlag2 | Represents the Enterprise Flag2 (Task) field. | 188744340
TaskEnterpriseFlag20 | Represents the Enterprise Flag20 (Task) field. | 188744358
TaskEnterpriseFlag3 | Represents the Enterprise Flag3 (Task) field. | 188744341
TaskEnterpriseFlag4 | Represents the Enterprise Flag4 (Task) field. | 188744342
TaskEnterpriseFlag5 | Represents the Enterprise Flag5 (Task) field. | 188744343
TaskEnterpriseFlag6 | Represents the Enterprise Flag6 (Task) field. | 188744344
TaskEnterpriseFlag7 | Represents the Enterprise Flag7 (Task) field. | 188744345
TaskEnterpriseFlag8 | Represents the Enterprise Flag8 (Task) field. | 188744346
TaskEnterpriseFlag9 | Represents the Enterprise Flag9 (Task) field. | 188744347
TaskEnterpriseNumber1 | Represents the Enterprise Number1 (Task) field. | 188744379
TaskEnterpriseNumber10 | Represents the Enterprise Number10 (Task) field. | 188744388
TaskEnterpriseNumber11 | Represents the Enterprise Number11 (Task) field. | 188744389
TaskEnterpriseNumber12 | Represents the Enterprise Number12 (Task) field. | 188744390
TaskEnterpriseNumber13 | Represents the Enterprise Number13 (Task) field. | 188744391
TaskEnterpriseNumber14 | Represents the Enterprise Number14 (Task) field. | 188744392
TaskEnterpriseNumber15 | Represents the Enterprise Number15 (Task) field. | 188744393
TaskEnterpriseNumber16 | Represents the Enterprise Number16 (Task) field. | 188744394
TaskEnterpriseNumber17 | Represents the Enterprise Number17 (Task) field. | 188744395
TaskEnterpriseNumber18 | Represents the Enterprise Number18 (Task) field. | 188744396
TaskEnterpriseNumber19 | Represents the Enterprise Number19 (Task) field. | 188744397
TaskEnterpriseNumber2 | Represents the Enterprise Number2 (Task) field. | 188744380
TaskEnterpriseNumber20 | Represents the Enterprise Number20 (Task) field. | 188744398
TaskEnterpriseNumber21 | Represents the Enterprise Number21 (Task) field. | 188744399
TaskEnterpriseNumber22 | Represents the Enterprise Number22 (Task) field. | 188744400
TaskEnterpriseNumber23 | Represents the Enterprise Number23 (Task) field. | 188744401
TaskEnterpriseNumber24 | Represents the Enterprise Number24 (Task) field. | 188744402
TaskEnterpriseNumber25 | Represents the Enterprise Number25 (Task) field. | 188744403
TaskEnterpriseNumber26 | Represents the Enterprise Number26 (Task) field. | 188744404
TaskEnterpriseNumber27 | Represents the Enterprise Number27 (Task) field. | 188744405
TaskEnterpriseNumber28 | Represents the Enterprise Number28 (Task) field. | 188744406
TaskEnterpriseNumber29 | Represents the Enterprise Number29 (Task) field. | 188744407
TaskEnterpriseNumber3 | Represents the Enterprise Number3 (Task) field. | 188744381
TaskEnterpriseNumber30 | Represents the Enterprise Number30 (Task) field. | 188744408
TaskEnterpriseNumber31 | Represents the Enterprise Number31 (Task) field. | 188744409
TaskEnterpriseNumber32 | Represents the Enterprise Number32 (Task) field. | 188744410
TaskEnterpriseNumber33 | Represents the Enterprise Number33 (Task) field. | 188744411
TaskEnterpriseNumber34 | Represents the Enterprise Number34 (Task) field. | 188744412
TaskEnterpriseNumber35 | Represents the Enterprise Number35 (Task) field. | 188744413
TaskEnterpriseNumber36 | Represents the Enterprise Number36 (Task) field. | 188744414
TaskEnterpriseNumber37 | Represents the Enterprise Number37 (Task) field. | 188744415
TaskEnterpriseNumber38 | Represents the Enterprise Number38 (Task) field. | 188744416
TaskEnterpriseNumber39 | Represents the Enterprise Number39 (Task) field. | 188744417
TaskEnterpriseNumber4 | Represents the Enterprise Number4 (Task) field. | 188744382
TaskEnterpriseNumber40 | Represents the Enterprise Number40 (Task) field. | 188744418
TaskEnterpriseNumber5 | Represents the Enterprise Number5 (Task) field. | 188744383
TaskEnterpriseNumber6 | Represents the Enterprise Number6 (Task) field. | 188744384
TaskEnterpriseNumber7 | Represents the Enterprise Number7 (Task) field. | 188744385
TaskEnterpriseNumber8 | Represents the Enterprise Number8 (Task) field. | 188744386
TaskEnterpriseNumber9 | Represents the Enterprise Number9 (Task) field. | 188744387
TaskEnterpriseOutlineCode1 | Represents the Enterprise OutlineCode1 (Task) field. | 188744419
TaskEnterpriseOutlineCode10 | Represents the Enterprise OutlineCode10 (Task) field. | 188744437
TaskEnterpriseOutlineCode11 | Represents the Enterprise OutlineCode11 (Task) field. | 188744439
TaskEnterpriseOutlineCode12 | Represents the Enterprise OutlineCode12 (Task) field. | 188744441
TaskEnterpriseOutlineCode13 | Represents the Enterprise OutlineCode13 (Task) field. | 188744443
TaskEnterpriseOutlineCode14 | Represents the Enterprise OutlineCode14 (Task) field. | 188744445
TaskEnterpriseOutlineCode15 | Represents the Enterprise OutlineCode15 (Task) field. | 188744447
TaskEnterpriseOutlineCode16 | Represents the Enterprise OutlineCode16 (Task) field. | 188744449
TaskEnterpriseOutlineCode17 | Represents the Enterprise OutlineCode17 (Task) field. | 188744451
TaskEnterpriseOutlineCode18 | Represents the Enterprise OutlineCode18 (Task) field. | 188744453
TaskEnterpriseOutlineCode19 | Represents the Enterprise OutlineCode19 (Task) field. | 188744455
TaskEnterpriseOutlineCode2 | Represents the Enterprise OutlineCode2 (Task) field. | 188744421
TaskEnterpriseOutlineCode20 | Represents the Enterprise OutlineCode20 (Task) field. | 188744457
TaskEnterpriseOutlineCode21 | Represents the Enterprise OutlineCode21 (Task) field. | 188744459
TaskEnterpriseOutlineCode22 | Represents the Enterprise OutlineCode22 (Task) field. | 188744461
TaskEnterpriseOutlineCode23 | Represents the Enterprise OutlineCode23 (Task) field. | 188744463
TaskEnterpriseOutlineCode24 | Represents the Enterprise OutlineCode24 (Task) field. | 188744465
TaskEnterpriseOutlineCode25 | Represents the Enterprise OutlineCode25 (Task) field. | 188744467
TaskEnterpriseOutlineCode26 | Represents the Enterprise OutlineCode26 (Task) field. | 188744469
TaskEnterpriseOutlineCode27 | Represents the Enterprise OutlineCode27 (Task) field. | 188744471
TaskEnterpriseOutlineCode28 | Represents the Enterprise OutlineCode28 (Task) field. | 188744473
TaskEnterpriseOutlineCode29 | Represents the Enterprise OutlineCode29 (Task) field. | 188744475
TaskEnterpriseOutlineCode3 | Represents the Enterprise OutlineCode3 (Task) field. | 188744423
TaskEnterpriseOutlineCode30 | Represents the Enterprise OutlineCode30 (Task) field. | 188744477
TaskEnterpriseOutlineCode4 | Represents the Enterprise OutlineCode4 (Task) field. | 188744425
TaskEnterpriseOutlineCode5 | Represents the Enterprise OutlineCode5 (Task) field. | 188744427
TaskEnterpriseOutlineCode6 | Represents the Enterprise OutlineCode6 (Task) field. | 188744429
TaskEnterpriseOutlineCode7 | Represents the Enterprise OutlineCode7 (Task) field. | 188744431
TaskEnterpriseOutlineCode8 | Represents the Enterprise OutlineCode8 (Task) field. | 188744433
TaskEnterpriseOutlineCode9 | Represents the Enterprise OutlineCode9 (Task) field. | 188744435
TaskEnterpriseProjectCost1 | Represents the Enterprise Project Cost1 (Task) field. | 188744529
TaskEnterpriseProjectCost10 | Represents the Enterprise Project Cost10 (Task) field. | 188744538
TaskEnterpriseProjectCost2 | Represents the Enterprise Project Cost2 (Task) field. | 188744530
TaskEnterpriseProjectCost3 | Represents the Enterprise Project Cost3 (Task) field. | 188744531
TaskEnterpriseProjectCost4 | Represents the Enterprise Project Cost4 (Task) field. | 188744532
TaskEnterpriseProjectCost5 | Represents the Enterprise Project Cost5 (Task) field. | 188744533
TaskEnterpriseProjectCost6 | Represents the Enterprise Project Cost6 (Task) field. | 188744534
TaskEnterpriseProjectCost7 | Represents the Enterprise Project Cost7 (Task) field. | 188744535
TaskEnterpriseProjectCost8 | Represents the Enterprise Project Cost8 (Task) field. | 188744536
TaskEnterpriseProjectCost9 | Represents the Enterprise Project Cost9 (Task) field. | 188744537
TaskEnterpriseProjectDate1 | Represents the Enterprise Project Date1 (Task) field. | 188744539
TaskEnterpriseProjectDate10 | Represents the Enterprise Project Date10 (Task) field. | 188744548
TaskEnterpriseProjectDate11 | Represents the Enterprise Project Date11 (Task) field. | 188744549
TaskEnterpriseProjectDate12 | Represents the Enterprise Project Date12 (Task) field. | 188744550
TaskEnterpriseProjectDate13 | Represents the Enterprise Project Date13 (Task) field. | 188744551
TaskEnterpriseProjectDate14 | Represents the Enterprise Project Date14 (Task) field. | 188744552
TaskEnterpriseProjectDate15 | Represents the Enterprise Project Date15 (Task) field. | 188744553
TaskEnterpriseProjectDate16 | Represents the Enterprise Project Date16 (Task) field. | 188744554
TaskEnterpriseProjectDate17 | Represents the Enterprise Project Date17 (Task) field. | 188744555
TaskEnterpriseProjectDate18 | Represents the Enterprise Project Date18 (Task) field. | 188744556
TaskEnterpriseProjectDate19 | Represents the Enterprise Project Date19 (Task) field. | 188744557
TaskEnterpriseProjectDate2 | Represents the Enterprise Project Date2 (Task) field. | 188744540
TaskEnterpriseProjectDate20 | Represents the Enterprise Project Date20 (Task) field. | 188744558
TaskEnterpriseProjectDate21 | Represents the Enterprise Project Date21 (Task) field. | 188744559
TaskEnterpriseProjectDate22 | Represents the Enterprise Project Date22 (Task) field. | 188744560
TaskEnterpriseProjectDate23 | Represents the Enterprise Project Date23 (Task) field. | 188744561
TaskEnterpriseProjectDate24 | Represents the Enterprise Project Date24 (Task) field. | 188744562
TaskEnterpriseProjectDate25 | Represents the Enterprise Project Date25 (Task) field. | 188744563
TaskEnterpriseProjectDate26 | Represents the Enterprise Project Date26 (Task) field. | 188744564
TaskEnterpriseProjectDate27 | Represents the Enterprise Project Date27 (Task) field. | 188744565
TaskEnterpriseProjectDate28 | Represents the Enterprise Project Date28 (Task) field. | 188744566
TaskEnterpriseProjectDate29 | Represents the Enterprise Project Date29 (Task) field. | 188744567
TaskEnterpriseProjectDate3 | Represents the Enterprise Project Date3 (Task) field. | 188744541
TaskEnterpriseProjectDate30 | Represents the Enterprise Project Date30 (Task) field. | 188744568
TaskEnterpriseProjectDate4 | Represents the Enterprise Project Date4 (Task) field. | 188744542
TaskEnterpriseProjectDate5 | Represents the Enterprise Project Date5 (Task) field. | 188744543
TaskEnterpriseProjectDate6 | Represents the Enterprise Project Date6 (Task) field. | 188744544
TaskEnterpriseProjectDate7 | Represents the Enterprise Project Date7 (Task) field. | 188744545
TaskEnterpriseProjectDate8 | Represents the Enterprise Project Date8 (Task) field. | 188744546
TaskEnterpriseProjectDate9 | Represents the Enterprise Project Date9 (Task) field. | 188744547
TaskEnterpriseProjectDuration1 | Represents the Enterprise Project Duration1 (Task) field. | 188744569
TaskEnterpriseProjectDuration10 | Represents the Enterprise Project Duration10 (Task) field. | 188744578
TaskEnterpriseProjectDuration2 | Represents the Enterprise Project Duration2 (Task) field. | 188744570
TaskEnterpriseProjectDuration3 | Represents the Enterprise Project Duration3 (Task) field. | 188744571
TaskEnterpriseProjectDuration4 | Represents the Enterprise Project Duration4 (Task) field. | 188744572
TaskEnterpriseProjectDuration5 | Represents the Enterprise Project Duration5 (Task) field. | 188744573
TaskEnterpriseProjectDuration6 | Represents the Enterprise Project Duration6 (Task) field. | 188744574
TaskEnterpriseProjectDuration7 | Represents the Enterprise Project Duration7 (Task) field. | 188744575
TaskEnterpriseProjectDuration8 | Represents the Enterprise Project Duration8 (Task) field. | 188744576
TaskEnterpriseProjectDuration9 | Represents the Enterprise Project Duration9 (Task) field. | 188744577
TaskEnterpriseProjectFlag1 | Represents the Enterprise Project Flag1 (Task) field. | 188744649
TaskEnterpriseProjectFlag10 | Represents the Enterprise Project Flag10 (Task) field. | 188744658
TaskEnterpriseProjectFlag11 | Represents the Enterprise Project Flag11 (Task) field. | 188744659
TaskEnterpriseProjectFlag12 | Represents the Enterprise Project Flag12 (Task) field. | 188744660
TaskEnterpriseProjectFlag13 | Represents the Enterprise Project Flag13 (Task) field. | 188744661
TaskEnterpriseProjectFlag14 | Represents the Enterprise Project Flag14 (Task) field. | 188744662
TaskEnterpriseProjectFlag15 | Represents the Enterprise Project Flag15 (Task) field. | 188744663
TaskEnterpriseProjectFlag16 | Represents the Enterprise Project Flag16 (Task) field. | 188744664
TaskEnterpriseProjectFlag17 | Represents the Enterprise Project Flag17 (Task) field. | 188744665
TaskEnterpriseProjectFlag18 | Represents the Enterprise Project Flag18 (Task) field. | 188744666
TaskEnterpriseProjectFlag19 | Represents the Enterprise Project Flag19 (Task) field. | 188744667
TaskEnterpriseProjectFlag2 | Represents the Enterprise Project Flag2 (Task) field. | 188744650
TaskEnterpriseProjectFlag20 | Represents the Enterprise Project Flag20 (Task) field. | 188744668
TaskEnterpriseProjectFlag3 | Represents the Enterprise Project Flag3 (Task) field. | 188744651
TaskEnterpriseProjectFlag4 | Represents the Enterprise Project Flag4 (Task) field. | 188744652
TaskEnterpriseProjectFlag5 | Represents the Enterprise Project Flag5 (Task) field. | 188744653
TaskEnterpriseProjectFlag6 | Represents the Enterprise Project Flag6 (Task) field. | 188744654
TaskEnterpriseProjectFlag7 | Represents the Enterprise Project Flag7 (Task) field. | 188744655
TaskEnterpriseProjectFlag8 | Represents the Enterprise Project Flag8 (Task) field. | 188744656
TaskEnterpriseProjectFlag9 | Represents the Enterprise Project Flag9 (Task) field. | 188744657
TaskEnterpriseProjectNumber1 | Represents the Enterprise Project Number1 (Task) field. | 188744689
TaskEnterpriseProjectNumber10 | Represents the Enterprise Project Number10 (Task) field. | 188744698
TaskEnterpriseProjectNumber11 | Represents the Enterprise Project Number11 (Task) field. | 188744699
TaskEnterpriseProjectNumber12 | Represents the Enterprise Project Number12 (Task) field. | 188744700
TaskEnterpriseProjectNumber13 | Represents the Enterprise Project Number13 (Task) field. | 188744701
TaskEnterpriseProjectNumber14 | Represents the Enterprise Project Number14 (Task) field. | 188744702
TaskEnterpriseProjectNumber15 | Represents the Enterprise Project Number15 (Task) field. | 188744703
TaskEnterpriseProjectNumber16 | Represents the Enterprise Project Number16 (Task) field. | 188744704
TaskEnterpriseProjectNumber17 | Represents the Enterprise Project Number17 (Task) field. | 188744705
TaskEnterpriseProjectNumber18 | Represents the Enterprise Project Number18 (Task) field. | 188744706
TaskEnterpriseProjectNumber19 | Represents the Enterprise Project Number19 (Task) field. | 188744707
TaskEnterpriseProjectNumber2 | Represents the Enterprise Project Number2 (Task) field. | 188744690
TaskEnterpriseProjectNumber20 | Represents the Enterprise Project Number20 (Task) field. | 188744708
TaskEnterpriseProjectNumber21 | Represents the Enterprise Project Number21 (Task) field. | 188744709
TaskEnterpriseProjectNumber22 | Represents the Enterprise Project Number22 (Task) field. | 188744710
TaskEnterpriseProjectNumber23 | Represents the Enterprise Project Number23 (Task) field. | 188744711
TaskEnterpriseProjectNumber24 | Represents the Enterprise Project Number24 (Task) field. | 188744712
TaskEnterpriseProjectNumber25 | Represents the Enterprise Project Number25 (Task) field. | 188744713
TaskEnterpriseProjectNumber26 | Represents the Enterprise Project Number26 (Task) field. | 188744714
TaskEnterpriseProjectNumber27 | Represents the Enterprise Project Number27 (Task) field. | 188744715
TaskEnterpriseProjectNumber28 | Represents the Enterprise Project Number28 (Task) field. | 188744716
TaskEnterpriseProjectNumber29 | Represents the Enterprise Project Number29 (Task) field. | 188744717
TaskEnterpriseProjectNumber3 | Represents the Enterprise Project Number3 (Task) field. | 188744691
TaskEnterpriseProjectNumber30 | Represents the Enterprise Project Number30 (Task) field. | 188744718
TaskEnterpriseProjectNumber31 | Represents the Enterprise Project Number31 (Task) field. | 188744719
TaskEnterpriseProjectNumber32 | Represents the Enterprise Project Number32 (Task) field. | 188744720
TaskEnterpriseProjectNumber33 | Represents the Enterprise Project Number33 (Task) field. | 188744721
TaskEnterpriseProjectNumber34 | Represents the Enterprise Project Number34 (Task) field. | 188744722
TaskEnterpriseProjectNumber35 | Represents the Enterprise Project Number35 (Task) field. | 188744723
TaskEnterpriseProjectNumber36 | Represents the Enterprise Project Number36 (Task) field. | 188744724
TaskEnterpriseProjectNumber37 | Represents the Enterprise Project Number37 (Task) field. | 188744725
TaskEnterpriseProjectNumber38 | Represents the Enterprise Project Number38 (Task) field. | 188744726
TaskEnterpriseProjectNumber39 | Represents the Enterprise Project Number39 (Task) field. | 188744727
TaskEnterpriseProjectNumber4 | Represents the Enterprise Project Number4(Task) field. | 188744692
TaskEnterpriseProjectNumber40 | Represents the Enterprise Project Number40 (Task) field. | 188744728
TaskEnterpriseProjectNumber5 | Represents the Enterprise Project Number5 (Task) field. | 188744693
TaskEnterpriseProjectNumber6 | Represents the Enterprise Project Number6 (Task) field. | 188744694
TaskEnterpriseProjectNumber7 | Represents the Enterprise Project Number7 (Task) field. | 188744695
TaskEnterpriseProjectNumber8 | Represents the Enterprise Project Number8 (Task) field. | 188744696
TaskEnterpriseProjectNumber9 | Represents the Enterprise Project Number9 (Task) field. | 188744697
TaskEnterpriseProjectOutlineCode1 | Represents the Enterprise Project OutlineCode1 (Task) field. | 188744589
TaskEnterpriseProjectOutlineCode10 | Represents the Enterprise Project OutlineCode10 (Task) field. | 188744598
TaskEnterpriseProjectOutlineCode11 | Represents the Enterprise Project OutlineCode11 (Task) field. | 188744599
TaskEnterpriseProjectOutlineCode12 | Represents the Enterprise Project OutlineCode12 (Task) field. | 188744600
TaskEnterpriseProjectOutlineCode13 | Represents the Enterprise Project OutlineCode13 (Task) field. | 188744601
TaskEnterpriseProjectOutlineCode14 | Represents the Enterprise Project OutlineCode14 (Task) field. | 188744602
TaskEnterpriseProjectOutlineCode15 | Represents the Enterprise Project OutlineCode15 (Task) field. | 188744603
TaskEnterpriseProjectOutlineCode16 | Represents the Enterprise Project OutlineCode16 (Task) field. | 188744604
TaskEnterpriseProjectOutlineCode17 | Represents the Enterprise Project OutlineCode17 (Task) field. | 188744605
TaskEnterpriseProjectOutlineCode18 | Represents the Enterprise Project OutlineCode18 (Task) field. | 188744606
TaskEnterpriseProjectOutlineCode19 | Represents the Enterprise Project OutlineCode19 (Task) field. | 188744607
TaskEnterpriseProjectOutlineCode2 | Represents the Enterprise Project OutlineCode2 (Task) field. | 188744590
TaskEnterpriseProjectOutlineCode20 | Represents the Enterprise Project OutlineCode2 (Task) field. | 188744608
TaskEnterpriseProjectOutlineCode21 | Represents the Enterprise Project OutlineCode21 (Task) field. | 188744609
TaskEnterpriseProjectOutlineCode22 | Represents the Enterprise Project OutlineCode22 (Task) field. | 188744610
TaskEnterpriseProjectOutlineCode23 | Represents the Enterprise Project OutlineCode23 (Task) field. | 188744611
TaskEnterpriseProjectOutlineCode24 | Represents the Enterprise Project OutlineCode24 (Task) field. | 188744612
TaskEnterpriseProjectOutlineCode25 | Represents the Enterprise Project OutlineCode25 (Task) field. | 188744613
TaskEnterpriseProjectOutlineCode26 | Represents the Enterprise Project OutlineCode26 (Task) field. | 188744614
TaskEnterpriseProjectOutlineCode27 | Represents the Enterprise Project OutlineCode27 (Task) field. | 188744615
TaskEnterpriseProjectOutlineCode28 | Represents the Enterprise Project OutlineCode28 (Task) field. | 188744616
TaskEnterpriseProjectOutlineCode29 | Represents the Enterprise Project OutlineCode29 (Task) field. | 188744617
TaskEnterpriseProjectOutlineCode3 | Represents the Enterprise Project OutlineCode3 (Task) field. | 188744591
TaskEnterpriseProjectOutlineCode30 | Represents the Enterprise Project OutlineCode30 (Task) field. | 188744618
TaskEnterpriseProjectOutlineCode4 | Represents the Enterprise Project OutlineCode4 (Task) field. | 188744592
TaskEnterpriseProjectOutlineCode5 | Represents the Enterprise Project OutlineCode5 (Task) field. | 188744593
TaskEnterpriseProjectOutlineCode6 | Represents the Enterprise Project OutlineCode6 (Task) field. | 188744594
TaskEnterpriseProjectOutlineCode7 | Represents the Enterprise Project OutlineCode7 (Task) field. | 188744595
TaskEnterpriseProjectOutlineCode8 | Represents the Enterprise Project OutlineCode8 (Task) field. | 188744596
TaskEnterpriseProjectOutlineCode9 | Represents the Enterprise Project OutlineCode9 (Task) field. | 188744597
TaskEnterpriseProjectText1 | Represents the Enterprise Project Text1 (Task) field. | 188744729
TaskEnterpriseProjectText10 | Represents the Enterprise Project Text10 (Task) field. | 188744738
TaskEnterpriseProjectText11 | Represents the Enterprise Project Text11 (Task) field. | 188744739
TaskEnterpriseProjectText12 | Represents the Enterprise Project Text12 (Task) field. | 188744740
TaskEnterpriseProjectText13 | Represents the Enterprise Project Text13 (Task) field. | 188744741
TaskEnterpriseProjectText14 | Represents the Enterprise Project Text14 (Task) field. | 188744742
TaskEnterpriseProjectText15 | Represents the Enterprise Project Text15 (Task) field. | 188744743
TaskEnterpriseProjectText16 | Represents the Enterprise Project Text16 (Task) field. | 188744744
TaskEnterpriseProjectText17 | Represents the Enterprise Project Text17 (Task) field. | 188744745
TaskEnterpriseProjectText18 | Represents the Enterprise Project Text18 (Task) field. | 188744746
TaskEnterpriseProjectText19 | Represents the Enterprise Project Text19 (Task) field. | 188744747
TaskEnterpriseProjectText2 | Represents the Enterprise Project Text2 (Task) field. | 188744730
TaskEnterpriseProjectText20 | Represents the Enterprise Project Text20 (Task) field. | 188744748
TaskEnterpriseProjectText21 | Represents the Enterprise Project Text21 (Task) field. | 188744749
TaskEnterpriseProjectText22 | Represents the Enterprise Project Text22 (Task) field. | 188744750
TaskEnterpriseProjectText23 | Represents the Enterprise Project Text23 (Task) field. | 188744751
TaskEnterpriseProjectText24 | Represents the Enterprise Project Text24 (Task) field. | 188744752
TaskEnterpriseProjectText25 | Represents the Enterprise Project Text25 (Task) field. | 188744753
TaskEnterpriseProjectText26 | Represents the Enterprise Project Text26 (Task) field. | 188744754
TaskEnterpriseProjectText27 | Represents the Enterprise Project Text27 (Task) field. | 188744755
TaskEnterpriseProjectText28 | Represents the Enterprise Project Text28 (Task) field. | 188744756
TaskEnterpriseProjectText29 | Represents the Enterprise Project Text29 (Task) field. | 188744757
TaskEnterpriseProjectText3 | Represents the Enterprise Project Text3 (Task) field. | 188744731
TaskEnterpriseProjectText30 | Represents the Enterprise Project Text30 (Task) field. | 188744758
TaskEnterpriseProjectText31 | Represents the Enterprise Project Text31 (Task) field. | 188744759
TaskEnterpriseProjectText32 | Represents the Enterprise Project Text32 (Task) field. | 188744760
TaskEnterpriseProjectText33 | Represents the Enterprise Project Text33 (Task) field. | 188744761
TaskEnterpriseProjectText34 | Represents the Enterprise Project Text34 (Task) field. | 188744762
TaskEnterpriseProjectText35 | Represents the Enterprise Project Text35 (Task) field. | 188744763
TaskEnterpriseProjectText36 | Represents the Enterprise Project Text36 (Task) field. | 188744764
TaskEnterpriseProjectText37 | Represents the Enterprise Project Text37 (Task) field. | 188744765
TaskEnterpriseProjectText38 | Represents the Enterprise Project Text38 (Task) field. | 188744766
TaskEnterpriseProjectText39 | Represents the Enterprise Project Text39 (Task) field. | 188744767
TaskEnterpriseProjectText4 | Represents the Enterprise Project Text4 (Task) field. | 188744732
TaskEnterpriseProjectText40 | Represents the Enterprise Project Text40 (Task) field. | 188744768
TaskEnterpriseProjectText5 | Represents the Enterprise Project Text5 (Task) field. | 188744733
TaskEnterpriseProjectText6 | Represents the Enterprise Project Text6 (Task) field. | 188744734
TaskEnterpriseProjectText7 | Represents the Enterprise Project Text7 (Task) field. | 188744735
TaskEnterpriseProjectText8 | Represents the Enterprise Project Text8 (Task) field. | 188744736
TaskEnterpriseProjectText9 | Represents the Enterprise Project Text9(Task) field. | 188744737
TaskEnterpriseText1 | Represents the Enterprise Text1 (Task) field. | 188744479
TaskEnterpriseText10 | Represents the Enterprise Text10 (Task) field. | 188744488
TaskEnterpriseText11 | Represents the Enterprise Text11 (Task) field. | 188744489
TaskEnterpriseText12 | Represents the Enterprise Text12 (Task) field. | 188744490
TaskEnterpriseText13 | Represents the Enterprise Text13 (Task) field. | 188744491
TaskEnterpriseText14 | Represents the Enterprise Text14 (Task) field. | 188744492
TaskEnterpriseText15 | Represents the Enterprise Text15 (Task) field. | 188744493
TaskEnterpriseText16 | Represents the Enterprise Text16 (Task) field. | 188744494
TaskEnterpriseText17 | Represents the Enterprise Text17 (Task) field. | 188744495
TaskEnterpriseText18 | Represents the Enterprise Text18 (Task) field. | 188744496
TaskEnterpriseText19 | Represents the Enterprise Text19 (Task) field. | 188744497
TaskEnterpriseText2 | Represents the Enterprise Text2 (Task) field. | 188744480
TaskEnterpriseText20 | Represents the Enterprise Text20 (Task) field. | 188744498
TaskEnterpriseText21 | Represents the Enterprise Text21 (Task) field. | 188744499
TaskEnterpriseText22 | Represents the Enterprise Text22 (Task) field. | 188744500
TaskEnterpriseText23 | Represents the Enterprise Text23 (Task) field. | 188744501
TaskEnterpriseText24 | Represents the Enterprise Text24 (Task) field. | 188744502
TaskEnterpriseText25 | Represents the Enterprise Text25 (Task) field. | 188744503
TaskEnterpriseText26 | Represents the Enterprise Text26 (Task) field. | 188744504
TaskEnterpriseText27 | Represents the Enterprise Text27 (Task) field. | 188744505
TaskEnterpriseText28 | Represents the Enterprise Text28 (Task) field. | 188744506
TaskEnterpriseText29 | Represents the Enterprise Text29 (Task) field. | 188744507
TaskEnterpriseText3 | Represents the Enterprise Text3 (Task) field. | 188744481
TaskEnterpriseText30 | Represents the Enterprise Text30 (Task) field. | 188744508
TaskEnterpriseText31 | Represents the Enterprise Text31 (Task) field. | 188744509
TaskEnterpriseText32 | Represents the Enterprise Text32 (Task) field. | 188744510
TaskEnterpriseText33 | Represents the Enterprise Text33 (Task) field. | 188744511
TaskEnterpriseText34 | Represents the Enterprise Text34 (Task) field. | 188744512
TaskEnterpriseText35 | Represents the Enterprise Text35 (Task) field. | 188744513
TaskEnterpriseText36 | Represents the Enterprise Text36 (Task) field. | 188744514
TaskEnterpriseText37 | Represents the Enterprise Text37 (Task) field. | 188744515
TaskEnterpriseText38 | Represents the Enterprise Text38 (Task) field. | 188744516
TaskEnterpriseText39 | Represents the Enterprise Text39 (Task) field. | 188744517
TaskEnterpriseText4 | Represents the Enterprise Text4 (Task) field. | 188744482
TaskEnterpriseText40 | Represents the Enterprise Text40 (Task) field. | 188744518
TaskEnterpriseText5 | Represents the Enterprise Text5 (Task) field. | 188744483
TaskEnterpriseText6 | Represents the Enterprise Text6 (Task) field. | 188744484
TaskEnterpriseText7 | Represents the Enterprise Text7 (Task) field. | 188744485
TaskEnterpriseText8 | Represents the Enterprise Text8 (Task) field. | 188744486
TaskEnterpriseText9 | Represents the Enterprise Text9 (Task) field. | 188744487
TaskErrorMessage | Represents the Error Message (Task) field. | 188744847
TaskEstimated | Represents the Estimated (Task) field. | 188744076
TaskExternalTask | Represents the External Task (Task) field. | 188743912
TaskFinish | Represents the Finish (Task) field. | 188743716
TaskFinish1 | Represents the Finish1 (Task) field. | 188743733
TaskFinish10 | Represents the Finish10 (Task) field. | 188743971
TaskFinish2 | Represents the Finish2 (Task) field. | 188743736
TaskFinish3 | Represents the Finish3 (Task) field. | 188743739
TaskFinish4 | Represents the Finish4 (Task) field. | 188743742
TaskFinish5 | Represents the Finish5 (Task) field. | 188743745
TaskFinish6 | Represents the Finish6 (Task) field. | 188743963
TaskFinish7 | Represents the Finish7 (Task) field. | 188743965
TaskFinish8 | Represents the Finish8 (Task) field. | 188743967
TaskFinish9 | Represents the Finish9 (Task) field. | 188743969
TaskFinishSlack | Represents the Finish Slack (Task) field. | 188744119
TaskFinishText | Represents the Task Finish Text (Task) field. | 188744966
TaskFinishVariance | Represents the Finish Variance (Task) field. | 188743726
TaskFixedCost | Represents the Fixed Cost (Task) field. | 188743688
TaskFixedCostAccrual | Represents the Fixed Cost Accrual (Task) field. | 188743880
TaskFixedDuration | Represents the Fixed Duration (Task) field. | 188743714
TaskFlag1 | Represents the Flag1 (Task) field. | 188743752
TaskFlag10 | Represents the Flag10 (Task) field. | 188743761
TaskFlag11 | Represents the Flag11 (Task) field. | 188743972
TaskFlag12 | Represents the Flag12 (Task) field. | 188743973
TaskFlag13 | Represents the Flag13 (Task) field. | 188743974
TaskFlag14 | Represents the Flag14 (Task) field. | 188743975
TaskFlag15 | Represents the Flag15 (Task) field. | 188743976
TaskFlag16 | Represents the Flag16 (Task) field. | 188743977
TaskFlag17 | Represents the Flag17 (Task) field. | 188743978
TaskFlag18 | Represents the Flag18 (Task) field. | 188743979
TaskFlag19 | Represents the Flag19 (Task) field. | 188743980
TaskFlag2 | Represents the Flag2 (Task) field. | 188743753
TaskFlag20 | Represents the Flag20 (Task) field. | 188743981
TaskFlag3 | Represents the Flag3 (Task) field. | 188743754
TaskFlag4 | Represents the Flag4 (Task) field. | 188743755
TaskFlag5 | Represents the Flag5 (Task) field. | 188743756
TaskFlag6 | Represents the Flag6 (Task) field. | 188743757
TaskFlag7 | Represents the Flag7 (Task) field. | 188743758
TaskFlag8 | Represents the Flag8 (Task) field. | 188743759
TaskFlag9 | Represents the Flag9 (Task) field. | 188743760
TaskFreeSlack | Represents the Free Slack (Task) field. | 188743701
TaskGroupBySummary | Represents the Group By Summary (Task) field. | 188744126
TaskGuid | Represents the Task GUID (Task) field. | 188744823
TaskHideBar | Represents the Hide Bar (Task) field. | 188743789
TaskHyperlink | Represents the Hyperlink (Task) field. | 188743897
TaskHyperlinkAddress | Represents the Hyperlink Address (Task) field. | 188743898
TaskHyperlinkHref | Represents the Hyperlink HRef (Task) field. | 188743900
TaskHyperlinkScreenTip | Represents the Hyperlink ScreenTip (Task) field. | 188744132
TaskHyperlinkSubAddress | Represents the Hyperlink Sub Address (Task) field. | 188743899
TaskID | Represents the ID (Task) field. | 188743703
TaskIgnoreResourceCalendar | Represents the Ignore Resource Calendar (Task) field. | 188744079
TaskIgnoreWarnings | Represents the Task Ignore Warnings (Task) field. | 188745012
TaskIndex | Represents the Index (Task) field. | 188744040
TaskIndicators | Represents the Indicators (Task) field. | 188743885
TaskIsAssignment | Represents the Is Assignment (Task) field. | 188743904
TaskIsDurationValid | Represents the field that shows whether task duration is valid, when converting from a manual to an automatically scheduled task. | 188744977
TaskIsFinishValid | Represents the field that shows whether task finish date is valid, when converting from a manual to an automatically scheduled task. | 188744976
TaskIsStartValid | Represents the field that shows whether task start date is valid, when converting from a manual to an automatically scheduled task. | 188744975
TaskIsPublished | Represents the Is Published (Task) field. | 188744845
TaskLateFinish | Represents the Late Finish (Task) field. | 188743720
TaskLateStart | Represents the Late Start (Task) field. | 188743719
TaskLevelAssignments | Represents the Level Assignments (Task) field. | 188743933
TaskLevelCanSplit | Represents the Level Can Split (Task) field. | 188743932
TaskLevelDelay | Represents the Level Delay (Task) field. | 188743700
TaskLinkedFields | Represents the Linked Fields (Task) field. | 188743778
TaskManual | Represents the Task Manual (TASK) field. | 188744960
TaskMarked | Represents the Marked (Task) field. | 188743751
TaskMilestone | Represents the Milestone (Task) field. | 188743704
TaskName | Represents the Name (Task) field. | 188743694
TaskNotes | Represents the Notes (Task) field. | 188743695
TaskNumber1 | Represents the Number1 (Task) field. | 188743767
TaskNumber10 | Represents the Number10 (Task) field. | 188743986
TaskNumber11 | Represents the Number11 (Task) field. | 188743987
TaskNumber12 | Represents the Number12 (Task) field. | 188743988
TaskNumber13 | Represents the Number13 (Task) field. | 188743989
TaskNumber14 | Represents the Number14 (Task) field. | 188743990
TaskNumber15 | Represents the Number15 (Task) field.. | 188743991
TaskNumber16 | Represents the Number16 (Task) field. | 188743992
TaskNumber17 | Represents the Number17 (Task) field. | 188743993
TaskNumber18 | Represents the Number18 (Task) field. | 188743994
TaskNumber19 | Represents the Number19 (Task) field. | 188743995
TaskNumber2 | Represents the Number2 (Task) field. | 188743768
TaskNumber20 | Represents the Number20 (Task) field. | 188743996
TaskNumber3 | Represents the Number3 (Task) field. | 188743769
TaskNumber4 | Represents the Number4 (Task) field. | 188743770
TaskNumber5 | Represents the Number5 (Task) field. | 188743771
TaskNumber6 | Represents the Number6 (Task) field. | 188743982
TaskNumber7 | Represents the Number7 (Task) field. | 188743983
TaskNumber8 | Represents the Number8 (Task) field. | 188743984
TaskNumber9 | Represents the Number9 (Task) field. | 188743985
TaskObjects | Represents the Objects (Task) field. | 188743777
TaskOutlineCode1 | Represents the Outline Code1 (Task) field. | 188744096
TaskOutlineCode10 | Represents the Outline Code10 (Task) field. | 188744114
TaskOutlineCode2 | Represents the Outline Code2 (Task) field. | 188744098
TaskOutlineCode3 | Represents the Outline Code3 (Task) field. | 188744100
TaskOutlineCode4 | Represents the Outline Code4 (Task) field. | 188744102
TaskOutlineCode5 | Represents the Outline Code5 (Task) field. | 188744104
TaskOutlineCode6 | Represents the Outline Code6 (Task) field. | 188744106
TaskOutlineCode7 | Represents the Outline Code7 (Task) field. | 188744108
TaskOutlineCode8 | Represents the Outline Code8 (Task) field. | 188744110
TaskOutlineCode9 | Represents the Outline Code9 (Task) field. | 188744112
TaskOutlineLevel | Represents the Outline Level (Task) field. | 188743765
TaskOutlineNumber | Represents the Outline Code (Task) field. | 188743782
TaskOverallocated | Represents the Overallocated (Task) field. | 188743905
TaskOvertimeCost | Represents the Overtime Cost (Task) field. | 188743848
TaskOvertimeWork | Represents the Overtime Work (Task) field. | 188743843
TaskPathDrivenSuccessor | The driven successor field for a task path. See the Task.PathDrivenSuccessor property. | 188745063
TaskPathDrivingPredecessor | The driving predecessor field for a task path. See the Task.PathDrivingPredecessor property. | 188745061
TaskPathPredecessor | The predecessor field for a task path. See the Task.PathPredecessor property. | 188745062
TaskPathSuccessor | The successor field for a task path. See the Task.PathSuccessor property. | 188745064
TaskParentTask | Represents the Parent Task (Task) field. | 188743815
TaskPercentComplete | Represents the Percent Complete (Task) field. | 188743712
TaskPercentWorkComplete | Represents the Percent Work Complete (Task) field. | 188743713
TaskPhysicalPercentComplete | Represents the Physical Percent Complete (Task) field. | 188744799
TaskPlaceholder | Represents the Task Placeholder (Task) field. | 188744961
TaskPredecessors | Represents the Predecessors (Task) field. | 188743727
TaskPreleveledFinish | Represents the Preleveled Finish (Task) field. | 188744050
TaskPreleveledStart | Represents the Preleveled Start (Task) field. | 188744049
TaskPriority | Represents the Priority (Task) field. | 188743705
TaskProject | Represents the Project (Task) field. | 188743764
TaskRecalcFlags | Represents the Recalc Flags (Task) field. | 188744930
TaskRecurring | Represents the Recurring (Task) field. | 188743809
TaskRegularWork | Represents the Regular Work (Task) field. | 188743846
TaskRemainingCost | Represents the Remaining Cost (Task) field. | 188743690
TaskRemainingDuration | Represents the Remaining Duration (Task) field. | 188743711
TaskRemainingOvertimeCost | Represents the Remaining Overtime Cost (Task) field. | 188743850
TaskRemainingOvertimeWork | Represents the Remaining Overtime Work (Task) field. | 188743845
TaskRemainingWork | Represents the Remaining Work (Task) field. | 188743684
TaskResourceEnterpriseMultiValueCode20 | Represents the Enterprise Resource MultiValue Code20 (Task) field. | 188744809
TaskResourceEnterpriseMultiValueCode21 | Represents the Enterprise Resource MultiValue Code21 (Task) field. | 188744810
TaskResourceEnterpriseMultiValueCode22 | Represents the Enterprise Resource MultiValue Code22 (Task) field. | 188744811
TaskResourceEnterpriseMultiValueCode23 | Represents the Enterprise Resource MultiValue Code23 (Task) field. | 188744812
TaskResourceEnterpriseMultiValueCode24 | Represents the Enterprise Resource MultiValue Code24 (Task) field. | 188744813
TaskResourceEnterpriseMultiValueCode25 | Represents the Enterprise Resource MultiValue Code25 (Task) field. | 188744814
TaskResourceEnterpriseMultiValueCode26 | Represents the Enterprise Resource MultiValue Code26 (Task) field. | 188744815
TaskResourceEnterpriseMultiValueCode27 | Represents the Enterprise Resource MultiValue Code27 (Task) field. | 188744816
TaskResourceEnterpriseMultiValueCode28 | Represents the Enterprise Resource MultiValue Code28 (Task) field. | 188744817
TaskResourceEnterpriseMultiValueCode29 | Represents the Enterprise Resource MultiValue Code29 (Task) field. | 188744818
TaskResourceEnterpriseOutlineCode1 | Represents the Enterprise Resource Outline Code1 (Task) field. | 188744769
TaskResourceEnterpriseOutlineCode10 | Represents the Enterprise Resource Outline Code10 (Task) field. | 188744778
TaskResourceEnterpriseOutlineCode11 | Represents the Enterprise Resource Outline Code11 (Task) field. | 188744779
TaskResourceEnterpriseOutlineCode12 | Represents the Enterprise Resource Outline Code12 (Task) field. | 188744780
TaskResourceEnterpriseOutlineCode13 | Represents the Enterprise Resource Outline Code13 (Task) field. | 188744781
TaskResourceEnterpriseOutlineCode14 | Represents the Enterprise Resource Outline Code14 (Task) field. | 188744782
TaskResourceEnterpriseOutlineCode15 | Represents the Enterprise Resource Outline Code15 (Task) field. | 188744783
TaskResourceEnterpriseOutlineCode16 | Represents the Enterprise Resource Outline Code16 (Task) field. | 188744784
TaskResourceEnterpriseOutlineCode17 | Represents the Enterprise Resource Outline Code17 (Task) field. | 188744785
TaskResourceEnterpriseOutlineCode18 | Represents the Enterprise Resource Outline Code18 (Task) field. | 188744786
TaskResourceEnterpriseOutlineCode19 | Represents the Enterprise Resource Outline Code19 (Task) field. | 188744787
TaskResourceEnterpriseOutlineCode2 | Represents the Enterprise Resource Outline Code2 (Task) field. | 188744770
TaskResourceEnterpriseOutlineCode20 | Represents the Enterprise Resource Outline Code20 (Task) field. | 188744788
TaskResourceEnterpriseOutlineCode21 | Represents the Enterprise Resource Outline Code21 (Task) field. | 188744789
TaskResourceEnterpriseOutlineCode22 | Represents the Enterprise Resource Outline Code22 (Task) field. | 188744790
TaskResourceEnterpriseOutlineCode23 | Represents the Enterprise Resource Outline Code23 (Task) field. | 188744791
TaskResourceEnterpriseOutlineCode24 | Represents the Enterprise Resource Outline Code24 (Task) field. | 188744792
TaskResourceEnterpriseOutlineCode25 | Represents the Enterprise Resource Outline Code25 (Task) field. | 188744793
TaskResourceEnterpriseOutlineCode26 | Represents the Enterprise Resource Outline Code26 (Task) field. | 188744794
TaskResourceEnterpriseOutlineCode27 | Represents the Enterprise Resource Outline Code27 (Task) field. | 188744795
TaskResourceEnterpriseOutlineCode28 | Represents the Enterprise Resource Outline Code28 (Task) field. | 188744796
TaskResourceEnterpriseOutlineCode29 | Represents the Enterprise Resource Outline Code29 (Task) field. | 188744797
TaskResourceEnterpriseOutlineCode3 | Represents the Enterprise Resource Outline Code3 (Task) field. | 188744771
TaskResourceEnterpriseOutlineCode4 | Represents the Enterprise Resource Outline Code4 (Task) field. | 188744772
TaskResourceEnterpriseOutlineCode5 | Represents the Enterprise Resource Outline Code5 (Task) field. | 188744773
TaskResourceEnterpriseOutlineCode6 | Represents the Enterprise Resource Outline Code6 (Task) field. | 188744774
TaskResourceEnterpriseOutlineCode7 | Represents the Enterprise Resource Outline Code7 (Task) field. | 188744775
TaskResourceEnterpriseOutlineCode8 | Represents the Enterprise Resource Outline Code8 (Task) field. | 188744776
TaskResourceEnterpriseOutlineCode9 | Represents the Enterprise Resource Outline Code9 (Task) field. | 188744777
TaskResourceEnterpriseRBS | Represents the Enterprise Resource RBS (Task) field. | 188744798
TaskResourceGroup | Represents the Resource Group (Task) field. | 188743793
TaskResourceInitials | Represents the Resource Initials (Task) field. | 188743730
TaskResourceNames | Represents the Resource Names (Task) field. | 188743729
TaskResourcePhonetics | Represents the Resource Phonetics (Task) field. | 188744029
TaskResourceType | Represents the Resource Type (Task) field. | 188744131
TaskResponsePending | Represents the Response Pending (Task) field. | 188743930
TaskResume | Represents the Resume (Task) field. | 188743779
TaskResumeNoEarlierThan | Represents the Resume No Earlier Than (Task) field. | 188743781
TaskRollup | Represents the Rollup (Task) field. | 188743762
TaskScheduledDuration | Represents the Task Scheduled Duration (Task) field. | 188745020
TaskScheduledFinish | Represents the Task Scheduled Finish (Task) field. | 188745019
TaskScheduledStart | Represents the Task Scheduled Start (Task) field. | 188745018
TaskSheetNotes | Represents the Sheet Notes (Task) field. | 188743774
TaskSPI | Represents the SPI (Task) field. | 188744218
TaskStart | Represents the Start (Task) field. | 188743715
TaskStart1 | Represents the Start1 (Task) field. | 188743732
TaskStart10 | Represents the Start10 (Task) field. | 188743970
TaskStart2 | Represents the Start2 (Task) field. | 188743735
TaskStart3 | Represents the Start3 (Task) field. | 188743738
TaskStart4 | Represents the Start4 (Task) field. | 188743741
TaskStart5 | Represents the Start5 (Task) field. | 188743744
TaskStart6 | Represents the Start6 (Task) field. | 188743962
TaskStart7 | Represents the Start7 (Task) field. | 188743964
TaskStart8 | Represents the Start8 (Task) field. | 188743966
TaskStart9 | Represents the Start9 (Task) field. | 188743968
TaskStartSlack | Represents the Start Slack (Task) field. | 188744118
TaskStartText | Represents the Task Start Text (Task) field. | 188744965
TaskStartVariance | Represents the Start Variance (Task) field. | 188743725
TaskStatus | Represents the Status (Task) field. | 188744223
TaskStatusIndicator | Represents the Status Indicator (Task) field. | 188744801
TaskStatusManagerName | Represents the Status Manager Name (Task) field. | 188744846
TaskStop | Represents the Stop (Task) field. | 188743780
TaskSubproject | Represents the Subproject (Task) field. | 188743706
TaskSubprojectReadOnly | Represents the Subproject Read Only (Task) field. | 188743926
TaskSuccessors | Represents the Successors (Task) field. | 188743728
TaskSummary | Represents the Summary (Task) field. | 188743772
TaskSV | Represents the SV (Task) field. | 188743693
TaskSVPercent | Represents the SV Percent (Task) field. | 188744220
TaskTCPI | Represents the TCPI (Task) field. | 188744222
TaskTeamStatusPending | Represents the Team Status Pending (Task) field. | 188743931
TaskText1 | Represents the Text1 (Task) field. | 188743731
TaskText10 | Represents the Text10 (Task) field. | 188743750
TaskText11 | Represents the Text11 (Task) field. | 188743997
TaskText12 | Represents the Text12 (Task) field. | 188743998
TaskText13 | Represents the Text13 (Task) field. | 188743999
TaskText14 | Represents the Text14 (Task) field. | 188744000
TaskText15 | Represents the Text15 (Task) field. | 188744001
TaskText16 | Represents the Text16 (Task) field. | 188744002
TaskText17 | Represents the Text17 (Task) field. | 188744003
TaskText18 | Represents the Text18 (Task) field. | 188744004
TaskText19 | Represents the Text19 (Task) field. | 188744005
TaskText2 | Represents the Text2 (Task) field. | 188743734
TaskText20 | Represents the Text20 (Task) field. | 188744006
TaskText21 | Represents the Text21 (Task) field. | 188744007
TaskText22 | Represents the Text22 (Task) field. | 188744008
TaskText23 | Represents the Text23 (Task) field. | 188744009
TaskText24 | Represents the Text24 (Task) field. | 188744010
TaskText25 | Represents the Text25 (Task) field. | 188744011
TaskText26 | Represents the Text26 (Task) field. | 188744012
TaskText27 | Represents the Text27 (Task) field. | 188744013
TaskText28 | Represents the Text28 (Task) field. | 188744014
TaskText29 | Represents the Text29 (Task) field. | 188744015
TaskText3 | Represents the Text3 (Task) field. | 188743737
TaskText30 | Represents the Text30 (Task) field. | 188744016
TaskText4 | Represents the Text4 (Task) field. | 188743740
TaskText5 | Represents the Text5 (Task) field. | 188743743
TaskText6 | Represents the Text6 (Task) field. | 188743746
TaskText7 | Represents the Text7 (Task) field. | 188743747
TaskText8 | Represents the Text8 (Task) field. | 188743748
TaskText9 | Represents the Text9 (Task) field. | 188743749
TaskTotalSlack | Represents the Total Slack (Task) field. | 188743702
TaskType | Represents the Type (Task) field. | 188743808
TaskUniqueID | Represents the Unique ID (Task) field. | 188743766
TaskUniquePredecessors | Represents the Unique Predecessors (Task) field. | 188743775
TaskUniqueSuccessors | Represents the Unique Successors (Task) field. | 188743776
TaskUpdateNeeded | Represents the Update Needed (Task) field. | 188743791
TaskVAC | Represents the VAC (Task) field. | 188744121
TaskWarning | Represents the Task Warning (Task) field. | 188744962
TaskWBS | Represents the WBS (Task) field. | 188743696
TaskWBSPredecessors | Represents the WBS Predecessors (Task) field. | 188744129
TaskWBSSuccessors | Represents the WBS Successors (Task) field. | 188744130
TaskWork | Represents the Work (Task) field. | 188743680
TaskWorkContour | Represents the Work Contour (Task) field. | 188743936
TaskWorkVariance | Represents the Work Variance (Task) field. | 188743683
TaskCompleteThrough | Available only in the Bar Styles dialog box in MSP and is represented as a bar on the Gantt Chart. | 188743799

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


FileFormat Enumeration

Specifies the project's file format.

public enum FileFormat

Members

Member Name | Description | Value
Undefined | Can not be defined. | 0
XML | Microsoft Project XML format. | 1
MPP8 | Microsoft Project 2000 format. | 2
MPP9 | Microsoft Project 2003 format. | 3
MPP12 | Microsoft Project 2007 format. | 4
MPP14 | Microsoft Project 2010 format. | 5
MPT9 | Microsoft Project 2003 template format. | 6
MPT12 | Microsoft Project 2007 template format. | 7
MPT14 | Microsoft Project 2010(2013) template format. | 8

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


Filter Class

Represents a filter in Project.

For a list of all members of this type, see Filter Members.

System.Object
Aspose.Tasks.Filter

public class Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Filter Members | Aspose.Tasks Namespace


Filter Members

Filter overview

Public Instance Constructors

Filter Constructor Initializes a new instance of the Filter class.

Public Instance Properties

Criteria | The criteria that tasks or resources must meet to be displayed in MSP view.
FilterType | Gets the type of the filter. Read-only ItemType.
Index | Gets the index of a Filter object in the Filters containing object. Read-only Int32.
Name | Gets the name of a Filter object. Read/write String.
ParentProject | Gets the parent of the Filter object. Read-only Project.
ShowInMenu | True if Project shows the filter name in the Filter drop-down list on the View tab of the Ribbon. Read/write Boolean.
ShowRelatedSummaryRows | True if related summary rows are displayed for the filter. Read/write Boolean.
Uid | The unique identifier of a filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Filter Class | Aspose.Tasks Namespace


Filter Constructor

Initializes a new instance of the Filter class.

public Filter();

See Also

Filter Class | Aspose.Tasks Namespace


Filter Properties

The properties of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Instance Properties

Criteria | The criteria that tasks or resources must meet to be displayed in MSP view.
FilterType | Gets the type of the filter. Read-only ItemType.
Index | Gets the index of a Filter object in the Filters containing object. Read-only Int32.
Name | Gets the name of a Filter object. Read/write String.
ParentProject | Gets the parent of the Filter object. Read-only Project.
ShowInMenu | True if Project shows the filter name in the Filter drop-down list on the View tab of the Ribbon. Read/write Boolean.
ShowRelatedSummaryRows | True if related summary rows are displayed for the filter. Read/write Boolean.
Uid | The unique identifier of a filter.

See Also

Filter Class | Aspose.Tasks Namespace


Criteria Property

Filter.Criteria Property

The criteria that tasks or resources must meet to be displayed in MSP view.

public FilterCriteria Criteria {get; set;}

See Also

Filter Class | Aspose.Tasks Namespace


FilterType Property

Filter.FilterType Property

Gets the type of the filter. Read-only ItemType.

public ItemType FilterType {get; set;}

See Also

Filter Class | Aspose.Tasks Namespace


Index Property

Filter.Index Property

Gets the index of a Filter object in the Filters containing object. Read-only Int32.

public int Index {get; set;}

See Also

Filter Class | Aspose.Tasks Namespace


Name Property

Filter.Name Property

Gets the name of a Filter object. Read/write String.

public string Name {get; set;}

See Also

Filter Class | Aspose.Tasks Namespace


ParentProject Property

Filter.ParentProject Property

Gets the parent of the Filter object. Read-only Project.

public Project ParentProject {get; set;}

See Also

Filter Class | Aspose.Tasks Namespace


ShowInMenu Property

Filter.ShowInMenu Property

True if Project shows the filter name in the Filter drop-down list on the View tab of the Ribbon. Read/write Boolean.

public bool ShowInMenu {get; set;}

See Also

Filter Class | Aspose.Tasks Namespace


ShowRelatedSummaryRows Property

Filter.ShowRelatedSummaryRows Property

True if related summary rows are displayed for the filter. Read/write Boolean.

public bool ShowRelatedSummaryRows {get; set;}

See Also

Filter Class | Aspose.Tasks Namespace


Uid Property

Filter.Uid Property

The unique identifier of a filter.

public int Uid {get; set;}

See Also

Filter Class | Aspose.Tasks Namespace


FilterComparisonType Enumeration

The type of comparison made between FieldName and Value that acts as selection criteria for the filter.

public enum FilterComparisonType

Members

Member Name | Description | Value
Equals | The value of Field equals Value. | 6
DoesNotEqual | The value of Field does not equal Value. | 7
IsGreaterThan | The value of Field is greater than Value. | 2
IsGreaterThanOrEqualTo | The value of Field is greater than or equal to Value. | 4
IsLessThan | The value of Field is less than Value. | 3
IsLessThanOrEqualTo | The value of Field is less than or equal to Value. | 5
IsWithin | The value of Field is within Value. | 1
IsNotWithin | The value of Field is not within Value. | 9
Contains | Field contains Value. | 8
DoesNotContain | Field does not contain Value. | 10
ContainsExactly | Field exactly contains Value. | 11
Undefined | Undefined value. | 0

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


FilterCriteria Class

Defines the criteria that tasks or resources must meet to be displayed in MSP view.

For a list of all members of this type, see FilterCriteria Members.

System.Object
Aspose.Tasks.FilterCriteria

public class FilterCriteria

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

FilterCriteria Members | Aspose.Tasks Namespace


FilterCriteria Members

FilterCriteria overview

Public Instance Constructors

FilterCriteria Constructor Initializes a new instance of the FilterCriteria class.

Public Instance Properties

CriteriaRows | A List of child FilterCriteria rows. If the filter contains more than one criterion row then the effect of an And operator is that the criteria for both rows must be met for the task or resource to be displayed as a result of this filter. The effect of an Or operator is that the criteria for one or the other row must be met.
Field | A Field to change.
Operation | Specifies how the criterion established with FieldName, Test, and Value relates to other criteria in the filter.
Test | The type of comparison made between FieldName and Value that acts as selection criteria for the filter. FilterComparisonType
Values | The object values to compare with the value of the field specified with FieldName.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterCriteria Class | Aspose.Tasks Namespace


FilterCriteria Constructor

Initializes a new instance of the FilterCriteria class.

public FilterCriteria();

See Also

FilterCriteria Class | Aspose.Tasks Namespace


FilterCriteria Properties

The properties of the FilterCriteria class are listed below. For a complete list of FilterCriteria class members, see the FilterCriteria Members topic.

Public Instance Properties

CriteriaRows | A List of child FilterCriteria rows. If the filter contains more than one criterion row then the effect of an And operator is that the criteria for both rows must be met for the task or resource to be displayed as a result of this filter. The effect of an Or operator is that the criteria for one or the other row must be met.
Field | A Field to change.
Operation | Specifies how the criterion established with FieldName, Test, and Value relates to other criteria in the filter.
Test | The type of comparison made between FieldName and Value that acts as selection criteria for the filter. FilterComparisonType
Values | The object values to compare with the value of the field specified with FieldName.

See Also

FilterCriteria Class | Aspose.Tasks Namespace


CriteriaRows Property

FilterCriteria.CriteriaRows Property

A List of child FilterCriteria rows. If the filter contains more than one criterion row then the effect of an And operator is that the criteria for both rows must be met for the task or resource to be displayed as a result of this filter. The effect of an Or operator is that the criteria for one or the other row must be met.

public FilterCriteria} CriteriaRows {get; set;}

See Also

FilterCriteria Class | Aspose.Tasks Namespace


Field Property

FilterCriteria.Field Property

A Field to change.

public Field Field {get; set;}

See Also

FilterCriteria Class | Aspose.Tasks Namespace


Operation Property

FilterCriteria.Operation Property

Specifies how the criterion established with FieldName, Test, and Value relates to other criteria in the filter.

public FilterOperation Operation {get; set;}

See Also

FilterCriteria Class | Aspose.Tasks Namespace


Test Property

FilterCriteria.Test Property

The type of comparison made between FieldName and Value that acts as selection criteria for the filter. FilterComparisonType

public FilterComparisonType Test {get; set;}

See Also

FilterCriteria Class | Aspose.Tasks Namespace


Values Property

FilterCriteria.Values Property

The object values to compare with the value of the field specified with FieldName.

public object[] Values {get;}

See Also

FilterCriteria Class | Aspose.Tasks Namespace


FilterCriteria Methods

The methods of the FilterCriteria class are listed below. For a complete list of FilterCriteria class members, see the FilterCriteria Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterCriteria Class | Aspose.Tasks Namespace


FilterCriteria.ToString Method

public override string ToString();

See Also

FilterCriteria Class | Aspose.Tasks Namespace


FilterOperation Enumeration

Specifies how the criterion established with FieldName, FilterComparisonType, and Value relates to other criteria in the filter.

public enum FilterOperation

Members

Member Name | Description | Value
Undefined | Undefined. | 0
And | AND operator. | 1
Or | OR operator. | 2

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


Filters Class

Contains a list of Filter objects. Implements ICollection<Filter> interface.

For a list of all members of this type, see Filters Members.

System.Object
Aspose.Tasks.Filters

public class Filters : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Filters Members | Aspose.Tasks Namespace


Filters Members

Filters overview

Public Instance Properties

Count |
IsReadOnly |
ParentProject | Gets the parent of the Filters object. Read-only Project.

Public Instance Methods

Add |
Clear |
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToList | Converts a filter collection to a list of Filter objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Filters Class | Aspose.Tasks Namespace


Filters Properties

The properties of the Filters class are listed below. For a complete list of Filters class members, see the Filters Members topic.

Public Instance Properties

Count |
IsReadOnly |
ParentProject | Gets the parent of the Filters object. Read-only Project.

See Also

Filters Class | Aspose.Tasks Namespace


Count Property

Filters.Count Property

public int Count {get;}

Implements

ICollection`1.Count

See Also

Filters Class | Aspose.Tasks Namespace


IsReadOnly Property

Filters.IsReadOnly Property

public bool IsReadOnly {get;}

Implements

ICollection`1.IsReadOnly

See Also

Filters Class | Aspose.Tasks Namespace


ParentProject Property

Filters.ParentProject Property

Gets the parent of the Filters object. Read-only Project.

public Project ParentProject {get; set;}

See Also

Filters Class | Aspose.Tasks Namespace


Filters Methods

The methods of the Filters class are listed below. For a complete list of Filters class members, see the Filters Members topic.

Public Instance Methods

Add |
Clear |
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToList | Converts a filter collection to a list of Filter objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Filters Class | Aspose.Tasks Namespace


Filters.Add Method

public void Add(
Filter item
);

Implements

ICollection`1.Add

See Also

Filters Class | Aspose.Tasks Namespace


Filters.Clear Method

public void Clear();

Implements

ICollection`1.Clear

See Also

Filters Class | Aspose.Tasks Namespace


Filters.Contains Method

public bool Contains(
Filter item
);

Implements

ICollection`1.Contains

See Also

Filters Class | Aspose.Tasks Namespace


Filters.CopyTo Method

public void CopyTo(
Filter[] array,
int arrayIndex
);

Implements

ICollection`1.CopyTo

See Also

Filters Class | Aspose.Tasks Namespace


Filters.GetEnumerator Method

public IEnumerator<Filter> GetEnumerator();

Implements

IEnumerable`1.GetEnumerator

See Also

Filters Class | Aspose.Tasks Namespace


Filters.Remove Method

public bool Remove(
Filter item
);

Implements

ICollection`1.Remove

See Also

Filters Class | Aspose.Tasks Namespace


Filters.ToList Method

Converts a filter collection to a list of Filter objects.

public List<Filter> ToList();

Return Value

Generic list of Filter objects.

See Also

Filters Class | Aspose.Tasks Namespace


GanttBarSize Enumeration

Specifies the height of a bar in points.

public enum GanttBarSize

Members

Member Name | Description | Value
BarSize6 | Bar size 6 points. | 0
BarSize8 | Bar size 8 points. | 1
BarSize10 | Bar size 10 points. | 2
BarSize12 | Bar size 12 points. | 3
BarSize14 | Bar size 14 points. | 4
BarSize18 | Bar size 18 points. | 5
BarSize24 | Bar size 24 points. | 6

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


GanttChartView Class

Represents a GanttChart view.

For a list of all members of this type, see GanttChartView Members.

System.Object
Aspose.Tasks.View
Aspose.Tasks.GanttChartView

public class GanttChartView : View

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

GanttChartView Members | Aspose.Tasks Namespace


GanttChartView Members

GanttChartView overview

Public Instance Constructors

GanttChartView Constructor Default constructor.

Public Instance Properties

AutoFilters | Gets a list of auto filters of a Gantt Chart view.
BarRounding | True if bars round to the nearest day. The default value is True.
BarSize | Specifies the height, in points, of the Gantt bars in the Gantt Chart.
BarStyles | List of gantt bar styles of the Gantt Chart view. GanttBarStyle.
BottomTimescaleTier | Gets or sets the bottom timescale tier of the Gantt Chart view. TimescaleTier.
Filter (inherited from View) | Gets or sets a Filter object representing the filter used in a single view. Read/write Filter.
Gridlines | List of Gridlines of the Gantt Chart view.
Group (inherited from View) | Gets or sets a Group object representing the group of the single view. Read/write Group.
HideRollupBarsWhenSummaryExpanded | True if rollup bars will be hidden when expanding summary task.
HighlightFilter (inherited from View) | True if Microsoft Project highlights the filter for a single view. Read/write Boolean.
Index (inherited from View) | Gets the index of a View object in the Views containing object. Read-only Int32.
MiddleTimescaleTier | Gets or sets the middle timescale tier of the Gantt Chart view. TimescaleTier.
Name (inherited from View) | Gets the name of a View object. Read/write String.
ParentProject (inherited from View) | Gets the parent of the View object. Read-only Project.
ProgressLines | Gets or sets progress lines for the Gantt Chart view. ProgressLines.
RollUpGanttBars | Specifies the rollup behavior of bars on the Gantt Chart.
Screen (inherited from View) | Gets the screen type for the single view. Read-only ViewScreen.
ShowBarSplits | Shows or hides task splits on the Gantt Chart.
ShowDrawings | Shows or hides drawings on the Gantt Chart.
ShowInMenu (inherited from View) | True if Project shows the single view name in the View or the Other Views drop-down lists in the Ribbon. Read/write Boolean.
Table (inherited from View) | Gets or sets a Table object representing the table of the single view. Read/write Table.
TableTextStyles | List of table text styles of the Gantt Chart view. TableTextStyle.
TextStyles | List of TextStyle of the Gantt Chart view.
TopTimescaleTier | Gets or sets the top timescale tier of the Gantt Chart view. TimescaleTier.
Type (inherited from View) | Gets the type of item in the single view, such as tasks or resources. Read-only ItemType.
Uid (inherited from View) | The unique identifier of a view.

Public Instance Methods

Equals (inherited from View) | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GanttChartView Class | Aspose.Tasks Namespace


GanttChartView Constructor

Default constructor.

public GanttChartView();

See Also

GanttChartView Class | Aspose.Tasks Namespace


GanttChartView Properties

The properties of the GanttChartView class are listed below. For a complete list of GanttChartView class members, see the GanttChartView Members topic.

Public Instance Properties

AutoFilters | Gets a list of auto filters of a Gantt Chart view.
BarRounding | True if bars round to the nearest day. The default value is True.
BarSize | Specifies the height, in points, of the Gantt bars in the Gantt Chart.
BarStyles | List of gantt bar styles of the Gantt Chart view. GanttBarStyle.
BottomTimescaleTier | Gets or sets the bottom timescale tier of the Gantt Chart view. TimescaleTier.
Filter (inherited from View) | Gets or sets a Filter object representing the filter used in a single view. Read/write Filter.
Gridlines | List of Gridlines of the Gantt Chart view.
Group (inherited from View) | Gets or sets a Group object representing the group of the single view. Read/write Group.
HideRollupBarsWhenSummaryExpanded | True if rollup bars will be hidden when expanding summary task.
HighlightFilter (inherited from View) | True if Microsoft Project highlights the filter for a single view. Read/write Boolean.
Index (inherited from View) | Gets the index of a View object in the Views containing object. Read-only Int32.
MiddleTimescaleTier | Gets or sets the middle timescale tier of the Gantt Chart view. TimescaleTier.
Name (inherited from View) | Gets the name of a View object. Read/write String.
ParentProject (inherited from View) | Gets the parent of the View object. Read-only Project.
ProgressLines | Gets or sets progress lines for the Gantt Chart view. ProgressLines.
RollUpGanttBars | Specifies the rollup behavior of bars on the Gantt Chart.
Screen (inherited from View) | Gets the screen type for the single view. Read-only ViewScreen.
ShowBarSplits | Shows or hides task splits on the Gantt Chart.
ShowDrawings | Shows or hides drawings on the Gantt Chart.
ShowInMenu (inherited from View) | True if Project shows the single view name in the View or the Other Views drop-down lists in the Ribbon. Read/write Boolean.
Table (inherited from View) | Gets or sets a Table object representing the table of the single view. Read/write Table.
TableTextStyles | List of table text styles of the Gantt Chart view. TableTextStyle.
TextStyles | List of TextStyle of the Gantt Chart view.
TopTimescaleTier | Gets or sets the top timescale tier of the Gantt Chart view. TimescaleTier.
Type (inherited from View) | Gets the type of item in the single view, such as tasks or resources. Read-only ItemType.
Uid (inherited from View) | The unique identifier of a view.

See Also

GanttChartView Class | Aspose.Tasks Namespace


AutoFilters Property

GanttChartView.AutoFilters Property

Gets a list of auto filters of a Gantt Chart view.

public Filters AutoFilters {get;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


BarRounding Property

GanttChartView.BarRounding Property

True if bars round to the nearest day. The default value is True.

public bool BarRounding {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


BarSize Property

GanttChartView.BarSize Property

Specifies the height, in points, of the Gantt bars in the Gantt Chart.

public GanttBarSize BarSize {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


BarStyles Property

GanttChartView.BarStyles Property

List of gantt bar styles of the Gantt Chart view. GanttBarStyle.

public GanttBarStyle} BarStyles {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


BottomTimescaleTier Property

GanttChartView.BottomTimescaleTier Property

Gets or sets the bottom timescale tier of the Gantt Chart view. TimescaleTier.

public TimescaleTier BottomTimescaleTier {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


Gridlines Property

GanttChartView.Gridlines Property

List of Gridlines of the Gantt Chart view.

public Gridlines} Gridlines {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


HideRollupBarsWhenSummaryExpanded Property

GanttChartView.HideRollupBarsWhenSummaryExpanded Property

True if rollup bars will be hidden when expanding summary task.

public bool HideRollupBarsWhenSummaryExpanded {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


MiddleTimescaleTier Property

GanttChartView.MiddleTimescaleTier Property

Gets or sets the middle timescale tier of the Gantt Chart view. TimescaleTier.

public TimescaleTier MiddleTimescaleTier {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


ProgressLines Property

GanttChartView.ProgressLines Property

Gets or sets progress lines for the Gantt Chart view. ProgressLines.

public ProgressLines ProgressLines {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


RollUpGanttBars Property

GanttChartView.RollUpGanttBars Property

Specifies the rollup behavior of bars on the Gantt Chart.

public bool RollUpGanttBars {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


ShowBarSplits Property

GanttChartView.ShowBarSplits Property

Shows or hides task splits on the Gantt Chart.

public bool ShowBarSplits {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


ShowDrawings Property

GanttChartView.ShowDrawings Property

Shows or hides drawings on the Gantt Chart.

public bool ShowDrawings {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


TableTextStyles Property

GanttChartView.TableTextStyles Property

List of table text styles of the Gantt Chart view. TableTextStyle.

public TableTextStyle} TableTextStyles {get;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


TextStyles Property

GanttChartView.TextStyles Property

List of TextStyle of the Gantt Chart view.

public TextStyle} TextStyles {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


TopTimescaleTier Property

GanttChartView.TopTimescaleTier Property

Gets or sets the top timescale tier of the Gantt Chart view. TimescaleTier.

public TimescaleTier TopTimescaleTier {get; set;}

See Also

GanttChartView Class | Aspose.Tasks Namespace


Group Class

Represents a group definition. A Group object is a member of the ResourceGroups collection or the TaskGroups collection.

For a list of all members of this type, see Group Members.

System.Object
Aspose.Tasks.Group

public class Group

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Group Members | Aspose.Tasks Namespace


Group Members

Group overview

Public Instance Constructors

Group Constructor Default constructor for Group object.

Public Instance Properties

GroupCriteria | Gets or sets a GroupCriteria collection representing the fields in a group definition. Read/write GroupCriteria.
Index | Gets the index of a Group object in the Groups containing object. Read-only Int32.
Name | Gets the name of a Group object. Read/write String.
ParentProject | Gets the parent of the Group object. Read-only Project.
ShowSummary | True if summary rows are displayed for the group. Read/write Boolean.
Uid | The unique identifier of a group.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Group Class | Aspose.Tasks Namespace


Group Constructor

Default constructor for Group object.

public Group();

See Also

Group Class | Aspose.Tasks Namespace


Group Properties

The properties of the Group class are listed below. For a complete list of Group class members, see the Group Members topic.

Public Instance Properties

GroupCriteria | Gets or sets a GroupCriteria collection representing the fields in a group definition. Read/write GroupCriteria.
Index | Gets the index of a Group object in the Groups containing object. Read-only Int32.
Name | Gets the name of a Group object. Read/write String.
ParentProject | Gets the parent of the Group object. Read-only Project.
ShowSummary | True if summary rows are displayed for the group. Read/write Boolean.
Uid | The unique identifier of a group.

See Also

Group Class | Aspose.Tasks Namespace


GroupCriteria Property

Group.GroupCriteria Property

Gets or sets a GroupCriteria collection representing the fields in a group definition. Read/write GroupCriteria.

public GroupCriteria GroupCriteria {get; set;}

See Also

Group Class | Aspose.Tasks Namespace


Index Property

Group.Index Property

Gets the index of a Group object in the Groups containing object. Read-only Int32.

public int Index {get; set;}

See Also

Group Class | Aspose.Tasks Namespace


Name Property

Group.Name Property

Gets the name of a Group object. Read/write String.

public string Name {get; set;}

See Also

Group Class | Aspose.Tasks Namespace


ParentProject Property

Group.ParentProject Property

Gets the parent of the Group object. Read-only Project.

public Project ParentProject {get; set;}

See Also

Group Class | Aspose.Tasks Namespace


ShowSummary Property

Group.ShowSummary Property

True if summary rows are displayed for the group. Read/write Boolean.

public bool ShowSummary {get; set;}

See Also

Group Class | Aspose.Tasks Namespace


Uid Property

Group.Uid Property

The unique identifier of a group.

public int Uid {get; set;}

See Also

Group Class | Aspose.Tasks Namespace


GroupCriteria Class

Contains a collection of GroupCriterion objects. Implements ICollection<GroupCriterion> interface.

For a list of all members of this type, see GroupCriteria Members.

System.Object
Aspose.Tasks.GroupCriteria

public class GroupCriteria : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

GroupCriteria Members | Aspose.Tasks Namespace


GroupCriteria Members

GroupCriteria overview

Public Instance Properties

Count |
IsReadOnly |
ParentGroup | Gets the parent of the GroupCriterion object. Read-only Group.

Public Instance Methods

Add |
Clear |
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToList | Converts a GroupCriterion collection to a list of GroupCriterion objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GroupCriteria Class | Aspose.Tasks Namespace


GroupCriteria Properties

The properties of the GroupCriteria class are listed below. For a complete list of GroupCriteria class members, see the GroupCriteria Members topic.

Public Instance Properties

Count |
IsReadOnly |
ParentGroup | Gets the parent of the GroupCriterion object. Read-only Group.

See Also

GroupCriteria Class | Aspose.Tasks Namespace


Count Property

GroupCriteria.Count Property

public int Count {get;}

Implements

ICollection`1.Count

See Also

GroupCriteria Class | Aspose.Tasks Namespace


IsReadOnly Property

GroupCriteria.IsReadOnly Property

public bool IsReadOnly {get;}

Implements

ICollection`1.IsReadOnly

See Also

GroupCriteria Class | Aspose.Tasks Namespace


ParentGroup Property

GroupCriteria.ParentGroup Property

Gets the parent of the GroupCriterion object. Read-only Group.

public Group ParentGroup {get; set;}

See Also

GroupCriteria Class | Aspose.Tasks Namespace


GroupCriteria Methods

The methods of the GroupCriteria class are listed below. For a complete list of GroupCriteria class members, see the GroupCriteria Members topic.

Public Instance Methods

Add |
Clear |
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToList | Converts a GroupCriterion collection to a list of GroupCriterion objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GroupCriteria Class | Aspose.Tasks Namespace


GroupCriteria.Add Method

public void Add(
GroupCriterion item
);

Implements

ICollection`1.Add

See Also

GroupCriteria Class | Aspose.Tasks Namespace


GroupCriteria.Clear Method

public void Clear();

Implements

ICollection`1.Clear

See Also

GroupCriteria Class | Aspose.Tasks Namespace


GroupCriteria.Contains Method

public bool Contains(
GroupCriterion item
);

Implements

ICollection`1.Contains

See Also

GroupCriteria Class | Aspose.Tasks Namespace


GroupCriteria.CopyTo Method

public void CopyTo(
GroupCriterion[] array,
int arrayIndex
);

Implements

ICollection`1.CopyTo

See Also

GroupCriteria Class | Aspose.Tasks Namespace


GroupCriteria.GetEnumerator Method

public IEnumerator<GroupCriterion> GetEnumerator();

Implements

IEnumerable`1.GetEnumerator

See Also

GroupCriteria Class | Aspose.Tasks Namespace


GroupCriteria.Remove Method

public bool Remove(
GroupCriterion item
);

Implements

ICollection`1.Remove

See Also

GroupCriteria Class | Aspose.Tasks Namespace


GroupCriteria.ToList Method

Converts a GroupCriterion collection to a list of GroupCriterion objects.

public List<GroupCriterion> ToList();

Return Value

Generic list of GroupCriterion objects.

See Also

GroupCriteria Class | Aspose.Tasks Namespace


GroupCriterion Class

Represents a criterion in a group definition. The GroupCriterion object is a member of the GroupCriteria collection.

For a list of all members of this type, see GroupCriterion Members.

System.Object
Aspose.Tasks.GroupCriterion

public class GroupCriterion

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

GroupCriterion Members | Aspose.Tasks Namespace


GroupCriterion Members

GroupCriterion overview

Public Instance Constructors

GroupCriterion Constructor Initializes a new instance of the GroupCriterion class.

Public Instance Properties

Ascending | True if a field used as a criterion in a group definition is sorted in ascending order. False if the field is sorted in descending order. Read/write Boolean.
CellColor | Gets or sets the color of the cell background for a field used as a criterion in a group definition. Read/write Color.
Field | Gets or sets the field being grouped by. Read/write Field.
Font | Gets or sets the font for a criterion in a group definition. Read/Write Font.
FontColor | Gets or sets the color of the font for a field used as a criterion in a group definition. Read/write Color.
GroupInterval | Gets or sets the interval for a field used as a criterion in a group definition. Read/write Object.
GroupOn | Gets or sets the type of grouping for a field used as a criterion in a group definition. Read/write GroupOn.
Index | Gets the index of a GroupCriterion object in the containing GroupCriteria collection. Read-only Int32.
ParentGroup | Gets the parent of the GroupCriterion object. Read-only Group.
Pattern | Gets or sets the pattern of the cell for a field used as a criterion in a group definition. Read/write BackgroundPattern.
StartAt | Gets or sets the start of the intervals for a field used as a criterion in a group definition. Read/write Object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GroupCriterion Class | Aspose.Tasks Namespace


GroupCriterion Constructor

Initializes a new instance of the GroupCriterion class.

public GroupCriterion();

See Also

GroupCriterion Class | Aspose.Tasks Namespace


GroupCriterion Properties

The properties of the GroupCriterion class are listed below. For a complete list of GroupCriterion class members, see the GroupCriterion Members topic.

Public Instance Properties

Ascending | True if a field used as a criterion in a group definition is sorted in ascending order. False if the field is sorted in descending order. Read/write Boolean.
CellColor | Gets or sets the color of the cell background for a field used as a criterion in a group definition. Read/write Color.
Field | Gets or sets the field being grouped by. Read/write Field.
Font | Gets or sets the font for a criterion in a group definition. Read/Write Font.
FontColor | Gets or sets the color of the font for a field used as a criterion in a group definition. Read/write Color.
GroupInterval | Gets or sets the interval for a field used as a criterion in a group definition. Read/write Object.
GroupOn | Gets or sets the type of grouping for a field used as a criterion in a group definition. Read/write GroupOn.
Index | Gets the index of a GroupCriterion object in the containing GroupCriteria collection. Read-only Int32.
ParentGroup | Gets the parent of the GroupCriterion object. Read-only Group.
Pattern | Gets or sets the pattern of the cell for a field used as a criterion in a group definition. Read/write BackgroundPattern.
StartAt | Gets or sets the start of the intervals for a field used as a criterion in a group definition. Read/write Object.

See Also

GroupCriterion Class | Aspose.Tasks Namespace


Ascending Property

GroupCriterion.Ascending Property

True if a field used as a criterion in a group definition is sorted in ascending order. False if the field is sorted in descending order. Read/write Boolean.

public bool Ascending {get; set;}

See Also

GroupCriterion Class | Aspose.Tasks Namespace


CellColor Property

GroupCriterion.CellColor Property

Gets or sets the color of the cell background for a field used as a criterion in a group definition. Read/write Color.

public Color CellColor {get; set;}

See Also

GroupCriterion Class | Aspose.Tasks Namespace


Field Property

GroupCriterion.Field Property

Gets or sets the field being grouped by. Read/write Field.

public Field Field {get; set;}

See Also

GroupCriterion Class | Aspose.Tasks Namespace


Font Property

GroupCriterion.Font Property

Gets or sets the font for a criterion in a group definition. Read/Write Font.

public Font Font {get; set;}

See Also

GroupCriterion Class | Aspose.Tasks Namespace


FontColor Property

GroupCriterion.FontColor Property

Gets or sets the color of the font for a field used as a criterion in a group definition. Read/write Color.

public Color FontColor {get; set;}

See Also

GroupCriterion Class | Aspose.Tasks Namespace


GroupInterval Property

GroupCriterion.GroupInterval Property

Gets or sets the interval for a field used as a criterion in a group definition. Read/write Object.

public object GroupInterval {get; set;}

See Also

GroupCriterion Class | Aspose.Tasks Namespace


GroupOn Property

GroupCriterion.GroupOn Property

Gets or sets the type of grouping for a field used as a criterion in a group definition. Read/write GroupOn.

public GroupOn GroupOn {get; set;}

See Also

GroupCriterion Class | Aspose.Tasks Namespace


Index Property

GroupCriterion.Index Property

Gets the index of a GroupCriterion object in the containing GroupCriteria collection. Read-only Int32.

public int Index {get; set;}

See Also

GroupCriterion Class | Aspose.Tasks Namespace


ParentGroup Property

GroupCriterion.ParentGroup Property

Gets the parent of the GroupCriterion object. Read-only Group.

public Group ParentGroup {get; set;}

See Also

GroupCriterion Class | Aspose.Tasks Namespace


Pattern Property

GroupCriterion.Pattern Property

Gets or sets the pattern of the cell for a field used as a criterion in a group definition. Read/write BackgroundPattern.

public BackgroundPattern Pattern {get; set;}

See Also

GroupCriterion Class | Aspose.Tasks Namespace


StartAt Property

GroupCriterion.StartAt Property

Gets or sets the start of the intervals for a field used as a criterion in a group definition. Read/write Object.

public object StartAt {get; set;}

See Also

GroupCriterion Class | Aspose.Tasks Namespace


GroupOn Enumeration

Specifes the type of grouping.

public enum GroupOn

Members

Member Name | Description | Value
DateDay | Group on date by day. | 13
DateEachValue | Group on date for each value. | 10
DateHour | Group on date by hour. | 12
DateMinute | Group on date by minute. | 11
DateMonth | Group on date by month. | 16
DateQtr | Group on date by quarter. | 17
DateThirdOfMonth | Group on date by each third of a month. | 15
DateWeek | Group on date by week. | 14
DateYear | Group on date by year. | 18
DurationDays | Group on duration by days. | 23
DurationEachValue | Group on duration for each value. | 20
DurationHours | Group on duration by hours. | 22
DurationMinutes | Group on duration by minutes. | 21
DurationMonths | Group on duration by months. | 25
DurationWeeks | Group on duration by weeks. | 24
EachValue | Group by each value. | 0
Interval | Group by the interval. | 1
OutlineEachValue | Group on each outline value. | 30
OutlineLevel | Group on the outline level. | 31
Pct1_10 | Group by 10 percent completion increments. | 45
Pct1_25 | Group by 25 percent completionincrements. | 44
Pct1_50 | Group by 50 percent completion increments. | 43
Pct1_99 | Group by 99 percent completion. | 42
PctEachValue | Group on percent of each value. | 40
PctInterval | Group on the interval percent. | 41
TextEachValue | Group on each text value. | 50
TextPrefix | Group on the text prefix. | 51

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


Groups Class

Contains a list of Group objects. Implements ICollection<Group> interface.

For a list of all members of this type, see Groups Members.

System.Object
Aspose.Tasks.Groups

public class Groups : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Groups Members | Aspose.Tasks Namespace


Groups Members

Groups overview

Public Instance Properties

Count |
IsReadOnly |
ParentProject | Gets the parent of the Group object. Read-only Project.

Public Instance Methods

Add |
Clear |
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToList | Converts a group collection to a list of Group objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Groups Class | Aspose.Tasks Namespace


Groups Properties

The properties of the Groups class are listed below. For a complete list of Groups class members, see the Groups Members topic.

Public Instance Properties

Count |
IsReadOnly |
ParentProject | Gets the parent of the Group object. Read-only Project.

See Also

Groups Class | Aspose.Tasks Namespace


Count Property

Groups.Count Property

public int Count {get;}

Implements

ICollection`1.Count

See Also

Groups Class | Aspose.Tasks Namespace


IsReadOnly Property

Groups.IsReadOnly Property

public bool IsReadOnly {get;}

Implements

ICollection`1.IsReadOnly

See Also

Groups Class | Aspose.Tasks Namespace


ParentProject Property

Groups.ParentProject Property

Gets the parent of the Group object. Read-only Project.

public Project ParentProject {get; set;}

See Also

Groups Class | Aspose.Tasks Namespace


Groups Methods

The methods of the Groups class are listed below. For a complete list of Groups class members, see the Groups Members topic.

Public Instance Methods

Add |
Clear |
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToList | Converts a group collection to a list of Group objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Groups Class | Aspose.Tasks Namespace


Groups.Add Method

public void Add(
Group item
);

Implements

ICollection`1.Add

See Also

Groups Class | Aspose.Tasks Namespace


Groups.Clear Method

public void Clear();

Implements

ICollection`1.Clear

See Also

Groups Class | Aspose.Tasks Namespace


Groups.Contains Method

public bool Contains(
Group item
);

Implements

ICollection`1.Contains

See Also

Groups Class | Aspose.Tasks Namespace


Groups.CopyTo Method

public void CopyTo(
Group[] array,
int arrayIndex
);

Implements

ICollection`1.CopyTo

See Also

Groups Class | Aspose.Tasks Namespace


Groups.GetEnumerator Method

public IEnumerator<Group> GetEnumerator();

Implements

IEnumerable`1.GetEnumerator

See Also

Groups Class | Aspose.Tasks Namespace


Groups.Remove Method

public bool Remove(
Group item
);

Implements

ICollection`1.Remove

See Also

Groups Class | Aspose.Tasks Namespace


Groups.ToList Method

Converts a group collection to a list of Group objects.

public List<Group> ToList();

Return Value

Generic list of Group objects.

See Also

Groups Class | Aspose.Tasks Namespace


ItemType Enumeration

Specifies the type of an item.

public enum ItemType

Members

Member Name | Description | Value
OtherItem | Other item. | 2
ResourceItem | Resource item. | 1
TaskItem | Task item. | 0

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


License Class

Provides methods to license the component.

For a list of all members of this type, see License Members.

System.Object
Aspose.Tasks.License

public class License

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As license = New license
License.SetLicense("MyLicense.lic")

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

License Members | Aspose.Tasks Namespace


License Members

License overview

Public Instance Constructors

License Constructor Initializes a new instance of this class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetLicense | Overloaded. Licenses the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

License Class | Aspose.Tasks Namespace


License Constructor

Initializes a new instance of this class.

public License();

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As license = New license
License.SetLicense("MyLicense.lic")

See Also

License Class | Aspose.Tasks Namespace


License Methods

The methods of the License class are listed below. For a complete list of License class members, see the License Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetLicense | Overloaded. Licenses the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

License Class | Aspose.Tasks Namespace


SetLicense Method

License.SetLicense Method

Licenses the component.

Overload List

Licenses the component.

public void SetLicense(Stream);

Licenses the component.

public void SetLicense(string);

See Also

License Class | Aspose.Tasks Namespace


License.SetLicense Method (Stream)

Licenses the component.

public void SetLicense(
Stream stream
);

Parameters

stream
A stream that contains the license.

Remarks

Use this method to load a license from a stream.

Example

[C#]

License license = new License();
license.SetLicense(myStream);

[Visual Basic]

Dim license as License = new License
license.SetLicense(myStream)

See Also

License Class | Aspose.Tasks Namespace | License.SetLicense Overload List


License.SetLicense Method (String)

Licenses the component.

public void SetLicense(
string licenseName
);

Parameters

licenseName
Can be a full or short file name or name of an embedded resource. Use an empty string to switch to evaluation mode.

Remarks

Tries to find the license in the following locations:

1. Explicit path.

2. The folder of the component assembly.

3. The folder of the client's calling assembly.

4. The folder of the entry assembly.

5. An embedded resource in the client's calling assembly.

Note:On the .NET Compact Framework, tries to find the license only in these locations:

1. Explicit path.

2. An embedded resource in the client's calling assembly.

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As License = New License
license.SetLicense("MyLicense.lic")

See Also

License Class | Aspose.Tasks Namespace | License.SetLicense Overload List


MaskType Enumeration

Specifies the type of a mask.

public enum MaskType

Members

Member Name | Description | Value
Null |  | 0
Numbers |  | 1
UpperCaseLetters |  | 2
LowerCaseLetters |  | 3
Characters |  | 4
Val4 |  | 5
Val5 | Lookup for Dates. | 6
Val6 | Lookup for Durations. | 7
Val7 | Lookup for Numbers. | 8
Val8 | Lookup for Flags. | 9
Val9 | Lookup for FinishDate. | 10

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


Month Enumeration

Specifies the month.

public enum Month

Remarks

While exporting into XML the Undefined values will be eliminated from resulting XML.

Members

Member Name | Description | Value
Undefined | The value was not defined in original project file. | -1
January | January | 0
February | February | 1
March | March | 2
April | April | 3
May | May | 4
June | June | 5
July | July | 6
August | August | 7
September | September | 8
October | October | 9
November | November | 10
December | December | 11

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


MonthItemType Enumeration

Specifies the month item for which an exception recurrence is scheduled.

public enum MonthItemType

Members

Member Name | Description | Value
Undefined | Undefined | -1
Day | Day | 0
Weekday | Weekday | 1
WeekendDay | WeekendDay | 2
Sunday | Sunday | 3
Monday | Monday | 4
Tuesday | Tuesday | 5
Wednesday | Wednesday | 6
Thursday | Thursday | 7
Friday | Friday | 8
Saturday | Saturday | 9

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


MonthPosition Enumeration

Specifies the position of a month item within a month.

public enum MonthPosition

Members

Member Name | Description | Value
Undefined | Undefined | -1
First | First position | 0
Second | Second position | 1
Third | Third position | 2
Fourth | Fourth position | 3
Last | Last position | 4

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


OutlineCode Class

Represents a value of an outline code.

For a list of all members of this type, see OutlineCode Members.

System.Object
Aspose.Tasks.OutlineCode

public class OutlineCode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Two pieces of data are necessary - a pointer to the outline code table that is specified by the FieldId, and the value that is specified either by the ValueId or ValueGuid pointer to the value list.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

OutlineCode Members | Aspose.Tasks Namespace


OutlineCode Members

OutlineCode overview

Public Instance Constructors

OutlineCode Constructor Initializes a new instance of the OutlineCode class.

Public Instance Properties

FieldId | The number value of the project Id (Pid) custom field. Read/write String.
ValueGuid | The Guid of the value in the value list. The ValueGuid matches the FieldGuid in the value list. Read/write Int32.
ValueId | The Id in the value list associated with the definition in the outline code collection. Read/write Int32.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OutlineCode Class | Aspose.Tasks Namespace


OutlineCode Constructor

Initializes a new instance of the OutlineCode class.

public OutlineCode();

See Also

OutlineCode Class | Aspose.Tasks Namespace


OutlineCode Properties

The properties of the OutlineCode class are listed below. For a complete list of OutlineCode class members, see the OutlineCode Members topic.

Public Instance Properties

FieldId | The number value of the project Id (Pid) custom field. Read/write String.
ValueGuid | The Guid of the value in the value list. The ValueGuid matches the FieldGuid in the value list. Read/write Int32.
ValueId | The Id in the value list associated with the definition in the outline code collection. Read/write Int32.

See Also

OutlineCode Class | Aspose.Tasks Namespace


FieldId Property

OutlineCode.FieldId Property

The number value of the project Id (Pid) custom field. Read/write String.

public string FieldId {get; set;}

See Also

OutlineCode Class | Aspose.Tasks Namespace


ValueGuid Property

OutlineCode.ValueGuid Property

The Guid of the value in the value list. The ValueGuid matches the FieldGuid in the value list. Read/write Int32.

public string ValueGuid {get; set;}

See Also

OutlineCode Class | Aspose.Tasks Namespace


ValueId Property

OutlineCode.ValueId Property

The Id in the value list associated with the definition in the outline code collection. Read/write Int32.

public int ValueId {get; set;}

See Also

OutlineCode Class | Aspose.Tasks Namespace


OutlineCodeDefinition Class

Represents an outline code definition.

For a list of all members of this type, see OutlineCodeDefinition Members.

System.Object
Aspose.Tasks.OutlineCodeDefinition

public class OutlineCodeDefinition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

OutlineCodeDefinition Members | Aspose.Tasks Namespace


OutlineCodeDefinition Members

OutlineCodeDefinition overview

Public Instance Constructors

OutlineCodeDefinition Constructor Initializes a new instance of the OutlineCodeDefinition class.

Public Instance Properties

Alias | The alias of a custom outline code. Read/write String.
AllLevelsRequired | Determines whether the new codes must have all levels. Not available for Enterprise Codes. Read/write Boolean.
Enterprise | Determines whether a custom outline code is an enterprise custom outline code. Read/write Boolean.
EnterpriseOutlineCodeAlias | The reference to another custom field for which this outline code definition is an alias. Read/write Int32.
FieldId | Corresponds to the field number of an outline code. Read/write String.
FieldName | The name of a custom outline code. Read/write String.
Guid | The Guid of an outline code. Read/write String.
LeafOnly | Determines whether the values specified in this outline code field must be leaf values. Read/write Boolean.
Masks | Returns List<OutlineMask> Masks. The table of entries that define the outline code mask. Read/write List of OutlineMask.
OnlyTableValuesAllowed | Determines whether the values specified must come from values table. Read/write Boolean.
PhoneticAlias | The phonetic pronunciation of the alias of the custom outline code. Read/write String.
ResourceSubstitutionEnabled | Determines whether the custom outline code can be used by the Resource Substitution Wizard in Microsoft Project. Read/write Boolean.
ShowIndent | Determines whether the indents of this outline code must be shown. Read/write Boolean.
Values | Returns List<OutlineValue> Values. The values of the table associated with this outline code. Read/write List of OutlineValue.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


OutlineCodeDefinition Constructor

Initializes a new instance of the OutlineCodeDefinition class.

public OutlineCodeDefinition();

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


OutlineCodeDefinition Properties

The properties of the OutlineCodeDefinition class are listed below. For a complete list of OutlineCodeDefinition class members, see the OutlineCodeDefinition Members topic.

Public Instance Properties

Alias | The alias of a custom outline code. Read/write String.
AllLevelsRequired | Determines whether the new codes must have all levels. Not available for Enterprise Codes. Read/write Boolean.
Enterprise | Determines whether a custom outline code is an enterprise custom outline code. Read/write Boolean.
EnterpriseOutlineCodeAlias | The reference to another custom field for which this outline code definition is an alias. Read/write Int32.
FieldId | Corresponds to the field number of an outline code. Read/write String.
FieldName | The name of a custom outline code. Read/write String.
Guid | The Guid of an outline code. Read/write String.
LeafOnly | Determines whether the values specified in this outline code field must be leaf values. Read/write Boolean.
Masks | Returns List<OutlineMask> Masks. The table of entries that define the outline code mask. Read/write List of OutlineMask.
OnlyTableValuesAllowed | Determines whether the values specified must come from values table. Read/write Boolean.
PhoneticAlias | The phonetic pronunciation of the alias of the custom outline code. Read/write String.
ResourceSubstitutionEnabled | Determines whether the custom outline code can be used by the Resource Substitution Wizard in Microsoft Project. Read/write Boolean.
ShowIndent | Determines whether the indents of this outline code must be shown. Read/write Boolean.
Values | Returns List<OutlineValue> Values. The values of the table associated with this outline code. Read/write List of OutlineValue.

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


Alias Property

OutlineCodeDefinition.Alias Property

The alias of a custom outline code. Read/write String.

public string Alias {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


AllLevelsRequired Property

OutlineCodeDefinition.AllLevelsRequired Property

Determines whether the new codes must have all levels. Not available for Enterprise Codes. Read/write Boolean.

public bool AllLevelsRequired {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


Enterprise Property

OutlineCodeDefinition.Enterprise Property

Determines whether a custom outline code is an enterprise custom outline code. Read/write Boolean.

public bool Enterprise {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


EnterpriseOutlineCodeAlias Property

OutlineCodeDefinition.EnterpriseOutlineCodeAlias Property

The reference to another custom field for which this outline code definition is an alias. Read/write Int32.

public int EnterpriseOutlineCodeAlias {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


FieldId Property

OutlineCodeDefinition.FieldId Property

Corresponds to the field number of an outline code. Read/write String.

public string FieldId {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


FieldName Property

OutlineCodeDefinition.FieldName Property

The name of a custom outline code. Read/write String.

public string FieldName {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


Guid Property

OutlineCodeDefinition.Guid Property

The Guid of an outline code. Read/write String.

public string Guid {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


LeafOnly Property

OutlineCodeDefinition.LeafOnly Property

Determines whether the values specified in this outline code field must be leaf values. Read/write Boolean.

public bool LeafOnly {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


Masks Property

OutlineCodeDefinition.Masks Property

Returns List<OutlineMask> Masks. The table of entries that define the outline code mask. Read/write List of OutlineMask.

public OutlineMask} Masks {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


OnlyTableValuesAllowed Property

OutlineCodeDefinition.OnlyTableValuesAllowed Property

Determines whether the values specified must come from values table. Read/write Boolean.

public bool OnlyTableValuesAllowed {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


PhoneticAlias Property

OutlineCodeDefinition.PhoneticAlias Property

The phonetic pronunciation of the alias of the custom outline code. Read/write String.

public string PhoneticAlias {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


ResourceSubstitutionEnabled Property

OutlineCodeDefinition.ResourceSubstitutionEnabled Property

Determines whether the custom outline code can be used by the Resource Substitution Wizard in Microsoft Project. Read/write Boolean.

public bool ResourceSubstitutionEnabled {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


ShowIndent Property

OutlineCodeDefinition.ShowIndent Property

Determines whether the indents of this outline code must be shown. Read/write Boolean.

public bool ShowIndent {get; set;}

Remarks

This is new for MS Project 2010 property.

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


Values Property

OutlineCodeDefinition.Values Property

Returns List<OutlineValue> Values. The values of the table associated with this outline code. Read/write List of OutlineValue.

public OutlineValue} Values {get; set;}

See Also

OutlineCodeDefinition Class | Aspose.Tasks Namespace


OutlineMask Class

Represents four elements of a mask which defines an outline code format.

For a list of all members of this type, see OutlineMask Members.

System.Object
Aspose.Tasks.OutlineMask

public class OutlineMask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

OutlineMask Members | Aspose.Tasks Namespace


OutlineMask Members

OutlineMask overview

Public Instance Constructors

OutlineMask Constructor Default constructor.

Public Instance Properties

Length | The maximum length (in characters) of the outline code values. 0 if length is not defined. Read/write Int32.
Level | The level of a mask. Read/write Int32.
Separator | The separator of code values. Read/write String.
Type | The type of a mask. Read/write MaskType.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OutlineMask Class | Aspose.Tasks Namespace


OutlineMask Constructor

Default constructor.

public OutlineMask();

See Also

OutlineMask Class | Aspose.Tasks Namespace


OutlineMask Properties

The properties of the OutlineMask class are listed below. For a complete list of OutlineMask class members, see the OutlineMask Members topic.

Public Instance Properties

Length | The maximum length (in characters) of the outline code values. 0 if length is not defined. Read/write Int32.
Level | The level of a mask. Read/write Int32.
Separator | The separator of code values. Read/write String.
Type | The type of a mask. Read/write MaskType.

See Also

OutlineMask Class | Aspose.Tasks Namespace


Length Property

OutlineMask.Length Property

The maximum length (in characters) of the outline code values. 0 if length is not defined. Read/write Int32.

public int Length {get; set;}

See Also

OutlineMask Class | Aspose.Tasks Namespace


Level Property

OutlineMask.Level Property

The level of a mask. Read/write Int32.

public int Level {get; set;}

See Also

OutlineMask Class | Aspose.Tasks Namespace


Separator Property

OutlineMask.Separator Property

The separator of code values. Read/write String.

public string Separator {get; set;}

See Also

OutlineMask Class | Aspose.Tasks Namespace


Type Property

OutlineMask.Type Property

The type of a mask. Read/write MaskType.

public MaskType Type {get; set;}

See Also

OutlineMask Class | Aspose.Tasks Namespace


OutlineValue Class

Represents an outline value.

For a list of all members of this type, see OutlineValue Members.

System.Object
Aspose.Tasks.OutlineValue

public class OutlineValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

OutlineValue Members | Aspose.Tasks Namespace


OutlineValue Members

OutlineValue overview

Public Instance Constructors

OutlineValue Constructor Initializes a new instance of the OutlineValue class.

Public Instance Properties

Description | The description of an outline value. Read/write String.
FieldGuid | The Guid of an outline code value. Read/write String.
IsCollapsed | Determines whether outline value is collapsed or not.
ParentValueId | The Id of a parent node of an outline code. Read/write Int32.
Type | The outline code type. Read/write OutlineValueType.
Value | The actual value. Read/write String.
ValueId | The unique Id of an outline code value within a project. Read/write Int32.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OutlineValue Class | Aspose.Tasks Namespace


OutlineValue Constructor

Initializes a new instance of the OutlineValue class.

public OutlineValue();

See Also

OutlineValue Class | Aspose.Tasks Namespace


OutlineValue Properties

The properties of the OutlineValue class are listed below. For a complete list of OutlineValue class members, see the OutlineValue Members topic.

Public Instance Properties

Description | The description of an outline value. Read/write String.
FieldGuid | The Guid of an outline code value. Read/write String.
IsCollapsed | Determines whether outline value is collapsed or not.
ParentValueId | The Id of a parent node of an outline code. Read/write Int32.
Type | The outline code type. Read/write OutlineValueType.
Value | The actual value. Read/write String.
ValueId | The unique Id of an outline code value within a project. Read/write Int32.

See Also

OutlineValue Class | Aspose.Tasks Namespace


Description Property

OutlineValue.Description Property

The description of an outline value. Read/write String.

public string Description {get; set;}

See Also

OutlineValue Class | Aspose.Tasks Namespace


FieldGuid Property

OutlineValue.FieldGuid Property

The Guid of an outline code value. Read/write String.

public string FieldGuid {get; set;}

See Also

OutlineValue Class | Aspose.Tasks Namespace


IsCollapsed Property

OutlineValue.IsCollapsed Property

Determines whether outline value is collapsed or not.

public bool IsCollapsed {get; set;}

Remarks

This is new for MS Project 2010 property.

See Also

OutlineValue Class | Aspose.Tasks Namespace


ParentValueId Property

OutlineValue.ParentValueId Property

The Id of a parent node of an outline code. Read/write Int32.

public int ParentValueId {get; set;}

See Also

OutlineValue Class | Aspose.Tasks Namespace


Type Property

OutlineValue.Type Property

The outline code type. Read/write OutlineValueType.

public OutlineValueType Type {get; set;}

See Also

OutlineValue Class | Aspose.Tasks Namespace


Value Property

OutlineValue.Value Property

The actual value. Read/write String.

public string Value {get; set;}

See Also

OutlineValue Class | Aspose.Tasks Namespace


ValueId Property

OutlineValue.ValueId Property

The unique Id of an outline code value within a project. Read/write Int32.

public int ValueId {get; set;}

See Also

OutlineValue Class | Aspose.Tasks Namespace


OutlineValueType Enumeration

Specifies the type of an outline value.

public enum OutlineValueType

Members

Member Name | Description | Value
Null | Null | 0
Date | Date | 1
Duration | Duration | 2
Cost | Cost | 3
Number | Number | 4
Flag | Flag | 5
Text | Text | 6
FinishDate | Finish Date | 7

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


Project Class

Represents a project.

For a list of all members of this type, see Project Members.

System.Object
Aspose.Tasks.Project

public class Project

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

How to create a simple project from scratch.

[C#]
// Create new empty project
Project project = new Project();
project.Name = "project name";
// Create calendars and add it to our project
Calendar cal1 = Calendar.MakeStandardCalendar();
cal1.Uid = 1;
Calendar cal2 = Calendar.MakeStandardCalendar();
cal2.Uid = 2;
project.Calendars.Add(cal1);
project.Calendars.Add(cal2);
// Create 5 tasks
Task task1 = new Task("task1", new TimeSpan(10, 0, 0, 0));
Task task2 = new Task("task2", new TimeSpan(5, 0, 0, 0));
Task task3 = new Task("task3", new TimeSpan(3, 0, 0, 0));
Task task4 = new Task("task4", new TimeSpan(4, 0, 0, 0));
Task task5 = new Task("task5", new TimeSpan(5, 0, 0, 0));
// Add first task as Root all other
// tasks as it’s children tasks
project.RootTask = task1;
task1.Children.Add(task2);
task1.Children.Add(task4);
task1.Children.Add(task5);
task2.Children.Add(task3);
// Tasks 1,2 and 4 will use calendar “Cal1”
task1.Calendar = cal1;
task2.Calendar = cal1;
task4.Calendar = cal1;
// Tasks 3 and 5 will use calendar “Cal2”
task3.Calendar = cal2;
task5.Calendar = cal2;
// Task 5 will be started after the finish of Task 4
project.TaskLinks.Add(new TaskLink(task4, task5, TaskLinkType.FinishToStart));
// Create 2 resources and also add it to the project
Resource res1 = new Resource("resource1");
res1.Uid = 1;
Resource res2 = new Resource("resource2");
res2.Uid = 2;
project.Resources.Add(res1);
project.Resources.Add(res2);
// Resource can use own customized calendars
res1.Calendar = cal2;
res2.Calendar = cal1;
// Now assign resources to tasks
project.ResourceAssignments.Add(new ResourceAssignment(task2, res1));
project.ResourceAssignments.Add(new ResourceAssignment(task4, res2));
project.ResourceAssignments.Add(new ResourceAssignment(task3, res1));
// IDs and UIDs should be recalculated
// after we finished project managing
project.CalcTaskIds();
project.CalcTaskUids();
project.CalcResourceIds();
project.CalcResourceUids();
project.CalcResourceAssignmentIds();
project.CalcResourceAssignmentUids();
project.CalcCalendarUids();
Modify existing project
[C#]
// load existing project
ProjectReader reader = new ProjectReader();
Project project;
using(FileStream rfs = new FileStream("e:/work/temp/testproj.mpp", FileMode.Open))
{
    project = reader.Read(rfs);
}
// find task by ID
Task task = project.GetTaskById(9);
// copy major properties
Task newTask = new Task("My new task", new TimeSpan(4, 0, 0, 0));
newTask.Id = task.Id;
newTask.Uid = task.Uid;
newTask.OutlineLevel = task.OutlineLevel;
newTask.OutlineNumber = task.OutlineNumber;
newTask.Calendar = task.Calendar;
newTask.ParentTask = task.ParentTask;
// sets new duration in working hours
newTask.Duration = new TimeSpan(16, 0, 0);
// remove old task
project.RemoveTask(task);
// adds new task
newTask.ParentTask.Children.Add(newTask);

// write new project
ProjectWriter writer = new ProjectWriter();
using(FileStrem wfs = new FileStream("e:/work/temp/new_project.xml", FileMode.OpenOrCreate))
{
    writer.Write(project, wfs), TasksDataFormat.XML);
}
How to convert from MPP to XML
[C#]
// Open existing project
ProjectReader reader = new ProjectReader();
Project project;
using(FileStream rfs = new FileStream("..\\..\\testdata\\files\\imp12.mpp", FileMode.Open))
{
    project = reader.Read(rfs);
}
XmlWriter writer = new XmlWriter();
using(FileStream wfs = new FileStream("c:\\temp\\out111.xml", FileMode.Create))
{
    writer.Write(project, wfs);
}

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Project Members | Aspose.Tasks Namespace


Project Members

Project overview

Public Instance Constructors

Project Overloaded. Initializes a new instance of the Project class.

Public Instance Properties

ActualsInSync | Determines whether all actual works have been synchronized with the project. Read/write Boolean.
AdminProject | Determines whether a project is an administrative project. Read/write Boolean.
AreEditableActualCosts | Determines whether actual costs are editable. Read/write Boolean.
AreNewTasksEffortDriven | Determines whether new tasks are effort driven. Read/write Boolean.
AreNewTasksEstimated | Determines whether an estimated duration is shown by default. Read/write Boolean.
Author | The author of a project. Read/write String.
AutoAddNewResourcesAndTasks | Determines whether new resources or tasks automatically added to a resource or task pool. Read/write Boolean.
Autolink | Determines whether inserted or moved tasks are autolinked. Read/write Boolean.
BaselineForEarnedValue | The specific baseline used to calculate Variance values.
CalculateAfterEdit | Determines whether to recalculate the project dependent fields automatically.
Calendar | The project calendar. Read/write Calendar.
Calendars | Returns List<Calendar> Calendars. Read/write List of Calendar.
CanSplitsInProgressTasks | Determines whether in-progress tasks can be split. Read/write Boolean.
Category | The category of a project. Read/write String.
Comments | Project's comments. Read/write String.
Company | The company where a project was created. Read/write String.
CreationDate | The date and time when a project was created. Read/write DateTime.
CriticalSlackLimit | The number of days to the end of a task when Microsoft Project marks that task as a critical task. Read/write Int32.
CurrencyCode | The three letter currency character code as defined in ISO 4217. Example of valid values is "USD". Read/write String.
CurrencyDigits | The number of digits after a decimal symbol. Read/write Int32.
CurrencySymbol | The currency symbol used in a project. Read/write String.
CurrencySymbolPosition | The position of a currency symbol. Read/write CurrencySymbolPositionType.
CurrentDate | The system date. Read/write DateTime.
CustomProperties | Project's custom properties hashtable. Read/write Hashtable.
DaysPerMonth | The number of days per month. Read/write Int32.
DefaultFinishTime | The default finish time of new tasks. Read/write DateTime.
DefaultFixedCostAccrual | The default type when fixed costs are accrued. Read/write CostAccrualType.
DefaultOvertimeRate | The default overtime rate for new resources. Read/write Double.
DefaultStandardRate | The default standard rate for new resources. Read/write Double.
DefaultStartTime | The default start time of new tasks. Read/write DateTime.
DefaultTaskEVMethod | The default earned value method for tasks. Read/write EarnedValueMethodType.
DefaultTaskType | The default type of new tasks. Read/write TaskType.
DefaultWeekWorkingDays | Returns List<WeekDay> of project default week working days and working times.
DurationFormat | The format for expressing the bulk duration. Read/write TimeUnitType.
EarnedValueMethod | The default method for calculating earned value. Read/write EarnedValueMethodType.
ExtendedAttributes | Returns List<ExtendedAttributeDefinition> ExtendedAttributes. The collection of extended attribute (custom fields) definitions associated with a project. Read/write List of ExtendedAttributeDefinition.
ExtendedCreationDate | Date used for calculation and reporting. Read/write DateTime.
FinishDate | The finish date of a project. Required if IsScheduleFromStart is false. Read/write DateTime.
FiscalYearStart | Determines whether the fiscal year numbering is used. Read/write Boolean.
FyStartDate | The month when fiscal year is starting. Read/write Month.
HonorConstraints | Determines whether tasks honour their constraint dates. Read/write Boolean.
HyperlinkBase | Project's hyperlink base. Read/write String.
IsInsertedProjectsLikeSummary | Determines whether subtasks are calculated as summary tasks. Read/write Boolean.
IsScheduleFromStart | Determines whether the project is scheduled from the start date or from finish date. Read/write Boolean.
IsSpreadActualCost | Determines whether actual costs are spread to the status date. Read/write Boolean.
IsSpreadPercentComplete | Determines whether a percent complete is spread to the status date. Read/write Boolean.
KeepTaskOnNearestWorkingTimeWhenMadeAutoScheduled | Determines whether manual tasks must be kept on nearest working time when made as auto scheduled. Read/write Boolean.
Keywords | Project's keywords. Read/write String.
LastAuthor | Project's last author. Read/write String.
LastPrinted | Project's last print time. Read/write DateTime.
LastSaved | The date when a project was saved last time. Read/write DateTime.
Manager | The manager of a project. Read/write String.
MicrosoftProjectServerURL | Determines whether a project was created by a Project Server user as opposed to an NT user. Read/write Boolean.
MinutesPerDay | The number of minutes per day. Read/write Int32.
MinutesPerWeek | The number of minutes per week. Read/write Int32.
MoveCompletedEndsBack | Determines whether the end of completed portions of tasks scheduled to start after the status date but started earlier should be moved back to the status date. Read/write Boolean.
MoveCompletedEndsForward | Determines whether the end of completed portions of tasks scheduled to have been completed before the status date but begun later should be moved up to the status date. Read/write Boolean.
MoveRemainingStartsBack | Determines whether the beginning of remaining portions of tasks scheduled to start after the status date but started earlier should be moved back to the status date. Read/write Boolean.
MoveRemainingStartsForward | Determines whether the beginning of remaining portions of tasks scheduled to have begun later should be moved up to the status date. Read/write Boolean.
MultipleCriticalPaths | Determines whether multiple critical paths are calculated. Read/write Boolean.
Name | The name of a project. Read/write String.
NewTasksAreManual | Determines whether new tasks created as manual. Read/write Boolean.
NewTaskStartDate | The default start date type for new tasks. Read/write TaskStartDateType.
NextCalendarUid | Returns next Calendar Uid. For project without calendars starts from 1, for project with only base standart calendar in starts from 3, else starts from max Uid + 1. By the way in works in MS Office Project. Increments each call.
NextResourceAssignmentUid | Returns next Resource assignment Uid. For project without resource assignments starts from 1, else starts from max Uid + 1. Increments each call.
NextResourceUid | Returns next Resource Uid. For project without resources starts from 0, else starts from max Uid + 1. Increments each call.
NextTaskUid | Returns next Task Uid. For project without tasks starts from 0, else starts from max Uid + 1. Increments each call.
OutlineCodes | Returns List<OutlineCodeDefinition> OutlineCodes. The collection of outline code definitions associated with a project. Read/write List of OutlineCodeDefinition.
RemoveFileProperties | Determines whether all file properties will be removed on save. Read/write Boolean.
ResourceAssignments | Returns List<ResourceAssignment> ResourceAssignments. Read/write List of ResourceAssignment.
ResourceFilters | Represents all the resource-based filter definitions. ResourceFilters is a collection of Filter objects.
ResourceGroups | Represents all of the resource-based group definitions. ResourceGroups is a collection of Group objects.
Resources | Returns List<Resource> Resources. Read/write List of Resource.
Revision | The number of times a project was saved. Read/write Int32.
RootTask | The root of the tree of tasks. Read/write Task.
SaveVersion | The version of Microsoft Office Project from which a project file was saved. Read/write Int32.
ShowProjectSummaryTask | Determines whether to show project summary task or not.
StartDate | The start date of a project. Required if IsScheduleFromStart is true. Read/write DateTime.
StatusDate | Date used for calculation and reporting. Read/write DateTime.
Subject | The subject of a project. Read/write String.
Tables | Contains a list of Table objects.
TaskFilters | Represents all the task-based filter definitions. TaskFilters is a collection of Filter objects.
TaskGroups | Represents all the task-based group definitions. TaskGroups is a collection of Group objects.
TaskLinks | Returns List<TaskLink> TaskLinks. Read/write List of TaskLink.
TaskUpdatesResource | Determines whether updates to tasks update resources. Read/write Boolean.
Template | Project's template. Read/write String.
Title | The title of a project. Read/write String.
Uid | The unique Id of a project. Read/write String.
UpdateManuallyScheduledTasksWhenEditingLinks | Determines whether manual tasks must be updated when links were edited. Read/write Boolean.
Views | Contains a list of View objects.
WeekStartDay | First day of a week. Read/write DayType.
WorkFormat | The default work unit format. Read/write TimeUnitType.

Public Instance Methods

AddResource | Overloaded. Adds new resource at the last position of a project resources collection.
AddResourceAssignment | Overloaded. Adds new assignment to a project ResourceAssignments collection.
AddTask | Overloaded. Adds new task to project tasks collection on the same outline level of the last task.
AddTaskLink | Add a task link to a project.
CalcCalendarUids | Overloaded. Recalculate Uids of calendars from 0 up to calendars collection length - 1.
CalcResourceAssignmentIds | Recalculate Ids of resource assignemnts.
CalcResourceAssignmentUids | Overloaded. Recalculate Uids of resource assignments from 0 up to resource assignments collection length - 1.
CalcResourceFields | Recalculates Id, Start and Finish of resources.
CalcResourceIds | Recalculate Ids of resources.
CalcResourceStartFinish | Recalculates Start and Finish of resources.
CalcResourceUids | Overloaded. Recalculate Uids of resources from 0 up to resources collection length - 1.
CalcSlacks | Obsolete. Calculates slacks of project tasks based on task early/late dates and sets tasks critical flag.
CalcTaskIds | Recalculate Ids of tasks.
CalcTaskUids | Recalculate Uids of tasks (from 0).
CalculateCriticalPath | Calculates EarlyDates, LateDates, Start, Finish and TotalSlacks of each task and determines critical path of project based on calculated values.
Check | Checks the project's structure. Returns true if the project's structure is correct and false if the structure is broken.
CopyTo | Copies project's main data and properties to another project.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Export | Overloaded. Export project using different renderers.
GetBaselineSaveTime | Returns the baseline save time.
GetCalendarByName | Returns a calendar with the specified name.
GetCalendarByUid | Returns a calendar with the specified Uid.
GetCriticalPath | Returns list of Critical tasks which comprise Critical Path of a project.
GetExtendedAttributeDefinitionById | Returns an extended attribute definition by id
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPageCount | Overloaded. Returns page count for the project to be rendered using default Timescale(Days).
GetPredecessors | Returns a list of tasks which are predecessors of the specified task.
GetResourceAssignmentByUid | Returns a resource assignment with the specified Uid.
GetResourceAssignmentsByResource | Finds all resource assignments for specified resource.
GetResourceAssignmentsByTask | Finds all resource assignments for specified task.
GetResourceByUid | Returns a resource with the specified Uid.
GetTaskById | Returns a task with the specified Id.
GetTaskByUid | Returns a task with the specified Uid.
GetType (inherited from Object) | Gets the Type of the current instance.
Print | Overloaded. Prints project to the default printer with default printer settings using the standard (no User Interface) print controller.
RemoveCalendar | Removes calendar from a project.
RemoveInvalidResourceAssignments | Eliminates invalid resource assignments from the project resource assignments list.
RemoveLink | Removes task link from a project.
RemoveResource | Removes a resource and all it's references from a project.
RemoveResourceAssignment | Removes a resource assignment.
RemoveTask | Overloaded. Removes a task from a project and all references to it.
RemoveTaskByUid | Removes a task with the specified uid,
ReplaceCalendar | Replaces a calendar and all references to it.
RescheduleUncompletedWorkToStartAfter | Overloaded. Reschedules uncompleted project work to start after a specified date.
Save | Overloaded. Saves the document to a file using the specified save options.
SaveAsTemplate | Overloaded. Saves the project as a template.
SaveReport | Overloaded. Saves the project overview report to the stream.
SetBaseline | Overloaded. Saves baseline fields to the specified baseline for the entire project.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateProjectWorkAsComplete | Overloaded. Updates all work as complete through a specified date for the entire project.
UpdateReferences | Updates ParentProject and ParentTask properties of all tasks in a project.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Project Class | Aspose.Tasks Namespace


Project Constructor

Default constructor.

Overload List

Default constructor.

public Project();

Creates new project from a template(existent mpp or mpt file).

public Project(Stream);

Creates new project from a template(existent mpp or mpt file).

public Project(Stream,string);

Creates new project from a template(existent mpp or mpt file).

public Project(string);

Creates new project from a password protected template(existent mpp or mpt file).

public Project(string,string);

See Also

Project Class | Aspose.Tasks Namespace


Project Constructor ()

Default constructor.

public Project();

See Also

Project Class | Aspose.Tasks Namespace | Project Constructor Overload List


Project Constructor (String, String)

Creates new project from a password protected template(existent mpp or mpt file).

public Project(
string template,
string protectionPassword
);

Parameters

template
Path to template to create project from.
protectionPassword
Protection password.

Remarks

Reading password protected files currently supported for MSP 2003 file format only.

See Also

Project Class | Aspose.Tasks Namespace | Project Constructor Overload List


Project Constructor (String)

Creates new project from a template(existent mpp or mpt file).

public Project(
string template
);

Parameters

template
Path to template to create project from.

See Also

Project Class | Aspose.Tasks Namespace | Project Constructor Overload List


Project Constructor (Stream)

Creates new project from a template(existent mpp or mpt file).

public Project(
Stream stream
);

Parameters

stream
Stream to load a template from.

See Also

Project Class | Aspose.Tasks Namespace | Project Constructor Overload List


Project Constructor (Stream, String)

Creates new project from a template(existent mpp or mpt file).

public Project(
Stream stream,
string protectionPassword
);

Parameters

stream
Stream to load a template from.
protectionPassword
Protection password.

Remarks

Reading password protected files currently supported for MSP 2003 file format only.

See Also

Project Class | Aspose.Tasks Namespace | Project Constructor Overload List


Project Properties

The properties of the Project class are listed below. For a complete list of Project class members, see the Project Members topic.

Public Instance Properties

ActualsInSync | Determines whether all actual works have been synchronized with the project. Read/write Boolean.
AdminProject | Determines whether a project is an administrative project. Read/write Boolean.
AreEditableActualCosts | Determines whether actual costs are editable. Read/write Boolean.
AreNewTasksEffortDriven | Determines whether new tasks are effort driven. Read/write Boolean.
AreNewTasksEstimated | Determines whether an estimated duration is shown by default. Read/write Boolean.
Author | The author of a project. Read/write String.
AutoAddNewResourcesAndTasks | Determines whether new resources or tasks automatically added to a resource or task pool. Read/write Boolean.
Autolink | Determines whether inserted or moved tasks are autolinked. Read/write Boolean.
BaselineForEarnedValue | The specific baseline used to calculate Variance values.
CalculateAfterEdit | Determines whether to recalculate the project dependent fields automatically.
Calendar | The project calendar. Read/write Calendar.
Calendars | Returns List<Calendar> Calendars. Read/write List of Calendar.
CanSplitsInProgressTasks | Determines whether in-progress tasks can be split. Read/write Boolean.
Category | The category of a project. Read/write String.
Comments | Project's comments. Read/write String.
Company | The company where a project was created. Read/write String.
CreationDate | The date and time when a project was created. Read/write DateTime.
CriticalSlackLimit | The number of days to the end of a task when Microsoft Project marks that task as a critical task. Read/write Int32.
CurrencyCode | The three letter currency character code as defined in ISO 4217. Example of valid values is "USD". Read/write String.
CurrencyDigits | The number of digits after a decimal symbol. Read/write Int32.
CurrencySymbol | The currency symbol used in a project. Read/write String.
CurrencySymbolPosition | The position of a currency symbol. Read/write CurrencySymbolPositionType.
CurrentDate | The system date. Read/write DateTime.
CustomProperties | Project's custom properties hashtable. Read/write Hashtable.
DaysPerMonth | The number of days per month. Read/write Int32.
DefaultFinishTime | The default finish time of new tasks. Read/write DateTime.
DefaultFixedCostAccrual | The default type when fixed costs are accrued. Read/write CostAccrualType.
DefaultOvertimeRate | The default overtime rate for new resources. Read/write Double.
DefaultStandardRate | The default standard rate for new resources. Read/write Double.
DefaultStartTime | The default start time of new tasks. Read/write DateTime.
DefaultTaskEVMethod | The default earned value method for tasks. Read/write EarnedValueMethodType.
DefaultTaskType | The default type of new tasks. Read/write TaskType.
DefaultWeekWorkingDays | Returns List<WeekDay> of project default week working days and working times.
DurationFormat | The format for expressing the bulk duration. Read/write TimeUnitType.
EarnedValueMethod | The default method for calculating earned value. Read/write EarnedValueMethodType.
ExtendedAttributes | Returns List<ExtendedAttributeDefinition> ExtendedAttributes. The collection of extended attribute (custom fields) definitions associated with a project. Read/write List of ExtendedAttributeDefinition.
ExtendedCreationDate | Date used for calculation and reporting. Read/write DateTime.
FinishDate | The finish date of a project. Required if IsScheduleFromStart is false. Read/write DateTime.
FiscalYearStart | Determines whether the fiscal year numbering is used. Read/write Boolean.
FyStartDate | The month when fiscal year is starting. Read/write Month.
HonorConstraints | Determines whether tasks honour their constraint dates. Read/write Boolean.
HyperlinkBase | Project's hyperlink base. Read/write String.
IsInsertedProjectsLikeSummary | Determines whether subtasks are calculated as summary tasks. Read/write Boolean.
IsScheduleFromStart | Determines whether the project is scheduled from the start date or from finish date. Read/write Boolean.
IsSpreadActualCost | Determines whether actual costs are spread to the status date. Read/write Boolean.
IsSpreadPercentComplete | Determines whether a percent complete is spread to the status date. Read/write Boolean.
KeepTaskOnNearestWorkingTimeWhenMadeAutoScheduled | Determines whether manual tasks must be kept on nearest working time when made as auto scheduled. Read/write Boolean.
Keywords | Project's keywords. Read/write String.
LastAuthor | Project's last author. Read/write String.
LastPrinted | Project's last print time. Read/write DateTime.
LastSaved | The date when a project was saved last time. Read/write DateTime.
Manager | The manager of a project. Read/write String.
MicrosoftProjectServerURL | Determines whether a project was created by a Project Server user as opposed to an NT user. Read/write Boolean.
MinutesPerDay | The number of minutes per day. Read/write Int32.
MinutesPerWeek | The number of minutes per week. Read/write Int32.
MoveCompletedEndsBack | Determines whether the end of completed portions of tasks scheduled to start after the status date but started earlier should be moved back to the status date. Read/write Boolean.
MoveCompletedEndsForward | Determines whether the end of completed portions of tasks scheduled to have been completed before the status date but begun later should be moved up to the status date. Read/write Boolean.
MoveRemainingStartsBack | Determines whether the beginning of remaining portions of tasks scheduled to start after the status date but started earlier should be moved back to the status date. Read/write Boolean.
MoveRemainingStartsForward | Determines whether the beginning of remaining portions of tasks scheduled to have begun later should be moved up to the status date. Read/write Boolean.
MultipleCriticalPaths | Determines whether multiple critical paths are calculated. Read/write Boolean.
Name | The name of a project. Read/write String.
NewTasksAreManual | Determines whether new tasks created as manual. Read/write Boolean.
NewTaskStartDate | The default start date type for new tasks. Read/write TaskStartDateType.
NextCalendarUid | Returns next Calendar Uid. For project without calendars starts from 1, for project with only base standart calendar in starts from 3, else starts from max Uid + 1. By the way in works in MS Office Project. Increments each call.
NextResourceAssignmentUid | Returns next Resource assignment Uid. For project without resource assignments starts from 1, else starts from max Uid + 1. Increments each call.
NextResourceUid | Returns next Resource Uid. For project without resources starts from 0, else starts from max Uid + 1. Increments each call.
NextTaskUid | Returns next Task Uid. For project without tasks starts from 0, else starts from max Uid + 1. Increments each call.
OutlineCodes | Returns List<OutlineCodeDefinition> OutlineCodes. The collection of outline code definitions associated with a project. Read/write List of OutlineCodeDefinition.
RemoveFileProperties | Determines whether all file properties will be removed on save. Read/write Boolean.
ResourceAssignments | Returns List<ResourceAssignment> ResourceAssignments. Read/write List of ResourceAssignment.
ResourceFilters | Represents all the resource-based filter definitions. ResourceFilters is a collection of Filter objects.
ResourceGroups | Represents all of the resource-based group definitions. ResourceGroups is a collection of Group objects.
Resources | Returns List<Resource> Resources. Read/write List of Resource.
Revision | The number of times a project was saved. Read/write Int32.
RootTask | The root of the tree of tasks. Read/write Task.
SaveVersion | The version of Microsoft Office Project from which a project file was saved. Read/write Int32.
ShowProjectSummaryTask | Determines whether to show project summary task or not.
StartDate | The start date of a project. Required if IsScheduleFromStart is true. Read/write DateTime.
StatusDate | Date used for calculation and reporting. Read/write DateTime.
Subject | The subject of a project. Read/write String.
Tables | Contains a list of Table objects.
TaskFilters | Represents all the task-based filter definitions. TaskFilters is a collection of Filter objects.
TaskGroups | Represents all the task-based group definitions. TaskGroups is a collection of Group objects.
TaskLinks | Returns List<TaskLink> TaskLinks. Read/write List of TaskLink.
TaskUpdatesResource | Determines whether updates to tasks update resources. Read/write Boolean.
Template | Project's template. Read/write String.
Title | The title of a project. Read/write String.
Uid | The unique Id of a project. Read/write String.
UpdateManuallyScheduledTasksWhenEditingLinks | Determines whether manual tasks must be updated when links were edited. Read/write Boolean.
Views | Contains a list of View objects.
WeekStartDay | First day of a week. Read/write DayType.
WorkFormat | The default work unit format. Read/write TimeUnitType.

See Also

Project Class | Aspose.Tasks Namespace


ActualsInSync Property

Project.ActualsInSync Property

Determines whether all actual works have been synchronized with the project. Read/write Boolean.

public bool ActualsInSync {get; set;}

Remarks

Reading supported for XML format only.

See Also

Project Class | Aspose.Tasks Namespace


AdminProject Property

Project.AdminProject Property

Determines whether a project is an administrative project. Read/write Boolean.

public bool AdminProject {get; set;}

Remarks

Reading supported for XML format only.

See Also

Project Class | Aspose.Tasks Namespace


AreEditableActualCosts Property

Project.AreEditableActualCosts Property

Determines whether actual costs are editable. Read/write Boolean.

public bool AreEditableActualCosts {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


AreNewTasksEffortDriven Property

Project.AreNewTasksEffortDriven Property

Determines whether new tasks are effort driven. Read/write Boolean.

public bool AreNewTasksEffortDriven {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


AreNewTasksEstimated Property

Project.AreNewTasksEstimated Property

Determines whether an estimated duration is shown by default. Read/write Boolean.

public bool AreNewTasksEstimated {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Author Property

Project.Author Property

The author of a project. Read/write String.

public string Author {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


AutoAddNewResourcesAndTasks Property

Project.AutoAddNewResourcesAndTasks Property

Determines whether new resources or tasks automatically added to a resource or task pool. Read/write Boolean.

public bool AutoAddNewResourcesAndTasks {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Autolink Property

Project.Autolink Property

Determines whether inserted or moved tasks are autolinked. Read/write Boolean.

public bool Autolink {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


BaselineForEarnedValue Property

Project.BaselineForEarnedValue Property

The specific baseline used to calculate Variance values.

public BaselineType BaselineForEarnedValue {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


CalculateAfterEdit Property

Project.CalculateAfterEdit Property

Determines whether to recalculate the project dependent fields automatically.

public bool CalculateAfterEdit {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Calendar Property

Project.Calendar Property

The project calendar. Read/write Calendar.

public Calendar Calendar {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Calendars Property

Project.Calendars Property

Returns List<Calendar> Calendars. Read/write List of Calendar.

public Calendar} Calendars {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


CanSplitsInProgressTasks Property

Project.CanSplitsInProgressTasks Property

Determines whether in-progress tasks can be split. Read/write Boolean.

public bool CanSplitsInProgressTasks {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Category Property

Project.Category Property

The category of a project. Read/write String.

public string Category {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Comments Property

Project.Comments Property

Project's comments. Read/write String.

public string Comments {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Company Property

Project.Company Property

The company where a project was created. Read/write String.

public string Company {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


CreationDate Property

Project.CreationDate Property

The date and time when a project was created. Read/write DateTime.

public DateTime CreationDate {get; set;}

Remarks

For MPP it is a UTC DateTime.

See Also

Project Class | Aspose.Tasks Namespace


CriticalSlackLimit Property

Project.CriticalSlackLimit Property

The number of days to the end of a task when Microsoft Project marks that task as a critical task. Read/write Int32.

public int CriticalSlackLimit {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


CurrencyCode Property

Project.CurrencyCode Property

The three letter currency character code as defined in ISO 4217. Example of valid values is "USD". Read/write String.

public string CurrencyCode {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


CurrencyDigits Property

Project.CurrencyDigits Property

The number of digits after a decimal symbol. Read/write Int32.

public int CurrencyDigits {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


CurrencySymbol Property

Project.CurrencySymbol Property

The currency symbol used in a project. Read/write String.

public string CurrencySymbol {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


CurrencySymbolPosition Property

Project.CurrencySymbolPosition Property

The position of a currency symbol. Read/write CurrencySymbolPositionType.

public CurrencySymbolPositionType CurrencySymbolPosition {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


CurrentDate Property

Project.CurrentDate Property

The system date. Read/write DateTime.

public DateTime CurrentDate {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


CustomProperties Property

Project.CustomProperties Property

Project's custom properties hashtable. Read/write Hashtable.

public Hashtable CustomProperties {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


DaysPerMonth Property

Project.DaysPerMonth Property

The number of days per month. Read/write Int32.

public int DaysPerMonth {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


DefaultFinishTime Property

Project.DefaultFinishTime Property

The default finish time of new tasks. Read/write DateTime.

public DateTime DefaultFinishTime {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


DefaultFixedCostAccrual Property

Project.DefaultFixedCostAccrual Property

The default type when fixed costs are accrued. Read/write CostAccrualType.

public CostAccrualType DefaultFixedCostAccrual {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


DefaultOvertimeRate Property

Project.DefaultOvertimeRate Property

The default overtime rate for new resources. Read/write Double.

public double DefaultOvertimeRate {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


DefaultStandardRate Property

Project.DefaultStandardRate Property

The default standard rate for new resources. Read/write Double.

public double DefaultStandardRate {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


DefaultStartTime Property

Project.DefaultStartTime Property

The default start time of new tasks. Read/write DateTime.

public DateTime DefaultStartTime {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


DefaultTaskEVMethod Property

Project.DefaultTaskEVMethod Property

The default earned value method for tasks. Read/write EarnedValueMethodType.

public EarnedValueMethodType DefaultTaskEVMethod {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


DefaultTaskType Property

Project.DefaultTaskType Property

The default type of new tasks. Read/write TaskType.

public TaskType DefaultTaskType {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


DefaultWeekWorkingDays Property

Project.DefaultWeekWorkingDays Property

Returns List<WeekDay> of project default week working days and working times.

public WeekDay} DefaultWeekWorkingDays {get; set;}

Remarks

The data contains only in mpp files (not in xml).

See Also

Project Class | Aspose.Tasks Namespace


DurationFormat Property

Project.DurationFormat Property

The format for expressing the bulk duration. Read/write TimeUnitType.

public TimeUnitType DurationFormat {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


EarnedValueMethod Property

Project.EarnedValueMethod Property

The default method for calculating earned value. Read/write EarnedValueMethodType.

public EarnedValueMethodType EarnedValueMethod {get; set;}

Remarks

Reading supported for XML format only.

See Also

Project Class | Aspose.Tasks Namespace


ExtendedAttributes Property

Project.ExtendedAttributes Property

Returns List<ExtendedAttributeDefinition> ExtendedAttributes. The collection of extended attribute (custom fields) definitions associated with a project. Read/write List of ExtendedAttributeDefinition.

public ExtendedAttributeDefinition} ExtendedAttributes {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


ExtendedCreationDate Property

Project.ExtendedCreationDate Property

Date used for calculation and reporting. Read/write DateTime.

public DateTime ExtendedCreationDate {get; set;}

Remarks

Reading supported for XML format only.

See Also

Project Class | Aspose.Tasks Namespace


FinishDate Property

Project.FinishDate Property

The finish date of a project. Required if IsScheduleFromStart is false. Read/write DateTime.

public DateTime FinishDate {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


FiscalYearStart Property

Project.FiscalYearStart Property

Determines whether the fiscal year numbering is used. Read/write Boolean.

public bool FiscalYearStart {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


FyStartDate Property

Project.FyStartDate Property

The month when fiscal year is starting. Read/write Month.

public Month FyStartDate {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


HonorConstraints Property

Project.HonorConstraints Property

Determines whether tasks honour their constraint dates. Read/write Boolean.

public bool HonorConstraints {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


HyperlinkBase Property

Project.HyperlinkBase Property

Project's hyperlink base. Read/write String.

public string HyperlinkBase {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


IsInsertedProjectsLikeSummary Property

Project.IsInsertedProjectsLikeSummary Property

Determines whether subtasks are calculated as summary tasks. Read/write Boolean.

public bool IsInsertedProjectsLikeSummary {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


IsScheduleFromStart Property

Project.IsScheduleFromStart Property

Determines whether the project is scheduled from the start date or from finish date. Read/write Boolean.

public bool IsScheduleFromStart {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


IsSpreadActualCost Property

Project.IsSpreadActualCost Property

Determines whether actual costs are spread to the status date. Read/write Boolean.

public bool IsSpreadActualCost {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


IsSpreadPercentComplete Property

Project.IsSpreadPercentComplete Property

Determines whether a percent complete is spread to the status date. Read/write Boolean.

public bool IsSpreadPercentComplete {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


KeepTaskOnNearestWorkingTimeWhenMadeAutoScheduled Property

Project.KeepTaskOnNearestWorkingTimeWhenMadeAutoScheduled Property

Determines whether manual tasks must be kept on nearest working time when made as auto scheduled. Read/write Boolean.

public bool KeepTaskOnNearestWorkingTimeWhenMadeAutoScheduled {get; set;}

Remarks

This is a new for MS Project 2010 property. Returns false if not defined.

See Also

Project Class | Aspose.Tasks Namespace


Keywords Property

Project.Keywords Property

Project's keywords. Read/write String.

public string Keywords {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


LastAuthor Property

Project.LastAuthor Property

Project's last author. Read/write String.

public string LastAuthor {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


LastPrinted Property

Project.LastPrinted Property

Project's last print time. Read/write DateTime.

public DateTime LastPrinted {get; set;}

Remarks

For MPP files it is a UTC date time.

See Also

Project Class | Aspose.Tasks Namespace


LastSaved Property

Project.LastSaved Property

The date when a project was saved last time. Read/write DateTime.

public DateTime LastSaved {get; set;}

Remarks

For MPP it is a UTC DateTime.

See Also

Project Class | Aspose.Tasks Namespace


Manager Property

Project.Manager Property

The manager of a project. Read/write String.

public string Manager {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


MicrosoftProjectServerURL Property

Project.MicrosoftProjectServerURL Property

Determines whether a project was created by a Project Server user as opposed to an NT user. Read/write Boolean.

public bool MicrosoftProjectServerURL {get; set;}

Remarks

Reading supported for XML format only.

See Also

Project Class | Aspose.Tasks Namespace


MinutesPerDay Property

Project.MinutesPerDay Property

The number of minutes per day. Read/write Int32.

public int MinutesPerDay {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


MinutesPerWeek Property

Project.MinutesPerWeek Property

The number of minutes per week. Read/write Int32.

public int MinutesPerWeek {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


MoveCompletedEndsBack Property

Project.MoveCompletedEndsBack Property

Determines whether the end of completed portions of tasks scheduled to start after the status date but started earlier should be moved back to the status date. Read/write Boolean.

public bool MoveCompletedEndsBack {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


MoveCompletedEndsForward Property

Project.MoveCompletedEndsForward Property

Determines whether the end of completed portions of tasks scheduled to have been completed before the status date but begun later should be moved up to the status date. Read/write Boolean.

public bool MoveCompletedEndsForward {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


MoveRemainingStartsBack Property

Project.MoveRemainingStartsBack Property

Determines whether the beginning of remaining portions of tasks scheduled to start after the status date but started earlier should be moved back to the status date. Read/write Boolean.

public bool MoveRemainingStartsBack {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


MoveRemainingStartsForward Property

Project.MoveRemainingStartsForward Property

Determines whether the beginning of remaining portions of tasks scheduled to have begun later should be moved up to the status date. Read/write Boolean.

public bool MoveRemainingStartsForward {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


MultipleCriticalPaths Property

Project.MultipleCriticalPaths Property

Determines whether multiple critical paths are calculated. Read/write Boolean.

public bool MultipleCriticalPaths {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Name Property

Project.Name Property

The name of a project. Read/write String.

public string Name {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


NewTasksAreManual Property

Project.NewTasksAreManual Property

Determines whether new tasks created as manual. Read/write Boolean.

public bool NewTasksAreManual {get; set;}

Remarks

This is a new for MS Project 2010 property. Returns false if not defined.

See Also

Project Class | Aspose.Tasks Namespace


NewTaskStartDate Property

Project.NewTaskStartDate Property

The default start date type for new tasks. Read/write TaskStartDateType.

public TaskStartDateType NewTaskStartDate {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


NextCalendarUid Property

Project.NextCalendarUid Property

Returns next Calendar Uid. For project without calendars starts from 1, for project with only base standart calendar in starts from 3, else starts from max Uid + 1. By the way in works in MS Office Project. Increments each call.

public int NextCalendarUid {get;}

See Also

Project Class | Aspose.Tasks Namespace


NextResourceAssignmentUid Property

Project.NextResourceAssignmentUid Property

Returns next Resource assignment Uid. For project without resource assignments starts from 1, else starts from max Uid + 1. Increments each call.

public int NextResourceAssignmentUid {get;}

See Also

Project Class | Aspose.Tasks Namespace


NextResourceUid Property

Project.NextResourceUid Property

Returns next Resource Uid. For project without resources starts from 0, else starts from max Uid + 1. Increments each call.

public int NextResourceUid {get;}

See Also

Project Class | Aspose.Tasks Namespace


NextTaskUid Property

Project.NextTaskUid Property

Returns next Task Uid. For project without tasks starts from 0, else starts from max Uid + 1. Increments each call.

public int NextTaskUid {get;}

See Also

Project Class | Aspose.Tasks Namespace


OutlineCodes Property

Project.OutlineCodes Property

Returns List<OutlineCodeDefinition> OutlineCodes. The collection of outline code definitions associated with a project. Read/write List of OutlineCodeDefinition.

public OutlineCodeDefinition} OutlineCodes {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


RemoveFileProperties Property

Project.RemoveFileProperties Property

Determines whether all file properties will be removed on save. Read/write Boolean.

public bool RemoveFileProperties {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


ResourceAssignments Property

Project.ResourceAssignments Property

Returns List<ResourceAssignment> ResourceAssignments. Read/write List of ResourceAssignment.

public ResourceAssignment} ResourceAssignments {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


ResourceFilters Property

Project.ResourceFilters Property

Represents all the resource-based filter definitions. ResourceFilters is a collection of Filter objects.

public Filters ResourceFilters {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


ResourceGroups Property

Project.ResourceGroups Property

Represents all of the resource-based group definitions. ResourceGroups is a collection of Group objects.

public Groups ResourceGroups {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Resources Property

Project.Resources Property

Returns List<Resource> Resources. Read/write List of Resource.

public Resource} Resources {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Revision Property

Project.Revision Property

The number of times a project was saved. Read/write Int32.

public int Revision {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


RootTask Property

Project.RootTask Property

The root of the tree of tasks. Read/write Task.

public Task RootTask {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


SaveVersion Property

Project.SaveVersion Property

The version of Microsoft Office Project from which a project file was saved. Read/write Int32.

public int SaveVersion {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


ShowProjectSummaryTask Property

Project.ShowProjectSummaryTask Property

Determines whether to show project summary task or not.

public bool ShowProjectSummaryTask {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


StartDate Property

Project.StartDate Property

The start date of a project. Required if IsScheduleFromStart is true. Read/write DateTime.

public DateTime StartDate {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


StatusDate Property

Project.StatusDate Property

Date used for calculation and reporting. Read/write DateTime.

public DateTime StatusDate {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Subject Property

Project.Subject Property

The subject of a project. Read/write String.

public string Subject {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Tables Property

Project.Tables Property

Contains a list of Table objects.

public Tables Tables {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


TaskFilters Property

Project.TaskFilters Property

Represents all the task-based filter definitions. TaskFilters is a collection of Filter objects.

public Filters TaskFilters {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


TaskGroups Property

Project.TaskGroups Property

Represents all the task-based group definitions. TaskGroups is a collection of Group objects.

public Groups TaskGroups {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


TaskLinks Property

Project.TaskLinks Property

Returns List<TaskLink> TaskLinks. Read/write List of TaskLink.

public TaskLink} TaskLinks {get;}

See Also

Project Class | Aspose.Tasks Namespace


TaskUpdatesResource Property

Project.TaskUpdatesResource Property

Determines whether updates to tasks update resources. Read/write Boolean.

public bool TaskUpdatesResource {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Template Property

Project.Template Property

Project's template. Read/write String.

public string Template {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Title Property

Project.Title Property

The title of a project. Read/write String.

public string Title {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Uid Property

Project.Uid Property

The unique Id of a project. Read/write String.

public string Uid {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


UpdateManuallyScheduledTasksWhenEditingLinks Property

Project.UpdateManuallyScheduledTasksWhenEditingLinks Property

Determines whether manual tasks must be updated when links were edited. Read/write Boolean.

public bool UpdateManuallyScheduledTasksWhenEditingLinks {get; set;}

Remarks

This is a new for MS Project 2010 property. Returns false if not defined.

See Also

Project Class | Aspose.Tasks Namespace


Views Property

Project.Views Property

Contains a list of View objects.

public Views Views {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


WeekStartDay Property

Project.WeekStartDay Property

First day of a week. Read/write DayType.

public DayType WeekStartDay {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


WorkFormat Property

Project.WorkFormat Property

The default work unit format. Read/write TimeUnitType.

public TimeUnitType WorkFormat {get; set;}

See Also

Project Class | Aspose.Tasks Namespace


Project Methods

The methods of the Project class are listed below. For a complete list of Project class members, see the Project Members topic.

Public Instance Methods

AddResource | Overloaded. Adds new resource at the last position of a project resources collection.
AddResourceAssignment | Overloaded. Adds new assignment to a project ResourceAssignments collection.
AddTask | Overloaded. Adds new task to project tasks collection on the same outline level of the last task.
AddTaskLink | Add a task link to a project.
CalcCalendarUids | Overloaded. Recalculate Uids of calendars from 0 up to calendars collection length - 1.
CalcResourceAssignmentIds | Recalculate Ids of resource assignemnts.
CalcResourceAssignmentUids | Overloaded. Recalculate Uids of resource assignments from 0 up to resource assignments collection length - 1.
CalcResourceFields | Recalculates Id, Start and Finish of resources.
CalcResourceIds | Recalculate Ids of resources.
CalcResourceStartFinish | Recalculates Start and Finish of resources.
CalcResourceUids | Overloaded. Recalculate Uids of resources from 0 up to resources collection length - 1.
CalcSlacks | Obsolete. Calculates slacks of project tasks based on task early/late dates and sets tasks critical flag.
CalcTaskIds | Recalculate Ids of tasks.
CalcTaskUids | Recalculate Uids of tasks (from 0).
CalculateCriticalPath | Calculates EarlyDates, LateDates, Start, Finish and TotalSlacks of each task and determines critical path of project based on calculated values.
Check | Checks the project's structure. Returns true if the project's structure is correct and false if the structure is broken.
CopyTo | Copies project's main data and properties to another project.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Export | Overloaded. Export project using different renderers.
GetBaselineSaveTime | Returns the baseline save time.
GetCalendarByName | Returns a calendar with the specified name.
GetCalendarByUid | Returns a calendar with the specified Uid.
GetCriticalPath | Returns list of Critical tasks which comprise Critical Path of a project.
GetExtendedAttributeDefinitionById | Returns an extended attribute definition by id
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPageCount | Overloaded. Returns page count for the project to be rendered using default Timescale(Days).
GetPredecessors | Returns a list of tasks which are predecessors of the specified task.
GetResourceAssignmentByUid | Returns a resource assignment with the specified Uid.
GetResourceAssignmentsByResource | Finds all resource assignments for specified resource.
GetResourceAssignmentsByTask | Finds all resource assignments for specified task.
GetResourceByUid | Returns a resource with the specified Uid.
GetTaskById | Returns a task with the specified Id.
GetTaskByUid | Returns a task with the specified Uid.
GetType (inherited from Object) | Gets the Type of the current instance.
Print | Overloaded. Prints project to the default printer with default printer settings using the standard (no User Interface) print controller.
RemoveCalendar | Removes calendar from a project.
RemoveInvalidResourceAssignments | Eliminates invalid resource assignments from the project resource assignments list.
RemoveLink | Removes task link from a project.
RemoveResource | Removes a resource and all it's references from a project.
RemoveResourceAssignment | Removes a resource assignment.
RemoveTask | Overloaded. Removes a task from a project and all references to it.
RemoveTaskByUid | Removes a task with the specified uid,
ReplaceCalendar | Replaces a calendar and all references to it.
RescheduleUncompletedWorkToStartAfter | Overloaded. Reschedules uncompleted project work to start after a specified date.
Save | Overloaded. Saves the document to a file using the specified save options.
SaveAsTemplate | Overloaded. Saves the project as a template.
SaveReport | Overloaded. Saves the project overview report to the stream.
SetBaseline | Overloaded. Saves baseline fields to the specified baseline for the entire project.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateProjectWorkAsComplete | Overloaded. Updates all work as complete through a specified date for the entire project.
UpdateReferences | Updates ParentProject and ParentTask properties of all tasks in a project.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Project Class | Aspose.Tasks Namespace


AddResource Method

Project.AddResource Method

Adds new resource at the last position of a project resources collection.

Overload List

Adds new resource at the last position of a project resources collection.

public Resource AddResource();

Adds new resource at the last position of a project resources collection.

public Resource AddResource(string);

Adds new resource at the specified position of a project resources collection.

public Resource AddResource(string,int);

See Also

Project Class | Aspose.Tasks Namespace


Project.AddResource Method ()

Adds new resource at the last position of a project resources collection.

public Resource AddResource();

Return Value

Added resource.

See Also

Project Class | Aspose.Tasks Namespace | Project.AddResource Overload List


Project.AddResource Method (String)

Adds new resource at the last position of a project resources collection.

public Resource AddResource(
string resourceName
);

Parameters

resourceName
Name of a resource.

Return Value

Added resource.

See Also

Project Class | Aspose.Tasks Namespace | Project.AddResource Overload List


Project.AddResource Method (String, Int32)

Adds new resource at the specified position of a project resources collection.

public Resource AddResource(
string resourceName,
int beforeResourceId
);

Parameters

resourceName
Name of a resource.
beforeResourceId
Position of a resource in a project resources collection.

Return Value

Added resource.

See Also

Project Class | Aspose.Tasks Namespace | Project.AddResource Overload List


AddResourceAssignment Method

Project.AddResourceAssignment Method

Adds new assignment to a project ResourceAssignments collection.

Overload List

Adds new assignment to a project ResourceAssignments collection.

public ResourceAssignment AddResourceAssignment(Task,Resource);

Adds new assignment to a project ResourceAssignments collection.

public ResourceAssignment AddResourceAssignment(Task,Resource,double);

See Also

Project Class | Aspose.Tasks Namespace


Project.AddResourceAssignment Method (Task, Resource)

Adds new assignment to a project ResourceAssignments collection.

public ResourceAssignment AddResourceAssignment(
Task task,
Resource resource
);

Parameters

task
A task to be assigned.
resource
A resource to be assigned.

Return Value

Added assignment.

See Also

Project Class | Aspose.Tasks Namespace | Project.AddResourceAssignment Overload List


Project.AddResourceAssignment Method (Task, Resource, Double)

Adds new assignment to a project ResourceAssignments collection.

public ResourceAssignment AddResourceAssignment(
Task task,
Resource resource,
double units
);

Parameters

task
A task to be assigned.
resource
A resource to be assigned.
units
The number of units for a new assignment.

Return Value

Added assignment.

See Also

Project Class | Aspose.Tasks Namespace | Project.AddResourceAssignment Overload List


AddTask Method

Project.AddTask Method

Adds new task to project tasks collection on the same outline level of the last task.

Overload List

Adds new task to project tasks collection on the same outline level of the last task.

public Task AddTask();

Inserts new task before task with provided id and on the same outline level.

public Task AddTask(int);

Adds new task to project tasks collection on the same outline level of the last task.

public Task AddTask(string);

Inserts new task before task with provided id and on the same outline level.

public Task AddTask(string,int);

See Also

Project Class | Aspose.Tasks Namespace


Project.AddTask Method ()

Adds new task to project tasks collection on the same outline level of the last task.

public Task AddTask();

Return Value

Added Task

See Also

Project Class | Aspose.Tasks Namespace | Project.AddTask Overload List


Project.AddTask Method (Int32)

Inserts new task before task with provided id and on the same outline level.

public Task AddTask(
int beforeTaskId
);

Parameters

beforeTaskId

Return Value

See Also

Project Class | Aspose.Tasks Namespace | Project.AddTask Overload List


Project.AddTask Method (String)

Adds new task to project tasks collection on the same outline level of the last task.

public Task AddTask(
string taskName
);

Parameters

taskName
Task name.

Return Value

Added Task

See Also

Project Class | Aspose.Tasks Namespace | Project.AddTask Overload List


Project.AddTask Method (String, Int32)

Inserts new task before task with provided id and on the same outline level.

public Task AddTask(
string taskName,
int beforeTaskId
);

Parameters

taskName
Task name.
beforeTaskId
Int32 Id of task before which new task will be inserted.

Return Value

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

Project Class | Aspose.Tasks Namespace | Project.AddTask Overload List


Project.AddTaskLink Method

Add a task link to a project.

public void AddTaskLink(
TaskLink link
);

Parameters

link
TaskLink to add.

See Also

Project Class | Aspose.Tasks Namespace


CalcCalendarUids Method

Project.CalcCalendarUids Method

Recalculate Uids of calendars from 0 up to calendars collection length - 1.

Overload List

Recalculate Uids of calendars from 0 up to calendars collection length - 1.

public void CalcCalendarUids();

Recalculate Uids of calendars from start value.

public void CalcCalendarUids(int);

See Also

Project Class | Aspose.Tasks Namespace


Project.CalcCalendarUids Method ()

Recalculate Uids of calendars from 0 up to calendars collection length - 1.

public void CalcCalendarUids();

See Also

Project Class | Aspose.Tasks Namespace | Project.CalcCalendarUids Overload List


Project.CalcCalendarUids Method (Int32)

Recalculate Uids of calendars from start value.

public void CalcCalendarUids(
int start
);

See Also

Project Class | Aspose.Tasks Namespace | Project.CalcCalendarUids Overload List


Project.CalcResourceAssignmentIds Method

Recalculate Ids of resource assignemnts.

public void CalcResourceAssignmentIds();

See Also

Project Class | Aspose.Tasks Namespace


CalcResourceAssignmentUids Method

Project.CalcResourceAssignmentUids Method

Recalculate Uids of resource assignments from 0 up to resource assignments collection length - 1.

Overload List

Recalculate Uids of resource assignments from 0 up to resource assignments collection length - 1.

public void CalcResourceAssignmentUids();

Recalculate Uids of resource assignments from start value.

public void CalcResourceAssignmentUids(int);

See Also

Project Class | Aspose.Tasks Namespace


Project.CalcResourceAssignmentUids Method ()

Recalculate Uids of resource assignments from 0 up to resource assignments collection length - 1.

public void CalcResourceAssignmentUids();

See Also

Project Class | Aspose.Tasks Namespace | Project.CalcResourceAssignmentUids Overload List


Project.CalcResourceAssignmentUids Method (Int32)

Recalculate Uids of resource assignments from start value.

public void CalcResourceAssignmentUids(
int start
);

See Also

Project Class | Aspose.Tasks Namespace | Project.CalcResourceAssignmentUids Overload List


Project.CalcResourceFields Method

Recalculates Id, Start and Finish of resources.

public void CalcResourceFields();

See Also

Project Class | Aspose.Tasks Namespace


Project.CalcResourceIds Method

Recalculate Ids of resources.

public void CalcResourceIds();

See Also

Project Class | Aspose.Tasks Namespace


Project.CalcResourceStartFinish Method

Recalculates Start and Finish of resources.

public void CalcResourceStartFinish();

See Also

Project Class | Aspose.Tasks Namespace


CalcResourceUids Method

Project.CalcResourceUids Method

Recalculate Uids of resources from 0 up to resources collection length - 1.

Overload List

Recalculate Uids of resources from 0 up to resources collection length - 1.

public void CalcResourceUids();

Recalculate Uids of resources from start value.

public void CalcResourceUids(int);

See Also

Project Class | Aspose.Tasks Namespace


Project.CalcResourceUids Method ()

Recalculate Uids of resources from 0 up to resources collection length - 1.

public void CalcResourceUids();

See Also

Project Class | Aspose.Tasks Namespace | Project.CalcResourceUids Overload List


Project.CalcResourceUids Method (Int32)

Recalculate Uids of resources from start value.

public void CalcResourceUids(
int start
);

See Also

Project Class | Aspose.Tasks Namespace | Project.CalcResourceUids Overload List


Project.CalcSlacks Method

NOTE: This method is now obsolete.

Use Task.Recalculate(Project.RootTask) instead.

Calculates slacks of project tasks based on task early/late dates and sets tasks critical flag.

public void CalcSlacks();

Remarks

Call this method only after all tasks early/date dates have been set.

See Also

Project Class | Aspose.Tasks Namespace


Project.CalcTaskIds Method

Recalculate Ids of tasks.

public void CalcTaskIds();

See Also

Project Class | Aspose.Tasks Namespace


Project.CalcTaskUids Method

Recalculate Uids of tasks (from 0).

public void CalcTaskUids();

See Also

Project Class | Aspose.Tasks Namespace


Project.CalculateCriticalPath Method

Calculates EarlyDates, LateDates, Start, Finish and TotalSlacks of each task and determines critical path of project based on calculated values.

public void CalculateCriticalPath();

See Also

Project Class | Aspose.Tasks Namespace


Project.Check Method

Checks the project's structure. Returns true if the project's structure is correct and false if the structure is broken.

public bool Check();

Return Value

See Also

Project Class | Aspose.Tasks Namespace


Project.CopyTo Method

Copies project's main data and properties to another project.

public void CopyTo(
Project another
);

Parameters

another
Another project to copy data to.

See Also

Project Class | Aspose.Tasks Namespace


Export Method

Project.Export Method

NOTE: This method is now obsolete.

The method is obsolete, use Project's Save method instead of it.

Export project to stream using different renders.

Overload List

Obsolete. Export project to stream using different renders.

public IRenderResult Export(RenderFormat,PresentationFormat,Stream,IRenderParam);

Obsolete. Export project to stream using different renderers.

public IRenderResult Export(RenderFormat,PresentationFormat,Stream,IRenderParam,bool,ArrayList);

Obsolete. Export project using different renderers and views.

public IRenderResult Export(RenderFormat,PresentationFormat,Stream,IRenderParam,bool,ArrayList,ProjectView);

Obsolete. Export project using different renderers.

public IRenderResult Export(RenderFormat,PresentationFormat,string,IRenderParam);

Obsolete. Export project using different renderers.

public IRenderResult Export(RenderFormat,PresentationFormat,string,IRenderParam,bool,ArrayList);

Obsolete. Export project using different renderers and views.

public IRenderResult Export(RenderFormat,PresentationFormat,string,IRenderParam,bool,ArrayList,ProjectView);

See Also

Project Class | Aspose.Tasks Namespace


Project.Export Method (RenderFormat, PresentationFormat, Stream, IRenderParam)

NOTE: This method is now obsolete.

The method is obsolete, use Project's Save method instead of it.

Export project to stream using different renders.

public IRenderResult Export(
RenderFormat renderFormat,
PresentationFormat presentationFormat,
Stream stream,
IRenderParam param
);

Parameters

renderFormat
RenderFormat rendering format.
presentationFormat
PresentationFormat presentetion format.
stream
The output stream.
param
IRenderParam as rendering parameter.

Return Value

IRenderResult as rendering result info.

Remarks

The method is marked as obsolete 03.20.2013. Use Project's Save method instead of it.

See Also

Project Class | Aspose.Tasks Namespace | Project.Export Overload List


Project.Export Method (RenderFormat, PresentationFormat, Stream, IRenderParam, Boolean, ArrayList)

NOTE: This method is now obsolete.

The method is obsolete, use Project's Save method instead of it.

Export project to stream using different renderers.

public IRenderResult Export(
RenderFormat renderFormat,
PresentationFormat presentationFormat,
Stream stream,
IRenderParam param,
bool expandAll,
ArrayList arrayExpanded
);

Parameters

renderFormat
RenderFormat rendering format.
presentationFormat
PresentationFormat presentation format.
stream
The output stream.
param
IRenderParam as rendering parameter.
expandAll
Boolean flag to expand all summary tasks or not.
arrayExpanded
ArrayList with expanded task UIDs.

Return Value

IRenderResult as rendering result info.

Remarks

The method is marked as obsolete 03.20.2013. Use Project's Save method instead of it.

See Also

Project Class | Aspose.Tasks Namespace | Project.Export Overload List


Project.Export Method (RenderFormat, PresentationFormat, Stream, IRenderParam, Boolean, ArrayList, ProjectView)

NOTE: This method is now obsolete.

The method is obsolete, use Project's Save method instead of it.

Export project using different renderers and views.

public IRenderResult Export(
RenderFormat renderFormat,
PresentationFormat presentationFormat,
Stream stream,
IRenderParam param,
bool expandAll,
ArrayList arrayExpanded,
ProjectView view
);

Parameters

renderFormat
RenderFormat rendering format.
presentationFormat
PresentationFormat presentation format.
stream
Stream as the output stream.
param
IRenderParam as rendering parameter.
expandAll
Boolean flag to expand all summary tasks or not.
arrayExpanded
ArrayList with expanded tasks UIDs.
view
ProjectView as project's view.

Return Value

IRenderResult as rendering result info.

Remarks

The method is marked as obsolete 03.20.2013. Use Project's Save method instead of it.

See Also

Project Class | Aspose.Tasks Namespace | Project.Export Overload List


Project.Export Method (RenderFormat, PresentationFormat, String, IRenderParam)

NOTE: This method is now obsolete.

The method is obsolete, use Project's Save method instead of it.

Export project using different renderers.

public IRenderResult Export(
RenderFormat renderFormat,
PresentationFormat presentationFormat,
string filename,
IRenderParam param
);

Parameters

renderFormat
RenderFormat rendering format.
presentationFormat
PresentationFormat presentation format.
filename
File name to export.
param
IRenderParam as rendering parameter.

Return Value

IRenderResult as rendering result info.

Remarks

The method is marked as obsolete 03.20.2013. Use Project's Save method instead of it.

See Also

Project Class | Aspose.Tasks Namespace | Project.Export Overload List


Project.Export Method (RenderFormat, PresentationFormat, String, IRenderParam, Boolean, ArrayList)

NOTE: This method is now obsolete.

The method is obsolete, use Project's Save method instead of it.

Export project using different renderers.

public IRenderResult Export(
RenderFormat renderFormat,
PresentationFormat presentationFormat,
string filename,
IRenderParam param,
bool expandAll,
ArrayList arrayExpanded
);

Parameters

renderFormat
RenderFormat rendering format.
presentationFormat
PresentationFormat presentation format.
filename
File name to export.
param
IRenderParam as rendering parameter.
expandAll
Boolean flag shows expand all tasks or not.
arrayExpanded
ArrayList with a list of expanded task UIDs.

Return Value

IRenderResult as rendering result.

Remarks

The method is marked as obsolete 03.20.2013. Use Project's Save method instead of it.

See Also

Project Class | Aspose.Tasks Namespace | Project.Export Overload List


Project.Export Method (RenderFormat, PresentationFormat, String, IRenderParam, Boolean, ArrayList, ProjectView)

NOTE: This method is now obsolete.

The method is obsolete, use Project's Save method instead of it.

Export project using different renderers and views.

public IRenderResult Export(
RenderFormat renderFormat,
PresentationFormat presentationFormat,
string filename,
IRenderParam param,
bool expandAll,
ArrayList arrayExpanded,
ProjectView view
);

Parameters

renderFormat
RenderFormat rendering format.
presentationFormat
PresentationFormat presentation format.
filename
File name to export.
param
IRenderParam as rendering parameter.
expandAll
Boolean flag to expand all summary tasks or not.
arrayExpanded
ArrayList with expanded tasks UIDs.
view
ProjectView as project's view.

Return Value

IRenderResult as rendering result info.

Remarks

The method is marked as obsolete 03.20.2013. Use Project's Save method instead of it.

See Also

Project Class | Aspose.Tasks Namespace | Project.Export Overload List


Project.GetBaselineSaveTime Method

Returns the baseline save time.

public DateTime GetBaselineSaveTime(
BaselineType baselineNumber
);

Parameters

baselineNumber
The baseline's number BaselineType.

Return Value

The baseline's last save date and time.

Remarks

Returns DateTime.MinValue if the baseline was not saved.

See Also

Project Class | Aspose.Tasks Namespace


Project.GetCalendarByName Method

Returns a calendar with the specified name.

public Calendar GetCalendarByName(
string name
);

Parameters

name
Name of a calendar.

Return Value

Calendar

See Also

Project Class | Aspose.Tasks Namespace


Project.GetCalendarByUid Method

Returns a calendar with the specified Uid.

public Calendar GetCalendarByUid(
int uid
);

Parameters

uid
Uid of a calendar.

Return Value

Calendar

See Also

Project Class | Aspose.Tasks Namespace


Project.GetCriticalPath Method

Returns list of Critical tasks which comprise Critical Path of a project.

public List<Task> GetCriticalPath();

Return Value

List of all critical tasks.

See Also

Project Class | Aspose.Tasks Namespace


Project.GetExtendedAttributeDefinitionById Method

Returns an extended attribute definition by id

public ExtendedAttributeDefinition GetExtendedAttributeDefinitionById(
int id
);

Parameters

id
specified id

Return Value

ExtendedAttributeDefinition with specified id.

See Also

Project Class | Aspose.Tasks Namespace


GetPageCount Method

Project.GetPageCount Method

Returns page count for the project to be rendered using default Timescale(Days).

Overload List

Returns page count for the project to be rendered using default Timescale(Days).

public int GetPageCount();

Returns page count for the project to be rendered using default Timescale(Days) and given PresentationFormat

public int GetPageCount(PresentationFormat);

Returns page count for the project to be rendered using given Timescale and PresentationFormat.

public int GetPageCount(PresentationFormat,Timescale);

Returns page count for the project to be rendered using given Timescale.

public int GetPageCount(Timescale);

See Also

Project Class | Aspose.Tasks Namespace


Project.GetPageCount Method ()

Returns page count for the project to be rendered using default Timescale(Days).

public int GetPageCount();

Return Value

Page count to be rendered.

See Also

Project Class | Aspose.Tasks Namespace | Project.GetPageCount Overload List


Project.GetPageCount Method (PresentationFormat)

Returns page count for the project to be rendered using default Timescale(Days) and given PresentationFormat

public int GetPageCount(
PresentationFormat format
);

Parameters

format
PresentationFormat to get page count for.

Return Value

Page count to be rendered.

See Also

Project Class | Aspose.Tasks Namespace | Project.GetPageCount Overload List


Project.GetPageCount Method (PresentationFormat, Timescale)

Returns page count for the project to be rendered using given Timescale and PresentationFormat.

public int GetPageCount(
PresentationFormat format,
Timescale scale
);

Parameters

format
PresentationFormat to get page count for.
scale
Timescale to get page count for.

Return Value

Page count to be rendered.

See Also

Project Class | Aspose.Tasks Namespace | Project.GetPageCount Overload List


Project.GetPageCount Method (Timescale)

Returns page count for the project to be rendered using given Timescale.

public int GetPageCount(
Timescale scale
);

Parameters

scale
Timescale to get page count for.

Return Value

Page count to be rendered.

See Also

Project Class | Aspose.Tasks Namespace | Project.GetPageCount Overload List


Project.GetPredecessors Method

Returns a list of tasks which are predecessors of the specified task.

public List<TaskLink> GetPredecessors(
Task task
);

Parameters

task
Task

Return Value

List of predecessors TaskLink.

See Also

Project Class | Aspose.Tasks Namespace


Project.GetResourceAssignmentByUid Method

Returns a resource assignment with the specified Uid.

public ResourceAssignment GetResourceAssignmentByUid(
int uid
);

Parameters

uid
Resource assignment Uid.

Return Value

Resource assignment.

See Also

Project Class | Aspose.Tasks Namespace


Project.GetResourceAssignmentsByResource Method

Finds all resource assignments for specified resource.

public List<ResourceAssignment> GetResourceAssignmentsByResource(
Resource resource
);

Parameters

resource
The resource.

Return Value

List of ResourceAssignment.

See Also

Project Class | Aspose.Tasks Namespace


Project.GetResourceAssignmentsByTask Method

Finds all resource assignments for specified task.

public List<ResourceAssignment> GetResourceAssignmentsByTask(
Task task
);

Parameters

task
The task.

Return Value

List of ResourceAssignment.

See Also

Project Class | Aspose.Tasks Namespace


Project.GetResourceByUid Method

Returns a resource with the specified Uid.

public Resource GetResourceByUid(
int uid
);

Parameters

uid
Resource Uid.

Return Value

Resource.

See Also

Project Class | Aspose.Tasks Namespace


Project.GetTaskById Method

Returns a task with the specified Id.

public Task GetTaskById(
int id
);

Parameters

id
Task Id

Return Value

Task

See Also

Project Class | Aspose.Tasks Namespace


Project.GetTaskByUid Method

Returns a task with the specified Uid.

public Task GetTaskByUid(
int uid
);

Parameters

uid
Task Uid.

Return Value

Task

See Also

Project Class | Aspose.Tasks Namespace


Print Method

Project.Print Method

Prints project to the default printer with default printer settings using the standard (no User Interface) print controller.

Overload List

Prints project to the default printer with default printer settings using the standard (no User Interface) print controller.

public void Print();

Prints project to the default printer with default printer settings and custom save options using the standard (no User Interface) print controller.

public void Print(PrintOptions);

Prints project according to the specified printer settings using the standard (no User Interface) print controller.

public void Print(PrinterSettings);

Prints project according to the specified printer settings and custom save options using the standard (no User Interface) print controller.

public void Print(PrinterSettings,PrintOptions);

Prints project according to the specified printer settings using the standard (no User Interface) print controller.

public void Print(PrinterSettings,string);

Prints project to the specified printer with default printer settings using the standard (no User Interface) print controller.

public void Print(string);

See Also

Project Class | Aspose.Tasks Namespace


Project.Print Method ()

Prints project to the default printer with default printer settings using the standard (no User Interface) print controller.

public void Print();

See Also

Project Class | Aspose.Tasks Namespace | Project.Print Overload List


Project.Print Method (PrintOptions)

Prints project to the default printer with default printer settings and custom save options using the standard (no User Interface) print controller.

public void Print(
PrintOptions options
);

See Also

Project Class | Aspose.Tasks Namespace | Project.Print Overload List


Project.Print Method (PrinterSettings)

Prints project according to the specified printer settings using the standard (no User Interface) print controller.

public void Print(
PrinterSettings printerSettings
);

Parameters

printerSettings
Specified instance of PrinterSettings.

See Also

Project Class | Aspose.Tasks Namespace | Project.Print Overload List


Project.Print Method (PrinterSettings, PrintOptions)

Prints project according to the specified printer settings and custom save options using the standard (no User Interface) print controller.

public void Print(
PrinterSettings printerSettings,
PrintOptions options
);

Parameters

printerSettings
Specified instance of PrinterSettings.
options
Specified instance of PrintOptions.

See Also

Project Class | Aspose.Tasks Namespace | Project.Print Overload List


Project.Print Method (PrinterSettings, String)

Prints project according to the specified printer settings using the standard (no User Interface) print controller.

public void Print(
PrinterSettings printerSettings,
string documentName
);

Parameters

printerSettings
Specified instance of PrinterSettings.
documentName
Document name.

See Also

Project Class | Aspose.Tasks Namespace | Project.Print Overload List


Project.Print Method (String)

Prints project to the specified printer with default printer settings using the standard (no User Interface) print controller.

public void Print(
string printerName
);

Parameters

printerName
Specified printer name.

See Also

Project Class | Aspose.Tasks Namespace | Project.Print Overload List


Project.RemoveCalendar Method

Removes calendar from a project.

public Calendar RemoveCalendar(
int uid
);

Parameters

uid
Uid of a calendar to remove.

Return Value

Removed calendar.

See Also

Project Class | Aspose.Tasks Namespace


Project.RemoveInvalidResourceAssignments Method

Eliminates invalid resource assignments from the project resource assignments list.

public void RemoveInvalidResourceAssignments();

Remarks

MS Project creates an empty resource assignment for each task. Call the method to remove them.

See Also

Project Class | Aspose.Tasks Namespace


Project.RemoveLink Method

Removes task link from a project.

public TaskLink RemoveLink(
TaskLink link
);

Parameters

link
TaskLink to remove.

Return Value

Removed TaskLink.

See Also

Project Class | Aspose.Tasks Namespace


Project.RemoveResource Method

Removes a resource and all it's references from a project.

public void RemoveResource(
int uid
);

Parameters

uid
Uid of a resource to remove.

See Also

Project Class | Aspose.Tasks Namespace


Project.RemoveResourceAssignment Method

Removes a resource assignment.

public ResourceAssignment RemoveResourceAssignment(
ResourceAssignment ra
);

Parameters

ra
Resource assignment to remove.

Return Value

Removed resource assignment.

See Also

Project Class | Aspose.Tasks Namespace


RemoveTask Method

Project.RemoveTask Method

Removes a task from a project and all references to it.

Overload List

Removes a task from a project and all references to it.

public void RemoveTask(Task);

Removes a task with the specified id.

public void RemoveTask(int);

See Also

Project Class | Aspose.Tasks Namespace


Project.RemoveTask Method (Task)

Removes a task from a project and all references to it.

public void RemoveTask(
Task task
);

Parameters

task
Task to remove.

See Also

Project Class | Aspose.Tasks Namespace | Project.RemoveTask Overload List


Project.RemoveTask Method (Int32)

Removes a task with the specified id.

public void RemoveTask(
int id
);

Parameters

id
Id of task to remove.

See Also

Project Class | Aspose.Tasks Namespace | Project.RemoveTask Overload List


Project.RemoveTaskByUid Method

Removes a task with the specified uid,

public void RemoveTaskByUid(
int uid
);

Parameters

uid
Uid of a task to remove.

See Also

Project Class | Aspose.Tasks Namespace


Project.ReplaceCalendar Method

Replaces a calendar and all references to it.

public Calendar ReplaceCalendar(
int uid,
Calendar newCal
);

Parameters

uid
Uid of the removed calendar.
newCal
New calendar.

Return Value

Removed calendar.

See Also

Project Class | Aspose.Tasks Namespace


RescheduleUncompletedWorkToStartAfter Method

Project.RescheduleUncompletedWorkToStartAfter Method

Reschedules uncompleted project work to start after a specified date.

Overload List

Reschedules uncompleted project work to start after a specified date.

public void RescheduleUncompletedWorkToStartAfter(DateTime);

Reschedules uncompleted work for a specified list of tasks to start after a specified date.

public void RescheduleUncompletedWorkToStartAfter(DateTime,Task});

See Also

Project Class | Aspose.Tasks Namespace


Project.RescheduleUncompletedWorkToStartAfter Method (DateTime)

Reschedules uncompleted project work to start after a specified date.

public void RescheduleUncompletedWorkToStartAfter(
DateTime after
);

Parameters

after
DateTime to reschedule uncompleted work after.

Remarks

Ensure that Project.CanSplitsInProgressTasks flag is set to true before using this method.

See Also

Project Class | Aspose.Tasks Namespace | Project.RescheduleUncompletedWorkToStartAfter Overload List


Project.RescheduleUncompletedWorkToStartAfter Method (DateTime, Task})

Reschedules uncompleted work for a specified list of tasks to start after a specified date.

public void RescheduleUncompletedWorkToStartAfter(
DateTime after,
List<Task> tasks
);

Parameters

after
DateTime to reschedule uncompleted work after.
tasks
List<Task> of tasks to reschedule uncompleted work for.

Remarks

Ensure that Project.CanSplitsInProgressTasks flag is set to true before using this method.

See Also

Project Class | Aspose.Tasks Namespace | Project.RescheduleUncompletedWorkToStartAfter Overload List


Save Method

Project.Save Method

Saves the project data to the stream.

Overload List

Saves the project data to the stream.

public void Save(Stream,SaveFileFormat);

Saves the project to a stream using the specified save options.

public void Save(Stream,SaveOptions);

Saves the project data to the file.

public void Save(string,SaveFileFormat);

Saves the document to a file using the specified save options.

public void Save(string,SaveOptions);

See Also

Project Class | Aspose.Tasks Namespace


Project.Save Method (Stream, SaveFileFormat)

Saves the project data to the stream.

public void Save(
Stream stream,
SaveFileFormat format
);

Parameters

stream
The stream.
format
SaveFileFormat save file format.

See Also

Project Class | Aspose.Tasks Namespace | Project.Save Overload List


Project.Save Method (Stream, SaveOptions)

Saves the project to a stream using the specified save options.

public void Save(
Stream stream,
SaveOptions options
);

Parameters

stream
The stream.
options
SaveOptions save options.

See Also

Project Class | Aspose.Tasks Namespace | Project.Save Overload List


Project.Save Method (String, SaveFileFormat)

Saves the project data to the file.

public void Save(
string filename,
SaveFileFormat format
);

Parameters

filename
The file name.
format
SaveFileFormat save file format.

See Also

Project Class | Aspose.Tasks Namespace | Project.Save Overload List


Project.Save Method (String, SaveOptions)

Saves the document to a file using the specified save options.

public void Save(
string filename,
SaveOptions options
);

Parameters

filename
The file name.
options
SaveOptions save options.

See Also

Project Class | Aspose.Tasks Namespace | Project.Save Overload List


SaveAsTemplate Method

Project.SaveAsTemplate Method

Saves the project as a template to a specified stream.

Overload List

Saves the project as a template to a specified stream.

public void SaveAsTemplate(Stream);

Saves the project as a template to a specified stream.

public void SaveAsTemplate(Stream,SaveTemplateOptions);

Saves the project as a template.

public void SaveAsTemplate(string);

Saves the project as a template.

public void SaveAsTemplate(string,SaveTemplateOptions);

See Also

Project Class | Aspose.Tasks Namespace


Project.SaveAsTemplate Method (Stream)

Saves the project as a template to a specified stream.

public void SaveAsTemplate(
Stream stream
);

Parameters

stream

See Also

Project Class | Aspose.Tasks Namespace | Project.SaveAsTemplate Overload List


Project.SaveAsTemplate Method (Stream, SaveTemplateOptions)

Saves the project as a template to a specified stream.

public void SaveAsTemplate(
Stream stream,
SaveTemplateOptions options
);

Parameters

stream
Stream to save the project template to.
options
SaveTemplateOptionsSpecifies additional options.

See Also

Project Class | Aspose.Tasks Namespace | Project.SaveAsTemplate Overload List


Project.SaveAsTemplate Method (String)

Saves the project as a template.

public void SaveAsTemplate(
string filename
);

Parameters

filename
the file name.

See Also

Project Class | Aspose.Tasks Namespace | Project.SaveAsTemplate Overload List


Project.SaveAsTemplate Method (String, SaveTemplateOptions)

Saves the project as a template.

public void SaveAsTemplate(
string filename,
SaveTemplateOptions options
);

Parameters

filename
The file name.
options
SaveTemplateOptionsSpecifies additional options.

See Also

Project Class | Aspose.Tasks Namespace | Project.SaveAsTemplate Overload List


SaveReport Method

Project.SaveReport Method

Saves the project overview report to the stream.

Overload List

Saves the project overview report to the stream.

public void SaveReport(Stream);

Saves the project report to a specified stream.

public void SaveReport(Stream,ReportType);

Saves the project overview report to pdf file.

public void SaveReport(string);

Saves the project report to pdf file.

public void SaveReport(string,ReportType);

See Also

Project Class | Aspose.Tasks Namespace


Project.SaveReport Method (Stream)

Saves the project overview report to the stream.

public void SaveReport(
Stream stream
);

Parameters

stream
The stream to save project report to.

See Also

Project Class | Aspose.Tasks Namespace | Project.SaveReport Overload List


Project.SaveReport Method (Stream, ReportType)

Saves the project report to a specified stream.

public void SaveReport(
Stream stream,
ReportType reportType
);

Parameters

stream
A stream to save project report to.
reportType
ReportType

See Also

Project Class | Aspose.Tasks Namespace | Project.SaveReport Overload List


Project.SaveReport Method (String)

Saves the project overview report to pdf file.

public void SaveReport(
string filename
);

Parameters

filename
The file name.

See Also

Project Class | Aspose.Tasks Namespace | Project.SaveReport Overload List


Project.SaveReport Method (String, ReportType)

Saves the project report to pdf file.

public void SaveReport(
string filename,
ReportType reportType
);

Parameters

filename
The file name.
reportType
ReportType

See Also

Project Class | Aspose.Tasks Namespace | Project.SaveReport Overload List


SetBaseline Method

Project.SetBaseline Method

Saves baseline fields to the specified baseline for the entire project.

Overload List

Saves baseline fields to the specified baseline for the entire project.

public void SetBaseline(BaselineType);

Saves baseline fields to the specified baseline for the selected tasks.

public void SetBaseline(BaselineType,Task});

See Also

Project Class | Aspose.Tasks Namespace


Project.SetBaseline Method (BaselineType)

Saves baseline fields to the specified baseline for the entire project.

public void SetBaseline(
BaselineType baselineType
);

Parameters

baselineType
BaselineType to save baseline data to.

See Also

Project Class | Aspose.Tasks Namespace | Project.SetBaseline Overload List


Project.SetBaseline Method (BaselineType, Task})

Saves baseline fields to the specified baseline for the selected tasks.

public void SetBaseline(
BaselineType baselineType,
List<Task> tasks
);

Parameters

baselineType
BaselineType to save baseline data to.
tasks
List of tasks to save baseline data for.

See Also

Project Class | Aspose.Tasks Namespace | Project.SetBaseline Overload List


UpdateProjectWorkAsComplete Method

Project.UpdateProjectWorkAsComplete Method

Updates all work as complete through a specified date for the entire project.

Overload List

Updates all work as complete through a specified date for the entire project.

public void UpdateProjectWorkAsComplete(DateTime,bool);

Updates all work as complete through a specified date for the specified list of tasks.

public void UpdateProjectWorkAsComplete(DateTime,bool,Task});

See Also

Project Class | Aspose.Tasks Namespace


Project.UpdateProjectWorkAsComplete Method (DateTime, Boolean)

Updates all work as complete through a specified date for the entire project.

public void UpdateProjectWorkAsComplete(
DateTime completeThrough,
bool setZeroOrHundredPercentCompleteOnly
);

Parameters

completeThrough
DateTime to update work as completed through.
setZeroOrHundredPercentCompleteOnly
If set to true updates only those tasks as 100% complete whose finish date is before specified complete-through date. Otherwise, calculates a percentage complete value based on scheduled start and complete-through dates.

See Also

Project Class | Aspose.Tasks Namespace | Project.UpdateProjectWorkAsComplete Overload List


Project.UpdateProjectWorkAsComplete Method (DateTime, Boolean, Task})

Updates all work as complete through a specified date for the specified list of tasks.

public void UpdateProjectWorkAsComplete(
DateTime completeThrough,
bool setZeroOrHundredPercentCompleteOnly,
List<Task> tasks
);

Parameters

completeThrough
DateTime to update work as completed through.
setZeroOrHundredPercentCompleteOnly
If set to true updates only those tasks as 100% complete whose finish date is before specified complete-through date. Otherwise, calculates a percentage complete value based on scheduled start and complete-through dates.
tasks
List<Task> of tasks to update work for.

See Also

Project Class | Aspose.Tasks Namespace | Project.UpdateProjectWorkAsComplete Overload List


Project.UpdateReferences Method

Updates ParentProject and ParentTask properties of all tasks in a project.

public void UpdateReferences();

See Also

Project Class | Aspose.Tasks Namespace


ProjectFileInfo Class

The class instance contains information about project file format and version of Microsoft Project where the file was created.

For a list of all members of this type, see ProjectFileInfo Members.

System.Object
Aspose.Tasks.ProjectFileInfo

public sealed class ProjectFileInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Use CanRead property to define that Aspose.Tasks can process the project file.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ProjectFileInfo Members | Aspose.Tasks Namespace


ProjectFileInfo Members

ProjectFileInfo overview

Public Instance Properties

CanRead | Defines can Aspose.Tasks process the project file.
ProjectApplicationInfo | Project file application info. Read only ApplicationInfo.
ProjectFileFormat | Project file format. Read only FileFormat.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ProjectFileInfo Class | Aspose.Tasks Namespace


ProjectFileInfo Properties

The properties of the ProjectFileInfo class are listed below. For a complete list of ProjectFileInfo class members, see the ProjectFileInfo Members topic.

Public Instance Properties

CanRead | Defines can Aspose.Tasks process the project file.
ProjectApplicationInfo | Project file application info. Read only ApplicationInfo.
ProjectFileFormat | Project file format. Read only FileFormat.

See Also

ProjectFileInfo Class | Aspose.Tasks Namespace


CanRead Property

ProjectFileInfo.CanRead Property

Defines can Aspose.Tasks process the project file.

public bool CanRead {get;}

See Also

ProjectFileInfo Class | Aspose.Tasks Namespace


ProjectApplicationInfo Property

ProjectFileInfo.ProjectApplicationInfo Property

Project file application info. Read only ApplicationInfo.

public ApplicationInfo ProjectApplicationInfo {get;}

See Also

ProjectFileInfo Class | Aspose.Tasks Namespace


ProjectFileFormat Property

ProjectFileInfo.ProjectFileFormat Property

Project file format. Read only FileFormat.

public FileFormat ProjectFileFormat {get;}

See Also

ProjectFileInfo Class | Aspose.Tasks Namespace


ProjectReader Class

Represents a class to read Project files in MPP, XML and MPX formats.

For a list of all members of this type, see ProjectReader Members.

System.Object
Aspose.Tasks.ProjectReader

public class ProjectReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ProjectReader Members | Aspose.Tasks Namespace


ProjectReader Members

ProjectReader overview

Public Instance Constructors

ProjectReader Overloaded. Initializes a new instance of the ProjectReader class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Read | Overloaded. Read project data from a stream.
ReadProjectFileInfo | Overloaded. Read project file info from the stream.
SetProjectXMLParsingStartedEventHandler | Set reader's project xml parsing started event handler.
SetTaskXMLParsingFinishedEventHandler | Set reader's project xml parsing finished event handler.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectReader Class | Aspose.Tasks Namespace


ProjectReader Constructor

Default constructor.

Overload List

Default constructor.

public ProjectReader();

public ProjectReader(string);

See Also

ProjectReader Class | Aspose.Tasks Namespace


ProjectReader Constructor ()

Default constructor.

public ProjectReader();

See Also

ProjectReader Class | Aspose.Tasks Namespace | ProjectReader Constructor Overload List


ProjectReader Constructor (String)

public ProjectReader(
string protectionPassword
);

Parameters

protectionPassword
Protection password.

Remarks

Reading password protected files currently supported for MSP 2003 file format only.

See Also

ProjectReader Class | Aspose.Tasks Namespace | ProjectReader Constructor Overload List


ProjectReader Methods

The methods of the ProjectReader class are listed below. For a complete list of ProjectReader class members, see the ProjectReader Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Read | Overloaded. Read project data from a stream.
ReadProjectFileInfo | Overloaded. Read project file info from the stream.
SetProjectXMLParsingStartedEventHandler | Set reader's project xml parsing started event handler.
SetTaskXMLParsingFinishedEventHandler | Set reader's project xml parsing finished event handler.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectReader Class | Aspose.Tasks Namespace


Read Method

ProjectReader.Read Method

Read project data from a stream.

Overload List

Read project data from a stream.

public Project Read(Stream);

Read project data from file.

public Project Read(string);

See Also

ProjectReader Class | Aspose.Tasks Namespace


ProjectReader.Read Method (Stream)

Read project data from a stream.

public Project Read(
Stream stream
);

Parameters

stream
Input stream.

Return Value

Created project.

Remarks

In case of exception it returns TasksReadingException.

See Also

ProjectReader Class | Aspose.Tasks Namespace | ProjectReader.Read Overload List


ProjectReader.Read Method (String)

Read project data from file.

public Project Read(
string filename
);

Parameters

filename
File to read.

Return Value

Readed project.

See Also

ProjectReader Class | Aspose.Tasks Namespace | ProjectReader.Read Overload List


ReadProjectFileInfo Method

ProjectReader.ReadProjectFileInfo Method

Read project file info from the stream.

Overload List

Read project file info from the stream.

public ProjectFileInfo ReadProjectFileInfo(Stream);

Read project file info from the file.

public ProjectFileInfo ReadProjectFileInfo(string);

See Also

ProjectReader Class | Aspose.Tasks Namespace


ProjectReader.ReadProjectFileInfo Method (Stream)

Read project file info from the stream.

public ProjectFileInfo ReadProjectFileInfo(
Stream stream
);

Parameters

stream
The data stream.

Return Value

The project file info ProjectFileInfo.

See Also

ProjectReader Class | Aspose.Tasks Namespace | ProjectReader.ReadProjectFileInfo Overload List


ProjectReader.ReadProjectFileInfo Method (String)

Read project file info from the file.

public ProjectFileInfo ReadProjectFileInfo(
string filename
);

Parameters

filename
The project filename.

Return Value

The project file info ProjectFileInfo.

See Also

ProjectReader Class | Aspose.Tasks Namespace | ProjectReader.ReadProjectFileInfo Overload List


ProjectReader.SetProjectXMLParsingStartedEventHandler Method

Set reader's project xml parsing started event handler.

public void SetProjectXMLParsingStartedEventHandler(
ProjectXMLParsingStarted handler
);

Parameters

handler
The handler ProjectXMLParsingStarted.

See Also

ProjectReader Class | Aspose.Tasks Namespace


ProjectReader.SetTaskXMLParsingFinishedEventHandler Method

Set reader's project xml parsing finished event handler.

public void SetTaskXMLParsingFinishedEventHandler(
TaskXMLParsingFinished handler
);

Parameters

handler
The handler TaskXMLParsingFinished.

See Also

ProjectReader Class | Aspose.Tasks Namespace


ProjectWriter Class

Represents a class to write Project to various file formats. Currently the only XML format is supported for writing.

For a list of all members of this type, see ProjectWriter Members.

System.Object
Aspose.Tasks.ProjectWriter

public class ProjectWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ProjectWriter Members | Aspose.Tasks Namespace


ProjectWriter Members

ProjectWriter overview

Public Instance Constructors

ProjectWriter Constructor Initializes a new instance of the ProjectWriter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetProjectXMLCreationFinishedEventHandler | Set writer's project xml creation finished event handler.
SetTaskXMLCreationFinishedEventHandler | Set reader's task xml creation finished event handler.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes project to a stream.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectWriter Class | Aspose.Tasks Namespace


ProjectWriter Constructor

Initializes a new instance of the ProjectWriter class.

public ProjectWriter();

See Also

ProjectWriter Class | Aspose.Tasks Namespace


ProjectWriter Methods

The methods of the ProjectWriter class are listed below. For a complete list of ProjectWriter class members, see the ProjectWriter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetProjectXMLCreationFinishedEventHandler | Set writer's project xml creation finished event handler.
SetTaskXMLCreationFinishedEventHandler | Set reader's task xml creation finished event handler.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes project to a stream.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectWriter Class | Aspose.Tasks Namespace


ProjectWriter.SetProjectXMLCreationFinishedEventHandler Method

Set writer's project xml creation finished event handler.

public void SetProjectXMLCreationFinishedEventHandler(
ProjectXMLCreationFinished handler
);

Parameters

handler
The handler ProjectXMLCreationFinished.

See Also

ProjectWriter Class | Aspose.Tasks Namespace


ProjectWriter.SetTaskXMLCreationFinishedEventHandler Method

Set reader's task xml creation finished event handler.

public void SetTaskXMLCreationFinishedEventHandler(
TaskXMLCreationFinished handler
);

Parameters

handler
The handler TaskXMLCreationFinished.

See Also

ProjectWriter Class | Aspose.Tasks Namespace


Write Method

ProjectWriter.Write Method

Writes project to a stream.

Overload List

Writes project to a stream.

public void Write(Project,Stream,TasksDataFormat);

Writes project to the file.

public void Write(Project,string,TasksDataFormat);

See Also

ProjectWriter Class | Aspose.Tasks Namespace


ProjectWriter.Write Method (Project, Stream, TasksDataFormat)

Writes project to a stream.

public void Write(
Project project,
Stream output,
TasksDataFormat fmt
);

Parameters

project
Project.
output
Output stream.
fmt
File formal. See TasksDataFormat

Remarks

Updating MPP files is not allowed in evaluation mode.

See Also

ProjectWriter Class | Aspose.Tasks Namespace | ProjectWriter.Write Overload List


ProjectWriter.Write Method (Project, String, TasksDataFormat)

Writes project to the file.

public void Write(
Project project,
string filename,
TasksDataFormat fmt
);

Parameters

project
Project to write.
filename
File to write.
fmt
File formal. See TasksDataFormat

See Also

ProjectWriter Class | Aspose.Tasks Namespace | ProjectWriter.Write Overload List


ProjectXMLCreationFinished Delegate

Project XML data creation finished delegate for XML data postprocessing.

public delegate void ProjectXMLCreationFinished(
XmlDocument doc,
Project project
);

Parameters

doc
The XML document.
project
The project.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


ProjectXMLParsingStarted Delegate

Project's XML parsing start delegate for XML data preprocessing.

public delegate void ProjectXMLParsingStarted(
XmlDocument doc,
Project project
);

Parameters

doc
Project's XML document.
project
The project.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


Rate Class

Represents a definition of a time period and rates applicable for a resource during that period.

For a list of all members of this type, see Rate Members.

System.Object
Aspose.Tasks.Rate

public class Rate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Rate Members | Aspose.Tasks Namespace


Rate Members

Rate overview

Public Instance Constructors

Rate Constructor Initializes a new instance of the Rate class.

Public Instance Properties

CostPerUse | The cost per use of a resource. This value retrieved from the current date if a rate table exists for a resource. Read/write Decimal.
OvertimeRate | The overtime rate for a resource for the specified period. Read/write Decimal.
OvertimeRateFormat | The units used by Microsoft Project to display the overtime rate. Read/write RateFormatType.
RatesFrom | The date when a rate becomes effective. Read/write DateTime.
RatesTo | The last date when a rate is effective. Read/write DateTime.
RateTable | The unique identifier of a rate table for a resource. Read/write RateType.
StandardRate | The standard rate for a resource for the specified period. Read/write Decimal.
StandardRateFormat | The units used by Microsoft Project to display the standard rate. Read/write RateFormatType.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Rate Class | Aspose.Tasks Namespace


Rate Constructor

Initializes a new instance of the Rate class.

public Rate();

See Also

Rate Class | Aspose.Tasks Namespace


Rate Properties

The properties of the Rate class are listed below. For a complete list of Rate class members, see the Rate Members topic.

Public Instance Properties

CostPerUse | The cost per use of a resource. This value retrieved from the current date if a rate table exists for a resource. Read/write Decimal.
OvertimeRate | The overtime rate for a resource for the specified period. Read/write Decimal.
OvertimeRateFormat | The units used by Microsoft Project to display the overtime rate. Read/write RateFormatType.
RatesFrom | The date when a rate becomes effective. Read/write DateTime.
RatesTo | The last date when a rate is effective. Read/write DateTime.
RateTable | The unique identifier of a rate table for a resource. Read/write RateType.
StandardRate | The standard rate for a resource for the specified period. Read/write Decimal.
StandardRateFormat | The units used by Microsoft Project to display the standard rate. Read/write RateFormatType.

See Also

Rate Class | Aspose.Tasks Namespace


CostPerUse Property

Rate.CostPerUse Property

The cost per use of a resource. This value retrieved from the current date if a rate table exists for a resource. Read/write Decimal.

public decimal CostPerUse {get; set;}

See Also

Rate Class | Aspose.Tasks Namespace


OvertimeRate Property

Rate.OvertimeRate Property

The overtime rate for a resource for the specified period. Read/write Decimal.

public decimal OvertimeRate {get; set;}

See Also

Rate Class | Aspose.Tasks Namespace


OvertimeRateFormat Property

Rate.OvertimeRateFormat Property

The units used by Microsoft Project to display the overtime rate. Read/write RateFormatType.

public RateFormatType OvertimeRateFormat {get; set;}

See Also

Rate Class | Aspose.Tasks Namespace


RatesFrom Property

Rate.RatesFrom Property

The date when a rate becomes effective. Read/write DateTime.

public DateTime RatesFrom {get; set;}

See Also

Rate Class | Aspose.Tasks Namespace


RatesTo Property

Rate.RatesTo Property

The last date when a rate is effective. Read/write DateTime.

public DateTime RatesTo {get; set;}

See Also

Rate Class | Aspose.Tasks Namespace


RateTable Property

Rate.RateTable Property

The unique identifier of a rate table for a resource. Read/write RateType.

public RateType RateTable {get; set;}

See Also

Rate Class | Aspose.Tasks Namespace


StandardRate Property

Rate.StandardRate Property

The standard rate for a resource for the specified period. Read/write Decimal.

public decimal StandardRate {get; set;}

See Also

Rate Class | Aspose.Tasks Namespace


StandardRateFormat Property

Rate.StandardRateFormat Property

The units used by Microsoft Project to display the standard rate. Read/write RateFormatType.

public RateFormatType StandardRateFormat {get; set;}

See Also

Rate Class | Aspose.Tasks Namespace


RateFormatType Enumeration

Specifies the units used by Microsoft Project to display a rate.

public enum RateFormatType

Remarks

While exporting into XML the Undefined values will be eliminated from resulting XML.

Members

Member Name | Description | Value
Undefined | The value was not defined in original project file. | -1
Minute | Minute ("min") | 0
Hour | Hour ("hr") | 1
Day | Day ("day") | 2
Week | Week ("wk") | 3
Month | Month ("mo") | 4
Year | Year ("yr") | 5
MaterialResourceRate | Material resource rate (empty) | 6

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


RateType Enumeration

Specifies the unique identifiers of a rate table.

public enum RateType

Members

Member Name | Description | Value
Undefined | Undefined value | -1
A | A | 0
B | B | 1
C | C | 2
D | D | 3
E | E | 4

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


Resource Class

Represents a resource in a project.

For a list of all members of this type, see Resource Members.

System.Object
Aspose.Tasks.Resource

public class Resource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Resource Members | Aspose.Tasks Namespace


Resource Members

Resource overview

Public Instance Constructors

Resource Overloaded. Initializes a new instance of the Resource class.

Public Instance Properties

AccrueAt | Determines how cost is accrued against the resource. Read/write CostAccrualType.
ActiveDirectoryGuid | The Active Directory Guid for a resource. Read/write String.
ActualCost | The actual cost incurred by the resource across all assigned tasks. Read/write Decimal.
ActualOvertimeCost | The actual overtime cost incurred by the resource across all assigned tasks. Read/write Decimal.
ActualOvertimeWork | The amount of actual overtime work performed by a resource. Read/write TimeSpan.
ActualOvertimeWorkProtected | The duration through which actual overtime work is protected. Read/write TimeSpan.
ActualWork | The amount of actual work performed by a resource. Read/write TimeSpan.
ActualWorkProtected | The duration through which actual work is protected. Read/write TimeSpan.
Acwp | The actual cost of a work performed by a resource for the project to-date. Read/write Double.
AssignmentOwner | The name of an assignment owner. Read/write String.
AssignmentOwnerGuid | The GUID of an assignment owner. Read/write String.
AvailabilityPeriods | Returns List<AvailabilityPeriod> AvailabilityPeriods. The collection of periods during which a resource is available. Read/write List of AvailabilityPeriod.
AvailableFrom | The first date when a resource is available. Read/write DateTime.
AvailableTo | The last date when a resource is available. Read/write DateTime.
BaseLine | Returns List<Baseline> BaseLine. The baseline values for a resource. Read/write List of Baseline.
Bcwp | The budgeted cost of a work performed by a resource for the project to-date. Read/write Double.
Bcws | The budget cost of a work scheduled for a resource. Read/write Double.
BookingType | The booking type of a resource. Read/write BookingType.
BudgetCost | The budget cost for a budget cost resource. Read/write Decimal
BudgetWork | The budget work for a budget work or material resource. Read/write TimeSpan.
Calendar | The calendar of a resource. Read/write Calendar.
CanLevel | Determines whether a resource can be leveled. Read/write Boolean.
Code | The code or other information about a resource. Read/write String.
Cost | The total project cost for a resource across all assigned tasks. Read/write Decimal.
CostCenter | Indicates which cost center the costs accrued by the resource should be charged to.
CostPerUse | The cost per use of a resource. This value retrieved from the current date if a rate table exists for the resource. Read/write Decimal.
CostVariance | The difference between a baseline cost and a cost. Read/write Double.
CreationDate | The date when a resource was created. Read/write DateTime.
Cv | The earned value cost variance, through the project status date. Read/write Double.
EmailAddress | The email address of a resource. Read/write String.
ExtendedAttribute | The value of an extended attribute. Read/write List of ExtendedAttribute.
Finish | The scheduled finish date of a resource. Read/write DateTime.
Group | The group to which a resource belongs. Read/write String.
Hyperlink | The title of a hyperlink associated with a resource. Read/write String.
HyperlinkAddress | The hyperlink associated with a resource. Read/write String.
HyperlinkSubAddress | The document bookmark of a hyperlink associated with a resource. Read/write String.
Id | The position identifier of a resource within the list of resources. Read/write Int32.
Initials | The initials of a resource. Read/write String.
IsBudget | Determines whether a resource is a budget resource. Read/write Boolean.
IsCostResource | Determines whether a resource is a cost resource. Read/write Boolean.
IsEnterprise | Determines whether a resource is an Enterprise resource. Read/write Boolean.
IsGeneric | Determines whether a resource is generic. Read/write Boolean.
IsInactive | Determines whether a resource is inactive. Read/write Boolean.
IsNull | Determines whether a resource is null. Read/write Boolean.
MaterialLabel | The unit of measure for the material resource. Read/write String.
MaxUnits | The maximum number of units of a resource is available. Read/write Double.
Name | The name of a resource. Read/write String.
Notes | Obsolete. The text notes associated with a resource. Read/write String.
NotesRTF | The text notes in RTF format. Read only String.
NotesText | Notes' plain text extracted from RTF data. Read/write String.
NtAccount | The NT account associated with a resource. Read/write String.
OutlineCode | Returns List<OutlineCode> OutlineCode. The value of an outline code. Read/write List of OutlineCode.
OverAllocated | Determines whether a resource is overallocated. Read/write Boolean.
Overtime | The overtime rate of a resource. Read/write Decimal.
OvertimeCost | The total overtime cost of a resource including actual and remaining overtime costs. Read/write Decimal.
OvertimeRate | The overtime rate of a resource. This value retrieved from the current date if a rate table exists for a resource. Read/write Decimal.
OvertimeRateFormat | The units used by Microsoft Project to display the overtime rate. Read/write RateFormatType.
OvertimeWork | The amount of overtime work assigned to a resource. Read/write TimeSpan.
PeakUnits | The largest number of units assigned to a resource at any time. Read/write Double.
PercentWorkComplete | The percentage of work completed across all tasks. Read/write Int32.
Phonetics | The phonetic spelling of the resource name. For use with Japanese only. Read/write String.
Rates | Returns List<Rate> Rates. The collection of periods and rates associated with each one. Read/write List of Rate.
RegularWork | The amount of non-overtime work assigned to a resource. Read/write TimeSpan.
RemainingCost | The remaining projected cost of a resource to complete all assigned tasks. Read/write Decimal.
RemainingOvertimeCost | The remaining projected overtime cost of a resource to complete all assigned tasks. Read/write Decimal.
RemainingOvertimeWork | The amount of remaining overtime work required to complete all tasks. Read/write TimeSpan.
RemainingWork | The amount of remaining work required to complete all assigned tasks. Read/write TimeSpan.
StandardRate | The standard rate of a resource. This value retrieved from the current date if a rate table exists for a resource. Read/write Decimal.
StandardRateFormat | The units used by Microsoft Project to display the standard rate. Read/write RateFormatType.
Start | The scheduled start date of a resource. Read/write DateTime.
Sv | The earned value schedule variance, through the project status date. Read/write Double.
TeamAssignmentPool | Determines whether the current resource is a team resource.
TimephasedData | Returns List<TimephasedData> TimephasedData. Read/write List of TimephasedData.
Type | The type of a resource. Read/write ResourceType.
Uid | The unique identifier of a resource. Read/write Int32.
Work | The total work assigned to a resource across all assigned tasks. Read/write TimeSpan.
WorkGroup | The type of a workgroup to which a resource belongs. Read/write WorkGroupType.
WorkVariance | The difference between a baseline work and a work Read/write Double.

Public Instance Methods

Delete | Deletes a resource and its assignments from project.
Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TimeScaleData | Overloaded. Returns List<TimephasedData> of timephased data within given start and end dates of specified timephasedDataType.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Resource Class | Aspose.Tasks Namespace


Resource Constructor

Default constructor.

Overload List

Default constructor.

public Resource();

Sets the name of a resource.

public Resource(string);

See Also

Resource Class | Aspose.Tasks Namespace


Resource Constructor ()

Default constructor.

public Resource();

See Also

Resource Class | Aspose.Tasks Namespace | Resource Constructor Overload List


Resource Constructor (String)

Sets the name of a resource.

public Resource(
string name
);

Parameters

name
New resource name.

See Also

Resource Class | Aspose.Tasks Namespace | Resource Constructor Overload List


Resource Properties

The properties of the Resource class are listed below. For a complete list of Resource class members, see the Resource Members topic.

Public Instance Properties

AccrueAt | Determines how cost is accrued against the resource. Read/write CostAccrualType.
ActiveDirectoryGuid | The Active Directory Guid for a resource. Read/write String.
ActualCost | The actual cost incurred by the resource across all assigned tasks. Read/write Decimal.
ActualOvertimeCost | The actual overtime cost incurred by the resource across all assigned tasks. Read/write Decimal.
ActualOvertimeWork | The amount of actual overtime work performed by a resource. Read/write TimeSpan.
ActualOvertimeWorkProtected | The duration through which actual overtime work is protected. Read/write TimeSpan.
ActualWork | The amount of actual work performed by a resource. Read/write TimeSpan.
ActualWorkProtected | The duration through which actual work is protected. Read/write TimeSpan.
Acwp | The actual cost of a work performed by a resource for the project to-date. Read/write Double.
AssignmentOwner | The name of an assignment owner. Read/write String.
AssignmentOwnerGuid | The GUID of an assignment owner. Read/write String.
AvailabilityPeriods | Returns List<AvailabilityPeriod> AvailabilityPeriods. The collection of periods during which a resource is available. Read/write List of AvailabilityPeriod.
AvailableFrom | The first date when a resource is available. Read/write DateTime.
AvailableTo | The last date when a resource is available. Read/write DateTime.
BaseLine | Returns List<Baseline> BaseLine. The baseline values for a resource. Read/write List of Baseline.
Bcwp | The budgeted cost of a work performed by a resource for the project to-date. Read/write Double.
Bcws | The budget cost of a work scheduled for a resource. Read/write Double.
BookingType | The booking type of a resource. Read/write BookingType.
BudgetCost | The budget cost for a budget cost resource. Read/write Decimal
BudgetWork | The budget work for a budget work or material resource. Read/write TimeSpan.
Calendar | The calendar of a resource. Read/write Calendar.
CanLevel | Determines whether a resource can be leveled. Read/write Boolean.
Code | The code or other information about a resource. Read/write String.
Cost | The total project cost for a resource across all assigned tasks. Read/write Decimal.
CostCenter | Indicates which cost center the costs accrued by the resource should be charged to.
CostPerUse | The cost per use of a resource. This value retrieved from the current date if a rate table exists for the resource. Read/write Decimal.
CostVariance | The difference between a baseline cost and a cost. Read/write Double.
CreationDate | The date when a resource was created. Read/write DateTime.
Cv | The earned value cost variance, through the project status date. Read/write Double.
EmailAddress | The email address of a resource. Read/write String.
ExtendedAttribute | The value of an extended attribute. Read/write List of ExtendedAttribute.
Finish | The scheduled finish date of a resource. Read/write DateTime.
Group | The group to which a resource belongs. Read/write String.
Hyperlink | The title of a hyperlink associated with a resource. Read/write String.
HyperlinkAddress | The hyperlink associated with a resource. Read/write String.
HyperlinkSubAddress | The document bookmark of a hyperlink associated with a resource. Read/write String.
Id | The position identifier of a resource within the list of resources. Read/write Int32.
Initials | The initials of a resource. Read/write String.
IsBudget | Determines whether a resource is a budget resource. Read/write Boolean.
IsCostResource | Determines whether a resource is a cost resource. Read/write Boolean.
IsEnterprise | Determines whether a resource is an Enterprise resource. Read/write Boolean.
IsGeneric | Determines whether a resource is generic. Read/write Boolean.
IsInactive | Determines whether a resource is inactive. Read/write Boolean.
IsNull | Determines whether a resource is null. Read/write Boolean.
MaterialLabel | The unit of measure for the material resource. Read/write String.
MaxUnits | The maximum number of units of a resource is available. Read/write Double.
Name | The name of a resource. Read/write String.
Notes | Obsolete. The text notes associated with a resource. Read/write String.
NotesRTF | The text notes in RTF format. Read only String.
NotesText | Notes' plain text extracted from RTF data. Read/write String.
NtAccount | The NT account associated with a resource. Read/write String.
OutlineCode | Returns List<OutlineCode> OutlineCode. The value of an outline code. Read/write List of OutlineCode.
OverAllocated | Determines whether a resource is overallocated. Read/write Boolean.
Overtime | The overtime rate of a resource. Read/write Decimal.
OvertimeCost | The total overtime cost of a resource including actual and remaining overtime costs. Read/write Decimal.
OvertimeRate | The overtime rate of a resource. This value retrieved from the current date if a rate table exists for a resource. Read/write Decimal.
OvertimeRateFormat | The units used by Microsoft Project to display the overtime rate. Read/write RateFormatType.
OvertimeWork | The amount of overtime work assigned to a resource. Read/write TimeSpan.
PeakUnits | The largest number of units assigned to a resource at any time. Read/write Double.
PercentWorkComplete | The percentage of work completed across all tasks. Read/write Int32.
Phonetics | The phonetic spelling of the resource name. For use with Japanese only. Read/write String.
Rates | Returns List<Rate> Rates. The collection of periods and rates associated with each one. Read/write List of Rate.
RegularWork | The amount of non-overtime work assigned to a resource. Read/write TimeSpan.
RemainingCost | The remaining projected cost of a resource to complete all assigned tasks. Read/write Decimal.
RemainingOvertimeCost | The remaining projected overtime cost of a resource to complete all assigned tasks. Read/write Decimal.
RemainingOvertimeWork | The amount of remaining overtime work required to complete all tasks. Read/write TimeSpan.
RemainingWork | The amount of remaining work required to complete all assigned tasks. Read/write TimeSpan.
StandardRate | The standard rate of a resource. This value retrieved from the current date if a rate table exists for a resource. Read/write Decimal.
StandardRateFormat | The units used by Microsoft Project to display the standard rate. Read/write RateFormatType.
Start | The scheduled start date of a resource. Read/write DateTime.
Sv | The earned value schedule variance, through the project status date. Read/write Double.
TeamAssignmentPool | Determines whether the current resource is a team resource.
TimephasedData | Returns List<TimephasedData> TimephasedData. Read/write List of TimephasedData.
Type | The type of a resource. Read/write ResourceType.
Uid | The unique identifier of a resource. Read/write Int32.
Work | The total work assigned to a resource across all assigned tasks. Read/write TimeSpan.
WorkGroup | The type of a workgroup to which a resource belongs. Read/write WorkGroupType.
WorkVariance | The difference between a baseline work and a work Read/write Double.

See Also

Resource Class | Aspose.Tasks Namespace


AccrueAt Property

Resource.AccrueAt Property

Determines how cost is accrued against the resource. Read/write CostAccrualType.

public CostAccrualType AccrueAt {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


ActiveDirectoryGuid Property

Resource.ActiveDirectoryGuid Property

The Active Directory Guid for a resource. Read/write String.

public string ActiveDirectoryGuid {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


ActualCost Property

Resource.ActualCost Property

The actual cost incurred by the resource across all assigned tasks. Read/write Decimal.

public decimal ActualCost {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


ActualOvertimeCost Property

Resource.ActualOvertimeCost Property

The actual overtime cost incurred by the resource across all assigned tasks. Read/write Decimal.

public decimal ActualOvertimeCost {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


ActualOvertimeWork Property

Resource.ActualOvertimeWork Property

The amount of actual overtime work performed by a resource. Read/write TimeSpan.

public TimeSpan ActualOvertimeWork {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


ActualOvertimeWorkProtected Property

Resource.ActualOvertimeWorkProtected Property

The duration through which actual overtime work is protected. Read/write TimeSpan.

public TimeSpan ActualOvertimeWorkProtected {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


ActualWork Property

Resource.ActualWork Property

The amount of actual work performed by a resource. Read/write TimeSpan.

public TimeSpan ActualWork {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


ActualWorkProtected Property

Resource.ActualWorkProtected Property

The duration through which actual work is protected. Read/write TimeSpan.

public TimeSpan ActualWorkProtected {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


Acwp Property

Resource.Acwp Property

The actual cost of a work performed by a resource for the project to-date. Read/write Double.

public double Acwp {get; set;}

Remarks

Still have differences with MS Project in some cases.

See Also

Resource Class | Aspose.Tasks Namespace


AssignmentOwner Property

Resource.AssignmentOwner Property

The name of an assignment owner. Read/write String.

public string AssignmentOwner {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


AssignmentOwnerGuid Property

Resource.AssignmentOwnerGuid Property

The GUID of an assignment owner. Read/write String.

public string AssignmentOwnerGuid {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


AvailabilityPeriods Property

Resource.AvailabilityPeriods Property

Returns List<AvailabilityPeriod> AvailabilityPeriods. The collection of periods during which a resource is available. Read/write List of AvailabilityPeriod.

public AvailabilityPeriod} AvailabilityPeriods {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


AvailableFrom Property

Resource.AvailableFrom Property

The first date when a resource is available. Read/write DateTime.

public DateTime AvailableFrom {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


AvailableTo Property

Resource.AvailableTo Property

The last date when a resource is available. Read/write DateTime.

public DateTime AvailableTo {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


BaseLine Property

Resource.BaseLine Property

Returns List<Baseline> BaseLine. The baseline values for a resource. Read/write List of Baseline.

public Baseline} BaseLine {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Bcwp Property

Resource.Bcwp Property

The budgeted cost of a work performed by a resource for the project to-date. Read/write Double.

public double Bcwp {get; set;}

Remarks

Still have differences with MS Project in some cases.

See Also

Resource Class | Aspose.Tasks Namespace


Bcws Property

Resource.Bcws Property

The budget cost of a work scheduled for a resource. Read/write Double.

public double Bcws {get; set;}

Remarks

Still have differences with MS Project in some cases.

See Also

Resource Class | Aspose.Tasks Namespace


BookingType Property

Resource.BookingType Property

The booking type of a resource. Read/write BookingType.

public BookingType BookingType {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


BudgetCost Property

Resource.BudgetCost Property

The budget cost for a budget cost resource. Read/write Decimal

public decimal BudgetCost {get;}

See Also

Resource Class | Aspose.Tasks Namespace


BudgetWork Property

Resource.BudgetWork Property

The budget work for a budget work or material resource. Read/write TimeSpan.

public TimeSpan BudgetWork {get;}

See Also

Resource Class | Aspose.Tasks Namespace


Calendar Property

Resource.Calendar Property

The calendar of a resource. Read/write Calendar.

public Calendar Calendar {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


CanLevel Property

Resource.CanLevel Property

Determines whether a resource can be leveled. Read/write Boolean.

public bool CanLevel {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Code Property

Resource.Code Property

The code or other information about a resource. Read/write String.

public string Code {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Cost Property

Resource.Cost Property

The total project cost for a resource across all assigned tasks. Read/write Decimal.

public decimal Cost {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


CostCenter Property

Resource.CostCenter Property

Indicates which cost center the costs accrued by the resource should be charged to.

public string CostCenter {get; set;}

Remarks

New for MS Project 2007 property.

See Also

Resource Class | Aspose.Tasks Namespace


CostPerUse Property

Resource.CostPerUse Property

The cost per use of a resource. This value retrieved from the current date if a rate table exists for the resource. Read/write Decimal.

public decimal CostPerUse {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


CostVariance Property

Resource.CostVariance Property

The difference between a baseline cost and a cost. Read/write Double.

public double CostVariance {get; set;}

Remarks

Reading supported for XML and MS Project 2007/2010 MPP formats only.

See Also

Resource Class | Aspose.Tasks Namespace


CreationDate Property

Resource.CreationDate Property

The date when a resource was created. Read/write DateTime.

public DateTime CreationDate {get; set;}

Remarks

Reading supported for XML and MPP 2003 formats only.

See Also

Resource Class | Aspose.Tasks Namespace


Cv Property

Resource.Cv Property

The earned value cost variance, through the project status date. Read/write Double.

public double Cv {get; set;}

Remarks

Still have some differences with MS Project for some cases.

See Also

Resource Class | Aspose.Tasks Namespace


EmailAddress Property

Resource.EmailAddress Property

The email address of a resource. Read/write String.

public string EmailAddress {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


ExtendedAttribute Property

Resource.ExtendedAttribute Property

The value of an extended attribute. Read/write List of ExtendedAttribute.

public ExtendedAttribute} ExtendedAttribute {get; set;}

Remarks

Two pieces of data are necessary - a pointer back to the extended attribute table which is specified either by the unique ID or the Field ID, and the value which is specified either with the value, or a pointer back to the value list.

See Also

Resource Class | Aspose.Tasks Namespace


Finish Property

Resource.Finish Property

The scheduled finish date of a resource. Read/write DateTime.

public DateTime Finish {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


Group Property

Resource.Group Property

The group to which a resource belongs. Read/write String.

public string Group {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Hyperlink Property

Resource.Hyperlink Property

The title of a hyperlink associated with a resource. Read/write String.

public string Hyperlink {get; set;}

Remarks

Reading supported for XML and MS Project 2007/2010 MPP formats only.

See Also

Resource Class | Aspose.Tasks Namespace


HyperlinkAddress Property

Resource.HyperlinkAddress Property

The hyperlink associated with a resource. Read/write String.

public string HyperlinkAddress {get; set;}

Remarks

Reading supported for XML and MS Project 2007/2010 MPP formats only.

See Also

Resource Class | Aspose.Tasks Namespace


HyperlinkSubAddress Property

Resource.HyperlinkSubAddress Property

The document bookmark of a hyperlink associated with a resource. Read/write String.

public string HyperlinkSubAddress {get; set;}

Remarks

Reading supported for XML and MS Project 2007/2010 MPP formats only.

See Also

Resource Class | Aspose.Tasks Namespace


Id Property

Resource.Id Property

The position identifier of a resource within the list of resources. Read/write Int32.

public int Id {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Initials Property

Resource.Initials Property

The initials of a resource. Read/write String.

public string Initials {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


IsBudget Property

Resource.IsBudget Property

Determines whether a resource is a budget resource. Read/write Boolean.

public bool IsBudget {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


IsCostResource Property

Resource.IsCostResource Property

Determines whether a resource is a cost resource. Read/write Boolean.

public bool IsCostResource {get; set;}

Remarks

New for MS Project 2007 property.

See Also

Resource Class | Aspose.Tasks Namespace


IsEnterprise Property

Resource.IsEnterprise Property

Determines whether a resource is an Enterprise resource. Read/write Boolean.

public bool IsEnterprise {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


IsGeneric Property

Resource.IsGeneric Property

Determines whether a resource is generic. Read/write Boolean.

public bool IsGeneric {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


IsInactive Property

Resource.IsInactive Property

Determines whether a resource is inactive. Read/write Boolean.

public bool IsInactive {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


IsNull Property

Resource.IsNull Property

Determines whether a resource is null. Read/write Boolean.

public bool IsNull {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


MaterialLabel Property

Resource.MaterialLabel Property

The unit of measure for the material resource. Read/write String.

public string MaterialLabel {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


MaxUnits Property

Resource.MaxUnits Property

The maximum number of units of a resource is available. Read/write Double.

public double MaxUnits {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Name Property

Resource.Name Property

The name of a resource. Read/write String.

public string Name {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Notes Property

Resource.Notes Property

NOTE: This property is now obsolete.

Use NotesText or NotesRTF instead.

The text notes associated with a resource. Read/write String.

public string Notes {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


NotesRTF Property

Resource.NotesRTF Property

The text notes in RTF format. Read only String.

public string NotesRTF {get;}

Remarks

Supported for MPP formats only.

See Also

Resource Class | Aspose.Tasks Namespace


NotesText Property

Resource.NotesText Property

Notes' plain text extracted from RTF data. Read/write String.

public string NotesText {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


NtAccount Property

Resource.NtAccount Property

The NT account associated with a resource. Read/write String.

public string NtAccount {get; set;}

Remarks

Reading supported for XML and MS Project 2007/2010 MPP formats only.

See Also

Resource Class | Aspose.Tasks Namespace


OutlineCode Property

Resource.OutlineCode Property

Returns List<OutlineCode> OutlineCode. The value of an outline code. Read/write List of OutlineCode.

public OutlineCode} OutlineCode {get; set;}

Remarks

Two pieces of data are necessary - a pointer to the outline code table that is specified by the FieldID, and the value that is specified either by the ValueID or ValueGUID pointer to the value list.

See Also

Resource Class | Aspose.Tasks Namespace


OverAllocated Property

Resource.OverAllocated Property

Determines whether a resource is overallocated. Read/write Boolean.

public bool OverAllocated {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Overtime Property

Resource.Overtime Property

The overtime rate of a resource. Read/write Decimal.

public decimal Overtime {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


OvertimeCost Property

Resource.OvertimeCost Property

The total overtime cost of a resource including actual and remaining overtime costs. Read/write Decimal.

public decimal OvertimeCost {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


OvertimeRate Property

Resource.OvertimeRate Property

The overtime rate of a resource. This value retrieved from the current date if a rate table exists for a resource. Read/write Decimal.

public decimal OvertimeRate {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


OvertimeRateFormat Property

Resource.OvertimeRateFormat Property

The units used by Microsoft Project to display the overtime rate. Read/write RateFormatType.

public RateFormatType OvertimeRateFormat {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


OvertimeWork Property

Resource.OvertimeWork Property

The amount of overtime work assigned to a resource. Read/write TimeSpan.

public TimeSpan OvertimeWork {get; set;}

Remarks

Reading supported for XML and MS Project 2007/2010 MPP formats only.

See Also

Resource Class | Aspose.Tasks Namespace


PeakUnits Property

Resource.PeakUnits Property

The largest number of units assigned to a resource at any time. Read/write Double.

public double PeakUnits {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


PercentWorkComplete Property

Resource.PercentWorkComplete Property

The percentage of work completed across all tasks. Read/write Int32.

public int PercentWorkComplete {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Phonetics Property

Resource.Phonetics Property

The phonetic spelling of the resource name. For use with Japanese only. Read/write String.

public string Phonetics {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Rates Property

Resource.Rates Property

Returns List<Rate> Rates. The collection of periods and rates associated with each one. Read/write List of Rate.

public Rate} Rates {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


RegularWork Property

Resource.RegularWork Property

The amount of non-overtime work assigned to a resource. Read/write TimeSpan.

public TimeSpan RegularWork {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


RemainingCost Property

Resource.RemainingCost Property

The remaining projected cost of a resource to complete all assigned tasks. Read/write Decimal.

public decimal RemainingCost {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


RemainingOvertimeCost Property

Resource.RemainingOvertimeCost Property

The remaining projected overtime cost of a resource to complete all assigned tasks. Read/write Decimal.

public decimal RemainingOvertimeCost {get; set;}

Remarks

Reading supported for XML and MS Project 2003 MPP formats only.

See Also

Resource Class | Aspose.Tasks Namespace


RemainingOvertimeWork Property

Resource.RemainingOvertimeWork Property

The amount of remaining overtime work required to complete all tasks. Read/write TimeSpan.

public TimeSpan RemainingOvertimeWork {get; set;}

Remarks

Reading supported for XML and MS Project 2007/2010 MPP formats only.

See Also

Resource Class | Aspose.Tasks Namespace


RemainingWork Property

Resource.RemainingWork Property

The amount of remaining work required to complete all assigned tasks. Read/write TimeSpan.

public TimeSpan RemainingWork {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


StandardRate Property

Resource.StandardRate Property

The standard rate of a resource. This value retrieved from the current date if a rate table exists for a resource. Read/write Decimal.

public decimal StandardRate {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


StandardRateFormat Property

Resource.StandardRateFormat Property

The units used by Microsoft Project to display the standard rate. Read/write RateFormatType.

public RateFormatType StandardRateFormat {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Start Property

Resource.Start Property

The scheduled start date of a resource. Read/write DateTime.

public DateTime Start {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


Sv Property

Resource.Sv Property

The earned value schedule variance, through the project status date. Read/write Double.

public double Sv {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


TeamAssignmentPool Property

Resource.TeamAssignmentPool Property

Determines whether the current resource is a team resource.

public bool TeamAssignmentPool {get; set;}

Remarks

New for MS Project 2007 property (Project Professional mpp only).

See Also

Resource Class | Aspose.Tasks Namespace


TimephasedData Property

Resource.TimephasedData Property

Returns List<TimephasedData> TimephasedData. Read/write List of TimephasedData.

public TimephasedData} TimephasedData {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


Type Property

Resource.Type Property

The type of a resource. Read/write ResourceType.

public ResourceType Type {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Uid Property

Resource.Uid Property

The unique identifier of a resource. Read/write Int32.

public int Uid {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


Work Property

Resource.Work Property

The total work assigned to a resource across all assigned tasks. Read/write TimeSpan.

public TimeSpan Work {get; set;}

See Also

Resource Class | Aspose.Tasks Namespace


WorkGroup Property

Resource.WorkGroup Property

The type of a workgroup to which a resource belongs. Read/write WorkGroupType.

public WorkGroupType WorkGroup {get; set;}

Remarks

Reading supported for XML format only.

See Also

Resource Class | Aspose.Tasks Namespace


WorkVariance Property

Resource.WorkVariance Property

The difference between a baseline work and a work Read/write Double.

public double WorkVariance {get; set;}

Remarks

Reading supported for XML and MS Project 2007/2010 MPP formats only.

See Also

Resource Class | Aspose.Tasks Namespace


Resource Methods

The methods of the Resource class are listed below. For a complete list of Resource class members, see the Resource Members topic.

Public Instance Methods

Delete | Deletes a resource and its assignments from project.
Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
TimeScaleData | Overloaded. Returns List<TimephasedData> of timephased data within given start and end dates of specified timephasedDataType.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Resource Class | Aspose.Tasks Namespace


Resource.Delete Method

Deletes a resource and its assignments from project.

public void Delete();

See Also

Resource Class | Aspose.Tasks Namespace


Resource.Equals Method

Returns a value indicating whether this instance is equal to a specified object.

public override bool Equals(
object obj
);

Parameters

obj
The object to compare with this instance.

Return Value

True if obj is a Resource that has the same Uid value as this instance; otherwise, false.

See Also

Resource Class | Aspose.Tasks Namespace


TimeScaleData Method

Resource.TimeScaleData Method

Returns List<TimephasedData> of timephased data within given start and end dates of ResourceTimeScaledData.TaskTimescaledWork type.

Overload List

Returns List<TimephasedData> of timephased data within given start and end dates of ResourceTimeScaledData.TaskTimescaledWork type.

public TimephasedData} TimeScaleData(DateTime,DateTime);

Returns List<TimephasedData> of timephased data within given start and end dates of specified timephasedDataType.

public TimephasedData} TimeScaleData(DateTime,DateTime,TimephasedDataType);

See Also

Resource Class | Aspose.Tasks Namespace


Resource.TimeScaleData Method (DateTime, DateTime)

Returns List<TimephasedData> of timephased data within given start and end dates of ResourceTimeScaledData.TaskTimescaledWork type.

public List<TimephasedData> TimeScaleData(
DateTime start,
DateTime end
);

Parameters

start
The start date for the timephased data.
end
The end date for the timephased data.

Return Value

List of TimephasedData.

See Also

Resource Class | Aspose.Tasks Namespace | Resource.TimeScaleData Overload List


Resource.TimeScaleData Method (DateTime, DateTime, TimephasedDataType)

Returns List<TimephasedData> of timephased data within given start and end dates of specified timephasedDataType.

public List<TimephasedData> TimeScaleData(
DateTime start,
DateTime end,
TimephasedDataType timephasedType
);

Parameters

start
The start date for the timephased data.
end
The end date for the timephased data.
timephasedType
The type of timephased data (TimephasedDataType).

Return Value

List of TimephasedData.

See Also

Resource Class | Aspose.Tasks Namespace | Resource.TimeScaleData Overload List


ResourceAssignment Class

Represents a resource assignment.

For a list of all members of this type, see ResourceAssignment Members.

System.Object
Aspose.Tasks.ResourceAssignment

public class ResourceAssignment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
// create resource
Resource resource = new Resource("Fred");
resource.Type = ResourceType.Work;
resource.Calendar = Calendar.MakeStandardCalendar();
// create task
Task task = new Task("Task1", new TimeSpan(16, 0, 0));
task.RemainingDuration = new TimeSpan(16, 0, 0);
task.Start = new DateTime(2001, 5, 13, 9, 0, 0);
// assign
ResourceAssignment resourceAssignment = new ResourceAssignment(task, resource);
// create timephased data
resourceAssignment.TimephasedDataFromTaskDuration(task.Calendar);

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ResourceAssignment Members | Aspose.Tasks Namespace


ResourceAssignment Members

ResourceAssignment overview

Public Instance Constructors

ResourceAssignment Overloaded. Initializes a new instance of the ResourceAssignment class.

Public Instance Properties

ActualCost | Returns or sets the actual cost incurred on an assignment. Read/write Decimal.
ActualFinish | Returns or sets the actual finish date of an assignment. Read/write DateTime.
ActualOvertimeCost | Returns or sets the actual overtime cost incurred on an assignment. Read/write Decimal.
ActualOvertimeWork | Returns or sets the actual amount of an overtime work incurred on an assignment. Read/write TimeSpan.
ActualOvertimeWorkProtected | Returns or sets the duration through which actual overtime work is protected. Read/write TimeSpan.
ActualStart | Returns or sets the actual start date of an assignment. Read/write DateTime.
ActualWork | Returns or sets the actual amount of a work incurred on an assignment. Read/write TimeSpan.
ActualWorkProtected | Returns or sets the duration through which actual work is protected. Read/write TimeSpan.
Acwp | Returns or sets the actual cost of a work performed on an assignment to-date. Read/write Double.
AssnOwner | Returns or sets the name of an assignment owner. Read/write String.
AssnOwnerGuid | Returns or sets the Guid of an assignment owner. Read/write String.
Baseline | Returns List<AssignmentBaseline> AssignmentBaseline. The collection of baseline values associated with an assignment. Read/write List of AssignmentBaseline.
Bcwp | Returns or sets the budgeted cost of a work performed on assignment to-date. Read/write Double.
Bcws | Returns or sets the budgeted cost of a work on assignment. Read/write Double.
BookingType | Returns or sets the booking type of an assignment. Read/write BookingType.
BudgetCost | Returns or sets the budgeted cost of resources on an assignment. Read/write Decimal.
BudgetWork | Returns or sets the budgeted work amount for a work or material resources on an assignment. Read/write TimeSpan.
Confirmed | Determines whether a resource has accepted all of its assignments. Read/write Boolean.
Cost | Returns or sets the projected or scheduled cost of an assignment. Read/write Decimal.
CostRateTable | Obsolete. Returns or sets the cost rate table used for an assignment. Read/write Int32.
CostRateTableType | Returns or sets the cost rate table used for this assignment. Resd/write RateType.
CostVariance | Returns or sets the difference between the cost and baseline cost of a resource. Read/write Double.
CreationDate | Returns or sets the date that the assignment was created. Read/write DateTime.
Cv | Returns or sets the earned value cost variance. Read/write Double.
Delay | Returns or sets the delay of an assignment. Read/write Int32.
ExtendedAttribute | Returns List<ExtendedAttibute> ExtendedAttribute. Read/write List of ExtendedAttribute.
Finish | Returns or sets the scheduled finish date of an assignment. Read/write DateTime.
FinishVariance | Returns or sets the variance of an assignment finish date from a baseline finish date. Read/write Int32.
FixedMaterial | Determines whether the consumption of an assigned material resource occurs in a single, fixed amount. Read/write Boolean.
HasFixedRateUnits | Determines whether the Units have Fixed Rate. Read/write Boolean.
Hyperlink | Returns or sets the title of the hyperlink associated with an assignment. Read/write String.
HyperlinkAddress | Returns or sets the hyperlink associated with an assignment. Read/write String.
HyperlinkSubAddress | Returns or sets the document bookmark of the hyperlink associated with an assignment. Read/write String.
LevelingDelay | Returns or sets the delay caused by leveling. Read/write Int32.
LevelingDelayFormat | Returns or sets the duration format of a delay. Read/write TimeUnitType.
LinkedFields | Determines whether the Project is linked to another OLE object. Read/write Boolean.
Milestone | Determines whether the assignment is a milestone. Read/write Boolean.
Notes | Returns or sets the text notes associated with an assignment. Read/write String.
Overallocated | Determines whether the assignment is overallocated. Read/write Boolean.
OvertimeCost | Returns or sets the sum of the actual and remaining overtime cost of an assignment. Read/write Decimal.
OvertimeWork | Returns or sets the scheduled overtime work of an assignment. Read/write TimeSpan.
PeakUnits | Returns or sets the largest number of a resource's units assigned to a task. Read/write Double.
PercentWorkComplete | Returns or sets the amount of a work completed on an assignment. Read/write Int32.
RateScale | Returns the time unit for the usage rate of the material resource assignment. Read/write Int32.
RegularWork | Returns or sets the amount of a non-overtime work scheduled for an assignment. Read/write TimeSpan.
RemainingCost | Returns or sets the remaining projected cost of completing an assignment. Read/write Decimal.
RemainingOvertimeCost | Returns or sets the remaining projected overtime cost of completing an assignment. Read/write Decimal.
RemainingOvertimeWork | Returns or sets the remaining overtime work scheduled to complete an assignment. Read/write TimeSpan.
RemainingWork | Returns or sets the remaining work scheduled to complete an assignment. Read/write TimeSpan.
Resource | Returns or sets the resource assigned to a task. Read/write Resource.
ResponsePending | Determines whether the response has been received for a TeamAssign message. Read/write Boolean.
Resume | Returns or sets the date when assignment is resumed. Read/write DateTime.
Start | Returns or sets the scheduled start date of an assignment. Read/write DateTime.
StartVariance | Returns or sets the variance of an assignment start date from a baseline start date. Read/write Int32.
Stop | Returns or sets the date when assignment is stopped. Read/write DateTime.
Summary | Determines whether the task is a summary task. Read/write Boolean.
Sv | Returns or sets the earned value schedule variance, through the project status date. Read/write Double.
Task | Returns or sets the task to which a resource is assigned. Read/write Task.
TimephasedData | Returns List<TimephasedData> TimephasedData. Read/write List of TimephasedData.
Uid | Returns or sets the unique identifier of an assignment. Read/write Int32.
Units | Returns or sets the number of units for an assignment. Read/write Double.
UpdateNeeded | Determines whether the resource assigned to a task needs to be updated as to the status of the task. Read/write Boolean.
Vac | Returns or sets the difference between basline cost and total cost. Read/write Double.
Work | Returns or sets the amount of scheduled work for an assignment. Read/write TimeSpan.
WorkContour | Returns or sets the work contour of an assignment. Read/write WorkContourType.
WorkVariance | Returns or sets the variance of an assignment work from the baseline work as minutes. Read/write Double.

Public Instance Methods

Delete | Deletes resource assignment from project assignments collection.
Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeTPs | Overloaded. Generates a list of TimephasedData.
SplitTask | Splits task into two parts.
TimephasedDataFromTaskDuration | Generates list of TimephasedData basen on the task duration and the scheduled start date.
TimeScaleData | Overloaded. Returns list of timephased data within given start and end dates of specified TimephasedDataType.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ResourceAssignment Constructor

Default constructor.

Overload List

Default constructor.

public ResourceAssignment();

Creates the resource assignment to a task.

public ResourceAssignment(Task,Resource);

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ResourceAssignment Constructor ()

Default constructor.

public ResourceAssignment();

See Also

ResourceAssignment Class | Aspose.Tasks Namespace | ResourceAssignment Constructor Overload List


ResourceAssignment Constructor (Task, Resource)

Creates the resource assignment to a task.

public ResourceAssignment(
Task task,
Resource resource
);

Parameters

task
task
resource
resource

See Also

ResourceAssignment Class | Aspose.Tasks Namespace | ResourceAssignment Constructor Overload List


ResourceAssignment Properties

The properties of the ResourceAssignment class are listed below. For a complete list of ResourceAssignment class members, see the ResourceAssignment Members topic.

Public Instance Properties

ActualCost | Returns or sets the actual cost incurred on an assignment. Read/write Decimal.
ActualFinish | Returns or sets the actual finish date of an assignment. Read/write DateTime.
ActualOvertimeCost | Returns or sets the actual overtime cost incurred on an assignment. Read/write Decimal.
ActualOvertimeWork | Returns or sets the actual amount of an overtime work incurred on an assignment. Read/write TimeSpan.
ActualOvertimeWorkProtected | Returns or sets the duration through which actual overtime work is protected. Read/write TimeSpan.
ActualStart | Returns or sets the actual start date of an assignment. Read/write DateTime.
ActualWork | Returns or sets the actual amount of a work incurred on an assignment. Read/write TimeSpan.
ActualWorkProtected | Returns or sets the duration through which actual work is protected. Read/write TimeSpan.
Acwp | Returns or sets the actual cost of a work performed on an assignment to-date. Read/write Double.
AssnOwner | Returns or sets the name of an assignment owner. Read/write String.
AssnOwnerGuid | Returns or sets the Guid of an assignment owner. Read/write String.
Baseline | Returns List<AssignmentBaseline> AssignmentBaseline. The collection of baseline values associated with an assignment. Read/write List of AssignmentBaseline.
Bcwp | Returns or sets the budgeted cost of a work performed on assignment to-date. Read/write Double.
Bcws | Returns or sets the budgeted cost of a work on assignment. Read/write Double.
BookingType | Returns or sets the booking type of an assignment. Read/write BookingType.
BudgetCost | Returns or sets the budgeted cost of resources on an assignment. Read/write Decimal.
BudgetWork | Returns or sets the budgeted work amount for a work or material resources on an assignment. Read/write TimeSpan.
Confirmed | Determines whether a resource has accepted all of its assignments. Read/write Boolean.
Cost | Returns or sets the projected or scheduled cost of an assignment. Read/write Decimal.
CostRateTable | Obsolete. Returns or sets the cost rate table used for an assignment. Read/write Int32.
CostRateTableType | Returns or sets the cost rate table used for this assignment. Resd/write RateType.
CostVariance | Returns or sets the difference between the cost and baseline cost of a resource. Read/write Double.
CreationDate | Returns or sets the date that the assignment was created. Read/write DateTime.
Cv | Returns or sets the earned value cost variance. Read/write Double.
Delay | Returns or sets the delay of an assignment. Read/write Int32.
ExtendedAttribute | Returns List<ExtendedAttibute> ExtendedAttribute. Read/write List of ExtendedAttribute.
Finish | Returns or sets the scheduled finish date of an assignment. Read/write DateTime.
FinishVariance | Returns or sets the variance of an assignment finish date from a baseline finish date. Read/write Int32.
FixedMaterial | Determines whether the consumption of an assigned material resource occurs in a single, fixed amount. Read/write Boolean.
HasFixedRateUnits | Determines whether the Units have Fixed Rate. Read/write Boolean.
Hyperlink | Returns or sets the title of the hyperlink associated with an assignment. Read/write String.
HyperlinkAddress | Returns or sets the hyperlink associated with an assignment. Read/write String.
HyperlinkSubAddress | Returns or sets the document bookmark of the hyperlink associated with an assignment. Read/write String.
LevelingDelay | Returns or sets the delay caused by leveling. Read/write Int32.
LevelingDelayFormat | Returns or sets the duration format of a delay. Read/write TimeUnitType.
LinkedFields | Determines whether the Project is linked to another OLE object. Read/write Boolean.
Milestone | Determines whether the assignment is a milestone. Read/write Boolean.
Notes | Returns or sets the text notes associated with an assignment. Read/write String.
Overallocated | Determines whether the assignment is overallocated. Read/write Boolean.
OvertimeCost | Returns or sets the sum of the actual and remaining overtime cost of an assignment. Read/write Decimal.
OvertimeWork | Returns or sets the scheduled overtime work of an assignment. Read/write TimeSpan.
PeakUnits | Returns or sets the largest number of a resource's units assigned to a task. Read/write Double.
PercentWorkComplete | Returns or sets the amount of a work completed on an assignment. Read/write Int32.
RateScale | Returns the time unit for the usage rate of the material resource assignment. Read/write Int32.
RegularWork | Returns or sets the amount of a non-overtime work scheduled for an assignment. Read/write TimeSpan.
RemainingCost | Returns or sets the remaining projected cost of completing an assignment. Read/write Decimal.
RemainingOvertimeCost | Returns or sets the remaining projected overtime cost of completing an assignment. Read/write Decimal.
RemainingOvertimeWork | Returns or sets the remaining overtime work scheduled to complete an assignment. Read/write TimeSpan.
RemainingWork | Returns or sets the remaining work scheduled to complete an assignment. Read/write TimeSpan.
Resource | Returns or sets the resource assigned to a task. Read/write Resource.
ResponsePending | Determines whether the response has been received for a TeamAssign message. Read/write Boolean.
Resume | Returns or sets the date when assignment is resumed. Read/write DateTime.
Start | Returns or sets the scheduled start date of an assignment. Read/write DateTime.
StartVariance | Returns or sets the variance of an assignment start date from a baseline start date. Read/write Int32.
Stop | Returns or sets the date when assignment is stopped. Read/write DateTime.
Summary | Determines whether the task is a summary task. Read/write Boolean.
Sv | Returns or sets the earned value schedule variance, through the project status date. Read/write Double.
Task | Returns or sets the task to which a resource is assigned. Read/write Task.
TimephasedData | Returns List<TimephasedData> TimephasedData. Read/write List of TimephasedData.
Uid | Returns or sets the unique identifier of an assignment. Read/write Int32.
Units | Returns or sets the number of units for an assignment. Read/write Double.
UpdateNeeded | Determines whether the resource assigned to a task needs to be updated as to the status of the task. Read/write Boolean.
Vac | Returns or sets the difference between basline cost and total cost. Read/write Double.
Work | Returns or sets the amount of scheduled work for an assignment. Read/write TimeSpan.
WorkContour | Returns or sets the work contour of an assignment. Read/write WorkContourType.
WorkVariance | Returns or sets the variance of an assignment work from the baseline work as minutes. Read/write Double.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ActualCost Property

ResourceAssignment.ActualCost Property

Returns or sets the actual cost incurred on an assignment. Read/write Decimal.

public decimal ActualCost {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ActualFinish Property

ResourceAssignment.ActualFinish Property

Returns or sets the actual finish date of an assignment. Read/write DateTime.

public DateTime ActualFinish {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ActualOvertimeCost Property

ResourceAssignment.ActualOvertimeCost Property

Returns or sets the actual overtime cost incurred on an assignment. Read/write Decimal.

public decimal ActualOvertimeCost {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ActualOvertimeWork Property

ResourceAssignment.ActualOvertimeWork Property

Returns or sets the actual amount of an overtime work incurred on an assignment. Read/write TimeSpan.

public TimeSpan ActualOvertimeWork {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ActualOvertimeWorkProtected Property

ResourceAssignment.ActualOvertimeWorkProtected Property

Returns or sets the duration through which actual overtime work is protected. Read/write TimeSpan.

public TimeSpan ActualOvertimeWorkProtected {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ActualStart Property

ResourceAssignment.ActualStart Property

Returns or sets the actual start date of an assignment. Read/write DateTime.

public DateTime ActualStart {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ActualWork Property

ResourceAssignment.ActualWork Property

Returns or sets the actual amount of a work incurred on an assignment. Read/write TimeSpan.

public TimeSpan ActualWork {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ActualWorkProtected Property

ResourceAssignment.ActualWorkProtected Property

Returns or sets the duration through which actual work is protected. Read/write TimeSpan.

public TimeSpan ActualWorkProtected {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Acwp Property

ResourceAssignment.Acwp Property

Returns or sets the actual cost of a work performed on an assignment to-date. Read/write Double.

public double Acwp {get; set;}

Remarks

Still have differences with MS Project in some cases.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


AssnOwner Property

ResourceAssignment.AssnOwner Property

Returns or sets the name of an assignment owner. Read/write String.

public string AssnOwner {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


AssnOwnerGuid Property

ResourceAssignment.AssnOwnerGuid Property

Returns or sets the Guid of an assignment owner. Read/write String.

public string AssnOwnerGuid {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Baseline Property

ResourceAssignment.Baseline Property

Returns List<AssignmentBaseline> AssignmentBaseline. The collection of baseline values associated with an assignment. Read/write List of AssignmentBaseline.

public AssignmentBaseline} Baseline {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Bcwp Property

ResourceAssignment.Bcwp Property

Returns or sets the budgeted cost of a work performed on assignment to-date. Read/write Double.

public double Bcwp {get; set;}

Remarks

Still have differences with MS Project in some cases.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Bcws Property

ResourceAssignment.Bcws Property

Returns or sets the budgeted cost of a work on assignment. Read/write Double.

public double Bcws {get; set;}

Remarks

Still have differences with MS Project in some cases.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


BookingType Property

ResourceAssignment.BookingType Property

Returns or sets the booking type of an assignment. Read/write BookingType.

public BookingType BookingType {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


BudgetCost Property

ResourceAssignment.BudgetCost Property

Returns or sets the budgeted cost of resources on an assignment. Read/write Decimal.

public decimal BudgetCost {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


BudgetWork Property

ResourceAssignment.BudgetWork Property

Returns or sets the budgeted work amount for a work or material resources on an assignment. Read/write TimeSpan.

public TimeSpan BudgetWork {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Confirmed Property

ResourceAssignment.Confirmed Property

Determines whether a resource has accepted all of its assignments. Read/write Boolean.

public bool Confirmed {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Cost Property

ResourceAssignment.Cost Property

Returns or sets the projected or scheduled cost of an assignment. Read/write Decimal.

public decimal Cost {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


CostRateTable Property

ResourceAssignment.CostRateTable Property

NOTE: This property is now obsolete.

Use CostRateTableType instead of it.

Returns or sets the cost rate table used for an assignment. Read/write Int32.

public int CostRateTable {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


CostRateTableType Property

ResourceAssignment.CostRateTableType Property

Returns or sets the cost rate table used for this assignment. Resd/write RateType.

public RateType CostRateTableType {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


CostVariance Property

ResourceAssignment.CostVariance Property

Returns or sets the difference between the cost and baseline cost of a resource. Read/write Double.

public double CostVariance {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


CreationDate Property

ResourceAssignment.CreationDate Property

Returns or sets the date that the assignment was created. Read/write DateTime.

public DateTime CreationDate {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Cv Property

ResourceAssignment.Cv Property

Returns or sets the earned value cost variance. Read/write Double.

public double Cv {get; set;}

Remarks

Still have differences with MS Project in some cases.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Delay Property

ResourceAssignment.Delay Property

Returns or sets the delay of an assignment. Read/write Int32.

public int Delay {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ExtendedAttribute Property

ResourceAssignment.ExtendedAttribute Property

Returns List<ExtendedAttibute> ExtendedAttribute. Read/write List of ExtendedAttribute.

public ExtendedAttribute} ExtendedAttribute {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Finish Property

ResourceAssignment.Finish Property

Returns or sets the scheduled finish date of an assignment. Read/write DateTime.

public DateTime Finish {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


FinishVariance Property

ResourceAssignment.FinishVariance Property

Returns or sets the variance of an assignment finish date from a baseline finish date. Read/write Int32.

public int FinishVariance {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


FixedMaterial Property

ResourceAssignment.FixedMaterial Property

Determines whether the consumption of an assigned material resource occurs in a single, fixed amount. Read/write Boolean.

public bool FixedMaterial {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


HasFixedRateUnits Property

ResourceAssignment.HasFixedRateUnits Property

Determines whether the Units have Fixed Rate. Read/write Boolean.

public bool HasFixedRateUnits {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Hyperlink Property

ResourceAssignment.Hyperlink Property

Returns or sets the title of the hyperlink associated with an assignment. Read/write String.

public string Hyperlink {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


HyperlinkAddress Property

ResourceAssignment.HyperlinkAddress Property

Returns or sets the hyperlink associated with an assignment. Read/write String.

public string HyperlinkAddress {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


HyperlinkSubAddress Property

ResourceAssignment.HyperlinkSubAddress Property

Returns or sets the document bookmark of the hyperlink associated with an assignment. Read/write String.

public string HyperlinkSubAddress {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


LevelingDelay Property

ResourceAssignment.LevelingDelay Property

Returns or sets the delay caused by leveling. Read/write Int32.

public int LevelingDelay {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


LevelingDelayFormat Property

ResourceAssignment.LevelingDelayFormat Property

Returns or sets the duration format of a delay. Read/write TimeUnitType.

public TimeUnitType LevelingDelayFormat {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


LinkedFields Property

ResourceAssignment.LinkedFields Property

Determines whether the Project is linked to another OLE object. Read/write Boolean.

public bool LinkedFields {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Milestone Property

ResourceAssignment.Milestone Property

Determines whether the assignment is a milestone. Read/write Boolean.

public bool Milestone {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Notes Property

ResourceAssignment.Notes Property

Returns or sets the text notes associated with an assignment. Read/write String.

public string Notes {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Overallocated Property

ResourceAssignment.Overallocated Property

Determines whether the assignment is overallocated. Read/write Boolean.

public bool Overallocated {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


OvertimeCost Property

ResourceAssignment.OvertimeCost Property

Returns or sets the sum of the actual and remaining overtime cost of an assignment. Read/write Decimal.

public decimal OvertimeCost {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


OvertimeWork Property

ResourceAssignment.OvertimeWork Property

Returns or sets the scheduled overtime work of an assignment. Read/write TimeSpan.

public TimeSpan OvertimeWork {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


PeakUnits Property

ResourceAssignment.PeakUnits Property

Returns or sets the largest number of a resource's units assigned to a task. Read/write Double.

public double PeakUnits {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


PercentWorkComplete Property

ResourceAssignment.PercentWorkComplete Property

Returns or sets the amount of a work completed on an assignment. Read/write Int32.

public int PercentWorkComplete {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


RateScale Property

ResourceAssignment.RateScale Property

Returns the time unit for the usage rate of the material resource assignment. Read/write Int32.

public int RateScale {get; set;}

Remarks

This is a new for MS Project 2010 property. Returns 0 if not defined. Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


RegularWork Property

ResourceAssignment.RegularWork Property

Returns or sets the amount of a non-overtime work scheduled for an assignment. Read/write TimeSpan.

public TimeSpan RegularWork {get; set;}

Remarks

Reading supported for XML and MS Project 2010 MPP formats only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


RemainingCost Property

ResourceAssignment.RemainingCost Property

Returns or sets the remaining projected cost of completing an assignment. Read/write Decimal.

public decimal RemainingCost {get; set;}

Remarks

Reading supported for XML and MS Project 2010 MPP formats only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


RemainingOvertimeCost Property

ResourceAssignment.RemainingOvertimeCost Property

Returns or sets the remaining projected overtime cost of completing an assignment. Read/write Decimal.

public decimal RemainingOvertimeCost {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


RemainingOvertimeWork Property

ResourceAssignment.RemainingOvertimeWork Property

Returns or sets the remaining overtime work scheduled to complete an assignment. Read/write TimeSpan.

public TimeSpan RemainingOvertimeWork {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


RemainingWork Property

ResourceAssignment.RemainingWork Property

Returns or sets the remaining work scheduled to complete an assignment. Read/write TimeSpan.

public TimeSpan RemainingWork {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Resource Property

ResourceAssignment.Resource Property

Returns or sets the resource assigned to a task. Read/write Resource.

public Resource Resource {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ResponsePending Property

ResourceAssignment.ResponsePending Property

Determines whether the response has been received for a TeamAssign message. Read/write Boolean.

public bool ResponsePending {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Resume Property

ResourceAssignment.Resume Property

Returns or sets the date when assignment is resumed. Read/write DateTime.

public DateTime Resume {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Start Property

ResourceAssignment.Start Property

Returns or sets the scheduled start date of an assignment. Read/write DateTime.

public DateTime Start {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


StartVariance Property

ResourceAssignment.StartVariance Property

Returns or sets the variance of an assignment start date from a baseline start date. Read/write Int32.

public int StartVariance {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Stop Property

ResourceAssignment.Stop Property

Returns or sets the date when assignment is stopped. Read/write DateTime.

public DateTime Stop {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Summary Property

ResourceAssignment.Summary Property

Determines whether the task is a summary task. Read/write Boolean.

public bool Summary {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Sv Property

ResourceAssignment.Sv Property

Returns or sets the earned value schedule variance, through the project status date. Read/write Double.

public double Sv {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Task Property

ResourceAssignment.Task Property

Returns or sets the task to which a resource is assigned. Read/write Task.

public Task Task {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


TimephasedData Property

ResourceAssignment.TimephasedData Property

Returns List<TimephasedData> TimephasedData. Read/write List of TimephasedData.

public TimephasedData} TimephasedData {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Uid Property

ResourceAssignment.Uid Property

Returns or sets the unique identifier of an assignment. Read/write Int32.

public int Uid {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Units Property

ResourceAssignment.Units Property

Returns or sets the number of units for an assignment. Read/write Double.

public double Units {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


UpdateNeeded Property

ResourceAssignment.UpdateNeeded Property

Determines whether the resource assigned to a task needs to be updated as to the status of the task. Read/write Boolean.

public bool UpdateNeeded {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Vac Property

ResourceAssignment.Vac Property

Returns or sets the difference between basline cost and total cost. Read/write Double.

public double Vac {get; set;}

Remarks

Reading supported for XML format only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


Work Property

ResourceAssignment.Work Property

Returns or sets the amount of scheduled work for an assignment. Read/write TimeSpan.

public TimeSpan Work {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


WorkContour Property

ResourceAssignment.WorkContour Property

Returns or sets the work contour of an assignment. Read/write WorkContourType.

public WorkContourType WorkContour {get; set;}

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


WorkVariance Property

ResourceAssignment.WorkVariance Property

Returns or sets the variance of an assignment work from the baseline work as minutes. Read/write Double.

public double WorkVariance {get; set;}

Remarks

Reading supported for XML and MS Project 2003/2010 MPP formats only.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ResourceAssignment Methods

The methods of the ResourceAssignment class are listed below. For a complete list of ResourceAssignment class members, see the ResourceAssignment Members topic.

Public Instance Methods

Delete | Deletes resource assignment from project assignments collection.
Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeTPs | Overloaded. Generates a list of TimephasedData.
SplitTask | Splits task into two parts.
TimephasedDataFromTaskDuration | Generates list of TimephasedData basen on the task duration and the scheduled start date.
TimeScaleData | Overloaded. Returns list of timephased data within given start and end dates of specified TimephasedDataType.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ResourceAssignment.Delete Method

Deletes resource assignment from project assignments collection.

public void Delete();

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ResourceAssignment.Equals Method

Returns a value indicating whether this instance is equal to a specified object.

public override bool Equals(
object obj
);

Parameters

obj
The object to compare with this instance.

Return Value

True if o is a ResourceAssignment that assign the same resource and task as this instance; otherwise, false.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


MakeTPs Method

ResourceAssignment.MakeTPs Method

Generates a list of TimephasedData.

Overload List

Generates a list of TimephasedData.

public DateTime MakeTPs(DateTime,TimeSpan,Calendar,TimephasedData},bool,int);

Generates a list of TimephasedData.

public DateTime MakeTPs(DateTime,TimeSpan,TimeSpan,Calendar,TimephasedData},double,int);

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ResourceAssignment.MakeTPs Method (DateTime, TimeSpan, Calendar, TimephasedData}, Boolean, Int32)

Generates a list of TimephasedData.

public DateTime MakeTPs(
DateTime start,
TimeSpan time,
Calendar calendar,
List<TimephasedData> outTP,
bool isWorking,
int type
);

Parameters

start
start date.
time
working time.
calendar
working calendar.
outTP
result.
isWorking
type

Return Value

finish date time.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace | ResourceAssignment.MakeTPs Overload List


ResourceAssignment.MakeTPs Method (DateTime, TimeSpan, TimeSpan, Calendar, TimephasedData}, Double, Int32)

Generates a list of TimephasedData.

public DateTime MakeTPs(
DateTime start,
TimeSpan time,
TimeSpan workTime,
Calendar calendar,
List<TimephasedData> outTP,
double units,
int type
);

Parameters

start
Start date.
time
Working time between start and finish dates.
workTime
Resource's working time.
calendar
The calendar.
outTP
Generated TimePhased data.
units
Resource's units.
type
TimephasedData type.

Return Value

Finish date.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace | ResourceAssignment.MakeTPs Overload List


ResourceAssignment.SplitTask Method

Splits task into two parts.

public void SplitTask(
DateTime start,
DateTime finish,
Calendar calendar
);

Parameters

start
beginning of work interruption.
finish
end of work interruption.
calendar
calendar.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ResourceAssignment.TimephasedDataFromTaskDuration Method

Generates list of TimephasedData basen on the task duration and the scheduled start date.

public void TimephasedDataFromTaskDuration(
Calendar calendar
);

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


TimeScaleData Method

ResourceAssignment.TimeScaleData Method

Returns list of timephased data within given start and end dates of AssignmentWork.

Overload List

Returns list of timephased data within given start and end dates of AssignmentWork.

public TimephasedData} TimeScaleData(DateTime,DateTime);

Returns list of timephased data within given start and end dates of specified TimephasedDataType.

public TimephasedData} TimeScaleData(DateTime,DateTime,TimephasedDataType);

See Also

ResourceAssignment Class | Aspose.Tasks Namespace


ResourceAssignment.TimeScaleData Method (DateTime, DateTime)

Returns list of timephased data within given start and end dates of AssignmentWork.

public List<TimephasedData> TimeScaleData(
DateTime start,
DateTime end
);

Parameters

start
The start date for the timephased data.
end
The end date for the timephased data.

Return Value

List of TimephasedData to be filled in.

See Also

ResourceAssignment Class | Aspose.Tasks Namespace | ResourceAssignment.TimeScaleData Overload List


ResourceAssignment.TimeScaleData Method (DateTime, DateTime, TimephasedDataType)

Returns list of timephased data within given start and end dates of specified TimephasedDataType.

public List<TimephasedData> TimeScaleData(
DateTime start,
DateTime end,
TimephasedDataType timephasedType
);

Parameters

start
The start date for the timephased data.
end
The end date for the timephased data.
timephasedType
The type of timephased data (TimephasedDataType).

See Also

ResourceAssignment Class | Aspose.Tasks Namespace | ResourceAssignment.TimeScaleData Overload List


ResourceType Enumeration

Specifies the type of a resource.

public enum ResourceType

Members

Member Name | Description | Value
Material | Material | 0
Work | Work | 1
Cost | Cost | 2

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


RollupType Enumeration

Specifies the rollup type.

public enum RollupType

Members

Member Name | Description | Value
Null | Null | 0
Maximum | Maximum | 1
Minimum | Minimum | 2
Count | Count | 3
Sum | Sum | 4
Average | Average | 5
AverageFirstSublevel | Average First Sublevel | 6
CountFirstSublevel | Count First Sublevel | 7
CountNonsummaries | Count Non-Summaries | 8

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


SplitPart Class

Represents a task portion. The SplitPart is a member of the task's SplitParts collection.

For a list of all members of this type, see SplitPart Members.

System.Object
Aspose.Tasks.SplitPart

public class SplitPart

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

SplitPart Members | Aspose.Tasks Namespace


SplitPart Members

SplitPart overview

Public Instance Properties

Finish | Returns the finish date of a SplitPart. Read only DateTime.
Index | Returns the index of an SplitPart in its containing collection. Read only Int32.
Start | Returns the start date of a SplitPart. Read only DateTime.

Public Instance Methods

Equals | Compares two split parts.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SplitPart Class | Aspose.Tasks Namespace


SplitPart Properties

The properties of the SplitPart class are listed below. For a complete list of SplitPart class members, see the SplitPart Members topic.

Public Instance Properties

Finish | Returns the finish date of a SplitPart. Read only DateTime.
Index | Returns the index of an SplitPart in its containing collection. Read only Int32.
Start | Returns the start date of a SplitPart. Read only DateTime.

See Also

SplitPart Class | Aspose.Tasks Namespace


Finish Property

SplitPart.Finish Property

Returns the finish date of a SplitPart. Read only DateTime.

public DateTime Finish {get; set;}

See Also

SplitPart Class | Aspose.Tasks Namespace


Index Property

SplitPart.Index Property

Returns the index of an SplitPart in its containing collection. Read only Int32.

public int Index {get;}

See Also

SplitPart Class | Aspose.Tasks Namespace


Start Property

SplitPart.Start Property

Returns the start date of a SplitPart. Read only DateTime.

public DateTime Start {get; set;}

See Also

SplitPart Class | Aspose.Tasks Namespace


SplitPart Methods

The methods of the SplitPart class are listed below. For a complete list of SplitPart class members, see the SplitPart Members topic.

Public Instance Methods

Equals | Compares two split parts.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SplitPart Class | Aspose.Tasks Namespace


SplitPart.Equals Method

Compares two split parts.

public override bool Equals(
object obj
);

Parameters

obj
Object to compare.

Return Value

See Also

SplitPart Class | Aspose.Tasks Namespace


SplitPartCollection Class

Collection that represents the portions of a task.

For a list of all members of this type, see SplitPartCollection Members.

System.Object
Aspose.Tasks.SplitPartCollection

public class SplitPartCollection : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

SplitPartCollection Members | Aspose.Tasks Namespace


SplitPartCollection Members

SplitPartCollection overview

Public Instance Properties

Count | Gets the number of parts in the collection. Read only Int32.
Item | Retrieves a task's split part at the given index.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Provides a simple "foreach" style iteration over the collection of SplitParts.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToArray | Copies all parts from the collection to a new array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SplitPartCollection Class | Aspose.Tasks Namespace


SplitPartCollection Properties

The properties of the SplitPartCollection class are listed below. For a complete list of SplitPartCollection class members, see the SplitPartCollection Members topic.

Public Instance Properties

Count | Gets the number of parts in the collection. Read only Int32.
Item | Retrieves a task's split part at the given index.

See Also

SplitPartCollection Class | Aspose.Tasks Namespace


Count Property

SplitPartCollection.Count Property

Gets the number of parts in the collection. Read only Int32.

public int Count {get;}

See Also

SplitPartCollection Class | Aspose.Tasks Namespace


Item Property

SplitPartCollection.Item Property

Retrieves a task's split part at the given index.

public SplitPart this[
int index
] {get;}

Parameters

index
The part index.

Remarks

The index is zero-based. Returns null if the index is outside array's boundaries.

See Also

SplitPartCollection Class | Aspose.Tasks Namespace


SplitPartCollection Methods

The methods of the SplitPartCollection class are listed below. For a complete list of SplitPartCollection class members, see the SplitPartCollection Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Provides a simple "foreach" style iteration over the collection of SplitParts.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToArray | Copies all parts from the collection to a new array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SplitPartCollection Class | Aspose.Tasks Namespace


SplitPartCollection.GetEnumerator Method

Provides a simple "foreach" style iteration over the collection of SplitParts.

public IEnumerator GetEnumerator();

Return Value

An IEnumerator.

Implements

IEnumerable.GetEnumerator

See Also

SplitPartCollection Class | Aspose.Tasks Namespace


SplitPartCollection.ToArray Method

Copies all parts from the collection to a new array.

public SplitPart[] ToArray();

Return Value

An array of SplitPart objects.

See Also

SplitPartCollection Class | Aspose.Tasks Namespace


Table Class

Represents a table in Project

For a list of all members of this type, see Table Members.

System.Object
Aspose.Tasks.Table

public class Table

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Table Members | Aspose.Tasks Namespace


Table Members

Table overview

Public Instance Constructors

Table Constructor Default constructor.

Public Instance Properties

Index | Gets the index of a Table object in the Tables containing object. Read-only Int32.
Name | Gets the name of a Table object. Read/write String.
ParentProject | Gets the parent of the Table object. Read-only Project.
ShowInMenu | True if Project shows the table name in the Tables drop-down list on the View tab of the Ribbon. Read/write Boolean.
TableFields | Gets a TableFields collection representing the fields in the table.
TableType | Gets the table type for the specified table. Read-only ItemType.
Uid | The unique identifier of a table.

Public Instance Methods

Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Table Class | Aspose.Tasks Namespace


Table Constructor

Default constructor.

public Table();

See Also

Table Class | Aspose.Tasks Namespace


Table Properties

The properties of the Table class are listed below. For a complete list of Table class members, see the Table Members topic.

Public Instance Properties

Index | Gets the index of a Table object in the Tables containing object. Read-only Int32.
Name | Gets the name of a Table object. Read/write String.
ParentProject | Gets the parent of the Table object. Read-only Project.
ShowInMenu | True if Project shows the table name in the Tables drop-down list on the View tab of the Ribbon. Read/write Boolean.
TableFields | Gets a TableFields collection representing the fields in the table.
TableType | Gets the table type for the specified table. Read-only ItemType.
Uid | The unique identifier of a table.

See Also

Table Class | Aspose.Tasks Namespace


Index Property

Table.Index Property

Gets the index of a Table object in the Tables containing object. Read-only Int32.

public int Index {get; set;}

See Also

Table Class | Aspose.Tasks Namespace


Name Property

Table.Name Property

Gets the name of a Table object. Read/write String.

public string Name {get; set;}

See Also

Table Class | Aspose.Tasks Namespace


ParentProject Property

Table.ParentProject Property

Gets the parent of the Table object. Read-only Project.

public Project ParentProject {get; set;}

See Also

Table Class | Aspose.Tasks Namespace


ShowInMenu Property

Table.ShowInMenu Property

True if Project shows the table name in the Tables drop-down list on the View tab of the Ribbon. Read/write Boolean.

public bool ShowInMenu {get; set;}

See Also

Table Class | Aspose.Tasks Namespace


TableFields Property

Table.TableFields Property

Gets a TableFields collection representing the fields in the table.

public TableFields TableFields {get; set;}

See Also

Table Class | Aspose.Tasks Namespace


TableType Property

Table.TableType Property

Gets the table type for the specified table. Read-only ItemType.

public ItemType TableType {get; set;}

See Also

Table Class | Aspose.Tasks Namespace


Uid Property

Table.Uid Property

The unique identifier of a table.

public int Uid {get; set;}

See Also

Table Class | Aspose.Tasks Namespace


Table Methods

The methods of the Table class are listed below. For a complete list of Table class members, see the Table Members topic.

Public Instance Methods

Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Table Class | Aspose.Tasks Namespace


Table.Equals Method

Returns a value indicating whether this instance is equal to a specified object.

public override bool Equals(
object obj
);

Parameters

obj
The object to compare with this instance.

Return Value

True if obj is a Table that has the same Uid value as this instance; otherwise, false.

See Also

Table Class | Aspose.Tasks Namespace


TableField Class

Represents a field of a table in Project.

For a list of all members of this type, see TableField Members.

System.Object
Aspose.Tasks.TableField

public class TableField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

TableField Members | Aspose.Tasks Namespace


TableField Members

TableField overview

Public Instance Constructors

TableField Constructor Initializes a new instance of the TableField class.

Public Instance Properties

AlignData | Gets or sets the alignment of data in a table field. Read/write StringAlignment.
AlignTitle | Gets or sets the alignment of the title in a table field. Read/write StringAlignment.
Field | Gets or sets the type of a table field. Read/write Field.
ParentTable | Gets the parent of the TableField object. Read-only Table.
Title | Gets or sets the title of the field in a table. Read/write String.
Width | Gets or sets the width in points of the field column in a table. Read/write Int32.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TableField Class | Aspose.Tasks Namespace


TableField Constructor

Initializes a new instance of the TableField class.

public TableField();

See Also

TableField Class | Aspose.Tasks Namespace


TableField Properties

The properties of the TableField class are listed below. For a complete list of TableField class members, see the TableField Members topic.

Public Instance Properties

AlignData | Gets or sets the alignment of data in a table field. Read/write StringAlignment.
AlignTitle | Gets or sets the alignment of the title in a table field. Read/write StringAlignment.
Field | Gets or sets the type of a table field. Read/write Field.
ParentTable | Gets the parent of the TableField object. Read-only Table.
Title | Gets or sets the title of the field in a table. Read/write String.
Width | Gets or sets the width in points of the field column in a table. Read/write Int32.

See Also

TableField Class | Aspose.Tasks Namespace


AlignData Property

TableField.AlignData Property

Gets or sets the alignment of data in a table field. Read/write StringAlignment.

public StringAlignment AlignData {get; set;}

See Also

TableField Class | Aspose.Tasks Namespace


AlignTitle Property

TableField.AlignTitle Property

Gets or sets the alignment of the title in a table field. Read/write StringAlignment.

public StringAlignment AlignTitle {get; set;}

See Also

TableField Class | Aspose.Tasks Namespace


Field Property

TableField.Field Property

Gets or sets the type of a table field. Read/write Field.

public Field Field {get; set;}

See Also

TableField Class | Aspose.Tasks Namespace


ParentTable Property

TableField.ParentTable Property

Gets the parent of the TableField object. Read-only Table.

public Table ParentTable {get; set;}

See Also

TableField Class | Aspose.Tasks Namespace


Title Property

TableField.Title Property

Gets or sets the title of the field in a table. Read/write String.

public string Title {get; set;}

See Also

TableField Class | Aspose.Tasks Namespace


Width Property

TableField.Width Property

Gets or sets the width in points of the field column in a table. Read/write Int32.

public int Width {get; set;}

See Also

TableField Class | Aspose.Tasks Namespace


TableFields Class

Contains a list of TableField objects. Implements IList<TableField> interface.

For a list of all members of this type, see TableFields Members.

System.Object
Aspose.Tasks.TableFields

public class TableFields : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

TableFields Members | Aspose.Tasks Namespace


TableFields Members

TableFields overview

Public Instance Properties

Count |
IsReadOnly |
Item |
ParentProject | Gets the parent of the TableFields object. Read-only Project.

Public Instance Methods

Add |
Clear |
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf |
Insert |
Remove |
RemoveAt |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TableFields Class | Aspose.Tasks Namespace


TableFields Properties

The properties of the TableFields class are listed below. For a complete list of TableFields class members, see the TableFields Members topic.

Public Instance Properties

Count |
IsReadOnly |
Item |
ParentProject | Gets the parent of the TableFields object. Read-only Project.

See Also

TableFields Class | Aspose.Tasks Namespace


Count Property

TableFields.Count Property

public int Count {get;}

Implements

ICollection`1.Count

See Also

TableFields Class | Aspose.Tasks Namespace


IsReadOnly Property

TableFields.IsReadOnly Property

public bool IsReadOnly {get;}

Implements

ICollection`1.IsReadOnly

See Also

TableFields Class | Aspose.Tasks Namespace


Item Property

TableFields.Item Property

public TableField this[
int index
] {get; set;}

Implements

IList`1.Item

See Also

TableFields Class | Aspose.Tasks Namespace


ParentProject Property

TableFields.ParentProject Property

Gets the parent of the TableFields object. Read-only Project.

public Project ParentProject {get;}

See Also

TableFields Class | Aspose.Tasks Namespace


TableFields Methods

The methods of the TableFields class are listed below. For a complete list of TableFields class members, see the TableFields Members topic.

Public Instance Methods

Add |
Clear |
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf |
Insert |
Remove |
RemoveAt |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TableFields Class | Aspose.Tasks Namespace


TableFields.Add Method

public void Add(
TableField item
);

Implements

ICollection`1.Add

See Also

TableFields Class | Aspose.Tasks Namespace


TableFields.Clear Method

public void Clear();

Implements

ICollection`1.Clear

See Also

TableFields Class | Aspose.Tasks Namespace


TableFields.Contains Method

public bool Contains(
TableField item
);

Implements

ICollection`1.Contains

See Also

TableFields Class | Aspose.Tasks Namespace


TableFields.CopyTo Method

public void CopyTo(
TableField[] array,
int arrayIndex
);

Implements

ICollection`1.CopyTo

See Also

TableFields Class | Aspose.Tasks Namespace


TableFields.GetEnumerator Method

public IEnumerator<TableField> GetEnumerator();

Implements

IEnumerable`1.GetEnumerator

See Also

TableFields Class | Aspose.Tasks Namespace


TableFields.IndexOf Method

public int IndexOf(
TableField item
);

Implements

IList`1.IndexOf

See Also

TableFields Class | Aspose.Tasks Namespace


TableFields.Insert Method

public void Insert(
int index,
TableField item
);

Implements

IList`1.Insert

See Also

TableFields Class | Aspose.Tasks Namespace


TableFields.Remove Method

public bool Remove(
TableField item
);

Implements

ICollection`1.Remove

See Also

TableFields Class | Aspose.Tasks Namespace


TableFields.RemoveAt Method

public void RemoveAt(
int index
);

Implements

IList`1.RemoveAt

See Also

TableFields Class | Aspose.Tasks Namespace


Tables Class

Contains a list of Table objects. Implements ICollection<Table> interface.

For a list of all members of this type, see Tables Members.

System.Object
Aspose.Tasks.Tables

public class Tables : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Tables Members | Aspose.Tasks Namespace


Tables Members

Tables overview

Public Instance Properties

Count |
IsReadOnly |
ParentProject | Gets the parent of the Table object. Read-only Project.

Public Instance Methods

Add |
Clear |
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToList | Converts a table collection to a list of Table objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Tables Class | Aspose.Tasks Namespace


Tables Properties

The properties of the Tables class are listed below. For a complete list of Tables class members, see the Tables Members topic.

Public Instance Properties

Count |
IsReadOnly |
ParentProject | Gets the parent of the Table object. Read-only Project.

See Also

Tables Class | Aspose.Tasks Namespace


Count Property

Tables.Count Property

public int Count {get;}

Implements

ICollection`1.Count

See Also

Tables Class | Aspose.Tasks Namespace


IsReadOnly Property

Tables.IsReadOnly Property

public bool IsReadOnly {get;}

Implements

ICollection`1.IsReadOnly

See Also

Tables Class | Aspose.Tasks Namespace


ParentProject Property

Tables.ParentProject Property

Gets the parent of the Table object. Read-only Project.

public Project ParentProject {get; set;}

See Also

Tables Class | Aspose.Tasks Namespace


Tables Methods

The methods of the Tables class are listed below. For a complete list of Tables class members, see the Tables Members topic.

Public Instance Methods

Add |
Clear |
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToList | Converts a table collection to a list of Table objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Tables Class | Aspose.Tasks Namespace


Tables.Add Method

public void Add(
Table item
);

Implements

ICollection`1.Add

See Also

Tables Class | Aspose.Tasks Namespace


Tables.Clear Method

public void Clear();

Implements

ICollection`1.Clear

See Also

Tables Class | Aspose.Tasks Namespace


Tables.Contains Method

public bool Contains(
Table item
);

Implements

ICollection`1.Contains

See Also

Tables Class | Aspose.Tasks Namespace


Tables.CopyTo Method

public void CopyTo(
Table[] array,
int arrayIndex
);

Implements

ICollection`1.CopyTo

See Also

Tables Class | Aspose.Tasks Namespace


Tables.GetEnumerator Method

public IEnumerator<Table> GetEnumerator();

Implements

IEnumerable`1.GetEnumerator

See Also

Tables Class | Aspose.Tasks Namespace


Tables.Remove Method

public bool Remove(
Table item
);

Implements

ICollection`1.Remove

See Also

Tables Class | Aspose.Tasks Namespace


Tables.ToList Method

Converts a table collection to a list of Table objects.

public List<Table> ToList();

Return Value

Generic list of Table objects.

See Also

Tables Class | Aspose.Tasks Namespace


Task Class

Represents a task in a project.

For a list of all members of this type, see Task Members.

System.Object
Aspose.Tasks.Task

public class Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Task Members | Aspose.Tasks Namespace


Task Members

Task overview

Public Static Methods

Recalculate | Recalculates task start/finish dates according to task duration. If duration is not set then sets default task duration. If applied to Project.RootTask reschedules all project's tasks start/finish dates, sets early/late dates and calulate slacks.
SetPercentComplete | Overloaded. Sets PercentComplete Property of task and makes necessary recalculations of ResourceAssignments if there are any.

Public Instance Constructors

Task Overloaded. Initializes a new instance of the Task class.

Public Instance Properties

ActualCost | The actual cost of a task. Read/write Decimal.
ActualDuration | The actual duration of a task. Read/write TimeSpan.
ActualFinish | The actual finish date of a task. Read/write DateTime.
ActualOvertimeCost | The actual overtime cost of a task. Read/write Decimal.
ActualOvertimeWork | The actual overtime work for a task. Read/write TimeSpan.
ActualOvertimeWorkProtected | The duration through which actual overtime work is protected. Read/write TimeSpan.
ActualStart | The actual start date of a task. Read/write DateTime.
ActualWork | The actual work for a task. Read/write TimeSpan.
ActualWorkProtected | The duration through which actual work is protected. Read/write TimeSpan.
Acwp | The actual cost of a work performed on the task to-date. Read/write Double.
Baseline | The collection of baseline values of the task
Bcwp | The budgeted cost of a work performed on a task to-date. Read/write Double.
Bcws | The budgeted cost of a work scheduled for a task. Read/write Double.
BudgetCost | The budget cost for a project summary task. Read Decimal
BudgetWork | The budget work for a project summary task. Read/write TimeSpan.
Calendar | The task calendar. Read/write Calendar.
CanLevelingSplit | Determines whether a leveling can split a task. Read/write Boolean.
Children | Returns List<Task> Children. List of children tasks Read/write list of Task.
CommitmentFinish | The finish date of a delivery. Read/write DateTime.
CommitmentStart | The start date of a delivery. Read/write DateTime.
CommitmentType | Determines whether a task has an associated delivery or a dependency on an associated delivery. Read/write Int32.
ConstraintDate | The date argument for the task constraint type. Read/write DateTime.
ConstraintType | The constraint on the start or finish date of a task. Read/write ConstraintType.
Contact | The contact person for a task. Read/write String.
Cost | The projected or scheduled cost of a task. Read/write Decimal.
CostVariance | The difference between the baseline cost and total cost for a task.
CreateDate | The date when a task was created. Read/write DateTime.
Cv | The earned value cost variance. Read/write Double.
Deadline | The deadline for a task to be completed. Read/write DateTime.
DisplayAsSummary | Defines whether the task should be displayed as a summary task. Read/write Boolean.
Duration | The planned duration of a task. Read/write TimeSpan.
DurationFormat | The format of expressing the duration of a task. Read/write TimeUnitType.
DurationVariance | Contains the difference between the total duration of a task and the baseline duration of a task. Calculated TimeSpan.
EarlyFinish | The early finish date of a task. Read/write DateTime.
EarlyStart | The early start date of a task. Read/write DateTime.
EarnedValueMethod | The method of calculating earned value. Read/write Int32.
ExtendedAttribute | Returns List<ExtendedAttribute> ExtendedAttribute. The value of an extended attribute. Read/write List of ExtendedAttribute.
ExternalId | If the task is an external task it contains the task's external ID.
ExternalTaskProject | The source location and task identifier of an external task. Read/write String.
Finish | The scheduled finish date of a task Read/write DateTime.
FinishSlack | Returns the task's finish slack. Read/write Int32.
FinishText | Returns the task's finish text. Read/write String.
FinishVariance | The variance of the task finish date from the baseline finish date as minutes. Read/write Int32.
FixedCost | The fixed cost of a task. Read/write Double.
FixedCostAccrual | Determines how the fixed cost is accrued against a task. Read/write CostAccrualType.
FreeSlack | The amount of a free slack. Read/write Int32.
FreeSlak | Obsolete. The amount of a free slack. Read/write Int32.
GUID | Task's GUID. Read/write String.
HideBar | Determines whether the GANTT bar of a task is hidden when displayed in Microsoft Project. Read/write Boolean.
Hyperlink | The title of a hyperlink associated with a task. Read/write String.
HyperlinkAddress | The hyperlink associated with a task. Read/write String.
HyperlinkSubAddress | The document bookmark of the hyperlink associated with a task. Read/write String.
Id | The position identifier of a task within the list of tasks. Read/write Int32.
IgnoreResourceCalendar | Determines whether a task ignores the resource calendar. Read/write Boolean.
IgnoreWarnings | Shows whether to hide the schedule conflict warning indicator or not.
IsActive | Determines if the task is active. Read/write Boolean.
IsCritical | Determines whether a task is in the critical chain. Read/write Boolean.
IsEffortDriven | Determines whether a task is effort-driven. Read/write Boolean.
IsEstimated | Determines whether a task is estimated. Read/write Boolean.
IsExpanded | Determines whether a summary task is expanded or not. Read/write Boolean.
IsExternalTask | Determines whether a task is external. Read only Boolean.
IsLevelAssignments | Determines whether a leveling can adjust assignments. Read/write Boolean.
IsManual | Determines whether a task is manually scheduled. Read/write Boolean.
IsMarked | Shows whether a task is marked for further action or identification of some kind.
IsMilestone | Determines whether a task is a milestone. Read/write Boolean.
IsNull | Determines whether a task is null. Read/write Boolean.
IsOverAllocated | Determines whether a task is overallocated. This element is informational only. Read/write Boolean.
IsPublished | Determines whether a task is published. Read/write Boolean.
IsRecurring | Determines whether a task is a recurring task. Read/write Boolean.
IsResumeValid | Determines whether a task can be resumed. Read/write Boolean.
IsRollup | Determines whether a task is rolled up. Read/write Boolean.
IsSubproject | Determines whether a task is an inserted project. Read/write Boolean.
IsSubprojectReadOnly | Determines whether a subproject is read-only. Read/write Boolean.
IsSummary | Determines whether a task is a summary task. Read only Boolean.
LateFinish | The late finish date of a task. Read/write DateTime.
LateStart | The late start date of a task. Read/write DateTime.
LevelingDelay | The delay caused by leveling a task. Read/write Int32.
LevelingDelayFromat | The format of expressing the duration of a delay. Read/write TimeUnitType.
ManualDuration | Defines manually scheduled duration of the tasks. Read/write TimeSpan.
ManualFinish | Defines manually scheduled finish of the tasks. Read/write DateTime.
ManualStart | Defines manually scheduled start of the tasks. Read/write DateTime.
Name | The name of a task. Read/write String.
Notes | Obsolete. The text notes associated with a task. Read/write String.
NotesRTF | The text notes in RTF format. Read only String.
NotesText | Notes' plain text extracted from RTF data. Read/write String.
OutlineCode | Returns List<OutlineCode> OutlineCode.
OutlineLevel | The outline level of a task. Read/write Int32.
OutlineNumber | The outline number of a task. Read/write String.
OvertimeCost | The sum of an actual and remaining overtime cost of a task. Read/write Decimal.
OvertimeWork | The amount of an overtime work scheduled for a task. Read/write TimeSpan.
ParentProject | The parent project of a task. Read/write Project.
ParentTask | The parent task of a task. Read/write Task.
PercentComplete | The percentage of the task duration completed. Read/write Int32.
PercentWorkComplete | The percentage of a task work completed. Read/write Int32.
PhysicalPercentComplete | The percentage complete value entered by the Project Manager. This can be used as an alternative for calculating BCWP. Read/write Int32.
PreLeveledFinish | The finish date of a task before it was leveled. Read/write DateTime.
PreLeveledStart | The start date of a task before it was leveled. Read/write DateTime.
Priority | The priority of a task from 0 to 1000. Read/write Int32.
RegularWork | The amount of non-overtime work scheduled for a task. Read/write TimeSpan.
RemainingCost | The remaining projected cost of completing a task. Read/write Decimal.
RemainingDuration | The amount of time required to complete the unfinished portion of a task. Read/write TimeSpan.
RemainingOvertimeCost | The remaining overtime cost projected to finish a task. Read/write Decimal.
RemainingOvertimeWork | The remaining overtime work scheduled to finish a task. Read/write TimeSpan.
RemainingWork | The remaining work scheduled to complete a task. Read/write TimeSpan.
Resume | The date when a task resumed. Read/write DateTime.
SplitParts | Returns a SplitPart collection that represents the portions of a task. Read only SplitPartCollection.
Start | The scheduled start date of a task. Read/write DateTime.
StartSlack | Returns the task's start slack. Read/write Int32.
StartText | Returns the task's start text. Read/write String.
StartVariance | The variance of the task start date from the baseline start date as minutes. Read/write Int32.
StatusManager | The name of a task status manager. Read/write String.
Stop | The date when a task was stopped. Read/write DateTime.
SubprojectName | The source location of a subproject. Read/write String.
TimephasedData | Returns List<TimephasedData> TimephasedData. The timephased data block associated with a task. Read/write List of TimephasedData.
TotalSlack | The amount of a total slack. Read/write Int32.
TotalSlak | Obsolete. The amount of a total slack. Read/write Int32.
Type | The type of a task. Read/write TaskType.
Uid | The unique Id of a task. Read/write Int32.
Wbs | The work breakdown structure code of a task. Read/write String.
WbsLevel | The rightmost WBS level of a task. Read/write String.
Work | The amount of the scheduled work for a task. Read/write TimeSpan.
WorkVariance | The variance of the task work from the baseline task work as minutes. Read/write Double.

Public Instance Methods

Clone | Creates full copy of a task without subtasks.
Delete | Deletes task from parent project tasks collection and all its assignments.
Equals | Returns a value indicating whether this instance is equal to a specified object.
GetDuration | Returns task duration in specified format.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OutlineIndent | Indents a task in the outline.
OutlineOutdent | Promotes a task in the outline.
SetPercentComplete | Overloaded. Sets PercentComplete Property of task instance and makes necessary recalculations of ResourceAssignments if there are any.
TimeScaleData | Overloaded. Returns timephased data within given start and end dates of specified timephasedDataType.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Task Class | Aspose.Tasks Namespace


Task Constructor

Creates task with the list of children.

Overload List

Default constructor.

public Task();

Creates task.

public Task(string);

Creates task with the list of children.

public Task(string,Task[]);

Creates task with the list of children.

public Task(string,Task});

Creates task with the specified name and duration.

public Task(string,TimeSpan);

See Also

Task Class | Aspose.Tasks Namespace


Task Constructor (String, Task[])

Creates task with the list of children.

public Task(
string name,
Task[] children
);

Parameters

name
Name of the task.
children
List of children.

See Also

Task Class | Aspose.Tasks Namespace | Task Constructor Overload List


Task Constructor (String, Task})

Creates task with the list of children.

public Task(
string name,
List<Task> children
);

Parameters

name
Name of the task.
children
List of children.

See Also

Task Class | Aspose.Tasks Namespace | Task Constructor Overload List


Task Constructor ()

Default constructor.

public Task();

See Also

Task Class | Aspose.Tasks Namespace | Task Constructor Overload List


Task Constructor (String)

Creates task.

public Task(
string name
);

Parameters

name
Name of the task.

See Also

Task Class | Aspose.Tasks Namespace | Task Constructor Overload List


Task Constructor (String, TimeSpan)

Creates task with the specified name and duration.

public Task(
string name,
TimeSpan duration
);

Parameters

name
Name of a task.
duration
Duration of a task.

See Also

Task Class | Aspose.Tasks Namespace | Task Constructor Overload List


Task Properties

The properties of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Instance Properties

ActualCost | The actual cost of a task. Read/write Decimal.
ActualDuration | The actual duration of a task. Read/write TimeSpan.
ActualFinish | The actual finish date of a task. Read/write DateTime.
ActualOvertimeCost | The actual overtime cost of a task. Read/write Decimal.
ActualOvertimeWork | The actual overtime work for a task. Read/write TimeSpan.
ActualOvertimeWorkProtected | The duration through which actual overtime work is protected. Read/write TimeSpan.
ActualStart | The actual start date of a task. Read/write DateTime.
ActualWork | The actual work for a task. Read/write TimeSpan.
ActualWorkProtected | The duration through which actual work is protected. Read/write TimeSpan.
Acwp | The actual cost of a work performed on the task to-date. Read/write Double.
Baseline | The collection of baseline values of the task
Bcwp | The budgeted cost of a work performed on a task to-date. Read/write Double.
Bcws | The budgeted cost of a work scheduled for a task. Read/write Double.
BudgetCost | The budget cost for a project summary task. Read Decimal
BudgetWork | The budget work for a project summary task. Read/write TimeSpan.
Calendar | The task calendar. Read/write Calendar.
CanLevelingSplit | Determines whether a leveling can split a task. Read/write Boolean.
Children | Returns List<Task> Children. List of children tasks Read/write list of Task.
CommitmentFinish | The finish date of a delivery. Read/write DateTime.
CommitmentStart | The start date of a delivery. Read/write DateTime.
CommitmentType | Determines whether a task has an associated delivery or a dependency on an associated delivery. Read/write Int32.
ConstraintDate | The date argument for the task constraint type. Read/write DateTime.
ConstraintType | The constraint on the start or finish date of a task. Read/write ConstraintType.
Contact | The contact person for a task. Read/write String.
Cost | The projected or scheduled cost of a task. Read/write Decimal.
CostVariance | The difference between the baseline cost and total cost for a task.
CreateDate | The date when a task was created. Read/write DateTime.
Cv | The earned value cost variance. Read/write Double.
Deadline | The deadline for a task to be completed. Read/write DateTime.
DisplayAsSummary | Defines whether the task should be displayed as a summary task. Read/write Boolean.
Duration | The planned duration of a task. Read/write TimeSpan.
DurationFormat | The format of expressing the duration of a task. Read/write TimeUnitType.
DurationVariance | Contains the difference between the total duration of a task and the baseline duration of a task. Calculated TimeSpan.
EarlyFinish | The early finish date of a task. Read/write DateTime.
EarlyStart | The early start date of a task. Read/write DateTime.
EarnedValueMethod | The method of calculating earned value. Read/write Int32.
ExtendedAttribute | Returns List<ExtendedAttribute> ExtendedAttribute. The value of an extended attribute. Read/write List of ExtendedAttribute.
ExternalId | If the task is an external task it contains the task's external ID.
ExternalTaskProject | The source location and task identifier of an external task. Read/write String.
Finish | The scheduled finish date of a task Read/write DateTime.
FinishSlack | Returns the task's finish slack. Read/write Int32.
FinishText | Returns the task's finish text. Read/write String.
FinishVariance | The variance of the task finish date from the baseline finish date as minutes. Read/write Int32.
FixedCost | The fixed cost of a task. Read/write Double.
FixedCostAccrual | Determines how the fixed cost is accrued against a task. Read/write CostAccrualType.
FreeSlack | The amount of a free slack. Read/write Int32.
FreeSlak | Obsolete. The amount of a free slack. Read/write Int32.
GUID | Task's GUID. Read/write String.
HideBar | Determines whether the GANTT bar of a task is hidden when displayed in Microsoft Project. Read/write Boolean.
Hyperlink | The title of a hyperlink associated with a task. Read/write String.
HyperlinkAddress | The hyperlink associated with a task. Read/write String.
HyperlinkSubAddress | The document bookmark of the hyperlink associated with a task. Read/write String.
Id | The position identifier of a task within the list of tasks. Read/write Int32.
IgnoreResourceCalendar | Determines whether a task ignores the resource calendar. Read/write Boolean.
IgnoreWarnings | Shows whether to hide the schedule conflict warning indicator or not.
IsActive | Determines if the task is active. Read/write Boolean.
IsCritical | Determines whether a task is in the critical chain. Read/write Boolean.
IsEffortDriven | Determines whether a task is effort-driven. Read/write Boolean.
IsEstimated | Determines whether a task is estimated. Read/write Boolean.
IsExpanded | Determines whether a summary task is expanded or not. Read/write Boolean.
IsExternalTask | Determines whether a task is external. Read only Boolean.
IsLevelAssignments | Determines whether a leveling can adjust assignments. Read/write Boolean.
IsManual | Determines whether a task is manually scheduled. Read/write Boolean.
IsMarked | Shows whether a task is marked for further action or identification of some kind.
IsMilestone | Determines whether a task is a milestone. Read/write Boolean.
IsNull | Determines whether a task is null. Read/write Boolean.
IsOverAllocated | Determines whether a task is overallocated. This element is informational only. Read/write Boolean.
IsPublished | Determines whether a task is published. Read/write Boolean.
IsRecurring | Determines whether a task is a recurring task. Read/write Boolean.
IsResumeValid | Determines whether a task can be resumed. Read/write Boolean.
IsRollup | Determines whether a task is rolled up. Read/write Boolean.
IsSubproject | Determines whether a task is an inserted project. Read/write Boolean.
IsSubprojectReadOnly | Determines whether a subproject is read-only. Read/write Boolean.
IsSummary | Determines whether a task is a summary task. Read only Boolean.
LateFinish | The late finish date of a task. Read/write DateTime.
LateStart | The late start date of a task. Read/write DateTime.
LevelingDelay | The delay caused by leveling a task. Read/write Int32.
LevelingDelayFromat | The format of expressing the duration of a delay. Read/write TimeUnitType.
ManualDuration | Defines manually scheduled duration of the tasks. Read/write TimeSpan.
ManualFinish | Defines manually scheduled finish of the tasks. Read/write DateTime.
ManualStart | Defines manually scheduled start of the tasks. Read/write DateTime.
Name | The name of a task. Read/write String.
Notes | Obsolete. The text notes associated with a task. Read/write String.
NotesRTF | The text notes in RTF format. Read only String.
NotesText | Notes' plain text extracted from RTF data. Read/write String.
OutlineCode | Returns List<OutlineCode> OutlineCode.
OutlineLevel | The outline level of a task. Read/write Int32.
OutlineNumber | The outline number of a task. Read/write String.
OvertimeCost | The sum of an actual and remaining overtime cost of a task. Read/write Decimal.
OvertimeWork | The amount of an overtime work scheduled for a task. Read/write TimeSpan.
ParentProject | The parent project of a task. Read/write Project.
ParentTask | The parent task of a task. Read/write Task.
PercentComplete | The percentage of the task duration completed. Read/write Int32.
PercentWorkComplete | The percentage of a task work completed. Read/write Int32.
PhysicalPercentComplete | The percentage complete value entered by the Project Manager. This can be used as an alternative for calculating BCWP. Read/write Int32.
PreLeveledFinish | The finish date of a task before it was leveled. Read/write DateTime.
PreLeveledStart | The start date of a task before it was leveled. Read/write DateTime.
Priority | The priority of a task from 0 to 1000. Read/write Int32.
RegularWork | The amount of non-overtime work scheduled for a task. Read/write TimeSpan.
RemainingCost | The remaining projected cost of completing a task. Read/write Decimal.
RemainingDuration | The amount of time required to complete the unfinished portion of a task. Read/write TimeSpan.
RemainingOvertimeCost | The remaining overtime cost projected to finish a task. Read/write Decimal.
RemainingOvertimeWork | The remaining overtime work scheduled to finish a task. Read/write TimeSpan.
RemainingWork | The remaining work scheduled to complete a task. Read/write TimeSpan.
Resume | The date when a task resumed. Read/write DateTime.
SplitParts | Returns a SplitPart collection that represents the portions of a task. Read only SplitPartCollection.
Start | The scheduled start date of a task. Read/write DateTime.
StartSlack | Returns the task's start slack. Read/write Int32.
StartText | Returns the task's start text. Read/write String.
StartVariance | The variance of the task start date from the baseline start date as minutes. Read/write Int32.
StatusManager | The name of a task status manager. Read/write String.
Stop | The date when a task was stopped. Read/write DateTime.
SubprojectName | The source location of a subproject. Read/write String.
TimephasedData | Returns List<TimephasedData> TimephasedData. The timephased data block associated with a task. Read/write List of TimephasedData.
TotalSlack | The amount of a total slack. Read/write Int32.
TotalSlak | Obsolete. The amount of a total slack. Read/write Int32.
Type | The type of a task. Read/write TaskType.
Uid | The unique Id of a task. Read/write Int32.
Wbs | The work breakdown structure code of a task. Read/write String.
WbsLevel | The rightmost WBS level of a task. Read/write String.
Work | The amount of the scheduled work for a task. Read/write TimeSpan.
WorkVariance | The variance of the task work from the baseline task work as minutes. Read/write Double.

See Also

Task Class | Aspose.Tasks Namespace


ActualCost Property

Task.ActualCost Property

The actual cost of a task. Read/write Decimal.

public decimal ActualCost {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


ActualDuration Property

Task.ActualDuration Property

The actual duration of a task. Read/write TimeSpan.

public TimeSpan ActualDuration {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


ActualFinish Property

Task.ActualFinish Property

The actual finish date of a task. Read/write DateTime.

public DateTime ActualFinish {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


ActualOvertimeCost Property

Task.ActualOvertimeCost Property

The actual overtime cost of a task. Read/write Decimal.

public decimal ActualOvertimeCost {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


ActualOvertimeWork Property

Task.ActualOvertimeWork Property

The actual overtime work for a task. Read/write TimeSpan.

public TimeSpan ActualOvertimeWork {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


ActualOvertimeWorkProtected Property

Task.ActualOvertimeWorkProtected Property

The duration through which actual overtime work is protected. Read/write TimeSpan.

public TimeSpan ActualOvertimeWorkProtected {get; set;}

Remarks

Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


ActualStart Property

Task.ActualStart Property

The actual start date of a task. Read/write DateTime.

public DateTime ActualStart {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


ActualWork Property

Task.ActualWork Property

The actual work for a task. Read/write TimeSpan.

public TimeSpan ActualWork {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


ActualWorkProtected Property

Task.ActualWorkProtected Property

The duration through which actual work is protected. Read/write TimeSpan.

public TimeSpan ActualWorkProtected {get; set;}

Remarks

Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


Acwp Property

Task.Acwp Property

The actual cost of a work performed on the task to-date. Read/write Double.

public double Acwp {get; set;}

Remarks

Still have differences with MS Project in some cases.

See Also

Task Class | Aspose.Tasks Namespace


Baseline Property

Task.Baseline Property

The collection of baseline values of the task

public TaskBaseline} Baseline {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Bcwp Property

Task.Bcwp Property

The budgeted cost of a work performed on a task to-date. Read/write Double.

public double Bcwp {get; set;}

Remarks

Still have differences with MS Project in some cases.

See Also

Task Class | Aspose.Tasks Namespace


Bcws Property

Task.Bcws Property

The budgeted cost of a work scheduled for a task. Read/write Double.

public double Bcws {get; set;}

Remarks

Still have differences with MS Project in some cases.

See Also

Task Class | Aspose.Tasks Namespace


BudgetCost Property

Task.BudgetCost Property

The budget cost for a project summary task. Read Decimal

public decimal BudgetCost {get;}

See Also

Task Class | Aspose.Tasks Namespace


BudgetWork Property

Task.BudgetWork Property

The budget work for a project summary task. Read/write TimeSpan.

public TimeSpan BudgetWork {get;}

See Also

Task Class | Aspose.Tasks Namespace


Calendar Property

Task.Calendar Property

The task calendar. Read/write Calendar.

public Calendar Calendar {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


CanLevelingSplit Property

Task.CanLevelingSplit Property

Determines whether a leveling can split a task. Read/write Boolean.

public bool CanLevelingSplit {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Children Property

Task.Children Property

Returns List<Task> Children. List of children tasks Read/write list of Task.

public Task} Children {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


CommitmentFinish Property

Task.CommitmentFinish Property

The finish date of a delivery. Read/write DateTime.

public DateTime CommitmentFinish {get; set;}

Remarks

Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


CommitmentStart Property

Task.CommitmentStart Property

The start date of a delivery. Read/write DateTime.

public DateTime CommitmentStart {get; set;}

Remarks

Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


CommitmentType Property

Task.CommitmentType Property

Determines whether a task has an associated delivery or a dependency on an associated delivery. Read/write Int32.

public int CommitmentType {get; set;}

Remarks

Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


ConstraintDate Property

Task.ConstraintDate Property

The date argument for the task constraint type. Read/write DateTime.

public DateTime ConstraintDate {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


ConstraintType Property

Task.ConstraintType Property

The constraint on the start or finish date of a task. Read/write ConstraintType.

public ConstraintType ConstraintType {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Contact Property

Task.Contact Property

The contact person for a task. Read/write String.

public string Contact {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Cost Property

Task.Cost Property

The projected or scheduled cost of a task. Read/write Decimal.

public decimal Cost {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


CostVariance Property

Task.CostVariance Property

The difference between the baseline cost and total cost for a task.

public double CostVariance {get; set;}

Remarks

Calculated field.

See Also

Task Class | Aspose.Tasks Namespace


CreateDate Property

Task.CreateDate Property

The date when a task was created. Read/write DateTime.

public DateTime CreateDate {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Cv Property

Task.Cv Property

The earned value cost variance. Read/write Double.

public double Cv {get; set;}

Remarks

Still have differences with MS Project in some cases.

See Also

Task Class | Aspose.Tasks Namespace


Deadline Property

Task.Deadline Property

The deadline for a task to be completed. Read/write DateTime.

public DateTime Deadline {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


DisplayAsSummary Property

Task.DisplayAsSummary Property

Defines whether the task should be displayed as a summary task. Read/write Boolean.

public bool DisplayAsSummary {get; set;}

Remarks

This is a new for MS Project 2010 property. Returns false if not defined. Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


Duration Property

Task.Duration Property

The planned duration of a task. Read/write TimeSpan.

public virtual TimeSpan Duration {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


DurationFormat Property

Task.DurationFormat Property

The format of expressing the duration of a task. Read/write TimeUnitType.

public TimeUnitType DurationFormat {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


DurationVariance Property

Task.DurationVariance Property

Contains the difference between the total duration of a task and the baseline duration of a task. Calculated TimeSpan.

public TimeSpan DurationVariance {get;}

See Also

Task Class | Aspose.Tasks Namespace


EarlyFinish Property

Task.EarlyFinish Property

The early finish date of a task. Read/write DateTime.

public DateTime EarlyFinish {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


EarlyStart Property

Task.EarlyStart Property

The early start date of a task. Read/write DateTime.

public DateTime EarlyStart {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


EarnedValueMethod Property

Task.EarnedValueMethod Property

The method of calculating earned value. Read/write Int32.

public int EarnedValueMethod {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


ExtendedAttribute Property

Task.ExtendedAttribute Property

Returns List<ExtendedAttribute> ExtendedAttribute. The value of an extended attribute. Read/write List of ExtendedAttribute.

public ExtendedAttribute} ExtendedAttribute {get; set;}

Remarks

Two pieces of data are necessary - a pointer back to the extended attribute table which is specified either by the unique ID or the Field ID, and the value which is specified either with the value, or a pointer back to the value list.

See Also

Task Class | Aspose.Tasks Namespace


ExternalId Property

Task.ExternalId Property

If the task is an external task it contains the task's external ID.

public int ExternalId {get; set;}

Remarks

Currently supported for MPP format only.

See Also

Task Class | Aspose.Tasks Namespace


ExternalTaskProject Property

Task.ExternalTaskProject Property

The source location and task identifier of an external task. Read/write String.

public string ExternalTaskProject {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Finish Property

Task.Finish Property

The scheduled finish date of a task Read/write DateTime.

public DateTime Finish {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


FinishSlack Property

Task.FinishSlack Property

Returns the task's finish slack. Read/write Int32.

public int FinishSlack {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


FinishText Property

Task.FinishText Property

Returns the task's finish text. Read/write String.

public string FinishText {get; set;}

Remarks

This is a new for MS Project 2010 property. Returns null if not defined.

See Also

Task Class | Aspose.Tasks Namespace


FinishVariance Property

Task.FinishVariance Property

The variance of the task finish date from the baseline finish date as minutes. Read/write Int32.

public int FinishVariance {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


FixedCost Property

Task.FixedCost Property

The fixed cost of a task. Read/write Double.

public double FixedCost {get; set;}

Remarks

Reading supported for XML and MS Project 2003/2007 MPP formats only.

See Also

Task Class | Aspose.Tasks Namespace


FixedCostAccrual Property

Task.FixedCostAccrual Property

Determines how the fixed cost is accrued against a task. Read/write CostAccrualType.

public CostAccrualType FixedCostAccrual {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


FreeSlack Property

Task.FreeSlack Property

The amount of a free slack. Read/write Int32.

public int FreeSlack {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


FreeSlak Property

Task.FreeSlak Property

NOTE: This property is now obsolete.

Use FreeSlack instead of it.

The amount of a free slack. Read/write Int32.

public int FreeSlak {get; set;}

Remarks

The property is obsolete, use FreeSlack instead of it.

See Also

Task Class | Aspose.Tasks Namespace


GUID Property

Task.GUID Property

Task's GUID. Read/write String.

public string GUID {get; set;}

Remarks

Currently supported for MS Project 2007/2010 MPP files only.

See Also

Task Class | Aspose.Tasks Namespace


HideBar Property

Task.HideBar Property

Determines whether the GANTT bar of a task is hidden when displayed in Microsoft Project. Read/write Boolean.

public bool HideBar {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Hyperlink Property

Task.Hyperlink Property

The title of a hyperlink associated with a task. Read/write String.

public string Hyperlink {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


HyperlinkAddress Property

Task.HyperlinkAddress Property

The hyperlink associated with a task. Read/write String.

public string HyperlinkAddress {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


HyperlinkSubAddress Property

Task.HyperlinkSubAddress Property

The document bookmark of the hyperlink associated with a task. Read/write String.

public string HyperlinkSubAddress {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Id Property

Task.Id Property

The position identifier of a task within the list of tasks. Read/write Int32.

public int Id {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


IgnoreResourceCalendar Property

Task.IgnoreResourceCalendar Property

Determines whether a task ignores the resource calendar. Read/write Boolean.

public bool IgnoreResourceCalendar {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


IgnoreWarnings Property

Task.IgnoreWarnings Property

Shows whether to hide the schedule conflict warning indicator or not.

public bool IgnoreWarnings {get; set;}

Remarks

New for MS Project 2010 field. Applies to mpp file format only.

See Also

Task Class | Aspose.Tasks Namespace


IsActive Property

Task.IsActive Property

Determines if the task is active. Read/write Boolean.

public bool IsActive {get; set;}

Remarks

This is a new for MS Project 2010 property. Returns true if not defined. Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


IsCritical Property

Task.IsCritical Property

Determines whether a task is in the critical chain. Read/write Boolean.

public bool IsCritical {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


IsEffortDriven Property

Task.IsEffortDriven Property

Determines whether a task is effort-driven. Read/write Boolean.

public bool IsEffortDriven {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


IsEstimated Property

Task.IsEstimated Property

Determines whether a task is estimated. Read/write Boolean.

public bool IsEstimated {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


IsExpanded Property

Task.IsExpanded Property

Determines whether a summary task is expanded or not. Read/write Boolean.

public bool IsExpanded {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


IsExternalTask Property

Task.IsExternalTask Property

Determines whether a task is external. Read only Boolean.

public bool IsExternalTask {get;}

See Also

Task Class | Aspose.Tasks Namespace


IsLevelAssignments Property

Task.IsLevelAssignments Property

Determines whether a leveling can adjust assignments. Read/write Boolean.

public bool IsLevelAssignments {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


IsManual Property

Task.IsManual Property

Determines whether a task is manually scheduled. Read/write Boolean.

public bool IsManual {get; set;}

Remarks

This is a new for MS Project 2010 property.

See Also

Task Class | Aspose.Tasks Namespace


IsMarked Property

Task.IsMarked Property

Shows whether a task is marked for further action or identification of some kind.

public bool IsMarked {get; set;}

Remarks

Applies to mpp file format only.

See Also

Task Class | Aspose.Tasks Namespace


IsMilestone Property

Task.IsMilestone Property

Determines whether a task is a milestone. Read/write Boolean.

public bool IsMilestone {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


IsNull Property

Task.IsNull Property

Determines whether a task is null. Read/write Boolean.

public bool IsNull {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


IsOverAllocated Property

Task.IsOverAllocated Property

Determines whether a task is overallocated. This element is informational only. Read/write Boolean.

public bool IsOverAllocated {get; set;}

Remarks

Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


IsPublished Property

Task.IsPublished Property

Determines whether a task is published. Read/write Boolean.

public bool IsPublished {get; set;}

Remarks

Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


IsRecurring Property

Task.IsRecurring Property

Determines whether a task is a recurring task. Read/write Boolean.

public bool IsRecurring {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


IsResumeValid Property

Task.IsResumeValid Property

Determines whether a task can be resumed. Read/write Boolean.

public bool IsResumeValid {get; set;}

Remarks

Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


IsRollup Property

Task.IsRollup Property

Determines whether a task is rolled up. Read/write Boolean.

public bool IsRollup {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


IsSubproject Property

Task.IsSubproject Property

Determines whether a task is an inserted project. Read/write Boolean.

public bool IsSubproject {get;}

See Also

Task Class | Aspose.Tasks Namespace


IsSubprojectReadOnly Property

Task.IsSubprojectReadOnly Property

Determines whether a subproject is read-only. Read/write Boolean.

public bool IsSubprojectReadOnly {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


IsSummary Property

Task.IsSummary Property

Determines whether a task is a summary task. Read only Boolean.

public bool IsSummary {get;}

See Also

Task Class | Aspose.Tasks Namespace


LateFinish Property

Task.LateFinish Property

The late finish date of a task. Read/write DateTime.

public DateTime LateFinish {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


LateStart Property

Task.LateStart Property

The late start date of a task. Read/write DateTime.

public DateTime LateStart {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


LevelingDelay Property

Task.LevelingDelay Property

The delay caused by leveling a task. Read/write Int32.

public int LevelingDelay {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


LevelingDelayFromat Property

Task.LevelingDelayFromat Property

The format of expressing the duration of a delay. Read/write TimeUnitType.

public TimeUnitType LevelingDelayFromat {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


ManualDuration Property

Task.ManualDuration Property

Defines manually scheduled duration of the tasks. Read/write TimeSpan.

public TimeSpan ManualDuration {get; set;}

Remarks

This is a new for MS Project 2010 property. Returns TimeSpan.MinValue if not defined.

See Also

Task Class | Aspose.Tasks Namespace


ManualFinish Property

Task.ManualFinish Property

Defines manually scheduled finish of the tasks. Read/write DateTime.

public DateTime ManualFinish {get; set;}

Remarks

This is a new for MS Project 2010 property. Returns DateTime.MinValue if not defined.

See Also

Task Class | Aspose.Tasks Namespace


ManualStart Property

Task.ManualStart Property

Defines manually scheduled start of the tasks. Read/write DateTime.

public DateTime ManualStart {get; set;}

Remarks

This is a new for MS Project 2010 property. Returns DateTime.MinValue if not defined.

See Also

Task Class | Aspose.Tasks Namespace


Name Property

Task.Name Property

The name of a task. Read/write String.

public string Name {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Notes Property

Task.Notes Property

NOTE: This property is now obsolete.

Use NotesText or NotesRTF instead.

The text notes associated with a task. Read/write String.

public string Notes {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


NotesRTF Property

Task.NotesRTF Property

The text notes in RTF format. Read only String.

public string NotesRTF {get;}

Remarks

Supported for MPP formats only.

See Also

Task Class | Aspose.Tasks Namespace


NotesText Property

Task.NotesText Property

Notes' plain text extracted from RTF data. Read/write String.

public string NotesText {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


OutlineCode Property

Task.OutlineCode Property

Returns List<OutlineCode> OutlineCode.

public OutlineCode} OutlineCode {get; set;}

Remarks

Two pieces of data are necessary - a pointer to the outline code table that is specified by the FieldID, and the value that is specified either by the ValueID or ValueGUID pointer to the value list.

See Also

Task Class | Aspose.Tasks Namespace


OutlineLevel Property

Task.OutlineLevel Property

The outline level of a task. Read/write Int32.

public int OutlineLevel {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


OutlineNumber Property

Task.OutlineNumber Property

The outline number of a task. Read/write String.

public string OutlineNumber {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


OvertimeCost Property

Task.OvertimeCost Property

The sum of an actual and remaining overtime cost of a task. Read/write Decimal.

public decimal OvertimeCost {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


OvertimeWork Property

Task.OvertimeWork Property

The amount of an overtime work scheduled for a task. Read/write TimeSpan.

public TimeSpan OvertimeWork {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


ParentProject Property

Task.ParentProject Property

The parent project of a task. Read/write Project.

public Project ParentProject {get; set;}

Remarks

Call Project.UpdateReferences to update these properties.

See Also

Task Class | Aspose.Tasks Namespace


ParentTask Property

Task.ParentTask Property

The parent task of a task. Read/write Task.

public Task ParentTask {get; set;}

Remarks

Call Project.UpdateReferences to update these properties.

See Also

Task Class | Aspose.Tasks Namespace


PercentComplete Property

Task.PercentComplete Property

The percentage of the task duration completed. Read/write Int32.

public virtual int PercentComplete {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


PercentWorkComplete Property

Task.PercentWorkComplete Property

The percentage of a task work completed. Read/write Int32.

public int PercentWorkComplete {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


PhysicalPercentComplete Property

Task.PhysicalPercentComplete Property

The percentage complete value entered by the Project Manager. This can be used as an alternative for calculating BCWP. Read/write Int32.

public int PhysicalPercentComplete {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


PreLeveledFinish Property

Task.PreLeveledFinish Property

The finish date of a task before it was leveled. Read/write DateTime.

public DateTime PreLeveledFinish {get; set;}

Remarks

Reading supported for XML and MS Project 2003/2007 MPP formats only.

See Also

Task Class | Aspose.Tasks Namespace


PreLeveledStart Property

Task.PreLeveledStart Property

The start date of a task before it was leveled. Read/write DateTime.

public DateTime PreLeveledStart {get; set;}

Remarks

Reading supported for XML and MS Project 2003/2007 MPP formats only.

See Also

Task Class | Aspose.Tasks Namespace


Priority Property

Task.Priority Property

The priority of a task from 0 to 1000. Read/write Int32.

public int Priority {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


RegularWork Property

Task.RegularWork Property

The amount of non-overtime work scheduled for a task. Read/write TimeSpan.

public TimeSpan RegularWork {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


RemainingCost Property

Task.RemainingCost Property

The remaining projected cost of completing a task. Read/write Decimal.

public decimal RemainingCost {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


RemainingDuration Property

Task.RemainingDuration Property

The amount of time required to complete the unfinished portion of a task. Read/write TimeSpan.

public TimeSpan RemainingDuration {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


RemainingOvertimeCost Property

Task.RemainingOvertimeCost Property

The remaining overtime cost projected to finish a task. Read/write Decimal.

public decimal RemainingOvertimeCost {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


RemainingOvertimeWork Property

Task.RemainingOvertimeWork Property

The remaining overtime work scheduled to finish a task. Read/write TimeSpan.

public TimeSpan RemainingOvertimeWork {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


RemainingWork Property

Task.RemainingWork Property

The remaining work scheduled to complete a task. Read/write TimeSpan.

public TimeSpan RemainingWork {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Resume Property

Task.Resume Property

The date when a task resumed. Read/write DateTime.

public DateTime Resume {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


SplitParts Property

Task.SplitParts Property

Returns a SplitPart collection that represents the portions of a task. Read only SplitPartCollection.

public SplitPartCollection SplitParts {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Start Property

Task.Start Property

The scheduled start date of a task. Read/write DateTime.

public virtual DateTime Start {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


StartSlack Property

Task.StartSlack Property

Returns the task's start slack. Read/write Int32.

public int StartSlack {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


StartText Property

Task.StartText Property

Returns the task's start text. Read/write String.

public string StartText {get; set;}

Remarks

This is a new for MS Project 2010 property. Returns null if not defined.

See Also

Task Class | Aspose.Tasks Namespace


StartVariance Property

Task.StartVariance Property

The variance of the task start date from the baseline start date as minutes. Read/write Int32.

public int StartVariance {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


StatusManager Property

Task.StatusManager Property

The name of a task status manager. Read/write String.

public string StatusManager {get; set;}

Remarks

Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


Stop Property

Task.Stop Property

The date when a task was stopped. Read/write DateTime.

public DateTime Stop {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


SubprojectName Property

Task.SubprojectName Property

The source location of a subproject. Read/write String.

public string SubprojectName {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


TimephasedData Property

Task.TimephasedData Property

Returns List<TimephasedData> TimephasedData. The timephased data block associated with a task. Read/write List of TimephasedData.

public TimephasedData} TimephasedData {get; set;}

Remarks

Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


TotalSlack Property

Task.TotalSlack Property

The amount of a total slack. Read/write Int32.

public int TotalSlack {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


TotalSlak Property

Task.TotalSlak Property

NOTE: This property is now obsolete.

Use TotalSlack instead of it.

The amount of a total slack. Read/write Int32.

public int TotalSlak {get; set;}

Remarks

The property is obsolete, use TotalSlack instead of it.

See Also

Task Class | Aspose.Tasks Namespace


Type Property

Task.Type Property

The type of a task. Read/write TaskType.

public TaskType Type {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Uid Property

Task.Uid Property

The unique Id of a task. Read/write Int32.

public int Uid {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


Wbs Property

Task.Wbs Property

The work breakdown structure code of a task. Read/write String.

public string Wbs {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


WbsLevel Property

Task.WbsLevel Property

The rightmost WBS level of a task. Read/write String.

public string WbsLevel {get; set;}

Remarks

Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


Work Property

Task.Work Property

The amount of the scheduled work for a task. Read/write TimeSpan.

public TimeSpan Work {get; set;}

See Also

Task Class | Aspose.Tasks Namespace


WorkVariance Property

Task.WorkVariance Property

The variance of the task work from the baseline task work as minutes. Read/write Double.

public double WorkVariance {get; set;}

Remarks

Reading supported for XML format only.

See Also

Task Class | Aspose.Tasks Namespace


Task Methods

The methods of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Static Methods

Recalculate | Recalculates task start/finish dates according to task duration. If duration is not set then sets default task duration. If applied to Project.RootTask reschedules all project's tasks start/finish dates, sets early/late dates and calulate slacks.
SetPercentComplete | Overloaded. Sets PercentComplete Property of task and makes necessary recalculations of ResourceAssignments if there are any.

Public Instance Methods

Clone | Creates full copy of a task without subtasks.
Delete | Deletes task from parent project tasks collection and all its assignments.
Equals | Returns a value indicating whether this instance is equal to a specified object.
GetDuration | Returns task duration in specified format.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OutlineIndent | Indents a task in the outline.
OutlineOutdent | Promotes a task in the outline.
SetPercentComplete | Overloaded. Sets PercentComplete Property of task instance and makes necessary recalculations of ResourceAssignments if there are any.
TimeScaleData | Overloaded. Returns timephased data within given start and end dates of specified timephasedDataType.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Task Class | Aspose.Tasks Namespace


Task.Clone Method

Creates full copy of a task without subtasks.

public object Clone();

Return Value

Created copy of a task.

See Also

Task Class | Aspose.Tasks Namespace


Task.Delete Method

Deletes task from parent project tasks collection and all its assignments.

public void Delete();

See Also

Task Class | Aspose.Tasks Namespace


Task.Equals Method

Returns a value indicating whether this instance is equal to a specified object.

public override bool Equals(
object o
);

Parameters

o
The object to compare with this instance.

Return Value

True if o is a Task that has the same Uid value as this instance; otherwise, false.

See Also

Task Class | Aspose.Tasks Namespace


Task.GetDuration Method

Returns task duration in specified format.

public double GetDuration(
TimeUnitType formatType
);

Parameters

formatType
TimeUnitType to get task duration in.

Return Value

Task duration in specified format.

See Also

Task Class | Aspose.Tasks Namespace


Task.OutlineIndent Method

Indents a task in the outline.

public void OutlineIndent();

See Also

Task Class | Aspose.Tasks Namespace


Task.OutlineOutdent Method

Promotes a task in the outline.

public void OutlineOutdent();

See Also

Task Class | Aspose.Tasks Namespace


Task.Recalculate Method

Recalculates task start/finish dates according to task duration. If duration is not set then sets default task duration. If applied to Project.RootTask reschedules all project's tasks start/finish dates, sets early/late dates and calulate slacks.

public static void Recalculate(
Task task
);

Parameters

task
Root task to recalculate.

See Also

Task Class | Aspose.Tasks Namespace


SetPercentComplete Method

Task.SetPercentComplete Method

Sets PercentComplete Property of task and makes necessary recalculations of ResourceAssignments if there are any.

Overload List

Sets PercentComplete Property of task and makes necessary recalculations of ResourceAssignments if there are any.

public static void SetPercentComplete(Task,int);

Sets PercentComplete Property of task instance and makes necessary recalculations of ResourceAssignments if there are any.

public void SetPercentComplete(int);

See Also

Task Class | Aspose.Tasks Namespace


Task.SetPercentComplete Method (Task, Int32)

Sets PercentComplete Property of task and makes necessary recalculations of ResourceAssignments if there are any.

public static void SetPercentComplete(
Task task,
int percent
);

Parameters

task
Task to set PercentComplete Property.
percent
Percent to set (from 0 to 100).

See Also

Task Class | Aspose.Tasks Namespace | Task.SetPercentComplete Overload List


Task.SetPercentComplete Method (Int32)

Sets PercentComplete Property of task instance and makes necessary recalculations of ResourceAssignments if there are any.

public void SetPercentComplete(
int percent
);

Parameters

percent
Percent to set (from 0 to 100).

See Also

Task Class | Aspose.Tasks Namespace | Task.SetPercentComplete Overload List


TimeScaleData Method

Task.TimeScaleData Method

Returns timephased data within given start and end dates of TaskTimeScaledData.TaskTimescaledWork type.

Overload List

Returns timephased data within given start and end dates of TaskTimeScaledData.TaskTimescaledWork type.

public TimephasedData} TimeScaleData(DateTime,DateTime);

Returns timephased data within given start and end dates of specified timephasedDataType.

public TimephasedData} TimeScaleData(DateTime,DateTime,TimephasedDataType);

See Also

Task Class | Aspose.Tasks Namespace


Task.TimeScaleData Method (DateTime, DateTime)

Returns timephased data within given start and end dates of TaskTimeScaledData.TaskTimescaledWork type.

public List<TimephasedData> TimeScaleData(
DateTime start,
DateTime end
);

Parameters

start
The start date for the timephased data.
end
The end date for the timephased data.

Return Value

List of TimephasedData to be filled in.

See Also

Task Class | Aspose.Tasks Namespace | Task.TimeScaleData Overload List


Task.TimeScaleData Method (DateTime, DateTime, TimephasedDataType)

Returns timephased data within given start and end dates of specified timephasedDataType.

public List<TimephasedData> TimeScaleData(
DateTime start,
DateTime end,
TimephasedDataType timephasedType
);

Parameters

start
The start date for the timephased data.
end
The end date for the timephased data.
timephasedType
The type of timephased data (TimephasedDataType).

See Also

Task Class | Aspose.Tasks Namespace | Task.TimeScaleData Overload List


TaskBaseline Class

Represents Baseline of a Task.

For a list of all members of this type, see TaskBaseline Members.

System.Object
Aspose.Tasks.Baseline
Aspose.Tasks.TaskBaseline

public class TaskBaseline : Baseline

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

TaskBaseline Members | Aspose.Tasks Namespace


TaskBaseline Members

TaskBaseline overview

Public Instance Constructors

TaskBaseline Constructor Default constructor.

Public Instance Properties

BaselineNumber (inherited from Baseline) | The unique number of a baseline data record. Read/write BaselineType.
Bcwp (inherited from Baseline) | The budgeted cost of a work performed by a resource for a project to-date. Read/write Double.
Bcws (inherited from Baseline) | The budget cost of a work scheduled for a resource. Read/write Double.
Cost (inherited from Baseline) | The projected cost of a resource when the baseline is saved. Read/write Decimal.
Duration | The scheduled duration of the task when the baseline was saved.
DurationFormat | The format for expressing the duration of the task baseline.
EstimatedDuration | Whether the baseline duration of the task was estimated.
Finish | The scheduled finish date of the task when the baseline was saved.
FixedCost | The fixed cost of the task when the baseline was saved.
Interim | Whether this is an Interim Baseline.
Number (inherited from Baseline) | Obsolete. The unique number of a baseline data record. Read/write Int32.
Start | The scheduled start date of the task when the baseline was saved.
TimephasedData | Returns List<TimephasedData> TimephasedData. The timephased data associated with the task baseline.
Work (inherited from Baseline) | The work assigned to a resource when the baseline is saved. Read/write TimeSpan.

Public Instance Methods

CompareTo (inherited from Baseline) |
Equals |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskBaseline Class | Aspose.Tasks Namespace


TaskBaseline Constructor

Default constructor.

public TaskBaseline();

See Also

TaskBaseline Class | Aspose.Tasks Namespace


TaskBaseline Properties

The properties of the TaskBaseline class are listed below. For a complete list of TaskBaseline class members, see the TaskBaseline Members topic.

Public Instance Properties

BaselineNumber (inherited from Baseline) | The unique number of a baseline data record. Read/write BaselineType.
Bcwp (inherited from Baseline) | The budgeted cost of a work performed by a resource for a project to-date. Read/write Double.
Bcws (inherited from Baseline) | The budget cost of a work scheduled for a resource. Read/write Double.
Cost (inherited from Baseline) | The projected cost of a resource when the baseline is saved. Read/write Decimal.
Duration | The scheduled duration of the task when the baseline was saved.
DurationFormat | The format for expressing the duration of the task baseline.
EstimatedDuration | Whether the baseline duration of the task was estimated.
Finish | The scheduled finish date of the task when the baseline was saved.
FixedCost | The fixed cost of the task when the baseline was saved.
Interim | Whether this is an Interim Baseline.
Number (inherited from Baseline) | Obsolete. The unique number of a baseline data record. Read/write Int32.
Start | The scheduled start date of the task when the baseline was saved.
TimephasedData | Returns List<TimephasedData> TimephasedData. The timephased data associated with the task baseline.
Work (inherited from Baseline) | The work assigned to a resource when the baseline is saved. Read/write TimeSpan.

See Also

TaskBaseline Class | Aspose.Tasks Namespace


Duration Property

TaskBaseline.Duration Property

The scheduled duration of the task when the baseline was saved.

public TimeSpan Duration {get; set;}

See Also

TaskBaseline Class | Aspose.Tasks Namespace


DurationFormat Property

TaskBaseline.DurationFormat Property

The format for expressing the duration of the task baseline.

public TimeUnitType DurationFormat {get; set;}

See Also

TaskBaseline Class | Aspose.Tasks Namespace


EstimatedDuration Property

TaskBaseline.EstimatedDuration Property

Whether the baseline duration of the task was estimated.

public bool EstimatedDuration {get; set;}

See Also

TaskBaseline Class | Aspose.Tasks Namespace


Finish Property

TaskBaseline.Finish Property

The scheduled finish date of the task when the baseline was saved.

public DateTime Finish {get; set;}

See Also

TaskBaseline Class | Aspose.Tasks Namespace


FixedCost Property

TaskBaseline.FixedCost Property

The fixed cost of the task when the baseline was saved.

public double FixedCost {get; set;}

See Also

TaskBaseline Class | Aspose.Tasks Namespace


Interim Property

TaskBaseline.Interim Property

Whether this is an Interim Baseline.

public bool Interim {get; set;}

See Also

TaskBaseline Class | Aspose.Tasks Namespace


Start Property

TaskBaseline.Start Property

The scheduled start date of the task when the baseline was saved.

public DateTime Start {get; set;}

See Also

TaskBaseline Class | Aspose.Tasks Namespace


TimephasedData Property

TaskBaseline.TimephasedData Property

Returns List<TimephasedData> TimephasedData. The timephased data associated with the task baseline.

public TimephasedData} TimephasedData {get; set;}

See Also

TaskBaseline Class | Aspose.Tasks Namespace


TaskBaseline Methods

The methods of the TaskBaseline class are listed below. For a complete list of TaskBaseline class members, see the TaskBaseline Members topic.

Public Instance Methods

CompareTo (inherited from Baseline) |
Equals |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskBaseline Class | Aspose.Tasks Namespace


TaskBaseline.Equals Method

public override bool Equals(
object obj
);

See Also

TaskBaseline Class | Aspose.Tasks Namespace


TaskLink Class

Represents a predecessor link.

For a list of all members of this type, see TaskLink Members.

System.Object
Aspose.Tasks.TaskLink

public class TaskLink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

TaskLink Members | Aspose.Tasks Namespace


TaskLink Members

TaskLink overview

Public Instance Constructors

TaskLink Constructor Default constructor.

Public Instance Properties

CrossProjectName | The external predecessor project. Read/write String.
IsCrossProject | Determines whether a predecessor is part of another project. Read/write Boolean.
LagFormat | The format for expressing the lag format. Read/write TimeUnitType.
LinkLag | The amount of lag in tenths of a minute. Read/write Int32.
LinkType | The type of a link. Read/write TaskLinkType.
PredTask | The predecessor task. Read/write Task.
SuccTask | The successor task. Read/write Task.

Public Instance Methods

Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskLink Class | Aspose.Tasks Namespace


TaskLink Constructor

Default constructor.

public TaskLink(
Task predTask,
Task succTask,
TaskLinkType linkType
);

Parameters

predTask
Predecessor task.
succTask
Successor task.
linkType
Type of the link.

See Also

TaskLink Class | Aspose.Tasks Namespace


TaskLink Properties

The properties of the TaskLink class are listed below. For a complete list of TaskLink class members, see the TaskLink Members topic.

Public Instance Properties

CrossProjectName | The external predecessor project. Read/write String.
IsCrossProject | Determines whether a predecessor is part of another project. Read/write Boolean.
LagFormat | The format for expressing the lag format. Read/write TimeUnitType.
LinkLag | The amount of lag in tenths of a minute. Read/write Int32.
LinkType | The type of a link. Read/write TaskLinkType.
PredTask | The predecessor task. Read/write Task.
SuccTask | The successor task. Read/write Task.

See Also

TaskLink Class | Aspose.Tasks Namespace


CrossProjectName Property

TaskLink.CrossProjectName Property

The external predecessor project. Read/write String.

public string CrossProjectName {get; set;}

See Also

TaskLink Class | Aspose.Tasks Namespace


IsCrossProject Property

TaskLink.IsCrossProject Property

Determines whether a predecessor is part of another project. Read/write Boolean.

public bool IsCrossProject {get; set;}

See Also

TaskLink Class | Aspose.Tasks Namespace


LagFormat Property

TaskLink.LagFormat Property

The format for expressing the lag format. Read/write TimeUnitType.

public TimeUnitType LagFormat {get; set;}

See Also

TaskLink Class | Aspose.Tasks Namespace


LinkLag Property

TaskLink.LinkLag Property

The amount of lag in tenths of a minute. Read/write Int32.

public int LinkLag {get; set;}

See Also

TaskLink Class | Aspose.Tasks Namespace


LinkType Property

TaskLink.LinkType Property

The type of a link. Read/write TaskLinkType.

public TaskLinkType LinkType {get; set;}

See Also

TaskLink Class | Aspose.Tasks Namespace


PredTask Property

TaskLink.PredTask Property

The predecessor task. Read/write Task.

public Task PredTask {get; set;}

See Also

TaskLink Class | Aspose.Tasks Namespace


SuccTask Property

TaskLink.SuccTask Property

The successor task. Read/write Task.

public Task SuccTask {get; set;}

See Also

TaskLink Class | Aspose.Tasks Namespace


TaskLink Methods

The methods of the TaskLink class are listed below. For a complete list of TaskLink class members, see the TaskLink Members topic.

Public Instance Methods

Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskLink Class | Aspose.Tasks Namespace


TaskLink.Equals Method

Returns a value indicating whether this instance is equal to a specified object.

public override bool Equals(
object obj
);

Parameters

obj
The object to compare with this instance.

Return Value

True if obj is a TaskLink that has the same predecessor and successor as this instance; otherwise, false.

See Also

TaskLink Class | Aspose.Tasks Namespace


TaskLinkType Enumeration

Specifies the type of tasks dependency.

public enum TaskLinkType

Members

Member Name | Description | Value
FinishToFinish | Finish-Finish relationship | 0
FinishToStart | Finish-Start relationship | 1
StartToFinish | Start-Finish relationship | 2
StartToStart | Start-Start relationship | 3

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


TasksDataFormat Enumeration

Specifies the project data formats.

public enum TasksDataFormat

Members

Member Name | Description | Value
XML | XML (MSPDI) format. | 0
MPP | MPP format, for data update only, real format (MPP9, MPP12, MPP14) defines by original MPP file. | 1

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


TasksException Class

Represents the standard internal exception type.

For a list of all members of this type, see TasksException Members.

System.Object
System.Exception
System.ApplicationException
Aspose.Tasks.TasksException
Aspose.Tasks.TasksReadingException
Aspose.Tasks.TasksWritingException

public class TasksException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

TasksException Members | Aspose.Tasks Namespace


TasksException Members

TasksException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TasksException Class | Aspose.Tasks Namespace


TasksReadingException Class

Represents the standard internal reading exception type.

For a list of all members of this type, see TasksReadingException Members.

System.Object
System.Exception
System.ApplicationException
Aspose.Tasks.TasksException
Aspose.Tasks.TasksReadingException

public class TasksReadingException : TasksException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

TasksReadingException Members | Aspose.Tasks Namespace


TasksReadingException Members

TasksReadingException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
LogText | Exception logging information.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TasksReadingException Class | Aspose.Tasks Namespace


TasksReadingException Properties

The properties of the TasksReadingException class are listed below. For a complete list of TasksReadingException class members, see the TasksReadingException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
LogText | Exception logging information.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

TasksReadingException Class | Aspose.Tasks Namespace


LogText Property

TasksReadingException.LogText Property

Exception logging information.

public string LogText {get;}

See Also

TasksReadingException Class | Aspose.Tasks Namespace


TaskStartDateType Enumeration

Specifies the type of a task's start date.

public enum TaskStartDateType

Remarks

While exporting into XML the Undefined values will be eliminated from resulting XML.

Members

Member Name | Description | Value
Undefined | The field's value was not defined in original project file. | -1
ProjectStartDate | Project start date | 0
CurrentDate | Current date | 1

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


TasksWritingException Class

Represents the standard internal writing exception type.

For a list of all members of this type, see TasksWritingException Members.

System.Object
System.Exception
System.ApplicationException
Aspose.Tasks.TasksException
Aspose.Tasks.TasksWritingException

public class TasksWritingException : TasksException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

TasksWritingException Members | Aspose.Tasks Namespace


TasksWritingException Members

TasksWritingException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
LogText | Exception logging information.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TasksWritingException Class | Aspose.Tasks Namespace


TasksWritingException Properties

The properties of the TasksWritingException class are listed below. For a complete list of TasksWritingException class members, see the TasksWritingException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
LogText | Exception logging information.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

TasksWritingException Class | Aspose.Tasks Namespace


LogText Property

TasksWritingException.LogText Property

Exception logging information.

public string LogText {get;}

See Also

TasksWritingException Class | Aspose.Tasks Namespace


TaskType Enumeration

Specifies the type of a task.

public enum TaskType

Remarks

While exporting into XML the Undefined values will be eliminated from resulting XML.

Members

Member Name | Description | Value
Undefined | Undefined value means that the field was not defined in original file | -1
FixedUnits | Fixed units | 0
FixedDuration | Fixed duration | 1
FixedWork | Fixed work | 2

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


TaskXMLCreationFinished Delegate

Task's XML element creation finished delegate for XML data postprocessing.

public delegate void TaskXMLCreationFinished(
XmlElement element,
Task task
);

Parameters

element
The XML element.
task
The task.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


TaskXMLParsingFinished Delegate

Task's XML parsing finish delegate for task's XML custom data processing.

public delegate void TaskXMLParsingFinished(
XmlElement element,
Task task
);

Parameters

element
The task's XML element
task
The task.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


TimephasedData Class

Represents a time phased data.

For a list of all members of this type, see TimephasedData Members.

System.Object
Aspose.Tasks.TimephasedData

public class TimephasedData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

TimephasedData Members | Aspose.Tasks Namespace


TimephasedData Members

TimephasedData overview

Public Instance Constructors

TimephasedData Constructor TimephasedData class default constractor.

Public Instance Properties

Finish | The finish date of a timephased data period. Read/write DateTime.
Start | The start date of a timephased data period. Read/write DateTime.
TimephasedDataType | The type of a timephased data. Read/write TimephasedDataType.
Type | Obsolete. The type of a timephased data. Read/write Int32.
Uid | The unique identifier of a timephased data Read/write Int32.
Unit | The time unit of a timephased data period. Read/write TimeUnitType.
Value | The value per unit of time for a timephased data period. Read/write String.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimephasedData Class | Aspose.Tasks Namespace


TimephasedData Constructor

TimephasedData class default constractor.

public TimephasedData();

See Also

TimephasedData Class | Aspose.Tasks Namespace


TimephasedData Properties

The properties of the TimephasedData class are listed below. For a complete list of TimephasedData class members, see the TimephasedData Members topic.

Public Instance Properties

Finish | The finish date of a timephased data period. Read/write DateTime.
Start | The start date of a timephased data period. Read/write DateTime.
TimephasedDataType | The type of a timephased data. Read/write TimephasedDataType.
Type | Obsolete. The type of a timephased data. Read/write Int32.
Uid | The unique identifier of a timephased data Read/write Int32.
Unit | The time unit of a timephased data period. Read/write TimeUnitType.
Value | The value per unit of time for a timephased data period. Read/write String.

See Also

TimephasedData Class | Aspose.Tasks Namespace


Finish Property

TimephasedData.Finish Property

The finish date of a timephased data period. Read/write DateTime.

public DateTime Finish {get; set;}

See Also

TimephasedData Class | Aspose.Tasks Namespace


Start Property

TimephasedData.Start Property

The start date of a timephased data period. Read/write DateTime.

public DateTime Start {get; set;}

See Also

TimephasedData Class | Aspose.Tasks Namespace


TimephasedDataType Property

TimephasedData.TimephasedDataType Property

The type of a timephased data. Read/write TimephasedDataType.

public TimephasedDataType TimephasedDataType {get; set;}

See Also

TimephasedData Class | Aspose.Tasks Namespace


Type Property

TimephasedData.Type Property

NOTE: This property is now obsolete.

Use TimephasedDataType instead of it.

The type of a timephased data. Read/write Int32.

public int Type {get; set;}

See Also

TimephasedData Class | Aspose.Tasks Namespace


Uid Property

TimephasedData.Uid Property

The unique identifier of a timephased data Read/write Int32.

public int Uid {get; set;}

See Also

TimephasedData Class | Aspose.Tasks Namespace


Unit Property

TimephasedData.Unit Property

The time unit of a timephased data period. Read/write TimeUnitType.

public TimeUnitType Unit {get; set;}

See Also

TimephasedData Class | Aspose.Tasks Namespace


Value Property

TimephasedData.Value Property

The value per unit of time for a timephased data period. Read/write String.

public string Value {get; set;}

See Also

TimephasedData Class | Aspose.Tasks Namespace


TimephasedDataType Enumeration

Specifies the type of timephased data.

public enum TimephasedDataType

Members

Member Name | Description | Value
Undefined | Undefined value. | -1
AssignmentRemainingWork | Assignment Remaining Work. | 1
AssignmentActualWork | Assignment Actual Work. | 2
AssignmentActualOvertimeWork | Assignment Actual Overtime Work. | 3
AssignmentBaselineWork | Assignment Baseline Work. | 4
AssignmentBaselineCost | Assignment Baseline Cost. | 5
AssignmentActualCost | Assignment Actual Cost. | 6
ResourceBaselineWork | Resource Baseline Work. | 7
ResourceBaselineCost | Resource Baseline Cost. | 8
TaskBaselineWork | Task Baseline Work. | 9
TaskBaselineCost | Task Baseline Cost. | 10
TaskPercentComplete | Task Percent Complete. | 11
AssignmentBaseline1Work | Assignment Baseline 1 Work | 16
AssignmentBaseline1Cost | Assignment Baseline 1 Cost. | 17
TaskBaseline1Work | Task Baseline 1 Work. | 18
TaskBaseline1Cost | Task Baseline 1 Cost. | 19
ResourceBaseline1Work | Resource Baseline 1 Work. | 20
ResourceBaseline1Cost | Resource Baseline 1 Cost. | 21
AssignmentBaseline2Work | Assignment Baseline 2 Work. | 22
AssignmentBaseline2Cost | Assignment Baseline 2 Cost. | 23
TaskBaseline2Work | Task Baseline 2 Work. | 24
TaskBaseline2Cost | Task Baseline 2 Cost. | 25
ResourceBaseline2Work | Resource Baseline 2 Work. | 26
ResourceBaseline2Cost | Resource Baseline 2 Cost. | 27
AssignmentBaseline3Work | Assignment Baseline 3 Work. | 28
AssignmentBaseline3Cost | Assignment Baseline 3 Cost. | 29
TaskBaseline3Work | Task Baseline 3 Work. | 30
TaskBaseline3Cost | Task Baseline 3 Cost. | 31
ResourceBaseline3Work | Resource Baseline 3 Work. | 32
ResourceBaseline3Cost | Resource Baseline 3 Cost. | 33
AssignmentBaseline4Work | Assignment Baseline 4 Work. | 34
AssignmentBaseline4Cost | Assignment Baseline 4 Cost. | 35
TaskBaseline4Work | Task Baseline 4 Work. | 36
TaskBaseline4Cost | Task Baseline 4 Cost. | 37
ResourceBaseline4Work | Resource Baseline 4 Work. | 38
ResourceBaseline4Cost | Resource Baseline 4 Cost. | 39
AssignmentBaseline5Work | Assignment Baseline 5 Work. | 40
AssignmentBaseline5Cost | Assignment Baseline 5 Cost. | 41
TaskBaseline5Work | Task Baseline 5 Work. | 42
TaskBaseline5Cost | Task Baseline 5 Cost. | 43
ResourceBaseline5Work | Resource Baseline 5 Work. | 44
ResourceBaseline5Cost | Resource Baseline 5 Cost. | 45
AssignmentBaseline6Work | Assignment Baseline 6 Work. | 46
AssignmentBaseline6Cost | Assignment Baseline 6 Cost. | 47
TaskBaseline6Work | Task Baseline 6 Work. | 48
TaskBaseline6Cost | Task Baseline 6 Cost. | 49
ResourceBaseline6Work | Resource Baseline 6 Work. | 50
ResourceBaseline6Cost | Resource Baseline 6 Cost. | 51
AssignmentBaseline7Work | Assignment Baseline 7 Work. | 52
AssignmentBaseline7Cost | Assignment Baseline 7 Cost. | 53
TaskBaseline7Work | Task Baseline 7 Work. | 54
TaskBaseline7Cost | Task Baseline 7 Cost. | 55
ResourceBaseline7Work | Resource Baseline 7 Work | 56
ResourceBaseline7Cost | Resource Baseline 7 Cost. | 57
AssignmentBaseline8Work | Assignment Baseline 8 Work. | 58
AssignmentBaseline8Cost | Assignment Baseline 8 Cost. | 59
TaskBaseline8Work | Task Baseline 8 Work. | 60
TaskBaseline8Cost | Task Baseline 8 Cost. | 61
ResourceBaseline8Work | Resource Baseline 8 Work. | 62
ResourceBaseline8Cost | Resource Baseline 8 Cost. | 63
AssignmentBaseline9Work | Assignment Baseline 9 Work. | 64
AssignmentBaseline9Cost | Assignment Baseline 9 Cost. | 65
TaskBaseline9Work | Task Baseline 9 Work. | 66
TaskBaseline9Cost | Task Baseline 9 Cost. | 67
ResourceBaseline9Work | Resource Baseline 9 Work. | 68
ResourceBaseline9Cost | Resource Baseline 9 Cost. | 69
AssignmentBaseline10Work | Assignment Baseline 10 Work. | 70
AssignmentBaseline10Cost | Assignment Baseline 10 Cost. | 71
TaskBaseline10Work | Task Baseline 10 Work. | 72
TaskBaseline10Cost | Task Baseline 10 Cost. | 73
ResourceBaseline10Work | Resource Baseline 10 Work. | 74
ResourceBaseline10Cost | Resource Baseline 10 Cost. | 75
PhysicalPercentComplete | Physical Percent Complete. | 76
TaskWork | Task Work. | 77
TaskCost | Task Cost. | 78
ResourceWork | Resource Work. | 79
ResourceCost | Resource Cost. | 80
AssignmentWork | Assignment Work. | 81
AssignmentCost | Assignment Cost. | 82

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


TimeUnitType Enumeration

Specifies the type of a time unit.

public enum TimeUnitType

Remarks

While exporting into XML the Undefined values will be eliminated from resulting XML.

Members

Member Name | Description | Value
Undefined | Undefined value means that the field was not defined in original project file. | -1
Minute | Minute | 0
ElapsedMinute | Elapsed minute | 1
Hour | Hour | 2
ElapsedHour | Elapsed hour | 3
Day | Day | 4
ElapsedDay | Elapsed day | 5
Week | Week | 6
ElapsedWeek | Elapsed week | 7
Month | Month | 8
ElapsedMonth | Elapsed month | 9
Percent | Percent | 10
ElapsedPercent | Elapsed percent | 11
Null | Null | 12
MinuteEstimated | Minute estimated | 13
ElapsedMinuteEstimated | Elapsed minute estimated | 14
HourEstimated | Hour estimated | 15
ElapsedHourEstimated | Elapsed hour estimated | 16
DayEstimated | Day estimated | 17
ElapsedDayEstimated | Elapsed day estimated | 18
WeekEstimated | Week estimated | 19
ElapsedWeekEstimated | Elapsed week estimated | 20
MonthEstimated | Month estimated | 21
ElapsedMonthEstimated | Elapsed month estimated | 22
PercentEstimated | Percent estimated | 23
ElapsedPercentEstimated | Elapsed percent estimated | 24
Year | Year | 25

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


Value Class

Represents a value in a value list.

For a list of all members of this type, see Value Members.

System.Object
Aspose.Tasks.Value

public class Value

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Value Members | Aspose.Tasks Namespace


Value Members

Value overview

Public Instance Constructors

Value Constructor Default constructor.

Public Instance Properties

Description | The description of a value. Read/write String.
Id | The unique Id of a value across a project. Read/write Int32.
Phonetic | The phonetic information about custom field name. Read/write String.
Val | The actual value. Read/write String.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Value Class | Aspose.Tasks Namespace


Value Constructor

Default constructor.

public Value();

See Also

Value Class | Aspose.Tasks Namespace


Value Properties

The properties of the Value class are listed below. For a complete list of Value class members, see the Value Members topic.

Public Instance Properties

Description | The description of a value. Read/write String.
Id | The unique Id of a value across a project. Read/write Int32.
Phonetic | The phonetic information about custom field name. Read/write String.
Val | The actual value. Read/write String.

See Also

Value Class | Aspose.Tasks Namespace


Description Property

Value.Description Property

The description of a value. Read/write String.

public string Description {get; set;}

See Also

Value Class | Aspose.Tasks Namespace


Id Property

Value.Id Property

The unique Id of a value across a project. Read/write Int32.

public int Id {get; set;}

See Also

Value Class | Aspose.Tasks Namespace


Phonetic Property

Value.Phonetic Property

The phonetic information about custom field name. Read/write String.

public string Phonetic {get; set;}

See Also

Value Class | Aspose.Tasks Namespace


Val Property

Value.Val Property

The actual value. Read/write String.

public string Val {get; set;}

See Also

Value Class | Aspose.Tasks Namespace


View Class

Represents a view in Project.

For a list of all members of this type, see View Members.

System.Object
Aspose.Tasks.View
Aspose.Tasks.GanttChartView

public class View

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

View Members | Aspose.Tasks Namespace


View Members

View overview

Public Instance Constructors

View Constructor Initializes a new instance of the View class.

Public Instance Properties

Filter | Gets or sets a Filter object representing the filter used in a single view. Read/write Filter.
Group | Gets or sets a Group object representing the group of the single view. Read/write Group.
HighlightFilter | True if Microsoft Project highlights the filter for a single view. Read/write Boolean.
Index | Gets the index of a View object in the Views containing object. Read-only Int32.
Name | Gets the name of a View object. Read/write String.
ParentProject | Gets the parent of the View object. Read-only Project.
Screen | Gets the screen type for the single view. Read-only ViewScreen.
ShowInMenu | True if Project shows the single view name in the View or the Other Views drop-down lists in the Ribbon. Read/write Boolean.
Table | Gets or sets a Table object representing the table of the single view. Read/write Table.
Type | Gets the type of item in the single view, such as tasks or resources. Read-only ItemType.
Uid | The unique identifier of a view.

Public Instance Methods

Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

View Class | Aspose.Tasks Namespace


View Constructor

Initializes a new instance of the View class.

public View();

See Also

View Class | Aspose.Tasks Namespace


View Properties

The properties of the View class are listed below. For a complete list of View class members, see the View Members topic.

Public Instance Properties

Filter | Gets or sets a Filter object representing the filter used in a single view. Read/write Filter.
Group | Gets or sets a Group object representing the group of the single view. Read/write Group.
HighlightFilter | True if Microsoft Project highlights the filter for a single view. Read/write Boolean.
Index | Gets the index of a View object in the Views containing object. Read-only Int32.
Name | Gets the name of a View object. Read/write String.
ParentProject | Gets the parent of the View object. Read-only Project.
Screen | Gets the screen type for the single view. Read-only ViewScreen.
ShowInMenu | True if Project shows the single view name in the View or the Other Views drop-down lists in the Ribbon. Read/write Boolean.
Table | Gets or sets a Table object representing the table of the single view. Read/write Table.
Type | Gets the type of item in the single view, such as tasks or resources. Read-only ItemType.
Uid | The unique identifier of a view.

See Also

View Class | Aspose.Tasks Namespace


Filter Property

View.Filter Property

Gets or sets a Filter object representing the filter used in a single view. Read/write Filter.

public Filter Filter {get; set;}

See Also

View Class | Aspose.Tasks Namespace


Group Property

View.Group Property

Gets or sets a Group object representing the group of the single view. Read/write Group.

public Group Group {get; set;}

See Also

View Class | Aspose.Tasks Namespace


HighlightFilter Property

View.HighlightFilter Property

True if Microsoft Project highlights the filter for a single view. Read/write Boolean.

public bool HighlightFilter {get; set;}

See Also

View Class | Aspose.Tasks Namespace


Index Property

View.Index Property

Gets the index of a View object in the Views containing object. Read-only Int32.

public int Index {get; set;}

See Also

View Class | Aspose.Tasks Namespace


Name Property

View.Name Property

Gets the name of a View object. Read/write String.

public string Name {get; set;}

See Also

View Class | Aspose.Tasks Namespace


ParentProject Property

View.ParentProject Property

Gets the parent of the View object. Read-only Project.

public Project ParentProject {get; set;}

See Also

View Class | Aspose.Tasks Namespace


Screen Property

View.Screen Property

Gets the screen type for the single view. Read-only ViewScreen.

public ViewScreen Screen {get; set;}

See Also

View Class | Aspose.Tasks Namespace


ShowInMenu Property

View.ShowInMenu Property

True if Project shows the single view name in the View or the Other Views drop-down lists in the Ribbon. Read/write Boolean.

public bool ShowInMenu {get; set;}

See Also

View Class | Aspose.Tasks Namespace


Table Property

View.Table Property

Gets or sets a Table object representing the table of the single view. Read/write Table.

public Table Table {get; set;}

See Also

View Class | Aspose.Tasks Namespace


Type Property

View.Type Property

Gets the type of item in the single view, such as tasks or resources. Read-only ItemType.

public ItemType Type {get; set;}

See Also

View Class | Aspose.Tasks Namespace


Uid Property

View.Uid Property

The unique identifier of a view.

public int Uid {get; set;}

See Also

View Class | Aspose.Tasks Namespace


View Methods

The methods of the View class are listed below. For a complete list of View class members, see the View Members topic.

Public Instance Methods

Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

View Class | Aspose.Tasks Namespace


View.Equals Method

Returns a value indicating whether this instance is equal to a specified object.

public override bool Equals(
object obj
);

Parameters

obj
The object to compare with this instance.

Return Value

True if obj is a View that has the same Uid value as this instance; otherwise, false.

See Also

View Class | Aspose.Tasks Namespace


Views Class

Contains a list of View objects. Implements ICollection<View> interface.

For a list of all members of this type, see Views Members.

System.Object
Aspose.Tasks.Views

public class Views : 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], 0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Views Members | Aspose.Tasks Namespace


Views Members

Views overview

Public Instance Properties

Count |
IsReadOnly |
ParentProject | Gets the parent of the View object. Read-only Project.

Public Instance Methods

Add |
Clear |
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToList | Converts a view collection to a list of View objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Views Class | Aspose.Tasks Namespace


Views Properties

The properties of the Views class are listed below. For a complete list of Views class members, see the Views Members topic.

Public Instance Properties

Count |
IsReadOnly |
ParentProject | Gets the parent of the View object. Read-only Project.

See Also

Views Class | Aspose.Tasks Namespace


Count Property

Views.Count Property

public int Count {get;}

Implements

ICollection`1.Count

See Also

Views Class | Aspose.Tasks Namespace


IsReadOnly Property

Views.IsReadOnly Property

public bool IsReadOnly {get;}

Implements

ICollection`1.IsReadOnly

See Also

Views Class | Aspose.Tasks Namespace


ParentProject Property

Views.ParentProject Property

Gets the parent of the View object. Read-only Project.

public Project ParentProject {get; set;}

See Also

Views Class | Aspose.Tasks Namespace


Views Methods

The methods of the Views class are listed below. For a complete list of Views class members, see the Views Members topic.

Public Instance Methods

Add |
Clear |
Contains |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToList | Converts a view collection to a list of View objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Views Class | Aspose.Tasks Namespace


Views.Add Method

public void Add(
View item
);

Implements

ICollection`1.Add

See Also

Views Class | Aspose.Tasks Namespace


Views.Clear Method

public void Clear();

Implements

ICollection`1.Clear

See Also

Views Class | Aspose.Tasks Namespace


Views.Contains Method

public bool Contains(
View item
);

Implements

ICollection`1.Contains

See Also

Views Class | Aspose.Tasks Namespace


Views.CopyTo Method

public void CopyTo(
View[] array,
int arrayIndex
);

Implements

ICollection`1.CopyTo

See Also

Views Class | Aspose.Tasks Namespace


Views.GetEnumerator Method

public IEnumerator<View> GetEnumerator();

Implements

IEnumerable`1.GetEnumerator

See Also

Views Class | Aspose.Tasks Namespace


Views.Remove Method

public bool Remove(
View item
);

Implements

ICollection`1.Remove

See Also

Views Class | Aspose.Tasks Namespace


Views.ToList Method

Converts a view collection to a list of View objects.

public List<View> ToList();

Return Value

Generic list of View objects.

See Also

Views Class | Aspose.Tasks Namespace


ViewScreen Enumeration

Specifies the screen type for a view.

public enum ViewScreen

Members

Member Name | Description | Value
Calendar | Calender View. | 13
Gantt | Gantt View. | 1
NetworkDiagram | Network Diagram View. | 2
RelationshipDiagram | Relationship Diagram View. | 3
ResourceForm | Resource Form View. | 6
ResourceGraph | Resource Graph View. | 8
ResourceNameForm | Resource Name Form View. | 12
ResourceSheet | Resource Sheet View. | 7
ResourceUsage | Resource Usage View. | 15
TaskDetailsForm | Task Details Form View. | 10
TaskForm | Task Form View. | 4
TaskNameForm | Task Name Form View. | 11
TaskSheet | Task Sheet View. | 5
TaskUsage | Task Usage View. | 14

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


WeekDay Class

Represents a weekday which either defines regular days of a week or exception days in a calendar.

For a list of all members of this type, see WeekDay Members.

System.Object
Aspose.Tasks.WeekDay

public class WeekDay : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

WeekDay Members | Aspose.Tasks Namespace


WeekDay Members

WeekDay overview

Public Static Methods

CastToDayType | Casts .Net's DayOfWeek to DayType.
CreateDefaultWorkingDay | Creates default working day.
SetDefaulWorkingTime | Sets default time periods for the specified week day.

Public Instance Constructors

WeekDay Overloaded. Initializes a new instance of the WeekDay class.

Public Instance Properties

DayType | Returns or sets the type of a day. Read/write DayType.
DayWorking | Determines whether the specified date or day type is working. Read/write Boolean.
FromDate | Returns or sets the beginning of an exception time. Read/write DateTime.
ToDate | Returns or sets the end of an exception time. Read/write DateTime.
WorkingTimes | Returns List<WorkingTime> WorkingTimes. The collection of working times that define the time worked on the weekday. Read/write List of WorkingTime.

Public Instance Methods

Clone | Implementation of IClonable interface, returns a deep copy of the week day.
Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWorkingTime | Returns the working time for a week day.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WeekDay Class | Aspose.Tasks Namespace


WeekDay Constructor

Creates new weekday with the specified day type.

Overload List

Default constructor.

public WeekDay();

Creates new weekday with the specified day type.

public WeekDay(DayType);

Creates new weekday with the specified day type and list of working time periods.

public WeekDay(DayType,WorkingTime});

See Also

WeekDay Class | Aspose.Tasks Namespace


WeekDay Constructor (DayType)

Creates new weekday with the specified day type.

public WeekDay(
DayType dayType
);

Parameters

dayType
Day type.

See Also

WeekDay Class | Aspose.Tasks Namespace | WeekDay Constructor Overload List


WeekDay Constructor (DayType, WorkingTime})

Creates new weekday with the specified day type and list of working time periods.

public WeekDay(
DayType dayType,
List<WorkingTime> workingTimes
);

Parameters

dayType
Day type.
workingTimes
List of working time periods.

See Also

WeekDay Class | Aspose.Tasks Namespace | WeekDay Constructor Overload List


WeekDay Constructor ()

Default constructor.

public WeekDay();

See Also

WeekDay Class | Aspose.Tasks Namespace | WeekDay Constructor Overload List


WeekDay Properties

The properties of the WeekDay class are listed below. For a complete list of WeekDay class members, see the WeekDay Members topic.

Public Instance Properties

DayType | Returns or sets the type of a day. Read/write DayType.
DayWorking | Determines whether the specified date or day type is working. Read/write Boolean.
FromDate | Returns or sets the beginning of an exception time. Read/write DateTime.
ToDate | Returns or sets the end of an exception time. Read/write DateTime.
WorkingTimes | Returns List<WorkingTime> WorkingTimes. The collection of working times that define the time worked on the weekday. Read/write List of WorkingTime.

See Also

WeekDay Class | Aspose.Tasks Namespace


DayType Property

WeekDay.DayType Property

Returns or sets the type of a day. Read/write DayType.

public DayType DayType {get; set;}

See Also

WeekDay Class | Aspose.Tasks Namespace


DayWorking Property

WeekDay.DayWorking Property

Determines whether the specified date or day type is working. Read/write Boolean.

public bool DayWorking {get; set;}

See Also

WeekDay Class | Aspose.Tasks Namespace


FromDate Property

WeekDay.FromDate Property

Returns or sets the beginning of an exception time. Read/write DateTime.

public DateTime FromDate {get; set;}

See Also

WeekDay Class | Aspose.Tasks Namespace


ToDate Property

WeekDay.ToDate Property

Returns or sets the end of an exception time. Read/write DateTime.

public DateTime ToDate {get; set;}

See Also

WeekDay Class | Aspose.Tasks Namespace


WorkingTimes Property

WeekDay.WorkingTimes Property

Returns List<WorkingTime> WorkingTimes. The collection of working times that define the time worked on the weekday. Read/write List of WorkingTime.

public WorkingTime} WorkingTimes {get; set;}

See Also

WeekDay Class | Aspose.Tasks Namespace


WeekDay Methods

The methods of the WeekDay class are listed below. For a complete list of WeekDay class members, see the WeekDay Members topic.

Public Static Methods

CastToDayType | Casts .Net's DayOfWeek to DayType.
CreateDefaultWorkingDay | Creates default working day.
SetDefaulWorkingTime | Sets default time periods for the specified week day.

Public Instance Methods

Clone | Implementation of IClonable interface, returns a deep copy of the week day.
Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWorkingTime | Returns the working time for a week day.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WeekDay Class | Aspose.Tasks Namespace


WeekDay.CastToDayType Method

Casts .Net's DayOfWeek to DayType.

public static DayType CastToDayType(
DayOfWeek dw
);

Parameters

dw
Day of week.

Return Value

Day type.

See Also

WeekDay Class | Aspose.Tasks Namespace


WeekDay.Clone Method

Implementation of IClonable interface, returns a deep copy of the week day.

public object Clone();

Return Value

The deep copy.

Implements

ICloneable.Clone

See Also

WeekDay Class | Aspose.Tasks Namespace


WeekDay.CreateDefaultWorkingDay Method

Creates default working day.

public static WeekDay CreateDefaultWorkingDay(
DayType dayType
);

Parameters

dayType
Day type.

Return Value

See Also

WeekDay Class | Aspose.Tasks Namespace


WeekDay.Equals Method

Returns a value indicating whether this instance is equal to a specified object.

public override bool Equals(
object obj
);

Parameters

obj
The object to compare with this instance.

Return Value

True if obj is a WeekDay that has the same FromDate, ToDate values and WoringTimes as this instance; otherwise, false.

See Also

WeekDay Class | Aspose.Tasks Namespace


WeekDay.GetWorkingTime Method

Returns the working time for a week day.

public TimeSpan GetWorkingTime();

Return Value

Working time.

See Also

WeekDay Class | Aspose.Tasks Namespace


WeekDay.SetDefaulWorkingTime Method

Sets default time periods for the specified week day.

public static void SetDefaulWorkingTime(
WeekDay day
);

Parameters

day
Week day.

See Also

WeekDay Class | Aspose.Tasks Namespace


WorkContourType Enumeration

Specifies the contour of a work.

public enum WorkContourType

Remarks

While exporting into XML the Undefined values will be eliminated from resulting XML.

Members

Member Name | Description | Value
Undefined | The value was not defined in original project file. | -1
Flat |  | 0
BackLoaded |  | 1
FrontLoaded |  | 2
DoublePeak |  | 3
EarlyPeak |  | 4
LatePeak |  | 5
Bell |  | 6
Turtle |  | 7
Contoured |  | 8

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


WorkDay Class

Represents a work day.

For a list of all members of this type, see WorkDay Members.

System.Object
Aspose.Tasks.WorkDay

public class WorkDay

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

WorkDay Members | Aspose.Tasks Namespace


WorkDay Members

WorkDay overview

Public Instance Constructors

WorkDay Constructor Initializes a new instance of the WorkDay class.

Public Instance Properties

DayType | Returns or sets the type of a day. Read/write DayType
DayWorking | Determines whether the specified date or day type is working. Read/write Boolean.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WorkDay Class | Aspose.Tasks Namespace


WorkDay Constructor

Initializes a new instance of the WorkDay class.

public WorkDay();

See Also

WorkDay Class | Aspose.Tasks Namespace


WorkDay Properties

The properties of the WorkDay class are listed below. For a complete list of WorkDay class members, see the WorkDay Members topic.

Public Instance Properties

DayType | Returns or sets the type of a day. Read/write DayType
DayWorking | Determines whether the specified date or day type is working. Read/write Boolean.

See Also

WorkDay Class | Aspose.Tasks Namespace


DayType Property

WorkDay.DayType Property

Returns or sets the type of a day. Read/write DayType

public DayType DayType {get; set;}

See Also

WorkDay Class | Aspose.Tasks Namespace


DayWorking Property

WorkDay.DayWorking Property

Determines whether the specified date or day type is working. Read/write Boolean.

public bool DayWorking {get; set;}

See Also

WorkDay Class | Aspose.Tasks Namespace


WorkGroupType Enumeration

Specifies the type of a workgroup.

public enum WorkGroupType

Members

Member Name | Description | Value
Default | Default workgroup | 0
None |  | 1
Email | Email workgroup | 2
Web | Web workgroup | 3

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks Namespace


WorkingTime Class

Represents a working time during a weekday.

For a list of all members of this type, see WorkingTime Members.

System.Object
Aspose.Tasks.WorkingTime

public class WorkingTime

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

WorkingTime Members | Aspose.Tasks Namespace


WorkingTime Members

WorkingTime overview

Public Instance Constructors

WorkingTime Constructor Initializes a new instance of the WorkingTime class.

Public Instance Properties

FromTime | Returns or sets the beginning of a working time. Read/write DateTime.
ToTime | Returns or sets the end of a working time. Read/write DateTime.

Public Instance Methods

Equals | Checks that the objects are equal.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WorkingTime Class | Aspose.Tasks Namespace


WorkingTime Constructor

Initializes a new instance of the WorkingTime class.

public WorkingTime();

See Also

WorkingTime Class | Aspose.Tasks Namespace


WorkingTime Properties

The properties of the WorkingTime class are listed below. For a complete list of WorkingTime class members, see the WorkingTime Members topic.

Public Instance Properties

FromTime | Returns or sets the beginning of a working time. Read/write DateTime.
ToTime | Returns or sets the end of a working time. Read/write DateTime.

See Also

WorkingTime Class | Aspose.Tasks Namespace


FromTime Property

WorkingTime.FromTime Property

Returns or sets the beginning of a working time. Read/write DateTime.

public DateTime FromTime {get; set;}

See Also

WorkingTime Class | Aspose.Tasks Namespace


ToTime Property

WorkingTime.ToTime Property

Returns or sets the end of a working time. Read/write DateTime.

public DateTime ToTime {get; set;}

See Also

WorkingTime Class | Aspose.Tasks Namespace


WorkingTime Methods

The methods of the WorkingTime class are listed below. For a complete list of WorkingTime class members, see the WorkingTime Members topic.

Public Instance Methods

Equals | Checks that the objects are equal.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WorkingTime Class | Aspose.Tasks Namespace


WorkingTime.Equals Method

Checks that the objects are equal.

public override bool Equals(
object obj
);

Parameters

obj
Second object to compare.

Return Value

True if the objects are equal, false otherwise.

See Also

WorkingTime Class | Aspose.Tasks Namespace


WorkUnit Class

Represents working hours.

For a list of all members of this type, see WorkUnit Members.

System.Object
Aspose.Tasks.WorkUnit

public class WorkUnit

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

WorkUnit Members | Aspose.Tasks Namespace


WorkUnit Members

WorkUnit overview

Public Instance Constructors

WorkUnit Constructor Creates new WorkUnit object with the specified From and To dates.

Public Instance Properties

From | Returns or sets the From date. Read/write DateTime.
To | Returns or sets the To date. Read/write DateTime.
WorkingHours | Returns or sets the duration of working hours. Read/write TimeSpan.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WorkUnit Class | Aspose.Tasks Namespace


WorkUnit Constructor

Creates new WorkUnit object with the specified From and To dates.

public WorkUnit(
DateTime from,
DateTime to
);

Parameters

from
Start date of working hours.
to
Finish date of working hours.

See Also

WorkUnit Class | Aspose.Tasks Namespace


WorkUnit Properties

The properties of the WorkUnit class are listed below. For a complete list of WorkUnit class members, see the WorkUnit Members topic.

Public Instance Properties

From | Returns or sets the From date. Read/write DateTime.
To | Returns or sets the To date. Read/write DateTime.
WorkingHours | Returns or sets the duration of working hours. Read/write TimeSpan.

See Also

WorkUnit Class | Aspose.Tasks Namespace


From Property

WorkUnit.From Property

Returns or sets the From date. Read/write DateTime.

public DateTime From {get; set;}

See Also

WorkUnit Class | Aspose.Tasks Namespace


To Property

WorkUnit.To Property

Returns or sets the To date. Read/write DateTime.

public DateTime To {get; set;}

See Also

WorkUnit Class | Aspose.Tasks Namespace


WorkingHours Property

WorkUnit.WorkingHours Property

Returns or sets the duration of working hours. Read/write TimeSpan.

public TimeSpan WorkingHours {get; set;}

See Also

WorkUnit Class | Aspose.Tasks Namespace


WorkWeek Class

Represents a work week.

For a list of all members of this type, see WorkWeek Members.

System.Object
Aspose.Tasks.WorkWeek

public class WorkWeek

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

WorkWeek Members | Aspose.Tasks Namespace


WorkWeek Members

WorkWeek overview

Public Instance Constructors

WorkWeek Constructor Initializes a new instance of the WorkWeek class.

Public Instance Properties

Name | Returns or sets the name of an effective week. Read/write String.
TimePeriod | Returns or sets the contiguous set of exception days. Read/write WorkingTime.
WeekDays | Returns or sets the list of week days. Read/write ArrayList.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WorkWeek Class | Aspose.Tasks Namespace


WorkWeek Constructor

Initializes a new instance of the WorkWeek class.

public WorkWeek();

See Also

WorkWeek Class | Aspose.Tasks Namespace


WorkWeek Properties

The properties of the WorkWeek class are listed below. For a complete list of WorkWeek class members, see the WorkWeek Members topic.

Public Instance Properties

Name | Returns or sets the name of an effective week. Read/write String.
TimePeriod | Returns or sets the contiguous set of exception days. Read/write WorkingTime.
WeekDays | Returns or sets the list of week days. Read/write ArrayList.

See Also

WorkWeek Class | Aspose.Tasks Namespace


Name Property

WorkWeek.Name Property

Returns or sets the name of an effective week. Read/write String.

public string Name {get; set;}

See Also

WorkWeek Class | Aspose.Tasks Namespace


TimePeriod Property

WorkWeek.TimePeriod Property

Returns or sets the contiguous set of exception days. Read/write WorkingTime.

public WorkingTime TimePeriod {get; set;}

See Also

WorkWeek Class | Aspose.Tasks Namespace


WeekDays Property

WorkWeek.WeekDays Property

Returns or sets the list of week days. Read/write ArrayList.

public ArrayList WeekDays {get; set;}

See Also

WorkWeek Class | Aspose.Tasks Namespace


Aspose.Tasks.Saving

Aspose.Tasks.Saving Namespace

Namespace hierarchy

Classes

Class | Description
CsvOptions | /// Allows to specify additional options when saving project to CSV.
ImageSaveOptions | Allows to specify additional options when rendering project pages to images.
PdfDigitalSignatureDetails | Contains details for a pdf digital signature.
PdfEncryptionDetails | Contains details for a pdf encryption.
PdfSaveOptions | Allows to specify additional options when rendering project pages to PDF.
PrimaveraSaveOptions | Allows to specify additional options when saving project to Primavera XER format.
PrintOptions | Allows to specify additional options when printing project.
SaveOptions | This is an abstract base class for classes that allow the user to specify additional options when saving a project into a particular format.
SaveTemplateOptions | Allows to specify additional options when saving a project as a template.
Spreadsheet2003SaveOptions | Allows to specify additional options when rendering project pages to Spreadsheet2003.
SvgOptions | Allows to specify additional options when rendering project pages to SVG.
XamlOptions | /// Allows to specify additional options when rendering project pages to XAML.
XlsxOptions | Allows to specify additional options when rendering project pages to XLSX.
XpsOptions | Allows to specify additional options when rendering project pages to XPS.

Enumerations

Enumeration | Description
CsvTextDelimiter | Text delimiter for csv format.
DataCategory | The category of data used when saving to csv.
PdfCompliance | Specifies the PDF compliance level to output file.
PdfDigitalSignatureHashAlgorithm | Specifies digital hash algorithm used by digital signature.
PdfEncryptionAlgorithm | Specifies the encryption algorithm to use for encrypting a PDF document.
PdfPermissions | Specifies permissions to use for accessing a PDF document.
PdfTextCompression | Specifies a type of compression applied to all content in the PDF file except images.
SaveFileFormat | Enumeration for saving project format selection.
TiffCompression | Specifies what type of compression to apply when saving pages to the TIFF format.


CsvOptions Class

/// Allows to specify additional options when saving project to CSV.

For a list of all members of this type, see CsvOptions Members.

System.Object
Aspose.Tasks.Saving.SaveOptions
Aspose.Tasks.Saving.CsvOptions

public class CsvOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

CsvOptions Members | Aspose.Tasks.Saving Namespace


CsvOptions Members

CsvOptions overview

Public Instance Constructors

CsvOptions Constructor Initializes a new instance of class that can be used to save project in csv format.

Public Instance Properties

BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DataCategory | DataCategory Data category to be saved.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
Encoding | Encoding to save csv with.
EndDate (inherited from SaveOptions) | Date to finish rendering to.
Filter | Filter to be appiled to data before saving. ICondition.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
IncludeHeaders | Specifies whether to include headers or not (default value is TRUE).
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextDelimiter | Text delimiter.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

end (inherited from SaveOptions)
pageCount (inherited from SaveOptions)
presentationFormat (inherited from SaveOptions)
saveFormat (inherited from SaveOptions)
start (inherited from SaveOptions)
timescale (inherited from SaveOptions)
view (inherited from SaveOptions)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CsvOptions Class | Aspose.Tasks.Saving Namespace


CsvOptions Constructor

Initializes a new instance of class that can be used to save project in csv format.

public CsvOptions();

See Also

CsvOptions Class | Aspose.Tasks.Saving Namespace


CsvOptions Properties

The properties of the CsvOptions class are listed below. For a complete list of CsvOptions class members, see the CsvOptions Members topic.

Public Instance Properties

BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DataCategory | DataCategory Data category to be saved.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
Encoding | Encoding to save csv with.
EndDate (inherited from SaveOptions) | Date to finish rendering to.
Filter | Filter to be appiled to data before saving. ICondition.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
IncludeHeaders | Specifies whether to include headers or not (default value is TRUE).
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextDelimiter | Text delimiter.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

See Also

CsvOptions Class | Aspose.Tasks.Saving Namespace


DataCategory Property

CsvOptions.DataCategory Property

DataCategory Data category to be saved.

public DataCategory DataCategory {get; set;}

See Also

CsvOptions Class | Aspose.Tasks.Saving Namespace


Encoding Property

CsvOptions.Encoding Property

Encoding to save csv with.

public Encoding Encoding {get; set;}

See Also

CsvOptions Class | Aspose.Tasks.Saving Namespace


Filter Property

CsvOptions.Filter Property

Filter to be appiled to data before saving. ICondition.

public ICondition Filter {get; set;}

See Also

CsvOptions Class | Aspose.Tasks.Saving Namespace


IncludeHeaders Property

CsvOptions.IncludeHeaders Property

Specifies whether to include headers or not (default value is TRUE).

public bool IncludeHeaders {get; set;}

See Also

CsvOptions Class | Aspose.Tasks.Saving Namespace


TextDelimiter Property

CsvOptions.TextDelimiter Property

Text delimiter.

public CsvTextDelimiter TextDelimiter {get; set;}

See Also

CsvOptions Class | Aspose.Tasks.Saving Namespace


CsvTextDelimiter Enumeration

Text delimiter for csv format.

public enum CsvTextDelimiter

Members

Member Name | Description | Value
Comma | Comma delimiter. | 0
Semicolon | Semicolon delimiter. | 1
Space | Space delimiter. | 2
Tab | Tab delimiter. | 3

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Saving Namespace


DataCategory Enumeration

The category of data used when saving to csv.

public enum DataCategory

Members

Member Name | Description | Value
Tasks | Tasks information. | 0
Resources | Resources information. | 1
Assignments | Assignments information. | 2

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Saving Namespace


ImageSaveOptions Class

Allows to specify additional options when rendering project pages to images.

For a list of all members of this type, see ImageSaveOptions Members.

System.Object
Aspose.Tasks.Saving.SaveOptions
Aspose.Tasks.Saving.ImageSaveOptions

public class ImageSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ImageSaveOptions Members | Aspose.Tasks.Saving Namespace


ImageSaveOptions Members

ImageSaveOptions overview

Public Instance Constructors

ImageSaveOptions Constructor Initializes a new instance of this class that can be used to save rendered images in TIFF, PNG, BMP or JPEG formats.

Public Instance Properties

BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
HorizontalResolution | Gets or sets the horizontal resolution in dpi.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PixelFormat | Gets or sets the format of the color data for each pixel in the image.
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RenderParam | Rendering params (for compliance with obsolete Project.Export method).
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
TiffCompression | Gets or sets the type of compression to apply when saving generated images to the TIFF format.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
VerticalResolution | Gets or sets the vertical resolution in dpi.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

end (inherited from SaveOptions)
pageCount (inherited from SaveOptions)
presentationFormat (inherited from SaveOptions)
saveFormat (inherited from SaveOptions)
start (inherited from SaveOptions)
timescale (inherited from SaveOptions)
view (inherited from SaveOptions)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageSaveOptions Class | Aspose.Tasks.Saving Namespace


ImageSaveOptions Constructor

Initializes a new instance of this class that can be used to save rendered images in TIFF, PNG, BMP or JPEG formats.

public ImageSaveOptions(
SaveFileFormat saveFormat
);

Parameters

saveFormat
Can be TIFF, PNG, BMP or JPEG SaveFileFormat.

See Also

ImageSaveOptions Class | Aspose.Tasks.Saving Namespace


ImageSaveOptions Properties

The properties of the ImageSaveOptions class are listed below. For a complete list of ImageSaveOptions class members, see the ImageSaveOptions Members topic.

Public Instance Properties

BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
HorizontalResolution | Gets or sets the horizontal resolution in dpi.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PixelFormat | Gets or sets the format of the color data for each pixel in the image.
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RenderParam | Rendering params (for compliance with obsolete Project.Export method).
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
TiffCompression | Gets or sets the type of compression to apply when saving generated images to the TIFF format.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
VerticalResolution | Gets or sets the vertical resolution in dpi.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

See Also

ImageSaveOptions Class | Aspose.Tasks.Saving Namespace


HorizontalResolution Property

ImageSaveOptions.HorizontalResolution Property

Gets or sets the horizontal resolution in dpi.

public float HorizontalResolution {get; set;}

See Also

ImageSaveOptions Class | Aspose.Tasks.Saving Namespace


PixelFormat Property

ImageSaveOptions.PixelFormat Property

Gets or sets the format of the color data for each pixel in the image.

public PixelFormat PixelFormat {get; set;}

See Also

ImageSaveOptions Class | Aspose.Tasks.Saving Namespace


RenderParam Property

ImageSaveOptions.RenderParam Property

Rendering params (for compliance with obsolete Project.Export method).

public IRenderParam RenderParam {get; set;}

See Also

ImageSaveOptions Class | Aspose.Tasks.Saving Namespace


TiffCompression Property

ImageSaveOptions.TiffCompression Property

Gets or sets the type of compression to apply when saving generated images to the TIFF format.

public TiffCompression TiffCompression {get; set;}

Remarks

Has effect only when saving to TIFF. The default value is Lzw.

See Also

ImageSaveOptions Class | Aspose.Tasks.Saving Namespace


VerticalResolution Property

ImageSaveOptions.VerticalResolution Property

Gets or sets the vertical resolution in dpi.

public float VerticalResolution {get; set;}

See Also

ImageSaveOptions Class | Aspose.Tasks.Saving Namespace


PdfCompliance Enumeration

Specifies the PDF compliance level to output file.

public enum PdfCompliance

Members

Member Name | Description | Value
Pdf15 | PDF/15 level of compliance. | 0
PdfA1a | PDF/A-1a level of compliance. | 1
PdfA1b | PDF/A-1b level of compliance. | 2

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Saving Namespace


PdfDigitalSignatureDetails Class

Contains details for a pdf digital signature.

For a list of all members of this type, see PdfDigitalSignatureDetails Members.

System.Object
Aspose.Tasks.Saving.PdfDigitalSignatureDetails

public class PdfDigitalSignatureDetails

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

At the moment digitally signing PDF documents is only available on .NET 2.0 or higher.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

PdfDigitalSignatureDetails Members | Aspose.Tasks.Saving Namespace


PdfDigitalSignatureDetails Members

PdfDigitalSignatureDetails overview

Public Instance Constructors

PdfDigitalSignatureDetails Constructor Ctor.

Public Instance Properties

Certificate | Certificate to sign with.
HashAlgorithm | Hash algorithm.
Location | Location of signing.
Reason | The reason of signing.
SignatureDate | Date of signing.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PdfDigitalSignatureDetails Class | Aspose.Tasks.Saving Namespace


PdfDigitalSignatureDetails Constructor

Ctor.

public PdfDigitalSignatureDetails(
X509Certificate2 certificate,
string reason,
string location,
DateTime signatureDate,
PdfDigitalSignatureHashAlgorithm hashAlgorithm
);

See Also

PdfDigitalSignatureDetails Class | Aspose.Tasks.Saving Namespace


PdfDigitalSignatureDetails Properties

The properties of the PdfDigitalSignatureDetails class are listed below. For a complete list of PdfDigitalSignatureDetails class members, see the PdfDigitalSignatureDetails Members topic.

Public Instance Properties

Certificate | Certificate to sign with.
HashAlgorithm | Hash algorithm.
Location | Location of signing.
Reason | The reason of signing.
SignatureDate | Date of signing.

See Also

PdfDigitalSignatureDetails Class | Aspose.Tasks.Saving Namespace


Certificate Property

PdfDigitalSignatureDetails.Certificate Property

Certificate to sign with.

public X509Certificate2 Certificate {get; set;}

See Also

PdfDigitalSignatureDetails Class | Aspose.Tasks.Saving Namespace


HashAlgorithm Property

PdfDigitalSignatureDetails.HashAlgorithm Property

Hash algorithm.

public PdfDigitalSignatureHashAlgorithm HashAlgorithm {get; set;}

See Also

PdfDigitalSignatureDetails Class | Aspose.Tasks.Saving Namespace


Location Property

PdfDigitalSignatureDetails.Location Property

Location of signing.

public string Location {get; set;}

See Also

PdfDigitalSignatureDetails Class | Aspose.Tasks.Saving Namespace


Reason Property

PdfDigitalSignatureDetails.Reason Property

The reason of signing.

public string Reason {get; set;}

See Also

PdfDigitalSignatureDetails Class | Aspose.Tasks.Saving Namespace


SignatureDate Property

PdfDigitalSignatureDetails.SignatureDate Property

Date of signing.

public DateTime SignatureDate {get; set;}

See Also

PdfDigitalSignatureDetails Class | Aspose.Tasks.Saving Namespace


PdfDigitalSignatureHashAlgorithm Enumeration

Specifies digital hash algorithm used by digital signature.

public enum PdfDigitalSignatureHashAlgorithm

Members

Member Name | Description | Value
Sha1 | Specifies a digital hash algorithm used by a digital signature. | 0
Sha256 | Specifies a digital hash algorithm used by a digital signature. | 1
Sha384 | Specifies a digital hash algorithm used by a digital signature. | 2
Sha512 | Specifies a digital hash algorithm used by a digital signature. | 3
Md5 | Specifies a digital hash algorithm used by a digital signature. | 4

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Saving Namespace


PdfEncryptionAlgorithm Enumeration

Specifies the encryption algorithm to use for encrypting a PDF document.

public enum PdfEncryptionAlgorithm

Members

Member Name | Description | Value
RC4_40 | Specifies the encryption algorithm to use for encrypting a PDF document. | 0
RC4_128 | Specifies the encryption algorithm to use for encrypting a PDF document. | 1

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Saving Namespace


PdfEncryptionDetails Class

Contains details for a pdf encryption.

For a list of all members of this type, see PdfEncryptionDetails Members.

System.Object
Aspose.Tasks.Saving.PdfEncryptionDetails

public class PdfEncryptionDetails

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

PdfEncryptionDetails Members | Aspose.Tasks.Saving Namespace


PdfEncryptionDetails Members

PdfEncryptionDetails overview

Public Instance Constructors

PdfEncryptionDetails Constructor Ctor.

Public Instance Properties

EncryptionAlgorithm | Gets or sets the encryption mode.
OwnerPassword | Gets or sets the Owner password.
Permissions | Gets or sets the permissions.
UserPassword | Gets or sets the User password.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PdfEncryptionDetails Class | Aspose.Tasks.Saving Namespace


PdfEncryptionDetails Constructor

Ctor.

public PdfEncryptionDetails(
string userPassword,
string ownerPassword,
PdfEncryptionAlgorithm encryptionAlgorithm
);

See Also

PdfEncryptionDetails Class | Aspose.Tasks.Saving Namespace


PdfEncryptionDetails Properties

The properties of the PdfEncryptionDetails class are listed below. For a complete list of PdfEncryptionDetails class members, see the PdfEncryptionDetails Members topic.

Public Instance Properties

EncryptionAlgorithm | Gets or sets the encryption mode.
OwnerPassword | Gets or sets the Owner password.
Permissions | Gets or sets the permissions.
UserPassword | Gets or sets the User password.

See Also

PdfEncryptionDetails Class | Aspose.Tasks.Saving Namespace


EncryptionAlgorithm Property

PdfEncryptionDetails.EncryptionAlgorithm Property

Gets or sets the encryption mode.

public PdfEncryptionAlgorithm EncryptionAlgorithm {get; set;}

See Also

PdfEncryptionDetails Class | Aspose.Tasks.Saving Namespace


OwnerPassword Property

PdfEncryptionDetails.OwnerPassword Property

Gets or sets the Owner password.

public string OwnerPassword {get; set;}

Remarks

Opening the document with the correct owner password (assuming it is not the same as the user password) allows full (owner) access to the document. This unlimited access includes the ability to change the document’s passwords and access permissions.

See Also

PdfEncryptionDetails Class | Aspose.Tasks.Saving Namespace


Permissions Property

PdfEncryptionDetails.Permissions Property

Gets or sets the permissions.

public PdfPermissions Permissions {get; set;}

See Also

PdfEncryptionDetails Class | Aspose.Tasks.Saving Namespace


UserPassword Property

PdfEncryptionDetails.UserPassword Property

Gets or sets the User password.

public string UserPassword {get; set;}

Remarks

Opening the document with the correct user password (or opening a document that does not have a user password) allows additional operations to be performed according to the user access permissions specified in the document’s encryption dictionary.

See Also

PdfEncryptionDetails Class | Aspose.Tasks.Saving Namespace


PdfPermissions Enumeration

Specifies permissions to use for accessing a PDF document.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum PdfPermissions

Members

Member Name | Description | Value
DisallowAll | Specifies permissions to use for accessing a PDF document. | 0
Printing | Specifies permissions to use for accessing a PDF document. | 4
ModifyContents | Specifies permissions to use for accessing a PDF document. | 8
ContentCopy | Specifies permissions to use for accessing a PDF document. | 16
ModifyAnnotations | Specifies permissions to use for accessing a PDF document. | 32
FillIn | Specifies permissions to use for accessing a PDF document. | 256
ContentCopyForAccessibility | Specifies permissions to use for accessing a PDF document. | 512
DocumentAssembly | Specifies permissions to use for accessing a PDF document. | 1024
HighResolutionPrinting | Specifies permissions to use for accessing a PDF document. | 2052
AllowAll | Specifies permissions to use for accessing a PDF document. | 65535

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Saving Namespace


PdfSaveOptions Class

Allows to specify additional options when rendering project pages to PDF.

For a list of all members of this type, see PdfSaveOptions Members.

System.Object
Aspose.Tasks.Saving.SaveOptions
Aspose.Tasks.Saving.PdfSaveOptions

public class PdfSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

PdfSaveOptions Members | Aspose.Tasks.Saving Namespace


PdfSaveOptions Members

PdfSaveOptions overview

Public Instance Constructors

PdfSaveOptions Constructor Initializes a new instance of class that can be used to save a document in the Pdf format.

Public Instance Properties

BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
Compliance | Desired conformance level for generated PDF document. Default is Pdf15.
DigitalSignatureDetails | Gets or sets a digital signature details. If not set, then no signing will be performed.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EncryptionDetails | Gets or sets a encryption details. If not set, then no encryption will be performed.
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextCompression | Specifies compression type to be used for all content streams except images. Default is Flate.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

end (inherited from SaveOptions)
pageCount (inherited from SaveOptions)
presentationFormat (inherited from SaveOptions)
saveFormat (inherited from SaveOptions)
start (inherited from SaveOptions)
timescale (inherited from SaveOptions)
view (inherited from SaveOptions)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PdfSaveOptions Class | Aspose.Tasks.Saving Namespace


PdfSaveOptions Constructor

Initializes a new instance of class that can be used to save a document in the Pdf format.

public PdfSaveOptions();

See Also

PdfSaveOptions Class | Aspose.Tasks.Saving Namespace


PdfSaveOptions Properties

The properties of the PdfSaveOptions class are listed below. For a complete list of PdfSaveOptions class members, see the PdfSaveOptions Members topic.

Public Instance Properties

BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
Compliance | Desired conformance level for generated PDF document. Default is Pdf15.
DigitalSignatureDetails | Gets or sets a digital signature details. If not set, then no signing will be performed.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EncryptionDetails | Gets or sets a encryption details. If not set, then no encryption will be performed.
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextCompression | Specifies compression type to be used for all content streams except images. Default is Flate.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

See Also

PdfSaveOptions Class | Aspose.Tasks.Saving Namespace


Compliance Property

PdfSaveOptions.Compliance Property

Desired conformance level for generated PDF document. Default is Pdf15.

public PdfCompliance Compliance {get; set;}

See Also

PdfSaveOptions Class | Aspose.Tasks.Saving Namespace


DigitalSignatureDetails Property

PdfSaveOptions.DigitalSignatureDetails Property

Gets or sets a digital signature details. If not set, then no signing will be performed.

public PdfDigitalSignatureDetails DigitalSignatureDetails {get; set;}

See Also

PdfSaveOptions Class | Aspose.Tasks.Saving Namespace


EncryptionDetails Property

PdfSaveOptions.EncryptionDetails Property

Gets or sets a encryption details. If not set, then no encryption will be performed.

public PdfEncryptionDetails EncryptionDetails {get; set;}

See Also

PdfSaveOptions Class | Aspose.Tasks.Saving Namespace


TextCompression Property

PdfSaveOptions.TextCompression Property

Specifies compression type to be used for all content streams except images. Default is Flate.

public PdfTextCompression TextCompression {get; set;}

See Also

PdfSaveOptions Class | Aspose.Tasks.Saving Namespace


PdfTextCompression Enumeration

Specifies a type of compression applied to all content in the PDF file except images.

public enum PdfTextCompression

Members

Member Name | Description | Value
None | No compression. | 0
Flate | Flate compression. | 1

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Saving Namespace


PrimaveraSaveOptions Class

Allows to specify additional options when saving project to Primavera XER format.

For a list of all members of this type, see PrimaveraSaveOptions Members.

System.Object
Aspose.Tasks.Saving.SaveOptions
Aspose.Tasks.Saving.PrimaveraSaveOptions

public class PrimaveraSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

PrimaveraSaveOptions Members | Aspose.Tasks.Saving Namespace


PrimaveraSaveOptions Members

PrimaveraSaveOptions overview

Public Instance Constructors

PrimaveraSaveOptions Constructor Initializes a new instance of class that can be used to save project in Primavera XER format.

Public Instance Properties

ActivityIdIncrement | The increment used in renumbering of activity IDs.
ActivityIdPrefix | The prefix used in renumbering of activity IDs.
ActivityIdSuffix | The suffix used in renumbering of activity IDs.
BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RenumberActivityIds | Renumbers activity IDs if set to true.
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

end (inherited from SaveOptions)
pageCount (inherited from SaveOptions)
presentationFormat (inherited from SaveOptions)
saveFormat (inherited from SaveOptions)
start (inherited from SaveOptions)
timescale (inherited from SaveOptions)
view (inherited from SaveOptions)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrimaveraSaveOptions Class | Aspose.Tasks.Saving Namespace


PrimaveraSaveOptions Constructor

Initializes a new instance of class that can be used to save project in Primavera XER format.

public PrimaveraSaveOptions();

See Also

PrimaveraSaveOptions Class | Aspose.Tasks.Saving Namespace


PrimaveraSaveOptions Properties

The properties of the PrimaveraSaveOptions class are listed below. For a complete list of PrimaveraSaveOptions class members, see the PrimaveraSaveOptions Members topic.

Public Instance Properties

ActivityIdIncrement | The increment used in renumbering of activity IDs.
ActivityIdPrefix | The prefix used in renumbering of activity IDs.
ActivityIdSuffix | The suffix used in renumbering of activity IDs.
BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RenumberActivityIds | Renumbers activity IDs if set to true.
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

See Also

PrimaveraSaveOptions Class | Aspose.Tasks.Saving Namespace


ActivityIdIncrement Property

PrimaveraSaveOptions.ActivityIdIncrement Property

The increment used in renumbering of activity IDs.

public int ActivityIdIncrement {get; set;}

See Also

PrimaveraSaveOptions Class | Aspose.Tasks.Saving Namespace


ActivityIdPrefix Property

PrimaveraSaveOptions.ActivityIdPrefix Property

The prefix used in renumbering of activity IDs.

public string ActivityIdPrefix {get; set;}

See Also

PrimaveraSaveOptions Class | Aspose.Tasks.Saving Namespace


ActivityIdSuffix Property

PrimaveraSaveOptions.ActivityIdSuffix Property

The suffix used in renumbering of activity IDs.

public int ActivityIdSuffix {get; set;}

See Also

PrimaveraSaveOptions Class | Aspose.Tasks.Saving Namespace


RenumberActivityIds Property

PrimaveraSaveOptions.RenumberActivityIds Property

Renumbers activity IDs if set to true.

public bool RenumberActivityIds {get; set;}

See Also

PrimaveraSaveOptions Class | Aspose.Tasks.Saving Namespace


PrintOptions Class

Allows to specify additional options when printing project.

For a list of all members of this type, see PrintOptions Members.

System.Object
Aspose.Tasks.Saving.SaveOptions
Aspose.Tasks.Saving.PrintOptions

public class PrintOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

PrintOptions Members | Aspose.Tasks.Saving Namespace


PrintOptions Members

PrintOptions overview

Public Instance Constructors

PrintOptions Constructor Initializes a new instance of class that can be used to set different options to print project.

Public Instance Properties

BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

end (inherited from SaveOptions)
pageCount (inherited from SaveOptions)
presentationFormat (inherited from SaveOptions)
saveFormat (inherited from SaveOptions)
start (inherited from SaveOptions)
timescale (inherited from SaveOptions)
view (inherited from SaveOptions)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrintOptions Class | Aspose.Tasks.Saving Namespace


PrintOptions Constructor

Initializes a new instance of class that can be used to set different options to print project.

public PrintOptions();

See Also

PrintOptions Class | Aspose.Tasks.Saving Namespace


SaveFileFormat Enumeration

Enumeration for saving project format selection.

public enum SaveFileFormat

Members

Member Name | Description | Value
MPP | mpp format. | 0
XML | xml format. | 1
HTML | html format. | 2
BMP | bmp format. | 3
PNG | pdg format. | 4
JPEG | jpeg format. | 5
PDF | pdf format. | 6
TIFF | tiff format. | 7
XPS | xps format. | 8
XAML | xaml format. | 9
SVG | svg format. | 10
CSV | csv format. | 11
TXT | text format (tab delimited). | 12
Spreadsheet2003 | Spreadsheet XML (excel 2003). | 13
XLSX | OOXML (excel 2007). | 14
PrimaveraP6XML | Primavera P6 xml format. | 15
PrimaveraXER | Primavera PM xer format. | 16

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Saving Namespace


SaveOptions Class

This is an abstract base class for classes that allow the user to specify additional options when saving a project into a particular format.

For a list of all members of this type, see SaveOptions Members.

System.Object
Aspose.Tasks.Saving.SaveOptions
Derived types

public abstract class SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

An instance of any derived class from SaveOptions class is passed to the stream Save or string Save overloads for the user to define custom options when saving a document.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

SaveOptions Members | Aspose.Tasks.Saving Namespace


SaveOptions Members

SaveOptions overview

Public Instance Properties

BarStyles | List of BarStyle that appear in project view.
DrawNonWorkingTime | Draws non-working time (Default value is TRUE).
EndDate | Date to finish rendering to.
FitContent | Increases row height to fit content if set to true.
Gridlines | List of Gridline that appear in project view.
LegendOnEachPage | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor | Non-working time color.
PageCount | Gets the number of pages of project.
PageSize | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat | Specifies the PresentationFormat in which the document will be saved.
RollUpGanttBars | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask | Renders project summary task if set to true.
StartDate | Date to start rendering from.
TasksComparer | Comparer to sort tasks on Gantt Chart.
TextStyles | List of TextStyle that appear in project view.
Timescale | The minimal time period to render. The default value is Days.
View | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

SaveOptions Constructor Initializes a new instance of the SaveOptions class.

Protected Instance Fields

end
pageCount
presentationFormat
saveFormat
start
timescale
view

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


SaveOptions Constructor

Initializes a new instance of the SaveOptions class.

protected SaveOptions();

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


SaveOptions Fields

The fields of the SaveOptions class are listed below. For a complete list of SaveOptions class members, see the SaveOptions Members topic.

Protected Instance Fields

end
pageCount
presentationFormat
saveFormat
start
timescale
view

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


SaveOptions.end Field

protected DateTime end;

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


PageCount Property

SaveOptions.PageCount Property

Gets the number of pages of project.

public int PageCount {get;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


PresentationFormat Property

SaveOptions.PresentationFormat Property

Specifies the PresentationFormat in which the document will be saved.

public PresentationFormat PresentationFormat {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


SaveFormat Property

SaveOptions.SaveFormat Property

Specifies the format in which the document will be saved if this save options object is used.

public SaveFileFormat SaveFormat {get;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


SaveOptions.start Field

protected DateTime start;

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


Timescale Property

SaveOptions.Timescale Property

The minimal time period to render. The default value is Days.

public Timescale Timescale {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


View Property

SaveOptions.View Property

Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

public ProjectView View {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


SaveOptions Properties

The properties of the SaveOptions class are listed below. For a complete list of SaveOptions class members, see the SaveOptions Members topic.

Public Instance Properties

BarStyles | List of BarStyle that appear in project view.
DrawNonWorkingTime | Draws non-working time (Default value is TRUE).
EndDate | Date to finish rendering to.
FitContent | Increases row height to fit content if set to true.
Gridlines | List of Gridline that appear in project view.
LegendOnEachPage | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor | Non-working time color.
PageCount | Gets the number of pages of project.
PageSize | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat | Specifies the PresentationFormat in which the document will be saved.
RollUpGanttBars | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask | Renders project summary task if set to true.
StartDate | Date to start rendering from.
TasksComparer | Comparer to sort tasks on Gantt Chart.
TextStyles | List of TextStyle that appear in project view.
Timescale | The minimal time period to render. The default value is Days.
View | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


BarStyles Property

SaveOptions.BarStyles Property

List of BarStyle that appear in project view.

public BarStyle} BarStyles {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


DrawNonWorkingTime Property

SaveOptions.DrawNonWorkingTime Property

Draws non-working time (Default value is TRUE).

public bool DrawNonWorkingTime {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


EndDate Property

SaveOptions.EndDate Property

Date to finish rendering to.

public DateTime EndDate {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


FitContent Property

SaveOptions.FitContent Property

Increases row height to fit content if set to true.

public bool FitContent {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


Gridlines Property

SaveOptions.Gridlines Property

List of Gridline that appear in project view.

public Gridline} Gridlines {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


LegendOnEachPage Property

SaveOptions.LegendOnEachPage Property

Shows legend on each page (Default value is TRUE).

public bool LegendOnEachPage {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


MarkCriticalTasks Property

SaveOptions.MarkCriticalTasks Property

Display critical tasks in red color (Default value is FALSE).

public bool MarkCriticalTasks {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


NonWorkingTimeColor Property

SaveOptions.NonWorkingTimeColor Property

Non-working time color.

public Color NonWorkingTimeColor {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


PageSize Property

SaveOptions.PageSize Property

Specifies size of page to be rendered (Default value is PageSize.A4).

public PageSize PageSize {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


RollUpGanttBars Property

SaveOptions.RollUpGanttBars Property

Marks subtasks on the summary task bar (Default value is FALSE).

public bool RollUpGanttBars {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


ShowProjectSummaryTask Property

SaveOptions.ShowProjectSummaryTask Property

Renders project summary task if set to true.

public bool ShowProjectSummaryTask {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


StartDate Property

SaveOptions.StartDate Property

Date to start rendering from.

public DateTime StartDate {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


TasksComparer Property

SaveOptions.TasksComparer Property

Comparer to sort tasks on Gantt Chart.

public Task} TasksComparer {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


TextStyles Property

SaveOptions.TextStyles Property

List of TextStyle that appear in project view.

public TextStyle} TextStyles {get; set;}

See Also

SaveOptions Class | Aspose.Tasks.Saving Namespace


SaveTemplateOptions Class

Allows to specify additional options when saving a project as a template.

For a list of all members of this type, see SaveTemplateOptions Members.

System.Object
Aspose.Tasks.Saving.SaveTemplateOptions

public class SaveTemplateOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

SaveTemplateOptions Members | Aspose.Tasks.Saving Namespace


SaveTemplateOptions Members

SaveTemplateOptions overview

Public Instance Constructors

SaveTemplateOptions Constructor Initializes a new instance of the SaveTemplateOptions class.

Public Instance Properties

RemoveActualValues | Removes all actual values from a project template.
RemoveBaselineValues | Removes all baseline values from a project template.
RemoveFixedCosts | Removes all fixed costs from a project template.
RemoveResourceRates | Removes resource rates from a project template.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SaveTemplateOptions Class | Aspose.Tasks.Saving Namespace


SaveTemplateOptions Constructor

Initializes a new instance of the SaveTemplateOptions class.

public SaveTemplateOptions();

See Also

SaveTemplateOptions Class | Aspose.Tasks.Saving Namespace


SaveTemplateOptions Properties

The properties of the SaveTemplateOptions class are listed below. For a complete list of SaveTemplateOptions class members, see the SaveTemplateOptions Members topic.

Public Instance Properties

RemoveActualValues | Removes all actual values from a project template.
RemoveBaselineValues | Removes all baseline values from a project template.
RemoveFixedCosts | Removes all fixed costs from a project template.
RemoveResourceRates | Removes resource rates from a project template.

See Also

SaveTemplateOptions Class | Aspose.Tasks.Saving Namespace


RemoveActualValues Property

SaveTemplateOptions.RemoveActualValues Property

Removes all actual values from a project template.

public bool RemoveActualValues {get; set;}

See Also

SaveTemplateOptions Class | Aspose.Tasks.Saving Namespace


RemoveBaselineValues Property

SaveTemplateOptions.RemoveBaselineValues Property

Removes all baseline values from a project template.

public bool RemoveBaselineValues {get; set;}

See Also

SaveTemplateOptions Class | Aspose.Tasks.Saving Namespace


RemoveFixedCosts Property

SaveTemplateOptions.RemoveFixedCosts Property

Removes all fixed costs from a project template.

public bool RemoveFixedCosts {get; set;}

See Also

SaveTemplateOptions Class | Aspose.Tasks.Saving Namespace


RemoveResourceRates Property

SaveTemplateOptions.RemoveResourceRates Property

Removes resource rates from a project template.

public bool RemoveResourceRates {get; set;}

See Also

SaveTemplateOptions Class | Aspose.Tasks.Saving Namespace


Spreadsheet2003SaveOptions Class

Allows to specify additional options when rendering project pages to Spreadsheet2003.

For a list of all members of this type, see Spreadsheet2003SaveOptions Members.

System.Object
Aspose.Tasks.Saving.SaveOptions
Aspose.Tasks.Saving.Spreadsheet2003SaveOptions

public class Spreadsheet2003SaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Spreadsheet2003SaveOptions Members | Aspose.Tasks.Saving Namespace


Spreadsheet2003SaveOptions Members

Spreadsheet2003SaveOptions overview

Public Instance Constructors

Spreadsheet2003SaveOptions Constructor Initializes a new instance of class that can be used to save project in Spreadsheet2003 format.

Public Instance Properties

AssignmentView | Stores a list of the assignments view columns to render (AssignmentViewColumn).
BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
ResourceView | Stores a list of the resource view columns to render (ResourceViewColumn).
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

end (inherited from SaveOptions)
pageCount (inherited from SaveOptions)
presentationFormat (inherited from SaveOptions)
saveFormat (inherited from SaveOptions)
start (inherited from SaveOptions)
timescale (inherited from SaveOptions)
view (inherited from SaveOptions)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Spreadsheet2003SaveOptions Class | Aspose.Tasks.Saving Namespace


Spreadsheet2003SaveOptions Constructor

Initializes a new instance of class that can be used to save project in Spreadsheet2003 format.

public Spreadsheet2003SaveOptions();

See Also

Spreadsheet2003SaveOptions Class | Aspose.Tasks.Saving Namespace


Spreadsheet2003SaveOptions Properties

The properties of the Spreadsheet2003SaveOptions class are listed below. For a complete list of Spreadsheet2003SaveOptions class members, see the Spreadsheet2003SaveOptions Members topic.

Public Instance Properties

AssignmentView | Stores a list of the assignments view columns to render (AssignmentViewColumn).
BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
ResourceView | Stores a list of the resource view columns to render (ResourceViewColumn).
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

See Also

Spreadsheet2003SaveOptions Class | Aspose.Tasks.Saving Namespace


AssignmentView Property

Spreadsheet2003SaveOptions.AssignmentView Property

Stores a list of the assignments view columns to render (AssignmentViewColumn).

public ProjectView AssignmentView {get; set;}

See Also

Spreadsheet2003SaveOptions Class | Aspose.Tasks.Saving Namespace


ResourceView Property

Spreadsheet2003SaveOptions.ResourceView Property

Stores a list of the resource view columns to render (ResourceViewColumn).

public ProjectView ResourceView {get; set;}

See Also

Spreadsheet2003SaveOptions Class | Aspose.Tasks.Saving Namespace


SvgOptions Class

Allows to specify additional options when rendering project pages to SVG.

For a list of all members of this type, see SvgOptions Members.

System.Object
Aspose.Tasks.Saving.SaveOptions
Aspose.Tasks.Saving.SvgOptions

public class SvgOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

SvgOptions Members | Aspose.Tasks.Saving Namespace


SvgOptions Members

SvgOptions overview

Public Instance Constructors

SvgOptions Constructor Initializes a new instance of class that can be used to save project in xaml format.

Public Instance Properties

BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

end (inherited from SaveOptions)
pageCount (inherited from SaveOptions)
presentationFormat (inherited from SaveOptions)
saveFormat (inherited from SaveOptions)
start (inherited from SaveOptions)
timescale (inherited from SaveOptions)
view (inherited from SaveOptions)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SvgOptions Class | Aspose.Tasks.Saving Namespace


SvgOptions Constructor

Initializes a new instance of class that can be used to save project in xaml format.

public SvgOptions();

See Also

SvgOptions Class | Aspose.Tasks.Saving Namespace


TiffCompression Enumeration

Specifies what type of compression to apply when saving pages to the TIFF format.

public enum TiffCompression

Members

Member Name | Description | Value
None | Specifies no compression. | 1
Rle | Specifies the RLE compression scheme. | 2
Ccitt3 | Specifies the CCITT3 compression scheme. | 3
Ccitt4 | Specifies the CCITT4 compression scheme. | 4
Lzw | Specifies the LZW compression scheme. | 5

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Saving Namespace


XamlOptions Class

/// Allows to specify additional options when rendering project pages to XAML.

For a list of all members of this type, see XamlOptions Members.

System.Object
Aspose.Tasks.Saving.SaveOptions
Aspose.Tasks.Saving.XamlOptions

public class XamlOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

XamlOptions Members | Aspose.Tasks.Saving Namespace


XamlOptions Members

XamlOptions overview

Public Instance Constructors

XamlOptions Constructor Initializes a new instance of class that can be used to save project in xaml format.

Public Instance Properties

BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

end (inherited from SaveOptions)
pageCount (inherited from SaveOptions)
presentationFormat (inherited from SaveOptions)
saveFormat (inherited from SaveOptions)
start (inherited from SaveOptions)
timescale (inherited from SaveOptions)
view (inherited from SaveOptions)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XamlOptions Class | Aspose.Tasks.Saving Namespace


XamlOptions Constructor

Initializes a new instance of class that can be used to save project in xaml format.

public XamlOptions();

See Also

XamlOptions Class | Aspose.Tasks.Saving Namespace


XlsxOptions Class

Allows to specify additional options when rendering project pages to XLSX.

For a list of all members of this type, see XlsxOptions Members.

System.Object
Aspose.Tasks.Saving.SaveOptions
Aspose.Tasks.Saving.XlsxOptions

public class XlsxOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

XlsxOptions Members | Aspose.Tasks.Saving Namespace


XlsxOptions Members

XlsxOptions overview

Public Instance Constructors

XlsxOptions Constructor Initializes a new instance of class that can be used to save project in xlsx format.

Public Instance Properties

AssignmentView | Stores a list of the assignments view columns to render (AssignmentViewColumn).
BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
ResourceView | Stores a list of the resource view columns to render (ResourceViewColumn).
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

end (inherited from SaveOptions)
pageCount (inherited from SaveOptions)
presentationFormat (inherited from SaveOptions)
saveFormat (inherited from SaveOptions)
start (inherited from SaveOptions)
timescale (inherited from SaveOptions)
view (inherited from SaveOptions)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XlsxOptions Class | Aspose.Tasks.Saving Namespace


XlsxOptions Constructor

Initializes a new instance of class that can be used to save project in xlsx format.

public XlsxOptions();

See Also

XlsxOptions Class | Aspose.Tasks.Saving Namespace


XlsxOptions Properties

The properties of the XlsxOptions class are listed below. For a complete list of XlsxOptions class members, see the XlsxOptions Members topic.

Public Instance Properties

AssignmentView | Stores a list of the assignments view columns to render (AssignmentViewColumn).
BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
ResourceView | Stores a list of the resource view columns to render (ResourceViewColumn).
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

See Also

XlsxOptions Class | Aspose.Tasks.Saving Namespace


AssignmentView Property

XlsxOptions.AssignmentView Property

Stores a list of the assignments view columns to render (AssignmentViewColumn).

public ProjectView AssignmentView {get; set;}

See Also

XlsxOptions Class | Aspose.Tasks.Saving Namespace


ResourceView Property

XlsxOptions.ResourceView Property

Stores a list of the resource view columns to render (ResourceViewColumn).

public ProjectView ResourceView {get; set;}

See Also

XlsxOptions Class | Aspose.Tasks.Saving Namespace


XpsOptions Class

Allows to specify additional options when rendering project pages to XPS.

For a list of all members of this type, see XpsOptions Members.

System.Object
Aspose.Tasks.Saving.SaveOptions
Aspose.Tasks.Saving.XpsOptions

public class XpsOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Saving

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

XpsOptions Members | Aspose.Tasks.Saving Namespace


XpsOptions Members

XpsOptions overview

Public Instance Constructors

XpsOptions Constructor Initializes a new instance of class that can be used to save project in xps format.

Public Instance Properties

BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RenderMetafileAsBitmap | Renders metafile as bitmap.
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

end (inherited from SaveOptions)
pageCount (inherited from SaveOptions)
presentationFormat (inherited from SaveOptions)
saveFormat (inherited from SaveOptions)
start (inherited from SaveOptions)
timescale (inherited from SaveOptions)
view (inherited from SaveOptions)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XpsOptions Class | Aspose.Tasks.Saving Namespace


XpsOptions Constructor

Initializes a new instance of class that can be used to save project in xps format.

public XpsOptions();

See Also

XpsOptions Class | Aspose.Tasks.Saving Namespace


XpsOptions Properties

The properties of the XpsOptions class are listed below. For a complete list of XpsOptions class members, see the XpsOptions Members topic.

Public Instance Properties

BarStyles (inherited from SaveOptions) | List of BarStyle that appear in project view.
DrawNonWorkingTime (inherited from SaveOptions) | Draws non-working time (Default value is TRUE).
EndDate (inherited from SaveOptions) | Date to finish rendering to.
FitContent (inherited from SaveOptions) | Increases row height to fit content if set to true.
Gridlines (inherited from SaveOptions) | List of Gridline that appear in project view.
LegendOnEachPage (inherited from SaveOptions) | Shows legend on each page (Default value is TRUE).
MarkCriticalTasks (inherited from SaveOptions) | Display critical tasks in red color (Default value is FALSE).
NonWorkingTimeColor (inherited from SaveOptions) | Non-working time color.
PageCount (inherited from SaveOptions) | Gets the number of pages of project.
PageSize (inherited from SaveOptions) | Specifies size of page to be rendered (Default value is PageSize.A4).
PresentationFormat (inherited from SaveOptions) | Specifies the PresentationFormat in which the document will be saved.
RenderMetafileAsBitmap | Renders metafile as bitmap.
RollUpGanttBars (inherited from SaveOptions) | Marks subtasks on the summary task bar (Default value is FALSE).
SaveFormat (inherited from SaveOptions) | Specifies the format in which the document will be saved if this save options object is used.
ShowProjectSummaryTask (inherited from SaveOptions) | Renders project summary task if set to true.
StartDate (inherited from SaveOptions) | Date to start rendering from.
TasksComparer (inherited from SaveOptions) | Comparer to sort tasks on Gantt Chart.
TextStyles (inherited from SaveOptions) | List of TextStyle that appear in project view.
Timescale (inherited from SaveOptions) | The minimal time period to render. The default value is Days.
View (inherited from SaveOptions) | Stores a list of the view columns to render (GanttChartColumn). If not set then task ids, task names, start and finish are rendered only.

See Also

XpsOptions Class | Aspose.Tasks.Saving Namespace


RenderMetafileAsBitmap Property

XpsOptions.RenderMetafileAsBitmap Property

Renders metafile as bitmap.

public bool RenderMetafileAsBitmap {get; set;}

See Also

XpsOptions Class | Aspose.Tasks.Saving Namespace


Aspose.Tasks.Util

Aspose.Tasks.Util Namespace

Namespace hierarchy

Classes

Class | Description
And | Applies logical AND to the specified conditions.
AndAllCondition | Applies logical AND to all conditions. For example: cond1 AND cond2 AND cond3...
ArrayUtils | Utility class for ArrayList processing.
CheckCircuit | Checks a tree (of tasks) whether it contains a circuit.
ChildTasksCollector | Collects all child tasks.
FilterCriticalTasks | Filters critical tasks.
FilterResourceAssignByResource | Filter resource assignments by resource.
FilterResourceAssignByTask | Filter resource assignments by task.
Not | Applies logical NOT to the specified condition.
RemoveTask | Removes the specified task from a tree of tasks.
TaskUtils | Helper class which provides useful operations with tasks.

Interfaces

Interface | Description
IAlgorithm | Represents an algorithm that can be applyed to a list of objects.
ICondition | Represents a condition which can be used by filters or search methods.
ITreeAlgorithm | Represents an algorithm that can be applyed to a tree of objects.


And Class

Applies logical AND to the specified conditions.

For a list of all members of this type, see And Members.

System.Object
Aspose.Tasks.Util.And

public class And : ICondition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

And Members | Aspose.Tasks.Util Namespace


And Members

And overview

Public Instance Constructors

And Constructor Creates new And condition.

Public Instance Methods

Check | Returns true if the specified object satisfy the conditions.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

And Class | Aspose.Tasks.Util Namespace


And Constructor

Creates new And condition.

public And(
ICondition cond1,
ICondition cond2
);

Parameters

cond1
First condition.
cond2
Second condition.

See Also

And Class | Aspose.Tasks.Util Namespace


And Methods

The methods of the And class are listed below. For a complete list of And class members, see the And Members topic.

Public Instance Methods

Check | Returns true if the specified object satisfy the conditions.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

And Class | Aspose.Tasks.Util Namespace


And.Check Method

Returns true if the specified object satisfy the conditions.

public bool Check(
object el
);

Parameters

el
The object to check.

Return Value

True if the object satisfy the conditions.

Implements

ICondition.Check

See Also

And Class | Aspose.Tasks.Util Namespace


AndAllCondition Class

Applies logical AND to all conditions. For example: cond1 AND cond2 AND cond3...

For a list of all members of this type, see AndAllCondition Members.

System.Object
Aspose.Tasks.Util.AndAllCondition

public class AndAllCondition : ICondition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

AndAllCondition Members | Aspose.Tasks.Util Namespace


AndAllCondition Members

AndAllCondition overview

Public Instance Constructors

AndAllCondition Constructor Creates new And condition.

Public Instance Methods

Check | Returns true if the specified object satisfy the conditions.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AndAllCondition Class | Aspose.Tasks.Util Namespace


AndAllCondition Constructor

Creates new And condition.

public AndAllCondition(
ArrayList conditions
);

Parameters

conditions
ArrayList with conditions.

See Also

AndAllCondition Class | Aspose.Tasks.Util Namespace


AndAllCondition Methods

The methods of the AndAllCondition class are listed below. For a complete list of AndAllCondition class members, see the AndAllCondition Members topic.

Public Instance Methods

Check | Returns true if the specified object satisfy the conditions.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AndAllCondition Class | Aspose.Tasks.Util Namespace


AndAllCondition.Check Method

Returns true if the specified object satisfy the conditions.

public bool Check(
object el
);

Parameters

el
The object to check.

Return Value

True if the object satisfy the conditions.

Implements

ICondition.Check

See Also

AndAllCondition Class | Aspose.Tasks.Util Namespace


ArrayUtils Class

Utility class for ArrayList processing.

For a list of all members of this type, see ArrayUtils Members.

System.Object
Aspose.Tasks.Util.ArrayUtils

public class ArrayUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ArrayUtils Members | Aspose.Tasks.Util Namespace


ArrayUtils Members

ArrayUtils overview

Public Static Methods

Apply | Apply algorithm for each ArrayList element starting from specified position.
Filter | Filter ArrayList elements by specified condition.
Find | Find first occurence of an ArrayList element which satisfy specified condition.

Public Instance Constructors

ArrayUtils Constructor Initializes a new instance of the ArrayUtils class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayUtils Class | Aspose.Tasks.Util Namespace


ArrayUtils Constructor

Initializes a new instance of the ArrayUtils class.

public ArrayUtils();

See Also

ArrayUtils Class | Aspose.Tasks.Util Namespace


ArrayUtils Methods

The methods of the ArrayUtils class are listed below. For a complete list of ArrayUtils class members, see the ArrayUtils Members topic.

Public Static Methods

Apply | Apply algorithm for each ArrayList element starting from specified position.
Filter | Filter ArrayList elements by specified condition.
Find | Find first occurence of an ArrayList element which satisfy specified condition.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayUtils Class | Aspose.Tasks.Util Namespace


ArrayUtils.Apply Method

Apply algorithm for each ArrayList element starting from specified position.

public static void Apply(
ArrayList array,
IAlgorithm algorithm,
int startIndex
);

Parameters

array
ArrayList to process.
algorithm
Applied algorithm.
startIndex
Start element position.

See Also

ArrayUtils Class | Aspose.Tasks.Util Namespace


ArrayUtils.Filter Method

Filter ArrayList elements by specified condition.

public static ArrayList Filter(
ArrayList array,
ICondition cond
);

Parameters

array
ArrayList to process.
cond
Condition used to filter ArrayList.

Return Value

Filtered ArrayList.

See Also

ArrayUtils Class | Aspose.Tasks.Util Namespace


ArrayUtils.Find Method

Find first occurence of an ArrayList element which satisfy specified condition.

public static object Find(
ArrayList array,
ICondition cond
);

Parameters

array
ArrayList to process.
cond
Condition used to find ArrayList element.

Return Value

ArayList element or null.

See Also

ArrayUtils Class | Aspose.Tasks.Util Namespace


CheckCircuit Class

Checks a tree (of tasks) whether it contains a circuit.

For a list of all members of this type, see CheckCircuit Members.

System.Object
Aspose.Tasks.Util.CheckCircuit

public class CheckCircuit : ITreeAlgorithm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

CheckCircuit Members | Aspose.Tasks.Util Namespace


CheckCircuit Members

CheckCircuit overview

Public Instance Constructors

CheckCircuit Constructor Creates circuit checker.

Public Instance Methods

Alg | Check if the specified object was already processed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostAlg | Do nothing.
PreAlg | Do nothing.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckCircuit Class | Aspose.Tasks.Util Namespace


CheckCircuit Constructor

Creates circuit checker.

public CheckCircuit();

See Also

CheckCircuit Class | Aspose.Tasks.Util Namespace


CheckCircuit Methods

The methods of the CheckCircuit class are listed below. For a complete list of CheckCircuit class members, see the CheckCircuit Members topic.

Public Instance Methods

Alg | Check if the specified object was already processed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostAlg | Do nothing.
PreAlg | Do nothing.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckCircuit Class | Aspose.Tasks.Util Namespace


CheckCircuit.Alg Method

Check if the specified object was already processed.

public void Alg(
object el,
int level
);

Parameters

el
Object to process.
level
Tree node level.

Implements

ITreeAlgorithm.Alg

See Also

CheckCircuit Class | Aspose.Tasks.Util Namespace


CheckCircuit.PostAlg Method

Do nothing.

public void PostAlg(
object el,
int level
);

Parameters

el
level

Implements

ITreeAlgorithm.PostAlg

See Also

CheckCircuit Class | Aspose.Tasks.Util Namespace


CheckCircuit.PreAlg Method

Do nothing.

public void PreAlg(
object el,
int level
);

Parameters

el
level

Implements

ITreeAlgorithm.PreAlg

See Also

CheckCircuit Class | Aspose.Tasks.Util Namespace


ChildTasksCollector Class

Collects all child tasks.

For a list of all members of this type, see ChildTasksCollector Members.

System.Object
Aspose.Tasks.Util.ChildTasksCollector

public class ChildTasksCollector : ITreeAlgorithm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ChildTasksCollector Members | Aspose.Tasks.Util Namespace


ChildTasksCollector Members

ChildTasksCollector overview

Public Instance Constructors

ChildTasksCollector Constructor Creates child tasks collector.

Public Instance Properties

Tasks Returns ArrayList collected child objects (tasks).

Public Instance Methods

Alg | Processes the specified object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostAlg | Do nothing.
PreAlg | Do nothing.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChildTasksCollector Class | Aspose.Tasks.Util Namespace


ChildTasksCollector Constructor

Creates child tasks collector.

public ChildTasksCollector();

See Also

ChildTasksCollector Class | Aspose.Tasks.Util Namespace


ChildTasksCollector Properties

The properties of the ChildTasksCollector class are listed below. For a complete list of ChildTasksCollector class members, see the ChildTasksCollector Members topic.

Public Instance Properties

Tasks Returns ArrayList collected child objects (tasks).

See Also

ChildTasksCollector Class | Aspose.Tasks.Util Namespace


Tasks Property

ChildTasksCollector.Tasks Property

Returns ArrayList collected child objects (tasks).

public Task} Tasks {get;}

See Also

ChildTasksCollector Class | Aspose.Tasks.Util Namespace


ChildTasksCollector Methods

The methods of the ChildTasksCollector class are listed below. For a complete list of ChildTasksCollector class members, see the ChildTasksCollector Members topic.

Public Instance Methods

Alg | Processes the specified object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostAlg | Do nothing.
PreAlg | Do nothing.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChildTasksCollector Class | Aspose.Tasks.Util Namespace


ChildTasksCollector.Alg Method

Processes the specified object.

public void Alg(
object el,
int level
);

Parameters

el
Object to process.
level
Tree node level.

Implements

ITreeAlgorithm.Alg

See Also

ChildTasksCollector Class | Aspose.Tasks.Util Namespace


ChildTasksCollector.PostAlg Method

Do nothing.

public void PostAlg(
object el,
int level
);

Parameters

el
level

Implements

ITreeAlgorithm.PostAlg

See Also

ChildTasksCollector Class | Aspose.Tasks.Util Namespace


ChildTasksCollector.PreAlg Method

Do nothing.

public void PreAlg(
object el,
int level
);

Parameters

el
level

Implements

ITreeAlgorithm.PreAlg

See Also

ChildTasksCollector Class | Aspose.Tasks.Util Namespace


FilterCriticalTasks Class

Filters critical tasks.

For a list of all members of this type, see FilterCriticalTasks Members.

System.Object
Aspose.Tasks.Util.FilterCriticalTasks

public class FilterCriticalTasks : ICondition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

FilterCriticalTasks Members | Aspose.Tasks.Util Namespace


FilterCriticalTasks Members

FilterCriticalTasks overview

Public Instance Constructors

FilterCriticalTasks Constructor Initializes a new instance of the FilterCriticalTasks class.

Public Instance Methods

Check | Returns true if task is critical.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterCriticalTasks Class | Aspose.Tasks.Util Namespace


FilterCriticalTasks Constructor

Initializes a new instance of the FilterCriticalTasks class.

public FilterCriticalTasks();

See Also

FilterCriticalTasks Class | Aspose.Tasks.Util Namespace


FilterCriticalTasks Methods

The methods of the FilterCriticalTasks class are listed below. For a complete list of FilterCriticalTasks class members, see the FilterCriticalTasks Members topic.

Public Instance Methods

Check | Returns true if task is critical.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterCriticalTasks Class | Aspose.Tasks.Util Namespace


FilterCriticalTasks.Check Method

Returns true if task is critical.

public bool Check(
object el
);

Parameters

el
Task to check.

Return Value

True, if the task is critical.

Implements

ICondition.Check

See Also

FilterCriticalTasks Class | Aspose.Tasks.Util Namespace


FilterResourceAssignByResource Class

Filter resource assignments by resource.

For a list of all members of this type, see FilterResourceAssignByResource Members.

System.Object
Aspose.Tasks.Util.FilterResourceAssignByResource

public class FilterResourceAssignByResource : ICondition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

FilterResourceAssignByResource Members | Aspose.Tasks.Util Namespace


FilterResourceAssignByResource Members

FilterResourceAssignByResource overview

Public Instance Constructors

FilterResourceAssignByResource Constructor Creates filter of resource assignments for the specified resource.

Public Instance Methods

Check | Returns true if a specified resource assignment belongs to a resource.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterResourceAssignByResource Class | Aspose.Tasks.Util Namespace


FilterResourceAssignByResource Constructor

Creates filter of resource assignments for the specified resource.

public FilterResourceAssignByResource(
Resource resource
);

Parameters

resource
Resource to filter.

See Also

FilterResourceAssignByResource Class | Aspose.Tasks.Util Namespace


FilterResourceAssignByResource Methods

The methods of the FilterResourceAssignByResource class are listed below. For a complete list of FilterResourceAssignByResource class members, see the FilterResourceAssignByResource Members topic.

Public Instance Methods

Check | Returns true if a specified resource assignment belongs to a resource.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterResourceAssignByResource Class | Aspose.Tasks.Util Namespace


FilterResourceAssignByResource.Check Method

Returns true if a specified resource assignment belongs to a resource.

public bool Check(
object el
);

Parameters

el
Resourse assignment to check.

Return Value

Implements

ICondition.Check

See Also

FilterResourceAssignByResource Class | Aspose.Tasks.Util Namespace


FilterResourceAssignByTask Class

Filter resource assignments by task.

For a list of all members of this type, see FilterResourceAssignByTask Members.

System.Object
Aspose.Tasks.Util.FilterResourceAssignByTask

public class FilterResourceAssignByTask : ICondition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

FilterResourceAssignByTask Members | Aspose.Tasks.Util Namespace


FilterResourceAssignByTask Members

FilterResourceAssignByTask overview

Public Instance Constructors

FilterResourceAssignByTask Constructor Creates filter of resource assignments for the specified task.

Public Instance Methods

Check | Returns true if a specified resource assignment belongs to a task.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterResourceAssignByTask Class | Aspose.Tasks.Util Namespace


FilterResourceAssignByTask Constructor

Creates filter of resource assignments for the specified task.

public FilterResourceAssignByTask(
Task task
);

Parameters

task
Task to filter.

See Also

FilterResourceAssignByTask Class | Aspose.Tasks.Util Namespace


FilterResourceAssignByTask Methods

The methods of the FilterResourceAssignByTask class are listed below. For a complete list of FilterResourceAssignByTask class members, see the FilterResourceAssignByTask Members topic.

Public Instance Methods

Check | Returns true if a specified resource assignment belongs to a task.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterResourceAssignByTask Class | Aspose.Tasks.Util Namespace


FilterResourceAssignByTask.Check Method

Returns true if a specified resource assignment belongs to a task.

public bool Check(
object el
);

Parameters

el
Resourse assignment to check.

Return Value

Implements

ICondition.Check

See Also

FilterResourceAssignByTask Class | Aspose.Tasks.Util Namespace


IAlgorithm Interface

Represents an algorithm that can be applyed to a list of objects.

For a list of all members of this type, see IAlgorithm Members.

public interface IAlgorithm

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

IAlgorithm Members | Aspose.Tasks.Util Namespace


IAlgorithm Members

IAlgorithm overview

Public Instance Methods

Alg | Processes an object in the list. Called after PreAlg();
PostAlg | Called after processing of an object.
PreAlg | Called before processing of an object.

See Also

IAlgorithm Interface | Aspose.Tasks.Util Namespace


IAlgorithm Methods

The methods of the IAlgorithm interface are listed below. For a complete list of IAlgorithm interface members, see the IAlgorithm Members topic.

Public Instance Methods

Alg | Processes an object in the list. Called after PreAlg();
PostAlg | Called after processing of an object.
PreAlg | Called before processing of an object.

See Also

IAlgorithm Interface | Aspose.Tasks.Util Namespace


IAlgorithm.Alg Method

Processes an object in the list. Called after PreAlg();

void Alg(
object el,
int index
);

Parameters

el
Processed object.
index
Index of the object.

See Also

IAlgorithm Interface | Aspose.Tasks.Util Namespace


IAlgorithm.PostAlg Method

Called after processing of an object.

void PostAlg(
object el,
int index
);

Parameters

el
Processed object.
index
Index of the object.

See Also

IAlgorithm Interface | Aspose.Tasks.Util Namespace


IAlgorithm.PreAlg Method

Called before processing of an object.

void PreAlg(
object el,
int index
);

Parameters

el
Processed object.
index
Index of the object.

See Also

IAlgorithm Interface | Aspose.Tasks.Util Namespace


ICondition Interface

Represents a condition which can be used by filters or search methods.

For a list of all members of this type, see ICondition Members.

public interface ICondition

Types that implement ICondition

Type | Description
And | Applies logical AND to the specified conditions.
AndAllCondition | Applies logical AND to all conditions. For example: cond1 AND cond2 AND cond3...
FilterCriticalTasks | Filters critical tasks.
FilterResourceAssignByResource | Filter resource assignments by resource.
FilterResourceAssignByTask | Filter resource assignments by task.
Not | Applies logical NOT to the specified condition.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ICondition Members | Aspose.Tasks.Util Namespace


ICondition Members

ICondition overview

Public Instance Methods

Check Returns true if the specified object satisfy the conditions.

See Also

ICondition Interface | Aspose.Tasks.Util Namespace


ICondition Methods

The methods of the ICondition interface are listed below. For a complete list of ICondition interface members, see the ICondition Members topic.

Public Instance Methods

Check Returns true if the specified object satisfy the conditions.

See Also

ICondition Interface | Aspose.Tasks.Util Namespace


ICondition.Check Method

Returns true if the specified object satisfy the conditions.

bool Check(
object el
);

Parameters

el
The object to check.

Return Value

True if the object satisfy the conditions.

See Also

ICondition Interface | Aspose.Tasks.Util Namespace


ITreeAlgorithm Interface

Represents an algorithm that can be applyed to a tree of objects.

For a list of all members of this type, see ITreeAlgorithm Members.

public interface ITreeAlgorithm

Types that implement ITreeAlgorithm

Type | Description
CheckCircuit | Checks a tree (of tasks) whether it contains a circuit.
ChildTasksCollector | Collects all child tasks.
RemoveTask | Removes the specified task from a tree of tasks.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ITreeAlgorithm Members | Aspose.Tasks.Util Namespace


ITreeAlgorithm Members

ITreeAlgorithm overview

Public Instance Methods

Alg | Processes a node of a tree. Called after PreAlg().
PostAlg | Called after processing of a node of a tree.
PreAlg | Called before processing of a node of a tree.

See Also

ITreeAlgorithm Interface | Aspose.Tasks.Util Namespace


ITreeAlgorithm Methods

The methods of the ITreeAlgorithm interface are listed below. For a complete list of ITreeAlgorithm interface members, see the ITreeAlgorithm Members topic.

Public Instance Methods

Alg | Processes a node of a tree. Called after PreAlg().
PostAlg | Called after processing of a node of a tree.
PreAlg | Called before processing of a node of a tree.

See Also

ITreeAlgorithm Interface | Aspose.Tasks.Util Namespace


ITreeAlgorithm.Alg Method

Processes a node of a tree. Called after PreAlg().

void Alg(
object el,
int level
);

Parameters

el
Node to process.
level
Tree node level

See Also

ITreeAlgorithm Interface | Aspose.Tasks.Util Namespace


ITreeAlgorithm.PostAlg Method

Called after processing of a node of a tree.

void PostAlg(
object el,
int level
);

Parameters

el
Node to process.
level
Tree node level.

See Also

ITreeAlgorithm Interface | Aspose.Tasks.Util Namespace


ITreeAlgorithm.PreAlg Method

Called before processing of a node of a tree.

void PreAlg(
object el,
int level
);

Parameters

el
Node to process.
level
Tree node level.

See Also

ITreeAlgorithm Interface | Aspose.Tasks.Util Namespace


Not Class

Applies logical NOT to the specified condition.

For a list of all members of this type, see Not Members.

System.Object
Aspose.Tasks.Util.Not

public class Not : ICondition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Not Members | Aspose.Tasks.Util Namespace


Not Members

Not overview

Public Instance Constructors

Not Constructor Creates Not condition.

Public Instance Methods

Check | Returns true if the specified object satisfy the condition.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Not Class | Aspose.Tasks.Util Namespace


Not Constructor

Creates Not condition.

public Not(
ICondition condition
);

Parameters

condition
Specified condition.

See Also

Not Class | Aspose.Tasks.Util Namespace


Not Methods

The methods of the Not class are listed below. For a complete list of Not class members, see the Not Members topic.

Public Instance Methods

Check | Returns true if the specified object satisfy the condition.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Not Class | Aspose.Tasks.Util Namespace


Not.Check Method

Returns true if the specified object satisfy the condition.

public bool Check(
object el
);

Parameters

el
The object to check.

Return Value

True if the object satisfy the condition.

Implements

ICondition.Check

See Also

Not Class | Aspose.Tasks.Util Namespace


RemoveTask Class

Removes the specified task from a tree of tasks.

For a list of all members of this type, see RemoveTask Members.

System.Object
Aspose.Tasks.Util.RemoveTask

public class RemoveTask : ITreeAlgorithm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

RemoveTask Members | Aspose.Tasks.Util Namespace


RemoveTask Members

RemoveTask overview

Public Instance Constructors

RemoveTask Constructor Creates task remover.

Public Instance Methods

Alg | Do nothing.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostAlg | Do nothing.
PreAlg | Removes the task from the specified parent task.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveTask Class | Aspose.Tasks.Util Namespace


RemoveTask Constructor

Creates task remover.

public RemoveTask(
Task task
);

Parameters

task
Task to remove.

See Also

RemoveTask Class | Aspose.Tasks.Util Namespace


RemoveTask Methods

The methods of the RemoveTask class are listed below. For a complete list of RemoveTask class members, see the RemoveTask Members topic.

Public Instance Methods

Alg | Do nothing.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostAlg | Do nothing.
PreAlg | Removes the task from the specified parent task.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveTask Class | Aspose.Tasks.Util Namespace


RemoveTask.Alg Method

Do nothing.

public void Alg(
object el,
int level
);

Parameters

el
level

Implements

ITreeAlgorithm.Alg

See Also

RemoveTask Class | Aspose.Tasks.Util Namespace


RemoveTask.PostAlg Method

Do nothing.

public void PostAlg(
object el,
int level
);

Parameters

el
level

Implements

ITreeAlgorithm.PostAlg

See Also

RemoveTask Class | Aspose.Tasks.Util Namespace


RemoveTask.PreAlg Method

Removes the task from the specified parent task.

public void PreAlg(
object el,
int level
);

Parameters

el
Parent task.
level
Tree node level.

Implements

ITreeAlgorithm.PreAlg

See Also

RemoveTask Class | Aspose.Tasks.Util Namespace


TaskUtils Class

Helper class which provides useful operations with tasks.

For a list of all members of this type, see TaskUtils Members.

System.Object
Aspose.Tasks.Util.TaskUtils

public class TaskUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Util

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

TaskUtils Members | Aspose.Tasks.Util Namespace


TaskUtils Members

TaskUtils overview

Public Static Methods

Apply | Applies specified algorithm to each task of a tree.
Filter | Builds new tree of tasks which satisfy the condition.
Find | Finds a task which satisfy the condition in a tree of tasks.
TaskChildrenCount | Recursively calculates a number of task's children tasks through all levels.

Public Instance Constructors

TaskUtils Constructor Initializes a new instance of the TaskUtils class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskUtils Class | Aspose.Tasks.Util Namespace


TaskUtils Constructor

Initializes a new instance of the TaskUtils class.

public TaskUtils();

See Also

TaskUtils Class | Aspose.Tasks.Util Namespace


TaskUtils Methods

The methods of the TaskUtils class are listed below. For a complete list of TaskUtils class members, see the TaskUtils Members topic.

Public Static Methods

Apply | Applies specified algorithm to each task of a tree.
Filter | Builds new tree of tasks which satisfy the condition.
Find | Finds a task which satisfy the condition in a tree of tasks.
TaskChildrenCount | Recursively calculates a number of task's children tasks through all levels.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskUtils Class | Aspose.Tasks.Util Namespace


TaskUtils.Apply Method

Applies specified algorithm to each task of a tree.

public static void Apply(
Task root,
ITreeAlgorithm alg,
int level
);

Parameters

root
Root of the tree
alg
Applied algorithm.
level
Level of the root task.

See Also

TaskUtils Class | Aspose.Tasks.Util Namespace


TaskUtils.Filter Method

Builds new tree of tasks which satisfy the condition.

public static Task Filter(
Task root,
ICondition cond
);

Parameters

root
Root of the tree.
cond
Applied condition.

Return Value

Root of a new tree.

See Also

TaskUtils Class | Aspose.Tasks.Util Namespace


TaskUtils.Find Method

Finds a task which satisfy the condition in a tree of tasks.

public static Task Find(
Task root,
ICondition cond
);

Parameters

root
Root of the tree.
cond
Applied condition.

Return Value

Task if task was found, otherwise null.

See Also

TaskUtils Class | Aspose.Tasks.Util Namespace


TaskUtils.TaskChildrenCount Method

Recursively calculates a number of task's children tasks through all levels.

public static int TaskChildrenCount(
Task task
);

Parameters

task
The task which children calculate.

Return Value

The number of children.

See Also

TaskUtils Class | Aspose.Tasks.Util Namespace


Aspose.Tasks.Visualization

Aspose.Tasks.Visualization Namespace

Namespace hierarchy

Classes

Class | Description
AssignmentViewColumn | Project's view class.
BarStyle | Change the visual style of the bar for the item in the project view.
BaseHtmlRenderParam | Parameter for html rendering.
BaseImageRenderParam | Parameter for image rendering.
BaseRenderParam | Abstract default implementation of IRenderParam, base class for all rendering parameters.
GanttBarStyle | Represents a bar style used by MSP in Gantt Chart view.
GanttChartColumn | Project's view class
Gridline | The horizontal or vertical line that appears in the project view.
Gridlines | Represents gridlines that appear in a GanttChart view.
HtmlRenderStyles | Contains html rendering CSS styling information.
ProgressLines | Represents progress lines in a Gantt Chart view.
ProjectView | Project's view class
RecurringInterval | Represents recurring intervals used in progress lines of a Gantt Chart view.
ResourceViewColumn | Project's view class used in ResourceUsage view and ResourceSheet view.
TableTextStyle | Represents a text style in a view table.
TextStyle | Change the visual style of the text for an item in the project view.
TimescaleTier | Represents a single tier of the timescale on a Gantt Chart.

Interfaces

Interface | Description
IHitable | Root interface for all hitable objects.
IHitTestResult | Returns hit testing result.
IRenderParam | Base interface for rendering params.
IRenderResult | Returns rendering result.

Delegates

Delegate | Description
AssignmentToColumnTextConverter | ResourceAssignment data to column's string converter.
BarStyle.TaskToBarTextConverter |
ResourceToColumnTextConverter | Resource's data to column's string converter.
TaskToColumnTextConverter | Task's data to column's string converter.

Enumerations

Enumeration | Description
BarItemType | Item type to change a bar style for.
BarShape | Shape of a bar rectangle.
DateLabel | Specifies the display format for date and time labels in a timescale.
GanttBarEndShape | Represents end shape in bars and progress points in progress lines.
GanttBarFillPattern | Fill pattern used in middle shape of a gantt bar.
GanttBarMiddleShape | Specifies the middle shape of a bar.
GanttBarType | Specifies the bar type.
GridlineType | Type of gridline.
Interval | Specifies recurring intervals to display progress lines at.
LinePattern | Line pattern.
PageSize | Specifies page size.
PresentationFormat | Enumeration for presentation format.
RecurringInterval.DayType |
RenderFormat | Enumeration for different render formats.
RenderResult | Enumeration for render results.
RenderScale | Enumeration for rendering period scaling.
ReportType | Type of the project's graphical report.
Shape | Shape of a marker at the beginning or end of the bar style to be rendered when saving view data to some of SaveFileFormat.
TextItemType | Item type to change a text style for.
Timescale | The minimal time period to render when saving project view data to some of SaveFileFormat.
TimescaleUnit | Specifies the unit of time for any tier of a timescale in a Gantt chart or other timephased view.


AssignmentToColumnTextConverter Delegate

ResourceAssignment data to column's string converter.

public delegate string AssignmentToColumnTextConverter(
ResourceAssignment assignment
);

Parameters

assignment
ResourceAssignment.

Return Value

String data for the column.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


AssignmentViewColumn Class

Project's view class.

For a list of all members of this type, see AssignmentViewColumn Members.

System.Object
Aspose.Tasks.Visualization.AssignmentViewColumn

public class AssignmentViewColumn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

AssignmentViewColumn Members | Aspose.Tasks.Visualization Namespace


AssignmentViewColumn Members

AssignmentViewColumn overview

Public Instance Constructors

AssignmentViewColumn Constructor Public AssignmentViewColumn constructor.

Public Instance Properties

Name | The column name.
StringAlignment | StringAlignment of the text.
Width | The column width.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnText | Converts current resource assignment to the column text.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssignmentViewColumn Class | Aspose.Tasks.Visualization Namespace


AssignmentViewColumn Constructor

Public AssignmentViewColumn constructor.

public AssignmentViewColumn(
string name,
int width,
AssignmentToColumnTextConverter converter
);

Parameters

name
Column's name.
width
Column's width in pixels.
converter
Assignment data to column text converter.

See Also

AssignmentViewColumn Class | Aspose.Tasks.Visualization Namespace


AssignmentViewColumn Properties

The properties of the AssignmentViewColumn class are listed below. For a complete list of AssignmentViewColumn class members, see the AssignmentViewColumn Members topic.

Public Instance Properties

Name | The column name.
StringAlignment | StringAlignment of the text.
Width | The column width.

See Also

AssignmentViewColumn Class | Aspose.Tasks.Visualization Namespace


Name Property

AssignmentViewColumn.Name Property

The column name.

public string Name {get;}

See Also

AssignmentViewColumn Class | Aspose.Tasks.Visualization Namespace


StringAlignment Property

AssignmentViewColumn.StringAlignment Property

StringAlignment of the text.

public StringAlignment StringAlignment {get; set;}

See Also

AssignmentViewColumn Class | Aspose.Tasks.Visualization Namespace


Width Property

AssignmentViewColumn.Width Property

The column width.

public int Width {get;}

See Also

AssignmentViewColumn Class | Aspose.Tasks.Visualization Namespace


AssignmentViewColumn Methods

The methods of the AssignmentViewColumn class are listed below. For a complete list of AssignmentViewColumn class members, see the AssignmentViewColumn Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnText | Converts current resource assignment to the column text.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssignmentViewColumn Class | Aspose.Tasks.Visualization Namespace


AssignmentViewColumn.GetColumnText Method

Converts current resource assignment to the column text.

public string GetColumnText(
ResourceAssignment assignment
);

Parameters

assignment
Current assignment.

Return Value

The column text.

See Also

AssignmentViewColumn Class | Aspose.Tasks.Visualization Namespace


BarItemType Enumeration

Item type to change a bar style for.

public enum BarItemType

Members

Member Name | Description | Value
Task | Task item type. | 0
Summary | Summary task item type. | 1
ProjectSummary | Project summary task item type. | 2
ManualTask | Manual task item type. | 3
InactiveTask | Inactive task item type. | 4
CriticalTask | Critical task item type. | 5

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


BarShape Enumeration

Shape of a bar rectangle.

public enum BarShape

Members

Member Name | Description | Value
Full | Full rectangle. | 0
HalfHeight | Half height rectangle. | 1
Thin | Thin rectangle. | 2

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


BarStyle Class

Change the visual style of the bar for the item in the project view.

For a list of all members of this type, see BarStyle Members.

System.Object
Aspose.Tasks.Visualization.BarStyle

public class BarStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

BarStyle Members | Aspose.Tasks.Visualization Namespace


BarStyle Members

BarStyle overview

Public Instance Constructors

BarStyle Constructor Creates default bar style.

Public Instance Properties

BarColor | Color of the bar style.
BarShape | BarShape of the bar style.
BarTextConverter | TaskToBarTextConverter to get text for the bar to render.
EndShape | Shape at the end of the bar.
EndShapeColor | Color of the shape at the end of the bar.
ItemType | BarItemType of the bar style.
StartShape | Shape at the beginning of the bar.
StartShapeColor | Color of the shape at the beginning of the bar.
TextStyle | TextStyle of the text to render on the right of the bar.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BarStyle Class | Aspose.Tasks.Visualization Namespace


BarStyle Constructor

Creates default bar style.

public BarStyle();

See Also

BarStyle Class | Aspose.Tasks.Visualization Namespace


BarStyle Properties

The properties of the BarStyle class are listed below. For a complete list of BarStyle class members, see the BarStyle Members topic.

Public Instance Properties

BarColor | Color of the bar style.
BarShape | BarShape of the bar style.
BarTextConverter | TaskToBarTextConverter to get text for the bar to render.
EndShape | Shape at the end of the bar.
EndShapeColor | Color of the shape at the end of the bar.
ItemType | BarItemType of the bar style.
StartShape | Shape at the beginning of the bar.
StartShapeColor | Color of the shape at the beginning of the bar.
TextStyle | TextStyle of the text to render on the right of the bar.

See Also

BarStyle Class | Aspose.Tasks.Visualization Namespace


BarColor Property

BarStyle.BarColor Property

Color of the bar style.

public Color BarColor {get; set;}

See Also

BarStyle Class | Aspose.Tasks.Visualization Namespace


BarShape Property

BarStyle.BarShape Property

BarShape of the bar style.

public BarShape BarShape {get; set;}

See Also

BarStyle Class | Aspose.Tasks.Visualization Namespace


BarTextConverter Property

BarStyle.BarTextConverter Property

TaskToBarTextConverter to get text for the bar to render.

public TaskToBarTextConverter BarTextConverter {get; set;}

See Also

BarStyle Class | Aspose.Tasks.Visualization Namespace


EndShape Property

BarStyle.EndShape Property

Shape at the end of the bar.

public Shape EndShape {get; set;}

See Also

BarStyle Class | Aspose.Tasks.Visualization Namespace


EndShapeColor Property

BarStyle.EndShapeColor Property

Color of the shape at the end of the bar.

public Color EndShapeColor {get; set;}

See Also

BarStyle Class | Aspose.Tasks.Visualization Namespace


ItemType Property

BarStyle.ItemType Property

BarItemType of the bar style.

public BarItemType ItemType {get; set;}

See Also

BarStyle Class | Aspose.Tasks.Visualization Namespace


StartShape Property

BarStyle.StartShape Property

Shape at the beginning of the bar.

public Shape StartShape {get; set;}

See Also

BarStyle Class | Aspose.Tasks.Visualization Namespace


StartShapeColor Property

BarStyle.StartShapeColor Property

Color of the shape at the beginning of the bar.

public Color StartShapeColor {get; set;}

See Also

BarStyle Class | Aspose.Tasks.Visualization Namespace


TextStyle Property

BarStyle.TextStyle Property

TextStyle of the text to render on the right of the bar.

public TextStyle TextStyle {get; set;}

See Also

BarStyle Class | Aspose.Tasks.Visualization Namespace


BarStyle.TaskToBarTextConverter Delegate

public delegate string BarStyle.TaskToBarTextConverter(
Task task
);

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


BaseHtmlRenderParam Class

Parameter for html rendering.

For a list of all members of this type, see BaseHtmlRenderParam Members.

System.Object
Aspose.Tasks.Visualization.BaseRenderParam
Aspose.Tasks.Visualization.BaseHtmlRenderParam

public class BaseHtmlRenderParam : BaseRenderParam

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

BaseHtmlRenderParam Members | Aspose.Tasks.Visualization Namespace


BaseHtmlRenderParam Members

BaseHtmlRenderParam overview

Public Instance Constructors

BaseHtmlRenderParam Overloaded. Initializes a new instance of the BaseHtmlRenderParam class.

Public Instance Properties

EndDate (inherited from BaseRenderParam) | Rendering end date.
LegendOnEachPage (inherited from BaseRenderParam) | Show legend on each page or on the firsts only.
Location (inherited from BaseRenderParam) | Rendering start point.
Page (inherited from BaseRenderParam) | Page to render.
SBuilder | String builder to render.
Scale (inherited from BaseRenderParam) | Time rendering scale.
Size (inherited from BaseRenderParam) | Rendering size.
StartDate (inherited from BaseRenderParam) | Renderiong start date.
Styles | Set of rendering styles.
Zoom (inherited from BaseRenderParam) | Rendering zoom.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseHtmlRenderParam Class | Aspose.Tasks.Visualization Namespace


BaseHtmlRenderParam Constructor

Public constructor of BaseHtmlRenderParam.

Overload List

Public constructor of BaseHtmlRenderParam.

public BaseHtmlRenderParam(StringBuilder,Point,Size,int,int,bool);

Public constructor of BaseHtmlRenderParam.

public BaseHtmlRenderParam(StringBuilder,Point,Size,int,int,bool,DateTime,DateTime);

Public constructor of BaseHtmlRenderParam.

public BaseHtmlRenderParam(StringBuilder,Point,Size,int,int,bool,DateTime,DateTime,HtmlRenderStyles);

Public constructor of BaseHtmlRenderParam.

public BaseHtmlRenderParam(StringBuilder,Point,Size,int,int,bool,DateTime,DateTime,HtmlRenderStyles,RenderScale);

See Also

BaseHtmlRenderParam Class | Aspose.Tasks.Visualization Namespace


BaseHtmlRenderParam Constructor (StringBuilder, Point, Size, Int32, Int32, Boolean)

Public constructor of BaseHtmlRenderParam.

public BaseHtmlRenderParam(
StringBuilder sBuilder,
Point location,
Size size,
int zoom,
int page,
bool legendOnEachPage
);

Parameters

sBuilder
String builder to render.
location
Rendering start point.
size
Rendering size.
zoom
Rendering zoom.
page
Page to render.
legendOnEachPage
Show legend on each page.

See Also

BaseHtmlRenderParam Class | Aspose.Tasks.Visualization Namespace | BaseHtmlRenderParam Constructor Overload List


BaseHtmlRenderParam Constructor (StringBuilder, Point, Size, Int32, Int32, Boolean, DateTime, DateTime)

Public constructor of BaseHtmlRenderParam.

public BaseHtmlRenderParam(
StringBuilder sBuilder,
Point location,
Size size,
int zoom,
int page,
bool legendOnEachPage,
DateTime startDate,
DateTime endDate
);

Parameters

sBuilder
String builder to render.
location
Rendering start point.
size
Rendering size.
zoom
Rendering zoom.
page
Page to render.
legendOnEachPage
Show legend on each page.
startDate
Rendering start date.
endDate
Rendering end date.

See Also

BaseHtmlRenderParam Class | Aspose.Tasks.Visualization Namespace | BaseHtmlRenderParam Constructor Overload List


BaseHtmlRenderParam Constructor (StringBuilder, Point, Size, Int32, Int32, Boolean, DateTime, DateTime, HtmlRenderStyles)

Public constructor of BaseHtmlRenderParam.

public BaseHtmlRenderParam(
StringBuilder sBuilder,
Point location,
Size size,
int zoom,
int page,
bool legendOnEachPage,
DateTime startDate,
DateTime endDate,
HtmlRenderStyles styles
);

Parameters

sBuilder
String builder to render.
location
Rendering start point.
size
Rendering size.
zoom
Rendering zoom.
page
Page to render.
legendOnEachPage
Show legend on each page.
startDate
Rendering start date.
endDate
Rendering end date.
styles
Set of rendering styles.

See Also

BaseHtmlRenderParam Class | Aspose.Tasks.Visualization Namespace | BaseHtmlRenderParam Constructor Overload List


BaseHtmlRenderParam Constructor (StringBuilder, Point, Size, Int32, Int32, Boolean, DateTime, DateTime, HtmlRenderStyles, RenderScale)

Public constructor of BaseHtmlRenderParam.

public BaseHtmlRenderParam(
StringBuilder sBuilder,
Point location,
Size size,
int zoom,
int page,
bool legendOnEachPage,
DateTime startDate,
DateTime endDate,
HtmlRenderStyles styles,
RenderScale scale
);

Parameters

sBuilder
String builder to render.
location
Rendering start point.
size
Rendering size.
zoom
Rendering zoom.
page
Page to render.
legendOnEachPage
Show legend on each page.
startDate
Rendering start date.
endDate
Rendering end date.
styles
Set of rendering styles.
scale
Time rendering scale.

See Also

BaseHtmlRenderParam Class | Aspose.Tasks.Visualization Namespace | BaseHtmlRenderParam Constructor Overload List


BaseHtmlRenderParam Properties

The properties of the BaseHtmlRenderParam class are listed below. For a complete list of BaseHtmlRenderParam class members, see the BaseHtmlRenderParam Members topic.

Public Instance Properties

EndDate (inherited from BaseRenderParam) | Rendering end date.
LegendOnEachPage (inherited from BaseRenderParam) | Show legend on each page or on the firsts only.
Location (inherited from BaseRenderParam) | Rendering start point.
Page (inherited from BaseRenderParam) | Page to render.
SBuilder | String builder to render.
Scale (inherited from BaseRenderParam) | Time rendering scale.
Size (inherited from BaseRenderParam) | Rendering size.
StartDate (inherited from BaseRenderParam) | Renderiong start date.
Styles | Set of rendering styles.
Zoom (inherited from BaseRenderParam) | Rendering zoom.

See Also

BaseHtmlRenderParam Class | Aspose.Tasks.Visualization Namespace


SBuilder Property

BaseHtmlRenderParam.SBuilder Property

String builder to render.

public StringBuilder SBuilder {get; set;}

See Also

BaseHtmlRenderParam Class | Aspose.Tasks.Visualization Namespace


Styles Property

BaseHtmlRenderParam.Styles Property

Set of rendering styles.

public HtmlRenderStyles Styles {get; set;}

See Also

BaseHtmlRenderParam Class | Aspose.Tasks.Visualization Namespace


BaseImageRenderParam Class

Parameter for image rendering.

For a list of all members of this type, see BaseImageRenderParam Members.

System.Object
Aspose.Tasks.Visualization.BaseRenderParam
Aspose.Tasks.Visualization.BaseImageRenderParam

public class BaseImageRenderParam : BaseRenderParam

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

BaseImageRenderParam Members | Aspose.Tasks.Visualization Namespace


BaseImageRenderParam Members

BaseImageRenderParam overview

Public Instance Constructors

BaseImageRenderParam Overloaded. Initializes a new instance of the BaseImageRenderParam class.

Public Instance Properties

EndDate (inherited from BaseRenderParam) | Rendering end date.
Format | Image saving format.
Gfx | Graphics to render.
LegendOnEachPage (inherited from BaseRenderParam) | Show legend on each page or on the firsts only.
Location (inherited from BaseRenderParam) | Rendering start point.
Page (inherited from BaseRenderParam) | Page to render.
Scale (inherited from BaseRenderParam) | Time rendering scale.
Size (inherited from BaseRenderParam) | Rendering size.
StartDate (inherited from BaseRenderParam) | Renderiong start date.
Zoom (inherited from BaseRenderParam) | Rendering zoom.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseImageRenderParam Class | Aspose.Tasks.Visualization Namespace


BaseImageRenderParam Constructor

BaseImageRenderParam public constructor.

Overload List

BaseImageRenderParam public constructor.

public BaseImageRenderParam(Graphics,Point,Size,int,int,bool);

BaseImageRenderParam public constructor.

public BaseImageRenderParam(Graphics,Point,Size,int,int,bool,DateTime,DateTime);

BaseImageRenderParam public constructor.

public BaseImageRenderParam(Graphics,Point,Size,int,int,bool,DateTime,DateTime,RenderScale);

BaseImageRenderParam public constructor.

public BaseImageRenderParam(Graphics,Point,Size,int,int,bool,DateTime,DateTime,RenderScale,ImageFormat);

See Also

BaseImageRenderParam Class | Aspose.Tasks.Visualization Namespace


BaseImageRenderParam Constructor (Graphics, Point, Size, Int32, Int32, Boolean)

BaseImageRenderParam public constructor.

public BaseImageRenderParam(
Graphics gfx,
Point location,
Size size,
int zoom,
int page,
bool legendOnEachPage
);

Parameters

gfx
Graphics to render.
location
Start location.
size
Rendering size.
zoom
Rendering zoom.
page
Page to render.
legendOnEachPage
Show legend on each page.

See Also

BaseImageRenderParam Class | Aspose.Tasks.Visualization Namespace | BaseImageRenderParam Constructor Overload List


BaseImageRenderParam Constructor (Graphics, Point, Size, Int32, Int32, Boolean, DateTime, DateTime)

BaseImageRenderParam public constructor.

public BaseImageRenderParam(
Graphics gfx,
Point location,
Size size,
int zoom,
int page,
bool legendOnEachPage,
DateTime startDate,
DateTime endDate
);

Parameters

gfx
Graphics to render.
location
Start location.
size
Rendering size.
zoom
Rendering zoom.
page
Page to render.
legendOnEachPage
Show legend on each page.
startDate
Rendering start date.
endDate
Rendering end date.

See Also

BaseImageRenderParam Class | Aspose.Tasks.Visualization Namespace | BaseImageRenderParam Constructor Overload List


BaseImageRenderParam Constructor (Graphics, Point, Size, Int32, Int32, Boolean, DateTime, DateTime, RenderScale)

BaseImageRenderParam public constructor.

public BaseImageRenderParam(
Graphics gfx,
Point location,
Size size,
int zoom,
int page,
bool legendOnEachPage,
DateTime startDate,
DateTime endDate,
RenderScale scale
);

Parameters

gfx
Graphics to render.
location
Start location.
size
Rendering size.
zoom
Rendering zoom.
page
Page to render.
legendOnEachPage
Show legend on each page.
startDate
Rendering start date.
endDate
Rendering end date.
scale
Time scale.

See Also

BaseImageRenderParam Class | Aspose.Tasks.Visualization Namespace | BaseImageRenderParam Constructor Overload List


BaseImageRenderParam Constructor (Graphics, Point, Size, Int32, Int32, Boolean, DateTime, DateTime, RenderScale, ImageFormat)

BaseImageRenderParam public constructor.

public BaseImageRenderParam(
Graphics gfx,
Point location,
Size size,
int zoom,
int page,
bool legendOnEachPage,
DateTime startDate,
DateTime endDate,
RenderScale scale,
ImageFormat format
);

Parameters

gfx
Graphics to render.
location
Start location.
size
Rendering size.
zoom
Rendering zoom.
page
Page to render.
legendOnEachPage
Show legend on each page.
startDate
Rendering start date.
endDate
Rendering end date.
scale
Time scale.
format
Image saving format.

See Also

BaseImageRenderParam Class | Aspose.Tasks.Visualization Namespace | BaseImageRenderParam Constructor Overload List


BaseImageRenderParam Properties

The properties of the BaseImageRenderParam class are listed below. For a complete list of BaseImageRenderParam class members, see the BaseImageRenderParam Members topic.

Public Instance Properties

EndDate (inherited from BaseRenderParam) | Rendering end date.
Format | Image saving format.
Gfx | Graphics to render.
LegendOnEachPage (inherited from BaseRenderParam) | Show legend on each page or on the firsts only.
Location (inherited from BaseRenderParam) | Rendering start point.
Page (inherited from BaseRenderParam) | Page to render.
Scale (inherited from BaseRenderParam) | Time rendering scale.
Size (inherited from BaseRenderParam) | Rendering size.
StartDate (inherited from BaseRenderParam) | Renderiong start date.
Zoom (inherited from BaseRenderParam) | Rendering zoom.

See Also

BaseImageRenderParam Class | Aspose.Tasks.Visualization Namespace


Format Property

BaseImageRenderParam.Format Property

Image saving format.

public ImageFormat Format {get; set;}

See Also

BaseImageRenderParam Class | Aspose.Tasks.Visualization Namespace


Gfx Property

BaseImageRenderParam.Gfx Property

Graphics to render.

public Graphics Gfx {get; set;}

See Also

BaseImageRenderParam Class | Aspose.Tasks.Visualization Namespace


BaseRenderParam Class

Abstract default implementation of IRenderParam, base class for all rendering parameters.

For a list of all members of this type, see BaseRenderParam Members.

System.Object
Aspose.Tasks.Visualization.BaseRenderParam
Aspose.Tasks.Visualization.BaseHtmlRenderParam
Aspose.Tasks.Visualization.BaseImageRenderParam

public abstract class BaseRenderParam : IRenderParam

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

BaseRenderParam Members | Aspose.Tasks.Visualization Namespace


BaseRenderParam Members

BaseRenderParam overview

Public Instance Properties

EndDate | Rendering end date.
LegendOnEachPage | Show legend on each page or on the firsts only.
Location | Rendering start point.
Page | Page to render.
Scale | Time rendering scale.
Size | Rendering size.
StartDate | Renderiong start date.
Zoom | Rendering zoom.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseRenderParam Class | Aspose.Tasks.Visualization Namespace


BaseRenderParam Properties

The properties of the BaseRenderParam class are listed below. For a complete list of BaseRenderParam class members, see the BaseRenderParam Members topic.

Public Instance Properties

EndDate | Rendering end date.
LegendOnEachPage | Show legend on each page or on the firsts only.
Location | Rendering start point.
Page | Page to render.
Scale | Time rendering scale.
Size | Rendering size.
StartDate | Renderiong start date.
Zoom | Rendering zoom.

See Also

BaseRenderParam Class | Aspose.Tasks.Visualization Namespace


EndDate Property

BaseRenderParam.EndDate Property

Rendering end date.

public DateTime EndDate {get; set;}

Implements

IRenderParam.EndDate

See Also

BaseRenderParam Class | Aspose.Tasks.Visualization Namespace


LegendOnEachPage Property

BaseRenderParam.LegendOnEachPage Property

Show legend on each page or on the firsts only.

public bool LegendOnEachPage {get; set;}

Implements

IRenderParam.LegendOnEachPage

See Also

BaseRenderParam Class | Aspose.Tasks.Visualization Namespace


Location Property

BaseRenderParam.Location Property

Rendering start point.

public Point Location {get; set;}

Implements

IRenderParam.Location

See Also

BaseRenderParam Class | Aspose.Tasks.Visualization Namespace


Page Property

BaseRenderParam.Page Property

Page to render.

public int Page {get; set;}

Implements

IRenderParam.Page

See Also

BaseRenderParam Class | Aspose.Tasks.Visualization Namespace


Scale Property

BaseRenderParam.Scale Property

Time rendering scale.

public RenderScale Scale {get; set;}

Implements

IRenderParam.Scale

See Also

BaseRenderParam Class | Aspose.Tasks.Visualization Namespace


Size Property

BaseRenderParam.Size Property

Rendering size.

public Size Size {get; set;}

Implements

IRenderParam.Size

See Also

BaseRenderParam Class | Aspose.Tasks.Visualization Namespace


StartDate Property

BaseRenderParam.StartDate Property

Renderiong start date.

public DateTime StartDate {get; set;}

Implements

IRenderParam.StartDate

See Also

BaseRenderParam Class | Aspose.Tasks.Visualization Namespace


Zoom Property

BaseRenderParam.Zoom Property

Rendering zoom.

public int Zoom {get; set;}

Implements

IRenderParam.Zoom

See Also

BaseRenderParam Class | Aspose.Tasks.Visualization Namespace


DateLabel Enumeration

Specifies the display format for date and time labels in a timescale.

public enum DateLabel

Members

Member Name | Description | Value
None | No date is displayed. | 35
Day_ddd | Examples: Mon, Tue. | 19
Day_ddd_dd | Examples: Mon 30, Tue 1 | 105
Day_ddd_m_dd | Examples: Mon S 30, Tue O 1 | 112
Day_ddd_mm_dd | Examples: Mon 9/30, Tue 10/1 | 108
Day_ddd_mm_dd_yy | Examples: Mon 9/30/02, Tue 10/1/02 | 52
Day_ddd_mmm_dd | Examples: Mon Sep 30, Tue Oct 1 | 23
Day_ddd_mmm_dd_yyy | Examples: Mon September 30 '02, Tue October 1 '02 | 22
Day_ddd_mmmm_dd | Examples: Mon September 30, Tue October 1 | 111
Day_dddd | Examples: Tuesday, Wednesday. | 18
Day_ddi | Examples: Mo, Tu | 119
Day_ddi_dd | Examples: Mo 30, Tu 1 | 106
Day_ddi_m_dd | Examples: Mo S 30, Tu O 1 | 113
Day_ddi_mm_dd | Examples: Mo 9/30, Tu 10/1 | 109
Day_di | Examples: M, T | 20
Day_di_dd | Examples: M 30, T 1 | 107
Day_di_m_dd | Examples: M S 30, T O 1 | 114
Day_di_mm_dd | Examples: M 9/30, T 10/1 | 110
Day_didd | Examples: M30, T1 | 121
Day_m_dd | Examples: S 30, O 1 | 115
Day_mm_dd | Examples: 9/30, 10/1 | 27
Day_mm_dd_yy | Examples: 9/30/02, 10/1/02 | 26
Day_mmm_dd | Examples: Sep 30, Oct 1 | 25
Day_mmm_dd_yyy | Examples: Sep 30 '02, Oct 10 '02 | 24
DayFromEnd_Day_dd | Examples: Day 2, Day 1, Day -1, Day -2 from the project end. | 41
DayFromEnd_dd | Examples: 2, 1, -1, -2 | 54
DayFromEnd_Ddd | Examples: D2, D1, D-1, D-2 | 53
DayFromStart_Day_dd | Examples: Day -2, Day -1, Day 1, Day 2 from the project start. | 40
DayFromStart_dd | Examples: -2, -1, 1, 2 | 56
DayFromStart_Ddd | Examples: D-2, D-1, D1, D2 | 55
DayOfMonth_dd | Examples: 30, 1 | 21
DayOfYear_dd | Examples: 77, 78 | 118
DayOfYear_dd_yyy | Examples: 77 '10, 78 '10 | 116
DayOfYear_dd_yyyy | Examples: 77 2010, 78 2010 | 117
HalfYear_h | Examples: 1, 2. Requires the time unit to be pjTimescaleHalfYears. | 128
HalfYear_Hh | Examples: H1, H2 | 127
HalfYear_Hh_yyy | Examples: H1 '10, H2 '10 | 126
HalfYear_hhh_Half | Examples: 1st Half, 2nd Half | 123
HalfYear_hHyy | Examples: 1H10, 2H10 | 129
HalfYear_Hlf_h | Examples: Half 1, Half 2 | 125
HalfYear_Hlf_h_yyyy | Examples: Half 1, 2010; Half 2, 2010 | 124
HalfYearFromEnd_h | Examples: 2, 1, -1, -2. Half years from the project end date. | 135
HalfYearFromEnd_Half_h | Examples: Half 2, Half 1, Half -1, Half -2 | 133
HalfYearFromEnd_Hh | Examples: H2, H1, H-1, H-2 | 134
HalfYearFromStart_h | Examples: -2, -1, 1, 2. Half years from the project start date. | 132
HalfYearFromStart_Half_h | Examples: Half -2, Half -1, Half 1, Half 2 | 130
HalfYearFromStart_Hh | Examples: H-2, H-1, H1, H2 | 131
Hour_ddd_mmm_dd_hhAM | Examples: Wed Mar 18, 8 AM; Wed Mar 18, 9 AM. Requires the time unit to be pjTimescaleHours. | 28
Hour_hh | Examples: 8, 9, 10, 11 | 32
Hour_hh_mmAM | Examples: 8:00 AM, 9:00 AM | 30
Hour_hhAM | Examples: 8AM, 9AM | 31
Hour_mm_dd_hhAM | Examples: 3/18 8 AM, 3/18 9 AM | 120
Hour_mmm_dd_hhAM | Examples: Mar 18, 8 AM; Mar 18, 9 AM | 29
HourFromEnd_hh | Examples: 3, 2, 1, -1, -2 hours from the project end. | 77
HourFromEnd_Hhh | Examples: H3, H2, H1, H-1, H-2 | 76
HourFromEnd_Hour_hh | Examples: Hour 3, Hour 2, Hour 1, Hour -1, Hour -2 | 39
HourFromStart_hh | Examples: -2, -1, 1, 2, 3 hours from the project start. | 79
HourFromStart_Hhh | Examples: H-2, H-1, H1, H2, H3 | 78
HourFromStart_Hour_hh | Examples: Hour -2, Hour -1, Hour 1, Hour 2, Hour 3 | 38
Minute_hh_mmAM | Examples: 8:00 AM, 8:01 AM, 8:02 AM. Requires the time unit to be pjTimescaleMinutes. | 33
Minute_mm | Examples: 0, 1, 2, ..., 59 minutes | 34
MinuteFromEnd_Minute_mm | Examples: Minute 181, Minute 180, ..., Minute 1, Minute -1 from the project end. | 37
MinuteFromEnd_mm | Examples: 181, 180, ..., 1, -1 | 81
MinuteFromEnd_Mmm | Examples: M181, M180, ..., M1, M-1 | 80
MinuteFromStart_Minute_mm | Examples: Minute -2, Minute -1, Minute 1, ... Minute 180 from the project start. | 36
MinuteFromStart_mm | Examples: -2, -1, 1, ..., 180 | 83
MinuteFromStart_Mmm | Examples: M-2, M-1, M1, ..., M180 | 82
Month_m | Examples: M, A, M, J, J. Requires the time unit to be pjTimescaleMonths. | 11
Month_mm | Examples: 11, 12, 1, 2 | 57
Month_mm_yy | Examples: 3/10, 4/10, 5/10 | 86
Month_mm_yyy | Examples: 3 '10, 4 '10, 5 '10 | 85
Month_mmm | Examples: Mar, Apr, May | 10
Month_mmm_yyy | Examples: Mar '10, Apr '10, May '10 | 8
Month_mmmm | Examples: March, April, May | 9
Month_mmmm_yyyy | Examples: March 2010, April 2010, May 2010 | 7
MonthFromEnd_mm | Examples: 2, 1, -1, -2 months from the project end. | 59
MonthFromEnd_Mmm | Examples: M2, M1, M-1, M-2 | 58
MonthFromEnd_Month_mm | Examples: Month 2, Month 1, Month -1, Month -2 | 45
MonthFromStart_mm | Examples: -2, -2, 1, 2 months from the project start. | 61
MonthFromStart_Mmm | Examples: M-2, M-1, M1, M2 | 60
MonthFromStart_Month_mm | Examples: Month -2, Month -1, Month 1, Month 2 | 44
Quarter_q | Examples: 3, 4, 1. Requires the time unit to be pjTimescaleQuarters. | 62
Quarter_Qq | Examples: Q3, Q4, Q1 | 6
Quarter_Qq_yyy | Examples: Q3 '10, Q4 '10, Q1 '11 | 4
Quarter_qqq_Quarter | Examples: 3rd Quarter, 4th Quarter, 1st Quarter | 2
Quarter_qQyy | Examples: 3Q10, 4Q10, 1Q11 | 51
Quarter_Qtr_q | Examples: Qtr 3, Qtr 4, Qtr1 | 5
Quarter_Qtr_q_yyyy | Examples: Qtr3, 2010; Qtr4, 2010; Qtr1, 2011 | 3
QuarterFromEnd_q | Examples: 5, 4, 3, 2, 1, -1 quarters from the project end. | 64
QuarterFromEnd_Qq | Examples: Q5, Q4, Q3, Q2, Q1, Q-1 | 63
QuarterFromEnd_Quarter_q | Examples: Quarter 5, Quarter 4, Quarter 3, Quarter 2, Quarter 1, Quarter -1 | 47
QuarterFromStart_q | Examples: -5, -4, -3, -2, -1, 1 quarters from the project start. | 66
QuarterFromStart_Qq | Examples: Q-5, Q-4, Q-3, Q-2, Q-1, Q1 | 65
QuarterFromStart_Quarter_q | Examples: Quarter -5, Quarter -4, Quarter -3, Quarter -2, Quarter -1, Quarter 1 | 46
ThirdsOfMonths_dd | Examples: 1, 11, 21, 1. Requires the time unit to be pjTimescaleThirdsOfMonths. | 136
ThirdsOfMonths_ddd | Examples: B, M, E, B | 137
ThirdsOfMonths_dddd | Examples: Beginning, Middle, End, Beginning | 138
ThirdsOfMonths_mm_dd | Examples: 3/1, 3/11, 3/21, 4/1 | 139
ThirdsOfMonths_mm_dd_yy | Examples: 3/1/10, 3/11/10, 3/21/10, 4/1/10 | 145
ThirdsOfMonths_mm_ddd | Examples: 3/B, 3/M, 3/E, 4/B | 140
ThirdsOfMonths_mm_ddd_yy | Examples: 3/B/10, 3/M/10, 3/E/10, 4/B/10 | 146
ThirdsOfMonths_mmm_dd | Examples: Mar 1, Mar 11, Mar 21, Apr 1 | 142
ThirdsOfMonths_mmm_dd_yy | Examples: Mar 1, '10; Mar 11, '10; Mar 21, '10; Apr 1, 10 | 147
ThirdsOfMonths_mmm_ddd | Examples: Mar B, Mar M, Mar E, Apr B | 143
ThirdsOfMonths_mmm_ddd_yy | Examples: Mar B, '10; Mar M, '10; Mar E, '10; Apr B '10 | 148
ThirdsOfMonths_mmmm_dd | Examples: March 1, March 11, March 21, April 1 | 144
ThirdsOfMonths_mmmm_dd_yyyy | Examples: March 1, 2010; March 11, 2010; March 21, 2010; April 1, 2010 | 149
ThirdsOfMonths_mmmm_dddd | Examples: March Beginning, March Middle, March End, April Beginning | 141
ThirdsOfMonths_mmmm_dddd_yyyy | Examples: March Beginning, 2010; March Middle, 2010; March End, 2010; April Beginning, 2010 | 150
Week_ddd_dd | Examples: Sun 21, Sun 28, Sun 4. Requires the time unit to be pjTimescaleWeeks. | 88
Week_ddd_m_dd | Examples: Sun M 21, Sun M 28, Sun A 4 | 97
Week_ddd_mm_dd | Examples: Sun 3/21, Sun 3/28, Sun 4/4 | 90
Week_ddd_mm_dd_yy | Examples: Sun 3/21/10, Sun 3/28/10, Sun 4/4/10 | 100
Week_ddd_mmm_dd | Examples: Sun Mar 21, Sun Mar 28, Sun Apr 4 | 93
Week_ddd_mmm_dd_yyy | Examples: Sun Mar 21, '10; Sun Mar 28, '10; Sun Apr 4, '10 | 101
Week_ddd_mmmm_dd | Examples: Sun Mar 21, Sun March 28, Sun Apr 4 | 96
Week_ddd_mmmm_dd_yyy | Examples: Sun Mar 21, '10; Sun March 28, '10; Sun Apr 4, '10 | 102
Week_ddd_ww | Examples: Sun 12, Sun 13, Sun 14 | 103
Week_ddi_m_dd | Examples: Sun M 21, Sun M 28, Sun A 4 | 98
Week_ddi_mm_dd | Examples: Su 3/21. Su 3/28, Su 4/4 | 91
Week_ddi_mmm_dd | Examples: Su Mar 21, Su Mar 28, Su Apr 4 | 94
Week_di_m_dd | Examples: S M 21, S M 28, S A 4 | 99
Week_di_mm_dd | Examples: S 3/21, S 3/28, S 4/4 | 92
Week_di_mmm_dd | Examples: S Mar 21, S Mar 28, S Apr 4 | 95
Week_m_dd | Examples: M21, M28, A 4 | 89
Week_mm_dd | Examples: 3/21, 3/28, 4/4 | 17
Week_mm_dd_yy | Examples: 3/21/10. 3/28/10, 4/4/10 | 16
Week_mmm_dd | Examples: Mar 21, Mar 28, Apr 4 | 15
Week_mmm_dd_yyy | Examples: Mar 21, '10; Mar 28, '10; Apr 4, '10 | 13
Week_mmmm_dd | Examples: March 21, March 28, April 4 | 14
Week_mmmm_dd_yyyy | Examples: March 21, 2010; March 28, 2010; April 4, 2010 | 12
WeekDayOfMonth_dd | Examples: 21, 28, 4 | 87
WeekFromEnd_Week_ww | Examples: Week 2, Week 1, Week -1 from the project end. | 43
WeekFromEnd_ww | Examples: 2, 1, -1 | 68
WeekFromEnd_Www | Examples: W2, W1, W-1 | 67
WeekFromStart_Week_ww | Examples: Week -1, Week 1, Week 2 from the project start. | 42
WeekFromStart_ww | Examples: -1, 1, 2 | 70
WeekFromStart_Www | Examples: W-1, W1, W2 | 69
WeekNumber_dd_ww | Examples: 1 12, 1 13, 1 14 (day 1 of week 12, day 1 of week 13, and so forth) | 104
WeekNumber_ww | Examples: 12, 13, 14 | 50
Year_yy | Examples: 10, 11, 12. Requires the time unit to be pjTimescaleYears. | 75
Year_yyy | Examples: '10, '11, '12 | 1
Year_yyyy | Examples: 2010, 2011, 2012 | 0
YearFromEnd_Year_yy | Examples: Year 2, Year 1, Year -1 from the project end. | 49
YearFromEnd_yy | Examples: 2, 1, -1 | 72
YearFromEnd_Yyy | Examples: Y2, Y1, Y-1 | 71
YearFromStart_Year_yy | Examples: Year -1, Year 1, Year 2 from the project start. | 48
YearFromStart_yy | Examples: -1, 1, 2 | 74
YearFromStart_Yyy | Examples: Y-1, Y1, Y2 | 73

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


GanttBarEndShape Enumeration

Represents end shape in bars and progress points in progress lines.

public enum GanttBarEndShape

Members

Member Name | Description | Value
ArrowDown | Arrow pointing down. | 14
ArrowUp | Arrow pointing up. | 8
CaretDownTop | Caret pointing down on the top half of the bar. | 9
CaretUpBottom | Caret pointing up on the bottom half of the bar. | 10
Circle | Circle. | 19
CircleArrowDown | Circled arrow pointing down. | 18
CircleArrowUp | Circled arrow pointing up. | 17
CircleDiamond | Circled diamond. | 13
CircleTriangleDown | Circled triangle pointing down. | 16
CircleTriangleUp | Circled triangle pointing up. | 15
Diamond | Diamond. | 3
HouseDown | Upside-down house. | 2
HouseUp | House. | 1
LeftBracket | Left bracket. | 21
LeftFade | Left fade. | 23
LineShape | Line. | 11
NoBarEndShape | None. | 0
RightBracket | Right bracket. | 22
RightFade | Right fade. | 24
Square | Square. | 12
Star | Star. | 20
TriangleDown | Triangle pointing down. | 5
TriangleLeft | Triangle pointing left. | 7
TriangleRight | Triangle pointing right. | 6
TriangleUp | Circled triangle pointing up. | 4

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


GanttBarFillPattern Enumeration

Fill pattern used in middle shape of a gantt bar.

public enum GanttBarFillPattern

Members

Member Name | Description | Value
DarkFill | Dark fill pattern. | 4
DiagonalCross | Diagonal cross pattern. | 7
DiagonalLeft | Diagonal left pattern. | 5
DiagonalRight | Diagonal right pattern. | 6
Hollow | Hollow pattern. | 0
LightFill | Light fill pattern. | 2
LineCross | Line cross pattern. | 10
LineHorizontal | Line horizontal pattern. | 9
LineVertical | Line vertical pattern. | 8
MediumFill | Medium fill pattern. | 3
SolidFill | Solid fill pattern. | 1

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


GanttBarMiddleShape Enumeration

Specifies the middle shape of a bar.

public enum GanttBarMiddleShape

Members

Member Name | Description | Value
LineBottom | Bottom line. | 7
LineMiddle | Middle line. | 6
LineTop | Top line. | 5
None | None. | 0
RectangleBar | Rectangle. | 1
RectangleBottom | Rectangle bottom. | 4
RectangleMiddle | Rectangle middle. | 3
RectangleTop | Rectangle top. | 2

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


GanttBarStyle Class

Represents a bar style used by MSP in Gantt Chart view.

For a list of all members of this type, see GanttBarStyle Members.

System.Object
Aspose.Tasks.Visualization.GanttBarStyle

public class GanttBarStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

GanttBarStyle Members | Aspose.Tasks.Visualization Namespace


GanttBarStyle Members

GanttBarStyle overview

Public Instance Constructors

GanttBarStyle Constructor Initializes a new instance of the GanttBarStyle class.

Public Instance Properties

BottomField | Data to be displayed on the bottom of the bar. Field.
EndShape | An end shape of the bar.
EndShapeColor | A color of the end shape.
EndShapeType | A type of the end shape. GanttBarType.
From | Start point position of the gantt bar. Field.
InsideField | Data to be displayed inside of the bar. Field.
LeftField | Data to be displayed on the left of the bar. Field.
MiddleFillPattern | A fill pattern of the gantt bar.
MiddleShape | A middle shape of the bar.
MiddleShapeColor | A color of the middle shape.
Name | A name of the style.
RightField | Data to be displayed on the right of the bar. Field.
Row | A row number. Can be from 1 to 4 (1 is default value).
ShowFor | Task categories separated by semicolumns, which are to be represented by the gantt bar.
StartShape | A start shape of the bar.
StartShapeColor | A color of the start shape.
StartShapeType | A type of the start shape. GanttBarType.
To | Finish point position of the gantt bar.
TopField | Data to be displayed on the top of the bar. Field.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


GanttBarStyle Constructor

Initializes a new instance of the GanttBarStyle class.

public GanttBarStyle();

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


GanttBarStyle Properties

The properties of the GanttBarStyle class are listed below. For a complete list of GanttBarStyle class members, see the GanttBarStyle Members topic.

Public Instance Properties

BottomField | Data to be displayed on the bottom of the bar. Field.
EndShape | An end shape of the bar.
EndShapeColor | A color of the end shape.
EndShapeType | A type of the end shape. GanttBarType.
From | Start point position of the gantt bar. Field.
InsideField | Data to be displayed inside of the bar. Field.
LeftField | Data to be displayed on the left of the bar. Field.
MiddleFillPattern | A fill pattern of the gantt bar.
MiddleShape | A middle shape of the bar.
MiddleShapeColor | A color of the middle shape.
Name | A name of the style.
RightField | Data to be displayed on the right of the bar. Field.
Row | A row number. Can be from 1 to 4 (1 is default value).
ShowFor | Task categories separated by semicolumns, which are to be represented by the gantt bar.
StartShape | A start shape of the bar.
StartShapeColor | A color of the start shape.
StartShapeType | A type of the start shape. GanttBarType.
To | Finish point position of the gantt bar.
TopField | Data to be displayed on the top of the bar. Field.

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


BottomField Property

GanttBarStyle.BottomField Property

Data to be displayed on the bottom of the bar. Field.

public Field BottomField {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


EndShape Property

GanttBarStyle.EndShape Property

An end shape of the bar.

public GanttBarEndShape EndShape {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


EndShapeColor Property

GanttBarStyle.EndShapeColor Property

A color of the end shape.

public Color EndShapeColor {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


EndShapeType Property

GanttBarStyle.EndShapeType Property

A type of the end shape. GanttBarType.

public GanttBarType EndShapeType {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


From Property

GanttBarStyle.From Property

Start point position of the gantt bar. Field.

public Field From {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


InsideField Property

GanttBarStyle.InsideField Property

Data to be displayed inside of the bar. Field.

public Field InsideField {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


LeftField Property

GanttBarStyle.LeftField Property

Data to be displayed on the left of the bar. Field.

public Field LeftField {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


MiddleFillPattern Property

GanttBarStyle.MiddleFillPattern Property

A fill pattern of the gantt bar.

public GanttBarFillPattern MiddleFillPattern {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


MiddleShape Property

GanttBarStyle.MiddleShape Property

A middle shape of the bar.

public GanttBarMiddleShape MiddleShape {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


MiddleShapeColor Property

GanttBarStyle.MiddleShapeColor Property

A color of the middle shape.

public Color MiddleShapeColor {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


Name Property

GanttBarStyle.Name Property

A name of the style.

public string Name {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


RightField Property

GanttBarStyle.RightField Property

Data to be displayed on the right of the bar. Field.

public Field RightField {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


Row Property

GanttBarStyle.Row Property

A row number. Can be from 1 to 4 (1 is default value).

public int Row {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


ShowFor Property

GanttBarStyle.ShowFor Property

Task categories separated by semicolumns, which are to be represented by the gantt bar.

public string ShowFor {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


StartShape Property

GanttBarStyle.StartShape Property

A start shape of the bar.

public GanttBarEndShape StartShape {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


StartShapeColor Property

GanttBarStyle.StartShapeColor Property

A color of the start shape.

public Color StartShapeColor {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


StartShapeType Property

GanttBarStyle.StartShapeType Property

A type of the start shape. GanttBarType.

public GanttBarType StartShapeType {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


To Property

GanttBarStyle.To Property

Finish point position of the gantt bar.

public Field To {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


TopField Property

GanttBarStyle.TopField Property

Data to be displayed on the top of the bar. Field.

public Field TopField {get; set;}

See Also

GanttBarStyle Class | Aspose.Tasks.Visualization Namespace


GanttBarType Enumeration

Specifies the bar type.

public enum GanttBarType

Members

Member Name | Description | Value
Dashed | Dashed. | 2
Framed | Framed. | 1
Solid | Solid. | 0

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


GanttChartColumn Class

Project's view class

For a list of all members of this type, see GanttChartColumn Members.

System.Object
Aspose.Tasks.Visualization.GanttChartColumn

public class GanttChartColumn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

GanttChartColumn Members | Aspose.Tasks.Visualization Namespace


GanttChartColumn Members

GanttChartColumn overview

Public Instance Constructors

GanttChartColumn Constructor Public GanttChartColumn constructor.

Public Instance Properties

Name | The column name
StringAlignment | StringAlignment of the text.
Width | The column width.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnText | Converts current task to the column text.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GanttChartColumn Class | Aspose.Tasks.Visualization Namespace


GanttChartColumn Constructor

Public GanttChartColumn constructor.

public GanttChartColumn(
string name,
int width,
TaskToColumnTextConverter converter
);

Parameters

name
Column's name.
width
Column's width in pixels.
converter
Task data to column text converter.

See Also

GanttChartColumn Class | Aspose.Tasks.Visualization Namespace


GanttChartColumn Properties

The properties of the GanttChartColumn class are listed below. For a complete list of GanttChartColumn class members, see the GanttChartColumn Members topic.

Public Instance Properties

Name | The column name
StringAlignment | StringAlignment of the text.
Width | The column width.

See Also

GanttChartColumn Class | Aspose.Tasks.Visualization Namespace


Name Property

GanttChartColumn.Name Property

The column name

public string Name {get;}

See Also

GanttChartColumn Class | Aspose.Tasks.Visualization Namespace


StringAlignment Property

GanttChartColumn.StringAlignment Property

StringAlignment of the text.

public StringAlignment StringAlignment {get; set;}

See Also

GanttChartColumn Class | Aspose.Tasks.Visualization Namespace


Width Property

GanttChartColumn.Width Property

The column width.

public int Width {get;}

See Also

GanttChartColumn Class | Aspose.Tasks.Visualization Namespace


GanttChartColumn Methods

The methods of the GanttChartColumn class are listed below. For a complete list of GanttChartColumn class members, see the GanttChartColumn Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnText | Converts current task to the column text.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GanttChartColumn Class | Aspose.Tasks.Visualization Namespace


GanttChartColumn.GetColumnText Method

Converts current task to the column text.

public string GetColumnText(
Task task
);

Parameters

task
Current task.

Return Value

The column text.

See Also

GanttChartColumn Class | Aspose.Tasks.Visualization Namespace


Gridline Class

The horizontal or vertical line that appears in the project view.

For a list of all members of this type, see Gridline Members.

System.Object
Aspose.Tasks.Visualization.Gridline

public class Gridline

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Gridline Members | Aspose.Tasks.Visualization Namespace


Gridline Members

Gridline overview

Public Instance Constructors

Gridline Constructor Initializes a new instance of the Gridline class.

Public Instance Properties

Color | Color of a gridline.
GridlineType | Type of gridline (GridlineType).
Pattern | LinePattern of a gridline.

Public Instance Methods

Equals |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Gridline Class | Aspose.Tasks.Visualization Namespace


Gridline Constructor

Initializes a new instance of the Gridline class.

public Gridline();

See Also

Gridline Class | Aspose.Tasks.Visualization Namespace


Gridline Properties

The properties of the Gridline class are listed below. For a complete list of Gridline class members, see the Gridline Members topic.

Public Instance Properties

Color | Color of a gridline.
GridlineType | Type of gridline (GridlineType).
Pattern | LinePattern of a gridline.

See Also

Gridline Class | Aspose.Tasks.Visualization Namespace


Color Property

Gridline.Color Property

Color of a gridline.

public Color Color {get; set;}

See Also

Gridline Class | Aspose.Tasks.Visualization Namespace


GridlineType Property

Gridline.GridlineType Property

Type of gridline (GridlineType).

public GridlineType GridlineType {get; set;}

See Also

Gridline Class | Aspose.Tasks.Visualization Namespace


Pattern Property

Gridline.Pattern Property

LinePattern of a gridline.

public LinePattern Pattern {get; set;}

See Also

Gridline Class | Aspose.Tasks.Visualization Namespace


Gridline Methods

The methods of the Gridline class are listed below. For a complete list of Gridline class members, see the Gridline Members topic.

Public Instance Methods

Equals |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Gridline Class | Aspose.Tasks.Visualization Namespace


Gridline.Equals Method

public override bool Equals(
object obj
);

See Also

Gridline Class | Aspose.Tasks.Visualization Namespace


Gridlines Class

Represents gridlines that appear in a GanttChart view.

For a list of all members of this type, see Gridlines Members.

System.Object
Aspose.Tasks.Visualization.Gridlines

public class Gridlines

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Gridlines Members | Aspose.Tasks.Visualization Namespace


Gridlines Members

Gridlines overview

Public Instance Constructors

Gridlines Constructor Initializes a new instance of the Gridlines class.

Public Instance Properties

Interval | A number from 0 to 99 that specifies the interval between gridlines.
IntervalColor | The color of secondary gridlines.
IntervalPattern | The line pattern for secondary gridlines.
NormalColor | The color of normal gridlines.
NormalPattern | The line pattern for normal gridlines.
Type | The gridline type. Read/write GridlineType.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Gridlines Class | Aspose.Tasks.Visualization Namespace


Gridlines Constructor

Initializes a new instance of the Gridlines class.

public Gridlines();

See Also

Gridlines Class | Aspose.Tasks.Visualization Namespace


Gridlines Properties

The properties of the Gridlines class are listed below. For a complete list of Gridlines class members, see the Gridlines Members topic.

Public Instance Properties

Interval | A number from 0 to 99 that specifies the interval between gridlines.
IntervalColor | The color of secondary gridlines.
IntervalPattern | The line pattern for secondary gridlines.
NormalColor | The color of normal gridlines.
NormalPattern | The line pattern for normal gridlines.
Type | The gridline type. Read/write GridlineType.

See Also

Gridlines Class | Aspose.Tasks.Visualization Namespace


Interval Property

Gridlines.Interval Property

A number from 0 to 99 that specifies the interval between gridlines.

public int Interval {get; set;}

See Also

Gridlines Class | Aspose.Tasks.Visualization Namespace


IntervalColor Property

Gridlines.IntervalColor Property

The color of secondary gridlines.

public Color IntervalColor {get; set;}

See Also

Gridlines Class | Aspose.Tasks.Visualization Namespace


IntervalPattern Property

Gridlines.IntervalPattern Property

The line pattern for secondary gridlines.

public LinePattern IntervalPattern {get; set;}

See Also

Gridlines Class | Aspose.Tasks.Visualization Namespace


NormalColor Property

Gridlines.NormalColor Property

The color of normal gridlines.

public Color NormalColor {get; set;}

See Also

Gridlines Class | Aspose.Tasks.Visualization Namespace


NormalPattern Property

Gridlines.NormalPattern Property

The line pattern for normal gridlines.

public LinePattern NormalPattern {get; set;}

See Also

Gridlines Class | Aspose.Tasks.Visualization Namespace


Type Property

Gridlines.Type Property

The gridline type. Read/write GridlineType.

public GridlineType Type {get; set;}

See Also

Gridlines Class | Aspose.Tasks.Visualization Namespace


GridlineType Enumeration

Type of gridline.

public enum GridlineType

Members

Member Name | Description | Value
GanttRow | Gridline of a gantt row. | 0
TopTierColumn | Gridline of top tier column. | 1
BottomTierColumn | Gridline of bottom tier column. | 2
SheetRow | Gridline of a sheet row. | 3
SheetColumn | Gridline of a sheet column. | 4
UsageRow | Gridline of a usage row. | 5
UsageColumn | Gridline of a usage column. | 6
GanttTitleVertical | Gantt title vertical. | 7
GanttTitleHorizontal | Gantt title horizontal. | 8
BarRows | Bar rows. | 9
GanttProjectStart | Gantt project start. | 10
GanttProjectFinish | Gantt project finish. | 11
GanttStatusDate | Gantt status date. | 12
GanttCurrentDate | Gantt current date. | 13
GanttPageBreaks | Gantt page breaks. | 14

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


HtmlRenderStyles Class

Contains html rendering CSS styling information.

For a list of all members of this type, see HtmlRenderStyles Members.

System.Object
Aspose.Tasks.Visualization.HtmlRenderStyles

public class HtmlRenderStyles

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

HtmlRenderStyles Members | Aspose.Tasks.Visualization Namespace


HtmlRenderStyles Members

HtmlRenderStyles overview

Public Instance Constructors

HtmlRenderStyles Overloaded. Initializes a new instance of the HtmlRenderStyles class.

Public Instance Properties

ParentTaskStyle | Parent tasks CSS style.
TableStyle | Main table CSS style.
TaskStyle | Task's CSS style.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HtmlRenderStyles Class | Aspose.Tasks.Visualization Namespace


HtmlRenderStyles Constructor

Default public constructor.

Overload List

Default public constructor.

public HtmlRenderStyles();

Public construtor of HtmlRenderStyles.

public HtmlRenderStyles(string,string,string);

See Also

HtmlRenderStyles Class | Aspose.Tasks.Visualization Namespace


HtmlRenderStyles Constructor ()

Default public constructor.

public HtmlRenderStyles();

See Also

HtmlRenderStyles Class | Aspose.Tasks.Visualization Namespace | HtmlRenderStyles Constructor Overload List


HtmlRenderStyles Constructor (String, String, String)

Public construtor of HtmlRenderStyles.

public HtmlRenderStyles(
string tableStyle,
string taskStyle,
string parentTaskStyle
);

Parameters

tableStyle
CSS style for main table.
taskStyle
Task's CSS style.
parentTaskStyle
Parent task's CSS style.

See Also

HtmlRenderStyles Class | Aspose.Tasks.Visualization Namespace | HtmlRenderStyles Constructor Overload List


HtmlRenderStyles Properties

The properties of the HtmlRenderStyles class are listed below. For a complete list of HtmlRenderStyles class members, see the HtmlRenderStyles Members topic.

Public Instance Properties

ParentTaskStyle | Parent tasks CSS style.
TableStyle | Main table CSS style.
TaskStyle | Task's CSS style.

See Also

HtmlRenderStyles Class | Aspose.Tasks.Visualization Namespace


ParentTaskStyle Property

HtmlRenderStyles.ParentTaskStyle Property

Parent tasks CSS style.

public string ParentTaskStyle {get; set;}

See Also

HtmlRenderStyles Class | Aspose.Tasks.Visualization Namespace


TableStyle Property

HtmlRenderStyles.TableStyle Property

Main table CSS style.

public string TableStyle {get; set;}

See Also

HtmlRenderStyles Class | Aspose.Tasks.Visualization Namespace


TaskStyle Property

HtmlRenderStyles.TaskStyle Property

Task's CSS style.

public string TaskStyle {get; set;}

See Also

HtmlRenderStyles Class | Aspose.Tasks.Visualization Namespace


IHitable Interface

Root interface for all hitable objects.

For a list of all members of this type, see IHitable Members.

public interface IHitable

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

IHitable Members | Aspose.Tasks.Visualization Namespace


IHitable Members

IHitable overview

Public Instance Properties

HitableObject | Hitable object.
HitableRect | Hitable client rectangle.
HitableText | Hitable text.
HitableUID | Hitable UID string.
Result | IHitTestResult which was hit, null if not any.

Public Instance Methods

IsHit Was some object to hit.

See Also

IHitable Interface | Aspose.Tasks.Visualization Namespace


IHitable Properties

The properties of the IHitable interface are listed below. For a complete list of IHitable interface members, see the IHitable Members topic.

Public Instance Properties

HitableObject | Hitable object.
HitableRect | Hitable client rectangle.
HitableText | Hitable text.
HitableUID | Hitable UID string.
Result | IHitTestResult which was hit, null if not any.

See Also

IHitable Interface | Aspose.Tasks.Visualization Namespace


HitableObject Property

IHitable.HitableObject Property

Hitable object.

object HitableObject {get;}

See Also

IHitable Interface | Aspose.Tasks.Visualization Namespace


HitableRect Property

IHitable.HitableRect Property

Hitable client rectangle.

Rectangle HitableRect {get;}

See Also

IHitable Interface | Aspose.Tasks.Visualization Namespace


HitableText Property

IHitable.HitableText Property

Hitable text.

string HitableText {get;}

See Also

IHitable Interface | Aspose.Tasks.Visualization Namespace


HitableUID Property

IHitable.HitableUID Property

Hitable UID string.

int HitableUID {get;}

See Also

IHitable Interface | Aspose.Tasks.Visualization Namespace


Result Property

IHitable.Result Property

IHitTestResult which was hit, null if not any.

IHitTestResult Result {get;}

See Also

IHitable Interface | Aspose.Tasks.Visualization Namespace


IHitable Methods

The methods of the IHitable interface are listed below. For a complete list of IHitable interface members, see the IHitable Members topic.

Public Instance Methods

IsHit Was some object to hit.

See Also

IHitable Interface | Aspose.Tasks.Visualization Namespace


IHitable.IsHit Method

Was some object to hit.

bool IsHit(
Point point
);

Parameters

point
Hit point.

Return Value

Hit test result.

See Also

IHitable Interface | Aspose.Tasks.Visualization Namespace


IHitTestResult Interface

Returns hit testing result.

For a list of all members of this type, see IHitTestResult Members.

public interface IHitTestResult

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

IHitTestResult Members | Aspose.Tasks.Visualization Namespace


IHitTestResult Members

IHitTestResult overview

Public Instance Properties

HitObject | Object if hit, null else.
IsHit | Was something to hit.

See Also

IHitTestResult Interface | Aspose.Tasks.Visualization Namespace


IHitTestResult Properties

The properties of the IHitTestResult interface are listed below. For a complete list of IHitTestResult interface members, see the IHitTestResult Members topic.

Public Instance Properties

HitObject | Object if hit, null else.
IsHit | Was something to hit.

See Also

IHitTestResult Interface | Aspose.Tasks.Visualization Namespace


HitObject Property

IHitTestResult.HitObject Property

Object if hit, null else.

object HitObject {get;}

See Also

IHitTestResult Interface | Aspose.Tasks.Visualization Namespace


IsHit Property

IHitTestResult.IsHit Property

Was something to hit.

bool IsHit {get;}

See Also

IHitTestResult Interface | Aspose.Tasks.Visualization Namespace


Interval Enumeration

Specifies recurring intervals to display progress lines at.

public enum Interval

Members

Member Name | Description | Value
Daily | Daily. | 0
Weekly | Weekly. | 1
Monthly | Monthly. | 2

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


IRenderParam Interface

Base interface for rendering params.

For a list of all members of this type, see IRenderParam Members.

public interface IRenderParam

Types that implement IRenderParam

Type | Description
BaseHtmlRenderParam | Parameter for html rendering.
BaseImageRenderParam | Parameter for image rendering.
BaseRenderParam | Abstract default implementation of IRenderParam, base class for all rendering parameters.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

IRenderParam Members | Aspose.Tasks.Visualization Namespace


IRenderParam Members

IRenderParam overview

Public Instance Properties

EndDate | Rendering end date.
LegendOnEachPage | Show legend on each page or on the first only.
Location | Rendering start location.
Page | Page number to render.
Scale | Time rendering scale.
Size | Rendering size, Size.Empty if not used.
StartDate | Rendering start date.
Zoom | Zoom value.

See Also

IRenderParam Interface | Aspose.Tasks.Visualization Namespace


IRenderParam Properties

The properties of the IRenderParam interface are listed below. For a complete list of IRenderParam interface members, see the IRenderParam Members topic.

Public Instance Properties

EndDate | Rendering end date.
LegendOnEachPage | Show legend on each page or on the first only.
Location | Rendering start location.
Page | Page number to render.
Scale | Time rendering scale.
Size | Rendering size, Size.Empty if not used.
StartDate | Rendering start date.
Zoom | Zoom value.

See Also

IRenderParam Interface | Aspose.Tasks.Visualization Namespace


EndDate Property

IRenderParam.EndDate Property

Rendering end date.

DateTime EndDate {get; set;}

See Also

IRenderParam Interface | Aspose.Tasks.Visualization Namespace


LegendOnEachPage Property

IRenderParam.LegendOnEachPage Property

Show legend on each page or on the first only.

bool LegendOnEachPage {get; set;}

See Also

IRenderParam Interface | Aspose.Tasks.Visualization Namespace


Location Property

IRenderParam.Location Property

Rendering start location.

Point Location {get; set;}

See Also

IRenderParam Interface | Aspose.Tasks.Visualization Namespace


Page Property

IRenderParam.Page Property

Page number to render.

int Page {get; set;}

See Also

IRenderParam Interface | Aspose.Tasks.Visualization Namespace


Scale Property

IRenderParam.Scale Property

Time rendering scale.

RenderScale Scale {get; set;}

See Also

IRenderParam Interface | Aspose.Tasks.Visualization Namespace


Size Property

IRenderParam.Size Property

Rendering size, Size.Empty if not used.

Size Size {get; set;}

See Also

IRenderParam Interface | Aspose.Tasks.Visualization Namespace


StartDate Property

IRenderParam.StartDate Property

Rendering start date.

DateTime StartDate {get; set;}

See Also

IRenderParam Interface | Aspose.Tasks.Visualization Namespace


Zoom Property

IRenderParam.Zoom Property

Zoom value.

int Zoom {get; set;}

See Also

IRenderParam Interface | Aspose.Tasks.Visualization Namespace


IRenderResult Interface

Returns rendering result.

For a list of all members of this type, see IRenderResult Members.

public interface IRenderResult

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

IRenderResult Members | Aspose.Tasks.Visualization Namespace


IRenderResult Members

IRenderResult overview

Public Instance Properties

Message | Error message or empty.
NumberOfPages | Total number of pages.
PagesInHeight | Number of pages in height.
PagesInWidth | Number of pages in width.
Result | Rendering result.

See Also

IRenderResult Interface | Aspose.Tasks.Visualization Namespace


IRenderResult Properties

The properties of the IRenderResult interface are listed below. For a complete list of IRenderResult interface members, see the IRenderResult Members topic.

Public Instance Properties

Message | Error message or empty.
NumberOfPages | Total number of pages.
PagesInHeight | Number of pages in height.
PagesInWidth | Number of pages in width.
Result | Rendering result.

See Also

IRenderResult Interface | Aspose.Tasks.Visualization Namespace


Message Property

IRenderResult.Message Property

Error message or empty.

string Message {get;}

See Also

IRenderResult Interface | Aspose.Tasks.Visualization Namespace


NumberOfPages Property

IRenderResult.NumberOfPages Property

Total number of pages.

int NumberOfPages {get;}

See Also

IRenderResult Interface | Aspose.Tasks.Visualization Namespace


PagesInHeight Property

IRenderResult.PagesInHeight Property

Number of pages in height.

int PagesInHeight {get;}

See Also

IRenderResult Interface | Aspose.Tasks.Visualization Namespace


PagesInWidth Property

IRenderResult.PagesInWidth Property

Number of pages in width.

int PagesInWidth {get;}

See Also

IRenderResult Interface | Aspose.Tasks.Visualization Namespace


Result Property

IRenderResult.Result Property

Rendering result.

RenderResult Result {get;}

See Also

IRenderResult Interface | Aspose.Tasks.Visualization Namespace


LinePattern Enumeration

Line pattern.

public enum LinePattern

Members

Member Name | Description | Value
None | A line will not be shown. | 0
Solid | Solid. | 1
CloseDot | Close dot. | 3
Dotted | Dotted. | 4
Dashed | Dashed. | 2

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


PageSize Enumeration

Specifies page size.

public enum PageSize

Members

Member Name | Description | Value
Letter | 792x612 | 0
Ledger | 1224x792 | 1
A0 | 3371x2384 | 2
A1 | 2384x1685 | 3
A2 | 1684x1190 | 4
A3 | 1190x842 | 5
A4 | 842x595 | 6

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


PresentationFormat Enumeration

Enumeration for presentation format.

public enum PresentationFormat

Members

Member Name | Description | Value
GanttChart | Gantt Chart presentation format. | 0
TaskUsage | Task usage presentation format. | 1
ResourceUsage | Resource usage presentation format. | 2
ResourceSheet | Resource sheet presentation format. | 3

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


ProgressLines Class

Represents progress lines in a Gantt Chart view.

For a list of all members of this type, see ProgressLines Members.

System.Object
Aspose.Tasks.Visualization.ProgressLines

public class ProgressLines

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ProgressLines Members | Aspose.Tasks.Visualization Namespace


ProgressLines Members

ProgressLines overview

Public Instance Constructors

ProgressLines Constructor Initializes a new instance of the ProgressLines class.

Public Instance Properties

BeginAtDate | Specifies a date to display progress lines from.
BeginAtProjectStart | Determines whether to display progress lines from the beginning of the project start date.
DateFormat | Date format (DateLabel).
DisplayAtCurrentDate | Determines whether to display progress line at current date.
DisplayAtRecurringIntervals | Determines whether to display progress line at recurring intervals.
DisplaySelected | Determines whether to display progress lines at the selected dates.
Font | A font used for progress line label.
IsBaselinePlan | Determines whether to display progress lines for baseline plan or actual.
LineColor | LIne color for current progress line.
LinePattern | Line pattern of current progress line. LinePattern.
OtherLineColor | A color of other progress line.
OtherLinePattern | Line pattern for other progress line.
OtherProgressPointColor | A color of other progress point.
OtherProgressPointShape | Progress point shape of other progress line.
ProgressPointColor | A color of progress point.
ProgressPointShape | Progress point shape. GanttBarEndShape.
RecurringInterval | Recurring interval. RecurringInterval.
SelectedDates | A list of selected dates to display progress lines for. List<DateTime>
ShowDate | Determines whether to show date for each progress line.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


ProgressLines Constructor

Initializes a new instance of the ProgressLines class.

public ProgressLines();

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


ProgressLines Properties

The properties of the ProgressLines class are listed below. For a complete list of ProgressLines class members, see the ProgressLines Members topic.

Public Instance Properties

BeginAtDate | Specifies a date to display progress lines from.
BeginAtProjectStart | Determines whether to display progress lines from the beginning of the project start date.
DateFormat | Date format (DateLabel).
DisplayAtCurrentDate | Determines whether to display progress line at current date.
DisplayAtRecurringIntervals | Determines whether to display progress line at recurring intervals.
DisplaySelected | Determines whether to display progress lines at the selected dates.
Font | A font used for progress line label.
IsBaselinePlan | Determines whether to display progress lines for baseline plan or actual.
LineColor | LIne color for current progress line.
LinePattern | Line pattern of current progress line. LinePattern.
OtherLineColor | A color of other progress line.
OtherLinePattern | Line pattern for other progress line.
OtherProgressPointColor | A color of other progress point.
OtherProgressPointShape | Progress point shape of other progress line.
ProgressPointColor | A color of progress point.
ProgressPointShape | Progress point shape. GanttBarEndShape.
RecurringInterval | Recurring interval. RecurringInterval.
SelectedDates | A list of selected dates to display progress lines for. List<DateTime>
ShowDate | Determines whether to show date for each progress line.

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


BeginAtDate Property

ProgressLines.BeginAtDate Property

Specifies a date to display progress lines from.

public DateTime BeginAtDate {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


BeginAtProjectStart Property

ProgressLines.BeginAtProjectStart Property

Determines whether to display progress lines from the beginning of the project start date.

public bool BeginAtProjectStart {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


DateFormat Property

ProgressLines.DateFormat Property

Date format (DateLabel).

public DateLabel DateFormat {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


DisplayAtCurrentDate Property

ProgressLines.DisplayAtCurrentDate Property

Determines whether to display progress line at current date.

public bool DisplayAtCurrentDate {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


DisplayAtRecurringIntervals Property

ProgressLines.DisplayAtRecurringIntervals Property

Determines whether to display progress line at recurring intervals.

public bool DisplayAtRecurringIntervals {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


DisplaySelected Property

ProgressLines.DisplaySelected Property

Determines whether to display progress lines at the selected dates.

public bool DisplaySelected {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


Font Property

ProgressLines.Font Property

A font used for progress line label.

public Font Font {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


IsBaselinePlan Property

ProgressLines.IsBaselinePlan Property

Determines whether to display progress lines for baseline plan or actual.

public bool IsBaselinePlan {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


LineColor Property

ProgressLines.LineColor Property

LIne color for current progress line.

public Color LineColor {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


LinePattern Property

ProgressLines.LinePattern Property

Line pattern of current progress line. LinePattern.

public LinePattern LinePattern {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


OtherLineColor Property

ProgressLines.OtherLineColor Property

A color of other progress line.

public Color OtherLineColor {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


OtherLinePattern Property

ProgressLines.OtherLinePattern Property

Line pattern for other progress line.

public LinePattern OtherLinePattern {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


OtherProgressPointColor Property

ProgressLines.OtherProgressPointColor Property

A color of other progress point.

public Color OtherProgressPointColor {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


OtherProgressPointShape Property

ProgressLines.OtherProgressPointShape Property

Progress point shape of other progress line.

public GanttBarEndShape OtherProgressPointShape {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


ProgressPointColor Property

ProgressLines.ProgressPointColor Property

A color of progress point.

public Color ProgressPointColor {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


ProgressPointShape Property

ProgressLines.ProgressPointShape Property

Progress point shape. GanttBarEndShape.

public GanttBarEndShape ProgressPointShape {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


RecurringInterval Property

ProgressLines.RecurringInterval Property

Recurring interval. RecurringInterval.

public RecurringInterval RecurringInterval {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


SelectedDates Property

ProgressLines.SelectedDates Property

A list of selected dates to display progress lines for. List<DateTime>

public DateTime} SelectedDates {get;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


ShowDate Property

ProgressLines.ShowDate Property

Determines whether to show date for each progress line.

public bool ShowDate {get; set;}

See Also

ProgressLines Class | Aspose.Tasks.Visualization Namespace


ProjectView Class

Project's view class

For a list of all members of this type, see ProjectView Members.

System.Object
Aspose.Tasks.Visualization.ProjectView

public class ProjectView

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ProjectView Members | Aspose.Tasks.Visualization Namespace


ProjectView Members

ProjectView overview

Public Static Methods

GetDefaultAssignmentView | Includes Uid, task name, resource name, work and duration assignment columns.
GetDefaultGanttChartView | Includes id, name, duration, start and finish task columns.
GetDefaultResourceSheetView | Includes Uid, resource name, type, material label, initials, group, max units, standard rate, overtime rate, cost per use, accrue at, base calendar and code resource columns.
GetDefaultResourceUsageView | Includes Uid, name, start, finish and work resource columns.

Public Instance Constructors

ProjectView Constructor ProjectView public constructor.

Public Instance Properties

Columns The project view columns.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectView Class | Aspose.Tasks.Visualization Namespace


ProjectView Constructor

ProjectView public constructor.

public ProjectView(
ArrayList columns
);

Parameters

columns
A list of the view columns.

See Also

ProjectView Class | Aspose.Tasks.Visualization Namespace


ProjectView Properties

The properties of the ProjectView class are listed below. For a complete list of ProjectView class members, see the ProjectView Members topic.

Public Instance Properties

Columns The project view columns.

See Also

ProjectView Class | Aspose.Tasks.Visualization Namespace


Columns Property

ProjectView.Columns Property

The project view columns.

public ArrayList Columns {get;}

See Also

ProjectView Class | Aspose.Tasks.Visualization Namespace


ProjectView Methods

The methods of the ProjectView class are listed below. For a complete list of ProjectView class members, see the ProjectView Members topic.

Public Static Methods

GetDefaultAssignmentView | Includes Uid, task name, resource name, work and duration assignment columns.
GetDefaultGanttChartView | Includes id, name, duration, start and finish task columns.
GetDefaultResourceSheetView | Includes Uid, resource name, type, material label, initials, group, max units, standard rate, overtime rate, cost per use, accrue at, base calendar and code resource columns.
GetDefaultResourceUsageView | Includes Uid, name, start, finish and work resource columns.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectView Class | Aspose.Tasks.Visualization Namespace


ProjectView.GetDefaultAssignmentView Method

Includes Uid, task name, resource name, work and duration assignment columns.

public static ProjectView GetDefaultAssignmentView();

Return Value

ArrayList of AssignmentViewColumn.

See Also

ProjectView Class | Aspose.Tasks.Visualization Namespace


ProjectView.GetDefaultGanttChartView Method

Includes id, name, duration, start and finish task columns.

public static ProjectView GetDefaultGanttChartView();

Return Value

ArrayList of GanttChartColumn.

See Also

ProjectView Class | Aspose.Tasks.Visualization Namespace


ProjectView.GetDefaultResourceSheetView Method

Includes Uid, resource name, type, material label, initials, group, max units, standard rate, overtime rate, cost per use, accrue at, base calendar and code resource columns.

public static ProjectView GetDefaultResourceSheetView();

Return Value

ArrayList of ResourceViewColumn.

See Also

ProjectView Class | Aspose.Tasks.Visualization Namespace


ProjectView.GetDefaultResourceUsageView Method

Includes Uid, name, start, finish and work resource columns.

public static ProjectView GetDefaultResourceUsageView();

Return Value

ArrayList of ResourceViewColumn.

See Also

ProjectView Class | Aspose.Tasks.Visualization Namespace


RecurringInterval Class

Represents recurring intervals used in progress lines of a Gantt Chart view.

For a list of all members of this type, see RecurringInterval Members.

System.Object
Aspose.Tasks.Visualization.RecurringInterval

public class RecurringInterval

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

RecurringInterval Members | Aspose.Tasks.Visualization Namespace


RecurringInterval Members

RecurringInterval overview

Public Instance Constructors

RecurringInterval Constructor Initializes a new instance of the RecurringInterval class.

Public Instance Properties

DailyDayNumber | Daily day number.
DailyWorkday | Determines whether a day is workday for daily progress lines.
Interval | Recurring interval. Can be any value of Interval type.
MonthlyDay | Determines whether to show monthly progress lines by day.
MonthlyDayDayNumber | Day number of monthly progress lines.
MonthlyDayMonthNumber | Month number of monthly progress lines.
MonthlyFirstLast | Determines whether to show progress lines by first or last predefined day.
MonthlyFirstLastDay | Specified first or last day type of monthly progress lines.
MonthlyFirstLastMonthNumber | Month number of progress lines, which are shown by first or last predefined day.
WeeklyDays | A list of days for weekly progress lines.
WeeklyWeekNumber | Week number for weekly progress lines.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


RecurringInterval Constructor

Initializes a new instance of the RecurringInterval class.

public RecurringInterval();

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


RecurringInterval Properties

The properties of the RecurringInterval class are listed below. For a complete list of RecurringInterval class members, see the RecurringInterval Members topic.

Public Instance Properties

DailyDayNumber | Daily day number.
DailyWorkday | Determines whether a day is workday for daily progress lines.
Interval | Recurring interval. Can be any value of Interval type.
MonthlyDay | Determines whether to show monthly progress lines by day.
MonthlyDayDayNumber | Day number of monthly progress lines.
MonthlyDayMonthNumber | Month number of monthly progress lines.
MonthlyFirstLast | Determines whether to show progress lines by first or last predefined day.
MonthlyFirstLastDay | Specified first or last day type of monthly progress lines.
MonthlyFirstLastMonthNumber | Month number of progress lines, which are shown by first or last predefined day.
WeeklyDays | A list of days for weekly progress lines.
WeeklyWeekNumber | Week number for weekly progress lines.

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


DailyDayNumber Property

RecurringInterval.DailyDayNumber Property

Daily day number.

public int DailyDayNumber {get; set;}

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


DailyWorkday Property

RecurringInterval.DailyWorkday Property

Determines whether a day is workday for daily progress lines.

public bool DailyWorkday {get; set;}

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


Interval Property

RecurringInterval.Interval Property

Recurring interval. Can be any value of Interval type.

public Interval Interval {get; set;}

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


MonthlyDay Property

RecurringInterval.MonthlyDay Property

Determines whether to show monthly progress lines by day.

public bool MonthlyDay {get; set;}

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


MonthlyDayDayNumber Property

RecurringInterval.MonthlyDayDayNumber Property

Day number of monthly progress lines.

public int MonthlyDayDayNumber {get; set;}

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


MonthlyDayMonthNumber Property

RecurringInterval.MonthlyDayMonthNumber Property

Month number of monthly progress lines.

public int MonthlyDayMonthNumber {get; set;}

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


MonthlyFirstLast Property

RecurringInterval.MonthlyFirstLast Property

Determines whether to show progress lines by first or last predefined day.

public bool MonthlyFirstLast {get; set;}

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


MonthlyFirstLastDay Property

RecurringInterval.MonthlyFirstLastDay Property

Specified first or last day type of monthly progress lines.

public DayType MonthlyFirstLastDay {get; set;}

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


MonthlyFirstLastMonthNumber Property

RecurringInterval.MonthlyFirstLastMonthNumber Property

Month number of progress lines, which are shown by first or last predefined day.

public int MonthlyFirstLastMonthNumber {get; set;}

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


WeeklyDays Property

RecurringInterval.WeeklyDays Property

A list of days for weekly progress lines.

public DayType} WeeklyDays {get;}

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


WeeklyWeekNumber Property

RecurringInterval.WeeklyWeekNumber Property

Week number for weekly progress lines.

public int WeeklyWeekNumber {get; set;}

See Also

RecurringInterval Class | Aspose.Tasks.Visualization Namespace


RecurringInterval.DayType Enumeration

public enum RecurringInterval.DayType

Members

Member Name | Description | Value
Sunday |  | 1
Monday |  | 2
Tuesday |  | 3
Wednesday |  | 4
Thursday |  | 5
Friday |  | 6
Saturday |  | 7
Day |  | 8
Workday |  | 9
NonworkingDay |  | 10

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


RenderFormat Enumeration

Enumeration for different render formats.

public enum RenderFormat

Members

Member Name | Description | Value
Image | Render to image. | 0
Html | Render to HTML. | 1

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


RenderResult Enumeration

Enumeration for render results.

public enum RenderResult

Members

Member Name | Description | Value
OK | OK result. | 0
Failure | Failure result, read message for detail. | 1

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


RenderScale Enumeration

Enumeration for rendering period scaling.

public enum RenderScale

Members

Member Name | Description | Value
Default | Default time rendering scale. | 0
Week | Show one week per page in width. | 1
CoupleOfWeeks | Show two weeks per page in width. | 2
Month | Show one month per page in width. | 3
Project | Put all project in one page in width. | 4

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


ReportType Enumeration

Type of the project's graphical report.

public enum ReportType

Members

Member Name | Description | Value
ProjectOverview | Shows the project’s start and finish date, percentage of duration that’s complete, percentage complete for top-level tasks and coming up milestones. | 0
CostOverview | Shows the project’s start and finish dates, the current scheduled and remaining cost, % Complete and cost values for top-level tasks. | 1
WorkOverview | Shows baseline, actual, remaining work for each top-level task and work for work resources. | 2
ResourceOverview | Shows baseline, actual, and remaining work by resource. | 3
ResourceCostOverview | Shows baseline, actual, and remaining cost by resource. | 4
CriticalTasks | Shows project tasks that are critical. | 5
LateTasks | Shows project tasks that are late. | 6
Milestones | Shows milestones that are late, coming up and completed. | 7
UpcomingTask | Shows tasks that are due during the current week and tasks starting during current week. | 8
CostOverruns | Shows cost variance by task and resource. | 9
TaskCostOverview | Shows baseline, actual, and remaining cost of all top-level tasks. | 10
OverallocatedResources | Shows the number of remaining work hours for overallocated resources. | 11
SlippingTasks | Shows tasks that are due to finish after their baseline finish dates (baseline must be set). | 12
BestPracticeAnalyzer | Shows tasks with no actual work, not assigned tasks, tasks with duration less than 8 hours and summaries assigned with the resources. | 13
Burndown | Includes work burndown and task burndown charts. The work burndown chart shows how much work people have finished, how much is scheduled to be finished before the project finish date, and the baseline estimate of how much work would be completed at this point in the project. The task burndown chart shows the number of tasks finished, the number remaining, and the baseline estimate of how many would be finished at this point in the project. | 14
CashFlow | Shows the costs and cumulative costs per quarter for all top-level tasks. | 15

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


ResourceToColumnTextConverter Delegate

Resource's data to column's string converter.

public delegate string ResourceToColumnTextConverter(
Resource resource
);

Parameters

resource
Current resource.

Return Value

String data for the column.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


ResourceViewColumn Class

Project's view class used in ResourceUsage view and ResourceSheet view.

For a list of all members of this type, see ResourceViewColumn Members.

System.Object
Aspose.Tasks.Visualization.ResourceViewColumn

public class ResourceViewColumn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

ResourceViewColumn Members | Aspose.Tasks.Visualization Namespace


ResourceViewColumn Members

ResourceViewColumn overview

Public Instance Constructors

ResourceViewColumn Constructor Public ResourceViewColumn constructor.

Public Instance Properties

Name | The column name.
StringAlignment | StringAlignment of the text.
Width | The column width.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnText | Converts current resource to the column text.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceViewColumn Class | Aspose.Tasks.Visualization Namespace


ResourceViewColumn Constructor

Public ResourceViewColumn constructor.

public ResourceViewColumn(
string name,
int width,
ResourceToColumnTextConverter converter
);

Parameters

name
Column's name.
width
Column's width in pixels.
converter
Resource data to column text converter.

See Also

ResourceViewColumn Class | Aspose.Tasks.Visualization Namespace


ResourceViewColumn Properties

The properties of the ResourceViewColumn class are listed below. For a complete list of ResourceViewColumn class members, see the ResourceViewColumn Members topic.

Public Instance Properties

Name | The column name.
StringAlignment | StringAlignment of the text.
Width | The column width.

See Also

ResourceViewColumn Class | Aspose.Tasks.Visualization Namespace


Name Property

ResourceViewColumn.Name Property

The column name.

public string Name {get;}

See Also

ResourceViewColumn Class | Aspose.Tasks.Visualization Namespace


StringAlignment Property

ResourceViewColumn.StringAlignment Property

StringAlignment of the text.

public StringAlignment StringAlignment {get; set;}

See Also

ResourceViewColumn Class | Aspose.Tasks.Visualization Namespace


Width Property

ResourceViewColumn.Width Property

The column width.

public int Width {get;}

See Also

ResourceViewColumn Class | Aspose.Tasks.Visualization Namespace


ResourceViewColumn Methods

The methods of the ResourceViewColumn class are listed below. For a complete list of ResourceViewColumn class members, see the ResourceViewColumn Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnText | Converts current resource to the column text.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceViewColumn Class | Aspose.Tasks.Visualization Namespace


ResourceViewColumn.GetColumnText Method

Converts current resource to the column text.

public string GetColumnText(
Resource resource
);

Parameters

resource
Current resource.

Return Value

The column text.

See Also

ResourceViewColumn Class | Aspose.Tasks.Visualization Namespace


Shape Enumeration

Shape of a marker at the beginning or end of the bar style to be rendered when saving view data to some of SaveFileFormat.

public enum Shape

Members

Member Name | Description | Value
None | None. | 0
VerticalLine | Vertical line. | 1
Pentagon | Pentagon. | 2
Triangle | Triangle. | 3
LeftBracket | Left bracket. | 4
RightBracket | Right bracket. | 5

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


TableTextStyle Class

Represents a text style in a view table.

For a list of all members of this type, see TableTextStyle Members.

System.Object
Aspose.Tasks.Visualization.TextStyle
Aspose.Tasks.Visualization.TableTextStyle

public class TableTextStyle : TextStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

TableTextStyle Members | Aspose.Tasks.Visualization Namespace


TableTextStyle Members

TableTextStyle overview

Public Instance Constructors

TableTextStyle Constructor Constructor.

Public Instance Properties

BackgroundColor (inherited from TextStyle) | Gets or sets background color of the text style. Color.
BackgroundPattern (inherited from TextStyle) | Gets or sets background pattern of the text style. BackgroundPattern.
Color (inherited from TextStyle) | Color of the text.
Field | A field the style is to be applied to. Field.
FontFamily (inherited from TextStyle) | FontFamily of the text style.
FontStyle (inherited from TextStyle) | FontStyle of the text style font.
ItemType |
RowUid | A row unique id. Return -1 if the style is to be applied to all rows of a view.
SizeInPoints (inherited from TextStyle) | Size in points of the text style font.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TableTextStyle Class | Aspose.Tasks.Visualization Namespace


TableTextStyle Constructor

Constructor.

public TableTextStyle(
int rowUid
);

See Also

TableTextStyle Class | Aspose.Tasks.Visualization Namespace


TableTextStyle Properties

The properties of the TableTextStyle class are listed below. For a complete list of TableTextStyle class members, see the TableTextStyle Members topic.

Public Instance Properties

BackgroundColor (inherited from TextStyle) | Gets or sets background color of the text style. Color.
BackgroundPattern (inherited from TextStyle) | Gets or sets background pattern of the text style. BackgroundPattern.
Color (inherited from TextStyle) | Color of the text.
Field | A field the style is to be applied to. Field.
FontFamily (inherited from TextStyle) | FontFamily of the text style.
FontStyle (inherited from TextStyle) | FontStyle of the text style font.
ItemType |
RowUid | A row unique id. Return -1 if the style is to be applied to all rows of a view.
SizeInPoints (inherited from TextStyle) | Size in points of the text style font.

See Also

TableTextStyle Class | Aspose.Tasks.Visualization Namespace


Field Property

TableTextStyle.Field Property

A field the style is to be applied to. Field.

public Field Field {get; set;}

See Also

TableTextStyle Class | Aspose.Tasks.Visualization Namespace


ItemType Property

TableTextStyle.ItemType Property

public override TextItemType ItemType {get;}

See Also

TableTextStyle Class | Aspose.Tasks.Visualization Namespace


RowUid Property

TableTextStyle.RowUid Property

A row unique id. Return -1 if the style is to be applied to all rows of a view.

public int RowUid {get; set;}

See Also

TableTextStyle Class | Aspose.Tasks.Visualization Namespace


TaskToColumnTextConverter Delegate

Task's data to column's string converter.

public delegate string TaskToColumnTextConverter(
Task task
);

Parameters

task
Current task.

Return Value

String data for the column.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


TextItemType Enumeration

Item type to change a text style for.

public enum TextItemType

Members

Member Name | Description | Value
RowColumnTitles | Row and column titles. | 0
CriticalTasks | Critical tasks. | 1
NoncriticalTasks | Noncritical tasks. | 2
MilestoneTasks | Milestone tasks. | 3
InactiveTasks | Inactive tasks. | 4
SummaryTasks | Summary tasks. | 5
AssignmentRow | Assignment row. | 6
TopTimescaleTier | Top timescale tier. | 7
BottomTimescaleTier | Bottom timescale tier. | 8
MiddleTimescaleTier | Midlle timescale tier. | 9
Resources | Resource sheet. | 10
TaskFilterHighlight | Task Filter Highlight text item. | 11
BarTextBottom | Bar Text Bottom text item. | 12
BarTextInside | Bar Text Inside text item. | 13
BarTextLeft | Bar Text Left text item. | 14
BarTextRight | Bar Text Right text item. | 15
BarTextTop | Bar Text Top text item. | 16
MarkedTasks | Marked task text item. | 17
ProjectSummary | Project summary task text item. | 18
ExternalTasks | External tasks text item. | 19
Allocated | Allocated text item. | 20

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


TextStyle Class

Change the visual style of the text for an item in the project view.

For a list of all members of this type, see TextStyle Members.

System.Object
Aspose.Tasks.Visualization.TextStyle
Aspose.Tasks.Visualization.TableTextStyle

public class TextStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

TextStyle Members | Aspose.Tasks.Visualization Namespace


TextStyle Members

TextStyle overview

Public Instance Constructors

TextStyle Constructor Initializes a new instance of the TextStyle class.

Public Instance Properties

BackgroundColor | Gets or sets background color of the text style. Color.
BackgroundPattern | Gets or sets background pattern of the text style. BackgroundPattern.
Color | Color of the text.
FontFamily | FontFamily of the text style.
FontStyle | FontStyle of the text style font.
ItemType | TextItemType of the text style.
SizeInPoints | Size in points of the text style font.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextStyle Class | Aspose.Tasks.Visualization Namespace


TextStyle Constructor

Initializes a new instance of the TextStyle class.

public TextStyle();

See Also

TextStyle Class | Aspose.Tasks.Visualization Namespace


TextStyle Properties

The properties of the TextStyle class are listed below. For a complete list of TextStyle class members, see the TextStyle Members topic.

Public Instance Properties

BackgroundColor | Gets or sets background color of the text style. Color.
BackgroundPattern | Gets or sets background pattern of the text style. BackgroundPattern.
Color | Color of the text.
FontFamily | FontFamily of the text style.
FontStyle | FontStyle of the text style font.
ItemType | TextItemType of the text style.
SizeInPoints | Size in points of the text style font.

See Also

TextStyle Class | Aspose.Tasks.Visualization Namespace


BackgroundColor Property

TextStyle.BackgroundColor Property

Gets or sets background color of the text style. Color.

public Color BackgroundColor {get; set;}

See Also

TextStyle Class | Aspose.Tasks.Visualization Namespace


BackgroundPattern Property

TextStyle.BackgroundPattern Property

Gets or sets background pattern of the text style. BackgroundPattern.

public BackgroundPattern BackgroundPattern {get; set;}

See Also

TextStyle Class | Aspose.Tasks.Visualization Namespace


Color Property

TextStyle.Color Property

Color of the text.

public Color Color {get; set;}

See Also

TextStyle Class | Aspose.Tasks.Visualization Namespace


FontFamily Property

TextStyle.FontFamily Property

FontFamily of the text style.

public FontFamily FontFamily {get; set;}

See Also

TextStyle Class | Aspose.Tasks.Visualization Namespace


FontStyle Property

TextStyle.FontStyle Property

FontStyle of the text style font.

public FontStyle FontStyle {get; set;}

See Also

TextStyle Class | Aspose.Tasks.Visualization Namespace


ItemType Property

TextStyle.ItemType Property

TextItemType of the text style.

public virtual TextItemType ItemType {get; set;}

See Also

TextStyle Class | Aspose.Tasks.Visualization Namespace


SizeInPoints Property

TextStyle.SizeInPoints Property

Size in points of the text style font.

public float SizeInPoints {get; set;}

See Also

TextStyle Class | Aspose.Tasks.Visualization Namespace


Timescale Enumeration

The minimal time period to render when saving project view data to some of SaveFileFormat.

public enum Timescale

Members

Member Name | Description | Value
Days | Minimal level of detail is one day. | 1
ThirdsOfMonths | Minimal level of detail is one third of month. | 10
Months | Minimal level of detail is one month. | 30

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


TimescaleTier Class

Represents a single tier of the timescale on a Gantt Chart.

For a list of all members of this type, see TimescaleTier Members.

System.Object
Aspose.Tasks.Visualization.TimescaleTier

public class TimescaleTier

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

TimescaleTier Members | Aspose.Tasks.Visualization Namespace


TimescaleTier Members

TimescaleTier overview

Public Instance Constructors

TimescaleTier Constructor Initializes a new instance of the TimescaleTier class.

Public Instance Properties

Alignment | Specifies how to align labels within each time period of the tier (StringAlignment).
Count | Specifies the time unit interval in which to show labels for the tier.
Label | Date label for the timescale tier (DateLabel).
ShowTicks | Specifies whether to show tick marks that separate time periods in the tier.
Unit | Timescale unit for the timescale tier (TimescaleUnit).
UsesFiscalYear | Specifies whether to base the tier labels on the fiscal year.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimescaleTier Class | Aspose.Tasks.Visualization Namespace


TimescaleTier Constructor

Initializes a new instance of the TimescaleTier class.

public TimescaleTier();

See Also

TimescaleTier Class | Aspose.Tasks.Visualization Namespace


TimescaleTier Properties

The properties of the TimescaleTier class are listed below. For a complete list of TimescaleTier class members, see the TimescaleTier Members topic.

Public Instance Properties

Alignment | Specifies how to align labels within each time period of the tier (StringAlignment).
Count | Specifies the time unit interval in which to show labels for the tier.
Label | Date label for the timescale tier (DateLabel).
ShowTicks | Specifies whether to show tick marks that separate time periods in the tier.
Unit | Timescale unit for the timescale tier (TimescaleUnit).
UsesFiscalYear | Specifies whether to base the tier labels on the fiscal year.

See Also

TimescaleTier Class | Aspose.Tasks.Visualization Namespace


Alignment Property

TimescaleTier.Alignment Property

Specifies how to align labels within each time period of the tier (StringAlignment).

public StringAlignment Alignment {get; set;}

See Also

TimescaleTier Class | Aspose.Tasks.Visualization Namespace


Count Property

TimescaleTier.Count Property

Specifies the time unit interval in which to show labels for the tier.

public int Count {get; set;}

See Also

TimescaleTier Class | Aspose.Tasks.Visualization Namespace


Label Property

TimescaleTier.Label Property

Date label for the timescale tier (DateLabel).

public DateLabel Label {get; set;}

See Also

TimescaleTier Class | Aspose.Tasks.Visualization Namespace


ShowTicks Property

TimescaleTier.ShowTicks Property

Specifies whether to show tick marks that separate time periods in the tier.

public bool ShowTicks {get; set;}

See Also

TimescaleTier Class | Aspose.Tasks.Visualization Namespace


Unit Property

TimescaleTier.Unit Property

Timescale unit for the timescale tier (TimescaleUnit).

public TimescaleUnit Unit {get; set;}

See Also

TimescaleTier Class | Aspose.Tasks.Visualization Namespace


UsesFiscalYear Property

TimescaleTier.UsesFiscalYear Property

Specifies whether to base the tier labels on the fiscal year.

public bool UsesFiscalYear {get; set;}

See Also

TimescaleTier Class | Aspose.Tasks.Visualization Namespace


TimescaleUnit Enumeration

Specifies the unit of time for any tier of a timescale in a Gantt chart or other timephased view.

public enum TimescaleUnit

Members

Member Name | Description | Value
None | None. The timescale tier uses the default unit. | -1
Minutes | Minutes | 0
Hours | Hours. | 1
Days | Days. | 2
Weeks | Weeks. | 3
ThirdsOfMonths | Thirds of months. | 4
Months | Months. | 5
Quarters | Quarters of years. | 6
HalfYears | Half years. | 7
Years | Years. | 8

Requirements

Namespace: Aspose.Tasks.Visualization

Assembly: Aspose.Tasks (in Aspose.Tasks.dll)

See Also

Aspose.Tasks.Visualization Namespace


SaveOptions Hierarchy

System.Object
SaveOptions
CsvOptions
ImageSaveOptions
PdfSaveOptions
PrimaveraSaveOptions
PrintOptions
Spreadsheet2003SaveOptions
SvgOptions
XamlOptions
XlsxOptions
XpsOptions

See Also

SaveOptions Class | SaveOptions Members | Aspose.Tasks.Saving Namespace


Aspose.Tasks.SavingHierarchy

Aspose.Tasks.Saving Hierarchy

System.Object
Aspose.Tasks.Saving.PdfDigitalSignatureDetails
Aspose.Tasks.Saving.PdfEncryptionDetails
Aspose.Tasks.Saving.SaveOptions
Aspose.Tasks.Saving.CsvOptions
Aspose.Tasks.Saving.ImageSaveOptions
Aspose.Tasks.Saving.PdfSaveOptions
Aspose.Tasks.Saving.PrimaveraSaveOptions
Aspose.Tasks.Saving.PrintOptions
Aspose.Tasks.Saving.Spreadsheet2003SaveOptions
Aspose.Tasks.Saving.SvgOptions
Aspose.Tasks.Saving.XamlOptions
Aspose.Tasks.Saving.XlsxOptions
Aspose.Tasks.Saving.XpsOptions
Aspose.Tasks.Saving.SaveTemplateOptions
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Tasks.Saving.CsvTextDelimiter
Aspose.Tasks.Saving.DataCategory
Aspose.Tasks.Saving.PdfCompliance
Aspose.Tasks.Saving.PdfDigitalSignatureHashAlgorithm
Aspose.Tasks.Saving.PdfEncryptionAlgorithm
Aspose.Tasks.Saving.PdfPermissions
Aspose.Tasks.Saving.PdfTextCompression
Aspose.Tasks.Saving.SaveFileFormat
Aspose.Tasks.Saving.TiffCompression

See Also

Aspose.Tasks.Saving Namespace


Aspose.Tasks.UtilHierarchy

Aspose.Tasks.Util Hierarchy

System.Object
Aspose.Tasks.Util.And ---- Aspose.Tasks.Util.ICondition
Aspose.Tasks.Util.AndAllCondition ---- Aspose.Tasks.Util.ICondition
Aspose.Tasks.Util.ArrayUtils
Aspose.Tasks.Util.CheckCircuit ---- Aspose.Tasks.Util.ITreeAlgorithm
Aspose.Tasks.Util.ChildTasksCollector ---- Aspose.Tasks.Util.ITreeAlgorithm
Aspose.Tasks.Util.FilterCriticalTasks ---- Aspose.Tasks.Util.ICondition
Aspose.Tasks.Util.FilterResourceAssignByResource ---- Aspose.Tasks.Util.ICondition
Aspose.Tasks.Util.FilterResourceAssignByTask ---- Aspose.Tasks.Util.ICondition
Aspose.Tasks.Util.IAlgorithm
Aspose.Tasks.Util.ICondition
Aspose.Tasks.Util.ITreeAlgorithm
Aspose.Tasks.Util.Not ---- Aspose.Tasks.Util.ICondition
Aspose.Tasks.Util.RemoveTask ---- Aspose.Tasks.Util.ITreeAlgorithm
Aspose.Tasks.Util.TaskUtils

See Also

Aspose.Tasks.Util Namespace


Aspose.Tasks.VisualizationHierarchy

Aspose.Tasks.Visualization Hierarchy

System.Object
Aspose.Tasks.Visualization.AssignmentViewColumn
Aspose.Tasks.Visualization.BarStyle
Aspose.Tasks.Visualization.BaseRenderParam ---- Aspose.Tasks.Visualization.IRenderParam
Aspose.Tasks.Visualization.BaseHtmlRenderParam
Aspose.Tasks.Visualization.BaseImageRenderParam
Aspose.Tasks.Visualization.GanttBarStyle
Aspose.Tasks.Visualization.GanttChartColumn
Aspose.Tasks.Visualization.Gridline
Aspose.Tasks.Visualization.Gridlines
Aspose.Tasks.Visualization.HtmlRenderStyles
Aspose.Tasks.Visualization.IHitable
Aspose.Tasks.Visualization.IHitTestResult
Aspose.Tasks.Visualization.IRenderParam
Aspose.Tasks.Visualization.IRenderResult
Aspose.Tasks.Visualization.ProgressLines
Aspose.Tasks.Visualization.ProjectView
Aspose.Tasks.Visualization.RecurringInterval
Aspose.Tasks.Visualization.ResourceViewColumn
Aspose.Tasks.Visualization.TextStyle
Aspose.Tasks.Visualization.TableTextStyle
Aspose.Tasks.Visualization.TimescaleTier
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aspose.Tasks.Visualization.AssignmentToColumnTextConverter
Aspose.Tasks.Visualization.BarStyle.TaskToBarTextConverter
Aspose.Tasks.Visualization.ResourceToColumnTextConverter
Aspose.Tasks.Visualization.TaskToColumnTextConverter
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Tasks.Visualization.BarItemType
Aspose.Tasks.Visualization.BarShape
Aspose.Tasks.Visualization.DateLabel
Aspose.Tasks.Visualization.GanttBarEndShape
Aspose.Tasks.Visualization.GanttBarFillPattern
Aspose.Tasks.Visualization.GanttBarMiddleShape
Aspose.Tasks.Visualization.GanttBarType
Aspose.Tasks.Visualization.GridlineType
Aspose.Tasks.Visualization.Interval
Aspose.Tasks.Visualization.LinePattern
Aspose.Tasks.Visualization.PageSize
Aspose.Tasks.Visualization.PresentationFormat
Aspose.Tasks.Visualization.RecurringInterval.DayType
Aspose.Tasks.Visualization.RenderFormat
Aspose.Tasks.Visualization.RenderResult
Aspose.Tasks.Visualization.RenderScale
Aspose.Tasks.Visualization.ReportType
Aspose.Tasks.Visualization.Shape
Aspose.Tasks.Visualization.TextItemType
Aspose.Tasks.Visualization.Timescale
Aspose.Tasks.Visualization.TimescaleUnit

See Also

Aspose.Tasks.Visualization Namespace


Aspose.TasksHierarchy

Aspose.Tasks Hierarchy

System.Object
Aspose.Tasks.AvailabilityPeriod
Aspose.Tasks.Baseline ---- System.IComparable
Aspose.Tasks.AssignmentBaseline
Aspose.Tasks.TaskBaseline
Aspose.Tasks.BuildVersionInfo
Aspose.Tasks.Calendar
Aspose.Tasks.CalendarException
Aspose.Tasks.ExtendedAttribute
Aspose.Tasks.ExtendedAttributeDefinition
Aspose.Tasks.Filter
Aspose.Tasks.FilterCriteria
Aspose.Tasks.Filters ---- System.Collections.Generic.ICollection`1[[Aspose.Tasks.Filter, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[Aspose.Tasks.Filter, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Tasks.Group
Aspose.Tasks.GroupCriteria ---- System.Collections.Generic.ICollection`1[[Aspose.Tasks.GroupCriterion, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[Aspose.Tasks.GroupCriterion, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Tasks.GroupCriterion
Aspose.Tasks.Groups ---- System.Collections.Generic.ICollection`1[[Aspose.Tasks.Group, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[Aspose.Tasks.Group, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Tasks.License
Aspose.Tasks.OutlineCode
Aspose.Tasks.OutlineCodeDefinition
Aspose.Tasks.OutlineMask
Aspose.Tasks.OutlineValue
Aspose.Tasks.Project
Aspose.Tasks.ProjectFileInfo
Aspose.Tasks.ProjectReader
Aspose.Tasks.ProjectWriter
Aspose.Tasks.Rate
Aspose.Tasks.Resource
Aspose.Tasks.ResourceAssignment
Aspose.Tasks.SplitPart
Aspose.Tasks.SplitPartCollection ---- System.Collections.IEnumerable
Aspose.Tasks.Table
Aspose.Tasks.TableField
Aspose.Tasks.TableFields ---- System.Collections.Generic.ICollection`1[[Aspose.Tasks.TableField, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[Aspose.Tasks.TableField, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IList`1[[Aspose.Tasks.TableField, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Tasks.Tables ---- System.Collections.Generic.ICollection`1[[Aspose.Tasks.Table, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[Aspose.Tasks.Table, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Tasks.Task
Aspose.Tasks.TaskLink
Aspose.Tasks.TimephasedData
Aspose.Tasks.Value
Aspose.Tasks.View
Aspose.Tasks.GanttChartView
Aspose.Tasks.Views ---- System.Collections.Generic.ICollection`1[[Aspose.Tasks.View, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.Generic.IEnumerable`1[[Aspose.Tasks.View, Aspose.Tasks, Version=6.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56]], System.Collections.IEnumerable
Aspose.Tasks.WeekDay ---- System.ICloneable
Aspose.Tasks.WorkDay
Aspose.Tasks.WorkingTime
Aspose.Tasks.WorkUnit
Aspose.Tasks.WorkWeek
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aspose.Tasks.ProjectXMLCreationFinished
Aspose.Tasks.ProjectXMLParsingStarted
Aspose.Tasks.TaskXMLCreationFinished
Aspose.Tasks.TaskXMLParsingFinished
System.Exception ---- System.Runtime.Serialization.ISerializable
System.ApplicationException
Aspose.Tasks.TasksException
Aspose.Tasks.TasksReadingException
Aspose.Tasks.TasksWritingException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Tasks.ApplicationInfo
Aspose.Tasks.BackgroundPattern
Aspose.Tasks.BaselineType
Aspose.Tasks.BookingType
Aspose.Tasks.CalculationType
Aspose.Tasks.CalendarExceptionType
Aspose.Tasks.ConstraintType
Aspose.Tasks.CostAccrualType
Aspose.Tasks.CurrencySymbolPositionType
Aspose.Tasks.CustomFieldType
Aspose.Tasks.DayType
Aspose.Tasks.EarnedValueMethodType
Aspose.Tasks.ElementType
Aspose.Tasks.ExtendedAttributeResource
Aspose.Tasks.ExtendedAttributeTask
Aspose.Tasks.Field
Aspose.Tasks.FileFormat
Aspose.Tasks.FilterComparisonType
Aspose.Tasks.FilterOperation
Aspose.Tasks.GanttBarSize
Aspose.Tasks.GroupOn
Aspose.Tasks.ItemType
Aspose.Tasks.MaskType
Aspose.Tasks.Month
Aspose.Tasks.MonthItemType
Aspose.Tasks.MonthPosition
Aspose.Tasks.OutlineValueType
Aspose.Tasks.RateFormatType
Aspose.Tasks.RateType
Aspose.Tasks.ResourceType
Aspose.Tasks.RollupType
Aspose.Tasks.TaskLinkType
Aspose.Tasks.TasksDataFormat
Aspose.Tasks.TaskStartDateType
Aspose.Tasks.TaskType
Aspose.Tasks.TimephasedDataType
Aspose.Tasks.TimeUnitType
Aspose.Tasks.ViewScreen
Aspose.Tasks.WorkContourType
Aspose.Tasks.WorkGroupType

See Also

Aspose.Tasks Namespace