Aurigma Image Uploader 7.0.11

Introduction

  • Collapse All Sections
  • See Also
  • Language Filter ( all languages )

Image Uploader is a powerful upload component designed for Web 2.0 projects, photo print services, galleries, social networks, e-commerce, and other upload-enabled and image-centric solutions. Its primary intent is making mass file uploads easy. Here, it enables uploading of entire folders and on the fly ZIP compression of selected files before sending them to a server.

Image Uploader is a client-side add-on supported by the most of browsers and operating systems. It is shppied with the following facilities intended to integrate this add-on with Web solutions on various platforms:

  • Image Uploader ASP.NET makes it possible to deploy and configure Image Uploader in Microsoft Visual Studio via design mode and handle uploaded data almost without coding.
  • Image Uploader PHP is a collection of classes that allows PHP developers to work with Image Uploader in a usual way as with a common PHP object.
  • Image Uploader JavaScript is a core client-side library used in both Image Uploader ASP.NET and Image Uploader PHP. This library does not provide facilities to handle uploaded data server-side; however, it is more flexible and can be used with any HTTP-compliant server platform (not only ASP.NET or PHP).

Image Uploader provides a rich functionality that can be used to solve a variety of specific tasks. This way, it can be used in a wide range of solutions and meets the requirements posed both for the upload workflow and for the upload tool itself. To illustrate it, let us highlight the most important Image Uploader features:

  • Fast and fail-safe upload. Image Uploader sends files and additional data as fast as it can. To make the upload more reliable, it sends files in separate packages containing a few files and data. Additionally, Image Uploader can break large files into chunks and upload them one by one in separate requests. If however, the upload is broken, it can be automatically resumed without sending already uploaded files again.
  • Pre-upload image processing. Image Uploader performs all the image-related operations client-side. It can recompress, resize, rotate, and crop images, apply watermarks, and extract EXIF and IPTC metadata.
  • User-friendly upload. Upload process is indicated with a progress bar, so a user always knows how long to wait, and they can always stop the upload process if it takes too long time.
  • Integratability and customizability. Image Uploader installation pack contains real-life code samples allowing you to integrate it in your existing solution with ease. The customizability of the POST request allows seamless data exchange between Image Uploader and third-party applications and APIs. As a tool, Image Uploader is designed to change its appearance easily. It provides a rich functionality to replace buttons by your images, customize colors, fonts and other look and feel settings, and even change panes layout - all this allows you to adapt Image Uploader to your website look and feel. Furthermore, you can modify not just Image Uploader appearance, but also any text captions and messages. This way you can translate Image Uploader user interface to any language.
  • Upload files to cloud storages support. Image Uploader includes special extensions which allow uploading files directly to the cloud storage from a browser. The most popular storages Amazon S3 and Nirvanix are supported. The Uploading to Cloud Storages topic contains the detailed instructions on how to implement it.

Image Uploader is available in four editions: Express, Professional, Print, and Premium. Express and Professional editions are intended to be used in projects that do not require making thumbnails larger than 3 or 5 megapixels and the other printing-related features, namely, Web 2.0 solutions, professional solutions, e-commerce solutions, and so on. Image Uploader Print, however, is designed to be used in various pre-print and photo-print solutions. See the Comparison of Image Uploader Editions topic for more details.

See Also

Manual

  • How Does Image Uploader Work
  • Where Image Uploader Can Be Useful
  • Before You Started
Copyright © 2002-2010 by Aurigma, Inc. Send feedback concerning the documentation or get the support.


Where Image Uploader Can Be Useful

Why Image Uploader

Image Uploader delivers substantial value to all stake holders involved both in the project development flow and in the production and profit making.

Solution Owners

Image Uploader is a powerful upload component designed for Web 2.0 projects, photo print services, image galleries, e-commerce and any other image-centered and/or upload-enabled solutions.

Solution Developers

For the developer, Image Uploader is more than just a client-side control. It is an SDK that ships with the following facilities to embed this control into web solution:

  • Image Uploader ASP.NET makes it possible to deploy and configure Image Uploader in Microsoft Visual Studio via design mode and handle uploaded data almost without coding.
  • Image Uploader PHP is a collection of classes that allows PHP developers to work with Image Uploader in a usual way as with a common PHP object.
  • Image Uploader JavaScript is a core client-side library used in both Image Uploader ASP.NET and Image Uploader PHP. This library does not provide facilities to handle uploaded data server-side; however, it is more flexible and can be used with any HTTP-compliant server platform (not only ASP.NET or PHP).

This SDK also includes the detailed documentation (covering both the API and the features) and real-life samples for the most widely used server platforms.

End Users

From the point of view of the end user, Image Uploader has an attractive appearance and intuitive user interface.

Image Uploader features several layouts, so you can choose the one that is the most appropriate for the solution. Moreover, you can choose to show the progress bar and remaining upload time estimation. End users can abort and resume uploads, use drag-n-drop and upload entire folders, too.

To start uploading, a user only needs to have Java Runtime Environment installed (for non-Internet Explorer browsers) and Image Uploader downloaded and enabled.

Objectives Solved

Making mass file uploads easy - that is what Image Uploader is all about. It also enables uploads of entire folders, ZIP compression, user quota and basic image processing functionality. The imaging capabilities of Image Uploader cover the needs of a variety of photo-centered solutions, including photo print services, Web 2.0, picture galleries, stock photo auctions, etc.

Image Uploader does all imaging client-side, which spares the server a great deal of load. The imaging-related operations include cropping, resizing, rotation, watermarking, EXIF and IPTC metadata extraction, and JPEG compression. This way, you only need to get enough bandwidth to receive the photos ready for printing or public display.

Image Uploader provides a wide range of supervisory functions (i.e. user quota). These include specifying the maximum and minimum permissible size of the uploaded files (both in pixels and megabytes), restricting allowed file extensions, disallowing uploads of CMYK images, etc.

Moreover, Image Uploader allows getting and posting supplementary data from the client. To that end, it enables the end user to enter descriptions for files. Besides, the fields of the POST requests sent by Image Uploader can be customized to send arbitrary data to the server.

Image Uploader works with any server part that is able to receive POST requests via HTTP. To illustrate this, we have included several samples for the most popular server platforms.

Integratability and Compatibility

Image Uploader easily integrates with your existing solutions. The customizability of the POST request allows seamless data exchange between the control and in-house and third-party applications and APIs.

Image Uploader supports the majority of modern browsers, including Internet Explorer, Firefox, Safari (for MacOS only), and Google Chrome. This allows convenient uploads on Windows, MacOS, Linux, Unix and FreeBSD.

Image Uploader GUI elements are widely customizable: you can specify captions or images for the buttons, text for messages and warnings, background colors and much more. The GUI is easily localizable into any language, and it also ships with ready-to-use translations for 15 locales, including Chinese (both simplified and traditional), Czech, Dutch, English, French, German, Italian, Japanese, Korean, Norwegian, Russian, Spanish, Swedish, and Turkish. The sample that comes with the SDK shows how to enable on-the-fly locale switching without reloading the page.

Versatility to Serve Many Industries

Image Uploader provides rich functionality that can be used to solve a variety of specific tasks. This way, it can be used in a wide range of solutions, including Web 2.0, printing, real estate, and car dealer services, medical services, etc. Here, Image Uploader meets the requirements posed both for the upload workflow and for the upload tool itself. To see how it caters for various industries, let us consider some examples:

  1. Web 2.0 projects have a bunch of requirements that are rather different in their nature:

    • essentially flexible and easily customizable GUI
    • client-side thumbnail generation
    • capability of uploading arbitrary data along with files
    • quota for the file size in pixels and megabytes
    • client-side watermarking

  2. Printing services mostly have requirements directly related to processing of large images:

    • working with huge bitmaps
    • client-side resize, rotation, and cropping
    • handling EXIF and IPTC metadata
    • quality meter that allows choosing the optimal paper size for printing the photos

  3. Professional solutions for various industries (including e-commerce) require an assorted set of features:

    • uploading both image and non-image files
    • preparing resized images on the client side
    • client-side file compression
    • quota for the size of both files uploaded at a time and for a single file


Before You Started

Introducing Image Uploader

Image Uploader is a powerful upload component designed for Web 2.0 projects as well as image-oriented and upload-enabled solutions. It provides a rich functionality which allows solving a big number of specific tasks and makes it able to meet requirements posed both for the upload workflow and for the upload tool itself.

The most significant Image Uploader features are client-side image processing, including such actions as resizing, rotating, cropping, and watermarking. User-friendly upload is indicated with a progress bar and provided with an ability to resume broken uploads without resending already uploaded files. Also there is the ability to customize Image Uploader GUI elements as well as the uploaded data format.

So, if Image Uploader is the tool you need, let us familiarize you with it more closely. To begin with Image Uploader, you need to download Image Uploader SDK from http://www.aurigma.com/Products/ImageUploader/FreeTrial.aspx location. Here the SDK is available in the following packages:

  • ImageUploader.exe, Windows-only installer
  • ImageUploaderNoSetup.zip, ZIP archive

The steps to install both these packages are listed in the Installation and Deployment Notes topic.

The present article considers how to embed Image Uploader into a project. The main advantage of Image Uploader is that it is designed to be integrated with both work-in-progress and completed projects.

Note

In the case when your project is already based on a previous version of Image Uploader you can easily upgrade it to the latest one using the upgrading guidelines.

Embedding Image Uploader into Project

Image Uploader SDK includes several tools intended to insert Image Uploader into a web page. Each tool has its own pros and cons, which allows you to choose the one which meets your requirements more precisely. Carefully read descriptions of these tools below; it will help you to make the right decision.

Image Uploader ASP.NET

Image Uploader ASP.NET was developed especially for the ASP.NET server platform. It represents a set of ASP.NET server controls which allow deploying and configuring Image Uploader in Microsoft Visual Studio in design mode. Its another advantage is that it significantly simplifies handling uploaded data and saves you the trouble of parsing POST request yourself. This tool is intended most of all for ASP.NET developers; here it enables them to use Image Uploader in a straight-forward way just as the other ASP.NET server controls.

So, if you are going to use Image Uploader in an ASP.NET application, this tool would be the best choice. See Quick Start with Image Uploader ASP.NET to get started with it.

Image Uploader PHP

This tool can be used with PHP platform only. Image Uploader PHP contains a collection of PHP classes intended to deploy and configure Image Uploader as well as to handle uploaded data. Image Uploader PHP has nearly the same functionality as Image Uploader ASP.NET.

Thus, Image Uploader PHP is the best solution for PHP applications. Read the Quick Start with Image Uploader PHP topic and see for yourself.

Image Uploader JavaScript

Contrary to the first two tools, the current one is compatible with any HTTP-compliant server platform and. It is a base for both Image Uploader ASP.NET and Image Uploader PHP. Image Uploader JavaScript is more complicated in comparison with previously described ones; it requires configuring Image Uploader parameters manually and does not provide any facility to handle uploaded data. On the other hand, it is more flexible and can be used not only with ASP.NET or PHP. See the Quick Start with Image Uploader PHP topic to begin with this tool.

Evaluating Image Uploader

After you insert Image Uploader into a page, try to upload some files. Most likely, the upload process will not start and you get the following message:

No valid license key for current DNS/IP address specified. If you see this message please contact site administrator.

To get rid of this message and allow Image Uploader to upload files you should register a license key. This key can be trial or full. Full keys are required for a production purpose and will be considered below.

Trial keys allow evaluating Image Uploader on any domain during the 30 days period. Another limitation of the evaluation version is the trial message which is shown whenever you start the upload. You can find the detailed instructions on how to obtain and register trial license keys in the Evaluating and Registering Image Uploader topic.

Additionally, there are two more ways to evaluate Image Uploader. The first one is to use it on localhost domain where it always works as a full version. The second way is to register development keys which can be used for development purposes only. To obtain development keys just create support case and request them.

Integrating Image Uploader with Project

Image Uploader is designed to be easily integrated with your existing solution, including both look and feel and uploaded data format. It provides a rich functionality to replace buttons by your images, customize colors, fonts and other appearance settings. See the Customizing Appearance topic for details. As for the uploaded data, you can adapt the POST request format for comparability with your server-side API. Here you can add your custom fields as well as rename and remove default ones. Find the detailed information about this feature in the Uploading Additional Data, Configuring POST Format, and POST Field Reference topics.

Moving Project to Production Server

First of all, before to move Image Uploader-enabled project to your production server you need to obtain and register full license keys. These keys should be associated with the domain name or IP address of your server. Carefully read the Evaluating and Registering Image Uploader topic before purchase keys.

The next step is to copy Image Uploader redistributable files along with your application code to the production server. Depending on the way you have embedded Image Uploader into your project you should use the following files:

  • For Image Uploader ASP.NET use Aurigma.ImageUploader.dll file.
  • For Image Uploader PHP use /ImageUploaderPHP folder.
  • For Image Uploader JavaScript use /Scripts folder.

Probably, you may need to slightly configure your server before publish your solution. For example, to grant read and write permissions for folders you are going to upload files to or set the limitation for maximum POST request length. Find details in the Configuring ASP.NET and Configuring PHP topics.

Troubleshooting

If you encounter some problem during installation, evaluation, or uploading try to find a solution in the knowledge base available in the Troubleshooting section. It contains information on how to resolve typical problems which may occur with Image Uploader.

In the case if this information does not help and the problem still occurs feel free to create support case and report us about it.

See Also

Manual

  • Upgrading from Image Uploader ASP.NET Control 6.x
  • Upgrading from Image Uploader PHP Library 6.x
  • Upgrading from Image Uploader 6.x
  • Quick Start with Image Uploader ASP.NET
  • Quick Start with Image Uploader PHP
  • Quick Start with Image Uploader JavaScript
  • Upgrading from Image Uploader ASP.NET Control 6.x
  • Upgrading from Image Uploader PHP Library 6.x
  • Upgrading from Image Uploader 6.x
  • Uploading Additional Data in ASP.NET
  • Uploading Additional Data in PHP


Image Uploader Fundamentals

This section describes Image Uploader fundamentals.

In This Section

How Does Image Uploader Work
Working with Images
Comparison of Image Uploader Editions
Security Approach in Image Uploader


How Does Image Uploader Work

What is Image Uploader?

Image Uploader is the solution intended to make mass file upload easier. It is simply embedded into HTML code of your web page and does not require end-user to download and install it manually. A modern appearance and intuitive user interface make Image Uploader attractive for end-users as well as clear for computer novices. Here is a common workflow to upload files with Image Uploader:

  1. Users visit a page where Image Uploader resides and select as many files as they want.
  2. When all the files are added, they click Upload.
  3. Image Uploader prepares a HTTP POST request with user-selected files and additional data and sends it to the server page specified in its settings. This page receives and processes the request and performs any other upload-related actions.
  4. Progress bar with remaining upload time estimation is shown during the upload process; so, users always know how long to wait, and they can always stop the upload if it takes too long.

Additionally, Image Uploader is able to apply automatic client-side data optimization before sending it. For example, it can resize images and compress files to ZIP archives. This way the add-on reduces traffic, uploading time, and server disk amount used to store your data.

The figure below demonstrates Image Uploader architecture:

Image Uploader architecture

Let us consider its main parts in detail.

How Does It Work Client-Side?

On the client-side, Image Uploader consists of two parts which implement almost similar functionality:

  • ActiveX control (for Internet Explorer)
  • Java applet (for Mozilla Firefox, Safari, or other browsers having Java runtime support)

Both parts implement a common functionality, namely, user interface for selecting and sorting files, pre-upload file processing, and sending files via HTTP POST request.

Image Uploader JavaScript unifies these parts; it determines a browser type and loads the corresponding component (ActiveX or Java). It provides an API for configuring Image Uploader and manipulating it at runtime, i.e. change properties, call methods, and handle events. Image Uploader JavaScript also helps to debug integration of the control with your web service by displaying notifications if some parameters have inconsistent values. These notifications can be disabled when you are ready to go live with your web site. Find details in the Using JavaScript API article.

How Does It Work Server-Side?

Since Image Uploader sends files and data in HTTP POST request, the server-side part is represented with a web server which hosts your application. This server performs all the upload-related tasks, such as receiving and saving uploaded files to necessary folders, updating a database, sending email notifications, and etc. In a word, this part implements the internal logic of your application which uses Image Uploader.

When developing this part you may implement your own upload script which will parse the POST request received from Image Uploader. In this case you can use any server platform which is able to receive HTTP POST request. Another way is to use Image Uploader ASP.NET or Image Uploader PHP . They both get the uploaded data, parse it, and provide a typed access to files and text fields on the server side. The built-in autosave feature allows you to create your upload solution without writing a line of code. Refer the Saving Uploaded Files in ASP.NET or Saving Uploaded Files in PHP topic depending on the platform you are going to use Image Uploader with.

One more case is when your application is integrated with a cloud storage, i.e. Amazon S3 or Nirvanix. Here you do not need to receive files from Image Uploader and redirect them to the storage because Image Uploader supports uploading files directly from a browser to a cloud storage. Find details in the Uploading to Cloud Storages article.

Image Uploader ASP.NET

Image Uploader ASP.NET is set of ASP.NET server controls which allow deploying and configuring Image Uploader in Microsoft Visual Studio in design mode. Its another advantage is that it significantly simplifies handling uploaded data and saves you the trouble of parsing POST request yourself. The Quick Start with Image Uploader ASP.NET topic gives outlook on how to use it in your web solution.

Image Uploader PHP

Image Uploader PHP implements almost the same functionality and offers the same advantages as Image Uploader ASP.NET. It allows PHP developers to work with Image Uploader in a usual way as with a common PHP object. Find the detailed information about the PHP library in the Quick Start with Image Uploader PHP topic.

See Also

Manual

  • Introduction
  • Where Image Uploader Can Be Useful
  • Using JavaScript API
  • Saving Uploaded Files in ASP.NET
  • Saving Uploaded Files in PHP
  • Quick Start with Image Uploader ASP.NET
  • Quick Start with Image Uploader PHP
  • Quick Start with Image Uploader JavaScript


Working with Images

Although Image Uploader is intended for uploading files of various types, it additionally provides some imaging capabilities. In other words, Image Uploader can perform the following image-related tasks:

  • display previews
  • resize and recompress images using JPEG algorithm
  • rotate and crop images (both manually by the user and automatically)
  • apply watermarks
  • handle EXIF and IPTC metadata

Image Uploader recognizes the following file formats as images:

  • JPEG
  • TIFF (in Internet Explorer only)
  • BMP
  • GIF
  • PNG
  • PSD (in Internet Explorer only)
  • WBMP (in Internet Explorer only)
Note

Image Uploader can load files of these formats and display previews for them, however, it can save the image only into the single format - JPEG. So if you create a thumbnail for some image file (say, GIF), or create a rotated version, it will be saved to JPEG format. See more details in the Uploading Images section.


Comparison of Image Uploader Editions

Image Uploader comes in four editions: Express, Professional, Print, and Premium. This topic compares them by functionality.

Restrictions | Express | Professional | Print | Premium
Maximum file size | 100 Mb | 2 Gb | 2 Gb | any
Maximim size of created thumbnail | 3 megapixels | 5 megapixels | any | any
Maximim number of files | 100 | any | any | any
Features | Express | Professional | Print | Premium
Displaying and uploading folders |  | * | * | *
Using Thumbnail control |  | * | * | *
Saving and restoring upload list |  | * | * | *
Automatic upload recovery |  | * | * | *
Uploading hash sums |  | * | * | *
Registering several license keys that allows you to host Image Uploader on one domain and upload files to another |  | * | * | *
Preserving EXIF metadata when creating thumbnails |  |  | * | *
Preserving original color space when creating thumbnails |  |  | * | *
Using quality meter |  |  | * | *
Using HTTPS for both host and upload pages |  | * | * | *
Using private-label version |  |  |  | by request

As you can see Image Uploader Print includes printing-specific features in addition to Express and Professional. In that way Express and Professional editions are intended to be used in projects that do not require making thumbnails larger than 3 or 5 megapixels and the other printing-related features, namely, Web 2.0 solutions, professional solutions, e-commerce solutions, and so on. Image Uploader Print, however, is designed to be used in various pre-print and photo-print solutions.

All the Image Uploader editions differ in license keys. It means if you purchase Express or Professional edition you get a license key that locks Print and Premium functionality and vice versa. Nevertheless, installation packages are the same for all editions.

  • Uploading Folders in ASP.NET
  • Uploading Folders in PHP
  • Uploading Folders in Other Platforms
  • Uploading Hash Sums in ASP.NET
  • Uploading Hash Sums in PHP
  • Uploading Hash Sums in Other Platforms
  • Using Private-label Version of Image Uploader ASP.NET
  • Using Private-label Version of Image Uploader PHP
  • Using Private-label Version of Image Uploader JavaScript
  • Thumbnail (ASP.NET)
  • Thumbnail (PHP)
  • thumbnail (JavaScript)


Security Approach in Image Uploader

This topic gives information about security approach used during Image Uploader development.

Security at Center of Attention

During the development of Image Uploader Aurigma, Inc. took care of avoiding any potential security problems. As Image Uploader is a software which is installed from the web, neglecting these problems might lead to security holes. For this reason any feature that could potentially cause security risks was rejected.

If any security holes in the Image Uploader are found, all the customers are immediately informed about possible issues and the problem is fixed as soon as possible.

Those customers, who would like to make sure whether the code safety is ok themselves, can purchase the Image Uploader source code. In addition to security audit these customers can carry out customization. Please contact Aurigma sales department if you are interested.

Sandbox

The main principle of Image Uploader architecture is a sandbox. It means that Image Uploader API does not provide any access to the file system or other resources. Unlike some competing uploading components, Image Uploader does not have such unsafe features as the ability to get a list of files in a given folder or add files to the upload list via client scripts, etc. These features would allow malicious persons to steal files from those computers where Image Uploader is installed.

Image Uploader requires the user to carry out all potentially dangerous operations through the user interface. None of such operations can be done without user's knowledge.

Access to Files in Upload List

Image Uploader provides an access to the list of files which are already choosen by the user for the upload. However, it does not compromise security, because the user adds these files to the upload list manually.

By the way, similar functionality is available in Internet Explorer: you can get a name of the file opened in the standard <input type="file"> element.

ActiveX vs. Java

Some people are worried about low safety of the ActiveX technology against high safety of Java applets. Sometimes they ask whether the Java part of Image Uploader is more secure than the ActiveX one.

The answer is NO. To be able to work with files on a local machine, the Java applet has to go out from Java sandbox (in other words, make the security level the same as in ActiveX). This way using Java applets for uploading would not bring any security benefits.


Image Uploader User Interface

This section describes Image Uploader user interface.

In This Section

Layouts
View Modes
Additional Controls and Indicators
Image Editor
Keyboard Shortcuts


Layouts

Image Uploader has two different-looking layouts that determine its appearance. To specify, which one of them should be used, set the Uploader.PaneLayout property.

Three Panes Layout

This is a default layout which consists of three panes:

  • Tree pane is the folder tree allowing a user to navigate his or her file system.
  • Folder pane displays the content of the currently selected folder.
  • Upload pane contains files ready to be uploaded.
Three Panes Layout

Both the tree and upload panes are collapsible.

Three Panes Layout

Image Uploader displays this layout when the Uploader.PaneLayout property is ThreePanes.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server"
    PaneLayout="ThreePanes" />

PHP

$uploader = new Uploader("Uploader1");
$uploader->setPaneLayout("ThreePanes");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    paneLayout: 'ThreePanes'
});

Uploading Files

To upload files in this layout, follow these steps:

  1. In the tree pane select a folder containing necessary files and/or folders.
  2. In the folder pane check desired files and/or folders or drag-and-drop them onto the upload pane. To check all files at once use the Check all option of the context menu.
  3. Select necessary files and/or folders in Windows Explorer, Finder, or any other graphic shell you use and drop them onto the upload pane.
  4. Repeat Steps 1-3 until all the necessary files are added to the upload pane.
  5. Click the Upload button.

One Pane Layout

The one pane layout is more minimalistic than a default one. Here Image Uploader displays only the upload pane representing a list of files selected for upload.

One Pane Layout

To specify this layout set the Uploader.PaneLayout property to the OnePane value:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server"
    PaneLayout="OnePane" />

PHP

$uploader = new Uploader("Uploader1");
$uploader->setPaneLayout("OnePane");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    paneLayout: 'OnePane'
});

Uploading Files

  1. Add files to the upload pane using the following ways:
    • Select necessary files and/or folders in Windows Explorer, Finder, or any other graphic shell you use and drop them onto the upload pane.
    • Call the uploadPane.addFiles() method and select files in the standard Open File dialog.
    • Call the uploadPane.addFolders() method and select a folder in the standard Open Folder dialog.
  2. Repeat Step 1 until all the necessary files are added to the upload pane.
  3. Click the Upload button.

See Also

Reference

  • PaneLayout Property

Manual

  • View Modes
  • Customizing Appearance
  • PaneLayout (ASP.NET)
  • PaneLayout (PHP)
  • paneLayout (JavaScript)
  • PaneLayout (ASP.NET)
  • PaneLayout (PHP)
  • paneLayout (JavaScript)
  • PaneLayout (ASP.NET)
  • PaneLayout (PHP)
  • paneLayout (JavaScript)
  • PaneLayout (ASP.NET)
  • PaneLayout (PHP)
  • paneLayout (JavaScript)


View Modes

View modes allow users to browse their files in a familiar way. There are four view modes that are available for use in both the folder and upload panes. Users can change view mode via the context menu by clicking the right mouse button on the folder or upload pane. They are:

  • Thumbnails
  • Tiles
  • Details
  • List

Additionally, you can set a default mode using the FolderPane.ViewMode and UploadPane.ViewMode properties.

Thumbnails

This mode is mostly used for browsing image files. It displays files as large thumbnails without any additional information. If, however, a user wants to know a file name they just need to move the mouse pointer over the thumbnail.

Use the following code to display files initially in this mode.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <FolderPane ViewMode="Thumbnails" />
    <UploadPane ViewMode="Thumbnails" />
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getFolderPane()->setViewMode("Thumbnails");
$uploader->getUploadPane()->setViewMode("Thumbnails");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    folderPane: {viewMode: 'Thumbnails'},
    uploadPane: {viewMode: 'Thumbnails'}
});

Tiles

This view is intended for displaying files of various types. Here each file appears as a thumbnail (or icon for non-image files), with a file name and details (file type, last modification date, and file size) on the right. This is the most informative mode; however, it requires much space to display a file.

Use the following code to display files initially in this mode.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <FolderPane ViewMode="Tiles" />
    <UploadPane ViewMode="Tiles" />
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getFolderPane()->setViewMode("Tiles");
$uploader->getUploadPane()->setViewMode("Tiles");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    folderPane: {viewMode: 'Tiles'},
    uploadPane: {viewMode: 'Tiles'}
});

Details

In this view, a table, in which each row corresponds to a file, is displayed. The table contains of six columns:

  • Name
  • Info
  • Size
  • Type
  • Last modification date
  • Image dimensions

This view shows more information about files.

Use the following code to display files initially in this mode.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <FolderPane ViewMode="Details" />
    <UploadPane ViewMode="Details" />
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getFolderPane()->setViewMode("Details");
$uploader->getUploadPane()->setViewMode("Details");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    folderPane: {viewMode: 'Details'},
    uploadPane: {viewMode: 'Details'}
});

List

This view is used to browse files of various types. It displays files as small thumbnails (or icons for non-image files) with names on the right. The advantage of this view is that more files can be seen at a time.

Use the following code to display files initially in this mode.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <FolderPane ViewMode="List" />
    <UploadPane ViewMode="List" />
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getFolderPane()->setViewMode("List");
$uploader->getUploadPane()->setViewMode("List");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    folderPane: {viewMode: 'List'},
    uploadPane: {viewMode: 'List'}
});

See Also

Reference

  • FolderPane.ViewMode Property
  • UploadPane.ViewMode Property

Manual

  • Layouts
  • Customizing Appearance
  • ViewMode (ASP.NET)
  • ViewMode (PHP)
  • viewMode (JavaScript)
  • ViewMode (ASP.NET)
  • ViewMode (PHP)
  • viewMode (JavaScript)
  • ViewMode (ASP.NET)
  • ViewMode (PHP)
  • viewMode (JavaScript)
  • ViewMode (ASP.NET)
  • ViewMode (PHP)
  • viewMode (JavaScript)


Additional Controls and Indicators

The most attractive view modes are thumbnails and tiles as they display thumbnails of original images and are more obvious to a user. In these modes, pane items may have additional controls and indicators. Let us discuss them in detail.

Controls

Controls are interactive icons displayed on the pane item's surface when a mouse pointer hovers over this item. Using additional controls a user can perform some actions on one or several items. All the controls, except of editor, support multi-selection, it means that all the selected items can be simultaneously checked, rotated, provided with a description, or removed.

Check Box

This control appears only in the three panes layout and does not require any extra set-up, as it appears automatically. Using check boxes a user can select files for upload.

Thumbnais | Tiles | List | Details

Rotation Control

This control appears as an arrow in both the folder pane and upload panes and supports both layouts. By clicking the arrow a user rotates images by 90 degrees clockwise. This control is enabled by default; if, however, you want to disable it set the Uploader.EnableRotation property to false.

Thumbnais | Tiles

The following properties will help you to customize this control:

  • PaneItem.RotationIconImageFormat
  • PaneItem.RotationIconTooltip

Image Editor Control

This control appears in a form of a magnifier in both the folder and upload panes and supports both layouts. By clicking this magnifier a user opens the image editor allowing them to crop or rotate an image as well as add a description. This control is enabled by default; if, however, you want to disable it set the Uploader.EnableImageEditor property to false.

Thumbnais | Tiles

Here are the properties allowing you to customize this control:

  • PaneItem.ImageEditorIconImageFormat
  • PaneItem.ImageEditorIconTooltip

Description Editor Control

This control appears in a form of a note icon in both the folder and upload panes and supports both layouts. By clicking this icon a user opens the description editor allowing them to attach descriptions to files. This control is enabled by default; if, however, you want to disable it set the Uploader.EnableDescriptionEditor property to false.

Thumbnais | Tiles

The following properties allow you to customize the description control:

  • PaneItem.DescriptionEditorIconImageFormat
  • PaneItem.DescriptionEditorIconTooltip

Removal Control

This control appears in a form of a cross in the one pane layout only. By clicking this cross a user removes files from the upload list. This control cannot be disabled.

Thumbnais | Tiles

Use the properties below to customize the removal control:

  • PaneItem.RemovalIconImageFormat
  • PaneItem.RemovalIconTooltip

Indicators

Indicators are non-interactive icons displayed on the pane item's surface independently of items selection and mouse hover. They state that the item or items meet certain conditions.

Quality Meter

This indicator appears in both the folder and upload panes and supports both layouts. However, it is displayed in the thumbnails view only. It appears as a colored strip divided in sections, where each section corresponds to some predefined format. To add this control to pane items, initialize the PaneItem.QualityMeter property as it is described in the Using Quality Meter topic. The strip will show up automatically.

Image Cropped Indicator

This indicator appears in both the folder and upload panes and supports both layouts. In addition to the thumbnails and tiles views, image cropped indicator is displayed in the details view too. This indicator is shown if the image was cropped via the image editor.

Thumbnais | Tiles | Details

The following properties will help you to customize this indicator:

  • PaneItem.ImageCroppedIconImageFormat
  • PaneItem.ImageCroppedIconTooltip

Description Added Indicator

This indicator appears in both the folder and upload panes and supports both layouts. In addition to the thumbnails and tiles view, description indicator is displayed in the details view too. This indicator is shown if the file is provided with a description.

Thumbnais | Tiles | Details

Use the PaneItem.DescriptionAddedIconImageFormat property to customize appearance of this indicator.

See Also

Reference

  • PaneItem Class
  • QualityMeter Class

Manual

  • Layouts
  • View Modes
  • Image Editor
  • Customizing Appearance
  • Using Quality Meter
  • EnableRotation (ASP.NET)
  • EnableRotation (PHP)
  • enableRotation (JavaScript)
  • RotationIconImageFormat (ASP.NET)
  • RotationIconImageFormat (PHP)
  • rotationIconImageFormat (JavaScript)
  • RotationIconTooltip (ASP.NET)
  • RotationIconTooltip (PHP)
  • rotationIconTooltip (JavaScript)
  • EnableImageEditor (ASP.NET)
  • EnableImageEditor (PHP)
  • enableImageEditor (JavaScript)
  • ImageEditorIconImageFormat (ASP.NET)
  • ImageEditorIconImageFormat (PHP)
  • imageEditorIconImageFormat (JavaScript)
  • ImageEditorIconTooltip (ASP.NET)
  • ImageEditorIconTooltip (PHP)
  • imageEditorIconTooltip (JavaScript)
  • EnableDescriptionEditor (ASP.NET)
  • EnableDescriptionEditor (PHP)
  • enableDescriptionEditor (JavaScript)
  • DescriptionEditorIconImageFormat (ASP.NET)
  • DescriptionEditorIconImageFormat (PHP)
  • descriptionEditorIconImageFormat (JavaScript)
  • DescriptionEditorIconTooltip (ASP.NET)
  • DescriptionEditorIconTooltip (PHP)
  • descriptionEditorIconTooltip (JavaScript)
  • RemovalIconImageFormat (ASP.NET)
  • RemovalIconImageFormat (PHP)
  • removalIconImageFormat (JavaScript)
  • RemovalIconTooltip (ASP.NET)
  • RemovalIconTooltip (PHP)
  • removalIconTooltip (JavaScript)
  • QualityMeter (ASP.NET)
  • QualityMeter (PHP)
  • qualityMeter (JavaScript)
  • ImageCroppedIconImageFormat (ASP.NET)
  • ImageCroppedIconImageFormat (PHP)
  • imageCroppedIconImageFormat (JavaScript)
  • ImageCroppedIconTooltip (ASP.NET)
  • ImageCroppedIconTooltip (PHP)
  • imageCroppedIconTooltip (JavaScript)
  • DescriptionAddedIconImageFormat (ASP.NET)
  • DescriptionAddedIconImageFormat (PHP)
  • descriptionAddedIconImageFormat (JavaScript)
  • PaneItem (ASP.NET)
  • PaneItem (PHP)
  • paneItem (JavaScript)
  • QualityMeter (ASP.NET)
  • QualityMeter (PHP)
  • qualityMeter (JavaScript)


Image Editor

Image Uploader comes with a built-in image editor allowing users to preview and edit their images as well as attach text descriptions. Image editor is enabled by default and can be launched just by clicking the image editor control or by selecting the corresponding context menu item.

Image editor supports two image-editing operations, namely, rotation and cropping. The rotation can be performed by clicking the Rotate button. To crop an image you should select the desired area using the rectangle rubberband and click Crop to apply transformation and continue editing or Save and close to apply crop and exit the image editor.

All its buttons, text labels, and colors are customizable via the ImageEditor properties. See the Customizing Appearance topic for details.

If do not need to provide your users with an ability to edit their images, you can disable it by setting the Uploader.EnableImageEditor property to false. Additionally, the image editor functionality can be partially disabled via the following properties:

  • ImageEditor.EnableCrop enables or disables the cropping functionality. If it is false, the rectangular area cannot be selected and Crop and Cancel crop buttons are hidden.
  • Uploader.EnableRotation enables or disables the rotation functionality. If it is false, the Rotate button is hidden. Note, that this property affects the rotation control too.
  • Uploader.EnableDescriptionEditor enables or disables the adding description ability. If it is false the description field is hidden. Note, that this property affects the description editor control too.

See Also

Reference

  • Uploader Class
  • ImageEditor Class
  • ContextMenu Class

Manual

  • Customizing Appearance
  • Additional Controls and Indicators
  • Rotating and Cropping
  • EditText (ASP.NET)
  • EditText (PHP)
  • editText (JavaScript)
  • ImageEditor (ASP.NET)
  • ImageEditor (PHP)
  • imageEditor (JavaScript)
  • EnableImageEditor (ASP.NET)
  • EnableImageEditor (PHP)
  • enableImageEditor (JavaScript)
  • EnableCrop (ASP.NET)
  • EnableCrop (PHP)
  • enableCrop (JavaScript)
  • EnableRotation (ASP.NET)
  • EnableRotation (PHP)
  • enableRotation (JavaScript)
  • EnableDescriptionEditor (ASP.NET)
  • EnableDescriptionEditor (PHP)
  • enableDescriptionEditor (JavaScript)
  • Uploader (ASP.NET)
  • Uploader (PHP)
  • uploader (JavaScript)
  • ImageEditor (ASP.NET)
  • ImageEditor (PHP)
  • imageEditor (JavaScript)
  • ContextMenu (ASP.NET)
  • ContextMenu (PHP)
  • contextMenu (JavaScript)


Keyboard Shortcuts

This table lists keyboard shortcuts you can use with Image Uploader.

Shortcut | Action
Arrows | Tree pane: navigate through the folder tree. Folder and upload panes: navigates through the file list.
Shift+Arrows | Navigate through the items, adding them to selection.
Ctrl+Arrows | Navigate through the items without selection modification.
BackSpace | Folder pane: move to the parent folder. Upload pane: delete an item from the upload list.
Tab | Move focus on the next control element.
Shift+Tab | Move focus on the previous control element.
Enter | Open file in associated viewer software if the Uploader.EnableFileViewer property is true.
Space | Three panes layout: check/uncheck selected items.
Delete | Upload pane: delete an item from the upload list.
Ctrl+A | Select all the items.
  • EnableFileViewer (ASP.NET)
  • EnableFileViewer (PHP)
  • enableFileViewer (JavaScript)


Getting Started

This section contains basic things that are necessary to know to get started with Image Uploader.

In This Section

System Requirements
Installation and Deployment Notes
Image Uploader ASP.NET
Image Uploader PHP
Image Uploader JavaScript
Installing Image Uploader on Client Side
Evaluating and Registering Image Uploader
Upgrading Minor Versions


System Requirements

Client Side

Operating Systems

  • Windows XP/Vista/7 (including East Asian editions)
  • MacOS 10.5 or later
  • *NIX systems with Java Runtime Environment

Browsers

  • Internet Explorer (Windows) 6 or later. ActiveX controls and JavaScript should be enabled in the browser settings.

  • A browser which supports Java applets with JRE 1.5:

    • Any Mozilla-family browser, including Firefox 2 or later, Netscape, and others
    • Safari (Mac)
    • Google Chrome

    LiveConnect availability (required for some advanced features such as an additional form name uploading, event handling, etc).

    Java applets and JavaScript should be enabled in the browser settings.

Note

Some Mac browsers require Java Embedding Plug-in to be JRE 1.5-compatible.

These browsers do not require this plug-in:

  • Safari
  • Firefox version 2.0 or later

The following browsers are not supported:

  • Internet Explorer for Mac (no JRE 1.5 compatibility)
  • Opera

Server Side

Image Uploader ASP.NET

  • Microsoft Visual Studio 2005/2008/2010
  • .NET Framework 2.0, 3.x, 4.0

Image Uploader PHP

  • PHP 5/6


Installation and Deployment Notes

This topic provides instructions on how to install and uninstall Image Uploader SDK on the developer machine. Also, it describes files which should be deployed with an application which uses Aurigma Image Uploader 7.0.11.

Installation

Download Image Uploader SDK from http://www.aurigma.com/Products/ImageUploader/FreeTrial.aspx location. Here the SDK is available in the following packages:

  • ImageUploader.exe, Windows-only installer
  • ImageUploaderNoSetup.zip, ZIP archive

If you downloaded the Windows-only installer, just run the ImageUploader.exe file and follow the wizard steps. During one of these steps you specify the folder where to install all Image Uploader SDK files. Typically this is C:\Program Files\Aurigma\Image Uploader 7.0.11. When the installation is completed you get a number of folders and files organized in the following structure:

/Image Uploader 7.0.11
    /ASP.NET
        /Binaries
            Aurigma.ImageUploader.dll
        /Samples_ImageUploaderAspNet
        /Samples_ImageUploaderJavaScript
    /PHP
        /PHPClasses
        /Samples_ImageUploaderJavaScript
        /Samples_ImageUploaderPHP
    /RequestEvaluationKey
    /Scripts
    ImageUploader.chm

Use ImageUploaderNoSetup.zip for non-Windows platforms. Unpack this archive into any folder on your computer to get SDK files

Note

There is no need to install Image Uploader SDK on a server where you are going to run your application. Image Uploader SDK is necessary on the developer machine only.

Uninstallation

To uninstall Image Uploader SDK open Control Panel, click Programs and Features, then select Aurigma Image Uploader 7.0.11 and click Uninstall. After that click Yes, and follow the wizard instructions.

Files to be Deployed

Image Uploader SDK contains many files and folders, including Image Uploader itself, special wrappers, demo application sources, and documentation. Of course, you do not need to copy all these files to your production server. The files to be moved to production server depend on a way used to embed Image Uploader into your web application. There are three ways:

Image Uploader ASP.NET

Image Uploader ASP.NET enables ASP.NET developers to use Image Uploader in a straight-forward way just as a common server control. See details in the Quick Start with Image Uploader ASP.NET topic. If you use this way you need to copy the Aurigma.ImageUploader.dll file to the /bin folder of your web application.

Image Uploader PHP

Image Uploader PHP is a collection of classes which implement nearly the same functionality as the ASP.NET wrapper. Read more about Image Uploader PHP in the Quick Start with Image Uploader PHP topic. In the case if you embed Image Uploader using this wrapper you need to deploy the /ImageUploaderPHP folder along with other files of your application.

Image Uploader JavaScript

Image Uploader JavaScript includes a special API which is a base for both Image Uploader ASP.NET and Image Uploader PHP. To familiarize with this wrapper read the Quick Start with Image Uploader JavaScript topic first. All the files you need to deploy when using Image Uploader JavaScript are located in the /Scripts folder.

Configuring Permissions

When deploying an application which uses Image Uploader do not forget to set enough permissions to the folder you save files to:

  • On Windows NT/2000/XP you should grant the modify permission to the Internet guest user (IUSR_<machinename>).
  • On Windows 2003 Server you should grant the modify permission to the NETWORK SERVICE group.
  • On Windows Vista/2008 Server/7 you should grant the modify permission to the account your site application pool is running under, Network Service by default.
  • For *NIX systems you should specify read and write permissions.

See Also

Manual

  • Quick Start with Image Uploader ASP.NET
  • Quick Start with Image Uploader PHP
  • Quick Start with Image Uploader JavaScript


Image Uploader ASP.NET

This section contains the basic information necessary to know how to get started with Image Uploader ASP.NET.

In This Section

Quick Start with Image Uploader ASP.NET
Upgrading from Image Uploader ASP.NET Control 6.x
Using Private-label Version of Image Uploader ASP.NET


Quick Start with Image Uploader ASP.NET

Image Uploader ASP.NET is a server control intended to make deployment of Image Uploader, configuring it, and handling uploaded data easier. It allows ASP.NET developers to utilize Image Uploader in a straight-forward way just as a common ASP.NET server control, and provides the following advantages over a standard way of deployment (this way is described in the Quick Start with Image Uploader JavaScript topic):

  • Easy to insert Image Uploader into ASP.NET Web Form. You just drag and drop the control onto your page in Visual Studio designer, and it automatically generates client-side code and deploys Image Uploader-related files.
  • Ability to configure Image Uploader in Visual Studio using Properties editor.
  • Simplification of server upload script. The control gets data sent from the client, parses it, and provides typed access to this data server-side.
  • Autosave of uploaded files. Image Uploader ASP.NET allows you to create your upload solution without writing a line of code.

Adding Control to Page

To add Image Uploader ASP.NET into a web page just walk through the following steps:

  1. Create new ASP.NET Web site (in Visual Studio 2008 menu File -> New -> Web Site...).

    New Web Site dialog

  2. Add Image Uploader ASP.NET to the toolbox:

    1. Right-click on the tab of toolbox where you want to add this control and select Choose Items....
    2. Find the Uploader in the .NET Framework Components tab.
    3. If you cannot find this component, click Browse... and find the Aurigma.ImageUploader.dll assembly. This DLL can be found in Image Uploader installation folder (typically this is C:\Program Files\Aurigma\Image Uploader 7.0.11).
    4. Click OK on both Open and Choose Toolbox Items dialogs.
    Choose Toolbox Items dialog

  3. Open the page where Image Uploader should be placed in the design mode, then drag and drop the Uploader item into the desired position.

  4. Set this page as start page. To do it, right-click this page (default.aspx) in Solution Explorer and select the Set As Start Page menu option.

Uploading Files

Let us examine Image Uploader ASP.NET usage by the example of a simple file catalog. Suppose the catalog requires a user to upload files of various types and displays links to download these files. To perform this task we can phase it as follows.

Configuring Control

There are two ways to configure Image Uploader. The first one is to use the list of control properties in Properties editor. See the Image Uploader ASP.NET Reference for the detailed information about available properties.

Uploader control properties

The second way is to modify Uploader properties in the source of an ASP.NET page declaratively. See the source code of the main page of our catalog (default.aspx) below.

ASP.NET

<%@ Page Language="C#" AutoEventWireup="true"  CodeFile="Default.aspx.cs" Inherits="_Default" %>
<%@ Register assembly="Aurigma.ImageUploader" Namespace="Aurigma.ImageUploader" tagprefix="aur" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title>Image Uploader ASP.NET Sample</title>
</head>
<body>
    <form id="form1" runat="server">
        <aur:Uploader ID="Uploader1" runat="server"
                Height="480px" Width="650px"
                AutoSave="true"
                DestinationFolder="~/Catalog"
                LicenseKey="XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY">
            <UploadSettings RedirectUrl="catalog.aspx" />
            <Converters>
                <aur:Converter Mode="*.*=SourceFile" />
            </Converters>
        </aur:Uploader>
    </form>
</body>
</html>

On this page we set mandatory parameters, such as Image Uploader identifier and its dimensions, as well as optional parameters required by our file catalog. Here we enable the autosave feature and set a page to which the user will be redirected when the upload successfully completes. To configure Image Uploader to send original files we use the Uploader.Converters property which accepts a set of Converter instances. Each instance specifies what will be uploaded (original file as is, thumbnail created from original image file, icon associated with original file, or original file compressed into ZIP archive) for each of the user-selected files. Since we need to upload original files only, we set a one converter with the SourceFile mode. Read more about converters in the Configuring Files to be Uploaded topic.

One more significant property is Uploader.LicenseKey which specifies trial or full license key. If license key is not set Image Uploader will not send files (the exception is usage of uploader on localhost domain). See the Evaluating and Registering Image Uploader topic for details.

Handling Upload

This sample demostrates how to configure the autosave feature of Image Uploader ASP.NET. This feature saves you the trouble of writing server-side upload script by yourself. All you need is to set the AutoSave property to true. Then specify the folder where you want to save files via the DestinationFolder property. The code snippet above demonstrates how these properties can be specified. Now all the files sent by Image Uploader will be saved to this folder.

Displaying Uploaded Files

On the configuring step we set the UploadSettings.RedirectUrl property to the "catalog.aspx" value. It means that Image Uploader will redirect users to this page after the upload successfully completes. So, it would be convenient to list links to the uploaded files here. To implement this functionality we iterate through all the files stored in the /Catalog folder and display a link to each of them. See the source code below.

catalog.aspx:

ASP.NET

<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Catalog.aspx.cs" Inherits="Catalog" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title>Catalog</title>
</head>
<body>
    <asp:DataList ID="DataList1" Width="100%" RepeatLayout="Table" RepeatDirection="Vertical"
        RepeatColumns="1" runat="server">
        <HeaderTemplate></HeaderTemplate>
        <ItemTemplate>
            <a href="<%# catalogPath + System.IO.Path.GetFileName(Container.DataItem.ToString()) %>" target="_blank">
               <%# System.IO.Path.GetFileName(Container.DataItem.ToString()) %>
            </a>
        </ItemTemplate>
        <FooterTemplate></FooterTemplate>
    </asp:DataList>
</body>
</html>

catalog.aspx.cs:

C#

public partial class Catalog : System.Web.UI.Page
{
    protected string catalogPath;

    protected void Page_Load(object sender, EventArgs e)
    {
        catalogPath = "Catalog/";
        DataList1.DataSource = System.IO.Directory.GetFiles(Server.MapPath(catalogPath));
        DataList1.DataBind();
    }
}
Note

You may run the file catalog application considered here on your server. To do it, just paste source code to default.aspx, catalog.aspx, and catalog.aspx.cs files to your server using the following folder structure:

/bin
    Aurigma.ImageUploader.dll
/Catalog
catalog.aspx
catalog.aspx.cs
default.aspx

Make sure that the /Catalog folder has enough permissions to save files to.

Uploading Images

One more example of Image Uploader usage is an image gallery. Suppose, it requires a user to upload original images along with their downsized copies. This task can be divided into the same phases as the previous one.

Configuring Control

The configuration of the Image Uploader ASP.NET used for our image gallery is almost the same as for the file catalog described above.

ASP.NET

<%@ Page Language="C#" AutoEventWireup="true"  CodeFile="Default.aspx.cs" Inherits="_Default" %>
<%@ Register assembly="Aurigma.ImageUploader" Namespace="Aurigma.ImageUploader" tagprefix="aur" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title>Image Uploader ASP.NET Sample</title>
</head>
<body>
    <form id="form1" runat="server">
        <aur:Uploader ID="Uploader1" runat="server"
                Height="480px" Width="650px"
                AutoSave="true"
                DestinationFolder="~/Gallery"
                LicenseKey="XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY">
            <UploadSettings RedirectUrl="gallery.aspx" />
            <Converters>
                <aur:Converter Mode="*.*=SourceFile" />
                <aur:Converter Mode="*.*=Thumbnail"
                               ThumbnailHeight="120"
                               ThumbnailWidth="120"
                               ThumbnailFitMode="Fit" />
            </Converters>
        </aur:Uploader>
    </form>
</body>
</html>

The difference is that we set an additional converter to specify a thumbnail which will be created for each image file and will be fitted to 120x120 pixels. Read more about converters in the Configuring Files to be Uploaded topic.

Handling Upload

The gallery uses the autosave feature as well as the file catalog. So it releases you from necessary to handle the upload by yourself.

Pay attention that the names of files stored in the destination folder are not equal to the original filenames. Each name has a suffix corresponding to the converter used to create this file (except for the SourceFile one). In our sample we set two converters, that is why there are two files stored for each user-selected file:

  • name.ext, the original file specified with the first converter
  • name.ext_Thumbnail1.jpg, a downsized copy of the original image configured with the second converter

See the ConvertedFile.Name property description for a full list of possible suffixes.

Displaying Uploaded Images

On the configuring step we specified the UploadSettings.RedirectUrl property to the "gallery.aspx" value. It means that Image Uploader will redirect users to this page after the upload successfully completes. So, it would be convenient to display uploaded images here. To implement this functionality we iterate through all the files stored in the destination folder and display each thumbnail (file with _Thumbnail1 suffix) as a link to its original image (no suffix). See comments in the source code below.

gallery.aspx:

ASP.NET

<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Gallery.aspx.cs" Inherits="Gallery" %>
<%@ Import Namespace="System.Collections.Generic" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head id="Head1" runat="server">
    <title>Gallery</title>
</head>
<body>
    <asp:DataList ID="DataList1" Width="100%" RepeatLayout="Table" RepeatDirection="Vertical"
        RepeatColumns="4" runat="server">
        <HeaderTemplate></HeaderTemplate>
        <ItemTemplate>
            <a href="<%# galleryPath + ((KeyValuePair<string, string>)Container.DataItem).Key %>" target="_blank">
                <img src="<%# galleryPath + ((KeyValuePair<string, string>)Container.DataItem).Value %>" />
            </a>
        </ItemTemplate>
        <FooterTemplate></FooterTemplate>
    </asp:DataList>
</body>
</html>

gallery.aspx.cs:

C#

public partial class Gallery : System.Web.UI.Page
{
    protected string galleryPath;

    protected void Page_Load(object sender, EventArgs e)
    {
        galleryPath = "Gallery/";
        System.IO.DirectoryInfo dir = new System.IO.DirectoryInfo(Server.MapPath(galleryPath));
        //A key-value pair collection. Key - name of the original file, value - thumbnail filename
        System.Collections.Generic.Dictionary<string, string> files =
            new System.Collections.Generic.Dictionary<string, string>();

        //Iterate through all files
        foreach (System.IO.FileInfo file in dir.GetFiles())
        {
            int pos = file.Name.IndexOf("_Thumbnail1");
            //The file is not a thumbnail, so it is a source file
            if (pos == -1)
            {
                //Construct name of the corresponded thumbnail
                string thumbnailName = file.Name + "_Thumbnail1.jpg";
                //Check if this thumbnail exists
                if (System.IO.File.Exists(dir.FullName + thumbnailName))
                {
                    files.Add(file.Name, thumbnailName);
                }
            }
        }

        DataList1.DataSource = files;
        DataList1.DataBind();
    }
}
Note

You may run this image gallery application on your server. To do it, just paste source code to default.aspx, gallery.aspx, and gallery.aspx.cs files to your server using the following folder structure:

/bin
    Aurigma.ImageUploader.dll
/Gallery
default.aspx
gallery.aspx
gallery.aspx.cs

Make sure that /Gallery folder has enough permissions to save files to.

See Also

Reference

  • Image Uploader ASP.NET Reference
  • Uploader Class

Manual

  • Configuring Files to be Uploaded
  • Evaluating and Registering Image Uploader
  • Installation and Deployment Notes
  • Saving Uploaded Files in ASP.NET


Upgrading from Image Uploader ASP.NET Control 6.x

Aurigma.ImageUploader Namespace

BackgroundImageFormat Class

This class is replaced by BackgroundImageFormat.

BaseControl Class

Properties

 | Old Member | New Member
public property | ActiveXControlCabFileName | BaseClientControl.CodeBase
public property | ActiveXControlClassId | ActiveXControl.ClassId
public property | ActiveXControlEnabled | Eliminated.
public property | ActiveXControlProgId | ActiveXControl.ProgId
public property | ActiveXControlUseCustomCodeBase | BaseClientControl.UseCustomCodeBase
public property | ActiveXControlVersion | BaseClientControl.Version
public property | Height | Uploader.Height and Thumbnail.Height
public property | InstallationProgress | Eliminated. Use the InstallationProgress.TargetControlID instead.
public property | IUEmbedScriptUseCustomCodeBase | Eliminated. Use the BaseControl.RegisterClientScripts(String}) instead.
public property | JavaAppletClassName | JavaControl.ClassName
public property | JavaAppletEnabled | Eliminated.
public property | JavaAppletJarFileName | BaseClientControl.CodeBase
public property | JavaAppletUseCustomCodeBase | BaseClientControl.UseCustomCodeBase
public property | JavaAppletVersion | BaseClientControl.Version
public property | JavaScriptWriterVariableName | Eliminated.
public property | OnClientFullPageLoad | Eliminated. Use the BaseClientEvent.EventName = ClientEventNames.InitComplete or ThumbnailClientEventNames.InitComplete instead.
public property | OnClientInitWriter | Eliminated. Use the BaseClientEvent.EventName = ClientEventNames.PreRender or ThumbnailClientEventNames.PreRender instead.
public property | ScriptsDirectory | Eliminated. Use the BaseControl.RegisterClientScripts(IEnumerable) instead.
public property | Width | Uploader.Width and Thumbnail.Width

Methods

 | Old Member | New Member
public method | RegisterClientScripts | BaseControl.RegisterClientScripts(IEnumerable)

BaseExtender Class

This class is replaced by BaseExtender.

BaseFileInfo Class

This class is eliminated. Use the UploadedFile and ConvertedFile instead.

BaseImageUploaderExtender Class

Properties

 | Old Member | New Member
public method | ImageUploaderID | BaseUploaderExtender.TargetControlID

BaseMetaPropertyList Class

This class is eliminated. Use the Package.PackageFields instead.

ClientEventList Class

This class is eliminated. Use the BaseClientEvent(T) instead.

ExifList Class

This class is eliminated. Use the Package.PackageFields instead.

FileUploadEventArgs Class

This class is replaced by FileUploadedEventArgs.

Properties

 | Old Member | New Member
public property | Angle | UploadedFile.Angle
public property | Description | UploadedFile.Description
public property | Exif | Eliminated. Use the Package.PackageFields instead.
public property | FileCount | Package.PackageFileCount
public property | FileIndex | UploadedFile.Index
public property | FirstUploaded | Eliminated.
public property | Iptc | Eliminated. Use the Package.PackageFields instead.
public property | OriginalFileName | Eliminated. Use the UploadedFile.SourceName instead.
public property | PackageCount | Package.PackageCount
public property | PackageGuid | Package.PackageGuid
public property | PackageIndex | Package.PackageIndex
public property | RelativeFilePath | UploadedFile.RelativePath
public property | SourceFile | Eliminated. Use the UploadedFile.ConvertedFiles instead.
public property | Thumbnails | Eliminated. Use the UploadedFile.ConvertedFiles instead.

FontInfo Class

This class is replaced by FontFormat.

ImageFormat Class

This class is replaced by ImageFormat.

ImageUploader Class

Properties

 | Old Member | New Member
public property | Action | UploadSettings.ActionUrl
public property | AddFolderDialogButtonCancelText | AddFilesProgressDialog.CancelButtonText
public property | AddFolderDialogButtonSkipAllText | Eliminated.
public property | AddFolderDialogButtonSkipText | Eliminated.
public property | AddFolderDialogTitleText | AddFilesProgressDialog.TitleText
public property | AdditionalFormName | Metadata.AdditionalFormName
public property | AdvancedDetailsFailedItemBackgroundColor | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsGridLineColor | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsGridLineStyle | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsIdleItemBackgroundColor | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsInProcessItemBackgroundColor | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsPreviewThumbnailSize | Eliminated. The AdvancedDetails view is not supported any more.
public property | AllowAutoRotate | Uploader.EnableAutoRotation
public property | AllowCmykImages | Restrictions.EnableCmyk
public property | AllowDisproportionalExifThumbnails | PaneItem.EnableDisproportionalExifThumbnails
public property | AllowFolderUpload | Eliminated. Use the Uploader.FolderProcessingMode instead.
public property | AllowLargePreview | Eliminated. Use the Uploader.EnableImageEditor instead.
public property | AllowMultipleRemove | Eliminated. Multiple removal is enabled by default.
public property | AllowMultipleRotate | Eliminated. Multiple rotation is enabled if Uploader.EnableRotation is true.
public property | AllowMultipleSelection | Eliminated. Multiple selection is enabled by default.
public property | AllowRotate | Uploader.EnableRotation
public property | AllowTreePaneWidthChange | Eliminated. The tree pane is resizable by default.
public property | AuthenticationRequestBasicText | Eliminated. Use the AuthenticationDialog.Text instead.
public property | AuthenticationRequestButtonCancelText | AuthenticationDialog.CancelButtonText
public property | AuthenticationRequestButtonOkText | AuthenticationDialog.OkButtonText
public property | AuthenticationRequestDomainText | Eliminated.
public property | AuthenticationRequestLoginText | AuthenticationDialog.LoginText
public property | AuthenticationRequestNtlmText | Eliminated. Use the AuthenticationDialog.Text instead.
public property | AuthenticationRequestPasswordText | AuthenticationDialog.PasswordText
public property | AuthenticationType | Eliminated.
public property | AutoRecoverMaxTriesCount | UploadSettings.AutoRecoveryMaxAttemptCount
public property | AutoRecoverTimeOut | UploadSettings.AutoRecoveryTimeout
public property | BackgroundColor | Uploader.BackgroundColor
public property | ButtonAddAllToUploadListImageFormat | Eliminated. The Add All button was removed from Image Uploader GUI.
public property | ButtonAddAllToUploadListText | Eliminated. The Add All button was removed from Image Uploader GUI.
public property | ButtonAddFilesImageFormat | Eliminated. The Add Files button was removed from Image Uploader GUI.
public property | ButtonAddFilesText | Eliminated. The Add Files button was removed from Image Uploader GUI.
public property | ButtonAddFoldersImageFormat | Eliminated. The Add Folders button was removed from Image Uploader GUI.
public property | ButtonAddFoldersText | Eliminated. The Add Folders button was removed from Image Uploader GUI.
public property | ButtonAddToUploadListImageFormat | Eliminated. The Add button was removed from Image Uploader GUI.
public property | ButtonAddToUploadListText | Eliminated. The Add button was removed from Image Uploader GUI.
public property | ButtonAdvancedDetailsCancelImageFormat | Eliminated. The AdvancedDetails view is not supported any more.
public property | ButtonAdvancedDetailsCancelText | Eliminated. The AdvancedDetails view is not supported any more.
public property | ButtonCheckAllImageFormat | Eliminated. The Check All button was removed from Image Uploader GUI.
public property | ButtonCheckAllText | Eliminated. The Check All button was removed from Image Uploader GUI.
public property | ButtonDeleteFilesImageFormat | Eliminated. The Delete button was removed from Image Uploader GUI.
public property | ButtonDeleteFilesText | Eliminated. The Delete button was removed from Image Uploader GUI.
public property | ButtonDeselectAllImageFormat | Eliminated. The Deselect All button was removed from Image Uploader GUI.
public property | ButtonDeselectAllText | Eliminated. The Deselect All button was removed from Image Uploader GUI.
public property | ButtonFont | Eliminated. Use the Uploader.PaneFont instead.
public property | ButtonPasteImageFormat | Eliminated. The Paste button was removed from Image Uploader GUI.
public property | ButtonPasteText | Eliminated.The Paste button was removed from Image Uploader GUI.
public property | ButtonRemoveAllFromUploadListImageFormat | Eliminated. The Remove All button was removed from Image Uploader GUI.
public property | ButtonRemoveAllFromUploadListText | Eliminated. The Remove All button was removed from Image Uploader GUI.
public property | ButtonRemoveFromUploadListImageFormat | Eliminated. The Remove button was removed from Image Uploader GUI.
public property | ButtonRemoveFromUploadListText | Eliminated. The Remove button was removed from Image Uploader GUI.
public property | ButtonSelectAllImageFormat | Eliminated. The Select All button was removed from Image Uploader GUI.
public property | ButtonSelectAllText | Eliminated. The Select All button was removed from Image Uploader GUI.
public property | ButtonSendImageFormat | Uploader.UploadButtonImageFormat
public property | ButtonSendText | Uploader.UploadButtonText
public property | ButtonStopImageFormat | Uploader.CancelUploadButtonImageFormat
public property | ButtonStopText | Uploader.CancelUploadButtonText
public property | ButtonUncheckAllImageFormat | Eliminated. The Uncheck All button was removed from Image Uploader GUI.
public property | ButtonUncheckAllText | Eliminated. The Uncheck All button was removed from Image Uploader GUI.
public property | CacheGuiGraphics | Eliminated.
public property | Charset | UploadSettings.Charset
public property | CheckFilesBySelectAllButton | Eliminated. Buttons Check All/Uncheck All and Select All/Deselect All were removed from Image Uploader GUI.
public property | CmykImagesAreNotAllowedText | Eliminated. Denied files are not maked in the folder pane. Use the Messages.CmykImagesNotAllowed to specify an error message and tooltip.
public property | DeleteFilesDialogTitleText | DeleteFilesDialog.TitleText
public property | DeleteSelectedFilesDialogMessageText | Eliminated. Selected files cannot be deleted via Image Uploader.
public property | DeleteUploadedFiles | Uploader.EnableOriginalFilesDeletion
public property | DeleteUploadedFilesDialogMessageText | DeleteFilesDialog.Message
public property | DeniedFileMask | Restrictions.DeniedFileMask
public property | DescriptionEditorButtonCancelText | DescriptionEditor.CancelHyperlinkText
public property | DescriptionEditorButtonOkText | DescriptionEditor.SaveButtonText
public property | DescriptionsReadOnly | Eliminated.
public property | DescriptionTooltipText | Eliminated.
public property | DimensionsAreTooLargeText | Eliminated. Denied files are not maked in the folder pane. Use the Messages.DimensionsTooLarge to specify an error message and tooltip.
public property | DimensionsAreTooSmallText | Eliminated. Denied files are not maked in the folder pane. Use the Messages.DimensionsTooSmall to specify an error message and tooltip.
public property | DisplayNameActiveSelectedTextColor | PaneItem.SelectedTextColor
public property | DisplayNameActiveUnselectedTextColor | Uploader.TextColor
public property | DisplayNameInactiveSelectedTextColor | Eliminated. Use the SelectedTextColor instead.
public property | DisplayNameInactiveUnselectedTextColor | Eliminated. Use the Uploader.TextColor instead.
public property | DropFilesHereImageFormat | UploadPane.DropFilesHereImageFormat
public property | DropFilesHereText | UploadPane.DropFilesHereText
public property | EditDescriptionText | Eliminated.
public property | EditDescriptionTextColor | Eliminated.
public property | EditDescriptionTooltipText | Eliminated.
public property | EnableFileViewer | Uploader.EnableFileViewer
public property | EnableInstantUpload | UploadSettings.EnableInstantUpload
public property | EnableRemoveIcon | Eliminated. The removal icon is enabled by default.
public property | ErrorDeletingFilesDialogMessageText | Messages.DeletingFilesError
public property | ExtractExif | Metadata.Exif
public property | ExtractIptc | Metadata.Iptc
public property | FileIsTooLargeText | Eliminated. Denied files are not maked in the folder pane. Use the Messages.MaxFileSizeExceeded to specify an error message and tooltip.
public property | FileIsTooSmallText | Eliminated. Denied files are not maked in the folder pane. Use the Messages.FileSizeTooSmall to specify an error message and tooltip.
public property | FileMask | Restrictions.FileMask
public property | FilesPerOnePackageCount | UploadSettings.FilesPerPackage
public property | FolderPaneAllowRotate | Eliminated. Use the Uploader.EnableRotation instead.
public property | FolderPaneBackgroundColor | Eliminated. Use the Uploader.BackgroundColor instead.
public property | FolderPaneBorderStyle | Eliminated. Use the Uploader.BorderStyle instead.
public property | FolderPaneHeight | FolderPane.Height
public property | FolderPaneShowDescriptions | Eliminated. Use the Uploader.EnableDescriptionEditor instead.
public property | FolderPaneSortMode | FolderPane.SortMode
public property | FolderView | FolderPane.ViewMode
public property | GuiGraphicsVersion | Eliminated.
public property | HashAlgorithm | Metadata.Hash
public property | HoursText | UploadProgressDialog.HoursText
public property | IncludeSubfolders | Eliminated. Use the Uploader.FolderProcessingMode instead.
public property | IncludeSubfoldersText | Eliminated.
public property | IncorrectFileActiveSelectedTextColor | Eliminated. Incorrect files are hidden by default.
public property | IncorrectFileActiveUnselectedTextColor | Eliminated. Incorrect files are hidden by default.
public property | IncorrectFileInactiveSelectedTextColor | Eliminated. Incorrect files are hidden by default.
public property | IncorrectFileInactiveUnselectedTextColor | Eliminated. Incorrect files are hidden by default.
public property | IsRequestCompletelyReceived | Eliminated.
public property | KilobytesText | UploadProgressDialog.KilobytesText
public property | LargePreviewBackgroundColor | Eliminated. The large preview window was replaced by the Image Editor.
public property | LargePreviewGeneratingPreviewText | Eliminated. The large preview window was replaced by the Image Editor.
public property | LargePreviewHeight | Eliminated. The large preview window was replaced by the Image Editor.
public property | LargePreviewIconImageFormat | Eliminated. Use the PaneItem.ImageEditorIconImageFormat instead.
public property | LargePreviewIconTooltipText | Eliminated. Use the PaneItem.ImageEditorIconTooltip instead.
public property | LargePreviewNoPreviewAvailableText | Eliminated. The large preview window was replaced by the Image Editor.
public property | LargePreviewWidth | Eliminated. The large preview window was replaced by the Image Editor.
public property | LicenseKey | Uploader.LicenseKey
public property | ListColumnFileNameText | DetailsViewColumns.FileNameText
public property | ListColumnFileSizeText | DetailsViewColumns.FileSizeText
public property | ListColumnFileTypeText | DetailsViewColumns.FileTypeText
public property | ListColumnLastModifiedText | DetailsViewColumns.LastModifiedText
public property | ListKilobytesText | Eliminated. The kilobytes unit in the file size column of the Details view is always KB.
public property | LoadingFilesText | Uploader.LoadingFolderContentText
public property | LookAndFeel | Eliminated.
public property | MaxConnectionCount | Eliminated.
public property | MaxDescriptionTextLength | DescriptionEditor.MaxTextLength
public property | MaxFileCount | Restrictions.MaxFileCount
public property | MaxFileSize | Restrictions.MaxFileSize
public property | MaxImageHeight | Restrictions.MaxImageHeight
public property | MaxImageWidth | Restrictions.MaxImageWidth
public property | MaxTotalFileSize | Restrictions.MaxTotalFileSize
public property | MegabytesText | UploadProgressDialog.MegabytesText
public property | MenuAddAllToUploadListText | ContextMenu.CheckAllText
public property | MenuAddToUploadListText | ContextMenu.CheckText
public property | MenuArrangeByModifiedText | ContextMenu.ArrangeByModifiedText
public property | MenuArrangeByNameText | ContextMenu.ArrangeByNameText
public property | MenuArrangeByPathText | ContextMenu.ArrangeByPathText
public property | MenuArrangeBySizeText | ContextMenu.ArrangeBySizeText
public property | MenuArrangeByText | ContextMenu.ArrangeByText
public property | MenuArrangeByTypeText | ContextMenu.ArrangeByTypeText
public property | MenuArrangeByUnsortedText | Eliminated. Items are unsorted by default.
public property | MenuDeselectAllText | Eliminated. The Deselect All menu item was removed from Image Uploader GUI.
public property | MenuDetailsText | ContextMenu.DetailsViewText
public property | MenuIconsText | Eliminated. The Icon view mode is not supported any more.
public property | MenuInvertSelectionText | Eliminated. The Invert Selection menu item was removed from Image Uploader GUI.
public property | MenuListText | ContextMenu.ListViewText
public property | MenuRefreshText | Eliminated.
public property | MenuRemoveAllFromUploadListText | ContextMenu.RemoveAllText or ContextMenu.UncheckAllText depending on the selected layout.
public property | MenuRemoveFromUploadListText | ContextMenu.RemoveText or ContextMenu.UncheckText depending on the selected layout.
public property | MenuSelectAllText | Eliminated. The Select All menu item was removed from Image Uploader GUI.
public property | MenuThumbnailsText | ContextMenu.ThumbnailsViewText
public property | MessageBoxTitleText | Eliminated. Messages are displayed in the information bar instead of a message box.
public property | MessageCannotConnectToInternetText | Eliminated.
public property | MessageCmykImagesAreNotAllowedText | Messages.CmykImagesNotAllowed
public property | MessageDimensionsAreTooLargeText | Messages.DimensionsTooLarge
public property | MessageDimensionsAreTooSmallText | Messages.DimensionsTooSmall
public property | MessageFileSizeIsTooSmallText | Messages.FileSizeTooSmall
public property | MessageMaxFileCountExceededText | Messages.MaxFileCountExceeded
public property | MessageMaxFileSizeExceededText | Messages.MaxFileSizeExceeded
public property | MessageMaxTotalFileSizeExceededText | Eliminated.
public property | MessageNoInternetSessionWasEstablishedText | Eliminated.
public property | MessageNoResponseFromServerText | Messages.NoResponseFromServer
public property | MessageRetryOpenFolderText | Eliminated.
public property | MessageServerNotFoundText | Messages.ServerNotFound
public property | MessageSwitchAnotherFolderWarningText | Eliminated.
public property | MessageUnexpectedErrorText | Messages.UnexpectedError
public property | MessageUploadCancelledText | Messages.UploadCancelled
public property | MessageUploadCompleteText | Messages.UploadCompleted
public property | MessageUploadFailedText | Messages.UploadFailed
public property | MessageUserSpecifiedTimeoutHasExpiredText | Eliminated.
public property | MetaDataSeparator | Metadata.ValueSeparator
public property | MinFileCount | Restrictions.MinFileCount
public property | MinFileSize | Restrictions.MinFileSize
public property | MinImageHeight | Restrictions.MinImageHeight
public property | MinImageWidth | Restrictions.MinImageWidth
public property | MinutesText | UploadProgressDialog.MinutesText
public property | OnClientAfterUpload | Eliminated. Use the ClientEvent.EventName = AfterUpload instead.
public property | OnClientBeforeUpload | Eliminated. Use the ClientEvent.EventName = BeforeUpload instead.
public property | OnClientError | Eliminated. Use the ClientEvent.EventName = Error instead.
public property | OnClientFolderChange | Eliminated. Use the ClientEvent.EventName = FolderChange instead.
public property | OnClientInitComplete | Eliminated. Use the ClientEvent.EventName = InitComplete instead.
public property | OnClientPackageBeforeUpload | Eliminated. Use the ClientEvent.EventName = BeforePackageUpload instead.
public property | OnClientPackageComplete | Eliminated. Use the ClientEvent.EventName = AfterPackageUpload instead.
public property | OnClientPackageError | Eliminated. Use the ClientEvent.EventName = Error instead.
public property | OnClientPackageProgress | Eliminated. Use the ClientEvent.EventName = Progress instead.
public property | OnClientPaneResize | Eliminated.
public property | OnClientProgress | Eliminated. Use the ClientEvent.EventName = Progress instead.
public property | OnClientSelectionChange | Eliminated. Use the ClientEvent.EventName = SelectionChange instead.
public property | OnClientSortModeChange | Eliminated.
public property | OnClientUploadFileCountChange | Eliminated. Use the ClientEvent.EventName = UploadFileCountChange instead.
public property | OnClientViewChange | Eliminated. Use the ClientEvent.EventName = ViewChange instead.
public property | PaneBackgroundColor | Eliminated. Use the Uploader.BackgroundColor instead.
public property | PaneFont | Uploader.PaneFont
public property | PaneLayout | Uploader.PaneLayout
public property | PasteFileNameTemplate | Uploader.PasteFileNameTemplate
public property | PostFormat | Eliminated.
public property | PreserveHttpCookies | Eliminated. Image Uploader ASP.NET preserves HTTP-only cookies by default.
public property | PreviewThumbnailActiveDropHighlightedColor | Eliminated.
public property | PreviewThumbnailActiveSelectionColor | Eliminated. Use the PaneItem.SelectionColor and PaneItem.SelectionHoverColor instead.
public property | PreviewThumbnailBorderColor | Eliminated. Use the PaneItem.SelectionBorderColor and PaneItem.InactiveSelectionBorderColor instead.
public property | PreviewThumbnailBorderHoverColor | Eliminated. Use the PaneItem.HoverBorderColor and PaneItem.SelectionHoverBorderColor instead.
public property | PreviewThumbnailInactiveDropHighlightedColor | Eliminated.
public property | PreviewThumbnailInactiveSelectionColor | Eliminated. Use the PaneItem.InactiveSelectionColor and PaneItem.HoverColor instead.
public property | PreviewThumbnailResizeQuality | PaneItem.PreviewQuality
public property | PreviewThumbnailSize | Eliminated. Use the FolderPane.PreviewSize and UploadPane.PreviewSize instead.
public property | ProgressDialogCancelButtonText | UploadProgressDialog.CancelUploadButtonText
public property | ProgressDialogCloseButtonText | Eliminated.
public property | ProgressDialogCloseWhenUploadCompletesText | Eliminated.
public property | ProgressDialogEstimatedTimeText | UploadProgressDialog.EstimationText
public property | ProgressDialogPreparingDataText | Eliminated.
public property | ProgressDialogPreviewThumbnailSize | Eliminated.
public property | ProgressDialogSentText | UploadProgressDialog.InfoText
public property | ProgressDialogTitleText | UploadProgressDialog.TitleText
public property | ProgressDialogWaitingForResponseFromServerText | Eliminated.
public property | ProgressDialogWaitingForRetryText | Eliminated.
public property | ProgressDialogWidth | Eliminated.
public property | QualityMeterAcceptableQualityColor | QualityMeter.AcceptableQualityColor
public property | QualityMeterBackgroundColor | QualityMeter.BackgroundColor
public property | QualityMeterBorderColor | QualityMeter.BorderColor
public property | QualityMeterFormats | QualityMeter.Formats
public property | QualityMeterHeight | QualityMeter.Height
public property | QualityMeterHighQualityColor | QualityMeter.HighQualityColor
public property | QualityMeterLowQualityColor | QualityMeter.LowQualityColor
public property | RedirectUrl | UploadSettings.RedirectUrl
public property | RememberLastVisitedFolder | Eliminated. Image Uploader remembers the last visited folder by default.
public property | RemoveIconImageFormat | PaneItem.RemovalIconImageFormat
public property | RemoveIconTooltipText | PaneItem.RemovalIconTooltip
public property | RotateIconClockwiseImageFormat | PaneItem.RotationIconImageFormat
public property | RotateIconClockwiseTooltipText | PaneItem.RotationIconTooltip
public property | RotateIconCounterclockwiseImageFormat | Eliminated. Use the PaneItem.RotationIconImageFormat instead.
public property | RotateIconCounterclockwiseTooltipText | Eliminated. Use the PaneItem.RotationIconTooltip instaed.
public property | SecondsText | UploadProgressDialog.SecondsText
public property | SendDefaultFields | Eliminated. Use the metadata.enableAllStandardFields(Boolean) instead.
public property | ShowButtons | Eliminated.
public property | ShowContextMenu | Uploader.EnableContextMenu
public property | ShowDebugWindow | Eliminated.
public property | ShowDescriptions | Eliminated. Use the Uploader.EnableDescriptionEditor instead.
public property | ShowFileNames | PaneItem.ShowFileNameInThumbnailsView
public property | ShowSubfolders | Eliminated. Use the Uploader.FolderProcessingMode instead.
public property | ShowUploadListButtons | Eliminated.
public property | SilentMode | Uploader.EnableUploadProgress
public property | SplitterLineColor | Eliminated. Use the Uploader.PanelBorderColor instead.
public property | SplitterLineStyle | Eliminated.
public property | ThumbnailHorizontalSpacing | Eliminated.
public property | ThumbnailVerticalSpacing | Eliminated.
public property | TimeFormat | UploadProgressDialog.TimeFormat
public property | TimeOut | UploadSettings.ConnectionTimeout
public property | TreePaneBackgroundColor | Eliminated. Use the Uploader.BackgroundColor instead.
public property | TreePaneBorderStyle | Eliminated. Use the Uploader.BorderStyle instead.
public property | TreePaneWidth | TreePane.Width
public property | UncheckUploadedFiles | Eliminated. Image Uploader removes files from the upload list after they are successfully uploaded, by default.
public property | UnixFileSystemRootText | TreePane.UnixFileSystemRootText
public property | UnixHomeDirectoryText | TreePane.UnixHomeDirectoryText
public property | UploadPaneAllowRotate | Eliminated. Use the Uploader.EnableRotation instead.
public property | UploadPaneBackgroundColor | Eliminated. Use the Uploader.BackgroundColor instead.
public property | UploadPaneBackgroundImageFormat | Eliminated.
public property | UploadPaneBorderStyle | Eliminated. Use the Uploader.BorderStyle instead.
public property | UploadPaneShowDescriptions | Eliminated. Use the Uploader.EnableDescriptionEditor instead.
public property | UploadPaneSortMode | UploadPane.SortMode
public property | UploadSourceFile | Eliminated. Use the Converter.Mode = SourceFile instead.
public property | UploadThumbnailXBackgroundColor | Converter.ThumbnailBgColor
public property | UploadThumbnailXCompressOversizedOnly | Converter.ThumbnailCompressOversizedOnly
public property | UploadThumbnailXCompressionMode | Converter.Mode
public property | UploadThumbnailXCopyExif | Converter.ThumbnailCopyExif
public property | UploadThumbnailXCopyIptc | Converter.ThumbnailCopyIptc
public property | UploadThumbnailXFitMode | Converter.ThumbnailFitMode
public property | UploadThumbnailXHeight | Converter.ThumbnailHeight
public property | UploadThumbnailXJpegQuality | Converter.ThumbnailJpegQuality
public property | UploadThumbnailXResizeQuality | Converter.ThumbnailResizeQuality
public property | UploadThumbnailXResolution | Converter.ThumbnailResolution
public property | UploadThumbnailXWatermark | Converter.ThumbnailWatermark
public property | UploadThumbnailXWidth | Converter.ThumbnailWidth
public property | UploadView | UploadPane.ViewMode
public property | UserAgent | Metadata.UserAgent
public property | UseSystemColors | Eliminated.

Events

 | Old Member | New Member
public event | FileUploaded | BaseUploadControl.FileUploaded

InstallationProgress Class

Properties

 | Old Member | New Member
public property | AltInstallerEnabled | Eliminated. Alternative instructions are not displayed by default. If you need to provide such instructions use the InstallationProgress.AltInstallerHtml.
public property | AltInstallerHtml | InstallationProgress.AltInstallerHtml
public property | AltInstallerUrl | Eliminated. If you need to provide a URL specify it in the InstallationProgress.AltInstallerHtml value.
public property | BeforeIE6XPSP2InstallJavaHtml | Eliminated.
public property | BeforeIE6XPSP2InstructionsHtml | InstallationProgress.BeforeIE6XPSP2InstructionsHtml
public property | BeforeIE6XPSP2ProgressHtml | InstallationProgress.BeforeIE6XPSP2ProgressHtml
public property | CommonHtml | InstallationProgress.CommonHtml
public property | CommonInstallJavaHtml | Eliminated. Use the InstallationProgress.InstallJavaHtml instead.
public property | IE6XPSP2InstallJavaHtml | Eliminated.
public property | IE6XPSP2InstructionsHtml | InstallationProgress.IE6XPSP2InstructionsHtml
public property | IE6XPSP2ProgressHtml | InstallationProgress.IE6XPSP2ProgressHtml
public property | IE7InstallJavaHtml | Eliminated.
public property | IE7InstructionsHtml | InstallationProgress.IE7InstructionsHtml
public property | IE7ProgressHtml | InstallationProgress.IE7ProgressHtml
public property | IE8InstructionsHtml | Eliminated.
public property | IE8InstructionsHtml | InstallationProgress.IE8InstructionsHtml
public property | IE8ProgressHtml | InstallationProgress.IE8ProgressHtml
public property | InstructionsCssClass | InstallationProgress.InstructionsCssClass
public property | JavaProgressHtml | Eliminated. Use the InstallationProgress.ProgressHtml instead.
public property | MacInstallJavaHtml | InstallationProgress.MacInstallJavaHtml
public property | MiscBrowsersInstallJavaHtml | InstallationProgress.InstallJavaHtml
public property | ProgressCssClass | InstallationProgress.ProgressCssClass
public property | ProgressHtml | InstallationProgress.ProgressHtml
public property | ProgressImageUrl | InstallationProgress.ProgressImageUrl
public property | UpdateInstructions | InstallationProgress.UpdateInstructions
public property | Visible | Eliminated. Use InstallationProgress.ShowDownloadingScreen and InstallationProgress.ShowInstallationScreen instead.

IptcList Class

This class is eliminated. Use the Package.PackageFields instead.

ShellComboBox Class

This class is eliminated.

SourceFileInfo Class

This class is eliminated. Use the UploadedFile instead.

Properties

 | Old Member | New Member
public property | CreatedDateTime | Eliminated. Use the UploadedFile.SourceCreatedDateTime or UploadedFile.SourceCreatedDateTimeLocal instead.
public property | FileSize | UploadedFile.SourceSize
public property | HashCodeMD2 | Eliminated. Hash values are available via Package.PackageFields by their names.
public property | HashCodeMD5 | Eliminated. Hash values are available via Package.PackageFields by their names.
public property | HashCodeSHA | Eliminated. Hash values are available via Package.PackageFields by their names.
public property | Height | UploadedFile.SourceHeight
public property | HorizontalResolution | UploadedFile.SourceXResolution
public property | ModifiedDateTime | Eliminated. Use the UploadedFile.SourceLastModifiedDateTime or UploadedFile.SourceLastModifiedDateTimeLocal instead.
public property | VerticalResolution | UploadedFile.SourceYResolution
public property | Width | UploadedFile.SourceWidth

Methods

 | Old Member | New Member
public method | ValidateHashCodeMD5 | Eliminated.
public method | ValidateHashCodeSHA | Eliminated.

Thumbnail Class

Properties

 | Old Member | New Member
public property | BackgroundColor | Thumbnail.BackgroundColor
public property | Guid | Thumbnail.Guid
public property | OnClientClick | Eliminated. Use the ThumbnailClientEvent.EventName = Click instead.
public property | OnClientInitComplete | Eliminated. Use the ThumbnailClientEvent.EventName = InitComplete instead.
public property | ParentControlName | Thumbnail.ParentControlName
public property | View | Eliminated.

ThumbnailInfo Class

This class is eliminated. Use the ConvertedFile instead.

Properties

 | Old Member | New Member
public property | CompressionMode | ConvertedFile.Mode
public property | FileSize | ConvertedFile.Size
public property | Height | ConvertedFile.Height
public property | Index | Eliminated.
public property | Succeeded | Eliminated.
public property | Width | ConvertedFile.Width

ThumbnailList Class

This class is eliminated. Use the ConvertedFileCollection instead.

ThumbnailListEnumerator Class

This class is eliminated.

UploadPane Class

This class is eliminated.

Enumerations

 | Old Member | New Member
public enumeration | AuthenticationType | Eliminated.
public enumeration | BackgroundPosition | BackgroundPosition
public enumeration | BorderStyle | BorderStyle
public enumeration | CompressionMode | Eliminated.
public enumeration | LineStyle | Eliminated.
public enumeration | PaneLayout | PaneLayoutMode
public enumeration | PostFormat | Eliminated.
public enumeration | ResizeQuality | ResizeQuality
public enumeration | SortMode | PaneSortMode
public enumeration | ThumbnailFallbackMode | Eliminated.
public enumeration | ThumbnailFitMode | ThumbnailFitMode
public enumeration | View | PaneViewMode

Aurigma.ImageUploader.AmazonS3 Namespace

AmazonS3Extender Class

Properties

 | Old Member | New Member
public property | AWSAccessKeyId | AmazonS3Extender.AWSAccessKeyId
public property | Bucket | AmazonS3Extender.Bucket
public property | BucketHostName | AmazonS3Extender.BucketHostName
public property | PolicyExpiration | AmazonS3Extender.PolicyExpiration
public property | SecretAccessKey | AmazonS3Extender.SecretAccessKey
public property | SourceFile | Eliminated. Use the AmazonS3Extender.Files instead.
public property | Thumbnail1 | Eliminated. Use the AmazonS3Extender.Files instead.
public property | Thumbnail2 | Eliminated. Use the AmazonS3Extender.Files instead.
public property | Thumbnail3 | Eliminated. Use the AmazonS3Extender.Files instead.

CustomMetaProperty Class

This class is replaced by CustomMetaProperty.

FileSettings Class

Properties

 | Old Member | New Member
public property | Acl | FileSettings.Acl
public property | Key | FileSettings.Key
public property | MaxContentLength | FileSettings.MaxFileSize
public property | MetaProperties | FileSettings.Meta
public property | MinContentLength | FileSettings.MinFileSize

MetaProperty Class

This class is replaced by MetaProperty.

PredefinedMetaProperty Class

This class is replaced by PredefinedMetaProperty.

Aurigma.ImageUploader.Nirvanix Namespace

NirvanixException Class

This class is replaced by NirvanixException.

NirvanixExtender Class

Properties

 | Old Member | New Member
public property | AppKey | NirvanixExtender.AppKey
public property | DestFolderPath | NirvanixExtender.DestFolderPath
public property | FileOverwrite | NirvanixExtender.FileOverwrite
public property | FirstByteExpiration | NirvanixExtender.FirstByteExpiration
public property | IpRestricted | NirvanixExtender.IpRestricted
public property | LastByteExpiration | NirvanixExtender.LastByteExpiration
public property | Password | NirvanixExtender.Password
public property | SizeBytes | NirvanixExtender.SizeBytes
public property | Username | NirvanixExtender.Username


Using Private-label Version of Image Uploader ASP.NET

When users download and install Image Uploader to the browser, they see the security dialog which asks whether they trust Aurigma, Inc. and want to install the control. However, if you prefer to display your company name instead of Aurigma. Inc., rename Image Uploader control, and sign it with your own digital signature you need to order a private-label version of Image Uploader. Additionally private-label versions can contain enhanced functionality not available in the standard version. If you need a private-label version of Image Uploader, please, contact our sales team at sales@aurigma.com.

Note

Private-lable versions are available in Image Uploader Premium only. See the Comparison of Image Uploader Editions topic for details.

This article describes how to use a private-label version of Image Uploader in ASP.NET application. The following approach is also useful when you upgrade .cab and .jar files obtained from Aurigma, Inc. without updating Image Uploader ASP.NET (Aurigma.ImageUploader.dll file) itself.

Walk through the following steps to configure the wrapper to launch private-label version of Image Uploader:

  1. Obtain *.cab and *.jar files as well as private-label embedding instructions from Aurigma, Inc. For example, you have got MyUploader.cab and MyUploader.jar files.
  2. Copy these files to any folder of your application.
  3. Add an ActiveXControl parameter to the Uploader control and configure it in the following way:
    1. Specify a path to MyUploader.cab file as a value of the CustomCodeBase property.
    2. Set the UseCustomCodeBase to true.
    3. Specify CLSID and PROGID of the ActiveX control as values of the ClassId and ProgId properties respectively.
  4. Add an Uploader.JavaControl parameter and configure it as follows:
    1. Specify a path to MyUploader.jar file as a value of the CustomCodeBase property.
    2. Set the UseCustomCodeBase to true.
    3. Specify Java applet class name with the ClassName property.

All the information you need to specify using these properties will be provided to you by Aurigma, Inc. If some parameters were not sent you should use default values.

The code sample below demonstrates how to implement this.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <ActiveXControl CustomCodeBase="MyUploader.cab" UseCustomCodeBase="True"
        ClassId="XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX" ProgId="MyCompany.MyUploader" />
    <JavaControl CustomCodeBase="MyUploader.jar" UseCustomCodeBase="True"
        ClassName="com.mycompany.myuploader.MyUploader.class" />
</aur:Uploader>

See Also

Reference

  • ActiveXControl Class
  • JavaControl Class

Manual

  • Quick Start with Image Uploader ASP.NET


Image Uploader PHP

This section contains the basic information necessary to know how to get started with Image Uploader PHP.

In This Section

Quick Start with Image Uploader PHP
Upgrading from Image Uploader PHP Library 6.x
Using Private-label Version of Image Uploader PHP


Quick Start with Image Uploader PHP

Image Uploader PHP is a collection of classes that are meant to make deployment of Image Uploader and handling uploaded data easier. Using this collection, PHP developers can work with Image Uploader in a usual way as with a common PHP object. Image Uploader PHP provides several advantages over a standard way of deployment described in the Quick Start with Image Uploader JavaScript article:

  • Simplification of the deployment process. You just initialize an Uploader object and call its render() method which automatically inserts Image Uploader onto a page.
  • Ability to process uploaded data without parsing it. Image Uploader PHP includes a number of classes which receive the uploaded data, parse it, and provide a typed access to this data.

Adding Library to Page

To add Image Uploader to a web page you just need to perform the following steps:

  1. Copy the /ImageUploaderPHP folder to an application. It can be found in Image Uploader installation folder (typically this is C:\Program Files\Aurigma\Image Uploader 7.0.11\PHPClasses\ImageUploaderPHP).

  2. Link the Uploader.class.php file with the page which will host Image Uploader.

    PHP

    <?php
    require_once "ImageUploaderPHP/Uploader.class.php";
?>

  3. Create new instance of the Uploader class. Then configure Image Uploader in the way described in the following sections. After you have initialized necessary parameters call the render() method which generates Image Uploader embedding code and writes it into the page.

    PHP

    <?php
    $uploader = new Uploader("Uploader1");

    //configure Image Uploader

    $uploader->render();
?>
    Note

    Call the render() method in the position of the page you want to insert Image Uploader into.

Uploading Files

Here we discuss how to use Image Uploader PHP by the example of a simple file catalog. Suppose the catalog requires to upload files of various types and displays links to download these files. To implement this we should configure an Uploader object and save uploaded files on a server. The sections below describe these steps in detail.

Configuring

To configure Image Uploader parameters you should set corresponding properties of the Uploader object. For example, the ID property specifies a unique identifier of the control.

Here is the source code of the main page of our catalog (index.php).

PHP

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title>Image Uploader PHP Sample</title>
</head>
<body>
    <?php
        require_once "ImageUploaderPHP/Uploader.class.php";

        // create Uploader object and specify its ID and size
        $uploader = new Uploader("Uploader1");
        $uploader->setWidth("650px");
        $uploader->setHeight("480px");

        // specify a license key
        $uploader->setLicenseKey("XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY");

        // configure upload settings
        $uploader->getUploadSettings()->setActionUrl("upload.php");
        $uploader->getUploadSettings()->setRedirectUrl("catalog.php");

        //configure uploaded files
        $converters = &$uploader->getConverters();
        // one converter for uploading source file
        $converter = new Converter();
        $converter->setMode("*.*=SourceFile");
        $converters[] = $converter;

        // render Uploader
        $uploader->render();
    ?>
</body>
</html>

On this page we host Image Uploader and configure it, namely, specify its ID and size, server upload script and the page to which the user will be redirected when the upload successfully completes. To configure Image Uploader to send original files we used the Uploader.Converters property which returns a set of Converter instances. Each instance specifies what will be uploaded (original file as is, thumbnail created from original image file, icon associated with original file, or original file compressed into ZIP archive) for each of the user-selected files. Since we need to upload original files only, we set one converter with the SourceFile mode. Read more about converters in the Configuring Files to be Uploaded topic.

One more significant property is Uploader.LicenseKey which specifies trial or full license key. If license key is not set Image Uploader will not send files (the exception is usage of uploader on localhost domain). See the Evaluating and Registering Image Uploader topic for details.

Note

All the parameters should be specified before the call to the render() method; otherwise, parameters added after it will be ignored.

Handling Upload

The uploaded data can be saved using the UploadHandler.saveFiles(string) method which saves all the received files to the specified folder. This method returns an array of full filenames of saved files. According to the catalog requirements, we store files set to upload by a user in /Catalog folder.

Here is the source code of the upload script (upload.php) used in our catalog.

PHP

<?php
require_once "ImageUploaderPHP/UploadHandler.class.php";

$uploadHandler = new UploadHandler();
$uploadHandler->saveFiles("Catalog/");
?>
Note

For versions of PHP earlier than 6.0 disable the magic_quotes_gpc directive in your php.ini file.

Displaying Uploaded Files

On the configuring step we specified the UploadSettings.RedirectUrl property to the "catalog.php" value. It means that Image Uploader will redirect users to this page after the upload successfully completes. So, it would be convenient to list links to the uploaded files here. To implement this functionality we iterate through all the files stored in the /Catalog folder and display a link to each of them. See the source code below.

PHP

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title>Catalog</title>
</head>
<body>
<?php
$catalogPath = "Catalog/";

//Open catalog directory
if (is_dir($catalogPath)) {
    if ($directory = opendir($catalogPath)) {
        //Iterate through all files
        while (($file = readdir($directory))){
            //Process files only
            if (!is_dir($file)){
                echo "<a href=\"$catalogPath$file\" target=\"_blank\">\n";
                echo "    $file\n";
                echo "</a><br />\n";
            }
        }
        closedir($directory);
    }
}
?>
</body>
</html>
Note

You may run the file catalog application considered here on your server. To do it, just paste source code to index.php, upload.php, and catalog.php files to your server using the following folder structure:

/Catalog
/ImageUploaderPHP
catalog.php
index.php
upload.php

Make sure that the /Catalog folder has enough permissions to save files to.

Uploading Images

One more example of Image Uploader usage is an image gallery. Suppose it requires a user to upload original images along with their downsized copies. This task can be divided on the same phases as the previous one.

Configuring

The configuration of the Uploader object used for our image gallery is almost the same as for the file catalog described above.

PHP

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title>Image Uploader PHP Sample</title>
</head>
<body>
    <?php
        require_once "ImageUploaderPHP/Uploader.class.php";

        // create Uploader object and specify its ID and size
        $uploader = new Uploader("Uploader1");
        $uploader->setWidth("650px");
        $uploader->setHeight("480px");

        // specify a license key
        $uploader->setLicenseKey("XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY");

        // configure upload settings
        $uploader->getUploadSettings()->setActionUrl("upload.php");
        $uploader->getUploadSettings()->setRedirectUrl("gallery.php");

        //configure uploaded files
        $converters = &$uploader->getConverters();
        // one converter for uploading source file
        $converter = new Converter();
        $converter->setMode("*.*=SourceFile");
        $converters[] = $converter;
        // and second - for uploading thumbnail
        $converter = new Converter();
        $converter->setMode("*.*=Thumbnail");
        // set thumbnail size
        $converter->setThumbnailWidth(120);
        $converter->setThumbnailHeight(120);
        $converter->setThumbnailFitMode("Fit");
        $converters[] = $converter;

        // render Uploader
        $uploader->render();
    ?>
</body>
</html>

The difference is that we set an additional converter to specify a thumbnail which will be created for each image file and will be fitted to 120x120 pixels. Read more about converters in the Configuring Files to be Uploaded topic.

Handling Upload

Here we use the UploadHandler.saveFiles(string) method to save uploaded files to the /Gallery folder, as it is demonstrated in upload.php source code below.

PHP

<?php
require_once "ImageUploaderPHP/UploadHandler.class.php";

$uploadHandler = new UploadHandler();
$uploadHandler->saveFiles("Gallery/");
?>

Pay attention that the names of files stored in the destination folder are not equal to the original filenames. Each name has a suffix corresponding to the converter used to create this file(except for the SourceFile one). In our sample we set two converters, that is why there are two files stored for each user-selected file:

  • name.ext, the original image specified with the first converter
  • name.ext_Thumbnail1.jpg, a downsized copy of the original image configured with the second converter

See the ConvertedFile.Name property description for a full list of possible suffixes.

Displaying Uploaded Images

On the configuring step we specified the UploadSettings.RedirectUrl property to the "gallery.php" value. It means that Image Uploader will redirect users to this page after the upload successfully completes. So, it would be convenient to display uploaded images here. To implement this functionality we iterate through all the files stored in the destination folder and display each thumbnail (file with _Thumbnail1 suffix) as a link to its original image (no suffix). See comments in the source code below.

PHP

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title>Gallery</title>
</head>
<body>
<?php
$galleryPath = "Gallery/";

//Open catalog directory
if (is_dir($galleryPath)) {
    if ($directory = opendir($galleryPath)) {
        //Iterate through all files
        while (($file = readdir($directory))){
            //Process files only
            if (!is_dir($file)){
                $pos = strpos($file, "_Thumbnail1");
                //The file is not a thumbnail, so it is a source file
                if ($pos == false){
                    //Construct name of the corresponded thumbnail
                    $thumbnailName = $file."_Thumbnail1.jpg";
                    //Check if this thumbnail exists
                    if (file_exists("$galleryPath$thumbnailName")){
                        echo "<a href=\"$galleryPath$file\" target=\"_blank\">\n";
                        echo "    <img src=\"$galleryPath$thumbnailName\" />\n";
                        echo "</a>    \n";
                    }
                }
            }
        }
        closedir($directory);
    }
}
?>
</body>
</html>
Note

You may run the image gallery application on your server. To do it, just paste source code to index.php, upload.php, and gallery.php files to your server using the following folder structure:

/Gallery
/ImageUploaderPHP
gallery.php
index.php
upload.php

Make sure that /Gallery folder has enough permissions to save files to.

See Also

Reference

  • Image Uploader PHP Reference
  • Uploader Class

Manual

  • Configuring Files to be Uploaded
  • Evaluating and Registering Image Uploader
  • Installation and Deployment Notes
  • Saving Uploaded Files in PHP


Upgrading from Image Uploader PHP Library 6.x

AmazonS3Extender Class

Properties

 | Old Member | New Member
public property | AWSAccessKeyId | AmazonS3Extender.AWSAccessKeyId
public property | Bucket | AmazonS3Extender.Bucket
public property | BucketHostName | AmazonS3Extender.BucketHostName
public property | PolicyExpiration | AmazonS3Extender.PolicyExpiration
public property | SecretAccessKey | AmazonS3Extender.SecretAccessKey
public property | SourceFile | Eliminated. Use the AmazonS3Extender.Files instead.
public property | Thumbnail1 | Eliminated. Use the AmazonS3Extender.Files instead.
public property | Thumbnail2 | Eliminated. Use the AmazonS3Extender.Files instead.
public property | Thumbnail3 | Eliminated. Use the AmazonS3Extender.Files instead.

BackgroundImageFormat Class

This class is replaced by BackgroundImageFormat.

BaseControl Class

Properties

 | Old Member | New Member
public property | ActiveXControlCabFileName | BaseClientControl.CodeBase
public property | ActiveXControlClassId | ActiveXControl.ClassId
public property | ActiveXControlEnabled | Eliminated.
public property | ActiveXControlProgId | ActiveXControl.ProgId
public property | ActiveXControlVersion | BaseClientControl.Version
public property | Height | Uploader.Height and Thumbnail.Height
public property | Id | BaseControl.ID
public property | InstallationProgress | Eliminated. Use the InstallationProgress(Uploader) instead.
public property | JavaAppletClassName | JavaControl.ClassName
public property | JavaAppletEnabled | Eliminated.
public property | JavaAppletJarFileName | BaseClientControl.CodeBase
public property | JavaAppletVersion | BaseClientControl.Version
public property | JavaScriptWriterVariableName | Eliminated.
public property | ScriptsDirectory | BaseControl.ScriptsDirectory
public property | Width | Uploader.Width and Thumbnail.Width
public property | ClientFullPageLoad | Eliminated.
public property | ClientInitWriter | Eliminated.

Methods

 | Old Member | New Member
public method | RegisterClientScripts | Eliminated. Use the BaseControl.ScriptsDirectory instead.

Events

 | Old Member | New Member
public event | ClientFullPageLoad | Eliminated. Use the ClientEvents.InitComplete or ThumbnailClientEvents.InitComplete instead.
public event | ClientInitWriter | Eliminated. Use the ClientEvents.PreRender or ThumbnailClientEvents.PreRender instead.

CustomMetaProperty Class

This class is eliminated. Use the FileSettings.Meta instead.

FileSettings Class

Properties

 | Old Member | New Member
public property | Acl | FileSettings.Acl
public property | Key | FileSettings.Key

Methods

 | Old Member | New Member
public method | addMetaProperty | Eliminated. Use the FileSettings.Meta instead.
public method | removeMetaProperty | Eliminated. Use the FileSettings.Meta instead.

ImageFormat Class

This class is replaced by ImageFormat

ImageUploader Class

Properties

 | Old Member | New Member
public property | Action | UploadSettings.ActionUrl
public property | AddFolderDialogButtonCancelText | AddFilesProgressDialog.CancelButtonText
public property | AddFolderDialogButtonSkipAllText | Eliminated.
public property | AddFolderDialogButtonSkipText | Eliminated.
public property | AddFolderDialogTitleText | AddFilesProgressDialog.TitleText
public property | AdditionalFormName | Metadata.AdditionalFormName
public property | AdvancedDetailsFailedItemBackgroundColor | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsGridLineColor | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsGridLineStyle | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsIdleItemBackgroundColor | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsInProcessItemBackgroundColor | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsPreviewThumbnailSize | Eliminated. The AdvancedDetails view is not supported any more.
public property | AllowAutoRotate | Uploader.EnableAutoRotation
public property | AllowCmykImages | Restrictions.EnableCmyk
public property | AllowDisproportionalExifThumbnails | PaneItem.EnableDisproportionalExifThumbnails
public property | AllowFolderUpload | Eliminated. Use the Uploader.FolderProcessingMode instead.
public property | AllowLargePreview | Eliminated. Use the Uploader.EnableImageEditor instead.
public property | AllowMultipleRemove | Eliminated. Multiple removal is enabled by default.
public property | AllowMultipleRotate | Eliminated. Multiple rotation is enabled if Uploader.EnableRotation is true.
public property | AllowMultipleSelection | Eliminated. Multiple selection is enabled by default.
public property | AllowRotate | Uploader.EnableRotation
public property | AllowTreePaneWidthChange | Eliminated. The tree pane is resizable by default.
public property | AuthenticationRequestBasicText | Eliminated. Use the AuthenticationDialog.Text instead.
public property | AuthenticationRequestButtonCancelText | AuthenticationDialog.CancelButtonText
public property | AuthenticationRequestButtonOkText | AuthenticationDialog.OkButtonText
public property | AuthenticationRequestDomainText | Eliminated.
public property | AuthenticationRequestLoginText | AuthenticationDialog.LoginText
public property | AuthenticationRequestNtlmText | Eliminated. Use the AuthenticationDialog.Text instead.
public property | AuthenticationRequestPasswordText | AuthenticationDialog.PasswordText
public property | AuthenticationType | Eliminated.
public property | AutoRecoverMaxTriesCount | UploadSettings.AutoRecoveryMaxAttemptCount
public property | AutoRecoverTimeOut | UploadSettings.AutoRecoveryTimeout
public property | BackgroundColor | Uploader.BackgroundColor
public property | ButtonAddAllToUploadListImageFormat | Eliminated. The Add All button was removed from Image Uploader GUI.
public property | ButtonAddAllToUploadListText | Eliminated. The Add All button was removed from Image Uploader GUI.
public property | ButtonAddFilesImageFormat | Eliminated. The Add Files button was removed from Image Uploader GUI.
public property | ButtonAddFilesText | Eliminated. The Add Files button was removed from Image Uploader GUI.
public property | ButtonAddFoldersImageFormat | Eliminated. The Add Folders button was removed from Image Uploader GUI.
public property | ButtonAddFoldersText | Eliminated. The Add Folders button was removed from Image Uploader GUI.
public property | ButtonAddToUploadListImageFormat | Eliminated. The Add button was removed from Image Uploader GUI.
public property | ButtonAddToUploadListText | Eliminated. The Add button was removed from Image Uploader GUI.
public property | ButtonAdvancedDetailsCancelImageFormat | Eliminated. The AdvancedDetails view is not supported any more.
public property | ButtonAdvancedDetailsCancelText | Eliminated. The AdvancedDetails view is not supported any more.
public property | ButtonCheckAllImageFormat | Eliminated. The Check All button was removed from Image Uploader GUI.
public property | ButtonCheckAllText | Eliminated. The Check All button was removed from Image Uploader GUI.
public property | ButtonDeleteFilesImageFormat | Eliminated. The Delete button was removed from Image Uploader GUI.
public property | ButtonDeleteFilesText | Eliminated. The Delete button was removed from Image Uploader GUI.
public property | ButtonDeselectAllImageFormat | Eliminated. The Deselect All button was removed from Image Uploader GUI.
public property | ButtonDeselectAllText | Eliminated. The Deselect All button was removed from Image Uploader GUI.
public property | ButtonFont | Eliminated. Use the Uploader.PaneFont instead.
public property | ButtonPasteImageFormat | Eliminated. The Paste button was removed from Image Uploader GUI.
public property | ButtonPasteText | Eliminated.The Paste button was removed from Image Uploader GUI.
public property | ButtonRemoveAllFromUploadListImageFormat | Eliminated. The Remove All button was removed from Image Uploader GUI.
public property | ButtonRemoveAllFromUploadListText | Eliminated. The Remove All button was removed from Image Uploader GUI.
public property | ButtonRemoveFromUploadListImageFormat | Eliminated. The Remove button was removed from Image Uploader GUI.
public property | ButtonRemoveFromUploadListText | Eliminated. The Remove button was removed from Image Uploader GUI.
public property | ButtonSelectAllImageFormat | Eliminated. The Select All button was removed from Image Uploader GUI.
public property | ButtonSelectAllText | Eliminated. The Select All button was removed from Image Uploader GUI.
public property | ButtonSendImageFormat | Uploader.UploadButtonImageFormat
public property | ButtonSendText | Uploader.UploadButtonText
public property | ButtonStopImageFormat | Uploader.CancelUploadButtonImageFormat
public property | ButtonStopText | Uploader.CancelUploadButtonText
public property | ButtonUncheckAllImageFormat | Eliminated. The Uncheck All button was removed from Image Uploader GUI.
public property | ButtonUncheckAllText | Eliminated. The Uncheck All button was removed from Image Uploader GUI.
public property | CacheGuiGraphics | Eliminated.
public property | Charset | UploadSettings.Charset
public property | CheckFilesBySelectAllButton | Eliminated. Buttons Check All/Uncheck All and Select All/Deselect All were removed from Image Uploader GUI.
public property | CmykImagesAreNotAllowedText | Eliminated. Denied files are not maked in the folder pane. Use the Messages.CmykImagesNotAllowed to specify an error message and tooltip.
public property | DeleteFilesDialogTitleText | DeleteFilesDialog.TitleText
public property | DeleteSelectedFilesDialogMessageText | Eliminated. Selected files cannot be deleted via Image Uploader.
public property | DeleteUploadedFiles | Uploader.EnableOriginalFilesDeletion
public property | DeleteUploadedFilesDialogMessageText | DeleteFilesDialog.Message
public property | DeniedFileMask | Restrictions.DeniedFileMask
public property | DescriptionEditorButtonCancelText | DescriptionEditor.CancelHyperlinkText
public property | DescriptionEditorButtonOkText | DescriptionEditor.SaveButtonText
public property | DescriptionsReadOnly | Eliminated.
public property | DescriptionTooltipText | Eliminated.
public property | DimensionsAreTooLargeText | Eliminated. Denied files are not maked in the folder pane. Use the Messages.DimensionsTooLarge to specify an error message and tooltip.
public property | DimensionsAreTooSmallText | Eliminated. Denied files are not maked in the folder pane. Use the Messages.DimensionsTooSmall to specify an error message and tooltip.
public property | DisplayNameActiveSelectedTextColor | PaneItem.SelectedTextColor
public property | DisplayNameActiveUnselectedTextColor | Uploader.TextColor
public property | DisplayNameInactiveSelectedTextColor | Eliminated. Use the SelectedTextColor instead.
public property | DisplayNameInactiveUnselectedTextColor | Eliminated. Use the Uploader.TextColor instead.
public property | DropFilesHereImageFormat | UploadPane.DropFilesHereImageFormat
public property | DropFilesHereText | UploadPane.DropFilesHereText
public property | EditDescriptionText | Eliminated.
public property | EditDescriptionTextColor | Eliminated.
public property | EditDescriptionTooltipText | Eliminated.
public property | EnableFileViewer | Uploader.EnableFileViewer
public property | EnableInstantUpload | UploadSettings.EnableInstantUpload
public property | EnableRemoveIcon | Eliminated. The removal icon is enabled by default.
public property | ErrorDeletingFilesDialogMessageText | Messages.DeletingFilesError
public property | ExtractExif | Metadata.Exif
public property | ExtractIptc | Metadata.Iptc
public property | FileIsTooLargeText | Eliminated. Denied files are not maked in the folder pane. Use the Messages.MaxFileSizeExceeded to specify an error message and tooltip.
public property | FileIsTooSmallText | Eliminated. Denied files are not maked in the folder pane. Use the Messages.FileSizeTooSmall to specify an error message and tooltip.
public property | FileMask | Restrictions.FileMask
public property | FilesPerOnePackageCount | UploadSettings.FilesPerPackage
public property | FolderPaneAllowRotate | Eliminated. Use the Uploader.EnableRotation instead.
public property | FolderPaneBackgroundColor | Eliminated. Use the Uploader.BackgroundColor instead.
public property | FolderPaneBorderStyle | Eliminated. Use the Uploader.BorderStyle instead.
public property | FolderPaneHeight | FolderPane.Height
public property | FolderPaneShowDescriptions | Eliminated. Use the Uploader.EnableDescriptionEditor instead.
public property | FolderPaneSortMode | FolderPane.SortMode
public property | FolderView | FolderPane.ViewMode
public property | GuiGraphicsVersion | Eliminated.
public property | HashAlgorithm | Metadata.Hash
public property | HoursText | UploadProgressDialog.HoursText
public property | IncludeSubfolders | Eliminated. Use the Uploader.FolderProcessingMode instead.
public property | IncludeSubfoldersText | Eliminated.
public property | IncorrectFileActiveSelectedTextColor | Eliminated. Incorrect files are hidden by default.
public property | IncorrectFileActiveUnselectedTextColor | Eliminated. Incorrect files are hidden by default.
public property | IncorrectFileInactiveSelectedTextColor | Eliminated. Incorrect files are hidden by default.
public property | IncorrectFileInactiveUnselectedTextColor | Eliminated. Incorrect files are hidden by default.
public property | KilobytesText | UploadProgressDialog.KilobytesText
public property | LargePreviewBackgroundColor | Eliminated. The large preview window was replaced by the Image Editor.
public property | LargePreviewGeneratingPreviewText | Eliminated. The large preview window was replaced by the Image Editor.
public property | LargePreviewHeight | Eliminated. The large preview window was replaced by the Image Editor.
public property | LargePreviewIconImageFormat | Eliminated. Use the PaneItem.ImageEditorIconImageFormat instead.
public property | LargePreviewIconTooltipText | Eliminated. Use the PaneItem.ImageEditorIconTooltip instead.
public property | LargePreviewNoPreviewAvailableText | Eliminated. The large preview window was replaced by the Image Editor.
public property | LargePreviewWidth | Eliminated. The large preview window was replaced by the Image Editor.
public property | LicenseKey | Uploader.LicenseKey
public property | ListColumnFileNameText | DetailsViewColumns.FileNameText
public property | ListColumnFileSizeText | DetailsViewColumns.FileSizeText
public property | ListColumnFileTypeText | DetailsViewColumns.FileTypeText
public property | ListColumnLastModifiedText | DetailsViewColumns.LastModifiedText
public property | ListKilobytesText | Eliminated. The kilobytes unit in the file size column of the Details view is always KB.
public property | LoadingFilesText | Uploader.LoadingFolderContentText
public property | LookAndFeel | Eliminated.
public property | MaxConnectionCount | Eliminated.
public property | MaxDescriptionTextLength | DescriptionEditor.MaxTextLength
public property | MaxFileCount | Restrictions.MaxFileCount
public property | MaxFileSize | Restrictions.MaxFileSize
public property | MaxImageHeight | Restrictions.MaxImageHeight
public property | MaxImageWidth | Restrictions.MaxImageWidth
public property | MaxTotalFileSize | Restrictions.MaxTotalFileSize
public property | MegabytesText | UploadProgressDialog.MegabytesText
public property | MenuAddAllToUploadListText | ContextMenu.CheckAllText
public property | MenuAddToUploadListText | ContextMenu.CheckText
public property | MenuArrangeByModifiedText | ContextMenu.ArrangeByModifiedText
public property | MenuArrangeByNameText | ContextMenu.ArrangeByNameText
public property | MenuArrangeByPathText | ContextMenu.ArrangeByPathText
public property | MenuArrangeBySizeText | ContextMenu.ArrangeBySizeText
public property | MenuArrangeByText | ContextMenu.ArrangeByText
public property | MenuArrangeByTypeText | ContextMenu.ArrangeByTypeText
public property | MenuArrangeByUnsortedText | Eliminated. Items are unsorted by default.
public property | MenuDeselectAllText | Eliminated. The Deselect All menu item was removed from Image Uploader GUI.
public property | MenuDetailsText | ContextMenu.DetailsViewText
public property | MenuIconsText | Eliminated. The Icon view mode is not supported any more.
public property | MenuInvertSelectionText | Eliminated. The Invert Selection menu item was removed from Image Uploader GUI.
public property | MenuListText | ContextMenu.ListViewText
public property | MenuRefreshText | Eliminated.
public property | MenuRemoveAllFromUploadListText | ContextMenu.RemoveAllText or ContextMenu.UncheckAllText depending on the selected layout.
public property | MenuRemoveFromUploadListText | ContextMenu.RemoveText or ContextMenu.UncheckText depending on the selected layout.
public property | MenuSelectAllText | Eliminated. The Select All menu item was removed from Image Uploader GUI.
public property | MenuThumbnailsText | ContextMenu.ThumbnailsViewText
public property | MessageBoxTitleText | Eliminated. Messages are displayed in the information bar instead of a message box.
public property | MessageCannotConnectToInternetText | Eliminated.
public property | MessageCmykImagesAreNotAllowedText | Messages.CmykImagesNotAllowed
public property | MessageDimensionsAreTooLargeText | Messages.DimensionsTooLarge
public property | MessageDimensionsAreTooSmallText | Messages.DimensionsTooSmall
public property | MessageFileSizeIsTooSmallText | Messages.FileSizeTooSmall
public property | MessageMaxFileCountExceededText | Messages.MaxFileCountExceeded
public property | MessageMaxFileSizeExceededText | Messages.MaxFileSizeExceeded
public property | MessageMaxTotalFileSizeExceededText | Eliminated.
public property | MessageNoInternetSessionWasEstablishedText | Eliminated.
public property | MessageNoResponseFromServerText | Messages.NoResponseFromServer
public property | MessageRetryOpenFolderText | Eliminated.
public property | MessageServerNotFoundText | Messages.ServerNotFound
public property | MessageSwitchAnotherFolderWarningText | Eliminated.
public property | MessageUnexpectedErrorText | Messages.UnexpectedError
public property | MessageUploadCancelledText | Messages.UploadCancelled
public property | MessageUploadCompleteText | Messages.UploadCompleted
public property | MessageUploadFailedText | Messages.UploadFailed
public property | MessageUserSpecifiedTimeoutHasExpiredText | Eliminated.
public property | MetaDataSeparator | Metadata.ValueSeparator
public property | MinFileCount | Restrictions.MinFileCount
public property | MinFileSize | Restrictions.MinFileSize
public property | MinImageHeight | Restrictions.MinImageHeight
public property | MinImageWidth | Restrictions.MinImageWidth
public property | MinutesText | UploadProgressDialog.MinutesText
public property | PaneBackgroundColor | Eliminated. Use the Uploader.BackgroundColor instead.
public property | PaneFont | Uploader.PaneFont
public property | PaneLayout | Uploader.PaneLayout
public property | PasteFileNameTemplate | Uploader.PasteFileNameTemplate
public property | PostFormat | Eliminated.
public property | PreserveHttpCookies | Eliminated. Image Uploader PHP preserves HTTP-only cookies by default.
public property | PreviewThumbnailActiveDropHighlightedColor | Eliminated.
public property | PreviewThumbnailActiveSelectionColor | Eliminated. Use the PaneItem.SelectionColor and PaneItem.SelectionHoverColor instead.
public property | PreviewThumbnailBorderColor | Eliminated. Use the PaneItem.SelectionBorderColor and PaneItem.InactiveSelectionBorderColor instead.
public property | PreviewThumbnailBorderHoverColor | Eliminated. Use the PaneItem.HoverBorderColor and PaneItem.SelectionHoverBorderColor instead.
public property | PreviewThumbnailInactiveDropHighlightedColor | Eliminated.
public property | PreviewThumbnailInactiveSelectionColor | Eliminated. Use the PaneItem.InactiveSelectionColor and PaneItem.HoverColor instead.
public property | PreviewThumbnailResizeQuality | PaneItem.PreviewQuality
public property | PreviewThumbnailSize | Eliminated. Use the FolderPane.PreviewSize and UploadPane.PreviewSize instead.
public property | ProgressDialogCancelButtonText | UploadProgressDialog.CancelUploadButtonText
public property | ProgressDialogCloseButtonText | Eliminated.
public property | ProgressDialogCloseWhenUploadCompletesText | Eliminated.
public property | ProgressDialogEstimatedTimeText | UploadProgressDialog.EstimationText
public property | ProgressDialogPreparingDataText | Eliminated.
public property | ProgressDialogPreviewThumbnailSize | Eliminated.
public property | ProgressDialogSentText | UploadProgressDialog.InfoText
public property | ProgressDialogTitleText | UploadProgressDialog.TitleText
public property | ProgressDialogWaitingForResponseFromServerText | Eliminated.
public property | ProgressDialogWaitingForRetryText | Eliminated.
public property | ProgressDialogWidth | Eliminated.
public property | QualityMeterAcceptableQualityColor | QualityMeter.AcceptableQualityColor
public property | QualityMeterBackgroundColor | QualityMeter.BackgroundColor
public property | QualityMeterBorderColor | QualityMeter.BorderColor
public property | QualityMeterFormats | QualityMeter.Formats
public property | QualityMeterHeight | QualityMeter.Height
public property | QualityMeterHighQualityColor | QualityMeter.HighQualityColor
public property | QualityMeterLowQualityColor | QualityMeter.LowQualityColor
public property | RedirectUrl | UploadSettings.RedirectUrl
public property | RememberLastVisitedFolder | Eliminated. Image Uploader remembers the last visited folder by default.
public property | RemoveIconImageFormat | PaneItem.RemovalIconImageFormat
public property | RemoveIconTooltipText | PaneItem.RemovalIconTooltip
public property | RotateIconClockwiseImageFormat | PaneItem.RotationIconImageFormat
public property | RotateIconClockwiseTooltipText | PaneItem.RotationIconTooltip
public property | RotateIconCounterclockwiseImageFormat | Eliminated. Use the PaneItem.RotationIconImageFormat instead.
public property | RotateIconCounterclockwiseTooltipText | Eliminated. Use the PaneItem.RotationIconTooltip instaed.
public property | SecondsText | UploadProgressDialog.SecondsText
public property | SendDefaultFields | Eliminated. Use the metadata.enableAllStandardFields(Boolean) instead.
public property | ShowButtons | Eliminated.
public property | ShowContextMenu | Uploader.EnableContextMenu
public property | ShowDebugWindow | Eliminated.
public property | ShowDescriptions | Eliminated. Use the Uploader.EnableDescriptionEditor instead.
public property | ShowFileNames | PaneItem.ShowFileNameInThumbnailsView
public property | ShowSubfolders | Eliminated. Use the Uploader.FolderProcessingMode instead.
public property | ShowUploadListButtons | Eliminated.
public property | SilentMode | Uploader.EnableUploadProgress
public property | SplitterLineColor | Eliminated. Use the Uploader.PanelBorderColor instead.
public property | SplitterLineStyle | Eliminated.
public property | ThumbnailHorizontalSpacing | Eliminated.
public property | ThumbnailVerticalSpacing | Eliminated.
public property | TimeFormat | UploadProgressDialog.TimeFormat
public property | TimeOut | UploadSettings.ConnectionTimeout
public property | TreePaneBackgroundColor | Eliminated. Use the Uploader.BackgroundColor instead.
public property | TreePaneBorderStyle | Eliminated. Use the Uploader.BorderStyle instead.
public property | TreePaneWidth | TreePane.Width
public property | UncheckUploadedFiles | Eliminated. Image Uploader removes files from the upload list after they are successfully uploaded, by default.
public property | UnixFileSystemRootText | TreePane.UnixFileSystemRootText
public property | UnixHomeDirectoryText | TreePane.UnixHomeDirectoryText
public property | UploadPaneAllowRotate | Eliminated. Use the Uploader.EnableRotation instead.
public property | UploadPaneBackgroundColor | Eliminated. Use the Uploader.BackgroundColor instead.
public property | UploadPaneBackgroundImageFormat | Eliminated.
public property | UploadPaneBorderStyle | Eliminated. Use the Uploader.BorderStyle instead.
public property | UploadPaneShowDescriptions | Eliminated. Use the Uploader.EnableDescriptionEditor instead.
public property | UploadPaneSortMode | UploadPane.SortMode
public property | UploadSourceFile | Eliminated. Use the Converter.Mode = SourceFile instead.
public property | UploadThumbnailXBackgroundColor | Converter.ThumbnailBgColor
public property | UploadThumbnailXCompressOversizedOnly | Converter.ThumbnailCompressOversizedOnly
public property | UploadThumbnailXCompressionMode | Converter.Mode
public property | UploadThumbnailXCopyExif | Converter.ThumbnailCopyExif
public property | UploadThumbnailXCopyIptc | Converter.ThumbnailCopyIptc
public property | UploadThumbnailXFitMode | Converter.ThumbnailFitMode
public property | UploadThumbnailXHeight | Converter.ThumbnailHeight
public property | UploadThumbnailXJpegQuality | Converter.ThumbnailJpegQuality
public property | UploadThumbnailXResizeQuality | Converter.ThumbnailResizeQuality
public property | UploadThumbnailXResolution | Converter.ThumbnailResolution
public property | UploadThumbnailXWatermark | Converter.ThumbnailWatermark
public property | UploadThumbnailXWidth | Converter.ThumbnailWidth
public property | UploadView | UploadPane.ViewMode
public property | UserAgent | Metadata.UserAgent
public property | UseSystemColors | Eliminated.

Methods

 | Old Member | New Member
public method | render | BaseControl.render()

Events

 | Old Member | New Member
public property | ClientAfterUpload | Eliminated. Use the ClientEvents.AfterUpload instead.
public property | ClientBeforeUpload | Eliminated. Use the ClientEvents.BeforeUpload instead.
public property | ClientError | Eliminated. Use the ClientEvents.Error instead.
public property | ClientFolderChange | Eliminated. Use the ClientEvents.FolderChange instead.
public property | ClientInitComplete | Eliminated. Use the ClientEvents.InitComplete instead.
public property | ClientPackageBeforeUpload | Eliminated. Use the ClientEvents.BeforePackageUpload instead.
public property | ClientPackageComplete | Eliminated. Use the ClientEvents.AfterPackageUpload instead.
public property | ClientPackageError | Eliminated. Use the ClientEvents.Error instead.
public property | ClientPackageProgress | Eliminated. Use the ClientEvents.Progress instead.
public property | ClientPaneResize | Eliminated.
public property | ClientProgress | Eliminated. Use the ClientEvents.Progress instead.
public property | ClientSelectionChange | Eliminated. Use the ClientEvents.SelectionChange instead.
public property | ClientSortModeChange | Eliminated.
public property | ClientUploadFileCountChange | Eliminated. Use the ClientEvents.UploadFileCountChange instead.
public property | ClientViewChange | Eliminated. Use the ClientEvents.ViewChange instead.

InstallationProgress Class

Properties

 | Old Member | New Member
public property | AltInstallerEnabled | Eliminated. Alternative instructions are not displayed by default. If you need to provide such instructions use the InstallationProgress.AltInstallerHtml.
public property | AltInstallerHtml | InstallationProgress.AltInstallerHtml
public property | AltInstallerUrl | Eliminated. If you need to provide a URL specify it in the InstallationProgress.AltInstallerHtml value.
public property | BeforeIE6XPSP2InstallJavaHtml | Eliminated.
public property | BeforeIE6XPSP2InstructionsHtml | InstallationProgress.BeforeIE6XPSP2InstructionsHtml
public property | BeforeIE6XPSP2ProgressHtml | InstallationProgress.BeforeIE6XPSP2ProgressHtml
public property | CommonHtml | InstallationProgress.CommonHtml
public property | CommonInstallJavaHtml | Eliminated. Use the InstallationProgress.InstallJavaHtml instead.
public property | IE6XPSP2InstallJavaHtml | Eliminated.
public property | IE6XPSP2InstructionsHtml | InstallationProgress.IE6XPSP2InstructionsHtml
public property | IE6XPSP2ProgressHtml | InstallationProgress.IE6XPSP2ProgressHtml
public property | IE7InstallJavaHtml | Eliminated.
public property | IE7InstructionsHtml | InstallationProgress.IE7InstructionsHtml
public property | IE7ProgressHtml | InstallationProgress.IE7ProgressHtml
public property | IE8InstructionsHtml | Eliminated.
public property | IE8InstructionsHtml | InstallationProgress.IE8InstructionsHtml
public property | IE8ProgressHtml | InstallationProgress.IE8ProgressHtml
public property | InstructionsCssClass | InstallationProgress.InstructionsCssClass
public property | JavaProgressHtml | Eliminated. Use the InstallationProgress.ProgressHtml instead.
public property | MacInstallJavaHtml | InstallationProgress.MacInstallJavaHtml
public property | MiscBrowsersInstallJavaHtml | InstallationProgress.InstallJavaHtml
public property | ProgressCssClass | InstallationProgress.ProgressCssClass
public property | ProgressHtml | InstallationProgress.ProgressHtml
public property | ProgressImageUrl | InstallationProgress.ProgressImageUrl
public property | UpdateInstructions | InstallationProgress.UpdateInstructions
public property | Visible | Eliminated. Use InstallationProgress.ShowDownloadingScreen and InstallationProgress.ShowInstallationScreen instead.

MetaProperty Class

This class is eliminated. Use the FileSettings.Meta instead.

NirvanixExtender Class

Properties

 | Old Member | New Member
public property | AppKey | NirvanixExtender.AppKey
public property | DestFolderPath | NirvanixExtender.DestFolderPath
public property | FileOverwrite | NirvanixExtender.FileOverwrite
public property | FirstByteExpiration | NirvanixExtender.FirstByteExpiration
public property | IpRestricted | NirvanixExtender.IpRestricted
public property | LastByteExpiration | NirvanixExtender.LastByteExpiration
public property | Password | NirvanixExtender.Password
public property | SizeBytes | NirvanixExtender.SizeBytes
public property | Username | NirvanixExtender.Username

PredefinedMetaProperty Class

This class is eliminated. Use the FileSettings.Meta instead.

ShellComboBox Class

This class is eliminated.

SourceFileInfo Class

Properties

 | Old Member | New Member
public property | ContentLength | Eliminated.
public property | ContentType | Eliminated.
public property | CreatedDateTime | Eliminated. Use the UploadedFile.SourceCreatedDateTime or UploadedFile.SourceCreatedDateTimeLocal instead.
public property | FileName | UploadedFile.SourceName
public property | FileSize | UploadedFile.SourceSize
public property | HashCodeMD2 | Eliminated. Hash values are available via Package.PackageFields by their names.
public property | HashCodeMD5 | Eliminated. Hash values are available via Package.PackageFields by their names.
public property | HashCodeSHA | Eliminated. Hash values are available via Package.PackageFields by their names.
public property | Height | UploadedFile.SourceHeight
public property | HorizontalResolution | UploadedFile.SourceXResolution
public property | ModifiedDateTime | Eliminated. Use the UploadedFile.SourceLastModifiedDateTime or UploadedFile.SourceLastModifiedDateTimeLocal instead.
public property | VerticalResolution | UploadedFile.SourceYResolution
public property | Width | UploadedFile.SourceWidth

Methods

 | Old Member | New Member
public method | getSafeFileName | Eliminated.
public method | save | Eliminated. Use the ConvertedFile.moveTo(string) instead.
public method | saveToFolder | Eliminated. Use the ConvertedFile.moveTo(string) instead.
public method | validateHashCodeMD5 | Eliminated.
public method | validateHashCodeSHA | Eliminated.

Thumbnail Class

Properties

 | Old Member | New Member
public property | BackgroundColor | Thumbnail.BackgroundColor
public property | Guid | Thumbnail.Guid
public property | ParentControlName | Thumbnail.ParentControlName
public property | View | Eliminated.

Methods

 | Old Member | New Member
public method | render | BaseControl.render()

Events

 | Old Member | New Member
public property | ClientClick | Eliminated. Use the ThumbnailClientEvents.Click instead.
public property | ClientInitComplete | Eliminated. Use the ThumbnailClientEvents.InitComplete instead.

ThumbnailInfo Class

Properties

 | Old Member | New Member
public property | CompressionMode | ConvertedFile.Mode
public property | ContentLength | Eliminated.
public property | ContentType | Eliminated.
public property | FileName | ConvertedFile.Name
public property | FileSize | ConvertedFile.Size
public property | Height | ConvertedFile.Height
public property | Index | Eliminated.
public property | Succeeded | Eliminated.
public property | Width | ConvertedFile.Width

Methods

 | Old Member | New Member
public method | getSafeFileName | Eliminated.
public method | save | Eliminated. Use the ConvertedFile.moveTo(string) instead.
public method | saveToFolder | Eliminated. Use the ConvertedFile.moveTo(string) instead.

UploadedFile Class

Properties

 | Old Member | New Member
public property | Angle | UploadedFile.Angle
public property | Description | UploadedFile.Description
public property | Exif | Eliminated. Use the Package.PackageFields instead.
public property | FileCount | Package.PackageFileCount
public property | FileIndex | UploadedFile.Index
public property | FirstUploaded | Eliminated.
public property | Iptc | Eliminated. Use the Package.PackageFields instead.
public property | OriginalFileName | Eliminated. Use the UploadedFile.SourceName instead.
public property | PackageCount | Package.PackageCount
public property | PackageGuid | Package.PackageGuid
public property | PackageIndex | Package.PackageIndex
public property | RelativeFilePath | UploadedFile.RelativePath
public property | SourceFile | Eliminated. Use the UploadedFile.ConvertedFiles instead.
public property | Thumbnails | Eliminated. Use the UploadedFile.ConvertedFiles instead.

UploadedFiles Class

Methods

 | Old Member | New Member
public method | isRequestCompletelyReceived | Eliminated.
public method | fetchNext | Eliminated. Use the UploadHandler.FileUploadedCallback instead.
public method | getAll | Eliminated. Use the UploadHandler.AllFilesUploadedCallback instead.
public method | moveFirst | Eliminated.

UploadPane Class

This class is eliminated.


Using Private-label Version of Image Uploader PHP

When users download and install Image Uploader to the browser, they see the security dialog which asks whether they trust Aurigma, Inc. and want to install the control. However, if you prefer to display your company name instead of Aurigma, Inc., rename Image Uploader control, and sign it with your own digital signature you need to order a private-label version of Image Uploader. Additionally private-label versions can contain enhanced functionality not available in the standard version. If you need a private-label version of Image Uploader, please, contact our sales team at sales@aurigma.com.

Note

Private-lable versions are available in Image Uploader Premium only. See the Comparison of Image Uploader Editions topic for details.

This article describes how to use a private-label version of Image Uploader in PHP application. The following approach is also useful when you upgrade .cab and .jar files obtained from Aurigma, Inc. without updating Image Uploader PHP (ImageUploaderPHP folder) itself.

Walk through the following steps to configure the wrapper to launch private-label version of Image Uploader:

  1. Obtain *.cab and *.jar files as well as private-label embedding instructions from Aurigma, Inc. For example, you have got MyUploader.cab and MyUploader.jar files.
  2. Copy these files to any folder of your application.
  3. Configure the ActiveXControl property to the Uploader control in the following way:
    1. Specify a path to MyUploader.cab file as a value of the CodeBase property.
    2. Specify CLSID and PROGID of the ActiveX control as values of the ClassId and ProgId properties respectively.
  4. Configure the Uploader.JavaControl property as follows:
    1. Specify a path to MyUploader.jar file as a value of the CodeBase property.
    2. Specify Java applet class name with the ClassName property.

All the information you need to specify using these properties will be provided to you by Aurigma, Inc. If some parameters were not sent you should use default values.

The code sample below demonstrates how to implement this.

PHP

$uploader = new Uploader("Uploader1");

$uploader->getActiveXControl()->setCodeBase("MyUploader.cab");
$uploader->getActiveXControl()->setClassId("XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX");
$uploader->getActiveXControl()->setProgId("MyCompany.MyUploader");

$uploader->getJavaControl()->setCodeBase("MyUploader.jar");
$uploader->getJavaControl()->setClassName("com.mycompany.myuploader.MyUploader.class");

$uploader->render();

See Also

Reference

  • ActiveXControl Class
  • JavaControl Class

Manual

  • Quick Start with Image Uploader PHP


Image Uploader JavaScript

This section contains the basic information necessary to know how to get started with Image Uploader JavaScript.

In This Section

Quick Start with Image Uploader JavaScript
Upgrading from Image Uploader 6.x
Using Private-label Version of Image Uploader JavaScript


Quick Start with Image Uploader JavaScript

Image Uploader JavaScript is a set of JavaScript classes intended to embed Image Uploader into a web page via <script type="text/javascript"> block. This JavaScript (aurigma.uploader.js) is a base for both Image Uploader ASP.NET and Image Uploader PHP. Using the JavaScript library is more complicated: it requires configuring Image Uploader parameters manually and does not provide facilities to handle uploaded data server-side. However, it is more flexible and can be used with any HTTP-compliant server platform (not only ASP.NET or PHP).

Adding Image Uploader to Page

To add Image Uploader to the page you just need to perform the following steps:

  1. Copy the /Scripts folder to your web application. It can be found in Image Uploader installation folder (typically this is C:\Program Files\Aurigma\Image Uploader 7.0.11\Scripts).

  2. Link the aurigma.uploader.js file with the page which will host Image Uploader.

    JavaScript

    <script type="text/javascript" src="Scripts/aurigma.uploader.js"></script>

  3. Add JavaScript block to the position where you want to insert Image Uploader. Here create a new instance of the uploader class and specify its identifier via the uploader.id parameter.

    JavaScript

    <script type="text/javascript">
var u = $au.uploader({
    id: 'Uploader1'

    // configure Image Uploader

});

u.writeHtml();
</script>

  4. Then configure it in the way described in the following sections and call the uploader.writeHtml() method.

    Note:

    As soon as you call the uploader.writeHtml(), all necessary HTML code is inserted into the page at the current position. Alternatively, you can get the string with appropriate HTML code using the uploader.getHtml() method, and write it to the necessary position manually (maybe with some modifications).

Uploading Files

Here we discuss how to use Image Uploader JavaScript by the example of a simple file catalog. Suppose that the catalog requires a user to upload files of various types and displays links to download these files. To implement this we should configure an uploader object and save uploaded files on a server. The sections below describe these steps in detail.

Configuring

To configure Image Uploader you should set properties of the uploader object. See the Image Uploader PHP Reference for the detailed information about available properties.

The properties accepting objects (such us uploader.uploadSettings or uploader.converters) should be specified in JSON format. Using this format you can also initialize all the uploader properties when creating it. Alternatively, you can use the uploader.set(Object) method which accepts a JSON formatted string containing one or several properties definition.

Here is the source code of the main page of our catalog:

JavaScript

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title>Image Uploader JavaScript Sample</title>
</head>
<body>
    <script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
    <script type="text/javascript">
    var u = $au.uploader({
        id: 'Uploader1',
        width: '650px',
        height: '480px',
        licenseKey: 'XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY',
        converters: [
            { mode: '*.*=SourceFile' }
        ],
        uploadSettings: {
            actionUrl: 'upload.aspx',
            redirectUrl: 'gallery.aspx'
        }
    });

    u.writeHtml();
    </script>
</body>
</html>

On this page we set a mandatory parameter—Image Uploader identifier, as well as optional parameters required by our file catalog. Here we specify server upload script and a page to which a user will be redirected when the upload successfully completes. To configure Image Uploader to send original files we used the uploader.converters property which accepts an array of converter objects. Each object specifies what will be uploaded (original file as is, thumbnail created from original image file, icon associated with original file, or original file compressed into ZIP archive) for each of the user-selected files. Since we need to upload original files only, we set a one converter with the SourceFile mode. Read more about converters in the Configuring Files to be Uploaded topic.

One more significant property is uploader.licenseKey which specifies trial or full license key. If license key is not set Image Uploader will not send files (the exception is usage of uploader on localhost domain). See the Evaluating and Registering Image Uploader topic for details.

Handling Upload

According to the catalog requirements we save original files to the /Catalog folder. The way to implement it depends on your server platform. Find the detailed instructions and code samples on how to save uploaded files in the Saving Uploaded Files in ASP.NET and Saving Uploaded Files in PHP articles.

Displaying Uploaded Files

On the configuring step we set the uploadSettings.redirectUrl property. It specifies a page to which Image Uploader will redirect users after the upload successfully completes. So, it would be convenient to list links to the uploaded files here. To implement this functionality we iterate through all the files stored in the /Catalog folder and display a link to each of them.

The script which generates this page depends on your server platform. For example, if you save uploaded files in ASP.NET, you can use the script listed in the Quick Start with Image Uploader ASP.NET topic. For PHP platform use the analogue from the Quick Start with Image Uploader PHP article.

Uploading Images

One more example of Image Uploader usage is an image gallery. Suppose, it requires a user to upload original images along with their downsized copies. This task can be divided into the same phases as the previous one.

Configuring

The configuration of the uploader object used for our image gallery is almost the same as for the file catalog described above.

JavaScript

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title>Image Uploader JavaScript Sample</title>
</head>
<body>
    <script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
    <script type="text/javascript">
    var u = $au.uploader({
        id: 'Uploader1',
        width: '650px',
        height: '480px',
        licenseKey: 'XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY',
        converters: [
            { mode: '*.*=SourceFile' },
            { mode: '*.*=Thumbnail;*.*=Icon', thumbnailFitMode: 'Fit', thumbnailWidth: '120', thumbnailHeight: '120' }
        ],
        uploadSettings: {
            actionUrl: 'upload.aspx',
            redirectUrl: 'gallery.aspx'
        }
    });

    u.writeHtml();
    </script>
</body>
</html>

The difference is that we set an additional converter to specify a thumbnail which will be created for each image file and will be fitted to 120x120 pixels. For non-image files this converter will send icons. Read more about converters in the Configuring Files to be Uploaded topic.

Handling Upload

The gallery stores original images and their thumbnails in /Gallery and /Gallery/Thumbnails folders respectively. The way to implement it depends on your server platform. Find the detailed instructions and code samples on how to save uploaded files in the Saving Uploaded Files in ASP.NET and Saving Uploaded Files in PHP articles.

Displaying Uploaded Files

On the configuring step we set the uploadSettings.redirectUrl property. It specifies a page to which Image Uploader will redirect users after the upload successfully completes. So, it would be convenient to display uploaded files here. To implement this functionality we iterate through all the previews stored in the /Gallery/Thumbnails folder and display each thumbnail as a link to its original image (original images are stored in the /Gallery folder).

The script which generates this page depends on your server platform. For example, if you save uploaded files in ASP.NET, you can use the script listed in the Quick Start with Image Uploader ASP.NET topic. For PHP platform use the analogue from the Quick Start with Image Uploader PHP article.

See Also

Reference

  • Image Uploader PHP Reference
  • uploader Class

Manual

  • Configuring Files to be Uploaded
  • Evaluating and Registering Image Uploader
  • Saving Uploaded Files in ASP.NET
  • Saving Uploaded Files in PHP


Upgrading from Image Uploader 6.x

Image Uploader API

ImageUploader Class

Properties

 | Old Member | New Member
Appearance Group
public property | AdvancedDetailsFailedItemBackgroundColor | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsGridLineColor | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsGridLineStyle | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsIdleItemBackgroundColor | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsInProcessItemBackgroundColor | Eliminated. The AdvancedDetails view is not supported any more.
public property | AdvancedDetailsPreviewThumbnailSize | Eliminated. The AdvancedDetails view is not supported any more.
public property | BackgroundColor | uploader.backgroundColor
public property | ButtonAddAllToUploadListImageFormat | Eliminated. The Add All button was removed from Image Uploader GUI.
public property | ButtonAddFilesImageFormat | Eliminated. The Add Files button was removed from Image Uploader GUI.
public property | ButtonAddFoldersImageFormat | Eliminated. The Add Folders button was removed from Image Uploader GUI.
public property | ButtonAddToUploadListImageFormat | Eliminated. The Add button was removed from Image Uploader GUI.
public property | ButtonAdvancedDetailsCancelImageFormat | Eliminated. The AdvancedDetails view is not supported any more.
public property | ButtonCheckAllImageFormat | Eliminated. The Check All button was removed from Image Uploader GUI.
public property | ButtonDeleteFilesImageFormat | Eliminated. The Delete button was removed from Image Uploader GUI.
public property | ButtonDeselectAllImageFormat | Eliminated. The Deselect All button was removed from Image Uploader GUI.
public property | ButtonFont | Eliminated. Use the uploader.paneFont instead.
public property | ButtonPasteImageFormat | Eliminated. The Paste button was removed from Image Uploader GUI.
public property | ButtonRemoveAllFromUploadListImageFormat | Eliminated. The Remove All button was removed from Image Uploader GUI.
public property | ButtonRemoveFromUploadListImageFormat | Eliminated. The Remove button was removed from Image Uploader GUI.
public property | ButtonSelectAllImageFormat | Eliminated. The Select All button was removed from Image Uploader GUI.
public property | ButtonSendImageFormat | uploader.uploadButtonImageFormat
public property | ButtonStopImageFormat | uploader.cancelUploadButtonImageFormat
public property | ButtonUncheckAllImageFormat | Eliminated. The Uncheck All button was removed from Image Uploader GUI.
public property | CacheGuiGraphics | Eliminated.
public property | DisplayNameActiveSelectedTextColor | paneItem.selectedTextColor
public property | DisplayNameActiveUnselectedTextColor | uploader.textColor
public property | DisplayNameInactiveSelectedTextColor | Eliminated. Use the paneItem.selectedTextColor instead.
public property | DisplayNameInactiveUnselectedTextColor | Eliminated. Use the uploader.textColor instead.
public property | DropFilesHereImageFormat | uploadPane.dropFilesHereImageFormat
public property | EditDescriptionTextColor | Eliminated.
public property | FolderPaneBackgroundColor | Eliminated. Use the uploader.backgroundColor instead.
public property | FolderPaneBorderStyle | Eliminated. Use the uploader.borderStyle instead.
public property | FolderPaneHeight | folderPane.height
public property | FolderView | folderPane.viewMode
public property | GuiGraphicsVersion | Eliminated.
public property | IncorrectFileActiveSelectedTextColor | Eliminated. Incorrect files are hidden by default.
public property | IncorrectFileActiveUnselectedTextColor | Eliminated. Incorrect files are hidden by default.
public property | IncorrectFileInactiveSelectedTextColor | Eliminated. Incorrect files are hidden by default.
public property | IncorrectFileInactiveUnselectedTextColor | Eliminated. Incorrect files are hidden by default.
public property | LargePreviewBackgroundColor | Eliminated. The large preview window was replaced by the Image Editor.
public property | LargePreviewHeight | Eliminated. The large preview window was replaced by the Image Editor.
public property | LargePreviewIconImageFormat | Eliminated. Use the paneItem.imageEditorIconImageFormat instead.
public property | LargePreviewWidth | Eliminated. The large preview window was replaced by the Image Editor.
public property | LookAndFeel | Eliminated.
public property | PaneBackgroundColor | Eliminated. Use the uploader.backgroundColor instead.
public property | PaneFont | uploader.paneFont
public property | PaneItemDesign | Eliminated.
public property | PaneLayout | uploader.paneLayout
public property | PreviewThumbnailActiveDropHighlightedColor | Eliminated.
public property | PreviewThumbnailActiveSelectionColor | Eliminated. Use the paneItem.selectionColor and paneItem.selectionHoverColor instead.
public property | PreviewThumbnailBorderColor | Eliminated. Use the paneItem.selectionBorderColor and paneItem.inactiveSelectionBorderColor instead.
public property | PreviewThumbnailBorderHoverColor | Eliminated. Use the paneItem.hoverBorderColor and paneItem.selectionHoverBorderColor instead.
public property | PreviewThumbnailInactiveDropHighlightedColor | Eliminated.
public property | PreviewThumbnailInactiveSelectionColor | Eliminated. Use the paneItem.inactiveSelectionColor and paneItem.hoverColor instead.
public property | PreviewThumbnailResizeQuality | paneItem.previewQuality
public property | PreviewThumbnailSize | Eliminated. Use the folderPane.previewSize and uploadPane.previewSize instead.
public property | ProgressDialogPreviewThumbnailSize | Eliminated.
public property | ProgressDialogWidth | Eliminated.
public property | QualityMeterAcceptableQualityColor | qualityMeter.acceptableQualityColor
public property | QualityMeterBackgroundColor | qualityMeter.backgroundColor
public property | QualityMeterBorderColor | qualityMeter.borderColor
public property | QualityMeterFormats | qualityMeter.formats
public property | QualityMeterHeight | qualityMeter.height
public property | QualityMeterHighQualityColor | qualityMeter.highQualityColor
public property | QualityMeterLowQualityColor | qualityMeter.lowQualityColor
public property | RemoveIconImageFormat | paneItem.removalIconImageFormat
public property | RotateIconClockwiseImageFormat | paneItem.rotationIconImageFormat
public property | RotateIconCounterclockwiseImageFormat | Eliminated. Use the paneItem.rotationIconImageFormat instead.
public property | ShowButtons | Eliminated.
public property | ShowUploadListButtons | Eliminated.
public property | SplitterLineColor | Eliminated. Use the uploader.panelBorderColor instead.
public property | SplitterLineStyle | Eliminated.
public property | ThumbnailHorizontalSpacing | Eliminated.
public property | ThumbnailVerticalSpacing | Eliminated.
public property | TimeFormat | uploadProgressDialog.timeFormat
public property | TreePaneBackgroundColor | Eliminated. Use the uploader.backgroundColor instead.
public property | TreePaneBorderStyle | Eliminated. Use the uploader.borderStyle instead.
public property | TreePaneWidth | treePane.width
public property | UploadPaneBackgroundColor | Eliminated. Use the uploader.backgroundColor instead.
public property | UploadPaneBackgroundImageFormat | Eliminated.
public property | UploadPaneBorderStyle | Eliminated. Use the uploader.borderStyle instead.
public property | UploadView | uploadPane.viewMode
public property | UseSystemColors | Eliminated.
 | Old Member | New Member
Behavior Group
public property | AllowAutoRotate | uploader.enableAutoRotation
public property | AllowCmykImages | restrictions.enableCmyk
public property | AllowDisproportionalExifThumbnails | paneItem.enableDisproportionalExifThumbnails
public property | AllowFolderUpload | Eliminated. Use the uploader.folderProcessingMode instead.
public property | AllowLargePreview | Eliminated. Use the uploader.enableImageEditor instead.
public property | AllowMultipleRemove | Eliminated. Multiple removal is enabled by default.
public property | AllowMultipleRotate | Eliminated. Multiple rotation is enabled if uploader.enableRotation is true.
public property | AllowMultipleSelection | Eliminated. Multiple selection is enabled by default.
public property | AllowRotate | uploader.enableRotation
public property | AllowTreePaneWidthChange | Eliminated. The tree pane is resizable by default.
public property | AuthenticationType | Eliminated.
public property | CheckFilesBySelectAllButton | Eliminated. Buttons Check All/Uncheck All and Select All/Deselect All were removed from Image Uploader GUI.
public property | DeleteUploadedFiles | uploader.enableOriginalFilesDeletion
public property | DeniedFileMask | restrictions.deniedFileMask
public property | DescriptionsReadOnly | Eliminated.
public property | EnableFileViewer | uploader.enableFileViewer
public property | EnableInstantUpload | uploadSettings.enableInstantUpload
public property | EnableRemoveIcon | Eliminated. The removal icon is enabled by default.
public property | FileMask | restrictions.fileMask
public property | FolderPaneAllowRotate | Eliminated. Use the uploader.enableRotation instead.
public property | FolderPaneShowDescriptions | Eliminated. Use the uploader.enableDescriptionEditor instead.
public property | FolderPaneSortMode | folderPane.sortMode
public property | IncludeSubfolders | Eliminated. Use the uploader.folderProcessingMode instead.
public property | JreVersion | Eliminated.
public property | LicenseKey | uploader.licenseKey
public property | MaxDescriptionTextLength | descriptionEditor.maxTextLength
public property | PaneItemCanBeUploaded | Eliminated.
public property | PaneItemChecked | Eliminated.
public property | PaneItemCount | Eliminated.
public property | PaneItemEnabled | Eliminated.
public property | PaneItemSelected | Eliminated.
public property | RedirectUrl | uploadSettings.redirectUrl
public property | RememberLastVisitedFolder | Eliminated. Image Uploader remembers the last visited folder by default.
public property | SendDefaultFields | Eliminated. Use the metadata.enableAllStandardFields(Boolean) instead.
public property | ShowContextMenu | uploader.enableContextMenu
public property | ShowDebugWindow | Eliminated.
public property | ShowDescriptions | Eliminated. Use the uploader.enableDescriptionEditor instead.
public property | ShowFileNames | paneItem.showFileNameInThumbnailsView
public property | ShowSubfolders | Eliminated. Use the uploader.folderProcessingMode instead.
public property | SilentMode | uploader.enableUploadProgress
public property | UncheckUploadedFiles | Eliminated. Image Uploader removes files from the upload list after they are successfully uploaded, by default.
public property | UploadPaneAllowRotate | Eliminated. Use the uploader.enableRotation instead.
public property | UploadPaneShowDescriptions | Eliminated. Use the uploader.enableDescriptionEditor instead.
public property | UploadPaneSortMode | uploadPane.sortMode
public property | Version | Eliminated. Use the activeXControl.actualVersion and javaControl.actualVersion instead.
 | Old Member | New Member
Text Group
public property | AddFolderDialogButtonCancelText | addFilesProgressDialog.cancelButtonText
public property | AddFolderDialogButtonSkipAllText | Eliminated.
public property | AddFolderDialogButtonSkipText | Eliminated.
public property | AddFolderDialogTitleText | addFilesProgressDialog.titleText
public property | AuthenticationRequestBasicText | Eliminated. Use the authenticationDialog.text instead.
public property | AuthenticationRequestButtonCancelText | authenticationDialog.cancelButtonText
public property | AuthenticationRequestButtonOkText | authenticationDialog.okButtonText
public property | AuthenticationRequestDomainText | Eliminated.
public property | AuthenticationRequestLoginText | authenticationDialog.loginText
public property | AuthenticationRequestNtlmText | Eliminated. Use the authenticationDialog.text instead.
public property | AuthenticationRequestPasswordText | authenticationDialog.passwordText
public property | ButtonAddAllToUploadListText | Eliminated. The Add All button was removed from Image Uploader GUI.
public property | ButtonAddFilesText | Eliminated. The Add Files button was removed from Image Uploader GUI.
public property | ButtonAddFoldersText | Eliminated. The Add Folders button was removed from Image Uploader GUI.
public property | ButtonAddToUploadListText | Eliminated. The Add button was removed from Image Uploader GUI.
public property | ButtonAdvancedDetailsCancelText | Eliminated. The AdvancedDetails view is not supported any more.
public property | ButtonCheckAllText | Eliminated. The Check All button was removed from Image Uploader GUI.
public property | ButtonDeleteFilesText | Eliminated. The Delete button was removed from Image Uploader GUI.
public property | ButtonDeselectAllText | Eliminated. The Deselect All button was removed from Image Uploader GUI.
public property | ButtonPasteText | Eliminated.The Paste button was removed from Image Uploader GUI.
public property | ButtonRemoveAllFromUploadListText | Eliminated. The Remove All button was removed from Image Uploader GUI.
public property | ButtonRemoveFromUploadListText | Eliminated. The Remove button was removed from Image Uploader GUI.
public property | ButtonSelectAllText | Eliminated. The Select All button was removed from Image Uploader GUI.
public property | ButtonSendText | uploader.uploadButtonText
public property | ButtonStopText | uploader.cancelUploadButtonText
public property | ButtonUncheckAllText | Eliminated. The Uncheck All button was removed from Image Uploader GUI.
public property | CmykImagesAreNotAllowedText | Eliminated. Denied files are not maked in the folder pane. Use the messages.cmykImagesNotAllowed to specify an error message and tooltip.
public property | DeleteFilesDialogTitleText | deleteFilesDialog.titleText
public property | DeleteSelectedFilesDialogMessageText | Eliminated. Selected files cannot be deleted via Image Uploader.
public property | DeleteUploadedFilesDialogMessageText | deleteFilesDialog.message
public property | DescriptionEditorButtonCancelText | descriptionEditor.cancelHyperlinkText
public property | DescriptionEditorButtonOkText | descriptionEditor.saveButtonText
public property | DescriptionTooltipText | Eliminated.
public property | DimensionsAreTooLargeText | Eliminated. Denied files are not maked in the folder pane. Use the messages.dimensionsTooLarge to specify an error message and tooltip.
public property | DimensionsAreTooSmallText | Eliminated. Denied files are not maked in the folder pane. Use the messages.dimensionsTooSmall to specify an error message and tooltip.
public property | DropFilesHereText | uploadPane.dropFilesHereText
public property | EditDescriptionText | Eliminated.
public property | EditDescriptionTooltipText | Eliminated.
public property | ErrorDeletingFilesDialogMessageText | messages.deletingFilesError
public property | FileIsTooLargeText | Eliminated. Denied files are not maked in the folder pane. Use the messages.maxFileSizeExceeded to specify an error message and tooltip.
public property | FileIsTooSmallText | Eliminated. Denied files are not maked in the folder pane. Use the messages.fileSizeTooSmall to specify an error message and tooltip.
public property | HoursText | uploadProgressDialog.hoursText
public property | IncludeSubfoldersText | Eliminated.
public property | KilobytesText | uploadProgressDialog.kilobytesText
public property | LargePreviewGeneratingPreviewText | Eliminated. The large preview window was replaced by the Image Editor.
public property | LargePreviewIconTooltipText | Eliminated. Use the paneItem.imageEditorIconTooltip instead.
public property | LargePreviewNoPreviewAvailableText | Eliminated. The large preview window was replaced by the Image Editor.
public property | ListColumnFileNameText | detailsViewColumns.fileNameText
public property | ListColumnFileSizeText | detailsViewColumns.fileSizeText
public property | ListColumnFileTypeText | detailsViewColumns.fileTypeText
public property | ListColumnLastModifiedText | detailsViewColumns.lastModifiedText
public property | ListKilobytesText | Eliminated. The kilobytes unit in the file size column of the Details view is always KB.
public property | LoadingFilesText | uploader.loadingFolderContentText
public property | MegabytesText | uploadProgressDialog.megabytesText
public property | MenuAddAllToUploadListText | contextMenu.checkAllText
public property | MenuAddToUploadListText | contextMenu.checkText
public property | MenuArrangeByModifiedText | contextMenu.arrangeByModifiedText
public property | MenuArrangeByNameText | contextMenu.arrangeByNameText
public property | MenuArrangeByPathText | contextMenu.arrangeByPathText
public property | MenuArrangeBySizeText | contextMenu.arrangeBySizeText
public property | MenuArrangeByText | contextMenu.arrangeByText
public property | MenuArrangeByTypeText | contextMenu.arrangeByTypeText
public property | MenuArrangeByUnsortedText | Eliminated. Items are unsorted by default.
public property | MenuDeselectAllText | Eliminated. The Deselect All menu item was removed from Image Uploader GUI.
public property | MenuDetailsText | contextMenu.detailsViewText
public property | MenuIconsText | Eliminated. The Icon view mode is not supported any more.
public property | MenuInvertSelectionText | Eliminated. The Invert Selection menu item was removed from Image Uploader GUI.
public property | MenuListText | contextMenu.listViewText
public property | MenuRefreshText | Eliminated.
public property | MenuRemoveAllFromUploadListText | contextMenu.removeAllText or contextMenu.uncheckAllText depending on the selected layout.
public property | MenuRemoveFromUploadListText | contextMenu.removeText or contextMenu.uncheckText depending on the selected layout.
public property | MenuSelectAllText | Eliminated. The Select All menu item was removed from Image Uploader GUI.
public property | MenuThumbnailsText | contextMenu.thumbnailsViewText
public property | MessageBoxTitleText | Eliminated. Messages are displayed in the information bar instead of a message box.
public property | MessageCannotConnectToInternetText | Eliminated.
public property | MessageCmykImagesAreNotAllowedText | messages.cmykImagesNotAllowed
public property | MessageDimensionsAreTooLargeText | messages.dimensionsTooLarge
public property | MessageDimensionsAreTooSmallText | messages.dimensionsTooSmall
public property | MessageFileSizeIsTooSmallText | messages.fileSizeTooSmall
public property | MessageMaxFileCountExceededText | messages.maxFileCountExceeded
public property | MessageMaxFileSizeExceededText | messages.maxFileSizeExceeded
public property | MessageMaxTotalFileSizeExceededText | Eliminated.
public property | MessageNoInternetSessionWasEstablishedText | Eliminated.
public property | MessageNoResponseFromServerText | messages.noResponseFromServer
public property | MessageRetryOpenFolderText | Eliminated.
public property | MessageServerNotFoundText | messages.serverNotFound
public property | MessageSwitchAnotherFolderWarningText | Eliminated.
public property | MessageUnexpectedErrorText | messages.unexpectedError
public property | MessageUploadCancelledText | messages.uploadCancelled
public property | MessageUploadCompleteText | messages.uploadCompleted
public property | MessageUploadFailedText | messages.uploadFailed
public property | MessageUserSpecifiedTimeoutHasExpiredText | Eliminated.
public property | MinutesText | uploadProgressDialog.minutesText
public property | ProgressDialogCancelButtonText | uploadProgressDialog.cancelUploadButtonText
public property | ProgressDialogCloseButtonText | Eliminated.
public property | ProgressDialogCloseWhenUploadCompletesText | Eliminated.
public property | ProgressDialogEstimatedTimeText | uploadProgressDialog.estimationText
public property | ProgressDialogPreparingDataText | Eliminated.
public property | ProgressDialogSentText | uploadProgressDialog.infoText
public property | ProgressDialogTitleText | uploadProgressDialog.titleText
public property | ProgressDialogWaitingForResponseFromServerText | Eliminated.
public property | ProgressDialogWaitingForRetryText | Eliminated.
public property | RemoveIconTooltipText | paneItem.removalIconTooltip
public property | RotateIconClockwiseTooltipText | paneItem.rotationIconTooltip
public property | RotateIconCounterclockwiseTooltipText | Eliminated. Use the paneItem.rotationIconTooltip instaed.
public property | SecondsText | uploadProgressDialog.secondsText
public property | UnixFileSystemRootText | treePane.unixFileSystemRootText
public property | UnixHomeDirectoryText | treePane.unixHomeDirectoryText
 | Old Member | New Member
Upload Group
public property | Action | uploadSettings.actionUrl
public property | AdditionalFormName | metadata.additionalFormName
public property | AutoRecoverMaxTriesCount | uploadSettings.autoRecoveryMaxAttemptCount
public property | AutoRecoverTimeOut | uploadSettings.autoRecoveryTimeout
public property | Charset | uploadSettings.charset
public property | CurrentConnectionId | Eliminated.
public property | ExtractExif | metadata.exif
public property | ExtractIptc | metadata.iptc
public property | FilesPerOnePackageCount | uploadSettings.filesPerPackage
public property | HashAlgorithm | metadata.hash
public property | MaxConnectionCount | Eliminated.
public property | MaxFileCount | restrictions.maxFileCount
public property | MaxFileSize | restrictions.maxFileSize
public property | MaxImageHeight | restrictions.maxImageHeight
public property | MaxImageWidth | restrictions.maxImageWidth
public property | MaxTotalFileSize | restrictions.maxTotalFileSize
public property | MetaDataSeparator | metadata.valueSeparator
public property | MinFileCount | restrictions.minFileCount
public property | MinFileSize | restrictions.minFileSize
public property | MinImageHeight | restrictions.minImageHeight
public property | MinImageWidth | restrictions.minImageWidth
public property | PasteFileNameTemplate | uploader.pasteFileNameTemplate
public property | PostFormat | Eliminated.
public property | TimeOut | uploadSettings.connectionTimeout
public property | TotalFileSize | Eliminated. Use the files.totalFileSize() instead.
public property | UploadFileAngle | file.angle
public property | UploadFileCount | Eliminated. Use the files.count() instead.
public property | UploadFileDescription | file.description
public property | UploadFileFocused | file.focused
public property | UploadFileFormat | file.format
public property | UploadFileGuid | file.guid
public property | UploadFileHeight | file.height
public property | UploadFileHorizontalResolution | file.horizontalResolution
public property | UploadFileName | file.name
public property | UploadFileSelected | file.selected
public property | UploadFileSize | file.size
public property | UploadFileType | file.type
public property | UploadFileVerticalResolution | file.verticalResolution
public property | UploadFileWidth | file.width
public property | UploadSourceFile | Eliminated. Use the converter.mode = SourceFile instead.
public property | UploadThumbnailXBackgroundColor | converter.thumbnailBgColor
public property | UploadThumbnailXCompressOversizedOnly | converter.thumbnailCompressOversizedOnly
public property | UploadThumbnailXCompressionMode | converter.mode
public property | UploadThumbnailXCopyExif | converter.thumbnailCopyExif
public property | UploadThumbnailXCopyIptc | converter.thumbnailCopyIptc
public property | UploadThumbnailXFitMode | converter.thumbnailFitMode
public property | UploadThumbnailXHeight | converter.thumbnailHeight
public property | UploadThumbnailXJpegQuality | converter.thumbnailJpegQuality
public property | UploadThumbnailXResizeQuality | converter.thumbnailResizeQuality
public property | UploadThumbnailXResolution | converter.thumbnailResolution
public property | UploadThumbnailXWatermark | converter.thumbnailWatermark
public property | UploadThumbnailXWidth | converter.thumbnailWidth
public property | UserAgent | metadata.userAgent

Methods

 | Old Member | New Member
public method | AddCookie | metadata.addCookie(String)
public method | AddField | metadata.addCustomField(String, String, Boolean)
public method | AddFiles | uploadPane.addFiles()
public method | AddFolders | uploadPane.addFolders()
public method | CanGoToFolder | folderPane.canGoToFolder(String)
public method | DeselectAll | folderPane.deselectAll()
public method | GoToFolder | folderPane.goToFolder(String)
public method | GoToParentFolder | folderPane.goToParentFolder()
public method | GoToPreviousFolder | folderPane.goToPreviousFolder()
public method | LoadUploadList | uploadPane.loadUploadList(Number)
public method | Refresh | Eliminated.
public method | RemoveAllFromUploadList | uploadPane.removeAllFiles()
public method | RemoveField | Eliminated. Use the metadata.enableStandardField(String, Boolean) and metadata.removeCustomField(String) instead.
public method | RemoveFromUploadList | uploadPane.removeSelectedFiles()
public method | RenameField | metadata.renameStandardField(String, String)
public method | ResetCookies | metadata.resetCookie()
public method | SaveUploadList | uploadPane.saveUploadList(Number)
public method | SelectAll | folderPane.selectAll()
public method | Send | uploader.upload()
public method | Stop | uploader.cancelUpload()
public method | UploadFileRemove | files.remove(Number)
public method | UploadThumbnailAdd | Eliminated. Use the converters.add() instead.
public method | UploadThumbnailRemove | Eliminated. Use the converters.remove(Number) instead.

Events

 | Old Member | New Member
public event | AfterUpload | Uploader.AfterUpload
public event | BeforeUpload | Uploader.BeforeUpload
public event | Error | Uploader.Error
public event | FolderChange | Uploader.FolderChange
public event | InitComplete | Uploader.InitComplete
public event | PackageBeforeUpload | Uploader.BeforePackageUpload
public event | PackageComplete | Uploader.AfterPackageUpload
public event | PackageError | Eliminated. Use the Uploader.Error instead.
public event | PackageProgress | Eliminated. Use the Uploader.Progress instead.
public event | PaneResize | Eliminated.
public event | Progress | Uploader.Progress
public event | SelectionChange | Uploader.SelectionChange
public event | SortModeChange | Eliminated.
public event | UploadFileCountChange | Uploader.UploadFileCountChange
public event | ViewChange | Uploader.ViewChange

ShellComboBox Class

This class was eliminated.

Thumbnail Class

Properties

 | Old Member | New Member
public property | BackgroundColor | thumbnail.backgroundColor
public property | Guid | thumbnail.guid
public property | Index | Eliminated.
public property | ParentControlName | thumbnail.parentControlName
public property | View | Eliminated.

Events

 | Old Member | New Member
public event | Click | Thumbnail.Click
public event | InitComplete | Thumbnail.InitComplete

UploadPane Class

This class was eliminated.

Image Uploader Embedding Scripts Library

iuembed.js

Methods

 | Old Member | New Member
public method | addParam | Eliminated.
public method | addEventListener | Eliminated.
public method | getActiveXInstalled | Eliminated.
public method | getActiveXInstalledToUpdate | Eliminated.
public method | getControlType | Eliminated.
public method | getJREInstalled | Eliminated.
public method | getJREVersion | Eliminated.
public method | getHtml | uploader.getHtml() and thumbnail.getHtml()
public method | getParam | Eliminated.
public method | removeEventListener | Eliminated.
public method | removeParam | Eliminated.
public method | writeHtml | uploader.writeHtml() and thumbnail.writeHtml()

Properties

 | Old Member | New Member
public property | activeXControlCodeBase | activeXControl.codeBase
public property | activeXControlEnabled | Eliminated.
public property | activeXControlVersion | activeXControl.version
public property | controlType | Eliminated.
public property | height | uploader.height and thumbnail.height
public property | id | uploader.id and thumbnail.id
public property | javaAppletCached | javaControl.cached
public property | javaAppletCodeBase | javaControl.codeBase
public property | javaAppletEnabled | Eliminated.
public property | javaAppletVersion | javaControl.version
public property | showNonemptyResponse | Eliminated.
public property | width | uploader.width and thumbnail.width

Standalone Functions

 | Old Member | New Member
public function | getImageUploader | Eliminated. Use $au.uploader('Uploader1') and $au.thumbnail('Thumbnail1') instead.

Members for Private-Label Versions

 | Old Member | New Member
public property | activeXControlCodeBase | activeXControl.codeBase
public property | activeXClassId | activeXControl.classId
public property | activeXProgId | activeXControl.progId
public property | javaAppletJarFileName | javaControl.codeBase
public property | javaAppletClassName | javaControl.className

iuembed.InstallationProgress.js

InstallationProgressExtender class was replaced by the installationProgress.

Properties

 | Old Member | New Member
public property | AltInstallerEnabled | Eliminated. Alternative instructions are not displayed by default. If you need to provide such instructions use the installationProgress.altInstallerHtml.
public property | AltInstallerHtml | installationProgress.altInstallerHtml
public property | AltInstallerUrl | Eliminated. If you need to provide a URL specify it in the installationProgress.altInstallerHtml value.
public property | BeforeIE6XPSP2InstallJavaHtml | Eliminated.
public property | BeforeIE6XPSP2InstructionsHtml | installationProgress.beforeIE6XPSP2InstructionsHtml
public property | BeforeIE6XPSP2ProgressHtml | installationProgress.beforeIE6XPSP2ProgressHtml
public property | CommonHtml | installationProgress.commonHtml
public property | CommonInstallJavaHtml | Eliminated. Use the installationProgress.installJavaHtml instead.
public property | IE6XPSP2InstallJavaHtml | Eliminated.
public property | IE6XPSP2InstructionsHtml | installationProgress.IE6XPSP2InstructionsHtml
public property | IE6XPSP2ProgressHtml | installationProgress.IE6XPSP2ProgressHtml
public property | IE7InstallJavaHtml | Eliminated.
public property | IE7InstructionsHtml | installationProgress.IE7InstructionsHtml
public property | IE7ProgressHtml | installationProgress.IE7ProgressHtml
public property | IE8InstructionsHtml | Eliminated.
public property | IE8InstructionsHtml | installationProgress.IE8InstructionsHtml
public property | IE8ProgressHtml | installationProgress.IE8ProgressHtml
public property | InstructionsCssClass | installationProgress.instructionsCssClass
public property | JavaProgressHtml | Eliminated. Use the installationProgress.progressHtml instead.
public property | MacInstallJavaHtml | installationProgress.macInstallJavaHtml
public property | MiscBrowsersInstallJavaHtml | installationProgress.installJavaHtml
public property | ProgressCssClass | installationProgress.progressCssClass
public property | ProgressHtml | installationProgress.progressHtml
public property | ProgressImageUrl | installationProgress.progressImageUrl
public property | UpdateInstructions | installationProgress.updateInstructions

iuembed.AmazonS3.js

AmazonS3Extender Class

Properties
 | Old Member | New Member
public property | AWSAccessKeyId | amazonS3Extender.accessKeyId
public property | Bucket | amazonS3Extender.bucket
public property | BucketHostName | amazonS3Extender.bucketHostName
public property | SourceFile | Eliminated. Use the amazonS3Extender.converters instead.
public property | Thumbnail1 | Eliminated. Use the amazonS3Extender.converters instead.
public property | Thumbnail2 | Eliminated. Use the amazonS3Extender.converters instead.
public property | Thumbnail3 | Eliminated. Use the amazonS3Extender.converters instead.

FileSettings Class

Properties
 | Old Member | New Member
public property | Acl | fileSettings.acl
public property | Key | fileSettings.key
public property | Policy | fileSettings.policy
public property | Signature | fileSettings.signature
Methods
 | Old Member | New Member
public function | addPredefinedProperty | Eliminated. Use the fileSettings.meta instead.
public function | addProperty | Eliminated. Use the fileSettings.meta instead.
public function | getProperty | Eliminated. Use the fileSettings.meta instead.
public function | removeProperty | Eliminated. Use the fileSettings.meta instead.

iuembed.Nirvanix.js

Properties

 | Old Member | New Member
public property | UploadToken | nirvanixExtender.uploadToken
public property | UploadHost | nirvanixExtender.uploadHost
public property | DestFolderPath | nirvanixExtender.destFolderPath

Events

 | Old Member | New Member
public event | ServiceError | nirvanixExtender.serviceError

Image Uploader POST Fields

 | Old Field | New Field
Upload Information
field | PackageIndex | PackageIndex
field | PackageCount | PackageCount
field | PackageGuid | PackageGuid
field | FileCount | PackageFileCount
 | Old Field | New Field
Original File Information
field | SourceFile_[ItemIndex] | Eliminated. Use the SourceFile converter and retrieve the corresponding File[converterIndex]_[itemIndex] field.
field | FileName_[ItemIndex] | SourceName_[itemIndex]
field | SourceFileSize_[ItemIndex] | SourceSize_[itemIndex]
field | SourceFileCreatedDateTime_[ItemIndex] | SourceCreatedDateTime_[itemIndex]
field | SourceFileLastModifiedDateTime_[ItemIndex] | SourceLastModifiedDateTime_[itemIndex]
field | SourceFileCreatedDateTimeLocal_[ItemIndex] | SourceCreatedDateTimeLocal_[itemIndex]
field | SourceFileLastModifiedDateTimeLocal_[ItemIndex] | SourceLastModifiedDateTimeLocal_[itemIndex]
field | Width_[ItemIndex] | SourceWidth_[itemIndex]
field | Height_[ItemIndex] | SourceHeight_[itemIndex]
field | HorizontalResolution_[ItemIndex] | HorizontalResolution_[itemIndex]
field | VerticalResolution_[ItemIndex] | VerticalResolution_[itemIndex]
 | Old Field | New Field
Thumbnail Information
field | Thumbnail[ThumbnailIndex]_[ItemIndex] | Eliminated. Use the Thumbnail, Zip, or Icon converter and retrieve the corresponding File[converterIndex]_[itemIndex] field.
field | UploadFile[ThumbnailIndex]CompressionMode_[ItemIndex] | File[converterIndex]Mode_[itemIndex]
field | Thumbnail[ThumbnailIndex]FileSize_[ItemIndex] | File[converterIndex]Size_[itemIndex]
field | Thumbnail[ThumbnailIndex]Width_[ItemIndex] | File[converterIndex]Width_[itemIndex]
field | Thumbnail[ThumbnailIndex]Height_[ItemIndex] | File[converterIndex]Height_[itemIndex]
field | Thumbnail[ThumbnailIndex]Succeeded_[ItemIndex] | Eliminated. If the converted file cannot be created it is not sent at all.
 | Old Field | New Field
User Input
field | Angle_[ItemIndex] | Angle_[itemIndex]
field | Description_[ItemIndex] | Description_[itemIndex]
Note

[itemIndex] and [converterIndex] placeholders are zero-based.


Using Private-label Version of Image Uploader JavaScript

When users download and install Image Uploader to the browser, they see the security dialog which asks whether they trust Aurigma, Inc. and want to install the control. However, if you prefer to display your company name instead of Aurigma, Inc., rename Image Uploader control, and sign it with your own digital signature you need to order a private-label version of Image Uploader. Additionally private-label versions can contain enhanced functionality not available in the standard version. If you need a private-label version of Image Uploader, please, contact our sales team at sales@aurigma.com.

Note

Private-lable versions are available in Image Uploader Premium only. See the Comparison of Image Uploader Editions topic for details.

This article describes how to use a private-label version of Image Uploader using JavaScript wrapper. Walk through the following steps to configure the wrapper to launch private-label version of Image Uploader:

  1. Obtain *.cab and *.jar files as well as private-label embedding instructions from Aurigma, Inc. For example, you have got MyUploader.cab and MyUploader.jar files.
  2. Copy these files to any folder of your application.
  3. Configure the activeXControl property of the uploader object in the following way:
    1. Specify a path to MyUploader.cab file as a value of the codeBase property.
    2. Specify CLSID and PROGID of the ActiveX control as values of the classId and progId properties respectively.
  4. Configure the uploader.javaControl property as follows:
    1. Specify a path to MyUploader.jar file as a value of the codeBase property.
    2. Specify Java applet class name with the className property.

All the information you need to specify using these properties will be provided to you by Aurigma, Inc. If some parameters were not sent you should use default values.

The code sample below demonstrates how to implement this.

JavaScript

$au.uploader({
    id: 'Uploader1',
    activeXControl: {
        codeBase: "MyUploader.cab",
        classId: "XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX",
        progId: "MyCompany.MyUploader"
    },
    javaControl: {
        codeBase: "MyUploader.jar",
        className: "com.mycompany.myuploader.MyUploader.class"
    }
});

See Also

Reference

  • activeXControl Class
  • javaControl Class

Manual

  • Quick Start with Image Uploader JavaScript


Installing Image Uploader on Client Side

When a user visits the page that contains Image Uploader, it is automatically downloaded and installed. This process is discussed below.

Internet Explorer on Windows

Depending on Internet Explorer settings, the Information Bar may be displayed.

Installation in Internet Explorer 8

A user should click on the Information Bar and select Install This Add-on or Run Add-on from the dropdown menu.

Information bar for add-on installation in Internet Explorer 8

Then a user should click Install in the add-on installation dialog.

Add-on installation dialog in Internet Explorer 8

By default, Internet Explorer settings allow automatic installation of add-ons (with security dialog). However, sometimes automatic installation is disabled. Typically it happens in corporate networks if the security policy of the company does not allow it.

To give users with such security settings a possibility to use Image Uploader, you can provide them with a standalone installer (ImageUploaderRedistributable.msi). It can be downloaded from the following location:

http://www.aurigma.com/Products/ImageUploader/FreeTrial.aspx

Alternatively, they can download the /Scripts/ImageUploader7.cab from your site and register Image Uploader manually by extracting the OCX file from ImageUploader7.cab and running regsvr32 utility for this file:

regsvr32 ImageUploader7.ocx

Once Image Uploader is installed, it will not be downloaded again. If you need to update it (e.g. when deploying new version), find instructions in the Upgrading Minor Versions topic.

Other Browsers and Operating Systems

If a user opens a page with Image Uploader in one of the other supported browsers, they should make sure that Java Runtime Environment (JRE) 1.5 or later is installed. If so, Image Uploader will be automatically downloaded and installed. Depending on the browser settings, security dialog prompting whether a user permits installation of Image Uploader may be displayed.

Users should click the Yes button (or OK depending on the client platform) to proceed with installation.

If Java applet caching is enabled on the client side and you use caching in the code (as done in all demo applications), once Image Uploader is loaded on this page, it is cached and will not be downloaded again. If you need to update it (e.g. when deploying new version), find instructions in the Upgrading Minor Versions topic.

Image Uploader Installation Progress

Additionally, Image Uploader wrappers allow displaying special instructions helping users to download and install the add-on. This feature is called installation progress and looks like the following screenshot:

Find details about this feature in the Using Image Uploader Installation Progress topic.

See Also

Manual

  • System Requirements
  • Upgrading Minor Versions
  • Using Image Uploader Installation Progress


Evaluating and Registering Image Uploader

Evaluating Image Uploader

If you would like to evaluate Image Uploader before making a purchase decision you can do it as follows:

  • Use Image Uploader on localhost domain where it always works as a full version.
  • Register a trial license key.

Trial license key is not associated with any domain name or IP address and allows uploading files to any web sites. It also does not constrain the functionality of Image Uploader but puts the following limitations on its usage:

  • Every time you send files to a server you get the following message:

    This is a trial version. It can be used in evaluation process only.

  • You can use Image Uploader with a trial license key during the 30 days evaluation period only.

Note

The evaluation version of Image Uploader neither puts any limitations on the number of files that can be uploaded nor constrains its functionality anyhow. So if the evaluation version does not work properly, we highly encourage you to create support case and tell us about the problem.

Obtain Trial License Key via Image Uploader Evaluation License Keys Request

To request trial license key you should use Image Uploader Evaluation License Keys Request tool which is distributed with the product. To launch this tool click the Start button, point to All Programs, and then point to Aurigma. Point to Image Uploader 7.0.11 and click Image Uploader Evaluation License Keys Request.

If you downloaded Image Uploader no setup archive (ImageUploaderNoSetup.zip) just unpack this archive and run the /RequestEvaluationKey/RequestKeyOnWindows.exe file.

Then enter your E-mail and Password, you are registered with www.aurigma.com, and then click Request.

After you request trial license keys they are automatically registered in all sample applications installed along with Image Uploader. Then you can move these samples to your web server. If, however, you need to apply these keys to another application just paste them to this application as it is described in the Registering License Key section.

Obtain Trial License Key Manually

If you cannot obtain trial license keys using Image Uploader Evaluation License Keys Request tool for some reason you can do it online (http://www.aurigma.com/MyAurigma/MyLicenses.aspx).

Removing Limitations of Evaluation Version

After you purchase a license for Image Uploader you get one or several full license keys. Full license key is associated with the domain name or IP address of the site where Image Uploader will be used (speaking more precisely - the address of the server where you will host the control and submit files to). If the full license key matches the address you have provided, Image Uploader works as a full version, otherwise, it will not work at all. It will show the following message every time you start the upload:

No valid license key for current address specified. If you see this message, please, contact site administrator.

There are two licensing options available for Image Uploader:

Domain License

Allows using Image Uploader at the domain name you specified during activation.

Note

License key is generated for a full-qualified domain name, i.e. it works neither with other domains associated with the same site nor with any subdomains of this domain. The only exception is the www subdomain.

In other words, if you generate a license key for the yoursite.com domain, it will not be valid for subdomain.yoursite.com, but will be valid for www.yoursite.com.

You can also specify an IP address, but in this case users need to type this address in the navigation bar of their browser.

IP License

Allows using Image Uploader with all domains associated with a specific IP address specified during activation.

Note

IP license can be requested for Image Uploader Premium only. See the Comparison of Image Uploader Editions topic for details.

Development and Staging License Keys

These license keys are associated with a domain name or IP address of the website too with only one difference, they can be used for development or staging purposes only. To inform that you are using a staging or development license key on your site a special watermark is displayed over Image Uploader surface.

Registering License Key

Note

Image Uploader Express does not support registering of several license keys. See the Comparison of Image Uploader Editions topic for details.

To register license key just specify it as a value of the Uploader.LicenseKey property. Here is how you can do that (note that if you have several keys, they should be separated with semi-colons):

ASP.NET

<aur:Uploader ID="Uploader1" runat="server"
    LicenseKey="XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY" />

PHP

$uploader = new Uploader("Uploader1");
$uploader->setLicenseKey("XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY");

JavaScript

$au.uploader({
    licenseKey: 'XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY'
})

See Also

Reference

  • LicenseKey Property

Manual

  • Quick Start with Image Uploader ASP.NET
  • Quick Start with Image Uploader PHP
  • Quick Start with Image Uploader JavaScript
  • Licensing Information
  • LicenseKey (ASP.NET)
  • LicenseKey (PHP)
  • licenseKey (JavaScript)
  • LicenseKey (ASP.NET)
  • LicenseKey (PHP)
  • licenseKey (JavaScript)


Upgrading Minor Versions

From time to time new versions of Image Uploader with new features and bug fixes are released. This topic discusses how to upgrade minor versions of Image Uploader properly.

The way to upgrade Image Uploader depends on the used wrapper:

Image Uploader ASP.NET

If Image Uploader is embedded using the ASP.NET wrapper, all what you need to update Image Uploader is copying new Aurigma.ImageUploader.dll to the /bin folder of your application instead of the old one.

Image Uploader PHP

To update Image Uploader embedded with PHP wrapper just replace the /ImageUploaderPHP folder with a new one.

Image Uploader JavaScript

In the case of JavaScript wrapper usage, you should copy a new /Scripts folder to your application.

See Also

Manual

  • Quick Start with Image Uploader ASP.NET
  • Quick Start with Image Uploader PHP
  • Quick Start with Image Uploader JavaScript
  • Installing Image Uploader on Client Side


Using Image Uploader

This section contains how-to topics that describe Image Uploader usage in different aspects.

In This Section

Uploading in ASP.NET
Uploading in PHP
Uploading in Other Platforms
Configuring and Handling Upload on Client-Sides
Uploading Images
Customizing User Interface
Configuring Restriction Rules for Files
Using Image Uploader at Runtime


Uploading in ASP.NET

This section consists of topics that discuss uploading in ASP.NET platform

In This Section

Configuring ASP.NET
Saving Uploaded Files in ASP.NET
Uploading Folders in ASP.NET
Uploading Additional Data in ASP.NET
Maintaining Sessions and Authentication in ASP.NET
Debugging ASP.NET Upload Scripts


Configuring ASP.NET

Typically, default server configuration does not allow uploading files with Image Uploader. This topic describes how to configure a server you are going to deploy Image Uploader on properly.

Configuring Permissions

The folder where you are going to save files should have modify permissions. Depending on your operating system it can be set in one of the following ways:

  • On Windows NT/2000/XP you should grant the modify permission to the Internet guest user (IUSR_<machinename>).
  • On Windows 2003 Server you should grant the modify permission to the NETWORK SERVICE group.
  • On Windows Vista/2008 Server/7 you should grant the modify permission to the account your site application pool is running under, Network Service by default.

Configuring Maximum POST Request Length

Usually limitation for maximum POST request length is specified to reduce the risk of DoS attacks. If the request size exceeds a specific value, it is considered malicious and the upload would be broken.

If you are going to upload files larger than the default limitation, increase the latter as you need.

For IIS 7:

  1. Go to C:\Windows\System32\inetsrv\config\applicationHost.config and change

    XML

    <section name="requestFiltering" overrideModeDefault="Deny" />

    to:

    XML

    <section name="requestFiltering" overrideModeDefault="Allow" />

  2. Add to your application's web.config the following sections:

    XML

    <system.webServer>
    <security>
        <requestFiltering>
            <requestLimits maxAllowedContentLength ="2147482624" /> <!-- in bytes -->
        </requestFiltering>
    </security>
</system.webServer>

    XML

    <system.web>
     <httpRuntime maxRequestLength="2097151"/> <!-- in kilobytes -->
</system.web>

For IIS 6:

Add to your application's web.config the following section:

XML

<system.web>
    <httpRuntime maxRequestLength="2097151"/> <!-- in kilobytes -->
</system.web>

If you have URLScan installed and still experience this problem, go through the following steps:

  1. Open the UrlScan.ini file which is typically located at C:\Windows\system32\inetsrv\urlscan folder.
  2. Set the MaxAllowedContentLength key to the desired value (in bytes).
  3. Save changes and restart IIS.


Saving Uploaded Files in ASP.NET

As you know Image Uploader sends files and additional metadata from client computers to server side in HTTP POST requests. This approach requires server script to parse the received requests and handle uploaded data. Reading this topic you will get to know how to extract files and additional data sent by clients, save it all to file system on a server or handle in some other way. There are three approaches to perform this task:

  • Uploading files to the specified folder on a server. This is the simplest way, it allows saving all uploaded files almost without coding. However, this method is not flexible enough, so do not use it if you need to get access to additional data (such as information about original files, additional fields, etc.).
  • Extended processing of uploaded data using Image Uploader server-side controls and components. This approach gives you flexible typed access to all data sent from client computers. It suites best for ASP.NET applications because Image Uploader ASP.NET components offer server-side API allowing to accomplish any operation on the uploaded data in a usual for ASP.NET developers way.
  • Parsing POST requests using standard ASP.NET Request object. This method is not different from when you are using form-based file upload in HTML (browse/upload buttons on your page). In case if you use it you get untyped access to uploaded data, also this approach does not support automatic assembling files from chunks (in case if you enable them in Image Uploader, of course). The main advantage of this method is that you do not have additional references to Aurigma assemblies in your ASP.NET application.
Note

If you parse requests using the ASP.NET Request object and enable sending files by chunks you will have to write significant amount of non-trivial server-side code to assembly the files on your server. This way, we do not recommend enabling chunks if you use this method of handling requests.

Further in this topic every approach will be described in detail. Firstly, let us describe Image Uploader ASP.NET components.

Server-side Components

All the Image Uploader ASP.NET classes and types are located in the Aurigma.ImageUploader.dll assembly. There are three main ones allowing to process the data uploaded from client computers (Uploader, UploadRequest and UploadHandler). All three of them have similar API and functionality giving flexible typed access to these data. Which class to use in your application depends on where you handle the received data:

  • Uploader is a WebForms control. This control can both embed Image Uploader in a web page (e.g. using Microsoft Visual Studio designer) and handle the data being uploaded by Image Uploader from client computers at run-time. Use this component if you host Image Uploader and receive uploads at the same web page. For more information on how to embed Image Uploader in a web page see the Quick Start with Image Uploader ASP.NET topic.
  • UploadRequest is a non-visual WebForms control. It is a right choice if you set up Image Uploader to upload files to a page different from one where it is hosted. Put UploadRequest component on the page which receives the uploads to handle them.
  • UploadHandler class implements the IHttpHandler interface. If you want to create your own custom HTTP handler (see the HTTP Handlers and HTTP Modules Overview MSDN article) which receives and processes data uploaded from client machines, it is a solution for you. You just need to inherit your .ashx handler from this class and it will automatically parse requests received from Image Uploader and will expose API to access the files and data.

Uploading Files to Specified Folder

This section describes the simplest way of handling uploaded data - autosave. This approach allows you to save all the uploaded files to the specified folder on your server without writing a lot of code. All server-side components described in the previous section can save uploaded files automatically. You just have to choose the component, plug it in your ASP.NET application and configure the Autosave and the DestinationFolder properties. To enable autosave feature set the Autosave property to true. After that set the DestinationFolder property to the path to folder where uploaded files are saved. If the specified folder does not exist Image Uploader tries to create it.

Also autosave supports the Uploader.FolderProcessingMode feature that allows uploading whole folders rather than just files and restoring their structure on server side automatically, see the Uploading Folders in ASP.NET topic for more information.

If you need to process the saved files in some way, then a page specified in the UploadSettings.RedirectUrl setting is the right place for this. Just put your code there and it will be executed after the upload process is completed.

The following examples show how to configure autosave for each of the server-side components.

Autosave via Uploader Control

After embedding the Uploader control in your page as it is described in the Quick Start with Image Uploader ASP.NET topic, configure the control like it is shown below:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server"
    AutoSave="true"
    DestinationFolder="~/Catalog" />

Autosave via UploadRequest Control

This control is configured in the same manner as Uploader. Additionally you have to configure the UploadSettings.ActionUrl property, set it to a URL to a page where the UploadRequest control is hosted (both absolute and relative URLs are supported), as it is shown here:

ASP.NET

<aur:Uploader runat="server">
    <UploadSettings ActionUrl="UploadRequestPage.aspx" />
</aur:Uploader>

Autosave via UploadHandler Class

Since UploadHandler is not a WebForms control you do not have to create a separate page to host it. You just create a new handler (an .ashx file), which inherits from the UploadHandler. For example, like this one:

C#

public class SimpleHandler : Aurigma.ImageUploader.UploadHandler
{
    public SimpleHandler ()
    {
        DestinationFolder = "~/Catalog";
        AutoSave = true;
    }
}

And specify a URL to this handler as a value of the UploadSettings.ActionUrl property (both absolute and relative URLs are supported).

Note

If your file storage is located separately from your web site (for example, on another disk or server), it is recommended to additionally specify the TempDirectory property which configures a temporary folder where ASP.NET server-side part of Image Uploader saves files before moving them to the DestinationFolder. Thus, TempDirectory should be located at the same disk where you store files.

Filenames Conversions and Collisions

Image Uploader prepares files on client side in the way set by so-called converters. Each converter specifies what to do with a file selected for upload: upload it as is or apply some transformation before upload (resize image down, extract and send icon associated with a file, or compress a file to ZIP format). Converters (except for SourceFile one) add suffixes to file names uploaded to a server. For example, the name.ext_Thumbnail0.ext filename is the result of applying Mode="*.*=Thumbnail" converter on name.ext file. For a full list of possible suffixes see the ConvertedFile.Name property description.

Filenames collisions may occur while saving uploaded files to a destination folder. If the destination folder already has a file with the same name as uploaded one, the uploaded file will be saved under its name appended by _xx, where xx is a number starting from 2. For example, if there is a file with the name name.ext in the destination folder and a user tries to upload another file with the same name then uploaded file is saved as name_02.ext file. If name_02.ext file exists as well then the recently uploaded file gets name_03.ext filename and so on.

Extended Processing of Uploaded Data

This approach requires quite a bit of code, however, this method is more flexible than autosave described before. The main idea is to handle uploaded files and data in the FileUploaded and/or AllFilesUploaded event handlers of the mentioned before server-side components. The first event fires each time a user-specified file is successfully uploaded. The second event fires when the whole upload session completes and all the files, metadata, and additional data are received on the server side. It means that the first event fires as many times as number of files selected for upload, whereas the second one fires only once.

Now, when you understand the differences between these events, let us discuss how exactly to create these event handlers. There are two steps to this process:

  • creating skeleton event handler
  • writing implementation of event handler

Creating Skeleton Event Handlers

Before creating an event handler you have to select server-side component to use. If you do not know the differences between them, please, read the server-side components section of this article.

Using Uploader and UploadRequest Controls

To add FileUploaded and/or AllFilesUploaded event handler for the Uploader control just specify event name in the control events list or add OnFileUploaded and/or OnAllFilesUploaded parameters declaratively. The following example creates both event handlers for the Uploader control.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server"
    OnFileUploaded="FileUploaded"
    OnAllFilesUploaded="AllFilesUploaded" />

The page code-behind should contain these event handlers with the specified names:

C#

protected void FileUploaded(object sender, Aurigma.ImageUploader.FileUploadedEventArgs e)
{
    // Your code
}

protected void AllFilesUploaded(object sender, Aurigma.ImageUploader.AllFilesUploadedEventArgs e)
{
    // Your code
}

The UploadRequest event handlers can be created in the same way as analogous Uploader event handlers described above. There is the only difference - in case of using UploadRequest you have to set the UploadSettings.ActionUrl property to the page containing the UploadRequest instance.

There is the example of event handler below.

Using UploadHandler Class

In case of using the UploadHandler you have to create a new class derived from the UploadHandler class and add events handlers to this new class. In the following example the SimpleHandler class (contained in the SimpleHandler.ashx file) is this new derived class.

C#

public class SimpleHandler : Aurigma.ImageUploader.UploadHandler
{
    public SimpleHandler()
    {
        FileUploaded += OnFileUploaded;
        AllFilesUploaded += OnAllFilesUploaded;
    }

    public void OnFileUploaded(object sender, Aurigma.ImageUploader.FileUploadedEventArgs e)
    {
        // put your code here...
    }

    public void OnAllFilesUploaded(object sender, Aurigma.ImageUploader.AllFilesUploadedEventArgs e)
    {
        // put your code here...
    }

}

Then implement these handlers, for example, like it is shown in the example below.

And, finally, set the UploadSettings.ActionUrl property:

ASP.NET

<aur:Uploader runat="server">
    <UploadSettings ActionUrl="SimpleHandler.ashx" />
</aur:Uploader>

Writing Implementation of Event Handlers

After creating a skeleton event handler you have to write its implementation. You can accomplish any operation on the uploaded data using Image Uploader ASP.NET types and classes. For example, not just save all files to the same folder, but change destination depending on file type. Also you can save metadata of uploaded files to your database or to an XML file which allows you to perform, for example, various file-sorting operations. For better understanding let us separate description of the uploaded data handling into the following sections:

  • files handling
  • metadata handling

Files Handling

The ASP.NET server-side part of Image Uploader among its types has the UploadedFile class. This type holds all the data associated with a single file selected for upload (files prepared on client side by Image Uploader from the original file in accordance with converters set in the settings, additional fields, and other data). The FileUploaded and AllFilesUploaded events give access to the UploadedFile instances via arguments of their event handlers: FileUploadedEventArgs.UploadedFile and AllFilesUploadedEventArgs.UploadedFiles properties, respectively.

Now let us examine how to get access to uploaded files via the UploadedFile instances. Each UploadedFile object has associated collection of files prepared by Image Uploader converters on client side. Each of these files is represented by an instance of the ConvertedFile type. This way, the collection of converted files associated with a particular file selected for upload is accessible via the UploadedFile.ConvertedFiles property.

Each ConvertedFile has three main members to handle the file:

  • the FileStream property for getting access to the file content
  • the MoveTo(String) method for moving the file to the specified location
  • the SaveAs(String) method for copying the file to the specified location

The main difference between MoveTo(String) and SaveAs(String) methods is in the following. By the moment when the FileUploaded or AllFilesUploaded event is fired, ASP.NET server-side part of Image Uploader has already completed parsing of HTTP POST request(s) and saved files to a temporary folder which is configured via the TempDirectory property. When you trigger the MoveTo(String) method, it moves the file from this temporary folder to the specified one. However, when you call the SaveAs(String) method copies the file from a temporary location to the specified folder. MoveTo(String) method works faster when you transfer the file from a temporary location (which is in the /App_Data folder, by default) to a location on the same disk. That is the difference. Thus, it is recommended to select temporary folder on the same disk where your file storage is located.

Metadata Handling

All the metadata uploaded along with a file is accessible through the UploadedFile properties and can be divided into the following groups:

File Location

There is the only one property in this group - UploadedFile.RelativePath which returns a relative path to the original file on the client machine. This property makes sense only if Image Uploader is allowed to upload folders (FolderProcessingMode has Upload value).

Original File Information

This group includes properties containing information about the original file:

  • SourceCreatedDateTime and SourceCreatedDateTimeLocal represent creation date of the original file.
  • SourceLastModifiedDateTime and SourceLastModifiedDateTimeLocal represent last modification date of the original file.
  • SourceHeight and SourceWidth represent dimensions of the original file (in pixels) if it is an image.
  • SourceXResolution and SourceYResolution represent horizontal and vertical resolutions of the original file (in dpi) if it is an image.
  • SourceName represents the original file name.
  • SourceSize represents the original file size.
Converted File Information

The ConvertedFile class provides access to some additional information along with access to the converted file itself. Its properties contain the following information:

  • Mode contains a converter type applied to create the converted file.
  • Size represents size (in bytes) of the converted file.
  • Height and Width represent dimensions of the created downsized image (in pixels) if the converter was set to resize an original image down.
User-defined Data

This group includes the following properties:

  • Angle contains the rotation angle of the uploaded file if it is an image.
  • Description contains a user-provided description of the uploaded file.
  • CropBounds contains bounds of cropped area set for the uploaded file if it is an image.
  • Tag contains the tag of uploaded file.
  • PackageFields contains a collection of POST fields including the fields specified through the Uploader.Metadata set of properties (Metadata.AdditionalFormName, Metadata.Exif, Metadata.Iptc) and via the metadata.addCustomField(String, String, Boolean) client method.

Event Handler Example

This example is an FileUploaded event handler implementation which saves an original file and its resized copy to the ../Gallery/ and ../Gallery/Thumbnails/ folders respectively and writes some file-related information (filenames, image dimensions, user description, and etc.) to an XML file.

C#

protected void FileUploaded(object sender, Aurigma.ImageUploader.FileUploadedEventArgs e)
{
    string galleryPath = Server.MapPath("Gallery/");
    string thumbnailsPath = galleryPath + "Thumbnails/";

    //Save original file.
    //It is the first file in ConvertedFiles collection as we set first converter mode to SourceFile.
    string sourceFileName = GetSafeFileName(galleryPath, e.UploadedFile.SourceName);
    e.UploadedFile.ConvertedFiles[0].SaveAs(System.IO.Path.Combine(galleryPath, sourceFileName));

    //Save thumbnail.
    //It is the second file in ConvertedFiles collection as we set second converter mode to Thumbnail.
    string thumbnailFileName = GetSafeFileName(thumbnailsPath, e.UploadedFile.SourceName);
    e.UploadedFile.ConvertedFiles[1].SaveAs(System.IO.Path.Combine(thumbnailsPath, thumbnailFileName));

    //Save file info.
    System.Xml.XmlDocument descriptions = new System.Xml.XmlDocument();
    if (System.IO.File.Exists(galleryPath + "Descriptions.xml"))
        descriptions.Load(galleryPath + "Descriptions.xml");
    else
        descriptions.AppendChild(descriptions.CreateElement("files"));

    System.Xml.XmlElement file = descriptions.CreateElement("file");
    file.SetAttribute("name", sourceFileName);
    file.SetAttribute("thumbName", thumbnailFileName);
    file.SetAttribute("width", Convert.ToString(e.UploadedFile.SourceWidth));
    file.SetAttribute("height", Convert.ToString(e.UploadedFile.SourceHeight));
    file.SetAttribute("description", e.UploadedFile.Description);
    descriptions.DocumentElement.AppendChild(file);
    //Save xml file with uploaded files info.
    descriptions.Save(galleryPath + "Descriptions.xml");
}

private string GetSafeFileName(string path, string fileName)
{
    // ...
}

Parsing POST Requests Using Standard ASP.NET Request Object

The last way of handling uploaded files is to parse the request manually via the intrinsic Request object of System.Web.HttpRequest class. Before the Page_Load method is called, ASP.NET initializes the Request object, i.e. finishes receiving HTTP POST request from a client computer and fills the Form and Files collections in. To simplify accessing the POST request fields Image Uploader ASP.NET provides the PostFields class.

Note

If you choose this approach we do not recommend enabling chunks, otherwise you will have to write significant amount of non-trivial server-side code to assembly the files on your server.

Note

Image Uploader sends a HEAD request before the POST one, so, you should check the type of Request.

The following code sample saves original files, thumbnails, and original file-related information using described approach.

C#

private void Page_Load(System.Object sender, System.EventArgs e)
{
    if (System.String.Equals(Request.RequestType, "POST"))
    {
        string galleryPath = Server.MapPath("Gallery/");
        string thumbnailsPath = galleryPath + "Thumbnails/";

        int fileCount = int.Parse(Request[PostFields.PackageFileCount]);
        for (int i = 0; i < fileCount; i++)
        {
            string originalFileName = Request[string.Format(PostFields.SourceName, i)];

            // save original file
            string sourceFileName = GetSafeFileName(galleryPath, originalFileName);
            HttpPostedFile sourceFile = Request.Files[string.Format(PostFields.File, 0, i)];
            if (sourceFile != null)
                sourceFile.SaveAs(System.IO.Path.Combine(galleryPath, sourceFileName));

            // save thumbnail
            string thumbnailFileName = GetSafeFileName(thumbnailsPath, originalFileName);
            HttpPostedFile thumbnailFile = Request.Files[string.Format(PostFields.File, 1, i)];
            if (thumbnailFile != null)
                thumbnailFile.SaveAs(System.IO.Path.Combine(thumbnailsPath, thumbnailFileName));

            //Save file info.
            System.Xml.XmlDocument descriptions = new System.Xml.XmlDocument();
            if (System.IO.File.Exists(galleryPath + "Descriptions.xml"))
                descriptions.Load(galleryPath + "Descriptions.xml");
            else
                descriptions.AppendChild(descriptions.CreateElement("files"));

            System.Xml.XmlElement file = descriptions.CreateElement("file");
            file.SetAttribute("name", sourceFileName);
            file.SetAttribute("thumbName", thumbnailFileName);
            file.SetAttribute("width", Request[string.Format(PostFields.SourceWidth, i)]);
            file.SetAttribute("height", Request[string.Format(PostFields.SourceHeight, i)]);
            file.SetAttribute("description", Request[string.Format(PostFields.Description, i)]);
            descriptions.DocumentElement.AppendChild(file);
            //Save xml file with uploaded files info.
            descriptions.Save(galleryPath + "Descriptions.xml");
        }
    }
}

private string GetSafeFileName(string path, string fileName)
{
    // ...
}

See Also

Reference

  • Uploader Class
  • UploadRequest Class
  • UploadHandler Class
  • UploadSettings Class
  • Converter Class
  • FileUploadedEventArgs Class
  • AllFilesUploadedEventArgs Class
  • UploadedFile Class
  • ConvertedFile Class
  • Package Class
  • PostFields Class

Manual

  • Quick Start with Image Uploader ASP.NET
  • Configuring Files to be Uploaded
  • Configuring Common Upload Settings
  • Uploading Folders in ASP.NET

MSDN Articles

  • HTTP Handlers and HTTP Modules Overview
  • Uploader.FileUploaded
  • UploadRequest.FileUploaded
  • UploadHandler.FileUploaded
  • Uploader.AllFilesUploaded
  • UploadRequest.AllFilesUploaded
  • UploadHandler.AllFilesUploaded
  • Uploader.AutoSave
  • UploadRequest.AutoSave
  • UploadHandler.AutoSave
  • Uploader.DestinationFolder
  • UploadRequest.DestinationFolder
  • UploadHandler.DestinationFolder
  • Uploader.TempDirectory
  • UploadRequest.TempDirectory
  • UploadHandler.TempDirectory


Uploading Folders in ASP.NET

Uploading folders is extremely useful when users are allowed to upload large amounts of files. This topic describes how to set up uploading folders on client side and restore folders structure on a server.

Note

Image Uploader Express does not display and upload folders. See the Comparison of Image Uploader Editions topic for details.

Uploading Folders on Client Side

Configuring folders uploading in Image Uploader is straight-forward and simple to understand. You use the only one property - Uploader.FolderProcessingMode to say to the control how to deal with folders. Let us describe all FolderProcessingMode possible values:

  • Skip does not show subfolders in the folder pane, so it is impossible to select a whole folder if it is not a current folder. Only files are uploaded.
  • Show makes subfolders visible in the folder pane, so a user can select whole folders. However, restoring folders structure on server side is impossible, because no file path information is uploaded. Only files are uploaded, even if a user selects a folder.
  • Upload shows subfolders in the folder pane, so a user can select whole folders. Moreover, it is possible to restore folders structure on a server, because Image Uploader sends each file along with its path relative to the selected folder. Folders and files are uploaded.
Note

When a user selects a folder to upload all its subfolders become selected recursively, in Show and Upload modes.

To allow uploading folder set the FolderProcessingMode property to Upload, like it is shown in the following configuration:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server" FolderProcessingMode="Upload" />

In this case, if a user selects a whole folder, all the files located in this folder will be recursively added to the upload pane; so a user can clearly see all the files selected for upload at once. When a user clicks Upload, the structure of this folder will be sent to a server via relative paths to each of the selected files. For example, if a user sends a MyDocuments folder, which contains a MyPhotos subfolder, all files inside this subfolder will be sent to a server along with MyDocuments\MyPhotos\filename relative paths and all files contained directly in the MyDocuments folder will have MyDocuments\filename relative paths.

Note

Image Uploader sends only relative paths along with uploaded files, never absolute, because of the security reason.

Restoring Folders Structure on Server Side

There are three ways to restore folders structure on server side corresponding to approaches described in the Saving Uploaded Files in ASP.NET topic. Let us examine each of these ways in detail, beginning with the simplest one.

Restoring Folders Structure Automatically

In this case all the uploaded files and folders are saved on a server automatically. All you need is just to enable the autosave feature for chosen Image Uploader ASP.NET server-side component. If you do not know what component to choose, either Uploader, UploadRequest, or UploadHandler, please, see the server-side components section. In order to configure the component set the Autosave property to true and specify the DestinationFolder with a path where uploaded files and folders should be saved. For more information on this approach see the uploading files to the specified folder section.

Here is the example which allows uploading folders and enables autosave for the Uploader control.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server" FolderProcessingMode="Upload"
    Autosave="true" DestinationFolder="~/Catalog" />

Restoring Folders Structure Using Server-side Components

Here you recreate uploaded folders manually using one of the following server-side components: Uploader, UploadRequest, or UploadHandler. If you are unfamiliar with these classes, please, read the server-side components section first. Each of these components exposes the FileUploaded and AllFilesUploaded events allowing you to access all the uploaded file details via the UploadedFile properties. In particular, a relative path is available through the UploadedFile.RelativePath property. For more information about these events see the extended processing of uploaded data section.

The following example uses the FileUploaded event to create a folder for the currently uploaded file (if it was uploaded within a folder, of course) and save this file in it.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server" FolderProcessingMode="Upload"
    OnFileUploaded="FileUploaded" />

C#

protected void FileUploaded(object sender, Aurigma.ImageUploader.FileUploadedEventArgs e)
{
    string absPath = System.IO.Path.Combine(Server.MapPath("Gallery/"), e.UploadedFile.RelativePath);

    System.IO.DirectoryInfo destFolder = new System.IO.DirectoryInfo(absPath);
    if (!destFolder.Exists)
        destFolder.Create();

    string fileName = System.IO.Path.Combine(destFolder.FullName, e.UploadedFile.SourceName);
    e.UploadedFile.ConvertedFiles[0].SaveAs(fileName);
}

Restoring Folders Structure Using POST Fields Data

This method requires only a standard ASP.NET Request object to get a relative path to the uploaded file. The path is stored in the SourceName field of received POST request, so you can use it to restore folder structure manually. We also recommend you to use the PostFields class to get names of POST fields. For more information about saving files this way, see the parsing POST requests using standard ASP.NET Request object section.

Note

Image Uploader sends a HEAD request before the POST one, so, you should check the type of Request.

The example below parses the received request via the standard ASP.NET Request object, creates uploaded folders, and saves files to them.

C#

protected void Page_Load(System.Object sender, System.EventArgs e)
{
    if (string.Equals(Request.RequestType, "POST"))
    {
        int fileCount = int.Parse(Request.Params[Aurigma.ImageUploader.PostFields.PackageCount]);
        for (int i = 0; i < fileCount; i++)
        {
            if (Request.Files[string.Format(Aurigma.ImageUploader.PostFields.File, 0, i)] != null)
            {
                string fileName = System.IO.Path.Combine(Server.MapPath("Uploads/"),
                    Request[string.Format(Aurigma.ImageUploader.PostFields.SourceName, i)]);
                Request.Files[string.Format(Aurigma.ImageUploader.PostFields.File, 0, i)].SaveAs(fileName);
            }
        }
    }
}

See Also

Reference

  • Uploader Class
  • UploadRequest Class
  • UploadHandler Class
  • FileUploadedEventArgs Class
  • UploadedFile Class
  • PostFields Class

Manual

  • Saving Uploaded Files in ASP.NET
  • Uploader.FileUploaded
  • UploadRequest.FileUploaded
  • UploadHandler.FileUploaded
  • Uploader.AllFilesUploaded
  • UploadRequest.AllFilesUploaded
  • UploadHandler.AllFilesUploaded
  • Uploader.AutoSave
  • UploadRequest.AutoSave
  • UploadHandler.AutoSave
  • Uploader.DestinationFolder
  • UploadRequest.DestinationFolder
  • UploadHandler.DestinationFolder


Uploading Additional Data in ASP.NET

Pretty often it is necessary to send additional information along with files. Image Uploader comprehensively solves this task and supports uploading the following kinds of additional information:

  • a common information about upload defined by the Web site logic, such as an author name, keywords, or a category caption
  • a simple text description
  • a hidden tag
  • image crop bounds and rotation angle
  • more image-specific information, like copyright notes and camera parameters during capturing, contained in EXIF and IPTC fields
  • hash sums

This topic has three paragraphs, namely, uploading common data, uploading image-specific data and hash sums. Each of them describes approaches on how to send and receive relevant data, possibilities provided by these approaches, and code samples.

Note

If you are unfamiliar with the Saving Uploaded Files in ASP.NET topic, please, read it first.

Uploading Common Data

This section describes several approaches to uploading additional data. They are quite different but have two features in common, namely, independence of file types and upload of common data.

  • To get user-provided information about a whole upload you may use an HTML form, as it is described in the using additional HTML form section. This approach is simple to use and understand, it is also quite flexible. Pay attention that in this case you cannot upload different data for different files, only one set of data for a whole upload.
  • To add hidden data to a whole upload you can use custom fields. As opposed to the previous method, this one allows you to add data programmatically. For more information about this approach, see the using additional field section.
  • To upload user-defined file descriptions you do not need to configure Image Uploader beforehand, so it is the simplest way to get additional information with each uploaded file. Receiving of descriptions is examined in the using descriptions section.
  • To send a hidden piece of data for each user-selected file you may use tags. This approach is described in the using tags section.
  • To add elementary information to upload you can pass additional data as arguments like it is usually done in GET requests, this approach is described in the using query string section.

Using Additional HTML Form

Using HTML forms is the most straight-forward way to upload data in web applications, thus Image Uploader supports it. All you need is just to add the desired form to the same page where the Uploader control is hosted and set the Metadata.AdditionalFormName property to the name of created form. Then, when a user clicks Upload, the form data will be submitted along with user-selected files. On the server side, the fields of this form are accessible through the Package.PackageFields collection by their names.

An additional form can contain HTML input elements of different types, for example, you may use:

  • text for an author name
  • checkbox to determine whether to send a notification about the upload completion
  • select to choose keywords related to the upload
Note

The following input types are not allowed: file, image, button, and reset. Their values will not be sent at all.

Sending Data

The following configuration makes Image Uploader sending data from the addForm form along with uploaded files.

ASP.NET

<form id="addForm" name="addForm">
   <input ID="keywords" name="keywords" type="text" />
   <input ID="addressee" name="addressee" type="text" />
</form>
<form id="form1" runat="server">
    <aur:Uploader ID="Uploader1" runat="server" OnAllFilesUploaded="AllFilesUploaded">
        <Metadata AdditionalFormName="addForm" />
    </aur:Uploader>
</form>

Receiving Sent Data

Fields of the additional form are sent in each package, though in the following example we use the first package, which number is 0, because there is always at least one package in the upload session.

C#

protected void AllFilesUploaded(object sender, Aurigma.ImageUploader.AllFilesUploadedEventArgs e)
{
    string keywords = e.Packages[0].PackageFields["keywords"];
    string addressee = e.Packages[0].PackageFields["addressee"];
}

Using Additional Field

Additional fields can be attached to the POST request using the metadata.addCustomField(String, String, Boolean) method. It accepts the following parameters:

  1. name of the additional field
  2. value of the additional field
  3. optional parameter telling how to deal with previous value of this field, which is overwritten by default

You may add custom fields to the upload request only at runtime using the Image Uploader JavaScript API. Custom fields can use any format you like but should not conflict with the standard field names. See the POST Field Reference topic for a full list of standard Image Uploader fields.

On the server side, additional fields are accessible through the Package.PackageFields collection by their names.

The following example sends and receives an additional field named authorField. Here the metadata.addCustomField(String, String, Boolean) method is called in the BeforeUpload event handler, which fires when the upload is about to be started. For more information about events, please, see the using events section.

Sending Data

ASP.NET

<script type="text/javascript" language="javascript">
function onBeforeUpload() {
    this.metadata().addCustomField('authorField', 'Author Name');
}
</script>
<form id="form1" runat="server">
    <aur:Uploader ID="Uploader1" runat="server" OnAllFilesUploaded="AllFilesUploaded" >
        <ClientEvents>
            <aur:ClientEvent EventName="BeforeUpload" HandlerName="onBeforeUpload" />
        </ClientEvents>
    </aur:Uploader>
</form>

Receiving Sent Data

Additional fields are sent in each package, though in the following example we use the first package, which number is 0, because there is always at least one package in the upload session.

C#

protected void AllFilesUploaded(object sender, Aurigma.ImageUploader.AllFilesUploadedEventArgs e)
{
    string author = e.Packages[0].PackageFields["authorField"];
}

Receiving Descriptions

Each file uploaded via Image Uploader may have a description. There is no need to turn this possibility on, because it is enabled by default. So, let us examine how to get descriptions of uploaded files on a server using the FileUploaded event handler:

C#

protected void FileUploaded(object sender, Aurigma.ImageUploader.FileUploadedEventArgs e)
{
    string description = e.UploadedFile.Description;
}

Using Tags

Tags give you an opportunity to send a hidden piece of data with each user-selected file. To attach such data use the file.tag property as it is demonstrated in the sample below. You may set tags only at runtime using the Image Uploader JavaScript API.

On the server side you may get a tag through the UploadedFile.Tag property.

The following example sends and receives tags for all selected files. Here the file.tag property is specified in the BeforeUpload event handler, which fires when the upload is about to be started. For more information about events, please, see the using events section.

Sending Data

ASP.NET

<script type="text/javascript" language="javascript">
function onBeforeUpload() {
    var files = $au.uploader('Uploader1').files();
    var count = files.count();
    for (var i = 0; i < count; i++)
        files.get(i).tag('tag;file_' + i);
}
</script>
<form id="form1" runat="server">
   <aur:Uploader ID="Uploader1" runat="server" OnFileUploaded="FileUploaded">
        <Converters>
            <aur:Converter Mode="*.*=SourceFile" />
        </Converters>
        <ClientEvents>
            <aur:ClientEvent EventName="BeforeUpload" HandlerName="onBeforeUpload" />
        </ClientEvents>
    </aur:Uploader>
</form>

Receiving Sent Data

C#

protected void FileUploaded(object sender, Aurigma.ImageUploader.FileUploadedEventArgs e)
{
    string tag = e.UploadedFile.Tag;
}

Using Query String

To pass data via the query string, just add necessary arguments to the upload script URL (UploadSettings.ActionUrl) and parse the request on a server as it is shown in the example below.

Sending Data

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <UploadSettings ActionUrl="Default.aspx?argument1=value1&argument2=value2" />
</aur:Uploader>

Receiving Sent Data

C#

protected void Page_Load(object sender, EventArgs e)
{
    if (System.String.Equals(Request.RequestType, "POST"))
    {
        string arg1 = Request["argument1"];
        string arg2 = Request["argument2"];
   }
}

Uploading Image-specific Data

Image Uploader has some imaging capabilities, which are described in the Working with Images topic and Uploading Images section. Let us describe two of these features, which allow uploading additional data:

  1. Rotating and Cropping of images are enabled in Image Uploader by default. So, it is a good idea to get rotation angle and crop bounds on a server. To know more on how to do this, see the receiving rotation angle and crop bounds section.
  2. Working with EXIF and IPTC Metadata provides, among other possibilities, an opportunity to extract and upload EXIF and IPTC fields for each user-selected image. EXIF metadata is a special information about the image, written into the file by the capturing device when an image was captured. These metadata may provide camera parameters during capturing, date and time of the capturing, photographer's name, and etc. IPTC is another metadata format, which is widely used in journalism to keep information about a photo, like byline, subject, location, and etc. See the handling EXIF and IPTC metadata section for detailed description on how to send and receive such metadata.

Receiving Rotation Angle and Crop Bounds

A rotation angle and crop bounds can be got through the Angle and CropBounds properties of the UploadedFile class respectively. Image Uploader measures rotation angle in degrees clockwise.

As soon as rotation and cropping of images are allowed by default, there is no need to configure Image Uploader to send them, so the following example shows only how to receive such data on a server.

C#

protected void FileUploaded(object sender, Aurigma.ImageUploader.FileUploadedEventArgs e)
{
    int angle = e.UploadedFile.Angle;
    Rectangle cropBounds = e.UploadedFile.CropBounds;
}

Handling EXIF and IPTC Metadata

To upload EXIF or IPTC values, you should specify the desired fields using the Metadata.Exif and Metadata.Iptc properties. Both these properties represent semicolon separated lists of field names which should be extracted and uploaded along with images. Metadata.ValueSeparator sets a string separator for fields which can contain multiple string values, like IptcKeyword.

Sending Data

The following example sends two EXIF and two IPTC fields for each user-selected image:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server" OnFileUploaded="FileUploaded">
    <Converters>
        <aur:Converter Mode="*.*=SourceFile" />
    </Converters>
    <Metadata Iptc="IptcCopyrightNotice;IptcKeyword" ValueSeparator=";"
        Exif="ExifColorSpace;ExifDateTime" />
</aur:Uploader>

Receiving Sent Data

The following example gets the EXIF and IPTC fields sent accordingly to the previous configuration and writes these values to the Descriptions.xml file. Here uploaded fields are contained in the Package.PackageFields collection and can be retrieved by keys named in the following way: FieldName_xx, where FieldName is a name of an EXIF or IPTC field and xx is the index of an uploaded file in this package.

C#

protected void FileUploaded(object sender, Aurigma.ImageUploader.FileUploadedEventArgs e)
{
    string galleryPath = Server.MapPath("Gallery");
    System.Xml.XmlDocument descriptions = new System.Xml.XmlDocument();
    if (System.IO.File.Exists(galleryPath + "Descriptions.xml"))
        descriptions.Load(galleryPath + "Descriptions.xml");
    else
        descriptions.AppendChild(descriptions.CreateElement("files"));

    System.Xml.XmlElement file = descriptions.CreateElement("file");
    file.SetAttribute("name", e.UploadedFile.SourceName);
    file.SetAttribute("CopyrightNotice", e.UploadedFile.Package.PackageFields["IptcCopyrightNotice_" + e.UploadedFile.Index]);
    file.SetAttribute("IptcKeyword", e.UploadedFile.Package.PackageFields["IptcKeyword_" + e.UploadedFile.Index]);
    file.SetAttribute("ExifColorSpace", e.UploadedFile.Package.PackageFields["ExifColorSpace_" + e.UploadedFile.Index]);
    file.SetAttribute("ExifDateTime", e.UploadedFile.Package.PackageFields["ExifDateTime_" + e.UploadedFile.Index]);
    descriptions.DocumentElement.AppendChild(file);
    descriptions.Save(galleryPath + "Descriptions.xml");
}
Note

All date/time values have the following format: YYYY:MM:DD hh:mm:ss. For example, May 11, 2006, 2:40PM would be represented as: 2006:05:11 14:40:00.

Using Hash Sums

Note

Image Uploader Express does not upload hash sums. See the Comparison of Image Uploader Editions topic for details.

File hash sum uniqely identifies the file, so it is useful in the following situations: to check upload integrity and to detect duplicate files.

Image Uploader provides the Metadata.Hash property to handle hash sums. If you specify this property and select at least one algorithm, Image Uploader will calculate hash values for user-selected files, encode them using the Base64 algorithm, and send along with files. On the server side the uploaded hash sums are accessible through the Package.PackageFields collection. Name of a field containing hash sum is HashCodeAlgorithmName_xx, where AlgorithmName is one of the following algorithms - SHA, MD2, or MD5, and xx is the index of an uploaded file in a package. If you specify several algorithms, several hash values will be sent (one value per algorithm).

Checking upload integrity works in the following way:

  1. You set one or several hash algorithms in the Metadata.Hash property.
  2. Before the upload begins, Image Uploader calculates the hash value (or several values) according to settings specified on the first step.
  3. Base64-encoded hash value is appended to the request.
  4. The server side code calculates the hash value using the same algorithm and compares it with the uploaded one.
  5. If hash values are the same, the verification is successful. Otherwise, the upload is corrupted.
Note

Image Uploader sends hash sums generated for original files regardless of Converter.Mode you use. So, if you are going to implement integrity check, please, be sure that you enabled a SourceFile Converter on the client side and calculate hash values for copies of original files on a server.

The following two-part example illustrates this algorithm. The first part configures Image Uploader to send an MD5 hash sum for each user-selected file. While the second one calculates the MD5 hash sum of the received copy of original file, compares it with the uploaded sum, and saves the file if both hash sums are identical, which means that upload is successful.

Sending Data

ASP.NET

<aur:Uploader ID="Uploader1" runat="server" OnFileUploaded="FileUploaded">
    <Metadata Hash="MD5" />
    <Converters>
        <aur:Converter Mode="*.*=SourceFile" />
    </Converters>
</aur:Uploader>

Receiving Sent Data

C#

protected void FileUploaded(object sender, Aurigma.ImageUploader.FileUploadedEventArgs e)
{
    Aurigma.ImageUploader.ConvertedFile sourceFile = e.UploadedFile.ConvertedFiles[0];
    System.Security.Cryptography.MD5 md5 =
        new System.Security.Cryptography.MD5CryptoServiceProvider();
    string actualMd5 = Convert.ToBase64String(md5.ComputeHash(sourceFile.FileStream),
        Base64FormattingOptions.InsertLineBreaks);
    string receivedMd5 = e.UploadedFile.Package.PackageFields["HashCodeMD5_" + e.UploadedFile.Index];
    if (string.Equals(actualMd5, receivedMd5))
    {
        sourceFile.SaveAs(System.IO.Path.Combine(Server.MapPath("Gallery"), sourceFile.Name));
    }
}

See Also

Reference

  • Metadata Class
  • Package Class
  • addCustomField(String, String, Boolean) Method
  • tag Property
  • UploadedFile Class
  • FileUploaded
  • AllFilesUploaded
  • BeforeUpload Event
  • ActionUrl Property

Manual

  • Saving Uploaded Files in ASP.NET
  • Configuring POST Format
  • Using JavaScript API
  • Rotating and Cropping
  • Working with EXIF and IPTC Metadata
  • Working with Images
  • Uploader.FileUploaded
  • UploadRequest.FileUploaded
  • UploadHandler.FileUploaded
  • Uploader.AllFilesUploaded
  • UploadRequest.AllFilesUploaded
  • UploadHandler.AllFilesUploaded


Maintaining Sessions and Authentication in ASP.NET

If you are going to utilize Image Uploader in non-Internet Explorer browsers (Firefox, Safari, and etc), you should take care about keeping your session and authentication cookies saved if they are used. The fact is that Image Uploader does not send cookies in output requests in non-Internet Explorer browsers by default and, therefore, session and authentication tickets are lost during the upload. To work around this problem you may employ special facilities provided either by Image Uploader ASP.NET or Image Uploader JavaScript. Let us consider how to use them.

Using Image Uploader ASP.NET Control

If you use Image Uploader ASP.NET, session and authentication information will be automatically passed to the upload request. If you are unfamiliar with Image Uploader ASP.NET, please, see the Quick Start with Image Uploader ASP.NET topic.

In order to configure the ASP.NET authentication scheme you should add the authentication section to your web.config, for example, like it is shown in the following example:

XML

<authentication mode="Forms">
  <forms name="AurigmaUser" loginUrl="~/Login.aspx" defaultUrl="~/Default.aspx"
         protection="All" path="/" timeout="525600"/>
</authentication>

Using Image Uploader JavaScript API

If you prefer not to use Image Uploader ASP.NET, then you should add cookies to the upload request manually via the Image Uploader JavaScript. To do it, use the metadata.addCookie(String) method which accepts cookie in the following format: "cookieName=cookieValue". The most convenient place to call this method is the BeforeUpload event handler, because this event fires when the upload is about to be started.

JavaScript

function beforeUploadHandler(){
    var u = $au.uploader('Uploader1');
    u.metadata().addCookie('ASP.NET_SessionId=<%=Page.Session.SessionID%>');
    u.metadata().addCookie('<%=FormsAuthentication.FormsCookieName%>=' +
        '<%=Request.Cookies[FormsAuthentication.FormsCookieName].Value %>');
};

var u = $au.uploader({
    id: 'Uploader1',
    events: { beforeUpload: beforeUploadHandler}
});

u.writeHtml();

The previous example uses ASP.NET_SessionId as session cookie name, because it is default name for this cookie in ASP.NET. However, you may determine the session cookie name programatically, as follows:

C#

((System.Web.Configuration.SessionStateSection)ConfigurationManager.GetSection("system.web/sessionState")).CookieName

See Also

Reference

  • metadata Class
  • Uploader Class
  • BeforeUpload Event

Manual

  • Quick Start with Image Uploader ASP.NET
  • Using JavaScript API


Debugging ASP.NET Upload Scripts

This topic describes different approaches for solving the issue when Image Uploader is unable to successfully upload files and displays the following error message:

500: Internal Server Error

This error message indicates that some server-side error occurred during the upload process. Here are the most probable issues causing the problem:

  • Image Uploader cannot save uploaded files because of wrong permissions configuration. See the Configuring ASP.NET topic to get to know how to set required permissions.
  • The request size is too big. See the Configuring ASP.NET topic to get to know how to increase maximum request length.
  • There is an error in your server upload script (specified with the UploadSettings.ActionUrl property). See the debug approaches described below to find the error.
Note

If you experience an issue having different sympthoms than ones described in this article, please, see the Basic Steps in Troubleshooting topic.

Here we consider the following approaches for handling and debugging server-side errors:

  • Error logging approach is more convenient for production applications. It catches all the exceptions and writes error details to a log file; so, it does not show any information about errors to users.
  • Handling error event approach implies showing the server response when some error occurs. If displaying errors is enabled, this response contains error details. However, this approach requires some modifications of Image Uploader settings.
  • Using sniffer allows you to view server response without necessity to modify embedding code, but it uses a third-party tool.
  • Running script in debug mode means debugging ASP.NET Web applications in the same manner as Windows Forms.

Error Logging

This strategy implies enclosing the part of the upload script which saves files in try/catch block and writing exception details to external log file. The code sample below implements the LogError(String,String) method to create a current date log file in the /Logs folder of an application and write error message and stack trace to this log file.

C#

private void LogError(string errorMessage, string stackTrace)
{
    string logPath = Server.MapPath("~/Logs/" + DateTime.Today.ToString("MM-dd-yy") + ".log");
    if (!System.IO.File.Exists(logPath))
        System.IO.File.Create(logPath).Close();

    using (System.IO.StreamWriter w = System.IO.File.AppendText(logPath))
    {
        w.WriteLine("{0} Error: {1}",
            DateTime.Now.ToString(System.Globalization.CultureInfo.InvariantCulture),
            errorMessage);
        w.WriteLine(stackTrace);
        w.Flush();
        w.Close();
    }
}

protected void AllFilesUploaded(object sender, Aurigma.ImageUploader.AllFilesUploadedEventArgs e)
{
    try
    {
        SaveFiles(e);
    }
    catch (Exception ex)
    {
        LogError(ex.Message, ex.StackTrace);
    }
}

private void SaveFiles(Aurigma.ImageUploader.AllFilesUploadedEventArgs e)
{
    // ...
    // Saving uploaded files
    // ...
}

This method writes error details in the following way:

10/18/2010 15:52:11 Error: Object reference not set to an instance of an object.
    at _Default.SaveFiles(AllFilesUploadedEventArgs e) in c:\inetpub\wwwroot\Uploader\ErrorLogging\upload.aspx:line 66
    at _Default.AllFilesUploaded(Object sender, AllFilesUploadedEventArgs e) in c:\inetpub\wwwroot\Uploader\ErrorLogging\upload.aspx:line 51

You may need to slightly modify the code above to use the described approach with other methods of Saving Uploaded Files in ASP.NET.

Handling Error Event

If you are not familiar with the client events in Image Uploader, please, read the Using JavaScript API topic first.

Image Uploader exposes the Error event which fires when a server or client-side error occurs. Error type is defined by the errorCode argument of this event, and in the case of server-side error it is equal to 4. The full list of error codes can be found in Error event parameters. Detailed description of an occurred error is available through the errorPage which represents the web page returned from the server.

The following example shows how to display error details if a server-side error occurs.

ASP.NET

<script type="text/javascript">
function errorHandler(errorCode, httpResponseCode, errorPage, additionalInfo){
    if (errorCode == 4) {
        var newWindow = window.open();
        with (newWindow.document) {
            open("text/html");
            write(errorPage);
            close();
        }
    }
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName ="Error" HandlerName="errorHandler" />
    </ClientEvents>
</aur:Uploader>

Using Sniffer

Sniffer is a network analyzer software which allows tracking interactions between client-side and server-side parts of an application. Here we consider the Fiddler tool as an example of debugging server-side upload script.

  1. Open default.aspx in your browser. If it is able to send traffic to Fiddler, the corresponded session will be displayed in the Web Sessions pane of the tool.
  2. Send a file via Image Uploader.

  3. Double-click the upload.aspx session in the Web Sessions pane.

    Using Fiddler to debug upload script in ASP.NET

    Find upload session details in the left part of Fiddler's interface. Here it contains the POST request sent by Image Uploader and the response returned by your upload script. So, if your upload script contains an error this error details will be displayed in the returned response.

Running Script in Debug Mode

Microsoft Visual Studio allows debugging ASP.NET Web applications in the same manner as Windows Forms. See the Debugging ASP.NET Web Applications During Development and Debugging Deployed ASP.NET Web Applications MSDN topics for step-by-step instructions on how to debug ASP.NET Web applications.

See Also

Reference

  • Error Event
  • UploadSettings.ActionUrl Property

Manual

  • Saving Uploaded Files in ASP.NET
  • Configuring ASP.NET
  • Basic Steps in Troubleshooting
  • Using JavaScript API

Other Resources

  • Fiddler
  • Debugging ASP.NET Web Applications During Development
  • Debugging Deployed ASP.NET Web Applications


Uploading in PHP

This section consists of topics that discuss uploading in PHP platform.

In This Section

Configuring PHP
Saving Uploaded Files in PHP
Uploading Folders in PHP
Uploading Additional Data in PHP
Maintaining Sessions and Authentication in PHP
Debugging PHP Upload Scripts


Configuring PHP

Typically, default server configuration does not allow uploading files with Image Uploader. This topic describes how to configure a server you are going to deploy Image Uploader on properly.

Configuring Permissions

The folder where you are going to save files should have modify permissions. Depending on your operating system it can be set in one of the following ways:

  • On Windows NT/2000/XP you should grant the modify permission to the Internet guest user (IUSR_<machinename>).
  • On Windows 2003 Server you should grant the modify permission to the NETWORK SERVICE group.
  • On Windows Vista/2008 Server/7 you should grant the modify permission to the account your site application pool is running under, Network Service by default.
  • For *NIX systems you should specify read and write permissions.

Configuring Maximum POST Request Length

Usually, a limitation for maximum POST request length is specified to reduce the risk of DoS attacks. If the request size exceeds a specific value, it is considered malicious and the upload would be broken.

Editing PHP Configuration Files

To increase the limit of the maximum upload size, you should edit your PHP configuration files:

  1. Open the php.ini file. You can find it:

    • on Linux in /etc/php.ini
    • on Windows in c:\windows\php.ini

  2. Set the required limits:

    post_max_size = 100MB
upload_max_filesize = 100MB

  3. Optionally, set the following parameters:

    • memory_limit
    • upload_tmp_dir
    • max_execution_time

To make sure that new settings are applied, use the phpinfo() function which outputs information about the current state of PHP.

PHP

<?php
    phpinfo();
?>

Configuring Apache Web Server

If you use the Apache web server, you should also edit the php.conf file:

  1. Open the php.conf file. You can find it:

    • on Linux in /etc/httpd/conf.d/php.conf
    • on Windows in <Apache installation folder>\conf\php.conf

  2. Change the LimitRequestBody parameter according to the post_max_size value, e.g.:

    LimitRequestBody 104857600

Do not forget to restart your server after modifying its configuration.

Configuring IIS Web Server

If you use the IIS web server, you should follow one of the next configurations.

IIS 7 Configuration

  1. Go to C:\Windows\System32\inetsrv\config\applicationHost.config and change

    XML

    <section name="requestFiltering" overrideModeDefault="Deny" />

    to:

    XML

    <section name="requestFiltering" overrideModeDefault="Allow" />

  2. Add to your application's web.config the following sections:

    XML

    <system.webServer>
    <security>
        <requestFiltering>
            <requestLimits maxAllowedContentLength ="2147482624" /> <!-- in bytes -->
        </requestFiltering>
    </security>
</system.webServer>

    XML

    <system.web>
     <httpRuntime maxRequestLength="2097151"/> <!-- in kilobytes -->
</system.web>

IIS 6 Configuration

Add to your application's web.config the following section:

XML

<system.web>
    <httpRuntime maxRequestLength="2097151"/> <!-- in kilobytes -->
</system.web>

If you have URLScan installed and still experience this problem, go through the following steps:

  1. Open the UrlScan.ini file which is typically located at C:\Windows\system32\inetsrv\urlscan folder.
  2. Set the MaxAllowedContentLength key to the desired value (in bytes).
  3. Save changes and restart IIS.

Do not forget to restart your server after modifying its configuration.


Saving Uploaded Files in PHP

As you know Image Uploader sends files and additional metadata from client computers to server side in HTTP POST requests. This approach requires server script to parse the received requests and handle uploaded data. Reading this topic you will get to know how to extract files and additional data sent by clients, save it all to file system on a server or handle in some other way. There are three approaches to perform this task:

  • Uploading files to the specified folder on a server. This is the simplest way, it allows saving all uploaded files almost without coding. However, this method is not flexible enough, so do not use it if you need to get access to additional data (such as information about original files, additional fields, etc.).
  • Extended processing of uploaded data using the UploadHandler. This approach gives you flexible typed access to all data sent from client computers. It suites best for PHP applications because Image Uploader PHP classes offer server-side API allowing to accomplish any operation on the uploaded data in a usual for PHP developers way.
  • Parsing POST requests using PHP predefined variables ($_FILES and $_POST). This method is not different from when you are using form-based file upload in HTML (browse/upload buttons on your page). In case if you use it you get untyped access to uploaded data, also this approach does not support automatic assembling files from chunks (in case if you enable them in the Image Uploader, of course). The main advantage of this method is that you do not have additional references to Image Uploader PHP in your application.
Note

If you parse requests using PHP predefined variables and enable sending files by chunks you will have to write significant amount of non-trivial server-side code to assembly the files on your server. This way, we do not recommend enabling chunks if you use this method of handling requests.

Further in this topic every approach will be described in detail. Let us start with the UploadHandler class description.

The UploadHandler Class

All the Image Uploader PHP classes are located in the /ImageUploaderPHP/ folder. The key class is UploadHandler, which allows processing the data uploaded from client computers. This class has user-friendly API and functionality giving flexible typed access to these data. In order to use UploadHandler you have to include UploadHandler.class.php into your upload handling script (see: Quick Start with Image Uploader PHP), for example, upload.php:

PHP

<?php
require_once "ImageUploaderPHP/UploadHandler.class.php";
$handler = new UploadHandler();
?>

And specify URL to this script as a value of the UploadSettings.ActionUrl property (both absolute and relative URLs are supported) like it is shown below:

PHP

<?php
$uploader->getUploadSettings()->setActionUrl("upload.php");
?>

Uploading Files to Specified Folder

This section describes the simplest way of handling uploaded data - autosave. This approach allows you to save all the uploaded files to the specified folder on your server without writing a lot of code. The UploadHandler class described in the previous section can save uploaded files automatically. You just create a new instance of this class in your upload handling script and call its saveFiles(string) method providing a path to the folder where uploaded files should be saved as a parameter. If the specified folder does not exist Image Uploader tries to create it.

Also autosave supports the Uploader.FolderProcessingMode feature that allows uploading whole folders rather than just files and restoring their structure on server side automatically, see the Uploading Folders in PHP topic for more information.

If you need to process the saved files in some way, then a page specified in the UploadSettings.RedirectUrl setting is the right place for this. Just put your code there and it will be executed after the upload process is completed.

The example below shows how to save all the uploaded files.

The upload.php file:

PHP

<?php
require_once "ImageUploaderPHP/UploadHandler.class.php";

$handler = new UploadHandler();
$handler->saveFiles("Catalog/");
?>

And a script initializing the Uploader object must contain the following code:

PHP

<?php
$uploader->getUploadSettings()->setActionUrl("upload.php");
?>

Filenames Conversions and Collisions

Image Uploader prepares files on client side in the way set by so-called converters. Each converter specifies what to do with a file selected for upload: upload it as is or apply some transformation before upload (resize image down, extract and send icon associated with a file, or compress a file to ZIP format). Converters (except for SourceFile one) add suffixes to file names uploaded to a server. For example, the name.ext_Thumbnail0.ext filename is the result of applying Mode="*.*=Thumbnail" converter on name.ext file. For a full list of possible suffixes see the ConvertedFile.Name property description.

Filenames collisions may occur while saving uploaded files to a destination folder. If the destination folder already has a file with the same name as uploaded one, the uploaded file will be saved under its name appended by _xx, where xx is a number starting from 2. For example, if there is a file with the name name.ext in the destination folder and a user tries to upload another file with the same name then uploaded file is saved as name_02.ext file. If name_02.ext file exists as well then the recently uploaded file gets name_03.ext filename and so on.

Extended Processing of Uploaded Data

This approach requires quite a bit of code, however, this method is more flexible than autosave described before. The main idea is to handle uploaded files and data in the callback functions specified by FileUploadedCallback and/or AllFilesUploadedCallback settings of the mentioned before UploadHandler class. The first function is called each time a user-specified file is successfully uploaded. The second function is called when the whole upload session completes and all the files, metadata, and additional data are received on the server side. So, the first one is called as many times as number of files selected for upload, whereas the second one is called only once.

Now, when you understand the differences between these events, let us discuss how exactly to create these event handlers. There are two steps to this process:

  • creating skeleton callback function
  • writing implementation of callback function

Creating Skeleton Callback Functions

There is a requirement for the callback functions - they must have an argument, which gets an UploadedFile or an UploadedFile array value. The following example sets both, FileUploadedCallback and AllFilesUploadedCallback, callback functions, and enables request processing by calling the processRequest() method:

PHP

<?php
require_once "ImageUploaderPHP/UploadHandler.class.php";

$handler = new UploadHandler();
$handler->setFileUploadedCallback("saveUploadedFile");
$handler->setAllFilesUploadedCallback("saveAllUploadedFiles");
$handler->processRequest();

function saveAllUploadedFiles($uploadedFiles) {
    //...
    foreach ($uploadedFiles as $uploadedFile)
    {
        //...
    }
    //...
}

function saveUploadedFile($uploadedFile) {
    //...
}
?>

There is the example of callback function implementation below.

Also do not forget to set the UploadSettings.ActionUrl property.

Writing Implementation of Callback Functions

For better understanding let us separate description of the uploaded data handling into the following sections:

  • files handling
  • metadata handling

Files Handling

The PHP server-side part of Image Uploader among its types has the UploadedFile class. This type holds all the data associated with a single file selected for upload (files prepared on client side by Image Uploader from the original file in accordance with converters set in the settings, additional fields, and other data). The FileUploadedCallback callback function gives access to an UploadedFile instance through the function argument. The AllFilesUploadedCallback callback function gives access to an array of UploadedFile objects also via its argument.

Now let us examine how to get access to uploaded files via the UploadedFile instances. Each UploadedFile object has associated collection of files prepared by Image Uploader converters on client side. Each of these files is represented by an instance of the ConvertedFile type. This way, the collection of converted files associated with a particular file selected for upload is accessible via the UploadedFile.ConvertedFiles property.

Each ConvertedFile object has two main members to handle the file:

  • the FileContent property for getting access to the file content
  • the moveTo(string) method for moving the file to the specified location

Metadata Handling

All the metadata uploaded along with a file is accessible through the UploadedFile properties and can be divided into the following groups:

File Location

There is the only one property in this group - the UploadedFile.RelativePath which returns a relative path to the original file on the client machine. This property makes sense only if Image Uploader is allowed to upload folders (FolderProcessingMode has Upload value).

Original File Information

This group includes properties containing information about the original file:

  • SourceCreatedDateTime and SourceCreatedDateTimeLocal represent creation date of the original file.
  • SourceLastModifiedDateTime and SourceLastModifiedDateTimeLocal represent last modification date of the original file.
  • SourceHeight and SourceWidth represent dimensions of the original file (in pixels) if it is an image.
  • SourceXResolution and SourceYResolution represent horizontal and vertical resolutions of the original file (in dpi) if it is an image.
  • SourceName represents the original file name.
  • SourceSize represents the original file size.

Converted File Information

The ConvertedFile class provides access to some additional information along with access to the converted file itself. Its properties contain the following information:

  • Mode contains a converter type applied to create the converted file.
  • Size represents size (in bytes) of the converted file.
  • Height and Width represent dimensions of the created downsized image (in pixels) if the converter was set to resize an original image down.

User-defined Data

This group includes the following properties:

  • Angle contains the rotation angle of the uploaded file if it is an image.
  • Description contains a user-provided description of the uploaded file.
  • CropBounds contains bounds of cropped area set for the uploaded file if it is an image.
  • Tag contains the tag of uploaded file.
  • PackageFields contains a collection of POST fields including the fields specified through the Uploader.Metadata set of properties (Metadata.AdditionalFormName, Metadata.Exif, Metadata.Iptc) and via the metadata.addCustomField(String, String, Boolean) client method.

Callback Function Example

This example is a FileUploadedCallback callback function which saves an original file and its resized copy to the ../Gallery/ and ../Gallery/Thumbnails/ folders respectively and writes some file-related information (filenames, image dimensions, user description, and etc.) to an XML file. This function is called only once when the whole upload session completes as it is set by the AllFilesUploadedCallback property.

PHP

<?php
function saveAllUploadedFiles($uploadedFiles) {
    $galleryPath = "Gallery/";
    $absGalleryPath = realpath($galleryPath);
    $absThumbnailsPath = realpath($galleryPath . DIRECTORY_SEPARATOR . "Thumbnails/");

    //Create or load XML file which will keep information about files (image dimensions, description, etc).
    $descriptions = new DOMDocument('1.0');
    if (file_exists($absGalleryPath . DIRECTORY_SEPARATOR . "Descriptions.xml"))
        $descriptions->load($absGalleryPath . DIRECTORY_SEPARATOR . "Descriptions.xml");
    else
        $descriptions->appendChild($descriptions->createElement("files"));

    foreach ($uploadedFiles as $uploadedFile)
    {
        $convertedFiles = $uploadedFile->getConvertedFiles();
        //Save original file.
        //It is the first file in ConvertedFiles collection as we set first converter mode to SourceFile.
        $sourceFile = $convertedFiles[0];
        getSafeFileName($absGalleryPath, rawurlencode($uploadedFile->getSourceName()));
        $sourceFile->moveTo($absGalleryPath . DIRECTORY_SEPARATOR . $sourceFileName);

        //Save thumbnail.
        //It is the second file in ConvertedFiles collection as we set second converter mode to Thumbnail.
        $thumbnailFile = $convertedFiles[1];
        $thumbnailFileName = getSafeFileName($absThumbnailsPath, rawurlencode($uploadedFile->getSourceName()));
        $thumbnailFile->moveTo($absThumbnailsPath . DIRECTORY_SEPARATOR . $thumbnailFileName);

        //Save file info.
        $xmlFile = $descriptions->createElement("file");
        $xmlFile->setAttribute("name", $sourceFileName);
        $xmlFile->setAttribute("thumbName", $thumbnailFileName);
        $xmlFile->setAttribute("width", $uploadedFile->getSourceWidth());
        $xmlFile->setAttribute("height", $uploadedFile->getSourceHeight());
        $xmlFile->setAttribute("description", $uploadedFile->getDescription());
        $descriptions->documentElement->appendChild($xmlFile);
    }
    $descriptions->save($absGalleryPath . DIRECTORY_SEPARATOR . "Descriptions.xml");
}

function getSafeFileName($path, $fileName) {
    // ...
}
?>

Parsing POST Requests Using PHP Predefined Variables ($_FILES and $_POST)

The last way of handling uploaded files is to parse the upload request manually via the $_FILES and $_POST "superglobals". To simplify accessing the POST request fields Image Uploader PHP provides the PostFields class.

Note

If you choose this approach we do not recommend enabling chunks, otherwise you will have to write significant amount of non-trivial server-side code to assembly the files on your server.

The following code sample demonstrates how to save original files, thumbnails, and original file-related information using described approach.

PHP

<?php
require_once "ImageUploaderPHP/PostFields.class.php";

$galleryPath = "Gallery";
$absGalleryPath = realpath($galleryPath);
$absThumbnailsPath = realpath($galleryPath . DIRECTORY_SEPARATOR . "Thumbnails");

//Create or load XML file which will keep information about files (image dimensions, description, etc).
$descriptions = new DOMDocument('1.0');
if (file_exists($absGalleryPath . DIRECTORY_SEPARATOR . "Descriptions.xml"))
    $descriptions->load($absGalleryPath . DIRECTORY_SEPARATOR . "Descriptions.xml");
else
    $descriptions->appendChild($descriptions->createElement("files"));

//Get number of files in the current package.
$fileCount = $_POST[PostFields::packageFileCount];

//Iterate through uploaded data and save the original file, thumbnail, and description.
for ($i = 0; $i < $fileCount; $i++) {

    $originalFileName = rawurlencode($_POST[sprintf(PostFields::sourceName,$i)]);

    //save source file
    $sourceFileName = getSafeFileName($absGalleryPath, $originalFileName);
    if (isset($_FILES[sprintf(PostFields::file, 0, $i)])) {
        move_uploaded_file($_FILES[sprintf(PostFields::file, 0, $i)]["tmp_name"],
            $absGalleryPath . DIRECTORY_SEPARATOR . $sourceFileName);
    }

    //save thumbnail file
    $thumbnailFileName = getSafeFileName($absThumbnailsPath, $originalFileName);
    if (isset($_FILES[sprintf(PostFields::file, 1, $i)])) {
         move_uploaded_file($_FILES[sprintf(PostFields::file, 1, $i)]["tmp_name"],
            $absThumbnailsPath . DIRECTORY_SEPARATOR . $thumbnailFileName);
    }

    //Save file info.
    $xmlFile = $descriptions->createElement("file");
    $xmlFile->setAttribute("name", $sourceFileName);
    $xmlFile->setAttribute("thumbName", $thumbnailFileName);
    $xmlFile->setAttribute("width", $_POST[sprintf(PostFields::sourceWidth, $i)]);
    $xmlFile->setAttribute("height", $_POST[sprintf(PostFields::sourceHeight, $i)]);
    $xmlFile->setAttribute("description", $_POST[sprintf(PostFields::description, $i)]);
    $descriptions->documentElement->appendChild($xmlFile);

}

$descriptions->save($absGalleryPath . DIRECTORY_SEPARATOR . "Descriptions.xml");

function getSafeFileName($path, $fileName) {
    // ...
}
?>

Also do not forget to set the UploadSettings.ActionUrl property.

See Also

Reference

  • Uploader Class
  • UploadHandler Class
  • UploadSettings Class
  • UploadedFile Class
  • ConvertedFile Class
  • Package Class
  • PostFields Class

Manual

  • Quick Start with Image Uploader PHP
  • Configuring Common Upload Settings
  • Configuring Files to be Uploaded
  • Uploading Folders in PHP


Uploading Folders in PHP

Uploading folders is extremely useful when users are allowed to upload large amounts of files. This topic describes how to set up uploading folders on client side and restore folders structure on a server.

Note

Image Uploader Express does not display and upload folders. See the Comparison of Image Uploader Editions topic for details.

Uploading Folders on Client Side

Configuring folders uploading in Image Uploader is straight-forward and simple to understand. You use the only one property - Uploader.FolderProcessingMode to say to the control how to deal with folders. Let us describe all FolderProcessingMode possible values:

  • Skip does not show subfolders in the folder pane, so it is impossible to select a whole folder if it is not a current folder. Only files are uploaded.
  • Show makes subfolders visible in the folder pane, so a user can select whole folders. However, restoring folders structure on server side is impossible, because no file path information is uploaded. Only files are uploaded, even if a user selects a folder.
  • Upload shows subfolders in the folder pane, so a user can select whole folders. Moreover, it is possible to restore folders structure on a server, because Image Uploader sends each file along with its path relative to the selected folder. Folders and files are uploaded.
Note

When a user selects a folder to upload all its subfolders become selected recursively, in Show and Upload modes.

To allow uploading folder set the FolderProcessingMode property to Upload, like it is shown in the following configuration:

PHP

<?php
    require_once "ImageUploaderPHP/Uploader.class.php";
    $uploader = new Uploader("Uploader1");
    $uploader->setFolderProcessingMode("Upload");
    $uploader->render();
?>

In this case, if a user selects a whole folder, all the files located in this folder will be recursively added to the upload pane; so a user can clearly see all the files selected for upload at once. When a user clicks Upload, the structure of this folder will be sent to a server via relative paths to each of the selected files. For example, if a user sends a MyDocuments folder, which contains a MyPhotos subfolder, all files inside this subfolder will be sent to a server along with MyDocuments\MyPhotos\filename relative paths and all files contained directly in the MyDocuments folder will have MyDocuments\filename relative paths.

Note

Image Uploader sends only relative paths along with uploaded files, never absolute, because of the security reason.

Restoring Folders Structure on Server Side

There are three ways to restore folders structure on server side corresponding to approaches described in the Saving Uploaded Files in PHP topic. Let us examine each of these ways in detail, beginning with the simplest one.

Restoring Folders Structure Automatically

In this case all the uploaded files and folders are saved on a server automatically. All you need is just to create an UploadHandler instance, in the script specified by the UploadSettings.ActionUrl property, and call its UploadHandler.saveFiles(string) method providing a path to the folder where uploaded files should be saved as a parameter. If you are unfamiliar with the UploadHandler class, please, see the server-side components section.

Here is the example which allows uploading folders and saves files and folders automatically to the Gallery folder of your site.

PHP

<?php
    require_once "ImageUploaderPHP/UploadHandler.class.php";

    $handler = new UploadHandler();
    $handler->saveFiles("Gallery/");
?>

Restoring Folders Structure Using Server-side Component

Here you recreate uploaded folders manually using the UploadHandler server-side component. If you are unfamiliar with it, please, read the server-side components section first. The UploadHandler class exposes the FileUploadedCallback and AllFilesUploadedCallback properties allowing you to set callback functions giving access all the uploaded file details via the UploadedFile properties. In particular, a relative path is available through the UploadedFile.RelativePath property. For more information about these callbacks see the extended processing of uploaded data section.

The following example uses the FileUploadedCallback property to create a folder for the currently uploaded file (if it was uploaded within a folder, of course) and save this file in it.

PHP

<?php
    require_once "ImageUploaderPHP/UploadHandler.class.php";

    function saveUploadedFile($uploadedFile) {
        $absGalleryPath = realpath("Catalog/") . DIRECTORY_SEPARATOR;
        $convertedFiles = $uploadedFile->getConvertedFiles();
        $sourceFile = $convertedFiles[0];
        $destFolder = $absGalleryPath . $uploadedFile->getRelativePath();
        $relativePath = $uploadedFile->getRelativePath();
        if (!file_exists($destFolder))
        {
            mkdir($destFolder, 0777, true);
        }
        $sourceFile->moveTo($destFolder . DIRECTORY_SEPARATOR . rawurlencode($uploadedFile->getSourceName()));
    }
    $handler = new UploadHandler();
    $handler->setFileUploadedCallback("saveUploadedFile");
    $handler->processRequest();
?>

Restoring Folders Structure Using POST Fields Data

This method requires only the standard PHP $_POST "superglobal" to get a relative path to the uploaded file. The path is stored in the SourceName field of received POST request, so you can use it to restore folder structure manually. We also recommend you to use the PostFields class to get names of POST fields. For more information about saving files this way, see the parsing POST requests using PHP predefined variables section.

The example below parses the received request via the standard PHP $_POST and $_FILES arrays, creates uploaded folders, and saves files to them.

PHP

<?php
    require_once "ImageUploaderPHP/PostFields.class.php";

    $absGalleryPath = realpath("Gallery/");
    $fileCount = $_POST[PostFields::packageFileCount];
    for ($i = 0; $i < $fileCount; $i++) {
        if (isset($_FILES[sprintf(PostFields::file, 0, $i)])) {
            $destFolder = $absGalleryPath . DIRECTORY_SEPARATOR . $_POST[sprintf(PostFields::sourceName, $i)];
            $destFolder = substr($destFolder, 0, strrpos($destFolder, "\\"));
            if (!file_exists($destFolder))
            {
                mkdir($destFolder, 0777, true);
            }
            move_uploaded_file($_FILES[sprintf(PostFields::file, 0, $i)]["tmp_name"], $absGalleryPath .
                DIRECTORY_SEPARATOR . $_POST[sprintf(PostFields::sourceName, $i)]);
        }
    }
?>

See Also

Reference

  • Uploader Class
  • UploadHandler Class
  • UploadedFile Class
  • PostFields Class

Manual

  • Saving Uploaded Files in PHP


Uploading Additional Data in PHP

Pretty often it is necessary to send additional information along with files. Image Uploader comprehensively solves this task and supports uploading the following kinds of additional information:

  • a common information about upload defined by the Web site logic, such as an author name, keywords, or a category caption
  • a simple text description
  • a hidden tag
  • image crop bounds and rotation angle
  • more image-specific information, like copyright notes and camera parameters during capturing, contained in EXIF and IPTC fields
  • hash sums

This topic has three paragraphs, namely, uploading common data, uploading image-specific data and hash sums. Each of them describes approaches on how to send and receive relevant data, possibilities provided by these approaches, and code samples.

Note

If you are unfamiliar with the Saving Uploaded Files in PHP topic, please, read it first.

Uploading Common Data

This section describes several approaches to uploading additional data. They are quite different but have two features in common, namely, independence of file types and upload of common data.

  • To get user-provided information about a whole upload you may use an HTML form, as it is described in the using additional HTML form section. This approach is simple to use and understand, it is also quite flexible. Pay attention that in this case you cannot upload different data for different files, only one set of data for a whole upload.
  • To add hidden data to a whole upload you can use custom fields. As opposed to the previous method, this one allows you to add data programmatically. For more information about this approach, see the using additional field section.
  • To upload user-defined file descriptions you do not need to configure Image Uploader beforehand, so it is the simplest way to get additional information with each uploaded file. Receiving of descriptions is examined in the using descriptions section.
  • To send a hidden piece of data for each user-selected file you may use tags. This approach is described in the using tags section.
  • To add elementary information to upload you can pass additional data as arguments like it is usually done in GET requests, this approach is described in the using query string section.

Using Additional HTML Form

Using HTML forms is the most straight-forward way to upload data in web applications, thus Image Uploader supports it. All you need is just to add the desired form to the same page where the Uploader class instance is hosted and set the Metadata.AdditionalFormName property to the name of created form. Then, when a user clicks Upload, the form data will be submitted along with user-selected files. On the server side, the fields of this form are accessible through the Package.PackageFields collection by their names.

An additional form can contain HTML input elements of different types, for example, you may use:

  • text for an author name
  • checkbox to determine whether to send a notification about the upload completion
  • select to choose keywords related to the upload
Note

The following input types are not allowed: file, image, button, and reset. Their values will not be sent at all.

Sending Data

The following configuration makes Image Uploader sending data from the addForm form along with uploaded files.

PHP

<form id="addForm" name="addForm">
    <input ID="keywords" name="keywords" type="text" />
    <input ID="addressee" name="addressee" type="text" />
</form>

<?php
    require_once "ImageUploaderPHP/Uploader.class.php";

    $uploader = new Uploader("Uploader1");
    $uploader->getUploadSettings()->setActionUrl("upload.php");
    $uploader->getMetadata()->setAdditionalFormName("addForm");
    $uploader->render();
?>

Receiving Sent Data

Fields of the additional form are sent in each package, though in the following example we use package containing the first file, which number is 0, because there is always at least one file in the upload session.

C#

require_once "ImageUploaderPHP/UploadHandler.class.php";
function saveAllUploadedFiles($uploadedFiles) {
    $packageFields = $uploadedFiles[0]->getPackage()->getPackageFields();
    $keywords = $packageFields["keywords"];
    $addressee = $packageFields["addressee"];
}

$handler = new UploadHandler();
$handler->setAllFilesUploadedCallback("saveAllUploadedFiles");
$handler->processRequest();

Using Additional Field

Additional fields can be attached to the POST request using the metadata.addCustomField(String, String, Boolean) method. It accepts the following parameters:

  1. name of the additional field
  2. value of the additional field
  3. optional parameter telling how to deal with previous value of this field, which is overwritten by default

You may add custom fields to the upload request only at runtime using the Image Uploader JavaScript API. Custom fields can use any format you like but should not conflict with the standard field names. See the POST Field Reference topic for a full list of standard Image Uploader fields.

On the server side, additional fields are accessible through the Package.PackageFields collection by their names.

The following example sends and receives an additional field named authorField. Here the metadata.addCustomField(String, String, Boolean) method is called in the BeforeUpload event handler, which fires when the upload is about to be started. For more information about events, please, see the using events section.

Sending Data

PHP

<script type="text/javascript" language="javascript">
function onBeforeUpload() {
    $au.uploader('Uploader1').metadata().addCustomField('authorField', 'Author Name');
}
</script>
<?php
    require_once "ImageUploaderPHP/Uploader.class.php";

    $uploader = new Uploader("Uploader1");
    $uploader->getUploadSettings()->setActionUrl("upload.php");
    $uploader->getClientEvents()->setBeforeUpload("onBeforeUpload");
    $uploader->render();
?>

Receiving Sent Data

Additional fields are sent in each package, though in the following example we use package containing the first file, which number is 0, because there is always at least one file in the upload session.

C#

require_once "ImageUploaderPHP/UploadHandler.class.php";
function saveAllUploadedFiles($uploadedFiles) {
    $packageFields = $uploadedFiles[0]->getPackage()->getPackageFields();
    $author = $packageFields["authorField"];
}

$handler = new UploadHandler();
$handler->setAllFilesUploadedCallback("saveAllUploadedFiles");
$handler->processRequest();

Receiving Descriptions

Each file uploaded via Image Uploader may have a description. There is no need to turn this possibility on, because it is enabled by default. So, let us examine how to get descriptions of uploaded files on a server using the callback function specified by the UploadHandler.FileUploadedCallback property:

C#

require_once "ImageUploaderPHP/UploadHandler.class.php";
function saveUploadedFile($uploadedFile) {
    $description = $uploadedFile->getDescription();
}

$handler = new UploadHandler();
$handler->setFileUploadedCallback("saveUploadedFile");
$handler->processRequest();

Using Tags

Tags give you an opportunity to send a hidden piece of data with each user-selected file. To attach such data use the file.tag property as it is demonstrated in the sample below. You may set tags only at runtime using the Image Uploader JavaScript API.

On the server side you may get a tag through the UploadedFile.Tag property.

The following example sends and receives tags for all selected files. Here the file.tag property is specified in the BeforeUpload event handler, which fires when the upload is about to be started. For more information about events, please, see the using events section.

Sending Data

PHP

<script type="text/javascript" language="javascript">
function onBeforeUpload() {
    var files = $au.uploader('Uploader1').files();
    var count = files.count();
    for (var i = 0; i < count; i++)
        files.get(i).tag('tag;file_' + i);
}
</script>
<?php
    require_once "ImageUploaderPHP/Uploader.class.php";

    $uploader = new Uploader("Uploader1");
    $uploader->getUploadSettings()->setActionUrl("upload.php");
    $converters = &$uploader->getConverters();
    $converter = new Converter();
    $converter->setMode("*.*=SourceFile");
    $converters[] = $converter;
    $uploader->getClientEvents()->setBeforeUpload("onBeforeUpload");
    $uploader->render();
?>

Receiving Sent Data

C#

require_once "ImageUploaderPHP/UploadHandler.class.php";
function saveUploadedFile($uploadedFile) {
    $tag = $uploadedFile->getTag();
}

$handler = new UploadHandler();
$handler->setFileUploadedCallback("saveUploadedFile");
$handler->processRequest();

Using Query String

To pass data via the query string, just add necessary arguments to the upload script URL (UploadSettings.ActionUrl) and parse the request on a server as it is shown in the example below.

Sending Data

PHP

<?php
    require_once "ImageUploaderPHP/Uploader.class.php";

    $uploader = new Uploader("Uploader1");
    $uploader->getUploadSettings()->setActionUrl("upload.php?argument1=value1&argument2=value2");
    $uploader->render();
?>

Receiving Sent Data

C#

require_once "ImageUploaderPHP/UploadHandler.class.php";
function saveAllUploadedFiles($uploadedFiles) {
    $argument1 = $_GET["argument1"];
    $argument2 = $_GET["argument2"];
}

$handler = new UploadHandler();
$handler->setAllFilesUploadedCallback("saveAllUploadedFiles");
$handler->processRequest();

Uploading Image-specific Data

Image Uploader has some imaging capabilities, which are described in the Working with Images topic and Uploading Images section. Let us describe two of these features, which allow uploading additional data:

  1. Rotating and Cropping of images are enabled in Image Uploader by default. So, it is a good idea to get rotation angle and crop bounds on a server. To know more on how to do this, see the receiving rotation angle and crop bounds section.
  2. Working with EXIF and IPTC Metadata provides, among other possibilities, an opportunity to extract and upload EXIF and IPTC fields for each user-selected image. EXIF metadata is a special information about the image, written into the file by the capturing device when an image was captured. These metadata may provide camera parameters during capturing, date and time of the capturing, photographer's name, and etc. IPTC is another metadata format, which is widely used in journalism to keep information about a photo, like byline, subject, location, and etc. See the handling EXIF and IPTC metadata section for detailed description on how to send and receive such metadata.

Receiving Rotation Angle and Crop Bounds

A rotation angle and crop bounds can be got through the Angle and CropBounds properties of the UploadedFile class respectively. Image Uploader measures rotation angle in degrees clockwise.

As soon as rotation and cropping of images are allowed by default, there is no need to configure Image Uploader to send them, so the following example shows only how to receive such data on a server.

C#

require_once "ImageUploaderPHP/UploadHandler.class.php";
function saveUploadedFile($uploadedFile) {
    $angle = $uploadedFile->getAngle();
    $cropBounds = $uploadedFile->getCropBounds();
}

Handling EXIF and IPTC Metadata

To upload EXIF or IPTC values, you should specify the desired fields using the Metadata.Exif and Metadata.Iptc properties. Both these properties represent semicolon separated lists of field names which should be extracted and uploaded along with images. Metadata.ValueSeparator sets a string separator for fields which can contain multiple string values, like IptcKeyword.

Sending Data

The following example sends two EXIF and two IPTC fields for each user-selected image:

PHP

<?php
    require_once "ImageUploaderPHP/Uploader.class.php";

    $uploader = new Uploader("Uploader1");
    $uploader->getUploadSettings()->setActionUrl("upload.php");
    $converters = &$uploader->getConverters();
    $converter = new Converter();
    $converter->setMode("*.*=SourceFile");
    $converters[] = $converter;
    $uploader->getMetadata()->setIptc("IptcCopyrightNotice;IptcKeyword");
    $uploader->getMetadata()->setExif("ExifColorSpace;ExifDateTime");
    $uploader->getMetadata()->setValueSeparator(";");
    $uploader->render();
?>

Receiving Sent Data

The following example gets the EXIF and IPTC fields sent accordingly to the previous configuration and writes these values to the Descriptions.xml file. Here uploaded fields are contained in the Package.PackageFields collection and can be retrieved by keys named in the following way: FieldName_xx, where FieldName is a name of an EXIF or IPTC field and xx is the index of an uploaded file in this package.

C#

require_once "ImageUploaderPHP/UploadHandler.class.php";
function saveUploadedFile($uploadedFile) {
    $absGalleryPath = realpath("Gallery/");
    $packageFields = $uploadedFile->getPackage()->getPackageFields();

    $descriptions = new DOMDocument('1.0');
    if (file_exists($absGalleryPath . "/Descriptions.xml"))
        $descriptions->load($absGalleryPath . "/Descriptions.xml");
    else
        $descriptions->appendChild($descriptions->createElement("files"));

    $xmlFile = $descriptions->createElement("file");
    $xmlFile->setAttribute("name",  $uploadedFile->getSourceName());
    $xmlFile->setAttribute("CopyrightNotice", $packageFields["IptcCopyrightNotice_" . $uploadedFile->getIndex()]);
    $xmlFile->setAttribute("IptcKeyword", $packageFields["IptcKeyword_" . $uploadedFile->getIndex()]);
    $xmlFile->setAttribute("ExifColorSpace", $packageFields["ExifColorSpace_" . $uploadedFile->getIndex()]);
    $xmlFile->setAttribute("ExifDateTime", $packageFields["ExifDateTime_" . $uploadedFile->getIndex()]);
    $descriptions->documentElement->appendChild($xmlFile);
    $descriptions->save($absGalleryPath . "/Descriptions.xml");
}

$handler = new UploadHandler();
$handler->setFileUploadedCallback("saveUploadedFile");
$handler->processRequest();
Note

All date/time values have the following format: YYYY:MM:DD hh:mm:ss. For example, May 11, 2006, 2:40PM would be represented as: 2006:05:11 14:40:00.

Using Hash Sums

Note

Image Uploader Express does not upload hash sums. See the Comparison of Image Uploader Editions topic for details.

File hash sum uniqely identifies the file, so it is useful in the following situations: to check upload integrity and to detect duplicate files.

Image Uploader provides the Metadata.Hash property to handle hash sums. If you specify this property and select at least one algorithm, Image Uploader will calculate hash values for user-selected files, encode them using the Base64 algorithm, and send along with files. On the server side the uploaded hash sums are accessible through the Package.PackageFields collection. Name of a field containing hash sum is HashCodeAlgorithmName_xx, where AlgorithmName is one of the following algorithms - SHA, MD2, or MD5, and xx is the index of an uploaded file in a package. If you specify several algorithms, several hash values will be sent (one value per algorithm).

Checking upload integrity works in the following way:

  1. You set one or several hash algorithms in the Metadata.Hash property.
  2. Before the upload begins, Image Uploader calculates the hash value (or several values) according to settings specified on the first step.
  3. Base64-encoded hash value is appended to the request.
  4. The server side code calculates the hash value using the same algorithm and compares it with the uploaded one.
  5. If hash values are the same, the verification is successful. Otherwise, the upload is corrupted.
Note

Image Uploader sends hash sums generated for original files regardless of Converter.Mode you use. So, if you are going to implement integrity check, please, be sure that you enabled a SourceFile Converter on the client side and calculate hash values for copies of original files on a server.

The following two-part example illustrates this algorithm. The first part configures Image Uploader to send an MD5 hash sum for each user-selected file. While the second one calculates the MD5 hash sum of the received copy of original file, compares it with the uploaded sum, and saves the file if both hash sums are identical, which means that upload is successful.

Sending Data

PHP

<?php
    require_once "ImageUploaderPHP/Uploader.class.php";

    $uploader = new Uploader("Uploader1");
    $uploader->getUploadSettings()->setActionUrl("upload.php");
    $converters = &$uploader->getConverters();
    $converter = new Converter();
    $converter->setMode("*.*=SourceFile");
    $converters[] = $converter;
    $uploader->getMetadata()->setHash("MD5");
    $uploader->render();
?>

Receiving Sent Data

C#

require_once "ImageUploaderPHP/UploadHandler.class.php";
function saveUploadedFile($uploadedFile) {
    $packageFields = $uploadedFile->getPackage()->getPackageFields();
    $convertedFiles = $uploadedFile->getConvertedFiles();
    $md5Hash = base64_encode(md5($convertedFiles[0]->getFileContent(), true));
    if ($md5Hash == $packageFields["HashCodeMD5_" . $uploadedFile->getIndex()])
        $convertedFiles[0]->moveTo(realpath("Gallery/") . DIRECTORY_SEPARATOR . $uploadedFile->getSourceName());
}

$handler = new UploadHandler();
$handler->setFileUploadedCallback("saveUploadedFile");
$handler->processRequest();

See Also

Reference

  • Metadata Class
  • Package Class
  • addCustomField(String, String, Boolean) Method
  • tag Property
  • UploadedFile Class
  • BeforeUpload Event
  • ActionUrl Property

Manual

  • Saving Uploaded Files in PHP
  • Configuring POST Format
  • Using JavaScript API
  • Rotating and Cropping
  • Working with EXIF and IPTC Metadata
  • Working with Images


Maintaining Sessions and Authentication in PHP

If you are going to utilize Image Uploader in non-Internet Explorer browsers (Firefox, Safari, and etc), you should take care about keeping your session and authentication cookies saved if they are used. The fact is that Image Uploader does not send cookies in output requests in non-Internet Explorer browsers by default and, therefore, session and authentication tickets are lost during the upload. To work around this problem you may employ special facilities provided either by Image Uploader PHP or Image Uploader JavaScript. Let us consider how to use them.

Using Image Uploader PHP Library

If you use Image Uploader PHP, session and authentication information will be automatically passed to the upload request. If you are unfamiliar with Image Uploader PHP, please, see the Quick Start with Image Uploader PHP topic.

Using Image Uploader JavaScript API

If you prefer not to use Image Uploader PHP, then you should add cookies to the upload request manually via the Image Uploader JavaScript. To do it, use the metadata.addCookie(String) method which accepts cookie in the following format: "cookieName=cookieValue". The most convenient place to call this method is the BeforeUpload event handler, because this event fires when the upload is about to be started.

JavaScript

function beforeUploadHandler(){
    var u = $au.uploader('Uploader1');
    u.metadata().addCookie('PHPSESSID=<?=$_COOKIE["PHPSESSID"]?>');
};

var u = $au.uploader({
    id: 'Uploader1',
    events: {beforeUpload: beforeUploadHandler},
});
u.writeHtml();

See Also

Reference

  • metadata Class
  • Uploader Class
  • BeforeUpload Event

Manual

  • Quick Start with Image Uploader PHP
  • Using JavaScript API


Debugging PHP Upload Scripts

This topic describes different approaches for solving the issue when Image Uploader is unable to successfully upload files and displays the following error message:

500: Internal Server Error

Also, sometimes you may see the message saying that upload is successful, but files appear not uploaded; this may indicates a server error too, but not necessarily.

In this case, please, firstly check that you specified at least one Converter, your upload script really saves files (see the Saving Uploaded Files in PHP topic), and you are looking for files in the right folder.

Here are the most probable issues causing the server-side error:

  • Image Uploader cannot save uploaded files because of wrong permissions configuration. See the Configuring PHP topic to get to know how to set required permissions.
  • The request size is too big. See the Configuring PHP topic to get to know how to increase maximum request length.
  • There is an error in your upload script (specified with the UploadSettings.ActionUrl property). See the debug approaches described below to find the error.
Note

If you experience an issue having different sympthoms than ones described in this article, please, see the Basic Steps in Troubleshooting topic.

Here we consider the following approaches for handling and debugging server-side errors:

  • Error logging approach is more convenient for production applications. It catches all the exceptions and writes error details to a log file; so, it does not show any information about errors to users.
  • Event handling approach implies showing the server response when some error occurs. If displaying errors is enabled, this response contains error details. However, this approach requires some modifications of Image Uploader settings.
  • Using sniffer allows you to view server response without necessity to modify embedding code, but it uses a third-party tool.
  • Running script in debug mode means debugging PHP scripts in the same manner as standalone applications.

Error Logging

PHP configuration file (php.ini) contains the Error handling and logging section which controls how errors are handled and reported. To configure error logging set the following parameters:

error_reporting  =  E_ALL
log_errors = On

The first one defines what error levels should be handled. We set E_ALL which means: all errors, warnings, and notices. The second parameter states whether these error reports should be written to a log file. If On, as we have set, error messages will be written to the <Apache installation folder>\logs\error.log file in the following way:

[Mon Oct 18 12:27:53 2010] [error] [client 127.0.0.1] PHP Warning: require_once(ImageUploaderPHP/UploadHandle.class.php) [function.require-once]: failed to open stream: No such file or directory in C:\\htdocs\\PhpLibrarySample\\upload.php on line 2, referer: http://localhost/PhpLibrarySample/imageuploaderphp/scripts/imageuploader.jar

Optionally, you can set a limitation for the error file length using the log_errors_max_len parameter.

Event Handling

If you are not familiar with the client events in Image Uploader, please, read the Using JavaScript API topic first.

Image Uploader provides two events which are helpful for debugging, namely, Error and AfterUpload. The first one fires when a server or client-side error occurs, and the second one fires when an upload is supposed to be successful. We recommend to handle both events simultaneously to get debug information on server errors, because there is a known problem with PHP applications: they can return HTTP code 200 (in our case it means successful upload) even if some error occurs.

The Error event provides detailed description of an occurred error through the errorPage parameter which represents the web page returned from the server. To ignore non-server errors you can use the errorCode argument, since it is equal to 4 in case of internal server error. For the full list of error codes, please, see the Error event parameters paragraph.

The idea of catching errors via the AfterUpload event is as follows:

  1. Make your upload script to return some predefined response after all the uploaded files were saved.
  2. In the AfterUpload event handler check whether a string returned by the response parameter contains the predefined one.
  3. If this check is failed, it means that an error has occurred and the response parameter contains the error-related information.

Let us presume that server-side upload script returns a "complete" string (predefined response) after all the uploaded files were saved. This can be done as follows:

PHP

<?php
// ... save uploaded files

echo "complete";
?>

The following example shows how to display error details if a server-side error occurs.

PHP

<script type="text/javascript">
function showErrorWindow(errorMessage){
    var newWindow = window.open();
    with (newWindow.document) {
        open("text/html");
        write("A server error occured<br/>");
        write("Error Message: " + errorMessage);
        close();
    }
}

function errorHandler(errorCode, httpResponseCode, errorPage, additionalInfo){
    //Occured error is a server error
    if (errorCode == 4) {
        showErrorWindow(errorPage);
    }
}

function afterUploadHandler(response){
    //Some server-side error occurred
    if (response.indexOf("complete") > -1){
        showErrorWindow(response);
    }
}
</script>

<?php
    require_once "ImageUploaderPHP/Uploader.class.php";
    $uploader = new Uploader('Uploader1');
    $uploader->getClientEvents()->setError("errorHandler");
    $uploader->getClientEvents()->setAfterUpload("afterUploadHandler");
    $uploader->render();
?>
Note

If error details are not displayed, make sure that display_errors parameter in your php.ini is set to On.

Using Sniffer

As an example of network analyzer tool we use the Fiddler. Here we discuss how to use it to debug server-side upload script.

  1. Open index.php in your browser. If it is able to send traffic to Fiddler, the corresponded session will be displayed in the Web Sessions pane of the tool.
  2. Send a file via Image Uploader.

  3. Double-click the upload.php session in the Web Sessions pane.

    Using Fiddler to debug upload script in PHP

    Find upload session details in the left part of Fiddler's interface. Here it contains the POST request sent by Image Uploader and the response returned by your upload script. So, if your upload script contains an error this error details will be displayed in the returned response.

    Note

    If error details are not displayed, make sure that display_errors parameter in your php.ini is set to On.

Running Script in Debug Mode

Basically, PHP does not support debugging, but you can use third-party debuggers, such as Xdebug. You may use Xdebug with different IDEs (for example, with Eclipse), the Debugging PHP applications with xdebug article tells how to use Xdebug with Eclipse.

You may also use an IDE, which supports debugging PHP scripts, such as CodeLobster PHP Edition.

See Also

Reference

  • Error Event
  • UploadSettings.ActionUrl Property
  • Converter Class

Manual

  • Saving Uploaded Files in PHP
  • Configuring ASP.NET
  • Basic Steps in Troubleshooting

Other Resources

  • Fiddler
  • CodeLobster PHP Edition
  • Xdebug
  • Debugging PHP applications with xdebug


Uploading in Other Platforms

This section consists of topics that discuss uploading in other platforms.

In This Section

Uploading Folders in Other Platforms
Debugging Upload Scripts in Other Platforms


Uploading Folders in Other Platforms

Uploading folders is extremely useful when users are allowed to upload large amounts of files. This topic describes how to set up uploading folders on client side and restore folders structure on a server.

Note

Image Uploader Express does not display and upload folders. See the Comparison of Image Uploader Editions topic for details.

Uploading Folders on Client Side

Configuring folders uploading in Image Uploader is straight-forward and simple to understand. You use the only one property - uploader.folderProcessingMode to say to the control how to deal with folders. Let us describe all folderProcessingMode possible values:

  • Skip does not show subfolders in the folder pane, so it is impossible to select a whole folder if it is not a current folder. Only files are uploaded.
  • Show makes subfolders visible in the folder pane, so a user can select whole folders. However, restoring folders structure on server side is impossible, because no file path information is uploaded. Only files are uploaded, even if a user selects a folder.
  • Upload shows subfolders in the folder pane, so a user can select whole folders. Moreover, it is possible to restore folders structure on a server, because Image Uploader sends each file along with its path relative to the selected folder. Folders and files are uploaded.
Note

When a user selects a folder to upload all its subfolders become selected recursively, in Show and Upload modes.

To allow uploading folder set the folderProcessingMode property to Upload, like it is shown in the following configuration:

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    folderProcessingMode: 'Upload'
});

In this case, if a user selects a whole folder, all the files located in this folder will be recursively added to the upload pane; so a user can clearly see all the files selected for upload at once. When a user clicks Upload, the structure of this folder will be sent to a server via relative paths to each of the selected files. For example, if a user sends a MyDocuments folder, which contains a MyPhotos subfolder, all files inside this subfolder will be sent to a server along with MyDocuments\MyPhotos\filename relative paths and all files contained directly in the MyDocuments folder will have MyDocuments\filename relative paths.

Note

Image Uploader sends only relative paths along with uploaded files, never absolute, because of the security reason.

Restoring Folders Structure on Server Side

As stated in the previous section, the Upload folder processing mode allows uploading entire folders. As a result, the SourceName_i POST field will contain not only the filename but also a relative path to the ith file. So, if you want to restore folders structure on the server, you should parse the SourceName_i field and recreate a path to the ith file, folder by folder. The following algorithm describes this idea more detailed:

  1. Define the folder to save uploaded folders to.

  2. Iterate through all files uploaded in the current package (their total number is contained in the PackageFileCount field).

    In this loop:

    1. Read a relative path to each received file from the SourceName_i POST field, where i is an index of this file.
    2. Parse this path to get all the folder names and the file name.
    3. Append the relative path to the path defined on the first step.
    4. Save the file to this path.

The examined algorithm may look in pseudocode as follows:

pseudocode

//The folder to save uploaded folders to
string catalogPath

iterate through each file (i)
{
    //Take the value from the SourceName_i POST field
    string relativePath = POST["SourceName_" + i]

    //The 'split' function splits a string into an array of substrings using
    //the specified delimiter ('\' in our case)
    array folderStructure = split(relativePath, "\")

    //The 'count' function returns number of elements in array
    integer folderCount = count(folderStructure)

    //This value containes only the name of received file
    string fileName = folderStructure[folderCount]

    //The 'goToFolder' function changes the current working folder to the specified one
    goToFolder(catalogPath)

    //iterate through all but last one folder names
    iterate through folderCount-1 elements of folderStructure (j)
    {
        //The 'exists' function checks if the specified folder exists under the current location
        if not exists(folderStructure[j])
        {
            //The 'createFolder' function creates a subfolder
            createFolder(folderStructure[j])
        }
        goToFolder(folderStructure[j])
    }

    //The 'save' function saves the i-th file in the current working folder with the fileName name
    save(file[i], fileName)
}

See Also

Reference

  • uploader Class

Manual

  • POST Field Reference


Debugging Upload Scripts in Other Platforms

This topic describes different approaches for solving the issue when Image Uploader is unable to successfully upload files and displays the following error message:

500: Internal Server Error

Also, sometimes you may see the message saying that upload is successful, but files appear not uploaded; this may indicates a server error too, but not necessarily.

In this case, please, firstly check that you specified at least one converter, your upload script really saves files, and you are looking for files in the right folder.

Here are the most probable issues causing the server-side error:

  • Image Uploader cannot save uploaded files because of wrong permissions configuration. See the Installation and Deployment Notes topic to get to know how to set required permissions.
  • The request size is too big. See your web server documentation to get to know how to increase maximum request length.
  • There is an error in your upload script (specified with the uploadSettings.actionUrl property). See the debug approaches described below to find the error.
Note

If you experience an issue having different sympthoms than ones described in this article, please, see the Basic Steps in Troubleshooting topic.

Here we consider the following approaches for handling and debugging server-side errors:

  • Event handling approach implies showing the server response when some error occurs. If displaying errors is enabled, this response contains error details. However, this approach requires some modifications of Image Uploader settings.
  • Using sniffer allows you to view server response without necessity to modify embedding code, but it uses a third-party tool.
  • Using debug console allows you to view errors, debug messages from Image Uploader, and information messages.

Event Handling

If you are not familiar with the client events in Image Uploader, please, read the Using JavaScript API topic first.

Image Uploader provides two events which are helpful for debugging, namely, Error and AfterUpload. The first one fires when a server or client-side error occurs, and the second one fires when an upload is supposed to be successful. We recommend to handle both events simultaneously to get debug information on server errors.

The Error event provides detailed description of an occurred error through the errorPage parameter which represents the web page returned from the server. To ignore non-server errors you can use the errorCode argument, since it is equal to 4 in case of internal server error. For the full list of error codes, please, see the Error event parameters paragraph.

The idea of catching errors via the AfterUpload event is as follows:

  1. Make your upload script to return some predefined response after all the uploaded files were saved.
  2. In the AfterUpload event handler check whether a string returned by the response parameter contains the predefined one.
  3. If this check is failed, it means that an error has occurred and the response parameter contains the error-related information.

Let us presume that server-side upload script returns a "complete" string (predefined response) after all the uploaded files were saved, then the following code will show error details if a server-side error occurs.

JavaScript

<script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
<script type="text/javascript">
function showErrorWindow(errorMessage){
    var newWindow = window.open();
    with (newWindow.document) {
        open("text/html");
        write("A server error occured<br/>");
        write("Error Message: " + errorMessage);
        close();
    }
}

function errorHandler(errorCode, httpResponseCode, errorPage, additionalInfo){
    //Occured error is a server error
    if (errorCode == 4) {
        showErrorWindow(errorPage);
    }
}

function afterUploadHandler(response){
    //Some server-side error occurred
    if (response.indexOf("complete") > -1){
        showErrorWindow(response);
    }
}

    var u = $au.uploader({
        id: 'Uploader1',
        events: { afterUpload: afterUploadHandler,
            error: errorHandler}
    });
    u.writeHtml();
</script>

Using Sniffer

As an example of network analyzer tool we use the Fiddler. Here we discuss how to use it to debug server-side upload script.

  1. Open your application in browser. If it is able to send traffic to Fiddler, the corresponded session will be displayed in the Web Sessions pane of the tool.
  2. Send a file via Image Uploader.

  3. Double-click the session with server error in the Web Sessions pane.

Using Fiddler to debug upload script

Find upload session details in the left part of Fiddler's interface. Here it contains the POST request sent by Image Uploader and the response returned by your upload script. So, if your upload script contains an error this error details will be displayed in the returned response.

Using Debug Console

You can use the debug class and the error console of browser to view Image Uploader error and warning messages along with the response returned by your upload script.

In order to do it you should, firstly, insert the following code before rendering Image Uploader:

JavaScript

<script type="text/javascript">
    $au.debug().level(3);
    $au.debug().mode(['popup','console']);
</script>

Secondly, open the console. Here are the ways to open the console in the most popular browsers:

  • In Internet Explorer 8 open Tools -> Developer Tools (or press F12), then select Script tab in the left pane and click Console in the right pane.
  • In Mozilla Firefox we recommend to use Firebug.
  • In Google Chrome click the Wrench icon and select Tools -> JavaScript Console (or press Ctrl+Shift+J).
  • In Safari turn on the Develop menu in the Advanced pane of Safari Preferences, after that go to Develop -> Show Error Console (or press Cmd+Alt+C).

If your browser has no error console, please, allow pop-up windows in your browser.

For more information about the debug class, please, see the Using JavaScript API topic.

See Also

Reference

  • Error Event
  • uploadSettings.actionUrl Property
  • converter Class

Manual

  • Basic Steps in Troubleshooting
  • Installation and Deployment Notes

Other Resources

  • Fiddler
  • Firebug


Configuring and Handling Upload on Client-Sides

This section consists of topics that discuss different upload-related subjects which are not depend on particular server platform.

In This Section

Configuring Common Upload Settings
Configuring Files to be Uploaded
Sending All Files at Once or in Several Parts
Configuring Fail-Safe Upload
Configuring POST Format
Handling Upload Completion
Adding Authentication
Uploading to Cloud Storages


Configuring Common Upload Settings

Image Uploader is a client-side application which does not save files on server disk itself. It just submits user-selected files to a page specified in its settings and redirects users to another page when the upload completes. The present topic describes how to specify a page to which Image Uploader submits file and a page where Image Uploader redirects users when upload successfully completes.

Besides these URLs, Image Uploader allows specifying:

  • What and how many converted files should be send for each user-selected file.
  • Whether to send all files at ones or separate them in several parts.
  • How many times and in what interval Image Uploader should try to resume a broken upload.
  • How to rename default POST fields or prohibit them from submitting at all.

All the upload-related parameters can be configured via the UploadSettings property of the Uploader class. Here the upload page is specified with the ActionUrl property, and the redirection page is specified with RedirectUrl.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <UploadSettings ActionUrl="upload.aspx"
        RedirectUrl="gallery.aspx" />
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getUploadSettings()->setActionUrl("upload.php");
$uploader->getUploadSettings()->setRedirectUrl("gallery.php");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    uploadSettings: { actionUrl: 'upload.aspx', redirectUrl: 'gallery.aspx' }
});

The ActionUrl specifies an URL to the page where files are posted. That page should contain the server code which parses the upload request, saves files to the necessary folders on server, and performs any other additional actions. Usually, this URL must have a specific extension (depending on the web server settings). For ASP.NET platform it should be .aspx, for PHP it is .php, for Perl it can be .pl or .cgi, etc. In other words, the file containing this script should have the extension registered in the settings of your web server as a server page. Otherwise upload will fail. If you want to submit files to the same page where Image Uploader is hosted, specify the dot character (.) as a value of this property.

When users upload files using the standard <input type="file"> element, they expect to be redirected to the page where they have submitted the files. However, Image Uploader works in a different way. The response generated by the page, which is specified with the ActionUrl property, is sent back to Image Uploader and not to the browser. As soon as Image Uploader receives this response, the upload is considered to be completed; and the user is redirected to the page specified with the RedirectUrl property. If you do not need this redirection, set this property to an empty string.

When specifying these properties, take into account the following cases:

Using Quotation Marks and Semicolons

URLs can contain semicolon or quotation mark characters (e.g. http://upload.server.com/uploadFile;jsessionid=123?param='value'). If they do, enclose such URLs in single (' ') or double (" ") quotes to avoid parameter parsing errors. Also, quotation marks (both single ' and double ") inside URLs should be escaped with a backslash:

"http://upload.server.com/uploadFile;jsessionid=123?param=\'value\'"

Using Absolute and Relative URLs

URLs can be both absolute (e.g. "http://domain.com/Gallery/gallery.aspx") and relative to the current page (e.g. "/Gallery/gallery.aspx").

For example, if Image Uploader is inserted into the http://domain.com/ImageUploader/default.aspx page, the relative URLs specified via the RedirectUrl property will correspond to the following locations.

Specified URL | Expected Location
"/Gallery/gallery.aspx" | http://domain.com/Gallery/gallery.aspx
"./Gallery/gallery.aspx" | http://domain.com/ImageUploader/Gallery/gallery.aspx
"Gallery/gallery.aspx" | http://domain.com/ImageUploader/Gallery/gallery.aspx
"gallery.aspx" | http://domain.com/ImageUploader/gallery.aspx

See Also

Reference

  • UploadSettings Class

Manual

  • Configuring Files to be Uploaded
  • Sending All Files at Once or in Several Parts
  • Configuring Fail-Safe Upload
  • Configuring POST Format
  • UploadSettings (ASP.NET)
  • UploadSettings (PHP)
  • uploadSettings (JavaScript)
  • Uploader (ASP.NET)
  • Uploader (PHP)
  • uploader (JavaScript)
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)
  • RedirectUrl (ASP.NET)
  • RedirectUrl (PHP)
  • redirectUrl (JavaScript)
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)
  • RedirectUrl (ASP.NET)
  • RedirectUrl (PHP)
  • redirectUrl (JavaScript)
  • RedirectUrl (ASP.NET)
  • RedirectUrl (PHP)
  • redirectUrl (JavaScript)
  • UploadSettings (ASP.NET)
  • UploadSettings (PHP)
  • uploadSettings (JavaScript)


Configuring Files to be Uploaded

After specifying common upload settings, it is required to set at least one Converter. Each Converter configures a one converted file (original file as is, thumbnail created from original image file, icon associated with original file, or original file compressed into ZIP archive) that will be uploaded for each of the user-selected files.

For example, you configure Image Uploader to send an original file and a downsized copy of image (if the original file is an image) or an icon associated with the original file. It means that if the user selects two files (a JPEG image and a PDF document) Image Uploader will send four files:

  • the JPEG image and the PDF file themselves
  • a resized copy of the image and a PDF icon

The following samples demonstrate this configuration.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Converters>
        <aur:Converter Mode="*.*=SourceFile" />
        <aur:Converter Mode="*.*=Thumbnail;*.*=Icon"
            ThumbnailHeight="120"
            ThumbnailWidth="120"
            ThumbnailFitMode="Fit" />
    </Converters>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");

$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=SourceFile");
$converters[] = $converter;
$converter = new Converter();
$converter->setMode("*.*=Thumbnail;*.*=Icon");
$converter->setThumbnailWidth(120);
$converter->setThumbnailHeight(120);
$converter->setThumbnailFitMode("Fit");
$converters[] = $converter;

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    converters: [
        {mode: '*.*=SourceFile'},
        {mode: '*.*=Thumbnail;*.*=Icon', thumbnailFitMode: 'Fit', thumbnailWidth: '120', thumbnailHeight: '120'}
    ]
});

The way you retrieve and save converted files on the server side depends on the platform you use. Find the detailed instructions in the Saving Uploaded Files in ASP.NET and Saving Uploaded Files in PHP topics.

Consider the Converter properties in detail below.

Configuring Conversion Mode

The Mode is the most prominent property of the Converter class. It specifies what will be uploaded for each file selected for upload (i.e. the original file, a downsized copy of the image, an icon, or a ZIP archive). One Converter instance can specify different types of converted files for various types of files selected for upload client-side. For instance, you can configure the Converter to send downsized copies of images for JPEG images and original files for files of other types. It can be done using the aforementioned Mode property.

The Mode property accepts a format string consisting of masks=mode pairs separated by a semicolon. Each pair includes a set of file masks separated by commas and a corresponding mode. In general, this string has the following syntax:

mask11,mask12,...=mode1;mask21,mask22,...=mode2;...

Here is the list of supported modes:

  • SourceFile means that the selected file will be uploaded from a user's computer without any changes.
  • Thumbnail works as follows: if the selected file is an image, it will be resized using the parameters listed below and uploaded as a JPEG file. Otherwise, a converted file will not be sent.
  • Icon means that the system icon associated with the selected file will be uploaded.
  • Zip means that the selected file will be packed into a ZIP archive and then uploaded.
  • None means that no file will be uploaded.

When Image Uploader prepares the upload request it extracts masks=mode pairs. It checks whether the name of the current file fits the file mask specified in the pair. If it fits the current pair, Image Uploader sends an item specified in the pair to a server. Otherwise, if no appropriate file mask is found or Image Uploader is unable to create a downsized copy of the image (if mode is specified as Thumbnail and the current file is not an image), Image Uploader checks the next pair in the same manner.

Note

If there is no file mask corresponding to the original file extension or no appropriate mode, then Image Uploader does not send this converted file.

Uploading Thumbnails

If you specify the Mode property to send a thumbnail, you can also set the following thumbnail parameters:

  • ThumbnailHeight and ThumbnailWidth specify the height and width of the thumbnail respectively.

  • ThumbnailFitMode specifies how the thumbnail is to be resized. The following values are supported:

    • Fit means that the original image should be resized to fit the rectangle specified with the ThumbnailHeight and ThumbnailWidth properties. Note that the proportions of the original image will be kept.
    • Width means that the original image should be resized to be not wider than the ThumbnailWidth value.
    • Height means that the original image should be resized to be not higher than the ThumbnailHeight value.
    • ActualSize means that dimensions of the original image should be keeped; however, it can be rotated or recompressed if necessary.
  • ThumbnailApplyCrop specifies whether the thumbnail should be cropped.
  • ThumbnailBgColor specifies the background color of the thumbnail. This color is used when the thumbnail is created for an image with transparency.
  • ThumbnailCompressOversizedOnly specifies whether an original image should be uploaded as the thumbnail in case when original image dimensions and file size are not bigger than dimensions and file size of this thumbnail.
  • ThumbnailCopyExif specifies whether the thumbnail should contain EXIF metadata copied from the original file.
  • ThumbnailCopyIptc specifies whether the thumbnail should contain IPTC metadata copied from the original file.
  • ThumbnailJpegQuality specifies a JPEG quality value for the thumbnail. This is a number in the [0, 100] range. If you specify 0, the file size will be extremely small, but the quality will be very low (almost always unacceptable). Alternatively, if you specify 100, the file size will be quite large, but JPEG artifacts will be almost invisible.
  • ThumbnailKeepColorSpace specifies whether to preserve original color space when creating the thumbnail.
  • ThumbnailResizeQuality specifies a resize quality value of the thumbnail.
  • ThumbnailResolution specifies an image resolution of the thumbnail. If 0 value is specified, the original image resolution is used.
  • ThumbnailWatermark specifies a watermark of the thumbnail.

See Also

Refernce

  • Converter Class

Manual

  • Configuring Common Upload Settings
  • Saving Uploaded Files in ASP.NET
  • Saving Uploaded Files in PHP
  • Uploading Images
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • Mode (ASP.NET)
  • Mode (PHP)
  • mode (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • Mode (ASP.NET)
  • Mode (PHP)
  • mode (JavaScript)
  • Mode (ASP.NET)
  • Mode (PHP)
  • mode (JavaScript)
  • Mode (ASP.NET)
  • Mode (PHP)
  • mode (JavaScript)
  • ThumbnailHeight (ASP.NET)
  • ThumbnailHeight (PHP)
  • thumbnailHeight (JavaScript)
  • ThumbnailWidth (ASP.NET)
  • ThumbnailWidth (PHP)
  • thumbnailWidth (JavaScript)
  • ThumbnailFitMode (ASP.NET)
  • ThumbnailFitMode (PHP)
  • thumbnailFitMode (JavaScript)
  • ThumbnailHeight (ASP.NET)
  • ThumbnailHeight (PHP)
  • thumbnailHeight (JavaScript)
  • ThumbnailWidth (ASP.NET)
  • ThumbnailWidth (PHP)
  • thumbnailWidth (JavaScript)
  • ThumbnailWidth (ASP.NET)
  • ThumbnailWidth (PHP)
  • thumbnailWidth (JavaScript)
  • ThumbnailHeight (ASP.NET)
  • ThumbnailHeight (PHP)
  • thumbnailHeight (JavaScript)
  • ThumbnailApplyCrop (ASP.NET)
  • ThumbnailApplyCrop (PHP)
  • thumbnailApplyCrop (JavaScript)
  • ThumbnailBgColor (ASP.NET)
  • ThumbnailBgColor (PHP)
  • thumbnailBgColor (JavaScript)
  • ThumbnailCompressOversizedOnly (ASP.NET)
  • ThumbnailCompressOversizedOnly (PHP)
  • thumbnailCompressOversizedOnly (JavaScript)
  • ThumbnailCopyExif (ASP.NET)
  • ThumbnailCopyExif (PHP)
  • thumbnailCopyExif (JavaScript)
  • ThumbnailCopyIptc (ASP.NET)
  • ThumbnailCopyIptc (PHP)
  • thumbnailCopyIptc (JavaScript)
  • ThumbnailJpegQuality (ASP.NET)
  • ThumbnailJpegQuality (PHP)
  • thumbnailJpegQuality (JavaScript)
  • ThumbnailKeepColorSpace (ASP.NET)
  • ThumbnailKeepColorSpace (PHP)
  • thumbnailKeepColorSpace (JavaScript)
  • ThumbnailResizeQuality (ASP.NET)
  • ThumbnailResizeQuality (PHP)
  • thumbnailResizeQuality (JavaScript)
  • ThumbnailResolution (ASP.NET)
  • ThumbnailResolution (PHP)
  • thumbnailResolution (JavaScript)
  • ThumbnailWatermark (ASP.NET)
  • ThumbnailWatermark (PHP)
  • thumbnailWatermark (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)


Sending All Files at Once or in Several Parts

Image Uploader allows uploading files in the following modes:

  • sending all files at once
  • sending files in several packages
  • sending files in several chunks
  • sending converted files separately

Each mode has its own advantages and disadvantages. Let us look at them more closely.

Sending All Files at Once

This is default mode. To make Image Uploader to send all files at once, set the UploadSettings.FilesPerPackage to 0 and UploadSettings.ChunkSize to 0.

The figure below demonstrates how Image Uploader sends all the converted files at once. First, it creates a POST request containing converted files and metadata for all user-selected files. After that this request is submitted to the server and Image Uploader waits for a response from the server stating that the upload was completely finished.

Uploading all files at once
Figure 1. Uploading all files at once.

Sending Files in Several Packages

To turn the package upload mode on, set the FilesPerPackage property to a positive integer (number of user-selected files which will be processed and uploaded within a package) and ChunkSize to 0.

In this mode Image Uploader restricts the POST request by file count. It means that every request sending within an upload session cannot contain more than FilesPerPackage x converters count files. To do it, Image Uploader prepares a POST request containing converted files and metadata for FilesPerPackage user-selected files. After that this request (package) is submitted to the server, and Image Uploader waits for a confirmation of a successful upload of this package. When this confirmation is received, the next package is uploaded in the same manner. This procedure is repeated until all the converted files are uploaded. The next figure illustrates this mode.

Uploading in several Packages
Figure 2. Uploading in several Packages. FilesPerPackage is 1

Sending Files in Several Chunks

To configure the chunk upload mode, set the FilesPerPackage property to 0 and ChunkSize to a positive integer (number of bytes allowed to upload within a request).

Here Image Uploader restricts the POST request by size. It means that every request sending within an upload session cannot contain more than ChunkSize bytes of binary data. When Image Uploader works in this mode it adds converted files and metadata to a POST request until the request length exceeds ChunkSize + metadata size bytes. If the last added file does not meet the chunk size limitation, Image Uploader adds just a portion of this file to complete this chunk. The remaining portion will be added at the beginning of the next chunk. After that this request (chunk) is submitted to the server, and Image Uploader waits for a confirmation of a successful upload of this chunk. When this confirmation is received, the next chunk is uploaded in the same manner. The figure below demonstrates the chunk upload mode.

Uploading in several chunks
Figure 3. Uploading in several chunks.

Note

When you turn this mode on, it is highly recommended to use Image Uploader ASP.NET or Image Uploader PHP to handle upload on the server side. Both these libraries automatically compose files from chunks uploaded in separate HTTP requests, and provide access to them.

In the case of combining package and chunk upload modes, Image Uploader divides files into chunks only within a package. It means that converted files belonging to different packages will be sent in separate requests even though they may fit in one chunk.

Sending Converted Files Separately

In this mode Image Uploader sends each converted file in a separate POST request. For example, if you set two converters (say, a copy of the original file and its thumbnail), select two files, and click Upload; Image Uploader will send four requests. To activate this mode set the UploadSettings.UploadConverterOutputSeparately property to true.

Note

When Image Uploader sends converted files separately it does not take into account the FilesPerPackage value. However, if the ChunkSize is greater than 0, Image Uploader divides converted files, which size exceeds this value, into chunks and sends them separately.

Comparison of Upload Modes

Client-Side

  • Memory usage. Generally speaking, uploading all the files at once should consume a lot of memory to be able to upload a large number of files. The multipart/form-data block is an indivisible byte stream, and Image Uploader should commit enough memory to be able to prepare it. So, in case of a single POST request, the control should have a memory block containing all converted files, and in multiple packages mode, it only needs a memory block large enough to contain the part which is currently being uploaded. However, as Image Uploader caches the request to disk using temporary files, the difference disappears. That means, client-side memory usage is equal for all upload modes.
  • Upload recovery. Sometimes the upload process can be broken because of some external reasons (for example, physical connection problems, timeout, etc). Image Uploader can automatically resume a broken upload by resending the unsuccessful request. It means that if the single request mode is used, all the files will be sent again even if the only last one has failed. On the opposite, if you send files in separate requests, successfully uploaded ones will not be resent when the upload process is broken. Moreover, in the case of chunk upload usage, Image Uploader will try to resend the unsuccessful chunk; however, if the broken upload cannot be resumed, the whole package containing this chunk is considered as unsuccessful. That is why it is recommended to combine package and chunk upload modes. For more details on upload recovery, refer to the Configuring Fail-Safe Upload topic.
  • Total time of upload. Upload consists of three stages: establishing a connection, upload itself, and waiting for a confirmation of success. In the single request upload mode Image Uploader performs connection initialization and finalization only once, whereas in the multiple requests modes it repeats these actions for every request. That is why uploading in several parts has some time overhead in comparison to the former one. However, usually this difference is not big enough.

Server-Side

  • Memory Usage. When data is being uploaded, the server accepts the uploaded multipart/form-data block and begins to process it. Different server platforms process uploads in a different way. Some of them accumulate the entire block in memory and, when upload is finished, start splitting it into files, etc. Others work in a more efficient way: they flush uploaded data into temporary files until the upload completes. If it is not the case, and a user uploads data in a huge block (for example, 100 files at the same time), you may get unacceptable memory usage. See the Saving Uploaded Files in ASP.NET or Saving Uploaded Files in PHP topic to get more information on how upload is processed by components of different platforms. If server platform you use is not optimized for uploading huge amounts of data, use the multiple requests upload mode.

    Note

    Reducing resource usage on the server is much more important than on the client side, because, otherwise, it can cause a dramatic performance fall of the entire Web server.

  • Server-side limitations. The majority of web servers have limitations for maximum POST request length and script execution timeout. These limitations may cause the upload problem when the currently uploading request exceeds a maximum allowable length or the upload processing script works too long. Increasing these limitations is rather unsafe because it becomes easier to overload the server. That is why upload in parts may help. However, even if you configure Image Uploader to send one file per request, this problem persists for too big files. Thus, if it is expected that your users will upload large size file, it is recommended to turn chunk upload more on.

    Note

    In the case of chunk upload usage, set the ChunkSize property to the little less value than a maximum POST request length limitation. The reason is that the physical size of the currently uploaded request (chunk) is ChunkSize + metadata fields.

  • Upload script logic. Uploading files in multiple parts significantly complicates the logic of the upload processing script. In the case of the package upload mode, you should additionally determine to what upload session the currently processing package belongs. The cost complicated mode is the chunk upload; here you should bundle portions of files uploaded in separate requests. However, Image Uploader ASP.NET and Image Uploader PHP provide classes which allow operating with files sent in multiple requests as if they were uploaded at a time.

See Also

Reference

  • Converter Class
  • FilesPerPackage Property
  • ChunkSize Property
  • UploadConverterOutputSeparately Property
  • AutoRecoveryMaxAttemptCount Property
  • AutoRecoveryTimeout Property

Manual

  • Configuring Files to be Uploaded
  • Configuring Fail-Safe Upload
  • Saving Uploaded Files in ASP.NET
  • Saving Uploaded Files in PHP
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • UploadConverterOutputSeparately (ASP.NET)
  • UploadConverterOutputSeparately (PHP)
  • uploadConverterOutputSeparately (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • UploadConverterOutputSeparately (ASP.NET)
  • UploadConverterOutputSeparately (PHP)
  • uploadConverterOutputSeparately (JavaScript)
  • AutoRecoveryMaxAttemptCount (ASP.NET)
  • AutoRecoveryMaxAttemptCount (PHP)
  • autoRecoveryMaxAttemptCount (JavaScript)
  • AutoRecoveryTimeout (ASP.NET)
  • AutoRecoveryTimeout (PHP)
  • autoRecoveryTimeout (JavaScript)


Configuring Fail-Safe Upload

Sometimes connection problems occur unexpectedly during the uploading of files to server. Such problems cause several inconvenient situations which force users to:

  • Resend files manually (by clicking Upload).
  • Send already uploaded files again because it is not guaranteed that such files are saved on a server.
  • Select and upload all files anew in the case if the computer hangs or the light is switched off.

To avoid these situations Image Uploader offers several possibilities of recovering the upload process. These possibilities can be configured via the properties of the UploadSettings class. Let us consider them in more detail.

Firstly, Image Uploader supports hands-free upload recovery by resending the last failed request. Here you just set a number of attempts (AutoRecoveryMaxAttemptCount) and a time interval between them (AutoRecoveryTimeout).

Note

Image Uploader Express does not support automatic upload recovery. See the Comparison of Image Uploader Editions topic for details.

However, this method is not so effective in itself because Image Uploader sends all the files in one request by default. It means that in the case of the connection problem Image Uploader will resend all the selected files, even if only the last file has failed. So, we strongly recommend you to use the multiple requests upload mode along with the automatic upload recovery. This upload mode is particularly described in the Sending All Files at Once or in Several Parts topic. For brevity, we consider the most commonly used configuration of this upload mode: sending each file in a separate package (FilesPerPackage = 1) and dividing too large files into 10 Mb chunks (ChunkSize = 10485760).

Let us describe advantages of this configuration. When a user selects small files (less than 10 Mb), Image Uploader sends them one by one. And, in the case of the connection problem, only the last unsuccessful file will be resent. On the other hand, too large files (greater than 10 Mb) are sending in chunks. It means that Image Uploader will resend only the last chunck while the automatic upload recovery is performed. However, when Image Uploader has exhausted all attempts, the whole package containing this chunk is considered as unsuccessful.

Although you may change the ChunkSize value, take into account the following:

  • The increasing of this value will increase the amount of data which will be resend in the case of connection problem.
  • The decreasing of this value will increase the maintenance traffic.
Note

It is highly recommended to use Image Uploader ASP.NET or Image Uploader PHP to handle upload on the server side. Both of them automatically bundle pieces of one file, uploaded in separated chunks, and provide an access to this file as if it was uploaded as a whole.

In the most cases Image Uploader resumes the upload process automatically; but if it is impossible (the connection problem appears permanent), the last uploading package is considered as failed. If it happened, the upload list still contains all the unsent files, including the one which was sending when the upload was broken, and a user can resend them manually (just by clicking Upload one more time).

Additionally, you can extend your Image Uploader configuration to make it resistant to deeper problems, for example, when a page containing Image Uploader is closed or a computer is rebooted or suddenly turned off. By default, such problems cause clearing of the upload list and make a user to select all the files again. Fortunately, Image Uploader can save and restore upload list, even if a totally unexpected problem took place. This feature is described in the Restoring Upload List topic.

The code sample below demonstrates how to configure a fail-safe upload.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <UploadSettings AutoRecoveryMaxAttemptsCount="10"
        AutoRecoveryTimeout="2000"
        FilesPerPackage="1"
        ChunkSize="10485760"/>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getUploadSettings()->setAutoRecoveryMaxAttemptsCount(10);
$uploader->getUploadSettings()->setAutoRecoveryTimeout(2000);
$uploader->getUploadSettings()->setFilesPerPackage(1);
$uploader->getUploadSettings()->setChunkSize(10485760);

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    uploadSettings: {
        autoRecoveryMaxAttemptsCount: 10,
        autoRecoveryTimeout: 2000,
        filesPerPackage: 1,
        chunkSize: 10485760
    }
});

See Also

Reference

  • FilesPerPackage Property
  • ChunkSize Property
  • AutoRecoveryMaxAttemptCount Property
  • AutoRecoveryTimeout Property

Manual

  • Sending All Files at Once or in Several Parts
  • Saving Uploaded Files in ASP.NET
  • Saving Uploaded Files in PHP
  • Restoring Upload List
  • UploadSettings (ASP.NET)
  • UploadSettings (PHP)
  • uploadSettings (JavaScript)
  • AutoRecoveryMaxAttemptCount (ASP.NET)
  • AutoRecoveryMaxAttemptCount (PHP)
  • autoRecoveryMaxAttemptCount (JavaScript)
  • AutoRecoveryTimeout (ASP.NET)
  • AutoRecoveryTimeout (PHP)
  • autoRecoveryTimeout (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • AutoRecoveryMaxAttemptCount (ASP.NET)
  • AutoRecoveryMaxAttemptCount (PHP)
  • autoRecoveryMaxAttemptCount (JavaScript)
  • AutoRecoveryTimeout (ASP.NET)
  • AutoRecoveryTimeout (PHP)
  • autoRecoveryTimeout (JavaScript)


Configuring POST Format

Let us assume the situation when you already have a web site and you just want to embed Image Uploader in it. For example, your server-side scripts parse the POST request in a strongly defined format, and of course you do not want to rewrite them to make compatible with Image Uploader. In that case you just need to configure the control to send the POST request in the necessary format.

As you know, Image Uploader sends files and additional data as POST fields. There are two kinds of these fields:

  • Standard fields contain all the files and other upload information generated by Image Uploader. Standard fields have a predefined format by default.
  • Additional fields are custom. They can be attached to the POST request using the Metadata.AdditionalFormName property or the metadata.addCustomField(String, String, Boolean) method. Additional fields can use any format you like but should not conflict with the standard field names.

See the POST Field Reference topic for more details.

If a predefined format of standard POST fields is inconvenient for you, like in the situation described at the beginning of this article, you can rename them using the renameStandardField(String, String) method. This method uses two string parameters originalName and newName, where originalName is a name of some standard field and newName is its new name. Both parameters can contain particular indices or use the following placeholders:

  • [itemIndex] is the current index of the uploaded file.
  • [converterIndex] is the current index of the converted file.

The code sample below demonstrates how to rename standard POST fields and attach the additional fields to make Image Uploader compatible with server-side scripts which parse the POST request in the following format:

  • Author means author of the uploaded file.
  • Number means number of the uploaded file.
  • FileN is original file, where N is an index of this file.
  • FileN-Description is description of the Nth uploaded file.
  • FileN-ThumbnailX is the Xth thumbnail for the Nth uploaded image, or icon for non-image files.
  • FileN-ThumbnailX-Size is size of the Xth thumbnail of the Nth uploaded image.
  • FileN-ThumbnailX-Width is width of the Xth thumbnail of the Nth uploaded image.
  • FileN-ThumbnailX-Height is height of the Xth thumbnail of the Nth uploaded image.

JavaScript

var u = $au.uploader({
    id: 'Uploader1',

    converters: [
        { mode: '*.*=SourceFile'},
        { mode: '*.*=Thumbnail;*.*=Icon', thumbnailFitMode: 'Fit', thumbnailWidth: '120', thumbnailHeight: '120' },
        { mode: '*.*=Thumbnail;*.*=Icon', thumbnailFitMode: 'Fit', thumbnailWidth: '640', thumbnailHeight: '480' }
    ],

    //... other parameters ...
});

u.metadata().addCustomField("Author", author);
u.metadata().renameStandardField("PackageFileCount", "Number");
u.metadata().renameStandardField("File0_[itemIndex]", "File[itemIndex]");
u.metadata().renameStandardField("Description_[itemIndex]", "File[itemIndex]-Description");
u.metadata().renameStandardField("File[converterIndex]_[itemIndex]", "File[itemIndex]-Thumbnail[converterIndex]");
u.metadata().renameStandardField("File[converterIndex]Size_[itemIndex]", "File[itemIndex]-Thumbnail[converterIndex]-Size");
u.metadata().renameStandardField("File[converterIndex]Width_[itemIndex]", "File[itemIndex]-Thumbnail[converterIndex]-Width");
u.metadata().renameStandardField("File[converterIndex]Height_[itemIndex]", "File[itemIndex]-Thumbnail[converterIndex]-Height");

u.writeHtml();
Note

Renamed fields cannot be retrieved using the PostFields constants.

See Also

Reference

  • Metadata Class
  • POST Field Reference

Manual

  • Uploading Additional Data in ASP.NET
  • Uploading Additional Data in PHP
  • AdditionalFormName (ASP.NET)
  • AdditionalFormName (PHP)
  • additionalFormName (JavaScript)
  • PostFields (ASP.NET)
  • PostFields (PHP)
  • Metadata (ASP.NET)
  • Metadata (PHP)
  • metadata (JavaScript)


Handling Upload Completion

When a user uploads files using a standard <input type="file"> element, they expect to be redirected to the page they have submitted files to. However, Image Uploader works in a different way. The response generated by the page, which is specified with the UploadSettings.ActionUrl property, is sent back to Image Uploader rather than to the browser. In other words, it works as follows:

  1. Image Uploader submits files to the server using POST requests.
  2. The server script specified with the ActionUrl property processes uploaded files and sends some HTML back to Image Uploader.
  3. As soon as Image Uploader receives the response, the upload is considered completed. Now, the response should be handled somehow.

What will actually happen on the last step depends on you. First of all, no action can be taken. This is convenient when Image Uploader is inserted into a pop-up window and you would like to have it opened in the background.

Another popular behavior is to redirect a user to another page which, for example, displays uploaded files. The simplest way to accomplish this is to use the UploadSettings.RedirectUrl property:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <UploadSettings ActionUrl="upload.aspx"
        RedirectUrl="gallery.aspx" />
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getUploadSettings()->setActionUrl("upload.php");
$uploader->getUploadSettings()->setRedirectUrl("gallery.php");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    uploadSettings: { actionUrl: 'upload.aspx', redirectUrl: 'gallery.aspx' }
});

A more complicated, but more flexible way of handling the server response is to use the AfterUpload event. It is raised upon successful upload, and with it you can perform any actions allowed in client-side scripting. For example, you may specify another way of redirecting a user:

JavaScript

function afterUploadHandler(response) {
    window.location = "gallery.aspx";
}

var u = $au.uploader({
    id: 'Uploader1',
    events: { afterUpload: afterUploadHandler }
});

Or you can get access to the server response returned from the upload processing script. Here we demonstrate how to display a page returned from a server:

JavaScript

function afterUploadHandler(response) {
    var newWindow = window.open();
    with (newWindow.document) {
        open("text/html");
        write(response);
        close();
    }
}

var u = $au.uploader({
    id: 'Uploader1',
    events: { afterUpload: afterUploadHandler }
});

See Also

Reference

  • ActionUrl Property
  • RedirectUrl Property
  • AfterUpload Event
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)
  • RedirectUrl (ASP.NET)
  • RedirectUrl (PHP)
  • redirectUrl (JavaScript)
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)
  • RedirectUrl (ASP.NET)
  • RedirectUrl (PHP)
  • redirectUrl (JavaScript)


Adding Authentication

Many web-sites contain sensitive information and require only authorized users to have access to it. Authentication and authorization mechanisms aim at organizing the access control. Access is usually controlled by insisting on an authentication procedure allowing to establish the identity of the user and, then, grant those privileges as may be authorized to that identity. User name and password are usually used as identification credentials. In the case if specified user name/password pair is valid the person is considered as an authenticated user and, after that, the site logic determines resources the user can access.

This article describes authentication mechanisms that you can use along with Image Uploader:

  • basic and digest authentication
  • integrated Windows authentication (NTLM)
  • custom cookie-based authentication
  • URL-based authentication

In addition, Image Uploader supports HTTPS connections.

Image Uploader behaves differently in Internet Explorer and other browsers. Main difference from authentication point of view is that Image Uploader is not integrated with non-Internet Explorer browsers. It means that Image Uploader opens connection sockets "manually" and sends files and other data independently from a non-Internet Explorer browser, although it can get additional data and cookies through HTML and JavaScript beforehand. Also, Image Uploader cannot use most of a non-Internet Explorer browser security settings as well as authentication mechanism used on a page that hosts Image Uploader. Contrarily, if Image Uploader is launched in Internet Explorer, it uses HTTP communication layer of this browser to upload files. So, the transfer is performed in the same way as it is done by Internet Explorer and Image Uploader uses the same HTTP settings as a web page hosting it.

Due to this difference you need to perform some additional steps to implement authentication for non-Internet Explorer browsers. See paragraphs below for the detailed information on how this difference affects certain authentication types.

Basic and Digest Authentication

Basic and digest authentication are widely used on the Internet because they are supported by most browsers and are easy to implement. The main difference between these authentication mechanisms is that basic authentication sends the user name and password over the network as a plain text, whereas digest authentication hashes user credentials using MD5 algorithm. Both authentication schemes do not require any server-side scripting support. So, all you need to use any of them is to set up your web server (refer to your web server documentation for instructions). Image Uploader automatically determines what type of authentication (basic or digest) your site uses.

If your site is secured using basic or digest authentication the following login dialog will pop up in non-Internet Explorer browsers before upload, even if the user is already logged in:

To customize this dialog you may use the AuthenticationDialog class, for more information, please, see the Customizing Appearance topic.

Integrated Windows Authentication (NTLM)

Integrated Windows Authentication (also known as Windows NT Challenge/Response or NTLM authentication) directly uses Windows NT user accounts. It hashes the user name and password before transmitting them across the network. Like basic and digest authentication, this scheme does not require any server-side scripting support. For instructions on configuring your web server, refer to its documentation.

Important

Image Uploader supports NTLM authentication only in Internet Explorer. So, if you choose NTLM authentication for your site, users will cannot access it via non-Internet Explorer browsers (Firefox, Safari, and etc).

Custom Cookie-Based Authentication

This scheme requires additional support in server-side scripts. What exactly you will have to do depends on your web server, scripting language, and frameworks you use. But in general you will need to:

  • Provide some storage for user credentials.
  • Create a login form to check user names and passwords and set cookies.
  • Add checks, whether the user is identified, to your server scripts.
  • Send authentication and session cookies along with uploading files (in non-Internet Explorer browsers only).

For more information about the last step, please, see the maintaining sessions and authentication topic.

URL-Based Authentication

In general, this mechanism is similar to the previous one, but in this case all the information required for user identification is passed through the URL, not via cookies. In other words, you need to specify a special URL in the UploadSettings.ActionUrl property, like UploadScriptName?id=ldmvqinmsodjuhfqajmduj, to send the user identity. Then the server-side upload script will analyze the id request variable and apply corresponding permissions level.

See Also

Reference

  • AuthenticationDialog Class
  • ActionUrl Property
  • Customizing Appearance

Manual

  • Maintaining Sessions and Authentication in ASP.NET
  • Maintaining Sessions and Authentication in PHP
  • Maintaining Sessions and Authentication in ASP.NET
  • Maintaining Sessions and Authentication in PHP
  • AuthenticationDialog (ASP.NET)
  • AuthenticationDialog (PHP)
  • authenticationDialog (JavaScript)
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)
  • AuthenticationDialog (ASP.NET)
  • AuthenticationDialog (PHP)
  • authenticationDialog (JavaScript)
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)


Uploading to Cloud Storages

Cloud storage (in cloud computing) is a data storage available via the Internet as a Web service, like file sharing, backup services and so on. There are a lot of cloud storage providers on the Web and Image Uploader supports uploading files to the most popular of them, namely Amazon S3 and Nirvanix.

So if your Web application is integrated with one of these cloud storages you can use Image Uploader to upload files directly to them. To implement this functionality Image Uploader includes special classes - extenders which modify the POST request to make it compatible with cloud storage services.

Note

If you extend Image Uploader to upload files to Amazon S3 or Nirvanix storage, do not specify the UploadSettings.ActionUrl property directly. Both extenders configure this setting automatically.

Uploading to Amazon S3

When you create an account in the Amazon Web Service (AWS) you obtain your Access Key Id and Secret Access Key. These parameters are used for authentication purposes:

  • AWS Access Key Id identifies your AWS account. This key is included in every AWS request to identify the user.
  • Secret Access Key is never included into requests and used to sign AWS requests. Each request must contain a valid signature calculated using the Secret Access Key, otherwise authentication will fail.

To store objects Amazon S3 uses buckets which are quite similar to Internet domain names and must be unique within the Amazon S3. For example, if the object named myphotos/holiday.jpg is stored in the mybucket bucket, the URL to access this object is http://mybucket.s3.amazonaws.com/myphotos/holiday.jpg. Every bucket has an associated access control list used to verify whether the sender is able to access this bucket. Each object represents a file and metadata stored within a bucket using a unique key. A bucket and key together uniquely identify each object stored in the Amazon S3.

In the simplest case, to create a new Amazon S3 object you need to send the POST request which identifies the sender and defines the object to be created. It means that Image Uploader can be used for this purpose. So, to implement this functionality you can take an advantage of one of the following approaches.

Using Image Uploader JavaScript

This approach is more complicated but can be used with any Image Uploader supported server platform. It lies in using the amazonS3Extender class defined in the /Scripts/aurigma.uploader.amazons3.js file. However, before you initialize this class instance you should prepare additional data required for uploading to Amazon S3 storage: the security policy and signature.

Note

The security policy and signature should be created for each converted file configured with the uploader.converters property. If you are unfamiliar converters read the Configuring Files to be Uploaded topic first.

The policy is a UTF-8 and Base64 encoded JSON document which specifies the date when this policy expires and conditions the request must meet. The expiration date must be in ISO8601 GMT date format. The conditions are used to validate the uploaded object and include definitions for access control list, bucket, key, and metadata fields (both default and custom).

Here is the code sample that creates a policy document which expires in 100 minutes and defines an access control list option, bucket name, uploaded file, two default fields (width and height), and one custom (author).

C#

public string ConstructPolicy()
{
    StringBuilder policy = new StringBuilder();
    DateTime expDate = DateTime.Now.ToUniversalTime().AddSeconds(6000);

    policy.AppendLine("{ \"expiration\": \"" + expDate.ToString("s") + ".000Z\"");
    policy.AppendLine(", \"conditions\": [");
    policy.AppendLine(" {\"acl\": \"public-read\" }");
    policy.AppendLine(" , {\"bucket\": \"" + _bucket + "\" }");
    policy.AppendLine(" , {\"success_action_status\": \"200\"}");
    policy.AppendLine(" , [\"starts-with\", \"$key\", \"\"]");

    policy.AppendLine(" , [\"starts-with\", \"$x-amz-meta-width\", \"\"]");
    policy.AppendLine(" , [\"starts-with\", \"$x-amz-meta-height\", \"\"]");
    policy.AppendLine(" , [\"starts-with\", \"$x-amz-meta-author\", \"\"]");

    policy.AppendLine("]");
    policy.AppendLine("}");

    // Encode the policy using UTF-8.
    byte[] bytes = Encoding.UTF8.GetBytes(policy.ToString());

    // Encode those UTF-8 bytes using Base64.
    return Convert.ToBase64String(bytes);
}

To create a signature, sign the policy with your Secret Access Key using HMAC SHA-1 and encode the SHA-1 signature using Base64. See the code sample below, it demonstrates how to create a signature in .NET.

C#

public string CreateSignature()
{
    _policy = ConstructPolicy();

    // Sign the policy with your Secret Access Key using HMAC SHA-1.
    System.Security.Cryptography.HMACSHA1 hmac = new System.Security.Cryptography.HMACSHA1();
    hmac.Key = System.Text.Encoding.UTF8.GetBytes(_secretAccessKey);

    byte[] signb = hmac.ComputeHash(System.Text.Encoding.UTF8.GetBytes(_policy));

    // Encode the SHA-1 signature using Base64.
    _signature = Convert.ToBase64String(signb);
}

Then initialize an amazonS3Extender object and specify your AWSAccessKeyId and bucket using the accessKeyId and bucket properties. However, if you have a host name associated with an Amazon S3 bucket you should additionally specify this host name using the bucketHostName property.

Then for each converted file add a fileSettings instance specifying:

  • access control list which should be equal to the acl value defined in the policy (acl)
  • key of Amazon S3 object to be created for this converted file (key); here you can use the ${filename} variable to set a name of this file
  • policy constructed and encoded before (policy)
  • signature (signature)
  • set of predefined and custom metadata fields which will be uploaded within this file (meta); these fields should be defined in the policy

JavaScript

<script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
<script type="text/javascript" src="Scripts/aurigma.uploader.amazons3.js">  </script>
<script type="text/javascript">
var u = $au.uploader({
    id: 'Uploader1',
    converters: [
        {mode: '*.*=SourceFile'},
        // ... Other converters
    ]
});

var as3 = $au.amazonS3Extender(u);
as3.accessKeyId(_AWSAccessKeyId);
as3.bucket(_bucket);
as3.bucketHostName('http://yourdomain.com/');
as3.converters([
    {
        acl: 'public-read',
        key: '${filename}',
        policy: _policy,
        signature: _signature,
        meta: [
            { name: 'Width', field: 'SourceWidth_[itemIndex]'},
            { name: 'Height', field: 'SourceHeight_[itemIndex]'},
            { name: 'Author', value: 'John Smith'}
        ]
    },
    // ... Other converters
]);

u.writeHtml();
</script>

See the Amazon S3 Documentation for the detailed information on how to upload files to Amazon S3 using POST.

Using Image Uploader ASP.NET

This approach is simpler, but applicable for ASP.NET applications only. It releases you from necessity to prepare the policy and signature yourself as well as familiarize with the Amazon S3 API. You just need to perform the following steps to force Image Uploader to upload files directly to Amazon S3 storage:

  1. Initialize an AmazonS3Extender object.
  2. Specify your AWSAccessKeyId, secretAccessKey, and bucket as values of the AWSAccessKeyId, SecretAccessKey, and Bucket properties.

  3. For each converted file add a FileSettings instance and configure it as follows:

    1. Set acl and key for this file using the Acl and Key properties.
    2. Add as many metadata fields as you like by adding PredefinedMetaProperty and CustomMetaProperty objects to the FileSettings.Meta collection.

C#

<%@ Register assembly="Aurigma.ImageUploader" Namespace="Aurigma.ImageUploader" tagprefix="cc1" %>
<%@ Register assembly="Aurigma.ImageUploader" namespace="Aurigma.ImageUploader.AmazonS3" tagprefix="cc1" %>
<!--... Omitted for brevity ...-->
<form id="form1" runat="server">
    <cc1:Uploader ID="Uploader1" runat="server">
        <Converters>
            <cc1:Converter Mode="*.*=SourceFile" />
            <!-- Other converters -->
        </Converters>
    </cc1:Uploader>
    <cc1:AmazonS3Extender runat="server" ID="AmazonS3Extender1" TargetControlID="Uploader1"
        AWSAccessKeyId="<%$ _AWSAccessKeyId %>"
        Bucket="<%$ _Bucket %>"
        SecretAccessKey="<%$ _SecretAccessKey %>"
        PolicyExpiration="6000">
        <cc1:FileSettings Acl="public-read" Key="${filename}">
            <cc1:PredefinedMetaProperty Field="SourceWidth_[itemIndex]" Name="width" />
            <cc1:PredefinedMetaProperty Field="SourceHeight_[itemIndex]" Name="height" />
            <cc1:CustomMetaProperty Name="Author" Value="John Smith" />
        </cc1:FileSettings>
        <!-- Other files -->
    </cc1:AmazonS3Extender>
</form>

Using Image Uploader PHP

The present approach is to use Image Uploader PHP to upload files to Amazon S3 storage. To implement this functionality Image Uploader PHP exposes the same name classes and the same object model as the ASP.NET control (see the section above). So, to extend Image Uploader with a direct upload to Amazon S3 storage, follow the steps below:

  1. Create an AmazonS3Extender object.
  2. Specify your AWSAccessKeyId, bucket, and secretAccessKey as values of the AWSAccessKeyId, Bucket, and SecretAccessKey properties respectively.

  3. For each converted file add a FileSettings instance and configure it as follows:

    1. Set acl and key for this file using the Acl and Key properties.
    2. Add predefined and custom metadata fields to the FileSettings.Meta array.

PHP

require_once "ImageUploaderPHP/Uploader.class.php";
require_once "ImageUploaderPHP/AmazonS3Extender.class.php";

$uploader = new Uploader("Uploader1");
$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=SourceFile");
$converters[] = $converter;
//Other converters

$as3 = new AmazonS3Extender($uploader);
$as3->setAWSAcceccKeyId($AWSAccessKeyId);
$as3->setBucket($Bucket);
$as3->setSecretAccessKey($SecretAccessKey);
$files = &$as3->getFiles();
$file = new FileSettings();
$file->setAcl("public-read");
$file->setKey('${filename}');
$file->setMeta(array(
  array("name" => "Author", "value" => "John Smith"),
  array("name" => "width", "field" => "SourceWidth_[itemIndex]"),
  array("name" => "height", "field" => "SourceHeight_[itemIndex]")
));
$files[] = $file;
//Other files

$uploader->render();

Uploading to Nirvanix

Note

The Nirvanix service allows uploading files only. All metadata sent by Image Uploader will be ignored.

In the common case, to access Nirvanix storage you must provide the username and password you are registered in the service with. Another access parameter is the application key which represents an identifier of the application you are going to access.

By analogy with Amazon S3, to configure Image Uploader to upload files to the Nirvanix service you may use one of the following approaches.

Using Image Uploader JavaScript

This approach is more flexible but requires you to be familiarized with the Nirvanix API. All you need in this case is to send at least two requests to the Nirvanix service, parse returned XML responses, and instantiate a nirvanixExtender object defined in the /Scripts/aurigma.uploader.nirvanix.js file. Each request represents a call to a corresponding Nirvanix method. The URL format for requests is:

http(s)://services.nirvanix.com/ws/{NameSpace}/MethodName.ashx?name=value&name2=value2

When you call some method you get a response in XML format. The default XML response for methods which do not return data is:

XML

<Response>
    <ResponseCode>0</ResponseCode>
</Response>

So, with the nirvanixExtender you can configure Image Uploader to send files directly to the Nirvanix storage from any HTTP-compliant server platform. To implement this functionality go through the following steps:

  1. Call the Login method with your appKey, userName, and password:

    /ws/Authentication/Login.ashx?appKey=your_key&userName=your_name&password=your_password

  2. Retrieve the sessionToken from the returned response.

  3. Call the GetStorageNodeExtended method with the sessionToken obtained on the previous step, size of the file to be uploaded, and the destination folder:

    /ws/IMFS/GetStorageNodeExtended.ashx?sessionToken=your_token&sizeBytes=filesize&destFolderPath=path

  4. Retrieve the uploadHost and uploadToken from the returned response.

  5. Add a nirvanixExtender object to your Image Uploader configuration. Pass the uploadToken and uploadHost returned by the GetStorageNodeExtended method and the destination folder to this object. Use the uploadToken, uploadHost, and destFolderPath properties for it.

    Note

    The destination folder passed to the GetStorageNodeExtended method must be equal to the one specified with the destFolderPath property.

    JavaScript

    <script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
<script type="text/javascript" src="Scripts/aurigma.uploader.nirvanix.js">  </script>
<script type="text/javascript">
var u = $au.uploader({
    id: 'Uploader1',
    converters: [
        {mode: '*.*=SourceFile'},
        // ... Other converters
    ]
});

var nx = $au.nirvanixExtender(u);
nx.uploadToken(_uploadToken);
nx.uploadHost(_uploadHost);
nx.destFolderPath('/upload/');

u.writeHtml();
</script>

Using Image Uploader ASP.NET

This approach is simpler than the first described. Here you do not need to call Nirvanix methods directly; Image Uploader ASP.NET obtains the required data itself. Thus, you just need to initialize a NirvanixExtender object and specify your appKey, userName, and password as values of the corresponding properties. See the code sample below.

C#

<%@ Register assembly="Aurigma.ImageUploader" Namespace="Aurigma.ImageUploader" tagprefix="cc1" %>
<%@ Register assembly="Aurigma.ImageUploader" namespace="Aurigma.ImageUploader.Nirvanix" tagprefix="cc1" %>
<!--... Omitted for brevity ...-->
<form id="form1" runat="server">
    <cc1:Uploader ID="Uploader1" runat="server">
        <Converters>
            <cc1:Converter Mode="*.*=SourceFile" />
            <!-- Other converters -->
        </Converters>
    </cc1:Uploader>
    <cc1:NirvanixExtender runat="server" ID="NirvanixExtender1" TargetControlID="Uploader1"
        DestFolderPath="/upload/"
        AppKey="<%$ _appKey %>"
        Password="<%$ _password %>"
        Username="<%$ _username %>" />
</form>

Using Image Uploader PHP

By analogy with Image Uploader ASP.NET, Image Uploader PHP includes the NirvanixExtender class to support a direct upload to Nirvanix storage. To implement this functionality just set your appKey, userName, and password as values of the AppKey, Username, and Password properties.

PHP

require_once "ImageUploaderPHP/Uploader.class.php";
require_once "ImageUploaderPHP/NirvanixExtender.class.php";

$uploader = new Uploader("Uploader1");
$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=SourceFile");
$converters[] = $converter;
//Other converters

$nx = new NirvanixExtender($uploader);
$nx->setAppKey($app_key);
$nx->setUsername($username);
$nx->setPassword($password);
$nx->setDestFolderPath("/upload/");

$uploader->render();

See Also

Reference

  • AmazonS3Extender Class
  • FileSettings Class
  • NirvanixExtender Class
  • POST Field Reference

Manual

  • Configuring Files to be Uploaded

Other Resources

  • Amazon Simple Storage Service API Reference
  • Nirvanix Web Services API Developer's Guide
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)
  • AmazonS3Extender (ASP.NET)
  • AmazonS3Extender (PHP)
  • amazonS3Extender (JavaScript)
  • FileSettings (ASP.NET)
  • FileSettings (PHP)
  • fileSettings (JavaScript)
  • NirvanixExtender (ASP.NET)
  • NirvanixExtender (PHP)
  • nirvanixExtender (JavaScript)


Uploading Images

This section tells about transforming user-selected images before upload. Image Uploader can resize, recompress, rotate, crop and watermark images on a client side. These transformations may be combined, for example, an image can be resized and watermarked at the same time. You may create any number of transformed versions of one image, for example, the first one is considerably downsized version, the second one is watermarked, and the third one is cropped and watermarked. An image you get after applying any set of transformations is called thumbnail.

To configure a thumbnail you should add a Converter to the Uploader.Converters collection and set its Mode property to Thumbnail. For more information about converters, please, see the Configuring Files to be Uploaded topic.

Each thumbnail is a file, so on the server you can save uploaded thumbnails using any approach examined in the saving uploaded files topic.

Now, when you have an idea about what thumbnail means in terms of Image Uploader, how to configure converters, and how to save uploaded files, let us briefly describe each topic of this section:

  • The Resizing and Recompressing topic tells about basic concepts, such as thumbnail size, quality, and resolution. It also gives an advice on how to handle the situation when a thumbnail cannot be created.
  • The Rotating and Cropping topic describes how to rotate and crop images in two modes: manual and automatic. It also provides instructions on how to highlight a rectangular area of an image to mark an object or a person out.
  • The Applying Watermarks topic has a lot to tell about adding watermarks, which may be text or image, solid or transparent, and can be put in any place of an image.
  • The Working with EXIF and IPTC Metadata topic gives a brief definition of what metadata is, and describes Image Uploader possibilities in metadata handling, especially preserving metadata in thumbnails.
Note

Image Uploader can load a lot of image formats and display previews for them, however, it can save the image only into the single format - JPEG. So, all thumbnails created by Image Uploader are JPEG images.

  • saving uploaded files in PHP
  • saving uploaded files in ASP.NET
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • Converters (ASP.NET)
  • Converters (PHP)
  • converters (JavaScript)
  • Mode (ASP.NET)
  • Mode (PHP)
  • mode (JavaScript)


Resizing and Recompressing

As you know, any image transformed and sent by Image Uploader is called thumbnail. To upload thumbnails you need to create a Converter and set its Mode property to Thumbnail. Then use its ThumbnailXXX properties to configure thumbnails. This topic examines resizing and recompressing settings and describes how to handle the situation when a thumbnail cannot be created.

Thumbnail Size

Note

Image Uploader Express and Professional restrict a size (width x height) of each created thumbnail to 3 and 5 megapixels respectively. For example, the size of 1500x1500 thumbnail is 2.25 megapixels (1500 pixels x 1500 pixels = 2.25 megapixels), so such thumbnail can be uploaded with Image Uploader Express. See the Comparison of Image Uploader Editions topic for details.

There are three settings specifying how the original image will be resized to create a thumbnail:

  • ThumbnailHeight is the height of the thumbnail.
  • ThumbnailWidth is the width of the thumbnail.
  • ThumbnailFitMode is the fit mode of the thumbnail.

The ThumbnailFitMode is quite complicated, so let us describe it in detail. Fit mode is an important setting for thumbnail creation. It specifies if the thumbnail should be resized at all, and if yes, how it should be shrunk to fit the specified dimensions. The ThumbnailFitMode property has the following possible values:

  • Fit means that the original image should be resized to fit the rectangle specified with the ThumbnailHeight and ThumbnailWidth properties. Note that the proportions of the original image will be kept.
  • Width means that the original image should be resized to be no wider than the ThumbnailWidth value. Image is resized proportionally, so the ThumbnailHeight property is ignored in this mode.
  • Height means that the original image should be resized to be no higher than the ThumbnailHeight value. Image is resized proportionally, so the ThumbnailWidth property is ignored in this mode.
  • ActualSize means that dimensions of the original image should be kept; however, it can be rotated or recompressed if necessary.
Note

Image Uploader can only downsize images, so if specified thumbnail size (ThumbnailHeight and ThumbnailWidth) is larger than the original image size thumbnail will be equal in size to the original image.

The next example illustrates how to create a thumbnail converter and set its general properties.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Converters>
        <aur:Converter Mode="*.*=Thumbnail"
           ThumbnailHeight="200"
           ThumbnailWidth="200"
           ThumbnailFitMode="Fit" />
    </Converters>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=Thumbnail");
$converter->setThumbnailWidth(200);
$converter->setThumbnailHeight(200);
$converter->setThumbnailFitMode("Fit");
$converters[] = $converter;

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    converters: [{mode: '*.*=Thumbnail',
        thumbnailWidth: 200,
        thumbnailHeight: 200,
        thumbnailFitMode: 'Fit'}]
});

Thumbnail Quality

The only thumbnail supported file format is JPEG. It means that a thumbnail will be a JPEG image whatever format an original image has. This image format has an ability to balance between file size and image quality. You can specify JPEG quality of a thumbnail via the ThumbnailJpegQuality property which accepts a number in the range [0, 100]. If you specify 0, the file will be extremely small, but the quality will be very low (almost always unacceptable). Alternatively, if you specify 100, the file will be quite large, but JPEG artifacts will be almost invisible. Usually, small images have rather low quality (to be loaded quickly), whereas screen-size images have higher quality. The default ThumbnailJpegQuality value is 80 which is the most balanced and common JPEG quality.

Note

If you set the JPEG quality to a large value, and upload a JPEG file that has poor quality initially, the file size may increase (although the quality will not become better). It is not guaranteed that the output JPEG will have the same or less size than the original file. This effect is caused by specificity of JPEG compression algorithm.

That is why if you expect that users will upload poor-quality JPEG files, it makes sense to set the quality to a low value.

There is also the ThumbnailResizeQuality property which is related to the thumbnail quality. This property specifies the quality of resize. The resize quality should not be confused with the JPEG quality: the latter specifies the quality of recompression, not resize. As for now, you may choose between the following quality values: Low, Medium, and High. The default is Medium, as soon as it provides fast resizing and good quality at the same time.

Thumbnail Resolution

Image Uploader allows specifying image resolution for created thumbnails via the ThumbnailResolution property. This parameter is measured in DPI and sets horizontal and vertical resolution of a thumbnail. You can set your custom resolution for thumbnails or keep an original image resolution. The default value of the ThumbnailResolution is 0 meaning that the original image resolution is used.

If Thumbnail is Bigger Than Original Image

Image Uploader cannot resize images up. Therefore, if you specify thumbnail dimensions bigger than dimensions of the original file, the thumbnail will be actually created with the dimensions of the original file. Optionally Image Uploader allows sending the original file instead of thumbnail (which is recompressed to JPEG while it is created) in the case when dimensions and file size of the original file are not bigger than the dimensions and file size of the thumbnail. To enable this behavior you should set the ThumbnailCompressOversizedOnly property to true.

Handling Image Transparency

All the thumbnails are created as JPEG images, and the JPEG format does not support transparency. That does not mean that you will be unable to create thumbnails for transparent images. The thumbnails will simply be created on a background of some color. You can set this color using the ThumbnailBgColor property. To specify desired background color use a hex representation of the RGB triad in HTML-style syntax (#rrggbb). Default background color is white (#FFFFFF).

Keeping Image Color Space

Note

Image Uploader Express and Professional do not keep original color space while creating thumbnails. See the Comparison of Image Uploader Editions topic for details.

An original image may have RGB, CMYK, Grayscale, or some else color space. By default Image Uploader creates RGB thumbnails. If this behavior does not suit you set the ThumbnailKeepColorSpace property to true, as a result the thumbnail will be created in the original color space.

If Thumbnail Cannot be Created

It is possible that some specific thumbnail will fail to be created, for example, when the original file is corrupted or it is non-image. To handle this situation specify one more conversion mode (e.g. SourceFile or Icon) after the Thumbnail one. In this case, if applying of the first mode has failed, Image Uploader will try to use the next one.

The following example illustrates the idea.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Converters>
        <!-- Send the source file if the thumbnail cannot be created -->
        <aur:Converter Mode="*.*=Thumbnail;*.*=SourceFile" />
        <!-- Send an icon if the thumbnail cannot be created -->
        <aur:Converter Mode="*.*=Thumbnail;*.*=Icon" />
    </Converters>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$converters = &$uploader->getConverters();
$converter = new Converter();
//Send the source file if the thumbnail cannot be created
$converter->setMode("*.*=Thumbnail;*.*=SourceFile");
$converters[] = $converter;
$converter = new Converter();
//Send an icon if the thumbnail cannot be created
$converter->setMode("*.*=Thumbnail;*.*=Icon");
$converters[] = $converter;

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    converters: [
        //Send the original file if the thumbnail cannot be created
        {mode: '*.*=Thumbnail;*.*=SourceFile'},
        //Send an icon if the thumbnail cannot be created
        {mode: '*.*=Thumbnail;*.*=Icon'}
    ]
});

See Also

Reference

  • Converter Class

Manual

  • Uploading Images
  • Rotating and Cropping
  • Working with EXIF and IPTC Metadata
  • Applying Watermarks
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • Mode (ASP.NET)
  • Mode (PHP)
  • mode (JavaScript)
  • ThumbnailHeight (ASP.NET)
  • ThumbnailHeight (PHP)
  • thumbnailHeight (JavaScript)
  • ThumbnailWidth (ASP.NET)
  • ThumbnailWidth (PHP)
  • thumbnailWidth (JavaScript)
  • ThumbnailFitMode (ASP.NET)
  • ThumbnailFitMode (PHP)
  • thumbnailFitMode (JavaScript)
  • ThumbnailFitMode (ASP.NET)
  • ThumbnailFitMode (PHP)
  • thumbnailFitMode (JavaScript)
  • ThumbnailFitMode (ASP.NET)
  • ThumbnailFitMode (PHP)
  • thumbnailFitMode (JavaScript)
  • ThumbnailHeight (ASP.NET)
  • ThumbnailHeight (PHP)
  • thumbnailHeight (JavaScript)
  • ThumbnailWidth (ASP.NET)
  • ThumbnailWidth (PHP)
  • thumbnailWidth (JavaScript)
  • ThumbnailWidth (ASP.NET)
  • ThumbnailWidth (PHP)
  • thumbnailWidth (JavaScript)
  • ThumbnailHeight (ASP.NET)
  • ThumbnailHeight (PHP)
  • thumbnailHeight (JavaScript)
  • ThumbnailHeight (ASP.NET)
  • ThumbnailHeight (PHP)
  • thumbnailHeight (JavaScript)
  • ThumbnailWidth (ASP.NET)
  • ThumbnailWidth (PHP)
  • thumbnailWidth (JavaScript)
  • ThumbnailHeight (ASP.NET)
  • ThumbnailHeight (PHP)
  • thumbnailHeight (JavaScript)
  • ThumbnailWidth (ASP.NET)
  • ThumbnailWidth (PHP)
  • thumbnailWidth (JavaScript)
  • ThumbnailJpegQuality (ASP.NET)
  • ThumbnailJpegQuality (PHP)
  • thumbnailJpegQuality (JavaScript)
  • ThumbnailJpegQuality (ASP.NET)
  • ThumbnailJpegQuality (PHP)
  • thumbnailJpegQuality (JavaScript)
  • ThumbnailResizeQuality (ASP.NET)
  • ThumbnailResizeQuality (PHP)
  • thumbnailResizeQuality (JavaScript)
  • ThumbnailResolution (ASP.NET)
  • ThumbnailResolution (PHP)
  • thumbnailResolution (JavaScript)
  • ThumbnailResolution (ASP.NET)
  • ThumbnailResolution (PHP)
  • thumbnailResolution (JavaScript)
  • ThumbnailCompressOversizedOnly (ASP.NET)
  • ThumbnailCompressOversizedOnly (PHP)
  • thumbnailCompressOversizedOnly (JavaScript)
  • ThumbnailBgColor (ASP.NET)
  • ThumbnailBgColor (PHP)
  • thumbnailBgColor (JavaScript)
  • ThumbnailKeepColorSpace (ASP.NET)
  • ThumbnailKeepColorSpace (PHP)
  • thumbnailKeepColorSpace (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)


Rotating and Cropping

Rotating and cropping are two basic photo-editing actions. Image Uploader provides the built-in image editor to perform these actions manually by a user, or you can configure Image Uploader to rotate and crop images automatically. This topic consists of two parts, namely, rotating images and cropping images, each tells how to configure Image Uploader to upload edited versions of images and edit images automatically.

Rotating Images

There are two approaches to rotating images in Image Uploader:

  • manual rotation based on the user-given rotation angle
  • automatic rotation based on the EXIF metadata

Manual Rotation

By default manual rotation is enabled in Image Uploader. It means that a user can rotate images either by clicking the rotation control, or using the image editor. To upload rotated images you just need to specify a Converter with Thumbnail Mode, as it is shown in the example below.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Converters>
        <aur:Converter Mode="*.*=Thumbnail" ThumbnailFitMode="ActualSize" />
    </Converters>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=Thumbnail");
$converter->setThumbnailFitMode("ActualSize");
$converters[] = $converter;

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    converters: [{mode: '*.*=Thumbnail',
        thumbnailFitMode: 'ActualSize'}]
});

You may also get rotation angle value on the server and handle it in a way that suites your requirements, for more information, please, see the receiving rotation angle paragraph.

To disable manual image rotation set the Uploader.EnableRotation property to false.

Automatic Rotation

Automatic rotation means that Image Uploader rotates images automatically, if needed. The decision, whether to rotate an image or not, is based on the EXIF metadata contained in the original image. To turn automatic rotation on you have to set the Uploader.EnableAutoRotation property to true and add a Thumbnail converter, as it is shown in the following example.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server" EnableAutoRotation="true">
    <Converters>
        <aur:Converter Mode="*.*=Thumbnail" ThumbnailFitMode="ActualSize" />
    </Converters>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->setEnableAutoRotation(true);
$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=Thumbnail");
$converter->setThumbnailFitMode("ActualSize");
$converters[] = $converter;

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    enableAutoRotation: true,
    converters: [{mode: '*.*=Thumbnail',
        thumbnailFitMode: 'ActualSize'}]
});
Note

Though it may be convenient, remember that not all the cameras recognize orientation properly. Reading EXIF data also slows down the process of folder scanning, and if the folder contains a lot of images, the decrease in speed may be noticeable.

Cropping Images

This paragraph describes main approaches to cropping in Image Uploader:

  • Manual cropping is a classic use case of any crop tool. It allows a user to remove unwanted areas from an image.
  • Automatic cropping is a programmatic way to crop each user-selected image using a predefined rectangular area.
  • Uploading rectangular selection is especially helpful in social networking. This allows users to highlight an area of an image.

Manual Cropping

A user can crop images via the image editor. When a user crops an image this way, Image Uploader saves the crop bounds. To upload cropped images you have to create a Thumbnail converter and set its ThumbnailApplyCrop property to true, like it is shown in the following example.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server" >
    <Converters>
        <aur:Converter Mode="*.*=Thumbnail"
           ThumbnailFitMode="ActualSize"
           ThumbnailApplyCrop="true" />
    </Converters>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=Thumbnail");
$converter->setThumbnailFitMode("ActualSize");
$converter->setThumbnailApplyCrop(true);
$converters[] = $converter;

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    converters: [{mode: '*.*=Thumbnail',
        thumbnailFitMode: 'ActualSize',
        thumbnailApplyCrop: true}]
});

Automatic Cropping

This paragraph describes how to crop each user-selected image automatically. Automatic cropping consists of two parts:

  1. Setting crop bounds. To perform this task you should iterate through user-selected images and specify crop bounds for each of them via the file.cropBounds property. This should be done before upload begins, so we recommend to place the corresponding code to the BeforeUpload event handler. For more information about client events in Image Uploader, please, see the using events topic.
  2. Upload cropped images. Here, you just create a Thumbnail converter and set its ThumbnailApplyCrop property to true.

The following example crops 200 x 200 pixels rectangle out of the center of each user-selected image.

ASP.NET

<script type="text/javascript">
function beforeUploadHandler(){
    var cropWidth = 200;
    var cropHeight = 200;
    var count = $au.uploader('Uploader1').files().count();
    for (var i=0; i < count; i++) {
        var $file = $au.uploader('Uploader1').files().get(i);
        var imageCenterX = $file.width() / 2;
        var imageCenterY = $file.height() / 2;
        var cropBounds = [(imageCenterX - cropWidth/2),
            (imageCenterY - cropHeight/2), cropWidth, cropHeight];
        $file.cropBounds(cropBounds);
    }
}
</script>

<aur:Uploader ID="Uploader1" runat="server" >
    <Converters>
        <aur:Converter Mode="*.*=Thumbnail"
           ThumbnailFitMode="ActualSize"
           ThumbnailApplyCrop="true" />
    </Converters>
    <ClientEvents>
        <aur:ClientEvent EventName="BeforeUpload" HandlerName="beforeUploadHandler" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function beforeUploadHandler(){
    var cropWidth = 200;
    var cropHeight = 200;
    var count = $au.uploader('Uploader1').files().count();
    for (var i=0; i < count; i++) {
        var $file = $au.uploader('Uploader1').files().get(i);
        var imageCenterX = $file.width() / 2;
        var imageCenterY = $file.height() / 2;
        var cropBounds = [(imageCenterX - cropWidth/2),
            (imageCenterY - cropHeight/2), cropWidth, cropHeight];
        $file.cropBounds(cropBounds);
    }
}
</script>
<?php
$uploader = new Uploader("Uploader1");
$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=Thumbnail");
$converter->setThumbnailFitMode("ActualSize");
$converter->setThumbnailApplyCrop(true);
$converters[] = $converter;
$uploader->getClientEvents()->setBeforeUpload("beforeUploadHandler");
$uploader->render();
?>

JavaScript

function beforeUploadHandler(){
    var cropWidth = 200;
    var cropHeight = 200;
    var count = this.files().count();
    for (var i=0; i < count; i++) {
        var $file = this.files().get(i);
        var imageCenterX = $file.width() / 2;
        var imageCenterY = $file.height() / 2;
        var cropBounds = [(imageCenterX - cropWidth/2),
            (imageCenterY - cropHeight/2), cropWidth, cropHeight];
        $file.cropBounds(cropBounds);
    }
}

var u = $au.uploader({
    id: 'Uploader1',
    converters: [{mode: '*.*=Thumbnail',
        thumbnailFitMode: 'ActualSize',
        thumbnailApplyCrop: true}],
    events: { beforeUpload: beforeUploadHandler }
});

Uploading Rectangular Selection

Selecting an image area to highlight a person or an object is a quite popular idea in social networking. In Image Uploader a user actually selects a rectangular area of an image while cropping this image. Bounds of this rectangle will be uploaded along with the image, no matter what converter mode you use (in this case you can set SourceFile mode). So, on the server side you may receive user-given selection and show the highlighted area on the image.

To get to know how to obtain crop bounds on the server side, please, see the receiving crop bounds paragraph.

See Also

Reference

  • Uploader Class
  • EnableRotation Property
  • Converter Class
  • ThumbnailApplyCrop Property
  • file Class
  • files Class
  • BeforeUpload Event

Manual

  • Image Editor
  • Uploading Images
  • Resizing and Recompressing
  • Working with EXIF and IPTC Metadata
  • Applying Watermarks
  • receiving rotation angle in ASP.NET
  • receiving rotation angle in PHP
  • receiving crop bounds in ASP.NET
  • receiving crop bounds in PHP
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • Mode (ASP.NET)
  • Mode (PHP)
  • mode (JavaScript)
  • EnableRotation (ASP.NET)
  • EnableRotation (PHP)
  • enableRotation (JavaScript)
  • EnableAutoRotation (ASP.NET)
  • EnableAutoRotation (PHP)
  • enableAutoRotation (JavaScript)
  • ThumbnailApplyCrop (ASP.NET)
  • ThumbnailApplyCrop (PHP)
  • thumbnailApplyCrop (JavaScript)
  • ThumbnailApplyCrop (ASP.NET)
  • ThumbnailApplyCrop (PHP)
  • thumbnailApplyCrop (JavaScript)
  • Uploader (ASP.NET)
  • Uploader (PHP)
  • uploader (JavaScript)
  • EnableRotation (ASP.NET)
  • EnableRotation (PHP)
  • enableRotation (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • ThumbnailApplyCrop (ASP.NET)
  • ThumbnailApplyCrop (PHP)
  • thumbnailApplyCrop (JavaScript)


Applying Watermarks

A watermark is a text or an image which is printed upon the image, and provides a simple means of adding useful information like date and time, the name of the image author, or some logo. With Image Uploader you can easily add watermarks to thumbnails before they are uploaded. Here you can use a text or an image as a watermark, specify watermark position and opacity, and set some other watermark parameters.

This topic consists of the following sections:

  • The general settings section shows how to turn watermarking on and describes parameters related to both text and image watermarks.
  • The text watermarks section tells about text-specific watermark settings and gives the example of adding text watermark to an image.
  • The image watermarks section describes image-specific watermark settings and gives the example of adding image watermark to an image.
  • The watermarking original images section contains the example of applying watermark to an original image.

General Settings

To apply a watermark to user-selected images you should add a Thumbnail converter and specify its ThumbnailWatermark property. This property accepts a string containing a semicolon-separated list of watermark settings: variable1=value1;variable2=value2;.... Now, let us describe parameters that are common for both image and text watermarks:

  • Position specifies watermark position relatively to the watermarking image.
  • OffsetX sets horizontal offset (in pixels) of the watermark relatively to the position it is anchored to.
  • OffsetY sets vertical offset (in pixels) of the watermark relatively the position it is anchored to.
  • Opacity specifies watermark opacity percentage, 0 means total transparency, 100 means the watermark is opaque.
Note

Watermark parameters are case insensitive and can be specified in any order.

If you set both text and image watermarks, take into consideration that the text is always drawn over the image watermark and the positions of the text and image watermarks are calculated separately.

Text Watermarks

This section tells about text watermarks, the most common text watermark is date stamp, also it may be an image author name, a brief comment, or something else. You can use all the general settings with text watermarks and the following text-specific properties:

  • Text specifies text of watermark.
  • Font specifies font name. This font should be installed on the client machine.
  • Size specifies font size (in pixels).
  • Style specifies font style. The following styles are supported: Bold, Italic, Underlined. To get multi-style text specify several styles separated by a comma, for example, "Style=Bold,Italic" gives bold and italic at the same time.
  • FillColor specifies font color. It has the same syntax as all Image Uploader color properties (HTML-style #rrggbb RGB value). Default value is an empty string, which allows to create only outlined text without inner fill.

You also can specify background and outline of the text watermark:

  • BackgroundColor specifies color of background (HTML-style #rrggbb RGB value).
  • BackgroundMarginWidth and BackgroundMarginHeight set width and height of additional space outside of the watermark filled with background (in pixels).
  • OutlineColor specifies color of outline (HTML-style #rrggbb RGB value).
  • OutlineWidth sets width of outline (in pixels).

The following example demonstartes how to add text watermark, containing current system date and time, to uploading images:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server" >
    <Converters>
        <aur:Converter Mode="*.*=Thumbnail"
           ThumbnailFitMode="Fit" ThumbnailWidth="320" ThumbnailHeight="240" />
    </Converters>
</aur:Uploader>

C#

protected void Page_Load(object sender, EventArgs e)
{
    Uploader1.Converters[0].ThumbnailWatermark = "Text=" + DateTime.Now.ToString() + ";Size=20;" +
    "Style=Bold;FillColor=#00ff00;Opacity=60;Position=BottomRight;OffsetY=5;OffsetX=5;" +
    "BackgroundColor=#a6caf0;BackgroundMarginWidth=5;OutlineColor=#000080;OutlineWidth=1";
}

PHP

$uploader = new Uploader("Uploader1");
$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=Thumbnail");
$converter->setThumbnailFitMode("Fit");
$converter->setThumbnailWidth(320);
$converter->setThumbnailHeight(240);
$converter->setThumbnailWatermark("Text=" . date("m.d.Y H:i:s") . ";Size=20;Style=Bold;" .
    "FillColor=#00ff00;Opacity=60;Position=BottomRight;OffsetY=5;OffsetX=5;" .
    "BackgroundColor=#a6caf0;BackgroundMarginWidth=5;OutlineColor=#000080;OutlineWidth=1");
$converters[] = $converter;

JavaScript

var currDate = new Date();
var currDateString = (currDate.getMonth()+1) + '.' + currDate.getDate() + '.' + currDate.getFullYear() +
    ' ' + currDate.getHours() + ':' + currDate.getMinutes() + ':' + currDate.getSeconds();
var u = $au.uploader({
    id: 'Uploader1',
    converters: [{mode: '*.*=Thumbnail',
        thumbnailWidth: 320,
        thumbnailHeight: 240,
        thumbnailFitMode: 'Fit',
        thumbnailWatermark: 'Text=' + currDateString + ';Size=20;Style=Bold;' +
        'FillColor=#00ff00;Opacity=60;Position=BottomRight;OffsetY=5;OffsetX=5;' +
        'BackgroundColor=#a6caf0;BackgroundMarginWidth=5;OutlineColor=#000080;OutlineWidth=1'}]
});

An image after applying text watermark.

Image Watermarks

Usually a logo is used as an image watermark, however, it could be any picture. You can use all the general settings with image watermarks, but you have to specify the following three parameters, which are required for image watermarks:

  • ImageUrl specifies URL to an image that will be used as the watermark. You may specify either absolute or relative path.
  • Width sets width of the image that will be used as the watermark (in pixels).
  • Height sets height of the image that will be used as the watermark (in pixels).

Applying watermarks is rather easy, however, you should remember some things about this process:

  • You can use any images supported by Image Uploader as watermarks.
  • If the image watermarks are resized, they can only be downsized (if it is needed).

The following example adds watermark.png picture as a watermark to uploading images:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server" >
    <Converters>
        <aur:Converter Mode="*.*=Thumbnail"
           ThumbnailFitMode="Fit" ThumbnailWidth="320" ThumbnailHeight="240"
           ThumbnailWatermark="ImageUrl=watermark.png;Width=190;Height=60;Opacity=60;OffsetY=20" />
    </Converters>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=Thumbnail");
$converter->setThumbnailFitMode("Fit");
$converter->setThumbnailWidth(320);
$converter->setThumbnailHeight(240);
$converter->setThumbnailWatermark("ImageUrl=watermark.png;" .
    "Width=190;Height=60;Opacity=60;OffsetY=20");
$converters[] = $converter;

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    converters: [{mode: '*.*=Thumbnail',
        thumbnailWidth: 320,
        thumbnailHeight: 240,
        thumbnailFitMode: 'Fit',
        thumbnailWatermark: 'ImageUrl=watermark.png;Width=190;Height=60;Opacity=60;OffsetY=20'}]
});

A watermarked image.

Watermarking Original Images

In order to watermark original images you should:

  1. Create a Thumbnail converter.
  2. Set the Converter.ThumbnailFitMode to ActualSize.
  3. Configure text or image watermark for this converter as it is described in the sections above.

The following example shows how to add image watermark to original images:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server" >
    <Converters>
        <aur:Converter Mode="*.*=Thumbnail"
            ThumbnailFitMode="ActualSize"
            ThumbnailWatermark="ImageUrl=watermark.png;Width=190;Height=60;Opacity=60;OffsetY=20" />
    </Converters>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=Thumbnail");
$converter->setThumbnailFitMode("ActualSize");
$converter->setThumbnailWatermark("ImageUrl=watermark.png;" .
    "Width=190;Height=60;Opacity=60;OffsetY=20");
$converters[] = $converter;

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    converters: [{mode: '*.*=Thumbnail',
        thumbnailFitMode: 'ActualSize',
        thumbnailWatermark: 'ImageUrl=watermark.png;Width=190;Height=60;Opacity=60;OffsetY=20'}]
});

See Also

Reference

  • Converter Class
  • ThumbnailWatermark Property
  • Uploader Class

Manual

  • Uploading Images
  • Resizing and Recompressing
  • Working with EXIF and IPTC Metadata
  • Rotating and Cropping
  • ThumbnailWatermark (ASP.NET)
  • ThumbnailWatermark (PHP)
  • thumbnailWatermark (JavaScript)
  • ThumbnailFitMode (ASP.NET)
  • ThumbnailFitMode (PHP)
  • thumbnailFitMode (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • ThumbnailWatermark (ASP.NET)
  • ThumbnailWatermark (PHP)
  • thumbnailWatermark (JavaScript)
  • Uploader (ASP.NET)
  • Uploader (PHP)
  • uploader (JavaScript)


Working with EXIF and IPTC Metadata

Metadata is the additional data that image contains. Such information can be used, for example:

  • to provide higher results during printing
  • to get exact date and time of the image creation
  • to categorize images
  • to implement advanced image search

Image Uploader works with two metadata formats: EXIF and IPTC.

When an image is captured, the capturing device writes EXIF (Exchangeable Image File Format) information about the image into the captured file. EXIF fields may contain such information as camera parameters during capturing, date and time of the capturing, photographer's name, and etc. It can even contain GPS information. For more information about EXIF, please, see the EXIF Specification article.

IPTC (International Press Telecommunications Council) Information Interchange Model is widely used in journalism to keep such information as byline, subject, location, and etc. For more information about the IPTC format, please, see the IPTC Specification article.

Image Uploader supports the following metadata-related features:

  • Preserving EXIF and IPTC metadata while creating thumbnails can be extremely useful if you do not upload original files, but need to get all metadata embedded in the received thumbnails.
  • Extracting and uploading metadata allows you to specify metadata fields you want to get on the server. These fields will be extracted on the client side and sent along with other files and data. On the server side, you just retrieve them from the upload request, without writing a lot of non-trivial additional server code to extract metadata.
  • Automatic rotation based on EXIF metadata is useful if you want to get images in the orientation they were actually done.

Preserving EXIF and IPTC Metadata While Creating Thumbnails

Note

Image Uploader Express and Professional do not preserve EXIF metadata while creating thumbnails. See the Comparison of Image Uploader Editions topic for details.

You can make Image Uploader to send transformed (resized, rotated, cropped, watermarked, and etc) images. However, you may wonder what happens with EXIF and IPTC metadata when you perform imaging operations with Image Uploader. It is especially important when you process uploaded images with some specific software, e.g. for printing them at photo labs.

Fortunately, you can preserve EXIF and IPTC metadata using the ThumbnailCopyExif and ThumbnailCopyIptc properties of the Converter class. Just set the property to true and metadata of chosen type will be embedded in the corresponding thumbnail.

Default value of both discussing properties is false, this allows making uploaded thumbnails a bit smaller.

The following example configures the converter to create thumbnails with both types of metadata (EXIF and IPTC) preserved.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Converters>
        <aur:Converter Mode="*.*=Thumbnail"
           ThumbnailCopyExif="true"
           ThumbnailCopyIptc="true" />
    </Converters>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=Thumbnail");
$converter->setThumbnailCopyExif(true);
$converter->setThumbnailCopyIptc(true);
$converters[] = $converter;

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    converters: [{mode: '*.*=Thumbnail',
        thumbnailCopyExif: true,
        thumbnailCopyIptc: true}]
});

See Also

Reference

  • Converter Class
  • ThumbnailCopyExif Property
  • ThumbnailCopyIptc Property

Manual

  • Uploading Images
  • Uploading Additional Data in ASP.NET
  • Uploading Additional Data in PHP
  • Rotating and Cropping
  • Resizing and Recompressing
  • Applying Watermarks

Other Resources

  • EXIF Specification
  • IPTC Specification
  • extracting and uploading metadata in ASP.NET
  • extracting and uploading metadata in PHP
  • ThumbnailCopyExif (ASP.NET)
  • ThumbnailCopyExif (PHP)
  • thumbnailCopyExif (JavaScript)
  • ThumbnailCopyIptc (ASP.NET)
  • ThumbnailCopyIptc (PHP)
  • thumbnailCopyIptc (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • ThumbnailCopyExif (ASP.NET)
  • ThumbnailCopyExif (PHP)
  • thumbnailCopyExif (JavaScript)
  • ThumbnailCopyIptc (ASP.NET)
  • ThumbnailCopyIptc (PHP)
  • thumbnailCopyIptc (JavaScript)


Customizing User Interface

This section provides information about Image Uploader appearance customization. It touches upon such questions as look-and-feel modification, localization (i.e. GUI translation to various languages), and even performing deep user interface customization.

In This Section

Customizing Appearance
Localization
Using Image Uploader Installation Progress
Using Quality Meter


Customizing Appearance

The figures below demonstrate what elements of Image Uploader can be changed and what properties are responsible for the changes. If you click the property name, you will get to the reference description of this property.

  • Three Panes Layout
  • One Pane Layout
  • Image Editor
  • Thumbnails View
  • Quality Meter
  • Adding Files Dialog
  • Uploading Files Dialog
  • Instant Upload
  • Information Bar
  • Authentication Dialog
  • Delete File Dialog
  • Loading Content
  • Unix File System

Three Panes Layout

In three panes layout Image Uploader consists of the following panes:

  • Tree pane is the folder tree allowing a user to navigate their file system.
  • Folder pane displays the content of the currently selected folder.
  • Upload pane contains files ready to be uploaded.
Uploader.BackgroundColor Uploader.BorderStyle Uploader.BackgroundColor Uploader.PanelBorderColor Uploader.HeaderTextColor Uploader.HeaderColor Uploader.TextColor Uploader.AuxiliaryTextColor ContextMenu.OpenText ContextMenu.EditText ContextMenu.EditDescriptionText ContextMenu.RemoveText ContextMenu.UncheckText ContextMenu.CheckText Uploader.Height Uploader.Width UploadPane.DropFilesHereText UploadPane.DropFilesHereImageFormat DetailsViewColumns.LastModifiedText DetailsViewColumns.InfoText DetailsViewColumns.FileTypeText DetailsViewColumns.FileSizeText DetailsViewColumns.FileNameText DetailsViewColumns.DimensionsText FolderPane.HeaderAllowedText FolderPane.HeaderAllText FolderPane.Height FolderPane.FilterHintText TreePane.TitleText TreePane.Width

One Pane Layout

In one pane layout Image Uploader displays only the upload pane representing a list of files selected for upload.

PaneItem.SelectedTextColor Uploader.BorderStyle Uploader.BackgroundColor Uploader.HyperlinkColor Uploader.TextColor Uploader.AuxiliaryTextColor Uploader.Height Uploader.Width ContextMenu.PasteText ContextMenu.ListViewText ContextMenu.DetailsViewText ContextMenu.TilesViewText ContextMenu.ThumbnailsViewText ContextMenu.RemoveAllText ContextMenu.UncheckAllText ContextMenu.CheckAllText ContextMenu.ArrangeByTypeText ContextMenu.ArrangeByText ContextMenu.ArrangeBySizeText ContextMenu.ArrangeByPathText ContextMenu.ArrangeByNameText ContextMenu.ArrangeByModifiedText ContextMenu.ArrangeByDimensionsText DescriptionEditor.SaveButtonText DescriptionEditor.OrEscLabelText DescriptionEditor.CancelHyperlinkText StatusPane.Color StatusPane.ClearAllHyperlinkText StatusPane.NoFilesToUploadText StatusPane.FilesToUploadText Uploader.UploadButtonText Uploader.UploadButtonImageFormat Uploader.CancelUploadButtonText Uploader.CancelUploadButtonImageFormat

Image Editor

Image editor is intended to preview and edit images as well as attach text descriptions.

Uploader.PanelBorderColor Uploader.PanelColor Uploader.BackgroundColor Uploader.AuxiliaryTextColor ImageEditor.DescriptionHintText ImageEditor.SaveButtonText ImageEditor.SaveButtonImageFormat ImageEditor.RotateButtonText ImageEditor.RotateButtonImageFormat ImageEditor.CropButtonText ImageEditor.CropButtonImageFormat ImageEditor.CancelCropButtonText ImageEditor.CancelCropButtonImageFormat ImageEditor.CancelButtonText ImageEditor.CancelButtonImageFormat

Thumbnails View

Thumbnail view can be used in both the folder pane and upload panes and in both layouts.

UploadPane.PreviewSize FolderPane.PreviewSize PaneItem.SelectionHoverColor PaneItem.SelectionHoverBorderColor PaneItem.SelectionColor PaneItem.SelectionBorderColor PaneItem.RotationIconTooltip PaneItem.RotationIconImageFormat PaneItem.RemovalIconTooltip PaneItem.RemovalIconImageFormat PaneItem.InactiveSelectionColor PaneItem.InactiveSelectionBorderColor PaneItem.ImageEditorIconTooltip PaneItem.ImageEditorIconImageFormat PaneItem.ImageCroppedIconTooltip PaneItem.ImageCroppedIconImageFormat PaneItem.HoverColor PaneItem.HoverBorderColor PaneItem.DescriptionEditorIconTooltip PaneItem.DescriptionEditorIconImageFormat PaneItem.DescriptionAddedIconImageFormat

Quality Meter

Quality meter appears in the thumbnails view and indicates which formats can be used for printing certain images.

QualityMeter.LowQualityColor QualityMeter.HighQualityColor QualityMeter.Height QualityMeter.Formats QualityMeter.BorderColor QualityMeter.BackgroundColor QualityMeter.AcceptableQualityColor

Adding Files Dialog

This dialog is displayed when a user selects quite a lot of files.

Uploader.PanelColor Uploader.BackgroundColor Uploader.TextColor AddFilesProgressDialog.WaitText AddFilesProgressDialog.TotalFilesText AddFilesProgressDialog.TitleText AddFilesProgressDialog.CurrentFileText AddFilesProgressDialog.CancelButtonText

Uploading Files Dialog

This dialog appears during the upload. It consists of a progress bar and status information.

UploadProgressDialog.MegabytesText Uploader.PanelColor Uploader.BackgroundColor UploadProgressDialog.TitleText UploadProgressDialog.SecondsText UploadProgressDialog.MinutesText UploadProgressDialog.KilobytesText UploadProgressDialog.InfoText UploadProgressDialog.HoursText UploadProgressDialog.EstimationText UploadProgressDialog.CancelUploadButtonText

Instant Upload

In the instant upload mode Image Uploader starts the upload process right after a user has added files to the upload pane.

UploadProgressDialog.HideButtonText StatusPane.ProgressBarText

Information Bar

Information bar displays information, warning, and error messages.

FolderPane.FilterClearIconImageFormat InformationBar.CloseIconImageFormat Messages.UploadFailed Messages.UploadCompleted Messages.UploadCancelled Messages.UnexpectedError Messages.ServerNotFound Messages.NoResponseFromServer Messages.MaxTotalFileSizeExceeded Messages.MaxFileSizeExceeded Messages.MaxFileCountExceeded Messages.FilesNotAdded Messages.FileSizeTooSmall Messages.FileNameNotAllowed Messages.DimensionsTooSmall Messages.DimensionsTooLarge Messages.DeletingFilesError Messages.CmykImagesNotAllowed InformationBar.WarningColor InformationBar.MessageColor InformationBar.ErrorColor

Authentication Dialog

This dialog appears in non-Internet Explorer browsers when a user should enter their credentials.

AuthenticationDialog.Text AuthenticationDialog.RealmText AuthenticationDialog.PasswordText AuthenticationDialog.OkButtonText AuthenticationDialog.LoginText AuthenticationDialog.CancelButtonText

Delete File Dialog

This dialog that appears in non-Internet Explorer browsers and asks a user to confirm that they really want to delete uploaded files.

DeleteFilesDialog.TitleText DeleteFilesDialog.Message

Loading Content

These labels are displayed while Image Uploader scans the folder content and builds the file list.

Uploader.LoadingFolderContentText

Unix File System

The tree pane on *NIX operating systems is slightly different from the tree panes on other systems. For *NIX users, you can change text that labels the home directory and the root directory.

TreePane.UnixHomeDirectoryText TreePane.UnixFileSystemRootText


Localization

To make Image Uploader usage easier for non-English users, we provide a possibility to change all text that can ever be displayed by the control. Each text label, button caption, or error message can be changed using the appropriate class property.

Let us examine this opportunity by the example of solving the following tasks:

  • Simple translation of the interface into a single language.
  • Implementing multilingual interface.

Translating Interface into Single Language

This task implies that Image Uploader user interface is translated into a single language. Here you can use the following ways:

  1. Simply specify each property when initializing an Uploader object.
  2. Use predefined localizations shipped with Image Uploader SDK.
  3. Use your own localization scripts.

Translating Interface Manually

In the first case, necessary text properties with translation are added just like any other Image Uploader property. This way is the most suitable if you use default localization and want to modify some captions and messages.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server"
    CancelUploadButtonText="Stop"
    UploadButtonText="Send">
    <Messages CmykImagesNotAllowed="CMYK images are not allowed" />
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->setCancelUploadButtonText("Stop");
$uploader->setUploadButtonText("Send");
$uploader->getMessages()->setCmykImagesNotAllowed("CMYK images are not allowed");

JavaScript

var u = $au.uploader({
    cancelUploadButtonText: 'Stop',
    uploadButtonText: 'Send',
    messages:{
        cmykImagesNotAllowed: 'CMYK images are not allowed'
    }
});
Note

If you use the installation progress you should additionally localize the InstallationProgress properties. See details in the Using Image Uploader Installation Progress topic.

Using Predefined Localizations

The second way allows you to translate Image Uploader interface using just one line of code. All you need is to specify one of the available localizations via the Uploader.Language property. However, this property is supported only in Image Uploader ASP.NET and Image Uploader PHP.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server"
    Language="English">
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->setLanguage("en");

In Image Uploader JavaScript you should use aurigma.uploader.X_localization.js (where X is a language code) files which come with Image Uploader. These files are located in the /Scripts folder and contain all the text properties translated to the corresponding language. Thus, to translate Image Uploader interface, do the following:

  1. Link the aurigma.uploader.en_localization.js file with the page where you configure an uploader object.
  2. Pass the en_localization object defined in this file to the uploader.set(Object) method.

JavaScript

<script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
<script type="text/javascript" src="Scripts/aurigma.uploader.en_localization.js">  </script>
<script type="text/javascript">
var u = $au.uploader({
    // Image Uploader configuration
});
u.set(en_localization);
u.writeHtml();
</script>

You can use the aurigma.uploader.en_localization.js file as template to create your own localization script.

Using Custom Localization Scripts

As it was mentioned above, Image Uploader JavaScript comes with predefined localization scripts. Each script defines a JavaScript object containing all the Image Uploader text properties translated to a particular language. The same approach can be easily used to create your custom localization scripts.

Suppose, you want to translate Image Uploader user interface into German. Then you need to do the following:

  1. Create the aurigma.uploader.de_localization.js file in the /Scripts folder of your application (where the aurigma.uploader.js file resides).

    Note

    Localization file should be saved in UTF-8.

  2. Declare the de_localization object and add all the Image Uploader text properties.

    Here is a simplified example of this file:

    JavaScript

    var de_localization = {
    cancelUploadButtonText: 'Anhalten',
    uploadButtonText: 'Speichern',
    messages:{
        cmykImagesNotAllowed: 'CMYK-Bilder sind nicht erlaubt'
    }
};
  3. Link this file with the page where you configure an uploader object.

  4. Pass the de_localization object to the uploader.set(Object) method.

    Here is a simplified example of this file:

    JavaScript

    <script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
<script type="text/javascript" src="Scripts/aurigma.uploader.de_localization.js">  </script>
<script type="text/javascript">
var u = $au.uploader({
    // Image Uploader configuration
});
u.set(de_localization);
u.writeHtml();
</script>

The main advantage of this approach is that it allows you to keep Image Uploader text parameters separately from its configuration.

Implementing Multilingual Interface

The idea is the following: add a list of links containing available languages and translate Image Uploader GUI to the currently selected language. To implement this, insert links for languages you need. Each link should refer to the same page and add the lang parameter containing the selected language code. Then when the page is loading, just parse the lang parameter and configure Image Uploader to use the corresponding localization.

ASP.NET

<form id="form1" runat="server">
    <ul>
        <li>
            <asp:LinkButton ID="enLangLinkButton" runat="server" OnClick="langLinkButton_Click">
                English
            </asp:LinkButton>
        </li>
        <li>
            <asp:LinkButton ID="ruLangLinkButton" runat="server" OnClick="langLinkButton_Click">
                Russian
            </asp:LinkButton>
        </li>
    </ul>
    <aur:Uploader ID="Uploader1" runat="server" />
</form>

C#

protected void langLinkButton_Click(object sender, EventArgs e)
{
    if (sender == enLangLinkButton)
    {
        Uploader1.Language = Aurigma.ImageUploader.Language.English;
    }
    else if (sender == ruLangLinkButton)
    {
        Uploader1.Language = Aurigma.ImageUploader.Language.Russian;
    }
}

PHP

<ul>
    <li><a href="?lang=en" id="lang_en">English</a></li>
    <li><a href="?lang=ru" id="lang_ru">Russian</a></li>
</ul>
<?php
require_once "ImageUploaderPHP/Uploader.class.php";
$uploader = new Uploader('Uploader1');

// Set language
if (isset($_GET['lang'])) {
    switch ($_GET['lang']) {
        case 'en':
            $uploader->setLanguage('en');
            break;
        case 'ru':
            $uploader->setLanguage('ru');
            break;
    }
}

$uploader->render();
?>

JavaScript

<script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
<script type="text/javascript" src="Scripts/aurigma.uploader.en_localization.js">  </script>
<script type="text/javascript" src="Scripts/aurigma.uploader.ru_localization.js">  </script>
<ul>
    <li><a href="?lang=en" id="lang_en">English</a></li>
    <li><a href="?lang=ru" id="lang_ru">Russian</a></li>
</ul>
<script type="text/javascript">
var u = $au.uploader({
    id: 'Uploader1',
    // Image Uploader configuration
});

// Apply localization
var lang = /[?&]lang=(\w{2})/.exec(location.search || location.href);
if (lang) {
    lang = lang[1];
}

var langObject = window[lang + '_localization'];
if (langObject) {
    u.set(langObject);
}

u.writeHtml();
</script>

See Also

Reference

  • Uploader Class
  • InstallationProgress Class

Manual

  • Customizing Appearance
  • Using Image Uploader Installation Progress
  • InstallationProgress (ASP.NET)
  • InstallationProgress (PHP)
  • installationProgress (JavaScript)
  • Language (ASP.NET)
  • Language (PHP)
  • Uploader (ASP.NET)
  • Uploader (PHP)
  • uploader (JavaScript)
  • InstallationProgress (ASP.NET)
  • InstallationProgress (PHP)
  • installationProgress (JavaScript)


Using Image Uploader Installation Progress

Usually it takes some time to download and install Image Uploader. Moreover, users have to perform additional actions to complete the installation of the control, for instance, click the information bars and accept security warnings. It all may confuse users and they may consider Image Uploader as a security threat and cancel the installation. Because of this fact the add-on should display additional information while installation is in progress and provide users with instructions.

Image Uploader enables this functionality displaying special screens instead of the control during two major phases: downloading and installation. The downloading screen is displayed when Image Uploader is being downloaded from server to client; it contains a wait indicator, short descriptions, and the other instructions. The installation screen is displayed after Image Uploader is completely downloaded; it provides the instructions on how to install the add-on.

This functionality is implemented in the InstallationProgress class. It includes a number of properties intended to configure these screens. All the properties can be divided in two groups according to the stage they appear on, except for one property. The CommonHtml contains a HTML-marked description of Image Uploader displayed on both stages (downloading and installation). This description is intended to give users a brief explanation of what control is about to be installed.

Downloading Screen

This screen is useful in the case of slow Internet connection when downloading of Image Uploader may take long time. You can put a wait indicator here and tell users to be patient while Image Uploader is being loaded. You can use the following properties to configure this screen:

  • ShowDownloadingScreen specifies whether this screen should be displayed.
  • ProgressHtml specifies the text saying that the downloading of Image Uploader is in progress. Value defined in this property can contain {0} placeholder. Before displaying this screen, the placeholder is replaced with image URL defined in the ProgressImageUrl property (see the sample below). It allows you to customize images without changing HTML-marked text.
  • ProgressImageUrl specifies a custom image to display instead of default wait indicator (see description of ProgressHtml above for additional details).
  • BeforeIE6XPSP2ProgressHtml, IE6XPSP2ProgressHtml, IE7ProgressHtml, and IE8ProgressHtml specify downloading instructions depending on the browser type. Since different versions of browsers have different workflows of downloading add-ons you can use this set of properties to customize downloading instructions based on browser version Image Uploader is about to be installed on.
  • ProgressCssClass specifies a CSS class name to apply it to the downloading screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
ProgressImageUrl ProgressHtml IE8ProgressHtml IE7ProgressHtml IE6XPSP2ProgressHtml BeforeIE6XPSP2ProgressHtml CommonHtml

ASP.NET

<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="_Default" %>
<%@ Register assembly="Aurigma.ImageUploader" Namespace="Aurigma.ImageUploader" tagprefix="aur" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server">
    <title>Aurigma Image Uploader 7</title>
    <style type="text/css">.DownloadingScreenStyle {
        background-color:#ffffff;font-family:verdana;font-size:11px;padding:10px;text-align:center;
    }
    </style>
</head>
<body>
    <form id="form1" runat="server">
       <aur:Uploader runat="server" ID="Uploader1" />
       <aur:InstallationProgress runat="server" TargetControlID="Uploader1"
          ProgressHtml="&lt;p&gt;&lt;img src=\&quot;{0}\&quot; /&gt;&lt;br /&gt;Loading Aurigma Image Uploader...&lt;/p&gt;"
          ProgressImageUrl="mywaitIndicator.gif"
          ProgressCssClass="DownloadingScreenStyle" />
    </form>
</body>
</html>

PHP

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server">
    <title>Aurigma Image Uploader 7</title>
    <style type="text/css">.DownloadingScreenStyle {
        background-color:#ffffff;font-family:verdana;font-size:11px;padding:10px;text-align:center;
    }
    </style>
</head>
<body>
<?php
require_once "ImageUploaderPHP/Uploader.class.php";
require_once "ImageUploaderPHP/InstallationProgress.class.php";

$uploader = new Uploader("Uploader1");

$ip = new InstallationProgress($uploader);
$ip->setProgressHtml("<p><img src=\"{0}\" /><br />Loading Aurigma Image Uploader...</p>");
$ip->setProgressImageUrl("mywaitIndicator.gif");
$ip->setProgressCssClass("DownloadingScreenStyle");

$uploader->render();
?>
</body>
</html>

JavaScript

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <title>Aurigma Image Uploader 7</title>
        <script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
        <script type="text/javascript" src="Scripts/aurigma.uploader.installationprogress.js">  </script>
        <style type="text/css">.DownloadingScreenStyle {
            background-color:#ffffff;font-family:verdana;font-size:11px;padding:10px;text-align:center;
            }
        </style>
    </head>
    <body>
        <script type="text/javascript">
        var u = $au.uploader({id: 'Uploader1',
            width: '640', height: '480',
            // other params
        });
        var ip = $au.installationProgress(u);
        ip.progressHtml('<p><img src=\"{0}\" /><br />Loading Aurigma Image Uploader...</p>');
        ip.progressImageUrl('mywaitIndicator.gif');
        ip.progressCssClass('DownloadingScreenStyle');
        u.writeHtml();
        </script>
    </body>
</html>

Installation Screen

Installation phase starts after Image Uploader is completely downloaded. In the case of installation in Internet Explorer, the corresponded screen is shown when the security warning is about to be displayed. Thus, you can use it to provide users with the instructions on how to install the add-on or describe an alternative way (e.g. use a standalone installer) in the case if there are installation problems. As for non-Internet Explorer browsers, Image Uploader starts as soon as it is loaded. However, if it fails during the installation (JRE 1.5 is not installed or Java applets are disabled in a browser) this screen appears to provide users with instructions on how to setup Java and turn it on. The following properties can be used to configure this screen:

  • ShowInstallationScreen specifies whether this screen should be displayed.
  • BeforeIE6XPSP2InstructionsHtml, IE6XPSP2InstructionsHtml, IE7InstructionsHtml, and IE8InstructionsHtml specify installation instructions depending on the browser type. Since different versions of browsers have different workflows of installing add-ons you can use this set of properties to customize installation instructions based on browser version Image Uploader is about to be installed on.
  • InstallJavaHtml and MacInstallJavaHtml specify instructions on how to install Java depending on used platform.
  • AltInstallerHtml specifies a HTML-marked text appended to installation instructions in the case when Image Uploader is being installed in Internet Explorer (see the sample below).
  • UpdateInstructions specifies common instructions on how to update Image Uploader in Internet Explorer. This property appears if an earlier version of the control is already installed on the client machine and needed to be updated.
  • InstructionsCssClass specifies a CSS class name to apply it to the installation screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
InstallJavaHtml UpdateInstructions AltInstallerHtml IE8InstructionsHtml IE7InstructionsHtml IE6XPSP2InstructionsHtml BeforeIE6XPSP2InstructionsHtml CommonHtml MacInstallJavaHtml

ASP.NET

<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="_Default" %>
<%@ Register assembly="Aurigma.ImageUploader" Namespace="Aurigma.ImageUploader" tagprefix="aur" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server">
    <title>Aurigma Image Uploader 7</title>
    <style type="text/css">.InstallationScreenStyle {
        background-color:#ffffff;font-family:verdana;font-size:11px;padding:10px;text-align:center;
    }
    </style>
</head>
<body>
    <form id="form1" runat="server">
       <aur:Uploader runat="server" ID="Uploader1" />
       <aur:InstallationProgress runat="server" TargetControlID="Uploader1"
          AltInstallerHtml="&lt;p&gt;You can also download &lt;a href=&quot;http://mysite.com/standaloneInstaller/&quot;&gt;
            standalone installator&lt;/a&gt;.&lt;/p&gt;"
          InstructionsCssClass="InstallationScreenStyle" />
    </form>
</body>
</html>

PHP

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server">
    <title>Aurigma Image Uploader 7</title>
    <style type="text/css">.InstallationScreenStyle {
        background-color:#ffffff;font-family:verdana;font-size:11px;padding:10px;text-align:center;
    }
    </style>
</head>
<body>
<?php
require_once "ImageUploaderPHP/Uploader.class.php";
require_once "ImageUploaderPHP/InstallationProgress.class.php";

$uploader = new Uploader("Uploader1");

$ip = new InstallationProgress($uploader);
$ip->setAltInstallerHtml("<p>You can also download <a href=\"http://mysite.com/standaloneInstaller/\">
   standalone installator</a>.</p>");
$ip->setInstructionsCssClass("InstallationScreenStyle");

$uploader->render();
?>
</body>
</html>

JavaScript

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <title>Aurigma Image Uploader 7</title>
        <script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
        <script type="text/javascript" src="Scripts/aurigma.uploader.installationprogress.js">  </script>
        <style type="text/css">.InstallationScreenStyle {
            background-color:#ffffff;font-family:verdana;font-size:11px;padding:10px;text-align:center;
            }
        </style>
    </head>
    <body>
        <script type="text/javascript">
        var u = $au.uploader({id: 'Uploader1',
            width: '640', height: '480',
            // other params
        });
        var ip = $au.installationProgress(u);
        ip.altInstallerHtml('<p>You can also download <a href="http://mysite.com/standaloneInstaller/">'
            + 'standalone installator</a>.</p>');
        ip.instructionsCssClass('InstallationScreenStyle');
        u.writeHtml();
        </script>
    </body>
</html>

See Also

Reference

  • InstallationProgress Class

Manual

  • Quick Start with Image Uploader ASP.NET
  • Quick Start with Image Uploader PHP
  • Quick Start with Image Uploader JavaScript
  • InstallationProgress (ASP.NET)
  • InstallationProgress (PHP)
  • installationProgress (JavaScript)
  • CommonHtml (ASP.NET)
  • CommonHtml (PHP)
  • commonHtml (JavaScript)
  • ShowDownloadingScreen (ASP.NET)
  • ShowDownloadingScreen (PHP)
  • showDownloadingScreen (JavaScript)
  • ProgressHtml (ASP.NET)
  • ProgressHtml (PHP)
  • progressHtml (JavaScript)
  • ProgressImageUrl (ASP.NET)
  • ProgressImageUrl (PHP)
  • progressImageUrl (JavaScript)
  • ProgressImageUrl (ASP.NET)
  • ProgressImageUrl (PHP)
  • progressImageUrl (JavaScript)
  • ProgressHtml (ASP.NET)
  • ProgressHtml (PHP)
  • progressHtml (JavaScript)
  • BeforeIE6XPSP2ProgressHtml (ASP.NET)
  • BeforeIE6XPSP2ProgressHtml (PHP)
  • beforeIE6XPSP2ProgressHtml (JavaScript)
  • IE6XPSP2ProgressHtml (ASP.NET)
  • IE6XPSP2ProgressHtml (PHP)
  • IE6XPSP2ProgressHtml (JavaScript)
  • IE7ProgressHtml (ASP.NET)
  • IE7ProgressHtml (PHP)
  • IE7ProgressHtml (JavaScript)
  • IE8ProgressHtml (ASP.NET)
  • IE8ProgressHtml (PHP)
  • IE8ProgressHtml (JavaScript)
  • ProgressCssClass (ASP.NET)
  • ProgressCssClass (PHP)
  • progressCssClass (JavaScript)
  • ShowInstallationScreen (ASP.NET)
  • ShowInstallationScreen (PHP)
  • showInstallationScreen (JavaScript)
  • BeforeIE6XPSP2InstructionsHtml (ASP.NET)
  • BeforeIE6XPSP2InstructionsHtml (PHP)
  • beforeIE6XPSP2InstructionsHtml (JavaScript)
  • IE6XPSP2InstructionsHtml (ASP.NET)
  • IE6XPSP2InstructionsHtml (PHP)
  • IE6XPSP2InstructionsHtml (JavaScript)
  • IE7InstructionsHtml (ASP.NET)
  • IE7InstructionsHtml (PHP)
  • IE7InstructionsHtml (JavaScript)
  • IE8InstructionsHtml (ASP.NET)
  • IE8InstructionsHtml (PHP)
  • IE8InstructionsHtml (JavaScript)
  • InstallJavaHtml (ASP.NET)
  • InstallJavaHtml (PHP)
  • installJavaHtml (JavaScript)
  • MacInstallJavaHtml (ASP.NET)
  • MacInstallJavaHtml (PHP)
  • macInstallJavaHtml (JavaScript)
  • AltInstallerHtml (ASP.NET)
  • AltInstallerHtml (PHP)
  • altInstallerHtml (JavaScript)
  • UpdateInstructions (ASP.NET)
  • UpdateInstructions (PHP)
  • updateInstructions (JavaScript)
  • InstructionsCssClass (ASP.NET)
  • InstructionsCssClass (PHP)
  • instructionsCssClass (JavaScript)
  • InstallationProgress (ASP.NET)
  • InstallationProgress (PHP)
  • installationProgress (JavaScript)


Using Quality Meter

Image Uploader is commonly used for ordering digital photo prints through the web. Usually printing companies allow ordering photo prints in different print formats (e.g. 4 x 6 inches, 5 x 7 inches, etc). The larger the print format is selected, the larger image dimensions should be to get the acceptable quality. However, users (especially inexperienced ones) often do not have an idea what dimensions the image has and whether it can be printed in some format with the good enough quality. To indicate which formats can be used for printing certain images, Image Uploader allows displaying a so-called quality meter.

Note

Image Uploader Express and Professional disable quality meter functionality. See the Comparison of Image Uploader Editions topic for details.

The quality meter is represented with several color rectangles (see the figure below). Each rectangle corresponds to one print format. There are three color values: for formats that can be printed with high quality; for formats that can be printed with the acceptable quality, but with a lower resolution; and for formats that are too large for this image (the quality of the printed image in this format will be too low). On this screenshot the "good" formats are green, the acceptable formats are yellow, and the "bad" formats are grey.

QualityMeter.LowQualityColor QualityMeter.HighQualityColor QualityMeter.Height QualityMeter.Formats QualityMeter.BorderColor QualityMeter.BackgroundColor QualityMeter.AcceptableQualityColor

To turn the quality meter on you should configure a QualityMeter object and pass it to the PaneItem.QualityMeter property.

The mandatory property is Formats. If it is not set or have an incorrect value, the quality meter will not be displayed. Each format is represented with four values separated by a comma: name, maximum format size (in pixels), minimum format size (in pixels), and acceptable format ratio. The formats are separated by a semicolon. Here is an example:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <PaneItem>
        <QualityMeter Formats="4x6 inches,1800,1200,1.2;6x8 inches,2400,1800,1.25" />
    </PaneItem>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getPaneItem()->getQualityMeter()->setFormats("4x6 inches,1800,1200,1.2;6x8 inches,2400,1800,1.25");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    paneItem: {
        qualityMeter: {
            formats: '4x6 inches,1800,1200,1.2;6x8 inches,2400,1800,1.25'
        }
    }
});

This string describes two formats: 4 x 6 inches and 6 x 8 inches (assuming that we print with the resolution that is equal to 300 DPI). Let us review a quad describing the print format in more details. We will take 4 x 6 inches format as an example:

  • The name is 4 x 6 inches. It will be displayed as a tooltip when the mouse pointer hovers over this quality meter element.
  • The maximum format size in pixels is 1800. For the landscape orientation this will be the width, for the portrait orientation this will be the height. It is calculated in the following way: we simply multiply the number of required inches by the resolution your printer can handle. In our case it is 6 inches * 300 DPI = 1800 pixels.
  • The minimum format size in pixels is 1200. It is defined by analogy with the maximum format size: for the landscape orientation it will be the height, for the portrait orientation it will be the width. It is calculated in the similar way: 4 inches * 300 DPI = 1200 pixels.
  • The acceptable format ratio (further AR) is 1.2. This parameter is required when the image dimensions are less than the values specified with two previous parameters (print format dimensions). The AR is used to determine if the image can be printed with the acceptable quality or not. It works in the following way: we get a ratio between the print format dimension and the image dimension, and if this ratio is less than the AR, quality is acceptable, otherwise, printing in this format is not recommended. For example, for an image of size 1600 x 1066 calculations will be the following: 1800/1600 = 1.125 (the same is for height). The AR is 1.2. It means that we can mark this image as acceptable. If we take a 1024 x 768 image, we will find out that 1800/1024 = 1.7578125 and it is more than the AR. Thus, such an image should be marked as too small.

If the print format is good for the image, the appropriate quality meter element is filled with the color specified by the HighQualityColor property. Acceptable print formats are filled with AcceptableQualityColor. Non-recommended print formats are defined by the LowQualityColor property. You can also change the color of the border (the BorderColor property) and the background (the BackgroundColor property). The screenshot above demonstrates these settings.

Note

When customizing your quality meter, you may also specify its height using the Height property. Image Uploader will not let the quality meter overlay other controls, if you provide too large value for this property, so your layout will not be spoilt.

You may wonder why AR can be different for each format. The point is that the larger image you print, the less resolution you may use. It is related to the fact that larger prints are mostly used to be viewed at a long distance (e.g. they are hung on the wall) whereas small pictures are viewed at a short distance (e.g. in a photo album). When someone looks at the picture at a distance, they usually do not notice small details, and, therefore, there is no need to print the image with the same high resolution as smaller pictures.

This enables you to increase the AR for larger formats. For example, if for 4 x 6 inches format this it is 1.2 (in other words, the image can be 20% smaller than required and in this case it will be printed with 240 DPI instead of 300), for 20 x 30 inches you can freely set the AR = 1.5 (i.e. if the image will be 50% smaller than necessary, you still can print it with 150 DPI).

Note

All AR values in this article are approximate. You should select your own AR for each format according to capabilities of your printing machine and the quality standards accepted in your company.

Finally, let us see a simple code sample that defines a quality meter for the following formats:

  • 4 x 6"
  • 5 x 7"
  • 8 x 10"
  • 16 x 20"
  • 20 x 30"

You can also display a legend so that users could easily understand in what formats they can order their prints, but you will have to write HTML code for the legend yourself. The result may look similar to the picture below.

Format | Acceptable DPI | Recommended DPI | Acceptable Dimensions | Recommended Dimensions | Acceptable Ratio
4 x 6" | 200 | 300 | 1200 x 800 | 1800 x 1200 | 1.5
5 x 7" | 200 | 300 | 1400 x 1000 | 2100 x 1500 | 1.5
8 x 10" | 200 | 300 | 2000 x 1600 | 3000 x 2400 | 1.5
16 x 20" | 100 | 200 | 2000 x 1600 | 4000 x 3200 | 2
20 x 30" | 100 | 200 | 3000 x 2000 | 6000 x 4000 | 2

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <PaneItem>
        <QualityMeter Formats="4 x 6,1800,1200,1.5;5 x 7,2100,1500,1.5;
            8 x 10,3000,2400,1.5;16 x 20,4000,3200,2;30 x 20,6000,4000,2" />
    </PaneItem>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getPaneItem()->getQualityMeter()->setFormats("4 x 6,1800,1200,1.5;5 x 7,2100,1500,1.5;
    8 x 10,3000,2400,1.5;16 x 20,4000,3200,2;30 x 20,6000,4000,2");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    paneItem: {
        qualityMeter: {
            formats: '4 x 6,1800,1200,1.5;5 x 7,2100,1500,1.5;' +
                '8 x 10,3000,2400,1.5;16 x 20,4000,3200,2;30 x 20,6000,4000,2'
        }
    }
});

See Also

Reference

  • QualityMeter Class

Manual

  • Customizing Appearance
  • Additional Controls and Indicators
  • Setting Limitations for Images
  • QualityMeter (ASP.NET)
  • QualityMeter (PHP)
  • qualityMeter (JavaScript)
  • QualityMeter (ASP.NET)
  • QualityMeter (PHP)
  • qualityMeter (JavaScript)
  • Formats (ASP.NET)
  • Formats (PHP)
  • formats (JavaScript)
  • HighQualityColor (ASP.NET)
  • HighQualityColor (PHP)
  • highQualityColor (JavaScript)
  • AcceptableQualityColor (ASP.NET)
  • AcceptableQualityColor (PHP)
  • acceptableQualityColor (JavaScript)
  • LowQualityColor (ASP.NET)
  • LowQualityColor (PHP)
  • lowQualityColor (JavaScript)
  • BorderColor (ASP.NET)
  • BorderColor (PHP)
  • borderColor (JavaScript)
  • BackgroundColor (ASP.NET)
  • BackgroundColor (PHP)
  • backgroundColor (JavaScript)
  • Height (ASP.NET)
  • Height (PHP)
  • height (JavaScript)
  • QualityMeter (ASP.NET)
  • QualityMeter (PHP)
  • qualityMeter (JavaScript)


Configuring Restriction Rules for Files

This section contains information on the applying of various restrictions, such as:

  • filtering files by names and types
  • setting limitations for image dimensions or disabling CMYK images
  • setting limitations for single file size, number of uploaded files and total upload size

to the files that are selecting for the upload to your server. These restriction rules can be specified using the Restrictions class.

Note

All the limitations specified with Restrictions are checked client-side, so you should not interpret them as a reliable protection. A potentially malicious user can bypass all these limitations (by emulating Image Uploader). That is why it is highly recommended to implement server-side verification of uploaded files in addition to Restrictions properties.

In other words, all the limitation features discussed in this topic should be used solely for the convenience of the user. They should not be interpreted as a serious protection measure from malicious users.

In This Section

Filtering Files by Names and Types
Setting Limitations for Images
Setting Limitations for Size and Number of Files

  • Restrictions (ASP.NET)
  • Restrictions (PHP)
  • restrictions (JavaScript)
  • Restrictions (ASP.NET)
  • Restrictions (PHP)
  • restrictions (JavaScript)
  • Restrictions (ASP.NET)
  • Restrictions (PHP)
  • restrictions (JavaScript)


Filtering Files by Names and Types

Usually it makes sense to allow uploading only certain kinds of files. For example, if you use Image Uploader to:

  • gather photo print orders, you would prefer to show only JPEG files
  • upload web graphics, you would show GIF and PNG files as well
  • send documents to a storage, you would disable all the images and allow uploading only PDF files

This topic describes how to manage file type restrictions in Image Uploader.

To specify file type limitations, use the Restrictions.FileMask and Restrictions.DeniedFileMask properties. The first one specifies a file mask that designates which files should be visible in Image Uploader. The second property specifies a file mask for the files that are denied to be displayed.

Both properties support the following wildcards:

  • asterisk (*) for arbitrary substring
  • question mark (?) for single arbitrary character

Several masks can be specified. Use a semicolon to separate them.

Here are few examples of file masks:

  • *.jpg for files which have the .jpg extension (most JPEG files)
  • *.* for all the files which have any extension
  • *.doc;*.xls for files which have either .doc or .xls extension (Microsoft Office files)
  • *.mp? for most MPEG audio files (.mp3, .mp2, .mpa, .mp+ and etc)

Although Image Uploader does not show "wrong" files by default, users can see them after clicking Total files. The denied files cannot be selected, so they have no checkboxes near them. If, however, a user tries to add such files to upload list, Image Uploader displays an error message saying why this file is denied. Additionally, each denied file is equipped with a tooltip containing the same error message text. This text can be customized using the Messages.FileNameNotAllowed property.

Important

The Restrictions.FileMask and Restrictions.DeniedFileMask properties allow infiltrating files only by their names. But it cannot guarantee that files, say, with the .jpg extension are JPEG files indeed. Malicious user can rename executable files to .jpg and upload them as if they are images. That is why if an application Image Uploader is integrated with has increased security requirements, it is highly recommended to verify uploaded files on the server side.

Another reason for it is that a potential hacker can always emulate Image Uploader using <input type="file">. It will enable them to bypass Image Uploader and upload dangerous files. So the file mask filter never gives a 100% guarantee that only proper files are uploaded.

In other words, the Restrictions.FileMask and Restrictions.DeniedFileMask properties can be used only for the user convenience. It should not be interpreted as a serious protection from malicious users.

The code samples below demonstrate four different filters.

Allow Images Only

This example shows how to allow only images with .jpg, .jpeg, .png, .gif, .bmp extensions.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Restrictions FileMask="*.jpg;*.jpeg;*.png;*.gif;*.bmp"/>
    <Messages FilenameNotAllowed="You can add only images."/>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getRestrictions()->setFileMask("*.jpg;*.jpeg;*.png;*.gif;*.bmp");
$uploader->getMessages()->setFileNameNotAllowed("You can add only images.");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    restrictions: {fileMask: '*.jpg;*.jpeg;*.png;*.gif;*.bmp'},
    messages: {fileNameNotAllowed: 'You can add only images.'}
});

Allow Documents Only

The code below makes visible documents of following types: .txt, .rtf, .pdf, .doc, .docx, .xls, .xlsx.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Restrictions FileMask="*.txt;*.rtf;*.pdf;*.doc;*.docx;*.xls;*.xlsx"/>
    <Messages FilenameNotAllowed="You can add only documents."/>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getRestrictions()->setFileMask("*.txt;*.rtf;*.pdf;*.doc;*.docx;*.xls;*.xlsx");
$uploader->getMessages()->setFileNameNotAllowed("You can add only documents.");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    restrictions: {fileMask: '*.txt;*.rtf;*.pdf;*.doc;*.docx;*.xls;*.xlsx'},
    messages: {fileNameNotAllowed: 'You can add only documents.'}
});

Deny Executable Files

This example disables executable files via the Restrictions.DeniedFileMask property.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Restrictions DeniedFileMask="*.exe;*.bat;*.cmd;*.wsf"/>
    <Messages FilenameNotAllowed="You are not allowed to add executable files."/>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getRestrictions()->setDeniedFileMask("*.exe;*.bat;*.cmd;*.wsf");
$uploader->getMessages()->setFileNameNotAllowed("You are not allowed to add executable files.");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    restrictions: {deniedFileMask: '*.exe;*.bat;*.cmd;*.wsf'},
    messages: {fileNameNotAllowed: 'You are not allowed to add executable files.'}
});

Allow MPEG Files Only

The last example shows how to use a question mark (?) in files masks. Here Image Uploader allows selecting files like .mp3, .mp2, .mp+ and etc. This mask could be useful for allowing MPEG audio files only.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Restrictions FileMask="*.mp?"/>
    <Messages FilenameNotAllowed="You can add only MPEG audio files."/>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getRestrictions()->setFileMask("*.mp?");
$uploader->getMessages()->setFileNameNotAllowed("You can add only MPEG audio files.");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    restrictions: {fileMask: '*.mp?'},
    messages: {fileNameNotAllowed: 'You can add only MPEG audio files.'}
});

See Also

Reference

  • Restrictions Class
  • Messages Class

Manual

  • Setting Limitations for Images
  • Setting Limitations for Size and Number of Files
  • FileMask (ASP.NET)
  • FileMask (PHP)
  • fileMask (JavaScript)
  • DeniedFileMask (ASP.NET)
  • DeniedFileMask (PHP)
  • deniedFileMask (JavaScript)
  • FileNameNotAllowed (ASP.NET)
  • FileNameNotAllowed (PHP)
  • fileNameNotAllowed (JavaScript)
  • FileMask (ASP.NET)
  • FileMask (PHP)
  • fileMask (JavaScript)
  • DeniedFileMask (ASP.NET)
  • DeniedFileMask (PHP)
  • deniedFileMask (JavaScript)
  • FileMask (ASP.NET)
  • FileMask (PHP)
  • fileMask (JavaScript)
  • DeniedFileMask (ASP.NET)
  • DeniedFileMask (PHP)
  • deniedFileMask (JavaScript)
  • DeniedFileMask (ASP.NET)
  • DeniedFileMask (PHP)
  • deniedFileMask (JavaScript)
  • Restrictions (ASP.NET)
  • Restrictions (PHP)
  • restrictions (JavaScript)
  • Messages (ASP.NET)
  • Messages (PHP)
  • messages (JavaScript)


Setting Limitations for Images

When you use Image Uploader to upload images (rather than common files) to your web site, you may wish to limit dimensions or color model of these images; for example:

  • If you take photo print orders, you may want to cut off the files that are too small (which are smaller than, say, 640 x 480) and perhaps disable CMYK images.
  • If you provide photo blog hosting, typically it makes no sense to accept the files that are too large (which are larger than, say, 800 x 600).

Restricting Image Dimensions

To restrict dimensions the Restrictions class exposes the following properties:

  • MinImageWidth and MinImageHeight specify minimum allowed image dimensions (in pixels).
  • MaxImageWidth and MaxImageHeight specify maximum allowed image dimensions (in pixels).
Note

You may want to resize the images which are too large instead of prohibiting them. See the Resizing and Recompressing topic for more details on this.

Image Uploader does not show "wrong" images by default, but users can see them after clicking Total files. The denied images cannot be selected, so they have no checkboxes near them. If, however, a user tries to add such images to upload list, Image Uploader displays an error message saying why this image is denied. Additionally, each denied image is equipped with a tooltip containing the same error message text. This text can be customized using the Messages.DimensionsTooLarge and Messages.DimensionsTooSmall properties.

Both these properties should be set to 0 when no image dimension limitations are required.

In the following example only images smaller then 800 x 600 are allowed:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Restrictions MaxImageHeight="600" MaxImageWidth="800"/>
    <Messages DimensionsTooLarge="Image is too large, it should be smaller than 800x600 pixels."/>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getRestrictions()->setMaxImageHeight(600);
$uploader->getRestrictions()->setMaxImageWidth(800);
$uploader->getMessages()->setDimensionsTooLarge("Image is too large, it should be smaller than 800x600 pixels.");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    restrictions: {maxImageHeight: 600, maxImageWidth: 800},
    messages: {dimensionsTooLarge: 'Image is too large, it should be smaller than 800x600 pixels.'}
});

Disabling CMYK Images

To forbid your users to upload CMYK images set the Restrictions.EnableCmyk property to false. In that case Image Uploader does not display CMYK images until a user clicks Total files. Even so, such files still cannot be selected: they have no checkboxes near them and Image Uploader displays an error message saying that CMYK images are disabled whenever a user tries to add it to the upload list. Additionally, each CMYK image is equipped with a tooltip containing the same error message text. This text can be customized using the Messages.CmykImagesNotAllowed property.

Example below shows how to deny CMYK images:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Restrictions EnableCmyk="False" />
    <Messages CmykImagesNotAllowed="CMYK images are not allowed." />
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getRestrictions()->setEnableCmyk(false);
$uploader->getMessages()->setCmykImagesNotAllowed("CMYK images are not allowed.");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    restrictions: {enableCmyk: false},
    messages: {cmykImagesNotAllowed: 'CMYK images are not allowed.'}
});
Important

As limitations specified in Image Uploader are checked only on the client side, you should not interpret them as a reliable protection. A potential malicious user can bypass all these limitations (by emulating Image Uploader or modifying its parameters in a local copy of a page). That's why it is highly recommended to implement server-side verification of uploaded files in addition to Image Uploader file tests.

In other words, all the limitation features discussed in this article should be used solely for the convenience of the user. They should not be interpreted as a serious protection from malicious users.

See Also

Reference

  • Restrictions Class
  • Messages Class

Manual

  • Filtering Files by Names and Types
  • Setting Limitations for Size and Number of Files
  • Restrictions (ASP.NET)
  • Restrictions (PHP)
  • restrictions (JavaScript)
  • MinImageWidth (ASP.NET)
  • MinImageWidth (PHP)
  • minImageWidth (JavaScript)
  • MinImageHeight (ASP.NET)
  • MinImageHeight (PHP)
  • minImageHeight (JavaScript)
  • MaxImageWidth (ASP.NET)
  • MaxImageWidth (PHP)
  • maxImageWidth (JavaScript)
  • MaxImageHeight (ASP.NET)
  • MaxImageHeight (PHP)
  • maxImageHeight (JavaScript)
  • DimensionsTooLarge (ASP.NET)
  • DimensionsTooLarge (PHP)
  • dimensionsTooLarge (JavaScript)
  • DimensionsTooSmall (ASP.NET)
  • DimensionsTooSmall (PHP)
  • dimensionsTooSmall (JavaScript)
  • EnableCmyk (ASP.NET)
  • EnableCmyk (PHP)
  • enableCmyk (JavaScript)
  • CmykImagesNotAllowed (ASP.NET)
  • CmykImagesNotAllowed (PHP)
  • cmykImagesNotAllowed (JavaScript)
  • Restrictions (ASP.NET)
  • Restrictions (PHP)
  • restrictions (JavaScript)
  • Messages (ASP.NET)
  • Messages (PHP)
  • messages (JavaScript)


Setting Limitations for Size and Number of Files

Image Uploader allows not only filtering files by type, or limiting images but also limiting size and count of files. It is extremely useful when you:

  • want to allocate limited space on your server for users
  • provide file hosting service, which does not allow uploading of large files

Restricting Number of Files for Upload

Note

Image Uploader Express restricts the maximum number of user-selected files to 100. See the Comparison of Image Uploader Editions topic for details.

To limit the maximum and minimum number of files allowed for the upload in a single upload session, use the Restrictions.MaxFileCount and Restrictions.MinFileCount properties respectively. If a user selects more files than specified by the Restrictions.MaxFileCount property, an error message (which can be customized using the Messages.MaxFileCountExceeded property) appears. If a user selects fewer files than the Restrictions.MinFileCount property value, the Upload button is disabled and files cannot be uploaded.

To remove both limitations, set Restrictions.MaxFileCount to 0 and Restrictions.MinFileCount to 1.

This example shows how to limit number of files from 3 to 10:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Restrictions  MinFileCount="3" MaxFileCount="10"/>
    <Messages MaxFileCountExceeded="You can add not more than 10 files."/>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getRestrictions()->setMinFileCount(3);
$uploader->getRestrictions()->setMaxFileCount(10);
$uploader->getMessages()->setMaxFileCountExceeded("You can add not more than 10 files.");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    restrictions: {minFileCount: 3, maxFileCount: 10},
    messages: {maxFileCountExceeded: 'You can add not more than 10 files.'}
});

Restricting Upload Size

To set a limit on a total size of files selected for the upload, Image Uploader exposes the Restrictions.MaxTotalFileSize property. When the sum of selected file sizes exceeds this value, an error specified with the Messages.MaxTotalFileSizeExceeded property is displayed.

If you do not need to restrict the total file size, set Restrictions.MaxTotalFileSize to 0.

This limitation is applied to sizes of original files only. It does not take into account sizes of files created by Image Uploader from original ones (downsized copies of images, associated icons, compressed ZIP files) because there is no way to know their sizes before upload process starts. Therefore, the amount of actually uploaded bytes may noticeably differ from this value. So the Restrictions.MaxTotalFileSize property is useful when you upload original files without applying any client-side file transformations. Otherwise, if it is important to limit the POST request size, the only way is to configure maximum acceptable POST request length in the server settings.

This example shows how to limit upload size to 100 Mb:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Restrictions MaxTotalFileSize="104857600" />
    <Messages MaxTotalFileSizeExceeded="You are not allowed for uploading more than 100 MB."/>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getRestrictions()->setMaxTotalFileSize(104857600);
$uploader->getMessages()->setMaxTotalFileSizeExceeded("You are not allowed for uploading more than 100 MB.");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    restrictions: {maxTotalFileSize: 104857600},
    messages: {maxTotalFileSizeExceeded: 'You are not allowed for uploading more than 100 MB.'},
});

Restricting Single File Size

Note

Image Uploader Express restricts the maximum size of each user-selected file to 100 Mb. Image Uploader Professional and Print restrict the maximum size of each user-selected file to 2 Gb. See the Comparison of Image Uploader Editions topic for details.

You can set a limitation not only for total size of the files selected for the upload, but also for a single file size. Both lower and upper limitations can be specified via the Restrictions.MinFileSize and Restrictions.MaxFileSize properties respectively. Too large or too small files cannot be selected, so they are invisible by default. Even if a user clicks Total files and tries to add such files to the upload list, Image Uploader displays an error message specified with the Messages.FileSizeTooSmall or Messages.MaxFileSizeExceeded property. Additionally, each inappropriate file is equipped with a tooltip containing the same error message text.

Both these properties should be set to 0 when no file size limitations are required.

In the following example files smaller than 200 Kb or larger than 2 Mb are denied:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Restrictions MinFileSize="204800" MaxFileSize="2097152" />
    <Messages FileSizeTooSmall="File is too small. You can add files not smaller than 200 KB."
        MaxFileSizeExceeded="File is too large. You can add files not larger than 2 MB."/>
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
$uploader->getRestrictions()->setMinFileSize(204800);
$uploader->getRestrictions()->setMaxFileSize(2097152);
$uploader->getMessages()->setFileSizeTooSmall("File is too small. You can add files not smaller than 200 KB.");
$uploader->getMessages()->setMaxFileSizeExceeded("File is too large. You can add files not larger than 2 MB.");

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    restrictions: {minFileSize: 204800, maxFileSize: 2097152},
    messages: {fileSizeTooSmall: 'File is too small. You can add files not smaller than 200 KB.',
               maxFileSizeExceeded: 'File is too large. You can add files not larger than 2 MB.'}
});
Important

As limitations specified in Image Uploader are checked only on the client side, you should not interpret them as a reliable protection. A potential malicious user can bypass all these limitations (by emulating Image Uploader or modifying its parameters in a local copy of a page). That is why it is highly recommended to implement server-side verification of uploaded files in addition to Image Uploader file tests.

In other words, all limitation features discussed in this topic should be used solely for the convenience of the user. They should not be interpreted as a serious protection from malicious users.

See Also

Reference

  • Restrictions Class
  • Messages Class

Manual

  • Setting Limitations for Images
  • Filtering Files by Names and Types
  • MaxFileCount (ASP.NET)
  • MaxFileCount (PHP)
  • maxFileCount (JavaScript)
  • MinFileCount (ASP.NET)
  • MinFileCount (PHP)
  • minFileCount (JavaScript)
  • MaxFileCount (ASP.NET)
  • MaxFileCount (PHP)
  • maxFileCount (JavaScript)
  • MaxFileCountExceeded (ASP.NET)
  • MaxFileCountExceeded (PHP)
  • maxFileCountExceeded (JavaScript)
  • MinFileCount (ASP.NET)
  • MinFileCount (PHP)
  • minFileCount (JavaScript)
  • MaxFileCount (ASP.NET)
  • MaxFileCount (PHP)
  • maxFileCount (JavaScript)
  • MinFileCount (ASP.NET)
  • MinFileCount (PHP)
  • minFileCount (JavaScript)
  • MaxTotalFileSize (ASP.NET)
  • MaxTotalFileSize (PHP)
  • maxTotalFileSize (JavaScript)
  • MaxTotalFileSizeExceeded (ASP.NET)
  • MaxTotalFileSizeExceeded (PHP)
  • maxTotalFileSizeExceeded (JavaScript)
  • MaxTotalFileSize (ASP.NET)
  • MaxTotalFileSize (PHP)
  • maxTotalFileSize (JavaScript)
  • MaxTotalFileSize (ASP.NET)
  • MaxTotalFileSize (PHP)
  • maxTotalFileSize (JavaScript)
  • MinFileSize (ASP.NET)
  • MinFileSize (PHP)
  • minFileSize (JavaScript)
  • MaxFileSize (ASP.NET)
  • MaxFileSize (PHP)
  • maxFileSize (JavaScript)
  • FileSizeTooSmall (ASP.NET)
  • FileSizeTooSmall (PHP)
  • fileSizeTooSmall (JavaScript)
  • MaxFileSizeExceeded (ASP.NET)
  • MaxFileSizeExceeded (PHP)
  • maxFileSizeExceeded (JavaScript)
  • Restrictions (ASP.NET)
  • Restrictions (PHP)
  • restrictions (JavaScript)
  • Messages (ASP.NET)
  • Messages (PHP)
  • messages (JavaScript)


Using Image Uploader at Runtime

This section describes how to manipulate with Image Uploader at runtime via JavaScript API.

In This Section

Using JavaScript API
Restoring Upload List
Using Image Uploader in AJAX Applications


Using JavaScript API

Image Uploader JavaScript is used not only to embed Image Uploader into web page, but also to interact with it dynamically. Here it provides a number of properties, methods, and events, which can be used after Image Uploader is initialized. The present topic describes and illustrates by example the most significant aspects of Image Uploader runtime usage.

Getting Reference to Image Uploader by ID

When creating an Uploader object, we obligatory set its identifier via the Uploader.ID property.

JavaScript

$au.uploader({
    id: 'Uploader1',
    // ...
});

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <!-- ... -->
</aur:Uploader>

PHP

$uploader = new Uploader("Uploader1");
// ...

This identifier is used to refer to Image Uploader at runtime and, thus, modify its parameters, call methods, and handle events through JavaScript. The code snippet below demonstrates how to get reference to the Uploader instance.

JavaScript

var uploader = $au.uploader('Uploader1');

The following sections describe how to use Image Uploader properties, methods, and events at runtime.

Using Properties

To modify some Image Uploader properties after initialization, you should get a reference to the uploader object as described above, and modify these properties. If you need to modify several properties at once you can either change them one by one or call the uploader.set(Object) method.

Note

Not all Image Uploader properties can be modified at runtime. See Image Uploader JavaScript Reference for details.

The code sample below demonstrates how to implement a separate drop-down list containing available view modes. Here we change the folderPane.viewMode and uploadPane.viewMode properties respectively to the selected option.

JavaScript

<script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
<select id="selectView" onchange="changeView()">
    <option value="Thumbnails" selected="selected">Thumbnails</option>
    <option value="Tiles">Tiles</option>
    <option value="List">List</option>
    <option value="Details">Details</option>
</select>
<br />
<script type="text/javascript">
function changeView(){
    var selectView = document.getElementById('selectView');
    var value = selectView.options[selectView.selectedIndex].value;
    $au.uploader('Uploader1').folderPane().viewMode(value);
    $au.uploader('Uploader1').uploadPane().viewMode(value);
}

var u = $au.uploader({ id: 'Uploader1' });
u.writeHtml();
</script>

Using Methods

If you need to call Image Uploader methods, you should do it in the same way as for properties: get a reference to the uploader and call the method you need.

To demonstrate how to call methods we implement a custom Upload button which works in the same manner as the embedded one. When a user clicks it, we call the uploader.upload() method which initiates the upload.

JavaScript

<script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
<script type="text/javascript">
function upload(){
    $au.uploader('Uploader1').upload();
}

var u = $au.uploader({ id: 'Uploader1' });
u.writeHtml();
</script>
<br />
<input type="button" value="upload" onclick="upload()" />

Using Events

Image Uploader exposes a number of events which are handled in JavaScript. These events are intended to trace interactions between the user and the control from the initialization to the upload completion.

Adding Event Handlers

To add an event handler you need to write it in JavaScript:

JavaScript

<script type="text/javascript">
function beforeUploadHandler() {
    // ... Your code
}
</script>

The following actions depend on the way used to embed Image Uploader into your application.

In Image Uploader JavaScript event handlers can be added using the uploader.events property of the events type. This class exposes a number of properties representing available events. Each property accepts a string containing a name of the handler for corresponding event or an array of handler names.

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    events: {
        beforeUpload: beforeUploadHandler,
        afterUpload: [afterUploadHandler1, afterUploadHandler2]
    }
});

u.writeHtml();

Image Uploader ASP.NET allows configuring event handlers through the Uploader.ClientEvents property which accepts a set of ClientEvent instances. Each instance specifies the event name and name of the JavaScript function which will handle it. Names of supported events are contained in the ClientEventNames enumeration.

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="BeforeUpload" HandlerName="beforeUploadHandler" />
        <aur:ClientEvent EventName="AfterUpload" HandlerName="afterUploadHandler1" />
        <aur:ClientEvent EventName="AfterUpload" HandlerName="afterUploadHandler2" />
    </ClientEvents>
</aur:Uploader>

If you use Image Uploader PHP add event handlers via the Uploader.ClientEvents property. By analogy with JavaScript library, this property type is ClientEvents which implements properties representing Image Uploader events. Every property accepts a string containing a name of the handler for corresponding event or an array of handler names.

PHP

$uploader = new Uploader("Uploader1");

$uploader->getClientEvents()->setBeforeUpload("beforeUploadHandler");
$uploader->getClientEvents()->setAfterUpload(array("afterUploadHandler1", "afterUploadHandler2"));

$uploader->render();

Removing Event Handlers

Event handlers can be removed at runtime only, thus to remove previously added beforeUploadHandler just execute the following code:

JavaScript

$au.uploader('Uploader1').events().beforeUpload().remove(beforeUploadHandler);

Example

The following code sample demonstrates how to use the BeforeUpload event to configure a converter at runtime. Here a user can specify what should be uploaded for each original image - the image as is or its downsized copy. Additionally, this code handles all possible errors which can be occurred during Image Uploader work.

JavaScript

<script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
<select id="selectSize">
    <option value="original" selected="selected">original</option>
    <option value="100x100">100x100</option>
    <option value="320x240">320x240</option>
    <option value="640x480">640x480</option>
    <option value="800x600">800x600</option>
    <option value="1024x768">1024x768</option>
    <option value="1280x1024">1280x1024</option>
    <option value="1600x1200">1600x1200</option>
</select>
<br />
<script type="text/javascript">
function beforeUpload() {
    var selectSize = document.getElementById('selectSize');
    var value = selectSize.options[selectSize.selectedIndex].value;
    var converter = $au.uploader('Uploader1').converters().get(0);
    if (value == "original") {
        converter.mode("*.*=SourceFile");
    } else {
        value = value.split("x");
        var width = parseInt(value[0]);
        var height = parseInt(value[1]);

        converter.set({mode: "*.*=Thumbnail", thumbnailWidth: width, thumbnailHeight: height});
    }
}

function error(errorCode, httpResponseCode, errorPage, additionalInfo){
    alert(errorCode + "\n" + additionalInfo);
}

var u = $au.uploader({
    id: 'Uploader1',
    converters: [{mode: '*.*=SourceFile'}],
    events: {beforeUpload: [beforeUpload], error: [error]},
    uploadSettings: {
        actionUrl: "upload.aspx",
    }
});

u.writeHtml();
</script>

Debugging Image Uploader on Client Side

To make development and debugging of applications using Image Uploader easier Image Uploader JavaScript provides the debug class. It allows you to find the problem in the following cases:

  • assigning values to read-only properties
  • using an unsupported property or method
  • an error is detected in the event handler function
  • and others
Note

For information about handling server-side errors, please, see the Debugging Upload Scripts topic.

Using the debug class you can view error, warning, debug messages, and response from the upload processing script. To filter these messages you can use the debug.level property which supports the following values:

  • 0 shows no messages at all.
  • 1 shows errors only.
  • 2 shows errors and debug messages from Image Uploader.
  • 3 shows errors, debug messages from Image Uploader, and information messages.

If the level property is greater or equal to 2 you will also get response from the upload processing script.

You can specify debug information output via the debug.mode value. The following values are available:

  • console means debug messages are shown in the debug console of a browser. Here are the ways to open console in the most popular browsers:
    • In Internet Explorer 8 open Tools -> Developer Tools (or press F12), then select Script tab in the left pane and click Console in the right pane.
    • In Mozilla Firefox we recommend to use Firebug.
    • In Google Chrome click the Wrench icon and select Tools -> JavaScript Console (or press Ctrl+Shift+J).
    • In Safari turn on the Develop menu in the Advanced pane of Safari Preferences, after that go to Develop -> Show Error Console (or press Cmd+Alt+C).
  • pop-up window means the new pop-up window is created and debug messages are shown in it. Do not forget to allow pop-up windows beforehand.
  • alert means each debug message is shown in a separate alert dialog.

You can set one (like 'console') or several modes for displaying debug messages. In the case of several debug modes, messages will be shown in the first available mode. For example, if set the mode to ['popup','console'] messages will be shown in the console only if pop-up window failed to open (pop-ups are blocked frequently).

The following code inserted before rendering Image Uploader will print all debug messages to the console or to the pop-up window if the console is not available.

JavaScript

<script type="text/javascript">
    $au.debug().level(3);
    $au.debug().mode(['popup','console']);
</script>

Besides messages from Image Uploader you can send your own custom messages to the debug console via the showError(String) and showInfo(String) methods.

Note

It is recommended to set the level property to greater than 0 value on the development stage only. Disable debug messages on production application.

See Also

Manual

  • Quick Start with Image Uploader ASP.NET
  • Quick Start with Image Uploader PHP
  • Quick Start with Image Uploader JavaScript
  • Configuring Common Upload Settings
  • Debugging ASP.NET Upload Scripts
  • Debugging PHP Upload Scripts
  • Debugging Upload Scripts in Other Platforms
  • Debugging ASP.NET Upload Scripts
  • Debugging PHP Upload Scripts
  • Debugging Upload Scripts in Other Platforms
  • Uploader (ASP.NET)
  • Uploader (PHP)
  • uploader (JavaScript)
  • ID (PHP)
  • id (JavaScript)
  • Uploader (ASP.NET)
  • Uploader (PHP)
  • uploader (JavaScript)


Restoring Upload List

Suppose, a user opens a page with Image Uploader and selects files for the upload. They may leave this page for some reasons and reopen it after some time. And it would be nice to restore the upload list in this situation to prevent the user from selecting the same files again. Therefore, Image Uploader provides a possibility to save the upload list on the client side and restore it at any moment.

Note

Image Uploader Express does not restore upload lists. See the Comparison of Image Uploader Editions topic for details.

This functionality is implemented via the saveUploadList(Number), loadUploadList(Number), and resetUploadList(Number) methods of the uploadPane class:

  • saveUploadList(Number) saves the upload list with the specified ID.
  • loadUploadList(Number) loads the upload list with the specified ID.
  • resetUploadList(Number) resets the upload list with the specified ID.

All these methods use the ID parameter which should be a unique integer value corresponding to the particular upload list.

Note

Maximum number of upload lists allowed for saving is 50.

This feature can be illustrated with the examples below.

Multistep Upload Wizard

Using Image Uploader as a multistep upload wizard you can implement the following:

  1. Upload poor-quality thumbnails only.
  2. Show users these thumbnails to request some additional upload settings for each file.
  3. After all the preparations are done, return to the Image Uploader page and restore the upload list with files which were added on the first step.

Advanced Upload Recovering Functionality

Another application field of this feature is the advanced upload recovering functionality. In other words, you can handle the situation when the upload process was interrupted and can be resumed with the browser restart only. This functionality can be implemented as follows:

  1. Save the upload list before the upload process begins.
  2. Rewrite the upload list every time when the current file is successfully uploaded.
  3. Reset the upload list when all the files are uploaded.
  4. If some unexpected error occurs and Image Uploader should be reloaded, load the last modification of the upload list.

The following code sample demonstrates how to implement this functionality.

ASP.NET

<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="ImageUploader7._Default" %>
<%@ Register assembly="Aurigma.ImageUploader" Namespace="Aurigma.ImageUploader" tagprefix="aur" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title>Aurigma Image Uploader 7</title>
</head>
<body>
    <script type="text/javascript">
    function initCompleteHandler(){
        //Load the upload list
        $au.uploader('Uploader1').uploadPane().loadUploadList(1);
    }

    function beforePackageUploadHandler(){
        //Save the upload list
        $au.uploader('Uploader1').uploadPane().saveUploadList(1);
    }

    function afterUploadHandler(){
        //Reset the upload list
        $au.uploader('Uploader1').uploadPane().resetUploadList(1);
    }
    </script>
    <form id="form1" runat="server">
        <aur:Uploader ID="Uploader1" runat="server">
            <UploadSettings ActionUrl="upload.aspx" FilesPerPackage="1" />
            <ClientEvents>
                <aur:ClientEvent EventName="InitComplete" HandlerName="initCompleteHandler" />
                <aur:ClientEvent EventName="BeforePackageUpload" HandlerName="beforePackageUploadHandler" />
                <aur:ClientEvent EventName="AfterUpload" HandlerName="afterUploadHandler" />
            </ClientEvents>
        </aur:Uploader>
    </form>
</body>
</html>

PHP

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title>Aurigma Image Uploader 7</title>
</head>
<body>
    <script type="text/javascript">
    function initCompleteHandler(){
        //Load the upload list
        $au.uploader('Uploader1').uploadPane().loadUploadList(1);
    }

    function beforePackageUploadHandler(){
        //Save the upload list
        $au.uploader('Uploader1').uploadPane().saveUploadList(1);
    }

    function afterUploadHandler(){
        //Reset the upload list
        $au.uploader('Uploader1').uploadPane().resetUploadList(1);
    }
    </script>
    <?php
        require_once "ImageUploaderPHP/Uploader.class.php";
        $uploader = new Uploader("Uploader1");

        $uploader->getUploadSettings()->setActionUrl("upload.php");
        $uploader->getUploadSettings()->setFilesPerPackage(1);

        $uploader->getClientEvents()->setInitComplete("initCompleteHandler");
        $uploader->getClientEvents()->setBeforePackageUpload("beforePackageUploadHandler");
        $uploader->getClientEvents()->setAfterUpload("afterUploadHandler"));

        $uploader->render();
    ?>
</body>
</html>

JavaScript

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title>Aurigma Image Uploader 7</title>
</head>
<body>
    <script type="text/javascript" src="Scripts/aurigma.uploader.js">  </script>
    <script type="text/javascript">
    function initCompleteHandler(){
        //Load the upload list
        $au.uploader('Uploader1').uploadPane().loadUploadList(1);
    }

    function beforePackageUploadHandler(){
        //Save the upload list
        $au.uploader('Uploader1').uploadPane().saveUploadList(1);
    }

    function afterUploadHandler(){
        //Reset the upload list
        $au.uploader('Uploader1').uploadPane().resetUploadList(1);
    }

    var u = $au.uploader({
        id: 'Uploader1',

        uploadSettings: {
            actionUrl: "upload.aspx",
            filesPerPackage: 1
        },

        events: {
            initComplete: initCompleteHandler,
            beforePackageUpload: beforePackageUploadHandler,
            afterUpload: afterUploadHandler
        }
    });

    u.writeHtml();
    </script>
</body>
</html>

See Also

Reference

  • saveUploadList(Number) Method
  • loadUploadList(Number) Method
  • resetUploadList(Number) Method
  • BeforePackageUpload Event
  • InitComplete Event
  • AfterUpload Event

Manual

  • Configuring Fail-Safe Upload


Using Image Uploader in AJAX Applications

In the case when you embed Image Uploader into your AJAX-enabled application, you may need to hide and show the control at some time. To implement this you can use any approach which is normally used to hide and show HTML elements. For example, you can place the script which embeds Image Uploader inside <div> element and change its visibility to hidden or visible to hide or show it respectively. The following code sample demonstrates this approach:

ASP.NET

<%@ Register assembly="Aurigma.ImageUploader" Namespace="Aurigma.ImageUploader" tagprefix="aur" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head><title>Aurigma Image Uploader 7</title></head>
<body>
    <script type="text/javascript">
    var hidden = true;

    function showHideImageUploader(divId) {
        var div = document.getElementById(divId);
        if (hidden) {
            div.style.visibility = 'visible';
            div.style.height = 'auto';
        } else {
            div.style.visibility = 'hidden';
            div.style.height = '0px';
        }
        hidden = !hidden;
    }
    </script>
    <input type="button" onclick="showHideImageUploader('uploaderDiv')" value="Show/hide Image Uploader" />
    <div id="uploaderDiv" style="height: 0px; visibility: hidden;">
        <aur:Uploader ID="Uploader1" runat="server" />
    </div>
</body>
</html>

PHP

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head><title>Aurigma Image Uploader 7</title></head>
<body>
    <script type="text/javascript">
    var hidden = true;

    function showHideImageUploader(divId) {
        var div = document.getElementById(divId);
        if (hidden) {
            div.style.visibility = 'visible';
            div.style.height = 'auto';
        } else {
            div.style.visibility = 'hidden';
            div.style.height = '0px';
        }
        hidden = !hidden;
    }
    </script>
    <input type="button" onclick="showHideImageUploader('uploaderDiv')" value="Show/hide Image Uploader" />
    <div id="uploaderDiv" style="height: 0px; visibility: hidden;">
        <?php
            require_once "ImageUploaderPHP/Uploader.class.php";
            $uploader = new Uploader("Uploader1");
            $uploader->render();
        ?>
    </div>
</body>
</html>
</html>

JavaScript

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head><title>Aurigma Image Uploader 7</title></head>
<body>
    <script type="text/javascript" src="Scripts/aurigma.uploader.js"></script>
    <script type="text/javascript">
    var hidden = true;

    function showHideImageUploader(divId) {
        var div = document.getElementById(divId);
        if (hidden) {
            div.style.visibility = 'visible';
            div.style.height = 'auto';
        } else {
            div.style.visibility = 'hidden';
            div.style.height = '0px';
        }
        hidden = !hidden;
    }
    </script>
    <input type="button" onclick="showHideImageUploader('uploaderDiv')" value="Show/hide Image Uploader" />
    <div id="uploaderDiv" style="height: 0px; visibility: hidden;">
        <script type="text/javascript">
        var u = $au.uploader({id: 'Uploader1'});
        u.writeHtml();
        </script>
    </div>
</body>
</html>


Troubleshooting

Important

There are some Basic Steps in Troubleshooting we recommend to perform in the first hand.

If you still have a problem you cannot resolve, feel free to create support case. Please, send the following information:

  • Detailed description of the problem. Please, do not send reports like "Image Uploader does not work". Details are necessary so that technical support staff could help you. In particular, describe what steps you carry out to reproduce the problem.
  • Operating system and the browser where you experience this problem. If the problem occurs on the client side, please, try to reproduce the problem with several browsers (if possible).
  • Image Uploader version would be very helpful too.
  • Code snippet which embeds Image Uploader. Please, try to send only relevant code (especially if the page is large).
  • Debug class output, please, see the Basic Steps in Troubleshooting topic for information on how to get it.
  • Java console output (for non-Internet Explorer browsers only). See the Using Java Console topic to learn how to open the console.
  • Any other information that you think can help us, for example, screenshots.


Basic Steps in Troubleshooting

This topic is a guide which aims helping you to understand what is wrong with your application. Here we consider the most popular errors:

  • Image Uploader Does not Render
  • Message "Image Uploader Encountered Some Problem" Appears
  • Upload is Complete but Files are not Uploaded
  • Redirect Message Appears

If an error occurs we recommend you to start with the debug console which allows you to get error, debug, and information messages from Image Uploader right in your browser. To turn the debug console on you should:

  1. Set the DebugScriptLevel (or debug.level) to 3.
  2. Specify how debug messages should be displayed (in pop-up window, console, or alert) with the DebugScriptMode (or debug.mode) property.

  3. Allow pop-up windows or open browser error console. Here are the ways to open the console in the most popular browsers:

    • In Internet Explorer 8 open Tools -> Developer Tools (or press F12), then select Script tab in the left pane and click Console in the right pane.
    • In Mozilla Firefox we recommend to use Firebug.
    • In Google Chrome click the Wrench icon and select Tools -> JavaScript Console (or press Ctrl+Shift+J).
    • In Safari turn on the Develop menu in the Advanced pane of Safari Preferences, after that go to Develop -> Show Error Console (or press Cmd+Alt+C).
  4. Reload your application.

The following code inserted in your application will print all debug messages from Image Uploader to pop-up window (or to the console if pop-ups are blocked).

ASP.NET

<aur:Uploader ID="Uploader1" runat="server"
    DebugScriptLevel="3" DebugScriptMode="Default" >
</aur:Uploader>

PHP

<?php
    require_once "ImageUploaderPHP/Uploader.class.php";
    $uploader = new Uploader('Uploader1');
    $uploader->setDebugScriptLevel(3);
    $uploader->setDebugScriptMode("['popup','console']");
    $uploader->render();
?>

If you prefer JavaScript, remember that the following code should be inserted before rendering Image Uploader:

JavaScript

<script type="text/javascript">
    $au.debug().level(3);
    $au.debug().mode(['popup','console']);
</script>

For more information about the debug console, please, see the Using JavaScript API topic.

Image Uploader Does not Render

Firstly, make sure that Image Uploader is installed on the client side; for more information on how to install the client parts of Image Uploader, see the Installing Image Uploader on Client Side topic.

Another possible reason is an error in your script which embeds Image Uploader. Please, use the debug console as it is described at the beginning of this topic to find the error.

Message "Image Uploader Encountered Some Problem" Appears

It means that an internal server error has occurred. Far more likely that:

  • Image Uploader cannot save uploaded files because of wrong permissions configuration. See the Installation and Deployment Notes topic to get to know how to set required permissions.
  • The request size is too big. See the Configuring ASP.NET or Configuring PHP topics, or refer to your server documentation to get to know how to increase maximum request length.
  • There is an error in your upload script (specified with the UploadSettings.ActionUrl property); see the Debugging Upload Scripts topic.

Upload is Complete but Files are not Uploaded

This can indicate one of the following:

  • You did not specify any Converter. If so, specify at least one.
  • You do not actually save uploaded files. In this case, either implement the upload processing script or use the autosave feature. For more information, please, see the Saving Uploaded Files topic.
  • You use the autosave feature, but did not specify DestinationFolder.
  • You are trying to find files in a folder different from the one specified in your upload script.
  • You use PHP platform and experience a server-side error (HTTP code 500); see the Debugging PHP Upload Scripts topic.

Redirect Message Appears

There are three possible reasons of getting "The server attempted to redirect you to http://someserver.com, but server redirects are not supported." message:

  • Your upload script tries to redirect users to another page, but Image Uploader does not support redirection in an upload script. To implement redirection use the RedirectUrl property.
  • You upload in non-Internet Explorer browser and lost session or authorization cookies, so the sever tries to redirect you to the login page. Please, see the Maintaining Sessions and Authentication topic.
  • A server error has occurred and the server tried to redirect users to a custom error page, please, see the Debugging Upload Scripts topic.

See Also

Reference

  • debug Class
  • Converter Class
  • UploadSettings.ActionUrl Property
  • UploadSettings.RedirectUrl Property
  • BaseUploadControl.DestinationFolder Property

Manual

  • Debugging ASP.NET Upload Scripts
  • Debugging PHP Upload Scripts
  • Debugging Upload Scripts in Other Platforms
  • Saving Uploaded Files in PHP
  • Saving Uploaded Files in ASP.NET
  • Configuring PHP
  • Configuring ASP.NET
  • Installation and Deployment Notes
  • Using JavaScript API
  • Installing Image Uploader on Client Side
  • Maintaining Sessions and Authentication in ASP.NET
  • Maintaining Sessions and Authentication in PHP

Other Resources

  • Firebug
  • Debugging ASP.NET Upload Scripts
  • Debugging PHP Upload Scripts
  • Debugging Upload Scripts in Other Platforms
  • Saving Uploaded Files in ASP.NET
  • Saving Uploaded Files in PHP
  • Maintaining Sessions and Authentication in ASP.NET
  • Maintaining Sessions and Authentication in PHP
  • DebugScriptLevel (ASP.NET)
  • DebugScriptLevel (PHP)
  • DebugScriptMode (ASP.NET)
  • DebugScriptMode (PHP)
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • RedirectUrl (ASP.NET)
  • RedirectUrl (PHP)
  • redirectUrl (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)
  • RedirectUrl (ASP.NET)
  • RedirectUrl (PHP)
  • redirectUrl (JavaScript)


Using Java Console

When Image Uploader is utilized in non-Internet Explorer browsers (Firefox, Safari, and etc), it uses java applet as a client side application. Java applets provide a feature that is very useful when it is necessary to get additional information about some problem: special console where the applet can trace various debug information. This topic describes how to get information from the Java console.

Using Java Console

Opening Java Console on Windows

  1. Find the Java icon in the notification tray (coffee cup icon). If there is no Java in the system tray, you should enable it with the following steps:
    1. Go to Start menu -> Control Panel -> Java Plug-in.
    2. Switch to Basic tab (which is opened by default).
    3. Select the Show Java in System Tray checkbox.
    4. Click the Apply button and close the Java control panel.
  2. Right-click the Java icon in the system tray and select Open Console item.

Opening Java Console on Mac

  1. Open Finder -> Go -> Utilities -> Java Preferences by double click.
  2. Select the Advanced tab.
  3. Select the Show Console checkbox.
  4. Close Java Preferences.
  5. As soon as you run the browser with any Java applet, the console window will appear.

Java Console Usage

After you open Java console, use Image Uploader to reproduce the problem. Debug information will be automatically dumped into the console.

You can set the trace level - the parameter that determines how much debug information should be displayed. This value can be a number from 1 (brief) through 5 (most verbose).

To select a trace level, just type a number from 1 through 5 in the console.

Other console commands are displayed in the beginning of the console output. Also, you can display this list of commands by typing h in the console.

What Information Can Be Found?

Image Uploader writes various information into the console. Some information makes sense for developers only, but some information can be useful for you as well, for example:

  • version number of the ImageUploader7.jar
  • cookies, which are recognized by Image Uploader and about to be sent to the server
  • additional POST fields which will be sent to the server
  • HTTP response from the server (HTTP code as well as HTML generated by the upload processing page)
  • and any other details

If you create support case, the console output may help to find out the reason of the problem and its resolution.


Reference

This topic contains reference information related to Aurigma Image Uploader 7.0.11.

In This Section

Image Uploader ASP.NET Reference
Image Uploader PHP Reference
Image Uploader JavaScript Reference
Image Uploader Client-Side Events Reference
POST Field Reference


Image Uploader ASP.NET Reference

Image Uploader ASP.NET is a server control intended to make deployment of Image Uploader, configuring it, and handling uploaded data easier. It allows ASP.NET developers to utilize Image Uploader in a straight-forward way just as a common ASP.NET server control. Refer to the documentation to get started with Image Uploader ASP.NET.

Namespaces

Name | Description
Aurigma.ImageUploader.AmazonS3 | The Aurigma.ImageUploader.AmazonS3 namespace contains classes related to AmazonS3 extender.
Aurigma.ImageUploader | This is a root namespace of Image Uploader ASP.NET.
Aurigma.ImageUploader.Nirvanix | The Aurigma.ImageUploader.Nirvanix namespace contains classes related to Nirvanix extender.


Aurigma.ImageUploader Namespace

This is a root namespace of Image Uploader ASP.NET.

Classes

 | Class | Description
Public class | ActiveXControl | This class represents Image Uploader ActiveX control.
Public class | AddFilesProgressDialog | This class represents the adding files dialog which appears when a user selects quite a lot of files.
Public class | AllFilesUploadedEventArgs | This class provides data for BaseUploadControl.AllFilesUploaded, UploadHandler.AllFilesUploaded, and UploadRequest.AllFilesUploaded events.
Public class | AuthenticationDialog | This class represents the authentication dialog.
Public class | BackgroundImageFormat | This class specifies settings of a background image.
Public class | BaseClientControl | This is a base class for all client-side controls.
Public class | BaseClientEvent<(Of <(T>)>) | This is a base class for all Image Uploader client-side events.
Public class | BaseControl | This is a base class for all Image Uploader visual controls.
Public class | BaseExtender | This is a base class for BaseUploaderExtender.
Public class | BaseUploadControl | This is a base class for Uploader.
Public class | BaseUploaderExtender | This is a base class for all Image Uploader extenders.
Public class | ClientEvent | This class represents a client-side event.
Public class | ClientEventCollection | This class represents a collection of the Uploader client-side events.
Public class | ContextMenu | This class represents Image Uploader context menu. Use this class to customize or localize context menu options.
Public class | ConvertedFile | This class represents a converted file and exposes a number of properties and methods which provide an access to the converted file details (e.g. file name, size, conversion mode, and etc.) and allows saving it on a server.
Public class | ConvertedFileCollection | This class represents a collection of converted files.
Public class | Converter | This class represents a file converter.
Public class | ConverterCollection | This class represents a collection of file converters.
Public class | DeleteFilesDialog | This class represents the delete confirmation dialog which appears in non-Internet Explorer browsers when Uploader..::.EnableOriginalFilesDeletion is true.
Public class | DescriptionEditor | This class represents the description editor.
Public class | DetailsViewColumns | This class contains titles of columns displayed in the Details view.
Public class | FileUploadedEventArgs | This class provides data for BaseUploadControl.FileUploaded, UploadHandler.FileUploaded, and UploadRequest.FileUploaded events.
Public class | FolderPane | This class represents the folder pane.
Public class | FontFormat | This class specifies font settings.
Public class | GradientColorConverter | This class inherits from the TypeConverter and allows converting values of different types to the GradientColor type.
Public class | ImageEditor | This class represents the image editor.
Public class | ImageFormat | This class specifies different states of Image Uploader buttons and icons.
Public class | InformationBar | This class represents the information bar.
Public class | InstallationProgress | This class allows displaying special screens instead of Image Uploader during the downloading and installation phases.
Public class | JavaControl | This class represents Image Uploader Java applet.
Public class | Messages | This class contains error messages Image Uploader shows.
Public class | Metadata | This class represents an additional upload data.
Public class | Package | This class represents a package uploaded within the current session.
Public class | PaneItem | This class represents a pane item displayed in both the upload and folder panes.
Public class | PostFields | This class contains POST field names that are generated and uploaded by Image Uploader.
Public class | QualityMeter | This class represents the quality meter.
Public class | Restrictions | This class contains masks for allowed and denied file extensions and upload restrictions.
Public class | StatusPane | This class represents the status pane.
Public class | Thumbnail | This class represents a standalone thumbnail bound with some upload pane item of Image Uploader.
Public class | ThumbnailClientEvent | This class represents a client-side event.
Public class | ThumbnailClientEventCollection | This class represents a collection of the Thumbnail client-side events.
Public class | TreePane | This class represents the tree pane.
Public class | UploadedFile | This class provides an access to all the converted files and metadata related to a particular user-selected file.
Public class | Uploader | This class represents an ASP.NET server control intended for embedding Image Uploader into ASP.NET applications.
Public class | UploadException |
Public class | UploadHandler | This class represents an HTTP handler which allows processing Image Uploader requests.
Public class | UploadPane | This class represents the upload pane.
Public class | UploadProgressDialog | This class represents the uploading files dialog which appears during the upload.
Public class | UploadRequest | This class allows processing uploaded data in the same way as the Uploader control.
Public class | UploadSettings | This class represents the upload settings.

Structures

 | Structure | Description
Public structure | GradientColor | This structure represents linear gradient colors.

Enumerations

 | Enumeration | Description
Public enumeration | BackgroundPosition | Specifies possible values for background image position.
Public enumeration | BorderStyle | Specifies possible values for border styles.
Public enumeration | ClientEventNames | Specifies possible values for client-side event names.
Public enumeration | DebugScriptMode |
Public enumeration | FolderProcessingMode | Specifies possible values for folder processing modes.
Public enumeration | Language | Specifies possible values for Image Uploader localizations.
Public enumeration | PaneLayoutMode | Specifies possible values for layouts of Image Uploader panes.
Public enumeration | PaneSortMode | Specifies possible values for sort modes.
Public enumeration | PaneViewMode | Specifies possible values for Image Uploader view modes.
Public enumeration | ProgressBytesMode | Specifies possible values for the ProgressBytesMode property.
Public enumeration | ResizeQuality | Specifies possible values for resize qualities.
Public enumeration | ThumbnailClientEventNames | Specifies possible values for the Thumbnail control client-side event names.
Public enumeration | ThumbnailFitMode | Specifies possible values for thumbnail fit modes.

See Also

Reference

  • $au JavaScript Namespace


ActiveXControl Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

This class represents Image Uploader ActiveX control.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public NotInheritable Class ActiveXControl _
    Inherits BaseClientControl

C#

public sealed class ActiveXControl : BaseClientControl

Remarks

Note

This client-side control is used in Internet Explorer only.

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.BaseClientControl L Aurigma.ImageUploader..::.ActiveXControl

See Also

Reference

  • ActiveXControl Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.ActiveXControl
  • $au.activeXControl JavaScript Class
  • ActiveXControl PHP Class


ActiveXControl Members

  • ActiveXControl Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The ActiveXControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ClassId | Gets or sets a CLSID of the ActiveX control.
Public property | CodeBase | Gets a URL to client-side control. (Inherited from BaseClientControl.)
Public property | CustomCodeBase | Gets or sets a custom URL to client-side control. (Inherited from BaseClientControl.)
Public property | ProgId | Gets or sets a PROGID of the ActiveX control.
Public property | UseCustomCodeBase | Gets or sets a value indicating whether a custom URL to client-side control specified with the CustomCodeBase property is used. (Inherited from BaseClientControl.)
Public property | Version | Gets or sets a minimum required version of the client-side control. (Inherited from BaseClientControl.)

See Also

Reference

  • ActiveXControl Class
  • Aurigma.ImageUploader Namespace


ActiveXControl Properties

  • ActiveXControl Class
  • See Also
  • Language Filter ( all languages )

The ActiveXControl type exposes the following members.

Properties

 | Name | Description
Public property | ClassId | Gets or sets a CLSID of the ActiveX control.
Public property | CodeBase | Gets a URL to client-side control. (Inherited from BaseClientControl.)
Public property | CustomCodeBase | Gets or sets a custom URL to client-side control. (Inherited from BaseClientControl.)
Public property | ProgId | Gets or sets a PROGID of the ActiveX control.
Public property | UseCustomCodeBase | Gets or sets a value indicating whether a custom URL to client-side control specified with the CustomCodeBase property is used. (Inherited from BaseClientControl.)
Public property | Version | Gets or sets a minimum required version of the client-side control. (Inherited from BaseClientControl.)

See Also

Reference

  • ActiveXControl Class
  • Aurigma.ImageUploader Namespace


ClassId Property

ActiveXControl..::.ClassId Property

  • Collapse All Sections
  • ActiveXControl Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets or sets a CLSID of the ActiveX control.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ClassId As String

C#

public string ClassId { get; set; }

Property Value

Type: System..::.String

The CLSID of the ActiveX control.

Default value is "".

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • ActiveXControl Class
  • Aurigma.ImageUploader Namespace
  • $au.activeXControl.classId JavaScript Property
  • ActiveXControl.ClassId PHP Property

Manual

  • Using Private-label Version of Image Uploader ASP.NET


ProgId Property

ActiveXControl..::.ProgId Property

  • Collapse All Sections
  • ActiveXControl Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets or sets a PROGID of the ActiveX control.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ProgId As String

C#

public string ProgId { get; set; }

Property Value

Type: System..::.String

The PROGID of the ActiveX control.

Default value is "".

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • ActiveXControl Class
  • Aurigma.ImageUploader Namespace
  • $au.activeXControl.progId JavaScript Property
  • ActiveXControl.ProgId PHP Property

Manual

  • Using Private-label Version of Image Uploader ASP.NET


AddFilesProgressDialog Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the adding files dialog which appears when a user selects quite a lot of files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class AddFilesProgressDialog

C#

public class AddFilesProgressDialog

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.AddFilesProgressDialog

See Also

Reference

  • AddFilesProgressDialog Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.AddFilesProgressDialog
  • $au.addFilesProgressDialog JavaScript Class
  • AddFilesProgressDialog PHP Class

Manual

  • Customizing Appearance


AddFilesProgressDialog Members

  • AddFilesProgressDialog Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The AddFilesProgressDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | CancelButtonText | Gets or sets a caption of the Cancel button on the dialog displayed when a user selects quite a lot of files.
Public property | CurrentFileText | Gets or sets a text of the label which displays a name of the currently processing file.
Public property | TitleText | Gets or sets a title of the dialog displayed when a user selects quite a lot of files.
Public property | TotalFilesText | Get or sets a text of the label which displays a total number of processed files.
Public property | WaitText | Gets or sets a text of the label which is displayed while Image Uploader is preparing to add files.

See Also

Reference

  • AddFilesProgressDialog Class
  • Aurigma.ImageUploader Namespace


AddFilesProgressDialog Properties

  • AddFilesProgressDialog Class
  • See Also
  • Language Filter ( all languages )

The AddFilesProgressDialog type exposes the following members.

Properties

 | Name | Description
Public property | CancelButtonText | Gets or sets a caption of the Cancel button on the dialog displayed when a user selects quite a lot of files.
Public property | CurrentFileText | Gets or sets a text of the label which displays a name of the currently processing file.
Public property | TitleText | Gets or sets a title of the dialog displayed when a user selects quite a lot of files.
Public property | TotalFilesText | Get or sets a text of the label which displays a total number of processed files.
Public property | WaitText | Gets or sets a text of the label which is displayed while Image Uploader is preparing to add files.

See Also

Reference

  • AddFilesProgressDialog Class
  • Aurigma.ImageUploader Namespace


CancelButtonText Property

AddFilesProgressDialog..::.CancelButtonText Property

  • Collapse All Sections
  • AddFilesProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel button on the dialog displayed when a user selects quite a lot of files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CancelButtonText As String

C#

public string CancelButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the Cancel button on the adding files dialog.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • AddFilesProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.addFilesProgressDialog.cancelButtonText JavaScript Property
  • AddFilesProgressDialog.CancelButtonText PHP Property


CurrentFileText Property

AddFilesProgressDialog..::.CurrentFileText Property

  • Collapse All Sections
  • AddFilesProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text of the label which displays a name of the currently processing file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CurrentFileText As String

C#

public string CurrentFileText { get; set; }

Property Value

Type: System..::.String

The text of the Processing file label. It can contain the following placeholder:

[name]
replaced by the name of the currently processing file.

Default value is "Processing file: '[name]'".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • AddFilesProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.addFilesProgressDialog.currentFileText JavaScript Property
  • AddFilesProgressDialog.CurrentFileText PHP Property


TitleText Property

AddFilesProgressDialog..::.TitleText Property

  • Collapse All Sections
  • AddFilesProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the dialog displayed when a user selects quite a lot of files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property TitleText As String

C#

public string TitleText { get; set; }

Property Value

Type: System..::.String

The title of the adding files dialog.

Default value is "Adding files to upload queue".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • AddFilesProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.addFilesProgressDialog.titleText JavaScript Property
  • AddFilesProgressDialog.TitleText PHP Property


TotalFilesText Property

AddFilesProgressDialog..::.TotalFilesText Property

  • Collapse All Sections
  • AddFilesProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Get or sets a text of the label which displays a total number of processed files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property TotalFilesText As String

C#

public string TotalFilesText { get; set; }

Property Value

Type: System..::.String

The text of the Already processed files label. It can contain the following placeholder:

[count]
replaced by the total number of processed files.

Default value is "already processed files: [count]".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • AddFilesProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.addFilesProgressDialog.totalFilesText JavaScript Property
  • AddFilesProgressDialog.TotalFilesText PHP Property


WaitText Property

AddFilesProgressDialog..::.WaitText Property

  • Collapse All Sections
  • AddFilesProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the label which is displayed while Image Uploader is preparing to add files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property WaitText As String

C#

public string WaitText { get; set; }

Property Value

Type: System..::.String

The text of the Please wait label.

Default value is "Please wait, it may take some time...".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • AddFilesProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.addFilesProgressDialog.waitText JavaScript Property
  • AddFilesProgressDialog.WaitText PHP Property


AllFilesUploadedEventArgs Class

  • Members
  • See Also
  • Language Filter ( all languages )

This class provides data for BaseUploadControl.AllFilesUploaded, UploadHandler.AllFilesUploaded, and UploadRequest.AllFilesUploaded events.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class AllFilesUploadedEventArgs _
    Inherits EventArgs

C#

public class AllFilesUploadedEventArgs : EventArgs

Remarks

BaseUploadControl.AllFilesUploaded, UploadHandler.AllFilesUploaded, and UploadRequest.AllFilesUploaded events occur when the upload session completes.

Inheritance Hierarchy

System..::.Object L System..::.EventArgs L Aurigma.ImageUploader..::.AllFilesUploadedEventArgs

See Also

Reference

  • AllFilesUploadedEventArgs Members
  • Aurigma.ImageUploader Namespace

Manual

  • Saving Uploaded Files in ASP.NET


AllFilesUploadedEventArgs Members

  • AllFilesUploadedEventArgs Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The AllFilesUploadedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Packages | Gets an array of Package instances belonging to the completed upload session.
Public property | UploadedFiles | Gets a collection of UploadedFile instances belonging to the completed upload session.

See Also

Reference

  • AllFilesUploadedEventArgs Class
  • Aurigma.ImageUploader Namespace


AllFilesUploadedEventArgs Properties

  • AllFilesUploadedEventArgs Class
  • See Also
  • Language Filter ( all languages )

The AllFilesUploadedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Packages | Gets an array of Package instances belonging to the completed upload session.
Public property | UploadedFiles | Gets a collection of UploadedFile instances belonging to the completed upload session.

See Also

Reference

  • AllFilesUploadedEventArgs Class
  • Aurigma.ImageUploader Namespace


Packages Property

AllFilesUploadedEventArgs..::.Packages Property

  • Collapse All Sections
  • AllFilesUploadedEventArgs Class
  • See Also
  • Language Filter ( all languages )

Gets an array of Package instances belonging to the completed upload session.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Packages As Package()

C#

public Package[] Packages { get; }

Property Value

Type: array<Aurigma.ImageUploader..::.Package>[]()[]

The array of Package instances.

See Also

Reference

  • AllFilesUploadedEventArgs Class
  • Aurigma.ImageUploader Namespace


UploadedFiles Property

AllFilesUploadedEventArgs..::.UploadedFiles Property

  • Collapse All Sections
  • AllFilesUploadedEventArgs Class
  • See Also
  • Language Filter ( all languages )

Gets a collection of UploadedFile instances belonging to the completed upload session.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property UploadedFiles As List(Of UploadedFile)

C#

public List<UploadedFile> UploadedFiles { get; }

Property Value

Type: System.Collections.Generic..::.List<(Of <(T>)>)

The collection of UploadedFile instances.

See Also

Reference

  • AllFilesUploadedEventArgs Class
  • Aurigma.ImageUploader Namespace


AuthenticationDialog Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

This class represents the authentication dialog.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class AuthenticationDialog

C#

public class AuthenticationDialog

Remarks

This dialog is displayed when the server requests a password. It is displayed during each upload session, i.e. it does not remember the login information.

Note

The authentication dialog is displayed in non-Internet Explorer browsers only.

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.AuthenticationDialog

See Also

Reference

  • AuthenticationDialog Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.AuthenticationDialog
  • $au.authenticationDialog JavaScript Class
  • AuthenticationDialog PHP Class

Manual

  • Adding Authentication


AuthenticationDialog Members

  • AuthenticationDialog Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The AuthenticationDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | CancelButtonText | Gets or sets a caption of the Cancel button.
Public property | LoginText | Gets or sets a text of the Login label.
Public property | OkButtonText | Gets or sets a caption of the Ok button.
Public property | PasswordText | Gets or sets a text of the Password label.
Public property | RealmText | Gets or sets a text of the Realm label.
Public property | Text | Gets or sets a text of the dialog message.

See Also

Reference

  • AuthenticationDialog Class
  • Aurigma.ImageUploader Namespace


AuthenticationDialog Properties

  • AuthenticationDialog Class
  • See Also
  • Language Filter ( all languages )

The AuthenticationDialog type exposes the following members.

Properties

 | Name | Description
Public property | CancelButtonText | Gets or sets a caption of the Cancel button.
Public property | LoginText | Gets or sets a text of the Login label.
Public property | OkButtonText | Gets or sets a caption of the Ok button.
Public property | PasswordText | Gets or sets a text of the Password label.
Public property | RealmText | Gets or sets a text of the Realm label.
Public property | Text | Gets or sets a text of the dialog message.

See Also

Reference

  • AuthenticationDialog Class
  • Aurigma.ImageUploader Namespace


CancelButtonText Property

AuthenticationDialog..::.CancelButtonText Property

  • Collapse All Sections
  • AuthenticationDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the Cancel button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CancelButtonText As String

C#

public string CancelButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the Cancel button.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • AuthenticationDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.authenticationDialog.cancelButtonText JavaScript Property
  • AuthenticationDialog.CancelButtonText PHP Property


LoginText Property

AuthenticationDialog..::.LoginText Property

  • Collapse All Sections
  • AuthenticationDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the Login label.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property LoginText As String

C#

public string LoginText { get; set; }

Property Value

Type: System..::.String

The text of the Login label.

Default value is "Login:".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • AuthenticationDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.authenticationDialog.loginText JavaScript Property
  • AuthenticationDialog.LoginText PHP Property


OkButtonText Property

AuthenticationDialog..::.OkButtonText Property

  • Collapse All Sections
  • AuthenticationDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the Ok button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property OkButtonText As String

C#

public string OkButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the Ok button.

Default value is "Ok".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • AuthenticationDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.authenticationDialog.okButtonText JavaScript Property
  • AuthenticationDialog.OkButtonText PHP Property


PasswordText Property

AuthenticationDialog..::.PasswordText Property

  • Collapse All Sections
  • AuthenticationDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the Password label.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property PasswordText As String

C#

public string PasswordText { get; set; }

Property Value

Type: System..::.String

The text of the Password label.

Default value is "Password:".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • AuthenticationDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.authenticationDialog.passwordText JavaScript Property
  • AuthenticationDialog.PasswordText PHP Property


RealmText Property

AuthenticationDialog..::.RealmText Property

  • Collapse All Sections
  • AuthenticationDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the Realm label.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property RealmText As String

C#

public string RealmText { get; set; }

Property Value

Type: System..::.String

The text of the Realm label.

Default value is "Realm:".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • AuthenticationDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.authenticationDialog.realmText JavaScript Property
  • AuthenticationDialog.RealmText PHP Property


Text Property

AuthenticationDialog..::.Text Property

  • Collapse All Sections
  • AuthenticationDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the dialog message.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Text As String

C#

public string Text { get; set; }

Property Value

Type: System..::.String

The text of the dialog message. It can contain the following placeholder:

[name]
replaced by the name of the server which requests authentication.

Default value is "Host [name] requires authentication".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • AuthenticationDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.authenticationDialog.text JavaScript Property
  • AuthenticationDialog.Text PHP Property


BackgroundImageFormat Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class specifies settings of a background image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class BackgroundImageFormat

C#

public class BackgroundImageFormat

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.BackgroundImageFormat

See Also

Reference

  • BackgroundImageFormat Members
  • Aurigma.ImageUploader Namespace
  • UploadPane..::.DropFilesHereImageFormat
  • BackgroundImageFormat PHP Class


BackgroundImageFormat Members

  • BackgroundImageFormat Class
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The BackgroundImageFormat type exposes the following members.

Constructors

 | Name | Description
Public method | BackgroundImageFormat | Creates and initializes an instance of the BackgroundImageFormat class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Overloaded.

Properties

 | Name | Description
Public property | Height | Gets or sets a height of the background image.
Public property | Position | Gets or sets a position of the background image.
Public property | Url | Gets or sets a URL to the background image.
Public property | Width | Gets or sets a width of the background image.

See Also

Reference

  • BackgroundImageFormat Class
  • Aurigma.ImageUploader Namespace


BackgroundImageFormat Constructor

  • BackgroundImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the BackgroundImageFormat class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public BackgroundImageFormat()

See Also

Reference

  • BackgroundImageFormat Class
  • Aurigma.ImageUploader Namespace


BackgroundImageFormat Methods

  • BackgroundImageFormat Class
  • See Also
  • Language Filter ( all languages )

The BackgroundImageFormat type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Overloaded.

See Also

Reference

  • BackgroundImageFormat Class
  • Aurigma.ImageUploader Namespace


ToString Method

BackgroundImageFormat..::.ToString Method

  • Collapse All Sections
  • BackgroundImageFormat Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | ToString()()() | Returns a String that represents the current BackgroundImageFormat. (Overrides Object ..::. ToString()()().)
Public method | ToString(IUrlResolutionService) | Returns a String that represents the current BackgroundImageFormat.

See Also

Reference

  • BackgroundImageFormat Class
  • BackgroundImageFormat Members
  • Aurigma.ImageUploader Namespace


ToString Method

BackgroundImageFormat..::.ToString Method

  • Collapse All Sections
  • BackgroundImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns a String that represents the current BackgroundImageFormat.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Overrides Function ToString As String

C#

public override string ToString()

Return Value

Type: System..::.String

The string representation of this ImageFormat.

See Also

Reference

  • BackgroundImageFormat Class
  • ToString Overload
  • Aurigma.ImageUploader Namespace


ToString Method (IUrlResolutionService)

BackgroundImageFormat..::.ToString Method (IUrlResolutionService)

  • Collapse All Sections
  • BackgroundImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns a String that represents the current BackgroundImageFormat.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Function ToString ( _
    urlResolver As IUrlResolutionService _
) As String

C#

public string ToString(
    IUrlResolutionService urlResolver
)

Parameters

urlResolver

Type: System.Web.UI..::.IUrlResolutionService

The IUrlResolutionService used for resolving relative paths and paths that contain the ~ operator.

Return Value

Type: System..::.String

The string representation of this BackgroundImageFormat.

See Also

Reference

  • BackgroundImageFormat Class
  • ToString Overload
  • Aurigma.ImageUploader Namespace


BackgroundImageFormat Properties

  • BackgroundImageFormat Class
  • See Also
  • Language Filter ( all languages )

The BackgroundImageFormat type exposes the following members.

Properties

 | Name | Description
Public property | Height | Gets or sets a height of the background image.
Public property | Position | Gets or sets a position of the background image.
Public property | Url | Gets or sets a URL to the background image.
Public property | Width | Gets or sets a width of the background image.

See Also

Reference

  • BackgroundImageFormat Class
  • Aurigma.ImageUploader Namespace


Height Property

BackgroundImageFormat..::.Height Property

  • Collapse All Sections
  • BackgroundImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of the background image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Height As Integer

C#

public int Height { get; set; }

Property Value

Type: System..::.Int32

The height of the background image.

Default value is 0.

See Also

Reference

  • BackgroundImageFormat Class
  • Aurigma.ImageUploader Namespace
  • BackgroundImageFormat.Height PHP Property


Position Property

BackgroundImageFormat..::.Position Property

  • Collapse All Sections
  • BackgroundImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a position of the background image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Position As BackgroundPosition

C#

public BackgroundPosition Position { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.BackgroundPosition

The position of the background image.

Default value is Center.

See Also

Reference

  • BackgroundImageFormat Class
  • Aurigma.ImageUploader Namespace
  • BackgroundImageFormat.Position PHP Property


Url Property

BackgroundImageFormat..::.Url Property

  • Collapse All Sections
  • BackgroundImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the background image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Url As String

C#

public string Url { get; set; }

Property Value

Type: System..::.String

The URL to the background image.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • BackgroundImageFormat Class
  • Aurigma.ImageUploader Namespace
  • BackgroundImageFormat.Url PHP Property


Width Property

BackgroundImageFormat..::.Width Property

  • Collapse All Sections
  • BackgroundImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of the background image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Width As Integer

C#

public int Width { get; set; }

Property Value

Type: System..::.Int32

The width of the background image.

Default value is 0.

See Also

Reference

  • BackgroundImageFormat Class
  • Aurigma.ImageUploader Namespace
  • BackgroundImageFormat.Width PHP Property


BackgroundPosition Enumeration

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Specifies possible values for background image position.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration BackgroundPosition

C#

public enum BackgroundPosition

Members

Member name | Description
TopLeft | Background image is positioned in the left top corner.
TopCenter | Background image is positioned in the middle of the top side.
TopRight | Background image is positioned in the right top corner.
CenterLeft | Background image is positioned in the middle of the left side.
Center | Background image is positioned in the center.
CenterRight | Background image is positioned in the middle of the right side.
BottomLeft | Background image is positioned in the left bottom corner.
BottomCenter | Background image is positioned in the middle of the bottom side.
BottomRight | Background image is positioned in the right bottom corner.

See Also

Reference

  • Aurigma.ImageUploader Namespace


BaseClientControl Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This is a base class for all client-side controls.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustInherit Class BaseClientControl

C#

public abstract class BaseClientControl

Remarks

BaseClientControl is an abstract class which implements common functionality for client-side controls. You cannot instantiate objects of this class directly.

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.BaseClientControl L Aurigma.ImageUploader..::.ActiveXControl L Aurigma.ImageUploader..::.JavaControl

See Also

Reference

  • BaseClientControl Members
  • Aurigma.ImageUploader Namespace
  • BaseClientControl PHP Class


BaseClientControl Members

  • BaseClientControl Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The BaseClientControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | CodeBase | Gets a URL to client-side control.
Public property | CustomCodeBase | Gets or sets a custom URL to client-side control.
Public property | UseCustomCodeBase | Gets or sets a value indicating whether a custom URL to client-side control specified with the CustomCodeBase property is used.
Public property | Version | Gets or sets a minimum required version of the client-side control.

See Also

Reference

  • BaseClientControl Class
  • Aurigma.ImageUploader Namespace


BaseClientControl Properties

  • BaseClientControl Class
  • See Also
  • Language Filter ( all languages )

The BaseClientControl type exposes the following members.

Properties

 | Name | Description
Public property | CodeBase | Gets a URL to client-side control.
Public property | CustomCodeBase | Gets or sets a custom URL to client-side control.
Public property | UseCustomCodeBase | Gets or sets a value indicating whether a custom URL to client-side control specified with the CustomCodeBase property is used.
Public property | Version | Gets or sets a minimum required version of the client-side control.

See Also

Reference

  • BaseClientControl Class
  • Aurigma.ImageUploader Namespace


CodeBase Property

BaseClientControl..::.CodeBase Property

  • Collapse All Sections
  • BaseClientControl Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a URL to client-side control.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property CodeBase As String

C#

public string CodeBase { get; }

Property Value

Type: System..::.String

The URL to client-side control.

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • BaseClientControl Class
  • Aurigma.ImageUploader Namespace
  • BaseClientControl.CodeBase PHP Property

Manual

  • Using Private-label Version of Image Uploader ASP.NET


CustomCodeBase Property

BaseClientControl..::.CustomCodeBase Property

  • Collapse All Sections
  • BaseClientControl Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a custom URL to client-side control.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CustomCodeBase As String

C#

public string CustomCodeBase { get; set; }

Property Value

Type: System..::.String

The custom URL to client-side control.

Default value is "".

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • BaseClientControl Class
  • Aurigma.ImageUploader Namespace
  • BaseClientControl..::.UseCustomCodeBase

Manual

  • Using Private-label Version of Image Uploader ASP.NET


UseCustomCodeBase Property

BaseClientControl..::.UseCustomCodeBase Property

  • Collapse All Sections
  • BaseClientControl Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether a custom URL to client-side control specified with the CustomCodeBase property is used.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UseCustomCodeBase As Boolean

C#

public bool UseCustomCodeBase { get; set; }

Property Value

Type: System..::.Boolean

If true, Uploader loads a stand-alone version of the client-side control specified with the CustomCodeBase property. Otherwise, a built-it control is loaded.

Default value is false.

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • BaseClientControl Class
  • Aurigma.ImageUploader Namespace
  • BaseClientControl..::.CustomCodeBase

Manual

  • Using Private-label Version of Image Uploader ASP.NET


Version Property

BaseClientControl..::.Version Property

  • Collapse All Sections
  • BaseClientControl Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum required version of the client-side control.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Version As String

C#

public string Version { get; set; }

Property Value

Type: System..::.String

The minimum required version of the client-side control.

See Also

Reference

  • BaseClientControl Class
  • Aurigma.ImageUploader Namespace
  • BaseClientControl.Version PHP Property


BaseClientEvent(T) Class

BaseClientEvent<(Of <(T>)>) Class

  • Collapse All Sections
  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This is a base class for all Image Uploader client-side events.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class BaseClientEvent(Of T)

C#

public class BaseClientEvent<T>

Type Parameters

T

Remarks

BaseClientEvent<(Of <(T>)>) is an abstract class which implements common functionality for Image Uploader client-side events. You cannot instantiate objects of this class directly.

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.BaseClientEvent<(Of <(T>)>) L Aurigma.ImageUploader..::.ThumbnailClientEvent L Aurigma.ImageUploader..::.ClientEvent

See Also

Reference

  • BaseClientEvent<(Of <(T>)>) Members
  • Aurigma.ImageUploader Namespace


BaseClientEvent(T) Members

BaseClientEvent<(Of <(T>)>) Members

  • Collapse All Sections
  • BaseClientEvent<(Of <(T>)>) Class
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The BaseClientEvent<(Of <(T>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | BaseClientEvent<(Of <(T>)>) | Overloaded.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | EventName | Gets or sets a name of the client-side event.
Public property | HandlerName | Gets or sets a name of the client-side event handler.

See Also

Reference

  • BaseClientEvent<(Of <(T>)>) Class
  • Aurigma.ImageUploader Namespace


BaseClientEvent(T) Constructor

BaseClientEvent<(Of <(T>)>) Constructor

  • Collapse All Sections
  • BaseClientEvent<(Of <(T>)>) Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | BaseClientEvent<(Of <(T>)>)()()() | Creates and initializes an instance of the BaseClientEvent<(Of <(T>)>) class.
Public method | BaseClientEvent<(Of <(T>)>)(T, String) | Creates and initializes an instance of the BaseClientEvent<(Of <(T>)>) class.

See Also

Reference

  • BaseClientEvent<(Of <(T>)>) Class
  • BaseClientEvent<(Of <(T>)>) Members
  • Aurigma.ImageUploader Namespace


BaseClientEvent(T) Constructor

BaseClientEvent<(Of <(T>)>) Constructor

  • Collapse All Sections
  • BaseClientEvent<(Of <(T>)>) Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the BaseClientEvent<(Of <(T>)>) class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public BaseClientEvent()

See Also

Reference

  • BaseClientEvent<(Of <(T>)>) Class
  • BaseClientEvent<(Of <(T>)>) Overload
  • Aurigma.ImageUploader Namespace


BaseClientEvent(T) Constructor (T, String)

BaseClientEvent<(Of <(T>)>) Constructor (T, String)

  • Collapse All Sections
  • BaseClientEvent<(Of <(T>)>) Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the BaseClientEvent<(Of <(T>)>) class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New ( _
    eventName As T, _
    handlerName As String _
)

C#

public BaseClientEvent(
    T eventName,
    string handlerName
)

Parameters

eventName

Type: T

The name of the client-side event.

handlerName

Type: System..::.String

The name of the client-side event handler.

See Also

Reference

  • BaseClientEvent<(Of <(T>)>) Class
  • BaseClientEvent<(Of <(T>)>) Overload
  • Aurigma.ImageUploader Namespace


BaseClientEvent(T) Properties

BaseClientEvent<(Of <(T>)>) Properties

  • Collapse All Sections
  • BaseClientEvent<(Of <(T>)>) Class
  • See Also
  • Language Filter ( all languages )

The BaseClientEvent<(Of <(T>)>) type exposes the following members.

Properties

 | Name | Description
Public property | EventName | Gets or sets a name of the client-side event.
Public property | HandlerName | Gets or sets a name of the client-side event handler.

See Also

Reference

  • BaseClientEvent<(Of <(T>)>) Class
  • Aurigma.ImageUploader Namespace


EventName Property

BaseClientEvent<(Of <(T>)>)..::.EventName Property

  • Collapse All Sections
  • BaseClientEvent<(Of <(T>)>) Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a name of the client-side event.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EventName As T

C#

public T EventName { get; set; }

Property Value

Type: [T]

The name of the client-side event.

See Also

Reference

  • BaseClientEvent<(Of <(T>)>) Class
  • Aurigma.ImageUploader Namespace


HandlerName Property

BaseClientEvent<(Of <(T>)>)..::.HandlerName Property

  • Collapse All Sections
  • BaseClientEvent<(Of <(T>)>) Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a name of the client-side event handler.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property HandlerName As String

C#

public string HandlerName { get; set; }

Property Value

Type: System..::.String

The name of the client-side event handler.

See Also

Reference

  • BaseClientEvent<(Of <(T>)>) Class
  • Aurigma.ImageUploader Namespace


BaseControl Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This is a base class for all Image Uploader visual controls.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustInherit Class BaseControl _
    Inherits Control _
    Implements INamingContainer

C#

public abstract class BaseControl : Control, INamingContainer

Remarks

BaseControl is an abstract class which implements common functionality for Image Uploader visual controls. You cannot instantiate objects of this class directly.

Inheritance Hierarchy

System..::.Object L System.Web.UI..::.Control L Aurigma.ImageUploader..::.BaseControl L Aurigma.ImageUploader..::.Thumbnail L Aurigma.ImageUploader..::.BaseUploadControl

See Also

Reference

  • BaseControl Members
  • Aurigma.ImageUploader Namespace
  • BaseControl PHP Class


BaseControl Members

  • BaseControl Class
  • Methods
  • Properties
  • Events
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The BaseControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddedControl | (Inherited from Control.)
Protected method | AddParsedSubObject | (Inherited from Control.)
Public method | ApplyStyleSheetSkin | (Inherited from Control.)
Protected method | BuildProfileTree | (Inherited from Control.)
Protected method | ClearChildControlState | (Inherited from Control.)
Protected method | ClearChildState | (Inherited from Control.)
Protected method | ClearChildViewState | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | DataBind | Overloaded.
Protected method | DataBindChildren | (Inherited from Control.)
Public method | Dispose | (Inherited from Control.)
Protected method | EnsureChildControls | (Inherited from Control.)
Protected method | EnsureID | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindControl | Overloaded.
Public method | Focus | (Inherited from Control.)
Protected method | GetDesignModeState | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasControls | (Inherited from Control.)
Protected method | HasEvents | (Inherited from Control.)
Protected method | IsLiteralContent | (Inherited from Control.)
Protected method | LoadControlState | (Inherited from Control.)
Protected method | LoadViewState | (Inherited from Control.)
Protected method | MapPathSecure | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnBubbleEvent | (Inherited from Control.)
Protected method | OnDataBinding | (Inherited from Control.)
Protected method | OnInit | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Control.)
Protected method | OnPreRender | (Inherited from Control.)
Protected method | OnUnload | (Inherited from Control.)
Protected method | OpenFile | (Inherited from Control.)
Protected method | RaiseBubbleEvent | (Inherited from Control.)
Public method | RegisterClientScripts | Registers Image Uploader client-side scripts.
Protected method | RemovedControl | (Inherited from Control.)
Protected method | Render | (Inherited from Control.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderControl | Overloaded.
Protected method | ResolveAdapter | (Inherited from Control.)
Public method | ResolveClientUrl | (Inherited from Control.)
Public method | ResolveUrl | (Inherited from Control.)
Protected method | SaveControlState | (Inherited from Control.)
Protected method | SaveViewState | (Inherited from Control.)
Protected method | SetDesignModeState | (Inherited from Control.)
Public method | SetRenderMethodDelegate | (Inherited from Control.)
Public method | ToString | (Inherited from Object.)
Protected method | TrackViewState | (Inherited from Control.)

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | DebugScriptLevel | Gets or sets a debug level.
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0.
Protected property | DesignMode | (Inherited from Control.)
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | ManualRendering | Gets or sets a value indicating whether the control should be created but not rendered.
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Events

 | Name | Description
Public event | DataBinding | (Inherited from Control.)
Public event | Disposed | (Inherited from Control.)
Public event | Init | (Inherited from Control.)
Public event | Load | (Inherited from Control.)
Public event | PreRender | (Inherited from Control.)
Public event | Unload | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • BaseControl Class
  • Aurigma.ImageUploader Namespace


BaseControl Methods

  • BaseControl Class
  • See Also
  • Language Filter ( all languages )

The BaseControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddedControl | (Inherited from Control.)
Protected method | AddParsedSubObject | (Inherited from Control.)
Public method | ApplyStyleSheetSkin | (Inherited from Control.)
Protected method | BuildProfileTree | (Inherited from Control.)
Protected method | ClearChildControlState | (Inherited from Control.)
Protected method | ClearChildState | (Inherited from Control.)
Protected method | ClearChildViewState | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | DataBind | Overloaded.
Protected method | DataBindChildren | (Inherited from Control.)
Public method | Dispose | (Inherited from Control.)
Protected method | EnsureChildControls | (Inherited from Control.)
Protected method | EnsureID | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindControl | Overloaded.
Public method | Focus | (Inherited from Control.)
Protected method | GetDesignModeState | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasControls | (Inherited from Control.)
Protected method | HasEvents | (Inherited from Control.)
Protected method | IsLiteralContent | (Inherited from Control.)
Protected method | LoadControlState | (Inherited from Control.)
Protected method | LoadViewState | (Inherited from Control.)
Protected method | MapPathSecure | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnBubbleEvent | (Inherited from Control.)
Protected method | OnDataBinding | (Inherited from Control.)
Protected method | OnInit | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Control.)
Protected method | OnPreRender | (Inherited from Control.)
Protected method | OnUnload | (Inherited from Control.)
Protected method | OpenFile | (Inherited from Control.)
Protected method | RaiseBubbleEvent | (Inherited from Control.)
Public method | RegisterClientScripts | Registers Image Uploader client-side scripts.
Protected method | RemovedControl | (Inherited from Control.)
Protected method | Render | (Inherited from Control.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderControl | Overloaded.
Protected method | ResolveAdapter | (Inherited from Control.)
Public method | ResolveClientUrl | (Inherited from Control.)
Public method | ResolveUrl | (Inherited from Control.)
Protected method | SaveControlState | (Inherited from Control.)
Protected method | SaveViewState | (Inherited from Control.)
Protected method | SetDesignModeState | (Inherited from Control.)
Public method | SetRenderMethodDelegate | (Inherited from Control.)
Public method | ToString | (Inherited from Object.)
Protected method | TrackViewState | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)

See Also

Reference

  • BaseControl Class
  • Aurigma.ImageUploader Namespace


RegisterClientScripts Method

BaseControl..::.RegisterClientScripts Method

  • Collapse All Sections
  • BaseControl Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Registers Image Uploader client-side scripts.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub RegisterClientScripts ( _
    scripts As IEnumerable(Of String) _
)

C#

public void RegisterClientScripts(
    IEnumerable<string> scripts
)

Parameters

scripts

Type: System.Collections.Generic..::.IEnumerable <(Of <( String >)>)

An array of Image Uploader client-side scripts to register.

See Also

Reference

  • BaseControl Class
  • Aurigma.ImageUploader Namespace


BaseControl Properties

  • BaseControl Class
  • See Also
  • Language Filter ( all languages )

The BaseControl type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | DebugScriptLevel | Gets or sets a debug level.
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0.
Protected property | DesignMode | (Inherited from Control.)
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | ManualRendering | Gets or sets a value indicating whether the control should be created but not rendered.
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • BaseControl Class
  • Aurigma.ImageUploader Namespace


DebugScriptLevel Property

BaseControl..::.DebugScriptLevel Property

  • Collapse All Sections
  • BaseControl Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a debug level.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DebugScriptLevel As Integer

C#

public int DebugScriptLevel { get; set; }

Property Value

Type: System..::.Int32

The debug level. The following values are supported:

Value | Description
0 | Show no messages at all.
1 | Show errors only.
2 | Show errors and debug messages from Image Uploader.
3 | Show errors, debug messages from Image Uploader, and information messages.
Note

If DebugScriptLevel is greater than 0, the uncompressed client-side scripts are used.

Default value is 0.

See Also

Reference

  • BaseControl Class
  • Aurigma.ImageUploader Namespace
  • BaseControl.DebugScriptLevel PHP Property


DebugScriptMode Property

BaseControl..::.DebugScriptMode Property

  • Collapse All Sections
  • BaseControl Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DebugScriptMode As DebugScriptMode

C#

public DebugScriptMode DebugScriptMode { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.DebugScriptMode

The debug mode.

Default value is Default.

See Also

Reference

  • BaseControl Class
  • Aurigma.ImageUploader Namespace
  • BaseControl.DebugScriptMode PHP Property


ManualRendering Property

BaseControl..::.ManualRendering Property

  • Collapse All Sections
  • BaseControl Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the control should be created but not rendered.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ManualRendering As Boolean

C#

public bool ManualRendering { get; set; }

Property Value

Type: System..::.Boolean

If true, the control is created but not rendered. If so, you can render the control by calling the uploader.writeHtml or thumbnail.writeHtml method. If false, the control in rendered right after creation.

Default value is false.

See Also

Reference

  • BaseControl Class
  • Aurigma.ImageUploader Namespace
  • BaseControl.ManualRendering PHP Property


BaseExtender Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This is a base class for BaseUploaderExtender.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustInherit Class BaseExtender _
    Inherits Control

C#

public abstract class BaseExtender : Control

Remarks

BaseExtender is an abstract class which implements common functionality for Image Uploader extenders. You cannot instantiate objects of this class directly.

Inheritance Hierarchy

System..::.Object L System.Web.UI..::.Control L Aurigma.ImageUploader..::.BaseExtender L Aurigma.ImageUploader..::.BaseUploaderExtender

See Also

Reference

  • BaseExtender Members
  • Aurigma.ImageUploader Namespace


BaseExtender Members

  • BaseExtender Class
  • Methods
  • Properties
  • Events
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The BaseExtender type exposes the following members.

Methods

 | Name | Description
Protected method | AddedControl | (Inherited from Control.)
Protected method | AddParsedSubObject | (Inherited from Control.)
Public method | ApplyStyleSheetSkin | (Inherited from Control.)
Protected method | BuildProfileTree | (Inherited from Control.)
Protected method | ClearChildControlState | (Inherited from Control.)
Protected method | ClearChildState | (Inherited from Control.)
Protected method | ClearChildViewState | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | DataBind | Overloaded.
Protected method | DataBindChildren | (Inherited from Control.)
Public method | Dispose | (Inherited from Control.)
Protected method | EnsureChildControls | (Inherited from Control.)
Protected method | EnsureID | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindControl | Overloaded.
Public method | Focus | (Inherited from Control.)
Protected method | GetDesignModeState | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasControls | (Inherited from Control.)
Protected method | HasEvents | (Inherited from Control.)
Protected method | IsLiteralContent | (Inherited from Control.)
Protected method | LoadControlState | (Inherited from Control.)
Protected method | LoadViewState | (Inherited from Control.)
Protected method | MapPathSecure | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnBubbleEvent | (Inherited from Control.)
Protected method | OnDataBinding | (Inherited from Control.)
Protected method | OnInit | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Control.)
Protected method | OnPreRender | (Inherited from Control.)
Protected method | OnUnload | (Inherited from Control.)
Protected method | OpenFile | (Inherited from Control.)
Protected method | RaiseBubbleEvent | (Inherited from Control.)
Protected method | RemovedControl | (Inherited from Control.)
Protected method | Render | (Inherited from Control.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderControl | Overloaded.
Protected method | ResolveAdapter | (Inherited from Control.)
Public method | ResolveClientUrl | (Inherited from Control.)
Public method | ResolveUrl | (Inherited from Control.)
Protected method | SaveControlState | (Inherited from Control.)
Protected method | SaveViewState | (Inherited from Control.)
Protected method | SetDesignModeState | (Inherited from Control.)
Public method | SetRenderMethodDelegate | (Inherited from Control.)
Public method | ToString | (Inherited from Object.)
Protected method | TrackViewState | (Inherited from Control.)

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Protected property | DesignMode | (Inherited from Control.)
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Public property | TargetControlID | Gets or sets an ID of the target control instance associated with this extender.
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Events

 | Name | Description
Public event | DataBinding | (Inherited from Control.)
Public event | Disposed | (Inherited from Control.)
Public event | Init | (Inherited from Control.)
Public event | Load | (Inherited from Control.)
Public event | PreRender | (Inherited from Control.)
Public event | Unload | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • BaseExtender Class
  • Aurigma.ImageUploader Namespace


BaseExtender Properties

  • BaseExtender Class
  • See Also
  • Language Filter ( all languages )

The BaseExtender type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Protected property | DesignMode | (Inherited from Control.)
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Public property | TargetControlID | Gets or sets an ID of the target control instance associated with this extender.
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • BaseExtender Class
  • Aurigma.ImageUploader Namespace


TargetControlID Property

BaseExtender..::.TargetControlID Property

  • Collapse All Sections
  • BaseExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ID of the target control instance associated with this extender.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Overridable Property TargetControlID As String

C#

public virtual string TargetControlID { get; set; }

Property Value

Type: System..::.String

The ID of the target control instance associated with this extender.

See Also

Reference

  • BaseExtender Class
  • Aurigma.ImageUploader Namespace


BaseUploadControl Class

  • Members
  • See Also
  • Language Filter ( all languages )

This is a base class for Uploader.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustInherit Class BaseUploadControl _
    Inherits BaseControl

C#

public abstract class BaseUploadControl : BaseControl

Remarks

BaseUploadControl is an abstract class which implements common functionality for the Uploader control. You cannot instantiate objects of this class directly.

Inheritance Hierarchy

System..::.Object L System.Web.UI..::.Control L Aurigma.ImageUploader..::.BaseControl L Aurigma.ImageUploader..::.BaseUploadControl L Aurigma.ImageUploader..::.Uploader

See Also

Reference

  • BaseUploadControl Members
  • Aurigma.ImageUploader Namespace


BaseUploadControl Members

  • BaseUploadControl Class
  • Methods
  • Properties
  • Events
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The BaseUploadControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddedControl | (Inherited from Control.)
Protected method | AddParsedSubObject | (Inherited from Control.)
Public method | ApplyStyleSheetSkin | (Inherited from Control.)
Protected method | BuildProfileTree | (Inherited from Control.)
Protected method | ClearChildControlState | (Inherited from Control.)
Protected method | ClearChildState | (Inherited from Control.)
Protected method | ClearChildViewState | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | DataBind | Overloaded.
Protected method | DataBindChildren | (Inherited from Control.)
Public method | Dispose | (Inherited from Control.)
Protected method | EnsureChildControls | (Inherited from Control.)
Protected method | EnsureID | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindControl | Overloaded.
Public method | Focus | (Inherited from Control.)
Protected method | GetDesignModeState | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasControls | (Inherited from Control.)
Protected method | HasEvents | (Inherited from Control.)
Protected method | IsLiteralContent | (Inherited from Control.)
Protected method | LoadControlState | (Inherited from Control.)
Protected method | LoadViewState | (Inherited from Control.)
Protected method | MapPathSecure | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnBubbleEvent | (Inherited from Control.)
Protected method | OnDataBinding | (Inherited from Control.)
Protected method | OnInit | (Inherited from Control.)
Protected method | OnPreRender | (Inherited from Control.)
Protected method | OnUnload | (Inherited from Control.)
Protected method | OpenFile | (Inherited from Control.)
Protected method | RaiseBubbleEvent | (Inherited from Control.)
Public method | RegisterClientScripts | Registers Image Uploader client-side scripts. (Inherited from BaseControl.)
Protected method | RemovedControl | (Inherited from Control.)
Protected method | Render | (Inherited from Control.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderControl | Overloaded.
Protected method | ResolveAdapter | (Inherited from Control.)
Public method | ResolveClientUrl | (Inherited from Control.)
Public method | ResolveUrl | (Inherited from Control.)
Protected method | SaveControlState | (Inherited from Control.)
Protected method | SaveViewState | (Inherited from Control.)
Protected method | SetDesignModeState | (Inherited from Control.)
Public method | SetRenderMethodDelegate | (Inherited from Control.)
Public method | ToString | (Inherited from Object.)
Protected method | TrackViewState | (Inherited from Control.)

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | AutoSave | Gets or sets a value indicating whether uploaded files should be automatically saved.
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | DebugScriptLevel | Gets or sets a debug level. (Inherited from BaseControl.)
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0. (Inherited from BaseControl.)
Protected property | DesignMode | (Inherited from Control.)
Public property | DestinationFolder | Gets or sets a name of the folder to save uploaded files to.
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | ManualRendering | Gets or sets a value indicating whether the control should be created but not rendered. (Inherited from BaseControl.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Public property | TempDirectory | Gets or sets a path to the folder where the upload session cache should be saved.
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Events

 | Name | Description
Public event | AllFilesUploaded | Fires when the whole upload session completes.
Public event | DataBinding | (Inherited from Control.)
Public event | Disposed | (Inherited from Control.)
Public event | FileUploaded | Fires whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded.
Public event | Init | (Inherited from Control.)
Public event | Load | (Inherited from Control.)
Public event | PreRender | (Inherited from Control.)
Public event | Unload | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • BaseUploadControl Class
  • Aurigma.ImageUploader Namespace


BaseUploadControl Properties

  • BaseUploadControl Class
  • See Also
  • Language Filter ( all languages )

The BaseUploadControl type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | AutoSave | Gets or sets a value indicating whether uploaded files should be automatically saved.
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | DebugScriptLevel | Gets or sets a debug level. (Inherited from BaseControl.)
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0. (Inherited from BaseControl.)
Protected property | DesignMode | (Inherited from Control.)
Public property | DestinationFolder | Gets or sets a name of the folder to save uploaded files to.
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | ManualRendering | Gets or sets a value indicating whether the control should be created but not rendered. (Inherited from BaseControl.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Public property | TempDirectory | Gets or sets a path to the folder where the upload session cache should be saved.
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • BaseUploadControl Class
  • Aurigma.ImageUploader Namespace


AutoSave Property

BaseUploadControl..::.AutoSave Property

  • Collapse All Sections
  • BaseUploadControl Class
  • See Also
  • Language Filter ( all languages )

Gets or sets a value indicating whether uploaded files should be automatically saved.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property AutoSave As Boolean

C#

public bool AutoSave { get; set; }

Property Value

Type: System..::.Boolean

If true, Image Uploader ASP.NET saves uploaded files to the folder specified with the DestinationFolder property.

Default value is false.

See Also

Reference

  • BaseUploadControl Class
  • Aurigma.ImageUploader Namespace

Manual

  • Saving Uploaded Files in ASP.NET


DestinationFolder Property

BaseUploadControl..::.DestinationFolder Property

  • Collapse All Sections
  • BaseUploadControl Class
  • See Also
  • Language Filter ( all languages )

Gets or sets a name of the folder to save uploaded files to.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DestinationFolder As String

C#

public string DestinationFolder { get; set; }

Property Value

Type: System..::.String

The path where uploaded files should be saved if the autosave feature is enabled.

Default value is "".

Remarks

This property makes sense if AutoSave is set to true.

The path can be both absolute (C:\Uploads) or relative (/uploads, ./uploads, ../uploads). Additionally, the Web application root operator (~) is supported.

See Also

Reference

  • BaseUploadControl Class
  • Aurigma.ImageUploader Namespace

Manual

  • Saving Uploaded Files in ASP.NET


TempDirectory Property

BaseUploadControl..::.TempDirectory Property

  • Collapse All Sections
  • BaseUploadControl Class
  • See Also
  • Language Filter ( all languages )

Gets or sets a path to the folder where the upload session cache should be saved.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property TempDirectory As String

C#

public string TempDirectory { get; set; }

Property Value

Type: System..::.String

The path to the folder where BaseUploadControl saves the upload session cache.

Default value is "~/App_Data/UploadCache/".

Remarks

By the moment when the FileUploaded or AllFilesUploaded event is fired, the BaseUploadControl has already completed parsing of HTTP POST request(s) and saved files to a temporary folder specified by this property. Then, when you call the ConvertedFile.SaveAs(String) or ConvertedFile.MoveTo(String) method, files from this temporary folder are copied or moved to the specified path. Thus, it is recommended to select temporary folder on the same disk where your file storage is located.

This recommendation is also appropriate for autosave functionality.

See Also

Reference

  • BaseUploadControl Class
  • Aurigma.ImageUploader Namespace


BaseUploadControl Events

  • BaseUploadControl Class
  • See Also
  • Language Filter ( all languages )

The BaseUploadControl type exposes the following members.

Events

 | Name | Description
Public event | AllFilesUploaded | Fires when the whole upload session completes.
Public event | DataBinding | (Inherited from Control.)
Public event | Disposed | (Inherited from Control.)
Public event | FileUploaded | Fires whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded.
Public event | Init | (Inherited from Control.)
Public event | Load | (Inherited from Control.)
Public event | PreRender | (Inherited from Control.)
Public event | Unload | (Inherited from Control.)

See Also

Reference

  • BaseUploadControl Class
  • Aurigma.ImageUploader Namespace


AllFilesUploaded Event

BaseUploadControl..::.AllFilesUploaded Event

  • Collapse All Sections
  • BaseUploadControl Class
  • See Also
  • Language Filter ( all languages )

Fires when the whole upload session completes.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Event AllFilesUploaded As EventHandler(Of AllFilesUploadedEventArgs)

C#

public event EventHandler<AllFilesUploadedEventArgs> AllFilesUploaded

See Also

Reference

  • BaseUploadControl Class
  • Aurigma.ImageUploader Namespace
  • Aurigma.ImageUploader..::.AllFilesUploadedEventArgs

Manual

  • Saving Uploaded Files in ASP.NET


FileUploaded Event

BaseUploadControl..::.FileUploaded Event

  • Collapse All Sections
  • BaseUploadControl Class
  • See Also
  • Language Filter ( all languages )

Fires whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Event FileUploaded As EventHandler(Of FileUploadedEventArgs)

C#

public event EventHandler<FileUploadedEventArgs> FileUploaded

See Also

Reference

  • BaseUploadControl Class
  • Aurigma.ImageUploader Namespace
  • Aurigma.ImageUploader..::.FileUploadedEventArgs

Manual

  • Saving Uploaded Files in ASP.NET


BaseUploaderExtender Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This is a base class for all Image Uploader extenders.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustInherit Class BaseUploaderExtender _
    Inherits BaseExtender

C#

public abstract class BaseUploaderExtender : BaseExtender

Remarks

BaseUploaderExtender is an abstract class which implements common functionality for all Image Uploader extenders. You cannot instantiate objects of this class directly.

Inheritance Hierarchy

System..::.Object L System.Web.UI..::.Control L Aurigma.ImageUploader..::.BaseExtender L Aurigma.ImageUploader..::.BaseUploaderExtender L Aurigma.ImageUploader..::.InstallationProgress L Aurigma.ImageUploader.AmazonS3..::.AmazonS3Extender L Aurigma.ImageUploader.Nirvanix..::.NirvanixExtender

See Also

Reference

  • BaseUploaderExtender Members
  • Aurigma.ImageUploader Namespace


BaseUploaderExtender Members

  • BaseUploaderExtender Class
  • Constructors
  • Methods
  • Properties
  • Events
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The BaseUploaderExtender type exposes the following members.

Constructors

 | Name | Description
Public method | BaseUploaderExtender | Creates and initializes an instance of the BaseUploaderExtender class.

Methods

 | Name | Description
Protected method | AddedControl | (Inherited from Control.)
Protected method | AddParsedSubObject | (Inherited from Control.)
Public method | ApplyStyleSheetSkin | (Inherited from Control.)
Protected method | BuildProfileTree | (Inherited from Control.)
Protected method | ClearChildControlState | (Inherited from Control.)
Protected method | ClearChildState | (Inherited from Control.)
Protected method | ClearChildViewState | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | DataBind | Overloaded.
Protected method | DataBindChildren | (Inherited from Control.)
Public method | Dispose | (Inherited from Control.)
Protected method | EnsureChildControls | (Inherited from Control.)
Protected method | EnsureID | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindControl | Overloaded.
Public method | Focus | (Inherited from Control.)
Protected method | GetDesignModeState | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasControls | (Inherited from Control.)
Protected method | HasEvents | (Inherited from Control.)
Protected method | IsLiteralContent | (Inherited from Control.)
Protected method | LoadControlState | (Inherited from Control.)
Protected method | LoadViewState | (Inherited from Control.)
Protected method | MapPathSecure | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnBubbleEvent | (Inherited from Control.)
Protected method | OnDataBinding | (Inherited from Control.)
Protected method | OnInit | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Control.)
Protected method | OnPreRender | (Inherited from Control.)
Protected method | OnUnload | (Inherited from Control.)
Protected method | OpenFile | (Inherited from Control.)
Protected method | RaiseBubbleEvent | (Inherited from Control.)
Protected method | RemovedControl | (Inherited from Control.)
Protected method | Render | (Inherited from Control.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderControl | Overloaded.
Protected method | ResolveAdapter | (Inherited from Control.)
Public method | ResolveClientUrl | (Inherited from Control.)
Public method | ResolveUrl | (Inherited from Control.)
Protected method | SaveControlState | (Inherited from Control.)
Protected method | SaveViewState | (Inherited from Control.)
Protected method | SetDesignModeState | (Inherited from Control.)
Public method | SetRenderMethodDelegate | (Inherited from Control.)
Public method | ToString | (Inherited from Object.)
Protected method | TrackViewState | (Inherited from Control.)

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Protected property | DesignMode | (Inherited from Control.)
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Protected property | TargetControl | Gets a reference to the Uploader control instance associated with this extender.
Public property | TargetControlID | Gets or sets an ID of the Uploader control instance associated with this extender. (Overrides BaseExtender ..::. TargetControlID.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Events

 | Name | Description
Public event | DataBinding | (Inherited from Control.)
Public event | Disposed | (Inherited from Control.)
Public event | Init | (Inherited from Control.)
Public event | Load | (Inherited from Control.)
Public event | PreRender | (Inherited from Control.)
Public event | Unload | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • BaseUploaderExtender Class
  • Aurigma.ImageUploader Namespace


BaseUploaderExtender Constructor

  • BaseUploaderExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the BaseUploaderExtender class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public BaseUploaderExtender()

See Also

Reference

  • BaseUploaderExtender Class
  • Aurigma.ImageUploader Namespace


BaseUploaderExtender Properties

  • BaseUploaderExtender Class
  • See Also
  • Language Filter ( all languages )

The BaseUploaderExtender type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Protected property | DesignMode | (Inherited from Control.)
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Protected property | TargetControl | Gets a reference to the Uploader control instance associated with this extender.
Public property | TargetControlID | Gets or sets an ID of the Uploader control instance associated with this extender. (Overrides BaseExtender ..::. TargetControlID.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • BaseUploaderExtender Class
  • Aurigma.ImageUploader Namespace


TargetControl Property

BaseUploaderExtender..::.TargetControl Property

  • Collapse All Sections
  • BaseUploaderExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a reference to the Uploader control instance associated with this extender.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Protected ReadOnly Property TargetControl As Uploader

C#

protected Uploader TargetControl { get; }

Property Value

Type: Aurigma.ImageUploader..::.Uploader

The Uploader control instance associated with this extender.

See Also

Reference

  • BaseUploaderExtender Class
  • Aurigma.ImageUploader Namespace


TargetControlID Property

BaseUploaderExtender..::.TargetControlID Property

  • Collapse All Sections
  • BaseUploaderExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ID of the Uploader control instance associated with this extender.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Overrides Property TargetControlID As String

C#

public override string TargetControlID { get; set; }

Property Value

Type: System..::.String

The ID of the Uploader control instance associated with this extender.

See Also

Reference

  • BaseUploaderExtender Class
  • Aurigma.ImageUploader Namespace


BorderStyle Enumeration

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Specifies possible values for border styles.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration BorderStyle

C#

public enum BorderStyle

Members

Member name | Description
None | No border.
Fixed3D | 3D-like border style.
FixedSingle | Classic single line border style.

See Also

Reference

  • Aurigma.ImageUploader Namespace
  • Uploader..::.BorderStyle


ClientEvent Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a client-side event.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class ClientEvent _
    Inherits BaseClientEvent(Of ClientEventNames)

C#

public class ClientEvent : BaseClientEvent<ClientEventNames>

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.BaseClientEvent < (Of < ( ClientEventNames > ) > ) L Aurigma.ImageUploader..::.ClientEvent

See Also

Reference

  • ClientEvent Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.ClientEvents

Manual

  • Using Events


ClientEvent Members

  • ClientEvent Class
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The ClientEvent type exposes the following members.

Constructors

 | Name | Description
Public method | ClientEvent | Overloaded.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | EventName | Gets or sets a name of the client-side event. (Inherited from BaseClientEvent<(Of <(T>)>).)
Public property | HandlerName | Gets or sets a name of the client-side event handler. (Inherited from BaseClientEvent<(Of <(T>)>).)

See Also

Reference

  • ClientEvent Class
  • Aurigma.ImageUploader Namespace


ClientEvent Constructor

  • ClientEvent Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | ClientEvent()()() | Creates and initializes an instance of the ClientEvent class.
Public method | ClientEvent(ClientEventNames, String) | Creates and initializes an instance of the ClientEvent class.

See Also

Reference

  • ClientEvent Class
  • ClientEvent Members
  • Aurigma.ImageUploader Namespace


ClientEvent Constructor

  • ClientEvent Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the ClientEvent class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public ClientEvent()

See Also

Reference

  • ClientEvent Class
  • ClientEvent Overload
  • Aurigma.ImageUploader Namespace


ClientEvent Constructor (ClientEventNames, String)

  • ClientEvent Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the ClientEvent class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New ( _
    eventName As ClientEventNames, _
    handlerName As String _
)

C#

public ClientEvent(
    ClientEventNames eventName,
    string handlerName
)

Parameters

eventName

Type: Aurigma.ImageUploader..::.ClientEventNames

The name of the client-side event.

handlerName

Type: System..::.String

The name of the client-side event handler.

See Also

Reference

  • ClientEvent Class
  • ClientEvent Overload
  • Aurigma.ImageUploader Namespace


ClientEventCollection Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a collection of the Uploader client-side events.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class ClientEventCollection _
    Inherits Collection(Of ClientEvent)

C#

public class ClientEventCollection : Collection<ClientEvent>

Inheritance Hierarchy

System..::.Object L System.Collections.ObjectModel..::.Collection < (Of < ( ClientEvent > ) > ) L Aurigma.ImageUploader..::.ClientEventCollection

See Also

Reference

  • ClientEventCollection Members
  • Aurigma.ImageUploader Namespace


ClientEventCollection Members

  • ClientEventCollection Class
  • Methods
  • Properties
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The ClientEventCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from Collection <(Of <( ClientEvent >)>).)
Public method | Clear | (Inherited from Collection <(Of <( ClientEvent >)>).)
Protected method | ClearItems | (Inherited from Collection <(Of <( ClientEvent >)>).)
Public method | Contains | (Inherited from Collection <(Of <( ClientEvent >)>).)
Public method | CopyTo | (Inherited from Collection <(Of <( ClientEvent >)>).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection <(Of <( ClientEvent >)>).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection <(Of <( ClientEvent >)>).)
Public method | Insert | (Inherited from Collection <(Of <( ClientEvent >)>).)
Protected method | InsertItem | (Inherited from Collection <(Of <( ClientEvent >)>).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from Collection <(Of <( ClientEvent >)>).)
Public method | RemoveAt | (Inherited from Collection <(Of <( ClientEvent >)>).)
Protected method | RemoveItem | (Inherited from Collection <(Of <( ClientEvent >)>).)
Protected method | SetItem | (Inherited from Collection <(Of <( ClientEvent >)>).)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | (Inherited from Collection <(Of <( ClientEvent >)>).)
Public property | Item | (Inherited from Collection <(Of <( ClientEvent >)>).)
Protected property | Items | (Inherited from Collection <(Of <( ClientEvent >)>).)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::.Add | (Inherited from Collection <(Of <( ClientEvent >)>).)
Explicit interface implemetation | IList..::.Contains | (Inherited from Collection <(Of <( ClientEvent >)>).)
Explicit interface implemetation | ICollection..::.CopyTo | (Inherited from Collection <(Of <( ClientEvent >)>).)
Explicit interface implemetation | IEnumerable..::.GetEnumerator | (Inherited from Collection <(Of <( ClientEvent >)>).)
Explicit interface implemetation | IList..::.IndexOf | (Inherited from Collection <(Of <( ClientEvent >)>).)
Explicit interface implemetation | IList..::.Insert | (Inherited from Collection <(Of <( ClientEvent >)>).)
Explicit interface implemetation | IList..::.IsFixedSize | (Inherited from Collection <(Of <( ClientEvent >)>).)
Explicit interface implemetation | ICollection<(Of <(T>)>)..::.IsReadOnly | (Inherited from Collection <(Of <( ClientEvent >)>).)
Explicit interface implemetation | IList..::.IsReadOnly | (Inherited from Collection <(Of <( ClientEvent >)>).)
Explicit interface implemetation | ICollection..::.IsSynchronized | (Inherited from Collection <(Of <( ClientEvent >)>).)
Explicit interface implemetation | IList..::.Item | (Inherited from Collection <(Of <( ClientEvent >)>).)
Explicit interface implemetation | IList..::.Remove | (Inherited from Collection <(Of <( ClientEvent >)>).)
Explicit interface implemetation | ICollection..::.SyncRoot | (Inherited from Collection <(Of <( ClientEvent >)>).)

See Also

Reference

  • ClientEventCollection Class
  • Aurigma.ImageUploader Namespace


ClientEventNames Enumeration

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Specifies possible values for client-side event names.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration ClientEventNames

C#

public enum ClientEventNames

Members

Member name | Description
AfterPackageUpload | AfterPackageUpload event fires when the current package was uploaded successfully.
AfterSendRequest | AfterSendRequest event fires when the current POST request was uploaded successfully.
AfterUpload | AfterUpload event fires after successful upload.
BeforePackageUpload | BeforePackageUpload event fires when the current package is about to be uploaded.
BeforeSendRequest | BeforeSendRequest event fires when the current POST request is about to be uploaded.
BeforeUpload | BeforeUpload event fires when the upload is about to be started.
Error | Error event fires if some error occurred during the current upload session.
FolderChange | FolderChange event fires when a user goes to another folder.
InitComplete | InitComplete event fires when Image Uploader is completely created and initialized.
PreRender | PreRender event fires before the writeHtml or getHtml method is executed.
Progress | Progress event indicates the progress of the upload.
RestrictionFailed | RestrictionFailed event fires when some restriction is broken.
SelectionChange | SelectionChange event fires when a user changes a selection in the folder pane.
UploadFileCountChange | UploadFileCountChange event fires when a user adds/removes any files to/from the upload list.
ViewChange | ViewChange event fires when the view mode is changed.

See Also

Reference

  • Aurigma.ImageUploader Namespace
  • Uploader..::.ClientEvents


ContextMenu Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents Image Uploader context menu. Use this class to customize or localize context menu options.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class ContextMenu

C#

public class ContextMenu

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.ContextMenu

See Also

Reference

  • ContextMenu Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.ContextMenu
  • $au.contextMenu JavaScript Class
  • ContextMenu PHP Class

Manual

  • Customizing Appearance


ContextMenu Members

  • ContextMenu Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The ContextMenu type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ArrangeByDimensionsText | Gets or sets a caption of the Dimensions context menu item inside Arrange by group.
Public property | ArrangeByModifiedText | Gets or sets a caption of the Date modified context menu item inside Arrange by group.
Public property | ArrangeByNameText | Gets or sets a caption of the Name context menu item inside Arrange by group.
Public property | ArrangeByPathText | Gets or sets a caption of the Path context menu item inside Arrange by group.
Public property | ArrangeBySizeText | Gets or sets a caption of the Size context menu item inside Arrange by group.
Public property | ArrangeByText | Gets or sets a caption of the Sort by context menu.
Public property | ArrangeByTypeText | Gets or sets a caption of the Item type context menu item inside Arrange by group.
Public property | CheckAllText | Gets or sets a caption of the Check all context menu item.
Public property | CheckText | Gets or sets a caption of the Check context menu item.
Public property | DetailsViewText | Gets or sets a caption of the Details context menu item.
Public property | EditDescriptionText | Gets or sets a caption of the Edit description context menu item.
Public property | EditText | Gets or sets a caption of the Edit image context menu item.
Public property | ListViewText | Gets or sets a caption of the List context menu item.
Public property | OpenText | Gets or sets a caption of the Open context menu item.
Public property | PasteText | Gets or sets a caption of the Paste context menu item.
Public property | RemoveAllText | Gets or sets a caption of the Remove all from upload list context menu item.
Public property | RemoveText | Gets or sets a caption of the Remove from upload list context menu item.
Public property | ThumbnailsViewText | Gets or sets a caption of the Thumbnails context menu item.
Public property | TilesViewText | Gets or sets a caption of the Tiles context menu item.
Public property | UncheckAllText | Gets or sets a caption of the Uncheck all context menu item.
Public property | UncheckText | Gets or sets a caption of the Uncheck context menu item.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace


ContextMenu Properties

  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )

The ContextMenu type exposes the following members.

Properties

 | Name | Description
Public property | ArrangeByDimensionsText | Gets or sets a caption of the Dimensions context menu item inside Arrange by group.
Public property | ArrangeByModifiedText | Gets or sets a caption of the Date modified context menu item inside Arrange by group.
Public property | ArrangeByNameText | Gets or sets a caption of the Name context menu item inside Arrange by group.
Public property | ArrangeByPathText | Gets or sets a caption of the Path context menu item inside Arrange by group.
Public property | ArrangeBySizeText | Gets or sets a caption of the Size context menu item inside Arrange by group.
Public property | ArrangeByText | Gets or sets a caption of the Sort by context menu.
Public property | ArrangeByTypeText | Gets or sets a caption of the Item type context menu item inside Arrange by group.
Public property | CheckAllText | Gets or sets a caption of the Check all context menu item.
Public property | CheckText | Gets or sets a caption of the Check context menu item.
Public property | DetailsViewText | Gets or sets a caption of the Details context menu item.
Public property | EditDescriptionText | Gets or sets a caption of the Edit description context menu item.
Public property | EditText | Gets or sets a caption of the Edit image context menu item.
Public property | ListViewText | Gets or sets a caption of the List context menu item.
Public property | OpenText | Gets or sets a caption of the Open context menu item.
Public property | PasteText | Gets or sets a caption of the Paste context menu item.
Public property | RemoveAllText | Gets or sets a caption of the Remove all from upload list context menu item.
Public property | RemoveText | Gets or sets a caption of the Remove from upload list context menu item.
Public property | ThumbnailsViewText | Gets or sets a caption of the Thumbnails context menu item.
Public property | TilesViewText | Gets or sets a caption of the Tiles context menu item.
Public property | UncheckAllText | Gets or sets a caption of the Uncheck all context menu item.
Public property | UncheckText | Gets or sets a caption of the Uncheck context menu item.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace


ArrangeByDimensionsText Property

ContextMenu..::.ArrangeByDimensionsText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the Dimensions context menu item inside Arrange by group.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ArrangeByDimensionsText As String

C#

public string ArrangeByDimensionsText { get; set; }

Property Value

Type: System..::.String

The caption of the Dimensions context menu item.

Default value is "Dimensions".

Remarks

This menu item sorts files in a pane by image dimensions.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.arrangeByDimensionsText JavaScript Property
  • ContextMenu.ArrangeByDimensionsText PHP Property


ArrangeByModifiedText Property

ContextMenu..::.ArrangeByModifiedText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Date modified context menu item inside Arrange by group.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ArrangeByModifiedText As String

C#

public string ArrangeByModifiedText { get; set; }

Property Value

Type: System..::.String

The caption of the Date modified context menu item.

Default value is "Date modified".

Remarks

This menu item sorts files in a pane by last modified date.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.arrangeByModifiedText JavaScript Property
  • ContextMenu.ArrangeByModifiedText PHP Property


ArrangeByNameText Property

ContextMenu..::.ArrangeByNameText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Name context menu item inside Arrange by group.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ArrangeByNameText As String

C#

public string ArrangeByNameText { get; set; }

Property Value

Type: System..::.String

The caption of the Name context menu item.

Default value is "Name".

Remarks

This menu item sorts files in a pane by file name.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.arrangeByNameText JavaScript Property
  • ContextMenu.ArrangeByNameText PHP Property


ArrangeByPathText Property

ContextMenu..::.ArrangeByPathText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets or sets a caption of the Path context menu item inside Arrange by group.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ArrangeByPathText As String

C#

public string ArrangeByPathText { get; set; }

Property Value

Type: System..::.String

The caption of the Path context menu item.

Default value is "Path".

Remarks

This menu item sorts files in a pane by file path.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.arrangeByPathText JavaScript Property
  • ContextMenu.ArrangeByPathText PHP Property


ArrangeBySizeText Property

ContextMenu..::.ArrangeBySizeText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Size context menu item inside Arrange by group.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ArrangeBySizeText As String

C#

public string ArrangeBySizeText { get; set; }

Property Value

Type: System..::.String

The caption of the Size context menu item.

Default value is "Size".

Remarks

This menu item sorts files in a pane by file size.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.arrangeBySizeText JavaScript Property
  • ContextMenu.ArrangeBySizeText PHP Property


ArrangeByText Property

ContextMenu..::.ArrangeByText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Sort by context menu.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ArrangeByText As String

C#

public string ArrangeByText { get; set; }

Property Value

Type: System..::.String

The caption of the Sort by context menu item.

Default value is "Sort by".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.arrangeByText JavaScript Property
  • ContextMenu.ArrangeByText PHP Property


ArrangeByTypeText Property

ContextMenu..::.ArrangeByTypeText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Item type context menu item inside Arrange by group.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ArrangeByTypeText As String

C#

public string ArrangeByTypeText { get; set; }

Property Value

Type: System..::.String

The caption of the Item type context menu item.

Default value is "Type".

Remarks

This menu item sorts files in a pane by file type.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.arrangeByTypeText JavaScript Property
  • ContextMenu.ArrangeByTypeText PHP Property


CheckAllText Property

ContextMenu..::.CheckAllText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Check all context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CheckAllText As String

C#

public string CheckAllText { get; set; }

Property Value

Type: System..::.String

The caption of the Check all context menu item.

Default value is "Check all".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.checkAllText JavaScript Property
  • ContextMenu.CheckAllText PHP Property


CheckText Property

ContextMenu..::.CheckText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Check context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CheckText As String

C#

public string CheckText { get; set; }

Property Value

Type: System..::.String

The caption of the Check context menu item.

Default value is "Check".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.checkText JavaScript Property
  • ContextMenu.CheckText PHP Property


DetailsViewText Property

ContextMenu..::.DetailsViewText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Details context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DetailsViewText As String

C#

public string DetailsViewText { get; set; }

Property Value

Type: System..::.String

The caption of the Details context menu item.

Default value is "Details".

Remarks

This menu item switches the current pane view to Details mode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.detailsViewText JavaScript Property
  • ContextMenu.DetailsViewText PHP Property


EditDescriptionText Property

ContextMenu..::.EditDescriptionText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Edit description context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EditDescriptionText As String

C#

public string EditDescriptionText { get; set; }

Property Value

Type: System..::.String

The caption of the Edit description context menu item.

Default value is "Edit description...".

Remarks

This menu item opens the description editor.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.editDescriptionText JavaScript Property
  • ContextMenu.EditDescriptionText PHP Property


EditText Property

ContextMenu..::.EditText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Edit image context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EditText As String

C#

public string EditText { get; set; }

Property Value

Type: System..::.String

The caption of the Edit image context menu item.

Default value is "Edit image...".

Remarks

This menu item opens the image in the image editor.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.editText JavaScript Property
  • ContextMenu.EditText PHP Property


ListViewText Property

ContextMenu..::.ListViewText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the List context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ListViewText As String

C#

public string ListViewText { get; set; }

Property Value

Type: System..::.String

The caption of the List context menu item.

Default value is "List".

Remarks

This menu item switches the current pane view to List mode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.listViewText JavaScript Property
  • ContextMenu.ListViewText PHP Property


OpenText Property

ContextMenu..::.OpenText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Open context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property OpenText As String

C#

public string OpenText { get; set; }

Property Value

Type: System..::.String

The caption of the Open context menu item.

Default value is "Open".

Remarks

This menu item opens the file in the associated viewer software.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.openText JavaScript Property
  • ContextMenu.OpenText PHP Property


PasteText Property

ContextMenu..::.PasteText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets or sets a caption of the Paste context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property PasteText As String

C#

public string PasteText { get; set; }

Property Value

Type: System..::.String

The caption of the Paste context menu item.

Default value is "Paste".

Remarks

This menu item pastes an image (not a file) from a clipboard to the upload pane.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.pasteText JavaScript Property
  • ContextMenu.PasteText PHP Property


RemoveAllText Property

ContextMenu..::.RemoveAllText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Remove all from upload list context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property RemoveAllText As String

C#

public string RemoveAllText { get; set; }

Property Value

Type: System..::.String

The caption of the Remove all from upload list context menu item.

Default value is "Remove all".

Remarks

This menu item clears the upload list.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.removeAllText JavaScript Property
  • ContextMenu.RemoveAllText PHP Property


RemoveText Property

ContextMenu..::.RemoveText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Remove from upload list context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property RemoveText As String

C#

public string RemoveText { get; set; }

Property Value

Type: System..::.String

The caption of the Remove from upload list context menu item.

Default value is "Remove".

Remarks

This menu item removes selected items from the upload list.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.removeText JavaScript Property
  • ContextMenu.RemoveText PHP Property


ThumbnailsViewText Property

ContextMenu..::.ThumbnailsViewText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Thumbnails context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailsViewText As String

C#

public string ThumbnailsViewText { get; set; }

Property Value

Type: System..::.String

The caption of the Thumbnails context menu item.

Default value is "Thumbnails".

Remarks

This menu item switches the current pane view to Thumbnails mode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.thumbnailsViewText JavaScript Property
  • ContextMenu.ThumbnailsViewText PHP Property


TilesViewText Property

ContextMenu..::.TilesViewText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Tiles context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property TilesViewText As String

C#

public string TilesViewText { get; set; }

Property Value

Type: System..::.String

The caption of the Tiles context menu item.

Default value is "Tiles".

Remarks

This menu item switches the current pane view to Tiles mode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.tilesViewText JavaScript Property
  • ContextMenu.TilesViewText PHP Property


UncheckAllText Property

ContextMenu..::.UncheckAllText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Uncheck all context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UncheckAllText As String

C#

public string UncheckAllText { get; set; }

Property Value

Type: System..::.String

The caption of the Uncheck all context menu item.

Default value is "Uncheck all".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.uncheckAllText JavaScript Property
  • ContextMenu.UncheckAllText PHP Property


UncheckText Property

ContextMenu..::.UncheckText Property

  • Collapse All Sections
  • ContextMenu Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Uncheck context menu item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UncheckText As String

C#

public string UncheckText { get; set; }

Property Value

Type: System..::.String

The caption of the Uncheck context menu item.

Default value is "Uncheck".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader Namespace
  • $au.contextMenu.uncheckText JavaScript Property
  • ContextMenu.UncheckText PHP Property


ConvertedFile Class

  • Members
  • See Also
  • Language Filter ( all languages )

This class represents a converted file and exposes a number of properties and methods which provide an access to the converted file details (e.g. file name, size, conversion mode, and etc.) and allows saving it on a server.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class ConvertedFile

C#

public class ConvertedFile

Remarks

In terms of Image Uploader, converted file is a file uploaded for each of the user-selected files. These files are configured using the Converters property of the Uploader class.

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.ConvertedFile

See Also

Reference

  • ConvertedFile Members
  • Aurigma.ImageUploader Namespace
  • UploadedFile..::.ConvertedFiles
  • ConvertedFile PHP Class

Manual

  • Saving Uploaded Files in ASP.NET


ConvertedFile Members

  • ConvertedFile Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The ConvertedFile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveTo | Moves this converted file to the specified path.
Public method | SaveAs | Saves this converted file to the specified path.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | FileStream | Gets a Stream object that pointing to this converted file.
Public property | Height | Gets an actual height (in pixels) of this converted file if it is an image.
Public property | Index |
Public property | Mode | Gets a conversion mode actually applied to this converted file.
Public property | Name | Gets a name of this converted file.
Public property | Size | Gets a size of this converted file (in bytes).
Public property | Width | Gets an actual width (in pixels) of this converted file if it is an image.

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader Namespace


ConvertedFile Methods

  • ConvertedFile Class
  • See Also
  • Language Filter ( all languages )

The ConvertedFile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveTo | Moves this converted file to the specified path.
Public method | SaveAs | Saves this converted file to the specified path.
Public method | ToString | (Inherited from Object.)

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader Namespace


MoveTo Method

ConvertedFile..::.MoveTo Method

  • Collapse All Sections
  • ConvertedFile Class
  • See Also
  • Language Filter ( all languages )

Moves this converted file to the specified path.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub MoveTo ( _
    fileName As String _
)

C#

public void MoveTo(
    string fileName
)

Parameters

fileName

Type: System..::.String

The path to move this converted file to.

Remarks

The main difference between SaveAs(String) and MoveTo(String) methods is in the following. By the moment when the FileUploaded or AllFilesUploaded event is fired, ASP.NET server-side part of Image Uploader has already completed parsing of HTTP POST request(s) and saved files to a temporary folder which is configured via the TempDirectory property. When you trigger the MoveTo(String) method, it moves the file from this temporary folder to the specified one. However, when you call the SaveAs(String) method, it copies the file from a temporary location to the specified folder. So, the MoveTo(String) method works faster when you transfer the file from a temporary location (which is in the /App_Data folder, by default) to a location on the same disk. That is the difference.

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader Namespace
  • ConvertedFile..::.SaveAs(String)
  • BaseUploadControl.TempDirectory
  • UploadRequest.TempDirectory
  • UploadHandler.TempDirectory
  • ConvertedFile.moveTo(string) PHP Method


SaveAs Method

ConvertedFile..::.SaveAs Method

  • Collapse All Sections
  • ConvertedFile Class
  • See Also
  • Language Filter ( all languages )

Saves this converted file to the specified path.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub SaveAs ( _
    fileName As String _
)

C#

public void SaveAs(
    string fileName
)

Parameters

fileName

Type: System..::.String

The path to save this converted file to.

Remarks

The main difference between SaveAs(String) and MoveTo(String) methods is in the following. By the moment when the FileUploaded or AllFilesUploaded event is fired, ASP.NET server-side part of Image Uploader has already completed parsing of HTTP POST request(s) and saved files to a temporary folder which is configured via the TempDirectory property. When you trigger the MoveTo(String) method, it moves the file from this temporary folder to the specified one. However, when you call the SaveAs(String) method, it copies the file from a temporary location to the specified folder. So, the MoveTo(String) method works faster when you transfer the file from a temporary location (which is in the /App_Data folder, by default) to a location on the same disk. That is the difference.

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader Namespace
  • ConvertedFile..::.MoveTo(String)
  • BaseUploadControl.TempDirectory
  • UploadRequest.TempDirectory
  • UploadHandler.TempDirectory


ConvertedFile Properties

  • ConvertedFile Class
  • See Also
  • Language Filter ( all languages )

The ConvertedFile type exposes the following members.

Properties

 | Name | Description
Public property | FileStream | Gets a Stream object that pointing to this converted file.
Public property | Height | Gets an actual height (in pixels) of this converted file if it is an image.
Public property | Index |
Public property | Mode | Gets a conversion mode actually applied to this converted file.
Public property | Name | Gets a name of this converted file.
Public property | Size | Gets a size of this converted file (in bytes).
Public property | Width | Gets an actual width (in pixels) of this converted file if it is an image.

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader Namespace


FileStream Property

ConvertedFile..::.FileStream Property

  • Collapse All Sections
  • ConvertedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a Stream object that pointing to this converted file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property FileStream As Stream

C#

public Stream FileStream { get; }

Property Value

Type: System.IO..::.Stream

A stream pointing to this converted file.

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader Namespace


Height Property

ConvertedFile..::.Height Property

  • Collapse All Sections
  • ConvertedFile Class
  • See Also
  • Language Filter ( all languages )

Gets an actual height (in pixels) of this converted file if it is an image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Height As Integer

C#

public int Height { get; }

Property Value

Type: System..::.Int32

The actual height of this converted file if it is an image. Otherwise, this property returns 0.

Remarks

Depending on the ThumbnailFitMode, this value may differ from the value specified through the ThumbnailHeight property. This happens because Image Uploader preserves the aspect ratio of the image and not always can use the same dimensions as specified in the converter parameters.

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader Namespace
  • ConvertedFile.Height PHP Property


Index Property

ConvertedFile..::.Index Property

  • Collapse All Sections
  • ConvertedFile Class
  • See Also
  • Language Filter ( all languages )

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Index As Integer

C#

public int Index { get; }

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader Namespace


Mode Property

ConvertedFile..::.Mode Property

  • Collapse All Sections
  • ConvertedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a conversion mode actually applied to this converted file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Mode As String

C#

public string Mode { get; }

Property Value

Type: System..::.String

The mode of this converted file. Possible values are:

  • sourceFile - means that this converted file is a copy of the original file.
  • thumbnail - means that this converted file is a resized copy of the original file if it is an image.
  • icon - means that this converted file is a system icon associated with the original file type.
  • zip - means that this converted file is a ZIP archive of the original file.
  • none - means that this converted file was not created.

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader Namespace
  • ConvertedFile.Mode PHP Property


Name Property

ConvertedFile..::.Name Property

  • Collapse All Sections
  • ConvertedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a name of this converted file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Name As String

C#

public string Name { get; }

Property Value

Type: System..::.String

The name of this converted file.

Remarks

Depending on the Mode value this property returns one of the following names:

  • name.ext for sourceFile mode.
  • name.ext_ThumbnailX.jpg for thumbnail mode.
  • name.ext_IconX.jpg for icon mode.
  • name.ext_CompressedX.zip for zip mode.

Where X is a zero-based index of the Converter used to create this converted file.

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader Namespace
  • ConvertedFile.Name PHP Property


Size Property

ConvertedFile..::.Size Property

  • Collapse All Sections
  • ConvertedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a size of this converted file (in bytes).

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Size As Integer

C#

public int Size { get; }

Property Value

Type: System..::.Int32

The size of this converted file (in bytes).

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader Namespace
  • ConvertedFile.Size PHP Property


Width Property

ConvertedFile..::.Width Property

  • Collapse All Sections
  • ConvertedFile Class
  • See Also
  • Language Filter ( all languages )

Gets an actual width (in pixels) of this converted file if it is an image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Width As Integer

C#

public int Width { get; }

Property Value

Type: System..::.Int32

The actual width of this converted file if it is an image. Otherwise, this property returns 0.

Remarks

Depending on the ThumbnailFitMode, this value may differ from the value specified through the ThumbnailWidth property. This happens because Image Uploader preserves the aspect ratio of the image and not always can use the same dimensions as specified in the converter parameters.

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader Namespace
  • ConvertedFile.Width PHP Property


ConvertedFileCollection Class

  • Members
  • See Also
  • Language Filter ( all languages )

This class represents a collection of converted files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class ConvertedFileCollection _
    Implements IEnumerable(Of ConvertedFile), IEnumerable

C#

public class ConvertedFileCollection : IEnumerable<ConvertedFile>,
    IEnumerable

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.ConvertedFileCollection

See Also

Reference

  • ConvertedFileCollection Members
  • Aurigma.ImageUploader Namespace


ConvertedFileCollection Members

  • ConvertedFileCollection Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The ConvertedFileCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Get | Returns a converted file at the specified index.
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Overloaded.

See Also

Reference

  • ConvertedFileCollection Class
  • Aurigma.ImageUploader Namespace


ConvertedFileCollection Methods

  • ConvertedFileCollection Class
  • See Also
  • Language Filter ( all languages )

The ConvertedFileCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Get | Returns a converted file at the specified index.
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Reference

  • ConvertedFileCollection Class
  • Aurigma.ImageUploader Namespace


Get Method

ConvertedFileCollection..::.Get Method

  • Collapse All Sections
  • ConvertedFileCollection Class
  • See Also
  • Language Filter ( all languages )

Returns a converted file at the specified index.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Function Get ( _
    index As Integer _
) As ConvertedFile

C#

public ConvertedFile Get(
    int index
)

Parameters

index

Type: System..::.Int32

The zero-based index of the converted file to get.

Return Value

Type: Aurigma.ImageUploader..::.ConvertedFile

The converted file at the specified index.

See Also

Reference

  • ConvertedFileCollection Class
  • Aurigma.ImageUploader Namespace


GetEnumerator Method

ConvertedFileCollection..::.GetEnumerator Method

  • Collapse All Sections
  • ConvertedFileCollection Class
  • See Also
  • Language Filter ( all languages )

Returns an enumerator that iterates through this collection.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Function GetEnumerator As IEnumerator(Of ConvertedFile)

C#

public IEnumerator<ConvertedFile> GetEnumerator()

Return Value

Type: System.Collections.Generic..::.IEnumerator<(Of <(T>)>)

The IEnumerator<(Of <(T>)>) object that can be used to iterate through this collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

Reference

  • ConvertedFileCollection Class
  • Aurigma.ImageUploader Namespace


ConvertedFileCollection Properties

  • ConvertedFileCollection Class
  • See Also
  • Language Filter ( all languages )

Properties

 | Name | Description
Public property | Item | Overloaded.

See Also

Reference

  • ConvertedFileCollection Class
  • Aurigma.ImageUploader Namespace


Item Property

ConvertedFileCollection..::.Item Property

  • Collapse All Sections
  • ConvertedFileCollection Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public property | Item[([(Int32])]) | Gets a converted file at the specified index.
Public property | Item[([(String])]) | Gets a converted file with the specified field name.

See Also

Reference

  • ConvertedFileCollection Class
  • ConvertedFileCollection Members
  • Aurigma.ImageUploader Namespace


Item Property (Int32)

ConvertedFileCollection..::.Item Property (Int32)

  • Collapse All Sections
  • ConvertedFileCollection Class
  • See Also
  • Language Filter ( all languages )

Gets a converted file at the specified index.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Default Property Item ( _
    index As Integer _
) As ConvertedFile

C#

public ConvertedFile this[
    int index
] { get; }

Parameters

index

Type: System..::.Int32

Property Value

Type: Aurigma.ImageUploader..::.ConvertedFile

The converted file at the specified index.

See Also

Reference

  • ConvertedFileCollection Class
  • Item Overload
  • Aurigma.ImageUploader Namespace


Item Property (String)

ConvertedFileCollection..::.Item Property (String)

  • Collapse All Sections
  • ConvertedFileCollection Class
  • See Also
  • Language Filter ( all languages )

Gets a converted file with the specified field name.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Default Property Item ( _
    name As String _
) As ConvertedFile

C#

public ConvertedFile this[
    string name
] { get; }

Parameters

name

Type: System..::.String

Property Value

Type: Aurigma.ImageUploader..::.ConvertedFile

The converted file with the specified field name.

See Also

Reference

  • ConvertedFileCollection Class
  • Item Overload
  • Aurigma.ImageUploader Namespace


Converter Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a file converter.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class Converter

C#

public class Converter

Remarks

Image Uploader allows sending so-called converted files for each of the user-selected files. These files are configured using the Converters property of the Uploader object. This property accepts a collection of Converter instances. Each converter describes one file (source, thumbnail, icon, or ZIP archive) to be uploaded for every file a user selects.

For example, you set the following collection of converters:

ASP.NET

<aur:Uploader ID="Uploader1" runat="server">
    <Converters>
        <aur:Converter Mode="*.*=SourceFile" />
        <aur:Converter Mode="*.*=Thumbnail;*.*=Icon"
            ThumbnailHeight="120"
            ThumbnailWidth="120"
            ThumbnailFitMode="Fit" />
    </Converters>
</aur:Uploader>

It means that Image Uploader will send an original file and its resized copy or icon. So if a user selects two files (a JPEG image and a PDF document) Image Uploader will send four files:

  • the JPEG image and the PDF file themselves,
  • a resized copy of the image and a PDF icon.

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.Converter

See Also

Reference

  • Converter Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.Converters
  • $au.converter JavaScript Class
  • Converter PHP Class

Manual

  • Configuring Files to be Uploaded


Converter Members

  • Converter Class
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The Converter type exposes the following members.

Constructors

 | Name | Description
Public method | Converter | Creates and initializes an instance of the Converter class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Mode | Gets or sets a conversion mode of this converter.
Public property | ThumbnailApplyCrop | Gets or sets a value indicating whether the thumbnail should be cropped.
Public property | ThumbnailBgColor | Gets or sets a background color of the thumbnail.
Public property | ThumbnailCompressOversizedOnly | Gets or sets a value indicating whether an original image should be uploaded as the thumbnail in case when original image dimensions and file size are not bigger than dimensions and file size of this thumbnail.
Public property | ThumbnailCopyExif | Gets or sets a value indicating whether the thumbnail should contain EXIF metadata copied from the original file.
Public property | ThumbnailCopyIptc | Gets or sets a value indicating whether the thumbnail should contain IPTC metadata copied from the original file.
Public property | ThumbnailFitMode | Gets or sets a fit mode of the thumbnail.
Public property | ThumbnailHeight | Gets or sets a height restriction for the thumbnail.
Public property | ThumbnailJpegQuality | Gets or sets a JPEG quality of the thumbnail.
Public property | ThumbnailKeepColorSpace | Gets or sets a value indicating whether to preserve original color space when creating the thumbnail.
Public property | ThumbnailResizeQuality | Gets or sets a resize quality of the thumbnail.
Public property | ThumbnailResolution | Gets or sets an image resolution of the thumbnail.
Public property | ThumbnailWatermark | Gets or sets a watermark of the thumbnail.
Public property | ThumbnailWidth | Gets or sets a width restriction for the thumbnail.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace


Converter Constructor

  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the Converter class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public Converter()

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace


Converter Properties

  • Converter Class
  • See Also
  • Language Filter ( all languages )

The Converter type exposes the following members.

Properties

 | Name | Description
Public property | Mode | Gets or sets a conversion mode of this converter.
Public property | ThumbnailApplyCrop | Gets or sets a value indicating whether the thumbnail should be cropped.
Public property | ThumbnailBgColor | Gets or sets a background color of the thumbnail.
Public property | ThumbnailCompressOversizedOnly | Gets or sets a value indicating whether an original image should be uploaded as the thumbnail in case when original image dimensions and file size are not bigger than dimensions and file size of this thumbnail.
Public property | ThumbnailCopyExif | Gets or sets a value indicating whether the thumbnail should contain EXIF metadata copied from the original file.
Public property | ThumbnailCopyIptc | Gets or sets a value indicating whether the thumbnail should contain IPTC metadata copied from the original file.
Public property | ThumbnailFitMode | Gets or sets a fit mode of the thumbnail.
Public property | ThumbnailHeight | Gets or sets a height restriction for the thumbnail.
Public property | ThumbnailJpegQuality | Gets or sets a JPEG quality of the thumbnail.
Public property | ThumbnailKeepColorSpace | Gets or sets a value indicating whether to preserve original color space when creating the thumbnail.
Public property | ThumbnailResizeQuality | Gets or sets a resize quality of the thumbnail.
Public property | ThumbnailResolution | Gets or sets an image resolution of the thumbnail.
Public property | ThumbnailWatermark | Gets or sets a watermark of the thumbnail.
Public property | ThumbnailWidth | Gets or sets a width restriction for the thumbnail.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace


Mode Property

Converter..::.Mode Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a conversion mode of this converter.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Mode As String

C#

public string Mode { get; set; }

Property Value

Type: System..::.String

The conversion mode of this converter.

Default value is "".

Remarks

This property specifies a format string for a desired conversion mode. It consists of masks=mode pairs separated by semicolon. Each pair includes the set of file masks separated by comma and the corresponding mode. In general, this string has the following syntax:

mask11,mask12,...=mode1;mask21,mask22,...=mode2;...

When Image Uploader prepares the upload request it parses the conversion mode format string from the beginning to the end and extracts such pairs. For each file selected for upload Image Uploader gives the first pair. If it finds the file mask in this pair which matches the file extension, it applies the corresponding mode. Otherwise, if no appropriate file mask found, Image Uploader checks the next pairs in the same manner.

Note

If there is no file mask corresponding to the original file extension or appropriate mode Image Uploader does not send this converted file.

Here is the list of supported conversion modes:

Value | Description
SourceFile | means that the selected file will be uploaded from a user's computer without any changes.
Thumbnail | works as follows. If the selected file is image, it will be resized using the parameters listed below and uploaded as JPEG file. Otherwise, a converted file will not be sent.
Icon | means that a system icon associated with the selected file will be uploaded.
Zip | means that a ZIP archive of the selected file will be uploaded.
None | means that no file will be uploaded.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.mode JavaScript Property
  • Converter.Mode PHP Property

Manual

  • Configuring Files to be Uploaded
  • Uploading Images


ThumbnailApplyCrop Property

Converter..::.ThumbnailApplyCrop Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the thumbnail should be cropped.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailApplyCrop As Boolean

C#

public bool ThumbnailApplyCrop { get; set; }

Property Value

Type: System..::.Boolean

If true, the thumbnail is cropped using the specified crop bounds.

Default value is false.

Remarks

In order to set a crop rectangle, select a region in the image editor or use the file.cropBounds property.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailApplyCrop JavaScript Property
  • Converter.ThumbnailApplyCrop PHP Property

Manual

  • Rotating and Cropping


ThumbnailBgColor Property

Converter..::.ThumbnailBgColor Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of the thumbnail.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailBgColor As Color

C#

public Color ThumbnailBgColor { get; set; }

Property Value

Type: System.Drawing..::.Color

A background color of the thumbnail. This color is used when the thumbnail should be created for an image with transparency.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #FFFFFF.

Remarks

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailBgColor JavaScript Property
  • Converter.ThumbnailBgColor PHP Property

Manual

  • Resizing and Recompressing


ThumbnailCompressOversizedOnly Property

Converter..::.ThumbnailCompressOversizedOnly Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether an original image should be uploaded as the thumbnail in case when original image dimensions and file size are not bigger than dimensions and file size of this thumbnail.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailCompressOversizedOnly As Boolean

C#

public bool ThumbnailCompressOversizedOnly { get; set; }

Property Value

Type: System..::.Boolean

If true and:

  • The original file is JPEG;
  • No watermark is applied;
  • The dimensions of the original file are not bigger than the dimensions of the thumbnail;
  • The size in bytes of the original file is not greater than the size of the thumbnail.

Then the original file will be sent instead of the thumbnail. In all other cases a thumbnail is created.

Default value is false.

Remarks

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailCompressOversizedOnly JavaScript Property
  • Converter.ThumbnailCompressOversizedOnly PHP Property

Manual

  • Resizing and Recompressing


ThumbnailCopyExif Property

Converter..::.ThumbnailCopyExif Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the thumbnail should contain EXIF metadata copied from the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailCopyExif As Boolean

C#

public bool ThumbnailCopyExif { get; set; }

Property Value

Type: System..::.Boolean

If true, the EXIF information is copied from the original file. Otherwise, EXIF metadata will not be preserved.

Default value is false.

Remarks

Note

Image Uploader Express and Professional do not preserve EXIF metadata while creating thumbnails. See the Comparison of Image Uploader Editions topic for details.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailCopyExif JavaScript Property
  • Converter.ThumbnailCopyExif PHP Property

Manual

  • Working with EXIF and IPTC Metadata


ThumbnailCopyIptc Property

Converter..::.ThumbnailCopyIptc Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the thumbnail should contain IPTC metadata copied from the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailCopyIptc As Boolean

C#

public bool ThumbnailCopyIptc { get; set; }

Property Value

Type: System..::.Boolean

If true, the IPTC information is copied from the original file. Otherwise, IPTC metadata will not be preserved.

Default value is false.

Remarks

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailCopyIptc JavaScript Property
  • Converter.ThumbnailCopyIptc PHP Property

Manual

  • Working with EXIF and IPTC Metadata


ThumbnailFitMode Property

Converter..::.ThumbnailFitMode Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a fit mode of the thumbnail.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailFitMode As ThumbnailFitMode

C#

public ThumbnailFitMode ThumbnailFitMode { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.ThumbnailFitMode

The fit mode of the thumbnail.

Default value is Fit.

Remarks

Note

Image Uploader Express and Professional restrict a size (width x height) of each created thumbnail to 3 and 5 megapixels respectively. For example, the size of 1500x1500 thumbnail is 2.25 megapixels (1500 pixels x 1500 pixels = 2.25 megapixels), so such thumbnail can be uploaded with Image Uploader Express. See the Comparison of Image Uploader Editions topic for details.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailFitMode JavaScript Property
  • Converter.ThumbnailFitMode PHP Property

Manual

  • Resizing and Recompressing


ThumbnailHeight Property

Converter..::.ThumbnailHeight Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height restriction for the thumbnail.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailHeight As Integer

C#

public int ThumbnailHeight { get; set; }

Property Value

Type: System..::.Int32

The height of the thumbnail.

Default value is 96.

Remarks

Note

Image Uploader Express and Professional restrict a size (width x height) of each created thumbnail to 3 and 5 megapixels respectively. For example, the size of 1500x1500 thumbnail is 2.25 megapixels (1500 pixels x 1500 pixels = 2.25 megapixels), so such thumbnail can be uploaded with Image Uploader Express. See the Comparison of Image Uploader Editions topic for details.

Read about the ThumbnailFitMode property for more detailed information on how this property affects the thumbnail size.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailHeight JavaScript Property
  • Converter.ThumbnailHeight PHP Property

Manual

  • Resizing and Recompressing


ThumbnailJpegQuality Property

Converter..::.ThumbnailJpegQuality Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a JPEG quality of the thumbnail.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailJpegQuality As Integer

C#

public int ThumbnailJpegQuality { get; set; }

Property Value

Type: System..::.Int32

The JPEG quality of the thumbnail in range from 0 (the worst quality) to 100 (the best quality).

Default value is 100.

Remarks

You can reduce a thumbnail file size by specifying the lower quality.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailJpegQuality JavaScript Property
  • Converter.ThumbnailJpegQuality PHP Property

Manual

  • Resizing and Recompressing


ThumbnailKeepColorSpace Property

Converter..::.ThumbnailKeepColorSpace Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to preserve original color space when creating the thumbnail.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailKeepColorSpace As Boolean

C#

public bool ThumbnailKeepColorSpace { get; set; }

Property Value

Type: System..::.Boolean

If true, the thumbnail is created in the original file color space. Otherwise, the thumbnail is created in RGB color space.

Default value is false.

Remarks

Note

Image Uploader Express and Professional do not keep original color space while creating thumbnails. See the Comparison of Image Uploader Editions topic for details.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailKeepColorSpace JavaScript Property
  • Converter.ThumbnailKeepColorSpace PHP Property

Manual

  • Resizing and Recompressing


ThumbnailResizeQuality Property

Converter..::.ThumbnailResizeQuality Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a resize quality of the thumbnail.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailResizeQuality As ResizeQuality

C#

public ResizeQuality ThumbnailResizeQuality { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.ResizeQuality

The resize quality of the thumbnail.

Default value is Medium.

Remarks

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailResizeQuality JavaScript Property
  • Converter.ThumbnailResizeQuality PHP Property

Manual

  • Resizing and Recompressing


ThumbnailResolution Property

Converter..::.ThumbnailResolution Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an image resolution of the thumbnail.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailResolution As Integer

C#

public int ThumbnailResolution { get; set; }

Property Value

Type: System..::.Int32

The image resolution of the thumbnail (in DPI). If 0 value is specified, the original image resolution is used.

Default value is 0.

Remarks

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailResolution JavaScript Property
  • Converter.ThumbnailResolution PHP Property

Manual

  • Resizing and Recompressing


ThumbnailWatermark Property

Converter..::.ThumbnailWatermark Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a watermark of the thumbnail.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailWatermark As String

C#

public string ThumbnailWatermark { get; set; }

Property Value

Type: System..::.String

The watermark of the thumbnail. Watermark string syntax is described in the Remarks section.

If an empty string is specified, watermark will not be drawn on the thumbnail.

Default value is "".

Remarks

The watermark string consists of several variables separated with a semicolon:

variable1=value1;variable2=value2;...

The following variables are supported:

Variable Description
Text

Watermark text. If the text contains semicolon or quotation mark characters enclose it in single (' ') or double (" ") quotes. Additionally, quotation marks (both single ' and double ") inside the text should be escaped with a backslash. For example, to get a Andrew's Photos; Vacation text, set this variable as follows:

Text="Andrew\'s Photos; Vacation"

Note

If both text and an image are used as watermarks, the text will always be rendered over the image.

Default value is an empty string.

When the text watermark is specified, the following parameter also make sense:

  • FillColor
  • Font
  • Size
  • Style
  • Position
  • OffsetX
  • OffsetY
  • Opacity
  • BackgroundColor
  • BackgroundMarginWidth
  • BackgroundMarginHeight
  • OutlineColor
  • OutlineWidth
FillColor

Font color. It has the same syntax as all Image Uploader color properties (i.e. HTML-style #rrggbb RGB value).

Default value is an empty string (the fill is transparent).

Font

Font name. This font should be installed on the client machine. That is why it is highly recommended to use some generic font like Arial, Verdana, etc.

Default value is Arial.

Size

Font size (in pixels).

Default value is 12.

Style

Font style. The following styles are supported:

  • Bold
  • Italic
  • Underlined

You can specify several styles separated with a comma. Example:

Style=Bold,Italic

Default value is an empty string (regular font is used).

ImageUrl

Url to an image that will be used as the watermark.

Note

If both text and an image are used as watermarks, the text will always be rendered over the image.

Default value is an empty string.

When the image watermark is specified, the following parameter also make sense:

  • Width
  • Height
  • Position
  • OffsetX
  • OffsetY
  • Opacity
Width

Width of the image that will be used as the watermark. The image will be resized to the specified dimensions as an ordinary thumbnail, that is, the image can only be downsized, and its proportions are kept.

Default value is an empty string (actual image width is used).

Height

Height of the image that will be used as the watermark. The image will be resized to the specified dimensions as an ordinary thumbnail, that is, the image can only be downsized, and its proportions are kept.

Default value is an empty string (actual image height is used).

Position

Watermark position. It can take one of the following values:

  • TopLeft - watermark will be drawn in the top left corner of an image.
  • TopCenter - watermark will be drawn in the center of the top of an image.
  • TopRight - watermark will be drawn in the right top corner of an image.
  • CenterLeft - watermark will be drawn in the center of the left edge of an image.
  • Center - watermark will be drawn in the center of an image.
  • CenterRight - watermark will be drawn in the center of the right edge of an image.
  • BottomLeft - watermark will be drawn in the bottom left corner of an image.
  • BottomCenter - watermark will be drawn in the center of the bottom of an image.
  • BottomRight - watermark will be drawn in the bottom right corner of an image.

Default value is BottomRight.

OffsetX

Horizontal offset (in pixels) of the watermark relatively the position it is anchored to (according to the Position variable).

Note

If horizontal position is left or center, coordinates direction is left-to-right. If it is right, coordinates direction is flipped to right-to-left.

Default value is 0 (no offset).

OffsetY

Vertical offset (in pixels) of the watermark relatively the position it is anchored to (according to the Position variable).

Note

If vertical position is top or center, coordinates direction is top-to-bottom. If it is bottom, coordinates direction is flipped to bottom-to-top.

Default value is 0 (no offset).

Opacity

Watermark opacity percentage. If 0, the watermark is totally transparent. If 100, the watermark is opaque. Values between 0 and 100 will produce watermark with various level of transparency.

This value works for all elements of watermark. There is no way to configure different opacity for background, text outline and text fill.

Default value is 100.

BackgroundColor

Background color. It has the same syntax as all Image Uploader color properties (i.e. HTML-style #rrggbb RGB value).

Default value is an empty string (the background is transparent).

BackgroundMarginWidth

Width of additional space outside of the watermark filled with background (in pixels).

Default value is 0.

BackgroundMarginHeight

Height of additional space outside of the watermark filled with background (in pixels).

Default value is 0.

OutlineColor

Text outline color. It has the same syntax as all Image Uploader color properties (i.e. HTML-style #rrggbb RGB value).

Default value is an empty string (the outline is transparent).

OutlineWidth

Width of the text outline.

Default value is 1.

Note

The watermark string is case insensitive.

Though you can set both image and text watermarks at the same time, it makes sense to use only one of them. For text watermarks the only required variable is Text. Here is an example of the watermark string which will draw green semi-transparent italic text Aurigma in the bottom left corner of an image:

ASP.NET

ThumbnailWatermark="Text=Aurigma;Opacity=75;FillColor=#00ff00;Position=BottomLeft;Style=Italic;Size=30"

For image watermarks ImageUrl, Width, and Height are required. Here is an example of semi-transparent logo drawn in the top tight corner of the image:

ASP.NET

ThumbnailWatermark="ImageUrl=http://localhost/watermark.png;Width=86;Height=63;Position=TopRight;Opacity=50"

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailWatermark JavaScript Property
  • Converter.ThumbnailWatermark PHP Property

Manual

  • Applying Watermarks


ThumbnailWidth Property

Converter..::.ThumbnailWidth Property

  • Collapse All Sections
  • Converter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width restriction for the thumbnail.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ThumbnailWidth As Integer

C#

public int ThumbnailWidth { get; set; }

Property Value

Type: System..::.Int32

The width of the thumbnail.

Default value is 96.

Remarks

Note

Image Uploader Express and Professional restrict a size (width x height) of each created thumbnail to 3 and 5 megapixels respectively. For example, the size of 1500x1500 thumbnail is 2.25 megapixels (1500 pixels x 1500 pixels = 2.25 megapixels), so such thumbnail can be uploaded with Image Uploader Express. See the Comparison of Image Uploader Editions topic for details.

Read about the ThumbnailFitMode property for more detailed information on how this property affects the thumbnail size.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Converter Class
  • Aurigma.ImageUploader Namespace
  • $au.converter.thumbnailWidth JavaScript Property
  • Converter.ThumbnailWidth PHP Property

Manual

  • Resizing and Recompressing


ConverterCollection Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a collection of file converters.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class ConverterCollection _
    Inherits Collection(Of Converter)

C#

public class ConverterCollection : Collection<Converter>

Remarks

You can use this class to work with converters at runtime.

Inheritance Hierarchy

System..::.Object L System.Collections.ObjectModel..::.Collection < (Of < ( Converter > ) > ) L Aurigma.ImageUploader..::.ConverterCollection

See Also

Reference

  • ConverterCollection Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.Converters
  • $au.converters JavaScript Class


ConverterCollection Members

  • ConverterCollection Class
  • Methods
  • Properties
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The ConverterCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from Collection <(Of <( Converter >)>).)
Public method | Clear | (Inherited from Collection <(Of <( Converter >)>).)
Protected method | ClearItems | (Inherited from Collection <(Of <( Converter >)>).)
Public method | Contains | (Inherited from Collection <(Of <( Converter >)>).)
Public method | CopyTo | (Inherited from Collection <(Of <( Converter >)>).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection <(Of <( Converter >)>).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection <(Of <( Converter >)>).)
Public method | Insert | (Inherited from Collection <(Of <( Converter >)>).)
Protected method | InsertItem | (Inherited from Collection <(Of <( Converter >)>).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from Collection <(Of <( Converter >)>).)
Public method | RemoveAt | (Inherited from Collection <(Of <( Converter >)>).)
Protected method | RemoveItem | (Inherited from Collection <(Of <( Converter >)>).)
Protected method | SetItem | (Inherited from Collection <(Of <( Converter >)>).)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | (Inherited from Collection <(Of <( Converter >)>).)
Public property | Item | (Inherited from Collection <(Of <( Converter >)>).)
Protected property | Items | (Inherited from Collection <(Of <( Converter >)>).)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::.Add | (Inherited from Collection <(Of <( Converter >)>).)
Explicit interface implemetation | IList..::.Contains | (Inherited from Collection <(Of <( Converter >)>).)
Explicit interface implemetation | ICollection..::.CopyTo | (Inherited from Collection <(Of <( Converter >)>).)
Explicit interface implemetation | IEnumerable..::.GetEnumerator | (Inherited from Collection <(Of <( Converter >)>).)
Explicit interface implemetation | IList..::.IndexOf | (Inherited from Collection <(Of <( Converter >)>).)
Explicit interface implemetation | IList..::.Insert | (Inherited from Collection <(Of <( Converter >)>).)
Explicit interface implemetation | IList..::.IsFixedSize | (Inherited from Collection <(Of <( Converter >)>).)
Explicit interface implemetation | ICollection<(Of <(T>)>)..::.IsReadOnly | (Inherited from Collection <(Of <( Converter >)>).)
Explicit interface implemetation | IList..::.IsReadOnly | (Inherited from Collection <(Of <( Converter >)>).)
Explicit interface implemetation | ICollection..::.IsSynchronized | (Inherited from Collection <(Of <( Converter >)>).)
Explicit interface implemetation | IList..::.Item | (Inherited from Collection <(Of <( Converter >)>).)
Explicit interface implemetation | IList..::.Remove | (Inherited from Collection <(Of <( Converter >)>).)
Explicit interface implemetation | ICollection..::.SyncRoot | (Inherited from Collection <(Of <( Converter >)>).)

See Also

Reference

  • ConverterCollection Class
  • Aurigma.ImageUploader Namespace


DebugScriptMode Enumeration

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration DebugScriptMode

C#

public enum DebugScriptMode

Members

Member name | Description
Default | When the control is about to display a message, it uses the Popup mode. If it is failed, the Console and then Alert modes are used until the message is displayed correctly.
Popup | All the messages will be shown in a popup window.
Console | All the messages will be logged in a browser console (e.g. Firebug) if it is available.
Alert | All the messages will be shown in alerts.

See Also

Reference

  • Aurigma.ImageUploader Namespace


DeleteFilesDialog Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

This class represents the delete confirmation dialog which appears in non-Internet Explorer browsers when Uploader..::.EnableOriginalFilesDeletion is true.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class DeleteFilesDialog

C#

public class DeleteFilesDialog

Remarks

Note

A difference between Image Uploader behavior in Internet Explorer and other supported browsers is the following. When Image Uploader deletes files in Internet Explorer, it moves them in the way specified in the Recycle Bin properties. By default, a standard delete confirmation dialog appears and files are moved to the Recycle Bin if a user clicks Yes. However, if Image Uploader deletes files in any of other supported browsers, the internal delete confirmation dialog appears and files are removed permanently when a user clicks Yes.

If the file cannot be deleted, the DeletingFilesError message appears.

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.DeleteFilesDialog

See Also

Reference

  • DeleteFilesDialog Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.EnableOriginalFilesDeletion
  • Uploader..::.EnableOriginalFilesDeletion
  • Uploader..::.DeleteFilesDialog
  • $au.deleteFilesDialog JavaScript Class
  • DeleteFilesDialog PHP Class


DeleteFilesDialog Members

  • DeleteFilesDialog Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The DeleteFilesDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Message | Gets or sets a message of the dialog which asks a user to confirm that they really want to delete uploaded files.
Public property | TitleText | Gets or sets a title of the dialog which asks a user to confirm that they really want to delete uploaded files.

See Also

Reference

  • DeleteFilesDialog Class
  • Aurigma.ImageUploader Namespace


DeleteFilesDialog Properties

  • DeleteFilesDialog Class
  • See Also
  • Language Filter ( all languages )

The DeleteFilesDialog type exposes the following members.

Properties

 | Name | Description
Public property | Message | Gets or sets a message of the dialog which asks a user to confirm that they really want to delete uploaded files.
Public property | TitleText | Gets or sets a title of the dialog which asks a user to confirm that they really want to delete uploaded files.

See Also

Reference

  • DeleteFilesDialog Class
  • Aurigma.ImageUploader Namespace


Message Property

DeleteFilesDialog..::.Message Property

  • Collapse All Sections
  • DeleteFilesDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a message of the dialog which asks a user to confirm that they really want to delete uploaded files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Message As String

C#

public string Message { get; set; }

Property Value

Type: System..::.String

The text of the message of the delete confirmation dialog.

Default value is "Are you sure you want to permanently delete uploaded items?".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • DeleteFilesDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.deleteFilesDialog.message JavaScript Property
  • DeleteFilesDialog.Message PHP Property


TitleText Property

DeleteFilesDialog..::.TitleText Property

  • Collapse All Sections
  • DeleteFilesDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a title of the dialog which asks a user to confirm that they really want to delete uploaded files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property TitleText As String

C#

public string TitleText { get; set; }

Property Value

Type: System..::.String

The text of the title of the delete confirmation dialog.

Default value is "Delete File".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • DeleteFilesDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.deleteFilesDialog.titleText JavaScript Property
  • DeleteFilesDialog.TitleText PHP Property


DescriptionEditor Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the description editor.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class DescriptionEditor

C#

public class DescriptionEditor

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.DescriptionEditor

See Also

Reference

  • DescriptionEditor Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.DescriptionEditor
  • $au.descriptionEditor JavaScript Class
  • DescriptionEditor PHP Class

Manual

  • Customizing Appearance


DescriptionEditor Members

  • DescriptionEditor Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The DescriptionEditor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | CancelHyperlinkText | Gets or sets a caption of the Cancel hyperlink on the dialog displayed when a user clicks the description icon on the pane item surface.
Public property | MaxTextLength | Gets or sets a description length.
Public property | OrEscLabelText | Gets or sets a text of the Or Esc label.
Public property | SaveButtonText | Gets or sets a caption of the Save button on the dialog displayed when a user clicks the description icon on the pane item surface.

See Also

Reference

  • DescriptionEditor Class
  • Aurigma.ImageUploader Namespace


DescriptionEditor Properties

  • DescriptionEditor Class
  • See Also
  • Language Filter ( all languages )

The DescriptionEditor type exposes the following members.

Properties

 | Name | Description
Public property | CancelHyperlinkText | Gets or sets a caption of the Cancel hyperlink on the dialog displayed when a user clicks the description icon on the pane item surface.
Public property | MaxTextLength | Gets or sets a description length.
Public property | OrEscLabelText | Gets or sets a text of the Or Esc label.
Public property | SaveButtonText | Gets or sets a caption of the Save button on the dialog displayed when a user clicks the description icon on the pane item surface.

See Also

Reference

  • DescriptionEditor Class
  • Aurigma.ImageUploader Namespace


CancelHyperlinkText Property

DescriptionEditor..::.CancelHyperlinkText Property

  • Collapse All Sections
  • DescriptionEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel hyperlink on the dialog displayed when a user clicks the description icon on the pane item surface.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CancelHyperlinkText As String

C#

public string CancelHyperlinkText { get; set; }

Property Value

Type: System..::.String

The caption of the Cancel hyperlink on the description editor.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • DescriptionEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.descriptionEditor.cancelHyperlinkText JavaScript Property
  • DescriptionEditor.CancelHyperlinkText PHP Property


MaxTextLength Property

DescriptionEditor..::.MaxTextLength Property

  • Collapse All Sections
  • DescriptionEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a description length.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MaxTextLength As Integer

C#

public int MaxTextLength { get; set; }

Property Value

Type: System..::.Int32

The maximum allowed number of symbols in user-provided descriptions.

Default value is 512.

See Also

Reference

  • DescriptionEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.descriptionEditor.maxTextLength JavaScript Property
  • DescriptionEditor.MaxTextLength PHP Property


OrEscLabelText Property

DescriptionEditor..::.OrEscLabelText Property

  • Collapse All Sections
  • DescriptionEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text of the Or Esc label.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property OrEscLabelText As String

C#

public string OrEscLabelText { get; set; }

Property Value

Type: System..::.String

The text of the Or Esc label.

Default value is " (or Esc)".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • DescriptionEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.descriptionEditor.orEscLabelText JavaScript Property
  • DescriptionEditor.OrEscLabelText PHP Property


SaveButtonText Property

DescriptionEditor..::.SaveButtonText Property

  • Collapse All Sections
  • DescriptionEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Save button on the dialog displayed when a user clicks the description icon on the pane item surface.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property SaveButtonText As String

C#

public string SaveButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the Save button on the description editor.

Default value is "Save".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • DescriptionEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.descriptionEditor.saveButtonText JavaScript Property
  • DescriptionEditor.SaveButtonText PHP Property


DetailsViewColumns Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class contains titles of columns displayed in the Details view.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class DetailsViewColumns

C#

public class DetailsViewColumns

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.DetailsViewColumns

See Also

Reference

  • DetailsViewColumns Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.DetailsViewColumns
  • $au.detailsViewColumns JavaScript Class
  • DetailsViewColumns PHP Class

Manual

  • Customizing Appearance


DetailsViewColumns Members

  • DetailsViewColumns Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The DetailsViewColumns type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DimensionsText | Gets or sets a title of the Image dimensions column in the Details view.
Public property | FileNameText | Gets or sets a title of the Name column in the Details view.
Public property | FileSizeText | Gets or sets a title of the Size column in the Details view.
Public property | FileTypeText | Gets or sets a title of the Type column in the Details view.
Public property | InfoText | Gets or sets a title of the Info column in the Details view.
Public property | LastModifiedText | Gets or sets a title of the Date modified column in the Details view.

See Also

Reference

  • DetailsViewColumns Class
  • Aurigma.ImageUploader Namespace


DetailsViewColumns Properties

  • DetailsViewColumns Class
  • See Also
  • Language Filter ( all languages )

The DetailsViewColumns type exposes the following members.

Properties

 | Name | Description
Public property | DimensionsText | Gets or sets a title of the Image dimensions column in the Details view.
Public property | FileNameText | Gets or sets a title of the Name column in the Details view.
Public property | FileSizeText | Gets or sets a title of the Size column in the Details view.
Public property | FileTypeText | Gets or sets a title of the Type column in the Details view.
Public property | InfoText | Gets or sets a title of the Info column in the Details view.
Public property | LastModifiedText | Gets or sets a title of the Date modified column in the Details view.

See Also

Reference

  • DetailsViewColumns Class
  • Aurigma.ImageUploader Namespace


DimensionsText Property

DetailsViewColumns..::.DimensionsText Property

  • Collapse All Sections
  • DetailsViewColumns Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Image dimensions column in the Details view.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DimensionsText As String

C#

public string DimensionsText { get; set; }

Property Value

Type: System..::.String

The title of the Image dimensions column in the Details view.

Default value is "Image dimensions".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • DetailsViewColumns Class
  • Aurigma.ImageUploader Namespace
  • $au.detailsViewColumns.dimensionsText JavaScript Property
  • DetailsViewColumns.DimensionsText PHP Property


FileNameText Property

DetailsViewColumns..::.FileNameText Property

  • Collapse All Sections
  • DetailsViewColumns Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Name column in the Details view.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FileNameText As String

C#

public string FileNameText { get; set; }

Property Value

Type: System..::.String

The title of the Name column in the Details view.

Default value is "Name".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • DetailsViewColumns Class
  • Aurigma.ImageUploader Namespace
  • $au.detailsViewColumns.fileNameText JavaScript Property
  • DetailsViewColumns.FileNameText PHP Property


FileSizeText Property

DetailsViewColumns..::.FileSizeText Property

  • Collapse All Sections
  • DetailsViewColumns Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Size column in the Details view.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FileSizeText As String

C#

public string FileSizeText { get; set; }

Property Value

Type: System..::.String

The title of the Size column in the Details view.

Default value is "Size".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • DetailsViewColumns Class
  • Aurigma.ImageUploader Namespace
  • $au.detailsViewColumns.fileSizeText JavaScript Property
  • DetailsViewColumns.FileSizeText PHP Property


FileTypeText Property

DetailsViewColumns..::.FileTypeText Property

  • Collapse All Sections
  • DetailsViewColumns Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Type column in the Details view.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FileTypeText As String

C#

public string FileTypeText { get; set; }

Property Value

Type: System..::.String

The title of the Type column in the Details view.

Default value is "Type".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • DetailsViewColumns Class
  • Aurigma.ImageUploader Namespace
  • $au.detailsViewColumns.fileTypeText JavaScript Property
  • DetailsViewColumns.FileTypeText PHP Property


InfoText Property

DetailsViewColumns..::.InfoText Property

  • Collapse All Sections
  • DetailsViewColumns Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Info column in the Details view.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property InfoText As String

C#

public string InfoText { get; set; }

Property Value

Type: System..::.String

The title of the Info column in the Details view.

Default value is "Info".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • DetailsViewColumns Class
  • Aurigma.ImageUploader Namespace
  • $au.detailsViewColumns.infoText JavaScript Property
  • DetailsViewColumns.InfoText PHP Property


LastModifiedText Property

DetailsViewColumns..::.LastModifiedText Property

  • Collapse All Sections
  • DetailsViewColumns Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Date modified column in the Details view.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property LastModifiedText As String

C#

public string LastModifiedText { get; set; }

Property Value

Type: System..::.String

The title of the Date modified column in the Details view.

Default value is "Date modified".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • DetailsViewColumns Class
  • Aurigma.ImageUploader Namespace
  • $au.detailsViewColumns.lastModifiedText JavaScript Property
  • DetailsViewColumns.LastModifiedText PHP Property


FileUploadedEventArgs Class

  • Members
  • See Also
  • Language Filter ( all languages )

This class provides data for BaseUploadControl.FileUploaded, UploadHandler.FileUploaded, and UploadRequest.FileUploaded events.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class FileUploadedEventArgs _
    Inherits EventArgs

C#

public class FileUploadedEventArgs : EventArgs

Remarks

BaseUploadControl.FileUploaded, UploadHandler.FileUploaded, and UploadRequest.FileUploaded events occur whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded.

Inheritance Hierarchy

System..::.Object L System..::.EventArgs L Aurigma.ImageUploader..::.FileUploadedEventArgs

See Also

Reference

  • FileUploadedEventArgs Members
  • Aurigma.ImageUploader Namespace


FileUploadedEventArgs Members

  • FileUploadedEventArgs Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The FileUploadedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | UploadedFile | Gets an UploadedFile instance contained all the converted files and metadata related to a particular user-selected file.

See Also

Reference

  • FileUploadedEventArgs Class
  • Aurigma.ImageUploader Namespace


FileUploadedEventArgs Properties

  • FileUploadedEventArgs Class
  • See Also
  • Language Filter ( all languages )

The FileUploadedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | UploadedFile | Gets an UploadedFile instance contained all the converted files and metadata related to a particular user-selected file.

See Also

Reference

  • FileUploadedEventArgs Class
  • Aurigma.ImageUploader Namespace


UploadedFile Property

FileUploadedEventArgs..::.UploadedFile Property

  • Collapse All Sections
  • FileUploadedEventArgs Class
  • See Also
  • Language Filter ( all languages )

Gets an UploadedFile instance contained all the converted files and metadata related to a particular user-selected file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property UploadedFile As UploadedFile

C#

public UploadedFile UploadedFile { get; }

Property Value

Type: Aurigma.ImageUploader..::.UploadedFile

The UploadedFile contained all the converted files and metadata related to a particular user-selected file.

See Also

Reference

  • FileUploadedEventArgs Class
  • Aurigma.ImageUploader Namespace


FolderPane Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the folder pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class FolderPane

C#

public class FolderPane

Remarks

All the properties of this class make sense in ThreePanes layout only.

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.FolderPane

See Also

Reference

  • FolderPane Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.FolderPane
  • $au.folderPane JavaScript Class
  • FolderPane PHP Class

Manual

  • Layouts
  • Customizing Appearance


FolderPane Members

  • FolderPane Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The FolderPane type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | FilterClearIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the search box icon.
Public property | FilterHintText | Gets a sets a text of the prompt inside the search box.
Public property | HeaderAllowedText | Gets a sets a text of the Allowed label.
Public property | HeaderAllText | Gets a sets a text of the Total files label.
Public property | Height | Gets or sets a height of the folder pane.
Public property | PreviewSize | Gets or sets a size of the preview area in Thumbnails view.
Public property | ShowAllowedItemsOnly | Gets or sets value indicating whether to display denied files in the folder pane.
Public property | SortMode | Gets or sets a sort mode of the folder pane.
Public property | ViewMode | Gets or sets a view mode for the folder pane.

See Also

Reference

  • FolderPane Class
  • Aurigma.ImageUploader Namespace


FolderPane Properties

  • FolderPane Class
  • See Also
  • Language Filter ( all languages )

The FolderPane type exposes the following members.

Properties

 | Name | Description
Public property | FilterClearIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the search box icon.
Public property | FilterHintText | Gets a sets a text of the prompt inside the search box.
Public property | HeaderAllowedText | Gets a sets a text of the Allowed label.
Public property | HeaderAllText | Gets a sets a text of the Total files label.
Public property | Height | Gets or sets a height of the folder pane.
Public property | PreviewSize | Gets or sets a size of the preview area in Thumbnails view.
Public property | ShowAllowedItemsOnly | Gets or sets value indicating whether to display denied files in the folder pane.
Public property | SortMode | Gets or sets a sort mode of the folder pane.
Public property | ViewMode | Gets or sets a view mode for the folder pane.

See Also

Reference

  • FolderPane Class
  • Aurigma.ImageUploader Namespace


FilterClearIconImageFormat Property

FolderPane..::.FilterClearIconImageFormat Property

  • Collapse All Sections
  • FolderPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the search box icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property FilterClearIconImageFormat As ImageFormat

C#

public ImageFormat FilterClearIconImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the search box icon.

See Also

Reference

  • FolderPane Class
  • Aurigma.ImageUploader Namespace
  • $au.folderPane.filterClearIconImageFormat JavaScript Property
  • FolderPane.FilterClearIconImageFormat PHP Property


FilterHintText Property

FolderPane..::.FilterHintText Property

  • Collapse All Sections
  • FolderPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a sets a text of the prompt inside the search box.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FilterHintText As String

C#

public string FilterHintText { get; set; }

Property Value

Type: System..::.String

The text of the prompt inside the search box.

Default value is "Search ".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • FolderPane Class
  • Aurigma.ImageUploader Namespace
  • $au.folderPane.filterHintText JavaScript Property
  • FolderPane.FilterHintText PHP Property


HeaderAllowedText Property

FolderPane..::.HeaderAllowedText Property

  • Collapse All Sections
  • FolderPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a sets a text of the Allowed label.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property HeaderAllowedText As String

C#

public string HeaderAllowedText { get; set; }

Property Value

Type: System..::.String

The text of the Allowed label. It can contain the following placeholder:

[count]
replaced by the number of allowed files.

Default value is "allowed: [count]".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • FolderPane Class
  • Aurigma.ImageUploader Namespace
  • $au.folderPane.headerAllowedText JavaScript Property
  • FolderPane.HeaderAllowedText PHP Property


HeaderAllText Property

FolderPane..::.HeaderAllText Property

  • Collapse All Sections
  • FolderPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a sets a text of the Total files label.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property HeaderAllText As String

C#

public string HeaderAllText { get; set; }

Property Value

Type: System..::.String

The text of the Total files label. It can contain the following placeholder:

[count]
replaced by the total number of files.

Default value is "Total files: [count], ".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • FolderPane Class
  • Aurigma.ImageUploader Namespace
  • $au.folderPane.headerAllText JavaScript Property
  • FolderPane.HeaderAllText PHP Property


Height Property

FolderPane..::.Height Property

  • Collapse All Sections
  • FolderPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of the folder pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Height As Integer

C#

public int Height { get; set; }

Property Value

Type: System..::.Int32

The height of the folder pane.

Default value is 300.

See Also

Reference

  • FolderPane Class
  • Aurigma.ImageUploader Namespace
  • $au.folderPane.height JavaScript Property
  • FolderPane.Height PHP Property


PreviewSize Property

FolderPane..::.PreviewSize Property

  • Collapse All Sections
  • FolderPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a size of the preview area in Thumbnails view.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property PreviewSize As Integer

C#

public int PreviewSize { get; set; }

Property Value

Type: System..::.Int32

The size of the preview area (in pixels). In other words, this property specifies size of square the thumbnail is inscribed in.

Default value is 96.

See Also

Reference

  • FolderPane Class
  • Aurigma.ImageUploader Namespace
  • $au.folderPane.previewSize JavaScript Property
  • FolderPane.PreviewSize PHP Property


ShowAllowedItemsOnly Property

FolderPane..::.ShowAllowedItemsOnly Property

  • Collapse All Sections
  • FolderPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets value indicating whether to display denied files in the folder pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ShowAllowedItemsOnly As Boolean

C#

public bool ShowAllowedItemsOnly { get; set; }

Property Value

Type: System..::.Boolean

If true, the folder pane shows only those files which meet the specified Restrictions; otherwise, all the files are visible.

Default value is true.

Remarks

This property makes sense if at least one limitation is specified via the Restrictions properties.

See Also

Reference

  • FolderPane Class
  • Aurigma.ImageUploader Namespace
  • $au.folderPane.showAllowedItemsOnly JavaScript Property
  • FolderPane.ShowAllowedItemsOnly PHP Property

Manual

  • Configuring Restriction Rules for Files


SortMode Property

FolderPane..::.SortMode Property

  • Collapse All Sections
  • FolderPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a sort mode of the folder pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property SortMode As PaneSortMode

C#

public PaneSortMode SortMode { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.PaneSortMode

The sort mode of the folder pane.

Default value is Name.

Remarks

Sort mode is automatically reset to Unsorted when new items are added or re-arranged via drag-n-drop.

Note

If you set the same value twice, the sort order will toggle between ascending and descending and vice versa.

See Also

Reference

  • FolderPane Class
  • Aurigma.ImageUploader Namespace
  • $au.folderPane.sortMode JavaScript Property
  • FolderPane.SortMode PHP Property


ViewMode Property

FolderPane..::.ViewMode Property

  • Collapse All Sections
  • FolderPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a view mode for the folder pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ViewMode As PaneViewMode

C#

public PaneViewMode ViewMode { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.PaneViewMode

The view mode for the folder pane.

Default value is Thumbnails.

See Also

Reference

  • FolderPane Class
  • Aurigma.ImageUploader Namespace
  • $au.folderPane.viewMode JavaScript Property
  • FolderPane.ViewMode PHP Property

Manual

  • View Modes


FolderProcessingMode Enumeration

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Specifies possible values for folder processing modes.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration FolderProcessingMode

C#

public enum FolderProcessingMode

Members

Member name | Description
Skip | Subfolders are not shown in the folder pane, so it is impossible to upload a whole folder if it is not a current folder.
Show | Subfolders are visible in the folder pane, so a user can select whole folders. However, restoring folders structure on server side is impossible, because no file path information is uploaded.
Upload | Subfolders are shown in the folder pane, so a user can select whole folders. Moreover, it is possible to restore folders structure on a server, because Image Uploader sends each file along with its relative path to the selected folder.

See Also

Reference

  • Aurigma.ImageUploader Namespace
  • Uploader..::.FolderProcessingMode

Manual

  • Uploading Folders in ASP.NET


FontFormat Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class specifies font settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class FontFormat

C#

public class FontFormat

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.FontFormat

See Also

Reference

  • FontFormat Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.PaneFont
  • Uploader..::.TitleFont
  • FontFormat PHP Class


FontFormat Members

  • FontFormat Class
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The FontFormat type exposes the following members.

Constructors

 | Name | Description
Public method | FontFormat | Creates and initializes an instance of the FontFormat class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current FontFormat. (Overrides Object ..::. ToString()()().)

Properties

 | Name | Description
Public property | Bold | Gets or sets a value specifying whether the font is bold.
Public property | Italic | Gets or sets a value specifying whether the font is italic.
Public property | Name | Gets or sets a font name.
Public property | Size | Gets or sets a font size (in pixels).

See Also

Reference

  • FontFormat Class
  • Aurigma.ImageUploader Namespace


FontFormat Constructor

  • FontFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the FontFormat class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public FontFormat()

See Also

Reference

  • FontFormat Class
  • Aurigma.ImageUploader Namespace


FontFormat Methods

  • FontFormat Class
  • See Also
  • Language Filter ( all languages )

The FontFormat type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current FontFormat. (Overrides Object ..::. ToString()()().)

See Also

Reference

  • FontFormat Class
  • Aurigma.ImageUploader Namespace


ToString Method

FontFormat..::.ToString Method

  • Collapse All Sections
  • FontFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns a String that represents the current FontFormat.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Overrides Function ToString As String

C#

public override string ToString()

Return Value

Type: System..::.String

The string representation of this FontFormat.

See Also

Reference

  • FontFormat Class
  • Aurigma.ImageUploader Namespace


FontFormat Properties

  • FontFormat Class
  • See Also
  • Language Filter ( all languages )

The FontFormat type exposes the following members.

Properties

 | Name | Description
Public property | Bold | Gets or sets a value specifying whether the font is bold.
Public property | Italic | Gets or sets a value specifying whether the font is italic.
Public property | Name | Gets or sets a font name.
Public property | Size | Gets or sets a font size (in pixels).

See Also

Reference

  • FontFormat Class
  • Aurigma.ImageUploader Namespace


Bold Property

FontFormat..::.Bold Property

  • Collapse All Sections
  • FontFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value specifying whether the font is bold.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Bold As Boolean

C#

public bool Bold { get; set; }

Property Value

Type: System..::.Boolean

If true, the font is bold.

Default value is false.

See Also

Reference

  • FontFormat Class
  • Aurigma.ImageUploader Namespace
  • FontFormat.Bold PHP Property


Italic Property

FontFormat..::.Italic Property

  • Collapse All Sections
  • FontFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value specifying whether the font is italic.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Italic As Boolean

C#

public bool Italic { get; set; }

Property Value

Type: System..::.Boolean

If true, the font is italic.

Default value is false.

See Also

Reference

  • FontFormat Class
  • Aurigma.ImageUploader Namespace
  • FontFormat.Italic PHP Property


Name Property

FontFormat..::.Name Property

  • Collapse All Sections
  • FontFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a font name.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Name As String

C#

public string Name { get; set; }

Property Value

Type: System..::.String

The font name.

Default value is "".

Remarks

The font specified with this property should be installed on the client machine, so it is recommended to use only standard font names. When this property is not specified, the system default font is used.

See Also

Reference

  • FontFormat Class
  • Aurigma.ImageUploader Namespace
  • FontFormat.Name PHP Property


Size Property

FontFormat..::.Size Property

  • Collapse All Sections
  • FontFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a font size (in pixels).

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Size As Integer

C#

public int Size { get; set; }

Property Value

Type: System..::.Int32

The font size. If this property is 0, the system default font size is used.

Default value is 0.

See Also

Reference

  • FontFormat Class
  • Aurigma.ImageUploader Namespace
  • FontFormat.Size PHP Property


GradientColor Structure

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This structure represents linear gradient colors.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Structure GradientColor

C#

public struct GradientColor

See Also

Reference

  • GradientColor Members
  • Aurigma.ImageUploader Namespace


GradientColor Members

  • GradientColor Structure
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The GradientColor type exposes the following members.

Constructors

 | Name | Description
Public method | GradientColor | Overloaded.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a string representation of this gradient color. (Overrides ValueType ..::. ToString()()().)

Properties

 | Name | Description
Public property | Color1 | Gets or sets a top gradient color.
Public property | Color2 | Gets or sets a bottom gradient color.

See Also

Reference

  • GradientColor Structure
  • Aurigma.ImageUploader Namespace


GradientColor Constructor

  • GradientColor Structure
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | GradientColor(Color) | Creates and initializes an instance of the GradientColor class.
Public method | GradientColor(String) | Creates and initializes an instance of the GradientColor class.
Public method | GradientColor(Color, Color) | Creates and initializes an instance of the GradientColor class.

See Also

Reference

  • GradientColor Structure
  • GradientColor Members
  • Aurigma.ImageUploader Namespace


GradientColor Constructor (Color)

  • GradientColor Structure
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the GradientColor class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New ( _
    color As Color _
)

C#

public GradientColor(
    Color color
)

Parameters

color

Type: System.Drawing..::.Color

The color used for both a top and bottom colors.

See Also

Reference

  • GradientColor Structure
  • GradientColor Overload
  • Aurigma.ImageUploader Namespace


GradientColor Constructor (String)

  • GradientColor Structure
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the GradientColor class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New ( _
    color As String _
)

C#

public GradientColor(
    string color
)

Parameters

color

Type: System..::.String

The string representation of a gradient color. The string should have the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax.

See Also

Reference

  • GradientColor Structure
  • GradientColor Overload
  • Aurigma.ImageUploader Namespace


GradientColor Constructor (Color, Color)

  • GradientColor Structure
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the GradientColor class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New ( _
    color1 As Color, _
    color2 As Color _
)

C#

public GradientColor(
    Color color1,
    Color color2
)

Parameters

color1

Type: System.Drawing..::.Color

The top gradient color

color2

Type: System.Drawing..::.Color

The bottom gradient color.

See Also

Reference

  • GradientColor Structure
  • GradientColor Overload
  • Aurigma.ImageUploader Namespace


GradientColor Methods

  • GradientColor Structure
  • See Also
  • Language Filter ( all languages )

The GradientColor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a string representation of this gradient color. (Overrides ValueType ..::. ToString()()().)

See Also

Reference

  • GradientColor Structure
  • Aurigma.ImageUploader Namespace


ToString Method

GradientColor..::.ToString Method

  • Collapse All Sections
  • GradientColor Structure
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns a string representation of this gradient color.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Overrides Function ToString As String

C#

public override string ToString()

Return Value

Type: System..::.String

The string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom.

See Also

Reference

  • GradientColor Structure
  • Aurigma.ImageUploader Namespace


GradientColor Properties

  • GradientColor Structure
  • See Also
  • Language Filter ( all languages )

The GradientColor type exposes the following members.

Properties

 | Name | Description
Public property | Color1 | Gets or sets a top gradient color.
Public property | Color2 | Gets or sets a bottom gradient color.

See Also

Reference

  • GradientColor Structure
  • Aurigma.ImageUploader Namespace


Color1 Property

GradientColor..::.Color1 Property

  • Collapse All Sections
  • GradientColor Structure
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a top gradient color.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Color1 As Color

C#

public Color Color1 { get; set; }

Property Value

Type: System.Drawing..::.Color

The top gradient color.

See Also

Reference

  • GradientColor Structure
  • Aurigma.ImageUploader Namespace


Color2 Property

GradientColor..::.Color2 Property

  • Collapse All Sections
  • GradientColor Structure
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a bottom gradient color.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Color2 As Color

C#

public Color Color2 { get; set; }

Property Value

Type: System.Drawing..::.Color

The bottom gradient color.

See Also

Reference

  • GradientColor Structure
  • Aurigma.ImageUploader Namespace


GradientColorConverter Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class inherits from the TypeConverter and allows converting values of different types to the GradientColor type.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class GradientColorConverter _
    Inherits TypeConverter

C#

public class GradientColorConverter : TypeConverter

Inheritance Hierarchy

System..::.Object L System.ComponentModel..::.TypeConverter L Aurigma.ImageUploader..::.GradientColorConverter

See Also

Reference

  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


GradientColorConverter Members

  • GradientColorConverter Class
  • Constructors
  • Methods
  • See Also
  • Language Filter ( all languages )

The GradientColorConverter type exposes the following members.

Constructors

 | Name | Description
Public method | GradientColorConverter | Creates and initializes an instance of the GradientColorConverter class.

Methods

 | Name | Description
Public method | CanConvertFrom | Overloaded.
Public method | CanConvertTo | Overloaded.
Public method | ConvertFrom | Overloaded.
Public method | ConvertFromInvariantString | Overloaded.
Public method | ConvertFromString | Overloaded.
Public method | ConvertTo | Overloaded.
Public method | ConvertToInvariantString | Overloaded.
Public method | ConvertToString | Overloaded.
Public method | CreateInstance | Overloaded.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetConvertFromException | (Inherited from TypeConverter.)
Protected method | GetConvertToException | (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Overloaded.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetProperties | Overloaded.
Public method | GetPropertiesSupported | Overloaded.
Public method | GetStandardValues | Overloaded.
Public method | GetStandardValuesExclusive | Overloaded.
Public method | GetStandardValuesSupported | Overloaded.
Public method | GetType | (Inherited from Object.)
Public method | IsValid | Overloaded.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | SortProperties | (Inherited from TypeConverter.)
Public method | ToString | (Inherited from Object.)

See Also

Reference

  • GradientColorConverter Class
  • Aurigma.ImageUploader Namespace


GradientColorConverter Constructor

  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the GradientColorConverter class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public GradientColorConverter()

See Also

Reference

  • GradientColorConverter Class
  • Aurigma.ImageUploader Namespace


GradientColorConverter Methods

  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

The GradientColorConverter type exposes the following members.

Methods

 | Name | Description
Public method | CanConvertFrom | Overloaded.
Public method | CanConvertTo | Overloaded.
Public method | ConvertFrom | Overloaded.
Public method | ConvertFromInvariantString | Overloaded.
Public method | ConvertFromString | Overloaded.
Public method | ConvertTo | Overloaded.
Public method | ConvertToInvariantString | Overloaded.
Public method | ConvertToString | Overloaded.
Public method | CreateInstance | Overloaded.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetConvertFromException | (Inherited from TypeConverter.)
Protected method | GetConvertToException | (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Overloaded.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetProperties | Overloaded.
Public method | GetPropertiesSupported | Overloaded.
Public method | GetStandardValues | Overloaded.
Public method | GetStandardValuesExclusive | Overloaded.
Public method | GetStandardValuesSupported | Overloaded.
Public method | GetType | (Inherited from Object.)
Public method | IsValid | Overloaded.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | SortProperties | (Inherited from TypeConverter.)
Public method | ToString | (Inherited from Object.)

See Also

Reference

  • GradientColorConverter Class
  • Aurigma.ImageUploader Namespace


CanConvertFrom Method

GradientColorConverter..::.CanConvertFrom Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | CanConvertFrom(Type) | (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns a value indicating whether this converter can convert an object of the given type to the GradientColor type, using the specified context. (Overrides TypeConverter ..::. CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


CanConvertFrom Method (ITypeDescriptorContext, Type)

GradientColorConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns a value indicating whether this converter can convert an object of the given type to the GradientColor type, using the specified context.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean

C#

public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)

Parameters

context

Type: System.ComponentModel..::.ITypeDescriptorContext

The format context.

sourceType

Type: System..::.Type

The type you want to convert from.

Return Value

Type: System..::.Boolean

true if this converter can perform the conversion; otherwise, false.

See Also

Reference

  • GradientColorConverter Class
  • CanConvertFrom Overload
  • Aurigma.ImageUploader Namespace


CanConvertTo Method

GradientColorConverter..::.CanConvertTo Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | CanConvertTo(Type) | (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns a value indicating whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter ..::. CanConvertTo(ITypeDescriptorContext, Type).)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


CanConvertTo Method (ITypeDescriptorContext, Type)

GradientColorConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns a value indicating whether this converter can convert the object to the specified type, using the specified context.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean

C#

public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)

Parameters

context

Type: System.ComponentModel..::.ITypeDescriptorContext

The format context.

destinationType

Type: System..::.Type

The type you want to convert to.

Return Value

Type: System..::.Boolean

true if this converter can perform the conversion; otherwise, false.

See Also

Reference

  • GradientColorConverter Class
  • CanConvertTo Overload
  • Aurigma.ImageUploader Namespace


ConvertFrom Method

GradientColorConverter..::.ConvertFrom Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | ConvertFrom(Object) | (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the GradientColor type, using the specified context and culture information. (Overrides TypeConverter ..::. ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


ConvertFromInvariantString Method

GradientColorConverter..::.ConvertFromInvariantString Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | ConvertFromInvariantString(String) | (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | (Inherited from TypeConverter.)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


ConvertFromString Method

GradientColorConverter..::.ConvertFromString Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | ConvertFromString(String) | (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | (Inherited from TypeConverter.)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

GradientColorConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Converts the given object to the GradientColor type, using the specified context and culture information.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object

C#

public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)

Parameters

context

Type: System.ComponentModel..::.ITypeDescriptorContext

The format context.

culture

Type: System.Globalization..::.CultureInfo

The current culture.

value

Type: System..::.Object

The object to convert.

Return Value

Type: System..::.Object

The converted value.

See Also

Reference

  • GradientColorConverter Class
  • ConvertFrom Overload
  • Aurigma.ImageUploader Namespace


ConvertTo Method

GradientColorConverter..::.ConvertTo Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | ConvertTo(Object, Type) | (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter ..::. ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


ConvertToInvariantString Method

GradientColorConverter..::.ConvertToInvariantString Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | ConvertToInvariantString(Object) | (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


ConvertToString Method

GradientColorConverter..::.ConvertToString Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | ConvertToString(Object) | (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | (Inherited from TypeConverter.)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

GradientColorConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object

C#

public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)

Parameters

context

Type: System.ComponentModel..::.ITypeDescriptorContext

The format context.

culture

Type: System.Globalization..::.CultureInfo

The current culture.

value

Type: System..::.Object

The object to convert.

destinationType

Type: System..::.Type

The type to convert the value to.

Return Value

Type: System..::.Object

The converted value.

See Also

Reference

  • GradientColorConverter Class
  • ConvertTo Overload
  • Aurigma.ImageUploader Namespace


ImageEditor Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the image editor.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class ImageEditor

C#

public class ImageEditor

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.ImageEditor

See Also

Reference

  • ImageEditor Members
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor JavaScript Class
  • ImageEditor PHP Class

Manual

  • Image Editor
  • Customizing Appearance


ImageEditor Members

  • ImageEditor Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The ImageEditor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | CancelButtonImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the Cancel button.
Public property | CancelButtonText | Gets or sets a caption of the Cancel button.
Public property | CancelCropButtonImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the Cancel Crop button.
Public property | CancelCropButtonText | Gets or sets a caption of the Cancel crop button.
Public property | CropButtonImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the Crop button.
Public property | CropButtonText | Gets or sets a caption of the Crop button.
Public property | CropMinSize | Gets or sets minimum width and height of the crop rectangle (in pixels).
Public property | CropRatio | Gets or sets an aspect ratio of the crop rectangle.
Public property | DescriptionHintText | Gets or sets a text of the prompt which is displayed when no description is entered.
Public property | EnableCrop | Gets or sets a value indicating whether it is possible to crop an image in the image editor.
Public property | RotateButtonImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the Rotate button.
Public property | RotateButtonText | Gets or sets a caption of the Rotate button.
Public property | SaveButtonImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the Save and close button.
Public property | SaveButtonText | Gets or sets a caption of the Save and close button.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace


ImageEditor Properties

  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )

The ImageEditor type exposes the following members.

Properties

 | Name | Description
Public property | CancelButtonImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the Cancel button.
Public property | CancelButtonText | Gets or sets a caption of the Cancel button.
Public property | CancelCropButtonImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the Cancel Crop button.
Public property | CancelCropButtonText | Gets or sets a caption of the Cancel crop button.
Public property | CropButtonImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the Crop button.
Public property | CropButtonText | Gets or sets a caption of the Crop button.
Public property | CropMinSize | Gets or sets minimum width and height of the crop rectangle (in pixels).
Public property | CropRatio | Gets or sets an aspect ratio of the crop rectangle.
Public property | DescriptionHintText | Gets or sets a text of the prompt which is displayed when no description is entered.
Public property | EnableCrop | Gets or sets a value indicating whether it is possible to crop an image in the image editor.
Public property | RotateButtonImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the Rotate button.
Public property | RotateButtonText | Gets or sets a caption of the Rotate button.
Public property | SaveButtonImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the Save and close button.
Public property | SaveButtonText | Gets or sets a caption of the Save and close button.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace


CancelButtonImageFormat Property

ImageEditor..::.CancelButtonImageFormat Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the Cancel button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property CancelButtonImageFormat As ImageFormat

C#

public ImageFormat CancelButtonImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the Cancel button.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.cancelButtonImageFormat JavaScript Property
  • ImageEditor.CancelButtonImageFormat PHP Property


CancelButtonText Property

ImageEditor..::.CancelButtonText Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CancelButtonText As String

C#

public string CancelButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the Cancel button.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.cancelButtonText JavaScript Property
  • ImageEditor.CancelButtonText PHP Property


CancelCropButtonImageFormat Property

ImageEditor..::.CancelCropButtonImageFormat Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the Cancel Crop button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property CancelCropButtonImageFormat As ImageFormat

C#

public ImageFormat CancelCropButtonImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the Cancel crop button.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.cancelCropButtonImageFormat JavaScript Property
  • ImageEditor.CancelCropButtonImageFormat PHP Property


CancelCropButtonText Property

ImageEditor..::.CancelCropButtonText Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel crop button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CancelCropButtonText As String

C#

public string CancelCropButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the Cancel crop button.

Default value is "Cancel crop".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.cancelCropButtonText JavaScript Property
  • ImageEditor.CancelCropButtonText PHP Property


CropButtonImageFormat Property

ImageEditor..::.CropButtonImageFormat Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the Crop button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property CropButtonImageFormat As ImageFormat

C#

public ImageFormat CropButtonImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the Crop button.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.cropButtonImageFormat JavaScript Property
  • ImageEditor.CropButtonImageFormat PHP Property


CropButtonText Property

ImageEditor..::.CropButtonText Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Crop button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CropButtonText As String

C#

public string CropButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the Crop button.

Default value is "Crop".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.cropButtonText JavaScript Property
  • ImageEditor.CropButtonText PHP Property


CropMinSize Property

ImageEditor..::.CropMinSize Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets minimum width and height of the crop rectangle (in pixels).

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CropMinSize As Integer

C#

public int CropMinSize { get; set; }

Property Value

Type: System..::.Int32

The minimum width and height of the crop rectangle (in pixels).

Default value is 50.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.cropMinSize JavaScript Property
  • ImageEditor.CropMinSize PHP Property


CropRatio Property

ImageEditor..::.CropRatio Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an aspect ratio of the crop rectangle.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CropRatio As Single

C#

public float CropRatio { get; set; }

Property Value

Type: System..::.Single

The aspect ratio of the crop rectangle. If 0 no aspect ratio is given.

Default value is 0.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.cropRatio JavaScript Property
  • ImageEditor.CropRatio PHP Property


DescriptionHintText Property

ImageEditor..::.DescriptionHintText Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text of the prompt which is displayed when no description is entered.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DescriptionHintText As String

C#

public string DescriptionHintText { get; set; }

Property Value

Type: System..::.String

The text of the Type description here prompt.

Default value is "Type description here...".

Remarks

Note

This property also specifies the same prompt in the description editor.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.descriptionHintText JavaScript Property
  • ImageEditor.DescriptionHintText PHP Property


EnableCrop Property

ImageEditor..::.EnableCrop Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is possible to crop an image in the image editor.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableCrop As Boolean

C#

public bool EnableCrop { get; set; }

Property Value

Type: System..::.Boolean

If true, the crop functionality is supported in the image editor; otherwise, images can only be previewed, rotated, and/or provided with a description.

Default value is true.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.enableCrop JavaScript Property
  • ImageEditor.EnableCrop PHP Property


RotateButtonImageFormat Property

ImageEditor..::.RotateButtonImageFormat Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the Rotate button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property RotateButtonImageFormat As ImageFormat

C#

public ImageFormat RotateButtonImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the Rotate button.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.rotateButtonImageFormat JavaScript Property
  • ImageEditor.RotateButtonImageFormat PHP Property


RotateButtonText Property

ImageEditor..::.RotateButtonText Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Rotate button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property RotateButtonText As String

C#

public string RotateButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the Rotate button.

Default value is "Rotate".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.rotateButtonText JavaScript Property
  • ImageEditor.RotateButtonText PHP Property


SaveButtonImageFormat Property

ImageEditor..::.SaveButtonImageFormat Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the Save and close button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property SaveButtonImageFormat As ImageFormat

C#

public ImageFormat SaveButtonImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the Save and close button.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.saveButtonImageFormat JavaScript Property
  • ImageEditor.SaveButtonImageFormat PHP Property


SaveButtonText Property

ImageEditor..::.SaveButtonText Property

  • Collapse All Sections
  • ImageEditor Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Save and close button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property SaveButtonText As String

C#

public string SaveButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the Save and close button.

Default value is "Save and close".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ImageEditor Class
  • Aurigma.ImageUploader Namespace
  • $au.imageEditor.saveButtonText JavaScript Property
  • ImageEditor.SaveButtonText PHP Property


ImageFormat Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class specifies different states of Image Uploader buttons and icons.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class ImageFormat

C#

public class ImageFormat

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.ImageFormat

See Also

Reference

  • ImageFormat Members
  • Aurigma.ImageUploader Namespace
  • ImageFormat PHP Class


ImageFormat Members

  • ImageFormat Class
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The ImageFormat type exposes the following members.

Constructors

 | Name | Description
Public method | ImageFormat | Creates and initializes an instance of the ImageFormat class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Overloaded.

Properties

 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of the button or icon.
Public property | Height | Gets or sets a height of the button or icon.
Public property | UrlDisabled | Gets or sets a URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Public property | UrlHover | Gets or sets a URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
Public property | UrlHoverFocused | Gets or sets a URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
Public property | UrlNormal | Gets or sets a URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus.
Public property | UrlNormalFocused | Gets or sets a URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
Public property | UrlPressed | Gets or sets a URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
Public property | Width | Gets or sets a width of the button or icon.

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace


ImageFormat Constructor

  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the ImageFormat class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public ImageFormat()

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace


ImageFormat Methods

  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )

The ImageFormat type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Overloaded.

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace


ToString Method

ImageFormat..::.ToString Method

  • Collapse All Sections
  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | ToString()()() | Returns a String that represents the current ImageFormat. (Overrides Object ..::. ToString()()().)
Public method | ToString(IUrlResolutionService) | Returns a String that represents the current ImageFormat.

See Also

Reference

  • ImageFormat Class
  • ImageFormat Members
  • Aurigma.ImageUploader Namespace


ToString Method

ImageFormat..::.ToString Method

  • Collapse All Sections
  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns a String that represents the current ImageFormat.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Overrides Function ToString As String

C#

public override string ToString()

Return Value

Type: System..::.String

The string representation of this ImageFormat.

See Also

Reference

  • ImageFormat Class
  • ToString Overload
  • Aurigma.ImageUploader Namespace


ToString Method (IUrlResolutionService)

ImageFormat..::.ToString Method (IUrlResolutionService)

  • Collapse All Sections
  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns a String that represents the current ImageFormat.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Function ToString ( _
    urlResolver As IUrlResolutionService _
) As String

C#

public string ToString(
    IUrlResolutionService urlResolver
)

Parameters

urlResolver

Type: System.Web.UI..::.IUrlResolutionService

The IUrlResolutionService used for resolving relative paths and paths that contain the ~ operator.

Return Value

Type: System..::.String

The string representation of this ImageFormat.

See Also

Reference

  • ImageFormat Class
  • ToString Overload
  • Aurigma.ImageUploader Namespace


ImageFormat Properties

  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )

The ImageFormat type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of the button or icon.
Public property | Height | Gets or sets a height of the button or icon.
Public property | UrlDisabled | Gets or sets a URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Public property | UrlHover | Gets or sets a URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
Public property | UrlHoverFocused | Gets or sets a URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
Public property | UrlNormal | Gets or sets a URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus.
Public property | UrlNormalFocused | Gets or sets a URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
Public property | UrlPressed | Gets or sets a URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
Public property | Width | Gets or sets a width of the button or icon.

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace


BackgroundColor Property

ImageFormat..::.BackgroundColor Property

  • Collapse All Sections
  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of the button or icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property BackgroundColor As Color

C#

public Color BackgroundColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The background color of button or icon.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Remarks

The rectangle specified with Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the BackgroundColor property value is used.

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace
  • ImageFormat.BackgroundColor PHP Property


Height Property

ImageFormat..::.Height Property

  • Collapse All Sections
  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of the button or icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Height As Integer

C#

public int Height { get; set; }

Property Value

Type: System..::.Int32

The height of a button or icon (in pixels).

Default value is 0.

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace
  • ImageFormat.Height PHP Property


UrlDisabled Property

ImageFormat..::.UrlDisabled Property

  • Collapse All Sections
  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UrlDisabled As String

C#

public string UrlDisabled { get; set; }

Property Value

Type: System..::.String

The URL to the image which represents a button/icon when it is disabled.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace
  • ImageFormat.UrlDisabled PHP Property


UrlHover Property

ImageFormat..::.UrlHover Property

  • Collapse All Sections
  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UrlHover As String

C#

public string UrlHover { get; set; }

Property Value

Type: System..::.String

The URL to the image which represents a button/icon when a mouse button is hovered over it.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace
  • ImageFormat.UrlHover PHP Property


UrlHoverFocused Property

ImageFormat..::.UrlHoverFocused Property

  • Collapse All Sections
  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UrlHoverFocused As String

C#

public string UrlHoverFocused { get; set; }

Property Value

Type: System..::.String

The URL to the image which represents a button/icon when a mouse button is hovered over it and the button/icon is in focus.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace
  • ImageFormat.UrlHoverFocused PHP Property


UrlNormal Property

ImageFormat..::.UrlNormal Property

  • Collapse All Sections
  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UrlNormal As String

C#

public string UrlNormal { get; set; }

Property Value

Type: System..::.String

The URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace
  • ImageFormat.UrlNormal PHP Property


UrlNormalFocused Property

ImageFormat..::.UrlNormalFocused Property

  • Collapse All Sections
  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UrlNormalFocused As String

C#

public string UrlNormalFocused { get; set; }

Property Value

Type: System..::.String

The URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button/icon is in focus.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace
  • ImageFormat.UrlNormalFocused PHP Property


UrlPressed Property

ImageFormat..::.UrlPressed Property

  • Collapse All Sections
  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UrlPressed As String

C#

public string UrlPressed { get; set; }

Property Value

Type: System..::.String

The URL to the image which represents a button/icon when it is pressed.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace
  • ImageFormat.UrlPressed PHP Property


Width Property

ImageFormat..::.Width Property

  • Collapse All Sections
  • ImageFormat Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of the button or icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Width As Integer

C#

public int Width { get; set; }

Property Value

Type: System..::.Int32

The width of a button or icon (in pixels).

Default value is 0.

See Also

Reference

  • ImageFormat Class
  • Aurigma.ImageUploader Namespace
  • ImageFormat.Width PHP Property


InformationBar Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the information bar.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class InformationBar

C#

public class InformationBar

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.InformationBar

See Also

Reference

  • InformationBar Members
  • Aurigma.ImageUploader Namespace
  • $au.informationBar JavaScript Class
  • InformationBar PHP Class

Manual

  • Customizing Appearance


InformationBar Members

  • InformationBar Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The InformationBar type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | CloseIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the information bar icon.
Public property | ErrorColor | Gets or sets a color of the information bar when it displays an error message.
Public property | MessageColor | Gets or sets a color of the information bar when it displays an information massage message.
Public property | WarningColor | Gets or sets a color of the information bar when it displays a warning message.

See Also

Reference

  • InformationBar Class
  • Aurigma.ImageUploader Namespace


InformationBar Properties

  • InformationBar Class
  • See Also
  • Language Filter ( all languages )

The InformationBar type exposes the following members.

Properties

 | Name | Description
Public property | CloseIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the information bar icon.
Public property | ErrorColor | Gets or sets a color of the information bar when it displays an error message.
Public property | MessageColor | Gets or sets a color of the information bar when it displays an information massage message.
Public property | WarningColor | Gets or sets a color of the information bar when it displays a warning message.

See Also

Reference

  • InformationBar Class
  • Aurigma.ImageUploader Namespace


CloseIconImageFormat Property

InformationBar..::.CloseIconImageFormat Property

  • Collapse All Sections
  • InformationBar Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the information bar icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property CloseIconImageFormat As ImageFormat

C#

public ImageFormat CloseIconImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the information bar icon.

See Also

Reference

  • InformationBar Class
  • Aurigma.ImageUploader Namespace
  • $au.informationBar.closeIconImageFormat JavaScript Property
  • InformationBar.CloseIconImageFormat PHP Property


ErrorColor Property

InformationBar..::.ErrorColor Property

  • Collapse All Sections
  • InformationBar Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the information bar when it displays an error message.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ErrorColor As Color

C#

public Color ErrorColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of the error message. Such messages appear when upload in broken.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #f14b54.

See Also

Reference

  • InformationBar Class
  • Aurigma.ImageUploader Namespace
  • $au.informationBar.errorColor JavaScript Property
  • InformationBar.ErrorColor PHP Property


MessageColor Property

InformationBar..::.MessageColor Property

  • Collapse All Sections
  • InformationBar Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the information bar when it displays an information massage message.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MessageColor As Color

C#

public Color MessageColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of the information message. Such message appears when upload is completed successfully.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #a3ffa8.

See Also

Reference

  • InformationBar Class
  • Aurigma.ImageUploader Namespace
  • $au.informationBar.messageColor JavaScript Property
  • InformationBar.MessageColor PHP Property


WarningColor Property

InformationBar..::.WarningColor Property

  • Collapse All Sections
  • InformationBar Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the information bar when it displays a warning message.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property WarningColor As Color

C#

public Color WarningColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of the warning message. Such messages are displayed when a file does not meet the specified restrictions.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #fde2a6.

See Also

Reference

  • InformationBar Class
  • Aurigma.ImageUploader Namespace
  • $au.informationBar.warningColor JavaScript Property
  • InformationBar.WarningColor PHP Property


InstallationProgress Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class allows displaying special screens instead of Image Uploader during the downloading and installation phases.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class InstallationProgress _
    Inherits BaseUploaderExtender

C#

public class InstallationProgress : BaseUploaderExtender

Inheritance Hierarchy

System..::.Object L System.Web.UI..::.Control L Aurigma.ImageUploader..::.BaseExtender L Aurigma.ImageUploader..::.BaseUploaderExtender L Aurigma.ImageUploader..::.InstallationProgress

See Also

Reference

  • InstallationProgress Members
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress JavaScript Class
  • InstallationProgress PHP Class

Manual

  • Using Image Uploader Installation Progress


InstallationProgress Members

  • InstallationProgress Class
  • Constructors
  • Methods
  • Properties
  • Events
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The InstallationProgress type exposes the following members.

Constructors

 | Name | Description
Public method | InstallationProgress | Creates and initializes an instance of the InstallationProgress class.

Methods

 | Name | Description
Protected method | AddedControl | (Inherited from Control.)
Protected method | AddParsedSubObject | (Inherited from Control.)
Public method | ApplyStyleSheetSkin | (Inherited from Control.)
Protected method | BuildProfileTree | (Inherited from Control.)
Protected method | ClearChildControlState | (Inherited from Control.)
Protected method | ClearChildState | (Inherited from Control.)
Protected method | ClearChildViewState | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | DataBind | Overloaded.
Protected method | DataBindChildren | (Inherited from Control.)
Public method | Dispose | (Inherited from Control.)
Protected method | EnsureChildControls | (Inherited from Control.)
Protected method | EnsureID | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindControl | Overloaded.
Public method | Focus | (Inherited from Control.)
Protected method | GetDesignModeState | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasControls | (Inherited from Control.)
Protected method | HasEvents | (Inherited from Control.)
Protected method | IsLiteralContent | (Inherited from Control.)
Protected method | LoadControlState | (Inherited from Control.)
Protected method | LoadViewState | (Inherited from Control.)
Protected method | MapPathSecure | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnBubbleEvent | (Inherited from Control.)
Protected method | OnDataBinding | (Inherited from Control.)
Protected method | OnInit | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Control.)
Protected method | OnUnload | (Inherited from Control.)
Protected method | OpenFile | (Inherited from Control.)
Protected method | RaiseBubbleEvent | (Inherited from Control.)
Protected method | RemovedControl | (Inherited from Control.)
Protected method | Render | (Inherited from Control.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderControl | Overloaded.
Protected method | ResolveAdapter | (Inherited from Control.)
Public method | ResolveClientUrl | (Inherited from Control.)
Public method | ResolveUrl | (Inherited from Control.)
Protected method | SaveControlState | (Inherited from Control.)
Protected method | SaveViewState | (Inherited from Control.)
Protected method | SetDesignModeState | (Inherited from Control.)
Public method | SetRenderMethodDelegate | (Inherited from Control.)
Public method | ToString | (Inherited from Object.)
Protected method | TrackViewState | (Inherited from Control.)

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AltInstallerHtml | Sets an HTML-marked text appended to installation instructions and saying how to install Image Uploader in alternative way (e.g. use a standalone installer).
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | BeforeIE6XPSP2InstructionsHtml | Sets installation instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.
Public property | BeforeIE6XPSP2ProgressHtml | Set downloading instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Public property | CommonHtml | Sets an HTML-marked description of Image Uploader displayed on the both stages (downloading and installation).
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Protected property | DesignMode | (Inherited from Control.)
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Public property | IE6XPSP2InstructionsHtml | Sets installation instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.
Public property | IE6XPSP2ProgressHtml | Sets downloading instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.
Public property | IE7InstructionsHtml | Sets installation instructions for Internet Explorer 7.
Public property | IE7ProgressHtml | Sets downloading instructions for Internet Explorer 7.
Public property | IE8InstructionsHtml | Sets installation instructions for Internet Explorer 8.
Public property | IE8ProgressHtml | Sets downloading instructions for Internet Explorer 8.
Public property | InstallJavaHtml | Sets installation instructions for non-Internet Explorer browsers.
Public property | InstructionsCssClass | Sets a CSS class name to apply it to the installation screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | MacInstallJavaHtml | Sets installation instructions for Mac browsers.
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ProgressCssClass | Sets a CSS class name to apply it to the downloading screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
Public property | ProgressHtml | Sets a text saying that the downloading of Image Uploader is in progress.
Public property | ProgressImageUrl | Sets a URL to a custom image which replaces a default wait indicator.
Public property | ShowDownloadingScreen | Sets a value indicating whether the downloading screen should be displayed.
Public property | ShowInstallationScreen | Sets a value indicating whether the installation screen should be displayed.
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Protected property | TargetControl | Gets a reference to the Uploader control instance associated with this extender. (Inherited from BaseUploaderExtender.)
Public property | TargetControlID | Gets or sets an ID of the Uploader control instance associated with this extender. (Inherited from BaseUploaderExtender.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Public property | UpdateInstructions | Sets common instructions on how to update Image Uploader control.
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Events

 | Name | Description
Public event | DataBinding | (Inherited from Control.)
Public event | Disposed | (Inherited from Control.)
Public event | Init | (Inherited from Control.)
Public event | Load | (Inherited from Control.)
Public event | PreRender | (Inherited from Control.)
Public event | Unload | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace


InstallationProgress Constructor

  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the InstallationProgress class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public InstallationProgress()

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress(uploader) JavaScript Constructor
  • InstallationProgress(Uploader) PHP Constructor


InstallationProgress Properties

  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )

The InstallationProgress type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AltInstallerHtml | Sets an HTML-marked text appended to installation instructions and saying how to install Image Uploader in alternative way (e.g. use a standalone installer).
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | BeforeIE6XPSP2InstructionsHtml | Sets installation instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.
Public property | BeforeIE6XPSP2ProgressHtml | Set downloading instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Public property | CommonHtml | Sets an HTML-marked description of Image Uploader displayed on the both stages (downloading and installation).
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Protected property | DesignMode | (Inherited from Control.)
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Public property | IE6XPSP2InstructionsHtml | Sets installation instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.
Public property | IE6XPSP2ProgressHtml | Sets downloading instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.
Public property | IE7InstructionsHtml | Sets installation instructions for Internet Explorer 7.
Public property | IE7ProgressHtml | Sets downloading instructions for Internet Explorer 7.
Public property | IE8InstructionsHtml | Sets installation instructions for Internet Explorer 8.
Public property | IE8ProgressHtml | Sets downloading instructions for Internet Explorer 8.
Public property | InstallJavaHtml | Sets installation instructions for non-Internet Explorer browsers.
Public property | InstructionsCssClass | Sets a CSS class name to apply it to the installation screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | MacInstallJavaHtml | Sets installation instructions for Mac browsers.
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ProgressCssClass | Sets a CSS class name to apply it to the downloading screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
Public property | ProgressHtml | Sets a text saying that the downloading of Image Uploader is in progress.
Public property | ProgressImageUrl | Sets a URL to a custom image which replaces a default wait indicator.
Public property | ShowDownloadingScreen | Sets a value indicating whether the downloading screen should be displayed.
Public property | ShowInstallationScreen | Sets a value indicating whether the installation screen should be displayed.
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Protected property | TargetControl | Gets a reference to the Uploader control instance associated with this extender. (Inherited from BaseUploaderExtender.)
Public property | TargetControlID | Gets or sets an ID of the Uploader control instance associated with this extender. (Inherited from BaseUploaderExtender.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Public property | UpdateInstructions | Sets common instructions on how to update Image Uploader control.
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace


AltInstallerHtml Property

InstallationProgress..::.AltInstallerHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Sets an HTML-marked text appended to installation instructions and saying how to install Image Uploader in alternative way (e.g. use a standalone installer).

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property AltInstallerHtml As String

C#

public string AltInstallerHtml { get; set; }

Property Value

Type: System..::.String

The instructions on how to install Image Uploader in alternative way.

Default value is "".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.altInstallerHtml JavaScript Property
  • InstallationProgress.AltInstallerHtml PHP Property


BeforeIE6XPSP2InstructionsHtml Property

InstallationProgress..::.BeforeIE6XPSP2InstructionsHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Sets installation instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property BeforeIE6XPSP2InstructionsHtml As String

C#

public string BeforeIE6XPSP2InstructionsHtml { get; set; }

Property Value

Type: System..::.String

The installation instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.

Default value is "<p>To install Image Uploader, please reload the page and click the <strong>Yes</strong> button when you see the control installation dialog. If you don't see installation dialog, please check your security settings.</p>".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.beforeIE6XPSP2InstructionsHtml JavaScript Property
  • InstallationProgress.BeforeIE6XPSP2InstructionsHtml PHP Property


BeforeIE6XPSP2ProgressHtml Property

InstallationProgress..::.BeforeIE6XPSP2ProgressHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Set downloading instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property BeforeIE6XPSP2ProgressHtml As String

C#

public string BeforeIE6XPSP2ProgressHtml { get; set; }

Property Value

Type: System..::.String

The downloading instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.

Default value is "<p>To install Image Uploader, please wait until the control will be loaded and click the <strong>Yes</strong> button when you see the installation dialog.</p>".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.beforeIE6XPSP2ProgressHtml JavaScript Property
  • InstallationProgress.BeforeIE6XPSP2ProgressHtml PHP Property


CommonHtml Property

InstallationProgress..::.CommonHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets an HTML-marked description of Image Uploader displayed on the both stages (downloading and installation).

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CommonHtml As String

C#

public string CommonHtml { get; set; }

Property Value

Type: System..::.String

The description of Image Uploader.

Default value is "<p>Aurigma Image Uploader control is necessary to upload your files quickly and easily. You will be able to select multiple images in user-friendly interface instead of clumsy input fields with <strong>Browse</strong> button.</p>".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.commonHtml JavaScript Property
  • InstallationProgress.CommonHtml PHP Property


IE6XPSP2InstructionsHtml Property

InstallationProgress..::.IE6XPSP2InstructionsHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Sets installation instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property IE6XPSP2InstructionsHtml As String

C#

public string IE6XPSP2InstructionsHtml { get; set; }

Property Value

Type: System..::.String

The installation instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.

Default value is "<p>To install Image Uploader, please click on the <strong>Information Bar</strong> and select <strong>Install ActiveX Control</strong> from the dropdown menu. After page reload click <strong>Install</strong> when you see the control installation dialog. If you don't see Information Bar, please try to reload the page and/or check your security settings.</p>".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.IE6XPSP2InstructionsHtml JavaScript Property
  • InstallationProgress.IE6XPSP2InstructionsHtml PHP Property


IE6XPSP2ProgressHtml Property

InstallationProgress..::.IE6XPSP2ProgressHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Sets downloading instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property IE6XPSP2ProgressHtml As String

C#

public string IE6XPSP2ProgressHtml { get; set; }

Property Value

Type: System..::.String

The downloading instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.

Default value is "<p>Please wait until the control will be loaded.</p>".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.IE6XPSP2ProgressHtml JavaScript Property
  • InstallationProgress.IE6XPSP2ProgressHtml PHP Property


IE7InstructionsHtml Property

InstallationProgress..::.IE7InstructionsHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Sets installation instructions for Internet Explorer 7.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property IE7InstructionsHtml As String

C#

public string IE7InstructionsHtml { get; set; }

Property Value

Type: System..::.String

The installation instructions for Internet Explorer 7.

Default value is "<p>To install Image Uploader, please click on the <strong>Information Bar</strong> and select <strong>Install ActiveX Control</strong> or <strong>Run ActiveX Control</strong> from the dropdown menu.</p> <p>Then either click <strong>Run</strong> or after the page reload click <strong>Install</strong> when you see the control installation dialog. If you don't see Information Bar, please try to reload the page and/or check your security settings.</p>".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.IE7InstructionsHtml JavaScript Property
  • InstallationProgress.IE7InstructionsHtml PHP Property


IE7ProgressHtml Property

InstallationProgress..::.IE7ProgressHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Sets downloading instructions for Internet Explorer 7.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property IE7ProgressHtml As String

C#

public string IE7ProgressHtml { get; set; }

Property Value

Type: System..::.String

The downloading instructions for Internet Explorer 7.

Default value is "<p>Please wait until the control will be loaded.</p>".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.IE7ProgressHtml JavaScript Property
  • InstallationProgress.IE7ProgressHtml PHP Property


IE8InstructionsHtml Property

InstallationProgress..::.IE8InstructionsHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Sets installation instructions for Internet Explorer 8.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property IE8InstructionsHtml As String

C#

public string IE8InstructionsHtml { get; set; }

Property Value

Type: System..::.String

The installation instructions for Internet Explorer 8.

Default value is "<p>To install Image Uploader, please click on the <strong>Information Bar</strong> and select <strong>Install This Add-on</strong> or <strong>Run Add-on</strong> from the dropdown menu.</p> <p>Then either click <strong>Run</strong> or after the page reload click <strong>Install</strong> when you see the control installation dialog. If you don't see Information Bar, please try to reload the page and/or check your security settings.</p>".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.IE8InstructionsHtml JavaScript Property
  • InstallationProgress.IE8InstructionsHtml PHP Property


IE8ProgressHtml Property

InstallationProgress..::.IE8ProgressHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Sets downloading instructions for Internet Explorer 8.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property IE8ProgressHtml As String

C#

public string IE8ProgressHtml { get; set; }

Property Value

Type: System..::.String

The downloading instructions for Internet Explorer 8.

Default value is "<p>Please wait until the control will be loaded.</p>".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.IE8ProgressHtml JavaScript Property
  • InstallationProgress.IE8ProgressHtml PHP Property


InstallJavaHtml Property

InstallationProgress..::.InstallJavaHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Sets installation instructions for non-Internet Explorer browsers.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property InstallJavaHtml As String

C#

public string InstallJavaHtml { get; set; }

Property Value

Type: System..::.String

Sets installation instructions for non-Internet Explorer browsers.

Default value is "<p>Please <a href=\"http://www.java.com/getjava/\">download</a> and install Java.</p>".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.installJavaHtml JavaScript Property
  • InstallationProgress.InstallJavaHtml PHP Property


InstructionsCssClass Property

InstallationProgress..::.InstructionsCssClass Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a CSS class name to apply it to the installation screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property InstructionsCssClass As String

C#

public string InstructionsCssClass { get; set; }

Property Value

Type: System..::.String

The CSS class name to apply it to the installation screen.

Default value is "".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.instructionsCssClass JavaScript Property
  • InstallationProgress.InstructionsCssClass PHP Property


MacInstallJavaHtml Property

InstallationProgress..::.MacInstallJavaHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Sets installation instructions for Mac browsers.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MacInstallJavaHtml As String

C#

public string MacInstallJavaHtml { get; set; }

Property Value

Type: System..::.String

The installation instructions for Mac browsers.

Default value is "<p>Use the <a href=\"http://support.apple.com/kb/HT1338\">Software Update</a> feature (available on the Apple menu) to check that you have the most up-to-date version of Java for your Mac.</p>".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.macInstallJavaHtml JavaScript Property
  • InstallationProgress.MacInstallJavaHtml PHP Property


ProgressCssClass Property

InstallationProgress..::.ProgressCssClass Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a CSS class name to apply it to the downloading screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ProgressCssClass As String

C#

public string ProgressCssClass { get; set; }

Property Value

Type: System..::.String

The CSS class name to apply it to the downloading screen.

Default value is "".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.progressCssClass JavaScript Property
  • InstallationProgress.ProgressCssClass PHP Property


ProgressHtml Property

InstallationProgress..::.ProgressHtml Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a text saying that the downloading of Image Uploader is in progress.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ProgressHtml As String

C#

public string ProgressHtml { get; set; }

Property Value

Type: System..::.String

The text saying that the downloading of Image Uploader is in progress.

The value of this property can contain {0} placeholder. Before displaying the downloading screen, this placeholder is replaced with image URL defined in the ProgressImageUrl property. It allows you to customize images without changing HTML-marked text.

Default value is "<p><img src=\"{0}\" /><br /> Loading Aurigma Image Uploader...</p>".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.progressHtml JavaScript Property
  • InstallationProgress.ProgressHtml PHP Property


ProgressImageUrl Property

InstallationProgress..::.ProgressImageUrl Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a URL to a custom image which replaces a default wait indicator.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ProgressImageUrl As String

C#

public string ProgressImageUrl { get; set; }

Property Value

Type: System..::.String

The URL to a custom image which replaces a default wait indicator.

Default value is "Scripts/InstallationProgress.gif".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.progressImageUrl JavaScript Property
  • InstallationProgress.ProgressImageUrl PHP Property


ShowDownloadingScreen Property

InstallationProgress..::.ShowDownloadingScreen Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a value indicating whether the downloading screen should be displayed.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ShowDownloadingScreen As Boolean

C#

public bool ShowDownloadingScreen { get; set; }

Property Value

Type: System..::.Boolean

If true

Default value is true.

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.showDownloadingScreen JavaScript Property
  • InstallationProgress.ShowDownloadingScreen PHP Property


ShowInstallationScreen Property

InstallationProgress..::.ShowInstallationScreen Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a value indicating whether the installation screen should be displayed.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ShowInstallationScreen As Boolean

C#

public bool ShowInstallationScreen { get; set; }

Property Value

Type: System..::.Boolean

If true

Default value is true.

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.showInstallationScreen JavaScript Property
  • InstallationProgress.ShowInstallationScreen PHP Property


UpdateInstructions Property

InstallationProgress..::.UpdateInstructions Property

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Sets common instructions on how to update Image Uploader control.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UpdateInstructions As String

C#

public string UpdateInstructions { get; set; }

Property Value

Type: System..::.String

The instructions on how to update Image Uploader control.

Default value is "You need to update Image Uploader control. Click <strong>Install</strong> or <strong>Run</strong> button when you see the control installation dialog. If you don't see installation dialog, please try to reload the page.".

See Also

Reference

  • InstallationProgress Class
  • Aurigma.ImageUploader Namespace
  • $au.installationProgress.updateInstructions JavaScript Property
  • InstallationProgress.UpdateInstructions PHP Property


JavaControl Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

This class represents Image Uploader Java applet.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public NotInheritable Class JavaControl _
    Inherits BaseClientControl

C#

public sealed class JavaControl : BaseClientControl

Remarks

Note

This client-side control is used in all browsers except Internet Explorer.

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.BaseClientControl L Aurigma.ImageUploader..::.JavaControl

See Also

Reference

  • JavaControl Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.JavaControl
  • $au.javaControl JavaScript Class
  • JavaControl PHP Class


JavaControl Members

  • JavaControl Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The JavaControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Cached | Gets or sets a value which enables or disables caching for Image Uploader Java applet.
Public property | ClassName | Gets or sets a class name of Image Uploader Java applet.
Public property | CodeBase | Gets a URL to client-side control. (Inherited from BaseClientControl.)
Public property | CustomCodeBase | Gets or sets a custom URL to client-side control. (Inherited from BaseClientControl.)
Public property | UseCustomCodeBase | Gets or sets a value indicating whether a custom URL to client-side control specified with the CustomCodeBase property is used. (Inherited from BaseClientControl.)
Public property | Version | Gets or sets a minimum required version of the client-side control. (Inherited from BaseClientControl.)

See Also

Reference

  • JavaControl Class
  • Aurigma.ImageUploader Namespace


JavaControl Properties

  • JavaControl Class
  • See Also
  • Language Filter ( all languages )

The JavaControl type exposes the following members.

Properties

 | Name | Description
Public property | Cached | Gets or sets a value which enables or disables caching for Image Uploader Java applet.
Public property | ClassName | Gets or sets a class name of Image Uploader Java applet.
Public property | CodeBase | Gets a URL to client-side control. (Inherited from BaseClientControl.)
Public property | CustomCodeBase | Gets or sets a custom URL to client-side control. (Inherited from BaseClientControl.)
Public property | UseCustomCodeBase | Gets or sets a value indicating whether a custom URL to client-side control specified with the CustomCodeBase property is used. (Inherited from BaseClientControl.)
Public property | Version | Gets or sets a minimum required version of the client-side control. (Inherited from BaseClientControl.)

See Also

Reference

  • JavaControl Class
  • Aurigma.ImageUploader Namespace


Cached Property

JavaControl..::.Cached Property

  • Collapse All Sections
  • JavaControl Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a value which enables or disables caching for Image Uploader Java applet.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Cached As Boolean

C#

public bool Cached { get; set; }

Property Value

Type: System..::.Boolean

If true, the Java applet is not re-downloaded until you update it on the server. Otherwise, the applet is re-downloaded every time a user visits this page.

Default value is true.

See Also

Reference

  • JavaControl Class
  • Aurigma.ImageUploader Namespace
  • $au.javaControl.cached JavaScript Property
  • JavaControl.Cached PHP Property


ClassName Property

JavaControl..::.ClassName Property

  • Collapse All Sections
  • JavaControl Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a class name of Image Uploader Java applet.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ClassName As String

C#

public string ClassName { get; set; }

Property Value

Type: System..::.String

The class name of Image Uploader Java applet.

Default value is "".

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • JavaControl Class
  • Aurigma.ImageUploader Namespace
  • $au.javaControl.className JavaScript Property
  • JavaControl.ClassName PHP Property

Manual

  • Using Private-label Version of Image Uploader ASP.NET


Language Enumeration

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Specifies possible values for Image Uploader localizations.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration Language

C#

public enum Language

Members

Member name | Description
Default | Default localization.
English | English localization.
Hebrew | Hebrew localization.
Russian | Russian localization.

See Also

Reference

  • Aurigma.ImageUploader Namespace


Messages Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class contains error messages Image Uploader shows.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class Messages

C#

public class Messages

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.Messages

See Also

Reference

  • Messages Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.Messages
  • $au.messages JavaScript Class
  • Messages PHP Class


Messages Members

  • Messages Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The Messages type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | CmykImagesNotAllowed | Gets or sets a message which states that the selected image is CMYK, when CMYK images are denied for the upload.
Public property | DeletingFilesError | Gets or sets a message which states that the uploaded file cannot be deleted.
Public property | DimensionsTooLarge | Gets or sets a message which states that the width or height of the selected image is too large.
Public property | DimensionsTooSmall | Gets or sets a message which states that the width or height of selected image is too small.
Public property | FileNameNotAllowed | Gets or sets a message which states that a user tries to select a file that has not allowed name.
Public property | FileSizeTooSmall | Gets or sets a message which states that a user tries to select a file that is too small.
Public property | FilesNotAdded | Gets or sets the message displayed when a user tries to add files and some of them were not added because of restrictions.
Public property | MaxFileCountExceeded | Gets or sets a message which states that a user tries to select too many files.
Public property | MaxFileSizeExceeded | Gets or sets a message which states that a user tries to select a file that is too big.
Public property | MaxTotalFileSizeExceeded | Gets or sets a message which states that the total size of selected files is too large.
Public property | NoResponseFromServer | Gets or sets a message which states that an error was encountered when sending a request to the server and the server did not return any response.
Public property | ServerNotFound | Gets or sets a message which states that the server, specified in the UploadSettings.ActionUrl parameter cannot be found.
Public property | UnexpectedError | Gets or sets a user-friendly message for errors which are meaningful to website developer only.
Public property | UploadCancelled | Gets or sets a message which states that a user cancelled the upload.
Public property | UploadCompleted | Gets or sets a message which notifies that the upload is successfully finished.
Public property | UploadFailed | Gets or sets a message which states that the upload failed because the connection was broken.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace


Messages Properties

  • Messages Class
  • See Also
  • Language Filter ( all languages )

The Messages type exposes the following members.

Properties

 | Name | Description
Public property | CmykImagesNotAllowed | Gets or sets a message which states that the selected image is CMYK, when CMYK images are denied for the upload.
Public property | DeletingFilesError | Gets or sets a message which states that the uploaded file cannot be deleted.
Public property | DimensionsTooLarge | Gets or sets a message which states that the width or height of the selected image is too large.
Public property | DimensionsTooSmall | Gets or sets a message which states that the width or height of selected image is too small.
Public property | FileNameNotAllowed | Gets or sets a message which states that a user tries to select a file that has not allowed name.
Public property | FileSizeTooSmall | Gets or sets a message which states that a user tries to select a file that is too small.
Public property | FilesNotAdded | Gets or sets the message displayed when a user tries to add files and some of them were not added because of restrictions.
Public property | MaxFileCountExceeded | Gets or sets a message which states that a user tries to select too many files.
Public property | MaxFileSizeExceeded | Gets or sets a message which states that a user tries to select a file that is too big.
Public property | MaxTotalFileSizeExceeded | Gets or sets a message which states that the total size of selected files is too large.
Public property | NoResponseFromServer | Gets or sets a message which states that an error was encountered when sending a request to the server and the server did not return any response.
Public property | ServerNotFound | Gets or sets a message which states that the server, specified in the UploadSettings.ActionUrl parameter cannot be found.
Public property | UnexpectedError | Gets or sets a user-friendly message for errors which are meaningful to website developer only.
Public property | UploadCancelled | Gets or sets a message which states that a user cancelled the upload.
Public property | UploadCompleted | Gets or sets a message which notifies that the upload is successfully finished.
Public property | UploadFailed | Gets or sets a message which states that the upload failed because the connection was broken.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace


CmykImagesNotAllowed Property

Messages..::.CmykImagesNotAllowed Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the selected image is CMYK, when CMYK images are denied for the upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CmykImagesNotAllowed As String

C#

public string CmykImagesNotAllowed { get; set; }

Property Value

Type: System..::.String

The message which states that the selected image is CMYK.

Default value is "CMYK images are not allowed.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • Restrictions..::.EnableCmyk
  • $au.messages.cmykImagesNotAllowed JavaScript Property
  • Messages.CmykImagesNotAllowed PHP Property


DeletingFilesError Property

Messages..::.DeletingFilesError Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a message which states that the uploaded file cannot be deleted.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DeletingFilesError As String

C#

public string DeletingFilesError { get; set; }

Property Value

Type: System..::.String

The message which states that the uploaded file cannot be deleted, e.g. it is used by another application. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be deleted.

Default value is "The file '[name]' cannot be deleted".

Remarks

Note

A difference between Image Uploader behavior in Internet Explorer and other supported browsers is the following. When Image Uploader deletes files in Internet Explorer, it moves them in the way specified in the Recycle Bin properties. By default, a standard delete confirmation dialog appears and files are moved to the Recycle Bin if a user clicks Yes. However, if Image Uploader deletes files in any of other supported browsers, the internal delete confirmation dialog appears and files are removed permanently when a user clicks Yes.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • $au.messages.deletingFilesError JavaScript Property
  • Messages.DeletingFilesError PHP Property


DimensionsTooLarge Property

Messages..::.DimensionsTooLarge Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the width or height of the selected image is too large.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DimensionsTooLarge As String

C#

public string DimensionsTooLarge { get; set; }

Property Value

Type: System..::.String

The message which states that the width or height of the selected image is too large (i.e. exceeds the MaxImageWidth or MaxImageHeight property). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The image '[name]' is too large to be selected.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • Restrictions..::.MaxImageWidth
  • Restrictions..::.MaxImageHeight
  • $au.messages.dimensionsTooLarge JavaScript Property
  • Messages.DimensionsTooLarge PHP Property


DimensionsTooSmall Property

Messages..::.DimensionsTooSmall Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the width or height of selected image is too small.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DimensionsTooSmall As String

C#

public string DimensionsTooSmall { get; set; }

Property Value

Type: System..::.String

The message which states that the width or height of the selected image is too small (i.e. it is less than MinImageWidth or MinImageHeight property). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The image '[name]' is too small to be selected.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • Restrictions..::.MinImageWidth
  • Restrictions..::.MinImageHeight
  • $au.messages.dimensionsTooSmall JavaScript Property
  • Messages.DimensionsTooSmall PHP Property


FileNameNotAllowed Property

Messages..::.FileNameNotAllowed Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user tries to select a file that has not allowed name.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FileNameNotAllowed As String

C#

public string FileNameNotAllowed { get; set; }

Property Value

Type: System..::.String

The message which states that a user tries to select a file that has not allowed name (i.e. the file name does not match FileMask, or matches DeniedFileMask). It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. This file has inadmissible name.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • Restrictions..::.FileMask
  • Restrictions..::.DeniedFileMask
  • $au.messages.fileNameNotAllowed JavaScript Property
  • Messages.FileNameNotAllowed PHP Property


FileSizeTooSmall Property

Messages..::.FileSizeTooSmall Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user tries to select a file that is too small.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FileSizeTooSmall As String

C#

public string FileSizeTooSmall { get; set; }

Property Value

Type: System..::.String

The message which states that a user tries to select too small file (i.e. the file size is smaller than MinFileSize value). It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. This file size is smaller than the limit.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • Restrictions..::.MinFileSize
  • $au.messages.fileSizeTooSmall JavaScript Property
  • Messages.FileSizeTooSmall PHP Property


FilesNotAdded Property

Messages..::.FilesNotAdded Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the message displayed when a user tries to add files and some of them were not added because of restrictions.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FilesNotAdded As String

C#

public string FilesNotAdded { get; set; }

Property Value

Type: System..::.String

The message which states that a user tries to add files and some of them were not added because of restrictions. It can contain the following placeholder:

[count]
replaced by the number of files which were not added.

Default value is "[count] files were not added due to restrictions.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • $au.messages.filesNotAdded JavaScript Property
  • Messages.FilesNotAdded PHP Property


MaxFileCountExceeded Property

Messages..::.MaxFileCountExceeded Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user tries to select too many files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MaxFileCountExceeded As String

C#

public string MaxFileCountExceeded { get; set; }

Property Value

Type: System..::.String

The message which states that a user tries to select too many files (i.e. the number of the selected files is bigger than the MaxFileCount value). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. Amount of files exceeds the limit.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • Restrictions..::.MaxFileCount
  • $au.messages.maxFileCountExceeded JavaScript Property
  • Messages.MaxFileCountExceeded PHP Property


MaxFileSizeExceeded Property

Messages..::.MaxFileSizeExceeded Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user tries to select a file that is too big.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MaxFileSizeExceeded As String

C#

public string MaxFileSizeExceeded { get; set; }

Property Value

Type: System..::.String

The message which states that a user tries to select too large file (i.e. the file size exceeds the MaxFileSize value). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. This file size exceeds the limit.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • Restrictions..::.MaxFileSize
  • $au.messages.maxFileSizeExceeded JavaScript Property
  • Messages.MaxFileSizeExceeded PHP Property


MaxTotalFileSizeExceeded Property

Messages..::.MaxTotalFileSizeExceeded Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the total size of selected files is too large.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MaxTotalFileSizeExceeded As String

C#

public string MaxTotalFileSizeExceeded { get; set; }

Property Value

Type: System..::.String

The message which states that the total size of selected files is too large (i.e. exceeds the MaxTotalFileSize value). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. Total upload data size exceeds the limit.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • Restrictions..::.MaxTotalFileSize
  • $au.messages.maxTotalFileSizeExceeded JavaScript Property
  • Messages.MaxTotalFileSizeExceeded PHP Property


NoResponseFromServer Property

Messages..::.NoResponseFromServer Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that an error was encountered when sending a request to the server and the server did not return any response.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property NoResponseFromServer As String

C#

public string NoResponseFromServer { get; set; }

Property Value

Type: System..::.String

The message which states that an error was encountered when sending a request to the server and the server did not return any response. To disable this message, set it to an empty string.

Default value is "No response from server.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • $au.messages.noResponseFromServer JavaScript Property
  • Messages.NoResponseFromServer PHP Property


ServerNotFound Property

Messages..::.ServerNotFound Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the server, specified in the UploadSettings.ActionUrl parameter cannot be found.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ServerNotFound As String

C#

public string ServerNotFound { get; set; }

Property Value

Type: System..::.String

The message which states that the server, specified in the ActionUrl parameter cannot be found (e.g. the name of this server is misspelled or the server is down). To disable this message, set it to empty string. It can contain the following placeholder:

[name]
replaced by the name of the server which cannot be reached (as specified in the ActionUrl parameter).

Default value is "The server or proxy [name] cannot be found.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • UploadSettings..::.ActionUrl
  • $au.messages.serverNotFound JavaScript Property
  • Messages.ServerNotFound PHP Property


UnexpectedError Property

Messages..::.UnexpectedError Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a user-friendly message for errors which are meaningful to website developer only.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UnexpectedError As String

C#

public string UnexpectedError { get; set; }

Property Value

Type: System..::.String

The user-friendly error message. To disable this message, set it to an empty string.

Default value is "Image Uploader encountered some problem. If you see this message, contact web master.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • $au.messages.unexpectedError JavaScript Property
  • Messages.UnexpectedError PHP Property


UploadCancelled Property

Messages..::.UploadCancelled Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user cancelled the upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UploadCancelled As String

C#

public string UploadCancelled { get; set; }

Property Value

Type: System..::.String

The message which states that a user cancelled the upload. To disable this message, set it to an empty string.

Default value is "Upload is cancelled.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • $au.messages.uploadCancelled JavaScript Property
  • Messages.UploadCancelled PHP Property


UploadCompleted Property

Messages..::.UploadCompleted Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which notifies that the upload is successfully finished.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UploadCompleted As String

C#

public string UploadCompleted { get; set; }

Property Value

Type: System..::.String

The message which notifies that the upload is successfully finished. To disable this message, set it to an empty string.

Default value is "Upload complete.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • $au.messages.uploadCompleted JavaScript Property
  • Messages.UploadCompleted PHP Property


UploadFailed Property

Messages..::.UploadFailed Property

  • Collapse All Sections
  • Messages Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the upload failed because the connection was broken.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UploadFailed As String

C#

public string UploadFailed { get; set; }

Property Value

Type: System..::.String

The message stating that the upload failed because the connection was broken. To disable this message, set it to an empty string.

Default value is "Upload failed (the connection was interrupted).".

Remarks

Typically this error occurs when timeout expires (either server-side or client-side).

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Messages Class
  • Aurigma.ImageUploader Namespace
  • $au.messages.uploadFailed JavaScript Property
  • Messages.UploadFailed PHP Property


Metadata Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents an additional upload data.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class Metadata

C#

public class Metadata

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.Metadata

See Also

Reference

  • Metadata Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.Metadata
  • $au.metadata JavaScript Class
  • Metadata PHP Class

Manual

  • Uploading Additional Data in ASP.NET


Metadata Members

  • Metadata Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The Metadata type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalFormName | Gets or sets a name or ID of the HTML form with additional information which should be sent to the server along with files.
Public property | Exif | Gets or sets a list of EXIF fields which should be extracted and uploaded along with other data.
Public property | Hash | Gets or sets an algorithm to generate a hash value for each user-selected file.
Public property | Iptc | Gets or sets a list of IPTC fields which should be extracted and uploaded along with other data.
Public property | UserAgent | Gets or sets a user-agent string.
Public property | ValueSeparator | Gets or sets a sequence of characters used to separate strings stored in one metadata field (such as IptcKeyword).

See Also

Reference

  • Metadata Class
  • Aurigma.ImageUploader Namespace


Metadata Properties

  • Metadata Class
  • See Also
  • Language Filter ( all languages )

The Metadata type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalFormName | Gets or sets a name or ID of the HTML form with additional information which should be sent to the server along with files.
Public property | Exif | Gets or sets a list of EXIF fields which should be extracted and uploaded along with other data.
Public property | Hash | Gets or sets an algorithm to generate a hash value for each user-selected file.
Public property | Iptc | Gets or sets a list of IPTC fields which should be extracted and uploaded along with other data.
Public property | UserAgent | Gets or sets a user-agent string.
Public property | ValueSeparator | Gets or sets a sequence of characters used to separate strings stored in one metadata field (such as IptcKeyword).

See Also

Reference

  • Metadata Class
  • Aurigma.ImageUploader Namespace


AdditionalFormName Property

Metadata..::.AdditionalFormName Property

  • Collapse All Sections
  • Metadata Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a name or ID of the HTML form with additional information which should be sent to the server along with files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property AdditionalFormName As String

C#

public string AdditionalFormName { get; set; }

Property Value

Type: System..::.String

The name or ID for the form you need to submit along with files. If this value is an empty string or an invalid form name (which does not exist on this page), no additional form is sent.

Default value is "".

Remarks

The additional form may contain the following elements:

  • Input fields (except of <input type="image"> and <input type="file">).
  • Text areas.
  • Select elements.
Note

The additional form must be placed into the same frame with the Uploader.

See Also

Reference

  • Metadata Class
  • Aurigma.ImageUploader Namespace
  • $au.metadata.additionalFormName JavaScript Property
  • Metadata.AdditionalFormName PHP Property


Exif Property

Metadata..::.Exif Property

  • Collapse All Sections
  • Metadata Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of EXIF fields which should be extracted and uploaded along with other data.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Exif As String

C#

public string Exif { get; set; }

Property Value

Type: System..::.String

The string containing EXIF field names which you want to extract separated with a semicolon.

You will find possible names of EXIF fields in the table below.

Field name | Description
ExifApertureValue | The lens aperture (in APEX units).
ExifArtist | The name of photographer or image creator.
ExifBitsPerSample | The number of bits per image component.
ExifBrightnessValue | The brightness value (in APEX units).
ExifCFAPattern | The color filter pattern.
ExifColorSpace | The color space of the image.
ExifComponentsConfiguration | The order of pixel channels (components).
ExifCompressedBitsPerPixel | The number of bits per pixel in the compressed image.
ExifCompression | The compression type.
ExifContrast | The contrast settings applied when images was captured.
ExifCopyright | The copyright information.
ExifCustomRendered | Value that indicates that special processing was applied to the image.
ExifDateTime | The date and time of image creation.
ExifDateTimeDigitized | The date and time when the image was converted into digital representation.
ExifDateTimeOriginal | The date and time when the original file was created.
ExifDeviceSettingDescription | The description of the image capturing device settings.
ExifDigitalZoomRatio | The digital zoom ratio.
ExifExifVersion | The version of the EXIF specification this data is stored at.
ExifExposureBiasValue | The exposure bias (in APEX units).
ExifExposureIndex | The exposure index of the device when image is being captured.
ExifExposureMode | The exposure mode.
ExifExposureProgram | The exposure program.
ExifExposureTime | The exposure time (in seconds).
ExifFileSource | The image source.
ExifFlash | The flash status.
ExifFlashEnergy | The flash energy (in BCPS).
ExifFlashPixVersion | The version of FlashPix format.
ExifFNumber | The F number.
ExifFocalLength | The focal length of the lens (in millimeters).
ExifFocalLengthIn35mmFilm | The focal length of the lens assuming 35mm film camera is used (in millimeters).
ExifFocalPlaneResolutionUnit | The unit to measure focal plane resolution with (i.e. ExifFocalPlaneXResolution and ExifFocalPlaneYResolution).
ExifFocalPlaneXResolution | The horizontal resolution of the camera focal plane.
ExifFocalPlaneYResolution | The vertical resolution of the camera focal plane.
ExifGainControl | The overall image gain adjustment.
ExifGpsAltitude | The altitude.
ExifGpsAltitudeRef | The altitude reference.
ExifGpsAreaInformation | The name of GPS area.
ExifGpsDateStamp | The GPS datestamp.
ExifGpsDestBearing | The bearing to the destination point (in degrees).
ExifGpsDestBearingRef | The reference for giving the bearing to the destination point.
ExifGpsDestDistance | The distance to the destination point.
ExifGpsDestDistanceRef | The unit for distance to the destination point.
ExifGpsDestLatitude | The destination point latitude.
ExifGpsDestLatitudeRef | The destination point latitude reference (north or south).
ExifGpsDestLongitude | The destination point longitude.
ExifGpsDestLongitudeRef | The destination point longitude reference (west or east).
ExifGpsDifferential | The GPS differential correction.
ExifGpsDOP | The GPS data degree of precision.
ExifGpsImgDirection | The direction of the image when it was captured (in degrees).
ExifGpsImgDirectionRef | The reference for giving the direction of the image when it was captured.
ExifGpsLatitude | The latitude.
ExifGpsLatitudeRef | The latitude reference (north or south).
ExifGpsLongitude | The longitude.
ExifGpsLongitudeRef | The longitude reference (west or east).
ExifGpsMapDatum | The geodetic survey data.
ExifGpsMeasureMode | The GPS measurement mode.
ExifGpsProcessingMethod | The name of GPS processing method.
ExifGpsSatellites | The details about GPS satellites used in measurement.
ExifGpsSpeed | The speed of the GPS receiver movement.
ExifGpsSpeedRef | The Unit for speed of movement of GPS receiver.
ExifGpsStatus | The status of GPS receiver when image was recorded.
ExifGpsTimeStamp | The GPS timestamp (in UTC).
ExifGpsTrack | The direction of GPS receiver movement (in degrees).
ExifGpsTrackRef | The reference for giving the direction of GPS receiver movement.
ExifGpsVersionID | The version of the GPSVersionID tag.
ExifImageDescription | The title of the image.
ExifImageHeight | The height of the image in pixels.
ExifImageUniqueID | The 128-bit unique ID of the image.
ExifImageWidth | The width of the image in pixels.
ExifInteroperabilityIndex | The index of interoperability rule.
ExifISOSpeedRatings | The ISO speed and the ISO latitude of the device.
ExifLightSource | The light source.
ExifMake | The name of manufacturer of the camera (or other recording equipment).
ExifMakerNote | The custom comments. May contain any information maker want to store.
ExifMaxApertureValue | The smallest F of the lens (in APEX units).
ExifMeteringMode | The metering mode.
ExifModel | The name of the model of the camera (or other recording equipment).
ExifOECF | The opto-electronic conversion function.
ExifOrientation | The orientation of image (how it is rotated relative to the top left corner).
ExifPhotometricInterpretation | The pixel composition.
ExifPixelXDimension | The valid width of the meaningful image.
ExifPixelYDimension | The valid height of the meaningful image.
ExifPlanarConfiguration | The planar configuration of the pixel components (planar or chunky).
ExifPrimaryChromaticities | The chromaticity of the three primary colors of the image.
ExifReferenceBlackWhite | The reference for black and white point of the image.
ExifRelatedSoundFile | The name of an audio file associated with this image.
ExifResolutionUnit | The unit image resolution is measured in (i.e. ExifXResolution and ExifYResolution).
ExifRowsPerStrip | Rows per strip (if image is divided into strips).
ExifSamplesPerPixel | The number of components (channels) in one pixel.
ExifSaturation | The saturation settings applied when images was captured.
ExifSceneCaptureType | The type of scene was captured by camera (landscape, night scene, portrait, etc).
ExifSceneType | The type of scene.
ExifSensingMethod | The sensor type of the device.
ExifSharpness | The sharpness settings applied when images was captured.
ExifShutterSpeed | The shutter speed (in APEX units).
ExifSoftware | The name of the software that created this image.
ExifSpatialFrequencyResponse | The spatial frequency response values.
ExifSpectralSensitivity | The spectral sensitivity.
ExifStripByteCounts | The total number of bytes in one strip.
ExifStripOffsets | The bitmap stride (byte offset between strips).
ExifSubjectArea | The subject area.
ExifSubjectDistance | The distance to the subject (in meters).
ExifSubjectDistanceRange | The kind of distance to the subject (macro, close, or distant).
ExifSubjectLocation | The location of the main subject in the scene.
ExifSubSecTime | The fractions of seconds for the ExifDateTime field.
ExifSubSecTimeDigitized | The fractions of seconds for the ExifDateTimeDigitized field.
ExifSubSecTimeOriginal | The fractions of seconds for the ExifDateTimeOriginal field.
ExifThumbnailBitsPerSample | The number of bits per channel in the thumbnail.
ExifThumbnailCompression | The compression type of the thumbnail.
ExifThumbnailHeight | The height of the thumbnail in pixel.
ExifThumbnailOrientation | The orientation of the thumbnail (how it is rotated relative to the top left corner).
ExifThumbnailPhotometricInterpretation | The pixel composition of the thumbnail.
ExifThumbnailResolutionUnit | The unit thumbnail resolution is measured in (i.e.ExifThumbnailXResolution and ExifThumbnailYResolution).
ExifThumbnailRowsPerStrip | Rows per strip in the thumbnail (if thumbnail is divided into strips).
ExifThumbnailSamplesPerPixel | The number of components (channels) in one pixel of the thumbnail.
ExifThumbnailStripByteCounts | The total number of bytes in one strip of the thumbnail.
ExifThumbnailStripOffsets | The thumbnail stride (byte offset between strips).
ExifThumbnailWidth | The width of the thumbnail in pixels.
ExifThumbnailXResolution | The horizontal resolution of the thumbnail.
ExifThumbnailYResolution | The vertical resolution of the thumbnail.
ExifTransferFunction | The transfer function in tabular form.
ExifUserComment | The additional comments or keywords on the image available for users.
ExifWhiteBalance | The mode of the white balance when the image was captured.
ExifWhitePoint | The white point of the image.
ExifXResolution | The horizontal resolution of the image.
ExifYCbCrCoefficients | The coefficients used during the transformation between RGB and YCbCr colorspaces.
ExifYCbCrPositioning | The position of chrominance components relative to the luminosity component.
ExifYCbCrSubSampling | Sampling ratio of the chrominance components relative to the luminosity component.
ExifYResolution | The vertical resolution of the image.

All date/time values have the following format: YYYY:MM:DD hh:mm:ss. E.g. 11th of May 2006, 2:40PM would be represented as: 2006:05:11 14:40:00.

For more details regarding interpretation of these values, refer to the EXIF specification.

Default value is "".

Remarks

To get an uploaded EXIF value at the server, use the Package.PackageFields collection. Here this value can be retrieved by a key named in the following way: XXX_N, where XXX is a string value specified in this property (EXIF field name), and N is the index of the file in the request. E.g. if the property value is ExifDateTime;ExifOrientation;ExifModel, the PackageFields collection will contain the following keys:

  • ExifDateTime_1, ExifDateTime_2, etc.
  • ExifOrientation_1, ExifOrientation_2, etc.
  • ExifModel_1, ExifModel_2, etc.

If you prefer to extract EXIF fields on the server, you can get them from the original file, or specify to preserve EXIF fields in the thumbnails you are going to upload. To do it, use the ThumbnailCopyExif property.

See Also

Reference

  • Metadata Class
  • Aurigma.ImageUploader Namespace
  • $au.metadata.exif JavaScript Property
  • Metadata.Exif PHP Property


Hash Property

Metadata..::.Hash Property

  • Collapse All Sections
  • Metadata Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an algorithm to generate a hash value for each user-selected file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Hash As String

C#

public string Hash { get; set; }

Property Value

Type: System..::.String

The algorithm to generate a hash value for each user-selected file.

Possible values are listed in the table below.

Value | Description
SHA | SHA hash algorithm.
MD2 | MD2 hash algorithm.
MD5 | MD5 hash algorithm.

You can specify several hash algorithms separated by semicolon.

Default value is "".

Remarks

Note

Image Uploader Express does not upload hash sums. See the Comparison of Image Uploader Editions topic for details.

The hash is calculated only for the original file, not for converted files (even if the original file is not uploaded).

To get an uploaded hash sum at the server, use the Package.PackageFields collection. Here this value can be retrieved by a key named in the following way: HashCodeXXX_N, where XXX is a string value specified in this property (hash algorithm), and N is the index of the file in the request. E.g. if the property value is MD5;SHA, the PackageFields collection will contain the following keys:

  • HashCodeMD5_1, HashCodeMD5_2, etc.
  • HashCodeSHA_1, HashCodeSHA_2, etc.
Note

Hash calculation is quite resource-intensive operation. That is why if you need not verify uploaded files on the server, it makes sense to disable this feature to make Image Uploader faster. To do it, just specify empty string in this property.

See Also

Reference

  • Metadata Class
  • Aurigma.ImageUploader Namespace
  • $au.metadata.hash JavaScript Property
  • Metadata.Hash PHP Property


Iptc Property

Metadata..::.Iptc Property

  • Collapse All Sections
  • Metadata Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of IPTC fields which should be extracted and uploaded along with other data.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Iptc As String

C#

public string Iptc { get; set; }

Property Value

Type: System..::.String

The string containing IPTC field names which you want to extract, separated with a semicolon.

You will find possible names of IPTC fields in the table below.

Field name | Description
IptcByline | The name of the creator of the image, e.g. artist, photographer, etc.
IptcBylineTitle | The byline title (e.g. staff photographer, correspondent, etc).
IptcCredit | The provider of the image.
IptcSource | The original owner of the intellectual content of this image.
IptcObjectName | The short reference for the object.
IptcDateCreated | The date the image (as an intellectual content, rather than physical file) created.
IptcCity | The city of the image origin.
IptcState | The state/province of the image origin.
IptcCountry | The country of the image origin.
IptcOriginalTransmissionReference | The location of the original transmission.
IptcCopyrightNotice | The copyright notice.
IptcCaption | The textual description of the image.
IptcWriter | The name of editor or other person involved in the writing.
IptcHeadline | The brief overview for the image.
IptcSpecialInstructions | Some custom editorial instructions.
IptcCategory | The image category.
IptcSupplementaryCategory | The supplementary category for the image.
IptcUrgency | The editorial urgency of the content.
IptcKeyword | The keywords used for search.

All date values have the following format: YYYYMMDD. E.g. 11th of May 2006 would be represented as: 20060511.

For more information about interpretation of these values, refer to IPTC specification (version 4.1 is currently supported).

Default value is "".

Remarks

To get an uploaded IPTC value at the server, use the Package.PackageFields collection. Here this value can be retrieved by a key named in the following way: XXX_N, where XXX is a string value specified in this property (IPTC field name), and N is the index of the file in the request. E.g. if the property value is IptcCountry;IptcCity;IptcObjectName, the PackageFields collection will contain the following keys:

  • IptcCountry_1, IptcCountry_2, etc.
  • IptcCity_1, IptcCity_2, etc.
  • IptcObjectName_1, IptcObjectName_2, etc.

If you prefer to extract IPTC fields on the server, you can get them from the original file, or specify to preserve IPTC fields in the thumbnails you are going to upload. To do it, use the ThumbnailCopyIptc property.

See Also

Reference

  • Metadata Class
  • Aurigma.ImageUploader Namespace
  • $au.metadata.iptc JavaScript Property
  • Metadata.Iptc PHP Property


UserAgent Property

Metadata..::.UserAgent Property

  • Collapse All Sections
  • Metadata Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a user-agent string.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UserAgent As String

C#

public string UserAgent { get; set; }

Property Value

Type: System..::.String

The user-agent string which is sent by Image Uploader in the header of the upload request.

Default value is "".

Remarks

Note

During initialization, this value is set to the user-agent string of a browser which hosts Image Uploader.

See Also

Reference

  • Metadata Class
  • Aurigma.ImageUploader Namespace
  • $au.metadata.userAgent JavaScript Property
  • Metadata.UserAgent PHP Property


ValueSeparator Property

Metadata..::.ValueSeparator Property

  • Collapse All Sections
  • Metadata Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a sequence of characters used to separate strings stored in one metadata field (such as IptcKeyword).

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ValueSeparator As String

C#

public string ValueSeparator { get; set; }

Property Value

Type: System..::.String

The sequence of characters used to separate strings stored in one metadata field.

Default value is " ".

Remarks

Some metadata fields like IptcKeyword can contain multiple string values. Suppose you upload an image which contains several keywords: portrait, old photo, black and white. All these keywords are stored in one IptcKeyword field. So, if you specified this field for upload (using the Iptc property) the IptcKeyword_0 POST field will contain all these keywords gathered into one string separated with this property value. For example, if you set it to the ";" you will get the "portrait;old photo;black and white" POST field value.

See Also

Reference

  • Metadata Class
  • Aurigma.ImageUploader Namespace
  • $au.metadata.valueSeparator JavaScript Property
  • Metadata.ValueSeparator PHP Property


Package Class

  • Members
  • See Also
  • Language Filter ( all languages )

This class represents a package uploaded within the current session.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustInherit Class Package

C#

public abstract class Package

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.Package

See Also

Reference

  • Package Members
  • Aurigma.ImageUploader Namespace
  • Package PHP Class

Manual

  • Saving Uploaded Files in ASP.NET


Package Members

  • Package Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The Package type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | PackageCount | Gets a total number of packages uploaded within the current session.
Public property | PackageFields | Gets a name-value collection of POST fields uploaded within this package.
Public property | PackageFileCount | Gets a number of files uploaded within this package.
Public property | PackageGuid | Gets a unique identifier of the current upload session.
Public property | PackageIndex | Gets an index of this package inside the current session.
Public property | UploadedFiles | Gets a collection of UploadedFile instances belonging to this package.

See Also

Reference

  • Package Class
  • Aurigma.ImageUploader Namespace


Package Properties

  • Package Class
  • See Also
  • Language Filter ( all languages )

The Package type exposes the following members.

Properties

 | Name | Description
Public property | PackageCount | Gets a total number of packages uploaded within the current session.
Public property | PackageFields | Gets a name-value collection of POST fields uploaded within this package.
Public property | PackageFileCount | Gets a number of files uploaded within this package.
Public property | PackageGuid | Gets a unique identifier of the current upload session.
Public property | PackageIndex | Gets an index of this package inside the current session.
Public property | UploadedFiles | Gets a collection of UploadedFile instances belonging to this package.

See Also

Reference

  • Package Class
  • Aurigma.ImageUploader Namespace


PackageCount Property

Package..::.PackageCount Property

  • Collapse All Sections
  • Package Class
  • See Also
  • Language Filter ( all languages )

Gets a total number of packages uploaded within the current session.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property PackageCount As Integer

C#

public abstract int PackageCount { get; }

Property Value

Type: System..::.Int32

The total number of packages uploaded within the current session.

See Also

Reference

  • Package Class
  • Aurigma.ImageUploader Namespace
  • Package.PackageCount PHP Property


PackageFields Property

Package..::.PackageFields Property

  • Collapse All Sections
  • Package Class
  • See Also
  • Language Filter ( all languages )

Gets a name-value collection of POST fields uploaded within this package.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property PackageFields As NameValueCollection

C#

public abstract NameValueCollection PackageFields { get; }

Property Value

Type: System.Collections.Specialized..::.NameValueCollection

The name-value collection of POST fields uploaded within this package.

Remarks

This collection contains additional data specified for the upload via the Metadata property. To access these data use kays named in the following way: XXX_N, where XXX is a string value specified in one of the Metadata properties.

See Also

Reference

  • Package Class
  • Aurigma.ImageUploader Namespace
  • Aurigma.ImageUploader..::.Metadata
  • Package.PackageFields PHP Property

Manual

  • Uploading Additional Data in ASP.NET


PackageFileCount Property

Package..::.PackageFileCount Property

  • Collapse All Sections
  • Package Class
  • See Also
  • Language Filter ( all languages )

Gets a number of files uploaded within this package.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property PackageFileCount As Integer

C#

public abstract int PackageFileCount { get; }

Property Value

Type: System..::.Int32

The number of files uploaded within this package.

See Also

Reference

  • Package Class
  • Aurigma.ImageUploader Namespace
  • Package.PackageFileCount PHP Property


PackageGuid Property

Package..::.PackageGuid Property

  • Collapse All Sections
  • Package Class
  • See Also
  • Language Filter ( all languages )

Gets a unique identifier of the current upload session.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property PackageGuid As Guid

C#

public abstract Guid PackageGuid { get; }

Property Value

Type: System..::.Guid

The unique identifier of the current upload session.

Remarks

When the upload session is separated into several packages (FilesPerPackage is greater than 0), each package has the same GUID. So you can use it to determine whether files are uploaded in the same session.

See Also

Reference

  • Package Class
  • Aurigma.ImageUploader Namespace
  • Package.PackageGuid PHP Property


PackageIndex Property

Package..::.PackageIndex Property

  • Collapse All Sections
  • Package Class
  • See Also
  • Language Filter ( all languages )

Gets an index of this package inside the current session.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property PackageIndex As Integer

C#

public abstract int PackageIndex { get; }

Property Value

Type: System..::.Int32

The zero-based index of this package inside the current session.

Remarks

Using this property you can recognize the order of files if they are sent in different packages.

See Also

Reference

  • Package Class
  • Aurigma.ImageUploader Namespace
  • Package.PackageIndex PHP Property


UploadedFiles Property

Package..::.UploadedFiles Property

  • Collapse All Sections
  • Package Class
  • See Also
  • Language Filter ( all languages )

Gets a collection of UploadedFile instances belonging to this package.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property UploadedFiles As ReadOnlyCollection(Of UploadedFile)

C#

public abstract ReadOnlyCollection<UploadedFile> UploadedFiles { get; }

Property Value

Type: System.Collections.Generic..::.IEnumerable<(Of <(T>)>)

The collection of UploadedFile instances. Each instance contains all the converted files and metadata related to a particular user-selected file.

See Also

Reference

  • Package Class
  • Aurigma.ImageUploader Namespace
  • Package.UploadedFiles PHP Property


PaneItem Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a pane item displayed in both the upload and folder panes.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class PaneItem

C#

public class PaneItem

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.PaneItem

See Also

Reference

  • PaneItem Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.PaneItem
  • $au.paneItem JavaScript Class
  • PaneItem PHP Class

Manual

  • Additional Controls and Indicators
  • Customizing Appearance


PaneItem Members

  • PaneItem Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The PaneItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DescriptionAddedIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the description added icon.
Public property | DescriptionEditorIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the description editor icon.
Public property | DescriptionEditorIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the description editor icon.
Public property | EnableDisproportionalExifThumbnails | Get or sets a value indicating whether Image Uploader should generate a preview thumbnail from the original image in the case when thumbnail saved in EXIF metadata is out of proportions of original image.
Public property | EnableFileNameTooltip | Get or sets a value indicating whether a tooltip containing a filename should be displayed when the mouse pointer hovers over the pane item.
Public property | HoverBorderColor | Gets or sets a color of the pane item border when the mouse pointer hovers over it.
Public property | HoverColor | Gets or sets a color of the pane item when the mouse pointer hovers over it.
Public property | ImageCroppedIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the image cropped icon.
Public property | ImageCroppedIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image cropped icon.
Public property | ImageEditorIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the image editor icon.
Public property | ImageEditorIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image editor icon.
Public property | InactiveSelectionBorderColor | Gets or sets a color of the pane item border when it is selected and not in focus.
Public property | InactiveSelectionColor | Gets or sets a color of the pane item when it is selected and not in focus.
Public property | PreviewQuality | Gets or sets a resize quality of preview thumbnails.
Public property | QualityMeter | Gets the quality meter settings.
Public property | RemovalIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the removal icon.
Public property | RemovalIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the removal icon.
Public property | RotationIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the rotation icon.
Public property | RotationIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the rotation icon.
Public property | SelectedTextColor | Gets or sets a color of the pane item text when it is selected.
Public property | SelectionBorderColor | Gets or sets a color of the pane item border when it is selected.
Public property | SelectionColor | Gets or sets a color of the pane item when it is selected.
Public property | SelectionHoverBorderColor | Gets or sets a color of the pane item border when it is selected and the mouse pointer hovers over it.
Public property | SelectionHoverColor | Gets or sets a color of the pane item when it is selected and the mouse pointer hovers over it.
Public property | ShowFileNameInThumbnailsView | Gets or sets a value indicating whether to display filenames in the Thumbnails view.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace


PaneItem Properties

  • PaneItem Class
  • See Also
  • Language Filter ( all languages )

The PaneItem type exposes the following members.

Properties

 | Name | Description
Public property | DescriptionAddedIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the description added icon.
Public property | DescriptionEditorIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the description editor icon.
Public property | DescriptionEditorIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the description editor icon.
Public property | EnableDisproportionalExifThumbnails | Get or sets a value indicating whether Image Uploader should generate a preview thumbnail from the original image in the case when thumbnail saved in EXIF metadata is out of proportions of original image.
Public property | EnableFileNameTooltip | Get or sets a value indicating whether a tooltip containing a filename should be displayed when the mouse pointer hovers over the pane item.
Public property | HoverBorderColor | Gets or sets a color of the pane item border when the mouse pointer hovers over it.
Public property | HoverColor | Gets or sets a color of the pane item when the mouse pointer hovers over it.
Public property | ImageCroppedIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the image cropped icon.
Public property | ImageCroppedIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image cropped icon.
Public property | ImageEditorIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the image editor icon.
Public property | ImageEditorIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image editor icon.
Public property | InactiveSelectionBorderColor | Gets or sets a color of the pane item border when it is selected and not in focus.
Public property | InactiveSelectionColor | Gets or sets a color of the pane item when it is selected and not in focus.
Public property | PreviewQuality | Gets or sets a resize quality of preview thumbnails.
Public property | QualityMeter | Gets the quality meter settings.
Public property | RemovalIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the removal icon.
Public property | RemovalIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the removal icon.
Public property | RotationIconImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the rotation icon.
Public property | RotationIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the rotation icon.
Public property | SelectedTextColor | Gets or sets a color of the pane item text when it is selected.
Public property | SelectionBorderColor | Gets or sets a color of the pane item border when it is selected.
Public property | SelectionColor | Gets or sets a color of the pane item when it is selected.
Public property | SelectionHoverBorderColor | Gets or sets a color of the pane item border when it is selected and the mouse pointer hovers over it.
Public property | SelectionHoverColor | Gets or sets a color of the pane item when it is selected and the mouse pointer hovers over it.
Public property | ShowFileNameInThumbnailsView | Gets or sets a value indicating whether to display filenames in the Thumbnails view.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace


DescriptionAddedIconImageFormat Property

PaneItem..::.DescriptionAddedIconImageFormat Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the description added icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property DescriptionAddedIconImageFormat As ImageFormat

C#

public ImageFormat DescriptionAddedIconImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the description added icon.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.descriptionAddedIconImageFormat JavaScript Property
  • PaneItem.DescriptionAddedIconImageFormat PHP Property


DescriptionEditorIconImageFormat Property

PaneItem..::.DescriptionEditorIconImageFormat Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the description editor icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property DescriptionEditorIconImageFormat As ImageFormat

C#

public ImageFormat DescriptionEditorIconImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the description editor icon.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.descriptionEditorIconImageFormat JavaScript Property
  • PaneItem.DescriptionEditorIconImageFormat PHP Property


DescriptionEditorIconTooltip Property

PaneItem..::.DescriptionEditorIconTooltip Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the description editor icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DescriptionEditorIconTooltip As String

C#

public string DescriptionEditorIconTooltip { get; set; }

Property Value

Type: System..::.String

The text of the tooltip which is displayed when the mouse pointer hovers over the description editor icon.

Default value is "Edit description".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.descriptionEditorIconTooltip JavaScript Property
  • PaneItem.DescriptionEditorIconTooltip PHP Property


EnableDisproportionalExifThumbnails Property

PaneItem..::.EnableDisproportionalExifThumbnails Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Get or sets a value indicating whether Image Uploader should generate a preview thumbnail from the original image in the case when thumbnail saved in EXIF metadata is out of proportions of original image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableDisproportionalExifThumbnails As Boolean

C#

public bool EnableDisproportionalExifThumbnails { get; set; }

Property Value

Type: System..::.Boolean

If true Image Uploader displays disproportional EXIF thumbnails in the list, otherwise the control resizes original image to the thumbnail size.

Default value is true.

Remarks

Note

This property takes effect in the Thumbnails, Tiles, and List views only.

To accelerate folder navigation Image Uploader supports displaying EXIF thumbnails in the folder and upload panes when the Thumbnails, Tiles, or List view mode is set. Such thumbnails are created by the most of cameras and stored along with image data. However, some cameras may create EXIF thumbnails which are out of proportions of original images. If so disproportional thumbnails will have black stripes above and below them. In this case you can set this property to false to regenerate preview thumbnails from original images and get rid of black stripes or specify a true value to display disproportional thumbnails instead.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.enableDisproportionalExifThumbnails JavaScript Property
  • PaneItem.EnableDisproportionalExifThumbnails PHP Property


EnableFileNameTooltip Property

PaneItem..::.EnableFileNameTooltip Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Get or sets a value indicating whether a tooltip containing a filename should be displayed when the mouse pointer hovers over the pane item.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableFileNameTooltip As Boolean

C#

public bool EnableFileNameTooltip { get; set; }

Property Value

Type: System..::.Boolean

If true filename tooltip is displayed when the mouse pointer hovers over the pane item.

Default value is false.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.enableFileNameTooltip JavaScript Property
  • PaneItem.EnableFileNameTooltip PHP Property


HoverBorderColor Property

PaneItem..::.HoverBorderColor Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item border when the mouse pointer hovers over it.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property HoverBorderColor As Color

C#

public Color HoverBorderColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of the pane item border when the mouse pointer hovers over it.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #99DEFD.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.hoverBorderColor JavaScript Property
  • PaneItem.HoverBorderColor PHP Property


HoverColor Property

PaneItem..::.HoverColor Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item when the mouse pointer hovers over it.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property HoverColor As GradientColor

C#

public GradientColor HoverColor { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.GradientColor

The color of the pane item when the mouse pointer hovers over it.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is #F5FAFD;#EDF8FE.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.hoverColor JavaScript Property
  • PaneItem.HoverColor PHP Property


ImageCroppedIconImageFormat Property

PaneItem..::.ImageCroppedIconImageFormat Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the image cropped icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property ImageCroppedIconImageFormat As ImageFormat

C#

public ImageFormat ImageCroppedIconImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the image cropped icon.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.imageCroppedIconImageFormat JavaScript Property
  • PaneItem.ImageCroppedIconImageFormat PHP Property


ImageCroppedIconTooltip Property

PaneItem..::.ImageCroppedIconTooltip Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image cropped icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ImageCroppedIconTooltip As String

C#

public string ImageCroppedIconTooltip { get; set; }

Property Value

Type: System..::.String

The text of the tooltip which is displayed when the mouse pointer hovers over the image cropped icon.

Default value is "The image is cropped.".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.imageCroppedIconTooltip JavaScript Property
  • PaneItem.ImageCroppedIconTooltip PHP Property


ImageEditorIconImageFormat Property

PaneItem..::.ImageEditorIconImageFormat Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the image editor icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property ImageEditorIconImageFormat As ImageFormat

C#

public ImageFormat ImageEditorIconImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the image editor icon.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.imageEditorIconImageFormat JavaScript Property
  • PaneItem.ImageEditorIconImageFormat PHP Property


ImageEditorIconTooltip Property

PaneItem..::.ImageEditorIconTooltip Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image editor icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ImageEditorIconTooltip As String

C#

public string ImageEditorIconTooltip { get; set; }

Property Value

Type: System..::.String

The text of the tooltip which is displayed when the mouse pointer hovers over the image editor icon.

Default value is "Preview / edit image".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.imageEditorIconTooltip JavaScript Property
  • PaneItem.ImageEditorIconTooltip PHP Property


InactiveSelectionBorderColor Property

PaneItem..::.InactiveSelectionBorderColor Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item border when it is selected and not in focus.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property InactiveSelectionBorderColor As Color

C#

public Color InactiveSelectionBorderColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of the pane item border when it is selected and not in focus.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #D9D9D9.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.inactiveSelectionBorderColor JavaScript Property
  • PaneItem.InactiveSelectionBorderColor PHP Property


InactiveSelectionColor Property

PaneItem..::.InactiveSelectionColor Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item when it is selected and not in focus.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property InactiveSelectionColor As GradientColor

C#

public GradientColor InactiveSelectionColor { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.GradientColor

The color of the pane item when it is selected and not in focus.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is #f8f8f8;#e5e5e5.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.inactiveSelectionColor JavaScript Property
  • PaneItem.InactiveSelectionColor PHP Property


PreviewQuality Property

PaneItem..::.PreviewQuality Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a resize quality of preview thumbnails.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property PreviewQuality As ResizeQuality

C#

public ResizeQuality PreviewQuality { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.ResizeQuality

The resize quality of preview thumbnails.

Default value is Medium.

Remarks

Note

This property takes effect in the Thumbnails, Tiles, and List views only.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.previewQuality JavaScript Property
  • PaneItem.PreviewQuality PHP Property


QualityMeter Property

PaneItem..::.QualityMeter Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the quality meter settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property QualityMeter As QualityMeter

C#

public QualityMeter QualityMeter { get; }

Property Value

Type: Aurigma.ImageUploader..::.QualityMeter

The quality meter settings.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.qualityMeter JavaScript Property
  • PaneItem.QualityMeter PHP Property

Manual

  • Using Quality Meter


RemovalIconImageFormat Property

PaneItem..::.RemovalIconImageFormat Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the removal icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property RemovalIconImageFormat As ImageFormat

C#

public ImageFormat RemovalIconImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the removal icon.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.removalIconImageFormat JavaScript Property
  • PaneItem.RemovalIconImageFormat PHP Property


RemovalIconTooltip Property

PaneItem..::.RemovalIconTooltip Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the removal icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property RemovalIconTooltip As String

C#

public string RemovalIconTooltip { get; set; }

Property Value

Type: System..::.String

The text of the tooltip which is displayed when the mouse pointer hovers over the removal icon.

Default value is "Remove".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.removalIconTooltip JavaScript Property
  • PaneItem.RemovalIconTooltip PHP Property


RotationIconImageFormat Property

PaneItem..::.RotationIconImageFormat Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the rotation icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property RotationIconImageFormat As ImageFormat

C#

public ImageFormat RotationIconImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the rotation icon.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.rotationIconImageFormat JavaScript Property
  • PaneItem.RotationIconImageFormat PHP Property


RotationIconTooltip Property

PaneItem..::.RotationIconTooltip Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the rotation icon.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property RotationIconTooltip As String

C#

public string RotationIconTooltip { get; set; }

Property Value

Type: System..::.String

The text of the tooltip which is displayed when the mouse pointer hovers over the rotation icon.

Default value is "Rotate".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.rotationIconTooltip JavaScript Property
  • PaneItem.RotationIconTooltip PHP Property


SelectedTextColor Property

PaneItem..::.SelectedTextColor Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item text when it is selected.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property SelectedTextColor As Color

C#

public Color SelectedTextColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of the pane item text when it is selected.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #000000.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.selectedTextColor JavaScript Property
  • PaneItem.SelectedTextColor PHP Property


SelectionBorderColor Property

PaneItem..::.SelectionBorderColor Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item border when it is selected.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property SelectionBorderColor As Color

C#

public Color SelectionBorderColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of the pane item border when it is selected.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #99defd.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.selectionBorderColor JavaScript Property
  • PaneItem.SelectionBorderColor PHP Property


SelectionColor Property

PaneItem..::.SelectionColor Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item when it is selected.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property SelectionColor As GradientColor

C#

public GradientColor SelectionColor { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.GradientColor

The color of the pane item when it is selected.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is #f0f8fd;#d5effc.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.selectionColor JavaScript Property
  • PaneItem.SelectionColor PHP Property


SelectionHoverBorderColor Property

PaneItem..::.SelectionHoverBorderColor Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item border when it is selected and the mouse pointer hovers over it.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property SelectionHoverBorderColor As Color

C#

public Color SelectionHoverBorderColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of the pane item border when it is selected and the mouse pointer hovers over it.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #99defd.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.selectionHoverBorderColor JavaScript Property
  • PaneItem.SelectionHoverBorderColor PHP Property


SelectionHoverColor Property

PaneItem..::.SelectionHoverColor Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item when it is selected and the mouse pointer hovers over it.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property SelectionHoverColor As GradientColor

C#

public GradientColor SelectionHoverColor { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.GradientColor

The color of the pane item when it is selected and the mouse pointer hovers over it.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is #e8f6fd;#c4e8fa.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.selectionHoverColor JavaScript Property
  • PaneItem.SelectionHoverColor PHP Property


ShowFileNameInThumbnailsView Property

PaneItem..::.ShowFileNameInThumbnailsView Property

  • Collapse All Sections
  • PaneItem Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to display filenames in the Thumbnails view.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ShowFileNameInThumbnailsView As Boolean

C#

public bool ShowFileNameInThumbnailsView { get; set; }

Property Value

Type: System..::.Boolean

If true, filenames are displayed under thumbnails; otherwise, only thumbnails are shown.

Default value is false.

See Also

Reference

  • PaneItem Class
  • Aurigma.ImageUploader Namespace
  • $au.paneItem.showFileNameInThumbnailsView JavaScript Property
  • PaneItem.ShowFileNameInThumbnailsView PHP Property


PaneLayoutMode Enumeration

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Specifies possible values for layouts of Image Uploader panes.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration PaneLayoutMode

C#

public enum PaneLayoutMode

Members

Member name | Description
OnePane | Only the upload pane representing a list of user-selected files is displayed. Users can drag-and-drop necessary files from Windows Explorer, Finder, or any other graphic shell to this list.
ThreePanes | Folders tree + folder view + upload list. Drag-n-drop the necessary files from the folder view or Windows Explorer to the upload list.

See Also

Reference

  • Aurigma.ImageUploader Namespace
  • Uploader..::.PaneLayout


PaneSortMode Enumeration

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Specifies possible values for sort modes.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration PaneSortMode

C#

public enum PaneSortMode

Members

Member name | Description
Name | Items are sorted by name alphabetically.
Size | Items are sorted by file size.
Type | Items are sorted by file type alphabetically.
Modified | Items are sorted by the date of last modification.
Path | Items are sorted by full path.
Dimensions | Items are sorted by image dimensions.
Unsorted | Items are unsorted.

See Also

Reference

  • Aurigma.ImageUploader Namespace
  • FolderPane.SortMode
  • UploadPane.SortMode


PaneViewMode Enumeration

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Specifies possible values for Image Uploader view modes.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration PaneViewMode

C#

public enum PaneViewMode

Members

Member name | Description
Thumbnails | Images are displayed as thumbnails, non-images are displayed as icons. It is possible to attach a description to each file. If a file is recognized as image, it can be cropped and rotated.
Tiles | Each file appears as a thumbnail (or icon for non-image files), with a file name and details (file type, last modification date, and file size) on the right. It is possible to attach a description to each file. If a file is recognized as image, it can be cropped and rotated.
Details | Files are displayed as small thumbnails (or icons for non-image files) with names on the right.
List | All the files are displayed as a detailed list (icon + filename + info + size + last modification date + type + image dimensions).

See Also

Reference

  • Aurigma.ImageUploader Namespace
  • FolderPane.ViewMode
  • UploadPane.ViewMode


PostFields Class

  • Members
  • See Also
  • Language Filter ( all languages )

This class contains POST field names that are generated and uploaded by Image Uploader.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public NotInheritable Class PostFields

C#

public static class PostFields

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.PostFields

See Also

Reference

  • PostFields Members
  • Aurigma.ImageUploader Namespace
  • PostFields PHP Class


PostFields Members

  • PostFields Class
  • Methods
  • Fields
  • See Also
  • Language Filter ( all languages )

The PostFields type exposes the following members.

Methods

Name | Description
GetDateTimeValue | Returns a DateTime that represent a value of the specified field.
GetIntValue | Returns a Int32 that represent a value of the specified field.
GetStringValue | Returns a String that represent a value of the specified field.

Fields

Name | Description
Angle | Represents the name of the field which contains a rotation angle.
CropBounds | Represents the name of the field which contains bounds of cropped area.
Description | Represents the name of the field which contains a user-provided description of the original file.
File | Represents the name of the field which contains a converted file.
FileChunkCount | Represents the name of the field which contains a number of chunks on which the converted file was divided.
FileChunkIndex | Represents the name of the field which contains a zero-based index of the chunk.
FileHeight | Represents the name of the field which contains an actual height of the converted file.
FileMode | Represents the name of the field which contains the mode of the converted file.
FileName | Represents the name of the field which contains the name of the converted file.
FileSize | Represents the name of the field which contains the size of the converted file.
FileWidth | Represents the name of the field which contains an actual width of the converted file.
PackageComplete | Represents the name of the field which is sent in the end of the package.
PackageCount | Represents the name of the field which contains a total number of packages (i.e. requests) in the current upload session.
PackageFileCount | Represents the name of the field which contains the number of files uploaded in the current package.
PackageGuid | Represents the name of the field which contains a unique identifier of the current upload session.
PackageIndex | Represents the name of the field which contains a zero-based index of the package inside the current upload session.
RequestComplete | Represents the name of the field which is sent in the end of the upload request.
SourceCreatedDateTime | Represents the name of the field which contains a creation date of the original file.
SourceCreatedDateTimeLocal | Represents the name of the field which contains a local creation date of the original file.
SourceHeight | Represents the name of the field which contains the height of the original file.
SourceLastModifiedDateTime | Represents the name of the field which contains a last modification date of the original file.
SourceLastModifiedDateTimeLocal | Represents the name of the field which contains a local last modification date of the original file.
SourceName | Represents the name of the field which contains the name of the original file.
SourceSize | Represents the name of the field which contains the size of the original file.
SourceWidth | Represents the name of the field which contains the width of the original file.
SourceXResolution | Represents the name of the field which contains a horizontal resolution of the original file.
SourceYResolution | Represents the name of the field which contains a vertical resolution of the original file.
Tag | Represents the name of the field which contains a tag of the original file.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace


PostFields Fields

  • PostFields Class
  • See Also
  • Language Filter ( all languages )

The PostFields type exposes the following members.

Fields

Name | Description
Angle | Represents the name of the field which contains a rotation angle.
CropBounds | Represents the name of the field which contains bounds of cropped area.
Description | Represents the name of the field which contains a user-provided description of the original file.
File | Represents the name of the field which contains a converted file.
FileChunkCount | Represents the name of the field which contains a number of chunks on which the converted file was divided.
FileChunkIndex | Represents the name of the field which contains a zero-based index of the chunk.
FileHeight | Represents the name of the field which contains an actual height of the converted file.
FileMode | Represents the name of the field which contains the mode of the converted file.
FileName | Represents the name of the field which contains the name of the converted file.
FileSize | Represents the name of the field which contains the size of the converted file.
FileWidth | Represents the name of the field which contains an actual width of the converted file.
PackageComplete | Represents the name of the field which is sent in the end of the package.
PackageCount | Represents the name of the field which contains a total number of packages (i.e. requests) in the current upload session.
PackageFileCount | Represents the name of the field which contains the number of files uploaded in the current package.
PackageGuid | Represents the name of the field which contains a unique identifier of the current upload session.
PackageIndex | Represents the name of the field which contains a zero-based index of the package inside the current upload session.
RequestComplete | Represents the name of the field which is sent in the end of the upload request.
SourceCreatedDateTime | Represents the name of the field which contains a creation date of the original file.
SourceCreatedDateTimeLocal | Represents the name of the field which contains a local creation date of the original file.
SourceHeight | Represents the name of the field which contains the height of the original file.
SourceLastModifiedDateTime | Represents the name of the field which contains a last modification date of the original file.
SourceLastModifiedDateTimeLocal | Represents the name of the field which contains a local last modification date of the original file.
SourceName | Represents the name of the field which contains the name of the original file.
SourceSize | Represents the name of the field which contains the size of the original file.
SourceWidth | Represents the name of the field which contains the width of the original file.
SourceXResolution | Represents the name of the field which contains a horizontal resolution of the original file.
SourceYResolution | Represents the name of the field which contains a vertical resolution of the original file.
Tag | Represents the name of the field which contains a tag of the original file.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace


Angle Field

PostFields..::.Angle Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a rotation angle.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • Angle


CropBounds Field

PostFields..::.CropBounds Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains bounds of cropped area.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • CropBounds


Description Field

PostFields..::.Description Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a user-provided description of the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • Description


File Field

PostFields..::.File Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a converted file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains two placeholders:

{0}
replaced by the index of this file in the uploaded package.
{1}
replaced by the index of the converted file created for the {0}th user-selected file.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • File


FileChunkCount Field

PostFields..::.FileChunkCount Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a number of chunks on which the converted file was divided.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains two placeholders:

{0}
replaced by the index of this file in the uploaded package.
{1}
replaced by the index of the converted file created for the {0}th user-selected file.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • FileChunkCount


FileChunkIndex Field

PostFields..::.FileChunkIndex Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a zero-based index of the chunk.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains two placeholders:

{0}
replaced by the index of this file in the uploaded package.
{1}
replaced by the index of the converted file created for the {0}th user-selected file.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • FileChunkIndex


FileHeight Field

PostFields..::.FileHeight Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains an actual height of the converted file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains two placeholders:

{0}
replaced by the index of this file in the uploaded package.
{1}
replaced by the index of the converted file created for the {0}th user-selected file.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • FileHeight


FileMode Field

PostFields..::.FileMode Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains the mode of the converted file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains two placeholders:

{0}
replaced by the index of this file in the uploaded package.
{1}
replaced by the index of the converted file created for the {0}th user-selected file.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • FileMode


FileName Field

PostFields..::.FileName Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains the name of the converted file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains two placeholders:

{0}
replaced by the index of this file in the uploaded package.
{1}
replaced by the index of the converted file created for the {0}th user-selected file.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • FileName


FileSize Field

PostFields..::.FileSize Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains the size of the converted file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains two placeholders:

{0}
replaced by the index of this file in the uploaded package.
{1}
replaced by the index of the converted file created for the {0}th user-selected file.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • FileSize


FileWidth Field

PostFields..::.FileWidth Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains an actual width of the converted file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains two placeholders:

{0}
replaced by the index of this file in the uploaded package.
{1}
replaced by the index of the converted file created for the {0}th user-selected file.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • FileWidth


PackageComplete Field

PostFields..::.PackageComplete Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which is sent in the end of the package.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • PackageComplete


PackageCount Field

PostFields..::.PackageCount Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a total number of packages (i.e. requests) in the current upload session.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • PackageCount


PackageFileCount Field

PostFields..::.PackageFileCount Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains the number of files uploaded in the current package.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • PackageFileCount


PackageGuid Field

PostFields..::.PackageGuid Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a unique identifier of the current upload session.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • PackageGuid


PackageIndex Field

PostFields..::.PackageIndex Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a zero-based index of the package inside the current upload session.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • PackageIndex


RequestComplete Field

PostFields..::.RequestComplete Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which is sent in the end of the upload request.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • RequestComplete


SourceCreatedDateTime Field

PostFields..::.SourceCreatedDateTime Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a creation date of the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • SourceCreatedDateTime


SourceCreatedDateTimeLocal Field

PostFields..::.SourceCreatedDateTimeLocal Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a local creation date of the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • SourceCreatedDateTimeLocal


SourceHeight Field

PostFields..::.SourceHeight Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains the height of the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • SourceHeight


SourceLastModifiedDateTime Field

PostFields..::.SourceLastModifiedDateTime Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a last modification date of the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • SourceLastModifiedDateTime


SourceLastModifiedDateTimeLocal Field

PostFields..::.SourceLastModifiedDateTimeLocal Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a local last modification date of the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • SourceLastModifiedDateTimeLocal


SourceName Field

PostFields..::.SourceName Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains the name of the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • SourceName


SourceSize Field

PostFields..::.SourceSize Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains the size of the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • SourceSize


SourceWidth Field

PostFields..::.SourceWidth Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains the width of the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • SourceWidth


SourceXResolution Field

PostFields..::.SourceXResolution Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a horizontal resolution of the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • SourceXResolution


SourceYResolution Field

PostFields..::.SourceYResolution Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a vertical resolution of the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • SourceYResolution


Tag Field

PostFields..::.Tag Field

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Represents the name of the field which contains a tag of the original file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Remarks

The value of this field contains the following placeholder:

{0}
replaced by the index of this file in the uploaded package.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace
  • Tag


PostFields Methods

  • PostFields Class
  • See Also
  • Language Filter ( all languages )

The PostFields type exposes the following members.

Methods

Name | Description
GetDateTimeValue | Returns a DateTime that represent a value of the specified field.
GetIntValue | Returns a Int32 that represent a value of the specified field.
GetStringValue | Returns a String that represent a value of the specified field.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace


GetDateTimeValue Method

PostFields..::.GetDateTimeValue Method

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Returns a DateTime that represent a value of the specified field.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Shared Function GetDateTimeValue ( _
    fields As NameValueCollection, _
    name As String _
) As DateTime

C#

public static DateTime GetDateTimeValue(
    NameValueCollection fields,
    string name
)

Parameters

fields

Type: System.Collections.Specialized..::.NameValueCollection

The collection of POST fields returned by the Package.PackageFields property.

name

Type: System..::.String

The name of the field to retrieve a value.

Return Value

Type: System..::.DateTime

The DateTime representation of the specified field value.

Note

If the value cannot be converted to DateTime, this method returns an empty DateTime object.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace


GetIntValue Method

PostFields..::.GetIntValue Method

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Returns a Int32 that represent a value of the specified field.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Shared Function GetIntValue ( _
    fields As NameValueCollection, _
    name As String _
) As Integer

C#

public static int GetIntValue(
    NameValueCollection fields,
    string name
)

Parameters

fields

Type: System.Collections.Specialized..::.NameValueCollection

The collection of POST fields returned by the Package.PackageFields property.

name

Type: System..::.String

The name of the field to retrieve a value.

Return Value

Type: System..::.Int32

The Int32 representation of the specified field value.

Note

If the value cannot be converted to Int32, this method returns 0.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace


GetStringValue Method

PostFields..::.GetStringValue Method

  • Collapse All Sections
  • PostFields Class
  • See Also
  • Language Filter ( all languages )

Returns a String that represent a value of the specified field.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Shared Function GetStringValue ( _
    fields As NameValueCollection, _
    name As String _
) As String

C#

public static string GetStringValue(
    NameValueCollection fields,
    string name
)

Parameters

fields

Type: System.Collections.Specialized..::.NameValueCollection

The collection of POST fields returned by the Package.PackageFields property.

name

Type: System..::.String

The name of the field to retrieve a value.

Return Value

Type: System..::.String

The String representation of the specified field value.

See Also

Reference

  • PostFields Class
  • Aurigma.ImageUploader Namespace


ProgressBytesMode Enumeration

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Specifies possible values for the ProgressBytesMode property.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration ProgressBytesMode

C#

public enum ProgressBytesMode

Members

Member name | Description
ByPackageSize | The size of the uploaded session and the uploaded bytes are measured by the size of the current package. Thus, this mode is the nearest estimation of the uploaded bytes when you set several converters and upload all files in one package (i.e. FilesPerPackage is 0).
BySourceSize | The size of the upload session and the uploaded bytes are measured by sizes of user-selected files. For example, if you select two files of 5 and 10 Mb, the total upload size will be 15 Mb and the amount of uploaded bytes will grow from 0 to 15 Mb during the upload, regardless of converted files and other auxiliary data. Thus, this mode is the nearest estimation of the uploaded bytes when you upload original files only.

Remarks

This property determines how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server. These data are used in the uploading files dialog and the Progress event.

See Also

Reference

  • Aurigma.ImageUploader Namespace
  • UploadSettings..::.ProgressBytesMode
  • Progress

Manual

  • Configuring Files to be Uploaded


QualityMeter Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the quality meter.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class QualityMeter

C#

public class QualityMeter

Remarks

Note

Image Uploader Express and Professional disable quality meter functionality. See the Comparison of Image Uploader Editions topic for details.

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.QualityMeter

See Also

Reference

  • QualityMeter Members
  • Aurigma.ImageUploader Namespace
  • PaneItem..::.QualityMeter
  • $au.qualityMeter JavaScript Class
  • QualityMeter PHP Class

Manual

  • Additional Controls and Indicators
  • Using Quality Meter


QualityMeter Members

  • QualityMeter Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The QualityMeter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AcceptableQualityColor | Gets or sets a color of the quality meter element which corresponds to the maximum acceptable print format
Public property | BackgroundColor | Gets or sets a background color of the quality meter.
Public property | BorderColor | Gets or sets a color of the quality meter border.
Public property | Formats | Gets or sets print formats for the quality meter.
Public property | Height | Gets or sets a height of each quality meter rectangle.
Public property | HighQualityColor | Gets or sets a color of the quality meter element which corresponds to the recommended print format.
Public property | LowQualityColor | Gets or sets a color of the quality meter element corresponding to the print format which is not recommended for printing.

See Also

Reference

  • QualityMeter Class
  • Aurigma.ImageUploader Namespace


QualityMeter Properties

  • QualityMeter Class
  • See Also
  • Language Filter ( all languages )

The QualityMeter type exposes the following members.

Properties

 | Name | Description
Public property | AcceptableQualityColor | Gets or sets a color of the quality meter element which corresponds to the maximum acceptable print format
Public property | BackgroundColor | Gets or sets a background color of the quality meter.
Public property | BorderColor | Gets or sets a color of the quality meter border.
Public property | Formats | Gets or sets print formats for the quality meter.
Public property | Height | Gets or sets a height of each quality meter rectangle.
Public property | HighQualityColor | Gets or sets a color of the quality meter element which corresponds to the recommended print format.
Public property | LowQualityColor | Gets or sets a color of the quality meter element corresponding to the print format which is not recommended for printing.

See Also

Reference

  • QualityMeter Class
  • Aurigma.ImageUploader Namespace


AcceptableQualityColor Property

QualityMeter..::.AcceptableQualityColor Property

  • Collapse All Sections
  • QualityMeter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the quality meter element which corresponds to the maximum acceptable print format

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property AcceptableQualityColor As Color

C#

public Color AcceptableQualityColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of the quality meter element for acceptable print formats.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #ffc600.

Remarks

The quality of the print in this format will be good enough, but worse than for allowed print formats that is specified with the HighQualityColor.

See Also

Reference

  • QualityMeter Class
  • Aurigma.ImageUploader Namespace
  • $au.qualityMeter.acceptableQualityColor JavaScript Property
  • QualityMeter.AcceptableQualityColor PHP Property


BackgroundColor Property

QualityMeter..::.BackgroundColor Property

  • Collapse All Sections
  • QualityMeter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of the quality meter.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property BackgroundColor As Color

C#

public Color BackgroundColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The background color of the quality meter.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #ffffff.

See Also

Reference

  • QualityMeter Class
  • Aurigma.ImageUploader Namespace
  • $au.qualityMeter.backgroundColor JavaScript Property
  • QualityMeter.BackgroundColor PHP Property


BorderColor Property

QualityMeter..::.BorderColor Property

  • Collapse All Sections
  • QualityMeter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the quality meter border.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property BorderColor As Color

C#

public Color BorderColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of the quality meter border.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #154575.

See Also

Reference

  • QualityMeter Class
  • Aurigma.ImageUploader Namespace
  • $au.qualityMeter.borderColor JavaScript Property
  • QualityMeter.BorderColor PHP Property


Formats Property

QualityMeter..::.Formats Property

  • Collapse All Sections
  • QualityMeter Class
  • Example
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets print formats for the quality meter.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Formats As String

C#

public string Formats { get; set; }

Property Value

Type: System..::.String

Print formats used in the quality meter. Format of this string is the following:

Format1 name,format1 width (pixels),format1 height (pixels),format1 acceptable ratio;Format2 name,format2 width (pixels),format2 height (pixels),format2 acceptable ratio;...

In other words:

  • Each format is defined with 4 mandatory parameters: name, width, height, and acceptable ratio.
  • Parameters are separated by comma.
  • Formats are separated by semicolon.

See the Remarks section for more details about syntax of this string.

If this property is not initialized or set to incorrect value no quality meter is displayed.

Default value is "".

Remarks

As mentioned above, each print format is described with four parameters:

Format name

Name of the print format which will be displayed as a tooltip when a mouse is hovering over an appropriate quality meter element.

If the format name contains semicolon or quotation mark characters enclose this format in single (' ') or double (" ") quotes. Additionally, quotation marks (both single ' and double ") inside the name should be escaped with a backslash. For example, to get a User's format name, set this format as follows:

"User\'s format,1800,1200,1.2";...

Format width
Minimum width (in pixels) which the photo should have to be interpreted as high quality for this print format (i.e. colored by the HighQualityColor value).
Format height
Minimum height (in pixels) which the photo should have to be interpreted as high quality for this print format (i.e. colored by the HighQualityColor value).
Acceptable ratio (further, AR)
Maximum acceptable ratio of format width (or height) and actual photo width (or height). If format width/photo width will be larger than AR, the photo will be interpreted as unacceptable for this print format.
Note

To be interpreted as high quality, the photo should have both width and height equal or larger than specified ones. Say, if width conforms to the limitation, but height does not, the photo will not be interpreted as high quality.

Examples

Imagine we specify the following quality meter string:

ASP.NET

<QualityMeter Formats="4x6 inches,1800,1200,1.2;6x8 inches,2400,1800,1.3;" />

It means that you specify two formats: 4x6 inches (1200x1800 pixels if to print with resolution equal to 300 DPI) and 6x8 inches (1800x2400 pixels for 300 DPI). This way the quality meter will have two elements. The table below demonstrates the quality meter values for images of different size. Let us assume that the default values for the quality meter colors are used (allowed formats are green, acceptable - yellow, non-recommended ones are gray).

Image dimensions Quality meter colors Comment
2000x3000
  • 4x6 inches - Green
  • 6x8 inches - Green
Image dimensions exceed both format restrictions, so we can freely print it in both formats.
1500x2000
  • 4x6 inches - Green
  • 6x8 inches - Yellow

The dimensions are larger than 4x6 inches, but smaller than 6x8 inches. Now we should estimate if it can be printed with the acceptable quality in 6x8 format. To do it, calculate the ratio between the format dimensions and the actual image dimensions (we take a width for brevity):

1800/1500 = 1.2

Now we compare this value with the acceptable ratio (AR) specified as the fourth parameter. If this value is larger than AR, an image cannot be printed with this format, if otherwise - it is acceptable.

The AR specified for 6x8 inches is 1.3, thus it is acceptable and we mark a color meter with yellow.

1200x1800
  • 4x6 inches - Green
  • 6x8 inches - Gray

The dimensions conform 4x6 inches, but are smaller than 6x8 inches. This time if we calculate the ratio between the format dimensions and the actual image dimensions, we will get:

1800/1200 = 1.5

It is larger than the AR (which is equal to 1.3) and that is why if we print this image in the 6x8 inches format, we will get quite poor quality. So we mark this color meter item to gray (i.e. as "not recommended").

1024x1536
  • 4x6 inches - Yellow
  • 6x8 inches - Gray

The dimensions of this image are smaller than both formats. It is obviously too small for the 6x8 inches format, but let us check it for the 4x6 format:

1200/1024 = 1.171875

The AR for the 4x6 inches format is 1.2, i.e. this image acceptable for it, and the appropriate quality meter element is yellow.

96x96
  • 4x6 inches - Gray
  • 6x8 inches - Gray
It is obvious that this image is too small to be printed even on a matchbox, so both elements of the quality meter are gray.

See Also

Reference

  • QualityMeter Class
  • Aurigma.ImageUploader Namespace
  • $au.qualityMeter.formats JavaScript Property
  • QualityMeter.Formats PHP Property


Height Property

QualityMeter..::.Height Property

  • Collapse All Sections
  • QualityMeter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of each quality meter rectangle.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Height As Integer

C#

public int Height { get; set; }

Property Value

Type: System..::.Int32

The height of each quality meter rectangle.

Default value is 11.

Remarks

If the quality meter height is larger than a thumbnail height (specified with the FolderPane.PreviewSize and UploadPane.PreviewSize properties), it is automatically shrunk down to fit this distance.

See Also

Reference

  • QualityMeter Class
  • Aurigma.ImageUploader Namespace
  • $au.qualityMeter.height JavaScript Property
  • QualityMeter.Height PHP Property


HighQualityColor Property

QualityMeter..::.HighQualityColor Property

  • Collapse All Sections
  • QualityMeter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the quality meter element which corresponds to the recommended print format.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property HighQualityColor As Color

C#

public Color HighQualityColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of the quality meter element which corresponds to the recommended print format.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #5bc529.

Remarks

If the image will be printed in this format, the quality will be high (i.e. the printing machine will be able to print it with high resolution).

See Also

Reference

  • QualityMeter Class
  • Aurigma.ImageUploader Namespace
  • $au.qualityMeter.highQualityColor JavaScript Property
  • QualityMeter.HighQualityColor PHP Property


LowQualityColor Property

QualityMeter..::.LowQualityColor Property

  • Collapse All Sections
  • QualityMeter Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the quality meter element corresponding to the print format which is not recommended for printing.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property LowQualityColor As Color

C#

public Color LowQualityColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of the quality meter element corresponding to the print format which is not recommended for printing.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #ececec.

Remarks

If the image will be printed in this format, the quality will be unacceptable because printing machine will not be able to print it with high enough resolution.

See Also

Reference

  • QualityMeter Class
  • Aurigma.ImageUploader Namespace
  • $au.qualityMeter.lowQualityColor JavaScript Property
  • QualityMeter.LowQualityColor PHP Property


ResizeQuality Enumeration

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Specifies possible values for resize qualities.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration ResizeQuality

C#

public enum ResizeQuality

Members

Member name | Description
Low | Low quality. The image is resized using the nearest-neighbor algorithm.
Medium | Medium quality. The image is resized using the anisotropic algorithm.
High | High quality. The image is resized using the lanczos algorithm.

See Also

Reference

  • Aurigma.ImageUploader Namespace
  • PaneItem.PreviewQuality
  • Converter.ThumbnailResizeQuality


Restrictions Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class contains masks for allowed and denied file extensions and upload restrictions.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class Restrictions

C#

public class Restrictions

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.Restrictions

See Also

Reference

  • Restrictions Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.Restrictions
  • $au.restrictions JavaScript Class
  • Restrictions PHP Class

Manual

  • Configuring Restriction Rules for Files


Restrictions Members

  • Restrictions Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The Restrictions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DeniedFileMask | Gets or set a file mask for the files that are denied to be uploaded.
Public property | EnableCmyk | Gets or sets a value indicating whether it is impossible to select CMYK images for the upload.
Public property | FileMask | Gets or sets a file mask for the files which are allowed to be uploaded.
Public property | MaxFileCount | Gets or sets a maximum number of files allowed for upload per one session.
Public property | MaxFileSize | Gets or sets a maximum file size which is allowed for upload to the server.
Public property | MaxImageHeight | Gets or sets a maximum image height allowed for upload.
Public property | MaxImageWidth | Gets or sets a maximum image width allowed for upload.
Public property | MaxTotalFileSize | Gets or sets a maximum total file size allowed for upload.
Public property | MinFileCount | Gets or sets a minimum number of files allowed for upload per one session.
Public property | MinFileSize | Gets or sets a minimum file size allowed for upload.
Public property | MinImageHeight | Gets or sets a minimum image height allowed for upload.
Public property | MinImageWidth | Gets or sets a minimum image width allowed for upload.

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace


Restrictions Properties

  • Restrictions Class
  • See Also
  • Language Filter ( all languages )

The Restrictions type exposes the following members.

Properties

 | Name | Description
Public property | DeniedFileMask | Gets or set a file mask for the files that are denied to be uploaded.
Public property | EnableCmyk | Gets or sets a value indicating whether it is impossible to select CMYK images for the upload.
Public property | FileMask | Gets or sets a file mask for the files which are allowed to be uploaded.
Public property | MaxFileCount | Gets or sets a maximum number of files allowed for upload per one session.
Public property | MaxFileSize | Gets or sets a maximum file size which is allowed for upload to the server.
Public property | MaxImageHeight | Gets or sets a maximum image height allowed for upload.
Public property | MaxImageWidth | Gets or sets a maximum image width allowed for upload.
Public property | MaxTotalFileSize | Gets or sets a maximum total file size allowed for upload.
Public property | MinFileCount | Gets or sets a minimum number of files allowed for upload per one session.
Public property | MinFileSize | Gets or sets a minimum file size allowed for upload.
Public property | MinImageHeight | Gets or sets a minimum image height allowed for upload.
Public property | MinImageWidth | Gets or sets a minimum image width allowed for upload.

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace


DeniedFileMask Property

Restrictions..::.DeniedFileMask Property

  • Collapse All Sections
  • Restrictions Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or set a file mask for the files that are denied to be uploaded.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DeniedFileMask As String

C#

public string DeniedFileMask { get; set; }

Property Value

Type: System..::.String

The file mask for the files that are denied to be uploaded. You can use the standard wildcards such as asterisk * (arbitrary substring) and question mark ? (arbitrary character). To specify several masks, separate them by semicolons, e.g. *.exe;*.asp;*.htm.

Default value is "".

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace
  • Messages..::.FileNameNotAllowed
  • $au.restrictions.deniedFileMask JavaScript Property
  • Restrictions.DeniedFileMask PHP Property

Manual

  • Filtering Files by Names and Types


EnableCmyk Property

Restrictions..::.EnableCmyk Property

  • Collapse All Sections
  • Restrictions Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is impossible to select CMYK images for the upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableCmyk As Boolean

C#

public bool EnableCmyk { get; set; }

Property Value

Type: System..::.Boolean

If false, a user cannot select CMYK images for the upload. Otherwise, CMYK images are allowed to be uploaded.

Default value is true.

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace
  • Messages..::.CmykImagesNotAllowed
  • $au.restrictions.enableCmyk JavaScript Property
  • Restrictions.EnableCmyk PHP Property

Manual

  • Setting Limitations for Images


FileMask Property

Restrictions..::.FileMask Property

  • Collapse All Sections
  • Restrictions Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a file mask for the files which are allowed to be uploaded.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FileMask As String

C#

public string FileMask { get; set; }

Property Value

Type: System..::.String

The file mask for the files which are allowed to be uploaded. You can use the standard wildcards such as asterisk * (arbitrary substring) and question mark ? (arbitrary character). To specify several masks, separate them by semicolons, e.g. *.jpg;*.jpeg;*.jpe. To display all possible files, use *.*.

Default value is "*.*".

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace
  • Messages..::.FileNameNotAllowed
  • $au.restrictions.fileMask JavaScript Property
  • Restrictions.FileMask PHP Property

Manual

  • Filtering Files by Names and Types


MaxFileCount Property

Restrictions..::.MaxFileCount Property

  • Collapse All Sections
  • Restrictions Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum number of files allowed for upload per one session.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MaxFileCount As Integer

C#

public int MaxFileCount { get; set; }

Property Value

Type: System..::.Int32

The maximum file count allowed for upload per one session. If the value is 0 then there is no limit.

Default value is 0.

Remarks

Note

Image Uploader Express restricts the maximum number of user-selected files to 100. See the Comparison of Image Uploader Editions topic for details.

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace
  • Messages..::.MaxFileCountExceeded
  • $au.restrictions.maxFileCount JavaScript Property
  • Restrictions.MaxFileCount PHP Property

Manual

  • Setting Limitations for Size and Number of Files


MaxFileSize Property

Restrictions..::.MaxFileSize Property

  • Collapse All Sections
  • Restrictions Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum file size which is allowed for upload to the server.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MaxFileSize As Long

C#

public long MaxFileSize { get; set; }

Property Value

Type: System..::.Int64

The maximum size (in bytes) for files allowed for upload. If the value is 0 then there is no limit.

Note

When you set the value that is more than 2 Gb, it is recommended to pass such value as a string.

Default value is 0.

Remarks

Note

Image Uploader Express restricts the maximum size of each user-selected file to 100 Mb. Image Uploader Professional and Print restrict the maximum size of each user-selected file to 2 Gb. See the Comparison of Image Uploader Editions topic for details.

This property limits only a single file. If you want to set limit for all selected files, use the MaxTotalFileSize property.

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace
  • Messages..::.MaxFileSizeExceeded
  • $au.restrictions.maxFileSize JavaScript Property
  • Restrictions.MaxFileSize PHP Property

Manual

  • Setting Limitations for Size and Number of Files


MaxImageHeight Property

Restrictions..::.MaxImageHeight Property

  • Collapse All Sections
  • Restrictions Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum image height allowed for upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MaxImageHeight As Integer

C#

public int MaxImageHeight { get; set; }

Property Value

Type: System..::.Int32

The maximum allowed image height (in pixels). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace
  • Messages..::.DimensionsTooLarge
  • $au.restrictions.maxImageHeight JavaScript Property
  • Restrictions.MaxImageHeight PHP Property

Manual

  • Setting Limitations for Images


MaxImageWidth Property

Restrictions..::.MaxImageWidth Property

  • Collapse All Sections
  • Restrictions Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum image width allowed for upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MaxImageWidth As Integer

C#

public int MaxImageWidth { get; set; }

Property Value

Type: System..::.Int32

The maximum allowed image width (in pixels). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace
  • Messages..::.DimensionsTooLarge
  • $au.restrictions.maxImageWidth JavaScript Property
  • Restrictions.MaxImageWidth PHP Property

Manual

  • Setting Limitations for Images


MaxTotalFileSize Property

Restrictions..::.MaxTotalFileSize Property

  • Collapse All Sections
  • Restrictions Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum total file size allowed for upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MaxTotalFileSize As Long

C#

public long MaxTotalFileSize { get; set; }

Property Value

Type: System..::.Int64

The maximum size (in bytes) of all files selected for upload. If the value is 0 then there is no limit.

Note

When you set the value that is more than 2 Gb, it is recommended to pass such value as a string.

Default value is 0.

Remarks

Note

Only original file sizes are taken into account. Size of converted files and other auxiliary data is disregarded. So this property is useful when you upload original files without applying any client-side file transformations.

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace
  • Messages..::.MaxTotalFileSizeExceeded
  • $au.restrictions.maxTotalFileSize JavaScript Property
  • Restrictions.MaxTotalFileSize PHP Property

Manual

  • Setting Limitations for Size and Number of Files


MinFileCount Property

Restrictions..::.MinFileCount Property

  • Collapse All Sections
  • Restrictions Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum number of files allowed for upload per one session.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MinFileCount As Integer

C#

public int MinFileCount { get; set; }

Property Value

Type: System..::.Int32

The minimum file count allowed for upload per one session.

Default value is 1.

Remarks

Note

The Upload button is disabled if the number of files selected for upload less than this value.

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace
  • $au.restrictions.minFileCount JavaScript Property
  • Restrictions.MinFileCount PHP Property

Manual

  • Setting Limitations for Size and Number of Files


MinFileSize Property

Restrictions..::.MinFileSize Property

  • Collapse All Sections
  • Restrictions Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum file size allowed for upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MinFileSize As Long

C#

public long MinFileSize { get; set; }

Property Value

Type: System..::.Int64

The minimum allowed file size (in bytes). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace
  • Messages..::.FileSizeTooSmall
  • $au.restrictions.minFileSize JavaScript Property
  • Restrictions.MinFileSize PHP Property

Manual

  • Setting Limitations for Size and Number of Files


MinImageHeight Property

Restrictions..::.MinImageHeight Property

  • Collapse All Sections
  • Restrictions Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum image height allowed for upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MinImageHeight As Integer

C#

public int MinImageHeight { get; set; }

Property Value

Type: System..::.Int32

The minimum allowed image height (in pixels). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace
  • Messages..::.DimensionsTooSmall
  • $au.restrictions.minImageHeight JavaScript Property
  • Restrictions.MinImageHeight PHP Property

Manual

  • Setting Limitations for Images


MinImageWidth Property

Restrictions..::.MinImageWidth Property

  • Collapse All Sections
  • Restrictions Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum image width allowed for upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MinImageWidth As Integer

C#

public int MinImageWidth { get; set; }

Property Value

Type: System..::.Int32

The minimum allowed image width (in pixels). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • Restrictions Class
  • Aurigma.ImageUploader Namespace
  • Messages..::.DimensionsTooSmall
  • $au.restrictions.minImageWidth JavaScript Property
  • Restrictions.MinImageWidth PHP Property

Manual

  • Setting Limitations for Images


StatusPane Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the status pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class StatusPane

C#

public class StatusPane

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.StatusPane

See Also

Reference

  • StatusPane Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.StatusPane
  • $au.statusPane JavaScript Class
  • StatusPane PHP Class

Manual

  • Customizing Appearance


StatusPane Members

  • StatusPane Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The StatusPane type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ClearAllHyperlinkText | Gets or sets a text of the Clear all hyperlink.
Public property | Color | Gets or sets a color of the status pane.
Public property | FilesToUploadText | Gets or sets a text on the status pane which is displayed when at least one file is added to the upload pane.
Public property | NoFilesToUploadText | Gets or sets a text on the status pane which is displayed when the upload pane is empty.
Public property | ProgressBarText | Gets or sets a text displayed in the progress bar during the upload if the instant upload feature is used.

See Also

Reference

  • StatusPane Class
  • Aurigma.ImageUploader Namespace


StatusPane Properties

  • StatusPane Class
  • See Also
  • Language Filter ( all languages )

The StatusPane type exposes the following members.

Properties

 | Name | Description
Public property | ClearAllHyperlinkText | Gets or sets a text of the Clear all hyperlink.
Public property | Color | Gets or sets a color of the status pane.
Public property | FilesToUploadText | Gets or sets a text on the status pane which is displayed when at least one file is added to the upload pane.
Public property | NoFilesToUploadText | Gets or sets a text on the status pane which is displayed when the upload pane is empty.
Public property | ProgressBarText | Gets or sets a text displayed in the progress bar during the upload if the instant upload feature is used.

See Also

Reference

  • StatusPane Class
  • Aurigma.ImageUploader Namespace


ClearAllHyperlinkText Property

StatusPane..::.ClearAllHyperlinkText Property

  • Collapse All Sections
  • StatusPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text of the Clear all hyperlink.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ClearAllHyperlinkText As String

C#

public string ClearAllHyperlinkText { get; set; }

Property Value

Type: System..::.String

The text of the Clear all hyperlink.

Default value is "clear all".

Remarks

By clicking this link, a user can remove all the files from the upload pane.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • StatusPane Class
  • Aurigma.ImageUploader Namespace
  • $au.statusPane.clearAllHyperlinkText JavaScript Property
  • StatusPane.ClearAllHyperlinkText PHP Property


Color Property

StatusPane..::.Color Property

  • Collapse All Sections
  • StatusPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the status pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Color As GradientColor

C#

public GradientColor Color { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.GradientColor

The color of the status pane.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is #f7f7f7;#efefef.

See Also

Reference

  • StatusPane Class
  • Aurigma.ImageUploader Namespace
  • $au.statusPane.color JavaScript Property
  • StatusPane.Color PHP Property


FilesToUploadText Property

StatusPane..::.FilesToUploadText Property

  • Collapse All Sections
  • StatusPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text on the status pane which is displayed when at least one file is added to the upload pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FilesToUploadText As String

C#

public string FilesToUploadText { get; set; }

Property Value

Type: System..::.String

The text stating how many files are added to the upload pane. It can contain the following placeholder:

[count]
replaced by the number of files actually added to the upload pane.

Default value is "Files selected to upload: [count]".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • StatusPane Class
  • Aurigma.ImageUploader Namespace
  • $au.statusPane.filesToUploadText JavaScript Property
  • StatusPane.FilesToUploadText PHP Property


NoFilesToUploadText Property

StatusPane..::.NoFilesToUploadText Property

  • Collapse All Sections
  • StatusPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text on the status pane which is displayed when the upload pane is empty.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property NoFilesToUploadText As String

C#

public string NoFilesToUploadText { get; set; }

Property Value

Type: System..::.String

The text stating that the upload pane is empty.

Default value is "No files to upload".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • StatusPane Class
  • Aurigma.ImageUploader Namespace
  • $au.statusPane.noFilesToUploadText JavaScript Property
  • StatusPane.NoFilesToUploadText PHP Property


ProgressBarText Property

StatusPane..::.ProgressBarText Property

  • Collapse All Sections
  • StatusPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text displayed in the progress bar during the upload if the instant upload feature is used.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ProgressBarText As String

C#

public string ProgressBarText { get; set; }

Property Value

Type: System..::.String

The text displaying a total percentage of the upload progress. It can contain the following placeholder:

[percents]
replaced by the total percentage of the upload progress.

Default value is "Uploading ([percents]%)".

Remarks

This property makes sense only if the EnableInstantUpload property is true.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • StatusPane Class
  • Aurigma.ImageUploader Namespace
  • UploadSettings..::.EnableInstantUpload
  • $au.statusPane.progressBarText JavaScript Property
  • StatusPane.ProgressBarText PHP Property


Thumbnail Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a standalone thumbnail bound with some upload pane item of Image Uploader.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class Thumbnail _
    Inherits BaseControl

C#

public class Thumbnail : BaseControl

Remarks

Note

Image Uploader Express disables the Thumbnail control.

This control can be used to build a custom upload list. For example, you can add extra fields for each item or design new upload list layout.

The idea is the following:

  1. Insert this control instance to the necessary position in HTML.
  2. Associate the control with an instance of Uploader which contains the upload list where to bind items from. You can do it using the ParentControlName property.
  3. Bind the control with some item from the upload list using the Guid property.

Inheritance Hierarchy

System..::.Object L System.Web.UI..::.Control L Aurigma.ImageUploader..::.BaseControl L Aurigma.ImageUploader..::.Thumbnail

See Also

Reference

  • Thumbnail Members
  • Aurigma.ImageUploader Namespace
  • $au.thumbnail JavaScript Class
  • Thumbnail PHP Class


Thumbnail Members

  • Thumbnail Class
  • Constructors
  • Methods
  • Properties
  • Events
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The Thumbnail type exposes the following members.

Constructors

 | Name | Description
Public method | Thumbnail | Creates and initializes an instance of the Thumbnail class.

Methods

 | Name | Description
Protected method | AddedControl | (Inherited from Control.)
Protected method | AddParsedSubObject | (Inherited from Control.)
Public method | ApplyStyleSheetSkin | (Inherited from Control.)
Protected method | BuildProfileTree | (Inherited from Control.)
Protected method | ClearChildControlState | (Inherited from Control.)
Protected method | ClearChildState | (Inherited from Control.)
Protected method | ClearChildViewState | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | DataBind | Overloaded.
Protected method | DataBindChildren | (Inherited from Control.)
Public method | Dispose | (Inherited from Control.)
Protected method | EnsureChildControls | (Inherited from Control.)
Protected method | EnsureID | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindControl | Overloaded.
Public method | Focus | (Inherited from Control.)
Protected method | GetDesignModeState | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasControls | (Inherited from Control.)
Protected method | HasEvents | (Inherited from Control.)
Protected method | IsLiteralContent | (Inherited from Control.)
Protected method | LoadControlState | (Inherited from Control.)
Protected method | LoadViewState | (Inherited from Control.)
Protected method | MapPathSecure | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnBubbleEvent | (Inherited from Control.)
Protected method | OnDataBinding | (Inherited from Control.)
Protected method | OnInit | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Control.)
Protected method | OnUnload | (Inherited from Control.)
Protected method | OpenFile | (Inherited from Control.)
Protected method | RaiseBubbleEvent | (Inherited from Control.)
Public method | RegisterClientScripts | Registers Image Uploader client-side scripts. (Inherited from BaseControl.)
Protected method | RemovedControl | (Inherited from Control.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderControl | Overloaded.
Protected method | ResolveAdapter | (Inherited from Control.)
Public method | ResolveClientUrl | (Inherited from Control.)
Public method | ResolveUrl | (Inherited from Control.)
Protected method | SaveControlState | (Inherited from Control.)
Protected method | SaveViewState | (Inherited from Control.)
Protected method | SetDesignModeState | (Inherited from Control.)
Public method | SetRenderMethodDelegate | (Inherited from Control.)
Public method | ToString | (Inherited from Object.)
Protected method | TrackViewState | (Inherited from Control.)

Properties

 | Name | Description
Public property | ActiveXControl | Gets the ActiveX control settings.
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | BackgroundColor | Gets or sets a background color of this Thumbnail instance.
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientEvents | Gets a collection of client-side events.
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | DebugScriptLevel | Gets or sets a debug level. (Inherited from BaseControl.)
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0. (Inherited from BaseControl.)
Protected property | DesignMode | (Inherited from Control.)
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Public property | Guid | Gets or sets a unique identifier (GUID) of the item which is represented with this Thumbnail instance.
Protected property | HasChildViewState | (Inherited from Control.)
Public property | Height | Gets or sets a height of this Thumbnail instance.
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Public property | JavaControl | Gets the Java applet settings.
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | ManualRendering | Gets or sets a value indicating whether the control should be created but not rendered. (Inherited from BaseControl.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentControlName | The Uploader control name this Thumbnail instance is associated with.
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)
Public property | Width | Gets or sets a width of this Thumbnail instance.

Events

 | Name | Description
Public event | DataBinding | (Inherited from Control.)
Public event | Disposed | (Inherited from Control.)
Public event | Init | (Inherited from Control.)
Public event | Load | (Inherited from Control.)
Public event | PreRender | (Inherited from Control.)
Public event | Unload | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • Thumbnail Class
  • Aurigma.ImageUploader Namespace


Thumbnail Constructor

  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Creates and initializes an instance of the Thumbnail class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public Thumbnail()

See Also

Reference

  • Thumbnail Class
  • Aurigma.ImageUploader Namespace
  • BaseControl(string) PHP Constructor


Thumbnail Properties

  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )

The Thumbnail type exposes the following members.

Properties

 | Name | Description
Public property | ActiveXControl | Gets the ActiveX control settings.
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | BackgroundColor | Gets or sets a background color of this Thumbnail instance.
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientEvents | Gets a collection of client-side events.
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | DebugScriptLevel | Gets or sets a debug level. (Inherited from BaseControl.)
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0. (Inherited from BaseControl.)
Protected property | DesignMode | (Inherited from Control.)
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Public property | Guid | Gets or sets a unique identifier (GUID) of the item which is represented with this Thumbnail instance.
Protected property | HasChildViewState | (Inherited from Control.)
Public property | Height | Gets or sets a height of this Thumbnail instance.
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Public property | JavaControl | Gets the Java applet settings.
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | ManualRendering | Gets or sets a value indicating whether the control should be created but not rendered. (Inherited from BaseControl.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentControlName | The Uploader control name this Thumbnail instance is associated with.
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)
Public property | Width | Gets or sets a width of this Thumbnail instance.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • Thumbnail Class
  • Aurigma.ImageUploader Namespace


ActiveXControl Property

Thumbnail..::.ActiveXControl Property

  • Collapse All Sections
  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets the ActiveX control settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property ActiveXControl As ActiveXControl

C#

public ActiveXControl ActiveXControl { get; }

Property Value

Type: Aurigma.ImageUploader..::.ActiveXControl

The ActiveX control settings.

See Also

Reference

  • Thumbnail Class
  • Aurigma.ImageUploader Namespace
  • $au.thumbnail.activeXControl JavaScript Property
  • Thumbnail.ActiveXControl PHP Property


BackgroundColor Property

Thumbnail..::.BackgroundColor Property

  • Collapse All Sections
  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of this Thumbnail instance.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property BackgroundColor As Color

C#

public Color BackgroundColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The background color of the Thumbnail control.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #ffffff.

See Also

Reference

  • Thumbnail Class
  • Aurigma.ImageUploader Namespace
  • $au.thumbnail.backgroundColor JavaScript Property
  • Thumbnail.BackgroundColor PHP Property


ClientEvents Property

Thumbnail..::.ClientEvents Property

  • Collapse All Sections
  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a collection of client-side events.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property ClientEvents As ThumbnailClientEventCollection

C#

public ThumbnailClientEventCollection ClientEvents { get; }

Property Value

Type: Aurigma.ImageUploader..::.ThumbnailClientEventCollection

The collection of client-side events.

See Also

Reference

  • Thumbnail Class
  • Aurigma.ImageUploader Namespace
  • $au.thumbnail.events JavaScript Property
  • Thumbnail.ClientEvents PHP Property


Guid Property

Thumbnail..::.Guid Property

  • Collapse All Sections
  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a unique identifier (GUID) of the item which is represented with this Thumbnail instance.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Guid As String

C#

public string Guid { get; set; }

Property Value

Type: System..::.String

The GUID of the item which is represented with the Thumbnail control.

Default value is "".

Remarks

Before binding the Thumbnail with some upload list item, you should specify the parent Uploader control. You can do it using the ParentControlName property.

See Also

Reference

  • Thumbnail Class
  • Aurigma.ImageUploader Namespace
  • $au.thumbnail.guid JavaScript Property
  • Thumbnail.Guid PHP Property


Height Property

Thumbnail..::.Height Property

  • Collapse All Sections
  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of this Thumbnail instance.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Height As Unit

C#

public Unit Height { get; set; }

Property Value

Type: System.Web.UI.WebControls..::.Unit

The height of the Thumbnail control.

Default value is 100px.

See Also

Reference

  • Thumbnail Class
  • Aurigma.ImageUploader Namespace
  • $au.thumbnail.height JavaScript Property
  • Thumbnail.Height PHP Property


JavaControl Property

Thumbnail..::.JavaControl Property

  • Collapse All Sections
  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets the Java applet settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property JavaControl As JavaControl

C#

public JavaControl JavaControl { get; }

Property Value

Type: Aurigma.ImageUploader..::.JavaControl

The Java applet settings.

See Also

Reference

  • Thumbnail Class
  • Aurigma.ImageUploader Namespace
  • $au.thumbnail.javaControl JavaScript Property
  • Thumbnail.JavaControl PHP Property


ParentControlName Property

Thumbnail..::.ParentControlName Property

  • Collapse All Sections
  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

The Uploader control name this Thumbnail instance is associated with.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ParentControlName As String

C#

public string ParentControlName { get; set; }

Property Value

Type: System..::.String

Gets or sets a name of the Uploader control this Thumbnail instance is associated with.

Default value is "".

Remarks

After you associate this Thumbnail control with a parent Uploader, you should bind it with some item from the upload list. To do it, set the Guid property to the GUID of this item. You can get it using the file.guid property.

See Also

Reference

  • Thumbnail Class
  • Aurigma.ImageUploader Namespace
  • $au.thumbnail.parentControlName JavaScript Property
  • Thumbnail.ParentControlName PHP Property


Width Property

Thumbnail..::.Width Property

  • Collapse All Sections
  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of this Thumbnail instance.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Width As Unit

C#

public Unit Width { get; set; }

Property Value

Type: System.Web.UI.WebControls..::.Unit

The width of the Thumbnail control.

Default value is 100px.

See Also

Reference

  • Thumbnail Class
  • Aurigma.ImageUploader Namespace
  • $au.thumbnail.width JavaScript Property
  • Thumbnail.Width PHP Property


ThumbnailClientEvent Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a client-side event.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class ThumbnailClientEvent _
    Inherits BaseClientEvent(Of ThumbnailClientEventNames)

C#

public class ThumbnailClientEvent : BaseClientEvent<ThumbnailClientEventNames>

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.BaseClientEvent < (Of < ( ThumbnailClientEventNames > ) > ) L Aurigma.ImageUploader..::.ThumbnailClientEvent

See Also

Reference

  • ThumbnailClientEvent Members
  • Aurigma.ImageUploader Namespace
  • Thumbnail..::.ClientEvents

Manual

  • Using Events


ThumbnailClientEvent Members

  • ThumbnailClientEvent Class
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The ThumbnailClientEvent type exposes the following members.

Constructors

 | Name | Description
Public method | ThumbnailClientEvent | Overloaded.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | EventName | Gets or sets a name of the client-side event. (Inherited from BaseClientEvent<(Of <(T>)>).)
Public property | HandlerName | Gets or sets a name of the client-side event handler. (Inherited from BaseClientEvent<(Of <(T>)>).)

See Also

Reference

  • ThumbnailClientEvent Class
  • Aurigma.ImageUploader Namespace


ThumbnailClientEvent Constructor

  • ThumbnailClientEvent Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | ThumbnailClientEvent()()() | Creates and initializes an instance of the ThumbnailClientEvent class.
Public method | ThumbnailClientEvent(ThumbnailClientEventNames, String) | Creates and initializes an instance of the ThumbnailClientEvent class.

See Also

Reference

  • ThumbnailClientEvent Class
  • ThumbnailClientEvent Members
  • Aurigma.ImageUploader Namespace


ThumbnailClientEvent Constructor

  • ThumbnailClientEvent Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the ThumbnailClientEvent class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public ThumbnailClientEvent()

See Also

Reference

  • ThumbnailClientEvent Class
  • ThumbnailClientEvent Overload
  • Aurigma.ImageUploader Namespace


ThumbnailClientEvent Constructor (ThumbnailClientEventNames, String)

  • ThumbnailClientEvent Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the ThumbnailClientEvent class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New ( _
    eventName As ThumbnailClientEventNames, _
    handlerName As String _
)

C#

public ThumbnailClientEvent(
    ThumbnailClientEventNames eventName,
    string handlerName
)

Parameters

eventName

Type: Aurigma.ImageUploader..::.ThumbnailClientEventNames

The name of the client-side event.

handlerName

Type: System..::.String

The name of the client-side event handler.

See Also

Reference

  • ThumbnailClientEvent Class
  • ThumbnailClientEvent Overload
  • Aurigma.ImageUploader Namespace


ThumbnailClientEventCollection Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a collection of the Thumbnail client-side events.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class ThumbnailClientEventCollection _
    Inherits Collection(Of ThumbnailClientEvent)

C#

public class ThumbnailClientEventCollection : Collection<ThumbnailClientEvent>

Inheritance Hierarchy

System..::.Object L System.Collections.ObjectModel..::.Collection < (Of < ( ThumbnailClientEvent > ) > ) L Aurigma.ImageUploader..::.ThumbnailClientEventCollection

See Also

Reference

  • ThumbnailClientEventCollection Members
  • Aurigma.ImageUploader Namespace


ThumbnailClientEventCollection Members

  • ThumbnailClientEventCollection Class
  • Methods
  • Properties
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The ThumbnailClientEventCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Public method | Clear | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Protected method | ClearItems | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Public method | Contains | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Public method | CopyTo | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Public method | Insert | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Protected method | InsertItem | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Public method | RemoveAt | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Protected method | RemoveItem | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Protected method | SetItem | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Public property | Item | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Protected property | Items | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::.Add | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Explicit interface implemetation | IList..::.Contains | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Explicit interface implemetation | ICollection..::.CopyTo | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Explicit interface implemetation | IEnumerable..::.GetEnumerator | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Explicit interface implemetation | IList..::.IndexOf | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Explicit interface implemetation | IList..::.Insert | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Explicit interface implemetation | IList..::.IsFixedSize | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Explicit interface implemetation | ICollection<(Of <(T>)>)..::.IsReadOnly | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Explicit interface implemetation | IList..::.IsReadOnly | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Explicit interface implemetation | ICollection..::.IsSynchronized | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Explicit interface implemetation | IList..::.Item | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Explicit interface implemetation | IList..::.Remove | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)
Explicit interface implemetation | ICollection..::.SyncRoot | (Inherited from Collection <(Of <( ThumbnailClientEvent >)>).)

See Also

Reference

  • ThumbnailClientEventCollection Class
  • Aurigma.ImageUploader Namespace


ThumbnailClientEventNames Enumeration

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Specifies possible values for the Thumbnail control client-side event names.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration ThumbnailClientEventNames

C#

public enum ThumbnailClientEventNames

Members

Member name | Description
Click | Click event fires when the Thumbnail control is clicked.
InitComplete | InitComplete event fires when the Thumbnail control is completely created and initialized.
PreRender | PreRender event fires before the writeHtml or getHtml method is executed.

See Also

Reference

  • Aurigma.ImageUploader Namespace
  • Thumbnail..::.ClientEvents


ThumbnailFitMode Enumeration

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Specifies possible values for thumbnail fit modes.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Enumeration ThumbnailFitMode

C#

public enum ThumbnailFitMode

Members

Member name | Description
Fit | The original image should be resized to fit the rectangle specified with the ThumbnailHeight and ThumbnailWidth properties. Note that the proportions of the original image will be kept.
Width | The original image should be resized to be no higher than the ThumbnailWidth value.
Height | The original image should be resized to be no wider than the ThumbnailHeight value.
ActualSize | Dimensions of the original image should be keeped; however, it can be rotated or recompressed if necessary.

See Also

Reference

  • Aurigma.ImageUploader Namespace
  • Converter..::.ThumbnailFitMode


TreePane Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the tree pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class TreePane

C#

public class TreePane

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.TreePane

See Also

Reference

  • TreePane Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.TreePane
  • $au.treePane JavaScript Class
  • TreePane PHP Class

Manual

  • Layouts


TreePane Members

  • TreePane Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The TreePane type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | TitleText | Gets or sets a title of the tree pane.
Public property | UnixFileSystemRootText | Gets or sets a caption of the folder tree node which specifies the system directory at *NIX systems.
Public property | UnixHomeDirectoryText | Gets or sets a caption of the folder tree node which specifies the home directory at *NIX systems.
Public property | Width | Gets or sets a width of the tree pane.

See Also

Reference

  • TreePane Class
  • Aurigma.ImageUploader Namespace


TreePane Properties

  • TreePane Class
  • See Also
  • Language Filter ( all languages )

The TreePane type exposes the following members.

Properties

 | Name | Description
Public property | TitleText | Gets or sets a title of the tree pane.
Public property | UnixFileSystemRootText | Gets or sets a caption of the folder tree node which specifies the system directory at *NIX systems.
Public property | UnixHomeDirectoryText | Gets or sets a caption of the folder tree node which specifies the home directory at *NIX systems.
Public property | Width | Gets or sets a width of the tree pane.

See Also

Reference

  • TreePane Class
  • Aurigma.ImageUploader Namespace


TitleText Property

TreePane..::.TitleText Property

  • Collapse All Sections
  • TreePane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the tree pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property TitleText As String

C#

public string TitleText { get; set; }

Property Value

Type: System..::.String

The title of the tree pane.

Default value is "Folders".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • TreePane Class
  • Aurigma.ImageUploader Namespace
  • $au.treePane.titleText JavaScript Property
  • TreePane.TitleText PHP Property


UnixFileSystemRootText Property

TreePane..::.UnixFileSystemRootText Property

  • Collapse All Sections
  • TreePane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the folder tree node which specifies the system directory at *NIX systems.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UnixFileSystemRootText As String

C#

public string UnixFileSystemRootText { get; set; }

Property Value

Type: System..::.String

The caption of the folder tree node which specifies the system directory at *NIX systems.

Default value is "Filesystem".

Remarks

Note

This value is used only at Linux and different sorts of Unix. For Windows and Mac the system-dependent values are extracted and used.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • TreePane Class
  • Aurigma.ImageUploader Namespace
  • TreePane..::.UnixHomeDirectoryText
  • $au.treePane.unixFileSystemRootText JavaScript Property
  • TreePane.UnixFileSystemRootText PHP Property


UnixHomeDirectoryText Property

TreePane..::.UnixHomeDirectoryText Property

  • Collapse All Sections
  • TreePane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the folder tree node which specifies the home directory at *NIX systems.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UnixHomeDirectoryText As String

C#

public string UnixHomeDirectoryText { get; set; }

Property Value

Type: System..::.String

The caption of the folder tree node which specifies the home directory at *NIX systems.

Default value is "Home Folder".

Remarks

Note

This value is used only at Linux and different sorts of Unix. For Windows and Mac the system-dependent values are extracted and used.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • TreePane Class
  • Aurigma.ImageUploader Namespace
  • TreePane..::.UnixFileSystemRootText
  • $au.treePane.unixHomeDirectoryText JavaScript Property
  • TreePane.UnixHomeDirectoryText PHP Property


Width Property

TreePane..::.Width Property

  • Collapse All Sections
  • TreePane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of the tree pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Width As Integer

C#

public int Width { get; set; }

Property Value

Type: System..::.Int32

The width of the tree pane (in pixels).

Default value is 200.

See Also

Reference

  • TreePane Class
  • Aurigma.ImageUploader Namespace
  • $au.treePane.width JavaScript Property
  • TreePane.Width PHP Property


UploadedFile Class

  • Members
  • See Also
  • Language Filter ( all languages )

This class provides an access to all the converted files and metadata related to a particular user-selected file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustInherit Class UploadedFile

C#

public abstract class UploadedFile

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.UploadedFile

See Also

Reference

  • UploadedFile Members
  • Aurigma.ImageUploader Namespace
  • UploadedFile PHP Class

Manual

  • Saving Uploaded Files in ASP.NET


UploadedFile Members

  • UploadedFile Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The UploadedFile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Angle | Gets a rotation angle of this user-selected file (measured in degrees clockwise).
Public property | ConvertedFiles | Gets an array of converted files created for this user-selected file.
Public property | CropBounds | Gets a crop bounds of this user-selected file if it is an image.
Public property | Description | Gets a user-provided description of this user-selected file.
Public property | Index | Gets index of this user-selected file within a package.
Public property | Package | Gets a Package instance related to this user-selected file.
Public property | RelativePath | Gets a relative path to this user-selected file on the client machine.
Public property | SourceCreatedDateTime | Gets a creation date of this user-selected file.
Public property | SourceCreatedDateTimeLocal | Gets a local creation date of this user-selected file.
Public property | SourceHeight | Gets a height of this user-selected file (in pixels) if it is an image.
Public property | SourceLastModifiedDateTime | Gets a last modification date of this user-selected file.
Public property | SourceLastModifiedDateTimeLocal | Gets a local last modification date of this user-selected file.
Public property | SourceName | Gets a name of this user-selected file.
Public property | SourceSize | Gets a size of this user-selected file in bytes.
Public property | SourceWidth | Gets a width of this user-selected file (in pixels) if it is an image.
Public property | SourceXResolution | Gets a horizontal resolution of this user-selected file (measured in DPI - dots per inches) if it is an image.
Public property | SourceYResolution | Gets a vertical resolution of this user-selected file (measured in DPI - dots per inches) if it is an image.
Public property | Tag | Gets a tag provided to this user-selected file.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace


UploadedFile Properties

  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

The UploadedFile type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets a rotation angle of this user-selected file (measured in degrees clockwise).
Public property | ConvertedFiles | Gets an array of converted files created for this user-selected file.
Public property | CropBounds | Gets a crop bounds of this user-selected file if it is an image.
Public property | Description | Gets a user-provided description of this user-selected file.
Public property | Index | Gets index of this user-selected file within a package.
Public property | Package | Gets a Package instance related to this user-selected file.
Public property | RelativePath | Gets a relative path to this user-selected file on the client machine.
Public property | SourceCreatedDateTime | Gets a creation date of this user-selected file.
Public property | SourceCreatedDateTimeLocal | Gets a local creation date of this user-selected file.
Public property | SourceHeight | Gets a height of this user-selected file (in pixels) if it is an image.
Public property | SourceLastModifiedDateTime | Gets a last modification date of this user-selected file.
Public property | SourceLastModifiedDateTimeLocal | Gets a local last modification date of this user-selected file.
Public property | SourceName | Gets a name of this user-selected file.
Public property | SourceSize | Gets a size of this user-selected file in bytes.
Public property | SourceWidth | Gets a width of this user-selected file (in pixels) if it is an image.
Public property | SourceXResolution | Gets a horizontal resolution of this user-selected file (measured in DPI - dots per inches) if it is an image.
Public property | SourceYResolution | Gets a vertical resolution of this user-selected file (measured in DPI - dots per inches) if it is an image.
Public property | Tag | Gets a tag provided to this user-selected file.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace


Angle Property

UploadedFile..::.Angle Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a rotation angle of this user-selected file (measured in degrees clockwise).

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property Angle As Integer

C#

public abstract int Angle { get; }

Property Value

Type: System..::.Int32

The rotation angle of this user-selected file.

Remarks

This property is changed if a user clicks an arrow icon to rotate an image, or if the automatic EXIF rotation is enabled (see the EnableAutoRotation property for more details). You can use it if you want to rotate images on the server side (e.g. if you upload original files only). Possible values are:

  • 0
  • 90
  • 180
  • 270

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.Angle PHP Property


ConvertedFiles Property

UploadedFile..::.ConvertedFiles Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets an array of converted files created for this user-selected file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property ConvertedFiles As ConvertedFileCollection

C#

public abstract ConvertedFileCollection ConvertedFiles { get; }

Property Value

Type: Aurigma.ImageUploader..::.ConvertedFileCollection

The array of converted files created for this user-selected file.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • Aurigma.ImageUploader..::.ConvertedFile
  • UploadedFile.ConvertedFiles PHP Property


CropBounds Property

UploadedFile..::.CropBounds Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a crop bounds of this user-selected file if it is an image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property CropBounds As Rectangle

C#

public abstract Rectangle CropBounds { get; }

Property Value

Type: System.Drawing..::.Rectangle

The crop bounds of this user-selected file if it is an image. Otherwise, this property returns a 0 size rectangle.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.CropBounds PHP Property


Description Property

UploadedFile..::.Description Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a user-provided description of this user-selected file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property Description As String

C#

public abstract string Description { get; }

Property Value

Type: System..::.String

The user-provided description of this user-selected file.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.Description PHP Property


Index Property

UploadedFile..::.Index Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets index of this user-selected file within a package.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property Index As Integer

C#

public abstract int Index { get; }

Property Value

Type: System..::.Int32

The index of this user-selected file within a package.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.Index PHP Property


Package Property

UploadedFile..::.Package Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a Package instance related to this user-selected file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property Package As Package

C#

public abstract Package Package { get; }

Property Value

Type: Aurigma.ImageUploader..::.Package

The Package instance related to this user-selected file.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.Package PHP Property


RelativePath Property

UploadedFile..::.RelativePath Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a relative path to this user-selected file on the client machine.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property RelativePath As String

C#

public abstract string RelativePath { get; }

Property Value

Type: System..::.String

The relative path to this user-selected file.

Remarks

This property makes sense only if the folder upload feature is turned on (Uploader.FolderProcessingMode is upload) and the user-selected file is located inside a subfolder. In that case this property contains a relative path to this file and the SourceName represents its filename. For example, if the user sends a My Documents\My Photos\00001.jpg file its SourceName_i POST field will contain My Documents\My Photos\00001.jpg value. However, the RelativePath property will contain My Documents\My Photos\ value.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.RelativePath PHP Property

Manual

  • Uploading Folders in ASP.NET


SourceCreatedDateTime Property

UploadedFile..::.SourceCreatedDateTime Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a creation date of this user-selected file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property SourceCreatedDateTime As DateTime

C#

public abstract DateTime SourceCreatedDateTime { get; }

Property Value

Type: System..::.DateTime

The creation date of this user-selected file.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.SourceCreatedDateTime PHP Property


SourceCreatedDateTimeLocal Property

UploadedFile..::.SourceCreatedDateTimeLocal Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a local creation date of this user-selected file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property SourceCreatedDateTimeLocal As DateTime

C#

public abstract DateTime SourceCreatedDateTimeLocal { get; }

Property Value

Type: System..::.DateTime

The local creation date of this user-selected file.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.SourceCreatedDateTimeLocal PHP Property


SourceHeight Property

UploadedFile..::.SourceHeight Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a height of this user-selected file (in pixels) if it is an image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property SourceHeight As Integer

C#

public abstract int SourceHeight { get; }

Property Value

Type: System..::.Int32

The height of this user-selected file (in pixels) if it is an image. Otherwise, this property returns 0.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.SourceHeight PHP Property


SourceLastModifiedDateTime Property

UploadedFile..::.SourceLastModifiedDateTime Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a last modification date of this user-selected file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property SourceLastModifiedDateTime As DateTime

C#

public abstract DateTime SourceLastModifiedDateTime { get; }

Property Value

Type: System..::.DateTime

The last modification date of this user-selected file.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.SourceLastModifiedDateTime PHP Property


SourceLastModifiedDateTimeLocal Property

UploadedFile..::.SourceLastModifiedDateTimeLocal Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a local last modification date of this user-selected file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property SourceLastModifiedDateTimeLocal As DateTime

C#

public abstract DateTime SourceLastModifiedDateTimeLocal { get; }

Property Value

Type: System..::.DateTime

The local last modification date of this user-selected file.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.SourceLastModifiedDateTimeLocal PHP Property


SourceName Property

UploadedFile..::.SourceName Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a name of this user-selected file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property SourceName As String

C#

public abstract string SourceName { get; }

Property Value

Type: System..::.String

The name of this user-selected file.

Remarks

It is useful to employ this property to get name of the original file when only resized copy of an image is uploaded.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.SourceName PHP Property


SourceSize Property

UploadedFile..::.SourceSize Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a size of this user-selected file in bytes.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property SourceSize As Integer

C#

public abstract int SourceSize { get; }

Property Value

Type: System..::.Int32

The size of this user-selected file in bytes.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.SourceSize PHP Property


SourceWidth Property

UploadedFile..::.SourceWidth Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a width of this user-selected file (in pixels) if it is an image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property SourceWidth As Integer

C#

public abstract int SourceWidth { get; }

Property Value

Type: System..::.Int32

The width of this user-selected file (in pixels) it it is an image. Otherwise, this property returns 0.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.SourceWidth PHP Property


SourceXResolution Property

UploadedFile..::.SourceXResolution Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a horizontal resolution of this user-selected file (measured in DPI - dots per inches) if it is an image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property SourceXResolution As Integer

C#

public abstract int SourceXResolution { get; }

Property Value

Type: System..::.Int32

The horizontal resolution of this user-selected file (in DPI) if it is an image. Otherwise, this property returns 0.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.SourceXResolution PHP Property


SourceYResolution Property

UploadedFile..::.SourceYResolution Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a vertical resolution of this user-selected file (measured in DPI - dots per inches) if it is an image.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property SourceYResolution As Integer

C#

public abstract int SourceYResolution { get; }

Property Value

Type: System..::.Int32

The vertical resolution of this user-selected file (in DPI) if it is an image. Otherwise, this property returns 0.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.SourceYResolution PHP Property


Tag Property

UploadedFile..::.Tag Property

  • Collapse All Sections
  • UploadedFile Class
  • See Also
  • Language Filter ( all languages )

Gets a tag provided to this user-selected file.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustOverride ReadOnly Property Tag As String

C#

public abstract string Tag { get; }

Property Value

Type: System..::.String

The tag provided to this user-selected file.

See Also

Reference

  • UploadedFile Class
  • Aurigma.ImageUploader Namespace
  • UploadedFile.Tag PHP Property


Uploader Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents an ASP.NET server control intended for embedding Image Uploader into ASP.NET applications.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public NotInheritable Class Uploader _
    Inherits BaseUploadControl

C#

public sealed class Uploader : BaseUploadControl

Remarks

This class allows configuring Image Uploader in Microsoft Visual Studio in design mode through the Form editor and handling uploaded data without parsing the POST request. To configure Image Uploader appearance and its upload format this class exposes a number of properties. To handle uploaded data this control implements the FileUploaded event which fires whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded. All the uploaded data is available through the FileUploadedEventArgs properties.

Inheritance Hierarchy

System..::.Object L System.Web.UI..::.Control L Aurigma.ImageUploader..::.BaseControl L Aurigma.ImageUploader..::.BaseUploadControl L Aurigma.ImageUploader..::.Uploader

See Also

Reference

  • Uploader Members
  • Aurigma.ImageUploader Namespace
  • $au.uploader JavaScript Class
  • Uploader PHP Class

Manual

  • Quick Start with Image Uploader ASP.NET


Uploader Members

  • Uploader Class
  • Constructors
  • Methods
  • Properties
  • Events
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The Uploader type exposes the following members.

Constructors

 | Name | Description
Public method | Uploader | Creates and initializes an instance of the Uploader class.

Methods

 | Name | Description
Protected method | AddedControl | (Inherited from Control.)
Protected method | AddParsedSubObject | (Inherited from Control.)
Public method | ApplyStyleSheetSkin | (Inherited from Control.)
Protected method | BuildProfileTree | (Inherited from Control.)
Protected method | ClearChildControlState | (Inherited from Control.)
Protected method | ClearChildState | (Inherited from Control.)
Protected method | ClearChildViewState | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | DataBind | Overloaded.
Protected method | DataBindChildren | (Inherited from Control.)
Public method | Dispose | (Inherited from Control.)
Protected method | EnsureChildControls | (Inherited from Control.)
Protected method | EnsureID | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindControl | Overloaded.
Public method | Focus | (Inherited from Control.)
Protected method | GetDesignModeState | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasControls | (Inherited from Control.)
Protected method | HasEvents | (Inherited from Control.)
Protected method | IsLiteralContent | (Inherited from Control.)
Protected method | LoadControlState | (Inherited from Control.)
Protected method | LoadViewState | (Inherited from Control.)
Protected method | MapPathSecure | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnBubbleEvent | (Inherited from Control.)
Protected method | OnDataBinding | (Inherited from Control.)
Protected method | OnInit | (Inherited from Control.)
Protected method | OnPreRender | (Inherited from Control.)
Protected method | OnUnload | (Inherited from Control.)
Protected method | OpenFile | (Inherited from Control.)
Protected method | RaiseBubbleEvent | (Inherited from Control.)
Public method | RegisterClientScripts | Registers Image Uploader client-side scripts. (Inherited from BaseControl.)
Protected method | RemovedControl | (Inherited from Control.)
Protected method | Render | (Inherited from Control.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderControl | Overloaded.
Protected method | ResolveAdapter | (Inherited from Control.)
Public method | ResolveClientUrl | (Inherited from Control.)
Public method | ResolveUrl | (Inherited from Control.)
Protected method | SaveControlState | (Inherited from Control.)
Protected method | SaveViewState | (Inherited from Control.)
Protected method | SetDesignModeState | (Inherited from Control.)
Public method | SetRenderMethodDelegate | (Inherited from Control.)
Public method | ToString | (Inherited from Object.)
Protected method | TrackViewState | (Inherited from Control.)

Properties

 | Name | Description
Public property | ActiveXControl | Gets Image Uploader ActiveX control settings.
Protected property | Adapter | (Inherited from Control.)
Public property | AddFilesProgressDialog | Gets settings of the dialog which appears when a user selects quite a lot of files.
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | AuthenticationDialog | Gets settings of the authentication dialog.
Public property | AutoSave | Gets or sets a value indicating whether uploaded files should be automatically saved. (Inherited from BaseUploadControl.)
Public property | AuxiliaryTextColor | Gets or sets a color of auxiliary text lables.
Public property | BackgroundColor | Gets or sets a background color of Image Uploader panes and editors.
Public property | BindingContainer | (Inherited from Control.)
Public property | BorderStyle | Gets or sets a border style of Image Uploader.
Public property | CancelUploadButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Cancel button.
Public property | CancelUploadButtonText | Gets an ImageFormat object configuring a list of images that are displayed in different states of the button which aborts the upload.
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientEvents | Gets a collection of client-side events.
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | ContextMenu | Gets the context menu settings.
Public property | Controls | (Inherited from Control.)
Public property | Converters | Gets a collection of converters.
Public property | DebugScriptLevel | Gets or sets a debug level. (Inherited from BaseControl.)
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0. (Inherited from BaseControl.)
Public property | DeleteFilesDialog | Gets the settings of the delete confirmation dialog.
Public property | DescriptionEditor | Gets the description editor settings.
Protected property | DesignMode | (Inherited from Control.)
Public property | DestinationFolder | Gets or sets a name of the folder to save uploaded files to. (Inherited from BaseUploadControl.)
Public property | DetailsViewColumns | Gets titles of columns displayed in the Details view.
Public property | DialogBorderColor | Gets or sets a color of a dialog border.
Public property | DialogColor | Gets or sets a color of Image Uploader dialogs.
Public property | EnableAutoRotation | Gets or sets a value indicating whether the automatic EXIF-based photo rotation feature is enabled.
Public property | EnableContextMenu | Gets or sets a value indicating whether to disaplay the context menu.
Public property | EnableDescriptionEditor | Gets or sets a value indicating whether it is possible to add descriptions to files.
Public property | EnableDragAndDrop | Gets or sets a value indicating whether internal drag-and-drop operations are supported.
Public property | EnableFileViewer | Gets or sets a value indicating whether to open the file in associated viewer software when it is double-clicked.
Public property | EnableImageEditor | Gets or sets a value indicating whether it is possible to open images in the image editor by clicking the image editor icon or the corresponging context menu option.
Public property | EnableOriginalFilesDeletion | Gets or sets a value indicating whether successfully uploaded files should be deleted.
Public property | EnableRotation | Gets or sets a value indicating whether it is possible to rotate images via Image Uploader GUI.
Public property | EnableStatusPane | Gets or sets a value indicating whether the status pane should be displayed.
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableUploadPane | Gets or sets a value indicating whether the upload pane should be displayed.
Public property | EnableUploadProgress | Gets or sets a value indicating whether the uploading files dialog is shown during the upload.
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Public property | FolderPane | Gets the folder pane settings.
Public property | FolderProcessingMode | Gets or sets the folder processing mode.
Protected property | HasChildViewState | (Inherited from Control.)
Public property | HeaderColor | Gets or sets a color of Image Uploader headers.
Public property | HeaderTextColor | Gets or sets a color of text in Image Uploader headers.
Public property | Height | Gets or sets a height of the control.
Public property | HyperlinkColor | Gets or sets a color of all the hyperlink elements.
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Public property | ImageEditor | Gets the image editor settings.
Public property | InformationBar | Gets the information bar settings.
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Public property | JavaControl | Gets Image Uploader Java applet settings.
Public property | Language | Gets or sets a control localization.
Public property | LicenseKey | Gets or sets a license key which allows evaluating, developing, or publishing Image Uploader according to the license key type (trial, development, or full).
Public property | LoadingFolderContentText | Gets or sets a text which is displayed while Image Uploader scans the folder content and builds the file list.
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | ManualRendering | Gets or sets a value indicating whether the control should be created but not rendered. (Inherited from BaseControl.)
Public property | Messages | Gets messages.
Public property | Metadata | Gets an additional upload data.
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | PaneFont | Gets a font format for all Image Uploader buttons and labels, except titles.
Public property | PaneItem | Gets the pane item settings.
Public property | PaneLayout | Gets of sets Image Uploader layout.
Public property | PanelBorderColor | Gets or sets a color of borders between Image Uploader panes.
Public property | PanelColor | Gets or sets a color of command areas.
Public property | Parent | (Inherited from Control.)
Public property | PasteFileNameTemplate | Gets or sets a file name template for files pasted from clipboard.
Public property | Restrictions | Gets upload restrictions.
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Public property | StatusPane | Gets the status pane settings.
Public property | TempDirectory | Gets or sets a path to the folder where the upload session cache should be saved. (Inherited from BaseUploadControl.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | TextColor | Gets or sets a color of primary labels.
Public property | TitleFont | Gets a font format for Image Uploader titles.
Public property | TreePane | Gets the tree pane settings.
Public property | UniqueID | (Inherited from Control.)
Public property | UploadButtonImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the Upload button.
Public property | UploadButtonText | Gets or sets a caption of the button which starts the upload of the selected files.
Public property | UploadPane | Gets the upload pane settings.
Public property | UploadProgressDialog | Gets the upload progress dialog settings.
Public property | UploadSettings | Gets upload settings.
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)
Public property | Width | Gets or sets a width of the control.

Events

 | Name | Description
Public event | AllFilesUploaded | Fires when the whole upload session completes. (Inherited from BaseUploadControl.)
Public event | DataBinding | (Inherited from Control.)
Public event | Disposed | (Inherited from Control.)
Public event | FileUploaded | Fires whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded. (Inherited from BaseUploadControl.)
Public event | Init | (Inherited from Control.)
Public event | Load | (Inherited from Control.)
Public event | PreRender | (Inherited from Control.)
Public event | Unload | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace


Uploader Constructor

  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the Uploader class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public Uploader()

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • BaseControl(string) PHP Constructor


Uploader Properties

  • Uploader Class
  • See Also
  • Language Filter ( all languages )

The Uploader type exposes the following members.

Properties

 | Name | Description
Public property | ActiveXControl | Gets Image Uploader ActiveX control settings.
Protected property | Adapter | (Inherited from Control.)
Public property | AddFilesProgressDialog | Gets settings of the dialog which appears when a user selects quite a lot of files.
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | AuthenticationDialog | Gets settings of the authentication dialog.
Public property | AutoSave | Gets or sets a value indicating whether uploaded files should be automatically saved. (Inherited from BaseUploadControl.)
Public property | AuxiliaryTextColor | Gets or sets a color of auxiliary text lables.
Public property | BackgroundColor | Gets or sets a background color of Image Uploader panes and editors.
Public property | BindingContainer | (Inherited from Control.)
Public property | BorderStyle | Gets or sets a border style of Image Uploader.
Public property | CancelUploadButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Cancel button.
Public property | CancelUploadButtonText | Gets an ImageFormat object configuring a list of images that are displayed in different states of the button which aborts the upload.
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientEvents | Gets a collection of client-side events.
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | ContextMenu | Gets the context menu settings.
Public property | Controls | (Inherited from Control.)
Public property | Converters | Gets a collection of converters.
Public property | DebugScriptLevel | Gets or sets a debug level. (Inherited from BaseControl.)
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0. (Inherited from BaseControl.)
Public property | DeleteFilesDialog | Gets the settings of the delete confirmation dialog.
Public property | DescriptionEditor | Gets the description editor settings.
Protected property | DesignMode | (Inherited from Control.)
Public property | DestinationFolder | Gets or sets a name of the folder to save uploaded files to. (Inherited from BaseUploadControl.)
Public property | DetailsViewColumns | Gets titles of columns displayed in the Details view.
Public property | DialogBorderColor | Gets or sets a color of a dialog border.
Public property | DialogColor | Gets or sets a color of Image Uploader dialogs.
Public property | EnableAutoRotation | Gets or sets a value indicating whether the automatic EXIF-based photo rotation feature is enabled.
Public property | EnableContextMenu | Gets or sets a value indicating whether to disaplay the context menu.
Public property | EnableDescriptionEditor | Gets or sets a value indicating whether it is possible to add descriptions to files.
Public property | EnableDragAndDrop | Gets or sets a value indicating whether internal drag-and-drop operations are supported.
Public property | EnableFileViewer | Gets or sets a value indicating whether to open the file in associated viewer software when it is double-clicked.
Public property | EnableImageEditor | Gets or sets a value indicating whether it is possible to open images in the image editor by clicking the image editor icon or the corresponging context menu option.
Public property | EnableOriginalFilesDeletion | Gets or sets a value indicating whether successfully uploaded files should be deleted.
Public property | EnableRotation | Gets or sets a value indicating whether it is possible to rotate images via Image Uploader GUI.
Public property | EnableStatusPane | Gets or sets a value indicating whether the status pane should be displayed.
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableUploadPane | Gets or sets a value indicating whether the upload pane should be displayed.
Public property | EnableUploadProgress | Gets or sets a value indicating whether the uploading files dialog is shown during the upload.
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Public property | FolderPane | Gets the folder pane settings.
Public property | FolderProcessingMode | Gets or sets the folder processing mode.
Protected property | HasChildViewState | (Inherited from Control.)
Public property | HeaderColor | Gets or sets a color of Image Uploader headers.
Public property | HeaderTextColor | Gets or sets a color of text in Image Uploader headers.
Public property | Height | Gets or sets a height of the control.
Public property | HyperlinkColor | Gets or sets a color of all the hyperlink elements.
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Public property | ImageEditor | Gets the image editor settings.
Public property | InformationBar | Gets the information bar settings.
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Public property | JavaControl | Gets Image Uploader Java applet settings.
Public property | Language | Gets or sets a control localization.
Public property | LicenseKey | Gets or sets a license key which allows evaluating, developing, or publishing Image Uploader according to the license key type (trial, development, or full).
Public property | LoadingFolderContentText | Gets or sets a text which is displayed while Image Uploader scans the folder content and builds the file list.
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | ManualRendering | Gets or sets a value indicating whether the control should be created but not rendered. (Inherited from BaseControl.)
Public property | Messages | Gets messages.
Public property | Metadata | Gets an additional upload data.
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | PaneFont | Gets a font format for all Image Uploader buttons and labels, except titles.
Public property | PaneItem | Gets the pane item settings.
Public property | PaneLayout | Gets of sets Image Uploader layout.
Public property | PanelBorderColor | Gets or sets a color of borders between Image Uploader panes.
Public property | PanelColor | Gets or sets a color of command areas.
Public property | Parent | (Inherited from Control.)
Public property | PasteFileNameTemplate | Gets or sets a file name template for files pasted from clipboard.
Public property | Restrictions | Gets upload restrictions.
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Public property | StatusPane | Gets the status pane settings.
Public property | TempDirectory | Gets or sets a path to the folder where the upload session cache should be saved. (Inherited from BaseUploadControl.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | TextColor | Gets or sets a color of primary labels.
Public property | TitleFont | Gets a font format for Image Uploader titles.
Public property | TreePane | Gets the tree pane settings.
Public property | UniqueID | (Inherited from Control.)
Public property | UploadButtonImageFormat | Gets an ImageFormat object configuring a list of images that are displayed in different states of the Upload button.
Public property | UploadButtonText | Gets or sets a caption of the button which starts the upload of the selected files.
Public property | UploadPane | Gets the upload pane settings.
Public property | UploadProgressDialog | Gets the upload progress dialog settings.
Public property | UploadSettings | Gets upload settings.
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)
Public property | Width | Gets or sets a width of the control.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace


ActiveXControl Property

Uploader..::.ActiveXControl Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets Image Uploader ActiveX control settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property ActiveXControl As ActiveXControl

C#

public ActiveXControl ActiveXControl { get; }

Property Value

Type: Aurigma.ImageUploader..::.ActiveXControl

Image Uploader ActiveX control settings.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.activeXControl JavaScript Property
  • Uploader.ActiveXControl PHP Property

Manual

  • Using Private-label Version of Image Uploader ASP.NET


AddFilesProgressDialog Property

Uploader..::.AddFilesProgressDialog Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets settings of the dialog which appears when a user selects quite a lot of files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property AddFilesProgressDialog As AddFilesProgressDialog

C#

public AddFilesProgressDialog AddFilesProgressDialog { get; }

Property Value

Type: Aurigma.ImageUploader..::.AddFilesProgressDialog

Settings of the dialog which appears when a user selects quite a lot of files.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.addFilesProgressDialog JavaScript Property
  • Uploader.AddFilesProgressDialog PHP Property


AuthenticationDialog Property

Uploader..::.AuthenticationDialog Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets settings of the authentication dialog.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property AuthenticationDialog As AuthenticationDialog

C#

public AuthenticationDialog AuthenticationDialog { get; }

Property Value

Type: Aurigma.ImageUploader..::.AuthenticationDialog

Settings of the authentication dialog.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.authenticationDialog JavaScript Property
  • Uploader.AuthenticationDialog PHP Property


AuxiliaryTextColor Property

Uploader..::.AuxiliaryTextColor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of auxiliary text lables.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property AuxiliaryTextColor As Color

C#

public Color AuxiliaryTextColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of of the following labels:

  • a prompt inside the search box;
  • a prompt inside the description editor;
  • file details in the Tiles view;
  • image details and a prompt in the image editor.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #8b8b8b.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.auxiliaryTextColor JavaScript Property
  • Uploader.AuxiliaryTextColor PHP Property


BackgroundColor Property

Uploader..::.BackgroundColor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of Image Uploader panes and editors.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property BackgroundColor As Color

C#

public Color BackgroundColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The background color of the following elements:

  • all the panes;
  • image editor;
  • description editor;
  • search box;
  • files adding and files uploading dialogs.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #ffffff.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.backgroundColor JavaScript Property
  • Uploader.BackgroundColor PHP Property


BorderStyle Property

Uploader..::.BorderStyle Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a border style of Image Uploader.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property BorderStyle As BorderStyle

C#

public BorderStyle BorderStyle { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.BorderStyle

The Image Uploader border style.

Default value is Fixed3D.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.borderStyle JavaScript Property
  • Uploader.BorderStyle PHP Property


CancelUploadButtonImageFormat Property

Uploader..::.CancelUploadButtonImageFormat Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the Cancel button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property CancelUploadButtonImageFormat As ImageFormat

C#

public ImageFormat CancelUploadButtonImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the Cancel button.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • Uploader..::.CancelUploadButtonText
  • $au.uploader.cancelUploadButtonImageFormat JavaScript Property
  • Uploader.CancelUploadButtonImageFormat PHP Property


CancelUploadButtonText Property

Uploader..::.CancelUploadButtonText Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the button which aborts the upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CancelUploadButtonText As String

C#

public string CancelUploadButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the Cancel button.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • Uploader..::.CancelUploadButtonImageFormat
  • $au.uploader.cancelUploadButtonText JavaScript Property
  • Uploader.CancelUploadButtonText PHP Property


ClientEvents Property

Uploader..::.ClientEvents Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a collection of client-side events.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property ClientEvents As ClientEventCollection

C#

public ClientEventCollection ClientEvents { get; }

Property Value

Type: Aurigma.ImageUploader..::.ClientEventCollection

The collection of client-side events.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.events JavaScript Property
  • Uploader.ClientEvents PHP Property

Manual

  • Using Events


ContextMenu Property

Uploader..::.ContextMenu Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the context menu settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property ContextMenu As ContextMenu

C#

public ContextMenu ContextMenu { get; }

Property Value

Type: Aurigma.ImageUploader..::.ContextMenu

The settings of the context menu.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.contextMenu JavaScript Property
  • Uploader.ContextMenu PHP Property


Converters Property

Uploader..::.Converters Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a collection of converters.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Converters As ConverterCollection

C#

public ConverterCollection Converters { get; }

Property Value

Type: Aurigma.ImageUploader..::.ConverterCollection

The collection of converters.

Remarks

Each conveter configures a one converted file (original file as is, thumbnail created from original image file, icon associated with original file, or original file compressed into ZIP archive) that will be uploaded for each of the user-selected files.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.converters JavaScript Property
  • Uploader.Converters PHP Property

Manual

  • Configuring Files to be Uploaded


DeleteFilesDialog Property

Uploader..::.DeleteFilesDialog Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets the settings of the delete confirmation dialog.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property DeleteFilesDialog As DeleteFilesDialog

C#

public DeleteFilesDialog DeleteFilesDialog { get; }

Property Value

Type: Aurigma.ImageUploader..::.DeleteFilesDialog

The delete confirmation dialog settings.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.deleteFilesDialog JavaScript Property
  • Uploader.DeleteFilesDialog PHP Property


DescriptionEditor Property

Uploader..::.DescriptionEditor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the description editor settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property DescriptionEditor As DescriptionEditor

C#

public DescriptionEditor DescriptionEditor { get; }

Property Value

Type: Aurigma.ImageUploader..::.DescriptionEditor

The settings of the description editor.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.descriptionEditor JavaScript Property
  • Uploader.DescriptionEditor PHP Property


DetailsViewColumns Property

Uploader..::.DetailsViewColumns Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets titles of columns displayed in the Details view.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property DetailsViewColumns As DetailsViewColumns

C#

public DetailsViewColumns DetailsViewColumns { get; }

Property Value

Type: Aurigma.ImageUploader..::.DetailsViewColumns

The titles of columns displayed in the Details view.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.detailsViewColumns JavaScript Property
  • Uploader.DetailsViewColumns PHP Property

Manual

  • View Modes


DialogBorderColor Property

Uploader..::.DialogBorderColor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of a dialog border.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DialogBorderColor As Color

C#

public Color DialogBorderColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of a dialog border.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #98b6ca.

Remarks

This property affects the following dialogs:

  • description editor,
  • files adding dialog,
  • files uploading dialog.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.dialogBorderColor JavaScript Property
  • Uploader.DialogBorderColor PHP Property


DialogColor Property

Uploader..::.DialogColor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of Image Uploader dialogs.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DialogColor As Color

C#

public Color DialogColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of Image Uploader dialogs.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #e7f7ff.

Remarks

This property affects the following dialogs:

  • description editor,
  • files adding dialog,
  • files uploading dialog.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.dialogColor JavaScript Property
  • Uploader.DialogColor PHP Property


EnableAutoRotation Property

Uploader..::.EnableAutoRotation Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the automatic EXIF-based photo rotation feature is enabled.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableAutoRotation As Boolean

C#

public bool EnableAutoRotation { get; set; }

Property Value

Type: System..::.Boolean

If true, Image Uploader automatically extracts the orientation information from an image and automatically rotates it. Otherwise, only manual rotation is available.

Default value is false.

Remarks

This feature works only for those photos which store EXIF information and orientation details are written there. Keep in mind that not each camera can recognize orientation properly, and therefore Image Uploader will not be able to rotate it.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.enableAutoRotation JavaScript Property
  • Uploader.EnableAutoRotation PHP Property


EnableContextMenu Property

Uploader..::.EnableContextMenu Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to disaplay the context menu.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableContextMenu As Boolean

C#

public bool EnableContextMenu { get; set; }

Property Value

Type: System..::.Boolean

If true, context menu is displayed when a user right-clicks panes and items; otherwise, right-clicks cause nothing.

Default value is true.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • Aurigma.ImageUploader..::.ContextMenu
  • $au.uploader.enableContextMenu JavaScript Property
  • Uploader.EnableContextMenu PHP Property


EnableDescriptionEditor Property

Uploader..::.EnableDescriptionEditor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is possible to add descriptions to files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableDescriptionEditor As Boolean

C#

public bool EnableDescriptionEditor { get; set; }

Property Value

Type: System..::.Boolean

If true, a user can add descriptions in the following ways:

  • by clicking the description control which appears when a mouse pointer hovers over the file;
  • by filling a special field in the image editor;
  • via the Edit description... option of the context menu.

Otherwise, descriptions can be added through the description property only.

Default value is true.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • Aurigma.ImageUploader..::.DescriptionEditor
  • Aurigma.ImageUploader..::.ImageEditor
  • $au.uploader.enableDescriptionEditor JavaScript Property
  • Uploader.EnableDescriptionEditor PHP Property

Manual

  • Additional Controls and Indicators


EnableDragAndDrop Property

Uploader..::.EnableDragAndDrop Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether internal drag-and-drop operations are supported.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableDragAndDrop As Boolean

C#

public bool EnableDragAndDrop { get; set; }

Property Value

Type: System..::.Boolean

If true, a user can use drag-and-drop to:

  • add files from the folder pane to the upload pane in ThreePanes layout;
  • reorder files in the upload pane in both layouts.

Otherwise, only external drag-and-drop (from Windows Explorer, Finder, or other shell) operations are supported.

Default value is true.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.enableDragAndDrop JavaScript Property
  • Uploader.EnableDragAndDrop PHP Property

Manual

  • Layouts


EnableFileViewer Property

Uploader..::.EnableFileViewer Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to open the file in associated viewer software when it is double-clicked.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableFileViewer As Boolean

C#

public bool EnableFileViewer { get; set; }

Property Value

Type: System..::.Boolean

If true, the file is opened in the external file viewer by double-clicking. Otherwise, double-click causes nothing.

Default value is true.

Remarks

If subfolders are shown (FolderProcessingMode is Show or Upload) double-clicking subfolders navigates to them regardless of the EnableFileViewer value.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.enableFileViewer JavaScript Property
  • Uploader.EnableFileViewer PHP Property


EnableImageEditor Property

Uploader..::.EnableImageEditor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is possible to open images in the image editor by clicking the image editor icon or the corresponging context menu option.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableImageEditor As Boolean

C#

public bool EnableImageEditor { get; set; }

Property Value

Type: System..::.Boolean

If true, any image in the folder or upload pane can be opened in the image editor; otherwise, the image editor icon and the Edit image... context menu are hidden.

Default value is true.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.enableImageEditor JavaScript Property
  • Uploader.EnableImageEditor PHP Property


EnableOriginalFilesDeletion Property

Uploader..::.EnableOriginalFilesDeletion Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether successfully uploaded files should be deleted.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableOriginalFilesDeletion As Boolean

C#

public bool EnableOriginalFilesDeletion { get; set; }

Property Value

Type: System..::.Boolean

If true, after successful upload Image Uploader shows a dialog, asking a user whether the uploaded files should be deleted. If a user clicks Yes, the files will be deleted.

Default value is false.

Remarks

Note

A difference between Image Uploader behavior in Internet Explorer and other supported browsers is the following. When Image Uploader deletes files in Internet Explorer, it moves them in the way specified in the Recycle Bin properties. By default, a standard delete confirmation dialog appears and files are moved to the Recycle Bin if a user clicks Yes. However, if Image Uploader deletes files in any of other supported browsers, the internal delete confirmation dialog appears and files are removed permanently when a user clicks Yes.

If the file cannot be deleted, the DeletingFilesError message appears.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • Aurigma.ImageUploader..::.DeleteFilesDialog
  • $au.uploader.enableOriginalFilesDeletion JavaScript Property
  • Uploader.EnableOriginalFilesDeletion PHP Property


EnableRotation Property

Uploader..::.EnableRotation Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is possible to rotate images via Image Uploader GUI.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableRotation As Boolean

C#

public bool EnableRotation { get; set; }

Property Value

Type: System..::.Boolean

If true, any image in the folder or upload pane can be rotated by 90 degrees clockwise by:

  • clicking the rotation icon on the pane item surface,
  • clicking the Rotate button of the image edtior.

Otherwise, images can be rotated via the angle property only.

Default value is true.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.enableRotation JavaScript Property
  • Uploader.EnableRotation PHP Property


EnableStatusPane Property

Uploader..::.EnableStatusPane Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the status pane should be displayed.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableStatusPane As Boolean

C#

public bool EnableStatusPane { get; set; }

Property Value

Type: System..::.Boolean

If true, the status pane is displayed in both layouts; otherwise, it is hidden.

Default value is true.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.enableStatusPane JavaScript Property
  • Uploader.EnableStatusPane PHP Property


EnableUploadPane Property

Uploader..::.EnableUploadPane Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the upload pane should be displayed.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableUploadPane As Boolean

C#

public bool EnableUploadPane { get; set; }

Property Value

Type: System..::.Boolean

If true, the upload pane is displayed in ThreePanes layout; otherwise, it is hidden.

Default value is true.

Remarks

This property makes sense in ThreePanes layout only.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.enableUploadPane JavaScript Property
  • Uploader.EnableUploadPane PHP Property


EnableUploadProgress Property

Uploader..::.EnableUploadProgress Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the uploading files dialog is shown during the upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableUploadProgress As Boolean

C#

public bool EnableUploadProgress { get; set; }

Property Value

Type: System..::.Boolean

If true, the uploading files dialog is displayed; otherwise, this dialog is hidden. However, there are alternative ways to indicate the upload progress:

  • activate the instant upload mode (i.e. set the UploadSettings.EnableInstantUpload is true),
  • implement a custom upload progress indicator yourself by using the Progress event.

Default value is true.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • UploadSettings..::.EnableInstantUpload
  • Progress
  • $au.uploader.enableUploadProgress JavaScript Property
  • Uploader.EnableUploadProgress PHP Property


FolderPane Property

Uploader..::.FolderPane Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the folder pane settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property FolderPane As FolderPane

C#

public FolderPane FolderPane { get; }

Property Value

Type: Aurigma.ImageUploader..::.FolderPane

The settings of the folder pane.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.folderPane JavaScript Property
  • Uploader.FolderPane PHP Property

Manual

  • Layouts


FolderProcessingMode Property

Uploader..::.FolderProcessingMode Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the folder processing mode.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FolderProcessingMode As FolderProcessingMode

C#

public FolderProcessingMode FolderProcessingMode { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.FolderProcessingMode

The folder processing mode.

Default value is Skip.

Remarks

Note

Image Uploader Express does not display and upload folders. See the Comparison of Image Uploader Editions topic for details.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.folderProcessingMode JavaScript Property
  • Uploader.FolderProcessingMode PHP Property

Manual

  • Uploading Folders in ASP.NET


HeaderColor Property

Uploader..::.HeaderColor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of Image Uploader headers.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property HeaderColor As GradientColor

C#

public GradientColor HeaderColor { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.GradientColor

The color of Image Uploader headers.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is #f2f6fb;#c4defb.

Remarks

This property affects the following headers:

  • tree pane header,
  • folder pane header.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.headerColor JavaScript Property
  • Uploader.HeaderColor PHP Property


HeaderTextColor Property

Uploader..::.HeaderTextColor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of text in Image Uploader headers.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property HeaderTextColor As Color

C#

public Color HeaderTextColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of text in Image Uploader headers.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #1a64a8.

Remarks

This property affects the following headers:

  • tree pane header,
  • folder pane header.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.headerTextColor JavaScript Property
  • Uploader.HeaderTextColor PHP Property

Manual

  • Layouts


Height Property

Uploader..::.Height Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of the control.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Height As Unit

C#

public Unit Height { get; set; }

Property Value

Type: System.Web.UI.WebControls..::.Unit

The height of the control.

Default value is 400px.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.height JavaScript Property
  • Uploader.Height PHP Property


HyperlinkColor Property

Uploader..::.HyperlinkColor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of all the hyperlink elements.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property HyperlinkColor As Color

C#

public Color HyperlinkColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of all the hyperlink elements.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #0066cc.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.hyperlinkColor JavaScript Property
  • Uploader.HyperlinkColor PHP Property


ImageEditor Property

Uploader..::.ImageEditor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the image editor settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property ImageEditor As ImageEditor

C#

public ImageEditor ImageEditor { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageEditor

The settings of the image editor appearance.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.imageEditor JavaScript Property
  • Uploader.ImageEditor PHP Property

Manual

  • Image Editor


InformationBar Property

Uploader..::.InformationBar Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the information bar settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property InformationBar As InformationBar

C#

public InformationBar InformationBar { get; }

Property Value

Type: Aurigma.ImageUploader..::.InformationBar

The settings of the information bar appearance.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.informationBar JavaScript Property
  • Uploader.InformationBar PHP Property


JavaControl Property

Uploader..::.JavaControl Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets Image Uploader Java applet settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property JavaControl As JavaControl

C#

public JavaControl JavaControl { get; }

Property Value

Type: Aurigma.ImageUploader..::.JavaControl

Image Uploader Java applet settings.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.javaControl JavaScript Property
  • Uploader.JavaControl PHP Property

Manual

  • Using Private-label Version of Image Uploader ASP.NET


Language Property

Uploader..::.Language Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a control localization.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Language As Language

C#

public Language Language { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.Language

The control localization.

Value | Description
en | English localization.
ru | Russian localization.

Default value is Default.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • Uploader.Language PHP Property


LicenseKey Property

Uploader..::.LicenseKey Property

  • Collapse All Sections
  • Uploader Class
  • Example
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a license key which allows evaluating, developing, or publishing Image Uploader according to the license key type (trial, development, or full).

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property LicenseKey As String

C#

public string LicenseKey { get; set; }

Property Value

Type: System..::.String

The valid license key.

If it is necessary to specify several license keys just separate them with semicolons. See the Example section below.

Default value is "".

Remarks

Note

Image Uploader Express does not support registering of several license keys. See the Comparison of Image Uploader Editions topic for details.

Image Uploader always works as a full version on localhost domain (regardless to the license key).

If you have any questions regarding licensing options or any other sales-related queries, do not hesitate to contact at sales@aurigma.com for more details.

Examples

ASP.NET

<aur:Uploader ID="Uploader1" runat="server"
    LicenseKey="XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY" />

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.licenseKey JavaScript Property
  • Uploader.LicenseKey PHP Property

Manual

  • Quick Start with Image Uploader ASP.NET
  • Evaluating and Registering Image Uploader


LoadingFolderContentText Property

Uploader..::.LoadingFolderContentText Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text which is displayed while Image Uploader scans the folder content and builds the file list.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property LoadingFolderContentText As String

C#

public string LoadingFolderContentText { get; set; }

Property Value

Type: System..::.String

The text which is displayed while Image Uploader scans the folder content and builds the file list.

Default value is "Loading content...".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.loadingFolderContentText JavaScript Property
  • Uploader.LoadingFolderContentText PHP Property


Messages Property

Uploader..::.Messages Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets messages.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Messages As Messages

C#

public Messages Messages { get; }

Property Value

Type: Aurigma.ImageUploader..::.Messages

The messages.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.messages JavaScript Property
  • Uploader.Messages PHP Property

Manual

  • Localization


Metadata Property

Uploader..::.Metadata Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an additional upload data.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Metadata As Metadata

C#

public Metadata Metadata { get; }

Property Value

Type: Aurigma.ImageUploader..::.Metadata

The additional upload data.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.metadata JavaScript Property
  • Uploader.Metadata PHP Property

Manual

  • Uploading Additional Data in ASP.NET


PaneFont Property

Uploader..::.PaneFont Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a font format for all Image Uploader buttons and labels, except titles.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property PaneFont As FontFormat

C#

public FontFormat PaneFont { get; }

Property Value

Type: Aurigma.ImageUploader..::.FontFormat

The font format for all Image Uploader buttons and labels. If this property is not specified, a default system font is used.

Remarks

The string which specifies font format has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Name | Font name. This font should be installed on the client machine, so it is recommended to use only standard font names. When this parameter is not specified, the system default font is used.
Size | Font size (in pixels). If this parameter is not specified, the system default font size is used.
Style

Font style. The following styles are supported:

  • Bold
  • Italic

You can specify several styles separated with a comma. Example:

Style=Bold,Italic

If this parameter is not specified, regular font is used.

Note

The format string is case insensitive.

If you need to customize a title font, use the TitleFont.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • Uploader..::.TitleFont
  • $au.uploader.paneFont JavaScript Property
  • Uploader.PaneFont PHP Property


PaneItem Property

Uploader..::.PaneItem Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the pane item settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property PaneItem As PaneItem

C#

public PaneItem PaneItem { get; }

Property Value

Type: Aurigma.ImageUploader..::.PaneItem

The pane item settings.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.paneItem JavaScript Property
  • Uploader.PaneItem PHP Property


PaneLayout Property

Uploader..::.PaneLayout Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets of sets Image Uploader layout.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property PaneLayout As PaneLayoutMode

C#

public PaneLayoutMode PaneLayout { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.PaneLayoutMode

The Image Uploader layout.

Default value is ThreePanes.

Remarks

Keep in mind that Image Uploader is not designed to switch between layouts in run-time.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.paneLayout JavaScript Property
  • Uploader.PaneLayout PHP Property

Manual

  • Layouts


PanelBorderColor Property

Uploader..::.PanelBorderColor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of borders between Image Uploader panes.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property PanelBorderColor As Color

C#

public Color PanelBorderColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of Image Uploader pane borders.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #aaaaaa.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.panelBorderColor JavaScript Property
  • Uploader.PanelBorderColor PHP Property


PanelColor Property

Uploader..::.PanelColor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of command areas.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property PanelColor As Color

C#

public Color PanelColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of a command area of the following windows:

  • image editor,
  • adding files dialog,
  • uploading files dialog.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #f5f5f5.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.panelColor JavaScript Property
  • Uploader.PanelColor PHP Property


PasteFileNameTemplate Property

Uploader..::.PasteFileNameTemplate Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets or sets a file name template for files pasted from clipboard.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property PasteFileNameTemplate As String

C#

public string PasteFileNameTemplate { get; set; }

Property Value

Type: System..::.String

The file name template for files pasted from clipboard. It can contain any characters allowed for file names and use the following placeholders:

[date]
Current date (i.e. when the file was pasted from clipboard).
[time]
Current time (i.e. when the file was pasted from clipboard).

Default value is "Paste_[date]_[time]".

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.pasteFileNameTemplate JavaScript Property
  • Uploader.PasteFileNameTemplate PHP Property


Restrictions Property

Uploader..::.Restrictions Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets upload restrictions.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Restrictions As Restrictions

C#

public Restrictions Restrictions { get; }

Property Value

Type: Aurigma.ImageUploader..::.Restrictions

The upload restrictions.

Remarks

Note

All the limitations specified here are checked client-side, so you should not interpret them as a reliable protection. A potentially malicious user can bypass all these limitations (by emulating Image Uploader). That is why it is highly recommended to implement server-side verification of uploaded files in addition to Restrictions properties.

In other words, all the limitation features discussed in this topic should be used solely for the convenience of the user. They should not be interpreted as a serious protection measure from malicious users.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.restrictions JavaScript Property
  • Uploader.Restrictions PHP Property

Manual

  • Configuring Restriction Rules for Files


StatusPane Property

Uploader..::.StatusPane Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the status pane settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property StatusPane As StatusPane

C#

public StatusPane StatusPane { get; }

Property Value

Type: Aurigma.ImageUploader..::.StatusPane

The settings of the status pane.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.statusPane JavaScript Property
  • Uploader.StatusPane PHP Property

Manual

  • Layouts


TextColor Property

Uploader..::.TextColor Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of primary labels.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property TextColor As Color

C#

public Color TextColor { get; set; }

Property Value

Type: System.Drawing..::.Color

The color of Image Uploader labels except for:

  • auxiliary labels (are customized with the AuxiliaryTextColor property);
  • header labels (are customized with the HeaderTextColor property);
  • buttons,
  • context menu.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is #000000.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.textColor JavaScript Property
  • Uploader.TextColor PHP Property


TitleFont Property

Uploader..::.TitleFont Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a font format for Image Uploader titles.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property TitleFont As FontFormat

C#

public FontFormat TitleFont { get; }

Property Value

Type: Aurigma.ImageUploader..::.FontFormat

The font format for:

  • tree pane header title;
  • folder pane header title;
  • adding files dialog title;
  • uploading files dialog title;
  • status pane text (always regular, even if the bold style is specified).

If this property is not specified, a default font is used.

Remarks

The string which specifies font format has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Name | Font name. This font should be installed on the client machine, so it is recommended to use only standard font names. When this parameter is not specified, the system default font is used.
Size | Font size (in pixels). If this parameter is not specified, the system default font size is used.
Style

Font style. The following styles are supported:

  • Bold
  • Italic

You can specify several styles separated with a comma. Example:

Style=Bold,Italic

If this parameter is not specified, regular font is used.

Note

The format string is case insensitive.

Other fonts are specified via the PaneFont property.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • Uploader..::.PaneFont
  • $au.uploader.titleFont JavaScript Property
  • Uploader.TitleFont PHP Property

Manual

  • Layouts


TreePane Property

Uploader..::.TreePane Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the tree pane settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property TreePane As TreePane

C#

public TreePane TreePane { get; }

Property Value

Type: Aurigma.ImageUploader..::.TreePane

The tree pane settings

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.treePane JavaScript Property
  • Uploader.TreePane PHP Property

Manual

  • Layouts


UploadButtonImageFormat Property

Uploader..::.UploadButtonImageFormat Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an ImageFormat object configuring a list of images that are displayed in different states of the Upload button.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property UploadButtonImageFormat As ImageFormat

C#

public ImageFormat UploadButtonImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.ImageFormat

The list of custom images of the Upload button.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • Uploader..::.UploadButtonText
  • $au.uploader.uploadButtonImageFormat JavaScript Property
  • Uploader.UploadButtonImageFormat PHP Property


UploadButtonText Property

Uploader..::.UploadButtonText Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the button which starts the upload of the selected files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UploadButtonText As String

C#

public string UploadButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the Upload button.

Default value is "Upload".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • Uploader..::.UploadButtonImageFormat
  • $au.uploader.uploadButtonText JavaScript Property
  • Uploader.UploadButtonText PHP Property


UploadPane Property

Uploader..::.UploadPane Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the upload pane settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property UploadPane As UploadPane

C#

public UploadPane UploadPane { get; }

Property Value

Type: Aurigma.ImageUploader..::.UploadPane

The upload pane settings.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.uploadPane JavaScript Property
  • Uploader.UploadPane PHP Property

Manual

  • Layouts


UploadProgressDialog Property

Uploader..::.UploadProgressDialog Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the upload progress dialog settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property UploadProgressDialog As UploadProgressDialog

C#

public UploadProgressDialog UploadProgressDialog { get; }

Property Value

Type: Aurigma.ImageUploader..::.UploadProgressDialog

The upload progress dialog settings.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.uploadProgressDialog JavaScript Property
  • Uploader.UploadProgressDialog PHP Property


UploadSettings Property

Uploader..::.UploadSettings Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets upload settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property UploadSettings As UploadSettings

C#

public UploadSettings UploadSettings { get; }

Property Value

Type: Aurigma.ImageUploader..::.UploadSettings

The upload settings.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.uploadSettings JavaScript Property
  • Uploader.UploadSettings PHP Property

Manual

  • Configuring Common Upload Settings


Width Property

Uploader..::.Width Property

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of the control.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Width As Unit

C#

public Unit Width { get; set; }

Property Value

Type: System.Web.UI.WebControls..::.Unit

The width of the control.

Default value is 600px.

See Also

Reference

  • Uploader Class
  • Aurigma.ImageUploader Namespace
  • $au.uploader.width JavaScript Property
  • Uploader.Width PHP Property


UploadException Class

  • Members
  • See Also
  • Language Filter ( all languages )

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class UploadException _
    Inherits Exception

C#

public class UploadException : Exception

Inheritance Hierarchy

System..::.Object L System..::.Exception L Aurigma.ImageUploader..::.UploadException

See Also

Reference

  • UploadException Members
  • Aurigma.ImageUploader Namespace


UploadException Members

  • UploadException Class
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The UploadException type exposes the following members.

Constructors

 | Name | Description
Public method | UploadException |

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Protected property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)

See Also

Reference

  • UploadException Class
  • Aurigma.ImageUploader Namespace


UploadException Constructor

  • UploadException Class
  • See Also
  • Language Filter ( all languages )

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New ( _
    message As String _
)

C#

public UploadException(
    string message
)

Parameters

message

Type: System..::.String

See Also

Reference

  • UploadException Class
  • Aurigma.ImageUploader Namespace


UploadHandler Class

  • Members
  • See Also
  • Language Filter ( all languages )

This class represents an HTTP handler which allows processing Image Uploader requests.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class UploadHandler _
    Implements IHttpHandler

C#

public class UploadHandler : IHttpHandler

Remarks

This class implements the IHttpHandler interface. Thus, to employ it you just need to inherit your .ashx handler from this class and it will automatically parse requests received from Image Uploader and will expose API to access the files and data.

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.UploadHandler

See Also

Reference

  • UploadHandler Members
  • Aurigma.ImageUploader Namespace
  • UploadHandler PHP Class

Manual

  • Saving Uploaded Files in ASP.NET
  • HTTP Handlers and HTTP Modules Overview


UploadHandler Members

  • UploadHandler Class
  • Constructors
  • Methods
  • Properties
  • Events
  • See Also
  • Language Filter ( all languages )

The UploadHandler type exposes the following members.

Constructors

 | Name | Description
Public method | UploadHandler | Creates and initializes an instance of the UploadHandler class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessRequest | Enables processing of Image Uploader requests.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoSave | Gets or sets a value indicating whether uploaded files should be automatically saved.
Public property | CacheAliveTimeout | Gets or sets a maximum time (in seconds) the upload session cache will be saved.
Public property | DestinationFolder | Gets or sets a name of the folder to save uploaded files to.
Public property | IsReusable | Gets a value indicating whether another request can use this handler.
Public property | TempDirectory | Gets or sets a path to the folder where UploadHandler saves the upload session cache.

Events

 | Name | Description
Public event | AllFilesUploaded | Fires when the whole upload session completes.
Public event | FileUploaded | Fires whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded.

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace


UploadHandler Constructor

  • UploadHandler Class
  • See Also
  • Language Filter ( all languages )

Creates and initializes an instance of the UploadHandler class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public UploadHandler()

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace


UploadHandler Methods

  • UploadHandler Class
  • See Also
  • Language Filter ( all languages )

The UploadHandler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessRequest | Enables processing of Image Uploader requests.
Public method | ToString | (Inherited from Object.)

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace


ProcessRequest Method

UploadHandler..::.ProcessRequest Method

  • Collapse All Sections
  • UploadHandler Class
  • See Also
  • Language Filter ( all languages )

Enables processing of Image Uploader requests.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub ProcessRequest ( _
    context As HttpContext _
)

C#

public void ProcessRequest(
    HttpContext context
)

Parameters

context

Type: System.Web..::.HttpContext

The HttpContext object that provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service Image Uploader requests.

Implements

IHttpHandler..::.ProcessRequest(HttpContext)

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace
  • UploadHandler.processRequest PHP Method


UploadHandler Properties

  • UploadHandler Class
  • See Also
  • Language Filter ( all languages )

The UploadHandler type exposes the following members.

Properties

 | Name | Description
Public property | AutoSave | Gets or sets a value indicating whether uploaded files should be automatically saved.
Public property | CacheAliveTimeout | Gets or sets a maximum time (in seconds) the upload session cache will be saved.
Public property | DestinationFolder | Gets or sets a name of the folder to save uploaded files to.
Public property | IsReusable | Gets a value indicating whether another request can use this handler.
Public property | TempDirectory | Gets or sets a path to the folder where UploadHandler saves the upload session cache.

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace


AutoSave Property

UploadHandler..::.AutoSave Property

  • Collapse All Sections
  • UploadHandler Class
  • See Also
  • Language Filter ( all languages )

Gets or sets a value indicating whether uploaded files should be automatically saved.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property AutoSave As Boolean

C#

public bool AutoSave { get; set; }

Property Value

Type: System..::.String

If true, Image Uploader ASP.NET saves uploaded files to the folder specified with the DestinationFolder property.

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace


CacheAliveTimeout Property

UploadHandler..::.CacheAliveTimeout Property

  • Collapse All Sections
  • UploadHandler Class
  • See Also
  • Language Filter ( all languages )

Gets or sets a maximum time (in seconds) the upload session cache will be saved.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CacheAliveTimeout As TimeSpan

C#

public TimeSpan CacheAliveTimeout { get; set; }

Property Value

Type: System..::.Int32

The maximum time (in seconds) the upload session cache will be saved.

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace
  • UploadHandler.CacheAliveTimeout PHP Property


DestinationFolder Property

UploadHandler..::.DestinationFolder Property

  • Collapse All Sections
  • UploadHandler Class
  • See Also
  • Language Filter ( all languages )

Gets or sets a name of the folder to save uploaded files to.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DestinationFolder As String

C#

public string DestinationFolder { get; set; }

Property Value

Type: System..::.String

The path where uploaded files should be saved if the autosave feature is enabled.

Remarks

This property makes sense if AutoSave is set to true.

The path can be both absolute (C:\Uploads) or relative (/uploads, ./uploads, ../uploads). Additionally, the Web application root operator (~) is supported.

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace


IsReusable Property

UploadHandler..::.IsReusable Property

  • Collapse All Sections
  • UploadHandler Class
  • See Also
  • Language Filter ( all languages )

Gets a value indicating whether another request can use this handler.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property IsReusable As Boolean

C#

public bool IsReusable { get; }

Property Value

Type: System..::.String

This property always returns false.

Implements

IHttpHandler..::.IsReusable

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace


TempDirectory Property

UploadHandler..::.TempDirectory Property

  • Collapse All Sections
  • UploadHandler Class
  • See Also
  • Language Filter ( all languages )

Gets or sets a path to the folder where UploadHandler saves the upload session cache.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property TempDirectory As String

C#

public string TempDirectory { get; set; }

Property Value

Type: System..::.String

The path to the folder where UploadHandler saves the upload session cache.

Default value is "~/App_Data/UploadCache/".

Remarks

By the moment when the FileUploaded or AllFilesUploaded event is fired, the UploadHandler has already completed parsing of HTTP POST request(s) and saved files to a temporary folder specified by this property. Then, when you call the ConvertedFile.SaveAs(String) or ConvertedFile.MoveTo(String) method, files from this temporary folder are copied or moved to the specified path. Thus, it is recommended to select temporary folder on the same disk where your file storage is located.

This recommendation is also appropriate for autosave functionality.

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace
  • UploadHandler.UploadCacheDirectory PHP Property


UploadHandler Events

  • UploadHandler Class
  • See Also
  • Language Filter ( all languages )

The UploadHandler type exposes the following members.

Events

 | Name | Description
Public event | AllFilesUploaded | Fires when the whole upload session completes.
Public event | FileUploaded | Fires whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded.

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace


AllFilesUploaded Event

UploadHandler..::.AllFilesUploaded Event

  • Collapse All Sections
  • UploadHandler Class
  • See Also
  • Language Filter ( all languages )

Fires when the whole upload session completes.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Event AllFilesUploaded As EventHandler(Of AllFilesUploadedEventArgs)

C#

public event EventHandler<AllFilesUploadedEventArgs> AllFilesUploaded

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace
  • Aurigma.ImageUploader..::.AllFilesUploadedEventArgs


FileUploaded Event

UploadHandler..::.FileUploaded Event

  • Collapse All Sections
  • UploadHandler Class
  • See Also
  • Language Filter ( all languages )

Fires whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Event FileUploaded As EventHandler(Of FileUploadedEventArgs)

C#

public event EventHandler<FileUploadedEventArgs> FileUploaded

See Also

Reference

  • UploadHandler Class
  • Aurigma.ImageUploader Namespace
  • Aurigma.ImageUploader..::.FileUploadedEventArgs


UploadPane Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the upload pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class UploadPane

C#

public class UploadPane

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.UploadPane

See Also

Reference

  • UploadPane Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.UploadPane
  • $au.uploadPane JavaScript Class
  • UploadPane PHP Class

Manual

  • Layouts


UploadPane Members

  • UploadPane Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The UploadPane type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DropFilesHereImageFormat | Gets an BackgroundImageFormat object configuring an image displayed on the upload pane when it is empty.
Public property | DropFilesHereText | Gets or sets a label displayed on the upload pane when it is empty.
Public property | PreviewSize | Gets or sets a size of the preview area when in Thumbnails view.
Public property | SortMode | Gets or sets a sort mode of the upload pane.
Public property | ViewMode | Gets or sets a view mode for the upload pane.

See Also

Reference

  • UploadPane Class
  • Aurigma.ImageUploader Namespace


UploadPane Properties

  • UploadPane Class
  • See Also
  • Language Filter ( all languages )

The UploadPane type exposes the following members.

Properties

 | Name | Description
Public property | DropFilesHereImageFormat | Gets an BackgroundImageFormat object configuring an image displayed on the upload pane when it is empty.
Public property | DropFilesHereText | Gets or sets a label displayed on the upload pane when it is empty.
Public property | PreviewSize | Gets or sets a size of the preview area when in Thumbnails view.
Public property | SortMode | Gets or sets a sort mode of the upload pane.
Public property | ViewMode | Gets or sets a view mode for the upload pane.

See Also

Reference

  • UploadPane Class
  • Aurigma.ImageUploader Namespace


DropFilesHereImageFormat Property

UploadPane..::.DropFilesHereImageFormat Property

  • Collapse All Sections
  • UploadPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets an BackgroundImageFormat object configuring an image displayed on the upload pane when it is empty.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property DropFilesHereImageFormat As BackgroundImageFormat

C#

public BackgroundImageFormat DropFilesHereImageFormat { get; }

Property Value

Type: Aurigma.ImageUploader..::.BackgroundImageFormat

The image displayed on the upload pane when it is empty. If an empty string is specified, a standard Drop Files Here label is displayed.

See Also

Reference

  • UploadPane Class
  • Aurigma.ImageUploader Namespace
  • UploadPane..::.DropFilesHereText
  • $au.uploadPane.dropFilesHereImageFormat JavaScript Property
  • UploadPane.DropFilesHereImageFormat PHP Property

Manual

  • Layouts
  • Customizing Appearance


DropFilesHereText Property

UploadPane..::.DropFilesHereText Property

  • Collapse All Sections
  • UploadPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a label displayed on the upload pane when it is empty.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DropFilesHereText As String

C#

public string DropFilesHereText { get; set; }

Property Value

Type: System..::.String

The label displayed on the upload pane when it is empty.

Default value is "Drop files here...".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UploadPane Class
  • Aurigma.ImageUploader Namespace
  • UploadPane..::.DropFilesHereImageFormat
  • $au.uploadPane.dropFilesHereText JavaScript Property
  • UploadPane.DropFilesHereText PHP Property

Manual

  • Layouts


PreviewSize Property

UploadPane..::.PreviewSize Property

  • Collapse All Sections
  • UploadPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a size of the preview area when in Thumbnails view.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property PreviewSize As Integer

C#

public int PreviewSize { get; set; }

Property Value

Type: System..::.Int32

The size of the preview area (in pixels). In other words, this property specifies size of square the thumbnail is inscribed in.

Default value is 96.

See Also

Reference

  • UploadPane Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadPane.previewSize JavaScript Property
  • UploadPane.PreviewSize PHP Property


SortMode Property

UploadPane..::.SortMode Property

  • Collapse All Sections
  • UploadPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a sort mode of the upload pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property SortMode As PaneSortMode

C#

public PaneSortMode SortMode { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.PaneSortMode

The sort mode of the upload pane.

Default value is Unsorted.

Remarks

Sort mode is automatically reset to Unsorted when new items are added or re-arranged via drag-n-drop.

Note

If you set the same value twice, the sort order will toggle between ascending and descending and vice versa.

See Also

Reference

  • UploadPane Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadPane.sortMode JavaScript Property
  • UploadPane.SortMode PHP Property


ViewMode Property

UploadPane..::.ViewMode Property

  • Collapse All Sections
  • UploadPane Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a view mode for the upload pane.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ViewMode As PaneViewMode

C#

public PaneViewMode ViewMode { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.PaneViewMode

The view mode for the upload pane.

Default value is Thumbnails.

See Also

Reference

  • UploadPane Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadPane.viewMode JavaScript Property
  • UploadPane.ViewMode PHP Property

Manual

  • View Modes


UploadProgressDialog Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the uploading files dialog which appears during the upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class UploadProgressDialog

C#

public class UploadProgressDialog

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.UploadProgressDialog

See Also

Reference

  • UploadProgressDialog Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.UploadProgressDialog
  • $au.uploadProgressDialog JavaScript Class
  • UploadProgressDialog PHP Class

Manual

  • Customizing Appearance


UploadProgressDialog Members

  • UploadProgressDialog Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The UploadProgressDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | CancelUploadButtonText | Gets or sets a caption of the Cancel button on the dialog displayed during the upload.
Public property | EstimationText | Gets or sets a caption of the label which displays estimated time of the upload.
Public property | HideButtonText | Gets or sets a caption of the Hide button on the dialog displayed during the instant upload.
Public property | HoursText | Gets or sets a text for the hours unit in the uploading files dialog.
Public property | InfoText | Gets or sets a caption of the label which displays the upload propgress information.
Public property | KilobytesText | Gets or sets a text for the kilobytes unit in the uploading files dialog.
Public property | MegabytesText | Gets or sets a text for the megabytes unit in the uploading files dialog.
Public property | MinutesText | Gets or sets a text for the minutes unit in the uploading files dialog.
Public property | SecondsText | Gets or sets a text for the seconds unit in the uploading files dialog.
Public property | TimeFormat | Gets or sets a format of the time displayed in the EstimationText label.
Public property | TitleText | Gets or sets a title of the dialog displayed displayed during the upload.

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace


UploadProgressDialog Properties

  • UploadProgressDialog Class
  • See Also
  • Language Filter ( all languages )

The UploadProgressDialog type exposes the following members.

Properties

 | Name | Description
Public property | CancelUploadButtonText | Gets or sets a caption of the Cancel button on the dialog displayed during the upload.
Public property | EstimationText | Gets or sets a caption of the label which displays estimated time of the upload.
Public property | HideButtonText | Gets or sets a caption of the Hide button on the dialog displayed during the instant upload.
Public property | HoursText | Gets or sets a text for the hours unit in the uploading files dialog.
Public property | InfoText | Gets or sets a caption of the label which displays the upload propgress information.
Public property | KilobytesText | Gets or sets a text for the kilobytes unit in the uploading files dialog.
Public property | MegabytesText | Gets or sets a text for the megabytes unit in the uploading files dialog.
Public property | MinutesText | Gets or sets a text for the minutes unit in the uploading files dialog.
Public property | SecondsText | Gets or sets a text for the seconds unit in the uploading files dialog.
Public property | TimeFormat | Gets or sets a format of the time displayed in the EstimationText label.
Public property | TitleText | Gets or sets a title of the dialog displayed displayed during the upload.

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace


CancelUploadButtonText Property

UploadProgressDialog..::.CancelUploadButtonText Property

  • Collapse All Sections
  • UploadProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel button on the dialog displayed during the upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CancelUploadButtonText As String

C#

public string CancelUploadButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the Cancel button on the uploading files dialog.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadProgressDialog.cancelUploadButtonText JavaScript Property
  • UploadProgressDialog.CancelUploadButtonText PHP Property


EstimationText Property

UploadProgressDialog..::.EstimationText Property

  • Collapse All Sections
  • UploadProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the label which displays estimated time of the upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EstimationText As String

C#

public string EstimationText { get; set; }

Property Value

Type: System..::.String

The text of the Estimated remaining time label. It can contain the following placeholder:

[time]
replaced by the estimation of how much time is left.
Note

Format of the displayed time can be configured via the TimeFormat property.

Default value is "Estimated remaining time: [time]".

Remarks

Note

The estimation of the upload time may be quite inaccurate and depends on the UploadSettings.ProgressBytesMode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • UploadSettings.ProgressBytesMode
  • UploadProgressDialog..::.TimeFormat
  • UploadProgressDialog..::.HoursText
  • UploadProgressDialog..::.MinutesText
  • UploadProgressDialog..::.SecondsText
  • $au.uploadProgressDialog.estimationText JavaScript Property
  • UploadProgressDialog.EstimationText PHP Property


HideButtonText Property

UploadProgressDialog..::.HideButtonText Property

  • Collapse All Sections
  • UploadProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Hide button on the dialog displayed during the instant upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property HideButtonText As String

C#

public string HideButtonText { get; set; }

Property Value

Type: System..::.String

The caption of the button which hides the uploading files dialog when the instant upload mode is used.

Default value is "Hide".

Remarks

Note

This button arrears when files are uploaded instantly.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • UploadSettings.EnableInstantUpload
  • $au.uploadProgressDialog.hideButtonText JavaScript Property
  • UploadProgressDialog.HideButtonText PHP Property


HoursText Property

UploadProgressDialog..::.HoursText Property

  • Collapse All Sections
  • UploadProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets or sets a text for the hours unit in the uploading files dialog.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property HoursText As String

C#

public string HoursText { get; set; }

Property Value

Type: System..::.String

The text of the hours unit in the uploading files dialog. As this string is inserted at the end of a sentence, you should specify it without capitalization.

Default value is "hours".

Remarks

Note

This string is used when the TimeFormat value contains Appearance=Words setting.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • UploadProgressDialog..::.TimeFormat
  • UploadProgressDialog..::.EstimationText
  • $au.uploadProgressDialog.hoursText JavaScript Property
  • UploadProgressDialog.HoursText PHP Property


InfoText Property

UploadProgressDialog..::.InfoText Property

  • Collapse All Sections
  • UploadProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the label which displays the upload propgress information.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property InfoText As String

C#

public string InfoText { get; set; }

Property Value

Type: System..::.String

The text of the Files uploaded label. It can contain the following placeholder:

[files]
replaced by the number of files that have already been sent to a server.
[totalFiles]
replaced by the total number of files which should be sent in this upload session.
[bytes]
replaced by the number of bytes that have already been sent to a server.
[totalBytes]
replaced by the total size of the upload session.

Default value is "Files uploaded [files]/[totalFiles] ([bytes] of [totalBytes])".

Remarks

Note

The estimation of the uploaded and total bytes may be quite inaccurate and depends on the UploadSettings.ProgressBytesMode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • UploadSettings.ProgressBytesMode
  • UploadProgressDialog..::.KilobytesText
  • UploadProgressDialog..::.MegabytesText
  • $au.uploadProgressDialog.infoText JavaScript Property
  • UploadProgressDialog.InfoText PHP Property


KilobytesText Property

UploadProgressDialog..::.KilobytesText Property

  • Collapse All Sections
  • UploadProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets or sets a text for the kilobytes unit in the uploading files dialog.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property KilobytesText As String

C#

public string KilobytesText { get; set; }

Property Value

Type: System..::.String

The text of the kilobytes unit in the uploading files dialog.

Default value is "Kb".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • UploadProgressDialog..::.InfoText
  • $au.uploadProgressDialog.kilobytesText JavaScript Property
  • UploadProgressDialog.KilobytesText PHP Property


MegabytesText Property

UploadProgressDialog..::.MegabytesText Property

  • Collapse All Sections
  • UploadProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets or sets a text for the megabytes unit in the uploading files dialog.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MegabytesText As String

C#

public string MegabytesText { get; set; }

Property Value

Type: System..::.String

The text of the megabytes unit in the uploading files dialog.

Default value is "Mb".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • UploadProgressDialog..::.InfoText
  • $au.uploadProgressDialog.megabytesText JavaScript Property
  • UploadProgressDialog.MegabytesText PHP Property


MinutesText Property

UploadProgressDialog..::.MinutesText Property

  • Collapse All Sections
  • UploadProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets or sets a text for the minutes unit in the uploading files dialog.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MinutesText As String

C#

public string MinutesText { get; set; }

Property Value

Type: System..::.String

The text of the minutes unit in the uploading files dialog. As this string is inserted at the end of a sentence, you should specify it without capitalization.

Default value is "minutes".

Remarks

Note

This string is used when the TimeFormat value contains Appearance=Words setting.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • UploadProgressDialog..::.TimeFormat
  • UploadProgressDialog..::.EstimationText
  • $au.uploadProgressDialog.minutesText JavaScript Property
  • UploadProgressDialog.MinutesText PHP Property


SecondsText Property

UploadProgressDialog..::.SecondsText Property

  • Collapse All Sections
  • UploadProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets or sets a text for the seconds unit in the uploading files dialog.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property SecondsText As String

C#

public string SecondsText { get; set; }

Property Value

Type: System..::.String

The text of the seconds unit in the uploading files dialog. As this string is inserted at the end of a sentence, you should specify it without capitalization.

Default value is "seconds".

Remarks

Note

This string is used when the TimeFormat value contains Appearance=Words setting.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • UploadProgressDialog..::.TimeFormat
  • UploadProgressDialog..::.EstimationText
  • $au.uploadProgressDialog.secondsText JavaScript Property
  • UploadProgressDialog.SecondsText PHP Property


TimeFormat Property

UploadProgressDialog..::.TimeFormat Property

  • Collapse All Sections
  • UploadProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer

Gets or sets a format of the time displayed in the EstimationText label.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property TimeFormat As String

C#

public string TimeFormat { get; set; }

Property Value

Type: System..::.String

The time format string having the following syntax:

variable1=value1;variable2=value2;...

The order and case sensitivity are not important. Possible values are:

Appearance
Sets the view. Possible values: Words (XX hours XX minutes XX seconds), ColonSeparated (XX:XX:XX).
PresentDirection
Sets the order of the output of time. Possible values: any possible combinations of H, M and S symbols.
DigitsFormat
Display or not the leading "0", if a particular value is less than 10. Possible values: N, NN.
HideZero
Hide or not zero values. Possible values: TRUE, FALSE.

Default value is "Appearance=ColonSeparated; PresentDirection=HMS; DigitsFormat=NN; HideZero=FALSE".

Remarks

Here is an examples of the usage of this property. Say, you set the following value for it:

Appearance=Words;PresentDirection=HMS;DigitsFormat=N;HideZero=TRUE

Then all time values will be displayed like this:

5 minutes 30 seconds

or this:

1 hours 15 minutes 30 seconds

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • UploadProgressDialog..::.EstimationText
  • UploadProgressDialog..::.HoursText
  • UploadProgressDialog..::.MinutesText
  • UploadProgressDialog..::.SecondsText
  • $au.uploadProgressDialog.timeFormat JavaScript Property
  • UploadProgressDialog.TimeFormat PHP Property


TitleText Property

UploadProgressDialog..::.TitleText Property

  • Collapse All Sections
  • UploadProgressDialog Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the dialog displayed displayed during the upload.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property TitleText As String

C#

public string TitleText { get; set; }

Property Value

Type: System..::.String

The title of the uploading files dialog.

Default value is "Uploading files to server".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UploadProgressDialog Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadProgressDialog.titleText JavaScript Property
  • UploadProgressDialog.TitleText PHP Property


UploadRequest Class

  • Members
  • See Also
  • Language Filter ( all languages )

This class allows processing uploaded data in the same way as the Uploader control.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class UploadRequest _
    Inherits Control

C#

public class UploadRequest : Control

Remarks

This class is useful if you want to process uploaded data on another page (Image Uploader is not hosted on).

Inheritance Hierarchy

System..::.Object L System.Web.UI..::.Control L Aurigma.ImageUploader..::.UploadRequest

See Also

Reference

  • UploadRequest Members
  • Aurigma.ImageUploader Namespace

Manual

  • Saving Uploaded Files in ASP.NET


UploadRequest Members

  • UploadRequest Class
  • Constructors
  • Methods
  • Properties
  • Events
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The UploadRequest type exposes the following members.

Constructors

 | Name | Description
Public method | UploadRequest | Creates and initializes an instance of the UploadRequest class.

Methods

 | Name | Description
Protected method | AddedControl | (Inherited from Control.)
Protected method | AddParsedSubObject | (Inherited from Control.)
Public method | ApplyStyleSheetSkin | (Inherited from Control.)
Protected method | BuildProfileTree | (Inherited from Control.)
Protected method | ClearChildControlState | (Inherited from Control.)
Protected method | ClearChildState | (Inherited from Control.)
Protected method | ClearChildViewState | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | DataBind | Overloaded.
Protected method | DataBindChildren | (Inherited from Control.)
Public method | Dispose | (Inherited from Control.)
Protected method | EnsureChildControls | (Inherited from Control.)
Protected method | EnsureID | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindControl | Overloaded.
Public method | Focus | (Inherited from Control.)
Protected method | GetDesignModeState | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasControls | (Inherited from Control.)
Protected method | HasEvents | (Inherited from Control.)
Protected method | IsLiteralContent | (Inherited from Control.)
Protected method | LoadControlState | (Inherited from Control.)
Protected method | LoadViewState | (Inherited from Control.)
Protected method | MapPathSecure | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnBubbleEvent | (Inherited from Control.)
Protected method | OnDataBinding | (Inherited from Control.)
Protected method | OnInit | (Inherited from Control.)
Protected method | OnPreRender | (Inherited from Control.)
Protected method | OnUnload | (Inherited from Control.)
Protected method | OpenFile | (Inherited from Control.)
Protected method | RaiseBubbleEvent | (Inherited from Control.)
Protected method | RemovedControl | (Inherited from Control.)
Protected method | Render | (Inherited from Control.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderControl | Overloaded.
Protected method | ResolveAdapter | (Inherited from Control.)
Public method | ResolveClientUrl | (Inherited from Control.)
Public method | ResolveUrl | (Inherited from Control.)
Protected method | SaveControlState | (Inherited from Control.)
Protected method | SaveViewState | (Inherited from Control.)
Protected method | SetDesignModeState | (Inherited from Control.)
Public method | SetRenderMethodDelegate | (Inherited from Control.)
Public method | ToString | (Inherited from Object.)
Protected method | TrackViewState | (Inherited from Control.)

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | AutoSave | Gets or sets a value indicating whether uploaded files should be automatically saved.
Public property | BindingContainer | (Inherited from Control.)
Public property | CacheAliveTimeout | Gets or sets a maximum time (in seconds) the upload session cache will be saved.
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Protected property | DesignMode | (Inherited from Control.)
Public property | DestinationFolder | Gets or sets a name of the folder to save uploaded files to.
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Public property | TempDirectory | Gets or sets a path to the folder where UploadRequest saves the upload session cache.
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Events

 | Name | Description
Public event | AllFilesUploaded | Fires when the whole upload session completes.
Public event | DataBinding | (Inherited from Control.)
Public event | Disposed | (Inherited from Control.)
Public event | FileUploaded | Fires whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded.
Public event | Init | (Inherited from Control.)
Public event | Load | (Inherited from Control.)
Public event | PreRender | (Inherited from Control.)
Public event | Unload | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • UploadRequest Class
  • Aurigma.ImageUploader Namespace


UploadRequest Constructor

  • UploadRequest Class
  • See Also
  • Language Filter ( all languages )

Creates and initializes an instance of the UploadRequest class.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public UploadRequest()

See Also

Reference

  • UploadRequest Class
  • Aurigma.ImageUploader Namespace


UploadRequest Properties

  • UploadRequest Class
  • See Also
  • Language Filter ( all languages )

The UploadRequest type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | AutoSave | Gets or sets a value indicating whether uploaded files should be automatically saved.
Public property | BindingContainer | (Inherited from Control.)
Public property | CacheAliveTimeout | Gets or sets a maximum time (in seconds) the upload session cache will be saved.
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Protected property | DesignMode | (Inherited from Control.)
Public property | DestinationFolder | Gets or sets a name of the folder to save uploaded files to.
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Public property | TempDirectory | Gets or sets a path to the folder where UploadRequest saves the upload session cache.
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • UploadRequest Class
  • Aurigma.ImageUploader Namespace


AutoSave Property

UploadRequest..::.AutoSave Property

  • Collapse All Sections
  • UploadRequest Class
  • See Also
  • Language Filter ( all languages )

Gets or sets a value indicating whether uploaded files should be automatically saved.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property AutoSave As Boolean

C#

public bool AutoSave { get; set; }

Property Value

Type: System..::.Boolean

If true, Image Uploader ASP.NET saves uploaded files to the folder specified with the DestinationFolder property.

Default value is false.

See Also

Reference

  • UploadRequest Class
  • Aurigma.ImageUploader Namespace


CacheAliveTimeout Property

UploadRequest..::.CacheAliveTimeout Property

  • Collapse All Sections
  • UploadRequest Class
  • See Also
  • Language Filter ( all languages )

Gets or sets a maximum time (in seconds) the upload session cache will be saved.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property CacheAliveTimeout As TimeSpan

C#

public TimeSpan CacheAliveTimeout { get; set; }

Property Value

Type: System..::.TimeSpan

The maximum time (in seconds) the upload session cache will be saved.

See Also

Reference

  • UploadRequest Class
  • Aurigma.ImageUploader Namespace


DestinationFolder Property

UploadRequest..::.DestinationFolder Property

  • Collapse All Sections
  • UploadRequest Class
  • See Also
  • Language Filter ( all languages )

Gets or sets a name of the folder to save uploaded files to.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DestinationFolder As String

C#

public string DestinationFolder { get; set; }

Property Value

Type: System..::.String

The path where uploaded files should be saved if the autosave feature is enabled.

Default value is "".

Remarks

This property makes sense if AutoSave is set to true.

The path can be both absolute (C:\Uploads) or relative (/uploads, ./uploads, ../uploads). Additionally, the Web application root operator (~) is supported.

See Also

Reference

  • UploadRequest Class
  • Aurigma.ImageUploader Namespace


TempDirectory Property

UploadRequest..::.TempDirectory Property

  • Collapse All Sections
  • UploadRequest Class
  • See Also
  • Language Filter ( all languages )

Gets or sets a path to the folder where UploadRequest saves the upload session cache.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property TempDirectory As String

C#

public string TempDirectory { get; set; }

Property Value

Type: System..::.String

The path to the folder where UploadRequest saves the upload session cache.

Default value is "~/App_Data/UploadCache/".

Remarks

By the moment when the FileUploaded or AllFilesUploaded event is fired, the UploadRequest has already completed parsing of HTTP POST request(s) and saved files to a temporary folder specified by this property. Then, when you call the ConvertedFile.SaveAs(String) or ConvertedFile.MoveTo(String) method, files from this temporary folder are copied or moved to the specified path. Thus, it is recommended to select temporary folder on the same disk where your file storage is located.

This recommendation is also appropriate for autosave functionality.

See Also

Reference

  • UploadRequest Class
  • Aurigma.ImageUploader Namespace


UploadRequest Events

  • UploadRequest Class
  • See Also
  • Language Filter ( all languages )

The UploadRequest type exposes the following members.

Events

 | Name | Description
Public event | AllFilesUploaded | Fires when the whole upload session completes.
Public event | DataBinding | (Inherited from Control.)
Public event | Disposed | (Inherited from Control.)
Public event | FileUploaded | Fires whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded.
Public event | Init | (Inherited from Control.)
Public event | Load | (Inherited from Control.)
Public event | PreRender | (Inherited from Control.)
Public event | Unload | (Inherited from Control.)

See Also

Reference

  • UploadRequest Class
  • Aurigma.ImageUploader Namespace


AllFilesUploaded Event

UploadRequest..::.AllFilesUploaded Event

  • Collapse All Sections
  • UploadRequest Class
  • See Also
  • Language Filter ( all languages )

Fires when the whole upload session completes.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Event AllFilesUploaded As EventHandler(Of AllFilesUploadedEventArgs)

C#

public event EventHandler<AllFilesUploadedEventArgs> AllFilesUploaded

See Also

Reference

  • UploadRequest Class
  • Aurigma.ImageUploader Namespace
  • Aurigma.ImageUploader..::.AllFilesUploadedEventArgs


FileUploaded Event

UploadRequest..::.FileUploaded Event

  • Collapse All Sections
  • UploadRequest Class
  • See Also
  • Language Filter ( all languages )

Fires whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Event FileUploaded As EventHandler(Of FileUploadedEventArgs)

C#

public event EventHandler<FileUploadedEventArgs> FileUploaded

See Also

Reference

  • UploadRequest Class
  • Aurigma.ImageUploader Namespace
  • Aurigma.ImageUploader..::.FileUploadedEventArgs


UploadSettings Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the upload settings.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public NotInheritable Class UploadSettings

C#

public sealed class UploadSettings

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader..::.UploadSettings

See Also

Reference

  • UploadSettings Members
  • Aurigma.ImageUploader Namespace
  • Uploader..::.UploadSettings
  • $au.uploadSettings JavaScript Class
  • UploadSettings PHP Class


UploadSettings Members

  • UploadSettings Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The UploadSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ActionUrl | Gets or sets a URL to the page files are posted to.
Public property | AutoRecoveryMaxAttemptCount | Gets or sets a number of tries that should be performed to submit files.
Public property | AutoRecoveryTimeout | Gets or sets an interval in which Image Uploader should try to resume the upload if it was interrupted.
Public property | Charset | Gets or sets a charset used to encode the text data submitted by Image Uploader.
Public property | ChunkSize | Gets or sets a maximium allowed size of binary data (in bytes) uploaded within a POST request.
Public property | ConnectionTimeout | Gets or sets a timeout of the HTTP connection.
Public property | EnableInstantUpload | Gets or sets a value indicating whether to start sending files right after they are added to the upload pane not waiting for Upload button click.
Public property | FilesPerPackage | Gets or sets a number of user-selected files which will be processed and uploaded within a single request.
Public property | ProgressBytesMode | Gets or sets a value specifying how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server.
Public property | RedirectUrl | Gets or sets a URL to which a user will be redirected when the upload successfully completes.
Public property | UploadConverterOutputSeparately | Gets or sets a value indicating whether to send each converted file in a separate request.

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace


UploadSettings Properties

  • UploadSettings Class
  • See Also
  • Language Filter ( all languages )

The UploadSettings type exposes the following members.

Properties

 | Name | Description
Public property | ActionUrl | Gets or sets a URL to the page files are posted to.
Public property | AutoRecoveryMaxAttemptCount | Gets or sets a number of tries that should be performed to submit files.
Public property | AutoRecoveryTimeout | Gets or sets an interval in which Image Uploader should try to resume the upload if it was interrupted.
Public property | Charset | Gets or sets a charset used to encode the text data submitted by Image Uploader.
Public property | ChunkSize | Gets or sets a maximium allowed size of binary data (in bytes) uploaded within a POST request.
Public property | ConnectionTimeout | Gets or sets a timeout of the HTTP connection.
Public property | EnableInstantUpload | Gets or sets a value indicating whether to start sending files right after they are added to the upload pane not waiting for Upload button click.
Public property | FilesPerPackage | Gets or sets a number of user-selected files which will be processed and uploaded within a single request.
Public property | ProgressBytesMode | Gets or sets a value specifying how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server.
Public property | RedirectUrl | Gets or sets a URL to which a user will be redirected when the upload successfully completes.
Public property | UploadConverterOutputSeparately | Gets or sets a value indicating whether to send each converted file in a separate request.

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace


ActionUrl Property

UploadSettings..::.ActionUrl Property

  • Collapse All Sections
  • UploadSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the page files are posted to.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ActionUrl As String

C#

public string ActionUrl { get; set; }

Property Value

Type: System..::.String

The URL to the page files are posted to. When specifying this value, take into account the following cases:

Using Quotation Marks and Semicolons

URLs can contain semicolon or quotation mark characters (like this one: http://upload.server.com/uploadFile;jsessionid=123?param='value'). If so, to avoid parameter parsing errors enclose such URLs in single (' ') or double (" ") quotes. Additionally, quotation marks (both single ' and double ") inside URLs should be escaped with a backslash:

"http://upload.server.com/uploadFile;jsessionid=123?param=\'value\'"

Uploading to the Same Page

If you want to submit files to the same page where Image Uploader is hosted, specify the dot character (.) as a value of this property.

Using Absolute and Relative URLs

URLs can be both absolute (e.g. http://domain.com/upload/upload.aspx) and relative to the current page (e.g. /upload/upload.aspx).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/default.aspx page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/upload/upload.aspx" | http://domain.com/upload/upload.aspx
"./upload/upload.aspx" | http://domain.com/ImageUploader/upload/upload.aspx
"upload/upload.aspx" | http://domain.com/ImageUploader/upload/upload.aspx
"upload.aspx" | http://domain.com/ImageUploader/upload.aspx

Default value is ".".

Remarks

That page should contain the server code which parses the upload request, saves files to necessary folders on server and performs any other additional actions.

Note

Usually this URL must have a specific extension (depending on the web server settings). For ASP platform it should be .asp, for ASP.NET the extension is .aspx, for PHP it is .php, for Perl it can be .pl or .cgi, etc. In other words, the file containing this script should have the extension registered in the settings of your web server as a server page. Otherwise upload will fail.

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace
  • UploadSettings..::.RedirectUrl
  • $au.uploadSettings.actionUrl JavaScript Property
  • UploadSettings.ActionUrl PHP Property

Manual

  • Configuring Common Upload Settings
  • Saving Uploaded Files in ASP.NET


AutoRecoveryMaxAttemptCount Property

UploadSettings..::.AutoRecoveryMaxAttemptCount Property

  • Collapse All Sections
  • UploadSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a number of tries that should be performed to submit files.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property AutoRecoveryMaxAttemptCount As Integer

C#

public int AutoRecoveryMaxAttemptCount { get; set; }

Property Value

Type: System..::.Int32

The number of attempts for upload to do (including the very first attempt). If you want to disable automatic resuming feature, set this property to 1.

Default value is 1.

Remarks

Note

Image Uploader Express does not support automatic upload recovery. See the Comparison of Image Uploader Editions topic for details.

Time interval between each next retry is configured with the AutoRecoveryTimeout property.

Note

Image Uploader tries to resend the request that has failed. If the request (package) contains more than one file, these files will be resent again. It means that if you use the auto-recovering feature, the optimal value for the FilesPerPackage property would be 1.

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadSettings.autoRecoveryMaxAttemptCount JavaScript Property
  • UploadSettings.AutoRecoveryMaxAttemptCount PHP Property

Manual

  • Configuring Fail-Safe Upload


AutoRecoveryTimeout Property

UploadSettings..::.AutoRecoveryTimeout Property

  • Collapse All Sections
  • UploadSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an interval in which Image Uploader should try to resume the upload if it was interrupted.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property AutoRecoveryTimeout As Integer

C#

public int AutoRecoveryTimeout { get; set; }

Property Value

Type: System..::.Int32

The number of milliseconds the Image Uploader should wait between attempts.

Default value is 5000.

Remarks

Note

Image Uploader Express does not support automatic upload recovery. See the Comparison of Image Uploader Editions topic for details.

This parameter takes effect if only the AutoRecoveryMaxAttemptCount is greater than 1.

Note

Image Uploader tries to resend the request that has failed. If the request (package) contains more than one file, these files will be resent again. It means that if you use the auto-recovering feature, the optimal value for the FilesPerPackage property would be 1.

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadSettings.autoRecoveryTimeout JavaScript Property
  • UploadSettings.AutoRecoveryTimeout PHP Property

Manual

  • Configuring Fail-Safe Upload


Charset Property

UploadSettings..::.Charset Property

  • Collapse All Sections
  • UploadSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a charset used to encode the text data submitted by Image Uploader.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Charset As String

C#

public string Charset { get; set; }

Property Value

Type: System..::.String

The charset. See possible values in the Remarks section.

Default value is "UTF-8".

Remarks

The table below contains some supported charsets. Visit Sun site for a full list of supported encodings.

Charset | Description
US-ASCII | Seven-bit ASCII, a.k.a. ISO646-US, a.k.a. the Basic Latin block of the Unicode character set.
ISO-8859-1 | ISO Latin Alphabet No. 1, a.k.a. ISO-LATIN-1.
UTF-8 | Eight-bit UCS Transformation Format.
UTF-16BE | Sixteen-bit UCS Transformation Format, big-endian byte order.
UTF-16LE | Sixteen-bit UCS Transformation Format, little-endian byte order.
UTF-16 | Sixteen-bit UCS Transformation Format, byte order identified by an optional byte-order mark.
windows-1250 | Windows Eastern European.
windows-1251 | Windows Cyrillic.
windows-1252 | Windows Latin-1.
windows-1253 | Windows Greek.
windows-1254 | Windows Turkish.
windows-1257 | Windows Baltic.
KOI8-R | KOI-8, Russian.

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadSettings.charset JavaScript Property
  • UploadSettings.Charset PHP Property


ChunkSize Property

UploadSettings..::.ChunkSize Property

  • Collapse All Sections
  • UploadSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximium allowed size of binary data (in bytes) uploaded within a POST request.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ChunkSize As Integer

C#

public int ChunkSize { get; set; }

Property Value

Type: System..::.Int32

The number of bytes allowed to upload within a request. When this value is 0, converted file uploaded entirely in accordiance with FilesPerPackage and UploadConverterOutputSeparately properties.

Default value is 0.

Remarks

When this property is greater than 0, Image Uploader adds converted files and metadata to a POST request until the request length exceeds ChunkSize + metadata size bytes. If the last added file does not meet the chunk size limitation, Image Uploader adds just a portion of this file to complete this chunk. The remaining portion will be added at the beginning of the next chunk. Each chunk is submitted to a server as a separate request. It gives a number of benefits: makes each request compartible with maximum POST request length limitation and allows resuming partially uploaded files.

Note

When you turn this mode on, it is highly recommended to use Image Uploader ASP.NET to handle upload on the server side. This wrapper automatically bundles pieces of one file, uploaded in separated chunks, and provides an access to this file as if it was uploaded entirely.

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadSettings.chunkSize JavaScript Property
  • UploadSettings.ChunkSize PHP Property

Manual

  • Sending All Files at Once or in Several Parts


ConnectionTimeout Property

UploadSettings..::.ConnectionTimeout Property

  • Collapse All Sections
  • UploadSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a timeout of the HTTP connection.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ConnectionTimeout As Integer

C#

public int ConnectionTimeout { get; set; }

Property Value

Type: System..::.Int32

The HTTP timeout (in milliseconds). If 0, timeout is infinite (i.e. disabled).

Default value is 0.

Remarks

When timeout expires, the Image Uploader assumes that the connection has been lost and terminates the upload process.

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadSettings.connectionTimeout JavaScript Property
  • UploadSettings.ConnectionTimeout PHP Property


EnableInstantUpload Property

UploadSettings..::.EnableInstantUpload Property

  • Collapse All Sections
  • UploadSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to start sending files right after they are added to the upload pane not waiting for Upload button click.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property EnableInstantUpload As Boolean

C#

public bool EnableInstantUpload { get; set; }

Property Value

Type: System..::.Boolean

If true, the upload process starts instantly when files are added to the upload pane. Otherwise, the upload starts when the Upload button is clicked.

Default value is false.

Remarks

Note

This property takes effect in OnePane layout only.

If this property is true it causes the following changes in Image Uploader user interface:

  • The uploading files dialog is initially hidden.
  • The status pane is equipped with a progress bar indicating the upload progress.
  • The uploading files dialog can be shown by clicking the status pane.
  • The uploading files dialog contains the Hide button which makes this dialog invisible.

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadSettings.enableInstantUpload JavaScript Property
  • UploadSettings.EnableInstantUpload PHP Property

Manual

  • Layouts


FilesPerPackage Property

UploadSettings..::.FilesPerPackage Property

  • Collapse All Sections
  • UploadSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a number of user-selected files which will be processed and uploaded within a single request.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FilesPerPackage As Integer

C#

public int FilesPerPackage { get; set; }

Property Value

Type: System..::.Int32

The number of user-serlected files that will be processed and uploaded within a single request. If more files are selected, they are submitted in separate requests. When this value is 0, all the files are uploaded in one request.

Default value is 0.

Remarks

When this property is greater than 0, Image Uploader sends converted files and metadata for FilesPerPackage user-selected files per each request. Typical scenario is when you set this value to 1, i.e. every user-selected file is processed and uploaded in a separate request. It gives a number of benefits: reduces amount of memory used on the server to process requests from Image Uploader and allows resuming partially completed upload if it has been broken, etc.

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadSettings.filesPerPackage JavaScript Property
  • UploadSettings.FilesPerPackage PHP Property

Manual

  • Sending All Files at Once or in Several Parts
  • Configuring Fail-Safe Upload


ProgressBytesMode Property

UploadSettings..::.ProgressBytesMode Property

  • Collapse All Sections
  • UploadSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value specifying how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property ProgressBytesMode As ProgressBytesMode

C#

public ProgressBytesMode ProgressBytesMode { get; set; }

Property Value

Type: Aurigma.ImageUploader..::.ProgressBytesMode

The progress bytes estimation mode.

Default value is ByPackageSize.

Remarks

This property determines how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server. These data are used in the uploading files dialog and the Progress event.

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace
  • Progress
  • UploadSettings..::.FilesPerPackage
  • $au.uploadSettings.progressBytesMode JavaScript Property
  • UploadSettings.ProgressBytesMode PHP Property

Manual

  • Sending All Files at Once or in Several Parts


RedirectUrl Property

UploadSettings..::.RedirectUrl Property

  • Collapse All Sections
  • UploadSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to which a user will be redirected when the upload successfully completes.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property RedirectUrl As String

C#

public string RedirectUrl { get; set; }

Property Value

Type: System..::.String

The URL to which a user will be redirected when the upload successfully completes. If it is an empty string, Image Uploader will not try to redirect.

Default value is "".

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace
  • UploadSettings..::.ActionUrl
  • $au.uploadSettings.redirectUrl JavaScript Property
  • UploadSettings.RedirectUrl PHP Property

Manual

  • Configuring Common Upload Settings


UploadConverterOutputSeparately Property

UploadSettings..::.UploadConverterOutputSeparately Property

  • Collapse All Sections
  • UploadSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to send each converted file in a separate request.

Namespace: Aurigma.ImageUploader
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property UploadConverterOutputSeparately As Boolean

C#

public bool UploadConverterOutputSeparately { get; set; }

Property Value

Type: System..::.Boolean

If true, each converted file is uploaded in a separate POST request.

Default value is false.

Remarks

Note

When Image Uploader sends converted files separately it does not take into account the FilesPerPackage value. However, if the ChunkSize is greater than 0, Image Uploader divides converted files, which size exceeds this value, into chunks and sends them separately.

See Also

Reference

  • UploadSettings Class
  • Aurigma.ImageUploader Namespace
  • $au.uploadSettings.uploadConverterOutputSeparately JavaScript Property
  • UploadSettings.UploadConverterOutputSeparately PHP Property

Manual

  • Sending All Files at Once or in Several Parts


Aurigma.ImageUploader.AmazonS3 Namespace

The Aurigma.ImageUploader.AmazonS3 namespace contains classes related to AmazonS3 extender.

Classes

 | Class | Description
Public class | AmazonS3Extender | This class extends Image Uploader with a direct upload to Amazon S3 storage.
Public class | CustomMetaProperty | This class represents a custom metadata field to be uploaded to Amazon S3 storage.
Public class | FileSettings | This class contains a list of settings for file to be uploaded to Amazon S3 storage.
Public class | FileSettingsCollection | This class represents collection of settings for files to be uploaded to Amazon S3 storage.
Public class | MetaProperty | This is a base class for CustomMetaProperty and PredefinedMetaProperty classes.
Public class | PredefinedMetaProperty | This class represents a predefined metadata field to be uploaded to Amazon S3 storage.

See Also

Reference

  • $au.amazonS3Extender JavaScript Namespace


AmazonS3Extender Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class extends Image Uploader with a direct upload to Amazon S3 storage.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class AmazonS3Extender _
    Inherits BaseUploaderExtender

C#

public class AmazonS3Extender : BaseUploaderExtender

Inheritance Hierarchy

System..::.Object L System.Web.UI..::.Control L Aurigma.ImageUploader..::.BaseExtender L Aurigma.ImageUploader..::.BaseUploaderExtender L Aurigma.ImageUploader.AmazonS3..::.AmazonS3Extender

See Also

Reference

  • AmazonS3Extender Members
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • $au.amazonS3Extender JavaScript Class
  • AmazonS3Extender PHP Class


AmazonS3Extender Members

  • AmazonS3Extender Class
  • Constructors
  • Methods
  • Properties
  • Events
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The AmazonS3Extender type exposes the following members.

Constructors

 | Name | Description
Public method | AmazonS3Extender | Creates and initializes an instance of the AmazonS3Extender class.

Methods

 | Name | Description
Protected method | AddedControl | (Inherited from Control.)
Protected method | AddParsedSubObject | (Inherited from Control.)
Public method | ApplyStyleSheetSkin | (Inherited from Control.)
Protected method | BuildProfileTree | (Inherited from Control.)
Protected method | ClearChildControlState | (Inherited from Control.)
Protected method | ClearChildState | (Inherited from Control.)
Protected method | ClearChildViewState | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | DataBind | Overloaded.
Protected method | DataBindChildren | (Inherited from Control.)
Public method | Dispose | (Inherited from Control.)
Protected method | EnsureChildControls | (Inherited from Control.)
Protected method | EnsureID | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindControl | Overloaded.
Public method | Focus | (Inherited from Control.)
Protected method | GetDesignModeState | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasControls | (Inherited from Control.)
Protected method | HasEvents | (Inherited from Control.)
Protected method | IsLiteralContent | (Inherited from Control.)
Protected method | LoadControlState | (Inherited from Control.)
Protected method | LoadViewState | (Inherited from Control.)
Protected method | MapPathSecure | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnBubbleEvent | (Inherited from Control.)
Protected method | OnDataBinding | (Inherited from Control.)
Protected method | OnInit | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Control.)
Protected method | OnUnload | (Inherited from Control.)
Protected method | OpenFile | (Inherited from Control.)
Protected method | RaiseBubbleEvent | (Inherited from Control.)
Protected method | RemovedControl | (Inherited from Control.)
Protected method | Render | (Inherited from Control.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderControl | Overloaded.
Protected method | ResolveAdapter | (Inherited from Control.)
Public method | ResolveClientUrl | (Inherited from Control.)
Public method | ResolveUrl | (Inherited from Control.)
Protected method | SaveControlState | (Inherited from Control.)
Protected method | SaveViewState | (Inherited from Control.)
Protected method | SetDesignModeState | (Inherited from Control.)
Public method | SetRenderMethodDelegate | (Inherited from Control.)
Public method | ToString | (Inherited from Object.)
Protected method | TrackViewState | (Inherited from Control.)

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | AWSAccessKeyId | Gets or set an AWS Access Key ID of the owner of the bucket.
Public property | BindingContainer | (Inherited from Control.)
Public property | Bucket | Gets or sets a bucket name.
Public property | BucketHostName | Gets or sets a custom bucket host name.
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Protected property | DesignMode | (Inherited from Control.)
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Public property | Files | Gets a collection of settings for files to be uploaded.
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | PolicyExpiration | Gets or sets an expiration date of the policy.
Public property | SecretAccessKey | Gets or sets a secret access key.
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Protected property | TargetControl | Gets a reference to the Uploader control instance associated with this extender. (Inherited from BaseUploaderExtender.)
Public property | TargetControlID | Gets or sets an ID of the Uploader control instance associated with this extender. (Inherited from BaseUploaderExtender.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Events

 | Name | Description
Public event | DataBinding | (Inherited from Control.)
Public event | Disposed | (Inherited from Control.)
Public event | Init | (Inherited from Control.)
Public event | Load | (Inherited from Control.)
Public event | PreRender | (Inherited from Control.)
Public event | Unload | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • AmazonS3Extender Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


AmazonS3Extender Constructor

  • AmazonS3Extender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the AmazonS3Extender class.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public AmazonS3Extender()

See Also

Reference

  • AmazonS3Extender Class
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • $au.amazonS3Extender(uploader) JavaScript Constructor
  • AmazonS3Extender(Uploader) PHP Constructor


AmazonS3Extender Properties

  • AmazonS3Extender Class
  • See Also
  • Language Filter ( all languages )

The AmazonS3Extender type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | AWSAccessKeyId | Gets or set an AWS Access Key ID of the owner of the bucket.
Public property | BindingContainer | (Inherited from Control.)
Public property | Bucket | Gets or sets a bucket name.
Public property | BucketHostName | Gets or sets a custom bucket host name.
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Protected property | DesignMode | (Inherited from Control.)
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Public property | Files | Gets a collection of settings for files to be uploaded.
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | PolicyExpiration | Gets or sets an expiration date of the policy.
Public property | SecretAccessKey | Gets or sets a secret access key.
Public property | Site | (Inherited from Control.)
Public property | SkinID | (Inherited from Control.)
Protected property | TargetControl | Gets a reference to the Uploader control instance associated with this extender. (Inherited from BaseUploaderExtender.)
Public property | TargetControlID | Gets or sets an ID of the Uploader control instance associated with this extender. (Inherited from BaseUploaderExtender.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • AmazonS3Extender Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


AWSAccessKeyId Property

AmazonS3Extender..::.AWSAccessKeyId Property

  • Collapse All Sections
  • AmazonS3Extender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or set an AWS Access Key ID of the owner of the bucket.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property AWSAccessKeyId As String

C#

public string AWSAccessKeyId { get; set; }

Property Value

Type: System..::.String

The AWS Access Key ID of the owner of the bucket.

Default value is "".

See Also

Reference

  • AmazonS3Extender Class
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • $au.amazonS3Extender.accessKeyId JavaScript Property
  • AmazonS3Extender.AWSAccessKeyId PHP Property


Bucket Property

AmazonS3Extender..::.Bucket Property

  • Collapse All Sections
  • AmazonS3Extender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a bucket name.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Bucket As String

C#

public string Bucket { get; set; }

Property Value

Type: System..::.String

The bucket name.

Default value is "".

See Also

Reference

  • AmazonS3Extender Class
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • $au.amazonS3Extender.bucket JavaScript Property
  • AmazonS3Extender.Bucket PHP Property


BucketHostName Property

AmazonS3Extender..::.BucketHostName Property

  • Collapse All Sections
  • AmazonS3Extender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a custom bucket host name.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property BucketHostName As String

C#

public string BucketHostName { get; set; }

Property Value

Type: System..::.String

The custom bucket host name.

Default value is "".

See Also

Reference

  • AmazonS3Extender Class
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • $au.amazonS3Extender.bucketHostName JavaScript Property
  • AmazonS3Extender.BucketHostName PHP Property


Files Property

AmazonS3Extender..::.Files Property

  • Collapse All Sections
  • AmazonS3Extender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a collection of settings for files to be uploaded.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Files As FileSettingsCollection

C#

public FileSettingsCollection Files { get; }

Property Value

Type: Aurigma.ImageUploader.AmazonS3..::.FileSettingsCollection

The collection of settings for files to be uploaded.

See Also

Reference

  • AmazonS3Extender Class
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • $au.amazonS3Extender.converters JavaScript Property
  • AmazonS3Extender.Files PHP Property


PolicyExpiration Property

AmazonS3Extender..::.PolicyExpiration Property

  • Collapse All Sections
  • AmazonS3Extender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an expiration date of the policy.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property PolicyExpiration As Integer

C#

public int PolicyExpiration { get; set; }

Property Value

Type: System..::.Int32

The expiration date of the policy.

Default value is 86400.

See Also

Reference

  • AmazonS3Extender Class
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • AmazonS3Extender.PolicyExpiration PHP Property


SecretAccessKey Property

AmazonS3Extender..::.SecretAccessKey Property

  • Collapse All Sections
  • AmazonS3Extender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a secret access key.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property SecretAccessKey As String

C#

public string SecretAccessKey { get; set; }

Property Value

Type: System..::.String

The secret access key.

Default value is "".

See Also

Reference

  • AmazonS3Extender Class
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • AmazonS3Extender.SecretAccessKey PHP Property


CustomMetaProperty Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a custom metadata field to be uploaded to Amazon S3 storage.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class CustomMetaProperty _
    Inherits MetaProperty

C#

public class CustomMetaProperty : MetaProperty

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader.AmazonS3..::.MetaProperty L Aurigma.ImageUploader.AmazonS3..::.CustomMetaProperty

See Also

Reference

  • CustomMetaProperty Members
  • Aurigma.ImageUploader.AmazonS3 Namespace


CustomMetaProperty Members

  • CustomMetaProperty Class
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The CustomMetaProperty type exposes the following members.

Constructors

 | Name | Description
Public method | CustomMetaProperty | Creates and initializes an instance of the CustomMetaProperty class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current MetaProperty. (Inherited from MetaProperty.)

Properties

 | Name | Description
Public property | Name | Gets or sets a name of the metadata property. (Inherited from MetaProperty.)
Public property | Value | Gets or sets a value of the custom metadata field be to uploaded to Amazon S3 storage.

See Also

Reference

  • CustomMetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


CustomMetaProperty Constructor

  • CustomMetaProperty Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the CustomMetaProperty class.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public CustomMetaProperty()

See Also

Reference

  • CustomMetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


CustomMetaProperty Properties

  • CustomMetaProperty Class
  • See Also
  • Language Filter ( all languages )

The CustomMetaProperty type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets a name of the metadata property. (Inherited from MetaProperty.)
Public property | Value | Gets or sets a value of the custom metadata field be to uploaded to Amazon S3 storage.

See Also

Reference

  • CustomMetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


Value Property

CustomMetaProperty..::.Value Property

  • Collapse All Sections
  • CustomMetaProperty Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value of the custom metadata field be to uploaded to Amazon S3 storage.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Value As String

C#

public string Value { get; set; }

Property Value

Type: System..::.String

The value of the custom metadata field.

See Also

Reference

  • CustomMetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


FileSettings Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class contains a list of settings for file to be uploaded to Amazon S3 storage.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class FileSettings

C#

public class FileSettings

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader.AmazonS3..::.FileSettings

See Also

Reference

  • FileSettings Members
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • $au.amazonS3Extender.fileSettings JavaScript Class
  • FileSettings PHP Class


FileSettings Members

  • FileSettings Class
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The FileSettings type exposes the following members.

Constructors

 | Name | Description
Public method | FileSettings | Creates and initializes an instance of the FileSettings class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Acl | Gets or sets an Amazon S3 access control list. Options include private, public-read, public-read-write, and authenticated-read.
Public property | Key | Gets or sets an Amazon S3 file key.
Public property | MaxFileSize | Gets or sets a maximum allowable size for file to be uploaded.
Public property | Meta | Gets a list of MetaProperty objects representing metadata fields to be uploaded to Amazon S3 storage.
Public property | MinFileSize | Gets or sets a minimum allowable size for file to be uploaded.

See Also

Reference

  • FileSettings Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


FileSettings Constructor

  • FileSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the FileSettings class.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public FileSettings()

See Also

Reference

  • FileSettings Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


FileSettings Properties

  • FileSettings Class
  • See Also
  • Language Filter ( all languages )

The FileSettings type exposes the following members.

Properties

 | Name | Description
Public property | Acl | Gets or sets an Amazon S3 access control list. Options include private, public-read, public-read-write, and authenticated-read.
Public property | Key | Gets or sets an Amazon S3 file key.
Public property | MaxFileSize | Gets or sets a maximum allowable size for file to be uploaded.
Public property | Meta | Gets a list of MetaProperty objects representing metadata fields to be uploaded to Amazon S3 storage.
Public property | MinFileSize | Gets or sets a minimum allowable size for file to be uploaded.

See Also

Reference

  • FileSettings Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


Acl Property

FileSettings..::.Acl Property

  • Collapse All Sections
  • FileSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an Amazon S3 access control list. Options include private, public-read, public-read-write, and authenticated-read.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Acl As String

C#

public string Acl { get; set; }

Property Value

Type: System..::.String

The Amazon S3 access control list.

Default value is "private".

See Also

Reference

  • FileSettings Class
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • $au.amazonS3Extender.fileSettings.acl JavaScript Property
  • FileSettings.Acl PHP Property


Key Property

FileSettings..::.Key Property

  • Collapse All Sections
  • FileSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an Amazon S3 file key.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Key As String

C#

public string Key { get; set; }

Property Value

Type: System..::.String

The Amazon S3 file key.

Default value is "${filename}".

See Also

Reference

  • FileSettings Class
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • $au.amazonS3Extender.fileSettings.key JavaScript Property
  • FileSettings.Key PHP Property


MaxFileSize Property

FileSettings..::.MaxFileSize Property

  • Collapse All Sections
  • FileSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum allowable size for file to be uploaded.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MaxFileSize As Long

C#

public long MaxFileSize { get; set; }

Property Value

Type: System..::.Int64

The maximum allowable size for file to be uploaded.

Default value is 5368709120.

See Also

Reference

  • FileSettings Class
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • FileSettings.MaxFileSize PHP Property


Meta Property

FileSettings..::.Meta Property

  • Collapse All Sections
  • FileSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a list of MetaProperty objects representing metadata fields to be uploaded to Amazon S3 storage.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public ReadOnly Property Meta As List(Of MetaProperty)

C#

public List<MetaProperty> Meta { get; }

Property Value

Type: System.Collections.Generic..::.List<(Of <(T>)>)

The list of MetaProperty objects representing metadata fields to be uploaded to Amazon S3 storage.

The array of metadata fields to be uploaded to Amazon S3 storage.

See Also

Reference

  • FileSettings Class
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • $au.amazonS3Extender.fileSettings.meta JavaScript Property
  • FileSettings.Meta PHP Property


MinFileSize Property

FileSettings..::.MinFileSize Property

  • Collapse All Sections
  • FileSettings Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum allowable size for file to be uploaded.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property MinFileSize As Long

C#

public long MinFileSize { get; set; }

Property Value

Type: System..::.Int64

The minimum allowable size for file to be uploaded.

Default value is 0.

See Also

Reference

  • FileSettings Class
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • FileSettings.MinFileSize PHP Property


FileSettingsCollection Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents collection of settings for files to be uploaded to Amazon S3 storage.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class FileSettingsCollection _
    Inherits Collection(Of FileSettings)

C#

public class FileSettingsCollection : Collection<FileSettings>

Inheritance Hierarchy

System..::.Object L System.Collections.ObjectModel..::.Collection < (Of < ( FileSettings > ) > ) L Aurigma.ImageUploader.AmazonS3..::.FileSettingsCollection

See Also

Reference

  • FileSettingsCollection Members
  • Aurigma.ImageUploader.AmazonS3 Namespace
  • $au.amazonS3Extender.converters JavaScript Class


FileSettingsCollection Members

  • FileSettingsCollection Class
  • Methods
  • Properties
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The FileSettingsCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from Collection <(Of <( FileSettings >)>).)
Public method | Clear | (Inherited from Collection <(Of <( FileSettings >)>).)
Protected method | ClearItems | (Inherited from Collection <(Of <( FileSettings >)>).)
Public method | Contains | (Inherited from Collection <(Of <( FileSettings >)>).)
Public method | CopyTo | (Inherited from Collection <(Of <( FileSettings >)>).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection <(Of <( FileSettings >)>).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection <(Of <( FileSettings >)>).)
Public method | Insert | (Inherited from Collection <(Of <( FileSettings >)>).)
Protected method | InsertItem | (Inherited from Collection <(Of <( FileSettings >)>).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from Collection <(Of <( FileSettings >)>).)
Public method | RemoveAt | (Inherited from Collection <(Of <( FileSettings >)>).)
Protected method | RemoveItem | (Inherited from Collection <(Of <( FileSettings >)>).)
Protected method | SetItem | (Inherited from Collection <(Of <( FileSettings >)>).)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | (Inherited from Collection <(Of <( FileSettings >)>).)
Public property | Item | (Inherited from Collection <(Of <( FileSettings >)>).)
Protected property | Items | (Inherited from Collection <(Of <( FileSettings >)>).)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::.Add | (Inherited from Collection <(Of <( FileSettings >)>).)
Explicit interface implemetation | IList..::.Contains | (Inherited from Collection <(Of <( FileSettings >)>).)
Explicit interface implemetation | ICollection..::.CopyTo | (Inherited from Collection <(Of <( FileSettings >)>).)
Explicit interface implemetation | IEnumerable..::.GetEnumerator | (Inherited from Collection <(Of <( FileSettings >)>).)
Explicit interface implemetation | IList..::.IndexOf | (Inherited from Collection <(Of <( FileSettings >)>).)
Explicit interface implemetation | IList..::.Insert | (Inherited from Collection <(Of <( FileSettings >)>).)
Explicit interface implemetation | IList..::.IsFixedSize | (Inherited from Collection <(Of <( FileSettings >)>).)
Explicit interface implemetation | ICollection<(Of <(T>)>)..::.IsReadOnly | (Inherited from Collection <(Of <( FileSettings >)>).)
Explicit interface implemetation | IList..::.IsReadOnly | (Inherited from Collection <(Of <( FileSettings >)>).)
Explicit interface implemetation | ICollection..::.IsSynchronized | (Inherited from Collection <(Of <( FileSettings >)>).)
Explicit interface implemetation | IList..::.Item | (Inherited from Collection <(Of <( FileSettings >)>).)
Explicit interface implemetation | IList..::.Remove | (Inherited from Collection <(Of <( FileSettings >)>).)
Explicit interface implemetation | ICollection..::.SyncRoot | (Inherited from Collection <(Of <( FileSettings >)>).)

See Also

Reference

  • FileSettingsCollection Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


MetaProperty Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This is a base class for CustomMetaProperty and PredefinedMetaProperty classes.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public MustInherit Class MetaProperty

C#

public abstract class MetaProperty

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader.AmazonS3..::.MetaProperty L Aurigma.ImageUploader.AmazonS3..::.CustomMetaProperty L Aurigma.ImageUploader.AmazonS3..::.PredefinedMetaProperty

See Also

Reference

  • MetaProperty Members
  • Aurigma.ImageUploader.AmazonS3 Namespace


MetaProperty Members

  • MetaProperty Class
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The MetaProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current MetaProperty. (Overrides Object ..::. ToString()()().)

Properties

 | Name | Description
Public property | Name | Gets or sets a name of the metadata property.

See Also

Reference

  • MetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


MetaProperty Methods

  • MetaProperty Class
  • See Also
  • Language Filter ( all languages )

The MetaProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current MetaProperty. (Overrides Object ..::. ToString()()().)

See Also

Reference

  • MetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


ToString Method

MetaProperty..::.ToString Method

  • Collapse All Sections
  • MetaProperty Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns a String that represents the current MetaProperty.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Overrides Function ToString As String

C#

public override string ToString()

Return Value

Type: System..::.String

The string representation of the current MetaProperty.

See Also

Reference

  • MetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


MetaProperty Properties

  • MetaProperty Class
  • See Also
  • Language Filter ( all languages )

The MetaProperty type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets a name of the metadata property.

See Also

Reference

  • MetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


Name Property

MetaProperty..::.Name Property

  • Collapse All Sections
  • MetaProperty Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a name of the metadata property.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Name As String

C#

public string Name { get; set; }

Property Value

Type: System..::.String

The name of the metadata property.

See Also

Reference

  • MetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


PredefinedMetaProperty Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a predefined metadata field to be uploaded to Amazon S3 storage.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class PredefinedMetaProperty _
    Inherits MetaProperty

C#

public class PredefinedMetaProperty : MetaProperty

Inheritance Hierarchy

System..::.Object L Aurigma.ImageUploader.AmazonS3..::.MetaProperty L Aurigma.ImageUploader.AmazonS3..::.PredefinedMetaProperty

See Also

Reference

  • PredefinedMetaProperty Members
  • Aurigma.ImageUploader.AmazonS3 Namespace


PredefinedMetaProperty Members

  • PredefinedMetaProperty Class
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The PredefinedMetaProperty type exposes the following members.

Constructors

 | Name | Description
Public method | PredefinedMetaProperty | Creates and initializes an instance of the PredefinedMetaProperty class.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current MetaProperty. (Inherited from MetaProperty.)

Properties

 | Name | Description
Public property | Field | Gets or sets a value of the predefined metadata field to be uploaded to Amazon S3 storage.
Public property | Name | Gets or sets a name of the metadata property. (Inherited from MetaProperty.)

See Also

Reference

  • PredefinedMetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


PredefinedMetaProperty Constructor

  • PredefinedMetaProperty Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the PredefinedMetaProperty class.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public PredefinedMetaProperty()

See Also

Reference

  • PredefinedMetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


PredefinedMetaProperty Properties

  • PredefinedMetaProperty Class
  • See Also
  • Language Filter ( all languages )

The PredefinedMetaProperty type exposes the following members.

Properties

 | Name | Description
Public property | Field | Gets or sets a value of the predefined metadata field to be uploaded to Amazon S3 storage.
Public property | Name | Gets or sets a name of the metadata property. (Inherited from MetaProperty.)

See Also

Reference

  • PredefinedMetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


Field Property

PredefinedMetaProperty..::.Field Property

  • Collapse All Sections
  • PredefinedMetaProperty Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value of the predefined metadata field to be uploaded to Amazon S3 storage.

Namespace: Aurigma.ImageUploader.AmazonS3
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Field As String

C#

public string Field { get; set; }

Property Value

Type: System..::.String

The value of the predefined metadata field.

See Also

Reference

  • PredefinedMetaProperty Class
  • Aurigma.ImageUploader.AmazonS3 Namespace


Aurigma.ImageUploader.AmazonS3.Design Namespace

Classes

 | Class | Description
Public class | AmazonS3Designer |


AmazonS3Designer Class

  • Members
  • See Also
  • Language Filter ( all languages )

Namespace: Aurigma.ImageUploader.AmazonS3.Design
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class AmazonS3Designer _
    Inherits ControlDesigner

C#

public class AmazonS3Designer : ControlDesigner

Inheritance Hierarchy

System..::.Object L System.ComponentModel.Design..::.ComponentDesigner L System.Web.UI.Design..::.HtmlControlDesigner L System.Web.UI.Design..::.ControlDesigner L Aurigma.ImageUploader.AmazonS3.Design..::.AmazonS3Designer

See Also

Reference

  • AmazonS3Designer Members
  • Aurigma.ImageUploader.AmazonS3.Design Namespace


AmazonS3Designer Members

  • AmazonS3Designer Class
  • Constructors
  • Methods
  • Properties
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The AmazonS3Designer type exposes the following members.

Constructors

 | Name | Description
Public method | AmazonS3Designer |

Methods

 | Name | Description
Protected method | CreateErrorDesignTimeHtml | Overloaded.
Protected method | CreatePlaceHolderDesignTimeHtml | Overloaded.
Protected method | CreateViewControl | (Inherited from ControlDesigner.)
Public method | Dispose | Overloaded.
Public method | DoDefaultAction | (Inherited from ComponentDesigner.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from ComponentDesigner.)
Public method | GetBounds | (Inherited from ControlDesigner.)
Public method | GetDesignTimeHtml | Overloaded.
Public method | GetEditableDesignerRegionContent | (Inherited from ControlDesigner.)
Protected method | GetEmptyDesignTimeHtml | (Inherited from ControlDesigner.)
Protected method | GetErrorDesignTimeHtml | (Inherited from ControlDesigner.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetPersistenceContent | (Inherited from ControlDesigner.)
Public method | GetPersistInnerHtml | (Inherited from ControlDesigner.)
Protected method | GetService | (Inherited from ComponentDesigner.)
Public method | GetType | (Inherited from Object.)
Public method | GetViewRendering | (Inherited from ControlDesigner.)
Public method | Initialize | (Inherited from ControlDesigner.)
Public method | InitializeExistingComponent | (Inherited from ComponentDesigner.)
Public method | InitializeNewComponent | (Inherited from ComponentDesigner.)
Public method | InitializeNonDefault | (Inherited from ComponentDesigner.)
Public method | Invalidate | Overloaded.
Protected method | InvokeGetInheritanceAttribute | (Inherited from ComponentDesigner.)
Public method | IsPropertyBound | (Inherited from ControlDesigner.)
Public method | Localize | (Inherited from ControlDesigner.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnAutoFormatApplied | (Inherited from ControlDesigner.)
Protected method | OnBehaviorAttached | (Inherited from HtmlControlDesigner.)
Protected method | OnBehaviorDetaching | (Inherited from HtmlControlDesigner.)
Protected method | OnBindingsCollectionChanged | (Inherited from ControlDesigner.)
Protected method | OnClick | (Inherited from ControlDesigner.)
Public method | OnComponentChanged | (Inherited from ControlDesigner.)
Public method | OnComponentChanging | (Inherited from ControlDesigner.)
Protected method | OnControlResize | (Inherited from ControlDesigner.)
Protected method | OnPaint | (Inherited from ControlDesigner.)
Public method | OnSetComponentDefaults | (Inherited from ComponentDesigner.)
Public method | OnSetParent | (Inherited from HtmlControlDesigner.)
Protected method | PostFilterAttributes | (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | (Inherited from HtmlControlDesigner.)
Protected method | PreFilterProperties | (Inherited from ControlDesigner.)
Protected method | RaiseComponentChanged | (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | (Inherited from ComponentDesigner.)
Public method | RaiseResizeEvent | (Inherited from ControlDesigner.)
Public method | RegisterClone | (Inherited from ControlDesigner.)
Public method | SetEditableDesignerRegionContent | (Inherited from ControlDesigner.)
Protected method | SetRegionContent | (Inherited from ControlDesigner.)
Protected method | SetViewFlags | (Inherited from ControlDesigner.)
Public method | ToString | (Inherited from Object.)
Public method | UpdateDesignTimeHtml | (Inherited from ControlDesigner.)

Properties

 | Name | Description
Public property | ActionLists | (Inherited from ControlDesigner.)
Public property | AllowResize | (Inherited from ControlDesigner.)
Public property | AssociatedComponents | (Inherited from ComponentDesigner.)
Public property | AutoFormats | (Inherited from ControlDesigner.)
Public property | Behavior | (Inherited from HtmlControlDesigner.)
Public property | Component | (Inherited from ComponentDesigner.)
Public property | DataBindings | (Inherited from HtmlControlDesigner.)
Protected property | DataBindingsEnabled | (Inherited from ControlDesigner.)
Protected property | DesignerState | (Inherited from ControlDesigner.)
Protected property | DesignTimeElement | (Inherited from HtmlControlDesigner.)
Protected property | DesignTimeElementView | (Inherited from ControlDesigner.)
Public property | DesignTimeHtmlRequiresLoadComplete | (Inherited from ControlDesigner.)
Public property | Expressions | (Inherited from HtmlControlDesigner.)
Protected property | HidePropertiesInTemplateMode | (Inherited from ControlDesigner.)
Public property | ID | (Inherited from ControlDesigner.)
Protected property | InheritanceAttribute | (Inherited from ComponentDesigner.)
Protected property | Inherited | (Inherited from ComponentDesigner.)
Protected property | InTemplateMode | (Inherited from ControlDesigner.)
Public property | IsDirty | (Inherited from ControlDesigner.)
Protected property | ParentComponent | (Inherited from ComponentDesigner.)
Public property | ReadOnly | (Inherited from ControlDesigner.)
Protected property | RootDesigner | (Inherited from ControlDesigner.)
Protected property | ShadowProperties | (Inherited from ComponentDesigner.)
Public property | ShouldCodeSerialize | (Inherited from HtmlControlDesigner.)
Protected property | Tag | (Inherited from ControlDesigner.)
Public property | TemplateGroups | (Inherited from ControlDesigner.)
Protected property | UsePreviewControl | (Inherited from ControlDesigner.)
Public property | Verbs | (Inherited from ComponentDesigner.)
Public property | ViewControl | (Inherited from ControlDesigner.)
Public property | ViewControlCreated | (Inherited from ControlDesigner.)
Protected property | Visible | (Inherited from ControlDesigner.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ITreeDesigner..::.Children | (Inherited from ComponentDesigner.)
Explicit interface implemetation | ITreeDesigner..::.Parent | (Inherited from ComponentDesigner.)
Explicit interface implemetation | IDesignerFilter..::.PostFilterAttributes | (Inherited from ComponentDesigner.)
Explicit interface implemetation | IDesignerFilter..::.PostFilterEvents | (Inherited from ComponentDesigner.)
Explicit interface implemetation | IDesignerFilter..::.PostFilterProperties | (Inherited from ComponentDesigner.)
Explicit interface implemetation | IDesignerFilter..::.PreFilterAttributes | (Inherited from ComponentDesigner.)
Explicit interface implemetation | IDesignerFilter..::.PreFilterEvents | (Inherited from ComponentDesigner.)
Explicit interface implemetation | IDesignerFilter..::.PreFilterProperties | (Inherited from ComponentDesigner.)

See Also

Reference

  • AmazonS3Designer Class
  • Aurigma.ImageUploader.AmazonS3.Design Namespace


AmazonS3Designer Constructor

  • AmazonS3Designer Class
  • See Also
  • Language Filter ( all languages )

Namespace: Aurigma.ImageUploader.AmazonS3.Design
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public AmazonS3Designer()

See Also

Reference

  • AmazonS3Designer Class
  • Aurigma.ImageUploader.AmazonS3.Design Namespace


AmazonS3Designer Methods

  • AmazonS3Designer Class
  • See Also
  • Language Filter ( all languages )

The AmazonS3Designer type exposes the following members.

Methods

 | Name | Description
Protected method | CreateErrorDesignTimeHtml | Overloaded.
Protected method | CreatePlaceHolderDesignTimeHtml | Overloaded.
Protected method | CreateViewControl | (Inherited from ControlDesigner.)
Public method | Dispose | Overloaded.
Public method | DoDefaultAction | (Inherited from ComponentDesigner.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from ComponentDesigner.)
Public method | GetBounds | (Inherited from ControlDesigner.)
Public method | GetDesignTimeHtml | Overloaded.
Public method | GetEditableDesignerRegionContent | (Inherited from ControlDesigner.)
Protected method | GetEmptyDesignTimeHtml | (Inherited from ControlDesigner.)
Protected method | GetErrorDesignTimeHtml | (Inherited from ControlDesigner.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetPersistenceContent | (Inherited from ControlDesigner.)
Public method | GetPersistInnerHtml | (Inherited from ControlDesigner.)
Protected method | GetService | (Inherited from ComponentDesigner.)
Public method | GetType | (Inherited from Object.)
Public method | GetViewRendering | (Inherited from ControlDesigner.)
Public method | Initialize | (Inherited from ControlDesigner.)
Public method | InitializeExistingComponent | (Inherited from ComponentDesigner.)
Public method | InitializeNewComponent | (Inherited from ComponentDesigner.)
Public method | InitializeNonDefault | (Inherited from ComponentDesigner.)
Public method | Invalidate | Overloaded.
Protected method | InvokeGetInheritanceAttribute | (Inherited from ComponentDesigner.)
Public method | IsPropertyBound | (Inherited from ControlDesigner.)
Public method | Localize | (Inherited from ControlDesigner.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnAutoFormatApplied | (Inherited from ControlDesigner.)
Protected method | OnBehaviorAttached | (Inherited from HtmlControlDesigner.)
Protected method | OnBehaviorDetaching | (Inherited from HtmlControlDesigner.)
Protected method | OnBindingsCollectionChanged | (Inherited from ControlDesigner.)
Protected method | OnClick | (Inherited from ControlDesigner.)
Public method | OnComponentChanged | (Inherited from ControlDesigner.)
Public method | OnComponentChanging | (Inherited from ControlDesigner.)
Protected method | OnControlResize | (Inherited from ControlDesigner.)
Protected method | OnPaint | (Inherited from ControlDesigner.)
Public method | OnSetComponentDefaults | (Inherited from ComponentDesigner.)
Public method | OnSetParent | (Inherited from HtmlControlDesigner.)
Protected method | PostFilterAttributes | (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | (Inherited from HtmlControlDesigner.)
Protected method | PreFilterProperties | (Inherited from ControlDesigner.)
Protected method | RaiseComponentChanged | (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | (Inherited from ComponentDesigner.)
Public method | RaiseResizeEvent | (Inherited from ControlDesigner.)
Public method | RegisterClone | (Inherited from ControlDesigner.)
Public method | SetEditableDesignerRegionContent | (Inherited from ControlDesigner.)
Protected method | SetRegionContent | (Inherited from ControlDesigner.)
Protected method | SetViewFlags | (Inherited from ControlDesigner.)
Public method | ToString | (Inherited from Object.)
Public method | UpdateDesignTimeHtml | (Inherited from ControlDesigner.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IDesignerFilter..::.PostFilterAttributes | (Inherited from ComponentDesigner.)
Explicit interface implemetation | IDesignerFilter..::.PostFilterEvents | (Inherited from ComponentDesigner.)
Explicit interface implemetation | IDesignerFilter..::.PostFilterProperties | (Inherited from ComponentDesigner.)
Explicit interface implemetation | IDesignerFilter..::.PreFilterAttributes | (Inherited from ComponentDesigner.)
Explicit interface implemetation | IDesignerFilter..::.PreFilterEvents | (Inherited from ComponentDesigner.)
Explicit interface implemetation | IDesignerFilter..::.PreFilterProperties | (Inherited from ComponentDesigner.)

See Also

Reference

  • AmazonS3Designer Class
  • Aurigma.ImageUploader.AmazonS3.Design Namespace


GetDesignTimeHtml Method

AmazonS3Designer..::.GetDesignTimeHtml Method

  • Collapse All Sections
  • AmazonS3Designer Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | GetDesignTimeHtml()()() | (Overrides ControlDesigner ..::. GetDesignTimeHtml()()().)
Public method | GetDesignTimeHtml(DesignerRegionCollection) | (Inherited from ControlDesigner.)

See Also

Reference

  • AmazonS3Designer Class
  • AmazonS3Designer Members
  • Aurigma.ImageUploader.AmazonS3.Design Namespace


GetDesignTimeHtml Method

AmazonS3Designer..::.GetDesignTimeHtml Method

  • Collapse All Sections
  • AmazonS3Designer Class
  • See Also
  • Language Filter ( all languages )

Namespace: Aurigma.ImageUploader.AmazonS3.Design
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Overrides Function GetDesignTimeHtml As String

C#

public override string GetDesignTimeHtml()

See Also

Reference

  • AmazonS3Designer Class
  • GetDesignTimeHtml Overload
  • Aurigma.ImageUploader.AmazonS3.Design Namespace


Aurigma.ImageUploader.Nirvanix Namespace

The Aurigma.ImageUploader.Nirvanix namespace contains classes related to Nirvanix extender.

Classes

 | Class | Description
Public class | NirvanixException | The exception which is thrown if some error occurred during upload to Nirvanix service.
Public class | NirvanixExtender | This class extends Image Uploader with a direct upload to Nirvanix storage.

See Also

Reference

  • $au.nirvanixExtender JavaScript Namespace


NirvanixException Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

The exception which is thrown if some error occurred during upload to Nirvanix service.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

<SerializableAttribute> _
Public Class NirvanixException _
    Inherits Exception _
    Implements ISerializable

C#

[SerializableAttribute]
public class NirvanixException : Exception, ISerializable

Inheritance Hierarchy

System..::.Object L System..::.Exception L Aurigma.ImageUploader.Nirvanix..::.NirvanixException

See Also

Reference

  • NirvanixException Members
  • Aurigma.ImageUploader.Nirvanix Namespace


NirvanixException Members

  • NirvanixException Class
  • Constructors
  • Methods
  • Properties
  • See Also
  • Language Filter ( all languages )

The NirvanixException type exposes the following members.

Constructors

 | Name | Description
Public method | NirvanixException | Overloaded.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Protected property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)

See Also

Reference

  • NirvanixException Class
  • Aurigma.ImageUploader.Nirvanix Namespace


NirvanixException Constructor

  • NirvanixException Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | NirvanixException()()() | Creates and initializes an instance of the NirvanixException class.
Public method | NirvanixException(String) | Creates and initializes an instance of the NirvanixException class with the specified message.
Public method | NirvanixException(String, Exception) | Creates and initializes an instance of the NirvanixException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

Reference

  • NirvanixException Class
  • NirvanixException Members
  • Aurigma.ImageUploader.Nirvanix Namespace


NirvanixException Constructor

  • NirvanixException Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the NirvanixException class.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public NirvanixException()

See Also

Reference

  • NirvanixException Class
  • NirvanixException Overload
  • Aurigma.ImageUploader.Nirvanix Namespace


NirvanixException Constructor (String)

  • NirvanixException Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the NirvanixException class with the specified message.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New ( _
    message As String _
)

C#

public NirvanixException(
    string message
)

Parameters

message

Type: System..::.String

The error message that explains the reason for the exception.

See Also

Reference

  • NirvanixException Class
  • NirvanixException Overload
  • Aurigma.ImageUploader.Nirvanix Namespace


NirvanixException Constructor (String, Exception)

  • NirvanixException Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the NirvanixException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New ( _
    message As String, _
    innerException As Exception _
)

C#

public NirvanixException(
    string message,
    Exception innerException
)

Parameters

message

Type: System..::.String

The error message that explains the reason for the exception.

innerException

Type: System..::.Exception

The exception that is the cause of the current exception. If the parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

  • NirvanixException Class
  • NirvanixException Overload
  • Aurigma.ImageUploader.Nirvanix Namespace


NirvanixExtender Class

  • Members
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class extends Image Uploader with a direct upload to Nirvanix storage.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Class NirvanixExtender _
    Inherits BaseUploaderExtender

C#

public class NirvanixExtender : BaseUploaderExtender

Inheritance Hierarchy

System..::.Object L System.Web.UI..::.Control L Aurigma.ImageUploader..::.BaseExtender L Aurigma.ImageUploader..::.BaseUploaderExtender L Aurigma.ImageUploader.Nirvanix..::.NirvanixExtender

See Also

Reference

  • NirvanixExtender Members
  • Aurigma.ImageUploader.Nirvanix Namespace
  • $au.nirvanixExtender JavaScript Class
  • NirvanixExtender PHP Class


NirvanixExtender Members

  • NirvanixExtender Class
  • Constructors
  • Methods
  • Properties
  • Events
  • Explicit Interface Implementations
  • See Also
  • Language Filter ( all languages )

The NirvanixExtender type exposes the following members.

Constructors

 | Name | Description
Public method | NirvanixExtender | Creates and initializes an instance of the NirvanixExtender class.

Methods

 | Name | Description
Protected method | AddedControl | (Inherited from Control.)
Protected method | AddParsedSubObject | (Inherited from Control.)
Public method | ApplyStyleSheetSkin | (Inherited from Control.)
Protected method | BuildProfileTree | (Inherited from Control.)
Protected method | ClearChildControlState | (Inherited from Control.)
Protected method | ClearChildState | (Inherited from Control.)
Protected method | ClearChildViewState | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | DataBind | Overloaded.
Protected method | DataBindChildren | (Inherited from Control.)
Public method | Dispose | (Inherited from Control.)
Protected method | EnsureChildControls | (Inherited from Control.)
Protected method | EnsureID | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindControl | Overloaded.
Public method | Focus | (Inherited from Control.)
Protected method | GetDesignModeState | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasControls | (Inherited from Control.)
Protected method | HasEvents | (Inherited from Control.)
Protected method | IsLiteralContent | (Inherited from Control.)
Protected method | LoadControlState | (Inherited from Control.)
Protected method | LoadViewState | (Inherited from Control.)
Protected method | MapPathSecure | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnBubbleEvent | (Inherited from Control.)
Protected method | OnDataBinding | (Inherited from Control.)
Protected method | OnInit | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Control.)
Protected method | OnUnload | (Inherited from Control.)
Protected method | OpenFile | (Inherited from Control.)
Protected method | RaiseBubbleEvent | (Inherited from Control.)
Protected method | RemovedControl | (Inherited from Control.)
Protected method | Render | (Inherited from Control.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderControl | Overloaded.
Protected method | ResolveAdapter | (Inherited from Control.)
Public method | ResolveClientUrl | (Inherited from Control.)
Public method | ResolveUrl | (Inherited from Control.)
Protected method | SaveControlState | (Inherited from Control.)
Protected method | SaveViewState | (Inherited from Control.)
Protected method | SetDesignModeState | (Inherited from Control.)
Public method | SetRenderMethodDelegate | (Inherited from Control.)
Public method | ToString | (Inherited from Object.)
Protected method | TrackViewState | (Inherited from Control.)

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppKey | Gets or sets an application key that contains the user to be logged in.
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Protected property | DesignMode | (Inherited from Control.)
Public property | DestFolderPath | Gets or sets a destination path of the files being uploaded.
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Public property | FileOverwrite | Gets or sets a value indicating whether a file with the same name in the destination folder should be overwritten by a file uploaded using the upload token.
Public property | FirstByteExpiration | Gets or sets a number of seconds the upload token has until the first byte of an upload is transferred.
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Public property | IpRestricted | Gets or sets a value indicating whether the upload token should be restricted to the consumerIP.
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Public property | LastByteExpiration | Gets or sets a number of seconds the upload token has until an upload is completed.
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | Password | Gets or sets the password for the account.
Public property | Site | (Inherited from Control.)
Public property | SizeBytes | Gets or sets a size of the file to be uploaded in bytes.
Public property | SkinID | (Inherited from Control.)
Protected property | TargetControl | Gets a reference to the Uploader control instance associated with this extender. (Inherited from BaseUploaderExtender.)
Public property | TargetControlID | Gets or sets an ID of the Uploader control instance associated with this extender. (Inherited from BaseUploaderExtender.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Public property | Username | Gets or sets an account name to log in with.
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Events

 | Name | Description
Public event | DataBinding | (Inherited from Control.)
Public event | Disposed | (Inherited from Control.)
Public event | Init | (Inherited from Control.)
Public event | Load | (Inherited from Control.)
Public event | PreRender | (Inherited from Control.)
Public event | Unload | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • NirvanixExtender Class
  • Aurigma.ImageUploader.Nirvanix Namespace


NirvanixExtender Constructor

  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the NirvanixExtender class.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Sub New

C#

public NirvanixExtender()

See Also

Reference

  • NirvanixExtender Class
  • Aurigma.ImageUploader.Nirvanix Namespace
  • $au.nirvanixExtender(uploader) JavaScript Constructor
  • NirvanixExtender(Uploader) PHP Constructor


NirvanixExtender Properties

  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )

The NirvanixExtender type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | (Inherited from Control.)
Public property | AppKey | Gets or sets an application key that contains the user to be logged in.
Public property | AppRelativeTemplateSourceDirectory | (Inherited from Control.)
Public property | BindingContainer | (Inherited from Control.)
Protected property | ChildControlsCreated | (Inherited from Control.)
Public property | ClientID | (Inherited from Control.)
Protected property | ClientIDSeparator | (Inherited from Control.)
Protected property | Context | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Protected property | DesignMode | (Inherited from Control.)
Public property | DestFolderPath | Gets or sets a destination path of the files being uploaded.
Public property | EnableTheming | (Inherited from Control.)
Public property | EnableViewState | (Inherited from Control.)
Protected property | Events | (Inherited from Control.)
Public property | FileOverwrite | Gets or sets a value indicating whether a file with the same name in the destination folder should be overwritten by a file uploaded using the upload token.
Public property | FirstByteExpiration | Gets or sets a number of seconds the upload token has until the first byte of an upload is transferred.
Protected property | HasChildViewState | (Inherited from Control.)
Public property | ID | (Inherited from Control.)
Protected property | IdSeparator | (Inherited from Control.)
Public property | IpRestricted | Gets or sets a value indicating whether the upload token should be restricted to the consumerIP.
Protected property | IsChildControlStateCleared | (Inherited from Control.)
Protected property | IsTrackingViewState | (Inherited from Control.)
Protected property | IsViewStateEnabled | (Inherited from Control.)
Public property | LastByteExpiration | Gets or sets a number of seconds the upload token has until an upload is completed.
Protected property | LoadViewStateByID | (Inherited from Control.)
Public property | NamingContainer | (Inherited from Control.)
Public property | Page | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | Password | Gets or sets the password for the account.
Public property | Site | (Inherited from Control.)
Public property | SizeBytes | Gets or sets a size of the file to be uploaded in bytes.
Public property | SkinID | (Inherited from Control.)
Protected property | TargetControl | Gets a reference to the Uploader control instance associated with this extender. (Inherited from BaseUploaderExtender.)
Public property | TargetControlID | Gets or sets an ID of the Uploader control instance associated with this extender. (Inherited from BaseUploaderExtender.)
Public property | TemplateControl | (Inherited from Control.)
Public property | TemplateSourceDirectory | (Inherited from Control.)
Public property | UniqueID | (Inherited from Control.)
Public property | Username | Gets or sets an account name to log in with.
Protected property | ViewState | (Inherited from Control.)
Protected property | ViewStateIgnoresCase | (Inherited from Control.)
Public property | Visible | (Inherited from Control.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.Expressions | (Inherited from Control.)
Explicit interface implemetation | IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
Explicit interface implemetation | IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
Explicit interface implemetation | IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

Reference

  • NirvanixExtender Class
  • Aurigma.ImageUploader.Nirvanix Namespace


AppKey Property

NirvanixExtender..::.AppKey Property

  • Collapse All Sections
  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an application key that contains the user to be logged in.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property AppKey As String

C#

public string AppKey { get; set; }

Property Value

Type: System..::.String

The application key that contains the user to be logged in.

Default value is "".

See Also

Reference

  • NirvanixExtender Class
  • Aurigma.ImageUploader.Nirvanix Namespace
  • NirvanixExtender.AppKey PHP Property


DestFolderPath Property

NirvanixExtender..::.DestFolderPath Property

  • Collapse All Sections
  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a destination path of the files being uploaded.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property DestFolderPath As String

C#

public string DestFolderPath { get; set; }

Property Value

Type: System..::.String

The destination path of the files being uploaded.

Default value is "".

See Also

Reference

  • NirvanixExtender Class
  • Aurigma.ImageUploader.Nirvanix Namespace
  • $au.nirvanixExtender.destFolderPath JavaScript Property
  • NirvanixExtender.DestFolderPath PHP Property


FileOverwrite Property

NirvanixExtender..::.FileOverwrite Property

  • Collapse All Sections
  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether a file with the same name in the destination folder should be overwritten by a file uploaded using the upload token.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FileOverwrite As Boolean

C#

public bool FileOverwrite { get; set; }

Property Value

Type: System..::.Boolean

If true, a file with the same name in the destination folder will be overwritten by a file uploaded using the upload token. Otherwise, name collisions will result in an upload error.

Default value is false.

See Also

Reference

  • NirvanixExtender Class
  • Aurigma.ImageUploader.Nirvanix Namespace
  • NirvanixExtender.FileOverwrite PHP Property


FirstByteExpiration Property

NirvanixExtender..::.FirstByteExpiration Property

  • Collapse All Sections
  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a number of seconds the upload token has until the first byte of an upload is transferred.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property FirstByteExpiration As Integer

C#

public int FirstByteExpiration { get; set; }

Property Value

Type: System..::.Int32

The number of seconds the upload token has until the first byte of an upload is transferred.

Default value is 600.

See Also

Reference

  • NirvanixExtender Class
  • Aurigma.ImageUploader.Nirvanix Namespace
  • NirvanixExtender.FirstByteExpiration PHP Property


IpRestricted Property

NirvanixExtender..::.IpRestricted Property

  • Collapse All Sections
  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the upload token should be restricted to the consumerIP.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property IpRestricted As Boolean

C#

public bool IpRestricted { get; set; }

Property Value

Type: System..::.Boolean

If true, the upload token will be restricted to the consumerIP.

Default value is false.

See Also

Reference

  • NirvanixExtender Class
  • Aurigma.ImageUploader.Nirvanix Namespace
  • NirvanixExtender.IpRestricted PHP Property


LastByteExpiration Property

NirvanixExtender..::.LastByteExpiration Property

  • Collapse All Sections
  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a number of seconds the upload token has until an upload is completed.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property LastByteExpiration As Integer

C#

public int LastByteExpiration { get; set; }

Property Value

Type: System..::.Int32

The number of seconds the upload token has until an upload is completed.

Default value is 259200.

See Also

Reference

  • NirvanixExtender Class
  • Aurigma.ImageUploader.Nirvanix Namespace
  • NirvanixExtender.LastByteExpiration PHP Property


Password Property

NirvanixExtender..::.Password Property

  • Collapse All Sections
  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the password for the account.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Password As String

C#

public string Password { get; set; }

Property Value

Type: System..::.String

The password for the account.

Default value is "".

See Also

Reference

  • NirvanixExtender Class
  • Aurigma.ImageUploader.Nirvanix Namespace
  • NirvanixExtender.Password PHP Property


SizeBytes Property

NirvanixExtender..::.SizeBytes Property

  • Collapse All Sections
  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a size of the file to be uploaded in bytes.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property SizeBytes As Integer

C#

public int SizeBytes { get; set; }

Property Value

Type: System..::.Int32

The size of the file to be uploaded in bytes.

Default value is 10485760.

See Also

Reference

  • NirvanixExtender Class
  • Aurigma.ImageUploader.Nirvanix Namespace
  • NirvanixExtender.SizeBytes PHP Property


Username Property

NirvanixExtender..::.Username Property

  • Collapse All Sections
  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )
  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an account name to log in with.

Namespace: Aurigma.ImageUploader.Nirvanix
Assembly: Aurigma.ImageUploader (in Aurigma.ImageUploader.dll)

Syntax

Visual Basic

Public Property Username As String

C#

public string Username { get; set; }

Property Value

Type: System..::.String

The account name to log in with.

Default value is "".

See Also

Reference

  • NirvanixExtender Class
  • Aurigma.ImageUploader.Nirvanix Namespace
  • NirvanixExtender.Username PHP Property


Image Uploader PHP Reference

Image Uploader PHP is a collection of classes that are meant to make deployment of Image Uploader and handling uploaded data easier. Using this collection, PHP developers can work with Image Uploader in a usual way as with a common PHP object. Refer to the documentation to get started with Image Uploader PHP.

Classes

 | Name | Description
Public class | ActiveXControl | This class represents Image Uploader ActiveX control.
Public class | AddFilesProgressDialog | This class represents the adding files dialog which appears when a user selects quite a lot of files.
Public class | AuthenticationDialog | This class represents the authentication dialog.
Public class | BackgroundImageFormat | This class specifies settings of a background image.
Public class | BaseClientControl | This is a base class for all client-side controls.
Public class | BaseControl | This is a base class for all Image Uploader visual controls.
Public class | ClientEvents | This class provides access to Image Uploader client-side events.
Public class | ContextMenu | This class represents Image Uploader context menu. Use this class to customize or localize context menu options.
Public class | ConvertedFile | This class represents a converted file and exposes a number of properties and methods which provide an access to the converted file details (e.g. file name, size, conversion mode, and etc.) and allows saving it on a server.
Public class | Converter | This class represents a file converter.
Public class | DeleteFilesDialog | This class represents the delete confirmation dialog which appears in non-Internet Explorer browsers when EnableOriginalFilesDeletion is true.
Public class | DescriptionEditor | This class represents the description editor.
Public class | DetailsViewColumns | This class contains titles of columns displayed in the Details view.
Public class | FolderPane | This class represents the folder pane.
Public class | FontFormat | This class specifies font settings.
Public class | ImageEditor | This class represents the image editor.
Public class | ImageFormat | This class specifies different states of Image Uploader buttons and icons.
Public class | InformationBar | This class represents the information bar.
Public class | InstallationProgress | This class allows displaying special screens instead of Image Uploader during the downloading and installation phases.
Public class | JavaControl | This class represents Image Uploader Java applet.
Public class | Messages | This class contains error messages Image Uploader shows.
Public class | Metadata | This class represents an additional upload data.
Public class | Package | This class represents a package uploaded within the current session.
Public class | PaneItem | This class represents a pane item displayed in both the upload and folder panes.
Public class | PostFields | This class contains POST field names that are generated and uploaded by Image Uploader.
Public class | QualityMeter | This class represents the quality meter.
Public class | Restrictions | This class contains masks for allowed and denied file extensions and upload restrictions.
Public class | StatusPane | This class represents the status pane.
Public class | Thumbnail | This class represents a standalone thumbnail bound with some upload pane item of Image Uploader.
Public class | ThumbnailClientEvents | This class provides access to client-side events of the Thumbnail control.
Public class | TreePane | This class represents the tree pane.
Public class | UploadedFile | This class provides an access to all the converted files and metadata related to a particular user-selected file.
Public class | Uploader | This class is intended for embedding Image Uploader into PHP applications.
Public class | UploadHandler | This class allows processing the data uploaded by Image Uploader from client computers.
Public class | UploadPane | This class represents the upload pane.
Public class | UploadProgressDialog | This class represents the uploading files dialog which appears during the upload.
Public class | UploadSettings | This class represents the upload settings.
Public class | AmazonS3Extender | This class extends Image Uploader with a direct upload to Amazon S3 storage.
Public class | FileSettings | This class contains a list of settings for file to be uploaded to Amazon S3 storage.
Public class | NirvanixExtender | This class extends Image Uploader with a direct upload to Nirvanix storage.


ActiveXControl Class

  • Supported browsers: Internet Explorer

This class represents Image Uploader ActiveX control.

For a list of all members of this class, see ActiveXControl Members.

Syntax

PHP

class ActiveXControl extends BaseClientControl {
}

Remarks

Note

This client-side control is used in Internet Explorer only.

Inheritance Hierarchy

BaseClientControl LActiveXControl

See Also

Reference

  • ActiveXControl Property
  • Aurigma.ImageUploader.ActiveXControl ASP.NET Class
  • $au.activeXControl JavaScript Class


ActiveXControl Members

  • Properties
  • Language Filter ( all languages )

The ActiveXControl type exposes the following members.

Properties

 | Name | Description
Public property | ClassId | Gets or sets a CLSID of the ActiveX control.
Public property | CodeBase | Gets or sets a URL to client-side control. (Inherited from BaseClientControl.)
Public property | ProgId | Gets or sets a PROGID of the ActiveX control.
Public property | Version | Gets or sets a minimum required version of the client-side control. (Inherited from BaseClientControl.)


ActiveXControl Properties

  • Properties
  • Language Filter ( all languages )

The ActiveXControl type exposes the following properties.

Properties

 | Name | Description
Public property | ClassId | Gets or sets a CLSID of the ActiveX control.
Public property | CodeBase | Gets or sets a URL to client-side control. (Inherited from BaseClientControl.)
Public property | ProgId | Gets or sets a PROGID of the ActiveX control.
Public property | Version | Gets or sets a minimum required version of the client-side control. (Inherited from BaseClientControl.)


ActiveXControl.ClassId Property

  • Supported browsers: Internet Explorer

Gets or sets a CLSID of the ActiveX control.

Syntax

PHP

public function getClassId() {
}

public function setClassId($value) {
}

Property Value

Type: string

The CLSID of the ActiveX control.

Default value is "".

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ActiveXControl.ClassId ASP.NET Property
  • $au.activeXControl.classId JavaScript Property

Manual

  • Using Private-label Version of Image Uploader PHP


ActiveXControl.ProgId Property

  • Supported browsers: Internet Explorer

Gets or sets a PROGID of the ActiveX control.

Syntax

PHP

public function getProgId() {
}

public function setProgId($value) {
}

Property Value

Type: string

The PROGID of the ActiveX control.

Default value is "".

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ActiveXControl.ProgId ASP.NET Property
  • $au.activeXControl.progId JavaScript Property

Manual

  • Using Private-label Version of Image Uploader PHP


AddFilesProgressDialog Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the adding files dialog which appears when a user selects quite a lot of files.

For a list of all members of this class, see AddFilesProgressDialog Members.

Syntax

PHP

class AddFilesProgressDialog {
}

See Also

Reference

  • AddFilesProgressDialog Property
  • Aurigma.ImageUploader.AddFilesProgressDialog ASP.NET Class
  • $au.addFilesProgressDialog JavaScript Class

Manual

  • Customizing Appearance


AddFilesProgressDialog Members

  • Properties
  • Language Filter ( all languages )

The AddFilesProgressDialog type exposes the following members.

Properties

 | Name | Description
Public property | CancelButtonText | Gets or sets a caption of the Cancel button on the dialog displayed when a user selects quite a lot of files.
Public property | CurrentFileText | Gets or sets a text of the label which displays a name of the currently processing file.
Public property | TitleText | Gets or sets a title of the dialog displayed when a user selects quite a lot of files.
Public property | TotalFilesText | Get or sets a text of the label which displays a total number of processed files.
Public property | WaitText | Gets or sets a text of the label which is displayed while Image Uploader is preparing to add files.


AddFilesProgressDialog Properties

  • Properties
  • Language Filter ( all languages )

The AddFilesProgressDialog type exposes the following properties.

Properties

 | Name | Description
Public property | CancelButtonText | Gets or sets a caption of the Cancel button on the dialog displayed when a user selects quite a lot of files.
Public property | CurrentFileText | Gets or sets a text of the label which displays a name of the currently processing file.
Public property | TitleText | Gets or sets a title of the dialog displayed when a user selects quite a lot of files.
Public property | TotalFilesText | Get or sets a text of the label which displays a total number of processed files.
Public property | WaitText | Gets or sets a text of the label which is displayed while Image Uploader is preparing to add files.


AddFilesProgressDialog.CancelButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel button on the dialog displayed when a user selects quite a lot of files.

Syntax

PHP

public function getCancelButtonText() {
}

public function setCancelButtonText($value) {
}

Property Value

Type: string

The caption of the Cancel button on the adding files dialog.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AddFilesProgressDialog.CancelButtonText ASP.NET Property
  • $au.addFilesProgressDialog.cancelButtonText JavaScript Property


AddFilesProgressDialog.CurrentFileText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text of the label which displays a name of the currently processing file.

Syntax

PHP

public function getCurrentFileText() {
}

public function setCurrentFileText($value) {
}

Property Value

Type: string

The text of the Processing file label. It can contain the following placeholder:

[name]
replaced by the name of the currently processing file.

Default value is "Processing file: '[name]'".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AddFilesProgressDialog.CurrentFileText ASP.NET Property
  • $au.addFilesProgressDialog.currentFileText JavaScript Property


AddFilesProgressDialog.TitleText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the dialog displayed when a user selects quite a lot of files.

Syntax

PHP

public function getTitleText() {
}

public function setTitleText($value) {
}

Property Value

Type: string

The title of the adding files dialog.

Default value is "Adding files to upload queue".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AddFilesProgressDialog.TitleText ASP.NET Property
  • $au.addFilesProgressDialog.titleText JavaScript Property


AddFilesProgressDialog.TotalFilesText Property

  • Supported browsers: Firefox Google Chrome Safari

Get or sets a text of the label which displays a total number of processed files.

Syntax

PHP

public function getTotalFilesText() {
}

public function setTotalFilesText($value) {
}

Property Value

Type: string

The text of the Already processed files label. It can contain the following placeholder:

[count]
replaced by the total number of processed files.

Default value is "already processed files: [count]".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AddFilesProgressDialog.TotalFilesText ASP.NET Property
  • $au.addFilesProgressDialog.totalFilesText JavaScript Property


AddFilesProgressDialog.WaitText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the label which is displayed while Image Uploader is preparing to add files.

Syntax

PHP

public function getWaitText() {
}

public function setWaitText($value) {
}

Property Value

Type: string

The text of the Please wait label.

Default value is "Please wait, it may take some time...".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AddFilesProgressDialog.WaitText ASP.NET Property
  • $au.addFilesProgressDialog.waitText JavaScript Property


AuthenticationDialog Class

  • Supported browsers: Firefox Google Chrome Safari

This class represents the authentication dialog.

For a list of all members of this class, see AuthenticationDialog Members.

Syntax

PHP

class AuthenticationDialog {
}

Remarks

This dialog is displayed when the server requests a password. It is displayed during each upload session, i.e. it does not remember the login information.

Note

The authentication dialog is displayed in non-Internet Explorer browsers only.

See Also

Reference

  • AuthenticationDialog Property
  • Aurigma.ImageUploader.AuthenticationDialog ASP.NET Class
  • $au.authenticationDialog JavaScript Class

Manual

  • Adding Authentication


AuthenticationDialog Members

  • Properties
  • Language Filter ( all languages )

The AuthenticationDialog type exposes the following members.

Properties

 | Name | Description
Public property | CancelButtonText | Gets or sets a caption of the Cancel button.
Public property | LoginText | Gets or sets a text of the Login label.
Public property | OkButtonText | Gets or sets a caption of the Ok button.
Public property | PasswordText | Gets or sets a text of the Password label.
Public property | RealmText | Gets or sets a text of the Realm label.
Public property | Text | Gets or sets a text of the dialog message.


AuthenticationDialog Properties

  • Properties
  • Language Filter ( all languages )

The AuthenticationDialog type exposes the following properties.

Properties

 | Name | Description
Public property | CancelButtonText | Gets or sets a caption of the Cancel button.
Public property | LoginText | Gets or sets a text of the Login label.
Public property | OkButtonText | Gets or sets a caption of the Ok button.
Public property | PasswordText | Gets or sets a text of the Password label.
Public property | RealmText | Gets or sets a text of the Realm label.
Public property | Text | Gets or sets a text of the dialog message.


AuthenticationDialog.CancelButtonText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the Cancel button.

Syntax

PHP

public function getCancelButtonText() {
}

public function setCancelButtonText($value) {
}

Property Value

Type: string

The caption of the Cancel button.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AuthenticationDialog.CancelButtonText ASP.NET Property
  • $au.authenticationDialog.cancelButtonText JavaScript Property


AuthenticationDialog.LoginText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the Login label.

Syntax

PHP

public function getLoginText() {
}

public function setLoginText($value) {
}

Property Value

Type: string

The text of the Login label.

Default value is "Login:".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AuthenticationDialog.LoginText ASP.NET Property
  • $au.authenticationDialog.loginText JavaScript Property


AuthenticationDialog.OkButtonText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the Ok button.

Syntax

PHP

public function getOkButtonText() {
}

public function setOkButtonText($value) {
}

Property Value

Type: string

The caption of the Ok button.

Default value is "Ok".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AuthenticationDialog.OkButtonText ASP.NET Property
  • $au.authenticationDialog.okButtonText JavaScript Property


AuthenticationDialog.PasswordText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the Password label.

Syntax

PHP

public function getPasswordText() {
}

public function setPasswordText($value) {
}

Property Value

Type: string

The text of the Password label.

Default value is "Password:".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AuthenticationDialog.PasswordText ASP.NET Property
  • $au.authenticationDialog.passwordText JavaScript Property


AuthenticationDialog.RealmText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the Realm label.

Syntax

PHP

public function getRealmText() {
}

public function setRealmText($value) {
}

Property Value

Type: string

The text of the Realm label.

Default value is "Realm:".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AuthenticationDialog.RealmText ASP.NET Property
  • $au.authenticationDialog.realmText JavaScript Property


AuthenticationDialog.Text Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the dialog message.

Syntax

PHP

public function getText() {
}

public function setText($value) {
}

Property Value

Type: string

The text of the dialog message. It can contain the following placeholder:

[name]
replaced by the name of the server which requests authentication.

Default value is "Host [name] requires authentication".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AuthenticationDialog.Text ASP.NET Property
  • $au.authenticationDialog.text JavaScript Property


BackgroundImageFormat Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class specifies settings of a background image.

For a list of all members of this class, see BackgroundImageFormat Members.

Syntax

PHP

class BackgroundImageFormat {
}

See Also

Reference

  • DropFilesHereImageFormat Property
  • Aurigma.ImageUploader.BackgroundImageFormat ASP.NET Class


BackgroundImageFormat Members

  • Properties
  • Language Filter ( all languages )

The BackgroundImageFormat type exposes the following members.

Properties

 | Name | Description
Public property | Height | Gets or sets a height of the background image.
Public property | Position | Gets or sets a position of the background image.
Public property | Url | Gets or sets a URL to the background image.
Public property | Width | Gets or sets a width of the background image.


BackgroundImageFormat Properties

  • Properties
  • Language Filter ( all languages )

The BackgroundImageFormat type exposes the following properties.

Properties

 | Name | Description
Public property | Height | Gets or sets a height of the background image.
Public property | Position | Gets or sets a position of the background image.
Public property | Url | Gets or sets a URL to the background image.
Public property | Width | Gets or sets a width of the background image.


BackgroundImageFormat.Height Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of the background image.

Syntax

PHP

public function getHeight() {
}

public function setHeight($value) {
}

Property Value

Type: integer

The height of the background image.

Default value is 0.

See Also

Reference

  • Aurigma.ImageUploader.BackgroundImageFormat.Height ASP.NET Property


BackgroundImageFormat.Position Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a position of the background image.

Syntax

PHP

public function getPosition() {
}

public function setPosition($value) {
}

Property Value

Type: string

The position of the background image.

The following values are supported:

  • TopLeft - image will be displayed in the top left corner of the upload pane.
  • TopCenter - image will be displayed in the center of the top of the upload pane.
  • TopRight - image will be displayed in the right top corner of the upload pane.
  • CenterLeft - image will be displayed in the center of the left edge of the upload pane.
  • Center - image will be displayed in the center of the upload pane.
  • CenterRight - image will be displayed in the center of the right edge of the upload pane.
  • BottomLeft - image will be displayed in the bottom left corner of the upload pane.
  • BottomCenter - image will be displayed in the center of the bottom of the upload pane.
  • BottomRight - image will be displayed in the bottom right corner of the upload pane.

Default value is "Center".

See Also

Reference

  • Aurigma.ImageUploader.BackgroundImageFormat.Position ASP.NET Property


BackgroundImageFormat.Url Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the background image.

Syntax

PHP

public function getUrl() {
}

public function setUrl($value) {
}

Property Value

Type: string

The URL to the background image.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.BackgroundImageFormat.Url ASP.NET Property


BackgroundImageFormat.Width Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of the background image.

Syntax

PHP

public function getWidth() {
}

public function setWidth($value) {
}

Property Value

Type: integer

The width of the background image.

Default value is 0.

See Also

Reference

  • Aurigma.ImageUploader.BackgroundImageFormat.Width ASP.NET Property


BaseClientControl Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This is a base class for all client-side controls.

For a list of all members of this class, see BaseClientControl Members.

Syntax

PHP

abstract class BaseClientControl {
}

Remarks

BaseClientControl is an abstract class which implements common functionality for client-side controls. You cannot instantiate objects of this class directly.

Inheritance Hierarchy

LBaseClientControl L ActiveXControl L JavaControl

See Also

Reference

  • Aurigma.ImageUploader.BaseClientControl ASP.NET Class


BaseClientControl Members

  • Properties
  • Language Filter ( all languages )

The BaseClientControl type exposes the following members.

Properties

 | Name | Description
Public property | CodeBase | Gets or sets a URL to client-side control.
Public property | Version | Gets or sets a minimum required version of the client-side control.


BaseClientControl Properties

  • Properties
  • Language Filter ( all languages )

The BaseClientControl type exposes the following properties.

Properties

 | Name | Description
Public property | CodeBase | Gets or sets a URL to client-side control.
Public property | Version | Gets or sets a minimum required version of the client-side control.


BaseClientControl.CodeBase Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to client-side control.

Syntax

PHP

public function getCodeBase() {
}

public function setCodeBase($value) {
}

Property Value

Type: string

The URL to client-side control.

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.BaseClientControl.CodeBase ASP.NET Property

Manual

  • Using Private-label Version of Image Uploader PHP


BaseClientControl.Version Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum required version of the client-side control.

Syntax

PHP

public function getVersion() {
}

public function setVersion($value) {
}

Property Value

Type: string

The minimum required version of the client-side control.

See Also

Reference

  • Aurigma.ImageUploader.BaseClientControl.Version ASP.NET Property


BaseControl Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This is a base class for all Image Uploader visual controls.

For a list of all members of this class, see BaseControl Members.

Syntax

PHP

abstract class BaseControl {
}

Remarks

BaseControl is an abstract class which implements common functionality for Image Uploader visual controls. You cannot instantiate objects of this class directly.

Inheritance Hierarchy

LBaseControl L Thumbnail L Uploader

See Also

Reference

  • Aurigma.ImageUploader.BaseControl ASP.NET Class


BaseControl Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The BaseControl type exposes the following members.

Constructors

 | Name | Description
Public method | BaseControl(string) | Creates and initializes an instance of the BaseControl class.

Methods

 | Name | Description
Public method | render | Generates the control embedding code and writes it into the page.

Properties

 | Name | Description
Public property | DebugScriptLevel | Gets or sets a debug level.
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0.
Public property | ID | Gets or sets an ID of the control that is used to get a reference to this control.
Public property | ManualRendering | Gets or sets a value indicating whether the control should be created but not rendered.
Public property | ScriptsDirectory | Gets or sets a URL from which a stand-alone aurigma.uploader.js file will be downloaded.


BaseControl(string) Constructor

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the BaseControl class.

Syntax

PHP

public function BaseControl($id) {
}

Parameters

id

Type: string

The ID of this BaseControl instance.


BaseControl Methods

  • Methods
  • Language Filter ( all languages )

The BaseControl type exposes the following methods.

Methods

 | Name | Description
Public method | render | Generates the control embedding code and writes it into the page.


BaseControl.render Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Generates the control embedding code and writes it into the page.

Syntax

PHP

public function render() {
}


BaseControl Properties

  • Properties
  • Language Filter ( all languages )

The BaseControl type exposes the following properties.

Properties

 | Name | Description
Public property | DebugScriptLevel | Gets or sets a debug level.
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0.
Public property | ID | Gets or sets an ID of the control that is used to get a reference to this control.
Public property | ManualRendering | Gets or sets a value indicating whether the control should be created but not rendered.
Public property | ScriptsDirectory | Gets or sets a URL from which a stand-alone aurigma.uploader.js file will be downloaded.


BaseControl.DebugScriptLevel Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a debug level.

Syntax

PHP

public function getDebugScriptLevel() {
}

public function setDebugScriptLevel($value) {
}

Property Value

Type: integer

The debug level. The following values are supported:

Value | Description
0 | Show no messages at all.
1 | Show errors only.
2 | Show errors and debug messages from Image Uploader.
3 | Show errors, debug messages from Image Uploader, and information messages.
Note

If DebugScriptLevel is greater than 0, the uncompressed client-side scripts are used.

Default value is 0.

See Also

Reference

  • Aurigma.ImageUploader.BaseControl.DebugScriptLevel ASP.NET Property


BaseControl.DebugScriptMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0.

Syntax

PHP

public function getDebugScriptMode() {
}

public function setDebugScriptMode($value) {
}

Property Value

Type: string

The string containing one or several debug modes. The following values are supported:

Value | Description
popup | All the messages will be shown in a popup window.
console | All the messages will be logged in a browser console (e.g. Firebug) if it is available.
alert | All the messages will be shown in alerts.
Note

If several debug modes are specified, they are used as follows. When the control is about to display a message, it uses the first specified mode. If it is failed, the next mode is used until the message is displayed correctly.

Default value is "['popup', 'console', 'alert']".

See Also

Reference

  • Aurigma.ImageUploader.BaseControl.DebugScriptMode ASP.NET Property


BaseControl.ID Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ID of the control that is used to get a reference to this control.

Syntax

PHP

public function getID() {
}

public function setID($value) {
}

Property Value

Type: string

The ID of the control.


BaseControl.ManualRendering Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the control should be created but not rendered.

Syntax

PHP

public function getManualRendering() {
}

public function setManualRendering($value) {
}

Property Value

Type: boolean

If true, the control is created but not rendered. If so, you can render the control by calling the uploader.writeHtml() or thumbnail.writeHtml() method. If false, the control in rendered right after creation.

Default value is false.

See Also

Reference

  • Aurigma.ImageUploader.BaseControl.ManualRendering ASP.NET Property


BaseControl.ScriptsDirectory Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL from which a stand-alone aurigma.uploader.js file will be downloaded.

Syntax

PHP

public function getScriptsDirectory() {
}

public function setScriptsDirectory($value) {
}

Property Value

Type: string

The URL from which a stand-alone aurigma.uploader.js file will be downloaded.


ClientEvents Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class provides access to Image Uploader client-side events.

For a list of all members of this class, see ClientEvents Members.

Syntax

PHP

class ClientEvents {
}

See Also

Reference

  • ClientEvents Property
  • $au.events JavaScript Class


ClientEvents Members

  • Properties
  • Language Filter ( all languages )

The ClientEvents type exposes the following members.

Properties

 | Name | Description
Public property | AfterPackageUpload | Gets or sets an array of AfterPackageUpload event handlers.
Public property | AfterSendRequest | Gets or sets an array of AfterSendRequest event handlers.
Public property | AfterUpload | Gets or sets an array of AfterUpload event handlers.
Public property | BeforePackageUpload | Gets or sets an array of BeforePackageUpload event handlers.
Public property | BeforeSendRequest | Gets or sets an array of BeforeSendRequest event handlers.
Public property | BeforeUpload | Gets or sets an array of BeforeUpload event handlers.
Public property | Error | Gets or sets an array of Error event handlers.
Public property | FolderChange | Gets or sets an array of FolderChange event handlers.
Public property | InitComplete | Gets or sets an array of InitComplete event handlers.
Public property | PreRender | Gets or sets an array of PreRender event handlers.
Public property | Progress | Gets or sets an array of Progress event handlers.
Public property | RestrictionFailed | Gets or sets an array of RestrictionFailed event handlers.
Public property | SelectionChange | Gets or sets an array of SelectionChange event handlers.
Public property | UploadFileCountChange | Gets or sets an array of UploadFileCountChange event handlers.
Public property | ViewChange | Gets or sets an array of ViewChange event handlers.


ClientEvents Properties

  • Properties
  • Language Filter ( all languages )

The ClientEvents type exposes the following properties.

Properties

 | Name | Description
Public property | AfterPackageUpload | Gets or sets an array of AfterPackageUpload event handlers.
Public property | AfterSendRequest | Gets or sets an array of AfterSendRequest event handlers.
Public property | AfterUpload | Gets or sets an array of AfterUpload event handlers.
Public property | BeforePackageUpload | Gets or sets an array of BeforePackageUpload event handlers.
Public property | BeforeSendRequest | Gets or sets an array of BeforeSendRequest event handlers.
Public property | BeforeUpload | Gets or sets an array of BeforeUpload event handlers.
Public property | Error | Gets or sets an array of Error event handlers.
Public property | FolderChange | Gets or sets an array of FolderChange event handlers.
Public property | InitComplete | Gets or sets an array of InitComplete event handlers.
Public property | PreRender | Gets or sets an array of PreRender event handlers.
Public property | Progress | Gets or sets an array of Progress event handlers.
Public property | RestrictionFailed | Gets or sets an array of RestrictionFailed event handlers.
Public property | SelectionChange | Gets or sets an array of SelectionChange event handlers.
Public property | UploadFileCountChange | Gets or sets an array of UploadFileCountChange event handlers.
Public property | ViewChange | Gets or sets an array of ViewChange event handlers.


ClientEvents.AfterPackageUpload Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of AfterPackageUpload event handlers.

Syntax

PHP

public function &getAfterPackageUpload() {
}

public function setAfterPackageUpload($value) {
}

Property Value

Type: array

The string containing a name of AfterPackageUpload event handler or an array of handler names.

Remarks

This event fires when the current package was uploaded successfully.

See Also

Reference

  • AfterPackageUpload Client-Side Event
  • $au.events.afterPackageUpload JavaScript Property


ClientEvents.AfterSendRequest Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of AfterSendRequest event handlers.

Syntax

PHP

public function &getAfterSendRequest() {
}

public function setAfterSendRequest($value) {
}

Property Value

Type: array

The string containing a name of AfterSendRequest event handler or an array of handler names.

Remarks

This event fires when the current POST request was uploaded successfully.

See Also

Reference

  • AfterSendRequest Client-Side Event
  • $au.events.afterSendRequest JavaScript Property


ClientEvents.AfterUpload Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of AfterUpload event handlers.

Syntax

PHP

public function &getAfterUpload() {
}

public function setAfterUpload($value) {
}

Property Value

Type: array

The string containing a name of AfterUpload event handler or an array of handler names.

Remarks

This event fires after successful upload.

See Also

Reference

  • AfterUpload Client-Side Event
  • $au.events.afterUpload JavaScript Property


ClientEvents.BeforePackageUpload Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of BeforePackageUpload event handlers.

Syntax

PHP

public function &getBeforePackageUpload() {
}

public function setBeforePackageUpload($value) {
}

Property Value

Type: array

The string containing a name of BeforePackageUpload event handler or an array of handler names.

Remarks

This event fires when the current package is about to be uploaded.

See Also

Reference

  • BeforePackageUpload Client-Side Event
  • $au.events.beforePackageUpload JavaScript Property


ClientEvents.BeforeSendRequest Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of BeforeSendRequest event handlers.

Syntax

PHP

public function &getBeforeSendRequest() {
}

public function setBeforeSendRequest($value) {
}

Property Value

Type: array

The string containing a name of BeforeSendRequest event handler or an array of handler names.

Remarks

This event fires when the current POST request is about to be uploaded.

See Also

Reference

  • BeforeSendRequest Client-Side Event
  • $au.events.beforeSendRequest JavaScript Property


ClientEvents.BeforeUpload Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of BeforeUpload event handlers.

Syntax

PHP

public function &getBeforeUpload() {
}

public function setBeforeUpload($value) {
}

Property Value

Type: array

The string containing a name of BeforeUpload event handler or an array of handler names.

Remarks

This event fires when the upload is about to be started.

See Also

Reference

  • BeforeUpload Client-Side Event
  • $au.events.beforeUpload JavaScript Property


ClientEvents.Error Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of Error event handlers.

Syntax

PHP

public function &getError() {
}

public function setError($value) {
}

Property Value

Type: array

The string containing a name of Error event handler or an array of handler names.

Remarks

This event fires if some error occurred during the current upload session.

See Also

Reference

  • Error Client-Side Event
  • $au.events.error JavaScript Property


ClientEvents.FolderChange Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of FolderChange event handlers.

Syntax

PHP

public function &getFolderChange() {
}

public function setFolderChange($value) {
}

Property Value

Type: array

The string containing a name of FolderChange event handler or an array of handler names.

Remarks

This event fires when a user goes to another folder.

See Also

Reference

  • FolderChange Client-Side Event
  • $au.events.folderChange JavaScript Property


ClientEvents.InitComplete Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of InitComplete event handlers.

Syntax

PHP

public function &getInitComplete() {
}

public function setInitComplete($value) {
}

Property Value

Type: array

The string containing a name of InitComplete event handler or an array of handler names.

Remarks

This event fires when Image Uploader is completely created and initialized.

See Also

Reference

  • InitComplete Client-Side Event
  • $au.events.initComplete JavaScript Property


ClientEvents.PreRender Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of PreRender event handlers.

Syntax

PHP

public function &getPreRender() {
}

public function setPreRender($value) {
}

Property Value

Type: array

The string containing a name of PreRender event handler or an array of handler names.

Remarks

This event fires before the writeHtml() or getHtml() method is executed.

See Also

Reference

  • PreRender Client-Side Event
  • $au.events.preRender JavaScript Property


ClientEvents.Progress Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of Progress event handlers.

Syntax

PHP

public function &getProgress() {
}

public function setProgress($value) {
}

Property Value

Type: array

The string containing a name of Progress event handler or an array of handler names.

Remarks

This event indicates the progress of the upload.

See Also

Reference

  • Progress Client-Side Event
  • $au.events.progress JavaScript Property


ClientEvents.RestrictionFailed Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of RestrictionFailed event handlers.

Syntax

PHP

public function &getRestrictionFailed() {
}

public function setRestrictionFailed($value) {
}

Property Value

Type: array

The string containing a name of RestrictionFailed event handler or an array of handler names.

Remarks

This event fires when some restriction is broken.

See Also

Reference

  • RestrictionFailed Client-Side Event
  • $au.events.restrictionFailed JavaScript Property


ClientEvents.SelectionChange Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of SelectionChange event handlers.

Syntax

PHP

public function &getSelectionChange() {
}

public function setSelectionChange($value) {
}

Property Value

Type: array

The string containing a name of SelectionChange event handler or an array of handler names.

Remarks

This event fires when a user changes a selection in the upload pane.

See Also

Reference

  • SelectionChange Client-Side Event
  • $au.events.selectionChange JavaScript Property


ClientEvents.UploadFileCountChange Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of UploadFileCountChange event handlers.

Syntax

PHP

public function &getUploadFileCountChange() {
}

public function setUploadFileCountChange($value) {
}

Property Value

Type: array

The string containing a name of UploadFileCountChange event handler or an array of handler names.

Remarks

This event fires when a user adds/removes any files to/from the upload list.

See Also

Reference

  • UploadFileCountChange Client-Side Event
  • $au.events.uploadFileCountChange JavaScript Property


ClientEvents.ViewChange Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of ViewChange event handlers.

Syntax

PHP

public function &getViewChange() {
}

public function setViewChange($value) {
}

Property Value

Type: array

The string containing a name of ViewChange event handler or an array of handler names.

Remarks

This event fires when the view mode is changed.

See Also

Reference

  • ViewChange Client-Side Event
  • $au.events.viewChange JavaScript Property


ContextMenu Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents Image Uploader context menu. Use this class to customize or localize context menu options.

For a list of all members of this class, see ContextMenu Members.

Syntax

PHP

class ContextMenu {
}

See Also

Reference

  • ContextMenu Property
  • Aurigma.ImageUploader.ContextMenu ASP.NET Class
  • $au.contextMenu JavaScript Class

Manual

  • Customizing Appearance


ContextMenu Members

  • Properties
  • Language Filter ( all languages )

The ContextMenu type exposes the following members.

Properties

 | Name | Description
Public property | ArrangeByDimensionsText | Gets or sets a caption of the Dimensions context menu item inside Arrange by group.
Public property | ArrangeByModifiedText | Gets or sets a caption of the Date modified context menu item inside Arrange by group.
Public property | ArrangeByNameText | Gets or sets a caption of the Name context menu item inside Arrange by group.
Public property | ArrangeByPathText | Gets or sets a caption of the Path context menu item inside Arrange by group.
Public property | ArrangeBySizeText | Gets or sets a caption of the Size context menu item inside Arrange by group.
Public property | ArrangeByText | Gets or sets a caption of the Sort by context menu.
Public property | ArrangeByTypeText | Gets or sets a caption of the Item type context menu item inside Arrange by group.
Public property | CheckAllText | Gets or sets a caption of the Check all context menu item.
Public property | CheckText | Gets or sets a caption of the Check context menu item.
Public property | DetailsViewText | Gets or sets a caption of the Details context menu item.
Public property | EditDescriptionText | Gets or sets a caption of the Edit description context menu item.
Public property | EditText | Gets or sets a caption of the Edit image context menu item.
Public property | ListViewText | Gets or sets a caption of the List context menu item.
Public property | OpenText | Gets or sets a caption of the Open context menu item.
Public property | PasteText | Gets or sets a caption of the Paste context menu item.
Public property | RemoveAllText | Gets or sets a caption of the Remove all from upload list context menu item.
Public property | RemoveText | Gets or sets a caption of the Remove from upload list context menu item.
Public property | ThumbnailsViewText | Gets or sets a caption of the Thumbnails context menu item.
Public property | TilesViewText | Gets or sets a caption of the Tiles context menu item.
Public property | UncheckAllText | Gets or sets a caption of the Uncheck all context menu item.
Public property | UncheckText | Gets or sets a caption of the Uncheck context menu item.


ContextMenu Properties

  • Properties
  • Language Filter ( all languages )

The ContextMenu type exposes the following properties.

Properties

 | Name | Description
Public property | ArrangeByDimensionsText | Gets or sets a caption of the Dimensions context menu item inside Arrange by group.
Public property | ArrangeByModifiedText | Gets or sets a caption of the Date modified context menu item inside Arrange by group.
Public property | ArrangeByNameText | Gets or sets a caption of the Name context menu item inside Arrange by group.
Public property | ArrangeByPathText | Gets or sets a caption of the Path context menu item inside Arrange by group.
Public property | ArrangeBySizeText | Gets or sets a caption of the Size context menu item inside Arrange by group.
Public property | ArrangeByText | Gets or sets a caption of the Sort by context menu.
Public property | ArrangeByTypeText | Gets or sets a caption of the Item type context menu item inside Arrange by group.
Public property | CheckAllText | Gets or sets a caption of the Check all context menu item.
Public property | CheckText | Gets or sets a caption of the Check context menu item.
Public property | DetailsViewText | Gets or sets a caption of the Details context menu item.
Public property | EditDescriptionText | Gets or sets a caption of the Edit description context menu item.
Public property | EditText | Gets or sets a caption of the Edit image context menu item.
Public property | ListViewText | Gets or sets a caption of the List context menu item.
Public property | OpenText | Gets or sets a caption of the Open context menu item.
Public property | PasteText | Gets or sets a caption of the Paste context menu item.
Public property | RemoveAllText | Gets or sets a caption of the Remove all from upload list context menu item.
Public property | RemoveText | Gets or sets a caption of the Remove from upload list context menu item.
Public property | ThumbnailsViewText | Gets or sets a caption of the Thumbnails context menu item.
Public property | TilesViewText | Gets or sets a caption of the Tiles context menu item.
Public property | UncheckAllText | Gets or sets a caption of the Uncheck all context menu item.
Public property | UncheckText | Gets or sets a caption of the Uncheck context menu item.


ContextMenu.ArrangeByDimensionsText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the Dimensions context menu item inside Arrange by group.

Syntax

PHP

public function getArrangeByDimensionsText() {
}

public function setArrangeByDimensionsText($value) {
}

Property Value

Type: string

The caption of the Dimensions context menu item.

Default value is "Dimensions".

Remarks

This menu item sorts files in a pane by image dimensions.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeByDimensionsText ASP.NET Property
  • $au.contextMenu.arrangeByDimensionsText JavaScript Property


ContextMenu.ArrangeByModifiedText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Date modified context menu item inside Arrange by group.

Syntax

PHP

public function getArrangeByModifiedText() {
}

public function setArrangeByModifiedText($value) {
}

Property Value

Type: string

The caption of the Date modified context menu item.

Default value is "Date modified".

Remarks

This menu item sorts files in a pane by last modified date.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeByModifiedText ASP.NET Property
  • $au.contextMenu.arrangeByModifiedText JavaScript Property


ContextMenu.ArrangeByNameText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Name context menu item inside Arrange by group.

Syntax

PHP

public function getArrangeByNameText() {
}

public function setArrangeByNameText($value) {
}

Property Value

Type: string

The caption of the Name context menu item.

Default value is "Name".

Remarks

This menu item sorts files in a pane by file name.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeByNameText ASP.NET Property
  • $au.contextMenu.arrangeByNameText JavaScript Property


ContextMenu.ArrangeByPathText Property

  • Supported browsers: Internet Explorer

Gets or sets a caption of the Path context menu item inside Arrange by group.

Syntax

PHP

public function getArrangeByPathText() {
}

public function setArrangeByPathText($value) {
}

Property Value

Type: string

The caption of the Path context menu item.

Default value is "Path".

Remarks

This menu item sorts files in a pane by file path.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeByPathText ASP.NET Property
  • $au.contextMenu.arrangeByPathText JavaScript Property


ContextMenu.ArrangeBySizeText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Size context menu item inside Arrange by group.

Syntax

PHP

public function getArrangeBySizeText() {
}

public function setArrangeBySizeText($value) {
}

Property Value

Type: string

The caption of the Size context menu item.

Default value is "Size".

Remarks

This menu item sorts files in a pane by file size.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeBySizeText ASP.NET Property
  • $au.contextMenu.arrangeBySizeText JavaScript Property


ContextMenu.ArrangeByText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Sort by context menu.

Syntax

PHP

public function getArrangeByText() {
}

public function setArrangeByText($value) {
}

Property Value

Type: string

The caption of the Sort by context menu item.

Default value is "Sort by".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeByText ASP.NET Property
  • $au.contextMenu.arrangeByText JavaScript Property


ContextMenu.ArrangeByTypeText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Item type context menu item inside Arrange by group.

Syntax

PHP

public function getArrangeByTypeText() {
}

public function setArrangeByTypeText($value) {
}

Property Value

Type: string

The caption of the Item type context menu item.

Default value is "Type".

Remarks

This menu item sorts files in a pane by file type.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeByTypeText ASP.NET Property
  • $au.contextMenu.arrangeByTypeText JavaScript Property


ContextMenu.CheckAllText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Check all context menu item.

Syntax

PHP

public function getCheckAllText() {
}

public function setCheckAllText($value) {
}

Property Value

Type: string

The caption of the Check all context menu item.

Default value is "Check all".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.CheckAllText ASP.NET Property
  • $au.contextMenu.checkAllText JavaScript Property


ContextMenu.CheckText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Check context menu item.

Syntax

PHP

public function getCheckText() {
}

public function setCheckText($value) {
}

Property Value

Type: string

The caption of the Check context menu item.

Default value is "Check".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.CheckText ASP.NET Property
  • $au.contextMenu.checkText JavaScript Property


ContextMenu.DetailsViewText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Details context menu item.

Syntax

PHP

public function getDetailsViewText() {
}

public function setDetailsViewText($value) {
}

Property Value

Type: string

The caption of the Details context menu item.

Default value is "Details".

Remarks

This menu item switches the current pane view to Details mode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.DetailsViewText ASP.NET Property
  • $au.contextMenu.detailsViewText JavaScript Property


ContextMenu.EditDescriptionText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Edit description context menu item.

Syntax

PHP

public function getEditDescriptionText() {
}

public function setEditDescriptionText($value) {
}

Property Value

Type: string

The caption of the Edit description context menu item.

Default value is "Edit description...".

Remarks

This menu item opens the description editor.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.EditDescriptionText ASP.NET Property
  • $au.contextMenu.editDescriptionText JavaScript Property


ContextMenu.EditText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Edit image context menu item.

Syntax

PHP

public function getEditText() {
}

public function setEditText($value) {
}

Property Value

Type: string

The caption of the Edit image context menu item.

Default value is "Edit image...".

Remarks

This menu item opens the image in the image editor.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.EditText ASP.NET Property
  • $au.contextMenu.editText JavaScript Property


ContextMenu.ListViewText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the List context menu item.

Syntax

PHP

public function getListViewText() {
}

public function setListViewText($value) {
}

Property Value

Type: string

The caption of the List context menu item.

Default value is "List".

Remarks

This menu item switches the current pane view to List mode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ListViewText ASP.NET Property
  • $au.contextMenu.listViewText JavaScript Property


ContextMenu.OpenText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Open context menu item.

Syntax

PHP

public function getOpenText() {
}

public function setOpenText($value) {
}

Property Value

Type: string

The caption of the Open context menu item.

Default value is "Open".

Remarks

This menu item opens the file in the associated viewer software.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.OpenText ASP.NET Property
  • $au.contextMenu.openText JavaScript Property


ContextMenu.PasteText Property

  • Supported browsers: Internet Explorer

Gets or sets a caption of the Paste context menu item.

Syntax

PHP

public function getPasteText() {
}

public function setPasteText($value) {
}

Property Value

Type: string

The caption of the Paste context menu item.

Default value is "Paste".

Remarks

This menu item pastes an image (not a file) from a clipboard to the upload pane.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.PasteText ASP.NET Property
  • $au.contextMenu.pasteText JavaScript Property


ContextMenu.RemoveAllText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Remove all from upload list context menu item.

Syntax

PHP

public function getRemoveAllText() {
}

public function setRemoveAllText($value) {
}

Property Value

Type: string

The caption of the Remove all from upload list context menu item.

Default value is "Remove all".

Remarks

This menu item clears the upload list.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.RemoveAllText ASP.NET Property
  • $au.contextMenu.removeAllText JavaScript Property


ContextMenu.RemoveText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Remove from upload list context menu item.

Syntax

PHP

public function getRemoveText() {
}

public function setRemoveText($value) {
}

Property Value

Type: string

The caption of the Remove from upload list context menu item.

Default value is "Remove".

Remarks

This menu item removes selected items from the upload list.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.RemoveText ASP.NET Property
  • $au.contextMenu.removeText JavaScript Property


ContextMenu.ThumbnailsViewText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Thumbnails context menu item.

Syntax

PHP

public function getThumbnailsViewText() {
}

public function setThumbnailsViewText($value) {
}

Property Value

Type: string

The caption of the Thumbnails context menu item.

Default value is "Thumbnails".

Remarks

This menu item switches the current pane view to Thumbnails mode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ThumbnailsViewText ASP.NET Property
  • $au.contextMenu.thumbnailsViewText JavaScript Property


ContextMenu.TilesViewText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Tiles context menu item.

Syntax

PHP

public function getTilesViewText() {
}

public function setTilesViewText($value) {
}

Property Value

Type: string

The caption of the Tiles context menu item.

Default value is "Tiles".

Remarks

This menu item switches the current pane view to Tiles mode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.TilesViewText ASP.NET Property
  • $au.contextMenu.tilesViewText JavaScript Property


ContextMenu.UncheckAllText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Uncheck all context menu item.

Syntax

PHP

public function getUncheckAllText() {
}

public function setUncheckAllText($value) {
}

Property Value

Type: string

The caption of the Uncheck all context menu item.

Default value is "Uncheck all".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.UncheckAllText ASP.NET Property
  • $au.contextMenu.uncheckAllText JavaScript Property


ContextMenu.UncheckText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Uncheck context menu item.

Syntax

PHP

public function getUncheckText() {
}

public function setUncheckText($value) {
}

Property Value

Type: string

The caption of the Uncheck context menu item.

Default value is "Uncheck".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.UncheckText ASP.NET Property
  • $au.contextMenu.uncheckText JavaScript Property


ConvertedFile Class

This class represents a converted file and exposes a number of properties and methods which provide an access to the converted file details (e.g. file name, size, conversion mode, and etc.) and allows saving it on a server.

For a list of all members of this class, see ConvertedFile Members.

Syntax

PHP

class ConvertedFile {
}

Remarks

In terms of Image Uploader, converted file is a file uploaded for each of the user-selected files. These files are configured using the Converters property of the Uploader class.

See Also

Reference

  • ConvertedFiles Property
  • Aurigma.ImageUploader.ConvertedFile ASP.NET Class

Manual

  • Saving Uploaded Files in PHP


ConvertedFile Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The ConvertedFile type exposes the following members.

Methods

 | Name | Description
Public method | moveTo(string) | Moves this converted file to the specified path.

Properties

 | Name | Description
Public property | FileContent | Gets content of this converted file represented into string.
Public property | Height | Gets an actual height (in pixels) of this converted file if it is an image.
Public property | Mode | Gets a conversion mode actually applied to this converted file.
Public property | Name | Gets a name of this converted file.
Public property | Size | Gets a size of this converted file (in bytes).
Public property | Width | Gets an actual width (in pixels) of this converted file if it is an image.


ConvertedFile Methods

  • Methods
  • Language Filter ( all languages )

The ConvertedFile type exposes the following methods.

Methods

 | Name | Description
Public method | moveTo(string) | Moves this converted file to the specified path.


ConvertedFile.moveTo(string) Method

Moves this converted file to the specified path.

Syntax

PHP

public function moveTo($destination) {
}

Parameters

destination

Type: string

The path to move this converted file to.

See Also

Reference

  • UploadCacheDirectory Property
  • Aurigma.ImageUploader.ConvertedFile.MoveTo(String) ASP.NET Method


ConvertedFile Properties

  • Properties
  • Language Filter ( all languages )

The ConvertedFile type exposes the following properties.

Properties

 | Name | Description
Public property | FileContent | Gets content of this converted file represented into string.
Public property | Height | Gets an actual height (in pixels) of this converted file if it is an image.
Public property | Mode | Gets a conversion mode actually applied to this converted file.
Public property | Name | Gets a name of this converted file.
Public property | Size | Gets a size of this converted file (in bytes).
Public property | Width | Gets an actual width (in pixels) of this converted file if it is an image.


ConvertedFile.FileContent Property

Gets content of this converted file represented into string.

Syntax

PHP

public function getFileContent() {
}

Property Value

Type: string

A string containing this converted file.


ConvertedFile.Height Property

Gets an actual height (in pixels) of this converted file if it is an image.

Syntax

PHP

public function getHeight() {
}

Property Value

Type: string

The actual height of this converted file if it is an image. Otherwise, this property returns 0.

Remarks

Depending on the ThumbnailFitMode, this value may differ from the value specified through the ThumbnailHeight property. This happens because Image Uploader preserves the aspect ratio of the image and not always can use the same dimensions as specified in the converter parameters.

See Also

Reference

  • Aurigma.ImageUploader.ConvertedFile.Height ASP.NET Property


ConvertedFile.Mode Property

Gets a conversion mode actually applied to this converted file.

Syntax

PHP

public function getMode() {
}

Property Value

Type: string

The mode of this converted file. Possible values are:

  • sourceFile - means that this converted file is a copy of the original file.
  • thumbnail - means that this converted file is a resized copy of the original file if it is an image.
  • icon - means that this converted file is a system icon associated with the original file type.
  • zip - means that this converted file is a ZIP archive of the original file.
  • none - means that this converted file was not created.

See Also

Reference

  • Aurigma.ImageUploader.ConvertedFile.Mode ASP.NET Property


ConvertedFile.Name Property

Gets a name of this converted file.

Syntax

PHP

public function getName() {
}

Property Value

Type: string

The name of this converted file.

Remarks

Depending on the Mode value this property returns one of the following names:

  • name.ext for sourceFile mode.
  • name.ext_ThumbnailX.jpg for thumbnail mode.
  • name.ext_IconX.jpg for icon mode.
  • name.ext_CompressedX.zip for zip mode.

Where X is a zero-based index of the Converter used to create this converted file.

See Also

Reference

  • Aurigma.ImageUploader.ConvertedFile.Name ASP.NET Property


ConvertedFile.Size Property

Gets a size of this converted file (in bytes).

Syntax

PHP

public function getSize() {
}

Property Value

Type: integer

The size of this converted file (in bytes).

See Also

Reference

  • Aurigma.ImageUploader.ConvertedFile.Size ASP.NET Property


ConvertedFile.Width Property

Gets an actual width (in pixels) of this converted file if it is an image.

Syntax

PHP

public function getWidth() {
}

Property Value

Type: string

The actual width of this converted file if it is an image. Otherwise, this property returns 0.

Remarks

Depending on the ThumbnailFitMode, this value may differ from the value specified through the ThumbnailWidth property. This happens because Image Uploader preserves the aspect ratio of the image and not always can use the same dimensions as specified in the converter parameters.

See Also

Reference

  • Aurigma.ImageUploader.ConvertedFile.Width ASP.NET Property


Converter Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a file converter.

For a list of all members of this class, see Converter Members.

Syntax

PHP

class Converter {
}

Remarks

Image Uploader allows sending so-called converted files for each of the user-selected files. These files are configured using the Converters property of the Uploader object. This property accepts a collection of Converter instances. Each converter describes one file (source, thumbnail, icon, or ZIP archive) to be uploaded for every file a user selects.

For example, you set the following collection of converters:

PHP

$uploader = new Uploader("Uploader1");

$converters = &$uploader->getConverters();
$converter = new Converter();
$converter->setMode("*.*=SourceFile");
$converters[] = $converter;
$converter = new Converter();
$converter->setMode("*.*=Thumbnail;*.*=Icon");
$converter->setThumbnailWidth(120);
$converter->setThumbnailHeight(120);
$converter->setThumbnailFitMode("Fit");
$converters[] = $converter;

It means that Image Uploader will send an original file and its resized copy or icon. So if a user selects two files (a JPEG image and a PDF document) Image Uploader will send four files:

  • the JPEG image and the PDF file themselves,
  • a resized copy of the image and a PDF icon.

See Also

Reference

  • Converters Property
  • Aurigma.ImageUploader.Converter ASP.NET Class
  • $au.converter JavaScript Class

Manual

  • Configuring Files to be Uploaded


Converter Members

  • Properties
  • Language Filter ( all languages )

The Converter type exposes the following members.

Properties

 | Name | Description
Public property | Mode | Gets or sets a conversion mode of this converter.
Public property | ThumbnailApplyCrop | Gets or sets a value indicating whether the thumbnail should be cropped.
Public property | ThumbnailBgColor | Gets or sets a background color of the thumbnail.
Public property | ThumbnailCompressOversizedOnly | Gets or sets a value indicating whether an original image should be uploaded as the thumbnail in case when original image dimensions and file size are not bigger than dimensions and file size of this thumbnail.
Public property | ThumbnailCopyExif | Gets or sets a value indicating whether the thumbnail should contain EXIF metadata copied from the original file.
Public property | ThumbnailCopyIptc | Gets or sets a value indicating whether the thumbnail should contain IPTC metadata copied from the original file.
Public property | ThumbnailFitMode | Gets or sets a fit mode of the thumbnail.
Public property | ThumbnailHeight | Gets or sets a height restriction for the thumbnail.
Public property | ThumbnailJpegQuality | Gets or sets a JPEG quality of the thumbnail.
Public property | ThumbnailKeepColorSpace | Gets or sets a value indicating whether to preserve original color space when creating the thumbnail.
Public property | ThumbnailResizeQuality | Gets or sets a resize quality of the thumbnail.
Public property | ThumbnailResolution | Gets or sets an image resolution of the thumbnail.
Public property | ThumbnailWatermark | Gets or sets a watermark of the thumbnail.
Public property | ThumbnailWidth | Gets or sets a width restriction for the thumbnail.


Converter Properties

  • Properties
  • Language Filter ( all languages )

The Converter type exposes the following properties.

Properties

 | Name | Description
Public property | Mode | Gets or sets a conversion mode of this converter.
Public property | ThumbnailApplyCrop | Gets or sets a value indicating whether the thumbnail should be cropped.
Public property | ThumbnailBgColor | Gets or sets a background color of the thumbnail.
Public property | ThumbnailCompressOversizedOnly | Gets or sets a value indicating whether an original image should be uploaded as the thumbnail in case when original image dimensions and file size are not bigger than dimensions and file size of this thumbnail.
Public property | ThumbnailCopyExif | Gets or sets a value indicating whether the thumbnail should contain EXIF metadata copied from the original file.
Public property | ThumbnailCopyIptc | Gets or sets a value indicating whether the thumbnail should contain IPTC metadata copied from the original file.
Public property | ThumbnailFitMode | Gets or sets a fit mode of the thumbnail.
Public property | ThumbnailHeight | Gets or sets a height restriction for the thumbnail.
Public property | ThumbnailJpegQuality | Gets or sets a JPEG quality of the thumbnail.
Public property | ThumbnailKeepColorSpace | Gets or sets a value indicating whether to preserve original color space when creating the thumbnail.
Public property | ThumbnailResizeQuality | Gets or sets a resize quality of the thumbnail.
Public property | ThumbnailResolution | Gets or sets an image resolution of the thumbnail.
Public property | ThumbnailWatermark | Gets or sets a watermark of the thumbnail.
Public property | ThumbnailWidth | Gets or sets a width restriction for the thumbnail.


Converter.Mode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a conversion mode of this converter.

Syntax

PHP

public function getMode() {
}

public function setMode($value) {
}

Property Value

Type: string

The conversion mode of this converter.

Default value is "".

Remarks

This property specifies a format string for a desired conversion mode. It consists of masks=mode pairs separated by semicolon. Each pair includes the set of file masks separated by comma and the corresponding mode. In general, this string has the following syntax:

mask11,mask12,...=mode1;mask21,mask22,...=mode2;...

When Image Uploader prepares the upload request it parses the conversion mode format string from the beginning to the end and extracts such pairs. For each file selected for upload Image Uploader gives the first pair. If it finds the file mask in this pair which matches the file extension, it applies the corresponding mode. Otherwise, if no appropriate file mask found, Image Uploader checks the next pairs in the same manner.

Note

If there is no file mask corresponding to the original file extension or appropriate mode Image Uploader does not send this converted file.

Here is the list of supported conversion modes:

Value | Description
SourceFile | means that the selected file will be uploaded from a user's computer without any changes.
Thumbnail | works as follows. If the selected file is image, it will be resized using the parameters listed below and uploaded as JPEG file. Otherwise, a converted file will not be sent.
Icon | means that a system icon associated with the selected file will be uploaded.
Zip | means that a ZIP archive of the selected file will be uploaded.
None | means that no file will be uploaded.

See Also

Reference

  • Aurigma.ImageUploader.Converter.Mode ASP.NET Property
  • $au.converter.mode JavaScript Property

Manual

  • Configuring Files to be Uploaded
  • Uploading Images


Converter.ThumbnailApplyCrop Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the thumbnail should be cropped.

Syntax

PHP

public function getThumbnailApplyCrop() {
}

public function setThumbnailApplyCrop($value) {
}

Property Value

Type: boolean

If true, the thumbnail is cropped using the specified crop bounds.

Default value is false.

Remarks

In order to set a crop rectangle, select a region in the image editor or use the file.cropBounds property.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailApplyCrop ASP.NET Property
  • $au.converter.thumbnailApplyCrop JavaScript Property

Manual

  • Rotating and Cropping


Converter.ThumbnailBgColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of the thumbnail.

Syntax

PHP

public function getThumbnailBgColor() {
}

public function setThumbnailBgColor($value) {
}

Property Value

Type: string

A background color of the thumbnail. This color is used when the thumbnail should be created for an image with transparency.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#FFFFFF".

Remarks

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailBgColor ASP.NET Property
  • $au.converter.thumbnailBgColor JavaScript Property

Manual

  • Resizing and Recompressing


Converter.ThumbnailCompressOversizedOnly Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether an original image should be uploaded as the thumbnail in case when original image dimensions and file size are not bigger than dimensions and file size of this thumbnail.

Syntax

PHP

public function getThumbnailCompressOversizedOnly() {
}

public function setThumbnailCompressOversizedOnly($value) {
}

Property Value

Type: boolean

If true and:

  • The original file is JPEG;
  • No watermark is applied;
  • The dimensions of the original file are not bigger than the dimensions of the thumbnail;
  • The size in bytes of the original file is not greater than the size of the thumbnail.

Then the original file will be sent instead of the thumbnail. In all other cases a thumbnail is created.

Default value is false.

Remarks

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailCompressOversizedOnly ASP.NET Property
  • $au.converter.thumbnailCompressOversizedOnly JavaScript Property

Manual

  • Resizing and Recompressing


Converter.ThumbnailCopyExif Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the thumbnail should contain EXIF metadata copied from the original file.

Syntax

PHP

public function getThumbnailCopyExif() {
}

public function setThumbnailCopyExif($value) {
}

Property Value

Type: boolean

If true, the EXIF information is copied from the original file. Otherwise, EXIF metadata will not be preserved.

Default value is false.

Remarks

Note

Image Uploader Express and Professional do not preserve EXIF metadata while creating thumbnails. See the Comparison of Image Uploader Editions topic for details.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailCopyExif ASP.NET Property
  • $au.converter.thumbnailCopyExif JavaScript Property

Manual

  • Working with EXIF and IPTC Metadata


Converter.ThumbnailCopyIptc Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the thumbnail should contain IPTC metadata copied from the original file.

Syntax

PHP

public function getThumbnailCopyIptc() {
}

public function setThumbnailCopyIptc($value) {
}

Property Value

Type: boolean

If true, the IPTC information is copied from the original file. Otherwise, IPTC metadata will not be preserved.

Default value is false.

Remarks

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailCopyIptc ASP.NET Property
  • $au.converter.thumbnailCopyIptc JavaScript Property

Manual

  • Working with EXIF and IPTC Metadata


Converter.ThumbnailFitMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a fit mode of the thumbnail.

Syntax

PHP

public function getThumbnailFitMode() {
}

public function setThumbnailFitMode($value) {
}

Property Value

Type: string

The fit mode of the thumbnail.

The following values are supported:

Value | Description
Fit | means that the original image should be resized to fit the rectangle specified with the ThumbnailHeight and ThumbnailWidth properties. Note that the proportions of the original image will be kept.
Width | means that the original image should be resized to be no wider than the ThumbnailWidth value.
Height | means that the original image should be resized to be no higher than the ThumbnailHeight value.
ActualSize | means that dimensions of the original image should be kept; however, it can be rotated or recompressed if necessary.

Default value is "Fit".

Remarks

Note

Image Uploader Express and Professional restrict a size (width x height) of each created thumbnail to 3 and 5 megapixels respectively. For example, the size of 1500x1500 thumbnail is 2.25 megapixels (1500 pixels x 1500 pixels = 2.25 megapixels), so such thumbnail can be uploaded with Image Uploader Express. See the Comparison of Image Uploader Editions topic for details.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailFitMode ASP.NET Property
  • $au.converter.thumbnailFitMode JavaScript Property

Manual

  • Resizing and Recompressing


Converter.ThumbnailHeight Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height restriction for the thumbnail.

Syntax

PHP

public function getThumbnailHeight() {
}

public function setThumbnailHeight($value) {
}

Property Value

Type: integer

The height of the thumbnail.

Default value is 96.

Remarks

Note

Image Uploader Express and Professional restrict a size (width x height) of each created thumbnail to 3 and 5 megapixels respectively. For example, the size of 1500x1500 thumbnail is 2.25 megapixels (1500 pixels x 1500 pixels = 2.25 megapixels), so such thumbnail can be uploaded with Image Uploader Express. See the Comparison of Image Uploader Editions topic for details.

Read about the ThumbnailFitMode property for more detailed information on how this property affects the thumbnail size.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailHeight ASP.NET Property
  • $au.converter.thumbnailHeight JavaScript Property

Manual

  • Resizing and Recompressing


Converter.ThumbnailJpegQuality Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a JPEG quality of the thumbnail.

Syntax

PHP

public function getThumbnailJpegQuality() {
}

public function setThumbnailJpegQuality($value) {
}

Property Value

Type: integer

The JPEG quality of the thumbnail in range from 0 (the worst quality) to 100 (the best quality).

Default value is 100.

Remarks

You can reduce a thumbnail file size by specifying the lower quality.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailJpegQuality ASP.NET Property
  • $au.converter.thumbnailJpegQuality JavaScript Property

Manual

  • Resizing and Recompressing


Converter.ThumbnailKeepColorSpace Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to preserve original color space when creating the thumbnail.

Syntax

PHP

public function getThumbnailKeepColorSpace() {
}

public function setThumbnailKeepColorSpace($value) {
}

Property Value

Type: boolean

If true, the thumbnail is created in the original file color space. Otherwise, the thumbnail is created in RGB color space.

Default value is false.

Remarks

Note

Image Uploader Express and Professional do not keep original color space while creating thumbnails. See the Comparison of Image Uploader Editions topic for details.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailKeepColorSpace ASP.NET Property
  • $au.converter.thumbnailKeepColorSpace JavaScript Property

Manual

  • Resizing and Recompressing


Converter.ThumbnailResizeQuality Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a resize quality of the thumbnail.

Syntax

PHP

public function getThumbnailResizeQuality() {
}

public function setThumbnailResizeQuality($value) {
}

Property Value

Type: string

The resize quality of the thumbnail.

The following values are supported:

Value | Description
Low | Low quality. The image is resized using the nearest-neighbor algorithm.
Medium | Medium quality. The image is resized using the anisotropic algorithm.
High | High quality. The image is resized using the lanczos algorithm.

Default value is "Medium".

Remarks

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailResizeQuality ASP.NET Property
  • $au.converter.thumbnailResizeQuality JavaScript Property

Manual

  • Resizing and Recompressing


Converter.ThumbnailResolution Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an image resolution of the thumbnail.

Syntax

PHP

public function getThumbnailResolution() {
}

public function setThumbnailResolution($value) {
}

Property Value

Type: integer

The image resolution of the thumbnail (in DPI). If 0 value is specified, the original image resolution is used.

Default value is 0.

Remarks

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailResolution ASP.NET Property
  • $au.converter.thumbnailResolution JavaScript Property

Manual

  • Resizing and Recompressing


Converter.ThumbnailWatermark Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a watermark of the thumbnail.

Syntax

PHP

public function getThumbnailWatermark() {
}

public function setThumbnailWatermark($value) {
}

Property Value

Type: string

The watermark of the thumbnail. Watermark string syntax is described in the Remarks section.

If an empty string is specified, watermark will not be drawn on the thumbnail.

Default value is "".

Remarks

The watermark string consists of several variables separated with a semicolon:

variable1=value1;variable2=value2;...

The following variables are supported:

Variable Description
Text

Watermark text. If the text contains semicolon or quotation mark characters enclose it in single (' ') or double (" ") quotes. Additionally, quotation marks (both single ' and double ") inside the text should be escaped with a backslash. For example, to get a Andrew's Photos; Vacation text, set this variable as follows:

Text="Andrew\'s Photos; Vacation"

Note

If both text and an image are used as watermarks, the text will always be rendered over the image.

Default value is an empty string.

When the text watermark is specified, the following parameter also make sense:

  • FillColor
  • Font
  • Size
  • Style
  • Position
  • OffsetX
  • OffsetY
  • Opacity
  • BackgroundColor
  • BackgroundMarginWidth
  • BackgroundMarginHeight
  • OutlineColor
  • OutlineWidth
FillColor

Font color. It has the same syntax as all Image Uploader color properties (i.e. HTML-style #rrggbb RGB value).

Default value is an empty string (the fill is transparent).

Font

Font name. This font should be installed on the client machine. That is why it is highly recommended to use some generic font like Arial, Verdana, etc.

Default value is Arial.

Size

Font size (in pixels).

Default value is 12.

Style

Font style. The following styles are supported:

  • Bold
  • Italic
  • Underlined

You can specify several styles separated with a comma. Example:

Style=Bold,Italic

Default value is an empty string (regular font is used).

ImageUrl

Url to an image that will be used as the watermark.

Note

If both text and an image are used as watermarks, the text will always be rendered over the image.

Default value is an empty string.

When the image watermark is specified, the following parameter also make sense:

  • Width
  • Height
  • Position
  • OffsetX
  • OffsetY
  • Opacity
Width

Width of the image that will be used as the watermark. The image will be resized to the specified dimensions as an ordinary thumbnail, that is, the image can only be downsized, and its proportions are kept.

Default value is an empty string (actual image width is used).

Height

Height of the image that will be used as the watermark. The image will be resized to the specified dimensions as an ordinary thumbnail, that is, the image can only be downsized, and its proportions are kept.

Default value is an empty string (actual image height is used).

Position

Watermark position. It can take one of the following values:

  • TopLeft - watermark will be drawn in the top left corner of an image.
  • TopCenter - watermark will be drawn in the center of the top of an image.
  • TopRight - watermark will be drawn in the right top corner of an image.
  • CenterLeft - watermark will be drawn in the center of the left edge of an image.
  • Center - watermark will be drawn in the center of an image.
  • CenterRight - watermark will be drawn in the center of the right edge of an image.
  • BottomLeft - watermark will be drawn in the bottom left corner of an image.
  • BottomCenter - watermark will be drawn in the center of the bottom of an image.
  • BottomRight - watermark will be drawn in the bottom right corner of an image.

Default value is BottomRight.

OffsetX

Horizontal offset (in pixels) of the watermark relatively the position it is anchored to (according to the Position variable).

Note

If horizontal position is left or center, coordinates direction is left-to-right. If it is right, coordinates direction is flipped to right-to-left.

Default value is 0 (no offset).

OffsetY

Vertical offset (in pixels) of the watermark relatively the position it is anchored to (according to the Position variable).

Note

If vertical position is top or center, coordinates direction is top-to-bottom. If it is bottom, coordinates direction is flipped to bottom-to-top.

Default value is 0 (no offset).

Opacity

Watermark opacity percentage. If 0, the watermark is totally transparent. If 100, the watermark is opaque. Values between 0 and 100 will produce watermark with various level of transparency.

This value works for all elements of watermark. There is no way to configure different opacity for background, text outline and text fill.

Default value is 100.

BackgroundColor

Background color. It has the same syntax as all Image Uploader color properties (i.e. HTML-style #rrggbb RGB value).

Default value is an empty string (the background is transparent).

BackgroundMarginWidth

Width of additional space outside of the watermark filled with background (in pixels).

Default value is 0.

BackgroundMarginHeight

Height of additional space outside of the watermark filled with background (in pixels).

Default value is 0.

OutlineColor

Text outline color. It has the same syntax as all Image Uploader color properties (i.e. HTML-style #rrggbb RGB value).

Default value is an empty string (the outline is transparent).

OutlineWidth

Width of the text outline.

Default value is 1.

Note

The watermark string is case insensitive.

Though you can set both image and text watermarks at the same time, it makes sense to use only one of them. For text watermarks the only required variable is Text. Here is an example of the watermark string which will draw green semi-transparent italic text Aurigma in the bottom left corner of an image:

PHP

$converter->setThumbnailWatermark("Text=Aurigma;Opacity=75;FillColor=#00ff00;Position=BottomLeft;Style=Italic;Size=30");

For image watermarks ImageUrl, Width, and Height are required. Here is an example of semi-transparent logo drawn in the top tight corner of the image:

PHP

$converter->setThumbnailWatermark("ImageUrl=http://localhost/watermark.png;Width=86;Height=63;Position=TopRight;Opacity=50");

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailWatermark ASP.NET Property
  • $au.converter.thumbnailWatermark JavaScript Property

Manual

  • Applying Watermarks


Converter.ThumbnailWidth Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width restriction for the thumbnail.

Syntax

PHP

public function getThumbnailWidth() {
}

public function setThumbnailWidth($value) {
}

Property Value

Type: integer

The width of the thumbnail.

Default value is 96.

Remarks

Note

Image Uploader Express and Professional restrict a size (width x height) of each created thumbnail to 3 and 5 megapixels respectively. For example, the size of 1500x1500 thumbnail is 2.25 megapixels (1500 pixels x 1500 pixels = 2.25 megapixels), so such thumbnail can be uploaded with Image Uploader Express. See the Comparison of Image Uploader Editions topic for details.

Read about the ThumbnailFitMode property for more detailed information on how this property affects the thumbnail size.

This property makes sense only if the Mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailWidth ASP.NET Property
  • $au.converter.thumbnailWidth JavaScript Property

Manual

  • Resizing and Recompressing


DeleteFilesDialog Class

  • Supported browsers: Firefox Google Chrome Safari

This class represents the delete confirmation dialog which appears in non-Internet Explorer browsers when EnableOriginalFilesDeletion is true.

For a list of all members of this class, see DeleteFilesDialog Members.

Syntax

PHP

class DeleteFilesDialog {
}

Remarks

Note

A difference between Image Uploader behavior in Internet Explorer and other supported browsers is the following. When Image Uploader deletes files in Internet Explorer, it moves them in the way specified in the Recycle Bin properties. By default, a standard delete confirmation dialog appears and files are moved to the Recycle Bin if a user clicks Yes. However, if Image Uploader deletes files in any of other supported browsers, the internal delete confirmation dialog appears and files are removed permanently when a user clicks Yes.

If the file cannot be deleted, the DeletingFilesError message appears.

See Also

Reference

  • EnableOriginalFilesDeletion Property
  • DeleteFilesDialog Property
  • Aurigma.ImageUploader.DeleteFilesDialog ASP.NET Class
  • $au.deleteFilesDialog JavaScript Class


DeleteFilesDialog Members

  • Properties
  • Language Filter ( all languages )

The DeleteFilesDialog type exposes the following members.

Properties

 | Name | Description
Public property | Message | Gets or sets a message of the dialog which asks a user to confirm that they really want to delete uploaded files.
Public property | TitleText | Gets or sets a title of the dialog which asks a user to confirm that they really want to delete uploaded files.


DeleteFilesDialog Properties

  • Properties
  • Language Filter ( all languages )

The DeleteFilesDialog type exposes the following properties.

Properties

 | Name | Description
Public property | Message | Gets or sets a message of the dialog which asks a user to confirm that they really want to delete uploaded files.
Public property | TitleText | Gets or sets a title of the dialog which asks a user to confirm that they really want to delete uploaded files.


DeleteFilesDialog.Message Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a message of the dialog which asks a user to confirm that they really want to delete uploaded files.

Syntax

PHP

public function getMessage() {
}

public function setMessage($value) {
}

Property Value

Type: string

The text of the message of the delete confirmation dialog.

Default value is "Are you sure you want to permanently delete uploaded items?".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DeleteFilesDialog.Message ASP.NET Property
  • $au.deleteFilesDialog.message JavaScript Property


DeleteFilesDialog.TitleText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a title of the dialog which asks a user to confirm that they really want to delete uploaded files.

Syntax

PHP

public function getTitleText() {
}

public function setTitleText($value) {
}

Property Value

Type: string

The text of the title of the delete confirmation dialog.

Default value is "Delete File".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DeleteFilesDialog.TitleText ASP.NET Property
  • $au.deleteFilesDialog.titleText JavaScript Property


DescriptionEditor Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the description editor.

For a list of all members of this class, see DescriptionEditor Members.

Syntax

PHP

class DescriptionEditor {
}

See Also

Reference

  • DescriptionEditor Property
  • Aurigma.ImageUploader.DescriptionEditor ASP.NET Class
  • $au.descriptionEditor JavaScript Class

Manual

  • Customizing Appearance


DescriptionEditor Members

  • Properties
  • Language Filter ( all languages )

The DescriptionEditor type exposes the following members.

Properties

 | Name | Description
Public property | CancelHyperlinkText | Gets or sets a caption of the Cancel hyperlink on the dialog displayed when a user clicks the description icon on the pane item surface.
Public property | MaxTextLength | Gets or sets a description length.
Public property | OrEscLabelText | Gets or sets a text of the Or Esc label.
Public property | SaveButtonText | Gets or sets a caption of the Save button on the dialog displayed when a user clicks the description icon on the pane item surface.


DescriptionEditor Properties

  • Properties
  • Language Filter ( all languages )

The DescriptionEditor type exposes the following properties.

Properties

 | Name | Description
Public property | CancelHyperlinkText | Gets or sets a caption of the Cancel hyperlink on the dialog displayed when a user clicks the description icon on the pane item surface.
Public property | MaxTextLength | Gets or sets a description length.
Public property | OrEscLabelText | Gets or sets a text of the Or Esc label.
Public property | SaveButtonText | Gets or sets a caption of the Save button on the dialog displayed when a user clicks the description icon on the pane item surface.


DescriptionEditor.CancelHyperlinkText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel hyperlink on the dialog displayed when a user clicks the description icon on the pane item surface.

Syntax

PHP

public function getCancelHyperlinkText() {
}

public function setCancelHyperlinkText($value) {
}

Property Value

Type: string

The caption of the Cancel hyperlink on the description editor.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DescriptionEditor.CancelHyperlinkText ASP.NET Property
  • $au.descriptionEditor.cancelHyperlinkText JavaScript Property


DescriptionEditor.MaxTextLength Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a description length.

Syntax

PHP

public function getMaxTextLength() {
}

public function setMaxTextLength($value) {
}

Property Value

Type: integer

The maximum allowed number of symbols in user-provided descriptions.

Default value is 512.

See Also

Reference

  • Aurigma.ImageUploader.DescriptionEditor.MaxTextLength ASP.NET Property
  • $au.descriptionEditor.maxTextLength JavaScript Property


DescriptionEditor.OrEscLabelText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text of the Or Esc label.

Syntax

PHP

public function getOrEscLabelText() {
}

public function setOrEscLabelText($value) {
}

Property Value

Type: string

The text of the Or Esc label.

Default value is " (or Esc)".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DescriptionEditor.OrEscLabelText ASP.NET Property
  • $au.descriptionEditor.orEscLabelText JavaScript Property


DescriptionEditor.SaveButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Save button on the dialog displayed when a user clicks the description icon on the pane item surface.

Syntax

PHP

public function getSaveButtonText() {
}

public function setSaveButtonText($value) {
}

Property Value

Type: string

The caption of the Save button on the description editor.

Default value is "Save".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DescriptionEditor.SaveButtonText ASP.NET Property
  • $au.descriptionEditor.saveButtonText JavaScript Property


DetailsViewColumns Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class contains titles of columns displayed in the Details view.

For a list of all members of this class, see DetailsViewColumns Members.

Syntax

PHP

class DetailsViewColumns {
}

See Also

Reference

  • DetailsViewColumns Property
  • Aurigma.ImageUploader.DetailsViewColumns ASP.NET Class
  • $au.detailsViewColumns JavaScript Class

Manual

  • Customizing Appearance


DetailsViewColumns Members

  • Properties
  • Language Filter ( all languages )

The DetailsViewColumns type exposes the following members.

Properties

 | Name | Description
Public property | DimensionsText | Gets or sets a title of the Image dimensions column in the Details view.
Public property | FileNameText | Gets or sets a title of the Name column in the Details view.
Public property | FileSizeText | Gets or sets a title of the Size column in the Details view.
Public property | FileTypeText | Gets or sets a title of the Type column in the Details view.
Public property | InfoText | Gets or sets a title of the Info column in the Details view.
Public property | LastModifiedText | Gets or sets a title of the Date modified column in the Details view.


DetailsViewColumns Properties

  • Properties
  • Language Filter ( all languages )

The DetailsViewColumns type exposes the following properties.

Properties

 | Name | Description
Public property | DimensionsText | Gets or sets a title of the Image dimensions column in the Details view.
Public property | FileNameText | Gets or sets a title of the Name column in the Details view.
Public property | FileSizeText | Gets or sets a title of the Size column in the Details view.
Public property | FileTypeText | Gets or sets a title of the Type column in the Details view.
Public property | InfoText | Gets or sets a title of the Info column in the Details view.
Public property | LastModifiedText | Gets or sets a title of the Date modified column in the Details view.


DetailsViewColumns.DimensionsText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Image dimensions column in the Details view.

Syntax

PHP

public function getDimensionsText() {
}

public function setDimensionsText($value) {
}

Property Value

Type: string

The title of the Image dimensions column in the Details view.

Default value is "Image dimensions".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DetailsViewColumns.DimensionsText ASP.NET Property
  • $au.detailsViewColumns.dimensionsText JavaScript Property


DetailsViewColumns.FileNameText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Name column in the Details view.

Syntax

PHP

public function getFileNameText() {
}

public function setFileNameText($value) {
}

Property Value

Type: string

The title of the Name column in the Details view.

Default value is "Name".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DetailsViewColumns.FileNameText ASP.NET Property
  • $au.detailsViewColumns.fileNameText JavaScript Property


DetailsViewColumns.FileSizeText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Size column in the Details view.

Syntax

PHP

public function getFileSizeText() {
}

public function setFileSizeText($value) {
}

Property Value

Type: string

The title of the Size column in the Details view.

Default value is "Size".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DetailsViewColumns.FileSizeText ASP.NET Property
  • $au.detailsViewColumns.fileSizeText JavaScript Property


DetailsViewColumns.FileTypeText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Type column in the Details view.

Syntax

PHP

public function getFileTypeText() {
}

public function setFileTypeText($value) {
}

Property Value

Type: string

The title of the Type column in the Details view.

Default value is "Type".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DetailsViewColumns.FileTypeText ASP.NET Property
  • $au.detailsViewColumns.fileTypeText JavaScript Property


DetailsViewColumns.InfoText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Info column in the Details view.

Syntax

PHP

public function getInfoText() {
}

public function setInfoText($value) {
}

Property Value

Type: string

The title of the Info column in the Details view.

Default value is "Info".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DetailsViewColumns.InfoText ASP.NET Property
  • $au.detailsViewColumns.infoText JavaScript Property


DetailsViewColumns.LastModifiedText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Date modified column in the Details view.

Syntax

PHP

public function getLastModifiedText() {
}

public function setLastModifiedText($value) {
}

Property Value

Type: string

The title of the Date modified column in the Details view.

Default value is "Date modified".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DetailsViewColumns.LastModifiedText ASP.NET Property
  • $au.detailsViewColumns.lastModifiedText JavaScript Property


FolderPane Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the folder pane.

For a list of all members of this class, see FolderPane Members.

Syntax

PHP

class FolderPane {
}

Remarks

All the properties of this class make sense in ThreePanes layout only.

See Also

Reference

  • FolderPane Property
  • Aurigma.ImageUploader.FolderPane ASP.NET Class
  • $au.folderPane JavaScript Class

Manual

  • Layouts
  • Customizing Appearance


FolderPane Members

  • Properties
  • Language Filter ( all languages )

The FolderPane type exposes the following members.

Properties

 | Name | Description
Public property | FilterClearIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the search box icon.
Public property | FilterHintText | Gets a sets a text of the prompt inside the search box.
Public property | HeaderAllText | Gets a sets a text of the Total files label.
Public property | HeaderAllowedText | Gets a sets a text of the Allowed label.
Public property | Height | Gets or sets a height of the folder pane.
Public property | PreviewSize | Gets or sets a size of the preview area in Thumbnails view.
Public property | ShowAllowedItemsOnly | Gets or sets value indicating whether to display denied files in the folder pane.
Public property | SortMode | Gets or sets a sort mode of the folder pane.
Public property | ViewMode | Gets or sets a view mode for the folder pane.


FolderPane Properties

  • Properties
  • Language Filter ( all languages )

The FolderPane type exposes the following properties.

Properties

 | Name | Description
Public property | FilterClearIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the search box icon.
Public property | FilterHintText | Gets a sets a text of the prompt inside the search box.
Public property | HeaderAllText | Gets a sets a text of the Total files label.
Public property | HeaderAllowedText | Gets a sets a text of the Allowed label.
Public property | Height | Gets or sets a height of the folder pane.
Public property | PreviewSize | Gets or sets a size of the preview area in Thumbnails view.
Public property | ShowAllowedItemsOnly | Gets or sets value indicating whether to display denied files in the folder pane.
Public property | SortMode | Gets or sets a sort mode of the folder pane.
Public property | ViewMode | Gets or sets a view mode for the folder pane.


FolderPane.FilterClearIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the search box icon.

Syntax

PHP

public function getFilterClearIconImageFormat() {
}

public function setFilterClearIconImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the search box icon.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.FilterClearIconImageFormat ASP.NET Property
  • $au.folderPane.filterClearIconImageFormat JavaScript Property


FolderPane.FilterHintText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a sets a text of the prompt inside the search box.

Syntax

PHP

public function getFilterHintText() {
}

public function setFilterHintText($value) {
}

Property Value

Type: string

The text of the prompt inside the search box.

Default value is "Search ".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.FilterHintText ASP.NET Property
  • $au.folderPane.filterHintText JavaScript Property


FolderPane.HeaderAllText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a sets a text of the Total files label.

Syntax

PHP

public function getHeaderAllText() {
}

public function setHeaderAllText($value) {
}

Property Value

Type: string

The text of the Total files label. It can contain the following placeholder:

[count]
replaced by the total number of files.

Default value is "Total files: [count], ".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.HeaderAllText ASP.NET Property
  • $au.folderPane.headerAllText JavaScript Property


FolderPane.HeaderAllowedText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a sets a text of the Allowed label.

Syntax

PHP

public function getHeaderAllowedText() {
}

public function setHeaderAllowedText($value) {
}

Property Value

Type: string

The text of the Allowed label. It can contain the following placeholder:

[count]
replaced by the number of allowed files.

Default value is "allowed: [count]".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.HeaderAllowedText ASP.NET Property
  • $au.folderPane.headerAllowedText JavaScript Property


FolderPane.Height Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of the folder pane.

Syntax

PHP

public function getHeight() {
}

public function setHeight($value) {
}

Property Value

Type: integer

The height of the folder pane.

Default value is 300.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.Height ASP.NET Property
  • $au.folderPane.height JavaScript Property


FolderPane.PreviewSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a size of the preview area in Thumbnails view.

Syntax

PHP

public function getPreviewSize() {
}

public function setPreviewSize($value) {
}

Property Value

Type: integer

The size of the preview area (in pixels). In other words, this property specifies size of square the thumbnail is inscribed in.

Default value is 96.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.PreviewSize ASP.NET Property
  • $au.folderPane.previewSize JavaScript Property


FolderPane.ShowAllowedItemsOnly Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets value indicating whether to display denied files in the folder pane.

Syntax

PHP

public function getShowAllowedItemsOnly() {
}

public function setShowAllowedItemsOnly($value) {
}

Property Value

Type: boolean

If true, the folder pane shows only those files which meet the specified Restrictions; otherwise, all the files are visible.

Default value is true.

Remarks

This property makes sense if at least one limitation is specified via the Restrictions properties.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.ShowAllowedItemsOnly ASP.NET Property
  • $au.folderPane.showAllowedItemsOnly JavaScript Property

Manual

  • Configuring Restriction Rules for Files


FolderPane.SortMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a sort mode of the folder pane.

Syntax

PHP

public function getSortMode() {
}

public function setSortMode($value) {
}

Property Value

Type: string

The sort mode of the folder pane.

The following values are supported:

Value | Description
Unsorted | Items are unsorted.
Name | Items are sorted by name alphabetically.
Size | Items are sorted by file size.
Type | Items are sorted by file type alphabetically.
Modified | Items are sorted by the date of last modification.
Path | Items are sorted by full path.
Dimensions | Items are sorted by image dimensions.
Note

The sort mode cannot be set to Unsorted value manually.

Default value is "Name".

Remarks

Sort mode is automatically reset to Unsorted when new items are added or re-arranged via drag-n-drop.

Note

If you set the same value twice, the sort order will toggle between ascending and descending and vice versa.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.SortMode ASP.NET Property
  • $au.folderPane.sortMode JavaScript Property


FolderPane.ViewMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a view mode for the folder pane.

Syntax

PHP

public function getViewMode() {
}

public function setViewMode($value) {
}

Property Value

Type: string

The view mode for the folder pane.

The following values are supported:

Value | Description
Thumbnails | Images are displayed as thumbnails, non-images are displayed as icons. It is possible to attach a description to each file. If a file is recognized as image, it can be cropped and rotated.
Tiles | Each file appears as a thumbnail (or icon for non-image files), with a file name and details (file type, last modification date, and file size) on the right. It is possible to attach a description to each file. If a file is recognized as image, it can be cropped and rotated.
Details | All the files are displayed as a detailed list (icon + filename + info + size + last modification date + type + image dimensions).
List | Files are displayed as small thumbnails (or icons for non-image files) with names on the right.

Default value is "Thumbnails".

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.ViewMode ASP.NET Property
  • $au.folderPane.viewMode JavaScript Property

Manual

  • View Modes


FontFormat Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class specifies font settings.

For a list of all members of this class, see FontFormat Members.

Syntax

PHP

class FontFormat {
}

See Also

Reference

  • PaneFont Property
  • TitleFont Property
  • Aurigma.ImageUploader.FontFormat ASP.NET Class


FontFormat Members

  • Properties
  • Language Filter ( all languages )

The FontFormat type exposes the following members.

Properties

 | Name | Description
Public property | Bold | Gets or sets a value specifying whether the font is bold.
Public property | Italic | Gets or sets a value specifying whether the font is italic.
Public property | Name | Gets or sets a font name.
Public property | Size | Gets or sets a font size (in pixels).


FontFormat Properties

  • Properties
  • Language Filter ( all languages )

The FontFormat type exposes the following properties.

Properties

 | Name | Description
Public property | Bold | Gets or sets a value specifying whether the font is bold.
Public property | Italic | Gets or sets a value specifying whether the font is italic.
Public property | Name | Gets or sets a font name.
Public property | Size | Gets or sets a font size (in pixels).


FontFormat.Bold Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value specifying whether the font is bold.

Syntax

PHP

public function getBold() {
}

public function setBold($value) {
}

Property Value

Type: boolean

If true, the font is bold.

Default value is false.

See Also

Reference

  • Aurigma.ImageUploader.FontFormat.Bold ASP.NET Property


FontFormat.Italic Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value specifying whether the font is italic.

Syntax

PHP

public function getItalic() {
}

public function setItalic($value) {
}

Property Value

Type: boolean

If true, the font is italic.

Default value is false.

See Also

Reference

  • Aurigma.ImageUploader.FontFormat.Italic ASP.NET Property


FontFormat.Name Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a font name.

Syntax

PHP

public function getName() {
}

public function setName($value) {
}

Property Value

Type: string

The font name.

Default value is "".

Remarks

The font specified with this property should be installed on the client machine, so it is recommended to use only standard font names. When this property is not specified, the system default font is used.

See Also

Reference

  • Aurigma.ImageUploader.FontFormat.Name ASP.NET Property


FontFormat.Size Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a font size (in pixels).

Syntax

PHP

public function getSize() {
}

public function setSize($value) {
}

Property Value

Type: integer

The font size. If this property is 0, the system default font size is used.

Default value is 0.

See Also

Reference

  • Aurigma.ImageUploader.FontFormat.Size ASP.NET Property


ImageEditor Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the image editor.

For a list of all members of this class, see ImageEditor Members.

Syntax

PHP

class ImageEditor {
}

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor ASP.NET Class
  • $au.imageEditor JavaScript Class

Manual

  • Image Editor
  • Customizing Appearance


ImageEditor Members

  • Properties
  • Language Filter ( all languages )

The ImageEditor type exposes the following members.

Properties

 | Name | Description
Public property | CancelButtonImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Cancel button.
Public property | CancelButtonText | Gets or sets a caption of the Cancel button.
Public property | CancelCropButtonImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Cancel Crop button.
Public property | CancelCropButtonText | Gets or sets a caption of the Cancel crop button.
Public property | CropButtonImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Crop button.
Public property | CropButtonText | Gets or sets a caption of the Crop button.
Public property | CropMinSize | Gets or sets minimum width and height of the crop rectangle (in pixels).
Public property | CropRatio | Gets or sets an aspect ratio of the crop rectangle.
Public property | DescriptionHintText | Gets or sets a text of the prompt which is displayed when no description is entered.
Public property | EnableCrop | Gets or sets a value indicating whether it is possible to crop an image in the image editor.
Public property | RotateButtonImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Rotate button.
Public property | RotateButtonText | Gets or sets a caption of the Rotate button.
Public property | SaveButtonImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Save and close button.
Public property | SaveButtonText | Gets or sets a caption of the Save and close button.


ImageEditor Properties

  • Properties
  • Language Filter ( all languages )

The ImageEditor type exposes the following properties.

Properties

 | Name | Description
Public property | CancelButtonImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Cancel button.
Public property | CancelButtonText | Gets or sets a caption of the Cancel button.
Public property | CancelCropButtonImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Cancel Crop button.
Public property | CancelCropButtonText | Gets or sets a caption of the Cancel crop button.
Public property | CropButtonImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Crop button.
Public property | CropButtonText | Gets or sets a caption of the Crop button.
Public property | CropMinSize | Gets or sets minimum width and height of the crop rectangle (in pixels).
Public property | CropRatio | Gets or sets an aspect ratio of the crop rectangle.
Public property | DescriptionHintText | Gets or sets a text of the prompt which is displayed when no description is entered.
Public property | EnableCrop | Gets or sets a value indicating whether it is possible to crop an image in the image editor.
Public property | RotateButtonImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Rotate button.
Public property | RotateButtonText | Gets or sets a caption of the Rotate button.
Public property | SaveButtonImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Save and close button.
Public property | SaveButtonText | Gets or sets a caption of the Save and close button.


ImageEditor.CancelButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Cancel button.

Syntax

PHP

public function getCancelButtonImageFormat() {
}

public function setCancelButtonImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the Cancel button.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CancelButtonImageFormat ASP.NET Property
  • $au.imageEditor.cancelButtonImageFormat JavaScript Property


ImageEditor.CancelButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel button.

Syntax

PHP

public function getCancelButtonText() {
}

public function setCancelButtonText($value) {
}

Property Value

Type: string

The caption of the Cancel button.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CancelButtonText ASP.NET Property
  • $au.imageEditor.cancelButtonText JavaScript Property


ImageEditor.CancelCropButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Cancel Crop button.

Syntax

PHP

public function getCancelCropButtonImageFormat() {
}

public function setCancelCropButtonImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the Cancel crop button.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CancelCropButtonImageFormat ASP.NET Property
  • $au.imageEditor.cancelCropButtonImageFormat JavaScript Property


ImageEditor.CancelCropButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel crop button.

Syntax

PHP

public function getCancelCropButtonText() {
}

public function setCancelCropButtonText($value) {
}

Property Value

Type: string

The caption of the Cancel crop button.

Default value is "Cancel crop".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CancelCropButtonText ASP.NET Property
  • $au.imageEditor.cancelCropButtonText JavaScript Property


ImageEditor.CropButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Crop button.

Syntax

PHP

public function getCropButtonImageFormat() {
}

public function setCropButtonImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the Crop button.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CropButtonImageFormat ASP.NET Property
  • $au.imageEditor.cropButtonImageFormat JavaScript Property


ImageEditor.CropButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Crop button.

Syntax

PHP

public function getCropButtonText() {
}

public function setCropButtonText($value) {
}

Property Value

Type: string

The caption of the Crop button.

Default value is "Crop".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CropButtonText ASP.NET Property
  • $au.imageEditor.cropButtonText JavaScript Property


ImageEditor.CropMinSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets minimum width and height of the crop rectangle (in pixels).

Syntax

PHP

public function getCropMinSize() {
}

public function setCropMinSize($value) {
}

Property Value

Type: integer

The minimum width and height of the crop rectangle (in pixels).

Default value is 50.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CropMinSize ASP.NET Property
  • $au.imageEditor.cropMinSize JavaScript Property


ImageEditor.CropRatio Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an aspect ratio of the crop rectangle.

Syntax

PHP

public function getCropRatio() {
}

public function setCropRatio($value) {
}

Property Value

Type: number

The aspect ratio of the crop rectangle. If 0 no aspect ratio is given.

Default value is 0.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CropRatio ASP.NET Property
  • $au.imageEditor.cropRatio JavaScript Property


ImageEditor.DescriptionHintText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text of the prompt which is displayed when no description is entered.

Syntax

PHP

public function getDescriptionHintText() {
}

public function setDescriptionHintText($value) {
}

Property Value

Type: string

The text of the Type description here prompt.

Default value is "Type description here...".

Remarks

Note

This property also specifies the same prompt in the description editor.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.DescriptionHintText ASP.NET Property
  • $au.imageEditor.descriptionHintText JavaScript Property


ImageEditor.EnableCrop Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is possible to crop an image in the image editor.

Syntax

PHP

public function getEnableCrop() {
}

public function setEnableCrop($value) {
}

Property Value

Type: boolean

If true, the crop functionality is supported in the image editor; otherwise, images can only be previewed, rotated, and/or provided with a description.

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.EnableCrop ASP.NET Property
  • $au.imageEditor.enableCrop JavaScript Property


ImageEditor.RotateButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Rotate button.

Syntax

PHP

public function getRotateButtonImageFormat() {
}

public function setRotateButtonImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the Rotate button.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.RotateButtonImageFormat ASP.NET Property
  • $au.imageEditor.rotateButtonImageFormat JavaScript Property


ImageEditor.RotateButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Rotate button.

Syntax

PHP

public function getRotateButtonText() {
}

public function setRotateButtonText($value) {
}

Property Value

Type: string

The caption of the Rotate button.

Default value is "Rotate".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.RotateButtonText ASP.NET Property
  • $au.imageEditor.rotateButtonText JavaScript Property


ImageEditor.SaveButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Save and close button.

Syntax

PHP

public function getSaveButtonImageFormat() {
}

public function setSaveButtonImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the Save and close button.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.SaveButtonImageFormat ASP.NET Property
  • $au.imageEditor.saveButtonImageFormat JavaScript Property


ImageEditor.SaveButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Save and close button.

Syntax

PHP

public function getSaveButtonText() {
}

public function setSaveButtonText($value) {
}

Property Value

Type: string

The caption of the Save and close button.

Default value is "Save and close".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.SaveButtonText ASP.NET Property
  • $au.imageEditor.saveButtonText JavaScript Property


ImageFormat Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class specifies different states of Image Uploader buttons and icons.

For a list of all members of this class, see ImageFormat Members.

Syntax

PHP

class ImageFormat {
}

See Also

Reference

  • Aurigma.ImageUploader.ImageFormat ASP.NET Class


ImageFormat Members

  • Properties
  • Language Filter ( all languages )

The ImageFormat type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of the button or icon.
Public property | Height | Gets or sets a height of the button or icon.
Public property | UrlDisabled | Gets or sets a URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Public property | UrlHover | Gets or sets a URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
Public property | UrlHoverFocused | Gets or sets a URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
Public property | UrlNormal | Gets or sets a URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus.
Public property | UrlNormalFocused | Gets or sets a URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
Public property | UrlPressed | Gets or sets a URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
Public property | Width | Gets or sets a width of the button or icon.


ImageFormat Properties

  • Properties
  • Language Filter ( all languages )

The ImageFormat type exposes the following properties.

Properties

 | Name | Description
Public property | BackgroundColor | Gets or sets a background color of the button or icon.
Public property | Height | Gets or sets a height of the button or icon.
Public property | UrlDisabled | Gets or sets a URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Public property | UrlHover | Gets or sets a URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
Public property | UrlHoverFocused | Gets or sets a URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
Public property | UrlNormal | Gets or sets a URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus.
Public property | UrlNormalFocused | Gets or sets a URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
Public property | UrlPressed | Gets or sets a URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
Public property | Width | Gets or sets a width of the button or icon.


ImageFormat.BackgroundColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of the button or icon.

Syntax

PHP

public function getBackgroundColor() {
}

public function setBackgroundColor($value) {
}

Property Value

Type: string

The background color of button or icon.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Remarks

The rectangle specified with Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the BackgroundColor property value is used.

See Also

Reference

  • Aurigma.ImageUploader.ImageFormat.BackgroundColor ASP.NET Property


ImageFormat.Height Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of the button or icon.

Syntax

PHP

public function getHeight() {
}

public function setHeight($value) {
}

Property Value

Type: integer

The height of a button or icon (in pixels).

Default value is 0.

See Also

Reference

  • Aurigma.ImageUploader.ImageFormat.Height ASP.NET Property


ImageFormat.UrlDisabled Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.

Syntax

PHP

public function getUrlDisabled() {
}

public function setUrlDisabled($value) {
}

Property Value

Type: string

The URL to the image which represents a button/icon when it is disabled.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.ImageFormat.UrlDisabled ASP.NET Property


ImageFormat.UrlHover Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.

Syntax

PHP

public function getUrlHover() {
}

public function setUrlHover($value) {
}

Property Value

Type: string

The URL to the image which represents a button/icon when a mouse button is hovered over it.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.ImageFormat.UrlHover ASP.NET Property


ImageFormat.UrlHoverFocused Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.

Syntax

PHP

public function getUrlHoverFocused() {
}

public function setUrlHoverFocused($value) {
}

Property Value

Type: string

The URL to the image which represents a button/icon when a mouse button is hovered over it and the button/icon is in focus.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.ImageFormat.UrlHoverFocused ASP.NET Property


ImageFormat.UrlNormal Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus.

Syntax

PHP

public function getUrlNormal() {
}

public function setUrlNormal($value) {
}

Property Value

Type: string

The URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.ImageFormat.UrlNormal ASP.NET Property


ImageFormat.UrlNormalFocused Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.

Syntax

PHP

public function getUrlNormalFocused() {
}

public function setUrlNormalFocused($value) {
}

Property Value

Type: string

The URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button/icon is in focus.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.ImageFormat.UrlNormalFocused ASP.NET Property


ImageFormat.UrlPressed Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.

Syntax

PHP

public function getUrlPressed() {
}

public function setUrlPressed($value) {
}

Property Value

Type: string

The URL to the image which represents a button/icon when it is pressed.

Default value is "".

Remarks

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.ImageFormat.UrlPressed ASP.NET Property


ImageFormat.Width Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of the button or icon.

Syntax

PHP

public function getWidth() {
}

public function setWidth($value) {
}

Property Value

Type: integer

The width of a button or icon (in pixels).

Default value is 0.

See Also

Reference

  • Aurigma.ImageUploader.ImageFormat.Width ASP.NET Property


InformationBar Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the information bar.

For a list of all members of this class, see InformationBar Members.

Syntax

PHP

class InformationBar {
}

See Also

Reference

  • Aurigma.ImageUploader.InformationBar ASP.NET Class
  • $au.informationBar JavaScript Class

Manual

  • Customizing Appearance


InformationBar Members

  • Properties
  • Language Filter ( all languages )

The InformationBar type exposes the following members.

Properties

 | Name | Description
Public property | CloseIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the information bar icon.
Public property | ErrorColor | Gets or sets a color of the information bar when it displays an error message.
Public property | MessageColor | Gets or sets a color of the information bar when it displays an information massage message.
Public property | WarningColor | Gets or sets a color of the information bar when it displays a warning message.


InformationBar Properties

  • Properties
  • Language Filter ( all languages )

The InformationBar type exposes the following properties.

Properties

 | Name | Description
Public property | CloseIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the information bar icon.
Public property | ErrorColor | Gets or sets a color of the information bar when it displays an error message.
Public property | MessageColor | Gets or sets a color of the information bar when it displays an information massage message.
Public property | WarningColor | Gets or sets a color of the information bar when it displays a warning message.


InformationBar.CloseIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the information bar icon.

Syntax

PHP

public function getCloseIconImageFormat() {
}

public function setCloseIconImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the information bar icon.

See Also

Reference

  • Aurigma.ImageUploader.InformationBar.CloseIconImageFormat ASP.NET Property
  • $au.informationBar.closeIconImageFormat JavaScript Property


InformationBar.ErrorColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the information bar when it displays an error message.

Syntax

PHP

public function getErrorColor() {
}

public function setErrorColor($value) {
}

Property Value

Type: string

The color of the error message. Such messages appear when upload in broken.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#f14b54".

See Also

Reference

  • Aurigma.ImageUploader.InformationBar.ErrorColor ASP.NET Property
  • $au.informationBar.errorColor JavaScript Property


InformationBar.MessageColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the information bar when it displays an information massage message.

Syntax

PHP

public function getMessageColor() {
}

public function setMessageColor($value) {
}

Property Value

Type: string

The color of the information message. Such message appears when upload is completed successfully.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#a3ffa8".

See Also

Reference

  • Aurigma.ImageUploader.InformationBar.MessageColor ASP.NET Property
  • $au.informationBar.messageColor JavaScript Property


InformationBar.WarningColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the information bar when it displays a warning message.

Syntax

PHP

public function getWarningColor() {
}

public function setWarningColor($value) {
}

Property Value

Type: string

The color of the warning message. Such messages are displayed when a file does not meet the specified restrictions.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#fde2a6".

See Also

Reference

  • Aurigma.ImageUploader.InformationBar.WarningColor ASP.NET Property
  • $au.informationBar.warningColor JavaScript Property


InstallationProgress Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class allows displaying special screens instead of Image Uploader during the downloading and installation phases.

For a list of all members of this class, see InstallationProgress Members.

Syntax

PHP

class InstallationProgress {
}

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress ASP.NET Class
  • $au.installationProgress JavaScript Class

Manual

  • Using Image Uploader Installation Progress


InstallationProgress Members

  • Properties
  • Language Filter ( all languages )

The InstallationProgress type exposes the following members.

Constructors

 | Name | Description
Public method | InstallationProgress(Uploader) | Creates and initializes an instance of the InstallationProgress class.

Properties

 | Name | Description
Public property | AltInstallerHtml | Sets an HTML-marked text appended to installation instructions and saying how to install Image Uploader in alternative way (e.g. use a standalone installer).
Public property | BeforeIE6XPSP2InstructionsHtml | Sets installation instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.
Public property | BeforeIE6XPSP2ProgressHtml | Set downloading instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.
Public property | CommonHtml | Sets an HTML-marked description of Image Uploader displayed on the both stages (downloading and installation).
Public property | IE6XPSP2InstructionsHtml | Sets installation instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.
Public property | IE6XPSP2ProgressHtml | Sets downloading instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.
Public property | IE7InstructionsHtml | Sets installation instructions for Internet Explorer 7.
Public property | IE7ProgressHtml | Sets downloading instructions for Internet Explorer 7.
Public property | IE8InstructionsHtml | Sets installation instructions for Internet Explorer 8.
Public property | IE8ProgressHtml | Sets downloading instructions for Internet Explorer 8.
Public property | InstallJavaHtml | Sets installation instructions for non-Internet Explorer browsers.
Public property | InstructionsCssClass | Sets a CSS class name to apply it to the installation screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
Public property | MacInstallJavaHtml | Sets installation instructions for Mac browsers.
Public property | ProgressCssClass | Sets a CSS class name to apply it to the downloading screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
Public property | ProgressHtml | Sets a text saying that the downloading of Image Uploader is in progress.
Public property | ProgressImageUrl | Sets a URL to a custom image which replaces a default wait indicator.
Public property | ShowDownloadingScreen | Sets a value indicating whether the downloading screen should be displayed.
Public property | ShowInstallationScreen | Sets a value indicating whether the installation screen should be displayed.
Public property | UpdateInstructions | Sets common instructions on how to update Image Uploader control.


InstallationProgress(Uploader) Constructor

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the InstallationProgress class.

Syntax

PHP

public function InstallationProgress($Uploader) {
}

Parameters

Uploader

Type: Uploader

The Uploader object to create this InstallationProgress for.

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress ASP.NET Constructor
  • $au.installationProgress(uploader) JavaScript Constructor


InstallationProgress Properties

  • Properties
  • Language Filter ( all languages )

The InstallationProgress type exposes the following properties.

Properties

 | Name | Description
Public property | AltInstallerHtml | Sets an HTML-marked text appended to installation instructions and saying how to install Image Uploader in alternative way (e.g. use a standalone installer).
Public property | BeforeIE6XPSP2InstructionsHtml | Sets installation instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.
Public property | BeforeIE6XPSP2ProgressHtml | Set downloading instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.
Public property | CommonHtml | Sets an HTML-marked description of Image Uploader displayed on the both stages (downloading and installation).
Public property | IE6XPSP2InstructionsHtml | Sets installation instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.
Public property | IE6XPSP2ProgressHtml | Sets downloading instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.
Public property | IE7InstructionsHtml | Sets installation instructions for Internet Explorer 7.
Public property | IE7ProgressHtml | Sets downloading instructions for Internet Explorer 7.
Public property | IE8InstructionsHtml | Sets installation instructions for Internet Explorer 8.
Public property | IE8ProgressHtml | Sets downloading instructions for Internet Explorer 8.
Public property | InstallJavaHtml | Sets installation instructions for non-Internet Explorer browsers.
Public property | InstructionsCssClass | Sets a CSS class name to apply it to the installation screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
Public property | MacInstallJavaHtml | Sets installation instructions for Mac browsers.
Public property | ProgressCssClass | Sets a CSS class name to apply it to the downloading screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
Public property | ProgressHtml | Sets a text saying that the downloading of Image Uploader is in progress.
Public property | ProgressImageUrl | Sets a URL to a custom image which replaces a default wait indicator.
Public property | ShowDownloadingScreen | Sets a value indicating whether the downloading screen should be displayed.
Public property | ShowInstallationScreen | Sets a value indicating whether the installation screen should be displayed.
Public property | UpdateInstructions | Sets common instructions on how to update Image Uploader control.


InstallationProgress.AltInstallerHtml Property

  • Supported browsers: Internet Explorer

Sets an HTML-marked text appended to installation instructions and saying how to install Image Uploader in alternative way (e.g. use a standalone installer).

Syntax

PHP

public function getAltInstallerHtml() {
}

public function setAltInstallerHtml($value) {
}

Property Value

Type: string

The instructions on how to install Image Uploader in alternative way.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.AltInstallerHtml ASP.NET Property
  • $au.installationProgress.altInstallerHtml JavaScript Property


InstallationProgress.BeforeIE6XPSP2InstructionsHtml Property

  • Supported browsers: Internet Explorer

Sets installation instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.

Syntax

PHP

public function getBeforeIE6XPSP2InstructionsHtml() {
}

public function setBeforeIE6XPSP2InstructionsHtml($value) {
}

Property Value

Type: string

The installation instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.

Default value is "<p>To install Image Uploader, please reload the page and click the <strong>Yes</strong> button when you see the control installation dialog. If you don't see installation dialog, please check your security settings.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.BeforeIE6XPSP2InstructionsHtml ASP.NET Property
  • $au.installationProgress.beforeIE6XPSP2InstructionsHtml JavaScript Property


InstallationProgress.BeforeIE6XPSP2ProgressHtml Property

  • Supported browsers: Internet Explorer

Set downloading instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.

Syntax

PHP

public function getBeforeIE6XPSP2ProgressHtml() {
}

public function setBeforeIE6XPSP2ProgressHtml($value) {
}

Property Value

Type: string

The downloading instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.

Default value is "<p>To install Image Uploader, please wait until the control will be loaded and click the <strong>Yes</strong> button when you see the installation dialog.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.BeforeIE6XPSP2ProgressHtml ASP.NET Property
  • $au.installationProgress.beforeIE6XPSP2ProgressHtml JavaScript Property


InstallationProgress.CommonHtml Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets an HTML-marked description of Image Uploader displayed on the both stages (downloading and installation).

Syntax

PHP

public function getCommonHtml() {
}

public function setCommonHtml($value) {
}

Property Value

Type: string

The description of Image Uploader.

Default value is "<p>Aurigma Image Uploader control is necessary to upload your files quickly and easily. You will be able to select multiple images in user-friendly interface instead of clumsy input fields with <strong>Browse</strong> button.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.CommonHtml ASP.NET Property
  • $au.installationProgress.commonHtml JavaScript Property


InstallationProgress.IE6XPSP2InstructionsHtml Property

  • Supported browsers: Internet Explorer

Sets installation instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.

Syntax

PHP

public function getIE6XPSP2InstructionsHtml() {
}

public function setIE6XPSP2InstructionsHtml($value) {
}

Property Value

Type: string

The installation instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.

Default value is "<p>To install Image Uploader, please click on the <strong>Information Bar</strong> and select <strong>Install ActiveX Control</strong> from the dropdown menu. After page reload click <strong>Install</strong> when you see the control installation dialog. If you don't see Information Bar, please try to reload the page and/or check your security settings.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.IE6XPSP2InstructionsHtml ASP.NET Property
  • $au.installationProgress.IE6XPSP2InstructionsHtml JavaScript Property


InstallationProgress.IE6XPSP2ProgressHtml Property

  • Supported browsers: Internet Explorer

Sets downloading instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.

Syntax

PHP

public function getIE6XPSP2ProgressHtml() {
}

public function setIE6XPSP2ProgressHtml($value) {
}

Property Value

Type: string

The downloading instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.

Default value is "<p>Please wait until the control will be loaded.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.IE6XPSP2ProgressHtml ASP.NET Property
  • $au.installationProgress.IE6XPSP2ProgressHtml JavaScript Property


InstallationProgress.IE7InstructionsHtml Property

  • Supported browsers: Internet Explorer

Sets installation instructions for Internet Explorer 7.

Syntax

PHP

public function getIE7InstructionsHtml() {
}

public function setIE7InstructionsHtml($value) {
}

Property Value

Type: string

The installation instructions for Internet Explorer 7.

Default value is "<p>To install Image Uploader, please click on the <strong>Information Bar</strong> and select <strong>Install ActiveX Control</strong> or <strong>Run ActiveX Control</strong> from the dropdown menu.</p> <p>Then either click <strong>Run</strong> or after the page reload click <strong>Install</strong> when you see the control installation dialog. If you don't see Information Bar, please try to reload the page and/or check your security settings.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.IE7InstructionsHtml ASP.NET Property
  • $au.installationProgress.IE7InstructionsHtml JavaScript Property


InstallationProgress.IE7ProgressHtml Property

  • Supported browsers: Internet Explorer

Sets downloading instructions for Internet Explorer 7.

Syntax

PHP

public function getIE7ProgressHtml() {
}

public function setIE7ProgressHtml($value) {
}

Property Value

Type: string

The downloading instructions for Internet Explorer 7.

Default value is "<p>Please wait until the control will be loaded.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.IE7ProgressHtml ASP.NET Property
  • $au.installationProgress.IE7ProgressHtml JavaScript Property


InstallationProgress.IE8InstructionsHtml Property

  • Supported browsers: Internet Explorer

Sets installation instructions for Internet Explorer 8.

Syntax

PHP

public function getIE8InstructionsHtml() {
}

public function setIE8InstructionsHtml($value) {
}

Property Value

Type: string

The installation instructions for Internet Explorer 8.

Default value is "<p>To install Image Uploader, please click on the <strong>Information Bar</strong> and select <strong>Install This Add-on</strong> or <strong>Run Add-on</strong> from the dropdown menu.</p> <p>Then either click <strong>Run</strong> or after the page reload click <strong>Install</strong> when you see the control installation dialog. If you don't see Information Bar, please try to reload the page and/or check your security settings.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.IE8InstructionsHtml ASP.NET Property
  • $au.installationProgress.IE8InstructionsHtml JavaScript Property


InstallationProgress.IE8ProgressHtml Property

  • Supported browsers: Internet Explorer

Sets downloading instructions for Internet Explorer 8.

Syntax

PHP

public function getIE8ProgressHtml() {
}

public function setIE8ProgressHtml($value) {
}

Property Value

Type: string

The downloading instructions for Internet Explorer 8.

Default value is "<p>Please wait until the control will be loaded.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.IE8ProgressHtml ASP.NET Property
  • $au.installationProgress.IE8ProgressHtml JavaScript Property


InstallationProgress.InstallJavaHtml Property

  • Supported browsers: Firefox Google Chrome Safari

Sets installation instructions for non-Internet Explorer browsers.

Syntax

PHP

public function getInstallJavaHtml() {
}

public function setInstallJavaHtml($value) {
}

Property Value

Type: string

Sets installation instructions for non-Internet Explorer browsers.

Default value is "<p>Please <a href=\"http://www.java.com/getjava/\">download</a> and install Java.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.InstallJavaHtml ASP.NET Property
  • $au.installationProgress.installJavaHtml JavaScript Property


InstallationProgress.InstructionsCssClass Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a CSS class name to apply it to the installation screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.

Syntax

PHP

public function getInstructionsCssClass() {
}

public function setInstructionsCssClass($value) {
}

Property Value

Type: string

The CSS class name to apply it to the installation screen.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.InstructionsCssClass ASP.NET Property
  • $au.installationProgress.instructionsCssClass JavaScript Property


InstallationProgress.MacInstallJavaHtml Property

  • Supported browsers: Firefox Google Chrome Safari

Sets installation instructions for Mac browsers.

Syntax

PHP

public function getMacInstallJavaHtml() {
}

public function setMacInstallJavaHtml($value) {
}

Property Value

Type: string

The installation instructions for Mac browsers.

Default value is "<p>Use the <a href=\"http://support.apple.com/kb/HT1338\">Software Update</a> feature (available on the Apple menu) to check that you have the most up-to-date version of Java for your Mac.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.MacInstallJavaHtml ASP.NET Property
  • $au.installationProgress.macInstallJavaHtml JavaScript Property


InstallationProgress.ProgressCssClass Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a CSS class name to apply it to the downloading screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.

Syntax

PHP

public function getProgressCssClass() {
}

public function setProgressCssClass($value) {
}

Property Value

Type: string

The CSS class name to apply it to the downloading screen.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.ProgressCssClass ASP.NET Property
  • $au.installationProgress.progressCssClass JavaScript Property


InstallationProgress.ProgressHtml Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a text saying that the downloading of Image Uploader is in progress.

Syntax

PHP

public function getProgressHtml() {
}

public function setProgressHtml($value) {
}

Property Value

Type: string

The text saying that the downloading of Image Uploader is in progress.

The value of this property can contain {0} placeholder. Before displaying the downloading screen, this placeholder is replaced with image URL defined in the ProgressImageUrl property. It allows you to customize images without changing HTML-marked text.

Default value is "<p><img src=\"{0}\" /><br /> Loading Aurigma Image Uploader...</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.ProgressHtml ASP.NET Property
  • $au.installationProgress.progressHtml JavaScript Property


InstallationProgress.ProgressImageUrl Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a URL to a custom image which replaces a default wait indicator.

Syntax

PHP

public function getProgressImageUrl() {
}

public function setProgressImageUrl($value) {
}

Property Value

Type: string

The URL to a custom image which replaces a default wait indicator.

Default value is "Scripts/InstallationProgress.gif".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.ProgressImageUrl ASP.NET Property
  • $au.installationProgress.progressImageUrl JavaScript Property


InstallationProgress.ShowDownloadingScreen Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a value indicating whether the downloading screen should be displayed.

Syntax

PHP

public function getShowDownloadingScreen() {
}

public function setShowDownloadingScreen($value) {
}

Property Value

Type: boolean

If true

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.ShowDownloadingScreen ASP.NET Property
  • $au.installationProgress.showDownloadingScreen JavaScript Property


InstallationProgress.ShowInstallationScreen Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a value indicating whether the installation screen should be displayed.

Syntax

PHP

public function getShowInstallationScreen() {
}

public function setShowInstallationScreen($value) {
}

Property Value

Type: booleab

If true

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.ShowInstallationScreen ASP.NET Property
  • $au.installationProgress.showInstallationScreen JavaScript Property


InstallationProgress.UpdateInstructions Property

  • Supported browsers: Internet Explorer

Sets common instructions on how to update Image Uploader control.

Syntax

PHP

public function getUpdateInstructions() {
}

public function setUpdateInstructions($value) {
}

Property Value

Type: string

The instructions on how to update Image Uploader control.

Default value is "You need to update Image Uploader control. Click <strong>Install</strong> or <strong>Run</strong> button when you see the control installation dialog. If you don't see installation dialog, please try to reload the page.".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.UpdateInstructions ASP.NET Property
  • $au.installationProgress.updateInstructions JavaScript Property


JavaControl Class

  • Supported browsers: Firefox Google Chrome Safari

This class represents Image Uploader Java applet.

For a list of all members of this class, see JavaControl Members.

Syntax

PHP

class JavaControl extends BaseClientControl {
}

Remarks

Note

This client-side control is used in all browsers except Internet Explorer.

Inheritance Hierarchy

BaseClientControl LJavaControl

See Also

Reference

  • JavaControl Property
  • Aurigma.ImageUploader.JavaControl ASP.NET Class
  • $au.javaControl JavaScript Class


JavaControl Members

  • Properties
  • Language Filter ( all languages )

The JavaControl type exposes the following members.

Properties

 | Name | Description
Public property | Cached | Gets or sets a value which enables or disables caching for Image Uploader Java applet.
Public property | ClassName | Gets or sets a class name of Image Uploader Java applet.
Public property | CodeBase | Gets or sets a URL to client-side control. (Inherited from BaseClientControl.)
Public property | Version | Gets or sets a minimum required version of the client-side control. (Inherited from BaseClientControl.)


JavaControl Properties

  • Properties
  • Language Filter ( all languages )

The JavaControl type exposes the following properties.

Properties

 | Name | Description
Public property | Cached | Gets or sets a value which enables or disables caching for Image Uploader Java applet.
Public property | ClassName | Gets or sets a class name of Image Uploader Java applet.
Public property | CodeBase | Gets or sets a URL to client-side control. (Inherited from BaseClientControl.)
Public property | Version | Gets or sets a minimum required version of the client-side control. (Inherited from BaseClientControl.)


JavaControl.Cached Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a value which enables or disables caching for Image Uploader Java applet.

Syntax

PHP

public function getCached() {
}

public function setCached($value) {
}

Property Value

Type: boolean

If true, the Java applet is not re-downloaded until you update it on the server. Otherwise, the applet is re-downloaded every time a user visits this page.

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.JavaControl.Cached ASP.NET Property
  • $au.javaControl.cached JavaScript Property


JavaControl.ClassName Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a class name of Image Uploader Java applet.

Syntax

PHP

public function getClassName() {
}

public function setClassName($value) {
}

Property Value

Type: string

The class name of Image Uploader Java applet.

Default value is "".

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.JavaControl.ClassName ASP.NET Property
  • $au.javaControl.className JavaScript Property

Manual

  • Using Private-label Version of Image Uploader PHP


Messages Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class contains error messages Image Uploader shows.

For a list of all members of this class, see Messages Members.

Syntax

PHP

class Messages {
}

See Also

Reference

  • Messages Property
  • Aurigma.ImageUploader.Messages ASP.NET Class
  • $au.messages JavaScript Class


Messages Members

  • Properties
  • Language Filter ( all languages )

The Messages type exposes the following members.

Properties

 | Name | Description
Public property | CmykImagesNotAllowed | Gets or sets a message which states that the selected image is CMYK, when CMYK images are denied for the upload.
Public property | DeletingFilesError | Gets or sets a message which states that the uploaded file cannot be deleted.
Public property | DimensionsTooLarge | Gets or sets a message which states that the width or height of the selected image is too large.
Public property | DimensionsTooSmall | Gets or sets a message which states that the width or height of selected image is too small.
Public property | FileNameNotAllowed | Gets or sets a message which states that a user tries to select a file that has not allowed name.
Public property | FileSizeTooSmall | Gets or sets a message which states that a user tries to select a file that is too small.
Public property | FilesNotAdded | Gets or sets the message displayed when a user tries to add files and some of them were not added because of restrictions.
Public property | MaxFileCountExceeded | Gets or sets a message which states that a user tries to select too many files.
Public property | MaxFileSizeExceeded | Gets or sets a message which states that a user tries to select a file that is too big.
Public property | MaxTotalFileSizeExceeded | Gets or sets a message which states that the total size of selected files is too large.
Public property | NoResponseFromServer | Gets or sets a message which states that an error was encountered when sending a request to the server and the server did not return any response.
Public property | ServerNotFound | Gets or sets a message which states that the server, specified in the UploadSettings.ActionUrl parameter cannot be found.
Public property | UnexpectedError | Gets or sets a user-friendly message for errors which are meaningful to website developer only.
Public property | UploadCancelled | Gets or sets a message which states that a user cancelled the upload.
Public property | UploadCompleted | Gets or sets a message which notifies that the upload is successfully finished.
Public property | UploadFailed | Gets or sets a message which states that the upload failed because the connection was broken.


Messages Properties

  • Properties
  • Language Filter ( all languages )

The Messages type exposes the following properties.

Properties

 | Name | Description
Public property | CmykImagesNotAllowed | Gets or sets a message which states that the selected image is CMYK, when CMYK images are denied for the upload.
Public property | DeletingFilesError | Gets or sets a message which states that the uploaded file cannot be deleted.
Public property | DimensionsTooLarge | Gets or sets a message which states that the width or height of the selected image is too large.
Public property | DimensionsTooSmall | Gets or sets a message which states that the width or height of selected image is too small.
Public property | FileNameNotAllowed | Gets or sets a message which states that a user tries to select a file that has not allowed name.
Public property | FileSizeTooSmall | Gets or sets a message which states that a user tries to select a file that is too small.
Public property | FilesNotAdded | Gets or sets the message displayed when a user tries to add files and some of them were not added because of restrictions.
Public property | MaxFileCountExceeded | Gets or sets a message which states that a user tries to select too many files.
Public property | MaxFileSizeExceeded | Gets or sets a message which states that a user tries to select a file that is too big.
Public property | MaxTotalFileSizeExceeded | Gets or sets a message which states that the total size of selected files is too large.
Public property | NoResponseFromServer | Gets or sets a message which states that an error was encountered when sending a request to the server and the server did not return any response.
Public property | ServerNotFound | Gets or sets a message which states that the server, specified in the UploadSettings.ActionUrl parameter cannot be found.
Public property | UnexpectedError | Gets or sets a user-friendly message for errors which are meaningful to website developer only.
Public property | UploadCancelled | Gets or sets a message which states that a user cancelled the upload.
Public property | UploadCompleted | Gets or sets a message which notifies that the upload is successfully finished.
Public property | UploadFailed | Gets or sets a message which states that the upload failed because the connection was broken.


Messages.CmykImagesNotAllowed Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the selected image is CMYK, when CMYK images are denied for the upload.

Syntax

PHP

public function getCmykImagesNotAllowed() {
}

public function setCmykImagesNotAllowed($value) {
}

Property Value

Type: string

The message which states that the selected image is CMYK.

Default value is "CMYK images are not allowed.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • EnableCmyk Property
  • Aurigma.ImageUploader.Messages.CmykImagesNotAllowed ASP.NET Property
  • $au.messages.cmykImagesNotAllowed JavaScript Property


Messages.DeletingFilesError Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a message which states that the uploaded file cannot be deleted.

Syntax

PHP

public function getDeletingFilesError() {
}

public function setDeletingFilesError($value) {
}

Property Value

Type: string

The message which states that the uploaded file cannot be deleted, e.g. it is used by another application. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be deleted.

Default value is "The file '[name]' cannot be deleted".

Remarks

Note

A difference between Image Uploader behavior in Internet Explorer and other supported browsers is the following. When Image Uploader deletes files in Internet Explorer, it moves them in the way specified in the Recycle Bin properties. By default, a standard delete confirmation dialog appears and files are moved to the Recycle Bin if a user clicks Yes. However, if Image Uploader deletes files in any of other supported browsers, the internal delete confirmation dialog appears and files are removed permanently when a user clicks Yes.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.DeletingFilesError ASP.NET Property
  • $au.messages.deletingFilesError JavaScript Property


Messages.DimensionsTooLarge Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the width or height of the selected image is too large.

Syntax

PHP

public function getDimensionsTooLarge() {
}

public function setDimensionsTooLarge($value) {
}

Property Value

Type: string

The message which states that the width or height of the selected image is too large (i.e. exceeds the MaxImageWidth or MaxImageHeight property). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The image '[name]' is too large to be selected.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • MaxImageWidth Property
  • MaxImageHeight Property
  • Aurigma.ImageUploader.Messages.DimensionsTooLarge ASP.NET Property
  • $au.messages.dimensionsTooLarge JavaScript Property


Messages.DimensionsTooSmall Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the width or height of selected image is too small.

Syntax

PHP

public function getDimensionsTooSmall() {
}

public function setDimensionsTooSmall($value) {
}

Property Value

Type: string

The message which states that the width or height of the selected image is too small (i.e. it is less than MinImageWidth or MinImageHeight property). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The image '[name]' is too small to be selected.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • MinImageWidth Property
  • MinImageHeight Property
  • Aurigma.ImageUploader.Messages.DimensionsTooSmall ASP.NET Property
  • $au.messages.dimensionsTooSmall JavaScript Property


Messages.FileNameNotAllowed Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user tries to select a file that has not allowed name.

Syntax

PHP

public function getFileNameNotAllowed() {
}

public function setFileNameNotAllowed($value) {
}

Property Value

Type: string

The message which states that a user tries to select a file that has not allowed name (i.e. the file name does not match FileMask, or matches DeniedFileMask). It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. This file has inadmissible name.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • FileMask Property
  • DeniedFileMask Property
  • Aurigma.ImageUploader.Messages.FileNameNotAllowed ASP.NET Property
  • $au.messages.fileNameNotAllowed JavaScript Property


Messages.FileSizeTooSmall Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user tries to select a file that is too small.

Syntax

PHP

public function getFileSizeTooSmall() {
}

public function setFileSizeTooSmall($value) {
}

Property Value

Type: string

The message which states that a user tries to select too small file (i.e. the file size is smaller than MinFileSize value). It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. This file size is smaller than the limit.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • MinFileSize Property
  • Aurigma.ImageUploader.Messages.FileSizeTooSmall ASP.NET Property
  • $au.messages.fileSizeTooSmall JavaScript Property


Messages.FilesNotAdded Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the message displayed when a user tries to add files and some of them were not added because of restrictions.

Syntax

PHP

public function getFilesNotAdded() {
}

public function setFilesNotAdded($value) {
}

Property Value

Type: string

The message which states that a user tries to add files and some of them were not added because of restrictions. It can contain the following placeholder:

[count]
replaced by the number of files which were not added.

Default value is "[count] files were not added due to restrictions.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.FilesNotAdded ASP.NET Property
  • $au.messages.filesNotAdded JavaScript Property


Messages.MaxFileCountExceeded Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user tries to select too many files.

Syntax

PHP

public function getMaxFileCountExceeded() {
}

public function setMaxFileCountExceeded($value) {
}

Property Value

Type: string

The message which states that a user tries to select too many files (i.e. the number of the selected files is bigger than the MaxFileCount value). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. Amount of files exceeds the limit.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • MaxFileCount Property
  • Aurigma.ImageUploader.Messages.MaxFileCountExceeded ASP.NET Property
  • $au.messages.maxFileCountExceeded JavaScript Property


Messages.MaxFileSizeExceeded Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user tries to select a file that is too big.

Syntax

PHP

public function getMaxFileSizeExceeded() {
}

public function setMaxFileSizeExceeded($value) {
}

Property Value

Type: string

The message which states that a user tries to select too large file (i.e. the file size exceeds the MaxFileSize value). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. This file size exceeds the limit.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • MaxFileSize Property
  • Aurigma.ImageUploader.Messages.MaxFileSizeExceeded ASP.NET Property
  • $au.messages.maxFileSizeExceeded JavaScript Property


Messages.MaxTotalFileSizeExceeded Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the total size of selected files is too large.

Syntax

PHP

public function getMaxTotalFileSizeExceeded() {
}

public function setMaxTotalFileSizeExceeded($value) {
}

Property Value

Type: string

The message which states that the total size of selected files is too large (i.e. exceeds the MaxTotalFileSize value). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. Total upload data size exceeds the limit.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • MaxTotalFileSize Property
  • Aurigma.ImageUploader.Messages.MaxTotalFileSizeExceeded ASP.NET Property
  • $au.messages.maxTotalFileSizeExceeded JavaScript Property


Messages.NoResponseFromServer Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that an error was encountered when sending a request to the server and the server did not return any response.

Syntax

PHP

public function getNoResponseFromServer() {
}

public function setNoResponseFromServer($value) {
}

Property Value

Type: string

The message which states that an error was encountered when sending a request to the server and the server did not return any response. To disable this message, set it to an empty string.

Default value is "No response from server.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.NoResponseFromServer ASP.NET Property
  • $au.messages.noResponseFromServer JavaScript Property


Messages.ServerNotFound Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the server, specified in the UploadSettings.ActionUrl parameter cannot be found.

Syntax

PHP

public function getServerNotFound() {
}

public function setServerNotFound($value) {
}

Property Value

Type: string

The message which states that the server, specified in the ActionUrl parameter cannot be found (e.g. the name of this server is misspelled or the server is down). To disable this message, set it to empty string. It can contain the following placeholder:

[name]
replaced by the name of the server which cannot be reached (as specified in the ActionUrl parameter).

Default value is "The server or proxy [name] cannot be found.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ActionUrl Property
  • Aurigma.ImageUploader.Messages.ServerNotFound ASP.NET Property
  • $au.messages.serverNotFound JavaScript Property


Messages.UnexpectedError Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a user-friendly message for errors which are meaningful to website developer only.

Syntax

PHP

public function getUnexpectedError() {
}

public function setUnexpectedError($value) {
}

Property Value

Type: string

The user-friendly error message. To disable this message, set it to an empty string.

Default value is "Image Uploader encountered some problem. If you see this message, contact web master.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.UnexpectedError ASP.NET Property
  • $au.messages.unexpectedError JavaScript Property


Messages.UploadCancelled Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user cancelled the upload.

Syntax

PHP

public function getUploadCancelled() {
}

public function setUploadCancelled($value) {
}

Property Value

Type: string

The message which states that a user cancelled the upload. To disable this message, set it to an empty string.

Default value is "Upload is cancelled.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.UploadCancelled ASP.NET Property
  • $au.messages.uploadCancelled JavaScript Property


Messages.UploadCompleted Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which notifies that the upload is successfully finished.

Syntax

PHP

public function getUploadCompleted() {
}

public function setUploadCompleted($value) {
}

Property Value

Type: string

The message which notifies that the upload is successfully finished. To disable this message, set it to an empty string.

Default value is "Upload complete.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.UploadCompleted ASP.NET Property
  • $au.messages.uploadCompleted JavaScript Property


Messages.UploadFailed Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the upload failed because the connection was broken.

Syntax

PHP

public function getUploadFailed() {
}

public function setUploadFailed($value) {
}

Property Value

Type: string

The message stating that the upload failed because the connection was broken. To disable this message, set it to an empty string.

Default value is "Upload failed (the connection was interrupted).".

Remarks

Typically this error occurs when timeout expires (either server-side or client-side).

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.UploadFailed ASP.NET Property
  • $au.messages.uploadFailed JavaScript Property


Metadata Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents an additional upload data.

For a list of all members of this class, see Metadata Members.

Syntax

PHP

class Metadata {
}

See Also

Reference

  • Metadata Property
  • Aurigma.ImageUploader.Metadata ASP.NET Class
  • $au.metadata JavaScript Class

Manual

  • Uploading Additional Data in PHP


Metadata Members

  • Properties
  • Language Filter ( all languages )

The Metadata type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalFormName | Gets or sets a name or ID of the HTML form with additional information which should be sent to the server along with files.
Public property | Exif | Gets or sets a list of EXIF fields which should be extracted and uploaded along with other data.
Public property | Hash | Gets or sets an algorithm to generate a hash value for each user-selected file.
Public property | Iptc | Gets or sets a list of IPTC fields which should be extracted and uploaded along with other data.
Public property | UserAgent | Gets or sets a user-agent string.
Public property | ValueSeparator | Gets or sets a sequence of characters used to separate strings stored in one metadata field (such as IptcKeyword).


Metadata Properties

  • Properties
  • Language Filter ( all languages )

The Metadata type exposes the following properties.

Properties

 | Name | Description
Public property | AdditionalFormName | Gets or sets a name or ID of the HTML form with additional information which should be sent to the server along with files.
Public property | Exif | Gets or sets a list of EXIF fields which should be extracted and uploaded along with other data.
Public property | Hash | Gets or sets an algorithm to generate a hash value for each user-selected file.
Public property | Iptc | Gets or sets a list of IPTC fields which should be extracted and uploaded along with other data.
Public property | UserAgent | Gets or sets a user-agent string.
Public property | ValueSeparator | Gets or sets a sequence of characters used to separate strings stored in one metadata field (such as IptcKeyword).


Metadata.AdditionalFormName Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a name or ID of the HTML form with additional information which should be sent to the server along with files.

Syntax

PHP

public function getAdditionalFormName() {
}

public function setAdditionalFormName($value) {
}

Property Value

Type: string

The name or ID for the form you need to submit along with files. If this value is an empty string or an invalid form name (which does not exist on this page), no additional form is sent.

Default value is "".

Remarks

The additional form may contain the following elements:

  • Input fields (except of <input type="image"> and <input type="file">).
  • Text areas.
  • Select elements.
Note

The additional form must be placed into the same frame with the Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Metadata.AdditionalFormName ASP.NET Property
  • $au.metadata.additionalFormName JavaScript Property


Metadata.Exif Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of EXIF fields which should be extracted and uploaded along with other data.

Syntax

PHP

public function getExif() {
}

public function setExif($value) {
}

Property Value

Type: string

The string containing EXIF field names which you want to extract separated with a semicolon.

You will find possible names of EXIF fields in the table below.

Field name | Description
ExifApertureValue | The lens aperture (in APEX units).
ExifArtist | The name of photographer or image creator.
ExifBitsPerSample | The number of bits per image component.
ExifBrightnessValue | The brightness value (in APEX units).
ExifCFAPattern | The color filter pattern.
ExifColorSpace | The color space of the image.
ExifComponentsConfiguration | The order of pixel channels (components).
ExifCompressedBitsPerPixel | The number of bits per pixel in the compressed image.
ExifCompression | The compression type.
ExifContrast | The contrast settings applied when images was captured.
ExifCopyright | The copyright information.
ExifCustomRendered | Value that indicates that special processing was applied to the image.
ExifDateTime | The date and time of image creation.
ExifDateTimeDigitized | The date and time when the image was converted into digital representation.
ExifDateTimeOriginal | The date and time when the original file was created.
ExifDeviceSettingDescription | The description of the image capturing device settings.
ExifDigitalZoomRatio | The digital zoom ratio.
ExifExifVersion | The version of the EXIF specification this data is stored at.
ExifExposureBiasValue | The exposure bias (in APEX units).
ExifExposureIndex | The exposure index of the device when image is being captured.
ExifExposureMode | The exposure mode.
ExifExposureProgram | The exposure program.
ExifExposureTime | The exposure time (in seconds).
ExifFileSource | The image source.
ExifFlash | The flash status.
ExifFlashEnergy | The flash energy (in BCPS).
ExifFlashPixVersion | The version of FlashPix format.
ExifFNumber | The F number.
ExifFocalLength | The focal length of the lens (in millimeters).
ExifFocalLengthIn35mmFilm | The focal length of the lens assuming 35mm film camera is used (in millimeters).
ExifFocalPlaneResolutionUnit | The unit to measure focal plane resolution with (i.e. ExifFocalPlaneXResolution and ExifFocalPlaneYResolution).
ExifFocalPlaneXResolution | The horizontal resolution of the camera focal plane.
ExifFocalPlaneYResolution | The vertical resolution of the camera focal plane.
ExifGainControl | The overall image gain adjustment.
ExifGpsAltitude | The altitude.
ExifGpsAltitudeRef | The altitude reference.
ExifGpsAreaInformation | The name of GPS area.
ExifGpsDateStamp | The GPS datestamp.
ExifGpsDestBearing | The bearing to the destination point (in degrees).
ExifGpsDestBearingRef | The reference for giving the bearing to the destination point.
ExifGpsDestDistance | The distance to the destination point.
ExifGpsDestDistanceRef | The unit for distance to the destination point.
ExifGpsDestLatitude | The destination point latitude.
ExifGpsDestLatitudeRef | The destination point latitude reference (north or south).
ExifGpsDestLongitude | The destination point longitude.
ExifGpsDestLongitudeRef | The destination point longitude reference (west or east).
ExifGpsDifferential | The GPS differential correction.
ExifGpsDOP | The GPS data degree of precision.
ExifGpsImgDirection | The direction of the image when it was captured (in degrees).
ExifGpsImgDirectionRef | The reference for giving the direction of the image when it was captured.
ExifGpsLatitude | The latitude.
ExifGpsLatitudeRef | The latitude reference (north or south).
ExifGpsLongitude | The longitude.
ExifGpsLongitudeRef | The longitude reference (west or east).
ExifGpsMapDatum | The geodetic survey data.
ExifGpsMeasureMode | The GPS measurement mode.
ExifGpsProcessingMethod | The name of GPS processing method.
ExifGpsSatellites | The details about GPS satellites used in measurement.
ExifGpsSpeed | The speed of the GPS receiver movement.
ExifGpsSpeedRef | The Unit for speed of movement of GPS receiver.
ExifGpsStatus | The status of GPS receiver when image was recorded.
ExifGpsTimeStamp | The GPS timestamp (in UTC).
ExifGpsTrack | The direction of GPS receiver movement (in degrees).
ExifGpsTrackRef | The reference for giving the direction of GPS receiver movement.
ExifGpsVersionID | The version of the GPSVersionID tag.
ExifImageDescription | The title of the image.
ExifImageHeight | The height of the image in pixels.
ExifImageUniqueID | The 128-bit unique ID of the image.
ExifImageWidth | The width of the image in pixels.
ExifInteroperabilityIndex | The index of interoperability rule.
ExifISOSpeedRatings | The ISO speed and the ISO latitude of the device.
ExifLightSource | The light source.
ExifMake | The name of manufacturer of the camera (or other recording equipment).
ExifMakerNote | The custom comments. May contain any information maker want to store.
ExifMaxApertureValue | The smallest F of the lens (in APEX units).
ExifMeteringMode | The metering mode.
ExifModel | The name of the model of the camera (or other recording equipment).
ExifOECF | The opto-electronic conversion function.
ExifOrientation | The orientation of image (how it is rotated relative to the top left corner).
ExifPhotometricInterpretation | The pixel composition.
ExifPixelXDimension | The valid width of the meaningful image.
ExifPixelYDimension | The valid height of the meaningful image.
ExifPlanarConfiguration | The planar configuration of the pixel components (planar or chunky).
ExifPrimaryChromaticities | The chromaticity of the three primary colors of the image.
ExifReferenceBlackWhite | The reference for black and white point of the image.
ExifRelatedSoundFile | The name of an audio file associated with this image.
ExifResolutionUnit | The unit image resolution is measured in (i.e. ExifXResolution and ExifYResolution).
ExifRowsPerStrip | Rows per strip (if image is divided into strips).
ExifSamplesPerPixel | The number of components (channels) in one pixel.
ExifSaturation | The saturation settings applied when images was captured.
ExifSceneCaptureType | The type of scene was captured by camera (landscape, night scene, portrait, etc).
ExifSceneType | The type of scene.
ExifSensingMethod | The sensor type of the device.
ExifSharpness | The sharpness settings applied when images was captured.
ExifShutterSpeed | The shutter speed (in APEX units).
ExifSoftware | The name of the software that created this image.
ExifSpatialFrequencyResponse | The spatial frequency response values.
ExifSpectralSensitivity | The spectral sensitivity.
ExifStripByteCounts | The total number of bytes in one strip.
ExifStripOffsets | The bitmap stride (byte offset between strips).
ExifSubjectArea | The subject area.
ExifSubjectDistance | The distance to the subject (in meters).
ExifSubjectDistanceRange | The kind of distance to the subject (macro, close, or distant).
ExifSubjectLocation | The location of the main subject in the scene.
ExifSubSecTime | The fractions of seconds for the ExifDateTime field.
ExifSubSecTimeDigitized | The fractions of seconds for the ExifDateTimeDigitized field.
ExifSubSecTimeOriginal | The fractions of seconds for the ExifDateTimeOriginal field.
ExifThumbnailBitsPerSample | The number of bits per channel in the thumbnail.
ExifThumbnailCompression | The compression type of the thumbnail.
ExifThumbnailHeight | The height of the thumbnail in pixel.
ExifThumbnailOrientation | The orientation of the thumbnail (how it is rotated relative to the top left corner).
ExifThumbnailPhotometricInterpretation | The pixel composition of the thumbnail.
ExifThumbnailResolutionUnit | The unit thumbnail resolution is measured in (i.e.ExifThumbnailXResolution and ExifThumbnailYResolution).
ExifThumbnailRowsPerStrip | Rows per strip in the thumbnail (if thumbnail is divided into strips).
ExifThumbnailSamplesPerPixel | The number of components (channels) in one pixel of the thumbnail.
ExifThumbnailStripByteCounts | The total number of bytes in one strip of the thumbnail.
ExifThumbnailStripOffsets | The thumbnail stride (byte offset between strips).
ExifThumbnailWidth | The width of the thumbnail in pixels.
ExifThumbnailXResolution | The horizontal resolution of the thumbnail.
ExifThumbnailYResolution | The vertical resolution of the thumbnail.
ExifTransferFunction | The transfer function in tabular form.
ExifUserComment | The additional comments or keywords on the image available for users.
ExifWhiteBalance | The mode of the white balance when the image was captured.
ExifWhitePoint | The white point of the image.
ExifXResolution | The horizontal resolution of the image.
ExifYCbCrCoefficients | The coefficients used during the transformation between RGB and YCbCr colorspaces.
ExifYCbCrPositioning | The position of chrominance components relative to the luminosity component.
ExifYCbCrSubSampling | Sampling ratio of the chrominance components relative to the luminosity component.
ExifYResolution | The vertical resolution of the image.

All date/time values have the following format: YYYY:MM:DD hh:mm:ss. E.g. 11th of May 2006, 2:40PM would be represented as: 2006:05:11 14:40:00.

For more details regarding interpretation of these values, refer to the EXIF specification.

Default value is "".

Remarks

To get an uploaded EXIF value at the server, use the Package.PackageFields collection. Here this value can be retrieved by a key named in the following way: XXX_N, where XXX is a string value specified in this property (EXIF field name), and N is the index of the file in the request. E.g. if the property value is ExifDateTime;ExifOrientation;ExifModel, the PackageFields collection will contain the following keys:

  • ExifDateTime_1, ExifDateTime_2, etc.
  • ExifOrientation_1, ExifOrientation_2, etc.
  • ExifModel_1, ExifModel_2, etc.

If you prefer to extract EXIF fields on the server, you can get them from the original file, or specify to preserve EXIF fields in the thumbnails you are going to upload. To do it, use the ThumbnailCopyExif property.

See Also

Reference

  • Aurigma.ImageUploader.Metadata.Exif ASP.NET Property
  • $au.metadata.exif JavaScript Property


Metadata.Hash Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an algorithm to generate a hash value for each user-selected file.

Syntax

PHP

public function getHash() {
}

public function setHash($value) {
}

Property Value

Type: string

The algorithm to generate a hash value for each user-selected file.

Possible values are listed in the table below.

Value | Description
SHA | SHA hash algorithm.
MD2 | MD2 hash algorithm.
MD5 | MD5 hash algorithm.

You can specify several hash algorithms separated by semicolon.

Default value is "".

Remarks

Note

Image Uploader Express does not upload hash sums. See the Comparison of Image Uploader Editions topic for details.

The hash is calculated only for the original file, not for converted files (even if the original file is not uploaded).

To get an uploaded hash sum at the server, use the Package.PackageFields collection. Here this value can be retrieved by a key named in the following way: HashCodeXXX_N, where XXX is a string value specified in this property (hash algorithm), and N is the index of the file in the request. E.g. if the property value is MD5;SHA, the PackageFields collection will contain the following keys:

  • HashCodeMD5_1, HashCodeMD5_2, etc.
  • HashCodeSHA_1, HashCodeSHA_2, etc.
Note

Hash calculation is quite resource-intensive operation. That is why if you need not verify uploaded files on the server, it makes sense to disable this feature to make Image Uploader faster. To do it, just specify empty string in this property.

See Also

Reference

  • Aurigma.ImageUploader.Metadata.Hash ASP.NET Property
  • $au.metadata.hash JavaScript Property


Metadata.Iptc Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of IPTC fields which should be extracted and uploaded along with other data.

Syntax

PHP

public function getIptc() {
}

public function setIptc($value) {
}

Property Value

Type: string

The string containing IPTC field names which you want to extract, separated with a semicolon.

You will find possible names of IPTC fields in the table below.

Field name | Description
IptcByline | The name of the creator of the image, e.g. artist, photographer, etc.
IptcBylineTitle | The byline title (e.g. staff photographer, correspondent, etc).
IptcCredit | The provider of the image.
IptcSource | The original owner of the intellectual content of this image.
IptcObjectName | The short reference for the object.
IptcDateCreated | The date the image (as an intellectual content, rather than physical file) created.
IptcCity | The city of the image origin.
IptcState | The state/province of the image origin.
IptcCountry | The country of the image origin.
IptcOriginalTransmissionReference | The location of the original transmission.
IptcCopyrightNotice | The copyright notice.
IptcCaption | The textual description of the image.
IptcWriter | The name of editor or other person involved in the writing.
IptcHeadline | The brief overview for the image.
IptcSpecialInstructions | Some custom editorial instructions.
IptcCategory | The image category.
IptcSupplementaryCategory | The supplementary category for the image.
IptcUrgency | The editorial urgency of the content.
IptcKeyword | The keywords used for search.

All date values have the following format: YYYYMMDD. E.g. 11th of May 2006 would be represented as: 20060511.

For more information about interpretation of these values, refer to IPTC specification (version 4.1 is currently supported).

Default value is "".

Remarks

To get an uploaded IPTC value at the server, use the Package.PackageFields collection. Here this value can be retrieved by a key named in the following way: XXX_N, where XXX is a string value specified in this property (IPTC field name), and N is the index of the file in the request. E.g. if the property value is IptcCountry;IptcCity;IptcObjectName, the PackageFields collection will contain the following keys:

  • IptcCountry_1, IptcCountry_2, etc.
  • IptcCity_1, IptcCity_2, etc.
  • IptcObjectName_1, IptcObjectName_2, etc.

If you prefer to extract IPTC fields on the server, you can get them from the original file, or specify to preserve IPTC fields in the thumbnails you are going to upload. To do it, use the ThumbnailCopyIptc property.

See Also

Reference

  • Aurigma.ImageUploader.Metadata.Iptc ASP.NET Property
  • $au.metadata.iptc JavaScript Property


Metadata.UserAgent Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a user-agent string.

Syntax

PHP

public function getUserAgent() {
}

public function setUserAgent($value) {
}

Property Value

Type: string

The user-agent string which is sent by Image Uploader in the header of the upload request.

Default value is "".

Remarks

Note

During initialization, this value is set to the user-agent string of a browser which hosts Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Metadata.UserAgent ASP.NET Property
  • $au.metadata.userAgent JavaScript Property


Metadata.ValueSeparator Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a sequence of characters used to separate strings stored in one metadata field (such as IptcKeyword).

Syntax

PHP

public function getValueSeparator() {
}

public function setValueSeparator($value) {
}

Property Value

Type: string

The sequence of characters used to separate strings stored in one metadata field.

Default value is " ".

Remarks

Some metadata fields like IptcKeyword can contain multiple string values. Suppose you upload an image which contains several keywords: portrait, old photo, black and white. All these keywords are stored in one IptcKeyword field. So, if you specified this field for upload (using the Iptc property) the IptcKeyword_0 POST field will contain all these keywords gathered into one string separated with this property value. For example, if you set it to the ";" you will get the "portrait;old photo;black and white" POST field value.

See Also

Reference

  • Aurigma.ImageUploader.Metadata.ValueSeparator ASP.NET Property
  • $au.metadata.valueSeparator JavaScript Property


Package Class

This class represents a package uploaded within the current session.

For a list of all members of this class, see Package Members.

Syntax

PHP

class Package {
}

See Also

Reference

  • Aurigma.ImageUploader.Package ASP.NET Class

Manual

  • Saving Uploaded Files in PHP


Package Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The Package type exposes the following members.

Methods

 | Name | Description
Public method | getPackageField(string) | Returns a value of the specified POST field uploaded within this package.

Properties

 | Name | Description
Public property | PackageCount | Gets a total number of packages uploaded within the current session.
Public property | PackageFields | Gets a name-value collection of POST fields uploaded within this package.
Public property | PackageFileCount | Gets a number of files uploaded within this package.
Public property | PackageGuid | Gets a unique identifier of the current upload session.
Public property | PackageIndex | Gets an index of this package inside the current session.
Public property | UploadedFiles | Gets a collection of UploadedFile instances belonging to this package.


Package Methods

  • Methods
  • Language Filter ( all languages )

The Package type exposes the following methods.

Methods

 | Name | Description
Public method | getPackageField(string) | Returns a value of the specified POST field uploaded within this package.


Package.getPackageField(string) Method

Returns a value of the specified POST field uploaded within this package.

Syntax

PHP

public function getPackageField($fieldName) {
}

Parameters

fieldName

Type: string

The name of the field to get.

Return Value

Type: string

The fieldName value.

See Also

Reference

  • PackageFields Property


Package Properties

  • Properties
  • Language Filter ( all languages )

The Package type exposes the following properties.

Properties

 | Name | Description
Public property | PackageCount | Gets a total number of packages uploaded within the current session.
Public property | PackageFields | Gets a name-value collection of POST fields uploaded within this package.
Public property | PackageFileCount | Gets a number of files uploaded within this package.
Public property | PackageGuid | Gets a unique identifier of the current upload session.
Public property | PackageIndex | Gets an index of this package inside the current session.
Public property | UploadedFiles | Gets a collection of UploadedFile instances belonging to this package.


Package.PackageCount Property

Gets a total number of packages uploaded within the current session.

Syntax

PHP

public function getPackageCount() {
}

Property Value

Type: string

The total number of packages uploaded within the current session.

See Also

Reference

  • Aurigma.ImageUploader.Package.PackageCount ASP.NET Property


Package.PackageFields Property

Gets a name-value collection of POST fields uploaded within this package.

Syntax

PHP

public function getPackageFields() {
}

Property Value

Type: array

The name-value collection of POST fields uploaded within this package.

Remarks

This collection contains additional data specified for the upload via the Metadata property. To access these data use kays named in the following way: XXX_N, where XXX is a string value specified in one of the Metadata properties.

See Also

Reference

  • Metadata Class
  • getPackageField(string) Method
  • Aurigma.ImageUploader.Package.PackageFields ASP.NET Property

Manual

  • Uploading Additional Data in PHP


Package.PackageFileCount Property

Gets a number of files uploaded within this package.

Syntax

PHP

public function getPackageFileCount() {
}

Property Value

Type: string

The number of files uploaded within this package.

See Also

Reference

  • Aurigma.ImageUploader.Package.PackageFileCount ASP.NET Property


Package.PackageGuid Property

Gets a unique identifier of the current upload session.

Syntax

PHP

public function getPackageGuid() {
}

Property Value

Type: string

The unique identifier of the current upload session.

Remarks

When the upload session is separated into several packages (FilesPerPackage is greater than 0), each package has the same GUID. So you can use it to determine whether files are uploaded in the same session.

See Also

Reference

  • Aurigma.ImageUploader.Package.PackageGuid ASP.NET Property


Package.PackageIndex Property

Gets an index of this package inside the current session.

Syntax

PHP

public function getPackageIndex() {
}

Property Value

Type: string

The zero-based index of this package inside the current session.

Remarks

Using this property you can recognize the order of files if they are sent in different packages.

See Also

Reference

  • Aurigma.ImageUploader.Package.PackageIndex ASP.NET Property


Package.UploadedFiles Property

Gets a collection of UploadedFile instances belonging to this package.

Syntax

PHP

public function getUploadedFiles() {
}

Property Value

Type: array

The collection of UploadedFile instances. Each instance contains all the converted files and metadata related to a particular user-selected file.

See Also

Reference

  • Aurigma.ImageUploader.Package.UploadedFiles ASP.NET Property


PaneItem Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a pane item displayed in both the upload and folder panes.

For a list of all members of this class, see PaneItem Members.

Syntax

PHP

class PaneItem {
}

See Also

Reference

  • PaneItem Property
  • Aurigma.ImageUploader.PaneItem ASP.NET Class
  • $au.paneItem JavaScript Class

Manual

  • Additional Controls and Indicators
  • Customizing Appearance


PaneItem Members

  • Properties
  • Language Filter ( all languages )

The PaneItem type exposes the following members.

Properties

 | Name | Description
Public property | DescriptionAddedIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the description added icon.
Public property | DescriptionEditorIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the description editor icon.
Public property | DescriptionEditorIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the description editor icon.
Public property | EnableDisproportionalExifThumbnails | Get or sets a value indicating whether Image Uploader should generate a preview thumbnail from the original image in the case when thumbnail saved in EXIF metadata is out of proportions of original image.
Public property | EnableFileNameTooltip | Get or sets a value indicating whether a tooltip containing a filename should be displayed when the mouse pointer hovers over the pane item.
Public property | HoverBorderColor | Gets or sets a color of the pane item border when the mouse pointer hovers over it.
Public property | HoverColor | Gets or sets a color of the pane item when the mouse pointer hovers over it.
Public property | ImageCroppedIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the image cropped icon.
Public property | ImageCroppedIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image cropped icon.
Public property | ImageEditorIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the image editor icon.
Public property | ImageEditorIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image editor icon.
Public property | InactiveSelectionBorderColor | Gets or sets a color of the pane item border when it is selected and not in focus.
Public property | InactiveSelectionColor | Gets or sets a color of the pane item when it is selected and not in focus.
Public property | PreviewQuality | Gets or sets a resize quality of preview thumbnails.
Public property | QualityMeter | Gets or sets the quality meter settings.
Public property | RemovalIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the removal icon.
Public property | RemovalIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the removal icon.
Public property | RotationIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the rotation icon.
Public property | RotationIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the rotation icon.
Public property | SelectedTextColor | Gets or sets a color of the pane item text when it is selected.
Public property | SelectionBorderColor | Gets or sets a color of the pane item border when it is selected.
Public property | SelectionColor | Gets or sets a color of the pane item when it is selected.
Public property | SelectionHoverBorderColor | Gets or sets a color of the pane item border when it is selected and the mouse pointer hovers over it.
Public property | SelectionHoverColor | Gets or sets a color of the pane item when it is selected and the mouse pointer hovers over it.
Public property | ShowFileNameInThumbnailsView | Gets or sets a value indicating whether to display filenames in the Thumbnails view.


PaneItem Properties

  • Properties
  • Language Filter ( all languages )

The PaneItem type exposes the following properties.

Properties

 | Name | Description
Public property | DescriptionAddedIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the description added icon.
Public property | DescriptionEditorIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the description editor icon.
Public property | DescriptionEditorIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the description editor icon.
Public property | EnableDisproportionalExifThumbnails | Get or sets a value indicating whether Image Uploader should generate a preview thumbnail from the original image in the case when thumbnail saved in EXIF metadata is out of proportions of original image.
Public property | EnableFileNameTooltip | Get or sets a value indicating whether a tooltip containing a filename should be displayed when the mouse pointer hovers over the pane item.
Public property | HoverBorderColor | Gets or sets a color of the pane item border when the mouse pointer hovers over it.
Public property | HoverColor | Gets or sets a color of the pane item when the mouse pointer hovers over it.
Public property | ImageCroppedIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the image cropped icon.
Public property | ImageCroppedIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image cropped icon.
Public property | ImageEditorIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the image editor icon.
Public property | ImageEditorIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image editor icon.
Public property | InactiveSelectionBorderColor | Gets or sets a color of the pane item border when it is selected and not in focus.
Public property | InactiveSelectionColor | Gets or sets a color of the pane item when it is selected and not in focus.
Public property | PreviewQuality | Gets or sets a resize quality of preview thumbnails.
Public property | QualityMeter | Gets or sets the quality meter settings.
Public property | RemovalIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the removal icon.
Public property | RemovalIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the removal icon.
Public property | RotationIconImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the rotation icon.
Public property | RotationIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the rotation icon.
Public property | SelectedTextColor | Gets or sets a color of the pane item text when it is selected.
Public property | SelectionBorderColor | Gets or sets a color of the pane item border when it is selected.
Public property | SelectionColor | Gets or sets a color of the pane item when it is selected.
Public property | SelectionHoverBorderColor | Gets or sets a color of the pane item border when it is selected and the mouse pointer hovers over it.
Public property | SelectionHoverColor | Gets or sets a color of the pane item when it is selected and the mouse pointer hovers over it.
Public property | ShowFileNameInThumbnailsView | Gets or sets a value indicating whether to display filenames in the Thumbnails view.


PaneItem.DescriptionAddedIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the description added icon.

Syntax

PHP

public function getDescriptionAddedIconImageFormat() {
}

public function setDescriptionAddedIconImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the description added icon.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.DescriptionAddedIconImageFormat ASP.NET Property
  • $au.paneItem.descriptionAddedIconImageFormat JavaScript Property


PaneItem.DescriptionEditorIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the description editor icon.

Syntax

PHP

public function getDescriptionEditorIconImageFormat() {
}

public function setDescriptionEditorIconImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the description editor icon.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.DescriptionEditorIconImageFormat ASP.NET Property
  • $au.paneItem.descriptionEditorIconImageFormat JavaScript Property


PaneItem.DescriptionEditorIconTooltip Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the description editor icon.

Syntax

PHP

public function getDescriptionEditorIconTooltip() {
}

public function setDescriptionEditorIconTooltip($value) {
}

Property Value

Type: string

The text of the tooltip which is displayed when the mouse pointer hovers over the description editor icon.

Default value is "Edit description".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.DescriptionEditorIconTooltip ASP.NET Property
  • $au.paneItem.descriptionEditorIconTooltip JavaScript Property


PaneItem.EnableDisproportionalExifThumbnails Property

  • Supported browsers: Firefox Google Chrome Safari

Get or sets a value indicating whether Image Uploader should generate a preview thumbnail from the original image in the case when thumbnail saved in EXIF metadata is out of proportions of original image.

Syntax

PHP

public function getEnableDisproportionalExifThumbnails() {
}

public function setEnableDisproportionalExifThumbnails($value) {
}

Property Value

Type: boolean

If true Image Uploader displays disproportional EXIF thumbnails in the list, otherwise the control resizes original image to the thumbnail size.

Default value is true.

Remarks

Note

This property takes effect in the Thumbnails, Tiles, and List views only.

To accelerate folder navigation Image Uploader supports displaying EXIF thumbnails in the folder and upload panes when the Thumbnails, Tiles, or List view mode is set. Such thumbnails are created by the most of cameras and stored along with image data. However, some cameras may create EXIF thumbnails which are out of proportions of original images. If so disproportional thumbnails will have black stripes above and below them. In this case you can set this property to false to regenerate preview thumbnails from original images and get rid of black stripes or specify a true value to display disproportional thumbnails instead.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.EnableDisproportionalExifThumbnails ASP.NET Property
  • $au.paneItem.enableDisproportionalExifThumbnails JavaScript Property


PaneItem.EnableFileNameTooltip Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Get or sets a value indicating whether a tooltip containing a filename should be displayed when the mouse pointer hovers over the pane item.

Syntax

PHP

public function getEnableFileNameTooltip() {
}

public function setEnableFileNameTooltip($value) {
}

Property Value

Type: boolean

If true filename tooltip is displayed when the mouse pointer hovers over the pane item.

Default value is false.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.EnableFileNameTooltip ASP.NET Property
  • $au.paneItem.enableFileNameTooltip JavaScript Property


PaneItem.HoverBorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item border when the mouse pointer hovers over it.

Syntax

PHP

public function getHoverBorderColor() {
}

public function setHoverBorderColor($value) {
}

Property Value

Type: string

The color of the pane item border when the mouse pointer hovers over it.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#99DEFD".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.HoverBorderColor ASP.NET Property
  • $au.paneItem.hoverBorderColor JavaScript Property


PaneItem.HoverColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item when the mouse pointer hovers over it.

Syntax

PHP

public function getHoverColor() {
}

public function setHoverColor($value) {
}

Property Value

Type: string

The color of the pane item when the mouse pointer hovers over it.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is "#F5FAFD;#EDF8FE".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.HoverColor ASP.NET Property
  • $au.paneItem.hoverColor JavaScript Property


PaneItem.ImageCroppedIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the image cropped icon.

Syntax

PHP

public function getImageCroppedIconImageFormat() {
}

public function setImageCroppedIconImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the image cropped icon.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.ImageCroppedIconImageFormat ASP.NET Property
  • $au.paneItem.imageCroppedIconImageFormat JavaScript Property


PaneItem.ImageCroppedIconTooltip Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image cropped icon.

Syntax

PHP

public function getImageCroppedIconTooltip() {
}

public function setImageCroppedIconTooltip($value) {
}

Property Value

Type: string

The text of the tooltip which is displayed when the mouse pointer hovers over the image cropped icon.

Default value is "The image is cropped.".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.ImageCroppedIconTooltip ASP.NET Property
  • $au.paneItem.imageCroppedIconTooltip JavaScript Property


PaneItem.ImageEditorIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the image editor icon.

Syntax

PHP

public function getImageEditorIconImageFormat() {
}

public function setImageEditorIconImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the image editor icon.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.ImageEditorIconImageFormat ASP.NET Property
  • $au.paneItem.imageEditorIconImageFormat JavaScript Property


PaneItem.ImageEditorIconTooltip Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image editor icon.

Syntax

PHP

public function getImageEditorIconTooltip() {
}

public function setImageEditorIconTooltip($value) {
}

Property Value

Type: string

The text of the tooltip which is displayed when the mouse pointer hovers over the image editor icon.

Default value is "Preview / edit image".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.ImageEditorIconTooltip ASP.NET Property
  • $au.paneItem.imageEditorIconTooltip JavaScript Property


PaneItem.InactiveSelectionBorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item border when it is selected and not in focus.

Syntax

PHP

public function getInactiveSelectionBorderColor() {
}

public function setInactiveSelectionBorderColor($value) {
}

Property Value

Type: string

The color of the pane item border when it is selected and not in focus.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#D9D9D9".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.InactiveSelectionBorderColor ASP.NET Property
  • $au.paneItem.inactiveSelectionBorderColor JavaScript Property


PaneItem.InactiveSelectionColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item when it is selected and not in focus.

Syntax

PHP

public function getInactiveSelectionColor() {
}

public function setInactiveSelectionColor($value) {
}

Property Value

Type: string

The color of the pane item when it is selected and not in focus.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is "#f8f8f8;#e5e5e5".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.InactiveSelectionColor ASP.NET Property
  • $au.paneItem.inactiveSelectionColor JavaScript Property


PaneItem.PreviewQuality Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a resize quality of preview thumbnails.

Syntax

PHP

public function getPreviewQuality() {
}

public function setPreviewQuality($value) {
}

Property Value

Type: string

The resize quality of preview thumbnails.

The following values are supported:

Value | Description
Low | Low quality. The image is resized using the nearest-neighbor algorithm.
Medium | Medium quality. The image is resized using the anisotropic algorithm.
High | High quality. The image is resized using the lanczos algorithm.

Default value is "Medium".

Remarks

Note

This property takes effect in the Thumbnails, Tiles, and List views only.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.PreviewQuality ASP.NET Property
  • $au.paneItem.previewQuality JavaScript Property


PaneItem.QualityMeter Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the quality meter settings.

Syntax

PHP

public function getQualityMeter() {
}

public function setQualityMeter($value) {
}

Property Value

Type: QualityMeter

The quality meter settings.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.QualityMeter ASP.NET Property
  • $au.paneItem.qualityMeter JavaScript Property

Manual

  • Using Quality Meter


PaneItem.RemovalIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the removal icon.

Syntax

PHP

public function getRemovalIconImageFormat() {
}

public function setRemovalIconImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the removal icon.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.RemovalIconImageFormat ASP.NET Property
  • $au.paneItem.removalIconImageFormat JavaScript Property


PaneItem.RemovalIconTooltip Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the removal icon.

Syntax

PHP

public function getRemovalIconTooltip() {
}

public function setRemovalIconTooltip($value) {
}

Property Value

Type: string

The text of the tooltip which is displayed when the mouse pointer hovers over the removal icon.

Default value is "Remove".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.RemovalIconTooltip ASP.NET Property
  • $au.paneItem.removalIconTooltip JavaScript Property


PaneItem.RotationIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the rotation icon.

Syntax

PHP

public function getRotationIconImageFormat() {
}

public function setRotationIconImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the rotation icon.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.RotationIconImageFormat ASP.NET Property
  • $au.paneItem.rotationIconImageFormat JavaScript Property


PaneItem.RotationIconTooltip Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the rotation icon.

Syntax

PHP

public function getRotationIconTooltip() {
}

public function setRotationIconTooltip($value) {
}

Property Value

Type: string

The text of the tooltip which is displayed when the mouse pointer hovers over the rotation icon.

Default value is "Rotate".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.RotationIconTooltip ASP.NET Property
  • $au.paneItem.rotationIconTooltip JavaScript Property


PaneItem.SelectedTextColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item text when it is selected.

Syntax

PHP

public function getSelectedTextColor() {
}

public function setSelectedTextColor($value) {
}

Property Value

Type: string

The color of the pane item text when it is selected.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#000000".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.SelectedTextColor ASP.NET Property
  • $au.paneItem.selectedTextColor JavaScript Property


PaneItem.SelectionBorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item border when it is selected.

Syntax

PHP

public function getSelectionBorderColor() {
}

public function setSelectionBorderColor($value) {
}

Property Value

Type: string

The color of the pane item border when it is selected.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#99defd".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.SelectionBorderColor ASP.NET Property
  • $au.paneItem.selectionBorderColor JavaScript Property


PaneItem.SelectionColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item when it is selected.

Syntax

PHP

public function getSelectionColor() {
}

public function setSelectionColor($value) {
}

Property Value

Type: string

The color of the pane item when it is selected.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is "#f0f8fd;#d5effc".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.SelectionColor ASP.NET Property
  • $au.paneItem.selectionColor JavaScript Property


PaneItem.SelectionHoverBorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item border when it is selected and the mouse pointer hovers over it.

Syntax

PHP

public function getSelectionHoverBorderColor() {
}

public function setSelectionHoverBorderColor($value) {
}

Property Value

Type: string

The color of the pane item border when it is selected and the mouse pointer hovers over it.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#99defd".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.SelectionHoverBorderColor ASP.NET Property
  • $au.paneItem.selectionHoverBorderColor JavaScript Property


PaneItem.SelectionHoverColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item when it is selected and the mouse pointer hovers over it.

Syntax

PHP

public function getSelectionHoverColor() {
}

public function setSelectionHoverColor($value) {
}

Property Value

Type: string

The color of the pane item when it is selected and the mouse pointer hovers over it.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is "#e8f6fd;#c4e8fa".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.SelectionHoverColor ASP.NET Property
  • $au.paneItem.selectionHoverColor JavaScript Property


PaneItem.ShowFileNameInThumbnailsView Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to display filenames in the Thumbnails view.

Syntax

PHP

public function getShowFileNameInThumbnailsView() {
}

public function setShowFileNameInThumbnailsView($value) {
}

Property Value

Type: boolean

If true, filenames are displayed under thumbnails; otherwise, only thumbnails are shown.

Default value is false.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.ShowFileNameInThumbnailsView ASP.NET Property
  • $au.paneItem.showFileNameInThumbnailsView JavaScript Property


PostFields Class

This class contains POST field names that are generated and uploaded by Image Uploader.

For a list of all members of this class, see PostFields Members.

Syntax

PHP

class PostFields {
}

See Also

Reference

  • Aurigma.ImageUploader.PostFields ASP.NET Class


PostFields Members

The PostFields type exposes the following members.

Fields

Name | Description
Angle | Represents the name of the field which contains a rotation angle.
CropBounds | Represents the name of the field which contains bounds of cropped area.
Description | Represents the name of the field which contains a user-provided description of the original file.
File | Represents the name of the field which contains a converted file.
FileChunkCount | Represents the name of the field which contains a number of chunks on which the converted file was divided.
FileChunkIndex | Represents the name of the field which contains a zero-based index of the chunk.
FileHeight | Represents the name of the field which contains an actual height of the converted file.
FileMode | Represents the name of the field which contains the mode of the converted file.
FileName | Represents the name of the field which contains the name of the converted file.
FileSize | Represents the name of the field which contains the size of the converted file.
FileWidth | Represents the name of the field which contains an actual width of the converted file.
PackageComplete | Represents the name of the field which is sent in the end of the package.
PackageCount | Represents the name of the field which contains a total number of packages (i.e. requests) in the current upload session.
PackageFileCount | Represents the name of the field which contains the number of files uploaded in the current package.
PackageGuid | Represents the name of the field which contains a unique identifier of the current upload session.
PackageIndex | Represents the name of the field which contains a zero-based index of the package inside the current upload session.
RequestComplete | Represents the name of the field which is sent in the end of the upload request.
SourceCreatedDateTime | Represents the name of the field which contains a creation date of the original file.
SourceCreatedDateTimeLocal | Represents the name of the field which contains a local creation date of the original file.
SourceHeight | Represents the name of the field which contains the height of the original file.
SourceLastModifiedDateTime | Represents the name of the field which contains a last modification date of the original file.
SourceLastModifiedDateTimeLocal | Represents the name of the field which contains a local last modification date of the original file.
SourceName | Represents the name of the field which contains the name of the original file.
SourceSize | Represents the name of the field which contains the size of the original file.
SourceWidth | Represents the name of the field which contains the width of the original file.
SourceXResolution | Represents the name of the field which contains a horizontal resolution of the original file.
SourceYResolution | Represents the name of the field which contains a vertical resolution of the original file.
Tag | Represents the name of the field which contains a tag of the original file.


PostFields Fields

The PostFields type exposes the following fields.

Fields

Name | Description
Angle | Represents the name of the field which contains a rotation angle.
CropBounds | Represents the name of the field which contains bounds of cropped area.
Description | Represents the name of the field which contains a user-provided description of the original file.
File | Represents the name of the field which contains a converted file.
FileChunkCount | Represents the name of the field which contains a number of chunks on which the converted file was divided.
FileChunkIndex | Represents the name of the field which contains a zero-based index of the chunk.
FileHeight | Represents the name of the field which contains an actual height of the converted file.
FileMode | Represents the name of the field which contains the mode of the converted file.
FileName | Represents the name of the field which contains the name of the converted file.
FileSize | Represents the name of the field which contains the size of the converted file.
FileWidth | Represents the name of the field which contains an actual width of the converted file.
PackageComplete | Represents the name of the field which is sent in the end of the package.
PackageCount | Represents the name of the field which contains a total number of packages (i.e. requests) in the current upload session.
PackageFileCount | Represents the name of the field which contains the number of files uploaded in the current package.
PackageGuid | Represents the name of the field which contains a unique identifier of the current upload session.
PackageIndex | Represents the name of the field which contains a zero-based index of the package inside the current upload session.
RequestComplete | Represents the name of the field which is sent in the end of the upload request.
SourceCreatedDateTime | Represents the name of the field which contains a creation date of the original file.
SourceCreatedDateTimeLocal | Represents the name of the field which contains a local creation date of the original file.
SourceHeight | Represents the name of the field which contains the height of the original file.
SourceLastModifiedDateTime | Represents the name of the field which contains a last modification date of the original file.
SourceLastModifiedDateTimeLocal | Represents the name of the field which contains a local last modification date of the original file.
SourceName | Represents the name of the field which contains the name of the original file.
SourceSize | Represents the name of the field which contains the size of the original file.
SourceWidth | Represents the name of the field which contains the width of the original file.
SourceXResolution | Represents the name of the field which contains a horizontal resolution of the original file.
SourceYResolution | Represents the name of the field which contains a vertical resolution of the original file.
Tag | Represents the name of the field which contains a tag of the original file.


PostFields.Angle Field

Represents the name of the field which contains a rotation angle.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • Angle


PostFields.CropBounds Field

Represents the name of the field which contains bounds of cropped area.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • CropBounds


PostFields.Description Field

Represents the name of the field which contains a user-provided description of the original file.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • Description


PostFields.File Field

Represents the name of the field which contains a converted file.

Remarks

The value of this field contains two placeholders:

first %d
replaced by the index of this file in the uploaded package.
second %d
replaced by the index of the converted file created for the user-selected file specified by the first placeholder.

See Also

Reference

  • File


PostFields.FileChunkCount Field

Represents the name of the field which contains a number of chunks on which the converted file was divided.

Remarks

The value of this field contains two placeholders:

first %d
replaced by the index of this file in the uploaded package.
second %d
replaced by the index of the converted file created for the user-selected file specified by the first placeholder.

See Also

Reference

  • FileChunkCount


PostFields.FileChunkIndex Field

Represents the name of the field which contains a zero-based index of the chunk.

Remarks

The value of this field contains two placeholders:

first %d
replaced by the index of this file in the uploaded package.
second %d
replaced by the index of the converted file created for the user-selected file specified by the first placeholder.

See Also

Reference

  • FileChunkIndex


PostFields.FileHeight Field

Represents the name of the field which contains an actual height of the converted file.

Remarks

The value of this field contains two placeholders:

first %d
replaced by the index of this file in the uploaded package.
second %d
replaced by the index of the converted file created for the user-selected file specified by the first placeholder.

See Also

Reference

  • FileHeight


PostFields.FileMode Field

Represents the name of the field which contains the mode of the converted file.

Remarks

The value of this field contains two placeholders:

first %d
replaced by the index of this file in the uploaded package.
second %d
replaced by the index of the converted file created for the user-selected file specified by the first placeholder.

See Also

Reference

  • FileMode


PostFields.FileName Field

Represents the name of the field which contains the name of the converted file.

Remarks

The value of this field contains two placeholders:

first %d
replaced by the index of this file in the uploaded package.
second %d
replaced by the index of the converted file created for the user-selected file specified by the first placeholder.

See Also

Reference

  • FileName


PostFields.FileSize Field

Represents the name of the field which contains the size of the converted file.

Remarks

The value of this field contains two placeholders:

first %d
replaced by the index of this file in the uploaded package.
second %d
replaced by the index of the converted file created for the user-selected file specified by the first placeholder.

See Also

Reference

  • FileSize


PostFields.FileWidth Field

Represents the name of the field which contains an actual width of the converted file.

Remarks

The value of this field contains two placeholders:

first %d
replaced by the index of this file in the uploaded package.
second %d
replaced by the index of the converted file created for the user-selected file specified by the first placeholder.

See Also

Reference

  • FileWidth


PostFields.PackageComplete Field

Represents the name of the field which is sent in the end of the package.

See Also

Reference

  • PackageComplete


PostFields.PackageCount Field

Represents the name of the field which contains a total number of packages (i.e. requests) in the current upload session.

See Also

Reference

  • PackageCount


PostFields.PackageFileCount Field

Represents the name of the field which contains the number of files uploaded in the current package.

See Also

Reference

  • PackageFileCount


PostFields.PackageGuid Field

Represents the name of the field which contains a unique identifier of the current upload session.

See Also

Reference

  • PackageGuid


PostFields.PackageIndex Field

Represents the name of the field which contains a zero-based index of the package inside the current upload session.

See Also

Reference

  • PackageIndex


PostFields.RequestComplete Field

Represents the name of the field which is sent in the end of the upload request.

See Also

Reference

  • RequestComplete


PostFields.SourceCreatedDateTime Field

Represents the name of the field which contains a creation date of the original file.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • SourceCreatedDateTime


PostFields.SourceCreatedDateTimeLocal Field

Represents the name of the field which contains a local creation date of the original file.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • SourceCreatedDateTimeLocal


PostFields.SourceHeight Field

Represents the name of the field which contains the height of the original file.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • SourceHeight


PostFields.SourceLastModifiedDateTime Field

Represents the name of the field which contains a last modification date of the original file.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • SourceLastModifiedDateTime


PostFields.SourceLastModifiedDateTimeLocal Field

Represents the name of the field which contains a local last modification date of the original file.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • SourceLastModifiedDateTimeLocal


PostFields.SourceName Field

Represents the name of the field which contains the name of the original file.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • SourceName


PostFields.SourceSize Field

Represents the name of the field which contains the size of the original file.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • SourceSize


PostFields.SourceWidth Field

Represents the name of the field which contains the width of the original file.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • SourceWidth


PostFields.SourceXResolution Field

Represents the name of the field which contains a horizontal resolution of the original file.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • SourceXResolution


PostFields.SourceYResolution Field

Represents the name of the field which contains a vertical resolution of the original file.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • SourceYResolution


PostFields.Tag Field

Represents the name of the field which contains a tag of the original file.

Remarks

The value of this field contains the following placeholder:

%d
replaced by the index of this file in the uploaded package.

See Also

Reference

  • Tag


QualityMeter Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the quality meter.

For a list of all members of this class, see QualityMeter Members.

Syntax

PHP

class QualityMeter {
}

Remarks

Note

Image Uploader Express and Professional disable quality meter functionality. See the Comparison of Image Uploader Editions topic for details.

See Also

Reference

  • QualityMeter Property
  • Aurigma.ImageUploader.QualityMeter ASP.NET Class
  • $au.qualityMeter JavaScript Class

Manual

  • Additional Controls and Indicators
  • Using Quality Meter


QualityMeter Members

  • Properties
  • Language Filter ( all languages )

The QualityMeter type exposes the following members.

Properties

 | Name | Description
Public property | AcceptableQualityColor | Gets or sets a color of the quality meter element which corresponds to the maximum acceptable print format
Public property | BackgroundColor | Gets or sets a background color of the quality meter.
Public property | BorderColor | Gets or sets a color of the quality meter border.
Public property | Formats | Gets or sets print formats for the quality meter.
Public property | Height | Gets or sets a height of each quality meter rectangle.
Public property | HighQualityColor | Gets or sets a color of the quality meter element which corresponds to the recommended print format.
Public property | LowQualityColor | Gets or sets a color of the quality meter element corresponding to the print format which is not recommended for printing.


QualityMeter Properties

  • Properties
  • Language Filter ( all languages )

The QualityMeter type exposes the following properties.

Properties

 | Name | Description
Public property | AcceptableQualityColor | Gets or sets a color of the quality meter element which corresponds to the maximum acceptable print format
Public property | BackgroundColor | Gets or sets a background color of the quality meter.
Public property | BorderColor | Gets or sets a color of the quality meter border.
Public property | Formats | Gets or sets print formats for the quality meter.
Public property | Height | Gets or sets a height of each quality meter rectangle.
Public property | HighQualityColor | Gets or sets a color of the quality meter element which corresponds to the recommended print format.
Public property | LowQualityColor | Gets or sets a color of the quality meter element corresponding to the print format which is not recommended for printing.


QualityMeter.AcceptableQualityColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the quality meter element which corresponds to the maximum acceptable print format

Syntax

PHP

public function getAcceptableQualityColor() {
}

public function setAcceptableQualityColor($value) {
}

Property Value

Type: string

The color of the quality meter element for acceptable print formats.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#ffc600".

Remarks

The quality of the print in this format will be good enough, but worse than for allowed print formats that is specified with the HighQualityColor.

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.AcceptableQualityColor ASP.NET Property
  • $au.qualityMeter.acceptableQualityColor JavaScript Property


QualityMeter.BackgroundColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of the quality meter.

Syntax

PHP

public function getBackgroundColor() {
}

public function setBackgroundColor($value) {
}

Property Value

Type: string

The background color of the quality meter.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#ffffff".

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.BackgroundColor ASP.NET Property
  • $au.qualityMeter.backgroundColor JavaScript Property


QualityMeter.BorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the quality meter border.

Syntax

PHP

public function getBorderColor() {
}

public function setBorderColor($value) {
}

Property Value

Type: string

The color of the quality meter border.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#154575".

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.BorderColor ASP.NET Property
  • $au.qualityMeter.borderColor JavaScript Property


QualityMeter.Formats Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets print formats for the quality meter.

Syntax

PHP

public function getFormats() {
}

public function setFormats($value) {
}

Property Value

Type: string

Print formats used in the quality meter. Format of this string is the following:

Format1 name,format1 width (pixels),format1 height (pixels),format1 acceptable ratio;Format2 name,format2 width (pixels),format2 height (pixels),format2 acceptable ratio;...

In other words:

  • Each format is defined with 4 mandatory parameters: name, width, height, and acceptable ratio.
  • Parameters are separated by comma.
  • Formats are separated by semicolon.

See the Remarks section for more details about syntax of this string.

If this property is not initialized or set to incorrect value no quality meter is displayed.

Default value is "".

Remarks

As mentioned above, each print format is described with four parameters:

Format name

Name of the print format which will be displayed as a tooltip when a mouse is hovering over an appropriate quality meter element.

If the format name contains semicolon or quotation mark characters enclose this format in single (' ') or double (" ") quotes. Additionally, quotation marks (both single ' and double ") inside the name should be escaped with a backslash. For example, to get a User's format name, set this format as follows:

"User\'s format,1800,1200,1.2";...

Format width
Minimum width (in pixels) which the photo should have to be interpreted as high quality for this print format (i.e. colored by the HighQualityColor value).
Format height
Minimum height (in pixels) which the photo should have to be interpreted as high quality for this print format (i.e. colored by the HighQualityColor value).
Acceptable ratio (further, AR)
Maximum acceptable ratio of format width (or height) and actual photo width (or height). If format width/photo width will be larger than AR, the photo will be interpreted as unacceptable for this print format.
Note

To be interpreted as high quality, the photo should have both width and height equal or larger than specified ones. Say, if width conforms to the limitation, but height does not, the photo will not be interpreted as high quality.

Example

Imagine we specify the following quality meter string:

PHP

$uploader->getQualityMeter()->setFormats("4x6 inches,1800,1200,1.2;6x8 inches,2400,1800,1.3;");

It means that you specify two formats: 4x6 inches (1200x1800 pixels if to print with resolution equal to 300 DPI) and 6x8 inches (1800x2400 pixels for 300 DPI). This way the quality meter will have two elements. The table below demonstrates the quality meter values for images of different size. Let us assume that the default values for the quality meter colors are used (allowed formats are green, acceptable - yellow, non-recommended ones are gray).

Image dimensions Quality meter colors Comment
2000x3000
  • 4x6 inches - Green
  • 6x8 inches - Green
Image dimensions exceed both format restrictions, so we can freely print it in both formats.
1500x2000
  • 4x6 inches - Green
  • 6x8 inches - Yellow

The dimensions are larger than 4x6 inches, but smaller than 6x8 inches. Now we should estimate if it can be printed with the acceptable quality in 6x8 format. To do it, calculate the ratio between the format dimensions and the actual image dimensions (we take a width for brevity):

1800/1500 = 1.2

Now we compare this value with the acceptable ratio (AR) specified as the fourth parameter. If this value is larger than AR, an image cannot be printed with this format, if otherwise - it is acceptable.

The AR specified for 6x8 inches is 1.3, thus it is acceptable and we mark a color meter with yellow.

1200x1800
  • 4x6 inches - Green
  • 6x8 inches - Gray

The dimensions conform 4x6 inches, but are smaller than 6x8 inches. This time if we calculate the ratio between the format dimensions and the actual image dimensions, we will get:

1800/1200 = 1.5

It is larger than the AR (which is equal to 1.3) and that is why if we print this image in the 6x8 inches format, we will get quite poor quality. So we mark this color meter item to gray (i.e. as "not recommended").

1024x1536
  • 4x6 inches - Yellow
  • 6x8 inches - Gray

The dimensions of this image are smaller than both formats. It is obviously too small for the 6x8 inches format, but let us check it for the 4x6 format:

1200/1024 = 1.171875

The AR for the 4x6 inches format is 1.2, i.e. this image acceptable for it, and the appropriate quality meter element is yellow.

96x96
  • 4x6 inches - Gray
  • 6x8 inches - Gray
It is obvious that this image is too small to be printed even on a matchbox, so both elements of the quality meter are gray.

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.Formats ASP.NET Property
  • $au.qualityMeter.formats JavaScript Property


QualityMeter.Height Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of each quality meter rectangle.

Syntax

PHP

public function getHeight() {
}

public function setHeight($value) {
}

Property Value

Type: integer

The height of each quality meter rectangle.

Default value is 11.

Remarks

If the quality meter height is larger than a thumbnail height (specified with the FolderPane.PreviewSize and UploadPane.PreviewSize properties), it is automatically shrunk down to fit this distance.

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.Height ASP.NET Property
  • $au.qualityMeter.height JavaScript Property


QualityMeter.HighQualityColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the quality meter element which corresponds to the recommended print format.

Syntax

PHP

public function getHighQualityColor() {
}

public function setHighQualityColor($value) {
}

Property Value

Type: string

The color of the quality meter element which corresponds to the recommended print format.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#5bc529".

Remarks

If the image will be printed in this format, the quality will be high (i.e. the printing machine will be able to print it with high resolution).

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.HighQualityColor ASP.NET Property
  • $au.qualityMeter.highQualityColor JavaScript Property


QualityMeter.LowQualityColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the quality meter element corresponding to the print format which is not recommended for printing.

Syntax

PHP

public function getLowQualityColor() {
}

public function setLowQualityColor($value) {
}

Property Value

Type: string

The color of the quality meter element corresponding to the print format which is not recommended for printing.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#ececec".

Remarks

If the image will be printed in this format, the quality will be unacceptable because printing machine will not be able to print it with high enough resolution.

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.LowQualityColor ASP.NET Property
  • $au.qualityMeter.lowQualityColor JavaScript Property


Restrictions Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class contains masks for allowed and denied file extensions and upload restrictions.

For a list of all members of this class, see Restrictions Members.

Syntax

PHP

class Restrictions {
}

See Also

Reference

  • Restrictions Property
  • Aurigma.ImageUploader.Restrictions ASP.NET Class
  • $au.restrictions JavaScript Class

Manual

  • Configuring Restriction Rules for Files


Restrictions Members

  • Properties
  • Language Filter ( all languages )

The Restrictions type exposes the following members.

Properties

 | Name | Description
Public property | DeniedFileMask | Gets or set a file mask for the files that are denied to be uploaded.
Public property | EnableCmyk | Gets or sets a value indicating whether it is impossible to select CMYK images for the upload.
Public property | FileMask | Gets or sets a file mask for the files which are allowed to be uploaded.
Public property | MaxFileCount | Gets or sets a maximum number of files allowed for upload per one session.
Public property | MaxFileSize | Gets or sets a maximum file size which is allowed for upload to the server.
Public property | MaxImageHeight | Gets or sets a maximum image height allowed for upload.
Public property | MaxImageWidth | Gets or sets a maximum image width allowed for upload.
Public property | MaxTotalFileSize | Gets or sets a maximum total file size allowed for upload.
Public property | MinFileCount | Gets or sets a minimum number of files allowed for upload per one session.
Public property | MinFileSize | Gets or sets a minimum file size allowed for upload.
Public property | MinImageHeight | Gets or sets a minimum image height allowed for upload.
Public property | MinImageWidth | Gets or sets a minimum image width allowed for upload.


Restrictions Properties

  • Properties
  • Language Filter ( all languages )

The Restrictions type exposes the following properties.

Properties

 | Name | Description
Public property | DeniedFileMask | Gets or set a file mask for the files that are denied to be uploaded.
Public property | EnableCmyk | Gets or sets a value indicating whether it is impossible to select CMYK images for the upload.
Public property | FileMask | Gets or sets a file mask for the files which are allowed to be uploaded.
Public property | MaxFileCount | Gets or sets a maximum number of files allowed for upload per one session.
Public property | MaxFileSize | Gets or sets a maximum file size which is allowed for upload to the server.
Public property | MaxImageHeight | Gets or sets a maximum image height allowed for upload.
Public property | MaxImageWidth | Gets or sets a maximum image width allowed for upload.
Public property | MaxTotalFileSize | Gets or sets a maximum total file size allowed for upload.
Public property | MinFileCount | Gets or sets a minimum number of files allowed for upload per one session.
Public property | MinFileSize | Gets or sets a minimum file size allowed for upload.
Public property | MinImageHeight | Gets or sets a minimum image height allowed for upload.
Public property | MinImageWidth | Gets or sets a minimum image width allowed for upload.


Restrictions.DeniedFileMask Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or set a file mask for the files that are denied to be uploaded.

Syntax

PHP

public function getDeniedFileMask() {
}

public function setDeniedFileMask($value) {
}

Property Value

Type: string

The file mask for the files that are denied to be uploaded. You can use the standard wildcards such as asterisk * (arbitrary substring) and question mark ? (arbitrary character). To specify several masks, separate them by semicolons, e.g. *.exe;*.asp;*.htm.

Default value is "".

See Also

Reference

  • FileNameNotAllowed Property
  • Aurigma.ImageUploader.Restrictions.DeniedFileMask ASP.NET Property
  • $au.restrictions.deniedFileMask JavaScript Property

Manual

  • Filtering Files by Names and Types


Restrictions.EnableCmyk Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is impossible to select CMYK images for the upload.

Syntax

PHP

public function getEnableCmyk() {
}

public function setEnableCmyk($value) {
}

Property Value

Type: boolean

If false, a user cannot select CMYK images for the upload. Otherwise, CMYK images are allowed to be uploaded.

Default value is true.

See Also

Reference

  • CmykImagesNotAllowed Property
  • Aurigma.ImageUploader.Restrictions.EnableCmyk ASP.NET Property
  • $au.restrictions.enableCmyk JavaScript Property

Manual

  • Setting Limitations for Images


Restrictions.FileMask Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a file mask for the files which are allowed to be uploaded.

Syntax

PHP

public function getFileMask() {
}

public function setFileMask($value) {
}

Property Value

Type: string

The file mask for the files which are allowed to be uploaded. You can use the standard wildcards such as asterisk * (arbitrary substring) and question mark ? (arbitrary character). To specify several masks, separate them by semicolons, e.g. *.jpg;*.jpeg;*.jpe. To display all possible files, use *.*.

Default value is "*.*".

See Also

Reference

  • FileNameNotAllowed Property
  • Aurigma.ImageUploader.Restrictions.FileMask ASP.NET Property
  • $au.restrictions.fileMask JavaScript Property

Manual

  • Filtering Files by Names and Types


Restrictions.MaxFileCount Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum number of files allowed for upload per one session.

Syntax

PHP

public function getMaxFileCount() {
}

public function setMaxFileCount($value) {
}

Property Value

Type: integer

The maximum file count allowed for upload per one session. If the value is 0 then there is no limit.

Default value is 0.

Remarks

Note

Image Uploader Express restricts the maximum number of user-selected files to 100. See the Comparison of Image Uploader Editions topic for details.

See Also

Reference

  • MaxFileCountExceeded Property
  • Aurigma.ImageUploader.Restrictions.MaxFileCount ASP.NET Property
  • $au.restrictions.maxFileCount JavaScript Property

Manual

  • Setting Limitations for Size and Number of Files


Restrictions.MaxFileSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum file size which is allowed for upload to the server.

Syntax

PHP

public function getMaxFileSize() {
}

public function setMaxFileSize($value) {
}

Property Value

Type: integer

The maximum size (in bytes) for files allowed for upload. If the value is 0 then there is no limit.

Note

When you set the value that is more than 2 Gb, it is recommended to pass such value as a string.

Default value is 0.

Remarks

Note

Image Uploader Express restricts the maximum size of each user-selected file to 100 Mb. Image Uploader Professional and Print restrict the maximum size of each user-selected file to 2 Gb. See the Comparison of Image Uploader Editions topic for details.

This property limits only a single file. If you want to set limit for all selected files, use the MaxTotalFileSize property.

See Also

Reference

  • MaxFileSizeExceeded Property
  • Aurigma.ImageUploader.Restrictions.MaxFileSize ASP.NET Property
  • $au.restrictions.maxFileSize JavaScript Property

Manual

  • Setting Limitations for Size and Number of Files


Restrictions.MaxImageHeight Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum image height allowed for upload.

Syntax

PHP

public function getMaxImageHeight() {
}

public function setMaxImageHeight($value) {
}

Property Value

Type: integer

The maximum allowed image height (in pixels). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • DimensionsTooLarge Property
  • Aurigma.ImageUploader.Restrictions.MaxImageHeight ASP.NET Property
  • $au.restrictions.maxImageHeight JavaScript Property

Manual

  • Setting Limitations for Images


Restrictions.MaxImageWidth Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum image width allowed for upload.

Syntax

PHP

public function getMaxImageWidth() {
}

public function setMaxImageWidth($value) {
}

Property Value

Type: integer

The maximum allowed image width (in pixels). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • DimensionsTooLarge Property
  • Aurigma.ImageUploader.Restrictions.MaxImageWidth ASP.NET Property
  • $au.restrictions.maxImageWidth JavaScript Property

Manual

  • Setting Limitations for Images


Restrictions.MaxTotalFileSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum total file size allowed for upload.

Syntax

PHP

public function getMaxTotalFileSize() {
}

public function setMaxTotalFileSize($value) {
}

Property Value

Type: integer

The maximum size (in bytes) of all files selected for upload. If the value is 0 then there is no limit.

Note

When you set the value that is more than 2 Gb, it is recommended to pass such value as a string.

Default value is 0.

Remarks

Note

Only original file sizes are taken into account. Size of converted files and other auxiliary data is disregarded. So this property is useful when you upload original files without applying any client-side file transformations.

See Also

Reference

  • MaxTotalFileSizeExceeded Property
  • Aurigma.ImageUploader.Restrictions.MaxTotalFileSize ASP.NET Property
  • $au.restrictions.maxTotalFileSize JavaScript Property

Manual

  • Setting Limitations for Size and Number of Files


Restrictions.MinFileCount Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum number of files allowed for upload per one session.

Syntax

PHP

public function getMinFileCount() {
}

public function setMinFileCount($value) {
}

Property Value

Type: integer

The minimum file count allowed for upload per one session.

Default value is 1.

Remarks

Note

The Upload button is disabled if the number of files selected for upload less than this value.

See Also

Reference

  • Aurigma.ImageUploader.Restrictions.MinFileCount ASP.NET Property
  • $au.restrictions.minFileCount JavaScript Property

Manual

  • Setting Limitations for Size and Number of Files


Restrictions.MinFileSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum file size allowed for upload.

Syntax

PHP

public function getMinFileSize() {
}

public function setMinFileSize($value) {
}

Property Value

Type: integer

The minimum allowed file size (in bytes). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • FileSizeTooSmall Property
  • Aurigma.ImageUploader.Restrictions.MinFileSize ASP.NET Property
  • $au.restrictions.minFileSize JavaScript Property

Manual

  • Setting Limitations for Size and Number of Files


Restrictions.MinImageHeight Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum image height allowed for upload.

Syntax

PHP

public function getMinImageHeight() {
}

public function setMinImageHeight($value) {
}

Property Value

Type: integer

The minimum allowed image height (in pixels). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • DimensionsTooSmall Property
  • Aurigma.ImageUploader.Restrictions.MinImageHeight ASP.NET Property
  • $au.restrictions.minImageHeight JavaScript Property

Manual

  • Setting Limitations for Images


Restrictions.MinImageWidth Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum image width allowed for upload.

Syntax

PHP

public function getMinImageWidth() {
}

public function setMinImageWidth($value) {
}

Property Value

Type: integer

The minimum allowed image width (in pixels). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • DimensionsTooSmall Property
  • Aurigma.ImageUploader.Restrictions.MinImageWidth ASP.NET Property
  • $au.restrictions.minImageWidth JavaScript Property

Manual

  • Setting Limitations for Images


StatusPane Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the status pane.

For a list of all members of this class, see StatusPane Members.

Syntax

PHP

class StatusPane {
}

See Also

Reference

  • StatusPane Property
  • Aurigma.ImageUploader.StatusPane ASP.NET Class
  • $au.statusPane JavaScript Class

Manual

  • Customizing Appearance


StatusPane Members

  • Properties
  • Language Filter ( all languages )

The StatusPane type exposes the following members.

Properties

 | Name | Description
Public property | ClearAllHyperlinkText | Gets or sets a text of the Clear all hyperlink.
Public property | Color | Gets or sets a color of the status pane.
Public property | FilesToUploadText | Gets or sets a text on the status pane which is displayed when at least one file is added to the upload pane.
Public property | NoFilesToUploadText | Gets or sets a text on the status pane which is displayed when the upload pane is empty.
Public property | ProgressBarText | Gets or sets a text displayed in the progress bar during the upload if the instant upload feature is used.


StatusPane Properties

  • Properties
  • Language Filter ( all languages )

The StatusPane type exposes the following properties.

Properties

 | Name | Description
Public property | ClearAllHyperlinkText | Gets or sets a text of the Clear all hyperlink.
Public property | Color | Gets or sets a color of the status pane.
Public property | FilesToUploadText | Gets or sets a text on the status pane which is displayed when at least one file is added to the upload pane.
Public property | NoFilesToUploadText | Gets or sets a text on the status pane which is displayed when the upload pane is empty.
Public property | ProgressBarText | Gets or sets a text displayed in the progress bar during the upload if the instant upload feature is used.


StatusPane.ClearAllHyperlinkText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text of the Clear all hyperlink.

Syntax

PHP

public function getClearAllHyperlinkText() {
}

public function setClearAllHyperlinkText($value) {
}

Property Value

Type: string

The text of the Clear all hyperlink.

Default value is "clear all".

Remarks

By clicking this link, a user can remove all the files from the upload pane.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.StatusPane.ClearAllHyperlinkText ASP.NET Property
  • $au.statusPane.clearAllHyperlinkText JavaScript Property


StatusPane.Color Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the status pane.

Syntax

PHP

public function getColor() {
}

public function setColor($value) {
}

Property Value

Type: string

The color of the status pane.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is "#f7f7f7;#efefef".

See Also

Reference

  • Aurigma.ImageUploader.StatusPane.Color ASP.NET Property
  • $au.statusPane.color JavaScript Property


StatusPane.FilesToUploadText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text on the status pane which is displayed when at least one file is added to the upload pane.

Syntax

PHP

public function getFilesToUploadText() {
}

public function setFilesToUploadText($value) {
}

Property Value

Type: string

The text stating how many files are added to the upload pane. It can contain the following placeholder:

[count]
replaced by the number of files actually added to the upload pane.

Default value is "Files selected to upload: [count]".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.StatusPane.FilesToUploadText ASP.NET Property
  • $au.statusPane.filesToUploadText JavaScript Property


StatusPane.NoFilesToUploadText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text on the status pane which is displayed when the upload pane is empty.

Syntax

PHP

public function getNoFilesToUploadText() {
}

public function setNoFilesToUploadText($value) {
}

Property Value

Type: string

The text stating that the upload pane is empty.

Default value is "No files to upload".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.StatusPane.NoFilesToUploadText ASP.NET Property
  • $au.statusPane.noFilesToUploadText JavaScript Property


StatusPane.ProgressBarText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text displayed in the progress bar during the upload if the instant upload feature is used.

Syntax

PHP

public function getProgressBarText() {
}

public function setProgressBarText($value) {
}

Property Value

Type: string

The text displaying a total percentage of the upload progress. It can contain the following placeholder:

[percents]
replaced by the total percentage of the upload progress.

Default value is "Uploading ([percents]%)".

Remarks

This property makes sense only if the EnableInstantUpload property is true.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • EnableInstantUpload Property
  • Aurigma.ImageUploader.StatusPane.ProgressBarText ASP.NET Property
  • $au.statusPane.progressBarText JavaScript Property


Thumbnail Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a standalone thumbnail bound with some upload pane item of Image Uploader.

For a list of all members of this class, see Thumbnail Members.

Syntax

PHP

class Thumbnail extends BaseControl {
}

Remarks

Note

Image Uploader Express disables the Thumbnail control.

This control can be used to build a custom upload list. For example, you can add extra fields for each item or design new upload list layout.

The idea is the following:

  1. Insert this control instance to the necessary position in HTML.
  2. Associate the control with an instance of Uploader which contains the upload list where to bind items from. You can do it using the ParentControlName property.
  3. Bind the control with some item from the upload list using the Guid property.

Inheritance Hierarchy

BaseControl LThumbnail

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail ASP.NET Class
  • $au.thumbnail JavaScript Class


Thumbnail Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The Thumbnail type exposes the following members.

Constructors

 | Name | Description
Public method | BaseControl(string) | Creates and initializes an instance of the BaseControl class. (Inherited from BaseControl.)

Methods

 | Name | Description
Public method | render | Generates the control embedding code and writes it into the page. (Inherited from BaseControl.)

Properties

 | Name | Description
Public property | ActiveXControl | Gets or sets the ActiveX control settings.
Public property | BackgroundColor | Gets or sets a background color of this Thumbnail instance.
Public property | ClientEvents | Gets or sets a collection of client-side events.
Public property | DebugScriptLevel | Gets or sets a debug level. (Inherited from BaseControl.)
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0. (Inherited from BaseControl.)
Public property | Guid | Gets or sets a unique identifier (GUID) of the item which is represented with this Thumbnail instance.
Public property | Height | Gets or sets a height of this Thumbnail instance.
Public property | ID | Gets or sets an ID of the control that is used to get a reference to this control. (Inherited from BaseControl.)
Public property | JavaControl | Gets or sets the Java applet settings.
Public property | ParentControlName | The Uploader control name this Thumbnail instance is associated with.
Public property | ScriptsDirectory | Gets or sets a URL from which a stand-alone aurigma.uploader.js file will be downloaded. (Inherited from BaseControl.)
Public property | Width | Gets or sets a width of this Thumbnail instance.


Thumbnail Methods

  • Methods
  • Language Filter ( all languages )

The Thumbnail type exposes the following methods.

Methods

 | Name | Description
Public method | render | Generates the control embedding code and writes it into the page. (Inherited from BaseControl.)


Thumbnail Properties

  • Properties
  • Language Filter ( all languages )

The Thumbnail type exposes the following properties.

Properties

 | Name | Description
Public property | ActiveXControl | Gets or sets the ActiveX control settings.
Public property | BackgroundColor | Gets or sets a background color of this Thumbnail instance.
Public property | ClientEvents | Gets or sets a collection of client-side events.
Public property | DebugScriptLevel | Gets or sets a debug level. (Inherited from BaseControl.)
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0. (Inherited from BaseControl.)
Public property | Guid | Gets or sets a unique identifier (GUID) of the item which is represented with this Thumbnail instance.
Public property | Height | Gets or sets a height of this Thumbnail instance.
Public property | ID | Gets or sets an ID of the control that is used to get a reference to this control. (Inherited from BaseControl.)
Public property | JavaControl | Gets or sets the Java applet settings.
Public property | ParentControlName | The Uploader control name this Thumbnail instance is associated with.
Public property | ScriptsDirectory | Gets or sets a URL from which a stand-alone aurigma.uploader.js file will be downloaded. (Inherited from BaseControl.)
Public property | Width | Gets or sets a width of this Thumbnail instance.


Thumbnail.ActiveXControl Property

  • Supported browsers: Internet Explorer

Gets or sets the ActiveX control settings.

Syntax

PHP

public function getActiveXControl() {
}

public function setActiveXControl($value) {
}

Property Value

Type: ActiveXControl

The ActiveX control settings.

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.ActiveXControl ASP.NET Property
  • $au.thumbnail.activeXControl JavaScript Property


Thumbnail.BackgroundColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of this Thumbnail instance.

Syntax

PHP

public function getBackgroundColor() {
}

public function setBackgroundColor($value) {
}

Property Value

Type: string

The background color of the Thumbnail control.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#ffffff".

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.BackgroundColor ASP.NET Property
  • $au.thumbnail.backgroundColor JavaScript Property


Thumbnail.ClientEvents Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a collection of client-side events.

Syntax

PHP

public function getClientEvents() {
}

public function setClientEvents($value) {
}

Property Value

Type: ThumbnailClientEvents

The collection of client-side events.

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.ClientEvents ASP.NET Property
  • $au.thumbnail.events JavaScript Property


Thumbnail.Guid Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a unique identifier (GUID) of the item which is represented with this Thumbnail instance.

Syntax

PHP

public function getGuid() {
}

public function setGuid($value) {
}

Property Value

Type: string

The GUID of the item which is represented with the Thumbnail control.

Default value is "".

Remarks

Before binding the Thumbnail with some upload list item, you should specify the parent Uploader control. You can do it using the ParentControlName property.

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.Guid ASP.NET Property
  • $au.thumbnail.guid JavaScript Property


Thumbnail.Height Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of this Thumbnail instance.

Syntax

PHP

public function getHeight() {
}

public function setHeight($value) {
}

Property Value

Type: string

The height of the Thumbnail control.

Default value is "100px".

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.Height ASP.NET Property
  • $au.thumbnail.height JavaScript Property


Thumbnail.JavaControl Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets the Java applet settings.

Syntax

PHP

public function getJavaControl() {
}

public function setJavaControl($value) {
}

Property Value

Type: JavaControl

The Java applet settings.

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.JavaControl ASP.NET Property
  • $au.thumbnail.javaControl JavaScript Property


Thumbnail.ParentControlName Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

The Uploader control name this Thumbnail instance is associated with.

Syntax

PHP

public function getParentControlName() {
}

public function setParentControlName($value) {
}

Property Value

Type: string

Gets or sets a name of the Uploader control this Thumbnail instance is associated with.

Default value is "".

Remarks

After you associate this Thumbnail control with a parent Uploader, you should bind it with some item from the upload list. To do it, set the Guid property to the GUID of this item. You can get it using the file.guid property.

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.ParentControlName ASP.NET Property
  • $au.thumbnail.parentControlName JavaScript Property


Thumbnail.Width Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of this Thumbnail instance.

Syntax

PHP

public function getWidth() {
}

public function setWidth($value) {
}

Property Value

Type: string

The width of the Thumbnail control.

Default value is "100px".

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.Width ASP.NET Property
  • $au.thumbnail.width JavaScript Property


ThumbnailClientEvents Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class provides access to client-side events of the Thumbnail control.

For a list of all members of this class, see ThumbnailClientEvents Members.

Syntax

PHP

class ThumbnailClientEvents {
}

See Also

Reference

  • $au.thumbnailEvents JavaScript Class


ThumbnailClientEvents Members

  • Properties
  • Language Filter ( all languages )

The ThumbnailClientEvents type exposes the following members.

Properties

 | Name | Description
Public property | Click | Gets or sets an array of Click event handlers.
Public property | InitComplete | Gets or sets an array of InitComplete event handlers.
Public property | PreRender | Gets or sets an array of PreRender event handlers.


ThumbnailClientEvents Properties

  • Properties
  • Language Filter ( all languages )

The ThumbnailClientEvents type exposes the following properties.

Properties

 | Name | Description
Public property | Click | Gets or sets an array of Click event handlers.
Public property | InitComplete | Gets or sets an array of InitComplete event handlers.
Public property | PreRender | Gets or sets an array of PreRender event handlers.


ThumbnailClientEvents.Click Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of Click event handlers.

Syntax

PHP

public function &getClick() {
}

public function setClick($value) {
}

Property Value

Type: array

The string containing a name of Click event handler or an array of handler names.

Remarks

This event fires when the Thumbnail control is clicked.

See Also

Reference

  • Click Client-Side Event
  • $au.thumbnailEvents.click JavaScript Property


ThumbnailClientEvents.InitComplete Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of InitComplete event handlers.

Syntax

PHP

public function &getInitComplete() {
}

public function setInitComplete($value) {
}

Property Value

Type: array

The string containing a name of InitComplete event handler or an array of handler names.

Remarks

This event fires when the Thumbnail control is completely created and initialized.

See Also

Reference

  • InitComplete Client-Side Event
  • $au.thumbnailEvents.initComplete JavaScript Property


ThumbnailClientEvents.PreRender Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of PreRender event handlers.

Syntax

PHP

public function &getPreRender() {
}

public function setPreRender($value) {
}

Property Value

Type: array

The string containing a name of PreRender event handler or an array of handler names.

Remarks

This event fires before the writeHtml() or getHtml() method is executed.

See Also

Reference

  • PreRender Client-Side Event
  • $au.thumbnailEvents.preRender JavaScript Property


TreePane Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the tree pane.

For a list of all members of this class, see TreePane Members.

Syntax

PHP

class TreePane {
}

See Also

Reference

  • TreePane Property
  • Aurigma.ImageUploader.TreePane ASP.NET Class
  • $au.treePane JavaScript Class

Manual

  • Layouts


TreePane Members

  • Properties
  • Language Filter ( all languages )

The TreePane type exposes the following members.

Properties

 | Name | Description
Public property | TitleText | Gets or sets a title of the tree pane.
Public property | UnixFileSystemRootText | Gets or sets a caption of the folder tree node which specifies the system directory at *NIX systems.
Public property | UnixHomeDirectoryText | Gets or sets a caption of the folder tree node which specifies the home directory at *NIX systems.
Public property | Width | Gets or sets a width of the tree pane.


TreePane Properties

  • Properties
  • Language Filter ( all languages )

The TreePane type exposes the following properties.

Properties

 | Name | Description
Public property | TitleText | Gets or sets a title of the tree pane.
Public property | UnixFileSystemRootText | Gets or sets a caption of the folder tree node which specifies the system directory at *NIX systems.
Public property | UnixHomeDirectoryText | Gets or sets a caption of the folder tree node which specifies the home directory at *NIX systems.
Public property | Width | Gets or sets a width of the tree pane.


TreePane.TitleText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the tree pane.

Syntax

PHP

public function getTitleText() {
}

public function setTitleText($value) {
}

Property Value

Type: string

The title of the tree pane.

Default value is "Folders".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.TreePane.TitleText ASP.NET Property
  • $au.treePane.titleText JavaScript Property


TreePane.UnixFileSystemRootText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the folder tree node which specifies the system directory at *NIX systems.

Syntax

PHP

public function getUnixFileSystemRootText() {
}

public function setUnixFileSystemRootText($value) {
}

Property Value

Type: string

The caption of the folder tree node which specifies the system directory at *NIX systems.

Default value is "Filesystem".

Remarks

Note

This value is used only at Linux and different sorts of Unix. For Windows and Mac the system-dependent values are extracted and used.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UnixHomeDirectoryText Property
  • Aurigma.ImageUploader.TreePane.UnixFileSystemRootText ASP.NET Property
  • $au.treePane.unixFileSystemRootText JavaScript Property


TreePane.UnixHomeDirectoryText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the folder tree node which specifies the home directory at *NIX systems.

Syntax

PHP

public function getUnixHomeDirectoryText() {
}

public function setUnixHomeDirectoryText($value) {
}

Property Value

Type: string

The caption of the folder tree node which specifies the home directory at *NIX systems.

Default value is "Home Folder".

Remarks

Note

This value is used only at Linux and different sorts of Unix. For Windows and Mac the system-dependent values are extracted and used.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UnixFileSystemRootText Property
  • Aurigma.ImageUploader.TreePane.UnixHomeDirectoryText ASP.NET Property
  • $au.treePane.unixHomeDirectoryText JavaScript Property


TreePane.Width Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of the tree pane.

Syntax

PHP

public function getWidth() {
}

public function setWidth($value) {
}

Property Value

Type: integer

The width of the tree pane (in pixels).

Default value is 200.

See Also

Reference

  • Aurigma.ImageUploader.TreePane.Width ASP.NET Property
  • $au.treePane.width JavaScript Property


UploadedFile Class

This class provides an access to all the converted files and metadata related to a particular user-selected file.

For a list of all members of this class, see UploadedFile Members.

Syntax

PHP

class UploadedFile {
}

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile ASP.NET Class

Manual

  • Saving Uploaded Files in PHP


UploadedFile Members

  • Properties
  • Language Filter ( all languages )

The UploadedFile type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets a rotation angle of this user-selected file (measured in degrees clockwise).
Public property | ConvertedFiles | Gets an array of converted files created for this user-selected file.
Public property | CropBounds | Gets a crop bounds of this user-selected file if it is an image.
Public property | Description | Gets a user-provided description of this user-selected file.
Public property | Index | Gets index of this user-selected file within a package.
Public property | Package | Gets a Package instance related to this user-selected file.
Public property | RelativePath | Gets a relative path to this user-selected file on the client machine.
Public property | SourceCreatedDateTime | Gets a creation date of this user-selected file.
Public property | SourceCreatedDateTimeLocal | Gets a local creation date of this user-selected file.
Public property | SourceHeight | Gets a height of this user-selected file (in pixels) if it is an image.
Public property | SourceLastModifiedDateTime | Gets a last modification date of this user-selected file.
Public property | SourceLastModifiedDateTimeLocal | Gets a local last modification date of this user-selected file.
Public property | SourceName | Gets a name of this user-selected file.
Public property | SourceSize | Gets a size of this user-selected file in bytes.
Public property | SourceWidth | Gets a width of this user-selected file (in pixels) if it is an image.
Public property | SourceXResolution | Gets a horizontal resolution of this user-selected file (measured in DPI - dots per inches) if it is an image.
Public property | SourceYResolution | Gets a vertical resolution of this user-selected file (measured in DPI - dots per inches) if it is an image.
Public property | Tag | Gets a tag provided to this user-selected file.


UploadedFile Properties

  • Properties
  • Language Filter ( all languages )

The UploadedFile type exposes the following properties.

Properties

 | Name | Description
Public property | Angle | Gets a rotation angle of this user-selected file (measured in degrees clockwise).
Public property | ConvertedFiles | Gets an array of converted files created for this user-selected file.
Public property | CropBounds | Gets a crop bounds of this user-selected file if it is an image.
Public property | Description | Gets a user-provided description of this user-selected file.
Public property | Index | Gets index of this user-selected file within a package.
Public property | Package | Gets a Package instance related to this user-selected file.
Public property | RelativePath | Gets a relative path to this user-selected file on the client machine.
Public property | SourceCreatedDateTime | Gets a creation date of this user-selected file.
Public property | SourceCreatedDateTimeLocal | Gets a local creation date of this user-selected file.
Public property | SourceHeight | Gets a height of this user-selected file (in pixels) if it is an image.
Public property | SourceLastModifiedDateTime | Gets a last modification date of this user-selected file.
Public property | SourceLastModifiedDateTimeLocal | Gets a local last modification date of this user-selected file.
Public property | SourceName | Gets a name of this user-selected file.
Public property | SourceSize | Gets a size of this user-selected file in bytes.
Public property | SourceWidth | Gets a width of this user-selected file (in pixels) if it is an image.
Public property | SourceXResolution | Gets a horizontal resolution of this user-selected file (measured in DPI - dots per inches) if it is an image.
Public property | SourceYResolution | Gets a vertical resolution of this user-selected file (measured in DPI - dots per inches) if it is an image.
Public property | Tag | Gets a tag provided to this user-selected file.


UploadedFile.Angle Property

Gets a rotation angle of this user-selected file (measured in degrees clockwise).

Syntax

PHP

public function getAngle() {
}

Property Value

Type: string

The rotation angle of this user-selected file.

Remarks

This property is changed if a user clicks an arrow icon to rotate an image, or if the automatic EXIF rotation is enabled (see the EnableAutoRotation property for more details). You can use it if you want to rotate images on the server side (e.g. if you upload original files only). Possible values are:

  • 0
  • 90
  • 180
  • 270

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.Angle ASP.NET Property


UploadedFile.ConvertedFiles Property

Gets an array of converted files created for this user-selected file.

Syntax

PHP

public function getConvertedFiles() {
}

Property Value

Type: array

The array of converted files created for this user-selected file.

See Also

Reference

  • ConvertedFile Class
  • Aurigma.ImageUploader.UploadedFile.ConvertedFiles ASP.NET Property


UploadedFile.CropBounds Property

Gets a crop bounds of this user-selected file if it is an image.

Syntax

PHP

public function getCropBounds() {
}

Property Value

Type: string

The crop bounds of this user-selected file if it is an image. Otherwise, this property returns a 0 size rectangle.

The value has the following format: left,top,right,bottom.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.CropBounds ASP.NET Property


UploadedFile.Description Property

Gets a user-provided description of this user-selected file.

Syntax

PHP

public function getDescription() {
}

Property Value

Type: string

The user-provided description of this user-selected file.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.Description ASP.NET Property


UploadedFile.Index Property

Gets index of this user-selected file within a package.

Syntax

PHP

public function getIndex() {
}

Property Value

Type: integer

The index of this user-selected file within a package.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.Index ASP.NET Property


UploadedFile.Package Property

Gets a Package instance related to this user-selected file.

Syntax

PHP

public function getPackage() {
}

Property Value

Type: Package

The Package instance related to this user-selected file.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.Package ASP.NET Property


UploadedFile.RelativePath Property

Gets a relative path to this user-selected file on the client machine.

Syntax

PHP

public function getRelativePath() {
}

Property Value

Type: string

The relative path to this user-selected file.

Remarks

This property makes sense only if the folder upload feature is turned on (Uploader.FolderProcessingMode is upload) and the user-selected file is located inside a subfolder. In that case this property contains a relative path to this file and the SourceName represents its filename. For example, if the user sends a My Documents\My Photos\00001.jpg file its SourceName_i POST field will contain My Documents\My Photos\00001.jpg value. However, the RelativePath property will contain My Documents\My Photos\ value.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.RelativePath ASP.NET Property

Manual

  • Uploading Folders in PHP


UploadedFile.SourceCreatedDateTime Property

Gets a creation date of this user-selected file.

Syntax

PHP

public function getSourceCreatedDateTime() {
}

Property Value

Type: string

The creation date of this user-selected file.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.SourceCreatedDateTime ASP.NET Property


UploadedFile.SourceCreatedDateTimeLocal Property

Gets a local creation date of this user-selected file.

Syntax

PHP

public function getSourceCreatedDateTimeLocal() {
}

Property Value

Type: string

The local creation date of this user-selected file.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.SourceCreatedDateTimeLocal ASP.NET Property


UploadedFile.SourceHeight Property

Gets a height of this user-selected file (in pixels) if it is an image.

Syntax

PHP

public function getSourceHeight() {
}

Property Value

Type: string

The height of this user-selected file (in pixels) if it is an image. Otherwise, this property returns 0.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.SourceHeight ASP.NET Property


UploadedFile.SourceLastModifiedDateTime Property

Gets a last modification date of this user-selected file.

Syntax

PHP

public function getSourceLastModifiedDateTime() {
}

Property Value

Type: string

The last modification date of this user-selected file.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.SourceLastModifiedDateTime ASP.NET Property


UploadedFile.SourceLastModifiedDateTimeLocal Property

Gets a local last modification date of this user-selected file.

Syntax

PHP

public function getSourceLastModifiedDateTimeLocal() {
}

Property Value

Type: string

The local last modification date of this user-selected file.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.SourceLastModifiedDateTimeLocal ASP.NET Property


UploadedFile.SourceName Property

Gets a name of this user-selected file.

Syntax

PHP

public function getSourceName() {
}

Property Value

Type: string

The name of this user-selected file.

Remarks

It is useful to employ this property to get name of the original file when only resized copy of an image is uploaded.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.SourceName ASP.NET Property


UploadedFile.SourceSize Property

Gets a size of this user-selected file in bytes.

Syntax

PHP

public function getSourceSize() {
}

Property Value

Type: string

The size of this user-selected file in bytes.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.SourceSize ASP.NET Property


UploadedFile.SourceWidth Property

Gets a width of this user-selected file (in pixels) if it is an image.

Syntax

PHP

public function getSourceWidth() {
}

Property Value

Type: string

The width of this user-selected file (in pixels) it it is an image. Otherwise, this property returns 0.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.SourceWidth ASP.NET Property


UploadedFile.SourceXResolution Property

Gets a horizontal resolution of this user-selected file (measured in DPI - dots per inches) if it is an image.

Syntax

PHP

public function getSourceXResolution() {
}

Property Value

Type: string

The horizontal resolution of this user-selected file (in DPI) if it is an image. Otherwise, this property returns 0.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.SourceXResolution ASP.NET Property


UploadedFile.SourceYResolution Property

Gets a vertical resolution of this user-selected file (measured in DPI - dots per inches) if it is an image.

Syntax

PHP

public function getSourceYResolution() {
}

Property Value

Type: string

The vertical resolution of this user-selected file (in DPI) if it is an image. Otherwise, this property returns 0.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.SourceYResolution ASP.NET Property


UploadedFile.Tag Property

Gets a tag provided to this user-selected file.

Syntax

PHP

public function getTag() {
}

Property Value

Type: string

The tag provided to this user-selected file.

See Also

Reference

  • Aurigma.ImageUploader.UploadedFile.Tag ASP.NET Property


Uploader Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class is intended for embedding Image Uploader into PHP applications.

For a list of all members of this class, see Uploader Members.

Syntax

PHP

class Uploader extends BaseControl {
}

Remarks

This class allows configuring Image Uploader as a common PHP object and handling uploaded data without parsing the POST request. To configure Image Uploader appearance and its upload format this class exposes a number of properties. To handle uploaded data Image Uploader PHP implements the UploadHandler class which provides the FileUploadedCallback parameter to specify a callback function. This function will be invoked whenever all the converted files and metadata related to a particular user-selected file are successfully uploaded. All the uploaded data is available through the UploadedFile properties.

Inheritance Hierarchy

BaseControl LUploader

See Also

Reference

  • Aurigma.ImageUploader.Uploader ASP.NET Class
  • $au.uploader JavaScript Class

Manual

  • Quick Start with Image Uploader PHP


Uploader Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The Uploader type exposes the following members.

Constructors

 | Name | Description
Public method | BaseControl(string) | Creates and initializes an instance of the BaseControl class. (Inherited from BaseControl.)

Methods

 | Name | Description
Public method | render | Generates the control embedding code and writes it into the page. (Inherited from BaseControl.)

Properties

 | Name | Description
Public property | ActiveXControl | Gets or sets Image Uploader ActiveX control settings.
Public property | AddFilesProgressDialog | Gets or sets settings of the dialog which appears when a user selects quite a lot of files.
Public property | AuthenticationDialog | Gets or sets settings of the authentication dialog.
Public property | AuxiliaryTextColor | Gets or sets a color of auxiliary text lables.
Public property | BackgroundColor | Gets or sets a background color of Image Uploader panes and editors.
Public property | BorderStyle | Gets or sets a border style of Image Uploader.
Public property | CancelUploadButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Cancel button.
Public property | CancelUploadButtonText | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the button which aborts the upload.
Public property | ClientEvents | Gets or sets a collection of client-side events.
Public property | ContextMenu | Gets or sets the context menu settings.
Public property | Converters | Gets or sets a collection of converters.
Public property | DebugScriptLevel | Gets or sets a debug level. (Inherited from BaseControl.)
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0. (Inherited from BaseControl.)
Public property | DeleteFilesDialog | Gets or sets the settings of the delete confirmation dialog.
Public property | DescriptionEditor | Gets or sets the description editor settings.
Public property | DetailsViewColumns | Gets or sets titles of columns displayed in the Details view.
Public property | DialogBorderColor | Gets or sets a color of a dialog border.
Public property | DialogColor | Gets or sets a color of Image Uploader dialogs.
Public property | EnableAutoRotation | Gets or sets a value indicating whether the automatic EXIF-based photo rotation feature is enabled.
Public property | EnableContextMenu | Gets or sets a value indicating whether to disaplay the context menu.
Public property | EnableDescriptionEditor | Gets or sets a value indicating whether it is possible to add descriptions to files.
Public property | EnableDragAndDrop | Gets or sets a value indicating whether internal drag-and-drop operations are supported.
Public property | EnableFileViewer | Gets or sets a value indicating whether to open the file in associated viewer software when it is double-clicked.
Public property | EnableImageEditor | Gets or sets a value indicating whether it is possible to open images in the image editor by clicking the image editor icon or the corresponging context menu option.
Public property | EnableOriginalFilesDeletion | Gets or sets a value indicating whether successfully uploaded files should be deleted.
Public property | EnableRotation | Gets or sets a value indicating whether it is possible to rotate images via Image Uploader GUI.
Public property | EnableStatusPane | Gets or sets a value indicating whether the status pane should be displayed.
Public property | EnableUploadPane | Gets or sets a value indicating whether the upload pane should be displayed.
Public property | EnableUploadProgress | Gets or sets a value indicating whether the uploading files dialog is shown during the upload.
Public property | FolderPane | Gets or sets the folder pane settings.
Public property | FolderProcessingMode | Gets or sets the folder processing mode.
Public property | HeaderColor | Gets or sets a color of Image Uploader headers.
Public property | HeaderTextColor | Gets or sets a color of text in Image Uploader headers.
Public property | Height | Gets or sets a height of the control.
Public property | HyperlinkColor | Gets or sets a color of all the hyperlink elements.
Public property | ID | Gets or sets an ID of the control that is used to get a reference to this control. (Inherited from BaseControl.)
Public property | ImageEditor | Gets or sets the image editor settings.
Public property | InformationBar | Gets or sets the information bar settings.
Public property | JavaControl | Gets or sets Image Uploader Java applet settings.
Public property | Language | Gets or sets a control localization.
Public property | LicenseKey | Gets or sets a license key which allows evaluating, developing, or publishing Image Uploader according to the license key type (trial, development, or full).
Public property | LoadingFolderContentText | Gets or sets a text which is displayed while Image Uploader scans the folder content and builds the file list.
Public property | Messages | Gets or sets messages.
Public property | Metadata | Gets or sets an additional upload data.
Public property | PaneFont | Gets or sets a font format for all Image Uploader buttons and labels, except titles.
Public property | PaneItem | Gets or sets the pane item settings.
Public property | PaneLayout | Gets of sets Image Uploader layout.
Public property | PanelBorderColor | Gets or sets a color of borders between Image Uploader panes.
Public property | PanelColor | Gets or sets a color of command areas.
Public property | PasteFileNameTemplate | Gets or sets a file name template for files pasted from clipboard.
Public property | Restrictions | Gets or sets upload restrictions.
Public property | ScriptsDirectory | Gets or sets a URL from which a stand-alone aurigma.uploader.js file will be downloaded. (Inherited from BaseControl.)
Public property | StatusPane | Gets or sets the status pane settings.
Public property | TextColor | Gets or sets a color of primary labels.
Public property | TitleFont | Gets or sets a font format for Image Uploader titles.
Public property | TreePane | Gets or sets the tree pane settings.
Public property | UploadButtonImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Upload button.
Public property | UploadButtonText | Gets or sets a caption of the button which starts the upload of the selected files.
Public property | UploadPane | Gets the upload pane settings.
Public property | UploadProgressDialog | Gets or sets the upload progress dialog settings.
Public property | UploadSettings | Gets or sets upload settings.
Public property | Width | Gets or sets a width of the control.


Uploader Methods

  • Methods
  • Language Filter ( all languages )

The Uploader type exposes the following methods.

Methods

 | Name | Description
Public method | render | Generates the control embedding code and writes it into the page. (Inherited from BaseControl.)


Uploader Properties

  • Properties
  • Language Filter ( all languages )

The Uploader type exposes the following properties.

Properties

 | Name | Description
Public property | ActiveXControl | Gets or sets Image Uploader ActiveX control settings.
Public property | AddFilesProgressDialog | Gets or sets settings of the dialog which appears when a user selects quite a lot of files.
Public property | AuthenticationDialog | Gets or sets settings of the authentication dialog.
Public property | AuxiliaryTextColor | Gets or sets a color of auxiliary text lables.
Public property | BackgroundColor | Gets or sets a background color of Image Uploader panes and editors.
Public property | BorderStyle | Gets or sets a border style of Image Uploader.
Public property | CancelUploadButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Cancel button.
Public property | CancelUploadButtonText | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the button which aborts the upload.
Public property | ClientEvents | Gets or sets a collection of client-side events.
Public property | ContextMenu | Gets or sets the context menu settings.
Public property | Converters | Gets or sets a collection of converters.
Public property | DebugScriptLevel | Gets or sets a debug level. (Inherited from BaseControl.)
Public property | DebugScriptMode | Gets or sets a debug mode which will be used to display messages if the DebugScriptLevel is greater than 0. (Inherited from BaseControl.)
Public property | DeleteFilesDialog | Gets or sets the settings of the delete confirmation dialog.
Public property | DescriptionEditor | Gets or sets the description editor settings.
Public property | DetailsViewColumns | Gets or sets titles of columns displayed in the Details view.
Public property | DialogBorderColor | Gets or sets a color of a dialog border.
Public property | DialogColor | Gets or sets a color of Image Uploader dialogs.
Public property | EnableAutoRotation | Gets or sets a value indicating whether the automatic EXIF-based photo rotation feature is enabled.
Public property | EnableContextMenu | Gets or sets a value indicating whether to disaplay the context menu.
Public property | EnableDescriptionEditor | Gets or sets a value indicating whether it is possible to add descriptions to files.
Public property | EnableDragAndDrop | Gets or sets a value indicating whether internal drag-and-drop operations are supported.
Public property | EnableFileViewer | Gets or sets a value indicating whether to open the file in associated viewer software when it is double-clicked.
Public property | EnableImageEditor | Gets or sets a value indicating whether it is possible to open images in the image editor by clicking the image editor icon or the corresponging context menu option.
Public property | EnableOriginalFilesDeletion | Gets or sets a value indicating whether successfully uploaded files should be deleted.
Public property | EnableRotation | Gets or sets a value indicating whether it is possible to rotate images via Image Uploader GUI.
Public property | EnableStatusPane | Gets or sets a value indicating whether the status pane should be displayed.
Public property | EnableUploadPane | Gets or sets a value indicating whether the upload pane should be displayed.
Public property | EnableUploadProgress | Gets or sets a value indicating whether the uploading files dialog is shown during the upload.
Public property | FolderPane | Gets or sets the folder pane settings.
Public property | FolderProcessingMode | Gets or sets the folder processing mode.
Public property | HeaderColor | Gets or sets a color of Image Uploader headers.
Public property | HeaderTextColor | Gets or sets a color of text in Image Uploader headers.
Public property | Height | Gets or sets a height of the control.
Public property | HyperlinkColor | Gets or sets a color of all the hyperlink elements.
Public property | ID | Gets or sets an ID of the control that is used to get a reference to this control. (Inherited from BaseControl.)
Public property | ImageEditor | Gets or sets the image editor settings.
Public property | InformationBar | Gets or sets the information bar settings.
Public property | JavaControl | Gets or sets Image Uploader Java applet settings.
Public property | Language | Gets or sets a control localization.
Public property | LicenseKey | Gets or sets a license key which allows evaluating, developing, or publishing Image Uploader according to the license key type (trial, development, or full).
Public property | LoadingFolderContentText | Gets or sets a text which is displayed while Image Uploader scans the folder content and builds the file list.
Public property | Messages | Gets or sets messages.
Public property | Metadata | Gets or sets an additional upload data.
Public property | PaneFont | Gets or sets a font format for all Image Uploader buttons and labels, except titles.
Public property | PaneItem | Gets or sets the pane item settings.
Public property | PaneLayout | Gets of sets Image Uploader layout.
Public property | PanelBorderColor | Gets or sets a color of borders between Image Uploader panes.
Public property | PanelColor | Gets or sets a color of command areas.
Public property | PasteFileNameTemplate | Gets or sets a file name template for files pasted from clipboard.
Public property | Restrictions | Gets or sets upload restrictions.
Public property | ScriptsDirectory | Gets or sets a URL from which a stand-alone aurigma.uploader.js file will be downloaded. (Inherited from BaseControl.)
Public property | StatusPane | Gets or sets the status pane settings.
Public property | TextColor | Gets or sets a color of primary labels.
Public property | TitleFont | Gets or sets a font format for Image Uploader titles.
Public property | TreePane | Gets or sets the tree pane settings.
Public property | UploadButtonImageFormat | Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Upload button.
Public property | UploadButtonText | Gets or sets a caption of the button which starts the upload of the selected files.
Public property | UploadPane | Gets the upload pane settings.
Public property | UploadProgressDialog | Gets or sets the upload progress dialog settings.
Public property | UploadSettings | Gets or sets upload settings.
Public property | Width | Gets or sets a width of the control.


Uploader.ActiveXControl Property

  • Supported browsers: Internet Explorer

Gets or sets Image Uploader ActiveX control settings.

Syntax

PHP

public function getActiveXControl() {
}

public function setActiveXControl($value) {
}

Property Value

Type: ActiveXControl

Image Uploader ActiveX control settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.ActiveXControl ASP.NET Property
  • $au.uploader.activeXControl JavaScript Property

Manual

  • Using Private-label Version of Image Uploader PHP


Uploader.AddFilesProgressDialog Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets settings of the dialog which appears when a user selects quite a lot of files.

Syntax

PHP

public function getAddFilesProgressDialog() {
}

public function setAddFilesProgressDialog($value) {
}

Property Value

Type: AddFilesProgressDialog

Settings of the dialog which appears when a user selects quite a lot of files.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.AddFilesProgressDialog ASP.NET Property
  • $au.uploader.addFilesProgressDialog JavaScript Property


Uploader.AuthenticationDialog Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets settings of the authentication dialog.

Syntax

PHP

public function getAuthenticationDialog() {
}

public function setAuthenticationDialog($value) {
}

Property Value

Type: AuthenticationDialog

Settings of the authentication dialog.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.AuthenticationDialog ASP.NET Property
  • $au.uploader.authenticationDialog JavaScript Property


Uploader.AuxiliaryTextColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of auxiliary text lables.

Syntax

PHP

public function getAuxiliaryTextColor() {
}

public function setAuxiliaryTextColor($value) {
}

Property Value

Type: string

The color of of the following labels:

  • a prompt inside the search box;
  • a prompt inside the description editor;
  • file details in the Tiles view;
  • image details and a prompt in the image editor.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#8b8b8b".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.AuxiliaryTextColor ASP.NET Property
  • $au.uploader.auxiliaryTextColor JavaScript Property


Uploader.BackgroundColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of Image Uploader panes and editors.

Syntax

PHP

public function getBackgroundColor() {
}

public function setBackgroundColor($value) {
}

Property Value

Type: string

The background color of the following elements:

  • all the panes;
  • image editor;
  • description editor;
  • search box;
  • files adding and files uploading dialogs.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#ffffff".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.BackgroundColor ASP.NET Property
  • $au.uploader.backgroundColor JavaScript Property


Uploader.BorderStyle Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a border style of Image Uploader.

Syntax

PHP

public function getBorderStyle() {
}

public function setBorderStyle($value) {
}

Property Value

Type: string

The Image Uploader border style.

The following values are supported:

Value | Description
None | No border.
Fixed3D | 3D-like border style.
FixedSingle | Classic single line border style.

Default value is "Fixed3D".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.BorderStyle ASP.NET Property
  • $au.uploader.borderStyle JavaScript Property


Uploader.CancelUploadButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the Cancel button.

Syntax

PHP

public function getCancelUploadButtonImageFormat() {
}

public function setCancelUploadButtonImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the Cancel button.

See Also

Reference

  • CancelUploadButtonText Property
  • Aurigma.ImageUploader.Uploader.CancelUploadButtonImageFormat ASP.NET Property
  • $au.uploader.cancelUploadButtonImageFormat JavaScript Property


Uploader.CancelUploadButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the button which aborts the upload.

Syntax

PHP

public function getCancelUploadButtonText() {
}

public function setCancelUploadButtonText($value) {
}

Property Value

Type: string

The caption of the Cancel button.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • CancelUploadButtonImageFormat Property
  • Aurigma.ImageUploader.Uploader.CancelUploadButtonText ASP.NET Property
  • $au.uploader.cancelUploadButtonText JavaScript Property


Uploader.ClientEvents Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a collection of client-side events.

Syntax

PHP

public function getClientEvents() {
}

public function setClientEvents($value) {
}

Property Value

Type: ClientEvents

The collection of client-side events.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.ClientEvents ASP.NET Property
  • $au.uploader.events JavaScript Property

Manual

  • Using Events


Uploader.ContextMenu Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the context menu settings.

Syntax

PHP

public function getContextMenu() {
}

public function setContextMenu($value) {
}

Property Value

Type: ContextMenu

The settings of the context menu.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.ContextMenu ASP.NET Property
  • $au.uploader.contextMenu JavaScript Property


Uploader.Converters Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a collection of converters.

Syntax

PHP

public function &getConverters() {
}

public function setConverters($value) {
}

Property Value

Type: array

The collection of converters.

Remarks

Each conveter configures a one converted file (original file as is, thumbnail created from original image file, icon associated with original file, or original file compressed into ZIP archive) that will be uploaded for each of the user-selected files.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Converters ASP.NET Property
  • $au.uploader.converters JavaScript Property

Manual

  • Configuring Files to be Uploaded


Uploader.DeleteFilesDialog Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets the settings of the delete confirmation dialog.

Syntax

PHP

public function getDeleteFilesDialog() {
}

public function setDeleteFilesDialog($value) {
}

Property Value

Type: DeleteFilesDialog

The delete confirmation dialog settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.DeleteFilesDialog ASP.NET Property
  • $au.uploader.deleteFilesDialog JavaScript Property


Uploader.DescriptionEditor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the description editor settings.

Syntax

PHP

public function getDescriptionEditor() {
}

public function setDescriptionEditor($value) {
}

Property Value

Type: DescriptionEditor

The settings of the description editor.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.DescriptionEditor ASP.NET Property
  • $au.uploader.descriptionEditor JavaScript Property


Uploader.DetailsViewColumns Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets titles of columns displayed in the Details view.

Syntax

PHP

public function getDetailsViewColumns() {
}

public function setDetailsViewColumns($value) {
}

Property Value

Type: DetailsViewColumns

The titles of columns displayed in the Details view.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.DetailsViewColumns ASP.NET Property
  • $au.uploader.detailsViewColumns JavaScript Property

Manual

  • View Modes


Uploader.DialogBorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of a dialog border.

Syntax

PHP

public function getDialogBorderColor() {
}

public function setDialogBorderColor($value) {
}

Property Value

Type: string

The color of a dialog border.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#98b6ca".

Remarks

This property affects the following dialogs:

  • description editor,
  • files adding dialog,
  • files uploading dialog.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.DialogBorderColor ASP.NET Property
  • $au.uploader.dialogBorderColor JavaScript Property


Uploader.DialogColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of Image Uploader dialogs.

Syntax

PHP

public function getDialogColor() {
}

public function setDialogColor($value) {
}

Property Value

Type: string

The color of Image Uploader dialogs.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#e7f7ff".

Remarks

This property affects the following dialogs:

  • description editor,
  • files adding dialog,
  • files uploading dialog.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.DialogColor ASP.NET Property
  • $au.uploader.dialogColor JavaScript Property


Uploader.EnableAutoRotation Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the automatic EXIF-based photo rotation feature is enabled.

Syntax

PHP

public function getEnableAutoRotation() {
}

public function setEnableAutoRotation($value) {
}

Property Value

Type: boolean

If true, Image Uploader automatically extracts the orientation information from an image and automatically rotates it. Otherwise, only manual rotation is available.

Default value is false.

Remarks

This feature works only for those photos which store EXIF information and orientation details are written there. Keep in mind that not each camera can recognize orientation properly, and therefore Image Uploader will not be able to rotate it.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableAutoRotation ASP.NET Property
  • $au.uploader.enableAutoRotation JavaScript Property


Uploader.EnableContextMenu Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to disaplay the context menu.

Syntax

PHP

public function getEnableContextMenu() {
}

public function setEnableContextMenu($value) {
}

Property Value

Type: boolean

If true, context menu is displayed when a user right-clicks panes and items; otherwise, right-clicks cause nothing.

Default value is true.

See Also

Reference

  • ContextMenu Class
  • Aurigma.ImageUploader.Uploader.EnableContextMenu ASP.NET Property
  • $au.uploader.enableContextMenu JavaScript Property


Uploader.EnableDescriptionEditor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is possible to add descriptions to files.

Syntax

PHP

public function getEnableDescriptionEditor() {
}

public function setEnableDescriptionEditor($value) {
}

Property Value

Type: boolean

If true, a user can add descriptions in the following ways:

  • by clicking the description control which appears when a mouse pointer hovers over the file;
  • by filling a special field in the image editor;
  • via the Edit description... option of the context menu.

Otherwise, descriptions can be added through the description property only.

Default value is true.

See Also

Reference

  • DescriptionEditor Class
  • ImageEditor Class
  • Aurigma.ImageUploader.Uploader.EnableDescriptionEditor ASP.NET Property
  • $au.uploader.enableDescriptionEditor JavaScript Property

Manual

  • Additional Controls and Indicators


Uploader.EnableDragAndDrop Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether internal drag-and-drop operations are supported.

Syntax

PHP

public function getEnableDragAndDrop() {
}

public function setEnableDragAndDrop($value) {
}

Property Value

Type: boolean

If true, a user can use drag-and-drop to:

  • add files from the folder pane to the upload pane in ThreePanes layout;
  • reorder files in the upload pane in both layouts.

Otherwise, only external drag-and-drop (from Windows Explorer, Finder, or other shell) operations are supported.

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableDragAndDrop ASP.NET Property
  • $au.uploader.enableDragAndDrop JavaScript Property

Manual

  • Layouts


Uploader.EnableFileViewer Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to open the file in associated viewer software when it is double-clicked.

Syntax

PHP

public function getEnableFileViewer() {
}

public function setEnableFileViewer($value) {
}

Property Value

Type: boolean

If true, the file is opened in the external file viewer by double-clicking. Otherwise, double-click causes nothing.

Default value is true.

Remarks

If subfolders are shown (FolderProcessingMode is show or upload) double-clicking subfolders navigates to them regardless of the EnableFileViewer value.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableFileViewer ASP.NET Property
  • $au.uploader.enableFileViewer JavaScript Property


Uploader.EnableImageEditor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is possible to open images in the image editor by clicking the image editor icon or the corresponging context menu option.

Syntax

PHP

public function getEnableImageEditor() {
}

public function setEnableImageEditor($value) {
}

Property Value

Type: boolean

If true, any image in the folder or upload pane can be opened in the image editor; otherwise, the image editor icon and the Edit image... context menu are hidden.

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableImageEditor ASP.NET Property
  • $au.uploader.enableImageEditor JavaScript Property


Uploader.EnableOriginalFilesDeletion Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether successfully uploaded files should be deleted.

Syntax

PHP

public function getEnableOriginalFilesDeletion() {
}

public function setEnableOriginalFilesDeletion($value) {
}

Property Value

Type: boolean

If true, after successful upload Image Uploader shows a dialog, asking a user whether the uploaded files should be deleted. If a user clicks Yes, the files will be deleted.

Default value is false.

Remarks

Note

A difference between Image Uploader behavior in Internet Explorer and other supported browsers is the following. When Image Uploader deletes files in Internet Explorer, it moves them in the way specified in the Recycle Bin properties. By default, a standard delete confirmation dialog appears and files are moved to the Recycle Bin if a user clicks Yes. However, if Image Uploader deletes files in any of other supported browsers, the internal delete confirmation dialog appears and files are removed permanently when a user clicks Yes.

If the file cannot be deleted, the DeletingFilesError message appears.

See Also

Reference

  • DeleteFilesDialog Class
  • Aurigma.ImageUploader.Uploader.EnableOriginalFilesDeletion ASP.NET Property
  • $au.uploader.enableOriginalFilesDeletion JavaScript Property


Uploader.EnableRotation Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is possible to rotate images via Image Uploader GUI.

Syntax

PHP

public function getEnableRotation() {
}

public function setEnableRotation($value) {
}

Property Value

Type: boolean

If true, any image in the folder or upload pane can be rotated by 90 degrees clockwise by:

  • clicking the rotation icon on the pane item surface,
  • clicking the Rotate button of the image edtior.

Otherwise, images can be rotated via the angle property only.

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableRotation ASP.NET Property
  • $au.uploader.enableRotation JavaScript Property


Uploader.EnableStatusPane Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the status pane should be displayed.

Syntax

PHP

public function getEnableStatusPane() {
}

public function setEnableStatusPane($value) {
}

Property Value

Type: boolean

If true, the status pane is displayed in both layouts; otherwise, it is hidden.

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableStatusPane ASP.NET Property
  • $au.uploader.enableStatusPane JavaScript Property


Uploader.EnableUploadPane Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the upload pane should be displayed.

Syntax

PHP

public function getEnableUploadPane() {
}

public function setEnableUploadPane($value) {
}

Property Value

Type: boolean

If true, the upload pane is displayed in ThreePanes layout; otherwise, it is hidden.

Default value is true.

Remarks

This property makes sense in ThreePanes layout only.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableUploadPane ASP.NET Property
  • $au.uploader.enableUploadPane JavaScript Property


Uploader.EnableUploadProgress Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the uploading files dialog is shown during the upload.

Syntax

PHP

public function getEnableUploadProgress() {
}

public function setEnableUploadProgress($value) {
}

Property Value

Type: boolean

If true, the uploading files dialog is displayed; otherwise, this dialog is hidden. However, there are alternative ways to indicate the upload progress:

  • activate the instant upload mode (i.e. set the UploadSettings.EnableInstantUpload is true),
  • implement a custom upload progress indicator yourself by using the Progress event.

Default value is true.

See Also

Reference

  • EnableInstantUpload Property
  • Progress Event
  • Aurigma.ImageUploader.Uploader.EnableUploadProgress ASP.NET Property
  • $au.uploader.enableUploadProgress JavaScript Property


Uploader.FolderPane Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the folder pane settings.

Syntax

PHP

public function getFolderPane() {
}

public function setFolderPane($value) {
}

Property Value

Type: FolderPane

The settings of the folder pane.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.FolderPane ASP.NET Property
  • $au.uploader.folderPane JavaScript Property

Manual

  • Layouts


Uploader.FolderProcessingMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the folder processing mode.

Syntax

PHP

public function getFolderProcessingMode() {
}

public function setFolderProcessingMode($value) {
}

Property Value

Type: string

The folder processing mode.

The following values are supported:

Value | Description
Skip | Subfolders are not shown in the folder pane, so it is impossible to upload a whole folder if it is not a current folder.
Show | Subfolders are visible in the folder pane, so a user can select whole folders. However, restoring folders structure on server side is impossible, because no file path information is uploaded.
Upload | Subfolders are shown in the folder pane, so a user can select whole folders. Moreover, it is possible to restore folders structure on a server, because Image Uploader sends each file along with its relative path to the selected folder.

Default value is "Skip".

Remarks

Note

Image Uploader Express does not display and upload folders. See the Comparison of Image Uploader Editions topic for details.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.FolderProcessingMode ASP.NET Property
  • $au.uploader.folderProcessingMode JavaScript Property

Manual

  • Uploading Folders in PHP


Uploader.HeaderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of Image Uploader headers.

Syntax

PHP

public function getHeaderColor() {
}

public function setHeaderColor($value) {
}

Property Value

Type: string

The color of Image Uploader headers.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is "#f2f6fb;#c4defb".

Remarks

This property affects the following headers:

  • tree pane header,
  • folder pane header.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.HeaderColor ASP.NET Property
  • $au.uploader.headerColor JavaScript Property


Uploader.HeaderTextColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of text in Image Uploader headers.

Syntax

PHP

public function getHeaderTextColor() {
}

public function setHeaderTextColor($value) {
}

Property Value

Type: string

The color of text in Image Uploader headers.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#1a64a8".

Remarks

This property affects the following headers:

  • tree pane header,
  • folder pane header.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.HeaderTextColor ASP.NET Property
  • $au.uploader.headerTextColor JavaScript Property

Manual

  • Layouts


Uploader.Height Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of the control.

Syntax

PHP

public function getHeight() {
}

public function setHeight($value) {
}

Property Value

Type: string

The height of the control.

Default value is "400px".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Height ASP.NET Property
  • $au.uploader.height JavaScript Property


Uploader.HyperlinkColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of all the hyperlink elements.

Syntax

PHP

public function getHyperlinkColor() {
}

public function setHyperlinkColor($value) {
}

Property Value

Type: string

The color of all the hyperlink elements.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#0066cc".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.HyperlinkColor ASP.NET Property
  • $au.uploader.hyperlinkColor JavaScript Property


Uploader.ImageEditor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the image editor settings.

Syntax

PHP

public function getImageEditor() {
}

public function setImageEditor($value) {
}

Property Value

Type: ImageEditor

The settings of the image editor appearance.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.ImageEditor ASP.NET Property
  • $au.uploader.imageEditor JavaScript Property

Manual

  • Image Editor


Uploader.InformationBar Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the information bar settings.

Syntax

PHP

public function getInformationBar() {
}

public function setInformationBar($value) {
}

Property Value

Type: InformationBar

The settings of the information bar appearance.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.InformationBar ASP.NET Property
  • $au.uploader.informationBar JavaScript Property


Uploader.JavaControl Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets Image Uploader Java applet settings.

Syntax

PHP

public function getJavaControl() {
}

public function setJavaControl($value) {
}

Property Value

Type: JavaControl

Image Uploader Java applet settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.JavaControl ASP.NET Property
  • $au.uploader.javaControl JavaScript Property

Manual

  • Using Private-label Version of Image Uploader PHP


Uploader.Language Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a control localization.

Syntax

PHP

public function getLanguage() {
}

public function setLanguage($value) {
}

Property Value

Type: string

The control localization.

The following values are supported:

Value | Description
en | English localization.
ru | Russian localization.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Language ASP.NET Property


Uploader.LicenseKey Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a license key which allows evaluating, developing, or publishing Image Uploader according to the license key type (trial, development, or full).

Syntax

PHP

public function getLicenseKey() {
}

public function setLicenseKey($value) {
}

Property Value

Type: string

The valid license key.

If it is necessary to specify several license keys just separate them with semicolons. See the Example section below.

Default value is "".

Remarks

Note

Image Uploader Express does not support registering of several license keys. See the Comparison of Image Uploader Editions topic for details.

Image Uploader always works as a full version on localhost domain (regardless to the license key).

If you have any questions regarding licensing options or any other sales-related queries, do not hesitate to contact at sales@aurigma.com for more details.

Example

PHP

$uploader = new Uploader("Uploader1");
$uploader->setLicenseKey("XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY");

See Also

Reference

  • Aurigma.ImageUploader.Uploader.LicenseKey ASP.NET Property
  • $au.uploader.licenseKey JavaScript Property

Manual

  • Quick Start with Image Uploader PHP
  • Evaluating and Registering Image Uploader


Uploader.LoadingFolderContentText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text which is displayed while Image Uploader scans the folder content and builds the file list.

Syntax

PHP

public function getLoadingFolderContentText() {
}

public function setLoadingFolderContentText($value) {
}

Property Value

Type: string

The text which is displayed while Image Uploader scans the folder content and builds the file list.

Default value is "Loading content...".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.LoadingFolderContentText ASP.NET Property
  • $au.uploader.loadingFolderContentText JavaScript Property


Uploader.Messages Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets messages.

Syntax

PHP

public function getMessages() {
}

public function setMessages($value) {
}

Property Value

Type: Messages

The messages.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Messages ASP.NET Property
  • $au.uploader.messages JavaScript Property

Manual

  • Localization


Uploader.Metadata Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an additional upload data.

Syntax

PHP

public function getMetadata() {
}

public function setMetadata($value) {
}

Property Value

Type: Metadata

The additional upload data.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Metadata ASP.NET Property
  • $au.uploader.metadata JavaScript Property

Manual

  • Uploading Additional Data in PHP


Uploader.PaneFont Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a font format for all Image Uploader buttons and labels, except titles.

Syntax

PHP

public function getPaneFont() {
}

public function setPaneFont($value) {
}

Property Value

Type: FontFormat

The font format for all Image Uploader buttons and labels. If this property is not specified, a default system font is used.

Remarks

The string which specifies font format has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Name | Font name. This font should be installed on the client machine, so it is recommended to use only standard font names. When this parameter is not specified, the system default font is used.
Size | Font size (in pixels). If this parameter is not specified, the system default font size is used.
Style

Font style. The following styles are supported:

  • Bold
  • Italic

You can specify several styles separated with a comma. Example:

Style=Bold,Italic

If this parameter is not specified, regular font is used.

Note

The format string is case insensitive.

If you need to customize a title font, use the TitleFont.

See Also

Reference

  • TitleFont Property
  • Aurigma.ImageUploader.Uploader.PaneFont ASP.NET Property
  • $au.uploader.paneFont JavaScript Property


Uploader.PaneItem Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the pane item settings.

Syntax

PHP

public function getPaneItem() {
}

public function setPaneItem($value) {
}

Property Value

Type: PaneItem

The pane item settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.PaneItem ASP.NET Property
  • $au.uploader.paneItem JavaScript Property


Uploader.PaneLayout Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets of sets Image Uploader layout.

Syntax

PHP

public function getPaneLayout() {
}

public function setPaneLayout($value) {
}

Property Value

Type: string

The Image Uploader layout.

The following values are supported:

Value | Description
OnePane | Only the upload pane representing a list of user-selected files is displayed. Users can drag-and-drop necessary files from Windows Explorer, Finder, or any other graphic shell to this list.
ThreePanes

Three panes are displayed:

  • Tree pane - is the folder tree allowing a user to navigate their file system.
  • Folder pane - displays the content of the currently selected folder.
  • Upload pane - contains files ready to be uploaded.

Default value is "TreePanes".

Remarks

Keep in mind that Image Uploader is not designed to switch between layouts in run-time.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.PaneLayout ASP.NET Property
  • $au.uploader.paneLayout JavaScript Property

Manual

  • Layouts


Uploader.PanelBorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of borders between Image Uploader panes.

Syntax

PHP

public function getPanelBorderColor() {
}

public function setPanelBorderColor($value) {
}

Property Value

Type: string

The color of Image Uploader pane borders.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#aaaaaa".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.PanelBorderColor ASP.NET Property
  • $au.uploader.panelBorderColor JavaScript Property


Uploader.PanelColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of command areas.

Syntax

PHP

public function getPanelColor() {
}

public function setPanelColor($value) {
}

Property Value

Type: string

The color of a command area of the following windows:

  • image editor,
  • adding files dialog,
  • uploading files dialog.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#f5f5f5".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.PanelColor ASP.NET Property
  • $au.uploader.panelColor JavaScript Property


Uploader.PasteFileNameTemplate Property

  • Supported browsers: Internet Explorer

Gets or sets a file name template for files pasted from clipboard.

Syntax

PHP

public function getPasteFileNameTemplate() {
}

public function setPasteFileNameTemplate($value) {
}

Property Value

Type: string

The file name template for files pasted from clipboard. It can contain any characters allowed for file names and use the following placeholders:

[date]
Current date (i.e. when the file was pasted from clipboard).
[time]
Current time (i.e. when the file was pasted from clipboard).

Default value is "Paste_[date]_[time]".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.PasteFileNameTemplate ASP.NET Property
  • $au.uploader.pasteFileNameTemplate JavaScript Property


Uploader.Restrictions Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets upload restrictions.

Syntax

PHP

public function getRestrictions() {
}

public function setRestrictions($value) {
}

Property Value

Type: Restrictions

The upload restrictions.

Remarks

Note

All the limitations specified here are checked client-side, so you should not interpret them as a reliable protection. A potentially malicious user can bypass all these limitations (by emulating Image Uploader). That is why it is highly recommended to implement server-side verification of uploaded files in addition to Restrictions properties.

In other words, all the limitation features discussed in this topic should be used solely for the convenience of the user. They should not be interpreted as a serious protection measure from malicious users.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Restrictions ASP.NET Property
  • $au.uploader.restrictions JavaScript Property

Manual

  • Configuring Restriction Rules for Files


Uploader.StatusPane Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the status pane settings.

Syntax

PHP

public function getStatusPane() {
}

public function setStatusPane($value) {
}

Property Value

Type: StatusPane

The settings of the status pane.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.StatusPane ASP.NET Property
  • $au.uploader.statusPane JavaScript Property

Manual

  • Layouts


Uploader.TextColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of primary labels.

Syntax

PHP

public function getTextColor() {
}

public function setTextColor($value) {
}

Property Value

Type: string

The color of Image Uploader labels except for:

  • auxiliary labels (are customized with the AuxiliaryTextColor property);
  • header labels (are customized with the HeaderTextColor property);
  • buttons,
  • context menu.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#000000".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.TextColor ASP.NET Property
  • $au.uploader.textColor JavaScript Property


Uploader.TitleFont Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a font format for Image Uploader titles.

Syntax

PHP

public function getTitleFont() {
}

public function setTitleFont($value) {
}

Property Value

Type: FontFormat

The font format for:

  • tree pane header title;
  • folder pane header title;
  • adding files dialog title;
  • uploading files dialog title;
  • status pane text (always regular, even if the bold style is specified).

If this property is not specified, a default font is used.

Remarks

The string which specifies font format has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Name | Font name. This font should be installed on the client machine, so it is recommended to use only standard font names. When this parameter is not specified, the system default font is used.
Size | Font size (in pixels). If this parameter is not specified, the system default font size is used.
Style

Font style. The following styles are supported:

  • Bold
  • Italic

You can specify several styles separated with a comma. Example:

Style=Bold,Italic

If this parameter is not specified, regular font is used.

Note

The format string is case insensitive.

Other fonts are specified via the PaneFont property.

See Also

Reference

  • PaneFont Property
  • Aurigma.ImageUploader.Uploader.TitleFont ASP.NET Property
  • $au.uploader.titleFont JavaScript Property

Manual

  • Layouts


Uploader.TreePane Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the tree pane settings.

Syntax

PHP

public function getTreePane() {
}

public function setTreePane($value) {
}

Property Value

Type: TreePane

The tree pane settings

See Also

Reference

  • Aurigma.ImageUploader.Uploader.TreePane ASP.NET Property
  • $au.uploader.treePane JavaScript Property

Manual

  • Layouts


Uploader.UploadButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an ImageFormat object configuring a list of images that are displayed in different states of the Upload button.

Syntax

PHP

public function getUploadButtonImageFormat() {
}

public function setUploadButtonImageFormat($value) {
}

Property Value

Type: ImageFormat

The list of custom images of the Upload button.

See Also

Reference

  • UploadButtonText Property
  • Aurigma.ImageUploader.Uploader.UploadButtonImageFormat ASP.NET Property
  • $au.uploader.uploadButtonImageFormat JavaScript Property


Uploader.UploadButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the button which starts the upload of the selected files.

Syntax

PHP

public function getUploadButtonText() {
}

public function setUploadButtonText($value) {
}

Property Value

Type: string

The caption of the Upload button.

Default value is "Upload".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • UploadButtonImageFormat Property
  • Aurigma.ImageUploader.Uploader.UploadButtonText ASP.NET Property
  • $au.uploader.uploadButtonText JavaScript Property


Uploader.UploadPane Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the upload pane settings.

Syntax

PHP

public function getUploadPane() {
}

public function setUploadPane($value) {
}

Property Value

Type: UploadPane

The upload pane settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.UploadPane ASP.NET Property
  • $au.uploader.uploadPane JavaScript Property

Manual

  • Layouts


Uploader.UploadProgressDialog Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the upload progress dialog settings.

Syntax

PHP

public function getUploadProgressDialog() {
}

public function setUploadProgressDialog($value) {
}

Property Value

Type: UploadProgressDialog

The upload progress dialog settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.UploadProgressDialog ASP.NET Property
  • $au.uploader.uploadProgressDialog JavaScript Property


Uploader.UploadSettings Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets upload settings.

Syntax

PHP

public function getUploadSettings() {
}

public function setUploadSettings($value) {
}

Property Value

Type: UploadSettings

The upload settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.UploadSettings ASP.NET Property
  • $au.uploader.uploadSettings JavaScript Property

Manual

  • Configuring Common Upload Settings


Uploader.Width Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of the control.

Syntax

PHP

public function getWidth() {
}

public function setWidth($value) {
}

Property Value

Type: string

The width of the control.

Default value is "600px".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Width ASP.NET Property
  • $au.uploader.width JavaScript Property


UploadHandler Class

This class allows processing the data uploaded by Image Uploader from client computers.

For a list of all members of this class, see UploadHandler Members.

Syntax

PHP

class UploadHandler {
}

Remarks

This class has user-friendly API and functionality giving flexible typed access to the uploaded data. In order to use UploadHandler you have to include UploadHandler.class.php into your upload handling script, for example, upload.php.

See Also

Reference

  • Aurigma.ImageUploader.UploadHandler ASP.NET Class

Manual

  • Saving Uploaded Files in PHP


UploadHandler Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The UploadHandler type exposes the following members.

Methods

 | Name | Description
Public method | processRequest | Enables processing of Image Uploader requests. Just call this method after specifying the AllFilesUploadedCallback and/or the FileUploadedCallback properties.
Public method | saveFiles(string) | Saves uploaded files to the specified path.

Properties

 | Name | Description
Public property | AllFilesUploadedCallback | Gets or sets the callback function which is called when the whole upload session completes and all the converted files and metadata are received on the server side.
Public property | CacheAliveTimeout | Gets or sets a maximum time (in seconds) the upload session cache will be saved.
Public property | FileUploadedCallback | Gets or sets the callback function which is called when all the converted files and metadata related to a particular user-selected file are successfully uploaded.
Public property | UploadCacheDirectory | Gets or sets a path to the folder where UploadHandler saves the upload session cache.


UploadHandler Methods

  • Methods
  • Language Filter ( all languages )

The UploadHandler type exposes the following methods.

Methods

 | Name | Description
Public method | processRequest | Enables processing of Image Uploader requests. Just call this method after specifying the AllFilesUploadedCallback and/or the FileUploadedCallback properties.
Public method | saveFiles(string) | Saves uploaded files to the specified path.


UploadHandler.processRequest Method

Enables processing of Image Uploader requests. Just call this method after specifying the AllFilesUploadedCallback and/or the FileUploadedCallback properties.

Syntax

PHP

public function processRequest() {
}

See Also

Reference

  • Aurigma.ImageUploader.UploadHandler.ProcessRequest(HttpContext) ASP.NET Method


UploadHandler.saveFiles(string) Method

Saves uploaded files to the specified path.

Syntax

PHP

public function saveFiles($destination) {
}

Parameters

destination

Type: string

The path where uploaded files should be saved.

Remarks

The path can be both absolute (C:\Uploads) or relative (/uploads, ./uploads, ../uploads).


UploadHandler Properties

  • Properties
  • Language Filter ( all languages )

The UploadHandler type exposes the following properties.

Properties

 | Name | Description
Public property | AllFilesUploadedCallback | Gets or sets the callback function which is called when the whole upload session completes and all the converted files and metadata are received on the server side.
Public property | CacheAliveTimeout | Gets or sets a maximum time (in seconds) the upload session cache will be saved.
Public property | FileUploadedCallback | Gets or sets the callback function which is called when all the converted files and metadata related to a particular user-selected file are successfully uploaded.
Public property | UploadCacheDirectory | Gets or sets a path to the folder where UploadHandler saves the upload session cache.


UploadHandler.AllFilesUploadedCallback Property

Gets or sets the callback function which is called when the whole upload session completes and all the converted files and metadata are received on the server side.

Syntax

PHP

public function getAllFilesUploadedCallback() {
}

public function setAllFilesUploadedCallback($value) {
}

Property Value

Type: string

Name of the callback function which is called when the whole upload session completes and all the converted files and metadata are received on the server side.

Remarks

The callback function must have an argument, which gets an UploadedFile array value.


UploadHandler.CacheAliveTimeout Property

Gets or sets a maximum time (in seconds) the upload session cache will be saved.

Syntax

PHP

public function getCacheAliveTimeout() {
}

public function setCacheAliveTimeout($value) {
}

Property Value

Type: integer

The maximum time (in seconds) the upload session cache will be saved.

See Also

Reference

  • Aurigma.ImageUploader.UploadHandler.CacheAliveTimeout ASP.NET Property


UploadHandler.FileUploadedCallback Property

Gets or sets the callback function which is called when all the converted files and metadata related to a particular user-selected file are successfully uploaded.

Syntax

PHP

public function getFileUploadedCallback() {
}

public function setFileUploadedCallback($value) {
}

Property Value

Type: string

Name of the callback function which is called when all the converted files and metadata related to a particular user-selected file are successfully uploaded.

Remarks

The callback function must have an argument, which gets an UploadedFile value.


UploadHandler.UploadCacheDirectory Property

Gets or sets a path to the folder where UploadHandler saves the upload session cache.

Syntax

PHP

public function getUploadCacheDirectory() {
}

public function setUploadCacheDirectory($value) {
}

Property Value

Type: string

The path to the folder where UploadHandler saves the upload session cache.

See Also

Reference

  • Aurigma.ImageUploader.UploadHandler.TempDirectory ASP.NET Property


UploadPane Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the upload pane.

For a list of all members of this class, see UploadPane Members.

Syntax

PHP

class UploadPane {
}

See Also

Reference

  • UploadPane Property
  • Aurigma.ImageUploader.UploadPane ASP.NET Class
  • $au.uploadPane JavaScript Class

Manual

  • Layouts


UploadPane Members

  • Properties
  • Language Filter ( all languages )

The UploadPane type exposes the following members.

Properties

 | Name | Description
Public property | DropFilesHereImageFormat | Gets or sets an BackgroundImageFormat object configuring a an image displayed on the upload pane when it is empty.
Public property | DropFilesHereText | Gets or sets a label displayed on the upload pane when it is empty.
Public property | PreviewSize | Gets or sets a size of the preview area when in Thumbnails view.
Public property | SortMode | Gets or sets a sort mode of the upload pane.
Public property | ViewMode | Gets or sets a view mode for the upload pane.


UploadPane Properties

  • Properties
  • Language Filter ( all languages )

The UploadPane type exposes the following properties.

Properties

 | Name | Description
Public property | DropFilesHereImageFormat | Gets or sets an BackgroundImageFormat object configuring a an image displayed on the upload pane when it is empty.
Public property | DropFilesHereText | Gets or sets a label displayed on the upload pane when it is empty.
Public property | PreviewSize | Gets or sets a size of the preview area when in Thumbnails view.
Public property | SortMode | Gets or sets a sort mode of the upload pane.
Public property | ViewMode | Gets or sets a view mode for the upload pane.


UploadPane.DropFilesHereImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an BackgroundImageFormat object configuring a an image displayed on the upload pane when it is empty.

Syntax

PHP

public function getDropFilesHereImageFormat() {
}

public function setDropFilesHereImageFormat($value) {
}

Property Value

Type: BackgroundImageFormat

The image displayed on the upload pane when it is empty. If an empty string is specified, a standard Drop Files Here label is displayed.

See Also

Reference

  • DropFilesHereText Property
  • Aurigma.ImageUploader.UploadPane.DropFilesHereImageFormat ASP.NET Property
  • $au.uploadPane.dropFilesHereImageFormat JavaScript Property

Manual

  • Layouts
  • Customizing Appearance


UploadPane.DropFilesHereText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a label displayed on the upload pane when it is empty.

Syntax

PHP

public function getDropFilesHereText() {
}

public function setDropFilesHereText($value) {
}

Property Value

Type: string

The label displayed on the upload pane when it is empty.

Default value is "Drop files here...".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • DropFilesHereImageFormat Property
  • Aurigma.ImageUploader.UploadPane.DropFilesHereText ASP.NET Property
  • $au.uploadPane.dropFilesHereText JavaScript Property

Manual

  • Layouts


UploadPane.PreviewSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a size of the preview area when in Thumbnails view.

Syntax

PHP

public function getPreviewSize() {
}

public function setPreviewSize($value) {
}

Property Value

Type: integer

The size of the preview area (in pixels). In other words, this property specifies size of square the thumbnail is inscribed in.

Default value is 96.

See Also

Reference

  • Aurigma.ImageUploader.UploadPane.PreviewSize ASP.NET Property
  • $au.uploadPane.previewSize JavaScript Property


UploadPane.SortMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a sort mode of the upload pane.

Syntax

PHP

public function getSortMode() {
}

public function setSortMode($value) {
}

Property Value

Type: string

The sort mode of the upload pane.

The following values are supported:

Value | Description
Unsorted | Items are unsorted.
Name | Items are sorted by name alphabetically.
Size | Items are sorted by file size.
Type | Items are sorted by file type alphabetically.
Modified | Items are sorted by the date of last modification.
Path | Items are sorted by full path.
Dimensions | Items are sorted by image dimensions.
Note

The sort mode cannot be set to Unsorted value manually.

Default value is "Unsorted".

Remarks

Sort mode is automatically reset to Unsorted when new items are added or re-arranged via drag-n-drop.

Note

If you set the same value twice, the sort order will toggle between ascending and descending and vice versa.

See Also

Reference

  • Aurigma.ImageUploader.UploadPane.SortMode ASP.NET Property
  • $au.uploadPane.sortMode JavaScript Property


UploadPane.ViewMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a view mode for the upload pane.

Syntax

PHP

public function getViewMode() {
}

public function setViewMode($value) {
}

Property Value

Type: string

The view mode for the upload pane.

The following values are supported:

Value | Description
Thumbnails | Images are displayed as thumbnails, non-images are displayed as icons. It is possible to attach a description to each file. If a file is recognized as image, it can be cropped and rotated.
Tiles | Each file appears as a thumbnail (or icon for non-image files), with a file name and details (file type, last modification date, and file size) on the right. It is possible to attach a description to each file. If a file is recognized as image, it can be cropped and rotated.
Details | All the files are displayed as a detailed list (icon + filename + info + size + last modification date + type + image dimensions).
List | Files are displayed as small thumbnails (or icons for non-image files) with names on the right.

Default value is "Thumbnails".

See Also

Reference

  • Aurigma.ImageUploader.UploadPane.ViewMode ASP.NET Property
  • $au.uploadPane.viewMode JavaScript Property

Manual

  • View Modes


UploadProgressDialog Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the uploading files dialog which appears during the upload.

For a list of all members of this class, see UploadProgressDialog Members.

Syntax

PHP

class UploadProgressDialog {
}

See Also

Reference

  • UploadProgressDialog Property
  • Aurigma.ImageUploader.UploadProgressDialog ASP.NET Class
  • $au.uploadProgressDialog JavaScript Class

Manual

  • Customizing Appearance


UploadProgressDialog Members

  • Properties
  • Language Filter ( all languages )

The UploadProgressDialog type exposes the following members.

Properties

 | Name | Description
Public property | CancelUploadButtonText | Gets or sets a caption of the Cancel button on the dialog displayed during the upload.
Public property | EstimationText | Gets or sets a caption of the label which displays estimated time of the upload.
Public property | HideButtonText | Gets or sets a caption of the Hide button on the dialog displayed during the instant upload.
Public property | HoursText | Gets or sets a text for the hours unit in the uploading files dialog.
Public property | InfoText | Gets or sets a caption of the label which displays the upload propgress information.
Public property | KilobytesText | Gets or sets a text for the kilobytes unit in the uploading files dialog.
Public property | MegabytesText | Gets or sets a text for the megabytes unit in the uploading files dialog.
Public property | MinutesText | Gets or sets a text for the minutes unit in the uploading files dialog.
Public property | SecondsText | Gets or sets a text for the seconds unit in the uploading files dialog.
Public property | TimeFormat | Gets or sets a format of the time displayed in the EstimationText label.
Public property | TitleText | Gets or sets a title of the dialog displayed displayed during the upload.


UploadProgressDialog Properties

  • Properties
  • Language Filter ( all languages )

The UploadProgressDialog type exposes the following properties.

Properties

 | Name | Description
Public property | CancelUploadButtonText | Gets or sets a caption of the Cancel button on the dialog displayed during the upload.
Public property | EstimationText | Gets or sets a caption of the label which displays estimated time of the upload.
Public property | HideButtonText | Gets or sets a caption of the Hide button on the dialog displayed during the instant upload.
Public property | HoursText | Gets or sets a text for the hours unit in the uploading files dialog.
Public property | InfoText | Gets or sets a caption of the label which displays the upload propgress information.
Public property | KilobytesText | Gets or sets a text for the kilobytes unit in the uploading files dialog.
Public property | MegabytesText | Gets or sets a text for the megabytes unit in the uploading files dialog.
Public property | MinutesText | Gets or sets a text for the minutes unit in the uploading files dialog.
Public property | SecondsText | Gets or sets a text for the seconds unit in the uploading files dialog.
Public property | TimeFormat | Gets or sets a format of the time displayed in the EstimationText label.
Public property | TitleText | Gets or sets a title of the dialog displayed displayed during the upload.


UploadProgressDialog.CancelUploadButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel button on the dialog displayed during the upload.

Syntax

PHP

public function getCancelUploadButtonText() {
}

public function setCancelUploadButtonText($value) {
}

Property Value

Type: string

The caption of the Cancel button on the uploading files dialog.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.UploadProgressDialog.CancelUploadButtonText ASP.NET Property
  • $au.uploadProgressDialog.cancelUploadButtonText JavaScript Property


UploadProgressDialog.EstimationText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the label which displays estimated time of the upload.

Syntax

PHP

public function getEstimationText() {
}

public function setEstimationText($value) {
}

Property Value

Type: string

The text of the Estimated remaining time label. It can contain the following placeholder:

[time]
replaced by the estimation of how much time is left.
Note

Format of the displayed time can be configured via the TimeFormat property.

Default value is "Estimated remaining time: [time]".

Remarks

Note

The estimation of the upload time may be quite inaccurate and depends on the UploadSettings.ProgressBytesMode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ProgressBytesMode Property
  • TimeFormat Property
  • HoursText Property
  • MinutesText Property
  • SecondsText Property
  • Aurigma.ImageUploader.UploadProgressDialog.EstimationText ASP.NET Property
  • $au.uploadProgressDialog.estimationText JavaScript Property


UploadProgressDialog.HideButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Hide button on the dialog displayed during the instant upload.

Syntax

PHP

public function getHideButtonText() {
}

public function setHideButtonText($value) {
}

Property Value

Type: string

The caption of the button which hides the uploading files dialog when the instant upload mode is used.

Default value is "Hide".

Remarks

Note

This button arrears when files are uploaded instantly.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • EnableInstantUpload Property
  • Aurigma.ImageUploader.UploadProgressDialog.HideButtonText ASP.NET Property
  • $au.uploadProgressDialog.hideButtonText JavaScript Property


UploadProgressDialog.HoursText Property

  • Supported browsers: Internet Explorer

Gets or sets a text for the hours unit in the uploading files dialog.

Syntax

PHP

public function getHoursText() {
}

public function setHoursText($value) {
}

Property Value

Type: string

The text of the hours unit in the uploading files dialog. As this string is inserted at the end of a sentence, you should specify it without capitalization.

Default value is "hours".

Remarks

Note

This string is used when the TimeFormat value contains Appearance=Words setting.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • TimeFormat Property
  • EstimationText Property
  • Aurigma.ImageUploader.UploadProgressDialog.HoursText ASP.NET Property
  • $au.uploadProgressDialog.hoursText JavaScript Property


UploadProgressDialog.InfoText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the label which displays the upload propgress information.

Syntax

PHP

public function getInfoText() {
}

public function setInfoText($value) {
}

Property Value

Type: string

The text of the Files uploaded label. It can contain the following placeholder:

[files]
replaced by the number of files that have already been sent to a server.
[totalFiles]
replaced by the total number of files which should be sent in this upload session.
[bytes]
replaced by the number of bytes that have already been sent to a server.
[totalBytes]
replaced by the total size of the upload session.

Default value is "Files uploaded [files]/[totalFiles] ([bytes] of [totalBytes])".

Remarks

Note

The estimation of the uploaded and total bytes may be quite inaccurate and depends on the UploadSettings.ProgressBytesMode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • ProgressBytesMode Property
  • KilobytesText Property
  • MegabytesText Property
  • Aurigma.ImageUploader.UploadProgressDialog.InfoText ASP.NET Property
  • $au.uploadProgressDialog.infoText JavaScript Property


UploadProgressDialog.KilobytesText Property

  • Supported browsers: Internet Explorer

Gets or sets a text for the kilobytes unit in the uploading files dialog.

Syntax

PHP

public function getKilobytesText() {
}

public function setKilobytesText($value) {
}

Property Value

Type: string

The text of the kilobytes unit in the uploading files dialog.

Default value is "Kb".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • InfoText Property
  • Aurigma.ImageUploader.UploadProgressDialog.KilobytesText ASP.NET Property
  • $au.uploadProgressDialog.kilobytesText JavaScript Property


UploadProgressDialog.MegabytesText Property

  • Supported browsers: Internet Explorer

Gets or sets a text for the megabytes unit in the uploading files dialog.

Syntax

PHP

public function getMegabytesText() {
}

public function setMegabytesText($value) {
}

Property Value

Type: string

The text of the megabytes unit in the uploading files dialog.

Default value is "Mb".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • InfoText Property
  • Aurigma.ImageUploader.UploadProgressDialog.MegabytesText ASP.NET Property
  • $au.uploadProgressDialog.megabytesText JavaScript Property


UploadProgressDialog.MinutesText Property

  • Supported browsers: Internet Explorer

Gets or sets a text for the minutes unit in the uploading files dialog.

Syntax

PHP

public function getMinutesText() {
}

public function setMinutesText($value) {
}

Property Value

Type: string

The text of the minutes unit in the uploading files dialog. As this string is inserted at the end of a sentence, you should specify it without capitalization.

Default value is "minutes".

Remarks

Note

This string is used when the TimeFormat value contains Appearance=Words setting.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • TimeFormat Property
  • EstimationText Property
  • Aurigma.ImageUploader.UploadProgressDialog.MinutesText ASP.NET Property
  • $au.uploadProgressDialog.minutesText JavaScript Property


UploadProgressDialog.SecondsText Property

  • Supported browsers: Internet Explorer

Gets or sets a text for the seconds unit in the uploading files dialog.

Syntax

PHP

public function getSecondsText() {
}

public function setSecondsText($value) {
}

Property Value

Type: string

The text of the seconds unit in the uploading files dialog. As this string is inserted at the end of a sentence, you should specify it without capitalization.

Default value is "seconds".

Remarks

Note

This string is used when the TimeFormat value contains Appearance=Words setting.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • TimeFormat Property
  • EstimationText Property
  • Aurigma.ImageUploader.UploadProgressDialog.SecondsText ASP.NET Property
  • $au.uploadProgressDialog.secondsText JavaScript Property


UploadProgressDialog.TimeFormat Property

  • Supported browsers: Internet Explorer

Gets or sets a format of the time displayed in the EstimationText label.

Syntax

PHP

public function getTimeFormat() {
}

public function setTimeFormat($value) {
}

Property Value

Type: string

The time format string having the following syntax:

variable1=value1;variable2=value2;...

The order and case sensitivity are not important. Possible values are:

Appearance
Sets the view. Possible values: Words (XX hours XX minutes XX seconds), ColonSeparated (XX:XX:XX).
PresentDirection
Sets the order of the output of time. Possible values: any possible combinations of H, M and S symbols.
DigitsFormat
Display or not the leading "0", if a particular value is less than 10. Possible values: N, NN.
HideZero
Hide or not zero values. Possible values: TRUE, FALSE.

Default value is "Appearance=ColonSeparated; PresentDirection=HMS; DigitsFormat=NN; HideZero=FALSE".

Remarks

Here is an examples of the usage of this property. Say, you set the following value for it:

Appearance=Words;PresentDirection=HMS;DigitsFormat=N;HideZero=TRUE

Then all time values will be displayed like this:

5 minutes 30 seconds

or this:

1 hours 15 minutes 30 seconds

See Also

Reference

  • EstimationText Property
  • HoursText Property
  • MinutesText Property
  • SecondsText Property
  • Aurigma.ImageUploader.UploadProgressDialog.TimeFormat ASP.NET Property
  • $au.uploadProgressDialog.timeFormat JavaScript Property


UploadProgressDialog.TitleText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the dialog displayed displayed during the upload.

Syntax

PHP

public function getTitleText() {
}

public function setTitleText($value) {
}

Property Value

Type: string

The title of the uploading files dialog.

Default value is "Uploading files to server".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.UploadProgressDialog.TitleText ASP.NET Property
  • $au.uploadProgressDialog.titleText JavaScript Property


UploadSettings Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the upload settings.

For a list of all members of this class, see UploadSettings Members.

Syntax

PHP

class UploadSettings {
}

See Also

Reference

  • UploadSettings Property
  • Aurigma.ImageUploader.UploadSettings ASP.NET Class
  • $au.uploadSettings JavaScript Class


UploadSettings Members

  • Properties
  • Language Filter ( all languages )

The UploadSettings type exposes the following members.

Properties

 | Name | Description
Public property | ActionUrl | Gets or sets a URL to the page files are posted to.
Public property | AutoRecoveryMaxAttemptCount | Gets or sets a number of tries that should be performed to submit files.
Public property | AutoRecoveryTimeout | Gets or sets an interval in which Image Uploader should try to resume the upload if it was interrupted.
Public property | Charset | Gets or sets a charset used to encode the text data submitted by Image Uploader.
Public property | ChunkSize | Gets or sets a maximium allowed size of binary data (in bytes) uploaded within a POST request.
Public property | ConnectionTimeout | Gets or sets a timeout of the HTTP connection.
Public property | EnableInstantUpload | Gets or sets a value indicating whether to start sending files right after they are added to the upload pane not waiting for Upload button click.
Public property | FilesPerPackage | Gets or sets a number of user-selected files which will be processed and uploaded within a single request.
Public property | ProgressBytesMode | Gets or sets a value specifying how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server.
Public property | RedirectUrl | Gets or sets a URL to which a user will be redirected when the upload successfully completes.
Public property | UploadConverterOutputSeparately | Gets or sets a value indicating whether to send each converted file in a separate request.


UploadSettings Properties

  • Properties
  • Language Filter ( all languages )

The UploadSettings type exposes the following properties.

Properties

 | Name | Description
Public property | ActionUrl | Gets or sets a URL to the page files are posted to.
Public property | AutoRecoveryMaxAttemptCount | Gets or sets a number of tries that should be performed to submit files.
Public property | AutoRecoveryTimeout | Gets or sets an interval in which Image Uploader should try to resume the upload if it was interrupted.
Public property | Charset | Gets or sets a charset used to encode the text data submitted by Image Uploader.
Public property | ChunkSize | Gets or sets a maximium allowed size of binary data (in bytes) uploaded within a POST request.
Public property | ConnectionTimeout | Gets or sets a timeout of the HTTP connection.
Public property | EnableInstantUpload | Gets or sets a value indicating whether to start sending files right after they are added to the upload pane not waiting for Upload button click.
Public property | FilesPerPackage | Gets or sets a number of user-selected files which will be processed and uploaded within a single request.
Public property | ProgressBytesMode | Gets or sets a value specifying how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server.
Public property | RedirectUrl | Gets or sets a URL to which a user will be redirected when the upload successfully completes.
Public property | UploadConverterOutputSeparately | Gets or sets a value indicating whether to send each converted file in a separate request.


UploadSettings.ActionUrl Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the page files are posted to.

Syntax

PHP

public function getActionUrl() {
}

public function setActionUrl($value) {
}

Property Value

Type: string

The URL to the page files are posted to. When specifying this value, take into account the following cases:

Using Quotation Marks and Semicolons

URLs can contain semicolon or quotation mark characters (like this one: http://upload.server.com/uploadFile;jsessionid=123?param='value'). If so, to avoid parameter parsing errors enclose such URLs in single (' ') or double (" ") quotes. Additionally, quotation marks (both single ' and double ") inside URLs should be escaped with a backslash:

"http://upload.server.com/uploadFile;jsessionid=123?param=\'value\'"

Uploading to the Same Page

If you want to submit files to the same page where Image Uploader is hosted, specify the dot character (.) as a value of this property.

Using Absolute and Relative URLs

URLs can be both absolute (e.g. http://domain.com/upload/upload.aspx) and relative to the current page (e.g. /upload/upload.aspx).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/default.aspx page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/upload/upload.aspx" | http://domain.com/upload/upload.aspx
"./upload/upload.aspx" | http://domain.com/ImageUploader/upload/upload.aspx
"upload/upload.aspx" | http://domain.com/ImageUploader/upload/upload.aspx
"upload.aspx" | http://domain.com/ImageUploader/upload.aspx

Default value is ".".

Remarks

That page should contain the server code which parses the upload request, saves files to necessary folders on server and performs any other additional actions.

Note

Usually this URL must have a specific extension (depending on the web server settings). For ASP platform it should be .asp, for ASP.NET the extension is .aspx, for PHP it is .php, for Perl it can be .pl or .cgi, etc. In other words, the file containing this script should have the extension registered in the settings of your web server as a server page. Otherwise upload will fail.

See Also

Reference

  • RedirectUrl Property
  • Aurigma.ImageUploader.UploadSettings.ActionUrl ASP.NET Property
  • $au.uploadSettings.actionUrl JavaScript Property

Manual

  • Configuring Common Upload Settings
  • Saving Uploaded Files in PHP


UploadSettings.AutoRecoveryMaxAttemptCount Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a number of tries that should be performed to submit files.

Syntax

PHP

public function getAutoRecoveryMaxAttemptCount() {
}

public function setAutoRecoveryMaxAttemptCount($value) {
}

Property Value

Type: integer

The number of attempts for upload to do (including the very first attempt). If you want to disable automatic resuming feature, set this property to 1.

Default value is 1.

Remarks

Note

Image Uploader Express does not support automatic upload recovery. See the Comparison of Image Uploader Editions topic for details.

Time interval between each next retry is configured with the AutoRecoveryTimeout property.

Note

Image Uploader tries to resend the request that has failed. If the request (package) contains more than one file, these files will be resent again. It means that if you use the auto-recovering feature, the optimal value for the FilesPerPackage property would be 1.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.AutoRecoveryMaxAttemptCount ASP.NET Property
  • $au.uploadSettings.autoRecoveryMaxAttemptCount JavaScript Property

Manual

  • Configuring Fail-Safe Upload


UploadSettings.AutoRecoveryTimeout Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an interval in which Image Uploader should try to resume the upload if it was interrupted.

Syntax

PHP

public function getAutoRecoveryTimeout() {
}

public function setAutoRecoveryTimeout($value) {
}

Property Value

Type: integer

The number of milliseconds the Image Uploader should wait between attempts.

Default value is 5000.

Remarks

Note

Image Uploader Express does not support automatic upload recovery. See the Comparison of Image Uploader Editions topic for details.

This parameter takes effect if only the AutoRecoveryMaxAttemptCount is greater than 1.

Note

Image Uploader tries to resend the request that has failed. If the request (package) contains more than one file, these files will be resent again. It means that if you use the auto-recovering feature, the optimal value for the FilesPerPackage property would be 1.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.AutoRecoveryTimeout ASP.NET Property
  • $au.uploadSettings.autoRecoveryTimeout JavaScript Property

Manual

  • Configuring Fail-Safe Upload


UploadSettings.Charset Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a charset used to encode the text data submitted by Image Uploader.

Syntax

PHP

public function getCharset() {
}

public function setCharset($value) {
}

Property Value

Type: string

The charset. See possible values in the Remarks section.

Default value is "UTF-8".

Remarks

The table below contains some supported charsets. Visit Sun site for a full list of supported encodings.

Charset | Description
US-ASCII | Seven-bit ASCII, a.k.a. ISO646-US, a.k.a. the Basic Latin block of the Unicode character set.
ISO-8859-1 | ISO Latin Alphabet No. 1, a.k.a. ISO-LATIN-1.
UTF-8 | Eight-bit UCS Transformation Format.
UTF-16BE | Sixteen-bit UCS Transformation Format, big-endian byte order.
UTF-16LE | Sixteen-bit UCS Transformation Format, little-endian byte order.
UTF-16 | Sixteen-bit UCS Transformation Format, byte order identified by an optional byte-order mark.
windows-1250 | Windows Eastern European.
windows-1251 | Windows Cyrillic.
windows-1252 | Windows Latin-1.
windows-1253 | Windows Greek.
windows-1254 | Windows Turkish.
windows-1257 | Windows Baltic.
KOI8-R | KOI-8, Russian.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.Charset ASP.NET Property
  • $au.uploadSettings.charset JavaScript Property


UploadSettings.ChunkSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximium allowed size of binary data (in bytes) uploaded within a POST request.

Syntax

PHP

public function getChunkSize() {
}

public function setChunkSize($value) {
}

Property Value

Type: integer

The number of bytes allowed to upload within a request. When this value is 0, converted file uploaded entirely in accordiance with FilesPerPackage and UploadConverterOutputSeparately properties.

Default value is 0.

Remarks

When this property is greater than 0, Image Uploader adds converted files and metadata to a POST request until the request length exceeds ChunkSize + metadata size bytes. If the last added file does not meet the chunk size limitation, Image Uploader adds just a portion of this file to complete this chunk. The remaining portion will be added at the beginning of the next chunk. Each chunk is submitted to a server as a separate request. It gives a number of benefits: makes each request compartible with maximum POST request length limitation and allows resuming partially uploaded files.

Note

When you turn this mode on, it is highly recommended to use Image Uploader PHP to handle upload on the server side. This wrapper automatically bundles pieces of one file, uploaded in separated chunks, and provides an access to this file as if it was uploaded entirely.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.ChunkSize ASP.NET Property
  • $au.uploadSettings.chunkSize JavaScript Property

Manual

  • Sending All Files at Once or in Several Parts


UploadSettings.ConnectionTimeout Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a timeout of the HTTP connection.

Syntax

PHP

public function getConnectionTimeout() {
}

public function setConnectionTimeout($value) {
}

Property Value

Type: integer

The HTTP timeout (in milliseconds). If 0, timeout is infinite (i.e. disabled).

Default value is 0.

Remarks

When timeout expires, the Image Uploader assumes that the connection has been lost and terminates the upload process.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.ConnectionTimeout ASP.NET Property
  • $au.uploadSettings.connectionTimeout JavaScript Property


UploadSettings.EnableInstantUpload Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to start sending files right after they are added to the upload pane not waiting for Upload button click.

Syntax

PHP

public function getEnableInstantUpload() {
}

public function setEnableInstantUpload($value) {
}

Property Value

Type: boolean

If true, the upload process starts instantly when files are added to the upload pane. Otherwise, the upload starts when the Upload button is clicked.

Default value is false.

Remarks

Note

This property takes effect in OnePane layout only.

If this property is true it causes the following changes in Image Uploader user interface:

  • The uploading files dialog is initially hidden.
  • The status pane is equipped with a progress bar indicating the upload progress.
  • The uploading files dialog can be shown by clicking the status pane.
  • The uploading files dialog contains the Hide button which makes this dialog invisible.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.EnableInstantUpload ASP.NET Property
  • $au.uploadSettings.enableInstantUpload JavaScript Property

Manual

  • Layouts


UploadSettings.FilesPerPackage Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a number of user-selected files which will be processed and uploaded within a single request.

Syntax

PHP

public function getFilesPerPackage() {
}

public function setFilesPerPackage($value) {
}

Property Value

Type: integer

The number of user-serlected files that will be processed and uploaded within a single request. If more files are selected, they are submitted in separate requests. When this value is 0, all the files are uploaded in one request.

Default value is 0.

Remarks

When this property is greater than 0, Image Uploader sends converted files and metadata for FilesPerPackage user-selected files per each request. Typical scenario is when you set this value to 1, i.e. every user-selected file is processed and uploaded in a separate request. It gives a number of benefits: reduces amount of memory used on the server to process requests from Image Uploader and allows resuming partially completed upload if it has been broken, etc.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.FilesPerPackage ASP.NET Property
  • $au.uploadSettings.filesPerPackage JavaScript Property

Manual

  • Sending All Files at Once or in Several Parts
  • Configuring Fail-Safe Upload


UploadSettings.ProgressBytesMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value specifying how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server.

Syntax

PHP

public function getProgressBytesMode() {
}

public function setProgressBytesMode($value) {
}

Property Value

Type: string

The progress bytes estimation mode.

The following values are supported:

Value | Description
ByPackageSize | The size of the uploaded session and the uploaded bytes are measured by the size of the current package. Thus, this mode is the nearest estimation of the uploaded bytes when you set several converters and upload all files in one package (i.e. FilesPerPackage is 0).
BySourceSize | The size of the upload session and the uploaded bytes are measured by sizes of user-selected files. For example, if you select two files of 5 and 10 Mb, the total upload size will be 15 Mb and the amount of uploaded bytes will grow from 0 to 15 Mb during the upload, regardless of converted files and other auxiliary data. Thus, this mode is the nearest estimation of the uploaded bytes when you upload original files only.

Default value is "ByPackageSize".

Remarks

This property determines how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server. These data are used in the uploading files dialog and the Progress event.

See Also

Reference

  • Progress Event
  • FilesPerPackage Property
  • Aurigma.ImageUploader.UploadSettings.ProgressBytesMode ASP.NET Property
  • $au.uploadSettings.progressBytesMode JavaScript Property

Manual

  • Sending All Files at Once or in Several Parts


UploadSettings.RedirectUrl Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to which a user will be redirected when the upload successfully completes.

Syntax

PHP

public function getRedirectUrl() {
}

public function setRedirectUrl($value) {
}

Property Value

Type: string

The URL to which a user will be redirected when the upload successfully completes. If it is an empty string, Image Uploader will not try to redirect.

Default value is "".

See Also

Reference

  • ActionUrl Property
  • Aurigma.ImageUploader.UploadSettings.RedirectUrl ASP.NET Property
  • $au.uploadSettings.redirectUrl JavaScript Property

Manual

  • Configuring Common Upload Settings


UploadSettings.UploadConverterOutputSeparately Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to send each converted file in a separate request.

Syntax

PHP

public function getUploadConverterOutputSeparately() {
}

public function setUploadConverterOutputSeparately($value) {
}

Property Value

Type: boolean

If true, each converted file is uploaded in a separate POST request.

Default value is false.

Remarks

Note

When Image Uploader sends converted files separately it does not take into account the FilesPerPackage value. However, if the ChunkSize is greater than 0, Image Uploader divides converted files, which size exceeds this value, into chunks and sends them separately.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.UploadConverterOutputSeparately ASP.NET Property
  • $au.uploadSettings.uploadConverterOutputSeparately JavaScript Property

Manual

  • Sending All Files at Once or in Several Parts


AmazonS3Extender Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class extends Image Uploader with a direct upload to Amazon S3 storage.

For a list of all members of this class, see AmazonS3Extender Members.

Syntax

PHP

class AmazonS3Extender {
}

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender ASP.NET Class
  • $au.amazonS3Extender JavaScript Class


AmazonS3Extender Members

  • Properties
  • Language Filter ( all languages )

The AmazonS3Extender type exposes the following members.

Constructors

 | Name | Description
Public method | AmazonS3Extender(Uploader) | Creates and initializes an instance of the AmazonS3Extender class.

Properties

 | Name | Description
Public property | AWSAccessKeyId | Gets or set an AWS Access Key ID of the owner of the bucket.
Public property | Bucket | Gets or sets a bucket name.
Public property | BucketHostName | Gets or sets a custom bucket host name.
Public property | Files | Gets or sets a collection of settings for files to be uploaded.
Public property | PolicyExpiration | Gets or sets an expiration date of the policy.
Public property | SecretAccessKey | Gets or sets a secret access key.


AmazonS3Extender(Uploader) Constructor

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the AmazonS3Extender class.

Syntax

PHP

public function AmazonS3Extender($uploader) {
}

Parameters

uploader

Type: Uploader

The Uploader object to create this AmazonS3Extender for.

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender ASP.NET Constructor
  • $au.amazonS3Extender(uploader) JavaScript Constructor


AmazonS3Extender Properties

  • Properties
  • Language Filter ( all languages )

The AmazonS3Extender type exposes the following properties.

Properties

 | Name | Description
Public property | AWSAccessKeyId | Gets or set an AWS Access Key ID of the owner of the bucket.
Public property | Bucket | Gets or sets a bucket name.
Public property | BucketHostName | Gets or sets a custom bucket host name.
Public property | Files | Gets or sets a collection of settings for files to be uploaded.
Public property | PolicyExpiration | Gets or sets an expiration date of the policy.
Public property | SecretAccessKey | Gets or sets a secret access key.


AmazonS3Extender.AWSAccessKeyId Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or set an AWS Access Key ID of the owner of the bucket.

Syntax

PHP

public function getAWSAccessKeyId() {
}

public function setAWSAccessKeyId($value) {
}

Property Value

Type: string

The AWS Access Key ID of the owner of the bucket.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender.AWSAccessKeyId ASP.NET Property
  • $au.amazonS3Extender.accessKeyId JavaScript Property


AmazonS3Extender.Bucket Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a bucket name.

Syntax

PHP

public function getBucket() {
}

public function setBucket($value) {
}

Property Value

Type: string

The bucket name.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender.Bucket ASP.NET Property
  • $au.amazonS3Extender.bucket JavaScript Property


AmazonS3Extender.BucketHostName Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a custom bucket host name.

Syntax

PHP

public function getBucketHostName() {
}

public function setBucketHostName($value) {
}

Property Value

Type: string

The custom bucket host name.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender.BucketHostName ASP.NET Property
  • $au.amazonS3Extender.bucketHostName JavaScript Property


AmazonS3Extender.Files Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a collection of settings for files to be uploaded.

Syntax

PHP

public function &getFiles() {
}

public function setFiles($value) {
}

Property Value

Type: array

The collection of settings for files to be uploaded.

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender.Files ASP.NET Property
  • $au.amazonS3Extender.converters JavaScript Property


AmazonS3Extender.PolicyExpiration Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an expiration date of the policy.

Syntax

PHP

public function getPolicyExpiration() {
}

public function setPolicyExpiration($value) {
}

Property Value

Type: integer

The expiration date of the policy.

Default value is 86400.

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender.PolicyExpiration ASP.NET Property


AmazonS3Extender.SecretAccessKey Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a secret access key.

Syntax

PHP

public function getSecretAccessKey() {
}

public function setSecretAccessKey($value) {
}

Property Value

Type: string

The secret access key.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender.SecretAccessKey ASP.NET Property


FileSettings Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class contains a list of settings for file to be uploaded to Amazon S3 storage.

For a list of all members of this class, see FileSettings Members.

Syntax

PHP

class FileSettings {
}

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.FileSettings ASP.NET Class
  • $au.amazonS3Extender.fileSettings JavaScript Class


FileSettings Members

  • Properties
  • Language Filter ( all languages )

The FileSettings type exposes the following members.

Properties

 | Name | Description
Public property | Acl | Gets or sets an Amazon S3 access control list. Options include private, public-read, public-read-write, and authenticated-read.
Public property | Key | Gets or sets an Amazon S3 file key.
Public property | MaxFileSize | Gets or sets a maximum allowable size for file to be uploaded.
Public property | Meta | Gets or sets an array of metadata fields to be uploaded to Amazon S3 storage.
Public property | MinFileSize | Gets or sets a minimum allowable size for file to be uploaded.


FileSettings Properties

  • Properties
  • Language Filter ( all languages )

The FileSettings type exposes the following properties.

Properties

 | Name | Description
Public property | Acl | Gets or sets an Amazon S3 access control list. Options include private, public-read, public-read-write, and authenticated-read.
Public property | Key | Gets or sets an Amazon S3 file key.
Public property | MaxFileSize | Gets or sets a maximum allowable size for file to be uploaded.
Public property | Meta | Gets or sets an array of metadata fields to be uploaded to Amazon S3 storage.
Public property | MinFileSize | Gets or sets a minimum allowable size for file to be uploaded.


FileSettings.Acl Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an Amazon S3 access control list. Options include private, public-read, public-read-write, and authenticated-read.

Syntax

PHP

public function getAcl() {
}

public function setAcl($value) {
}

Property Value

Type: string

The Amazon S3 access control list.

Default value is "private".

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.FileSettings.Acl ASP.NET Property
  • $au.amazonS3Extender.fileSettings.acl JavaScript Property


FileSettings.Key Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an Amazon S3 file key.

Syntax

PHP

public function getKey() {
}

public function setKey($value) {
}

Property Value

Type: string

The Amazon S3 file key.

Default value is "${filename}".

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.FileSettings.Key ASP.NET Property
  • $au.amazonS3Extender.fileSettings.key JavaScript Property


FileSettings.MaxFileSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum allowable size for file to be uploaded.

Syntax

PHP

public function getMaxFileSize() {
}

public function setMaxFileSize($value) {
}

Property Value

Type: integer

The maximum allowable size for file to be uploaded.

Default value is 5368709120.

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.FileSettings.MaxFileSize ASP.NET Property


FileSettings.Meta Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of metadata fields to be uploaded to Amazon S3 storage.

Syntax

PHP

public function &getMeta() {
}

public function setMeta($value) {
}

Property Value

Type: array

The array of metadata fields to be uploaded to Amazon S3 storage.

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.FileSettings.Meta ASP.NET Property
  • $au.amazonS3Extender.fileSettings.meta JavaScript Property


FileSettings.MinFileSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum allowable size for file to be uploaded.

Syntax

PHP

public function getMinFileSize() {
}

public function setMinFileSize($value) {
}

Property Value

Type: integer

The minimum allowable size for file to be uploaded.

Default value is 0.

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.FileSettings.MinFileSize ASP.NET Property


NirvanixExtender Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class extends Image Uploader with a direct upload to Nirvanix storage.

For a list of all members of this class, see NirvanixExtender Members.

Syntax

PHP

class NirvanixExtender {
}

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender ASP.NET Class
  • $au.nirvanixExtender JavaScript Class


NirvanixExtender Members

  • Properties
  • Language Filter ( all languages )

The NirvanixExtender type exposes the following members.

Constructors

 | Name | Description
Public method | NirvanixExtender(Uploader) | Creates and initializes an instance of the NirvanixExtender class.

Properties

 | Name | Description
Public property | AppKey | Gets or sets an application key that contains the user to be logged in.
Public property | DestFolderPath | Gets or sets a destination path of the files being uploaded.
Public property | FileOverwrite | Gets or sets a value indicating whether a file with the same name in the destination folder should be overwritten by a file uploaded using the upload token.
Public property | FirstByteExpiration | Gets or sets a number of seconds the upload token has until the first byte of an upload is transferred.
Public property | IpRestricted | Gets or sets a value indicating whether the upload token should be restricted to the consumerIP.
Public property | LastByteExpiration | Gets or sets a number of seconds the upload token has until an upload is completed.
Public property | Password | Gets or sets the password for the account.
Public property | SizeBytes | Gets or sets a size of the file to be uploaded in bytes.
Public property | Username | Gets or sets an account name to log in with.


NirvanixExtender(Uploader) Constructor

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the NirvanixExtender class.

Syntax

PHP

public function NirvanixExtender($uploader) {
}

Parameters

uploader

Type: Uploader

The Uploader object to create this NirvanixExtender for.

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender ASP.NET Constructor
  • $au.nirvanixExtender(uploader) JavaScript Constructor


NirvanixExtender Properties

  • Properties
  • Language Filter ( all languages )

The NirvanixExtender type exposes the following properties.

Properties

 | Name | Description
Public property | AppKey | Gets or sets an application key that contains the user to be logged in.
Public property | DestFolderPath | Gets or sets a destination path of the files being uploaded.
Public property | FileOverwrite | Gets or sets a value indicating whether a file with the same name in the destination folder should be overwritten by a file uploaded using the upload token.
Public property | FirstByteExpiration | Gets or sets a number of seconds the upload token has until the first byte of an upload is transferred.
Public property | IpRestricted | Gets or sets a value indicating whether the upload token should be restricted to the consumerIP.
Public property | LastByteExpiration | Gets or sets a number of seconds the upload token has until an upload is completed.
Public property | Password | Gets or sets the password for the account.
Public property | SizeBytes | Gets or sets a size of the file to be uploaded in bytes.
Public property | Username | Gets or sets an account name to log in with.


NirvanixExtender.AppKey Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an application key that contains the user to be logged in.

Syntax

PHP

public function getAppKey() {
}

public function setAppKey($value) {
}

Property Value

Type: string

The application key that contains the user to be logged in.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender.AppKey ASP.NET Property


NirvanixExtender.DestFolderPath Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a destination path of the files being uploaded.

Syntax

PHP

public function getDestFolderPath() {
}

public function setDestFolderPath($value) {
}

Property Value

Type: string

The destination path of the files being uploaded.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender.DestFolderPath ASP.NET Property
  • $au.nirvanixExtender.destFolderPath JavaScript Property


NirvanixExtender.FileOverwrite Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether a file with the same name in the destination folder should be overwritten by a file uploaded using the upload token.

Syntax

PHP

public function getFileOverwrite() {
}

public function setFileOverwrite($value) {
}

Property Value

Type: boolean

If true, a file with the same name in the destination folder will be overwritten by a file uploaded using the upload token. Otherwise, name collisions will result in an upload error.

Default value is false.

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender.FileOverwrite ASP.NET Property


NirvanixExtender.FirstByteExpiration Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a number of seconds the upload token has until the first byte of an upload is transferred.

Syntax

PHP

public function getFirstByteExpiration() {
}

public function setFirstByteExpiration($value) {
}

Property Value

Type: integer

The number of seconds the upload token has until the first byte of an upload is transferred.

Default value is 600.

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender.FirstByteExpiration ASP.NET Property


NirvanixExtender.IpRestricted Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the upload token should be restricted to the consumerIP.

Syntax

PHP

public function getIpRestricted() {
}

public function setIpRestricted($value) {
}

Property Value

Type: boolean

If true, the upload token will be restricted to the consumerIP.

Default value is false.

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender.IpRestricted ASP.NET Property


NirvanixExtender.LastByteExpiration Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a number of seconds the upload token has until an upload is completed.

Syntax

PHP

public function getLastByteExpiration() {
}

public function setLastByteExpiration($value) {
}

Property Value

Type: integer

The number of seconds the upload token has until an upload is completed.

Default value is 259200.

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender.LastByteExpiration ASP.NET Property


NirvanixExtender.Password Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the password for the account.

Syntax

PHP

public function getPassword() {
}

public function setPassword($value) {
}

Property Value

Type: string

The password for the account.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender.Password ASP.NET Property


NirvanixExtender.SizeBytes Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a size of the file to be uploaded in bytes.

Syntax

PHP

public function getSizeBytes() {
}

public function setSizeBytes($value) {
}

Property Value

Type: integer

The size of the file to be uploaded in bytes.

Default value is 10485760.

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender.SizeBytes ASP.NET Property


NirvanixExtender.Username Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an account name to log in with.

Syntax

PHP

public function getUsername() {
}

public function setUsername($value) {
}

Property Value

Type: string

The account name to log in with.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender.Username ASP.NET Property


Image Uploader JavaScript Reference

Image Uploader JavaScript is a collection of JavaScript classes that are used to embed Image Uploader to the HTML page. Refer to the documentation to get started with Image Uploader JavaScript.

Namespaces

Name | Description
$au | This is a root namespace of Image Uploader JavaScript.
$au.amazonS3Extender | The $au.amazonS3Extender namespace contains classes related to AmazonS3 extender.
$au.nirvanixExtender | The $au.nirvanixExtender namespace contains classes related to Nirvanix extender.


$au Namespace

This is a root namespace of Image Uploader JavaScript.

Classes

 | Name | Description
Public class | activeXControl | This class represents Image Uploader ActiveX control.
Public class | addFilesProgressDialog | This class represents the adding files dialog which appears when a user selects quite a lot of files.
Public class | authenticationDialog | This class represents the authentication dialog.
Public class | events | This class provides access to Image Uploader client-side events.
Public class | contextMenu | This class represents Image Uploader context menu. Use this class to customize or localize context menu options.
Public class | converter | This class represents a file converter.
Public class | converters | This class represents a collection of file converters.
Public class | debug | This class allows debugging the script which embeds Image Uploader into a page.
Public class | deleteFilesDialog | This class represents the delete confirmation dialog which appears in non-Internet Explorer browsers when enableOriginalFilesDeletion is true.
Public class | descriptionEditor | This class represents the description editor.
Public class | detailsViewColumns | This class contains titles of columns displayed in the Details view.
Public class | event | This class represents a collection of client-side event handlers.
Public class | file | This class represents the file actually contained in the upload pane.
Public class | files | This class represents a collection of files added to the upload pane. See Example for details.
Public class | folderPane | This class represents the folder pane.
Public class | imageEditor | This class represents the image editor.
Public class | informationBar | This class represents the information bar.
Public class | installationProgress | This class allows displaying special screens instead of Image Uploader during the downloading and installation phases.
Public class | javaControl | This class represents Image Uploader Java applet.
Public class | messages | This class contains error messages Image Uploader shows.
Public class | metadata | This class represents a name-value collection of additional upload data.
Public class | paneItem | This class represents a pane item displayed in both the upload and folder panes.
Public class | qualityMeter | This class represents the quality meter.
Public class | restrictions | This class contains masks for allowed and denied file extensions and upload restrictions.
Public class | statusPane | This class represents the status pane.
Public class | thumbnail | This class represents a standalone thumbnail bound with some upload pane item of Image Uploader.
Public class | thumbnailEvents | This class provides access to client-side events of the thumbnail control.
Public class | treePane | This class represents the tree pane.
Public class | uploader | This class is intended for embedding Image Uploader into a web page.
Public class | uploadPane | This class represents the upload pane.
Public class | uploadProgressDialog | This class represents the uploading files dialog which appears during the upload.
Public class | uploadSettings | This class represents the upload settings.

See Also

Reference

  • Aurigma.ImageUploader ASP.NET Namespace


activeXControl Class

  • Supported browsers: Internet Explorer

This class represents Image Uploader ActiveX control.

For a list of all members of this class, see activeXControl Members.

Syntax

JavaScript

$au.activeXControl = function() {
}

Remarks

Note

This client-side control is used in Internet Explorer only.

See Also

Reference

  • activeXControl Property
  • Aurigma.ImageUploader.ActiveXControl ASP.NET Class
  • ActiveXControl PHP Class


activeXControl Members

  • Properties
  • Language Filter ( all languages )

The activeXControl type exposes the following members.

Properties

 | Name | Description
Public property | actualVersion | Gets a version of the currently installed ActiveX control.
Public property | classId | Gets or sets a CLSID of the ActiveX control.
Public property | codeBase | Gets or sets a URL to the ImageUploader7.cab file.
Public property | progId | Gets or sets a PROGID of the ActiveX control.
Public property | version | Gets or sets a minimum required version of the ActiveX control.


activeXControl Properties

  • Properties
  • Language Filter ( all languages )

The activeXControl type exposes the following properties.

Properties

 | Name | Description
Public property | actualVersion | Gets a version of the currently installed ActiveX control.
Public property | classId | Gets or sets a CLSID of the ActiveX control.
Public property | codeBase | Gets or sets a URL to the ImageUploader7.cab file.
Public property | progId | Gets or sets a PROGID of the ActiveX control.
Public property | version | Gets or sets a minimum required version of the ActiveX control.


activeXControl.actualVersion Property

  • Supported browsers: Internet Explorer

Gets a version of the currently installed ActiveX control.

Syntax

JavaScript

Get/Set Value at Runtime

value = $au.uploader('uploaderID').activeXControl().actualVersion();

Property Value

Type: string

The version number of the currently installed ActiveX control.


activeXControl.classId Property

  • Supported browsers: Internet Explorer

Gets or sets a CLSID of the ActiveX control.

Syntax

JavaScript

Initialize

$au.uploader({
    activeXControl: {
        //...other params...
        classId: "",
        //...other params...
    }
})

Property Value

Type: String

The CLSID of the ActiveX control.

Default value is "".

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ActiveXControl.ClassId ASP.NET Property
  • ActiveXControl.ClassId PHP Property

Manual

  • Using Private-label Version of Image Uploader JavaScript


activeXControl.codeBase Property

  • Supported browsers: Internet Explorer

Gets or sets a URL to the ImageUploader7.cab file.

Syntax

JavaScript

Initialize

$au.uploader({
    activeXControl: {
        //...other params...
        codeBase: "Scripts/ImageUploader7.cab",
        //...other params...
    }
})

Property Value

Type: String

The URL to the ImageUploader7.cab file.

Default value is "Scripts/ImageUploader7.cab".

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Manual

  • Using Private-label Version of Image Uploader JavaScript


activeXControl.progId Property

  • Supported browsers: Internet Explorer

Gets or sets a PROGID of the ActiveX control.

Syntax

JavaScript

Initialize

$au.uploader({
    activeXControl: {
        //...other params...
        progId: "",
        //...other params...
    }
})

Property Value

Type: String

The PROGID of the ActiveX control.

Default value is "".

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ActiveXControl.ProgId ASP.NET Property
  • ActiveXControl.ProgId PHP Property

Manual

  • Using Private-label Version of Image Uploader JavaScript


activeXControl.version Property

  • Supported browsers: Internet Explorer

Gets or sets a minimum required version of the ActiveX control.

Syntax

JavaScript

Initialize

$au.uploader({
    activeXControl: {
        //...other params...
        version: "",
        //...other params...
    }
})

Property Value

Type: string

The minimum required version of the ActiveX control.

Default value is "".


addFilesProgressDialog Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the adding files dialog which appears when a user selects quite a lot of files.

For a list of all members of this class, see addFilesProgressDialog Members.

Syntax

JavaScript

$au.addFilesProgressDialog = function() {
}

See Also

Reference

  • addFilesProgressDialog Property
  • Aurigma.ImageUploader.AddFilesProgressDialog ASP.NET Class
  • AddFilesProgressDialog PHP Class

Manual

  • Customizing Appearance


addFilesProgressDialog Members

  • Properties
  • Language Filter ( all languages )

The addFilesProgressDialog type exposes the following members.

Properties

 | Name | Description
Public property | cancelButtonText | Gets or sets a caption of the Cancel button on the dialog displayed when a user selects quite a lot of files.
Public property | currentFileText | Gets or sets a text of the label which displays a name of the currently processing file.
Public property | titleText | Gets or sets a title of the dialog displayed when a user selects quite a lot of files.
Public property | totalFilesText | Get or sets a text of the label which displays a total number of processed files.
Public property | waitText | Gets or sets a text of the label which is displayed while Image Uploader is preparing to add files.


addFilesProgressDialog Properties

  • Properties
  • Language Filter ( all languages )

The addFilesProgressDialog type exposes the following properties.

Properties

 | Name | Description
Public property | cancelButtonText | Gets or sets a caption of the Cancel button on the dialog displayed when a user selects quite a lot of files.
Public property | currentFileText | Gets or sets a text of the label which displays a name of the currently processing file.
Public property | titleText | Gets or sets a title of the dialog displayed when a user selects quite a lot of files.
Public property | totalFilesText | Get or sets a text of the label which displays a total number of processed files.
Public property | waitText | Gets or sets a text of the label which is displayed while Image Uploader is preparing to add files.


addFilesProgressDialog.cancelButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel button on the dialog displayed when a user selects quite a lot of files.

Syntax

JavaScript

Initialize

$au.uploader({
    addFilesProgressDialog: {
        //...other params...
        cancelButtonText: "Cancel",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Cancel button on the adding files dialog.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AddFilesProgressDialog.CancelButtonText ASP.NET Property
  • AddFilesProgressDialog.CancelButtonText PHP Property


addFilesProgressDialog.currentFileText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text of the label which displays a name of the currently processing file.

Syntax

JavaScript

Initialize

$au.uploader({
    addFilesProgressDialog: {
        //...other params...
        currentFileText: "Processing file: '[name]'",
        //...other params...
    }
})

Property Value

Type: String

The text of the Processing file label. It can contain the following placeholder:

[name]
replaced by the name of the currently processing file.

Default value is "Processing file: '[name]'".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AddFilesProgressDialog.CurrentFileText ASP.NET Property
  • AddFilesProgressDialog.CurrentFileText PHP Property


addFilesProgressDialog.titleText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the dialog displayed when a user selects quite a lot of files.

Syntax

JavaScript

Initialize

$au.uploader({
    addFilesProgressDialog: {
        //...other params...
        titleText: "Adding files to upload queue",
        //...other params...
    }
})

Property Value

Type: String

The title of the adding files dialog.

Default value is "Adding files to upload queue".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AddFilesProgressDialog.TitleText ASP.NET Property
  • AddFilesProgressDialog.TitleText PHP Property


addFilesProgressDialog.totalFilesText Property

  • Supported browsers: Firefox Google Chrome Safari

Get or sets a text of the label which displays a total number of processed files.

Syntax

JavaScript

Initialize

$au.uploader({
    addFilesProgressDialog: {
        //...other params...
        totalFilesText: "already processed files: [count]",
        //...other params...
    }
})

Property Value

Type: String

The text of the Already processed files label. It can contain the following placeholder:

[count]
replaced by the total number of processed files.

Default value is "already processed files: [count]".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AddFilesProgressDialog.TotalFilesText ASP.NET Property
  • AddFilesProgressDialog.TotalFilesText PHP Property


addFilesProgressDialog.waitText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the label which is displayed while Image Uploader is preparing to add files.

Syntax

JavaScript

Initialize

$au.uploader({
    addFilesProgressDialog: {
        //...other params...
        waitText: "Please wait, it may take some time...",
        //...other params...
    }
})

Property Value

Type: String

The text of the Please wait label.

Default value is "Please wait, it may take some time...".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AddFilesProgressDialog.WaitText ASP.NET Property
  • AddFilesProgressDialog.WaitText PHP Property


authenticationDialog Class

  • Supported browsers: Firefox Google Chrome Safari

This class represents the authentication dialog.

For a list of all members of this class, see authenticationDialog Members.

Syntax

JavaScript

$au.authenticationDialog = function() {
}

Remarks

This dialog is displayed when the server requests a password. It is displayed during each upload session, i.e. it does not remember the login information.

Note

The authentication dialog is displayed in non-Internet Explorer browsers only.

See Also

Reference

  • authenticationDialog Property
  • Aurigma.ImageUploader.AuthenticationDialog ASP.NET Class
  • AuthenticationDialog PHP Class

Manual

  • Adding Authentication


authenticationDialog Members

  • Properties
  • Language Filter ( all languages )

The authenticationDialog type exposes the following members.

Properties

 | Name | Description
Public property | cancelButtonText | Gets or sets a caption of the Cancel button.
Public property | loginText | Gets or sets a text of the Login label.
Public property | okButtonText | Gets or sets a caption of the Ok button.
Public property | passwordText | Gets or sets a text of the Password label.
Public property | realmText | Gets or sets a text of the Realm label.
Public property | text | Gets or sets a text of the dialog message.


authenticationDialog Properties

  • Properties
  • Language Filter ( all languages )

The authenticationDialog type exposes the following properties.

Properties

 | Name | Description
Public property | cancelButtonText | Gets or sets a caption of the Cancel button.
Public property | loginText | Gets or sets a text of the Login label.
Public property | okButtonText | Gets or sets a caption of the Ok button.
Public property | passwordText | Gets or sets a text of the Password label.
Public property | realmText | Gets or sets a text of the Realm label.
Public property | text | Gets or sets a text of the dialog message.


authenticationDialog.cancelButtonText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the Cancel button.

Syntax

JavaScript

Initialize

$au.uploader({
    authenticationDialog: {
        //...other params...
        cancelButtonText: "Cancel",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Cancel button.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AuthenticationDialog.CancelButtonText ASP.NET Property
  • AuthenticationDialog.CancelButtonText PHP Property


authenticationDialog.loginText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the Login label.

Syntax

JavaScript

Initialize

$au.uploader({
    authenticationDialog: {
        //...other params...
        loginText: "Login:",
        //...other params...
    }
})

Property Value

Type: String

The text of the Login label.

Default value is "Login:".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AuthenticationDialog.LoginText ASP.NET Property
  • AuthenticationDialog.LoginText PHP Property


authenticationDialog.okButtonText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the Ok button.

Syntax

JavaScript

Initialize

$au.uploader({
    authenticationDialog: {
        //...other params...
        okButtonText: "Ok",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Ok button.

Default value is "Ok".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AuthenticationDialog.OkButtonText ASP.NET Property
  • AuthenticationDialog.OkButtonText PHP Property


authenticationDialog.passwordText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the Password label.

Syntax

JavaScript

Initialize

$au.uploader({
    authenticationDialog: {
        //...other params...
        passwordText: "Password:",
        //...other params...
    }
})

Property Value

Type: String

The text of the Password label.

Default value is "Password:".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AuthenticationDialog.PasswordText ASP.NET Property
  • AuthenticationDialog.PasswordText PHP Property


authenticationDialog.realmText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the Realm label.

Syntax

JavaScript

Initialize

$au.uploader({
    authenticationDialog: {
        //...other params...
        realmText: "Realm:",
        //...other params...
    }
})

Property Value

Type: String

The text of the Realm label.

Default value is "Realm:".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AuthenticationDialog.RealmText ASP.NET Property
  • AuthenticationDialog.RealmText PHP Property


authenticationDialog.text Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text of the dialog message.

Syntax

JavaScript

Initialize

$au.uploader({
    authenticationDialog: {
        //...other params...
        text: "Host [name] requires authentication",
        //...other params...
    }
})

Property Value

Type: String

The text of the dialog message. It can contain the following placeholder:

[name]
replaced by the name of the server which requests authentication.

Default value is "Host [name] requires authentication".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.AuthenticationDialog.Text ASP.NET Property
  • AuthenticationDialog.Text PHP Property


contextMenu Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents Image Uploader context menu. Use this class to customize or localize context menu options.

For a list of all members of this class, see contextMenu Members.

Syntax

JavaScript

$au.contextMenu = function() {
}

See Also

Reference

  • contextMenu Property
  • Aurigma.ImageUploader.ContextMenu ASP.NET Class
  • ContextMenu PHP Class

Manual

  • Customizing Appearance


contextMenu Members

  • Properties
  • Language Filter ( all languages )

The contextMenu type exposes the following members.

Properties

 | Name | Description
Public property | arrangeByDimensionsText | Gets or sets a caption of the Dimensions context menu item inside Arrange by group.
Public property | arrangeByModifiedText | Gets or sets a caption of the Date modified context menu item inside Arrange by group.
Public property | arrangeByNameText | Gets or sets a caption of the Name context menu item inside Arrange by group.
Public property | arrangeByPathText | Gets or sets a caption of the Path context menu item inside Arrange by group.
Public property | arrangeBySizeText | Gets or sets a caption of the Size context menu item inside Arrange by group.
Public property | arrangeByText | Gets or sets a caption of the Sort by context menu.
Public property | arrangeByTypeText | Gets or sets a caption of the Item type context menu item inside Arrange by group.
Public property | checkAllText | Gets or sets a caption of the Check all context menu item.
Public property | checkText | Gets or sets a caption of the Check context menu item.
Public property | detailsViewText | Gets or sets a caption of the Details context menu item.
Public property | editDescriptionText | Gets or sets a caption of the Edit description context menu item.
Public property | editText | Gets or sets a caption of the Edit image context menu item.
Public property | listViewText | Gets or sets a caption of the List context menu item.
Public property | openText | Gets or sets a caption of the Open context menu item.
Public property | pasteText | Gets or sets a caption of the Paste context menu item.
Public property | removeAllText | Gets or sets a caption of the Remove all from upload list context menu item.
Public property | removeText | Gets or sets a caption of the Remove from upload list context menu item.
Public property | thumbnailsViewText | Gets or sets a caption of the Thumbnails context menu item.
Public property | tilesViewText | Gets or sets a caption of the Tiles context menu item.
Public property | uncheckAllText | Gets or sets a caption of the Uncheck all context menu item.
Public property | uncheckText | Gets or sets a caption of the Uncheck context menu item.


contextMenu Properties

  • Properties
  • Language Filter ( all languages )

The contextMenu type exposes the following properties.

Properties

 | Name | Description
Public property | arrangeByDimensionsText | Gets or sets a caption of the Dimensions context menu item inside Arrange by group.
Public property | arrangeByModifiedText | Gets or sets a caption of the Date modified context menu item inside Arrange by group.
Public property | arrangeByNameText | Gets or sets a caption of the Name context menu item inside Arrange by group.
Public property | arrangeByPathText | Gets or sets a caption of the Path context menu item inside Arrange by group.
Public property | arrangeBySizeText | Gets or sets a caption of the Size context menu item inside Arrange by group.
Public property | arrangeByText | Gets or sets a caption of the Sort by context menu.
Public property | arrangeByTypeText | Gets or sets a caption of the Item type context menu item inside Arrange by group.
Public property | checkAllText | Gets or sets a caption of the Check all context menu item.
Public property | checkText | Gets or sets a caption of the Check context menu item.
Public property | detailsViewText | Gets or sets a caption of the Details context menu item.
Public property | editDescriptionText | Gets or sets a caption of the Edit description context menu item.
Public property | editText | Gets or sets a caption of the Edit image context menu item.
Public property | listViewText | Gets or sets a caption of the List context menu item.
Public property | openText | Gets or sets a caption of the Open context menu item.
Public property | pasteText | Gets or sets a caption of the Paste context menu item.
Public property | removeAllText | Gets or sets a caption of the Remove all from upload list context menu item.
Public property | removeText | Gets or sets a caption of the Remove from upload list context menu item.
Public property | thumbnailsViewText | Gets or sets a caption of the Thumbnails context menu item.
Public property | tilesViewText | Gets or sets a caption of the Tiles context menu item.
Public property | uncheckAllText | Gets or sets a caption of the Uncheck all context menu item.
Public property | uncheckText | Gets or sets a caption of the Uncheck context menu item.


contextMenu.arrangeByDimensionsText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the Dimensions context menu item inside Arrange by group.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        arrangeByDimensionsText: "Dimensions",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Dimensions context menu item.

Default value is "Dimensions".

Remarks

This menu item sorts files in a pane by image dimensions.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeByDimensionsText ASP.NET Property
  • ContextMenu.ArrangeByDimensionsText PHP Property


contextMenu.arrangeByModifiedText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Date modified context menu item inside Arrange by group.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        arrangeByModifiedText: "Date modified",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Date modified context menu item.

Default value is "Date modified".

Remarks

This menu item sorts files in a pane by last modified date.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeByModifiedText ASP.NET Property
  • ContextMenu.ArrangeByModifiedText PHP Property


contextMenu.arrangeByNameText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Name context menu item inside Arrange by group.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        arrangeByNameText: "Name",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Name context menu item.

Default value is "Name".

Remarks

This menu item sorts files in a pane by file name.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeByNameText ASP.NET Property
  • ContextMenu.ArrangeByNameText PHP Property


contextMenu.arrangeByPathText Property

  • Supported browsers: Internet Explorer

Gets or sets a caption of the Path context menu item inside Arrange by group.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        arrangeByPathText: "Path",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Path context menu item.

Default value is "Path".

Remarks

This menu item sorts files in a pane by file path.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeByPathText ASP.NET Property
  • ContextMenu.ArrangeByPathText PHP Property


contextMenu.arrangeBySizeText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Size context menu item inside Arrange by group.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        arrangeBySizeText: "Size",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Size context menu item.

Default value is "Size".

Remarks

This menu item sorts files in a pane by file size.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeBySizeText ASP.NET Property
  • ContextMenu.ArrangeBySizeText PHP Property


contextMenu.arrangeByText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Sort by context menu.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        arrangeByText: "Sort by",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Sort by context menu item.

Default value is "Sort by".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeByText ASP.NET Property
  • ContextMenu.ArrangeByText PHP Property


contextMenu.arrangeByTypeText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Item type context menu item inside Arrange by group.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        arrangeByTypeText: "Type",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Item type context menu item.

Default value is "Type".

Remarks

This menu item sorts files in a pane by file type.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ArrangeByTypeText ASP.NET Property
  • ContextMenu.ArrangeByTypeText PHP Property


contextMenu.checkAllText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Check all context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        checkAllText: "Check all",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Check all context menu item.

Default value is "Check all".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.CheckAllText ASP.NET Property
  • ContextMenu.CheckAllText PHP Property


contextMenu.checkText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Check context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        checkText: "Check",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Check context menu item.

Default value is "Check".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.CheckText ASP.NET Property
  • ContextMenu.CheckText PHP Property


contextMenu.detailsViewText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Details context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        detailsViewText: "Details",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Details context menu item.

Default value is "Details".

Remarks

This menu item switches the current pane view to Details mode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.DetailsViewText ASP.NET Property
  • ContextMenu.DetailsViewText PHP Property


contextMenu.editDescriptionText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Edit description context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        editDescriptionText: "Edit description...",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Edit description context menu item.

Default value is "Edit description...".

Remarks

This menu item opens the description editor.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.EditDescriptionText ASP.NET Property
  • ContextMenu.EditDescriptionText PHP Property


contextMenu.editText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Edit image context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        editText: "Edit image...",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Edit image context menu item.

Default value is "Edit image...".

Remarks

This menu item opens the image in the image editor.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.EditText ASP.NET Property
  • ContextMenu.EditText PHP Property


contextMenu.listViewText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the List context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        listViewText: "List",
        //...other params...
    }
})

Property Value

Type: String

The caption of the List context menu item.

Default value is "List".

Remarks

This menu item switches the current pane view to List mode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ListViewText ASP.NET Property
  • ContextMenu.ListViewText PHP Property


contextMenu.openText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Open context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        openText: "Open",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Open context menu item.

Default value is "Open".

Remarks

This menu item opens the file in the associated viewer software.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.OpenText ASP.NET Property
  • ContextMenu.OpenText PHP Property


contextMenu.pasteText Property

  • Supported browsers: Internet Explorer

Gets or sets a caption of the Paste context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        pasteText: "Paste",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Paste context menu item.

Default value is "Paste".

Remarks

This menu item pastes an image (not a file) from a clipboard to the upload pane.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.PasteText ASP.NET Property
  • ContextMenu.PasteText PHP Property


contextMenu.removeAllText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Remove all from upload list context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        removeAllText: "Remove all",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Remove all from upload list context menu item.

Default value is "Remove all".

Remarks

This menu item clears the upload list.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.RemoveAllText ASP.NET Property
  • ContextMenu.RemoveAllText PHP Property


contextMenu.removeText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Remove from upload list context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        removeText: "Remove",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Remove from upload list context menu item.

Default value is "Remove".

Remarks

This menu item removes selected items from the upload list.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.RemoveText ASP.NET Property
  • ContextMenu.RemoveText PHP Property


contextMenu.thumbnailsViewText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Thumbnails context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        thumbnailsViewText: "Thumbnails",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Thumbnails context menu item.

Default value is "Thumbnails".

Remarks

This menu item switches the current pane view to Thumbnails mode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.ThumbnailsViewText ASP.NET Property
  • ContextMenu.ThumbnailsViewText PHP Property


contextMenu.tilesViewText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Tiles context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        tilesViewText: "Tiles",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Tiles context menu item.

Default value is "Tiles".

Remarks

This menu item switches the current pane view to Tiles mode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.TilesViewText ASP.NET Property
  • ContextMenu.TilesViewText PHP Property


contextMenu.uncheckAllText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Uncheck all context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        uncheckAllText: "Uncheck all",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Uncheck all context menu item.

Default value is "Uncheck all".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.UncheckAllText ASP.NET Property
  • ContextMenu.UncheckAllText PHP Property


contextMenu.uncheckText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Uncheck context menu item.

Syntax

JavaScript

Initialize

$au.uploader({
    contextMenu: {
        //...other params...
        uncheckText: "Uncheck",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Uncheck context menu item.

Default value is "Uncheck".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ContextMenu.UncheckText ASP.NET Property
  • ContextMenu.UncheckText PHP Property


converter Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a file converter.

For a list of all members of this class, see converter Members.

Syntax

JavaScript

$au.converter = function() {
}

Remarks

Image Uploader allows sending so-called converted files for each of the user-selected files. These files are configured using the converters property of the uploader object. This property accepts a collection of converter instances. Each converter describes one file (source, thumbnail, icon, or ZIP archive) to be uploaded for every file a user selects.

For example, you set the following collection of converters:

JavaScript

var u = $au.uploader({
    id: 'Uploader1',
    converters: [
        {mode: '*.*=SourceFile'},
        {mode: '*.*=Thumbnail;*.*=Icon', thumbnailFitMode: 'Fit', thumbnailWidth: '120', thumbnailHeight: '120'}
    ]
});

It means that Image Uploader will send an original file and its resized copy or icon. So if a user selects two files (a JPEG image and a PDF document) Image Uploader will send four files:

  • the JPEG image and the PDF file themselves,
  • a resized copy of the image and a PDF icon.

See Also

Reference

  • converters Property
  • Aurigma.ImageUploader.Converter ASP.NET Class
  • Converter PHP Class

Manual

  • Configuring Files to be Uploaded


converter Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The converter type exposes the following members.

Methods

 | Name | Description
Public method | set(Object) | Sets the specified properties.

Properties

 | Name | Description
Public property | mode | Gets or sets a conversion mode of this converter.
Public property | thumbnailApplyCrop | Gets or sets a value indicating whether the thumbnail should be cropped.
Public property | thumbnailBgColor | Gets or sets a background color of the thumbnail.
Public property | thumbnailCompressOversizedOnly | Gets or sets a value indicating whether an original image should be uploaded as the thumbnail in case when original image dimensions and file size are not bigger than dimensions and file size of this thumbnail.
Public property | thumbnailCopyExif | Gets or sets a value indicating whether the thumbnail should contain EXIF metadata copied from the original file.
Public property | thumbnailCopyIptc | Gets or sets a value indicating whether the thumbnail should contain IPTC metadata copied from the original file.
Public property | thumbnailFitMode | Gets or sets a fit mode of the thumbnail.
Public property | thumbnailHeight | Gets or sets a height restriction for the thumbnail.
Public property | thumbnailJpegQuality | Gets or sets a JPEG quality of the thumbnail.
Public property | thumbnailKeepColorSpace | Gets or sets a value indicating whether to preserve original color space when creating the thumbnail.
Public property | thumbnailResizeQuality | Gets or sets a resize quality of the thumbnail.
Public property | thumbnailResolution | Gets or sets an image resolution of the thumbnail.
Public property | thumbnailWatermark | Gets or sets a watermark of the thumbnail.
Public property | thumbnailWidth | Gets or sets a width restriction for the thumbnail.


converter Methods

  • Methods
  • Language Filter ( all languages )

The converter type exposes the following methods.

Methods

 | Name | Description
Public method | set(Object) | Sets the specified properties.


converter.set(Object) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets the specified properties.

Syntax

JavaScript

$au.uploader('uploaderID').converters().get(index).set(paramsObj);

Parameters

paramsObj

Type: Object

A list of property names and values in JSON format.


converter Properties

  • Properties
  • Language Filter ( all languages )

The converter type exposes the following properties.

Properties

 | Name | Description
Public property | mode | Gets or sets a conversion mode of this converter.
Public property | thumbnailApplyCrop | Gets or sets a value indicating whether the thumbnail should be cropped.
Public property | thumbnailBgColor | Gets or sets a background color of the thumbnail.
Public property | thumbnailCompressOversizedOnly | Gets or sets a value indicating whether an original image should be uploaded as the thumbnail in case when original image dimensions and file size are not bigger than dimensions and file size of this thumbnail.
Public property | thumbnailCopyExif | Gets or sets a value indicating whether the thumbnail should contain EXIF metadata copied from the original file.
Public property | thumbnailCopyIptc | Gets or sets a value indicating whether the thumbnail should contain IPTC metadata copied from the original file.
Public property | thumbnailFitMode | Gets or sets a fit mode of the thumbnail.
Public property | thumbnailHeight | Gets or sets a height restriction for the thumbnail.
Public property | thumbnailJpegQuality | Gets or sets a JPEG quality of the thumbnail.
Public property | thumbnailKeepColorSpace | Gets or sets a value indicating whether to preserve original color space when creating the thumbnail.
Public property | thumbnailResizeQuality | Gets or sets a resize quality of the thumbnail.
Public property | thumbnailResolution | Gets or sets an image resolution of the thumbnail.
Public property | thumbnailWatermark | Gets or sets a watermark of the thumbnail.
Public property | thumbnailWidth | Gets or sets a width restriction for the thumbnail.


converter.mode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a conversion mode of this converter.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            mode: "",
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).mode(value);
value = $au.uploader('uploaderID').converters().get(index).mode();

Property Value

Type: String

The conversion mode of this converter.

Default value is "".

Remarks

This property specifies a format string for a desired conversion mode. It consists of masks=mode pairs separated by semicolon. Each pair includes the set of file masks separated by comma and the corresponding mode. In general, this string has the following syntax:

mask11,mask12,...=mode1;mask21,mask22,...=mode2;...

When Image Uploader prepares the upload request it parses the conversion mode format string from the beginning to the end and extracts such pairs. For each file selected for upload Image Uploader gives the first pair. If it finds the file mask in this pair which matches the file extension, it applies the corresponding mode. Otherwise, if no appropriate file mask found, Image Uploader checks the next pairs in the same manner.

Note

If there is no file mask corresponding to the original file extension or appropriate mode Image Uploader does not send this converted file.

Here is the list of supported conversion modes:

Value | Description
SourceFile | means that the selected file will be uploaded from a user's computer without any changes.
Thumbnail | works as follows. If the selected file is image, it will be resized using the parameters listed below and uploaded as JPEG file. Otherwise, a converted file will not be sent.
Icon | means that a system icon associated with the selected file will be uploaded.
Zip | means that a ZIP archive of the selected file will be uploaded.
None | means that no file will be uploaded.

See Also

Reference

  • Aurigma.ImageUploader.Converter.Mode ASP.NET Property
  • Converter.Mode PHP Property

Manual

  • Configuring Files to be Uploaded
  • Uploading Images


converter.thumbnailApplyCrop Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the thumbnail should be cropped.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailApplyCrop: false,
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailApplyCrop(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailApplyCrop();

Property Value

Type: Boolean

If true, the thumbnail is cropped using the specified crop bounds.

Default value is false.

Remarks

In order to set a crop rectangle, select a region in the image editor or use the file.cropBounds property.

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailApplyCrop ASP.NET Property
  • Converter.ThumbnailApplyCrop PHP Property

Manual

  • Rotating and Cropping


converter.thumbnailBgColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of the thumbnail.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailBgColor: "#FFFFFF",
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailBgColor(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailBgColor();

Property Value

Type: String

A background color of the thumbnail. This color is used when the thumbnail should be created for an image with transparency.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#FFFFFF".

Remarks

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailBgColor ASP.NET Property
  • Converter.ThumbnailBgColor PHP Property

Manual

  • Resizing and Recompressing


converter.thumbnailCompressOversizedOnly Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether an original image should be uploaded as the thumbnail in case when original image dimensions and file size are not bigger than dimensions and file size of this thumbnail.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailCompressOversizedOnly: false,
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailCompressOversizedOnly(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailCompressOversizedOnly();

Property Value

Type: Boolean

If true and:

  • The original file is JPEG;
  • No watermark is applied;
  • The dimensions of the original file are not bigger than the dimensions of the thumbnail;
  • The size in bytes of the original file is not greater than the size of the thumbnail.

Then the original file will be sent instead of the thumbnail. In all other cases a thumbnail is created.

Default value is false.

Remarks

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailCompressOversizedOnly ASP.NET Property
  • Converter.ThumbnailCompressOversizedOnly PHP Property

Manual

  • Resizing and Recompressing


converter.thumbnailCopyExif Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the thumbnail should contain EXIF metadata copied from the original file.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailCopyExif: false,
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailCopyExif(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailCopyExif();

Property Value

Type: Boolean

If true, the EXIF information is copied from the original file. Otherwise, EXIF metadata will not be preserved.

Default value is false.

Remarks

Note

Image Uploader Express and Professional do not preserve EXIF metadata while creating thumbnails. See the Comparison of Image Uploader Editions topic for details.

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailCopyExif ASP.NET Property
  • Converter.ThumbnailCopyExif PHP Property

Manual

  • Working with EXIF and IPTC Metadata


converter.thumbnailCopyIptc Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the thumbnail should contain IPTC metadata copied from the original file.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailCopyIptc: false,
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailCopyIptc(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailCopyIptc();

Property Value

Type: Boolean

If true, the IPTC information is copied from the original file. Otherwise, IPTC metadata will not be preserved.

Default value is false.

Remarks

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailCopyIptc ASP.NET Property
  • Converter.ThumbnailCopyIptc PHP Property

Manual

  • Working with EXIF and IPTC Metadata


converter.thumbnailFitMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a fit mode of the thumbnail.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailFitMode: "Fit",
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailFitMode(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailFitMode();

Property Value

Type: String

The fit mode of the thumbnail.

The following values are supported:

Value | Description
Fit | means that the original image should be resized to fit the rectangle specified with the thumbnailHeight and thumbnailWidth properties. Note that the proportions of the original image will be kept.
Width | means that the original image should be resized to be no wider than the thumbnailWidth value.
Height | means that the original image should be resized to be no higher than the thumbnailHeight value.
ActualSize | means that dimensions of the original image should be kept; however, it can be rotated or recompressed if necessary.

Default value is "Fit".

Remarks

Note

Image Uploader Express and Professional restrict a size (width x height) of each created thumbnail to 3 and 5 megapixels respectively. For example, the size of 1500x1500 thumbnail is 2.25 megapixels (1500 pixels x 1500 pixels = 2.25 megapixels), so such thumbnail can be uploaded with Image Uploader Express. See the Comparison of Image Uploader Editions topic for details.

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailFitMode ASP.NET Property
  • Converter.ThumbnailFitMode PHP Property

Manual

  • Resizing and Recompressing


converter.thumbnailHeight Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height restriction for the thumbnail.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailHeight: 96,
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailHeight(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailHeight();

Property Value

Type: Number

The height of the thumbnail.

Default value is 96.

Remarks

Note

Image Uploader Express and Professional restrict a size (width x height) of each created thumbnail to 3 and 5 megapixels respectively. For example, the size of 1500x1500 thumbnail is 2.25 megapixels (1500 pixels x 1500 pixels = 2.25 megapixels), so such thumbnail can be uploaded with Image Uploader Express. See the Comparison of Image Uploader Editions topic for details.

Read about the thumbnailFitMode property for more detailed information on how this property affects the thumbnail size.

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailHeight ASP.NET Property
  • Converter.ThumbnailHeight PHP Property

Manual

  • Resizing and Recompressing


converter.thumbnailJpegQuality Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a JPEG quality of the thumbnail.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailJpegQuality: 100,
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailJpegQuality(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailJpegQuality();

Property Value

Type: Number

The JPEG quality of the thumbnail in range from 0 (the worst quality) to 100 (the best quality).

Default value is 100.

Remarks

You can reduce a thumbnail file size by specifying the lower quality.

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailJpegQuality ASP.NET Property
  • Converter.ThumbnailJpegQuality PHP Property

Manual

  • Resizing and Recompressing


converter.thumbnailKeepColorSpace Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to preserve original color space when creating the thumbnail.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailKeepColorSpace: false,
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailKeepColorSpace(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailKeepColorSpace();

Property Value

Type: Boolean

If true, the thumbnail is created in the original file color space. Otherwise, the thumbnail is created in RGB color space.

Default value is false.

Remarks

Note

Image Uploader Express and Professional do not keep original color space while creating thumbnails. See the Comparison of Image Uploader Editions topic for details.

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailKeepColorSpace ASP.NET Property
  • Converter.ThumbnailKeepColorSpace PHP Property

Manual

  • Resizing and Recompressing


converter.thumbnailResizeQuality Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a resize quality of the thumbnail.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailResizeQuality: "Medium",
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailResizeQuality(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailResizeQuality();

Property Value

Type: String

The resize quality of the thumbnail.

The following values are supported:

Value | Description
Low | Low quality. The image is resized using the nearest-neighbor algorithm.
Medium | Medium quality. The image is resized using the anisotropic algorithm.
High | High quality. The image is resized using the lanczos algorithm.

Default value is "Medium".

Remarks

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailResizeQuality ASP.NET Property
  • Converter.ThumbnailResizeQuality PHP Property

Manual

  • Resizing and Recompressing


converter.thumbnailResolution Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an image resolution of the thumbnail.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailResolution: 0,
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailResolution(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailResolution();

Property Value

Type: Number

The image resolution of the thumbnail (in DPI). If 0 value is specified, the original image resolution is used.

Default value is 0.

Remarks

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailResolution ASP.NET Property
  • Converter.ThumbnailResolution PHP Property

Manual

  • Resizing and Recompressing


converter.thumbnailWatermark Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a watermark of the thumbnail.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailWatermark: "",
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailWatermark(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailWatermark();

Property Value

Type: String

The watermark of the thumbnail. Watermark string syntax is described in the Remarks section.

If an empty string is specified, watermark will not be drawn on the thumbnail.

Default value is "".

Remarks

The watermark string consists of several variables separated with a semicolon:

variable1=value1;variable2=value2;...

The following variables are supported:

Variable Description
Text

Watermark text. If the text contains semicolon or quotation mark characters enclose it in single (' ') or double (" ") quotes. Additionally, quotation marks (both single ' and double ") inside the text should be escaped with a backslash. For example, to get a Andrew's Photos; Vacation text, set this variable as follows:

Text="Andrew\'s Photos; Vacation"

Note

If both text and an image are used as watermarks, the text will always be rendered over the image.

Default value is an empty string.

When the text watermark is specified, the following parameter also make sense:

  • FillColor
  • Font
  • Size
  • Style
  • Position
  • OffsetX
  • OffsetY
  • Opacity
  • BackgroundColor
  • BackgroundMarginWidth
  • BackgroundMarginHeight
  • OutlineColor
  • OutlineWidth
FillColor

Font color. It has the same syntax as all Image Uploader color properties (i.e. HTML-style #rrggbb RGB value).

Default value is an empty string (the fill is transparent).

Font

Font name. This font should be installed on the client machine. That is why it is highly recommended to use some generic font like Arial, Verdana, etc.

Default value is Arial.

Size

Font size (in pixels).

Default value is 12.

Style

Font style. The following styles are supported:

  • Bold
  • Italic
  • Underlined

You can specify several styles separated with a comma. Example:

Style=Bold,Italic

Default value is an empty string (regular font is used).

ImageUrl

Url to an image that will be used as the watermark.

Note

If both text and an image are used as watermarks, the text will always be rendered over the image.

Default value is an empty string.

When the image watermark is specified, the following parameter also make sense:

  • Width
  • Height
  • Position
  • OffsetX
  • OffsetY
  • Opacity
Width

Width of the image that will be used as the watermark. The image will be resized to the specified dimensions as an ordinary thumbnail, that is, the image can only be downsized, and its proportions are kept.

Default value is an empty string (actual image width is used).

Height

Height of the image that will be used as the watermark. The image will be resized to the specified dimensions as an ordinary thumbnail, that is, the image can only be downsized, and its proportions are kept.

Default value is an empty string (actual image height is used).

Position

Watermark position. It can take one of the following values:

  • TopLeft - watermark will be drawn in the top left corner of an image.
  • TopCenter - watermark will be drawn in the center of the top of an image.
  • TopRight - watermark will be drawn in the right top corner of an image.
  • CenterLeft - watermark will be drawn in the center of the left edge of an image.
  • Center - watermark will be drawn in the center of an image.
  • CenterRight - watermark will be drawn in the center of the right edge of an image.
  • BottomLeft - watermark will be drawn in the bottom left corner of an image.
  • BottomCenter - watermark will be drawn in the center of the bottom of an image.
  • BottomRight - watermark will be drawn in the bottom right corner of an image.

Default value is BottomRight.

OffsetX

Horizontal offset (in pixels) of the watermark relatively the position it is anchored to (according to the Position variable).

Note

If horizontal position is left or center, coordinates direction is left-to-right. If it is right, coordinates direction is flipped to right-to-left.

Default value is 0 (no offset).

OffsetY

Vertical offset (in pixels) of the watermark relatively the position it is anchored to (according to the Position variable).

Note

If vertical position is top or center, coordinates direction is top-to-bottom. If it is bottom, coordinates direction is flipped to bottom-to-top.

Default value is 0 (no offset).

Opacity

Watermark opacity percentage. If 0, the watermark is totally transparent. If 100, the watermark is opaque. Values between 0 and 100 will produce watermark with various level of transparency.

This value works for all elements of watermark. There is no way to configure different opacity for background, text outline and text fill.

Default value is 100.

BackgroundColor

Background color. It has the same syntax as all Image Uploader color properties (i.e. HTML-style #rrggbb RGB value).

Default value is an empty string (the background is transparent).

BackgroundMarginWidth

Width of additional space outside of the watermark filled with background (in pixels).

Default value is 0.

BackgroundMarginHeight

Height of additional space outside of the watermark filled with background (in pixels).

Default value is 0.

OutlineColor

Text outline color. It has the same syntax as all Image Uploader color properties (i.e. HTML-style #rrggbb RGB value).

Default value is an empty string (the outline is transparent).

OutlineWidth

Width of the text outline.

Default value is 1.

Note

The watermark string is case insensitive.

Though you can set both image and text watermarks at the same time, it makes sense to use only one of them. For text watermarks the only required variable is Text. Here is an example of the watermark string which will draw green semi-transparent italic text Aurigma in the bottom left corner of an image:

JavaScript

thumbnailWatermark: 'Text=Aurigma;Opacity=75;FillColor=#00ff00;Position=BottomLeft;Style=Italic;Size=30'

For image watermarks ImageUrl, Width, and Height are required. Here is an example of semi-transparent logo drawn in the top tight corner of the image:

JavaScript

thumbnailWatermark: 'ImageUrl=http://localhost/watermark.png;Width=86;Height=63;Position=TopRight;Opacity=50'

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailWatermark ASP.NET Property
  • Converter.ThumbnailWatermark PHP Property

Manual

  • Applying Watermarks


converter.thumbnailWidth Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width restriction for the thumbnail.

Syntax

JavaScript

Initialize

$au.uploader({
    converters : [
        {
            //...other params...
            thumbnailWidth: 96,
            //...other params...
        }
    ]
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters().get(index).thumbnailWidth(value);
value = $au.uploader('uploaderID').converters().get(index).thumbnailWidth();

Property Value

Type: Number

The width of the thumbnail.

Default value is 96.

Remarks

Note

Image Uploader Express and Professional restrict a size (width x height) of each created thumbnail to 3 and 5 megapixels respectively. For example, the size of 1500x1500 thumbnail is 2.25 megapixels (1500 pixels x 1500 pixels = 2.25 megapixels), so such thumbnail can be uploaded with Image Uploader Express. See the Comparison of Image Uploader Editions topic for details.

Read about the thumbnailFitMode property for more detailed information on how this property affects the thumbnail size.

This property makes sense only if the mode property has the Thumbnail value.

See Also

Reference

  • Aurigma.ImageUploader.Converter.ThumbnailWidth ASP.NET Property
  • Converter.ThumbnailWidth PHP Property

Manual

  • Resizing and Recompressing


converters Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a collection of file converters.

For a list of all members of this class, see converters Members.

Syntax

JavaScript

$au.converters = function() {
}

Remarks

You can use this class to work with converters at runtime.

See Also

Reference

  • converters Property
  • Aurigma.ImageUploader.ConverterCollection ASP.NET Class


converters Members

  • Methods
  • Language Filter ( all languages )

The converters type exposes the following members.

Methods

 | Name | Description
Public method | add | Adds converter to the end of the collection.
Public method | count | Returns the number of converters actually contained in the collection.
Public method | get(Number) | Returns the converter at the specified index.
Public method | remove(Number) | Removes the converter at the specified index of the collection.
Public method | removeAll | Removes the all the converters from the collection.


converters Methods

  • Methods
  • Language Filter ( all languages )

The converters type exposes the following methods.

Methods

 | Name | Description
Public method | add | Adds converter to the end of the collection.
Public method | count | Returns the number of converters actually contained in the collection.
Public method | get(Number) | Returns the converter at the specified index.
Public method | remove(Number) | Removes the converter at the specified index of the collection.
Public method | removeAll | Removes the all the converters from the collection.


converters.add Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Adds converter to the end of the collection.

Syntax

JavaScript

$au.uploader('uploaderID').converters().add(paramsObj);

Parameters

paramsObj

Type: Object

Converter to add. If this parameter is not specified, a new converter will be created and added.

Return Value

Type: $au.converter

The added converter.


converters.count Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns the number of converters actually contained in the collection.

Syntax

JavaScript

$au.uploader('uploaderID').converters().count();

Return Value

Type: Number

The number of converters actually contained in the collection.


converters.get(Number) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns the converter at the specified index.

Syntax

JavaScript

$au.uploader('uploaderID').converters().get(index);

Parameters

index

Type: Number

The zero-based index of the converter to get.

Return Value

Type: $au.converter

The converter at the specified index.


converters.remove(Number) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Removes the converter at the specified index of the collection.

Syntax

JavaScript

$au.uploader('uploaderID').converters().remove(index);

Parameters

index

Type: Number

The zero-based index of the converter to remove.


converters.removeAll Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Removes the all the converters from the collection.

Syntax

JavaScript

$au.uploader('uploaderID').converters().removeAll();


debug Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class allows debugging the script which embeds Image Uploader into a page.

For a list of all members of this class, see debug Members.

Syntax

JavaScript

$au.debug = function() {
}

Remarks

This class allows showing errors and warnings if Image Uploader has wrong configuration or it is used incorrectly, for example:

  • assigning values to read-only properties;
  • using an unsupported property or method;
  • an error is detected in the event handler function;
  • and others...

This class also supports displaying debug messages from Image Uploader.


debug Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The debug type exposes the following members.

Methods

 | Name | Description
Public method | showError(String) | Shows an error message in accordance with the mode value if errors are allowed via the level property.
Public method | showInfo(String) | Shows an information message in accordance with the mode value if information messages are allowed via the level property.

Properties

 | Name | Description
Public property | level | Gets or sets a debug level.
Public property | mode | Gets or sets an array of available debug modes which will be used if the level is greater than 0.


debug Methods

  • Methods
  • Language Filter ( all languages )

The debug type exposes the following methods.

Methods

 | Name | Description
Public method | showError(String) | Shows an error message in accordance with the mode value if errors are allowed via the level property.
Public method | showInfo(String) | Shows an information message in accordance with the mode value if information messages are allowed via the level property.


debug.showError(String) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Shows an error message in accordance with the mode value if errors are allowed via the level property.

Syntax

JavaScript

$au.debug().showError(msg);

Parameters

msg

Type: String

The message to show.

Remarks

This method can be used to show a custom error message.


debug.showInfo(String) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Shows an information message in accordance with the mode value if information messages are allowed via the level property.

Syntax

JavaScript

$au.debug().showInfo(msg);

Parameters

msg

Type: String

The information message to show.

Remarks

This method can be used to show a custom information message.


debug Properties

  • Properties
  • Language Filter ( all languages )

The debug type exposes the following properties.

Properties

 | Name | Description
Public property | level | Gets or sets a debug level.
Public property | mode | Gets or sets an array of available debug modes which will be used if the level is greater than 0.


debug.level Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a debug level.

Syntax

JavaScript

$au.debug().level(value);
value = $au.debug().level();

Property Value

Type: Number

The debug level. The following values are supported:

Value | Description
0 | Show no messages at all.
1 | Show errors only.
2 | Show errors and debug messages from Image Uploader.
3 | Show errors, debug messages from Image Uploader, and information messages.

Default value is 0.

See Also

Manual

  • Using JavaScript API


debug.mode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of available debug modes which will be used if the level is greater than 0.

Syntax

JavaScript

$au.debug().mode(value);
value = $au.debug().mode();

Property Value

Type: Array

The string containing a debug mode or an array of available debug modes. The following values are supported:

Value | Description
popup | All the messages will be shown in a popup window.
console | All the messages will be logged in a browser console (e.g. Firebug) if it is available.
alert | All the messages will be shown in alerts.
Note

If the array of debug modes is specified, it is used as follows. When the debug class is about to display a message, it uses the first mode specified in this array. If it is failed, the next mode is used until the message is displayed correctly.

Default value is ['popup', 'console', 'alert'].

See Also

Manual

  • Using JavaScript API


deleteFilesDialog Class

  • Supported browsers: Firefox Google Chrome Safari

This class represents the delete confirmation dialog which appears in non-Internet Explorer browsers when enableOriginalFilesDeletion is true.

For a list of all members of this class, see deleteFilesDialog Members.

Syntax

JavaScript

$au.deleteFilesDialog = function() {
}

Remarks

Note

A difference between Image Uploader behavior in Internet Explorer and other supported browsers is the following. When Image Uploader deletes files in Internet Explorer, it moves them in the way specified in the Recycle Bin properties. By default, a standard delete confirmation dialog appears and files are moved to the Recycle Bin if a user clicks Yes. However, if Image Uploader deletes files in any of other supported browsers, the internal delete confirmation dialog appears and files are removed permanently when a user clicks Yes.

If the file cannot be deleted, the deletingFilesError message appears.

See Also

Reference

  • enableOriginalFilesDeletion Property
  • deleteFilesDialog Property
  • Aurigma.ImageUploader.DeleteFilesDialog ASP.NET Class
  • DeleteFilesDialog PHP Class


deleteFilesDialog Members

  • Properties
  • Language Filter ( all languages )

The deleteFilesDialog type exposes the following members.

Properties

 | Name | Description
Public property | message | Gets or sets a message of the dialog which asks a user to confirm that they really want to delete uploaded files.
Public property | titleText | Gets or sets a title of the dialog which asks a user to confirm that they really want to delete uploaded files.


deleteFilesDialog Properties

  • Properties
  • Language Filter ( all languages )

The deleteFilesDialog type exposes the following properties.

Properties

 | Name | Description
Public property | message | Gets or sets a message of the dialog which asks a user to confirm that they really want to delete uploaded files.
Public property | titleText | Gets or sets a title of the dialog which asks a user to confirm that they really want to delete uploaded files.


deleteFilesDialog.message Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a message of the dialog which asks a user to confirm that they really want to delete uploaded files.

Syntax

JavaScript

Initialize

$au.uploader({
    deleteFilesDialog: {
        //...other params...
        message: "Are you sure you want to permanently delete uploaded items?",
        //...other params...
    }
})

Property Value

Type: String

The text of the message of the delete confirmation dialog.

Default value is "Are you sure you want to permanently delete uploaded items?".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DeleteFilesDialog.Message ASP.NET Property
  • DeleteFilesDialog.Message PHP Property


deleteFilesDialog.titleText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a title of the dialog which asks a user to confirm that they really want to delete uploaded files.

Syntax

JavaScript

Initialize

$au.uploader({
    deleteFilesDialog: {
        //...other params...
        titleText: "Delete File",
        //...other params...
    }
})

Property Value

Type: String

The text of the title of the delete confirmation dialog.

Default value is "Delete File".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DeleteFilesDialog.TitleText ASP.NET Property
  • DeleteFilesDialog.TitleText PHP Property


descriptionEditor Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the description editor.

For a list of all members of this class, see descriptionEditor Members.

Syntax

JavaScript

$au.descriptionEditor = function() {
}

See Also

Reference

  • descriptionEditor Property
  • Aurigma.ImageUploader.DescriptionEditor ASP.NET Class
  • DescriptionEditor PHP Class

Manual

  • Customizing Appearance


descriptionEditor Members

  • Properties
  • Language Filter ( all languages )

The descriptionEditor type exposes the following members.

Properties

 | Name | Description
Public property | cancelHyperlinkText | Gets or sets a caption of the Cancel hyperlink on the dialog displayed when a user clicks the description icon on the pane item surface.
Public property | maxTextLength | Gets or sets a description length.
Public property | orEscLabelText | Gets or sets a text of the Or Esc label.
Public property | saveButtonText | Gets or sets a caption of the Save button on the dialog displayed when a user clicks the description icon on the pane item surface.


descriptionEditor Properties

  • Properties
  • Language Filter ( all languages )

The descriptionEditor type exposes the following properties.

Properties

 | Name | Description
Public property | cancelHyperlinkText | Gets or sets a caption of the Cancel hyperlink on the dialog displayed when a user clicks the description icon on the pane item surface.
Public property | maxTextLength | Gets or sets a description length.
Public property | orEscLabelText | Gets or sets a text of the Or Esc label.
Public property | saveButtonText | Gets or sets a caption of the Save button on the dialog displayed when a user clicks the description icon on the pane item surface.


descriptionEditor.cancelHyperlinkText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel hyperlink on the dialog displayed when a user clicks the description icon on the pane item surface.

Syntax

JavaScript

Initialize

$au.uploader({
    descriptionEditor: {
        //...other params...
        cancelHyperlinkText: "Cancel",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Cancel hyperlink on the description editor.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DescriptionEditor.CancelHyperlinkText ASP.NET Property
  • DescriptionEditor.CancelHyperlinkText PHP Property


descriptionEditor.maxTextLength Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a description length.

Syntax

JavaScript

Initialize

$au.uploader({
    descriptionEditor: {
        //...other params...
        maxTextLength: 512,
        //...other params...
    }
})

Property Value

Type: Number

The maximum allowed number of symbols in user-provided descriptions.

Default value is 512.

See Also

Reference

  • Aurigma.ImageUploader.DescriptionEditor.MaxTextLength ASP.NET Property
  • DescriptionEditor.MaxTextLength PHP Property


descriptionEditor.orEscLabelText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text of the Or Esc label.

Syntax

JavaScript

Initialize

$au.uploader({
    descriptionEditor: {
        //...other params...
        orEscLabelText: " (or Esc)",
        //...other params...
    }
})

Property Value

Type: String

The text of the Or Esc label.

Default value is " (or Esc)".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DescriptionEditor.OrEscLabelText ASP.NET Property
  • DescriptionEditor.OrEscLabelText PHP Property


descriptionEditor.saveButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Save button on the dialog displayed when a user clicks the description icon on the pane item surface.

Syntax

JavaScript

Initialize

$au.uploader({
    descriptionEditor: {
        //...other params...
        saveButtonText: "Save",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Save button on the description editor.

Default value is "Save".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DescriptionEditor.SaveButtonText ASP.NET Property
  • DescriptionEditor.SaveButtonText PHP Property


detailsViewColumns Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class contains titles of columns displayed in the Details view.

For a list of all members of this class, see detailsViewColumns Members.

Syntax

JavaScript

$au.detailsViewColumns = function() {
}

See Also

Reference

  • detailsViewColumns Property
  • Aurigma.ImageUploader.DetailsViewColumns ASP.NET Class
  • DetailsViewColumns PHP Class

Manual

  • Customizing Appearance


detailsViewColumns Members

  • Properties
  • Language Filter ( all languages )

The detailsViewColumns type exposes the following members.

Properties

 | Name | Description
Public property | dimensionsText | Gets or sets a title of the Image dimensions column in the Details view.
Public property | fileNameText | Gets or sets a title of the Name column in the Details view.
Public property | fileSizeText | Gets or sets a title of the Size column in the Details view.
Public property | fileTypeText | Gets or sets a title of the Type column in the Details view.
Public property | infoText | Gets or sets a title of the Info column in the Details view.
Public property | lastModifiedText | Gets or sets a title of the Date modified column in the Details view.


detailsViewColumns Properties

  • Properties
  • Language Filter ( all languages )

The detailsViewColumns type exposes the following properties.

Properties

 | Name | Description
Public property | dimensionsText | Gets or sets a title of the Image dimensions column in the Details view.
Public property | fileNameText | Gets or sets a title of the Name column in the Details view.
Public property | fileSizeText | Gets or sets a title of the Size column in the Details view.
Public property | fileTypeText | Gets or sets a title of the Type column in the Details view.
Public property | infoText | Gets or sets a title of the Info column in the Details view.
Public property | lastModifiedText | Gets or sets a title of the Date modified column in the Details view.


detailsViewColumns.dimensionsText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Image dimensions column in the Details view.

Syntax

JavaScript

Initialize

$au.uploader({
    detailsViewColumns: {
        //...other params...
        dimensionsText: "Image dimensions",
        //...other params...
    }
})

Property Value

Type: String

The title of the Image dimensions column in the Details view.

Default value is "Image dimensions".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DetailsViewColumns.DimensionsText ASP.NET Property
  • DetailsViewColumns.DimensionsText PHP Property


detailsViewColumns.fileNameText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Name column in the Details view.

Syntax

JavaScript

Initialize

$au.uploader({
    detailsViewColumns: {
        //...other params...
        fileNameText: "Name",
        //...other params...
    }
})

Property Value

Type: String

The title of the Name column in the Details view.

Default value is "Name".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DetailsViewColumns.FileNameText ASP.NET Property
  • DetailsViewColumns.FileNameText PHP Property


detailsViewColumns.fileSizeText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Size column in the Details view.

Syntax

JavaScript

Initialize

$au.uploader({
    detailsViewColumns: {
        //...other params...
        fileSizeText: "Size",
        //...other params...
    }
})

Property Value

Type: String

The title of the Size column in the Details view.

Default value is "Size".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DetailsViewColumns.FileSizeText ASP.NET Property
  • DetailsViewColumns.FileSizeText PHP Property


detailsViewColumns.fileTypeText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Type column in the Details view.

Syntax

JavaScript

Initialize

$au.uploader({
    detailsViewColumns: {
        //...other params...
        fileTypeText: "Type",
        //...other params...
    }
})

Property Value

Type: String

The title of the Type column in the Details view.

Default value is "Type".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DetailsViewColumns.FileTypeText ASP.NET Property
  • DetailsViewColumns.FileTypeText PHP Property


detailsViewColumns.infoText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Info column in the Details view.

Syntax

JavaScript

Initialize

$au.uploader({
    detailsViewColumns: {
        //...other params...
        infoText: "Info",
        //...other params...
    }
})

Property Value

Type: String

The title of the Info column in the Details view.

Default value is "Info".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DetailsViewColumns.InfoText ASP.NET Property
  • DetailsViewColumns.InfoText PHP Property


detailsViewColumns.lastModifiedText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the Date modified column in the Details view.

Syntax

JavaScript

Initialize

$au.uploader({
    detailsViewColumns: {
        //...other params...
        lastModifiedText: "Date modified",
        //...other params...
    }
})

Property Value

Type: String

The title of the Date modified column in the Details view.

Default value is "Date modified".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.DetailsViewColumns.LastModifiedText ASP.NET Property
  • DetailsViewColumns.LastModifiedText PHP Property


event Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a collection of client-side event handlers.

For a list of all members of this class, see event Members.

Syntax

JavaScript

$au.event = function() {
}

See Also

Reference

  • events Property

Manual

  • Using Events


event Members

  • Methods
  • Language Filter ( all languages )

The event type exposes the following members.

Methods

 | Name | Description
Public method | add(Function) | Adds the specified handler to the end of the collection.
Public method | clear | Clears the collection.
Public method | count | Returns the number of event handlers actually contained in the collection.
Public method | remove(Function) | Removes the specified handler from the collection.


event Methods

  • Methods
  • Language Filter ( all languages )

The event type exposes the following methods.

Methods

 | Name | Description
Public method | add(Function) | Adds the specified handler to the end of the collection.
Public method | clear | Clears the collection.
Public method | count | Returns the number of event handlers actually contained in the collection.
Public method | remove(Function) | Removes the specified handler from the collection.


event.add(Function) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Adds the specified handler to the end of the collection.

Syntax

JavaScript

$au.uploader('uploaderID').events().event().add(handler);

Parameters

handler

Type: Function

The function to add.


event.clear Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Clears the collection.

Syntax

JavaScript

$au.uploader('uploaderID').events().event().clear();


event.count Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns the number of event handlers actually contained in the collection.

Syntax

JavaScript

$au.uploader('uploaderID').events().event().count();

Return Value

Type: Number

The number of event handlers actually contained in the collection.


event.remove(Function) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Removes the specified handler from the collection.

Syntax

JavaScript

$au.uploader('uploaderID').events().event().remove(handler);

Parameters

handler

Type: Function

The function to remove.

Return Value

Type: Boolean

true if the specified handled was successfully removed from the collection; otherwise, false.


events Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class provides access to Image Uploader client-side events.

For a list of all members of this class, see events Members.

Syntax

JavaScript

$au.events = function() {
}

See Also

Reference

  • events Property
  • ClientEvents PHP Class


events Members

  • Properties
  • Language Filter ( all languages )

The events type exposes the following members.

Properties

 | Name | Description
Public property | afterPackageUpload | Gets or sets an array of AfterPackageUpload event handlers.
Public property | afterSendRequest | Gets or sets an array of AfterSendRequest event handlers.
Public property | afterUpload | Gets or sets an array of AfterUpload event handlers.
Public property | beforePackageUpload | Gets or sets an array of BeforePackageUpload event handlers.
Public property | beforeSendRequest | Gets or sets an array of BeforeSendRequest event handlers.
Public property | beforeUpload | Gets or sets an array of BeforeUpload event handlers.
Public property | error | Gets or sets an array of Error event handlers.
Public property | folderChange | Gets or sets an array of FolderChange event handlers.
Public property | initComplete | Gets or sets an array of InitComplete event handlers.
Public property | preRender | Gets or sets an array of PreRender event handlers.
Public property | progress | Gets or sets an array of Progress event handlers.
Public property | restrictionFailed | Gets or sets an array of RestrictionFailed event handlers.
Public property | selectionChange | Gets or sets an array of SelectionChange event handlers.
Public property | uploadFileCountChange | Gets or sets an array of UploadFileCountChange event handlers.
Public property | viewChange | Gets or sets an array of ViewChange event handlers.


events Properties

  • Properties
  • Language Filter ( all languages )

The events type exposes the following properties.

Properties

 | Name | Description
Public property | afterPackageUpload | Gets or sets an array of AfterPackageUpload event handlers.
Public property | afterSendRequest | Gets or sets an array of AfterSendRequest event handlers.
Public property | afterUpload | Gets or sets an array of AfterUpload event handlers.
Public property | beforePackageUpload | Gets or sets an array of BeforePackageUpload event handlers.
Public property | beforeSendRequest | Gets or sets an array of BeforeSendRequest event handlers.
Public property | beforeUpload | Gets or sets an array of BeforeUpload event handlers.
Public property | error | Gets or sets an array of Error event handlers.
Public property | folderChange | Gets or sets an array of FolderChange event handlers.
Public property | initComplete | Gets or sets an array of InitComplete event handlers.
Public property | preRender | Gets or sets an array of PreRender event handlers.
Public property | progress | Gets or sets an array of Progress event handlers.
Public property | restrictionFailed | Gets or sets an array of RestrictionFailed event handlers.
Public property | selectionChange | Gets or sets an array of SelectionChange event handlers.
Public property | uploadFileCountChange | Gets or sets an array of UploadFileCountChange event handlers.
Public property | viewChange | Gets or sets an array of ViewChange event handlers.


events.afterPackageUpload Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of AfterPackageUpload event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        afterPackageUpload: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().afterPackageUpload(value);
value = $au.uploader('uploaderID').events().afterPackageUpload();

Property Value

Type: $au.event

The string containing a name of AfterPackageUpload event handler or an array of handler names.

Remarks

This event fires when the current package was uploaded successfully.

See Also

Reference

  • AfterPackageUpload Client-Side Event
  • ClientEvents.AfterPackageUpload PHP Property


events.afterSendRequest Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of AfterSendRequest event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        afterSendRequest: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().afterSendRequest(value);
value = $au.uploader('uploaderID').events().afterSendRequest();

Property Value

Type: $au.event

The string containing a name of AfterSendRequest event handler or an array of handler names.

Remarks

This event fires when the current POST request was uploaded successfully.

See Also

Reference

  • AfterSendRequest Client-Side Event
  • ClientEvents.AfterSendRequest PHP Property


events.afterUpload Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of AfterUpload event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        afterUpload: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().afterUpload(value);
value = $au.uploader('uploaderID').events().afterUpload();

Property Value

Type: $au.event

The string containing a name of AfterUpload event handler or an array of handler names.

Remarks

This event fires after successful upload.

See Also

Reference

  • AfterUpload Client-Side Event
  • ClientEvents.AfterUpload PHP Property


events.beforePackageUpload Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of BeforePackageUpload event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        beforePackageUpload: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().beforePackageUpload(value);
value = $au.uploader('uploaderID').events().beforePackageUpload();

Property Value

Type: $au.event

The string containing a name of BeforePackageUpload event handler or an array of handler names.

Remarks

This event fires when the current package is about to be uploaded.

See Also

Reference

  • BeforePackageUpload Client-Side Event
  • ClientEvents.BeforePackageUpload PHP Property


events.beforeSendRequest Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of BeforeSendRequest event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        beforeSendRequest: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().beforeSendRequest(value);
value = $au.uploader('uploaderID').events().beforeSendRequest();

Property Value

Type: $au.event

The string containing a name of BeforeSendRequest event handler or an array of handler names.

Remarks

This event fires when the current POST request is about to be uploaded.

See Also

Reference

  • BeforeSendRequest Client-Side Event
  • ClientEvents.BeforeSendRequest PHP Property


events.beforeUpload Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of BeforeUpload event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        beforeUpload: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().beforeUpload(value);
value = $au.uploader('uploaderID').events().beforeUpload();

Property Value

Type: $au.event

The string containing a name of BeforeUpload event handler or an array of handler names.

Remarks

This event fires when the upload is about to be started.

See Also

Reference

  • BeforeUpload Client-Side Event
  • ClientEvents.BeforeUpload PHP Property


events.error Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of Error event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        error: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().error(value);
value = $au.uploader('uploaderID').events().error();

Property Value

Type: $au.event

The string containing a name of Error event handler or an array of handler names.

Remarks

This event fires if some error occurred during the current upload session.

See Also

Reference

  • Error Client-Side Event
  • ClientEvents.Error PHP Property


events.folderChange Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of FolderChange event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        folderChange: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().folderChange(value);
value = $au.uploader('uploaderID').events().folderChange();

Property Value

Type: $au.event

The string containing a name of FolderChange event handler or an array of handler names.

Remarks

This event fires when a user goes to another folder.

See Also

Reference

  • FolderChange Client-Side Event
  • ClientEvents.FolderChange PHP Property


events.initComplete Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of InitComplete event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        initComplete: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().initComplete(value);
value = $au.uploader('uploaderID').events().initComplete();

Property Value

Type: $au.event

The string containing a name of InitComplete event handler or an array of handler names.

Remarks

This event fires when Image Uploader is completely created and initialized.

See Also

Reference

  • InitComplete Client-Side Event
  • ClientEvents.InitComplete PHP Property


events.preRender Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of PreRender event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        preRender: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().preRender(value);
value = $au.uploader('uploaderID').events().preRender();

Property Value

Type: $au.event

The string containing a name of PreRender event handler or an array of handler names.

Remarks

This event fires before the writeHtml() or getHtml() method is executed.

See Also

Reference

  • PreRender Client-Side Event
  • ClientEvents.PreRender PHP Property


events.progress Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of Progress event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        progress: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().progress(value);
value = $au.uploader('uploaderID').events().progress();

Property Value

Type: $au.event

The string containing a name of Progress event handler or an array of handler names.

Remarks

This event indicates the progress of the upload.

See Also

Reference

  • Progress Client-Side Event
  • ClientEvents.Progress PHP Property


events.restrictionFailed Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of RestrictionFailed event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        restrictionFailed: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().restrictionFailed(value);
value = $au.uploader('uploaderID').events().restrictionFailed();

Property Value

Type: $au.event

The string containing a name of RestrictionFailed event handler or an array of handler names.

Remarks

This event fires when some restriction is broken.

See Also

Reference

  • RestrictionFailed Client-Side Event
  • ClientEvents.RestrictionFailed PHP Property


events.selectionChange Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of SelectionChange event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        selectionChange: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().selectionChange(value);
value = $au.uploader('uploaderID').events().selectionChange();

Property Value

Type: $au.event

The string containing a name of SelectionChange event handler or an array of handler names.

Remarks

This event fires when a user changes a selection in the upload pane.

See Also

Reference

  • SelectionChange Client-Side Event
  • ClientEvents.SelectionChange PHP Property


events.uploadFileCountChange Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of UploadFileCountChange event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        uploadFileCountChange: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().uploadFileCountChange(value);
value = $au.uploader('uploaderID').events().uploadFileCountChange();

Property Value

Type: $au.event

The string containing a name of UploadFileCountChange event handler or an array of handler names.

Remarks

This event fires when a user adds/removes any files to/from the upload list.

See Also

Reference

  • UploadFileCountChange Client-Side Event
  • ClientEvents.UploadFileCountChange PHP Property


events.viewChange Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of ViewChange event handlers.

Syntax

JavaScript

Initialize

$au.uploader({
    events: {
        //...other params...
        viewChange: [],
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events().viewChange(value);
value = $au.uploader('uploaderID').events().viewChange();

Property Value

Type: $au.event

The string containing a name of ViewChange event handler or an array of handler names.

Remarks

This event fires when the view mode is changed.

See Also

Reference

  • ViewChange Client-Side Event
  • ClientEvents.ViewChange PHP Property


file Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the file actually contained in the upload pane.

For a list of all members of this class, see file Members.

Syntax

JavaScript

$au.file = function() {
}

See Also

Reference

  • files Property


file Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The file type exposes the following members.

Methods

 | Name | Description
Public method | remove | Removes the user-selected files from the upload pane.

Properties

 | Name | Description
Public property | angle | Gets or sets a rotation angle of the user-selected file.
Public property | cropBounds | Gets or sets crop bounds of the user-selected file.
Public property | description | Gets or sets a description of the user-selected file.
Public property | focused | Gets a value indicating whether the user-selected file is in focus.
Public property | format | Gets a file format of the user-selected file.
Public property | guid | Gets a unique identifier of the user-selected file.
Public property | height | Gets a height of the user-selected file.
Public property | horizontalResolution | Gets a horizontal resolution of the user-selected file.
Public property | name | Gets or sets a name of the user-selected file.
Public property | selected | Gets or sets a value indicating whether the user-selected file is highlighted.
Public property | size | Gets a size of the user-selected file.
Public property | tag | Gets or sets a tag of the user-selected file.
Public property | type | Gets a type of the user-selected file.
Public property | verticalResolution | Gets a vertical resolution of the user-selected file.
Public property | width | Gets a width of the user-selected file.


file Methods

  • Methods
  • Language Filter ( all languages )

The file type exposes the following methods.

Methods

 | Name | Description
Public method | remove | Removes the user-selected files from the upload pane.


file.remove Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Removes the user-selected files from the upload pane.

Syntax

JavaScript

$au.uploader('uploaderID').files().get(index).remove();


file Properties

  • Properties
  • Language Filter ( all languages )

The file type exposes the following properties.

Properties

 | Name | Description
Public property | angle | Gets or sets a rotation angle of the user-selected file.
Public property | cropBounds | Gets or sets crop bounds of the user-selected file.
Public property | description | Gets or sets a description of the user-selected file.
Public property | focused | Gets a value indicating whether the user-selected file is in focus.
Public property | format | Gets a file format of the user-selected file.
Public property | guid | Gets a unique identifier of the user-selected file.
Public property | height | Gets a height of the user-selected file.
Public property | horizontalResolution | Gets a horizontal resolution of the user-selected file.
Public property | name | Gets or sets a name of the user-selected file.
Public property | selected | Gets or sets a value indicating whether the user-selected file is highlighted.
Public property | size | Gets a size of the user-selected file.
Public property | tag | Gets or sets a tag of the user-selected file.
Public property | type | Gets a type of the user-selected file.
Public property | verticalResolution | Gets a vertical resolution of the user-selected file.
Public property | width | Gets a width of the user-selected file.


file.angle Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a rotation angle of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

$au.uploader('uploaderID').files().get(index).angle(value);
value = $au.uploader('uploaderID').files().get(index).angle();

Property Value

Type: Number

The rotation angle of this file. Possible values are:

  • 0
  • 90
  • 180
  • 270

Remarks

Items can be rotated not only by the user, but also automatically, using the enableAutoRotation, and also by modifying this property.

Note

This property affects the file even if the rotation control is disabled (enableRotation is false).

See Also

Reference

  • enableRotation Property
  • enableAutoRotation Property


file.cropBounds Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets crop bounds of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

$au.uploader('uploaderID').files().get(index).cropBounds(value);
value = $au.uploader('uploaderID').files().get(index).cropBounds();

Property Value

Type: Array

The crop bounds of this file in the the following format: [left,top,right,bottom].


file.description Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a description of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

$au.uploader('uploaderID').files().get(index).description(value);
value = $au.uploader('uploaderID').files().get(index).description();

Property Value

Type: String

The description of this file.

The length of this string can be limited by the descriptionEditor.maxTextLength property.

Remarks

Note

Even if descriptions are disabled (enableDescriptionEditor is false), you can change description of the file via this property.

See Also

Reference

  • enableDescriptionEditor Property
  • maxTextLength Property


file.focused Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a value indicating whether the user-selected file is in focus.

Syntax

JavaScript

Get/Set Value at Runtime

$au.uploader('uploaderID').files().get(index).focused(value);
value = $au.uploader('uploaderID').files().get(index).focused();

Property Value

Type: Boolean

true means that this file is in focus, otherwise - out of focus.


file.format Property

  • Supported browsers: Internet Explorer

Gets a file format of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

value = $au.uploader('uploaderID').files().get(index).format();

Property Value

Type: String

The format of this file. The following values are supported:

Unknown | Unknown file format.
JPEG | JPEG file format.
BMP | BMP file format.
PNG | PNG file format.
PCX | PCX file format.
WBMP | WBMP file format.
GIF | GIF file format.
PSD | PSD file format.

Remarks

Note

Do not confuse this property with type. File format returned through this property is determined with Image Uploader by analyzing file content (rather than the file extension). In the same time the file type is retrieved from system (determined via the file extension).


file.guid Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a unique identifier of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

value = $au.uploader('uploaderID').files().get(index).guid();

Property Value

Type: String

The GUID that identifies this file.


file.height Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a height of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

value = $au.uploader('uploaderID').files().get(index).height();

Property Value

Type: Number

The height of this file (in pixels) if it is an image; otherwise, 0 is returned.


file.horizontalResolution Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a horizontal resolution of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

value = $au.uploader('uploaderID').files().get(index).horizontalResolution();

Property Value

Type: Number

The horizontal resolution of this file (in DPI) if it is an image; otherwise, 0 is returned.


file.name Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a name of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

value = $au.uploader('uploaderID').files().get(index).name();

Property Value

Type: String

The name of this file.


file.selected Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the user-selected file is highlighted.

Syntax

JavaScript

Get/Set Value at Runtime

$au.uploader('uploaderID').files().get(index).selected(value);
value = $au.uploader('uploaderID').files().get(index).selected();

Property Value

Type: Boolean

true if this file is selected (highlighted); otherwise, false.


file.size Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a size of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

value = $au.uploader('uploaderID').files().get(index).size();

Property Value

Type: Number

The size in bytes of this file.


file.tag Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a tag of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

$au.uploader('uploaderID').files().get(index).tag(value);
value = $au.uploader('uploaderID').files().get(index).tag();

Property Value

Type: String

The tag of this file.


file.type Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a type of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

value = $au.uploader('uploaderID').files().get(index).type();

Property Value

Type: String

The type of this file.

Remarks

Note

Do not confuse this property with format. The file type returned by this property is retrieved from system (determined via the file extension). This is the same string which is displayed in the Type column of the Details view. In the same time, file format is determined with Image Uploader by analyzing file content (rather than the file extension).


file.verticalResolution Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a vertical resolution of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

value = $au.uploader('uploaderID').files().get(index).verticalResolution();

Property Value

Type: Number

The vertical resolution of this file (in DPI) if it is an image; otherwise, 0 is returned.


file.width Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a width of the user-selected file.

Syntax

JavaScript

Get/Set Value at Runtime

value = $au.uploader('uploaderID').files().get(index).width();

Property Value

Type: Number

The width of this file (in pixels) if it is an image; otherwise, 0 is returned.


files Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a collection of files added to the upload pane. See Example for details.

For a list of all members of this class, see files Members.

Syntax

JavaScript

$au.files = function() {
}

Examples

This example rotates all the selected images in the upload pane by 90 degrees counterclockwise.

JavaScript

function rotateSelected(){
    var count = $au.uploader('Uploader1').files().count();
    for (var i = 0; i < count; i++){
        if ($au.uploader('Uploader1').files().get(i).selected()){
            var angle = $au.uploader('Uploader1').files().get(i).angle();
            angle = (angle - 90) % 360;
            $au.uploader('Uploader1').files().get(i).angle(angle);
        }
    }
}

See Also

Reference

  • files Property


files Members

  • Methods
  • Language Filter ( all languages )

The files type exposes the following members.

Methods

 | Name | Description
Public method | count | Returns the number of files actually contained in the upload pane.
Public method | get(Number) | Returns the file at the specified index.
Public method | remove(Number) | Removes the file at the specified index from the upload pane.
Public method | removeByGuid(String) | Removes the file with the specified GUID from the upload pane.
Public method | totalFileSize | Returns the total size of files selected for the upload.


files Methods

  • Methods
  • Language Filter ( all languages )

The files type exposes the following methods.

Methods

 | Name | Description
Public method | count | Returns the number of files actually contained in the upload pane.
Public method | get(Number) | Returns the file at the specified index.
Public method | remove(Number) | Removes the file at the specified index from the upload pane.
Public method | removeByGuid(String) | Removes the file with the specified GUID from the upload pane.
Public method | totalFileSize | Returns the total size of files selected for the upload.


files.count Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns the number of files actually contained in the upload pane.

Syntax

JavaScript

$au.uploader('uploaderID').files().count();

Return Value

Type: Number

The number of converters actually contained in the upload pane.

Remarks

You can use this property to enumerate files selected for the upload.


files.get(Number) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns the file at the specified index.

Syntax

JavaScript

$au.uploader('uploaderID').files().get(index);

Parameters

index

Type: Number

The zero-based index of the file to get.

Return Value

Type: $au.file

The file at the specified index.


files.remove(Number) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Removes the file at the specified index from the upload pane.

Syntax

JavaScript

$au.uploader('uploaderID').files().remove(index);

Parameters

index

Type: Number

The zero-based index of the file to remove.

Remarks

If you want to remove all files or all selected files from the upload pane use the uploadPane.removeAllFiles() or uploadPane.removeSelectedFiles() method respectively.


files.removeByGuid(String) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Removes the file with the specified GUID from the upload pane.

Syntax

JavaScript

$au.uploader('uploaderID').files().removeByGuid(guid);

Parameters

guid

Type: String

The GUID of the file to remove.

See Also

Reference

  • guid Property


files.totalFileSize Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns the total size of files selected for the upload.

Syntax

JavaScript

$au.uploader('uploaderID').files().totalFileSize();

Return Value

Type: Number

The total size (in bytes) of files actually contained in the upload pane.


folderPane Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the folder pane.

For a list of all members of this class, see folderPane Members.

Syntax

JavaScript

$au.folderPane = function() {
}

Remarks

All the properties of this class make sense in ThreePanes layout only.

See Also

Reference

  • folderPane Property
  • Aurigma.ImageUploader.FolderPane ASP.NET Class
  • FolderPane PHP Class

Manual

  • Layouts
  • Customizing Appearance


folderPane Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The folderPane type exposes the following members.

Methods

 | Name | Description
Public method | canGoToFolder(String) | Verifies whether the specified special folder is available.
Public method | deselectAll | Clears the selection from all folder pane items.
Public method | goToFolder(String) | Navigates to the specified folder. The parameter can contain either a path to the target folder (for example, C:/Images) or a member of enumeration which specifies a special folder (for example, My Documents, My Pictures, etc.).
Public method | goToParentFolder | Navigates to the parent folder.
Public method | goToPreviousFolder | Navigates to the previous folder.
Public method | selectAll | Selects all the items in the folder pane.

Properties

 | Name | Description
Public property | filterClearIconImageFormat | Gets or sets a list of images that are displayed in different states of the search box icon.
Public property | filterHintText | Gets a sets a text of the prompt inside the search box.
Public property | headerAllText | Gets a sets a text of the Total files label.
Public property | headerAllowedText | Gets a sets a text of the Allowed label.
Public property | height | Gets or sets a height of the folder pane.
Public property | previewSize | Gets or sets a size of the preview area in Thumbnails view.
Public property | showAllowedItemsOnly | Gets or sets value indicating whether to display denied files in the folder pane.
Public property | sortMode | Gets or sets a sort mode of the folder pane.
Public property | viewMode | Gets or sets a view mode for the folder pane.


folderPane Methods

  • Methods
  • Language Filter ( all languages )

The folderPane type exposes the following methods.

Methods

 | Name | Description
Public method | canGoToFolder(String) | Verifies whether the specified special folder is available.
Public method | deselectAll | Clears the selection from all folder pane items.
Public method | goToFolder(String) | Navigates to the specified folder. The parameter can contain either a path to the target folder (for example, C:/Images) or a member of enumeration which specifies a special folder (for example, My Documents, My Pictures, etc.).
Public method | goToParentFolder | Navigates to the parent folder.
Public method | goToPreviousFolder | Navigates to the previous folder.
Public method | selectAll | Selects all the items in the folder pane.


folderPane.canGoToFolder(String) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Verifies whether the specified special folder is available.

Syntax

JavaScript

$au.uploader('uploaderID').folderPane().canGoToFolder(folder);

Parameters

folder

Type: String

A member of this enumeration that specifies a special folder to check:

Value | Description
BitBucket | Recycle Bin
Desktop | Desktop (for the user currently logged into the system)
MyComputer | My Computer
MyDocuments | My Documents (for the user currently logged into the system)
MyMusic | My Music (for the user currently logged into the system)
MyPictures | My Pictures (for the user currently logged into the system)
MyVideo | My Video (for the user currently logged into the system)
Network | My Network Places

Return Value

Type: Boolean

true if the specified folder is available and Image Uploader can navigate it; otherwise, false.

Note

This method works only for special folders. You cannot verify physical path on the local machine with this method.

Remarks

This method is helpful if you use custom buttons to navigate to the special folder (like My Pictures or My Documents). For example you can check what special folders are available and hide buttons for the folders which are not available.

To navigate to a certain special folder, use the goToFolder(String) method.

See Also

Reference

  • goToFolder(String) Method
  • goToParentFolder() Method
  • goToPreviousFolder() Method


folderPane.deselectAll Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Clears the selection from all folder pane items.

Syntax

JavaScript

$au.uploader('uploaderID').folderPane().deselectAll();


folderPane.goToFolder(String) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Navigates to the specified folder. The parameter can contain either a path to the target folder (for example, C:/Images) or a member of enumeration which specifies a special folder (for example, My Documents, My Pictures, etc.).

Syntax

JavaScript

$au.uploader('uploaderID').folderPane().goToFolder(folder);

Parameters

folder

Type: String

A path to the target folder or a member of the following enumeration which specifies a special folder to navigate to:

Value | Description
BitBucket | Recycle Bin
Desktop | Desktop (for the user currently logged into the system)
MyComputer | My Computer
MyDocuments | My Documents (for the user currently logged into the system)
MyMusic | My Music (for the user currently logged into the system)
MyPictures | My Pictures (for the user currently logged into the system)
MyVideo | My Video (for the user currently logged into the system)
Network | My Network Places

Return Value

Type: Boolean

true if the specified folder is available and Image Uploader successfully navigates to it; otherwise, false.

Remarks

Note

When you call this method in non-Internet Explorer browser, take into account that not all the special folders will be available. Supported folders depend on the operating system on which Image Uploader is running. For example, on Windows it can navigate to Desktop and MyDocuments folders. In Internet Explorer all the listed folders are available.

To check if a certain folder is available on the given computer, use the canGoToFolder(String) method.

See Also

Reference

  • canGoToFolder(String) Method
  • goToParentFolder() Method
  • goToPreviousFolder() Method


folderPane.goToParentFolder Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Navigates to the parent folder.

Syntax

JavaScript

$au.uploader('uploaderID').folderPane().goToParentFolder();

Return Value

Type: Boolean

true if the operation is succeeded; otherwise, false. For example, it will fail if the current folder is the Desktop node of the folder tree (which is always the root node).

See Also

Reference

  • canGoToFolder(String) Method
  • goToFolder(String) Method
  • goToPreviousFolder() Method


folderPane.goToPreviousFolder Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Navigates to the previous folder.

Syntax

JavaScript

$au.uploader('uploaderID').folderPane().goToPreviousFolder();

Return Value

Type: Boolean

true if the operation is succeeded; otherwise, false. For example, it will return false if a user did not navigate any folder yet (i.e. the control is just loaded).

Remarks

Note

Image Uploader does not store a history of visited folders. Thus, you can navigate only to one previous folder. If you call this method twice, you will be moved back to the current folder.

See Also

Reference

  • canGoToFolder(String) Method
  • goToFolder(String) Method
  • goToParentFolder() Method


folderPane.selectAll Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Selects all the items in the folder pane.

Syntax

JavaScript

$au.uploader('uploaderID').folderPane().selectAll();


folderPane Properties

  • Properties
  • Language Filter ( all languages )

The folderPane type exposes the following properties.

Properties

 | Name | Description
Public property | filterClearIconImageFormat | Gets or sets a list of images that are displayed in different states of the search box icon.
Public property | filterHintText | Gets a sets a text of the prompt inside the search box.
Public property | headerAllText | Gets a sets a text of the Total files label.
Public property | headerAllowedText | Gets a sets a text of the Allowed label.
Public property | height | Gets or sets a height of the folder pane.
Public property | previewSize | Gets or sets a size of the preview area in Thumbnails view.
Public property | showAllowedItemsOnly | Gets or sets value indicating whether to display denied files in the folder pane.
Public property | sortMode | Gets or sets a sort mode of the folder pane.
Public property | viewMode | Gets or sets a view mode for the folder pane.


folderPane.filterClearIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the search box icon.

Syntax

JavaScript

Initialize

$au.uploader({
    folderPane: {
        //...other params...
        filterClearIconImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').folderPane().filterClearIconImageFormat(value);
value = $au.uploader('uploaderID').folderPane().filterClearIconImageFormat();

Property Value

Type: String

The list of custom images of the search box icon.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.FilterClearIconImageFormat ASP.NET Property
  • FolderPane.FilterClearIconImageFormat PHP Property


folderPane.filterHintText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a sets a text of the prompt inside the search box.

Syntax

JavaScript

Initialize

$au.uploader({
    folderPane: {
        //...other params...
        filterHintText: "Search ",
        //...other params...
    }
})

Property Value

Type: String

The text of the prompt inside the search box.

Default value is "Search ".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.FilterHintText ASP.NET Property
  • FolderPane.FilterHintText PHP Property


folderPane.headerAllText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a sets a text of the Total files label.

Syntax

JavaScript

Initialize

$au.uploader({
    folderPane: {
        //...other params...
        headerAllText: "Total files: [count], ",
        //...other params...
    }
})

Property Value

Type: String

The text of the Total files label. It can contain the following placeholder:

[count]
replaced by the total number of files.

Default value is "Total files: [count], ".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.HeaderAllText ASP.NET Property
  • FolderPane.HeaderAllText PHP Property


folderPane.headerAllowedText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets a sets a text of the Allowed label.

Syntax

JavaScript

Initialize

$au.uploader({
    folderPane: {
        //...other params...
        headerAllowedText: "allowed: [count]",
        //...other params...
    }
})

Property Value

Type: String

The text of the Allowed label. It can contain the following placeholder:

[count]
replaced by the number of allowed files.

Default value is "allowed: [count]".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.HeaderAllowedText ASP.NET Property
  • FolderPane.HeaderAllowedText PHP Property


folderPane.height Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of the folder pane.

Syntax

JavaScript

Initialize

$au.uploader({
    folderPane: {
        //...other params...
        height: 300,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').folderPane().height(value);
value = $au.uploader('uploaderID').folderPane().height();

Property Value

Type: Number

The height of the folder pane.

Default value is 300.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.Height ASP.NET Property
  • FolderPane.Height PHP Property


folderPane.previewSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a size of the preview area in Thumbnails view.

Syntax

JavaScript

Initialize

$au.uploader({
    folderPane: {
        //...other params...
        previewSize: 96,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').folderPane().previewSize(value);
value = $au.uploader('uploaderID').folderPane().previewSize();

Property Value

Type: Number

The size of the preview area (in pixels). In other words, this property specifies size of square the thumbnail is inscribed in.

Default value is 96.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.PreviewSize ASP.NET Property
  • FolderPane.PreviewSize PHP Property


folderPane.showAllowedItemsOnly Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets value indicating whether to display denied files in the folder pane.

Syntax

JavaScript

Initialize

$au.uploader({
    folderPane: {
        //...other params...
        showAllowedItemsOnly: true,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').folderPane().showAllowedItemsOnly(value);
value = $au.uploader('uploaderID').folderPane().showAllowedItemsOnly();

Property Value

Type: Boolean

If true, the folder pane shows only those files which meet the specified restrictions; otherwise, all the files are visible.

Default value is true.

Remarks

This property makes sense if at least one limitation is specified via the restrictions properties.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.ShowAllowedItemsOnly ASP.NET Property
  • FolderPane.ShowAllowedItemsOnly PHP Property

Manual

  • Configuring Restriction Rules for Files


folderPane.sortMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a sort mode of the folder pane.

Syntax

JavaScript

Initialize

$au.uploader({
    folderPane: {
        //...other params...
        sortMode: "Name",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').folderPane().sortMode(value);
value = $au.uploader('uploaderID').folderPane().sortMode();

Property Value

Type: String

The sort mode of the folder pane.

The following values are supported:

Value | Description
Unsorted | Items are unsorted.
Name | Items are sorted by name alphabetically.
Size | Items are sorted by file size.
Type | Items are sorted by file type alphabetically.
Modified | Items are sorted by the date of last modification.
Path | Items are sorted by full path.
Dimensions | Items are sorted by image dimensions.
Note

The sort mode cannot be set to Unsorted value manually.

Default value is "Name".

Remarks

Sort mode is automatically reset to Unsorted when new items are added or re-arranged via drag-n-drop.

Note

If you set the same value twice, the sort order will toggle between ascending and descending and vice versa.

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.SortMode ASP.NET Property
  • FolderPane.SortMode PHP Property


folderPane.viewMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a view mode for the folder pane.

Syntax

JavaScript

Initialize

$au.uploader({
    folderPane: {
        //...other params...
        viewMode: "Thumbnails",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').folderPane().viewMode(value);
value = $au.uploader('uploaderID').folderPane().viewMode();

Property Value

Type: String

The view mode for the folder pane.

The following values are supported:

Value | Description
Thumbnails | Images are displayed as thumbnails, non-images are displayed as icons. It is possible to attach a description to each file. If a file is recognized as image, it can be cropped and rotated.
Tiles | Each file appears as a thumbnail (or icon for non-image files), with a file name and details (file type, last modification date, and file size) on the right. It is possible to attach a description to each file. If a file is recognized as image, it can be cropped and rotated.
Details | All the files are displayed as a detailed list (icon + filename + info + size + last modification date + type + image dimensions).
List | Files are displayed as small thumbnails (or icons for non-image files) with names on the right.

Default value is "Thumbnails".

See Also

Reference

  • Aurigma.ImageUploader.FolderPane.ViewMode ASP.NET Property
  • FolderPane.ViewMode PHP Property

Manual

  • View Modes


imageEditor Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the image editor.

For a list of all members of this class, see imageEditor Members.

Syntax

JavaScript

$au.imageEditor = function() {
}

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor ASP.NET Class
  • ImageEditor PHP Class

Manual

  • Image Editor
  • Customizing Appearance


imageEditor Members

  • Properties
  • Language Filter ( all languages )

The imageEditor type exposes the following members.

Properties

 | Name | Description
Public property | cancelButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Cancel button.
Public property | cancelButtonText | Gets or sets a caption of the Cancel button.
Public property | cancelCropButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Cancel Crop button.
Public property | cancelCropButtonText | Gets or sets a caption of the Cancel crop button.
Public property | cropButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Crop button.
Public property | cropButtonText | Gets or sets a caption of the Crop button.
Public property | cropMinSize | Gets or sets minimum width and height of the crop rectangle (in pixels).
Public property | cropRatio | Gets or sets an aspect ratio of the crop rectangle.
Public property | descriptionHintText | Gets or sets a text of the prompt which is displayed when no description is entered.
Public property | enableCrop | Gets or sets a value indicating whether it is possible to crop an image in the image editor.
Public property | rotateButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Rotate button.
Public property | rotateButtonText | Gets or sets a caption of the Rotate button.
Public property | saveButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Save and close button.
Public property | saveButtonText | Gets or sets a caption of the Save and close button.


imageEditor Properties

  • Properties
  • Language Filter ( all languages )

The imageEditor type exposes the following properties.

Properties

 | Name | Description
Public property | cancelButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Cancel button.
Public property | cancelButtonText | Gets or sets a caption of the Cancel button.
Public property | cancelCropButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Cancel Crop button.
Public property | cancelCropButtonText | Gets or sets a caption of the Cancel crop button.
Public property | cropButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Crop button.
Public property | cropButtonText | Gets or sets a caption of the Crop button.
Public property | cropMinSize | Gets or sets minimum width and height of the crop rectangle (in pixels).
Public property | cropRatio | Gets or sets an aspect ratio of the crop rectangle.
Public property | descriptionHintText | Gets or sets a text of the prompt which is displayed when no description is entered.
Public property | enableCrop | Gets or sets a value indicating whether it is possible to crop an image in the image editor.
Public property | rotateButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Rotate button.
Public property | rotateButtonText | Gets or sets a caption of the Rotate button.
Public property | saveButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Save and close button.
Public property | saveButtonText | Gets or sets a caption of the Save and close button.


imageEditor.cancelButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the Cancel button.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        cancelButtonImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').imageEditor().cancelButtonImageFormat(value);
value = $au.uploader('uploaderID').imageEditor().cancelButtonImageFormat();

Property Value

Type: String

The list of custom images of the Cancel button.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CancelButtonImageFormat ASP.NET Property
  • ImageEditor.CancelButtonImageFormat PHP Property


imageEditor.cancelButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel button.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        cancelButtonText: "Cancel",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Cancel button.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CancelButtonText ASP.NET Property
  • ImageEditor.CancelButtonText PHP Property


imageEditor.cancelCropButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the Cancel Crop button.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        cancelCropButtonImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').imageEditor().cancelCropButtonImageFormat(value);
value = $au.uploader('uploaderID').imageEditor().cancelCropButtonImageFormat();

Property Value

Type: String

The list of custom images of the Cancel crop button.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CancelCropButtonImageFormat ASP.NET Property
  • ImageEditor.CancelCropButtonImageFormat PHP Property


imageEditor.cancelCropButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel crop button.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        cancelCropButtonText: "Cancel crop",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Cancel crop button.

Default value is "Cancel crop".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CancelCropButtonText ASP.NET Property
  • ImageEditor.CancelCropButtonText PHP Property


imageEditor.cropButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the Crop button.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        cropButtonImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').imageEditor().cropButtonImageFormat(value);
value = $au.uploader('uploaderID').imageEditor().cropButtonImageFormat();

Property Value

Type: String

The list of custom images of the Crop button.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CropButtonImageFormat ASP.NET Property
  • ImageEditor.CropButtonImageFormat PHP Property


imageEditor.cropButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Crop button.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        cropButtonText: "Crop",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Crop button.

Default value is "Crop".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CropButtonText ASP.NET Property
  • ImageEditor.CropButtonText PHP Property


imageEditor.cropMinSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets minimum width and height of the crop rectangle (in pixels).

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        cropMinSize: 50,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').imageEditor().cropMinSize(value);
value = $au.uploader('uploaderID').imageEditor().cropMinSize();

Property Value

Type: Number

The minimum width and height of the crop rectangle (in pixels).

Default value is 50.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CropMinSize ASP.NET Property
  • ImageEditor.CropMinSize PHP Property


imageEditor.cropRatio Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an aspect ratio of the crop rectangle.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        cropRatio: 0,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').imageEditor().cropRatio(value);
value = $au.uploader('uploaderID').imageEditor().cropRatio();

Property Value

Type: Number

The aspect ratio of the crop rectangle. If 0 no aspect ratio is given.

Default value is 0.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.CropRatio ASP.NET Property
  • ImageEditor.CropRatio PHP Property


imageEditor.descriptionHintText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text of the prompt which is displayed when no description is entered.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        descriptionHintText: "Type description here...",
        //...other params...
    }
})

Property Value

Type: String

The text of the Type description here prompt.

Default value is "Type description here...".

Remarks

Note

This property also specifies the same prompt in the description editor.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.DescriptionHintText ASP.NET Property
  • ImageEditor.DescriptionHintText PHP Property


imageEditor.enableCrop Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is possible to crop an image in the image editor.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        enableCrop: true,
        //...other params...
    }
})

Property Value

Type: Boolean

If true, the crop functionality is supported in the image editor; otherwise, images can only be previewed, rotated, and/or provided with a description.

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.EnableCrop ASP.NET Property
  • ImageEditor.EnableCrop PHP Property


imageEditor.rotateButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the Rotate button.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        rotateButtonImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').imageEditor().rotateButtonImageFormat(value);
value = $au.uploader('uploaderID').imageEditor().rotateButtonImageFormat();

Property Value

Type: String

The list of custom images of the Rotate button.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.RotateButtonImageFormat ASP.NET Property
  • ImageEditor.RotateButtonImageFormat PHP Property


imageEditor.rotateButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Rotate button.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        rotateButtonText: "Rotate",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Rotate button.

Default value is "Rotate".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.RotateButtonText ASP.NET Property
  • ImageEditor.RotateButtonText PHP Property


imageEditor.saveButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the Save and close button.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        saveButtonImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').imageEditor().saveButtonImageFormat(value);
value = $au.uploader('uploaderID').imageEditor().saveButtonImageFormat();

Property Value

Type: String

The list of custom images of the Save and close button.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.SaveButtonImageFormat ASP.NET Property
  • ImageEditor.SaveButtonImageFormat PHP Property


imageEditor.saveButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Save and close button.

Syntax

JavaScript

Initialize

$au.uploader({
    imageEditor: {
        //...other params...
        saveButtonText: "Save and close",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Save and close button.

Default value is "Save and close".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.ImageEditor.SaveButtonText ASP.NET Property
  • ImageEditor.SaveButtonText PHP Property


informationBar Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the information bar.

For a list of all members of this class, see informationBar Members.

Syntax

JavaScript

$au.informationBar = function() {
}

See Also

Reference

  • Aurigma.ImageUploader.InformationBar ASP.NET Class
  • InformationBar PHP Class

Manual

  • Customizing Appearance


informationBar Members

  • Properties
  • Language Filter ( all languages )

The informationBar type exposes the following members.

Properties

 | Name | Description
Public property | closeIconImageFormat | Gets or sets a list of images that are displayed in different states of the information bar icon.
Public property | errorColor | Gets or sets a color of the information bar when it displays an error message.
Public property | messageColor | Gets or sets a color of the information bar when it displays an information massage message.
Public property | warningColor | Gets or sets a color of the information bar when it displays a warning message.


informationBar Properties

  • Properties
  • Language Filter ( all languages )

The informationBar type exposes the following properties.

Properties

 | Name | Description
Public property | closeIconImageFormat | Gets or sets a list of images that are displayed in different states of the information bar icon.
Public property | errorColor | Gets or sets a color of the information bar when it displays an error message.
Public property | messageColor | Gets or sets a color of the information bar when it displays an information massage message.
Public property | warningColor | Gets or sets a color of the information bar when it displays a warning message.


informationBar.closeIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the information bar icon.

Syntax

JavaScript

Initialize

$au.uploader({
    informationBar: {
        //...other params...
        closeIconImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').informationBar().closeIconImageFormat(value);
value = $au.uploader('uploaderID').informationBar().closeIconImageFormat();

Property Value

Type: String

The list of custom images of the information bar icon.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.InformationBar.CloseIconImageFormat ASP.NET Property
  • InformationBar.CloseIconImageFormat PHP Property


informationBar.errorColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the information bar when it displays an error message.

Syntax

JavaScript

Initialize

$au.uploader({
    informationBar: {
        //...other params...
        errorColor: "#f14b54",
        //...other params...
    }
})

Property Value

Type: String

The color of the error message. Such messages appear when upload in broken.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#f14b54".

See Also

Reference

  • Aurigma.ImageUploader.InformationBar.ErrorColor ASP.NET Property
  • InformationBar.ErrorColor PHP Property


informationBar.messageColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the information bar when it displays an information massage message.

Syntax

JavaScript

Initialize

$au.uploader({
    informationBar: {
        //...other params...
        messageColor: "#a3ffa8",
        //...other params...
    }
})

Property Value

Type: String

The color of the information message. Such message appears when upload is completed successfully.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#a3ffa8".

See Also

Reference

  • Aurigma.ImageUploader.InformationBar.MessageColor ASP.NET Property
  • InformationBar.MessageColor PHP Property


informationBar.warningColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the information bar when it displays a warning message.

Syntax

JavaScript

Initialize

$au.uploader({
    informationBar: {
        //...other params...
        warningColor: "#fde2a6",
        //...other params...
    }
})

Property Value

Type: String

The color of the warning message. Such messages are displayed when a file does not meet the specified restrictions.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#fde2a6".

See Also

Reference

  • Aurigma.ImageUploader.InformationBar.WarningColor ASP.NET Property
  • InformationBar.WarningColor PHP Property


installationProgress Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class allows displaying special screens instead of Image Uploader during the downloading and installation phases.

For a list of all members of this class, see installationProgress Members.

Syntax

JavaScript

$au.installationProgress = function() {
}

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress ASP.NET Class
  • InstallationProgress PHP Class

Manual

  • Using Image Uploader Installation Progress


installationProgress Members

  • Properties
  • Language Filter ( all languages )

The installationProgress type exposes the following members.

Constructors

 | Name | Description
Public method | installationProgress(uploader) | Creates and initializes an instance of the installationProgress class.

Properties

 | Name | Description
Public property | IE6XPSP2InstructionsHtml | Sets installation instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.
Public property | IE6XPSP2ProgressHtml | Sets downloading instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.
Public property | IE7InstructionsHtml | Sets installation instructions for Internet Explorer 7.
Public property | IE7ProgressHtml | Sets downloading instructions for Internet Explorer 7.
Public property | IE8InstructionsHtml | Sets installation instructions for Internet Explorer 8.
Public property | IE8ProgressHtml | Sets downloading instructions for Internet Explorer 8.
Public property | altInstallerHtml | Sets an HTML-marked text appended to installation instructions and saying how to install Image Uploader in alternative way (e.g. use a standalone installer).
Public property | beforeIE6XPSP2InstructionsHtml | Sets installation instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.
Public property | beforeIE6XPSP2ProgressHtml | Set downloading instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.
Public property | commonHtml | Sets an HTML-marked description of Image Uploader displayed on the both stages (downloading and installation).
Public property | installJavaHtml | Sets installation instructions for non-Internet Explorer browsers.
Public property | instructionsCssClass | Sets a CSS class name to apply it to the installation screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
Public property | macInstallJavaHtml | Sets installation instructions for Mac browsers.
Public property | progressCssClass | Sets a CSS class name to apply it to the downloading screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
Public property | progressHtml | Sets a text saying that the downloading of Image Uploader is in progress.
Public property | progressImageUrl | Sets a URL to a custom image which replaces a default wait indicator.
Public property | showDownloadingScreen | Sets a value indicating whether the downloading screen should be displayed.
Public property | showInstallationScreen | Sets a value indicating whether the installation screen should be displayed.
Public property | updateInstructions | Sets common instructions on how to update Image Uploader control.


installationProgress(uploader) Constructor

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the installationProgress class.

Syntax

JavaScript

$au.installationProgress(uploader);

Parameters

uploader

Type: $au.uploader

The uploader object to create this installationProgress for.

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress ASP.NET Constructor
  • InstallationProgress(Uploader) PHP Constructor


installationProgress Properties

  • Properties
  • Language Filter ( all languages )

The installationProgress type exposes the following properties.

Properties

 | Name | Description
Public property | IE6XPSP2InstructionsHtml | Sets installation instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.
Public property | IE6XPSP2ProgressHtml | Sets downloading instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.
Public property | IE7InstructionsHtml | Sets installation instructions for Internet Explorer 7.
Public property | IE7ProgressHtml | Sets downloading instructions for Internet Explorer 7.
Public property | IE8InstructionsHtml | Sets installation instructions for Internet Explorer 8.
Public property | IE8ProgressHtml | Sets downloading instructions for Internet Explorer 8.
Public property | altInstallerHtml | Sets an HTML-marked text appended to installation instructions and saying how to install Image Uploader in alternative way (e.g. use a standalone installer).
Public property | beforeIE6XPSP2InstructionsHtml | Sets installation instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.
Public property | beforeIE6XPSP2ProgressHtml | Set downloading instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.
Public property | commonHtml | Sets an HTML-marked description of Image Uploader displayed on the both stages (downloading and installation).
Public property | installJavaHtml | Sets installation instructions for non-Internet Explorer browsers.
Public property | instructionsCssClass | Sets a CSS class name to apply it to the installation screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
Public property | macInstallJavaHtml | Sets installation instructions for Mac browsers.
Public property | progressCssClass | Sets a CSS class name to apply it to the downloading screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.
Public property | progressHtml | Sets a text saying that the downloading of Image Uploader is in progress.
Public property | progressImageUrl | Sets a URL to a custom image which replaces a default wait indicator.
Public property | showDownloadingScreen | Sets a value indicating whether the downloading screen should be displayed.
Public property | showInstallationScreen | Sets a value indicating whether the installation screen should be displayed.
Public property | updateInstructions | Sets common instructions on how to update Image Uploader control.


installationProgress.IE6XPSP2InstructionsHtml Property

  • Supported browsers: Internet Explorer

Sets installation instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.IE6XPSP2InstructionsHtml("<p>To install Image Uploader, please click on the <strong>Information Bar</strong> " +
"and select <strong>Install ActiveX Control</strong> from the dropdown menu. After page reload click " +
"<strong>Install</strong> when you see the control installation dialog. If you don't see Information Bar, " +
"please try to reload the page and/or check your security settings.</p>");
//...other params...
u.writeHtml();

Property Value

Type: String

The installation instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.

Default value is "<p>To install Image Uploader, please click on the <strong>Information Bar</strong> and select <strong>Install ActiveX Control</strong> from the dropdown menu. After page reload click <strong>Install</strong> when you see the control installation dialog. If you don't see Information Bar, please try to reload the page and/or check your security settings.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.IE6XPSP2InstructionsHtml ASP.NET Property
  • InstallationProgress.IE6XPSP2InstructionsHtml PHP Property


installationProgress.IE6XPSP2ProgressHtml Property

  • Supported browsers: Internet Explorer

Sets downloading instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.IE6XPSP2ProgressHtml("<p>Please wait until the control will be loaded.</p>");
//...other params...
u.writeHtml();

Property Value

Type: String

The downloading instructions for Internet Explorer 6 running on version of Windows equal to Windows XP Service Pack 2 or higher.

Default value is "<p>Please wait until the control will be loaded.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.IE6XPSP2ProgressHtml ASP.NET Property
  • InstallationProgress.IE6XPSP2ProgressHtml PHP Property


installationProgress.IE7InstructionsHtml Property

  • Supported browsers: Internet Explorer

Sets installation instructions for Internet Explorer 7.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.IE7InstructionsHtml("<p>To install Image Uploader, please click on the <strong>Information Bar</strong> " +
"and select <strong>Install ActiveX Control</strong> or <strong>Run ActiveX Control</strong> from the dropdown menu.</p>" +
"<p>Then either click <strong>Run</strong> or after the page reload click <strong>Install</strong> when you see the " +
"control installation dialog. If you don't see Information Bar, please try to reload the page and/or check your security " +
"settings.</p>");
//...other params...
u.writeHtml();

Property Value

Type: String

The installation instructions for Internet Explorer 7.

Default value is "<p>To install Image Uploader, please click on the <strong>Information Bar</strong> and select <strong>Install ActiveX Control</strong> or <strong>Run ActiveX Control</strong> from the dropdown menu.</p> <p>Then either click <strong>Run</strong> or after the page reload click <strong>Install</strong> when you see the control installation dialog. If you don't see Information Bar, please try to reload the page and/or check your security settings.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.IE7InstructionsHtml ASP.NET Property
  • InstallationProgress.IE7InstructionsHtml PHP Property


installationProgress.IE7ProgressHtml Property

  • Supported browsers: Internet Explorer

Sets downloading instructions for Internet Explorer 7.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.IE7ProgressHtml("<p>Please wait until the control will be loaded.</p>");
//...other params...
u.writeHtml();

Property Value

Type: String

The downloading instructions for Internet Explorer 7.

Default value is "<p>Please wait until the control will be loaded.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.IE7ProgressHtml ASP.NET Property
  • InstallationProgress.IE7ProgressHtml PHP Property


installationProgress.IE8InstructionsHtml Property

  • Supported browsers: Internet Explorer

Sets installation instructions for Internet Explorer 8.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.IE8InstructionsHtml("<p>To install Image Uploader, please click on the <strong>Information Bar</strong> " +
"and select <strong>Install This Add-on</strong> or <strong>Run Add-on</strong> from the dropdown menu.</p>" +
"<p>Then either click <strong>Run</strong> or after the page reload click <strong>Install</strong> when you see the " +
"control installation dialog. If you don't see Information Bar, please try to reload the page and/or check your " +
"security settings.</p>");
//...other params...
u.writeHtml();

Property Value

Type: String

The installation instructions for Internet Explorer 8.

Default value is "<p>To install Image Uploader, please click on the <strong>Information Bar</strong> and select <strong>Install This Add-on</strong> or <strong>Run Add-on</strong> from the dropdown menu.</p> <p>Then either click <strong>Run</strong> or after the page reload click <strong>Install</strong> when you see the control installation dialog. If you don't see Information Bar, please try to reload the page and/or check your security settings.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.IE8InstructionsHtml ASP.NET Property
  • InstallationProgress.IE8InstructionsHtml PHP Property


installationProgress.IE8ProgressHtml Property

  • Supported browsers: Internet Explorer

Sets downloading instructions for Internet Explorer 8.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.IE8ProgressHtml("<p>Please wait until the control will be loaded.</p>");
//...other params...
u.writeHtml();

Property Value

Type: String

The downloading instructions for Internet Explorer 8.

Default value is "<p>Please wait until the control will be loaded.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.IE8ProgressHtml ASP.NET Property
  • InstallationProgress.IE8ProgressHtml PHP Property


installationProgress.altInstallerHtml Property

  • Supported browsers: Internet Explorer

Sets an HTML-marked text appended to installation instructions and saying how to install Image Uploader in alternative way (e.g. use a standalone installer).

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.altInstallerHtml("");
//...other params...
u.writeHtml();

Property Value

Type: String

The instructions on how to install Image Uploader in alternative way.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.AltInstallerHtml ASP.NET Property
  • InstallationProgress.AltInstallerHtml PHP Property


installationProgress.beforeIE6XPSP2InstructionsHtml Property

  • Supported browsers: Internet Explorer

Sets installation instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.beforeIE6XPSP2InstructionsHtml("<p>To install Image Uploader, please reload the page and click " +
"the <strong>Yes</strong> button when you see the control installation dialog. " +
"If you don't see installation dialog, please check your security settings.</p>");
//...other params...
u.writeHtml();

Property Value

Type: String

The installation instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.

Default value is "<p>To install Image Uploader, please reload the page and click the <strong>Yes</strong> button when you see the control installation dialog. If you don't see installation dialog, please check your security settings.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.BeforeIE6XPSP2InstructionsHtml ASP.NET Property
  • InstallationProgress.BeforeIE6XPSP2InstructionsHtml PHP Property


installationProgress.beforeIE6XPSP2ProgressHtml Property

  • Supported browsers: Internet Explorer

Set downloading instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.beforeIE6XPSP2ProgressHtml("<p>To install Image Uploader, please wait until the control will be loaded and click " +
"the <strong>Yes</strong> button when you see the installation dialog.</p>");
//...other params...
u.writeHtml();

Property Value

Type: String

The downloading instructions for Internet Explorer 6 running on version of Windows earlier than Windows XP Service Pack 2.

Default value is "<p>To install Image Uploader, please wait until the control will be loaded and click the <strong>Yes</strong> button when you see the installation dialog.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.BeforeIE6XPSP2ProgressHtml ASP.NET Property
  • InstallationProgress.BeforeIE6XPSP2ProgressHtml PHP Property


installationProgress.commonHtml Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets an HTML-marked description of Image Uploader displayed on the both stages (downloading and installation).

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.commonHtml("<p>Aurigma Image Uploader control is necessary to upload " +
"your files quickly and easily. You will be able to select multiple images in user-friendly " +
"interface instead of clumsy input fields with <strong>Browse</strong> button.</p>");
//...other params...
u.writeHtml();

Property Value

Type: String

The description of Image Uploader.

Default value is "<p>Aurigma Image Uploader control is necessary to upload your files quickly and easily. You will be able to select multiple images in user-friendly interface instead of clumsy input fields with <strong>Browse</strong> button.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.CommonHtml ASP.NET Property
  • InstallationProgress.CommonHtml PHP Property


installationProgress.installJavaHtml Property

  • Supported browsers: Firefox Google Chrome Safari

Sets installation instructions for non-Internet Explorer browsers.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.installJavaHtml("<p>Please <a href=\"http://www.java.com/getjava/\">download</a> and " +
"install Java.</p>");
//...other params...
u.writeHtml();

Property Value

Type: String

Sets installation instructions for non-Internet Explorer browsers.

Default value is "<p>Please <a href=\"http://www.java.com/getjava/\">download</a> and install Java.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.InstallJavaHtml ASP.NET Property
  • InstallationProgress.InstallJavaHtml PHP Property


installationProgress.instructionsCssClass Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a CSS class name to apply it to the installation screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.instructionsCssClass("");
//...other params...
u.writeHtml();

Property Value

Type: String

The CSS class name to apply it to the installation screen.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.InstructionsCssClass ASP.NET Property
  • InstallationProgress.InstructionsCssClass PHP Property


installationProgress.macInstallJavaHtml Property

  • Supported browsers: Firefox Google Chrome Safari

Sets installation instructions for Mac browsers.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.macInstallJavaHtml("<p>Use the <a href=\"http://support.apple.com/kb/HT1338\">Software Update</a> " +
"feature (available on the Apple menu) to check that you have the most up-to-date version of Java for your Mac.</p>");
//...other params...
u.writeHtml();

Property Value

Type: String

The installation instructions for Mac browsers.

Default value is "<p>Use the <a href=\"http://support.apple.com/kb/HT1338\">Software Update</a> feature (available on the Apple menu) to check that you have the most up-to-date version of Java for your Mac.</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.MacInstallJavaHtml ASP.NET Property
  • InstallationProgress.MacInstallJavaHtml PHP Property


installationProgress.progressCssClass Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a CSS class name to apply it to the downloading screen. This class should be declared in a source code of the page Image Uploader is added to, or in the external CSS file linked to this page.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.progressCssClass("");
//...other params...
u.writeHtml();

Property Value

Type: String

The CSS class name to apply it to the downloading screen.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.ProgressCssClass ASP.NET Property
  • InstallationProgress.ProgressCssClass PHP Property


installationProgress.progressHtml Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a text saying that the downloading of Image Uploader is in progress.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.progressHtml("<p><img src=\"{0}\" /><br />" +
"Loading Aurigma Image Uploader...</p>");
//...other params...
u.writeHtml();

Property Value

Type: String

The text saying that the downloading of Image Uploader is in progress.

The value of this property can contain {0} placeholder. Before displaying the downloading screen, this placeholder is replaced with image URL defined in the progressImageUrl property. It allows you to customize images without changing HTML-marked text.

Default value is "<p><img src=\"{0}\" /><br /> Loading Aurigma Image Uploader...</p>".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.ProgressHtml ASP.NET Property
  • InstallationProgress.ProgressHtml PHP Property


installationProgress.progressImageUrl Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a URL to a custom image which replaces a default wait indicator.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.progressImageUrl("Scripts/InstallationProgress.gif");
//...other params...
u.writeHtml();

Property Value

Type: String

The URL to a custom image which replaces a default wait indicator.

Default value is "Scripts/InstallationProgress.gif".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.ProgressImageUrl ASP.NET Property
  • InstallationProgress.ProgressImageUrl PHP Property


installationProgress.showDownloadingScreen Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a value indicating whether the downloading screen should be displayed.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.showDownloadingScreen(true);
//...other params...
u.writeHtml();

Property Value

Type: Boolean

If true

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.ShowDownloadingScreen ASP.NET Property
  • InstallationProgress.ShowDownloadingScreen PHP Property


installationProgress.showInstallationScreen Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets a value indicating whether the installation screen should be displayed.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.showInstallationScreen(true);
//...other params...
u.writeHtml();

Property Value

Type: Boolean

If true

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.ShowInstallationScreen ASP.NET Property
  • InstallationProgress.ShowInstallationScreen PHP Property


installationProgress.updateInstructions Property

  • Supported browsers: Internet Explorer

Sets common instructions on how to update Image Uploader control.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var ip = $au.installationProgress(u);
ip.updateInstructions("You need to update Image Uploader control. Click <strong>Install</strong> " +
"or <strong>Run</strong> button when you see the control installation dialog. " +
"If you don't see installation dialog, please try to reload the page.");
//...other params...
u.writeHtml();

Property Value

Type: String

The instructions on how to update Image Uploader control.

Default value is "You need to update Image Uploader control. Click <strong>Install</strong> or <strong>Run</strong> button when you see the control installation dialog. If you don't see installation dialog, please try to reload the page.".

See Also

Reference

  • Aurigma.ImageUploader.InstallationProgress.UpdateInstructions ASP.NET Property
  • InstallationProgress.UpdateInstructions PHP Property


javaControl Class

  • Supported browsers: Firefox Google Chrome Safari

This class represents Image Uploader Java applet.

For a list of all members of this class, see javaControl Members.

Syntax

JavaScript

$au.javaControl = function() {
}

Remarks

Note

This client-side control is used in all browsers except Internet Explorer.

See Also

Reference

  • javaControl Property
  • Aurigma.ImageUploader.JavaControl ASP.NET Class
  • JavaControl PHP Class


javaControl Members

  • Properties
  • Language Filter ( all languages )

The javaControl type exposes the following members.

Properties

 | Name | Description
Public property | actualVersion | Gets a version of the currently installed Java applet.
Public property | cached | Gets or sets a value which enables or disables caching for Image Uploader Java applet.
Public property | className | Gets or sets a class name of Image Uploader Java applet.
Public property | codeBase | Gets or sets a URL to the ImageUploader7.jar file.
Public property | version | Gets or sets a minimum required version of the Java applet.


javaControl Properties

  • Properties
  • Language Filter ( all languages )

The javaControl type exposes the following properties.

Properties

 | Name | Description
Public property | actualVersion | Gets a version of the currently installed Java applet.
Public property | cached | Gets or sets a value which enables or disables caching for Image Uploader Java applet.
Public property | className | Gets or sets a class name of Image Uploader Java applet.
Public property | codeBase | Gets or sets a URL to the ImageUploader7.jar file.
Public property | version | Gets or sets a minimum required version of the Java applet.


javaControl.actualVersion Property

  • Supported browsers: Firefox Google Chrome Safari

Gets a version of the currently installed Java applet.

Syntax

JavaScript

Get/Set Value at Runtime

value = $au.uploader('uploaderID').javaControl().actualVersion();

Property Value

Type: string

The version number of the currently installed Java applet.


javaControl.cached Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a value which enables or disables caching for Image Uploader Java applet.

Syntax

JavaScript

Initialize

$au.uploader({
    javaControl: {
        //...other params...
        cached: true,
        //...other params...
    }
})

Property Value

Type: Boolean

If true, the Java applet is not re-downloaded until you update it on the server. Otherwise, the applet is re-downloaded every time a user visits this page.

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.JavaControl.Cached ASP.NET Property
  • JavaControl.Cached PHP Property


javaControl.className Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a class name of Image Uploader Java applet.

Syntax

JavaScript

Initialize

$au.uploader({
    javaControl: {
        //...other params...
        className: "",
        //...other params...
    }
})

Property Value

Type: String

The class name of Image Uploader Java applet.

Default value is "".

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.JavaControl.ClassName ASP.NET Property
  • JavaControl.ClassName PHP Property

Manual

  • Using Private-label Version of Image Uploader JavaScript


javaControl.codeBase Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a URL to the ImageUploader7.jar file.

Syntax

JavaScript

Initialize

$au.uploader({
    javaControl: {
        //...other params...
        codeBase: "Scripts/ImageUploader7.jar",
        //...other params...
    }
})

Property Value

Type: String

The URL to the ImageUploader7.jar file.

Default value is "Scripts/ImageUploader7.jar".

Remarks

This property is used to embed private-label version of Image Uploader.

See Also

Manual

  • Using Private-label Version of Image Uploader JavaScript


javaControl.version Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a minimum required version of the Java applet.

Syntax

JavaScript

Initialize

$au.uploader({
    javaControl: {
        //...other params...
        version: "",
        //...other params...
    }
})

Property Value

Type: String

The minimum required version of the Java applet.

Default value is "".


messages Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class contains error messages Image Uploader shows.

For a list of all members of this class, see messages Members.

Syntax

JavaScript

$au.messages = function() {
}

See Also

Reference

  • messages Property
  • Aurigma.ImageUploader.Messages ASP.NET Class
  • Messages PHP Class


messages Members

  • Properties
  • Language Filter ( all languages )

The messages type exposes the following members.

Properties

 | Name | Description
Public property | cmykImagesNotAllowed | Gets or sets a message which states that the selected image is CMYK, when CMYK images are denied for the upload.
Public property | deletingFilesError | Gets or sets a message which states that the uploaded file cannot be deleted.
Public property | dimensionsTooLarge | Gets or sets a message which states that the width or height of the selected image is too large.
Public property | dimensionsTooSmall | Gets or sets a message which states that the width or height of selected image is too small.
Public property | fileNameNotAllowed | Gets or sets a message which states that a user tries to select a file that has not allowed name.
Public property | fileSizeTooSmall | Gets or sets a message which states that a user tries to select a file that is too small.
Public property | filesNotAdded | Gets or sets the message displayed when a user tries to add files and some of them were not added because of restrictions.
Public property | maxFileCountExceeded | Gets or sets a message which states that a user tries to select too many files.
Public property | maxFileSizeExceeded | Gets or sets a message which states that a user tries to select a file that is too big.
Public property | maxTotalFileSizeExceeded | Gets or sets a message which states that the total size of selected files is too large.
Public property | noResponseFromServer | Gets or sets a message which states that an error was encountered when sending a request to the server and the server did not return any response.
Public property | serverNotFound | Gets or sets a message which states that the server, specified in the uploadSettings.actionUrl parameter cannot be found.
Public property | unexpectedError | Gets or sets a user-friendly message for errors which are meaningful to website developer only.
Public property | uploadCancelled | Gets or sets a message which states that a user cancelled the upload.
Public property | uploadCompleted | Gets or sets a message which notifies that the upload is successfully finished.
Public property | uploadFailed | Gets or sets a message which states that the upload failed because the connection was broken.


messages Properties

  • Properties
  • Language Filter ( all languages )

The messages type exposes the following properties.

Properties

 | Name | Description
Public property | cmykImagesNotAllowed | Gets or sets a message which states that the selected image is CMYK, when CMYK images are denied for the upload.
Public property | deletingFilesError | Gets or sets a message which states that the uploaded file cannot be deleted.
Public property | dimensionsTooLarge | Gets or sets a message which states that the width or height of the selected image is too large.
Public property | dimensionsTooSmall | Gets or sets a message which states that the width or height of selected image is too small.
Public property | fileNameNotAllowed | Gets or sets a message which states that a user tries to select a file that has not allowed name.
Public property | fileSizeTooSmall | Gets or sets a message which states that a user tries to select a file that is too small.
Public property | filesNotAdded | Gets or sets the message displayed when a user tries to add files and some of them were not added because of restrictions.
Public property | maxFileCountExceeded | Gets or sets a message which states that a user tries to select too many files.
Public property | maxFileSizeExceeded | Gets or sets a message which states that a user tries to select a file that is too big.
Public property | maxTotalFileSizeExceeded | Gets or sets a message which states that the total size of selected files is too large.
Public property | noResponseFromServer | Gets or sets a message which states that an error was encountered when sending a request to the server and the server did not return any response.
Public property | serverNotFound | Gets or sets a message which states that the server, specified in the uploadSettings.actionUrl parameter cannot be found.
Public property | unexpectedError | Gets or sets a user-friendly message for errors which are meaningful to website developer only.
Public property | uploadCancelled | Gets or sets a message which states that a user cancelled the upload.
Public property | uploadCompleted | Gets or sets a message which notifies that the upload is successfully finished.
Public property | uploadFailed | Gets or sets a message which states that the upload failed because the connection was broken.


messages.cmykImagesNotAllowed Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the selected image is CMYK, when CMYK images are denied for the upload.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        cmykImagesNotAllowed: "CMYK images are not allowed.",
        //...other params...
    }
})

Property Value

Type: String

The message which states that the selected image is CMYK.

Default value is "CMYK images are not allowed.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • enableCmyk Property
  • Aurigma.ImageUploader.Messages.CmykImagesNotAllowed ASP.NET Property
  • Messages.CmykImagesNotAllowed PHP Property


messages.deletingFilesError Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a message which states that the uploaded file cannot be deleted.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        deletingFilesError: "The file '[name]' cannot be deleted",
        //...other params...
    }
})

Property Value

Type: String

The message which states that the uploaded file cannot be deleted, e.g. it is used by another application. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be deleted.

Default value is "The file '[name]' cannot be deleted".

Remarks

Note

A difference between Image Uploader behavior in Internet Explorer and other supported browsers is the following. When Image Uploader deletes files in Internet Explorer, it moves them in the way specified in the Recycle Bin properties. By default, a standard delete confirmation dialog appears and files are moved to the Recycle Bin if a user clicks Yes. However, if Image Uploader deletes files in any of other supported browsers, the internal delete confirmation dialog appears and files are removed permanently when a user clicks Yes.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.DeletingFilesError ASP.NET Property
  • Messages.DeletingFilesError PHP Property


messages.dimensionsTooLarge Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the width or height of the selected image is too large.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        dimensionsTooLarge: "The image '[name]' is too large to be selected.",
        //...other params...
    }
})

Property Value

Type: String

The message which states that the width or height of the selected image is too large (i.e. exceeds the maxImageWidth or maxImageHeight property). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The image '[name]' is too large to be selected.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • maxImageWidth Property
  • maxImageHeight Property
  • Aurigma.ImageUploader.Messages.DimensionsTooLarge ASP.NET Property
  • Messages.DimensionsTooLarge PHP Property


messages.dimensionsTooSmall Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the width or height of selected image is too small.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        dimensionsTooSmall: "The image '[name]' is too small to be selected.",
        //...other params...
    }
})

Property Value

Type: String

The message which states that the width or height of the selected image is too small (i.e. it is less than minImageWidth or minImageHeight property). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The image '[name]' is too small to be selected.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • minImageWidth Property
  • minImageHeight Property
  • Aurigma.ImageUploader.Messages.DimensionsTooSmall ASP.NET Property
  • Messages.DimensionsTooSmall PHP Property


messages.fileNameNotAllowed Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user tries to select a file that has not allowed name.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        fileNameNotAllowed: "The file '[name]' cannot be selected. This file has inadmissible name.",
        //...other params...
    }
})

Property Value

Type: String

The message which states that a user tries to select a file that has not allowed name (i.e. the file name does not match fileMask, or matches deniedFileMask). It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. This file has inadmissible name.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • fileMask Property
  • deniedFileMask Property
  • Aurigma.ImageUploader.Messages.FileNameNotAllowed ASP.NET Property
  • Messages.FileNameNotAllowed PHP Property


messages.fileSizeTooSmall Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user tries to select a file that is too small.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        fileSizeTooSmall: "The file '[name]' cannot be selected. This file size is smaller than the limit.",
        //...other params...
    }
})

Property Value

Type: String

The message which states that a user tries to select too small file (i.e. the file size is smaller than minFileSize value). It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. This file size is smaller than the limit.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • minFileSize Property
  • Aurigma.ImageUploader.Messages.FileSizeTooSmall ASP.NET Property
  • Messages.FileSizeTooSmall PHP Property


messages.filesNotAdded Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the message displayed when a user tries to add files and some of them were not added because of restrictions.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        filesNotAdded: "[count] files were not added due to restrictions.",
        //...other params...
    }
})

Property Value

Type: String

The message which states that a user tries to add files and some of them were not added because of restrictions. It can contain the following placeholder:

[count]
replaced by the number of files which were not added.

Default value is "[count] files were not added due to restrictions.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.FilesNotAdded ASP.NET Property
  • Messages.FilesNotAdded PHP Property


messages.maxFileCountExceeded Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user tries to select too many files.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        maxFileCountExceeded: "The file '[name]' cannot be selected. Amount of files exceeds the limit.",
        //...other params...
    }
})

Property Value

Type: String

The message which states that a user tries to select too many files (i.e. the number of the selected files is bigger than the maxFileCount value). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. Amount of files exceeds the limit.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • maxFileCount Property
  • Aurigma.ImageUploader.Messages.MaxFileCountExceeded ASP.NET Property
  • Messages.MaxFileCountExceeded PHP Property


messages.maxFileSizeExceeded Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user tries to select a file that is too big.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        maxFileSizeExceeded: "The file '[name]' cannot be selected. This file size exceeds the limit.",
        //...other params...
    }
})

Property Value

Type: String

The message which states that a user tries to select too large file (i.e. the file size exceeds the maxFileSize value). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. This file size exceeds the limit.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • maxFileSize Property
  • Aurigma.ImageUploader.Messages.MaxFileSizeExceeded ASP.NET Property
  • Messages.MaxFileSizeExceeded PHP Property


messages.maxTotalFileSizeExceeded Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the total size of selected files is too large.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        maxTotalFileSizeExceeded: "The file '[name]' cannot be selected. Total upload data size exceeds the limit.",
        //...other params...
    }
})

Property Value

Type: String

The message which states that the total size of selected files is too large (i.e. exceeds the maxTotalFileSize value). To disable this message, set it to an empty string. It can contain the following placeholder:

[name]
replaced by the name of the file which cannot be added.

Default value is "The file '[name]' cannot be selected. Total upload data size exceeds the limit.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • maxTotalFileSize Property
  • Aurigma.ImageUploader.Messages.MaxTotalFileSizeExceeded ASP.NET Property
  • Messages.MaxTotalFileSizeExceeded PHP Property


messages.noResponseFromServer Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that an error was encountered when sending a request to the server and the server did not return any response.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        noResponseFromServer: "No response from server.",
        //...other params...
    }
})

Property Value

Type: String

The message which states that an error was encountered when sending a request to the server and the server did not return any response. To disable this message, set it to an empty string.

Default value is "No response from server.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.NoResponseFromServer ASP.NET Property
  • Messages.NoResponseFromServer PHP Property


messages.serverNotFound Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the server, specified in the uploadSettings.actionUrl parameter cannot be found.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        serverNotFound: "The server or proxy [name] cannot be found.",
        //...other params...
    }
})

Property Value

Type: String

The message which states that the server, specified in the actionUrl parameter cannot be found (e.g. the name of this server is misspelled or the server is down). To disable this message, set it to empty string. It can contain the following placeholder:

[name]
replaced by the name of the server which cannot be reached (as specified in the actionUrl parameter).

Default value is "The server or proxy [name] cannot be found.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • actionUrl Property
  • Aurigma.ImageUploader.Messages.ServerNotFound ASP.NET Property
  • Messages.ServerNotFound PHP Property


messages.unexpectedError Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a user-friendly message for errors which are meaningful to website developer only.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        unexpectedError: "Image Uploader encountered some problem. If you see this message, contact web master.",
        //...other params...
    }
})

Property Value

Type: String

The user-friendly error message. To disable this message, set it to an empty string.

Default value is "Image Uploader encountered some problem. If you see this message, contact web master.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.UnexpectedError ASP.NET Property
  • Messages.UnexpectedError PHP Property


messages.uploadCancelled Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that a user cancelled the upload.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        uploadCancelled: "Upload is cancelled.",
        //...other params...
    }
})

Property Value

Type: String

The message which states that a user cancelled the upload. To disable this message, set it to an empty string.

Default value is "Upload is cancelled.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.UploadCancelled ASP.NET Property
  • Messages.UploadCancelled PHP Property


messages.uploadCompleted Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which notifies that the upload is successfully finished.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        uploadCompleted: "Upload complete.",
        //...other params...
    }
})

Property Value

Type: String

The message which notifies that the upload is successfully finished. To disable this message, set it to an empty string.

Default value is "Upload complete.".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.UploadCompleted ASP.NET Property
  • Messages.UploadCompleted PHP Property


messages.uploadFailed Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a message which states that the upload failed because the connection was broken.

Syntax

JavaScript

Initialize

$au.uploader({
    messages: {
        //...other params...
        uploadFailed: "Upload failed (the connection was interrupted).",
        //...other params...
    }
})

Property Value

Type: String

The message stating that the upload failed because the connection was broken. To disable this message, set it to an empty string.

Default value is "Upload failed (the connection was interrupted).".

Remarks

Typically this error occurs when timeout expires (either server-side or client-side).

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Messages.UploadFailed ASP.NET Property
  • Messages.UploadFailed PHP Property


metadata Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a name-value collection of additional upload data.

For a list of all members of this class, see metadata Members.

Syntax

JavaScript

$au.metadata = function() {
}

See Also

Reference

  • metadata Property
  • Aurigma.ImageUploader.Metadata ASP.NET Class
  • Metadata PHP Class


metadata Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The metadata type exposes the following members.

Methods

 | Name | Description
Public method | addCookie(String) | Adds the specified cookie to the upload request.
Public method | addCustomField(String,String,Boolean) | Adds a custom field to the collection.
Public method | enableAllStandardFields(Boolean) | Enables or disables all the standard POST fields.
Public method | enableStandardField(String,Boolean) | Enables or disables the specified standard POST field.
Public method | removeCustomField(String) | Removes a custom field with the specified name.
Public method | renameStandardField(String,String) | Renames the specified standard POST field.
Public method | resetCookie | Removes all the cookies previously added to the request by the addCookie(String) method.

Properties

 | Name | Description
Public property | additionalFormName | Gets or sets a name or ID of the HTML form with additional information which should be sent to the server along with files.
Public property | exif | Gets or sets a list of EXIF fields which should be extracted and uploaded along with other data.
Public property | hash | Gets or sets an algorithm to generate a hash value for each user-selected file.
Public property | iptc | Gets or sets a list of IPTC fields which should be extracted and uploaded along with other data.
Public property | userAgent | Gets or sets a user-agent string.
Public property | valueSeparator | Gets or sets a sequence of characters used to separate strings stored in one metadata field (such as IptcKeyword).


metadata Methods

  • Methods
  • Language Filter ( all languages )

The metadata type exposes the following methods.

Methods

 | Name | Description
Public method | addCookie(String) | Adds the specified cookie to the upload request.
Public method | addCustomField(String,String,Boolean) | Adds a custom field to the collection.
Public method | enableAllStandardFields(Boolean) | Enables or disables all the standard POST fields.
Public method | enableStandardField(String,Boolean) | Enables or disables the specified standard POST field.
Public method | removeCustomField(String) | Removes a custom field with the specified name.
Public method | renameStandardField(String,String) | Renames the specified standard POST field.
Public method | resetCookie | Removes all the cookies previously added to the request by the addCookie(String) method.


metadata.addCookie(String) Method

  • Supported browsers: Firefox Google Chrome Safari

Adds the specified cookie to the upload request.

Syntax

JavaScript

$au.uploader('uploaderID').metadata().addCookie(cookie);

Parameters

cookie

Type: String

The cookie string to attach it to the upload request.

Remarks

Most browsers, such as Firefox since version 2.0.0.5 support HTTP-only cookies. They make it impossible to read these cookies using JavaScript. It increases security and prevents your site from cross-site scripting attacks.

When Image Uploader prepares the POST request before uploading it to the server, it extracts all cookies which are downloaded along with the page that hosts Image Uploader. To get cookie, Image Uploader uses the same object model as you do in JavaScript (as if you use document.cookie). However, the browser does not allow Image Uploader to get HTTP-only cookies. That is why when you post files to the server, it does not get such cookies.

Note

Image Uploader ASP.NET and Image Uploader PHP automatically pass the session and authentication information to the upload request.

However, if Image Uploader JavaScript is used, you should add cookies to the upload request manually. To do it, add each cookie you need to preserver via this method as it is shown below.

Use the resetCookie() method to remove cookies previously added by this method.

Example

Preserving cookies in ASP.NET:

JavaScript

function beforeUploadHandler(){
    var u = $au.uploader('Uploader1');
    u.metadata().addCookie('ASP.NET_SessionId=<%=Page.Session.SessionID%>');
    u.metadata().addCookie('<%=FormsAuthentication.FormsCookieName%>=' +
        '<%=Request.Cookies[FormsAuthentication.FormsCookieName].Value %>');
};

var u = $au.uploader({
    id: 'Uploader1',
    events: { beforeUpload: beforeUploadHandler}
});

u.writeHtml();

Preserving cookies in PHP:

JavaScript

function beforeUploadHandler(){
    var u = $au.uploader('Uploader1');
    u.metadata().addCookie('PHPSESSID=<?=$_COOKIE["PHPSESSID"]?>');
};

var u = $au.uploader({
    id: 'Uploader1',
    events: {beforeUpload: beforeUploadHandler},
});
u.writeHtml();

See Also

Reference

  • resetCookie() Method

Manual

  • Maintaining Sessions and Authentication in ASP.NET
  • Maintaining Sessions and Authentication in PHP


metadata.addCustomField(String,String,Boolean) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Adds a custom field to the collection.

Syntax

JavaScript

$au.uploader('uploaderID').metadata().addCustomField(name, value, add);

Parameters

name

Type: String

The custom field name.

value

Type: String

The value to add.

add

Type: Boolean

The value specifying how to handle a situation when a field with the given name is already added to the POST requst. If true, the previously added value will be preserved and a new field with the same name will be added. Otherwise, this value will be overwritten.


metadata.enableAllStandardFields(Boolean) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Enables or disables all the standard POST fields.

Syntax

JavaScript

$au.uploader('uploaderID').metadata().enableAllStandardFields(enable);

Parameters

enable

Type: Boolean

If true, all the standard POST fields are uploaded; otherwise, no standard fields are sent to a server.

See Also

Manual

  • POST Field Reference


metadata.enableStandardField(String,Boolean) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Enables or disables the specified standard POST field.

Syntax

JavaScript

$au.uploader('uploaderID').metadata().enableStandardField(name, enable);

Parameters

name

Type: String

The name of the standard POST field to enable/disable.

enable

Type: Boolean

If true, the specified standard POST field is uploaded; otherwise, this filed in not send to a server.

Remarks

The name parameter can contain particular indices or use the following placeholders:

[itemIndex]

Current index of the file.

JavaScript

u.metadata().enableStandardField("Tag_[itemIndex]", false);
[converterIndex]

Current index of the converted file.

JavaScript

u.metadata().enableStandardField("File[converterIndex]Size_[itemIndex]", false);

See Also

Manual

  • POST Field Reference


metadata.removeCustomField(String) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Removes a custom field with the specified name.

Syntax

JavaScript

$au.uploader('uploaderID').metadata().removeCustomField(name);

Parameters

name

Type: String

The custom field name.


metadata.renameStandardField(String,String) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Renames the specified standard POST field.

Syntax

JavaScript

$au.uploader('uploaderID').metadata().renameStandardField(originalName, newName);

Parameters

originalName

Type: String

The name of the standard POST field to rename.

newName

Type: String

The new fields name.

Remarks

Both originalName and newName parameters can contain particular indices or use the following placeholders:

[itemIndex]

Current index of the file.

JavaScript

u.metadata().renameStandardField("Description_[itemIndex]", "MyDescription_[itemIndex]");
[converterIndex]

Current index of the converted file.

JavaScript

u.metadata().renameStandardField("File[converterIndex]Mode_[itemIndex]", "MyFile[converterIndex]Mode_[itemIndex]");
[tagName]

Name of the extracted EXIF of IPTC field.

JavaScript

u.metadata().renameStandardField("[tagName]_[itemIndex]", "My[tagName]_[itemIndex]");

See Also

Manual

  • POST Field Reference
  • Configuring POST Format


metadata.resetCookie Method

  • Supported browsers: Firefox Google Chrome Safari

Removes all the cookies previously added to the request by the addCookie(String) method.

Syntax

JavaScript

$au.uploader('uploaderID').metadata().resetCookie();

See Also

Reference

  • addCookie(String) Method


metadata Properties

  • Properties
  • Language Filter ( all languages )

The metadata type exposes the following properties.

Properties

 | Name | Description
Public property | additionalFormName | Gets or sets a name or ID of the HTML form with additional information which should be sent to the server along with files.
Public property | exif | Gets or sets a list of EXIF fields which should be extracted and uploaded along with other data.
Public property | hash | Gets or sets an algorithm to generate a hash value for each user-selected file.
Public property | iptc | Gets or sets a list of IPTC fields which should be extracted and uploaded along with other data.
Public property | userAgent | Gets or sets a user-agent string.
Public property | valueSeparator | Gets or sets a sequence of characters used to separate strings stored in one metadata field (such as IptcKeyword).


metadata.additionalFormName Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a name or ID of the HTML form with additional information which should be sent to the server along with files.

Syntax

JavaScript

Initialize

$au.uploader({
    metadata: {
        //...other params...
        additionalFormName: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').metadata().additionalFormName(value);
value = $au.uploader('uploaderID').metadata().additionalFormName();

Property Value

Type: String

The name or ID for the form you need to submit along with files. If this value is an empty string or an invalid form name (which does not exist on this page), no additional form is sent.

Default value is "".

Remarks

The additional form may contain the following elements:

  • Input fields (except of <input type="image"> and <input type="file">).
  • Text areas.
  • Select elements.
Note

The additional form must be placed into the same frame with the uploader.

See Also

Reference

  • Aurigma.ImageUploader.Metadata.AdditionalFormName ASP.NET Property
  • Metadata.AdditionalFormName PHP Property


metadata.exif Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of EXIF fields which should be extracted and uploaded along with other data.

Syntax

JavaScript

Initialize

$au.uploader({
    metadata: {
        //...other params...
        exif: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').metadata().exif(value);
value = $au.uploader('uploaderID').metadata().exif();

Property Value

Type: String

The string containing EXIF field names which you want to extract separated with a semicolon.

You will find possible names of EXIF fields in the table below.

Field name | Description
ExifApertureValue | The lens aperture (in APEX units).
ExifArtist | The name of photographer or image creator.
ExifBitsPerSample | The number of bits per image component.
ExifBrightnessValue | The brightness value (in APEX units).
ExifCFAPattern | The color filter pattern.
ExifColorSpace | The color space of the image.
ExifComponentsConfiguration | The order of pixel channels (components).
ExifCompressedBitsPerPixel | The number of bits per pixel in the compressed image.
ExifCompression | The compression type.
ExifContrast | The contrast settings applied when images was captured.
ExifCopyright | The copyright information.
ExifCustomRendered | Value that indicates that special processing was applied to the image.
ExifDateTime | The date and time of image creation.
ExifDateTimeDigitized | The date and time when the image was converted into digital representation.
ExifDateTimeOriginal | The date and time when the original file was created.
ExifDeviceSettingDescription | The description of the image capturing device settings.
ExifDigitalZoomRatio | The digital zoom ratio.
ExifExifVersion | The version of the EXIF specification this data is stored at.
ExifExposureBiasValue | The exposure bias (in APEX units).
ExifExposureIndex | The exposure index of the device when image is being captured.
ExifExposureMode | The exposure mode.
ExifExposureProgram | The exposure program.
ExifExposureTime | The exposure time (in seconds).
ExifFileSource | The image source.
ExifFlash | The flash status.
ExifFlashEnergy | The flash energy (in BCPS).
ExifFlashPixVersion | The version of FlashPix format.
ExifFNumber | The F number.
ExifFocalLength | The focal length of the lens (in millimeters).
ExifFocalLengthIn35mmFilm | The focal length of the lens assuming 35mm film camera is used (in millimeters).
ExifFocalPlaneResolutionUnit | The unit to measure focal plane resolution with (i.e. ExifFocalPlaneXResolution and ExifFocalPlaneYResolution).
ExifFocalPlaneXResolution | The horizontal resolution of the camera focal plane.
ExifFocalPlaneYResolution | The vertical resolution of the camera focal plane.
ExifGainControl | The overall image gain adjustment.
ExifGpsAltitude | The altitude.
ExifGpsAltitudeRef | The altitude reference.
ExifGpsAreaInformation | The name of GPS area.
ExifGpsDateStamp | The GPS datestamp.
ExifGpsDestBearing | The bearing to the destination point (in degrees).
ExifGpsDestBearingRef | The reference for giving the bearing to the destination point.
ExifGpsDestDistance | The distance to the destination point.
ExifGpsDestDistanceRef | The unit for distance to the destination point.
ExifGpsDestLatitude | The destination point latitude.
ExifGpsDestLatitudeRef | The destination point latitude reference (north or south).
ExifGpsDestLongitude | The destination point longitude.
ExifGpsDestLongitudeRef | The destination point longitude reference (west or east).
ExifGpsDifferential | The GPS differential correction.
ExifGpsDOP | The GPS data degree of precision.
ExifGpsImgDirection | The direction of the image when it was captured (in degrees).
ExifGpsImgDirectionRef | The reference for giving the direction of the image when it was captured.
ExifGpsLatitude | The latitude.
ExifGpsLatitudeRef | The latitude reference (north or south).
ExifGpsLongitude | The longitude.
ExifGpsLongitudeRef | The longitude reference (west or east).
ExifGpsMapDatum | The geodetic survey data.
ExifGpsMeasureMode | The GPS measurement mode.
ExifGpsProcessingMethod | The name of GPS processing method.
ExifGpsSatellites | The details about GPS satellites used in measurement.
ExifGpsSpeed | The speed of the GPS receiver movement.
ExifGpsSpeedRef | The Unit for speed of movement of GPS receiver.
ExifGpsStatus | The status of GPS receiver when image was recorded.
ExifGpsTimeStamp | The GPS timestamp (in UTC).
ExifGpsTrack | The direction of GPS receiver movement (in degrees).
ExifGpsTrackRef | The reference for giving the direction of GPS receiver movement.
ExifGpsVersionID | The version of the GPSVersionID tag.
ExifImageDescription | The title of the image.
ExifImageHeight | The height of the image in pixels.
ExifImageUniqueID | The 128-bit unique ID of the image.
ExifImageWidth | The width of the image in pixels.
ExifInteroperabilityIndex | The index of interoperability rule.
ExifISOSpeedRatings | The ISO speed and the ISO latitude of the device.
ExifLightSource | The light source.
ExifMake | The name of manufacturer of the camera (or other recording equipment).
ExifMakerNote | The custom comments. May contain any information maker want to store.
ExifMaxApertureValue | The smallest F of the lens (in APEX units).
ExifMeteringMode | The metering mode.
ExifModel | The name of the model of the camera (or other recording equipment).
ExifOECF | The opto-electronic conversion function.
ExifOrientation | The orientation of image (how it is rotated relative to the top left corner).
ExifPhotometricInterpretation | The pixel composition.
ExifPixelXDimension | The valid width of the meaningful image.
ExifPixelYDimension | The valid height of the meaningful image.
ExifPlanarConfiguration | The planar configuration of the pixel components (planar or chunky).
ExifPrimaryChromaticities | The chromaticity of the three primary colors of the image.
ExifReferenceBlackWhite | The reference for black and white point of the image.
ExifRelatedSoundFile | The name of an audio file associated with this image.
ExifResolutionUnit | The unit image resolution is measured in (i.e. ExifXResolution and ExifYResolution).
ExifRowsPerStrip | Rows per strip (if image is divided into strips).
ExifSamplesPerPixel | The number of components (channels) in one pixel.
ExifSaturation | The saturation settings applied when images was captured.
ExifSceneCaptureType | The type of scene was captured by camera (landscape, night scene, portrait, etc).
ExifSceneType | The type of scene.
ExifSensingMethod | The sensor type of the device.
ExifSharpness | The sharpness settings applied when images was captured.
ExifShutterSpeed | The shutter speed (in APEX units).
ExifSoftware | The name of the software that created this image.
ExifSpatialFrequencyResponse | The spatial frequency response values.
ExifSpectralSensitivity | The spectral sensitivity.
ExifStripByteCounts | The total number of bytes in one strip.
ExifStripOffsets | The bitmap stride (byte offset between strips).
ExifSubjectArea | The subject area.
ExifSubjectDistance | The distance to the subject (in meters).
ExifSubjectDistanceRange | The kind of distance to the subject (macro, close, or distant).
ExifSubjectLocation | The location of the main subject in the scene.
ExifSubSecTime | The fractions of seconds for the ExifDateTime field.
ExifSubSecTimeDigitized | The fractions of seconds for the ExifDateTimeDigitized field.
ExifSubSecTimeOriginal | The fractions of seconds for the ExifDateTimeOriginal field.
ExifThumbnailBitsPerSample | The number of bits per channel in the thumbnail.
ExifThumbnailCompression | The compression type of the thumbnail.
ExifThumbnailHeight | The height of the thumbnail in pixel.
ExifThumbnailOrientation | The orientation of the thumbnail (how it is rotated relative to the top left corner).
ExifThumbnailPhotometricInterpretation | The pixel composition of the thumbnail.
ExifThumbnailResolutionUnit | The unit thumbnail resolution is measured in (i.e.ExifThumbnailXResolution and ExifThumbnailYResolution).
ExifThumbnailRowsPerStrip | Rows per strip in the thumbnail (if thumbnail is divided into strips).
ExifThumbnailSamplesPerPixel | The number of components (channels) in one pixel of the thumbnail.
ExifThumbnailStripByteCounts | The total number of bytes in one strip of the thumbnail.
ExifThumbnailStripOffsets | The thumbnail stride (byte offset between strips).
ExifThumbnailWidth | The width of the thumbnail in pixels.
ExifThumbnailXResolution | The horizontal resolution of the thumbnail.
ExifThumbnailYResolution | The vertical resolution of the thumbnail.
ExifTransferFunction | The transfer function in tabular form.
ExifUserComment | The additional comments or keywords on the image available for users.
ExifWhiteBalance | The mode of the white balance when the image was captured.
ExifWhitePoint | The white point of the image.
ExifXResolution | The horizontal resolution of the image.
ExifYCbCrCoefficients | The coefficients used during the transformation between RGB and YCbCr colorspaces.
ExifYCbCrPositioning | The position of chrominance components relative to the luminosity component.
ExifYCbCrSubSampling | Sampling ratio of the chrominance components relative to the luminosity component.
ExifYResolution | The vertical resolution of the image.

All date/time values have the following format: YYYY:MM:DD hh:mm:ss. E.g. 11th of May 2006, 2:40PM would be represented as: 2006:05:11 14:40:00.

For more details regarding interpretation of these values, refer to the EXIF specification.

Default value is "".

Remarks

To get an uploaded EXIF value at the server, you should extract POST field which is named in the following way: XXX_N, where XXX is a string value specified in this property (EXIF field name), and N is the index of the file in the request. E.g. if the property value is ExifDateTime;ExifOrientation;ExifModel, you will get the following POST fields:

  • ExifDateTime_1, ExifDateTime_2, etc.
  • ExifOrientation_1, ExifOrientation_2, etc.
  • ExifModel_1, ExifModel_2, etc.

If you prefer to extract EXIF fields on the server, you can get them from the original file, or specify to preserve EXIF fields in the thumbnails you are going to upload. To do it, use the thumbnailCopyExif property.

See Also

Reference

  • Aurigma.ImageUploader.Metadata.Exif ASP.NET Property
  • Metadata.Exif PHP Property


metadata.hash Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an algorithm to generate a hash value for each user-selected file.

Syntax

JavaScript

Initialize

$au.uploader({
    metadata: {
        //...other params...
        hash: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').metadata().hash(value);
value = $au.uploader('uploaderID').metadata().hash();

Property Value

Type: String

The algorithm to generate a hash value for each user-selected file.

Possible values are listed in the table below.

Value | Description
SHA | SHA hash algorithm.
MD2 | MD2 hash algorithm.
MD5 | MD5 hash algorithm.

You can specify several hash algorithms separated by semicolon.

Default value is "".

Remarks

Note

Image Uploader Express does not upload hash sums. See the Comparison of Image Uploader Editions topic for details.

The hash is calculated only for the original file, not for converted files (even if the original file is not uploaded).

To get an uploaded hash sum at the server, you should extract POST field which is named in the following way: HashCodeXXX_N, where XXX is a string value specified in this property (hash algorithm), and N is the index of the file in the request. E.g. if the property value is MD5;SHA, you will get the following POST fields:

  • HashCodeMD5_1, HashCodeMD5_2, etc.
  • HashCodeSHA_1, HashCodeSHA_2, etc.
Note

Hash calculation is quite resource-intensive operation. That is why if you need not verify uploaded files on the server, it makes sense to disable this feature to make Image Uploader faster. To do it, just specify empty string in this property.

See Also

Reference

  • Aurigma.ImageUploader.Metadata.Hash ASP.NET Property
  • Metadata.Hash PHP Property


metadata.iptc Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of IPTC fields which should be extracted and uploaded along with other data.

Syntax

JavaScript

Initialize

$au.uploader({
    metadata: {
        //...other params...
        iptc: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').metadata().iptc(value);
value = $au.uploader('uploaderID').metadata().iptc();

Property Value

Type: String

The string containing IPTC field names which you want to extract, separated with a semicolon.

You will find possible names of IPTC fields in the table below.

Field name | Description
IptcByline | The name of the creator of the image, e.g. artist, photographer, etc.
IptcBylineTitle | The byline title (e.g. staff photographer, correspondent, etc).
IptcCredit | The provider of the image.
IptcSource | The original owner of the intellectual content of this image.
IptcObjectName | The short reference for the object.
IptcDateCreated | The date the image (as an intellectual content, rather than physical file) created.
IptcCity | The city of the image origin.
IptcState | The state/province of the image origin.
IptcCountry | The country of the image origin.
IptcOriginalTransmissionReference | The location of the original transmission.
IptcCopyrightNotice | The copyright notice.
IptcCaption | The textual description of the image.
IptcWriter | The name of editor or other person involved in the writing.
IptcHeadline | The brief overview for the image.
IptcSpecialInstructions | Some custom editorial instructions.
IptcCategory | The image category.
IptcSupplementaryCategory | The supplementary category for the image.
IptcUrgency | The editorial urgency of the content.
IptcKeyword | The keywords used for search.

All date values have the following format: YYYYMMDD. E.g. 11th of May 2006 would be represented as: 20060511.

For more information about interpretation of these values, refer to IPTC specification (version 4.1 is currently supported).

Default value is "".

Remarks

To get an uploaded IPTC value at the server, you should extract POST field which is named in the following way: XXX_N, where XXX is a string value specified in this property (IPTC field name), and N is the index of the file in the request. E.g. if the property value is IptcCountry;IptcCity;IptcObjectName, you will get the following POST fields:

  • IptcCountry_1, IptcCountry_2, etc.
  • IptcCity_1, IptcCity_2, etc.
  • IptcObjectName_1, IptcObjectName_2, etc.

If you prefer to extract IPTC fields on the server, you can get them from the original file, or specify to preserve IPTC fields in the thumbnails you are going to upload. To do it, use the thumbnailCopyIptc property.

See Also

Reference

  • Aurigma.ImageUploader.Metadata.Iptc ASP.NET Property
  • Metadata.Iptc PHP Property


metadata.userAgent Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a user-agent string.

Syntax

JavaScript

Initialize

$au.uploader({
    metadata: {
        //...other params...
        userAgent: navigator.userAgent,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').metadata().userAgent(value);
value = $au.uploader('uploaderID').metadata().userAgent();

Property Value

Type: String

The user-agent string which is sent by Image Uploader in the header of the upload request.

Default value is navigator.userAgent.

Remarks

Note

During initialization, this value is set to the user-agent string of a browser which hosts Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Metadata.UserAgent ASP.NET Property
  • Metadata.UserAgent PHP Property


metadata.valueSeparator Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a sequence of characters used to separate strings stored in one metadata field (such as IptcKeyword).

Syntax

JavaScript

Initialize

$au.uploader({
    metadata: {
        //...other params...
        valueSeparator: " ",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').metadata().valueSeparator(value);
value = $au.uploader('uploaderID').metadata().valueSeparator();

Property Value

Type: String

The sequence of characters used to separate strings stored in one metadata field.

Default value is " ".

Remarks

Some metadata fields like IptcKeyword can contain multiple string values. Suppose you upload an image which contains several keywords: portrait, old photo, black and white. All these keywords are stored in one IptcKeyword field. So, if you specified this field for upload (using the iptc property) the IptcKeyword_0 POST field will contain all these keywords gathered into one string separated with this property value. For example, if you set it to the ";" you will get the "portrait;old photo;black and white" POST field value.

See Also

Reference

  • Aurigma.ImageUploader.Metadata.ValueSeparator ASP.NET Property
  • Metadata.ValueSeparator PHP Property


paneItem Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a pane item displayed in both the upload and folder panes.

For a list of all members of this class, see paneItem Members.

Syntax

JavaScript

$au.paneItem = function() {
}

See Also

Reference

  • paneItem Property
  • Aurigma.ImageUploader.PaneItem ASP.NET Class
  • PaneItem PHP Class

Manual

  • Additional Controls and Indicators
  • Customizing Appearance


paneItem Members

  • Properties
  • Language Filter ( all languages )

The paneItem type exposes the following members.

Properties

 | Name | Description
Public property | descriptionAddedIconImageFormat | Gets or sets a list of images that are displayed in different states of the description added icon.
Public property | descriptionEditorIconImageFormat | Gets or sets a list of images that are displayed in different states of the description editor icon.
Public property | descriptionEditorIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the description editor icon.
Public property | enableDisproportionalExifThumbnails | Get or sets a value indicating whether Image Uploader should generate a preview thumbnail from the original image in the case when thumbnail saved in EXIF metadata is out of proportions of original image.
Public property | enableFileNameTooltip | Get or sets a value indicating whether a tooltip containing a filename should be displayed when the mouse pointer hovers over the pane item.
Public property | hoverBorderColor | Gets or sets a color of the pane item border when the mouse pointer hovers over it.
Public property | hoverColor | Gets or sets a color of the pane item when the mouse pointer hovers over it.
Public property | imageCroppedIconImageFormat | Gets or sets a list of images that are displayed in different states of the image cropped icon.
Public property | imageCroppedIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image cropped icon.
Public property | imageEditorIconImageFormat | Gets or sets a list of images that are displayed in different states of the image editor icon.
Public property | imageEditorIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image editor icon.
Public property | inactiveSelectionBorderColor | Gets or sets a color of the pane item border when it is selected and not in focus.
Public property | inactiveSelectionColor | Gets or sets a color of the pane item when it is selected and not in focus.
Public property | previewQuality | Gets or sets a resize quality of preview thumbnails.
Public property | qualityMeter | Gets or sets the quality meter settings.
Public property | removalIconImageFormat | Gets or sets a list of images that are displayed in different states of the removal icon.
Public property | removalIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the removal icon.
Public property | rotationIconImageFormat | Gets or sets a list of images that are displayed in different states of the rotation icon.
Public property | rotationIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the rotation icon.
Public property | selectedTextColor | Gets or sets a color of the pane item text when it is selected.
Public property | selectionBorderColor | Gets or sets a color of the pane item border when it is selected.
Public property | selectionColor | Gets or sets a color of the pane item when it is selected.
Public property | selectionHoverBorderColor | Gets or sets a color of the pane item border when it is selected and the mouse pointer hovers over it.
Public property | selectionHoverColor | Gets or sets a color of the pane item when it is selected and the mouse pointer hovers over it.
Public property | showFileNameInThumbnailsView | Gets or sets a value indicating whether to display filenames in the Thumbnails view.


paneItem Properties

  • Properties
  • Language Filter ( all languages )

The paneItem type exposes the following properties.

Properties

 | Name | Description
Public property | descriptionAddedIconImageFormat | Gets or sets a list of images that are displayed in different states of the description added icon.
Public property | descriptionEditorIconImageFormat | Gets or sets a list of images that are displayed in different states of the description editor icon.
Public property | descriptionEditorIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the description editor icon.
Public property | enableDisproportionalExifThumbnails | Get or sets a value indicating whether Image Uploader should generate a preview thumbnail from the original image in the case when thumbnail saved in EXIF metadata is out of proportions of original image.
Public property | enableFileNameTooltip | Get or sets a value indicating whether a tooltip containing a filename should be displayed when the mouse pointer hovers over the pane item.
Public property | hoverBorderColor | Gets or sets a color of the pane item border when the mouse pointer hovers over it.
Public property | hoverColor | Gets or sets a color of the pane item when the mouse pointer hovers over it.
Public property | imageCroppedIconImageFormat | Gets or sets a list of images that are displayed in different states of the image cropped icon.
Public property | imageCroppedIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image cropped icon.
Public property | imageEditorIconImageFormat | Gets or sets a list of images that are displayed in different states of the image editor icon.
Public property | imageEditorIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image editor icon.
Public property | inactiveSelectionBorderColor | Gets or sets a color of the pane item border when it is selected and not in focus.
Public property | inactiveSelectionColor | Gets or sets a color of the pane item when it is selected and not in focus.
Public property | previewQuality | Gets or sets a resize quality of preview thumbnails.
Public property | qualityMeter | Gets or sets the quality meter settings.
Public property | removalIconImageFormat | Gets or sets a list of images that are displayed in different states of the removal icon.
Public property | removalIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the removal icon.
Public property | rotationIconImageFormat | Gets or sets a list of images that are displayed in different states of the rotation icon.
Public property | rotationIconTooltip | Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the rotation icon.
Public property | selectedTextColor | Gets or sets a color of the pane item text when it is selected.
Public property | selectionBorderColor | Gets or sets a color of the pane item border when it is selected.
Public property | selectionColor | Gets or sets a color of the pane item when it is selected.
Public property | selectionHoverBorderColor | Gets or sets a color of the pane item border when it is selected and the mouse pointer hovers over it.
Public property | selectionHoverColor | Gets or sets a color of the pane item when it is selected and the mouse pointer hovers over it.
Public property | showFileNameInThumbnailsView | Gets or sets a value indicating whether to display filenames in the Thumbnails view.


paneItem.descriptionAddedIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the description added icon.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        descriptionAddedIconImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().descriptionAddedIconImageFormat(value);
value = $au.uploader('uploaderID').paneItem().descriptionAddedIconImageFormat();

Property Value

Type: String

The list of custom images of the description added icon.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.DescriptionAddedIconImageFormat ASP.NET Property
  • PaneItem.DescriptionAddedIconImageFormat PHP Property


paneItem.descriptionEditorIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the description editor icon.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        descriptionEditorIconImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().descriptionEditorIconImageFormat(value);
value = $au.uploader('uploaderID').paneItem().descriptionEditorIconImageFormat();

Property Value

Type: String

The list of custom images of the description editor icon.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.DescriptionEditorIconImageFormat ASP.NET Property
  • PaneItem.DescriptionEditorIconImageFormat PHP Property


paneItem.descriptionEditorIconTooltip Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the description editor icon.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        descriptionEditorIconTooltip: "Edit description",
        //...other params...
    }
})

Property Value

Type: String

The text of the tooltip which is displayed when the mouse pointer hovers over the description editor icon.

Default value is "Edit description".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.DescriptionEditorIconTooltip ASP.NET Property
  • PaneItem.DescriptionEditorIconTooltip PHP Property


paneItem.enableDisproportionalExifThumbnails Property

  • Supported browsers: Firefox Google Chrome Safari

Get or sets a value indicating whether Image Uploader should generate a preview thumbnail from the original image in the case when thumbnail saved in EXIF metadata is out of proportions of original image.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        enableDisproportionalExifThumbnails: true,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().enableDisproportionalExifThumbnails(value);
value = $au.uploader('uploaderID').paneItem().enableDisproportionalExifThumbnails();

Property Value

Type: Boolean

If true Image Uploader displays disproportional EXIF thumbnails in the list, otherwise the control resizes original image to the thumbnail size.

Default value is true.

Remarks

Note

This property takes effect in the Thumbnails, Tiles, and List views only.

To accelerate folder navigation Image Uploader supports displaying EXIF thumbnails in the folder and upload panes when the Thumbnails, Tiles, or List view mode is set. Such thumbnails are created by the most of cameras and stored along with image data. However, some cameras may create EXIF thumbnails which are out of proportions of original images. If so disproportional thumbnails will have black stripes above and below them. In this case you can set this property to false to regenerate preview thumbnails from original images and get rid of black stripes or specify a true value to display disproportional thumbnails instead.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.EnableDisproportionalExifThumbnails ASP.NET Property
  • PaneItem.EnableDisproportionalExifThumbnails PHP Property


paneItem.enableFileNameTooltip Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Get or sets a value indicating whether a tooltip containing a filename should be displayed when the mouse pointer hovers over the pane item.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        enableFileNameTooltip: false,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().enableFileNameTooltip(value);
value = $au.uploader('uploaderID').paneItem().enableFileNameTooltip();

Property Value

Type: Boolean

If true filename tooltip is displayed when the mouse pointer hovers over the pane item.

Default value is false.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.EnableFileNameTooltip ASP.NET Property
  • PaneItem.EnableFileNameTooltip PHP Property


paneItem.hoverBorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item border when the mouse pointer hovers over it.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        hoverBorderColor: "#99DEFD",
        //...other params...
    }
})

Property Value

Type: String

The color of the pane item border when the mouse pointer hovers over it.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#99DEFD".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.HoverBorderColor ASP.NET Property
  • PaneItem.HoverBorderColor PHP Property


paneItem.hoverColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item when the mouse pointer hovers over it.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        hoverColor: "#F5FAFD;#EDF8FE",
        //...other params...
    }
})

Property Value

Type: String

The color of the pane item when the mouse pointer hovers over it.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is "#F5FAFD;#EDF8FE".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.HoverColor ASP.NET Property
  • PaneItem.HoverColor PHP Property


paneItem.imageCroppedIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the image cropped icon.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        imageCroppedIconImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().imageCroppedIconImageFormat(value);
value = $au.uploader('uploaderID').paneItem().imageCroppedIconImageFormat();

Property Value

Type: String

The list of custom images of the image cropped icon.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.ImageCroppedIconImageFormat ASP.NET Property
  • PaneItem.ImageCroppedIconImageFormat PHP Property


paneItem.imageCroppedIconTooltip Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image cropped icon.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        imageCroppedIconTooltip: "The image is cropped.",
        //...other params...
    }
})

Property Value

Type: String

The text of the tooltip which is displayed when the mouse pointer hovers over the image cropped icon.

Default value is "The image is cropped.".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.ImageCroppedIconTooltip ASP.NET Property
  • PaneItem.ImageCroppedIconTooltip PHP Property


paneItem.imageEditorIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the image editor icon.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        imageEditorIconImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().imageEditorIconImageFormat(value);
value = $au.uploader('uploaderID').paneItem().imageEditorIconImageFormat();

Property Value

Type: String

The list of custom images of the image editor icon.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.ImageEditorIconImageFormat ASP.NET Property
  • PaneItem.ImageEditorIconImageFormat PHP Property


paneItem.imageEditorIconTooltip Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the image editor icon.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        imageEditorIconTooltip: "Preview / edit image",
        //...other params...
    }
})

Property Value

Type: String

The text of the tooltip which is displayed when the mouse pointer hovers over the image editor icon.

Default value is "Preview / edit image".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.ImageEditorIconTooltip ASP.NET Property
  • PaneItem.ImageEditorIconTooltip PHP Property


paneItem.inactiveSelectionBorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item border when it is selected and not in focus.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        inactiveSelectionBorderColor: "#D9D9D9",
        //...other params...
    }
})

Property Value

Type: String

The color of the pane item border when it is selected and not in focus.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#D9D9D9".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.InactiveSelectionBorderColor ASP.NET Property
  • PaneItem.InactiveSelectionBorderColor PHP Property


paneItem.inactiveSelectionColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item when it is selected and not in focus.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        inactiveSelectionColor: "#f8f8f8;#e5e5e5",
        //...other params...
    }
})

Property Value

Type: String

The color of the pane item when it is selected and not in focus.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is "#f8f8f8;#e5e5e5".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.InactiveSelectionColor ASP.NET Property
  • PaneItem.InactiveSelectionColor PHP Property


paneItem.previewQuality Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a resize quality of preview thumbnails.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        previewQuality: "Medium",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().previewQuality(value);
value = $au.uploader('uploaderID').paneItem().previewQuality();

Property Value

Type: String

The resize quality of preview thumbnails.

The following values are supported:

Value | Description
Low | Low quality. The image is resized using the nearest-neighbor algorithm.
Medium | Medium quality. The image is resized using the anisotropic algorithm.
High | High quality. The image is resized using the lanczos algorithm.

Default value is "Medium".

Remarks

Note

This property takes effect in the Thumbnails, Tiles, and List views only.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.PreviewQuality ASP.NET Property
  • PaneItem.PreviewQuality PHP Property


paneItem.qualityMeter Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the quality meter settings.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        qualityMeter: {},
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().qualityMeter(value);
value = $au.uploader('uploaderID').paneItem().qualityMeter();

Property Value

Type: $au.qualityMeter

The quality meter settings.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.QualityMeter ASP.NET Property
  • PaneItem.QualityMeter PHP Property

Manual

  • Using Quality Meter


paneItem.removalIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the removal icon.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        removalIconImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().removalIconImageFormat(value);
value = $au.uploader('uploaderID').paneItem().removalIconImageFormat();

Property Value

Type: String

The list of custom images of the removal icon.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.RemovalIconImageFormat ASP.NET Property
  • PaneItem.RemovalIconImageFormat PHP Property


paneItem.removalIconTooltip Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the removal icon.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        removalIconTooltip: "Remove",
        //...other params...
    }
})

Property Value

Type: String

The text of the tooltip which is displayed when the mouse pointer hovers over the removal icon.

Default value is "Remove".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.RemovalIconTooltip ASP.NET Property
  • PaneItem.RemovalIconTooltip PHP Property


paneItem.rotationIconImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the rotation icon.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        rotationIconImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().rotationIconImageFormat(value);
value = $au.uploader('uploaderID').paneItem().rotationIconImageFormat();

Property Value

Type: String

The list of custom images of the rotation icon.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.RotationIconImageFormat ASP.NET Property
  • PaneItem.RotationIconImageFormat PHP Property


paneItem.rotationIconTooltip Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the text of the tooltip which is displayed when the mouse pointer hovers over the rotation icon.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        rotationIconTooltip: "Rotate",
        //...other params...
    }
})

Property Value

Type: String

The text of the tooltip which is displayed when the mouse pointer hovers over the rotation icon.

Default value is "Rotate".

Remarks

If you specify an empty string, the tooltip does not appear.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.RotationIconTooltip ASP.NET Property
  • PaneItem.RotationIconTooltip PHP Property


paneItem.selectedTextColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item text when it is selected.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        selectedTextColor: "#000000",
        //...other params...
    }
})

Property Value

Type: String

The color of the pane item text when it is selected.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#000000".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.SelectedTextColor ASP.NET Property
  • PaneItem.SelectedTextColor PHP Property


paneItem.selectionBorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item border when it is selected.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        selectionBorderColor: "#99defd",
        //...other params...
    }
})

Property Value

Type: String

The color of the pane item border when it is selected.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#99defd".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.SelectionBorderColor ASP.NET Property
  • PaneItem.SelectionBorderColor PHP Property


paneItem.selectionColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item when it is selected.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        selectionColor: "#f0f8fd;#d5effc",
        //...other params...
    }
})

Property Value

Type: String

The color of the pane item when it is selected.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is "#f0f8fd;#d5effc".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.SelectionColor ASP.NET Property
  • PaneItem.SelectionColor PHP Property


paneItem.selectionHoverBorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item border when it is selected and the mouse pointer hovers over it.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        selectionHoverBorderColor: "#99defd",
        //...other params...
    }
})

Property Value

Type: String

The color of the pane item border when it is selected and the mouse pointer hovers over it.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#99defd".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.SelectionHoverBorderColor ASP.NET Property
  • PaneItem.SelectionHoverBorderColor PHP Property


paneItem.selectionHoverColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the pane item when it is selected and the mouse pointer hovers over it.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        selectionHoverColor: "#e8f6fd;#c4e8fa",
        //...other params...
    }
})

Property Value

Type: String

The color of the pane item when it is selected and the mouse pointer hovers over it.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is "#e8f6fd;#c4e8fa".

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.SelectionHoverColor ASP.NET Property
  • PaneItem.SelectionHoverColor PHP Property


paneItem.showFileNameInThumbnailsView Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to display filenames in the Thumbnails view.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem: {
        //...other params...
        showFileNameInThumbnailsView: false,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().showFileNameInThumbnailsView(value);
value = $au.uploader('uploaderID').paneItem().showFileNameInThumbnailsView();

Property Value

Type: Boolean

If true, filenames are displayed under thumbnails; otherwise, only thumbnails are shown.

Default value is false.

See Also

Reference

  • Aurigma.ImageUploader.PaneItem.ShowFileNameInThumbnailsView ASP.NET Property
  • PaneItem.ShowFileNameInThumbnailsView PHP Property


qualityMeter Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the quality meter.

For a list of all members of this class, see qualityMeter Members.

Syntax

JavaScript

$au.qualityMeter = function() {
}

Remarks

Note

Image Uploader Express and Professional disable quality meter functionality. See the Comparison of Image Uploader Editions topic for details.

See Also

Reference

  • qualityMeter Property
  • Aurigma.ImageUploader.QualityMeter ASP.NET Class
  • QualityMeter PHP Class

Manual

  • Additional Controls and Indicators
  • Using Quality Meter


qualityMeter Members

  • Properties
  • Language Filter ( all languages )

The qualityMeter type exposes the following members.

Properties

 | Name | Description
Public property | acceptableQualityColor | Gets or sets a color of the quality meter element which corresponds to the maximum acceptable print format
Public property | backgroundColor | Gets or sets a background color of the quality meter.
Public property | borderColor | Gets or sets a color of the quality meter border.
Public property | formats | Gets or sets print formats for the quality meter.
Public property | height | Gets or sets a height of each quality meter rectangle.
Public property | highQualityColor | Gets or sets a color of the quality meter element which corresponds to the recommended print format.
Public property | lowQualityColor | Gets or sets a color of the quality meter element corresponding to the print format which is not recommended for printing.


qualityMeter Properties

  • Properties
  • Language Filter ( all languages )

The qualityMeter type exposes the following properties.

Properties

 | Name | Description
Public property | acceptableQualityColor | Gets or sets a color of the quality meter element which corresponds to the maximum acceptable print format
Public property | backgroundColor | Gets or sets a background color of the quality meter.
Public property | borderColor | Gets or sets a color of the quality meter border.
Public property | formats | Gets or sets print formats for the quality meter.
Public property | height | Gets or sets a height of each quality meter rectangle.
Public property | highQualityColor | Gets or sets a color of the quality meter element which corresponds to the recommended print format.
Public property | lowQualityColor | Gets or sets a color of the quality meter element corresponding to the print format which is not recommended for printing.


qualityMeter.acceptableQualityColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the quality meter element which corresponds to the maximum acceptable print format

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem : {
        qualityMeter: {
            //...other params...
            acceptableQualityColor: "#ffc600",
            //...other params...
        }
    }
})

Property Value

Type: String

The color of the quality meter element for acceptable print formats.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#ffc600".

Remarks

The quality of the print in this format will be good enough, but worse than for allowed print formats that is specified with the highQualityColor.

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.AcceptableQualityColor ASP.NET Property
  • QualityMeter.AcceptableQualityColor PHP Property


qualityMeter.backgroundColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of the quality meter.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem : {
        qualityMeter: {
            //...other params...
            backgroundColor: "#ffffff",
            //...other params...
        }
    }
})

Property Value

Type: String

The background color of the quality meter.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#ffffff".

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.BackgroundColor ASP.NET Property
  • QualityMeter.BackgroundColor PHP Property


qualityMeter.borderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the quality meter border.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem : {
        qualityMeter: {
            //...other params...
            borderColor: "#154575",
            //...other params...
        }
    }
})

Property Value

Type: String

The color of the quality meter border.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#154575".

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.BorderColor ASP.NET Property
  • QualityMeter.BorderColor PHP Property


qualityMeter.formats Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets print formats for the quality meter.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem : {
        qualityMeter: {
            //...other params...
            formats: "",
            //...other params...
        }
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().qualityMeter().formats(value);
value = $au.uploader('uploaderID').paneItem().qualityMeter().formats();

Property Value

Type: String

Print formats used in the quality meter. Format of this string is the following:

Format1 name,format1 width (pixels),format1 height (pixels),format1 acceptable ratio;Format2 name,format2 width (pixels),format2 height (pixels),format2 acceptable ratio;...

In other words:

  • Each format is defined with 4 mandatory parameters: name, width, height, and acceptable ratio.
  • Parameters are separated by comma.
  • Formats are separated by semicolon.

See the Remarks section for more details about syntax of this string.

If this property is not initialized or set to incorrect value no quality meter is displayed.

Default value is "".

Remarks

As mentioned above, each print format is described with four parameters:

Format name

Name of the print format which will be displayed as a tooltip when a mouse is hovering over an appropriate quality meter element.

If the format name contains semicolon or quotation mark characters enclose this format in single (' ') or double (" ") quotes. Additionally, quotation marks (both single ' and double ") inside the name should be escaped with a backslash. For example, to get a User's format name, set this format as follows:

"User\'s format,1800,1200,1.2";...

Format width
Minimum width (in pixels) which the photo should have to be interpreted as high quality for this print format (i.e. colored by the highQualityColor value).
Format height
Minimum height (in pixels) which the photo should have to be interpreted as high quality for this print format (i.e. colored by the highQualityColor value).
Acceptable ratio (further, AR)
Maximum acceptable ratio of format width (or height) and actual photo width (or height). If format width/photo width will be larger than AR, the photo will be interpreted as unacceptable for this print format.
Note

To be interpreted as high quality, the photo should have both width and height equal or larger than specified ones. Say, if width conforms to the limitation, but height does not, the photo will not be interpreted as high quality.

Example

Imagine we specify the following quality meter string:

JavaScript

qualityMeter:{
    formats: "4x6 inches,1800,1200,1.2;6x8 inches,2400,1800,1.3;"
}

It means that you specify two formats: 4x6 inches (1200x1800 pixels if to print with resolution equal to 300 DPI) and 6x8 inches (1800x2400 pixels for 300 DPI). This way the quality meter will have two elements. The table below demonstrates the quality meter values for images of different size. Let us assume that the default values for the quality meter colors are used (allowed formats are green, acceptable - yellow, non-recommended ones are gray).

Image dimensions Quality meter colors Comment
2000x3000
  • 4x6 inches - Green
  • 6x8 inches - Green
Image dimensions exceed both format restrictions, so we can freely print it in both formats.
1500x2000
  • 4x6 inches - Green
  • 6x8 inches - Yellow

The dimensions are larger than 4x6 inches, but smaller than 6x8 inches. Now we should estimate if it can be printed with the acceptable quality in 6x8 format. To do it, calculate the ratio between the format dimensions and the actual image dimensions (we take a width for brevity):

1800/1500 = 1.2

Now we compare this value with the acceptable ratio (AR) specified as the fourth parameter. If this value is larger than AR, an image cannot be printed with this format, if otherwise - it is acceptable.

The AR specified for 6x8 inches is 1.3, thus it is acceptable and we mark a color meter with yellow.

1200x1800
  • 4x6 inches - Green
  • 6x8 inches - Gray

The dimensions conform 4x6 inches, but are smaller than 6x8 inches. This time if we calculate the ratio between the format dimensions and the actual image dimensions, we will get:

1800/1200 = 1.5

It is larger than the AR (which is equal to 1.3) and that is why if we print this image in the 6x8 inches format, we will get quite poor quality. So we mark this color meter item to gray (i.e. as "not recommended").

1024x1536
  • 4x6 inches - Yellow
  • 6x8 inches - Gray

The dimensions of this image are smaller than both formats. It is obviously too small for the 6x8 inches format, but let us check it for the 4x6 format:

1200/1024 = 1.171875

The AR for the 4x6 inches format is 1.2, i.e. this image acceptable for it, and the appropriate quality meter element is yellow.

96x96
  • 4x6 inches - Gray
  • 6x8 inches - Gray
It is obvious that this image is too small to be printed even on a matchbox, so both elements of the quality meter are gray.

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.Formats ASP.NET Property
  • QualityMeter.Formats PHP Property


qualityMeter.height Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of each quality meter rectangle.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem : {
        qualityMeter: {
            //...other params...
            height: 11,
            //...other params...
        }
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem().qualityMeter().height(value);
value = $au.uploader('uploaderID').paneItem().qualityMeter().height();

Property Value

Type: Number

The height of each quality meter rectangle.

Default value is 11.

Remarks

If the quality meter height is larger than a thumbnail height (specified with the folderPane.previewSize and uploadPane.previewSize properties), it is automatically shrunk down to fit this distance.

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.Height ASP.NET Property
  • QualityMeter.Height PHP Property


qualityMeter.highQualityColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the quality meter element which corresponds to the recommended print format.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem : {
        qualityMeter: {
            //...other params...
            highQualityColor: "#5bc529",
            //...other params...
        }
    }
})

Property Value

Type: String

The color of the quality meter element which corresponds to the recommended print format.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#5bc529".

Remarks

If the image will be printed in this format, the quality will be high (i.e. the printing machine will be able to print it with high resolution).

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.HighQualityColor ASP.NET Property
  • QualityMeter.HighQualityColor PHP Property


qualityMeter.lowQualityColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the quality meter element corresponding to the print format which is not recommended for printing.

Syntax

JavaScript

Initialize

$au.uploader({
    paneItem : {
        qualityMeter: {
            //...other params...
            lowQualityColor: "#ececec",
            //...other params...
        }
    }
})

Property Value

Type: String

The color of the quality meter element corresponding to the print format which is not recommended for printing.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#ececec".

Remarks

If the image will be printed in this format, the quality will be unacceptable because printing machine will not be able to print it with high enough resolution.

See Also

Reference

  • Aurigma.ImageUploader.QualityMeter.LowQualityColor ASP.NET Property
  • QualityMeter.LowQualityColor PHP Property


restrictions Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class contains masks for allowed and denied file extensions and upload restrictions.

For a list of all members of this class, see restrictions Members.

Syntax

JavaScript

$au.restrictions = function() {
}

See Also

Reference

  • restrictions Property
  • Aurigma.ImageUploader.Restrictions ASP.NET Class
  • Restrictions PHP Class

Manual

  • Configuring Restriction Rules for Files


restrictions Members

  • Properties
  • Language Filter ( all languages )

The restrictions type exposes the following members.

Properties

 | Name | Description
Public property | deniedFileMask | Gets or set a file mask for the files that are denied to be uploaded.
Public property | enableCmyk | Gets or sets a value indicating whether it is impossible to select CMYK images for the upload.
Public property | fileMask | Gets or sets a file mask for the files which are allowed to be uploaded.
Public property | maxFileCount | Gets or sets a maximum number of files allowed for upload per one session.
Public property | maxFileSize | Gets or sets a maximum file size which is allowed for upload to the server.
Public property | maxImageHeight | Gets or sets a maximum image height allowed for upload.
Public property | maxImageWidth | Gets or sets a maximum image width allowed for upload.
Public property | maxTotalFileSize | Gets or sets a maximum total file size allowed for upload.
Public property | minFileCount | Gets or sets a minimum number of files allowed for upload per one session.
Public property | minFileSize | Gets or sets a minimum file size allowed for upload.
Public property | minImageHeight | Gets or sets a minimum image height allowed for upload.
Public property | minImageWidth | Gets or sets a minimum image width allowed for upload.


restrictions Properties

  • Properties
  • Language Filter ( all languages )

The restrictions type exposes the following properties.

Properties

 | Name | Description
Public property | deniedFileMask | Gets or set a file mask for the files that are denied to be uploaded.
Public property | enableCmyk | Gets or sets a value indicating whether it is impossible to select CMYK images for the upload.
Public property | fileMask | Gets or sets a file mask for the files which are allowed to be uploaded.
Public property | maxFileCount | Gets or sets a maximum number of files allowed for upload per one session.
Public property | maxFileSize | Gets or sets a maximum file size which is allowed for upload to the server.
Public property | maxImageHeight | Gets or sets a maximum image height allowed for upload.
Public property | maxImageWidth | Gets or sets a maximum image width allowed for upload.
Public property | maxTotalFileSize | Gets or sets a maximum total file size allowed for upload.
Public property | minFileCount | Gets or sets a minimum number of files allowed for upload per one session.
Public property | minFileSize | Gets or sets a minimum file size allowed for upload.
Public property | minImageHeight | Gets or sets a minimum image height allowed for upload.
Public property | minImageWidth | Gets or sets a minimum image width allowed for upload.


restrictions.deniedFileMask Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or set a file mask for the files that are denied to be uploaded.

Syntax

JavaScript

Initialize

$au.uploader({
    restrictions: {
        //...other params...
        deniedFileMask: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions().deniedFileMask(value);
value = $au.uploader('uploaderID').restrictions().deniedFileMask();

Property Value

Type: String

The file mask for the files that are denied to be uploaded. You can use the standard wildcards such as asterisk * (arbitrary substring) and question mark ? (arbitrary character). To specify several masks, separate them by semicolons, e.g. *.exe;*.asp;*.htm.

Default value is "".

See Also

Reference

  • fileNameNotAllowed Property
  • Aurigma.ImageUploader.Restrictions.DeniedFileMask ASP.NET Property
  • Restrictions.DeniedFileMask PHP Property

Manual

  • Filtering Files by Names and Types


restrictions.enableCmyk Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is impossible to select CMYK images for the upload.

Syntax

JavaScript

Initialize

$au.uploader({
    restrictions: {
        //...other params...
        enableCmyk: true,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions().enableCmyk(value);
value = $au.uploader('uploaderID').restrictions().enableCmyk();

Property Value

Type: Boolean

If false, a user cannot select CMYK images for the upload. Otherwise, CMYK images are allowed to be uploaded.

Default value is true.

See Also

Reference

  • cmykImagesNotAllowed Property
  • Aurigma.ImageUploader.Restrictions.EnableCmyk ASP.NET Property
  • Restrictions.EnableCmyk PHP Property

Manual

  • Setting Limitations for Images


restrictions.fileMask Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a file mask for the files which are allowed to be uploaded.

Syntax

JavaScript

Initialize

$au.uploader({
    restrictions: {
        //...other params...
        fileMask: "*.*",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions().fileMask(value);
value = $au.uploader('uploaderID').restrictions().fileMask();

Property Value

Type: String

The file mask for the files which are allowed to be uploaded. You can use the standard wildcards such as asterisk * (arbitrary substring) and question mark ? (arbitrary character). To specify several masks, separate them by semicolons, e.g. *.jpg;*.jpeg;*.jpe. To display all possible files, use *.*.

Default value is "*.*".

See Also

Reference

  • fileNameNotAllowed Property
  • Aurigma.ImageUploader.Restrictions.FileMask ASP.NET Property
  • Restrictions.FileMask PHP Property

Manual

  • Filtering Files by Names and Types


restrictions.maxFileCount Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum number of files allowed for upload per one session.

Syntax

JavaScript

Initialize

$au.uploader({
    restrictions: {
        //...other params...
        maxFileCount: 0,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions().maxFileCount(value);
value = $au.uploader('uploaderID').restrictions().maxFileCount();

Property Value

Type: Number

The maximum file count allowed for upload per one session. If the value is 0 then there is no limit.

Default value is 0.

Remarks

Note

Image Uploader Express restricts the maximum number of user-selected files to 100. See the Comparison of Image Uploader Editions topic for details.

See Also

Reference

  • maxFileCountExceeded Property
  • Aurigma.ImageUploader.Restrictions.MaxFileCount ASP.NET Property
  • Restrictions.MaxFileCount PHP Property

Manual

  • Setting Limitations for Size and Number of Files


restrictions.maxFileSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum file size which is allowed for upload to the server.

Syntax

JavaScript

Initialize

$au.uploader({
    restrictions: {
        //...other params...
        maxFileSize: 0,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions().maxFileSize(value);
value = $au.uploader('uploaderID').restrictions().maxFileSize();

Property Value

Type: Number

The maximum size (in bytes) for files allowed for upload. If the value is 0 then there is no limit.

Note

When you set the value that is more than 2 Gb, it is recommended to pass such value as a string.

Default value is 0.

Remarks

Note

Image Uploader Express restricts the maximum size of each user-selected file to 100 Mb. Image Uploader Professional and Print restrict the maximum size of each user-selected file to 2 Gb. See the Comparison of Image Uploader Editions topic for details.

This property limits only a single file. If you want to set limit for all selected files, use the maxTotalFileSize property.

See Also

Reference

  • maxFileSizeExceeded Property
  • Aurigma.ImageUploader.Restrictions.MaxFileSize ASP.NET Property
  • Restrictions.MaxFileSize PHP Property

Manual

  • Setting Limitations for Size and Number of Files


restrictions.maxImageHeight Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum image height allowed for upload.

Syntax

JavaScript

Initialize

$au.uploader({
    restrictions: {
        //...other params...
        maxImageHeight: 0,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions().maxImageHeight(value);
value = $au.uploader('uploaderID').restrictions().maxImageHeight();

Property Value

Type: Number

The maximum allowed image height (in pixels). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • dimensionsTooLarge Property
  • Aurigma.ImageUploader.Restrictions.MaxImageHeight ASP.NET Property
  • Restrictions.MaxImageHeight PHP Property

Manual

  • Setting Limitations for Images


restrictions.maxImageWidth Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum image width allowed for upload.

Syntax

JavaScript

Initialize

$au.uploader({
    restrictions: {
        //...other params...
        maxImageWidth: 0,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions().maxImageWidth(value);
value = $au.uploader('uploaderID').restrictions().maxImageWidth();

Property Value

Type: Number

The maximum allowed image width (in pixels). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • dimensionsTooLarge Property
  • Aurigma.ImageUploader.Restrictions.MaxImageWidth ASP.NET Property
  • Restrictions.MaxImageWidth PHP Property

Manual

  • Setting Limitations for Images


restrictions.maxTotalFileSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximum total file size allowed for upload.

Syntax

JavaScript

Initialize

$au.uploader({
    restrictions: {
        //...other params...
        maxTotalFileSize: 0,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions().maxTotalFileSize(value);
value = $au.uploader('uploaderID').restrictions().maxTotalFileSize();

Property Value

Type: Number

The maximum size (in bytes) of all files selected for upload. If the value is 0 then there is no limit.

Note

When you set the value that is more than 2 Gb, it is recommended to pass such value as a string.

Default value is 0.

Remarks

Note

Only original file sizes are taken into account. Size of converted files and other auxiliary data is disregarded. So this property is useful when you upload original files without applying any client-side file transformations.

See Also

Reference

  • maxTotalFileSizeExceeded Property
  • Aurigma.ImageUploader.Restrictions.MaxTotalFileSize ASP.NET Property
  • Restrictions.MaxTotalFileSize PHP Property

Manual

  • Setting Limitations for Size and Number of Files


restrictions.minFileCount Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum number of files allowed for upload per one session.

Syntax

JavaScript

Initialize

$au.uploader({
    restrictions: {
        //...other params...
        minFileCount: 1,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions().minFileCount(value);
value = $au.uploader('uploaderID').restrictions().minFileCount();

Property Value

Type: Number

The minimum file count allowed for upload per one session.

Default value is 1.

Remarks

Note

The Upload button is disabled if the number of files selected for upload less than this value.

See Also

Reference

  • Aurigma.ImageUploader.Restrictions.MinFileCount ASP.NET Property
  • Restrictions.MinFileCount PHP Property

Manual

  • Setting Limitations for Size and Number of Files


restrictions.minFileSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum file size allowed for upload.

Syntax

JavaScript

Initialize

$au.uploader({
    restrictions: {
        //...other params...
        minFileSize: 0,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions().minFileSize(value);
value = $au.uploader('uploaderID').restrictions().minFileSize();

Property Value

Type: Number

The minimum allowed file size (in bytes). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • fileSizeTooSmall Property
  • Aurigma.ImageUploader.Restrictions.MinFileSize ASP.NET Property
  • Restrictions.MinFileSize PHP Property

Manual

  • Setting Limitations for Size and Number of Files


restrictions.minImageHeight Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum image height allowed for upload.

Syntax

JavaScript

Initialize

$au.uploader({
    restrictions: {
        //...other params...
        minImageHeight: 0,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions().minImageHeight(value);
value = $au.uploader('uploaderID').restrictions().minImageHeight();

Property Value

Type: Number

The minimum allowed image height (in pixels). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • dimensionsTooSmall Property
  • Aurigma.ImageUploader.Restrictions.MinImageHeight ASP.NET Property
  • Restrictions.MinImageHeight PHP Property

Manual

  • Setting Limitations for Images


restrictions.minImageWidth Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a minimum image width allowed for upload.

Syntax

JavaScript

Initialize

$au.uploader({
    restrictions: {
        //...other params...
        minImageWidth: 0,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions().minImageWidth(value);
value = $au.uploader('uploaderID').restrictions().minImageWidth();

Property Value

Type: Number

The minimum allowed image width (in pixels). If the value is 0 then there is no limit.

Default value is 0.

See Also

Reference

  • dimensionsTooSmall Property
  • Aurigma.ImageUploader.Restrictions.MinImageWidth ASP.NET Property
  • Restrictions.MinImageWidth PHP Property

Manual

  • Setting Limitations for Images


statusPane Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the status pane.

For a list of all members of this class, see statusPane Members.

Syntax

JavaScript

$au.statusPane = function() {
}

See Also

Reference

  • statusPane Property
  • Aurigma.ImageUploader.StatusPane ASP.NET Class
  • StatusPane PHP Class

Manual

  • Customizing Appearance


statusPane Members

  • Properties
  • Language Filter ( all languages )

The statusPane type exposes the following members.

Properties

 | Name | Description
Public property | clearAllHyperlinkText | Gets or sets a text of the Clear all hyperlink.
Public property | color | Gets or sets a color of the status pane.
Public property | filesToUploadText | Gets or sets a text on the status pane which is displayed when at least one file is added to the upload pane.
Public property | noFilesToUploadText | Gets or sets a text on the status pane which is displayed when the upload pane is empty.
Public property | progressBarText | Gets or sets a text displayed in the progress bar during the upload if the instant upload feature is used.


statusPane Properties

  • Properties
  • Language Filter ( all languages )

The statusPane type exposes the following properties.

Properties

 | Name | Description
Public property | clearAllHyperlinkText | Gets or sets a text of the Clear all hyperlink.
Public property | color | Gets or sets a color of the status pane.
Public property | filesToUploadText | Gets or sets a text on the status pane which is displayed when at least one file is added to the upload pane.
Public property | noFilesToUploadText | Gets or sets a text on the status pane which is displayed when the upload pane is empty.
Public property | progressBarText | Gets or sets a text displayed in the progress bar during the upload if the instant upload feature is used.


statusPane.clearAllHyperlinkText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text of the Clear all hyperlink.

Syntax

JavaScript

Initialize

$au.uploader({
    statusPane: {
        //...other params...
        clearAllHyperlinkText: "clear all",
        //...other params...
    }
})

Property Value

Type: String

The text of the Clear all hyperlink.

Default value is "clear all".

Remarks

By clicking this link, a user can remove all the files from the upload pane.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.StatusPane.ClearAllHyperlinkText ASP.NET Property
  • StatusPane.ClearAllHyperlinkText PHP Property


statusPane.color Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of the status pane.

Syntax

JavaScript

Initialize

$au.uploader({
    statusPane: {
        //...other params...
        color: "#f7f7f7;#efefef",
        //...other params...
    }
})

Property Value

Type: String

The color of the status pane.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is "#f7f7f7;#efefef".

See Also

Reference

  • Aurigma.ImageUploader.StatusPane.Color ASP.NET Property
  • StatusPane.Color PHP Property


statusPane.filesToUploadText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text on the status pane which is displayed when at least one file is added to the upload pane.

Syntax

JavaScript

Initialize

$au.uploader({
    statusPane: {
        //...other params...
        filesToUploadText: "Files selected to upload: [count]",
        //...other params...
    }
})

Property Value

Type: String

The text stating how many files are added to the upload pane. It can contain the following placeholder:

[count]
replaced by the number of files actually added to the upload pane.

Default value is "Files selected to upload: [count]".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.StatusPane.FilesToUploadText ASP.NET Property
  • StatusPane.FilesToUploadText PHP Property


statusPane.noFilesToUploadText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text on the status pane which is displayed when the upload pane is empty.

Syntax

JavaScript

Initialize

$au.uploader({
    statusPane: {
        //...other params...
        noFilesToUploadText: "No files to upload",
        //...other params...
    }
})

Property Value

Type: String

The text stating that the upload pane is empty.

Default value is "No files to upload".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.StatusPane.NoFilesToUploadText ASP.NET Property
  • StatusPane.NoFilesToUploadText PHP Property


statusPane.progressBarText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a text displayed in the progress bar during the upload if the instant upload feature is used.

Syntax

JavaScript

Initialize

$au.uploader({
    statusPane: {
        //...other params...
        progressBarText: "Uploading ([percents]%)",
        //...other params...
    }
})

Property Value

Type: String

The text displaying a total percentage of the upload progress. It can contain the following placeholder:

[percents]
replaced by the total percentage of the upload progress.

Default value is "Uploading ([percents]%)".

Remarks

This property makes sense only if the enableInstantUpload property is true.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • enableInstantUpload Property
  • Aurigma.ImageUploader.StatusPane.ProgressBarText ASP.NET Property
  • StatusPane.ProgressBarText PHP Property


thumbnail Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents a standalone thumbnail bound with some upload pane item of Image Uploader.

For a list of all members of this class, see thumbnail Members.

Syntax

JavaScript

$au.thumbnail = function() {
}

Remarks

Note

Image Uploader Express disables the Thumbnail control.

This control can be used to build a custom upload list. For example, you can add extra fields for each item or design new upload list layout.

The idea is the following:

  1. Insert this control instance to the necessary position in HTML.
  2. Associate the control with an instance of uploader which contains the upload list where to bind items from. You can do it using the parentControlName property.
  3. Bind the control with some item from the upload list using the guid property.

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail ASP.NET Class
  • Thumbnail PHP Class


thumbnail Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The thumbnail type exposes the following members.

Methods

 | Name | Description
Public method | getHtml | Generates the HTML code which will embed the thumbnail control and returns it as a string.
Public method | writeHtml | Generates the HTML code which will embed the thumbnail control and writes this code directly into the page.

Properties

 | Name | Description
Public property | activeXControl | Gets or sets the ActiveX control settings.
Public property | backgroundColor | Gets or sets a background color of this thumbnail instance.
Public property | events | Gets or sets a collection of client-side events.
Public property | guid | Gets or sets a unique identifier (GUID) of the item which is represented with this thumbnail instance.
Public property | height | Gets or sets a height of this thumbnail instance.
Public property | id | Gets or sets a unique identifier of the thumbnail control.
Public property | javaControl | Gets or sets the Java applet settings.
Public property | parentControlName | The uploader control name this thumbnail instance is associated with.
Public property | width | Gets or sets a width of this thumbnail instance.


thumbnail Methods

  • Methods
  • Language Filter ( all languages )

The thumbnail type exposes the following methods.

Methods

 | Name | Description
Public method | getHtml | Generates the HTML code which will embed the thumbnail control and returns it as a string.
Public method | writeHtml | Generates the HTML code which will embed the thumbnail control and writes this code directly into the page.


thumbnail.getHtml Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Generates the HTML code which will embed the thumbnail control and returns it as a string.

Syntax

JavaScript

$au.thumbnail('uploaderID').getHtml();

Return Value

Type: String

The thumbnail control embedding code.


thumbnail.writeHtml Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Generates the HTML code which will embed the thumbnail control and writes this code directly into the page.

Syntax

JavaScript

$au.thumbnail('uploaderID').writeHtml();

Remarks

Note

As soon as you call the writeHtml(), all necessary HTML code is inserted into the page at the current position. Alternatively, you can get the string with appropriate HTML code using the getHtml() method, and write it to the necessary position manually (maybe with some modifications).


thumbnail Properties

  • Properties
  • Language Filter ( all languages )

The thumbnail type exposes the following properties.

Properties

 | Name | Description
Public property | activeXControl | Gets or sets the ActiveX control settings.
Public property | backgroundColor | Gets or sets a background color of this thumbnail instance.
Public property | events | Gets or sets a collection of client-side events.
Public property | guid | Gets or sets a unique identifier (GUID) of the item which is represented with this thumbnail instance.
Public property | height | Gets or sets a height of this thumbnail instance.
Public property | id | Gets or sets a unique identifier of the thumbnail control.
Public property | javaControl | Gets or sets the Java applet settings.
Public property | parentControlName | The uploader control name this thumbnail instance is associated with.
Public property | width | Gets or sets a width of this thumbnail instance.


thumbnail.activeXControl Property

  • Supported browsers: Internet Explorer

Gets or sets the ActiveX control settings.

Syntax

JavaScript

Initialize

$au.thumbnail({
    //...other params...
    activeXControl: {},
    //...other params...
})

Get/Set Value at Runtime

$au.thumbnail('thumbnailID').activeXControl(value);
value = $au.thumbnail('thumbnailID').activeXControl();

Property Value

Type: $au.activeXControl

The ActiveX control settings.

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.ActiveXControl ASP.NET Property
  • Thumbnail.ActiveXControl PHP Property


thumbnail.backgroundColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of this thumbnail instance.

Syntax

JavaScript

Initialize

$au.thumbnail({
    //...other params...
    backgroundColor: "#ffffff",
    //...other params...
})

Property Value

Type: String

The background color of the thumbnail control.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#ffffff".

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.BackgroundColor ASP.NET Property
  • Thumbnail.BackgroundColor PHP Property


thumbnail.events Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a collection of client-side events.

Syntax

JavaScript

Initialize

$au.thumbnail({
    //...other params...
    events: {},
    //...other params...
})

Get/Set Value at Runtime

$au.thumbnail('thumbnailID').events(value);
value = $au.thumbnail('thumbnailID').events();

Property Value

Type: $au.thumbnailEvents

The collection of client-side events.

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.ClientEvents ASP.NET Property
  • Thumbnail.ClientEvents PHP Property


thumbnail.guid Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a unique identifier (GUID) of the item which is represented with this thumbnail instance.

Syntax

JavaScript

Initialize

$au.thumbnail({
    //...other params...
    guid: "",
    //...other params...
})

Get/Set Value at Runtime

$au.thumbnail('thumbnailID').guid(value);
value = $au.thumbnail('thumbnailID').guid();

Property Value

Type: String

The GUID of the item which is represented with the thumbnail control.

Default value is "".

Remarks

Before binding the thumbnail with some upload list item, you should specify the parent uploader control. You can do it using the parentControlName property.

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.Guid ASP.NET Property
  • Thumbnail.Guid PHP Property


thumbnail.height Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of this thumbnail instance.

Syntax

JavaScript

Initialize

$au.thumbnail({
    //...other params...
    height: "100px",
    //...other params...
})

Get/Set Value at Runtime

$au.thumbnail('thumbnailID').height(value);
value = $au.thumbnail('thumbnailID').height();

Property Value

Type: String

The height of the thumbnail control.

Default value is "100px".

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.Height ASP.NET Property
  • Thumbnail.Height PHP Property


thumbnail.id Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a unique identifier of the thumbnail control.

Syntax

JavaScript

Initialize

$au.thumbnail({
    //...other params...
    id: "",
    //...other params...
})

Get/Set Value at Runtime

$au.thumbnail('thumbnailID').id(value);
value = $au.thumbnail('thumbnailID').id();

Property Value

Type: String

The unique identifier of the control.

Default value is "".

Remarks

This identifier is obligatiry set during initialization and used to refer to the thumbnail control at runtime and, thus, modify its parameters, call methods, and handle events through JavaScript.


thumbnail.javaControl Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets the Java applet settings.

Syntax

JavaScript

Initialize

$au.thumbnail({
    //...other params...
    javaControl: {},
    //...other params...
})

Get/Set Value at Runtime

$au.thumbnail('thumbnailID').javaControl(value);
value = $au.thumbnail('thumbnailID').javaControl();

Property Value

Type: $au.javaControl

The Java applet settings.

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.JavaControl ASP.NET Property
  • Thumbnail.JavaControl PHP Property


thumbnail.parentControlName Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

The uploader control name this thumbnail instance is associated with.

Syntax

JavaScript

Initialize

$au.thumbnail({
    //...other params...
    parentControlName: "",
    //...other params...
})

Get/Set Value at Runtime

$au.thumbnail('thumbnailID').parentControlName(value);
value = $au.thumbnail('thumbnailID').parentControlName();

Property Value

Type: String

Gets or sets a name of the uploader control this thumbnail instance is associated with.

Default value is "".

Remarks

After you associate this thumbnail control with a parent uploader, you should bind it with some item from the upload list. To do it, set the guid property to the GUID of this item. You can get it using the file.guid property.

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.ParentControlName ASP.NET Property
  • Thumbnail.ParentControlName PHP Property


thumbnail.width Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of this thumbnail instance.

Syntax

JavaScript

Initialize

$au.thumbnail({
    //...other params...
    width: "100px",
    //...other params...
})

Get/Set Value at Runtime

$au.thumbnail('thumbnailID').width(value);
value = $au.thumbnail('thumbnailID').width();

Property Value

Type: String

The width of the thumbnail control.

Default value is "100px".

See Also

Reference

  • Aurigma.ImageUploader.Thumbnail.Width ASP.NET Property
  • Thumbnail.Width PHP Property


thumbnailEvents Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class provides access to client-side events of the thumbnail control.

For a list of all members of this class, see thumbnailEvents Members.

Syntax

JavaScript

$au.thumbnailEvents = function() {
}

See Also

Reference

  • ThumbnailClientEvents PHP Class


thumbnailEvents Members

  • Properties
  • Language Filter ( all languages )

The thumbnailEvents type exposes the following members.

Properties

 | Name | Description
Public property | click | Gets or sets an array of Click event handlers.
Public property | initComplete | Gets or sets an array of InitComplete event handlers.
Public property | preRender | Gets or sets an array of PreRender event handlers.


thumbnailEvents Properties

  • Properties
  • Language Filter ( all languages )

The thumbnailEvents type exposes the following properties.

Properties

 | Name | Description
Public property | click | Gets or sets an array of Click event handlers.
Public property | initComplete | Gets or sets an array of InitComplete event handlers.
Public property | preRender | Gets or sets an array of PreRender event handlers.


thumbnailEvents.click Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of Click event handlers.

Syntax

JavaScript

Initialize

$au.thumbnail({
        events: {
            //...other params...
            click: [],
            //...other params...
        }
})

Get/Set Value at Runtime

$au.thumbnail('thumbnailID').events().click(value);
value = $au.thumbnail('thumbnailID').events().click();

Property Value

Type: $au.event

The string containing a name of Click event handler or an array of handler names.

Remarks

This event fires when the thumbnail control is clicked.

See Also

Reference

  • Click Client-Side Event
  • ThumbnailClientEvents.Click PHP Property


thumbnailEvents.initComplete Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of InitComplete event handlers.

Syntax

JavaScript

Initialize

$au.thumbnail({
        events: {
            //...other params...
            initComplete: [],
            //...other params...
        }
})

Get/Set Value at Runtime

$au.thumbnail('thumbnailID').events().initComplete(value);
value = $au.thumbnail('thumbnailID').events().initComplete();

Property Value

Type: $au.event

The string containing a name of InitComplete event handler or an array of handler names.

Remarks

This event fires when the thumbnail control is completely created and initialized.

See Also

Reference

  • InitComplete Client-Side Event
  • ThumbnailClientEvents.InitComplete PHP Property


thumbnailEvents.preRender Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of PreRender event handlers.

Syntax

JavaScript

Initialize

$au.thumbnail({
        events: {
            //...other params...
            preRender: [],
            //...other params...
        }
})

Get/Set Value at Runtime

$au.thumbnail('thumbnailID').events().preRender(value);
value = $au.thumbnail('thumbnailID').events().preRender();

Property Value

Type: $au.event

The string containing a name of PreRender event handler or an array of handler names.

Remarks

This event fires before the writeHtml() or getHtml() method is executed.

See Also

Reference

  • PreRender Client-Side Event
  • ThumbnailClientEvents.PreRender PHP Property


treePane Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the tree pane.

For a list of all members of this class, see treePane Members.

Syntax

JavaScript

$au.treePane = function() {
}

See Also

Reference

  • treePane Property
  • Aurigma.ImageUploader.TreePane ASP.NET Class
  • TreePane PHP Class

Manual

  • Layouts


treePane Members

  • Properties
  • Language Filter ( all languages )

The treePane type exposes the following members.

Properties

 | Name | Description
Public property | titleText | Gets or sets a title of the tree pane.
Public property | unixFileSystemRootText | Gets or sets a caption of the folder tree node which specifies the system directory at *NIX systems.
Public property | unixHomeDirectoryText | Gets or sets a caption of the folder tree node which specifies the home directory at *NIX systems.
Public property | width | Gets or sets a width of the tree pane.


treePane Properties

  • Properties
  • Language Filter ( all languages )

The treePane type exposes the following properties.

Properties

 | Name | Description
Public property | titleText | Gets or sets a title of the tree pane.
Public property | unixFileSystemRootText | Gets or sets a caption of the folder tree node which specifies the system directory at *NIX systems.
Public property | unixHomeDirectoryText | Gets or sets a caption of the folder tree node which specifies the home directory at *NIX systems.
Public property | width | Gets or sets a width of the tree pane.


treePane.titleText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the tree pane.

Syntax

JavaScript

Initialize

$au.uploader({
    treePane: {
        //...other params...
        titleText: "Folders",
        //...other params...
    }
})

Property Value

Type: String

The title of the tree pane.

Default value is "Folders".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.TreePane.TitleText ASP.NET Property
  • TreePane.TitleText PHP Property


treePane.unixFileSystemRootText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the folder tree node which specifies the system directory at *NIX systems.

Syntax

JavaScript

Initialize

$au.uploader({
    treePane: {
        //...other params...
        unixFileSystemRootText: "Filesystem",
        //...other params...
    }
})

Property Value

Type: String

The caption of the folder tree node which specifies the system directory at *NIX systems.

Default value is "Filesystem".

Remarks

Note

This value is used only at Linux and different sorts of Unix. For Windows and Mac the system-dependent values are extracted and used.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • unixHomeDirectoryText Property
  • Aurigma.ImageUploader.TreePane.UnixFileSystemRootText ASP.NET Property
  • TreePane.UnixFileSystemRootText PHP Property


treePane.unixHomeDirectoryText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a caption of the folder tree node which specifies the home directory at *NIX systems.

Syntax

JavaScript

Initialize

$au.uploader({
    treePane: {
        //...other params...
        unixHomeDirectoryText: "Home Folder",
        //...other params...
    }
})

Property Value

Type: String

The caption of the folder tree node which specifies the home directory at *NIX systems.

Default value is "Home Folder".

Remarks

Note

This value is used only at Linux and different sorts of Unix. For Windows and Mac the system-dependent values are extracted and used.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • unixFileSystemRootText Property
  • Aurigma.ImageUploader.TreePane.UnixHomeDirectoryText ASP.NET Property
  • TreePane.UnixHomeDirectoryText PHP Property


treePane.width Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of the tree pane.

Syntax

JavaScript

Initialize

$au.uploader({
    treePane: {
        //...other params...
        width: 200,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').treePane().width(value);
value = $au.uploader('uploaderID').treePane().width();

Property Value

Type: Number

The width of the tree pane (in pixels).

Default value is 200.

See Also

Reference

  • Aurigma.ImageUploader.TreePane.Width ASP.NET Property
  • TreePane.Width PHP Property


uploadPane Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the upload pane.

For a list of all members of this class, see uploadPane Members.

Syntax

JavaScript

$au.uploadPane = function() {
}

See Also

Reference

  • uploadPane Property
  • Aurigma.ImageUploader.UploadPane ASP.NET Class
  • UploadPane PHP Class

Manual

  • Layouts


uploadPane Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The uploadPane type exposes the following members.

Methods

 | Name | Description
Public method | addFiles | Opens a standard Open File dialog so that the user could select files for upload.
Public method | addFolders | Opens a standard Open Folder dialog so that the user can select folders for the upload.
Public method | loadUploadList(Number) | Loads the upload list with the specified id.
Public method | removeAllFiles | Removes all items from the upload list.
Public method | removeSelectedFiles | Removes selected items from the upload list.
Public method | resetUploadList(Number) | Resets the upload list with the specified id.
Public method | saveUploadList(Number) | Saves the upload list with the specified id.

Properties

 | Name | Description
Public property | dropFilesHereImageFormat | Gets or sets an image displayed on the upload pane when it is empty.
Public property | dropFilesHereText | Gets or sets a label displayed on the upload pane when it is empty.
Public property | previewSize | Gets or sets a size of the preview area when in Thumbnails view.
Public property | sortMode | Gets or sets a sort mode of the upload pane.
Public property | viewMode | Gets or sets a view mode for the upload pane.


uploadPane Methods

  • Methods
  • Language Filter ( all languages )

The uploadPane type exposes the following methods.

Methods

 | Name | Description
Public method | addFiles | Opens a standard Open File dialog so that the user could select files for upload.
Public method | addFolders | Opens a standard Open Folder dialog so that the user can select folders for the upload.
Public method | loadUploadList(Number) | Loads the upload list with the specified id.
Public method | removeAllFiles | Removes all items from the upload list.
Public method | removeSelectedFiles | Removes selected items from the upload list.
Public method | resetUploadList(Number) | Resets the upload list with the specified id.
Public method | saveUploadList(Number) | Saves the upload list with the specified id.


uploadPane.addFiles Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Opens a standard Open File dialog so that the user could select files for upload.

Syntax

JavaScript

$au.uploader('uploaderID').uploadPane().addFiles();

Remarks

Unlike in the file dialog opened by the browser for the <input type="file"> element, multiple selection is allowed.

The file filter for the dialog is formed from the fileMask property.

See Also

Reference

  • addFolders() Method


uploadPane.addFolders Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Opens a standard Open Folder dialog so that the user can select folders for the upload.

Syntax

JavaScript

$au.uploader('uploaderID').uploadPane().addFolders();

See Also

Reference

  • addFiles() Method


uploadPane.loadUploadList(Number) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Loads the upload list with the specified id.

Syntax

JavaScript

$au.uploader('uploaderID').uploadPane().loadUploadList(id);

Parameters

id

Type: Number

Unique integer value to load the upload list with this identifier.

Remarks

Note

Image Uploader Express does not restore upload lists. See the Comparison of Image Uploader Editions topic for details.

Maximum number of upload lists allowed for saving is 50.

See Also

Reference

  • resetUploadList(Number) Method
  • saveUploadList(Number) Method

Manual

  • Restoring Upload List


uploadPane.removeAllFiles Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Removes all items from the upload list.

Syntax

JavaScript

$au.uploader('uploaderID').uploadPane().removeAllFiles();

Remarks

Note

The contrary method addAllFiles is not available due the security reasons. If this method is required, you should create support case and order the private-label version. In this case it is possible to discuss the including of this feature.

See Also

Reference

  • removeSelectedFiles() Method


uploadPane.removeSelectedFiles Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Removes selected items from the upload list.

Syntax

JavaScript

$au.uploader('uploaderID').uploadPane().removeSelectedFiles();

Remarks

Note

The contrary method addSelectedFiles is not available due the security reasons. If this method is required, you should create support case and order the private-label version. In this case it is possible to discuss the including of this feature.

See Also

Reference

  • removeAllFiles() Method


uploadPane.resetUploadList(Number) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Resets the upload list with the specified id.

Syntax

JavaScript

$au.uploader('uploaderID').uploadPane().resetUploadList(id);

Parameters

id

Type: Number

Unique integer value to reset the upload list with this identifier.

Remarks

Note

Image Uploader Express does not restore upload lists. See the Comparison of Image Uploader Editions topic for details.

Maximum number of upload lists allowed for saving is 50.

See Also

Reference

  • loadUploadList(Number) Method
  • saveUploadList(Number) Method

Manual

  • Restoring Upload List


uploadPane.saveUploadList(Number) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Saves the upload list with the specified id.

Syntax

JavaScript

$au.uploader('uploaderID').uploadPane().saveUploadList(id);

Parameters

id

Type: Number

Unique integer value to save the current upload list with this identifier.

Remarks

Note

Image Uploader Express does not restore upload lists. See the Comparison of Image Uploader Editions topic for details.

Maximum number of upload lists allowed for saving is 50.

See Also

Reference

  • loadUploadList(Number) Method
  • resetUploadList(Number) Method

Manual

  • Restoring Upload List


uploadPane Properties

  • Properties
  • Language Filter ( all languages )

The uploadPane type exposes the following properties.

Properties

 | Name | Description
Public property | dropFilesHereImageFormat | Gets or sets an image displayed on the upload pane when it is empty.
Public property | dropFilesHereText | Gets or sets a label displayed on the upload pane when it is empty.
Public property | previewSize | Gets or sets a size of the preview area when in Thumbnails view.
Public property | sortMode | Gets or sets a sort mode of the upload pane.
Public property | viewMode | Gets or sets a view mode for the upload pane.


uploadPane.dropFilesHereImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an image displayed on the upload pane when it is empty.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadPane: {
        //...other params...
        dropFilesHereImageFormat: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadPane().dropFilesHereImageFormat(value);
value = $au.uploader('uploaderID').uploadPane().dropFilesHereImageFormat();

Property Value

Type: String

The image displayed on the upload pane when it is empty. If an empty string is specified, a standard Drop Files Here label is displayed.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies settings of this image has the following syntax:

variable1=value1;variable2=value2;...

The following variables are supported:

Variable | Description
Url | URL to the image. Mandatory.
Width | Width of the image. Optional.
Height | Height of the image. Optional.
Position

Image position. Optional. It can take one of the following values:

  • TopLeft - image will be displayed in the top left corner of the upload pane.
  • TopCenter - image will be displayed in the center of the top of the upload pane.
  • TopRight - image will be displayed in the right top corner of the upload pane.
  • CenterLeft - image will be displayed in the center of the left edge of the upload pane.
  • Center - image will be displayed in the center of the upload pane.
  • CenterRight - image will be displayed in the center of the right edge of the upload pane.
  • BottomLeft - image will be displayed in the bottom left corner of the upload pane.
  • BottomCenter - image will be displayed in the center of the bottom of the upload pane.
  • BottomRight - image will be displayed in the bottom right corner of the upload pane.

Default value is Center.

Note

The image format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • dropFilesHereText Property
  • Aurigma.ImageUploader.UploadPane.DropFilesHereImageFormat ASP.NET Property
  • UploadPane.DropFilesHereImageFormat PHP Property

Manual

  • Layouts
  • Customizing Appearance


uploadPane.dropFilesHereText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a label displayed on the upload pane when it is empty.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadPane: {
        //...other params...
        dropFilesHereText: "Drop files here...",
        //...other params...
    }
})

Property Value

Type: String

The label displayed on the upload pane when it is empty.

Default value is "Drop files here...".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • dropFilesHereImageFormat Property
  • Aurigma.ImageUploader.UploadPane.DropFilesHereText ASP.NET Property
  • UploadPane.DropFilesHereText PHP Property

Manual

  • Layouts


uploadPane.previewSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a size of the preview area when in Thumbnails view.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadPane: {
        //...other params...
        previewSize: 96,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadPane().previewSize(value);
value = $au.uploader('uploaderID').uploadPane().previewSize();

Property Value

Type: Number

The size of the preview area (in pixels). In other words, this property specifies size of square the thumbnail is inscribed in.

Default value is 96.

See Also

Reference

  • Aurigma.ImageUploader.UploadPane.PreviewSize ASP.NET Property
  • UploadPane.PreviewSize PHP Property


uploadPane.sortMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a sort mode of the upload pane.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadPane: {
        //...other params...
        sortMode: "Unsorted",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadPane().sortMode(value);
value = $au.uploader('uploaderID').uploadPane().sortMode();

Property Value

Type: String

The sort mode of the upload pane.

The following values are supported:

Value | Description
Unsorted | Items are unsorted.
Name | Items are sorted by name alphabetically.
Size | Items are sorted by file size.
Type | Items are sorted by file type alphabetically.
Modified | Items are sorted by the date of last modification.
Path | Items are sorted by full path.
Dimensions | Items are sorted by image dimensions.
Note

The sort mode cannot be set to Unsorted value manually.

Default value is "Unsorted".

Remarks

Sort mode is automatically reset to Unsorted when new items are added or re-arranged via drag-n-drop.

Note

If you set the same value twice, the sort order will toggle between ascending and descending and vice versa.

See Also

Reference

  • Aurigma.ImageUploader.UploadPane.SortMode ASP.NET Property
  • UploadPane.SortMode PHP Property


uploadPane.viewMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a view mode for the upload pane.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadPane: {
        //...other params...
        viewMode: "Thumbnails",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadPane().viewMode(value);
value = $au.uploader('uploaderID').uploadPane().viewMode();

Property Value

Type: String

The view mode for the upload pane.

The following values are supported:

Value | Description
Thumbnails | Images are displayed as thumbnails, non-images are displayed as icons. It is possible to attach a description to each file. If a file is recognized as image, it can be cropped and rotated.
Tiles | Each file appears as a thumbnail (or icon for non-image files), with a file name and details (file type, last modification date, and file size) on the right. It is possible to attach a description to each file. If a file is recognized as image, it can be cropped and rotated.
Details | All the files are displayed as a detailed list (icon + filename + info + size + last modification date + type + image dimensions).
List | Files are displayed as small thumbnails (or icons for non-image files) with names on the right.

Default value is "Thumbnails".

See Also

Reference

  • Aurigma.ImageUploader.UploadPane.ViewMode ASP.NET Property
  • UploadPane.ViewMode PHP Property

Manual

  • View Modes


uploadProgressDialog Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the uploading files dialog which appears during the upload.

For a list of all members of this class, see uploadProgressDialog Members.

Syntax

JavaScript

$au.uploadProgressDialog = function() {
}

See Also

Reference

  • uploadProgressDialog Property
  • Aurigma.ImageUploader.UploadProgressDialog ASP.NET Class
  • UploadProgressDialog PHP Class

Manual

  • Customizing Appearance


uploadProgressDialog Members

  • Properties
  • Language Filter ( all languages )

The uploadProgressDialog type exposes the following members.

Properties

 | Name | Description
Public property | cancelUploadButtonText | Gets or sets a caption of the Cancel button on the dialog displayed during the upload.
Public property | estimationText | Gets or sets a caption of the label which displays estimated time of the upload.
Public property | hideButtonText | Gets or sets a caption of the Hide button on the dialog displayed during the instant upload.
Public property | hoursText | Gets or sets a text for the hours unit in the uploading files dialog.
Public property | infoText | Gets or sets a caption of the label which displays the upload propgress information.
Public property | kilobytesText | Gets or sets a text for the kilobytes unit in the uploading files dialog.
Public property | megabytesText | Gets or sets a text for the megabytes unit in the uploading files dialog.
Public property | minutesText | Gets or sets a text for the minutes unit in the uploading files dialog.
Public property | secondsText | Gets or sets a text for the seconds unit in the uploading files dialog.
Public property | timeFormat | Gets or sets a format of the time displayed in the estimationText label.
Public property | titleText | Gets or sets a title of the dialog displayed displayed during the upload.


uploadProgressDialog Properties

  • Properties
  • Language Filter ( all languages )

The uploadProgressDialog type exposes the following properties.

Properties

 | Name | Description
Public property | cancelUploadButtonText | Gets or sets a caption of the Cancel button on the dialog displayed during the upload.
Public property | estimationText | Gets or sets a caption of the label which displays estimated time of the upload.
Public property | hideButtonText | Gets or sets a caption of the Hide button on the dialog displayed during the instant upload.
Public property | hoursText | Gets or sets a text for the hours unit in the uploading files dialog.
Public property | infoText | Gets or sets a caption of the label which displays the upload propgress information.
Public property | kilobytesText | Gets or sets a text for the kilobytes unit in the uploading files dialog.
Public property | megabytesText | Gets or sets a text for the megabytes unit in the uploading files dialog.
Public property | minutesText | Gets or sets a text for the minutes unit in the uploading files dialog.
Public property | secondsText | Gets or sets a text for the seconds unit in the uploading files dialog.
Public property | timeFormat | Gets or sets a format of the time displayed in the estimationText label.
Public property | titleText | Gets or sets a title of the dialog displayed displayed during the upload.


uploadProgressDialog.cancelUploadButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Cancel button on the dialog displayed during the upload.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadProgressDialog: {
        //...other params...
        cancelUploadButtonText: "Cancel",
        //...other params...
    }
})

Property Value

Type: String

The caption of the Cancel button on the uploading files dialog.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.UploadProgressDialog.CancelUploadButtonText ASP.NET Property
  • UploadProgressDialog.CancelUploadButtonText PHP Property


uploadProgressDialog.estimationText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the label which displays estimated time of the upload.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadProgressDialog: {
        //...other params...
        estimationText: "Estimated remaining time: [time]",
        //...other params...
    }
})

Property Value

Type: String

The text of the Estimated remaining time label. It can contain the following placeholder:

[time]
replaced by the estimation of how much time is left.
Note

Format of the displayed time can be configured via the timeFormat property.

Default value is "Estimated remaining time: [time]".

Remarks

Note

The estimation of the upload time may be quite inaccurate and depends on the uploadSettings.progressBytesMode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • progressBytesMode Property
  • timeFormat Property
  • hoursText Property
  • minutesText Property
  • secondsText Property
  • Aurigma.ImageUploader.UploadProgressDialog.EstimationText ASP.NET Property
  • UploadProgressDialog.EstimationText PHP Property


uploadProgressDialog.hideButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the Hide button on the dialog displayed during the instant upload.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadProgressDialog: {
        //...other params...
        hideButtonText: "Hide",
        //...other params...
    }
})

Property Value

Type: String

The caption of the button which hides the uploading files dialog when the instant upload mode is used.

Default value is "Hide".

Remarks

Note

This button arrears when files are uploaded instantly.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • enableInstantUpload Property
  • Aurigma.ImageUploader.UploadProgressDialog.HideButtonText ASP.NET Property
  • UploadProgressDialog.HideButtonText PHP Property


uploadProgressDialog.hoursText Property

  • Supported browsers: Internet Explorer

Gets or sets a text for the hours unit in the uploading files dialog.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadProgressDialog: {
        //...other params...
        hoursText: "hours",
        //...other params...
    }
})

Property Value

Type: String

The text of the hours unit in the uploading files dialog. As this string is inserted at the end of a sentence, you should specify it without capitalization.

Default value is "hours".

Remarks

Note

This string is used when the timeFormat value contains Appearance=Words setting.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • timeFormat Property
  • estimationText Property
  • Aurigma.ImageUploader.UploadProgressDialog.HoursText ASP.NET Property
  • UploadProgressDialog.HoursText PHP Property


uploadProgressDialog.infoText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the label which displays the upload propgress information.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadProgressDialog: {
        //...other params...
        infoText: "Files uploaded [files]/[totalFiles] ([bytes] of [totalBytes])",
        //...other params...
    }
})

Property Value

Type: String

The text of the Files uploaded label. It can contain the following placeholder:

[files]
replaced by the number of files that have already been sent to a server.
[totalFiles]
replaced by the total number of files which should be sent in this upload session.
[bytes]
replaced by the number of bytes that have already been sent to a server.
[totalBytes]
replaced by the total size of the upload session.

Default value is "Files uploaded [files]/[totalFiles] ([bytes] of [totalBytes])".

Remarks

Note

The estimation of the uploaded and total bytes may be quite inaccurate and depends on the uploadSettings.progressBytesMode.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • progressBytesMode Property
  • kilobytesText Property
  • megabytesText Property
  • Aurigma.ImageUploader.UploadProgressDialog.InfoText ASP.NET Property
  • UploadProgressDialog.InfoText PHP Property


uploadProgressDialog.kilobytesText Property

  • Supported browsers: Internet Explorer

Gets or sets a text for the kilobytes unit in the uploading files dialog.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadProgressDialog: {
        //...other params...
        kilobytesText: "Kb",
        //...other params...
    }
})

Property Value

Type: String

The text of the kilobytes unit in the uploading files dialog.

Default value is "Kb".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • infoText Property
  • Aurigma.ImageUploader.UploadProgressDialog.KilobytesText ASP.NET Property
  • UploadProgressDialog.KilobytesText PHP Property


uploadProgressDialog.megabytesText Property

  • Supported browsers: Internet Explorer

Gets or sets a text for the megabytes unit in the uploading files dialog.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadProgressDialog: {
        //...other params...
        megabytesText: "Mb",
        //...other params...
    }
})

Property Value

Type: String

The text of the megabytes unit in the uploading files dialog.

Default value is "Mb".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • infoText Property
  • Aurigma.ImageUploader.UploadProgressDialog.MegabytesText ASP.NET Property
  • UploadProgressDialog.MegabytesText PHP Property


uploadProgressDialog.minutesText Property

  • Supported browsers: Internet Explorer

Gets or sets a text for the minutes unit in the uploading files dialog.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadProgressDialog: {
        //...other params...
        minutesText: "minutes",
        //...other params...
    }
})

Property Value

Type: String

The text of the minutes unit in the uploading files dialog. As this string is inserted at the end of a sentence, you should specify it without capitalization.

Default value is "minutes".

Remarks

Note

This string is used when the timeFormat value contains Appearance=Words setting.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • timeFormat Property
  • estimationText Property
  • Aurigma.ImageUploader.UploadProgressDialog.MinutesText ASP.NET Property
  • UploadProgressDialog.MinutesText PHP Property


uploadProgressDialog.secondsText Property

  • Supported browsers: Internet Explorer

Gets or sets a text for the seconds unit in the uploading files dialog.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadProgressDialog: {
        //...other params...
        secondsText: "seconds",
        //...other params...
    }
})

Property Value

Type: String

The text of the seconds unit in the uploading files dialog. As this string is inserted at the end of a sentence, you should specify it without capitalization.

Default value is "seconds".

Remarks

Note

This string is used when the timeFormat value contains Appearance=Words setting.

This property is necessary for localization of Image Uploader.

See Also

Reference

  • timeFormat Property
  • estimationText Property
  • Aurigma.ImageUploader.UploadProgressDialog.SecondsText ASP.NET Property
  • UploadProgressDialog.SecondsText PHP Property


uploadProgressDialog.timeFormat Property

  • Supported browsers: Internet Explorer

Gets or sets a format of the time displayed in the estimationText label.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadProgressDialog: {
        //...other params...
        timeFormat: "Appearance=ColonSeparated; PresentDirection=HMS; DigitsFormat=NN; HideZero=FALSE",
        //...other params...
    }
})

Property Value

Type: String

The time format string having the following syntax:

variable1=value1;variable2=value2;...

The order and case sensitivity are not important. Possible values are:

Appearance
Sets the view. Possible values: Words (XX hours XX minutes XX seconds), ColonSeparated (XX:XX:XX).
PresentDirection
Sets the order of the output of time. Possible values: any possible combinations of H, M and S symbols.
DigitsFormat
Display or not the leading "0", if a particular value is less than 10. Possible values: N, NN.
HideZero
Hide or not zero values. Possible values: TRUE, FALSE.

Default value is "Appearance=ColonSeparated; PresentDirection=HMS; DigitsFormat=NN; HideZero=FALSE".

Remarks

Here is an examples of the usage of this property. Say, you set the following value for it:

Appearance=Words;PresentDirection=HMS;DigitsFormat=N;HideZero=TRUE

Then all time values will be displayed like this:

5 minutes 30 seconds

or this:

1 hours 15 minutes 30 seconds

See Also

Reference

  • estimationText Property
  • hoursText Property
  • minutesText Property
  • secondsText Property
  • Aurigma.ImageUploader.UploadProgressDialog.TimeFormat ASP.NET Property
  • UploadProgressDialog.TimeFormat PHP Property


uploadProgressDialog.titleText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a title of the dialog displayed displayed during the upload.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadProgressDialog: {
        //...other params...
        titleText: "Uploading files to server",
        //...other params...
    }
})

Property Value

Type: String

The title of the uploading files dialog.

Default value is "Uploading files to server".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.UploadProgressDialog.TitleText ASP.NET Property
  • UploadProgressDialog.TitleText PHP Property


uploadSettings Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents the upload settings.

For a list of all members of this class, see uploadSettings Members.

Syntax

JavaScript

$au.uploadSettings = function() {
}

See Also

Reference

  • uploadSettings Property
  • Aurigma.ImageUploader.UploadSettings ASP.NET Class
  • UploadSettings PHP Class


uploadSettings Members

  • Properties
  • Language Filter ( all languages )

The uploadSettings type exposes the following members.

Properties

 | Name | Description
Public property | actionUrl | Gets or sets a URL to the page files are posted to.
Public property | autoRecoveryMaxAttemptCount | Gets or sets a number of tries that should be performed to submit files.
Public property | autoRecoveryTimeout | Gets or sets an interval in which Image Uploader should try to resume the upload if it was interrupted.
Public property | charset | Gets or sets a charset used to encode the text data submitted by Image Uploader.
Public property | chunkSize | Gets or sets a maximium allowed size of binary data (in bytes) uploaded within a POST request.
Public property | connectionTimeout | Gets or sets a timeout of the HTTP connection.
Public property | enableInstantUpload | Gets or sets a value indicating whether to start sending files right after they are added to the upload pane not waiting for Upload button click.
Public property | filesPerPackage | Gets or sets a number of user-selected files which will be processed and uploaded within a single request.
Public property | progressBytesMode | Gets or sets a value specifying how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server.
Public property | redirectUrl | Gets or sets a URL to which a user will be redirected when the upload successfully completes.
Public property | uploadConverterOutputSeparately | Gets or sets a value indicating whether to send each converted file in a separate request.


uploadSettings Properties

  • Properties
  • Language Filter ( all languages )

The uploadSettings type exposes the following properties.

Properties

 | Name | Description
Public property | actionUrl | Gets or sets a URL to the page files are posted to.
Public property | autoRecoveryMaxAttemptCount | Gets or sets a number of tries that should be performed to submit files.
Public property | autoRecoveryTimeout | Gets or sets an interval in which Image Uploader should try to resume the upload if it was interrupted.
Public property | charset | Gets or sets a charset used to encode the text data submitted by Image Uploader.
Public property | chunkSize | Gets or sets a maximium allowed size of binary data (in bytes) uploaded within a POST request.
Public property | connectionTimeout | Gets or sets a timeout of the HTTP connection.
Public property | enableInstantUpload | Gets or sets a value indicating whether to start sending files right after they are added to the upload pane not waiting for Upload button click.
Public property | filesPerPackage | Gets or sets a number of user-selected files which will be processed and uploaded within a single request.
Public property | progressBytesMode | Gets or sets a value specifying how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server.
Public property | redirectUrl | Gets or sets a URL to which a user will be redirected when the upload successfully completes.
Public property | uploadConverterOutputSeparately | Gets or sets a value indicating whether to send each converted file in a separate request.


uploadSettings.actionUrl Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to the page files are posted to.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadSettings: {
        //...other params...
        actionUrl: ".",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadSettings().actionUrl(value);
value = $au.uploader('uploaderID').uploadSettings().actionUrl();

Property Value

Type: String

The URL to the page files are posted to. When specifying this value, take into account the following cases:

Using Quotation Marks and Semicolons

URLs can contain semicolon or quotation mark characters (like this one: http://upload.server.com/uploadFile;jsessionid=123?param='value'). If so, to avoid parameter parsing errors enclose such URLs in single (' ') or double (" ") quotes. Additionally, quotation marks (both single ' and double ") inside URLs should be escaped with a backslash:

"http://upload.server.com/uploadFile;jsessionid=123?param=\'value\'"

Uploading to the Same Page

If you want to submit files to the same page where Image Uploader is hosted, specify the dot character (.) as a value of this property.

Using Absolute and Relative URLs

URLs can be both absolute (e.g. http://domain.com/upload/upload.aspx) and relative to the current page (e.g. /upload/upload.aspx).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/default.aspx page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/upload/upload.aspx" | http://domain.com/upload/upload.aspx
"./upload/upload.aspx" | http://domain.com/ImageUploader/upload/upload.aspx
"upload/upload.aspx" | http://domain.com/ImageUploader/upload/upload.aspx
"upload.aspx" | http://domain.com/ImageUploader/upload.aspx

Default value is ".".

Remarks

That page should contain the server code which parses the upload request, saves files to necessary folders on server and performs any other additional actions.

Note

Usually this URL must have a specific extension (depending on the web server settings). For ASP platform it should be .asp, for ASP.NET the extension is .aspx, for PHP it is .php, for Perl it can be .pl or .cgi, etc. In other words, the file containing this script should have the extension registered in the settings of your web server as a server page. Otherwise upload will fail.

See Also

Reference

  • redirectUrl Property
  • Aurigma.ImageUploader.UploadSettings.ActionUrl ASP.NET Property
  • UploadSettings.ActionUrl PHP Property

Manual

  • Configuring Common Upload Settings


uploadSettings.autoRecoveryMaxAttemptCount Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a number of tries that should be performed to submit files.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadSettings: {
        //...other params...
        autoRecoveryMaxAttemptCount: 1,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadSettings().autoRecoveryMaxAttemptCount(value);
value = $au.uploader('uploaderID').uploadSettings().autoRecoveryMaxAttemptCount();

Property Value

Type: Number

The number of attempts for upload to do (including the very first attempt). If you want to disable automatic resuming feature, set this property to 1.

Default value is 1.

Remarks

Note

Image Uploader Express does not support automatic upload recovery. See the Comparison of Image Uploader Editions topic for details.

Time interval between each next retry is configured with the autoRecoveryTimeout property.

Note

Image Uploader tries to resend the request that has failed. If the request (package) contains more than one file, these files will be resent again. It means that if you use the auto-recovering feature, the optimal value for the filesPerPackage property would be 1.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.AutoRecoveryMaxAttemptCount ASP.NET Property
  • UploadSettings.AutoRecoveryMaxAttemptCount PHP Property

Manual

  • Configuring Fail-Safe Upload


uploadSettings.autoRecoveryTimeout Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an interval in which Image Uploader should try to resume the upload if it was interrupted.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadSettings: {
        //...other params...
        autoRecoveryTimeout: 5000,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadSettings().autoRecoveryTimeout(value);
value = $au.uploader('uploaderID').uploadSettings().autoRecoveryTimeout();

Property Value

Type: Number

The number of milliseconds the Image Uploader should wait between attempts.

Default value is 5000.

Remarks

Note

Image Uploader Express does not support automatic upload recovery. See the Comparison of Image Uploader Editions topic for details.

This parameter takes effect if only the autoRecoveryMaxAttemptCount is greater than 1.

Note

Image Uploader tries to resend the request that has failed. If the request (package) contains more than one file, these files will be resent again. It means that if you use the auto-recovering feature, the optimal value for the filesPerPackage property would be 1.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.AutoRecoveryTimeout ASP.NET Property
  • UploadSettings.AutoRecoveryTimeout PHP Property

Manual

  • Configuring Fail-Safe Upload


uploadSettings.charset Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a charset used to encode the text data submitted by Image Uploader.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadSettings: {
        //...other params...
        charset: "UTF-8",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadSettings().charset(value);
value = $au.uploader('uploaderID').uploadSettings().charset();

Property Value

Type: String

The charset. See possible values in the Remarks section.

Default value is "UTF-8".

Remarks

The table below contains some supported charsets. Visit Sun site for a full list of supported encodings.

Charset | Description
US-ASCII | Seven-bit ASCII, a.k.a. ISO646-US, a.k.a. the Basic Latin block of the Unicode character set.
ISO-8859-1 | ISO Latin Alphabet No. 1, a.k.a. ISO-LATIN-1.
UTF-8 | Eight-bit UCS Transformation Format.
UTF-16BE | Sixteen-bit UCS Transformation Format, big-endian byte order.
UTF-16LE | Sixteen-bit UCS Transformation Format, little-endian byte order.
UTF-16 | Sixteen-bit UCS Transformation Format, byte order identified by an optional byte-order mark.
windows-1250 | Windows Eastern European.
windows-1251 | Windows Cyrillic.
windows-1252 | Windows Latin-1.
windows-1253 | Windows Greek.
windows-1254 | Windows Turkish.
windows-1257 | Windows Baltic.
KOI8-R | KOI-8, Russian.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.Charset ASP.NET Property
  • UploadSettings.Charset PHP Property


uploadSettings.chunkSize Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a maximium allowed size of binary data (in bytes) uploaded within a POST request.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadSettings: {
        //...other params...
        chunkSize: 0,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadSettings().chunkSize(value);
value = $au.uploader('uploaderID').uploadSettings().chunkSize();

Property Value

Type: Number

The number of bytes allowed to upload within a request. When this value is 0, converted file uploaded entirely in accordiance with filesPerPackage and uploadConverterOutputSeparately properties.

Default value is 0.

Remarks

When this property is greater than 0, Image Uploader adds converted files and metadata to a POST request until the request length exceeds chunkSize + metadata size bytes. If the last added file does not meet the chunk size limitation, Image Uploader adds just a portion of this file to complete this chunk. The remaining portion will be added at the beginning of the next chunk. Each chunk is submitted to a server as a separate request. It gives a number of benefits: makes each request compartible with maximum POST request length limitation and allows resuming partially uploaded files.

Note

When you turn this mode on, it is highly recommended to use Image Uploader ASP.NET or Image Uploader PHP to handle upload on the server side. Both these wrappers automatically bundle pieces of one file, uploaded in separated chunks, and provide an access to this file as if it was uploaded entirely.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.ChunkSize ASP.NET Property
  • UploadSettings.ChunkSize PHP Property

Manual

  • Sending All Files at Once or in Several Parts


uploadSettings.connectionTimeout Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a timeout of the HTTP connection.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadSettings: {
        //...other params...
        connectionTimeout: 0,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadSettings().connectionTimeout(value);
value = $au.uploader('uploaderID').uploadSettings().connectionTimeout();

Property Value

Type: Number

The HTTP timeout (in milliseconds). If 0, timeout is infinite (i.e. disabled).

Default value is 0.

Remarks

When timeout expires, the Image Uploader assumes that the connection has been lost and terminates the upload process.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.ConnectionTimeout ASP.NET Property
  • UploadSettings.ConnectionTimeout PHP Property


uploadSettings.enableInstantUpload Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to start sending files right after they are added to the upload pane not waiting for Upload button click.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadSettings: {
        //...other params...
        enableInstantUpload: false,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadSettings().enableInstantUpload(value);
value = $au.uploader('uploaderID').uploadSettings().enableInstantUpload();

Property Value

Type: Boolean

If true, the upload process starts instantly when files are added to the upload pane. Otherwise, the upload starts when the Upload button is clicked.

Default value is false.

Remarks

Note

This property takes effect in OnePane layout only.

If this property is true it causes the following changes in Image Uploader user interface:

  • The uploading files dialog is initially hidden.
  • The status pane is equipped with a progress bar indicating the upload progress.
  • The uploading files dialog can be shown by clicking the status pane.
  • The uploading files dialog contains the Hide button which makes this dialog invisible.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.EnableInstantUpload ASP.NET Property
  • UploadSettings.EnableInstantUpload PHP Property

Manual

  • Layouts


uploadSettings.filesPerPackage Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a number of user-selected files which will be processed and uploaded within a single request.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadSettings: {
        //...other params...
        filesPerPackage: 0,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadSettings().filesPerPackage(value);
value = $au.uploader('uploaderID').uploadSettings().filesPerPackage();

Property Value

Type: Number

The number of user-serlected files that will be processed and uploaded within a single request. If more files are selected, they are submitted in separate requests. When this value is 0, all the files are uploaded in one request.

Default value is 0.

Remarks

When this property is greater than 0, Image Uploader sends converted files and metadata for filesPerPackage user-selected files per each request. Typical scenario is when you set this value to 1, i.e. every user-selected file is processed and uploaded in a separate request. It gives a number of benefits: reduces amount of memory used on the server to process requests from Image Uploader and allows resuming partially completed upload if it has been broken, etc.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.FilesPerPackage ASP.NET Property
  • UploadSettings.FilesPerPackage PHP Property

Manual

  • Sending All Files at Once or in Several Parts
  • Configuring Fail-Safe Upload


uploadSettings.progressBytesMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value specifying how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadSettings: {
        //...other params...
        progressBytesMode: "ByPackageSize",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadSettings().progressBytesMode(value);
value = $au.uploader('uploaderID').uploadSettings().progressBytesMode();

Property Value

Type: String

The progress bytes estimation mode.

The following values are supported:

Value | Description
ByPackageSize | The size of the uploaded session and the uploaded bytes are measured by the size of the current package. Thus, this mode is the nearest estimation of the uploaded bytes when you set several converters and upload all files in one package (i.e. filesPerPackage is 0).
BySourceSize | The size of the upload session and the uploaded bytes are measured by sizes of user-selected files. For example, if you select two files of 5 and 10 Mb, the total upload size will be 15 Mb and the amount of uploaded bytes will grow from 0 to 15 Mb during the upload, regardless of converted files and other auxiliary data. Thus, this mode is the nearest estimation of the uploaded bytes when you upload original files only.

Default value is "ByPackageSize".

Remarks

This property determines how to estimate the total size of the upload session as well as the amount of bytes that have already been sent to a server. These data are used in the uploading files dialog and the Progress event.

See Also

Reference

  • Progress Event
  • filesPerPackage Property
  • Aurigma.ImageUploader.UploadSettings.ProgressBytesMode ASP.NET Property
  • UploadSettings.ProgressBytesMode PHP Property

Manual

  • Sending All Files at Once or in Several Parts


uploadSettings.redirectUrl Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a URL to which a user will be redirected when the upload successfully completes.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadSettings: {
        //...other params...
        redirectUrl: "",
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadSettings().redirectUrl(value);
value = $au.uploader('uploaderID').uploadSettings().redirectUrl();

Property Value

Type: String

The URL to which a user will be redirected when the upload successfully completes. If it is an empty string, Image Uploader will not try to redirect.

Default value is "".

See Also

Reference

  • actionUrl Property
  • Aurigma.ImageUploader.UploadSettings.RedirectUrl ASP.NET Property
  • UploadSettings.RedirectUrl PHP Property

Manual

  • Configuring Common Upload Settings


uploadSettings.uploadConverterOutputSeparately Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to send each converted file in a separate request.

Syntax

JavaScript

Initialize

$au.uploader({
    uploadSettings: {
        //...other params...
        uploadConverterOutputSeparately: false,
        //...other params...
    }
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadSettings().uploadConverterOutputSeparately(value);
value = $au.uploader('uploaderID').uploadSettings().uploadConverterOutputSeparately();

Property Value

Type: Boolean

If true, each converted file is uploaded in a separate POST request.

Default value is false.

Remarks

Note

When Image Uploader sends converted files separately it does not take into account the filesPerPackage value. However, if the chunkSize is greater than 0, Image Uploader divides converted files, which size exceeds this value, into chunks and sends them separately.

See Also

Reference

  • Aurigma.ImageUploader.UploadSettings.UploadConverterOutputSeparately ASP.NET Property
  • UploadSettings.UploadConverterOutputSeparately PHP Property

Manual

  • Sending All Files at Once or in Several Parts


uploader Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class is intended for embedding Image Uploader into a web page.

For a list of all members of this class, see uploader Members.

Syntax

JavaScript

$au.uploader = function() {
}

Remarks

This class allows configuring Image Uploader as a common JavaScript object.

See Also

Reference

  • Aurigma.ImageUploader.Uploader ASP.NET Class
  • Uploader PHP Class

Manual

  • Quick Start with Image Uploader JavaScript


uploader Members

  • Properties
  • Methods
  • Language Filter ( all languages )

The uploader type exposes the following members.

Methods

 | Name | Description
Public method | cancelUpload | Stops the upload process.
Public method | getHtml | Generates the HTML code which will embed Image Uploader and returns it as a string.
Public method | set(Object) | Sets the specified properties.
Public method | upload | Starts the upload process.
Public method | writeHtml | Generates the HTML code which will embed Image Uploader and writes this code directly into the page.

Properties

 | Name | Description
Public property | activeXControl | Gets or sets Image Uploader ActiveX control settings.
Public property | addFilesProgressDialog | Gets or sets settings of the dialog which appears when a user selects quite a lot of files.
Public property | authenticationDialog | Gets or sets settings of the authentication dialog.
Public property | auxiliaryTextColor | Gets or sets a color of auxiliary text lables.
Public property | backgroundColor | Gets or sets a background color of Image Uploader panes and editors.
Public property | borderStyle | Gets or sets a border style of Image Uploader.
Public property | cancelUploadButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Cancel button.
Public property | cancelUploadButtonText | Gets or sets a list of images that are displayed in different states of the button which aborts the upload.
Public property | contextMenu | Gets or sets the context menu settings.
Public property | converters | Gets or sets a collection of converters.
Public property | deleteFilesDialog | Gets or sets the settings of the delete confirmation dialog.
Public property | descriptionEditor | Gets or sets the description editor settings.
Public property | detailsViewColumns | Gets or sets titles of columns displayed in the Details view.
Public property | dialogBorderColor | Gets or sets a color of a dialog border.
Public property | dialogColor | Gets or sets a color of Image Uploader dialogs.
Public property | enableAutoRotation | Gets or sets a value indicating whether the automatic EXIF-based photo rotation feature is enabled.
Public property | enableContextMenu | Gets or sets a value indicating whether to disaplay the context menu.
Public property | enableDescriptionEditor | Gets or sets a value indicating whether it is possible to add descriptions to files.
Public property | enableDragAndDrop | Gets or sets a value indicating whether internal drag-and-drop operations are supported.
Public property | enableFileViewer | Gets or sets a value indicating whether to open the file in associated viewer software when it is double-clicked.
Public property | enableImageEditor | Gets or sets a value indicating whether it is possible to open images in the image editor by clicking the image editor icon or the corresponging context menu option.
Public property | enableOriginalFilesDeletion | Gets or sets a value indicating whether successfully uploaded files should be deleted.
Public property | enableRotation | Gets or sets a value indicating whether it is possible to rotate images via Image Uploader GUI.
Public property | enableStatusPane | Gets or sets a value indicating whether the status pane should be displayed.
Public property | enableUploadPane | Gets or sets a value indicating whether the upload pane should be displayed.
Public property | enableUploadProgress | Gets or sets a value indicating whether the uploading files dialog is shown during the upload.
Public property | events | Gets or sets a collection of client-side events.
Public property | files | Gets or sets a collection of user-selected files.
Public property | folderPane | Gets or sets the folder pane settings.
Public property | folderProcessingMode | Gets or sets the folder processing mode.
Public property | headerColor | Gets or sets a color of Image Uploader headers.
Public property | headerTextColor | Gets or sets a color of text in Image Uploader headers.
Public property | height | Gets or sets a height of the control.
Public property | hyperlinkColor | Gets or sets a color of all the hyperlink elements.
Public property | id | Gets or sets a unique identifier of the control.
Public property | imageEditor | Gets or sets the image editor settings.
Public property | informationBar | Gets or sets the information bar settings.
Public property | javaControl | Gets or sets Image Uploader Java applet settings.
Public property | licenseKey | Gets or sets a license key which allows evaluating, developing, or publishing Image Uploader according to the license key type (trial, development, or full).
Public property | loadingFolderContentText | Gets or sets a text which is displayed while Image Uploader scans the folder content and builds the file list.
Public property | messages | Gets or sets messages.
Public property | metadata | Gets or sets an additional upload data.
Public property | paneFont | Gets or sets a font format for all Image Uploader buttons and labels, except titles.
Public property | paneItem | Gets or sets the pane item settings.
Public property | paneLayout | Gets of sets Image Uploader layout.
Public property | panelBorderColor | Gets or sets a color of borders between Image Uploader panes.
Public property | panelColor | Gets or sets a color of command areas.
Public property | pasteFileNameTemplate | Gets or sets a file name template for files pasted from clipboard.
Public property | restrictions | Gets or sets upload restrictions.
Public property | statusPane | Gets or sets the status pane settings.
Public property | textColor | Gets or sets a color of primary labels.
Public property | titleFont | Gets or sets a font format for Image Uploader titles.
Public property | treePane | Gets or sets the tree pane settings.
Public property | uploadButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Upload button.
Public property | uploadButtonText | Gets or sets a caption of the button which starts the upload of the selected files.
Public property | uploadPane | Gets the upload pane settings.
Public property | uploadProgressDialog | Gets or sets the upload progress dialog settings.
Public property | uploadSettings | Gets or sets upload settings.
Public property | width | Gets or sets a width of the control.


uploader Methods

  • Methods
  • Language Filter ( all languages )

The uploader type exposes the following methods.

Methods

 | Name | Description
Public method | cancelUpload | Stops the upload process.
Public method | getHtml | Generates the HTML code which will embed Image Uploader and returns it as a string.
Public method | set(Object) | Sets the specified properties.
Public method | upload | Starts the upload process.
Public method | writeHtml | Generates the HTML code which will embed Image Uploader and writes this code directly into the page.


uploader.cancelUpload Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Stops the upload process.

Syntax

JavaScript

$au.uploader('uploaderID').cancelUpload();

Remarks

It works in the same manner as if the Cancel button was clicked.

See Also

Reference

  • upload() Method


uploader.getHtml Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Generates the HTML code which will embed Image Uploader and returns it as a string.

Syntax

JavaScript

$au.uploader('uploaderID').getHtml();

Return Value

Type: String

Image Uploader embedding code.


uploader.set(Object) Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets the specified properties.

Syntax

JavaScript

$au.uploader('uploaderID').set(paramsObj);

Parameters

paramsObj

Type: Object

A list of property names and values in JSON format.

Example

JavaScript

var u = $au.uploader({id: 'Uploader1'});
u.set({ width: '660px',
    height: '480px',
    licenseKey: 'XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY',
    uploadSettings: {actionUrl: 'upload.aspx', redirectUrl: 'gallery.aspx'}
});


uploader.upload Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Starts the upload process.

Syntax

JavaScript

$au.uploader('uploaderID').upload();

Remarks

It works in the same manner as if the Upload button was clicked.

Files are uploaded to the URL specified by the actionUrl property. If it is necessary to upload not just files, but some additional data, you can use the metadata properties. When upload completes, redirection to the redirectUrl occurs.

Note

When Image Uploader uploads files, this method call is ignored (and the appropriate button is disabled). You should stop it first using the cancelUpload() method.

See Also

Reference

  • cancelUpload() Method


uploader.writeHtml Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Generates the HTML code which will embed Image Uploader and writes this code directly into the page.

Syntax

JavaScript

$au.uploader('uploaderID').writeHtml();

Remarks

Note

As soon as you call the writeHtml(), all necessary HTML code is inserted into the page at the current position. Alternatively, you can get the string with appropriate HTML code using the getHtml() method, and write it to the necessary position manually (maybe with some modifications).

See Also

Manual

  • Quick Start with Image Uploader JavaScript


uploader Properties

  • Properties
  • Language Filter ( all languages )

The uploader type exposes the following properties.

Properties

 | Name | Description
Public property | activeXControl | Gets or sets Image Uploader ActiveX control settings.
Public property | addFilesProgressDialog | Gets or sets settings of the dialog which appears when a user selects quite a lot of files.
Public property | authenticationDialog | Gets or sets settings of the authentication dialog.
Public property | auxiliaryTextColor | Gets or sets a color of auxiliary text lables.
Public property | backgroundColor | Gets or sets a background color of Image Uploader panes and editors.
Public property | borderStyle | Gets or sets a border style of Image Uploader.
Public property | cancelUploadButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Cancel button.
Public property | cancelUploadButtonText | Gets or sets a list of images that are displayed in different states of the button which aborts the upload.
Public property | contextMenu | Gets or sets the context menu settings.
Public property | converters | Gets or sets a collection of converters.
Public property | deleteFilesDialog | Gets or sets the settings of the delete confirmation dialog.
Public property | descriptionEditor | Gets or sets the description editor settings.
Public property | detailsViewColumns | Gets or sets titles of columns displayed in the Details view.
Public property | dialogBorderColor | Gets or sets a color of a dialog border.
Public property | dialogColor | Gets or sets a color of Image Uploader dialogs.
Public property | enableAutoRotation | Gets or sets a value indicating whether the automatic EXIF-based photo rotation feature is enabled.
Public property | enableContextMenu | Gets or sets a value indicating whether to disaplay the context menu.
Public property | enableDescriptionEditor | Gets or sets a value indicating whether it is possible to add descriptions to files.
Public property | enableDragAndDrop | Gets or sets a value indicating whether internal drag-and-drop operations are supported.
Public property | enableFileViewer | Gets or sets a value indicating whether to open the file in associated viewer software when it is double-clicked.
Public property | enableImageEditor | Gets or sets a value indicating whether it is possible to open images in the image editor by clicking the image editor icon or the corresponging context menu option.
Public property | enableOriginalFilesDeletion | Gets or sets a value indicating whether successfully uploaded files should be deleted.
Public property | enableRotation | Gets or sets a value indicating whether it is possible to rotate images via Image Uploader GUI.
Public property | enableStatusPane | Gets or sets a value indicating whether the status pane should be displayed.
Public property | enableUploadPane | Gets or sets a value indicating whether the upload pane should be displayed.
Public property | enableUploadProgress | Gets or sets a value indicating whether the uploading files dialog is shown during the upload.
Public property | events | Gets or sets a collection of client-side events.
Public property | files | Gets or sets a collection of user-selected files.
Public property | folderPane | Gets or sets the folder pane settings.
Public property | folderProcessingMode | Gets or sets the folder processing mode.
Public property | headerColor | Gets or sets a color of Image Uploader headers.
Public property | headerTextColor | Gets or sets a color of text in Image Uploader headers.
Public property | height | Gets or sets a height of the control.
Public property | hyperlinkColor | Gets or sets a color of all the hyperlink elements.
Public property | id | Gets or sets a unique identifier of the control.
Public property | imageEditor | Gets or sets the image editor settings.
Public property | informationBar | Gets or sets the information bar settings.
Public property | javaControl | Gets or sets Image Uploader Java applet settings.
Public property | licenseKey | Gets or sets a license key which allows evaluating, developing, or publishing Image Uploader according to the license key type (trial, development, or full).
Public property | loadingFolderContentText | Gets or sets a text which is displayed while Image Uploader scans the folder content and builds the file list.
Public property | messages | Gets or sets messages.
Public property | metadata | Gets or sets an additional upload data.
Public property | paneFont | Gets or sets a font format for all Image Uploader buttons and labels, except titles.
Public property | paneItem | Gets or sets the pane item settings.
Public property | paneLayout | Gets of sets Image Uploader layout.
Public property | panelBorderColor | Gets or sets a color of borders between Image Uploader panes.
Public property | panelColor | Gets or sets a color of command areas.
Public property | pasteFileNameTemplate | Gets or sets a file name template for files pasted from clipboard.
Public property | restrictions | Gets or sets upload restrictions.
Public property | statusPane | Gets or sets the status pane settings.
Public property | textColor | Gets or sets a color of primary labels.
Public property | titleFont | Gets or sets a font format for Image Uploader titles.
Public property | treePane | Gets or sets the tree pane settings.
Public property | uploadButtonImageFormat | Gets or sets a list of images that are displayed in different states of the Upload button.
Public property | uploadButtonText | Gets or sets a caption of the button which starts the upload of the selected files.
Public property | uploadPane | Gets the upload pane settings.
Public property | uploadProgressDialog | Gets or sets the upload progress dialog settings.
Public property | uploadSettings | Gets or sets upload settings.
Public property | width | Gets or sets a width of the control.


uploader.activeXControl Property

  • Supported browsers: Internet Explorer

Gets or sets Image Uploader ActiveX control settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    activeXControl: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').activeXControl(value);
value = $au.uploader('uploaderID').activeXControl();

Property Value

Type: $au.activeXControl

Image Uploader ActiveX control settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.ActiveXControl ASP.NET Property
  • Uploader.ActiveXControl PHP Property

Manual

  • Using Private-label Version of Image Uploader JavaScript


uploader.addFilesProgressDialog Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets settings of the dialog which appears when a user selects quite a lot of files.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    addFilesProgressDialog: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').addFilesProgressDialog(value);
value = $au.uploader('uploaderID').addFilesProgressDialog();

Property Value

Type: $au.addFilesProgressDialog

Settings of the dialog which appears when a user selects quite a lot of files.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.AddFilesProgressDialog ASP.NET Property
  • Uploader.AddFilesProgressDialog PHP Property


uploader.authenticationDialog Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets settings of the authentication dialog.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    authenticationDialog: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').authenticationDialog(value);
value = $au.uploader('uploaderID').authenticationDialog();

Property Value

Type: $au.authenticationDialog

Settings of the authentication dialog.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.AuthenticationDialog ASP.NET Property
  • Uploader.AuthenticationDialog PHP Property


uploader.auxiliaryTextColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of auxiliary text lables.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    auxiliaryTextColor: "#8b8b8b",
    //...other params...
})

Property Value

Type: String

The color of of the following labels:

  • a prompt inside the search box;
  • a prompt inside the description editor;
  • file details in the Tiles view;
  • image details and a prompt in the image editor.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#8b8b8b".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.AuxiliaryTextColor ASP.NET Property
  • Uploader.AuxiliaryTextColor PHP Property


uploader.backgroundColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a background color of Image Uploader panes and editors.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    backgroundColor: "#ffffff",
    //...other params...
})

Property Value

Type: String

The background color of the following elements:

  • all the panes;
  • image editor;
  • description editor;
  • search box;
  • files adding and files uploading dialogs.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#ffffff".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.BackgroundColor ASP.NET Property
  • Uploader.BackgroundColor PHP Property


uploader.borderStyle Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a border style of Image Uploader.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    borderStyle: "Fixed3D",
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').borderStyle(value);
value = $au.uploader('uploaderID').borderStyle();

Property Value

Type: String

The Image Uploader border style.

The following values are supported:

Value | Description
None | No border.
Fixed3D | 3D-like border style.
FixedSingle | Classic single line border style.

Default value is "Fixed3D".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.BorderStyle ASP.NET Property
  • Uploader.BorderStyle PHP Property


uploader.cancelUploadButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the Cancel button.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    cancelUploadButtonImageFormat: "",
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').cancelUploadButtonImageFormat(value);
value = $au.uploader('uploaderID').cancelUploadButtonImageFormat();

Property Value

Type: String

The list of custom images of the Cancel button.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • cancelUploadButtonText Property
  • Aurigma.ImageUploader.Uploader.CancelUploadButtonImageFormat ASP.NET Property
  • Uploader.CancelUploadButtonImageFormat PHP Property


uploader.cancelUploadButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the button which aborts the upload.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    cancelUploadButtonText: "Cancel",
    //...other params...
})

Property Value

Type: String

The caption of the Cancel button.

Default value is "Cancel".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • cancelUploadButtonImageFormat Property
  • Aurigma.ImageUploader.Uploader.CancelUploadButtonText ASP.NET Property
  • Uploader.CancelUploadButtonText PHP Property


uploader.contextMenu Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the context menu settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    contextMenu: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').contextMenu(value);
value = $au.uploader('uploaderID').contextMenu();

Property Value

Type: $au.contextMenu

The settings of the context menu.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.ContextMenu ASP.NET Property
  • Uploader.ContextMenu PHP Property


uploader.converters Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a collection of converters.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    converters: [],
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').converters(value);
value = $au.uploader('uploaderID').converters();

Property Value

Type: $au.converters

The collection of converters.

Remarks

Each conveter configures a one converted file (original file as is, thumbnail created from original image file, icon associated with original file, or original file compressed into ZIP archive) that will be uploaded for each of the user-selected files.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Converters ASP.NET Property
  • Uploader.Converters PHP Property

Manual

  • Configuring Files to be Uploaded


uploader.deleteFilesDialog Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets the settings of the delete confirmation dialog.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    deleteFilesDialog: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').deleteFilesDialog(value);
value = $au.uploader('uploaderID').deleteFilesDialog();

Property Value

Type: $au.deleteFilesDialog

The delete confirmation dialog settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.DeleteFilesDialog ASP.NET Property
  • Uploader.DeleteFilesDialog PHP Property


uploader.descriptionEditor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the description editor settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    descriptionEditor: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').descriptionEditor(value);
value = $au.uploader('uploaderID').descriptionEditor();

Property Value

Type: $au.descriptionEditor

The settings of the description editor.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.DescriptionEditor ASP.NET Property
  • Uploader.DescriptionEditor PHP Property


uploader.detailsViewColumns Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets titles of columns displayed in the Details view.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    detailsViewColumns: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').detailsViewColumns(value);
value = $au.uploader('uploaderID').detailsViewColumns();

Property Value

Type: $au.detailsViewColumns

The titles of columns displayed in the Details view.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.DetailsViewColumns ASP.NET Property
  • Uploader.DetailsViewColumns PHP Property

Manual

  • View Modes


uploader.dialogBorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of a dialog border.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    dialogBorderColor: "#98b6ca",
    //...other params...
})

Property Value

Type: String

The color of a dialog border.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#98b6ca".

Remarks

This property affects the following dialogs:

  • description editor,
  • files adding dialog,
  • files uploading dialog.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.DialogBorderColor ASP.NET Property
  • Uploader.DialogBorderColor PHP Property


uploader.dialogColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of Image Uploader dialogs.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    dialogColor: "#e7f7ff",
    //...other params...
})

Property Value

Type: String

The color of Image Uploader dialogs.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#e7f7ff".

Remarks

This property affects the following dialogs:

  • description editor,
  • files adding dialog,
  • files uploading dialog.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.DialogColor ASP.NET Property
  • Uploader.DialogColor PHP Property


uploader.enableAutoRotation Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the automatic EXIF-based photo rotation feature is enabled.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    enableAutoRotation: false,
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').enableAutoRotation(value);
value = $au.uploader('uploaderID').enableAutoRotation();

Property Value

Type: Boolean

If true, Image Uploader automatically extracts the orientation information from an image and automatically rotates it. Otherwise, only manual rotation is available.

Default value is false.

Remarks

This feature works only for those photos which store EXIF information and orientation details are written there. Keep in mind that not each camera can recognize orientation properly, and therefore Image Uploader will not be able to rotate it.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableAutoRotation ASP.NET Property
  • Uploader.EnableAutoRotation PHP Property


uploader.enableContextMenu Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to disaplay the context menu.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    enableContextMenu: true,
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').enableContextMenu(value);
value = $au.uploader('uploaderID').enableContextMenu();

Property Value

Type: Boolean

If true, context menu is displayed when a user right-clicks panes and items; otherwise, right-clicks cause nothing.

Default value is true.

See Also

Reference

  • contextMenu Class
  • Aurigma.ImageUploader.Uploader.EnableContextMenu ASP.NET Property
  • Uploader.EnableContextMenu PHP Property


uploader.enableDescriptionEditor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is possible to add descriptions to files.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    enableDescriptionEditor: true,
    //...other params...
})

Property Value

Type: Boolean

If true, a user can add descriptions in the following ways:

  • by clicking the description control which appears when a mouse pointer hovers over the file;
  • by filling a special field in the image editor;
  • via the Edit description... option of the context menu.

Otherwise, descriptions can be added through the description property only.

Default value is true.

See Also

Reference

  • descriptionEditor Class
  • imageEditor Class
  • Aurigma.ImageUploader.Uploader.EnableDescriptionEditor ASP.NET Property
  • Uploader.EnableDescriptionEditor PHP Property

Manual

  • Additional Controls and Indicators


uploader.enableDragAndDrop Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether internal drag-and-drop operations are supported.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    enableDragAndDrop: true,
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').enableDragAndDrop(value);
value = $au.uploader('uploaderID').enableDragAndDrop();

Property Value

Type: Boolean

If true, a user can use drag-and-drop to:

  • add files from the folder pane to the upload pane in ThreePanes layout;
  • reorder files in the upload pane in both layouts.

Otherwise, only external drag-and-drop (from Windows Explorer, Finder, or other shell) operations are supported.

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableDragAndDrop ASP.NET Property
  • Uploader.EnableDragAndDrop PHP Property

Manual

  • Layouts


uploader.enableFileViewer Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether to open the file in associated viewer software when it is double-clicked.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    enableFileViewer: true,
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').enableFileViewer(value);
value = $au.uploader('uploaderID').enableFileViewer();

Property Value

Type: Boolean

If true, the file is opened in the external file viewer by double-clicking. Otherwise, double-click causes nothing.

Default value is true.

Remarks

If subfolders are shown (folderProcessingMode is show or upload) double-clicking subfolders navigates to them regardless of the enableFileViewer value.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableFileViewer ASP.NET Property
  • Uploader.EnableFileViewer PHP Property


uploader.enableImageEditor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is possible to open images in the image editor by clicking the image editor icon or the corresponging context menu option.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    enableImageEditor: true,
    //...other params...
})

Property Value

Type: Boolean

If true, any image in the folder or upload pane can be opened in the image editor; otherwise, the image editor icon and the Edit image... context menu are hidden.

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableImageEditor ASP.NET Property
  • Uploader.EnableImageEditor PHP Property


uploader.enableOriginalFilesDeletion Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether successfully uploaded files should be deleted.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    enableOriginalFilesDeletion: false,
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').enableOriginalFilesDeletion(value);
value = $au.uploader('uploaderID').enableOriginalFilesDeletion();

Property Value

Type: Boolean

If true, after successful upload Image Uploader shows a dialog, asking a user whether the uploaded files should be deleted. If a user clicks Yes, the files will be deleted.

Default value is false.

Remarks

Note

A difference between Image Uploader behavior in Internet Explorer and other supported browsers is the following. When Image Uploader deletes files in Internet Explorer, it moves them in the way specified in the Recycle Bin properties. By default, a standard delete confirmation dialog appears and files are moved to the Recycle Bin if a user clicks Yes. However, if Image Uploader deletes files in any of other supported browsers, the internal delete confirmation dialog appears and files are removed permanently when a user clicks Yes.

If the file cannot be deleted, the deletingFilesError message appears.

See Also

Reference

  • deleteFilesDialog Class
  • Aurigma.ImageUploader.Uploader.EnableOriginalFilesDeletion ASP.NET Property
  • Uploader.EnableOriginalFilesDeletion PHP Property


uploader.enableRotation Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether it is possible to rotate images via Image Uploader GUI.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    enableRotation: true,
    //...other params...
})

Property Value

Type: Boolean

If true, any image in the folder or upload pane can be rotated by 90 degrees clockwise by:

  • clicking the rotation icon on the pane item surface,
  • clicking the Rotate button of the image edtior.

Otherwise, images can be rotated via the angle property only.

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableRotation ASP.NET Property
  • Uploader.EnableRotation PHP Property


uploader.enableStatusPane Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the status pane should be displayed.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    enableStatusPane: true,
    //...other params...
})

Property Value

Type: Boolean

If true, the status pane is displayed in both layouts; otherwise, it is hidden.

Default value is true.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableStatusPane ASP.NET Property
  • Uploader.EnableStatusPane PHP Property


uploader.enableUploadPane Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the upload pane should be displayed.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    enableUploadPane: true,
    //...other params...
})

Property Value

Type: Boolean

If true, the upload pane is displayed in ThreePanes layout; otherwise, it is hidden.

Default value is true.

Remarks

This property makes sense in ThreePanes layout only.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.EnableUploadPane ASP.NET Property
  • Uploader.EnableUploadPane PHP Property


uploader.enableUploadProgress Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a value indicating whether the uploading files dialog is shown during the upload.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    enableUploadProgress: true,
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').enableUploadProgress(value);
value = $au.uploader('uploaderID').enableUploadProgress();

Property Value

Type: Boolean

If true, the uploading files dialog is displayed; otherwise, this dialog is hidden. However, there are alternative ways to indicate the upload progress:

  • activate the instant upload mode (i.e. set the uploadSettings.enableInstantUpload is true),
  • implement a custom upload progress indicator yourself by using the Progress event.

Default value is true.

See Also

Reference

  • enableInstantUpload Property
  • Progress Event
  • Aurigma.ImageUploader.Uploader.EnableUploadProgress ASP.NET Property
  • Uploader.EnableUploadProgress PHP Property


uploader.events Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a collection of client-side events.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    events: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').events(value);
value = $au.uploader('uploaderID').events();

Property Value

Type: $au.events

The collection of client-side events.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.ClientEvents ASP.NET Property
  • Uploader.ClientEvents PHP Property

Manual

  • Using Events


uploader.files Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a collection of user-selected files.

Syntax

JavaScript

Get/Set Value at Runtime

$au.uploader('uploaderID').files(value);
value = $au.uploader('uploaderID').files();

Property Value

Type: $au.files

The collection of user-selected files.


uploader.folderPane Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the folder pane settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    folderPane: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').folderPane(value);
value = $au.uploader('uploaderID').folderPane();

Property Value

Type: $au.folderPane

The settings of the folder pane.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.FolderPane ASP.NET Property
  • Uploader.FolderPane PHP Property

Manual

  • Layouts


uploader.folderProcessingMode Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the folder processing mode.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    folderProcessingMode: "Skip",
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').folderProcessingMode(value);
value = $au.uploader('uploaderID').folderProcessingMode();

Property Value

Type: String

The folder processing mode.

The following values are supported:

Value | Description
Skip | Subfolders are not shown in the folder pane, so it is impossible to upload a whole folder if it is not a current folder.
Show | Subfolders are visible in the folder pane, so a user can select whole folders. However, restoring folders structure on server side is impossible, because no file path information is uploaded.
Upload | Subfolders are shown in the folder pane, so a user can select whole folders. Moreover, it is possible to restore folders structure on a server, because Image Uploader sends each file along with its relative path to the selected folder.

Default value is "Skip".

Remarks

Note

Image Uploader Express does not display and upload folders. See the Comparison of Image Uploader Editions topic for details.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.FolderProcessingMode ASP.NET Property
  • Uploader.FolderProcessingMode PHP Property

Manual

  • Uploading Folders in Other Platforms


uploader.headerColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of Image Uploader headers.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    headerColor: "#f2f6fb;#c4defb",
    //...other params...
})

Property Value

Type: String

The color of Image Uploader headers.

This element supports linear gradient fills, so this property accepts a string in the following format: #aaaaaa;#bbbbbb, where #aaaaaa specifies a top gradient color and #bbbbbb - a bottom. Both colors should be specified in a hex representation of the RGB triad in HTML-style syntax. If the only one color is set, the element appears solid.

Default value is "#f2f6fb;#c4defb".

Remarks

This property affects the following headers:

  • tree pane header,
  • folder pane header.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.HeaderColor ASP.NET Property
  • Uploader.HeaderColor PHP Property


uploader.headerTextColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of text in Image Uploader headers.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    headerTextColor: "#1a64a8",
    //...other params...
})

Property Value

Type: String

The color of text in Image Uploader headers.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#1a64a8".

Remarks

This property affects the following headers:

  • tree pane header,
  • folder pane header.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.HeaderTextColor ASP.NET Property
  • Uploader.HeaderTextColor PHP Property

Manual

  • Layouts


uploader.height Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a height of the control.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    height: "400px",
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').height(value);
value = $au.uploader('uploaderID').height();

Property Value

Type: String

The height of the control.

Default value is "400px".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Height ASP.NET Property
  • Uploader.Height PHP Property


uploader.hyperlinkColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of all the hyperlink elements.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    hyperlinkColor: "#0066cc",
    //...other params...
})

Property Value

Type: String

The color of all the hyperlink elements.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#0066cc".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.HyperlinkColor ASP.NET Property
  • Uploader.HyperlinkColor PHP Property


uploader.id Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a unique identifier of the control.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    id: "",
    //...other params...
})

Property Value

Type: String

The unique identifier of the control.

Default value is "".

Remarks

This identifier is obligatiry set during initialization and used to refer to Image Uploader at runtime and, thus, modify its parameters, call methods, and handle events through JavaScript.

See Also

Manual

  • Using JavaScript API


uploader.imageEditor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the image editor settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    imageEditor: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').imageEditor(value);
value = $au.uploader('uploaderID').imageEditor();

Property Value

Type: $au.imageEditor

The settings of the image editor appearance.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.ImageEditor ASP.NET Property
  • Uploader.ImageEditor PHP Property

Manual

  • Image Editor


uploader.informationBar Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the information bar settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    informationBar: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').informationBar(value);
value = $au.uploader('uploaderID').informationBar();

Property Value

Type: $au.informationBar

The settings of the information bar appearance.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.InformationBar ASP.NET Property
  • Uploader.InformationBar PHP Property


uploader.javaControl Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets Image Uploader Java applet settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    javaControl: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').javaControl(value);
value = $au.uploader('uploaderID').javaControl();

Property Value

Type: $au.javaControl

Image Uploader Java applet settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.JavaControl ASP.NET Property
  • Uploader.JavaControl PHP Property

Manual

  • Using Private-label Version of Image Uploader JavaScript


uploader.licenseKey Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a license key which allows evaluating, developing, or publishing Image Uploader according to the license key type (trial, development, or full).

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    licenseKey: "",
    //...other params...
})

Property Value

Type: String

The valid license key.

If it is necessary to specify several license keys just separate them with semicolons. See the Example section below.

Default value is "".

Remarks

Note

Image Uploader Express does not support registering of several license keys. See the Comparison of Image Uploader Editions topic for details.

Image Uploader always works as a full version on localhost domain (regardless to the license key).

If you have any questions regarding licensing options or any other sales-related queries, do not hesitate to contact at sales@aurigma.com for more details.

Example

JavaScript

$au.uploader({
    licenseKey: 'XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXXX;YYYYY-YYYYY-YYYYY-YYYYY-YYYYY-YYYYYY'
})

See Also

Reference

  • Aurigma.ImageUploader.Uploader.LicenseKey ASP.NET Property
  • Uploader.LicenseKey PHP Property

Manual

  • Quick Start with Image Uploader JavaScript
  • Evaluating and Registering Image Uploader


uploader.loadingFolderContentText Property

  • Supported browsers: Firefox Google Chrome Safari

Gets or sets a text which is displayed while Image Uploader scans the folder content and builds the file list.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    loadingFolderContentText: "Loading content...",
    //...other params...
})

Property Value

Type: String

The text which is displayed while Image Uploader scans the folder content and builds the file list.

Default value is "Loading content...".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.LoadingFolderContentText ASP.NET Property
  • Uploader.LoadingFolderContentText PHP Property


uploader.messages Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets messages.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    messages: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').messages(value);
value = $au.uploader('uploaderID').messages();

Property Value

Type: $au.messages

The messages.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Messages ASP.NET Property
  • Uploader.Messages PHP Property

Manual

  • Localization


uploader.metadata Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an additional upload data.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    metadata: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').metadata(value);
value = $au.uploader('uploaderID').metadata();

Property Value

Type: $au.metadata

The additional upload data.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Metadata ASP.NET Property
  • Uploader.Metadata PHP Property


uploader.paneFont Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a font format for all Image Uploader buttons and labels, except titles.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    paneFont: "",
    //...other params...
})

Property Value

Type: String

The font format for all Image Uploader buttons and labels. If this property is not specified, a default system font is used.

See the Remarks section for more details about the font format syntax.

Default value is "".

Remarks

The string which specifies font format has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Name | Font name. This font should be installed on the client machine, so it is recommended to use only standard font names. When this parameter is not specified, the system default font is used.
Size | Font size (in pixels). If this parameter is not specified, the system default font size is used.
Style

Font style. The following styles are supported:

  • Bold
  • Italic

You can specify several styles separated with a comma. Example:

Style=Bold,Italic

If this parameter is not specified, regular font is used.

Note

The format string is case insensitive.

If you need to customize a title font, use the titleFont.

See Also

Reference

  • titleFont Property
  • Aurigma.ImageUploader.Uploader.PaneFont ASP.NET Property
  • Uploader.PaneFont PHP Property


uploader.paneItem Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the pane item settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    paneItem: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').paneItem(value);
value = $au.uploader('uploaderID').paneItem();

Property Value

Type: $au.paneItem

The pane item settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.PaneItem ASP.NET Property
  • Uploader.PaneItem PHP Property


uploader.paneLayout Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets of sets Image Uploader layout.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    paneLayout: "TreePanes",
    //...other params...
})

Property Value

Type: String

The Image Uploader layout.

The following values are supported:

Value | Description
OnePane | Only the upload pane representing a list of user-selected files is displayed. Users can drag-and-drop necessary files from Windows Explorer, Finder, or any other graphic shell to this list.
ThreePanes

Three panes are displayed:

  • Tree pane - is the folder tree allowing a user to navigate their file system.
  • Folder pane - displays the content of the currently selected folder.
  • Upload pane - contains files ready to be uploaded.

Default value is "TreePanes".

Remarks

Keep in mind that Image Uploader is not designed to switch between layouts in run-time.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.PaneLayout ASP.NET Property
  • Uploader.PaneLayout PHP Property

Manual

  • Layouts


uploader.panelBorderColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of borders between Image Uploader panes.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    panelBorderColor: "#aaaaaa",
    //...other params...
})

Property Value

Type: String

The color of Image Uploader pane borders.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#aaaaaa".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.PanelBorderColor ASP.NET Property
  • Uploader.PanelBorderColor PHP Property


uploader.panelColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of command areas.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    panelColor: "#f5f5f5",
    //...other params...
})

Property Value

Type: String

The color of a command area of the following windows:

  • image editor,
  • adding files dialog,
  • uploading files dialog.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#f5f5f5".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.PanelColor ASP.NET Property
  • Uploader.PanelColor PHP Property


uploader.pasteFileNameTemplate Property

  • Supported browsers: Internet Explorer

Gets or sets a file name template for files pasted from clipboard.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    pasteFileNameTemplate: "Paste_[date]_[time]",
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').pasteFileNameTemplate(value);
value = $au.uploader('uploaderID').pasteFileNameTemplate();

Property Value

Type: String

The file name template for files pasted from clipboard. It can contain any characters allowed for file names and use the following placeholders:

[date]
Current date (i.e. when the file was pasted from clipboard).
[time]
Current time (i.e. when the file was pasted from clipboard).

Default value is "Paste_[date]_[time]".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.PasteFileNameTemplate ASP.NET Property
  • Uploader.PasteFileNameTemplate PHP Property


uploader.restrictions Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets upload restrictions.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    restrictions: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').restrictions(value);
value = $au.uploader('uploaderID').restrictions();

Property Value

Type: $au.restrictions

The upload restrictions.

Remarks

Note

All the limitations specified here are checked client-side, so you should not interpret them as a reliable protection. A potentially malicious user can bypass all these limitations (by emulating Image Uploader). That is why it is highly recommended to implement server-side verification of uploaded files in addition to restrictions properties.

In other words, all the limitation features discussed in this topic should be used solely for the convenience of the user. They should not be interpreted as a serious protection measure from malicious users.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Restrictions ASP.NET Property
  • Uploader.Restrictions PHP Property

Manual

  • Configuring Restriction Rules for Files


uploader.statusPane Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the status pane settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    statusPane: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').statusPane(value);
value = $au.uploader('uploaderID').statusPane();

Property Value

Type: $au.statusPane

The settings of the status pane.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.StatusPane ASP.NET Property
  • Uploader.StatusPane PHP Property

Manual

  • Layouts


uploader.textColor Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a color of primary labels.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    textColor: "#000000",
    //...other params...
})

Property Value

Type: String

The color of Image Uploader labels except for:

  • auxiliary labels (are customized with the auxiliaryTextColor property);
  • header labels (are customized with the headerTextColor property);
  • buttons,
  • context menu.

The color string should be specified in a hex representation of the RGB triad in HTML-style syntax (#rrggbb).

Default value is "#000000".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.TextColor ASP.NET Property
  • Uploader.TextColor PHP Property


uploader.titleFont Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a font format for Image Uploader titles.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    titleFont: "",
    //...other params...
})

Property Value

Type: String

The font format for:

  • tree pane header title;
  • folder pane header title;
  • adding files dialog title;
  • uploading files dialog title;
  • status pane text (always regular, even if the bold style is specified).

See the Remarks section for more details about the font format syntax.

If this property is not specified, a default font is used.

Default value is "".

Remarks

The string which specifies font format has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Name | Font name. This font should be installed on the client machine, so it is recommended to use only standard font names. When this parameter is not specified, the system default font is used.
Size | Font size (in pixels). If this parameter is not specified, the system default font size is used.
Style

Font style. The following styles are supported:

  • Bold
  • Italic

You can specify several styles separated with a comma. Example:

Style=Bold,Italic

If this parameter is not specified, regular font is used.

Note

The format string is case insensitive.

Other fonts are specified via the paneFont property.

See Also

Reference

  • paneFont Property
  • Aurigma.ImageUploader.Uploader.TitleFont ASP.NET Property
  • Uploader.TitleFont PHP Property

Manual

  • Layouts


uploader.treePane Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the tree pane settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    treePane: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').treePane(value);
value = $au.uploader('uploaderID').treePane();

Property Value

Type: $au.treePane

The tree pane settings

See Also

Reference

  • Aurigma.ImageUploader.Uploader.TreePane ASP.NET Property
  • Uploader.TreePane PHP Property

Manual

  • Layouts


uploader.uploadButtonImageFormat Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a list of images that are displayed in different states of the Upload button.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    uploadButtonImageFormat: "",
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadButtonImageFormat(value);
value = $au.uploader('uploaderID').uploadButtonImageFormat();

Property Value

Type: String

The list of custom images of the Upload button.

See the Remarks section for more details about syntax of this string.

Default value is "".

Remarks

The string which specifies images for a button has the following syntax:

variable1=value1;variable2=value2;...

Here is a list of supported variables:

Variable | Description
Width | Width of the button or icon.
Height | Height of the button or icon.
BackgroundColor | Background color of the button or icon. The rectangle specified Width/Height is filled with this color and displayed while images for buttons are downloaded. If omitted, the backgroundColor property is used.
UrlNormal | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, and the button is not in focus. Mandatory.
UrlNormalFocused | URL to the image which represents the button/icon when it is not pressed, mouse pointer is not hover over it, but the button is in focus. If omitted, last drawn image will be used.
UrlHover | URL to the image which represents a button/icon when a mouse button is hovered over it. If omitted, last drawn image will be used.
UrlHoverFocused | URL to the image which represents a button/icon when a mouse button is hovered over it, but the button/icon is in focus. If omitted, last drawn image will be used.
UrlPressed | URL to the image which represents a button/icon when it is pressed. If omitted, last drawn image will be used.
UrlDisabled | URL to the image which represents a button/icon when it is disabled. If omitted, last drawn image will be used. If omitted, last drawn image will be used.
Note

The format string is case insensitive.

You can use images of the all formats which are recognized by Image Uploader as images. If you load animated GIF files, only the first frame will be displayed.

Image URLs can be both absolute (e.g. http://domain.com/images/image.png) and relative to the current page (e.g. /images/image.png).

For example, if Image Uploader is inserted to the http://domain.com/ImageUploader/index.html page, the relative URLs specified via this property will correspond to the following locations.

Specified URL | Expected Location
"/images/image.png" | http://domain.com/images/image.png
"./images/image.png" | http://domain.com/ImageUploader/images/image.png
"images/image.png" | http://domain.com/ImageUploader/images/image.png
"image.png" | http://domain.com/ImageUploader/image.png

See Also

Reference

  • uploadButtonText Property
  • Aurigma.ImageUploader.Uploader.UploadButtonImageFormat ASP.NET Property
  • Uploader.UploadButtonImageFormat PHP Property


uploader.uploadButtonText Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a caption of the button which starts the upload of the selected files.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    uploadButtonText: "Upload",
    //...other params...
})

Property Value

Type: String

The caption of the Upload button.

Default value is "Upload".

Remarks

This property is necessary for localization of Image Uploader.

See Also

Reference

  • uploadButtonImageFormat Property
  • Aurigma.ImageUploader.Uploader.UploadButtonText ASP.NET Property
  • Uploader.UploadButtonText PHP Property


uploader.uploadPane Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets the upload pane settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    uploadPane: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadPane(value);
value = $au.uploader('uploaderID').uploadPane();

Property Value

Type: $au.uploadPane

The upload pane settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.UploadPane ASP.NET Property
  • Uploader.UploadPane PHP Property

Manual

  • Layouts


uploader.uploadProgressDialog Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the upload progress dialog settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    uploadProgressDialog: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadProgressDialog(value);
value = $au.uploader('uploaderID').uploadProgressDialog();

Property Value

Type: $au.uploadProgressDialog

The upload progress dialog settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.UploadProgressDialog ASP.NET Property
  • Uploader.UploadProgressDialog PHP Property


uploader.uploadSettings Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets upload settings.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    uploadSettings: {},
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').uploadSettings(value);
value = $au.uploader('uploaderID').uploadSettings();

Property Value

Type: $au.uploadSettings

The upload settings.

See Also

Reference

  • Aurigma.ImageUploader.Uploader.UploadSettings ASP.NET Property
  • Uploader.UploadSettings PHP Property

Manual

  • Configuring Common Upload Settings


uploader.width Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a width of the control.

Syntax

JavaScript

Initialize

$au.uploader({
    //...other params...
    width: "600px",
    //...other params...
})

Get/Set Value at Runtime

$au.uploader('uploaderID').width(value);
value = $au.uploader('uploaderID').width();

Property Value

Type: String

The width of the control.

Default value is "600px".

See Also

Reference

  • Aurigma.ImageUploader.Uploader.Width ASP.NET Property
  • Uploader.Width PHP Property


$au.amazonS3Extender Namespace

The $au.amazonS3Extender namespace contains classes related to AmazonS3 extender.

Classes

 | Name | Description
Public class | amazonS3Extender | This class extends Image Uploader with a direct upload to Amazon S3 storage.
Public class | fileSettings | This class contains a list of settings for file to be uploaded to Amazon S3 storage.
Public class | converters | This class represents collection of settings for files to be uploaded to Amazon S3 storage.

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3 ASP.NET Namespace


amazonS3Extender Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class extends Image Uploader with a direct upload to Amazon S3 storage.

For a list of all members of this class, see amazonS3Extender Members.

Syntax

JavaScript

$au.amazonS3Extender = function() {
}

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender ASP.NET Class
  • AmazonS3Extender PHP Class


amazonS3Extender Members

  • Properties
  • Language Filter ( all languages )

The amazonS3Extender type exposes the following members.

Constructors

 | Name | Description
Public method | amazonS3Extender(uploader) | Creates and initializes an instance of the amazonS3Extender class.

Properties

 | Name | Description
Public property | accessKeyId | Gets or set an AWS Access Key ID of the owner of the bucket.
Public property | bucket | Gets or sets a bucket name.
Public property | bucketHostName | Gets or sets a custom bucket host name.
Public property | converters | Gets or sets a collection of settings for files to be uploaded.


amazonS3Extender(uploader) Constructor

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the amazonS3Extender class.

Syntax

JavaScript

$au.amazonS3Extender(uploader);

Parameters

uploader

Type: $au.uploader

The uploader object to create this amazonS3Extender for.

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender ASP.NET Constructor
  • AmazonS3Extender(Uploader) PHP Constructor


amazonS3Extender Properties

  • Properties
  • Language Filter ( all languages )

The amazonS3Extender type exposes the following properties.

Properties

 | Name | Description
Public property | accessKeyId | Gets or set an AWS Access Key ID of the owner of the bucket.
Public property | bucket | Gets or sets a bucket name.
Public property | bucketHostName | Gets or sets a custom bucket host name.
Public property | converters | Gets or sets a collection of settings for files to be uploaded.


amazonS3Extender.accessKeyId Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or set an AWS Access Key ID of the owner of the bucket.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var as3 = $au.amazonS3Extender(u);
as3.accessKeyId("");
//...other params...
u.writeHtml();

Property Value

Type: String

The AWS Access Key ID of the owner of the bucket.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender.AWSAccessKeyId ASP.NET Property
  • AmazonS3Extender.AWSAccessKeyId PHP Property


amazonS3Extender.bucket Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a bucket name.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var as3 = $au.amazonS3Extender(u);
as3.bucket("");
//...other params...
u.writeHtml();

Property Value

Type: String

The bucket name.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender.Bucket ASP.NET Property
  • AmazonS3Extender.Bucket PHP Property


amazonS3Extender.bucketHostName Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a custom bucket host name.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var as3 = $au.amazonS3Extender(u);
as3.bucketHostName("");
//...other params...
u.writeHtml();

Property Value

Type: String

The custom bucket host name.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender.BucketHostName ASP.NET Property
  • AmazonS3Extender.BucketHostName PHP Property


amazonS3Extender.converters Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a collection of settings for files to be uploaded.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var as3 = $au.amazonS3Extender(u);
as3.converters([]);
//...other params...
u.writeHtml();

Property Value

Type: $au.amazonS3Extender.fileSettings

The collection of settings for files to be uploaded.

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.AmazonS3Extender.Files ASP.NET Property
  • AmazonS3Extender.Files PHP Property


converters Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class represents collection of settings for files to be uploaded to Amazon S3 storage.

For a list of all members of this class, see converters Members.

Syntax

JavaScript

$au.amazonS3Extender.converters = function() {
}

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.FileSettingsCollection ASP.NET Class


converters Members

  • Methods
  • Language Filter ( all languages )

The converters type exposes the following members.

Methods

 | Name | Description
Public method | clear | Clears the collection.
Public method | get | Returns the converter at the specified index.
Public method | remove | Removes the converter at the specified index of the collection.
Public method | set | Sets the specified properties.


converters Methods

  • Methods
  • Language Filter ( all languages )

The converters type exposes the following methods.

Methods

 | Name | Description
Public method | clear | Clears the collection.
Public method | get | Returns the converter at the specified index.
Public method | remove | Removes the converter at the specified index of the collection.
Public method | set | Sets the specified properties.


converters.clear Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Clears the collection.

Syntax

JavaScript

as3.converters().clear();


converters.get Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Returns the converter at the specified index.

Syntax

JavaScript

as3.converters().get(index);

Parameters

index

Type: Number

The zero-based index of the converter to get.

Return Value

Type: $au.amazonS3Extender.fileSettings

The converter at the specified index.


converters.remove Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Removes the converter at the specified index of the collection.

Syntax

JavaScript

as3.converters().remove(index);

Parameters

index

Type: Number

The zero-based index of the converter to remove.


converters.set Method

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Sets the specified properties.

Syntax

JavaScript

as3.converters().set(obj);

Parameters

obj

Type: Object

A list of property names and values in JSON format.


fileSettings Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class contains a list of settings for file to be uploaded to Amazon S3 storage.

For a list of all members of this class, see fileSettings Members.

Syntax

JavaScript

$au.amazonS3Extender.fileSettings = function() {
}

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.FileSettings ASP.NET Class
  • FileSettings PHP Class


fileSettings Members

  • Properties
  • Language Filter ( all languages )

The fileSettings type exposes the following members.

Properties

 | Name | Description
Public property | acl | Gets or sets an Amazon S3 access control list. Options include private, public-read, public-read-write, and authenticated-read.
Public property | key | Gets or sets an Amazon S3 file key.
Public property | meta | Gets or sets an array of metadata fields to be uploaded to Amazon S3 storage.
Public property | policy | Gets or sets a security policy describing what is permitted in the request. Requests without security policy are considered anonymous and only work on publicly writable buckets.
Public property | signature | Gets or sets a HMAC signature constructed using the secret key of the provided accessKeyId.


fileSettings Properties

  • Properties
  • Language Filter ( all languages )

The fileSettings type exposes the following properties.

Properties

 | Name | Description
Public property | acl | Gets or sets an Amazon S3 access control list. Options include private, public-read, public-read-write, and authenticated-read.
Public property | key | Gets or sets an Amazon S3 file key.
Public property | meta | Gets or sets an array of metadata fields to be uploaded to Amazon S3 storage.
Public property | policy | Gets or sets a security policy describing what is permitted in the request. Requests without security policy are considered anonymous and only work on publicly writable buckets.
Public property | signature | Gets or sets a HMAC signature constructed using the secret key of the provided accessKeyId.


fileSettings.acl Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an Amazon S3 access control list. Options include private, public-read, public-read-write, and authenticated-read.

Syntax

JavaScript

Initialize

as3.converters( [
        {
            //...other params...
            acl: "private",
            //...other params...
        }
    ]
})

Property Value

Type: String

The Amazon S3 access control list.

Default value is "private".

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.FileSettings.Acl ASP.NET Property
  • FileSettings.Acl PHP Property


fileSettings.key Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an Amazon S3 file key.

Syntax

JavaScript

Initialize

as3.converters( [
        {
            //...other params...
            key: "${filename}",
            //...other params...
        }
    ]
})

Property Value

Type: String

The Amazon S3 file key.

Default value is "${filename}".

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.FileSettings.Key ASP.NET Property
  • FileSettings.Key PHP Property


fileSettings.meta Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of metadata fields to be uploaded to Amazon S3 storage.

Syntax

JavaScript

Initialize

as3.converters( [
        {
            //...other params...
            meta
            //...other params...
        }
    ]
})

Property Value

Type: Array

The array of metadata fields to be uploaded to Amazon S3 storage.

See Also

Reference

  • Aurigma.ImageUploader.AmazonS3.FileSettings.Meta ASP.NET Property
  • FileSettings.Meta PHP Property


fileSettings.policy Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a security policy describing what is permitted in the request. Requests without security policy are considered anonymous and only work on publicly writable buckets.

Syntax

JavaScript

Initialize

as3.converters( [
        {
            //...other params...
            policy: "",
            //...other params...
        }
    ]
})

Property Value

Type: String

The security policy describing what is permitted in the request.

Default value is "".


fileSettings.signature Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a HMAC signature constructed using the secret key of the provided accessKeyId.

Syntax

JavaScript

Initialize

as3.converters( [
        {
            //...other params...
            signature: "",
            //...other params...
        }
    ]
})

Property Value

Type: String

The HMAC signature constructed using the secret key of the provided accessKeyId.

Default value is "".


$au.nirvanixExtender Namespace

The $au.nirvanixExtender namespace contains classes related to Nirvanix extender.

Classes

 | Name | Description
Public class | nirvanixExtender | This class extends Image Uploader with a direct upload to Nirvanix storage.

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix ASP.NET Namespace


nirvanixExtender Class

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This class extends Image Uploader with a direct upload to Nirvanix storage.

For a list of all members of this class, see nirvanixExtender Members.

Syntax

JavaScript

$au.nirvanixExtender = function() {
}

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender ASP.NET Class
  • NirvanixExtender PHP Class


nirvanixExtender Members

  • Properties
  • Language Filter ( all languages )

The nirvanixExtender type exposes the following members.

Constructors

 | Name | Description
Public method | nirvanixExtender(uploader) | Creates and initializes an instance of the nirvanixExtender class.

Properties

 | Name | Description
Public property | destFolderPath | Gets or sets a destination path of the files being uploaded.
Public property | serviceError | Gets or sets an array of ServiceError event handlers.
Public property | uploadHost | Gets or sets the server to upload to.
Public property | uploadToken | Gets or sets an access token to pass into one of the upload methods when performing an upload.


nirvanixExtender(uploader) Constructor

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Creates and initializes an instance of the nirvanixExtender class.

Syntax

JavaScript

$au.nirvanixExtender(uploader);

Parameters

uploader

Type: $au.uploader

The uploader object to create this nirvanixExtender for.

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender ASP.NET Constructor
  • NirvanixExtender(Uploader) PHP Constructor


nirvanixExtender Properties

  • Properties
  • Language Filter ( all languages )

The nirvanixExtender type exposes the following properties.

Properties

 | Name | Description
Public property | destFolderPath | Gets or sets a destination path of the files being uploaded.
Public property | serviceError | Gets or sets an array of ServiceError event handlers.
Public property | uploadHost | Gets or sets the server to upload to.
Public property | uploadToken | Gets or sets an access token to pass into one of the upload methods when performing an upload.


nirvanixExtender.destFolderPath Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets a destination path of the files being uploaded.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var nx = $au.nirvanixExtender(u);
nx.destFolderPath("");
//...other params...
u.writeHtml();

Property Value

Type: String

The destination path of the files being uploaded.

Default value is "".

See Also

Reference

  • Aurigma.ImageUploader.Nirvanix.NirvanixExtender.DestFolderPath ASP.NET Property
  • NirvanixExtender.DestFolderPath PHP Property


nirvanixExtender.serviceError Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an array of ServiceError event handlers.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var nx = $au.nirvanixExtender(u);
nx.serviceError(null);
//...other params...
u.writeHtml();

Property Value

Type: Array

The string containing a name of ServiceError event handler or an array of handler names.

Remarks

This event fires if some error occurred during upload to Nirvanix service.


nirvanixExtender.uploadHost Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets the server to upload to.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var nx = $au.nirvanixExtender(u);
nx.uploadHost("");
//...other params...
u.writeHtml();

Property Value

Type: String

The server to upload to.

Default value is "".


nirvanixExtender.uploadToken Property

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

Gets or sets an access token to pass into one of the upload methods when performing an upload.

Syntax

JavaScript

Initialize

var u = $au.uploader({
    //...other params...
});
var nx = $au.nirvanixExtender(u);
nx.uploadToken("");
//...other params...
u.writeHtml();

Property Value

Type: String

The access token to pass into one of the upload methods when performing an upload.

Default value is "".


Image Uploader Client-Side Events Reference

Image Uploader exposes the following client-side controls.

Controls

Name | Description
Uploader | The main control, which provides most of available functionality.
Thumbnail | Standalone thumbnail bound with some upload list item of Image Uploader.


Uploader Client-Side Events

  • Events
  • Language Filter ( all languages )

The Uploader control exposes the following client-side controls.

Events

 | Name | Description
Public event | AfterPackageUpload | This event fires when the current package was uploaded successfully.
Public event | AfterSendRequest | This event fires when the current POST request was uploaded successfully.
Public event | AfterUpload | This event fires after successful upload.
Public event | BeforePackageUpload | This event fires when the current package is about to be uploaded.
Public event | BeforeSendRequest | This event fires when the current POST request is about to be uploaded.
Public event | BeforeUpload | This event fires when the upload is about to be started.
Public event | Error | This event fires if some error occurred during the current upload session.
Public event | FolderChange | This event fires when a user goes to another folder.
Public event | InitComplete | This event fires when Image Uploader is completely created and initialized.
Public event | PreRender | This event fires before the writeHtml() or getHtml() method is executed.
Public event | Progress | This event indicates the progress of the upload.
Public event | RestrictionFailed | This event fires when some restriction is broken.
Public event | SelectionChange | This event fires when a user changes a selection in the upload pane.
Public event | UploadFileCountChange | This event fires when a user adds/removes any files to/from the upload list.
Public event | ViewChange | This event fires when the view mode is changed.


Uploader.AfterPackageUpload Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when the current package was uploaded successfully.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_AfterPackageUpload(packageIndex, response){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="AfterPackageUpload" HandlerName="Uploader1_AfterPackageUpload" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_AfterPackageUpload(packageIndex, response){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setAfterPackageUpload("Uploader1_AfterPackageUpload");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_AfterPackageUpload(packageIndex, response){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        afterPackageUpload: [Uploader1_AfterPackageUpload],
        //...other params...
    }
})

Parameters

packageIndex

Type: Number

The zero-based index of the package inside the current upload session.

response

Type: String

The HTML code of the page returned from the server-side upload script after processing the current package.

Return Value

Type: Boolean

If false, the upload process stops and the Error event is fired with error code 18.

Remarks

Note

This event makes sense if the FilesPerPackage property is greater than or equal to 1; otherwise, this event works equally to the AfterUpload.

You can use this event to stop the upload if the currently uploaded file fails some server-side verification. To do it you can use the following algorithm:

  1. Configure Image Uploader to send every file in a separate package, i.e. set the FilesPerPackage property to 1.

  2. Write your server-side upload script. It should apply some verification to the uploaded file and put the corresponded string value to the response. For example, "Success" if the file meets verification conditions or "Failed" if does not.

    C#

    <script runat="server">
void Page_Load()
{
    if (Request.Files.Count == 0)
        return;

    if (VerifyFile(Request.Files[0]))
        Response.Write("Success");
    else
        Response.Write("Failed");
}
</script>

  3. Then use the AfterPackageUpload event handler to check this response using the response parameter. If it equals to "Failed" the event handler should return false.

    JavaScript

    function afterPackageUpload(index, response){
    if (response.substring(0, 6) == "Failed")
        return false;
    else
        return true;
}
  4. Right now the upload process stops and the Error event is fired with error code 18.

See Also

Reference

  • Error Event
  • FilesPerPackage Property
  • AfterPackageUpload Property

Manual

  • Using Events
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • AfterPackageUpload (PHP)
  • afterPackageUpload (JavaScript)


Uploader.AfterSendRequest Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when the current POST request was uploaded successfully.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_AfterSendRequest(){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="AfterSendRequest" HandlerName="Uploader1_AfterSendRequest" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_AfterSendRequest(){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setAfterSendRequest("Uploader1_AfterSendRequest");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_AfterSendRequest(){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        afterSendRequest: [Uploader1_AfterSendRequest],
        //...other params...
    }
})

Remarks

Depending on the upload settings (UploadSettings configuration), the currently uploaded POST request can contain:

  • a whole upload session, if FilesPerPackage is 0 and ChunkSize is 0;
  • a package, if FilesPerPackage is greater than or equal to 1 and ChunkSize is 0;
  • a chunk, if FilesPerPackage is 1, ChunkSize is greater than 0, and a size of the currently uploaded file exceeds the ChunkSize value.

See Also

Reference

  • AfterSendRequest Property

Manual

  • Sending All Files at Once or in Several Parts
  • Using Events
  • UploadSettings (ASP.NET)
  • UploadSettings (PHP)
  • uploadSettings (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • AfterSendRequest (PHP)
  • afterSendRequest (JavaScript)


Uploader.AfterUpload Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires after successful upload.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_AfterUpload(response){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="AfterUpload" HandlerName="Uploader1_AfterUpload" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_AfterUpload(response){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setAfterUpload("Uploader1_AfterUpload");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_AfterUpload(response){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        afterUpload: [Uploader1_AfterUpload],
        //...other params...
    }
})

Parameters

response

Type: String

The HTML code of the page returned from the server-side upload script.

See Also

Reference

  • AfterUpload Property

Manual

  • Using Events
  • AfterUpload (PHP)
  • afterUpload (JavaScript)


Uploader.BeforePackageUpload Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when the current package is about to be uploaded.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_BeforePackageUpload(packageIndex){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="BeforePackageUpload" HandlerName="Uploader1_BeforePackageUpload" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_BeforePackageUpload(packageIndex){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setBeforePackageUpload("Uploader1_BeforePackageUpload");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_BeforePackageUpload(packageIndex){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        beforePackageUpload: [Uploader1_BeforePackageUpload],
        //...other params...
    }
})

Parameters

packageIndex

Type: Number

The zero-based index of the package inside the current upload session.

Remarks

Note

This event makes sense if the FilesPerPackage property is greater than or equal to 1; otherwise, this event works equally to the BeforeUpload.

See Also

Reference

  • FilesPerPackage Property
  • BeforePackageUpload Property

Manual

  • Using Events
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • BeforePackageUpload (PHP)
  • beforePackageUpload (JavaScript)


Uploader.BeforeSendRequest Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when the current POST request is about to be uploaded.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_BeforeSendRequest(){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="BeforeSendRequest" HandlerName="Uploader1_BeforeSendRequest" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_BeforeSendRequest(){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setBeforeSendRequest("Uploader1_BeforeSendRequest");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_BeforeSendRequest(){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        beforeSendRequest: [Uploader1_BeforeSendRequest],
        //...other params...
    }
})

Remarks

Depending on the upload settings (UploadSettings configuration), the currently uploaded POST request can contain:

  • a whole upload session, if FilesPerPackage is 0 and ChunkSize is 0;
  • a package, if FilesPerPackage is greater than or equal to 1 and ChunkSize is 0;
  • a chunk, if FilesPerPackage is 1, ChunkSize is greater than 0, and a size of the currently uploaded file exceeds the ChunkSize value.

See Also

Reference

  • BeforeSendRequest Property

Manual

  • Sending All Files at Once or in Several Parts
  • Using Events
  • UploadSettings (ASP.NET)
  • UploadSettings (PHP)
  • uploadSettings (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • BeforeSendRequest (PHP)
  • beforeSendRequest (JavaScript)


Uploader.BeforeUpload Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when the upload is about to be started.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_BeforeUpload(){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="BeforeUpload" HandlerName="Uploader1_BeforeUpload" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_BeforeUpload(){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setBeforeUpload("Uploader1_BeforeUpload");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_BeforeUpload(){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        beforeUpload: [Uploader1_BeforeUpload],
        //...other params...
    }
})

Return Value

Type: Boolean

If false (or zero), the upload is cancelled. Otherwise, upload begins immediately after the event handler finishes. This makes the event handler convenient for validating additional data provided by a user.

See Also

Reference

  • BeforeUpload Property

Manual

  • Using Events
  • BeforeUpload (PHP)
  • beforeUpload (JavaScript)


Uploader.Error Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires if some error occurred during the current upload session.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_Error(errorCode, httpResponseCode, errorPage, additionalInfo){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="Error" HandlerName="Uploader1_Error" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_Error(errorCode, httpResponseCode, errorPage, additionalInfo){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setError("Uploader1_Error");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_Error(errorCode, httpResponseCode, errorPage, additionalInfo){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        error: [Uploader1_Error],
        //...other params...
    }
})

Parameters

errorCode

Type: Number

One of the following values:

  • 1 - number of selected files is less than number of files allowed for the upload;
  • 2 - the URL specified in the ActionUrl property was not found;
  • 3 - the URL specified in the ActionUrl property has an incorrect syntax;
  • 4 - some server-side error occurred;
  • 9 - the upload was aborted by a user;
  • 10 - the Java applet throws an out of memory exception;
  • 11 - the server returned HTTP code 3xx (e.g. 302 or 304) during redirection;
  • 12 - the upload was aborted from the script (using the cancelUpload() method);
  • 13 - the trial period has expired;
  • 18 - the upload was aborted from the AfterPackageUpload event handler (the handler returns false);
  • 0 - unknown error.
httpResponseCode

Type: Number

The HTTP error code received from the server (if any).

errorPage

Type: String

The web page containing error description, returned from the server (if any).

additionalInfo

Type: String

Text message that can be displayed to the user.

Remarks

This event allows you to handle errors which can occur during the upload.

See Also

Reference

  • Error Property

Manual

  • Using Events
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)
  • ActionUrl (ASP.NET)
  • ActionUrl (PHP)
  • actionUrl (JavaScript)
  • Error (PHP)
  • error (JavaScript)


Uploader.FolderChange Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when a user goes to another folder.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_FolderChange(){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="FolderChange" HandlerName="Uploader1_FolderChange" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_FolderChange(){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setFolderChange("Uploader1_FolderChange");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_FolderChange(){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        folderChange: [Uploader1_FolderChange],
        //...other params...
    }
})

Remarks

This event is raised in both cases:

  • a user selected another folder in the tree pane,
  • a user double-clicks a folder in the folder pane (if subfolders are visible, of course).
Note

This event makes sense in ThreePanes layout only.

See Also

Reference

  • FolderProcessingMode Property
  • FolderChange Property

Manual

  • Layouts
  • Using Events
  • FolderProcessingMode (ASP.NET)
  • FolderProcessingMode (PHP)
  • folderProcessingMode (JavaScript)
  • FolderChange (PHP)
  • folderChange (JavaScript)


Uploader.InitComplete Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when Image Uploader is completely created and initialized.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_InitComplete(){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="InitComplete" HandlerName="Uploader1_InitComplete" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_InitComplete(){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setInitComplete("Uploader1_InitComplete");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_InitComplete(){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        initComplete: [Uploader1_InitComplete],
        //...other params...
    }
})

See Also

Reference

  • InitComplete Property

Manual

  • Using Events
  • InitComplete (PHP)
  • initComplete (JavaScript)


Uploader.PreRender Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires before the writeHtml() or getHtml() method is executed.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_PreRender(){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="PreRender" HandlerName="Uploader1_PreRender" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_PreRender(){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setPreRender("Uploader1_PreRender");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_PreRender(){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        preRender: [Uploader1_PreRender],
        //...other params...
    }
})

See Also

Reference

  • PreRender Property

Manual

  • Using Events
  • PreRender (PHP)
  • preRender (JavaScript)


Uploader.Progress Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event indicates the progress of the upload.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_Progress(percent, uploadedFiles, totalFiles, uploadedBytes, totalBytes){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="Progress" HandlerName="Uploader1_Progress" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_Progress(percent, uploadedFiles, totalFiles, uploadedBytes, totalBytes){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setProgress("Uploader1_Progress");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_Progress(percent, uploadedFiles, totalFiles, uploadedBytes, totalBytes){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        progress: [Uploader1_Progress],
        //...other params...
    }
})

Parameters

percent

Type: Number

Percentage of the whole upload process completion.

uploadedFiles

Type: Number

Number of the completely uploaded files.

totalFiles

Type: Number

Total number of files selected to be uploaded.

uploadedBytes

Type: Number

Amount of the completely uploaded bytes. This parameter depends on the ProgressBytesMode value:

  • ByPackageSize - this parameter returns the number of completely uploaded bytes of the current package;
  • BySourceSize - this parameter returns the number of completely uploaded bytes of user-selected files, regardless of converted files and other auxiliary data.
totalBytes

Type: Number

Total size (in bytes) of files selected to be uploaded. This parameter depends on the ProgressBytesMode value:

  • ByPackageSize - this parameter returns the size of the currently uploaded package;
  • BySourceSize - this parameter returns the total size of all user-selected files, regardless of converted files and other auxiliary data.

Remarks

This event allows you to implement a custom upload progress indicator directly in HTML code.

See Also

Reference

  • ProgressBytesMode Property
  • Progress Property

Manual

  • Using Events
  • ProgressBytesMode (ASP.NET)
  • ProgressBytesMode (PHP)
  • progressBytesMode (JavaScript)
  • ProgressBytesMode (ASP.NET)
  • ProgressBytesMode (PHP)
  • progressBytesMode (JavaScript)
  • ProgressBytesMode (ASP.NET)
  • ProgressBytesMode (PHP)
  • progressBytesMode (JavaScript)
  • Progress (PHP)
  • progress (JavaScript)


Uploader.RestrictionFailed Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when some restriction is broken.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_RestrictionFailed(errorCode, fileName, message){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="RestrictionFailed" HandlerName="Uploader1_RestrictionFailed" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_RestrictionFailed(errorCode, fileName, message){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setRestrictionFailed("Uploader1_RestrictionFailed");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_RestrictionFailed(errorCode, fileName, message){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        restrictionFailed: [Uploader1_RestrictionFailed],
        //...other params...
    }
})

Parameters

errorCode

Type: Number

One of the following values:

  • 0 - size of the selected file exceeds the MaxFileSize value;
  • 1 - size of the selected files is less than the MinFileSize value;
  • 2 - the selected image is CMYK, when CMYK images are denied for the upload (i.e. the EnableCmyk is false);
  • 3 - dimensions of the selected image are too large (i.e. image width or height exceeds the MaxImageHeight or MaxImageWidth value);
  • 4 - dimensions of the selected image are too small (i.e. image width or height is less than the MinImageHeight or MinImageWidth value);
  • 5 - the selected file has not allowed name (i.e. filename does not match FileMask, or matches DeniedFileMask);
  • 6 - number of selected files exceeds the MaxFileCount value;
  • 7 - total size of selected files exceeds the MaxTotalFileSize value;
fileName

Type: String

The name of the file which breaks the restriction.

message

Type: String

The message stating that the restriction is broken. The same message is displayed in the information bar.

See Also

Reference

  • Restrictions Class
  • RestrictionFailed Property

Manual

  • Configuring Restriction Rules for Files
  • Using Events
  • MaxFileSize (ASP.NET)
  • MaxFileSize (PHP)
  • maxFileSize (JavaScript)
  • MinFileSize (ASP.NET)
  • MinFileSize (PHP)
  • minFileSize (JavaScript)
  • EnableCmyk (ASP.NET)
  • EnableCmyk (PHP)
  • enableCmyk (JavaScript)
  • MaxImageHeight (ASP.NET)
  • MaxImageHeight (PHP)
  • maxImageHeight (JavaScript)
  • MaxImageWidth (ASP.NET)
  • MaxImageWidth (PHP)
  • maxImageWidth (JavaScript)
  • MinImageHeight (ASP.NET)
  • MinImageHeight (PHP)
  • minImageHeight (JavaScript)
  • MinImageWidth (ASP.NET)
  • MinImageWidth (PHP)
  • minImageWidth (JavaScript)
  • FileMask (ASP.NET)
  • FileMask (PHP)
  • fileMask (JavaScript)
  • DeniedFileMask (ASP.NET)
  • DeniedFileMask (PHP)
  • deniedFileMask (JavaScript)
  • MaxFileCount (ASP.NET)
  • MaxFileCount (PHP)
  • maxFileCount (JavaScript)
  • MaxTotalFileSize (ASP.NET)
  • MaxTotalFileSize (PHP)
  • maxTotalFileSize (JavaScript)
  • Restrictions (ASP.NET)
  • Restrictions (PHP)
  • restrictions (JavaScript)
  • RestrictionFailed (PHP)
  • restrictionFailed (JavaScript)


Uploader.SelectionChange Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when a user changes a selection in the upload pane.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_SelectionChange(){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="SelectionChange" HandlerName="Uploader1_SelectionChange" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_SelectionChange(){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setSelectionChange("Uploader1_SelectionChange");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_SelectionChange(){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        selectionChange: [Uploader1_SelectionChange],
        //...other params...
    }
})

See Also

Reference

  • SelectionChange Property

Manual

  • Using Events
  • SelectionChange (PHP)
  • selectionChange (JavaScript)


Uploader.UploadFileCountChange Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when a user adds/removes any files to/from the upload list.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_UploadFileCountChange(){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="UploadFileCountChange" HandlerName="Uploader1_UploadFileCountChange" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_UploadFileCountChange(){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setUploadFileCountChange("Uploader1_UploadFileCountChange");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_UploadFileCountChange(){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        uploadFileCountChange: [Uploader1_UploadFileCountChange],
        //...other params...
    }
})

Remarks

To determine how many files are currently selected for the upload, use the count() method. See example in the files class description. This event is useful if you implement custom buttons in HTML code, and you need to disable the Upload button when not enough files are selected.

See Also

Reference

  • files Class
  • UploadFileCountChange Property

Manual

  • Using Events
  • UploadFileCountChange (PHP)
  • uploadFileCountChange (JavaScript)


Uploader.ViewChange Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when the view mode is changed.

Syntax

ASP.NET

<script type="text/javascript">
function Uploader1_ViewChange(pane){
    //...your code...
}
</script>

<aur:Uploader ID="Uploader1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="ViewChange" HandlerName="Uploader1_ViewChange" />
    </ClientEvents>
</aur:Uploader>

PHP

<script type="text/javascript">
function Uploader1_ViewChange(pane){
    //...your code...
}
</script>

<?php
    $Uploader = new Uploader("Uploader1");
    //...other params...
    $Uploader->getClientEvents()->setViewChange("Uploader1_ViewChange");
    //...other params...
    $Uploader->render();
?>

JavaScript

function Uploader1_ViewChange(pane){
    //...your code...
}

$au.uploader({
    events: {
        //...other params...
        viewChange: [Uploader1_ViewChange],
        //...other params...
    }
})

Parameters

pane

Type: String

A member of this enumeration which specifies a pane where the view mode is changed:

Value | Description
FolderPane | The folder pane.
UploadPane | The upload pane.

Remarks

Typically you should use this event when it is necessary synchronize HTML user interface with view mode of Image Uploader. For example, if you add drop-down list which toggles view modes, this event enables you to update drop-down state if the view mode is changed through the context menu of the Image Uploader.

See Also

Reference

  • ViewChange Property

Manual

  • Layouts
  • Using Events
  • ViewChange (PHP)
  • viewChange (JavaScript)


Thumbnail Client-Side Events

  • Events
  • Language Filter ( all languages )

The Thumbnail control exposes the following client-side controls.

Events

 | Name | Description
Public event | Click | This event fires when the Thumbnail control is clicked.
Public event | InitComplete | This event fires when the Thumbnail control is completely created and initialized.
Public event | PreRender | This event fires before the writeHtml() or getHtml() method is executed.
  • Thumbnail (ASP.NET)
  • Thumbnail (PHP)
  • thumbnail (JavaScript)
  • Thumbnail (ASP.NET)
  • Thumbnail (PHP)
  • thumbnail (JavaScript)


Thumbnail.Click Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when the Thumbnail control is clicked.

Syntax

ASP.NET

<script type="text/javascript">
function Thumbnail1_Click(){
    //...your code...
}
</script>

<aur:Thumbnail ID="Thumbnail1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="Click" HandlerName="Thumbnail1_Click" />
    </ClientEvents>
</aur:Thumbnail>

PHP

<script type="text/javascript">
function Thumbnail1_Click(){
    //...your code...
}
</script>

<?php
    $Thumbnail = new Thumbnail("Thumbnail1");
    //...other params...
    $Thumbnail->getClientEvents()->setClick("Thumbnail1_Click");
    //...other params...
    $Thumbnail->render();
?>

JavaScript

function Thumbnail1_Click(){
    //...your code...
}

$au.thumbnail({
        events: {
            //...other params...
            click: [Thumbnail1_Click],
            //...other params...
        }
})
  • Thumbnail (ASP.NET)
  • Thumbnail (PHP)
  • thumbnail (JavaScript)


Thumbnail.InitComplete Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires when the Thumbnail control is completely created and initialized.

Syntax

ASP.NET

<script type="text/javascript">
function Thumbnail1_InitComplete(){
    //...your code...
}
</script>

<aur:Thumbnail ID="Thumbnail1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="InitComplete" HandlerName="Thumbnail1_InitComplete" />
    </ClientEvents>
</aur:Thumbnail>

PHP

<script type="text/javascript">
function Thumbnail1_InitComplete(){
    //...your code...
}
</script>

<?php
    $Thumbnail = new Thumbnail("Thumbnail1");
    //...other params...
    $Thumbnail->getClientEvents()->setInitComplete("Thumbnail1_InitComplete");
    //...other params...
    $Thumbnail->render();
?>

JavaScript

function Thumbnail1_InitComplete(){
    //...your code...
}

$au.thumbnail({
        events: {
            //...other params...
            initComplete: [Thumbnail1_InitComplete],
            //...other params...
        }
})
  • Thumbnail (ASP.NET)
  • Thumbnail (PHP)
  • thumbnail (JavaScript)


Thumbnail.PreRender Event

  • Supported browsers: Internet Explorer Firefox Google Chrome Safari

This event fires before the writeHtml() or getHtml() method is executed.

Syntax

ASP.NET

<script type="text/javascript">
function Thumbnail1_PreRender(){
    //...your code...
}
</script>

<aur:Thumbnail ID="Thumbnail1" runat="server">
    <ClientEvents>
        <aur:ClientEvent EventName="PreRender" HandlerName="Thumbnail1_PreRender" />
    </ClientEvents>
</aur:Thumbnail>

PHP

<script type="text/javascript">
function Thumbnail1_PreRender(){
    //...your code...
}
</script>

<?php
    $Thumbnail = new Thumbnail("Thumbnail1");
    //...other params...
    $Thumbnail->getClientEvents()->setPreRender("Thumbnail1_PreRender");
    //...other params...
    $Thumbnail->render();
?>

JavaScript

function Thumbnail1_PreRender(){
    //...your code...
}

$au.thumbnail({
        events: {
            //...other params...
            preRender: [Thumbnail1_PreRender],
            //...other params...
        }
})


POST Field Reference

This topic contains the information about POST fields (both standard and custom) which are sent by Image Uploader. Use it when writing the server-side upload processing code. You should extract them in the same manner as if they were sent through the standard HTML form. See Saving Uploaded Files in ASP.NET and Saving Uploaded Files in PHP topics for more details on how to work with them.

Standard Fields

Note

If you use Image Uploader ASP.NET or Image Uploader PHP you can refer standard fields via the PostFields constants.

The table below contains a list of POST fields that are generated and uploaded by Image Uploader, if they are enabled by the metadata.enableAllStandardFields(Boolean) or metadata.enableStandardField(String, Boolean) methods.

Name | Type | Description
Upload Information
PackageIndex Integer

Zero-based index of the package inside the current upload session.

Using this field you can recognize the order of the uploaded files if they are sent in different packages.
PackageCount Integer

A total number of packages in the current upload session.

In particular, when FilesPerPackage is 1, it can be used to get a total number of files uploaded within this upload session.
PackageGuid GUID

Unique identifier of the current upload session.

When the upload is separated into several packages, all of them will have the same GUID. So you can use it to determine whether files are uploaded in the same session (useful for concurrent uploads from several users).
PackageFileCount | Integer | Number of files uploaded in the current package.
Name | Type | Description
Original File Information
SourceName_N * String

Name of the original Nth file. If entire folder is uploaded, this field includes a folder structure, i.e. relative path of the file (relatively the folder which is being uploaded, including this folder name).

It is useful to employ this field to get name of the original file when only resized copy of an image is uploaded.
SourceSize_N * | Integer | Size of the original Nth file in bytes.
SourceCreatedDateTime_N * Time

Creation date of the original Nth file in EXIF-style format:
YYYY:MM:DD hh:mm:ss
For example, 28th of March, 2:40PM would be looking in the following way:
2005:03:28 14:40:00

Note

When you uploading in non-Internet Explorer browsers, this field contains an empty value.
SourceLastModifiedDateTime_N * Time

The last modification date of the original Nth file in EXIF-style format:
YYYY:MM:DD hh:mm:ss
For example, 28th of March, 2:40PM would be looking in the following way:
2005:03:28 14:40:00
SourceCreatedDateTimeLocal_N * Time

The local creation date of the original Nth file in EXIF-style format:
YYYY:MM:DD hh:mm:ss
For example, 28th of March, 2:40PM would be looking in the following way:
2005:03:28 14:40:00

Note

When you uploading in non-Internet Explorer browsers, this field contains an empty value.
SourceLastModifiedDateTimeLocal_N * Time

The local last modification date of the original Nth file in EXIF-style format:
YYYY:MM:DD hh:mm:ss
For example, 28th of March, 2:40PM would be looking in the following way:
2005:03:28 14:40:00
SourceWidth_N * | Integer | Width of the original Nth file in pixels if it is an image. Otherwise, this field contains 0.
SourceHeight_N * | Integer | Height of the original Nth file in pixels if it is an image. Otherwise, this field contains 0.
HorizontalResolution_N * | Integer | Horizontal resolution of the original Nth file if it is an image (measured in DPI - dots per inches). Otherwise, this field contains 0.
VerticalResolution_N * | Integer | Vertical resolution of the original Nth file if it is an image (measured in DPI - dots per inches). Otherwise, this field contains 0.
Name | Type | Description
Converted File Information
The fields from this group are sent if at least one Converter is specified.
FileX_N ** File

The Xth converted file for the Nth user-selected file.

Depending on the FileXMode_N field value this field contains a file with one of the following names:

  • name.ext for sourceFile mode
  • name.ext_ThumbnailX.jpg for thumbnail mode
  • name.ext_IconX.jpg for icon mode
  • name.ext_CompressedX.zip for zip mode
FileXMode_N ** String

The mode of the Xth converted file created for the Nth user-selected file. Possible values are:

  • sourceFile means the Xth converted file is a copy of the original file.
  • thumbnail means the Xth converted file is a resized copy of the original file if it is an image.
  • icon means the Xth converted file is a system icon associated with the original file type.
  • zip means the Xth converted file is a ZIP archive of the original file.
  • none means the Xth converted file was not created.
FileXSize_N ** | Integer | Size of the Xth converted file created for the Nth user-selected file (in bytes).
FileXWidth_N ** Integer

Actual width of the Xth converted file created for the Nth user-selected file if it is an image (in pixels). Otherwise, this field contains 0.

Depending on the Converter.ThumbnailFitMode, this value may differ from the value specified through the Converter.ThumbnailWidth property. This happens because Image Uploader preserves the aspect ratio of the image and not always can use the same dimensions as specified in the thumbnail parameters.
FileXHeight_N ** Integer

Actual height of the Xth converted file created for the Nth user-selected file if it is an image (in pixels). Otherwise, this field contains 0.

Depending on the ThumbnailFitMode, this value may differ from the value specified through the Converter.ThumbnailHeight property. This happens because Image Uploader preserves the aspect ratio of the image and not always can use the same dimensions as specified in the thumbnail parameters.
FileXChunkIndex_N ** Integer

Zero-based index of this chunk of the Xth converted file created for the Nth user-selected file.

Note

This field is sent if UploadSettings.ChunkSize is greater than 0.
FileXChunkCount_N ** Integer

Number of chunks of the Xth converted file created for the Nth user-selected file.

Note

This field is sent if ChunkSize is greater than 0.
Name | Type | Description
User Input
Angle_N * Integer

Rotation angle of the Nth user-specified file (measured in degrees clockwise).

You can use it if you want to rotate images on the server side (e.g. if you upload original files only). Possible values are:

  • 0
  • 90
  • 180
  • 270
Description_N * | String | User-provided description of the Nth user-selected file.
Tag_N * | String | Tag attached to the Nth user-selected file.
Crop_N * String

Crop bounds of the Nth user-selected image in the following format: left,top,right,bottom. For non-image files this field contains 0,0,0,0 value.

You can use it if you want to crop images on the server side (e.g. if you upload original file only).

* The N character appended to the field name is a placeholder for an index of this file in the uploaded package. This index is zero-based. For example, Image Uploader sends one file per package, so to retrieve a name of this file use the SourceName_0 field (the same is true for others XXX_N fields).

** Image Uploader can generate unlimited number of converted files per each user-selected file and send them to the server. The X character is a placeholder for an index of the converted file created for the Nth user-selected file. Maximum X value is not bigger than the number of Converter instances added to the Uploader.Converters array. For example, if you set two converters, the following fields will be available on the server: File0_0 and File1_0.
Note

Standard POST fields can be renamed using the metadata.renameStandardField(String, String) method. Read the configuring-post-format.htm topic for more details.

Custom Fields

Image Uploader is able to send not only fields described in the table above, but also custom fields. It can be done in two ways:

  • Using the Metadata.AdditionalFormName property. You just add the <form> element somewhere to your code, add elements to it (<input>, <select>, <textarea> elements are supported), and set its name as a value of this property. Then Image Uploader automatically appends data from this <form> to the request that is sent to the server.
  • Using the metadata.addCustomField(String, String, Boolean) method. It takes the name of a field you want to receive on the server and its value. The most convenient place to use this method is the BeforeUpload event. Any custom fields added via this method can be removed by calling the metadata.removeCustomField(String) method.

Additional Fields

Image Uploader can also extract and generate additional information for user-selected files and send it in POST request. In particular, you can extract EXIF and IPTC metadata from images just by specifying desired fields in the Metadata.Exif and Metadata.Iptc properties.

If it is necessary to organize robust upload and check the integrity of uploaded files, you can use the Metadata.Hash property. It specifies a hash algorithm used to generate a hash sum for each user-selected file. Thus, to verify whether a file is uploaded successfully, you just need to calculate its hash sum using the same algorithm and compares it with the uploaded one.

See the Uploading Additional Data in ASP.NET and Uploading Additional Data in PHP topics for details.

See Also

Reference

  • Converter Class
  • Metadata Class

Manual

  • Saving Uploaded Files in ASP.NET
  • Saving Uploaded Files in PHP
  • configuring-post-format.htm
  • Uploading Additional Data in ASP.NET
  • Uploading Additional Data in PHP
  • PostFields (ASP.NET)
  • PostFields (PHP)
  • FilesPerPackage (ASP.NET)
  • FilesPerPackage (PHP)
  • filesPerPackage (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • ThumbnailFitMode (ASP.NET)
  • ThumbnailFitMode (PHP)
  • thumbnailFitMode (JavaScript)
  • ThumbnailWidth (ASP.NET)
  • ThumbnailWidth (PHP)
  • thumbnailWidth (JavaScript)
  • ThumbnailFitMode (ASP.NET)
  • ThumbnailFitMode (PHP)
  • thumbnailFitMode (JavaScript)
  • ThumbnailHeight (ASP.NET)
  • ThumbnailHeight (PHP)
  • thumbnailHeight (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • ChunkSize (ASP.NET)
  • ChunkSize (PHP)
  • chunkSize (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • Converters (ASP.NET)
  • Converters (PHP)
  • converters (JavaScript)
  • AdditionalFormName (ASP.NET)
  • AdditionalFormName (PHP)
  • additionalFormName (JavaScript)
  • Exif (ASP.NET)
  • Exif (PHP)
  • exif (JavaScript)
  • Iptc (ASP.NET)
  • Iptc (PHP)
  • iptc (JavaScript)
  • Hash (ASP.NET)
  • Hash (PHP)
  • hash (JavaScript)
  • Converter (ASP.NET)
  • Converter (PHP)
  • converter (JavaScript)
  • Metadata (ASP.NET)
  • Metadata (PHP)
  • metadata (JavaScript)


Legal Notices

Aurigma Image Uploader © was developed by Aurigma, Inc. 2002-2010. Therefore, it is an intellectual property of Aurigma, Inc., and it can be used only under the proper license. Nobody except of Aurigma, Inc. can pretend to be the creator of Aurigma Image Uploader, create illegal copies, or infringe the copyright in whatever way.

Disclaimer

Aurigma, Inc. makes NO WARRANTY or representation, either express or implied, with respect to this software, its quality, accuracy, merchantability, or fitness for a particular purpose. This software is provided "AS IS", and you, its user, assume the entire risk as to its quality and accuracy.

Copyright Notices

ActiveX Control

ActiveX part of Image Uploader is partially based on the following third-party code:

  • JPEG library developed by the Independent JPEG Group (IJG)
  • libpng versions 1.0.7, July 1, 2000, through 1.2.5, October 3, 2002, are copyrighted © 2000-2002 Glenn Randers-Pehrson
  • libtiff copyrighted © 1988-1997 Sam Leffler and copyrighted © 1991-1997 Silicon Graphics, Inc
  • giflib copyrighted © 1997 Eric S. Raymond
  • zlib copyrighted © 1995-2003 Jean-loup Gailly and Mark Adler
  • Little cms copyrighted © 1998-2004 Marti Maria
  • Minizip copyrighted © 1998-2005 Gilles Vollant
  • JsonCpp developed by Baptiste Lepilleur

Java Applet

Java part of Image Uploader is partially based on the following third-party code:

  • HttpClient package (http://jakarta.apache.org/commons/httpclient/) copyrighted © 2001-2005, The Apache Software Foundation (http://www.apache.org/). All rights reserved
  • metadata-extractor package (http://www.drewnoakes.com/code/exif/) copyrighted © Drew Noakes
  • TrueZIP package (https://truezip.dev.java.net/) copyrighted © 2005-2007 Schlichtherle IT Services
  • JpegEncoder (http://www.obrador.com/essentialjpeg/acceptance.htm) copyrighted © 1998, James R. Weeks and BioElectroMech

Demo Applications

Demo applications are partially based on the following third-party code:

  • jQuery (http://jquery.com/) copyrighted © 2010 John Resig
  • jQuery UI (http://jqueryui.com/) copyrighted © 2010
  • FancyBox - jQuery Plugin (http://fancybox.net/) copyrighted © 2008-2010 Janis Skarnelis

Documentation

Documentation is partially based on the following third-party code:

  • google-code-prettify (http://code.google.com/p/google-code-prettify/) copyrighted © 2006 Google Inc


Licensing Information

This Electronic End User License Agreement (the "Agreement") is a legal agreement between you (either an individual or an entity), the licensee, and Aurigma Inc. (the "Licensor"), regarding the software and service titled "Image Uploader 7" that you about to download, downloaded, or otherwise obtained through other resources or media, or though a network in object code form or other related services, including without limitation (a) all of the contents of the files, including ActiveX control, Java applet, disk(s), CD-ROM(s) or other media with which this Agreement is provided and including all forms of code, such as Source Code and Object Code as provided and in a form that is provided by Licensor to you (the "Software"), (b) all successor upgrades, revisions, patches, enhancements, fixes modifications, copies, additions or maintenance releases of the Software, if any, licensed to you by the Licensor (collectively, the "Updates") provided that the Updates shall not include a new subsequent releases of the Software bearing a new first numeral such as 7.0 or 8.0 ("New Releases") but include any minor revisions of the Software version indicated by a change in the decimal numeral, such as 7.5 or 7.6, and (c) related user documentation and explanatory materials or files provided in written, "online" or electronic form (the "Documentation" and together with the Software and Updates, the "Product").

For the avoidance of doubt, by way of example, but not exclusion, if a specific file is provided by Licensor in Object Code only, the Source Code for such files shall not be deemed a part of the Software provided by Licensor to you. For purposes hereof "Source Code" shall mean the human-readable form of the computer programming code and related system documentation including all comments and any procedural code such as job control language and "Object Code" shall mean computer programs assembled or compiled in magnetic or electronic binary form on software media, which are readable and usable by machines, but not generally readable by humans without reverse-assembly, reverse-compiling, or reverse-engineering.

You are subject to the terms and conditions of this End User License Agreement whether you access or obtain the Product directly from the Licensor, or through any other source. For purposes hereof, "you" or "Licensee" means the individual person installing or using the Product on his or her own behalf (i.e. Permitted User (as such term defined below)); or, if the Product is being downloaded or installed on behalf of an organization, such as an employer, "you" means the organization for which the Product is downloaded or installed and it is represented hereby that such organization has authorized the person accepting this agreement to do so on its behalf. For purposes hereof the term "organization", without limitation, includes any partnership, limited liability company, corporation, association, joint stock company, trust, joint venture, labor organization, unincorporated organization, or governmental authority.

By accessing, downloading, storing, loading, installing, executing, displaying, copying the Product into the memory of a computer or otherwise benefiting from using the functionality of the Product in accordance with the Documentation ("Operating"), you agree to be bound by the terms of this Agreement. If you do not agree to the terms and conditions of this Agreement, the Licensor is unwilling to license the Product to you. In such event, you may not Operate or use the Product in any way.

For the purposes of this Agreement, "Licensor Site" shall mean the Internet website maintained by or on behalf of Licensor from which the Software is available for download pursuant to a license from Licensor. The Licensor Site is currently located at www.aurigma.com.

1. Proprietary Rights and Non-Disclosure

1.1. Ownership Rights

You agree that the Product and the authorship, systems, ideas, methods of operation, documentation and other information contained in the Product, are proprietary intellectual properties and/or the valuable trade secrets of the Licensor or its suppliers and/or licensors and are protected by civil and criminal law, and by the law of copyright, trade secret, trademark and patent of the United States, other countries and international treaties. You may use trademarks only insofar as to identify printed output produced by the Product in accordance with accepted trademark practice, including identification of trademark owner's name. Such use of ny trademark does not give you any rights of ownership in that trademark. The Licensor and/or its suppliers own and retain all right, title, and interest in and to the Product, including without limitations any error corrections, enhancements, Updates or other modifications to the Software, whether made by the Licensor or any third party, and all copyrights, patents, trade secret rights, trademarks, and other intellectual property rights therein. Your possession, installation or use of the Product does not transfer to you any title to the intellectual property in the Product, and you will not acquire any rights to the Product except as expressly set forth in this Agreement. Except as otherwise agreed by the parties, all copies of the Product made or distributed hereunder must contain the same proprietary notices that appear on and in the Product originally provided to you. Except as stated herein, this Agreement does not grant you any intellectual property rights in the Product and you acknowledge that the License, as further defined herein, granted under this Agreement only provides you with a right of limited use under the terms and conditions of this Agreement. You hereby acknowledge and agree that Aurigma Inc. is the sole owner of the trademark "Aurigma®" and that you will not interfere with Aurigma Inc.'s rights in the trademark, including challenging its use, registration of, or application to register such trademark, alone or in combination with other words, anywhere in the world, and that you will not harm, misuse, or bring into disrepute any Aurigma Inc.'s trademark. The goodwill derived from using any part of Aurigma Inc.'s trademark exclusively inures to the benefit of and belongs to Aurigma Inc. Except for the limited right to use Aurigma's trademarks in connection with the Use of the Product as customary pursuant to the industry standards, no other rights of any kind are granted hereunder, by implication or otherwise with regard to such trademarks. Any additional third-party trademarks, which are not licensed hereunder and not under Aurigma Inc.'s control, are subject to applicable third-party terms and conditions. Notwithstanding any provision to the contrary herein, nothing in this Agreement shall be construed as to grant you any rights or licenses with regard to such third-party trademarks or to entitle you to use such third party trademarks.

1.2. Source Code

You acknowledge that the source code for the Product is proprietary to the Licensor or its suppliers and/or licensors and constitutes trade secrets of the Licensor or its suppliers and/or licensors. Except as otherwise specifically provided herein, you agree not to disassemble, decompile or "unlock", decode or otherwise reverse-translate or reverse-engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of the Product or any part thereof provided solely in Object Code form but you may change, add or delete any files of the licensed copy of the Products and you may adapt or modify the Source Code solely for purposes of Operating a licensed copy of the Product and as expressly permitted pursuant to the type of the License purchased hereunder provided that you may not, in any event, remove or alter any copyright notices or other proprietary notices on any copies of the Product, whether so modified or not, and further provided that any such change, addition, deletion, adaptation or modification voids any express warranty provided herein and terminates any right to support services.

1.3. Confidential Information

You agree that, unless otherwise specifically provided herein the Product, including the specific design and structure of individual programs and the Product, constitute confidential proprietary information of the Licensor or its suppliers and/or licensors. You agree not to transfer, copy, disclose, provide or otherwise make available such confidential information in any form to any third party. For purposes hereof, "License Key" shall mean a file or a unique sequence of digit and/or symbols provided to you by the Licensor confirming the purchase of the license from the Licensor, which may carry the information about the License, i.e. its type, the user name and the number of licenses purchased, and enabling the full functionality of the Product in accordance with the License granted under this Agreement. You agree to implement reasonable security measures to protect such confidential information provided however, that you may make and distribute unlimited copies of the trial version of Product in object code only, including copies for commercial distribution, as long as each copy that you make and distribute contains this Agreement subject to end user's acceptance before the first use, and the same copyright and other proprietary notices pertaining to the Product that appear in the Product and further provided, that in connection with the distribution of the trial version of the Product you do not charge any fees without Licensor's prior written consent. Notwithstanding the foregoing, any embedded License Key information in the html source shall not be deemed a public disclosure or a violation of this Agreement. If you download the Software from the Internet or similar on-line source, you must include the copyright notices resident on the Software with any on-line distribution and on any media you distribute that includes the Software.

2. Grant of License

2.1. License

The Licensor grants you the non-exclusive and non-transferable license to store, load, install, execute, and display (to "Use") the specified version of the Software on a specified number of computers, workstations or servers strictly in accordance with the Specifications of the Software (i.e. to upload electronic files), provided that, such Use is deemed to be processed with (i) a single server if such server has not more than 2 CPUs, having not more than eight (8) "cores" per each CPU, for which the Software was designed and/or (ii) a single virtual cloud storage (VCS), if such VCS does not transmit more than 10 TB of data (each a "Client Device") pursuant to the terms and conditions of this Agreement ("License") and you hereby agree and accept such License as follows:

    1. Trial Version. If you have received, downloaded and/or installed a trial version of the Product and are hereby granted an evaluation license for the Software and you may Use the Product only for evaluation purposes and only during the applicable evaluation period of sixty (60) days (the "Trial Period"), unless otherwise indicated, from the date of the initial installation. Any use of the Product for other purposes or beyond the applicable evaluation period is strictly prohibited, provided however that, subject to the restrictions contained herein, you may copy and distribute a Trial Version of the Product as provided in Section 1.3 hereof. The Licensor shall not be required to provide any support and Updates, for the Trial Version of the Product. During the Trial Period, the Licensor provides no warranty and assumes and bears no liability whatsoever for the Trial Version of the Product.
    2. Beta Version. If you have received, downloaded and/or installed a "beta" version of the Product and are hereby granted a testing license for the Software and you may Use the Product only for testing purposes, until a commercial version of the Software becomes available. You may not distribute nor sell the Beta Version, and shall refer all inquires concerning the same to the Licensor at the following: sales@aurigma.com. The Licensor provides no warranty and assumes and bears no liability whatsoever for the Beta Version of the Product.
    3. Development/QA License. If the Product is licensed to you under (i) Express License, (ii) Professional License, (iii) Print License and/or (iv) Premium License, as such terms defined below (collectively, "Commercial Licenses") you may additionally obtain Development/Quality Assurance (QA) License on the terms and at prices set forth in the current price lists and as specified in the applicable invoicing or packaging for the Product (the "Development/QA License"). If you obtain the Development/QA License, in addition to the rights granted to you under any of Commercial Licenses, you may implement the Software with additional one (1) Domain that can be solely used for development, testing and quality assurance purposes and NOT for any other commercial or personal use, provided that, the number of Domains on which the Software can be Used may be extended by purchasing additional Development/QA License. If the Product is licensed to you under the Development/QA License, Licensor will provide you with Aurigma Help Desk Technical Support Services on terms and conditions of the underlined Commercial Licenses purchased in conjunction with the Development/QA License.
    4. Express License. If the Product is licensed under Express License (having abbreviated features as set forth on Licensor Site at: http://www.aurigma.com/Products/ChoosingAurigmaImageUploaderEdition.aspx) with the Software provided in Object Code only upon the terms specified in the applicable invoicing or packaging for the Product, Licensee may, under Express License, Operate one copy of the specified version of the Product on one Client Device and implemented solely with one (1) internet domain (the "Domain"), provided that, you may change the Domain upon written request to Licensor and payment of fee as provided in the applicable invoicing for the Product or Licensor Site, and further provided that you shall discontinue using the original Domain as soon as you designate the new Domain. For purposes of this Agreement, the "Domain" shall mean a full qualified domain name (FQDN) specified during the License purchase, and does not include subdomains of the Domain except for Domain name preceded with "www." For purposes of illustration only, if you have a License for the Domain "somedomain.com," you CAN upload files, both to somedomain.com and www.somedomain.com, but you CANNOT upload to sub.somedomain.com as well as to any other subdomain or other domains.
    5. Professional License. If the Product is licensed under Professional License with the Software provided only in Object Code upon the terms specified in the applicable invoicing or packaging for the Product, you may Operate one (1) copy of the Product on one (1) Client Device and implemented solely with one (1) Domain (the "Professional License"), provided that, if you have purchased more than a single Professional License to Operate a single (1) copy of the Product on one or more Client Devices or with more than one Domain (the "Multisite Use Licenses"), then the number of the Multisite Use Licenses shall be determined by the number of the Domains or Client Devices that can be Operated with one (1) copy of the Product. Additionally, if the Product is licensed under the Professional License, subject to this Agreement, you may obtain up to three (3) Development/Quality Assurance (QA) Licenses at no charge, provided that, any additional Development/Quality Assurance (QA) Licenses can be obtained at 50% discount from the price listed on Licensor Site at the time of requesting such Development/Quality Assurance (QA) Licenses.
    6. Print License. If the Product is licensed under Print License, in addition to the rights granted to you pursuant to Professional License described above, you will have access to the Print Licensing Plan, which is detailed on Licensor Site at: http://www.aurigma.com/Products/ImageUploader/PricingLicensing.aspx and which includes, inter alia, such features as ability to Use the Product to upload thumbnails of unlimited size for, quality meter and preservation of EXIF metadata and image resolution (the "Print License"). Additionally, if the Product is licensed under the Print License, subject to this Agreement, you may obtain up to three (3) Development/Quality Assurance (QA) Licenses at no charge, provided that, any additional Development/Quality Assurance (QA) Licenses can be obtained at 50% discount from the price listed on Licensor Site at the time of requesting such Development/Quality Assurance (QA) Licenses.
    7. Premium License. If the Product is licensed under Premium License with the Software provided only in Object Code upon the terms specified in the applicable invoicing or packaging for the Product, you may Operate one (1) copy of the Product having all features of the other License plans detailed in this Agreement and/or Licensor Site, as well as additional functionalities as set forth on Licensor Site at: http://www.aurigma.com/Products/ChoosingAurigmaImageUploaderEdition.aspx) on one (1) Client Device and implemented with any number of Domains that are located on your Client Devices (the "Premium License"). If the Product is licensed under Premium License, you may, upon request and payment of the applicable fee (if any), receive a "private label" version of the Software as set forth on Licensor Site at: http://www.aurigma.com/Products/PrivateLabelVersion.aspx and pursuant to this Agreement and Section 2.5. Additionally, if the Product is licensed under the Premium License, subject to this Agreement, you may obtain up to six (6) Development/Quality Assurance (QA) Licenses at no charge, provided that, any additional Development/Quality Assurance (QA) Licenses can be obtained at 50% discount from the price listed on Licensor Site at the time of requesting such Development/Quality Assurance (QA) Licenses.
    8. Notwithstanding anything to the contrary herein, except as otherwise agreed by Licensor in writing you may not sub-license, assign or otherwise transfer any rights granted to you herein to any third party, provided that, you may distribute the applications or components developed Using the Product (the "Results") to your customers.
    9. Grant of Multiple Licenses. If you have purchased multiple licenses for the Product, as reflected the License Key granted to you by the Licensor, then the number of multiple licenses and the licensing terms reflected in the License Key shall determine the number of copies of the Product you may have, the permitted Uses, the number of Client Devices and the number of the Domains on which you may Use and Operate the Product provided that unless the type of the License and explicit licensing terms, i.e. Express License, Professional License and Print License, and the License Key provides otherwise, each purchased License entitles you to Use the Product on one (1) Client Device and implemented solely with one (1) Domain. The Licensor reserves all rights not expressly granted herein.

2.2. Third Party Software

In order to Operate the Product you may require additional third-party software which is not licensed hereunder and not under Licensor's control. Notwithstanding any provision to the contrary herein, nothing in this Agreement shall be construed as to grant you any rights or licenses with regard to such third-party software or to entitle you to use such software.

2.3. Multiple Environment Product; Multiple Language Product; Multiple Copies; Bundles

If you use different versions of the Product or different language editions of the Product, if you receive the Product on multiple media, if you otherwise receive multiple copies of the Product, or if you received the Product bundled with other software, the total permitted number of your Client Devices and/or Domain connectors and server connectors on which all versions of the Product are installed shall correspond to the number of licenses you have obtained from the Licensor provided that unless the licensing terms and the License Key provides otherwise, each purchased license entitles you to install and Use the Product on one (1) Client Device and/or Domain connectors and server connectors and implemented solely with one (1) Domain. You may not rent, bundle with other products or materials, lease, sublicense, lend or transfer any versions or copies of the Product regardless of whether you use the Product or not without Licensor's written consent.

2.4. Updates; Support and Maintenance Services

Upon request and paying an appropriate annual subscription fees, Licensor will provide you with Licensor's online technical support and maintenance services ("Help Desk and Maintenance Support Services") for a period of one (1) year period, provided that you may extend the Help Desk Support and Maintenance Services, as available, by providing at least thirty (30) day notice to Licensor and paying for the appropriate annual subscription fees to Licensor per applicable terms and conditions set forth on the Licensor Site. Among other benefits of the Help Desk Support Maintenance and Support Services is that, during the term thereof, you may download free Updates and New Releases to the Product when and as the Licensor publishes them in its website or through other online services. If a particular version of the Product is an Update to a previous version of the Product, you must possess a valid license to such previous version in order to Use the Update and/or New Releases. You may continue to use the previous version of the Product on Licensee System after you receive the Update and/or New Releases in order to facilitate the transition to the Update and/or New Releases, provided that the Update and/or New Releases and the previous version are installed on the same Client Device. Notwithstanding anything to the contrary herein, you hereby acknowledge and agree that any obligation that Licensor may have with regard to supporting the previous version of the Product shall end upon availability of the Update and/or New Releases (i.e. in lieu of Licensor's resolving issues with regard to the previous version, you may be asked to install an Update and/or New Releases). Notwithstanding any provision to the contrary herein, except as specifically provided herein, nothing in this Agreement shall be construed as to grant you any rights or licenses with regard to the Updates and/or New Releases of the Product or to entitle you to any Updates and/or New Release. This Agreement does not obligate the Licensor to provide any Updates and/or New Release. Notwithstanding the foregoing, any Updates and/or New Release that you may receive become part of the Product and the terms of this Agreement apply to them (unless this Agreement is superceded by a further Agreement accompanying such Update or modified version of to the Product).

2.5. Customization and Fees

Licensor, solely at its own discretion, upon Licensee's written request and payment of the applicable fees, may create a customized version of the Product ("Customized Product") in accordance with the specifications provided by Licensee and agreed on by the Licensor. Notwithstanding anything contrary herein and for avoidance of doubt, Licensee hereby expressly agrees, that all right, title and interest to Customized Product and its derivative materials developed by the Licensor pursuant to this Section 2.5, including without limitations, a revision, modification, translation, abridgement, condensation, expansion, or any other form in which Product may be recast, transformed, or adapted ("Customization Materials") shall (i) solely belong to and be owned by the Licensor, and (ii) if applicable, vest in the Licensor immediately and irrevocably upon its creation and the Licensor shall have and enjoy any and all proprietary rights in and to the Customization Materials and Customized Product under all federal, state, and international intellectual property laws (including, without limitation, the Copyright Act of 1976, as amended) and laws of any other applicable jurisdiction.

2.6. OEM

Nothing contained in this Agreement allows you to bundle, merge or otherwise combine the Product or any portion thereof with your own application or application of any third party for any reason whatsoever. You may bundle, merge or otherwise combine the Product with your own application or application of any third party for which you legally obtained a license from such third party upon Licensor's written consent, which can be withheld at Licensor's sole discretion, and entering into an OEM agreement provided to you by Licensor ("OEM Agreement").

2.7. Licensee's Additional Obligations

Licensee shall maintain and enforce on its site or other applicable site where the Product is Operated, a privacy policy in accordance with industry standards and "terms of use" or "terms of service" as to which Licensee's customers must explicitly agree to prior to any use. Such documents shall detail, describe and restrict the use of the Products by site's customer and visitors to the rights granted to Licensee herein and provide protection, at least as restrictive of Licensor's proprietary rights, including without limitation, intellectual property rights and remedies, as this Agreement.

3. Term and Termination

The term of this Agreement ("Term") shall begin when you download, explicitly agree to the terms hereof, start Using the Product or install the Product (whichever is earlier) and shall continue, unless otherwise terminated pursuant hereto, in perpetuity or for the term specified in the License granted hereunder. The Licensor may terminate this Agreement by offering you a superseding Agreement for the Product or any replacement or modified version of or upgrade or New Release of the Product and conditioning your continued use of the Product or such replacement, modified or upgraded version or New Release on your acceptance of such superseding Agreement. This Agreement may be also terminated by the Licensor immediately and without notice if you fail to comply with any of your obligation or conditions of this Agreement. Without prejudice to any other rights, this Agreement will terminate automatically if you fail to comply with any of the limitations or other requirements described herein. Upon any termination or expiration of this Agreement, you must immediately cease use of the Product and destroy all copies of the Product.

No Rights Upon Termination. Upon termination of this Agreement you will no longer be authorized to Operate or use the Product in any way.

Material Terms and Conditions. You specifically agree that each of the terms and conditions of this Section 2 are material and that failure of you to comply with these terms and conditions shall constitute sufficient cause for Licensor to immediately terminate this Agreement and the License granted under this Agreement. The presence of this Section 3.3 shall not be relevant in determining the materiality of any other provision or breach of this Agreement by either party hereto.

4. Additional Covenants; Assignment of Intellectual Property Rights

4.1. Additional Limitations

Except as otherwise agreed by Licensor in writing, notwithstanding anything to the contrary herein, you may not Operate, Use, or modify the Product in any way as to form the basis for creating a product that provides the same, or substantially the same, functionality as the Product; and in the event you develop any modifications, enhancements, derivative works and/or extensions to the Product, either independently or jointly with Licensor, such modifications, enhancements, derivative works and/or extensions and all rights associated therewith will be the exclusive property of Licensor. You will not grant, either expressly or impliedly, any rights, title, interest, or licenses to any such modifications, enhancements, derivative works and/or extensions to any third party. You will, however, be entitled to use such modifications, enhancements, derivative works and/or extensions under the terms set forth in this Agreement. You hereby assign all right, title and interest in and to such modifications, enhancements, derivative works and/or extensions to the Product to Licensor. You also agree to execute, acknowledge and deliver to Licensor all documents and do all things Licensor deems necessary or desirable, at no cost to but at Licensor expense, to enable Licensor to obtain and secure such modifications, enhancements, derivative works and/or extensions anywhere in the world. You agree to secure all necessary rights and obligations from relevant employees or third parties in order to satisfy the above obligations.

4.2. Indemnification

In addition to the other requirements set forth in this Section 3, you hereby agree to indemnify, hold harmless, and defend Licensor from and against any and all liabilities, damages, losses, costs and expenses (including reasonable attorneys' fees) arising from or related to any claim, action, proceeding or allegation that arises or results, either directly or indirectly, from the use and distribution of any of your software application product(s), components or Results by any third party, including without limitation any of your customers and/or end-users.

5. Restrictions

5.1. No Transfers

Except as otherwise agreed by Licensor in writing, under no circumstances you shall sell, loan, rent, lease, loan, license, sublicense, publish, display, distribute, or otherwise transfer to a third party the Product, any copy or use thereof, in whole or in part, without Licensor's prior written consent, provided that if such non-waivable right is specifically granted to you under applicable law in your jurisdiction you may transfer your rights under this Agreement permanently to another person or entity, provided that a) you also transfer this Agreement, the Product, all accompanying printed materials, and all other software or hardware bundled or pre-installed with the Product, including all copies, Updates and prior versions, to such person or entity; b) retain no copies, including backups and copies stored on a Client Device; and c) the receiving party accepts the terms and conditions of this Agreement and any other terms and conditions upon which you legally purchased a license to the Product. Notwithstanding the foregoing, you may not transfer education, pre-release, or "not for resale" copies of the Product. In no case you may permit third parties to benefit from the use or functionality of the Product via a timesharing, service bureau or other arrangement, except to the extent such use is specified in the application price list, purchase order or product packaging for the Product.

5.2. Prohibitions

Except as otherwise specifically provided for in this Agreement, you may not use, copy, emulate, clone, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer, or otherwise reduce any party of the Product to human readable form or transfer the licensed Product, or any subset of the licensed Product, nor permit any third party to do so, except to the extent the foregoing restriction is expressly prohibited by applicable law. Notwithstanding the foregoing sentence, decompiling the Software is permitted to the extent the laws of your jurisdiction give you the non-waivable right to do so to obtain information necessary to render the Software interoperable with other software; provided, however, that you must first request such information from the Licensor and the Licensor may, in its discretion, either provide such information to you (subject to confidentiality terms) or impose reasonable conditions, including a reasonable fee, on such use of the Software to ensure that the Licensor's and its suppliers and/or licensors proprietary rights in the Software are protected. You may not modify, or create derivative works based upon the Product in whole or in part. Any such unauthorized use shall result in immediate and automatic termination of this Agreement and the License granted hereunder and may result in criminal and/or civil prosecution. Neither Product's binary code nor source may be used or reverse engineered to re-create the program algorithm, which is proprietary, without written permission of the Licensor. All rights not expressly granted here are reserved by Licensor and/or its suppliers and licensors, as applicable.

5.3. License Key

Except as specifically provided in this Agreement, you may not give, make available, give away, sell or otherwise transfer your registration License Key or any copy thereof to a third party. Product's License Key may not be distributed, except as provided herein, outside of the area of legal control of the person or persons who purchased the original License, without written permission of the Licensor. Doing so will result in an infringement of copyright. The Licensor retains the right of claims for compensation in respect of damage which occurred by your giving away the License Key or registration code contained therein. This claim shall also extend to all costs which the Licensor or its licensors incur in defending themselves.

5.4. No Extraction for Separate Use

You shall not extract or Use any functionality of this Software other than as part of normal Operation of the Product described in the Documentation and as integral part of Operation and functionality of the Product as a whole.

5.5. Proprietary Notices; Digital Signature and Copies

You may not remove any proprietary notices or labels on the Product. The Product shall always retain and maintain all electronic prominent copyright, logos and other notices (e.g. "Copyright © 2010 Aurigma Inc. and its licensors. All rights reserved" and/or "Powered by Aurigma"), including without limitation Thawte and other digital certificates as originally placed by Licensor. You may not copy the Product except as expressly permitted in Section 2 above.

5.6. No Transfer of Rights

Except as otherwise specifically provided herein, you may not transfer or assign any of the rights granted to you under this Agreement or any of your obligations pursuant hereto.

5.7. Compliance with Law

You agree that in Operating the Product and in using any report or information derived as a result of Operating this Product, you will comply with all applicable international, national, state, regional and local laws and regulations, including, without limitation, privacy, copyright, export control and obscenity law.

5.8. Additional Protection Measures

Solely for the purpose of preventing unlicensed use of the Product, the Software may install on your computer technological measures that are designed to prevent unlicensed use, and the Licensor may use this technology to confirm that you have a licensed copy of the Product. The update of these technological measures may occur through the installation of the Updates. The Updates will not install or may fail to Operate if installed on unlicensed copies of the Product. If you are not using a licensed copy of the Product, you are not allowed to install the Updates. The Licensor will not collect any personally identifiable information from your computer during this process.

6. LIMITED WARRANTY AND DISCLAIMER

6.1. Limited Warranty

The Licensor warrants that for the larger of (x) sixty (60) days and (y) the minimum warranty period required by non-waivable provision of applicable law (the "Warranty Period"), from the earlier of (i) original purchase of the media on which the Product is contained, or (ii) the date the License Key is provided to you by Licensor, the Product will be free from defects in materials and workmanship and that the Product will perform substantially in accordance with the Documentation or generally conform to the Product's specifications published by the Licensor. Non-substantial variations of performance from the Documentation do not establish a warranty right. THIS LIMITED WARRANTY DOES NOT APPLY TO TRIAL AND EVALUATION VERSIONS, UPDATES, PRE-RELEASE, TRYOUT, PRODUCT SAMPLER, OR NOT FOR RESALE (NFR) COPIES OF PRODUCT. To make a warranty claim, you must return the Product to the location where you obtained it along with proof of purchase within the applicable Warranty Period of the license fee you paid for the Product. THE LIMITED WARRANTY SET FORTH IN THIS SECTION GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE ADDITIONAL RIGHTS WHICH VARY FROM JURISDICTION TO JURISDICTION.

6.2. Customer Remedies

The Licensor and its suppliers' entire liability and your exclusive remedy for any breach of the foregoing warranty shall be at the Licensor's option: (i) return of the purchase price paid for the license, if any, (ii) replacement of the defective media in which the Product is contained or replacement of the conforming version of the Product, including, at the option of the Licensor, an upgrade to a later version or release of the Product, or (iii) correction of the defects, "bugs" or errors within reasonable period of time. You must return or make available the defective media and/or the Product to the Licensor at your expense with a copy of your receipt. This limited warranty is void if the defect has resulted from accident, abuse, or misapplication. Any replacement media will be warranted for the remainder of the original warranty period.

6.3. NO IMPLIED OR OTHER WARRANTIES

EXCEPT FOR THE FOREGOING LIMITED WARRANTY AND FOR ANY WARRANTY, CONDITION, REPRESENTATION OR TERM TO THE EXTENT TO WHICH THE SAME CANNOT OR MAY NOT BE EXCLUDED OR LIMITED BY LAW APPLICABLE TO YOU IN YOUR JURISDICTION, THE PRODUCT IS PROVIDED "AS-IS" WITHOUT ANY WARRANTY WHATSOEVER AND THE LICENSOR MAKES NO PROMISES, REPRESENTATIONS OR WARRANTIES, WHETHER EXPRESSED OR IMPLIED, WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE, REGARDING OR RELATING TO THE PRODUCT OR CONTENT THEREIN OR TO ANY OTHER MATERIAL FURNISHED OR PROVIDED TO YOU PURSUANT TO THIS AGREEMENT OR OTHERWISE. YOU ASSUME ALL RISKS AND RESPONSIBILITIES FOR SELECTION OF THE PRODUCT TO ACHIEVE YOUR INTENDED RESULTS, AND FOR THE INSTALLATION OF, USE OF, AND RESULTS OBTAINED FROM THE PRODUCT. THE LICENSOR MAKES NO WARRANTY THAT THE PRODUCT WILL BE ERROR FREE OR FREE FROM INTERRUPTION OR FAILURE, OR THAT IT IS COMPATIBLE WITH ANY PARTICULAR HARDWARE OR SOFTWARE. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, LICENSOR DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT OF THIRD PARTY RIGHTS, INTEGRATION, SATISFACTORY QUALITY OR FITNESS FOR ANY PARTICULAR PURPOSE WITH RESPECT TO THE PRODUCT AND THE ACCOMPANYING WRITTEN MATERIALS OR THE USE THEREOF. SOME JURISDICTIONS DO NOT ALLOW LIMITATIONS ON IMPLIED WARRANTIES, SO THE ABOVE LIMITATION MAY NOT APPLY TO YOU. YOU HEREBY ACKNOWLEDGE THAT THE PRODUCT MAY NOT BE OR BECOME AVAILABLE DUE TO ANY NUMBER OF FACTORS INCLUDING WITHOUT LIMITATION PERIODIC SYSTEM MAINTENANCE, SCHEDULED OR UNSCHEDULED, ACTS OF GOD, TECHNICAL FAILURE OF THE SOFTWARE, TELECOMMUNICATIONS INFRASTRUCTURE, OR DELAY OR DISRUPTION ATTRIBUTABLE TO VIRUSES, DENIAL OF SERVICE ATTACKS, INCREASED OR FLUCTUATING DEMAND, AND ACTIONS AND OMISSIONS OF THIRD PARTIES. THEREFORE, THE LICENSOR EXPRESSLY DISCLAIMS ANY EXPRESS OR IMPLIED WARRANTY REGARDING SYSTEM AND/OR SOFTWARE AVAILABILITY, ACCESSIBILITY, OR PERFORMANCE. THE LICENSOR DISCLAIMS ANY AND ALL LIABILITY FOR THE LOSS OF DATA DURING ANY COMMUNICATIONS AND ANY LIABILITY ARISING FROM OR RELATED TO ANY FAILURE BY THE LICENSOR TO TRANSMIT ACCURATE OR COMPLETE INFORMATION TO YOU.

6.4. LIMITED LIABILITY; NO LIABILITY FOR CONSEQUENTIAL DAMAGES

YOU ASSUME THE ENTIRE COST OF ANY DAMAGE RESULTING FROM YOUR USE OF THE PRODUCT AND THE INFORMATION CONTAINED IN OR COMPILED BY THE PRODUCT, AND THE INTERACTION (OR FAILURE TO INTERACT PROPERLY) WITH ANY OTHER HARDWARE OR SOFTWARE WHETHER PROVIDED BY THE LICENSOR OR A THIRD PARTY. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT WILL THE LICENSOR OR ITS SUPPLIERS OR LICENSORS BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, LOSS OF GOODWILL, WORK STOPPAGE, HARDWARE OR SOFTWARE DISRUPTION IMPAIRMENT OR FAILURE, REPAIR COSTS, TIME VALUE OR OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OR INABILITY TO USE THE PRODUCT, OR THE INCOMPATIBILITY OF THE PRODUCT WITH ANY HARDWARE SOFTWARE OR USAGE, EVEN IF SUCH PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT WILL LICENSOR'S TOTAL LIABILITY TO YOU FOR ALL DAMAGES IN ANY ONE OR MORE CAUSE OF ACTION, WHETHER IN CONTRACT, TORT OR OTHERWISE EXCEED THE AMOUNT PAID BY YOU FOR THE PRODUCT. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY TO THE EXTENT THAT APPLICABLE LAW PROHIBITS SUCH LIMITATION. FURTHERMORE, BECAUSE SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

7. Notice to U.S. Users.

7.1. Notice to U.S. Government End Users

The Product and accompanying Documentation are deemed to be "Commercial Items", as that term is defined at 48 C.F.R. §2.101, consisting of "Commercial Computer Software" and "Commercial Computer Software Documentation", respectively, as such terms are used in 48 C.F.R. §12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §§227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government end users (a) only as Commercial Items and (b) with only those rights, including any use, modification, reproduction, release, performance, display or disclosure of the Product and accompanying Documentation, as are granted to all other end users pursuant to the terms and conditions herein. Unpublished-rights reserved under the copyright laws of the United States.

7.2. U.S. Export Restrictions for U.S. Users

If you are a U.S. person or entity or if you are otherwise subject to U.S. laws and regulations, you acknowledge and agree that the Product may be subject to restrictions and controls imposed by the Export Administration Act and the Export Administration Regulations of the United States (the "Acts"). You agree and certify that neither the Product nor any direct product thereof is being or will be used for any purpose prohibited by the Acts. You may not Operate, download, export, or re-export the Product (a) into, or to a national or resident of, any country to which the United States has embargoed goods, or (b) to anyone on the United States Treasury Department's list of Specially Designated Nationals or the U.S. Commerce Department's Table of Deny Orders. By Using the Product, you are representing and warranting that you are not located in, under the control of, or a national or resident of any such country or on any such list. You acknowledge that it is your sole responsibility to comply with any and all government export and other applicable laws and that the Licensor has no further responsibility for such after the initial license to you. You warrant and represent that neither the U.S. Commerce Department, Bureau of Export Administration nor any other U.S. federal agency has suspended, revoked or denied your export privileges.

8. Your Information and the Licensor's Privacy Policy.

8.1. Privacy Policy

You hereby expressly consent to the Licensor's processing of your personal data (which may be collected by the Licensor or its distributors) according to the Licensor's current privacy policy as of the date of the effectiveness hereof which is incorporated into this Agreement by reference (see http://www.aurigma.com/About/Privacy.aspx). By entering into this Agreement, you agree that the Licensor may collect and retain information about you, including your name, email address and credit card information. The Licensor employs other companies and individuals to perform functions its behalf. Examples include fulfilling orders, delivering packages, sending postal mail and e-mail, removing repetitive information from customer lists, analyzing data, providing marketing assistance, processing credit card payments, and providing customer service. They have access to personal information needed to perform their functions, but may not use it for other purposes. The Licensor publishes a privacy policy on its web site and may amend such policy from time to time in its sole discretion. You should refer to the Licensor's privacy policy prior to agreeing to this Agreement for a more detailed explanation of how your information will be stored and used by the Licensor. If "you" are an organization, you will ensure that each member of your organization (including employees and contractors) about whom personal data may be provided to the Licensor has given his or her express consent to the Licensor's processing of such personal data. Personal data will be processed by the Licensor or its distributors in the country where it was collected, and possibly in the United States, European Union and Russian Federation. The laws of such jurisdictions regarding processing of personal data may be less or more stringent than the laws in your jurisdiction.

9. Miscellaneous.

9.1. Governing Law; Jurisdiction and Venue

This Agreement shall be governed by and construed and enforced in accordance with the laws of the Commonwealth of Virginia without reference to conflicts of law rules and principles. To the extent permitted by law, the provisions of this Agreement shall supersede any provisions of the Uniform Commercial Code as adopted or made applicable to the Products in any competent jurisdiction. This Agreement shall not be governed by the United Nations Convention on Contracts for the International Sale of Goods, the application of which is expressly disclaimed and excluded. If you are a resident of the United States for purpose of determination of personal jurisdiction, the federal and state courts within the Commonwealth of Virginia shall have exclusive jurisdiction to adjudicate any dispute arising out of this Agreement. You agree that this Agreement is to be performed in the Commonwealth of Virginia and that any action, dispute, controversy, or claim that may be instituted based on this Agreement, or arising out of or related to this Agreement or any alleged breach thereof, shall be prosecuted exclusively in the state and federal courts in of the Commonwealth Virginia and you, to the extent permitted by applicable law, hereby waive the right to change venue to any other state, county, district or jurisdiction; provided, however, that the Licensor as claimant shall be entitled to initiate proceedings in any court of competent jurisdiction. If you are a non-US resident you hereby agree that any dispute, controversy or claim arising or concerning this Agreement shall be determined and settled by arbitration in accordance with the International Chamber of Commerce accordance with the Rules of Arbitration of the International Chamber of Commerce (the "Rules"). The claimant party shall appoint one arbitrator and the respondent party shall appoint one arbitrator, and the two arbitrators so appointed shall appoint the third arbitrator, in accordance with the provisions of the Rules. The place of arbitration shall be Washington, DC, USA. The language of the arbitration shall be English. Any award granted by the arbitrator(s) shall be final and binding upon the involved parties and shall constitute the sole and exclusive remedy for any dispute between the involved parties regarding the issue at dispute resolved by such arbitration.

9.2. Period for Bringing Actions

No action, regardless of form, arising out of the transactions under this Agreement, may be brought by either party hereto more than one (1) year after the cause of action has occurred, or was discovered to have occurred, except that an action for infringement of intellectual property rights may be brought within the maximum applicable statutory period.

9.3. Entire Agreement; Severability; No Waiver

This Agreement is the entire agreement between you and supersedes any other prior agreements, proposals, communications or advertising, oral or written, with respect to the Product or to subject matter of this Agreement provided that the Licensor and you may limit, modify or changes the applicability of the terms of this Agreement by a prior, contemporaneous or subsequent written agreement by referencing this Section 9.3 of the Agreement and expressly providing for such limitation, modification or changes. You acknowledge that you have read this Agreement, understand it and agree to be bound by its terms. If any provision of this Agreement is found by a court of competent jurisdiction to be invalid, void, or unenforceable for any reason, in whole or in part, such provision will be more narrowly construed so that it becomes legal and enforceable, and the entire Agreement will not fail on account thereof and the balance of the Agreement will continue in full force and effect to the fullest extent permitted by law. No waiver of any breach of any provisions of this Agreement will constitute a waiver of any prior, concurrent or subsequent breach and no waiver will be effective unless made in writing. Notwithstanding any provisions to the contrary herein, the provisions concerning the confidential information, Licensee's obligations with respect to intellectual property rights or any duties, liabilities or obligations which by the terms hereof or in context are to survive termination, shall survive the termination or expiration of this Agreement and such termination or expiration shall not release Licensee of its obligations regarding such survived provisions.

9.4. Contact Information

Should you have any questions concerning this Agreement, or if you desire to contact the Licensor for any reason, please contact our Customer Department at: info@aurigma.com.

Copyright © 2002-2010 Aurigma Inc., and its licensors. All rights reserved. The Product, including the Software and any accompanying Documentation, are copyrighted and protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. Aurigma ® is a US registered trademark of Aurigma Inc. Any other third-party trademarks, which are not licensed hereunder and not under Aurigma Inc.'s control, are properties of the respective third party owners and licensees and are subject to applicable third-party terms and conditions.


DataBind Method

AmazonS3Extender..::.DataBind Method

  • Collapse All Sections
  • AmazonS3Extender Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | DataBind()()() | (Inherited from Control.)
Protected method | DataBind(Boolean) | (Inherited from Control.)

See Also

Reference

  • AmazonS3Extender Class
  • AmazonS3Extender Members
  • Aurigma.ImageUploader.AmazonS3 Namespace


FindControl Method

AmazonS3Extender..::.FindControl Method

  • Collapse All Sections
  • AmazonS3Extender Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | FindControl(String) | (Inherited from Control.)
Protected method | FindControl(String, Int32) | (Inherited from Control.)

See Also

Reference

  • AmazonS3Extender Class
  • AmazonS3Extender Members
  • Aurigma.ImageUploader.AmazonS3 Namespace


RenderControl Method

AmazonS3Extender..::.RenderControl Method

  • Collapse All Sections
  • AmazonS3Extender Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)

See Also

Reference

  • AmazonS3Extender Class
  • AmazonS3Extender Members
  • Aurigma.ImageUploader.AmazonS3 Namespace


CreateErrorDesignTimeHtml Method

AmazonS3Designer..::.CreateErrorDesignTimeHtml Method

  • Collapse All Sections
  • AmazonS3Designer Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Protected method | CreateErrorDesignTimeHtml(String) | (Inherited from ControlDesigner.)
Protected method | CreateErrorDesignTimeHtml(String, Exception) | (Inherited from ControlDesigner.)

See Also

Reference

  • AmazonS3Designer Class
  • AmazonS3Designer Members
  • Aurigma.ImageUploader.AmazonS3.Design Namespace


CreatePlaceHolderDesignTimeHtml Method

AmazonS3Designer..::.CreatePlaceHolderDesignTimeHtml Method

  • Collapse All Sections
  • AmazonS3Designer Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Protected method | CreatePlaceHolderDesignTimeHtml()()() | (Inherited from ControlDesigner.)
Protected method | CreatePlaceHolderDesignTimeHtml(String) | (Inherited from ControlDesigner.)

See Also

Reference

  • AmazonS3Designer Class
  • AmazonS3Designer Members
  • Aurigma.ImageUploader.AmazonS3.Design Namespace


Dispose Method

AmazonS3Designer..::.Dispose Method

  • Collapse All Sections
  • AmazonS3Designer Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | Dispose()()() | (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | (Inherited from HtmlControlDesigner.)

See Also

Reference

  • AmazonS3Designer Class
  • AmazonS3Designer Members
  • Aurigma.ImageUploader.AmazonS3.Design Namespace


Invalidate Method

AmazonS3Designer..::.Invalidate Method

  • Collapse All Sections
  • AmazonS3Designer Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | Invalidate()()() | (Inherited from ControlDesigner.)
Public method | Invalidate(Rectangle) | (Inherited from ControlDesigner.)

See Also

Reference

  • AmazonS3Designer Class
  • AmazonS3Designer Members
  • Aurigma.ImageUploader.AmazonS3.Design Namespace


DataBind Method

BaseControl..::.DataBind Method

  • Collapse All Sections
  • BaseControl Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | DataBind()()() | (Inherited from Control.)
Protected method | DataBind(Boolean) | (Inherited from Control.)

See Also

Reference

  • BaseControl Class
  • BaseControl Members
  • Aurigma.ImageUploader Namespace


FindControl Method

BaseControl..::.FindControl Method

  • Collapse All Sections
  • BaseControl Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | FindControl(String) | (Inherited from Control.)
Protected method | FindControl(String, Int32) | (Inherited from Control.)

See Also

Reference

  • BaseControl Class
  • BaseControl Members
  • Aurigma.ImageUploader Namespace


RenderControl Method

BaseControl..::.RenderControl Method

  • Collapse All Sections
  • BaseControl Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)

See Also

Reference

  • BaseControl Class
  • BaseControl Members
  • Aurigma.ImageUploader Namespace


DataBind Method

BaseExtender..::.DataBind Method

  • Collapse All Sections
  • BaseExtender Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | DataBind()()() | (Inherited from Control.)
Protected method | DataBind(Boolean) | (Inherited from Control.)

See Also

Reference

  • BaseExtender Class
  • BaseExtender Members
  • Aurigma.ImageUploader Namespace


FindControl Method

BaseExtender..::.FindControl Method

  • Collapse All Sections
  • BaseExtender Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | FindControl(String) | (Inherited from Control.)
Protected method | FindControl(String, Int32) | (Inherited from Control.)

See Also

Reference

  • BaseExtender Class
  • BaseExtender Members
  • Aurigma.ImageUploader Namespace


RenderControl Method

BaseExtender..::.RenderControl Method

  • Collapse All Sections
  • BaseExtender Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)

See Also

Reference

  • BaseExtender Class
  • BaseExtender Members
  • Aurigma.ImageUploader Namespace


DataBind Method

BaseUploadControl..::.DataBind Method

  • Collapse All Sections
  • BaseUploadControl Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | DataBind()()() | (Inherited from Control.)
Protected method | DataBind(Boolean) | (Inherited from Control.)

See Also

Reference

  • BaseUploadControl Class
  • BaseUploadControl Members
  • Aurigma.ImageUploader Namespace


FindControl Method

BaseUploadControl..::.FindControl Method

  • Collapse All Sections
  • BaseUploadControl Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | FindControl(String) | (Inherited from Control.)
Protected method | FindControl(String, Int32) | (Inherited from Control.)

See Also

Reference

  • BaseUploadControl Class
  • BaseUploadControl Members
  • Aurigma.ImageUploader Namespace


RenderControl Method

BaseUploadControl..::.RenderControl Method

  • Collapse All Sections
  • BaseUploadControl Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)

See Also

Reference

  • BaseUploadControl Class
  • BaseUploadControl Members
  • Aurigma.ImageUploader Namespace


DataBind Method

BaseUploaderExtender..::.DataBind Method

  • Collapse All Sections
  • BaseUploaderExtender Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | DataBind()()() | (Inherited from Control.)
Protected method | DataBind(Boolean) | (Inherited from Control.)

See Also

Reference

  • BaseUploaderExtender Class
  • BaseUploaderExtender Members
  • Aurigma.ImageUploader Namespace


FindControl Method

BaseUploaderExtender..::.FindControl Method

  • Collapse All Sections
  • BaseUploaderExtender Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | FindControl(String) | (Inherited from Control.)
Protected method | FindControl(String, Int32) | (Inherited from Control.)

See Also

Reference

  • BaseUploaderExtender Class
  • BaseUploaderExtender Members
  • Aurigma.ImageUploader Namespace


RenderControl Method

BaseUploaderExtender..::.RenderControl Method

  • Collapse All Sections
  • BaseUploaderExtender Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)

See Also

Reference

  • BaseUploaderExtender Class
  • BaseUploaderExtender Members
  • Aurigma.ImageUploader Namespace


CreateInstance Method

GradientColorConverter..::.CreateInstance Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | CreateInstance(IDictionary) | (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | (Inherited from TypeConverter.)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


GetCreateInstanceSupported Method

GradientColorConverter..::.GetCreateInstanceSupported Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | GetCreateInstanceSupported()()() | (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


GetProperties Method

GradientColorConverter..::.GetProperties Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | GetProperties(Object) | (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | (Inherited from TypeConverter.)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


GetPropertiesSupported Method

GradientColorConverter..::.GetPropertiesSupported Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | GetPropertiesSupported()()() | (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


GetStandardValues Method

GradientColorConverter..::.GetStandardValues Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | GetStandardValues()()() | (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | (Inherited from TypeConverter.)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


GetStandardValuesExclusive Method

GradientColorConverter..::.GetStandardValuesExclusive Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | GetStandardValuesExclusive()()() | (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | (Inherited from TypeConverter.)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


GetStandardValuesSupported Method

GradientColorConverter..::.GetStandardValuesSupported Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | GetStandardValuesSupported()()() | (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


IsValid Method

GradientColorConverter..::.IsValid Method

  • Collapse All Sections
  • GradientColorConverter Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | IsValid(Object) | (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)

See Also

Reference

  • GradientColorConverter Class
  • GradientColorConverter Members
  • Aurigma.ImageUploader Namespace


DataBind Method

InstallationProgress..::.DataBind Method

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | DataBind()()() | (Inherited from Control.)
Protected method | DataBind(Boolean) | (Inherited from Control.)

See Also

Reference

  • InstallationProgress Class
  • InstallationProgress Members
  • Aurigma.ImageUploader Namespace


FindControl Method

InstallationProgress..::.FindControl Method

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | FindControl(String) | (Inherited from Control.)
Protected method | FindControl(String, Int32) | (Inherited from Control.)

See Also

Reference

  • InstallationProgress Class
  • InstallationProgress Members
  • Aurigma.ImageUploader Namespace


RenderControl Method

InstallationProgress..::.RenderControl Method

  • Collapse All Sections
  • InstallationProgress Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)

See Also

Reference

  • InstallationProgress Class
  • InstallationProgress Members
  • Aurigma.ImageUploader Namespace


DataBind Method

NirvanixExtender..::.DataBind Method

  • Collapse All Sections
  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | DataBind()()() | (Inherited from Control.)
Protected method | DataBind(Boolean) | (Inherited from Control.)

See Also

Reference

  • NirvanixExtender Class
  • NirvanixExtender Members
  • Aurigma.ImageUploader.Nirvanix Namespace


FindControl Method

NirvanixExtender..::.FindControl Method

  • Collapse All Sections
  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | FindControl(String) | (Inherited from Control.)
Protected method | FindControl(String, Int32) | (Inherited from Control.)

See Also

Reference

  • NirvanixExtender Class
  • NirvanixExtender Members
  • Aurigma.ImageUploader.Nirvanix Namespace


RenderControl Method

NirvanixExtender..::.RenderControl Method

  • Collapse All Sections
  • NirvanixExtender Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)

See Also

Reference

  • NirvanixExtender Class
  • NirvanixExtender Members
  • Aurigma.ImageUploader.Nirvanix Namespace


DataBind Method

Thumbnail..::.DataBind Method

  • Collapse All Sections
  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | DataBind()()() | (Inherited from Control.)
Protected method | DataBind(Boolean) | (Inherited from Control.)

See Also

Reference

  • Thumbnail Class
  • Thumbnail Members
  • Aurigma.ImageUploader Namespace


FindControl Method

Thumbnail..::.FindControl Method

  • Collapse All Sections
  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | FindControl(String) | (Inherited from Control.)
Protected method | FindControl(String, Int32) | (Inherited from Control.)

See Also

Reference

  • Thumbnail Class
  • Thumbnail Members
  • Aurigma.ImageUploader Namespace


RenderControl Method

Thumbnail..::.RenderControl Method

  • Collapse All Sections
  • Thumbnail Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)

See Also

Reference

  • Thumbnail Class
  • Thumbnail Members
  • Aurigma.ImageUploader Namespace


DataBind Method

Uploader..::.DataBind Method

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | DataBind()()() | (Inherited from Control.)
Protected method | DataBind(Boolean) | (Inherited from Control.)

See Also

Reference

  • Uploader Class
  • Uploader Members
  • Aurigma.ImageUploader Namespace


FindControl Method

Uploader..::.FindControl Method

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | FindControl(String) | (Inherited from Control.)
Protected method | FindControl(String, Int32) | (Inherited from Control.)

See Also

Reference

  • Uploader Class
  • Uploader Members
  • Aurigma.ImageUploader Namespace


RenderControl Method

Uploader..::.RenderControl Method

  • Collapse All Sections
  • Uploader Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)

See Also

Reference

  • Uploader Class
  • Uploader Members
  • Aurigma.ImageUploader Namespace


DataBind Method

UploadRequest..::.DataBind Method

  • Collapse All Sections
  • UploadRequest Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | DataBind()()() | (Inherited from Control.)
Protected method | DataBind(Boolean) | (Inherited from Control.)

See Also

Reference

  • UploadRequest Class
  • UploadRequest Members
  • Aurigma.ImageUploader Namespace


FindControl Method

UploadRequest..::.FindControl Method

  • Collapse All Sections
  • UploadRequest Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | FindControl(String) | (Inherited from Control.)
Protected method | FindControl(String, Int32) | (Inherited from Control.)

See Also

Reference

  • UploadRequest Class
  • UploadRequest Members
  • Aurigma.ImageUploader Namespace


RenderControl Method

UploadRequest..::.RenderControl Method

  • Collapse All Sections
  • UploadRequest Class
  • See Also
  • Language Filter ( all languages )

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | (Inherited from Control.)

See Also

Reference

  • UploadRequest Class
  • UploadRequest Members
  • Aurigma.ImageUploader Namespace