Standard 版 V4

BB FlashBack の紹介

BB FlashBack はスクリーンレコーダーです。パソコンの画面の動きをムービーとして録画します。

録画が簡単

マウスの数クリックで BB FlashBack は Windows のデスクトップ上の動きをすべて録画することができます。

パソコンのサウンドを録音することもできます。マイクが接続されていればナレーションを吹き込むことも可能です。

パソコンに Web カメラが接続されていれば BB FlashBack はカメラからの映像も録画し、「ピクチャ・イン・ピクチャ」のムービーを生成することができます。

詳細は「BB FlashBack の基本」を参照してください。

ビデオ配信サイトへの簡単アップロード

BB FlashBack は、YouTube、Blip.tv、Viddler、Revver などの有名なビデオ配信サイトにムービーをアップロードすることで、ムービーの共有を簡単に行うことができます。

詳細は、「ムービーのアップロード」を参照してください。

一般的な形式への外部出力

ムービーは Flash、QuickTime (H264)、MPEG4、Windows Media Video (WMV)、GIF または AVI フォーマットへの出力が可能で、事実上すべての PC もしくはすべてのブラウザから視聴可能です。

詳細は、「ムービーの出力について」を参照してください。


ブルーベリーへのお問い合わせ

Blueberry はカスタムソフトウェアの開発と、専門技術および顧客のビジネス要求に対する理解力の組み合わせを必要とする顧客への IT コンサルティングにおいて長年にわたる経験を有しています。

製品とサービス

Blueberry の製品とサービスについての詳細は、弊社の Web サイトでご確認ください： www.bbsoftware.co.uk

本社： | Blueberry Software Ltd. Unit T1 The Arch 48-52 Floodgate Street Birmingham B5 5SL U.K.
最高経営責任者： | マーチン・グリーン martin.green@bbconsult.co.uk 052-355-5202


システム要件

1. Software Requirements and Restrictions

BB FlashBack runs on Windows XP and newer. 32 and 64 bit versions supported.

The capture driver (not required for recording, but may give better performance on older PCs) is certified for 32 and 64 bit versions of XP and Vista. It has been tested but not certified on Windows 2000, 2003, 7 and 8.

Windows 2000
users need to apply a hotfix to Windows before BB FlashBack will run. Go to http://support.microsoft.com/kb/816542 and click 'View and Request Hotfix Downloads' near the top of the page to request the hotfix from Microsoft.

Known Issue with Windows 8

When recording Windows 8, in 'Metro' mode on a touch device, a static mouse cursor will still be seen in the recording. This can be hidden by using the Actions -> Mouse Cursor -> Hide Mouse Cursor in Selected Frames function in BB FlashBack Pro. We are working on making BB FlashBack fully touch-compatible, and this will be a free update to BB FlashBack v4 in the coming weeks.

Terminal Sessions
BB FlashBack can record in a terminal session, but Capture Driver record mode cannot be used.

Windows Media Video (WMV) への出力

WMV フォーマットに出力するには Windows Media Player 9 以上がインストールされている必要があります。

QuickTime へ出力

QuickTime フォーマットに出力するには、QuickTime 7 以降がインストールされている必要があります。

2. ハードウェアの必要条件

CPU 速度： 最小 500MHz、推奨 1GHz

メモリ： 最小 256MB の RAM、推奨 512MB の RAM。ただし、1GB 以上の FBR ファイルをオープンする際は、最低 2GB の RAM が推奨されます。

ディスプレイ：Super VGA (800x600)またはそれ以上の解像度

グラフィックカード： 8MB ビデオメモリ、推奨 64MB 以上


BB FlashBack Pro 上位版へのアップグレード

BB FlashBack Pro 版はスクリーンの録画をレベルアップします。高度なビデオ編集とオーディオ編集が可能となり、ズームとパン効果や追加の外部出力フォーマットが適用できます。

Pro 版の試用の方法

  1. BB FlashBack Pro をダウンロードします。

  2. それをインストールします。同一 PC に Standard 版と Pro 版を同居させることができます。Pro 版は30日間試用することができますので、その間に購入またはアンインストールを決めることができます。

Standard 版のライセンスを Pro 版にアップグレードするには

  1. 「BB FlashBack Pro へのアップグレード」メニューを選択します。このメニューは、プレーヤーのヘルプメニュー、またはレコーダーのメインメニューにあります。

機能比較

 | Express | Standard | Pro
録画 |  |  |
録音とスクリーンおよび Web カメラの録画 | a | a | a
フルスクリーン、特定のウィンドウ、一部領域 | a | a | a
新旧の PC に対応させる録画モードの選択 | a | a | a
Windows Aero モードを録画 | a | a | a
アップロード |  |  |
Youtube、Blip.tv、Revver へのアップロード | a | a | a
一般的 HTTP、FTP サーバ、ファイルサーバへの新規アップロードプロファイルの作成 |  |  | a
出力 |  |  |
Flash への出力 - SWF と FLV (Flash ビデオ) | a | a | a
AVI へ出力 | a | a | a
QuickTime (H264) への出力 |  | a | a
GIF へ出力 |  | a | a
iDevices へ出力 |  | a | a
Windows Media Video (WMV) への出力 |  | a | a
スタンドアロン EXE へ出力 |  |  | a
MS PowerPoint への出力 |  |  | a
装飾 |  |  |
テキストボックス、画像、サウンド、ハイライト、ボタン、矢印、ぼかしの追加 |  | a | a
編集 |  |  |
フレーム単位の編集 |  |  | a
総合的なオーディオ編集機能 |  |  | a
効果 |  |  |
カーソルハイライト | a | a | a
ズームとパン |  |  | a
トランジションの追加 |  |  | a
クロッピング |  |  | a


ライセンスの購入

30 日間の試用期間を超えて BB FlashBack の全機能を継続して使用するには、ライセンスキーをご購入いただく必要があります。ライセンスはオンラインまたは電話にてご購入いただけます。

ライセンスキーの購入法と BB FlashBack への入力：

  1. BB FlashBack を起動する
    ライセンスキーを入力していない状態では、「BB FlashBack の購入」をご案内するオプションウィンドウが表示されます。そのオプションを選択してください。

    あるいは、プレーヤーのヘルプメニューかレコーダーのメインメニューにある「BB FlashBack Standard の購入」を選択します。

  2. ライセンスの購入
    ブラウザにオンラインショップのページが表示されたら、ライセンスキー購入のガイダンスに従います。登録メールアドレスにメールが送信されますので、メールアドレスを正しく登録してください。

  3. BB FlashBack にキーを入力
    キーを受け取ったら、それを BB FlashBack に入力します。これを行う方法は2通りあります。

    1. BB FlashBack を起動する
      ライセンスキーがまだ入力されていない場合は、「ライセンスキー入力」のオプションを表示するウィンドウが表示されます。このオプションを選択して、次に表示されるウィンドウでライセンスキーとユーザ名を入力します。ユーザ名は大文字小文字を区別します。

    2. プレーヤーの「ヘルプ」メニュー、またはレコーダーのメインメニューから「ライセンスキーの入力 / 確認」を選択します。次に表示されるウィンドウでライセンスキーとユーザ名を入力します。ユーザ名は大文字小文字を区別します。

      ライセンスキーは入力と同時に即時有効となります。

備考： この手続きはプレーヤーまたはレコーダーのどちらからでも実行可能です。どちらかで一度、キーを入力するだけで、BB FlashBack 全体としてライセンスが供与されます。手続きを両方で 2 回行う必要はありません。


ライセンスキー関連トラブル

オンラインで購入したが、メールでライセンスキーが送られてこない

Blueberry で登録する場合は、メールアドレスの登録が必須となります。登録されたメールアドレスに対して、製品をアクティベートするためのライセンスキーが送付されます。

メールの送信には万全を期しておりますが、ときとしてメールが迷惑メールフォルダに入れられてしまう場合があります。Blueberry 社からのライセンスキーを待っているにもかかわらずメールが届かないような場合は、迷惑メールフォルダをチェックしてみてください。

それでもなお、ライセンスキーのメールが見つけられない場合は、keys@bbsoftware.co.uk 宛にご連絡ください。

ライセンスキーの記されたメールを紛失してしまいました。オンラインで確認することもできますか？

はい、イギリスの Blueberry 社から製品を直接購入されている場合は、ライセンスキーをオンラインで確認することができます。http://www.bbsoftware.co.uk/support.aspx にログインし、「プロファイル」のリンクを選択してください。お客様のアカウントのページが表示されます。ページの上部にある、「購入済みのライセンスキーを見る」をクリックしてください。

BB FlashBack で制作したムービーを商用目的で配布することはライセンス上、許可されていますか？

はい、BB FlashBack で制作したすべてのムービーは、いかなる目的おいても自由に配布することができます。Blueberry 社に対するロイヤリティの支払いや他の費用などは一切掛かりません。

BB FlashBack にライセンスキーが入力できない

BB FlashBack にライセンスキーを入力するには、まずプレーヤーかレコーダーのいずれかを起動します。そして、プレーヤーのヘルプメニューまたはレコーダーのメインメニューにある「ライセンスキーの入力 / 参照」の項目を選択します。次のウィンドウで、Blueberry から送付されたメール、または弊社の Web サイト上に記載されたライセンスキーとユーザ名を正確に入力して OK を押します。ライセンスキーとユーザ名の値は、入力ミスを防ぐためにコピー & 貼り付けの操作で入力されることをお勧めします。

ライセンスキー関連のその他のヘルプ

なおも、ライセンスキーの受領、もしくは入力で問題が発生する場合は、keys@bbsoftware.co.uk にメールするか、または購入代理店に問い合わせして、問題の詳細をご連絡ください。


代理店

世界各地に登録代理店網があります。

Blueberry からの直販でなく代理店経由でお求めになりたい場合は、オンライン代理店リストを参照してください。


BB FlashBack の基本

BB FlashBack は「レコーダー」と「プレーヤー」からなる2つの異なるアプリケーションで構成されています。

レコーダー

  • デスクトップの録画
    Windows のデスクトップ上の出来事を録画し、FlashBack ムービーファイルとして保存します。
    詳細は、「ムービーを録画する」を参照してください。

  • サウンドの録音
    パソコンから出るサウンドや、マイクが接続されていればナレーションも録音します。Windows Vista であればナレーションとパソコンから出るサウンドを同時に録音することができます。
    詳細は、「サウンドを録音する」を参照してください。

  • Web カメラ映像の録画
    Web カメラが接続されていれば、BB FlashBack はそこからの映像も録画して、完成ムービーにピクチャ・イン・ピクチャの形式で表示させることができます。
    詳細は、「Web カメラ映像を録画する」を参照してください。

プレーヤー

  • ムービーの再生
    BB FlashBack ムービーの再生、編集、オブジェクトの追加を行うことができます。そしてそれを他のユーザが再生可能なムービーファイルとして保存します。
    詳細は、「ムービーを再生する」を参照してください。

  • テキストや画像でムービーに補足を入れる
    テキストボックスや画像、ハイライトやボタンをムービーに追加することができます。
    詳細については、「テキストボックスを追加する」、「画像を追加する」、「ハイライトを追加する」、「ボタンを追加する」を参照してください。

  • 他のファイル形式に出力
    ムービーが完成したら、それを各種のファイル形式に変換出力して他のユーザにムービーを披露することができます。他のユーザとのムービーの共有を参照してください。
    詳細は、「ムービーの出力について」を参照してください。

はじめに：

  1. BB FlashBack のレコーダーを使用してムービーを録画します。「ムービーを録画する」を参照してください。

  2. ひとたびムービーを録画すれば、それを BB FlashBack プレーヤーで表示させたり編集したりすることができます。詳細は、「ムービーを再生する」を参照してください。

  3. ムービーを他のユーザと共有するために、BB FlashBack プレーヤーには多くのファイル形式への出力オプションが用意されています。詳細は、「他のユーザとムービーを共有する」を参照してください。


レコーダーの基本

ムービーを録画する

マウスをわずか数クリックするだけで、BB FlashBack は Windows のデスクトップ上の出来事をすべて録画することができます。

フルスクリーンの録画か一部領域か、あるいは特定のウィンドウかを選択します。サウンドソースと Web カメラを選択し、 [image] ボタンをクリックすると、BB FlashBack がデスクトップを録画します。

録画を終了するには、 ボタンをクリックします。録画データはファイルに保存され、BB FlashBack のプレーヤーで編集したり、注釈を付け加えたり、あるいは標準的なビデオフォーマットに保存したりすることができるようになります。

ムービーを表示する：

ムービーを表示するための詳細は、「ムービーを再生する」を参照してください。

BB FlashBack レコーダーに関する詳細機能については、「レコーダーの機能について」を参照してください。


ムービーを再生する

デスクトップのショートカット、または Windows のスタートメニューから BB FlashBack プレーヤーを起動し、「ファイル」メニューの「開く」、またはツールバーの [image] ボタンを使ってムービーを再生します。

「ようこそ」ウィンドウから

レコーダーから開始してもプレーヤーから開始してもウェルカムウィンドウが表示されます：

「既存のムービーファイルを開く」をクリックして録画を選択し、再生します。

レコーダーからムービーを再生する：

  • レコーダーメインウィンドウの「ファイル」メニューから、「開く」または「最近開いたファイル」を選択して録画をオープンします。

  • レコーダーがタスクトレイまたはフローティングコントロールとして最小化されたら、アイコンをクリックするか、またはフローティングコントロールの [image] ボタンをクリックして、メインメニューを表示します。「再生」メニュー、またはメニューのトップにある最近録画されたムービーのリストを使用します。


ムービーを配布する

ムービーの共有

作成したムービーを他の PC ユーザや Mac ユーザと共有するには、ムービーをビデオ配信サイトにアップロードするか、または外部出力して出力ファイルを他のユーザに送付します。

ビデオ配信サイトにアップロード

BB FlashBack は www.youtube.com、blip.tv、www.viddler.com、www.revver.com などのビデオ配信サイトにムービーをアップロードすることができます。プレーヤーツールバーのアップロードボタンを使用してください。

この機能を使用するには、ビデオ配信サイトのアカウントが必要です。この機能を初めて使用する際に、BB FlashBack にログイン情報を登録する必要があります（次回からは記憶されます）。

アップロードが完了するとムービーの Web アドレスが表示されますので、このアドレスを送信することができるようになります。アドレスがオープンされるとブラウザ上でムービーが表示されます。

詳細は、「ムービーのアップロード」を参照してください。

ムービーの出力

作成したムービーを FlashBack ユーザ以外の人に見てもらいたいときは、ムービーを外部出力する必要があります。BB FlashBack は次のようなフォーマットの出力に対応しています。

  • Flash
    Web ページに埋め込むためのもっとも簡単なフォーマットです。再生用のコントローラを表示させることができます。このフォーマットを使用すれば、95 ％以上の PC と MAC 上でムービーを鑑賞することができます。
    Flash と EXE フォーマットは、「クリックして継続」などのテキストやボタンのようなインタラクティブな要素（双方向要素）をサポートする唯一のフォーマットです。
    詳細は、「Flash への出力」を参照してください。

  • QuickTime (H264)
    QuickTime は品質とファイルサイズのバランスを最適化する先進の圧縮技術を使用します。QuickTime ムービーは Web ページに埋め込んでストリーミング配信することが可能です。
    QuickTime はすべての Mac で再生が可能ですが、PC では QuickTime か iTunes がインストールされていなければなりません。
    QuickTime フォーマットに出力するには、QuickTime 7 以降がインストールされている必要があります。
    詳細は、「QuickTime (H264) への出力」を参照してください。

    Windows Media Video (WMV)
    QuickTime と同じく、このフォーマットも適切な品質とファイルサイズを自動生成します。そして、WMV ムービーも Web ページに埋め込むことが可能です。WMV ファイルは実質的にすべての PC 上で再生が可能ですが、一般的に Mac 上では再生できません。
    WMV フォーマットに出力するには、Windows Media Player 9 以降が必要です。
    詳細は、「Windows Media Video への出力」を参照してください。

  • AVI
    ムービーを上映するための非常に普及したフォーマットです。しかし、AVI への出力は詳しい知識を持たないユーザには使いづらい点があります。それは、出力時にムービーをエンコードするためのコーデックを選択しなければならないからです。画像の品質とファイルサイズは、どのコーデックを使用するかによって非常に変わってきます。再生 PC がエンコードで使用されたコーデックを備えていない場合は、AVI ファイルを再生することはできません。すべての Windows PC にそのコーデックがインストールされていなければならないという条件はあまりお勧めできません。
    詳細は、「AVI への出力」を参照してください。

BB FlashBack ユーザ以外の BB FlashBack Express ユーザや BB TestAssistant ユーザに送りたい

BB FlashBack で作成されたムービーファイル（FBR ファイル）をそのままお送りください。そのままで再生されます。FlashBack ファイルは通常、他の形式のファイルよりサイズが縮小されています。

Web ページ上にムービーを表示させる

Web ページにムービーを表示させるためのもっとも簡単な方法は、ムービーをビデオ配信サイトにアップロードするか、あるいはムービーに付与された埋め込みコードを使用することです。詳細は、「ムービーのアップロード」を参照してください。

高画質なムービー、あるいは双方向要素を備えたムービーを必要とする場合は、Flash に出力してその Flash 出力を Web サーバにコピーします。詳細は、「Web ページに Flash 出力を表示する」を参照してください。

WMV と QuickTime フォーマットも Web ページに埋め込むことができます。詳細は、「QuickTime ムービーを Web ページで表示する」を参照してください。

CD にムービーを取り込む

Flash、QuickTime、WMV フォーマットへの出力を試してみてください。どのフォーマットを使用すれば最も良い品質の画像で小さなファイルサイズを実現できるかは、ムービーの内容に依存します。ムービーが、動くビデオや多くの写真画像などを含んでいるような場合は、Flash、QuickTime、WMV フォーマットがファイルサイズを小さくできるかもしれません。


レコーダーメインウィンドウ

レコーダーのメインウィンドウでは主だった録画オプションを変更することができ、録画を簡単に開始することができます。

録画設定では、何を録画するかを選択します：

  • フルスクリーン（モニターが複数の場合はすべてのスクリーン）

  • 特定のウィンドウ

  • 特定の領域

サウンドを録音するには、「サウンドの録音」を ON にします。次に、音源を指定します。通常は、PC スピーカーか、マイクのどちらかを選択します。そして、最後に音量を調整します。
詳細はサウンドの録音を参照してください。

Web カメラを録画するには、「Web カメラの録画」を ON にします。Web カメラビデオの録画を参照してください。

録画中にレコーダーの表示を最小化するには、「録画中はトレイ/フローティングコントロールを最小化する」の設定を ON にします。トレイアイコン表示かフローティングコントロールの表示かは、ツールメニュー上で選択します。


レコーダーメインメニュー

レコーダーをアイコントレイに最小化し、そのアイコンをクリックすることでレコーダーのメインメニューを表示させます。または、レコーダーをフローティングコントロールに最小化し、 [image] ボタンをクリックして表示します。

レコーダーメインメニュー

このメニューから録画オプションダイアログの表示、新規ムービーの録画、レポートの作成、最近録画したムービーの再生などを行うことができます。

ムービーの録画中は、このメニューは録画の一時停止や停止などに使用されます。

メニュー項目

  • 最近録画したムービーのリスト： このリストは常にメニューの先頭に表示されます。ここには最近録画されたムービーの中から最新の10個のファイル名が表示されます。それぞれのファイルにはポップアウトメニューがあり、ムービーの再生、再録画などの一連のオプションが表示されます。詳細は「ムービーファイルのサブメニュー」を参照してください。

  • 再生： ファイル選択ダイアログが表示されます。そして BB FlashBack プレーヤーが起動され、選択されたムービーが再生されます。

  • 録画： 現在の設定を使用して、録画をすぐに開始します。

  • オプション： レコーダーオプションウィンドウの表示

  • 一時停止： （録画中にのみ有効）録画を一時停止します。

  • マーカーの追加： （録画中にのみ有効）録画中にマーカーを追加します。録画が一時停止し、マーカー名を入力するウィンドウが表示されます。

  • 録画の取り直し： 録画を取り直しします。それまでに録画された内容は破棄されます。

  • 停止： （録画中にのみ有効）録画を停止します。

  • ヘルプ： 現在の表示に関連したヘルプファイルを表示します。

  • サポート： サブメニューにある「Blueberry への障害レポート」を使用して、BB FlashBack 使用中の障害を Blueberry にレポートすることができます。詳細は「障害のレポート」を参照してください。

  • BB FlashBack の購入： 購入後は表示されません。

  • ライセンスの購入： ライセンスの購入法を示したヘルプを表示します。

  • BB FlashBack をオンラインで購入： オンラインショップを開くにはこれを選択します。詳細は「ライセンスの購入」を参照してください。

  • ライセンスキーの入力/確認： Blueberry から発行された BB FlashBack のライセンスキーとユーザ名を入力するダイアログを表示します。

  • トレイに最小化する： レコーダーを最小化して、通知領域にアイコンで表示します。

  • フローティングコントロールに最小化する： レコーダーを最小化して、フローティングツールバーで表示します。

  • アップデートの確認： BB FlashBack のバージョン更新情報をインターネット経由で確認します。

  • バージョン情報： バージョン情報ボックスを表示します。バージョン情報やライセンスキーを表示したり、ライセンスの登録や購入なども行えます。

  • 終了： レコーダーアプリケーションを閉じて終了します。


ムービーファイルポップアウトメニュー

ムービーファイルサブメニュー

最近録画されたムービーのリストにはそれぞれのサブメニューが表示されます：

メニュー項目

  • 開く： BB FlashBack プレーヤー上でムービーを開き、選択されたムービーファイルを自動的に再生します。

  • 新規のバグレポートに添付： このオプションは BB BugReporter をインストールしている場合にのみ表示されます。このオプションは新規のバグレポートを作成し、Bug Reporter を起動して選択されたムービーファイルを添付します。

  • Flash の再生： このオプションを選択すると、このムービーファイルから最後に出力された Flash ムービーを再生します。選択ムービーからの Flash 出力がまだない場合は、このオプションは表示されません。

  • Flash へ出力： このオプションは Flash ムービーファイルへの出力を行います。詳細は、「Flash へ出力する」を参照してください。

  • AVI への出力： このオプションは AVI ムービーへの出力を行います。詳細は、「AVI へ出力する」を参照してください。

  • WMV への出力： このオプションは WMV ムービーへの出力を行います。詳細は、「WMV へ出力する」を参照してください。

  • スタンドアロン EXE への出力：このオプションはスタンドアロン EXE 形式への出力を行います。詳細は、「EXE へ出力する」を参照してください。

  • PowerPoint への出力：このオプションは PowerPoint ファイルへの出力を行います。詳細は、「MS PowerPoint へ出力する」を参照してください。

  • Eメールで送信： デフォルトのメールソフトウェアで新しいメールを作成し、選択された形式のムービーを添付します。

  • 再録画： 選択されたムービーファイルと同じ名前で新しいムービーの録画を開始します。選択されたムービーファイルは上書きされ、新しい録画で置き換えられます。

  • メニューから除去： このオプションは選択されたムービーファイルを、最近録画されたムービーのリストから除去します。

  • 名前を付けて保存： このオプションはムービーを別のファイル名で保存します。

  • 削除： このオプションは選択されたムービーファイルを削除し、最近録画されたムービーのリストからも除去します。

  • 参照： このオプションは選択されたムービーファイルのあるフォルダをWindows柄エクスプローラでオープンします。

  • パスをクリップボードにコピー： ムービーファイルのフルパス名とファイル名をテキストとしてクリップボードにコピーします。


レコーダーオプションウィンドウ

ディスプレイオプションやサウンド、Web カメラ、その他の拡張オプションなどの録音設定を調整する際にこのウィンドウを使用します。

これらの設定は次回にクイック録画や録画を選択するときに使用されます。録画ウィザードはここでの設定をデフォルト設定として使用します。

レコーダーのオプションウィンドウ上には録画ウィザードよりもさらに多くの設定が用意されています。

レコーダーオプションウィンドウを表示する：

  1. レコーダーのメインメニューから「オプション」を選択するか
    または
    レコーダーのメインウィンドウにある「ツール」から「オプション」を選択します

レコーダーのオプションウィンドウには次のタブがあります：

  • 表示：録画中のウィンドウ表示の設定を行います。録画中、もしくは完成ムービーに BB FlashBack 自体がどのように表示されるかを設定します。詳細は、「ウィンドウ表示オプション」を参照してください。

  • サウンド： このタブを使用して、サウンドが録音されるタイミングとサウンドの形式、圧縮方法を選択します。

  • Web カメラ： 接続された Web カメラからの映像を録画するかどうかと、使用されるデバイスと形式を選択します。詳細は、「Web カメラ映像を録画する」を参照してください。

  • キーストローク： このタブは、キーストロークのキャプチャに関連するオプションを設定します。詳細は、「キーストロークをキャプチャする」を参照してください。

  • ホットキー： 録画中に録画コントロールのポップアップウィンドウを表示させるホットキーを定義します。詳細は、「ホットキーの定義と使用法」を参照してください。

  • ファイルサイズ： このタブを使用して、生成されるムービーファイルのサイズを制限するオプションを選択します。詳細は、「ムービーファイルサイズを制限する」を参照してください。

  • 録画モード： このタブを使用して録画モードを変更したり、キャプチャ時の秒当りのフレーム数を変更したりします。詳細は、「録画モードとパフォーマンス」を参照してください。

  • その他： このタブにはスタートアップオプションと、録画開始時に BB FlashBack が操作の合間に行う数々の遅延関連の設定があります。詳細は、「遅延をカスタマイズする」を参照してください。

  • 詳細設定： このタブには、主にパフォーマンスに関連した拡張設定があります。

  • 予約：設定した時間に BB FlashBack の録画を開始させたり、または特定のアプリケーションが起動して終了するまでを録画させたい場合はこの設定を使用します。詳細は録画の予約を参照してください。


レコーダーコントロールウィンドウ

録画中にマーカーを追加する

録画が進行中であっても、ポップアップウィンドウを使用することでマーカーを追加することができます。

録画中にポップアップウィンドウを表示させるには：

  1. レコーダーのメインメニューから「一時停止」を選択するか、またはホットキー（定義済みのもの - 詳細は「ホットキーの定義と使い方」を参照）を使用して録画を一時停止します。

  2. レコーダーのメインメニューから「マーカーを追加」を選択します。マーカー項目に名前を入力し、録画の現在地にマーカーを追加するために「追加」をクリックします。そして、「続ける」ボタンをクリックして録画を継続します。


レコーダーをタスクトレイやタスクバー、フローティングモードから使用する

レコーダーを最小化して使用する

BB FlashBack のレコーダーはタスクトレイ、またはフローティングコントロールに最小化することができます：

  • トレイアイコンとして
    レコーダーは通知領域にアイコンとして表示されます。これをクリックして、ポップアップメニューから各機能にアクセスします。

  • デスクトップ上にフローティング
    レコーダーはデスクトップ上にコントロールのセットとして表示されます。録画ボタンをクリックして録画を開始したり、または再生ボタンをクリックしてムービーを再生したりすることができます。下向き矢印をクリックして、タスクトレイ上のものと同じメニューを表示させることもできます。ツールバーは Windows デスクトップ上のどこにでも配置することができます。左側にある BB FlashBack ロゴをドラッグして位置を変えます。

ツールメニューのオプションを選択することでレコーダーの表示方法を変更することができます。


レコーダーの特徴について

サウンドを録音する

BB FlashBack はパソコンに接続されたマイクを通じてナレーションを録音することができます。

「サウンドを録音する」を参照

Web カメラ映像を録画する

パソコンに Web カメラが接続されていれば、BB FlashBack はデスクトップの録画と同時にカメラの映像を録画することができます。再生はピクチャ・イン・ピクチャのスタイルで行われます。

「Web カメラの映像を録画する」を参照してください。

ウィンドウ、一部領域、またはフルスクリーンの録画

BB FlashBackは3つのすべてが可能です。

「ウィンドウと領域を録画する」を参照してください。

マルチモニターシステムを録画する

BB FlashBack は同時に複数のモニターを1つのムービーに録画することができます。

「マルチモニターシステムでの録画」を参照してください。

録画中にWindows表示オプションを設定する

ムービーの幅と高さを削減するために、BB FlashBack は録画中のスクリーン解像度を下げることができます。

Windows のアニメーションやフェードイン・メニューなどのグラフィック効果は、ファイルサイズが大きくなって非力なパソコンでは再生が遅くなることがあります。これらのグラフィック効果は録画中は OFF にすることができます。

「Windows ディスプレーオプション」を参照してください。

録画の継続とムービーファイルサイズの制限

BB FlashBack は録画を継続しながら生成されるムービーファイルサイズを制限することができます。

「ムービーファイルサイズの制限」を参照してください。

録画モード

BB FlashBack には3種類の異なる録画法が用意されています。どの方法が良いかは Windows のバージョンとパソコンのハードウェアに依存します。

「録画モードとパフォーマンス」を参照してください。

ホットキーの設定

BB FlashBack は録画中にポップアップのコントロールウィンドウを表示させるためのホットキーを使用することができます。

「ホットキーの定義と使用法」を参照してください。


ウィンドウの録画と一部領域の録画

BB FlashBack は Windows のデスクトップ全体か、特定のウィンドウだけか、あるいは指定した領域だけを指定して録画することができます。レコーダーのメインウィンドウにてデスクトップ全体を録画するか、あるいは一部の領域だけを録画するかを選択します。

単一ウィンドウを録画する方法：

  1. レコーダーメインウィンドウにある録画設定で、ウィンドウを選択します。

  2. 指示に従って録画したいウィンドウをクリックします。赤いフレームがその周りに表示されます。その後、「録画」を押します。

録画対象となる領域は、選択されたウィンドウの領域に限定されます。

備考： 選択されたウィンドウを移動させると、録画される領域は元の位置のままとなります。ただし、オプションウィンドウの「詳細設定」タブにある「録画中のウィンドウの位置を追尾する」の設定を ON にしておくと、ウィンドウを移動させてもその位置を追尾するようになります。

選択されたウィンドウのサイズを録画中に変更しても、そのサイズ変更はムービーのサイズには反映されず、所期のサイズのままで録画されます。

一部の領域を録画するには：

  1. レコーダーメインウィンドウにある録画設定で、領域を選択します。

  2. 指定画面が表示されたら、赤枠でサイズと位置を決めます。そして、「録画」をクリックします。

録画は紫のフレームの内部領域に限定されます。

注意：録画中はレコーダーフレームのサイズと位置は変えることができません。


デュアルモニターシステムの録画

マルチモニターシステムの録画

BB FlashBack をマルチモニターで動作させている場合、複数のモニターの映像をひとつのムービーにまとめて録画することができます。

備考：「キャプチャドライバ」の録画モードは、プライマリモニターしか録画できません。

  • メインウィンドウの録画設定にて、「ひとつ以上のモニター」の録画を選択すると、録画が開始される前にどのモニターを録画の対象とするかの選択画面が表示されます。

  • 「ウィンドウ」または「一部領域」を録画対象として選択した場合、複数モニターに対象を広げることができます。モニターの対象から外れた領域は録画中は暗くなります。


Web カメラ映像を録画する

パソコンに Web カメラが接続されている場合、BB FlashBack はスクリーンの録画中に Web カメラからの映像も録画することができます。Web カメラの映像はムービー内に配置して出力することができます。

Web カメラ映像の表示と同時出力に関する詳細は、「Web カメラ映像を表示する」を参照してください。

Web カメラからの映像を録画するには：

  1. レコーダーのメインウィンドウ上で、「Web カメラを録画」の設定を ON にします。
    または
    レコーダーのオプションウィンドウで、「Web カメラ」タブにある「Web カメラからのビデオをキャプチャ」の設定を ON にします。

  2. ビデオをキャプチャするデバイスを選択します。

  3. 「設定」ボタンをクリックして Web カメラビデオのサイズを変更したり、明るさやコントラストなどを設定します。

備考： 録画中は画面には Web カメラ映像は表示されません。BB FlashBack プレーヤーでムービーを再生すると見ることができます。


録画モード

レコーダーオプションウィンドウの「録画モード」タブにて録画モードを設定します。BB FlashBack には 3 つの録画モードがあります。

  • GDI - 最も一般的な録画モードで、すべての Windows バージョン上の様々な環境でうまく動作します。

  • MPEG - 動画を録画する場合に最適なモードです。しかし、低スペックのパソコン上では、広大なデスクトップ画面の録画や高フレームレートでの録画には適さない場合があります。

  • キャプチャドライバ - 動画やアニメーションを含まない、通常の Windows アプリケーションを録画する場合に高いパフォーマンスが得られるモードです。特に、古いパソコンで録画を行う場合に、他のモードに比べてより良いパフォーマンスが得られます。ただし、Vista の Aero モードは録画できません。

「自動」モード

BB FlashBack はさらに、お使いのPCと現在の環境に最適なモードを選択する、「自動モード」を搭載しています。録画対象にメディアプレーヤー等のアプリケーションが検出された場合は、PC が高フレームレートに耐えうるかどうかを判定して、自動的に MPEG モードを選択します。メディアプレーヤーが検出されなかった場合や、ご使用中の PC が MPEG モードには非力であったりする場合は、自動的に GDI モードを選択します。また、PC が GDI モードに対しても非力であるような場合は、キャプチャドライバモードが選択されます。

Windows Vista および 7 ユーザ

GDI と MPEG モードは、Vista / 7 の Aero モードを録画することができます。

キャプチャドライバモードでの録画は、Windows を強制的にベーシックモードにします。Windows のベーシックグラフィックでの録画は、キャプチャドライバモードのほうが GDI モードより、より良いパフォーマンスとなめらかな映像が得られる場合があります。

1秒あたりのフレーム数をセットする

GDI または MPEG モードを使用する場合は、録画のフレームレートを調整することができます。

1秒あたりのフレーム数 （FPS） を高くすると完成後のムービーはよりなめらかな動きになりますが、録画中の PC のパフォーマンスは落ちる可能性があります。

FPS の値を低くすると、録画中のパソコンに与える負荷は減少しますが、完成後のムービーの動きはなめらかさに欠けます。

BB FlashBack は最適な初期値で FPS を設定するように試みます。ただし、理想的なレートは録画対象が何であるかに大きく依存しますので、検証を踏まえながら設定してください。

パフォーマンスが落ちる場合のトラブルシューティング

詳細は、「ビデオ録画のトラブルシューティング」を参照してください。


サウンドの録音

Windows のデスクトップの動きを録画しながら、BB FlashBack はパソコンに接続されたマイクを通して音声を録音することもできます。このサウンドトラックはムービーファイルに一緒に保存されます。

サウンドの録音を ON にするには：

  • レコーダーのメインウィンドウ、またはレコーダーオプションウィンドウの「サウンド」タブにある、「サウンドの録音」ボックスにチェックを入れます。

レコーダーのメインウィンドウでは、主な設定のみが表示されます。これに対して、レコーダーオプションウィンドウの「サウンド」タブでは、さらに詳細な設定まで表示されます。

サウンドデバイス

BB FlashBack は自動的にデフォルトのサウンドデバイスを選択します。たいていの PC ではこれで十分なのですが、ひとつ以上のサウンドカードを搭載している場合は、デフォルト以外のデバイスの選択が必要になる場合があります。オプションウィンドウの「サウンド」タブを開き、デバイスを選択します。

サウンドソース

  1. マイク
    接続されたマイクからナレーションを録音する場合に選択します。
    ウィンドウの右側にあるレベルスライダとボリュームインジケータを使い、マイクが正しく接続されていて音声が正しく集音されているかどうかを確認します。BB FlashBack 側から適切なマイクの音源が検出できない場合は、このオプションは無効化されます。

  2. PC スピーカー
    パソコンのスピーカーから出る音を録音したい場合にこのオプションを選択します。
    通常のサウンドデバイス（サウンドカード等）には録音用に複数の音源が用意されています。音源の選択ボタンを押してパソコンのスピーカーから出る音源を確認します。どの音源を録音するかを選択し、ミニスライダを使って個々の音量を調整することができます。

  3. その他のソース
    オプションウィンドウ上で、これらは「その他のソース」セクションに表示されます。メインウィンドウでは「ソース」のドロップダウンリストに表示されます。

    ここで、「ステレオミックス」が表示される場合がありますが、これは PC のスピーカーの音、または Windows XP では PC のスピーカーとマイクの音声を同時に録音したい場合に用いられます。

PC のスピーカーの音とマイクの音声を同時に録音する

Windows Vista と 7 では、録音用のメインソースとして PC スピーカーを選択します。そして：

メインウィンドウ上で、セカンドソースとして「マイク」を選択します。

オプションウィンドウ上で、「別のトラック上でマイクから録音する」を選択します。

Windows XP では、PC スピーカーからの音とマイクへの音声を同時に録音することはサウンドカードがそれに対応していれば可能ですが、多くの場合は不可です。したがって：

サウンドカード添付のドキュメントをよくお読みになり、

サウンドカードと共にインストールされているドライバの設定を参照してください。通常は、Windows のコントロールパネルか、またはデスクトップのタスクトレイ（デフォルトではデスクトップの右下）にあります。

オプションウィンドウ、またはメインウィンドウの「その他のソース」欄にリストアップされる、「ステレオミックス」の選択を試してみてください。

サウンド形式

オプションウィンドウ上ではサウンドフォーマットを選択することができますが、メインウィンドウ上ではできません。異なるサウンドフォーマットを選択すると、録音の音質とムービーファイル内におけるデータ容量が変わってきます。

下記から選択できます：

  1. サンプルレート
    サンプルレートが高ければ高いほど音質は良くなりますが、サウンドトラックが占めるファイル容量は増加します。

  2. ステレオ / モノ
    ステレオはモノより良い音質が得られますが、やはりムービーファイル容量は増加します。

  3. MP3 圧縮
    このオプションは、録画中や外部ファイル出力中ににクラッシュしたりとかの問題がない限り常に選択されます。このオプションの選択を解除するとムービーファイルサイズは大幅に増加します。
    BB FlashBack は LAME MP3 コーデックの再配布版を使用しています： www.mp3dev.org


録音に関するトラブルシューティング

録音に際しては、マイクからの録音、または PC から発生されるサウンドの録音のいずれをも、できるだけ容易に操作できるように努めています。

しかしながら、様々な PC のオーディオ機能や様々なサウンドカードの種類が存在することに起因して、トラブルに遭遇するケースもまれではありません。

マイクからの録音時のトラブル

PC サウンド録音時のトラブル

オーディオとビデオの同期に関するトラブル


PC サウンド録音時のトラブル

BB FlashBack はパソコンに接続されたマイクからでも、あるいはパソコンから出るサウンドでも、なるべく簡単に録音ができるようになっています。しかし、個々のパソコンやサウンドカードのさまざまなオーディオ能力の違いにより、問題が発生することがあり得ます。

DELL のパソコンを使用している場合：PC からのサウンドの録音で問題が生じた場合、PC によっては初期設定で録音ができなくなっている可能性を考慮してください。これは著作権侵害を防止するために意図的に PC サウンドが録音できないような仕様になっているためです。

解決法としてはレジストリの編集、もしくはサウンドドライバのアップデートが考えられますが、これらは特定の PC モデルに依存します。

「DELL (お使いの PC モデル名) 録音できない」等の文字列で検索してみることをお勧めします。解決法が見つかるかもしれません。

PC サウンドの録音で問題が生じる場合：

  1. PC スピーカーがサウンドソースとして選択されていることを確認します
    レコーダーオプションウィンドウのサウンドタブにて、「PC スピーカー」のオプションを選択します。PC スピーカーかヘッドフォンから音声が再生されると、右側にある色の付いたインジケータが動作するはずです。インジケータが動作しない場合は、録音の設定を見直す必要があります。下記の「ステップ 2」を参照してください。

  2. 「ステレオミックス」か「 WAVE 」が音源として選択されていることを確認します
    サウンドステップまたはタブにある、「合成するサウンドの選択...」ボタンをクリックします。これは、録音対象として選択されている「 PC 音源」を表示します。「ステレオミックス」か、または「 WAVE 」が音源として選択されていること、および、ボリュームスライダが右側にセットされていることを確認します。サウンドを再生してみて、レベルインジケータを見ながら、BB FlashBack が PC サウンドを正しく録音しているかどうかをチェックします。インジケータが動けばサウンドは正しく録音されています。動かない場合は、下記のステップ 3 をお試しください。

    備考：PC によっては、サウンドドライバと一緒にインストールされているプログラムを使用している「ステレオミックス」音源の選択を必要とする場合があります。Windows のコトロールパネル上でサウンドユーティリティプログラムを探すと、「 SoundMax 」あるいは「 SigmaTel オーディオ」とかの表示なっていることがあります。

  3. 「他の音源」を試してみます
    一部の PC では、正しい音源が PC 音源のウィンドウに表示されない場合があります。サウンドのステップ/タブで再び、「他の音源」のラジオボタンを選択して、可能であればドロップダウンリストから「ステレオミックス」または「 WAVE 」（あるいは両方）を試してみてください。そして再び、サウンドを再生して BB FlashBack のサウンド設定ウィンドウにあるレベルインジケータを確認します。

    それでもなお、PC サウンドを録音できない場合:

  4. サウンドカード用のドライバを更新します
    サウンドカード用のドライバを更新、あるいは再インストールすることで録音が可能になることがあります。

  5. インターネットで検索する
    ご使用中の PC 特有の修正問題がある場合があります。インターネットを利用してラップトップのモデル名やサウンドカードの名称、および「PC サウンドを録音できない」などの検索用語で検索してみてください。

  6. それでもなおかつ PC サウンドが録音できない場合
    PC によっては、著作権侵害を防止するために意図的に PC サウンドが録音できないような仕様になっている場合があります。

    場合によってはレジストリの書き換え、もしくは異なるバージョンのサウンドカードドライバをインストールすることで解決することもありますが、PC によってはそれでも駄目な場合があります。

    下記のページは、Dell の Latitude および Inspiron ラップトップにおいてドライバの差し替えで問題を解決する方法を示しています：
    http://www.ekhoury.com/2006/08/25/sigmatel-stereo-mix-support-for-dells/

    下記のページでは Inspiron ラップトップ向けの修正方法を解説しています。ただし、レジストリの編集を使用していますので、編集を誤ると、サウンドカードがまったく使えなくなってしまったり、他の副作用が出ることもありますので、レジストリの編集にはくれぐれも注意してください。
    http://forum.notebookreview.com/showthread.php?t=156400

    あとは、「PC サウンドが録音できない」等の用語で PC モデルと合わせて検索してみてください。解決の糸口がみつかる場合があります。


マイク録音時のトラブル

マイクからの録音でトラブルが発生した場合：

  1. 適切なマイクがパソコンのサウンドカードの正しい入力端子に接続されていることを確認します。

  2. BB FlashBack のサウンド設定ウィンドウ（「ツール」→「オプション」→「サウンド」タブ）にて、「マイク」のラジオボタンを選択します。

  3. 同じウィンドウ上で、「レベル」のスライダーを可能な限り最大に設定します。マイクに向かって話します。ウィンドウの右側にあるグリーンと赤のレベルインジケータが動くはずです。

    レベルインジケータが動いていれば、BB FlashBack レコーダーがサウンドを検知していることになります。動いていない場合は、マイクのサウンドチャネルからのサウンドが検知されていないことになりますので、下記の手順にそってマイクの設定が正しいかどうかを確認します。

  4. 同じウィンドウ上にて、「PC サウンド」のオプションを選択し、「合成するサウンドの選択」ボタンを押します。マイク音源が有効になっていて、ボリュームスライダが右側に位置していることを確認します。マイクに向かってもう一度何か話します。音量に合わせてレベルインジケータが動くかどうかを確認します。

  5. Windows のサウンドレコーダーを使用して、マイクによる録音を試します。

    1. Windows のスタートボタンから「すべてのプログラム」→「アクセサリ」→「エンターテイメント」→「サウンドレコーダー」でサウンドレコーダーを起動します。

    2. 「編集」メニューの「オーディオのプロパティ」を選択します。

    3. 「録音」デバイスの「音量」ボタンをクリックします。

    4. 「録音コントロール」で「マイク」が選択されていることを確認します。

    5. サウンドレコーダーに戻り、「録音」ボタンを押してマイクに向かって話します。

    6. 「停止」を押して「<<」ボタンを押し、そして再生します。録音が再生されない場合は、パソコンと Windows がマイクから正しく録音されるように設定されていないことになります。録音が再生された場合は、BB FlashBack 上で音源にマイクを選択して再び録音を試してみてください。

  6. Skype や MSN Messenger などの他のアプリケーションでもマイクが使用できるかどうか確認してください。もし正常に機能するようでしたら BB FlashBackでも正しく動作します。

マイクが他の Windows アプリケーションで正しく使用できて、なおも BB FlashBack で正しく録音できない場合、レコーダーオプションウィンドウにある「サウンド」タブを開いて「トラブルシューティング」ボタンを押してください（BB FlashBack レコーダー→「オプション」→「サウンド」タブ）。このボタンは Blueberry のテクニカルサポートチームにメールを送ります。上記のヒントの確認結果を添えて、トラブルに関するなるべく多くの情報をお送りください。


オーディオとビデオの同期トラブル

PC によっては、オーディオとビデオの同期に際してトラブルが発生する場合があります。特に長いムービーにおいて顕著となります。この問題は PC に搭載されている特定のサウンドカードに起因します。

BB FlashBack レコーダーを使用してテストを行うことができます。テストにより、サウンド同期問題を修正するためのオプションが選択できるようになります。

  1. レコーダーオプションウィンドウで「サウンド」タブを開きます。

  2. 「同期テスト」ボタンをクリックします。

テストには 30 秒ほどの時間を要します。同期問題が検出された場合は、「サウンド同期の追加設定」オプションが表示されます（レコーダーオプションウィンドウの「詳細」タブに表示されます）。このオプションを使用すると、録画の終了時にサウンドが処理されて圧縮が完了するまでの間、遅延を発生させるようにします。


キーストロークの記録

BB FlashBack は録画中のキーストロークを記録することができます。そしてそれを再生時にプレーヤー上で再生することができます。これは録画中にユーザによって操作されたアクション（ファンクションキーを押すとか）の動作を再生時に再現します。これらはムービーを見ただけでは知ることができない要素です。

この機能は知らず知らずのうちにパスワード入力の文字列も表示させてしまうため、デフォルトではパスワードの入力文字はアスタリスク記号 （*） で置き換えられます。

備考： BB FlashBack は Web ページ上のパスワード入力やリモートデスクトップセッション上のパスワード入力はアスタリスク変換することができません。入力された文字列はキーストロークログに保存され、BB FlashBack プレーヤーのキーログビューワで見ることができます。

キーストロークの録画を ON にするには：

  1. レコーダーオプションウィンドウで、「キーストローク」タブを選択する

  2. 必要に応じて、「キーストロークを記録する」のボックスにチェックを入れます。

キーストロークが記録されるとき、パスワード文字列の表示 / 非表示を切り替えるには「パスワード文字列の置き換え」チェックボックスを使用します。

再生中にキーストロークを表示するための詳細は、「キー押下を表示する」を参照してください。


ムービーのファイルサイズを制限する

BB FlashBack は作成されるムービーのファイルサイズを制限することができます。デフォルトでは制限はされていませんが、このオプションを有効にすることで、BB FlashBack が録画をし続けてディスクフルになったりすることを防ぐことができます。

2通りの選択モードがあります：

時間による制限

あらかじめ設定した時間分のムービーファイルを作成したい場合にこのオプションを選択します。例：このオプションを選択し、録画時間を最大 5分と設定します。そして 10分録画したとします。出来上がったムービーファイルは録画の最後の 5分間分となります。

単一ファイル当りの BB FlashBack の録画時間（分数）を設定する：

  1. レコーダーオプションウィンドウを開き、「ファイルサイズ」タブを選択します。

  2. 「時間で制限する」のラジオボタンを選択します。

  3. 「制限値」の入力項目に値を入力します。これは BB FlashBack が単一ムービーファイルとして録画する分単位の値となります。

サイズによる制限

このオプションを選択すると、BB FlashBack は一定のファイルサイズを越えるムービーファイルを作成しません。例：このオプションを選択してムービーの最大ファイルサイズを 5MB とします。出来上がったムービーは約 5MB、もしくはそれ以下のファイルサイズ（制限値に到達しない録画を行った場合）となります。

ムービーファイルの最大サイズを設定する：

  • レコーダーオプションウィンドウを開き、「ファイルサイズ」タブを選択します。

  • 「サイズで制限する」のラジオボタンを選択します。

  • 「制限値」の入力項目に値を入力します。これは単一ムービーファイルの最大ファイルサイズとなります。


ホットキーの定義と使用法

BB FlashBack レコーダーではホットキーの組み合わせを定義することができます。これは2つの目的で使用されます：

  1. 録画中にホットキーを押すと、録画ポップアップウィンドウが表示されます。このウィンドウを使用して録画を終了したり、一時停止したり、再開したりすることができます。

  2. BB FlashBack レコーダーがタスクトレイに常駐していて録画が実行されていないとき、ホットキーを押すことによって録画オプションウィンドウが表示されます。

ホットキーを定義する：

  1. レコーダーオプションウィンドウを開き、「ホットキー」タブを選択します。

  2. 「ホットキー」の項目にカーソルを置き、ホットキーとして割り当てたいキーの組み合わせを押します。ホットキーの項目にはキーの組み合わせが表示されます。

  3. 「OK」をクリックします。BB FlashBackレコーダーでホットキーが使用できます。


録画モードに関するトラブルシューティング

録画に関するトラブルシューティング

BB FlashBack は高いフレームレートで確実にスクリーンを録画することができるように研究されています。しかしながら、個々のパソコンの能力やビデオカードの種類は多岐にわたっており、場合によっては特定のアプリケーションで高画質の録画を得ることができない可能性があります。

動画などを録画すると品質が悪い / 動きがギクシャクする

  • GDI モードやキャプチャドライバモードではなく、MPEG モードを使用していることを確認します。

  • デスクトップ全体ではなく、ムービープレーヤーの部分だけを録画対象とします。

  • ウィザードの録画モードのステップにて、FPS の設定をいろいろと試してみます。FPS の設定を下げることで CPU への負荷を減少させ、滑らかな録画が得られるようになることがあります。

ムービーの再生アプリケーション等を録画した場合、映像が表示されるべき部分が真っ黒な四角になってしまうことがあります。

これは、ムービー再生ソフトウェアが「オーバーレイ」（録画が不可のハードウェアビデオアクセラレーション機能）を使用していることが原因です。

BB FlashBack 側で設定を変更するか、あるいはムービープレーヤー側自体の設定を変更して、オーバーレイを使用しないように設定を変更する必要があります。

  • Windows XP の場合：録画ウィザードの録画モードステップにおいて、詳細設定ボタンを押します。詳細設定ウィンドウで、「ハードウェアアクセラレーションを無効にする」を ON にします。録画が開始される前に、BB FlashBack はハードウェアアクセラレーションを無効にするための確認メッセージを表示します。

    備考：メディアプレーヤーの類のアプリケーションを録画する場合は、ハードウェアアクセラレーションを無効にしたあとに、それらのアプリケーションを再起動する必要があります。これにより、オーバーレイの使用が OFF になります。また、特定のムービープレーヤー（例：KM プレーヤーなど）を録画する場合は、オーバーレイを使用しないように、手動で設定を変更してやる必要があります。これらのプレーヤーはオーバーレイが無効になっていることを検知できません。

  • Windows Vista または 7 の場合： ムービープレーヤーを録画するには、そのアプリケーションがハードウェアアクセラレーションやオーバーレイを使用しないようにする設定を行う必要があります。設定方法はアプリケーションによってすべて異なります。

インストール後にキャプチャドライバモードが不可に

ときとして、ドライバがその選択を有効にさせるために、Windows の再起動を促す場合があります。録画モードステップやオプションウィンドウ上において、キャプチャドライバモードが無効になっていたりするのは、これが原因です。

BB FlashBack をインストールする際やレコーダーを起動する際に ASUS ソフトウェアに関するメッセージが表示された場合は、BB FlashBack はそのソフトウェアとドライバの互換性がありませんので、ドライバをインストールしません。詳細は、「この FAQ を見る」を参照してください。

Blueberry のテクニカルサポートにメールする方法：

録画モードやパフォーマンスの問題でトラブルが生じた場合は、テクニカルサポート部門にメールで問い合わせをしていただくことができます。

  1. レコーダーの「オプション」ウィンドウを開き、「録画モード」タブを選択します。

  2. 「トラブルシューティング」のボタンを押し、「サポートへメールを送る」を選択します。

  3. ウィザード上で問題の症状をなるべく詳しく記述します。レポートへの返信を必要とする場合はメールアドレスも記述してください。

  4. ウィザードはメールを直接、テクニカルサポート部門に送信します。送信パソコンのパソコン仕様も添付されます。ただし、個人情報は送信されません。パソコンのハードウェア構成だけが送信されます。


録画時のメモ書き

BB FlashBack は録画中にメモを記録することができ、これらのメモは最終ムービー上でテキストボックスとして表示させることができます。

録画時のメモを ON にする方法：

  1. レコーダーのオプションウィンドウ上で「録画時のメモ」タブを開き、「メモを有効にする」の設定を ON にします。

  2. メモの設定：

    • スクリーンの端にカーソルを移動させてメモウィンドウを表示します。
      どちらの端でメモを有効化させるかは、「マウスを移動させてメモウィンドウを表示」の設定で行います。

    • メモウィンドウが表示されている間は録画を自動的に一時停止して、それがムービーに表示されないようにすることができます。
      これを行うには、「メモウィンドウの表示時は録画を一時停止」で設定します。

    • マウスカーソルをメモウィンドウの外に移動させるか、またはウィンドウ上の「保存」ボタンを押してメモを保存することができます。
      これを行うには、「カーソルが離れたときにメモを自動保存」で設定します。

    • 録画が BB FlashBack プレーヤーでオープンされると、メモからテキストボックスが自動的に生成されます。
      これを行うには、「録画のオープン時にテキストボックスを自動生成」で設定します。

BB FlashBack プレーヤーでメモを見るには

「テキストボックスを自動生成」が ON になっている場合は、ムービーのテキストボックスでこれを見ることができます。これらは通常のテキストボックスですので、通常通り編集したり移動したりすることができます。

「テキストボックスの自動生成」が OFF になっている場合は、ムービーの左側のペイン上でメモを見ることができます。左端のペインが非表示になっている場合は、プレーヤーメニューの「表示」→「予備ペイン」→「キーログ」でこれを表示させることができます。


ウィンドウ表示オプション

BB FlashBack は、録画中の Windows の画面表示設定を変更することができます。設定を変更することにより、録画中のパフォーマンスが改善され、より小さなファイルサイズを実現します。

パフォーマンスの向上とファイルサイズの削減

Windows にはユーザインターフェイスの見栄えを良くするための数々のグラフィック効果が存在します。これらの効果を ON にすることは、ムービーを録画中または再生中のパソコンのパフォーマンスに影響を与えます。さらにムービーファイルサイズが大きくなる結果ともなります。BB FlashBack には録画時にこれらの効果を OFF にするオプションがあります。録画の終了時にはこれらの設定は元の設定に戻ります。

効果には次のようなものがあります：

  • マウスカーソルの影

  • メニューとツールチップのトランジッション効果（フェードインと拡張メニュー）

  • Windowsタイトルバーのグラデーション効果

  • コンボボックスとリストボックスのなめらかなスクロール

  • コンボボックスのサイドオープン効果

他にも、BB FlashBack がパフォーマンスの改善のために録画中に一時的に変更することのできる 2つの Windows 設定があります：

  • デスクトップの背景画像 - BB FlashBack はデスクトップの背景を単一カラーに置き換えます。

  • ウィンドウの移動時とリサイズ時にウィンドウの内容を表示する - BB FlashBack はウィンドウの移動時とリサイズ時にウィンドウの境界線だけを表示するように Windows を設定することができます。

録画中は Windows のグラフィック効果を無効にする：

  1. レコーダーのメインウィンドウにてツールメニューから「オプション」を選択し、「表示」タブを開きます。
    または
    レコーダーがタスクトレイまたはフローティングコントロールとして最小化されている場合は、メインメニュー（トレイアイコンをクリックするか、フローティングコントロールの [image] ボタンをクリックします）を表示し、オプションを選択して、「表示」タブを開きます。

  2. 「Windows グラフィック効果の無効化」のチェックボックスにチェックを入れます。BB FlashBack は録画中のグラフィック効果を OFF にします。

  3. 背景画像を単一カラーに設定し、リサイズ時にウィンドウの境界線だけを表示させるには、関連ボックスにチェックを入れます。


遅延設定をカスタマイズする

BB FlashBack のレコーダーオプションウィンドウで2通りの遅延設定を行うことができます。

  1. BB FlashBack レコーダーの録画ボタンクリック、またはメニュー項目の録画選択のタイミングと実際に録画が開始されるまでの間の遅延

  2. 「録画中は画面の解像度を変更する」という指定にしている場合、BB FlashBack はこの変更処理と実際の録画開始との間に遅延を挿入することができます。

遅延が実行されている間は、「?初期化中?」という小さなウィンドウが表示されます。

遅延設定をカスタマイズする：

  1. レコーダーオプションウィンドウを開き、「その他」タブを選択します。

  2. 上記、遅延 1 を設定するには、「録画前の遅延」項目の値を変更します。

  3. 上記、遅延 2 を設定するには、「画面解像度変更後の遅延」項目の値を変更します。


プレーヤーウィンドウ

このウィンドウを開いてムービーの再生と編集を行います。

 | Menus Toolbars Timeline Framebar and objects Sound tracks Movie
ギャラリー |

BB FlashBack プレーヤーのメインウィンドウの各部品：

メニュー

メニューの各機能はこのヘルプファイルに記述されています。プレーヤーメインメニューの項目を参照してください。

ツールバー

各ツールバーを利用することで、よく使用される主だった機能へクイックアクセスを行うことができます。

各機能の記述については、プレーヤーツールバーの項目を参照してください。

タイムライン

タイムラインはフレームバーとと共に、現在のムービー上で選択されているフレームまたは再生されているフレームの位置を示します。タイムラインは経過秒数またはフレーム番号で表示されます。

フレームバーとオブジェクト

フレームバーには選択可能な矩形としてムービーの各フレームが表示されます。選択されたフレームは赤く描画されます。フレームを選択すると、ムービー領域にそれが表示されます。

ムービーに追加したテキストボックスと画像のオブジェクトはフレームバーの下に表示されます。

サウンドトラック

ムービーにサウンドが含まれていると、各サウンドトラックがフレームバーの下にサウンドバーとして表示されます。サウンドトラックは複数行に渡る場合があります。

ムービー領域

ムービー領域はプレーヤーウィンドウのほとんどを占めています。再生時にはここでムービーが上映されます。

ギャラリー

この領域にはムービーへのドラッグが可能なテキストボックス、画像、その他のオブジェクトが保持されます。ギャラリーには自作のテキストボックス等を追加することもできます。

ステータスバー

ここは4つのセクションに分かれています。

一番右のセクションにはムービーの合計時間が表示されます。右から2番目のセクションには、選択フレームの録画中に押されたキーの値が表示されます。

他の2つのセクションには、一定時間処理が占有される場合の BB FlashBack のステータスメッセージが表示されます。


タイムラインとフレームバー

タイムライン

タイムラインは左端の最初のフレームから最終フレームまでのムービーの全長を表示します。タイムラインをクリックするとムービーのどこにでもジャンプすることができます。また、マウスをタイムライン上に持っていくと、その位置におけるムービーのサムネール画像が表示されますので、これをヒントに好きな位置に移動したりすることができます。

タイムラインは秒単位またはフレーム番号で表示されます。タイムラインの単位は、「表示」メニューにある「タイムラインの単位」で変更することができます。

フレームバー

フレームバーには、左端の先頭フレームから始まって右端の最終フレームまで、ムービー上の個々のフレームの画像表示が含まれています。各フレームは選択可能な矩形表示となっています。単一のフレーム、あるいは連続するフレームの範囲として選択することができます。そして編集操作によって修正することができます。

フレームバーはタイムラインの拡大表示ととらえることもできます。各フレームは極めて短い表示時間（規定値で 1/25 秒）で成り立っており、フレームバーの区間はムービー全体の一部のみを表示しています。

タイムラインをクリックすることで、その地点のフレームを選択したことになります。フレームバーは自動的にスクロールし、選択されたフレームを表示します。選択されたフレームは赤色になります。

フレームバーの詳細

下記の図はフレームバーとタイムラインの一部です。タイムラインは秒単位で表示されています。

フレームバーは 4 つの帯で構成されており、特定フレームにおけるオブジェクトの表示（テキストボックス、画像、サウンドなど）、ズームとパン効果の表示、マウスクリックの表示、キー入力の表示から成ります。

フレームバーとタイムラインの表示／非表示の切り替え：

  1. プレイヤーのメニューから「表示」を選択します。

  2. 「タイムライン」と「フレームバー」の項目をチェック／アンチェックして、表示／非表示を切り替えます。

オブジェクトの表示

ムービーにテキストボックスや画像などのオブジェクトを追加すると、これらはバーのオブジェクトセクションに表記されます。

テキストボックスが手前に表示され、画像がその次に表示されます。

オブジェクトの表示時間はバーの長さで表現されます。

バーをダブルクリックするとそのオブジェクトのプロパティウィンドウが表示されます。

ムービー上の表示タイミングを変更するには、バーをクリックしてからドラッグします。

表示時間の長さを変更するには、バー上の最後をクリックしてからドラッグします。

マウス操作の表示

フレームバーの中ほどのコマは、マウスの操作を示しています。

このバーにおけるフレームが青色になっていた場合、それはマウスカーソルがその区間で非表示になっていることを表しています。

ドットの位置は、そのフレーム上の画像におけるマウスポインタの位置を示しています。ドットの色はマウスの移動とクリックの可否を示しています。

グレー | マウスは移動していない。
黒 | マウスが移動した。
赤 | マウスがクリックされた。

キー押下の表示

この機能の詳細については、「キー押下の表示」のヘルプを参照してください。


Web カメラ映像を表示する

Web カメラ / ピクチャ・イン・ピクチャビデオ

BB FlashBack は、メインとなる録画スクリーン中にピクチャ・イン・ピクチャのビデオを表示させることができます。

スクリーンの録画中に同時に Web カメラからの映像を録画することができます。Web カメラ映像は BB FlashBack プレーヤー上で録画をオープンするとピクチャ・イン・ピクチャとして表示されます。

または、ピクチャ・イン・ピクチャとして使用するための映像を FLV、AVI、WMV ビデオファイルから入力することができます。

Web カメラ映像の録画に関する詳細は、「Web カメラ映像を録画する」を参照してください。

ピクチャ・イン・ピクチャとしてビデオファイルを入力するには

  1. ビデオをスタートさせたいフレームを選択します。

  2. 「挿入」メニューから「Webカメラ / ピクチャ・イン・ピクチャビデオ」メニューの項目を選択します。

  3. ビデオファイルを選択します。現在のフレーム上にピクチャ・イン・ピクチャビデオとして入力されます。

備考: コーデックの種類は非常に多岐にわたりますので、すべての AVI ファイルが正常に入力されるとは限りません。

Web カメラ映像表示モード

ムービーに Web カメラ映像を表示させる方式には次の2通りがあります：

  • 独自のウィンドウで表示
    このモードでは Web カメラ映像は独自のタイトルバーを持つ独自のウィンドウとして表示されます。このウィンドウは BB FlashBack プレーヤーのウィンドウとは独立していますので、デスクトップ上のどこにでも移動させることができます。
    このモードにおいては、Web カメラ映像は外部出力時には出力されません。

  • ムービーに埋め込み
    このモードでは、Web カメラ映像はムービー内にフレームとして表示されます。ムービーの外には移動することはできません。フレーム色と枠線の太さは Web カメラ映像のプロパティで設定することができます。
    このモードにおいては、Web カメラ映像は外部出力時に同時に出力されます。

あるいは、Web カメラ映像を完全に非表示にすることもできます。「表示」メニューにある「Web カメラ映像を表示」で Web カメラ映像の表示／非表示を切り替えます。

Web カメラ映像のモードを設定するには：

  1. Web カメラ映像のウィンドウをダブルクリックしてプロパティを開きます。

  2. プロパティウィンドウ上でモードを選択します。


ファイルツールバー

ファイルツールバーを使用すると、ワンクリックで、良く使用する機能にアクセスすることができます。

ファイルツールバーの表示・非表示の切り替え：

  1. プレーヤーのメニューバーから「表示」→「ツールバー」を選択します。

  2. ファイルツールバー項目にチェック入れるか、またはチェックを外すことで、ファイルツールバーの表示／非表示を切り替えることができます。

ボタン

ムービーファイルをオープンします。

現在のムービーを保存します。

選択したビデオ配信サイトや FTP サーバにムービーをアップロードします。

ムービーを対応ファイル形式のひとつに出力します。

  • Flash

  • Window media video (WMV)（Windows Media Player V9以上がインストールされていること）

  • QuickTime (QuickTime V7 以降がインストールされている場合)

  • AVI

出力に関する詳細は、このヘルプファイル内の「ムービーの出力」を参照してください。


プレーヤーツールバー

プレーヤーツールバーを使用すると、良く使用される機能へワンクリックでアクセスすることができます。

プレーヤーツールバーの表示／非表示の切り替え：

  1. プレーヤーのメニューバーから「表示」→「ツールバー」を選択します。

  2. 「プレーヤーツールバー」をチェック／アンチェックして、「プレーヤー」のツールバーの表示／非表示を切り替えます。

再生ボタン

再生を開始／再開します。

再生を一時停止します。

ナビゲーションボタン

 | 先頭のフレームに行きます。
 | 末尾のフレームに行きます。
 | 次のフレームに行きます。
 | ひとつ前のフレームに行きます。
ジャンプ： | ムービーに追加したいずれかのテキストボックス、画像、またはサウンドを選択して、オブジェクトが表示されるフレームに直接、ジャンプします。

下記のそれぞれの機能は、ナビゲーションボタンの横にある小さな下矢印をクリックすることで選択可能です。

マウスクリックのある次のフレームに行きます。

キー押下のある次のフレームに行きます。

次の大きなスクリーン書き換えに行きます。

次のマーカーに行きます。

次のテキストボックスに行きます。

次のサウンドに行きます。

次の画像に行きます。

上記の各機能は、「ひとつ前に戻る」のボタンにも対応しています。


編集ツールバー

編集ツールバーを使用すると、よく使用される機能の数々へワンクリックでアクセスすることができます。

編集ツールバーの表示・非表示の切り替え：

  1. プレーヤーのメニューバーから「表示」→「ツールバー」を選択します。

  2. 編集ツールバーの表示／非表示を切り替えるには、「編集ツールバー」の項目をチェック／アンチェックします。

ボタン

前回の編集操作を元に戻します。

元に戻した編集操作をやり直しします。


表示ツールバー

表示ツールバーを使用すると、各種の表示機能にワンクリックでアクセスすることができます。

表示ツールバーの表示／非表示を切り替えるには：

  1. プレーヤーのメニューバーから「表示」→「ツールバー」を選択します。

  2. 表示ツールバーの表示／非表示を切り替えるには、「表示」項目をチェック／アンチェックします。

ボタン

 | 外部プログラムによって生成されたログファイルを表示します。BB TestAssistant で録画されたムービーファイルにのみ適応されます。
 | ムービーを録画したパソコンの設定情報を表示します。BB TestAssistant によって録画されたムービーファイルにのみ適用されます。
表示： | ムービーに適用するスケールを選択します。ウィンドウのサイズにフィットさせます。
 | ムービーを Windows デスクトップ全体に拡大表示させたい場合にこのオプションをトグルさせます。ツールバーはその上に表示されます。プレーヤー上の他のパーツはすべて非表示となります。


サウンドツールバー

サウンドツールバーはワンクリックで各種サウンド機能にアクセスします。

サウンドツールバーの表示／非表示の切り替え：

  1. プレーヤーのメニューバーから「表示」→「ツールバー」を選択します。

  2. サウンドツールバーの表示／非表示を切り替えるには、「サウンド」項目をチェック／アンチェックします。

ボタン

選択されたフレームにサウンドファイルを追加します。

「ムービーへのサウンドの追加と録音」を参照してください。

ムービーにサウンドを録音します。

「ムービーへのサウンドの追加と録音」を参照してください。

再生中の音量を調整します。

再生中の音をミュートします。


オブジェクトツールバー

オブジェクトツールバーを使用すると、よく使用される機能に簡単にアクセスすることができます。

オブジェクトツールバーの表示／非表示を切り替えるには：

  1. プレーヤーのメニューバーから「表示」→「ツールバー」を選択します。

  2. オブジェクトツールバーの表示／非表示を切り替えるにはツールバーにチェックを入れるかまたはチェックを外します。

選択されているオブジェクトのプロパティダイアログを表示します。

選択されているオブジェクトを削除します。

現在のフレームにマーカーを挿入します。

マーカーについての詳細は、「ムービーでマーカーを使用する」を参照してください。

現在のフレームにテキストボックスを挿入します。

テキストボックス関連機能についての詳細は、「テキストボックス」を参照してください。

現在のフレームに画像を挿入します。

画像に関する詳細は、「画像を追加する」を参照してください。

現在のフレームにボタンを挿入します。

ボタンについての詳細は、「ボタンを追加する」を参照してください。

現在のフレームにハイライトを挿入します。

詳細は「ハイライトを追加する」を参照してください。

現在のフレームに矢印を挿入します。

詳細は、矢印の追加を参照してください。

現在のフレームにぼかしを挿入します。

詳細は、「ぼかし効果の追加」を参照してください。


ファイルメニュー

ファイルメニュー項目：

新規ムービーの録画 | 新しいムービーを録画するための録画ウィザードを表示します。
開く | ムービーファイルをオープンします。
閉じる | 現在のムービーファイルを閉じます。
保存 | 変更を現在のムービーファイルに上書き保存します。
名前を付けて保存 | 現在のムービーファイルを別名で保存します。
選択フレームをムービーとして保存 | 選択されたフレームを新しい FlashBack ムービーファイルとして保存します。
フレームをビットマップ画像として保存 | 現在のフレームをビットマップファイルに保存します。
出力 | サポートされているファイルフォーマットにムービーを出力します。詳細は、このヘルプファイルの「ムービーの出力」を参照してください。
バッチ出力ユーティリティ | 複数の FlashBack ムービーファイルを AVI や Flash 形式に一括で出力する、バッチ出力ツールをオープンします。 詳細は、「バッチ出力する」を参照してください。
アップロード | ムービーをビデオ配信サイトや FTP サーバにアップロードします。詳細は、「ムービーのアップロード」を参照してください。
特性 | スクリーンサイズ、ファイルサイズ、ムービーの長さ、フレームレートなど、現在のムービーの各種情報を表示します。
クリップボードへコピー | ムービーのファイル名をクリップボードへコピーします。
メールで送信 | ムービー、または出力ファイルが添付された新規のメールを開きます。
最近開いたムービー |
終了 | BB FlashBack プレーヤーを閉じます。


編集メニュー

編集メニュー項目：

元に戻す

直前の編集操作を取り消しし、編集前の状態に戻します。

やり直し

直前に取り消された編集操作を、やり直し操作します。

最前面へ移動

現在選択されているテキストボックスまたは画像を、そのフレーム上の他のすべてのオブジェクトの前面に移動します。

前面へ移動

現在選択されているテキストボックスまたは画像を、ムービー上の階層化されたオブジェクトのひとつ前面に移動します。

最背面へ移動

現在選択されているテキストボックスまたは画像を、そのフレーム上の他のすべてのオブジェクトの背面に移動します。

背面へ移動

現在選択されているテキストボックスまたは画像を、ムービー上の階層化されたオブジェクトのひとつ背面に移動します。

オブジェクトのコピー

選択されているオブジェクト（テキストボックス、画像、ハイライト、ボタン）を BB FlashBack のクリップボードにコピーします。

ムービー上でオブジェクトをクリックして選択します。

オブジェクトの貼り付け

コピーされているオブジェクトを現在のフレーム上に貼り付けします。

オブジェクト特性

現在選択されているテキストボックス、または画像のプロパティを編集します。

オブジェクトの削除

現在選択されているテキストボックスまたは画像を削除します。

一時停止画像

ムービーがテキストボックスや画像で一時停止ポイントに来たときに一時停止画像を表示させるにはこの項目をチェックします。

サブ項目では、一時停止に使用する画像と表示させる位置を指定します。

  • 一時停止画像の設定： 再生中にムービーが一時停止したときに表示される画像ファイルを選択します。

  • デフォルト一時停止画像の設定： 一時停止画像を BB FlashBack 付属のデフォルトの画像に戻します。

  • 一時停止画像の位置の設定： 一時停止画像が表示される位置を設定します。

マーカー

  • 現在のマーカーのリスト： これはムービー上のすべてのマーカーのリストです。このリストからマーカーを選択することで、そのフレームに移動することができます。

  • 削除： 現在のムービー上の各マーカーの名前を表示するサブメニューを表示します。
    マーカーを削除するにはサブメニューからそのマーカーを選択します。


挿入メニュー

FlashBack ムービー | 現在のフレームに FlashBack ムービー（.FBR ファイル）を挿入します。
テキスト | テキストボックスを現在選択されているフレーム上に現われるように追加します。 テキストボックスに関する詳細は、「テキストボックスについて」を参照してください。
マーカー | 現在のフレームにマーカーを追加します。 マーカーについての詳細は、「ムービーでマーカーを使用する」を参照してください。
画像 | 現在のフレームに画像を追加します。 画像についての詳細は、「画像を追加する」を参照してください。
矢印 | 現在のフレームに矢印を挿入します。 詳細は、矢印の追加を参照してください。
ボタン | 現在のフレームにボタンを追加 ボタンについての詳細は、「ボタンの追加」を参照してください。
ハイライト | 現在のフレームにハイライトを追加します。 詳細は「ハイライトを追加する」を参照してください。
サウンド | 新しいトラックとして、現在のフレームからスタートするサウンドファイルを追加します。 詳細は、「サウンド編集の基本」を参照してください。
透かし | ムービーに透かし画像を追加します。 詳細は、透かしの追加を参照してください。
一時停止 | 現在のフレームに一時停止を追加します。 詳細は、一時停止を参照してください。
Web カメラ / ピクチャ・イン・ピクチャビデオ | ピクチャ・イン・ピクチャ、あるいは Web カメラ映像として、FLV、AVI、WMV のムービーファイルを入力します。
ビデオファイル | ムービーにビデオファイルを挿入し、現在のフレームから開始します。 詳細は、ビデオファイルの挿入を参照してください。
ぼかし | ムービーにぼかし効果を挿入します。 詳細は、「ぼかし効果の追加」を参照してください。
マウスクリック | 選択したフレームにマウスクリックのイベントを挿入します。


表示メニュー

タイムライン

タイムラインの表示／非表示

フレームバー

フレームバーの表示／非表示

ステータスバー

ステータスバーの表示／非表示

ツールバー

このメニューには「編集」、「ファイル」、「プレーヤー」、「クロッピング」の各ツールバーの表示／非表示を切り替えるための 4つのサブ項目があります。

タイムラインの単位

このメニューにはタイムラインに表示される単位（秒またはフレーム）を選択するための2つのサブ項目があります。

タイムラインのサムネール

マウスがタイムラインまたはフレームバー上に来たときに表示されるサムネールのムービー枠のサイズを選択します。

キーログ

キーログウィンドウを表示し、ムービーに記録されている全てのキー入力を表示します。

「キー押下の表示」を参照してください。

キーバーモード

キーストロークの表示法を 2つのモードから選択します：

  • 非加工： そのフレーム上で発生したキーストロークを個々に表示します。

  • センテンス： 一連のキーストロークを単語としてグループ化します。

ムービーサイズ

このメニューのサブ項目はムービーの表示サイズを制御します：

  • 25％-100％ ： デフォルトでムービーはオリジナルサイズの 100％ で表示されます。100％ 以下のオプションを選択することでより小さいサイズで表示させることができます。

  • その他： このオプションは表示されるムービーのパーセントサイズを入力するダイアログボックスを表示させます。

  • ムービーをウィンドウに合わせる： このオプションを選択すると、ムービーのウィンドウサイズを、現在の BB FlashBack プレーヤーのウィンドウサイズに合うように自動的に調整します。

  • ウィンドウをムービーに合わせる： このオプションを選択すると、BB FlashBack プレーヤーのウィンドウサイズを、現在のムービーのサイズに合うように自動的に調整します。

フルスクリーン

このオプションを選択すると、ムービー領域が Windows のデスクトップ全体を占有します。ツールバーはその上に置かれます。プレーヤー画面の他の部品はすべて非表示となります。

フルスクリーン表示

フルスクリーンモード時に、どのユーザインターフェースを表示させるかを設定します。

デフォルトではタイムラインだけが表示されます。サブメニューを開いて、フレームバーとツールバーを表示させるようにすることができます。

オートスクロール

オートスクロールのサブメニューには 3つのオプションがあります：

  • なし： これを選択すると、オートスクロールがOFFになります。ムービーがムービー領域より大きい場合は、映像のすべてを見るには手動でスクロールする必要があります。

  • マウスを常に中央に： これを選択すると、BB FlashBack は常にムービー領域をスクロールさせて、マウスが中央に表示されるようにします。

  • マウスをほぼ中央に： これを選択すると、BB FlashBackはムービー領域を必要に応じてスクロールさせ、マウスがほぼ中央に来るように表示させます。

PC 情報の表示

BB TestAssistant で録画されたムービーファイルは、そのムービーを録画したパソコンの情報を保持しています。このメニューを選択すると、その情報が表示されます。

外部ログファイルの参照

外部プログラムによって生成されたログファイルを表示します。BB TestAssistant で録画されたムービーファイルにのみ適応されます。

別ウィンドウでムービーを表示

マルチモニターがある場合は、このオプションを選択して非プライマリ側のモニターにムービーをフルスクリーンで表示させることができます。プライマリモニターのほうにはツールバー、タイムライン、その他のコントロールを表示させます。

Web カメラモードの切り替え

Web カメラ映像は、独立したウィンドウ上で、またはムービー上に埋め込まれた形で表示させることができます。2つのモードを切り替えるにはこのメニューを使用します。

「 Web カメラ映像の表示と編集」を参照してください。

Web カメラビデオを表示

この項目を使用して、Web カメラ映像の表示/非表示を切り替えます。


ムービーメニュー

このメニューの項目：

再生

再生を開始、または一時停止中は再生を再開します。

再生速度

再生速度を 4倍、2倍、通常、1/2倍、1/4倍のスピードに設定します。

進む

次のフレームに移動します。

戻る

ひとつ前のフレームに移動します。

先頭フレーム

ムービーの最初のフレームに移動します。

末尾フレーム

ムービーの最終フレームに移動します。

前のマーカー

前のマーカーのあるフレームに移動します。

次のマーカー

次のマーカーのあるフレームに移動します。

前のマウスクリック

ひとつ前のマウスクリックイベントのあるフレームに移動します。

次のマウスクリック

マウスクリックイベントのある次のフレームに移動します。

繰り返し

ムービーをループ再生させるにはこのオプションをチェックにします。

一時停止箇所

このメニュー項目には4つのサブ項目があります：

  • マウスクリックで一時停止：このオプションをチェックにすると、マウスクリックのあるフレームごとに再生を一時停止します。

  • マーカーで一時停止：このオプションをチェックにすると、マーカーのあるフレームごとに再生を一時停止します。

  • テキストボックスで一時停止：このオプションをチェックにすると、テキストボックスが出現するフレームごとに再生を一時停止します。テキストボックスの詳細は「テキストボックスについて」を参照してください。

  • ムービーの一時停止を無視：このオプションをチェックにすると、ムービー中の一時停止をすべて無視します。

ムービーに一時停止を追加する方法の詳細はムービーに一時停止を挿入するを参照してください。

フレームにジャンプ

ムービーの特定のフレームまたはタイムラインの特定の箇所にジャンプします。

テキスト検索

このオプションは、ムービー上の何か特別なテキストが描画されたフレームにジャンプします。これは、ウィンドウのタイトルバーに描画されたテキストを検索したい場合に使用できます。これにより、特定のアプリケーションが登場するフレームを探すことができます。


サウンドメニュー

サウンドの追加 | 選択されたフレームにサウンドファイルを追加します。 「ムービーへのサウンドの追加と録音」を参照してください。
サウンドの録音 | ムービーにサウンドを録音します。 「ムービーへのサウンドの追加と録音」を参照してください。
サウンドオプション | デフォルトの再生デバイスを設定します。 サウンドオプションウィンドウを参照してください。


効果メニュー

カーソルのハイライト

マウスカーソルのハイライトプロパティを設定します - サイズ、色、それを囲む円の不透明度、クリックで円をハイライトさせるかどうかなどを設定します。


アクションメニュー

「マウスカーソル」サブメニュー:

カーソルを最前面に | マウスカーソルを、テキストボックスや画像などの他のオブジェクトより手前に表示させます。
カーソルを最背面に | マウスカーソルを他のオブジェクトの背後に移動させます。


ツールメニュー

ツールメニューの項目：

プレーヤーオプション | サウンド再生デバイスを設定します。また、BB FlashBack が自動的にアップデートを行うかどうかなど、他のオプションを設定します。 詳細は、「プレーヤーオプションウィンドウ」を参照してください。
録画オプション | レコーダーのオプションウィンドウを表示します。 詳細は、「レコーダーオプションウィンドウ」を参照してください。
EXE 出力から FBR を復元する | BB FlashBack から EXE 出力を取り出し、復元して元の FBR ファイルとして保存します。EXE 出力は FBR ファイル自体を包含しています。


ヘルプメニュー

ヘルプメニューの項目：

ヘルプ...

このヘルプファイルを表示します。

サポート

BB FlashBack にはアプリケーションの障害を Blueberry にレポートする機能があります。

  • ロキング自動実行の切り替え - BB FlashBack の内部ロキングを ON にします。

  • 障害を Blueberry にレポート - Blueberry に障害レポートを送信する処理を行うウィザードを表示します。

詳細は、「障害をレポートする」を参照してください。

BB FlashBack の購入

購入後は表示されません。

2つの項目があります：

  • ライセンスを購入する - ライセンス購入のヘルプを表示します。

  • BB FlashBack 2 の購入 - ライセンスをオンラインで購入する Blueberry の Web サイトのページを開きます。

ライセンスキーを入力／確認する

BB FlashBack のフルライセンス用に、Blueberry から発行されたライセンスキーとユーザ名を入力または確認するウィンドウを表示します。

アップデート確認

BB FlashBack の新しいバージョンをチェックします。見つかると、ダウンロードしてインストールするオプションが表示されます。

バージョン情報

BB FlashBack のバージョンを表示するバージョン情報ボックスを表示します。メールアドレスとサポート用の Web リンクが表示され、ライセンスキーを入力することができます。


キー押下の表示

BB FlashBack はムービーの録画中に押されたキーの履歴を2通りの方法で見ることができます。キー履歴ウィンドウとキーバーです。

キー履歴ウィンドウ

ムービーが録画されている最中のすべてのキー押下の履歴を表示します。特定の文字を検索したり、そのキーが入力されたフレームにジャンプしたりすることもできます。詳細は、「キー履歴ウィンドウ」を参照してください。

キーバー

各フレームごとにキーの押下を表示するフレームバーの一部です。詳細は、「キーバー」を参照してください。

備考： キーストロークは Windows NT4 での録画では記録されません。


キー履歴ウィンドウ

ムービーの録画中に押されたすべてのキー入力の履歴を表示します。単語を検索して、それが入力されたフレームにジャンプすることができます。

キー履歴ウィンドウを表示するには：

プレーヤーのメニューから「表示」→「キー履歴」を選択します。

キー履歴ウィンドウがムービー領域にフロート状態で表示されるか、またはムービー領域の横にドッキングされます。「ドッキング」、「アンドッキング」ボタンを使用して好みの設定を選択します。

表示モード

ウィンドウがキー押下のデータを表示させるには 2つの方法があります：すべてのキー押下を文字単位で表示する「非加工」モードと、キー押下を単語と行にまとめて読みやすく表示する「センテンス」モードです。

センテンスモードでは、入力の編集と修正の最終結果を表示します。たとえば、ユーザが「Treasure」を間違えて入力したとします：

Treasire

そして、これを修正するために BackSpace キーを 3回押して「 ure 」と入力したとすると、キー履歴ウィンドウにはセンテンスモードで次のように表示されます：

Treasure

BB FlashBack はキー押下を 1つにまとめています。ただし、これは BackSpace キーや矢印キー、Delete キーなどの単純な操作の場合のみ機能します。

なお、各キーの押下、または文章はタイムスタンプとともに表示されます。- その項目が入力されたときの、ムービー開始からの経過時間です。

ムービー内で入力された単語を探すには：

  1. キー履歴ウィンドウ上で、「検索」項目に単語または単語の一部を入力します。

  2. 「検索」ボタンを押します。BB FlashBack はムービー内のすべてのキー押下からその単語を探し、その単語の最初の文字が入力されたフレームにジャンプします。

自動位置付け機能

「自動位置付け」のボックスがチェックされていると、カーソルがキー履歴ウィンドウ内を移動するとともに、BB FlashBack は自動でカーソルのある文字が押されたフレームにジャンプします。

キー入力データの出力

「出力」ボタンを押すと、BB FlashBack は非加工モード、またはセンテンスモードのいずれかでキー押下データを XML に出力します。


キーバー

キーバーはフレーム上でのキー押下を表示するフレームバーのセクションです。

表示モード

キーバーにキーの押下データを表示させるには2通りの方法があります：押された文字を順序立ててすべて表示する「非加工」モードと、単語や行ごとに読みやすくまとめて表示する「センテンス」モードです。

ここに、ムービーの録画中に「test」と入力した場合の例を示します。1つは非加工モードの表示で、もう1つはセンテンスモードの表示です。

非加工モードでは次のようになります：

1文字1文字が押された個々のフレームを確認することができます。

これがセンテンスモードでは、押されたキーが1つの単語としてグループ化され、キーバー上ではその単語が入力された区間が青く塗りつぶされます。

つまり、非加工モードでは押されたキーを詳細に確認することができ、センテンスモードでは理解しやすい形で表示されることになります。

キーの表示モードを変更するには：

  • 「表示」→「キー履歴モード」を選択します。

センテンスモードについて

センテンスモードでは、入力の編集と修正の最終結果を表示します。たとえば、ユーザが「Treasure」を間違えて入力したとします：

Treasire

そして、これを修正するために BackSpace キーを 3回押して「 ure 」と入力したとすると、キー履歴ウィンドウにはセンテンスモードで次のように表示されます：

Treasure

BB FlashBack がキー押下を結合したことになります。ただし、これは BackSpace キー、矢印キー、Delete キーなどが使用された場合の単純なケースのみの対応となります。

非加工モードについて

単一フレーム上に 2文字以上が入力された場合は、非加工モードでは小さな緑の指標が表示されます。そのフレームにおけるすべてのキー押下を確認するにはマウスカーソルをフレーム上に持っていき、サムネール画像を表示させます。キー押下のリストが画像の下方に表示されます。

下記の例では、「 t 」と「 e 」のキーが同じフレーム上で押されています。マウスカーソルをその上に持っていくとサムネールが表示されます：

仮想キー

非加工モードとセンテンスモードの両方において、矢印キー、制御キー（ Ctrl、Alt など）、ファンクションキーなどの仮想キーは青色で表示されます。上記の例では、スペースキーが押されたときに小さな三角が表示されています。

下記に仮想キーの一覧と、BB FlashBack がキーバー上で表示する記号の一覧を示します：


プレイヤーオプションウィンドウ

プレーヤーオプションウィンドウではBB FlashBackプレーヤー使用時の詳細設定を行います。

オプションウィンドウを表示するには「ツール」メニューから「プレーヤーオプション」項目を選択します。

再生オプション：

  • 「ムービーの先頭に戻る」のチェックボックスを使用して、ムービーの終了時にプレイヤーをムービーの先頭フレームに戻します。このオプションが選択されていない場合、プレイヤーはムービーの終了時に最終フレームを表示したままにします。

  • 「自動再生」のチェックボックスを使用すると、ムービーファイルが「開く」メニューからオープンされた時、あるいは Windows 上のアイコンがダブルクリックされた時にプレイヤーが自動的にムービーの再生を開始します。

アップデートオプション

  • 「自動的にチェックする」のオプションを選択すると、BB FlashBack は新バージョンを毎日チェックします。このオプションが選択されていない場合は更新を手動でチェックする必要があります。詳細は、「BB FlashBack の更新をチェックする」を参照してください。

  • 「BB FlashBack の改善に協力する」のオプションを選択すると、BB FlashBack は更新のチェック時に使用履歴のデータを送信します。

    備考： この情報は完全な匿名で送信されます。BB FlashBack のクラッシュ情報や、どの機能がよく使用されているか、インストール時に問題があったどうかなどを知ることは Blueberry にとって大きな手助けとなります。このデータは将来の開発にも大きく貢献します。

サウンドオプション

  • プレイヤー上でのサウンド再生に使用されるサウンドデバイスを選択します。

  • メニューの「サウンドの挿入」、あるいはツールバーのボタンによって追加されたサウンドファイルに使用される、共通の MP3 圧縮レベルを設定します。

詳細設定：

  • BB FlashBack が使用するメモリの量を変更するには「メモリ使用量」のオプションを使用します。メモリを多く使用すると、再生時にムービーのタイムラインをクリックした時のランダムフレームの検索が早くなります。


AVI からの入力

AVI ファイルを FlashBack ムービーに変換する

BB FlashBack は AVI ビデオファイルを FlashBack 形式のムービー (.FBR ファイル) に変換することができます。プレーヤーで変換ファイルを開き、通常通りテキストやサウンドの追加、フレームの編集などを行うことができます。

備考： FlashBack ムービーファイルで使用される圧縮は動画用ではなく通常の Windows アプリケーションの録画用に最適化されています。したがって例えば、テレビ番組などの AVI ファイルを変換すると、できあがる FlashBack ムービーファイルは元の AVI ファイルよりサイズが大きくなる可能性があります。

備考： この機能は次のコーデックでエンコードされたAVIファイルでのみテストされ、サポートされています：フルフレーム（未圧縮）、Huffyuv、DivX 3 & 5、MS Video 1、Techsmith Screen Capture。

AVI ファイルを BB FlashBack ムービーファイルに変換する：

  1. プレーヤー上で、「ツール」メニューから「AVI ファイルを FlashBack ムービーに変換する」を選択します。

  2. 「AVI ファイル名」の項目に BB FlashBack で編集したい AVI ファイルを指定します。

  3. 「FlashBack ファイル名」の項目に、作成したい FlashBack のファイル名を指定します。

  4. 変換作業の終了時に、変換されたムービーをオープンしてすぐに編集作業に入りたい場合は、「変換後にムービーをオープンする」のチェックボックスをチェックします。


コマンドラインオプション

プレーヤーは次のようにコマンドラインから呼び出すことができます：

Flashback Player.exe [/オプション] ＜ムービー名＞

ここではオプションは任意で、ムービー名は必須です。オプションが指定されなかった場合、ムービーが再生されるだけとなります。下記のいずれかのオプションを指定してください。

  • /e ? オープンして編集します。

  • /f ? SWF に出力します。

  • /v ? AVI に出力します。

  • /? または /help ? オプションの一覧を表示します。


テキストボックスについて

テキストボックスを追加する

BB FlashBack プレーヤーはムービーの編集中にテキストボックスを追加することができます。これにより、特定の動きに対してコメントを追加することができます。

テキストボックスを追加するには：

  1. テキストボックスを追加したいフレームを選択します。

  2. プレーヤーメニューから「挿入」→「テキスト」を選択します。

    あるいは

    「編集」ツールバーの「テキスト挿入」ボタンを押します：

  3. 表示させたい文字をテキストボックスプロパティのウィンドウで入力します。ムービーに表示されるテキストのスタイル、ボックスの種類、表示時間の長さを指定します。

テキストボックスのプロパティを編集するには：

特定のテキストボックスに対応するテキストボックスプロパティのウィンドウを表示させるにはいろいろな方法があります。

  • ムービー領域上のテキストボックス自身をダブルクリックします。

    あるいは

  • ムービー領域のテキストボタンをクリックします。ボックスが青い線で囲まれ、選択されたことが確認できます。「編集」メニューから「テキストボックスプロパティ」を選択するか、あるいは編集ツールバーの [image] ボタンを押します。

    または

  • フレームバー上で、テキストボックスの開始を表す [image] 画像のあるフレームをダブルクリックします。

テキストボックスプロパティが表示されると、テキストの内容とスタイルが変更できるようになります。

このウィンドウの詳細は「テキストボックスプロパティ」を参照してください。

テキストボックスの表示期間を変更する

ムービー上のテキストボックスは、設定された時間の長さの間だけ表示されます。 ? テキストボックスのプロパティのステップ3でセットされた設定時間の長さです。

フレームバーを見ると、テキストボックスを追加したフレーム上に [image] 画像があり、それが終了するフレーム上に [image] 画像があるのが分かります。これらはムービー上におけるその表示の開始位置と終了位置を表しています。

その表示時間の長さは、テキフトボックスプロパティウィンドウ上で変更するか、あるいはフレームバー上で [image] アイコンと [image] アイコンをクリックしてドラッグすることにより変更することができます。その場合、クリックしたあと1秒間ホールドしてからドラッグしてください。

テキストボックスを移動するには：

BB FlashBack プレーヤーのムービー領域にあるテキストボックスにマウスを持っていき、マウスの左ボタンを押したままにします。カーソルの形状が [image] に変わりますので、左ボタンを押したままドラッグしてテキストボックスをムービー上の任意の位置に移動します。

別の方法として、テキストボックスプロパティの「位置」タブを使ってボックスの左上コーナーの座標を指定することもできます。

テキストボックスのサイズを変更するには：

これは通常のウィンドウのサイズ変更と同じ方法で行うことができます。BB FlashBack プレーヤーのムービー領域上で、マウスカーソルをテキストボックスのコーナー、または四隅に移動させます ? カーソルの形状が、ボックスのサイズ変更が行えるようにドラッグ可能であることを示す形に変わります。

別の方法として、テキストボックスプロパティの「位置」タブを使ってテキストボックスの幅と高さを指定することもできます。

テキストボックスを削除するには：

  1. クリックしてテキストボックスを選択します。

  2. プレーヤーのメインメニューから「編集」→「テキスト削除」を選択します。

    あるいは

    「編集」ツールバーの「オブジェクト削除」ボタンを押します：

テキストボックスでムービーを一時停止する

テキストボックスが表示されると、その内容を読む時間を確保するためにムービーの再生が自動的に一時停止して、再生継続の許可待ちの状態になります。この機能を特定のテキストボックスで可能にさせるには、テキストボックスのプロパティを開いて、「?ムービーをこのテキストボックスで一時停止する??」のチェックボックスにチェックを入れます。


テキストボックスプロパティ

テキストボックスプロパティのウィンドウはテキストボックスに表示されるテキスト、あるいはテキストのスタイル、テキストボックスのスタイル、再生中にムービーを一時停止するかどうかなどを変更するのに使用されます。

このウィンドウには 5つのタブがあります：

  • プロパティ： 「テキスト」の入力項目でテキストボックスに表示されるテキストを入力します。使用されるフォントとボックスのスタイルはこのタブにあるコントロールを使って設定することができます。スタイルに関する詳細は、下記のテキストボックススタイルを参照してください。

ムービー上でボックスが表示される時間の長さは、「テキスト表示時間」の項目に入力します。

テキストボックスが表示されたときにムービーを一時停止したい場合は、「このテキストボックスでムービーを一時停止」のチェックボックスにチェックを入れます。

  • スタイル： 現在のテキストボックスの外観をスタイルとして保存し、他のテキストボックスにも適用することができます。

  • 背景： このタブにあるコントロールはテキストボックスの背景と境界線の色を決定します。2色の色の変化（上から下、または左から右）を持つグラデーション効果のボックスを設定することができます。

  • 位置： このタブにはテキストボックスの詳細な位置決めを行うコントロールがあります。左上コーナーのピクセル単位の位置と、テキストボックスの幅と高さを入力することができます。

  • 影： 「影を付ける」を選択すると、テキストボックスに影を付けることができます。このタブにあるコントロールを使用して影の色、サイズ、不透明度を設定します。

  • トランジッション： トランジッションの時間を設定して、テキストボックスをフェードイン、フェードアウトさせます。

テキストボックススタイル

色、テキストサイズ、フォントなどのテキストボックスプロパティの組み合わせができたとき、これらの組み合わせを他の場面でも再び使用したい場合があります。その場合は、これらのプロパティをスタイルとして保存することができます。そして、そのスタイルを他のムービーのテキストボックスに適用して同じ外観にすることができます。

スタイルの保存方法：

  1. 該当するテキストボックスのプロパティを開きます。

  2. テキストボックスプロパティの「プロパティ」タブを選択し、「現在のスタイルを保存」のボタンをクリックします。

  3. スタイル名を入力し、OKを押します。

BB FlashBack は入力した名前を使用してスタイルを作成します。スタイルの名前は、どのムービー上でもテキストボックスの編集時に「テキストボックススタイルの選択」のドロップダウンリストに表示されます。

このスタイルをテキストボックスに適用するには、「テキストボックススタイルの選択」のドロップダウンリストからスタイル名を選択します。

テキストボックスのサイズと位置はスタイルには保存されません。


画像を追加する

BB FlashBack はムービー領域に画像を表示させることができます。

ムービーに画像ファイルを追加するには：

  1. フレームバー上で画像を追加したい位置のフレームを選択します。

  2. プレーヤーのメインメニューで「挿入」メニューから「画像」を選択します。 または 編集ツールバー上の画像挿入ボタンをクリックします：

  3. 画像ファイルを選択するには「画像の読み込み」ボタンをクリックします。有効なフォーマット：.jpg .png .bmp .gif .emf .wmf or .ico ファイル

画像を編集するには：

特定画像の画像プロパティダイアログを表示するには数々の方法があります。

  • ムービー領域の画像自体をダブルクリックします。 または

  • 画像をクリックして、画像の周りに青い枠線が表示されることを確認します。そして、編集ツールバーにある [image] ボタンを押すか、または「編集」メニューから「画像プロパティ」を選択します。

    または

  • フレームバー上で、画像の出現を表す [image] アイコンのフレームをダブルクリックします。

画像プロパティウィンドウでは次のような変更が行えます：

  • サイズと位置 - 画像は必要に応じて元画像を引き伸ばしたり縮めたりしてサイズ変更することができます。

  • 不透明度 - 画像全体の不透明度を設定します。

  • フレームバー上でズームとパン効果を探します。これを行う簡単な方法は、ツールバーにある「ジャンプ」の項目で効果を選択することです。そのフレームに直行することができます。

    アイコンはトランジッションの開始フレームを示しています。ズームとパン効果がここからスタートします。
    アイコンはトランジッションの終了フレームを示しています。ズームとパン効果はここで終了します。

  • 表示時間 - 画像の表示は表示時間の設定を行うことができます。または画像の表示とともにムービーを一時停止させることができます。

  • トランジッション - トランジッションの所要時間を設定することにより、画像をフェードイン／フェードアウトさせることができます。

画像を移動するには：

ムービー領域の画像ボックスにマウスを移動させ、マウスの左ボタンを押したままにします。カーソルの形が [image] に変わりますので、ドラッグして画像ボックスをムービーの任意の位置に移動します。

別の方法として、画像のプロパティダイアログ上で位置を設定することもできます。

画像の表示時間の長さを変更する方法：

次のいずれかを実行します：

  • 画像のプロパティウィンドウで表示時間の長さを変更するか

    または

  • フレームバー上で画像の開始フレームと終了フレームを表す [image] アイコンまたは [image] アイコンをクリックしてドラッグします。クリックしたあと、1秒間ホールドしてからドラッグしてください。

画像を削除するには：

  1. Select the Image by clicking it on the movie area.
  2. On the Player main menu, select Edit and then Delete Image.

    or

    On the     Edit toolbar, click the Delete Object button:


ハイライトの追加

ムービーの編集中にハイライトを追加することができます。これにより、ムービーの特定領域に注意を促すことが出来ます。

ハイライトを追加するには：

  1. ハイライトボックスを追加したいフレームを選択します。

  2. プレーヤーのメインメニューから「挿入」→「ハイライト」を選択します。
    または

    プレーヤーのツールバーにあるハイライトボタン [image] を押します。

  3. ハイライトの挿入ウィンドウでは、3 つのタブを使用してハイライトをカスタマイズすることができます。

    • 全般タブ - ハイライトの名前を入力し、ハイライト領域の形、背景色と枠線の色を選択します。

      枠線の太さをピクセル単位で指定したり、不透明度と表示時間を指定することもできます。また表示時間をムービーの一時停止に切り替え、マウスクリックされたら再開するという設定にすることもできます。

    • 位置タブ ? 位置タブ上で、ハイライトの左上コーナーの座標を設定することができます。

    • トランジッションタブ ? トランジッション時間の長さを設定することにより、ハイライトにフェードイン・フェードアウトの効果を適用することができます。

フレームバーにはハイライトを追加したことを示す [image] 画像が表示されます。ハイライトをさらに追加したい場合は、フレームバーのタイムラインを右クリックして「ハイライトの挿入」を選択します。

ツールバー上では「ジャンプ」のドロップダウンメニューからハイライトに直接ジャンプすることができます。

ハイライトのプロパティを編集するには：

特定のハイライトのプロパティダイアログを表示するにはいろいろな方法があります。

  • ハイライト領域をダブルクリックします。
    あるいは

  • ハイライト領域を右クリックして「プロパティ」を選択します。

ハイライトはスクリーン上の他の要素の前面、背面などに階層化させて配置することも可能です。ハイライト上を右クリックしてメニューから「前面に移動」または「背面に移動」を選択します。

ハイライトを移動するには：

ハイライトはデフォルトでは録画されたスクリーンの左上コーナーに表示されます。ハイライトをクリックしてドラッグすればムービー上の任意の位置に配置することができます。

別の方法として、ハイライト挿入ダイアログの「位置」タブ上でハイライトの左上コーナーの座標を指定することもできます。

ハイライトの表示時間の長さを変更する方法：

次のいずれかを実行します：

  • ハイライトのプロパティウィンドウで表示時間の長さを変更するか

    または

  • フレームバー上でハイライトの開始フレームと終了フレームを表す [image] アイコンまたは [image] アイコンをクリックしてドラッグします。クリックしたあと、1秒間ホールドしてからドラッグしてください。

ハイライトのサイズを変更するには：

ハイライトの枠線上にカーソルを置くとマウスの形状が変わり、ドラッグしてハイライトのサイズを変更することができるようになります。

別の方法として、ハイライト挿入ダイアログの「位置」タブ上でハイライトの幅と高さをピクセル単位で指定することもできます。

ハイライトを削除するには：

  1. ハイライトをクリックして選択します。

  2. プレーヤーのメインメニューから「編集」→「ハイライトの削除」を選択します。
    または
    ハイライトを右クリックして「削除」を選択します。

ハイライトでムービーを一時停止する

ハイライトの表示とともに、視聴者にハイライト領域に注意を促す時間を与えるためにムービーを自動的に一時停止させることができます。

特定のハイライトにこの機能を適用するには、画像挿入ウィンドウを開いて、「 ?マウスクリックまでムービーを一時停止??」のチェックボックスにチェックを入れます。


ボタンの追加

ボタンオブジェクトは Web ページを開いたり、ムービーの任意の位置にジャンプしたり、再生を停止/再開したりすることのできるインタラクティブオブジェクトです。

ボタンを追加するには：

  1. ボタンを追加したいフレームを選択します。

  2. プレーヤーのメインメニューから「挿入」→「ボタン」を選択します。

    あるいは

    「編集」ツールバーから「ボタンの挿入」ボタンを押します：

  3. ボタンプロパティウィンドウで：

    • ボタンの見出し文字を入力します。

    • テキストのスタイルとボタンの背景を選択します。

    • 表示される時間の長さを決めます。

    • 下記の中からアクションを取り決めます：

      1. 再生停止

      2. 再生開始

      3. URL を開く。Webページのアドレスを入力します。「http://」 はあっても無くてもかまいません。ボタンが押されると Web アドレスがデフォルト Web ブラウザでオープンされます。

      4. ムービーの特定の場所にジャンプします。フレーム番号やマーカー、あるいはテキストボックスや画像、ハイライト、サウンド、ボタンなどのオブジェクトにもジャンプできます。

      5. JavaScript の実行。ボタンがクリックされたときに実行される JavaScript を記述することができます。ただし、ムービーが BB FlashBack プレーヤー内で再生されているときは JavaScript は実行されません。ムービーが Flash 出力されたときのみ実行されます。

        JavaScript のコードには 400 文字までという制限がありますが、この制限よりもっと複雑な処理を実行させたい場合は、Flash 出力時に生成される Web ページ上でファンクションの呼び出しを行うことができます。

ボタンの表示時間の長さを変更する方法：

次のいずれかを実行します：

  • ボタンのプロパティウィンドウで表示時間の長さを変更するか

    または

  • フレームバー上でボタンの開始フレームと終了フレームを表す [image] アイコンまたは [image] アイコンをクリックしてドラッグします。クリックしたあと、1秒間ホールドしてからドラッグしてください。


矢印の追加

BB FlashBack はムービーに矢印を追加して、視聴者の注意を引いたり、詳細を強調したりすることができます。

矢印を追加するには：

  1. 矢印を追加したいフレームを選択します。

  2. プレーヤーのメインメニューで、「挿入」→「矢印」を選択するか
    または
    プレーヤーのツールバーで、「矢印」ボタンをクリックします。

矢印の外観を変える

矢印のプロパティを変更するには：

  • 矢印をダブルクリックするか
    または
    矢印を右クリックしてプロパティを選択します。

矢印のプロパティウィンドウには下記のタブが表示されます：

  • プロパティ
    ここで変更可能な設定：

    • 矢印の始まりと終りの形

    • 先頭と末尾の幅

    • 不透明度

    • 表示される時間の長さ

  • 外観
    ここで変更可能な設定：

    • 塗りつぶしの種類（線画またはグラデーション）とカラー

    • 境界線の外観

    • 影の外観

  • 位置
    このタブでは矢印の位置とサイズが変更可能です：

  • トランジッション
    矢印のフェードイン・アウトの設定を行います。

矢印は、ハイライトを右クリックして「前面に移動」、「背面に移動」などのオプションを選択することで、スクリーン上の他の要素の前面や背面などに階層的に移動させることができます。

矢印の位置とサイズを変更する

矢印を移動させるには、その中央をクリックしてドラッグします。先端と末尾の位置を変更するには、先端または末尾をクリックしてドラッグします。矢印の幅を広くしたり狭めたりするには、そのプロパティウィンドウの「プロパティ」タブにある「幅」プロパティを変更します。

矢印を削除するには：

クリックして矢印を選択します。

プレーヤーのメインメニューで、「編集」→「矢印の削除」を選択します。

または

選択されている矢印を右クリックし、「削除」を選択します。


透かしを追加する

BB FlashBack ではムービーに透かし画像を追加することができます。この画像はムービーの間中、その設定した位置とサイズで表示され続けます。

備考： 透かし画像は、ムービーの途中ではサイズや位置を変更することはできません。

透かしを追加するには：

  • 「挿入」メニューから「透かし」を選択します。

  • 画像ファイルを選択します。

透かしの位置を変更するには、画像をクリックしてドラッグし、ムービーの好きな位置に移動します。サイズを変更するには、画像の境界線か角にマウスカーソルを持っていき、それクリックしてドラッグします。


ぼかし効果の追加

BB FlashBack はムービーの細部をあいまいにさせるために、ぼかし効果を追加することができます。フォーム上の詳細をぼかしたいときにこれを利用します。

ぼかし効果を追加する方法：

  1. ぼかしを追加したいフレームを選択します。

  2. プレーヤーのメインメニューから「挿入」→「ぼかし」を選択します。
    または
    プレーヤーのツールバー上の「ぼかし」ボタンをクリックします。

ぼかしを右クリックして、ぼかしの強さを調整することができます。これを行うにはプロパティ上で「ぼかしの半径」を設定します。


ギャラリーの使用

BB FlashBack ではギャラリーにテキストボックスや画像、その他のオブジェクト追加することによって、それらを再利用することが可能になります。ギャラリーに登録されると、どのムービーに対してもそれらをドラッグするだけで再利用することが可能になります。

ギャラリーにオブジェクトを追加する方法

  • Ctrl キーを押しながら、オブジェクトをギャラリーにドラッグします。

    または

  • オブジェクト上を右クリックし、メニューから「ギャラリーへの追加」を選択します。

ギャラリーのオブジェクトをムービーにコピーする方法

  • ギャラリーからオブジェクトをムービーにドラッグするか、

    あるいは

  • ギャラリーのオブジェクトを右クリックして、メニューから「ムービーへ追加」を選択します。

ギャラリーのオブジェクトはそれをダブルクリックして編集することができます。

ギャラリーのオブジェクトを削除するには、それを右クリックしてメニューから「削除」を選択します。


マウスカーソルのハイライト

デフォルトでは、BB FlashBack はマウスカーソルの周りに黄色のハイライト円を描きます。この円の色や透明率、サイズや外観などを変えたり、あるいは非表示にしたりするには、「効果」メニューの「カーソルのハイライト」オプションを使用します。

備考： Windows の「マウスカーソルの軌跡」オプションを使用している場合は、ハイライト円は表示されません。


マウス操作のアニメーション

録画中にマウスボタンが押されたとき、BB FlashBack は完成後のムービーにアクションが起こったことを示すためのアニメーションを表示することができます。これらのアニメーションは、それらを構成するビットマップを編集してカスタマイズすることができます。

マウス操作アニメーションの ON/OFF を切り替えるには：

「効果」メニューで、「カーソルのハイライト」を選択します。そして、「マウスクリックのハイライト」の設定を選択・非選択します。


マウスを他のオブジェクトの前面または背面に配置する

デフォルトではマウスカーソルはテキストボックスや画像、ハイライトなど、ムービーに追加された他のオブジェクトの背面を移動します。

しかし、場合によってはオリジナル録画のようにマウスカーソルを他のオブジェクトの前面に移動させたいこともあります。BB FlashBack ではこれを行うことができます。

備考： Web カメラのビデオウィンドウは例外となります。これは常にマウスカーソルや BB FlashBack に追加された他のオブジェクトの前面に表示されます。

他の表示オブジェクトの前面にカーソルを移動させるには：

  1. メニューの「アクション」→「カーソル」→「カーソルを前面に移動」を選択します。

カーソルを他のオブジェクトの後ろに移動したい場合は、同じメニューから「カーソルを背面に移動」を選択します。


ムービーにマーカーを使用する

BB FlashBack は作成できるムービーのサイズには制限がありません。現実的にはパソコンのディスクの空き容量によって制限されますが、ディスクの容量がある限りは何分でも、あるいは何時間に渡るムービーでも作成することができます。

大きなムービー中に何度も繰り返し表示させたい特別なイベントがあった場合、そこを何度も同じ操作で繰り返し探す作業はきっと退屈な作業になることでしょう。

ムービーの特定箇所にいち早くアクセスするために、BB FlashBack プレーヤーにはマーカーを付ける機能が用意されています。マーカーは特定のフレームにラベルを付けるという単純な機能です。これにより、簡単にそのフレームにたどり着くことができるようになります。

マーカーの追加、または削除を行うには：

マーカーは「挿入」メニューの「マーカー」で追加されます。

下記のいずれかの方法で削除されます：

  • 「編集」→「マーカー」→「削除」とたどり、削除したいマーカーを選択します。

または

  • フレームバー上でマーカーのあるフレームを右クリックして、「マーカーの削除」を選択します。

マーカーに移動する方法とマーカーのリストを見る方法

「編集」→「マーカー」で表示されるメニューの先頭に、現在のムービーにあるマーカーのリストが表示されます。リストからそのひとつを選択すると、そのマーカーのあるフレームに直接ジャンプすることができます。

また、プレーヤーツールバーにある「ジャンプ」のドロップダウンリストからもマーカーのリストを見ることができます。

プレーヤー上でムービーを再生する際、「ムービー」メニューにある「次のマーカー」、「前のマーカー」を使用することでその前後にあるマーカーに行ったり来たりすることができます。


オートスクロールムービー

ムービーを録画した後、再生画面領域の一部だけをカットして再生したい場合があります。

ムービーの表示領域を狭めるには、BB FlashBack のクロッピング機能を使用します。ムービーはその領域内でマウスが常に表示されるように自動的にスクロールします。

ムービーをクロッピングするには：

  1. BB FlashBack プレーヤーでムービーを開き、クロッピングボタン [image] をクリックして、クロッピングを ON にします。
    または、「効果」のメニューから「クロッピング矩形を設定する」を選択します。

  2. クロッピングされる部分を表す青色の矩形が表示されます。必要に応じてサイズ調整と位置決めを行います。

クロッピングを OFF にするには、クロッピングボタン [image] をもう一度押します。

クロッピングされたムービーをプレビューするには:

  1. ツールバー上の「効果の適用」ボタンをクリックするか、または「効果」メニューの「効果の適用」を選択します。

    効果が適用されると、ムービーが出力されたときの状態と全く同じ状態で表示されます（出力時に適用される拡大・縮小機能や、他の効果を除きます）。


ビデオファイルの挿入

BB FlashBack はビデオファイルをスクリーン録画に挿入することができます。

備考：これを行うと、FBR のファイルサイズが膨大になります。

FlashBack ムービーにビデオファイルを挿入するには

  1. メインメニューから、「挿入」→「ビデオファイル」を選択します。

  2. ビデオファイルを選択します。

  3. BB FlashBack ムービーへのサイズ決めを選択します

  4. インとアウトのトランジションを設定します（トランジションの詳細はこちらです）

備考：一部のビデオファイルは BB FlashBack に挿入することができません。一般的に、Windows Media Player で正常に再生されるものであれば、BB FlashBack に挿入可能です。


一時停止

設定された時間の間、または次にマウスでクリックされるまでの間、再生を一時停止させる一時停止オブジェクトをムービーに追加することができます。一時停止オブジェクトは非表示です。ムービーが一時停止されている間は音声も停止します。

一時停止オブジェクトを追加するには：

  • 一時停止を追加したいフレームを選択します。

  • 「挿入」メニューから「一時停止」を選択します。

一時停止オブジェクトの設定を変更するには

設定ウィンドウを表示するには、フレームバーにある一時停止オブジェクトのアイコンをダブルクリックします。

テキストボックスや画像、その他のオブジェクトが表示されている間、一時停止させる

テキストボックスや画像、その他のムービー内のオブジェクトの「期間」の設定では、そのオブジェクトが表示されている間だけムービーを一時停止することができます。これは、ムービー内におけるオブジェクトとして、同じ長さのフレーム上に一時停止オブジェクトを生成します。一時停止の表示は、ムービーオブジェクトの「期間」設定を利用するか、またはフレームバーにある一時停止オブジェクトのアイコンをダブルクリックすることで、表示の長さを変更することができます。

備考： 同じフレームから始まるその他のオブジェクトは、表示期間を設定することはできません。一時停止オブジェクトにリンクされたオブジェクトと同じ期間が設定されます。

ムービーが一時停止されている間、「クリックして続ける」の画像を表示する

一時停止で「マウスクリックまで一時停止」のオプションを選択した場合は、「ムービーが一時停止されている間、一時停止の画像を表示する」を選択することができます。デフォルトの一時停止画像がムービーの左上コーナーに現われ、「一時停止：クリックして続ける」と表示されます。一時停止画像の見栄えや位置を変更したい場合は、下記のヘルプを参照してください。

一時停止画像を変更するには：

  1. プレーヤーのメインメニューから、「編集」→「一時停止画像」→「一時停止画像の設定」を選択します。

  2. ビットマップファイルを選択します。

ムービーが一時停止箇所に到達すると選択されたビットマップ画像が表示されます。

デフォルトの一時停止画像に戻したいときは、「編集」メニューから「一時停止画像」→「デフォルトの一時停止画像に戻す」を選択します。

一時停止画像の位置を変更するには：

  1. プレーヤーのメインメニューから、「編集」→「一時停止画像」→「一時停止画像の位置設定」を選択します。ムービー領域に一時停止画像が現われます。

  2. マウスカーソルを使用して一時停止画像の位置決めを行います。位置が決まったらそのまま次の編集操作を続行します。

ムービーが一時停止箇所に到達すると、一時停止画像が選択した位置に表示されます。


トランジッション

ビデオファイルや BB FlashBack ムービーを挿入したときはトランジションが自動的に追加されて、挿入されたムービーの始まりと終りの結合をスムーズにさせます。

トランジションは、その長さや途中での一時停止の可否などのタイプを指定することができます。トランジションの 3 つのタイプは：

  • 白へのフェード - たとえばフレームの 100 番にトランジションを追加したとすると、フレームの 99 番から白へのフェードが始まって、フレームの 100 番は白からのフェードが始まります。

  • 黒へのフェード - 同様に、99 番から黒へのフェードが始まり、100 番のフレームは黒からのフェードで始まります。

  • クロスフェード - このフェードはフレーム 99 番からフレーム 100 番にフェードします。

トランジションフレーム

トランジションが追加されると、フレムーバーの表示はこのようになります：

グレーのフレームはトランジションの一部ですので、通常のフレームのように編集することはできません。これらのフレーム上には注釈を挿入することができません。


ムービーの出力について

作成したムービーを FlashBack ユーザ以外の人に見てもらいたいときは、ムービーを外部出力する必要があります。BB FlashBack は次のようなフォーマットの出力に対応しています。

  • Flash
    Web ページへの埋め込みが最も簡単なフォーマットです。フル再生コントローラがあり、95 ％以上の PC や Mac でムービーの再生が可能なフォーマットです。
    Flash、および EXE は「クリックで続行」などのテキストボックスやボタンなどのインタラクティブな要素をサポートする唯一のフォーマットです。
    詳細は、「Flash への出力」を参照してください。

  • QuickTime (H264)
    QuickTime は品質とファイルサイズのバランスを最適化する先進の圧縮技術を使用します。QuickTime ムービーは Web ページに埋め込んでストリーミング配信することが可能です。
    QuickTime はすべての Mac で再生が可能ですが、PC では QuickTime か iTunes がインストールされていなければなりません。
    QuickTime フォーマットに出力するには、QuickTime 7 以降がインストールされている必要があります。
    詳細は、「QuickTime (H264) への出力」を参照してください。

  • Windows Media Video (WMV)
    QuickTime と同じく、このフォーマットも適切な品質とファイルサイズを自動生成します。そして、WMV ムービーも Web ページに埋め込むことが可能です。WMV ファイルは実質的にすべての PC 上で再生が可能ですが、一般的に Mac 上では再生できません。
    WMV フォーマットに出力するには、Windows Media Player 9 以降が必要です。
    詳細は、「Windows Media Video への出力」を参照してください。

  • MPEG4
    このフォーマットも高画質で小さなファイルサイズを生成します。ただし、QuickTime や WMV ほど圧縮率は高くありません。デフォルトでは、Windows Media Player では MPEG4 フォーマットのビデオを再生することができませんので、ビデオを多くの Windows PC に配布しようと考えている場合は、このフォーマットは良い選択肢ではないかもしれません。しかしながら、このフォーマットは Apple Mac OS X と iPhone、iPad、そしてビデオ再生可能な iPods でサポートされています。
    詳細は、MPEG4 への出力を参照してください。

  • AVI
    ムービーを上映するための非常に普及したフォーマットです。しかし、AVI への出力は詳しい知識を持たないユーザには使いづらい点があります。それは、出力時にムービーをエンコードするためのコーデックを選択しなければならないからです。画像の品質とファイルサイズは、どのコーデックを使用するかによって非常に変わってきます。再生 PC がエンコードで使用されたコーデックを備えていない場合は、AVI ファイルを再生することはできません。すべての Windows PC にそのコーデックがインストールされていなければならないという条件はあまりお勧めできません。詳細は、「AVI への出力」を参照してください。

  • GIF
    このフォーマットはアニメ動画ファイルで、Web ページへの配置が非常に容易です。ただし、低フレームレートで短時間の小規模アニメに適しています。Web ページに配置されると、あらゆるデバイスとブラウザから再生することが可能です。詳細は、「GIF への出力」を参照してください。

BB FlashBack ユーザ以外の BB FlashBack Express ユーザや BB TestAssistant ユーザに送りたい

BB FlashBack で作成されたムービーファイル（FBR ファイル）をそのままお送りください。そのままで再生されます。FlashBack ファイルは通常、他の形式のファイルよりサイズが縮小されています。

Web ページ上にムービーを表示させる

Flash、QuickTime、WMV フォーマットはすべて Web ページに埋め込むことができます。

Flash に関する詳細は、「Flash 出力を Web ページで再生する」を参照してください。

CD にムービーを取り込む

Flash、QuickTime、WMV、EXE フォーマットへの出力を試してみてください。どのフォーマットを使用すれば最も良い品質の画像で小さなファイルサイズを実現できるかは、ムービーの内容に依存します。ムービーが、動くビデオや多くの写真画像などを含んでいるような場合は、Flash、QuickTime、WMV フォーマットがファイルサイズを小さくできるかもしれません。


出力フォーマットの比較

フォーマットの簡易比較

 | AVI | WMV | QuickTime | EXE | Apple iDevices | GIF | Flash-SWF | Flash-FLV
品質 | コーデックに依存（詳細） | 高 | 高 | 無損失 | 高 | 低 | 無損失または JPG | 高
ファイルサイズ | コーデックに依存（詳細） | 良 | 良 | 録画内容に依存 | 良 | サイズ肥大の可能性 | 録画内容に依存 | 良
双方向要素の設置 |  |  |  | a |  |  | a | a
Web ページへの埋込み |  | a | a |  |  | a | a | a
広範囲な PC との互換性 | コーデックに依存（詳細） | a | サードパーティ製ソフトウェアが必要 | a | サードパーティ製ソフトウェアが必要 | a （Web ページ配置時） | a | a
MAC との互換性 | コーデックに依存（詳細） | サードパーティ製ソフトウェアが必要 | a |  | a | a （Web ページ配置時） | a | a

＊EXE 出力と Flash-SWF 出力のファイルサイズは、ムービーに動画やアニメーションが含まれていた場合、AVI、WMV、QuickTime、Flash-FLV に比べて非常に大きくなります。


Macromedia Flash 形式

Flash 形式に出力する

Flash は、ムービーやアニメーションを再生する場合に一般的に使用されるファイルフォーマットです。

Flash ムービーは、ほとんどの Web ブラウザ上で簡単に再生することができます。BB FlashBack がインストールされていない PC 環境や、Mac ユーザにムービーを配布したりする場合に使用すると便利です。

Flash 出力には、「クリックで続行」というようなテキストボックスやボタン等のインタラクティブ要素を含めることができます。

これらは Web ページに埋め込むことができ、再生コントローラを使用することができます。

ムービーを Flash 形式に出力するには：

プレーヤーのメインメニューから「ファイル」→「Flash への出力」を選択します。

またはファイルツールバーにある「出力」ボタンを押して Flash 形式を選択します。

詳細は、「Flash 出力オプション」を参照してください。

FLV と SWF フォーマット

BB FlashBack はムービーを SWF または Flash ビデオ （FLV） のいずれにも出力することができます。それぞれにはメリットとデメリットがあります。

詳細は、「Flash ビデオ （FLV） とスタンダード Flash （SWF） からの選択」を参照してください。

Flash 出力で生成されるファイル
選択されたオプションにより、BB FlashBack は Flash 出力時に異なる組み合わせのファイルを生成します。単一の SWF ファイルのときもあれば、複数の SWF ファイルと FLV ファイルのセットの場合もあります。

詳細は、「Flash 出力によって生成されるファイル」を参照してください。

Flash 出力の品質とファイルサイズ

ファイルサイズと品質のバランスを調整するには数々の方法があります。

詳細は、「Flash 出力の品質とファイルサイズを調整する」を参照してください。

Flash 再生コントローラのカスタマイズ

Flash 編集の知識があれば、オリジナルの再生コントローラを作成して、BB FlashBack からの出力ムービーにそれを適用させることができます。

詳細は、「Flash 再生コントローラのカスタマイズ」を参照してください。

Flash 出力の第三者利用を制限する

BB FlashBack は、Flash ムービーに対してサードパーティの Web サイトからのリンクや埋め込みを制限することができます。

詳細は、「Flash 出力のサードパーティ使用の制限」を参照してください。


Flash 出力オプション

「全般」タブ

  • 出力フレーム - ムービー全体か、あるいは出力するフレームセットを指定する場合にこれを使用します。出力前にフレームセットを選択しておくと、「選択フレーム」上にこのセットの範囲が表示されます。

  • フレームレート - 高いフレームレートほどムービーの動きはなめらかになります。ただし、一般的にファイルサイズは増加します。

  • スケーリング - Flash ムービーの縦横サイズを削減したい場合に設定します。

再生タブ

  • 再生開始 - ムービーが埋め込まれた Web ページがオープンされたときに、ムービーを自動的にダウンロードして再生が開始されるようにするか、あるいはクリックされるまでダウンロードを保留にするかどうかを決めることができます。

  • ムービーの終端 - ムービーの終端に到達したときに、先頭に戻って再生を再開させるかどうかを設定します。

  • プレビュー画像 - ムービーをダウンロードする前に、ムービーの最初のフレームの画像を表示させます。

    オプションとして、このプレビュー画像は「 _preview.swf 」というファイル名の独立した SWF ファイルに置くことができます。これにより、プレビュー画像のカスタマイズが容易になります。この設定は、「SWF ファイル生成」タブにあります。

  • 再生の一時停止 - ムービーがクリックされたときに、再生を一時停止させたり再開させたりすることができます。一時停止されたときは、ムービー上に「一時停止中」の画像が表示されます。

  • 事前ロード - BB FlashBack で出力され、Web ページ上に配置された Flash ムービーはエンドユーザにストリーム配信されます。これはムービーがユーザのパソコンに完全にダウンロードされる前に、ユーザの Web ブラウザ上では再生が開始されることを意味します。再生は、ムービーの再生に充分な量がダウンロードされた時点で開始され、ストリーミング配信はムービーの最後まで止まることなく継続されます。

    事前ロードの値を設定すると、このデフォルトの動作は無効となり、再生はムービー全体量の指定されたパーセントがダウンロードされた時点で開始されます。

「ビデオ品質」タブ

Flash ビデオ (FLV) または標準 Flash (SWF) を選択します。詳細は、「 Flash ビデオ (FLV) と標準 Flash (SWF) の選択の違い」を参照してください。

FLV を選択するか SWF を選択するかによって、出力時のファイルサイズと映像品質を調整するためのコントロールの表示が異なります。詳細は、「 Flash 出力時のサイズの削減」を参照してください。

「オーディオ」タブ

詳細は、「サウンド出力オプション」を参照してください。

再生コントローラタブ

視聴者への視聴体験を向上させるために、BB FlashBack には Flash 出力に際しての数々の機能を備えた再生コントローラが用意されています。この機能により、視聴者はメディアプレーヤーのようにムービーを一時停止したり、ボリュームを調整したり、ムービーの別の場所に移動したりすることができます。

BB FlashBack にあらかじめ用意された再生コントローラの中からいずれかを選択することができます。さらに、ツールバーにどのコントロールを表示させるかを決めることができます。

SWF のオーサリングツールがあり、Flash に関する知識があれば、ご自分で自前の再生コントローラを作成することもできます。詳細は、「 Flash 再生コントローラのカスタマイズ」を参照してください。

オートスクロールタブ

ムービーの大きさを小さくクロッピングし、再生中にマウスカーソルが自動的にムービーの中央に来るようにオートスクロールさせることができます。詳細は、「出力ムービーのオートスクロール」を参照してください。

「HTML テンプレート」タブ

Flash 出力時、BB FlashBack は Flash ムービーを見るための HTML ファイルを同時に作成します。HTML ファイルは Flash （SWF） ファイルと同じ名前で作成されます。

生成されるデフォルトの HTML ファイルを変更したい場合は、HTML テンプレートを用意することでこれを実現することができます。

詳細は、「 Flash 出力における HTML ファイルの使用法」を参照してください。

SWF ファイル生成タブ

SWF ファイルとして出力する場合、ムービー本体と再生コントロールを 1 つの SWF ファイルにまとめるか、または別々の SWF ファイルに分けるかを指定することができます。

1 つの SWF ファイルにまとめた場合、PDF ファイルなどのドキュメントへのムービーの埋め込みが容易になります。別々のファイルに分けた場合は、オンデマンド・ダウンロード方式の機能が使用できるようになり、Web ページ上でムービーがクリックされてからダウンロードを開始するという動作にすることができます。

詳細は、「Flash 出力によって生成されるファイル」を参照してください。

「その他」タブ

  • マウスカーソルの表示/非表示

  • 色形式 - 特定のムービーに対して減色を施し、これによりファイルサイズを減少させます。

  • 事前ロード - Flash ムービーデータのどこまでがダウンロードされたら再生を自動的に開始するかを設定します。デフォルトでは、現在のダウンロードレートを維持することにより、再生が最後まで処理可能であると判定されたときにムービーが開始されます。

「セキュリティ」タブ

BB FlashBack は Flash 出力の再生に有効期限を設けたり、あるいは再生にパスワードを掛けたりすることができます。これらのオプションは単一 SWF ファイルに出力したときのみ作用します。

さらに、出力された Flash ムービーを第 3 者の Web ページに埋め込むことを防止するオプションもあります。「Flash 出力の第 3 者利用を制限する」を参照してください。


Flash ビデオ (FLV) か、標準 Flash (SWF) かの選択

Flash 出力には2つのタイプが用意されています: Flash ビデオ (FLV) とスタンダード Flash (SWF) です。どちらが適しているかは出力するムービーに依存します。

Flash ビデオ (FLV) かスタンダード Flash (SWF) かの選択方法

Flash 出力のオプションウィンドウにある「ビデオ品質」のタブを選択し、「出力タイプ」を選択します。

FLV を使用するメリット:

  • 動画ビデオを扱うのに優れています。
    FLV は、ムービーに動画ビデオが含まれている場合に、SWF に比べてより小さなファイルサイズとなります。さらに、SWF ムービーのように、動くオブジェクトが移動したあとに、その「軌跡」が残るようなことがありません。

  • 長さに制限がありません。
    SWF では、1つのムービーが保持できるフレームの数に制限があります。ムービーがフレーム数の上限を超えている場合、BB FlashBack は SWF 出力時に自動的にフレームレートを削減します。FLV は長いムービーのような場合に便利です。

SWF を使用するメリット:

  • Web ページや PDF ドキュメント、あるいは他のドキュメントへの埋め込みが容易
    FLV フォーマットに出力すると、ムービー本体と再生コントローラ用の 2 つの異なるファイルが生成されます：_toolbar.swf および .flv （ は BB FlashBack でオープンされる .FBR ファイルの名前です）

    ムービーを PDF ファイルや Microsoft Office ドキュメントに埋め込む場合、あるいは Dreamweaver や類似の HTML エディタを使用してムービーを Web ページに埋め込む場合には、ムービーを 1 つの SWF ファイルにして出力する必要があります。BB FlashBack は、ムービー本体と再生コントローラをまとめて、単一の SWF ファイルにすることができます。

    詳細は、「Flash 出力で生成されるファイル」参照してください。

FLV ムービーの大きさ（面積）に関する制限事項

FLV ムービーの高さと幅は常に 16 の倍数となります。これは、ムービーがサイズ変更されたときに最適に再生されるための、FLV フォーマットの特質です。

これは、FLV が選択された場合は、出力される Flash ムービーは幅と高さを16の倍数にするために、左右、またはムービーの上下のどちらかに（再生コントロールをどちらに配置したかによって）パディングされる可能性があることを表しています。

パディングの色は、ムービーが埋め込まれた Web ページの配色に合わせて変更することができます。


Flash 出力サイズの削減

Flash 出力の画質とファイルサイズを調整する

BB FlashBack には Flash 出力時のファイルサイズや品質を調整するための数々のオプションが用意されています。

アクセス可能なビデオ品質のオプションは、Flash 出力オプションダイアログの「ビデオオ品質」タブで Flash Video (FLV) を選択したか、標準 Flash (SWF) を選択したかによって異なります。 詳細は、「 Flash Video (FLV) と標準 Flash (SWF) 選択の違い」を参照してください。

Flash ビデオ （FLV） 用のビデオ画質設定

  • FLV タイプ
    H263 は、より小さなファイルサイズを生成します。とくにムービーに動画が含まれている場合に効果を発揮します。
    「ScreenVideo」エンコーディングは、特にスクリーン映像の録画用に開発されています。H263 よりファイルサイズは大きくなりますが、画質は高くなります。

  • 画質
    高画質はより良い映像品質となりますが、ファイルサイズは増大します。

  • ビットレート
    高ビットレートは高画質を意味しますが、ファイルサイズは増大します。エンコーダは設定されたビットレートの画質を獲得するために機能しますが、画質がそのビットレートで得られるものより高い場合は、ビットレートをその画質に到達するまで増加させます。つまり、画質はビットレートより優先されます。

  • キーフレーム
    キーフレームが多ければ多いほど画質は高まりますが、ファイルサイズは増大します。

スタンダード Flash （SWF） 用のビデオ画質設定

  • 圧縮
    JPEG または無損失圧縮を選択します。

    • JPEG は通常、ファイルサイズが小さくなります。特に、ムービーに写真画像が含まれているときに有効です。しかしながら、動きのあるオブジェクトがあった場合には、JPEG 圧縮の特性により、これらがブロックノイズとなる場合があります。

    • 無損失は、無損失画質の画像が得られます。動きのあるオブジェクトがあってもノイズが発生することはありません。ただし、ファイルサイズは大きくなります。

  • 画質
    高画質の設定はより良い画像の品質を意味しますが、ファイルサイズは増大します。

  • 圧縮の最適化JPEG 圧縮におけるオプションです。これが選択されると、ムービー中のすべての画像を分析し、最適化技術を使用してムービー中の画像に対して高画質で無損失な圧縮を適用します。このオプションを OFF にすると、写真タイプの画像を多く含むムービーにおいてはファイルサイズが小さくなる場合があります。

フレームレート

高いフレームレートは通常、なめらかな動きを意味しますが、SWF ファイルと FLV ファイルはファイルサイズが増大します。

Flash 出力のオプションウィンドウにある「全般」タブで、フレームレートを変更します。

オーディオ設定

ムービーが音声を含んでいる場合、オーディオ設定を変更することで出力されるファイルサイズが大きく異なります。

Flash 出力のオプションウィンドウにある「オーディオ」タブを開き、オーディオオプションを設定します。

  • フォーマット
    カスタムフォーマットを選択した場合: より高い KHz の値は、より良い音質であることをを意味します。16 ビットは 8 ビットより良い音質となります。より良い音質は常にファイルサイズの増大を意味します。ステレオはモノよりファイルサイズが大きくなります。

  • MP3 圧縮
    BB FlashBack は、デフォルトではファイルサイズの削減のために MP3 圧縮を使用します。しかし、選択肢には多くの音質選択があります。例によって、音質が高ければ高いほどファイルサイズは大きくなります。

色濃度

写真画像などがほとんど入っていないファイルではムービー出力時に色数を制限することでファイルサイズを削減することができます。

出力ムービーの色濃度を変更するには：

  1. Flash出力オプションウィンドウの「その他」タブを開きます。

  2. 「色濃度」ドロップダウンリストから色濃度を選択し、ムービーを出力します。そしてファイルサイズが削減されたか確認します。


Flash 再生コントローラをカスタマイズする

BB FlashBack にはあらかじめ 3 種類の異なる再生コントローラがインストールされています。これらとは異なる見映えにしたり、機能の追加を行いたいような場合は、Flash の編集技術があれば、Flash 出力オプションの「再生コントロール」タブで、既存の再生コントローラの代わりにオリジナルの SWF ファイルを使用することができます。

BB FlashBack をインストールすると、インストール先の SWFControlBars フォルダに .FLA ソースファイル、.AS ActionScript ファイル、.FLP プロジェクトファイルの 3 つの再生コントロール用テンプレートがインストールされます。これらのファイルを修正して、必要なカスタマイズを行うことができます。

3 つのテンプレートのそれぞれに、3 つの FLA と SWF ファイルが用意されています。

例）メタリック用のテンプレート：

  • DefaultControlBar.fla / .swf - 複合 SWF 出力 （ツールバーとムービーが別々の SWF ファイル）、または FLV 出力用です。ActionScript 2 を使用します。

  • DefaultControlBarSingle.fla / .swf - 単一 SWF 出力 （再生コントロールとムービーが同一の SWF） 用です。ActionScript 2 を使用します。

  • DefaultControlBar3.fla / .swf - FLV 出力用で、ムービーがテキストボックスの「クリックして続行」等の双方向オブジェクトを含んでいる場合に使用します。ActionScript 3 を使用します。


Flash 出力がどのように HTML ファイルを使用するか

BB FlashBack が Flash への出力を行うと、Flash ムービーを埋め込んで再生するための HTML ファイルが生成されます。この HTML ファイルはムービーを Web ページに埋め込み方法を解説しています。この HTML ファイルは SWF ファイルと同じ名前になっています。

デフォルト HTML を変更する

デフォルトの HTML ファイルは非常にシンプルです。白い背景にムービーを表示しているだけです。そこで、このページに会社のロゴを表示させたり、ムービーの解説を加えたりしたいと思うかもしれません。その場合は自動出力された HTML ファイルを編集することができます。しかし何度も同じ修正を加えた HTML で出力するのであれば、新しい「テンプレート」を作成したほうが簡単な場合があります。

新規に HTML テンプレートを追加するには：

  1. Flash 出力オプションダイアログにある「HTML テンプレート」タブを開きます。

  2. 「新規」ボタンを押して、新しいテンプレートの名前を入力します。

  3. 「編集」ボタンを押して、HTML を編集モードにします。または「選択」ボタンを押して、あらかじめ用意してある HTML ファイルを選択します。

  4. HTML はダイアログ上で編集することができます。出力される HTML 上で、 タグが Flash ムービーを表示するコードで置き換えられます。

  5. HTML の編集をし終えたら、「保存」を押します。

「HTML テンプレート」タブにある「テンプレート名」のコンボボックスを経由して、新しいテンプレートを選択することができます。この HTML が出力時に使用されることになります。

「Flash 出力を Web ページに表示する」も参照してください。


Flash ムービーを Web ページに埋め込む

Flash 出力によって生成されたファイル

BB FlashBack は、SWF が選択されているか FLV が選択されているかによって異なるファイルを生成します。また、SWF に関してはオンデマンドダウンロードが設定されているか、あるいは PDF や他のドキュメントへの埋め込み設定がなされているかによっても異なるファイルを生成します。

ムービーを PDF ファイルや Microsoft Office ドキュメントに埋め込む場合、あるいは Dreamweaver や類似の HTML エディタを使用して Web ページに埋め込んだときに問題が生じた場合などに、ムービーをひとつの SWF ファイルにして出力する必要が生じる場合があります。詳細は下記を参照してください。

ムービーが埋め込まれた HTML ファイルは、選択されたフォーマットや他の設定に関わらず、常に生成されます。

FLV フォーマット

生成ファイル：

  • .html - Web ページにムービーを埋め込んで表示させる方法を提示します。

  • .flv - ムービー

  • _toolbar.swf - 再生用コントローラです。Web ページや他のドキュメントに埋め込んで、再生コントローラを表示させるためのファイルです。FLV ファイルをロードします。

SWF フォーマット

2つのオプションがあります。

  1. 単一の SWF には再生コントローラとムービー本体が含まれています。

    これはムービーを PDF ファイルや Microsoft Office ドキュメントなどに単独で埋め込むことができます。Dreamweaver などの HTML エディタを使用している場合にも、Web ページに容易に埋め込むことが可能となります。

  2. 再生コントローラとムービーが別々の SWF ファイルに保存された、複数の SWF ファイルです。

    この方式を使用するメリットは、ムービーをオンデマンドでダウンロードすることができるようになることです。Web ページやドキュメント上ではまずプレビュー画像と再生アイコンだけが表示され、それがクリックされた時点で初めてムービー全体がダウンロードされます。単一の SWF を選択した場合は、Web ページがロードされる時点でムービー全体もロードされます。

Flash 出力のオプションウィンドウにある「SWF ファイルの生成」タブで、単一 SWF ファイルに出力するか、複数からなる SWF ファイルに出力するかを選択することができます。

「単一 SWF」が選択されたときのファイル：

  • .html - Web ページにムービーを埋め込んで表示させる方法を提示します。

  • .swf - 再生コントローラとムービー本体が含まれます。

「複数 SWF」が選択されたときのファイル：

  • .html - Web ページにムービーを埋め込んで表示させる方法を提示します。

  • .swf - ムービー

  • _toolbar.swf - 再生コントローラです。ムービーを表示するために、Web ページや他のドキュメント内に埋め込むファイルです。.swf ファイルをロードします。

    そして、オプションとして

  • _preview.swf - 再生タブで、「クリックされるまでムービーをダウンロードしない」のオプションが選択され、プレビュー画像が選択されており、「SWF ファイル生成」タブの「プレビュー画像に別の SWF ファイルを使用する」が選択されているときに生成されます。そうでない場合は、プレビュー画像は _toolbar.swf ファイルに含まれます。


Flash プレーヤーのバージョン互換性

  • FLV に出力する場合は、ムービーの再生時に Flash プレーヤー V7 以降が必要となります。

  • SWF に出力する場合は、Flash プレーヤー V6 以降が必要となります。


Web ページで Flash 出力を表示する

BB FlashBack でムービーを Flash 形式に出力すると、ムービーが埋め込まれた Web ページファイル（HTML ファイル）が生成されます。

わずか数ステップでムービーを Web ページに埋め込むことができます。出力されたファイルをコピーして Web サーバにアップロードし、ムービーが保存されている SWF ファイルを参照している HTML コードを Web ページに追加します。

BB FlashBack は、ムービーの出力時に埋め込み用の HTML コードを自動生成します。

例：

mymovie.fbr を FLV 出力ではなく SWF への出力を選択して Flash へ出力したとします。すると 2 つのファイルが生成されます。

  • mymovie.html

  • mymovie.swf

mymovie.html を開きます。ムービーの下に、ムービーを Web ページに埋め込む方法の解説があります。入力フィールドにあるコードをクリップボードにコピーし、ムービーを表示させたい Web ページに貼り付けます。

Web ページと、出力されたすべての SWF およびアップロードされた FLV ファイルが同じフォルダにあれば、コードが機能してムービーが上映されます。

Web ページとアップロードされたファイルが異なるフォルダにある場合は、コードを変更してファイルの参照先を変える必要があります。Web ページにコピーしたコードを開きます。2箇所で .swf ファイル （mymovie.swf または mymovie_toolbar.swf） を参照しています。それぞれにおいて、toolbar.swf ファイルへの正しいフォルダパスを追加します。

詳細は、「Flash 出力で生成されるファイル」も参照してください。


ムービーとツールバーファイルを異なるフォルダに保存する

ムービーとツールバーを2つの異なるファイルとして出力した場合、ツールバーの保存されているフォルダとは異なるフォルダにムービーを保存することができます。これを行うには、「SWF ファイルの生成」のタブを開き、「ムービーファイルへのパス指定」という欄にチェックを入れます。そして、「ムービーファイルへの URL」の欄にムービーファイルへのパスを入力します（相対パスでも URL でもどちらでもかまいません）。

ムービーを上記のように出力せず、あとになって異なる位置に配置したいような場合は Flashvars を使用することができます。その場合、出力された HTML コードに fileName パラメータを追加する必要があります。


コントロールテキスト（および他のムービー設定）を HTML または Flashvars 経由で変更する

Flash ムービーを埋め込んだ HTML 上において、Flashvars を指定することにより、再生コントロール上のすべてのテキスト文字を上書きすることができます。この方法により、多くの出力設定を上書きすることが可能です。

Flashvars 使用法の詳細については、 http://kb2.adobe.com/cps/164/tn_16417.html を参照してください。

サポートする Flashvars

  • str1 (文字型) - 「 FlashBack ロゴ 」のドロップダウンメニューの最初の項目のテキストを表すエスケープ文字列を指定します。例: BB%20FlashBack%20により作成

  • str2 (文字型) - 「 FlashBack ロゴ 」のドロップダウンメニューの中の、BB FlashBack のホームページを開くテキストのエスケープ文字列を指定します。例: www.bbflashback.com%20にジャンプ

  • str3 (文字型) - 「 ツールバーの非表示 」のトグルコントロールの右側に表示されるテキストを表すエスケープ文字列を指定します。例: "非表示"

  • str4 (文字型) - 「 FlashBack ロゴ 」のドロップダウンのリンクをクリックして表示される URL を指定します。

  • str5 (文字型) - Flash プレーヤーのバージョンが古くて、ムービーを再生することができない場合に表示されるテキストを指定します。デフォルトでは、「Flash プレーヤーの V9 以降が必要です。バージョンアップはこちらです：」となります。

  • showToolbar ('true' または 'false') - ツールバーの表示・非表示を切り替えます。

  • topToolbar ('true' または 'false') - ツールバーの位置を切り替えます。false で下、true で上への配置となります。

  • showFullScreen ('true' または 'false') - フルスクリーンボタンの表示・非表示を切り替えます。

  • notScaleInFullScreen ('true' または 'false') - フルスクリーン時にムービーを拡大・縮小するかどうかを設定します。

  • autoHide ('true' または 'false') - true にすると、ツールバーは自動的に非表示になります。

  • showAutoHide ('true' または 'false') - 非表示ボタンの表示を切り替えます。

  • showTimer ('true' または 'false') - 上映時間と経過時間の表示・非表示を切り替えます。

  • showTimeline ('true' または 'false') - タイムラインの表示・非表示を切り替えます。

  • showNextButton ('true' または 'false') - 「次のフレーム」ボタンの表示・非表示を切り替えます。このパラメータは FLV ムービーの場合は無視されます。

  • showPrevButton ('true' または 'false') - 「前のフレーム」ボタンの表示・非表示を切り替えます。このパラメータは FLV ムービーの場合は無視されます。

  • showFBLogo ('true' または 'false') - BB FlashBack ロゴボタンの表示・非表示を切り替えます。ロゴボタンは BB FlashBack Web サイトへのリンクを持つドロップダウンメニューを表示します。

  • showVolumeBar ('true' または 'false') - ボリュームボタンの表示・非表示を切り替えます。

  • fileName (文字型) - 画面に表示され、ツールバー SWF から制御されるムービーのファイル名を指定します。例： test.swf または test.flv

  • showPausedOverlay ('true' または 'false') - ムービーが一時停止されたときに、一時停止画像を表示させる設定になっているかどうかを示します。

  • pauseByClickingOnMovie ('true' または 'false') - ムービーをクリックしたときに一時停止・再開を行わせるかどうかを示します。

  • startingPlaybackMode (整数型) - ユーザによって選択されている再生モードを示します。値:

    • 0: 「再生ボタン」がクリックされた時のみ、ムービーをダウンロードして再生する

    • 1: 自動的にムービーをダウンロードするが、クリックされるまでは再生しない

    • 2: ムービーを自動的にダウンロードして再生する

  • preloadPercent (整数型, 0-100) - 再生開始前にロードされるムービーの比率を指定します。デフォルトの 0 は、再生が自動で始まることを表します。- ムービー全体の長さのうち、ロード済みの長さが、指定した比率に達するとムービーがスタートします。そして、中断することなく、更なるダウンロードを継続します。

  • previewFilename (文字型) - NULL でない場合、ムービーがダウンロードされて再生が開始される前にロードされる、プレビュー画像の SWF の名前になります。

  • previewMode (整数型) - プレビュー画面の表示方法を示します。値:

    • 0: プレビュー画像なし

    • 1: プレビュー画像を外部 SWF ファイルからロードする。ファイル名は previewFileName パラメータから渡されます。

  • scaleMode - フルスクリーンモードのときに、ムービーの拡大・縮小を行わせたくない場合は、この値を 'noscale' にします。

  • dimPreview ('true' または 'false') - プレビューを薄く表示したい場合は、'true' に設定します。デフォルトは 'false' です。

ムービー上の特定のフレームにジャンプするための URL パラメータを使用する（他の設定も変更する）

HTML 内で Flashvars を指定する代わりに、URL 上で上記のパラメータを直接、渡すことも可能です。例： http://mydomain.com/path/movie.html?startingPlaybackMode=0

備考： URL パラメータの値は、同じ名称の Flashvars が存在した場合にその値を上書きします。

なお、このように設定を変更する際、startFrame パラメータを使用することができます。このパラメータは再生を開始させたい特定のフレームを指定します。この機能はすべての再生モードに対応しています。たとえば、ムービーを 70 番フレームから開始させたい場合は、次のように URL を記述します： http://mydomain.com/path/movie.html?startingPlaybackMode=0&startFrame=70


セキュリティで保護されたドメインとコードを使用する

Flash 出力の第三者利用を制限する

Flash ムービーをインターネット上の Web サイトに配置した場合、第三者はあなたの同意なく、勝手にその Flash ムービーを第三者の Web サイトに埋め込むことが可能となってしまいます。

これらを防止する目的で、出力された Flash ファイルが第三者ドメインや他の Web ページ、あるいは他の Flash ファイルからどのように再生できるかを制限するためのセキュアドメインとセキュアコードの設定を利用することができます。設定箇所は、Flash 出力オプションダイアログの「その他」のタブにあります。

セキュアドメインのリスト

セキュアドメインリストは、（ SWF ファイル自身の属するドメインに加えて）どのドメインが、出力ムービーの埋め込まれた Flash ムービーをホストしうるかを決定します。HTML ファイルがムービーをどのように表示するかには影響はありません。

セキュアドメインリストが空であれば、出力ファイルは SWF の置かれたドメインでのみロードされて再生されます。

セキュアコード

セキュアコードはさらに、再生前にムービーオブジェクトに渡されるパラメータを要求することによって、Flash 出力がサードパーティの SWF や HTML ファイルによってどのように再生されるかを制限します。

たとえば、セキュアコード「 123 」を設定してムービーを出力した場合、これを再生するには以下の 2 つのうちどちらかを実行する必要があります:

  • ムービーが他の SWF ファイルから再生される場合、フォームのアクションスクリプトが必要となります:
    exportedmovie.VerifySecurityCode("123")
    exportedmovie.play()

  • ムービーを HTML に埋め込む場合、次のように「 specialcode 」というパラメータをセキュアコードとして渡す必要があります:

    ...

    または


Flash プレーヤーセキュリティ警告

Flash 出力を再生させようとしてローカルのハードディスク上でファイルをオープンし、Web ページをオープンするようなムービーの機能（Open URL アクションを使ったボタンや、再生コントロールの BB FlashBack のロゴボタンの下にあるメニュー項目など）を使用すると、「Adobe Flash プレーヤーセキュリティ」という警告メッセージが表示される場合があります。

この場合 Flash は、ローカルドライブにある SWF を、リモート Web ページにアクセスさせるセキュリティリスクとみなしてこの警告メッセージを発します。

SWF が Web サーバ上にある場合はこのセキュリティ警告は表示されません。したがって、この問題は Flash がローカルハードドライブから再生されようとする場合にのみ発生する問題であるといえます。

この警告を回避するには、SWF が実行されるフォルダを「信頼されたフォルダ」のリストに追加します。埋め込まれた Flash プレーヤーを右クリックして「グローバル設定」を選択し、グローバルセキュリティ設定を変更することでこれを行います。そのフォルダを、「このロケーションにあるファイルを常に信頼する」のリストに追加します。


QuickTime (H264) へ出力

BB FlashBack はムービーを Apple の QuickTime フォーマットに出力することができます。このフォーマットは、すべての Apple Mac と、QuickTime プレーヤーがインストールされた PC（多くの PC にインストールされていますが、企業ユーザの PC にはインストールされていないケースもあります）上で再生可能です。

QuickTime 出力で使用される H264 エンコーディングは、特にインターネット上でのストリーミング配信に適しています。しかし、ムービーの再生前にすべてをダウンロードしなければならないような他のメディア経由で配信する場合でも、QuickTime は優れた能力を発揮します。

備考: QuickTime への出力を行うには、QuickTime 7 以降がインストールされている必要があります。

技術情報: BB FlashBack から出力される QuickTime ファイルは、H264 ビデオエンコーディングと MP4 コンテナフォーマットを使用します。

QuickTime フォーマットに出力するには:

  1. プレーヤーのメインメニューで、ファイルメニューにある「QuickTime への出力」を選択します。
    または
    ファイルツールバーにある出力ボタンをクリックし、QuickTime フォーマットを選択します。

  2. 出力オプションを設定します。詳細は下記を参照してください。

  3. 出力ファイルに名前を付け、「保存」をクリックして出力ファイルを作成します。

QuickTime ビデオの品質とファイルサイズを設定する

ビデオの品質を調整する方法は数々あります。ビデオの品質が良くなれば、一般的にファイルサイズは大きくなります。

  • フレームレート
    フレームレートが高くなれば動きは滑らかになりますが、ファイルサイズは大きくなります。
    QuickTime 出力オプションウィンドウにある「フレームレート」タブでフレームレートを設定します。

  • キーフレームレート
    キーフレームが増えれば画質は向上しますが、ファイルサイズは大きくなります。
    QuickTime 出力オプションウィンドウにある「フレームレート」タブでキーフレームレートを設定します。

  • 画質
    値を大きくすれば損失の無い高画質のビデオ映像が得られますが、ファイルサイズは増大します。
    QuickTime 出力オプションウィンドウの「ビデオ品質」タブにある「画質」を設定します。

  • シングル / マルチパス
    マルチパスのエンコーディングを使用すると、より高品質な結果が得られますが、処理時間は増大します。
    QuickTime 出力オプションウィンドウにある「ビデオ品質」タブでシングルまたはマルチパスのエンコーディングを選択します。

  • データレート
    データレート（ビットレート）が高いほど、画質は良くなりますが、ファイルサイズは増大します。データレートはムービーがどのような環境で再生されるかを考慮する必要があります。ムービーがインターネット経由でストリーミング配信されるような場合は、CD やハーディスクから再生される場合より、通常、値を低くします。

    最適なデータレートを決定するには、試行錯誤が必要です。「自動」の設定にして、ムービーの大きさや画質設定などからシステムに最適なレートを設定させる方法もあります。

    QuickTime 出力オプションウィンドウにある「ビデオ品質」タブでデータレートを設定します。


Web ページ上での QuickTime ムービーの再生

QuickTime ムービーは Web ページに埋め込んで再生させることができます。出力されたムービーファイルを Web サーバにコピーして、そのファイルを参照するために Web ページの HTML を編集する必要があります。

簡易チュートリアル:

http://www.oreillynet.com/pub/a/javascript/excerpt/learnwebdesign_chap22/

QuickTime ムービープレーヤーオブジェクトによって受け入れられるパラメータと、Internet Explorer 上で正しくムービーを表示させるために知っておくべき事がら:

http://www.apple.com/quicktime/tutorials/embed.html


Windows Media Video（WMV）への出力

BB FlashBack は Windows Media Video (WMV) 形式に出力することができます。この形式は一般的に AVI 出力よりも小さいファイルサイズで良い品質を得ることができ、Windows パソコンの大多数で再生することができます。WMV ファイルは、MAC ではサードパーティ製のソフトウェアがインストールされている場合のみ再生されます。

備考： WMV への出力は Windows Media Player V9 (またはそれ以上) がインストールされている必要があります。

WMV 形式に出力するには：

  1. プレーヤーのメインメニューから「ファイル」→「WMV へ出力」を選択します。
    または
    ファイルツールバーの「出力」ボタンを押して、「WMV 形式」を選択します。

  2. 出力オプションを設定します。詳細は下記を参照してください。

  3. WMV ファイルの名前を付け、「保存」を押して出力ファイルを作成します。

WMV 出力オプション

「全般」タブ

  • フレーム出力：フレームの範囲を選択している場合、BB FlashBack はデフォルトでこれらのフレームの範囲のみを出力します。範囲の指定がない場合は、ムービー全体が出力の対象となります。

  • スケール：100 ％より小さい値を選択して、ムービーの縦横サイズを縮小します。

「ビデオ」タブ

  • フレームレート： フレームレートが高ければ高いほど、ムービーはなめらかな動きになります。ただし、フレームレートが高くなると、ムービーのファイルサイズは大きくなります。

「ビデオ品質」タブ

  • コーデック：ほとんどの Windows パソコンは、Windows Media Video のシリーズ 9 コーデックでエンコードされたムービーを再生することができるようになっています。ただし、旧バージョンの Windows Media Player を搭載したパソコンでは問題が起きる場合があります。その理由から、このコントロール上で旧式の WMV コーデックも選択できるようになっています。詳細は、「WMV コーデックの互換性」を参照してください。
    Windows Media Video 9 スクリーンコーデックは、特に画面キャプチャされたムービーをエンコーディングする目的で Microsoft によって開発されました。これを利用すると最小ののファイルサイズが得られます。ただし、画質は Windows Media Video 9 より低下します。

  • 画質： これは最終ビデオ出力の画質を決定する 0 から 100 までの数値です。大きな値ほど画質が良くなり、ファイルサイズは増大します。

  • パス： 2 パスの選択は通常、画質は良くなりますが、出力に時間がかかります。

  • 可変ビットレート： インターネット上でストリーミング配信されるWMVファイルを出力する場合や、旧式のパソコン・デバイスをターゲットとした場合は、このボックスのチェックを外して固定ビットレートでエンコードしたほうが良い場合があります。通常、可変ビットレートのほうが高い画質が得られます。

  • ビットレート： ビットレートはムービーの画質を決定します。ビットレートが高いほど、良い画質が得られます。インターネット上でストリーミング配信されるファイルの出力をコントロールする場合に役立ちます。

備考： 可変ビットレートのチェックを外して出力している（固定ビットレートで出力している）場合、再生映像が途切れがちだったり、ビデオが滑らかでなくギクシャクしていたら、ビットレートを上げたり画質を落としたり、または両方を試してみてください。

「オーディオ」タブ

  • コーデック： ビデオオプションのように、Windows Media Audio のシリーズ 9 コーデックも最良の出力が得られるようになっています。旧式のコーデックは、旧バージョンの Windows Media Player を搭載したパソコン上でムービーを再生して、問題が発生した場合に利用されます。詳細は、「WMV コーデックの旧型 PC との互換性」を参照してください。

  • 形式： サウンド形式はサンプリングレートとモノ / ステレオ選択との組み合わせで決まります。サンプリングレートが高ければ高いほど音質は良くなりますが、出力ムービーファイルのサイズは大きくなります。ステレオではなくモノを選択するとムービーサイズは削減されますが、チャンネルは 2つではなく 1つになります。

  • パス： ビデオの設定のように、2 パスは通常、良い音質が得られますが、出力に時間がかかります。

  • 可変ビットレート： ビデオの設定のように、可変ビットレートはおおかたのケースにおいてより良い音質が得られますが、旧バージョンのWindows Media Player との互換性は、固定ビットレートのエンコーディングの場合より低くなります。

  • ビットレート/音質： 値が大きいほど音質は良くなりますが、出力ムービーファイルは大きくなります。

オートスクロールタブ

ムービーは小さなサイズに切り取られ、再生中はマウスカーソルが常にムービーの枠内に収まるよう自動的にスクロールします。詳細は、「出力ムービーのオートスクロール」を参照してください。

「その他」タブ

  • 「未登録製品にて作成」のメッセージを追加： このオプションを選択すると、ムービーの右上コーナーにムービーが BB FlashBack の未登録製品にて出力されたことを示すビットマップが追加されます。


WMVコーデック互換

旧型 PC における WMV の互換性

Windows Media シリーズ 9 コーデックでエンコードされたビデオとオーディオはほとんどの Windows パソコンで再生されます。一部の旧型パソコンでは Windows Media Player のバージョンによっては問題が発生することがあります。

デフォルトではWindows 2000にはWindows Media Player6.4がインストールされています。Windows MEにはバージョン7が、Windows XPにはバージョン8がインストールされています。

コーデック： | 動作
Windows Media Video 9 | Windows Media Player 6.4以降で再生されます。 しかしながら、このバージョンのプレーヤーではコーデックはデフォルトではインストールされていません。 - インターネットを検索して自動でダウンロードを試みます。
Windows Media Video 9 Screen | Windows Media Player 7以降で再生されます。Windows Media Player 6.4では再生されません。 Windows Media Player 7以降ではコーデックは自動でダウンロードされます。Windows Media Player 6.4はコーデックを検索しません。
Windows Media Audio 9 | 固定ビットレート：Windows Media Player 6.4以降で再生されます。 可変ビットレート：Windows Media Player 7以降で再生されます。Windows Media Player 6.4ではエラーになるか無音になります。
Windows Media Audio 9 Professional | Windows Media Player 7以降で再生されます。 Windows Media Player 7以降ではコーデックは自動でダウンロードされます。Windows Media Player 6.4はコーデックを検索しません。


AVI 形式

AVI 形式で出力する

AVI ファイルはムービーやアニメーションの再生に使用される一般的なフォーマットです。しかし、AVI フォーマットで出力されたファイルは、通常、Flash や QuickTime、EXE、WMV フォーマットなどで出力されたムービーよりファイルサイズが大きくなります。

コーデック

ムービーを AVI 形式で出力するにはコーデックの選択が必要となります。コーデックとは AVI ファイルの圧縮と再生に使用されるソフトウェアです。

AVI 出力に使用されるコーデックは、ファイルサイズと映像品質を決めるうえで大きな影響力を持っています。最良のコーデックを選択するには、技術的な知識と試行錯誤が必要とされます。一方、Flash や QuickTime、WMV、EXE ファイルなどへの出力の場合は単純なオプションとなります。

コーデックとコーデックの選択法についての詳細は、「AVI コーデックについて」を参照してください。

出力に要する時間、および最終ファイルサイズの大きさは次の4項目に大きく依存します：

  1. ムービーの長さと煩雑さ

  2. 使用されるコーデック

  3. サウンド形式と圧縮の可否（サウンドを含んでいる場合）

  4. ムービーのフレームレート（フレームレートが高いほどムービーはスムーズになりますが、出力されるファイルサイズは大きくなります）

AVI 形式でムービーを出力するには：

  1. プレーヤーのメインメニューから「ファイル」→「AVI へ出力」を選択します。
    または
    ファイルツールバーにある「出力」ボタンを押して AVI 形式を選択します。

  2. 圧縮に使用するコーデックを選択します。詳細情報については、「AVI コーデックについて」を参照してください。

  3. 必要に応じて、出力したいムービーの表示サイズを変更します。AVI ムービーファイルは、ここで設定する幅と高さで縮小または拡大されて出力されます。

  4. 出力ファイル用のフレームレートを選択します。フレームレートが高ければ高いほど再生はなめらかになりますが、出力ファイルのサイズは大きくなります。BB FlashBack は最も滑らかで最も大きなファイルサイズとなるフルフレームレートの選択オプションと、フレームレートを 1/2 または 1/4 に削減し、滑らかさを犠牲にしてファイルサイズを小さくする選択オプションなどを用意しています。

  5. 必要に応じて、ムービーの縦横サイズを小さくする「スケール」の値を設定します。

  6. 必要に応じて、サウンド出力オプションを変更します。詳細は、「サウンド出力オプション」を参照してください。

  7. 「出力」をクリックします。

  8. 新規 AVI ムービーのファイル名を決め、「保存」を押してムービーをその名前で保存します。


コーデックについて

AVI コーデックについて

コーデックとは AVI ムービーファイルを生成して再生するために使用されるソフトウェアのことです。BB FlashBack ムービーファイルを AVI フォーマットに出力するにはコーデックを選択する必要があります。

出力される AVI ファイルのファイルサイズと画質は、エンコード時に使用されるコーデックに大きく依存します。

AVI 出力において満足な結果が得られないような場合は、使用しているコーデックに問題がある場合があります。

コーデックの選択は一般的に複雑ですので、ムービーの共有のことを考えた場合は、むしろ Flash や Windows Medis Video （Standard 版と Pro 版のみ）、QuickTime （Standard 版と Pro 版のみ） などの他のフォーマットを選択したほうがベターな場合があります。

良いコーデックをみつけるには

Windows に標準でインストールされているコーデックは、ファイルサイズと画質のバランスにおいてベストであるとは言えません。より良い出力結果が得られるフリーのコーデックに、XVid があります。これは、http://www.xvid.org/Downloads.15.0.html からダウンロード可能で、これをインストールすれば BB FlashBack ムービーの出力時にこのコーデックを選択することができるようになります。また、DivX codec （www.divx.com） もお勧めです。

ただし、Windows Media Player でこれを再生する場合は、その PC にも同じコーデックがインストールされている必要があることに注意しなければなりません。

Windows のデフォルトコーデック

Windows にはデフォルトでいくつかのコーデックがインストールされています： Intel、フルフレーム、Cinepak、Microsoft Video 1 です。この中のいずれかを選択しておけば、その AVI はほとんどの Windows PC 上で問題なく再生されるはずです。

Intel YUV とフルフレームは高い画質を生成しますが、ファイルサイズが非常に大きくなります。

Microsoft Video 1 と Cinepak では、Video 1 のほうが画質は良くなりますが、ファイルサイズは Cinepak より大きくなります。


MPEG4 への出力

MPEG4 フォーマットは、出力したビデオを Apple 製のデバイスに配布する場合に特に便利です。このフォーマットでの出力は、iPad や、iPhone、ビデオ再生可能な iPods で再生される場合にこれ以上の変換が不要となります。

MPEG4 フォーマットは、Windows PC ではあまり広くサポートされていません。それは、Windows Media Player（ほとんどの PC のデフォルトビデオプレーヤー）が、デフォルトでは MPEG4 の再生をサポートしていないからです。再生を行うにはサードパーティ製のコーデックが必要です。

テクニカルノート： BB FlashBack の MPEG4 出力は MP4 コンテナ上で、ビデオ映像に MPEG4-ASP （シンプルプロファイルのレベル 1）のエンコーディングを使用し、オーディオには AAC を使用しています。

Apple デバイスへの出力の最適化

BB FlashBack は Apple デバイス （iPad、iPhone、iPod） への出力の縦横サイズを最適化できます。MPEG4 出力のオプションウィンドウにある「デバイスへの最適化」でデバイスのカテゴリを選択することによって、縦横サイズが自動的に設定されます。

推奨された縦横サイズより大きい、または小さいものを出力した場合、ビデオファイルは Apple デバイス上で一応、うまく再生はされますが、ディスプレイのサイズに応じて自動調整されることになります。通常は、ディスプレイサイズより大きいサイズで出力しても何も得るものはなく、単にファイルサイズが大きくなるだけです。逆にディスプレイサイズより小さいサイズで出力した場合は、画質が落ちる原因となります。「デバイスへの最適化」の設定を使用することにより、不必要な大きさを生成しない、または出力ファイルの画質を落とさないという設定にもなります。

ムービーを MPEG4 フォーマットに出力するには：

  1. プレーヤーのメインメニューで、「ファイル」→「MPEG4 への出力」を選択します。
    またはフファイルールバーにある「出出力ボタンをクリックし、MPEG4 フォーマットを選択します。

  2. 表示されるダイアログ上で、ビデオとオーディオの品質のオプションを設定します。

  3. OK をクリックして、ムービーを .mp4 ファイルに保存します


GIF への出力

BB FlashBack は GIF フォーマットに出力することができます。GIF ファイルは Web ページへの埋め込みが簡単ですが、低フレームレートの短時間で小さなアニメのみに適しています。

ブラウザによっても動作が異なるのでフレームレートや画面の大きさ等の制限の定義は難しいですが、GIF フォーマットに出力した際にファイルサイズが肥大化してパフォーマンスが落ちていないか留意する必要があります。

GIF フォーマットに出力する方法

  1. プレーヤーのメインメニューから「ファイル」→「GIF への出力」を選択するか、
    または
    ファイルツールバー上の「出力」ボタンをクリックして、「GIF フォーマット」を選択します。

  2. 表示されるダイアログ上で、ビデオとオーディオの品質のオプションを設定します。

  3. 備考：GIF をループ再生させるには、「一般」タブの「ループ再生」の設定を使用します。

  4. OK ボタンを押してムービーを .GIF ファイルに保存します。


サウンド出力オプション

ムービーにサウンドが含まれている場合は、出力されるムービーファイルにもサウンドが含まれます。

オーディオ出力オプションは出力ファイルのサイズとサウンドの品質を決定します：

  • 形式： サウンド形式はサンプリングレートとモノ / ステレオ選択との組み合わせで決まります。サンプリングレートが高ければ高いほど音質は良くなりますが、出力ムービーファイルのサイズは大きくなります。ステレオではなくモノを選択するとムービーサイズは削減されますが、チャンネルは 2つではなく 1つになります。

  • MP3 圧縮：このオプションは、サウンドのある出力ムービーのサイズを大きく削減します。BB FlashBack でムービーを出力する際にトラブルが発生する場合のみチェックを外してください。MP3 オプションは WMV 出力では無効となります。

備考： BB FlashBack はオープンソースである LAME MP3 コーデックの再頒布版を使用しています： www.mp3dev.org


バッチ出力

BB FlashBack には、複数のファイルをまとめて出力するバッチ出力機能が用意されています。

実行させるには、BB FlashBack プレーヤーの「ファイル」メニューから「バッチ出力」ユーティリティを選択します。

バッチ出力ツールは、「新 FBR フォーマットへの変換」機能を通して、FlashBack ムービー（FBR）を旧フォーマットから最新フォーマットに変換する場合にも使用されます。この変換処理は、通常、ムービーが BB FlashBack プレーヤーでオープンされる場合に実行されます。

バッチ出力ツールを用いてムービーを出力するには

  1. ムービーに出力したい FBR ファイルを「出力ムービー」リストに追加します。「追加」ボタンをクリックしながら必要とするファイルを選択していきます。ファイルを選択して「除去」ボタンをクリックすることで出力リストからファイルを除去することもできます。

  2. 出力先フォルダを選択します。出力ファイルがここに生成されます。

  3. 必要とする出力フォーマットを選択します。

  4. BB FlashBack で通常行う出力オプションの設定を行います。選択したオプションは出力されるすべてのファイルに適用されます。

  5. 「出力」を押すと処理が開始されます。「現在のファイルをキャンセル」のボタンを押すと、現在出力中のファイルをキャンセルすることができます。または、「すべてキャンセル」をクリックして、全体の処理をキャンセルすることができます。出力ツールウィンドウの下にある「ステータス」リストはそれぞれのファイルが正しく出力されたかどうかを示しています。


ムービーのアップロード

BB FlashBack はビデオ配信サイトにムービーをアップロードすることができます。この機能を使用すれば Web アドレスを送信するだけでムービーを共有できるようになります。アップロード先は、YouTube、Blip.tv、Viddler、Revver です。アップロードする前に、該当サイトのアカウントを取得している必要があります。

ムービーをアップロードするには：

  1. まず、アップロード先のビデオ配信サイトのアカウントを取得します。BB FlashBack は www.youtube.com、blip.tv、www.viddler.com、www.revver.com に対応しています。

  2. ツールバー上にある「アップロード」ボタンをクリックします。

    デフォルトはYouTubeになっています。ボタンの右下にある小さな矢印を押すと、別のアップロードプロファイルを選択することができます。一度選択すると、次回からはデフォルトになります。

  3. ログイン情報の入力
    ムービーを自分のアカウントに対してアップロードするのに必要となります。次回からは記憶されます。

  4. ムービーに関する情報を入力する

    • ここに入力するタイトルと内容は、Web サイト上でムービーが表示されるときにブラウザ上に表示されます。

    • 「タグ」は検索用のヘルプとして使用されます。ムービーの内容に関連するタグを取り決めます。

    • ムービーを「プライベート」に設定することのできるサイトもあります。これは特定のユーザだけにムービーを公開します。

  5. アドレスを取得して共有します。
    ムービーのアップロードが完了すると、Web アドレス （URL） が表示されます。アドレスをクリックするとビデオ配信サイト上でムービーが上映されます。

    備考： 特定のサイトではビデオの受付処理に時間を要する場合があります。受付処理完了前に URL をオープンすると、ビデオが見つからないというメッセージが表示される場合があります。

備考： ビデオ配信サイトで表示されるムービーは、テキストボックスやボタンを用いて「クリックで継続...」などとするインタラクティブな要素を配置することができません。このような機能を持たせたい場合は、Flash （SWF） への出力を行い、出力されたファイルを Web サーバにアップロードする必要があります。詳細は、「Web ページで Flash 出力を表示する」を参照してください。


FTP と FileCopy へのアップロード

公開のビデオ配信サイトへのアップロードに加えて、BB FlashBack は FTP サーバおよび PC や LAN 上のフォルダにもムービーをアップロードすることができます。

FTP サーバにアップロードする

プレーヤータスクバーのアップロードボタンで、「FTP へアップロード」を選択します。

FTP サーバ詳細ウィンドウのオプション：

  • サーバアドレス
    例： ftp.mycompany.com

  • ログイン名とパスワード
    FTP サーバへの認証情報

  • Home フォルダ
    アカウント用のフォルダに対して、こちらはファイルをアップロードする FTP サーバ上のフォルダです。

  • URL ベースのダウンロード
    FTP サーバによっては、アップロードされたファイルに対してサーバ名やフォルダ名ではなく、公開のダウンロードアドレスを付与する場合があります。アップロードの完了時に BB FlashBack 上で正しいダウンロードアドレスを表示させるには、「URL ベースのダウンロード」の設定を行います。

    URL ベースのダウンロードは、ファイルの公開ダウンロードアドレスのルートとなります。たとえば、FTP サーバがファイルの公開ダウンロードアドレスとして ftp://myserver.com/public/ を公開しているとします。このとき、URL ベースのダウンロードとして「 ftp://myserver.com/public/ 」を設定しておくと、アップロードの完了時に BB FlashBack がアップロードファイル名を追加して、ダウンロードアドレスを「 ftp://myserver.com/public/myfilename.file 」と表示します。

FileCopy プロファイルを使用してアップロードする

FileCopy プロファイルは FBR ムービーファイルをコピーしたり、あるいはそれを外部出力してローカルネットワーク上のフォルダにコピーします。

FileCopy アップロードのプロファイルを使用する場合は、ファイルのコピー先のフォルダを指定するだけです。UNC 名の使用とドライブ名の使用が可能です。


サウンド編集について

サウンド編集の基本

BB FlashBack には強力なマルチトラック・サウンド編集機能が用意されています。追加のナレーションを録音したりサウンドファイルをムービーに追加したりできます。

このページではサウンド編集の基本を解説しています。

サウンドの選択

音量の変更

サウンドのミュート

より拡張された機能についてのトピックをご覧ください：

ムービーへのサウンドの追加と録音

BB FlashBack は、フレームバーの下にサウンドトラックが表示されています。それぞれのトラックは、青い波形画像として表示されます。

下の画像には 2 つのトラックがあります： 「ナレーション」と「サウンド効果」です。

サウンドファイルを追加するか、または新しいナレーションを録音すると、新しいサウンドが新規のトラックとして追加されます。

ムービーにサウンドを録音すると、このサウンドは「メイントラック」として表示されます。

備考: ステレオトラックは 2 つの異なるチャネルの画像ではなく、1 つの波形として表示されます。トラックはステレオで再生されますが、見かけ上の問題で 1 つの波形として表示されます。

サウンドの選択

  • トラックを選択するにはヘッダをクリックします。選択されたヘッダは赤色になります。

音量の変更

トラック全体のボリューム調整をするには：

    1. トラックのヘッダを右クリックして、ボリュームアップとボリュームダウンを選択します。

サウンドのミュート

ミュート切り替えボタンでサウンドをミュートする：

ミュートされたトラックはグレーで表示されます。

トラック全体のミュートを切り替えるには：

    1. トラック名を右クリックしてメニューからミュート項目を選択します。


ムービーにサウンドを追加する

ムービーにサウンドを追加または録音する

BB FlashBack はムービーにサウンドファイルを追加したり、ナレーションや PC サウンドを追加したりすることができます。

ムービーにサウンドファイルを追加するには：

  1. サウンドを追加したいムービー上のフレームを選択します。

  2. サウンド追加ボタン [image] を押します。

  3. サウンドファイルを選択して OK ボタンを押します。

    サウンドは、選択されたフレーム上に新しいトラックの新しいクリップとして追加されます。

ムービーに録音する

BB FlashBack は接続されたマイクを通して音声を録音したり、パソコンのスピーカーから流れるサウンドを録音したりすることができます。

ムービーにサウンドを録音するには

  1. 録音を追加したいムービーのフレームを選択します。

  2. 録音ボタン [image] を押します。

  3. まず、録音ソースを選択します。通常はマイクからの録音か、あるいはスピーカーから流れ出る PC のサウンドかのいずれかになります。詳細は下記の「録音ソースの選択」を参照してください。

  4. ムービーの再生が始まり、先に選択しておいたフレームから録音が開始されます。

  5. 録画や再生を止めるには、ツールバー上の一時停止ボタンを押します。

    選択されたフレームにおいて、サウンドが新しいトラック上の新しいクリップとして追加されます。

録音ソースを選択する

録音ダイアログ上で、BB FlashBack の録音時に使用されるサウンドソースとサウンド形式を選択します。

1. サウンドデバイスの選択

サウンドデバイスのドロップダウンリストからデバイスを選択します。通常のパソコンには「デフォルト」サウンドデバイスと各サウンドカード用のサウンドデバイス、あるいは他の音声再生用や録音用のサウンドデバイスが登録されています。録音したいデバイスを選択してください。

2. 音源の選択

次の 3 つのオプションから選択します：

    1. マイク
      接続されたマイクからナレーションを録音する場合はこれを選択します。

      ダイアログ右側のレベル調整スライダとボリューム表示でマイクが正しく接続されていて集音されていることを確認します。

      選択されたサウンドデバイス上に適切なマイクのソースが検出できない場合は、このオプションは有効となりません。

    2. PC サウンド
      パソコンのスピーカーから出るサウンドを録音したい場合、このオプションを選択します。

      通常のサウンドデバイス（サウンドカード等）には録音用に複数のソースが用意されています。ソースの選択ボタンを押してパソコンから出るサウンドのソースを確認します。ここで録音に使用するソースを選択し、ミニスライダを使って関連ボリュームの調整を行います。

      ウィンドウの右にある「レベル」メーターを使って、BB FlashBack が録音用のサウンドを認識しているかどうかを確認できます。

    3. その他のサウンド
      PC のスピーカーから再生されないようなサウンドソースを選択する場合にこれを使用します。

3. サウンド形式の選択

どのサウンド形式を選択するかによって、録音の品質とムービーファイル上に占めるデータ容量が変化します。

下記を選択します。

    1. KHz 当りのサンプリングレート
      レートが高ければ高いほど音質は良くなりますが、サウンドトラックが占有するファイルスペースは大きくなります。

    2. ステレオ / モノ
      ステレオはモノより良い音質が得られますが、やはりムービーファイル容量は増加します。

    3. MP3 圧縮
      このオプションは、ムービーの録画時や出力時にクラッシュもなく、とくに問題がない限りは常に選択しておきます。選択を解除すると、ムービーのファイルサイズは非常に大きくなります。

      BB FlashBack は LAME MP3 コーデックの再頒布版を使用しています： www.mp3dev.org


録音オプションウィンドウ

サウンドオプションウィンドウ

このウィンドウの用途：

  • サウンド出力デバイスを再生時に使用します。


サウンド同期障害

ときおり、オーディオとビデオの同期で問題が発生する場合があります。下記はこの問題を解決するためのヒントです。

サウンドの同期問題はハードウェアに大きく依存することに留意してください。別の PC で録画を行うと全く問題が起こらない場合があります。

  1. レコーダーの同期問題を解消する
    レコーダーのオプションウィンドウにある「サウンド」タブを開き、「サウンドの同期」ボタンをクリックします。BB FlashBack はサウンドハードウェアをテストします。そして可能であれば、次回以降における同期問題を解消するための自動調整を行います。


BB FlashBack をコマンドラインから使用する

BB FlashBack は、録画や外部出力をコマンドラインから行うことのできる FBCmd.exe というプログラムも同時にインストールされます。

使用法：

FBCmd.exe [アクション] [オプション]

アクション：

/start | 録画を開始します。
/stop | 録画を終了します。
/exit | レコーダーを終了する。
/save-config | FBCmd の環境設定を現在のコマンドラインオプションで上書きします。
/export-configs [ファイルパス] | 環境設定ファイルを [ファイルパス] フォルダに出力します。 環境設定ファイルとは： "FBCmd Recorder.xml" - 録画処理用のオプション設定 "FBCmd ExportWMV.xml" - WMV 出力用のオプション設定 "FBCmd ExportFlash.xml" - Flash 出力用のオプション設定 "FBCmd ExportAVI.xml" - AVI 出力用のオプション設定 現在の BB FlashBack のデフォルト設定を使用せずにカスタマイズ設定を行うには、/recorder-config、/avi-config、/wmv-config、/swf-config のオプションを用いてこれらの XML ファイルを指定します。

/stop 使用時のオプション：

/save-fbr [ファイル名] | 録画されたムービーを [ファイル名] に保存する
/save-avi [ファイル名] | 録画されたムービーを AVI に出力する
/avi-config [ファイル名] | AVI 出力用の環境設定ファイルを使用する
/save-wmv [ファイル名] | 録画されたムービーを WMV に出力する
/wmv-config [ファイル名] | WMV 出力用の環境設定を使用する
/save-swf [ファイル名] | 録画されたムービーを Flash に出力する
/swf-config [ファイル名] | Flash 出力用の環境設定を使用する

したがって、録画の開始、終了、WMV への保存を行うためのコマンドラインは次のようになります：

FBCMD /start

そして

FBCMD /stop /save-wmv c:\test.wmv

これはデフォルトの WMV 出力設定を使用します。別の設定を使用するには、BB FlashBack のレコーダーを使用して環境設定を定義します。そして、それを FBCMD /export-configs コマンドを用いて XML ファイルに出力します。すると、録画の終了時や出力時に /wmv-config オプションを経由して WMV 用の環境設定を指定することができるようになります。具体的には次のようになります：

FBCMD /stop /save-wmv c:\test.wmv /wmv-config c:\fbcmd exportwmv.xml

/start アクション使用時のオプション：

/recorder-config [ファイル名]

カスタマイズ用録画の環境設定を使用する


サポートへ問い合わせ

最初に、問い合わせ事項がヘルプファイルに記載されていないかどうか確認してください：

  • トラブルシューティング FAQ

  • 録音に関するトラブルシューティング

  • サウンド同期障害

  • ビデオ録画時のトラブルシューティング

サポートへの問い合わせ：

  1. サポートメニューを開きます。プレーヤーではヘルプメニュー、レコーダーではメインメニュー上にあります。

  2. 「BB FlashBack のサポート」を選択し、問い合わせ先を参照します。


FAQ

トラブルシューティング FAQ

録画

インストール時やレコーダーの実行時に、ASUSソフトウェアについての警告が出ます。

録画に入ると、システムが極端に遅くなります。

録画時に、BB キャプチャドライバについてのエラーメッセージが表示されます。

DVD やビデオクリップを録画しようとしても、うまくいかないか、あるいは結果がよくありません。

GDI 録画モードが無効になっているか、または低フレームレートでしか利用できません。

キャプチャドライバ録画モードは無効です。

サウンド

ムービーの録画中にサウンドを録音することができません。

ムービーの再生時にサウンドが再生されません。

サウンドも一緒に録音したのですが、ムービーの再生時にサウンドとビデオ映像とがだんだんずれてきます。

出力

ムービーを AVI ファイルに出力しました。自分のパソコンでは再生されるのですが、他のパソコンでは再生されません。

どの形式に出力しても、映像の右上コーナーに '製作ソフトウェア' というロゴが表示されます。これはライセンスを購入しても表示されるのでしょうか？

ムービーを Flash に出力したのですが、SWF ファイルがゆがんでいるのか、画質が悪いです。

その他

最終ムービーファイルのサイズに影響する要素は何ですか？

ムービーを再生させると、画像またはテキストのどちらかが正しく表示されないか、または両方とも表示されません。

アップデートウィザードのチェックを利用して BB FlashBack をアップデートできません。

試用版のフルキーまたは延長キーがプログラムで受け付けられません。

FBR ムービーファイルがプレーヤーでオープンできません。

BB FlashBack を Windows NT で使用しているのですが、プレーヤーを実行することができません。

インストールしてレコーダーを実行させると、ASUS ソフトウェアについての警告が表示される。

弊社の調査により、ASUS の '拡張ディスプレイドライバ' が同一パソコン上に 'ミラー' ディスプレイドライバとしてインストールされると、システムに極度な不安定を招くことが分かりました。FlashBack のキャプチャドライバも 'ミラー' ディスプレイドライバの1つだからです。

この問題があまりに深刻であるため、BB FlashBack （またはそのインストーラ） が ASUS ドライバのインストールを検出した場合は、キャプチャドライバはインストールいたしません。その場合でも BB FlashBack は録画を行うことはできますが、キャプチャドライバモードよりパフォーマンスの低い GDI 録画モードを使用して録画を行います。

ASUS ソフトウェアがアンインストールされると、キャプチャドライバは BB FlashBack レコーダーの次回の起動時に自動的にインストールされます。

ページの先頭に戻る

録画を行っている時のシステムの動きがあまりにも遅いです。

レコーダーオプションウィンドウの「録画モード」タブ、または録画ウィザードの録画モードステップ上で録画モードを変更するか、またはフレームレートを下げてみてください。

特に、マルチコアでない CPU（Pentium 4 や Celeron、Atom 等）上で MPEG モードを使用していたり、あるいは高解像度のデスクトップ（1280x1024 以上など）の全体をを録画していたりすると、このような問題が発生するかもしれません。

ページの先頭に戻る

録画中に、BB キャプチャドライバに関するエラーメッセージが表示されることがあります。

この問題は、キャプチャドライバのインストールが破損していることが原因である場合があります。その場合は、BB FlashBack に同梱されている修正プログラムで再インストールを行うことができます。BB FlashBack のインストールフォルダを開き、「FlashbackDriverInstaller.exe」を起動してください。そして、「Uninstall BB Capture Driver」を選択し、次に「Install BB Capture Driver」を選択します。これにより、ドライバが再インストールされます。

ページの先頭に戻る

DVD やビデオクリップを録画したいのですが、うまくいかないか、結果が貧弱であるかのどちらかです。

「ビデオ録画のトラブルシューティング」を参照してください。

ページの先頭に戻る

完成ムービーのファイルサイズを決める要因となるものは？

FBR ムービーファイルのファイルサイズは、ムービーの長さよりもむしろムービーの内容により決定されます。デスクトップの静止画像を表示しているだけの長いムービーは、多くの画像や写真を含んだ短いムービーよりもサイズにおいては小さくなります。 ムービーのサイズを増大させる大きな要因としては、写真画像、Windows の壁紙、Web サイトの画像、アニメーション、ウィンドウのスクロール、Windows のグラフィック効果などがあります。

BB FlashBack は、グラフィカルな壁紙や Windows のグラフィック効果を録画中にだけ自動的に OFF にすることができます。これらのオプションはレコーダーのオプションダイアログの 'グラフィック' タブにあります。

サウンドトラックもムービーの最終サイズを増大させます。サウンドトラックによって追加されたサイズを削減するには、サウンド録音オプション （レコーダーのオプション→ 'サウンド' タブ） にある "MP3 圧縮" を有効にします。 プレーヤーアプリケーション上でサウンドを追加する場合にも、WAV ファイルよりも MP3 ファイルを入力するようにしてください。

ファイルサイズは、他の形式のファイル （FBR でないファイル） に出力する場合に大きく変化します。Flash 形式は通常、AVI 形式より小さなファイルサイズとなります。AVI ファイルの場合は AVI 出力時に選択されたコーデックがファイルサイズを決めるうえで大きな要素となります。

ページの先頭に戻る

ムービーを再生すると、グラフィックまたはテキストのどちらかが表示されないか、または両方とも表示されません。

複数のグラフィックカードを持つコンピュータを使用している場合、Windows のコントロールパネルを開き、「画面」→「設定」タブ→「詳細設定」で、プライマリグラフィックカードを他のビデオカードに切り替えます。

録画にキャプチャドライバモード （Windows 2000、XP のデフォルト） を使用している場合、Flash やゲーム、ムービープレーヤーやアニメーションなどの特殊なテクノロジーを録画すると、再生時にひずみが発生する場合があります。このような場合、他の録画方式を選択することで問題が解消される場合があります。録画方式を変更するには BB FlashBack レコーダーの「オプション」から「録画モード」タブを開き、GDI 録画モードを選択します。モードを変更したあとに再び録画を試してみて、ひずみの問題が解消されるかどうかを確認してください。

ページの先頭に戻る

ムービーを再生したときに、サウンドが聞こえません。

まずはじめに、通常の状態でパソコンから音が出るかどうかをテストします。サウンドファイルを再生してみます。音楽ファイルが再生されなければサウンドの設定が正しく定義されていないことになります。

パソコンにマイクが接続されている状態であれば、Windows に標準添付の 'サウンドレコーダー' で録音と再生のテストを行うことができます。テストを行っても音声が再生されないのであれば、録音の音源としてマイクが正しく設定されていないことになります。音源としてマイクが正しく選択されていることと、ボリュームが適切であることを確認する必要があります。Windows のサウンドレコーダーを使用して、「編集」→「オーディオのプロパティ」で設定を行ってください。録音用の正しいサウンドデバイスを選択し、ボリュームの調整が録音時と再生時ともに適正であるかどうかをチェックします。

デフォルトでは、Windows の 'サウンドレコーダー' は「スタート」→「すべてのプログラム」→「アクセサリ」→「エンターテイメント」にあります。

パソコンのサウンド設定が正しいことが確認できたら、BB FlashBack レコーダーのメニューから「オプション」→「サウンド」タブを開き、"サウンドの録音を有効にする" のオプションが ON になっているかどうかを確認します （OFF になっている場合は、ムービーの録画時にサウンドはキャプチャされません）。

ヘルプ項目の「サウンドの録音」を参照してください。マイクおよびパソコンスピーカーからの録音についての詳細な解説があります。

ページの先頭に戻る

アップデートの確認ウィザードを使用して BB FlashBack のアップデートを行うことができません。

まずはじめに、コンピュータが正しくインターネットに接続されているかどうかを確認してください。インターネットブラウザを使用して Web サイトがオープンされるかどうかで確認することができます。インターネットに接続されていない場合は、アップデートウィザードは "チェック中のエラー" を表示するようになっています。

アップデートの確認ウィザードが起動されるときは、シリアルキーがチェックされます。15日間有効の BB FlashBack シェアウェアバージョンを使用している場合、延長用の試用キーを使用している場合、または購入後のフルキーを使用している場合、キーは受け付けられます。弊社のサーバ上にお手元のキーが登録されていない場合は、アップデートウィザードは "ライセンスキーが認識されません" というメッセージを表示します。このエラーメッセージが表示された場合は、弊社までお問い合わせください。

ページの先頭に戻る

フルキーまたは延長用試用キーがプログラムで受け付けられません。

試用キーは大文字小文字を区別することとスペースを含むことに注意してください。

BB FlashBack 上で延長用の試用キーが 1回使用されると、その後の延長用キーはすべて拒否されます（延長は 1回だけ認められます）。さらに延長を希望される場合は弊社にご相談ください。

弊社のサーバ上で 2005年 2月 1日以降に生成されたすべてのシリアルキー（延長用試用キーであるか、購入されたフルキーであるかにかかわらず）は、以前のものより桁数が多くなっていることと、BB FlashBack のバージョン 1.4.1 以上が必要であることに留意してください。それ以前のバージョンでは動作いたしません。BB FlashBack の最新バージョンは次からダウンロードできます: www.bbsoftware.co.uk/BBFlashBack/Download.aspx

ライセンスキー関連の問題の詳細は、「ライセンスキーのトラブルですか？」を参照してください。

ページの先頭に戻る

FBR ムービーファイルがプレーヤーでオープンできません。
プレーヤーがエラーメッセージを表示して FBR ムービーをオープンできない場合や、オープンしてもすぐに閉じてしまう場合、完全にクラッシュしてしまう場合など

ムービーファイルが BB FlashBack のバージョン 1.4 で作成または編集されたものであって、これをバージョン 1.4 のムービーをサポートしていない、それ以前のバージョンのプレーヤーでオープンしようとしていることが考えられます。BB FlashBack の最新版を次からダウンロードされることをお勧めします: www.bbsoftware.co.uk/BBFlashBack/Download.aspx

または、ファイルが破損していることも考えられる原因となります。ファイルの保存中に割り込みがあったり、ハードウェア的なエラーのあるディスクに保存されたりすると、このような現象が発生することがあります。ファイルが破損している場合、ファイルを自動的にリカバリする方法はありませんので、最新のバックアップからリストアしていただくしかありません。

ページの先頭に戻る

Windows NT で BB FlashBack を使用しているのですが、プレーヤーを起動することができません。

残念ながら、BB FlashBack プレーヤーは Windows NT には対応していません。レコーダーはこの OS 上でも正常に動作します。

ページの先頭に戻る

ムービーを AVI ファイルに出力しました。自分のパソコンでは再生されるのですが、他のパソコンでは再生されません。

出力時にこの形式を選択すると、BB FlashBack はパソコンにインストールされているコーデックのリストの中から、出力に使用するコーデックの選択を促します。選択されたコーデックは、AVI ムービーを表示させるために、再生用のパソコンにもインストールされている必要があります。

視聴者に関連コーデックのインストールを勧めるか、または他のコーデックを使用しての出力、他の形式を使用しての出力を行ってください。

ページの先頭に戻る

出力を行うと、どの形式に出力しても 'created by' という画像が右上コーナーに表示されます。これはライセンスを購入しても表示されるのですか？

いいえ、'created by' の画像は、ライセンスされていない BB FlashBack で出力された場合にのみ表示されます。

ページの先頭に戻る

ムービーを Flash に出力したのですが、SWF ファイルがひずんでいるのか、画質が悪いです。

Flash 出力を選択した場合は、BB FlashBack は HTML ファイルと SWF ファイルの両方を作成します。ムービーを見るには両方のファイルが必要です。ムービーを正しいサイズと画質で表示させるには、HTML ファイルのほうをオープンしてください。

ページの先頭に戻る

サウンドを入れて録画しました。ムービーを再生させると、サウンドと映像がだんだんずれていきます。

この問題は、特定のサウンドハードウェア上で発生します。レコーダーオプションウィンドウの「詳細設定」タブを開き、'補正サウンド同期を使用する' のボックスにチェックを入れてください。

備考： サウンドの同期問題が解消されるまで、この機能を使用すると特定の PC ではクラッシュを引き起こすケースがあると警告されます。このために、デフォルトでは設定が ON になっていません。

ページの先頭に戻る


トラブルのレポート

BB FlashBack は、トラブルが発生したときにそれを Blueberry にレポートする機能を装備しています。レポートは最近の実行ログを自動的に作成し、PC 環境情報を収集して、レポートに画面のハードコピーを添付できるようにします。

最新の実行記録を送信できるようにするには、BB FlashBack のロギングを ON にする必要があります。デフォルトではロギングは OFF になっています。

Blueberry に障害をレポートするには

  1. ロギングを有効にする
    BB FlashBack を起動し、「サポート」メニューにある「ロギング自動実行を ON にする」を選択します。

    • プレーヤー上では、ヘルプメニューにサポートメニューがあります。

    • レコーダーでは、メインメニューを参照してください。

    あるいは、BB FlashBack を起動できない場合は、Windows の「スタート」メニュー→「BB FlashBack」メニュー→「Support」にある、「ロギング自動実行を ON にする」を選択します。

  2. 障害を再現する
    BB FlashBack（プレーヤーまたはレコーダー）を再起動し、障害を再現します。

  3. レポートを開始します。
    「障害を Blueberry にレポートする」を開きます。
    これは、プレーヤーの「ヘルプ」→「サポート」か、レコーダーの「サポート」メニューにあります。

  4. レポートを送信する
    症状を書き込み（返信を希望する場合はメールアドレスを添えます）、送信ボタンを押します。

    レポートウィンドウにある「添付ファイルの変更」ボタンをクリックして、レポートに画面のハードコピーとファイルを添付することができます。


BB FlashBackアップデートのチェック

BB FlashBack のアップデートの確認

BB FlashBack は新しいバージョンがあるかどうかをチェックすることができます。現在実行しているものより新しいバージョンが見つかると、ダウンロードとインストールのオプションが表示されます。

確認とダウンロードにはインターネット接続が必要です。インターネット接続がダイヤルアップの場合はダイヤル接続の手順に進みます。

BB FlashBack のアップデートを確認するには：

  1. プレイヤーの「ヘルプ」メニュー、またはレコーダーのメインメニューにある「アップデートの確認」を選択します。

  2. 自動更新ウィザードの指示にしたがって新しいバージョンをチェックします。見つかった場合はダウンロードしてインストールします。使用

アップデートの自動チェック

BB FlashBack は、作業中にバックグラウンド上でもアップデートを確認することができます。見つかった場合はダウンロードしてインストールするかどうかの確認が表示されます。

プレーヤー上で自動アップデートチェックのON/OFFを切り替えるには：

  1. 「ツール」→「プレーヤーオプション」メニューの選択

  2. 自動更新のチェックボックスにチェックを入れるか、またはチェックを外します。

レコーダー上で自動アップデートチェックのON/OFFを切り替えるには：

  1. レコーダーのメインメニューから「オプション」を選択します。

  2. オプションダイアログで「その他」を選択します。

  3. 自動更新のチェックボックスにチェックを入れるか、またはチェックを外します。


エンドユーザライセンス

ライセンス

BB FlashBack のインストールフォルダにある Licence.rtf ファイルに、BB FlashBack のエンドユーザライセンス契約（EULA）が記載されています。

BB FlashBack で制作されたムービーは、Blueberry ソフトウェア社にロイヤリティを支払うことなく、すべての個人用途および商用用途において、これを使用することができます。


クロッピングについて

ムービーを録画した後、再生画面領域の一部だけをカットして再生したい場合があります。

ムービー表示面積の一部だけを切り抜いて画面サイズを小さくする、BB FlashBack のクロッピング機能が使用できます。

ムービーをクロッピングするには：

  1. BB FlashBack プレーヤーでムービーを開き、クロッピングボタン [image] をクリックして、クロッピングを ON にします。
    または、「効果」のメニューから「クロッピング矩形を設定する」を選択します。

  2. クロッピングされる部分を表す青色の矩形が表示されます。必要に応じてサイズ調整と位置決めを行います。

クロッピングを OFF にするには、クロッピングボタン [image] をもう一度押します。

クロッピングされたムービーをプレビューするには:

  1. ツールバー上の「効果の適用」ボタンをクリックするか、または「効果」メニューの「効果の適用」を選択します。

    備考： 「効果の適用」機能は、設定されているズーム・パン効果にも適用されます。ムービーを出力したときと全く同じ状態で表示されます（拡大・縮小機能や、出力時に適用される他の効果を除きます）。

クロップムービーのオートスクロール

クロッピング矩形を使用し、マウスをその中に常時表示させるように設定することができます。「効果」→「クロッピング矩形のオートスクロール」を使用すると、マウスを追従してムービーの中央、または中央付近に常に表示させることができます。

クロッピング矩形にオートスクロールが設定されている場合、ズーム・パン効果が適用されている箇所は位置は移動せずに、サイズ変更だけが適用されます。これは、マウスを表示領域に常に表示させるためです。

クロッピングを確定させる

FlashBack ムービー (.FBR file) のファイルサイズを削減するために、選択領域以外を破棄してクロッピングを確定させることができます。

これを行うには：「効果」メニューから「クロッピングの確定」を選択します。


ムービーの編集について

ムービーを録画し終えると、BB FlashBack は映像効果を演出するためにテキストや画像やサウンドによる解説を追加したりすることができるようになります。

解説

テキストボックス、画像、ボタン、ハイライト、サウンドをムービーに追加することができます。詳細は「テキストボックスについて」、「画像の追加」、「ハイライトの追加」、「ボタンの追加」、「サウンドの追加」を参照してください。

サウンド

ムービーにサウンドファイルを追加したり、あるいは新しいサウンドトラックを録音したりできます。詳細は「サウンド編集の基本」を参照してください。

一時停止

ムービーに一時停止を追加することができます。これによりムービーは再生時に指定箇所で一時停止し、視聴者の再生再開の指示を待ちます。詳細は「ムービーに一時停止を挿入する」を参照してください。


イベントについて

映画館やテレビで見られる伝統的な映画と同じく、BB FlashBack のムービーも静止画フレームの集合体であるといえます。

各フレームは、そのフレーム内において描画変更などの複数のイベントを持つことができます。

ウィンドウの全体を描くような複雑な操作は、多くの分離したイベントに分解され、それぞれがウィンドウ全体の一部を描くことになります。

ムービーを分離したフレームで再生する場合、BB FlashBack プレーヤーは個々のイベントを 1 つのフレーム上に置かなければなりません。フレームにイベントを配置する方法には 2 種類があり、プレーヤーはそのどちらかを使用します。デフォルトの配置方法から変更が必要になることはめったにありませんが、オプションは用意されています。

異なるイベント割当法を選択する必要があるのはなぜ？

ムービーの再生がスムーズでない場合、デフォルトのアロケーション法（プロポーショナル）が短時間内に過剰なイベントでフレームを満たしてしまっている可能性があります。このような場合、他のアロケーション法（フロー）のほうがより良い再生結果をもたらすことがあります。

イベント割当の設定方法

  • プレーヤーのメインメニューから「ファイル」→「プロパティ」を選択します。

  • 「フレームレート」タブを選択します。

  • 2つのイベント割当法からひとつを選択します：プロポーショナル（デフォルト）またはフロー


サウンドの形式と圧縮について

ムービーの録画と同時に音声を録音する場合、各種設定を変更するにはレコーダーオプションウィンドウの「サウンド」タブを使用します。

サウンド形式

音声の録音あるいは外部出力を行うには数々の形式が用いられます。異なる形式を選択することで録音の品質やムービーファイル上に占める容量が決まります。

  1. サンプリングレート：例 「44.1KHz」。サンプリングレートが高いとサウンドの品質は向上しますが、ムービーファイルは大きくなります。

  2. モノ / ステレオ： マイクがステレオ録音に対応しているとサウンドの品質はよくなりますが、ムービーファイルは大きくなります。

  3. ビット/サンプル： 8 BIT または 16 BIT： ビット/サンプルが高くなるとサウンドの品質が向上し、ムービーファイルは大きくなります。

MP3 圧縮

BB FlashBack は MP3 圧縮を使って、録音される音声を圧縮することができます。これによりムービーファイルは小さくなります。録音中に問題がなければここを「チェック」にします。

BB FlashBack は LAME MP3 コーデックの再頒布版を使用しています： www.mp3dev.org


ズームとパン効果について

BB FlashBack はムービーの特定領域を「ズームイン」させることができます。これにより、スクリーン上の出来事を強調することができます。

このページの内容：

ズームインの方法

ズームとパン効果をプレビューするには

ズームとパン効果の領域を変更するには

ズームとパン効果を削除するには

推移時間を変更するには

ズームを取り消すには

ズームインの方法

  1. ズーム効果を表示させたいフレームを選択します。

  2. ツールバーのズーム/パン追加のボタン [image] を押します。

  3. ズームとパンプロパティのダイアログで「指定領域」を選択してOKボタンを押します。

  4. ムービー領域に緑の矩形が表示されます。これがムービーをズームインさせる領域の印となります。つまり、緑の矩形部分がムービー領域全体の大きさにまで拡大されることになります。

    緑の矩形は次のように表示されます。

    左上コーナーの [image] のハンドルをドラッグすることで緑の矩形部分を移動させることができます。

ズームとパン効果をプレビューするには

ツールバーの「効果の適用」ボタンをクリックして、出力時にムービーがどのように再生されるかを確認します。
効果が適用されると、緑色の枠は表示されなくなります。

「効果の適用」ボタンをもう一度クリックして、効果を解除します。すると緑色の枠が再び現われ、ムービーがズームインされるときの領域の変更が可能になります。

ズームとパン効果を変更するには

ズーム/パン効果を追加すると、この変更はムービーの後続のすべてのフレームに反映されます。効果の適用以降にある適当なフレームを選択し、「効果の適用」を ON にします。すると緑色の枠が表示されるので、ムービーの表示領域を確認することができます。

任意のフレーム上で緑の矩形の位置やサイズを変更すると、その変更はズームとパン効果のすべてのフレームに反映されます。変更のために、最初にズームとパン効果を追加したフレームを探す必要はありません。

ズームとパン効果を削除するには

  1. フレームバー上でズームとパン効果を探します。簡単な見つけ方はツールバーの「ジャンプ」コントロールでその効果を選択する方法です。そのフレームに直接ジャンプすることが出来ます。
    フレームバー上に次のような表示を見つけることができます。

    アイコンは推移の開始フレームであることを表します。ズームとパンがそこからスタートします。
    アイコンは推移の終了フレームであることを表します。ズームとパンがそこで終了します。

  2. アイコンを右クリックして「ズームとパンの削除」を選択します。
    または
    ツールバーのズームとパンの削除ボタン [image] を押します。

ズームとパン効果のトランジッション速度を変更する

  1. フレームバー上でズームとパン効果を探します。これを行う簡単な方法は、ツールバーにある「ジャンプ」の項目で効果を選択することです。そのフレームに直行することができます。

    アイコンはトランジッションの開始フレームであることを示しています。ズームとパンがここからスタートします。
    アイコンはトランジッションの終了フレームであることを示しています。ズームとパンはここで終了します。

  2. フレームバーにある [image] か [image] アイコンかのどちらかをドラッグして、トランジッションの開始と終了を移動させます。
    または
    アイコンをダブルクリックして、ズームとパン効果のプロパティウィンドウを表示します。

ズームを元に戻すには

ズームとパン効果を追加すると、これはそれ以降のムービーのフレーム全体にわたる表示を切り替えます。ズームインしたあと、元のようにズームアウトしてムービーの全体像を表示させるには、2つめのズームとパン効果を追加する必要があります。

ズームアウトして元のムービーの全体像を表示させるには：

  1. ズームアウトしたいフレームを探します。

  2. ツールバーのズーム/パン追加のボタン [image] を押します。

  3. ズームとパンのプロパティウィンドウ上で「表示領域」設定にある「ムービー全体」を選択します。そして、OK をクリックします。

ムービーはその位置でズームアウトします。


サウンドファイルを追加する

ムービーにサウンドファイルを追加するには：

  1. フレームバー上でサウンドを追加したいフレームを選択します。

  2. プレーヤーのメインメニューから「編集」→「サウンドの追加」を選択します。

    または

    編集ツールバー上のサウンドの追加ボタン [image] を押します。

  3. サウンドファイルを選択します：.wav または .mp3

フレームバー上のサウンドを追加したフレームには [image] 画像が現われます。再生時には選択されたサウンドファイルはそのフレームで再生されます。

サウンドを編集するには：

  1. フレームバー上にてサウンドを含むフレームを選択します ? の画像が表示されています。

  2. プレーヤーのメインメニューから「編集」→「サウンドの編集」を選択します。

    または

    編集ツールバーにあるサウンドの編集ボタン [image] をクリックします。

置き換えるサウンドファイルを再選択することができるようになります。

サウンドファイルを削除するには：

  1. フレームバー上にてサウンドを含むフレームを選択します ? の画像が表示されています。

  2. プレーヤーのメインメニューから「編集」→「サウンドの削除」を選択します。

    または

    編集ツールバーにあるサウンドの削除ボタン [image] をクリックします。


ムービーにサウンドを追加する

BB FlashBack を使用して、ムービーにサウンドを追加することができます。サウンドはイベントを強調する単純な効果音から、ムービー上の操作を解説するナレーションの録音に至るまで、何でも構いません。

ムービーにサウンドを追加するには2つの方法があります。

  1. ムービーの特定の場所にサウンドファイルを追加する方法。詳細は、「サウンドファイルを追加する」を参照してください。

  2. 録音オプションウィンドウで定義されたサウンドソースから録音する方法（例：マイク等）。録音はムービー全体、あるいはムービーの一部に対して適用されます。詳細は、「サウンドトラックを録音する」を参照してください。


出力ムービーのオートスクロール

ムービーの表示面積を縮小し、マウスカーソルが常に表示されるように自動的にスクロールさせたい場合、クロッピング矩形を追加して「クロッピング矩形のオートスクロール」オプションを ON にします。

詳細は、「クロッピングについて」を参照してください。


アップロードプロファイルを作成する

BB FlashBack には標準で 6 つのアップロードプロファイルが用意されています：Youtube、Blip.tv、Viddler、Revver、FileCopy、FTP です。アップロードプロファイルには、BB FlashBack がサーバにムービーをアップロードするための手順である、認証方式や必要とされるファイルフォーマット、サーバのアドレス、サーバへの配信方法などが記述されています。

アップロードプロファイルは自由に追加することができます。これにより、ムービーをすばやく Web サーバや FTP サーバ、ローカルファイルサーバなどにアップロードすることができます。

作成するプロファイルの数には制限はありません。異なる FTP サーバやローカルサーバ用にいくつでも作成することができます。

アップロードの操作時に、変更を許可する項目を事前に取り決めます。ログイン情報やビデオフォーマット、サーバアドレスを修正することができます。アップロード時にそれらが変更されることを許可します。

アップロードプロファイルの作成方法

  1. BB FlashBack プレーヤー上で、「ファイル」→「アップロードプロファイルの管理」を選択します。ツールバーのアップロードボタンからドロップダウンメニューで表示させることもできます。

  2. アップロードプロファイルの管理ウィンドウで、「追加」ボタンをクリックします。

  3. サーバタイプとプロファイル名の設定
    BB FlashBack が認証とファイル転送を正常に行えるよう、アップロード先のサーバタイプを指定する必要があります。
    プロファイル名は、「ファイル」→「アップロード」メニュー、および「アップロード」ボタンのドロップダウンメニューに表示されます。

  4. 有効なビデオフォーマットの選択
    BB FlashBack は、複数のビデオファイルフォーマットからいずれかを選択してムービーをアップロードします。このウィンドウでは、アップロード時にどのフォーマットを有効するかを選択します。サーバタイプによって、特定のファイルフォーマットを指定します。ただし、YouTube に FBR ファイルを直接アップロードしたりすることはできません。WMV、QuickTime、FLV、AVI などから選択する必要があります。

    ビデオフォーマットがひとつだけ選択されている場合は、アップロード時にフォーマットの選択画面は表示されません。フォーマットは自動で決定されます。フォーマットがひとつ以上選択されて場合は、アップロード時にフォーマットを選択することができるようになります。

    「ビデオフォーマットの設定変更を許可する」のチェックボックスが ON になっていると、アップロード時にビデオとオーディオの品質を変更するウィンドウが表示されるようになります。

    「ビデオフォーマットの設定変更を許可する」のチェックボックスが OFF になっていて、なおかつフォーマットがひとつだけ選択されていると、アップロード時にビデオファイルのフォーマットに関連した選択は表示されなくなります。ログイン詳細とムービー情報が表示され、BB FlashBack は即座にアップロードを開始します。

  5. ログインとサーバ詳細の入力
    サーバタイプにより、サーバアドレスとログイン詳細を入力しなければならない場合があります。ただし、その時点ではログイン詳細は入力せず、アップロード時にアカウント情報を入力するという選択を行うこともできます。

    アップロード時にこれらの詳細を編集できるようにすることもできます。


フレームをクロッピングする

BB FlashBack にはムービーから選択フレーム以外のフレームを取り除く機能があります。

ムービーをクロッピングして選択フレームだけにするには：

  1. 残したいムービーのフレーム範囲を選択します。

  2. プレーヤーのメインメニューから「編集」→「フレームの切り取り」を選択します。

    または

    編集ツールバーにある [image] ボタンを選択します。


MS PowerPoint への出力

BB FlashBack はムービーを MS PowerPoint 形式に出力することができます。生成された PPT ファイルはオープンと同時にムービーが自動再生されます。

備考： PowerPoint を含む Office 2000 以降がインストールされている場合のみ、PowerPoint 形式に出力することができます。

PowerPoint形式に出力するには：

  1. プレーヤーのメインメニューの「ファイル」から「PowerPointに出力」を選択します。 または 「ファイル」ツールバーの「出力」ボタンをクリックし、「PowerPoint」形式を選択します。

  2. 必要に応じて出力オプションをデフォルトの設定から変更します。方法は Flash 出力時の設定変更と同じです。詳細は、「Flash 出力オプション」を参照してください。

  3. 「出力」をクリックします。

  4. PPT ファイル用のファイル名を付け、「保存」を押してムービーをその名前で保存します。


スタンドアロン EXE への出力

BB FlashBack はムービーを、Microsoft Windows のほとんどすべてのバージョン上で動作する実行可能形式のファイルに出力することができます。ユーザは Windows の Explorer からそのファイルを実行するだけでムービーを表示することができます。ファイルがオープンされると、ムービーは自動的に再生されます。

ユーザは BB FlashBack プレーヤーや Flash 出力にあるものと同じような再生コントローラを使用することができます。ムービー上の別の箇所にジャンプしたり、再生の一時停止や再開も行うことができます。

ムービーをスタンドアロン EXE に出力するには：

  1. プレーヤーのメインメニューから、「ファイル」→「スタンドアロン EXE への出力」を選択します。
    または
    ファイルツールバーにある「出力」ボタンを押してスタンドアロン EXE 形式を選択します。

  2. 表示されるダイアログでオプションを設定します：

    • ムービープレーヤーの初期サイズ

    • 分離した複数のフレームでムービーを表示する場合、BB FlashBack プレーヤーは、個々のイベントを 1 つのフレーム上に配置する必要があります。プレーヤーはフレームにイベントを割り当てるのに、2 つのイベント割当法のうち 1 つを使用します。デフォルトの方法から変更を必要とすることはめったにありませんが、オプションには含まれています。

    • ムービーメニュー表示の切り替え。ツールバーと同じく、ムービーメニューからもムービーの再生を制御することができます。

    • キャッシュ設定（下記のキャッシュ設定セクションを参照してください）。

    • オートスクロール。オートスクロール機能を使うと、ムービーがムービーサイズより小さなウィンドウ上で再生された場合でもマウスカーソルが常に表示されるように、ムービーを自動でスクロールさせることができます。。

  3. オプション設定が確認できたらファイル名を指定してムービーを出力します。

保存された EXE は圧縮して BB FlashBack を持たないユーザに送付することができます。

キャッシュ設定

出力された EXE を実行してムービーの別の箇所にジャンプしようとしたとき、ムービープレーヤーがその箇所までの早送りをしてフレームを描画するまでの間、小さな遅延が発生することがあります。この遅延はキャッシュの設定を変更することで削減することができます。

ムービーの任意の地点にすばやくジャンプできるようにするには、キャッシュサイズを増加させます。キャッシュサイズを増加させた場合のデメリットは、大きなキャッシュはパソコンのメモリを多く消費するという点です。ムービーサイズが大きく（10 分以上）、タイムラインを頻繁にクリックしてムービーの中を行ったり来たりすることが多いような場合のみ、デフォルトの「最小」からキャッシュサイズを増加してください。

EXE 出力ダイアログの「キャッシュ」タブにあるキャッシュサイズオプションを選択します。


サウンド同期問題を修正する

スクリーンの録画中に録音されたサウンドが、時としてムービーの再生時にビデオ映像と同期しなくなることがあります。その原因として考えられるのが、パソコンのサウンドハードウェアの設定が時として不正確なサンプリングレートを生成し得るというケースです。その結果、サウンドトラックの長さとビデオ映像の長さが異なってしまいます。

再同期機能はこれを修正します。サウンドを再サンプリングし、ビデオ映像とまったく同じ長さにします。

この機能はサウンドトラックウィンドウからも呼び出すことができます。

問題がある場合にビデオとサウンドの再同期を取る：

  1. 「サウンド」メニューから「サウンドトラック」を選択します。

  2. 非同期のトラックを選択し、「再同期」のボタンを押します。

  3. 初期設定のまま OK をクリックします。


フレームレート

ムービーのフレームレートは、「プロパティ」ダイアログを使用して設定することができます。このフレームレートは標準再生において使用され、出力時のデフォルトとして使用されます。

ムービーにフレームレートを適用するには：

  1. プレーヤー上で、「ファイル」→「プロパティ」を選択します。

  2. 「フレームレート」タブでフレームレートの値を適切に設定します。デフォルトでは毎秒 25フレームとなっています。低スペックのパソコン上では、再生能力を考慮してこの値を下げたほうがよい場合があります。


マウスカーソルを非表示にする

BB FlashBack は再生中にマウスカーソルを非表示にすることができます。フレームの範囲を選択して、ムービーの再生時にそのフレーム上でカーソルを非表示にするという設定を行います。

マウスカーソルを非表示にするには：

  1. マウスカーソルを非表示にしたいフレームを選択します。

  2. 「アクション」メニューから「マウスカーソル」→「マウスカーソルを非表示にする」を選択します。

  3. 選択されたフレームがマウスバー上で青色になり、該当フレーム上でマウスが非表示になっていることを表してます。

そのフレーム上で再びカーソルを表示させるには、フレームを選択して「アクション」→「マウスカーソル」→「マウスカーソルを表示する」を選択します。


ムービーに一時停止を挿入する

ムービーを一時停止して、次に続行を指示するまでその画面のままにしておきたい場合があります。これによってテキストボックスを時間を掛けて読んだり、スクリーン上での出来事をじっくりと確認したりすることができるようになります。

BB FlashBack は、すべての装飾オブジェクト（テキストボックス、画像、マーカー、ボタン、ハイライト）において再生を一時停止させることができます。ムービーは、ユーザがマウスクリックするか、キーを押すまで一時停止した状態となります。

ムービーの一時停止を挿入するには：

  1. プレーヤーの「挿入」メニューから、追加したい装飾オブジェクトを選択します。

  2. そのオブジェクトの設定ウィンドウで、「ムービーの一時停止...」を選択します。

ムービーが一時停止したときに表示される画像を変更するには：

  1. プレーヤーのメインメニューから、「編集」→「一時停止画像」→「一時停止画像の設定」を選択します。

  2. ビットマップファイルを選択します。

ムービーが一時停止箇所に到達すると選択されたビットマップ画像が表示されます。

デフォルトの一時停止画像に戻したいときは、「編集」メニューから「一時停止画像」→「デフォルトの一時停止画像に戻す」を選択します。

一時停止の画像が表示される場所を変更するには：

  1. プレーヤーのメインメニューから、「編集」→「一時停止画像」→「一時停止画像の位置設定」を選択します。ムービー領域に一時停止画像が現われます。

  2. マウスカーソルを使用して一時停止画像の位置決めを行います。位置が決まったらそのまま次の編集操作を続行します。

ムービーが一時停止箇所に到達すると、一時停止画像が選択した位置に表示されます。


フレームの挿入

フレームの挿入と削除

フレームの削除

ムービーからフレームを削除する：

  1. 単一のフレームか、または連続する複数のフレームを選択します。フレーム選択の詳細については、「フレームを選択する」を参照してください。

  2. プレーヤーのメインメニューから「編集」→「フレームの削除」を選択します。

    または

    編集ツールバーにある「削除」ボタン [image] を押します。

備考： 削除機能は選択サウンドにも適用されます。サウンドとフレームを同時に選択する方法の詳細は、「サウンドとフレームの選択の詳細」を参照してください。

フレームと一時停止の挿入

フレームの挿入機能は、現在選択されているフレームから 1つ以上の重複したフレームを作成します。この効果はムービーの一時停止を作成することにあります。一時停止はたとえば、特定のイベントがテキストボックスの表示／非表示と同期することを確実にするために使用されます。

ムービーにフレームを挿入する

  1. 単一のフレームを選択します。

  2. プレーヤーのメインメニューから「編集」→「フレームの挿入」を選択します。

    または

    編集ツールバーにある「フレームの挿入」ボタン [image] を押します。

  3. 「フレームの挿入」ウィンドウでは挿入するフレームの数を入力するか、あるいは一時停止の時間の長さを 1/1000 秒単位で入力して「OK」を押します。選択されているフレームのうしろに、複製されたフレームが挿入されます。

備考： サウンドが再生されている箇所に一時停止を挿入すると、無音を挿入するか、あるいはサウンドをそのままにしておくかの選択が必要となります。このとき、「サウンドトラックに無音を挿入」のチェックボックスを使ってこれを指示します。


クリップとトラックの結合と分離

BB FlashBack は複数のクリップやトラックを選択し、それらをひとつのものとして結合することができます。

単一のクリップは 2つ、または 3つのクリップに分割することができます。そしてそれらの個々のサウンドごとに位置を変えたり、ボリュームを調整したりすることができます。

クリップの結合

Shift キーを押しながらハンドルをクリックして、ひとつ以上のクリップを選択します。

隣接するクリップだけが選択されます。

選択されたクリップは赤色で表示されます。

ツールバーにあるクリップの結合ボタン [image] を押してクリップを結合します。または「サウンド」メニューから「クリップの結合」を選択します。

トラックの結合

すべてのクリップをひとつのトラックに移動させるためにトラックを結合します。

トラックを結合するには：

  1. プレーヤーの左にあるトラックのヘッダを右クリックしてトラックを選択します。ヘッダは選択されたことを示すために赤色になります：

    結合したいすべてのトラックを選択します。

  2. 選択されたトラックのひとつのヘッダを右クリックして、メニューにある「トラックの結合」を押します。またはツールバーにあるトラックの結合ボタン [image] を押します。

備考： トラックがひとつに合体されるとき、クリップがオーバーラップしない場合にのみトラックを結合することができます。

クリップの分割

BB FlashBack はひとつのクリップを複数のクリップに分割して、それぞれのクリップごとに位置を変えたり、音量を調整したりすることができます。

クリップを2つに分割するには：

  1. クリップを分割したい位置を選択します。

  2. ツールバーのクリップの分割ボタン [image] を押すか、または「サウンド」メニューの「クリップの分割」を選択します。

クリップを 3つに分割するには中央となるクリップを選択します：

  1. サウンドのセクションを選択します。

  2. ツールバーにあるクリップの分割ボタン [image] を押すか、または「サウンド」メニューの「クリップの分割」を選択します。

    選択されたセクションはひとつのクリップとなります：


フレームの結合

フレームの結合機能はムービーの見栄えを整理するのに便利です。

フレーム結合機能の使用例：

アプリケーションの録画が始まると、録画データは多くの独立した複雑なフレームで構成されることになります。再生されるムービー上では同じ映像になっているような場合であっても、実際には複数のフレームに渡って別々に描画されています。

ムービーの見栄えを改良したり、あるいは複数の画面をひとつの画面にまとめたりするのに、フレームの範囲を指定して範囲の最初のフレームから最後のフレームまでをひとつの映像として結合させることができます。結合とはこれらのフレームのすべてがひとつのフレームに合併されることを表し、すべての画面がひとつの画面となることを意味します。

結合はムービー全体の上映時間の長さには影響を与えません。結合されたフレームはすべて同一の映像としてムービー上に表示されます。

フレームの範囲を結合するには：

  1. フレームの範囲を選択します。フレームの選択法についての詳細は、「フレームを選択する」を参照してください。

  2. プレーヤーのメインメニューから「編集」→「フレームの結合」を選択します。

    または

    編集ツールバーにあるフレームの結合ボタン [image] を押します。


サウンドとフレームの選択についての詳細

フレームバーかサウンドトラックをクリックまたはドラッグすることでフレームの選択を行うことが出来ます。あるいは Shift キーを押しながら範囲の開始ポイントと終了ポイントをクリックすることでも範囲指定を行うことができます。

複数のトラック上で同じフレーム／区間を選択する

BB FlashBack は単一のサウンドトラック上またはフレームバー上で範囲を選択して、その範囲を他のトラック上にも同じ範囲の選択として適用することができます。編集操作は同じ選択範囲上で複数のサウンドトラックとムービーフレームに対して同時に適用されます。

フレームバーやサウンドトラックの左端にあるヘッダをクリックすると、範囲選択の ON/OFF をトグル式に切り替えることができます。

同じ範囲選択をすべてのトラック（フレームバーも含めて）に対して適用することができます。上記において「サウンド効果」のトラックヘッダをクリックすることによって、すでに選択されているフレームと同じ範囲の選択がサウンドトラックの範囲としても適用されます：

これで、フレームバーとサウンドトラックの両方に対して同じ範囲が選択されたことになります。

常に選択の対象とするためのロックオプションを使用する

フレームバーやトラックを常に範囲選択の対象としたい場合は、ロック／アンロックのトグルボタンを使用することができます。

下図においては両方のトラックが「アンロック」となっていますので、いずれかひとつのトラック上で範囲を選択しても同じ範囲選択は他のトラックには適用されません。

トラック／フレームバーの選択ステータスを変更するには [image] アイコンをクリックします。ステータスが「ロック」されたことを示すためにアイコンは [image] に変わります。


マウスカーソルの再録画

ムービーにおけるマウスの動きを整理したいとか修正したい場合があります。BB FlashBack はムービーの一部、あるいは全体にわたってマウスの軌跡だけをあとから再録画することができます。

ムービーの一部にマウスの軌跡を再録画するには：

  1. マウスを再録画したいフレームを選択します。

  2. メニューから「アクション」→「カーソル」→「マウスカーソルの再録画」→「選択フレーム」を選択します。秒読みが始まりますので、マウスを正しい開始位置に移動させます。

  3. カウントダウンが終了するとムービーが再生されます。マウスを好きなように移動させて軌跡を変更します。BB FlashBack はその動きを録画します。

マウスの動きをムービー全体に対して再録画するには、メニューから「アクション」→「カーソル」→「マウスカーソルの再録画」→「ムービー全体」を選択します。


プレーヤー上でサウンドトラックを録音する

サウンドトラックの録音

BB FlashBack はムービーの録画時にサウンドも録音することができます。ムービーの編集時にあとからサウンドを追加することも可能です。プレーヤーを使用してメインサウンドトラックの一部、または全体を再録音したり、またはトラックを追加してサウンドを録音することも可能です。

備考： BB FlashBack はレコーダー（またはプレーヤー）によって録音された最初のトラックを「メイントラック」として扱います。サウンドトラックウィンドウ上では「 Sounds\0.mp3 」というファイル名になります。

備考： 下記の例はナレーションの録音に関する話題です。録音オプションウィンドウにあるどの音源からでも録音することができます。

BB FlashBack プレーヤー上でサウンドを録音するには：

  1. 「アクション」メニューから「サウンド」→「録音」を選択します。

録音ウィンドウのオプション設定には次のような機能があります：

  • 追加のサウンドトラックを録音する
    すでにムービーに存在するトラックに追加して、別のサウンドを録音します。既存のサウンドは変更されません。

  • 録音サウンドでメインサウンドトラックを上書き
    これから録音するサウンドでメインサウンドトラックのサウンドを置き換えます。例えばナレーションの誤りを訂正したりすることができます。
    「録音前にメインサウンドトラックのすべてを削除する」のオプションを選択すると、メインサウンドトラック全体が削除され、新しく録音されるサウンドで置き換えられます。

個々のサウンドトラックはサウンドトラックウィンドウで削除したり、ボリュームを変更したりすることができます。

ナレーションの一部を置き換えるには：

BB FlashBack レコーダーでナレーションを録音したのち、再録音したい場合は：

  1. 置き換えたいナレーションを含むフレームを選択します。

  2. 「アクション」メニューから「サウンド」→「録音」を選択します。

  3. 「録音されたサウンドでメインサウンドトラックを上書きする」を選択します。

  4. 「録音前にメインサウンドトラックのすべてを削除する」を選択しないでください。

  5. OKを押して選択フレーム用の新しいサウンドを録音します。これによりメインサウンドトラックが置き換えられますが、他のサウンドは変更されません。

新しいナレーションを録音するには：

ムービーの既存のナレーションを置き換え、ナレーションのすべてを新しいものとするには：

  1. ムービーの最初のフレームを選択します。

  2. 「アクション」メニューから「サウンド」→「録音」を選択します。

  3. 「録音されたサウンドでメインサウンドトラックを上書きする」を選択します。

  4. 「録音前にすべてのメインサウンドトラックを削除する」を選択します。

  5. OK をクリックして、ムービー全体に対する新しいサウンドを録音します。これはメインサウンドトラックを置き換えますが、他のサウンドは変更しません、

既存のサウンド全体に帽子をかぶるかぶせるナレーションを録音するには：

  1. ムービー全体にナレーションを録音するにはムービーの最初のフレームを選択します。一部の区間だけに録音したい場合はそのフレームの区間を選択します。

  2. メニューから「アクション」→「サウンド」→「録音」を選択します。

  3. 「追加のサウンドトラックを録音」を選択します。

  4. OK をクリックして、まったく新しいサウンドトラックを録音します。既存のサウンドは変更されません。


予約録画

BB FlashBack は録画の開始と終了の予約を行うことが出来ます。さらに、特定のアプリケーションの開始と終了のタイミングでの録画の予約を行うこともできます。

設定した時間に録画の開始と終了を行う：

  1. レコーダーのオプションウィンドウを開き、「予約」タブを選択します。

  2. 「予約の使用」設定を ON にします。

  3. 「開始時間」の設定で開始時間をセットし、「終了時間」の設定で終了時間をセットします。

  4. オプションウィンドウを閉じ、通常通り、録画を開始します。録画ボタンをクリックすると、録画が予約されていることを知らせるメッセージが表示されます。レコーダーのメインウィンドウは通常通り、オープンされたまま残るか、または最小化され、セットされた時間に録画が始まります。

予約された録画が終了すると、設定は OFF になります。したがって、次の録画は予約無しに通常通りの方法で録画が開始されます。

特定のアプリケーションの開始時と終了時の録画予約の設定：

  1. レコーダーのオプションウィンドウを開き、「予約」タブを選択します。

  2. 「予約の使用」設定を ON にします。

  3. 「特定のアプリケーション起動時」の設定を ON にします。これは、BB FlashBack が特定のアプリケーションの起動を監視し、それが起動されたら録画を開始するという設定です。もし、指定時間までにアプリケーションが起動されなかった場合は、BB FlashBack はその時間に到達した時点で録画を開始します。

    アプリケーションのタイトルバーに表示されるテキスト、または実行ファイル名を指定することにより、監視するアプリケーションを特定することができます（例：Internet Explorer の場合は iexplore.exe）。

  4. 「このアプリケーションだけを録画」の設定を ON にした場合は、映像はデスクトップ全体の縦横サイズで記録されますが、アプリケーション以外の部分は黒く塗りつぶされて再生されます。


フレームの選択

さまざまな編集操作は単一のフレーム上、もしくは連続したフレーム上で操作されます。たとえば、「テキストの追加」は単一のフレームにテキストボックスを追加し、「フレームの結合」は指定されたフレームの範囲をひとつに結合します。

現在のフレームは常に 1つのフレームから成ります。これはフレームバー上に赤色で表示されており、そのフレームの画像は下のムービー領域に表示されます。

単一のフレームを選択するには：

単一のフレームの選択は簡単です ? マウスの左ボタンでフレームバーをクリックするか、あるいはムービー領域のタイムラインをクリックしてフレームバーのフレームを赤くハイライトさせるだけです。

フレームの範囲を選択するには：

フレームの範囲を選択する方法は2通りあります：

  1. Shift キーを押しながら、範囲の開始位置と終了位置をクリックします。この方法で、フレームバーとタイムラインのどちらをクリックしても範囲指定することができます。

  2. マウスボタンを押しながら範囲の開始フレームと終了フレームを指定します。つまり、フレームバーまたはタイムライン上でカーソルをドラッグして範囲を指定します。

選択されたフレームは赤色で表示されます。

フレームバーの選択とサウンドトラックの選択を連動させることができます。これにより、複数のサウンドトラックとムービーフレームの同じ範囲に対して編集操作を行うことができます。

Web カメラの映像が含まれている場合、Web カメラのヘッダをクリックすることでこちらも範囲に含めたり除外したりすることができます。

詳細は、「サウンドとフレームの選択について」を参照してください。

範囲の開始地点、もしくは終了地点を変更するには：

Shift キーを押しながら再度、フレームバー上のフレームをクリックします。クリックしたフレームが範囲の終了位置より開始位置に近い場合、BB FlashBack は範囲の開始をそのフレームに変更します。逆に、クリックしたフレームが範囲の終了位置に近い場合、BB FlashBack はそのフレームを範囲の終了位置に変更します。

Shift キーを押しながらフレームバーをクリックすると、範囲の開始フレームと終了フレームの両方を変更することができます。

範囲の開始地点と終了地点をすばやく見つけるには：

Ctrl キーを押しながら左右の矢印キーを押すと、現在のフレームは範囲の開始または終了位置に切り替わります。通常通り、現在のフレームはフレームバー上に赤色でハイライトされ、ムービー領域に表示されます。

これはフレームの範囲を結合する場合に便利です。たとえば範囲の開始位置と終了位置が正しいかどうかを確認する場合などです。

非活動のフレームを選択するには：

活動の無いフレームが連続していて、その部分の削除が必要となった場合、非活動フレームの選択機能を使用することができます。

非活動のフレームの連続からいずれか 1つのフレームを選択します。そして、「編集」→「非活動フレームの選択」を選択します。これで、隣接するフレームの中からキーボード入力もマウス操作も画面の活動もないフレームがすべて選択されます。


マウスの動きをなめらかにする

BB FlashBack は選択フレーム上でのマウスの動きをなめらかにすることができます。

マウスは、選択範囲の先頭フレームから最終フレームまでの間でなめらかに移動します。必要に応じて途中で停止のためにクリックを挿入することもできます。

この機能は、マウスの不必要な遠回りの動きをなめらかな動きに変換するために使用されます。

ムービーの特定区間でマウスの動きをスムーズにするには：

  1. マウスの移動をなめらかにさせたいフレームを範囲選択します。BB FlashBack は選択範囲の開始フレームから終了フレームまでの間のマウスの動作をなめらかな動作に変更します。

  2. 「アクション」メニューから「カーソル」→「マウスの動作をなめらかに」を選択します。


サウンド編集操作

サウンドのコピーと切り取り、貼り付け

BB FlashBack はクリップ上のサウンドをコピーしたり切り取ったりすることができます。そしてそれを他のクリップや新しいトラック上に貼り付けすることができます。

サウンドのコピーと貼り付け方法：

  1. クリップ上のサウンドを選択し、サウンドツールバーにあるコピーまたは切り取りボタン [image] を使用するか、あるいは「サウンド」メニューから「コピーと切り取り」を選択します。

  2. 既存のトラックにサウンドを貼り付けるには、トラック上の位置を選択してサウンドツールバーにある「貼り付け」ボタン [image] をクリックします。またはメニューから「サウンド」→「貼り付け」を選択します。

    サウンドを新しいトラックに貼り付けるには、「貼り付け」をクリックするときにトラック上で何も選択していないことを確認してください。新しいトラックが作成されクリップが貼り付けられます。

備考： これらの機能は Windows の通常のクリップボードは使用しません。サウンドは BB FlashBack 上の特別なサウンドクリップボードからコピーされて貼り付けられます。

無音の挿入

BB FlashBack はサウンドトラックに「無音」を挿入することができます。オプションとして、同時に空白フレームを挿入することもできます。

トラック上の位置を選択して、編集ツールバーにある「挿入」ボタン [image] を押します。またはメニューから「編集」→「フレーム/無音の挿入」を選択します。

備考： 設定時間を選択して無音の挿入を行うと、挿入される無音の長さを設定することができます。無音の長さはデフォルトの値になります。

備考： フレームが選択されていると、フレームがさらにムービーに挿入されます。フレームが選択されていない場合は、挿入機能でフレームは挿入されません。フレームバーのヘッダが赤くなっているかどうかで、フレームが選択されているかどうかが分かります。

サウンドとフレームの選択に関する詳細は、「サウンドとフレームの選択についての詳細」を参照してください。

ムービーのクロッピングとサウンドトラック

BB FlashBack はサウンドトラックを選択された区間にクロッピングすることができます。オプションとして、ムービー全体を選択された区間にクロッピングすることもできます。

サウンドの区間を選択し、編集ツールバーにある「クロッピング」ボタン [image] を押します。またはメニューから「編集」→「クロッピング」を選択します。

操作の確認が表示されます。選択されたサウンドトラックは選択された区間に切り取られます。選択範囲以外はすべて削除されます。

備考： フレームが選択されていると（すなわちフレームバーのヘッダが下記のように赤くなっていると）：

フレームは選択範囲に切り取られます。ムービー全体の長さは短くなります。

サウンドとフレームの選択に関する詳細は、「サウンドとフレームの選択についての詳細」を参照してください。


フレームの分割

備考： この機能がどのように働くかを理解するには、まずイベントについて理解する必要があります。イベントとは何か、イベントがフレームにどのように関連するかについての解説は、「 イベントについて」を参照してください。

BB FlashBack のプレーヤーは非常に多くのイベントを単一のフレームに割り当てることが可能です。これは一部のイベントを非表示にしてしまう原因ともなります。

このような場合、フレームを分割することによってムービーの外見を改善することができます。新しいフレームは選択フレームの直後に作成され、選択フレーム上のイベントの半分は新しいフレーム上に配置されます。すると、それまでひとつのフレーム上に配置されていたすべてのイベントは2つに分割され、結果としてムービーがなめらかに再生されることになります。

フレームを分割するには：

  1. 2つに分割したいフレームを選択します。

  2. プレーヤーのメインメニューから「編集」→「フレームの分割」を選択します。

    または

    編集ツールバーにあるフレームの分割ボタン [image] を押します。


クロッピングメニュー

クロッピングメニュー項目:

クロッピング矩形を設定する | クロッピング矩形の位置とサイズ変更を行います。
クロッピング矩形を再生 | クロッピング矩形内の部分だけを再生します。
クロッピングを確定する | クロッピング矩形部分を永久に切り取り、確定します。


クロッピングツールバー

クロッピングツールバーを使用すると、クロッピング機能の数々にワンクリックでアクセスすることができます。

クロッピングツールバーの表示 / 非表示の切り替え：

  1. プレーヤーのメニューバーから「表示」→「ツールバー」を選択します。

  2. クロッピングツールバーの表示 / 非表示を切り替えるには、「クロッピング」項目をチェック / アンチェックします。

ボタン

カーソルのハイライトやマウスクリックのハイライトを編集する


マーカーメニュー

マーカーメニューを使用するとマーカーの追加や削除、マーカーへのジャンプを行うことができます。巨大ムービー上で上手にマーカーを利用するための詳細は、「ムービー上でマーカーを使用する」を参照してください。

マーカーメニューの項目：

現在のマーカーリスト | ムービー上のすべてのマーカーのリストが表示されます。マーカーを選択することでそのフレームに直接ジャンプすることができます。
追加 | 現在のフレームにマーカーを追加します。
削除 | 現在のムービー上の各マーカー名を表示するサブメニューを開きます。 マーカーを削除するにはこのサブメニューから該当マーカーを選択します。


録画ウィンドウ

録画ウィザード

録画ウィザードは録画を開始する前にレコーダーのメイン設定を見直すことができます。

BB FlashBack ツールバーの [image] ボタンをクリックしてウィザードを表示します。または、レコーダーのメインメニューにある「録画」を選択するか、タスクトレイのレコーダーをダブルクリックしても表示させることができます。

備考： 前回の録画と同じ設定を使用する場合は、レコーダーのメインメニューから「クイック録画」を選択することができます。これはウィザードの表示なしで録画を開始します。

ウィザードには5つのステップがあります。

  1. ビデオ設定
    録画するディスプレイとその解像度を選択し、Windows のグラフィック効果を無効にして録画のファイルサイズを削減するためのオプションを選択します。ムービーに BB FlashBack 自身を表示させない設定もここで行います。
    詳細は、「Windows のディスプレイオプション」を参照してください。

  2. サウンド設定
    サウンドの音源と形式を選択します。
    詳細は、「録音する」を参照してください。

  3. Web カメラ
    ビデオソースと形式を選択し、画質のテストを行います。
    詳細は、「Web カメラ映像を録画する」を参照してください。

  4. 録画モード
    録画するソフトウェアのタイプに合わせて最適なパフォーマンスが得られるよう録画モードを選択します。
    詳細は、「録画モード」を参照してください。

  5. その他のオプション
    BB FlashBackには録画のサイズを制限したり、ホットキーの設定やキーストロークを記録させたりするオプションがあります。詳細は、「キーストロークの記録」、「ムービーのファイルサイズを制限する」、「ホットキーの定義と使い方」を参照してください。

  6. 録画領域の設定
    録画対象をフルスクリーンとするか、個別ウィンドウとするか、あるいは指定領域とするかを選択します。また、録画中に録画コントロールツールをどのように表示するかを設定します。


レコーダーメニュー

レコーダーメニュー項目：

設定 |
録画 | BB FlashBack レコーダーを起動し、録画ウィンドウを表示します。 詳細は、「録画ウィンドウ」を参照してください。


サウンドトラックウィンドウ

このウィンドウにはムービーに含まれる個々のサウンドが表示されます。そしてミュート、ボリューム変更、サウンドの削除などを行ったりすることができます。

サウンドトラックウィンドウを表示するには：

  1. 「アクション」メニューから「サウンド」→「サウンドトラック」を選択します。

    または

    編集ツールバーにある [image] ボタンを押します。

ボリュームを変更したりサウンドを削除したりするだけでなく、サウンドトラックウィンドウではムービーに含まれるどのサウンドでも個別のサウンドファイルとして保存することができます。これを行うには、保存したいサウンドを選択して「ファイルへ保存」のボタンを押します。

このウィンドウからアクセス可能な「再同期」機能の詳細については、「サウンドの再同期問題を解決する」を参照してください。


フレーム作業

フレーム作業について

FlashBack ムービーは劇場やテレビで見る昔ながらの映画のように、一連の連続した静止画から構成されるムービーです。

BB FlashBack のフレーム編集機能を使用すると、ムービーの一部を取り除いたり、一時停止用の空白フレームを挿入したり、あるいはムービー上におけるどんな大きな変更をも整理してムービーの調整を行うことができます。

フレームバーとタイムラインの機能

フレームバーとタイムラインのコントロールを使用すると、単一のフレームもしくは複数のフレームを選択して編集操作を行うことができます。詳細については、「タイムラインとフレームバー」、「フレームを選択する」を参照してください。